APOXI: File Index

  • Main Page
  • Modules
  • Namespaces
  • Data Structures
  • Files
  • Related Pages
  • File List
  • Globals

APOXI File List

Here is a list of all files with brief descriptions:
AtlConfig.hpp [code]
DisplayConfig.hpp [code]
EditConfig.hpp [code]
FontConfig.hpp [code]
GuiEngineConfig.hpp [code]
GuiObjectFactory.hpp [code]
KeyboardConfig.hpp [code]
LocaleConfig.hpp [code]
MemoryConfig.hpp [code]
OptionalConfig.hpp [code]
T9InputConfig.hpp [code]
ThemeConfig.hpp [code]
Zi8InputConfig.hpp [code]
apoxi.defines
apoxi.features
ApoxiLib.hpp [code]
ApoxiVersion.hpp [code]
Adc/AdcTemplates.cpp
Adc/ApoxiAdcVersion.cpp
Adc/AuxProvider.cpp
Adc/AuxProvider.hpp [code]
Adc/BaseDataHandler.cpp
Adc/BaseDataHandler.hpp [code]
Adc/CbmiProvider.cpp
Adc/CbmiProvider.hpp [code]
Adc/CbmiRangeProvider.cpp
Adc/CbmiRangeProvider.hpp [code]
Adc/ChvProvider.cpp
Adc/ChvProvider.hpp [code]
Adc/CmiProvider.cpp
Adc/CmiProvider.hpp [code]
Adc/CompoundSmsItem.cpp
Adc/CompoundSmsItem.hpp [code]
Adc/CountryProvider.cpp
Adc/CountryProvider.hpp [code]
Adc/CphsAuxProvider.cpp
Adc/CphsAuxProvider.hpp [code]
Adc/CphsServPflProvider.cpp
Adc/CphsServPflProvider.hpp [code]
Adc/DataHandler.cpp
Adc/DataHandler.hpp [code]
Adc/DirectoryIterator.hpp [code]
Adc/EccProvider.cpp
Adc/EccProvider.hpp [code]
Adc/FfsHandler.hpp [code]
Adc/FfsMimeTypeMap.hpp [code]
Adc/FfsSim.hpp [code]
Adc/FfsTypes.hpp [code]
Adc/File.hpp [code]
Adc/FileBinData.hpp [code]
Adc/FileChunkOperator.hpp [code]
Adc/FileDataSink.hpp [code]
Adc/FileDataSource.hpp [code]
Adc/FileFilter.hpp [code]
Adc/FileVisitor.hpp [code]
Adc/FlashDirectoryIteratorImp.hpp [code]
Adc/FlashFileImp.hpp [code]
Adc/FlashStorageDeviceImp.hpp [code]
Adc/FlsFile.hpp [code]
Adc/Lib.hpp [code]
Adc/LockProvider.cpp
Adc/LockProvider.hpp [code]
Adc/MbiProvider.cpp
Adc/MbiProvider.hpp [code]
Adc/MimeTypeTable.hpp [code]
Adc/MsgTypes.cpp
Adc/MsgTypes.hpp [code]
Adc/Path.hpp [code]
Adc/Pathname.hpp [code]
Adc/PathProfile.hpp [code]
Adc/PbBaseProvider.cpp
Adc/PbBaseProvider.hpp [code]
Adc/PlmnProvider.cpp
Adc/PlmnProvider.hpp [code]
Adc/PreComp.cpp
Adc/PreComp.hpp [code]
Adc/PrefExtLangProvider.cpp
Adc/PrefExtLangProvider.hpp [code]
Adc/PrefLangProvider.cpp
Adc/PrefLangProvider.hpp [code]
Adc/PrefPlmnProvider.cpp
Adc/PrefPlmnProvider.hpp [code]
Adc/ProvIds.hpp [code]
Adc/RfsMsgTypes.hpp [code]
Adc/RootDirectoryIteratorImp.hpp [code]
Adc/RootFileImp.hpp [code]
Adc/RootFileSystem.hpp [code]
Adc/RootStorageDeviceImp.hpp [code]
Adc/SimAccessor.cpp
Adc/SimAccessor.hpp [code]
Adc/SimAuxHandler.cpp
Adc/SimAuxHandler.hpp [code]
Adc/SimChvHandler.cpp
Adc/SimChvHandler.hpp [code]
Adc/SimCphsHandler.cpp
Adc/SimCphsHandler.hpp [code]
Adc/SimPbBaseHandler.cpp
Adc/SimPbBaseHandler.hpp [code]
Adc/SimPbEntry.cpp
Adc/SimPbEntry.hpp [code]
Adc/SimPbEntryCont.cpp
Adc/SimPbEntryCont.hpp [code]
Adc/SimPduHandler.cpp
Adc/SimPduHandler.hpp [code]
Adc/SimSmsParamHandler.cpp
Adc/SimSmsParamHandler.hpp [code]
Adc/SimTkCommands.cpp
Adc/SimTkCommands.hpp [code]
Adc/SimTkMainMenuProvider.cpp
Adc/SimTkMainMenuProvider.hpp [code]
Adc/SmsBaseArchiveProvider.cpp
Adc/SmsBaseArchiveProvider.hpp [code]
Adc/SmsBaseInboxProvider.cpp
Adc/SmsBaseInboxProvider.hpp [code]
Adc/SmsBaseOutboxProvider.cpp
Adc/SmsBaseOutboxProvider.hpp [code]
Adc/SmsBaseStatusReportProvider.cpp
Adc/SmsBaseStatusReportProvider.hpp [code]
Adc/SmsBaseUnreadProvider.cpp
Adc/SmsBaseUnreadProvider.hpp [code]
Adc/SmsClass0Provider.cpp
Adc/SmsClass0Provider.hpp [code]
Adc/SmsInfoElements.cpp
Adc/SmsInfoElements.hpp [code]
Adc/SmsParamProvider.cpp
Adc/SmsParamProvider.hpp [code]
Adc/SmsProvider.cpp
Adc/SmsProvider.hpp [code]
Adc/SmsReadProvider.cpp
Adc/SmsReadProvider.hpp [code]
Adc/SmsSentProvider.cpp
Adc/SmsSentProvider.hpp [code]
Adc/SmsUnreadProvider.cpp
Adc/SmsUnreadProvider.hpp [code]
Adc/SmsUnsentProvider.cpp
Adc/SmsUnsentProvider.hpp [code]
Adc/SstProvider.cpp
Adc/SstProvider.hpp [code]
Adc/StatusProvider.cpp
Adc/StatusProvider.hpp [code]
Adc/StorageDevice.hpp [code]
Adc/StorageDeviceFilter.hpp [code]
Adc/StorageDeviceIterator.hpp [code]
Adc/StorageDeviceVisitor.hpp [code]
Adc/Types.hpp [code]
Adc/UsimPbAccessor.cpp
Adc/UsimPbAccessor.hpp [code]
Adc/UsimPbAddData.cpp
Adc/UsimPbAddData.hpp [code]
Adc/UsimPbCommit.hpp [code]
Adc/UsimPbEntry.cpp
Adc/UsimPbEntry.hpp [code]
Adc/UsimPbEntryCont.cpp
Adc/UsimPbEntryCont.hpp [code]
Adc/UsimPbHandler.cpp
Adc/UsimPbHandler.hpp [code]
Adc/UsimPbPropertyProvider.cpp
Adc/UsimPbPropertyProvider.hpp [code]
Adc/UsimPbProvider.cpp
Adc/UsimPbProvider.hpp [code]
Adc/UsimPbXasProvider.cpp
Adc/UsimPbXasProvider.hpp [code]
AddOns/Lib.hpp [code]
AddOns/AdcExtensions/AdcExtensionsPreComp.cpp
AddOns/AdcExtensions/AdcExtensionsPreComp.hpp [code]
AddOns/AdcExtensions/DataRecord.cpp
AddOns/AdcExtensions/DataRecord.hpp [code]
AddOns/AdcExtensions/DataRecordHandler.cpp
AddOns/AdcExtensions/DataRecordHandler.hpp [code]
AddOns/AdcExtensions/DcsLanguageFilterRule.cpp
AddOns/AdcExtensions/DcsLanguageFilterRule.hpp [code]
AddOns/AdcExtensions/LanguageCodeRes.cpp
AddOns/AdcExtensions/LanguageCodeRes.hpp [code]
AddOns/AdcExtensions/LanguageProvider.cpp
AddOns/AdcExtensions/LanguageProvider.hpp [code]
AddOns/AdcExtensions/NvRam.hpp [code]
AddOns/AdcExtensions/NvRamDataRecordHandler.hpp [code]
AddOns/AdcExtensions/NvRamStorage.hpp [code]
AddOns/AdcExtensions/ProviderIds.hpp [code]
AddOns/AdcExtensions/Record.hpp [code]
AddOns/AdcExtensions/RecordHandler.cpp
AddOns/AdcExtensions/RecordHandler.hpp [code]
AddOns/Aes/AesCryptInterface.cpp
AddOns/Aes/AesCryptInterface.hpp [code]
AddOns/AfsFat/ApoxiAfsFatVersion.cpp
AddOns/AfsFat/FatDirectoryIteratorImp.cpp
AddOns/AfsFat/FatDirectoryIteratorImp.hpp [code]
AddOns/AfsFat/FatFile.cpp
AddOns/AfsFat/FatFile.hpp [code]
AddOns/AfsFat/FatFileImp.cpp
AddOns/AfsFat/FatFileImp.hpp [code]
AddOns/AfsFat/FatFsMsgTypes.cpp
AddOns/AfsFat/FatFsMsgTypes.hpp [code]
AddOns/AfsFat/FatHandler.cpp
AddOns/AfsFat/FatHandler.hpp [code]
AddOns/AfsFat/FatSim.cpp
AddOns/AfsFat/FatSim.hpp [code]
AddOns/AfsFat/FatStorageDeviceImp.cpp
AddOns/AfsFat/FatStorageDeviceImp.hpp [code]
AddOns/AfsFat/FatTypes.hpp [code]
AddOns/AfsFat/PreComp.cpp
AddOns/AfsFat/PreComp.hpp [code]
AddOns/AfsFfs/ApoxiAfsFfsVersion.cpp
AddOns/AfsFfs/FlashDirectoryIteratorImp.cpp
AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp [code]
AddOns/AfsFfs/FlashFileImp.cpp
AddOns/AfsFfs/FlashFileImp.hpp [code]
AddOns/AfsFfs/FlashStorageDeviceImp.cpp
AddOns/AfsFfs/FlashStorageDeviceImp.hpp [code]
AddOns/AfsFfs/PreComp.cpp
AddOns/AfsFfs/PreComp.hpp [code]
AddOns/AfsRam/AfsRamTemplates.cpp
AddOns/AfsRam/ApoxiAfsRamVersion.cpp
AddOns/AfsRam/PreComp.cpp
AddOns/AfsRam/PreComp.hpp [code]
AddOns/AfsRam/RamDataSink.cpp
AddOns/AfsRam/RamDataSink.hpp [code]
AddOns/AfsRam/RamDataSource.cpp
AddOns/AfsRam/RamDataSource.hpp [code]
AddOns/AfsRam/RamDirectoryIteratorImp.cpp
AddOns/AfsRam/RamDirectoryIteratorImp.hpp [code]
AddOns/AfsRam/RamFile.cpp
AddOns/AfsRam/RamFile.hpp [code]
AddOns/AfsRam/RamFileImp.cpp
AddOns/AfsRam/RamFileImp.hpp [code]
AddOns/AfsRam/RamFileNode.cpp
AddOns/AfsRam/RamFileNode.hpp [code]
AddOns/AfsRam/RamFileObj.cpp
AddOns/AfsRam/RamFileObj.hpp [code]
AddOns/AfsRam/RamFileSystem.cpp
AddOns/AfsRam/RamFileSystem.hpp [code]
AddOns/AfsRam/RamHandler.cpp
AddOns/AfsRam/RamHandler.hpp [code]
AddOns/AfsRam/RamStorageDeviceImp.cpp
AddOns/AfsRam/RamStorageDeviceImp.hpp [code]
AddOns/AfsRam/RamStorageMapper.cpp
AddOns/AfsRam/RamStorageMapper.hpp [code]
AddOns/AfsRam/RamTypes.hpp [code]
AddOns/AfsRfs/AfsRfsTemplates.cpp
AddOns/AfsRfs/ApoxiAfsRfsVersion.cpp
AddOns/AfsRfs/PreComp.cpp
AddOns/AfsRfs/PreComp.hpp [code]
AddOns/AfsRfs/RootDirectoryIteratorImp.cpp
AddOns/AfsRfs/RootDirectoryIteratorImp.hpp [code]
AddOns/AfsRfs/RootFileImp.cpp
AddOns/AfsRfs/RootFileImp.hpp [code]
AddOns/AfsRfs/RootStorageDeviceImp.cpp
AddOns/AfsRfs/RootStorageDeviceImp.hpp [code]
AddOns/AuxExtensions/AppendProvider.cpp
AddOns/AuxExtensions/AppendProvider.hpp [code]
AddOns/AuxExtensions/AuxExtensionsPreComp.cpp
AddOns/AuxExtensions/AuxExtensionsPreComp.hpp [code]
AddOns/AuxExtensions/DualFilterProvider.cpp
AddOns/AuxExtensions/DualFilterProvider.hpp [code]
AddOns/AuxExtensions/JoinProvider.cpp
AddOns/AuxExtensions/JoinProvider.hpp [code]
AddOns/AuxExtensions/JoinRule.cpp
AddOns/AuxExtensions/JoinRule.hpp [code]
AddOns/AuxExtensions/MergeProvider.cpp
AddOns/AuxExtensions/MergeProvider.hpp [code]
AddOns/AuxExtensions/MimeCoding.cpp
AddOns/AuxExtensions/MimeCoding.hpp [code]
AddOns/AuxExtensions/PhoneNumberMergeProvider.cpp
AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp [code]
AddOns/AuxExtensions/ProviderIds.hpp [code]
AddOns/AuxExtensions/SwitchedRleCompression.hpp [code]
AddOns/BtSocket/BtSocketAddr.cpp
AddOns/BtSocket/BtSocketAddr.hpp [code]
AddOns/BtSocket/PreComp.cpp
AddOns/BtSocket/PreComp.hpp [code]
AddOns/CodecManager/AudioCapturerEncoder.hpp [code]
AddOns/CodecManager/AudioDecoder.hpp [code]
AddOns/CodecManager/AudioDecoderRenderer.hpp [code]
AddOns/CodecManager/AudioEncoder.hpp [code]
AddOns/CodecManager/CodecDevice.hpp [code]
AddOns/CodecManager/CodecManager.cpp
AddOns/CodecManager/CodecManager.hpp [code]
AddOns/CodecManager/VideoDecoder.hpp [code]
AddOns/CodecManager/VideoEncoder.hpp [code]
AddOns/Drm/Drm.hpp [code]
AddOns/Drm/DrmConstraint.cpp
AddOns/Drm/DrmDcfParser.cpp
AddOns/Drm/DrmDcfParser.hpp [code]
AddOns/Drm/DrmMessage.cpp
AddOns/Drm/DrmMessage.hpp [code]
AddOns/Drm/DrmPermission.cpp
AddOns/Drm/DrmPreComp.cpp
AddOns/Drm/DrmPreComp.hpp [code]
AddOns/Drm/DrmRelparser.cpp
AddOns/Drm/DrmRelparser.hpp [code]
AddOns/Drm/DrmRelWbxml.cpp
AddOns/Drm/DrmRelWbxml.hpp [code]
AddOns/Drm/DrmRelXml.cpp
AddOns/Drm/DrmRelXml.hpp [code]
AddOns/Drm/DrmRights.hpp [code]
AddOns/Drm/DrmRightsContainer.cpp
AddOns/Drm/DrmRightsObject.cpp
AddOns/Drm/DrmRightsStore.cpp
AddOns/Drm/DrmRightsStore.hpp [code]
AddOns/Drm/DrmSecurity.cpp
AddOns/Drm/DrmSecurity.hpp [code]
AddOns/Drm/DrmSubsystem.cpp
AddOns/Drm/DrmSubsystem.hpp [code]
AddOns/Drm/DrmTemplates.cpp
AddOns/Drm/DrmUtils.cpp
AddOns/Drm/DrmUtils.hpp [code]
AddOns/Drm/DrmWapPushMsg.cpp
AddOns/Drm/DrmWapPushMsg.hpp [code]
AddOns/Drm/MultipartParser.cpp
AddOns/Drm/MultipartParser.hpp [code]
AddOns/GuiInputExtensions/AbstractPredictiveInputBox.cpp
AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp [code]
AddOns/GuiInputExtensions/PreComp.cpp
AddOns/GuiInputExtensions/PreComp.hpp [code]
AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.cpp
AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp [code]
AddOns/GuiMenuAccessors/AccessorAction.cpp
AddOns/GuiMenuAccessors/AccessorAction.hpp [code]
AddOns/GuiMenuAccessors/AccessorActionExtension.cpp
AddOns/GuiMenuAccessors/AccessorActionExtension.hpp [code]
AddOns/GuiMenuAccessors/ActionMenuAccessor.cpp
AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp [code]
AddOns/GuiMenuAccessors/ApplicationAction.cpp
AddOns/GuiMenuAccessors/ApplicationAction.hpp [code]
AddOns/GuiMenuAccessors/MsgTypes.cpp
AddOns/GuiMenuAccessors/MsgTypes.hpp [code]
AddOns/GuiMenuAccessors/PreComp.cpp
AddOns/GuiMenuAccessors/PreComp.hpp [code]
AddOns/GuiMenuAccessors/SubMenuAction.cpp
AddOns/GuiMenuAccessors/SubMenuAction.hpp [code]
AddOns/GuiMenuAccessors/TopLevelMenu.cpp
AddOns/GuiMenuAccessors/TopLevelMenu.hpp [code]
AddOns/HttpWapInterface/HttpWap/HttpHandler.cpp
AddOns/HttpWapInterface/HttpWap/HttpHandler.hpp [code]
AddOns/HttpWapInterface/HttpWap/HttpWapInterfacePreComp.cpp
AddOns/HttpWapInterface/HttpWap/HttpWapInterfacePreComp.hpp [code]
AddOns/HttpWapInterface/HttpWap/HttpWapMgr.cpp
AddOns/HttpWapInterface/HttpWap/HttpWapMgr.hpp [code]
AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp [code]
AddOns/HttpWapInterface/HttpWap/WapHandler.cpp
AddOns/HttpWapInterface/HttpWap/WapHandler.hpp [code]
AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.cpp
AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp [code]
AddOns/HttpWapInterface/HttpWapPlugin/HttpWapPluginPreComp.cpp
AddOns/HttpWapInterface/HttpWapPlugin/HttpWapPluginPreComp.hpp [code]
AddOns/HttpWapInterface/WapProfileMgmt/HttpWapProfileMgmtPreComp.cpp
AddOns/HttpWapInterface/WapProfileMgmt/HttpWapProfileMgmtPreComp.hpp [code]
AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.cpp
AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp [code]
AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.cpp
AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp [code]
AddOns/jpeglib/jmemnobs_APOXI.cpp
AddOns/Lcs/3GPP/LcsArgs.cpp
AddOns/Lcs/3GPP/LcsArgs.hpp [code]
AddOns/Lcs/3GPP/LcsMsgProcessor.cpp
AddOns/Lcs/3GPP/LcsMsgProcessor.hpp [code]
AddOns/Lcs/3GPP/LcsProviderImpl.cpp
AddOns/Lcs/3GPP/LcsProviderImpl.hpp [code]
AddOns/Lcs/3GPP/LcsSignalMapTableNode.cpp
AddOns/Lcs/3GPP/LcsSignalMapTableNode.hpp [code]
AddOns/Lcs/3GPP/LcsSignalProcessor.cpp
AddOns/Lcs/3GPP/LcsSignalProcessor.hpp [code]
AddOns/Lcs/3GPP/LcsStackMsgArgs.cpp
AddOns/Lcs/3GPP/LcsStackMsgArgs.hpp [code]
AddOns/Lcs/Common/LcsCommonArgs.cpp
AddOns/Lcs/Common/LcsCommonArgs.hpp [code]
AddOns/Lcs/Common/LcsCommonMsgProcessor.cpp
AddOns/Lcs/Common/LcsCommonMsgProcessor.hpp [code]
AddOns/Lcs/Common/LcsCommonMsgTypes.cpp
AddOns/Lcs/Common/LcsCommonMsgTypes.hpp [code]
AddOns/Lcs/Common/LcsCommonSignalMapTableNode.cpp
AddOns/Lcs/Common/LcsCommonSignalMapTableNode.hpp [code]
AddOns/Lcs/Common/LcsCommonSignalProcessor.cpp
AddOns/Lcs/Common/LcsCommonSignalProcessor.hpp [code]
AddOns/Lcs/Common/LcsCommonStackMsgArgs.cpp
AddOns/Lcs/Common/LcsCommonStackMsgArgs.hpp [code]
AddOns/Lcs/Common/LcsDecls.hpp [code]
AddOns/Lcs/Common/LcsPreComp.cpp
AddOns/Lcs/Common/LcsPreComp.hpp [code]
AddOns/Lcs/Common/LcsProvider.cpp
AddOns/Lcs/Common/LcsProvider.hpp [code]
AddOns/Lcs/Common/LcsProviderImplBase.cpp
AddOns/Lcs/Common/LcsProviderImplBase.hpp [code]
AddOns/Lcs/Common/LcsRepeatTimer.cpp
AddOns/Lcs/Common/LcsRepeatTimer.hpp [code]
AddOns/Lcs/Common/LcsReqProcessor.cpp
AddOns/Lcs/Common/LcsReqProcessor.hpp [code]
AddOns/Lcs/Common/LcsTimer.cpp
AddOns/Lcs/Common/LcsTimer.hpp [code]
AddOns/Lcs/Common/LcsTypes.hpp [code]
AddOns/Lcs/Common/LcsUtils.cpp
AddOns/Lcs/Common/LcsUtils.hpp [code]
AddOns/Lcs/GLTP/AidDataRequests.cpp
AddOns/Lcs/GLTP/AidDataRequests.hpp [code]
AddOns/Lcs/GLTP/AssistanceData.cpp
AddOns/Lcs/GLTP/AssistanceData.hpp [code]
AddOns/Lcs/GLTP/GltpArgs.cpp
AddOns/Lcs/GLTP/GltpArgs.hpp [code]
AddOns/Lcs/GLTP/GltpMsgProcessor.cpp
AddOns/Lcs/GLTP/GltpMsgProcessor.hpp [code]
AddOns/Lcs/GLTP/GltpMsgTypes.cpp
AddOns/Lcs/GLTP/GltpMsgTypes.hpp [code]
AddOns/Lcs/GLTP/GltpProviderImpl.cpp
AddOns/Lcs/GLTP/GltpProviderImpl.hpp [code]
AddOns/Lcs/GLTP/GltpSignalMapTableNode.cpp
AddOns/Lcs/GLTP/GltpSignalMapTableNode.hpp [code]
AddOns/Lcs/GLTP/GltpSignalProcessor.cpp
AddOns/Lcs/GLTP/GltpSignalProcessor.hpp [code]
AddOns/Lcs/GLTP/GltpStackMsgArgs.cpp
AddOns/Lcs/GLTP/GltpStackMsgArgs.hpp [code]
AddOns/Lcs/GLTP/GltpTypes.hpp [code]
AddOns/Lcs/StandAlone/SaArgs.cpp
AddOns/Lcs/StandAlone/SaArgs.hpp [code]
AddOns/Lcs/StandAlone/SaMsgProcessor.cpp
AddOns/Lcs/StandAlone/SaMsgProcessor.hpp [code]
AddOns/Lcs/StandAlone/SaProviderImpl.cpp
AddOns/Lcs/StandAlone/SaProviderImpl.hpp [code]
AddOns/Lcs/StandAlone/SaSignalMapTableNode.cpp
AddOns/Lcs/StandAlone/SaSignalMapTableNode.hpp [code]
AddOns/Lcs/StandAlone/SaSignalProcessor.cpp
AddOns/Lcs/StandAlone/SaSignalProcessor.hpp [code]
AddOns/Lcs/StandAlone/SaStackMsgArgs.cpp
AddOns/Lcs/StandAlone/SaStackMsgArgs.hpp [code]
AddOns/MediaFramework/DisplaySettings.hpp [code]
AddOns/MediaFramework/Media.hpp [code]
AddOns/MediaFramework/MediaBox.hpp [code]
AddOns/MediaFramework/MediaFrameworkCaps.hpp [code]
AddOns/MediaFramework/MediaInfo.hpp [code]
AddOns/MediaFramework/MediaManager.hpp [code]
AddOns/MediaFramework/MediaObtainer.hpp [code]
AddOns/MediaFramework/MediaPlayer.hpp [code]
AddOns/MediaFramework/MediaRecorder.hpp [code]
AddOns/MediaFramework/MsgTypes.hpp [code]
AddOns/MediaFramework/PreComp.hpp [code]
AddOns/MediaFramework/RecordSettings.hpp [code]
AddOns/MediaFramework/VideoCaptureParameters.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EFOApoxiLayer.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EFOBinData.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EFODataSink.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAllocLogs.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDecoder.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDecoder.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDefines.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDeviceImpl.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDeviceImpl.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioUtils.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioUtils.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecManager.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecManager.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecUtils.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecUtils.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiFile.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiFile.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoCapture.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoCaptureExp.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDecoder.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDecoder.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDefines.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoEncoder.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoEncoder.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoRenderer.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoRendererExp.hpp [code]
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoUtils.cpp
AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoUtils.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiThread.cpp
AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiThread.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiTimer.cpp
AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiTimer.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiBinData.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiBinData.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataSink.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataSink.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataTypes.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiDisplaySettings.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiDisplaySettings.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMediaInfo.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMediaInfo.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMimeTypeTable.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMimeTypeTable.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMsgDispatcher.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMsgDispatcher.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutex.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutex.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutexObtainer.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutexObtainer.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiOs.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiOs.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiPlayerEnum.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecorderEnum.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecordSettings.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecordSettings.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiSemaphore.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiSemaphore.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiServiceThread.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiServiceThread.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiThread.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiThread.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiTicks.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiTicks.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiTimer.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiTimer.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmApoxiUtilities.cpp
AddOns/MediaFramework/ApoxiExtensions/EmApoxiUtilities.hpp [code]
AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.cpp
AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.hpp [code]
AddOns/MediaFramework/MMfrInterfaceImpl/DisplaySettings.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/Media.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/MediaBox.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/MediaFrameworkVersion.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/MediaInfo.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/MediaManager.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/MediaObtainer.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayer.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayerImpl.hpp [code]
AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorder.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorderImpl.hpp [code]
AddOns/MediaFramework/MMfrInterfaceImpl/MsgTypes.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/PreComp.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/RecordSettings.cpp
AddOns/MediaFramework/MMfrInterfaceImpl/VideoCaptureParameters.cpp
AddOns/MediaFramework/Network/EmApoxiDataConnManager.cpp
AddOns/MediaFramework/Network/EmApoxiDataConnManager.hpp [code]
AddOns/MediaFramework/Network/EmApoxiDataConnProfileManager.cpp
AddOns/MediaFramework/Network/EmApoxiDataConnProfileManager.hpp [code]
AddOns/MediaFramework/Network/EmApoxiDnsClient.cpp
AddOns/MediaFramework/Network/EmApoxiDnsClient.hpp [code]
AddOns/MediaFramework/Network/EmApoxiInetSocketAddr.cpp
AddOns/MediaFramework/Network/EmApoxiInetSocketAddr.hpp [code]
AddOns/MediaFramework/Network/EmApoxiInterface.hpp [code]
AddOns/MediaFramework/Network/EmApoxiIpAddr.cpp
AddOns/MediaFramework/Network/EmApoxiIpAddr.hpp [code]
AddOns/MediaFramework/Network/EmApoxiIpPortNo.cpp
AddOns/MediaFramework/Network/EmApoxiIpPortNo.hpp [code]
AddOns/MediaFramework/Network/EmApoxiSocketHandler.cpp
AddOns/MediaFramework/Network/EmApoxiSocketHandler.hpp [code]
AddOns/MediaFramework/Network/EmApoxiTcpSocket.cpp
AddOns/MediaFramework/Network/EmApoxiTcpSocket.hpp [code]
AddOns/MediaFramework/Network/EmApoxiUdpSocket.cpp
AddOns/MediaFramework/Network/EmApoxiUdpSocket.hpp [code]
AddOns/MediaFramework/Network/ExtndDnsClient.cpp
AddOns/MediaFramework/Network/ExtndDnsClient.hpp [code]
AddOns/MediaFramework/Network/ExtndServiceThreadForNetwork.cpp
AddOns/MediaFramework/Network/ExtndServiceThreadForNetwork.hpp [code]
AddOns/MediaFramework/Network/ExtndTcpSocket.cpp
AddOns/MediaFramework/Network/ExtndTcpSocket.hpp [code]
AddOns/MediaFramework/Network/ExtndUdpSocket.cpp
AddOns/MediaFramework/Network/ExtndUdpSocket.hpp [code]
AddOns/MediaFramework/Network/NetworkServiceThreadMsgTypes.cpp
AddOns/MediaFramework/Network/NetworkServiceThreadMsgTypes.hpp [code]
AddOns/MmCall/AtCommand.cpp
AddOns/MmCall/AtCommand.hpp [code]
AddOns/MmCall/AtResponse.cpp
AddOns/MmCall/AtResponse.hpp [code]
AddOns/MmCall/AtResponseIterator.cpp
AddOns/MmCall/AtResponseIterator.hpp [code]
AddOns/MmCall/MmCallDispatcher.cpp
AddOns/MmCall/MmCallDispatcher.hpp [code]
AddOns/MmCall/MmCallHandler.cpp
AddOns/MmCall/MmCallHandler.hpp [code]
AddOns/MmCall/MmCallHdl.cpp
AddOns/MmCall/MmCallHdl.hpp [code]
AddOns/MmCall/MmCallInfo.cpp
AddOns/MmCall/MmCallInfo.hpp [code]
AddOns/MmCall/MmCallMessages.cpp
AddOns/MmCall/MmCallMessages.hpp [code]
AddOns/MmCall/MmCallPreComp.cpp
AddOns/MmCall/MmCallPreComp.hpp [code]
AddOns/MmCall/MmCallSerialTerminalListener.cpp
AddOns/MmCall/MmCallSerialTerminalListener.hpp [code]
AddOns/MmCall/MmTypes.hpp [code]
AddOns/MmCall/SerialTerminal.cpp
AddOns/MmCall/SerialTerminal.hpp [code]
AddOns/MmCall/SerialTerminalArg.cpp
AddOns/MmCall/SerialTerminalArg.hpp [code]
AddOns/MmCall/SerialTerminalListener.cpp
AddOns/MmCall/SerialTerminalListener.hpp [code]
AddOns/MmCall/SerialTerminalMsgArgs.cpp
AddOns/MmCall/SerialTerminalMsgArgs.hpp [code]
AddOns/MmCall/SerialTerminalSocket.cpp
AddOns/MmCall/SerialTerminalSocket.hpp [code]
AddOns/MmCall/SioGlueSignalListener.cpp
AddOns/MmCall/SioGlueSignalListener.hpp [code]
AddOns/MmCall/SioGlueWrapper.cpp
AddOns/MmCall/SioGlueWrapper.hpp [code]
AddOns/MmCall/SocketSerialTerminalListener.cpp
AddOns/MmCall/SocketSerialTerminalListener.hpp [code]
AddOns/MmCall/XCallInfoResponseParser.cpp
AddOns/MmCall/XCallInfoResponseParser.hpp [code]
AddOns/MultiMedia/AbstractIMelodyParser.hpp [code]
AddOns/MultiMedia/AudioContext.hpp [code]
AddOns/MultiMedia/AudioItem.cpp
AddOns/MultiMedia/AudioItem.hpp [code]
AddOns/MultiMedia/BmpDecoder.cpp
AddOns/MultiMedia/BmpDecoder.hpp [code]
AddOns/MultiMedia/BmpImage.cpp
AddOns/MultiMedia/BmpImage.hpp [code]
AddOns/MultiMedia/BoundedItem.cpp
AddOns/MultiMedia/BoundedItem.hpp [code]
AddOns/MultiMedia/CompoundItemReferrer.cpp
AddOns/MultiMedia/CompoundItemReferrer.hpp [code]
AddOns/MultiMedia/GeneralCompoundItem.cpp
AddOns/MultiMedia/GeneralCompoundItem.hpp [code]
AddOns/MultiMedia/GifDecoder.cpp
AddOns/MultiMedia/GifDecoder.hpp [code]
AddOns/MultiMedia/GifImage.cpp
AddOns/MultiMedia/GifImage.hpp [code]
AddOns/MultiMedia/ImageFactory.cpp
AddOns/MultiMedia/ImageFactory.hpp [code]
AddOns/MultiMedia/ImageItem.cpp
AddOns/MultiMedia/ImageItem.hpp [code]
AddOns/MultiMedia/IMelody.hpp [code]
AddOns/MultiMedia/JpegDecoder.cpp
AddOns/MultiMedia/JpegDecoder.hpp [code]
AddOns/MultiMedia/JpegEncoder.cpp
AddOns/MultiMedia/JpegEncoder.hpp [code]
AddOns/MultiMedia/JpegEncodingThreadlet.cpp
AddOns/MultiMedia/JpegEncodingThreadlet.hpp [code]
AddOns/MultiMedia/JpegImage.cpp
AddOns/MultiMedia/JpegImage.hpp [code]
AddOns/MultiMedia/Melody.hpp [code]
AddOns/MultiMedia/MidiSound.hpp [code]
AddOns/MultiMedia/MultiMediaEditor.cpp
AddOns/MultiMedia/MultiMediaEditor.hpp [code]
AddOns/MultiMedia/MultiMediaEditorDocument.cpp
AddOns/MultiMedia/MultiMediaEditorDocument.hpp [code]
AddOns/MultiMedia/MultiMediaTemplates.cpp
AddOns/MultiMedia/NativeImage.hpp [code]
AddOns/MultiMedia/ParagraphCompoundItem.cpp
AddOns/MultiMedia/ParagraphCompoundItem.hpp [code]
AddOns/MultiMedia/ParagraphMarker.cpp
AddOns/MultiMedia/ParagraphMarker.hpp [code]
AddOns/MultiMedia/PngDecoder.cpp
AddOns/MultiMedia/PngDecoder.hpp [code]
AddOns/MultiMedia/PngEncoder.cpp
AddOns/MultiMedia/PngEncoder.hpp [code]
AddOns/MultiMedia/PngEncodingThreadlet.cpp
AddOns/MultiMedia/PngEncodingThreadlet.hpp [code]
AddOns/MultiMedia/PngImage.cpp
AddOns/MultiMedia/PngImage.hpp [code]
AddOns/MultiMedia/PreComp.cpp
AddOns/MultiMedia/PreComp.hpp [code]
AddOns/MultiMedia/PreparedSound.hpp [code]
AddOns/MultiMedia/RichTextCompoundItem.cpp
AddOns/MultiMedia/RichTextCompoundItem.hpp [code]
AddOns/MultiMedia/SmafSound.hpp [code]
AddOns/MultiMedia/Sound.hpp [code]
AddOns/MultiMedia/SoundItem.hpp [code]
AddOns/MultiMedia/Unzip.hpp [code]
AddOns/MultiMedia/UnzipBinData.cpp
AddOns/MultiMedia/UnzipBinData.hpp [code]
AddOns/MultiMedia/UnzipFfs.cpp
AddOns/MultiMedia/UnzipFfs.hpp [code]
AddOns/MultiMedia/Unzipper.cpp
AddOns/MultiMedia/Unzipper.hpp [code]
AddOns/MultiMedia/VCardItem.cpp
AddOns/MultiMedia/VCardItem.hpp [code]
AddOns/MultiMedia/WbmpDecoder.cpp
AddOns/MultiMedia/WbmpDecoder.hpp [code]
AddOns/MultiMedia/WbmpImage.cpp
AddOns/MultiMedia/WbmpImage.hpp [code]
AddOns/RfsObexFtpServer/PreComp.cpp
AddOns/RfsObexFtpServer/PreComp.hpp [code]
AddOns/RfsObexFtpServer/RfsObexFtpServer.cpp
AddOns/RfsObexFtpServer/RfsObexFtpServer.hpp [code]
AddOns/SerialSocket/SerialClientSocket.cpp
AddOns/SerialSocket/SerialClientSocket.hpp [code]
AddOns/SerialSocket/SerialIoAdapter.cpp
AddOns/SerialSocket/SerialIoAdapter.hpp [code]
AddOns/SerialSocket/SerialIoAdapterStub.cpp
AddOns/SerialSocket/SerialServerSocket.cpp
AddOns/SerialSocket/SerialServerSocket.hpp [code]
AddOns/SerialSocket/SerialSocket.cpp
AddOns/SerialSocket/SerialSocket.hpp [code]
AddOns/SerialSocket/SerialSocketData.cpp
AddOns/SerialSocket/SerialSocketData.hpp [code]
AddOns/SerialSocket/SerialSocketDataLock.hpp [code]
AddOns/SerialSocket/SerialSocketsPreComp.cpp
AddOns/SerialSocket/SerialSocketsPreComp.hpp [code]
AddOns/SerialSocket/SerialSocketSubSystem.cpp
AddOns/SerialSocket/SerialSocketSubSystem.hpp [code]
AddOns/SerialSocket/SerialSocketThread.cpp
AddOns/SerialSocket/SerialSocketThread.hpp [code]
AddOns/SerialSocket/SockAddress.hpp [code]
AddOns/Server/ApoxiServerVersion.cpp
AddOns/Server/AuthProvider.cpp
AddOns/Server/AuthProvider.hpp [code]
AddOns/Server/PreComp.cpp
AddOns/Server/PreComp.hpp [code]
AddOns/Server/Server.cpp
AddOns/Server/Server.hpp [code]
AddOns/Server/ServerClient.cpp
AddOns/Server/ServerClient.hpp [code]
AddOns/Server/ServerConfig.cpp
AddOns/Server/ServerConfig.hpp [code]
AddOns/Server/FtpServer/ApoxiFtpServerVersion.cpp
AddOns/Server/FtpServer/FtpAuthProvider.cpp
AddOns/Server/FtpServer/FtpAuthProvider.hpp [code]
AddOns/Server/FtpServer/FtpClient.cpp
AddOns/Server/FtpServer/FtpClient.hpp [code]
AddOns/Server/FtpServer/FtpDataServerSocket.cpp
AddOns/Server/FtpServer/FtpDataServerSocket.hpp [code]
AddOns/Server/FtpServer/FtpDataSocket.cpp
AddOns/Server/FtpServer/FtpDataSocket.hpp [code]
AddOns/Server/FtpServer/FtpInTransfer.cpp
AddOns/Server/FtpServer/FtpInTransfer.hpp [code]
AddOns/Server/FtpServer/FtpOutTransfer.cpp
AddOns/Server/FtpServer/FtpOutTransfer.hpp [code]
AddOns/Server/FtpServer/FtpRequest.cpp
AddOns/Server/FtpServer/FtpRequest.hpp [code]
AddOns/Server/FtpServer/FtpServer.cpp
AddOns/Server/FtpServer/FtpServer.hpp [code]
AddOns/Server/FtpServer/FtpServerConfig.cpp
AddOns/Server/FtpServer/FtpServerConfig.hpp [code]
AddOns/Server/FtpServer/FtpServerSocket.cpp
AddOns/Server/FtpServer/FtpServerSocket.hpp [code]
AddOns/Server/FtpServer/FtpSocket.cpp
AddOns/Server/FtpServer/FtpSocket.hpp [code]
AddOns/Server/FtpServer/FtpTransfer.cpp
AddOns/Server/FtpServer/FtpTransfer.hpp [code]
AddOns/Server/FtpServer/FtpTypes.hpp [code]
AddOns/Server/FtpServer/MsgTypes.cpp
AddOns/Server/FtpServer/MsgTypes.hpp [code]
AddOns/Server/FtpServer/PreComp.cpp
AddOns/Server/FtpServer/PreComp.hpp [code]
AddOns/Server/HttpServer/ApoxiHttpServerVersion.cpp
AddOns/Server/HttpServer/HttpApplication.cpp
AddOns/Server/HttpServer/HttpApplication.hpp [code]
AddOns/Server/HttpServer/HttpApplicationSupplier.cpp
AddOns/Server/HttpServer/HttpApplicationSupplier.hpp [code]
AddOns/Server/HttpServer/HttpAuthProvider.cpp
AddOns/Server/HttpServer/HttpAuthProvider.hpp [code]
AddOns/Server/HttpServer/HttpClient.cpp
AddOns/Server/HttpServer/HttpClient.hpp [code]
AddOns/Server/HttpServer/HttpRequest.cpp
AddOns/Server/HttpServer/HttpRequest.hpp [code]
AddOns/Server/HttpServer/HttpResponse.cpp
AddOns/Server/HttpServer/HttpResponse.hpp [code]
AddOns/Server/HttpServer/HttpServer.cpp
AddOns/Server/HttpServer/HttpServer.hpp [code]
AddOns/Server/HttpServer/HttpServerConfig.cpp
AddOns/Server/HttpServer/HttpServerConfig.hpp [code]
AddOns/Server/HttpServer/HttpServerSocket.cpp
AddOns/Server/HttpServer/HttpServerSocket.hpp [code]
AddOns/Server/HttpServer/HttpSocket.cpp
AddOns/Server/HttpServer/HttpSocket.hpp [code]
AddOns/Server/HttpServer/HttpTypes.hpp [code]
AddOns/Server/HttpServer/MsgTypes.cpp
AddOns/Server/HttpServer/MsgTypes.hpp [code]
AddOns/Server/HttpServer/PreComp.cpp
AddOns/Server/HttpServer/PreComp.hpp [code]
AddOns/Services/Service.cpp
AddOns/Services/Service.hpp [code]
AddOns/Services/ServiceBroker.cpp
AddOns/Services/ServiceBroker.hpp [code]
AddOns/Services/ServicesTemplates.cpp
AddOns/SioSocketAdapter/IrSocketAddr.cpp
AddOns/SioSocketAdapter/IrSocketAddr.hpp [code]
AddOns/SioSocketAdapter/PreComp.cpp
AddOns/SioSocketAdapter/PreComp.hpp [code]
AddOns/SioSocketAdapter/SioSocketAdapter.cpp
AddOns/SioSocketAdapter/SioSocketAdapter.hpp [code]
AddOns/StreamObex/apoxi_emcpp_OBEXAdapter.hpp [code]
AddOns/StreamObex/emcpp_apoxi_OBEXAdapter.hpp [code]
AddOns/StreamObex/StreamObexImpl.cpp
AddOns/StreamObex/StreamObexImpl.hpp [code]
AddOns/StreamObex/StreamObexPreComp.cpp
AddOns/StreamObex/StreamObexPreComp.hpp [code]
AddOns/StreamObex/StreamObexTransport.cpp
AddOns/StreamObex/StreamObexTransport.hpp [code]
AddOns/Svg/fonts.hpp [code]
AddOns/Svg/MsgTypes.cpp
AddOns/Svg/MsgTypes.hpp [code]
AddOns/Svg/PreComp.cpp
AddOns/Svg/PreComp.hpp [code]
AddOns/Svg/SvgConfig.hpp [code]
AddOns/Svg/SvgDebug.hpp [code]
AddOns/Svg/SvgDecoder.cpp
AddOns/Svg/SvgDecoder.hpp [code]
AddOns/Svg/SvgFileWrapper.cpp
AddOns/Svg/SvgFileWrapper.hpp [code]
AddOns/Svg/SvgFixPoint.cpp
AddOns/Svg/SvgFixPoint.hpp [code]
AddOns/Svg/SvgGzFileWrapper.cpp
AddOns/Svg/SvgGzFileWrapper.hpp [code]
AddOns/Svg/SvgImage.cpp
AddOns/Svg/SvgImage.hpp [code]
AddOns/Svg/SvgImageFileWrapper.cpp
AddOns/Svg/SvgImageFileWrapper.hpp [code]
AddOns/Svg/SvgIoWrapper.cpp
AddOns/Svg/SvgIoWrapper.hpp [code]
AddOns/Svg/SvgMimeUtil.cpp
AddOns/Svg/SvgMimeUtil.hpp [code]
AddOns/Svg/SvgPlayer.cpp
AddOns/Svg/SvgPlayer.hpp [code]
AddOns/SyncML/DBService.hpp [code]
AddOns/SyncML/MsgTypes.cpp
AddOns/SyncML/MsgTypes.hpp [code]
AddOns/SyncML/SyncMLManager.cpp
AddOns/SyncML/SyncMLManager.hpp [code]
AddOns/SyncML/SyncMLPreComp.cpp
AddOns/SyncML/SyncMLPreComp.hpp [code]
AddOns/T9/ChineseT9InputMapper.cpp
AddOns/T9/ChineseT9InputMapper.hpp [code]
AddOns/T9/ChineseT9Wrapper.cpp
AddOns/T9/ChineseT9Wrapper.hpp [code]
AddOns/T9/EnglishT9InputMapper.cpp
AddOns/T9/EnglishT9InputMapper.hpp [code]
AddOns/T9/PreComp.cpp
AddOns/T9/PreComp.hpp [code]
AddOns/T9/SelectionBox.cpp
AddOns/T9/SelectionBox.hpp [code]
AddOns/T9/StrokeBox.cpp
AddOns/T9/StrokeBox.hpp [code]
AddOns/T9/T9InputMapper.cpp
AddOns/T9/T9InputMapper.hpp [code]
AddOns/T9/T9Pack.cpp
AddOns/T9/T9Pack.hpp [code]
AddOns/T9/T9PackConnector.cpp
AddOns/T9/T9PackConnector.hpp [code]
AddOns/T9/T9PinyinBox.cpp
AddOns/T9/T9PinyinBox.hpp [code]
AddOns/T9/T9PredictiveInputBox.cpp
AddOns/T9/T9PredictiveInputBox.hpp [code]
AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp [code]
AddOns/T9/T9Wrapper.cpp
AddOns/T9/T9Wrapper.hpp [code]
AddOns/Translation/EnumTranslationTable.cpp
AddOns/Translation/EnumTranslationTable.hpp [code]
AddOns/Translation/Lib.hpp [code]
AddOns/Translation/PreComp.cpp
AddOns/Translation/PreComp.hpp [code]
AddOns/Translation/ValueTextMap.cpp
AddOns/Translation/ValueTextMap.hpp [code]
AddOns/Usb/UsbMsgTypes.hpp [code]
AddOns/Usb/UsbPreComp.cpp
AddOns/Usb/UsbPreComp.hpp [code]
AddOns/Usb/UsbSubSystem.cpp
AddOns/Usb/UsbSubSystem.hpp [code]
AddOns/Usb/UsbTransport.cpp
AddOns/Usb/UsbTransport.hpp [code]
AddOns/Usb/Obex/UsbObexServerAddress.cpp
AddOns/Usb/Obex/UsbObexServerAddress.hpp [code]
AddOns/Usb/Obex/UsbObexTransport.cpp
AddOns/Usb/Obex/UsbObexTransport.hpp [code]
AddOns/VoiceRecognition/ApoxiVoiceRecognitionVersion.cpp
AddOns/VoiceRecognition/DummyVrEngineParams.cpp
AddOns/VoiceRecognition/DummyVrEngineParams.hpp [code]
AddOns/VoiceRecognition/MsgTypes.cpp
AddOns/VoiceRecognition/MsgTypes.hpp [code]
AddOns/VoiceRecognition/PreComp.cpp
AddOns/VoiceRecognition/PreComp.hpp [code]
AddOns/VoiceRecognition/TelecaVrEngineParams.cpp
AddOns/VoiceRecognition/TelecaVrEngineParams.hpp [code]
AddOns/VoiceRecognition/VrConfig.cpp
AddOns/VoiceRecognition/VrConfig.hpp [code]
AddOns/VoiceRecognition/VrData.cpp
AddOns/VoiceRecognition/VrData.hpp [code]
AddOns/VoiceRecognition/VrDispatcher.cpp
AddOns/VoiceRecognition/VrDispatcher.hpp [code]
AddOns/VoiceRecognition/VrEngineParams.cpp
AddOns/VoiceRecognition/VrEngineParams.hpp [code]
AddOns/VoiceRecognition/VrHandler.cpp
AddOns/VoiceRecognition/VrHandler.hpp [code]
AddOns/VoiceRecognition/VrHostController.cpp
AddOns/VoiceRecognition/VrHostController.hpp [code]
AddOns/VoiceRecognition/VrStackMsgArgs.cpp
AddOns/VoiceRecognition/VrStackMsgArgs.hpp [code]
AddOns/VoiceRecognition/VrStackMsgArgTable.cpp
AddOns/VoiceRecognition/VrStackMsgArgTable.hpp [code]
AddOns/VoiceRecognition/VrTemplateData.cpp
AddOns/VoiceRecognition/VrTemplateData.hpp [code]
AddOns/VoiceRecognition/VrTemplates.cpp
AddOns/VoiceRecognition/VrTypes.hpp [code]
AddOns/VoiceRecognition/VrWaitDispatcher.cpp
AddOns/VoiceRecognition/VrWaitDispatcher.hpp [code]
AddOns/Wbxml/MinBasicString.cpp
AddOns/Wbxml/WbxmlParser.cpp
AddOns/Wbxml/WbxmlParser2.cpp
AddOns/Wbxml/WbxmlParser3.cpp
AddOns/Wbxml/WbxmlPreComp.cpp
AddOns/Wbxml/WbxmlPreComp.hpp [code]
AddOns/Wbxml/WbxmlTemplates.cpp
AddOns/Wbxml/WbxmlVector.hpp [code]
AddOns/XmlParser/bistream.cpp
AddOns/XmlParser/hash.cpp
AddOns/XmlParser/parsifal.cpp
AddOns/XmlParser/PreComp.cpp
AddOns/XmlParser/PreComp.hpp [code]
AddOns/XmlParser/stk.cpp
AddOns/XmlParser/utils.cpp
AddOns/XmlParser/vector.cpp
AddOns/XmlParser/xml_parser.cpp
AddOns/XmlParser/xml_parser.hpp [code]
AddOns/YamahaMapi/AudioMapiManager.cpp
AddOns/YamahaMapi/AudioMapiManager.hpp [code]
AddOns/YamahaMapi/AudioMapiPreComp.cpp
AddOns/YamahaMapi/AudioMapiPreComp.hpp [code]
AddOns/YamahaMapi/MapiAudioPlayer.cpp
AddOns/YamahaMapi/MapiAudioPlayer.hpp [code]
AddOns/YamahaMapi/MapiAudioReference.cpp
AddOns/YamahaMapi/MapiAudioReference.hpp [code]
AddOns/Zi8/Zi8AlphabetBox.cpp
AddOns/Zi8/Zi8AlphabetBox.hpp [code]
AddOns/Zi8/Zi8InputMapper.cpp
AddOns/Zi8/Zi8InputMapper.hpp [code]
AddOns/Zi8/Zi8PreComp.cpp
AddOns/Zi8/Zi8PreComp.hpp [code]
AddOns/Zi8/Zi8PredictiveInputBox.cpp
AddOns/Zi8/Zi8PredictiveInputBox.hpp [code]
AddOns/Zi8/Zi8SelectionBox.cpp
AddOns/Zi8/Zi8SelectionBox.hpp [code]
AddOns/Zi8/Zi8StrokeBox.cpp
AddOns/Zi8/Zi8StrokeBox.hpp [code]
AddOns/Zi8/Zi8Wrapper.cpp
AddOns/Zi8/Zi8Wrapper.hpp [code]
Afs/AfsMsgTypes.cpp
Afs/AfsMsgTypes.hpp [code]
Afs/ApoxiAfsVersion.cpp
Afs/BackupFileHandler.cpp
Afs/BackupFileHandler.hpp [code]
Afs/DeletedNode.hpp [code]
Afs/DirtyFileHandler.cpp
Afs/DirtyFileHandler.hpp [code]
Afs/GuidServiceTable.cpp
Afs/GuidServiceTable.hpp [code]
Afs/LocalDataStore.cpp
Afs/LocalDataStore.hpp [code]
Afs/LockTable.cpp
Afs/LockTable.hpp [code]
Afs/LockTableList.cpp
Afs/LockTableList.hpp [code]
Afs/NodeFileHandler.cpp
Afs/NodeFileHandler.hpp [code]
Afs/NotificationTable.cpp
Afs/NotificationTable.hpp [code]
Afs/ObjectDataConverter.cpp
Afs/ObjectDataConverter.hpp [code]
Afs/ObjectTreeService.cpp
Afs/ObjectTreeService.hpp [code]
Afs/PreComp.cpp
Afs/PreComp.hpp [code]
Afs/RegDefines.hpp [code]
Afs/RegDeleteBuffer.cpp
Afs/RegDeleteBuffer.hpp [code]
Afs/Registry.cpp
Afs/Registry.hpp [code]
Afs/RegistryTypes.hpp [code]
Afs/RegIterator.cpp
Afs/RegIterator.hpp [code]
Afs/RegManager.cpp
Afs/RegManager.hpp [code]
Afs/RegMemoryPool.cpp
Afs/RegMemoryPool.hpp [code]
Afs/RegNodeFile.cpp
Afs/RegNodeFile.hpp [code]
Afs/Uri.cpp
Afs/Uri.hpp [code]
Afs/UriMappingTable.cpp
Afs/UriMappingTable.hpp [code]
Afs/Ffs/FfsHandler.cpp
Afs/Ffs/FfsHandler.hpp [code]
Afs/Ffs/FfsMimeTypeMap.cpp
Afs/Ffs/FfsMimeTypeMap.hpp [code]
Afs/Ffs/FfsSim.cpp
Afs/Ffs/FfsSim.hpp [code]
Afs/Ffs/FfsTypes.hpp [code]
Afs/Ffs/FlsFile.cpp
Afs/Ffs/FlsFile.hpp [code]
Afs/HostFsSim/HostCoreFsSim.cpp
Afs/HostFsSim/HostCoreFsSim.hpp [code]
Afs/Rfs/DirectoryIterator.cpp
Afs/Rfs/DirectoryIterator.hpp [code]
Afs/Rfs/File.cpp
Afs/Rfs/File.hpp [code]
Afs/Rfs/FileBinData.cpp
Afs/Rfs/FileBinData.hpp [code]
Afs/Rfs/FileChunkOperator.cpp
Afs/Rfs/FileChunkOperator.hpp [code]
Afs/Rfs/FileDataSink.cpp
Afs/Rfs/FileDataSink.hpp [code]
Afs/Rfs/FileDataSource.cpp
Afs/Rfs/FileDataSource.hpp [code]
Afs/Rfs/FileFilter.cpp
Afs/Rfs/FileFilter.hpp [code]
Afs/Rfs/FileVisitor.cpp
Afs/Rfs/FileVisitor.hpp [code]
Afs/Rfs/Path.cpp
Afs/Rfs/Path.hpp [code]
Afs/Rfs/Pathname.cpp
Afs/Rfs/Pathname.hpp [code]
Afs/Rfs/PathProfile.cpp
Afs/Rfs/PathProfile.hpp [code]
Afs/Rfs/RfsConfig.hpp [code]
Afs/Rfs/RfsMsgTypes.cpp
Afs/Rfs/RfsMsgTypes.hpp [code]
Afs/Rfs/RfsTemplates.cpp
Afs/Rfs/RootFileSystem.cpp
Afs/Rfs/RootFileSystem.hpp [code]
Afs/Rfs/StorageDevice.cpp
Afs/Rfs/StorageDevice.hpp [code]
Afs/Rfs/StorageDeviceFilter.cpp
Afs/Rfs/StorageDeviceFilter.hpp [code]
Afs/Rfs/StorageDeviceIterator.cpp
Afs/Rfs/StorageDeviceIterator.hpp [code]
Afs/Rfs/StorageDeviceVisitor.cpp
Afs/Rfs/StorageDeviceVisitor.hpp [code]
Apc/Accessory.hpp [code]
Apc/ApcTemplates.cpp
Apc/ApoxiApcVersion.cpp
Apc/ApoxiStartUp.hpp [code]
Apc/AtcStackMsgArgs.cpp
Apc/AtcStackMsgArgs.hpp [code]
Apc/AtcTypes.hpp [code]
Apc/AudioErrorMsg.hpp [code]
Apc/AudioMsg.hpp [code]
Apc/AudioStoppedMsg.hpp [code]
Apc/AudioSuspendedMsg.hpp [code]
Apc/AudioTypes.cpp
Apc/AudioTypes.hpp [code]
Apc/AudioVoiceMemoOutOfSpaceMsg.hpp [code]
Apc/BaseInformationElement.cpp
Apc/BaseInformationElement.hpp [code]
Apc/CallMiscStackMsgArgs.cpp
Apc/CallMiscStackMsgArgs.hpp [code]
Apc/Cbs.cpp
Apc/Cbs.hpp [code]
Apc/CbsStackMsgArgs.cpp
Apc/CbsStackMsgArgs.hpp [code]
Apc/CdStackMsgArgs.cpp
Apc/CdStackMsgArgs.hpp [code]
Apc/ChvStackMsgArgs.cpp
Apc/ChvStackMsgArgs.hpp [code]
Apc/CommandType.cpp
Apc/CommandType.hpp [code]
Apc/CommonStackMsgArgs.cpp
Apc/CommonStackMsgArgs.hpp [code]
Apc/CrssStackMsgArgs.cpp
Apc/CrssStackMsgArgs.hpp [code]
Apc/DataCodingScheme.cpp
Apc/DataCodingScheme.hpp [code]
Apc/ImageData.cpp
Apc/ImageData.hpp [code]
Apc/ImageStackMsgArgs.cpp
Apc/ImageStackMsgArgs.hpp [code]
Apc/InformationElement.cpp
Apc/InformationElement.hpp [code]
Apc/Lib.hpp [code]
Apc/LockTypes.hpp [code]
Apc/MdhSmsStackMsgArgs.cpp
Apc/MdhSmsStackMsgArgs.hpp [code]
Apc/MdhTypes.hpp [code]
Apc/Message.hpp [code]
Apc/MessageIdentifier.cpp
Apc/MessageIdentifier.hpp [code]
Apc/MessageImpl.cpp
Apc/MessageTypeIndicator.cpp
Apc/MessageTypeIndicator.hpp [code]
Apc/MiscStackMsgArgs.cpp
Apc/MiscStackMsgArgs.hpp [code]
Apc/MocStackMsgArgs.cpp
Apc/MocStackMsgArgs.hpp [code]
Apc/MtcStackMsgArgs.cpp
Apc/MtcStackMsgArgs.hpp [code]
Apc/NetworkStackMsgArgs.cpp
Apc/NetworkStackMsgArgs.hpp [code]
Apc/NetworkTypes.cpp
Apc/NetworkTypes.hpp [code]
Apc/OmStackMsgArgs.cpp
Apc/OmStackMsgArgs.hpp [code]
Apc/ParameterIndicator.cpp
Apc/ParameterIndicator.hpp [code]
Apc/PdpTypes.hpp [code]
Apc/PhoneBookStackMsgArgs.cpp
Apc/PhoneBookStackMsgArgs.hpp [code]
Apc/PlmnScanList.cpp
Apc/PlmnScanList.hpp [code]
Apc/PlmnStackMsgArgs.cpp
Apc/PlmnStackMsgArgs.hpp [code]
Apc/PowerStackMsgArgs.cpp
Apc/PowerStackMsgArgs.hpp [code]
Apc/PreComp.cpp
Apc/PreComp.hpp [code]
Apc/ProtocolIdentifier.cpp
Apc/ProtocolIdentifier.hpp [code]
Apc/ShortMessageFailureCause.cpp
Apc/ShortMessageFailureCause.hpp [code]
Apc/ShortMessageStatus.cpp
Apc/ShortMessageStatus.hpp [code]
Apc/SignalTypes.hpp [code]
Apc/SimDataTypes.cpp
Apc/SimDataTypes.hpp [code]
Apc/SimLockTypes.hpp [code]
Apc/SimMiscStackMsgArgs.cpp
Apc/SimMiscStackMsgArgs.hpp [code]
Apc/SimMiscTypes.hpp [code]
Apc/SimTkStackMsgArgs.cpp
Apc/SimTkStackMsgArgs.hpp [code]
Apc/SimTkTypes.cpp
Apc/SimTkTypes.hpp [code]
Apc/Sms.cpp
Apc/Sms.hpp [code]
Apc/SmsStackMsgArgs.cpp
Apc/SmsStackMsgArgs.hpp [code]
Apc/SsErrorCode.hpp [code]
Apc/SsNotification.hpp [code]
Apc/SsStackMsgArgs.cpp
Apc/SsStackMsgArgs.hpp [code]
Apc/SsStackMsgArgument.cpp
Apc/SsStackMsgArgument.hpp [code]
Apc/SsStatus.hpp [code]
Apc/StackInterface.cpp
Apc/StackInterface.hpp [code]
Apc/StackMsgArgument.cpp
Apc/StackMsgArgument.hpp [code]
Apc/StackWrapper.cpp
Apc/StackWrapper.hpp [code]
Apc/StreamOperators.cpp
Apc/StreamOperators.hpp [code]
Apc/TaggedProblemCode.hpp [code]
Apc/Tlv.cpp
Apc/Tlv.hpp [code]
Apc/Tpdu.cpp
Apc/Tpdu.hpp [code]
Apc/UserData.cpp
Apc/UserData.hpp [code]
Apc/UsimPbTypes.cpp
Apc/UsimPbTypes.hpp [code]
Apc/ValidityPeriod.cpp
Apc/ValidityPeriod.hpp [code]
Apc/SignalHandler/ApoxiApcSignalHandlerVersion.cpp
Apc/SignalHandler/AtcSignalProcessor.cpp
Apc/SignalHandler/AtcStackMsgProcessor.cpp
Apc/SignalHandler/AtKeyParser.cpp
Apc/SignalHandler/AtKeyParser.hpp [code]
Apc/SignalHandler/AtSignalProcessor.cpp
Apc/SignalHandler/AudioSignalProcessor.cpp
Apc/SignalHandler/CallMiscSignalProcessor.cpp
Apc/SignalHandler/CallMiscStackMsgProcessor.cpp
Apc/SignalHandler/CbsSignalProcessor.cpp
Apc/SignalHandler/CbsStackMsgProcessor.cpp
Apc/SignalHandler/ChvSignalProcessor.cpp
Apc/SignalHandler/ChvStackMsgProcessor.cpp
Apc/SignalHandler/CommonSignalMapTableNode.cpp
Apc/SignalHandler/CommonSignalMapTableNode.hpp [code]
Apc/SignalHandler/CommonSignalProcessor.hpp [code]
Apc/SignalHandler/CommonStackMsgMapTableNode.cpp
Apc/SignalHandler/CommonStackMsgMapTableNode.hpp [code]
Apc/SignalHandler/CommonStackMsgProcessor.hpp [code]
Apc/SignalHandler/CrssSignalProcessor.cpp
Apc/SignalHandler/CrssStackMsgProcessor.cpp
Apc/SignalHandler/ImageSignalProcessor.cpp
Apc/SignalHandler/ImageStackMsgProcessor.cpp
Apc/SignalHandler/KeyMsgGenerator.cpp
Apc/SignalHandler/KeyMsgGenerator.hpp [code]
Apc/SignalHandler/Lib.hpp [code]
Apc/SignalHandler/MdhSignalProcessor.cpp
Apc/SignalHandler/MdhStackMsgProcessor.cpp
Apc/SignalHandler/MiscSignalProcessor.cpp
Apc/SignalHandler/MiscStackMsgProcessor.cpp
Apc/SignalHandler/MocSignalProcessor.cpp
Apc/SignalHandler/MocStackMsgProcessor.cpp
Apc/SignalHandler/MtcSignalProcessor.cpp
Apc/SignalHandler/MtcStackMsgProcessor.cpp
Apc/SignalHandler/NetworkSignalProcessor.cpp
Apc/SignalHandler/NetworkStackMsgProcessor.cpp
Apc/SignalHandler/OmSignalProcessor.cpp
Apc/SignalHandler/OmStackMsgProcessor.cpp
Apc/SignalHandler/PhoneBookSignalProcessor.cpp
Apc/SignalHandler/PhoneBookStackMsgProcessor.cpp
Apc/SignalHandler/PlmnSignalProcessor.cpp
Apc/SignalHandler/PlmnStackMsgProcessor.cpp
Apc/SignalHandler/PowerSignalProcessor.cpp
Apc/SignalHandler/PowerStackMsgProcessor.cpp
Apc/SignalHandler/PreComp.cpp
Apc/SignalHandler/PreComp.hpp [code]
Apc/SignalHandler/ProcessNode.cpp
Apc/SignalHandler/ProcessNode.hpp [code]
Apc/SignalHandler/SignalHandler.cpp
Apc/SignalHandler/SignalHandler.hpp [code]
Apc/SignalHandler/SignalMapTable.cpp
Apc/SignalHandler/SignalMapTable.hpp [code]
Apc/SignalHandler/SignalMapTableEntry.hpp [code]
Apc/SignalHandler/SignalMapTableNode.cpp
Apc/SignalHandler/SignalMapTableNode.hpp [code]
Apc/SignalHandler/SimMiscSignalProcessor.cpp
Apc/SignalHandler/SimMiscStackMsgProcessor.cpp
Apc/SignalHandler/SimTkLetClassESignalProcessor.cpp
Apc/SignalHandler/SimTkLetClassEStackMsgProcessor.cpp
Apc/SignalHandler/SimTkSignalProcessor.cpp
Apc/SignalHandler/SimTkStackMsgProcessor.cpp
Apc/SignalHandler/SmsSignalProcessor.cpp
Apc/SignalHandler/SmsStackMsgProcessor.cpp
Apc/SignalHandler/SsCcbsSignalProcessor.cpp
Apc/SignalHandler/SsCcbsStackMsgProcessor.cpp
Apc/SignalHandler/SsSignalProcessor.cpp
Apc/SignalHandler/SsStackMsgProcessor.cpp
Apc/SignalHandler/StackMsgMapTable.cpp
Apc/SignalHandler/StackMsgMapTable.hpp [code]
Apc/SignalHandler/StackMsgMapTableEntry.hpp [code]
Apc/SignalHandler/StackMsgMapTableNode.cpp
Apc/SignalHandler/StackMsgMapTableNode.hpp [code]
Apc/SignalHandler/StackMsgProcessor.cpp
Apc/SignalHandler/StackMsgProcessor.hpp [code]
Apc/SignalHandler/StackTranslator.cpp
Apc/SignalHandler/StackTranslator.hpp [code]
Apc/SignalHandler/StatusHandlerProcessor.cpp
Apc/SignalHandler/StatusStackMsgProcessor.cpp
Asc/AccDispatcher.cpp
Asc/AccDispatcher.hpp [code]
Asc/AccHandler.cpp
Asc/AccHandler.hpp [code]
Asc/AdcInterface.cpp
Asc/AdcInterface.hpp [code]
Asc/AocDispatcher.cpp
Asc/AocDispatcher.hpp [code]
Asc/AocHandler.cpp
Asc/AocHandler.hpp [code]
Asc/ApoxiAscVersion.cpp
Asc/AscTemplates.cpp
Asc/AtBaseManager.cpp
Asc/AtBaseManager.hpp [code]
Asc/AtcDispatcher.cpp
Asc/AtcDispatcher.hpp [code]
Asc/AtcHandler.cpp
Asc/AtcHandler.hpp [code]
Asc/AtManager.cpp
Asc/AtManager.hpp [code]
Asc/BaseHandler.cpp
Asc/BaseHandler.hpp [code]
Asc/BattHandler.hpp [code]
Asc/BootDispatcher.cpp
Asc/BootDispatcher.hpp [code]
Asc/BootHandler.cpp
Asc/BootHandler.hpp [code]
Asc/CallBarringHandler.cpp
Asc/CallBarringHandler.hpp [code]
Asc/CallControlDispatcher.cpp
Asc/CallControlDispatcher.hpp [code]
Asc/CallControlHandler.cpp
Asc/CallControlHandler.hpp [code]
Asc/CallDeflectionDispatcher.cpp
Asc/CallDeflectionDispatcher.hpp [code]
Asc/CallDeflectionHandler.cpp
Asc/CallDeflectionHandler.hpp [code]
Asc/CallDispatcher.cpp
Asc/CallDispatcher.hpp [code]
Asc/CallForwardingHandler.cpp
Asc/CallForwardingHandler.hpp [code]
Asc/CallHandler.cpp
Asc/CallHandler.hpp [code]
Asc/CallHandlingData.cpp
Asc/CallHandlingData.hpp [code]
Asc/CallHdl.cpp
Asc/CallHdl.hpp [code]
Asc/CallHdlBase.cpp
Asc/CallHdlBase.hpp [code]
Asc/CallReleaseDispatcher.cpp
Asc/CallReleaseDispatcher.hpp [code]
Asc/CallWaitingHandler.cpp
Asc/CallWaitingHandler.hpp [code]
Asc/CbsDispatcher.cpp
Asc/CbsDispatcher.hpp [code]
Asc/CbsFilterList.cpp
Asc/CbsFilterList.hpp [code]
Asc/CbsHandler.cpp
Asc/CbsHandler.hpp [code]
Asc/CbsStartDispatcher.cpp
Asc/CbsStartDispatcher.hpp [code]
Asc/CbsStopDispatcher.cpp
Asc/CbsStopDispatcher.hpp [code]
Asc/ChrHandler.hpp [code]
Asc/ClipHandler.cpp
Asc/ClipHandler.hpp [code]
Asc/ClirHandler.cpp
Asc/ClirHandler.hpp [code]
Asc/CnapHandler.cpp
Asc/CnapHandler.hpp [code]
Asc/ColpHandler.cpp
Asc/ColpHandler.hpp [code]
Asc/ColrHandler.cpp
Asc/ColrHandler.hpp [code]
Asc/CrssDispatcher.cpp
Asc/CrssDispatcher.hpp [code]
Asc/CrssHandler.cpp
Asc/CrssHandler.hpp [code]
Asc/DataCall.hpp [code]
Asc/DataCallContext.cpp
Asc/DataCallContext.hpp [code]
Asc/DataCallControl.hpp [code]
Asc/DataCallHdl.hpp [code]
Asc/DataCallTypes.hpp [code]
Asc/DtmfDispatcher.cpp
Asc/DtmfDispatcher.hpp [code]
Asc/EmlppHandler.cpp
Asc/EmlppHandler.hpp [code]
Asc/ExternalPsdContextListener.cpp
Asc/ExternalPsdContextListener.hpp [code]
Asc/HandlerData.cpp
Asc/HandlerData.hpp [code]
Asc/HandlerFactory.hpp [code]
Asc/HandlerId.hpp [code]
Asc/HandlerList.cpp
Asc/HandlerList.hpp [code]
Asc/HandlerListDataTable.cpp
Asc/InputAction.cpp
Asc/InputAction.hpp [code]
Asc/InputAnalyzer.cpp
Asc/InputAnalyzer.hpp [code]
Asc/InputParser.cpp
Asc/InputParser.hpp [code]
Asc/InputParserTranslator.cpp
Asc/InputParserTranslator.hpp [code]
Asc/Lib.hpp [code]
Asc/MainHandler.cpp
Asc/MainHandler.hpp [code]
Asc/MainHandlerAccess.cpp
Asc/MainHandlerAccess.hpp [code]
Asc/MobileOriginatedUssdHandler.cpp
Asc/MobileOriginatedUssdHandler.hpp [code]
Asc/MocVoiceDispatcher.cpp
Asc/MocVoiceDispatcher.hpp [code]
Asc/MocVoiceHandler.cpp
Asc/MocVoiceHandler.hpp [code]
Asc/MptyCallHdl.cpp
Asc/MptyCallHdl.hpp [code]
Asc/MsgArgs.cpp
Asc/MsgArgs.hpp [code]
Asc/MtcVoiceAcceptDispatcher.cpp
Asc/MtcVoiceAcceptDispatcher.hpp [code]
Asc/MtcVoiceDispatcher.cpp
Asc/MtcVoiceDispatcher.hpp [code]
Asc/MtcVoiceHandler.cpp
Asc/MtcVoiceHandler.hpp [code]
Asc/MultiSlotDispatcher.cpp
Asc/MultiSlotDispatcher.hpp [code]
Asc/MultiSlotHandler.cpp
Asc/MultiSlotHandler.hpp [code]
Asc/NetworkDispatcher.cpp
Asc/NetworkDispatcher.hpp [code]
Asc/NetworkHandler.cpp
Asc/NetworkHandler.hpp [code]
Asc/PdpContext.cpp
Asc/PdpContext.hpp [code]
Asc/PdpContextControl.hpp [code]
Asc/PdpContextManager.cpp
Asc/PdpContextManager.hpp [code]
Asc/PdpContextManagerControl.hpp [code]
Asc/PlmnDispatcher.cpp
Asc/PlmnDispatcher.hpp [code]
Asc/PlmnHandler.cpp
Asc/PlmnHandler.hpp [code]
Asc/PlmnRatDispatcher.cpp
Asc/PlmnRatDispatcher.hpp [code]
Asc/PlmnScanDispatcher.cpp
Asc/PlmnScanDispatcher.hpp [code]
Asc/PortHeaderInformation.cpp
Asc/PortHeaderInformation.hpp [code]
Asc/PowerDispatcher.cpp
Asc/PowerDispatcher.hpp [code]
Asc/PowerDownDispatcher.cpp
Asc/PowerDownDispatcher.hpp [code]
Asc/PowerHandler.cpp
Asc/PowerHandler.hpp [code]
Asc/PppFrame.cpp
Asc/PppFrame.hpp [code]
Asc/PreComp.cpp
Asc/PreComp.hpp [code]
Asc/RedialDispatcher.cpp
Asc/RedialDispatcher.hpp [code]
Asc/RtcHandler.hpp [code]
Asc/SigDispatcher.cpp
Asc/SigDispatcher.hpp [code]
Asc/SigHandler.cpp
Asc/SigHandler.hpp [code]
Asc/SimDispatcher.cpp
Asc/SimDispatcher.hpp [code]
Asc/SimHandler.cpp
Asc/SimHandler.hpp [code]
Asc/SimTkDispatcher.cpp
Asc/SimTkDispatcher.hpp [code]
Asc/SimTkHandler.cpp
Asc/SimTkHandler.hpp [code]
Asc/SimTkLceDispatcher.cpp
Asc/SimTkLceDispatcher.hpp [code]
Asc/SimTkLceHandler.cpp
Asc/SimTkLceHandler.hpp [code]
Asc/SimTkLceService.cpp
Asc/SimTkLceService.hpp [code]
Asc/SmsContext.cpp
Asc/SmsContext.hpp [code]
Asc/SmsDispatcher.cpp
Asc/SmsDispatcher.hpp [code]
Asc/SmsFactory.cpp
Asc/SmsFactory.hpp [code]
Asc/SmsHandler.cpp
Asc/SmsHandler.hpp [code]
Asc/SmsSendDispatcher.cpp
Asc/SmsSendDispatcher.hpp [code]
Asc/SmsSendProtector.cpp
Asc/SmsSendProtector.hpp [code]
Asc/SmsSocket.cpp
Asc/SmsSocket.hpp [code]
Asc/SmsSocketListener.cpp
Asc/SmsSocketListener.hpp [code]
Asc/SmsSocketSignalMapTableNode.cpp
Asc/SmsSocketSignalMapTableNode.hpp [code]
Asc/SsBaseHandler.cpp
Asc/SsBaseHandler.hpp [code]
Asc/SsCcbsDispatcher.cpp
Asc/SsCcbsDispatcher.hpp [code]
Asc/SsCcbsHandler.cpp
Asc/SsCcbsHandler.hpp [code]
Asc/SsClHandler.cpp
Asc/SsClHandler.hpp [code]
Asc/SsDispatcher.hpp [code]
Asc/SsHandler.hpp [code]
Asc/SsMainHandler.cpp
Asc/SsMainHandler.hpp [code]
Asc/SsMessage.cpp
Asc/SsMessage.hpp [code]
Asc/SsWaitDispatcher.hpp [code]
Asc/StackControl.cpp
Asc/StackControl.hpp [code]
Asc/StackIndicationMsgTypes.cpp
Asc/StackIndicationMsgTypes.hpp [code]
Asc/StackMsgActiveWaitDispatcher.cpp
Asc/StackMsgActiveWaitDispatcher.hpp [code]
Asc/StackMsgDispatcher.cpp
Asc/StackMsgDispatcher.hpp [code]
Asc/StatusDispatcher.cpp
Asc/StatusDispatcher.hpp [code]
Asc/SupplementaryServiceAction.cpp
Asc/SupplementaryServiceAction.hpp [code]
Asc/SupplementaryServiceDispatcher.cpp
Asc/SupplementaryServiceDispatcher.hpp [code]
Asc/SupplementaryServiceWaitDispatcher.cpp
Asc/SupplementaryServiceWaitDispatcher.hpp [code]
Asc/TchInterface.cpp
Asc/TchInterface.hpp [code]
Asc/TipdBasedActiveWaitDispatcher.cpp
Asc/TipdBasedActiveWaitDispatcher.hpp [code]
Asc/TtyInterface.cpp
Asc/TtyInterface.hpp [code]
Asc/Types.hpp [code]
Asc/UssdHandler.cpp
Asc/UssdHandler.hpp [code]
Asc/UusHandler.cpp
Asc/UusHandler.hpp [code]
Asc/ValueMap.hpp [code]
Asc/Host/DataCallHdl.cpp
Asc/Host/DataCallSignalProcessor.cpp
Asc/Host/DataCallSignalProcessor.hpp [code]
Asc/Host/PdpContext.host.cpp
Asc/Host/PdpContextManager.host.cpp
Asc/Host/PreComp.cpp
Asc/Host/ValueMap.hpp [code]
Asc/Target/DataCallHdl.cpp
Asc/Target/DataCallSignalMapTableNode.cpp
Asc/Target/DataCallSignalMapTableNode.hpp [code]
Asc/Target/DataCallSignalProcessor.cpp
Asc/Target/DataCallSignalProcessor.hpp [code]
Asc/Target/PdpContext.target.cpp
Asc/Target/PdpContextManager.target.cpp
Asc/Target/PdpContextSignalMapTableNode.cpp
Asc/Target/PdpContextSignalMapTableNode.hpp [code]
Asc/Target/PdpContextSignalProcessor.cpp
Asc/Target/PdpContextSignalProcessor.hpp [code]
Asc/Target/PreComp.cpp
Asc/Target/ValueMap.hpp [code]
Atl/AtlApplication.cpp
Atl/AtlApplication.hpp [code]
Atl/AtlApplicationPlugin.cpp
Atl/AtlApplicationPlugin.hpp [code]
Atl/AtlApplicationPluginStartup.cpp
Atl/AtlApplicationPluginStartup.hpp [code]
Atl/AtlMsgTypes.cpp
Atl/AtlMsgTypes.hpp [code]
Atl/AtlPreComp.cpp
Atl/AtlPreComp.hpp [code]
Atl/AtlTemplates.cpp
Atl/AtlWindow.cpp
Atl/AtlWindow.hpp [code]
Atl/EnumTextMap.cpp
Atl/EnumTextMap.hpp [code]
Atl/Fraction.cpp
Atl/Fraction.hpp [code]
Atl/IdentifierHandler.cpp
Atl/IdentifierHandler.hpp [code]
Atl/InputMapperFactory.cpp
Atl/InputMapperFactory.hpp [code]
Atl/PhoneNumberMatchRule.cpp
Atl/PhoneNumberMatchRule.hpp [code]
Atl/ResourceID.cpp
Atl/ResourceID.hpp [code]
Atl/SettingsProvider.cpp
Atl/SettingsProvider.hpp [code]
Atl/Config/DynamicMenuPool.cpp
Atl/Config/DynamicMenuPool.hpp [code]
Atl/Config/MenuResourceTable.hpp [code]
Atl/Context/ContextDescription.cpp
Atl/Context/ContextDescription.hpp [code]
Atl/Context/ContextDescriptionTypes.hpp [code]
Atl/Context/ContextFeatureHandle.cpp
Atl/Context/ContextFeatureHandle.hpp [code]
Atl/Context/ContextID.hpp [code]
Atl/Context/ContextManager.cpp
Atl/Context/ContextManager.hpp [code]
Atl/Context/ContextTable.cpp
Atl/Context/ContextTable.hpp [code]
Atl/Context/ContextTableNode.cpp
Atl/Context/ContextTableNode.hpp [code]
Atl/Context/KeyManager.cpp
Atl/Context/KeyManager.hpp [code]
Atl/Context/KeyMapping.cpp
Atl/Context/KeyMapping.hpp [code]
Atl/Context/KeySequence.cpp
Atl/Context/KeySequence.hpp [code]
Atl/Context/MenuDesc.cpp
Atl/Context/MenuDesc.hpp [code]
Atl/Context/MenuDescObj.cpp
Atl/Context/MenuDescObj.hpp [code]
Atl/Context/MenuProperties.cpp
Atl/Context/MenuProperties.hpp [code]
Atl/Context/SoftkeyDesc.cpp
Atl/Context/SoftkeyDesc.hpp [code]
Atl/Features/AppFeatureID.cpp
Atl/Features/AppFeatureID.hpp [code]
Atl/Features/ApplicationID.hpp [code]
Atl/Features/BackToIdleFeature.cpp
Atl/Features/BackToIdleFeature.hpp [code]
Atl/Features/ContextFeature.cpp
Atl/Features/ContextFeature.hpp [code]
Atl/Features/ContextFeatureItem.cpp
Atl/Features/ContextFeatureItem.hpp [code]
Atl/Features/Feature.cpp
Atl/Features/Feature.hpp [code]
Atl/Features/FeatureBroker.cpp
Atl/Features/FeatureBroker.hpp [code]
Atl/Features/FeatureHandle.cpp
Atl/Features/FeatureHandle.hpp [code]
Atl/Features/FeatureID.hpp [code]
Atl/Features/FeatureItem.cpp
Atl/Features/FeatureItem.hpp [code]
Atl/Features/FeatureItemContainer.cpp
Atl/Features/FeatureItemContainer.hpp [code]
Atl/Features/FeatureItemContainerID.hpp [code]
Atl/Features/FeaturePool.cpp
Atl/Features/FeaturePool.hpp [code]
Atl/Features/IndicatorItem.cpp
Atl/Features/IndicatorItem.hpp [code]
Atl/Features/ItemObj.cpp
Atl/Features/ItemObj.hpp [code]
Atl/Features/MenuID.hpp [code]
Atl/Features/MenuIdObj.cpp
Atl/Features/MenuIdObj.hpp [code]
Atl/Features/MenuPool.cpp
Atl/Features/MenuPool.hpp [code]
Atl/Features/MenuTable.cpp
Atl/Features/MenuTable.hpp [code]
Atl/Features/MenuTableNode.cpp
Atl/Features/MenuTableNode.hpp [code]
Atl/Features/ProviderProxyContainer.cpp
Atl/Features/ProviderProxyContainer.hpp [code]
Atl/Features/ProviderProxyItem.cpp
Atl/Features/ProviderProxyItem.hpp [code]
Atl/Features/TriggerKeyFeature.cpp
Atl/Features/TriggerKeyFeature.hpp [code]
Atl/Features/ValueItem.hpp [code]
Atl/Gui/AtlItemBox.cpp
Atl/Gui/AtlItemBox.hpp [code]
Atl/Gui/AtlItemGrid.hpp [code]
Atl/Gui/AtlItemGridWindow.cpp
Atl/Gui/AtlItemGridWindow.hpp [code]
Atl/Gui/AtlItemListWindow.cpp
Atl/Gui/AtlItemListWindow.hpp [code]
Atl/Gui/AtlItemMenu.hpp [code]
Atl/Gui/AtlItemMenuWindow.cpp
Atl/Gui/AtlItemMenuWindow.hpp [code]
Atl/Gui/AtlItemRenderer.hpp [code]
Atl/Gui/AtlLabelListWindow.cpp
Atl/Gui/AtlLabelListWindow.hpp [code]
Atl/Gui/ImgObtObj.cpp
Atl/Gui/ImgObtObj.hpp [code]
Atl/Gui/Indicator.hpp [code]
Atl/Gui/IndicatorBar.hpp [code]
Atl/Gui/IndicatorBarID.hpp [code]
Atl/Gui/IndicatorDescription.hpp [code]
Atl/Gui/IndicatorID.hpp [code]
Atl/Gui/IndicatorPaneObject.hpp [code]
Atl/Gui/ItemLabel.cpp
Atl/Gui/ItemLabel.hpp [code]
Atl/Gui/MainDesktop.cpp
Atl/Gui/MainDesktop.hpp [code]
Atl/Properties/AtlPropertyEditor.hpp [code]
Atl/Properties/ListPropertyDescriptor.cpp
Atl/Properties/ListPropertyDescriptor.hpp [code]
Atl/Properties/MappingPolicy.cpp
Atl/Properties/MappingPolicy.hpp [code]
Atl/Properties/Property.cpp
Atl/Properties/Property.hpp [code]
Atl/Properties/PropertyDescriptor.cpp
Atl/Properties/PropertyDescriptor.hpp [code]
Atl/Properties/PropertyEditor.cpp
Atl/Properties/PropertyEditor.hpp [code]
Atl/Properties/PropertyEditorFactory.cpp
Atl/Properties/PropertyEditorFactory.hpp [code]
Atl/Properties/PropertyEditorID.hpp [code]
Atl/Properties/PropertyID.hpp [code]
Atl/Properties/PropertyItem.cpp
Atl/Properties/PropertyItem.hpp [code]
Atl/Properties/SubstitutedText.cpp
Atl/Properties/SubstitutedText.hpp [code]
Atl/Properties/TextIconPairArray.cpp
Atl/Properties/TextIconPairArray.hpp [code]
Atl/Properties/ValueMappingPropertyDescriptor.hpp [code]
Audio/audio_private.cpp
Audio/audio_private.hpp [code]
Audio/AudioAccessoryDetails.cpp
Audio/AudioAccessoryDetails.hpp [code]
Audio/AudioAccessoryStore.cpp
Audio/AudioAccessoryStore.hpp [code]
Audio/AudioActiveReference.cpp
Audio/AudioActiveReference.hpp [code]
Audio/AudioDeviceBase.cpp
Audio/AudioDeviceBase.hpp [code]
Audio/AudioDeviceManager.cpp
Audio/AudioDeviceManager.hpp [code]
Audio/AudioError.cpp
Audio/AudioError.hpp [code]
Audio/AudioMsgProcessor.cpp
Audio/AudioMsgProcessor.hpp [code]
Audio/AudioPath.cpp
Audio/AudioPath.hpp [code]
Audio/AudioPathManager.cpp
Audio/AudioPathManager.hpp [code]
Audio/AudioPlayer.cpp
Audio/AudioPlayer.hpp [code]
Audio/AudioPlayerEvent.hpp [code]
Audio/AudioPlayerStore.cpp
Audio/AudioPlayerStore.hpp [code]
Audio/AudioPreComp.cpp
Audio/AudioPreComp.hpp [code]
Audio/AudioPreset.cpp
Audio/AudioPreset.hpp [code]
Audio/AudioPresetStore.cpp
Audio/AudioPresetStore.hpp [code]
Audio/AudioPriorityManager.cpp
Audio/AudioPriorityManager.hpp [code]
Audio/AudioReference.cpp
Audio/AudioReference.hpp [code]
Audio/AudioSignalMapTableNode.cpp
Audio/AudioSignalMapTableNode.hpp [code]
Audio/AudioSuspendedDetails.cpp
Audio/AudioSuspendedDetails.hpp [code]
Audio/AudioTemplates.cpp
Audio/AudioUtility.cpp
Audio/AudioUtility.hpp [code]
Audio/AudioVibratorDevice.cpp
Audio/AudioVibratorDevice.hpp [code]
Audio/CombinedDeviceAudioReference.cpp
Audio/CombinedDeviceAudioReference.hpp [code]
Audio/CustomIMelodyAudioReference.cpp
Audio/CustomIMelodyAudioReference.hpp [code]
Audio/CustomRingerAudioReference.cpp
Audio/CustomRingerAudioReference.hpp [code]
Audio/CustomSmafPhraseAudioReference.cpp
Audio/CustomSmafPhraseAudioReference.hpp [code]
Audio/CustomToneAudioReference.cpp
Audio/CustomToneAudioReference.hpp [code]
Audio/DwdDevice.cpp
Audio/DwdDevice.hpp [code]
Audio/DwdPlayer.cpp
Audio/DwdPlayer.hpp [code]
Audio/FlagCaretaker.cpp
Audio/FlagCaretaker.hpp [code]
Audio/FmRadioAudioPlayer.cpp
Audio/FmRadioAudioPlayer.hpp [code]
Audio/GenericFeatureData.cpp
Audio/GenericFeatureData.hpp [code]
Audio/MmfPlayer.cpp
Audio/MmfPlayer.hpp [code]
Audio/Mp3AudioPlayer.cpp
Audio/Mp3AudioPlayer.hpp [code]
Audio/Mp3AudioReference.cpp
Audio/Mp3AudioReference.hpp [code]
Audio/PcmAudioPlayer.cpp
Audio/PcmAudioPlayer.hpp [code]
Audio/PcmAudioReference.cpp
Audio/PcmAudioReference.hpp [code]
Audio/PresetAudioReference.cpp
Audio/PresetAudioReference.hpp [code]
Audio/RadioAudioDevice.cpp
Audio/RadioAudioDevice.hpp [code]
Audio/RingerAudioInternalMidiPlayer.cpp
Audio/RingerAudioInternalMidiPlayer.hpp [code]
Audio/RingerAudioPlayer.cpp
Audio/RingerAudioPlayer.hpp [code]
Audio/RingerAudioReference.cpp
Audio/RingerAudioReference.hpp [code]
Audio/SimpleAudioDevice.cpp
Audio/SimpleAudioDevice.hpp [code]
Audio/SimpleAudioReference.cpp
Audio/SimpleAudioReference.hpp [code]
Audio/SpeechSimpleAudioDevice.cpp
Audio/SpeechSimpleAudioDevice.hpp [code]
Audio/StreamAudioPlayer.cpp
Audio/StreamAudioPlayer.hpp [code]
Audio/StreamAudioReference.cpp
Audio/StreamAudioReference.hpp [code]
Audio/TimeFeatureObject.cpp
Audio/TimeFeatureObject.hpp [code]
Audio/ToneAudioPlayer.cpp
Audio/ToneAudioPlayer.hpp [code]
Audio/ToneAudioReference.cpp
Audio/ToneAudioReference.hpp [code]
Audio/VoiceMemoAudioPlayer.cpp
Audio/VoiceMemoAudioPlayer.hpp [code]
Audio/VoiceMemoAudioReference.cpp
Audio/VoiceMemoAudioReference.hpp [code]
Audio/Messages/AudioDeviceStatusMsg.cpp
Audio/Messages/AudioDeviceStatusMsg.hpp [code]
Audio/Messages/AudioErrorMsg.cpp
Audio/Messages/AudioErrorMsg.hpp [code]
Audio/Messages/AudioGetPlayPositionMsg.cpp
Audio/Messages/AudioGetPlayPositionMsg.hpp [code]
Audio/Messages/AudioMessages.cpp
Audio/Messages/AudioMessages.hpp [code]
Audio/Messages/AudioMsg.cpp
Audio/Messages/AudioMsg.hpp [code]
Audio/Messages/AudioPlayTimeMsg.cpp
Audio/Messages/AudioPlayTimeMsg.hpp [code]
Audio/Messages/AudioRadioDeviceNotificationMsg.cpp
Audio/Messages/AudioRadioDeviceNotificationMsg.hpp [code]
Audio/Messages/AudioRestartedMsg.cpp
Audio/Messages/AudioRestartedMsg.hpp [code]
Audio/Messages/AudioResumedMsg.cpp
Audio/Messages/AudioResumedMsg.hpp [code]
Audio/Messages/AudioStartedMsg.cpp
Audio/Messages/AudioStartedMsg.hpp [code]
Audio/Messages/AudioStoppedMsg.cpp
Audio/Messages/AudioStoppedMsg.hpp [code]
Audio/Messages/AudioStreamingSyncMsg.cpp
Audio/Messages/AudioStreamingSyncMsg.hpp [code]
Audio/Messages/AudioSuspendedMsg.cpp
Audio/Messages/AudioSuspendedMsg.hpp [code]
Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.cpp
Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp [code]
Audio/RtStreaming/DataSourceRtStreamingSource.cpp
Audio/RtStreaming/DataSourceRtStreamingSource.hpp [code]
Audio/RtStreaming/RtStreamingBuffer.cpp
Audio/RtStreaming/RtStreamingBuffer.hpp [code]
Audio/RtStreaming/RtStreamingConn.cpp
Audio/RtStreaming/RtStreamingConn.hpp [code]
Audio/RtStreaming/RtStreamingEndPoint.cpp
Audio/RtStreaming/RtStreamingEndPoint.hpp [code]
Audio/RtStreaming/RtStreamingSink.cpp
Audio/RtStreaming/RtStreamingSink.hpp [code]
Audio/RtStreaming/RtStreamingSource.cpp
Audio/RtStreaming/RtStreamingSource.hpp [code]
Auxiliary/AbstractDelegationProvider.cpp
Auxiliary/AbstractDelegationProvider.hpp [code]
Auxiliary/AlphaCoding.cpp
Auxiliary/AlphaCoding.hpp [code]
Auxiliary/ApoxiAuxiliaryVersion.cpp
Auxiliary/AuxiliaryTemplates.cpp
Auxiliary/BinarySearch.hpp [code]
Auxiliary/BinData.cpp
Auxiliary/BinData.hpp [code]
Auxiliary/BinDataDataSource.cpp
Auxiliary/BinDataDataSource.hpp [code]
Auxiliary/BinDataOwner.hpp [code]
Auxiliary/BitField.hpp [code]
Auxiliary/BitVector.hpp [code]
Auxiliary/BlobObject.cpp
Auxiliary/BlobObject.hpp [code]
Auxiliary/BlobPtr.cpp
Auxiliary/BlobPtr.hpp [code]
Auxiliary/BubbleSortProvider.cpp
Auxiliary/BubbleSortProvider.hpp [code]
Auxiliary/BufferedData.cpp
Auxiliary/BufferedData.hpp [code]
Auxiliary/BufferPoolManager.cpp
Auxiliary/BufferPoolManager.hpp [code]
Auxiliary/ByteBuffer.cpp
Auxiliary/ByteBuffer.hpp [code]
Auxiliary/CachingSortProvider.cpp
Auxiliary/CachingSortProvider.hpp [code]
Auxiliary/ChildBinData.cpp
Auxiliary/ChildBinData.hpp [code]
Auxiliary/ChineseQuickSortProvider.cpp
Auxiliary/ChineseQuickSortProvider.hpp [code]
Auxiliary/Conversion.cpp
Auxiliary/Conversion.hpp [code]
Auxiliary/CountryCodes.hpp [code]
Auxiliary/DataCoding.cpp
Auxiliary/DataCoding.hpp [code]
Auxiliary/DataItem.cpp
Auxiliary/DataItem.hpp [code]
Auxiliary/DataSink.cpp
Auxiliary/DataSink.hpp [code]
Auxiliary/DataSource.cpp
Auxiliary/DataSource.hpp [code]
Auxiliary/DataSourceBinData.cpp
Auxiliary/DataSourceBinData.hpp [code]
Auxiliary/Date.cpp
Auxiliary/Date.hpp [code]
Auxiliary/DateTime.cpp
Auxiliary/DateTime.hpp [code]
Auxiliary/DbgDump.cpp
Auxiliary/DbgDump.hpp [code]
Auxiliary/DistinctProvider.cpp
Auxiliary/DistinctProvider.hpp [code]
Auxiliary/DrmAsset.cpp
Auxiliary/DrmAsset.hpp [code]
Auxiliary/DrmCore.hpp [code]
Auxiliary/DrmInfo.cpp
Auxiliary/DrmInfo.hpp [code]
Auxiliary/DynamicBitVector.hpp [code]
Auxiliary/ElementList.cpp
Auxiliary/ElementList.hpp [code]
Auxiliary/EventData.hpp [code]
Auxiliary/FifoLinkedList.hpp [code]
Auxiliary/FileBinData.hpp [code]
Auxiliary/FilterProvider.cpp
Auxiliary/FilterProvider.hpp [code]
Auxiliary/FilterRule.cpp
Auxiliary/FilterRule.hpp [code]
Auxiliary/Find2Provider.cpp
Auxiliary/Find2Provider.hpp [code]
Auxiliary/FindProvider.cpp
Auxiliary/FindProvider.hpp [code]
Auxiliary/FixedPtrArray.hpp [code]
Auxiliary/GenericObject.cpp
Auxiliary/GenericObject.hpp [code]
Auxiliary/HashTable.cpp
Auxiliary/HashTable.hpp [code]
Auxiliary/HeapDataSink.cpp
Auxiliary/HeapDataSink.hpp [code]
Auxiliary/HeapDataSource.cpp
Auxiliary/HeapDataSource.hpp [code]
Auxiliary/HeapObject.hpp [code]
Auxiliary/HostDebugTimeStamp.cpp
Auxiliary/HostDebugTimeStamp.hpp [code]
Auxiliary/HostIniFile.cpp
Auxiliary/HostIniFile.hpp [code]
Auxiliary/Iana.hpp [code]
Auxiliary/ImageObtainerDataSource.cpp
Auxiliary/ImageObtainerDataSource.hpp [code]
Auxiliary/IndexTable.hpp [code]
Auxiliary/IpAddr.cpp
Auxiliary/IpAddr.hpp [code]
Auxiliary/IpPortNo.cpp
Auxiliary/IpPortNo.hpp [code]
Auxiliary/JapaneseTranscoder.cpp
Auxiliary/JapaneseTranscoder.hpp [code]
Auxiliary/Latin.hpp [code]
Auxiliary/Lib.hpp [code]
Auxiliary/Linkable.hpp [code]
Auxiliary/LinkedList.cpp
Auxiliary/LinkedList.hpp [code]
Auxiliary/Macros.hpp [code]
Auxiliary/MainProvider.cpp
Auxiliary/MainProvider.hpp [code]
Auxiliary/Map.hpp [code]
Auxiliary/MemPool.cpp
Auxiliary/MemPool.hpp [code]
Auxiliary/MessageFactory.cpp
Auxiliary/MessageFactory.hpp [code]
Auxiliary/MimeTypeTable.cpp
Auxiliary/MimeTypeTable.hpp [code]
Auxiliary/MimeTypeTableUtils.hpp [code]
Auxiliary/NiSharedPtr.hpp [code]
Auxiliary/NonCloneable.cpp
Auxiliary/NonCloneable.hpp [code]
Auxiliary/ObjectObtainer.cpp
Auxiliary/ObjectObtainer.hpp [code]
Auxiliary/ObjectReferrer.hpp [code]
Auxiliary/ObservableObject.cpp
Auxiliary/ObservableObject.hpp [code]
Auxiliary/Observer.cpp
Auxiliary/Observer.hpp [code]
Auxiliary/PhoneNumber.cpp
Auxiliary/PhoneNumber.hpp [code]
Auxiliary/PreComp.cpp
Auxiliary/PreComp.hpp [code]
Auxiliary/Protector.cpp
Auxiliary/Protector.hpp [code]
Auxiliary/Provider.cpp
Auxiliary/Provider.hpp [code]
Auxiliary/ProviderListener.cpp
Auxiliary/ProviderListener.hpp [code]
Auxiliary/QuickSortProvider.cpp
Auxiliary/QuickSortProvider.hpp [code]
Auxiliary/RamData.cpp
Auxiliary/RamData.hpp [code]
Auxiliary/RegBlobObject.cpp
Auxiliary/RegBlobObject.hpp [code]
Auxiliary/RomData.cpp
Auxiliary/RomData.hpp [code]
Auxiliary/RomDataRes.hpp [code]
Auxiliary/SharedPtr.hpp [code]
Auxiliary/SimpleMap.hpp [code]
Auxiliary/SingleArgHook.hpp [code]
Auxiliary/SortProvider.cpp
Auxiliary/SortProvider.hpp [code]
Auxiliary/StateMachine.cpp
Auxiliary/StateMachine.hpp [code]
Auxiliary/Stream.cpp
Auxiliary/Stream.hpp [code]
Auxiliary/StreamingCallback.hpp [code]
Auxiliary/StreamingInfo.cpp
Auxiliary/StreamingInfo.hpp [code]
Auxiliary/StreamingReadInfo.cpp
Auxiliary/StreamingReadInfo.hpp [code]
Auxiliary/StreamingWriteInfo.cpp
Auxiliary/StreamingWriteInfo.hpp [code]
Auxiliary/StreamReader.cpp
Auxiliary/StreamReader.hpp [code]
Auxiliary/StreamWriter.cpp
Auxiliary/StreamWriter.hpp [code]
Auxiliary/String.cpp
Auxiliary/String.hpp [code]
Auxiliary/StringDataSink.cpp
Auxiliary/StringDataSink.hpp [code]
Auxiliary/StrPrintf.cpp
Auxiliary/StrUtil.hpp [code]
Auxiliary/SwitchedRleCompression.cpp
Auxiliary/SwitchedRleCompression.hpp [code]
Auxiliary/ThreadSafeProvider.cpp
Auxiliary/ThreadSafeProvider.hpp [code]
Auxiliary/Time.cpp
Auxiliary/Time.hpp [code]
Auxiliary/TimeSpan.cpp
Auxiliary/TimeSpan.hpp [code]
Auxiliary/TimeZone.cpp
Auxiliary/TimeZone.hpp [code]
Auxiliary/TriggerTimer.hpp [code]
Auxiliary/TypeOfAddress.cpp
Auxiliary/TypeOfAddress.hpp [code]
Auxiliary/Unicode.cpp
Auxiliary/Unicode.hpp [code]
Auxiliary/VCard.cpp
Auxiliary/VCard.hpp [code]
Auxiliary/Vector.hpp [code]
Auxiliary/WCattr.cpp
Auxiliary/WCattr.hpp [code]
Auxiliary/WCattr_tbl.hpp [code]
Auxiliary/WildcardStrncmp.cpp
Auxiliary/WildcardStrncmp.hpp [code]
Auxiliary/Wsprintf.cpp
Auxiliary/Wsscanf.cpp
Auxiliary/WString.cpp
Auxiliary/WString.hpp [code]
Auxiliary/WStrUtil.cpp
Auxiliary/WStrUtil.hpp [code]
Bluetooth/BtApplicationMessage.cpp
Bluetooth/BtApplicationMessage.hpp [code]
Bluetooth/BtAudioAccessoryService.cpp
Bluetooth/BtAudioAccessoryService.hpp [code]
Bluetooth/BtCancelableBroadcastRequest.cpp
Bluetooth/BtCancelableBroadcastRequest.hpp [code]
Bluetooth/BtCancelableMulticastRequest.cpp
Bluetooth/BtCancelableMulticastRequest.hpp [code]
Bluetooth/BtCancelableRequest.cpp
Bluetooth/BtCancelableRequest.hpp [code]
Bluetooth/BtConnectionBasedController.cpp
Bluetooth/BtConnectionBasedController.hpp [code]
Bluetooth/BtConnectionlessController.cpp
Bluetooth/BtConnectionlessController.hpp [code]
Bluetooth/BtConnectRequest.cpp
Bluetooth/BtConnectRequest.hpp [code]
Bluetooth/BtConstants.hpp [code]
Bluetooth/BtController.cpp
Bluetooth/BtController.hpp [code]
Bluetooth/BtDevice.cpp
Bluetooth/BtDevice.hpp [code]
Bluetooth/BtDeviceAddress.cpp
Bluetooth/BtDeviceAddress.hpp [code]
Bluetooth/BtDeviceAndServiceClass.cpp
Bluetooth/BtDeviceAndServiceClass.hpp [code]
Bluetooth/BtDeviceFilter.cpp
Bluetooth/BtDeviceFilter.hpp [code]
Bluetooth/BtDeviceList.cpp
Bluetooth/BtDeviceList.hpp [code]
Bluetooth/BtDeviceListIterator.cpp
Bluetooth/BtDeviceListIterator.hpp [code]
Bluetooth/BtDeviceListReverseIterator.cpp
Bluetooth/BtDeviceListReverseIterator.hpp [code]
Bluetooth/BtDevicePairRequest.cpp
Bluetooth/BtDevicePairRequest.hpp [code]
Bluetooth/BtDeviceSearchRequest.cpp
Bluetooth/BtDeviceSearchRequest.hpp [code]
Bluetooth/BtDeviceTrustRequest.cpp
Bluetooth/BtDeviceTrustRequest.hpp [code]
Bluetooth/BtDeviceUnpairRequest.cpp
Bluetooth/BtDeviceUnpairRequest.hpp [code]
Bluetooth/BtDeviceUntrustRequest.cpp
Bluetooth/BtDeviceUntrustRequest.hpp [code]
Bluetooth/BtDisconnectRequest.cpp
Bluetooth/BtDisconnectRequest.hpp [code]
Bluetooth/BtEvent.cpp
Bluetooth/BtEvent.hpp [code]
Bluetooth/BtGapAndSdapApplicationMessage.cpp
Bluetooth/BtGapAndSdapApplicationMessage.hpp [code]
Bluetooth/BtGapAndSdapController.cpp
Bluetooth/BtGapAndSdapController.hpp [code]
Bluetooth/BtGapAndSdapRequestMessage.cpp
Bluetooth/BtGapAndSdapRequestMessage.hpp [code]
Bluetooth/BtLocalRequest.cpp
Bluetooth/BtLocalRequest.hpp [code]
Bluetooth/BtLocalSettings.cpp
Bluetooth/BtLocalSettings.hpp [code]
Bluetooth/BtMultiConnectionController.cpp
Bluetooth/BtMultiConnectionController.hpp [code]
Bluetooth/BtObexResponseCode.hpp [code]
Bluetooth/BtObservableService.cpp
Bluetooth/BtObservableService.hpp [code]
Bluetooth/BtOperationBase.cpp
Bluetooth/BtOperationBase.hpp [code]
Bluetooth/BtOperationSelectDevice.cpp
Bluetooth/BtOperationSelectDevice.hpp [code]
Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.cpp
Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp [code]
Bluetooth/BtQuerySupportedProfilesRequest.cpp
Bluetooth/BtQuerySupportedProfilesRequest.hpp [code]
Bluetooth/BtRequest.cpp
Bluetooth/BtRequest.hpp [code]
Bluetooth/BtRequestMessage.cpp
Bluetooth/BtRequestMessage.hpp [code]
Bluetooth/BtRequestOperationMessage.cpp
Bluetooth/BtRequestOperationMessage.hpp [code]
Bluetooth/BtRequestRespondRequest.cpp
Bluetooth/BtRequestRespondRequest.hpp [code]
Bluetooth/BtRespondAuthorizationRequest.cpp
Bluetooth/BtRespondAuthorizationRequest.hpp [code]
Bluetooth/BtSddbDataElements.cpp
Bluetooth/BtSddbDataElements.hpp [code]
Bluetooth/BtSddbEvent.cpp
Bluetooth/BtSddbEvent.hpp [code]
Bluetooth/BtSddbRegisterServiceRecordRequest.cpp
Bluetooth/BtSddbRegisterServiceRecordRequest.hpp [code]
Bluetooth/BtSddbRequest.cpp
Bluetooth/BtSddbRequest.hpp [code]
Bluetooth/BtSddbService.cpp
Bluetooth/BtSddbService.hpp [code]
Bluetooth/BtSddbServiceAttribute.cpp
Bluetooth/BtSddbServiceAttribute.hpp [code]
Bluetooth/BtSddbServiceMessage.cpp
Bluetooth/BtSddbServiceMessage.hpp [code]
Bluetooth/BtSddbServiceObserver.cpp
Bluetooth/BtSddbServiceObserver.hpp [code]
Bluetooth/BtSddbServiceRecord.cpp
Bluetooth/BtSddbServiceRecord.hpp [code]
Bluetooth/BtSddbUnregisterServiceRecordRequest.cpp
Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp [code]
Bluetooth/BtSendPasskeyRequest.cpp
Bluetooth/BtSendPasskeyRequest.hpp [code]
Bluetooth/BtService.cpp
Bluetooth/BtService.hpp [code]
Bluetooth/BtServiceDiscoveryDatabase.cpp
Bluetooth/BtServiceDiscoveryDatabase.hpp [code]
Bluetooth/BtServiceMessage.cpp
Bluetooth/BtServiceMessage.hpp [code]
Bluetooth/BtServiceObserver.cpp
Bluetooth/BtServiceObserver.hpp [code]
Bluetooth/BtServiceRequest.cpp
Bluetooth/BtServiceRequest.hpp [code]
Bluetooth/BtServiceVerifyRequest.cpp
Bluetooth/BtServiceVerifyRequest.hpp [code]
Bluetooth/BtServiceVerifyResult.cpp
Bluetooth/BtServiceVerifyResult.hpp [code]
Bluetooth/BtSetRemoteDeviceNameRequest.cpp
Bluetooth/BtSetRemoteDeviceNameRequest.hpp [code]
Bluetooth/BtSingleConnectionController.cpp
Bluetooth/BtSingleConnectionController.hpp [code]
Bluetooth/BtSvrDataElement.cpp
Bluetooth/BtSvrDataElement.hpp [code]
Bluetooth/BtSvrServiceAttribute.cpp
Bluetooth/BtSvrServiceAttribute.hpp [code]
Bluetooth/BtSvrServiceRecord.cpp
Bluetooth/BtSvrServiceRecord.hpp [code]
Bluetooth/BtTemplates.cpp
Bluetooth/BtTransport.cpp
Bluetooth/BtTransport.hpp [code]
Bluetooth/BtTypes.hpp [code]
Bluetooth/BtUncancelablePointToPointRequest.cpp
Bluetooth/BtUncancelablePointToPointRequest.hpp [code]
Bluetooth/BtUncancelableRequest.cpp
Bluetooth/BtUncancelableRequest.hpp [code]
Bluetooth/BtUtility.cpp
Bluetooth/BtUtility.hpp [code]
Bluetooth/Lib.hpp [code]
Bluetooth/PreComp.cpp
Bluetooth/PreComp.hpp [code]
Bluetooth/AVRCP/BtAvrcpConnectRequest.cpp
Bluetooth/AVRCP/BtAvrcpConnectRequest.hpp [code]
Bluetooth/AVRCP/BtAvrcpConnectResponse.cpp
Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp [code]
Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.cpp
Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp [code]
Bluetooth/AVRCP/BtAvrcpDisconnectRequest.cpp
Bluetooth/AVRCP/BtAvrcpDisconnectRequest.hpp [code]
Bluetooth/AVRCP/BtAvrcpMessageArguments.cpp
Bluetooth/AVRCP/BtAvrcpMessageArguments.hpp [code]
Bluetooth/AVRCP/BtAvrcpNotificationMessage.cpp
Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp [code]
Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.cpp
Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp [code]
Bluetooth/AVRCP/BtAvrcpOperationController.cpp
Bluetooth/AVRCP/BtAvrcpOperationController.hpp [code]
Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.cpp
Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp [code]
Bluetooth/AVRCP/BtAvrcpOperationService.cpp
Bluetooth/AVRCP/BtAvrcpOperationService.hpp [code]
Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.cpp
Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.hpp [code]
Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.cpp
Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp [code]
Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.cpp
Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp [code]
Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.cpp
Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp [code]
Bluetooth/AVRCP/BtAvrcpRawFrameParams.cpp
Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp [code]
Bluetooth/AVRCP/BtAvrcpRawFrameRequest.cpp
Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp [code]
Bluetooth/AVRCP/BtAvrcpRegisterParams.cpp
Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp [code]
Bluetooth/AVRCP/BtAvrcpRegisterRequest.cpp
Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp [code]
Bluetooth/AVRCP/BtAvrcpRegistrationController.cpp
Bluetooth/AVRCP/BtAvrcpRegistrationController.hpp [code]
Bluetooth/AVRCP/BtAvrcpRegistrationService.cpp
Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp [code]
Bluetooth/AVRCP/BtAvrcpRequest.cpp
Bluetooth/AVRCP/BtAvrcpRequest.hpp [code]
Bluetooth/AVRCP/BtAvrcpService.cpp
Bluetooth/AVRCP/BtAvrcpService.hpp [code]
Bluetooth/AVRCP/BtAvrcpServiceMessage.cpp
Bluetooth/AVRCP/BtAvrcpServiceMessage.hpp [code]
Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.cpp
Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp [code]
Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.cpp
Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp [code]
Bluetooth/AVRCP/BtAvrcpUnitInfoParams.cpp
Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp [code]
Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.cpp
Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp [code]
Bluetooth/AVRCP/BtTypes.hpp [code]
Bluetooth/AVRCP/PreComp.cpp
Bluetooth/AVRCP/PreComp.hpp [code]
Bluetooth/BIP/BtBipAbortReq.cpp
Bluetooth/BIP/BtBipAbortReq.hpp [code]
Bluetooth/BIP/BtBipClientService.cpp
Bluetooth/BIP/BtBipClientService.hpp [code]
Bluetooth/BIP/BtBipConnectReq.cpp
Bluetooth/BIP/BtBipConnectReq.hpp [code]
Bluetooth/BIP/BtBipController.cpp
Bluetooth/BIP/BtBipController.hpp [code]
Bluetooth/BIP/BtBipDataConverter.cpp
Bluetooth/BIP/BtBipDataConverter.hpp [code]
Bluetooth/BIP/BtBipDeleteImageReq.cpp
Bluetooth/BIP/BtBipDeleteImageReq.hpp [code]
Bluetooth/BIP/BtBipDisconnectReq.cpp
Bluetooth/BIP/BtBipDisconnectReq.hpp [code]
Bluetooth/BIP/BtBipGetImagePropertiesReq.cpp
Bluetooth/BIP/BtBipGetImagePropertiesReq.hpp [code]
Bluetooth/BIP/BtBipGetImagePropertiesRsp.cpp
Bluetooth/BIP/BtBipGetImagePropertiesRsp.hpp [code]
Bluetooth/BIP/BtBipGetImageReq.cpp
Bluetooth/BIP/BtBipGetImageReq.hpp [code]
Bluetooth/BIP/BtBipGetImageRsp.cpp
Bluetooth/BIP/BtBipGetImageRsp.hpp [code]
Bluetooth/BIP/BtBipGetImagesListReq.cpp
Bluetooth/BIP/BtBipGetImagesListReq.hpp [code]
Bluetooth/BIP/BtBipGetImagesListRsp.cpp
Bluetooth/BIP/BtBipGetImagesListRsp.hpp [code]
Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.cpp
Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.hpp [code]
Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.cpp
Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.hpp [code]
Bluetooth/BIP/BtBipGetLinkedAttachmentReq.cpp
Bluetooth/BIP/BtBipGetLinkedAttachmentReq.hpp [code]
Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.cpp
Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.hpp [code]
Bluetooth/BIP/BtBipGetLinkedThumbnailReq.cpp
Bluetooth/BIP/BtBipGetLinkedThumbnailReq.hpp [code]
Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.cpp
Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.hpp [code]
Bluetooth/BIP/BtBipGetReq.cpp
Bluetooth/BIP/BtBipGetReq.hpp [code]
Bluetooth/BIP/BtBipGetRsp.cpp
Bluetooth/BIP/BtBipGetRsp.hpp [code]
Bluetooth/BIP/BtBipMecelXmlConverter.cpp
Bluetooth/BIP/BtBipMecelXmlConverter.hpp [code]
Bluetooth/BIP/BtBipMsgArg.cpp
Bluetooth/BIP/BtBipMsgArg.hpp [code]
Bluetooth/BIP/BtBipNotificationMsg.cpp
Bluetooth/BIP/BtBipNotificationMsg.hpp [code]
Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Bluetooth/BIP/BtBipNotificationMsgArg.hpp [code]
Bluetooth/BIP/BtBipPutAttachReq.cpp
Bluetooth/BIP/BtBipPutAttachReq.hpp [code]
Bluetooth/BIP/BtBipPutAttachRsp.cpp
Bluetooth/BIP/BtBipPutAttachRsp.hpp [code]
Bluetooth/BIP/BtBipPutImageReq.cpp
Bluetooth/BIP/BtBipPutImageReq.hpp [code]
Bluetooth/BIP/BtBipPutImageRsp.cpp
Bluetooth/BIP/BtBipPutImageRsp.hpp [code]
Bluetooth/BIP/BtBipPutReq.cpp
Bluetooth/BIP/BtBipPutReq.hpp [code]
Bluetooth/BIP/BtBipPutRsp.cpp
Bluetooth/BIP/BtBipPutRsp.hpp [code]
Bluetooth/BIP/BtBipPutThumbReq.cpp
Bluetooth/BIP/BtBipPutThumbReq.hpp [code]
Bluetooth/BIP/BtBipPutThumbRsp.cpp
Bluetooth/BIP/BtBipPutThumbRsp.hpp [code]
Bluetooth/BIP/BtBipReq.cpp
Bluetooth/BIP/BtBipReq.hpp [code]
Bluetooth/BIP/BtBipServerService.cpp
Bluetooth/BIP/BtBipServerService.hpp [code]
Bluetooth/BIP/BtBipService.cpp
Bluetooth/BIP/BtBipService.hpp [code]
Bluetooth/BIP/BtBipServiceMsg.cpp
Bluetooth/BIP/BtBipServiceMsg.hpp [code]
Bluetooth/BIP/BtBipTypes.cpp
Bluetooth/BIP/BtBipTypes.hpp [code]
Bluetooth/BIP/PreComp.cpp
Bluetooth/BIP/PreComp.hpp [code]
Bluetooth/BPP/BtBppClientService.cpp
Bluetooth/BPP/BtBppClientService.hpp [code]
Bluetooth/BPP/BtBppController.cpp
Bluetooth/BPP/BtBppController.hpp [code]
Bluetooth/BPP/BtBppReq.cpp
Bluetooth/BPP/BtBppReq.hpp [code]
Bluetooth/BPP/BtBppServerService.hpp [code]
Bluetooth/BPP/BtBppService.cpp
Bluetooth/BPP/BtBppService.hpp [code]
Bluetooth/BPP/BtBppServiceMessage.cpp
Bluetooth/BPP/BtBppServiceMessage.hpp [code]
Bluetooth/BPP/BtBppSndAbortReqRequest.cpp
Bluetooth/BPP/BtBppSndAbortReqRequest.hpp [code]
Bluetooth/BPP/BtBppSndFilePushReqRequest.cpp
Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp [code]
Bluetooth/BPP/BtBppSndGetRefObjRspRequest.cpp
Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp [code]
Bluetooth/BPP/BtBppTestData.hpp [code]
Bluetooth/BPP/BtBppTypes.hpp [code]
Bluetooth/BPP/PreComp.cpp
Bluetooth/BPP/PreComp.hpp [code]
Bluetooth/DUN/BtDunApplicationMessage.cpp
Bluetooth/DUN/BtDunApplicationMessage.hpp [code]
Bluetooth/DUN/BtDunController.cpp
Bluetooth/DUN/BtDunController.hpp [code]
Bluetooth/DUN/BtDunDisconnectRequest.cpp
Bluetooth/DUN/BtDunDisconnectRequest.hpp [code]
Bluetooth/DUN/BtDunService.cpp
Bluetooth/DUN/BtDunService.hpp [code]
Bluetooth/DUN/BtDunServiceMessage.cpp
Bluetooth/DUN/BtDunServiceMessage.hpp [code]
Bluetooth/DUN/Lib.hpp [code]
Bluetooth/DUN/PreComp.cpp
Bluetooth/DUN/PreComp.hpp [code]
Bluetooth/FAX/BtFaxApplicationMessage.cpp
Bluetooth/FAX/BtFaxApplicationMessage.hpp [code]
Bluetooth/FAX/BtFaxController.cpp
Bluetooth/FAX/BtFaxController.hpp [code]
Bluetooth/FAX/BtFaxDisconnectRequest.cpp
Bluetooth/FAX/BtFaxDisconnectRequest.hpp [code]
Bluetooth/FAX/BtFaxService.cpp
Bluetooth/FAX/BtFaxService.hpp [code]
Bluetooth/FAX/BtFaxServiceMessage.cpp
Bluetooth/FAX/BtFaxServiceMessage.hpp [code]
Bluetooth/FAX/Lib.hpp [code]
Bluetooth/FAX/PreComp.cpp
Bluetooth/FAX/PreComp.hpp [code]
Bluetooth/HF/BtHfConnectRequest.cpp
Bluetooth/HF/BtHfConnectRequest.hpp [code]
Bluetooth/HF/BtHfController.cpp
Bluetooth/HF/BtHfController.hpp [code]
Bluetooth/HF/BtHfControllerMessage.cpp
Bluetooth/HF/BtHfControllerMessage.hpp [code]
Bluetooth/HF/BtHfControllerMessageArgument.cpp
Bluetooth/HF/BtHfControllerMessageArgument.hpp [code]
Bluetooth/HF/BtHfDisconnectRequest.cpp
Bluetooth/HF/BtHfDisconnectRequest.hpp [code]
Bluetooth/HF/BtHfMessageArguments.cpp
Bluetooth/HF/BtHfMessageArguments.hpp [code]
Bluetooth/HF/BtHfNotificationMessage.cpp
Bluetooth/HF/BtHfNotificationMessage.hpp [code]
Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Bluetooth/HF/BtHfNotificationMessageArgument.hpp [code]
Bluetooth/HF/BtHfRequest.cpp
Bluetooth/HF/BtHfRequest.hpp [code]
Bluetooth/HF/BtHfService.cpp
Bluetooth/HF/BtHfService.hpp [code]
Bluetooth/HF/BtHfServiceMessage.cpp
Bluetooth/HF/BtHfServiceMessage.hpp [code]
Bluetooth/HF/BtHfSetMicrophoneGainRequest.cpp
Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp [code]
Bluetooth/HF/BtHfSetSpeakerGainRequest.cpp
Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp [code]
Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.cpp
Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp [code]
Bluetooth/HF/BtHfTransferAudioToPhoneRequest.cpp
Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp [code]
Bluetooth/HF/BtTypes.hpp [code]
Bluetooth/HF/Lib.hpp [code]
Bluetooth/HF/PreComp.cpp
Bluetooth/HF/PreComp.hpp [code]
Bluetooth/HS/BtHsConnectRequest.cpp
Bluetooth/HS/BtHsConnectRequest.hpp [code]
Bluetooth/HS/BtHsController.cpp
Bluetooth/HS/BtHsController.hpp [code]
Bluetooth/HS/BtHsControllerMessage.cpp
Bluetooth/HS/BtHsControllerMessage.hpp [code]
Bluetooth/HS/BtHsControllerMessageArgument.cpp
Bluetooth/HS/BtHsControllerMessageArgument.hpp [code]
Bluetooth/HS/BtHsDisconnectRequest.cpp
Bluetooth/HS/BtHsDisconnectRequest.hpp [code]
Bluetooth/HS/BtHsMessageArguments.cpp
Bluetooth/HS/BtHsMessageArguments.hpp [code]
Bluetooth/HS/BtHsNotificationMessage.cpp
Bluetooth/HS/BtHsNotificationMessage.hpp [code]
Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Bluetooth/HS/BtHsNotificationMessageArgument.hpp [code]
Bluetooth/HS/BtHsRequest.cpp
Bluetooth/HS/BtHsRequest.hpp [code]
Bluetooth/HS/BtHsRingRequest.cpp
Bluetooth/HS/BtHsRingRequest.hpp [code]
Bluetooth/HS/BtHsService.cpp
Bluetooth/HS/BtHsService.hpp [code]
Bluetooth/HS/BtHsServiceMessage.cpp
Bluetooth/HS/BtHsServiceMessage.hpp [code]
Bluetooth/HS/BtHsSetMicrophoneGainRequest.cpp
Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp [code]
Bluetooth/HS/BtHsSetSpeakerGainRequest.cpp
Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp [code]
Bluetooth/HS/BtHsStopRingRequest.cpp
Bluetooth/HS/BtHsStopRingRequest.hpp [code]
Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.cpp
Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp [code]
Bluetooth/HS/BtHsTransferAudioToPhoneRequest.cpp
Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp [code]
Bluetooth/HS/BtTypes.hpp [code]
Bluetooth/HS/Lib.hpp [code]
Bluetooth/HS/PreComp.cpp
Bluetooth/HS/PreComp.hpp [code]
Bluetooth/JSR82/BtJsr82Url.cpp
Bluetooth/JSR82/BtJsr82Url.hpp [code]
Bluetooth/JSR82/PreComp.cpp
Bluetooth/JSR82/PreComp.hpp [code]
Bluetooth/OBEX/BtObexAbortRequest.cpp
Bluetooth/OBEX/BtObexAbortRequest.hpp [code]
Bluetooth/OBEX/BtObexClientOperationRequest.cpp
Bluetooth/OBEX/BtObexClientOperationRequest.hpp [code]
Bluetooth/OBEX/BtObexClientService.cpp
Bluetooth/OBEX/BtObexClientService.hpp [code]
Bluetooth/OBEX/BtObexClientServiceObserver.cpp
Bluetooth/OBEX/BtObexClientServiceObserver.hpp [code]
Bluetooth/OBEX/BtObexConnectRequest.cpp
Bluetooth/OBEX/BtObexConnectRequest.hpp [code]
Bluetooth/OBEX/BtObexController.cpp
Bluetooth/OBEX/BtObexController.hpp [code]
Bluetooth/OBEX/BtObexDisconnectRequest.cpp
Bluetooth/OBEX/BtObexDisconnectRequest.hpp [code]
Bluetooth/OBEX/BtObexEvent.cpp
Bluetooth/OBEX/BtObexEvent.hpp [code]
Bluetooth/OBEX/BtObexGetRequest.cpp
Bluetooth/OBEX/BtObexGetRequest.hpp [code]
Bluetooth/OBEX/BtObexMessageArguments.cpp
Bluetooth/OBEX/BtObexMessageArguments.hpp [code]
Bluetooth/OBEX/BtObexNotificationMessage.cpp
Bluetooth/OBEX/BtObexNotificationMessage.hpp [code]
Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp [code]
Bluetooth/OBEX/BtObexPutRequest.cpp
Bluetooth/OBEX/BtObexPutRequest.hpp [code]
Bluetooth/OBEX/BtObexRegisterClientRequest.cpp
Bluetooth/OBEX/BtObexRegisterClientRequest.hpp [code]
Bluetooth/OBEX/BtObexRegisterServerRequest.cpp
Bluetooth/OBEX/BtObexRegisterServerRequest.hpp [code]
Bluetooth/OBEX/BtObexRequest.cpp
Bluetooth/OBEX/BtObexRequest.hpp [code]
Bluetooth/OBEX/BtObexServerService.cpp
Bluetooth/OBEX/BtObexServerService.hpp [code]
Bluetooth/OBEX/BtObexServerServiceObserver.cpp
Bluetooth/OBEX/BtObexServerServiceObserver.hpp [code]
Bluetooth/OBEX/BtObexService.cpp
Bluetooth/OBEX/BtObexService.hpp [code]
Bluetooth/OBEX/BtObexServiceMessage.cpp
Bluetooth/OBEX/BtObexServiceMessage.hpp [code]
Bluetooth/OBEX/BtObexServiceObserver.cpp
Bluetooth/OBEX/BtObexServiceObserver.hpp [code]
Bluetooth/OBEX/BtObexSetPathRequest.cpp
Bluetooth/OBEX/BtObexSetPathRequest.hpp [code]
Bluetooth/OBEX/BtObexUnregisterClientRequest.cpp
Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp [code]
Bluetooth/OBEX/BtObexUnregisterServerRequest.cpp
Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp [code]
Bluetooth/OBEX/BtTypes.hpp [code]
Bluetooth/OBEX/Lib.hpp [code]
Bluetooth/OBEX/PreComp.cpp
Bluetooth/OBEX/PreComp.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.cpp
Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.cpp
Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.cpp
Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexImpl.cpp
Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexImplAddress.cpp
Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.cpp
Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.cpp
Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.cpp
Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.cpp
Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexServiceTable.cpp
Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexTransport.cpp
Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp [code]
Bluetooth/OBEX/ObexTransport/BtObexTransportTemplates.cpp
Bluetooth/OBEX/ObexTransport/PreComp.cpp
Bluetooth/OBEX/ObexTransport/PreComp.hpp [code]
Compat/AbstractEditBox.cpp
Compat/AbstractEditBox.hpp [code]
Compat/AbstractIMelodyParser.cpp
Compat/AbstractIMelodyParser.hpp [code]
Compat/AbstractListBox.cpp
Compat/AbstractListBox.hpp [code]
Compat/AbstractMenuAccessor.cpp
Compat/AbstractMenuAccessor.hpp [code]
Compat/AbstractMenuList.cpp
Compat/AbstractMenuList.hpp [code]
Compat/ActionExtension.cpp
Compat/ActionExtension.hpp [code]
Compat/Animation.cpp
Compat/Animation.hpp [code]
Compat/AtlItemGrid.cpp
Compat/AtlItemGrid.hpp [code]
Compat/AtlItemMenu.cpp
Compat/AtlItemMenu.hpp [code]
Compat/AtlItemRenderer.cpp
Compat/AtlItemRenderer.hpp [code]
Compat/AudioContext.cpp
Compat/AudioContext.hpp [code]
Compat/BattHandler.cpp
Compat/BattHandler.hpp [code]
Compat/BufferedOutputStream.cpp
Compat/BufferedOutputStream.hpp [code]
Compat/CancelAction.cpp
Compat/CancelAction.hpp [code]
Compat/CheckBox.cpp
Compat/CheckBox.hpp [code]
Compat/CheckBoxItem.hpp [code]
Compat/CheckBoxList.cpp
Compat/CheckBoxList.hpp [code]
Compat/ChrHandler.cpp
Compat/ChrHandler.hpp [code]
Compat/CompatInfo.cpp
Compat/CompatTemplates.cpp
Compat/ConfirmAction.cpp
Compat/ConfirmAction.hpp [code]
Compat/DateEditBox.cpp
Compat/DateEditBox.hpp [code]
Compat/DebugOutputStream.cpp
Compat/DebugOutputStream.hpp [code]
Compat/DialogWindow.cpp
Compat/DialogWindow.hpp [code]
Compat/EditBox.cpp
Compat/EditBox.hpp [code]
Compat/FfsFile.cpp
Compat/FfsFile.hpp [code]
Compat/FileInputStream.cpp
Compat/FileInputStream.hpp [code]
Compat/FileOutputStream.cpp
Compat/FileOutputStream.hpp [code]
Compat/Grid.cpp
Compat/Grid.hpp [code]
Compat/IMelody.cpp
Compat/IMelody.hpp [code]
Compat/Indicator.cpp
Compat/Indicator.hpp [code]
Compat/IndicatorBar.cpp
Compat/IndicatorBar.hpp [code]
Compat/IndicatorBarID.hpp [code]
Compat/IndicatorDescription.cpp
Compat/IndicatorDescription.hpp [code]
Compat/IndicatorID.hpp [code]
Compat/IndicatorPaneObject.cpp
Compat/IndicatorPaneObject.hpp [code]
Compat/InputStream.cpp
Compat/InputStream.hpp [code]
Compat/Lib.hpp [code]
Compat/Melody.cpp
Compat/Melody.hpp [code]
Compat/Menu.cpp
Compat/Menu.hpp [code]
Compat/MenuAccessor.cpp
Compat/MenuAccessor.hpp [code]
Compat/MenuItem.cpp
Compat/MenuItem.hpp [code]
Compat/MenuList.cpp
Compat/MenuList.hpp [code]
Compat/MenuTextIterator.hpp [code]
Compat/MenuTextPtrArrayIterator.cpp
Compat/MenuTextPtrArrayIterator.hpp [code]
Compat/MenuWindow.cpp
Compat/MenuWindow.hpp [code]
Compat/MidiSound.cpp
Compat/MidiSound.hpp [code]
Compat/NvRam.cpp
Compat/NvRam.hpp [code]
Compat/NvRamDataRecordHandler.cpp
Compat/NvRamDataRecordHandler.hpp [code]
Compat/NvRamStorage.cpp
Compat/NvRamStorage.hpp [code]
Compat/OutputStream.cpp
Compat/OutputStream.hpp [code]
Compat/PreComp.cpp
Compat/PreComp.hpp [code]
Compat/PreparedSound.cpp
Compat/PreparedSound.hpp [code]
Compat/ProviderListBox.cpp
Compat/ProviderListBox.hpp [code]
Compat/RadioButton.cpp
Compat/RadioButton.hpp [code]
Compat/RadioButtonItem.hpp [code]
Compat/RadioButtonList.cpp
Compat/RadioButtonList.hpp [code]
Compat/ResourceManager.cpp
Compat/ResourceManager.hpp [code]
Compat/RtcHandler.cpp
Compat/RtcHandler.hpp [code]
Compat/SetLanguageAction.cpp
Compat/SetLanguageAction.hpp [code]
Compat/SetThemeAction.cpp
Compat/SetThemeAction.hpp [code]
Compat/SharedTimer.cpp
Compat/SharedTimer.hpp [code]
Compat/SmafSound.cpp
Compat/SmafSound.hpp [code]
Compat/SoftkeyBar.cpp
Compat/SoftkeyBar.hpp [code]
Compat/Sound.cpp
Compat/Sound.hpp [code]
Compat/SoundItem.cpp
Compat/SoundItem.hpp [code]
Compat/SsDispatcher.cpp
Compat/SsDispatcher.hpp [code]
Compat/SsHandler.cpp
Compat/SsHandler.hpp [code]
Compat/SsWaitDispatcher.cpp
Compat/SsWaitDispatcher.hpp [code]
Compat/TextList.cpp
Compat/TextList.hpp [code]
Compat/TextMenuAccessor.cpp
Compat/TextMenuAccessor.hpp [code]
Compat/TimeEditBox.cpp
Compat/TimeEditBox.hpp [code]
Compat/TraceOutputStream.cpp
Compat/TraceOutputStream.hpp [code]
Compat/WinMenuItem.cpp
Compat/WinMenuItem.hpp [code]
Compat/WinRect.cpp
Compat/WinRect.hpp [code]
Compat/Devices/BP30/Audio.cpp
Compat/Devices/BP30/Audio.hpp [code]
Compat/Devices/BP30/PreComp.cpp
Compat/Devices/BP30/PreComp.hpp [code]
Compat/Devices/MPE/Audio.cpp
Compat/Devices/MPE/Audio.hpp [code]
Compat/Devices/MPE/PreComp.cpp
Compat/Devices/MPE/PreComp.hpp [code]
Compat/Devices/MPEU/Audio.cpp
Compat/Devices/MPEU/Audio.hpp [code]
Compat/Devices/MPEU/PreComp.cpp
Compat/Devices/MPEU/PreComp.hpp [code]
Compat/Devices/SGold/Audio.cpp
Compat/Devices/SGold/Audio.hpp [code]
Compat/Devices/SGold/PreComp.cpp
Compat/Devices/SGold/PreComp.hpp [code]
Compat/Devices/Win32/Audio.cpp
Compat/Devices/Win32/Audio.hpp [code]
Compat/Devices/Win32/PreComp.cpp
Compat/Devices/Win32/PreComp.hpp [code]
Compat/GlobalThemes/PreComp.cpp
Compat/GlobalThemes/PreComp.hpp [code]
Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.cpp
Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.hpp [code]
Compat/GlobalThemes/BlackAndWhiteTheme/PreComp.cpp
Compat/GlobalThemes/BlackAndWhiteTheme/PreComp.hpp [code]
Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.cpp
Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.hpp [code]
Compat/GlobalThemes/BlueSkyChineseTheme/PreComp.cpp
Compat/GlobalThemes/BlueSkyChineseTheme/PreComp.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.cpp
Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp [code]
Compat/GlobalThemes/BlueSkyTheme/PreComp.cpp
Compat/GlobalThemes/BlueSkyTheme/PreComp.hpp [code]
Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.cpp
Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.hpp [code]
Compat/GlobalThemes/DefaultChineseTheme/PreComp.cpp
Compat/GlobalThemes/DefaultChineseTheme/PreComp.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultTextListView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultTextListView.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultTheme.cpp
Compat/GlobalThemes/DefaultTheme/DefaultTheme.hpp [code]
Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.cpp
Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp [code]
Compat/GlobalThemes/DefaultTheme/PreComp.cpp
Compat/GlobalThemes/DefaultTheme/PreComp.hpp [code]
Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.cpp
Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp [code]
Compat/GlobalThemes/FoggyTheme/FoggyTheme.cpp
Compat/GlobalThemes/FoggyTheme/FoggyTheme.hpp [code]
Compat/GlobalThemes/FoggyTheme/PreComp.cpp
Compat/GlobalThemes/FoggyTheme/PreComp.hpp [code]
Compat/GlobalThemes/TestTheme/PreComp.cpp
Compat/GlobalThemes/TestTheme/PreComp.hpp [code]
Compat/GlobalThemes/TestTheme/TestCheckBoxListView.cpp
Compat/GlobalThemes/TestTheme/TestCheckBoxListView.hpp [code]
Compat/GlobalThemes/TestTheme/TestCheckBoxView.cpp
Compat/GlobalThemes/TestTheme/TestCheckBoxView.hpp [code]
Compat/GlobalThemes/TestTheme/TestControlFrameView.cpp
Compat/GlobalThemes/TestTheme/TestControlFrameView.hpp [code]
Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.cpp
Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.hpp [code]
Compat/GlobalThemes/TestTheme/TestPushButtonView.cpp
Compat/GlobalThemes/TestTheme/TestPushButtonView.hpp [code]
Compat/GlobalThemes/TestTheme/TestRadioButtonListView.cpp
Compat/GlobalThemes/TestTheme/TestRadioButtonListView.hpp [code]
Compat/GlobalThemes/TestTheme/TestRadioButtonView.cpp
Compat/GlobalThemes/TestTheme/TestRadioButtonView.hpp [code]
Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.cpp
Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.hpp [code]
Compat/GlobalThemes/TestTheme/TestTheme.cpp
Compat/GlobalThemes/TestTheme/TestTheme.hpp [code]
Compat/GlobalThemes/TestTheme/TestWindowFrameView.cpp
Compat/GlobalThemes/TestTheme/TestWindowFrameView.hpp [code]
Devices/AbstractDevice.cpp
Devices/AbstractDevice.hpp [code]
Devices/AbstractLockableDevice.cpp
Devices/AbstractLockableDevice.hpp [code]
Devices/AbstractTransport.cpp
Devices/AbstractTransport.hpp [code]
Devices/AudioAccessoryDetails.hpp [code]
Devices/AudioAccessoryStore.hpp [code]
Devices/AudioActiveReference.hpp [code]
Devices/AudioDef.hpp [code]
Devices/AudioDeviceBase.hpp [code]
Devices/AudioDeviceManager.hpp [code]
Devices/AudioDwdIdManager.hpp [code]
Devices/AudioError.hpp [code]
Devices/AudioMsgProcessor.hpp [code]
Devices/AudioPath.hpp [code]
Devices/AudioPathManager.hpp [code]
Devices/AudioPlayer.hpp [code]
Devices/AudioPreset.hpp [code]
Devices/AudioPresetStore.hpp [code]
Devices/AudioPriorityManager.hpp [code]
Devices/AudioReference.hpp [code]
Devices/AudioSignalMapTableNode.hpp [code]
Devices/AudioSuspendedDetails.hpp [code]
Devices/AudioUtility.hpp [code]
Devices/AudioVibratorDevice.hpp [code]
Devices/Camera.hpp [code]
Devices/CameraInterface.hpp [code]
Devices/Charger.hpp [code]
Devices/ChargerInterface.hpp [code]
Devices/ChargerMsgTypes.cpp
Devices/ChargerMsgTypes.hpp [code]
Devices/ChargerSignalMapTableNode.cpp
Devices/ChargerSignalMapTableNode.hpp [code]
Devices/ChargerSignalProcessor.cpp
Devices/ChargerSignalProcessor.hpp [code]
Devices/CustomIMelodyAudioReference.hpp [code]
Devices/CustomRingerAudioReference.hpp [code]
Devices/CustomSmafPhraseAudioReference.hpp [code]
Devices/CustomToneAudioReference.hpp [code]
Devices/DefaultDisplay.hpp [code]
Devices/Device.hpp [code]
Devices/DeviceManager.cpp
Devices/DeviceManager.hpp [code]
Devices/DevicesPreComp.cpp
Devices/DevicesPreComp.hpp [code]
Devices/DevicesTemplates.cpp
Devices/Display.cpp
Devices/Display.hpp [code]
Devices/DisplayMsgTypes.cpp
Devices/DisplayMsgTypes.hpp [code]
Devices/Fota.hpp [code]
Devices/FotaInterface.hpp [code]
Devices/Keyboard.hpp [code]
Devices/KeyboardInterface.hpp [code]
Devices/Led.hpp [code]
Devices/LedInterface.hpp [code]
Devices/LedMsgTypes.cpp
Devices/LedMsgTypes.hpp [code]
Devices/LedSignalMapTableNode.cpp
Devices/LedSignalMapTableNode.hpp [code]
Devices/LedSignalProcessor.cpp
Devices/LedSignalProcessor.hpp [code]
Devices/MP3AudioPlayer.hpp [code]
Devices/MP3AudioReference.hpp [code]
Devices/PCMAudioPlayer.hpp [code]
Devices/PCMAudioReference.hpp [code]
Devices/PresetAudioReference.hpp [code]
Devices/RadioAudioDevice.hpp [code]
Devices/RealTimeClock.hpp [code]
Devices/RealTimeClockInterface.hpp [code]
Devices/RingerAudioInternalMidiPlayer.hpp [code]
Devices/RingerAudioPlayer.hpp [code]
Devices/RingerAudioReference.hpp [code]
Devices/RtcMsgTypes.cpp
Devices/RtcMsgTypes.hpp [code]
Devices/RtcSignalMapTableNode.cpp
Devices/RtcSignalMapTableNode.hpp [code]
Devices/RtcSignalProcessor.cpp
Devices/RtcSignalProcessor.hpp [code]
Devices/ShutDown.cpp
Devices/ShutDown.hpp [code]
Devices/SimpleAudioDevice.hpp [code]
Devices/SimpleAudioReference.hpp [code]
Devices/SpeechSimpleAudioDevice.hpp [code]
Devices/StartUp.cpp
Devices/StartUp.hpp [code]
Devices/StillCamera.hpp [code]
Devices/StillCameraInterface.hpp [code]
Devices/StreamAudioPlayer.hpp [code]
Devices/StreamAudioReference.hpp [code]
Devices/ToneAudioPlayer.hpp [code]
Devices/ToneAudioReference.hpp [code]
Devices/VibratorDevice.cpp
Devices/VibratorDevice.hpp [code]
Devices/VideoCamera.hpp [code]
Devices/VideoCameraInterface.hpp [code]
Devices/VirtualDisplay.hpp [code]
Devices/VoiceMemoAudioPlayer.hpp [code]
Devices/VoiceMemoAudioReference.hpp [code]
Devices/BP30/Audio.hpp [code]
Devices/BP30/BitBlit_16Bpp.cpp
Devices/BP30/Camera.cpp
Devices/BP30/Camera.hpp [code]
Devices/BP30/Charger.cpp
Devices/BP30/Charger.hpp [code]
Devices/BP30/DefaultDisplay.cpp
Devices/BP30/DefaultDisplay.hpp [code]
Devices/BP30/DrawChar_16Bpp.cpp
Devices/BP30/FillRect_16Bpp.cpp
Devices/BP30/Fota.cpp
Devices/BP30/Fota.hpp [code]
Devices/BP30/Keyboard.cpp
Devices/BP30/Keyboard.hpp [code]
Devices/BP30/Led.cpp
Devices/BP30/Led.hpp [code]
Devices/BP30/PreComp.cpp
Devices/BP30/PreComp.hpp [code]
Devices/BP30/RealTimeClock.cpp
Devices/BP30/RealTimeClock.hpp [code]
Devices/BP30/ScrollHorizontal_16Bpp.cpp
Devices/BP30/ScrollVertical_16Bpp.cpp
Devices/BP30/StillCamera.cpp
Devices/BP30/StillCamera.hpp [code]
Devices/BP30/VideoCamera.cpp
Devices/BP30/VideoCamera.hpp [code]
Devices/BP30/VideoChannel.cpp
Devices/BP30/VideoChannel.hpp [code]
Devices/BP30/VirtualDisplay.cpp
Devices/BP30/VirtualDisplay.hpp [code]
Devices/Messages/AudioDeviceStatusMsg.hpp [code]
Devices/Messages/AudioErrorMsg.hpp [code]
Devices/Messages/AudioMsg.hpp [code]
Devices/Messages/AudioPlayTimeMsg.hpp [code]
Devices/Messages/AudioRadioDeviceNotificationMsg.hpp [code]
Devices/Messages/AudioRestartedMsg.hpp [code]
Devices/Messages/AudioResumedMsg.hpp [code]
Devices/Messages/AudioStartedMsg.hpp [code]
Devices/Messages/AudioStoppedMsg.hpp [code]
Devices/Messages/AudioStreamingSyncMsg.hpp [code]
Devices/Messages/AudioSuspendedMsg.hpp [code]
Devices/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp [code]
Devices/Messages/TransportNotificationMsg.cpp
Devices/Messages/TransportNotificationMsg.hpp [code]
Devices/MPE/Audio.hpp [code]
Devices/MPE/BackLight.cpp
Devices/MPE/BackLight.hpp [code]
Devices/MPE/Camera.cpp
Devices/MPE/Camera.hpp [code]
Devices/MPE/Charger.cpp
Devices/MPE/Charger.hpp [code]
Devices/MPE/DefaultDisplay.cpp
Devices/MPE/DefaultDisplay.hpp [code]
Devices/MPE/Fota.cpp
Devices/MPE/Fota.hpp [code]
Devices/MPE/Keyboard.cpp
Devices/MPE/Keyboard.hpp [code]
Devices/MPE/Led.cpp
Devices/MPE/Led.hpp [code]
Devices/MPE/PreComp.cpp
Devices/MPE/PreComp.hpp [code]
Devices/MPE/RealTimeClock.cpp
Devices/MPE/RealTimeClock.hpp [code]
Devices/MPE/StillCamera.cpp
Devices/MPE/StillCamera.hpp [code]
Devices/MPE/VideoCamera.cpp
Devices/MPE/VideoCamera.hpp [code]
Devices/MPE/VideoChannel.cpp
Devices/MPE/VideoChannel.hpp [code]
Devices/MPE/VirtualDisplay.cpp
Devices/MPE/VirtualDisplay.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.cpp
Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.cpp
Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.cpp
Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzCodecsPreComp.cpp
Devices/MPE/Extensions/EmzCodecs/EmzCodecsPreComp.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.cpp
Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.cpp
Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.cpp
Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.cpp
Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.cpp
Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.cpp
Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.cpp
Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.cpp
Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.cpp
Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.cpp
Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.hpp [code]
Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp [code]
Devices/MPEU/Audio.hpp [code]
Devices/MPEU/BackLight.cpp
Devices/MPEU/BackLight.hpp [code]
Devices/MPEU/Camera.cpp
Devices/MPEU/Camera.hpp [code]
Devices/MPEU/Charger.cpp
Devices/MPEU/Charger.hpp [code]
Devices/MPEU/DefaultDisplay.cpp
Devices/MPEU/DefaultDisplay.hpp [code]
Devices/MPEU/Fota.cpp
Devices/MPEU/Fota.hpp [code]
Devices/MPEU/Keyboard.cpp
Devices/MPEU/Keyboard.hpp [code]
Devices/MPEU/Led.cpp
Devices/MPEU/Led.hpp [code]
Devices/MPEU/PreComp.cpp
Devices/MPEU/PreComp.hpp [code]
Devices/MPEU/RealTimeClock.cpp
Devices/MPEU/RealTimeClock.hpp [code]
Devices/MPEU/StillCamera.cpp
Devices/MPEU/StillCamera.hpp [code]
Devices/MPEU/VideoCamera.cpp
Devices/MPEU/VideoCamera.hpp [code]
Devices/MPEU/VideoChannel.cpp
Devices/MPEU/VideoChannel.hpp [code]
Devices/MPEU/VirtualDisplay.cpp
Devices/MPEU/VirtualDisplay.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.cpp
Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.cpp
Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.cpp
Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.cpp
Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.cpp
Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.cpp
Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiConfig.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.cpp
Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.cpp
Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.hpp [code]
Devices/MPEU/Extensions/AtiW2282/AtiUtils.cpp
Devices/MPEU/Extensions/AtiW2282/AtiUtils.hpp [code]
Devices/MPEU/Extensions/AtiW2282/Camera.cpp
Devices/MPEU/Extensions/AtiW2282/Camera.hpp [code]
Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.cpp
Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.hpp [code]
Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.cpp
Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.hpp [code]
Devices/MPEU/Extensions/AtiW2282/StillCamera.cpp
Devices/MPEU/Extensions/AtiW2282/StillCamera.hpp [code]
Devices/MPEU/Extensions/AtiW2282/VideoCamera.cpp
Devices/MPEU/Extensions/AtiW2282/VideoCamera.hpp [code]
Devices/MPEU/Extensions/AtiW2282/VideoChannel.cpp
Devices/MPEU/Extensions/AtiW2282/VideoChannel.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzCodecsPreComp.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzCodecsPreComp.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.cpp
Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp [code]
Devices/MPEU/Extensions/EmzCodecs/EmzUtils.hpp [code]
Devices/SGold/Audio.hpp [code]
Devices/SGold/BackLight.cpp
Devices/SGold/BackLight.hpp [code]
Devices/SGold/Camera.cpp
Devices/SGold/Camera.hpp [code]
Devices/SGold/Charger.cpp
Devices/SGold/Charger.hpp [code]
Devices/SGold/DefaultDisplay.cpp
Devices/SGold/DefaultDisplay.hpp [code]
Devices/SGold/Fota.cpp
Devices/SGold/Fota.hpp [code]
Devices/SGold/Keyboard.cpp
Devices/SGold/Keyboard.hpp [code]
Devices/SGold/Led.cpp
Devices/SGold/Led.hpp [code]
Devices/SGold/PreComp.cpp
Devices/SGold/PreComp.hpp [code]
Devices/SGold/RealTimeClock.cpp
Devices/SGold/RealTimeClock.hpp [code]
Devices/SGold/StillCamera.cpp
Devices/SGold/StillCamera.hpp [code]
Devices/SGold/VideoCamera.cpp
Devices/SGold/VideoCamera.hpp [code]
Devices/SGold/VideoChannel.cpp
Devices/SGold/VideoChannel.hpp [code]
Devices/SGold/VirtualDisplay.cpp
Devices/SGold/VirtualDisplay.hpp [code]
Devices/SGold/Companion/Epson716/Camera.cpp
Devices/SGold/Companion/Epson716/VideoCamera.cpp
Devices/SGold/Companion/Scicos3020/Camera.cpp
Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.cpp
Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.hpp [code]
Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.cpp
Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.hpp [code]
Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.cpp
Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.hpp [code]
Devices/SGold/Companion/Scicos3020/VideoCamera.cpp
Devices/SharedMethods/BitBlit_16Bpp.cpp
Devices/SharedMethods/BitBlit_24Bpp.cpp
Devices/SharedMethods/BitBlit_32Bpp.cpp
Devices/SharedMethods/BitBlit_8Bpp.cpp
Devices/SharedMethods/BitBlit_Planes.cpp
Devices/SharedMethods/ConvertToColorValue_Bpp.cpp
Devices/SharedMethods/ConvertToColorValue_Planes.cpp
Devices/SharedMethods/Ddrv.cpp
Devices/SharedMethods/DrawChar_16Bpp.cpp
Devices/SharedMethods/DrawChar_24Bpp.cpp
Devices/SharedMethods/DrawChar_32Bpp.cpp
Devices/SharedMethods/DrawChar_8Bpp.cpp
Devices/SharedMethods/DrawChar_Planes.cpp
Devices/SharedMethods/FillRect_16Bpp.cpp
Devices/SharedMethods/FillRect_24Bpp.cpp
Devices/SharedMethods/FillRect_32Bpp.cpp
Devices/SharedMethods/FillRect_8Bpp.cpp
Devices/SharedMethods/FillRect_Planes.cpp
Devices/SharedMethods/GetPixelColor_16Bpp.cpp
Devices/SharedMethods/GetPixelColor_24Bpp.cpp
Devices/SharedMethods/GetPixelColor_32Bpp.cpp
Devices/SharedMethods/GetPixelColor_8Bpp.cpp
Devices/SharedMethods/GetPixelColor_Planes.cpp
Devices/SharedMethods/KeyboardTimer.cpp
Devices/SharedMethods/ScrollHorizontal_16Bpp.cpp
Devices/SharedMethods/ScrollHorizontal_24Bpp.cpp
Devices/SharedMethods/ScrollHorizontal_32Bpp.cpp
Devices/SharedMethods/ScrollHorizontal_8Bpp.cpp
Devices/SharedMethods/ScrollHorizontal_Planes.cpp
Devices/SharedMethods/ScrollVertical_16Bpp.cpp
Devices/SharedMethods/ScrollVertical_24Bpp.cpp
Devices/SharedMethods/ScrollVertical_32Bpp.cpp
Devices/SharedMethods/ScrollVertical_8Bpp.cpp
Devices/SharedMethods/ScrollVertical_Planes.cpp
Devices/SharedMethods/SetPixel_16Bpp.cpp
Devices/SharedMethods/SetPixel_24Bpp.cpp
Devices/SharedMethods/SetPixel_32Bpp.cpp
Devices/SharedMethods/SetPixel_8Bpp.cpp
Devices/SharedMethods/SetPixel_Planes.cpp
Devices/Win32/AmplifierAudioDevice.cpp
Devices/Win32/AmplifierAudioDevice.hpp [code]
Devices/Win32/AragonServer.cpp
Devices/Win32/AragonServer.hpp [code]
Devices/Win32/aud_drv.cpp
Devices/Win32/Audio.hpp [code]
Devices/Win32/Camera.cpp
Devices/Win32/Camera.hpp [code]
Devices/Win32/CamWin32.cpp
Devices/Win32/CamWin32.hpp [code]
Devices/Win32/Charger.cpp
Devices/Win32/Charger.hpp [code]
Devices/Win32/DefaultDisplay.cpp
Devices/Win32/DefaultDisplay.hpp [code]
Devices/Win32/Fota.cpp
Devices/Win32/Fota.hpp [code]
Devices/Win32/GatiManager.cpp
Devices/Win32/GatiManager.hpp [code]
Devices/Win32/GatiServer.hpp [code]
Devices/Win32/GenericAudioDevice.cpp
Devices/Win32/GenericAudioDevice.hpp [code]
Devices/Win32/HostAudioDriver.cpp
Devices/Win32/HostAudioDriver.hpp [code]
Devices/Win32/HostAudioGatiServer.cpp
Devices/Win32/HostAudioGatiServer.hpp [code]
Devices/Win32/Keyboard.cpp
Devices/Win32/Keyboard.hpp [code]
Devices/Win32/KeyToneAudioDevice.cpp
Devices/Win32/KeyToneAudioDevice.hpp [code]
Devices/Win32/Led.cpp
Devices/Win32/Led.hpp [code]
Devices/Win32/MiscAudioDevice.cpp
Devices/Win32/MiscAudioDevice.hpp [code]
Devices/Win32/MmiSimClient.cpp
Devices/Win32/MmiSimClient.hpp [code]
Devices/Win32/MmiSimProtocol.hpp [code]
Devices/Win32/MmiSimServer.cpp
Devices/Win32/MmiSimServer.hpp [code]
Devices/Win32/Mp3AudioDevice.cpp
Devices/Win32/Mp3AudioDevice.hpp [code]
Devices/Win32/PreComp.cpp
Devices/Win32/PreComp.hpp [code]
Devices/Win32/RealTimeClock.cpp
Devices/Win32/RealTimeClock.hpp [code]
Devices/Win32/RingerAudioDevice.cpp
Devices/Win32/RingerAudioDevice.hpp [code]
Devices/Win32/SpeechAudioDevice.cpp
Devices/Win32/SpeechAudioDevice.hpp [code]
Devices/Win32/StillCamera.cpp
Devices/Win32/StillCamera.hpp [code]
Devices/Win32/ToneAudioDevice.cpp
Devices/Win32/ToneAudioDevice.hpp [code]
Devices/Win32/vib_drv.cpp
Devices/Win32/VideoCamera.cpp
Devices/Win32/VideoCamera.hpp [code]
Devices/Win32/VideoChannel.cpp
Devices/Win32/VideoChannel.hpp [code]
Devices/Win32/VirtualDisplay.cpp
Devices/Win32/VirtualDisplay.hpp [code]
Devices/Win32/VoiceMemoAudioDevice.cpp
Devices/Win32/VoiceMemoAudioDevice.hpp [code]
GlobalThemes/CustomizableTheme/CTControlFrameView.cpp
GlobalThemes/CustomizableTheme/CTControlFrameView.hpp [code]
GlobalThemes/CustomizableTheme/CTPanelView.cpp
GlobalThemes/CustomizableTheme/CTPanelView.hpp [code]
GlobalThemes/CustomizableTheme/CTPositionIndicatorView.cpp
GlobalThemes/CustomizableTheme/CTPositionIndicatorView.hpp [code]
GlobalThemes/CustomizableTheme/CTPreComp.cpp
GlobalThemes/CustomizableTheme/CTPreComp.hpp [code]
GlobalThemes/CustomizableTheme/CTProgressBarView.cpp
GlobalThemes/CustomizableTheme/CTProgressBarView.hpp [code]
GlobalThemes/CustomizableTheme/CTPushButtonView.cpp
GlobalThemes/CustomizableTheme/CTPushButtonView.hpp [code]
GlobalThemes/CustomizableTheme/CTResourcePack.cpp
GlobalThemes/CustomizableTheme/CTResourcePack.hpp [code]
GlobalThemes/CustomizableTheme/CTResourceParser.cpp
GlobalThemes/CustomizableTheme/CTResourceParser.hpp [code]
GlobalThemes/CustomizableTheme/CTWindowFrameView.cpp
GlobalThemes/CustomizableTheme/CTWindowFrameView.hpp [code]
GlobalThemes/CustomizableTheme/CustomizableTheme.cpp
GlobalThemes/CustomizableTheme/CustomizableTheme.hpp [code]
GlobalThemes/DefaultTheme/DefaultCheckBoxListView.cpp
GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp [code]
GlobalThemes/DefaultTheme/DefaultCheckBoxView.cpp
GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp [code]
GlobalThemes/DefaultTheme/DefaultControlFrameView.cpp
GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp [code]
GlobalThemes/DefaultTheme/DefaultPanelView.cpp
GlobalThemes/DefaultTheme/DefaultPanelView.hpp [code]
GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.cpp
GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp [code]
GlobalThemes/DefaultTheme/DefaultProgressBarView.cpp
GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp [code]
GlobalThemes/DefaultTheme/DefaultPushButtonView.cpp
GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp [code]
GlobalThemes/DefaultTheme/DefaultRadioButtonListView.cpp
GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp [code]
GlobalThemes/DefaultTheme/DefaultRadioButtonView.cpp
GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp [code]
GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.cpp
GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp [code]
GlobalThemes/DefaultTheme/DefaultTabButtonView.cpp
GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp [code]
GlobalThemes/DefaultTheme/DefaultTabControlView.cpp
GlobalThemes/DefaultTheme/DefaultTabControlView.hpp [code]
GlobalThemes/DefaultTheme/DefaultTextListView.cpp
GlobalThemes/DefaultTheme/DefaultTextListView.hpp [code]
GlobalThemes/DefaultTheme/DefaultTheme.cpp
GlobalThemes/DefaultTheme/DefaultTheme.hpp [code]
GlobalThemes/DefaultTheme/DefaultWindowFrameView.cpp
GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp [code]
GlobalThemes/DefaultTheme/PreComp.cpp
GlobalThemes/DefaultTheme/PreComp.hpp [code]
GlobalThemes/FoggyTheme/FoggyPanelView.cpp
GlobalThemes/FoggyTheme/FoggyPanelView.hpp [code]
GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.cpp
GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp [code]
GlobalThemes/FoggyTheme/FoggyPushButtonView.cpp
GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp [code]
GlobalThemes/FoggyTheme/FoggySoftkeyBarView.cpp
GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp [code]
GlobalThemes/FoggyTheme/FoggyTheme.cpp
GlobalThemes/FoggyTheme/FoggyTheme.hpp [code]
GlobalThemes/FoggyTheme/FoggyWindowFrameView.cpp
GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp [code]
GlobalThemes/FoggyTheme/PreComp.cpp
GlobalThemes/FoggyTheme/PreComp.hpp [code]
Gui/AbstractButton.cpp
Gui/AbstractButton.hpp [code]
Gui/AbstractEditor.cpp
Gui/AbstractEditor.hpp [code]
Gui/AbstractEditorItem.cpp
Gui/AbstractEditorItem.hpp [code]
Gui/AbstractGrid.cpp
Gui/AbstractGrid.hpp [code]
Gui/AbstractItemContainer.cpp
Gui/AbstractItemContainer.hpp [code]
Gui/AbstractItemGrid.cpp
Gui/AbstractItemGrid.hpp [code]
Gui/AbstractItemRenderer.cpp
Gui/AbstractItemRenderer.hpp [code]
Gui/AbstractLineEditor.cpp
Gui/AbstractLineEditor.hpp [code]
Gui/AbstractListBox.hpp [code]
Gui/AbstractMenuAccessor.hpp [code]
Gui/AbstractMenuList.hpp [code]
Gui/AbstractMultiLineEditor.cpp
Gui/AbstractMultiLineEditor.hpp [code]
Gui/AbstractRenderer.cpp
Gui/AbstractRenderer.hpp [code]
Gui/AbstractTextObject.cpp
Gui/AbstractTextObject.hpp [code]
Gui/AbstractTextRenderer.cpp
Gui/AbstractTextRenderer.hpp [code]
Gui/AbstractToggleAction.cpp
Gui/AbstractToggleAction.hpp [code]
Gui/AcacLanguage.cpp
Gui/AcacLanguage.hpp [code]
Gui/AcacTypes.hpp [code]
Gui/Action.cpp
Gui/Action.hpp [code]
Gui/ActionExtension.hpp [code]
Gui/Alert.cpp
Gui/Alert.hpp [code]
Gui/AnimatedTextLine.cpp
Gui/AnimatedTextLine.hpp [code]
Gui/Animation.hpp [code]
Gui/ApoxiGuiVersion.cpp
Gui/ArabicTextRenderer.cpp
Gui/ArabicTextRenderer.hpp [code]
Gui/AtomItem.cpp
Gui/AtomItem.hpp [code]
Gui/BasicPackConnector.cpp
Gui/BasicPackConnector.hpp [code]
Gui/BidiManager.cpp
Gui/BidiManager.hpp [code]
Gui/Bitmap.cpp
Gui/Bitmap.hpp [code]
Gui/BitmapDc.cpp
Gui/BitmapDc.hpp [code]
Gui/Brush.hpp [code]
Gui/CalculatorInputMapper.cpp
Gui/CalculatorInputMapper.hpp [code]
Gui/CancelAction.hpp [code]
Gui/Caret.cpp
Gui/Caret.hpp [code]
Gui/CharItem.cpp
Gui/CharItem.hpp [code]
Gui/CheckBox.hpp [code]
Gui/CheckBoxAction.cpp
Gui/CheckBoxAction.hpp [code]
Gui/CheckBoxControl.cpp
Gui/CheckBoxControl.hpp [code]
Gui/CheckBoxItem.hpp [code]
Gui/CheckBoxList.hpp [code]
Gui/ClientDc.cpp
Gui/ClientDc.hpp [code]
Gui/CloseWindowAction.cpp
Gui/CloseWindowAction.hpp [code]
Gui/Color.cpp
Gui/Color.hpp [code]
Gui/ColorSegmentation.hpp [code]
Gui/ColorTable.hpp [code]
Gui/Component.cpp
Gui/Component.hpp [code]
Gui/CompoundItem.cpp
Gui/CompoundItem.hpp [code]
Gui/ConfirmAction.hpp [code]
Gui/ContextMenu.cpp
Gui/ContextMenu.hpp [code]
Gui/Control.cpp
Gui/Control.hpp [code]
Gui/ControlDc.cpp
Gui/ControlDc.hpp [code]
Gui/ControlFrameView.cpp
Gui/ControlFrameView.hpp [code]
Gui/DataPack.cpp
Gui/DataPack.hpp [code]
Gui/DateCompoundItem.cpp
Gui/DateCompoundItem.hpp [code]
Gui/DateEditor.cpp
Gui/DateEditor.hpp [code]
Gui/DateEditorDocument.cpp
Gui/DateEditorDocument.hpp [code]
Gui/DateTimeInputMapper.cpp
Gui/DateTimeInputMapper.hpp [code]
Gui/DecodingThreadlet.cpp
Gui/DecodingThreadlet.hpp [code]
Gui/DefaultCaret.cpp
Gui/DefaultCaret.hpp [code]
Gui/DefaultItemRenderer.cpp
Gui/DefaultItemRenderer.hpp [code]
Gui/Desktop.cpp
Gui/Desktop.hpp [code]
Gui/DeviceContext.cpp
Gui/DeviceContext.hpp [code]
Gui/DialogWindow.hpp [code]
Gui/DisplayDc.cpp
Gui/DisplayDc.hpp [code]
Gui/DrawableObject.cpp
Gui/DrawableObject.hpp [code]
Gui/EditorDocument.cpp
Gui/EditorDocument.hpp [code]
Gui/EditorLine.cpp
Gui/EditorLine.hpp [code]
Gui/EncodingThreadlet.cpp
Gui/EncodingThreadlet.hpp [code]
Gui/FilePack.cpp
Gui/FilePack.hpp [code]
Gui/FilePackConnector.cpp
Gui/FilePackConnector.hpp [code]
Gui/FlowLayout.cpp
Gui/FlowLayout.hpp [code]
Gui/Font.cpp
Gui/Font.hpp [code]
Gui/FontEntry.cpp
Gui/FontEntry.hpp [code]
Gui/FontManager.cpp
Gui/FontManager.hpp [code]
Gui/FontPack.cpp
Gui/FontPack.hpp [code]
Gui/FontPackConnector.cpp
Gui/FontPackConnector.hpp [code]
Gui/FrameDc.cpp
Gui/FrameDc.hpp [code]
Gui/GlassPane.cpp
Gui/GlassPane.hpp [code]
Gui/GridLayout.cpp
Gui/GridLayout.hpp [code]
Gui/GuiObjectDescr.cpp
Gui/GuiObjectDescr.hpp [code]
Gui/GuiObjectIterator.cpp
Gui/GuiObjectIterator.hpp [code]
Gui/GuiPropertyIdIterator.cpp
Gui/GuiPropertyIdIterator.hpp [code]
Gui/GuiPropertyIterator.cpp
Gui/GuiPropertyIterator.hpp [code]
Gui/GuiTemplates.cpp
Gui/HindiTextRenderer.cpp
Gui/HindiTextRenderer.hpp [code]
Gui/IconSet.cpp
Gui/IconSet.hpp [code]
Gui/IconState.cpp
Gui/IconState.hpp [code]
Gui/Image.cpp
Gui/Image.hpp [code]
Gui/ImageBox.cpp
Gui/ImageBox.hpp [code]
Gui/ImageDecoder.cpp
Gui/ImageDecoder.hpp [code]
Gui/ImageEncoder.cpp
Gui/ImageEncoder.hpp [code]
Gui/ImageFactory.hpp [code]
Gui/ImageObtainer.cpp
Gui/ImageObtainer.hpp [code]
Gui/InputMapper.cpp
Gui/InputMapper.hpp [code]
Gui/IpAddrCompoundItem.cpp
Gui/IpAddrCompoundItem.hpp [code]
Gui/IpAddrEditor.cpp
Gui/IpAddrEditor.hpp [code]
Gui/IpAddrEditorDocument.cpp
Gui/IpAddrEditorDocument.hpp [code]
Gui/IpAddrInputMapper.cpp
Gui/IpAddrInputMapper.hpp [code]
Gui/Item.cpp
Gui/Item.hpp [code]
Gui/ItemBox.cpp
Gui/ItemBox.hpp [code]
Gui/ItemContainer.cpp
Gui/ItemContainer.hpp [code]
Gui/ItemGrid.cpp
Gui/ItemGrid.hpp [code]
Gui/ItemMenu.cpp
Gui/ItemMenu.hpp [code]
Gui/ItemRendererProperties.cpp
Gui/ItemRendererProperties.hpp [code]
Gui/ItemTree.cpp
Gui/ItemTree.hpp [code]
Gui/JapaneseTextRenderer.cpp
Gui/JapaneseTextRenderer.hpp [code]
Gui/LanguageManager.cpp
Gui/LanguageManager.hpp [code]
Gui/Layouter.cpp
Gui/Layouter.hpp [code]
Gui/LayouterControl.hpp [code]
Gui/Lib.hpp [code]
Gui/LineEditor.cpp
Gui/LineEditor.hpp [code]
Gui/Locale.cpp
Gui/Locale.hpp [code]
Gui/Menu.hpp [code]
Gui/MenuAccessor.hpp [code]
Gui/MenuTextIterator.hpp [code]
Gui/MenuTextPtrArrayIterator.hpp [code]
Gui/MessageBox.cpp
Gui/MessageBox.hpp [code]
Gui/Model.cpp
Gui/Model.hpp [code]
Gui/MsgTypes.cpp
Gui/MsgTypes.hpp [code]
Gui/MultiLineEditor.cpp
Gui/MultiLineEditor.hpp [code]
Gui/MultiTabInputMapper.hpp [code]
Gui/MultiTapCaret.cpp
Gui/MultiTapCaret.hpp [code]
Gui/MultiTapInputMapper.cpp
Gui/MultiTapInputMapper.hpp [code]
Gui/NativeImage.cpp
Gui/NativeImage.hpp [code]
Gui/NumericInputMapper.cpp
Gui/NumericInputMapper.hpp [code]
Gui/OpenContextMenuAction.cpp
Gui/OpenContextMenuAction.hpp [code]
Gui/OpenWindowAction.cpp
Gui/OpenWindowAction.hpp [code]
Gui/OptionalConfigBase.hpp [code]
Gui/PagingMap.hpp [code]
Gui/PaintDc.cpp
Gui/PaintDc.hpp [code]
Gui/Panel.cpp
Gui/Panel.hpp [code]
Gui/PasswordEditor.cpp
Gui/PasswordEditor.hpp [code]
Gui/Pen.cpp
Gui/Pen.hpp [code]
Gui/PhoneNumberInputMapper.cpp
Gui/PhoneNumberInputMapper.hpp [code]
Gui/Point.cpp
Gui/Point.hpp [code]
Gui/PositionIndicator.cpp
Gui/PositionIndicator.hpp [code]
Gui/PreComp.cpp
Gui/PreComp.hpp [code]
Gui/PredInputMapper.cpp
Gui/PredInputMapper.hpp [code]
Gui/ProgressBar.cpp
Gui/ProgressBar.hpp [code]
Gui/ProviderListBox.hpp [code]
Gui/PushButton.cpp
Gui/PushButton.hpp [code]
Gui/RadioButton.hpp [code]
Gui/RadioButtonAction.cpp
Gui/RadioButtonAction.hpp [code]
Gui/RadioButtonControl.cpp
Gui/RadioButtonControl.hpp [code]
Gui/RadioButtonGroup.cpp
Gui/RadioButtonGroup.hpp [code]
Gui/RadioButtonItem.hpp [code]
Gui/RadioButtonList.hpp [code]
Gui/Rect.cpp
Gui/Rect.hpp [code]
Gui/ResourceManager.cpp
Gui/ResourceManager.hpp [code]
Gui/ResourceParser.cpp
Gui/ResourceParser.hpp [code]
Gui/ResourceReader.cpp
Gui/ResourceReader.hpp [code]
Gui/RomFont.cpp
Gui/RomFont.hpp [code]
Gui/ScrollBehavior.hpp [code]
Gui/SetLanguageAction.hpp [code]
Gui/SetThemeAction.hpp [code]
Gui/SimpleTextRenderer.cpp
Gui/SimpleTextRenderer.hpp [code]
Gui/Size.hpp [code]
Gui/SoftkeyBar.hpp [code]
Gui/SyncPaintDc.cpp
Gui/SyncPaintDc.hpp [code]
Gui/TabButton.cpp
Gui/TabButton.hpp [code]
Gui/TabControl.cpp
Gui/TabControl.hpp [code]
Gui/TextBox.cpp
Gui/TextBox.hpp [code]
Gui/TextCompoundItem.cpp
Gui/TextCompoundItem.hpp [code]
Gui/TextEditorDocument.cpp
Gui/TextEditorDocument.hpp [code]
Gui/TextFormat.cpp
Gui/TextFormat.hpp [code]
Gui/TextLine.cpp
Gui/TextLine.hpp [code]
Gui/TextList.hpp [code]
Gui/TextMenuAccessor.hpp [code]
Gui/TextPack.cpp
Gui/TextPack.hpp [code]
Gui/TextPackConnector.cpp
Gui/TextPackConnector.hpp [code]
Gui/ThaiTextRenderer.cpp
Gui/ThaiTextRenderer.hpp [code]
Gui/Theme.cpp
Gui/Theme.hpp [code]
Gui/ThemeManager.cpp
Gui/ThemeManager.hpp [code]
Gui/TimeCompoundItem.cpp
Gui/TimeCompoundItem.hpp [code]
Gui/TimeEditor.cpp
Gui/TimeEditor.hpp [code]
Gui/TimeEditorDocument.cpp
Gui/TimeEditorDocument.hpp [code]
Gui/ToggleActionGroup.cpp
Gui/ToggleActionGroup.hpp [code]
Gui/VietnameseTextRenderer.cpp
Gui/VietnameseTextRenderer.hpp [code]
Gui/View.cpp
Gui/View.hpp [code]
Gui/Window.cpp
Gui/Window.hpp [code]
Gui/WindowFrameView.cpp
Gui/WindowFrameView.hpp [code]
Gui/WindowManager.cpp
Gui/WindowManager.hpp [code]
Irda/IrdaTransport.cpp
Irda/IrdaTransport.hpp [code]
Irda/IrdaTypes.hpp [code]
Irda/PreComp.cpp
Irda/PreComp.hpp [code]
Irda/Obex/IrdaObexAddr.cpp
Irda/Obex/IrdaObexAddr.hpp [code]
Irda/Obex/IrdaObexImpl.cpp
Irda/Obex/IrdaObexImpl.hpp [code]
Irda/Obex/IrdaObexTransport.cpp
Irda/Obex/IrdaObexTransport.hpp [code]
Irda/Obex/PreComp.cpp
Irda/Obex/PreComp.hpp [code]
Kernel/AbstractExternalData.cpp
Kernel/AbstractExternalData.hpp [code]
Kernel/AbstractScheduler.cpp
Kernel/AbstractScheduler.hpp [code]
Kernel/ActiveWaitDispatcher.cpp
Kernel/ActiveWaitDispatcher.hpp [code]
Kernel/AlarmManager.cpp
Kernel/AlarmManager.hpp [code]
Kernel/Allocator.cpp
Kernel/Allocator.hpp [code]
Kernel/ApoxiKernelVersion.cpp
Kernel/ApoxiThread.cpp
Kernel/ApoxiThread.hpp [code]
Kernel/AppContainer.cpp
Kernel/AppContainer.hpp [code]
Kernel/AppContainerRoutingTable.cpp
Kernel/AppContainerRoutingTable.hpp [code]
Kernel/Application.cpp
Kernel/Application.hpp [code]
Kernel/ApplicationTracer.cpp
Kernel/ApplicationTracer.hpp [code]
Kernel/AppRoutingTable.hpp [code]
Kernel/Condition.cpp
Kernel/Condition.hpp [code]
Kernel/DbgTimingMeasurement.cpp
Kernel/DbgTimingMeasurement.hpp [code]
Kernel/Dispatcher.cpp
Kernel/Dispatcher.hpp [code]
Kernel/DispatcherAction.hpp [code]
Kernel/ExecutionContext.cpp
Kernel/ExecutionContext.hpp [code]
Kernel/ExternalCommunicationHandler.cpp
Kernel/ExternalCommunicationHandler.hpp [code]
Kernel/FunctionTracer.hpp [code]
Kernel/GenericWorkerTask.cpp
Kernel/GenericWorkerTask.hpp [code]
Kernel/HeapManager.cpp
Kernel/HeapManager.hpp [code]
Kernel/HeapVector.cpp
Kernel/HeapVector.hpp [code]
Kernel/HookedMessageReferrerList.cpp
Kernel/HookedMessageReferrerList.hpp [code]
Kernel/InputMap.cpp
Kernel/InputMap.hpp [code]
Kernel/InputStream.hpp [code]
Kernel/KernelTemplates.cpp
Kernel/Lib.hpp [code]
Kernel/MachType.hpp [code]
Kernel/Message.cpp
Kernel/Message.hpp [code]
Kernel/MessageHook.cpp
Kernel/MessageHook.hpp [code]
Kernel/MessageHookList.cpp
Kernel/MessageHookList.hpp [code]
Kernel/MessageHookNotificationMsg.cpp
Kernel/MessageHookNotificationMsg.hpp [code]
Kernel/MessageMap.hpp [code]
Kernel/MessageMapDispatcher.cpp
Kernel/MessageMapDispatcher.hpp [code]
Kernel/MessageReferrer.cpp
Kernel/MessageReferrer.hpp [code]
Kernel/MessageRouter.cpp
Kernel/MessageRouter.hpp [code]
Kernel/MsgCategory.cpp
Kernel/MsgCategory.hpp [code]
Kernel/MsgClass.hpp [code]
Kernel/MsgQueue.cpp
Kernel/MsgQueue.hpp [code]
Kernel/MsgTypes.cpp
Kernel/MsgTypes.hpp [code]
Kernel/OutputStream.hpp [code]
Kernel/PreComp.cpp
Kernel/PreComp.hpp [code]
Kernel/RuntimeConfigurator.cpp
Kernel/RuntimeConfigurator.hpp [code]
Kernel/ServiceThread.cpp
Kernel/ServiceThread.hpp [code]
Kernel/ServiceThreadStarter.cpp
Kernel/ServiceThreadStarter.hpp [code]
Kernel/SimpleScheduler.cpp
Kernel/SimpleScheduler.hpp [code]
Kernel/SubSystem.cpp
Kernel/SubSystem.hpp [code]
Kernel/SubSystemManager.cpp
Kernel/SubSystemManager.hpp [code]
Kernel/System.cpp
Kernel/System.hpp [code]
Kernel/Threadlet.cpp
Kernel/Threadlet.hpp [code]
Kernel/Timer.cpp
Kernel/Timer.hpp [code]
Kernel/Trace.hpp [code]
Kernel/Types.hpp [code]
Kernel/UserDispatcher.cpp
Kernel/UserDispatcher.hpp [code]
Kernel/VersionInfo.cpp
Kernel/VersionInfo.hpp [code]
Kernel/Os/AppMutex.cpp
Kernel/Os/AppMutex.hpp [code]
Kernel/Os/InternalTracer.hpp [code]
Kernel/Os/IsrDataContainer.hpp [code]
Kernel/Os/IsrDataManager.cpp
Kernel/Os/IsrDataManager.hpp [code]
Kernel/Os/IsrDataMarshaller.cpp
Kernel/Os/IsrDataMarshaller.hpp [code]
Kernel/Os/Mutex.cpp
Kernel/Os/Mutex.hpp [code]
Kernel/Os/MutexObtainer.cpp
Kernel/Os/MutexObtainer.hpp [code]
Kernel/Os/Os.cpp
Kernel/Os/Os.hpp [code]
Kernel/Os/OsClass.hpp [code]
Kernel/Os/OsStrLib.cpp
Kernel/Os/OsStrLib.hpp [code]
Kernel/Os/PreComp.cpp
Kernel/Os/Scheduler.hpp [code]
Kernel/Os/Semaphore.hpp [code]
Kernel/Os/SemObtainer.cpp
Kernel/Os/SemObtainer.hpp [code]
Kernel/Os/SimpleMutex.cpp
Kernel/Os/SimpleMutex.hpp [code]
Kernel/Os/SimpleSemaphore.hpp [code]
Kernel/Os/SystemTimer.hpp [code]
Kernel/Os/TestWriter.cpp
Kernel/Os/TestWriter.hpp [code]
Kernel/Os/Thread.hpp [code]
Kernel/Os/Ticks.hpp [code]
Kernel/Os/TickValue.cpp
Kernel/Os/TickValue.hpp [code]
Kernel/Os/Trap.hpp [code]
Kernel/Os/Nuc32/InternalTracer.cpp
Kernel/Os/Nuc32/Nuc32.cpp
Kernel/Os/Nuc32/Nuc32.hpp [code]
Kernel/Os/Nuc32/NucInc.hpp [code]
Kernel/Os/Nuc32/PreComp.cpp
Kernel/Os/Nuc32/RingBuffer.cpp
Kernel/Os/Nuc32/RingBuffer.hpp [code]
Kernel/Os/Nuc32/Scheduler.cpp
Kernel/Os/Nuc32/Scheduler.hpp [code]
Kernel/Os/Nuc32/Semaphore.cpp
Kernel/Os/Nuc32/Semaphore.hpp [code]
Kernel/Os/Nuc32/SimpleSemaphore.cpp
Kernel/Os/Nuc32/SimpleSemaphore.hpp [code]
Kernel/Os/Nuc32/SocketPeer.cpp
Kernel/Os/Nuc32/SocketPeer.hpp [code]
Kernel/Os/Nuc32/SystemTimer.cpp
Kernel/Os/Nuc32/SystemTimer.hpp [code]
Kernel/Os/Nuc32/Thread.cpp
Kernel/Os/Nuc32/Thread.hpp [code]
Kernel/Os/Nuc32/Ticks.cpp
Kernel/Os/Nuc32/Ticks.hpp [code]
Kernel/Os/Nuc32/Trap.cpp
Kernel/Os/Nuc32/Trap.hpp [code]
Kernel/Os/Win32/InternalTracer.cpp
Kernel/Os/Win32/PreComp.cpp
Kernel/Os/Win32/Scheduler.cpp
Kernel/Os/Win32/Scheduler.hpp [code]
Kernel/Os/Win32/Semaphore.cpp
Kernel/Os/Win32/Semaphore.hpp [code]
Kernel/Os/Win32/SimpleSemaphore.cpp
Kernel/Os/Win32/SimpleSemaphore.hpp [code]
Kernel/Os/Win32/SystemTimer.cpp
Kernel/Os/Win32/SystemTimer.hpp [code]
Kernel/Os/Win32/Thread.cpp
Kernel/Os/Win32/Thread.hpp [code]
Kernel/Os/Win32/Ticks.cpp
Kernel/Os/Win32/Ticks.hpp [code]
Kernel/Os/Win32/Trap.cpp
Kernel/Os/Win32/Trap.hpp [code]
Kernel/Os/Win32/Win32.cpp
Kernel/Os/Win32/Win32.hpp [code]
Kernel/Os/Win32/WinInc.hpp [code]
Obex/FsmEngine.cpp
Obex/FsmEngine.hpp [code]
Obex/ObexAbstractPort.cpp
Obex/ObexAbstractPort.hpp [code]
Obex/ObexAddress.cpp
Obex/ObexAddress.hpp [code]
Obex/ObexAddrPtr.hpp [code]
Obex/ObexAppMsg.cpp
Obex/ObexAppMsg.hpp [code]
Obex/ObexBuffer.cpp
Obex/ObexBuffer.hpp [code]
Obex/ObexChannel.cpp
Obex/ObexChannel.hpp [code]
Obex/ObexClient.cpp
Obex/ObexClient.hpp [code]
Obex/ObexClientDispatcher.cpp
Obex/ObexClientDispatcher.hpp [code]
Obex/ObexClientOppImpl.cpp
Obex/ObexClientOppImpl.hpp [code]
Obex/ObexClientPort.cpp
Obex/ObexClientPort.hpp [code]
Obex/ObexConfig.hpp [code]
Obex/ObexDataServer.cpp
Obex/ObexDataServer.hpp [code]
Obex/ObexDispatcher.cpp
Obex/ObexDispatcher.hpp [code]
Obex/ObexFtpDataServer.cpp
Obex/ObexFtpDataServer.hpp [code]
Obex/ObexFtpServer.cpp
Obex/ObexFtpServer.hpp [code]
Obex/ObexHeader.cpp
Obex/ObexHeader.hpp [code]
Obex/ObexHeaderBuilder.cpp
Obex/ObexHeaderBuilder.hpp [code]
Obex/ObexHeaderList.cpp
Obex/ObexHeaderList.hpp [code]
Obex/ObexLayer.cpp
Obex/ObexLayer.hpp [code]
Obex/ObexMessages.cpp
Obex/ObexMessages.hpp [code]
Obex/ObexMngr.cpp
Obex/ObexMngr.hpp [code]
Obex/ObexObject.cpp
Obex/ObexObject.hpp [code]
Obex/ObexObjectData.hpp [code]
Obex/ObexOperationId.cpp
Obex/ObexOperationId.hpp [code]
Obex/ObexOppBinDataPushClient.cpp
Obex/ObexOppBinDataPushClient.hpp [code]
Obex/ObexOppClient.cpp
Obex/ObexOppClient.hpp [code]
Obex/ObexOppDataSinkPushServer.cpp
Obex/ObexOppDataSinkPushServer.hpp [code]
Obex/ObexOppLayer.cpp
Obex/ObexOppLayer.hpp [code]
Obex/ObexOppServer.cpp
Obex/ObexOppServer.hpp [code]
Obex/ObexProtocol.cpp
Obex/ObexProtocol.hpp [code]
Obex/ObexResult.hpp [code]
Obex/ObexServer.cpp
Obex/ObexServer.hpp [code]
Obex/ObexServerDispatcher.cpp
Obex/ObexServerDispatcher.hpp [code]
Obex/ObexServerInfo.cpp
Obex/ObexServerInfo.hpp [code]
Obex/ObexServerMngr.cpp
Obex/ObexServerMngr.hpp [code]
Obex/ObexServerOppImpl.cpp
Obex/ObexServerOppImpl.hpp [code]
Obex/ObexServerPort.cpp
Obex/ObexServerPort.hpp [code]
Obex/ObexServerVisitor.cpp
Obex/ObexServerVisitor.hpp [code]
Obex/ObexTemplates.cpp
Obex/ObexTransport.cpp
Obex/ObexTransport.hpp [code]
Obex/ObexTransportMsg.cpp
Obex/ObexTransportMsg.hpp [code]
Obex/ObexTransportSet.cpp
Obex/ObexTransportSet.hpp [code]
Obex/ObexTypes.hpp [code]
Obex/ObexUrlParser.cpp
Obex/ObexUrlParser.hpp [code]
Obex/ObexVCardMsg.cpp
Obex/ObexVCardMsg.hpp [code]
Obex/PreComp.cpp
Obex/PreComp.hpp [code]
Obex/VCard.hpp [code]
Socket/CsdDataConn.cpp
Socket/CsdDataConn.hpp [code]
Socket/CsdDataConnProfile.cpp
Socket/CsdDataConnProfile.hpp [code]
Socket/DataConn.cpp
Socket/DataConn.hpp [code]
Socket/DataConnManager.cpp
Socket/DataConnManager.hpp [code]
Socket/DataConnProfile.cpp
Socket/DataConnProfile.hpp [code]
Socket/DataConnProfileManager.cpp
Socket/DataConnProfileManager.hpp [code]
Socket/DataConnProfileStorage.cpp
Socket/DataConnProfileStorage.hpp [code]
Socket/DnsClient.cpp
Socket/DnsClient.hpp [code]
Socket/DnsClientTest.cpp
Socket/DnsClientTest.hpp [code]
Socket/DnsClientTypes.hpp [code]
Socket/InetSocket.cpp
Socket/InetSocket.hpp [code]
Socket/InetSocketAddr.cpp
Socket/InetSocketAddr.hpp [code]
Socket/NetAdapterHandler.cpp
Socket/NetAdapterHandler.hpp [code]
Socket/PersistDataConnProfile.cpp
Socket/PersistDataConnProfile.hpp [code]
Socket/PppDataConn.cpp
Socket/PppDataConn.hpp [code]
Socket/PreComp.cpp
Socket/PreComp.hpp [code]
Socket/PsdDataConn.cpp
Socket/PsdDataConn.hpp [code]
Socket/PsdDataConnProfile.cpp
Socket/PsdDataConnProfile.hpp [code]
Socket/SerDataConn.cpp
Socket/SerDataConn.hpp [code]
Socket/SerDataConnProfile.cpp
Socket/SerDataConnProfile.hpp [code]
Socket/Socket.cpp
Socket/Socket.hpp [code]
Socket/SocketData.cpp
Socket/SocketData.hpp [code]
Socket/SocketDataLock.hpp [code]
Socket/SocketHandler.cpp
Socket/SocketHandler.hpp [code]
Socket/SocketMsg.cpp
Socket/SocketMsg.hpp [code]
Socket/SocketRxThread.cpp
Socket/SocketRxThread.hpp [code]
Socket/SocketSubSystem.cpp
Socket/SocketSubSystem.hpp [code]
Socket/SocketTemplates.cpp
Socket/SocketTypes.cpp
Socket/SocketTypes.hpp [code]
Socket/TcpServerSocket.cpp
Socket/TcpServerSocket.hpp [code]
Socket/TcpSocket.cpp
Socket/TcpSocket.hpp [code]
Socket/TcpSocketBase.hpp [code]
Socket/UdpSocket.cpp
Socket/UdpSocket.hpp [code]
Socket/Sys/SysSocket.hpp [code]
Socket/Sys/SysSocketBase.cpp
Socket/Sys/SysSocketBase.hpp [code]
Socket/Sys/GlBsd/BsdSysSocket.cpp
Socket/Sys/GlBsd/BsdSysSocket.hpp [code]
Socket/Sys/GlDummy/DummyDnsClient.hpp [code]
Socket/Sys/GlDummy/DummySysSocket.hpp [code]
Socket/Sys/GlLwip/LwipSysDnsClient.cpp
Socket/Sys/GlLwip/LwipSysDnsClient.hpp [code]
Socket/Sys/GlLwip/LwipSysSocket.cpp
Socket/Sys/GlLwip/LwipSysSocket.hpp [code]
Socket/Sys/GlUsnet/UsnetSysSocket.cpp
Socket/Sys/GlUsnet/UsnetSysSocket.hpp [code]
Socket/Sys/GlWin32/Win32SysDnsClient.cpp
Socket/Sys/GlWin32/Win32SysDnsClient.hpp [code]
Socket/Sys/GlWin32/Win32SysSocket.cpp
Socket/Sys/GlWin32/Win32SysSocket.hpp [code]
Socket/Test/UdpServer/UdpServer.cpp
UnitTest/AsyncUnitTestCase.cpp
UnitTest/AsyncUnitTestCase.hpp [code]
UnitTest/Decorator.cpp
UnitTest/Decorator.hpp [code]
UnitTest/MsgTypes.cpp
UnitTest/MsgTypes.hpp [code]
UnitTest/PreComp.cpp
UnitTest/PreComp.hpp [code]
UnitTest/UnitTest.cpp
UnitTest/UnitTest.hpp [code]
UnitTest/UnitTestAutoRepository.cpp
UnitTest/UnitTestAutoRepository.hpp [code]
UnitTest/UnitTestCase.cpp
UnitTest/UnitTestCase.hpp [code]
UnitTest/UnitTestCommunicator.cpp
UnitTest/UnitTestCommunicator.hpp [code]
UnitTest/UnitTestData.cpp
UnitTest/UnitTestData.hpp [code]
UnitTest/UnitTestMacros.cpp
UnitTest/UnitTestMacros.hpp [code]
UnitTest/UnitTestRegistrar.hpp [code]
UnitTest/UnitTestRepository.cpp
UnitTest/UnitTestRepository.hpp [code]
UnitTest/UnitTestResult.cpp
UnitTest/UnitTestResult.hpp [code]
UnitTest/UnitTestRunner.cpp
UnitTest/UnitTestRunner.hpp [code]
UnitTest/UnitTestStaticRepository.cpp
UnitTest/UnitTestStaticRepository.hpp [code]
UnitTest/UnitTestSuite.cpp
UnitTest/UnitTestSuite.hpp [code]
UnitTest/UTTcpSocket.cpp
UnitTest/UTTcpSocket.hpp [code]
Applications/AdvPhonebook/AdvPbAction.cpp
Applications/AdvPhonebook/AdvPbAction.hpp [code]
Applications/AdvPhonebook/AdvPbApp.cpp
Applications/AdvPhonebook/AdvPbApp.hpp [code]
Applications/AdvPhonebook/AdvPbMsgTypes.cpp
Applications/AdvPhonebook/AdvPbMsgTypes.hpp [code]
Applications/AdvPhonebook/AdvPbPreComp.cpp
Applications/AdvPhonebook/AdvPbPreComp.hpp [code]
Applications/AdvPhonebook/AdvPbWin.cpp
Applications/AdvPhonebook/AdvPbWin.hpp [code]
Applications/AdvPhonebook/ApbVersion.cpp
Applications/AdvPhonebook/ApbVersion.hpp [code]
Applications/AdvPhonebook/BasicPbWin.cpp
Applications/AdvPhonebook/BasicPbWin.hpp [code]
Applications/AdvPhonebook/CopyHandler.cpp
Applications/AdvPhonebook/CopyHandler.hpp [code]
Applications/AdvPhonebook/GroupProvider.cpp
Applications/AdvPhonebook/GroupProvider.hpp [code]
Applications/AdvPhonebook/PbAbstractWin.cpp
Applications/AdvPhonebook/PbAbstractWin.hpp [code]
Applications/AdvPhonebook/PbAction.cpp
Applications/AdvPhonebook/PbAction.hpp [code]
Applications/AdvPhonebook/PbAdvAddEditEntry.cpp
Applications/AdvPhonebook/PbAdvAddEditEntry.hpp [code]
Applications/AdvPhonebook/PbAdvDataHandler.cpp
Applications/AdvPhonebook/PbAdvDataHandler.hpp [code]
Applications/AdvPhonebook/PbAdvDetails.cpp
Applications/AdvPhonebook/PbAdvDetails.hpp [code]
Applications/AdvPhonebook/PbBaseWin.cpp
Applications/AdvPhonebook/PbBaseWin.hpp [code]
Applications/AdvPhonebook/PbConfig.hpp [code]
Applications/AdvPhonebook/PbDataHandler.cpp
Applications/AdvPhonebook/PbDataHandler.hpp [code]
Applications/AdvPhonebook/PbDetailFilterProvider.cpp
Applications/AdvPhonebook/PbDetailFilterProvider.hpp [code]
Applications/AdvPhonebook/PbDetailListBox.cpp
Applications/AdvPhonebook/PbDetailListBox.hpp [code]
Applications/AdvPhonebook/PbDetails.cpp
Applications/AdvPhonebook/PbDetails.hpp [code]
Applications/AdvPhonebook/PbFfsNameHandler.cpp
Applications/AdvPhonebook/PbFfsNameHandler.hpp [code]
Applications/AdvPhonebook/PbFfsNumberHandler.cpp
Applications/AdvPhonebook/PbFfsNumberHandler.hpp [code]
Applications/AdvPhonebook/PbLazySynchronizer.cpp
Applications/AdvPhonebook/PbLazySynchronizer.hpp [code]
Applications/AdvPhonebook/PbManualSynchronizer.cpp
Applications/AdvPhonebook/PbManualSynchronizer.hpp [code]
Applications/AdvPhonebook/PbMergeProvider.cpp
Applications/AdvPhonebook/PbMergeProvider.hpp [code]
Applications/AdvPhonebook/PbNameEditBox.cpp
Applications/AdvPhonebook/PbNameEditBox.hpp [code]
Applications/AdvPhonebook/PbNameFilterProvider.cpp
Applications/AdvPhonebook/PbNameFilterProvider.hpp [code]
Applications/AdvPhonebook/PbNameHandler.cpp
Applications/AdvPhonebook/PbNameHandler.hpp [code]
Applications/AdvPhonebook/PbNameNumberProvider.cpp
Applications/AdvPhonebook/PbNameNumberProvider.hpp [code]
Applications/AdvPhonebook/PbNameProvider.cpp
Applications/AdvPhonebook/PbNameProvider.hpp [code]
Applications/AdvPhonebook/PbNextFreeIdRecord.cpp
Applications/AdvPhonebook/PbNextFreeIdRecord.hpp [code]
Applications/AdvPhonebook/PbNumberHandler.cpp
Applications/AdvPhonebook/PbNumberHandler.hpp [code]
Applications/AdvPhonebook/PbNumberProvider.cpp
Applications/AdvPhonebook/PbNumberProvider.hpp [code]
Applications/AdvPhonebook/PbNvRamNameHandler.cpp
Applications/AdvPhonebook/PbNvRamNameHandler.hpp [code]
Applications/AdvPhonebook/PbNvRamNumberHandler.cpp
Applications/AdvPhonebook/PbNvRamNumberHandler.hpp [code]
Applications/AdvPhonebook/PbPhoneNumberPrompt.cpp
Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp [code]
Applications/AdvPhonebook/PbProviderListener.cpp
Applications/AdvPhonebook/PbProviderListener.hpp [code]
Applications/AdvPhonebook/PbProvIds.hpp [code]
Applications/AdvPhonebook/PbProvListBox.cpp
Applications/AdvPhonebook/PbProvListBox.hpp [code]
Applications/AdvPhonebook/PbRecord.cpp
Applications/AdvPhonebook/PbRecord.hpp [code]
Applications/AdvPhonebook/PbRecordHandler.cpp
Applications/AdvPhonebook/PbRecordHandler.hpp [code]
Applications/AdvPhonebook/PbRecordProvider.cpp
Applications/AdvPhonebook/PbRecordProvider.hpp [code]
Applications/AdvPhonebook/PbSelectGroup.cpp
Applications/AdvPhonebook/PbSelectGroup.hpp [code]
Applications/AdvPhonebook/PbSelectNoType.cpp
Applications/AdvPhonebook/PbSelectNoType.hpp [code]
Applications/AdvPhonebook/PbSelectNumberWin.cpp
Applications/AdvPhonebook/PbSelectNumberWin.hpp [code]
Applications/AdvPhonebook/PbSimProvider.cpp
Applications/AdvPhonebook/PbSimProvider.hpp [code]
Applications/AdvPhonebook/PbSortedProvider.cpp
Applications/AdvPhonebook/PbSortedProvider.hpp [code]
Applications/AdvPhonebook/PbSynchronizer.cpp
Applications/AdvPhonebook/PbSynchronizer.hpp [code]
Applications/AdvPhonebook/PbTypes.hpp [code]
Applications/AdvPhonebook/PhonebookApp.cpp
Applications/AdvPhonebook/PhonebookApp.hpp [code]
Applications/AdvPhonebook/PhonebookWin.cpp
Applications/AdvPhonebook/PhonebookWin.hpp [code]
Applications/AdvPhonebook/ProvListBoxWin.cpp
Applications/AdvPhonebook/ProvListBoxWin.hpp [code]
Applications/AdvPhonebook/SyncPhoneThreadlet.cpp
Applications/AdvPhonebook/SyncPhoneThreadlet.hpp [code]
Applications/AdvPhonebook/UpdatePbThreadlet.cpp
Applications/AdvPhonebook/UpdatePbThreadlet.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.cpp
Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpCommandInterface.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.cpp
Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.cpp
Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpPanelApplication.cpp
Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.cpp
Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpPanelService.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.cpp
Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpPreComp.cpp
Applications/BluetoothAvrcp/BtAvrcpPreComp.hpp [code]
Applications/BluetoothAvrcp/BtAvrcpProfileService.cpp
Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp [code]
Applications/BtApp/BtActiveDeviceWindow.cpp
Applications/BtApp/BtActiveDeviceWindow.hpp [code]
Applications/BtApp/BtApplication.cpp
Applications/BtApp/BtApplication.hpp [code]
Applications/BtApp/BtApplicationRequests.cpp
Applications/BtApp/BtApplicationRequests.hpp [code]
Applications/BtApp/BtApplicationWindows.cpp
Applications/BtApp/BtApplicationWindows.hpp [code]
Applications/BtApp/BtDeviceDetailWindow.cpp
Applications/BtApp/BtDeviceDetailWindow.hpp [code]
Applications/BtApp/BtDeviceListsWindows.cpp
Applications/BtApp/BtDeviceListsWindows.hpp [code]
Applications/BtApp/BtLocalSettingsWindows.cpp
Applications/BtApp/BtLocalSettingsWindows.hpp [code]
Applications/BtApp/BtMsgTypes.cpp
Applications/BtApp/BtMsgTypes.hpp [code]
Applications/BtApp/PreComp.cpp
Applications/BtApp/PreComp.hpp [code]
Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.cpp
Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.hpp [code]
Applications/BtApp/BtDunAppPlugin/BtDunProfileService.cpp
Applications/BtApp/BtDunAppPlugin/BtDunProfileService.hpp [code]
Applications/BtApp/BtDunAppPlugin/PreComp.cpp
Applications/BtApp/BtDunAppPlugin/PreComp.hpp [code]
Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.cpp
Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.hpp [code]
Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.cpp
Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.hpp [code]
Applications/BtApp/BtFaxAppPlugin/PreComp.cpp
Applications/BtApp/BtFaxAppPlugin/PreComp.hpp [code]
Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.cpp
Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.hpp [code]
Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.cpp
Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.hpp [code]
Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.cpp
Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.hpp [code]
Applications/BtApp/BtHfAppPlugin/BtHfProfileService.cpp
Applications/BtApp/BtHfAppPlugin/BtHfProfileService.hpp [code]
Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.cpp
Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp [code]
Applications/BtApp/BtHfAppPlugin/BtHfProvider.cpp
Applications/BtApp/BtHfAppPlugin/BtHfProvider.hpp [code]
Applications/BtApp/BtHfAppPlugin/BtHfRecord.cpp
Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp [code]
Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.cpp
Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.hpp [code]
Applications/BtApp/BtHfAppPlugin/PreComp.cpp
Applications/BtApp/BtHfAppPlugin/PreComp.hpp [code]
Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.cpp
Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.hpp [code]
Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.cpp
Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.hpp [code]
Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.cpp
Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.hpp [code]
Applications/BtApp/BtHsAppPlugin/BtHsProfileService.cpp
Applications/BtApp/BtHsAppPlugin/BtHsProfileService.hpp [code]
Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.cpp
Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.hpp [code]
Applications/BtApp/BtHsAppPlugin/PreComp.cpp
Applications/BtApp/BtHsAppPlugin/PreComp.hpp [code]
Applications/Calendar/CalendarAddRecordWin.cpp
Applications/Calendar/CalendarAddRecordWin.hpp [code]
Applications/Calendar/CalendarApp.cpp
Applications/Calendar/CalendarApp.hpp [code]
Applications/Calendar/CalendarAppPreComp.cpp
Applications/Calendar/CalendarAppPreComp.hpp [code]
Applications/Calendar/CalendarDialogWin.cpp
Applications/Calendar/CalendarDialogWin.hpp [code]
Applications/Calendar/CalendarGotoDateWin.cpp
Applications/Calendar/CalendarGotoDateWin.hpp [code]
Applications/Calendar/CalendarGrid.cpp
Applications/Calendar/CalendarGrid.hpp [code]
Applications/Calendar/CalendarListWin.cpp
Applications/Calendar/CalendarListWin.hpp [code]
Applications/Calendar/CalendarMonthSelector.cpp
Applications/Calendar/CalendarMonthSelector.hpp [code]
Applications/Calendar/CalendarMonthWin.cpp
Applications/Calendar/CalendarMonthWin.hpp [code]
Applications/Calendar/CalendarProvider.cpp
Applications/Calendar/CalendarProvider.hpp [code]
Applications/Calendar/CalendarRecord.cpp
Applications/Calendar/CalendarRecord.hpp [code]
Applications/Calendar/CalendarRecordsList.cpp
Applications/Calendar/CalendarRecordsList.hpp [code]
Applications/Calendar/CalendarRecordsListBox.cpp
Applications/Calendar/CalendarRecordsListBox.hpp [code]
Applications/Camera/CameraApp.cpp
Applications/Camera/CameraApp.hpp [code]
Applications/Camera/CameraCaptureWin.cpp
Applications/Camera/CameraCaptureWin.hpp [code]
Applications/Camera/CameraLayoutSettingsWin.cpp
Applications/Camera/CameraOptionSettingsWin.cpp
Applications/Camera/CameraOptionSettingsWin.hpp [code]
Applications/Camera/CameraPreComp.cpp
Applications/Camera/CameraPreComp.hpp [code]
Applications/Camera/CameraSettings.cpp
Applications/Camera/CameraSettings.hpp [code]
Applications/Camera/CameraSettingsWin.cpp
Applications/Camera/CameraSettingsWin.hpp [code]
Applications/Camera/CameraViewFinderWin.cpp
Applications/Camera/CameraViewFinderWin.hpp [code]
Applications/Camera/MsgTypes.cpp
Applications/Camera/MsgTypes.hpp [code]
Applications/DataConn/CsdDataConnProvider.cpp
Applications/DataConn/CsdDataConnProvider.hpp [code]
Applications/DataConn/DataConnAccessor.cpp
Applications/DataConn/DataConnAccessor.hpp [code]
Applications/DataConn/DataConnApp.cpp
Applications/DataConn/DataConnApp.hpp [code]
Applications/DataConn/DataConnOptionWin.cpp
Applications/DataConn/DataConnOptionWin.hpp [code]
Applications/DataConn/DataConnPreComp.cpp
Applications/DataConn/DataConnPreComp.hpp [code]
Applications/DataConn/DataConnProvider.cpp
Applications/DataConn/DataConnProvider.hpp [code]
Applications/DataConn/DataConnSettings.hpp [code]
Applications/DataConn/DataConnTextMaps.cpp
Applications/DataConn/DataConnTextMaps.hpp [code]
Applications/DataConn/DataConnTypeWin.cpp
Applications/DataConn/DataConnTypeWin.hpp [code]
Applications/DataConn/DataConnVersion.cpp
Applications/DataConn/DataConnVersion.hpp [code]
Applications/DataConn/DataConnWin.cpp
Applications/DataConn/DataConnWin.hpp [code]
Applications/DataConn/IpAddrPrompt.cpp
Applications/DataConn/IpAddrPrompt.hpp [code]
Applications/DataConn/MyDataConnProfileStorage.cpp
Applications/DataConn/MyDataConnProfileStorage.hpp [code]
Applications/DataConn/NumberPrompt.cpp
Applications/DataConn/NumberPrompt.hpp [code]
Applications/DataConn/PsdDataConnProvider.cpp
Applications/DataConn/PsdDataConnProvider.hpp [code]
Applications/DataConn/SerDataConnProvider.cpp
Applications/DataConn/SerDataConnProvider.hpp [code]
Applications/Ems/EmsApp.cpp
Applications/Ems/EmsApp.hpp [code]
Applications/Ems/EmsComposeWin.cpp
Applications/Ems/EmsComposeWin.hpp [code]
Applications/Ems/EmsCreator.cpp
Applications/Ems/EmsCreator.hpp [code]
Applications/Ems/EmsEditor.cpp
Applications/Ems/EmsEditor.hpp [code]
Applications/Ems/EmsEditorListener.cpp
Applications/Ems/EmsEditorListener.hpp [code]
Applications/Ems/EmsIeParser.cpp
Applications/Ems/EmsIeParser.hpp [code]
Applications/Ems/EmsImage.cpp
Applications/Ems/EmsImage.hpp [code]
Applications/Ems/EmsInsertPrompt.cpp
Applications/Ems/EmsInsertPrompt.hpp [code]
Applications/Ems/EmsPreComp.cpp
Applications/Ems/EmsPreComp.hpp [code]
Applications/Ems/EmsResourceMaps.cpp
Applications/Ems/EmsResourceMaps.hpp [code]
Applications/Ems/EmsVersion.cpp
Applications/Ems/EmsVersion.hpp [code]
Applications/Ems/EmsViewerWin.cpp
Applications/Ems/EmsViewerWin.hpp [code]
Applications/Ems/PredefinedEmsImage.cpp
Applications/Ems/PredefinedEmsImage.hpp [code]
Applications/Ems/PredefinedEmsSound.cpp
Applications/Ems/PredefinedEmsSound.hpp [code]
Applications/Ems/Sms/AbstractSmsApp.cpp
Applications/Ems/Sms/AbstractSmsApp.hpp [code]
Applications/Ems/Sms/AbstractSmsComposeWin.cpp
Applications/Ems/Sms/AbstractSmsComposeWin.hpp [code]
Applications/Ems/Sms/AbstractSmsUtiltyProcessor.hpp [code]
Applications/Ems/Sms/AbstractSmsViewerWin.cpp
Applications/Ems/Sms/AbstractSmsViewerWin.hpp [code]
Applications/Ems/Sms/SmsAlerts.cpp
Applications/Ems/Sms/SmsAlerts.hpp [code]
Applications/Ems/Sms/SmsApp.cpp
Applications/Ems/Sms/SmsApp.hpp [code]
Applications/Ems/Sms/SmsBasicProvider.cpp
Applications/Ems/Sms/SmsBasicProvider.hpp [code]
Applications/Ems/Sms/SmsComposeWin.cpp
Applications/Ems/Sms/SmsComposeWin.hpp [code]
Applications/Ems/Sms/SmsEditor.cpp
Applications/Ems/Sms/SmsEditor.hpp [code]
Applications/Ems/Sms/SmsFolderProvider.cpp
Applications/Ems/Sms/SmsFolderProvider.hpp [code]
Applications/Ems/Sms/SmsIndicationState.cpp
Applications/Ems/Sms/SmsIndicationState.hpp [code]
Applications/Ems/Sms/SmsMsgTypes.cpp
Applications/Ems/Sms/SmsMsgTypes.hpp [code]
Applications/Ems/Sms/SmsPreComp.cpp
Applications/Ems/Sms/SmsPreComp.hpp [code]
Applications/Ems/Sms/SmsSendingConfirmDialog.cpp
Applications/Ems/Sms/SmsSendingConfirmDialog.hpp [code]
Applications/Ems/Sms/SmsService.cpp
Applications/Ems/Sms/SmsService.hpp [code]
Applications/Ems/Sms/SmsSettingsProvider.cpp
Applications/Ems/Sms/SmsSettingsProvider.hpp [code]
Applications/Ems/Sms/SmsSettingsRecord.cpp
Applications/Ems/Sms/SmsSettingsRecord.hpp [code]
Applications/Ems/Sms/SmsTemplateProvider.cpp
Applications/Ems/Sms/SmsTemplateProvider.hpp [code]
Applications/Ems/Sms/SmsTextMaps.cpp
Applications/Ems/Sms/SmsTextMaps.hpp [code]
Applications/Ems/Sms/SmsTextParser.cpp
Applications/Ems/Sms/SmsTextParser.hpp [code]
Applications/Ems/Sms/SmsUtility.cpp
Applications/Ems/Sms/SmsUtility.hpp [code]
Applications/Ems/Sms/SmsViewerWin.cpp
Applications/Ems/Sms/SmsViewerWin.hpp [code]
Applications/FmRadio/FmRadioApplication.cpp
Applications/FmRadio/FmRadioApplication.hpp [code]
Applications/FmRadio/FmRadioApplicationPreComp.cpp
Applications/FmRadio/FmRadioApplicationPreComp.hpp [code]
Applications/FmRadio/FmRadioEditWin.cpp
Applications/FmRadio/FmRadioEditWin.hpp [code]
Applications/FmRadio/FmRadioSelectStrongerFreq.cpp
Applications/FmRadio/FmRadioSelectStrongerFreq.hpp [code]
Applications/FmRadio/FmRadioSettingsProvider.cpp
Applications/FmRadio/FmRadioSettingsProvider.hpp [code]
Applications/FmRadio/FmRadioSettingsRecord.cpp
Applications/FmRadio/FmRadioSettingsRecord.hpp [code]
Applications/FmRadio/FmRadioStationsProvider.cpp
Applications/FmRadio/FmRadioStationsProvider.hpp [code]
Applications/FmRadio/FmRadioStationsRecord.cpp
Applications/FmRadio/FmRadioStationsRecord.hpp [code]
Applications/FmRadio/FmRadioVersion.cpp
Applications/FmRadio/FmRadioVersion.hpp [code]
Applications/FmRadio/FmRadioWindow.cpp
Applications/FmRadio/FmRadioWindow.hpp [code]
Applications/ImageBrowser/ImageBrowserApp.cpp
Applications/ImageBrowser/ImageBrowserApp.hpp [code]
Applications/ImageBrowser/ImageBrowserDetailWin.cpp
Applications/ImageBrowser/ImageBrowserDetailWin.hpp [code]
Applications/ImageBrowser/ImageBrowserMsgTypes.cpp
Applications/ImageBrowser/ImageBrowserMsgTypes.hpp [code]
Applications/ImageBrowser/ImageBrowserPreComp.cpp
Applications/ImageBrowser/ImageBrowserPreComp.hpp [code]
Applications/ImageBrowser/ImageBrowserTestWin.cpp
Applications/ImageBrowser/ImageBrowserTestWin.hpp [code]
Applications/ImageBrowser/ImageBrowserWin.cpp
Applications/ImageBrowser/ImageBrowserWin.hpp [code]
Applications/ImageBrowser/ImageListBoxModel.cpp
Applications/ImageBrowser/ImageListBoxModel.hpp [code]
Applications/ImageBrowser/ImageMetaData.cpp
Applications/ImageBrowser/ImageMetaData.hpp [code]
Applications/ImageBrowser/ImageRef.cpp
Applications/ImageBrowser/ImageRef.hpp [code]
Applications/ImageBrowser/ImageRefContainer.cpp
Applications/ImageBrowser/ImageRefContainer.hpp [code]
Applications/ImageBrowser/ImageRefGenContainer.cpp
Applications/ImageBrowser/ImageRefGenContainer.hpp [code]
Applications/ImageBrowser/ImageView.cpp
Applications/ImageBrowser/ImageView.hpp [code]
Applications/ImageBrowser/ImageViewListBoxModel.cpp
Applications/ImageBrowser/ImageViewListBoxModel.hpp [code]
Applications/ImageBrowser/ImgbrVersion.cpp
Applications/ImageBrowser/ImgbrVersion.hpp [code]
Applications/ImageBrowser/SampleImages.cpp
Applications/ImageBrowser/SampleImages.hpp [code]
Applications/ImageBrowser/SavingProgressWin.cpp
Applications/ImageBrowser/SavingProgressWin.hpp [code]
Applications/ImageBrowser/Common/BrowserSaveWin.cpp
Applications/ImageBrowser/Common/BrowserSaveWin.hpp [code]
Applications/ImageBrowser/Common/BrowserView.cpp
Applications/ImageBrowser/Common/BrowserView.hpp [code]
Applications/ImageBrowser/Common/BrowserViewContainer.cpp
Applications/ImageBrowser/Common/BrowserViewContainer.hpp [code]
Applications/ImageBrowser/Common/FileNameListBoxModel.cpp
Applications/ImageBrowser/Common/FileNameListBoxModel.hpp [code]
Applications/ImageBrowser/Common/FileNameView.cpp
Applications/ImageBrowser/Common/FileNameView.hpp [code]
Applications/ImageBrowser/Common/InfoDialog.cpp
Applications/ImageBrowser/Common/InfoDialog.hpp [code]
Applications/ImageBrowser/Common/MediaBrowserPreComp.cpp
Applications/ImageBrowser/Common/MediaBrowserPreComp.hpp [code]
Applications/ImageBrowser/Common/MediaBrowserUtils.cpp
Applications/ImageBrowser/Common/MediaBrowserUtils.hpp [code]
Applications/ImageBrowser/Common/MediaFilter.cpp
Applications/ImageBrowser/Common/MediaFilter.hpp [code]
Applications/ImageBrowser/Common/MediaRef.cpp
Applications/ImageBrowser/Common/MediaRef.hpp [code]
Applications/ImageBrowser/Common/MediaRefContainer.cpp
Applications/ImageBrowser/Common/MediaRefContainer.hpp [code]
Applications/ImageBrowser/Common/MediaVisitor.cpp
Applications/ImageBrowser/Common/MediaVisitor.hpp [code]
Applications/ImageBrowser/Common/MetaData.cpp
Applications/ImageBrowser/Common/MetaData.hpp [code]
Applications/ImageBrowser/Common/RenameFileDialog.cpp
Applications/ImageBrowser/Common/RenameFileDialog.hpp [code]
Applications/IrdaApp/IrdaApp.cpp
Applications/IrdaApp/IrdaApp.hpp [code]
Applications/IrdaApp/IrdaAppPreComp.cpp
Applications/IrdaApp/IrdaAppPreComp.hpp [code]
Applications/IrdaApp/IrdaAppVersion.cpp
Applications/IrdaApp/IrdaAppVersion.hpp [code]
Applications/IrdaApp/IrdaWin.cpp
Applications/IrdaApp/IrdaWin.hpp [code]
Applications/Lcs/LcsAppMsgTypes.cpp
Applications/Lcs/LcsAppMsgTypes.hpp [code]
Applications/Lcs/LcsAppPreComp.cpp
Applications/Lcs/LcsAppPreComp.hpp [code]
Applications/Lcs/LcsAppUtils.cpp
Applications/Lcs/LcsAppUtils.hpp [code]
Applications/Lcs/LcsFeatTypes.hpp [code]
Applications/Lcs/LcsMainApp.cpp
Applications/Lcs/LcsMainApp.hpp [code]
Applications/Lcs/LcsMainMenuWin.cpp
Applications/Lcs/LcsMainMenuWin.hpp [code]
Applications/Lcs/LcsOptionsMenuWin.cpp
Applications/Lcs/LcsOptionsMenuWin.hpp [code]
Applications/Lcs/LcsWapIntf.cpp
Applications/Lcs/LcsWapIntf.hpp [code]
Applications/Lcs/LcsWString.cpp
Applications/Lcs/LcsWString.hpp [code]
Applications/Lcs/LocationResultWin.cpp
Applications/Lcs/LocationResultWin.hpp [code]
Applications/Lcs/LocationVerifWin.cpp
Applications/Lcs/LocationVerifWin.hpp [code]
Applications/Lcs/LocResController.cpp
Applications/Lcs/LocResController.hpp [code]
Applications/Lcs/ResultWinBase.cpp
Applications/Lcs/ResultWinBase.hpp [code]
Applications/Lcs/SatteliteGraphWin.cpp
Applications/Lcs/SatteliteGraphWin.hpp [code]
Applications/Lcs/SatteliteInfoWin.cpp
Applications/Lcs/SatteliteInfoWin.hpp [code]
Applications/Lcs/TransferLocationDialogWin.cpp
Applications/Lcs/TransferLocationDialogWin.hpp [code]
Applications/LcsTransports/GLTP/GltpAppMsgTypes.cpp
Applications/LcsTransports/GLTP/GltpAppMsgTypes.hpp [code]
Applications/LcsTransports/GLTP/GltpAppPreComp.cpp
Applications/LcsTransports/GLTP/GltpAppPreComp.hpp [code]
Applications/LcsTransports/GLTP/GltpConnApp.cpp
Applications/LcsTransports/GLTP/GltpConnApp.hpp [code]
Applications/LcsTransports/GLTP/LcsSocket.cpp
Applications/LcsTransports/GLTP/LcsSocket.hpp [code]
Applications/LcsTransports/Settings/AidingDataWin.cpp
Applications/LcsTransports/Settings/AidingDataWin.hpp [code]
Applications/LcsTransports/Settings/LcsRegUri.hpp [code]
Applications/LcsTransports/Settings/LcsSettingsApp.cpp
Applications/LcsTransports/Settings/LcsSettingsApp.hpp [code]
Applications/LcsTransports/Settings/LcsSettingsAppPreComp.cpp
Applications/LcsTransports/Settings/LcsSettingsAppPreComp.hpp [code]
Applications/LcsTransports/Settings/LcsSettingsUtils.cpp
Applications/LcsTransports/Settings/LcsSettingsUtils.hpp [code]
Applications/LcsTransports/Settings/SelfLocationDialogWin.cpp
Applications/LcsTransports/Settings/SelfLocationDialogWin.hpp [code]
Applications/LcsTransports/Settings/ServerAddressWin.cpp
Applications/LcsTransports/Settings/ServerAddressWin.hpp [code]
Applications/ObexApp/ObexApp.cpp
Applications/ObexApp/ObexApp.hpp [code]
Applications/ObexApp/ObexAppPreComp.cpp
Applications/ObexApp/ObexAppPreComp.hpp [code]
Applications/ObexApp/ObexAppVersion.cpp
Applications/ObexApp/ObexAppVersion.hpp [code]
Applications/ObexApp/ObexTransportWin.cpp
Applications/ObexApp/ObexTransportWin.hpp [code]
Applications/RegEditorClient/RegApp.cpp
Applications/RegEditorClient/RegApp.hpp [code]
Applications/RegEditorClient/RegAppCommon.cpp
Applications/RegEditorClient/RegAppCommon.hpp [code]
Applications/RegEditorClient/RegAppFirstWin.cpp
Applications/RegEditorClient/RegAppFirstWin.hpp [code]
Applications/RegEditorClient/RegAppPreComp.cpp
Applications/RegEditorClient/RegAppPreComp.hpp [code]
Applications/RegEditorClient/RegAppWin.cpp
Applications/RegEditorClient/RegAppWin.hpp [code]
Applications/RegEditorClient/RegEncoderDecoder.cpp
Applications/RegEditorClient/RegEncoderDecoder.hpp [code]
Applications/RegEditorClient/RegInterface.cpp
Applications/RegEditorClient/RegInterface.hpp [code]
Applications/SocketTest/FfsMenu.cpp
Applications/SocketTest/FfsMenu.hpp [code]
Applications/SocketTest/FfsTestBase.cpp
Applications/SocketTest/FfsTestBase.hpp [code]
Applications/SocketTest/FfsTestDispWin.cpp
Applications/SocketTest/FfsTestDispWin.hpp [code]
Applications/SocketTest/FfsTestError.hpp [code]
Applications/SocketTest/FfsTestMenu.cpp
Applications/SocketTest/FfsTestMenu.hpp [code]
Applications/SocketTest/FfsTestResultsMenu.cpp
Applications/SocketTest/FfsTestResultsMenu.hpp [code]
Applications/SocketTest/FfsTests.cpp
Applications/SocketTest/FfsTests.hpp [code]
Applications/SocketTest/FfsTestThread.cpp
Applications/SocketTest/FfsTestThread.hpp [code]
Applications/SocketTest/FfsTestThreadlet.cpp
Applications/SocketTest/FfsTestThreadlet.hpp [code]
Applications/SocketTest/IpAddrPrompt.cpp
Applications/SocketTest/IpAddrPrompt.hpp [code]
Applications/SocketTest/PreComp.cpp
Applications/SocketTest/PreComp.hpp [code]
Applications/SocketTest/SocketTestApp.cpp
Applications/SocketTest/SocketTestApp.hpp [code]
Applications/SocketTest/SocketTestDefines.hpp [code]
Applications/SocketTest/SocketTestMsgTypes.cpp
Applications/SocketTest/SocketTestMsgTypes.hpp [code]
Applications/SocketTest/SocketTestProgressWin.cpp
Applications/SocketTest/SocketTestProgressWin.hpp [code]
Applications/SocketTest/SocketTestResultsWin.cpp
Applications/SocketTest/SocketTestResultsWin.hpp [code]
Applications/SocketTest/SocketTestSettingsWin.cpp
Applications/SocketTest/SocketTestSettingsWin.hpp [code]
Applications/SocketTest/SocketTestT.cpp
Applications/SocketTest/SocketTestT.hpp [code]
Applications/SocketTest/SocketTestT1.cpp
Applications/SocketTest/SocketTestT1.hpp [code]
Applications/SocketTest/SocketTestT2.cpp
Applications/SocketTest/SocketTestT2.hpp [code]
Applications/SocketTest/SocketTestT3.cpp
Applications/SocketTest/SocketTestT3.hpp [code]
Applications/SocketTest/SocketTestT4.cpp
Applications/SocketTest/SocketTestT4.hpp [code]
Applications/SocketTest/SocketTestT5.cpp
Applications/SocketTest/SocketTestT5.hpp [code]
Applications/SocketTest/SocketTestT6.cpp
Applications/SocketTest/SocketTestT6.hpp [code]
Applications/SocketTest/SocketTestT7.cpp
Applications/SocketTest/SocketTestT7.hpp [code]
Applications/SocketTest/SocketTestT8.cpp
Applications/SocketTest/SocketTestT8.hpp [code]
Applications/SocketTest/SocketTestTests.cpp
Applications/SocketTest/SocketTestTests.hpp [code]
Applications/SocketTest/SocketTestVersion.cpp
Applications/SocketTest/SocketTestVersion.hpp [code]
Applications/SocketTest/SocketTestWin.cpp
Applications/SocketTest/SocketTestWin.hpp [code]
Applications/SocketTest/TcpServerTestSocket.cpp
Applications/SocketTest/TcpServerTestSocket.hpp [code]
Applications/SocketTest/TcpTestSocket.cpp
Applications/SocketTest/TcpTestSocket.hpp [code]
Applications/SocketTest/UdpTestSocket.cpp
Applications/SocketTest/UdpTestSocket.hpp [code]
Applications/SoundBrowser/AmrSound.cpp
Applications/SoundBrowser/AmrSound.hpp [code]
Applications/SoundBrowser/SampleIMelodies.cpp
Applications/SoundBrowser/SampleIMelodies.hpp [code]
Applications/SoundBrowser/SoundBrowserApp.cpp
Applications/SoundBrowser/SoundBrowserApp.hpp [code]
Applications/SoundBrowser/SoundBrowserMsgTypes.cpp
Applications/SoundBrowser/SoundBrowserMsgTypes.hpp [code]
Applications/SoundBrowser/SoundBrowserPreComp.cpp
Applications/SoundBrowser/SoundBrowserPreComp.hpp [code]
Applications/SoundBrowser/SoundBrowserTestWin.cpp
Applications/SoundBrowser/SoundBrowserTestWin.hpp [code]
Applications/SoundBrowser/SoundBrowserVersion.cpp
Applications/SoundBrowser/SoundBrowserVersion.hpp [code]
Applications/SoundBrowser/SoundBrowserWin.cpp
Applications/SoundBrowser/SoundBrowserWin.hpp [code]
Applications/SoundBrowser/SoundMetaData.cpp
Applications/SoundBrowser/SoundMetaData.hpp [code]
Applications/SoundBrowser/SoundRef.cpp
Applications/SoundBrowser/SoundRef.hpp [code]
Applications/SoundBrowser/SoundRefContainer.cpp
Applications/SoundBrowser/SoundRefContainer.hpp [code]
Applications/SoundBrowser/Common/BrowserSaveWin.cpp
Applications/SoundBrowser/Common/BrowserSaveWin.hpp [code]
Applications/SoundBrowser/Common/BrowserView.cpp
Applications/SoundBrowser/Common/BrowserView.hpp [code]
Applications/SoundBrowser/Common/BrowserViewContainer.cpp
Applications/SoundBrowser/Common/BrowserViewContainer.hpp [code]
Applications/SoundBrowser/Common/FileNameListBoxModel.cpp
Applications/SoundBrowser/Common/FileNameListBoxModel.hpp [code]
Applications/SoundBrowser/Common/FileNameView.cpp
Applications/SoundBrowser/Common/FileNameView.hpp [code]
Applications/SoundBrowser/Common/InfoDialog.cpp
Applications/SoundBrowser/Common/InfoDialog.hpp [code]
Applications/SoundBrowser/Common/MediaBrowserPreComp.cpp
Applications/SoundBrowser/Common/MediaBrowserPreComp.hpp [code]
Applications/SoundBrowser/Common/MediaBrowserUtils.cpp
Applications/SoundBrowser/Common/MediaBrowserUtils.hpp [code]
Applications/SoundBrowser/Common/MediaFilter.cpp
Applications/SoundBrowser/Common/MediaFilter.hpp [code]
Applications/SoundBrowser/Common/MediaRef.cpp
Applications/SoundBrowser/Common/MediaRef.hpp [code]
Applications/SoundBrowser/Common/MediaRefContainer.cpp
Applications/SoundBrowser/Common/MediaRefContainer.hpp [code]
Applications/SoundBrowser/Common/MediaVisitor.cpp
Applications/SoundBrowser/Common/MediaVisitor.hpp [code]
Applications/SoundBrowser/Common/MetaData.cpp
Applications/SoundBrowser/Common/MetaData.hpp [code]
Applications/SoundBrowser/Common/RenameFileDialog.cpp
Applications/SoundBrowser/Common/RenameFileDialog.hpp [code]
Applications/ToDo/ToDoApp.cpp
Applications/ToDo/ToDoApp.hpp [code]
Applications/ToDo/ToDoComposeWin.cpp
Applications/ToDo/ToDoComposeWin.hpp [code]
Applications/ToDo/ToDoDialogWin.cpp
Applications/ToDo/ToDoDialogWin.hpp [code]
Applications/ToDo/ToDoListWin.cpp
Applications/ToDo/ToDoListWin.hpp [code]
Applications/ToDo/ToDoPreComp.cpp
Applications/ToDo/ToDoPreComp.hpp [code]
Applications/ToDo/ToDoProvider.cpp
Applications/ToDo/ToDoProvider.hpp [code]
Applications/ToDo/ToDoRecord.cpp
Applications/ToDo/ToDoRecord.hpp [code]
Applications/UnifiedInbox/UibActionAccessor.cpp
Applications/UnifiedInbox/UibActionAccessor.hpp [code]
Applications/UnifiedInbox/UibApp.cpp
Applications/UnifiedInbox/UibApp.hpp [code]
Applications/UnifiedInbox/UibFolderWin.cpp
Applications/UnifiedInbox/UibFolderWin.hpp [code]
Applications/UnifiedInbox/UibInboxProvider.cpp
Applications/UnifiedInbox/UibInboxProvider.hpp [code]
Applications/UnifiedInbox/UibListBoxModel.cpp
Applications/UnifiedInbox/UibListBoxModel.hpp [code]
Applications/UnifiedInbox/UibMsgTypes.cpp
Applications/UnifiedInbox/UibMsgTypes.hpp [code]
Applications/UnifiedInbox/UibPreComp.cpp
Applications/UnifiedInbox/UibPreComp.hpp [code]
Applications/UnifiedInbox/UibServiceImpl.cpp
Applications/UnifiedInbox/UibServiceImpl.hpp [code]
Applications/UnifiedInbox/UibSettingsProvider.cpp
Applications/UnifiedInbox/UibSettingsProvider.hpp [code]
Applications/UnifiedInbox/UibSettingsRecord.cpp
Applications/UnifiedInbox/UibSettingsRecord.hpp [code]
Applications/UnifiedInbox/UibSettingsWin.cpp
Applications/UnifiedInbox/UibSettingsWin.hpp [code]
Applications/UnifiedInbox/UibUpdateThreadlet.cpp
Applications/UnifiedInbox/UibUpdateThreadlet.hpp [code]
Applications/UnifiedInbox/UibVersion.cpp
Applications/UnifiedInbox/UibVersion.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.cpp
Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibInboxTest.cpp
Applications/UnifiedInbox/UibUnitTests/UibInboxTest.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.cpp
Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.cpp
Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.cpp
Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.cpp
Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibSortingTest.cpp
Applications/UnifiedInbox/UibUnitTests/UibSortingTest.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibTestControl.cpp
Applications/UnifiedInbox/UibUnitTests/UibTestControl.hpp [code]
Applications/UnifiedInbox/UibUnitTests/UibTests.cpp
Applications/UnifiedInbox/UibUnitTests/UibTests.hpp [code]
Applications/UsbApp/UsbApp.cpp
Applications/UsbApp/UsbApp.hpp [code]
Applications/UsbApp/UsbAppPreComp.cpp
Applications/UsbApp/UsbAppPreComp.hpp [code]
Applications/UsbApp/UsbVersion.cpp
Applications/UsbApp/UsbVersion.hpp [code]
Applications/VoiceMemo/VoiceMemoApp.cpp
Applications/VoiceMemo/VoiceMemoApp.hpp [code]
Applications/VoiceMemo/VoiceMemoMenuAccessor.cpp
Applications/VoiceMemo/VoiceMemoMenuAccessor.hpp [code]
Applications/VoiceMemo/VoiceMemoPreComp.cpp
Applications/VoiceMemo/VoiceMemoPreComp.hpp [code]
Applications/VoiceMemo/VoiceMemoRecordWin.cpp
Applications/VoiceMemo/VoiceMemoRecordWin.hpp [code]
Applications/VoiceMemo/VoiceMemoVersion.cpp
Applications/VoiceMemo/VoiceMemoVersion.hpp [code]
Applications/VoiceMemo/VoiceMemoWin.cpp
Applications/VoiceMemo/VoiceMemoWin.hpp [code]
Generated on Tue Jan 24 14:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlConfig.hpp File Reference

  • Data Structures
  • Files
  • Related Pages
  • File List
  • Globals

AtlConfig.hpp File Reference

#include <Atl/Features/BackToIdleFeature.hpp>
#include <Atl/Features/TriggerKeyFeature.hpp>
#include <Atl/Features/FeaturePool.hpp>
#include <Atl/Features/FeatureItem.hpp>
#include <Atl/Features/MenuPool.hpp>
#include <Atl/Properties/PropertyEditor.hpp>
#include <Atl/Properties/PropertyEditorID.hpp>
#include <Atl/Context/ContextManager.hpp>

Include dependency graph for AtlConfig.hpp:

Go to the source code of this file.

Data Structures

class | AtlConfig

Defines

#define | Atl_AtlConfig_hpp

Define Documentation

#define Atl_AtlConfig_hpp

Generated on Wed Jan 25 00:53:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlConfig.hpp Source File

  • File List
  • Globals

AtlConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Atl_AtlConfig_hpp)
00011 #define Atl_AtlConfig_hpp
00014
00015 #include <Atl/Features/BackToIdleFeature.hpp>
00016 #include <Atl/Features/TriggerKeyFeature.hpp>
00017 #include <Atl/Features/FeaturePool.hpp>
00018 #include <Atl/Features/FeatureItem.hpp>
00019 #include <Atl/Features/MenuPool.hpp>
00020 #include <Atl/Properties/PropertyEditor.hpp>
00021 #include <Atl/Properties/PropertyEditorID.hpp>
00022 #include <Atl/Context/ContextManager.hpp>
00023
00024 #ifdef APOXI_ARAGON_SUPPORT
00025 static const WString c_aragon_menu_filename = L"/ffs/dynamic_menu_pool.rc";
00026 #endif
00027
00028
00034 class AtlConfig {
00035     friend class ContextManager;
00036
00037     public:
00039         static PropertyEditor* CreateEditor(const PropertyEditorID& id);
00040
00042         static MenuPool* GetMenuPool();
00043
00045         static FeatureItem* GetPlatformFeatureItem(FeatureID& featureID);
00046
00047     private:
00048         AtlConfig();
00049
00050         enum FeatureIds {
00051             TriggerSelect,
00052             TriggerBack,
00053             TriggerClose,
00054             TriggerCancel,
00055             TriggerConfirm,
00056             TriggerDelete,
00057             CloseAll,
00058             FeatureCnt
00059         };
00060
00061         static void SetPlatformFeaturesEnabled(BOOLEAN enabled);
00062         static KeyCode GetKeyCode(INT feature_id);
00063
00064         static FeaturePool       m_default_feature_pool;
00065         static TriggerKeyFeature m_trigger_keys[FeatureCnt - 1];
00066         static BackToIdleFeature m_close_all_feature;
00067         static FeatureItem m_feature_items[FeatureCnt];
00068         static const CHAR* m_feature_ids[FeatureCnt - 1];
00069         static const CHAR* m_feature_texts[FeatureCnt];
00070 };
00071
00073 #endif  // Atl_AtlConfig_hpp
00074
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplayConfig.hpp File Reference

DisplayConfig.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for DisplayConfig.hpp:

Go to the source code of this file.

Data Structures

class | DisplayConfig

Defines

#define | Apoxi_DisplayConfig_hpp

Define Documentation

#define Apoxi_DisplayConfig_hpp

Generated on Wed Jan 25 00:53:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplayConfig.hpp Source File

DisplayConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DisplayConfig_hpp)
00011 #define Apoxi_DisplayConfig_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017 struct ColorTable;
00018 struct ColorSegmentation;
00019
00025 class DisplayConfig {
00026     public:
00031         static UINT8 GDI_HUGE* GetFrameBuffer(INT display_idx);
00032
00041         static UINT8 GDI_HUGE* GetTransferBuffer(INT display_idx);
00042
00048         static UINT8 GDI_HUGE* GetMaskBuffer(INT display_idx);
00049
00052         static INT GetDisplayCount();
00053
00055         static XYDIM GetWidth(INT display_idx);
00056
00058         static XYDIM GetHeight(INT display_idx);
00059
00062         static INT GetBitsPerPixel(INT display_idx);
00063
00067         static BOOLEAN PlanesMode(INT display_idx);
00068
00072         static const ColorTable& GetColorTable(INT display_idx);
00073
00075         static const ColorSegmentation& GetColorSegmentation(INT display_idx);
00076 };
00077
00079 #endif  // Apoxi_DisplayConfig_hpp
00080
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditConfig.hpp File Reference

EditConfig.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for EditConfig.hpp:

Go to the source code of this file.

Data Structures

class | EditConfig

Defines

#define | Apoxi_EditConfig_hpp

Typedefs

typedef Vector< InputMapperFactory * > | InputMapperVector

Define Documentation

#define Apoxi_EditConfig_hpp

Generated on Wed Jan 25 00:53:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditConfig.hpp Source File

EditConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_EditConfig_hpp)
00011 #define Apoxi_EditConfig_hpp
00014
00015 /*  Do not change this header file. Each class in the configuration-lib must
00016     stay binary-compatible with Apoxi.  */
00017
00018 #include <Kernel/Types.hpp>
00019
00020 class InputMapper;
00021 class InputMapperFactory;
00022 typedef Vector<InputMapperFactory*> InputMapperVector;
00023
00029 class EditConfig {
00030     public:
00032         static UINT32 GetBlinkRate();
00033
00035         static UINT32 GetPagingTimeout();
00036
00038         static WCHAR GetDtmfSeparator();
00039
00041         static WCHAR GetWildcard();
00042
00047         static InputMapper* AllocInputMapper(INT input_mapper_id);
00048
00049     private:
00051         static InputMapperVector m_imfv;
00052 };
00053
00055 #endif  // Apoxi_EditConfig_hpp
00056
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FontConfig.hpp File Reference

FontConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/ThaiTextRenderer.hpp>

Include dependency graph for FontConfig.hpp:

Go to the source code of this file.

Data Structures

class | FontConfig

Defines

#define | Apoxi_FontConfig_hpp

Define Documentation

#define Apoxi_FontConfig_hpp

Generated on Wed Jan 25 00:53:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FontConfig.hpp Source File

FontConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FontConfig_hpp)
00011 #define Apoxi_FontConfig_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/ThaiTextRenderer.hpp>
00017
00018 class Font;
00019
00025 class FontConfig {
00026     public:
00028         static const Font& GetFont(INT idx);
00029
00031         static INT GetFontCount();
00032
00035         static ThaiTextRenderer::ThaiFontHint* GetThaiFontHints(const Font& font);
00036 };
00037
00039 #endif  // Apoxi_FontConfig_hpp
00040
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiEngineConfig.hpp File Reference

GuiEngineConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/ScrollBehavior.hpp>
#include <Gui/IconState.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Gui/Size.hpp>

Include dependency graph for GuiEngineConfig.hpp:

Go to the source code of this file.

Data Structures

class | GuiEngineConfig

Defines

#define | Apoxi_GuiEngineConfig_hpp

Define Documentation

#define Apoxi_GuiEngineConfig_hpp

Generated on Wed Jan 25 00:53:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiEngineConfig.hpp Source File

GuiEngineConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_GuiEngineConfig_hpp)
00011 #define Apoxi_GuiEngineConfig_hpp
00014
00015 class AbstractItemRenderer;
00016 class ItemRendererProperties;
00017 class AbstractTextRenderer;
00018
00019 #include <Kernel/Types.hpp>
00020 #include <Gui/ScrollBehavior.hpp>
00021 #include <Gui/IconState.hpp>
00022 #include <Gui/ImageObtainer.hpp>
00023 #include <Gui/Size.hpp>
00024
00030 class GuiEngineConfig {
00031     public:
00035         static ScrollBehavior GetScrollBehavior();
00036
00040         static UINT32 GetSharedImageBufferMax();
00041
00047         static UINT32 GetImageBufferMax();
00048
00051         static AbstractItemRenderer* ObtainItemRenderer(const ItemRendererProperties* properties = 0);
00052
00054         static void ReleaseItemRenderer(AbstractItemRenderer* renderer);
00055
00058         static const ItemRendererProperties* GetDefaultItemRendererProperties();
00059
00061         static Size GetIconSize(IconState::Size size);
00062
00065         static AbstractTextRenderer& GetTextRenderer(LanguageManager::LanguageType language_id);
00066
00070         static const ColorValue* GetIconColorTable();
00071 };
00072
00074 #endif  // Apoxi_GuiEngineConfig_hpp
00075
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiObjectFactory.hpp File Reference

GuiObjectFactory.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for GuiObjectFactory.hpp:

Go to the source code of this file.

Data Structures

class | GuiObjectFactory

Defines

#define | Apoxi_GuiObjectFactory_hpp

Define Documentation

#define Apoxi_GuiObjectFactory_hpp

Generated on Wed Jan 25 00:53:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiObjectFactory.hpp Source File

GuiObjectFactory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_GuiObjectFactory_hpp)
00011 #define Apoxi_GuiObjectFactory_hpp
00014
00015 class ResourceParser;
00016 class CTResourceParser;
00017 class GuiObjectDescr;
00018 class CTResourcePack;
00019 class WString;
00020
00021 #include <Kernel/Types.hpp>
00022 #include <Auxiliary/Vector.hpp>
00023
00024
00027 class GuiObjectFactory {
00028     public:
00051         enum ClassType {
00052             UnknownClassType = 255,
00053             ObjectReference = 0,
00054             AlertClassType = 1,
00055             AnimatedTextLineClassType = 2,
00056             CheckBoxControlClassType = 3,
00057             ContextMenuClassType = 4,
00058             DateEditorClassType = 5,
00059             ImageBoxClassType = 6,
00060             IpAddrEditorClassType = 7,
00061             ItemGridClassType = 8,
00062             ItemMenuClassType = 9,
00063             ItemTreeClassType = 10,
00064             LayouterControlClassType = 11,
00065             LineEditorClassType = 12,
00066             MessageBoxClassType = 13,
00067             MultiLineEditorClassType = 14,
00068             MultiMediaEditorClassType = 15,
00069             PasswordEditorClassType = 16,
00070             ProgressBarClassType = 17,
00071             PushButtonClassType = 18,
00072             RadioButtonControlClassType = 19,
00073             RadioButtonGroupClassType = 20,
00074             TextLineClassType = 21,
00075             TimeEditorClassType = 22,
00076             WindowClassType = 23,
00077             ItemMenuWindowClassType = 24,
00078             AtlWindowClassType = 25,
00079             AbstractEditorClassType = 26,
00080             AbstractGridClassType = 27,
00081             AbstractItemContainerClassType = 28,
00082             AbstractItemGridClassType = 29,
00083             AbstractLineEditorClassType = 30,
00084             AbstractMultiLineEditorClassType = 31,
00085             AbstractPredictiveInputBoxClassType = 32,
00086             AbstractTextObjectClassType = 33,
00087             ActionClassType = 34,
00088             ComponentClassType = 35,
00089             ControlClassType = 36,
00090             DispatcherClassType = 37,
00091             DrawableObjectClassType = 38,
00092             ImageObtainerClassType = 39,
00093             ItemClassType = 40,
00094             ItemContainerClassType = 41,
00095             ItemRendererPropertiesClassType = 42,
00096             PositionIndicatorClassType = 43,
00097             TextFormatClassType = 44,
00098             MenuDescClassType = 45,
00099             MenuPropertiesClassType = 46,
00100             FeatureItemContainerClassType = 47,
00101             MenuMapClassType = 48,
00102             PropertyContainerClassType = 49,
00103             FeatureItemClassType = 50,
00104             TextBoxClassType = 51,
00105             CloseWindowActionClassType = 52,
00106             OpenWindowActionClassType = 53,
00107             RadioButtonActionClassType = 54,
00108             ContextFeatureItemClassType = 55,
00109             MenuResourceTableType = 56,
00110             CtResourcePackClassType = 57,
00111             PropertyItemClassType = 58,
00112             ItemBoxClassType = 59,
00113             IndicatorItemClassType = 60,
00114             PropertyDescriptorClassType = 61,
00115             AtlItemBoxClassType = 62,
00116             ValueMappingPropertyDescriptorClassType = 63,
00117             MappingPolicyClassType = 64,
00118             RangeMappingPolicyClassType = 65,
00119             ProgressPropertyDescriptorClassType = 66,
00120             PasswordPropertyDescriptorClassType = 67
00121         };
00122
00127         enum PropertyId {
00128             UnknownProp = 255,
00129             DelayProp = 0,
00130             TextProp = 1,
00131             TextFormatProp = 2,
00132             TextLineAnimTypeProp = 3,
00133             StartDelayProp = 4,
00134             AnimSpeedProp = 5,
00135             StepProp = 6,
00136             BoundsProp = 7,
00137             SelectedProp = 8,
00138             XProp = 9,
00139             YProp = 10,
00140             CornerProp = 11,
00141             ItemContProp = 12,
00142             DateProp = 13,
00143             ObtainerProp = 14,
00144             AutostartProp = 15,
00145             BufferingProp = 16,
00146             IpAddrProp = 17,
00147             ColumnCountProp = 18,
00148             AdjustWinTitleProp = 19,
00149             RowCountProp = 20,
00150             ColCountProp = 21,
00151             MinSizeProp = 22,
00152             CellsProp = 23,
00153             RowPropertiesProp = 24,
00154             ColumnPropertiesProp = 25,
00155             MaxTextLengthProp = 26,
00156             FontProp = 27,
00157             TypeProp = 28,
00158             TitleProp = 29,
00159             MessageProp = 30,
00160             ReadOnlyProp = 31,
00161             LineHeightProp = 32,
00162             TextAttrProp = 33,
00163             ForegroundcolorProp = 34,
00164             BackgroundcolorProp = 35,
00165             TopLineGapProp = 36,
00166             BottomLineGapProp = 37,
00167             ProgressProp = 38,
00168             RadioButtonGroupProp = 39,
00169             VerticalCenteredProp = 40,
00170             TimeProp = 41,
00171             FocusPriorityProp = 42,
00172             SkActionsProp = 43,
00173             LeftSoftkeyProp = 44,
00174             RightSoftkeyProp = 45,
00175             MenuIdProp = 46,
00176             ActionProp = 47,
00177             InputMapperIdProp = 48,
00178             ItemProp = 49,
00179             RendererPropertiesProp = 50,
00180             PositionIndicatorEnabledProp = 51,
00181             MEditorProp = 52,
00182             ModeProp = 53,
00183             ColorProp = 54,
00184             FrameTypeProp = 55,
00185             AutoClearEnabledProp = 56,
00186             MaximizedProp = 57,
00187             EnabledProp = 58,
00188             DisabledProp = 59,
00189             DisplayIdxProp = 60,
00190             ComponentsProp = 61,
00191             AutoLayoutProp = 62,
00192             ImageUriProp = 63,
00193             IconProp = 64,
00194             SyncModeEnabledProp = 65,
00195             ItemRendererDisplayTypeProp = 66,
00196             ItemRendererAnimTypeProp = 67,
00197             ScrollDelayProp = 68,
00198             ScrollGapProp = 69,
00199             FullScreenPerItemProp = 70,
00200             TransparentProp = 71,
00201             MultiLineProp = 72,
00202             CenteredVerticalProp = 73,
00203             IndicateItemContProp = 74,
00204             BackgrColorProp = 75,
00205             HeightProp = 76,
00206             GapProp = 77,
00207             OrientationProp = 78,
00208             MinValueProp = 79,
00209             MaxValueProp = 80,
00210             VisibleValuesCountProp = 81,
00211             ValueProp = 82,
00212             TextAlignProp = 83,
00213             FontAlignProp = 84,
00214             FeatureItemContainerProp = 85,
00215             MenuPropertiesProp = 86,
00216             MenuTypeProp = 87,
00217             FeatureItemContainerIdProp = 88,
00218             ItemsProp = 89,
00219             MenuPositionProp = 90,
00220             ActualViewProp = 91,
00221             EndUserDefineableViewsProp = 92,
00222             IsEndUserDefineableProp = 93,
00223             DefaultViewProp = 94,
00224             MenuMapMenuIdsProp = 95,
00225             MenuMapMenuDescProp = 96,
00226             PropertyListProp = 97,
00227             AppIdProp = 98,
00228             FeatureIdProp = 99,
00229             StartAnimationProp = 100,
00230             WindowProp = 101,
00231             ModalProp = 102,
00232             DispatcherProp = 103,
00233             PosProp = 104,
00234             ItemRendererProp = 105,
00235             ContextItemProp = 106,
00236             CloseAfterTriggerProp = 107,
00237             MenuResourceTableEntryProp = 108,
00238             LargeIconProp = 109,
00239             MenuResourceTableSizeProp = 110,
00240             MenuResourceTableEntryResourceIdProp = 111,
00241             MenuResourceTableEntryMenuIdProp = 112,
00242             IsSeparatorProp = 113,
00243             PropertyItemEditorProp = 114,
00244             PropertyItemTypeProp = 115,
00245             FeatureKeyProp = 116,
00246             PropertyDescriptorProp = 117,
00247             LabelProp = 118,
00248             TextIconPairCountProp = 119,
00249             TextIconPairProp = 120,
00250             MappingPolicyProp = 121,
00251             RangeCountProp = 122,
00252             IconValueMapProp = 123,
00253             BackgroundImageProp = 124,
00254             FrameLayoutHintProp = 125,
00255             ParentAreaProp = 126,
00256             HorizontalProp = 127,
00257             AlignInfoProps = 128,
00258             PropCount = 129     // mandatory last entry
00259         };
00260
00263         enum ParseType {
00264             UnknownType,
00265             BooleanType,
00266             XyDimType,
00267             IntegerType,
00268             UInt8Type,
00269             UInt16Type,
00270             WStringType,
00271             StringType,
00272             ColorType,
00273             RectType,
00274             IpAddrType,
00275             DateType,
00276             TimeType,
00277             SizeType,
00278             PositionType,
00279             FrameType,
00280             ParentAreaType,
00281             CornerType,
00282             TextAttrType,
00283             TextAlignType,
00284             FontAlignType,
00285             AnimatedTextLineAnimType,
00286             MessageBoxType,
00287             InputMapperIdType,
00288             PredInputMapperPredModeType,
00289             ItemRendererPropertiesType,
00290             ItemRendererPropertiesDisplayType,
00291             ItemRendererPropertiesAnimType,
00292             PositionIndicatorOrientationType,
00293             MenuType,
00294             FontSystemFontIdType,
00295             CellPropsType,
00296             RowColumnPropType,
00297             FeatureKeyType,
00298             TextIconPairType,
00299             AlignInfoPropsType
00300         };
00301
00310         static void* Create(ResourceParser& parser, const GuiObjectDescr& descr);
00311
00323         static BOOLEAN Destroy(void* instance, GuiObjectFactory::ClassType class_type, BOOLEAN force);
00324
00337         static BOOLEAN Finalize(void* src_gui_obj,
00338                                 GuiObjectFactory::ClassType src_class_type,
00339                                 void* target_gui_obj,
00340                                 GuiObjectFactory::PropertyId prop_id);
00341
00345         static BOOLEAN IsComponent(ClassType class_type);
00346
00351         static GuiObjectFactory::ClassType MapBinaryIdToClassType(UINT8 class_id);
00352
00357         static GuiObjectFactory::PropertyId MapBinaryIdToPropertyId(UINT8 prop_id);
00358
00365         static GuiObjectFactory::ParseType MapPropertyIdToParseType(const GuiObjectFactory::PropertyId property_id);
00366
00376         static BOOLEAN GetPropertyValue(ResourceParser& parser,
00377                                         GuiObjectFactory::ParseType parse_type, void* value);
00378
00386         static CTResourcePack* CreateCtResourcePack(CTResourceParser& parser, UINT16 id);
00387 };
00388
00390 #endif  // Apoxi_GuiObjectFactory_hpp
00391
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyboardConfig.hpp File Reference

KeyboardConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/InputMap.hpp>

Include dependency graph for KeyboardConfig.hpp:

Go to the source code of this file.

Data Structures

class | KeyboardConfig

Defines

#define | Apoxi_KeyboardConfig_hpp

Define Documentation

#define Apoxi_KeyboardConfig_hpp

Generated on Wed Jan 25 00:53:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyboardConfig.hpp Source File

KeyboardConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_KeyboardConfig_hpp)
00011 #define Apoxi_KeyboardConfig_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/InputMap.hpp>
00017
00023 class KeyboardConfig {
00024     public:
00026         static KeyCode GetArrowLeft();
00027
00029         static KeyCode GetArrowRight();
00030
00032         static KeyCode GetArrowUp();
00033
00035         static KeyCode GetArrowDown();
00036
00038         static KeyCode GetSoftkey(INT index);
00039
00041         static INT GetSoftkeyCount();
00042
00044         static KeyCode GetNumber(UINT8 number);
00045
00047         static KeyCode GetGreenKey();
00048
00050         static KeyCode GetRedKey();
00051
00053         static KeyCode GetDeleteKey();
00054
00057         static KeyCode GetCustomKey(WCHAR custom_key);
00058
00060         static INT GetAutorepeatDelay();
00061
00063         static INT GetAutorepeatInterval();
00064
00066         static INT GetLongKeyDelay();
00067
00069         static INT GetVeryLongKeyDelay();
00070
00072         static const InputMap& GetInputMap(INT index);
00073
00075         static KeyCode GetHeadsetKey();
00076
00078         static KeyCode GetOptionKey();
00079
00081         static KeyCode GetSelectKey();
00082
00084         static KeyCode GetBackKey();
00085
00087         static KeyCode GetCloseKey();
00088
00090         static KeyCode GetCancelKey();
00091
00093         static KeyCode GetClearAllKey();
00094
00096         static KeyCode GetInputTogglingKey();
00097
00099         static KeyCode GetConfirmKey();
00100 };
00101
00103
00104 #endif  // Apoxi_KeyboardConfig_hpp
00105
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocaleConfig.hpp File Reference

LocaleConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Locale.hpp>

Include dependency graph for LocaleConfig.hpp:

Go to the source code of this file.

Data Structures

class | LocaleConfig

Defines

#define | Apoxi_LocaleConfig_hpp

Define Documentation

#define Apoxi_LocaleConfig_hpp

Generated on Wed Jan 25 00:53:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocaleConfig.hpp Source File

LocaleConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_LocaleConfig_hpp)
00011 #define Apoxi_LocaleConfig_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Locale.hpp>
00017
00018 struct PagingMap;
00019
00025 class LocaleConfig {
00026     public:
00028         static INT GetSettingsCount();
00029
00033         static const Locale::LocaleData& GetSetting(INT idx);
00034
00036         static INT GetLanguageCount();
00037
00044         static INT GetLanguageId(const WCHAR* iso2_code);
00045
00051         static LanguageManager::LanguageType GetLanguageType(INT lang_id);
00052
00055         static INT GetStringCount();
00056
00058         static const WCHAR* const* GetTranslationTable();
00059
00061         static const PagingMap& GetPagingMap(INT idx);
00062 };
00063
00065 #endif  // Apoxi_LocaleConfig_hpp
00066
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MemoryConfig.hpp File Reference

MemoryConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/HeapVector.hpp>

Include dependency graph for MemoryConfig.hpp:

Go to the source code of this file.

Data Structures

class | MemoryConfig

Defines

#define | Apoxi_MemoryConfig_hpp

Define Documentation

#define Apoxi_MemoryConfig_hpp

Generated on Wed Jan 25 00:53:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MemoryConfig.hpp Source File

MemoryConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MemoryConfig_hpp)
00011 #define Apoxi_MemoryConfig_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/HeapVector.hpp>
00017
00023 class MemoryConfig {
00024     public:
00027         static HeapVector::HeapTableEntry * GetHeapBase();
00028
00031         static BOOLEAN IsInRom(const void* ptr);
00032 };
00033
00035 #endif  // Apoxi_MemoryConfig_hpp
00036
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OptionalConfig.hpp File Reference

OptionalConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/OptionalConfigBase.hpp>

Include dependency graph for OptionalConfig.hpp:

Go to the source code of this file.

Data Structures

class | OptionalConfig

Defines

#define | Apoxi_OptionalConfig_hpp

Define Documentation

#define Apoxi_OptionalConfig_hpp

Generated on Wed Jan 25 00:53:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OptionalConfig.hpp Source File

OptionalConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_OptionalConfig_hpp)
00011 #define Apoxi_OptionalConfig_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/OptionalConfigBase.hpp>
00017
00029 class OptionalConfig : public OptionalConfigBase {
00030     public:
00034         static BOOLEAN GetSetting(INT group_id, INT setting_id, INT &result);
00035 };
00036
00038 #endif  // Apoxi_OptionalConfig_hpp
00039
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9InputConfig.hpp File Reference

T9InputConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/T9/T9Wrapper.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>

Include dependency graph for T9InputConfig.hpp:

Go to the source code of this file.

Data Structures

class | T9InputConfig

Defines

#define | Apoxi_T9InputConfig_hpp

Define Documentation

#define Apoxi_T9InputConfig_hpp

Generated on Wed Jan 25 00:53:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9InputConfig.hpp Source File

T9InputConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_T9InputConfig_hpp)
00011 #define Apoxi_T9InputConfig_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/T9/T9Wrapper.hpp>
00017 #include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
00018
00019 class Font;
00020
00026 class T9InputConfig {
00027     public:
00029         enum T9FunctionCode {
00030             MenuFunction,
00031             NextFunction,
00032             PreviousFunction,
00033             ShiftFunction,
00034             SpaceFunction,
00035             SymbolEntryRequestFunction, // used with longpress to open a window where symbols can be picked
00036             ToggleNumericModeFunction // used with longpress to switch to numeric mode
00037         };
00038
00040         static const Font& GetFont(AbstractPredictiveInputBox::PredFontId pred_font_id);
00041
00043         static const BitmapRes* GetBitmap(AbstractPredictiveInputBox::PredBitmapId pred_bitmap_id);
00044
00047         static KeyCode GetKeyForFunction(T9FunctionCode function_code);
00048
00050         static WCHAR GetObjectReplacementCharacter () { return 0x0FFFC; }
00051
00052         static WCHAR GetStroke(INT stroke);
00053
00054         static WCHAR GetSymbol(UINT8 row, UINT8 page);
00055
00057         static UINT8 GetSymbolRows();
00058
00060         static UINT8 GetSymbolPages();
00061
00065         static CHAR* LoadT9Udb(UINT16& data_size);
00066
00067         static void SaveT9Udb();
00068
00069         static INT GetT9BufferSize();
00070
00071         static INT GetT9UdbSize();
00072
00073 #if defined(APOXI_COMPAT_2_7_0)
00074
00075         static KeyCode GetT9NextKey();
00076 #endif
00077         static const UINT8 c_t9_symbol_rows;
00078         static const UINT8 c_t9_symbol_pages;
00079 };
00080
00082 #endif  // Apoxi_T9InputConfig_hpp
00083
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThemeConfig.hpp File Reference

ThemeConfig.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ThemeConfig.hpp:

Go to the source code of this file.

Data Structures

class | ThemeConfig

Defines

#define | Apoxi_ThemeConfig_hpp

Define Documentation

#define Apoxi_ThemeConfig_hpp

Generated on Wed Jan 25 00:53:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThemeConfig.hpp Source File

ThemeConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ThemeConfig_hpp)
00011 #define Apoxi_ThemeConfig_hpp
00014
00015 class Theme;
00016 #include <Kernel/Types.hpp>
00017
00023 class ThemeConfig {
00024     public:
00027         static const Theme& GetTheme(INT idx);
00028
00031         static INT GetThemeCount();
00032
00039         static INT GetFontId(SystemFontId id, const Theme &theme);
00040 };
00041
00043 #endif  // Apoxi_ThemeConfig_hpp
00044
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8InputConfig.hpp File Reference

Zi8InputConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>

Include dependency graph for Zi8InputConfig.hpp:

Go to the source code of this file.

Data Structures

class | Zi8InputConfig

Defines

#define | Apoxi_Zi8InputConfig_hpp

Define Documentation

#define Apoxi_Zi8InputConfig_hpp

Generated on Wed Jan 25 00:53:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8InputConfig.hpp Source File

Zi8InputConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Zi8InputConfig_hpp)
00011 #define Apoxi_Zi8InputConfig_hpp
00014
00015 /*  Do not change this header file. Each class in the configuration-lib must
00016     stay binary-compatible with Apoxi.  */
00017
00018 #include <Kernel/Types.hpp>
00019 #include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
00020
00021 class Font;
00022
00028 class Zi8InputConfig {
00029     public:
00030         static const Font& GetFont(AbstractPredictiveInputBox::PredFontId pred_font_id);
00031         static const BitmapRes* GetBitmap(AbstractPredictiveInputBox::PredBitmapId pred_bitmap_id);
00032         static const WCHAR GetStroke(const INT stroke);
00033         static const WCHAR* GetSymbolCandidates();
00034         static const UINT8 GetSymbolCandidatesLength();
00035         static CHAR* LoadZi8Udb(UINT16& data_size);
00036         static void SaveZi8Udb();
00037 };
00038
00040 #endif  // Apoxi_Zi8InputConfig_hpp
00041
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: apoxi.defines File Reference

apoxi.defines File Reference

Defines

#define | APOXI_3D_AMPLIFIER_SUPPORT
Adds the themes 'Foggy Theme' and 'Customizable Theme'.
#define | APOXI_3GPP_REL_4_5
Stack interface define to support 3GPP Release 4/5
#define | APOXI_3GPP_REL_99
Stack interface define to support 3GPP Release 99
#define | APOXI_ADC_CCP_CODE
Temporary test code for CCP access
#define | APOXI_ADC_SIMTK_PROACTIVE_CODE
Temporary code for Simtk simulation triggering
#define | APOXI_ADDITIONAL_THEMES_SUPPORT
Adds the themes 'Foggy Theme' and 'Customizable Theme'.
#define | APOXI_ALARMMANAGER_MAX_ENTRIES
Maximum number of different ExecutionContext's (Applications) which accesses AlarmManger
#define | APOXI_APN_NAME_LEN_MAX
Brief description
#define | APOXI_APPLICATION_TRACER_MAX_APPS
Brief description
#define | APOXI_ARAGON_MAX_BUFFER_SIZE
Describes the buffer size for the communication with the ARAGON Tool.
#define | APOXI_ARAGON_SUPPORT
Enables support for ARAGON.
#define | APOXI_AT_KEY_PARSER_TEST
Brief description
#define | APOXI_AT_MMI_INTERWORKING_CALL
Call interworking with other clients.
#define | APOXI_AT_MMI_INTERWORKING_REJECT
Brief description
#define | APOXI_AT_MMI_INTERWORKING_SIMTK
SIMTK interworking with other clients.
#define | APOXI_AT_MMI_INTERWORKING_SS
SS interworking with other clients.
#define | APOXI_AT_MMI_INTERWORKING_USSD
USSD interworking with other clients.
#define | APOXI_ATL_SUPPORT
Enables support for ATL.
#define | APOXI_AUX_CHINESEQUICKSORT_DEBUG
Brief description
#define | APOXI_AUX_QUICKSORT_DEBUG
Brief description
#define | APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX
Brief description
#define | APOXI_BEARER_PROFILE_NAME_LEN_MAX
Brief description
#define | APOXI_BEARER_PROFILE_PASSWD_LEN_MAX
Brief description
#define | APOXI_BIG_ENDIAN
Define for Big Endian support.
#define | APOXI_BLUETOOTH
Brief description
#define | APOXI_BT_A2DP_SUPPORT
Bluetooth Advanced Audio Distribution Profile
#define | APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY
Default security settings for OBEX client connections over Bluetooth
#define | APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY
Default security settings for OBEX services over Bluetooth
#define | APOXI_BYTEBUFFER_TEST_SUITE
Brief description
#define | APOXI_CACHED_POLYGON_EDGES_MAX
Defines the maximum numbers of edges a polygon may have on the stack.
#define | APOXI_CAMERA_MPE_COMPAT
Backwards compat define for MPE camera features
#define | APOXI_CAMERA_SUPPORT
Enables the support for the still camera and video camera device.
#define | APOXI_CAMERA_TWINVIEWFINDER_SUPPORT
TwinViewfinder
#define | APOXI_CAMERA_WIN32
Brief description
#define | APOXI_CBS_DEFAULT_ACTIVE_TIMER
Default value of the active timer value for the CBS subsystem
#define | APOXI_CBS_DEFAULT_SLEEP_TIMER
Default value of the sleep timer value for the CBS subsystem
#define | APOXI_CBS_LIMITATION_MSG
Enables support of the MN_SMS_CB_MESSAGE_ID_LIMIT_IND signal Enables the support of the MN_SMS_CB_MESSAGE_ID_LIMIT_IND signal which indicates the maximum ranges of possible message IDs. This value is then posted via the message CbsLimitMsg.
#define | APOXI_CINGULAR_INPUT_TEST
shall not be set manually
#define | APOXI_COMPAT_1_11_0
Compatibility define for APOXI_1.11.0
#define | APOXI_COMPAT_1_12_0
Compatibility define for APOXI_1.12.0
#define | APOXI_COMPAT_1_13_0
Compatibility define for APOXI_1.13.0
#define | APOXI_COMPAT_1_7_0
Compatibility define for APOXI_1.7.0
#define | APOXI_COMPAT_1_8_0
Compatibility define for APOXI_1.8.0
#define | APOXI_COMPAT_1_9_0
Compatibility define for APOXI_1.9.0
#define | APOXI_COMPAT_2_0_0
Compatibility define for APOXI_2.0.0
#define | APOXI_COMPAT_2_1_0
Compatibility define for APOXI_2.1.0
#define | APOXI_COMPAT_2_2_0
Compatibility define for APOXI_2.2.0
#define | APOXI_COMPAT_2_3_0
Compatibility define for APOXI_2.3.0
#define | APOXI_COMPAT_2_4_0
Compatibility define for APOXI_2.4.0
#define | APOXI_COMPAT_2_6_0
Compatibility define for APOXI_2.6.0
#define | APOXI_COMPAT_2_7_0
Compatibility define for APOXI_2.7.0
#define | APOXI_COMPAT_2_8_0
Compatibility define for APOXI_2.8.0
#define | APOXI_COMPAT_2_9_0
Compatibility define for APOXI_2.9.0
#define | APOXI_COMPILER_ADS
Compiler define for ARM Developer Suite (ADS) compiler
#define | APOXI_COMPILER_C166
Compiler define for Tasking C166 compiler
#define | APOXI_COMPILER_MSVC
Compiler define for Microsoft Visual C/C++ (MSVC) compiler
#define | APOXI_COMPILER_RVCT
Compiler define for RealView Compilation Tools (RVCT) compiler
#define | APOXI_CONFIG_DBG_OUT_RANGE_ARRAY
Defines the amount of possible DBG_OUT Id Ranges on target.
#define | APOXI_CRASH_DEBUG
Brief description
#define | APOXI_CTM
Activate TTY.
#define | APOXI_DATA_CONN_PROFILE_COUNT
Brief description
#define | APOXI_DATA_CONN_TEMP_PROFILE_COUNT
Brief description
#define | APOXI_DEBUG_IMAGE_DECODING
Decreases the performance of image decoding to relieve debugging.
#define | APOXI_DISABLE_CPP_CASTS
Brief description
#define | APOXI_DISABLE_ENLARGED_GRID_SELECTION
Disables the possibility of having an enlarged grid selection.
#define | APOXI_DISABLE_FILTERED_SMS_PROVIDERS
Disables certain SmsProviders via define.
#define | APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING
Disables the recursive QuickSort algorithm of the QuickSortProvider.
#define | APOXI_DISABLE_SOFTKEYBAR
Disables the obsolete softkey bar.
#define | APOXI_DISABLE_TAB_CONTROL
Disables the tab control.
#define | APOXI_DISPLAY_16BPP
Must be defined if the display is organized as 16 bits per pixel.
#define | APOXI_DISPLAY_24BPP
Must be defined if the display is organized as 24 bits per pixel.
#define | APOXI_DISPLAY_32BPP
Must be defined if the display is organized as 24 bits per pixel.
#define | APOXI_DISPLAY_8BPP
#define | APOXI_DISPLAY_FORMAT_BIG_ENDIAN
Must be defined if the pixels of the display are organized in big endian.
#define | APOXI_DISPLAY_PLANES
Must be set if the display is organized in planes format or is monochrome.
#define | APOXI_DR_SMSR_SCA_BUG_NOT_FIXED
Brief description
#define | APOXI_DUAL_DISPLAY_SUPPORT
Enables dual display support for the default DisplayConfig class.
#define | APOXI_EM_CONTROL_ENABLED
Engineering mode control
#define | APOXI_ENABLE_ADVANCED_TRANSLATION
Enables the advanced translation format.
#define | APOXI_ENABLE_ALPHA_BLENDING
Enables the alpha blending for drawing operations.
#define | APOXI_ENABLE_ANIMATED_TITLE
Enables support for animated titles inside a window.
#define | APOXI_ENABLE_ARC_DRAWING
Enables the drawing of Arcs.
#define | APOXI_ENABLE_C166_APOXIGUI_RAMCODE
Enables the execution of some gif decoding routines in internal RAM (for C166-based chipsets only)
#define | APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE
Enables the execution of display device code in internal RAM (for C166-based chip sets only)
#define | APOXI_ENABLE_C166_GIFDECODER_RAMCODE
Enables the execution of some gif decoding routines in internal RAM (for C166-based chipsets only)
#define | APOXI_ENABLE_C166_HUGEBITMAP_DRAW
Enables the draw of huge bitmaps (>64kbyes of data, for C166-based chip sets only)
#define | APOXI_ENABLE_C166_RECT_RAMCODE
Enables the execution of Rect class methods (Rect.cpp) in internal RAM (for C166-based chip sets only)
#define | APOXI_ENABLE_CBS_ACTIVE_TIMER_INTERFACE
Support of the active timer value of stack
#define | APOXI_ENABLE_CIRCLE_DRAWING
Enables the drawing of circles.
#define | APOXI_ENABLE_CONC_SMS_SCA_CHECK
Enables checking of the SCA in case of Concatenated SMS Enables checking of the SCA in case of Concatenated SMS, this means if the define is set also the SCA of a SMS will be used for checking if a TPDU belongs to a concatenated SMS.
#define | APOXI_ENABLE_DBG_OUT
Enables the output of debugging information.
#define | APOXI_ENABLE_DIAGONAL_LINE_DRAWING
Enables the drawing of diagonal lines.
#define | APOXI_ENABLE_ECC_CUSTOMIZATION
Support of the ECC code customization
#define | APOXI_ENABLE_GSM_BITMAP_DRAWING
Enables the drawing of GSM bitmaps.
#define | APOXI_ENABLE_JAPANESE_TRANSCODER
Enables the Japanese transcoder, which allows to convert text stored in the UCS-2 format to and from SJIS, JIS or EUC.
#define | APOXI_ENABLE_ME_PHONEBOOK_REQUEST
Support of the ATC ME phonebook requests
#define | APOXI_ENABLE_MOC_CALL_RESTRICTION
Enables MOC call restriction.
#define | APOXI_ENABLE_OBSOLETE_STRING_INTERFACE
Brief description
#define | APOXI_ENABLE_OBSOLETE_WSTRING_INTERFACE
Brief description
#define | APOXI_ENABLE_POLYGON_DRAWING
Enables the drawing of polygons.
#define | APOXI_ENABLE_POSITION_PREVIEW
Enables the preview of the menu position inside the title bar of a window.
#define | APOXI_ENABLE_R2L_TEST
Treats A - Z as right to left characters.
#define | APOXI_ENABLE_RUNTIME_CONFIGURATION
Runtime configuration (e.g. via AT commands)
#define | APOXI_ENABLE_SDL_SIGNAL_SIGNATURE_CHECK
SDL signal signature check
#define | APOXI_ENABLE_SMOOTH_SCROLLING
Enables a smooth scrolling for menus and lists.
#define | APOXI_ENABLE_STACK_CHECK
Enables checking the system stack inside APOXI application containers.
#define | APOXI_ENABLE_SVG_FONT_SERIALIZATION
Enables engine mode for doing font serialization.
#define | APOXI_ENABLE_SVG_SYSTEM_FONTS
Enables support for system fonts in SVG engine.
#define | APOXI_ENABLE_TIMING_MEASUREMENTS
Enables the usage of class DbgTimingMeasurement.
#define | APOXI_ENABLE_TRAP_INFO_SCREEN
Redirects trap output to main display
#define | APOXI_ENABLE_USIM_PHONEBOOK
Enables the support of the USIM phonebook
#define | APOXI_ENALBE_NEW_STARTUP_INTERFACE
Brief description
#define | APOXI_EXTERNAL_PCH_CONTROL_SUPPORT
Enables external PCH control support.
#define | APOXI_FACTORY_CUSTOMIZATION_SUPPORT
Allows to use factory customized packs for languages and T9 dictionaries.
#define | APOXI_FFS_EXTENDED_DEBUG
Brief description
#define | APOXI_FFS_USER_MAPPING
Brief description
#define | APOXI_FM_RADIO_SUPPORT
FM radio support
#define | APOXI_FOTA_SUPPORT
Firmware update Over The Air
#define | APOXI_GDD_2_0_INTERFACE
If set, the APOXI display device will use the GDD 2.0 interface.
#define | APOXI_GDD_INTERFACE
Brief description
#define | APOXI_GTL_DIF
Brief description
#define | APOXI_GTL_EBU
Brief description
#define | APOXI_HEAP_CONTEXT_USAGE
shall not be set manually Adds a context vector per page which contains a context id of the object which is allocated, this is necessary for identification to which context an object belongs. Take into account that additional memory is used to held this context information.
#define | APOXI_HEAP_DISABLE_64K_ALIGNMENT
Disables the address alignment to 64 K addresses
#define | APOXI_HEAP_LENGTH_VECTOR
shall not be set manually
#define | APOXI_HEAP_LOG
Brief description
#define | APOXI_HEAP_MEM_ACCESS_CHECK
Enables checking wrong frees (double called) and memory overwrites Enables checking wrong frees (double called) and memory overwrites. Take into account that enabling this define will have impact on memory consumption and runtime. It is set automatically under Win32. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf
#define | APOXI_HEAP_MEM_ALLOC_TRACE
Enables trace output of each allocate and free call Enables trace output of each allocate and free call, shall be used only under Win32 because very much trace output is done.
#define | APOXI_HEAP_MEM_ASSERT_ON_FAILED_ALLOC
Enables throwing an assertion when no memory can be allocated Enables throwing an assertion when no memory can be allocated.
#define | APOXI_HEAP_MEM_CONTEXT_TRACE
Enables collecting information about allocation done by Apps/Threads Enables collecting information about allocation done by Apps/Threads. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf
#define | APOXI_HEAP_MEM_CONTEXT_TRACE_MAX_CTX
Number of maximum contexts which can be traced if APOXI_HEAP_MEM_CONTEXT_TRACE is set
#define | APOXI_HEAP_MEM_DETECT_CONFIG
Enables the detection of a suitable memory configuration For detailed description please refer to the document: UserGuide_MemoryManagement.pdf
#define | APOXI_HEAP_MEM_POOL_TRACE
Enables collecting information of memory pages Enables collecting information of memory pages and allow tracing out a visual view of all memory pages on the trace interface. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf
#define | APOXI_HEAP_NAME_USAGE
shall not be set manually Adds a character array per page which will be used for certain debug outputs. Take into account that additional memory is used to held this context information.
#define | APOXI_HEAP_STATS_USAGE
shall not be set manually Adds a statistics structure per page which will be used for certain debug outputs. Take into account that additional memory is used to held this context information.
#define | APOXI_HEAP_TEST
shall not be set manually
#define | APOXI_HOST_NAME_LEN_MAX
Brief description
#define | APOXI_HOST_USE_DUMMY_PCH
Brief description
#define | APOXI_HOST_USE_PCH_SIGNALS
Brief description
#define | APOXI_IANA_ALL_PORT_NUMBERS
Brief description
#define | APOXI_ICC_SIM
Define for support of the ICC SIM
#define | APOXI_ICC_USIM
Define for support of the ICC USIM
#define | APOXI_INCLUDE_DRM
Brief description
#define | APOXI_LED_NEW_INTERFACE
Enables new multi-color LED interface
#define | APOXI_LETTERCLASSE_SUPPORT
Brief description
#define | APOXI_LIB_ADDON_AFSFAT
Enables support for FAT devices
#define | APOXI_LIB_ADDON_AFSFFS
Brief description
#define | APOXI_LIB_ADDON_AFSRAM
Brief description
#define | APOXI_LIB_ADDON_AFSRFS
Brief description
#define | APOXI_LIB_ADDON_MMCALL
Multimedia Call Handling API
#define | APOXI_LIB_ADDON_VR
Brief description
#define | APOXI_LIB_BLUETOOTH
Brief description
#define | APOXI_LIB_IRDA
Brief description
#define | APOXI_LIB_OBEX
Brief description
#define | APOXI_LITTLE_ENDIAN
Define for Little Endian support.
#define | APOXI_MAX_DISPLAY_COUNT
Defines the maximum number of displays APOXI can handle at the same time.
#define | APOXI_MAX_INET_SOCKET_COUNT
Brief description
#define | APOXI_MAX_LANGUAGE_COUNT
Defines the maximum number of languages APOXI can handle at the same time.
#define | APOXI_MAX_SOFTKEY_COUNT
Defines the maximum number of softkeys.
#define | APOXI_MEM_TRACE
Brief description
#define | APOXI_MEMORY_WIN32_REDIRECT_HUGEALLOCATION
Enables Redirection of HugeAllocations to Allocations under Win32 Redirects HugeAllocations to Allocations under Win32.
#define | APOXI_MMCI_SUPPORT
Brief description
#define | APOXI_MP3_SUPPORT
MP3 support having codec available in the firmware
#define | APOXI_MSG_QUEUE_KEY_ENTRY_LIMIT
Limitation for queued key entries
#define | APOXI_MSG_QUEUE_YIELD_COUNTER
Counter for Yield calls in MsgQueue
#define | APOXI_MSG_QUEUE_YIELD_PERIOD
Time period for Yield calls in MsgQueue
#define | APOXI_MULTIMEDIA_SUPPORT
Enables the addon multimedia, which contains image decoders and a multimedia editor.
#define | APOXI_NO_MSG_BROADCAST_ON_STARTUP
Brief description
#define | APOXI_NOSTREAMING
Brief description
#define | APOXI_OBEX_MAX_NO_SELECTIONS
Maximum number of concurrently running transport address selection procedures
#define | APOXI_OBEX_MAX_NO_TRANSPORTS
Maximum number of transport protocols supported by APOXI OBEX
#define | APOXI_PHONENUMBER_MATCH_DEFAULT_DEPTH
Default number of digits which shall be used for matching method
#define | APOXI_PHONENUMBER_TEST_SUITE
Brief description
#define | APOXI_PLATFORM_BP30
Platform define for BP30
#define | APOXI_PLATFORM_MP1U
Platform define for MP1U
#define | APOXI_PLATFORM_MPE
Platform define for MP-E
#define | APOXI_PLATFORM_MPEU
Platform define for MP-EU
#define | APOXI_PNG_ENCODER_SUPPORT
Enables the PNG encoder.
#define | APOXI_POLYGON_EDGES_MAX
Defines the maximum numbers of edges a polygon may have.
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND
Defines timer impreciseness to optimize power consumption.
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE
Defines timer impreciseness to optimize power consumption.
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND
Defines timer impreciseness to optimize power consumption.
#define | APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE
Brief description
#define | APOXI_RAT_DUAL
Define for support of the dual mode RAT
#define | APOXI_RAT_GSM
Define for support of the single mode RAT GSM
#define | APOXI_RAT_UMTS
Define for support of the single mode RAT GSM
#define | APOXI_REG_LARGE_BLOB_SIZE
Brief description
#define | APOXI_REG_MAP_FILE_RECORDS_MAX
Brief description
#define | APOXI_REG_MAX_ASOT
Brief description
#define | APOXI_REG_MAX_MIME_TYPE_LEN
Brief description
#define | APOXI_REG_MAX_POOL_BUFFERS
Brief description
#define | APOXI_REG_MAX_URIS_IN_TABLE
Brief description
#define | APOXI_REG_NODE_FILE_SIZE_MAX
Brief description
#define | APOXI_REG_NODE_NAME_SIZE_MAX
Brief description
#define | APOXI_REG_SMALL_BLOB_SIZE_MAX
Brief description
#define | APOXI_REG_URI_SIZE_MAX
Brief description
#define | APOXI_REG_VERSION
Brief description
#define | APOXI_REGISTERED_TABLE_SIZE
Brief description
#define | APOXI_REGISTRY_TEST
Brief description
#define | APOXI_RTOS_DUMMY
Brief description
#define | APOXI_RTOS_LINUX
(Real time) operating system define for Linux
#define | APOXI_RTOS_NUC16
Brief description
#define | APOXI_RTOS_NUC16S
Brief description
#define | APOXI_RTOS_NUC16U
Brief description
#define | APOXI_RTOS_NUC32
(Real time) operating system define for Nucleus 32bit
#define | APOXI_RTOS_OSE166
(Real time) operating system define for OSE166
#define | APOXI_RTOS_POCKETPC
Brief description
#define | APOXI_RTOS_SIM166
Brief description
#define | APOXI_RTOS_WIN32
(Real time) operating system define for Windows 32bit
#define | APOXI_SCICOS_MM_CHIP_SUPPORT
Brief description
#define | APOXI_SDMMCSPI_SUPPORT
Brief description
#define | APOXI_SECURECLOCK_SUPPORT
Secure Clock
#define | APOXI_SEMAPHORE_M_FIRST_SWE
Brief description
#define | APOXI_SER_DATACONN_SUPPORT
Brief description
#define | APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT
Timeout for closing applications during shut-down.
#define | APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL
Interval for shutdown device for checking applications.
#define | APOXI_SIMTK_TRANSACTIONID_SUPPORT
Enables support of Sim toolkit transaction Ids of GFS20 and GFS21 Enables support of Sim toolkit transaction Ids of GFS20 and GFS21, for older stacks this shall not be set.
#define | APOXI_SMS_NEW_PROVIDERS
New SMS Providers
#define | APOXI_SMS_NOWAIT_ON_RELOAD
Prevent from active wait during reload of TPDUs
#define | APOXI_SMSSOCKET_MAX_CACHED_TPDUS
Defines the maximum number of Tpdus which shall be cached by a SmsSocket Defines the maximum number of Tpdus which shall be cached by a SmsSocket for an application, which has been registered. The default value is set to 12.
#define | APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS
Defines the maximum number of applications which can register for a SmsSocket Defines the maximum number of applications which can register for a SmsSocket which then shall be notified in case a PushSms arrives. The default value is set to 2.
#define | APOXI_SOCKET_ENSURE_CONTEXT
Brief description
#define | APOXI_SOCKET_EXTENDED_TRACE
Brief description
#define | APOXI_SOCKET_OPERATION_LOCK
Brief description
#define | APOXI_SOCKET_PARANOIA
Brief description
#define | APOXI_SOCKET_SYSTEM_BSD
Brief description
#define | APOXI_SOCKET_SYSTEM_DUMMY
Brief description
#define | APOXI_SOCKET_SYSTEM_LWIP
Brief description
#define | APOXI_SOCKET_SYSTEM_USNET
Brief description
#define | APOXI_SOCKET_SYSTEM_WIN32
Brief description
#define | APOXI_STRING_EXTENDED_DEBUG
Brief description
#define | APOXI_STRING_TEST_SUITE
Brief description
#define | APOXI_SUPPORT_CSMSREFNOREQ
Enables support of retrieving the concatenated SMS reference number Enables support of retrieving the concatenated SMS reference number of GFS 20 and GFS 21, for older stacks this shall not be set.
#define | APOXI_SUPPORT_MOSMS_TIMESTAMP
Enables support of retrieving time stamps of MOSMS Enables support of retrieving time stamps of MOSMS of GFS 20 and GFS 21, for older stacks this shall not be set.
#define | APOXI_SUPPORT_NETWORK_ECC_LIST
Enables support of ECC network list Enables support of retrieving ECCs over the air GFS 20 and GFS 21, for older stacks this shall not be set.
#define | APOXI_SUPPORT_NORMAL_SMS_LOADING
Disables the fast loading feature of the DR process and APOXI Disables the fast loading feature of the DR process and APOXI. This shall be only set for testing purposes.
#define | APOXI_SUPPORT_SMS_DELETION_CMD
Enables support of the bulk deletion signal of DR-process Enables support of the bulk deletion signal of DR-process of GFS20 and GFS 21, for older stacks this shall not be set.
#define | APOXI_SUPPORT_SMS_DELETION_CMD_GORS
Support +CMGD command to delete several SMS at once
#define | APOXI_SUPPORT_SMS_NEWMSG_PAYLOAD
Enables support of the TPDU payload of incoming SMS signal of DR-process Enables support of the TPDU payload of incoming SMS signal of DR-process of GFS20 and GFS 21, for older stacks this shall not be set. This allows processing the new arrived TPDU without reloading the TPDU from SIM or Flash.
#define | APOXI_SVG_SUPPORT
Enables support for scalable vector graphics.
#define | APOXI_SYNC_RELEASE
Brief description
#define | APOXI_SYSTEM_STACK_SWAPPING
Brief description
#define | APOXI_T9_SUPPORT
Enables the predictive text engine T9.
#define | APOXI_TARGETSYSTEM_HOST
Host build environment define
#define | APOXI_TARGETSYSTEM_HW
Target build environment define
#define | APOXI_TESTING
Brief description
#define | APOXI_THREAD_PRIORITY_NORMAL
Default priority level for APOXI tasks
#define | APOXI_TRACE
Brief description
#define | APOXI_TRACE_DISABLED
Brief description
#define | APOXI_TRACE_LEVEL_2
Brief description
#define | APOXI_TRACE_LEVEL_3
Brief description
#define | APOXI_TRACE_MEM
Brief description
#define | APOXI_TRACE_SOCKETS
Brief description
#define | APOXI_UNITTEST
Enables APOXI Unittest framework
#define | APOXI_UNITTEST_MMI
Brief description
#define | APOXI_UNITTEST_NO_FILENAMES
Disables output of filenames, where a unittest failed.
#define | APOXI_UNITTEST_NO_MESSAGE
Disables extensive console output while unittest run.
#define | APOXI_UNITTEST_NO_TESTNAMES
Brief description
#define | APOXI_UNITTEST_STATIC_REPOSITORY
Brief description
#define | APOXI_UNITTEST_TCPIP
Enable TCP/IP connections for controlling unit tests.
#define | APOXI_UNITTEST_TRACE
Brief description
#define | APOXI_UUS_SUPPORT
Enables UUS support
#define | APOXI_VIBRATOR_SUPPORT
Brief description
#define | APOXI_VIDEO_SUPPORT
Enables video support for the display device.
#define | APOXI_WAP_STACK
Brief description
#define | APOXI_WCATTR_NULL_DEF
Brief description
#define | APOXI_WSTRING_EXTENDED_DEBUG
Brief description
#define | APOXI_WSTRING_TEST_SUITE
Brief description
#define | APOXI_YAMAHA_MAPI_SUPPORT
Yamaha Mapi
#define | APOXI_YAMAHA_RINGER_SUPPORT
Enables the YAMAHA audio player.
#define | APOXI_ZI8_SUPPORT
Enables the predictive text engine eZi text.
#define | APOXI_ZLIB_USE_STACK_MEM_FUNCS
Brief description
#define | FEAT_BT_BPP

#define | FEAT_SIOSOCKETADAPTER
Define for Low Level SIO Sockets access over Serial Sockets
#define | SIMTK_LETTERCLASS_E
SIM Toolkit Letter Class E

Variables

def APOXI_DISPLAY_8BPP brief<
i > Must be defined if the
display is organized as bits
per pixel</i > Must be defined
if the display is organized
as bits per pixel If more
than one display is supported
and both displays have a different
bits per pixel 		setting
Generated on Tue Jan 24 17:10:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: apoxi.features File Reference

apoxi.features File Reference

Defines

#define | ADDITIONAL_THEMES
Adds the themes 'Foggy Theme' and 'Customizable Theme'.
#define | AFSFAT
APOXI filesystem AFSFAT
#define | AFSFFS
APOXI FlashFileSystem
#define | AFSRAM
APOXI file system AFSRAM
#define | AFSRFS
APOXI RootFileSystem
#define | ARAGON
ARAGON is used to build a phone MMI with the ARAGON IDE on a host computer.
#define | AT_MMI_INTERWORKING
Interworking between APOXI and other stack-clients.
#define | ATI
The feature ATI mainly covers the new generic companion interface (GCI) adressing video codecs, audio codecs and graphics device driver interfaces for ATI W2x82 companion
#define | ATL
ATL - Application Template Library
#define | AUD_MASTER_VOLUME_CONCEPT

#define | BLUETOOTH
bluetooth
#define | CAMERA
Enables the support for the still camera and video camera device.
#define | CODEC_MAN
Allows to use codec manager for MMFr
#define | DEBUG_INFO
Activate debug trace output and crash debug output
#define | DRM
Allows protection of content using digital rights technology (incl. aes, xmlparser, wbxml)
#define | DUAL_DISPLAY
Enables dual display support for the default DisplayConfig class.
#define | EMZ_CODECS
Allows to use SW audio and video codecs from Emuzed
#define | EXTERNAL_RINGER
Enable the YAMAHA player support
#define | FAT_FS
Activates FAT file system support on driver layer
#define | FEAT_BT_A2DP
Activate Bluetooth Advanced Audio Distribution Profile
#define | FEAT_BT_AVRCP
Activate Bluetooth Audio Video Remote Control Profile
#define | FEAT_BT_BIP
Bluetooth Basic Imaging Profile
#define | FEAT_BT_BPP
Bluetooth Basic Printing Profile
#define | FEAT_BTSOCKET
Bluetooth specific address class
#define | FEAT_EXTERNAL_PCH_CONTROL
External PCH Control
#define | FEAT_FOTA
Firmware update Over The Air
#define | FEAT_MMCALL
Multimedia Call Handling API
#define | FEAT_SECURECLOCK
Secure Clock
#define | FEAT_SERIALSOCKET
Generic Serial Socket Interface
#define | FEAT_SIOSOCKETADAPTER
Define for Low Level SIO Sockets access over Serial Sockets
#define | FFS
Activates flash file system (FFS) on driver layer
#define | FMRADIO
FM radio support
#define | FTPSERVER
Allows to create, start and use an FTP server in APOXI.
#define | GDD
use graphics device driver (GDD)
#define | GTL
GTL
#define | HTTPSERVER
Allows to create, start and use an HTTP server in APOXI.
#define | HTTPWAPINTERFACE
HTTP/WAP and profile management interface
#define | INTERNATIONALIZATION
Allows to use factory customized packs for languages and T9 dictionaries.
#define | IRDA
IrDA (in case of combination with OBEX, the IrDA/Obex transport is also activated
#define | LCS
location based services using AGPS technology
#define | MEDIAFRAMEWORK
mediaframework
#define | MENU_ACCESSORS
Obsolete feature, which enables menu accessor support for GUI.
#define | MM_CHIP_SCICOS
Support for SciCOS companion chip
#define | MMCI
Activates multi media card (MMC) on egold, sgold, or sgold2
#define | MP3
MP3 support having codec available in the firmware
#define | MSFS

#define | MULTIMEDIA
Multimedia addons (incl. libpng & zlib)
#define | OBEX
OBEX - OBject EXchange protocol support
#define | OBEXFTP_RFS
Obex-FTP server for APOXI Root File System (RFS)
#define | PNG_ENCODER
Enables PNG encoder
#define | POWER_SAVING_RELEASE

#define | SDMMCSPI
Activates multi media card (MMC) and SD-card on sgoldlite
#define | SER_DATACONN_SUPPORT
serial data connection support
#define | SERVER
Generic server interface.
#define | SIMTK_LETTERCLASS_E
SIM Toolkit Letter Class E
#define | SOCKET
IP socket module
#define | SVG
Enables support for SVG
#define | SYNCML
SyncML
#define | T9
Predictive input T9
#define | TESTING
Enabling APOXI Tester instrumentations
#define | TTY
TTY, TeleTYpewriter
#define | UNITTEST
Unittest Framework
#define | USB
USB support
#define | UUS
User-to-User Signaling (UUS)
#define | VIB
Vibrator support
#define | VOICERECOGNITION
Voice Recognition
#define | YAMAHA_MAPI
Yamaha Mapi
#define | ZI8
Predictive input ZI8
Generated on Tue Jan 24 17:10:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ApoxiLib.hpp File Reference

ApoxiLib.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for ApoxiLib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define ApoxiLib_hpp

Define Documentation

#define ApoxiLib_hpp

Generated on Tue Jan 24 17:11:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ApoxiLib.hpp Source File

ApoxiLib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ApoxiLib_hpp)
00010 #define ApoxiLib_hpp
00011
00012 #include <Kernel/Lib.hpp>
00013 #include <Auxiliary/Lib.hpp>
00014 #include <Gui/Lib.hpp>
00015 #include <Adc/Lib.hpp>
00016 #include <Asc/Lib.hpp>
00017
00018 #endif  // ApoxiLib_hpp
00019
Generated on Tue Jan 24 14:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ApoxiVersion.hpp File Reference

ApoxiVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | ApoxiLib_hpp
#define | APOXIVERSION "APOXI_2.10.0_TIV_05"

Define Documentation

#define ApoxiLib_hpp

#define APOXIVERSION "APOXI_2.10.0_TIV_05"

Generated on Tue Jan 24 17:11:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ApoxiVersion.hpp Source File

ApoxiVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007                         This file is generated,
00008                 D O   N O T   M O D I F Y   B Y   H A N D
00009     ------------------------------------------------------------------------ */
00010
00011 #if !defined(ApoxiLib_hpp)
00012 #define ApoxiLib_hpp
00013
00017
00022
00027
00032
00037
00042
00047
00052
00057
00062
00067
00072
00077
00082
00083 /*
00084 ApoxiVersion.hpp contains the official Apoxi Version which should be used in the
00085 different <Module>Version.cpp files as long as those Modules are not versioned and
00086 released separately
00087 */
00088 #define APOXIVERSION "APOXI_2.10.0_TIV_05"
00089
00090 #endif  // ApoxiLib_hpp
00091
Generated on Tue Jan 24 14:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/AdcTemplates.cpp File Reference

Adc/AdcTemplates.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Adc/SimPbEntryCont.hpp>
#include <Adc/SimPduHandler.hpp>

Include dependency graph for AdcTemplates.cpp:

Generated on Tue Jan 24 14:52:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/ApoxiAdcVersion.cpp File Reference

Adc/ApoxiAdcVersion.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiAdcVersion.cpp:

Functions

ApoxiDefVersionInfo (Adc, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | Adc | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 14:52:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/AuxProvider.cpp File Reference

Adc/AuxProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "AuxProvider.hpp"

Include dependency graph for AuxProvider.cpp:

Generated on Tue Jan 24 14:52:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/AuxProvider.hpp File Reference

Adc/AuxProvider.hpp File Reference

#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>
#include <Auxiliary/ThreadSafeProvider.hpp>

Include dependency graph for AuxProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AuxProvider

Defines

#define | Adc_AuxProvider_hpp

Define Documentation

#define Adc_AuxProvider_hpp

Generated on Tue Jan 24 14:52:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/AuxProvider.hpp Source File

Adc/AuxProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_AuxProvider_hpp)
00015 #define Adc_AuxProvider_hpp
00019
00020 #include <Adc/ProvIds.hpp>
00021 #include <Adc/SimAuxHandler.hpp>
00022 #include <Auxiliary/ThreadSafeProvider.hpp>
00023
00024 /*------------------------------------------------------------------
00025                             AuxProvider
00026  ------------------------------------------------------------------*/
00027
00075 class AuxProvider : public ThreadSafeProvider
00076 {
00077     public:
00078         typedef ThreadSafeProvider Base;
00079
00081         AuxProvider();
00083         virtual ~AuxProvider();
00085         virtual INT GetProviderId() const;
00087         void Init(SimAuxHandler * aux_handler, Protector * protector);
00089         virtual INT RowCount();
00091         virtual BOOLEAN Update(ProviderListener * listener = 0);
00093         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00095         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00097         virtual BOOLEAN CommitRow(INT row);
00098
00099     private:
00100         void ClearBufferVariables();
00101
00102         SimAuxHandler * m_aux_handler;
00103         UINT32   m_commit_acm;
00104         UINT32   m_commit_acm2;
00105         UINT32   m_commit_acmmax;
00106         WString  m_commit_cur_code;
00107         INT      m_commit_exp;
00108         UINT     m_commit_eppu;
00109         INT      m_columnid;
00110 };
00111
00113 #endif
00114
Generated on Tue Jan 24 14:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/BaseDataHandler.cpp File Reference

Adc/BaseDataHandler.cpp File Reference

#include "Adc/PreComp.hpp"
#include "BaseDataHandler.hpp"

Include dependency graph for BaseDataHandler.cpp:

Generated on Tue Jan 24 14:52:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/BaseDataHandler.hpp File Reference

Adc/BaseDataHandler.hpp File Reference

#include <Adc/SimAccessor.hpp>

Include dependency graph for BaseDataHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BaseDataHandler

Defines

#define | Adc_BaseDataHandler_hpp

Define Documentation

#define Adc_BaseDataHandler_hpp

Generated on Tue Jan 24 14:52:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/BaseDataHandler.hpp Source File

Adc/BaseDataHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_BaseDataHandler_hpp)
00010 #define Adc_BaseDataHandler_hpp
00014
00015 #include <Adc/SimAccessor.hpp>
00016
00017 class BaseDataHandler
00018 {
00019     public:
00020         BaseDataHandler();
00021         virtual ~BaseDataHandler();
00022
00023         void Init(SimAccessor * handler);
00024
00025         BOOLEAN IsSimAccessAllowed() const { return SimAccessor::IsSimAccessAllowed(); }
00026         BOOLEAN IsSimPresent() const  { return SimAccessor::IsSimPresent(); }
00027         BOOLEAN IsUsimInserted() const { return SimAccessor::IsUsimInserted(); };
00028
00029     protected:
00030         SimAccessor *   m_sim_handler;
00031 };
00032
00034 #endif
00035
00036
Generated on Tue Jan 24 14:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CbmiProvider.cpp File Reference

Adc/CbmiProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "CbmiProvider.hpp"

Include dependency graph for CbmiProvider.cpp:

Generated on Tue Jan 24 14:52:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CbmiProvider.hpp File Reference

Adc/CbmiProvider.hpp File Reference

#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>
#include <Auxiliary/ThreadSafeProvider.hpp>

Include dependency graph for CbmiProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CbmiProvider

Defines

#define | Adc_CbmiProvider_hpp

Define Documentation

#define Adc_CbmiProvider_hpp

Generated on Tue Jan 24 14:52:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CbmiProvider.hpp Source File

Adc/CbmiProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_CbmiProvider_hpp)
00015 #define Adc_CbmiProvider_hpp
00019
00020 #include <Adc/ProvIds.hpp>
00021 #include <Adc/SimAuxHandler.hpp>
00022 #include <Auxiliary/ThreadSafeProvider.hpp>
00023
00024 /*------------------------------------------------------------------
00025                             CbmiProvider
00026  ------------------------------------------------------------------*/
00027
00041 class CbmiProvider : public ThreadSafeProvider
00042 {
00043     public:
00044         typedef ThreadSafeProvider Base;
00046         CbmiProvider();
00048         virtual ~CbmiProvider();
00050         virtual INT GetProviderId() const;
00052         void Init(SimAuxHandler * aux_handler, Protector * protector);
00054         virtual INT RowCount();
00056         virtual INT MaxRowCount();
00058         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00060         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00062         virtual BOOLEAN CommitRow(INT row);
00064         virtual BOOLEAN DeleteRow(INT row);
00066         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00068         virtual BOOLEAN Update(ProviderListener * listener = 0);
00069
00070     private:
00071         void ClearBufferVariables() {
00072             m_commit_cbmi = 0xFFFF;
00073         }
00074
00075         SimAuxHandler * m_aux_handler;
00076         UINT16          m_commit_cbmi;
00077 };
00078
00080 #endif
00081
00082
Generated on Tue Jan 24 14:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CbmiRangeProvider.cpp File Reference

Adc/CbmiRangeProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "CbmiRangeProvider.hpp"

Include dependency graph for CbmiRangeProvider.cpp:

Generated on Tue Jan 24 14:52:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CbmiRangeProvider.hpp File Reference

Adc/CbmiRangeProvider.hpp File Reference

#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>
#include <Auxiliary/ThreadSafeProvider.hpp>

Include dependency graph for CbmiRangeProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CbmiRangeProvider

Defines

#define | Adc_CbmiRangeProvider_hpp

Define Documentation

#define Adc_CbmiRangeProvider_hpp

Generated on Tue Jan 24 14:52:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CbmiRangeProvider.hpp Source File

Adc/CbmiRangeProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_CbmiRangeProvider_hpp)
00015 #define Adc_CbmiRangeProvider_hpp
00019
00020 #include <Adc/ProvIds.hpp>
00021 #include <Adc/SimAuxHandler.hpp>
00022 #include <Auxiliary/ThreadSafeProvider.hpp>
00023
00024 /*------------------------------------------------------------------
00025                             CbmiRangeProvider
00026  ------------------------------------------------------------------*/
00027
00042 class CbmiRangeProvider : public ThreadSafeProvider
00043 {
00044     public:
00045         typedef ThreadSafeProvider Base;
00047         CbmiRangeProvider();
00049         virtual ~CbmiRangeProvider();
00051         virtual INT GetProviderId() const;
00053         void Init(SimAuxHandler * aux_handler, Protector * protector);
00055         virtual INT RowCount();
00057         virtual INT MaxRowCount();
00059         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00061         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00063         virtual BOOLEAN CommitRow(INT row);
00065         virtual BOOLEAN DeleteRow(INT row);
00067         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00069         virtual BOOLEAN Update(ProviderListener * listener = 0);
00070
00071     private:
00072         void ClearBufferVariables() {
00073             m_commit_cbmi_low = 0xFFFF;
00074             m_commit_cbmi_high = 0xFFFF;
00075         }
00076
00077         SimAuxHandler * m_aux_handler;
00078         UINT16          m_commit_cbmi_low;
00079         UINT16          m_commit_cbmi_high;
00080 };
00081
00083 #endif
00084
00085
Generated on Tue Jan 24 14:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/ChvProvider.cpp File Reference

Adc/ChvProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "ChvProvider.hpp"

Include dependency graph for ChvProvider.cpp:

Generated on Tue Jan 24 14:52:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/ChvProvider.hpp File Reference

Adc/ChvProvider.hpp File Reference

#include <Adc/ProvIds.hpp>
#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/SimChvHandler.hpp>

Include dependency graph for ChvProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ChvProvider

Defines

#define | Adc_ChvProvider_hpp

Define Documentation

#define Adc_ChvProvider_hpp

Generated on Tue Jan 24 14:52:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/ChvProvider.hpp Source File

Adc/ChvProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_ChvProvider_hpp)
00010 #define Adc_ChvProvider_hpp
00014
00015 #include <Adc/ProvIds.hpp>
00016 #include <Auxiliary/ThreadSafeProvider.hpp>
00017 #include <Adc/SimChvHandler.hpp>
00018
00019 /*------------------------------------------------------------------
00020                             ChvProvider
00021  ------------------------------------------------------------------*/
00022
00038 class ChvProvider : public ThreadSafeProvider
00039 {
00040     public:
00041         typedef ThreadSafeProvider Base;
00043         ChvProvider();
00045         virtual ~ChvProvider();
00047         virtual INT GetProviderId() const;
00049         void Init(SimChvHandler * chv_handler, Protector * protector);
00051         virtual Provider::Status GetStatus() const;
00053         virtual BOOLEAN Update(ProviderListener * listener = 0);
00055         virtual INT RowCount();
00057         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00058
00059     private:
00060         SimChvHandler *m_chv_handler;
00061
00062 };
00063
00065 #endif
00066
00067
Generated on Tue Jan 24 14:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CmiProvider.cpp File Reference

Adc/CmiProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "CmiProvider.hpp"

Include dependency graph for CmiProvider.cpp:

Generated on Tue Jan 24 14:52:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CmiProvider.hpp File Reference

Adc/CmiProvider.hpp File Reference

#include <Adc/ProvIds.hpp>
#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/SimAuxHandler.hpp>

Include dependency graph for CmiProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CmiProvider

Defines

#define | Adc_CmiProvider_hpp

Define Documentation

#define Adc_CmiProvider_hpp

Generated on Tue Jan 24 14:52:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CmiProvider.hpp Source File

Adc/CmiProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_CmiProvider_hpp)
00010 #define Adc_CmiProvider_hpp
00014
00015 #include <Adc/ProvIds.hpp>
00016 #include <Auxiliary/ThreadSafeProvider.hpp>
00017 #include <Adc/SimAuxHandler.hpp>
00018
00019 /*------------------------------------------------------------------
00020                             CmiProvider
00021  ------------------------------------------------------------------*/
00022
00038 class CmiProvider : public ThreadSafeProvider
00039 {
00040     public:
00041         typedef ThreadSafeProvider Base;
00043         CmiProvider();
00045         virtual ~CmiProvider();
00047         virtual INT GetProviderId() const;
00049         void Init(SimAuxHandler * chv_handler, Protector * protector);
00051         virtual Provider::Status GetStatus() const;
00053         virtual BOOLEAN Update(ProviderListener * listener = 0);
00055         virtual INT RowCount();
00057         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00058
00059     private:
00060         SimAuxHandler *m_aux_handler;
00061
00062 };
00063
00065 #endif
00066
00067
Generated on Tue Jan 24 14:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CompoundSmsItem.cpp File Reference

Adc/CompoundSmsItem.cpp File Reference

#include "Adc/PreComp.hpp"
#include "CompoundSmsItem.hpp"

Include dependency graph for CompoundSmsItem.cpp:

Generated on Tue Jan 24 14:52:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CompoundSmsItem.hpp File Reference

Adc/CompoundSmsItem.hpp File Reference

#include <Apc/UserData.hpp>
#include <Apc/BaseInformationElement.hpp>
#include <Auxiliary/GenericObject.hpp>
#include <Adc/SimPduHandler.hpp>

Include dependency graph for CompoundSmsItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CompoundSmsItem
class | CompoundTpduItem

Defines

#define | Adc_CompoundSmsItem_hpp

Variables

const GenericTypeId | c_compound_sms_item_type = c_apoxi_base_gentypes + 2
const GenericTypeId | c_compound_tpdu_item_type = c_apoxi_base_gentypes + 3

Define Documentation

#define Adc_CompoundSmsItem_hpp

Generated on Tue Jan 24 14:52:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CompoundSmsItem.hpp Source File

Adc/CompoundSmsItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_CompoundSmsItem_hpp)
00010 #define Adc_CompoundSmsItem_hpp
00014
00015 #include <Apc/UserData.hpp>
00016 #include <Apc/BaseInformationElement.hpp>
00017 #include <Auxiliary/GenericObject.hpp>
00018
00019 #include <Adc/SimPduHandler.hpp>
00020
00022 //
00023 // CompoundSmsItem
00024 //
00026
00027 const GenericTypeId c_compound_sms_item_type  = c_apoxi_base_gentypes + 2;
00028
00033 class CompoundSmsItem : public GenericObject
00034 {
00035     typedef GenericObject Base;
00036
00037     public:
00039         CompoundSmsItem(SimPduHandler * handler, SmsFilterType filter_type, INT recno);
00040
00041         virtual ~CompoundSmsItem();
00043         BOOLEAN StartIteration();
00045         BOOLEAN GetBaseInformationElement(BaseInformationElement & ie);
00046
00047         virtual GenericObject * Copy() const;
00048         virtual BOOLEAN         IsEqual(GenericObject * object);
00049         virtual GenericTypeId   GetTypeId();
00050
00051     private:
00052         BOOLEAN LoadFirstTpdu(BOOLEAN & isexisting);
00053         BOOLEAN LoadNextTpdu(BOOLEAN & isexisting);
00054
00055         void InitializeUserDataHeader();
00056
00057         SimPduHandler *         m_pdu_handler;
00058         SmsFilterType           m_filter_type;
00059         INT                     m_recno;
00060
00061         TpduHeaderInformation * m_header_info;
00062         Tpdu *                  m_actual_pdu;
00063         INT                     m_tpduno;
00064         INT                     m_actual_seq_nr;
00065         INT                     m_max_count;
00066         UserDataHeader          m_udh;
00067
00068         BOOLEAN                 m_at_pdu_start;
00069         BOOLEAN                 m_start_ie_parsing;
00070         BOOLEAN                 m_missing_pdu;
00071         BOOLEAN                 m_end_of_stream;
00072 };
00073
00075 //
00076 // CompoundTpduItem
00077 //
00079
00080 const GenericTypeId c_compound_tpdu_item_type  = c_apoxi_base_gentypes + 3;
00081
00082 class CompoundTpduItem : public GenericObject
00083 {
00084     typedef GenericObject Base;
00085
00086     public:
00087         CompoundTpduItem(SimPduHandler * handler, SmsFilterType filter_type, INT recno);
00088
00089         virtual ~CompoundTpduItem();
00090
00091         virtual GenericObject * Copy() const;
00092         virtual BOOLEAN         IsEqual(GenericObject * object);
00093         virtual GenericTypeId   GetTypeId();
00094
00095         BOOLEAN LoadFirstTpdu();
00096         BOOLEAN LoadNextTpdu();
00097         BOOLEAN GetTpdu(Tpdu & tpdu, INT & tpduno);
00098         BOOLEAN WriteTpdu(const Tpdu & tpdu, INT tpduno);
00099
00100     private:
00101         BOOLEAN LoadFirstTpdu(BOOLEAN & isexisting);
00102         BOOLEAN LoadNextTpdu(BOOLEAN & isexisting);
00103
00104         SimPduHandler *         m_pdu_handler;
00105         SmsFilterType           m_filter_type;
00106         INT                     m_recno;
00107
00108         TpduHeaderInformation * m_header_info;
00109         Tpdu *                  m_actual_pdu;
00110         INT                     m_tpduno;
00111         INT                     m_actual_seq_nr;
00112         INT                     m_max_count;
00113         BOOLEAN                 m_missing_pdu;
00114
00115 };
00116
00118 #endif
00119
Generated on Tue Jan 24 14:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CountryProvider.cpp File Reference

Adc/CountryProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "CountryProvider.hpp"

Include dependency graph for CountryProvider.cpp:

Generated on Tue Jan 24 14:52:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CountryProvider.hpp File Reference

Adc/CountryProvider.hpp File Reference

#include <Adc/ProvIds.hpp>
#include <Auxiliary/Provider.hpp>

Include dependency graph for CountryProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CountryProvider

Defines

#define | Adc_CountryProvider_hpp

Define Documentation

#define Adc_CountryProvider_hpp

Generated on Tue Jan 24 14:52:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CountryProvider.hpp Source File

Adc/CountryProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_CountryProvider_hpp)
00015 #define Adc_CountryProvider_hpp
00019
00020 #include <Adc/ProvIds.hpp>
00021 #include <Auxiliary/Provider.hpp>
00022
00023 /*------------------------------------------------------------------
00024                             CountryProvider
00025  ------------------------------------------------------------------*/
00040 class CountryProvider : public Provider
00041 {
00042     public:
00043         typedef Provider Base;
00045         CountryProvider();
00047         virtual ~CountryProvider();
00049         virtual INT GetProviderId() const;
00050
00051         virtual Provider::Status GetStatus() const;
00053         virtual INT RowCount();
00055         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00056
00057 };
00058
00060 #endif
00061
00062
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CphsAuxProvider.cpp File Reference

Adc/CphsAuxProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "CphsAuxProvider.hpp"

Include dependency graph for CphsAuxProvider.cpp:

Generated on Tue Jan 24 14:52:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CphsAuxProvider.hpp File Reference

Adc/CphsAuxProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimCphsHandler.hpp>

Include dependency graph for CphsAuxProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CphsAuxProvider

Defines

#define | Adc_CphsAuxProvider_hpp

Define Documentation

#define Adc_CphsAuxProvider_hpp

Generated on Tue Jan 24 14:52:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CphsAuxProvider.hpp Source File

Adc/CphsAuxProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_CphsAuxProvider_hpp)
00015 #define Adc_CphsAuxProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimCphsHandler.hpp>
00024
00025 /*------------------------------------------------------------------
00026                             CphsAuxProvider
00027  ------------------------------------------------------------------*/
00028
00068 class CphsAuxProvider : public ThreadSafeProvider
00069 {
00070     public:
00071         typedef ThreadSafeProvider Base;
00072
00074         CphsAuxProvider();
00076         virtual ~CphsAuxProvider();
00078         virtual INT GetProviderId() const;
00080         void Init(SimCphsHandler * cphs_handler, Protector * protector);
00082         virtual INT RowCount();
00084         virtual BOOLEAN Update(ProviderListener * listener = 0);
00086         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00088         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00090         virtual BOOLEAN CommitRow(INT row);
00091
00092     private:
00093         void ClearBufferVariables();
00094
00095         SimCphsHandler * m_cphs_handler;
00096
00097         INT      m_columnid;
00098         BOOLEAN  m_value;
00099
00100 };
00101
00103 #endif
00104
00105
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CphsServPflProvider.cpp File Reference

Adc/CphsServPflProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "CphsServPflProvider.hpp"

Include dependency graph for CphsServPflProvider.cpp:

Generated on Tue Jan 24 14:52:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CphsServPflProvider.hpp File Reference

Adc/CphsServPflProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimCphsHandler.hpp>

Include dependency graph for CphsServPflProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CphsServPflProvider

Defines

#define | Adc_CphsServPflProvider_hpp

Define Documentation

#define Adc_CphsServPflProvider_hpp

Generated on Tue Jan 24 14:52:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/CphsServPflProvider.hpp Source File

Adc/CphsServPflProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_CphsServPflProvider_hpp)
00015 #define Adc_CphsServPflProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimCphsHandler.hpp>
00024
00025 /*------------------------------------------------------------------
00026                             CphsServPflProvider
00027  ------------------------------------------------------------------*/
00028
00029 class SimCphsHandler;
00030
00102 class CphsServPflProvider : public ThreadSafeProvider
00103 {
00104     public:
00105         typedef ThreadSafeProvider Base;
00106
00108         CphsServPflProvider();
00110         virtual ~CphsServPflProvider();
00112         virtual INT GetProviderId() const;
00114         void Init(SimCphsHandler * cphs_handler, Protector * protector);
00116         virtual INT RowCount();
00118         virtual BOOLEAN Update(ProviderListener * listener = 0);
00120         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00122         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00124         virtual BOOLEAN CommitRow(INT row);
00125
00126
00127     private:
00128         void ClearBufferVariables();
00129
00130         SimCphsHandler * m_cphs_handler;
00131
00132         INT      m_columnid;
00133         BOOLEAN  m_value;
00134
00135 };
00136
00138 #endif
00139
00140
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/DataHandler.cpp File Reference

Adc/DataHandler.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <Kernel/System.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include "DataHandler.hpp"

Include dependency graph for DataHandler.cpp:

Functions

ApoxiUseVersionInfo (Adc)

Variables

LookupAlphaIdExtension g_defaultlookup

Function Documentation

ApoxiUseVersionInfo ( Adc )

Variable Documentation

LookupAlphaIdExtension g_defaultlookup

Generated on Tue Jan 24 14:52:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/DataHandler.hpp File Reference

Adc/DataHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/SubSystem.hpp>
#include <Kernel/SubSystemManager.hpp>
#include <Auxiliary/BitVector.hpp>
#include <Apc/LockTypes.hpp>
#include <Adc/Types.hpp>
#include <Adc/SimAccessor.hpp>
#include <Adc/SimAuxHandler.hpp>
#include <Adc/SimPbBaseHandler.hpp>
#include <Adc/SimSmsParamHandler.hpp>
#include <Adc/SimChvHandler.hpp>
#include <Adc/SimPduHandler.hpp>
#include <Adc/PbBaseProvider.hpp>
#include <Adc/AuxProvider.hpp>
#include <Adc/PrefPlmnProvider.hpp>
#include <Adc/PrefLangProvider.hpp>
#include <Adc/PrefExtLangProvider.hpp>
#include <Adc/SstProvider.hpp>
#include <Adc/EccProvider.hpp>
#include <Adc/ChvProvider.hpp>
#include <Adc/SmsProvider.hpp>
#include <Adc/SmsUnreadProvider.hpp>
#include <Adc/SmsReadProvider.hpp>
#include <Adc/SmsUnsentProvider.hpp>
#include <Adc/SmsSentProvider.hpp>
#include <Adc/SmsClass0Provider.hpp>
#include <Adc/SmsParamProvider.hpp>
#include <Adc/CountryProvider.hpp>
#include <Adc/PlmnProvider.hpp>
#include <Adc/StatusProvider.hpp>
#include <Adc/LockProvider.hpp>
#include <Adc/CbmiProvider.hpp>
#include <Adc/CbmiRangeProvider.hpp>
#include <Adc/CphsAuxProvider.hpp>
#include <Adc/CphsServPflProvider.hpp>
#include <Adc/SimCphsHandler.hpp>
#include <Adc/SimTkMainMenuProvider.hpp>
#include <Adc/CmiProvider.hpp>
#include <Adc/MbiProvider.hpp>
#include <Auxiliary/TimeZone.hpp>
#include <Auxiliary/MainProvider.hpp>
#include <Apc/SimMiscStackMsgArgs.hpp>
#include <Apc/UsimPbTypes.hpp>

Include dependency graph for DataHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BootControl
class | BootState
class | DataControl
class | DataHandler
class | LookupAlphaIdExtension

Defines

#define | Adc_DataHandler_hpp

Define Documentation

#define Adc_DataHandler_hpp

Generated on Tue Jan 24 14:53:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/DataHandler.hpp Source File

Adc/DataHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Adc_DataHandler_hpp)
00009 #define Adc_DataHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/SubSystem.hpp>
00015 #include <Kernel/SubSystemManager.hpp>
00016 #include <Auxiliary/BitVector.hpp>
00017
00018 #include <Apc/LockTypes.hpp>
00019
00020 #include <Adc/Types.hpp>
00021
00022 #include <Adc/SimAccessor.hpp>
00023 #include <Adc/SimAuxHandler.hpp>
00024 #include <Adc/SimPbBaseHandler.hpp>
00025 #include <Adc/SimSmsParamHandler.hpp>
00026 #include <Adc/SimChvHandler.hpp>
00027 #include <Adc/SimPduHandler.hpp>
00028
00029 #include <Adc/PbBaseProvider.hpp>
00030 #include <Adc/AuxProvider.hpp>
00031 #include <Adc/PrefPlmnProvider.hpp>
00032 #include <Adc/PrefLangProvider.hpp>
00033 #include <Adc/PrefExtLangProvider.hpp>
00034 #include <Adc/SstProvider.hpp>
00035 #include <Adc/EccProvider.hpp>
00036
00037 #include <Adc/ChvProvider.hpp>
00038 #include <Adc/SmsProvider.hpp>
00039
00040 #if defined(APOXI_SMS_NEW_PROVIDERS)
00041     #include <Adc/SmsBaseInboxProvider.hpp>
00042     #include <Adc/SmsBaseOutboxProvider.hpp>
00043     #include <Adc/SmsBaseArchiveProvider.hpp>
00044     #include <Adc/SmsBaseStatusReportProvider.hpp>
00045     #include <Adc/SmsBaseUnreadProvider.hpp>
00046 #elif !defined(APOXI_DISABLE_FILTERED_SMS_PROVIDERS)
00047 #include <Adc/SmsUnreadProvider.hpp>
00048     #include <Adc/SmsReadProvider.hpp>
00049 #include <Adc/SmsUnsentProvider.hpp>
00050     #include <Adc/SmsSentProvider.hpp>
00051 #endif // (APOXI_SMS_NEW_PROVIDERS)
00052
00053 #include <Adc/SmsClass0Provider.hpp>
00054 #include <Adc/SmsParamProvider.hpp>
00055 #include <Adc/CountryProvider.hpp>
00056 #include <Adc/PlmnProvider.hpp>
00057 #include <Adc/StatusProvider.hpp>
00058 #include <Adc/LockProvider.hpp>
00059 #include <Adc/CbmiProvider.hpp>
00060 #include <Adc/CbmiRangeProvider.hpp>
00061 #include <Adc/CphsAuxProvider.hpp>
00062 #include <Adc/CphsServPflProvider.hpp>
00063 #include <Adc/SimCphsHandler.hpp>
00064 #include <Adc/SimTkMainMenuProvider.hpp>
00065 #include <Adc/CmiProvider.hpp>
00066 #include <Adc/MbiProvider.hpp>
00067
00068 #include <Adc/SimAccessor.hpp>
00069 #include <Auxiliary/TimeZone.hpp>
00070 #include <Auxiliary/MainProvider.hpp>
00071 #include <Apc/SimMiscStackMsgArgs.hpp>
00072
00073 #include <Apc/UsimPbTypes.hpp>
00074 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00075     #include <Apc/PhoneBookStackMsgArgs.hpp>
00076     #include <Adc/UsimPbAccessor.hpp>
00077     #include <Adc/UsimPbHandler.hpp>
00078     #include <Adc/UsimPbXasProvider.hpp>
00079     #include <Adc/UsimPbPropertyProvider.hpp>
00080     #include <Adc/UsimPbProvider.hpp>
00081 #endif
00082
00083 class BlobObject;
00084
00085 /*  ========================================================================
00086     DataHandler
00087     ======================================================================== */
00088
00092 class DataHandler : public MainProvider
00093 {
00094     friend class SimAccessor;
00095     friend class SimPduHandler;
00096
00097     public:
00098         typedef MainProvider Base;
00099
00100         DataHandler();
00101         virtual ~DataHandler();
00102
00103         BOOLEAN Startup();
00104         BOOLEAN Shutdown();
00105
00106         SimAccessor *   GetSimAccessor() { return (&m_simaccessor); }
00107
00109         SimChvHandler * GetSimChvHandler() { return (&m_simchvhandler); }
00110
00111         SimPduHandler * GetSimPduHandler() { return (&m_simpduhandler); }
00112
00113         SimCphsHandler * GetSimCphsHandler() { return (&m_simcphshandler); }
00114
00115         MainProvider * GetMainProvider() { return this; }
00116
00118         virtual Provider * GetProvider(INT columnid);
00119
00121         DataAvailability GetDataAvailability(INT columnid);
00122
00123     /* /////////////////////////////////////////////////////////////////
00124     // these calls can directly be called
00126
00128         BOOLEAN ActivateFdn();
00130         BOOLEAN DeactivateFdn();
00132         BOOLEAN ActivateBdn();
00134         BOOLEAN DeactivateBdn();
00135
00137         BOOLEAN IsSimPresent();
00139         BOOLEAN IsSimAccessAllowed();
00141         BOOLEAN IsUsimInserted();
00143         BOOLEAN WasSimChanged();
00144
00146         BOOLEAN IsFdnActivated() const { return m_simaccessor.IsFdnActivated(); }
00148         BOOLEAN IsBdnActivated() const { return m_simaccessor.IsBdnActivated(); }
00150         BOOLEAN IsAdnReadWritableIfFdnActive() const { return m_simaccessor.IsAdnReadWritableIfFdnActive(); }
00152         BOOLEAN IsBdnReadWritableIfBdnNotActive() const { return m_simaccessor.IsBdnReadWritableIfBdnNotActive(); }
00153
00155         BOOLEAN IsGprsFdnActivationCodePresent();
00156
00158         BOOLEAN GetSimIconDescription(INT recno, SimIconDescription & data);
00160         BOOLEAN GetSimImage(const SimImageDescriptor & imgdesc, SimImage & data);
00161
00162         BOOLEAN UpdateLockInformation();
00164         BOOLEAN ModifyLock(const SecLockAction lockaction, const SecLockType locktype,
00165                            const WString & oldpwd, const WString & newpwd);
00166
00168         void SetInitialPrefferedStorageMedia(Sms::StorageType storagetype);
00170         BOOLEAN ChangePreferredStorageMedia(Sms::StorageType storagetype);
00171         Sms::StorageType GetPreferredStorageMedia() const;
00172
00173         WString GetActiveExtLanguage() const;
00175         void SetActiveExtLanguage(const WString & language);
00176         BOOLEAN IsSimResetPossible() const;
00178         void SetSimResetPossible(BOOLEAN resetable);
00179         BOOLEAN IsSimRefreshPossible() const;
00181         void SetSimRefreshPossible(BOOLEAN refreshable);
00182
00183
00185         UINT8 GetConcSmsPduMaxNo() { return SimPduHandler::GetConcSmsPduMaxNo(); }
00187         void SetConcSmsPduMaxNo(UINT8 no) { SimPduHandler::SetConcSmsPduMaxNo(no); }
00188
00190         BOOLEAN IsPartlyConcSmsStateChangeable() { return SimPduHandler::IsPartlyConcSmsStateChangeable(); }
00192         void SetPartlyConcSmsStateChangeable(BOOLEAN changeable) { SimPduHandler::SetPartlyConcSmsStateChangeable(changeable); }
00193
00195         void EnablePidCheckForConcSms(BOOLEAN pidcheck = TRUE) { SimPduHandler::EnablePidCheckForConcSms(pidcheck); }
00196
00198         void SetMaxNoOfPduCache(UINT16 pdu_no_cache) { SimPduHandler::SetMaxNoOfPduCache(pdu_no_cache); }
00199
00201         void SetSmsHeaderCacheParams(INT noofentries = 30, INT noofchars = 20) { SimPduHandler::SetSmsHeaderCacheParams(noofentries,noofchars); }
00202
00204         SimUpdateStatus GetLastSimUpdateStatus() { return m_simaccessor.GetLastSimUpdateStatus(); }
00205
00207         void EnableBuiltinEccCodes(BOOLEAN enable = TRUE) {
00208             DBG_OUT((L"Obsolete Interface DataHandler::EnableBuiltinEccCodes used, Builtin ECCs are always enabled\n"));
00209         }
00210
00212         BOOLEAN MdhRequestCsmsRefNo(UINT16 & ref_no);
00213
00216         BOOLEAN GetEmlppSubscription(EmlppPriorityLevel idx, BOOLEAN & subscribed);
00217
00220         BOOLEAN GetEmlppSetupCallCondition(EmlppPriorityLevel idx, BOOLEAN & condition);
00221
00223         PowerMode GetPowerMode();
00224
00228         BOOLEAN LookupAlphaId(const PhoneNumber & phno, WString & alphaid, BOOLEAN uselookupalphaext = TRUE);
00229
00231         BcdPlmn GetHomeBcdPlmn() const;
00233         Plmn GetHomePlmn() const;
00234
00236         Plmn GetRegisteredPlmn() const;
00238         BcdPlmn GetRegisteredBcdPlmn() const;
00239
00241         UINT16 GetRegisteredLac() const;
00242
00246         BOOLEAN GetEonsPlmnName(const BcdPlmn & checkplmn, UINT16 lac, WString & longname, WString & shortname);
00248         BOOLEAN GetEonsPlmnName(const Plmn & checkplmn, UINT16 lac, WString & longname, WString & shortname);
00249
00256         BOOLEAN CheckSpnData(const BcdPlmn & regplmn,   // registered Plmn
00257                             BOOLEAN & showregplmn,      // show the registered plmn name
00258                             BOOLEAN & showspnname,      // show the spn name
00259                             WString & spnname,          // returned spn name
00260                             BOOLEAN use_spn_display_condition = FALSE);
00262         BOOLEAN CheckSpnData(const Plmn & regplmn,  // registered Plmn
00263                             BOOLEAN & showregplmn,  // show the registered plmn name
00264                             BOOLEAN & showspnname,  // show the spn name
00265                             WString & spnname,      // returned spn name
00266                             BOOLEAN use_spn_display_condition = FALSE);
00267
00270         BOOLEAN LookupPlmnName(const BcdPlmn & plmn, WString & longname, WString & shortname,
00271                                 NetType & nettype, WString & countryname);
00273         BOOLEAN LookupPlmnName(const Plmn & plmn, WString & longname, WString & shortname,
00274                                 NetType & nettype, WString & countryname);
00275
00277         BOOLEAN InitMexe();
00279         UINT GetSimMexeCertificateCount() const;
00283         SimMexeCertificate * GetSimMexeCertificate(UINT idx);
00284
00286         BOOLEAN IsEccCode(const WString & checkstr);
00287
00290         EccCategory GetEccCategory(const WString & checkstr);
00291
00294         const CfuServiceArray & GetCfuServiceArray() const;
00295
00298         BOOLEAN IsCingularNetworkSelectionMenuControlSupportEnabled(BOOLEAN & enabled);
00299
00301         BOOLEAN IsCingularSimInserted();
00302
00305         BOOLEAN IsCspPlmnModeBitSet(BOOLEAN & isset);
00306
00308         EccCustomization * GetEccCustomization();
00309
00314         BOOLEAN IsSimServiceEnabled(SimServiceId id, BOOLEAN & enabled);
00317         BOOLEAN GetUsimPbLocReport(UsimPbLocReport & report);
00318
00321         BOOLEAN SelectUsimPb(UsimPbLocation location);
00322
00324         UsimPbLocation GetSelectedUsimPb() const;
00325
00328         BOOLEAN DeselectUsimPb();
00329
00330
00331     /* //////////////////////////////////////////////////////////////////
00332     //
00333     // these calls are called internally
00334     //
00336
00337         void Reset();
00338         void CancelAllSimRequests() { m_simaccessor.CancelAllRequests(); }
00339
00340         void SetSecLockStates(const SecLockStates & lockstates);
00341         void SetSimLockStates(const SimLockStates & lockstates);
00342
00343         BOOLEAN RefreshData(const SimRefreshIndArg & arg);
00344         BOOLEAN RefreshDataSimTk(const SimEfRefresh & refreshstruct);
00345         BOOLEAN RefreshSimMruProperty(const SimMruPropertyRefreshIndArg & arg);
00346
00347         void SetSimInfo(const SimInfo & info);
00348         void SetSimAccess(const SimIndicator indicator);
00349         void SetSimInitInfo(const SimInitResult & info, const Imsi & imsi, UINT8 adnbyte, UINT8 bdnbyte);
00350         void SetSimErrorCode(const SimErrorCode errorcode);
00351         void SetMdhWaitingIndicatorArray(const MdhWaitIndicatorArray & wia);
00352         void SetCfuServiceArray(const CfuServiceArray & servicearray);
00353         void SetEccNetworkArray(const EccNetworkArray & eccarray);
00354
00355         void ReloadNewMsgTpdu(Tpdu &tpdu, INT tpduno);
00356         void ReloadTpdu(INT recno);
00357         BOOLEAN StoreTpdu(const Tpdu &tpdu);
00358         BOOLEAN StoreTpdu(const Tpdu &tpdu, const Sms::StorageType storage_type);
00359         BOOLEAN ActivateSmsUsage();
00360         void SetMaxConcRefNo(UINT16 refno);
00361
00362         void SetSimTkMainMenu(const SetupMenuReqArg & arg);
00363         void SetBatteryLoadLevel(const BatteryLoadLevel level);
00364
00365         void SetRegisterMode(const RegisterMode mode);
00366         void SetRegisterStatus(const RegisterStatus status);
00367         void SetRegisteredPlmn(const Plmn & plmn);
00368         void SetRegisterRejectCause(const RegisterRejectCause rejectcause);
00369
00370         void SetSignalStrengthLevel(const SignalStrengthLevel signalstrength);
00371         void SetSignalQualityLevel(const SignalQualityLevel signalquality);
00372
00373
00374         void SetSignalStrengthMax(const SignalStrengthMax signalstrength);
00375         void SetSignalQualityMax(const SignalQualityMax signalquality);
00376
00377
00378         void SetGprsAttached(BOOLEAN gprs_attached);
00379
00380         void SetNetworkNameLong(const WString &network_name_long);
00381         void GetNetworkNameLong(WString &network_name_long);
00382         void SetNetworkNameShort(const WString &network_name_short);
00383         void GetNetworkNameShort(WString &network_name_short);
00384
00385         void SetTimeZone(const TimeZone &timezone);
00386         void GetTimeZone(TimeZone &timezone);
00387
00388         void GetLsaIdentifier(LsaIdentifier &lsaidentifier);
00389         void SetLsaIdentifier(const LsaIdentifier &lsaidentifier);
00390         void GetIsLsaIdentifierPresent(BOOLEAN islsaidentifierpresent);
00391         void SetIsLsaIdentifierPresent(const BOOLEAN islsaidentifierpresent);
00392
00393         void SetLastCcm(UINT32 last_ccm);
00394     // SetLastCcm2 is used for Line2 when using ALS
00395         void SetLastCcm2(UINT32 last_ccm);
00396
00397         void SetLai(const Lai &lai);
00398         void SetCellId(const CellId & cellid);
00399
00400         void SetGprsClass(const GprsClass gprs_class){m_statusprovider.SetGprsClass(gprs_class);}
00401         void SetGprsClassChangeOrigin(const ProcessSource gprs_class_change_origin){m_statusprovider.SetGprsClassChangeOrigin(gprs_class_change_origin);}
00402         void SetRadioAccessTechnology(const RadioAccessTechnology &rat){m_statusprovider.SetRadioAccessTechnology(rat);}
00403         void SetGsmBand(const GsmBand & band){m_statusprovider.SetGsmBand(band);}
00404         void SetPowerMode(PowerMode power_mode) {m_statusprovider.SetPowerMode(power_mode);}
00405         void SetRatChangeMode(const RatChangeMode &rat_change_mode){m_statusprovider.SetRatChangeMode(rat_change_mode);}
00406         void SetScanStatus(BOOLEAN scan_status);
00407         BOOLEAN GetScanStatus();
00408         RadioAccessTechnology GetRadioAccessTechnology(){return m_statusprovider.GetRadioAccessTechnology();}
00409         GsmBand GetGsmBand(){return m_statusprovider.GetGsmBand();}
00410         BatteryLoadLevel GetBatteryLoadLevel(){return m_statusprovider.GetBatteryLoadLevel();}
00411         SignalStrengthLevel GetSignalStrengthLevel(){return m_statusprovider.GetSignalStrengthLevel();}
00412         SignalQualityLevel GetSignalQualityLevel(){return m_statusprovider.GetSignalQualityLevel();}
00413
00414     private:
00415         SimAccessor             m_simaccessor;       // responsible for retrieving data from sim
00416
00417         SimAuxHandler           m_simauxhandler;
00418         SimSmsParamHandler      m_smsparamhandler;
00419         SimPduHandler           m_simpduhandler;
00420         SimPbBaseHandler        m_simadnhandler;
00421         SimPbBaseHandler        m_simlndhandler;
00422         SimPbBaseHandler        m_simfdnhandler;
00423         SimPbBaseHandler        m_simbdnhandler;
00424         SimPbBaseHandler        m_simsdnhandler;
00425         SimPbBaseHandler        m_simmsisdnhandler;
00426         SimPbBaseHandler        m_simcphsmboxhandler;
00427         SimPbBaseHandler        m_simcphsinfonohandler;
00428         SimPbBaseHandler        m_simmbdnhandler;
00429
00430         SimCphsHandler          m_simcphshandler;
00431         SimChvHandler           m_simchvhandler;
00432
00433
00434         AuxProvider             m_auxprovider;
00435         PrefPlmnProvider        m_prefplmnprovider;
00436         PrefLangProvider        m_preflangprovider;
00437         PrefExtLangProvider     m_prefextlangprovider;
00438         EccProvider             m_eccprovider;
00439         SstProvider             m_sstprovider;
00440
00441         PbBaseProvider          m_adnprovider;
00442         PbBaseProvider          m_msisdnprovider;
00443         PbBaseProvider          m_fdnprovider;
00444         PbBaseProvider          m_lndprovider;
00445         PbBaseProvider          m_cphsmboxprovider;
00446         PbBaseProvider          m_cphsinfonoprovider;
00447         PbBaseProvider          m_bdnprovider;
00448         PbBaseProvider          m_sdnprovider;
00449         PbBaseProvider          m_mbdnprovider;
00450
00451         ChvProvider             m_chvprovider;
00452
00453         SmsProvider             m_sms_provider;
00454
00455 #if defined(APOXI_SMS_NEW_PROVIDERS)
00456         SmsBaseInboxProvider        m_sms_base_inbox_provider;
00457         SmsBaseOutboxProvider       m_sms_base_outbox_provider;
00458         SmsBaseArchiveProvider      m_sms_base_archive_provider;
00459         SmsBaseStatusReportProvider m_sms_base_statusreport_provider;
00460         SmsBaseUnreadProvider       m_sms_base_unread_provider;
00461 #elif !defined(APOXI_DISABLE_FILTERED_SMS_PROVIDERS)
00462         SmsReadProvider         m_sms_read_provider;
00463         SmsUnreadProvider       m_sms_unread_provider;
00464         SmsSentProvider         m_sms_sent_provider;
00465         SmsUnsentProvider       m_sms_unsent_provider;
00466 #endif  // (APOXI_SMS_NEW_PROVIDERS
00467
00468         SmsParamProvider        m_smsparamprovider;
00469         SmsCountProvider        m_sms_count_provider;
00470         SmsMsgWaitingProvider   m_sms_msg_wait_provider;
00471
00472         CphsAuxProvider         m_cphs_auxprovider;
00473         CphsServPflProvider     m_cphs_servpflprovider;
00474
00475         CbmiProvider            m_cbmiprovider;
00476         CbmiRangeProvider       m_cbmirangeprovider;
00477
00478         SimTkMainMenuProvider   m_simtkmainmenuprov;
00479         SmsClass0Provider       m_sms_class0_provider;
00480
00481         CountryProvider         m_countryprovider;
00482         PlmnProvider            m_plmnprovider;
00483         StatusProvider          m_statusprovider;
00484         LockProvider            m_lockprovider;
00485
00486         CmiProvider             m_cmiprovider;
00487         MbiProvider             m_mbiprovider;
00488
00489         Protector               m_phonebookprotector;
00490         Protector               m_smsprotector;
00491         Protector               m_auxiliaryprotector;
00492
00493 #if defined(APOXI_ICC_USIM)
00494         UstProvider             m_ustprovider;
00495         EstProvider             m_estprovider;
00496         PrefExtLangProvider     m_prefextlang2provider;
00497 #endif
00498         EccCustomization        m_ecccustomization;
00499         SimServices             m_simservices;
00500
00501 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00502     public:
00503         UsimPbHandler * GetUsimPbHandler() { return (&m_usimpbhandler); }
00504     private:
00505         UsimPbAccessor          m_usimpbaccessor;
00506         UsimPbHandler           m_usimpbhandler;
00507         UsimPbXasProvider       m_usimpb_gas_provider;
00508         UsimPbXasProvider       m_usimpb_aas_provider;
00509         UsimPbPropertyProvider  m_usimpb_prop_provider;
00510         UsimPbProvider          m_usimpb_provider;
00511 #endif
00512
00513 };
00514
00515 /*  ========================================================================
00516     BootState
00517     ======================================================================== */
00518
00522 class BootState
00523 {
00524     public:
00525         enum {
00526             NO_PROVIDERS = c_end_provider_range - c_start_provider_range,
00527             BITS_PER_UINT = sizeof(UINT) * 8,
00528             BITFIELDSIZE = (((NO_PROVIDERS*2) + BITS_PER_UINT - 1) / BITS_PER_UINT) * BITS_PER_UINT,
00529         };
00530
00531         BootState();
00532         ~BootState();
00533
00535         BOOLEAN IsUpdated(INT providerid) const;
00537         BOOLEAN IsAvailable(INT providerid) const;
00538
00540         void SetUpdated(INT providerid);
00542         void SetAvailable(INT providerid);
00543
00544 #if defined(_DEBUG)
00545         void DumpStates();
00546 #endif
00547
00548     private:
00549         // first NO_PROVIDERS describes IsLoaded, next NO_PROVIDERS describes IsAvailable
00550         BitVector<BITFIELDSIZE> m_bitvector;
00551 };
00552
00553 /*  ========================================================================
00554     BootControl
00555     ======================================================================== */
00556
00560 class BootControl
00561 {
00562     public:
00563         friend class SmsLoadingFinishedCondition;
00564
00565         BootControl();
00566         ~BootControl();
00567         enum {
00568             NO_PROVIDERS = c_end_provider_range - c_start_provider_range,
00569         };
00570
00571
00572         // is called from Asc/BootHandler
00573         void RequestOnStartup(INT providerid, BootNotification notification);
00574
00575         // is called from Asc/BootDispatcher
00576         void StartLoading();
00577
00578         // is called from Asc/BootDispatcher
00579         void OnFinishedSmsLoading();
00580
00581         // is called from handlers and providers
00582         void SendDataControlBootProgressMsg(INT providerid, INT progress);
00583
00584         // is called after a Sim init is received
00585         void DisableLoading() { m_allowed = FALSE; }
00586
00587         // is called after a Sim full access is received
00588         void EnableLoading() { m_allowed = TRUE; }
00589
00590         // checks if loading is allowed
00591         BOOLEAN IsLoadingAllowed() { return m_allowed; }
00592
00593     private:
00594         BootNotification GetBootNotification(INT providerid);
00595         BOOLEAN ShallBeLoaded(INT providerid);
00596         void UpdateProvider(INT providerid);
00597         void SendDataControlBootMsg();
00598
00599         UINT8 m_provider_control[NO_PROVIDERS];
00600
00601         BootState m_bootstate;
00602         BOOLEAN   m_smsloaded;
00603         BOOLEAN   m_allowed;
00604 };
00605
00606 /*  ========================================================================
00607     DataControl
00608     ======================================================================== */
00609
00613 class DataControl : public SubSystem
00614 {
00615     public:
00616         typedef SubSystem Base;
00617
00618         DataControl();
00619
00620         virtual ~DataControl();
00621
00622         virtual const WCHAR* GetName() const;
00623
00624         virtual void OnPowerUp();
00625
00626         virtual void OnPowerDown();
00627
00628         virtual UINT8 GetPriority() const;
00629
00630         virtual SubSystemManager::BootSequenceState InvokeAt() const;
00631
00633         static DataHandler* GetDataHandler();
00635         static MainProvider* GetMainProvider();
00637         static void PostNotification(DataControlType type);
00639         static SimAccessor * GetSimAccessor() { return m_datahandler.GetSimAccessor(); }
00641         static BootControl * GetBootControl() { return &m_bootcontrol; }
00642
00643     private:
00644         static DataControl * m_instance;
00645         static DataHandler   m_datahandler;
00646         static BootControl   m_bootcontrol;
00647 };
00648
00649 /*  ========================================================================
00650     LookupAlphaIdExtension
00651     ======================================================================== */
00652
00661 class LookupAlphaIdExtension {
00662
00663     public:
00665         LookupAlphaIdExtension();
00667         virtual ~LookupAlphaIdExtension();
00668
00671         static LookupAlphaIdExtension* GetInstance();
00673         static void Register(LookupAlphaIdExtension * alpha);
00675         static void Unregister();
00677         static BOOLEAN IsRegistered();
00679         virtual BOOLEAN LookupAlphaId(const PhoneNumber & phno, WString & alphaid);
00680
00681     private:
00682         static LookupAlphaIdExtension * m_registerdalphaid;
00683 };
00684
00685
00687 #endif
00688
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/DirectoryIterator.hpp File Reference

Adc/DirectoryIterator.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/DirectoryIterator.hpp Source File

Adc/DirectoryIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/DirectoryIterator.hpp. Please use " \
00010     "Afs/Rfs/DirectoryIterator.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/DirectoryIterator.hpp>
00014 #else
00015     #error Adc/DirectoryIterator.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/EccProvider.cpp File Reference

Adc/EccProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "EccProvider.hpp"

Include dependency graph for EccProvider.cpp:

Functions

WString | GetEccWString (INT idx)

Variables

const INT | c_emergency_list_length = MSAP_EMERGENCY_LIST_LENGTH
const INT | c_emergency_list_length_sim = MSAP_EMERGENCY_LIST_LENGTH_SIM

Function Documentation

WString GetEccWString ( INT idx )

Variable Documentation

const INT c_emergency_list_length = MSAP_EMERGENCY_LIST_LENGTH

const INT c_emergency_list_length_sim = MSAP_EMERGENCY_LIST_LENGTH_SIM

Generated on Tue Jan 24 14:53:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/EccProvider.hpp File Reference

Adc/EccProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>

Include dependency graph for EccProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EccCustomization
class | EccProvider

Defines

#define | Adc_EccProvider_hpp

Variables

const INT | c_max_customizable_codes = 1

Define Documentation

#define Adc_EccProvider_hpp

Generated on Tue Jan 24 14:53:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/EccProvider.hpp Source File

Adc/EccProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_EccProvider_hpp)
00015 #define Adc_EccProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimAuxHandler.hpp>
00024
00025 /*------------------------------------------------------------------
00026                             EccProvider
00027  ------------------------------------------------------------------*/
00028
00052 #if defined(APOXI_ENABLE_ECC_CUSTOMIZATION)
00053     const INT c_max_customizable_codes = MAX_ECC_LIST_LEN;
00054 #else
00055     const INT c_max_customizable_codes = 1;
00056 #endif
00057
00058 class EccProvider : public ThreadSafeProvider
00059 {
00060     public:
00061         typedef ThreadSafeProvider Base;
00063         EccProvider();
00065         virtual ~EccProvider();
00067         virtual INT GetProviderId() const;
00069         void Init(SimAuxHandler * aux_handler, Protector * protector);
00071         virtual INT RowCount();
00073         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00075         virtual BOOLEAN Update(ProviderListener * listener = 0);
00076
00077         BOOLEAN IsEccCode(const WString & checkstr);
00078
00079         EccCategory GetEccCategory(const WString & checkstr);
00080
00081         void SetEccNetworkArray(const EccNetworkArray & eccarray);
00082
00083     private:
00084         INT GetNoOfBuiltinEccCodes();
00085         BOOLEAN FillCustomizedEccs();
00086
00087         void GetNetworkEcc(INT idx, WString & eccstr, UINT8 & ecccategory);
00088         INT GetNoOfNetworkEccs() { return m_networkarray.m_number; }
00089
00090         SimAuxHandler * m_aux_handler;
00091         EccNetworkArray m_networkarray;
00092
00093         WString         m_actual_cust_codes[c_max_customizable_codes];
00094         INT             m_noofcustomizedcodes;
00095
00096 };
00097
00098 /*------------------------------------------------------------------
00099                             EccCustomization
00100  ------------------------------------------------------------------*/
00101
00102 #if defined(APOXI_ENABLE_ECC_CUSTOMIZATION)
00103
00110
00111 enum EccSimValidity {
00113     EccNotValid = 0x00,                                         // no bit set
00115     EccValidSimNotPresent = MSAP_ECC_SIM_NOT_PRES,              // bit 0 set
00117     EccValidSimPresent = MSAP_ECC_SIM_PRES,                     // bit 1 set
00119     EccValidAlways  = MSAP_ECC_SIM_PRES | MSAP_ECC_SIM_NOT_PRES // bit 0 and 1 set
00120 };
00121
00123 class EccCustomization
00124 {
00125     public:
00126         EccCustomization();
00127         ~EccCustomization();
00128
00131         BOOLEAN AddEccCode(const WString & ecccode, EccSimValidity validity);
00132
00139         BOOLEAN SetEccVector(INT bufferlen, const UINT8 * buffer);
00140
00142         BOOLEAN Clear();
00143
00146         BOOLEAN Commit(BOOLEAN dont_use_hardcoded_eccs);
00147
00148     // Gets the ECC as WString
00149         BOOLEAN GetEcc(INT idx, WString & ecc);
00150     // Gets the EccSimValidity
00151         EccSimValidity GetEccSimValidity(INT idx);
00152     // Gets the overall number of set m_noofcodes
00153         INT GetNoOfCodes() { return m_codes.len; }
00154     // Shall be hardcoded eccs be used
00155         BOOLEAN AreHardcodedEccsUsed() { return ! m_dont_use_hardcoded_eccs; }
00156
00157     private:
00158         T_ECC_CUST_LIST m_codes;
00159         BOOLEAN         m_dont_use_hardcoded_eccs;
00160 };
00161
00162 #else
00163
00164 // dummy object for the case APOXI_ENABLE_ECC_CUSTOMIZATION is not set
00165 class EccCustomization
00166 {
00167 };
00168
00169 #endif
00170
00171
00173 #endif
00174
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FfsHandler.hpp File Reference

Adc/FfsHandler.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FfsHandler.hpp Source File

Adc/FfsHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FfsHandler.hpp. Please use " \
00010     "Afs/Ffs/FfsHandler.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Ffs/FfsHandler.hpp>
00014 #else
00015     #error Adc/FfsHandler.hpp was moved to Afs/Ffs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FfsMimeTypeMap.hpp File Reference

Adc/FfsMimeTypeMap.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 14:53:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FfsMimeTypeMap.hpp Source File

Adc/FfsMimeTypeMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if defined(APOXI_COMPILER_MSVC)
00009 #pragma message("Reference to old Adc/FfsMimeTypeMap.hpp. Please use " \
00010     "Afs/Ffs/FfsMimeTypeMap.hpp instead.")
00011 #endif
00012
00013 #if defined(APOXI_COMPAT_2_2_0)
00014     #include <Afs/Ffs/FfsMimeTypeMap.hpp>
00015 #else
00016     #error Adc/FfsMimeTypeMap.hpp was moved to Afs/Ffs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00017 #endif
00018
00019
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FfsSim.hpp File Reference

Adc/FfsSim.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FfsSim.hpp Source File

Adc/FfsSim.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FfsSim.hpp. Please use " \
00010     "Afs/Ffs/FfsSim.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Ffs/FfsSim.hpp>
00014 #else
00015     #error Adc/FfsSim.hpp was moved to Afs/Ffs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FfsTypes.hpp File Reference

Adc/FfsTypes.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FfsTypes.hpp Source File

Adc/FfsTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FfsTypes.hpp. Please use " \
00010     "Afs/Ffs/FfsTypes.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Ffs/FfsTypes.hpp>
00014 #else
00015     #error Adc/FfsTypes.hpp was moved to Afs/Ffs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/File.hpp File Reference

Adc/File.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 14:53:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/File.hpp Source File

Adc/File.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if defined(APOXI_COMPILER_MSVC)
00009 #pragma message("Reference to old Adc/File.hpp. Please use " \
00010     "Afs/Rfs/File.hpp instead.")
00011 #endif
00012
00013 #if defined(APOXI_COMPAT_2_2_0)
00014     #include <Afs/Rfs/File.hpp>
00015 #else
00016     #error Adc/File.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00017 #endif
00018
00019
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileBinData.hpp File Reference

Adc/FileBinData.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileBinData.hpp Source File

Adc/FileBinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FileBinData.hpp. Please use " \
00010     "Afs/Rfs/FileBinData.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/FileBinData.hpp>
00014 #else
00015     #error Adc/FileBinData.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileChunkOperator.hpp File Reference

Adc/FileChunkOperator.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileChunkOperator.hpp Source File

Adc/FileChunkOperator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FileChunkOperator.hpp. Please use " \
00010     "Afs/Rfs/FileChunkOperator.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/FileChunkOperator.hpp>
00014 #else
00015     #error Adc/FileChunkOperator.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileDataSink.hpp File Reference

Adc/FileDataSink.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileDataSink.hpp Source File

Adc/FileDataSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FileDataSink.hpp. Please use " \
00010     "Afs/Rfs/FileDataSink.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/FileDataSink.hpp>
00014 #else
00015     #error Adc/FileDataSink.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileDataSource.hpp File Reference

Adc/FileDataSource.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileDataSource.hpp Source File

Adc/FileDataSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FileDataSource.hpp. Please use " \
00010     "Afs/Rfs/FileDataSource.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/FileDataSource.hpp>
00014 #else
00015     #error Adc/FileDataSource.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileFilter.hpp File Reference

Adc/FileFilter.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileFilter.hpp Source File

Adc/FileFilter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FileFilter.hpp. Please use " \
00010     "Afs/Rfs/FileFilter.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/FileFilter.hpp>
00014 #else
00015     #error Adc/FileFilter.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileVisitor.hpp File Reference

Adc/FileVisitor.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FileVisitor.hpp Source File

Adc/FileVisitor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FileVisitor.hpp. Please use " \
00010     "Afs/Rfs/FileVisitor.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/FileVisitor.hpp>
00014 #else
00015     #error Adc/FileVisitor.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FlashDirectoryIteratorImp.hpp File Reference

Adc/FlashDirectoryIteratorImp.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FlashDirectoryIteratorImp.hpp Source File

Adc/FlashDirectoryIteratorImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FlashDirectoryIteratorImp.hpp. Please use " \
00010     "AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp>
00014 #else
00015     #error Adc/FlashDirectoryIteratorImp.hpp was moved to AddOns/AfsFfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FlashFileImp.hpp File Reference

Adc/FlashFileImp.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:53:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FlashFileImp.hpp Source File

Adc/FlashFileImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FlashFileImp.hpp. Please use " \
00010     "AddOns/AfsFfs/FlashFileImp.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <AddOns/AfsFfs/FlashFileImp.hpp>
00014 #else
00015     #error Adc/FlashFileImp.hpp was moved to AddOns/AfsFfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FlashStorageDeviceImp.hpp File Reference

Adc/FlashStorageDeviceImp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 14:53:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FlashStorageDeviceImp.hpp Source File

Adc/FlashStorageDeviceImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FlashStorageDeviceImp.hpp. Please use " \
00010     "AddOns/AfsFfs/FlashStorageDeviceImp.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <AddOns/AfsFfs/FlashStorageDeviceImp.hpp>
00014 #else
00015     #error Adc/FlashStorageDeviceImp.hpp was moved to AddOns/AfsFfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FlsFile.hpp File Reference

Adc/FlsFile.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 14:53:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/FlsFile.hpp Source File

Adc/FlsFile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/FlsFile.hpp. Please use " \
00010     "Afs/Ffs/FlsFile.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Ffs/FlsFile.hpp>
00014 #else
00015     #error Adc/FlsFile.hpp was moved to Afs/Ffs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/Lib.hpp File Reference

Adc/Lib.hpp File Reference

#include <Adc/DataHandler.hpp>
#include <Adc/SimAccessor.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/BaseDataHandler.hpp>
#include <Adc/MsgTypes.hpp>
#include <Adc/CompoundSmsItem.hpp>

Include dependency graph for Lib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Adc_Lib_hpp

Define Documentation

#define Adc_Lib_hpp

Generated on Tue Jan 24 14:53:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/Lib.hpp Source File

Adc/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_Lib_hpp)
00010 #define Adc_Lib_hpp
00013
00014 #include <Adc/DataHandler.hpp>
00015 #include <Adc/SimAccessor.hpp>
00016 #include <Adc/ProvIds.hpp>
00017 #include <Adc/BaseDataHandler.hpp>
00018 #include <Adc/MsgTypes.hpp>
00019 #include <Adc/CompoundSmsItem.hpp>
00020
00022 #endif
00023
00024
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/LockProvider.cpp File Reference

Adc/LockProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "LockProvider.hpp"

Include dependency graph for LockProvider.cpp:

Generated on Tue Jan 24 14:54:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/LockProvider.hpp File Reference

Adc/LockProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Apc/LockTypes.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimChvHandler.hpp>

Include dependency graph for LockProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LockProvider

Defines

#define | Adc_LockProvider_hpp

Define Documentation

#define Adc_LockProvider_hpp

Generated on Tue Jan 24 14:54:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/LockProvider.hpp Source File

Adc/LockProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_LockProvider_hpp)
00015 #define Adc_LockProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021 #include <Apc/LockTypes.hpp>
00022
00023 #include <Adc/ProvIds.hpp>
00024 #include <Adc/SimChvHandler.hpp>
00025
00026
00027 /*------------------------------------------------------------------
00028                             LockProvider
00029  ------------------------------------------------------------------*/
00030
00061 class LockProvider : public ThreadSafeProvider
00062 {
00063     public:
00064         typedef ThreadSafeProvider Base;
00066         LockProvider();
00068         virtual ~LockProvider();
00070         virtual INT GetProviderId() const;
00072         void Init(SimChvHandler * chv_handler, Protector * protector);
00074         virtual INT RowCount();
00076         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00077
00078     private:
00079         SimChvHandler *m_chv_handler;
00080 };
00081
00083 #endif
00084
00085
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/MbiProvider.cpp File Reference

Adc/MbiProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "MbiProvider.hpp"

Include dependency graph for MbiProvider.cpp:

Generated on Tue Jan 24 14:54:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/MbiProvider.hpp File Reference

Adc/MbiProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>

Include dependency graph for MbiProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MbiProvider

Defines

#define | Adc_MbiProvider_hpp

Define Documentation

#define Adc_MbiProvider_hpp

Generated on Tue Jan 24 14:54:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/MbiProvider.hpp Source File

Adc/MbiProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_MbiProvider_hpp)
00015 #define Adc_MbiProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimAuxHandler.hpp>
00024
00025 /*------------------------------------------------------------------
00026                             MbiProvider
00027  ------------------------------------------------------------------*/
00028
00047 class MbiProvider : public ThreadSafeProvider
00048 {
00049     public:
00050         typedef ThreadSafeProvider Base;
00051
00053         MbiProvider();
00055         virtual ~MbiProvider();
00057         virtual INT GetProviderId() const;
00059         void Init(SimAuxHandler * handler, Protector * protector);
00061         virtual BOOLEAN SelectRow(INT row);
00063         virtual INT RowCount();
00065         virtual INT MaxRowCount();
00067         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00069         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00071         virtual BOOLEAN CommitRow(INT row);
00073         virtual BOOLEAN Update(ProviderListener * listener = 0);
00074
00075
00076     private:
00077         void ClearBufferVariables();
00078
00079         SimAuxHandler * m_aux_handler;
00080         UINT8 m_buffer[c_max_mbi_record_length];
00081
00082 };
00083
00085 #endif
00086
00087
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/MimeTypeTable.hpp File Reference

Adc/MimeTypeTable.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:54:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/MimeTypeTable.hpp Source File

Adc/MimeTypeTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/MimeTypeTable.hpp. Please use " \
00010     "Auxiliary/MimeTypeTable.hpp and/or Adc/FfsMimeTypeMap.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_1_13_0)
00013     // Adc/MimeTypeTable.hpp moved to Auxiliary and the FFS related methods
00014     // moved to new file Adc/FfsMimeTypeMap.hpp.
00015     #include <Auxiliary/MimeTypeTable.hpp>
00016 #else
00017     #error Adc/MimeTypeTable.hpp is out of date. Nevertheless, to use it define APOXI_COMPAT_1_13_0.
00018 #endif
00019
00020
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/MsgTypes.cpp File Reference

Adc/MsgTypes.cpp File Reference

#include "Adc/PreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/MsgTypes.hpp File Reference

Adc/MsgTypes.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/Application.hpp>
#include <Adc/Types.hpp>
#include <Adc/DataHandler.hpp>
#include <Apc/UsimPbTypes.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataControlBootMsg
class | DataControlBootProgressMsg
class | DataControlEndBootMsg
class | DataControlModificationMsg
class | DataControlPhonebookStateMsg
class | DataControlStartBootMsg
class | UsimPbReadyMsg
class | UsimPbResetedMsg

Defines

#define | Adc_MsgTypes_hpp

Define Documentation

#define Adc_MsgTypes_hpp

Generated on Tue Jan 24 14:55:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/MsgTypes.hpp Source File

Adc/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\grossau_latest_sv\lnz_apoxi\Apoxi\Adc\MsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Adc_MsgTypes_hpp)
00016 #define Adc_MsgTypes_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Kernel/Application.hpp>
00021 #include <Adc/Types.hpp>
00022 #include <Adc/DataHandler.hpp>
00023 #include <Apc/UsimPbTypes.hpp>
00024
00025
00026 /* ----------------------------------------------------------------------
00027     Classes
00028     ---------------------------------------------------------------------- */
00029
00030 /*  ======================================================================
00031     Class DataControlModificationMsg
00032     ====================================================================== */
00033
00034 class DataControlModificationMsg : public Message {
00035     public:
00036         DataControlModificationMsg(const DataControlType& dataControlType, Application* application);
00037         virtual ~DataControlModificationMsg();
00038
00039         virtual const MsgMetaData& GetMetaData() const;
00040         void SetDataControlType(const DataControlType& dataControlType) { m_dataControlType = dataControlType; }
00041         const DataControlType& GetDataControlType() const { return m_dataControlType; }
00042         void SetApplication(Application* application) { m_application = application; }
00043         Application* GetApplication() const { return m_application; }
00044         virtual Message* Clone() const;
00045
00046         enum  {
00047             ID = 19000
00048             };
00049
00050     private:
00051         static const MsgMetaData m_meta_data;
00052         DataControlType m_dataControlType;
00053         Application* m_application;
00054
00055     };
00056
00057
00058 /*  ======================================================================
00059     Class DataControlStartBootMsg
00060     ====================================================================== */
00061
00062 class DataControlStartBootMsg : public Message {
00063     public:
00064         DataControlStartBootMsg();
00065         virtual ~DataControlStartBootMsg();
00066
00067         virtual const MsgMetaData& GetMetaData() const;
00068         virtual Message* Clone() const;
00069
00070         enum  {
00071             ID = 19001
00072             };
00073
00074     private:
00075         static const MsgMetaData m_meta_data;
00076
00077     };
00078
00079
00080 /*  ======================================================================
00081     Class DataControlBootProgressMsg
00082     ====================================================================== */
00083
00084 class DataControlBootProgressMsg : public Message {
00085     public:
00086         DataControlBootProgressMsg(INT provider_id, INT progress);
00087         virtual ~DataControlBootProgressMsg();
00088
00089         virtual const MsgMetaData& GetMetaData() const;
00090         void SetProviderId(INT provider_id) { m_provider_id = provider_id; }
00091         INT GetProviderId() const { return m_provider_id; }
00092         void SetProgress(INT progress) { m_progress = progress; }
00093         INT GetProgress() const { return m_progress; }
00094         virtual Message* Clone() const;
00095
00096         enum  {
00097             ID = 19002
00098             };
00099
00100     private:
00101         static const MsgMetaData m_meta_data;
00102         INT m_provider_id;
00103         INT m_progress;
00104
00105     };
00106
00107
00108 /*  ======================================================================
00109     Class DataControlBootMsg
00110     ====================================================================== */
00111
00112 class DataControlBootMsg : public Message {
00113     public:
00114         DataControlBootMsg(const BootState& boot_state);
00115         virtual ~DataControlBootMsg();
00116
00117         virtual const MsgMetaData& GetMetaData() const;
00118         void SetBootState(const BootState& boot_state) { m_boot_state = boot_state; }
00119         const BootState& GetBootState() const { return m_boot_state; }
00120         virtual Message* Clone() const;
00121
00122         enum  {
00123             ID = 19003
00124             };
00125
00126     private:
00127         static const MsgMetaData m_meta_data;
00128         BootState m_boot_state;
00129
00130     };
00131
00132
00133 /*  ======================================================================
00134     Class DataControlEndBootMsg
00135     ====================================================================== */
00136
00137 class DataControlEndBootMsg : public Message {
00138     public:
00139         DataControlEndBootMsg(const BootState& boot_state);
00140         virtual ~DataControlEndBootMsg();
00141
00142         virtual const MsgMetaData& GetMetaData() const;
00143         void SetBootState(const BootState& boot_state) { m_boot_state = boot_state; }
00144         const BootState& GetBootState() const { return m_boot_state; }
00145         virtual Message* Clone() const;
00146
00147         enum  {
00148             ID = 19004
00149             };
00150
00151     private:
00152         static const MsgMetaData m_meta_data;
00153         BootState m_boot_state;
00154
00155     };
00156
00157
00158 /*  ======================================================================
00159     Class DataControlPhonebookStateMsg
00160     ====================================================================== */
00161
00162 class DataControlPhonebookStateMsg : public Message {
00163     public:
00164         DataControlPhonebookStateMsg(BOOLEAN fdn_enabled, BOOLEAN bdn_enabled);
00165         virtual ~DataControlPhonebookStateMsg();
00166
00167         virtual const MsgMetaData& GetMetaData() const;
00168         void SetFdnEnabled(BOOLEAN fdn_enabled) { m_fdn_enabled = fdn_enabled; }
00169         BOOLEAN IsFdnEnabled() const { return m_fdn_enabled; }
00170         void SetBdnEnabled(BOOLEAN bdn_enabled) { m_bdn_enabled = bdn_enabled; }
00171         BOOLEAN IsBdnEnabled() const { return m_bdn_enabled; }
00172         virtual Message* Clone() const;
00173
00174         enum  {
00175             ID = 19005
00176             };
00177
00178     private:
00179         static const MsgMetaData m_meta_data;
00180         BOOLEAN m_fdn_enabled;
00181         BOOLEAN m_bdn_enabled;
00182
00183     };
00184
00185
00186 /*  ======================================================================
00187     Class UsimPbReadyMsg
00188     ====================================================================== */
00189
00191 class UsimPbReadyMsg : public Message {
00192     public:
00193         UsimPbReadyMsg(const UsimPbResult& usim_pb_result);
00194         virtual ~UsimPbReadyMsg();
00195
00196         virtual const MsgMetaData& GetMetaData() const;
00197         void SetUsimPbResult(const UsimPbResult& usim_pb_result) { m_usim_pb_result = usim_pb_result; }
00198         const UsimPbResult& GetUsimPbResult() const { return m_usim_pb_result; }
00199         virtual Message* Clone() const;
00200
00201         enum  {
00202             ID = 19010
00203             };
00204
00205     private:
00206         static const MsgMetaData m_meta_data;
00207         UsimPbResult m_usim_pb_result;
00208
00209     };
00210
00211
00212 /*  ======================================================================
00213     Class UsimPbResetedMsg
00214     ====================================================================== */
00215
00217 class UsimPbResetedMsg : public Message {
00218     public:
00219         UsimPbResetedMsg();
00220         virtual ~UsimPbResetedMsg();
00221
00222         virtual const MsgMetaData& GetMetaData() const;
00223         virtual Message* Clone() const;
00224
00225         enum  {
00226             ID = 19011
00227             };
00228
00229     private:
00230         static const MsgMetaData m_meta_data;
00231
00232     };
00233
00234 #endif // Adc_MsgTypes_hpp
00235
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/Path.hpp File Reference

Adc/Path.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:56:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/Path.hpp Source File

Adc/Path.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/Path.hpp. Please use " \
00010     "Afs/Rfs/Path.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/Path.hpp>
00014 #else
00015     #error Adc/Path.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/Pathname.hpp File Reference

Adc/Pathname.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 14:56:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/Pathname.hpp Source File

Adc/Pathname.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if defined(APOXI_COMPILER_MSVC)
00009 #pragma message("Reference to old Adc/Pathname.hpp. Please use " \
00010     "Afs/Rfs/Pathname.hpp instead.")
00011 #endif
00012
00013 #if defined(APOXI_COMPAT_2_2_0)
00014     #include <Afs/Rfs/Pathname.hpp>
00015 #else
00016     #error Adc/Pathname.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00017 #endif
00018
00019
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PathProfile.hpp File Reference

Adc/PathProfile.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 14:56:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PathProfile.hpp Source File

Adc/PathProfile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/PathProfile.hpp. Please use " \
00010     "Afs/Rfs/PathProfile.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/PathProfile.hpp>
00014 #else
00015     #error Adc/PathProfile.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PbBaseProvider.cpp File Reference

Adc/PbBaseProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SimPbEntry.hpp"
#include "PbBaseProvider.hpp"

Include dependency graph for PbBaseProvider.cpp:

Generated on Tue Jan 24 14:56:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PbBaseProvider.hpp File Reference

Adc/PbBaseProvider.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/SimPbEntry.hpp>
#include <Adc/SimPbBaseHandler.hpp>

Include dependency graph for PbBaseProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbBaseProvider

Defines

#define | Adc_PbBaseProvider_hpp

Define Documentation

#define Adc_PbBaseProvider_hpp

Generated on Tue Jan 24 14:56:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PbBaseProvider.hpp Source File

Adc/PbBaseProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_PbBaseProvider_hpp)
00015 #define Adc_PbBaseProvider_hpp
00019
00020 #include <Auxiliary/WString.hpp>
00021 #include <Auxiliary/PhoneNumber.hpp>
00022
00023 #include <Auxiliary/ThreadSafeProvider.hpp>
00024
00025 #include <Adc/SimPbEntry.hpp>
00026 #include <Adc/SimPbBaseHandler.hpp>
00027
00028 /*------------------------------------------------------------------
00029                             PbBaseProvider
00030  ------------------------------------------------------------------*/
00031
00061 class PbBaseProvider : public ThreadSafeProvider
00062 {
00063     public:
00064         typedef ThreadSafeProvider Base;
00066         PbBaseProvider();
00068         virtual ~PbBaseProvider();
00069
00070         void Init(SimPbBaseHandler * handler, Protector * protector, INT provid);
00072         virtual INT RowCount();
00074         virtual INT MaxRowCount();
00076         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00078         virtual const WString * GetWString(INT columnid, INT row);
00080         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00082         virtual BOOLEAN Update(ProviderListener * listener);
00084         virtual BOOLEAN CommitRow(INT row);
00086         virtual BOOLEAN SelectRow(INT row);
00088         virtual BOOLEAN AppendRow();
00090         virtual BOOLEAN DeleteRow(INT row);
00092         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00094         virtual BOOLEAN IsWStringDataCached() const;
00096         SimPbEntry * GetEntry(INT row) {
00097             ASSERT_DEBUG(m_handler!=0);
00098             return m_handler->GetEntry(row);
00099         };
00100
00101         virtual INT GetProviderId() const;
00103         virtual INT GetSortedColumnId() const;
00105         virtual INT GetProgress();
00106
00107
00108     protected:
00109         SimPbBaseHandler * GetHandler() { return m_handler; }
00110
00111         INT GetAlphaTagSize();
00112         INT GetTagSize();
00113
00114         void ClearBufferVariables();
00115
00116         BOOLEAN DefaultCommitRow(INT row);
00117         BOOLEAN DefaultAppendRow();
00118         BOOLEAN DefaultDeleteRow(INT row);
00119         BOOLEAN DefaultDeleteAllRows(ProviderListener * listener = 0);
00120
00121         WString     m_commit_string;
00122         PhoneNumber m_commit_phonenumber;
00123         Number      m_commit_cmi_no;
00124
00125
00126         SimPbBaseHandler * m_handler;
00127         INT                m_provid;
00128
00129 };
00130
00131
00133 #endif
00134
00135
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PlmnProvider.cpp File Reference

Adc/PlmnProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Auxiliary/FilterRule.hpp>
#include <Auxiliary/Find2Provider.hpp>
#include "PlmnProvider.hpp"

Include dependency graph for PlmnProvider.cpp:

Generated on Tue Jan 24 14:56:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PlmnProvider.hpp File Reference

Adc/PlmnProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>
#include <Apc/SignalTypes.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/CountryProvider.hpp>

Include dependency graph for PlmnProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PlmnProvider

Defines

#define | Adc_PlmnProvider_hpp

Define Documentation

#define Adc_PlmnProvider_hpp

Generated on Tue Jan 24 14:56:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PlmnProvider.hpp Source File

Adc/PlmnProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_PlmnProvider_hpp)
00015 #define Adc_PlmnProvider_hpp
00019
00020 #include <Auxiliary/Provider.hpp>
00021 #include <Apc/SignalTypes.hpp>
00022
00023 #include <Adc/ProvIds.hpp>
00024 #include <Adc/CountryProvider.hpp>
00025
00026
00027 /*------------------------------------------------------------------
00028                             PlmnProvider
00029  ------------------------------------------------------------------*/
00030
00051 class PlmnProvider : public Provider
00052 {
00053     public:
00054         typedef Provider Base;
00056         PlmnProvider();
00058         virtual INT GetProviderId() const;
00060         virtual ~PlmnProvider();
00061
00062         virtual Status GetStatus() const;
00064         virtual INT RowCount();
00066         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00068         BOOLEAN LookupPlmnRow(INT & row, Mcc mcc, Mnc mnc);
00069
00070 };
00071
00073 #endif
00074
00075
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PreComp.cpp File Reference

Adc/PreComp.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:56:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PreComp.hpp File Reference

Adc/PreComp.hpp File Reference

#include <Adc/SimAccessor.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/BaseDataHandler.hpp>
#include <Adc/MsgTypes.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:16:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PreComp.hpp Source File

Adc/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Adc/SimAccessor.hpp>
00010 #include <Adc/ProvIds.hpp>
00011 #include <Adc/BaseDataHandler.hpp>
00012 #include <Adc/MsgTypes.hpp>
00013
00014
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefExtLangProvider.cpp File Reference

Adc/PrefExtLangProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "PrefExtLangProvider.hpp"

Include dependency graph for PrefExtLangProvider.cpp:

Generated on Tue Jan 24 15:25:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefExtLangProvider.hpp File Reference

Adc/PrefExtLangProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>

Include dependency graph for PrefExtLangProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PrefExtLangProvider

Defines

#define | Adc_PrefExtLangProvider_hpp

Define Documentation

#define Adc_PrefExtLangProvider_hpp

Generated on Tue Jan 24 15:25:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefExtLangProvider.hpp Source File

Adc/PrefExtLangProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_PrefExtLangProvider_hpp)
00015 #define Adc_PrefExtLangProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimAuxHandler.hpp>
00024
00025
00026 /*------------------------------------------------------------------
00027                             PrefExtLangProvider
00028  ------------------------------------------------------------------*/
00029
00050 class PrefExtLangProvider : public ThreadSafeProvider
00051 {
00052     public:
00053         typedef ThreadSafeProvider Base;
00055         PrefExtLangProvider();
00057         virtual ~PrefExtLangProvider();
00059         virtual INT GetProviderId() const;
00061         void Init(SimAuxHandler * aux_handler, Protector * protector, INT instance_nr = 0);
00063         virtual INT RowCount();
00065         virtual INT MaxRowCount();
00067         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00069         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00071         virtual BOOLEAN AppendRow();
00073         virtual BOOLEAN InsertRow(INT row);
00075         virtual BOOLEAN CommitRow(INT row);
00077         virtual BOOLEAN DeleteRow(INT row);
00079         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00081         virtual BOOLEAN Update(ProviderListener * listener = 0);
00082
00083     private:
00084         void ClearBufferVariables() {
00085             m_commit_lang.Clear();
00086         }
00087
00088         SimAuxHandler * m_aux_handler;
00089         WString         m_commit_lang;
00090         INT             m_instance_nr;
00091 };
00092
00094 #endif
00095
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefLangProvider.cpp File Reference

Adc/PrefLangProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "PrefLangProvider.hpp"

Include dependency graph for PrefLangProvider.cpp:

Generated on Tue Jan 24 15:25:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefLangProvider.hpp File Reference

Adc/PrefLangProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>

Include dependency graph for PrefLangProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PrefLangProvider

Defines

#define | Adc_PrefLangProvider_hpp

Define Documentation

#define Adc_PrefLangProvider_hpp

Generated on Tue Jan 24 15:25:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefLangProvider.hpp Source File

Adc/PrefLangProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_PrefLangProvider_hpp)
00015 #define Adc_PrefLangProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimAuxHandler.hpp>
00024
00025 /*------------------------------------------------------------------
00026                             PrefLangProvider
00027  ------------------------------------------------------------------*/
00028
00042 class PrefLangProvider : public ThreadSafeProvider
00043 {
00044     public:
00045         typedef ThreadSafeProvider Base;
00047         PrefLangProvider();
00049         virtual ~PrefLangProvider();
00051         virtual INT GetProviderId() const;
00053         void Init(SimAuxHandler * aux_handler, Protector * protector);
00055         virtual INT RowCount();
00057         virtual INT MaxRowCount();
00059         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00061         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00063         virtual BOOLEAN AppendRow();
00065         virtual BOOLEAN InsertRow(INT row);
00067         virtual BOOLEAN CommitRow(INT row);
00069         virtual BOOLEAN DeleteRow(INT row);
00071         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00073         virtual BOOLEAN Update(ProviderListener * listener = 0);
00074
00075     private:
00076         void ClearBufferVariables() {
00077             m_commit_lang = 0xFF;
00078         }
00079
00080         SimAuxHandler * m_aux_handler;
00081         UINT8           m_commit_lang;
00082 };
00083
00085 #endif
00086
00087
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefPlmnProvider.cpp File Reference

Adc/PrefPlmnProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "PrefPlmnProvider.hpp"

Include dependency graph for PrefPlmnProvider.cpp:

Generated on Tue Jan 24 15:25:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefPlmnProvider.hpp File Reference

Adc/PrefPlmnProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>

Include dependency graph for PrefPlmnProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PrefPlmnProvider

Defines

#define | Adc_PrefPlmnProvider_hpp

Define Documentation

#define Adc_PrefPlmnProvider_hpp

Generated on Tue Jan 24 15:26:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/PrefPlmnProvider.hpp Source File

Adc/PrefPlmnProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_PrefPlmnProvider_hpp)
00015 #define Adc_PrefPlmnProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimAuxHandler.hpp>
00024
00025 /*------------------------------------------------------------------
00026                             PrefPlmnProvider
00027  ------------------------------------------------------------------*/
00028
00045 class PrefPlmnProvider : public ThreadSafeProvider
00046 {
00047     public:
00048         typedef ThreadSafeProvider Base;
00050         PrefPlmnProvider();
00052         virtual ~PrefPlmnProvider();
00054         virtual INT GetProviderId() const;
00056         void Init(SimAuxHandler * aux_handler, Protector * protector);
00058         virtual INT RowCount();
00060         virtual INT MaxRowCount();
00062         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00064         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00066         virtual BOOLEAN AppendRow();
00068         virtual BOOLEAN InsertRow(INT row);
00070         virtual BOOLEAN CommitRow(INT row);
00072         virtual BOOLEAN SelectRow(INT row);
00074         virtual BOOLEAN DeleteRow(INT row);
00076         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00078         virtual BOOLEAN Update(ProviderListener * listener = 0);
00079
00080
00081     private:
00082         void ClearBufferVariables() {
00083             m_commit_mnc = InvalidMnc;
00084             m_commit_mcc = InvalidMcc;
00085             m_commit_ati = 0x0000;
00086         }
00087
00088         BcdPlmn GetBcdPlmn() const;
00089
00090         SimAuxHandler * m_aux_handler;
00091         Mnc             m_commit_mnc;
00092         Mcc             m_commit_mcc;
00093         UINT16          m_commit_ati;
00094 };
00095
00097 #endif
00098
00099
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/ProvIds.hpp File Reference

Adc/ProvIds.hpp File Reference

#include <Auxiliary/Provider.hpp>

Include dependency graph for ProvIds.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Adc_ProvIds_hpp

Typedefs

typedef __Colid | ProviderId

Enumerations

enum __Colid {
c_start_provider_range = 1000, c_aux_provider_id = 1000, c_adn_provider_id = 1001, c_msisdn_provider_id = 1002,
c_lnd_provider_id = 1003, c_fdn_provider_id = 1004, c_prefplmn_provider_id = 1005, c_preflang_provider_id = 1006,
c_status_provider_id = 1007, c_chv_provider_id = 1008, c_ecc_provider_id = 1009, c_sst_provider_id = 1010,
c_simtk_mainmenu_provider_id = 1011, c_prefextlang_provider_id = 1012, c_sms_provider_id = 1013, c_sms_unread_provider_id = 1014,
c_sms_sent_provider_id = 1015, c_sms_unsent_provider_id = 1016, c_sms_read_provider_id = 1017, c_sms_parameter_provider_id = 1018,
c_sms_class0_provider_id = 1019, c_sms_count_provider_id = 1020, c_sms_message_provider_id = 1021, c_country_provider_id = 1022,
c_plmn_provider_id = 1023, c_bdn_provider_id = 1024, c_sdn_provider_id = 1025, c_cphs_aux_provider_id = 1026,
c_cphs_mbox_provider_id = 1027, c_cphs_costumer_prof_provider_id = 1028, c_cphs_infono_provider_id = 1029, c_lock_provider_id = 1030,
c_cbmi_provider_id = 1031, c_cbmi_range_provider_id = 1032, c_ust_provider_id = 1033, c_est_provider_id = 1034,
c_cmi_provider_id = 1035, c_sms_base_inbox_provider_id = 1036, c_sms_base_outbox_provider_id = 1037, c_sms_base_archive_provider_id = 1038,
c_sms_base_statusreport_provider_id = 1039, c_sms_base_unread_provider_id = 1040, c_prefextlang2_provider_id = 1041, c_mbdn_provider_id = 1042,
c_mbi_provider_id = 1043, c_usimpb_groupname_provider_id = 1044, c_usimpb_addnumberstring_provider_id = 1045, c_usimpb_property_provider_id = 1046,
c_usimpb_provider_id = 1047, c_end_provider_range, c_imsi_id = 1100, c_mcc_id = 1101,
c_mnc_id = 1102, c_sim_ind_id = 1103, c_icc_id = 1104, c_sim_type_id = 1105,
c_sim_phase_id = 1106, c_lang_pref_id = 1107, c_fdn_state_id = 1108, c_spn_id = 1109,
c_spn_display_condition_id = 1110, c_acm_id = 1111, c_acmmax_id = 1112, c_currency_code_id = 1113,
c_currency_exp_id = 1114, c_currency_eppu_id = 1115, c_imei_id = 1116, c_sim_init_result_id = 1117,
c_acm2_id = 1118, c_ofm_to_be_activated_id = 1119, c_network_lockstate_id = 1125, c_sp_lockstate_id = 1126,
c_sim_lockstate_id = 1127, c_corporate_lockstate_id = 1128, c_sim_errorcode_id = 1129, c_loci_update_status_id = 1130,
c_loci_mcc_id = 1131, c_loci_mnc_id = 1132, c_loci_lac_id = 1133, c_loci_mnc_threedigits_id = 1134,
c_acm_chv_id = 1140, c_acmmax_chv_id = 1141, c_puct_chv_id = 1142, c_mnc_threedigits_id = 1150,
c_simpos_id = 1200, c_phone_no_id = 1201, c_name_id = 1202, c_alphatagsize_id = 1203,
c_tagsize_id = 1204, c_nextfreeposition_id = 1205, c_freeextrecords_id = 1206, c_index_level_id = 1220,
c_nw_spec_id = 1221, c_premium_serv_id = 1222, c_cmi_record_id = 1223, c_cc_id = 1301,
c_country_shortname_id = 1302, c_plmn_name_id = 1404, c_plmn_shortname_id = 1405, c_networktype_id = 1406,
c_access_technology_id = 1502, c_act_supported_id = 1503, c_mode_id = 1600, c_state_id = 1601,
c_reject_cause_id = 1602, c_signal_strength_id = 1605, c_signal_quality_id = 1606, c_battery_load_id = 1607,
c_clir_mode_id = 1608, c_redialing_active_id = 1609, c_gprs_class_id = 1610, c_gprs_class_change_origin_id = 1611,
c_network_name_long_id = 1612, c_network_name_short_id = 1613, c_tz_offset_id = 1614, c_tz_dst_id = 1615,
c_gprs_available_id = 1616, c_gprs_attached_id = 1617, c_succ_16bit_conc_sms_ref_no = 1620, c_last_ccm_id = 1621,
c_last_ccm2_id = 1622, c_lai_mcc_id = 1623, c_lai_mnc_id = 1624, c_lai_lac_id = 1625,
c_rat_id = 1626, c_gsm_band_id = 1627, c_rat_change_mode_id = 1628, c_eep_calibration_status_id = 1629,
c_pref_service_id = 1630, c_signal_strength_max_id = 1631, c_signal_quality_max_id = 1632, c_cellid_id = 1633,
c_ext_lang_pref_id = 1701, c_sms_string_id = 1800, c_sms_phonenumber_id = 1801, c_sms_date_id = 1802,
c_sms_time_id = 1803, c_sms_msg_class_id = 1804, c_sms_pdu_data_id = 1805, c_sms_status_id = 1807,
c_sms_recno_id = 1808, c_sms_msg_type_id = 1809, c_sms_coding_group_id = 1810, c_sms_dcs_id = 1811,
c_sms_message_status_id = 1812, c_sms_datetime_id = 1813, c_sms_conc_status_id = 1814, c_sms_refno_id = 1815,
c_sms_compound_sms_id = 1816, c_sms_storage_media_id = 1817, c_sms_compound_tpdu_id = 1818, c_sms_protid_id = 1819,
c_sms_sca_id = 1820, c_sms_reply_path_flag_id = 1821, c_sms_header_text_id = 1822, c_sms_conc_ref_no_id = 1830,
c_sms_conc_max_no_id = 1831, c_sms_conc_seq_no_id = 1832, c_sms_pos_id = 1833, c_sms_conc_tpdu_num_id = 1834,
c_sms_no_pdu_sim_id = 1835, c_sms_no_pdu_flash_id = 1836, c_sms_alpha_id = 1837, c_sms_extended_data_id = 1838,
c_sms_debugstring_id = 1840, c_sms_sum_id = 1850, c_sms_free_pdu_id = 1851, c_sms_tpdu_capacity_id = 1852,
c_sms_tpdu_occupied_id = 1853, c_sms_tpdu_empty_id = 1854, c_sms_unread_count_id = 1855, c_sms_read_count_id = 1856,
c_sms_unsent_count_id = 1857, c_sms_sent_count_id = 1858, c_msg_ind_level_id = 1880, c_msg_count_id = 1881,
c_msg_ind_setting_id = 1882, c_msg_ind_sms_type_id = 1883, c_msg_update_id = 1884, c_msg_position_id = 1885,
c_no_id = 1900, c_attempts_left_id = 1902, c_unblocking_attempts_left_id = 1903, c_ecc_id = 2000,
c_ecc_alpha_id = 2001, c_ecc_category_id = 2002, c_ecc_source_id = 2003, c_ecc_phonenumber_id = 2004,
c_ecc_sim_network_cnt_id = 2005, c_service_allocated_id = 2100, c_service_activated_id = 2101, c_options_id = 2200,
c_title_id = 2201, c_title_icon_id = 2202, c_title_icon_isselfexp_id = 2203, c_item_id = 2204,
c_next_action_id = 2205, c_icon_id = 2206, c_item_string_id = 2207, c_icon_isselfexp_id = 2208,
c_service_center_address_id = 2220, c_destination_address_id = 2221, c_protocol_identifier_id = 2222, c_data_coding_scheme_id = 2223,
c_validity_period_id = 2224, c_sms_param_name_id = 2225, c_smsp_alpha_id_len_id = 2226, c_cphs_phase_id = 2300,
c_infnrs_activated_id = 2301, c_infnrs_allocated_id = 2302, c_csp_activated_id = 2303, c_csp_allocated_id = 2304,
c_sst_activated_id = 2305, c_sst_allocated_id = 2306, c_mboxnrs_activated_id = 2307, c_mboxnrs_allocated_id = 2308,
c_opname_activated_id = 2309, c_opname_allocated_id = 2310, c_operator_name_id = 2315, c_operator_shortname_id = 2316,
c_msg_wait_ind_line1_id = 2317, c_msg_wait_ind_line2_id = 2318, c_msg_wait_ind_fax_id = 2319, c_msg_wait_ind_data_id = 2320,
c_call_fwd_line1_id = 2321, c_call_fwd_line2_id = 2322, c_call_fwd_fax_id = 2323, c_call_fwd_data_id = 2324,
c_line_in_use_id = 2330, c_line_is_locked_id = 2331, c_cphs_is_present_id = 2332, c_orange_welcome_msg_id = 2333,
c_serv_cfu_id = 2400, c_serv_cfb_id = 2401, c_serv_cfnry_id = 2402, c_serv_cfnrc_id = 2403,
c_serv_ct_id = 2404, c_serv_boac_id = 2405, c_serv_boic_id = 2406, c_serv_boic_exhc_id = 2407,
c_serv_baic_id = 2408, c_serv_bic_roam_id = 2409, c_serv_mpty_id = 2410, c_serv_cug_id = 2411,
c_serv_aoc_id = 2412, c_serv_pref_cug_id = 2413, c_serv_cug_oa_id = 2414, c_serv_hold_id = 2415,
c_serv_cw_id = 2416, c_serv_ccbs_id = 2417, c_serv_usr_usr_sig_id = 2418, c_serv_sm_mt_id = 2419,
c_serv_sm_mo_id = 2420, c_serv_sm_cb_id = 2421, c_serv_repl_path_id = 2422, c_serv_del_conf_id = 2423,
c_serv_protid_id = 2424, c_serv_val_per_id = 2425, c_serv_als_id = 2426, c_serv_clip_id = 2427,
c_serv_co_lr_id = 2428, c_serv_co_lp_id = 2429, c_serv_mci_id = 2430, c_serv_cli_send_id = 2431,
c_serv_cli_block_id = 2432, c_serv_gprs_id = 2433, c_serv_hscsd_id = 2434, c_serv_vgrp_call_id = 2435,
c_serv_voice_bcst_serv_id = 2436, c_serv_mtpl_subs_pfl_id = 2437, c_serv_mtpl_band_id = 2438, c_serv_plmn_mode_id = 2439,
c_serv_vps_id = 2440, c_serv_smmo_paging_id = 2441, c_serv_smmo_email_id = 2442, c_serv_fax_id = 2443,
c_serv_data_id = 2444, c_serv_language_id = 2445, c_serv_info_numbers_id = 2446, c_no_locks_id = 2500,
c_no_files = 2501, c_cause_id = 2502, c_result_id = 2503, c_lock_type_id = 2504,
c_lock_status_id = 2505, c_lock_result_id = 2506, c_lock_dcp_sup_id = 2507, c_lock_retrial_method_id = 2508,
c_lock_retrial_count_id = 2509, c_lock_time_id = 2510, c_lock_order_id = 2511, c_unlock_startup = 2512,
c_unlock_menubased = 2513, c_unlock_keybased = 2514, c_cbmi_id = 2600, c_cbmi_range_low_id = 2700,
c_cbmi_range_high_id = 2701, c_service_available_id = 2800, c_cmi_alpha_id = 2900, c_cmi_id = 2901,
c_mdni_voicemail_id = 2910, c_mdni_fax_id = 2911, c_mdni_electronic_mail_id = 2912, c_mdni_other_id = 2913,
c_mdni_videomail_id = 2914, c_group_id = 3000, c_group_id_end = 3019, c_anr_id = 3020,
c_anr_id_end = 3039, c_aas_id = 3040, c_aas_id_end = 3059, c_add_name_id = 3060,
c_add_name_id_end = 3079, c_email_adr_id = 3080, c_email_adr_id_end = 3099, c_uid_id = 3100,
c_hidden_info_id = 3101, c_slice_id = 3102, c_total_rec_id = 3200, c_max_rec_id = 3201,
c_first_rec_id = 3202, c_last_rec_id = 3203, c_max_group_columns_id = 3205, c_gas_size_id = 3206,
c_gas_max_rec_id = 3207, c_aas_size_id = 3208, c_aas_max_rec_id = 3209, c_sync_supported_id = 3210,
c_hiddenkey_supported_id = 3211, c_max_email_adr_columns_id = 3212, c_max_add_name_columns_id = 3213, c_max_anr_columns_id = 3214,
c_is_free_ext_id = 3220, c_add_name_size_id = 3300, c_email_adr_size_id = 3320, c_is_free_anr_id = 3340,
c_is_free_add_name_id = 3360, c_is_free_email_adr_id = 3380, c_dummy = c_invalid_colid
}

Define Documentation

#define Adc_ProvIds_hpp

Typedef Documentation

typedef __Colid ProviderId

Enumeration Type Documentation

enum __Colid

Enumerator:
c_start_provider_range
c_aux_provider_id
c_adn_provider_id
c_msisdn_provider_id
c_lnd_provider_id
c_fdn_provider_id
c_prefplmn_provider_id
c_preflang_provider_id
c_status_provider_id
c_chv_provider_id
c_ecc_provider_id
c_sst_provider_id
c_simtk_mainmenu_provider_id
c_prefextlang_provider_id
c_sms_provider_id
c_sms_unread_provider_id
c_sms_sent_provider_id
c_sms_unsent_provider_id
c_sms_read_provider_id
c_sms_parameter_provider_id
c_sms_class0_provider_id
c_sms_count_provider_id
c_sms_message_provider_id
c_country_provider_id
c_plmn_provider_id
c_bdn_provider_id
c_sdn_provider_id
c_cphs_aux_provider_id
c_cphs_mbox_provider_id
c_cphs_costumer_prof_provider_id
c_cphs_infono_provider_id
c_lock_provider_id
c_cbmi_provider_id
c_cbmi_range_provider_id
c_ust_provider_id
c_est_provider_id
c_cmi_provider_id
c_sms_base_inbox_provider_id
c_sms_base_outbox_provider_id
c_sms_base_archive_provider_id
c_sms_base_statusreport_provider_id
c_sms_base_unread_provider_id
c_prefextlang2_provider_id
c_mbdn_provider_id
c_mbi_provider_id
c_usimpb_groupname_provider_id
c_usimpb_addnumberstring_provider_id
c_usimpb_property_provider_id
c_usimpb_provider_id
c_end_provider_range
c_imsi_id
c_mcc_id
c_mnc_id
c_sim_ind_id
c_icc_id
c_sim_type_id
c_sim_phase_id
c_lang_pref_id
c_fdn_state_id
c_spn_id
c_spn_display_condition_id
c_acm_id
c_acmmax_id
c_currency_code_id
c_currency_exp_id
c_currency_eppu_id
c_imei_id
c_sim_init_result_id
c_acm2_id
c_ofm_to_be_activated_id
c_network_lockstate_id
c_sp_lockstate_id
c_sim_lockstate_id
c_corporate_lockstate_id
c_sim_errorcode_id
c_loci_update_status_id
c_loci_mcc_id
c_loci_mnc_id
c_loci_lac_id
c_loci_mnc_threedigits_id
c_acm_chv_id
c_acmmax_chv_id
c_puct_chv_id
c_mnc_threedigits_id
c_simpos_id
c_phone_no_id
c_name_id
c_alphatagsize_id
c_tagsize_id
c_nextfreeposition_id
c_freeextrecords_id
c_index_level_id
c_nw_spec_id
c_premium_serv_id
c_cmi_record_id
c_cc_id
c_country_shortname_id
c_plmn_name_id
c_plmn_shortname_id
c_networktype_id
c_access_technology_id
c_act_supported_id
c_mode_id
c_state_id
c_reject_cause_id
c_signal_strength_id
c_signal_quality_id
c_battery_load_id
c_clir_mode_id
c_redialing_active_id
c_gprs_class_id
c_gprs_class_change_origin_id
c_network_name_long_id
c_network_name_short_id
c_tz_offset_id
c_tz_dst_id
c_gprs_available_id
c_gprs_attached_id
c_succ_16bit_conc_sms_ref_no
c_last_ccm_id
c_last_ccm2_id
c_lai_mcc_id
c_lai_mnc_id
c_lai_lac_id
c_rat_id
c_gsm_band_id
c_rat_change_mode_id
c_eep_calibration_status_id
c_pref_service_id
c_signal_strength_max_id
c_signal_quality_max_id
c_cellid_id
c_ext_lang_pref_id
c_sms_string_id
c_sms_phonenumber_id
c_sms_date_id
c_sms_time_id
c_sms_msg_class_id
c_sms_pdu_data_id
c_sms_status_id
c_sms_recno_id
c_sms_msg_type_id
c_sms_coding_group_id
c_sms_dcs_id
c_sms_message_status_id
c_sms_datetime_id
c_sms_conc_status_id
c_sms_refno_id
c_sms_compound_sms_id
c_sms_storage_media_id
c_sms_compound_tpdu_id
c_sms_protid_id
c_sms_sca_id
c_sms_reply_path_flag_id
c_sms_header_text_id
c_sms_conc_ref_no_id
c_sms_conc_max_no_id
c_sms_conc_seq_no_id
c_sms_pos_id
c_sms_conc_tpdu_num_id
c_sms_no_pdu_sim_id
c_sms_no_pdu_flash_id
c_sms_alpha_id
c_sms_extended_data_id
c_sms_debugstring_id
c_sms_sum_id
c_sms_free_pdu_id
c_sms_tpdu_capacity_id
c_sms_tpdu_occupied_id
c_sms_tpdu_empty_id
c_sms_unread_count_id
c_sms_read_count_id
c_sms_unsent_count_id
c_sms_sent_count_id
c_msg_ind_level_id
c_msg_count_id
c_msg_ind_setting_id
c_msg_ind_sms_type_id
c_msg_update_id
c_msg_position_id
c_no_id
c_attempts_left_id
c_unblocking_attempts_left_id
c_ecc_id
c_ecc_alpha_id
c_ecc_category_id
c_ecc_source_id
c_ecc_phonenumber_id
c_ecc_sim_network_cnt_id
c_service_allocated_id
c_service_activated_id
c_options_id
c_title_id
c_title_icon_id
c_title_icon_isselfexp_id
c_item_id
c_next_action_id
c_icon_id
c_item_string_id
c_icon_isselfexp_id
c_service_center_address_id
c_destination_address_id
c_protocol_identifier_id
c_data_coding_scheme_id
c_validity_period_id
c_sms_param_name_id
c_smsp_alpha_id_len_id
c_cphs_phase_id
c_infnrs_activated_id
c_infnrs_allocated_id
c_csp_activated_id
c_csp_allocated_id
c_sst_activated_id
c_sst_allocated_id
c_mboxnrs_activated_id
c_mboxnrs_allocated_id
c_opname_activated_id
c_opname_allocated_id
c_operator_name_id
c_operator_shortname_id
c_msg_wait_ind_line1_id
c_msg_wait_ind_line2_id
c_msg_wait_ind_fax_id
c_msg_wait_ind_data_id
c_call_fwd_line1_id
c_call_fwd_line2_id
c_call_fwd_fax_id
c_call_fwd_data_id
c_line_in_use_id
c_line_is_locked_id
c_cphs_is_present_id
c_orange_welcome_msg_id
c_serv_cfu_id
c_serv_cfb_id
c_serv_cfnry_id
c_serv_cfnrc_id
c_serv_ct_id
c_serv_boac_id
c_serv_boic_id
c_serv_boic_exhc_id
c_serv_baic_id
c_serv_bic_roam_id
c_serv_mpty_id
c_serv_cug_id
c_serv_aoc_id
c_serv_pref_cug_id
c_serv_cug_oa_id
c_serv_hold_id
c_serv_cw_id
c_serv_ccbs_id
c_serv_usr_usr_sig_id
c_serv_sm_mt_id
c_serv_sm_mo_id
c_serv_sm_cb_id
c_serv_repl_path_id
c_serv_del_conf_id
c_serv_protid_id
c_serv_val_per_id
c_serv_als_id
c_serv_clip_id
c_serv_co_lr_id
c_serv_co_lp_id
c_serv_mci_id
c_serv_cli_send_id
c_serv_cli_block_id
c_serv_gprs_id
c_serv_hscsd_id
c_serv_vgrp_call_id
c_serv_voice_bcst_serv_id
c_serv_mtpl_subs_pfl_id
c_serv_mtpl_band_id
c_serv_plmn_mode_id
c_serv_vps_id
c_serv_smmo_paging_id
c_serv_smmo_email_id
c_serv_fax_id
c_serv_data_id
c_serv_language_id
c_serv_info_numbers_id
c_no_locks_id
c_no_files
c_cause_id
c_result_id
c_lock_type_id
c_lock_status_id
c_lock_result_id
c_lock_dcp_sup_id
c_lock_retrial_method_id
c_lock_retrial_count_id
c_lock_time_id
c_lock_order_id
c_unlock_startup
c_unlock_menubased
c_unlock_keybased
c_cbmi_id
c_cbmi_range_low_id
c_cbmi_range_high_id
c_service_available_id
c_cmi_alpha_id
c_cmi_id
c_mdni_voicemail_id
c_mdni_fax_id
c_mdni_electronic_mail_id
c_mdni_other_id
c_mdni_videomail_id
c_group_id
c_group_id_end
c_anr_id
c_anr_id_end
c_aas_id
c_aas_id_end
c_add_name_id
c_add_name_id_end
c_email_adr_id
c_email_adr_id_end
c_uid_id
c_hidden_info_id
c_slice_id
c_total_rec_id
c_max_rec_id
c_first_rec_id
c_last_rec_id
c_max_group_columns_id
c_gas_size_id
c_gas_max_rec_id
c_aas_size_id
c_aas_max_rec_id
c_sync_supported_id
c_hiddenkey_supported_id
c_max_email_adr_columns_id
c_max_add_name_columns_id
c_max_anr_columns_id
c_is_free_ext_id
c_add_name_size_id
c_email_adr_size_id
c_is_free_anr_id
c_is_free_add_name_id
c_is_free_email_adr_id
c_dummy

Generated on Tue Jan 24 15:26:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/ProvIds.hpp Source File

Adc/ProvIds.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_ProvIds_hpp)
00015 #define Adc_ProvIds_hpp
00016
00017 // ////////////////////////////////////////////////////////////////////////
00018
00019 #include <Auxiliary/Provider.hpp>
00020
00021
00022
00023 enum __Colid
00024 {
00025
00026 /*------------------------------------------------------------------
00027                             Main Columns
00028  ------------------------------------------------------------------*/
00029
00030 c_start_provider_range          = 1000, // must be the base !!!
00031
00032 c_aux_provider_id               = 1000,
00033 c_adn_provider_id               = 1001,
00034 c_msisdn_provider_id            = 1002,
00035 c_lnd_provider_id               = 1003,
00036 c_fdn_provider_id               = 1004,
00037 c_prefplmn_provider_id          = 1005,
00038 c_preflang_provider_id          = 1006,
00039 c_status_provider_id            = 1007,
00040 c_chv_provider_id               = 1008,
00041 c_ecc_provider_id               = 1009,
00042
00043 c_sst_provider_id               = 1010,
00044 c_simtk_mainmenu_provider_id    = 1011,
00045 c_prefextlang_provider_id       = 1012,
00046 c_sms_provider_id               = 1013,
00047 c_sms_unread_provider_id        = 1014,
00048 c_sms_sent_provider_id          = 1015,
00049 c_sms_unsent_provider_id        = 1016,
00050 c_sms_read_provider_id          = 1017,
00051 c_sms_parameter_provider_id     = 1018,
00052 c_sms_class0_provider_id        = 1019,
00053
00054 c_sms_count_provider_id         = 1020,
00055 c_sms_message_provider_id       = 1021,
00056 c_country_provider_id           = 1022,
00057 c_plmn_provider_id              = 1023,
00058 c_bdn_provider_id               = 1024,
00059 c_sdn_provider_id               = 1025,
00060 c_cphs_aux_provider_id          = 1026,
00061 c_cphs_mbox_provider_id         = 1027,
00062 c_cphs_costumer_prof_provider_id= 1028,
00063 c_cphs_infono_provider_id       = 1029,
00064
00065 c_lock_provider_id              = 1030,
00066 c_cbmi_provider_id              = 1031,
00067 c_cbmi_range_provider_id        = 1032,
00068 c_ust_provider_id               = 1033,
00069 c_est_provider_id               = 1034,
00070 c_cmi_provider_id               = 1035,
00071 c_sms_base_inbox_provider_id    = 1036,
00072 c_sms_base_outbox_provider_id   = 1037,
00073 c_sms_base_archive_provider_id  = 1038,
00074 c_sms_base_statusreport_provider_id  = 1039,
00075
00076 c_sms_base_unread_provider_id   = 1040,
00077 c_prefextlang2_provider_id      = 1041,
00078 c_mbdn_provider_id              = 1042,
00079 c_mbi_provider_id               = 1043,
00080
00081 c_usimpb_groupname_provider_id  = 1044,
00082 c_usimpb_addnumberstring_provider_id    = 1045,
00083 c_usimpb_property_provider_id   = 1046,
00084 c_usimpb_provider_id            = 1047,
00085
00086 c_end_provider_range,               // provider ids must be start at 1000
00087
00088
00089 /*------------------------------------------------------------------
00090                             Auxilary Columns
00091  ------------------------------------------------------------------*/
00092 c_imsi_id                       = 1100,
00093 c_mcc_id                        = 1101,
00094 c_mnc_id                        = 1102,
00095 c_sim_ind_id                    = 1103,
00096 c_icc_id                        = 1104,
00097 c_sim_type_id                   = 1105,
00098 c_sim_phase_id                  = 1106,
00099 c_lang_pref_id                  = 1107,
00100 c_fdn_state_id                  = 1108,
00101 c_spn_id                        = 1109,
00102 c_spn_display_condition_id      = 1110,
00103 c_acm_id                        = 1111,
00104 c_acmmax_id                     = 1112,
00105 c_currency_code_id              = 1113,
00106 c_currency_exp_id               = 1114,
00107 c_currency_eppu_id              = 1115,
00108 c_imei_id                       = 1116,
00109 c_sim_init_result_id            = 1117,
00110 c_acm2_id                       = 1118,
00111 c_ofm_to_be_activated_id        = 1119,
00112
00113 c_network_lockstate_id          = 1125,
00114 c_sp_lockstate_id               = 1126,
00115 c_sim_lockstate_id              = 1127,
00116 c_corporate_lockstate_id        = 1128,
00117 c_sim_errorcode_id              = 1129,
00118
00119 c_loci_update_status_id         = 1130,
00120 c_loci_mcc_id                   = 1131,
00121 c_loci_mnc_id                   = 1132,
00122 c_loci_lac_id                   = 1133,
00123 c_loci_mnc_threedigits_id       = 1134,
00124
00125 c_acm_chv_id                    = 1140,
00126 c_acmmax_chv_id                 = 1141,
00127 c_puct_chv_id                   = 1142,
00128
00129 c_mnc_threedigits_id            = 1150,
00130
00131
00132 /*------------------------------------------------------------------
00133                         Adn,Msisdn,Fdn,Lnd Columns
00134  ------------------------------------------------------------------*/
00135 c_simpos_id                     = 1200,
00136 c_phone_no_id                   = 1201,
00137 c_name_id                       = 1202,
00138 c_alphatagsize_id               = 1203,
00139 c_tagsize_id                    = 1204,
00140 c_nextfreeposition_id           = 1205,
00141 c_freeextrecords_id             = 1206,
00142
00143 // only relevant for CPHS_INFNUM
00144 c_index_level_id                = 1220,
00145 c_nw_spec_id                    = 1221,
00146 c_premium_serv_id               = 1222,
00147
00148 // only relevant for BDN
00149 c_cmi_record_id                 = 1223,
00150
00151
00152 /*------------------------------------------------------------------
00153                     CountryProvider Columns
00154  ------------------------------------------------------------------*/
00155 //c_mcc_id                      = 1300,     // mobile country code // already defined
00156 c_cc_id                         = 1301,     // international country code
00157 c_country_shortname_id          = 1302,     // short name of country
00158
00159 /*------------------------------------------------------------------
00160                     PlmnProvider Columns
00161  ------------------------------------------------------------------*/
00162 //c_mcc_id                      = 1400,     // mobile country code          // already defined
00163 //c_cc_id                       = 1401,     // international country code   // already defined
00164 //c_country_shortname_id        = 1402,     // short name of country        // already defined
00165 //c_mnc_id                      = 1403,     // mobile network code          // already defined
00166 c_plmn_name_id                  = 1404,     // name of plmn
00167 c_plmn_shortname_id             = 1405,     // short name of plmn
00168 c_networktype_id                = 1406,     // type of network (GSM900, GSM1800, GSM1900, ...)
00169
00170 /*------------------------------------------------------------------
00171                             Pref Plmn Columns
00172  ------------------------------------------------------------------*/
00173 //c_mcc_id                      = 1500,     // mobile country code          // already defined
00174 //c_mnc_id                      = 1501,     // international country code   // already defined
00175 c_access_technology_id          = 1502,     // access technology identifier
00176 c_act_supported_id              = 1503,     // is access technology supported
00177
00178
00179 /*------------------------------------------------------------------
00180             StatusProvider Columns (registration, battery, nitz, ...)
00181  ------------------------------------------------------------------*/
00182 c_mode_id                       = 1600,     // registration mode (automatic vs. manual)
00183 c_state_id                      = 1601,     // registration state (normal, limited, no service)
00184 c_reject_cause_id               = 1602,     // registration reject cause (on last registration change)
00185 //c_mcc_id                      = 1603,     // mobile country code of registered plmn
00186 //c_mnc_id                      = 1604,     // international country code of registered plmn
00187 //c_mnc_threedigits_id          = 1150, // has the mnc three digits
00188 c_signal_strength_id            = 1605,     // radio signal strength level
00189 c_signal_quality_id             = 1606,     // radio signal quality level (only valid on active calls)
00190 c_battery_load_id               = 1607,     // battery load level
00191 c_clir_mode_id                  = 1608,     // clir mode
00192 c_redialing_active_id           = 1609,     // redialing active ?
00193 c_gprs_class_id                 = 1610,     // current active GPRS mobile class
00194 c_gprs_class_change_origin_id   = 1611,     // process source, which initiatiated last gprs class change
00195 c_network_name_long_id          = 1612,     // Network Identifier Name Long of NITZ Signal
00196 c_network_name_short_id         = 1613,     // Network Identifier Name Short of NITZ Signal
00197 c_tz_offset_id                  = 1614,     // time zone offset from UT (GMT) in units of 15 minutes
00198 c_tz_dst_id                     = 1615,     // daylight saving time (adjustment can be +1h of +2h)
00199 c_gprs_available_id             = 1616,     // indicates if gprs is available
00200 c_gprs_attached_id              = 1617,     // indicates the gprs attach-status
00201 c_succ_16bit_conc_sms_ref_no    = 1620,     // successive 16-bit reference counter for concatenated sms (should be stored permanent)
00202 c_last_ccm_id                   = 1621,     // last current call meter of AOC
00203 c_last_ccm2_id                  = 1622,     // last current call meter of AOC for Line2 ALS
00204 c_lai_mcc_id                    = 1623,     // mobile country code of lai plmn
00205 c_lai_mnc_id                    = 1624,     // international country code of lai plmn
00206 c_lai_lac_id                    = 1625,     // lac of lai
00207 c_rat_id                        = 1626,     // Radio Access Technology
00208 c_gsm_band_id                   = 1627,     // GSM-Band (900, 900P, 900E, 1800, ....)
00209 c_rat_change_mode_id            = 1628,     // RAT Change Mode
00210 c_eep_calibration_status_id     = 1629,     // calibration status of the eeprom
00211 c_pref_service_id               = 1630,     // pref GsmService CS or PS, CS Paging active = CS, CS Paging deactive = PS
00212 c_signal_strength_max_id        = 1631,     // radio signal strength level
00213 c_signal_quality_max_id         = 1632,     // radio signal quality level (only valid on active calls)
00214 c_cellid_id                     = 1633,     // cell id
00215
00216 /*------------------------------------------------------------------
00217                             Pref Lang Columns
00218  ------------------------------------------------------------------*/
00219 //c_lang_pref_id                = 1700,
00220
00221 /*------------------------------------------------------------------
00222                             Pref Ext Lang Columns
00223  ------------------------------------------------------------------*/
00224 c_ext_lang_pref_id              = 1701,
00225
00226 /*------------------------------------------------------------------
00227                             Sms Columns
00228  ------------------------------------------------------------------*/
00229 c_sms_string_id                 = 1800,
00230 c_sms_phonenumber_id            = 1801,
00231 c_sms_date_id                   = 1802,
00232 c_sms_time_id                   = 1803,
00233 c_sms_msg_class_id              = 1804,
00234 c_sms_pdu_data_id               = 1805,
00235 c_sms_status_id                 = 1807,
00236 c_sms_recno_id                  = 1808,
00237 c_sms_msg_type_id               = 1809,
00238 c_sms_coding_group_id           = 1810,
00239 c_sms_dcs_id                    = 1811,
00240 c_sms_message_status_id         = 1812,
00241 c_sms_datetime_id               = 1813,
00242 c_sms_conc_status_id            = 1814,
00243 c_sms_refno_id                  = 1815,
00244 c_sms_compound_sms_id           = 1816,
00245 c_sms_storage_media_id          = 1817,
00246 c_sms_compound_tpdu_id          = 1818,
00247 c_sms_protid_id                 = 1819,
00248 c_sms_sca_id                    = 1820,
00249 c_sms_reply_path_flag_id        = 1821,
00250 c_sms_header_text_id            = 1822,
00251
00252 c_sms_conc_ref_no_id            = 1830,
00253 c_sms_conc_max_no_id            = 1831,
00254 c_sms_conc_seq_no_id            = 1832,
00255
00256 c_sms_pos_id                    = 1833,
00257 c_sms_conc_tpdu_num_id          = 1834,
00258 c_sms_no_pdu_sim_id             = 1835,
00259 c_sms_no_pdu_flash_id           = 1836,
00260 c_sms_alpha_id                  = 1837,
00261 c_sms_extended_data_id          = 1838,
00262
00263 c_sms_debugstring_id            = 1840,
00264
00265 /*------------------------------------------------------------------
00266                         Sms Count Columns
00267  ------------------------------------------------------------------*/
00268 c_sms_sum_id                    = 1850,
00269 c_sms_free_pdu_id               = 1851,
00270 c_sms_tpdu_capacity_id          = 1852,
00271 c_sms_tpdu_occupied_id          = 1853,
00272 c_sms_tpdu_empty_id             = 1854,
00273 c_sms_unread_count_id           = 1855,
00274 c_sms_read_count_id             = 1856,
00275 c_sms_unsent_count_id           = 1857,
00276 c_sms_sent_count_id             = 1858,
00277
00278 /*------------------------------------------------------------------
00279                         Sms Message Columns
00280  ------------------------------------------------------------------*/
00281 c_msg_ind_level_id              = 1880,
00282 c_msg_count_id                  = 1881,
00283 c_msg_ind_setting_id            = 1882,
00284 c_msg_ind_sms_type_id           = 1883,
00285 c_msg_update_id                 = 1884,
00286 c_msg_position_id               = 1885,
00287
00288 /*------------------------------------------------------------------
00289                         ChvProvider Columns
00290  ------------------------------------------------------------------*/
00291 c_no_id                         = 1900,     // cardholder verification (chv) number (type AdcChvNo)
00292 //c_state_id                    = 1901,     // state of chv (type AdcChvStatus)
00293 c_attempts_left_id              = 1902,     // attemts left to verify chv
00294 c_unblocking_attempts_left_id   = 1903,     // attemts left to verify unblocking code of chv
00295
00296 /*------------------------------------------------------------------
00297                         EccProvider Columns
00298  ------------------------------------------------------------------*/
00299 c_ecc_id                        = 2000,     // ecc number as wstring
00300 c_ecc_alpha_id                  = 2001,     // alpha id (USIM)
00301 c_ecc_category_id               = 2002,     // category byte
00302 c_ecc_source_id                 = 2003,     // the source of the ECC
00303 c_ecc_phonenumber_id            = 2004,     // ECC as a phonenumber
00304 c_ecc_sim_network_cnt_id        = 2005,     // summary of sim and network ECCs
00305
00306 /*------------------------------------------------------------------
00307                         SstProvider Columns
00308  ------------------------------------------------------------------*/
00309 c_service_allocated_id          = 2100,
00310 c_service_activated_id          = 2101,
00311
00312 /*------------------------------------------------------------------
00313                         SimTkMainMenuProvider Columns
00314  ------------------------------------------------------------------*/
00315
00316 c_options_id                    = 2200,
00317 c_title_id                      = 2201,
00318 c_title_icon_id                 = 2202,
00319 c_title_icon_isselfexp_id       = 2203,
00320 c_item_id                       = 2204,
00321 c_next_action_id                = 2205,
00322 c_icon_id                       = 2206,
00323 c_item_string_id                = 2207,
00324 c_icon_isselfexp_id             = 2208,
00325
00326 /*------------------------------------------------------------------
00327                         Sms Parameter Provider
00328  ------------------------------------------------------------------*/
00329
00330 c_service_center_address_id     = 2220,
00331 c_destination_address_id        = 2221,
00332 c_protocol_identifier_id        = 2222,
00333 c_data_coding_scheme_id         = 2223,
00334 c_validity_period_id            = 2224,
00335 c_sms_param_name_id             = 2225,
00336 c_smsp_alpha_id_len_id          = 2226,
00337
00338 /*------------------------------------------------------------------
00339                         Cphs Auxiliary provider
00340  ------------------------------------------------------------------*/
00341
00342 c_cphs_phase_id                 = 2300,
00343 c_infnrs_activated_id           = 2301,
00344 c_infnrs_allocated_id           = 2302,
00345 c_csp_activated_id              = 2303,
00346 c_csp_allocated_id              = 2304,
00347 c_sst_activated_id              = 2305,
00348 c_sst_allocated_id              = 2306,
00349 c_mboxnrs_activated_id          = 2307,
00350 c_mboxnrs_allocated_id          = 2308,
00351 c_opname_activated_id           = 2309,
00352 c_opname_allocated_id           = 2310,
00353
00354 c_operator_name_id              = 2315,
00355 c_operator_shortname_id         = 2316,
00356 c_msg_wait_ind_line1_id         = 2317,
00357 c_msg_wait_ind_line2_id         = 2318,
00358 c_msg_wait_ind_fax_id           = 2319,
00359 c_msg_wait_ind_data_id          = 2320,
00360 c_call_fwd_line1_id             = 2321,
00361 c_call_fwd_line2_id             = 2322,
00362 c_call_fwd_fax_id               = 2323,
00363 c_call_fwd_data_id              = 2324,
00364
00365 c_line_in_use_id                = 2330,
00366 c_line_is_locked_id             = 2331,
00367 c_cphs_is_present_id            = 2332,
00368 c_orange_welcome_msg_id         = 2333,
00369
00370
00371 /*------------------------------------------------------------------
00372                         Cphs Customer Service Profile provider
00373  ------------------------------------------------------------------*/
00374
00375 c_serv_cfu_id                   = 2400,
00376 c_serv_cfb_id                   = 2401,
00377 c_serv_cfnry_id                 = 2402,
00378 c_serv_cfnrc_id                 = 2403,
00379 c_serv_ct_id                    = 2404,
00380 c_serv_boac_id                  = 2405,
00381 c_serv_boic_id                  = 2406,
00382 c_serv_boic_exhc_id             = 2407,
00383 c_serv_baic_id                  = 2408,
00384 c_serv_bic_roam_id              = 2409,
00385 c_serv_mpty_id                  = 2410,
00386 c_serv_cug_id                   = 2411,
00387 c_serv_aoc_id                   = 2412,
00388 c_serv_pref_cug_id              = 2413,
00389 c_serv_cug_oa_id                = 2414,
00390 c_serv_hold_id                  = 2415,
00391 c_serv_cw_id                    = 2416,
00392 c_serv_ccbs_id                  = 2417,
00393 c_serv_usr_usr_sig_id           = 2418,
00394 c_serv_sm_mt_id                 = 2419,
00395 c_serv_sm_mo_id                 = 2420,
00396 c_serv_sm_cb_id                 = 2421,
00397 c_serv_repl_path_id             = 2422,
00398 c_serv_del_conf_id              = 2423,
00399 c_serv_protid_id                = 2424,
00400 c_serv_val_per_id               = 2425,
00401 c_serv_als_id                   = 2426,
00402 c_serv_clip_id                  = 2427,
00403 c_serv_co_lr_id                 = 2428,
00404 c_serv_co_lp_id                 = 2429,
00405 c_serv_mci_id                   = 2430,
00406 c_serv_cli_send_id              = 2431,
00407 c_serv_cli_block_id             = 2432,
00408 c_serv_gprs_id                  = 2433,
00409 c_serv_hscsd_id                 = 2434,
00410 c_serv_vgrp_call_id             = 2435,
00411 c_serv_voice_bcst_serv_id       = 2436,
00412 c_serv_mtpl_subs_pfl_id         = 2437,
00413 c_serv_mtpl_band_id             = 2438,
00414 c_serv_plmn_mode_id             = 2439,
00415 c_serv_vps_id                   = 2440,
00416 c_serv_smmo_paging_id           = 2441,
00417 c_serv_smmo_email_id            = 2442,
00418 c_serv_fax_id                   = 2443,
00419 c_serv_data_id                  = 2444,
00420 c_serv_language_id              = 2445,
00421 c_serv_info_numbers_id          = 2446,
00422
00423 /*------------------------------------------------------------------
00424                         Lock provider
00425  ------------------------------------------------------------------*/
00426
00427 c_no_locks_id                   = 2500,
00428 c_no_files                      = 2501,
00429 c_cause_id                      = 2502,
00430 c_result_id                     = 2503,
00431 c_lock_type_id                  = 2504,
00432 c_lock_status_id                = 2505,
00433 c_lock_result_id                = 2506,
00434 c_lock_dcp_sup_id               = 2507,
00435 c_lock_retrial_method_id        = 2508,
00436 c_lock_retrial_count_id         = 2509,
00437 c_lock_time_id                  = 2510,
00438 c_lock_order_id                 = 2511,
00439 c_unlock_startup                = 2512,
00440 c_unlock_menubased              = 2513,
00441 c_unlock_keybased               = 2514,
00442
00443 /*------------------------------------------------------------------
00444                         Cbmi provider
00445  ------------------------------------------------------------------*/
00446
00447 c_cbmi_id                       = 2600,
00448
00449 /*------------------------------------------------------------------
00450                         Cbmi range provider
00451  ------------------------------------------------------------------*/
00452
00453 c_cbmi_range_low_id             = 2700,
00454 c_cbmi_range_high_id            = 2701,
00455
00456
00457 /*------------------------------------------------------------------
00458                         UstProvider Columns
00459  ------------------------------------------------------------------*/
00460 c_service_available_id          = 2800,     // (USIM)
00461
00462 /*------------------------------------------------------------------
00463                         EstProvider Columns
00464  ------------------------------------------------------------------*/
00465 //c_service_activated_id        = 2801,     // (USIM)   // already defined
00466
00467 /*------------------------------------------------------------------
00468                         CmiProvider Columns
00469  ------------------------------------------------------------------*/
00470 c_cmi_alpha_id                  = 2900,
00471 c_cmi_id                        = 2901,
00472
00473 /*------------------------------------------------------------------
00474                         MbiProvider Columns
00475  ------------------------------------------------------------------*/
00476 c_mdni_voicemail_id             = 2910,
00477 c_mdni_fax_id                   = 2911,
00478 c_mdni_electronic_mail_id       = 2912,
00479 c_mdni_other_id                 = 2913,
00480 c_mdni_videomail_id             = 2914,
00481
00482 /*------------------------------------------------------------------
00483                     UsimPbXasProvider Columns
00484     used with c_usimpb_groupname_provider_id
00485     used with c_usimpb_addnumberstring_provider_id
00486  ------------------------------------------------------------------*/
00487 //c_name_id                     = 1202,
00488
00489
00490 /*------------------------------------------------------------------
00491                     UsimPbProvider Columns
00492  ------------------------------------------------------------------*/
00493
00494 //c_simpos_id                   = 1200,
00495 //c_phone_no_id                 = 1201,
00496 //c_name_id                     = 1202,
00497 //c_alphatagsize_id             = 1203,
00498 //c_tagsize_id                  = 1204,
00499 //c_nextfreeposition_id         = 1205,
00500 c_group_id                      = 3000, // used range 3000..3019
00501 c_group_id_end                  = 3019,
00502 c_anr_id                        = 3020, // used range 3020..3039
00503 c_anr_id_end                    = 3039,
00504 c_aas_id                        = 3040, // used range 3040..3059
00505 c_aas_id_end                    = 3059,
00506 c_add_name_id                   = 3060, // used range 3060..3079
00507 c_add_name_id_end               = 3079,
00508 c_email_adr_id                  = 3080, // used range 3080..3099
00509 c_email_adr_id_end              = 3099, // used range 3080..3099
00510 c_uid_id                        = 3100,
00511 c_hidden_info_id                = 3101,
00512 c_slice_id                      = 3102,
00513
00514
00515 /*------------------------------------------------------------------
00516                     UsimPbPropertyProvider Columns
00517  ------------------------------------------------------------------*/
00518
00519 c_total_rec_id                  = 3200,
00520 c_max_rec_id                    = 3201,
00521 c_first_rec_id                  = 3202,
00522 c_last_rec_id                   = 3203,
00523 //c_alphatagsize_id             = 3204,
00524 c_max_group_columns_id          = 3205,
00525 c_gas_size_id                   = 3206,
00526 c_gas_max_rec_id                = 3207,
00527 c_aas_size_id                   = 3208,
00528 c_aas_max_rec_id                = 3209,
00529 c_sync_supported_id             = 3210,
00530 c_hiddenkey_supported_id        = 3211,
00531 c_max_email_adr_columns_id      = 3212,
00532 c_max_add_name_columns_id       = 3213,
00533 c_max_anr_columns_id            = 3214,
00534 c_is_free_ext_id                = 3220,
00535 c_add_name_size_id              = 3300, // used range 3300..3319
00536 c_email_adr_size_id             = 3320, // used range 3020..3039
00537 c_is_free_anr_id                = 3340, // used range 3040..3059
00538 c_is_free_add_name_id           = 3360, // used range 3060..3079
00539 c_is_free_email_adr_id          = 3380, // used range 3080..3099
00540
00541
00542 /*------------------------------------------------------------------
00543                         end of enumvalues
00544  ------------------------------------------------------------------*/
00545
00546
00547 c_dummy                         = c_invalid_colid
00548
00549 };
00550
00551
00552 typedef __Colid ProviderId;
00553
00554
00555 #endif
00556
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RfsMsgTypes.hpp File Reference

Adc/RfsMsgTypes.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 15:26:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RfsMsgTypes.hpp Source File

Adc/RfsMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/RfsMsgTypes.hpp. Please use " \
00010     "Afs/Rfs/RfsMsgTypes.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/RfsMsgTypes.hpp>
00014 #else
00015     #error Adc/RfsMsgTypes.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RootDirectoryIteratorImp.hpp File Reference

Adc/RootDirectoryIteratorImp.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 15:26:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RootDirectoryIteratorImp.hpp Source File

Adc/RootDirectoryIteratorImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/RootDirectoryIteratorImp.hpp. Please use " \
00010     "AddOns/AfsRfs/RootDirectoryIteratorImp.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <AddOns/AfsRfs/RootDirectoryIteratorImp.hpp>
00014 #else
00015     #error Adc/RootDirectoryIteratorImp.hpp was moved to AddOns/AfsRfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RootFileImp.hpp File Reference

Adc/RootFileImp.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 15:26:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RootFileImp.hpp Source File

Adc/RootFileImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/RootFileImp.hpp. Please use " \
00010     "AddOns/AfsRfs/RootFileImp.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <AddOns/AfsRfs/RootFileImp.hpp>
00014 #else
00015     #error Adc/RootFileImp.hpp was moved to AddOns/AfsRfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RootFileSystem.hpp File Reference

Adc/RootFileSystem.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:26:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RootFileSystem.hpp Source File

Adc/RootFileSystem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/RootFileSystem.hpp. Please use " \
00010     "Afs/Rfs/RootFileSystem.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/RootFileSystem.hpp>
00014 #else
00015     #error Adc/RootFileSystem.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RootStorageDeviceImp.hpp File Reference

Adc/RootStorageDeviceImp.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 15:26:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/RootStorageDeviceImp.hpp Source File

Adc/RootStorageDeviceImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/RootStorageDeviceImp.hpp. Please use " \
00010     "AddOns/AfsRfs/RootStorageDeviceImp.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <AddOns/AfsRfs/RootStorageDeviceImp.hpp>
00014 #else
00015     #error Adc/RootStorageDeviceImp.hpp was moved to AddOns/AfsRfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimAccessor.cpp File Reference

Adc/SimAccessor.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SimAccessor.hpp"
#include "DataHandler.hpp"
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/System.hpp>
#include <Apc/PhoneBookStackMsgArgs.hpp>
#include <Apc/MiscStackMsgArgs.hpp>
#include <Apc/ChvStackMsgArgs.hpp>
#include <Apc/PowerStackMsgArgs.hpp>
#include <Apc/SmsStackMsgArgs.hpp>
#include <Apc/ImageStackMsgArgs.hpp>

Include dependency graph for SimAccessor.cpp:

Functions

SimUpdateStatus GetGenericStatus (UINT16 status)

Function Documentation

SimUpdateStatus GetGenericStatus ( UINT16 status )

Generated on Tue Jan 24 15:26:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimAccessor.hpp File Reference

Adc/SimAccessor.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/UserDispatcher.hpp>
#include <Kernel/MessageReferrer.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Apc/SimMiscTypes.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Apc/ImageData.hpp>
#include <Apc/Sms.hpp>
#include <Apc/StackMsgArgument.hpp>
#include <Apc/SimLockTypes.hpp>
#include <Apc/LockTypes.hpp>
#include <Apc/Message.hpp>

Include dependency graph for SimAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimAccessor
struct | SimAccessor::SimAccessorStruct
class | SimUserDispatcher

Defines

#define | Adc_SimAccessor_hpp

Enumerations

enum | DataAvailability { DataAccessible, DataNotPresent, DataAccessUndefined }

Variables

const INT | c_acm_rec_size = 3
const INT | c_ccp_rec_size = 14
const SimFileId | c_df_cingular_id = 0x7f66
const SimFileId | c_df_graphics_id = 0x5F50
const SimFileId | c_df_gsm_id = 0x7F20
const SimFileId | c_df_mexe_id = 0x5F3C
const SimFileId | c_df_mf_id = 0x3F00
const SimFileId | c_df_orange_id = 0x7f40
const SimFileId | c_df_telecom_id = 0x7F10
const INT | c_ecc_rec_size = 3
const SimFileId | c_ef_acm_id = 0x6F39
const SimFileId | c_ef_acmmax_id = 0x6F37
const SimFileId | c_ef_ad_id = 0x6FAD
const SimFileId | c_ef_adn_id = 0x6F3A
const SimFileId | c_ef_arpk_id = 0x4F42
const SimFileId | c_ef_bdn_id = 0x6F4D
const SimFileId | c_ef_call_fwrd_id = 0x6F13
const SimFileId | c_ef_cbmi_id = 0x6F45
const SimFileId | c_ef_cbmid_id = 0x6F48
const SimFileId | c_ef_cbmir_id = 0x6F50
const SimFileId | c_ef_ccp_id = 0x6F3D
const SimFileId | c_ef_cfis_id = 0x6FCB
const SimFileId | c_ef_cmi_id = 0x6F58
const SimFileId | c_ef_cphs_info_no_id = 0x6F19
const SimFileId | c_ef_cphsinfo_id = 0x6F16
const SimFileId | c_ef_cust_serv_id = 0x6F15
const SimFileId | c_ef_dynamic2_id = 0x6f92
const SimFileId | c_ef_dynamic_id = 0x6f9F
const SimFileId | c_ef_ecc_id = 0x6FB7
const SimFileId | c_ef_elp_id = 0x2F05
const SimFileId | c_ef_emlpp_id = 0x6FB5
const SimFileId | c_ef_ext1_id = 0x6F4A
const SimFileId | c_ef_ext2_id = 0x6F4B
const SimFileId | c_ef_ext3_id = 0x6F4C
const SimFileId | c_ef_ext4_id = 0x6F4E
const SimFileId | c_ef_ext6_id = 0x6FC8
const SimFileId | c_ef_ext7_id = 0x6FCC
const SimFileId | c_ef_fdn_id = 0x6F3B
const SimFileId | c_ef_img_id = 0x4F20
const SimFileId | c_ef_imsi_id = 0x6F07
const SimFileId | c_ef_lnd_id = 0x6F44
const SimFileId | c_ef_loci_id = 0x6F7E
const SimFileId | c_ef_lp_id = 0x6F05
const SimFileId | c_ef_mbdn_id = 0x6FC7
const SimFileId | c_ef_mbi_id = 0x6Fc9
const SimFileId | c_ef_mbox_no_id = 0x6F17
const SimFileId | c_ef_mexest_id = 0x4F40
const SimFileId | c_ef_msisdn_id = 0x6F40
const SimFileId | c_ef_opl_id = 0x6FC6
const SimFileId | c_ef_opn_str_srt_id = 0x6F18
const SimFileId | c_ef_opname_str_id = 0x6F14
const SimFileId | c_ef_orpk_id = 0x4F41
const SimFileId | c_ef_param_id = 0x6f9B
const SimFileId | c_ef_plmnsel_id = 0x6F30
const SimFileId | c_ef_plmnselwact_id = 0x6F60
const SimFileId | c_ef_pnn_id = 0x6FC5
const SimFileId | c_ef_puct_id = 0x6F41
const SimFileId | c_ef_sdn_id = 0x6F49
const SimFileId | c_ef_sms_id = 0x6F3C
const SimFileId | c_ef_smsp_id = 0x6F42
const SimFileId | c_ef_smsr_id = 0x6F47
const SimFileId | c_ef_smss_id = 0x6F43
const SimFileId | c_ef_spdi_id = 0x6FCD
const SimFileId | c_ef_spn_id = 0x6F46
const SimFileId | c_ef_sst_id = 0x6F38
const SimFileId | c_ef_tprpk_id = 0x4F43
const SimFileId | c_ef_tst_id = 0x6FD2
const SimFileId | c_ef_vbs_id = 0x6FB3
const SimFileId | c_ef_vbss_id = 0x6FB4
const SimFileId | c_ef_vgcs_id = 0x6FB1
const SimFileId | c_ef_vgcss_id = 0x6FB2
const SimFileId | c_ef_vmsg_wtng_id = 0x6F11
const INT | c_maxpending_messages = 8
const INT | c_plmn_rec_size = 3
const INT | c_puct_rec_size = 5
const INT | c_timeout_seconds = 30
const INT | c_tst_file_size = 8

Define Documentation

#define Adc_SimAccessor_hpp

Generated on Tue Jan 24 15:26:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimAccessor.hpp Source File

Adc/SimAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Adc_SimAccessor_hpp)
00009 #define Adc_SimAccessor_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/Application.hpp>
00015 #include <Kernel/UserDispatcher.hpp>
00016 #include <Kernel/MessageReferrer.hpp>
00017 #include <Kernel/Os/Mutex.hpp>
00018
00019 #include <Apc/SimMiscTypes.hpp>
00020 #include <Apc/NetworkTypes.hpp>
00021 #include <Apc/ImageData.hpp>
00022 #include <Apc/Sms.hpp>
00023 #include <Apc/StackMsgArgument.hpp>
00024 #include <Apc/SimLockTypes.hpp>
00025 #include <Apc/LockTypes.hpp>
00026 #include <Apc/Message.hpp>
00027
00028 /*  ========================================================================
00029     DataAvailability
00030     ======================================================================== */
00031
00036 enum DataAvailability {
00038     DataAccessible,
00040     DataNotPresent,
00042     DataAccessUndefined
00043 };
00044
00045
00046 class DataHandler;
00047
00048 // ///////////////////////////////////////////////////////
00049
00050 const INT c_maxpending_messages     = 8;
00051 const INT c_timeout_seconds         = 30;
00052
00053 // Record sizes //////////////////////////////////////////
00054
00055 const INT c_plmn_rec_size           = 3;
00056 const INT c_acm_rec_size            = 3;
00057 const INT c_puct_rec_size           = 5;
00058 const INT c_ecc_rec_size            = 3;
00059 const INT c_ccp_rec_size            = 14;
00060 const INT c_tst_file_size           = 8;
00061
00062 // Sim File Ids //////////////////////////////////////////
00063
00064 // Dedicated File Ids
00065 const SimFileId c_df_mf_id          = 0x3F00;
00066 const SimFileId c_df_gsm_id         = 0x7F20;
00067 const SimFileId c_df_telecom_id     = 0x7F10;
00068 const SimFileId c_df_graphics_id    = 0x5F50;
00069 const SimFileId c_df_mexe_id        = 0x5F3C;
00070 const SimFileId c_df_orange_id      = 0x7f40;
00071 const SimFileId c_df_cingular_id    = 0x7f66;
00072
00073 // Common Elementary File Ids
00074 const SimFileId c_ef_elp_id         = 0x2F05;
00075 const SimFileId c_ef_acm_id         = 0x6F39;
00076 const SimFileId c_ef_acmmax_id      = 0x6F37;
00077 const SimFileId c_ef_vgcs_id        = 0x6FB1;
00078 const SimFileId c_ef_vgcss_id       = 0x6FB2;
00079 const SimFileId c_ef_vbs_id         = 0x6FB3;
00080 const SimFileId c_ef_vbss_id        = 0x6FB4;
00081 const SimFileId c_ef_ecc_id         = 0x6FB7;
00082 const SimFileId c_ef_sst_id         = 0x6F38;
00083 const SimFileId c_ef_plmnsel_id     = 0x6F30;
00084 const SimFileId c_ef_plmnselwact_id = 0x6F60;
00085 const SimFileId c_ef_puct_id        = 0x6F41;
00086 const SimFileId c_ef_smsp_id        = 0x6F42;
00087 const SimFileId c_ef_smss_id        = 0x6F43;
00088 const SimFileId c_ef_smsr_id        = 0x6F47;
00089 const SimFileId c_ef_lp_id          = 0x6F05;
00090 const SimFileId c_ef_imsi_id        = 0x6F07;
00091 const SimFileId c_ef_spn_id         = 0x6F46;
00092 const SimFileId c_ef_cbmi_id        = 0x6F45;
00093 const SimFileId c_ef_cbmid_id       = 0x6F48;
00094 const SimFileId c_ef_cbmir_id       = 0x6F50;
00095 const SimFileId c_ef_ccp_id         = 0x6F3D;
00096 const SimFileId c_ef_img_id         = 0x4F20;
00097 const SimFileId c_ef_adn_id         = 0x6F3A;
00098 const SimFileId c_ef_fdn_id         = 0x6F3B;
00099 const SimFileId c_ef_sms_id         = 0x6F3C;
00100 const SimFileId c_ef_msisdn_id      = 0x6F40;
00101 const SimFileId c_ef_lnd_id         = 0x6F44;
00102 const SimFileId c_ef_sdn_id         = 0x6F49;
00103 const SimFileId c_ef_bdn_id         = 0x6F4D;
00104 const SimFileId c_ef_ad_id          = 0x6FAD;
00105 const SimFileId c_ef_loci_id        = 0x6F7E;
00106 const SimFileId c_ef_emlpp_id       = 0x6FB5;
00107 const SimFileId c_ef_spdi_id        = 0x6FCD;
00108 const SimFileId c_ef_cmi_id         = 0x6F58;
00109 const SimFileId c_ef_mbdn_id        = 0x6FC7;
00110 const SimFileId c_ef_cfis_id        = 0x6FCB;
00111 const SimFileId c_ef_mbi_id         = 0x6Fc9;
00112
00113 const SimFileId c_ef_ext1_id        = 0x6F4A;
00114 const SimFileId c_ef_ext2_id        = 0x6F4B;
00115 const SimFileId c_ef_ext3_id        = 0x6F4C;
00116 const SimFileId c_ef_ext4_id        = 0x6F4E;
00117 const SimFileId c_ef_ext6_id        = 0x6FC8;
00118 const SimFileId c_ef_ext7_id        = 0x6FCC;
00119
00120 // Cphs Elementary File Ids
00121 const SimFileId c_ef_vmsg_wtng_id   = 0x6F11;
00122 const SimFileId c_ef_call_fwrd_id   = 0x6F13;
00123 const SimFileId c_ef_opname_str_id  = 0x6F14;
00124 const SimFileId c_ef_cust_serv_id   = 0x6F15;
00125 const SimFileId c_ef_cphsinfo_id    = 0x6F16;
00126 const SimFileId c_ef_mbox_no_id     = 0x6F17;
00127 const SimFileId c_ef_opn_str_srt_id = 0x6F18;
00128 const SimFileId c_ef_cphs_info_no_id= 0x6F19;
00129
00130 // Cingular Elementary File Ids
00131 const SimFileId c_ef_tst_id         = 0x6FD2;
00132
00133 // Orange File Ids
00134 const SimFileId c_ef_dynamic_id     = 0x6f9F;
00135 const SimFileId c_ef_dynamic2_id    = 0x6f92;
00136 const SimFileId c_ef_param_id       = 0x6f9B;
00137
00138 // EONS
00139 const SimFileId c_ef_opl_id         = 0x6FC6;
00140 const SimFileId c_ef_pnn_id         = 0x6FC5;
00141
00142 // Mexe
00143 const SimFileId c_ef_mexest_id      = 0x4F40;
00144 const SimFileId c_ef_orpk_id        = 0x4F41;
00145 const SimFileId c_ef_arpk_id        = 0x4F42;
00146 const SimFileId c_ef_tprpk_id       = 0x4F43;
00147
00148 // SimAccessor ///////////////////////////////////////////
00149
00150 class SimAccessor {
00151     public:
00152         friend class SimUserDispatcher;
00153         friend class MessageReceivedCondition;
00154         friend class MessageSendableCondition;
00155         friend class MessageStartCondition;
00156         friend class MessageQueueEmptyCondition;
00157
00158         friend class UsimPlmnListDispatcher;
00159         friend class UsimSmsParamDispatcher;
00160
00161 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00162         friend class UsimPbAccessor;
00163 #endif
00164
00165         SimAccessor();
00166         virtual ~SimAccessor();
00167
00168         void Init();
00169         void Cleanup() const;
00170         void Reset();
00171
00172         BOOLEAN GetFdnState() const { return m_fdn_state; }
00173         void SetFdnState(BOOLEAN state) { m_fdn_state = state; }
00174
00175         BOOLEAN GetBdnState() const { return m_bdn_state; }
00176         void SetBdnState(BOOLEAN state) { m_bdn_state = state; }
00177
00178         BOOLEAN IsAdnReadWritableIfFdnActive() const { return m_adn_rw_state; }
00179         void SetAdnReadWritableState(BOOLEAN state) { m_adn_rw_state = state; }
00180
00181         BOOLEAN IsBdnReadWritableIfBdnNotActive() const { return m_bdn_rw_state; }
00182         void SetBdnReadWritableState(BOOLEAN state) { m_bdn_rw_state = state; }
00183
00184         void SetSimInfo(const SimInfo & siminfo);
00185         void SetSimIndicator(const SimIndicator indicator);
00186         SimIndicator GetSimIndicator();
00187         const SimChangedState & GetSimChangedState() const { return m_sim_info.changed_state; }
00188
00189         BOOLEAN GetSimInfo(SimInfo & siminfo);
00190
00191         static BOOLEAN IsSimAccessAllowed();
00192         static BOOLEAN IsSimPresent();
00193         static BOOLEAN IsUsimInserted();
00194
00195         void CancelAllRequests();
00196
00197 // Fileinfo
00198         UINT GetFileLength(SimFileId fileid);
00199         SimUpdateStatus GetFileInfo(SimFileId fileid, UINT & filesize, UINT & recordlength, ChvNo & chvno);
00200         DataAvailability GetDataAvailability(SimFileId fileid);
00201
00202 // ModifyLock
00203         BOOLEAN ModifyLock(const SecLockCommand & command, SecLockStates & lockstates);
00204
00205 // Imei
00206         BOOLEAN         GetImei(Imei & imei);
00207 // Loci
00208         BOOLEAN         GetLociData(LociData & locidata);
00209 // Pref Languages
00210         SimUpdateStatus GetPrefLanguageArray(INT startpos, LanguageArray & langarray);
00211         SimUpdateStatus UpdatePrefLanguageArray(INT startpos, const LanguageArray & langarray);
00212         UINT GetPrefLanguageFileLength() { return GetFileLength(c_ef_lp_id); }
00213 // Pref Ext Languages
00214         SimUpdateStatus GetPrefExtLanguageArray(INT startpos, ExtLanguageArray & langarray);
00215         SimUpdateStatus UpdatePrefExtLanguageArray(INT startpos, const ExtLanguageArray & langarray);
00216         UINT GetPrefExtLanguageFileLength() { return GetFileLength(c_ef_elp_id); }
00217
00218 // Phonebook
00219         BOOLEAN         GetPhoneBookInfo(PhoneBookInfo & info);
00220         SimUpdateStatus GetPhoneBookEntry(INT recno, PhoneBookType phonebooktype,
00221                                           INT & textlength, INT & datalength, UINT8 * data);
00222         SimUpdateStatus UpdatePhoneBookEntry(INT recno, PhoneBookType phonebooktype,
00223                                              INT datalength, const UINT8 * data);
00224         SimUpdateStatus GetPhoneBookCountInfo(PhoneBookCntType phonebooktype,
00225                                               INT & records, INT & usedrecords);
00226
00227         SimUpdateStatus ActivateFdn();
00228         SimUpdateStatus DeactivateFdn();
00229
00230         BOOLEAN IsFdnActivated() const { return m_fdn_state; }
00231         BOOLEAN IsBdnActivated() const { return m_bdn_state; }
00232
00233         SimUpdateStatus ActivateBdn();
00234         SimUpdateStatus DeactivateBdn();
00235
00236 // Prefered Plmns
00237         SimUpdateStatus GetPlmnList(UINT8 * plmnlist, INT length);
00238         SimUpdateStatus UpdatePlmnList(INT start, const UINT8 * plmnlist, INT length);
00239         UINT GetPrefPlmnFileLength() { return GetFileLength(c_ef_plmnsel_id); }
00240
00241 // Prefered Plmns with ACT
00242         SimUpdateStatus GetPlmnwActList(UsimPlmn * plmnlist, INT count);
00243         SimUpdateStatus UpdatePlmnwActList(INT start, const UsimPlmn * plmnlist, INT length);
00244         UINT GetPlmnwActFileLength();
00245
00246 // Acm
00247         SimUpdateStatus GetAcm(INT recno, Acm & data, AcmSelector selector);
00248         SimUpdateStatus UpdateAcm(INT recno, const Acm & data, AcmSelector selector);
00249
00250 // Acm Max
00251         SimUpdateStatus GetMaxAcm(Acm & data);
00252         SimUpdateStatus UpdateMaxAcm(const Acm & data);
00253 // Puct
00254         SimUpdateStatus GetPuct(Puct & puct);
00255         SimUpdateStatus UpdatePuct(const Puct & puct);
00256
00257 // Sst
00258         SimUpdateStatus GetServiceTable(SimServiceTable & sst);
00259 // Spn & Spdi
00260         SimUpdateStatus GetSpn(ServiceProviderStruct & spn);
00261         SimUpdateStatus GetSpdiInfo(INT & length);
00262         SimUpdateStatus GetSpdiData(INT length, UINT8 * buffer);
00263
00264 // Ecc
00265         SimUpdateStatus GetEccArray(EccArray & eccarray, INT & length);
00266
00267 // Chvs
00268         ChvStatus VerifyChv(ChvNo chvno, const CHAR * chvptr, ChvAttemptsStruct & chvattempts);
00269         ChvStatus ChangeChv(ChvNo chvno, const CHAR * oldchvptr, const CHAR * newchvptr,
00270                             ChvAttemptsStruct & chvattempts);
00271         ChvStatus UnblockChv(ChvNo chvno, const CHAR * unbchvptr, const CHAR * newchvptr,
00272                              ChvAttemptsStruct & chvattempts);
00273
00274         ChvStatus EnableChv1(const CHAR * chvptr, ChvAttemptsStruct & chvattempts);
00275         ChvStatus DisableChv1(const CHAR * chvptr, ChvAttemptsStruct & chvattempts);
00276
00277         ChvStatus EnablePin(ChvNo chvno, const CHAR * chvptr, ChvAttemptsStruct & chvattempts);
00278         ChvStatus DisablePin(ChvNo chvno, const CHAR * chvptr, ChvAttemptsStruct & chvattempts);
00279
00280         UINT GetSmsrCount();
00281         SimUpdateStatus GetSmsr(INT recno, UINT8 & link, SmsrData &smsr);
00282         SimUpdateStatus UpdateSmsr(INT recno, UINT8 link, const SmsrData &smsr);
00283
00284 // Sms Parameters
00285         BOOLEAN GetSmsParamFileSizes(UINT8 & reclength, INT & bufferlen);
00286         SimUpdateStatus GetSmsParam(INT recno, UINT8 * data, INT len);
00287         SimUpdateStatus UpdateSmsParam(INT recno, const UINT8 * data, INT bufferlen);
00288
00289 // SimToolkit icons
00290         BOOLEAN GetSimIconDescription(INT recno, SimIconDescription & data);
00291         BOOLEAN GetSimImage(const SimImageDescriptor & imgdesc, SimImage & data);
00292
00293 // CBMI
00294         UINT GetCbmiFileLength() { return GetFileLength(c_ef_cbmi_id); }
00295         SimUpdateStatus GetCbmi(INT recno, CbmiData & data);
00296         BOOLEAN GetCbmi(UINT8 * data, INT maxlen);
00297         SimUpdateStatus UpdateCbmi(INT recno, const CbmiData & data);
00298 // CBMI Range
00299         UINT GetCbmirFileLength() { return GetFileLength(c_ef_cbmir_id); }
00300         SimUpdateStatus GetCbmir(INT recno, CbmiRange & data);
00301         BOOLEAN GetCbmir(UINT8 * data, INT maxlen);
00302         SimUpdateStatus UpdateCbmir(INT recno, const CbmiRange & data);
00303 // CCP
00304 #if defined(APOXI_ADC_CCP_CODE)
00305         UINT GetCcpFileLength() { return GetFileLength(c_ef_ccp_id); }
00306         SimUpdateStatus GetCcp(INT recno, CcpData & data);
00307         SimUpdateStatus UpdateCcp(INT recno, const CcpData & data);
00308 #endif
00309
00310 // EMLPP
00311         SimUpdateStatus GetEmlpp(UINT8 & priority, UINT8 & fastcallsetup);
00312
00313 // EONS
00314         SimUpdateStatus GetPnnInfo(INT & recordcount, INT & recordlength);
00315         SimUpdateStatus GetPnnRecord(INT recordno, INT recordsize, UINT8 * buffer);
00316         SimUpdateStatus GetOplInfo(INT & recordcount, INT & recordlength);
00317         SimUpdateStatus GetOplRecord(INT recordno, INT recordsize, UINT8 * buffer);
00318 // Mexe
00319         SimUpdateStatus GetMexeSt(UINT8 & mexest);
00320         SimUpdateStatus GetMexeRootPublicKeyProperty(SimFileId fileid, UINT & recordcount, UINT & recordlength);
00321         SimUpdateStatus GetMexeRootPublicKeyRecord(SimFileId fileid, UINT recordno, UINT recordsize, UINT8 * buffer);
00322         SimUpdateStatus GetMexeCertificateContent(SimFileId fileid, UINT size, UINT offset, UINT8 * buffer);
00323
00324 // CPHS Interface
00325         SimUpdateStatus GetCphsIst(CphsIstArray & data);
00326         SimUpdateStatus GetCphsVmwf(CphsVmwfArray & data);
00327         SimUpdateStatus UpdateCphsVmwf(const CphsVmwfArray & data);
00328         SimUpdateStatus GetCphsCfuf(CphsCfufArray & data);
00329         SimUpdateStatus UpdateCphsCfuf(const CphsCfufArray & data);
00330         SimUpdateStatus GetCphsOnm(CphsOnmName & data);
00331         SimUpdateStatus GetCphsOns(CphsOnsName & data);
00332         SimUpdateStatus GetCphsCsp(LineSelector selector, CphsCspArray & data);
00333         SimUpdateStatus UpdateCphsCsp(LineSelector selector, INT noofgroup, const CphsCspArray & data);
00334 // MRU Property
00335         SimUpdateStatus UpdateMruProperty(UINT16 type, UINT8 index, UINT8 bitnumber, UINT8 bitvalue);
00336
00337 // Orange dyn flags
00338         SimUpdateStatus GetDynamicFlag(UINT8 & data);
00339         SimUpdateStatus GetDynamic2Flag(UINT8 & data);
00340         SimUpdateStatus UpdateDynamicFlag(UINT8 data);
00341         SimUpdateStatus UpdateDynamic2Flag(UINT8 data);
00342         SimUpdateStatus GetOrangeParam(SimEfOrangeParam & data);
00343         SimUpdateStatus UpdateOrangeParam(const SimEfOrangeParam & data);
00344 // Cingular
00345         SimUpdateStatus GetTstFile(UINT8 * data);
00346
00347 // Generic Interface
00348         SimUpdateStatus GetSimData(SimFileId df_id, SimFileId ef_id, BOOLEAN istransparent, UINT16 offset,
00349                                    UINT8 * data, INT maxlen, BOOLEAN usimcommand = FALSE);
00350         SimUpdateStatus SetSimData(SimFileId df_id, SimFileId ef_id, BOOLEAN istransparent,
00351                                    UINT16 offset, const UINT8 * data, UINT8 length, BOOLEAN usimcommand = FALSE);
00352         SimUpdateStatus GetUsimFileProperty(SimFileId df_id, SimFileId ef_id, UINT & filesize, UINT & recordlength);
00353         SimUpdateStatus UsimSelect(SimFileId df_id, SimFileId ef_id);
00354         SimUpdateStatus GetSimFileProperty(SimFileId df_id, SimFileId ef_id, UINT & filesize, UINT & recordlength);
00355
00356 // SMS
00357         BOOLEAN ActivateSmsUsage();
00358         Sms::StorageType GetInitialPrefferedStorageMedia() const { return m_prefered_storage_media; }
00359         Sms::StorageType GetPreferredStorageMedia() const { return m_prefered_storage_media; }
00360         void SetInitialPrefferedStorageMedia(Sms::StorageType type) { m_prefered_storage_media = type; }
00361
00362 // Simtoolkit Simulation Interface
00363         BOOLEAN SendProactiveCommand(SimApduData * apdu, UINT8 & responsevalue);
00364         BOOLEAN SendProactiveCommandConfirmation();
00365
00366         BOOLEAN GetSimPduCount(INT &pdu_count);
00367         BOOLEAN GetNvRamPduCount(INT &pdu_count);
00368 // CMI
00369         UINT GetCmiCount();
00370         SimUpdateStatus GetCmi(UINT recno, CmiRecord & cmirecord);
00371 // MBI
00372         UINT GetMbiCount(UINT & recordlength);
00373         SimUpdateStatus GetMbi(UINT recno, UINT8 * mbidata, UINT recordlength);
00374         SimUpdateStatus UpdateMbi(UINT recno, const UINT8 * mbidata, UINT recordlength);
00375
00376
00377
00378 // DR methods
00379     private:
00380         MdhResult MdhRegister(MdhViewHdl &view_hdl);
00381     public:
00382         MdhResult MdhMakeView(MdhViewHdl &view_hdl);
00383         MdhResult MdhSetViewConfig(MdhViewHdl view_hdl, const MdhViewConfig &view_config);
00384         MdhResult MdhUpdateSmsStatus(MdhViewHdl view_hdl, INT recno, UINT8 recordstatus, BOOLEAN complete);
00385         SimUpdateStatus MdhUpdateSmsStatus(MdhViewHdl view_hdl, INT recno, UINT8 recordstatus);
00386         MdhResult MdhSetStorageMedia(MdhWorkMedia work_media);
00387         MdhResult MdhGetSms(MdhViewHdl view_hdl, INT recno, TpduConc &tpduconc, MdhTimeStamp & timestamp, MdhExtendedData & ext_data);
00388         SimUpdateStatus MdhGetSms(MdhViewHdl view_hdl, INT recno, Tpdu &tpdu, MdhTimeStamp & timestamp, MdhExtendedData & ext_data);
00389         MdhResult MdhUpdateSms(MdhViewHdl view_hdl, INT recno, const TpduNode &tpdunode, UINT8 &no_saved,
00390                                INT &storedrecno, MdhTimeStamp & timestamp);
00391         SimUpdateStatus MdhUpdateSms(MdhViewHdl view_hdl, INT recno, const Tpdu &tpdu,
00392                                INT & storedrecno, MdhTimeStamp & timestamp);
00393         MdhResult MdhGetSmsReport(MdhViewHdl view_hdl, INT recno, SmsrData &data);
00394         static MdhWorkMedia SmsToMdhWorkMediaTranslation(Sms::StorageType work_media);
00395         static Sms::StorageType MdhToSmsWorkMediaTranslation(MdhWorkMedia work_media);
00396         MdhResult MdhDeleteSms(MdhViewHdl view_hdl, INT recno, const MdhDeletionCmd & cmd);
00397         MdhResult MdhSetSmsExtendedData(MdhViewHdl view_hdl, INT recno, const MdhExtendedData & ext_data);
00398
00399         BOOLEAN MdhRequestCsmsRefNo(UINT16 & ref_no);
00400
00401 // Others
00402         SimUpdateStatus GetLastSimUpdateStatus();
00403         SimCardType DetectSimCardType();
00404         SmsMoreMessageType QuerySmsMoreMessageType();
00405
00406 #if defined(APOXI_ICC_USIM)
00407 // service tables
00408         SimUpdateStatus GetUsimUst(UsimUst & ust);
00409         SimUpdateStatus GetUsimEst(UsimEst & est);
00410 // loci files
00411         SimUpdateStatus GetUsimCsLoci(LociData & data);
00412         SimUpdateStatus GetUsimPsLoci(PsLociData & data);
00413
00414 // pref plmn lists
00415         SimUpdateStatus GetUsimPlmnList(UsimReadType type, UsimPlmn * plmnlist,
00416                                         INT maxcount, INT & noofplmn);
00417         SimUpdateStatus UpdateUsimPlmn(INT pos, const UsimPlmn & plmn, UsimUpdateAction action);
00418 // pref lang files
00419         SimUpdateStatus GetUsimLanguageList(UsimLangFileType filetype, ExtLanguage * langlist,
00420                                             INT maxcount, INT & nooflang);
00421         SimUpdateStatus UpdateUsimLanguage(UsimLangFileType, INT pos, const UsimLanguage & lang, UsimUpdateAction action);
00422
00423 // ecc
00424         SimUpdateStatus GetUsimEccRecord(INT recno, UsimEccRecord & record);
00425 // smsparams
00426         SimUpdateStatus GetUsimSmsParam(INT recno, UINT8 * data, INT len, INT & alphalen);
00427         SimUpdateStatus UpdateUsimSmsParam(INT recno, const UINT8 * data, INT bufferlen);
00428 // file property
00429         SimUpdateStatus GetUsimFileProperty(UsimReadType type, UsimFileProperty & property);
00430
00431 #endif
00432
00433     private:
00434         struct SimAccessorStruct {
00435             StackMsgArgId     inid;
00436             StackMsgArgId     outid;
00437             MessageReferrer * msgref;
00438             Application *     app;
00439             UINT16            priority;
00440             Ticks             timestamp;
00441             UINT32            param;
00442         };
00443
00444         Mutex               m_mutex;
00445         static SimInfo      m_sim_info;
00446         static SimCardType  m_simtype;
00447
00448         SimAccessorStruct   m_pendingmsg[c_maxpending_messages];
00449
00450         SimUpdateStatus     m_last_update_status;
00451
00452         BOOLEAN             m_fdn_state;
00453         BOOLEAN             m_bdn_state;
00454         BOOLEAN             m_adn_rw_state;
00455         BOOLEAN             m_bdn_rw_state;
00456
00457         Sms::StorageType    m_prefered_storage_media;
00458
00459         MdhViewHdl          m_main_view_hdl;
00460
00461         void    ActivateMessage(StackMsgArgId id, UINT32 param = 0);
00462         void    DeactivateMessage(StackMsgArgId id, UINT32 param = 0);
00463         BOOLEAN IsMessageReceived(StackMsgArgId id, UINT32 param);
00464         BOOLEAN IsMessageSendable(StackMsgArgId id, UINT32 param);
00465         BOOLEAN IsMessageQueueEmpty();
00466
00467         void StartSendingSignal(UserDispatcher & ud, BOOLEAN generic_active = FALSE);
00468         void FinishSendingSignal(UserDispatcher & ud);
00469         StackMsgArgument * GetArgument(StackMsgArgId id, UINT32 param = 0);
00470         StackMsgArgument * ExecuteStackMessage(StackMsgArgId id, StackMsgArgument* arg, UINT32 param = 0);
00471         StackMsgArgument * ProcessStackMessage(StackMsgArgId id, StackMsgArgument* sendarg);
00472
00473         BOOLEAN SendApdu(const SimFileId df_id, BOOLEAN df_res,
00474                          const SimFileId ef_id, BOOLEAN ef_res,
00475                          SimApduData * apdu);
00476
00477 };
00478
00479 // SimUserDispatcher /////////////////////////////////////
00480
00481 class SimUserDispatcher : public UserDispatcher {
00482     typedef UserDispatcher Base;
00483
00484     public:
00485         SimUserDispatcher(SimAccessor * accessor);
00486         virtual ~SimUserDispatcher();
00487
00488         static BOOLEAN HasParamAttribute(StackMsgArgId id);
00489         static BOOLEAN HasParam(StackMsgArgument * arg, UINT32 param);
00490
00491     protected:
00492         virtual BOOLEAN OnMessage(const Message &msg);
00493
00494     private:
00495         SimAccessor * m_accessor;
00496
00497 };
00498
00500 #endif // Adc_SimAccessor_hpp
00501
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimAuxHandler.cpp File Reference

Adc/SimAuxHandler.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Auxiliary/AlphaCoding.hpp>
#include <Auxiliary/DataCoding.hpp>
#include <Auxiliary/DbgDump.hpp>
#include <Kernel/System.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include "SimAuxHandler.hpp"

Include dependency graph for SimAuxHandler.cpp:

Functions

INT | FindFirstByte (const UINT8 *address, INT size, UINT8 eos)
UINT16 | SwapBytes (UINT16 value)

Variables

const UINT8 | c_full_name_ie = 0x43
const UINT8 | c_short_name_ie = 0x45

Function Documentation

UINT16 SwapBytes ( UINT16 value ) [inline]

Variable Documentation

const UINT8 c_full_name_ie = 0x43

const UINT8 c_short_name_ie = 0x45

Generated on Tue Jan 24 15:26:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimAuxHandler.hpp File Reference

Adc/SimAuxHandler.hpp File Reference

#include <Adc/BaseDataHandler.hpp>
#include <Auxiliary/FixedPtrArray.hpp>
#include <Apc/StackWrapper.hpp>

Include dependency graph for SimAuxHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MexeDescriptor
class | OplEntry
class | PnnEntry
class | SimAuxHandler
struct | SimAuxHandler::ExtLanguageBuffer
class | SimMexeCertificate

Defines

#define | Adc_SimAuxHandler_hpp

Enumerations

enum | MexeCertType { OperatorRootPublicKey, AdministratorRootPublicKey, ThirdPartyRootPublicKey }
MexeCertType describes the different types of cerificates stored in the DF-Mexe directory. More...

Functions

INT | FindFirstByte (const UINT8 *address, INT size, UINT8 eos)

Variables

const INT | c_max_cbmi = 30
const INT | c_max_cbmir = 30
const INT | c_max_ccp = 5
const INT | c_max_cmi_records = 10
const INT | c_max_ecc_records = 10
const INT | c_max_ext_lang_buffer_size = c_max_extlanguages*2
const INT | c_max_extlanguages = 30
const INT | c_max_lang_buffer_size = c_max_languages*1
const INT | c_max_languages = 30
const INT | c_max_mbi_record_length = 5
const INT | c_max_plmn_buffer_size = c_max_plmns*3
const INT | c_max_plmns = 50

Define Documentation

#define Adc_SimAuxHandler_hpp

Generated on Tue Jan 24 15:26:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimAuxHandler.hpp Source File

Adc/SimAuxHandler.hpp

Go to the documentation of this file.
00001
00002 /*  ------------------------------------------------------------------------
00003     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Adc_SimAuxHandler_hpp)
00011 #define Adc_SimAuxHandler_hpp
00015
00016 #include <Adc/BaseDataHandler.hpp>
00017 #include <Auxiliary/FixedPtrArray.hpp>
00018 #include <Apc/StackWrapper.hpp>
00019
00020 /*  ========================================================================
00021                             Limitations
00022     ========================================================================*/
00023
00024 const INT c_max_plmns = 50;                                     // = 50 plmns
00025 const INT c_max_plmn_buffer_size = c_max_plmns*3;               // = 50 plmns
00026 const INT c_max_languages = 30;                                 // = 30 languages
00027 const INT c_max_lang_buffer_size = c_max_languages*1;           // = 30 languages
00028 const INT c_max_extlanguages = 30;                              // = 30 languages
00029 const INT c_max_ext_lang_buffer_size = c_max_extlanguages*2;    // = 30 languages
00030
00031 const INT c_max_cbmi = 30;                                      // = 30 cbmi entries
00032 const INT c_max_cbmir = 30;                                     // = 30 cbmir entries
00033
00034 const INT c_max_ccp = 5;                                        // = 5 ccp entries
00035
00036 const INT c_max_ecc_records = 10;                               // = 10 usim ecc records
00037
00038 const INT c_max_cmi_records = 10;                               // = 10 cmi records
00039
00040 const INT c_max_mbi_record_length = 5;                          // = 5 bytes per mbi record
00041
00042
00043 struct SimLockStates;
00044 class SimAccessor;
00045
00046 /*  ========================================================================
00047                             EONS structures
00048     ========================================================================*/
00049
00050 class PnnEntry
00051 {
00052     public:
00053         PnnEntry() : m_longci(FALSE), m_shortci(FALSE) {}
00054
00055         WString m_longname;
00056         WString m_shortname;
00057         BOOLEAN m_longci;
00058         BOOLEAN m_shortci;
00059 };
00060
00061 class OplEntry
00062 {
00063     public:
00064         enum {
00065             c_opl_buffer_len = 8
00066         };
00067
00068         OplEntry(const UINT8 * buffer) { memcpy(m_buffer,buffer,c_opl_buffer_len); }
00069
00070     // content is define in 3GPP TS 31.102 4.2.59
00071         BOOLEAN IsBcdPlmnMatching(BcdPlmn checkplmn) const {
00072             return StackWrapper::IsBcdPlmnMatching(checkplmn,((UINT16)m_buffer[0]<<8)+m_buffer[1],m_buffer[2]);
00073         }
00074         UINT16  GetLacLow() const { return ((UINT16)m_buffer[3]<<8) + m_buffer[4]; }
00075         UINT16  GetLacHigh() const { return ((UINT16)m_buffer[5]<<8) + m_buffer[6]; }
00076         BOOLEAN HasEntireLacRange() const { return GetLacLow()==0x0000 && GetLacHigh()==0xFFFE; }
00077         INT     GetPnnRecordId() { return (INT)m_buffer[7]; }
00078         BOOLEAN HasPnnRecordId() const { return m_buffer[7]!=0x00 && m_buffer[7]!=0xFF; }
00079
00080
00081         UINT8 m_buffer[c_opl_buffer_len];
00082 };
00083
00084 /*  ========================================================================
00085                             Mexe structures
00086     ========================================================================*/
00087
00089 enum MexeCertType
00090 {
00092     OperatorRootPublicKey,
00094     AdministratorRootPublicKey,
00096     ThirdPartyRootPublicKey
00097 };
00098
00099 // is for internal use only, holds the Mexe descriptor entries of the SIM/USIM of the ORPK,ARPK,TPRPK
00100 // files in the DF-Mexe directory
00101 class MexeDescriptor
00102 {
00103     public:
00104         MexeDescriptor(MexeCertType type, const UINT8 * buffer, UINT16 len) {
00105             ASSERT_DEBUG(len>=10);
00106             m_length = len;
00107             m_type = type;
00108             m_buffer = new UINT8[len];
00109             ASSERT_DEBUG(m_buffer!=0);
00110             memcpy(m_buffer,buffer,len);
00111         }
00112
00113         ~MexeDescriptor() {
00114             delete[] m_buffer;
00115             m_buffer = 0;
00116             m_length = 0;
00117         }
00118
00119         MexeCertType GetMexeCertType() const {
00120             return m_type;
00121         }
00122
00123     // content is defined in 3GPP TS 51.011 10.4.4.2
00124
00125         BOOLEAN IsValid() const {
00126             ASSERT_DEBUG(m_buffer!=0); return (*m_buffer & 0x01)==0x00;
00127         }
00128
00129         BOOLEAN IsAuthorityCert() const {
00130             ASSERT_DEBUG(m_buffer!=0); return (m_buffer[1] & 0x01)==0x01;
00131         }
00132
00133         UINT GetCertType() const {
00134             ASSERT_DEBUG(m_buffer!=0); return (UINT)(m_buffer[2]);
00135         }
00136
00137         SimFileId GetSimFileId() const {
00138             ASSERT_DEBUG(m_buffer!=0); return (SimFileId)((m_buffer[3]<<8)+m_buffer[4]);
00139         }
00140
00141         UINT16 GetCertOffset() const {
00142             ASSERT_DEBUG(m_buffer!=0); return (UINT16)((m_buffer[5]<<8)+m_buffer[6]);
00143         }
00144
00145         UINT16 GetCertLength() const {
00146             ASSERT_DEBUG(m_buffer!=0); return (UINT16)((m_buffer[7]<<8)+m_buffer[8]);
00147         }
00148
00149         UINT8 GetKeyIdLength() const {
00150             ASSERT_DEBUG(m_buffer!=0); return (m_buffer[9]);
00151         }
00152
00153         UINT8 * GetKeyIdBuffer() const {
00154             ASSERT_DEBUG(m_buffer!=0);
00155             return (GetKeyIdLength()>0) ? &m_buffer[10] : 0;
00156         }
00157
00158     private:
00159         UINT8 *      m_buffer;
00160         UINT16       m_length;
00161         MexeCertType m_type;
00162 };
00163
00168 class SimMexeCertificate
00169 {
00170     public:
00172         SimMexeCertificate(MexeDescriptor * certdesc, UINT8 * certbuffer, UINT16 certsize)
00173         {
00174             ASSERT_DEBUG(certsize>0);
00175             ASSERT_DEBUG(certdesc!=0);
00176             ASSERT_DEBUG(certbuffer!=0);
00177             m_certdesc = certdesc;
00178             m_certsize = certsize;
00179             m_certbuffer = certbuffer;
00180         }
00181
00183         ~SimMexeCertificate() {
00184             delete[] m_certbuffer;
00185             m_certbuffer = 0;
00186             m_certsize = 0;
00187             m_certdesc = 0;
00188         }
00189
00191         MexeCertType GetMexeCertType() const {
00192             ASSERT_DEBUG(m_certdesc!=0 && m_certbuffer!=0); return m_certdesc->GetMexeCertType();
00193         }
00194
00196         BOOLEAN IsValid() const {
00197             ASSERT_DEBUG(m_certdesc!=0 && m_certbuffer!=0); return m_certdesc->IsValid();
00198         }
00199
00201         BOOLEAN IsAuthorityCert() const {
00202             ASSERT_DEBUG(m_certdesc!=0 && m_certbuffer!=0); return m_certdesc->IsAuthorityCert();
00203         }
00204
00206         UINT GetCertType() const {
00207             ASSERT_DEBUG(m_certdesc!=0 && m_certbuffer!=0); return m_certdesc->GetCertType();
00208         }
00209
00211         UINT16 GetCertSize() const {
00212             ASSERT_DEBUG(m_certdesc!=0 && m_certbuffer!=0); return m_certsize;
00213         }
00214
00216         const UINT8 * GetCertBuffer() const {
00217             ASSERT_DEBUG(m_certdesc!=0 && m_certbuffer!=0); return m_certbuffer;
00218         }
00219
00221         UINT8 GetKeyIdLength() const {
00222             ASSERT_DEBUG(m_certdesc!=0 && m_certbuffer!=0);  return m_certdesc->GetKeyIdLength();
00223         }
00224
00226         UINT8 * GetKeyIdBuffer() const {
00227             ASSERT_DEBUG(m_certdesc!=0 && m_certbuffer!=0);  return m_certdesc->GetKeyIdBuffer();
00228         }
00229
00230     private:
00231         MexeDescriptor * m_certdesc;
00232         UINT16           m_certsize;
00233         UINT8 *          m_certbuffer;
00234 };
00235
00236 /*  ========================================================================
00237                             Helper function
00238     ========================================================================*/
00239
00240 INT FindFirstByte(const UINT8 * address, INT size, UINT8 eos);
00241
00242 /*  ========================================================================
00243                             SimAuxHandler
00244     ========================================================================*/
00245
00246 class SimAuxHandler : public BaseDataHandler
00247 {
00248     typedef BaseDataHandler Base;
00249
00250     public:
00251         SimAuxHandler();
00252         virtual ~SimAuxHandler();
00253
00254 // Reset
00255         void Reset();
00256
00257 // InitResult
00258         void SetInitResult(const SimInitResult & initresult);
00259         SimInitResult GetInitResult() const;
00260
00261 // Resetable/Refreshable by Simtoolkit
00262         BOOLEAN IsSimResetPossible() const;
00263         void SetSimResetPossible(BOOLEAN resetable);
00264         BOOLEAN IsSimRefreshPossible() const;
00265         void SetSimRefreshPossible(BOOLEAN refreshable);
00266
00267 // Chv1/Chv2 checking
00268         BOOLEAN DetectChvProtection(UINT16 fileid, ChvNo & chvno);
00269
00270 // Ofm
00271         BOOLEAN IsOfmToBeActivated();
00272
00273 // Imsi
00274         void SetImsi(const Imsi & imsi);
00275         BOOLEAN GetImsiString(WString & imsi) const;
00276         BcdPlmn GetImsiBcdPlmn() const;
00277
00278 // Imei
00279         BOOLEAN GetImeiString(WString & imei);
00280
00281 // Plmn lookup
00282         BOOLEAN LookupPlmnName(const Plmn & plmn, WString & longname, WString & shortname,
00283                                NetType & nettype, WString & countryname);
00284
00285 // Spn & Spdi
00286         BOOLEAN GetSpnData(WString & spnstr, BOOLEAN & condition);
00287         BOOLEAN CheckSpnData(const Plmn & regplmn, BOOLEAN & showregplmn,
00288                              BOOLEAN & showspnname, WString & spnname,
00289                              BOOLEAN use_spn_display_condition);
00290
00291 // Loci
00292         BOOLEAN RetrieveLociData(LociData & locidata);
00293         BOOLEAN GetLocationUpdateStatus(LocationUpdateStatus & status);
00294         BOOLEAN GetLocationBcdPlmn(BcdPlmn & plmn);
00295         BOOLEAN GetLocationLac(UINT16 & lac);
00296
00297 // SimInfo
00298         BOOLEAN GetSimInfo(SimInfo & siminfo) const;
00299
00300         void SetSimLockStatus(const SimLockStates & lockstates);
00301         BOOLEAN GetSimLockStates(SimLockStates & lockstates) const;
00302
00303 // SimErrorCode
00304         void SetSimErrorCode(const SimErrorCode errorcode);
00305         BOOLEAN GetSimErrorCode(SimErrorCode & errorcode) const;
00306
00307 // Iccid
00308         BOOLEAN GetIccidString(WString & iccid) const;
00309
00310 // Prefered Plmns
00311         UINT8   GetPlmnCount() const;
00312         UINT8   GetMaxPlmnCount() const;
00313         BOOLEAN RetrievePlmnList();
00314         BcdPlmn GetBcdPlmn(INT idx) const;
00315         BOOLEAN UpdatePlmn(INT idx, BcdPlmn plmn);
00316         BOOLEAN InsertPlmn(INT idx, BcdPlmn plmn);
00317         BOOLEAN DeletePlmn(INT idx);
00318         BOOLEAN DeleteAllPlmns();
00319
00320 // Prefered Plmns PlmnwACT
00321         BOOLEAN IsPlmnwactPresent() { return m_plmnwact_present; }
00322
00323         BOOLEAN RetrievePlmnwactList();
00324         BcdPlmn GetBcdPlmnwAct(INT idx) const;
00325         UINT16  GetPlmnAct(INT idx) const;
00326
00327         BOOLEAN DeletePlmnwAct(INT idx);
00328         BOOLEAN DeleteAllPlmnwAct();
00329         BOOLEAN InsertPlmnwAct(INT idx, BcdPlmn plmn, UINT16 rat);
00330         BOOLEAN UpdatePlmnwAct(INT idx, BcdPlmn plmn, UINT16 rat);
00331
00332 // Pref Languages
00333         UINT8   GetLanguageCount() const;
00334         UINT8   GetMaxLangCount() const;
00335         Language GetLanguage(INT idx) const;
00336         BOOLEAN RetrieveLanguageList();
00337         BOOLEAN UpdateLanguage(INT idx, Language language);
00338         BOOLEAN InsertLanguage(INT idx, Language language);
00339         BOOLEAN DeleteLanguage(INT idx);
00340         BOOLEAN DeleteAllLanguages();
00341
00342 // Pref Ext Languages
00343         UINT8   GetExtLanguageCount(INT instance_nr) const;
00344         UINT8   GetMaxExtLangCount(INT instance_nr) const;
00345         WString GetExtLanguage(INT idx, INT instance_nr) const;
00346         BOOLEAN RetrieveExtLanguageList(INT instance_nr);
00347         BOOLEAN UpdateExtLanguage(INT idx, const WString & language, INT instance_nr);
00348         BOOLEAN InsertExtLanguage(INT idx, const WString & language, INT instance_nr);
00349         BOOLEAN DeleteExtLanguage(INT idx, INT instance_nr);
00350         BOOLEAN DeleteAllExtLanguages(INT instance_nr);
00351
00352         WString GetActiveExtLanguage() const;
00353         void SetActiveExtLanguage(const WString & language);
00354
00355 // Puct
00356         BOOLEAN GetPuctData(WString & currencycode, UINT & eppu, INT & exponent);
00357         BOOLEAN UpdatePuctData(const WString & currencycode, UINT eppu, INT exponent);
00358
00359 // Acm
00360         BOOLEAN GetAcm(UINT32 & value, AcmSelector selector = Acm1);
00361         BOOLEAN UpdateAcm(UINT32 value, AcmSelector selector = Acm1);
00362         BOOLEAN GetMaxAcm(UINT32 & value);
00363         BOOLEAN UpdateMaxAcm(UINT32 value);
00364
00365 // Ecc
00366         UINT8   GetEccCount() const;
00367         BOOLEAN RetrieveEccList();
00368         BOOLEAN GetEcc(UINT idx, WString & eccstr);
00369
00370 // Sst
00371         UINT8   GetSstCount() const;
00372         BOOLEAN RetrieveSst();
00373         BOOLEAN GetServiceValues(UINT idx, BOOLEAN & allocated, BOOLEAN & activated);
00374
00375 // Ccp
00376 #if defined(APOXI_ADC_CCP_CODE)
00377         INT GetMaxCcpCount();
00378         INT GetCcpCount();
00379         BOOLEAN GetCcp(INT idx, UINT8 * ccp_rec);
00380         BOOLEAN UpdateCcp(INT idx, const UINT8 * ccp_rec);
00381 #endif
00382
00383 // Cbmi
00384         UINT8   GetMaxCbmiCount() const;
00385         BOOLEAN RetrieveCbmi();
00386         BOOLEAN GetCbmi(UINT idx, UINT16 & cbmi);
00387         BOOLEAN UpdateCbmi(UINT idx, UINT16 cbmi);
00388
00389 // Cbmi ranges
00390         UINT8   GetMaxCbmiRangeCount() const;
00391         BOOLEAN RetrieveCbmiRanges();
00392         BOOLEAN GetCbmiRange(UINT idx, UINT16 & rangehigh, UINT16 & rangelow);
00393         BOOLEAN UpdateCbmiRange(UINT idx, UINT16 rangehigh, UINT16 rangelow);
00394
00395 // Cmi
00396         UINT8   GetMaxCmiCount() const;
00397         BOOLEAN RetrieveCmi();
00398         BOOLEAN GetCmi(UINT idx, WString & alphaid, UINT8 & cmi);
00399
00400 // Mbi
00401         UINT8   GetMaxMbiCount() const;
00402         UINT8   GetMbiRecordSize() const;
00403         BOOLEAN RetrieveMbi();
00404         BOOLEAN GetMbiRecord(UINT idx, UINT8 * buffer);
00405         BOOLEAN UpdateMbiRecord(UINT idx, const UINT8 * buffer);
00406
00407 // Ccp
00408         UINT8   GetMaxCcpCount() const;
00409         BOOLEAN RetrieveCcp();
00410         BOOLEAN GetCcp(UINT idx, CcpData & data);
00411         BOOLEAN UpdateCcp(UINT idx, const CcpData & data);
00412
00413 // Fdn
00414         BOOLEAN GetFdnState() const;
00415
00416 // Emlpp
00417         BOOLEAN GetEmlppSubscription(EmlppPriorityLevel idx, BOOLEAN & subscribed);
00418         BOOLEAN GetEmlppSetupCallCondition(EmlppPriorityLevel idx, BOOLEAN & condition);
00419 // EONS
00420         BOOLEAN RetrieveEonsData(BOOLEAN pnnenabled, BOOLEAN oplenabled);
00421         BOOLEAN GetEonsPlmnName(const BcdPlmn & checkplmn, UINT16 lac, WString & longname, WString & shortname);
00422
00423 // Mexe
00424         BOOLEAN InitMexe();
00425         UINT    GetSimMexeCertificateCount() const { return m_cert_count; }
00426         SimMexeCertificate * GetSimMexeCertificate(UINT idx);
00427
00428 // Mark unread for Simtoolkit
00429         void MarkImsiUnread() { m_imsi_ispresent = FALSE; }
00430         void MarkPrefPlmnUnread() { m_plmn_list_isupdated = FALSE; }
00431         void MarkPrefLangUnread() { m_lang_list_isupdated = FALSE; }
00432         void MarkPrefExtLangUnread() {
00433                 m_extlang[0].m_ext_lang_list_isupdated = FALSE;
00434                 m_extlang[1].m_ext_lang_list_isupdated = FALSE;
00435         }
00436         void MarkEccUnread() { m_ecc_ispresent = FALSE; }
00437         void MarkSstUnread() { m_sst_ispresent = FALSE; }
00438         void MarkSpnUnread() { m_spn_ispresent = FALSE; }
00439         void MarkCcpUnread() { m_ccp_ispresent = FALSE; }
00440         void MarkCbmiUnread() { m_cbmi_ispresent = FALSE; }
00441         void MarkCbmirUnread() { m_cbmir_ispresent = FALSE; }
00442         void MarkAcmUnread() { m_acm_ispresent = FALSE; }
00443         void MarkAcmMaxUnread() { m_acmmax_ispresent = FALSE; }
00444         void MarkPuctUnread() { m_puct_ispresent = FALSE; }
00445
00446 #if defined(APOXI_ICC_USIM)
00447
00448 // ECC USIM
00449     public:
00450         UINT8   GetUsimEccCount() const;
00451         BOOLEAN RetrieveUsimEccList();
00452         BOOLEAN GetUsimEcc(UINT idx, WString & eccstr, WString & alphaid, UINT8 & servicecategory);
00453     private:
00454         UsimEccRecord m_eccrecords[c_max_ecc_records];
00455
00456 // UST USIM
00457     public:
00458         UINT8   GetUstCount() const;
00459         BOOLEAN RetrieveUst();
00460         BOOLEAN IsUsimServiceAvailable(UINT idx, BOOLEAN & available);
00461     private:
00462         UsimUst m_ust;
00463         BOOLEAN m_ust_ispresent;
00464
00465 // EST USIM
00466     public:
00467         UINT8   GetEstCount() const;
00468         BOOLEAN RetrieveEst();
00469         BOOLEAN IsUsimServiceEnabled(UINT idx, BOOLEAN & enabled);
00470     private:
00471         UsimEst m_est;
00472         BOOLEAN m_est_ispresent;
00473
00474 #endif
00475
00476
00477     private:
00478         BOOLEAN CommitLanguageList();
00479         BOOLEAN CommitExtLanguageList(INT instance_nr);
00480
00481         BOOLEAN CommitPlmnList();
00482
00483         BOOLEAN RetrieveSpn();
00484         BOOLEAN RetrieveSpdiData();
00485         BOOLEAN IsPlmnInSpdiData(const Plmn & plmn);
00486
00487         Imei * RetrieveImei();
00488         Puct * RetrievePuct();
00489         BOOLEAN RetrieveEmlpp();
00490
00491         static WString ConvertBcdStreamToString(const UINT8 * stream, INT length, INT ignorenibble = 0);
00492
00493     // decoding is done as described in 3GPP TS 31.102 V6.3.0 (4.2.58) and 3GPP TS 24.008 (10.5.3.5a)
00494         PnnEntry * CreatePnnEntry(UINT8 * buffer, INT len);
00495     // creates an oplentry if valid
00496         OplEntry * CreateOplEntry(UINT8 * buffer);
00497
00498         SimInitResult m_initresult;
00499
00500         BOOLEAN     m_sim_resetable;
00501         BOOLEAN     m_sim_refreshable;
00502         BOOLEAN     m_imsi_ispresent;
00503         BOOLEAN     m_imei_ispresent;
00504         BOOLEAN     m_plmnwact_present;
00505         BOOLEAN     m_plmn_list_isupdated;
00506         BOOLEAN     m_lang_list_isupdated;
00507         BOOLEAN     m_ext_lang_list_isupdated;
00508         BOOLEAN     m_acm_ispresent;
00509         BOOLEAN     m_acmmax_ispresent;
00510         BOOLEAN     m_puct_ispresent;
00511
00512         BOOLEAN     m_ecc_ispresent;
00513         BOOLEAN     m_sim_info_isupdated;
00514         BOOLEAN     m_sim_lockstates_isupdated;
00515         BOOLEAN     m_sim_errorcode_isupdated;
00516         BOOLEAN     m_sst_ispresent;
00517
00518         BOOLEAN     m_spn_isinitialized;
00519         BOOLEAN     m_spn_ispresent;
00520         BOOLEAN     m_spdi_isinitialized;
00521         BOOLEAN     m_spdi_ispresent;
00522
00523         BOOLEAN     m_ccp_ispresent;
00524         BOOLEAN     m_cbmi_ispresent;
00525         BOOLEAN     m_cbmir_ispresent;
00526         BOOLEAN     m_emlpp_ispresent;
00527         BOOLEAN     m_emlpp_isupdated;
00528
00529         Imsi          m_imsi;
00530         Imei          m_imei;
00531         SimLockStates m_sim_lockstates;
00532         SimErrorCode  m_sim_errorcode;
00533         BOOLEAN       m_sminitfinshed;
00534
00535         UINT8       m_plmn_max_count;
00536         UINT8       m_plmn_count;
00537         UINT8       m_plmn_list[c_max_plmn_buffer_size];
00538         UsimPlmn    m_plmn_wact_list[c_max_plmns];
00539
00540         UINT8       m_lang_max_count;
00541         UINT8       m_lang_count;
00542         Language    m_lang_list[c_max_languages];
00543
00544         struct ExtLanguageBuffer {
00545             BOOLEAN     m_ext_lang_list_isupdated;
00546             UINT8       m_ext_lang_max_count;
00547             UINT8       m_ext_lang_count;
00548             ExtLanguage m_ext_lang_list[c_max_extlanguages];
00549         };
00550
00551         ExtLanguageBuffer m_extlang[2];
00552
00553         ExtLanguageBuffer & GetExtLanguageBuffer(INT instance_nr) {
00554             ASSERT_DEBUG(instance_nr==0 || instance_nr==1);
00555             return m_extlang[instance_nr];
00556         };
00557         const ExtLanguageBuffer & GetExtLanguageBuffer(INT instance_nr) const {
00558             ASSERT_DEBUG(instance_nr==0 || instance_nr==1);
00559             return m_extlang[instance_nr];
00560         };
00561
00562         ExtLanguage m_active_ext_lang;
00563
00564         ServiceProviderStruct m_spn;
00565
00566         Puct        m_puct;
00567         UINT8       m_ecc_count;
00568         EccArray    m_eccarray;
00569         UINT8           m_sst_count;
00570         SimServiceTable m_sst;
00571
00572         UINT8      m_cbmi_max_count;
00573         UINT8      m_cbmi_list[c_max_cbmi*2];
00574
00575         UINT8      m_cbmir_max_count;
00576         UINT8      m_cbmir_list[c_max_cbmir*4];
00577
00578         UINT8      m_ccp_max_count;
00579         UINT8      m_ccp_list[c_max_ccp*14];
00580
00581         UINT8      m_emlpp_priority;
00582         UINT8      m_emlpp_fastcallsetup;
00583 // CMI
00584         BOOLEAN    m_cmi_ispresent;
00585         UINT8      m_cmi_max_count;
00586         CmiRecord  m_cmi_records[c_max_cmi_records];
00587
00588 // EONS
00589         UINT8      m_eons_initialized;
00590         UINT8      m_eons_present;
00591         FixedPtrArray<PnnEntry>  m_pnn_entries;
00592         FixedPtrArray<OplEntry>  m_opl_entries;
00593         Plmn *     m_spdi_entries;
00594         INT        m_spdi_plmn_count;
00595
00596 // Mexe
00597         BOOLEAN    m_mexe_initialized;
00598         FixedPtrArray<MexeDescriptor>  m_mexe_entries;
00599         UINT       m_cert_count;
00600
00601 // MBI
00602         BOOLEAN    m_mbi_ispresent;
00603         UINT8      m_mbi_max_count;
00604         UINT8      m_mbi_record_size;
00605         UINT8 *    m_mbi_buffer;
00606
00607 };
00608
00609 #endif
00610
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimChvHandler.cpp File Reference

Adc/SimChvHandler.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SimChvHandler.hpp"

Include dependency graph for SimChvHandler.cpp:

Functions

BOOLEAN | CorrectSimKeyboardAllowed (UINT8 value)
BOOLEAN | CorrectSimMenuAllowed (UINT8 value)
BOOLEAN | NoSimKeyboardAllowed (UINT8 value)
BOOLEAN | NoSimMenuAllowed (UINT8 value)
BOOLEAN | WrongSimKeyboardAllowed (UINT8 value)
BOOLEAN | WrongSimStartupAllowed (UINT8 value)

Function Documentation

BOOLEAN CorrectSimKeyboardAllowed ( UINT8 value ) [inline]

BOOLEAN CorrectSimMenuAllowed ( UINT8 value ) [inline]

BOOLEAN NoSimKeyboardAllowed ( UINT8 value ) [inline]

BOOLEAN NoSimMenuAllowed ( UINT8 value ) [inline]

BOOLEAN WrongSimKeyboardAllowed ( UINT8 value ) [inline]

BOOLEAN WrongSimStartupAllowed ( UINT8 value ) [inline]

Generated on Tue Jan 24 15:26:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimChvHandler.hpp File Reference

Adc/SimChvHandler.hpp File Reference

#include <Adc/BaseDataHandler.hpp>

Include dependency graph for SimChvHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimChvHandler

Defines

#define | Adc_SimChvHandler_hpp

Variables

const INT | c_attempts_left_undefined = 0xff

Define Documentation

#define Adc_SimChvHandler_hpp

Generated on Tue Jan 24 15:26:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimChvHandler.hpp Source File

Adc/SimChvHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_SimChvHandler_hpp)
00010 #define Adc_SimChvHandler_hpp
00014
00015 #include <Adc/BaseDataHandler.hpp>
00016
00017 class SimAccessor;
00018
00019 const INT c_attempts_left_undefined = 0xff;
00020
00023 class SimChvHandler : public BaseDataHandler
00024 {
00025     typedef BaseDataHandler Base;
00026
00027     public:
00028         SimChvHandler();
00029         virtual ~SimChvHandler();
00030
00031         void Reset();
00032
00033 // chv handler
00034         INT GetMaxNumbersStored() const;
00035
00036         void InitChvData(const SimInfo & simInfo);
00037         void RefreshChvData(const ChvData& chv_data);
00038         const ChvData & GetChvData(INT idx) const;
00039
00041         ChvStatus VerifyChv (ChvNo chv_no, const WString &chv_str);
00043         ChvStatus ChangeChv (ChvNo chv_no, const WString &old_chv_str, const WString &new_chv_str);
00045         ChvStatus UnblockChv(ChvNo chv_no, const WString &unblocking_str, const WString &new_chv_str);
00047         ChvStatus EnableChv (ChvNo chv_no, const WString &chv_str);
00049         ChvStatus DisableChv(ChvNo chv_no, const WString &chv_str);
00050
00051 // lock states
00052         void SetSecLockStates(const SecLockStates & lockstates);
00053         const SecLockStates & GetSecLockStates() const { return m_lockstates; }
00054 // imsi plmn, set by the SimMccMncIndArg signal, used to determine the language
00055         void SetImsiPlmn(const Plmn & plmn) { m_imsiplmn = plmn; }
00056         const Plmn & GetImsiPlmn() const { return m_imsiplmn; }
00057
00058         BOOLEAN IsUnlockingAllowedOnStartup();
00059         BOOLEAN IsUnlockingAllowedPerMenu();
00060         BOOLEAN IsUnlockingAllowedKeyBased();
00061
00062         BOOLEAN ModifyLock(const SecLockAction lockaction, const SecLockType locktype,
00063                            const WString & oldpwd, const WString & newpwd);
00064
00065         BOOLEAN UpdateChvData(ChvNo no,
00066                               ChvStatus status,
00067                               ChvAttempts attempts_left = c_attempts_left_undefined,
00068                               ChvAttempts unblocking_attempts_left = c_attempts_left_undefined);
00069
00070     private:
00071         void SortSecLockStates();
00072
00073         INT      m_numbers_stored;
00074         ChvData  m_chv_data[c_max_chvs];
00075         BOOLEAN  m_chv_data_initialized;
00076
00077         SecLockStates m_lockstates; // lock structure
00078         Plmn          m_imsiplmn;   // imsi plmn used for unlocking for correct language
00079
00080 };
00081
00083 #endif
00084
00085
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimCphsHandler.cpp File Reference

Adc/SimCphsHandler.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Auxiliary/AlphaCoding.hpp>
#include <Auxiliary/DataCoding.hpp>
#include "SimCphsHandler.hpp"
#include "SimAuxHandler.hpp"

Include dependency graph for SimCphsHandler.cpp:

Generated on Tue Jan 24 15:26:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimCphsHandler.hpp File Reference

Adc/SimCphsHandler.hpp File Reference

#include <Adc/BaseDataHandler.hpp>

Include dependency graph for SimCphsHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimCphsHandler

Defines

#define | Adc_SimCphsHandler_hpp

Variables

const INT | c_cphs_sst_count = c_cphs_sst_len*4
const INT | c_cphs_sst_len = 2
const INT | c_op_srt_name_file_len = 10

Define Documentation

#define Adc_SimCphsHandler_hpp

Generated on Tue Jan 24 15:26:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimCphsHandler.hpp Source File

Adc/SimCphsHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Adc_SimCphsHandler_hpp)
00009 #define Adc_SimCphsHandler_hpp
00013
00014 #include <Adc/BaseDataHandler.hpp>
00015
00016 // length of Cphs-Sst
00017 const INT c_cphs_sst_len = 2;
00018 const INT c_cphs_sst_count = c_cphs_sst_len*4;
00019
00020 // length of Cphs-Operator name shortform
00021 const INT c_op_srt_name_file_len = 10;
00022
00023 class SimCphsHandler : public BaseDataHandler
00024 {
00025     typedef BaseDataHandler Base;
00026
00027     public:
00028         // values are used for shifting
00029         enum VoiceMsgType {
00030             MsgTypeLine1    = 8,
00031             MsgTypeLine2    = 12,
00032             MsgTypeFax      = 0,
00033             MsgTypeData     = 4,
00034         };
00035         // MS byte represents the Service Group Code,
00036         // LS byte represents the bit significance for each SGC
00037         enum CphsServGroupCode {
00038             ServCfu             = 0x0180,
00039             ServCfb             = 0x0140,
00040             ServCfnry           = 0x0120,
00041             ServCfnrc           = 0x0110,
00042             ServCt              = 0x0108,
00043             ServBoac            = 0x0280,
00044             ServBoic            = 0x0240,
00045             ServBoicExHc        = 0x0220,
00046             ServBaic            = 0x0210,
00047             ServBicRoam         = 0x0208,
00048             ServMpty            = 0x0380,
00049             ServCug             = 0x0340,
00050             ServAoC             = 0x0320,
00051             ServPrefCug         = 0x0310,
00052             ServCugOA           = 0x0308,
00053             ServHold            = 0x0480,
00054             ServCw              = 0x0440,
00055             ServCcbs            = 0x0420,
00056             ServUserUserSig     = 0x0410,
00057             ServSmMt            = 0x0580,
00058             ServSmMo            = 0x0540,
00059             ServSmCb            = 0x0520,
00060             ServReplyPath       = 0x0510,
00061             ServDelConf         = 0x0508,
00062             ServProtId          = 0x0504,
00063             ServValPeriod       = 0x0502,
00064             ServAls             = 0x0680,
00065             ServClip            = 0x0880,
00066             ServCoLr            = 0x0820,
00067             ServCoLp            = 0x0810,
00068             ServMci             = 0x0808,
00069             ServCliSend         = 0x0802,
00070             ServCliBlock        = 0x0801,
00071             ServGprs            = 0x0980,
00072             ServHscsd           = 0x0940,
00073             ServVoiceGrpCall    = 0x0920,
00074             ServVoiceBcstServ   = 0x0910,
00075             ServMtplSubscrPfl   = 0x0908,
00076             ServMtplBand        = 0x0904,
00077             ServPlmnMode        = 0xc080,
00078             ServVps             = 0xc040,
00079             ServSmmoPaging      = 0xc020,
00080             ServSmmoEmail       = 0xc010,
00081             ServFax             = 0xc008,
00082             ServData            = 0xc004,
00083             ServLanguage        = 0xc001,
00084             ServInfoNumbers     = 0xd5ff,
00085         };
00086
00087         SimCphsHandler();
00088         virtual ~SimCphsHandler();
00089
00090         void Reset();
00091
00092         BOOLEAN GetCphsPhase(UINT8 &phase);
00093         BOOLEAN IsServiceAllocated(UINT idx, BOOLEAN & allocated);
00094         BOOLEAN IsServiceActivated(UINT idx, BOOLEAN & activated);
00095
00096         BOOLEAN GetOpName(WString &name);
00097
00098         BOOLEAN GetOpShortName(WString &name);
00099
00100         BOOLEAN IsVoiceMsgWaiting(VoiceMsgType type, BOOLEAN &waiting);
00101         BOOLEAN IsCallFwdUncondActive(VoiceMsgType type, BOOLEAN &active);
00102         BOOLEAN SetVoiceMsgWaiting(VoiceMsgType type, BOOLEAN waiting);
00103         BOOLEAN SetCallFwdUncondActive(VoiceMsgType type, BOOLEAN active);
00104
00105         BOOLEAN IsCphsServAccessible(LineSelector line, SimCphsHandler::CphsServGroupCode code, BOOLEAN &accessible);
00106         BOOLEAN SetCphsServAccessible(LineSelector line, SimCphsHandler::CphsServGroupCode code, BOOLEAN accessible);
00107         BOOLEAN RetrieveCspData();
00108
00109         BOOLEAN GetLineInUse(INT & line);
00110         BOOLEAN SetLineInUse(INT line);
00111         BOOLEAN GetLineLocked(BOOLEAN & locked);
00112         BOOLEAN SetLineLocked(BOOLEAN locked);
00113         void InitMruDynflags(const SimInfo & info);
00114
00115         BOOLEAN IsCphsPresent(BOOLEAN & present);
00116
00117         BOOLEAN GetOrangeWelcomeMsg(WString & welcomemsg);
00118
00119 // Cingular
00120         BOOLEAN RetrieveCingularTst();
00121         BOOLEAN IsCingularNetworkSelectionMenuControlSupportEnabled(BOOLEAN & enabled);
00122         BOOLEAN IsCspPlmnModeBitSet(BOOLEAN & isset);
00123
00124
00125 // Mark unread for Simtoolkit & other Async notifications
00126         void MarkOpNameUnread() { m_is_op_name_retr = FALSE; }
00127         void MarkOpSNameUnread() { m_is_op_sname_retr = FALSE; }
00128         void MarkCphsInfoUnread() { m_is_cphs_info_retr = FALSE; }
00129         void MarkCspUnread() { m_is_csp_init = FALSE; }
00130         void MarkVmwfUnread() { m_is_vmwf_init = FALSE; }
00131         void MarkCfufUnread() { m_is_cfuf_init = FALSE; }
00132         void MarkLineInUseUnread() { m_is_line_in_use_init = FALSE; }
00133         void MarkLineLockedUnread() { m_is_line_locked_init = FALSE; }
00134         void MarkWelcomeMsgUnread() { m_is_welcome_msg_init = FALSE; }
00135
00136     private:
00137         BOOLEAN RetrieveCphsInfo();
00138         BOOLEAN RetrieveOpShortName();
00139         UINT8 * GetCspBuffer(LineSelector line);
00140
00141         BOOLEAN m_is_op_name_retr;
00142         BOOLEAN m_is_op_sname_retr;
00143         BOOLEAN m_is_cphs_info_retr;
00144         BOOLEAN m_is_csp_init;
00145         BOOLEAN m_is_line_in_use_init;
00146         BOOLEAN m_is_line_locked_init;
00147         BOOLEAN m_is_welcome_msg_init;
00148         BOOLEAN m_is_vmwf_init;
00149         BOOLEAN m_is_cfuf_init;
00150         BOOLEAN m_is_tst_present;
00151
00152         WString m_op_name;
00153         WString m_op_sname;
00154         WString m_welcome_msg;
00155
00156         CphsCspArray m_cphs_csp;
00157         CphsCspArray m_cphs_csp2;
00158         CphsIstArray m_cphs_info;
00159         CphsVmwfArray m_vmwf_data;
00160         CphsCfufArray m_cfuf_data;
00161
00162         UINT8   m_line_in_use;
00163         UINT8   m_line_locked;
00164         UINT8   m_cingular_network_selection;
00165         UINT8   m_mru_dyn;
00166         UINT8   m_mru_dyn2;
00167 };
00168
00170 #endif
00171
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbBaseHandler.cpp File Reference

Adc/SimPbBaseHandler.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SimAccessor.hpp"
#include "SimPbEntry.hpp"
#include "SimPbEntryCont.hpp"
#include <Auxiliary/AlphaCoding.hpp>
#include <Asc/InputAnalyzer.hpp>
#include "SimPbBaseHandler.hpp"

Include dependency graph for SimPbBaseHandler.cpp:

Generated on Tue Jan 24 15:26:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbBaseHandler.hpp File Reference

Adc/SimPbBaseHandler.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Apc/SignalTypes.hpp>
#include <Adc/BaseDataHandler.hpp>
#include <Adc/SimPbEntryCont.hpp>

Include dependency graph for SimPbBaseHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimPbBaseHandler

Defines

#define | Adc_SimPbBaseHandler_hpp

Define Documentation

#define Adc_SimPbBaseHandler_hpp

Generated on Tue Jan 24 15:26:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbBaseHandler.hpp Source File

Adc/SimPbBaseHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_SimPbBaseHandler_hpp)
00010 #define Adc_SimPbBaseHandler_hpp
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Auxiliary/PhoneNumber.hpp>
00017
00018 #include <Apc/SignalTypes.hpp>
00019
00020 #include <Adc/BaseDataHandler.hpp>
00021 #include <Adc/SimPbEntryCont.hpp>
00022
00023
00024 class SimAccessor;
00025 class SimPbEntry;
00026 class Provider;
00027 class ProviderListener;
00028
00029 class SimPbBaseHandler : public BaseDataHandler
00030 {
00031     typedef BaseDataHandler Base;
00032
00033     public:
00034         SimPbBaseHandler();
00035         virtual ~SimPbBaseHandler();
00036         void Init(SimAccessor * handler,PhoneBookType pbtype, DataControlType dctype);
00037
00038         BOOLEAN Initialize();
00039         void Reset();
00040
00041         INT GetMaxCount();
00042         INT GetTagSize();
00043         PhoneBookType GetPhoneBookType() const { return m_pbtype; }
00044         DataControlType GetNotificationType() const { return m_dctype; }
00045
00046         BOOLEAN LoadAllEntries(Provider * parentprov, ProviderListener * listener = 0);
00047         BOOLEAN IsSimAccessAllowed() const;
00048         BOOLEAN RefreshData(INT recno);
00049         void Refresh();
00050
00051         BOOLEAN DeleteEntries(ProviderListener * listener = 0);
00052
00053         INT GetAlphaTagSize();
00054         INT GetProgress() const { return m_progress; }
00055         INT GetExistingCount();
00056
00057         INT GetNextFreePosition();
00058
00059         SimPbEntry * GetEntry(INT recno);
00060         BOOLEAN UpdateEntry(INT recno, const WString & name, const PhoneNumber & bcdnr,
00061                             UINT8 cmi_no, INT & newrow);
00062         BOOLEAN DeleteEntry(INT recno);
00063         BOOLEAN DeleteLndEntry(INT recno);
00064
00065         BOOLEAN LookupAlphaId(const PhoneNumber & phno, WString & alphaid);
00066         INT GetFreeExtRecords();
00067
00068     protected:
00069         INT GetMaxAdnCount() { return m_adn_maxrecs; }
00070         INT GetMaxFdnCount() { return m_fdn_maxrecs; }
00071         INT GetMaxLndCount() { return m_lnd_maxrecs; }
00072         INT GetMaxMsisdnCount() { return m_msisdn_maxrecs; }
00073         INT GetMaxCphsMBoxCount() { return m_cphs_mbox_maxrecs; }
00074         INT GetMaxCphsInfoNoCount() { return m_cphs_infono_maxrecs; }
00075         INT GetMaxSdnCount() { return m_sdn_maxrecs; }
00076         INT GetMaxBdnCount() { return m_bdn_maxrecs; }
00077         INT GetMaxMbdnCount() { return m_mbdn_maxrecs; }
00078
00079         INT GetAdnTagSize() { return m_adn_tagsize; }
00080         INT GetFdnTagSize() { return m_fdn_tagsize; }
00081         INT GetLndTagSize() { return m_lnd_tagsize; }
00082         INT GetMsisdnTagSize() { return m_msisdn_tagsize; }
00083         INT GetCphsMBoxTagSize() { return m_cphs_mbox_tagsize; }
00084         INT GetCphsInfoNoTagSize() { return m_cphs_infono_tagsize; }
00085         INT GetSdnTagSize() { return m_sdn_tagsize; }
00086         INT GetBdnTagSize() { return m_bdn_tagsize; }
00087         INT GetMbdnTagSize() { return m_mbdn_tagsize; }
00088
00089         static BOOLEAN  m_pbinfo_initialized;
00090         static UINT8 *  m_readwritebuffer;
00091         static INT      m_readwritebuffersize;
00092
00093         static INT      m_adn_tagsize;
00094         static INT      m_fdn_tagsize;
00095         static INT      m_lnd_tagsize;
00096         static INT      m_msisdn_tagsize;
00097         static INT      m_cphs_mbox_tagsize;
00098         static INT      m_cphs_infono_tagsize;
00099         static INT      m_sdn_tagsize;
00100         static INT      m_bdn_tagsize;
00101         static INT      m_mbdn_tagsize;
00102
00103         static INT      m_adn_maxrecs;
00104         static INT      m_fdn_maxrecs;
00105         static INT      m_lnd_maxrecs;
00106         static INT      m_msisdn_maxrecs;
00107         static INT      m_cphs_mbox_maxrecs;
00108         static INT      m_cphs_infono_maxrecs;
00109         static INT      m_sdn_maxrecs;
00110         static INT      m_bdn_maxrecs;
00111         static INT      m_mbdn_maxrecs;
00112
00113         static INT      m_prefered_alloc_wstring_size;
00114
00115         INT FillRWBuffer(const WString & name, INT txtlen, const PhoneNumber & bcdnr);
00116         void EmptyRWBuffer() {
00117             if(m_readwritebuffer!=0 && m_readwritebuffersize>0) {
00118                 memset(m_readwritebuffer,0xff,m_readwritebuffersize);
00119             }
00120         }
00121
00122         SimUpdateStatus LoadContainerEntry(INT recno);
00123
00124     protected:
00125         SimPbEntryCont * GetEntryContainer() { return m_container; }
00126         void SetEntryContainer(SimPbEntryCont * cont) { m_container = cont; }
00127
00128     private:
00129         INT                 m_progress;
00130         INT                 m_lastprogress;
00131         SimPbEntryCont *    m_container;
00132         DataControlType     m_dctype;
00133         PhoneBookType       m_pbtype;
00134
00135 };
00136
00138 #endif
00139
00140
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbEntry.cpp File Reference

Adc/SimPbEntry.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SimPbEntry.hpp"

Include dependency graph for SimPbEntry.cpp:

Generated on Tue Jan 24 15:26:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbEntry.hpp File Reference

Adc/SimPbEntry.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>

Include dependency graph for SimPbEntry.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimPbEntry

Defines

#define | Adc_SimPbEntry_hpp

Variables

const SimPbEntry *const | c_unread_entry = (SimPbEntry *)-1

Define Documentation

#define Adc_SimPbEntry_hpp

Generated on Tue Jan 24 15:26:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbEntry.hpp Source File

Adc/SimPbEntry.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_SimPbEntry_hpp)
00010 #define Adc_SimPbEntry_hpp
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Auxiliary/PhoneNumber.hpp>
00017
00018 class SimPbEntry
00019 {
00020     public:
00021         SimPbEntry();
00022         SimPbEntry(const SimPbEntry & entry);
00023
00024         ~SimPbEntry(); // destructor not virtual !!!
00025
00026         INT                 GetRecNo() const { return m_recno; }
00027         const WString &     GetName() const { return m_name; }
00028         const PhoneNumber & GetPhoneNumber() const { return m_phonenumber; }
00029         UINT8               GetCphsStatus() const { return m_cphsstatus; }
00030         UINT8               GetCmiRecordNo() const { return m_cmi_no; }
00031
00032         BOOLEAN             HasData() const;
00033         INT                 GetCphsIndexLevelIndicator() const { return (INT)(m_cphsstatus & 0x0F); }
00034         BOOLEAN             HasCphsPremiumServiceIndicator() const { return (INT)(m_cphsstatus & 0x10) > 0; }
00035         BOOLEAN             HasCphsNetworkSpecificIndicator() const { return (INT)(m_cphsstatus & 0x20) > 0; }
00036
00037         void SetData(INT recno, const PhoneNumber & phno, const WString & name, UINT8 cphsstatus, UINT8 cmi_no);
00038         void ClearData();
00039         void ResetData();
00040
00041         SimPbEntry & operator = (const SimPbEntry & szCopy);
00042
00043     private:
00044         INT         m_recno;
00045         WString     m_name;
00046         PhoneNumber m_phonenumber;
00047         UINT8       m_cphsstatus;   // only used for CPHS_INFNUM entries
00048         UINT8       m_cmi_no;       // only used for BDN entries
00049 };
00050
00051 const SimPbEntry * const c_unread_entry = (SimPbEntry *)-1;
00052
00053
00055 #endif
00056
00057
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbEntryCont.cpp File Reference

Adc/SimPbEntryCont.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SimPbEntry.hpp"
#include "SimPbEntryCont.hpp"

Include dependency graph for SimPbEntryCont.cpp:

Generated on Tue Jan 24 15:26:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbEntryCont.hpp File Reference

Adc/SimPbEntryCont.hpp File Reference

#include <Auxiliary/FixedPtrArray.hpp>
#include <Auxiliary/IndexTable.hpp>
#include <Auxiliary/DynamicBitVector.hpp>
#include <Adc/SimPbEntry.hpp>

Include dependency graph for SimPbEntryCont.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimPbEntryCont

Defines

#define | Adc_SimPbEntryCont_hpp

Variables

const INT | c_invalid_position = -2

Define Documentation

#define Adc_SimPbEntryCont_hpp

Generated on Tue Jan 24 15:26:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPbEntryCont.hpp Source File

Adc/SimPbEntryCont.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_SimPbEntryCont_hpp)
00010 #define Adc_SimPbEntryCont_hpp
00014
00015 #include <Auxiliary/FixedPtrArray.hpp>
00016 #include <Auxiliary/IndexTable.hpp>
00017 #include <Auxiliary/DynamicBitVector.hpp>
00018
00019 #include <Adc/SimPbEntry.hpp>
00020
00021
00022 const INT c_invalid_position = -2;
00023
00024 class SimPbEntryCont
00025 {
00026     private:
00027         enum {
00028             BITS_PER_UINT = sizeof(UINT) * 8,
00029         };
00030
00031     public:
00032         SimPbEntryCont(INT nr_entries, BOOLEAN sorted = FALSE);
00033         ~SimPbEntryCont();
00034
00035         void SetReady(BOOLEAN ready = TRUE) { m_ready = ready; }
00036         BOOLEAN IsReady() const { return m_ready; }
00037
00038         INT GetMaxEntries() const { return m_max_entries; }
00039         INT GetTextLength() const { return m_text_length; }
00040         void SetTextLength(INT length) { m_text_length = length; }
00041
00042         void Reset() { DeleteAllData(); }
00043
00044         INT  PutData(INT recno, const PhoneNumber & phno, const WString & wstr,
00045                      UINT8 cphsstatus, UINT8 cmi_no);
00046         void DeleteData(INT recno);
00047         void DeleteAllData();
00048         void DeleteAllObjects();
00049
00050         SimPbEntry * GetEntry(INT idx) const;
00051
00052         INT          GetFirstFreeSimPosition();
00053         INT          GetExistingCount() { return m_effcount; }
00054
00055     private:
00056         BOOLEAN                    m_sorted;
00057         BOOLEAN                    m_ready;
00058         FixedPtrArray<SimPbEntry>  m_entries;
00059         INT                        m_max_entries;
00060         INT                        m_text_length;
00061         INT                        m_effcount;
00062         DynamicBitVector *         m_used_entries;
00063
00064
00065         void InsertData(INT recno, INT simpos, const PhoneNumber & phno, const WString & wstr,
00066                         UINT8 cphsstatus, UINT8 cmi_no);
00067         INT  FindInsertPosition(const WString & wstr);
00068
00069 };
00070
00072 #endif
00073
00074
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPduHandler.cpp File Reference

Adc/SimPduHandler.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SimPduHandler.hpp"
#include <Kernel/System.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Auxiliary/FixedPtrArray.hpp>
#include <Apc/UserData.hpp>

Include dependency graph for SimPduHandler.cpp:

Functions

BOOLEAN | IsValidCriteria (UINT8 criteria)

Variables

const BOOLEAN | c_csms_pid_check_enabled = FALSE
const BOOLEAN | c_default_csms_state_changeable = TRUE
const UINT16 | c_default_tpdu_cache_size = 10
const UINT16 | c_empty_internal_refno = 0xFFFF
const INT16 | c_empty_reload_entry = -1
const INT | c_smsr_no_link = -2

Function Documentation

BOOLEAN IsValidCriteria ( UINT8 criteria ) [inline]

Variable Documentation

const BOOLEAN c_csms_pid_check_enabled = FALSE

const BOOLEAN c_default_csms_state_changeable = TRUE

const UINT16 c_default_tpdu_cache_size = 10

const UINT16 c_empty_internal_refno = 0xFFFF

const INT16 c_empty_reload_entry = -1

const INT c_smsr_no_link = -2

Generated on Tue Jan 24 15:26:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPduHandler.hpp File Reference

Adc/SimPduHandler.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Auxiliary/FixedPtrArray.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include <Auxiliary/BlobObject.hpp>
#include <Auxiliary/IndexTable.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/MessageTypeIndicator.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <Apc/ShortMessageStatus.hpp>
#include <Adc/BaseDataHandler.hpp>
#include <Apc/MdhSmsStackMsgArgs.hpp>

Include dependency graph for SimPduHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimPduHandler
struct | SimPduHandler::SmsrCache
struct | SimPduHandler::TpduCount
class | SmsWStringCache
class | SmsWStringCache::Entry
class | TpduCache
struct | TpduHeaderInformation
struct | TpduPhoneNumberPersist

Defines

#define | Adc_SimPduHandler_hpp

Enumerations

enum | ConcatenetedStatus { NormalSms = 0, ConcatenetedSms = 1, PartlyConcatenetedSms = 2, InvalidSms = 3 }
enum | SmsDeleteStatus { SmsDeleteRead = 0x01, SmsDeleteUnread = 0x02, SmsDeleteSent = 0x04, SmsDeleteUnsent = 0x08 }
enum SmsFilterType {
AllSmsFilterType = 0, UnreadSmsFilterType = 1, ReadSmsFilterType = 2, UnsentSmsFilterType = 3,
SentSmsFilterType = 4
}
enum TpduCountType {
SimTpdus = 0, NvramTpdus = 1, SmsReportTpdus = 2, OverallTpdus = 3,
NoOfCountTypes = 4
}

Variables

const UINT8 | c_default_max_pdu_per_sms = 255
const UINT16 | c_max_nvram_pdus = DR_MAX_NVRAM_SMS
const UINT16 | c_max_pdus = c_max_sim_pdus + c_max_nvram_pdus + c_max_smsr_pdus
const INT16 | c_max_reloadable_pdus = 30
const UINT16 | c_max_sim_pdus = DR_MAX_SUPPORTED_SIM_SMS
const UINT16 | c_max_smsr_in_ram = 5
const UINT16 | c_max_smsr_length = 40
const UINT16 | c_max_smsr_pdus = 20
const UINT16 | c_max_table1 = c_max_pdus/2
const UINT16 | c_max_table2 = c_max_pdus - c_max_table1

Define Documentation

#define Adc_SimPduHandler_hpp

Generated on Tue Jan 24 15:26:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimPduHandler.hpp Source File

Adc/SimPduHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_SimPduHandler_hpp)
00010 #define Adc_SimPduHandler_hpp
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Auxiliary/PhoneNumber.hpp>
00017 #include <Auxiliary/DateTime.hpp>
00018 #include <Auxiliary/FixedPtrArray.hpp>
00019 #include <Auxiliary/ProviderListener.hpp>
00020 #include <Auxiliary/BlobObject.hpp>
00021 #include <Auxiliary/IndexTable.hpp>
00022
00023 #include <Apc/SignalTypes.hpp>
00024 #include <Apc/MessageTypeIndicator.hpp>
00025 #include <Apc/DataCodingScheme.hpp>
00026 #include <Apc/ShortMessageStatus.hpp>
00027 #include <Adc/BaseDataHandler.hpp>
00028 #include <Apc/MdhSmsStackMsgArgs.hpp>
00029
00030 /*  ========================================================================
00031     SmsFilterType
00032     ======================================================================== */
00034 enum SmsFilterType {
00036     AllSmsFilterType          = 0,
00038 #if defined (APOXI_SMS_NEW_PROVIDERS)
00039     InboxSmsFilterType        = 1,
00041     OutboxSmsFilterType       = 2,
00043     ArchiveSmsFilterType      = 3,
00045     StatusReportSmsFilterType = 4,
00047     UnreadSmsFilterType       = 5,
00049 #else
00050     UnreadSmsFilterType       = 1,
00052     ReadSmsFilterType         = 2,
00054     UnsentSmsFilterType       = 3,
00056     SentSmsFilterType         = 4
00057 #endif
00058 };
00059
00060 /*  ========================================================================
00061     SmsDeleteStatus
00062     ======================================================================== */
00064 enum SmsDeleteStatus {
00066     SmsDeleteRead =     0x01,           // 0000 0001
00068     SmsDeleteUnread =   0x02,           // 0000 0010
00070     SmsDeleteSent =     0x04,           // 0000 0100
00072     SmsDeleteUnsent =   0x08            // 0000 1000
00073 };
00074
00075 /*  ========================================================================
00076     SmsWStringCache
00077     ======================================================================== */
00078
00079 class SmsWStringCache
00080 {
00081     public:
00082         enum {
00083             c_invalid_rec_no = 0x2000
00084         };
00085
00086     class Entry
00087     {
00088         public:
00089             Entry(INT size) { m_recno=c_invalid_rec_no; m_text.PreAlloc(size+1); }
00090
00091             UINT16              GetRecNo() const { return m_recno; }
00092             const WString &     GetText() const { return m_text; }
00093             void SetData(UINT16 recno, const WString & text) { m_recno=recno; m_text = text; }
00094
00095         private:
00096             UINT16      m_recno;
00097             WString     m_text;
00098     };
00099
00100     typedef FixedPtrArray<Entry> CacheArray;
00101
00102     public:
00103         SmsWStringCache();
00104         ~SmsWStringCache();
00105
00106         void Init(INT noofentries, INT noofchars);
00107         UINT16 Put(const WString & string, UINT16 newrecno, UINT16 & cacheidx);
00108
00109         const WString & GetWString(INT index) const {
00110             ASSERT_DEBUG(m_cachearray[index]!=0);
00111             return m_cachearray[index]->GetText();
00112         };
00113         UINT16 GetRecNo(INT index) const {
00114             ASSERT_DEBUG(m_cachearray[index]!=0);
00115             return m_cachearray[index]->GetRecNo();
00116         };
00117         void SetData(INT index, UINT16 recno, const WString & text) {
00118             ASSERT_DEBUG(m_cachearray[index]!=0);
00119             m_cachearray[index]->SetData(recno, text);
00120         };
00121
00122
00123     private:
00124         INT                m_noofentries;
00125         INT                m_noofchars;
00126         CacheArray         m_cachearray;
00127         INT                m_iterator;
00128 };
00129
00130 /*  ========================================================================
00131     ConcatenetedStatus
00132     ======================================================================== */
00134 enum ConcatenetedStatus {
00136     NormalSms = 0,
00138     ConcatenetedSms = 1,
00140     PartlyConcatenetedSms = 2,
00142     InvalidSms = 3
00143 };
00144
00145 /*  ========================================================================
00146     TpduCountType
00147     ======================================================================== */
00149 enum TpduCountType {
00151     SimTpdus = 0,
00153     NvramTpdus = 1,
00155     SmsReportTpdus = 2,
00157     OverallTpdus = 3,
00159     NoOfCountTypes = 4
00160 };
00161
00162 class SimPduHandler;
00163
00164 /*  ========================================================================
00165     TpduHeaderInformation
00166     ======================================================================== */
00168 struct TpduPhoneNumberPersist
00169 {
00170     UINT8 m_data[12];
00171
00172     void Clear() {
00173         memset(m_data,0xFF,sizeof(m_data));
00174         m_data[0] = 0;
00175     }
00176     BOOLEAN IsEqual(const TpduPhoneNumberPersist & persist) const {
00177         return memcmp(m_data, persist.m_data, sizeof(m_data))==0;
00178     }
00179     void Set(const PhoneNumber & phno) {
00180         Clear();
00181         memcpy(m_data,phno.GetRawBCDBuffer(),phno.GetRawBCDLength());
00182     }
00183 };
00184
00185 /*  ========================================================================
00186     TpduHeaderInformation
00187     ======================================================================== */
00189 struct TpduHeaderInformation
00190 {
00191         void Init();
00192         void Clear();
00193
00194         void SetTpduInformation(Tpdu & tpdu, Sms::StorageType storagetype, MdhTimeStamp timestamp, MdhExtendedData ext_data);
00195
00196         BOOLEAN                         IsValid() const;
00197         Tpdu::Status                    GetStatus() const { return (Tpdu::Status)m_status; }
00198         void                            SetStatus(Tpdu::Status status) { m_status = status; }
00199         MessageTypeIndicator::Type      GetMessageType() const { return (MessageTypeIndicator::Type)m_bitfield.m_msg_type; }
00200         DataCodingScheme::MessageClass  GetMessageClass() const { return (DataCodingScheme::MessageClass)m_bitfield.m_msg_class; }
00201         DataCodingScheme::GroupId       GetGroupId() const { return (DataCodingScheme::GroupId)m_bitfield.m_coding_group; }
00202         ShortMessageStatus              GetShortMessageStatus() const {  return m_msg_status; }
00203         DataCodingScheme                GetDcs() const { return m_dcs; }
00204         ProtocolIdentifier              GetPid() const { return m_protid; }
00205         const DateTime::Persist &       GetDateTime() const { return m_datetime; }
00206         void                            SetDateTime(const DateTime::Persist & datetime) { m_datetime = datetime; }
00207         BOOLEAN                         IsDateTimeValid() const { return ! m_datetime.IsZero(); }
00208         BOOLEAN                         ReplyPathExists() const { return m_bitfield.m_reply_path_exists; }
00209         const TpduPhoneNumberPersist &  GetPhoneNumber() const { return m_phnr; }
00210 //      BOOLEAN                         IsPhoneNumberValid() const { return ! GetPhoneNumber().IsInvalid(); }
00211         BOOLEAN                         IsConcateneted() const { return m_bitfield.m_is_concateneted; }
00212         UINT16                          GetConcRefNo() const { return m_conc_ref_no; }
00213         UINT8                           GetConcMaxNo() const { return m_conc_max_no; }
00214         UINT8                           GetConcSeqNo() const { return m_conc_seq_no; }
00215
00216         SmsPortNo                       GetSmsPortNo() const { return m_sms_port_no; }
00217         UINT8                           GetPayloadSize() const { return m_payload_size; }
00218
00219         UINT32                          GetExtendedData() const { return m_extended_data; }
00220
00221         UINT16                          GetInternalRecNo() const { return m_int_ref_no; }
00222         void                            SetInternalRecNo(UINT16 ref_no) { m_int_ref_no = ref_no; }
00223         ConcatenetedStatus              GetConcatenetedStatus() const { return (ConcatenetedStatus)m_bitfield.m_concateneted_status; }
00224         void                            SetConcatenetedStatus(ConcatenetedStatus status) { m_bitfield.m_concateneted_status = status; }
00225
00226         const SmsReferenceNumber&       GetReferenceNumber() const { return (m_refno); }
00227         Sms::StorageType                GetSmsStorageType() const { return (Sms::StorageType)m_storagetype; }
00228         void                            SetSmsStorageType(Sms::StorageType type) { m_storagetype = type; }
00229
00230         static UINT16                   GetMaxConcRefNo() { return m_max_conc_ref_no; }
00231         UINT8                           GetConcatenetedTpduNum() const { return m_conc_num; }
00232         void                            SetConcatenetedTpduNum(UINT8 conc_num) { m_conc_num = conc_num; }
00233         UINT8                           GetSimStoredTpduNum() const { return m_sim_stored; }
00234         UINT8                           GetFlashStoredTpduNum() const { return m_flash_stored; }
00235         void                            SetSimFlashStoredTpduNum(UINT8 sim_num, UINT8 flash_num) {
00236                                             m_sim_stored = sim_num;
00237                                             m_flash_stored = flash_num;
00238                                         }
00239 #if defined(APOXI_ENABLE_CONC_SMS_SCA_CHECK)
00240         UINT32                          GetScaHash() const { return m_sca_hash; }
00241 #endif
00242         UINT16                          GetWStringCashPos() const { return m_cache_pos; }
00243         void                            SetWStringCashPos(UINT16 pos) { m_cache_pos = pos; }
00244
00245         BOOLEAN                         HasWrongStatus() const { return m_wrong_status; }
00246         void                            SetWrongStatus(BOOLEAN status) { m_wrong_status = status;}
00247
00248
00249 //  private:
00250         TpduPhoneNumberPersist          m_phnr;             // 12 byte
00251         DateTime::Persist               m_datetime;         // 4  byte
00252 #if defined(APOXI_ENABLE_CONC_SMS_SCA_CHECK)
00253         UINT32                          m_sca_hash;         // 4  byte
00254 #endif
00255         DataCodingScheme                m_dcs;              // 2  byte
00256         SmsPortNo                       m_sms_port_no;      // 2  byte
00257         UINT16                          m_conc_ref_no;      // 2  byte
00258         UINT16                          m_int_ref_no;       // 2  byte
00259         struct {
00260             UINT                        m_reply_path_exists   : 1;
00261             UINT                        m_is_concateneted     : 1;
00262             UINT                        m_concateneted_status : 2;
00263             UINT                        m_msg_type            : 4;
00264             UINT                        m_msg_class           : 4;
00265             UINT                        m_coding_group        : 4;
00266         } m_bitfield;                                       // 2  byte
00267         UINT8                           m_conc_max_no;      // 1  byte
00268         UINT8                           m_conc_seq_no;      // 1  byte
00269         UINT8                           m_storagetype;      // 1  byte
00270         SmsReferenceNumber              m_refno;            // 1  byte
00271         ShortMessageStatus              m_msg_status;       // 1  byte
00272         UINT8                           m_payload_size;     // 1  byte
00273         ProtocolIdentifier              m_protid;           // 1  byte
00274         UINT8                           m_conc_num;         // 1  byte
00275         UINT8                           m_status;           // 1  byte
00276         UINT8                           m_sim_stored;       // 1  byte
00277         UINT8                           m_flash_stored;     // 1  byte
00278         UINT16                          m_cache_pos;        // 2  bytes
00279                                                             // Sum = 43 bytes + 1 = 44 bytes
00280         BOOLEAN                         m_wrong_status;     // 1  byte
00281                                                             // Sum = 42 bytes
00282         static UINT16                   m_max_conc_ref_no;
00283         UINT32                          m_extended_data;    // 4 additional bytes
00284 };
00285
00286
00287 /*  ========================================================================
00288     TpduCache
00289     ======================================================================== */
00291 class TpduCache
00292 {
00293     typedef FixedPtrArray<Tpdu> TpduCacheArray;
00294
00295     public:
00296         TpduCache(UINT16 maxcache, SimPduHandler * handler);
00297         ~TpduCache();
00298
00299         Tpdu *   GetTpdu(UINT16 tpduno, MdhViewHdl viewhdl, MdhTimeStamp & timestamp, MdhExtendedData & ext_data);
00300         BOOLEAN  MarkAsInvalid(UINT16 tpduno);
00301         void     Clear();
00302         void     Resize(UINT16 maxcache);
00303         void     SetStatus(UINT16 tpduno, Tpdu::Status status);
00304     #if defined(APOXI_ENABLE_SMS_EXTENDED_DATA)
00305         BOOLEAN  UpdateExtendedData(UINT16 tpduno, MdhExtendedData ext_data);
00306     #endif
00307
00308
00309     private:
00310         UINT16             m_counter;
00311         UINT16             m_maxcache;
00312         TpduCacheArray     m_cached_tdpus;
00313         IndexTable<UINT16> m_cached_tdpu_nos;
00314         IndexTable<UINT32> m_cached_timestamps;
00315     #if defined(APOXI_ENABLE_SMS_EXTENDED_DATA)
00316         IndexTable<UINT32> m_cached_extended_data;
00317     #endif
00318
00319         SimPduHandler *    m_handler;
00320 };
00321
00322 const UINT16 c_max_smsr_in_ram = 5;
00323 const UINT16 c_max_smsr_pdus = 20;
00324 const UINT16 c_max_sim_pdus = DR_MAX_SUPPORTED_SIM_SMS;
00325 const UINT16 c_max_nvram_pdus = DR_MAX_NVRAM_SMS;
00326 const UINT16 c_max_pdus = c_max_sim_pdus + c_max_nvram_pdus + c_max_smsr_pdus;
00327 const UINT16 c_max_table1 = c_max_pdus/2;
00328 const UINT16 c_max_table2 = c_max_pdus - c_max_table1;
00329 const INT16  c_max_reloadable_pdus = 30;
00330 const UINT8  c_default_max_pdu_per_sms = 255;
00331 const UINT16 c_max_smsr_length = 40;
00332
00333 /*  ========================================================================
00334     SimPduHandler
00335     ======================================================================== */
00336
00337
00338 class SimPduHandler : public BaseDataHandler
00339 {
00340     struct TpduCount {
00341         UINT16 m_sum;
00342         UINT16 m_free;
00343 #if defined (APOXI_SMS_NEW_PROVIDERS)
00344         UINT16 m_read;
00345         UINT16 m_unread;
00346         UINT16 m_sent;
00347         UINT16 m_unsent;
00348 #endif
00349     };
00350
00351     struct SmsrCache {
00352         Tpdu::Status   m_status;
00353         INT            m_link;
00354         UINT8          m_data[c_max_smsr_length];
00355     };
00356
00357     typedef BaseDataHandler Base;
00358
00359     typedef FixedPtrArray<TpduHeaderInformation> TpduHeaderInformationArray;
00360
00361     friend class CompoundSmsItem;
00362     friend class CompoundTpduItem;
00363     friend class TpduCache;
00364
00365     public:
00366         SimPduHandler();
00367         virtual ~SimPduHandler();
00368
00369         void Reset();
00370         void Refresh();
00371
00372         void Init(SimAccessor * handler);
00373
00374         BOOLEAN ChangePreferredStorageMedia(Sms::StorageType storagetype);
00375         Sms::StorageType GetPreferredStorageMedia() const;
00376
00377         INT GetProgress() const { return m_progress; }
00378
00379         BOOLEAN    Update(ProviderListener * listener);
00380
00381         void       ReloadNewMsgTpdu(Tpdu &tpdu, INT tpduno);
00382         void       ReloadTpdu(INT tpduno);
00383         BOOLEAN    StoreTpdu(const Tpdu &tpdu, INT tpduno = 0);
00384         BOOLEAN    StoreTpdu(const Tpdu &tpdu, const Sms::StorageType storage_type);
00385         BOOLEAN    StoreTpdu(const Tpdu &tpdu, const Sms::StorageType storage_type, INT & dst_tpduno);
00386         BOOLEAN    RefreshData(INT tpduno, MdhTimeStamp timestamp);
00387         BOOLEAN    RefreshStatusData(INT tpduno, Tpdu::Status newstatus);
00388         INT    GetMaxCount() const { return (INT)m_max_count; }
00389
00390 #if defined(APOXI_SMS_NEW_PROVIDERS)
00391         INT GetInboxCount() const { return (INT)m_inbox_count; }
00392         INT GetOutboxCount() const { return (INT)m_outbox_count; }
00393         INT GetArchiveCount() const { return (INT)m_archive_count; }
00394         INT GetStatusReportCount() const { return (INT)m_statusreport_count; }
00395         INT GetUnreadCount() const { return (INT)m_unread_count; }
00396
00397         INT GetProviderCount(SmsFilterType filter){ return GetRecnoTableSize(filter); }
00398
00399         INT  GetOccupiedTpduCount(TpduCountType type) const;
00400         INT  GetEmptyTpduCount(TpduCountType type) const;
00401         INT  GetMaxTpduCount(TpduCountType type) const;
00402
00403         INT  GetReadTpduCount(TpduCountType type) const;
00404         INT  GetUnreadTpduCount(TpduCountType type) const;
00405         INT  GetSentTpduCount(TpduCountType type) const;
00406         INT  GetUnsentTpduCount(TpduCountType type) const;
00407
00408     #if defined(_DEBUG)
00409         UINT32 GetSortDuration(SmsFilterType filter);
00410         UINT32 GetIndexDuration();
00411         INT    GetIterationDepth(SmsFilterType filter);
00412     #endif
00413 #else
00414         INT    GetReadCount() const { return (INT)m_read_count; }
00415         INT    GetUnreadCount() const { return (INT)m_unread_count; }
00416         INT    GetSentCount() const { return (INT)m_sent_count; }
00417         INT    GetUnsentCount() const { return (INT)m_unsent_count; }
00418 #endif
00419         const TpduCount & GetTpduCount(TpduCountType type) {
00420             ASSERT_DEBUG((INT)type >= (INT)SimTpdus && (INT)type < (INT)NoOfCountTypes);
00421             return m_count_table[type];
00422         }
00423
00424         INT                    GetSmsTpduPosition(INT recno, SmsFilterType filter_type);
00425         Tpdu *                 GetSmsTpdu(INT recno, SmsFilterType filter_type);
00426         TpduHeaderInformation * GetSmsInformation(INT recno, SmsFilterType filter_type);
00427         BOOLEAN                GetSmsWString(INT recno, SmsFilterType filter_type, WString & wstr);
00428         BOOLEAN                GetHeaderText(INT recno, SmsFilterType filter_type, WString & wstr);
00429
00430         BOOLEAN                SetSmsStatus(INT recno, SmsFilterType filter_type, Tpdu::Status newstatus);
00431         BOOLEAN                DeleteAllSms(SmsFilterType filter_type);
00432         BOOLEAN                DeleteAllSms(SmsDeleteStatus criteriamask, BOOLEAN smsreports);
00433         BOOLEAN                GetSmsDebugWString(INT recno, SmsFilterType filter_type, WString & wstr);
00434
00435         BOOLEAN                IsSmsFilterTypeMatch(SmsFilterType filter, INT recno);
00436
00437         static void SetEmptyNumberText(const WCHAR * text) { m_missing_part_text = text; }
00438         static UINT8 GetConcSmsPduMaxNo() { return m_max_conc_pdu_no; }
00439         static void SetConcSmsPduMaxNo(UINT8 no) { ASSERT_DEBUG(no>0); m_max_conc_pdu_no = no; }
00440         static BOOLEAN IsPartlyConcSmsStateChangeable() { return m_csms_state_changeable; }
00441         static void SetPartlyConcSmsStateChangeable(BOOLEAN changeable) { m_csms_state_changeable = changeable; }
00442         static void SetMaxNoOfPduCache(UINT16 pdu_no_cache) { ASSERT_DEBUG(pdu_no_cache>0); m_pdu_no_cache = pdu_no_cache; }
00443         static void SetSmsHeaderCacheParams(INT noofentries, INT noofchars) {
00444             m_no_cache_header = noofentries;
00445             m_no_cache_chars = noofchars;
00446         }
00447         static void EnablePidCheckForConcSms(BOOLEAN pidcheck) { m_csms_pid_check_enabled = pidcheck; }
00448
00449         BOOLEAN         IsSubSystemInitialized() const { return m_init_sub_system; }
00450
00451         BOOLEAN         InitSmsTransmit(INT simno, INT nvramno);
00452         BOOLEAN         StoreSmsTransmit(Tpdu & tpdu, INT tpduno, MdhWorkMedia workmedia, MdhTimeStamp timestamp, MdhExtendedData ext_data);
00453         BOOLEAN         UpdateTransmit(ProviderListener * listener);
00454
00455         void            OnMdhSmsDeletion(const MdhSmsDeletionIndArg & arg);
00456
00457         void            OnNewStatusReportArrived(const MdhNewStatusReportIndArg & arg);
00458         BOOLEAN         IsReloadInProgress() const { return m_reloadinprogress; }
00459
00460         BOOLEAN         GetNextFreeTpduNo(const Sms::StorageType storage_type, INT & tpduno);
00461         BOOLEAN         IsSpaceLeftOnStorageMedia(const Sms::StorageType storage_type, INT required_tpdus = 1);
00462         BOOLEAN         IsSpaceLeftOnStorageMedia(TpduCountType type, INT required_tpdus = 1);
00463         TpduCountType   GetTpduCountType(const Sms::StorageType storage_type);
00464
00465         Sms::StorageType GetStorageMediaPrimitive(const Sms::StorageType storage_type);
00466
00467         BOOLEAN         CopyTo(INT tpduno, const Sms::StorageType storage_type, ProtocolIdentifier pid, INT & dst_tpduno);
00468         BOOLEAN         CopyTo(INT tpduno, const Sms::StorageType storage_type, INT & dst_tpduno);
00469
00470         INT             FindRowByTpduNumber(INT tpduno, SmsFilterType filter);
00471
00472         BOOLEAN         SetSmsExtendedData(INT recno, const MdhExtendedData & ext_data);
00473
00474     private:
00475         TpduHeaderInformation * GetTpduHeaderInformationPtr(INT idx) {
00476             ASSERT_DEBUG(idx<c_max_pdus);
00477             if(idx<c_max_table1) {
00478                 return &m_header_entries1[idx];
00479             } else {
00480                 return &m_header_entries2[idx-c_max_table1];
00481             }
00482         }
00483
00484         BOOLEAN         ReloadMarkedPdus(BOOLEAN allowbuildindextable = TRUE);
00485         BOOLEAN         InitStorageSubSystem();
00486
00487         INT             GetTpduNo(INT recno, SmsFilterType filter_type);
00488         INT             GetConcatenedTpduNo(UINT16 intrecno, UINT8 conc_seq_no);
00489
00490         BOOLEAN         LoadAllTpduHeaderInformation(ProviderListener * listener);
00491         BOOLEAN         CreateTpduHeaderInformationObjects();
00492         void            DeleteTpduHeaderInformationObjects();
00493         BOOLEAN         LoadTpduHeaderInformation(INT tpduno);
00494         BOOLEAN         UpdateTpduStatus(INT tpduno, Tpdu::Status recordstatus);
00495         BOOLEAN         GetTpduWString(INT tpduno, WString & wstr);
00496         void            UpdateInternalInformation();
00497         void            UpdateInternalInformation(INT tpduno);
00498         void            MakeIndextables();
00499
00500         void            ClearSmsrData();
00501         INT             PutSmsrData(INT link, const UINT8 * data, INT length, BOOLEAN withsca);
00502         BOOLEAN         GetSmsrTpdu(INT pos, Tpdu & tpdu);
00503         INT             GetSmsrTpduPos(INT link);
00504         void            DeleteSmsrTpdu(INT link);
00505         BOOLEAN         LoadPossibleSmsrTpdu();
00506
00507         Tpdu *          GetTpduPrimitive(INT recno, MdhTimeStamp & timestamp, MdhExtendedData & ext_data);
00508         Tpdu *          GetTpduPrimitive(INT recno);
00509
00510         Sms::StorageType GetTpduStorageMediaTypePrimitive(INT recno);
00511
00512         BOOLEAN         UpdateTpduStatusPrimitive(INT recno, UINT8 status, BOOLEAN readwrite);
00513         BOOLEAN         StoreTpduPrimitive(INT recno, const Tpdu & tpdu, INT & position);
00514
00515         BOOLEAN         GetSimPduCount(INT &pdu_count);
00516         BOOLEAN         GetNvRamPduCount(INT &pdu_count);
00517         BOOLEAN         GetSmsrPduCount(INT &pdu_count);
00518
00519         void            ClearCsmsRecCache(INT no);
00520         void            PutStringIntoCache(TpduHeaderInformation * headerinfo, Tpdu & tpdu, INT tpduno);
00521
00522         BOOLEAN         GetStorageMediaInformation(const Sms::StorageType storage_type, Sms::StorageType & basic_type, INT required_tpdus = 1);
00523         BOOLEAN         CopyTpdu(const Tpdu &tpdu, Sms::StorageType storage_type, ProtocolIdentifier pid, BOOLEAN pid_valid, INT & dst_tpduno);
00524         BOOLEAN         CopyTo(INT tpduno, const Sms::StorageType storage_type, ProtocolIdentifier pid, BOOLEAN pid_valid, INT & dst_tpduno);
00525
00526
00527 #if defined(APOXI_SMS_NEW_PROVIDERS)
00528
00529         void ResetTpduCountType(TpduCountType type);
00530
00531     #if defined(_DEBUG)
00532         void InitDebugMemberVariables();
00533         void SetSortDuration(UINT32 time, SmsFilterType filter);
00534         void SetIterationDepth(SmsFilterType filter);
00535     #endif
00536
00537         DateTime::Persist GetDateTime(INT recno, SmsFilterType filter) {
00538             INT tpduno = GetTpduNo(recno, filter);
00539
00540             if(tpduno < 0) {
00541                 DateTime::Persist dt_zero = {0};
00542                 return dt_zero;
00543             }
00544             TpduHeaderInformation * headerinfo = GetTpduHeaderInformationPtr(tpduno);
00545             ASSERT_DEBUG(headerinfo != 0);
00546
00547             return headerinfo->GetDateTime();
00548         }
00549
00550         INT  Partition(UINT16 a[], INT first, INT last, SmsFilterType filter);
00551         void QuickSort(SmsFilterType filter);
00552         void QuickSort(UINT16 a[], INT first, INT last, SmsFilterType filter);
00553         void Swap(UINT16 & a, UINT16 & b);
00554
00555         UINT16 * GetRecnoTable(SmsFilterType filter);
00556         INT      GetRecnoTableSize(SmsFilterType filter);
00557 #endif
00558
00559         MdhViewHdl m_viewhdl;
00560         UINT16     m_nvram_offset;
00561
00562         INT     m_progress;
00563         BOOLEAN m_synchronized;
00564         BOOLEAN m_init_sub_system;
00565         BOOLEAN m_reloadinprogress;
00566
00567         UINT16  m_tpdu_count;
00568
00569 #if defined(APOXI_SMS_NEW_PROVIDERS)
00570         UINT16  m_inbox_count;
00571         UINT16  m_outbox_count;
00572         UINT16  m_archive_count;
00573         UINT16  m_statusreport_count;
00574         UINT16  m_unread_count;
00575
00576     #if defined(_DEBUG)
00577         UINT32 m_indexing_time;
00578         INT m_count_iteration;
00579
00580         UINT32 m_sorttime_inbox;
00581         UINT32 m_sorttime_outbox;
00582         UINT32 m_sorttime_archive;
00583         UINT32 m_sorttime_status;
00584         UINT32 m_sorttime_unread;
00585
00586         INT m_iteration_inbox;
00587         INT m_iteration_outbox;
00588         INT m_iteration_archive;
00589         INT m_iteration_status;
00590         INT m_iteration_unread;
00591     #endif
00592 #else
00593         UINT16  m_read_count;
00594         UINT16  m_unread_count;
00595         UINT16  m_sent_count;
00596         UINT16  m_unsent_count;
00597 #endif
00598
00599         UINT16  m_max_count;
00600         UINT16  m_smsr_count;
00601         UINT16  m_smsr_offset;
00602
00603         INT16 m_pdu_reload[c_max_reloadable_pdus];
00604
00605         TpduCache * m_tpdu_cache;
00606
00607         TpduCount m_count_table[NoOfCountTypes];
00608
00609         static UINT8   m_max_conc_pdu_no;
00610         static BOOLEAN m_csms_state_changeable;
00611         static UINT16  m_pdu_no_cache;
00612         static UINT16  m_no_cache_header;
00613         static UINT16  m_no_cache_chars;
00614         static BOOLEAN m_csms_pid_check_enabled;
00615
00616
00617         static const WCHAR * m_missing_part_text;
00618
00619         static TpduHeaderInformation m_header_entries1[c_max_table1];
00620         static TpduHeaderInformation m_header_entries2[c_max_table2];
00621         static SmsrCache             m_smsr_cache[c_max_smsr_pdus];
00622
00623
00624         static UINT16 m_recnos[c_max_pdus];
00625
00626 #if defined(APOXI_SMS_NEW_PROVIDERS)
00627         static UINT16 m_inbox_recnos[c_max_pdus];
00628         static UINT16 m_outbox_recnos[c_max_pdus];
00629         static UINT16 m_archive_recnos[c_max_pdus];
00630         static UINT16 m_statusreport_recnos[c_max_pdus];
00631         static UINT16 m_unread_recnos[c_max_pdus];
00632 #elif !defined(APOXI_DISABLE_FILTERED_SMS_PROVIDERS)
00633         static UINT16 m_read_recnos[c_max_pdus];
00634         static UINT16 m_unread_recnos[c_max_pdus];
00635         static UINT16 m_sent_recnos[c_max_pdus];
00636         static UINT16 m_unsent_recnos[c_max_pdus];
00637 #endif
00638         static UINT16 m_delete_recnos[c_max_pdus];
00639         static UINT16 m_csms_recs[c_default_max_pdu_per_sms+1];
00640
00641         SmsWStringCache m_wstringcache;
00642 };
00643
00644
00646 #endif
00647
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimSmsParamHandler.cpp File Reference

Adc/SimSmsParamHandler.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Auxiliary/AlphaCoding.hpp>
#include "SimSmsParamHandler.hpp"

Include dependency graph for SimSmsParamHandler.cpp:

Variables

const INT | c_offset_dcs = 12 + 12 + 1 + 1
const INT | c_offset_dest_address = 1
const INT | c_offset_protocol_id = 12 + 12 + 1
const INT | c_offset_sc_address = 12 + 1
const INT | c_offset_vp = 12 + 12 + 1 + 1 + 1

Variable Documentation

const INT c_offset_dcs = 12 + 12 + 1 + 1

const INT c_offset_dest_address = 1

const INT c_offset_protocol_id = 12 + 12 + 1

const INT c_offset_sc_address = 12 + 1

const INT c_offset_vp = 12 + 12 + 1 + 1 + 1

Generated on Tue Jan 24 15:26:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimSmsParamHandler.hpp File Reference

Adc/SimSmsParamHandler.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/FixedPtrArray.hpp>
#include <Apc/SignalTypes.hpp>
#include <Adc/BaseDataHandler.hpp>

Include dependency graph for SimSmsParamHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimSmsParameter
struct | SimSmsParameter::Record
class | SimSmsParamHandler

Defines

#define | Adc_SimSmsParamHandler_hpp

Variables

const INT | c_max_smsparameters = 10
const INT | c_size_smsparameters = 28
const INT | c_smsp_rw_buffer_len = c_max_smsparam_entry_len

Define Documentation

#define Adc_SimSmsParamHandler_hpp

Generated on Tue Jan 24 15:26:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimSmsParamHandler.hpp Source File

Adc/SimSmsParamHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_SimSmsParamHandler_hpp)
00010 #define Adc_SimSmsParamHandler_hpp
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Auxiliary/PhoneNumber.hpp>
00017 #include <Auxiliary/FixedPtrArray.hpp>
00018
00019 #include <Apc/SignalTypes.hpp>
00020
00021 #include <Adc/BaseDataHandler.hpp>
00022
00023
00024 class SimAccessor;
00025
00026 const INT c_size_smsparameters = 28;
00027 const INT c_max_smsparameters = 10;
00028
00029 class SimSmsParameter
00030 {
00031     public:
00032         struct Record {
00033             WString     m_name;
00034             PhoneNumber m_da;
00035             PhoneNumber m_sca;
00036             UINT8       m_protid;
00037             UINT8       m_dcs;
00038             UINT8       m_vp;
00039
00040             BOOLEAN     m_exist_name;
00041             BOOLEAN     m_exist_da;
00042             BOOLEAN     m_exist_sca;
00043             BOOLEAN     m_exist_protid;
00044             BOOLEAN     m_exist_dcs;
00045             BOOLEAN     m_exist_vp;
00046         };
00047
00048         SimSmsParameter(const WString & name, const UINT8 * buffer);
00049         ~SimSmsParameter();
00050
00051         const UINT8 * GetSmspBuffer() const { return m_smsp_buffer; };
00052
00053         const WString & GetName() const { return m_name; }
00054
00055         BOOLEAN GetSmsParameter(SimSmsParameter::Record & record);
00056         BOOLEAN SetSmsParameter(const SimSmsParameter::Record & record);
00057     private:
00058         WString       m_name;
00059         UINT8         m_smsp_buffer[c_size_smsparameters];
00060 };
00061
00062 const INT c_smsp_rw_buffer_len = c_max_smsparam_entry_len;
00063
00065 class SimSmsParamHandler : public BaseDataHandler
00066 {
00067     typedef BaseDataHandler Base;
00068
00069     typedef FixedPtrArray<SimSmsParameter> SmsParameterArray;
00070
00071     public:
00072         SimSmsParamHandler();
00073         virtual ~SimSmsParamHandler();
00074
00075         void Reset();
00076         void Refresh();
00077
00078         BOOLEAN RefreshData(INT );
00079
00080         BOOLEAN GetAlphaIdLength(INT & length);
00081
00082         BOOLEAN GetSmsParameter(INT recno, SimSmsParameter::Record & record);
00083         BOOLEAN SetSmsParameter(INT recno, const SimSmsParameter::Record & record);
00084
00085         BOOLEAN RetrieveSmsServiceParameter();
00086         BOOLEAN RetrieveUsimSmsServiceParameter();
00087         BOOLEAN UpdateSmsServiceParameter(INT recno, BOOLEAN deleterecord = FALSE);
00088
00089         INT     GetMaxSmspCount() const { return m_smsp_entries; }
00090
00091     private:
00092         void  Clear();
00093
00094         SmsParameterArray m_entries;
00095
00096         BOOLEAN     m_smsp_isupdated;
00097         UINT8       m_smsp_alpha_len;
00098         UINT8       m_smsp_entries;
00099         UINT8       m_smsp_rec_len;
00100
00101         UINT8 m_rw_buffer[c_smsp_rw_buffer_len];
00102 };
00103
00105 #endif
00106
00107
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimTkCommands.cpp File Reference

Adc/SimTkCommands.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Auxiliary/WString.hpp>
#include "SimTkCommands.hpp"

Include dependency graph for SimTkCommands.cpp:

Generated on Tue Jan 24 15:26:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimTkCommands.hpp File Reference

Adc/SimTkCommands.hpp File Reference

#include <Adc/DataHandler.hpp>

Include dependency graph for SimTkCommands.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Adc_SimTkCommands_hpp

Define Documentation

#define Adc_SimTkCommands_hpp

Generated on Tue Jan 24 15:26:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimTkCommands.hpp Source File

Adc/SimTkCommands.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Adc_SimTkCommands_hpp)
00009 #define Adc_SimTkCommands_hpp
00012
00013 #include <Adc/DataHandler.hpp>
00014
00015 #if defined(APOXI_ADC_SIMTK_PROACTIVE_CODE)
00016
00018
00019 const INT c_sim_response = 159;
00020 const INT c_sim_toolkit_busy = 147;
00021 const INT c_sim_removed = 9;
00022 const INT c_sim_normal_ending = 144;
00023
00024 enum SimTkTestEventListCode {
00025     c_useractivity = 0x04,
00026     c_idlescreenactivity = 0x05,
00027     c_langselection = 0x07
00028 };
00029
00030 class SimTkCommands
00031 {
00032     public:
00033
00034 // sends a proactive sim reset cmd to the sim prozess which leads to a reset of the sim
00035 // for simulation on host, stack debugging and changing values is necessary
00036         static BOOLEAN SendSimReset();
00037
00038 // triggers a Simtk event notification of type SimTkTestEventListCode
00039         static BOOLEAN SendSetupEventList(SimTkTestEventListCode code);
00040
00041 // triggers a Simtk language notification
00042         static BOOLEAN SendLanguageNotification(ExtLanguage language);
00043
00044 // triggers a Simtk request to ask for the active language
00045         static BOOLEAN SendProvideLocalLanguage();
00046
00047 // triggers a simtk file refresh notification for a single file please refer to GSM 11.11
00048         static BOOLEAN SendSimRefresh(UINT16 df, UINT16 ef);
00049
00050 // triggers a refresh of all sim files
00051         static BOOLEAN SendSimAllRefresh();
00052
00053 // sends a Simtk 8-bit display text
00054         static BOOLEAN SendDisplayText(const WString & text,
00055                                        BOOLEAN highpriority = FALSE,
00056                                        BOOLEAN waitforuser = FALSE);
00057 // sends a Simtk getinkey request
00058         static BOOLEAN SendGetInkey(const WString & text,
00059                                     BOOLEAN digitsonly = FALSE,
00060                                     BOOLEAN smsdefaultalphabet = TRUE,
00061                                     BOOLEAN yesnorequest = FALSE,
00062                                     BOOLEAN helpavailable = FALSE);
00063 // sends a Simtk getinput request
00064         static BOOLEAN SendGetInput(const WString & text, INT min, INT max,
00065                                     BOOLEAN digitsonly = FALSE,
00066                                     BOOLEAN smsdefaultalphabet = TRUE,
00067                                     BOOLEAN userecho = TRUE,
00068                                     BOOLEAN smspacked = FALSE,
00069                                     BOOLEAN helpavailable = FALSE);
00070 // send a SimTk playtone request
00071         static BOOLEAN SendPlayTone(const WString & text = L"",
00072                                     BOOLEAN tonetag = FALSE,
00073                                     UINT8 tone = 0,
00074                                     BOOLEAN durationtag = FALSE,
00075                                     UINT8 timeunit = 0,
00076                                     UINT8 timeinterval = 0);
00077 // send a Simtk setupidletext request
00078         static BOOLEAN SendSetupIdleModeText(const WString & text);
00079
00080 // send a Simtk menu request
00081         static BOOLEAN SendSetupMenu(const WString & menutext,
00082                                      const WString & item1,
00083                                      const WString & item2,
00084                                      BOOLEAN softkeyprefered = FALSE,
00085                                      BOOLEAN helpavailable = FALSE);
00086
00087
00088
00089     private:
00090         static SimApduData m_apdu;
00091 };
00092 #endif
00093
00095 #endif
00096
00097
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimTkMainMenuProvider.cpp File Reference

Adc/SimTkMainMenuProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Apc/SimTkTypes.hpp>
#include "SimTkMainMenuProvider.hpp"

Include dependency graph for SimTkMainMenuProvider.cpp:

Generated on Tue Jan 24 15:26:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimTkMainMenuProvider.hpp File Reference

Adc/SimTkMainMenuProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/SimTkStackMsgArgs.hpp>
#include <Adc/ProvIds.hpp>

Include dependency graph for SimTkMainMenuProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimTkMainMenuProvider

Defines

#define | Adc_SimTkMainMenuProvider_hpp

Define Documentation

#define Adc_SimTkMainMenuProvider_hpp

Generated on Tue Jan 24 15:27:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SimTkMainMenuProvider.hpp Source File

Adc/SimTkMainMenuProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SimTkMainMenuProvider_hpp)
00015 #define Adc_SimTkMainMenuProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Apc/SignalTypes.hpp>
00023 #include <Apc/SimTkStackMsgArgs.hpp>
00024
00025 #include <Adc/ProvIds.hpp>
00026
00027 /*------------------------------------------------------------------
00028                             SimTkMainMenuProvider
00029  ------------------------------------------------------------------*/
00030
00049 class SimTkMainMenuProvider : public ThreadSafeProvider
00050 {
00051     public:
00052         typedef ThreadSafeProvider Base;
00054         SimTkMainMenuProvider();
00056         virtual ~SimTkMainMenuProvider();
00058         virtual INT GetProviderId() const;
00060         virtual INT RowCount();
00062         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00064         virtual BOOLEAN Update(ProviderListener * listener = 0);
00065
00066         void SetSimTkMainMenu(const SetupMenuReqArg & arg);
00067
00068         void Reset();
00069
00070     private:
00071         SimSetupMenuOptions      m_options;
00072         SimAlphaIdentifier       m_title;
00073         SimIconIdentifier        m_titleicon;
00074         SimItemIdentifierList    m_item_list;
00075         SimNextActionIdentifier  m_nextaction_list;
00076         SimIconIdentifier        m_icon_list;
00077 };
00078
00080 #endif
00081
00082
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseArchiveProvider.cpp File Reference

Adc/SmsBaseArchiveProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsBaseArchiveProvider.hpp"

Include dependency graph for SmsBaseArchiveProvider.cpp:

Generated on Tue Jan 24 15:27:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseArchiveProvider.hpp File Reference

Adc/SmsBaseArchiveProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsBaseArchiveProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Adc_SmsArchiveProvider_hpp

Define Documentation

#define Adc_SmsArchiveProvider_hpp

Generated on Tue Jan 24 15:27:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseArchiveProvider.hpp Source File

Adc/SmsBaseArchiveProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsArchiveProvider_hpp)
00015 #define Adc_SmsArchiveProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if defined(APOXI_SMS_NEW_PROVIDERS)
00023
00034 class SmsBaseArchiveProvider : public SmsProvider
00035 {
00036     typedef SmsProvider Base;
00037
00038     public:
00040         SmsBaseArchiveProvider();
00042         virtual ~SmsBaseArchiveProvider();
00044         virtual INT GetProviderId() const;
00046         virtual INT RowCount();
00047
00048     protected:
00050         virtual SmsFilterType GetSmsFilterType() const { return ArchiveSmsFilterType; }
00051 };
00052
00053 #endif // (APOXI_SMS_NEW_PROVIDERS)
00054
00055 #endif
00056
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseInboxProvider.cpp File Reference

Adc/SmsBaseInboxProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsBaseInboxProvider.hpp"

Include dependency graph for SmsBaseInboxProvider.cpp:

Generated on Tue Jan 24 15:27:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseInboxProvider.hpp File Reference

Adc/SmsBaseInboxProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsBaseInboxProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Adc_SmsInboxProvider_hpp

Define Documentation

#define Adc_SmsInboxProvider_hpp

Generated on Tue Jan 24 15:27:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseInboxProvider.hpp Source File

Adc/SmsBaseInboxProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsInboxProvider_hpp)
00015 #define Adc_SmsInboxProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if defined(APOXI_SMS_NEW_PROVIDERS)
00023
00035 class SmsBaseInboxProvider : public SmsProvider
00036 {
00037     typedef SmsProvider Base;
00038
00039     public:
00041         SmsBaseInboxProvider();
00043         virtual ~SmsBaseInboxProvider();
00045         virtual INT GetProviderId() const;
00047         virtual INT RowCount();
00048
00049     protected:
00051         virtual SmsFilterType GetSmsFilterType() const { return InboxSmsFilterType; }
00052 };
00053
00054 #endif // APOXI_SMS_NEW_PROVIDERS)
00055
00056 #endif
00057
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseOutboxProvider.cpp File Reference

Adc/SmsBaseOutboxProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsBaseOutboxProvider.hpp"

Include dependency graph for SmsBaseOutboxProvider.cpp:

Generated on Tue Jan 24 15:27:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseOutboxProvider.hpp File Reference

Adc/SmsBaseOutboxProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsBaseOutboxProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Adc_SmsOutboxProvider_hpp

Define Documentation

#define Adc_SmsOutboxProvider_hpp

Generated on Tue Jan 24 15:27:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseOutboxProvider.hpp Source File

Adc/SmsBaseOutboxProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsOutboxProvider_hpp)
00015 #define Adc_SmsOutboxProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if defined(APOXI_SMS_NEW_PROVIDERS)
00023
00034 class SmsBaseOutboxProvider : public SmsProvider
00035 {
00036     typedef SmsProvider Base;
00037
00038     public:
00040         SmsBaseOutboxProvider();
00042         virtual ~SmsBaseOutboxProvider();
00044         virtual INT GetProviderId() const;
00045
00047         virtual INT RowCount();
00048
00049     protected:
00051         virtual SmsFilterType GetSmsFilterType() const { return OutboxSmsFilterType; }
00052 };
00053
00054 #endif // (APOXI_SMS_NEW_PROVIDERS)
00055
00056 #endif
00057
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseStatusReportProvider.cpp File Reference

Adc/SmsBaseStatusReportProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsBaseStatusReportProvider.hpp"

Include dependency graph for SmsBaseStatusReportProvider.cpp:

Generated on Tue Jan 24 15:27:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseStatusReportProvider.hpp File Reference

Adc/SmsBaseStatusReportProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsBaseStatusReportProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Adc_SmsStatusReportProvider_hpp

Define Documentation

#define Adc_SmsStatusReportProvider_hpp

Generated on Tue Jan 24 15:27:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseStatusReportProvider.hpp Source File

Adc/SmsBaseStatusReportProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsStatusReportProvider_hpp)
00015 #define Adc_SmsStatusReportProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if defined(APOXI_SMS_NEW_PROVIDERS)
00023
00035 class SmsBaseStatusReportProvider : public SmsProvider
00036 {
00037     typedef SmsProvider Base;
00038
00039     public:
00041         SmsBaseStatusReportProvider();
00043         virtual ~SmsBaseStatusReportProvider();
00045         virtual INT GetProviderId() const;
00047         virtual INT RowCount();
00048
00049     protected:
00051         virtual SmsFilterType GetSmsFilterType() const { return StatusReportSmsFilterType; }
00052 };
00053
00054 #endif // (APOXI_SMS_NEW_PROVIDERS)
00055
00056 #endif
00057
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseUnreadProvider.cpp File Reference

Adc/SmsBaseUnreadProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsBaseUnreadProvider.hpp"

Include dependency graph for SmsBaseUnreadProvider.cpp:

Generated on Tue Jan 24 15:27:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseUnreadProvider.hpp File Reference

Adc/SmsBaseUnreadProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsBaseUnreadProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Adc_SmsBaseUnreadProvider_hpp

Define Documentation

#define Adc_SmsBaseUnreadProvider_hpp

Generated on Tue Jan 24 15:27:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsBaseUnreadProvider.hpp Source File

Adc/SmsBaseUnreadProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsBaseUnreadProvider_hpp)
00015 #define Adc_SmsBaseUnreadProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if defined(APOXI_SMS_NEW_PROVIDERS)
00023
00037 class SmsBaseUnreadProvider : public SmsProvider
00038 {
00039     typedef SmsProvider Base;
00040
00041     public:
00043         SmsBaseUnreadProvider();
00045         virtual ~SmsBaseUnreadProvider();
00047         virtual INT GetProviderId() const;
00049         virtual INT RowCount();
00050
00051     protected:
00053         virtual SmsFilterType GetSmsFilterType() const { return UnreadSmsFilterType; }
00054 };
00055
00056 #endif // (APOXI_SMS_NEW_PROVIDERS)
00057
00058 #endif
00059
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsClass0Provider.cpp File Reference

Adc/SmsClass0Provider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsClass0Provider.hpp"
#include "Apc/StackWrapper.hpp"
#include "Apc/Sms.hpp"

Include dependency graph for SmsClass0Provider.cpp:

Generated on Tue Jan 24 15:27:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsClass0Provider.hpp File Reference

Adc/SmsClass0Provider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsClass0Provider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsClass0Provider

Defines

#define | Adc_SmsClass0Provider_hpp

Define Documentation

#define Adc_SmsClass0Provider_hpp

Generated on Tue Jan 24 15:27:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsClass0Provider.hpp Source File

Adc/SmsClass0Provider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsClass0Provider_hpp)
00015 #define Adc_SmsClass0Provider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00032 class SmsClass0Provider : public SmsProvider
00033 {
00034     typedef SmsProvider Base;
00035
00036     public:
00037
00039         SmsClass0Provider();
00041         virtual ~SmsClass0Provider();
00043         virtual Status GetStatus() const;
00045         virtual INT GetProviderId() const;
00047 //      void Init();
00049         virtual INT RowCount();
00051         virtual BOOLEAN Update(ProviderListener *listener = 0);
00052
00054         virtual INT MaxRowCount();
00056         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00057
00059         virtual BOOLEAN ToggleRow(INT row);
00061         virtual BOOLEAN DeleteRow(INT row);
00063         virtual BOOLEAN DeleteAllRows(ProviderListener *listener = 0);
00065         virtual INT GetProgress();
00066
00067     private:
00068         Tpdu m_tpdu;
00069 };
00070
00072 #endif
00073
00074
Generated on Tue Jan 24 14:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsInfoElements.cpp File Reference

Adc/SmsInfoElements.cpp File Reference

#include "Adc/PreComp.hpp"
#include "Adc/SmsInfoelements.hpp"

Include dependency graph for SmsInfoElements.cpp:

Generated on Tue Jan 24 15:27:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsInfoElements.hpp File Reference

Adc/SmsInfoElements.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_SmsInfoelements_hpp

Define Documentation

#define Adc_SmsInfoelements_hpp

Generated on Tue Jan 24 15:27:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsInfoElements.hpp Source File

Adc/SmsInfoElements.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2001 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 // =============================================================================
00015 //
00016 //                              includes
00017 //
00018 // =============================================================================
00019 #if !defined(Adc_SmsInfoelements_hpp)
00020 #define Adc_SmsInfoelements_hpp
00021
00022 #ifdef HARRY
00023 /*------------------------------------------------------------------
00024         Concatenated short messages, 16-bit and 8-bit reference number
00025  ------------------------------------------------------------------*/
00029 class ConcatInfoElement16Bit
00030 {
00031     public:
00033         ConcatInfoElement16Bit(InformationElement * info_element);
00035         ~ConcatInfoElement16Bit() {};
00037         inline INT GetReferenceNumber() const {return m_reference_number;};
00039         inline INT GetMaxNumberOfSms() const {return m_max_number_of_sms;};
00041         inline INT GetSequenceNumber() const {return m_sequence_number;};
00042
00043     private:
00044         INT m_reference_number;
00045         INT m_max_number_of_sms;
00046         INT m_sequence_number;
00047
00048 };
00049
00053 class ConcatInfoElement8Bit
00054 {
00055     public:
00057         ConcatInfoElement8Bit(InformationElement * info_element);
00059         ~ConcatInfoElement8Bit() {};
00061         inline INT GetReferenceNumber() { return m_reference_number;};
00063         inline INT GetMaxNumberOfSms() {return m_max_number_of_sms;};
00065         inline INT GetSequenceNumber() {return m_sequence_number;};
00066
00067     private:
00068         INT m_reference_number;
00069         INT m_max_number_of_sms;
00070         INT m_sequence_number;
00071
00072 };
00073
00074
00075 /*------------------------------------------------------------------
00076         Text Formatting
00077  ------------------------------------------------------------------*/
00078
00081 class EmsTextFormatting
00082 {
00083     public:
00085         EmsTextFormatting(InformationElement * info_element);
00087         ~EmsTextFormatting() {};
00089         inline INT GetStartPos() const {return m_start_pos;};
00091         inline INT GetFormattingLength() const {return m_formatting_length;};
00093         inline EmsTextAlignment GetAlignment() const {return (EmsTextAlignment)(m_formatting_mode & 0x3);};
00095         inline EmsTextFontSize GetFontSize() const {return (EmsTextFontSize)((m_formatting_mode & 0xC) >> 2);};
00097         inline EmsStyleStatus GetFontStyleBold() const {return (EmsStyleStatus)(m_formatting_mode & 0x10);};
00099         inline EmsStyleStatus GetFontStyleItalic() const {return (EmsStyleStatus)(m_formatting_mode & 0x20);};
00101         inline EmsStyleStatus GetFontStyleUnderlined() const {return (EmsStyleStatus)(m_formatting_mode & 0x40);};
00103         inline EmsStyleStatus GetFontStyleStrikethrough() const {return (EmsStyleStatus)(m_formatting_mode & 0x80);};
00104
00105
00106     private:
00107         INT m_start_pos;
00108         INT m_formatting_length;
00109         INT m_formatting_mode;
00110
00111 };
00112
00113
00114 /*------------------------------------------------------------------
00115         Predefined Sound
00116  ------------------------------------------------------------------*/
00118 class EmsPredefinedSound
00119 {
00120     public:
00122         EmsPredefinedSound(InformationElement * info_element);
00124         ~EmsPredefinedSound() {};
00126         inline INT GetStartPos() const {return m_start_pos;};
00128         inline INT GetSoundNumber() const {return m_sound_number;};
00129
00130     private:
00131         INT m_start_pos;
00132         INT m_sound_number;
00133
00134 };
00135
00136
00137 /*------------------------------------------------------------------
00138         Predefined Animation
00139  ------------------------------------------------------------------*/
00141 class EmsPredefinedAnimation
00142 {
00143     public:
00145         EmsPredefinedAnimation(InformationElement * info_element);
00147         ~EmsPredefinedAnimation() {};
00149         inline INT GetStartPos() const {return m_start_pos;};
00151         inline INT GetAnimationNumber() const {return m_animation_number;};
00152
00153     private:
00154         INT m_start_pos;
00155         INT m_animation_number;
00156 };
00157
00158
00159 /*------------------------------------------------------------------
00160         Small Picture
00161  ------------------------------------------------------------------*/
00163 class EmsSmallPicture
00164 {
00165     public:
00167         EmsSmallPicture(InformationElement * info_element);
00169         virtual ~EmsSmallPicture() {};
00171         inline INT GetStartPos() const {return m_start_pos;};
00173         inline const UINT8* GetPictureData() const {return m_picture_data;};
00174
00175     private:
00176         INT    m_start_pos;
00177         const UINT8 *m_picture_data;
00178 };
00179
00180 /*------------------------------------------------------------------
00181         Variable Picture
00182  ------------------------------------------------------------------*/
00184 class EmsVariablePicture
00185 {
00186     public:
00188         EmsVariablePicture(InformationElement * info_element);
00190         virtual ~EmsVariablePicture() {};
00191
00193         inline INT GetStartPos() const {return m_start_pos;};
00195         inline INT GetHorizontalDim() const {return m_horizontal_dim;};
00197         inline INT GetVerticalDim() const {return m_vertical_dim;};
00199         inline const UINT8* GetPictureData() const {return m_picture_data;};
00200
00201     private:
00202         INT    m_start_pos;
00203         INT    m_horizontal_dim;
00204         INT    m_vertical_dim;
00205         const UINT8 *m_picture_data;
00206
00207 };
00208
00209 /*------------------------------------------------------------------
00210         InfoElementParser
00211  ------------------------------------------------------------------*/
00213 class InfoElementParser
00214 {
00215     public:
00217         InfoElementParser(UserDataHeader udh);
00219         ~InfoElementParser() {};
00220
00222         BOOLEAN FindInfoElement(InformationElementIdentifier info_elment_id);
00224         InformationElementIdentifier GetInformationElementIdentifier();
00226         BOOLEAN NextInformationElement();
00228         InformationElement GetInformationElement();
00229
00230     private:
00231         UserDataHeader m_udh;
00232         INT            m_offset;
00233
00234 };
00235
00236 #endif
00237
00238 #endif;
00239
00240
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsParamProvider.cpp File Reference

Adc/SmsParamProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsParamProvider.hpp"

Include dependency graph for SmsParamProvider.cpp:

Generated on Tue Jan 24 15:27:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsParamProvider.hpp File Reference

Adc/SmsParamProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimSmsParamHandler.hpp>

Include dependency graph for SmsParamProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsParamProvider

Defines

#define | Adc_SmsParamProvider_hpp

Define Documentation

#define Adc_SmsParamProvider_hpp

Generated on Tue Jan 24 15:27:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsParamProvider.hpp Source File

Adc/SmsParamProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsParamProvider_hpp)
00015 #define Adc_SmsParamProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimSmsParamHandler.hpp>
00024
00025 /*------------------------------------------------------------------
00026                             SmsParamProvider
00027  ------------------------------------------------------------------*/
00028
00045 class SmsParamProvider : public ThreadSafeProvider
00046 {
00047     public:
00048         typedef ThreadSafeProvider Base;
00049
00051         SmsParamProvider();
00053         virtual ~SmsParamProvider();
00055         virtual INT GetProviderId() const;
00057         void Init(SimSmsParamHandler * smsp_handler, Protector * protector);
00059         virtual BOOLEAN SelectRow(INT row);
00061         virtual INT RowCount();
00063         virtual INT MaxRowCount();
00065         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00067         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00069         virtual BOOLEAN CommitRow(INT row);
00071         virtual BOOLEAN DeleteRow(INT row);
00073         virtual BOOLEAN AppendRow();
00075         virtual BOOLEAN Update(ProviderListener * listener = 0);
00076
00077
00078     private:
00079         void ClearBufferVariables();
00080         BOOLEAN WriteRow(INT row);
00081
00082         SimSmsParamHandler * m_smsp_handler;
00083
00084         SimSmsParameter::Record m_record;
00085
00086 };
00087
00089 #endif
00090
00091
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsProvider.cpp File Reference

Adc/SmsProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Apc/StackInterface.hpp>
#include "CompoundSmsItem.hpp"
#include "SmsProvider.hpp"

Include dependency graph for SmsProvider.cpp:

Generated on Tue Jan 24 15:27:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsProvider.hpp File Reference

Adc/SmsProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Apc/Sms.hpp>
#include <Adc/ProvIds.hpp>

Include dependency graph for SmsProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsCountProvider
class | SmsMsgWaitingProvider
class | SmsProvider

Defines

#define | Adc_SmsProvider_hpp

Define Documentation

#define Adc_SmsProvider_hpp

Generated on Tue Jan 24 15:27:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsProvider.hpp Source File

Adc/SmsProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsProvider_hpp)
00015 #define Adc_SmsProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Apc/Sms.hpp>
00023
00024 #include <Adc/ProvIds.hpp>
00025
00026
00027 class SimPduHandler;
00028
00065 class SmsProvider : public ThreadSafeProvider
00066 {
00067     public:
00068         typedef ThreadSafeProvider Base;
00069
00071         SmsProvider();
00073         virtual ~SmsProvider();
00075         virtual INT GetProviderId() const;
00077         void Init(SimPduHandler * sim_pdu_handler, Protector * protector);
00079         virtual INT RowCount();
00080
00082         virtual INT MaxRowCount();
00084         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00085
00087         virtual BOOLEAN ToggleRow(INT row);
00089         virtual BOOLEAN DeleteRow(INT row);
00091         virtual BOOLEAN DeleteAllRows(ProviderListener *listener = 0);
00093         virtual BOOLEAN Update(ProviderListener *listener = 0);
00095         virtual BOOLEAN SetDataItem(const DataItem & item, INT column_id);
00097         virtual BOOLEAN CommitRow(INT row);
00099         virtual INT GetProgress();
00103         BOOLEAN DeleteAllSms(SmsDeleteStatus criteriamask, BOOLEAN smsreports = FALSE) {
00104             ASSERT_DEBUG(m_sim_pdu_handler!=0);
00105             return m_sim_pdu_handler->DeleteAllSms(criteriamask, smsreports);
00106         }
00108         BOOLEAN NotifyAsyncChange();
00109
00111         static void SetEmptyNumberText(const WCHAR* text) { SimPduHandler::SetEmptyNumberText(text); }
00112
00113         // is called if SmsDispatcher::OnMdhSmsTransmitStopInd times out
00114         void ForceNormalUpdateOnStartup() { m_forcenormalupdateonstartup = TRUE; }
00115
00122         BOOLEAN CopyTo(INT row, const Sms::StorageType type, INT & src_row, INT & dst_row);
00131         BOOLEAN CopyTo(INT row, const Sms::StorageType type, ProtocolIdentifier pid, INT & src_row, INT & dst_row);
00132
00134         INT FindRowByTpduNumber(INT tpdu_no);
00135
00136     protected:
00137         SimPduHandler * m_sim_pdu_handler;
00138
00139         BOOLEAN GetDataItem(INT column_id, DataItem &item, TpduHeaderInformation * headerinformation);
00140
00141         virtual SmsFilterType GetSmsFilterType() const { return AllSmsFilterType; }
00142         virtual Tpdu::Status GetDestinationTpduStatus() const { return Tpdu::UndefinedStatus; }
00143
00144     private:
00145         Tpdu::Status    CalcDestinationTpduStatus(INT row) const;
00146         void            ClearBufferVariables();
00147
00148         BOOLEAN         m_forcenormalupdateonstartup;
00149         INT             m_column_id;
00150         UINT32          m_commit_ext_data;
00151 };
00152
00153
00191 class SmsCountProvider : public ThreadSafeProvider
00192 {
00193     public:
00194         typedef ThreadSafeProvider Base;
00195
00197         SmsCountProvider();
00199         virtual ~SmsCountProvider();
00201         virtual INT GetProviderId() const;
00203         void Init(SimPduHandler * sim_pdu_handler, Protector * protector);
00205         virtual INT RowCount();
00207         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00209         virtual BOOLEAN Update(ProviderListener *listener = 0);
00210
00211     protected:
00212         SimPduHandler * m_sim_pdu_handler;
00213
00214 };
00215
00238 class SmsMsgWaitingProvider : public ThreadSafeProvider
00239 {
00240     public:
00241         typedef ThreadSafeProvider Base;
00242
00244         SmsMsgWaitingProvider();
00246         virtual ~SmsMsgWaitingProvider();
00248         virtual INT GetProviderId() const;
00250         void Init(SimPduHandler * sim_pdu_handler, Protector * protector);
00252         virtual INT RowCount();
00254         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00256         virtual BOOLEAN Update(ProviderListener *listener = 0);
00257
00258         void SetMdhWaitingIndicatorArray(const MdhWaitIndicatorArray & wia);
00259
00260     protected:
00261         SimPduHandler * m_sim_pdu_handler;
00262
00263     private:
00264         MdhWaitIndicatorArray m_wia;
00265         BOOLEAN               m_initialized;
00266 };
00267
00268
00270 #endif
00271
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsReadProvider.cpp File Reference

Adc/SmsReadProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsReadProvider.hpp"

Include dependency graph for SmsReadProvider.cpp:

Generated on Tue Jan 24 15:27:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsReadProvider.hpp File Reference

Adc/SmsReadProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsReadProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsReadProvider

Defines

#define | Adc_SmsReadProvider_hpp

Define Documentation

#define Adc_SmsReadProvider_hpp

Generated on Tue Jan 24 15:27:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsReadProvider.hpp Source File

Adc/SmsReadProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsReadProvider_hpp)
00015 #define Adc_SmsReadProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if !defined(APOXI_SMS_NEW_PROVIDERS) && !defined(APOXI_DISABLE_FILTERED_SMS_PROVIDERS)
00023
00034 class SmsReadProvider : public SmsProvider
00035 {
00036     typedef SmsProvider Base;
00037
00038     public:
00040         SmsReadProvider();
00042         virtual ~SmsReadProvider();
00044         virtual INT GetProviderId() const;
00046         virtual INT RowCount();
00047
00048     protected:
00050         virtual SmsFilterType GetSmsFilterType() const { return ReadSmsFilterType; }
00052         virtual Tpdu::Status GetDestinationTpduStatus() const { return Tpdu::Unread; }
00053
00054 };
00055
00056 #endif // !(APOXI_SMS_NEW_PROVIDERS)
00057
00058 #endif
00059
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsSentProvider.cpp File Reference

Adc/SmsSentProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsSentProvider.hpp"

Include dependency graph for SmsSentProvider.cpp:

Generated on Tue Jan 24 15:27:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsSentProvider.hpp File Reference

Adc/SmsSentProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsSentProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsSentProvider

Defines

#define | Adc_SmsSentProvider_hpp

Define Documentation

#define Adc_SmsSentProvider_hpp

Generated on Tue Jan 24 15:27:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsSentProvider.hpp Source File

Adc/SmsSentProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsSentProvider_hpp)
00015 #define Adc_SmsSentProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if !defined(APOXI_SMS_NEW_PROVIDERS) && !defined(APOXI_DISABLE_FILTERED_SMS_PROVIDERS)
00023
00034 class SmsSentProvider : public SmsProvider
00035 {
00036     typedef SmsProvider Base;
00037
00038     public:
00040         SmsSentProvider();
00042         virtual ~SmsSentProvider();
00044         virtual INT GetProviderId() const;
00046         virtual INT RowCount();
00047
00048     protected:
00050         virtual SmsFilterType GetSmsFilterType() const { return SentSmsFilterType; }
00052         virtual Tpdu::Status GetDestinationTpduStatus() const { return Tpdu::Unsent; }
00053
00054 };
00055
00056 #endif // !(APOXI_SMS_NEW_PROVIDERS)
00057
00058 #endif
00059
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsUnreadProvider.cpp File Reference

Adc/SmsUnreadProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsUnreadProvider.hpp"

Include dependency graph for SmsUnreadProvider.cpp:

Generated on Tue Jan 24 15:27:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsUnreadProvider.hpp File Reference

Adc/SmsUnreadProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsUnreadProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsUnreadProvider

Defines

#define | Adc_SmsUnreadProvider_hpp

Define Documentation

#define Adc_SmsUnreadProvider_hpp

Generated on Tue Jan 24 15:27:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsUnreadProvider.hpp Source File

Adc/SmsUnreadProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsUnreadProvider_hpp)
00015 #define Adc_SmsUnreadProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if !defined(APOXI_SMS_NEW_PROVIDERS) && !defined(APOXI_DISABLE_FILTERED_SMS_PROVIDERS)
00023
00037 class SmsUnreadProvider : public SmsProvider
00038 {
00039     typedef SmsProvider Base;
00040
00041     public:
00043         SmsUnreadProvider();
00045         virtual ~SmsUnreadProvider();
00047         virtual INT GetProviderId() const;
00049         virtual INT RowCount();
00050
00051     protected:
00053         virtual SmsFilterType GetSmsFilterType() const { return UnreadSmsFilterType; }
00055         virtual Tpdu::Status GetDestinationTpduStatus() const { return Tpdu::Read; }
00056 };
00057
00058 #endif // !(APOXI_SMS_NEW_PROVIDERS)
00059
00060 #endif
00061
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsUnsentProvider.cpp File Reference

Adc/SmsUnsentProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SmsUnsentProvider.hpp"

Include dependency graph for SmsUnsentProvider.cpp:

Generated on Tue Jan 24 15:27:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsUnsentProvider.hpp File Reference

Adc/SmsUnsentProvider.hpp File Reference

#include <Adc/SmsProvider.hpp>

Include dependency graph for SmsUnsentProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsUnsentProvider

Defines

#define | Adc_SmsUnsentProvider_hpp

Define Documentation

#define Adc_SmsUnsentProvider_hpp

Generated on Tue Jan 24 15:27:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SmsUnsentProvider.hpp Source File

Adc/SmsUnsentProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SmsUnsentProvider_hpp)
00015 #define Adc_SmsUnsentProvider_hpp
00019
00020 #include <Adc/SmsProvider.hpp>
00021
00022 #if !defined(APOXI_SMS_NEW_PROVIDERS) && !defined(APOXI_DISABLE_FILTERED_SMS_PROVIDERS)
00023
00037 class SmsUnsentProvider : public SmsProvider
00038 {
00039     typedef SmsProvider Base;
00040
00041     public:
00043         SmsUnsentProvider();
00045         virtual ~SmsUnsentProvider();
00047         virtual INT GetProviderId() const;
00049         virtual INT RowCount();
00050
00051     protected:
00053         virtual SmsFilterType GetSmsFilterType() const { return UnsentSmsFilterType; }
00055         virtual Tpdu::Status GetDestinationTpduStatus() const { return Tpdu::Sent; }
00056
00057 };
00058
00059 #endif // !(APOXI_SMS_NEW_PROVIDERS)
00060
00061 #endif
00062
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SstProvider.cpp File Reference

Adc/SstProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include "SstProvider.hpp"

Include dependency graph for SstProvider.cpp:

Generated on Tue Jan 24 15:27:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SstProvider.hpp File Reference

Adc/SstProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Adc/ProvIds.hpp>
#include <Adc/SimAuxHandler.hpp>

Include dependency graph for SstProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimServices
class | SstProvider

Defines

#define | Adc_SstProvider_hpp

Enumerations

enum | EstTableIndexes { c_est_fdn = 1, c_est_bdn = 2, c_est_apn_acl = 3 }
enum SimServiceId {
SimServiceChv1Disable, SimServiceAdn, SimServiceFdn, SimServiceBdn,
SimServiceMsisdn, SimServiceLnd, SimServiceSms, SimServiceAoc,
SimServicePrefPlmn, SimServicePlmnwAct, SimServiceSmsParameter, SimServiceSdn,
SimServiceCbmi, SimServiceCbmiRanges, SimServiceSpn, SimServiceImages,
SimServiceMexe, SimServicePnn, SimServiceOpl, SimServiceMbdn,
SimServiceMwis, SimServiceCfis, SimServiceSpdi, SimServiceInvalid
}
enum SstTableIndexes {
c_sst_chv1_disable_function = 1, c_sst_adn = 2, c_sst_fdn = 3, c_sst_sms = 4,
c_sst_aoc = 5, c_sst_ccp = 6, c_sst_plmn_sel = 7, c_sst_msisdn = 9,
c_sst_ext1 = 10, c_sst_ext2 = 11, c_sst_sms_parameters = 12, c_sst_lnd = 13,
c_sst_cbmi = 14, c_sst_gil1 = 15, c_sst_gil2 = 16, c_sst_spn = 17,
c_sst_sdn = 18, c_sst_ext3 = 19, c_sst_vgcs_gil = 21, c_sst_vbs_gil = 22,
c_sst_emlpp = 23, c_sst_emlpp_answer = 24, c_sst_dwld_sms_cb = 25, c_sst_dwld_sms_pp = 26,
c_sst_menu_selection = 27, c_sst_call_control = 28, c_sst_proactive_sim = 29, c_sst_cbmi_ranges = 30,
c_sst_bdn = 31, c_sst_ext4 = 32, c_sst_depers_control_keys = 33, c_sst_coop_network_list = 34,
c_sst_sms_reports = 35, c_sst_networkind_alerting = 36, c_sst_mo_sm_sim = 37, c_sst_gprs = 38,
c_sst_image = 39, c_sst_solsa = 40, c_sst_ussd_in_callcontrol = 41, c_sst_run_at_command = 42,
c_sst_plmn_sel_access_tech = 43, c_sst_oplmn_sel_access_tech = 44, c_sst_hplmn_access_tech = 45, c_sst_cpbcch_info = 46,
c_sst_investigation_scan = 47, c_sst_eccp = 48, c_sst_mexe = 49, c_sst_pnn = 51,
c_sst_opl = 52, c_sst_mbdn = 53, c_sst_mwis = 54, c_sst_cfis = 55,
c_sst_spdi = 56, c_sst_mms = 57, c_sst_ext8 = 58, c_sst_mms_user_con_params = 59
}
enum UstTableIndexes {
c_ust_local_pb = 1, c_ust_fdn_pb = 2, c_ust_ext2 = 3, c_ust_sdn_pb = 4,
c_ust_ext3 = 5, c_ust_bdn_pb = 6, c_ust_ext4 = 7, c_ust_out_call_info = 8,
c_ust_in_call_info = 9, c_ust_sms = 10, c_ust_smsr = 11, c_ust_smsp = 12,
c_ust_aoc = 13, c_ust_ccp = 14, c_ust_cbmi = 15, c_ust_cbmir = 16,
c_ust_gid_level1 = 17, c_ust_gid_level2 = 18, c_ust_spn = 19, c_ust_plmnwact = 20,
c_ust_msisdn = 21, c_ust_image = 22, c_ust_notused = 23, c_ust_emlpp = 24,
c_ust_auto_emlpp = 25, c_ust_rfu = 26, c_ust_gsm_access = 27, c_ust_datadownload_smspp = 28,
c_ust_datadownload_smscb = 29, c_ust_callcontrol_usim = 30, c_ust_mosmscontrol_usim = 31, c_ust_runat_command = 32,
c_ust_set_to_1 = 33, c_ust_est = 34, c_ust_acl = 35, c_ust_dck = 36,
c_ust_coop_network_list = 37, c_ust_gsm_security_context = 38, c_ust_cpbcch_info = 39, c_ust_inv_scan = 40,
c_ust_mexe = 41, c_ust_opcont_plmnwact = 42, c_ust_hplmnwact = 43, c_ust_ext5 = 44,
c_ust_plmn_networkname = 45, c_ust_op_plmnlist = 46, c_ust_mbdn = 47, c_ust_mwis = 48,
c_ust_cfis = 49, c_ust_res = 50, c_ust_spdi = 51, c_ust_mms = 52,
c_ust_ext8 = 53, c_ust_callcontrol_gprs_usim = 54, c_ust_mms_ucp = 55, c_ust_nia = 56,
c_ust_vgcs = 57, c_ust_vbs = 58, c_ust_pseudonym = 59, c_ust_user_plmn_sel_wlan_access = 60,
c_ust_operator_plmn_sel_wlan_access = 61, c_ust_user_wsid_list = 62, c_ust_operator_wsid_list = 63, c_ust_vgcs_security = 64,
c_ust_vbs_security = 65, c_ust_wlan_reauthentication = 66, c_ust_mms_storage = 67, c_ust_generic_bootstrapping = 68,
c_ust_mbms_security = 69, c_ust_datadownload_ussd_appl = 70, c_ust_equivalent_hplmn = 71
}

Define Documentation

#define Adc_SstProvider_hpp

Generated on Tue Jan 24 15:27:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/SstProvider.hpp Source File

Adc/SstProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_SstProvider_hpp)
00015 #define Adc_SstProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Adc/ProvIds.hpp>
00023 #include <Adc/SimAuxHandler.hpp>
00024
00025 /*------------------------------------------------------------------
00026                             SstProvider
00027  ------------------------------------------------------------------*/
00028
00031 enum SstTableIndexes {
00033     c_sst_chv1_disable_function     = 1,
00035     c_sst_adn                       = 2,
00037     c_sst_fdn                       = 3,
00039     c_sst_sms                       = 4,
00041     c_sst_aoc                       = 5,
00043     c_sst_ccp                       = 6,
00045     c_sst_plmn_sel                  = 7,
00046 //  c_reserved
00048     c_sst_msisdn                    = 9,
00050     c_sst_ext1                      = 10,
00052     c_sst_ext2                      = 11,
00054     c_sst_sms_parameters            = 12,
00056     c_sst_lnd                       = 13,
00058     c_sst_cbmi                      = 14,
00060     c_sst_gil1                      = 15,
00062     c_sst_gil2                      = 16,
00064     c_sst_spn                       = 17,
00066     c_sst_sdn                       = 18,
00068     c_sst_ext3                      = 19,
00069 //  c_reserved
00071     c_sst_vgcs_gil                  = 21,
00073     c_sst_vbs_gil                   = 22,
00075     c_sst_emlpp                     = 23,
00077     c_sst_emlpp_answer              = 24,
00079     c_sst_dwld_sms_cb               = 25,
00081     c_sst_dwld_sms_pp               = 26,
00083     c_sst_menu_selection            = 27,
00085     c_sst_call_control              = 28,
00087     c_sst_proactive_sim             = 29,
00089     c_sst_cbmi_ranges               = 30,
00091     c_sst_bdn                       = 31,
00093     c_sst_ext4                      = 32,
00095     c_sst_depers_control_keys       = 33,
00097     c_sst_coop_network_list         = 34,
00099     c_sst_sms_reports               = 35,
00101     c_sst_networkind_alerting       = 36,
00103     c_sst_mo_sm_sim                 = 37,
00105     c_sst_gprs                      = 38,
00107     c_sst_image                     = 39,
00109     c_sst_solsa                     = 40,
00111     c_sst_ussd_in_callcontrol       = 41,
00113     c_sst_run_at_command            = 42,
00115     c_sst_plmn_sel_access_tech      = 43,
00117     c_sst_oplmn_sel_access_tech     = 44,
00119     c_sst_hplmn_access_tech         = 45,
00121     c_sst_cpbcch_info               = 46,
00123     c_sst_investigation_scan        = 47,
00125     c_sst_eccp                      = 48,
00127     c_sst_mexe                      = 49,
00128 //  c_sst_reserved                  = 50,
00130     c_sst_pnn                       = 51,
00132     c_sst_opl                       = 52,
00134     c_sst_mbdn                      = 53,
00136     c_sst_mwis                      = 54,
00138     c_sst_cfis                      = 55,
00140     c_sst_spdi                      = 56,
00142     c_sst_mms                       = 57,
00144     c_sst_ext8                      = 58,
00146     c_sst_mms_user_con_params       = 59
00147 };
00148
00162 class SstProvider : public ThreadSafeProvider
00163 {
00164     public:
00165         typedef ThreadSafeProvider Base;
00166
00168         SstProvider();
00170         virtual ~SstProvider();
00172         virtual INT GetProviderId() const;
00174         void Init(SimAuxHandler * aux_handler, Protector * protector);
00176         virtual INT RowCount();
00178         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00180         virtual BOOLEAN Update(ProviderListener * listener = 0);
00181
00182     private:
00183         SimAuxHandler * m_aux_handler;
00184 };
00185
00186 /*------------------------------------------------------------------
00187                             UstProvider
00188  ------------------------------------------------------------------*/
00189
00192 enum UstTableIndexes {
00194     c_ust_local_pb                      = 1,
00196     c_ust_fdn_pb                        = 2,
00198     c_ust_ext2                          = 3,
00200     c_ust_sdn_pb                        = 4,
00202     c_ust_ext3                          = 5,
00204     c_ust_bdn_pb                        = 6,
00206     c_ust_ext4                          = 7,
00208     c_ust_out_call_info                 = 8,
00210     c_ust_in_call_info                  = 9,
00212     c_ust_sms                           = 10,
00214     c_ust_smsr                          = 11,
00216     c_ust_smsp                          = 12,
00218     c_ust_aoc                           = 13,
00220     c_ust_ccp                           = 14,
00222     c_ust_cbmi                          = 15,
00224     c_ust_cbmir                         = 16,
00226     c_ust_gid_level1                    = 17,
00228     c_ust_gid_level2                    = 18,
00230     c_ust_spn                           = 19,
00232     c_ust_plmnwact                      = 20,
00234     c_ust_msisdn                        = 21,
00236     c_ust_image                         = 22,
00238     c_ust_notused                       = 23,
00240     c_ust_emlpp                         = 24,
00242     c_ust_auto_emlpp                    = 25,
00244     c_ust_rfu                           = 26,
00246     c_ust_gsm_access                    = 27,
00248     c_ust_datadownload_smspp            = 28,
00250     c_ust_datadownload_smscb            = 29,
00252     c_ust_callcontrol_usim              = 30,
00254     c_ust_mosmscontrol_usim             = 31,
00256     c_ust_runat_command                 = 32,
00258     c_ust_set_to_1                      = 33,
00260     c_ust_est                           = 34,
00262     c_ust_acl                           = 35,
00264     c_ust_dck                           = 36,
00266     c_ust_coop_network_list             = 37,
00268     c_ust_gsm_security_context          = 38,
00270     c_ust_cpbcch_info                   = 39,
00272     c_ust_inv_scan                      = 40,
00274     c_ust_mexe                          = 41,
00276     c_ust_opcont_plmnwact               = 42,
00278     c_ust_hplmnwact                     = 43,
00280     c_ust_ext5                          = 44,
00282     c_ust_plmn_networkname              = 45,
00284     c_ust_op_plmnlist                   = 46,
00286     c_ust_mbdn                          = 47,
00288     c_ust_mwis                          = 48,
00290     c_ust_cfis                          = 49,
00292     c_ust_res                           = 50,
00294     c_ust_spdi                          = 51,
00296     c_ust_mms                           = 52,
00298     c_ust_ext8                          = 53,
00300     c_ust_callcontrol_gprs_usim         = 54,
00302     c_ust_mms_ucp                       = 55,
00304     c_ust_nia                           = 56,
00306     c_ust_vgcs                          = 57,
00308     c_ust_vbs                           = 58,
00310     c_ust_pseudonym                     = 59,
00312     c_ust_user_plmn_sel_wlan_access     = 60,
00314     c_ust_operator_plmn_sel_wlan_access = 61,
00316     c_ust_user_wsid_list                = 62,
00318     c_ust_operator_wsid_list            = 63,
00320     c_ust_vgcs_security                 = 64,
00322     c_ust_vbs_security                  = 65,
00324     c_ust_wlan_reauthentication         = 66,
00326     c_ust_mms_storage                   = 67,
00328     c_ust_generic_bootstrapping         = 68,
00330     c_ust_mbms_security                 = 69,
00332     c_ust_datadownload_ussd_appl        = 70,
00334     c_ust_equivalent_hplmn              = 71
00335
00336 };
00337
00338 #if defined(APOXI_ICC_USIM)
00339
00353 class UstProvider : public ThreadSafeProvider
00354 {
00355     public:
00356         typedef ThreadSafeProvider Base;
00357
00359         UstProvider();
00361         virtual ~UstProvider();
00363         virtual INT GetProviderId() const;
00365         void Init(SimAuxHandler * aux_handler, Protector * protector);
00367         virtual INT RowCount();
00369         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00371         virtual BOOLEAN Update(ProviderListener * listener = 0);
00372
00373     private:
00374         SimAuxHandler * m_aux_handler;
00375 };
00376
00377 #endif
00378
00381 enum EstTableIndexes {
00383     c_est_fdn                           = 1,
00385     c_est_bdn                           = 2,
00387     c_est_apn_acl                       = 3,
00388
00389 };
00390
00391 #if defined(APOXI_ICC_USIM)
00392
00406 class EstProvider : public ThreadSafeProvider
00407 {
00408     public:
00409         typedef ThreadSafeProvider Base;
00410
00412         EstProvider();
00414         virtual ~EstProvider();
00416         virtual INT GetProviderId() const;
00418         void Init(SimAuxHandler * aux_handler, Protector * protector);
00420         virtual INT RowCount();
00422         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00424         virtual BOOLEAN Update(ProviderListener * listener = 0);
00425
00426     private:
00427         SimAuxHandler * m_aux_handler;
00428 };
00429
00430 #endif
00431
00432 /* SimServices is the module which allow checking if certain services on SIM are enabled or not.
00433 It works independent if an SIM or USIM is inserted by checking the SST or UST/EST. New
00434 enumerations have to be introduced as the enumeration of SST and UST are not compatible.*/
00435
00438 enum SimServiceId {
00440     SimServiceChv1Disable,
00442     SimServiceAdn,
00444     SimServiceFdn,
00446     SimServiceBdn,
00448     SimServiceMsisdn,
00450     SimServiceLnd,
00452     SimServiceSms,
00454     SimServiceAoc,
00456     SimServicePrefPlmn,
00458     SimServicePlmnwAct,
00460     SimServiceSmsParameter,
00462     SimServiceSdn,
00464     SimServiceCbmi,
00466     SimServiceCbmiRanges,
00468     SimServiceSpn,
00470     SimServiceImages,
00472     SimServiceMexe,
00474     SimServicePnn,
00476     SimServiceOpl,
00478     SimServiceMbdn,
00480     SimServiceMwis,
00482     SimServiceCfis,
00484     SimServiceSpdi,
00485
00487     SimServiceInvalid
00488 };
00489
00490 class SimServices
00491 {
00492     public:
00493         SimServices();
00494         virtual ~SimServices();
00495         void Init(SimAuxHandler * aux_handler);
00496         BOOLEAN IsSimServiceEnabled(SimServiceId id, BOOLEAN & isenabled);
00497
00498     private:
00499         SimAuxHandler * m_aux_handler;
00500 };
00501
00502
00503
00505 #endif
00506
00507
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StatusProvider.cpp File Reference

Adc/StatusProvider.cpp File Reference

#include "Adc/PreComp.hpp"
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/TimeZone.hpp>
#include <stack/driver.h>
#include "StatusProvider.hpp"

Include dependency graph for StatusProvider.cpp:

Generated on Tue Jan 24 15:27:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StatusProvider.hpp File Reference

Adc/StatusProvider.hpp File Reference

#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Adc/ProvIds.hpp>

Include dependency graph for StatusProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StatusProvider

Defines

#define | Adc_StatusProvider_hpp

Define Documentation

#define Adc_StatusProvider_hpp

Generated on Tue Jan 24 15:27:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StatusProvider.hpp Source File

Adc/StatusProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_StatusProvider_hpp)
00015 #define Adc_StatusProvider_hpp
00019
00020 #include <Auxiliary/ThreadSafeProvider.hpp>
00021
00022 #include <Apc/NetworkTypes.hpp>
00023
00024 #include <Adc/ProvIds.hpp>
00025
00026
00027 /*------------------------------------------------------------------
00028                             StatusProvider
00029  ------------------------------------------------------------------*/
00030
00071 class StatusProvider : public ThreadSafeProvider
00072 {
00073     public:
00074         typedef ThreadSafeProvider Base;
00076         StatusProvider();
00078         virtual ~StatusProvider();
00080         virtual INT GetProviderId() const;
00082         virtual INT RowCount();
00084         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00086         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00088         virtual BOOLEAN CommitRow(INT row);
00089
00090         void Reset();
00091
00092 // this method sets an initial value for the concateneted sms
00093         void SetMaxConcRefNo(UINT16 refno) { m_succ_16bit_conc_sms_ref_no = refno; }
00094
00095 // this methods are called by ASC therefore they are inline, used once
00096         void SetLastCcm(UINT32 last_ccm) { m_last_ccm= last_ccm; }
00097         void GetLastCcm(UINT32 &last_ccm) { last_ccm= m_last_ccm; }
00098         // for Line2 when using ALS
00099         void SetLastCcm2(UINT32 last_ccm) { m_last_ccm2= last_ccm; }
00100         // for Line2 when using ALS
00101         void GetLastCcm2(UINT32 &last_ccm) { last_ccm= m_last_ccm2; }
00102         void SetTimeZone(const TimeZone &timezone);
00103         void GetTimeZone(TimeZone &timezone);
00104         void GetLsaIdentifier(LsaIdentifier &lsaidentifier) { lsaidentifier = m_lsaidentifier; }
00105         void SetLsaIdentifier(const LsaIdentifier &lsaidentifier) { m_lsaidentifier = lsaidentifier; }
00106         void GetIsLsaIdentifierPresent(BOOLEAN & lsaidentifier) { lsaidentifier = m_islsaidentifierpresent; }
00107         void SetIsLsaIdentifierPresent(const BOOLEAN lsaidentifier) { m_islsaidentifierpresent = lsaidentifier; }
00108         void SetNetworkNameLong(const WString &network_name_long) { m_network_name_long = network_name_long; }
00109         void GetNetworkNameLong(WString &network_name_long) { network_name_long = m_network_name_long; }
00110         void SetNetworkNameShort(const WString &network_name_short) { m_network_name_short= network_name_short; }
00111         void GetNetworkNameShort(WString &network_name_short) { network_name_short= m_network_name_short; }
00112         void SetBatteryLoadLevel(const BatteryLoadLevel level) { m_battery_load = level; }
00113         void SetRegisterMode(const RegisterMode mode) { m_registration_mode = mode; }
00114         void SetRegisterStatus(const RegisterStatus status) { m_registration_state = status; }
00115         void SetRegisteredPlmn(const Plmn & plmn) { m_registered_plmn = plmn; }
00116         void SetRegisterRejectCause(const RegisterRejectCause rejectcause) { m_registration_reject_cause = rejectcause; }
00117         void SetSignalStrengthLevel(const SignalStrengthLevel signalstrength) { m_signal_strength = signalstrength; };
00118         void SetSignalQualityLevel(const SignalQualityLevel signalquality) {m_signal_quality = signalquality; }
00119         void SetGprsAttached(BOOLEAN gprs_attached) { m_gprs_attached = gprs_attached; }
00120         void SetLai(const Lai & lai) { m_lai = lai; }
00121         void SetCellId(const CellId & cellid) { m_cellid = cellid; }
00122         void SetGprsClass(const GprsClass gprs_class) { m_gprs_class = gprs_class; }
00123         void SetGprsClassChangeOrigin(const ProcessSource gprs_class_change_origin) { m_gprs_class_change_origin = gprs_class_change_origin; }
00124         void SetRadioAccessTechnology(const RadioAccessTechnology rat)  { m_rat = rat; }
00125         void SetRatChangeMode(const RatChangeMode mode) { m_rat_change_mode = mode; }
00126         void SetGsmBand(const GsmBand band) { m_gsm_band = band; }
00127         Plmn GetRegisteredPlmn() const { return m_registered_plmn; }
00129         void GetRegisteredPlmn(Plmn &plmn) { plmn = m_registered_plmn; }
00130
00131         UINT16 GetRegisteredLac() const { return m_lai.lac; }
00132
00133
00134         BatteryLoadLevel GetBatteryLoadLevel(){return m_battery_load;}
00135         SignalStrengthLevel GetSignalStrengthLevel(){return m_signal_strength;}
00136         SignalQualityLevel GetSignalQualityLevel(){return m_signal_quality;}
00137
00138         void SetSignalStrengthMax(const SignalStrengthMax signalstrength){m_signal_strength_max = signalstrength;}
00139         void SetSignalQualityMax(const SignalQualityMax signalquality){m_signal_quality_max = signalquality;}
00140         SignalStrengthMax GetSignalStrengthMax(){return m_signal_strength_max;}
00141         SignalQualityMax GetSignalQualityMax(){return m_signal_quality_max;}
00142
00143         RadioAccessTechnology GetRadioAccessTechnology(){return m_rat;}
00144         RatChangeMode GetRatChangeMode(){return m_rat_change_mode;}
00145         GsmBand GetGsmBand(){return m_gsm_band;}
00146
00147         // Get the calibration status of the eeprom
00148         void GetEepCalibrationStatus(BOOLEAN &eep_calibration_status);
00149         void SetPowerMode(PowerMode power_mode){m_power_mode = power_mode;}
00150         PowerMode GetPowerMode(){return m_power_mode;}
00151
00152         void SetCfuServiceArray(const CfuServiceArray & servicearray) {
00153             m_cfu_servicearray = servicearray;
00154         }
00155         const CfuServiceArray & GetCfuServiceArray() const {
00156             return m_cfu_servicearray;
00157         }
00158
00159         void SetScanStatus(BOOLEAN scan_status){ m_scan_status = scan_status; }
00160         BOOLEAN GetScanStatus(){ return m_scan_status; }
00161
00162     private:
00163         RegisterMode         m_registration_mode;           // registration mode
00164         RegisterStatus       m_registration_state;          // registration state
00165         RegisterRejectCause  m_registration_reject_cause;   // registration reject  cause
00166         Plmn                 m_registered_plmn;             // registered plmn
00167         SignalStrengthLevel  m_signal_strength;             // radio signal strength level
00168         SignalQualityLevel   m_signal_quality;              // radio signal quality level (only valid on active calls)
00169         SignalStrengthMax    m_signal_strength_max;             // maximum possible radio signal strength level
00170         SignalQualityMax     m_signal_quality_max;              // maximum possible radio signal quality level (only valid on active calls)
00171
00172         BatteryLoadLevel     m_battery_load;                // battery  load level
00173         WString              m_network_name_long;           // network information long
00174         WString              m_network_name_short;          // network information short
00175         BOOLEAN              m_gprs_attached;               // indicates if gprs service is attached
00176         INT                  m_tz_offset;                   // time zone offset from UT (GMT) in units of 15 minutes
00177         UINT8                m_tz_dst;                      // daylight saving time (adjustment can be +1h of +2h)
00178         LsaIdentifier        m_lsaidentifier;               // LSA (Localized Service Area) Identifier (from MM_INFORMATION message, TS 24.008)
00179         BOOLEAN              m_islsaidentifierpresent;      // indicates, if LSA (Localized Service Area) Identifier is present
00180         UINT16               m_succ_16bit_conc_sms_ref_no;  // successive 16-bit reference counter for concatenated sms (should be stored permanent)
00181         UINT32               m_last_ccm;                    // last current call meter of AOCI
00182         UINT32               m_last_ccm2;                   // last current call meter of AOCI for line 2 (ALS)
00183         Lai                  m_lai;                         // location area information
00184         CellId               m_cellid;                      // cell id from CellInfoIndArg
00185         GprsClass            m_gprs_class;                  // current active GPRS mobile class
00186         ProcessSource        m_gprs_class_change_origin;    // process source, which initiatiated last gprs class change
00187         RadioAccessTechnology m_rat;
00188         RatChangeMode           m_rat_change_mode;
00189         GsmBand                 m_gsm_band;
00190
00191 // these settings has to be implemented in NVRAM
00192         ClirMode             m_clir_mode;                   // Clir mode setting
00193         BOOLEAN              m_redialing_active;            // Redialing mode setting
00194
00195 // settings of eeprom
00196         BOOLEAN             m_eep_calibration_status;       // Calibration status of eeprom
00197         PowerMode           m_power_mode;                   // current power mode
00198         GsmService          m_pref_service;
00199         CfuServiceArray     m_cfu_servicearray;             // CFU flags array, accessed via DataHandler
00200         BOOLEAN             m_scan_status;                  //Plmn-scan in progress
00201
00202
00203 };
00204
00206 #endif
00207
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StorageDevice.hpp File Reference

Adc/StorageDevice.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:27:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StorageDevice.hpp Source File

Adc/StorageDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/StorageDevice.hpp. Please use " \
00010     "Afs/Rfs/StorageDevice.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/StorageDevice.hpp>
00014 #else
00015     #error Adc/StorageDevice.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StorageDeviceFilter.hpp File Reference

Adc/StorageDeviceFilter.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 15:27:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StorageDeviceFilter.hpp Source File

Adc/StorageDeviceFilter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/StorageDeviceFilter.hpp. Please use " \
00010     "Afs/Rfs/StorageDeviceFilter.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/StorageDeviceFilter.hpp>
00014 #else
00015     #error Adc/StorageDeviceFilter.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StorageDeviceIterator.hpp File Reference

Adc/StorageDeviceIterator.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 15:27:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StorageDeviceIterator.hpp Source File

Adc/StorageDeviceIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/StorageDeviceIterator.hpp. Please use " \
00010     "Afs/Rfs/StorageDeviceIterator.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/StorageDeviceIterator.hpp>
00014 #else
00015     #error Adc/StorageDeviceIterator.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StorageDeviceVisitor.hpp File Reference

Adc/StorageDeviceVisitor.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 15:27:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/StorageDeviceVisitor.hpp Source File

Adc/StorageDeviceVisitor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Adc/StorageDeviceVisitor.hpp. Please use " \
00010     "Afs/Rfs/StorageDeviceVisitor.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/StorageDeviceVisitor.hpp>
00014 #else
00015     #error Adc/StorageDeviceVisitor.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/Types.hpp File Reference

Adc/Types.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Adc_Types_hpp

Enumerations

enum | BootNotification { BootNoRequest, BootFinishedNotification, BootLoadNotification, BootNotAvailable }
enum DataControlType {
SimAdnPhonebook, SimFdnPhonebook, SimMsisdnPhonebook, SimLndPhonebook,
SimCphsMBoxPhonebook, SimCphsInfoNoPhonebook, SimSdnPhonebook, SimBdnPhonebook,
SimMbdnPhonebook, SimSmsParameters, SimSms, SimPreferedLanguages,
SimPreferedExtLanguages, SimPreferedPlmns, SimPuct, SimAcm,
SimAcmMax, SimSst, SimImsi, SimSpn,
SimEcc, SimCphsInfo, SimCphsOpName, SimCphsOpShortName,
SimCphsCsp, SimCbmi, SimCbmiRange, SimCcp,
UsimPhonebook, DynamicAlsFlags, SimAll
}

Define Documentation

#define Adc_Types_hpp

Generated on Tue Jan 24 15:27:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/Types.hpp Source File

Adc/Types.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Adc_Types_hpp)
00009 #define Adc_Types_hpp
00012
00013 /*  ========================================================================
00014     DataControlType
00015     ======================================================================== */
00016
00020 enum DataControlType
00021 {
00023     SimAdnPhonebook,
00025     SimFdnPhonebook,
00027     SimMsisdnPhonebook,
00029     SimLndPhonebook,
00031     SimCphsMBoxPhonebook,
00033     SimCphsInfoNoPhonebook,
00035     SimSdnPhonebook,
00037     SimBdnPhonebook,
00039     SimMbdnPhonebook,
00041     SimSmsParameters,
00043     SimSms,
00045     SimPreferedLanguages,
00047     SimPreferedExtLanguages,
00049     SimPreferedPlmns,
00051     SimPuct,
00053     SimAcm,
00055     SimAcmMax,
00057     SimSst,
00059     SimImsi,
00061     SimSpn,
00063     SimEcc,
00065     SimCphsInfo,
00067     SimCphsOpName,
00069     SimCphsOpShortName,
00071     SimCphsCsp,
00073     SimCbmi,
00075     SimCbmiRange,
00077     SimCcp,
00079     UsimPhonebook,
00081     DynamicAlsFlags,
00083     SimAll
00084 };
00085
00086
00087 /*  ========================================================================
00088     BootNotification
00089     ======================================================================== */
00090
00093 enum BootNotification
00094 {
00096     BootNoRequest,
00098     BootFinishedNotification,
00100     BootLoadNotification,
00102     BootNotAvailable,
00103 };
00104
00105
00107 #endif  // Asc_Types_hpp
00108
00109
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbAccessor.cpp File Reference

Adc/UsimPbAccessor.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for UsimPbAccessor.cpp:

Generated on Tue Jan 24 16:19:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbAccessor.hpp File Reference

Adc/UsimPbAccessor.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbAcessor_hpp

Define Documentation

#define Adc_UsimPbAcessor_hpp

Generated on Tue Jan 24 16:19:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbAccessor.hpp Source File

Adc/UsimPbAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Adc_UsimPbAcessor_hpp)
00009 #define Adc_UsimPbAcessor_hpp
00010
00011 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00012
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Kernel/UserDispatcher.hpp>
00018 #include <Kernel/MessageReferrer.hpp>
00019 #include <Kernel/Os/Mutex.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Apc/UsimPbTypes.hpp>
00022 #include <Adc/SimAccessor.hpp>
00023
00025 //
00026 //
00027 //  USIM PB Simulation
00028 //
00029 //
00031
00032 #if defined(APOXI_USIM_PB_SIMULATION)
00033     // maximum record size
00034     const INT c_max_record_size =   254;
00035     // ADN description
00036     const INT c_no_adn_files    =   2;
00037     const INT c_no_adn1_recs    =   200;
00038     const INT c_no_adn2_recs    =   150;
00039
00040     const INT c_no_adn_all      =   c_no_adn1_recs+c_no_adn2_recs;
00041
00042     const INT c_no_adn1_rec_size=   36;
00043     const INT c_no_adn2_rec_size=   34;
00044     // GAS description
00045     const INT c_no_gas_recs =   10;
00046     const INT c_no_gas_rec_size =   20;
00047     // AAS description
00048     const INT c_no_aas_recs =   6;
00049     const INT c_no_aas_rec_size =   20;
00050     // ANR description
00051     const INT c_no_anr_per_rec  =   3;
00052     const INT c_no_anr_rec_size =   15;
00053     // GRP description
00054     const INT c_no_grp_rec_size =   6;
00055     // SNE description
00056     const INT c_no_sne_per_rec  =   2;
00057     const INT c_no_sne_rec_size =   100;
00058     // EMAIL description
00059     const INT c_no_email_per_rec=   2;
00060     const INT c_no_email_rec_size=  100;
00061
00062     struct AdnRecord {
00063         UINT8 m_data[c_max_record_size];
00064     };
00065     struct GasRecord {
00066         UINT8 m_data[c_no_gas_rec_size];
00067     };
00068     struct AasRecord {
00069         UINT8 m_data[c_no_aas_rec_size];
00070     };
00071     struct GrpRecord {
00072         UINT8 m_data[c_no_grp_rec_size];
00073     };
00074     struct AnrRecord {
00075         UINT8 m_data[c_no_anr_rec_size];
00076     };
00077     struct SneRecord {
00078         UINT8 m_data[c_no_sne_rec_size];
00079     };
00080     struct EmailRecord {
00081         UINT8 m_data[c_no_email_rec_size];
00082     };
00083
00084     struct SimulAdn {
00085         AdnRecord   m_rec[c_no_adn_all];
00086         GrpRecord   m_grp[c_no_adn_all];
00087         AnrRecord   m_anr[c_no_adn_all][c_no_anr_per_rec];
00088         SneRecord   m_sne[c_no_adn_all][c_no_sne_per_rec];
00089         EmailRecord m_email[c_no_adn_all][c_no_email_per_rec];
00090         UINT16      m_uid[c_no_adn_all];
00091         UINT8       m_hiddenkey[c_no_adn_all];
00092     };
00093     struct SimulGas {
00094         GasRecord m_rec[c_no_gas_recs];
00095     };
00096     struct SimulAas {
00097         AasRecord m_rec[c_no_aas_recs];
00098     };
00099 #endif
00100
00102 //
00103 //
00104 //  UsimPbAccessor
00105 //
00106 //
00108
00109 class UsimPbAccessor
00110 {
00111     public:
00112
00113         UsimPbAccessor();
00114         virtual ~UsimPbAccessor();
00115
00116         void Init(SimAccessor * sim_accessor);
00117         void Reset();
00118
00119         static BOOLEAN IsUsimAccessAllowed() {
00120 #if defined(APOXI_USIM_PB_SIMULATION)
00121             return SimAccessor::IsSimAccessAllowed();
00122 #else
00123             return SimAccessor::IsSimAccessAllowed() && SimAccessor::IsUsimInserted();
00124 #endif
00125         }
00126
00127         BOOLEAN IsUsimPbSelected() const { return m_selected_location!=UsimPbNotSelected; }
00128
00129         UsimPbLocation GetSelectedUsimPb() const { return m_selected_location; }
00130
00131         // this is directly called from APC to set the data necessary in time
00132         void SetUsimPbSelection(UsimPbLocation location, const T_PB_DESCRIPTOR & desc) {
00133             m_selected_location = location;
00134             m_desc = desc;
00135         }
00136
00138
00139         // get information about the phonebooks
00140         UsimPbResult GetLocation(UsimPbLocReport & report);
00141         // select a phonebook and retrieve information
00142         UsimPbResult SelectLocation(UsimPbLocation location, BOOLEAN cachefilling);
00143         // read a phonebook record
00144         UsimPbResult ReadPbRecord(INT recno,
00145                                   UsimPbRwRecord & record,
00146                                   UsimPbRefRecord & refrecord);
00147         // update a phonebook record
00148         UsimPbResult UpdatePbRecord(INT recno,
00149                                     INT startrecno,
00150                                     const UsimPbChangedField & changes,
00151                                     const UsimPbRwRecord & record,
00152                                     UINT16 & uid);
00153         // read linked data of a phonebook record
00154         UsimPbResult ReadRefData(UsimPbRefType reftype,
00155                                  INT recno,
00156                                  INT ref_recno,
00157                                  INT handle,
00158                                  T_DATA & data);
00159         // update linked data of a phonebook record
00160         UsimPbResult UpdateRefData(UsimPbRefType reftype,
00161                                    INT recno,
00162                                    INT & ref_recno,
00163                                    INT handle,
00164                                    const T_DATA & data);
00165         // read additional data type 3 files
00166         UsimPbResult ReadAddData(UsimPbAddType type,
00167                                  INT handle,
00168                                  INT recno,
00169                                  T_DATA & data);
00170         // update additional data type 3 files
00171         UsimPbResult UpdateAddData(UsimPbAddType type,
00172                                    INT handle,
00173                                    INT recno,
00174                                    T_DATA & data);
00175         // get the fill status
00176         UsimPbResult UpdateFillStatus();
00177         // stops the usim phonebook
00178         UsimPbResult UsimPbStop();
00179
00180         // indicates a change
00181         void IndicateChange() { m_change_indication = TRUE; }
00182
00183
00184
00185         static BOOLEAN HasParamAttribute(StackMsgArgId id);
00186         static BOOLEAN HasParam(StackMsgArgument * arg, UINT32 param);
00187
00189
00190         // returns the number of ADN files within the phonebook, an ADN file together
00191         // with other files of phonebook we call a "slice"
00192         UINT GetSliceCount() const;
00193         // returns the number of ADN records of all ADN files
00194         UINT GetTotalRecordCount() const;
00195         // returns the slice number which the recno belongs to
00196         UINT GetSliceNo(UINT recno) const;
00197
00198         // return the record size of the ADN of a slice
00199         UINT GetAdnRecordSize(UINT slice) const;
00200         // return the maximum record size of all ADNs
00201         UINT GetMaxAdnRecordSize() const;
00202         // return the alpha identifier size of the ADN of a slice
00203         UINT GetAdnAlphaIdSize(UINT slice) const;
00204         // return the record count of the ADN of a slice
00205         UINT GetAdnRecordCount(UINT slice) const;
00206         // return the used record count of the ADN of a slice
00207         UINT GetAdnUsedRecordCount(UINT slice) const;
00208         // return the free record count of the ADN of a slice
00209         UINT GetAdnFreeRecordCount(UINT slice) const;
00210         // get the number of possible EXT records
00211         UINT GetExtRecordCount(UINT slice) const;
00212         // get the number of used EXT records
00213         UINT GetExtUsedRecordCount(UINT slice) const;
00214         // get the number of free EXT records
00215         UINT GetExtFreeRecordCount(UINT slice) const;
00216
00217         // return the maximum number of groups per ADN record for all slices
00218         UINT GetMaxGroupPerAdnEntry() const;
00219         // return the number of group per ADN record of a slice, can be 0 if no groups
00220         // are supported then also no GAS is present
00221         UINT GetGroupPerAdnEntry(UINT slice) const;
00222         // return the GAS record size / count of a slice, current implementation only uses the
00223         // information of slice 0, because the assumption is that only one shared EF-GAS exists
00224         BOOLEAN IsGasSupported(UINT slice = 0) const;
00225         UINT GetGasRecordSize(UINT slice = 0) const;
00226         UINT GetGasRecordCount(UINT slice = 0) const;
00227         UINT GetGasUsedRecordCount(UINT slice = 0) const;
00228         UINT GetGasFreeRecordCount(UINT slice = 0) const;
00229         INT  GetGasHandle(UINT slice = 0) const;
00230
00231         // return the AAS record size / count of a slice, current implementation only uses the
00232         // information of slice 0, beacuse the assumption is that only one shared EF-AAS exists
00233         BOOLEAN IsAasSupported(UINT slice = 0) const;
00234         UINT GetAasRecordSize(UINT slice = 0) const;
00235         UINT GetAasRecordCount(UINT slice = 0) const;
00236         UINT GetAasUsedRecordCount(UINT slice = 0) const;
00237         UINT GetAasFreeRecordCount(UINT slice = 0) const;
00238         INT GetAasHandle(UINT slice = 0) const;
00239
00240         // indicates if hidden key information is supported, indicates if file EF-PBC is present
00241         BOOLEAN IsHiddenKeySupported() const;
00242         // indicates if phonebook control is supported, indicates presence of EF-UID etc.
00243         BOOLEAN IsSyncSupported() const;
00244
00245         // ANR
00246         // return the number of ANRs per ADN record supported, can be 0
00247         UINT GetAnrPerAdnEntry() const;
00248         // returns the to be used handle when reading/updating an entry
00249         INT GetAnrHandle(UINT slice, UINT entityno);
00250         // returns the recordsize which shall be used for allocating memory for the transfer buffer
00251         // this size also include the additional 2 bytes for SFI and record identifier
00252         UINT8 GetAnrRecordSize(UINT slice, UINT entityno);
00253         // returns the total number of ANR records
00254         UINT GetAnrRecordCount(UINT slice, UINT entityno) const;
00255         // returns the used number of ANR records
00256         UINT GetAnrUsedRecordCount(UINT slice, UINT entityno) const;
00257         // returns the free number of ANR records
00258         UINT GetAnrFreeRecordCount(UINT slice, UINT entityno) const;
00259         // returns the linktype if Type2/Type3 then the last two bytes of record shall be ignored
00260         UsimPbLinkType GetAnrFileType(UINT slice, UINT entityno);
00261
00262         // SNE
00263         // return the number of SNEs per ADN record supported, can be 0
00264         UINT GetSnePerAdnEntry() const;
00265         // returns the to be used handle when reading/updating an entry
00266         INT GetSneHandle(UINT slice, UINT entityno);
00267         // returns the recordsize which shall be used for allocating memory for the transfer buffer
00268         // this size also include the additional 2 bytes for SFI and record identifier
00269         UINT8 GetSneRecordSize(UINT slice, UINT entityno);
00270         // returns the total number of SNE records
00271         UINT GetSneRecordCount(UINT slice, UINT entityno) const;
00272         // returns the used number of SNE records
00273         UINT GetSneUsedRecordCount(UINT slice, UINT entityno) const;
00274         // returns the free number of SNE records
00275         UINT GetSneFreeRecordCount(UINT slice, UINT entityno) const;
00276         // returns the linktype if Type2/Type3 then the last two bytes of record shall be ignored
00277         UsimPbLinkType GetSneFileType(UINT slice, UINT entityno);
00278
00279         // EMAIL
00280         // return the number of emails per ADN record supported, can be 0
00281         UINT GetEmailPerAdnEntry() const;
00282         // returns the to be used handle when reading/updating an entry
00283         INT GetEmailHandle(UINT slice, UINT entityno);
00284         // returns the recordsize which shall be used for allocating memory for the transfer buffer
00285         // this size also include the additional 2 bytes for SFI and record identifier
00286         UINT8 GetEmailRecordSize(UINT slice, UINT entityno);
00287         // returns the total number of SNE records
00288         UINT GetEmailRecordCount(UINT slice, UINT entityno) const;
00289         // returns the used number of SNE records
00290         UINT GetEmailUsedRecordCount(UINT slice, UINT entityno) const;
00291         // returns the free number of SNE records
00292         UINT GetEmailFreeRecordCount(UINT slice, UINT entityno) const;
00293         // returns the linktype if Type2/Type3 then the last two bytes of record shall be ignored
00294         UsimPbLinkType GetEmailFileType(UINT slice, UINT entityno);
00295
00296     private:
00297         SimAccessor *    m_sim_accessor;
00298         T_PB_DESCRIPTOR  m_desc;
00299         UsimPbLocation   m_selected_location;
00300         UsimPbFillStatus m_fill_status;
00301         BOOLEAN          m_change_indication;
00302
00303 #if defined(APOXI_USIM_PB_SIMULATION)
00304         SimulAdn m_adn;
00305         SimulGas m_gas;
00306         SimulAas m_aas;
00307         void GenerateTestData();
00308 #endif
00309
00310 };
00311
00313
00314 #endif // APOXI_ENABLE_USIM_PHONEBOOK
00315
00316 #endif // Adc_UsimPbAcessor_hpp
00317
Generated on Tue Jan 24 14:44:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbAddData.cpp File Reference

Adc/UsimPbAddData.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for UsimPbAddData.cpp:

Generated on Tue Jan 24 16:19:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbAddData.hpp File Reference

Adc/UsimPbAddData.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbAddData_hpp

Define Documentation

#define Adc_UsimPbAddData_hpp

Generated on Tue Jan 24 16:19:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbAddData.hpp Source File

Adc/UsimPbAddData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_UsimPbAddData_hpp)
00010 #define Adc_UsimPbAddData_hpp
00011
00012 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00013
00017
00018 #include <Auxiliary/WString.hpp>
00019 #include <Auxiliary/PhoneNumber.hpp>
00020 #include <Auxiliary/DataItem.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     UsimPbAddData
00024     ------------------------------------------------------------------------ */
00025 // allow hold various number of data items of the sam type. The behaviour is
00026 // controlled by the number of entries and columns. A pointer array with
00027 // entries*columns is always allocated, this array is type checked with the parameter
00028 // DataType. If misused, assertions are thrown. This container class is used
00029 // for SNE, ANR, EMAIL entries.
00030
00031 class UsimPbAddData
00032 {
00033     // a union which can be either a pointer to a wstring or a phonenumber object
00034     struct UsimPbAddDataItem
00035     {
00036         union {
00037             PhoneNumber * m_phno;
00038             WString * m_wstr;
00039         } m_val;
00040     };
00041
00042     public:
00043         UsimPbAddData();
00044         ~UsimPbAddData(); // destructor not virtual !!!
00045
00046         // creates a dynamically array which contain pointers to objects of DataType
00047         BOOLEAN Init(UINT entries, UINT columns, DataType type);
00048
00049         // get the WString if existing, otherwise an empty WString object
00050         const WString & GetWString(UINT idx, UINT column) const;
00051         // set the WString object, if it is empty, then object which was pointed to is deleted
00052         void SetWString(UINT idx, UINT column, const WString & wstr);
00053
00054         // get the PhoneNumber if existing, otherwise an empty WString object
00055         const PhoneNumber & GetPhoneNumber(UINT idx, UINT column) const;
00056         // set the PhoneNumber object, if it is empty, then object which was pointed to is deleted
00057         void SetPhoneNumber(UINT idx, UINT column, const PhoneNumber & phno);
00058
00059         // get the recno of the item
00060         UINT8 GetRecno(UINT idx, UINT column) const;
00061         // set the recno of the item
00062         void SetRecno(UINT idx, UINT column, UINT8 recno);
00063
00064         // returns TRUE if the object is ready for operation
00065         BOOLEAN IsReady() const { return (m_ptrs!=0); }
00066
00067         // static empty objects which are used for returning empty objects in case ptr = 0
00068         static const WString     c_empty_wstr;
00069         static const PhoneNumber c_empty_phno;
00070
00071     private:
00072         DataType m_type;
00073         UINT     m_entries;
00074         UINT     m_columns;
00075         UsimPbAddDataItem * m_ptrs;
00076         UINT8 *  m_recnos;
00077 };
00078
00080
00081 #endif //#if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00082
00083 #endif
00084
00085
Generated on Tue Jan 24 14:44:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbCommit.hpp File Reference

Adc/UsimPbCommit.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbCommit_hpp

Define Documentation

#define Adc_UsimPbCommit_hpp

Generated on Tue Jan 24 16:19:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbCommit.hpp Source File

Adc/UsimPbCommit.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_UsimPbCommit_hpp)
00010 #define Adc_UsimPbCommit_hpp
00011
00012 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00013
00017
00018 #include <Auxiliary/WString.hpp>
00019 #include <Auxiliary/PhoneNumber.hpp>
00020 #include <Auxiliary/BitField.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Uint8CommitArray
00024     ------------------------------------------------------------------------ */
00025 // Array is used for Provider commit stuff
00026 class Uint8CommitArray
00027 {
00028     public:
00029         void Clear() {
00030             for(INT j=0; j<c_pb_max_file_type_per_record; j++) {
00031                 m_val[j] = 0;
00032             }
00033             m_set.Clear();
00034         }
00035         void Set(UINT idx, UINT8 id) {
00036             m_val[idx] = id;
00037             m_set.SetTrue(idx);
00038         }
00039         UINT8 Get(UINT idx) const {
00040             return m_val[idx];
00041         }
00042         BOOLEAN WasChanged(UINT idx) const {
00043             return m_set.GetBit(idx);
00044         }
00045         BOOLEAN IsUsed() const {
00046             return m_set.Get()!=0;
00047         }
00048
00049         UINT8       m_val[c_pb_max_file_type_per_record];
00050         BitField16  m_set;
00051 };
00052
00053 /*  ------------------------------------------------------------------------
00054     PhoneNumberCommitArray
00055     ------------------------------------------------------------------------ */
00056 // Array is used for Provider commit stuff
00057 class PhoneNumberCommitArray
00058 {
00059     public:
00060         void Clear() {
00061             for(INT j=0; j<c_pb_max_file_type_per_record; j++) {
00062                 m_val[j].Clear();
00063             }
00064             m_set.Clear();
00065         }
00066         void Set(UINT idx, const PhoneNumber & phno) {
00067             m_val[idx] = phno;
00068             m_set.SetTrue(idx);
00069         }
00070         const PhoneNumber & Get(UINT idx) const {
00071             return m_val[idx];
00072         }
00073         BOOLEAN WasChanged(UINT idx) const {
00074             return m_set.GetBit(idx);
00075         }
00076         BOOLEAN IsUsed() const {
00077             return m_set.Get()!=0;
00078         }
00079
00080         PhoneNumber m_val[c_pb_max_file_type_per_record];
00081         BitField16  m_set;
00082 };
00083
00084 /*  ------------------------------------------------------------------------
00085     WStringCommitArray
00086     ------------------------------------------------------------------------ */
00087 // Array is used for Provider commit stuff
00088 class WStringCommitArray
00089 {
00090     public:
00091         void Clear() {
00092             for(INT j=0; j<c_pb_max_file_type_per_record; j++) {
00093                 m_val[j].Clear();
00094             }
00095             m_set.Clear();
00096         }
00097         void Set(UINT idx, const WString & phno) {
00098             m_val[idx] = phno;
00099             m_set.SetTrue(idx);
00100         }
00101         const WString & Get(UINT idx) const {
00102             return m_val[idx];
00103         }
00104         BOOLEAN WasChanged(UINT idx) const {
00105             return m_set.GetBit(idx);
00106         }
00107         BOOLEAN IsUsed() const {
00108             return m_set.Get()!=0;
00109         }
00110
00111         WString     m_val[c_pb_max_file_type_per_record];
00112         BitField16  m_set;
00113 };
00114
00116
00117 #endif // APOXI_ENABLE_USIM_PHONEBOOK
00118
00119 #endif
00120
00121
Generated on Tue Jan 24 14:44:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbEntry.cpp File Reference

Adc/UsimPbEntry.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for UsimPbEntry.cpp:

Generated on Tue Jan 24 16:20:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbEntry.hpp File Reference

Adc/UsimPbEntry.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbEntry_hpp

Define Documentation

#define Adc_UsimPbEntry_hpp

Generated on Tue Jan 24 16:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbEntry.hpp Source File

Adc/UsimPbEntry.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_UsimPbEntry_hpp)
00010 #define Adc_UsimPbEntry_hpp
00011
00012 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00013
00017
00018 #include <Auxiliary/WString.hpp>
00019 #include <Auxiliary/PhoneNumber.hpp>
00020
00021 /*  ------------------------------------------------------------------------
00022     UsimPbEntry
00023     ------------------------------------------------------------------------ */
00024 // class which caches one ADN entry, WString, Phonenumber, Simpos
00025
00026 class UsimPbEntry
00027 {
00028     public:
00029         UsimPbEntry();
00030         UsimPbEntry(const UsimPbEntry & entry);
00031
00032         ~UsimPbEntry(); // destructor not virtual !!!
00033
00034         // the position on the SIM, by meaning the number used for the stack but starting with 0
00035         UINT16              GetRecNo() const { return m_recno; }
00036         // the alpha identifier as a WSstring
00037         const WString &     GetName() const { return m_name; }
00038         // the phonenumber of the ADN record
00039         const PhoneNumber & GetPhoneNumber() const { return m_phonenumber; }
00040         // checks if entry either contains a phonenumber and/or a wstring
00041         BOOLEAN             HasData() const;
00042         // fill the data entry
00043         void SetData(UINT16 recno, const PhoneNumber & phno, const WString & name);
00044         // clear the phonenumber and wstring but recno is still remaining
00045         void ClearData();
00046         // clears all member
00047         void ResetData();
00048
00049         UsimPbEntry & operator = (const UsimPbEntry & entry);
00050
00051     private:
00052         WString     m_name;
00053         PhoneNumber m_phonenumber;
00054         UINT16      m_recno;
00055 };
00056
00057 // defines an unused sim entry pointer
00058 const UsimPbEntry * const c_unread_usim_entry = (UsimPbEntry *)-1;
00059 // defines an invalid record number
00060 const UINT16 c_invalid_usim_rec_number = ~0;
00061
00062
00064
00065 #endif //#if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00066
00067 #endif
00068
00069
Generated on Tue Jan 24 14:44:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbEntryCont.cpp File Reference

Adc/UsimPbEntryCont.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for UsimPbEntryCont.cpp:

Generated on Tue Jan 24 16:20:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbEntryCont.hpp File Reference

Adc/UsimPbEntryCont.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbEntryCont_hpp

Define Documentation

#define Adc_UsimPbEntryCont_hpp

Generated on Tue Jan 24 16:20:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbEntryCont.hpp Source File

Adc/UsimPbEntryCont.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_UsimPbEntryCont_hpp)
00010 #define Adc_UsimPbEntryCont_hpp
00011
00012 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00013
00017
00018 #include <Auxiliary/FixedPtrArray.hpp>
00019 #include <Auxiliary/IndexTable.hpp>
00020 #include <Auxiliary/DynamicBitVector.hpp>
00021
00022 #include <Adc/UsimPbEntry.hpp>
00023 #include <Adc/UsimPbAddData.hpp>
00024
00025 /*  ------------------------------------------------------------------------
00026     UsimPbEntryCont
00027     ------------------------------------------------------------------------ */
00028 // container class which caches all necessary phonebook data, like
00029 // ADN, UID, SNE, EMAIL, ANR, GRP in form of other data structures
00030
00031 const INT c_invalid_usim_position = -2;
00032
00033 class UsimPbEntryCont
00034 {
00035     private:
00036         enum {
00037             BITS_PER_UINT = sizeof(UINT) * 8,
00038         };
00039
00040     public:
00041         UsimPbEntryCont(UINT nr_entries,
00042                          UINT groupsperentry,
00043                          BOOLEAN hiddeninfo,
00044                          BOOLEAN syncsupported,
00045                          UINT anrperentry,
00046                          UINT sneperentry,
00047                          UINT emailperentry,
00048                          BOOLEAN sorted = FALSE);
00049         ~UsimPbEntryCont();
00050
00051         void SetReady(BOOLEAN ready = TRUE) { m_ready = ready; }
00052         BOOLEAN IsReady() const { return m_ready; }
00053
00054         UINT GetMaxEntries() const { return m_max_entries; }
00055
00056         void Reset() { DeleteAllData(); }
00057
00058         INT  PutData(UINT recno, const PhoneNumber & phno, const WString & wstr);
00059         BOOLEAN PutAdditionalData(UINT recno, const UsimPbRwRecord & record);
00060
00061         // delete methods
00062         void DeleteData(UINT recno);
00063         void DeleteAllData();
00064         void DeleteAllObjects();
00065
00066         void DeleteAdditionalData(UINT recno);
00067
00068         UsimPbEntry * GetEntry(UINT idx) const;
00069
00070         // Hiddeninfo
00071         BOOLEAN HasHiddenInfo() const { return m_hidden_info!=0; }
00072         UINT8 GetHiddenInfo(UINT idx) const;
00073         BOOLEAN SetHiddenInfo(UINT idx, UINT8 hiddeninfo);
00074
00075         // Uid
00076         BOOLEAN HasUid() const { return m_sync_info!=0; }
00077         UINT16 GetUid(UINT idx) const;
00078         BOOLEAN SetUid(UINT idx, UINT16 uid);
00079
00080         // Group
00081         BOOLEAN HasGroups() const { return m_grouping_info!=0; }
00082         UINT8 GetGroup(UINT idx, UINT grpidx) const;
00083         BOOLEAN SetGroup(UINT idx, UINT grpidx, UINT8 grp);
00084         BOOLEAN SetGroupVector(UINT idx, UINT grplength, const UINT8 * grpvector);
00085         const UINT8 * GetGroupVector(UINT idx);
00086
00087
00088         // ANR
00089         BOOLEAN HasAnr() const { return m_anr_entries.IsReady(); }
00090         const PhoneNumber & GetAnrPhoneNumber(UINT idx, UINT anrdx) const;
00091         UINT8 GetAnrAasRecordId(UINT idx, UINT anrdx) const;
00092         UINT8 GetAnrRecno(UINT idx, UINT anridx) const;
00093         BOOLEAN SetAnr(UINT idx, UINT anrdx, const PhoneNumber & phno, UINT8 aasrecid);
00094         BOOLEAN SetAnrPhoneNumber(UINT idx, UINT anrdx, const PhoneNumber & phno);
00095         BOOLEAN SetAnrAasRecordId(UINT idx, UINT anrdx, UINT8 aasrecid);
00096         BOOLEAN SetAnrRecno(UINT idx, UINT anridx, UINT8 recno);
00097
00098         // SNE
00099         BOOLEAN HasSne() const { return m_sne_entries.IsReady(); }
00100         const WString & GetSne(UINT idx, UINT sneidx) const;
00101         BOOLEAN SetSne(UINT idx, UINT sneidx, const WString & wstr, UINT8 recno);
00102         UINT8 GetSneRecno(UINT idx, UINT sneidx) const;
00103
00104         // EMAIL
00105         BOOLEAN HasEmail() const { return m_email_entries.IsReady(); }
00106         const WString & GetEmail(UINT idx, UINT emailidx) const;
00107         BOOLEAN SetEmail(UINT idx, UINT emailidx, const WString & wstr, UINT8 recno);
00108         UINT8 GetEmailRecno(UINT idx, UINT emailidx) const;
00109
00110         INT   GetFirstFreeSimPosition();
00111         INT   GetExistingCount() { return m_effcount; }
00112
00113         void DbgOut(UINT idx) const;
00114
00115     private:
00116         FixedPtrArray<UsimPbEntry> m_entries;
00117         DynamicBitVector *         m_used_entries;
00118         UINT8 *                    m_grouping_info;
00119         UINT8 *                    m_hidden_info;
00120         UINT16 *                   m_sync_info;
00121         UINT8 *                    m_aasrecid_info;
00122         UsimPbAddData              m_anr_entries;
00123         UsimPbAddData              m_sne_entries;
00124         UsimPbAddData              m_email_entries;
00125         UINT                       m_max_entries;
00126         UINT                       m_effcount;
00127
00128         BOOLEAN                    m_sorted;
00129         BOOLEAN                    m_ready;
00130         UINT8                      m_groupsperentry;
00131         UINT8                      m_anrperentry;
00132         UINT8                      m_sneperentry;
00133         UINT8                      m_emailperentry;
00134
00135         void InsertData(UINT recno, INT simpos, const PhoneNumber & phno, const WString & wstr);
00136         INT  FindInsertPosition(const WString & wstr);
00137
00138 };
00139
00141
00142 #endif //#if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00143
00144
00145 #endif
00146
00147
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbHandler.cpp File Reference

Adc/UsimPbHandler.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for UsimPbHandler.cpp:

Generated on Tue Jan 24 16:20:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbHandler.hpp File Reference

Adc/UsimPbHandler.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbHandler_hpp

Define Documentation

#define Adc_UsimPbHandler_hpp

Generated on Tue Jan 24 16:20:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbHandler.hpp Source File

Adc/UsimPbHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_UsimPbHandler_hpp)
00010 #define Adc_UsimPbHandler_hpp
00011
00012 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00013
00017
00018 #include <Auxiliary/WString.hpp>
00019 #include <Auxiliary/PhoneNumber.hpp>
00020 #include <Auxiliary/Vector.hpp>
00021
00022 #include <Apc/SignalTypes.hpp>
00023 #include <Apc/UsimPbTypes.hpp>
00024
00025 #include <Adc/UsimPbAccessor.hpp>
00026 #include <Adc/UsimPbEntryCont.hpp>
00027 #include <Adc/UsimPbCommit.hpp>
00028
00029 /*//////////////////////////////////////////////////////////////////////////////
00030 //
00031 // UsimPbHandler
00032 //
00034
00035 class UsimPbHandler
00036 {
00037     public:
00038         // maximum supported number of records in GAS and AAS
00039         enum {
00040             c_max_supported_gas_recs = 20,
00041             c_max_supported_aas_recs = 20,
00042         };
00043
00044         // GAS WString buffer, no dyn array used because of overhead
00045         struct GasArray {
00046             WString m_wstr[c_max_supported_gas_recs];
00047         };
00048         // AAS WString buffer, no dyn array used because of overhead
00049         struct AasArray {
00050             WString m_wstr[c_max_supported_aas_recs];
00051         };
00052
00053         // constructor & desctructor
00054         UsimPbHandler();
00055         virtual ~UsimPbHandler();
00056
00057         // pointer initializing
00058         void Init(UsimPbAccessor * accessor);
00059         // is access to the USIM phoenbook allowed
00060         BOOLEAN IsUsimAccessAllowed() {
00061             return UsimPbAccessor::IsUsimAccessAllowed();
00062         }
00063
00064         // resets the data structure and clears all buffers including structure data of accessor
00065         void Reset();
00066         // clears the cached data
00067         void ClearCachedData();
00068
00069         //
00070         UsimPbAccessor * GetUsimPbAccessor() { ASSERT_DEBUG(m_pb_accessor!=0); return m_pb_accessor; }
00071         //
00072         UsimPbEntryCont * GetUsimPbEntryCont() { ASSERT_DEBUG(m_container!=0); return m_container; }
00073
00074
00075     // GAS and AAS handling
00076         // returns the number of GAS or AAS records
00077         UINT GetXasCount(UsimPbAddType type) const;
00078         // returns the records size of GAS or AAS records
00079         UINT GetXasSize(UsimPbAddType type) const;
00080         // returns the filehandle
00081         INT GetXasHandle(UsimPbAddType type) const;
00082
00083         // loads the GAS or AAS records into cache
00084         BOOLEAN RetrieveXas(UsimPbAddType type);
00085         // returns a GAS or AAS string to caller
00086         BOOLEAN GetXasRecord(UsimPbAddType type, UINT recno, WString & name) const;
00087         // updates GAS or AAS string on USIM and cache
00088         BOOLEAN UpdateXasRecord(UsimPbAddType type, UINT recno, const WString & name);
00089
00090     // phonebook handling
00091         // selects the phonebook
00092         BOOLEAN SelectPhonebook(UsimPbLocation location);
00093         // initializes the phonebook
00094         BOOLEAN InitializePhonebook();
00095         // deselects the phonebook
00096         BOOLEAN DeselectPhonebook();
00097
00098         // called from ASC to indicate that startup is now finished
00099         void StartupFinished(UsimPbResult result);
00100         // post the usim ready message (defined in ASC)
00101         void PostUsimPbReadyMsg();
00102
00103         // returns the maximúm number of ADN records
00104         INT GetMaxCount();
00105         // get the number of existing records
00106         INT GetExistingCount();
00107         // get the next free position
00108         INT GetNextFreePosition();
00109         // returns the tag size dependend of the record position
00110         INT GetTagSize(UINT simpos);
00111         // returns the alpha tag size dependned of the record poistion
00112         INT GetAlphaTagSize(UINT simpos);
00113         // loads all entries from the phonebook
00114         BOOLEAN LoadAllEntries(Provider * parentprov, ProviderListener * listener = 0);
00115         // refreshing
00116         BOOLEAN RefreshData(INT recno);
00117         void Refresh();
00118         // delete all entries
00119         BOOLEAN DeleteEntries(ProviderListener * listener = 0);
00120         // updates an entry
00121         BOOLEAN UpdateEntry(INT recno, const WString & name, const PhoneNumber & bcdnr, INT & newrow);
00122         // deletes an entry
00123         BOOLEAN DeleteEntry(INT recno);
00124         // get progress
00125         INT GetProgress() const { return m_progress; }
00126         // get one entry from the container, whereas recno is the position inside container
00127         UsimPbEntry * GetEntry(INT recno);
00128         // get the group value if available of a phonebook entry
00129         BOOLEAN GetGroup(UINT simpos, UINT idx, UINT8 & group);
00130         // set the hidden info value of a phonebook entry
00131         BOOLEAN UpdateHiddenInfo(UINT simpos, UINT8 hiddeninfo);
00132         // set the group values of a phonebook entry
00133         BOOLEAN UpdateGroups(UINT simpos, const UsimPbGroups & groups);
00134         // set the anr values of a phonebook entry
00135         BOOLEAN UpdateAnr(UINT simpos, const PhoneNumberCommitArray & anr, const Uint8CommitArray & aas);
00136         // set the sne or email values of a phonebook entry
00137         BOOLEAN UpdateRefType(UsimPbRefType type, UINT simpos, const WStringCommitArray & email);
00138         // push/refreshes an entry which comes from APC
00139         BOOLEAN PushUsimPbEntry(const UsimPbReadAsyncIndArg & arg);
00140         // refresh an data XAS entry which comes from APC
00141         BOOLEAN RefreshUsimPbDataEntry(const UsimPbReadDataAsyncIndArg & arg);
00142         // refresh reference datas which comes direct from APC
00143         BOOLEAN RefreshUsimPbRefEntry(const UsimPbReadRefAsyncIndArg & arg);
00144
00145     private:
00146         UsimPbResult LoadContainerEntry(INT recno);
00147         UsimPbResult LoadContainerRefEntries(INT recno, const UsimPbRefRecord & refrecord);
00148
00149         void ClearRwBuffer(INT length);
00150
00151         // buffers of GAS and AAS strings
00152         GasArray m_gas_entries;
00153         AasArray m_aas_entries;
00154         // states if GAS and AAS have been updated
00155         BOOLEAN     m_gas_isupdated;
00156         BOOLEAN     m_aas_isupdated;
00157
00158         INT                 m_progress;
00159         UsimPbEntryCont *   m_container;
00160         UsimPbAccessor *    m_pb_accessor;
00161         BOOLEAN             m_pbinfo_initialized;
00162         UINT8 *             m_rwbuffer;
00163         INT                 m_rwbuffer_maxlength;
00164
00165         BOOLEAN             m_refentry_loading;
00166         UsimPbResult        m_startup_result;
00167
00168 };
00169
00171
00172 #endif // APOXI_ENABLE_USIM_PHONEBOOK
00173
00174 #endif
00175
00176
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbPropertyProvider.cpp File Reference

Adc/UsimPbPropertyProvider.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for UsimPbPropertyProvider.cpp:

Generated on Tue Jan 24 16:20:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbPropertyProvider.hpp File Reference

Adc/UsimPbPropertyProvider.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbPropertyProvider_hpp

Define Documentation

#define Adc_UsimPbPropertyProvider_hpp

Generated on Tue Jan 24 16:20:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbPropertyProvider.hpp Source File

Adc/UsimPbPropertyProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_UsimPbPropertyProvider_hpp)
00015 #define Adc_UsimPbPropertyProvider_hpp
00016
00017 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00018
00022
00023 #include <Auxiliary/ThreadSafeProvider.hpp>
00024
00025 #include <Adc/ProvIds.hpp>
00026 #include <Adc/UsimPbHandler.hpp>
00027
00028 /*------------------------------------------------------------------
00029                             UsimPbPropertyProvider
00030  ------------------------------------------------------------------*/
00031
00063 class UsimPbPropertyProvider : public ThreadSafeProvider
00064 {
00065     public:
00066         typedef ThreadSafeProvider Base;
00067
00069         UsimPbPropertyProvider();
00071         virtual ~UsimPbPropertyProvider();
00073         virtual INT GetProviderId() const;
00075         void Init(UsimPbHandler * handler, Protector * protector);
00077         virtual INT RowCount();
00079         virtual INT MaxRowCount();
00081         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00083         virtual BOOLEAN Update(ProviderListener * listener = 0);
00084
00085     private:
00086         UsimPbHandler *      m_usimpb_handler;
00087 };
00088
00090
00091 #endif // APOXI_ENABLE_USIM_PHONEBOOK
00092
00093 #endif
00094
00095
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbProvider.cpp File Reference

Adc/UsimPbProvider.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for UsimPbProvider.cpp:

Generated on Tue Jan 24 16:20:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbProvider.hpp File Reference

Adc/UsimPbProvider.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbProvider_hpp

Define Documentation

#define Adc_UsimPbProvider_hpp

Generated on Tue Jan 24 16:20:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbProvider.hpp Source File

Adc/UsimPbProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_UsimPbProvider_hpp)
00015 #define Adc_UsimPbProvider_hpp
00016
00017 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00018
00022
00023 #include <Auxiliary/WString.hpp>
00024 #include <Auxiliary/PhoneNumber.hpp>
00025
00026 #include <Auxiliary/ThreadSafeProvider.hpp>
00027
00028 #include <Apc/UsimPbTypes.hpp>
00029 #include <Adc/UsimPbHandler.hpp>
00030 #include <Adc/UsimPbCommit.hpp>
00031
00032 /*------------------------------------------------------------------
00033                             UsimPbProvider
00034  ------------------------------------------------------------------*/
00035
00057 class UsimPbProvider : public ThreadSafeProvider
00058 {
00059     public:
00060         typedef ThreadSafeProvider Base;
00062         UsimPbProvider();
00064         virtual ~UsimPbProvider();
00065
00066         void Init(UsimPbHandler * handler, Protector * protector);
00068         virtual INT RowCount();
00070         virtual INT MaxRowCount();
00072         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00074         virtual const WString * GetWString(INT columnid, INT row);
00076         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00078         virtual BOOLEAN Update(ProviderListener * listener);
00080         virtual BOOLEAN CommitRow(INT row);
00082         virtual BOOLEAN SelectRow(INT row);
00084         virtual BOOLEAN AppendRow();
00086         virtual BOOLEAN DeleteRow(INT row);
00088         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00090         virtual BOOLEAN IsWStringDataCached() const;
00092         virtual INT GetProviderId() const;
00094         virtual INT GetSortedColumnId() const;
00096         virtual INT GetProgress();
00098         UsimPbEntry * GetEntry(INT row);
00099
00100
00101     protected:
00102         void ClearBufferVariables();
00103         BOOLEAN CommitAdditionalAttributes(UINT simpos);
00104
00105         WString                                 m_commit_string;
00106         PhoneNumber                             m_commit_phonenumber;
00107         UsimPbGroups                            m_commit_groups;
00108         PhoneNumberCommitArray                  m_commit_anr;
00109         WStringCommitArray                      m_commit_sne;
00110         WStringCommitArray                      m_commit_email;
00111         Uint8CommitArray                        m_commit_aas_rec;
00112         UINT8                                   m_commit_hiddeninfo;
00113         BOOLEAN                                 m_is_set_adn;
00114         BOOLEAN                                 m_is_set_hiddeninfo;
00115
00116         UsimPbHandler * m_handler;
00117
00118 };
00119
00120
00122
00123 #endif //#if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00124
00125 #endif
00126
00127
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbXasProvider.cpp File Reference

Adc/UsimPbXasProvider.cpp File Reference

#include "Adc/PreComp.hpp"

Include dependency graph for UsimPbXasProvider.cpp:

Generated on Tue Jan 24 16:20:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbXasProvider.hpp File Reference

Adc/UsimPbXasProvider.hpp File Reference

Go to the source code of this file.

Defines

#define Adc_UsimPbXasProvider_hpp

Define Documentation

#define Adc_UsimPbXasProvider_hpp

Generated on Tue Jan 24 16:20:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Adc/UsimPbXasProvider.hpp Source File

Adc/UsimPbXasProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Adc_UsimPbXasProvider_hpp)
00015 #define Adc_UsimPbXasProvider_hpp
00016
00017 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00018
00022
00023 #include <Auxiliary/ThreadSafeProvider.hpp>
00024
00025 #include <Adc/ProvIds.hpp>
00026 #include <Adc/UsimPbHandler.hpp>
00027
00028 /*------------------------------------------------------------------
00029                             UsimPbXasProvider
00030  ------------------------------------------------------------------*/
00031
00048 class UsimPbXasProvider : public ThreadSafeProvider
00049 {
00050     public:
00051         typedef ThreadSafeProvider Base;
00052
00054         UsimPbXasProvider();
00056         virtual ~UsimPbXasProvider();
00058         virtual INT GetProviderId() const;
00060         void Init(UsimPbHandler * handler, Protector * protector, UsimPbAddType type);
00062         virtual INT RowCount();
00064         virtual INT MaxRowCount();
00066         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00068         virtual BOOLEAN Update(ProviderListener * listener = 0);
00070         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00072         virtual BOOLEAN CommitRow(INT row);
00074         virtual BOOLEAN DeleteRow(INT row);
00076         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00077
00078
00079     private:
00080         UsimPbHandler *      m_usimpb_handler;
00081         WString              m_commitstring;
00082         UsimPbAddType m_type;
00083 };
00084
00086
00087 #endif // APOXI_ENABLE_USIM_PHONEBOOK
00088
00089 #endif
00090
00091
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lib.hpp File Reference

AddOns/Lib.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define AddOns_Lib_hpp

Define Documentation

#define AddOns_Lib_hpp

Generated on Tue Jan 24 14:53:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lib.hpp Source File

AddOns/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lib_hpp)
00010 #define AddOns_Lib_hpp
00013
00014 // TODO: include sub-addons dependant from compile-settings
00015
00017 #endif  // Gui_Lib_hpp
00018
00019
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/AdcExtensionsPreComp.cpp File Reference

AddOns/AdcExtensions/AdcExtensionsPreComp.cpp File Reference

#include "AdcExtensionsPreComp.hpp"

Include dependency graph for AdcExtensionsPreComp.cpp:

Generated on Tue Jan 24 16:20:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/AdcExtensionsPreComp.hpp File Reference

AddOns/AdcExtensions/AdcExtensionsPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>

Include dependency graph for AdcExtensionsPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:20:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/AdcExtensionsPreComp.hpp Source File

AddOns/AdcExtensions/AdcExtensionsPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Apc/Lib.hpp>
00012 #include <Adc/Lib.hpp>
00013
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DataRecord.cpp File Reference

AddOns/AdcExtensions/DataRecord.cpp File Reference

#include "AdcExtensionsPreComp.hpp"
#include "DataRecord.hpp"

Include dependency graph for DataRecord.cpp:

Generated on Tue Jan 24 16:20:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DataRecord.hpp File Reference

AddOns/AdcExtensions/DataRecord.hpp File Reference

#include <AddOns/AdcExtensions/DataRecordHandler.hpp>

Include dependency graph for DataRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataRecord

Defines

#define | Apoxi_AdcExtensions_DataRecord_hpp

Typedefs

typedef INT | DataRecordId

Variables

const DataRecordId | c_no_data_record_id = -1

Define Documentation

#define Apoxi_AdcExtensions_DataRecord_hpp

Typedef Documentation

typedef INT DataRecordId

Variable Documentation

const DataRecordId c_no_data_record_id = -1

Generated on Tue Jan 24 16:20:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DataRecord.hpp Source File

AddOns/AdcExtensions/DataRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AdcExtensions_DataRecord_hpp)
00009 #define Apoxi_AdcExtensions_DataRecord_hpp
00010
00011 #include <AddOns/AdcExtensions/DataRecordHandler.hpp>
00012
00013 typedef INT DataRecordId;
00014 const DataRecordId c_no_data_record_id = -1;
00015
00016 class DataRecord {
00017     public:
00018         DataRecord(DataRecordId id, BOOLEAN deleted=FALSE);
00019         DataRecordId GetId() const { return m_id; }
00020
00021     private:
00022         BOOLEAN IsDeleted() const;
00023         void Delete();
00024
00025         DataRecordId m_id;
00026         BOOLEAN m_deleted;
00027
00028         friend class DataRecordHandler;
00029 };
00030
00031 #endif  // Apoxi_AdcExtensions_DataRecord_hpp
00032
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DataRecordHandler.cpp File Reference

AddOns/AdcExtensions/DataRecordHandler.cpp File Reference

#include "AdcExtensionsPreComp.hpp"
#include "DataRecord.hpp"
#include "DataRecordHandler.hpp"

Include dependency graph for DataRecordHandler.cpp:

Generated on Tue Jan 24 16:20:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DataRecordHandler.hpp File Reference

AddOns/AdcExtensions/DataRecordHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataRecordHandler

Defines

#define | Apoxi_AdcExtensions_DataRecordHandler_hpp

Define Documentation

#define Apoxi_AdcExtensions_DataRecordHandler_hpp

Generated on Tue Jan 24 16:20:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DataRecordHandler.hpp Source File

AddOns/AdcExtensions/DataRecordHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AdcExtensions_DataRecordHandler_hpp)
00009 #define Apoxi_AdcExtensions_DataRecordHandler_hpp
00010
00011 class DataRecord;
00012
00017 class DataRecordHandler {
00018     public:
00020         DataRecordHandler(INT record_length);
00021
00027         virtual BOOLEAN LoadRecord(INT row, DataRecord *rec) = 0;
00028
00036         virtual BOOLEAN StoreRecord(INT row, const DataRecord *rec) = 0;
00037
00042         virtual BOOLEAN AddRecord(const DataRecord *rec) = 0;
00043
00049         virtual BOOLEAN DeleteRecord(INT row) = 0;
00050
00051     protected:
00052         BOOLEAN IsRecordDeleted(const DataRecord &rec) const;
00053         void MarkRecordDeleted(DataRecord &rec);
00054         INT m_record_length;
00055 };
00056
00057
00058 #endif  // Apoxi_AdcExtensions_DataRecordHandler_hpp
00059
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DcsLanguageFilterRule.cpp File Reference

AddOns/AdcExtensions/DcsLanguageFilterRule.cpp File Reference

#include "AdcExtensionsPreComp.hpp"
#include "DcsLanguageFilterRule.hpp"
#include <Apc/DataCodingScheme.hpp>

Include dependency graph for DcsLanguageFilterRule.cpp:

Generated on Tue Jan 24 16:20:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DcsLanguageFilterRule.hpp File Reference

AddOns/AdcExtensions/DcsLanguageFilterRule.hpp File Reference

#include <Auxiliary/FilterRule.hpp>

Include dependency graph for DcsLanguageFilterRule.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DcsLanguageFilterRule

Defines

#define | Apoxi_AdcExtensions_DcsLanguageFilterRule_hpp

Define Documentation

#define Apoxi_AdcExtensions_DcsLanguageFilterRule_hpp

Generated on Tue Jan 24 16:21:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/DcsLanguageFilterRule.hpp Source File

AddOns/AdcExtensions/DcsLanguageFilterRule.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AdcExtensions_DcsLanguageFilterRule_hpp)
00010 #define Apoxi_AdcExtensions_DcsLanguageFilterRule_hpp
00011
00012 #include <Auxiliary/FilterRule.hpp>
00013
00015 class DcsLanguageFilterRule : public FilterRule {
00016     typedef FilterRule Base;
00017
00018     public:
00020         DcsLanguageFilterRule ();
00021
00023         virtual ~DcsLanguageFilterRule ();
00024
00026         virtual BOOLEAN ExecuteRule(const DataItem& dataitem);
00027 };
00028
00029 #endif // Apoxi_AdcExtensions_DcsLanguageFilterRule_hpp
00030
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/LanguageCodeRes.cpp File Reference

AddOns/AdcExtensions/LanguageCodeRes.cpp File Reference

#include "AdcExtensionsPreComp.hpp"
#include "LanguageCodeRes.hpp"

Include dependency graph for LanguageCodeRes.cpp:

Variables

const LanguageCodeTableEntry | c_language_code_table []
const INT | c_language_table_entry_count = sizeof(c_language_code_table)/sizeof(c_language_code_table[0])

Variable Documentation

const LanguageCodeTableEntry c_language_code_table[]

const INT c_language_table_entry_count = sizeof(c_language_code_table)/sizeof(c_language_code_table[0])

Generated on Tue Jan 24 16:21:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/LanguageCodeRes.hpp File Reference

AddOns/AdcExtensions/LanguageCodeRes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/DataCodingScheme.hpp>

Include dependency graph for LanguageCodeRes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | LanguageCodeTableEntry

Defines

#define | Apoxi_AdcExtensions_LanguageCodeRes_hpp

Variables

const LanguageCodeTableEntry | c_language_code_table []
const INT | c_language_table_entry_count

Define Documentation

#define Apoxi_AdcExtensions_LanguageCodeRes_hpp

Variable Documentation

const LanguageCodeTableEntry c_language_code_table[]

const INT c_language_table_entry_count

Generated on Tue Jan 24 16:21:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/LanguageCodeRes.hpp Source File

AddOns/AdcExtensions/LanguageCodeRes.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003    ------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted without prior written authorisation.
00007    ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AdcExtensions_LanguageCodeRes_hpp)
00010 #define Apoxi_AdcExtensions_LanguageCodeRes_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Apc/DataCodingScheme.hpp>
00014
00015 struct LanguageCodeTableEntry {
00016     DataCodingScheme::Language dcs_lang_code;   // Code of some languages according to CBS Data Coding Scheme.
00017                                                 // Any language, that is not supported by DCS has 'Language unspecified'.
00018     const WCHAR* lang_name;             // English name, can be used for translations
00019     const WCHAR* iso_3ltr_code;         // 3 letter ISO 639 language code
00020     const WCHAR* iso_2ltr_code;         // 2 letter ISO 639 language code
00021     UINT8           gsm_lang_code;              // 1 byte GSM language code; Stored on SIM, Read by PrefExtLangProvider
00022 };
00023
00024 extern const LanguageCodeTableEntry c_language_code_table[];
00025 extern const INT c_language_table_entry_count;
00026
00027 #endif  //Apoxi_AdcExtensions_LanguageCodeRes_hpp
00028
00029
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/LanguageProvider.cpp File Reference

AddOns/AdcExtensions/LanguageProvider.cpp File Reference

#include "AdcExtensionsPreComp.hpp"
#include "LanguageProvider.hpp"

Include dependency graph for LanguageProvider.cpp:

Generated on Tue Jan 24 16:21:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/LanguageProvider.hpp File Reference

AddOns/AdcExtensions/LanguageProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>
#include <AddOns/AdcExtensions/LanguageCodeRes.hpp>
#include <AddOns/AdcExtensions/ProviderIds.hpp>

Include dependency graph for LanguageProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LanguageProvider

Defines

#define | Apoxi_AdcExtensions_LanguageProvider_hpp

Define Documentation

#define Apoxi_AdcExtensions_LanguageProvider_hpp

Generated on Tue Jan 24 16:21:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/LanguageProvider.hpp Source File

AddOns/AdcExtensions/LanguageProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Apoxi_AdcExtensions_LanguageProvider_hpp)
00015 #define Apoxi_AdcExtensions_LanguageProvider_hpp
00016
00017 #include <Auxiliary/Provider.hpp>
00018 #include <AddOns/AdcExtensions/LanguageCodeRes.hpp>
00019 #include <AddOns/AdcExtensions/ProviderIds.hpp>
00020
00032 class LanguageProvider : public Provider
00033 {
00034     typedef Provider Base;
00035
00036     public:
00038         LanguageProvider();
00039
00041         virtual ~LanguageProvider();
00042
00044         virtual INT GetProviderId() const;
00045
00047         virtual INT RowCount();
00048
00050         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00051 };
00052
00053 #endif  // Apoxi_AdcExtensions_LanguageProvider_hpp
00054
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/NvRam.hpp File Reference

AddOns/AdcExtensions/NvRam.hpp File Reference

#include <Compat/NvRam.hpp>

Include dependency graph for NvRam.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 16:21:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/NvRam.hpp Source File

AddOns/AdcExtensions/NvRam.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  The class NvRam has been moved to Compat.
00010     This header-file assures backward-compatibility for
00011     applications written with APOXI-versions smaller than 1.6.2.*/
00012 #include <Compat/NvRam.hpp>
00013
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/NvRamDataRecordHandler.hpp File Reference

AddOns/AdcExtensions/NvRamDataRecordHandler.hpp File Reference

#include <Compat/NvRamDataRecordHandler.hpp>

Include dependency graph for NvRamDataRecordHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:21:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/NvRamDataRecordHandler.hpp Source File

AddOns/AdcExtensions/NvRamDataRecordHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  The class NvRamDataRecordHandler has been moved to Compat.
00010     This header-file assures backward-compatibility for
00011     applications written with APOXI-versions smaller than 1.6.2.*/
00012 #include <Compat/NvRamDataRecordHandler.hpp>
00013
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/NvRamStorage.hpp File Reference

AddOns/AdcExtensions/NvRamStorage.hpp File Reference

#include <Compat/NvRamStorage.hpp>

Include dependency graph for NvRamStorage.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 16:21:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/NvRamStorage.hpp Source File

AddOns/AdcExtensions/NvRamStorage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  The class NvRamStorage has been moved to Compat.
00010     This header-file assures backward-compatibility for
00011     applications written with APOXI-versions smaller than 1.6.2.*/
00012 #include <Compat/NvRamStorage.hpp>
00013
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/ProviderIds.hpp File Reference

AddOns/AdcExtensions/ProviderIds.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_AdcExtensions_ProviderIds_hpp

Variables

const INT | c_2_letter_iso639_code_id = 5302
const INT | c_3_letter_iso639_code_id = 5303
const INT | c_dcs_language_code_id = 5301
const INT | c_gsm_code_id = 5304
const INT | c_language_name_id = 5300
const INT | c_language_provider_id = 5000

Define Documentation

#define Apoxi_AdcExtensions_ProviderIds_hpp

Variable Documentation

const INT c_2_letter_iso639_code_id = 5302

const INT c_3_letter_iso639_code_id = 5303

const INT c_dcs_language_code_id = 5301

const INT c_gsm_code_id = 5304

const INT c_language_name_id = 5300

const INT c_language_provider_id = 5000

Generated on Tue Jan 24 16:21:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/ProviderIds.hpp Source File

AddOns/AdcExtensions/ProviderIds.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (Apoxi_AdcExtensions_ProviderIds_hpp)
00010 #define Apoxi_AdcExtensions_ProviderIds_hpp
00011
00012 // Reserved range: 5000 to 5999
00013
00014 /*  ------------------------------------------------------------------------
00015     Provider ids
00016     ------------------------------------------------------------------------ */
00017
00018 const INT c_language_provider_id            = 5000;
00019
00020 /*  ------------------------------------------------------------------------
00021     Provider column ids
00022     ------------------------------------------------------------------------ */
00023
00024 // Language Provider
00025 const INT c_language_name_id                = 5300;
00026 const INT c_dcs_language_code_id            = 5301;
00027 const INT c_2_letter_iso639_code_id         = 5302;
00028 const INT c_3_letter_iso639_code_id         = 5303;
00029 const INT c_gsm_code_id                     = 5304;
00030
00031 #endif // Apoxi_AdcExtensions_ProviderIds_hpp
00032
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/Record.hpp File Reference

AddOns/AdcExtensions/Record.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Record

Defines

#define | Apoxi_AdcExtensions_Record_hpp

Define Documentation

#define Apoxi_AdcExtensions_Record_hpp

Generated on Tue Jan 24 16:21:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/Record.hpp Source File

AddOns/AdcExtensions/Record.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AdcExtensions_Record_hpp)
00009 #define Apoxi_AdcExtensions_Record_hpp
00010
00014 class Record {
00015
00016     public:
00018         Record() {};
00019
00021         virtual const UINT8* GetData() = 0;
00022
00024         virtual void SetData(const UINT8* data) = 0;
00025
00027         virtual INT GetPersistentSize() = 0;
00028
00030         virtual void MarkDeleted() {};
00031
00033         virtual BOOLEAN IsRecordDeleted() { return FALSE; }
00034
00035 };
00036
00037 #endif  // Apoxi_AdcExtensions_Record_hpp
00038
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/RecordHandler.cpp File Reference

AddOns/AdcExtensions/RecordHandler.cpp File Reference

#include "AdcExtensionsPreComp.hpp"
#include "RecordHandler.hpp"

Include dependency graph for RecordHandler.cpp:

Generated on Tue Jan 24 16:21:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/RecordHandler.hpp File Reference

AddOns/AdcExtensions/RecordHandler.hpp File Reference

#include <Afs/Rfs/File.hpp>
#include <Auxiliary/IndexTable.hpp>
#include <AddOns/AdcExtensions/Record.hpp>

Include dependency graph for RecordHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RecordHandler
struct | RecordHandler::StructuredDataHeader

Defines

#define | Apoxi_AdcExtensions_RecordHandler_hpp

Define Documentation

#define Apoxi_AdcExtensions_RecordHandler_hpp

Generated on Tue Jan 24 16:21:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AdcExtensions/RecordHandler.hpp Source File

AddOns/AdcExtensions/RecordHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AdcExtensions_RecordHandler_hpp)
00009 #define Apoxi_AdcExtensions_RecordHandler_hpp
00010
00011 #include <Afs/Rfs/File.hpp>
00012 #include <Auxiliary/IndexTable.hpp>
00013 #include <AddOns/AdcExtensions/Record.hpp>
00014
00015
00032 class RecordHandler {
00033     public:
00034
00036         RecordHandler();
00037
00039         ~RecordHandler();
00040
00042         BOOLEAN Init(FilePtr file, Record* record, INT max_rows, BOOLEAN sequential = TRUE);
00043
00045         BOOLEAN Lock();
00046
00048         BOOLEAN Unlock();
00049
00051         virtual BOOLEAN ExistsRecord(INT row);
00052
00054         virtual BOOLEAN LoadRecord(INT row, Record *rec);
00055
00057         virtual BOOLEAN StoreRecord(INT row, Record *rec);
00058
00060         virtual BOOLEAN AddRecord(Record *rec);
00061
00063         virtual BOOLEAN DeleteRecord(INT row);
00064
00066         virtual BOOLEAN DeleteAllRecords();
00067
00069         INT GetRowCount() const;
00070
00072         void SetRecordTableValue(INT logical, INT physical);
00073
00074
00075     private:
00076
00078         void SetStoreFlag(INT row, BOOLEAN filled);
00079
00081         BOOLEAN GetStoreFlag(INT row);
00082
00084         BOOLEAN WriteStoreFlags();
00085
00087         BOOLEAN OpenFile(File::OpenMode open_mode);
00088
00090         BOOLEAN CloseFile();
00091
00092
00093         FilePtr         m_file;
00094         Record*         m_record;
00095         INT             m_row_count;
00096         INT             m_max_rows;
00097         INT             m_last_row;
00098         IndexTable<INT> m_record_table;
00099
00100         struct StructuredDataHeader {
00101             UINT32      offset;
00102             UINT16      record_length;
00103             UINT16      row_count;
00104             UINT8       version;
00105         } m_header;
00106
00107         UINT8*          m_store_flags;
00108         UINT8*          m_header_cache;
00109
00110         INT             m_row_count_offset;
00111         INT             m_store_flags_offset;
00112         INT             m_nof_store_flag_bytes;
00113         BOOLEAN         m_sequential;
00114         BOOLEAN         m_locked;
00115         BOOLEAN         m_initialized;
00116 };
00117
00118
00119 #endif  // Apoxi_AdcExtensions_RecordHandler_hpp
00120
00121
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Aes/AesCryptInterface.cpp File Reference

AddOns/Aes/AesCryptInterface.cpp File Reference

#include "AesCryptInterface.hpp"
#include "Impl/aes.h"
#include <string.h>

Include dependency graph for AesCryptInterface.cpp:

Generated on Tue Jan 24 16:21:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Aes/AesCryptInterface.hpp File Reference

AddOns/Aes/AesCryptInterface.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for AesCryptInterface.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AesCrypt

Defines

#define | AesCryptInterface_hpp

Enumerations

enum | AesError { AesErrorNone = 0, AesGeneralError, AesNoKey, AesInvalidBlockWindow }

Define Documentation

#define AesCryptInterface_hpp

Enumeration Type Documentation

enum AesError

Aes Error - Enumerator to define AES error codes Used by GetLastError.

See also:
GetLastError
Enumerator:
AesErrorNone
AesGeneralError
AesNoKey
AesInvalidBlockWindow

Generated on Tue Jan 24 16:21:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Aes/AesCryptInterface.hpp Source File

AddOns/Aes/AesCryptInterface.hpp

Go to the documentation of this file.
00001 #if !defined(AesCryptInterface_hpp)
00002 #define AesCryptInterface_hpp
00003
00004 #include <Kernel/Types.hpp>
00005
00006 // AES currently is provided from Prof. Gladman's C implementation
00007 // It currently supports the following features only (to reduce code size)
00008 // Features chosen for DRM
00009 //
00010 //  - Decryption only
00011 //  - 128 bit keysize
00012 //  - CBC Mode
00013 //  - 128 bit blocksize
00014 //
00015
00018 enum AesError {
00019     AesErrorNone = 0,           // No Error
00020     AesGeneralError,            // General failure - no specific info available
00021     AesNoKey,                   // Key not set
00022     AesInvalidBlockWindow       // Invalid start_block end_block combination
00023 };
00024
00077
00078 class AesCrypt {
00079     public:
00081         enum PaddingMethod {
00082             PaddingMethod2630,          // RFC 2630
00083             PaddingMethodNone           // None
00084         };
00085
00086         // Constructor
00087         AesCrypt() : m_last_error(AesErrorNone) {}
00088         // Destructor
00089         ~AesCrypt() {}
00090
00094         void SetKey(const UINT8* key);
00095
00099         AesError GetLastAesError() const
00100             { return m_last_error; }
00101
00116         INT DecryptBuffer(const BYTE* in, BYTE* out,
00117             UINT buf_len, PaddingMethod pad_method,
00118             UINT start_block=0, UINT end_block=0);
00119
00120     private:
00121         UINT8           m_key[16];              // 128 bit Key
00122         AesError        m_last_error;           // Last occured error code
00123
00130         void XorBlock(BYTE* left, const BYTE* right, const UINT16 len);
00131 };
00132
00134 #endif // AesCryptInterface_hpp
00135
00136
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/ApoxiAfsFatVersion.cpp File Reference

AddOns/AfsFat/ApoxiAfsFatVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiAfsFatVersion.cpp:

Functions

ApoxiDefVersionInfo (AfsFat, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | AfsFat | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:21:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatDirectoryIteratorImp.cpp File Reference

AddOns/AfsFat/FatDirectoryIteratorImp.cpp File Reference

#include "PreComp.hpp"
#include "FatDirectoryIteratorImp.hpp"
#include "FatHandler.hpp"
#include "FatStorageDeviceImp.hpp"
#include <Afs/Rfs/FileFilter.hpp>

Include dependency graph for FatDirectoryIteratorImp.cpp:

Generated on Tue Jan 24 16:21:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatDirectoryIteratorImp.hpp File Reference

AddOns/AfsFat/FatDirectoryIteratorImp.hpp File Reference

#include <Afs/Rfs/DirectoryIterator.hpp>
#include <AddOns/AfsFat/FatTypes.hpp>

Include dependency graph for FatDirectoryIteratorImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FatDirectoryIteratorImp
Directory iterator implementation for FAT storage device. More...

Defines

#define | Apoxi_FatDirectoryIteratorImp_hpp

Define Documentation

#define Apoxi_FatDirectoryIteratorImp_hpp

Generated on Tue Jan 24 16:21:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatDirectoryIteratorImp.hpp Source File

AddOns/AfsFat/FatDirectoryIteratorImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FatDirectoryIteratorImp_hpp)
00011 #define Apoxi_FatDirectoryIteratorImp_hpp
00014
00015 #include <Afs/Rfs/DirectoryIterator.hpp>
00016 #include <AddOns/AfsFat/FatTypes.hpp>
00017
00022 class FatDirectoryIteratorImp : public DirectoryIterator
00023 {
00024     protected:
00025         explicit FatDirectoryIteratorImp(const Pathname &dir_pathname,
00026             const WString &device_id, const FileFilterPtr &filter);
00027
00029         virtual ~FatDirectoryIteratorImp();
00030
00031         virtual DirectoryIterator& AtomicIncrement();
00032
00033         friend class FatStorageDeviceImp;
00034
00035     private:
00039         BOOLEAN FindNext();
00040
00041         inline BOOLEAN IsCurrentDir(const FatFindData &find_data) const;
00042         inline BOOLEAN IsParentDir(const FatFindData &find_data) const;
00043
00044         void GetFileNameFromFindData(const FatFindData &find_data);
00045
00046         FatFindData m_find_data;
00047 };
00048
00050 #endif  // Apoxi_FatDirectoryIteratorImp_hpp
00051
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFile.cpp File Reference

AddOns/AfsFat/FatFile.cpp File Reference

#include "PreComp.hpp"
#include "FatFile.hpp"
#include "FatHandler.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for FatFile.cpp:

Generated on Tue Jan 24 16:21:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFile.hpp File Reference

AddOns/AfsFat/FatFile.hpp File Reference

#include <Auxiliary/String.hpp>
#include <AddOns/AfsFat/FatTypes.hpp>
#include <Afs/Rfs/File.hpp>

Include dependency graph for FatFile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FatFile

Defines

#define | Apoxi_FatFile_hpp

Define Documentation

#define Apoxi_FatFile_hpp

Generated on Tue Jan 24 16:21:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFile.hpp Source File

AddOns/AfsFat/FatFile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FatFile_hpp)
00011 #define Apoxi_FatFile_hpp
00014
00015 #include <Auxiliary/String.hpp>
00016 #include <AddOns/AfsFat/FatTypes.hpp>
00017 #include <Afs/Rfs/File.hpp>
00018
00019 class FatFile
00020 {
00021     public:
00022         FatFile();
00023         ~FatFile();
00024
00025         static void StreamingDriverReadCallback(INT16 result, void *client_arg);
00026         static void StreamingDriverWriteCallback(INT16 result, void *client_arg);
00027
00031         inline BOOLEAN IsInitialized() const { return m_filehandle != -1; }
00032
00034         BOOLEAN AssureInitialized(const CHAR *filename) const;
00035
00036         BOOLEAN Open(const CHAR *filename, FatOpenMode mode);
00037         BOOLEAN OpenStreaming(const CHAR *filename, FatOpenMode mode);
00038         BOOLEAN Create(const CHAR *filename, UINT32 size);
00039         BOOLEAN CreateStreaming(const CHAR *filename);
00040         BOOLEAN Close();
00041         BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 bytes);
00042         BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 max_no_bytes,
00043             UINT32 &bytes_read);
00044         BOOLEAN ReadStreaming(void HUGE *buffer, UINT32 count, UINT32 bytes_read);
00045         BOOLEAN ReadStreamingAsync(void HUGE *buffer, UINT32 count,
00046                 void (callback_func)(File::Error result, UINT32 bytes_operated));
00047         BOOLEAN Write(const void HUGE *buffer, UINT32 offset, UINT32 no_bytes);
00048         BOOLEAN WriteStreaming(const void HUGE *buffer, UINT32 count);
00049         BOOLEAN WriteStreamingAsync(const void HUGE *buffer, UINT32 count,
00050                 void (callback_func)(File::Error result, UINT32 bytes_operated));
00051         BOOLEAN Delete();
00052         BOOLEAN Rename(const CHAR *new_filename);
00053         BOOLEAN Resize(UINT32 new_size);
00054         BOOLEAN GetFileSize(UINT32 &file_size) const;
00055         BOOLEAN GetCreationTimestamp(FatTimeRecord &time_stamp) const;
00056         BOOLEAN GetLastUpdateTimestamp(FatTimeRecord &time_stamp) const;
00057         BOOLEAN GetLastAccessTimestamp(FatTimeRecord &time_stamp) const;
00058         FatError GetLastError() const;
00059         BOOLEAN IsOpen() const;
00060         BOOLEAN SetReadOnly(BOOLEAN read_only);
00061         BOOLEAN IsReadOnly() const;
00062         BOOLEAN SetHidden(BOOLEAN hidden);
00063         BOOLEAN IsHidden() const;
00064         BOOLEAN SetArchive(BOOLEAN archive);
00065         BOOLEAN IsArchive() const;
00066
00069         BOOLEAN GetHandle(FatHandle &file_handle) const;
00070
00071     private:
00072         BOOLEAN Open(FatOpenMode mode);
00073         BOOLEAN GetFileInfo() const;
00074         BOOLEAN InternalWrite(const void HUGE *src, UINT32 offset, UINT32 nof);
00075         BOOLEAN InternalOpen(FatOpenMode mode);
00076         BOOLEAN Create(UINT32 size);
00077         BOOLEAN Append(const void HUGE *src, UINT32 nof);
00078         BOOLEAN Upsize(UINT32 new_size);
00079         BOOLEAN Downsize(UINT32 new_size);
00080
00081         mutable BOOLEAN m_is_info_upd;
00082         BOOLEAN m_is_open;
00083         BOOLEAN m_is_writable;
00084         BOOLEAN m_is_streaming;
00085         UINT32 m_streaming_bytes_operated;
00086         UINT32 m_streaming_buf_size;
00087         FatOpenMode m_open_mode;
00088         File::StreamingCallback m_streaming_cb;
00089
00090         mutable FatError m_last_error;
00091         FatHandle m_filehandle;
00092         String m_filename;
00093         mutable FatFileInfo m_file_info;
00094 };
00095
00097 #endif  // Apoxi_FatFile_hpp
00098
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFileImp.cpp File Reference

AddOns/AfsFat/FatFileImp.cpp File Reference

#include "PreComp.hpp"
#include "FatFileImp.hpp"
#include "FatHandler.hpp"
#include "FatStorageDeviceImp.hpp"
#include <Auxiliary/Date.hpp>

Include dependency graph for FatFileImp.cpp:

Generated on Tue Jan 24 16:21:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFileImp.hpp File Reference

AddOns/AfsFat/FatFileImp.hpp File Reference

#include <Afs/Rfs/File.hpp>
#include <AddOns/AfsFat/FatFile.hpp>

Include dependency graph for FatFileImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FatFileImp
File implementation for FAT filesystem (FAT) storage devices More...

Defines

#define | Apoxi_FatFileImp_hpp

Define Documentation

#define Apoxi_FatFileImp_hpp

Generated on Tue Jan 24 16:21:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFileImp.hpp Source File

AddOns/AfsFat/FatFileImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FatFileImp_hpp)
00011 #define Apoxi_FatFileImp_hpp
00014
00015 #include <Afs/Rfs/File.hpp>
00016 #include <AddOns/AfsFat/FatFile.hpp>
00017
00024 class FatFileImp : public File
00025 {
00026     typedef File Base;
00027
00028     friend class FatStorageDeviceImp;
00029
00030     public:
00034         static const UINT PROP_NATIVEHANDLE;
00035
00036         virtual BOOLEAN Open(OpenMode open_mode);
00037         virtual BOOLEAN OpenStreaming(OpenMode open_mode);
00038         virtual BOOLEAN IsOpen() const;
00039         virtual BOOLEAN Close();
00040         virtual BOOLEAN Create(UINT32 size);
00041         virtual BOOLEAN CreateStreaming();
00042         virtual BOOLEAN CreateDir();
00043         virtual BOOLEAN Resize(UINT32 new_size, UINT32 copy_buf_size);
00044         virtual BOOLEAN Delete();
00045         virtual BOOLEAN Rename(const WString &new_name);
00046         virtual BOOLEAN SetReadOnly(BOOLEAN read_only);
00047         virtual BOOLEAN IsReadOnly() const;
00048         virtual BOOLEAN SetHidden(BOOLEAN hidden);
00049         virtual BOOLEAN IsHidden() const;
00050         virtual BOOLEAN SetArchive(BOOLEAN archive);
00051         virtual BOOLEAN IsArchive() const;
00052         virtual BOOLEAN GetSize(UINT32 &size) const;
00053         virtual BOOLEAN GetAttributes(Attributes &attributes) const;
00054         virtual BOOLEAN GetCreationDate(Date &date) const;
00055         virtual BOOLEAN GetModificationDate(Date &date) const;
00056         virtual BOOLEAN GetAccessDate(Date &date) const;
00057         virtual const WString& GetStorageDeviceId() const;
00058         virtual BOOLEAN GetNativeProperty(UINT prop_Id, void *val) const;
00059
00060     protected:
00061         FatFileImp(const Pathname &pathname, const WString &device_id);
00062
00063         virtual ~FatFileImp();
00064
00065         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset, UINT32 count);
00066         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset,
00067             UINT32 max_count, UINT32 &bytes_read);
00068         virtual BOOLEAN DoReadStreaming(void HUGE *buffer, UINT32 count,
00069             UINT32 &bytes_read);
00070         virtual BOOLEAN DoReadStreamingAsync(void HUGE *buffer, UINT32 count,
00071             StreamingCallback);
00072         virtual BOOLEAN DoWrite(const void HUGE *buffer, UINT32 offset,
00073             UINT32 count);
00074         virtual BOOLEAN DoWriteStreaming(const void HUGE *buffer, UINT32 count);
00075         virtual BOOLEAN DoWriteStreamingAsync(const void HUGE *buffer, UINT32 count,
00076             StreamingCallback);
00077
00078         virtual FileState& MyState();
00079         virtual const FileState& MyState() const;
00080
00081         static FatOpenMode TranslateOpenMode(OpenMode open_mode);
00082         static inline Date DateFromDriverDate(UINT16 date);
00083
00084     private:
00086         FileState m_state;
00088         FatFile m_fat_file;
00089 };
00090
00092 #endif  // Apoxi_FatFileImp_hpp
00093
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFsMsgTypes.cpp File Reference

AddOns/AfsFat/FatFsMsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "FatFsMsgTypes.hpp"

Include dependency graph for FatFsMsgTypes.cpp:

Generated on Tue Jan 24 16:21:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFsMsgTypes.hpp File Reference

AddOns/AfsFat/FatFsMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for FatFsMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FatFsUsbMassStorageReleaseMsg
class | FatFsUsbMassStorageRequestMsg

Defines

#define | FatFsMsgTypes_hpp__ST_1128347975150

Define Documentation

#define FatFsMsgTypes_hpp__ST_1128347975150

Generated on Tue Jan 24 16:21:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatFsMsgTypes.hpp Source File

AddOns/AfsFat/FatFsMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "src\koglerm_snap_apoxi_tester\lnz_apoxi\Apoxi\AddOns\AfsFat\FatFsMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(FatFsMsgTypes_hpp__ST_1128347975150)
00017 #define FatFsMsgTypes_hpp__ST_1128347975150
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Auxiliary/WString.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class FatFsUsbMassStorageRequestMsg
00029     ====================================================================== */
00030
00034 class FatFsUsbMassStorageRequestMsg : public Message {
00035     public:
00036         FatFsUsbMassStorageRequestMsg(const WString& storage_device_id, BOOLEAN request_granted);
00037         virtual ~FatFsUsbMassStorageRequestMsg();
00038
00039         virtual const MsgMetaData& GetMetaData() const;
00040         const WString& GetStorageDeviceId() const { return m_storage_device_id; }
00041         BOOLEAN IsRequestGranted() const { return m_request_granted; }
00042         virtual Message* Clone() const;
00043
00044         enum  {
00045             ID = 16060
00046             };
00047
00048     private:
00049         static const MsgMetaData m_meta_data;
00050         WString m_storage_device_id;
00051         BOOLEAN m_request_granted;
00052
00053     };
00054
00055
00056 /*  ======================================================================
00057     Class FatFsUsbMassStorageReleaseMsg
00058     ====================================================================== */
00059
00063 class FatFsUsbMassStorageReleaseMsg : public Message {
00064     public:
00065         FatFsUsbMassStorageReleaseMsg(const WString& storage_device_id);
00066         virtual ~FatFsUsbMassStorageReleaseMsg();
00067
00068         virtual const MsgMetaData& GetMetaData() const;
00069         const WString& GetStorageDeviceId() const { return m_storage_device_id; }
00070         virtual Message* Clone() const;
00071
00072         enum  {
00073             ID = 16061
00074             };
00075
00076     private:
00077         static const MsgMetaData m_meta_data;
00078         WString m_storage_device_id;
00079
00080     };
00081
00082 #endif // FatFsMsgTypes_hpp__ST_1128347975150
00083
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatHandler.cpp File Reference

AddOns/AfsFat/FatHandler.cpp File Reference

#include "PreComp.hpp"
#include "FatHandler.hpp"
#include <Auxiliary/Macros.hpp>
#include <string.h>

Include dependency graph for FatHandler.cpp:

Generated on Tue Jan 24 16:21:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatHandler.hpp File Reference

AddOns/AfsFat/FatHandler.hpp File Reference

#include <AddOns/AfsFat/FatTypes.hpp>

Include dependency graph for FatHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class FatHandler

Generated on Tue Jan 24 16:21:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatHandler.hpp Source File

AddOns/AfsFat/FatHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined Apoxi_FatHandler_hpp
00011 #define Apoxi_FatHandler_hpp
00014
00015 #include <AddOns/AfsFat/FatTypes.hpp>
00016
00017 class FatHandler
00018 {
00019     public:
00028         static FatHandle Create(const CHAR *file_name, UINT32 size);
00029
00039         static FatHandle Open(const CHAR *file_name, FatOpenMode mode);
00040
00048         static BOOLEAN Close(FatHandle hp);
00049
00059         static BOOLEAN Read(FatHandle hp, UINT8 HUGE *buffer, UINT32 count);
00060
00072         static BOOLEAN ReadStreaming(FatHandle hp, UINT8 HUGE *buffer,
00073                             UINT32 count, UINT32 bytes_read, void *client_arg);
00074
00095         static BOOLEAN ReadStreamingAsync(FatHandle hp, UINT8 HUGE *buffer,
00096                             UINT32 count,
00097                             void (callback_func)(INT16 result, void *client_arg),
00098                             void *client_arg);
00099
00109         static BOOLEAN Write(FatHandle hp, const UINT8 HUGE *buffer,
00110                             UINT32 count);
00111
00123         static BOOLEAN WriteStreaming(FatHandle hp, const UINT8 HUGE *buffer,
00124                             UINT32 count, void *client_arg);
00125
00146         static BOOLEAN WriteStreamingAsync(FatHandle hp,
00147                             const UINT8 HUGE *buffer, UINT32 count,
00148                             void (callback_func)(INT16 result, void *client_arg),
00149                             void *client_arg);
00150
00151
00163         static UINT32 Seek(FatHandle hp, INT32 offset, INT16 origin,
00164             INT16 &err_flag);
00165
00173         static BOOLEAN Append(FatHandle hp, const UINT8 HUGE *buffer,
00174             UINT32 count);
00175
00183         static BOOLEAN Rename(const CHAR *current_file_name,
00184                               const CHAR *new_file_name);
00185
00192         static BOOLEAN Delete(const CHAR *file_name);
00193
00199         static BOOLEAN MakeDir(const CHAR *dir_name);
00200
00206         static BOOLEAN RemoveDir(const CHAR *dir_name);
00207
00213         static BOOLEAN ChangeDir(const CHAR *dir_name);
00214
00226         static BOOLEAN GetCurrentDir(const CHAR *drive_letter,
00227             CHAR *current_dir);
00228
00234         static BOOLEAN FileExists(const CHAR *file_name);
00235
00239         static UINT32 GetFreeSpaceSize();
00240
00248         static BOOLEAN GetFileInfo(const CHAR *file_name, FatFileInfo &info);
00249
00258         static BOOLEAN FindFirst(FatFindData &find_data, const CHAR *filespec);
00259
00266         static BOOLEAN FindNext(FatFindData &find_data);
00267
00271         static void FindDone(FatFindData &find_data);
00272
00278         static BOOLEAN IsDirectory(const CHAR *pathname);
00279
00286         static BOOLEAN GetAttributes(const CHAR *filename, UINT16 &attr);
00287
00294         static BOOLEAN SetAttributes(const CHAR *filename, UINT16 attr);
00295
00299         static FatError GetLastError();
00300
00305         static BOOLEAN Flush(FatHandle hp);
00306
00312         static BOOLEAN Truncate(FatHandle hp, UINT32 new_size);
00313
00316         static BOOLEAN DiskOpen(FsDeviceType device);
00317         static BOOLEAN DiskClose(FsDeviceType device);
00318         static void DiskAbort(FsDeviceType device);
00319         static BOOLEAN DiskFormat(FsDeviceType device, BOOLEAN quick);
00320         static BOOLEAN DiskInfo(FsDeviceType device, BOOLEAN &mounted,
00321             UINT8 &nof_partitions);
00322         static BOOLEAN DiskAssignDriveLetter(FsDeviceType device,
00323             CHAR drive_letter);
00324         static BOOLEAN DiskSetDefaultDevice(FsDeviceType device);
00325         static BOOLEAN DiskFlush(FsDeviceType device);
00326         static UINT16 DiskGetLastDeviceError(FsDeviceType device);
00328 };
00329
00331 #endif  // Apoxi_FatHandler_hpp
00332
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatSim.cpp File Reference

AddOns/AfsFat/FatSim.cpp File Reference

#include "PreComp.hpp"
#include "FatSim.hpp"
#include <Kernel/System.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Afs/HostFsSim/HostCoreFsSim.hpp>

Include dependency graph for FatSim.cpp:

Typedefs

typedef SimpleMap< long, String > | HostDirectoryIteratorMap

Functions

BOOL | FS_assign_driveletter (fs_device_type device, char drive_letter)
BOOL | FS_close (fs_fd_type fd)
void | FS_deactivate (void)
BOOL | FS_delete (const char *filename)
void | FS_device_notify (long device_id, BOOL media_present)
void | FS_diskabort (fs_device_type device)
BOOL | FS_diskclose (fs_device_type device)
BOOL | FS_diskflush (fs_device_type device)
BOOL | FS_diskinfo (fs_device_type device, BOOL *mounted, ubyte *nof_partitions)
BOOL | FS_diskopen (fs_device_type device)
void | FS_finddone (fs_dstat_type *statobj)
BOOL | FS_findfirst (fs_dstat_type *statobj, const char *pattern)
BOOL | FS_findnext (fs_dstat_type *statobj)
BOOL | FS_flush (fs_fd_type fd)
BOOL | FS_format (fs_device_type device, BOOL quick)
ulong | FS_free (fs_device_type device)
BOOL | FS_get_attributes (const char *filename, ushort *attributes)
fs_device_type | FS_get_default_device (void)
BOOL | FS_get_file_length_streaming (fs_fd_type fd, ulong *file_size, void(*callback)(sshort result, void *client_arg), void *client_arg)
BOOL | FS_get_file_pos_streaming (fs_fd_type fd, ulong *pos, void(*callback)(sshort result, void *client_arg), void *client_arg)
sshort | FS_get_last_device_error (fs_device_type device)
sshort | FS_get_last_error (void)
ubyte | FS_get_registered_devices (const fs_registered_info_type **device_list)
BOOL | FS_getcwd (const char *drive, char *path)
BOOL | FS_init_rtos (void)
BOOL | FS_isdir (const char *path)
BOOL | FS_mkdir (const char *path)
fs_fd_type | FS_open (const char *filename, ushort flag, ushort mode)
BOOL | FS_read (fs_fd_type fd, ubyte huge *buffer, ulong count)
ulong | FS_read_max (fs_fd_type fd, ubyte huge *buffer, ulong count)
BOOL | FS_read_streaming (fs_fd_type fd, ubyte huge *buffer, ulong count, void(*callback)(sshort result, void *client_arg), void *client_arg)
BOOL | FS_register_media_status_notification (fs_device_type device, void(*notify_func)(fs_device_type device, BOOL media_present, void *client_arg), void *client_arg)
BOOL | FS_rename (const char *old_filename, const char *new_filename)
BOOL | FS_rmdir (const char *path)
ulong | FS_seek (fs_fd_type fd, slong offset, sshort origin, sshort *err_flag)
BOOL | FS_set_attributes (const char *filename, ushort attributes)
BOOL | FS_set_default_device (fs_device_type device)
BOOL | FS_set_file_pos_streaming (fs_fd_type fd, ulong pos, void(*callback)(sshort result, void *client_arg), void *client_arg)
BOOL | FS_setcwd (const char *path)
BOOL | FS_stat (const char *filename, fs_stat_type *pstat)
BOOL | FS_truncate (fs_fd_type fd, ulong new_size)
BOOL | FS_write (fs_fd_type fd, const ubyte huge *buffer, ulong count)
BOOL | FS_write_streaming (fs_fd_type fd, const ubyte huge *buffer, ulong count, void(*callback)(sshort result, void *client_arg), void *client_arg)
const char * | GetDeviceId (const char drive_letter)
const char * | GetDeviceId (fs_device_type device)
void | HostInitFatFsStorageDevices (const HostFatFsDeviceDescMapPtr &device_map)

Typedef Documentation

typedef SimpleMap<long, String> HostDirectoryIteratorMap

Function Documentation

BOOL FS_assign_driveletter | ( | fs_device_type | device,
 |  | char | drive_letter
 | ) |

BOOL FS_close ( fs_fd_type fd )

void FS_deactivate ( void )

BOOL FS_delete ( const char * filename )

void FS_device_notify | ( | long | device_id,
 |  | BOOL | media_present
 | ) |

void FS_diskabort ( fs_device_type device )

BOOL FS_diskclose ( fs_device_type device )

BOOL FS_diskflush ( fs_device_type device )

BOOL FS_diskinfo | ( | fs_device_type | device,
 |  | BOOL * | mounted,
 |  | ubyte * | nof_partitions
 | ) |

BOOL FS_diskopen ( fs_device_type device )

void FS_finddone ( fs_dstat_type * statobj )

BOOL FS_findfirst | ( | fs_dstat_type * | statobj,
 |  | const char * | pattern
 | ) |

BOOL FS_findnext ( fs_dstat_type * statobj )

BOOL FS_flush ( fs_fd_type fd )

BOOL FS_format | ( | fs_device_type | device,
 |  | BOOL | quick
 | ) |

ulong FS_free ( fs_device_type device )

BOOL FS_get_attributes | ( | const char * | filename,
 |  | ushort * | attributes
 | ) |

fs_device_type FS_get_default_device ( void )

BOOL FS_get_file_length_streaming | ( | fs_fd_type | fd,
 |  | ulong * | file_size,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

BOOL FS_get_file_pos_streaming | ( | fs_fd_type | fd,
 |  | ulong * | pos,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

sshort FS_get_last_device_error ( fs_device_type device )

sshort FS_get_last_error ( void )

ubyte FS_get_registered_devices ( const fs_registered_info_type ** device_list )

BOOL FS_getcwd | ( | const char * | drive,
 |  | char * | path
 | ) |

BOOL FS_init_rtos ( void )

BOOL FS_isdir ( const char * path )

BOOL FS_mkdir ( const char * path )

fs_fd_type FS_open | ( | const char * | filename,
 |  | ushort | flag,
 |  | ushort | mode
 | ) |

BOOL FS_read | ( | fs_fd_type | fd,
 |  | ubyte huge * | buffer,
 |  | ulong | count
 | ) |

ulong FS_read_max | ( | fs_fd_type | fd,
 |  | ubyte huge * | buffer,
 |  | ulong | count
 | ) |

BOOL FS_read_streaming | ( | fs_fd_type | fd,
 |  | ubyte huge * | buffer,
 |  | ulong | count,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

BOOL FS_register_media_status_notification | ( | fs_device_type | device,
 |  | void(*)(fs_device_type device, BOOL media_present, void *client_arg) | notify_func,
 |  | void * | client_arg
 | ) |

BOOL FS_rename | ( | const char * | old_filename,
 |  | const char * | new_filename
 | ) |

BOOL FS_rmdir ( const char * path )

ulong FS_seek | ( | fs_fd_type | fd,
 |  | slong | offset,
 |  | sshort | origin,
 |  | sshort * | err_flag
 | ) |

BOOL FS_set_attributes | ( | const char * | filename,
 |  | ushort | attributes
 | ) |

BOOL FS_set_default_device ( fs_device_type device )

BOOL FS_set_file_pos_streaming | ( | fs_fd_type | fd,
 |  | ulong | pos,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

BOOL FS_setcwd ( const char * path )

BOOL FS_stat | ( | const char * | filename,
 |  | fs_stat_type * | pstat
 | ) |

BOOL FS_truncate | ( | fs_fd_type | fd,
 |  | ulong | new_size
 | ) |

BOOL FS_write | ( | fs_fd_type | fd,
 |  | const ubyte huge * | buffer,
 |  | ulong | count
 | ) |

BOOL FS_write_streaming | ( | fs_fd_type | fd,
 |  | const ubyte huge * | buffer,
 |  | ulong | count,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

const char* GetDeviceId ( const char drive_letter )

const char* GetDeviceId ( fs_device_type device )

void HostInitFatFsStorageDevices ( const HostFatFsDeviceDescMapPtr & device_map )

Generated on Tue Jan 24 16:22:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatSim.hpp File Reference

AddOns/AfsFat/FatSim.hpp File Reference

#include <Auxiliary/SimpleMap.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for FatSim.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | datestr
struct | dstat
struct | fs_registered_info_type
struct | fs_stat
struct | HostFatFsDeviceDescriptor

Defines

#define | ADIRENT 0x10
#define | AHIDDEN 0x02
#define | ANORMAL 0x00
#define | Apoxi_FatSim_hpp
#define | ARCHIVE 0x20
#define | ARDONLY 0x01
#define | ASYSTEM 0x04
#define | AVOLUME 0x08
#define | CHICAGO_EXT 0x0F
#define | CRERR_BAD_FORMAT 301
#define | CRERR_BAD_MEDIA 303
#define | CRERR_ECC_ERROR 307
#define | CRERR_ID_ERROR 306
#define | CRERR_MEDIA_CHANGED 304
#define | CRERR_MEDIA_FAILURE 305
#define | CRERR_NO_MEDIA 302
#define | FS_APPEND PO_APPEND
#define | FS_BINARY PO_BINARY
#define | FS_CREAT PO_CREAT
#define | FS_ERR_ACCES PEACCES
#define | FS_ERR_BAD_FORMAT CRERR_BAD_FORMAT
#define | FS_ERR_BAD_MEDIA CRERR_BAD_MEDIA
#define | FS_ERR_BADF PEBADF
#define | FS_ERR_DEVICE PEDEVICE
#define | FS_ERR_ECC_ERROR CRERR_ECC_ERROR
#define | FS_ERR_EXIST PEEXIST
#define | FS_ERR_FAULT PEFAULT
#define | FS_ERR_ID_ERROR CRERR_ID_ERROR
#define | FS_ERR_INVAL PEINVAL
#define | FS_ERR_IO PEIO
#define | FS_ERR_MEDIA_CHANGED CRERR_MEDIA_CHANGED
#define | FS_ERR_MEDIA_FAILURE CRERR_MEDIA_FAILURE
#define | FS_ERR_MFILE PEMFILE
#define | FS_ERR_NO_MEDIA CRERR_NO_MEDIA
#define | FS_ERR_NOENT PENOENT
#define | FS_ERR_NOSPC PENOSPC
#define | FS_ERR_OPERATION_NOT_POSSIBLE 3
#define | FS_ERR_SHARE PESHARE
#define | FS_ERR_USER_ID_ERROR 4
#define | FS_EXCL PO_EXCL
#define | FS_FAILURE 0
#define | FS_INVALID_FILEHANDLE INVALID_PCFD
#define | FS_IREAD PS_IREAD
#define | FS_IWRITE PS_IWRITE
#define | FS_MAX_NO_OPEN_FILES 100
#define | FS_MAXPATH 256
#define | FS_NOF_DEVICES 3
#define | FS_NOSHAREANY PO_NOSHAREANY
#define | FS_NOSHAREWRITE PO_NOSHAREWRITE
#define | FS_RDONLY PO_RDONLY
#define | FS_RDWR PO_RDWR
#define | FS_SEEK_CUR PSEEK_CUR
#define | FS_SEEK_END PSEEK_END
#define | FS_SEEK_SET PSEEK_SET
#define | FS_SUCCESS 1
#define | FS_TEXT PO_TEXT
#define | FS_TRUNC PO_TRUNC
#define | FS_WRONLY PO_WRONLY
#define | huge
#define | INVALID_PCFD -1
#define | PCFD long
#define | PEACCES 13
#define | PEBADF 9
#define | PEDEVICE 31
#define | PEEXIST 17
#define | PEFAULT 18
#define | PEINVAL 22
#define | PEIO 19
#define | PEMFILE 24
#define | PENOENT 2
#define | PENOSPC 28
#define | PESHARE 30
#define | PESUCCESS 1
#define | PO_APPEND 0x0800
#define | PO_BINARY 0x8000
#define | PO_CREAT 0x0100
#define | PO_EXCL 0x0400
#define | PO_NOSHAREANY 0x0010
#define | PO_NOSHAREWRITE 0x0020
#define | PO_RDONLY 0x0000
#define | PO_RDWR 0x0002
#define | PO_TEXT 0x4000
#define | PO_TRUNC 0x0200
#define | PO_WRONLY 0x0001
#define | PS_IREAD 0000200
#define | PS_IWRITE 0000400
#define | PSEEK_CUR 1
#define | PSEEK_END 2
#define | PSEEK_SET 0

Typedefs

typedef int | BOOL
typedef datestr | DATESTR
typedef dstat | DSTAT
typedef DSTAT | fs_dstat_type
typedef PCFD | fs_fd_type
typedef BOOL(* | FS_MS_StatusNotificationFunction_type )(fs_device_type drive_id, ConnectType request, void *user_data)
typedef STAT | fs_stat_type
typedef SimpleMap< const CHAR,
HostFatFsDeviceDescriptor > 		HostFatFsDeviceDescMap
typedef NiSharedPtr< HostFatFsDeviceDescMap > | HostFatFsDeviceDescMapPtr
typedef signed int | slong
typedef signed short | sshort
typedef fs_stat | STAT
typedef unsigned char | ubyte
typedef unsigned long | ulong
typedef unsigned short | ushort

Enumerations

enum | ConnectType { FS_MS_connect, FS_MS_disconnect }
enum fs_device_type {
FS_MMCSD_DEV = 1, FS_FTL_DEVICE1, FS_FFS_DEVICE, FS_TEST_DEVICE1 = 240,
FS_TEST_DEVICE2, FS_TEST_DEVICE3
}

Functions

BOOL | FS_assign_driveletter (fs_device_type device, char drive_letter)
BOOL | FS_close (fs_fd_type fd)
void | FS_deactivate (void)
BOOL | FS_delete (const char *filename)
void | FS_device_notify (long device_id, BOOL media_present)
void | FS_diskabort (fs_device_type device)
BOOL | FS_diskclose (fs_device_type device)
BOOL | FS_diskflush (fs_device_type device)
BOOL | FS_diskinfo (fs_device_type device, BOOL *mounted, ubyte *nof_partitions)
BOOL | FS_diskopen (fs_device_type device)
void | FS_finddone (fs_dstat_type *statobj)
BOOL | FS_findfirst (fs_dstat_type *statobj, const char *pattern)
BOOL | FS_findnext (fs_dstat_type *statobj)
BOOL | FS_flush (fs_fd_type fd)
BOOL | FS_format (fs_device_type device, BOOL quick)
ulong | FS_free (fs_device_type device)
BOOL | FS_get_attributes (const char *filename, ushort *attributes)
fs_device_type | FS_get_default_device (void)
BOOL | FS_get_file_length_streaming (fs_fd_type fd, ulong *file_size, void(*callback)(sshort result, void *client_arg), void *client_arg)
BOOL | FS_get_file_pos_streaming (fs_fd_type fd, ulong *pos, void(*callback)(sshort result, void *client_arg), void *client_arg)
sshort | FS_get_last_device_error (fs_device_type device)
sshort | FS_get_last_error (void)
ubyte | FS_get_registered_devices (const fs_registered_info_type **device_list)
BOOL | FS_getcwd (const char *drive, char *path)
BOOL | FS_init_rtos (void)
BOOL | FS_isdir (const char *path)
BOOL | FS_mkdir (const char *path)
BOOL | FS_MS_AssignStatusNotificationFunction (FS_MS_StatusNotificationFunction_type notification_function, void *user_data)
fs_fd_type | FS_open (const char *filename, ushort flag, ushort mode)
BOOL | FS_read (fs_fd_type fd, ubyte huge *buffer, ulong count)
ulong | FS_read_max (fs_fd_type fd, ubyte huge *buffer, ulong count)
BOOL | FS_read_streaming (fs_fd_type fd, ubyte huge *buffer, ulong count, void(*callback)(sshort result, void *client_arg), void *client_arg)
BOOL | FS_register_media_status_notification (fs_device_type device, void(*notify_func)(fs_device_type device, BOOL media_present, void *client_arg), void *client_arg)
BOOL | FS_rename (const char *old_filename, const char *new_filename)
BOOL | FS_rmdir (const char *path)
ulong | FS_seek (fs_fd_type fd, slong offset, sshort origin, sshort *err_flag)
BOOL | FS_set_attributes (const char *filename, ushort attributes)
BOOL | FS_set_default_device (fs_device_type device)
BOOL | FS_set_file_pos_streaming (fs_fd_type fd, ulong pos, void(*callback)(sshort result, void *client_arg), void *client_arg)
BOOL | FS_setcwd (const char *path)
BOOL | FS_stat (const char *filename, fs_stat_type *pstat)
BOOL | FS_truncate (fs_fd_type fd, ulong new_size)
BOOL | FS_write (fs_fd_type fd, const ubyte huge *buffer, ulong count)
BOOL | FS_write_streaming (fs_fd_type fd, const ubyte huge *buffer, ulong count, void(*callback)(sshort result, void *client_arg), void *client_arg)
void | HostInitFatFsStorageDevices (const HostFatFsDeviceDescMapPtr &device_map)

Define Documentation

#define ADIRENT 0x10

#define AHIDDEN 0x02

#define ANORMAL 0x00

#define Apoxi_FatSim_hpp

#define ARCHIVE 0x20

#define ARDONLY 0x01

#define ASYSTEM 0x04

#define AVOLUME 0x08

#define CHICAGO_EXT 0x0F

#define CRERR_BAD_FORMAT 301

#define CRERR_BAD_MEDIA 303

#define CRERR_ECC_ERROR 307

#define CRERR_ID_ERROR 306

#define CRERR_MEDIA_CHANGED 304

#define CRERR_MEDIA_FAILURE 305

#define CRERR_NO_MEDIA 302

#define FS_APPEND PO_APPEND

#define FS_BINARY PO_BINARY

#define FS_CREAT PO_CREAT

#define FS_ERR_ACCES PEACCES

#define FS_ERR_BAD_FORMAT CRERR_BAD_FORMAT

#define FS_ERR_BAD_MEDIA CRERR_BAD_MEDIA

#define FS_ERR_BADF PEBADF

#define FS_ERR_DEVICE PEDEVICE

#define FS_ERR_ECC_ERROR CRERR_ECC_ERROR

#define FS_ERR_EXIST PEEXIST

#define FS_ERR_FAULT PEFAULT

#define FS_ERR_ID_ERROR CRERR_ID_ERROR

#define FS_ERR_INVAL PEINVAL

#define FS_ERR_IO PEIO

#define FS_ERR_MEDIA_CHANGED CRERR_MEDIA_CHANGED

#define FS_ERR_MEDIA_FAILURE CRERR_MEDIA_FAILURE

#define FS_ERR_MFILE PEMFILE

#define FS_ERR_NO_MEDIA CRERR_NO_MEDIA

#define FS_ERR_NOENT PENOENT

#define FS_ERR_NOSPC PENOSPC

#define FS_ERR_OPERATION_NOT_POSSIBLE 3

#define FS_ERR_SHARE PESHARE

#define FS_ERR_USER_ID_ERROR 4

#define FS_EXCL PO_EXCL

#define FS_FAILURE 0

#define FS_INVALID_FILEHANDLE INVALID_PCFD

#define FS_IREAD PS_IREAD

#define FS_IWRITE PS_IWRITE

#define FS_MAX_NO_OPEN_FILES 100

#define FS_MAXPATH 256

#define FS_NOF_DEVICES 3

#define FS_NOSHAREANY PO_NOSHAREANY

#define FS_NOSHAREWRITE PO_NOSHAREWRITE

#define FS_RDONLY PO_RDONLY

#define FS_RDWR PO_RDWR

#define FS_SEEK_CUR PSEEK_CUR

#define FS_SEEK_END PSEEK_END

#define FS_SEEK_SET PSEEK_SET

#define FS_SUCCESS 1

#define FS_TEXT PO_TEXT

#define FS_TRUNC PO_TRUNC

#define FS_WRONLY PO_WRONLY

#define huge

#define INVALID_PCFD -1

#define PCFD long

#define PEACCES 13

#define PEBADF 9

#define PEDEVICE 31

#define PEEXIST 17

#define PEFAULT 18

#define PEINVAL 22

#define PEIO 19

#define PEMFILE 24

#define PENOENT 2

#define PENOSPC 28

#define PESHARE 30

#define PESUCCESS 1

#define PO_APPEND 0x0800

#define PO_BINARY 0x8000

#define PO_CREAT 0x0100

#define PO_EXCL 0x0400

#define PO_NOSHAREANY 0x0010

#define PO_NOSHAREWRITE 0x0020

#define PO_RDONLY 0x0000

#define PO_RDWR 0x0002

#define PO_TEXT 0x4000

#define PO_TRUNC 0x0200

#define PO_WRONLY 0x0001

#define PS_IREAD 0000200

#define PS_IWRITE 0000400

#define PSEEK_CUR 1

#define PSEEK_END 2

#define PSEEK_SET 0

Typedef Documentation

typedef int BOOL

typedef struct datestr DATESTR

typedef struct dstat DSTAT

typedef DSTAT fs_dstat_type

typedef PCFD fs_fd_type

typedef BOOL(* FS_MS_StatusNotificationFunction_type)(fs_device_type drive_id, ConnectType request, void *user_data)

typedef STAT fs_stat_type

typedef SimpleMap<const CHAR, HostFatFsDeviceDescriptor> HostFatFsDeviceDescMap

typedef NiSharedPtr<HostFatFsDeviceDescMap> HostFatFsDeviceDescMapPtr

typedef signed int slong

typedef signed short sshort

typedef struct fs_stat STAT

typedef unsigned char ubyte

typedef unsigned long ulong

typedef unsigned short ushort

Enumeration Type Documentation

enum ConnectType

Enumerator:
FS_MS_connect
FS_MS_disconnect

enum fs_device_type

Enumerator:
FS_MMCSD_DEV
FS_FTL_DEVICE1
FS_FFS_DEVICE
FS_TEST_DEVICE1
FS_TEST_DEVICE2
FS_TEST_DEVICE3

Function Documentation

BOOL FS_assign_driveletter | ( | fs_device_type | device,
 |  | char | drive_letter
 | ) |

BOOL FS_close ( fs_fd_type fd )

void FS_deactivate ( void )

BOOL FS_delete ( const char * filename )

void FS_device_notify | ( | long | device_id,
 |  | BOOL | media_present
 | ) |

void FS_diskabort ( fs_device_type device )

BOOL FS_diskclose ( fs_device_type device )

BOOL FS_diskflush ( fs_device_type device )

BOOL FS_diskinfo | ( | fs_device_type | device,
 |  | BOOL * | mounted,
 |  | ubyte * | nof_partitions
 | ) |

BOOL FS_diskopen ( fs_device_type device )

void FS_finddone ( fs_dstat_type * statobj )

BOOL FS_findfirst | ( | fs_dstat_type * | statobj,
 |  | const char * | pattern
 | ) |

BOOL FS_findnext ( fs_dstat_type * statobj )

BOOL FS_flush ( fs_fd_type fd )

BOOL FS_format | ( | fs_device_type | device,
 |  | BOOL | quick
 | ) |

ulong FS_free ( fs_device_type device )

BOOL FS_get_attributes | ( | const char * | filename,
 |  | ushort * | attributes
 | ) |

fs_device_type FS_get_default_device ( void )

BOOL FS_get_file_length_streaming | ( | fs_fd_type | fd,
 |  | ulong * | file_size,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

BOOL FS_get_file_pos_streaming | ( | fs_fd_type | fd,
 |  | ulong * | pos,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

sshort FS_get_last_device_error ( fs_device_type device )

sshort FS_get_last_error ( void )

ubyte FS_get_registered_devices ( const fs_registered_info_type ** device_list )

BOOL FS_getcwd | ( | const char * | drive,
 |  | char * | path
 | ) |

BOOL FS_init_rtos ( void )

BOOL FS_isdir ( const char * path )

BOOL FS_mkdir ( const char * path )

BOOL FS_MS_AssignStatusNotificationFunction | ( | FS_MS_StatusNotificationFunction_type | notification_function,
 |  | void * | user_data
 | ) |

fs_fd_type FS_open | ( | const char * | filename,
 |  | ushort | flag,
 |  | ushort | mode
 | ) |

BOOL FS_read | ( | fs_fd_type | fd,
 |  | ubyte huge * | buffer,
 |  | ulong | count
 | ) |

ulong FS_read_max | ( | fs_fd_type | fd,
 |  | ubyte huge * | buffer,
 |  | ulong | count
 | ) |

BOOL FS_read_streaming | ( | fs_fd_type | fd,
 |  | ubyte huge * | buffer,
 |  | ulong | count,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

BOOL FS_register_media_status_notification | ( | fs_device_type | device,
 |  | void(*)(fs_device_type device, BOOL media_present, void *client_arg) | notify_func,
 |  | void * | client_arg
 | ) |

BOOL FS_rename | ( | const char * | old_filename,
 |  | const char * | new_filename
 | ) |

BOOL FS_rmdir ( const char * path )

ulong FS_seek | ( | fs_fd_type | fd,
 |  | slong | offset,
 |  | sshort | origin,
 |  | sshort * | err_flag
 | ) |

BOOL FS_set_attributes | ( | const char * | filename,
 |  | ushort | attributes
 | ) |

BOOL FS_set_default_device ( fs_device_type device )

BOOL FS_set_file_pos_streaming | ( | fs_fd_type | fd,
 |  | ulong | pos,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

BOOL FS_setcwd ( const char * path )

BOOL FS_stat | ( | const char * | filename,
 |  | fs_stat_type * | pstat
 | ) |

BOOL FS_truncate | ( | fs_fd_type | fd,
 |  | ulong | new_size
 | ) |

BOOL FS_write | ( | fs_fd_type | fd,
 |  | const ubyte huge * | buffer,
 |  | ulong | count
 | ) |

BOOL FS_write_streaming | ( | fs_fd_type | fd,
 |  | const ubyte huge * | buffer,
 |  | ulong | count,
 |  | void(*)(sshort result, void *client_arg) | callback,
 |  | void * | client_arg
 | ) |

void HostInitFatFsStorageDevices ( const HostFatFsDeviceDescMapPtr & device_map )

Generated on Tue Jan 24 16:22:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatSim.hpp Source File

AddOns/AfsFat/FatSim.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FatSim_hpp)
00011 #define Apoxi_FatSim_hpp
00012
00013 typedef unsigned char ubyte;
00014 typedef signed short sshort;
00015 typedef unsigned short ushort;
00016 typedef signed int slong;
00017
00018 typedef unsigned long ulong;
00019 typedef int BOOL;
00020
00021 /* We define huge to the empty string for removing the huge modifier from the
00022    \dwddrv\FS\src\fs.h interfaces (see below). */
00023 #define huge
00024
00025 /****************************************************************************/
00026 /*              \dwddrv\FS\src\fs_config.h                                  */
00027 /****************************************************************************/
00028
00029 /* Maximum path length. */
00030 #define FS_MAXPATH        256
00031
00032 /* Maximum number of open files.
00033    This is the number of simultaneous
00034    files that may be opened at one time. */
00035 #define FS_MAX_NO_OPEN_FILES           100
00036
00037 #define FS_NOF_DEVICES 3 // This is the maximum number of device, which can be registered.
00038
00039 /* Definition of the supported device types */
00040 typedef enum
00041 {
00042     // Zero is a reserved value;
00043     FS_MMCSD_DEV    = 1,
00044     FS_FTL_DEVICE1,
00045     FS_FFS_DEVICE,
00046     // Insert new device types aboce this line
00047
00048     // Form this point is special devices used in host test environment
00049     FS_TEST_DEVICE1 = 240,
00050     FS_TEST_DEVICE2,
00051     FS_TEST_DEVICE3
00052 } fs_device_type;
00053
00054 /****************************************************************************/
00055 /*              \dwddrv\FS\src\fs_sdapi.h                                   */
00056 /****************************************************************************/
00057
00058 #define PCFD     long          /* file desc */
00059 #define INVALID_PCFD    -1
00060
00061 /*********************** CRITICAL_ERROR_HANDLER ******************************/
00062 /* Arguments to critical_error_handler() */
00063 #define CRERR_BAD_FORMAT        301
00064 #define CRERR_NO_MEDIA           302
00065 #define CRERR_BAD_MEDIA          303
00066 #define CRERR_MEDIA_CHANGED      304
00067 #define CRERR_MEDIA_FAILURE      305
00068 #define CRERR_ID_ERROR          306
00069 #define CRERR_ECC_ERROR         307
00070
00071 /* Date stamp structure */
00072 typedef struct datestr {
00073     ushort date;            /* Current Date */
00074     ushort time;            /* Current time */
00075 } DATESTR;
00076
00077 /* Structure for user to do recursive search for files in a selected drive */
00078 typedef struct dstat {
00079    char    fname[10];      /* Null terminated file and extension */
00080    char    fext[4];
00081    ushort  fattribute;     /* File attributes */
00082    ushort  ftime;          /* Time & Date last modified. See date */
00083    ushort  fdate;          /* and time handlers for getting info */
00084    ulong   fsize;          /* File size */
00085    sshort  driveno;
00086    char    longFileName[FS_MAXPATH];
00087    char    pname[10];      /* Pattern. */
00088    char    pext[4];
00089    char    path[FS_MAXPATH];
00090    char    plongFileName[FS_MAXPATH];
00091    void    *pobj;
00092    void    *pmom;
00093 } DSTAT;
00094
00095 /****************************************************************************/
00096 /**************************** FILE SYSTEM API *******************************/
00097 /****************************************************************************/
00098
00099 #define ARDONLY         0x01    /* MS-DOS File attributes */
00100 #define AHIDDEN         0x02
00101 #define ASYSTEM         0x04
00102 #define AVOLUME         0x08
00103 #define ADIRENT         0x10
00104 #define ARCHIVE         0x20
00105 #define ANORMAL         0x00
00106 #define CHICAGO_EXT     0x0F    /* Chicago extended filename attribute */
00107
00108 /*
00109 ** Structure for use by with file statistic.
00110 ** Portions of this structure and the macros were lifted from BSD sources.
00111 ** See the RTFS ANSI library for BSD terms & conditions.
00112 */
00113 typedef struct fs_stat
00114 {
00115     ulong   st_mode;        /* (see S_xxxx below) */
00116     ulong   st_size;        /* file size, in bytes */
00117     slong    st_blksize;     /* optimal blocksize for I/O (cluster size) */
00118     slong    st_blocks;      /* blocks allocated for file */
00119     DATESTR st_atime;       /* last access (all times are the same) */
00120     DATESTR st_mtime;       /* last modification */
00121     DATESTR st_ctime;       /* last file status change */
00122     sshort   st_dev;         /* (drive number, rtfs) */
00123     sshort   st_ino;         /* inode number (0) */
00124     sshort   st_nlink;       /* (always 1) */
00125     sshort   st_rdev;        /* (drive number, rtfs) */
00126     ushort  fattribute;     /* File attributes - DOS attributes
00127                             (non standard but useful)
00128                             */
00129     ushort  padding;
00130 } STAT;
00131
00132 /* File creation permissions for open */
00133 /* Note: OCTAL */
00134 #define PS_IWRITE       0000400 /* Write permitted  */
00135 #define PS_IREAD        0000200 /* Read permitted. (Always true anyway) */
00136
00137 /* File access flags */
00138 #define PO_RDONLY       0x0000 /* Open for read only */
00139 #define PO_WRONLY       0x0001 /* Open for write only */
00140 #define PO_RDWR         0x0002 /* Read/write access allowed. */
00141 #define PO_CREAT        0x0100 /* Create the file if it does not exist. */
00142 #define PO_TRUNC        0x0200 /* Truncate the file if it already exists */
00143 #define PO_EXCL         0x0400 /* Fail if creating and already exists */
00144 #define PO_APPEND       0x0800 /* Seek to eof on each write */
00145 #define PO_TEXT         0x4000 /* Ignored */
00146 #define PO_BINARY       0x8000 /* Ignored. All file access is binary */
00147 #define PO_NOSHAREANY   0x0010 /* Wants this open to fail if already open.
00148                                   Other opens will fail while this open
00149                                   is active */
00150 #define PO_NOSHAREWRITE 0x0020 /* Wants this opens to fail if already open
00151                                   for write. Other open for write calls
00152                                   will fail while this open is active. */
00153
00154 /* ErrNO values */
00155 #define PESUCCESS       1       /* No error */
00156 #define PENOENT         2       /* File not found or path to file not found */
00157 #define PEBADF          9       /* Invalid file descriptor */
00158 #define PEACCES         13      /* Attempt to open a read only file or a special (directory) */
00159 #define PEEXIST         17      /* Exclusive access requested but file already exists. */
00160 #define PEFAULT         18      /* Unknown error. */
00161 #define PEIO            19      /* I/O error.. */
00162 #define PEINVAL         22      /* Seek to negative file pointer attempted. */
00163 #define PEMFILE         24      /* No file descriptors available (too many files open) */
00164 #define PENOSPC         28      /* Write failed. Presumably because of no space */
00165 #define PESHARE         30      /* Open failed do to sharing */
00166 #define PEDEVICE        31      /* No Valid Disk Present */
00167
00168 /* Arguments to SEEK */
00169 #define PSEEK_SET       0       /* offset from begining of file */
00170 #define PSEEK_CUR       1       /* offset from current file pointer */
00171 #define PSEEK_END       2       /* offset from end of file */
00172
00173 /****************************************************************************/
00174 /*              \dwddrv\FS\src\fs.h                                         */
00175 /****************************************************************************/
00176
00177 // FS error codes:
00178 #define FS_FAILURE                     0
00179 #define FS_SUCCESS                     1
00180 #define FS_ERR_OPERATION_NOT_POSSIBLE  3
00181 #define FS_ERR_USER_ID_ERROR           4
00182
00183 /*********************** CRITICAL_ERROR_HANDLER ******************************/
00184 /* Arguments to critical_error_handler() */
00185 #define FS_ERR_BAD_FORMAT              CRERR_BAD_FORMAT        //301
00186 #define FS_ERR_NO_MEDIA                CRERR_NO_MEDIA         //302
00187 #define FS_ERR_BAD_MEDIA               CRERR_BAD_MEDIA        //303
00188 #define FS_ERR_MEDIA_CHANGED           CRERR_MEDIA_CHANGED    //304
00189 #define FS_ERR_MEDIA_FAILURE           CRERR_MEDIA_FAILURE    //305
00190 #define FS_ERR_ID_ERROR                CRERR_ID_ERROR          //306
00191 #define FS_ERR_ECC_ERROR               CRERR_ECC_ERROR         //307
00192
00193 /* Filesystem Errno values */
00194 #define FS_ERR_NOENT                   PENOENT  //  2      /* File not found or path to file not found */
00195 #define FS_ERR_BADF                    PEBADF   //  9      /* Invalid file descriptor */
00196 #define FS_ERR_ACCES                   PEACCES  // 13      /* Attempt to open a read only file or a special (directory) */
00197 #define FS_ERR_EXIST                   PEEXIST  // 17      /* Exclusive access requested but file already exists. */
00198 #define FS_ERR_FAULT                   PEFAULT  // 18      /* Unknown error. */
00199 #define FS_ERR_IO                      PEIO     // 19      /* I/O error. */
00200 #define FS_ERR_INVAL                   PEINVAL  // 22      /* Seek to negative file pointer attempted. */
00201 #define FS_ERR_MFILE                   PEMFILE  // 24      /* No file descriptors available (too many files open) */
00202 #define FS_ERR_NOSPC                   PENOSPC  // 28      /* Write failed. Presumably because of no space */
00203 #define FS_ERR_SHARE                   PESHARE  // 30      /* Open failed do to sharing */
00204 #define FS_ERR_DEVICE                  PEDEVICE // 31      /* No Valid Disk Present */
00205
00206 /* Arguments to SEEK */
00207 #define FS_SEEK_SET                    PSEEK_SET       /* offset from begining of file */
00208 #define FS_SEEK_CUR                    PSEEK_CUR       /* offset from current file pointer */
00209 #define FS_SEEK_END                    PSEEK_END       /* offset from end of file */
00210
00211 /* File open flags */
00212 #define FS_RDONLY                      PO_RDONLY       /* Open for read only */
00213 #define FS_WRONLY                      PO_WRONLY       /* Open for write only */
00214 #define FS_RDWR                        PO_RDWR         /* Read/write access allowed. */
00215 #define FS_APPEND                      PO_APPEND       /* Seek to eof on each write */
00216 #define FS_CREAT                       PO_CREAT        /* Create the file if it does not exist. */
00217 #define FS_TRUNC                       PO_TRUNC        /* Truncate the file if it already exists */
00218 #define FS_EXCL                        PO_EXCL         /* Fail if creating and already exists */
00219 #define FS_TEXT                        PO_TEXT         /* Ignored */
00220 #define FS_BINARY                      PO_BINARY       /* Ignored. All file access is binary */
00221 #define FS_NOSHAREANY                  PO_NOSHAREANY   /* Wants this open to fail if already open. Other opens will fail while this open is active */
00222 #define FS_NOSHAREWRITE                PO_NOSHAREWRITE /* Wants this opens to fail if already open for write. Other open for write calls will fail while this open is active. */
00223
00224 /* File open modes */
00225 #define FS_IWRITE                      PS_IWRITE /* Write permitted */
00226 #define FS_IREAD                       PS_IREAD  /* Read permitted. (Always true anyway) */
00227
00228 typedef struct
00229 {
00230     fs_device_type device;
00231     char           drive_letter;
00232     BOOL           removable;
00233     BOOL           indication;
00234     BOOL           media_present;
00235     void           (*notification_func)(fs_device_type device, BOOL media_present, void *client_arg);
00236     void           *client_arg;
00237 }  fs_registered_info_type;
00238
00239 /* Structure for user to do recursive search for files in a selected drive */
00240 typedef DSTAT fs_dstat_type;
00241
00242 /*
00243 ** Structure for use by with file statistic.
00244 */
00245 typedef STAT fs_stat_type;
00246
00247 /*
00248 ** File handle returned by FS_open and used in later file operations.
00249 */
00250 typedef PCFD fs_fd_type;
00251 #define FS_INVALID_FILEHANDLE INVALID_PCFD
00252
00253 /*---------------------------------------*/
00254 /* global functions.                     */
00255 /*---------------------------------------*/
00256
00257 //Init/deactivate functions:
00258 extern BOOL FS_init_rtos(void);
00259 extern void FS_deactivate(void);
00260
00261 //Register devices
00262 extern ubyte FS_get_registered_devices(const fs_registered_info_type **device_list) ;
00263 extern BOOL FS_assign_driveletter(fs_device_type device, char drive_letter);
00264 extern BOOL FS_register_media_status_notification(fs_device_type device, void (*notify_func)(fs_device_type device, BOOL media_present, void *client_arg), void *client_arg);
00265 extern void FS_device_notify(long device_id, BOOL media_present);
00266
00267 //Disk/device services:
00268 extern BOOL FS_diskopen(fs_device_type device);
00269 extern BOOL FS_diskflush(fs_device_type device);
00270 extern BOOL FS_diskclose(fs_device_type device);
00271 extern void FS_diskabort(fs_device_type device);
00272 extern BOOL FS_diskinfo(fs_device_type device, BOOL *mounted, ubyte *nof_partitions);
00273
00274 extern BOOL FS_format(fs_device_type device, BOOL quick);
00275 extern ulong FS_free(fs_device_type device);
00276
00277 extern fs_device_type FS_get_default_device(void);
00278 extern BOOL FS_set_default_device(fs_device_type device);
00279
00280 //FS directory operating functions:
00281 extern BOOL FS_mkdir(const char *path);
00282 extern BOOL FS_rmdir(const char *path);
00283 extern BOOL FS_isdir(const char *path);
00284
00285 extern BOOL FS_getcwd(const char *drive, char *path);
00286 extern BOOL FS_setcwd(const char *path);
00287
00288 extern BOOL FS_findfirst(fs_dstat_type *statobj, const char *pattern);
00289 extern BOOL FS_findnext(fs_dstat_type *statobj);
00290 extern void FS_finddone(fs_dstat_type *statobj);
00291
00292 //FS file operating functions:
00293 extern fs_fd_type FS_open(const char *filename, ushort flag, ushort mode);
00294 extern BOOL FS_close(fs_fd_type fd);
00295 extern BOOL FS_read(fs_fd_type fd, ubyte huge *buffer, ulong count);
00296 extern ulong FS_read_max(fs_fd_type fd, ubyte huge *buffer, ulong count);
00297 extern BOOL FS_write(fs_fd_type fd, const ubyte huge *buffer, ulong count);
00298 extern BOOL FS_flush(fs_fd_type fd);
00299 extern BOOL FS_truncate(fs_fd_type fd, ulong new_size);
00300
00301 //FS Streaming data
00302 extern BOOL FS_read_streaming(fs_fd_type fd, ubyte huge *buffer, ulong count, void (*callback)(sshort result, void *client_arg), void *client_arg);
00303 extern BOOL FS_write_streaming(fs_fd_type fd, const ubyte huge *buffer, ulong count, void (*callback)(sshort result, void *client_arg), void *client_arg);
00304 extern BOOL FS_get_file_length_streaming(fs_fd_type fd, ulong *file_size, void (*callback)(sshort result, void *client_arg), void *client_arg);
00305 extern BOOL FS_get_file_pos_streaming(fs_fd_type fd, ulong *pos, void (*callback)(sshort result, void *client_arg), void *client_arg);
00306 extern BOOL FS_set_file_pos_streaming(fs_fd_type fd, ulong pos, void (*callback)(sshort result, void *client_arg), void *client_arg);
00307
00308 extern BOOL FS_rename(const char *old_filename, const char *new_filename);
00309 extern BOOL FS_delete(const char *filename);
00310
00311 extern BOOL FS_get_attributes(const char *filename, ushort *attributes);
00312 extern BOOL FS_set_attributes(const char *filename, ushort attributes);
00313
00314 extern ulong FS_seek(fs_fd_type fd, slong offset, sshort origin, sshort *err_flag);
00315 extern BOOL FS_stat(const char *filename, fs_stat_type *pstat);
00316
00317 //FS Errorhandling
00318 extern sshort FS_get_last_error(void);
00319 extern sshort FS_get_last_device_error(fs_device_type device);
00320
00321 /****************************************************************************/
00322 /*              \dwddrv\FS\src\fs_massstorage_APOXI.h                       */
00323 /****************************************************************************/
00324
00325 typedef enum {
00326     FS_MS_connect,
00327     FS_MS_disconnect
00328 } ConnectType;
00329
00330 typedef BOOL (*FS_MS_StatusNotificationFunction_type)(
00331     fs_device_type drive_id,
00332     ConnectType request,
00333     void *user_data);
00334
00335 BOOL FS_MS_AssignStatusNotificationFunction(FS_MS_StatusNotificationFunction_type notification_function, void *user_data);
00336
00337 /****************************************************************************/
00338 /*              non-driver related interface                                */
00339 /****************************************************************************/
00340
00341 #include <Auxiliary/SimpleMap.hpp>
00342 #include <Auxiliary/String.hpp>
00343 #include <Auxiliary/NiSharedPtr.hpp>
00344
00345 // The host storage device descriptor.
00346 struct HostFatFsDeviceDescriptor {
00347     String m_device_id;
00348     fs_device_type m_device;
00349
00350     HostFatFsDeviceDescriptor() : m_device(static_cast<fs_device_type>(0))
00351     { }
00352
00353     HostFatFsDeviceDescriptor(
00354         const String &m_device_id,
00355         fs_device_type m_device)
00356     :
00357         m_device_id(m_device_id),
00358         m_device(m_device)
00359     { }
00360 };
00361
00362 // Maps the drive letter to the according host storage device descriptor.
00363 typedef SimpleMap<const CHAR, HostFatFsDeviceDescriptor> HostFatFsDeviceDescMap;
00364
00365 // Shared pointer to the host storage device descriptor map.
00366 typedef NiSharedPtr<HostFatFsDeviceDescMap> HostFatFsDeviceDescMapPtr;
00367
00368 // Initializes the host simulator with the available storage devices.
00369 void HostInitFatFsStorageDevices(const HostFatFsDeviceDescMapPtr &device_map);
00370
00371 #endif  // Apoxi_FatSim_hpp
00372
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatStorageDeviceImp.cpp File Reference

AddOns/AfsFat/FatStorageDeviceImp.cpp File Reference

#include "PreComp.hpp"
#include "FatStorageDeviceImp.hpp"
#include "FatDirectoryIteratorImp.hpp"
#include "FatHandler.hpp"
#include "FatFileImp.hpp"
#include "FatFsMsgTypes.hpp"

Include dependency graph for FatStorageDeviceImp.cpp:

Defines

#define RFS_FAT_CHUNK_SIZE 1

Typedefs

typedef SimpleMap< FsDeviceType,
StorageDevicePtr > 		DeviceMap

Define Documentation

#define RFS_FAT_CHUNK_SIZE 1

Typedef Documentation

typedef SimpleMap<FsDeviceType, StorageDevicePtr> DeviceMap

Generated on Tue Jan 24 16:22:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatStorageDeviceImp.hpp File Reference

AddOns/AfsFat/FatStorageDeviceImp.hpp File Reference

#include <Afs/Rfs/StorageDevice.hpp>
#include <AddOns/AfsFat/FatTypes.hpp>

Include dependency graph for FatStorageDeviceImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FatStorageDeviceImp
Storage device implementation for FAT storage devices. More...
struct | FatStorageDeviceImp::FatFsDeviceDescriptor

Defines

#define | Apoxi_FatStorageDeviceImp_hpp

Define Documentation

#define Apoxi_FatStorageDeviceImp_hpp

Generated on Tue Jan 24 16:22:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatStorageDeviceImp.hpp Source File

AddOns/AfsFat/FatStorageDeviceImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FatStorageDeviceImp_hpp)
00011 #define Apoxi_FatStorageDeviceImp_hpp
00015
00016 #include <Afs/Rfs/StorageDevice.hpp>
00017 #include <AddOns/AfsFat/FatTypes.hpp>
00018
00023 class FatStorageDeviceImp : public StorageDevice
00024 {
00025     typedef StorageDevice Base;
00026
00027     friend class RootFileSystem;
00028     friend class FatFileImp;
00029     friend class FatFile;
00030     friend class FatDirectoryIteratorImp;
00031
00032     public:
00033         virtual BOOLEAN GetMediaAvailableStatus(BOOLEAN &media_present) const;
00034         virtual UINT32 GetFreeVolumeSize() const;
00035         virtual UINT32 GetTotalVolumeSize() const;
00036         virtual UINT32 GetUsedVolumeSize() const;
00037         virtual BOOLEAN IsReady() const;
00038         virtual BOOLEAN IsDirectory(const Pathname &pathname) const;
00039         virtual BOOLEAN Exists(const Pathname &pathname) const;
00040         virtual BOOLEAN Flush();
00041         virtual BOOLEAN Format(BOOLEAN quick = FALSE);
00042         virtual WString GetNativeFilePathname(const Pathname &pathname) const;
00043         virtual WString GetNativeDirectoryPathname(const Pathname &pathname)
00044             const;
00045         virtual UINT8 GetDefaultChunkSize() const;
00046
00047     private:
00048         struct FatFsDeviceDescriptor {
00050             FsDeviceType m_device_type;
00052             CHAR m_drive_letter;
00054             WString m_device_id;
00056             WString m_device_name;
00058             BOOLEAN m_removable_media;
00061             BOOLEAN m_media_available_notification;
00062
00063             FatFsDeviceDescriptor(
00064                 FsDeviceType device_type,
00065                 CHAR drive_letter,
00066                 const WString &device_id,
00067                 const WString &device_name,
00068                 BOOLEAN removable_media,
00069                 BOOLEAN media_available_notification)
00070             :
00071                 m_device_type(device_type),
00072                 m_drive_letter(drive_letter),
00073                 m_device_id(device_id),
00074                 m_device_name(device_name),
00075                 m_removable_media(removable_media),
00076                 m_media_available_notification(media_available_notification)
00077             { }
00078         };
00079
00081         static File::Error ConvertFatErrorToFileError(FatError fat_error);
00082
00088         FatStorageDeviceImp(const FatFsDeviceDescriptor &device_desc);
00089
00092         virtual ~FatStorageDeviceImp();
00093
00094         virtual FilePtr CreateFileObject(const Pathname &pathname) const;
00095         virtual DirectoryIteratorPtr CreateDirectoryIterator(
00096             const Pathname &dir_pathname, const FileFilterPtr &filter) const;
00097
00104         static BOOLEAN Setup();
00105
00112         static BOOLEAN Setup(FsDeviceType device_type);
00113
00114         virtual void OnNotifyMediaAvailableStatus(BOOLEAN media_present);
00115
00116         virtual BOOLEAN Shutdown();
00117
00118         BOOLEAN OnUsbMassStorageConnectEvent();
00119
00121         const FatFsDeviceDescriptor &m_desc;
00122
00123     private:
00124         friend class FatStorageDeviceImpInternals;
00125
00126         WString GetNativeHelper(const Pathname &pathname) const;
00127
00146         static BOOLEAN InitAndRegister(
00147             FsDeviceType device_type,
00148             CHAR drive_letter,
00149             BOOLEAN removable_media,
00150             BOOLEAN media_available_notification);
00151 };
00152
00154 #endif  // Apoxi_FatStorageDeviceImp_hpp
00155
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatTypes.hpp File Reference

AddOns/AfsFat/FatTypes.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for FatTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | FatFileInfo
struct | FatFindData
struct | FsRegistrationInfo

Defines

#define | Apoxi_FatTypes_hpp
#define | FatAccessFlagAppend FS_APPEND
#define | FatAccessFlagBinary FS_BINARY
#define | FatAccessFlagCreate FS_CREAT
#define | FatAccessFlagExcl FS_EXCL
#define | FatAccessFlagNoShareAny FS_NOSHAREANY
#define | FatAccessFlagNoShareWrite FS_NOSHAREWRITE
#define | FatAccessFlagRdOnly FS_RDONLY
#define | FatAccessFlagRdWr FS_RDWR
#define | FatAccessFlagText FS_TEXT
#define | FatAccessFlagTrunc FS_TRUNC
#define | FatAccessFlagWrOnly FS_WRONLY
#define | FatSeekBegin FS_SEEK_SET
#define | FatSeekCurrent FS_SEEK_CUR
#define | FatSeekEnd FS_SEEK_END

Typedefs

typedef fs_fd_type | FatHandle
typedef DATESTR | FatTimeRecord

Enumerations

enum FatError {
FatErrorFailure = FS_FAILURE, FatErrorSuccess = FS_SUCCESS, FatErrorOperationNotPossible = FS_ERR_OPERATION_NOT_POSSIBLE, FatErrorUserIdError = FS_ERR_USER_ID_ERROR,
FatErrorBadFormat = FS_ERR_BAD_FORMAT, FatErrorNoCard = FS_ERR_NO_MEDIA, FatErrorBadCard = FS_ERR_BAD_MEDIA, FatChangedCard = FS_ERR_MEDIA_CHANGED,
FatErrorCardFailure = FS_ERR_MEDIA_FAILURE, FatErrorIdError = FS_ERR_ID_ERROR, FatErrorEccError = FS_ERR_ECC_ERROR, FatErrorNotExist = FS_ERR_NOENT,
FatErrorBadFileDescriptor = FS_ERR_BADF, FatErrorAccessDenied = FS_ERR_ACCES, FatErrorFileAlreadyExist = FS_ERR_EXIST, FatErrorUnknown = FS_ERR_FAULT,
FatErrorIO = FS_ERR_IO, FatErrorNegativeFilePointer = FS_ERR_INVAL, FatErrorTooManyFileOpen = FS_ERR_MFILE, FatErrorNoSpace = FS_ERR_NOSPC,
FatErrorShare = FS_ERR_SHARE, FatErrorNoDisk = FS_ERR_DEVICE
}
enum FatFileAttribute {
FatFileAttrRdOnly = ARDONLY, FatFileAttrHidden = AHIDDEN, FatFileAttrSystem = ASYSTEM, FatFileAttrVolume = AVOLUME,
FatFileAttrDirectory = ADIRENT, FatFileAttrArchive = ARCHIVE, FatFileAttrNormal = ANORMAL, FatFileAttrChicagoExt = CHICAGO_EXT
}
enum | FatOpenMode { FatReadOnlyMode = FS_IREAD, FatReadAndWriteMode = FS_IREAD | FS_IWRITE }
enum | FsDeviceType { FsMmcSdDev = FS_MMCSD_DEV, FsNandDev = FS_FTL_DEVICE1, FsFatFfsDev = FS_FFS_DEVICE }

Variables

const UINT | c_max_fat_filename_len = FS_MAXPATH
const UINT | c_max_fat_max_no_open_files = FS_MAX_NO_OPEN_FILES

Define Documentation

#define Apoxi_FatTypes_hpp

Generated on Tue Jan 24 16:22:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/FatTypes.hpp Source File

AddOns/AfsFat/FatTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FatTypes_hpp)
00011 #define Apoxi_FatTypes_hpp
00014
00015 #if !defined(APOXI_LIB_ADDON_AFSFAT)
00016     #error The FAT filesystem (FAT) add-on is not activated properly - please enable feature AFSFAT!
00017 #elif defined(APOXI_RTOS_WIN32)
00018     // Host simulator for FAT devices.
00019     #include <AddOns/AfsFat/FatSim.hpp>
00020 #else
00021     #include <stack/driver.h>
00022 #endif
00023
00024 #include <Kernel/Types.hpp>
00025
00026 const UINT c_max_fat_filename_len = FS_MAXPATH;
00027 const UINT c_max_fat_max_no_open_files = FS_MAX_NO_OPEN_FILES;
00028
00029 typedef fs_fd_type FatHandle;
00030
00031 // FS error codes:
00032 enum FatError {
00033     FatErrorFailure                 = FS_FAILURE,
00034     FatErrorSuccess                 = FS_SUCCESS,
00035     FatErrorOperationNotPossible    = FS_ERR_OPERATION_NOT_POSSIBLE,
00036     FatErrorUserIdError             = FS_ERR_USER_ID_ERROR,
00037
00038     /* Arguments to critical_error_handler() */
00039     FatErrorBadFormat               = FS_ERR_BAD_FORMAT,
00040     FatErrorNoCard                  = FS_ERR_NO_MEDIA,
00041     FatErrorBadCard                 = FS_ERR_BAD_MEDIA,
00042     FatChangedCard                  = FS_ERR_MEDIA_CHANGED,
00043     FatErrorCardFailure             = FS_ERR_MEDIA_FAILURE,
00044     FatErrorIdError                 = FS_ERR_ID_ERROR,
00045     FatErrorEccError                = FS_ERR_ECC_ERROR,
00046
00047     /* Filesystem Errno values */
00048     FatErrorNotExist                = FS_ERR_NOENT, /* File not found or path to file not found */
00049     FatErrorBadFileDescriptor       = FS_ERR_BADF,  /* Invalid file descriptor */
00050     FatErrorAccessDenied            = FS_ERR_ACCES, /* Attempt to open a read only file or a special (directory) */
00051     FatErrorFileAlreadyExist        = FS_ERR_EXIST, /* Exclusive access requested but file already exists. */
00052     FatErrorUnknown                 = FS_ERR_FAULT, /* Unknown error. */
00053     FatErrorIO                      = FS_ERR_IO,    /* I/O error. */
00054     FatErrorNegativeFilePointer     = FS_ERR_INVAL, /* Seek to negative file pointer attempted. */
00055     FatErrorTooManyFileOpen         = FS_ERR_MFILE, /* No file descriptors available (too many files open) */
00056     FatErrorNoSpace                 = FS_ERR_NOSPC, /* Write failed. Presumably because of no space */
00057     FatErrorShare                   = FS_ERR_SHARE, /* Open failed do to sharing */
00058     FatErrorNoDisk                  = FS_ERR_DEVICE /* No Valid Disk Present */
00059 };
00060
00061 /* File open modes */
00062 enum FatOpenMode {
00063     FatReadOnlyMode     = FS_IREAD,
00064     FatReadAndWriteMode = FS_IREAD | FS_IWRITE
00065 };
00066
00067 /* File access flags */
00068 #define FatAccessFlagRdOnly         FS_RDONLY
00069 #define FatAccessFlagWrOnly         FS_WRONLY
00070 #define FatAccessFlagRdWr           FS_RDWR
00071 #define FatAccessFlagAppend         FS_APPEND
00072 #define FatAccessFlagCreate         FS_CREAT
00073 #define FatAccessFlagTrunc          FS_TRUNC
00074 #define FatAccessFlagExcl           FS_EXCL
00075 #define FatAccessFlagText           FS_TEXT
00076 #define FatAccessFlagBinary         FS_BINARY
00077 #define FatAccessFlagNoShareAny     FS_NOSHAREANY
00078 #define FatAccessFlagNoShareWrite   FS_NOSHAREWRITE
00079
00080 /* Arguments to seek */
00081 #define FatSeekBegin                FS_SEEK_SET
00082 #define FatSeekCurrent              FS_SEEK_CUR
00083 #define FatSeekEnd                  FS_SEEK_END
00084
00085 typedef DATESTR FatTimeRecord;
00086
00087 /* File info type */
00088 struct FatFileInfo {
00089     UINT32          st_mode;        /* (see S_xxxx below) */
00090     UINT32          st_size;        /* file size, in bytes */
00091     INT32           st_blksize;     /* optimal block size for I/O (cluster size) */
00092     INT32           st_blocks;      /* blocks allocated for file */
00093     FatTimeRecord   st_atime;       /* last access (all times are the same) */
00094     FatTimeRecord   st_mtime;       /* last modification */
00095     FatTimeRecord   st_ctime;       /* last file status change */
00096     INT16           st_dev;         /* (drive number, rtfs) */
00097     INT16           st_ino;         /* inode number (0) */
00098     INT16           st_nlink;       /* (always 1) */
00099     INT16           st_rdev;        /* (drive number, rtfs) */
00100     UINT16          fattribute;     /* File attributes - DOS attributes (non standard but useful) */
00101     UINT16          padding;
00102 };
00103
00104 /* Definition of the supported device types */
00105 typedef enum {
00106     // Zero is a reserved value
00107     FsMmcSdDev = FS_MMCSD_DEV,
00108     FsNandDev = FS_FTL_DEVICE1,
00109     FsFatFfsDev = FS_FFS_DEVICE
00110     // Insert new device types here
00111 } FsDeviceType;
00112
00113 // =============================================================================
00114 //  FS Registration Info
00115 // =============================================================================
00116
00118 typedef struct {
00119     FsDeviceType    device;
00120     CHAR            drive_letter;
00121     BOOLEAN         removable;
00122     BOOLEAN         indication;
00123     BOOLEAN         media_present;
00124     void            (*notification_func)(FsDeviceType device, BOOLEAN media_present, void *client_arg);
00125     void            *client_arg;
00126 } FsRegistrationInfo;
00127
00128 /* Structure for user to do recursive search for files in a selected drive */
00129 struct FatFindData {
00130     CHAR    fname[10];      /* Null terminated file and extension */
00131     CHAR    fext[4];
00132     UINT16  fattribute;     /* File attributes */
00133     UINT16  ftime;          /* Time & Date last modified. See date */
00134     UINT16  fdate;          /* and time handlers for getting info */
00135     UINT32  fsize;          /* File size */
00136     INT16   driveno;
00137     CHAR    longFileName[FS_MAXPATH];
00138     CHAR    pname[10];      /* Pattern. */
00139     CHAR    pext[4];
00140     CHAR    path[FS_MAXPATH];
00141     CHAR    plongFileName[FS_MAXPATH];
00142     void    *pobj;
00143     void    *pmom;
00144 };
00145
00146 enum FatFileAttribute {
00147     FatFileAttrRdOnly       = ARDONLY,
00148     FatFileAttrHidden       = AHIDDEN,
00149     FatFileAttrSystem       = ASYSTEM,
00150     FatFileAttrVolume       = AVOLUME,
00151     FatFileAttrDirectory    = ADIRENT,
00152     FatFileAttrArchive      = ARCHIVE,
00153     FatFileAttrNormal       = ANORMAL,
00154     FatFileAttrChicagoExt   = CHICAGO_EXT
00155 };
00156
00158 #endif  // Apoxi_FatTypes_hpp
00159
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/PreComp.cpp File Reference

AddOns/AfsFat/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:56:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/PreComp.hpp File Reference

AddOns/AfsFat/PreComp.hpp File Reference

#include <ApoxiVersion.hpp>
#include <AddOns/AfsFat/FatDirectoryIteratorImp.hpp>
#include <AddOns/AfsFat/FatFile.hpp>
#include <AddOns/AfsFat/FatFileImp.hpp>
#include <AddOns/AfsFat/FatHandler.hpp>
#include <AddOns/AfsFat/FatStorageDeviceImp.hpp>
#include <AddOns/AfsFat/FatTypes.hpp>
#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include <Afs/Rfs/StorageDevice.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Macros.hpp>
#include <Auxiliary/String.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/VersionInfo.hpp>
#include <string.h>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:16:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFat/PreComp.hpp Source File

AddOns/AfsFat/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(APOXI_LIB_ADDON_AFSFAT)
00010     #error The FAT file system (FAT) add-on is not activated properly - please enable feature AFSFAT!
00011 #elif defined(APOXI_RTOS_WIN32)
00012     // Host simulator for FAT.
00013     #include <AddOns/AfsFat/FatSim.hpp>
00014 #else
00015     #include <stack/driver.h>
00016 #endif
00017
00018 #include <ApoxiVersion.hpp>
00019
00020 #include <AddOns/AfsFat/FatDirectoryIteratorImp.hpp>
00021 #include <AddOns/AfsFat/FatFile.hpp>
00022 #include <AddOns/AfsFat/FatFileImp.hpp>
00023 #include <AddOns/AfsFat/FatHandler.hpp>
00024 #include <AddOns/AfsFat/FatStorageDeviceImp.hpp>
00025 #include <AddOns/AfsFat/FatTypes.hpp>
00026
00027 #include <Afs/Rfs/DirectoryIterator.hpp>
00028 #include <Afs/Rfs/File.hpp>
00029 #include <Afs/Rfs/FileFilter.hpp>
00030 #include <Afs/Rfs/StorageDevice.hpp>
00031
00032 #include <Auxiliary/Date.hpp>
00033 #include <Auxiliary/Macros.hpp>
00034 #include <Auxiliary/String.hpp>
00035
00036 #include <Kernel/Types.hpp>
00037 #include <Kernel/VersionInfo.hpp>
00038
00039 #include <string.h>
00040
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/ApoxiAfsFfsVersion.cpp File Reference

AddOns/AfsFfs/ApoxiAfsFfsVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiAfsFfsVersion.cpp:

Functions

ApoxiDefVersionInfo (AfsFfs, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | AfsFfs | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:23:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashDirectoryIteratorImp.cpp File Reference

AddOns/AfsFfs/FlashDirectoryIteratorImp.cpp File Reference

#include "PreComp.hpp"
#include "FlashDirectoryIteratorImp.hpp"
#include "FlashStorageDeviceImp.hpp"
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include <Auxiliary/WildcardStrncmp.hpp>

Include dependency graph for FlashDirectoryIteratorImp.cpp:

Generated on Tue Jan 24 16:23:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp File Reference

AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp File Reference

#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Ffs/FfsTypes.hpp>

Include dependency graph for FlashDirectoryIteratorImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FlashDirectoryIteratorImp
Directory iterator implementation for flash storage device. More...

Defines

#define | Apoxi_FlashDirectoryIteratorImp_hpp

Define Documentation

#define Apoxi_FlashDirectoryIteratorImp_hpp

Generated on Tue Jan 24 14:53:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp Source File

AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FlashDirectoryIteratorImp_hpp)
00011 #define Apoxi_FlashDirectoryIteratorImp_hpp
00014
00015 #include <Afs/Rfs/DirectoryIterator.hpp>
00016 #include <Afs/Ffs/FfsTypes.hpp>
00017
00022 class FlashDirectoryIteratorImp : public DirectoryIterator
00023 {
00024     protected:
00027         explicit FlashDirectoryIteratorImp(const Pathname &dir_pathname,
00028             const FileFilterPtr &filter, BOOLEAN find_dirs);
00029
00031         virtual ~FlashDirectoryIteratorImp();
00032
00033         virtual DirectoryIterator& AtomicIncrement();
00034
00035         friend class FlashStorageDeviceImp;
00036
00037     private:
00041         BOOLEAN FindNext(FfsFileId last_Id);
00042
00045         FfsRefType m_ref_file;
00046         FfsFileId m_file_Id;
00047
00048         BOOLEAN m_find_dirs;
00049         String m_working_dir;
00050 };
00051
00053 #endif  // Apoxi_FlashDirectoryIteratorImp_hpp
00054
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashFileImp.cpp File Reference

AddOns/AfsFfs/FlashFileImp.cpp File Reference

#include "PreComp.hpp"
#include "FlashFileImp.hpp"
#include "FlashStorageDeviceImp.hpp"
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Ffs/FfsMimeTypeMap.hpp>
#include <Auxiliary/Date.hpp>

Include dependency graph for FlashFileImp.cpp:

Generated on Tue Jan 24 16:23:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashFileImp.hpp File Reference

AddOns/AfsFfs/FlashFileImp.hpp File Reference

#include <Afs/Rfs/File.hpp>
#include <Afs/Ffs/FlsFile.hpp>

Include dependency graph for FlashFileImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FlashFileImp
File implementation for flash file system (FFS) storage device More...

Defines

#define | Apoxi_FlashFileImp_hpp

Define Documentation

#define Apoxi_FlashFileImp_hpp

Generated on Tue Jan 24 14:53:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashFileImp.hpp Source File

AddOns/AfsFfs/FlashFileImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FlashFileImp_hpp)
00011 #define Apoxi_FlashFileImp_hpp
00014
00015 #include <Afs/Rfs/File.hpp>
00016 #include <Afs/Ffs/FlsFile.hpp>
00017
00027 class FlashFileImp : public File
00028 {
00029     typedef File Base;
00030
00031     friend class FlashStorageDeviceImp;
00032
00033     public:
00037         static const UINT PROP_NATIVEHANDLE;
00041         static const UINT PROP_USERID;
00045         static const UINT PROP_DRM_ATTRIB;
00046
00047     public:
00048         virtual BOOLEAN Open(OpenMode open_mode);
00049         virtual BOOLEAN OpenStreaming(OpenMode open_mode);
00050         virtual BOOLEAN IsOpen() const { return m_fls_file.IsOpen(); }
00051         virtual BOOLEAN Close();
00052         virtual BOOLEAN Create(UINT32 size);
00053         virtual BOOLEAN CreateStreaming();
00054         virtual BOOLEAN CreateDir();
00055         virtual BOOLEAN Resize(UINT32 new_size, UINT32 copy_buf_size);
00056         virtual BOOLEAN Delete();
00057         virtual BOOLEAN Rename(const WString &new_name);
00058         virtual BOOLEAN SetReadOnly(BOOLEAN read_only);
00059         virtual BOOLEAN IsReadOnly() const;
00060         virtual BOOLEAN SetHidden(BOOLEAN hidden);
00061         virtual BOOLEAN IsHidden() const;
00062         virtual BOOLEAN SetArchive(BOOLEAN archive);
00063         virtual BOOLEAN IsArchive() const;
00064         virtual BOOLEAN GetSize(UINT32 &size) const;
00065         virtual BOOLEAN GetAttributes(Attributes &attributes) const;
00066         virtual BOOLEAN GetCreationDate(Date &date) const;
00067         virtual BOOLEAN GetModificationDate(Date &date) const;
00068         virtual const WString& GetStorageDeviceId() const;
00069         virtual BOOLEAN SetNativeProperty(UINT prop_Id, const void *val);
00070         virtual BOOLEAN GetNativeProperty(UINT prop_Id, void *val) const;
00071
00072     protected:
00073         FlashFileImp(const Pathname &pathname);
00074         virtual ~FlashFileImp();
00075
00076         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset, UINT32 count);
00077         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset,
00078             UINT32 max_count, UINT32 &bytes_read);
00079         virtual BOOLEAN DoReadStreaming(void HUGE *buffer, UINT32 count,
00080             UINT32 &bytes_read);
00081         virtual BOOLEAN DoReadStreamingAsync(void HUGE *buffer, UINT32 count,
00082             StreamingCallback);
00083         virtual BOOLEAN DoWrite(const void HUGE *buffer, UINT32 offset,
00084             UINT32 count);
00085         virtual BOOLEAN DoWriteStreaming(const void HUGE *buffer, UINT32 count);
00086         virtual BOOLEAN DoWriteStreamingAsync(const void HUGE *buffer, UINT32 count,
00087             StreamingCallback);
00088
00089         virtual FileState& MyState();
00090         virtual const FileState& MyState() const;
00091
00092     private:
00094         FileState m_state;
00096         FlsFile m_fls_file;
00097 };
00098
00100 #endif  // Apoxi_FlashFileImp_hpp
00101
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashStorageDeviceImp.cpp File Reference

AddOns/AfsFfs/FlashStorageDeviceImp.cpp File Reference

#include "PreComp.hpp"
#include "FlashStorageDeviceImp.hpp"
#include "FlashFileImp.hpp"
#include "FlashDirectoryIteratorImp.hpp"
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Rfs/FileFilter.hpp>

Include dependency graph for FlashStorageDeviceImp.cpp:

Defines

#define RFS_FFS_CHUNK_SIZE 1

Define Documentation

#define RFS_FFS_CHUNK_SIZE 1

Generated on Tue Jan 24 16:23:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashStorageDeviceImp.hpp File Reference

AddOns/AfsFfs/FlashStorageDeviceImp.hpp File Reference

#include <Afs/Rfs/StorageDevice.hpp>
#include <Afs/Ffs/FfsTypes.hpp>

Include dependency graph for FlashStorageDeviceImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FlashStorageDeviceImp
Storage device implementation for flash storage device. More...

Defines

#define | Apoxi_FlashStorageDeviceImp_hpp

Define Documentation

#define Apoxi_FlashStorageDeviceImp_hpp

Generated on Tue Jan 24 14:53:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/FlashStorageDeviceImp.hpp Source File

AddOns/AfsFfs/FlashStorageDeviceImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FlashStorageDeviceImp_hpp)
00011 #define Apoxi_FlashStorageDeviceImp_hpp
00015
00016 #include <Afs/Rfs/StorageDevice.hpp>
00017 #include <Afs/Ffs/FfsTypes.hpp>
00018
00023 class FlashStorageDeviceImp : public StorageDevice
00024 {
00025     typedef StorageDevice Base;
00026
00027     friend class RootFileSystem;
00028     friend class FlashFileImp;
00029     friend class FlashDirectoryIteratorImp;
00030     friend class FlsFile;
00031
00032     public:
00033         virtual UINT32 GetFreeVolumeSize() const;
00034         virtual UINT32 GetTotalVolumeSize() const;
00035         virtual UINT32 GetUsedVolumeSize() const;
00036         virtual BOOLEAN IsReady() const;
00037         virtual BOOLEAN IsDirectory(const Pathname &pathname) const;
00038         virtual BOOLEAN Exists(const Pathname &pathname) const;
00039         virtual BOOLEAN Format(BOOLEAN quick = FALSE);
00040         virtual WString GetNativeFilePathname(const Pathname &pathname) const;
00041         virtual WString GetNativeDirectoryPathname(const Pathname &pathname)
00042             const;
00043         virtual UINT8 GetDefaultChunkSize() const;
00044
00046         static const WString& GetId();
00047
00048     protected:
00050         FlashStorageDeviceImp();
00051
00054         virtual ~FlashStorageDeviceImp();
00055
00056         virtual FilePtr CreateFileObject(const Pathname &pathname) const;
00057         virtual DirectoryIteratorPtr CreateDirectoryIterator(
00058             const Pathname &dir_pathname, const FileFilterPtr &filter) const;
00059
00064         static BOOLEAN Setup();
00065
00067         static File::Error ConvertFfsErrorToFileError(FfsError ffs_error);
00068 };
00069
00071 #endif  // Apoxi_FlashStorageDeviceImp_hpp
00072
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/PreComp.cpp File Reference

AddOns/AfsFfs/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/PreComp.hpp File Reference

AddOns/AfsFfs/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:16:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsFfs/PreComp.hpp Source File

AddOns/AfsFfs/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/AfsRamTemplates.cpp File Reference

AddOns/AfsRam/AfsRamTemplates.cpp File Reference

#include "PreComp.hpp"
#include "RamStorageMapper.hpp"
#include "RamHandler.hpp"
#include "RamFileObj.hpp"

Include dependency graph for AfsRamTemplates.cpp:

Generated on Tue Jan 24 16:23:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/ApoxiAfsRamVersion.cpp File Reference

AddOns/AfsRam/ApoxiAfsRamVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiAfsRamVersion.cpp:

Functions

ApoxiDefVersionInfo (AfsRam, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | AfsRam | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:23:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/PreComp.cpp File Reference

AddOns/AfsRam/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/PreComp.hpp File Reference

AddOns/AfsRam/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:16:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/PreComp.hpp Source File

AddOns/AfsRam/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDataSink.cpp File Reference

AddOns/AfsRam/RamDataSink.cpp File Reference

#include "PreComp.hpp"
#include "RamDataSink.hpp"
#include <Afs/Rfs/File.hpp>

Include dependency graph for RamDataSink.cpp:

Generated on Tue Jan 24 16:23:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDataSink.hpp File Reference

AddOns/AfsRam/RamDataSink.hpp File Reference

#include <Afs/Rfs/FileDataSink.hpp>
#include <Afs/Rfs/File.hpp>

Include dependency graph for RamDataSink.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RamDataSink

Defines

#define | Apoxi_RamDataSink_hpp

Typedefs

typedef NiSharedPtr< RamDataSink > | RamDataSinkPtr
Smart-pointer controlling a RamDataSink object.

Define Documentation

#define Apoxi_RamDataSink_hpp

Generated on Tue Jan 24 16:23:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDataSink.hpp Source File

AddOns/AfsRam/RamDataSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RamDataSink_hpp)
00011 #define Apoxi_RamDataSink_hpp
00014
00015 #include <Afs/Rfs/FileDataSink.hpp>
00016 #include <Afs/Rfs/File.hpp>
00017
00018 class RamDataSink;
00019
00021 typedef NiSharedPtr<RamDataSink> RamDataSinkPtr;
00022
00028 class RamDataSink : public FileDataSink
00029 {
00030     typedef FileDataSink Base;
00031
00032     friend class RamDataSource;
00033
00034     public:
00043         RamDataSink(UINT32 initial_size = 0,
00044             DrmLocalId id = c_drm_invalid_local_id);
00045
00048         virtual ~RamDataSink();
00049
00066         BOOLEAN Save(const Path &file_path,
00067             UINT32 copy_buf_size = File::c_copy_buf_size) const;
00068
00069     protected:
00070         // Counts actually used instances.
00071         static UINT s_instance_cnt;
00072 };
00073
00075 #endif  // Apoxi_RamDataSink_hpp
00076
00077
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDataSource.cpp File Reference

AddOns/AfsRam/RamDataSource.cpp File Reference

#include "PreComp.hpp"
#include "RamDataSource.hpp"
#include "RamDataSink.hpp"
#include <Afs/Rfs/File.hpp>

Include dependency graph for RamDataSource.cpp:

Generated on Tue Jan 24 16:23:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDataSource.hpp File Reference

AddOns/AfsRam/RamDataSource.hpp File Reference

#include <Afs/Rfs/FileDataSource.hpp>

Include dependency graph for RamDataSource.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RamDataSource

Defines

#define | Apoxi_RamDataSource_hpp

Typedefs

typedef NiSharedPtr< RamDataSink > | RamDataSinkPtr
Smart-pointer controlling a RamDataSink object.
typedef NiSharedPtr< RamDataSource > | RamDataSourcePtr
Smart-pointer controlling a RamDataSource object.

Define Documentation

#define Apoxi_RamDataSource_hpp

Generated on Tue Jan 24 16:23:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDataSource.hpp Source File

AddOns/AfsRam/RamDataSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RamDataSource_hpp)
00011 #define Apoxi_RamDataSource_hpp
00014
00015 #include <Afs/Rfs/FileDataSource.hpp>
00016
00017 class RamDataSink;
00018 class RamDataSource;
00019
00021 typedef NiSharedPtr<RamDataSink> RamDataSinkPtr;
00023 typedef NiSharedPtr<RamDataSource> RamDataSourcePtr;
00024
00027 class RamDataSource : public FileDataSource
00028 {
00029     typedef FileDataSource Base;
00030
00031     public:
00040         RamDataSource(const RamDataSinkPtr &sink);
00041
00043         virtual ~RamDataSource();
00044
00045     protected:
00046         RamDataSinkPtr m_sink;
00047 };
00048
00050 #endif  // Apoxi_RamDataSource_hpp
00051
00052
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDirectoryIteratorImp.cpp File Reference

AddOns/AfsRam/RamDirectoryIteratorImp.cpp File Reference

#include "PreComp.hpp"
#include "RamDirectoryIteratorImp.hpp"
#include "RamHandler.hpp"
#include "RamStorageDeviceImp.hpp"
#include <Afs/Rfs/FileFilter.hpp>

Include dependency graph for RamDirectoryIteratorImp.cpp:

Generated on Tue Jan 24 16:23:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDirectoryIteratorImp.hpp File Reference

AddOns/AfsRam/RamDirectoryIteratorImp.hpp File Reference

#include <Afs/Rfs/DirectoryIterator.hpp>
#include <AddOns/AfsRam/RamFileNode.hpp>

Include dependency graph for RamDirectoryIteratorImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RamDirectoryIteratorImp

Defines

#define | Apoxi_RamDirectoryIteratorImp_hpp

Define Documentation

#define Apoxi_RamDirectoryIteratorImp_hpp

Generated on Tue Jan 24 16:23:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamDirectoryIteratorImp.hpp Source File

AddOns/AfsRam/RamDirectoryIteratorImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RamDirectoryIteratorImp_hpp)
00011 #define Apoxi_RamDirectoryIteratorImp_hpp
00014
00015 #include <Afs/Rfs/DirectoryIterator.hpp>
00016 #include <AddOns/AfsRam/RamFileNode.hpp>
00017
00020 class RamDirectoryIteratorImp : public DirectoryIterator
00021 {
00022     protected:
00025         explicit RamDirectoryIteratorImp(const Pathname &dir_pathname,
00026             const FileFilterPtr &filter);
00027
00029         virtual ~RamDirectoryIteratorImp();
00030
00031         virtual DirectoryIterator& AtomicIncrement();
00032
00033         friend class RamStorageDeviceImp;
00034
00035     private:
00040         inline BOOLEAN FindNext();
00041         BOOLEAN     IsCurrentDir(RamHandle dir_handle) const;
00042         //BOOLEAN       IsParentDir(RamHandle dir_handle);
00043
00044         void        GetFileNameFromFoundFile(RamHandle found_file);
00045         BOOLEAN     IsMatchTheFilter(FileFilterPtr filter) const;
00046
00047         RamHandle       m_found_file;
00048         BOOLEAN         m_has_next;
00049 };
00050
00052 #endif  // Apoxi_RamDirectoryIteratorImp_hpp
00053
00054
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFile.cpp File Reference

AddOns/AfsRam/RamFile.cpp File Reference

#include "PreComp.hpp"
#include "RamHandler.hpp"
#include "RamFile.hpp"

Include dependency graph for RamFile.cpp:

Generated on Tue Jan 24 16:23:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFile.hpp File Reference

AddOns/AfsRam/RamFile.hpp File Reference

#include <Auxiliary/String.hpp>
#include <AddOns/AfsRam/RamFileNode.hpp>

Include dependency graph for RamFile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RamFile

Typedefs

typedef NiSharedPtr< RamFile > | RamFilePtr

Generated on Tue Jan 24 16:23:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFile.hpp Source File

AddOns/AfsRam/RamFile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined Apoxi_RamFile_hpp
00011 #define Apoxi_RamFile_hpp
00014
00015 #include <Auxiliary/String.hpp>
00016 #include <AddOns/AfsRam/RamFileNode.hpp>
00017
00018 class RamFile;
00019 typedef NiSharedPtr<RamFile> RamFilePtr;
00020
00021 class RamFile
00022 {
00023     public:
00024         RamFile();
00025         ~RamFile();
00026
00030         inline BOOLEAN IsInitialized() const { return m_filehandle != 0; }
00031
00033         BOOLEAN AssureInitialized(const CHAR *filename);
00034
00035         BOOLEAN Open(const CHAR *filename, RamOpenMode mode);
00036         BOOLEAN Create(const CHAR *filename, UINT32 size);
00037         BOOLEAN Close();
00038         BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 bytes);
00039         BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 max_no_bytes,
00040             UINT32 &bytes_read);
00041         BOOLEAN Write(const void HUGE *buffer, UINT32 offset, UINT32 no_bytes);
00042         BOOLEAN Delete();
00043         BOOLEAN Rename(const CHAR *new_filename);
00044         BOOLEAN Resize(UINT32 new_size);
00045         BOOLEAN GetFileSize(UINT32 &file_size) const;
00046         BOOLEAN GetCreationTimestamp(Date &time_stamp) const;
00047         BOOLEAN GetLastUpdateTimestamp(Date &time_stamp) const;
00048         BOOLEAN GetLastAccessTimestamp(Date &time_stamp) const;
00049         RamError GetLastError() const;
00050         BOOLEAN IsOpen() const;
00051         BOOLEAN SetReadOnly(BOOLEAN read_only);
00052         BOOLEAN IsReadOnly() const;
00053         BOOLEAN SetHidden(BOOLEAN hidden);
00054         BOOLEAN IsHidden() const;
00055
00056     private:
00057         BOOLEAN Open(RamOpenMode mode);
00058         BOOLEAN GetFileInfo() const;
00059         BOOLEAN InternalWrite(const void HUGE *src, UINT32 offset, UINT32 nof);
00060         BOOLEAN InternalOpen(RamOpenMode mode);
00061         BOOLEAN Create(UINT32 size);
00062         BOOLEAN Append(const void HUGE *src, UINT32 nof);
00063
00064         mutable BOOLEAN m_is_info_upd;
00065         BOOLEAN m_is_open;
00066         BOOLEAN m_is_writable;
00067         RamOpenMode m_open_mode;
00068
00069         mutable RamError m_last_error;
00070         RamHandle m_filehandle;
00071         String m_filename;
00072         mutable RamFileInfo m_file_info;
00073
00074         // TODO implement file sharing
00075 };
00076
00078 #endif  // Apoxi_RamFile_hpp
00079
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileImp.cpp File Reference

AddOns/AfsRam/RamFileImp.cpp File Reference

#include "PreComp.hpp"
#include "RamFileImp.hpp"
#include "RamHandler.hpp"
#include "RamStorageDeviceImp.hpp"
#include <Auxiliary/Date.hpp>

Include dependency graph for RamFileImp.cpp:

Generated on Tue Jan 24 16:23:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileImp.hpp File Reference

AddOns/AfsRam/RamFileImp.hpp File Reference

#include <Afs/Rfs/File.hpp>
#include <AddOns/AfsRam/RamFile.hpp>

Include dependency graph for RamFileImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RamFileImp
File implementation for random access memory (RAM) storage device More...

Defines

#define | Apoxi_RamFileImp_hpp

Define Documentation

#define Apoxi_RamFileImp_hpp

Generated on Tue Jan 24 16:23:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileImp.hpp Source File

AddOns/AfsRam/RamFileImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RamFileImp_hpp)
00011 #define Apoxi_RamFileImp_hpp
00014
00015 #include <Afs/Rfs/File.hpp>
00016 #include <AddOns/AfsRam/RamFile.hpp>
00017
00024 class RamFileImp : public File
00025 {
00026     typedef File Base;
00027
00028     friend class RamStorageDeviceImp;
00029
00030     public:
00031         virtual BOOLEAN Open(OpenMode open_mode);
00032         virtual BOOLEAN OpenStreaming(OpenMode open_mode) {
00033             return FALSE;
00034         };
00035         virtual BOOLEAN IsOpen() const;
00036         virtual BOOLEAN Close();
00037         virtual BOOLEAN Create(UINT32 size);
00038         virtual BOOLEAN CreateStreaming() {
00039             return FALSE;
00040         };
00041         virtual BOOLEAN CreateDir();
00042         virtual BOOLEAN Resize(UINT32 new_size, UINT32 copy_buf_size);
00043         virtual BOOLEAN Delete();
00044         virtual BOOLEAN Rename(const WString &new_name);
00045         virtual BOOLEAN SetReadOnly(BOOLEAN read_only);
00046         virtual BOOLEAN IsReadOnly() const;
00047         virtual BOOLEAN SetHidden(BOOLEAN hidden);
00048         virtual BOOLEAN IsHidden() const;
00049         virtual BOOLEAN SetArchive(BOOLEAN archive);
00050         virtual BOOLEAN IsArchive() const;
00051         virtual BOOLEAN GetSize(UINT32 &size) const;
00052         virtual BOOLEAN GetAttributes(Attributes &attributes) const;
00053         virtual BOOLEAN GetCreationDate(Date &date) const;
00054         virtual BOOLEAN GetModificationDate(Date &date) const;
00055         virtual BOOLEAN GetAccessDate(Date &date) const;
00056         virtual const WString& GetStorageDeviceId() const;
00057
00058     protected:
00059         RamFileImp(const Pathname &pathname);
00060         virtual ~RamFileImp();
00061
00062         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset, UINT32 count);
00063         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset,
00064             UINT32 max_count, UINT32 &bytes_read);
00065         virtual BOOLEAN DoReadStreaming(void HUGE *buffer, UINT32 count,
00066             UINT32 &bytes_read){
00067                 return FALSE;
00068             };
00069         virtual BOOLEAN DoReadStreamingAsync(void HUGE *buffer, UINT32 count,
00070             StreamingCallback) {
00071                 return FALSE;
00072             };
00073
00074         virtual BOOLEAN DoWrite(const void HUGE *buffer, UINT32 offset,
00075             UINT32 count);
00076         virtual BOOLEAN DoWriteStreaming(const void HUGE *buffer, UINT32 count) {
00077                 return FALSE;
00078             };
00079         virtual BOOLEAN DoWriteStreamingAsync(const void HUGE *buffer,
00080             UINT32 count, StreamingCallback) {
00081                 return FALSE;
00082             };
00083
00084         virtual FileState& MyState();
00085         virtual const FileState& MyState() const;
00086
00087         static Error ConvertRamErrorToFileError(RamError ram_error);
00088         static RamOpenMode TranslateOpenMode(OpenMode open_mode);
00089
00090     private:
00092         FileState m_state;
00094         RamFile m_ram_file;
00095 };
00096
00098 #endif  // Apoxi_RamFileImp_hpp
00099
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileNode.cpp File Reference

AddOns/AfsRam/RamFileNode.cpp File Reference

#include "PreComp.hpp"
#include "RamFileNode.hpp"

Include dependency graph for RamFileNode.cpp:

Generated on Tue Jan 24 16:23:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileNode.hpp File Reference

AddOns/AfsRam/RamFileNode.hpp File Reference

#include <Auxiliary/String.hpp>
#include <AddOns/AfsRam/RamTypes.hpp>
#include <AddOns/AfsRam/RamFileObj.hpp>

Include dependency graph for RamFileNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RamFileNode

Typedefs

typedef RamFileNode * | RamHandle

Generated on Tue Jan 24 16:23:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileNode.hpp Source File

AddOns/AfsRam/RamFileNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined Apoxi_RamFileNode_hpp
00011 #define Apoxi_RamFileNode_hpp
00014
00015 #include <Auxiliary/String.hpp>
00016 #include <AddOns/AfsRam/RamTypes.hpp>
00017 #include <AddOns/AfsRam/RamFileObj.hpp>
00018
00019 class RamFileNode;
00020
00021 typedef RamFileNode *RamHandle;
00022 // TODO comment and document all header files -> DOXYGEN
00023 class RamFileNode
00024 {
00025     public:
00026         RamFileNode(
00027             RamFileObj *file_obj = 0,
00028             RamFileNode *parent = 0,
00029             RamFileNode *equal_directory_item = 0,
00030             RamFileNode *sub_directory_item = 0); // nodes and file object must be created externally
00031         ~RamFileNode();
00032
00033         BOOLEAN InsertEqualNode(RamFileNode *directory_item);
00034         BOOLEAN InsertSubNode(RamFileNode *file_item);
00035
00036         BOOLEAN DeleteSubNode(const Pathname &pathname);
00037         BOOLEAN DeleteEqualNode(const Pathname &pathname);
00038         BOOLEAN DeleteAllSubNodes();
00039         BOOLEAN DeleteAllEqualNodes();
00040
00041         RamFileNode* GetParentNode() const;
00042         RamFileNode* GetEqualDirectoryNode() const;
00043         RamFileNode* GetSubDirectoryNode() const;
00044         RamFileObj* GetRamFileObj() const;
00045         void SetRamFileObj(RamFileObj *file_obj); // file_obj must not be null
00046
00047         WString GetSegmentName() const;
00048         BOOLEAN SetSegmentName(const WString &segment_name);
00049
00050         WString TrackPathToRoot();
00051
00052     private:
00053         void InitFileNode(
00054             WString segment_name,
00055             RamFileObj *file_obj = 0,
00056             RamFileNode *parent = 0,
00057             RamFileNode *equal_directory_item = 0,
00058             RamFileNode *sub_directory_item = 0);
00059
00060         void SetParentNode(RamFileNode *parent);
00061         void SetEqualDirectoryNode(RamFileNode *equal_item);
00062         void SetSubDirectoryNode(RamFileNode *sub_item);
00063
00064         BOOLEAN IsRootNode() const;
00065
00066         BOOLEAN DeleteFileObj();
00067
00068         WString m_segment_name;
00069         RamFileNode *m_parent;
00070         RamFileNode *m_equal_directory_item;
00071         RamFileNode *m_sub_directory_item;
00072         RamFileObj *m_file_obj;
00073
00074         friend class RamFileSystem;
00075 };
00076
00078 #endif  // Apoxi_RamFileNode_hpp
00079
00080
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileObj.cpp File Reference

AddOns/AfsRam/RamFileObj.cpp File Reference

#include "PreComp.hpp"
#include "RamFileObj.hpp"
#include "RamStorageMapper.hpp"

Include dependency graph for RamFileObj.cpp:

Generated on Tue Jan 24 16:23:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileObj.hpp File Reference

AddOns/AfsRam/RamFileObj.hpp File Reference

#include <AddOns/AfsRam/RamTypes.hpp>
#include <Auxiliary/Vector.hpp>
#include <Afs/Rfs/Path.hpp>

Include dependency graph for RamFileObj.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class RamFileObj

Generated on Tue Jan 24 16:23:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileObj.hpp Source File

AddOns/AfsRam/RamFileObj.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined Apoxi_RamFileObj_hpp
00011 #define Apoxi_RamFileObj_hpp
00014
00015 #include <AddOns/AfsRam/RamTypes.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017 #include <Afs/Rfs/Path.hpp>
00018
00019 class Pathname;
00020
00021 class RamFileObj
00022 {
00023 public:
00024     RamFileObj(const WString &pathname,
00025                UINT16 attributes = RamFileAttrNormal,
00026                UINT32 size = 0);
00027     RamFileObj(const Pathname &pathname,
00028                UINT16 attributes = RamFileAttrNormal,
00029                UINT32 size = 0);
00030     RamFileObj(const RamFileObj &another_file_obj);
00031     ~RamFileObj();
00032
00033     BOOLEAN Reset(UINT32 size);
00034     BOOLEAN DeleteDataBlocks();
00035     BOOLEAN Resize(UINT32 new_size);
00036
00037     BOOLEAN SetAttributes(UINT16 attributes);
00038     UINT16 GetAttributes() const;
00039     BOOLEAN SetReadOnly(BOOLEAN is_read_only);
00040     BOOLEAN IsReadOnly() const;
00041     BOOLEAN SetHidden(BOOLEAN is_hidden);
00042     BOOLEAN IsHidden() const;
00043     BOOLEAN SetSystem(BOOLEAN is_system);
00044     BOOLEAN IsSystem() const;
00045     BOOLEAN SetVolume(BOOLEAN is_volume);
00046     BOOLEAN IsVolume() const;
00047     BOOLEAN SetDirectory(BOOLEAN is_directory);
00048     BOOLEAN IsDirectory() const;
00049     BOOLEAN SetArchive(BOOLEAN is_archive);
00050     BOOLEAN IsArchive() const;
00051
00052     void SetPathname(const Pathname &pathname);
00053     const Pathname& GetPathname() const;
00054     UINT32 GetSize() const;
00055     UINT32 GetAllocatedSize() const;
00056
00057     const WString GetName() const; // e.g. "abc.txt"
00058     const WString GetNativeFilePathname() const; // e.g. "/mydir/abc.txt"
00059     const WString GetNativeDirectoryPathname() const; // e.g. "/mydir"
00060
00061     // TODO implement file info method
00062     //RamFileInfo* GetFileInfo() const;
00063     BOOLEAN GetCreationDate(Date &date) const; // gives date of creation
00064     BOOLEAN GetModificationDate(Date &date) const; // gives date of last modification
00065     BOOLEAN GetAccessDate(Date &date) const; // gives date of last access
00066
00067     BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 count, UINT32 &bytes_read);
00068     BOOLEAN Write(UINT32 offset, const void HUGE *buffer, UINT32 count);
00069     BOOLEAN Append(const void HUGE *buffer, UINT32 count);
00070
00071     RamError GetLastError() const;
00072     UINT32 GetBlockCount() const;
00073
00074 private:
00075     Vector<RamBlockData> m_blocks; /* List of all data blocks in RAM for this file. */
00076
00077     UINT16 m_file_attributes; /* Attributes of the file, e.g. read only, directory, ... */
00078
00079     Date m_creation_date; /* Date of creation */
00080     Date m_modification_date; /* Date of last modification */
00081     Date m_access_date; /* Date of last access */
00082
00083     Path m_path; /* Path of the file */
00084
00085     mutable RamError m_last_error;
00086
00087     void InitFileObj(const Pathname &pathname,
00088                UINT16 attributes = RamFileAttrNormal,
00089                UINT32 size = 0); /* initializes components in constructor */
00090     UINT32 AllocateStorage(UINT32 size); /* allocates blocks in the storage */
00091
00092     BOOLEAN CopyDataBlocks(Vector<RamBlockData> &dest_vector, const Vector<RamBlockData> &src_vector) const;
00093     BOOLEAN DeleteDataBlocks(Vector<RamBlockData> &vect);
00094
00095     BOOLEAN TruncateSize(UINT32 new_size);
00096     BOOLEAN ExtendSize(UINT32 new_size);
00097
00098     UINT32 InternalWrite(UINT32 byte_index, const void HUGE *buffer, UINT32 count); // Writes a number of bytes to a specific place in file.
00099     UINT32 InternalRead(UINT32 byte_index, void HUGE *buffer, UINT32 count); // Reads a number of bytes from a specific place in file.
00100 };
00101
00103 #endif  // Apoxi_RamFileObj_hpp
00104
00105
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileSystem.cpp File Reference

AddOns/AfsRam/RamFileSystem.cpp File Reference

#include "PreComp.hpp"
#include "RamFileSystem.hpp"

Include dependency graph for RamFileSystem.cpp:

Generated on Tue Jan 24 16:23:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileSystem.hpp File Reference

AddOns/AfsRam/RamFileSystem.hpp File Reference

#include <AddOns/AfsRam/RamFileNode.hpp>
#include <AddOns/AfsRam/RamStorageMapper.hpp>
#include <AddOns/AfsRam/RamTypes.hpp>

Include dependency graph for RamFileSystem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class RamFileSystem

Generated on Tue Jan 24 16:23:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamFileSystem.hpp Source File

AddOns/AfsRam/RamFileSystem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined Apoxi_RamFileSystem_hpp
00011 #define Apoxi_RamFileSystem_hpp
00014
00015 #include <AddOns/AfsRam/RamFileNode.hpp>
00016 #include <AddOns/AfsRam/RamStorageMapper.hpp>
00017 #include <AddOns/AfsRam/RamTypes.hpp>
00018
00019 class RamFileSystem
00020 {
00021     public:
00026         static RamFileSystem* GetInstance() { return &m_instance; }
00027
00030         ~RamFileSystem();
00031
00036         RamHandle GetRootNode();
00037
00044         RamHandle FindNode(const Pathname &pathname, UINT16 attributes);
00045
00051         RamHandle InsertNode(RamFileObj *file_obj);
00052
00059         BOOLEAN DeleteNode(const Pathname &pathname, UINT16 attributes);
00060
00066         BOOLEAN AssignDriveLetter(UINT8 drive_letter);
00067
00072         UINT8 GetDriveLetter() const;
00073
00079         BOOLEAN FormatFileSystem(UINT16 block_size = c_ram_storage_default_block_size);
00080
00085         UINT32 GetSpaceSize() const;
00086
00091         UINT32 GetFreeSpaceSize() const;
00092
00097         UINT32 GetUsedSpaceSize() const;
00098
00103         RamError GetLastError() const;
00104
00112         WString GetTree(RamHandle node, UINT level = 0) const;
00113
00114     private:
00117         RamFileSystem();
00118
00121         void InitFileSystem();
00122
00125         static void Deinitialize();
00126
00135         RamHandle FindNodeHelper(RamHandle parent, const Pathname &pathname, UINT16 attributes, UINT8 level);
00136
00143         RamHandle InsertNodeHelper(RamHandle parent, RamFileObj *file_obj);
00144
00145         // represents the instance of the class
00146         static RamFileSystem m_instance;
00147         // represents the root directory of the file system
00148         RamFileNode m_root;
00149         // represents the storage mapper
00150         RamStorageMapper *m_storage_mapper;
00151         // represents the drive letter
00152         UINT8 m_drive_letter;
00153         // represents the last occurred error
00154         mutable RamError m_last_error;
00155 };
00156
00158 #endif  // Apoxi_RamFileSystem_hpp
00159
00160
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamHandler.cpp File Reference

AddOns/AfsRam/RamHandler.cpp File Reference

#include "PreComp.hpp"
#include "RamTypes.hpp"
#include "RamFileSystem.hpp"
#include "RamHandler.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for RamHandler.cpp:

Generated on Tue Jan 24 16:23:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamHandler.hpp File Reference

AddOns/AfsRam/RamHandler.hpp File Reference

#include <AddOns/AfsRam/RamTypes.hpp>
#include <AddOns/AfsRam/RamFileNode.hpp>
#include <AddOns/AfsRam/RamFileSystem.hpp>

Include dependency graph for RamHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class RamHandler

Generated on Tue Jan 24 16:23:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamHandler.hpp Source File

AddOns/AfsRam/RamHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined Apoxi_RamHandler_hpp
00011 #define Apoxi_RamHandler_hpp
00014
00015 #include <AddOns/AfsRam/RamTypes.hpp>
00016 #include <AddOns/AfsRam/RamFileNode.hpp>
00017 #include <AddOns/AfsRam/RamFileSystem.hpp>
00018
00019 class RamHandler
00020 {
00021     public:
00025         static void Initialize();
00026
00030         static void Deinitialize();
00031
00038         static RamHandle Create(const WString &file_name,
00039                                 UINT32 size);
00040
00046         static RamHandle Find(const WString &file_name);
00047
00058         static BOOLEAN Read(RamHandle hp,
00059                             INT32 offset,
00060                             void HUGE *buffer,
00061                             UINT32 count,
00062                             UINT32 &bytes_read);
00063
00073         static BOOLEAN Write(RamHandle hp,
00074                              INT32 offset,
00075                              const void HUGE *buffer,
00076                              UINT32 count);
00077
00085         static BOOLEAN Append(RamHandle hp,
00086                               const void HUGE *buffer,
00087                               UINT32 count);
00088
00096         static BOOLEAN Rename(const WString &old_file_name,
00097                               const WString &new_file_name);
00098
00106         static BOOLEAN Resize(RamHandle file_handle,
00107                               UINT32 new_size);
00108
00114         static BOOLEAN Delete(const WString &file_name);
00115
00121         static BOOLEAN MakeDir(const WString &dir_name);
00122
00127         static BOOLEAN RemoveDir(const WString &dir_name);
00128
00134         static BOOLEAN ChangeDir(const WString &dir_name);
00135
00141         static BOOLEAN GetCurrentDir(WString &current_dir);
00142
00148         static BOOLEAN IsCurrentDir(const RamHandle current_dir);
00149
00156         static BOOLEAN FileExists(const WString &file_name);
00157
00162         static UINT32 GetFreeSpaceSize();
00163
00168         static UINT32 GetTotalSpaceSize();
00169
00174         static UINT32 GetUsedSpaceSize();
00175
00182         static BOOLEAN GetFileInfo(const WString &file_name,
00183                                    RamFileInfo *info);
00184
00192         static BOOLEAN FindFirst(RamHandle *found_file,
00193                                  const WString &filespec);
00194
00201         static BOOLEAN FindNext(RamHandle *found_file);
00202
00205         static void FindDone();
00206
00213         static BOOLEAN IsDirectory(const WString &dir_name);
00214
00221         static BOOLEAN GetAttributes(const WString &filename,
00222                                      UINT16 &attr);
00223
00230         static BOOLEAN SetAttributes(const WString &filename,
00231                                      UINT16 attr);
00232
00237         static RamError GetLastError();
00238
00244         static BOOLEAN Flush(RamHandle hp);
00245
00252         static BOOLEAN Truncate(RamHandle hp,
00253                                 UINT32 new_size);
00254
00260         static BOOLEAN Format(UINT16 block_size = c_ram_storage_default_block_size);
00261
00262     private:
00263         // static object which represents the file system
00264         static RamFileSystem *m_file_system;
00265         // static object which represents the working directory
00266         static RamFileNode *m_working_directory;
00267
00268         // static object which saves the found entries used by FindFirst and FindNext
00269         static Vector<RamHandle> m_found_files;
00270         // static object which holds address of the iterator with the next found data
00271         static Vector<RamHandle>::Iterator m_next_found_file;
00272
00273         // static object which stores the last occurred error
00274         static RamError m_last_error;
00275
00281         static void FindData(const WString &filespec);
00282
00289         static BOOLEAN Match(const WString &str, const WString &pattern);
00290
00296         static Pathname GetAbsolutePathname(const WString &path_name);
00297 };
00298
00300 #endif  // Apoxi_RamHandler_hpp
00301
00302
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamStorageDeviceImp.cpp File Reference

AddOns/AfsRam/RamStorageDeviceImp.cpp File Reference

#include "PreComp.hpp"
#include "RamStorageDeviceImp.hpp"
#include "RamDirectoryIteratorImp.hpp"
#include "RamHandler.hpp"
#include "RamFileImp.hpp"

Include dependency graph for RamStorageDeviceImp.cpp:

Defines

#define RFS_RAM_CHUNK_SIZE 0

Define Documentation

#define RFS_RAM_CHUNK_SIZE 0

Generated on Tue Jan 24 16:23:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamStorageDeviceImp.hpp File Reference

AddOns/AfsRam/RamStorageDeviceImp.hpp File Reference

#include <Afs/Rfs/StorageDevice.hpp>

Include dependency graph for RamStorageDeviceImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RamStorageDeviceImp
Storage device implementation for RAM storage device. More...

Defines

#define | Apoxi_RamStorageDeviceImp_hpp

Define Documentation

#define Apoxi_RamStorageDeviceImp_hpp

Generated on Tue Jan 24 16:23:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamStorageDeviceImp.hpp Source File

AddOns/AfsRam/RamStorageDeviceImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RamStorageDeviceImp_hpp)
00011 #define Apoxi_RamStorageDeviceImp_hpp
00015
00016 #include <Afs/Rfs/StorageDevice.hpp>
00017
00022 class RamStorageDeviceImp : public StorageDevice
00023 {
00024     typedef StorageDevice Base;
00025
00026     friend class RootFileSystem;
00027
00028     public:
00029         virtual UINT32 GetFreeVolumeSize() const;
00030         virtual UINT32 GetTotalVolumeSize() const;
00031         virtual UINT32 GetUsedVolumeSize() const;
00032         virtual BOOLEAN IsReady() const;
00033         virtual BOOLEAN IsDirectory(const Pathname &pathname) const;
00034         virtual BOOLEAN Exists(const Pathname &pathname) const;
00035         virtual BOOLEAN Format(BOOLEAN quick = FALSE);
00036         virtual WString GetNativeFilePathname(const Pathname &pathname) const;
00037         virtual WString GetNativeDirectoryPathname(const Pathname &pathname)
00038             const;
00039         virtual UINT8 GetDefaultChunkSize() const;
00040
00042         static const WString& GetId();
00043
00044     protected:
00046         RamStorageDeviceImp();
00047
00050         virtual ~RamStorageDeviceImp();
00051
00052         virtual FilePtr CreateFileObject(const Pathname &pathname) const;
00053         virtual DirectoryIteratorPtr CreateDirectoryIterator(
00054             const Pathname &dir_pathname, const FileFilterPtr &filter) const;
00055
00060         static BOOLEAN Setup();
00061 };
00062
00064 #endif  // Apoxi_RamStorageDeviceImp_hpp
00065
00066
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamStorageMapper.cpp File Reference

AddOns/AfsRam/RamStorageMapper.cpp File Reference

#include "PreComp.hpp"
#include "RamStorageMapper.hpp"
#include <Kernel/HeapManager.hpp>

Include dependency graph for RamStorageMapper.cpp:

Generated on Tue Jan 24 16:23:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamStorageMapper.hpp File Reference

AddOns/AfsRam/RamStorageMapper.hpp File Reference

#include <AddOns/AfsRam/RamTypes.hpp>
#include <Auxiliary/DynamicBitVector.hpp>
#include <Auxiliary/SimpleMap.hpp>

Include dependency graph for RamStorageMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class RamStorageMapper

Generated on Tue Jan 24 16:23:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamStorageMapper.hpp Source File

AddOns/AfsRam/RamStorageMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined Apoxi_RamStorageMapper_hpp
00011 #define Apoxi_RamStorageMapper_hpp
00014
00015 #include <AddOns/AfsRam/RamTypes.hpp>
00016 #include <Auxiliary/DynamicBitVector.hpp>
00017 #include <Auxiliary/SimpleMap.hpp>
00018
00019 class RamStorageMapper
00020 {
00021     friend class RamFileObj;
00022
00023 public:
00026     ~RamStorageMapper();
00027
00032     static RamStorageMapper* GetInstance() { return &m_instance; }
00033
00038     UINT32 GetSize() const;
00039
00045     UINT32 GetUsedSize() const;
00046
00051     UINT32 GetFreeSize() const;
00052
00058     UINT16 GetBlockSize() const;
00059
00065     BOOLEAN GetFreeBlockIndex(UINT32 &block_index);
00066
00073     BOOLEAN ReadBlock(UINT32 block_index, void HUGE *block_buffer); // read one block
00074
00082     BOOLEAN ReadBlocks(UINT32 block_index, void HUGE *buffer, UINT32 count);
00083
00090     BOOLEAN WriteBlock(UINT32 block_index, const void HUGE *block_data);
00091
00099     BOOLEAN WriteBlocks(UINT32 block_index, const void HUGE *buffer, UINT32 count);
00100
00106     BOOLEAN DeleteBlock(UINT32 block_index);
00107
00114     BOOLEAN DeleteBlocks(UINT32 block_index, UINT32 count);
00115
00121     BOOLEAN FormatStorage(UINT16 block_size = c_ram_storage_default_block_size);
00122
00128     BOOLEAN IsBlockUsed(UINT32 block_index) const;
00129
00135     RamError GetLastError() const;
00136
00137 protected:
00140     void HUGE* GetBlock(UINT32 block_index) const;
00141
00142 private:
00147     RamStorageMapper(UINT16 block_size = c_ram_storage_default_block_size);
00148
00154     void InitStorage(UINT16 block_size);
00155
00160     BOOLEAN DeleteStorage();
00161
00164     static RamStorageMapper m_instance;
00165
00168     UINT16 m_block_size;
00169
00172     mutable RamError m_last_error;
00173
00176     SimpleMap<UINT, void HUGE*> m_blocks;
00177
00180     UINT32 m_free_block_index;
00181 };
00182
00184 #endif  // Apoxi_RamStorageMapper_hpp
00185
00186
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamTypes.hpp File Reference

AddOns/AfsRam/RamTypes.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/Date.hpp>

Include dependency graph for RamTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | RamBlockData
struct | RamFileInfo

Defines

#define | APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE 0x0400
#define | DBG_OUT_RANGE_AFSRAM_ALWAYS 35600
#define | DBG_OUT_RANGE_AFSRAM_ERROR 35602
#define | DBG_OUT_RANGE_AFSRAM_SUCCESS 35601
#define | DBG_OUT_RANGE_AFSRAM_UNITTEST 35603

Enumerations

enum RamError {
RamErrorSuccess = 0, RamErrorOperationNotPossible = 3, RamErrorNotExist = 2, RamErrorBadFileDescriptor = 9,
RamErrorFileAlreadyExist = 17, RamErrorAccessDenied = 13, RamErrorNegativeFilePointer = 22, RamErrorNoSpace = 28,
RamErrorShare = 30
}
enum RamFileAttribute {
RamFileAttrRdOnly = 0x01, RamFileAttrHidden = 0x02, RamFileAttrSystem = 0x04, RamFileAttrVolume = 0x08,
RamFileAttrDirectory = 0x10, RamFileAttrArchive = 0x20, RamFileAttrNormal = 0x40, RamFileAttrAll = 0xFF
}
enum | RamOpenMode { RamOpenModeRead = 0x0000200, RamOpenModeWrite = 0x0000400 }

Variables

const UINT16 | c_ram_storage_default_block_size = APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE

Generated on Tue Jan 24 16:23:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRam/RamTypes.hpp Source File

AddOns/AfsRam/RamTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined Apoxi_RamTypes_hpp
00011 #define Apoxi_RamTypes_hpp
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Auxiliary/Date.hpp>
00017
00018 #ifndef APOXI_RTOS_WIN32
00019     #include <stack/driver.h>
00020 #endif
00021
00022 // defines range for DBG_OUT
00023 #define DBG_OUT_RANGE_AFSRAM_ALWAYS     35600
00024 #define DBG_OUT_RANGE_AFSRAM_SUCCESS    35601
00025 #define DBG_OUT_RANGE_AFSRAM_ERROR      35602
00026 #define DBG_OUT_RANGE_AFSRAM_UNITTEST   35603
00027
00028 #if !defined APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE
00029     #define APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE 0x0400 // 1 KB
00030 #endif
00031
00032 // used by RamStorageMapper
00033 const UINT16 c_ram_storage_default_block_size = APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE;
00034
00035 enum RamError {
00036 // FS error codes:
00037     RamErrorSuccess                 = 0,
00038     RamErrorOperationNotPossible    = 3,
00039
00040 /* File system errno values */
00041     RamErrorNotExist                = 2,  /* File not found or path to file not found. */
00042     RamErrorBadFileDescriptor       = 9,  /* Invalid file descriptor. */
00043     RamErrorFileAlreadyExist        = 17, /* Exclusive access requested but file already exists. */
00044     RamErrorAccessDenied            = 13, /* Attempt to open a read only file or a special directory. */
00045     RamErrorNegativeFilePointer     = 22, /* Seek to negative file pointer attempted. */
00046     RamErrorNoSpace                 = 28, /* Write failed. Presumably because of no space. */
00047     RamErrorShare                   = 30  /* Open failed due to sharing. */
00048 };
00049
00050 /* Open file modes */
00051 enum RamOpenMode {
00052     RamOpenModeRead         = 0x0000200,
00053     RamOpenModeWrite        = 0x0000400
00054 };
00055
00056 /* File info type */
00057 struct RamFileInfo {
00058     UINT32          st_size;        /* file size, in bytes */
00059     INT32           st_blksize;     /* optimal block size for I/O (cluster size) */
00060     INT32           st_blocks;      /* blocks allocated for file */
00061     Date            st_atime;       /* last access (all times are the same) */
00062     Date            st_mtime;       /* last modification */
00063     Date            st_ctime;       /* last file status change */
00064     UINT16          fattribute;     /* file attributes - DOS attributes
00065                                        (non standard but useful) */
00066     UINT16          padding;
00067 };
00068
00069 enum RamFileAttribute {
00070     RamFileAttrRdOnly       = 0x01,
00071     RamFileAttrHidden       = 0x02,
00072     RamFileAttrSystem       = 0x04,
00073     RamFileAttrVolume       = 0x08,
00074     RamFileAttrDirectory    = 0x10,
00075     RamFileAttrArchive      = 0x20,
00076     RamFileAttrNormal       = 0x40,
00077     RamFileAttrAll          = 0xFF
00078 };
00079
00080 /*
00081     Defines a structure which represents a certain block index and the number of used bytes.
00082
00083     e.g. block_size = 16;
00084     [x|x|x|x|x|x|x|x|x|x|x|x|x|x|x|x]
00085     byte_count = 0
00086
00087     [a|x|x|x|x|x|x|x|x|x|x|x|x|x|x|x]
00088     byte_count = 1
00089
00090     [a|b|c|d|e|x|x|x|x|x|x|x|x|x|x|x]
00091     byte_count = 5
00092
00093     [a|b|c|d|e|f|g|h|i|j|k|l|m|n|o|p]
00094     byte_count = 16
00095 */
00096 struct RamBlockData {
00097     UINT32 block_index; // index of block in ram storage
00098     UINT32 used_bytes;  // number of bytes used in this block
00099 };
00100
00102 #endif  // Apoxi_RamTypes_hpp
00103
00104
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/AfsRfsTemplates.cpp File Reference

AddOns/AfsRfs/AfsRfsTemplates.cpp File Reference

#include "PreComp.hpp"
#include <Afs/Rfs/StorageDeviceIterator.hpp>

Include dependency graph for AfsRfsTemplates.cpp:

Generated on Tue Jan 24 16:23:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/ApoxiAfsRfsVersion.cpp File Reference

AddOns/AfsRfs/ApoxiAfsRfsVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiAfsRfsVersion.cpp:

Functions

ApoxiDefVersionInfo (AfsRfs, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | AfsRfs | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:23:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/PreComp.cpp File Reference

AddOns/AfsRfs/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/PreComp.hpp File Reference

AddOns/AfsRfs/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:16:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/PreComp.hpp Source File

AddOns/AfsRfs/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootDirectoryIteratorImp.cpp File Reference

AddOns/AfsRfs/RootDirectoryIteratorImp.cpp File Reference

#include "PreComp.hpp"
#include "RootDirectoryIteratorImp.hpp"
#include "RootStorageDeviceImp.hpp"
#include <Afs/Rfs/StorageDeviceIterator.hpp>

Include dependency graph for RootDirectoryIteratorImp.cpp:

Generated on Tue Jan 24 16:23:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootDirectoryIteratorImp.hpp File Reference

AddOns/AfsRfs/RootDirectoryIteratorImp.hpp File Reference

#include <Afs/Rfs/DirectoryIterator.hpp>

Include dependency graph for RootDirectoryIteratorImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RootDirectoryIteratorImp
Directory iterator implementation for root storage device. More...

Defines

#define | Apoxi_RootDirectoryIteratorImp_hpp

Define Documentation

#define Apoxi_RootDirectoryIteratorImp_hpp

Generated on Tue Jan 24 15:26:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootDirectoryIteratorImp.hpp Source File

AddOns/AfsRfs/RootDirectoryIteratorImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RootDirectoryIteratorImp_hpp)
00011 #define Apoxi_RootDirectoryIteratorImp_hpp
00014
00015 #include <Afs/Rfs/DirectoryIterator.hpp>
00016
00021 class RootDirectoryIteratorImp : public DirectoryIterator
00022 {
00023     public:
00026         explicit RootDirectoryIteratorImp(const Pathname &dir_pathname,
00027             const FileFilterPtr &filter,
00028             const StorageDeviceFilterPtr &dev_filter);
00029
00031         virtual File::Error GetLastError() const;
00032
00035         virtual void Increment();
00036
00037     protected:
00039         virtual ~RootDirectoryIteratorImp();
00040
00041         virtual DirectoryIterator& AtomicIncrement();
00042
00043     private:
00049         inline void ConstructCurrentPathname();
00050
00056         inline void ConstructCurrentDevicePathname();
00057
00059         inline void SkipRootStorageDevice();
00060
00061     protected:
00063         StorageDevicePtr m_cur_device;
00065         DirectoryIteratorPtr m_cur_dir_itor;
00067         Pathname m_cur_dev_pathname;
00068
00070         StorageDeviceIteratorPtr m_dev_itor;
00071 };
00072
00074 #endif  // Apoxi_RootDirectoryIteratorImp_hpp
00075
00076
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootFileImp.cpp File Reference

AddOns/AfsRfs/RootFileImp.cpp File Reference

#include "PreComp.hpp"
#include "RootFileImp.hpp"
#include "RootStorageDeviceImp.hpp"
#include <Afs/Rfs/StorageDevice.hpp>

Include dependency graph for RootFileImp.cpp:

Generated on Tue Jan 24 16:23:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootFileImp.hpp File Reference

AddOns/AfsRfs/RootFileImp.hpp File Reference

#include <Afs/Rfs/File.hpp>

Include dependency graph for RootFileImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RootFileImp
File implementation for virtual root storage device More...

Defines

#define | Apoxi_RootFileImp_hpp

Define Documentation

#define Apoxi_RootFileImp_hpp

Generated on Tue Jan 24 15:26:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootFileImp.hpp Source File

AddOns/AfsRfs/RootFileImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RootFileImp_hpp)
00011 #define Apoxi_RootFileImp_hpp
00014
00015 #include <Afs/Rfs/File.hpp>
00016
00023 class RootFileImp : public File
00024 {
00025     typedef File Base;
00026
00027     friend class RootStorageDeviceImp;
00028
00029     public:
00030         virtual BOOLEAN Open(OpenMode open_mode);
00031         virtual BOOLEAN OpenStreaming(OpenMode open_mode);
00032         virtual BOOLEAN IsOpen() const;
00033         virtual BOOLEAN Close();
00034         virtual BOOLEAN Create(UINT32 size);
00035         virtual BOOLEAN CreateStreaming();
00036         virtual BOOLEAN CreateDir();
00037         virtual BOOLEAN Resize(UINT32 new_size, UINT32 copy_buf_size);
00038         virtual BOOLEAN Delete();
00039         virtual BOOLEAN Copy(const Pathname &dest_pathname,
00040             const WString &dest_device_Id, UINT32 copy_buf_size);
00041         virtual BOOLEAN Split(UINT32 offset, const Pathname &new_file,
00042             UINT32 copy_buf_size);
00043         virtual BOOLEAN Rename(const WString &new_name);
00044         virtual BOOLEAN SetReadOnly(BOOLEAN read_only);
00045         virtual BOOLEAN IsReadOnly() const;
00046         virtual BOOLEAN SetHidden(BOOLEAN hidden);
00047         virtual BOOLEAN IsHidden() const;
00048         virtual BOOLEAN SetArchive(BOOLEAN archive);
00049         virtual BOOLEAN IsArchive() const;
00050         virtual BOOLEAN GetSize(UINT32 &size) const;
00051         virtual BOOLEAN GetAttributes(Attributes &attributes) const;
00052         virtual BOOLEAN GetCreationDate(Date &date) const;
00053         virtual BOOLEAN GetModificationDate(Date &date) const;
00054         virtual BOOLEAN GetAccessDate(Date &date) const;
00055         virtual const WString& GetStorageDeviceId() const;
00056         virtual BOOLEAN SetNativeProperty(UINT prop_Id, const void *val);
00057         virtual BOOLEAN GetNativeProperty(UINT prop_Id, void *val) const;
00058
00059     protected:
00060         RootFileImp(const Pathname &pathname);
00061         virtual ~RootFileImp();
00062
00063         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset, UINT32 count);
00064         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset,
00065             UINT32 max_count, UINT32 &bytes_read);
00066         virtual BOOLEAN DoReadStreaming(void HUGE *buffer, UINT32 count,
00067             UINT32 &bytes_read);
00068         virtual BOOLEAN DoReadStreamingAsync(void HUGE *buffer, UINT32 count,
00069             StreamingCallback);
00070
00071         virtual BOOLEAN DoWrite(const void HUGE *buffer, UINT32 offset,
00072             UINT32 count);
00073         virtual BOOLEAN DoWriteStreaming(const void HUGE *buffer, UINT32 count);
00074         virtual BOOLEAN DoWriteStreamingAsync(const void HUGE *buffer,
00075                                             UINT32 count, StreamingCallback);
00076
00077         virtual FileState& MyState();
00078         virtual const FileState& MyState() const;
00079
00081         inline BOOLEAN Delegate() const;
00082
00084         inline StorageDevicePtr GetDevice() const;
00085
00086     private:
00088         FilePtr m_file;
00089 };
00090
00092 #endif  // Apoxi_RootFileImp_hpp
00093
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootStorageDeviceImp.cpp File Reference

AddOns/AfsRfs/RootStorageDeviceImp.cpp File Reference

#include "PreComp.hpp"
#include "RootStorageDeviceImp.hpp"
#include "RootFileImp.hpp"
#include "RootDirectoryIteratorImp.hpp"
#include <Afs/Rfs/StorageDeviceIterator.hpp>
#include <Afs/Rfs/StorageDeviceFilter.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Rfs/FileFilter.hpp>

Include dependency graph for RootStorageDeviceImp.cpp:

Defines

#define RFS_RFS_CHUNK_SIZE 0

Define Documentation

#define RFS_RFS_CHUNK_SIZE 0

Generated on Tue Jan 24 16:23:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootStorageDeviceImp.hpp File Reference

AddOns/AfsRfs/RootStorageDeviceImp.hpp File Reference

#include <Afs/Rfs/StorageDevice.hpp>

Include dependency graph for RootStorageDeviceImp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RootStorageDeviceImp
Storage device implementation for virtual root storage device. More...

Defines

#define | Apoxi_RootStorageDeviceImp_hpp

Define Documentation

#define Apoxi_RootStorageDeviceImp_hpp

Generated on Tue Jan 24 15:26:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AfsRfs/RootStorageDeviceImp.hpp Source File

AddOns/AfsRfs/RootStorageDeviceImp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RootStorageDeviceImp_hpp)
00011 #define Apoxi_RootStorageDeviceImp_hpp
00015
00016 #include <Afs/Rfs/StorageDevice.hpp>
00017
00025 class RootStorageDeviceImp : public StorageDevice
00026 {
00027     typedef StorageDevice Base;
00028
00029     friend class RootFileSystem;
00030
00031     public:
00032         virtual UINT32 GetFreeVolumeSize() const;
00033         virtual UINT32 GetTotalVolumeSize() const;
00034         virtual UINT32 GetUsedVolumeSize() const;
00035
00038         virtual BOOLEAN IsReady() const;
00039
00040         virtual BOOLEAN IsDirectory(const Pathname &pathname) const;
00041         virtual BOOLEAN Exists(const Pathname &pathname) const;
00042
00044         virtual File::Error GetLastError() const
00045             { return File::OperationNotAllowedError; }
00046
00049         virtual BOOLEAN Format(BOOLEAN quick = FALSE);
00050
00051         virtual WString GetNativeFilePathname(const Pathname &pathname) const;
00052         virtual WString GetNativeDirectoryPathname(const Pathname &pathname)
00053             const;
00054         virtual UINT8 GetDefaultChunkSize() const;
00055         virtual BOOLEAN GetOpenFilesCounter(UINT &counter) const;
00056
00058         static const WString& GetId();
00059
00060     protected:
00062         RootStorageDeviceImp();
00063
00066         virtual ~RootStorageDeviceImp();
00067
00068         virtual FilePtr CreateFileObject(const Pathname &pathname) const;
00069         virtual DirectoryIteratorPtr CreateDirectoryIterator(
00070             const Pathname &dir_pathname, const FileFilterPtr &filter) const;
00071
00076         static BOOLEAN Setup();
00077 };
00078
00080 #endif  // Apoxi_RootStorageDeviceImp_hpp
00081
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/AppendProvider.cpp File Reference

AddOns/AuxExtensions/AppendProvider.cpp File Reference

#include <AddOns/AuxExtensions/AuxExtensionsPreComp.hpp>
#include <Config/Config.hpp>
#include "AppendProvider.hpp"

Include dependency graph for AppendProvider.cpp:

Generated on Tue Jan 24 16:23:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/AppendProvider.hpp File Reference

AddOns/AuxExtensions/AppendProvider.hpp File Reference

#include <Auxiliary/AbstractDelegationProvider.hpp>

Include dependency graph for AppendProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AppendProvider

Defines

#define | Apoxi_AuxExtensions_AppendProvider_hpp

Define Documentation

#define Apoxi_AuxExtensions_AppendProvider_hpp

Generated on Tue Jan 24 16:23:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/AppendProvider.hpp Source File

AddOns/AuxExtensions/AppendProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 **  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 **  ------------------------------------------------------------------------
00004 **  This document contains proprietary information belonging to COMNEON.
00005 **  Passing on and copying of this document, use and communication of its
00006 **  contents is not permitted without prior written authorisation.
00007 **  ------------------------------------------------------------------------
00008 */
00009
00010 #if ! defined(Apoxi_AuxExtensions_AppendProvider_hpp)
00011 #define Apoxi_AuxExtensions_AppendProvider_hpp
00015
00016 #include <Auxiliary/AbstractDelegationProvider.hpp>
00017
00018
00028 class AppendProvider : public AbstractDelegationProvider {
00029
00030     typedef AbstractDelegationProvider Base;
00031
00032     public:
00033
00035         AppendProvider();
00036
00038         virtual ~AppendProvider();
00039
00041         void Init();
00042
00044         virtual INT GetProviderId() const;
00045
00047         void SetProviderId(INT provider_id) {m_provider_id = provider_id;}
00048
00050         virtual INT RowCount();
00051
00053         virtual INT MaxRowCount();
00054
00059         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem &item);
00060
00062         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00063
00067         virtual BOOLEAN AppendRow();
00068
00070         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00071
00073         virtual BOOLEAN AddChildProvider(Provider* provider);
00074
00076         virtual BOOLEAN RemoveChildProvider(Provider* provider);
00077
00080         virtual BOOLEAN Update(ProviderListener * listener = 0);
00081
00083         virtual BOOLEAN Lock();
00084
00086         virtual BOOLEAN Unlock();
00087
00091         virtual INT GetSortedColumnId() const;
00092
00094         virtual INT GetProgress();
00095
00097         virtual BOOLEAN SetParameter(const DataItem &item);
00099         virtual void OnExecutingListener(Provider* provider = 0);
00100
00101     protected:
00102
00106         virtual BOOLEAN GetMappedRow(INT & mappedrow, INT row);
00107
00110         virtual void OnChildProviderModification(Provider* provider, const Provider::Modification& modification);
00111
00112
00113     private:
00116         Vector<Provider*>   m_provider_vec;
00117
00118         INT                 m_provider_id;
00119
00120 };
00121
00122 #endif //Apoxi_AuxExtensions_AppendProvider_hpp
00123
00124
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/AuxExtensionsPreComp.cpp File Reference

AddOns/AuxExtensions/AuxExtensionsPreComp.cpp File Reference

#include <AddOns/AuxExtensions/AuxExtensionsPreComp.hpp>

Include dependency graph for AuxExtensionsPreComp.cpp:

Generated on Tue Jan 24 16:23:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/AuxExtensionsPreComp.hpp File Reference

AddOns/AuxExtensions/AuxExtensionsPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for AuxExtensionsPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:24:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/AuxExtensionsPreComp.hpp Source File

AddOns/AuxExtensions/AuxExtensionsPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012
00013
Generated on Tue Jan 24 14:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/DualFilterProvider.cpp File Reference

AddOns/AuxExtensions/DualFilterProvider.cpp File Reference

#include <AddOns/AuxExtensions/AuxExtensionsPreComp.hpp>
#include "DualFilterProvider.hpp"

Include dependency graph for DualFilterProvider.cpp:

Generated on Tue Jan 24 16:24:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/DualFilterProvider.hpp File Reference

AddOns/AuxExtensions/DualFilterProvider.hpp File Reference

#include <Auxiliary/FilterProvider.hpp>

Include dependency graph for DualFilterProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DualFilterProvider

Defines

#define | _Apoxi_AuxExtensions_DualFilterProvider_hpp

Define Documentation

#define _Apoxi_AuxExtensions_DualFilterProvider_hpp

Generated on Tue Jan 24 16:24:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/DualFilterProvider.hpp Source File

AddOns/AuxExtensions/DualFilterProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Apoxi_AuxExtensions_DualFilterProvider_hpp)
00015 #define _Apoxi_AuxExtensions_DualFilterProvider_hpp
00019
00020 #include <Auxiliary/FilterProvider.hpp>
00021
00022 class DataItem;
00023 class FilterRule;
00024
00028 /* NOTE: No writing is possible on a DualFilterProvider. Use <em>GetChildRow</em> to get
00029 the row of the child provider and update the child provider directly.
00030 See also: <em>Provider, DataItem, FilterRule</em>.*/
00031 class DualFilterProvider : public FilterProvider
00032 {
00033     typedef FilterProvider Base;
00034     public:
00035
00036         enum FilterOperator {
00037             AndFilterOp,                // includes rows, where both rules matches
00038             OrFilterOp,                 // includes rows, where at least one rule match
00039             XorFilterOp,                // includes rows, where the first or the second, but not both rules matches
00040             FirstAndNotSecondFilterOp,  // includes rows, where the first but not the second rule match
00041             NotFirstAndSecondFilterOp,  // includes rows, where the not the first but the second rule match
00042             FirstOrNotSecondFilterOp,   // includes rows, where the first or not the second rule match
00043             NotFirstOrSecondFilterOp    // includes rows, where the not the first or the second rule match
00044         };
00045
00048         DualFilterProvider();
00049
00055         DualFilterProvider(Provider * provider, FilterRule * fst_rule, FilterRule* snd_rule,
00056                             INT fst_columnid = 0, INT snd_columnid = 0, FilterOperator op = AndFilterOp,
00057                             BOOLEAN negation = FALSE);
00059         virtual ~DualFilterProvider();
00060
00062         void Init(Provider * provider, FilterRule * fst_rule, FilterRule* snd_rule,
00063                     INT fst_columnid = 0, INT snd_columnid = 0, FilterOperator op = AndFilterOp,
00064                     BOOLEAN negation = FALSE);
00065
00067         void SetSecondFilterColumn(INT filtercolumn) { m_snd_column = filtercolumn; }
00068
00070         void SetSecondFilterRule(FilterRule * rule) { m_snd_rule = rule; }
00071
00073         virtual BOOLEAN SetParameter(const DataItem &item);
00074
00075     protected:
00076         virtual BOOLEAN IsRowFiltered(Provider* base_provider, INT row, BOOLEAN negate);
00077
00078     private:
00079         INT             m_snd_column;
00080         FilterOperator  m_filter_op;
00081         FilterRule*     m_snd_rule;
00082
00083 };
00084
00086 #endif  // _Apoxi_AuxExtensions_DualFilterProvider_hpp
00087
00088
Generated on Tue Jan 24 14:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/JoinProvider.cpp File Reference

AddOns/AuxExtensions/JoinProvider.cpp File Reference

#include <AddOns/AuxExtensions/AuxExtensionsPreComp.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include <Auxiliary/DataItem.hpp>
#include "JoinRule.hpp"
#include "JoinProvider.hpp"

Include dependency graph for JoinProvider.cpp:

Generated on Tue Jan 24 16:24:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/JoinProvider.hpp File Reference

AddOns/AuxExtensions/JoinProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>
#include <Auxiliary/IndexTable.hpp>
#include <AddOns/AuxExtensions/ProviderIds.hpp>

Include dependency graph for JoinProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | JoinProvider
class | JoinProviderListener

Defines

#define | Apoxi_AuxExtensions_JoinProvider_hpp

Define Documentation

#define Apoxi_AuxExtensions_JoinProvider_hpp

Generated on Tue Jan 24 16:24:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/JoinProvider.hpp Source File

AddOns/AuxExtensions/JoinProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Apoxi_AuxExtensions_JoinProvider_hpp)
00015 #define Apoxi_AuxExtensions_JoinProvider_hpp
00019
00020 #include <Auxiliary/Provider.hpp>
00021 #include <Auxiliary/IndexTable.hpp>
00022 #include <AddOns/AuxExtensions/ProviderIds.hpp>
00023
00024 class JoinRule;
00025
00039 class JoinProvider : public Provider
00040 {
00041     typedef Provider Base;
00042     public:
00043
00046         JoinProvider();
00047
00058         JoinProvider(INT provider_id, Provider* first_provider, Provider* second_provider, INT first_key_colid, INT second_key_colid, JoinRule* join_rule);
00060         virtual ~JoinProvider();
00061
00063         void Init(INT provider_id, Provider* first_provider, Provider* second_provider, INT first_key_colid, INT second_key_colid, JoinRule* join_rule);
00064
00066         Provider* GetFirstProvider() { return m_first_provider; }
00067
00069         Provider* GetSecondProvider() { return m_second_provider; }
00070
00072         INT GetFirstKeyColumnId() const { return m_first_key_id; }
00073
00075         INT GetSecondKeyColumnId() const { return m_second_key_id; }
00076
00078         JoinRule* GetJoinRule() { return m_join_rule; }
00079
00080 //      /// <em>SetJoinRule</em> sets the current rule for merging.
00081 //      void SetJoinRule(JoinRule* join_rule) { m_join_rule = join_rule; }
00082
00084         virtual INT GetProviderId() const;
00085
00087         virtual INT RowCount();
00088
00091         virtual INT MaxRowCount();
00092
00094         virtual INT ColumnCount() const;
00095
00097         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00098
00100         virtual BOOLEAN SetDataItem(const DataItem & item, INT column);
00101
00105         virtual BOOLEAN SelectRow(INT row);
00106
00110         virtual BOOLEAN CommitRow(INT row);
00111
00114         virtual BOOLEAN AppendRow();
00115
00118         virtual BOOLEAN InsertRow(INT row);
00119
00123         virtual BOOLEAN DeleteRow(INT row);
00124
00128         virtual BOOLEAN ToggleRow(INT row);
00129
00133         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00134
00136         virtual BOOLEAN Update(ProviderListener * listener = 0);
00137
00139         virtual INT GetProgress();
00140
00142         virtual const ColumnInfo * GetColumnInfo(INT column);
00143
00146         virtual BOOLEAN SetParameter(const DataItem &item);
00147
00149         virtual BOOLEAN Lock();
00150
00152         virtual BOOLEAN Unlock();
00153
00155         virtual void OnExecutingListener(Provider* child_provider);
00156
00158         enum AffectedProvider {
00160             Both,
00162             FirstOnly,
00164             SecondOnly,
00166             None
00167         };
00168
00169     protected:
00171         virtual void SetProgress (INT progress);
00172
00173     private:
00174         BOOLEAN             m_key_row_set;
00175         AffectedProvider    m_param;
00176         INT                 m_provider_id;
00177         INT                 m_first_key_id;
00178         INT                 m_second_key_id;
00179         INT                 m_rows;
00180         INT8                m_progress;
00181         JoinRule*           m_join_rule;
00182         Provider*           m_first_provider;
00183         Provider*           m_second_provider;
00184         IndexTable<INT>     m_first_joined_rows;
00185         IndexTable<INT>     m_second_joined_rows;
00186         static ColumnInfo   m_colinfo[];
00187 };
00188
00189 /* For internal use in derived classes of <em>JoinProvider</em> to handle a accurate
00190 progress indication.
00191 Delegates only <em>OnExecuting</em> to the child-listener.
00192 <em>OnStarted</em> and <em>OnFinished</em> on the child-listener should be invoked
00193 directly by the <em>JoinProvider</em>. */
00194 class JoinProviderListener : public ProviderListener {
00195     typedef ProviderListener Base;
00196     public:
00198         JoinProviderListener(JoinProvider* provider, Provider* child_provider, ProviderListener* child_listener);
00199
00201         virtual ~JoinProviderListener();
00202
00205         virtual void OnExecuting();
00206
00207         void SetChildProvider(Provider* child_provider) { m_child_provider = child_provider; }
00208
00209     private:
00210         JoinProvider*       m_join_provider;
00211         Provider*           m_child_provider;
00212         ProviderListener*   m_child_listener;
00213 };  //lint !e1712
00214
00216 #endif  // Apoxi_AuxExtensions_JoinProvider_hpp
00217
Generated on Tue Jan 24 14:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/JoinRule.cpp File Reference

AddOns/AuxExtensions/JoinRule.cpp File Reference

#include <AddOns/AuxExtensions/AuxExtensionsPreComp.hpp>
#include <Auxiliary/DataItem.hpp>
#include "JoinRule.hpp"

Include dependency graph for JoinRule.cpp:

Generated on Tue Jan 24 16:24:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/JoinRule.hpp File Reference

AddOns/AuxExtensions/JoinRule.hpp File Reference

#include <Auxiliary/PhoneNumber.hpp>

Include dependency graph for JoinRule.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | JoinRule
class | PhoneNumberJoinRule
class | StandardJoinRule
StandardJoinRule is a paramaterizable rule for standard relations More...

Defines

#define | Apoxi_AuxExtensions_JoinJoinRule_hpp

Define Documentation

#define Apoxi_AuxExtensions_JoinJoinRule_hpp

Generated on Tue Jan 24 16:24:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/JoinRule.hpp Source File

AddOns/AuxExtensions/JoinRule.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Apoxi_AuxExtensions_JoinJoinRule_hpp)
00015 #define Apoxi_AuxExtensions_JoinJoinRule_hpp
00019
00020 #include <Auxiliary/PhoneNumber.hpp>
00021
00022 class DataItem; //lint !e763
00023
00026 class JoinRule
00027 {
00028     public:
00029
00032         enum RelationType {
00034             Injective,
00036             Surjective,
00038             Bijective,
00040             Cartesian
00041         };
00042
00044         JoinRule();
00046         virtual ~JoinRule();
00047
00050         virtual BOOLEAN ExecuteRule(const DataItem& fst_item, const DataItem& snd_item) = 0;
00051
00053         virtual JoinRule::RelationType GetType() = 0;
00054 };
00055
00057 class StandardJoinRule : public JoinRule
00058 {
00059     typedef JoinRule Base;
00060     public:
00061
00062         enum ComparisonType {
00064             EqualType,
00066             NotEqualType,
00068             LessType,
00070             NotLessType,
00072             GreaterType,
00074             NotGreaterType,
00076             CartesianType
00077         };
00078
00080         StandardJoinRule();
00082         virtual ~StandardJoinRule();
00084         void Init (ComparisonType type);
00085
00087         virtual BOOLEAN ExecuteRule(const DataItem& fst_item, const DataItem& snd_item);
00089         virtual JoinRule::RelationType GetType();
00090
00091     private:
00092         ComparisonType m_type;
00093 };
00094
00095 class PhoneNumberJoinRule : public JoinRule
00096 {
00097     typedef JoinRule Base;
00098     public:
00099         PhoneNumberJoinRule();
00100         virtual ~PhoneNumberJoinRule();
00101         virtual BOOLEAN ExecuteRule(const DataItem& fst_item, const DataItem& snd_item);
00104         virtual BOOLEAN MatchPhoneNumbers(const PhoneNumber& number1, const PhoneNumber& number2);
00106         virtual JoinRule::RelationType GetType();
00107 };
00108
00110 #endif  // Apoxi_AuxExtensions_JoinJoinRule_hpp
00111
00112
Generated on Tue Jan 24 14:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/MergeProvider.cpp File Reference

AddOns/AuxExtensions/MergeProvider.cpp File Reference

#include <AddOns/AuxExtensions/AuxExtensionsPreComp.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/BinarySearch.hpp>
#include "JoinRule.hpp"
#include "MergeProvider.hpp"

Include dependency graph for MergeProvider.cpp:

Variables

const INT | c_mp_high_max = 80
const INT | c_mp_low_max = 40
const INT | c_mp_merge_max = 90

Variable Documentation

const INT c_mp_high_max = 80

const INT c_mp_low_max = 40

const INT c_mp_merge_max = 90

Generated on Tue Jan 24 16:24:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/MergeProvider.hpp File Reference

AddOns/AuxExtensions/MergeProvider.hpp File Reference

#include <Auxiliary/AbstractDelegationProvider.hpp>
#include <Auxiliary/IndexTable.hpp>
#include <AddOns/AuxExtensions/ProviderIds.hpp>

Include dependency graph for MergeProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MergeProvider

Defines

#define | Apoxi_AuxExtensions_MergeProvider_hpp

Define Documentation

#define Apoxi_AuxExtensions_MergeProvider_hpp

Generated on Tue Jan 24 16:24:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/MergeProvider.hpp Source File

AddOns/AuxExtensions/MergeProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Apoxi_AuxExtensions_MergeProvider_hpp)
00015 #define Apoxi_AuxExtensions_MergeProvider_hpp
00019
00020 #include <Auxiliary/AbstractDelegationProvider.hpp>
00021 #include <Auxiliary/IndexTable.hpp>
00022 #include <AddOns/AuxExtensions/ProviderIds.hpp>
00023
00024 class JoinRule;
00025
00036 class MergeProvider : public AbstractDelegationProvider
00037 {
00038     typedef AbstractDelegationProvider Base;
00039     public:
00040
00042         enum AffectedProvider {
00044             Both,
00046             ChildOnly,
00048             MergeOnly,
00050             None
00051         };
00052
00055         MergeProvider();
00056
00071         MergeProvider(INT provider_id, Provider* child_provider, Provider* merge_provider, INT child_key_colid, INT merge_key_colid, JoinRule* merge_rule, UINT max_cache_depth = 6);
00072
00074         virtual ~MergeProvider();
00075
00077         void Init(INT provider_id, Provider* child_provider, Provider* merged_provider, INT child_key_colid, INT merge_key_colid, JoinRule* merge_rule, UINT max_cache_depth = 6);
00078
00080         AffectedProvider GetAffectedProvider() { return m_param; }
00081
00083         Provider* GetMergedProvider() { return m_merge_provider; }
00084
00086         void SetMergedProvider(Provider* merged_provider, INT merge_key_colid);
00087
00089         INT GetChildKeyColumnId() const { return m_child_key_id; }
00090
00092         INT GetMergedKeyColumnId() const { return m_merge_key_id; }
00093
00095         JoinRule* GetMergeRule() { return m_merge_rule; }
00096
00098         void SetMergeRule(JoinRule* merge_rule);
00099
00101         virtual INT GetProviderId() const;
00102
00104         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00105
00108         virtual BOOLEAN GetDefaultDataItem(INT columnid, INT row, DataItem & item);
00109
00111         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00112
00116         virtual BOOLEAN SelectRow(INT row);
00117
00121         virtual BOOLEAN CommitRow(INT row);
00122
00124         virtual BOOLEAN AppendRow();
00125
00127         virtual BOOLEAN InsertRow(INT row);
00128
00132         virtual BOOLEAN DeleteRow(INT row);
00133
00137         virtual BOOLEAN ToggleRow(INT row);
00138
00142         virtual BOOLEAN DeleteAllRows(ProviderListener* listener = 0);
00143
00146         virtual BOOLEAN Update(ProviderListener* listener = 0);
00147
00149         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00150
00152         virtual INT ColumnCount() const;
00153
00155         virtual const ColumnInfo * GetColumnInfo(INT column);
00156
00159         virtual BOOLEAN SetParameter(const DataItem &item);
00160
00162         virtual BOOLEAN Lock();
00163
00165         virtual BOOLEAN Unlock();
00166
00168         virtual void OnExecutingListener(Provider* provider = 0);
00169
00170         void SetForceUpdate() { m_merge_needed = TRUE; }
00171
00172     protected:
00173         virtual void OnChildProviderModification(Provider* provider, const Provider::Modification& modification);
00174
00175         virtual BOOLEAN IsLess(const DataItem& item1, const DataItem& item2);
00176
00177         BOOLEAN UpdateIndexTable(ModificationType type, BOOLEAN child_prov_affected, INT row = c_no_row);
00178
00179         Provider*           m_merge_provider;
00180         INT                 m_merge_key_id;
00181
00182         void InitIndexTable();
00183         void QuickSortDataItems(INT& size, INT low, INT high);
00184         INT BinSearchRow(INT size, const DataItem& item, DataItem* cache = 0, UINT cache_size = 0, UINT8 cache_depth = 0);
00185
00187         UINT GetCacheSize(UINT8 max_cache_depth, INT row_count);
00188
00189         IndexTable<INT>     m_sorted_table;
00190         JoinRule*           m_merge_rule;
00191         INT8                m_max_progress;
00192         INT8                m_min_progress;
00193         BOOLEAN             m_merge_needed;
00194         INT                 m_child_key_id;
00195         IndexTable<INT>     m_merged_rows;
00196         UINT                m_max_cache_depth;
00197
00198     private:
00199         INT GetMergeRow(INT child_row);
00200         BOOLEAN MatchRows(INT child_row, INT merge_row);
00201
00202         BOOLEAN Alter(ModificationType type, INT row = -1);
00203
00204         AffectedProvider    m_param;
00205         INT                 m_provider_id;
00206         static ColumnInfo   m_colinfo[];
00207 };
00208
00210 #endif  // Apoxi_AuxExtensions_MergeProvider_hpp
00211
00212
Generated on Tue Jan 24 14:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/MimeCoding.cpp File Reference

AddOns/AuxExtensions/MimeCoding.cpp File Reference

#include <AddOns/AuxExtensions/AuxExtensionsPreComp.hpp>
#include "MimeCoding.hpp"
#include <Auxiliary/StrUtil.hpp>

Include dependency graph for MimeCoding.cpp:

Defines

#define | APOXI_MIME_TEST_LEN 100

Functions

void | TestMimeCoding ()

Define Documentation

#define APOXI_MIME_TEST_LEN 100

Function Documentation

void TestMimeCoding ( )

Generated on Tue Jan 24 16:24:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/MimeCoding.hpp File Reference

AddOns/AuxExtensions/MimeCoding.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for MimeCoding.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Base64Coder
class | MimeCoder
class | MimeCoding
class | QuotedPrintableCoder

Defines

#define | APOXI_MIME_LINE_WIDTH 76

Define Documentation

#define APOXI_MIME_LINE_WIDTH 76

Generated on Tue Jan 24 16:24:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/MimeCoding.hpp Source File

AddOns/AuxExtensions/MimeCoding.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifndef Apoxi_MimeCoding_hpp
00010 #define Apoxi_MimeCoding_hpp
00011
00012 #include <Kernel/Types.hpp>
00013
00014 #define APOXI_MIME_LINE_WIDTH 76
00015
00024 class MimeCoding
00025 {
00026     public:
00039         static INT EncodeQuotedPrintable(CHAR *buffer, INT buffer_length, const CHAR *data, INT data_length, BOOLEAN is_text);
00040
00051         static INT DecodeQuotedPrintable(CHAR *buffer, INT buffer_length, const CHAR *data, INT data_length, BOOLEAN is_text);
00052
00065         static INT EncodeBase64(CHAR *buffer, INT buffer_length, const CHAR *data, INT data_length, BOOLEAN is_text);
00066
00077         static INT DecodeBase64(CHAR *buffer, INT buffer_length, const CHAR *data, INT data_length, BOOLEAN is_text);
00078 };
00079
00080 class MimeCoder
00081 {
00082     public:
00083         MimeCoder(CHAR *buffer = 0, INT buffer_length = 0, BOOLEAN is_text = TRUE);
00084
00085         void Advance(INT amount);
00086         BOOLEAN Check(INT amount) const;
00087         BOOLEAN IsText() const { return m_is_text; }
00088
00089     protected:
00090         CHAR *m_buffer_ptr;
00091         INT m_buffer_length;
00092         INT m_buffer_left;
00093
00094         INT m_line_length;
00095
00096         BOOLEAN m_is_text;
00097 };
00098
00099 class QuotedPrintableCoder : public MimeCoder
00100 {
00101     public:
00102         QuotedPrintableCoder(CHAR *buffer = 0, INT buffer_length = 0, BOOLEAN is_text = TRUE);
00103
00104         BOOLEAN EncodePush(CHAR data, BOOLEAN last);
00105         BOOLEAN EncodeChar(CHAR data, BOOLEAN last, BOOLEAN coded = TRUE);
00106         INT EncodeEnd();
00107
00108         BOOLEAN DecodePush(CHAR data);
00109         INT DecodeChar(CHAR data);
00110         INT DecodeEnd();
00111     private:
00112         CHAR m_pending;
00113 };
00114
00115 class Base64Coder : public MimeCoder
00116 {
00117     public:
00118         Base64Coder(CHAR *buffer = 0, INT buffer_length = 0, BOOLEAN is_text = TRUE);
00119
00120         BOOLEAN EncodePush(CHAR data);
00121         INT EncodeEnd();
00122
00123         BOOLEAN DecodePush6Bits(INT code);
00124         BOOLEAN DecodePush(CHAR data);
00125         INT DecodeEnd();
00126     private:
00127
00128         UINT32 m_group;
00129         INT m_group_length;
00130 };
00131
00132 #endif // Apoxi_MimeCoding_hpp
00133
00134
Generated on Tue Jan 24 14:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/PhoneNumberMergeProvider.cpp File Reference

AddOns/AuxExtensions/PhoneNumberMergeProvider.cpp File Reference

#include <AddOns/AuxExtensions/AuxExtensionsPreComp.hpp>
#include <Auxiliary/DataItem.hpp>
#include "JoinRule.hpp"
#include "PhoneNumberMergeProvider.hpp"

Include dependency graph for PhoneNumberMergeProvider.cpp:

Generated on Tue Jan 24 16:24:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp File Reference

AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp File Reference

#include <AddOns/AuxExtensions/MergeProvider.hpp>

Include dependency graph for PhoneNumberMergeProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PhoneNumberMergeProvider

Defines

#define | Apoxi_AuxExtensions_PhoneNumberMergeProvider_hpp

Define Documentation

#define Apoxi_AuxExtensions_PhoneNumberMergeProvider_hpp

Generated on Tue Jan 24 16:24:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp Source File

AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AuxExtensions_PhoneNumberMergeProvider_hpp)
00010 #define Apoxi_AuxExtensions_PhoneNumberMergeProvider_hpp
00014
00015 #include <AddOns/AuxExtensions/MergeProvider.hpp>
00016
00022 class PhoneNumberJoinRule;
00023
00024 class PhoneNumberMergeProvider : public MergeProvider
00025 {
00026     typedef MergeProvider Base;
00027     public:
00028         PhoneNumberMergeProvider();
00029
00039         PhoneNumberMergeProvider(INT provider_id, Provider* child_provider, Provider* merged_provider, INT child_key_colid, INT merge_key_colid, PhoneNumberJoinRule* merge_rule);
00041         virtual ~PhoneNumberMergeProvider();
00042
00044         void Init(INT provider_id, Provider* child_provider, Provider* merge_provider, INT child_key_colid, INT merge_key_colid, PhoneNumberJoinRule* merge_rule);
00045
00047         virtual BOOLEAN GetDefaultDataItem(INT columnid, INT row, DataItem& item);
00048
00049     protected:
00050         virtual BOOLEAN IsPhoneNumberTextDefaultData(INT columnid, INT row);
00051         virtual BOOLEAN IsLess(const DataItem& item1, const DataItem& item2);
00052
00053 };
00054
00056 #endif  // Apoxi_AuxExtensions_PhoneNumberMergeProvider_hpp
00057
Generated on Tue Jan 24 14:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/ProviderIds.hpp File Reference

AddOns/AuxExtensions/ProviderIds.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_AuxExtensions_ProviderIds_hpp

Variables

const INT | c_first_provider_id = 6203
const INT | c_first_provider_row_id = 6201
const INT | c_key_column_id = 6200
const INT | c_merged_provider_id = 6216
const INT | c_merged_row_id = 6215
const INT | c_second_provider_id = 6204
const INT | c_second_provider_row_id = 6202

Define Documentation

#define Apoxi_AuxExtensions_ProviderIds_hpp

Generated on Tue Jan 24 16:21:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/ProviderIds.hpp Source File

AddOns/AuxExtensions/ProviderIds.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (Apoxi_AuxExtensions_ProviderIds_hpp)
00010 #define Apoxi_AuxExtensions_ProviderIds_hpp
00014
00015 // Reserved range: 6000 to 6999
00016
00017 /*  ------------------------------------------------------------------------
00018     Provider ids
00019     ------------------------------------------------------------------------ */
00020
00021 /*  ------------------------------------------------------------------------
00022     Provider column ids
00023     ------------------------------------------------------------------------ */
00024
00025 // Join Provider
00026 const INT c_key_column_id                   = 6200;
00027 const INT c_first_provider_row_id           = 6201;
00028 const INT c_second_provider_row_id          = 6202;
00029 const INT c_first_provider_id               = 6203;
00030 const INT c_second_provider_id              = 6204;
00031
00032 // MergeProvider
00033 const INT c_merged_row_id                   = 6215;
00034 const INT c_merged_provider_id              = 6216;
00035
00037 #endif // Apoxi_AuxExtensions_ProviderIds_hpp
00038
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/SwitchedRleCompression.hpp File Reference

AddOns/AuxExtensions/SwitchedRleCompression.hpp File Reference

#include <Auxiliary/SwitchedRleCompression.hpp>

Include dependency graph for SwitchedRleCompression.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 16:24:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/AuxExtensions/SwitchedRleCompression.hpp Source File

AddOns/AuxExtensions/SwitchedRleCompression.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class SwitchedRleCompression has been moved to Auxiliary.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6. */
00013 #include <Auxiliary/SwitchedRleCompression.hpp>
00014
00015
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/BtSocket/BtSocketAddr.cpp File Reference

AddOns/BtSocket/BtSocketAddr.cpp File Reference

#include "PreComp.hpp"
#include "BtSocketAddr.hpp"
#include <msimport.h>
#include <scttypes.h>
#include <sio.h>
#include <sio_sock.h>
#include <sio_common.h>
#include <msexport.h>
#include <btapi_common.h>
#include <io_sockbt.h>
#include <sio_sockbt.h>

Include dependency graph for BtSocketAddr.cpp:

Generated on Tue Jan 24 16:25:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/BtSocket/BtSocketAddr.hpp File Reference

AddOns/BtSocket/BtSocketAddr.hpp File Reference

#include <AddOns/SerialSocket/SockAddress.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>

Include dependency graph for BtSocketAddr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | L2CapSocketAddr
class | RfcommSocketAddr

Defines

#define | L2CA_RXMTU_GET 0x4003
#define | L2CA_RXMTU_SET 0x4002
#define | L2CA_TXMTU_GET 0x4001
#define | L2CA_TXMTU_SET 0x4000

Enumerations

enum | BtProtocol { c_bt_protocol_l2cap, c_bt_protocol_rfcomm }

Define Documentation

#define L2CA_RXMTU_GET 0x4003

#define L2CA_RXMTU_SET 0x4002

#define L2CA_TXMTU_GET 0x4001

#define L2CA_TXMTU_SET 0x4000

Enumeration Type Documentation

enum BtProtocol

Enumerator:
c_bt_protocol_l2cap
c_bt_protocol_rfcomm

Generated on Tue Jan 24 16:25:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/BtSocket/BtSocketAddr.hpp Source File

AddOns/BtSocket/BtSocketAddr.hpp

Go to the documentation of this file.
00001 /* ============================================================================
00002 ** Copyright (C) 2004-2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** ============================================================================
00004 **
00005 ** This document contains proprietary information belonging to COMNEON.
00006 ** Passing on and copying of this document, use and communication of its
00007 ** contents is not permitted without prior written authorisation.
00008 **
00009 ** ============================================================================
00010 ** Revision Information :
00011 **    File name: BtSocketAddr.hpp
00012 **    Version:
00013 **    Date: 2005-10-24    14:48:26
00014 **
00015 ** ============================================================================
00016 **
00017 ** Project:     VenusU
00018 ** Block:       BtSocketAddr
00019 ** Process:
00020 ** File name:   BtSocketAddr.hpp
00021 **
00022 ** ============================================================================
00023 **
00024 **
00025 ** ============================================================================
00026 ** History:
00027 **
00028 ** Date       Author                Comment
00029 ** ----------------------------------------------------------------------------
00030 **
00031 ** 31.08.05   Murugan/Balan         created.
00032 ** ============================================================================
00033 */
00034
00035 #ifndef SERIAL_BTSOCKADDRESS_H
00036 #define SERIAL_BTSOCKADDRESS_H
00037
00038 #include <AddOns/SerialSocket/SockAddress.hpp>
00039 #include <Bluetooth/BtDeviceAddress.hpp>
00040
00041 // for requesting TX and RX MTU size
00042 #define L2CA_TXMTU_SET      0x4000
00043 #define L2CA_RXMTU_SET      0x4002
00044
00045 // for getting the negotiated TX and RX MTU size
00046 #define L2CA_TXMTU_GET      0x4001
00047 #define L2CA_RXMTU_GET      0x4003
00048
00049 enum BtProtocol
00050 {
00051     c_bt_protocol_l2cap,
00052     c_bt_protocol_rfcomm
00053 };
00054
00055 //Socket RFCOMM address
00056 class RfcommSocketAddr : public SocketAddr
00057 {
00058 public:
00060     RfcommSocketAddr();
00065     RfcommSocketAddr(BtDeviceAddress& addr, UINT8 serverchannel);
00067     ~RfcommSocketAddr();
00070     void* GetSockAddr();
00073     INT32 GetSockAddrSize();
00074
00078     void GetDeviceAddress(BtDeviceAddress& btDevAddr);
00079
00082     unsigned char GetServerChannel();
00083
00084 private:
00085     void*      m_rfcommSockAddr;
00086     INT32   m_AddrSize;
00087 };
00088
00089 //Socket L2CAP address
00090 class L2CapSocketAddr : public SocketAddr
00091 {
00092 public:
00093     L2CapSocketAddr();
00098     L2CapSocketAddr(BtDeviceAddress& addr, UINT16 muxchan);
00101     void* GetSockAddr();
00104     INT32 GetSockAddrSize();
00105
00107     ~L2CapSocketAddr();
00108
00112     void GetDeviceAddress(BtDeviceAddress& btDevAddr);
00113
00116     unsigned short GetPsm();
00117
00118 private:
00119     void*   m_l2CapSockaddr;
00120     INT32   m_AddrSize;
00121
00122 };
00123
00124 #endif //SERIAL_BTSOCKADDRESS_H
00125
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/BtSocket/PreComp.cpp File Reference

AddOns/BtSocket/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/BtSocket/PreComp.hpp File Reference

AddOns/BtSocket/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:16:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/BtSocket/PreComp.hpp Source File

AddOns/BtSocket/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/AudioCapturerEncoder.hpp File Reference

AddOns/CodecManager/AudioCapturerEncoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>

Include dependency graph for AudioCapturerEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioCapturerEncoder

Defines

#define | Apoxi_AudioCapturerEncoder_hpp

Define Documentation

#define Apoxi_AudioCapturerEncoder_hpp

Generated on Tue Jan 24 16:25:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/AudioCapturerEncoder.hpp Source File

AddOns/CodecManager/AudioCapturerEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AudioCapturerEncoder_hpp)
00010 #define Apoxi_AudioCapturerEncoder_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecDevice.hpp>
00017
00023 class AudioCapturerEncoder : public CodecDevice {
00024     public:
00025
00033         typedef void (*CbReady)(void *context);
00034
00044         virtual ResultType Open(AudioChannel& audio_channel) = 0;
00045
00051         virtual void Close() = 0;
00052
00068         virtual ResultType RegisterCallbackFunctions(
00069                                         void* context,
00070                                         CbReady cb_data_available) = 0;
00071
00077         virtual ResultType GetAudioChannelId(AudioChannel& audio_channel) = 0;
00078
00088         virtual ResultType ConfigureAMR(    AmrIfFormat amr_if_format,
00089                                             EncQualityConfig quality_config,
00090                                             AmrDtxConfig dtx_config,
00091                                             UINT32 max_buffer_size) = 0;
00092
00103         virtual ResultType ConfigureAAC(    AacFormat aac_encoding_format,
00104                                             UINT16 sampling_rate,
00105                                             EncQualityConfig quality_config,
00106                                             MonoSteroConfig monostero_config,
00107                                             UINT32 max_buffer_size) = 0;
00108
00115         virtual ResultType GetBuffer(AudioIOBuffer** buffer) = 0;
00116
00117     protected:
00118
00119     private:
00120
00121     friend class CodecManager;
00122
00123 };
00124
00126 #endif // Apoxi_AudioCapturerEncoder_hpp
00127
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/AudioDecoder.hpp File Reference

AddOns/CodecManager/AudioDecoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>

Include dependency graph for AudioDecoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioDecoder

Defines

#define | Apoxi_AudioDecoder_hpp

Define Documentation

#define Apoxi_AudioDecoder_hpp

Generated on Tue Jan 24 16:25:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/AudioDecoder.hpp Source File

AddOns/CodecManager/AudioDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AudioDecoder_hpp)
00010 #define Apoxi_AudioDecoder_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecDevice.hpp>
00017
00023 class AudioDecoder : public CodecDevice {
00024     public:
00025
00028         enum ParameterType {
00036             QualityLevel,
00042             Format,
00043             EndOfParameterType
00044         };
00045
00047         enum DecodingFunctionType {
00048             DecodeBufferFct,
00049             DecodeFrameFct
00050         };
00051
00053         enum AacFormatType {
00055             AacRawFormat,
00058             AacAdifOrAdtsFormat,
00061             AacAdtsWithOneRawDataBlockFormat
00062         };
00063
00082         typedef void (*CbFrameDecoded)( ResultType result,
00083                                         void* context,
00084                                         const UINT8 HUGE* out_buf,
00085                                         UINT32 out_buf_len,
00086                                         UINT32 in_buf_used);
00087
00096         virtual ResultType Open() = 0;
00097
00103         virtual void Close() = 0;
00104
00129         virtual ResultType SetConfig(   const UINT8* config_stream,
00130                                         UINT32& config_len,
00131                                         const AudioDecoderParameters& params,
00132                                         AudioStreamInfo& stream_info) = 0;
00133
00145         virtual ResultType GetCapabilities(AudioCodecCapabilities& caps) = 0;
00146
00173         virtual ResultType AllocateOutputBuffers(
00174                                             UINT8 HUGE** &out_buf_array,
00175                                             UINT8& out_buf_count,
00176                                             UINT32& out_buf_len,
00177                                             DecodingFunctionType& dec_fct) = 0;
00178
00194         virtual ResultType RegisterCallbackFunctions(
00195                                         void* context,
00196                                         CbFrameDecoded cb_frame_decoded) = 0;
00197
00216         virtual ResultType DecodeBuffer(    const UINT8 HUGE* in_buf,
00217                                             UINT32 in_buf_len,
00218                                             const UINT8 HUGE* out_buf,
00219                                             UINT32 out_buf_len) = 0;
00220
00239         virtual ResultType DecodeFrame( const UINT8 HUGE* in_buf,
00240                                         UINT32 in_buf_len,
00241                                         const UINT8 HUGE* out_buf,
00242                                         UINT32 out_buf_len) = 0;
00243
00262         virtual ResultType SetParameters(   const ParameterType* types_array,
00263                                             const UINT32* values_array,
00264                                             UINT8 array_count) = 0;
00265
00287         virtual ResultType GetParameters(   const ParameterType* types_array,
00288                                             UINT32* values_array,
00289                                             UINT8 array_count) = 0;
00290
00291     protected:
00292
00293     private:
00294
00295     friend class CodecManager;
00296
00297 };
00298
00300 #endif // Apoxi_AudioDecoder_hpp
00301
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/AudioDecoderRenderer.hpp File Reference

AddOns/CodecManager/AudioDecoderRenderer.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>

Include dependency graph for AudioDecoderRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioDecoderRenderer

Defines

#define | Apoxi_AudioDecoderRenderer_hpp

Define Documentation

#define Apoxi_AudioDecoderRenderer_hpp

Generated on Tue Jan 24 16:25:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/AudioDecoderRenderer.hpp Source File

AddOns/CodecManager/AudioDecoderRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AudioDecoderRenderer_hpp)
00010 #define Apoxi_AudioDecoderRenderer_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/CodecDevice.hpp>
00018
00024 class AudioDecoderRenderer : public CodecDevice {
00025     public:
00026
00034         typedef void (*CbReady)(void *context);
00035
00045         virtual ResultType Open(AudioChannel& audio_channel) = 0;
00046
00052         virtual void Close() = 0;
00053
00071         virtual ResultType RegisterCallbackFunctions(
00072                                         void* context,
00073                                         CbReady cb_ready_for_data,
00074                                         CbResult cb_all_buffers_processed) = 0;
00075
00087         virtual ResultType DecodeRenderBuffer(AudioIOBuffer* buffer) = 0;
00088
00091         virtual ResultType GetAudioChannelId(AudioChannel& audio_channel) = 0;
00092
00093     protected:
00094
00095     private:
00096
00097     friend class CodecManager;
00098
00099 };
00100
00102 #endif // Apoxi_AudioDecoderRenderer_hpp
00103
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/AudioEncoder.hpp File Reference

AddOns/CodecManager/AudioEncoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>

Include dependency graph for AudioEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioEncoder

Defines

#define | Apoxi_AudioEncoder_hpp

Define Documentation

#define Apoxi_AudioEncoder_hpp

Generated on Tue Jan 24 16:25:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/AudioEncoder.hpp Source File

AddOns/CodecManager/AudioEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AudioEncoder_hpp)
00010 #define Apoxi_AudioEncoder_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecDevice.hpp>
00017
00023 class AudioEncoder : public CodecDevice {
00024     public:
00025
00028         enum ParameterType {
00034             BitPool,
00038             FilterBankBlockLength,
00039             EndOfParameterType
00040         };
00041
00043         enum EncodingFunctionType {
00044             EncodeBufferFct,
00045             EncodeFrameFct
00046         };
00047
00049         enum ChannelModeType {
00050             MonoChannelMode,
00051             DualChannelMode,
00052             StereoChannelMode,
00053             JointStereoChannelMode
00054         };
00055
00058         enum BitAllocationMethodType {
00059             LoudnessAllocation,
00060             SnrAllocation
00061         };
00062
00083         typedef void (*CbFrameEncoded)( ResultType result,
00084                                         void* context,
00085                                         const UINT8 HUGE* in_buf,
00086                                         UINT32 in_buf_used,
00087                                         const UINT8 HUGE* out_buf,
00088                                         UINT32 out_buf_len);
00089
00098         virtual ResultType Open() = 0;
00099
00105         virtual void Close() = 0;
00106
00114         virtual ResultType SetConfig(const AudioEncoderParameters& params) = 0;
00115
00127         virtual ResultType GetCapabilities(AudioCodecCapabilities& caps) = 0;
00128
00155         virtual ResultType AllocateOutputBuffers(
00156                                             UINT8 HUGE** &out_buf_array,
00157                                             UINT8& out_buf_count,
00158                                             UINT32& out_buf_len,
00159                                             EncodingFunctionType& enc_fct) = 0;
00160
00176         virtual ResultType RegisterCallbackFunctions(
00177                                         void* context,
00178                                         CbFrameEncoded cb_frame_encoded) = 0;
00179
00198         virtual ResultType EncodeBuffer(    const UINT8 HUGE* in_buf,
00199                                             UINT32 in_buf_len,
00200                                             const UINT8 HUGE* out_buf,
00201                                             UINT32 out_buf_len) = 0;
00202
00221         virtual ResultType EncodeFrame( const UINT8 HUGE* in_buf,
00222                                         UINT32 in_buf_len,
00223                                         const UINT8 HUGE* out_buf,
00224                                         UINT32 out_buf_len) = 0;
00225
00244         virtual ResultType SetParameters(   const ParameterType* types_array,
00245                                             const UINT32* values_array,
00246                                             UINT8 array_count) = 0;
00247
00269         virtual ResultType GetParameters(   const ParameterType* types_array,
00270                                             UINT32* values_array,
00271                                             UINT8 array_count) = 0;
00272
00273     protected:
00274
00275     private:
00276
00277     friend class CodecManager;
00278
00279 };
00280
00282 #endif // Apoxi_AudioEncoder_hpp
00283
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/CodecDevice.hpp File Reference

AddOns/CodecManager/CodecDevice.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for CodecDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CodecDevice
struct | CodecDevice::AudioChannel
struct | CodecDevice::AudioCodecCapabilities
struct | CodecDevice::AudioDecoderParameters
struct | CodecDevice::AudioEncoderParameters
struct | CodecDevice::AudioIOBuffer
struct | CodecDevice::AudioStreamInfo
struct | CodecDevice::Properties
struct | CodecDevice::VideoCodecCapabilities
struct | CodecDevice::VideoDecoderInfo
struct | CodecDevice::VideoDecoderParameters
struct | CodecDevice::VideoEncoderInfo
struct | CodecDevice::VideoEncoderParameters
struct | CodecDevice::VideoStreamInfo

Defines

#define | Apoxi_CodecDevice_hpp

Define Documentation

#define Apoxi_CodecDevice_hpp

Generated on Tue Jan 24 16:25:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/CodecDevice.hpp Source File

AddOns/CodecManager/CodecDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CodecDevice_hpp)
00010 #define Apoxi_CodecDevice_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/Macros.hpp>
00017
00018 class CodecDevice {
00019
00020     public:
00021
00023         typedef INT32 AudioChannelId;
00024
00026         struct AudioChannel {
00028             AudioChannelId m_id;
00029         };
00030
00032         typedef UINT32 TimestampMSec;
00033
00036         enum ResultType {
00038             Success = 0,
00040             MediaNotSupported,
00041             OutOfMemory,
00043             SmallBuffer,
00044             NullParameter,
00045             InvalidParameter,
00046             InvalidFrameSize,
00048             FeatureNotSupported,
00050             GeneralError,
00053             MaxNumberOfCodersReached,
00056             MaxNumberOfOperationsReached,
00058             ArrayTooShort,
00059             InvalidState,
00060             EndOfResultType
00061         };
00062
00064         enum CodecType {
00067             DefaultCodec = 0,
00070             UnknownCodec,
00071             Mpeg4Sp,
00072             H263Bl,
00073             GsmAmrNb,
00074             Mpeg4Aac,
00075             Qcelp,
00076             Evrc,
00077             Mp3,
00078             Mpeg4AacPlusV1,
00079             Mpeg4AacPlusV2,
00080             H264Bp,
00081             EndOfCodecType
00082         };
00083
00087         enum ApplicationCategoriesFlagsType {
00088             StorageAppCatFlag = 0x1,
00089             StreamingAppCatFlag = 0x2,
00090             TelephonyAppCatFlag = 0x4,
00091             GreatestValueOfApplicationCategoriesFlagsType = TelephonyAppCatFlag
00092         };
00093
00096         enum LocationType {
00097             HostLocation,
00098             CompanionLocation,
00099             EndOfLocationType
00100         };
00101
00104         enum DirectionType {
00105             UnspecificDirection,
00106             DecodingDirection,
00107             EncodingDirection,
00108             EndOfDirectionType
00109         };
00110
00112         enum AmrIfFormat {
00113             AmrFrameFormatUndefined = 0,
00114                         AmrFrameFormatConformance, /* KB: Added to ensure match with tGciAudioAmrInterfaceFormatConfig in gci_audio.h */
00115             AmrFrameFormatIf1,
00116             AmrFrameFormatIf2,
00117             AmrFrameFormatMime, /* KB: Added to ensure match with tGciAudioAmrInterfaceFormatConfig in gci_audio.h */
00118             AmrFrameFormatEnd
00119         };
00120
00122         enum EncQualityConfig {
00123             EncQualityLow,
00124             EncQualityMid,
00125             EncQualityHigh
00126         };
00127
00129         enum AmrDtxConfig {
00130             AmrDtxOff = 0,
00131             AmrDtxOn,
00132             AmrDtxEnd
00133         };
00134
00136         enum AacFormat {
00137             AacFormatAdts = 0,
00138             AacFormatAdif,
00139             AacFormatRaw,
00140             AacFormatEnd
00141         };
00142
00144         enum MonoSteroConfig {
00145             Mono = 0,
00146             Stereo,
00147             DualMono,
00148             MonoStereoConfigEnd
00149         };
00150
00152         struct AudioIOBuffer {
00154             UINT8* m_buffer;
00156             UINT32 m_buffer_len;
00158             BOOLEAN m_last_buffer;
00160             TimestampMSec m_time;
00161         };
00162
00164         struct VideoStreamInfo {
00166             CodecType m_stream_type;
00169             UINT32 m_max_bit_rate;
00172             UINT16 m_ext_width;
00175             UINT16 m_ext_height;
00177             UINT16 m_actual_width;
00179             UINT16 m_actual_height;
00181             UINT32 m_out_frame_length;
00185             UINT16 m_frame_rate_numerator;
00189             UINT16 m_frame_rate_denominator;
00195             INT m_left_offset;
00201             INT m_top_offset;
00202         };
00204         struct VideoDecoderInfo {
00206             LocationType m_location;
00209             BOOLEAN m_clock_support;
00210         };
00211
00213         struct VideoEncoderInfo {
00215             LocationType m_location;
00218             UINT32 m_in_buf_max_len;
00219         };
00220
00222         struct VideoCodecCapabilities {
00223
00225             VideoCodecCapabilities() : m_array_of_supported_codecs(0) {}
00226
00228             ~VideoCodecCapabilities() {delete [] m_array_of_supported_codecs;}
00229
00233             UINT8 m_num_of_supported_codecs;
00236             CodecType* m_array_of_supported_codecs;
00238             UINT16 m_min_width;
00240             UINT16 m_max_width;
00242             UINT16 m_min_height;
00244             UINT16 m_max_height;
00248             UINT16 m_min_frame_rate_numerator;
00252             UINT16 m_min_frame_rate_denominator;
00256             UINT16 m_max_frame_rate_numerator;
00260             UINT16 m_max_frame_rate_denominator;
00262             UINT32 m_min_bit_rate;
00264             UINT32 m_max_bit_rate;
00269             UINT16 m_min_quality_level;
00273             UINT16 m_max_quality_level;
00278             UINT32 m_application_categories;
00279         };
00280
00283         struct VideoEncoderParameters {
00285             UINT16 m_actual_width;
00287             UINT16 m_actual_height;
00291             UINT16 m_frame_rate_numerator;
00295             UINT16 m_frame_rate_denominator;
00297             UINT32 m_bit_rate;
00301             UINT32 m_timer_resolution;
00311             UINT16 m_quality_level;
00318             UINT32 m_application_category;
00319         };
00320
00323         struct VideoDecoderParameters {
00332             UINT16 m_quality_level;
00335             UINT32 m_max_bit_rate;
00343             UINT16 m_actual_width;
00351             UINT16 m_actual_height;
00357             UINT32 m_length_of_length_field;
00361             UINT32 m_length_of_header_length_field;
00362         };
00363
00365         struct AudioStreamInfo {
00367             CodecType m_codec_type;
00369             UINT32 m_sampling_frequency;
00371             UINT32 m_num_of_channels;
00372         };
00373
00375         struct AudioCodecCapabilities {
00376
00378             AudioCodecCapabilities() : m_array_of_supported_codecs(0) {}
00379
00381             ~AudioCodecCapabilities() {delete [] m_array_of_supported_codecs;}
00382
00386             UINT8 m_num_of_supported_codecs;
00389             CodecType* m_array_of_supported_codecs;
00392             UINT16 m_min_quality_level;
00394             UINT16 m_max_quality_level;
00399             UINT32 m_application_categories;
00400         };
00401
00404         struct AudioDecoderParameters {
00414             CodecType m_audio_codec;
00421             UINT16 m_quality_level;
00427             INT m_format;
00428         };
00429
00434         struct AudioEncoderParameters {
00436             UINT32 m_input_sampling_frequency;
00439             INT m_channel_mode;
00442             INT m_bit_allocation_method;
00444             UINT32 m_block_len;
00446             UINT32 m_num_of_subbands;
00450             INT16 m_bit_pool;
00451         };
00452
00455         struct Properties {
00456
00458             Properties() : m_array_of_supported_codecs(0) {}
00459
00461             ~Properties() {delete [] m_array_of_supported_codecs;}
00462
00464             DirectionType m_direction;
00467             BOOLEAN m_combined_device;
00469             CodecType* m_array_of_supported_codecs;
00472             UINT m_num_of_supported_codecs;
00473         };
00474
00485         typedef void (*CbResult)(   ResultType result,
00486                                     void* context);
00487
00502         typedef void (*CbResultAndTimeInfo)(ResultType result,
00503                                             void* context,
00504                                             UINT32 time_ms);
00505
00507         virtual ~CodecDevice() {}
00508
00516         virtual ResultType GetProperties(Properties& properties) = 0;
00517
00518     protected:
00519
00521         CodecDevice() {}
00522
00530         virtual ResultType SetCodec(CodecType codec) = 0;
00531
00532     private:
00533
00535         CodecDevice(const CodecDevice& device) { ASSERT_DEBUG(FALSE); }
00536
00538         CodecDevice& operator=(const CodecDevice& device) {
00539             if (&device != this) ASSERT_DEBUG(FALSE); return *this;
00540         }
00541
00542     friend class CodecManager;
00543
00544 };
00545
00547 #endif // Apoxi_CodecDevice_hpp
00548
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/CodecManager.cpp File Reference

AddOns/CodecManager/CodecManager.cpp File Reference

#include "CodecManager.hpp"
#include <Config/CodecConfig.hpp>

Include dependency graph for CodecManager.cpp:

Generated on Tue Jan 24 16:25:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/CodecManager.hpp File Reference

AddOns/CodecManager/CodecManager.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include "CodecDevice.hpp"

Include dependency graph for CodecManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CodecManager

Defines

#define | Apoxi_CodecManager_hpp

Define Documentation

#define Apoxi_CodecManager_hpp

Generated on Tue Jan 24 16:25:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/CodecManager.hpp Source File

AddOns/CodecManager/CodecManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CodecManager_hpp)
00010 #define Apoxi_CodecManager_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/Macros.hpp>
00017 #include "CodecDevice.hpp"
00018
00022 class CodecManager {
00023
00024     public:
00025
00043         CodecDevice::ResultType ObtainDecoder(
00044                                             CodecDevice*& codec_device,
00045                                             CodecDevice::CodecType codec_type,
00046                                             BOOLEAN& combined_device);
00047
00056         void ReleaseDecoder(CodecDevice* codec_device);
00057
00075         CodecDevice::ResultType ObtainEncoder(
00076                                             CodecDevice*& codec_device,
00077                                             CodecDevice::CodecType codec_type,
00078                                             BOOLEAN& combined_device);
00079
00088         void ReleaseEncoder(CodecDevice* codec_device);
00089
00099         CodecDevice::ResultType RegisterDecoder(CodecDevice* codec_device);
00100
00104         void UnregisterDecoder(CodecDevice* codec_device);
00105
00115         CodecDevice::ResultType RegisterEncoder(CodecDevice* codec_device);
00116
00120         void UnregisterEncoder(CodecDevice* codec_device);
00121
00123         virtual ~CodecManager();
00124
00125     private:
00126
00130         enum CoderFlagsType {
00133             CoderInUseFlag = 1<<0
00134         };
00135
00141         CodecDevice** m_reg_encoders_array;
00147         CodecDevice** m_reg_decoders_array;
00148
00154         UINT8* m_encoders_flags_array;
00160         UINT8* m_decoders_flags_array;
00161
00163         UINT8 m_num_of_reg_encoders;
00165         UINT8 m_num_of_reg_decoders;
00166
00169         UINT8 m_num_of_encoders_in_use;
00172         UINT8 m_num_of_decoders_in_use;
00173
00175         CodecManager();
00176
00178         CodecManager(const CodecManager& codec_man) { ASSERT_DEBUG(FALSE); }
00179
00181         CodecManager& operator=(const CodecManager& codec_man) {
00182             if (&codec_man != this) ASSERT_DEBUG(FALSE); return *this;
00183         }
00184
00188         static CodecManager& GetInstance();
00189
00190     friend class CodecConfig; // invokes the GetInstance() function
00191
00192 };
00193
00195 #endif // Apoxi_CodecManager_hpp
00196
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/VideoDecoder.hpp File Reference

AddOns/CodecManager/VideoDecoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>

Include dependency graph for VideoDecoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoDecoder

Defines

#define | Apoxi_VideoDecoder_hpp

Define Documentation

#define Apoxi_VideoDecoder_hpp

Generated on Tue Jan 24 16:25:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/VideoDecoder.hpp Source File

AddOns/CodecManager/VideoDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VideoDecoder_hpp)
00010 #define Apoxi_VideoDecoder_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/CodecDevice.hpp>
00018
00024 class VideoDecoder : public CodecDevice {
00025     public:
00026
00029         enum ParameterType {
00039             QualityLevel,
00040             EndOfParameterType
00041         };
00042
00047         enum FlagsType {
00049             LastFrameFlag = 1<<0,
00052             LastPacketInFrameFlag = 1<<1,
00056             ImmediateDecodingFlag = 1<<2,
00057             GreatestValueOfFlagsType = ImmediateDecodingFlag
00058         };
00059
00078         typedef void (*CbFrameDecoded)( ResultType result,
00079                                         void* context,
00080                                         const UINT8 HUGE* out_buf,
00081                                         UINT32 time_stamp);
00082
00091         typedef void (*CbInBufferFree)( void* context,
00092                                         UINT8 HUGE* in_buf);
00093
00105         virtual ResultType Open(VideoDecoderInfo& dec_info) = 0;
00106
00116         virtual ResultType Close() = 0;
00117
00128         virtual ResultType Start(
00129                                 CbResultAndTimeInfo cb_video_decoder_started,
00130                                 void* context) = 0;
00131
00142         virtual ResultType Stop(CbResult cb_video_decoder_stopped,
00143                                 void* context) = 0;
00144
00177         virtual ResultType SetConfig(
00178                             const UINT8* config_stream,
00179                             UINT32& config_len,
00180                             const VideoDecoderParameters& params,
00181                             VideoStreamInfo& stream_info) = 0;
00182
00194         virtual ResultType GetCapabilities(VideoCodecCapabilities& caps) = 0;
00195
00215         virtual ResultType AllocateOutputBuffers(   UINT8& buf_count,
00216                                                     UINT32& buf_len) = 0;
00217
00238         virtual ResultType RegisterCallbackFunctions(
00239                                         void* context,
00240                                         CbFrameDecoded cb_frame_decoded,
00241                                         CbInBufferFree cb_in_buf_free) = 0;
00242
00253         virtual ResultType SetAssociatedAudioCh(UINT32 audio_channel) = 0;
00254
00262         virtual ResultType SetVideoClockTime(UINT32 time_ms) = 0;
00263
00272         virtual ResultType GetCurrentVideoClockTime(UINT32& time_ms) = 0;
00273
00290         virtual ResultType DecodeFrame( const UINT8 HUGE* in_buf,
00291                                         UINT32 in_buf_len,
00292                                         UINT16 flags,
00293                                         UINT32 time_stamp) = 0;
00294
00309         virtual ResultType DecodePacket(    const UINT8 HUGE* in_buf,
00310                                             UINT32 in_buf_len,
00311                                             UINT16 flags) = 0;
00312
00324         virtual ResultType ReleaseOutputBuffer(const UINT8 HUGE* out_buf) = 0;
00325
00340         virtual ResultType FlushBuffers(    CbResult cb_video_decoder_flushed,
00341                                             void* context) = 0;
00342
00343     protected:
00344
00345     private:
00346
00347     friend class CodecManager;
00348
00349 };
00350
00352 #endif // Apoxi_VideoDecoder_hpp
00353
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/VideoEncoder.hpp File Reference

AddOns/CodecManager/VideoEncoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>

Include dependency graph for VideoEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoEncoder
struct | VideoEncoder::VideoEncoderDynParameters

Defines

#define | Apoxi_VideoEncoder_hpp

Define Documentation

#define Apoxi_VideoEncoder_hpp

Generated on Tue Jan 24 16:25:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/CodecManager/VideoEncoder.hpp Source File

AddOns/CodecManager/VideoEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VideoEncoder_hpp)
00010 #define Apoxi_VideoEncoder_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/CodecDevice.hpp>
00018
00024 class VideoEncoder : public CodecDevice {
00025     public:
00026
00028         enum FrameCodingType {
00029             IFrame,
00030             PFrame,
00031             EndOfFrameCodingType
00032         };
00033
00036         struct VideoEncoderDynParameters {
00040             UINT16 m_frame_rate_numerator;
00044             UINT16 m_frame_rate_denominator;
00046             UINT32 m_bit_rate;
00047         };
00048
00066         typedef void (*CbVideoFrameEncoded)(    ResultType result,
00067                                                 void* context,
00068                                                 UINT8 HUGE* out_buf,
00069                                                 UINT32 out_buf_len_used,
00070                                                 UINT32 time_stamp,
00071                                                 FrameCodingType vop_coding_type);
00072
00082         virtual ResultType Open() = 0;
00083
00093         virtual ResultType Close() = 0;
00094
00103         virtual ResultType SetConfig(   const VideoEncoderParameters& params,
00104                                         UINT32& out_buf_max_len) = 0;
00105
00112         virtual ResultType SetDynamicConfig(
00113                                         VideoEncoderDynParameters &params) = 0;
00114
00126         virtual ResultType GetCapabilities(VideoCodecCapabilities& caps) = 0;
00127
00148         virtual ResultType AllocateOutputBuffers(   UINT8& out_buf_count,
00149                                                     UINT32& out_buf_len) = 0;
00150
00164         virtual ResultType RegisterCallbackFunctions(
00165                                         void* context,
00166                                         CbVideoFrameEncoded cb_video_frame_encoded) = 0;
00167
00175         virtual ResultType Start() = 0;
00176
00188         virtual ResultType Stop(
00189                                             CbResult cb_video_encoder_stopped,
00190                                             void* context) = 0;
00191
00217         virtual ResultType EncodeFrame( UINT8 HUGE* in_buf,
00218                                         UINT32 time_stamp,
00219                                         UINT32 key_frame_ind) = 0;
00220
00228         virtual ResultType ReleaseOutputBuffer(UINT8 HUGE* out_buf) = 0;
00229
00242         virtual ResultType GetConfigStream( UINT8 HUGE*& out_buf,
00243                                             UINT32& out_buf_len) = 0;
00244
00252         virtual ResultType ReleaseConfigStreamBuffer(UINT8 HUGE* buf) = 0;
00253
00263         virtual ResultType FlushBuffers(    CbResult cb_video_encoder_flushed,
00264                                             void* context) = 0;
00265
00268         virtual ResultType InsertKeyFrame() = 0;
00269
00270     protected:
00271
00272     private:
00273
00274     friend class CodecManager;
00275 };
00276
00278 #endif // Apoxi_VideoEncoder_hpp
00279
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/Drm.hpp File Reference

AddOns/Drm/Drm.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Auxiliary/BinData.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/DrmCore.hpp>
#include <AddOns/Drm/DrmRights.hpp>
#include <AddOns/Drm/DrmRightsStore.hpp>

Include dependency graph for Drm.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | BlockData
struct | DrmMediaObject

Defines

#define | Apoxi_Drm_hpp

Define Documentation

#define Apoxi_Drm_hpp

Generated on Tue Jan 24 16:25:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/Drm.hpp Source File

AddOns/Drm/Drm.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_Drm_hpp)
00010 #define Apoxi_Drm_hpp
00011
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Auxiliary/Vector.hpp>
00018 #include <Auxiliary/DateTime.hpp>
00019 #include <Auxiliary/BinData.hpp>
00020 #include <Auxiliary/String.hpp>
00021
00022 #include <Auxiliary/DrmCore.hpp>
00023 #include <AddOns/Drm/DrmRights.hpp>
00024 #include <AddOns/Drm/DrmRightsStore.hpp>
00025
00027 struct DrmMediaObject {
00028
00030         UINT8 *m_content;
00031
00033         String m_content_type ;
00034
00036         INT m_content_len;
00037 };
00038
00045 struct BlockData {
00046     INT m_start_block_num ;         // Starting block number of data to parse.
00047     INT m_end_block_num ;           // End block number of data to parse.
00048     INT m_block_size ;              // Block size to use for each block to be parsed.
00049 } ;
00050
00051
00053 #endif
00054
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmConstraint.cpp File Reference

AddOns/Drm/DrmConstraint.cpp File Reference

#include "DrmPreComp.hpp"
#include "Drm.hpp"

Include dependency graph for DrmConstraint.cpp:

Generated on Tue Jan 24 16:25:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmDcfParser.cpp File Reference

AddOns/Drm/DrmDcfParser.cpp File Reference

#include "DrmPreComp.hpp"
#include "DrmDcfParser.hpp"
#include <stdio.h>

Include dependency graph for DrmDcfParser.cpp:

Generated on Tue Jan 24 16:25:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmDcfParser.hpp File Reference

AddOns/Drm/DrmDcfParser.hpp File Reference

#include <Auxiliary/BufferedData.hpp>
#include <Auxiliary/BinData.hpp>
#include <AddOns/Drm/Drm.hpp>

Include dependency graph for DrmDcfParser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | DrmDcfHeader
struct | DrmDcfHeaderData
class | DrmDcfParser

Defines

#define | Apoxi_DrmDcfParser_hpp
#define | CONTENT_DESCRIPTION_STR "Content-Description"
#define | CONTENT_NAME_STR "Content-Name"
#define | CONTENT_VENDOR_STR "Content-Vendor"
#define | DCF_SKIP_SPACE(b, l) while(*b == ' ' || *b == '\t') { b++; l--; }
#define | DCF_VALIDATE_DATA_SIZE(total_size, curr_size) if (total_size < curr_size) return FALSE;
#define | DRM_DCF_ERROR -1
#define | DRM_DCF_INVALID_BLOCK -2
#define | ENCRYPTION_METHOD_STR "Encryption-Method"
#define | ICON_URI_STR "Icon-URI"
#define | PADDING_STR "padding"
#define | RIGHT_ISSUER_STR "Rights-Issuer"

Define Documentation

#define Apoxi_DrmDcfParser_hpp

#define CONTENT_DESCRIPTION_STR "Content-Description"

#define CONTENT_NAME_STR "Content-Name"

#define CONTENT_VENDOR_STR "Content-Vendor"

#define DCF_SKIP_SPACE | ( | b,
 |  | l | ) | while(*b == ' ' || *b == '\t') { b++; l--; }

#define DCF_VALIDATE_DATA_SIZE | ( | total_size,
 |  | curr_size | ) | if (total_size < curr_size) return FALSE;

#define DRM_DCF_ERROR -1

#define DRM_DCF_INVALID_BLOCK -2

#define ENCRYPTION_METHOD_STR "Encryption-Method"

#define ICON_URI_STR "Icon-URI"

#define PADDING_STR "padding"

#define RIGHT_ISSUER_STR "Rights-Issuer"

Generated on Tue Jan 24 16:25:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmDcfParser.hpp Source File

AddOns/Drm/DrmDcfParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_DrmDcfParser_hpp)
00010 #define Apoxi_DrmDcfParser_hpp
00011
00012 //#define DRM_DCF_TEST
00013
00014 #include <Auxiliary/BufferedData.hpp>
00015 #include <Auxiliary/BinData.hpp>
00016 #include <AddOns/Drm/Drm.hpp>
00017
00018 // Dcf header name strings
00019 #define ENCRYPTION_METHOD_STR   "Encryption-Method"
00020 #define PADDING_STR             "padding"
00021 #define RIGHT_ISSUER_STR        "Rights-Issuer"
00022 #define CONTENT_NAME_STR        "Content-Name"
00023 #define CONTENT_DESCRIPTION_STR "Content-Description"
00024 #define CONTENT_VENDOR_STR      "Content-Vendor"
00025 #define ICON_URI_STR            "Icon-URI"
00026
00027 // Error code, this could be memory fail/parse error
00028 #define DRM_DCF_ERROR         -1
00029 #define DRM_DCF_INVALID_BLOCK -2
00030
00031 #define DCF_SKIP_SPACE(b, l) while(*b == ' ' || *b == '\t') { b++; l--; }
00032 #define DCF_VALIDATE_DATA_SIZE(total_size, curr_size) if (total_size < curr_size) return FALSE;
00033
00034
00036 typedef struct DrmDcfHeaderData {
00037     String m_name;
00038     String m_value;
00039 } DrmDcfHeaderData;
00040
00042 typedef struct DrmDcfHeader {
00043     Vector<DrmDcfHeaderData> m_header;
00044 } DrmDcfHeader;
00045
00048 class DrmDcfParser {
00049     public:
00050
00052         enum DrmDcfHeaderType {
00053             DrmDcfEncryptionMethod = 0,
00054             DrmDcfPaddingScheme,
00055             DrmDcfRightsIssuer,
00056             DrmDcfContentName,
00057             DrmDcfContentDescription,
00058             DrmDcfContentVendor,
00059             DrmDcfIconUriHeader,
00060             DrmDcfUnSupported
00061         };
00062
00065         DrmDcfParser(const BinData* bd);
00066         DrmDcfParser();
00067
00068         ~DrmDcfParser();
00069
00071         void SetDrmDcfMessage(const BinData* bd);
00072
00075         BOOLEAN GetVersion(UINT8& version) const;
00076
00079         BOOLEAN GetContentType(String& content_type);
00080
00083         BOOLEAN GetContentId(String& content_id);
00084
00088         BOOLEAN GetDcfHeader(enum DrmDcfHeaderType header_type, String &data);
00089
00092         BOOLEAN GetDcfHeader(const CHAR* header_name, String& header_value);
00093
00097         BOOLEAN GetDcfHeader(DrmDcfHeader &header);
00098
00101         INT GetMediaObjectLen();
00102
00105         INT GetMediaObjectOffSet();
00106
00114         INT GetBlockDataOffSet(INT block_num, INT block_sz, INT &new_block_sz);
00115
00116     private:
00117         // Points to user data
00118         const BinData* m_dcf_message;
00119
00120         // Holds entire DCF message header only,
00121         // By having this we can avoid the entire bin data message reading into an buffer
00122         UINT8* m_msg_header;
00123
00124         INT m_ct_len;
00125         INT m_cid_len;
00126         INT m_dcf_hdr_len;
00127         INT m_dcf_hdr_byte_count;
00128         INT m_data_len;
00129         INT m_data_byte_count;
00130         INT m_dcf_hdr_offset;
00131         INT m_data_offset;
00132
00133         // Helper functions
00134         BOOLEAN ParseMsgHeader();
00135         INT GetMbToInt(UINT8 *bytes, INT byte_count);
00136         INT GetHeaderData(CHAR* data, INT data_len, CHAR* h_name, DrmDcfHeaderData &h_data);
00137         BOOLEAN GetHeaderValue(CHAR* data, INT data_len, String &value, INT flag);
00138         BOOLEAN ParseMbOctets(INT start_offset, INT flag);
00139         INT ParseUserDefinedHeaders(CHAR* data, INT data_len, DrmDcfHeaderData &h_data);
00140 #ifdef DRM_DCF_TEST
00141         void DisplayParameters();
00142 #endif //DRM_DCF_TEST
00143 };
00144
00145 #endif // Apoxi_DrmDcfParser_hpp
00146
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmMessage.cpp File Reference

AddOns/Drm/DrmMessage.cpp File Reference

#include "DrmPreComp.hpp"
#include <Auxiliary/BinData.hpp>
#include <AddOns/AuxExtensions/MimeCoding.hpp>
#include <AddOns/Aes/AesCryptInterface.hpp>
#include <cctype>
#include <cstring>
#include "Drm.hpp"
#include "DrmMessage.hpp"
#include "MultipartParser.hpp"
#include "DrmRelparser.hpp"
#include "DrmDcfParser.hpp"
#include "DrmUtils.hpp"
#include "DrmWapPushMsg.hpp"

Include dependency graph for DrmMessage.cpp:

Generated on Tue Jan 24 16:25:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmMessage.hpp File Reference

AddOns/Drm/DrmMessage.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/DrmCore.hpp>
#include <AddOns/Drm/Drm.hpp>
#include <AddOns/Drm/DrmRights.hpp>
#include <AddOns/Drm/DrmRightsStore.hpp>
#include <AddOns/Drm/MultipartParser.hpp>

Include dependency graph for DrmMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmMessage

Defines

#define | Apoxi_Drm_Message_hpp

Define Documentation

#define Apoxi_Drm_Message_hpp

Generated on Tue Jan 24 16:25:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmMessage.hpp Source File

AddOns/Drm/DrmMessage.hpp

Go to the documentation of this file.
00001     /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_Drm_Message_hpp)
00010 #define Apoxi_Drm_Message_hpp
00011
00015
00016 struct DrmMediaObject;
00017
00018 #include <Kernel/Types.hpp>
00019 #include <Auxiliary/Vector.hpp>
00020 #include <Auxiliary/DateTime.hpp>
00021 #include <Auxiliary/String.hpp>
00022 #include <Auxiliary/DrmCore.hpp>
00023
00024 #include <AddOns/Drm/Drm.hpp>
00025 #include <AddOns/Drm/DrmRights.hpp>
00026 #include <AddOns/Drm/DrmRightsStore.hpp>
00027 #include <AddOns/Drm/MultipartParser.hpp>
00028
00029 #ifdef APOXI_INCLUDE_DRM_V2
00030
00032 struct DrmCryptInfo {
00033     DrmEncMethod            enc_method;
00034     DrmPaddingScheme        enc_padding;
00035     INT                     plaintext_length;
00036     UINT8*                  iv;                 // 16bytes
00037 };
00038
00039 typedef INT DrmHeaderType;
00040
00041 struct DrmMessageInfo{
00042     int                 content_offset;
00043     int                 content_size;
00044     DrmCryptInfo        crypt_info;
00045 };
00046 #endif
00047
00048
00054 class DrmMessage {
00055     public:
00056
00060         DrmMessage(const BinData *drm_message,  DrmMimeType drm_mime_type) ;
00061
00065         DrmMessage(const BinData *drm_message,  const CHAR * headers ) ;
00066
00067 #ifdef APOXI_INCLUDE_DRM_V2
00068         // ############# V2 Constructors ################
00069
00074         DrmMessage(FilePtr file_ptr, DrmMimeType drm_mime_type);
00077         // Copy constructor
00078         DrmMessage(const DrmMessage &obj) ;
00079
00080         //default Constructor
00081         DrmMessage();
00082
00083         // ############# V2 APIs added ################
00084
00088         void SetDrmHeaderInfo(DrmMessageInfo header_info);
00089
00093         DrmStatus StartMediaBlockAccess(BlockData& block_data);
00094
00102         DrmStatus GetNextMediaBlock(BYTE* content_buffer, INT& content_size);
00103
00111         DrmStatus GetPrevMediaBlock(BYTE* content_buffer, INT& content_size);
00112
00115         DrmStatus ResetMediaBlockAccess(BlockData& block_data);
00116
00123         DrmStatus   GetCryptInfo(DrmCryptInfo* drm_crypt_info);
00124
00127         String  GetContentURL() const;  // Get content URL
00128
00131         String  GetIconURL() const;     // Get Icon URI
00132
00135         String  GetInfoURL() const;             // Get Info URL
00136
00139         FilePtr GetFilePtr() const;             // Get File Ptr (NULL if it is buffer based)
00140
00144         INT GetContentOffset() const;
00148         INT GetContentSize() const;
00149
00155         DrmStatus GetDrmHeader(DrmHeaderType header_type, String& header_value);
00156
00157         // ############# End V2 additions ################
00158 #endif
00159
00161         ~DrmMessage() ;
00162
00167         static DrmMimeType GetDrmMimeType(const BinData *drm_message,const CHAR * base_mime_type) ;
00168
00173         DrmLocalId ProcessDrmMessage();
00174
00179         DrmStatus StripRelXml(UINT8** buf);
00180
00183         void SetDrmLocalId(const DrmLocalId local_id);
00184
00187         static String GetMediaMimeType(const BinData *drm_message, DrmMimeType drm_mime_type) ;
00188
00193         static String GetRawMediaMimeType(const BinData *drm_message, DrmMimeType drm_mime_type, BOOLEAN &more) ;
00194
00201         DrmStatus GetMediaObject(DrmOperation op, DrmMediaObject *media_object);
00202
00203
00213         BinData* GetMediaObject(DrmOperation op, DrmStatus& status);
00214
00223         DrmStatus  GetMediaObject(DrmOperation op, DrmMediaObject *media_object, BlockData *block_data);
00224
00236         BinData*  GetMediaObject(DrmOperation op,BlockData *block_data, DrmStatus& status);
00237
00246         DrmStatus GetRawMediaObject(BOOLEAN decrypt, DrmMediaObject *media_object);
00247
00257         DrmStatus  GetRawMediaObject(BOOLEAN decrypt, DrmMediaObject *media_object, BlockData *block_data);
00258
00269         BinData* GetRawMediaObject(BOOLEAN decrypt, DrmStatus& status);
00270
00283         BinData*  GetRawMediaObject(BOOLEAN decrypt,BlockData *block_data, DrmStatus& status);
00284
00289         static DrmLocalId ProcessRightsMessage(const BinData * drm_rights_msg);
00290
00294         String GetRightsIssuer() const;
00295
00299         DrmUid GetUid(DrmStatus &status) const;
00300
00301     private :
00302
00307         void Init(const BinData *drm_message, const CHAR * headers, DrmMimeType drm_mime_type) ;
00308
00311         DrmStatus CreateContainer(DrmLocalId localid, DrmOperation op, DrmRightsObjectContainer &ro_holder) ;
00312
00313         BOOLEAN UpdateMoMimeType(DrmLocalId local_id, String mime);
00314
00315         // Parses the Combined Delivery message
00316         DrmLocalId ParseCDMsg() ;
00317
00318         // Gets the offset in the block - base is the offset of media object
00319         BOOLEAN GetOffset(BlockData * block_data,INT buflen,INT* offset, INT* datalen);
00320
00321         // Gets the block and fills up media object structure - to be used with decoded/decrypted buf
00322         BOOLEAN GetBlockData(UINT8* buf,INT buflen,BlockData* block_data,DrmMediaObject *media_object);
00323         BOOLEAN GetBlockData(UINT8* buf,INT buflen,BlockData* block_data,BinData** media_object);
00324
00325         // Gets the block and fills up media object structure - to be used with non-decoded/plaintext data
00326         BOOLEAN GetBlockData(INT buflen,MultiPartData* b,BlockData* block_data,DrmMediaObject *media_object);
00327         BOOLEAN GetBlockData(INT buflen,MultiPartData* b,BlockData* block_data,BinData** media_object);
00328 #ifdef APOXI_INCLUDE_DRM_V2
00329         // Data members added for V2
00330         INT                 m_content_offset;
00331         INT                 m_content_size;
00332         FilePtr             m_file_ptr;
00333         DrmCryptInfo            m_drm_crypt_info;
00334
00335         // Block access
00336         BlockData           m_block_data;       // Sent from the user of the block access API
00337         INT                 m_current_block;    // To track the current block
00338 #endif
00339         DrmMimeType m_drm_mime_type ;
00340
00341         const BinData*      m_drm_message ;
00342         DrmLocalId m_local_id ;
00343         UINT8* m_decoded_buf;   // Pointer to decoded media object data - deleted when object expires
00344 };
00345
00346 #ifdef APOXI_INCLUDE_DRM_V2
00347
00350 struct DrmMultipartDcfMessage {
00351
00352     DrmDcfMessageType       m_type;             // Message type
00353     DrmMessage          m_dcf_message;      // DrmMessage
00354 };
00355
00360 class DrmMessageContainer {
00361     public:
00364         DrmMessageContainer();
00365
00369         INT GetCount() const;           // Content count
00370
00373         INT GetAllCount() const;        // Inclusive of preview and icons
00374
00378         DrmMessage& GetDrmMessage(INT i) ;
00379
00383         void AddDrmMessage(DrmMessage& drm_message,DrmDcfMessageType dcf_type);
00384
00387         INT GetInstantPreviewMessageCount() const ;
00390         DrmMessage& GetInstantPreviewMessage(INT i=0);
00393         INT GetIconMessageCount() const ;
00396         DrmMessage& GetIconMessage(INT i=0);
00397
00398         DrmStatus GetLastError();
00399
00400
00401     private:
00402         Vector<DrmMultipartDcfMessage> m_drm_multipart_msg;
00403         INT     m_count;
00404         INT     m_icon_count;
00405         INT     m_preview_count;
00406         INT     m_content_count;
00407         DrmStatus   m_last_error;
00408 };
00409
00415 class DrmMessageFactory {
00416     public:
00423         static DrmMessageContainer* GetDrmMessageContainer(const CHAR* headers, BinData* raw_drm_message, INT offset=0);
00424
00431         static DrmMessageContainer* GetDrmMessageContainer(const CHAR* headers, FilePtr file, INT offset=0);
00432 };
00433 #endif
00434
00436
00437 #endif //Apoxi_Drm_Message_hpp
00438
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmPermission.cpp File Reference

AddOns/Drm/DrmPermission.cpp File Reference

#include "DrmPreComp.hpp"
#include "Drm.hpp"

Include dependency graph for DrmPermission.cpp:

Generated on Tue Jan 24 16:25:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmPreComp.cpp File Reference

AddOns/Drm/DrmPreComp.cpp File Reference

#include "DrmPreComp.hpp"

Include dependency graph for DrmPreComp.cpp:

Generated on Tue Jan 24 16:25:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmPreComp.hpp File Reference

AddOns/Drm/DrmPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for DrmPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:25:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmPreComp.hpp Source File

AddOns/Drm/DrmPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Auxiliary/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelparser.cpp File Reference

AddOns/Drm/DrmRelparser.cpp File Reference

#include "DrmPreComp.hpp"
#include "DrmRelparser.hpp"
#include "DrmRelXml.hpp"
#include "DrmRelWbxml.hpp"

Include dependency graph for DrmRelparser.cpp:

Generated on Tue Jan 24 16:25:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelparser.hpp File Reference

AddOns/Drm/DrmRelparser.hpp File Reference

#include <AddOns/Drm/Drm.hpp>

Include dependency graph for DrmRelparser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmRelParser

Defines

#define | Apoxi_DrmRelParser_hpp

Enumerations

enum | DrmXmlFormat { DrmRightsXml, DrmRightsWbxml, DrmRightsNone }
XML Data Type. More...

Define Documentation

#define Apoxi_DrmRelParser_hpp

Generated on Tue Jan 24 16:25:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelparser.hpp Source File

AddOns/Drm/DrmRelparser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DrmRelParser_hpp)
00010 #define Apoxi_DrmRelParser_hpp
00011
00015
00016 #include <AddOns/Drm/Drm.hpp>
00017
00019 enum DrmXmlFormat {
00020     // Xml REL Data
00021     DrmRightsXml,
00022     // Wbxml REL Data
00023     DrmRightsWbxml,
00024     // None
00025     DrmRightsNone
00026 };
00027
00028 // Basic Drm Rel parser
00029 class DrmRelParser {
00030
00031     friend class XmlParserRel;
00032     friend class WbxmlParserRel;
00033
00034     public :
00035
00036         enum DrmVersion {
00037             // Drm version 1.0
00038             Drm_v_1_0 ,
00039             Drm_v_None
00040         };
00041
00042         DrmRelParser(DrmRightsObject& ro, const UINT8* rights_xml_buffer,DrmXmlFormat xml_format) : m_ro(ro) {
00043             m_xml_format = xml_format;
00044             m_rights_xml_data = rights_xml_buffer;
00045          }
00046
00047         DrmRelParser(DrmRightsObject& ro, const BinData* wbxml_data,DrmXmlFormat wbxml_format) : m_ro(ro) {
00048             m_xml_format = wbxml_format;
00049             m_wbxml_data = wbxml_data;
00050          }
00051
00055         INT32 Parse();
00056
00059         DrmVersion GetDrmVersion();
00060
00063         void SetDrmVersion(String& version){
00064             if(version.compare("1.0"))
00065                 m_drm_version = Drm_v_1_0;
00066             else
00067                 m_drm_version = Drm_v_None; // Should generate error and return according to spec
00068         }
00069
00070     protected :
00074         INT32 ParseXmlRel();
00075         DrmStatus ParseWbxmlRel(); // Phase 3
00076         DrmRightsObject& GetRightsObject()
00077         {
00078             return m_ro;
00079         }
00080
00081
00082     private :
00083         // Reference of rights object in container
00084         DrmRightsObject& m_ro;
00085
00088         const UINT8* m_rights_xml_data;
00089
00090         // BinData interface for WBXML REL data.
00091         const BinData* m_wbxml_data;
00092
00094         DrmXmlFormat m_xml_format;  // needs to be stored because parse can be called at any time, right now only XML and WBXML
00095                                      // change to UINT16 etc later when more formats are available
00096
00097         DrmVersion m_drm_version;   // DrmVersion 1-v1.0, 2-v2.0 ...
00098 };// DrmRelParser
00099
00101 #endif
00102
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelWbxml.cpp File Reference

AddOns/Drm/DrmRelWbxml.cpp File Reference

#include "DrmPreComp.hpp"
#include "DrmRelWbxml.hpp"
#include "DrmRelXml.hpp"

Include dependency graph for DrmRelWbxml.cpp:

Generated on Tue Jan 24 16:25:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelWbxml.hpp File Reference

AddOns/Drm/DrmRelWbxml.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/BinarySearch.hpp>
#include <AddOns/Drm/Drm.hpp>
#include <AddOns/Drm/DrmRelparser.hpp>
#include <AddOns/Wbxml/WbxmlHandlerBase.h>
#include <AddOns/Wbxml/HandlerBase.h>

Include dependency graph for DrmRelWbxml.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WbxmlParserRel
class | WbxmlRelHandler

Defines

#define | Apoxi_DrmRelWbxml_hpp

Define Documentation

#define Apoxi_DrmRelWbxml_hpp

Generated on Tue Jan 24 16:26:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelWbxml.hpp Source File

AddOns/Drm/DrmRelWbxml.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DrmRelWbxml_hpp)
00010 #define Apoxi_DrmRelWbxml_hpp
00011
00012 #include <Auxiliary/Linkable.hpp>
00013 #include <Auxiliary/LinkedList.hpp>
00014 #include <Auxiliary/String.hpp>
00015 #include <Auxiliary/BinarySearch.hpp>
00016
00017 #include <AddOns/Drm/Drm.hpp>
00018 #include <AddOns/Drm/DrmRelparser.hpp>
00019 #include <AddOns/Wbxml/WbxmlHandlerBase.h>
00020 #include <AddOns/Wbxml/HandlerBase.h>
00021
00022 // Wbxml Parser
00023 class WbxmlRelHandler : public WBXMLHandlerBase {
00024     public:
00025
00026         virtual void resolveTagName(Token token, CHAR* tagName, size_t tagNameLength) {
00027         }
00028
00029         virtual void resolveAttributeName(Token token,
00030             CHAR* attributeName, size_t attributeNameLength,
00031             CHAR* attributeValuePrefix, size_t attributeValuePrefixLength) {
00032         }
00033
00034         virtual void resolveAttributeValue(Token token,
00035             CHAR* attributeValue, size_t attributeValueLength) {
00036         }
00037 };
00038
00039
00040
00041 class WbxmlParserRel : public HandlerBase {
00042
00043     public:
00044
00045         // Wbxml token values as defined by specification DRMREL v1.0
00046         enum RelWbxmlTag_v1_0 {
00047             RelWbxmlRights = 0x05,
00048             RelWbxmlContext,
00049             RelWbxmlVersion,
00050             RelWbxmlUid,
00051             RelWbxmlAgreement,
00052             RelWbxmlAsset,
00053             RelWbxmlKeyInfo,
00054             RelWbxmlKeyValue,
00055             RelWbxmlPermission,
00056             RelWbxmlPlay,
00057             RelWbxmlDisplay,
00058             RelWbxmlExecute,
00059             RelWbxmlPrint,
00060             RelWbxmlConstraint,
00061             RelWbxmlCount,
00062             RelWbxmlDatetime,
00063             RelWbxmlStart,
00064             RelWbxmlEnd,
00065             RelWbxmlInterval,
00066             RelWbxmlNone
00067         };
00068
00069         // Wbxml attribute name token values as defined by specification DRMREL v1.0
00070         enum RelWbxmlAttName_v1_0 {
00071             RelWbxmlAttLang = 0x05,
00072             RelWbxmlAttDd,
00073             RelWbxmlAttSig,
00074             RelWbxmlAttNone
00075         };
00076
00077         // Wbxml attribute token values as defined by specification DRMREL v1.0
00078         enum RelWbxmlAttValue_v1_0 {
00079             RelWbxmlAttLangVal = 0x05,
00080             RelWbxmlAttDdVal,
00081             RelWbxmlAttSigVal,
00082             RelWbxmlAttValNone
00083         };
00084
00085         WbxmlParserRel(DrmRelParser& rh) : m_ro(rh.m_ro)
00086         {
00087             m_rel_parser = &rh;
00088             m_perm = 0;
00089             m_constraint = 0;
00090             m_permission_depth = 0;
00091             m_constraint_depth = 0;
00092             m_data_depth = 0;
00093             m_unknowntag = 0;
00094             m_unknowntag_depth = 0;
00095             m_err_val = FALSE;
00096         }
00097
00098         /* Cleans up on return */
00099         ~WbxmlParserRel();
00100
00101         void AddDefaultConstraints(DrmPermission * perm);
00102         void AddDefaultPermissions();
00103         DrmStatus GetParseStatus();
00104
00105         /* These are callbacks from open source code - Do not follow APOXI coding guidelines */
00106         virtual void setDocumentLocator(const Locator &locator);
00107         virtual void startDocument();
00108         virtual void endDocument();
00109         virtual void startElement(const SAXString& name, const AttributeList &atts,byte& tag, size_t depth);
00110         virtual void endElement(const SAXString& name,byte& tag,size_t depth);
00111         virtual void characters(const SAXString& chars,byte& tag);
00112         virtual void ignorableWhitespace(const SAXChar* ch, size_t length);
00113         virtual void processingInstruction(const SAXString& target, const SAXString& data);
00114         virtual void warning(const SAXParseException& e);
00115         virtual void error(const SAXParseException& e);
00116         virtual void fatalError(const SAXParseException& e);
00117
00118     private:
00119         DrmRightsObject& m_ro;
00120         DrmRelParser * m_rel_parser;
00121         BOOLEAN m_err_val ;             // Error value
00122
00123         DrmPermission*  m_perm;         // Pointer to permission
00124         DrmConstraint*  m_constraint;   // Pointer to constraint
00125
00126         INT m_permission_depth;         // Depth of permission tag if any - default 0
00127         INT m_constraint_depth;         // Depth of constraint tag if any - default 0
00128         INT m_data_depth;
00129         INT m_unknowntag;
00130         byte m_unknowntag_val;
00131         INT m_unknowntag_depth;// Depth of count,datetime etc tag if any - default 0
00132
00133         LinkedList<DrmConstraint> m_constraint_list;
00134         LinkedList<DrmPermission> m_perm_list;
00135 };
00136
00137 #endif //Apoxi_DrmRelWbxml_hpp
00138
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelXml.cpp File Reference

AddOns/Drm/DrmRelXml.cpp File Reference

#include "DrmPreComp.hpp"
#include <ctype.h>
#include <cctype>
#include <cstring>
#include "DrmRelXml.hpp"
#include "DrmUtils.hpp"

Include dependency graph for DrmRelXml.cpp:

Defines

#define | DRM_DAY_SECONDS 86400
#define | DRM_HOURS_SECONDS 3600
#define | DRM_MINUTES_SECONDS 60
#define | DRM_MONTH_SECONDS 2678400
#define | DRM_YEAR_SECONDS 31536000

Variables

CHAR * | RELTags_v1_0 []

Define Documentation

#define DRM_DAY_SECONDS 86400

#define DRM_HOURS_SECONDS 3600

#define DRM_MINUTES_SECONDS 60

#define DRM_MONTH_SECONDS 2678400

#define DRM_YEAR_SECONDS 31536000

Variable Documentation

CHAR* RELTags_v1_0[]

Initial value:

 {
    "ds:KeyInfo",
    "ds:KeyValue",
    "o-dd:count",
    "o-dd:datetime",
    "o-dd:display",
    "o-dd:end",
    "o-dd:execute",
    "o-dd:interval",
    "o-dd:play",
    "o-dd:print",
    "o-dd:start",
    "o-dd:uid",
    "o-dd:version",
    "o-ex:agreement",
    "o-ex:asset",
    "o-ex:constraint",
    "o-ex:context",
    "o-ex:permission",
    "o-ex:rights",
    "None"
}

Generated on Tue Jan 24 16:26:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelXml.hpp File Reference

AddOns/Drm/DrmRelXml.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/BinarySearch.hpp>
#include <AddOns/Drm/Drm.hpp>
#include <AddOns/Drm/DrmRelparser.hpp>
#include <AddOns/XmlParser/xml_parser.hpp>

Include dependency graph for DrmRelXml.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | XmlParserRel

Defines

#define | Apoxi_DrmXmlRelParser_hpp

Enumerations

enum | correction_type { ct_none, ct_negative, ct_positive }
enum date_type {
dt_none, gyear, gmonth, gday,
thour, tmin, tsec, tdiffhour,
tdiffmin
}

Define Documentation

#define Apoxi_DrmXmlRelParser_hpp

Generated on Tue Jan 24 16:26:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRelXml.hpp Source File

AddOns/Drm/DrmRelXml.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DrmXmlRelParser_hpp)
00010 #define Apoxi_DrmXmlRelParser_hpp
00011
00015
00016 #include <Auxiliary/Linkable.hpp>
00017 #include <Auxiliary/LinkedList.hpp>
00018 #include <Auxiliary/String.hpp>
00019 #include <Auxiliary/BinarySearch.hpp>
00020
00021 #include <AddOns/Drm/Drm.hpp>
00022 #include <AddOns/Drm/DrmRelparser.hpp>
00023 #include <AddOns/XmlParser/xml_parser.hpp>
00024
00025
00026 typedef enum date_type {
00027             dt_none,
00028             gyear,
00029             gmonth,
00030             gday,
00031             thour,
00032             tmin,
00033             tsec,
00034             tdiffhour,
00035             tdiffmin
00036         }date_type;
00037 typedef enum correction_type {
00038             ct_none,
00039             ct_negative,
00040             ct_positive
00041 }correction_type;
00042
00043
00044 // XML parser
00045 class XmlParserRel : public XMLParser {
00046     public :
00047         // For readability of code
00048         enum RelTag_v1_0 {
00049             RelTagKeyInfo = 0 ,
00050             RelTagKeyValue,
00051             RelTagCount,
00052             RelTagDatetime,
00053             RelTagDisplay,
00054             RelTagEnd,
00055             RelTagExecute,
00056             RelTagInterval,
00057             RelTagPlay,
00058             RelTagPrint,
00059             RelTagStart,
00060             RelTagUid,
00061             RelTagVersion,
00062             RelTagAgreement,
00063             RelTagAsset,
00064             RelTagConstraint,
00065             RelTagContext,
00066             RelTagPermission,
00067             RelTagRights,
00068             RelTagNone
00069         };
00070
00071         XmlParserRel(CHAR *s,DrmRelParser& rh) : XMLParser(s), m_ro (rh.m_ro), m_rel_parser(&rh)
00072         {
00073             m_perm = 0;
00074             m_constraint = 0;
00075             m_permission_depth = 0;
00076             m_constraint_depth = 0;
00077             m_data_depth = 0;
00078             m_unknowntag = 0;
00079             m_unknowntag_depth = 0;
00080         }
00081
00082         s32 Parse() { return XMLParser::Parse();}
00083
00084         void AddDefaultConstraints(DrmPermission * perm);
00085         void AddDefaultPermissions();
00086         static UINT32 ParseDateString(String& date_data, INT &parse_err);
00087         static UINT32 ParseInterval(String& validity_data, INT &parse_err);
00088
00089         virtual s32 XML_Error_Handler(INT ErrorCode, INT ErrorLine);
00090         virtual s32 XML_Start_Handler(void *UserData);
00091         virtual s32 XML_End_Handler(void *UserData);
00092         virtual s32 XML_StartElement_Handler(void *UserData, CHAR *uri, CHAR *localname, CHAR *qName, LPVECTOR atts);
00093         virtual s32 XML_EndElement_Handler(void *UserData, CHAR *uri, CHAR *localname, CHAR *qName);
00094         virtual s32 XML_Characters_Handler(void *UserData, CHAR *Chars, s32 cbsize);
00095         virtual s32 XML_PI_Handler(void *UserData, CHAR *Target, CHAR *Data);
00096         virtual s32 XML_StartCData_Handler(void *UserData);
00097         virtual s32 XML_EndCData_Handler(void *UserData);
00098
00099         /* Cleans up on return */
00100     virtual ~XmlParserRel();
00101
00102     private :
00103         DrmRightsObject& m_ro;
00104         DrmRelParser * m_rel_parser;
00105
00106         INT m_tag_index;                    // Tag index in tag name strings - needs to be persisted in object
00107         DrmPermission*  m_perm;         // Pointer to permission
00108         DrmConstraint*  m_constraint;       // Pointer to constraint
00109         INT m_permission_depth;         // Depth of permission tag if any - default 0
00110         INT m_constraint_depth;         // Depth of constraint tag if any - default 0
00111         INT m_data_depth;                   // Depth of count,datetime etc tag if any - default 0
00112         INT m_unknowntag;
00113         String m_unknowntag_val;
00114         INT m_unknowntag_depth;
00115
00116         LinkedList<DrmConstraint> m_constraint_list;
00117         LinkedList<DrmPermission> m_perm_list;
00118         static CHAR* trimSpaces (const CHAR *srcstr);
00119         static CHAR* parseDate(CHAR *srcstr, INT &year, INT &month, INT &day, date_type &count, INT &datetime_err);
00120         static INT parseTime(CHAR *srcstr, INT &hour, INT &min, INT &sec, correction_type  &corr_sign,INT &diffhour, INT &diffmin, INT &utc_time, date_type &count);
00121
00122 };
00123
00124 #endif //Apoxi_DrmXmlRelParser_hpp
00125
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRights.hpp File Reference

AddOns/Drm/DrmRights.hpp File Reference

#include <Auxiliary/DrmCore.hpp>

Include dependency graph for DrmRights.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmConstraint
union | DrmConstraint::Data
Union to store constraint data and current state.
class | DrmPermission
class | DrmRightsObject

Defines

#define | Apoxi_DrmRights_hpp
#define | DRM_RIGHTS_OP_NOT_FOUND 3
#define | DRM_RIGHTS_UPDATE_REQUIRED 2

Define Documentation

#define Apoxi_DrmRights_hpp

Generated on Tue Jan 24 16:26:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRights.hpp Source File

AddOns/Drm/DrmRights.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_DrmRights_hpp)
00010 #define Apoxi_DrmRights_hpp
00011
00015
00016 #include <Auxiliary/DrmCore.hpp>
00017
00018 #define DRM_RIGHTS_UPDATE_REQUIRED  2
00019 #define DRM_RIGHTS_OP_NOT_FOUND     3
00020
00023 class DrmConstraint : public Linkable<DrmConstraint> {
00024     public:
00026         enum Type {
00028             None,
00030             TypeCount,
00032             TypeDateTime,
00034             TypeInterval
00035         };
00036
00038         DrmConstraint();
00040         DrmConstraint(Type type, INT32 max_count);
00042         DrmConstraint(Type type, UINT32 sec_start, UINT32 sec_end);
00044         DrmConstraint(Type type, UINT32 sec_interval);
00046         virtual ~DrmConstraint();
00047
00049         Type GetType() const;
00050
00052         void GetCount(INT32 *consume_count, INT32 *max_count) const;
00053
00055         void GetCount(INT32 *consume_count, INT32 *max_count, INT32 *prev_count) const;
00056
00058         void GetDateTime(UINT32 *sec_start, UINT32 *sec_end) const;
00059
00061         void GetIntervall(UINT32 *sec_interval, UINT32 *first_consume) const ;
00062
00064         void GetIntervall(UINT32 *sec_interval, UINT32 *first_consume, UINT32 *prev_consume) const ;
00065
00067         void SetType(Type type);
00068
00071         void SetCount(INT32 max_count);
00072
00075         void SetConsumedCount(INT32 consume_count);
00076
00077         void SetPrevConsumedCount(INT32 prev_consume_count);
00078
00084         void SetStartDate(UINT32 sec_start);
00085         void SetEndDate(UINT32 sec_end);
00086
00089         void SetInterval(UINT32 sec_interval);
00090
00091         //
00092         void SetFirstConsumedInterval(UINT32 first_consume_interval);
00093
00094         //
00095         void SetPrevFirstConsumedInterval(UINT32 prev_consume_interval);
00096
00099         BOOLEAN DoesApply() const;
00100
00105         INT OnContentConsumedStart();
00106
00111         INT OnContentConsumedEnd();
00112
00117         INT OnRollback();
00118
00119     private:
00121         union Data {
00123             struct {
00125                 INT32 m_consume_count;
00127                 INT32 m_max_count;
00128                 INT32 m_prev_consume_count;
00129             } m_count_constraint;
00130
00131             struct {
00133                 UINT32 m_sec_start;
00135                 UINT32 m_sec_end;
00136                 // place holder for nothing
00137                 UINT32 m_prev_placeholder;
00138             } m_datetime_constraint;
00139
00140             struct {
00142                 UINT32 m_sec_intervall;
00144                 UINT32 m_first_consume;
00145                 UINT32 m_prev_first_consume;
00146             } m_intervall_constraint;
00147         };
00148
00149         Type m_type;
00150         Data m_data;
00151
00152         INT OnContentConsumed();
00153 };
00154
00157 class DrmPermission : public Linkable<DrmPermission> {
00158     public:
00159
00160         DrmPermission();
00161         virtual ~DrmPermission();
00162
00164         DrmOperation GetOpType() const;
00165
00167         INT GetConstraintsCount() const;
00168
00170         const DrmConstraint& GetConstraint(INT index) const;
00171
00174         BOOLEAN SetOpType(DrmOperation op);
00175
00180         BOOLEAN AddConstraint(const DrmConstraint &constraint);
00181
00183         BOOLEAN IsAllowed() const;
00184
00189         INT OnContentConsumedStart();
00190
00195         INT OnContentConsumedEnd();
00196
00201         INT OnRollback();
00202
00203         BOOLEAN GetDateConstraint(UINT32 &start_date, UINT32 &end_date);
00204         BOOLEAN GetIntervalConstraint(UINT32 &start_consume, UINT32 &max_consume);
00205         BOOLEAN GetCountConstraint(INT32 &consume_count, INT32 &max_count);
00206
00208         void SetConstraintDefaultValue(DrmConstraintDefValues def_constraints) { m_def_constraints = def_constraints; }
00209
00212         DrmConstraintDefValues GetConstraintDefaultValue() const { return m_def_constraints;}
00213
00214     private:
00215         DrmOperation m_op;
00216         DrmConstraintDefValues m_def_constraints;
00217         //BOOLEAN m_no_constraints;
00218         // Collection of constraints on a permission
00219         Vector<DrmConstraint> m_constraint;
00220 };
00221
00227 class DrmRightsObject {
00228     public:
00229
00230         DrmRightsObject();
00231         ~DrmRightsObject();
00232
00234         DrmLocalId GetLocalId() const;
00235
00237         DrmMimeType GetDrmMimeType() const;
00238
00239         // Return the media object MIME type
00240         MimeType GetMoMimeType() const;
00241
00243         const DrmUid& GetUid() const;
00244
00246         BOOLEAN GetKey(UINT8* key) const;
00247
00249         INT GetPermissionsCount() const;
00250
00252         DrmPermission& GetPermission(INT index);
00253
00255         DrmPermission* GetPermission(DrmOperation op) ;
00256
00258         void SetLocalId(DrmLocalId local_id);
00259
00261         void SetMimeType(DrmMimeType mime_type);
00262
00264         void SetMoMimeType(MimeType mime_type);
00265
00268         void SetUid(const DrmUid &uid);
00269
00272         void SetKey(const DrmKey &key);
00273
00275         UINT8 GetRefCount()
00276         {
00277             return m_ref_count ;
00278         }
00279
00281         void SetRefCount(UINT8 count)
00282         {
00283             m_ref_count = count ;
00284         }
00285
00292         BOOLEAN AddPermission(const DrmPermission &perm);
00293
00295         BOOLEAN IsAllowed(DrmOperation op) const;
00296
00301         INT OnContentConsumedStart(DrmOperation op);
00302
00307         INT OnContentConsumedEnd(DrmOperation op);
00308
00313         INT OnRollback(DrmOperation op);
00314
00315         INT IsConstraintAvailable(DrmOperation op);
00316         BOOLEAN GetDateConstraint(DrmOperation op, UINT32 &start_date, UINT32 &endDate);
00317         BOOLEAN GetIntervalConstraint(DrmOperation op, UINT32 &start_consume, UINT32 &max_consume);
00318         BOOLEAN GetCountConstraint(DrmOperation op, INT32 &consume_count, INT32 &max_count);
00319
00320     private:
00321         DrmLocalId m_local_id;
00322         DrmMimeType m_mime_type;
00323         MimeType m_mo_mime_type;
00324         DrmUid m_uid;
00325         DrmKey m_key;
00326         UINT8 m_ref_count;
00327
00328         // Collection of permissions for this rights object
00329         Vector<DrmPermission> m_perm;
00330 };
00331
00333 #endif // Apoxi_DrmRights_hpp
00334
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRightsContainer.cpp File Reference

AddOns/Drm/DrmRightsContainer.cpp File Reference

#include "DrmPreComp.hpp"
#include "Drm.hpp"

Include dependency graph for DrmRightsContainer.cpp:

Generated on Tue Jan 24 16:26:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRightsObject.cpp File Reference

AddOns/Drm/DrmRightsObject.cpp File Reference

#include "DrmPreComp.hpp"
#include "Drm.hpp"

Include dependency graph for DrmRightsObject.cpp:

Generated on Tue Jan 24 16:26:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRightsStore.cpp File Reference

AddOns/Drm/DrmRightsStore.cpp File Reference

#include "DrmPreComp.hpp"
#include <Afs/Ffs/FlsFile.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <stdio.h>
#include "Drm.hpp"
#include "DrmSecurity.hpp"

Include dependency graph for DrmRightsStore.cpp:

Generated on Tue Jan 24 16:26:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRightsStore.hpp File Reference

AddOns/Drm/DrmRightsStore.hpp File Reference

#include <Auxiliary/DrmCore.hpp>
#include <AddOns/Drm/DrmRights.hpp>
#include <AddOns/Drm/DrmSubsystem.hpp>

Include dependency graph for DrmRightsStore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | DrmRightsMapTableEntry
class | DrmRightsObjectContainer
class | DrmRightsObjectFile
class | DrmRightsObjectStore
class | DrmROStoreSingleton

Defines

#define | Apoxi_DrmRightsStore_hpp
#define | DRM_FL_LOCAL_ID APOXI_DRM_RIGHTS_OBJECT_MAX+1
#define | DRM_RO_FILE_PREFIX "adrm"

Typedefs

typedef DrmROStoreSingleton | DrmROStore

Define Documentation

#define Apoxi_DrmRightsStore_hpp

Generated on Tue Jan 24 16:26:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmRightsStore.hpp Source File

AddOns/Drm/DrmRightsStore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DrmRightsStore_hpp)
00011 #define Apoxi_DrmRightsStore_hpp
00012
00016
00017 #include <Auxiliary/DrmCore.hpp>
00018 #include <AddOns/Drm/DrmRights.hpp>
00019 #include <AddOns/Drm/DrmSubsystem.hpp>
00020
00021 //************************* DEBUG
00022 //#define       DRM_FFS_BYPASS
00023
00024 #define     DRM_FL_LOCAL_ID         APOXI_DRM_RIGHTS_OBJECT_MAX+1
00025 #define     DRM_RO_FILE_PREFIX      "adrm"
00026
00027 class FlsFile;
00028
00032 class DrmRightsObjectContainer {
00033     public:
00035         INT GetCount() const;
00036
00040         DrmRightsObject& GetRightsObject(INT i);
00041
00045         void AddRightsObject(const DrmRightsObject& rights_obj);
00046
00049         BOOLEAN IsAllowed(DrmOperation op);
00050
00055         BOOLEAN OnContentConsumedStart(DrmOperation op);
00056
00061         BOOLEAN OnContentConsumedEnd(DrmOperation op);
00062
00067         BOOLEAN OnRollback(DrmOperation op);
00068
00074         BOOLEAN IsDrmOpValid(DrmOperation op, MimeType mo_type) const;
00075
00076     private:
00077         Vector<DrmRightsObject> m_rights;
00078
00079         static DrmSubsystem drm_subsys;
00080 };
00081
00086 class DrmRightsObjectFile {
00087     public:
00094         static BOOLEAN Create(const CHAR* ro_file_path, DrmRightsObject& rights_obj);
00095
00103         static BOOLEAN Update(const CHAR* ro_file_path, DrmRightsObject& rights_obj);
00104
00110         static BOOLEAN GetRightsObject(const CHAR* ro_file_path, DrmRightsObject& rights_obj);
00111
00114         static BOOLEAN Delete(const CHAR* ro_file_path);
00115
00119         static BOOLEAN WriteRightsObject(FlsFile& fp, DrmRightsObject& rights_obj);
00120
00121         static UINT32 ReadROHeaderInfo(FlsFile& ro_file, DrmLocalId& id, DrmUid& uid);
00122
00126         static BOOLEAN ReadRightsObject(FlsFile& fp, DrmRightsObject& rights_obj);
00127
00128 #ifdef DRM_FFS_BYPASS
00129
00131         static BOOLEAN WriteRightsObject_debug(FILE* fp, DrmRightsObject& rights_obj);
00132         static BOOLEAN ReadRightsObject_debug(FILE* fp, DrmRightsObject& rights_obj);
00133 #endif
00134     private:
00135         static INT DrmGetRightsObjectSize(DrmRightsObject &rights_obj);
00136 };
00137
00143 struct DrmRightsMapTableEntry {
00144     BOOLEAN         m_is_valid;         // Validity flag
00145     DrmLocalId      m_local_id;         // Local ID
00146     String          m_uid;              // UID : Note : We could store a hash instead
00147     Vector<String>  m_ro_file_paths;    // Rights Object File Path(s)
00148 };
00149
00155 class DrmRightsObjectStore {
00156     public:
00157         DrmRightsObjectStore();
00161         void InitRightsObjectMapTable( void );
00162
00169         DrmLocalId GetNextLocalId(void);
00170
00174         BOOLEAN IsLocalIdValid(DrmLocalId local_id);
00175
00179         DrmLocalId MapUidToLocalId(const DrmUid &uid);
00180
00184         DrmUid MapLocalIdToUid(DrmLocalId id);
00185
00190         BOOLEAN GetDrmRights(const DrmLocalId &id, DrmRightsObjectContainer& ro_container);
00191
00195         DrmLocalId AddRightsObject(DrmRightsObject &ro);
00196
00200         BOOLEAN UpdateRightsObject(DrmRightsObject &ro, INT r_index);
00201
00205         BOOLEAN DeleteRightsObject(DrmLocalId id);
00206
00207 #ifdef DRM_RO_DEBUG
00208         void DebugDump(String& debug_info);
00209 #endif
00210
00211     private:
00212         BOOLEAN FillMapFromFile(const CHAR* ro_file_path);
00213
00223         BOOLEAN GenerateFileName(DrmLocalId id, String& file_name);
00224
00225         // Rights object table map -- for easy access of information
00226         // Element 0 corresponds to invalid rights
00227         // Element APOXI_DRM_RIGHTS_OBJECT_MAX+1 corresponds to FL
00228         // Hence we need to declare the array as APOXI_DRM_RIGHTS_OBJECT_MAX+2
00229         DrmRightsMapTableEntry  m_ro_map_table[APOXI_DRM_RIGHTS_OBJECT_MAX+2];
00230         static const UINT       m_max_map;
00231         BOOLEAN                 bInitDone;
00232 };
00233
00238 class DrmROStoreSingleton
00239 {
00240 public:
00244     static DrmRightsObjectStore* Instance()
00245     {
00246         if (m_instance == NULL) m_instance = new DrmRightsObjectStore;
00247
00248         ASSERT(m_instance != NULL);
00249
00250         return m_instance;
00251     }
00252
00256     static void DestroyInstance()
00257     {
00258         delete m_instance;
00259         m_instance = NULL;
00260     }
00261
00262 protected:
00265     DrmROStoreSingleton()
00266     {
00267     }
00268
00269     virtual ~DrmROStoreSingleton()
00270     {
00271     }
00272
00273 private:
00274     // Copy constructor.
00275     DrmROStoreSingleton(const DrmROStoreSingleton& source)
00276     {
00277     }
00278
00279     static DrmRightsObjectStore* m_instance;
00280 };
00281
00282 typedef DrmROStoreSingleton DrmROStore;
00283
00285
00286 #endif // Apoxi_DrmRightsStore_hpp
00287
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmSecurity.cpp File Reference

AddOns/Drm/DrmSecurity.cpp File Reference

#include "DrmPreComp.hpp"
#include "DrmSecurity.hpp"
#include <stack/stack.h>

Include dependency graph for DrmSecurity.cpp:

Generated on Tue Jan 24 16:26:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmSecurity.hpp File Reference

AddOns/Drm/DrmSecurity.hpp File Reference

#include <Adc/DataHandler.hpp>
#include <Adc/SimAccessor.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for DrmSecurity.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmSecurity

Defines

#define | Apoxi_DrmSecurity_hpp
#define | DRM_SECURITY_KEY_LEN 10
#define | DRM_SECURITY_MAGIC_NUMBER 7

Define Documentation

#define Apoxi_DrmSecurity_hpp

#define DRM_SECURITY_KEY_LEN 10

#define DRM_SECURITY_MAGIC_NUMBER 7

Generated on Tue Jan 24 16:26:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmSecurity.hpp Source File

AddOns/Drm/DrmSecurity.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_DrmSecurity_hpp)
00010 #define Apoxi_DrmSecurity_hpp
00011
00012 #include <Adc/DataHandler.hpp>
00013 #include <Adc/SimAccessor.hpp>
00014 #include <Apc/SignalTypes.hpp>
00015
00016 //Enable this for testing on host
00017 //#define DRM_SECURITY_TEST
00018
00019 //Enable this for HOST only
00020 //#define DRM_SECURITY_HOST_TESTING
00021
00022 //Enable this when NO encryption is required
00023 //#define DRM_SEURITY_NO_ENCRYPTION
00024
00025 #define DRM_SECURITY_KEY_LEN 10
00026 #define DRM_SECURITY_MAGIC_NUMBER 7
00027
00029 class DrmSecurity {
00030     public:
00031
00032         DrmSecurity() { };
00033         ~DrmSecurity() { };
00034
00039         static BOOLEAN DrmCrypt(UINT8 *in_buf, INT buf_len);
00040
00043         static void InitializeKey();
00044
00045     private:
00046         static UINT8 key[DRM_SECURITY_KEY_LEN];
00047         static BOOLEAN drm_key_init;
00048 #ifdef DRM_SECURITY_TEST
00049         static void DumpKey();
00050 #endif //DRM_SECURITY_TEST
00051 };
00052
00053 #endif //Apoxi_DrmSecurity_hpp
00054
00055
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmSubsystem.cpp File Reference

AddOns/Drm/DrmSubsystem.cpp File Reference

#include "DrmPreComp.hpp"
#include "Drm.hpp"
#include "DrmSubsystem.hpp"

Include dependency graph for DrmSubsystem.cpp:

Generated on Tue Jan 24 16:26:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmSubsystem.hpp File Reference

AddOns/Drm/DrmSubsystem.hpp File Reference

#include <Kernel/SubSystem.hpp>

Include dependency graph for DrmSubsystem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmSubsystem

Defines

#define | Apoxi_DrmSubsystem_hpp

Define Documentation

#define Apoxi_DrmSubsystem_hpp

Generated on Tue Jan 24 16:26:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmSubsystem.hpp Source File

AddOns/Drm/DrmSubsystem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_DrmSubsystem_hpp)
00009 #define Apoxi_DrmSubsystem_hpp
00010
00013
00014 #include <Kernel/SubSystem.hpp>
00015
00016 /*  ========================================================================
00017     DrmSubsystem
00018     ======================================================================== */
00020 class DrmSubsystem : public SubSystem {
00021
00022     public:
00023         DrmSubsystem();
00024
00025         static DrmSubsystem* GetInstance() { return m_instance; }
00026
00027         virtual const WCHAR* GetName() const { return L"APOXI DrmSubsystem"; }
00028
00030         virtual BootSequenceState InvokeAt() const { return (SubSystemManager::c_run_level_3); }
00031
00033         virtual UINT8 GetPriority() const { return (100); }
00034
00036         virtual void OnPowerUp();
00037
00039         virtual void OnPowerDown();
00040
00041     private:
00042
00043         static DrmSubsystem     *m_instance;
00044 };
00045
00047 #endif // Apoxi_DrmSubsystem_hpp
00048
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmTemplates.cpp File Reference

AddOns/Drm/DrmTemplates.cpp File Reference

#include <AddOns/Drm/DrmPreComp.hpp>
#include <AddOns/Drm/DrmDcfParser.hpp>
#include <AddOns/Drm/DrmRights.hpp>
#include <AddOns/Drm/MultipartParser.hpp>
#include <AddOns/Drm/DrmRightsStore.hpp>

Include dependency graph for DrmTemplates.cpp:

Generated on Tue Jan 24 16:26:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmUtils.cpp File Reference

AddOns/Drm/DrmUtils.cpp File Reference

#include "DrmPreComp.hpp"
#include <AddOns/AuxExtensions/MimeCoding.hpp>
#include "DrmUtils.hpp"

Include dependency graph for DrmUtils.cpp:

Generated on Tue Jan 24 16:26:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmUtils.hpp File Reference

AddOns/Drm/DrmUtils.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmUtils

Defines

#define | Apoxi_DrmUtils_hpp

Define Documentation

#define Apoxi_DrmUtils_hpp

Generated on Tue Jan 24 16:26:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmUtils.hpp Source File

AddOns/Drm/DrmUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_DrmUtils_hpp)
00009 #define Apoxi_DrmUtils_hpp
00010
00014
00019 class DrmUtils{
00020     public :
00027         static BOOLEAN DecodeBase64Data(UINT8* base64data, INT base64len, UINT8** decoded_buf, INT* buflen);
00028 } ;
00029
00030 #endif // Apoxi_DrmUtils_hpp
00031
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmWapPushMsg.cpp File Reference

AddOns/Drm/DrmWapPushMsg.cpp File Reference

#include "DrmPreComp.hpp"
#include "Auxiliary/DrmCore.hpp"
#include "Auxiliary/DrmAsset.hpp"
#include "AddOns/Drm/DrmMessage.hpp"
#include "DrmWapPushMsg.hpp"

Include dependency graph for DrmWapPushMsg.cpp:

Generated on Tue Jan 24 16:26:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmWapPushMsg.hpp File Reference

AddOns/Drm/DrmWapPushMsg.hpp File Reference

#include <Kernel/Message.hpp>

Include dependency graph for DrmWapPushMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmWapPushMsg

Defines

#define | DrmWapPushMsg_hpp__ST_1101449473226

Define Documentation

#define DrmWapPushMsg_hpp__ST_1101449473226

Generated on Tue Jan 24 16:26:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/DrmWapPushMsg.hpp Source File

AddOns/Drm/DrmWapPushMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "lnz_apoxi\Apoxi\AddOns\Drm\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014 #if !defined(DrmWapPushMsg_hpp__ST_1101449473226)
00015 #define DrmWapPushMsg_hpp__ST_1101449473226
00016 #include <Kernel/Message.hpp>
00017 /* ----------------------------------------------------------------------
00018     Classes
00019     ---------------------------------------------------------------------- */
00020 /*  ======================================================================
00021     Class DrmWapPushMsg
00022     ====================================================================== */
00024 class DrmWapPushMsg : public Message {
00025     public:
00026         DrmWapPushMsg(const DrmLocalId& local_id = c_drm_invalid_local_id);
00027         virtual ~DrmWapPushMsg();
00028
00029         virtual const MsgMetaData& GetMetaData() const;
00030         void SetLocalId(const DrmLocalId& local_id) { m_local_id = local_id; }
00031         const DrmLocalId& GetLocalId() const { return m_local_id; }
00032         virtual Message* Clone() const;
00033
00034         enum  {
00035             ID = 4350
00036             };
00037
00038     private:
00039         static const MsgMetaData m_meta_data;
00040         DrmLocalId m_local_id;
00041
00042     };
00043 #endif // DrmWapPushMsg_hpp__ST_1101449473226
00044
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/MultipartParser.cpp File Reference

AddOns/Drm/MultipartParser.cpp File Reference

#include <AddOns/Drm/DrmPreComp.hpp>
#include "MultipartParser.hpp"
#include <ctype.h>

Include dependency graph for MultipartParser.cpp:

Generated on Tue Jan 24 16:26:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/MultipartParser.hpp File Reference

AddOns/Drm/MultipartParser.hpp File Reference

#include <Auxiliary/BufferedData.hpp>
#include <Auxiliary/BinData.hpp>
#include <Kernel/Types.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for MultipartParser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | HeaderData
struct | MultiPartData
class | MultipartParser

Defines

#define | Apoxi_Multipart_Mime_hpp
#define | dprintf(x)
This flag will enable the debug prints and testing code fo the host.
#define | MULTIPART_COMMENT ';'
#define | MULTIPART_CR '\r'
#define | MULTIPART_ERROR_CONTENT_PARSING -7
#define | MULTIPART_ERROR_FILE_FORMAT -11
#define | MULTIPART_ERROR_HEADER_PARSING -8
#define | MULTIPART_ERROR_INVALID_BOUNDARY -4
#define | MULTIPART_ERROR_INVALID_END -3
#define | MULTIPART_ERROR_INVALID_INPUT -5
#define | MULTIPART_ERROR_INVALID_START -2
#define | MULTIPART_ERROR_INVALID_VALUE -6
#define | MULTIPART_ERROR_NO_HEADER -9
#define | MULTIPART_ERROR_NO_MEMORY -12
#define | MULTIPART_ERROR_REACHED_EOF -10
#define | MULTIPART_ERROR_UNKNOWN -1
#define | MULTIPART_ERROR_VALUE_NOT_FOUND -13
#define | MULTIPART_LF '\n'
#define | MULTIPART_SPACE ' '
#define | MULTIPART_SUCCESS 0
Multipart parsing Error codes.
#define | MULTIPART_TAB '\t'
#define | SKIP_SPACE(b, l) while(*b == MULTIPART_SPACE || *b == MULTIPART_TAB) { b++; l--; }
#define | STR_CONTENT_ENCODING "Content-Transfer-Encoding"
#define | STR_CONTENT_ID "Content-ID"
#define | STR_CONTENT_TYPE "Content-type"
Header names bieng filled inthe vector.
#define | STR_DESCRIPTION "Content-Description"
#define | STR_DISPOSITION "Content-Disposition"

Define Documentation

#define Apoxi_Multipart_Mime_hpp

Generated on Tue Jan 24 16:26:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Drm/MultipartParser.hpp Source File

AddOns/Drm/MultipartParser.hpp

Go to the documentation of this file.
00001 /*  =============================================================================
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     =============================================================================
00004
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     =============================================================================*/
00009
00010 #if !defined(Apoxi_Multipart_Mime_hpp)
00011 #define Apoxi_Multipart_Mime_hpp
00012
00016
00017 /************************* #INCLUDES *************************/
00018 #include <Auxiliary/BufferedData.hpp>
00019 #include <Auxiliary/BinData.hpp>
00020 #include <Kernel/Types.hpp>
00021 #include <Auxiliary/String.hpp>
00022 #include <Auxiliary/Vector.hpp>
00023 /************************* DEBUGs *************************/
00024
00026 //#define MULTIPART_DEBUG
00027
00028 #ifdef MULTIPART_DEBUG
00029 #include <stdio.h>
00030 #define dprintf(x) printf x;
00031 #else
00032 #define dprintf(x)
00033 #endif // MULTIPART_DEBUG
00034
00035 /************************** #DEFINES ****************************/
00036 #define MULTIPART_LF '\n'
00037 #define MULTIPART_CR '\r'
00038 #define MULTIPART_TAB '\t'
00039 #define MULTIPART_SPACE ' '
00040 #define MULTIPART_COMMENT ';'
00041 #define SKIP_SPACE(b, l) while(*b == MULTIPART_SPACE || *b == MULTIPART_TAB) { b++; l--; }
00042
00044 #define MULTIPART_SUCCESS                  0
00045 #define MULTIPART_ERROR_UNKNOWN           -1
00046 #define MULTIPART_ERROR_INVALID_START     -2
00047 #define MULTIPART_ERROR_INVALID_END       -3
00048 #define MULTIPART_ERROR_INVALID_BOUNDARY  -4
00049 #define MULTIPART_ERROR_INVALID_INPUT     -5
00050 #define MULTIPART_ERROR_INVALID_VALUE     -6
00051 #define MULTIPART_ERROR_CONTENT_PARSING   -7
00052 #define MULTIPART_ERROR_HEADER_PARSING    -8
00053 #define MULTIPART_ERROR_NO_HEADER         -9
00054 #define MULTIPART_ERROR_REACHED_EOF       -10
00055 #define MULTIPART_ERROR_FILE_FORMAT       -11
00056 #define MULTIPART_ERROR_NO_MEMORY         -12
00057 #define MULTIPART_ERROR_VALUE_NOT_FOUND   -13
00058
00060 #define STR_CONTENT_TYPE     "Content-type"
00061 #define STR_CONTENT_ENCODING "Content-Transfer-Encoding"
00062 #define STR_CONTENT_ID       "Content-ID"
00063 #define STR_DESCRIPTION      "Content-Description"
00064 #define STR_DISPOSITION      "Content-Disposition"
00065
00066 /********************* Structure definations **********************/
00067
00070 typedef struct HeaderData
00071 {
00073     String m_name;
00075     String m_value;
00076 } HeaderData;
00077
00081 typedef struct MultiPartData
00082 {
00084     INT m_bound_num;
00085
00087     INT  m_content_offset;
00088     INT  m_content_len;
00089
00091     Vector<HeaderData> m_header;
00092
00093 } MultiPartData;
00094
00101 class MultipartParser
00102 {
00103     public:
00104
00105         MultipartParser();
00106         ~MultipartParser();
00107
00111         static INT  GetNumBoundaries(const BinData& msg);
00112         static INT  GetNumBoundaries(const String& msg);
00113         static INT  GetNumBoundaries(const CHAR* msg, INT len);
00114
00121         static INT  Parse(const BinData& msg, INT bound_num, MultiPartData *data);
00122         static INT  Parse(const String& msg, INT bound_num, MultiPartData *data);
00123         static INT  Parse(const CHAR* msg, INT len, INT bound_num, MultiPartData *data);
00124
00131         static INT GetIndexForValue(CHAR *header_name, MultiPartData *data);
00132
00133     private:
00134         static INT ValidateEof(const CHAR *msg, INT len);
00135         static INT GetContentLength(const CHAR *msg, INT len, String boundary);
00136         static INT GetBoundaryName(const CHAR* msg, INT len, String &buf);
00137         static INT GetStringFromLine(const CHAR *msg, INT len, String& buf);
00138         static INT GetRawContentType(const CHAR *msg, INT len, String& buf);
00139         static INT GetContentId(const CHAR *msg, INT len, String& buf);
00140 };
00141
00143 #endif
00144
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiInputExtensions/AbstractPredictiveInputBox.cpp File Reference

AddOns/GuiInputExtensions/AbstractPredictiveInputBox.cpp File Reference

#include "PreComp.hpp"
#include <Gui/CharItem.hpp>
#include "AbstractPredictiveInputBox.hpp"
#include <Gui/MultiLineEditor.hpp>

Include dependency graph for AbstractPredictiveInputBox.cpp:

Generated on Tue Jan 24 16:26:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp File Reference

AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp File Reference

#include <Gui/Window.hpp>
#include <Gui/AbstractMultiLineEditor.hpp>
#include <Gui/PredInputMapper.hpp>
#include <Gui/Control.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for AbstractPredictiveInputBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractPredictiveInputBox

Defines

#define | Apoxi_AbstractPredictiveInputBox_hpp

Define Documentation

#define Apoxi_AbstractPredictiveInputBox_hpp

Generated on Tue Jan 24 16:26:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp Source File

AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_AbstractPredictiveInputBox_hpp)
00012 #define Apoxi_AbstractPredictiveInputBox_hpp
00016
00017 #include <Gui/Window.hpp>
00018 #include <Gui/AbstractMultiLineEditor.hpp>
00019 #include <Gui/PredInputMapper.hpp>
00020 #include <Gui/Control.hpp>
00021 #include <Config/KeyboardConfig.hpp>
00022
00024 class AbstractPredictiveInputBox : public Control {
00025     typedef Control Base;
00026
00027     public:
00029         enum PredFontId {
00030             // Font for the indicess of the selection box
00031             SelectionBoxIndexId,
00032             // Font for the simplified chinese in the selection box
00033             SelectionBoxSimpId,
00034             // Font for the traditional chinese in the selection box
00035             SelectionBoxTradId,
00036             // Font for chinese in the selection box
00037             SelectionBoxChineseId,
00038             // Font for the strokes in the stroke box
00039             StrokeBoxId,
00040             // Font for BoPoMoFo in the pinyin box
00041             PinyinBoxNumbersId,
00042             // component font for Zi8
00043             SelectionBoxComponentsId,
00044             //default
00045             PinyinBoxCharsId
00046
00047         };
00048
00050         enum PredBitmapId {
00052             UpDownArrowBitmapId,
00054             DownArrowBitmapId,
00056             UpArrowBitmapId,
00058             SelectBitmapId
00059         };
00060
00062         AbstractPredictiveInputBox();
00063
00065         AbstractPredictiveInputBox(Control* parent, AbstractMultiLineEditor* m_editor, Window* add_word_to_dict_win=0, Window* ext_punc_win=0);
00066
00068         virtual ~AbstractPredictiveInputBox();
00069
00071         void Init(Control* parent, AbstractMultiLineEditor* m_editor, Window* add_word_to_dict_win=0, Window* ext_punc_win=0);
00072
00074         virtual BOOLEAN SetMode(PredInputMapper::PredMode mode);
00075
00077         PredInputMapper::PredMode GetMode() const;
00078
00080         virtual BOOLEAN IsModeSupported(PredInputMapper::PredMode mode);
00081
00083         virtual INT GetCapsStatus() const = 0;
00084
00085         virtual BOOLEAN AddNewWordToUdb(const WString& word) = 0;
00086
00087     protected:
00089         virtual void OnGetFocus();
00090
00092         virtual void UpdateDrawableObjects() = 0;
00093
00094         // TODO: don't use protected members, make them private and provide getter methods
00095         AbstractMultiLineEditor* m_editor;
00096         Window* m_ext_punc_win;
00097         Window* m_add_word_to_dict_win;
00098
00099     private:
00100         BOOLEAN HasPredInputMapper() const;
00101 };
00102
00104 #endif  // Apoxi_AbstractPredictiveInputBox_hpp
00105
00106
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiInputExtensions/PreComp.cpp File Reference

AddOns/GuiInputExtensions/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiInputExtensions/PreComp.hpp File Reference

AddOns/GuiInputExtensions/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/System.hpp>
#include <Gui/View.hpp>
#include <Gui/Control.hpp>
#include <Gui/PositionIndicator.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:16:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiInputExtensions/PreComp.hpp Source File

AddOns/GuiInputExtensions/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 //lint -e506
00010 //lint -e774
00011 //lint -e527
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Gui/View.hpp>
00016 #include <Gui/Control.hpp>
00017 #include <Gui/PositionIndicator.hpp>
00018
00019
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.cpp File Reference

AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.cpp File Reference

#include "PreComp.hpp"
#include "AbstractActionMenuAccessor.hpp"
#include "AccessorActionExtension.hpp"
#include <Gui/Menu.hpp>
#include <Gui/Action.hpp>

Include dependency graph for AbstractActionMenuAccessor.cpp:

Generated on Tue Jan 24 16:26:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp File Reference

AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/Vector.hpp>
#include <Gui/MenuAccessor.hpp>

Include dependency graph for AbstractActionMenuAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractActionMenuAccessor

Defines

#define | Apoxi_AbstractActionMenuAccessor_hpp

Define Documentation

#define Apoxi_AbstractActionMenuAccessor_hpp

Generated on Tue Jan 24 16:26:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp Source File

AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractActionMenuAccessor_hpp)
00010 #define Apoxi_AbstractActionMenuAccessor_hpp
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017 #include <Gui/MenuAccessor.hpp>
00018
00019 class Action;
00020
00032 class AbstractActionMenuAccessor : public MenuAccessor {
00033     typedef MenuAccessor Base;
00034
00035     public:
00038         AbstractActionMenuAccessor();
00039
00041         AbstractActionMenuAccessor(const WCHAR* title);
00042
00044         ~AbstractActionMenuAccessor();
00045
00047         void Init(const WCHAR* title);
00048
00050         virtual Action* GetAction() = 0;
00051
00053         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00054
00056         virtual const BitmapRes* GetItemIcon(BOOLEAN highlighted);
00057
00059         virtual BOOLEAN IsEnabled();
00060
00062         virtual void Trigger(Menu* menu);
00063
00064     protected:
00066         virtual AbstractMenuAccessor* GetChild();
00067
00069         virtual void OnTrigger(INT selected_idx);
00070
00072         virtual void OnLanguageChanged();
00073 };
00074
00076 #endif  // Apoxi_AbstractActionMenuAccessor_hpp
00077
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AccessorAction.cpp File Reference

AddOns/GuiMenuAccessors/AccessorAction.cpp File Reference

#include "PreComp.hpp"
#include "AccessorAction.hpp"
#include <Kernel/Application.hpp>
#include <Gui/AbstractMenuAccessor.hpp>

Include dependency graph for AccessorAction.cpp:

Generated on Tue Jan 24 16:26:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AccessorAction.hpp File Reference

AddOns/GuiMenuAccessors/AccessorAction.hpp File Reference

#include <Gui/Action.hpp>
#include <AddOns/GuiMenuAccessors/AccessorActionExtension.hpp>

Include dependency graph for AccessorAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AccessorAction

Defines

#define | Apoxi_AccessorAction_hpp

Define Documentation

#define Apoxi_AccessorAction_hpp

Generated on Tue Jan 24 16:26:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AccessorAction.hpp Source File

AddOns/GuiMenuAccessors/AccessorAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AccessorAction_hpp)
00010 #define Apoxi_AccessorAction_hpp
00014
00015 #include <Gui/Action.hpp>
00016 #include <AddOns/GuiMenuAccessors/AccessorActionExtension.hpp>
00017
00018 class AbstractMenuAccessor;
00019
00029 class AccessorAction : public Action {
00030     typedef Action Base;
00031
00032     public:
00034         AccessorAction();
00035
00037         AccessorAction(Dispatcher* dispatcher,
00038                        AbstractMenuAccessor* accessor,
00039                        const WCHAR* text,
00040                        const BitmapRes* bitmap = 0,
00041                        BOOLEAN enabled = TRUE);
00042
00044         virtual ~AccessorAction();
00045
00047         void Init(Dispatcher* dispatcher,
00048                   AbstractMenuAccessor* accessor,
00049                   const WCHAR* text,
00050                   const BitmapRes* bitmap = 0,
00051                   BOOLEAN enabled = TRUE);
00052
00054         AbstractMenuAccessor* GetMenuAccessor() { return m_ext.GetMenuAccessor(); }
00055
00057         virtual const ActionExtension* GetExtension() const;
00058
00059     private:
00060         AccessorActionExtension m_ext;
00061 };
00062
00064 #endif // Apoxi_AccessorAction_hpp
00065
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AccessorActionExtension.cpp File Reference

AddOns/GuiMenuAccessors/AccessorActionExtension.cpp File Reference

#include "PreComp.hpp"
#include "AccessorActionExtension.hpp"

Include dependency graph for AccessorActionExtension.cpp:

Generated on Tue Jan 24 16:26:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AccessorActionExtension.hpp File Reference

AddOns/GuiMenuAccessors/AccessorActionExtension.hpp File Reference

#include <Gui/ActionExtension.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for AccessorActionExtension.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AccessorActionExtension

Defines

#define | Apoxi_AccessorActionExtension_hpp

Define Documentation

#define Apoxi_AccessorActionExtension_hpp

Generated on Tue Jan 24 16:26:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/AccessorActionExtension.hpp Source File

AddOns/GuiMenuAccessors/AccessorActionExtension.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AccessorActionExtension_hpp)
00010 #define Apoxi_AccessorActionExtension_hpp
00014
00015 #include <Gui/ActionExtension.hpp>
00016 #include <Auxiliary/WString.hpp>
00017
00018 class AbstractMenuAccessor;
00019
00022 class AccessorActionExtension : public ActionExtension {
00023     public:
00024         enum { ID = 0 };
00025
00027         AccessorActionExtension();
00028
00030         virtual ~AccessorActionExtension();
00031
00033         virtual INT GetId() const;
00034
00036         virtual BOOLEAN IsInstanceOf(INT id) const;
00037
00039         void SetMenuAccessor(AbstractMenuAccessor* accessor) { m_accessor = accessor; }
00040
00042         AbstractMenuAccessor* GetMenuAccessor() const { return m_accessor; }
00043
00044     private:
00045         AbstractMenuAccessor* m_accessor;
00046 };
00047
00049 #endif // Apoxi_AccessorActionExtension_hpp
00050
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/ActionMenuAccessor.cpp File Reference

AddOns/GuiMenuAccessors/ActionMenuAccessor.cpp File Reference

#include "PreComp.hpp"
#include "ActionMenuAccessor.hpp"
#include <Gui/Action.hpp>

Include dependency graph for ActionMenuAccessor.cpp:

Generated on Tue Jan 24 16:26:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp File Reference

AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/Vector.hpp>
#include <AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp>

Include dependency graph for ActionMenuAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ActionMenuAccessor

Defines

#define | Apoxi_ActionMenuAccessor_hpp

Define Documentation

#define Apoxi_ActionMenuAccessor_hpp

Generated on Tue Jan 24 16:26:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp Source File

AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ActionMenuAccessor_hpp)
00010 #define Apoxi_ActionMenuAccessor_hpp
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017 #include <AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp>
00018
00028 class ActionMenuAccessor : public AbstractActionMenuAccessor {
00029     typedef AbstractActionMenuAccessor Base;
00030
00031     public:
00034         ActionMenuAccessor();
00035
00043         ActionMenuAccessor(const WCHAR* title, INT action_count = 4);
00044
00046         ~ActionMenuAccessor();
00047
00055         void Init(const WCHAR* title, INT action_count = 4);
00056
00058         virtual BOOLEAN First();
00059
00061         virtual BOOLEAN Next();
00062
00064         virtual Action* GetAction();
00065
00068         void AddAction(Action* action);
00069
00071         void InsertAction(INT index, Action* action);
00072
00074         void RemoveAction(INT index);
00075
00077         void RemoveAllActions();
00078
00080         BOOLEAN ContainsAction(const Action& action) const;
00081
00083         void SetAction(INT index, Action* action);
00084
00086         Action* GetAction(INT index) const;
00087
00089         INT GetActionIndex(const Action& action) const;
00090
00092         INT GetActionCount() const;
00093
00094     protected:
00096         virtual void OnTrigger(INT selected_idx);
00097
00098     private:
00099         INT                         m_index;
00100         Vector<Action*>             m_action_vec;
00101
00102         void AssureValidIndex(INT& index) const;
00103 };
00104
00106 #endif  // Apoxi_ActionMenuAccessor_hpp
00107
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/ApplicationAction.cpp File Reference

AddOns/GuiMenuAccessors/ApplicationAction.cpp File Reference

#include "PreComp.hpp"
#include "MsgTypes.hpp"
#include "ApplicationAction.hpp"
#include <Kernel/Application.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Gui/AbstractMenuAccessor.hpp>

Include dependency graph for ApplicationAction.cpp:

Generated on Tue Jan 24 16:26:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/ApplicationAction.hpp File Reference

AddOns/GuiMenuAccessors/ApplicationAction.hpp File Reference

#include <Gui/Action.hpp>

Include dependency graph for ApplicationAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ApplicationAction

Defines

#define | Apoxi_ApplicationAction_hpp

Define Documentation

#define Apoxi_ApplicationAction_hpp

Generated on Tue Jan 24 16:26:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/ApplicationAction.hpp Source File

AddOns/GuiMenuAccessors/ApplicationAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ApplicationAction_hpp)
00010 #define Apoxi_ApplicationAction_hpp
00014
00015 #include <Gui/Action.hpp>
00016
00027 class ApplicationAction : public Action {
00028     typedef Action Base;
00029
00030     public:
00032         ApplicationAction();
00033
00035         ApplicationAction(Dispatcher* dispatcher,
00036                           Application* app,
00037                           const WCHAR* text,
00038                           const BitmapRes* bitmap = 0,
00039                           BOOLEAN enabled = TRUE);
00040
00042         virtual ~ApplicationAction();
00043
00045         void Init(Dispatcher* dispatcher,
00046                   Application* app,
00047                   const WCHAR* text,
00048                   const BitmapRes* bitmap = 0,
00049                   BOOLEAN enabled = TRUE);
00050
00052         Application* GetApplication() { return m_app; }
00053
00059         virtual BOOLEAN Execute();
00060
00061     private:
00062         Application* m_app;
00063 };
00064
00066 #endif // Apoxi_ApplicationAction_hpp
00067
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/MsgTypes.cpp File Reference

AddOns/GuiMenuAccessors/MsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/MsgTypes.hpp File Reference

AddOns/GuiMenuAccessors/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Gui/Action.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AppActionExecutedMsg

Defines

#define | MenuAccessors_MsgTypes_hpp

Define Documentation

#define MenuAccessors_MsgTypes_hpp

Generated on Tue Jan 24 14:55:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/MsgTypes.hpp Source File

AddOns/GuiMenuAccessors/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "src\koglerm_snap_host\lnz_development\src\Apoxi\AddOns\GuiMenuAccessors\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(MenuAccessors_MsgTypes_hpp)
00017 #define MenuAccessors_MsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Gui/Action.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class AppActionExecutedMsg
00029     ====================================================================== */
00030
00033 class AppActionExecutedMsg : public ContextMsg {
00034     public:
00035         AppActionExecutedMsg(ExecutionContext* context, Action* action);
00036         virtual ~AppActionExecutedMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         Action* GetAction() const { return m_action; }
00040         virtual Message* Clone() const;
00041
00042         enum  {
00043             ID = 4000
00044             };
00045
00046     private:
00047         static const MsgMetaData m_meta_data;
00048         Action* m_action;
00049
00050     };
00051
00052 #endif // MenuAccessors_MsgTypes_hpp
00053
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/PreComp.cpp File Reference

AddOns/GuiMenuAccessors/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/PreComp.hpp File Reference

AddOns/GuiMenuAccessors/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/System.hpp>
#include <Gui/AbstractMenuAccessor.hpp>
#include <Gui/MenuAccessor.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:16:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/PreComp.hpp Source File

AddOns/GuiMenuAccessors/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 //lint -e506
00010 //lint -e774
00011 //lint -e527
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Gui/AbstractMenuAccessor.hpp>
00016 #include <Gui/MenuAccessor.hpp>
00017
00018
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/SubMenuAction.cpp File Reference

AddOns/GuiMenuAccessors/SubMenuAction.cpp File Reference

#include "PreComp.hpp"
#include "SubMenuAction.hpp"
#include <Kernel/Application.hpp>
#include <Gui/AbstractMenuAccessor.hpp>

Include dependency graph for SubMenuAction.cpp:

Generated on Tue Jan 24 16:26:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/SubMenuAction.hpp File Reference

AddOns/GuiMenuAccessors/SubMenuAction.hpp File Reference

#include <Gui/Action.hpp>
#include <AddOns/GuiMenuAccessors/AccessorActionExtension.hpp>
#include <AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp>

Include dependency graph for SubMenuAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SubMenuAction

Defines

#define | Apoxi_SubMenuAction_hpp

Define Documentation

#define Apoxi_SubMenuAction_hpp

Generated on Tue Jan 24 16:26:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/SubMenuAction.hpp Source File

AddOns/GuiMenuAccessors/SubMenuAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SubMenuAction_hpp)
00010 #define Apoxi_SubMenuAction_hpp
00014
00015 #include <Gui/Action.hpp>
00016 #include <AddOns/GuiMenuAccessors/AccessorActionExtension.hpp>
00017 #include <AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp>
00018
00019 class AbstractMenuAccessor;
00020
00030 class SubMenuAction : public Action {
00031     typedef Action Base;
00032
00033     public:
00035         SubMenuAction();
00036
00038         SubMenuAction(Dispatcher* dispatcher,
00039                        const WCHAR* text,
00040                        const BitmapRes* bitmap = 0,
00041                        BOOLEAN enabled = TRUE);
00042
00044         virtual ~SubMenuAction();
00045
00047         void Init(Dispatcher* dispatcher,
00048                   const WCHAR* text,
00049                   const BitmapRes* bitmap = 0,
00050                   BOOLEAN enabled = TRUE);
00051
00052         void AddAction(Action* action);
00053
00055         AbstractMenuAccessor* GetMenuAccessor() { return m_ext.GetMenuAccessor(); }
00056
00058         virtual const ActionExtension* GetExtension() const;
00059
00060     private:
00061         AccessorActionExtension m_ext;
00062         ActionMenuAccessor      m_action_menu_accessor;
00063 };
00064
00066 #endif // Apoxi_SubMenuAction_hpp
00067
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/TopLevelMenu.cpp File Reference

AddOns/GuiMenuAccessors/TopLevelMenu.cpp File Reference

#include "PreComp.hpp"
#include "TopLevelMenu.hpp"
#include <Config/Resources/confirm_icon.hpp>
#include <Config/Resources/cancel_icon.hpp>

Include dependency graph for TopLevelMenu.cpp:

Generated on Tue Jan 24 16:26:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/TopLevelMenu.hpp File Reference

AddOns/GuiMenuAccessors/TopLevelMenu.hpp File Reference

#include <Gui/Menu.hpp>
#include <AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp>

Include dependency graph for TopLevelMenu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TopLevelMenu

Defines

#define | Apoxi_TopLevelMenu_hpp

Define Documentation

#define Apoxi_TopLevelMenu_hpp

Generated on Tue Jan 24 16:26:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/GuiMenuAccessors/TopLevelMenu.hpp Source File

AddOns/GuiMenuAccessors/TopLevelMenu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TopLevelMenu_hpp)
00010 #define Apoxi_TopLevelMenu_hpp
00014
00015 #include <Gui/Menu.hpp>
00016 #include <AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp>
00017
00020 class TopLevelMenu : public Menu {
00021     typedef Menu Base;
00022
00023     public:
00025         TopLevelMenu();
00026
00028         void Init(Control* parent, const WCHAR* text);
00029
00030         void AddAction(Action* action);
00031
00032     private:
00033         ActionMenuAccessor  m_action_menu_accessor;
00034 };
00035
00037 #endif // Apoxi_TopLevelMenu_hpp
00038
00039
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpHandler.cpp File Reference

AddOns/HttpWapInterface/HttpWap/HttpHandler.cpp File Reference

#include "HttpWapInterfacePreComp.hpp"
#include <Kernel/System.hpp>
#include "HttpHandler.hpp"
#include "HttpWapMgr.hpp"

Include dependency graph for HttpHandler.cpp:

Generated on Tue Jan 24 16:27:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpHandler.hpp File Reference

AddOns/HttpWapInterface/HttpWap/HttpHandler.hpp File Reference

#include <Kernel/UserDispatcher.hpp>
#include <Auxiliary/BinData.hpp>
#include <Auxiliary/WString.hpp>
#include "HttpWapMgrBase.hpp"

Include dependency graph for HttpHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class HttpHandler

Generated on Tue Jan 24 16:27:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpHandler.hpp Source File

AddOns/HttpWapInterface/HttpWap/HttpHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifndef HttpHandler_hpp
00010 #define HttpHandler_hpp
00013
00014
00015 #include <Kernel/UserDispatcher.hpp>
00016 #include <Auxiliary/BinData.hpp>
00017 #include <Auxiliary/WString.hpp>
00018
00019
00020
00021 #ifdef APOXI_WAP_STACK
00022 #include <Wap/Main/WapService.hpp>
00023 #include <Wap/Main/BrowserMsgTypes.hpp>
00024 #endif //APOXI_WAP_STACK
00025 #include "HttpWapMgrBase.hpp"
00026
00027
00028 /*
00029  * forward declarations
00030  */
00031 class Message;
00032 class HttpWapMgr;
00033
00034
00035
00036
00037
00052 class HttpHandler : public UserDispatcher  {
00053
00054
00055 public:
00056
00057   enum HttpConnStatus {
00058   HttpConnError,
00059   HttpConnClosed,
00060   HttpConnOpen,
00061   HttpConnSuspended
00062 };
00063
00065      HttpHandler();
00066
00068         virtual ~HttpHandler();
00069
00079
00080 #if defined(APOXI_COMPAT_2_3_0)
00081         virtual BOOLEAN HttpOpen(INT id);
00082 #else
00083         virtual BOOLEAN OpenHttp(INT id);
00084 #endif
00085
00095
00096 #if defined(APOXI_COMPAT_2_3_0)
00097         virtual BOOLEAN HttpRequestGet(INT& requ_id, const CHAR* URL,
00098                                        const CHAR* header);
00099 #else
00100         virtual BOOLEAN RequestGetHttp(INT& requ_id, const CHAR* URL,
00101                                        const CHAR* header);
00102 #endif
00103
00114
00115 #if defined(APOXI_COMPAT_2_3_0)
00116          virtual BOOLEAN HttpRequestHead(INT& requ_id, const CHAR* URL,
00117                                          const CHAR* header);
00118 #else
00119          virtual BOOLEAN RequestHeadHttp(INT& requ_id, const CHAR* URL,
00120                                          const CHAR* header);
00121 #endif
00122
00139
00140 #if defined(APOXI_COMPAT_2_3_0)
00141          virtual BOOLEAN HttpRequestPost(INT& requ_id,
00142                                          const CHAR* URL,
00143                                          const CHAR* header,
00144                                          BinData* body,
00145                                          INT more);
00146 #else
00147          virtual BOOLEAN RequestPostHttp(INT& requ_id,
00148                                          const CHAR* URL,
00149                                          const CHAR* header,
00150                                          BinData* body,
00151                                          INT more);
00152 #endif
00153
00167
00168 #if defined(APOXI_COMPAT_2_3_0)
00169            virtual BOOLEAN HttpRequestPostData(INT& request_id,
00170                                                BinData* body,
00171                                                INT more);
00172 #else
00173            virtual BOOLEAN RequestPostDataHttp(INT& request_id,
00174                                                BinData* body,
00175                                                INT more);
00176 #endif
00177
00186
00187 #if defined(APOXI_COMPAT_2_3_0)
00188          virtual BOOLEAN HttpCancel(INT requ_id);
00189 #else
00190          virtual BOOLEAN CancelHttp(INT requ_id);
00191 #endif
00192
00200
00201 #if defined(APOXI_COMPAT_2_3_0)
00202       virtual BOOLEAN HttpClose();
00203 #else
00204       virtual BOOLEAN CloseHttp();
00205 #endif
00206
00213
00214 #if defined(APOXI_COMPAT_2_3_0)
00215        virtual BOOLEAN HttpSuspend();
00216 #else
00217        virtual BOOLEAN SuspendHttp();
00218 #endif
00219
00226
00227 #if defined(APOXI_COMPAT_2_3_0)
00228        virtual BOOLEAN HttpResume();
00229 #else
00230        virtual BOOLEAN ResumeHttp();
00231 #endif
00232
00236
00237 #if defined(APOXI_COMPAT_2_3_0)
00238        virtual INT HttpGetConnId();
00239 #else
00240        virtual INT GetConnIdHttp();
00241 #endif
00242
00246
00247 #if defined(APOXI_COMPAT_2_3_0)
00248         virtual HttpConnStatus HttpGetConnStatus();
00249 #else
00250         virtual HttpConnStatus GetConnStatusHttp();
00251 #endif
00252 #ifdef APOXI_WAP_STACK
00253     /*CN200014015: Change request to return Get Secure session info
00254     By Markus Dannel(Java Team) */
00259 #if defined(APOXI_COMPAT_2_3_0)
00260        virtual BOOLEAN HttpGetSessionInfo(INT& request_id);
00261 #else
00262        virtual BOOLEAN GetSessionInfoHttp(INT& request_id);
00263 #endif
00264 #endif
00265
00266
00271
00272     virtual BOOLEAN AddRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert);
00273
00278
00279     virtual BOOLEAN ClearRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert);
00280
00286
00287     virtual BOOLEAN ReadRootCertificate(INT conn_id, UINT8** certData, UINT32* certLen);
00288
00296
00297     virtual BOOLEAN ReadUserCertificate(INT conn_id, UINT8** certData, UINT32* certLen, UINT8** certKey,UINT32* certKeyLen);
00298
00304
00305     virtual BOOLEAN AddUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert);
00306
00311
00312     virtual BOOLEAN ClearUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert);
00313
00314
00315     virtual BOOLEAN GetCipherSuiteName (INT conn_id, const UINT8** pCipherSuiteName);
00316
00317
00318
00319 protected:
00320
00343
00344     virtual BOOLEAN DecodeMessage(const Message& msg,
00345                                   INT& conn_id,
00346                                   INT& requ_id,
00347                                   INT& status,
00348                                   WString& header,
00349                                   BinData** body,
00350                                   INT& more,
00351                                   INT& length,
00352                                   WString& url);
00353
00361
00362     virtual BOOLEAN OnMessage(const Message& msg)=0 ;
00363
00371
00372     virtual BOOLEAN OnResponse(const Message& msg)=0;
00373
00374 #ifdef APOXI_WAP_STACK
00375
00385     virtual BOOLEAN DecodeGetSessionInfoResponseMessage(const Message& msg,
00386                                                         INT& result,
00387                                                         INT& conn_id,
00388                                                         INT& connection_type,
00389                                                         String& cipher_info,
00390                                              CertificateInfo_t& certificate);
00391 #endif //APOXI_WAP_STACK
00392
00393
00394 private:
00395
00396     INT m_conn_id;
00397
00398     HttpConnStatus m_conn_status;
00399
00400     HttpWapMgr* m_http_wap_mgr;
00401
00409
00410       BOOLEAN SetHttpResponseReceived(const CHAR* header,
00411                                       const BinData* body) ;
00412
00418
00419 #if defined(APOXI_COMPAT_2_3_0)
00420     BOOLEAN HttpSetConnId(INT conn_id);
00421 #else
00422     BOOLEAN SetConnIdHttp(INT conn_id);
00423 #endif
00424
00430
00431 #if defined(APOXI_COMPAT_2_3_0)
00432     BOOLEAN HttpSetConnStatus(HttpConnStatus status);
00433 #else
00434     BOOLEAN SetConnStatusHttp(HttpConnStatus status);
00435 #endif
00436
00437
00438 };
00439
00441 #endif  // HttpHandler_hpp
00442
00443
Generated on Tue Jan 24 14:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpWapInterfacePreComp.cpp File Reference

AddOns/HttpWapInterface/HttpWap/HttpWapInterfacePreComp.cpp File Reference

#include "HttpWapInterfacePreComp.hpp"

Include dependency graph for HttpWapInterfacePreComp.cpp:

Generated on Tue Jan 24 16:27:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpWapInterfacePreComp.hpp File Reference

AddOns/HttpWapInterface/HttpWap/HttpWapInterfacePreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for HttpWapInterfacePreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:27:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpWapInterfacePreComp.hpp Source File

AddOns/HttpWapInterface/HttpWap/HttpWapInterfacePreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Asc/Lib.hpp>
00012
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpWapMgr.cpp File Reference

AddOns/HttpWapInterface/HttpWap/HttpWapMgr.cpp File Reference

#include "HttpWapInterfacePreComp.hpp"
#include "HttpWapMgr.hpp"

Include dependency graph for HttpWapMgr.cpp:

Generated on Tue Jan 24 16:27:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpWapMgr.hpp File Reference

AddOns/HttpWapInterface/HttpWap/HttpWapMgr.hpp File Reference

#include <AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp>

Include dependency graph for HttpWapMgr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpWapMgr

Defines

#define | APOXI_MAX_CONN_LIMIT 100

Generated on Tue Jan 24 16:27:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpWapMgr.hpp Source File

AddOns/HttpWapInterface/HttpWap/HttpWapMgr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifndef HttpWapMgr_hpp
00010 #define HttpWapMgr_hpp
00013
00014 #include <AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp>
00015
00016 /*
00017  * forward declarations
00018  */
00019 class BinData;
00020 class Message;
00021 class HttpHandler;
00022 class HttpWapMgrPlugin;
00023
00024
00051 #define APOXI_MAX_CONN_LIMIT       100
00052
00053 class HttpWapMgr {
00054
00055
00056 public:
00057
00059     virtual ~HttpWapMgr();
00060
00061
00067
00068     static  HttpWapMgr* GetInstance();
00069
00070
00071 protected:
00072
00073
00074     HttpWapMgrPlugin* m_http_plugin;
00075
00076
00077
00078     INT m_conn_id_free_Slot[APOXI_MAX_CONN_LIMIT];
00079
00080
00102
00103     virtual BOOLEAN DecodeMessage(const Message& msg,
00104                                   INT& conn_id,
00105                                   INT& requ_id,
00106                                   INT& status,
00107                                   WString& header,
00108                                   BinData** body,
00109                                   INT& more,
00110                                   INT& length,
00111                                   WString& url);
00112
00113
00118
00119     BOOLEAN GetFreeConnId(INT& conn_id);
00120
00124
00125
00126     void ReleaseConnId(INT& conn_id);
00127
00128
00129     /*********************
00130
00131         HTTP functionality
00132
00133     **********************/
00134
00147
00148 #if defined(APOXI_COMPAT_2_3_0)
00149         virtual BOOLEAN HttpOpen(INT& conn_id, INT pr_id);
00150 #else
00151         virtual BOOLEAN OpenHttp(INT& conn_id, INT pr_id);
00152 #endif
00153
00154
00168
00169 #if defined(APOXI_COMPAT_2_3_0)
00170     virtual BOOLEAN HttpRequestGet( INT conn_id,
00171                                     INT& requ_id,
00172                                     const CHAR* URL,
00173                                     const CHAR* header);
00174 #else
00175     virtual BOOLEAN RequestGetHttp( INT conn_id,
00176                                     INT& requ_id,
00177                                     const CHAR* URL,
00178                                     const CHAR* header);
00179 #endif
00180
00193
00194 #if defined(APOXI_COMPAT_2_3_0)
00195     virtual BOOLEAN HttpRequestHead( INT conn_id,
00196                                     INT& requ_id,
00197                                     const CHAR* URL,
00198                                     const CHAR* header);
00199 #else
00200     virtual BOOLEAN RequestHeadHttp( INT conn_id,
00201                                     INT& requ_id,
00202                                     const CHAR* URL,
00203                                     const CHAR* header);
00204 #endif
00205
00225
00226 #if defined(APOXI_COMPAT_2_3_0)
00227     virtual BOOLEAN HttpRequestPost(INT conn_id,
00228                                     INT& requ_id,
00229                                     const CHAR* URL,
00230                                     const CHAR* header,
00231                                     BinData* body,
00232                                     INT more);
00233 #else
00234     virtual BOOLEAN RequestPostHttp(INT conn_id,
00235                                     INT& requ_id,
00236                                     const CHAR* URL,
00237                                     const CHAR* header,
00238                                     BinData* body,
00239                                     INT more);
00240 #endif
00241
00257
00258 #if defined(APOXI_COMPAT_2_3_0)
00259     virtual BOOLEAN HttpRequestPostData(INT conn_id,
00260                                         INT  requ_id,
00261                                         BinData* body,
00262                                         INT more);
00263 #else
00264     virtual BOOLEAN RequestPostDataHttp(INT conn_id,
00265                                         INT  requ_id,
00266                                         BinData* body,
00267                                         INT more);
00268 #endif
00269
00278
00279 #if defined(APOXI_COMPAT_2_3_0)
00280     virtual BOOLEAN HttpCancel(INT conn_id, INT requ_id);
00281 #else
00282     virtual BOOLEAN CancelHttp(INT conn_id, INT requ_id);
00283 #endif
00284
00294
00295 #if defined(APOXI_COMPAT_2_3_0)
00296     virtual BOOLEAN HttpClose(INT conn_id) ;
00297 #else
00298     virtual BOOLEAN CloseHttp(INT conn_id) ;
00299 #endif
00300
00312
00313 #if defined(APOXI_COMPAT_2_3_0)
00314     virtual BOOLEAN HttpSuspend(INT conn_id);
00315 #else
00316     virtual BOOLEAN SuspendHttp(INT conn_id);
00317 #endif
00318
00330
00331 #if defined(APOXI_COMPAT_2_3_0)
00332     virtual BOOLEAN HttpResume(INT conn_id) ;
00333 #else
00334     virtual BOOLEAN ResumeHttp(INT conn_id) ;
00335 #endif
00336
00342
00343 #if defined(APOXI_COMPAT_2_3_0)
00344     virtual INT HttpGetConnStatus();
00345 #else
00346     virtual INT GetConnStatusHttp();
00347 #endif
00348
00349 #ifdef APOXI_WAP_STACK
00350
00356 #if defined(APOXI_COMPAT_2_3_0)
00357     virtual BOOLEAN HttpGetSessionInfo(INT conn_id, INT& request_id);
00358 #else
00359     virtual BOOLEAN GetSessionInfoHttp(INT conn_id, INT& request_id);
00360 #endif
00361
00371     virtual BOOLEAN DecodeGetSessionInfoResponseMessage(
00372                                 const Message& msg,
00373                                           INT& result,
00374                                 INT& conn_id,
00375                                           INT& connection_type,
00376                                           String& cipher_info,
00377                                     CertificateInfo_t& certificate);
00378
00379 #endif //APOXI_WAP_STACK
00380
00381     /********************
00382
00383         WAP functionality
00384
00385     *********************/
00386
00405
00406 #if defined(APOXI_COMPAT_2_3_0)
00407     virtual BOOLEAN WapRegister(INT& conn_id,
00408                                 INT pr_id,
00409                                 WString& mime,
00410                                 INT app_id = 0);
00411 #else
00412     virtual BOOLEAN RegisterWap(INT& conn_id,
00413                                 INT pr_id,
00414                                 WString& mime,
00415                                 INT app_id = 0);
00416 #endif
00417
00427
00428 #if defined(APOXI_COMPAT_2_3_0)
00429     virtual BOOLEAN WapUnregister(INT& conn_id,const INT& pr_id);
00430 #else
00431     virtual BOOLEAN UnregisterWap(INT& conn_id,const INT& pr_id);
00432 #endif
00433
00441
00442 #if defined(APOXI_COMPAT_2_3_0)
00443     virtual BOOLEAN WapSuspend(INT  conn_id);
00444 #else
00445     virtual BOOLEAN SuspendWap(INT  conn_id);
00446 #endif
00447
00453
00454 #if defined(APOXI_COMPAT_2_3_0)
00455     virtual BOOLEAN WapResume(INT  conn_id);
00456 #else
00457     virtual BOOLEAN ResumeWap(INT  conn_id);
00458 #endif
00459
00467
00468 #if defined(APOXI_COMPAT_2_3_0)
00469     virtual BOOLEAN WapGetSessionStatus(INT conn_id);
00470 #else
00471     virtual BOOLEAN GetSessionStatusWap(INT conn_id);
00472 #endif
00473
00478
00479     virtual BOOLEAN AddRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert);
00480
00485
00486     virtual BOOLEAN ClearRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert);
00487
00493
00494     virtual BOOLEAN ReadRootCertificate(INT conn_id, UINT8** certData, UINT32* certLen);
00495
00503
00504     virtual BOOLEAN ReadUserCertificate(INT conn_id, UINT8** certData, UINT32* certLen, UINT8** certKey,UINT32* certKeyLen);
00505
00511
00512     virtual BOOLEAN AddUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert);
00513
00518
00519     virtual BOOLEAN ClearUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert);
00520
00521     virtual BOOLEAN GetCipherSuiteName (INT conn_id, const UINT8** pCipherSuiteName);
00522
00525     private :
00526
00527     friend class HttpHandler;
00528     friend class WapHandler;
00529
00530
00531     static HttpWapMgr m_http_wapmgr;
00532
00534     HttpWapMgr();
00535
00536
00537 };
00538
00540
00541 #endif  // HttpWapMgr_hpp
00542
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp File Reference

AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | comm_root_cert
struct | comm_user_cert
class | HttpWapMgrBase

Typedefs

typedef comm_root_cert | COMM_ROOT_CERT
typedef comm_user_cert | COMM_USER_CERT

Generated on Tue Jan 24 16:27:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp Source File

AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #ifndef HttpWapMgrBase_hpp
00011 #define HttpWapMgrBase_hpp
00014
00015
00016 #ifdef APOXI_WAP_STACK
00017 #include <Wap/Main/WapService.hpp>
00018 #include <Wap/Main/BrowserMsgTypes.hpp>
00019 #endif //APOXI_WAP_STACK
00020
00021
00022 #ifndef _JDI_COMMUNICATOR_H_
00023 typedef struct comm_root_cert
00024 {
00025
00026     INT8 *psContent;
00027     UINT32 uiLength;
00028     INT8 *pszContentType;
00029     struct comm_root_cert *pNext;
00030
00031 } COMM_ROOT_CERT;
00032
00033
00034 typedef struct comm_user_cert
00035 {
00036
00037     INT8 *psUserCert;
00038     UINT32 uiCertLen;
00039     INT8 *pszContentType;
00040     INT8 *psKey;
00041     UINT32 uiKeyLen;
00042     INT8 *pszPassword;
00043     struct comm_user_cert *pNext;
00044
00045 } COMM_USER_CERT;
00046 #endif
00047
00048
00049 class HttpWapMgrBase
00050 {
00051
00052 public:
00053
00054     HttpWapMgrBase(){};
00055     virtual ~HttpWapMgrBase(){};
00056
00079
00080     virtual BOOLEAN DecodeMessage(const Message& msg,INT& conn_id, INT& requ_id
00081                              ,INT& status,WString& header, BinData** body,
00082                              INT& more,INT& length,WString& url)=0;
00083
00097
00098 #if defined(APOXI_COMPAT_2_3_0)
00099     virtual BOOLEAN HttpOpen(INT& conn_id, INT pr_id)=0;
00100 #else
00101     virtual BOOLEAN OpenHttp(INT& conn_id, INT pr_id)=0;
00102 #endif
00103
00119
00120 #if defined(APOXI_COMPAT_2_3_0)
00121     virtual BOOLEAN HttpRequestGet(INT   conn_id,INT& requ_id,
00122                                 const CHAR* URL, const CHAR* header)=0;
00123 #else
00124     virtual BOOLEAN RequestGetHttp(INT   conn_id,INT& requ_id,
00125                                 const CHAR* URL, const CHAR* header)=0;
00126 #endif
00127
00144
00145 #if defined(APOXI_COMPAT_2_3_0)
00146     virtual BOOLEAN HttpRequestHead(INT conn_id,INT& requ_id,
00147                                         const CHAR* URL, const CHAR* header)=0;
00148 #else
00149     virtual BOOLEAN RequestHeadHttp(INT conn_id,INT& requ_id,
00150                                         const CHAR* URL, const CHAR* header)=0;
00151 #endif
00152
00175
00176 #if defined(APOXI_COMPAT_2_3_0)
00177     virtual BOOLEAN HttpRequestPost(INT  conn_id,
00178                                         INT& requ_id,
00179                                         const CHAR* URL,
00180                                         const CHAR* header,
00181                                         BinData* body,
00182                                         INT  more)=0;
00183 #else
00184     virtual BOOLEAN RequestPostHttp(INT  conn_id,
00185                                         INT& requ_id,
00186                                         const CHAR* URL,
00187                                         const CHAR* header,
00188                                         BinData* body,
00189                                         INT  more)=0;
00190 #endif
00191
00208
00209 #if defined(APOXI_COMPAT_2_3_0)
00210     virtual BOOLEAN HttpRequestPostData(INT conn_id,
00211                                         INT& requ_id,
00212                                         BinData*  body,
00213                                         INT more)=0;
00214 #else
00215     virtual BOOLEAN RequestPostDataHttp(INT conn_id,
00216                                         INT& requ_id,
00217                                         BinData*  body,
00218                                         INT more)=0;
00219 #endif
00220
00233
00234 #if defined(APOXI_COMPAT_2_3_0)
00235     virtual BOOLEAN HttpCancel(INT conn_id,INT requ_id)=0;
00236 #else
00237     virtual BOOLEAN CancelHttp(INT conn_id,INT requ_id)=0;
00238 #endif
00239
00250
00251 #if defined(APOXI_COMPAT_2_3_0)
00252     virtual BOOLEAN HttpClose(INT conn_id)=0;
00253 #else
00254     virtual BOOLEAN CloseHttp(INT conn_id)=0;
00255 #endif
00256
00267
00268 #if defined(APOXI_COMPAT_2_3_0)
00269     virtual BOOLEAN HttpSuspend(INT conn_id)=0;
00270 #else
00271     virtual BOOLEAN SuspendHttp(INT conn_id)=0;
00272 #endif
00273
00274
00285
00286 #if defined(APOXI_COMPAT_2_3_0)
00287     virtual BOOLEAN HttpResume(INT conn_id)=0;
00288 #else
00289     virtual BOOLEAN ResumeHttp(INT conn_id)=0;
00290 #endif
00291
00292 #ifdef APOXI_WAP_STACK
00293
00299
00300 #if defined(APOXI_COMPAT_2_3_0)
00301     virtual BOOLEAN HttpGetSessionInfo(INT conn_id, INT& request_id)=0;
00302 #else
00303     virtual BOOLEAN GetSessionInfoHttp(INT conn_id, INT& request_id)=0;
00304 #endif
00305
00315
00316     virtual BOOLEAN DecodeGetSessionInfoResponseMessage(
00317                                 const Message& msg,
00318                                           INT& result,
00319                                 INT& conn_id,
00320                                           INT& connection_type,
00321                                           String& cipher_info,
00322                                      CertificateInfo_t& certificate)=0;
00323 #endif //APOXI_WAP_STACK
00324
00325
00330
00331     virtual BOOLEAN IsMessageForMe()=0;
00332
00339
00340 #if defined(APOXI_COMPAT_2_3_0)
00341     virtual BOOLEAN WapGetSessionStatus()=0 ;
00342 #else
00343     virtual BOOLEAN GetSessionStatusWap()=0 ;
00344 #endif
00345
00346
00365
00366 #if defined(APOXI_COMPAT_2_3_0)
00367     virtual BOOLEAN WapRegister(const INT& conn_id,INT pr_id,
00368                                 WString& mime, INT app_id)=0;
00369 #else
00370     virtual BOOLEAN RegisterWap(const INT& conn_id,INT pr_id,
00371                                 WString& mime, INT app_id)=0;
00372 #endif
00373
00374
00380
00381 #if defined(APOXI_COMPAT_2_3_0)
00382     virtual BOOLEAN WapResume(INT conn_id)=0;
00383 #else
00384     virtual BOOLEAN ResumeWap(INT conn_id)=0;
00385 #endif
00386
00397
00398 #if defined(APOXI_COMPAT_2_3_0)
00399     virtual BOOLEAN WapUnregister(const INT& conn_id)=0;
00400 #else
00401     virtual BOOLEAN UnregisterWap(const INT& conn_id)=0;
00402 #endif
00403
00408
00409 #if defined(APOXI_COMPAT_2_3_0)
00410     virtual BOOLEAN WapSuspend(INT conn_id)=0;
00411 #else
00412     virtual BOOLEAN SuspendWap(INT conn_id)=0;
00413 #endif
00414
00419
00420     virtual BOOLEAN AddRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert)=0;
00421
00426
00427     virtual BOOLEAN ClearRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert)=0;
00428
00434
00435     virtual BOOLEAN ReadRootCertificate(INT conn_id, UINT8** certData, UINT32* certLen)=0;
00436
00444
00445     virtual BOOLEAN ReadUserCertificate(INT conn_id, UINT8** certData, UINT32* certLen, UINT8** certKey,UINT32* certKeyLen)=0;
00446
00452
00453     virtual BOOLEAN AddUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert)=0;
00454
00459
00460     virtual BOOLEAN ClearUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert)=0;
00461
00462     virtual BOOLEAN GetCipherSuiteName (INT conn_id, const UINT8** pCipherSuiteName) = 0;
00463
00464 };
00465
00467
00468 #endif
00469
00470
00471
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/WapHandler.cpp File Reference

AddOns/HttpWapInterface/HttpWap/WapHandler.cpp File Reference

#include "HttpWapInterfacePreComp.hpp"
#include "WapHandler.hpp"
#include <Kernel/System.hpp>

Include dependency graph for WapHandler.cpp:

Generated on Tue Jan 24 16:27:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/WapHandler.hpp File Reference

AddOns/HttpWapInterface/HttpWap/WapHandler.hpp File Reference

#include <Kernel/UserDispatcher.hpp>
#include <Auxiliary/BinData.hpp>
#include <Auxiliary/WString.hpp>
#include "HttpWapMgrBase.hpp"
#include "HttpWapMgr.hpp"

Include dependency graph for WapHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WapHandler

Defines

#define | WapHandler_hpp

Define Documentation

#define WapHandler_hpp

Generated on Tue Jan 24 16:27:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWap/WapHandler.hpp Source File

AddOns/HttpWapInterface/HttpWap/WapHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(WapHandler_hpp)
00010 #define WapHandler_hpp
00013
00014 #include <Kernel/UserDispatcher.hpp>
00015 #include <Auxiliary/BinData.hpp>
00016 #include <Auxiliary/WString.hpp>
00017 #include "HttpWapMgrBase.hpp"
00018 #include "HttpWapMgr.hpp"
00019
00020 /*
00021  * forward declarations
00022  */
00023 class Message;
00024
00047 class WapHandler : public UserDispatcher  {
00048
00049
00050 public:
00051
00052
00053 enum WapSessionStatus {
00054   WapSessionConnected,
00055   WapSessionSuspended
00056 };
00057
00058
00059     WapHandler();
00060     virtual ~WapHandler();
00061
00075
00076 #if defined(APOXI_COMPAT_2_3_0)
00077     virtual BOOLEAN WapRegister(INT pr_id,
00078                                 WString& mime,
00079                                 INT app_id = 0);
00080 #else
00081     virtual BOOLEAN RegisterWap(INT pr_id,
00082                                 WString& mime,
00083                                 INT app_id = 0);
00084 #endif
00085
00094
00095 #if defined(APOXI_COMPAT_2_3_0)
00096     virtual BOOLEAN WapUnregister(INT pr_id);
00097 #else
00098     virtual BOOLEAN UnregisterWap(INT pr_id);
00099 #endif
00100
00105
00106 #if defined(APOXI_COMPAT_2_3_0)
00107     virtual BOOLEAN WapSuspend(INT conn_id);
00108 #else
00109     virtual BOOLEAN SuspendWap(INT conn_id);
00110 #endif
00111
00116
00117 #if defined(APOXI_COMPAT_2_3_0)
00118     virtual BOOLEAN WapResume(INT conn_id);
00119 #else
00120     virtual BOOLEAN ResumeWap(INT conn_id);
00121 #endif
00122
00131
00132 #if defined(APOXI_COMPAT_2_3_0)
00133     virtual  INT WapGetConnId();
00134 #else
00135     virtual  INT GetConnIdWap();
00136 #endif
00137
00141
00142 #if defined(APOXI_COMPAT_2_3_0)
00143     virtual WapSessionStatus WapGetSessionStatus() ;
00144 #else
00145     virtual WapSessionStatus GetSessionStatusWap() ;
00146 #endif
00147
00152
00153     virtual BOOLEAN AddRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert);
00154
00159
00160     virtual BOOLEAN ClearRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert);
00161
00167
00168     virtual BOOLEAN ReadRootCertificate(INT conn_id, UINT8** certData, UINT32* certLen);
00169
00177
00178     virtual BOOLEAN ReadUserCertificate(INT conn_id, UINT8** certData, UINT32* certLen, UINT8** certKey,UINT32* certKeyLen);
00179
00185
00186     virtual BOOLEAN AddUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert);
00187
00192
00193     virtual BOOLEAN ClearUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert);
00194
00195     virtual BOOLEAN GetCipherSuiteName (INT conn_id, const UINT8** pCipherSuiteName);
00196
00197
00198 protected:
00199
00200
00223
00224     virtual BOOLEAN DecodeMessage(const Message& msg,
00225                                   INT& conn_id,
00226                                   INT& requ_id,
00227                                   INT& status,
00228                                   WString& header,
00229                                   BinData** body,
00230                                   INT& more,
00231                                   INT& length,
00232                                   WString& url);
00233
00239
00240     virtual BOOLEAN OnMessage(const Message& msg)=0;
00241
00249
00250     virtual BOOLEAN OnPush(const Message& msg) = 0;
00251
00258
00259     virtual BOOLEAN SetWapPushReceived(const CHAR* header,
00260                                        const BinData* body);
00261
00262     private :
00263
00264         HttpWapMgr* m_http_Wap_mgr;
00265
00266     INT m_connection_id;
00267     WapSessionStatus  m_conn_status;
00268
00272
00273 #if defined(APOXI_COMPAT_2_3_0)
00274     BOOLEAN WapSetConnId(INT conn_id);
00275 #else
00276     BOOLEAN SetConnIdWap(INT conn_id);
00277 #endif
00278
00282
00283 #if defined(APOXI_COMPAT_2_3_0)
00284     BOOLEAN WapSetConnStatus(WapSessionStatus status);
00285 #else
00286     BOOLEAN SetConnStatusWap(WapSessionStatus status);
00287 #endif
00288
00289
00290
00291 };
00293 #endif  // WapHandler_hpp
00294
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.cpp File Reference

AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.cpp File Reference

#include "HttpWapPluginPreComp.hpp"
#include <AddOns/Services/ServiceBroker.hpp>
#include <Auxiliary/RamData.hpp>
#include "HttpWapMgrPlugin.hpp"

Include dependency graph for HttpWapMgrPlugin.cpp:

Generated on Tue Jan 24 16:28:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp File Reference

AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <Auxiliary/WString.hpp>
#include <Kernel/System.hpp>
#include <AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp>
#include <AddOns/HttpWapInterface/HttpWap/HttpWapErrorCodes.h>

Include dependency graph for HttpWapMgrPlugin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpWapMgrPlugin

Defines

#define | MAXREQUESTLIMIT 100

Generated on Tue Jan 24 16:28:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp Source File

AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifndef PluginHttpWapMgr_hpp
00010 #define PluginHttpWapMgr_hpp
00013
00014
00015 #include <Auxiliary/BinData.hpp>
00016 #include <Auxiliary/WString.hpp>
00017 #include <Kernel/System.hpp>
00018
00019 #include <AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp>
00020 #include <AddOns/HttpWapInterface/HttpWap/HttpWapErrorCodes.h>
00021
00022 #ifdef APOXI_WAP_STACK
00023 #include <Wap/Main/WapService.hpp>
00024 #include <Wap/Main/BrowserMsgTypes.hpp>
00025 #endif //APOXI_WAP_STACK
00026
00027
00028
00029
00030
00031 #define MAXREQUESTLIMIT 100
00032
00033
00034
00035 class HttpWapMgrPlugin:public HttpWapMgrBase
00036 {
00037
00038 public:
00039
00040
00047
00048     static  HttpWapMgrPlugin* GetInstance();
00049
00051     virtual ~HttpWapMgrPlugin();
00052
00053
00054
00055 protected:
00056
00057     static HttpWapMgrPlugin m_http_wap_plugin;
00058
00059
00060     INT  m_request_id_free_Slot[MAXREQUESTLIMIT];
00061
00062
00085
00086     virtual BOOLEAN DecodeMessage(const Message& msg,
00087                                   INT& conn_id,
00088                                   INT& requ_id,
00089                                   INT& status,
00090                                   WString& header,
00091                                   BinData** body,
00092                                   INT& more,
00093                                   INT& length,
00094                                   WString& url);
00095
00108
00109 #if defined(APOXI_COMPAT_2_3_0)
00110     virtual BOOLEAN HttpOpen(INT& conn_id, INT pr_id);
00111 #else
00112     virtual BOOLEAN OpenHttp(INT& conn_id, INT pr_id);
00113 #endif
00114
00129
00130 #if defined(APOXI_COMPAT_2_3_0)
00131     virtual BOOLEAN HttpRequestGet(INT conn_id,
00132                                    INT& requ_id,
00133                                    const CHAR* URL,
00134                                    const CHAR* header);
00135 #else
00136     virtual BOOLEAN RequestGetHttp(INT conn_id,
00137                                    INT& requ_id,
00138                                    const CHAR* URL,
00139                                    const CHAR* header);
00140 #endif
00141
00157
00158 #if defined(APOXI_COMPAT_2_3_0)
00159     virtual BOOLEAN HttpRequestHead(INT conn_id,
00160                                      INT& requ_id,
00161                                      const CHAR* URL,
00162                                      const CHAR* header);
00163 #else
00164     virtual BOOLEAN RequestHeadHttp(INT conn_id,
00165                                      INT& requ_id,
00166                                      const CHAR* URL,
00167                                      const CHAR* header);
00168 #endif
00169
00191
00192 #if defined(APOXI_COMPAT_2_3_0)
00193     virtual BOOLEAN HttpRequestPost(INT  conn_id,
00194                                      INT& requ_id,
00195                                      const CHAR* URL,
00196                                      const CHAR* header,
00197                                      BinData* body,
00198                                      INT more);
00199 #else
00200     virtual BOOLEAN RequestPostHttp(INT  conn_id,
00201                                      INT& requ_id,
00202                                      const CHAR* URL,
00203                                      const CHAR* header,
00204                                      BinData* body,
00205                                      INT more);
00206 #endif
00207
00223
00224 #if defined(APOXI_COMPAT_2_3_0)
00225      virtual BOOLEAN HttpRequestPostData(INT conn_id,
00226                                          INT& requ_id,
00227                                          BinData* body,
00228                                          INT more);
00229 #else
00230      virtual BOOLEAN RequestPostDataHttp(INT conn_id,
00231                                          INT& requ_id,
00232                                          BinData* body,
00233                                          INT more);
00234 #endif
00235
00247
00248 #if defined(APOXI_COMPAT_2_3_0)
00249      virtual BOOLEAN HttpCancel(INT conn_id, INT requ_id);
00250 #else
00251      virtual BOOLEAN CancelHttp(INT conn_id, INT requ_id);
00252 #endif
00253
00264
00265 #if defined(APOXI_COMPAT_2_3_0)
00266      virtual BOOLEAN HttpClose(INT conn_id);
00267 #else
00268      virtual BOOLEAN CloseHttp(INT conn_id);
00269 #endif
00270
00281
00282 #if defined(APOXI_COMPAT_2_3_0)
00283      virtual BOOLEAN HttpSuspend(INT conn_id);
00284 #else
00285      virtual BOOLEAN SuspendHttp(INT conn_id);
00286 #endif
00287
00298
00299 #if defined(APOXI_COMPAT_2_3_0)
00300      virtual BOOLEAN HttpResume(INT conn_id);
00301 #else
00302      virtual BOOLEAN ResumeHttp(INT conn_id);
00303 #endif
00304
00305 #ifdef APOXI_WAP_STACK
00306
00312 #if defined(APOXI_COMPAT_2_3_0)
00313      virtual BOOLEAN HttpGetSessionInfo(INT conn_id, INT& request_id);
00314 #else
00315      virtual BOOLEAN GetSessionInfoHttp(INT conn_id, INT& request_id);
00316 #endif
00317
00327     virtual BOOLEAN DecodeGetSessionInfoResponseMessage(const Message& msg,
00328                             INT& result, INT& conn_id,
00329                                           INT& connection_type,
00330                                           String& cipher_info,
00331                                           CertificateInfo_t& certificate);
00332
00333 #endif //APOXI_WAP_STACK
00334
00335
00340
00341      virtual BOOLEAN IsMessageForMe();
00342
00349
00350 #if defined(APOXI_COMPAT_2_3_0)
00351      virtual BOOLEAN WapGetSessionStatus() ;
00352 #else
00353      virtual BOOLEAN GetSessionStatusWap() ;
00354 #endif
00355
00356
00375
00376 #if defined(APOXI_COMPAT_2_3_0)
00377      virtual BOOLEAN WapRegister(const INT& conn_id,
00378                                  INT pr_id,
00379                                  WString& mime,
00380                                  INT app_id);
00381 #else
00382      virtual BOOLEAN RegisterWap(const INT& conn_id,
00383                                  INT pr_id,
00384                                  WString& mime,
00385                                  INT app_id);
00386 #endif
00387
00388
00394
00395 #if defined(APOXI_COMPAT_2_3_0)
00396      virtual BOOLEAN WapResume(INT conn_id);
00397 #else
00398      virtual BOOLEAN ResumeWap(INT conn_id);
00399 #endif
00400
00411
00412 #if defined(APOXI_COMPAT_2_3_0)
00413      virtual BOOLEAN WapUnregister(const INT& conn_id);
00414 #else
00415      virtual BOOLEAN UnregisterWap(const INT& conn_id);
00416 #endif
00417
00422
00423 #if defined(APOXI_COMPAT_2_3_0)
00424      virtual BOOLEAN WapSuspend(INT conn_id);
00425 #else
00426      virtual BOOLEAN SuspendWap(INT conn_id);
00427 #endif
00428
00435
00436     BOOLEAN GetFreeRequestId(INT& request_id);
00437
00438
00443
00444     void ReleaseRequestId(INT& request_id);
00445
00450
00451     virtual BOOLEAN AddRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert);
00452
00457
00458     virtual BOOLEAN ClearRootCertificate(INT conn_id, const COMM_ROOT_CERT *pRootCert);
00459
00465
00466     virtual BOOLEAN ReadRootCertificate(INT conn_id, UINT8** certData, UINT32* certLen);
00467
00475
00476     virtual BOOLEAN ReadUserCertificate(INT conn_id, UINT8** certData, UINT32* certLen, UINT8** certKey,UINT32* certKeyLen);
00477
00483
00484     virtual BOOLEAN AddUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert);
00485
00490
00491     virtual BOOLEAN ClearUserCertificate(INT conn_id, const COMM_USER_CERT *pUserCert);
00492
00493     virtual BOOLEAN GetCipherSuiteName (INT conn_id, const UINT8** pCipherSuiteName);
00494
00495
00496     private:
00497
00498     friend class HttpWapMgr;
00499
00501     HttpWapMgrPlugin();
00502
00503
00504
00505 };
00506
00508 #endif  //PluginHttpWapMgr
00509
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWapPlugin/HttpWapPluginPreComp.cpp File Reference

AddOns/HttpWapInterface/HttpWapPlugin/HttpWapPluginPreComp.cpp File Reference

#include "HttpWapPluginPreComp.hpp"

Include dependency graph for HttpWapPluginPreComp.cpp:

Generated on Tue Jan 24 16:28:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWapPlugin/HttpWapPluginPreComp.hpp File Reference

AddOns/HttpWapInterface/HttpWapPlugin/HttpWapPluginPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for HttpWapPluginPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:28:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/HttpWapPlugin/HttpWapPluginPreComp.hpp Source File

AddOns/HttpWapInterface/HttpWapPlugin/HttpWapPluginPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Asc/Lib.hpp>
00012
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/HttpWapProfileMgmtPreComp.cpp File Reference

AddOns/HttpWapInterface/WapProfileMgmt/HttpWapProfileMgmtPreComp.cpp File Reference

#include "HttpWapProfileMgmtPreComp.hpp"

Include dependency graph for HttpWapProfileMgmtPreComp.cpp:

Generated on Tue Jan 24 16:28:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/HttpWapProfileMgmtPreComp.hpp File Reference

AddOns/HttpWapInterface/WapProfileMgmt/HttpWapProfileMgmtPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for HttpWapProfileMgmtPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:28:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/HttpWapProfileMgmtPreComp.hpp Source File

AddOns/HttpWapInterface/WapProfileMgmt/HttpWapProfileMgmtPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Asc/Lib.hpp>
00012
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.cpp File Reference

AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.cpp File Reference

#include "HttpWapProfileMgmtPreComp.hpp"
#include "WapProfile.hpp"
#include <Socket/DataConnProfileManager.hpp>

Include dependency graph for WapProfile.cpp:

Generated on Tue Jan 24 16:29:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp File Reference

AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp File Reference

#include <ApoxiLib.hpp>
#include <Socket/DataConnProfile.hpp>
#include <Socket/DataConnManager.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include <Afs/Registry.hpp>
#include <Afs/RegistryTypes.hpp>

Include dependency graph for WapProfile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WapProfile
struct | WapProfile::Ipv4E164
struct | WapProfile::PxLogicalCharacs
struct | WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
struct | WapProfile::PxLogicalCharacs::PxPhysicalCharacs
struct | WapProfile::PxLogicalCharacs::PxPortCharacs

Defines

#define | WapProfile_hpp

Typedefs

typedef UINT8 | WapProfileId

Define Documentation

#define WapProfile_hpp

Generated on Tue Jan 24 16:29:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp Source File

AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(WapProfile_hpp)
00010
00011 #define WapProfile_hpp
00012
00015
00016
00017 #include <ApoxiLib.hpp>
00018 #include <Socket/DataConnProfile.hpp>
00019 #include <Socket/DataConnManager.hpp>
00020
00021 #include <Auxiliary/DataItem.hpp>
00022 #include <Auxiliary/RegBlobObject.hpp>
00023 #include <Afs/Registry.hpp>
00024 #include <Afs/RegistryTypes.hpp>
00025
00026 typedef UINT8 WapProfileId;
00027
00028
00055 class WapProfile {
00056     public:
00057
00064         enum PxAddrType {
00065             IPv4,
00066             E164,
00067             Invalid
00068         };
00069
00079         enum PortService {
00080             WapConnectionless,
00081             WapSession,
00082             WapSecureConnectionless,
00083             WapSecureSession,
00084             WapWtaSecureSession,
00085             WapWtaSecureConnectionless,
00086             InvalidService
00087         };
00088
00095         enum WapAuthMethod {
00096             AuthMethodHttpBasic,
00097             AuthMethodHttpDigest,
00098             AuthMethodWtlsSs,
00099             InvalidMethod
00100         };
00101
00122         enum ProfileConstants {
00123                 c_invalid_id = 255,
00124                 c_invalid_set_id = 255,
00125                 c_max_proxy_id_len = 32,
00126                 c_max_proxy_p_id_len = 32,
00127                 c_max_proxy_name_len = 16,
00128                 c_max_profile_name_len1 = 16,
00129                 c_max_startpage_len = 64,
00130                 c_max_username_len = 16,
00131                 c_max_pwd_len = 16,
00132                 c_max_url_len1 = 255,
00133                 c_dataconn_profile_count = 5,
00134                 c_max_physical_set = 5,
00135                 c_max_auth_set = 5,
00136                 c_max_port_set = 5,
00137                 c_max_phy_port_set = 5,
00138                 c_max_domain = 4,
00139                 c_max_port_services = 5,
00140                 c_max_wap_profile_count = 5
00141         };
00142
00143         struct Ipv4E164 {
00144             IpAddr ipv4_address;
00145             WString e164_number;
00146             PxAddrType type;
00147         };
00148
00149         struct PxLogicalCharacs {
00150             PxLogicalCharacs() : m_wsp_version("1.2")
00151             {
00152             }
00153
00154             WString         m_proxy_id;
00155             WString         m_proxy_p_id;
00156             WString         m_proxy_name;
00157             WString         m_domain[c_max_domain];
00158             BOOLEAN         m_proxy_trusted;
00159             WString         m_startpage;
00160             WString         m_startpage_user_name;
00161             WString         m_startpage_pwd;
00162             WString         m_wsp_version;
00163             BOOLEAN         m_push_enabled;
00164
00165             struct PxAuthInfoCharacs : public Linkable<PxAuthInfoCharacs> {
00166                 WapAuthMethod   m_proxy_auth_type;
00167                 WString         m_auth_user_name;
00168                 WString         m_auth_pwd;
00169                 UINT8           m_auth_set_id;
00170             };
00171             LinkedList<PxAuthInfoCharacs> m_list_pxauthinfo;
00172
00173             struct PxPortCharacs : public Linkable<PxPortCharacs> {
00174                 UINT32          m_port;
00175                 PortService     m_port_service[c_max_port_services];
00176                 UINT8           m_port_set_id;
00177             };
00178             LinkedList<PxPortCharacs> m_list_port;
00179
00180             struct PxPhysicalCharacs : public Linkable<PxPhysicalCharacs> {
00181                 WString         m_phy_proxy_id;
00182                 WString         m_phy_domain[c_max_domain];
00183                 Ipv4E164        m_proxy_addr;
00184                 UINT8           m_physical_set_id;
00185                 UINT8           m_to_nap_id;
00186                 LinkedList<PxPortCharacs> m_list_phy_port;
00187                 BOOLEAN         m_phy_push_enabled;
00188             };
00189             LinkedList<PxPhysicalCharacs> m_list_pxphysical;
00190
00191         }; // PxLogicalCharacs
00192
00193     WapProfile();
00194     ~WapProfile();
00195
00209     BOOLEAN SetProxyId(const CHAR* proxy_id) ;
00210
00218     const WCHAR* GetProxyId() const ;
00219
00231     BOOLEAN SetProxyProviderId(const CHAR* proxy_p_id) ;
00232
00242     const WCHAR* GetProxyProviderId() const ;
00243
00251     BOOLEAN SetProxyName(const CHAR* name) ;
00252
00258     const WCHAR* GetProxyName() const ;
00259
00270     BOOLEAN SetDomain(INT number, const CHAR* domain) ;
00271
00280     const WCHAR* GetDomain(INT number) const ;
00281
00289     BOOLEAN SetTrust(BOOLEAN trust) ;
00290
00296     BOOLEAN GetTrust() const ;
00297
00306     BOOLEAN SetStartpage(const CHAR* startpage) ;
00307
00314     const WCHAR* GetStartpage() const ;
00315
00323     BOOLEAN SetStartpageUsername(const CHAR* username) ;
00324
00330     const WCHAR* GetStartpageUsername() const ;
00331
00339     BOOLEAN SetStartpagePassword(const CHAR* password) ;
00340
00346     const WCHAR* GetStartpagePassword() const ;
00347
00355     BOOLEAN SetWspVersion(const CHAR* version) ;
00356
00361     const WCHAR* GetWspVersion() const ;
00362
00369     BOOLEAN SetPushEnabled(BOOLEAN enable) ;
00370
00376     BOOLEAN IsPushEnabled() const ;
00377
00391     BOOLEAN SetAuthenticationMethod(WapAuthMethod method,
00392                                             INT   set = 0) ;
00393
00398     WapAuthMethod GetAuthenticationMethod(INT set = 0) const ;
00399
00411     BOOLEAN SetAuthenticationUsername(  const CHAR* username,
00412                                                 INT   set = 0) ;
00413
00419     const WCHAR* GetAuthenticationUsername(INT set = 0) const ;
00420
00432     BOOLEAN SetAuthenticationPassword(  const CHAR* password,
00433                                                 INT   set = 0) ;
00434
00440     const WCHAR* GetAuthenticationPassword(INT set = 0) const ;
00441
00442
00443
00459     BOOLEAN SetPortNumber(UINT port, INT set = 0) ;
00460
00465     UINT GetPortNumber(INT set = 0) const ;
00466
00475     BOOLEAN SetPortService( UINT port, PortService    service) ;
00476
00483     PortService GetPortService(UINT port) const ;
00484
00485
00486
00506     BOOLEAN SetPhysicalProxyId( const CHAR* proxy_id, INT   set = 0) ;
00507
00520     const WCHAR* GetPhysicalProxyId(INT set = 0) const ;
00521
00536     BOOLEAN SetPhysicalDomain(INT number, const CHAR* domain, INT set = 0) ;
00537
00550     const WCHAR* GetPhysicalDomain(INT number, INT set = 0) const ;
00551
00566     BOOLEAN SetPhysicalProxyAddress(const CHAR* address, PxAddrType addr_type,
00567                                                          INT set = 0) ;
00568
00584     const Ipv4E164& GetPhysicalProxyAddress(INT set = 0) const ;
00585
00596     BOOLEAN SetPhysicalPushEnabled(BOOLEAN pushenable, INT set = 0) ;
00597
00607     BOOLEAN IsPhysicalPushEnabled(INT set = 0) const ;
00608
00619     BOOLEAN SetDataConnId(INT id, INT set = 0) ;
00620
00629     INT GetDataConnId(INT set = 0) const ;
00630
00645     BOOLEAN SetPhysicalPortNumber(UINT port, INT physet = 0, INT set = 0) ;
00646
00659     UINT GetPhysicalPortNumber(INT physet = 0, INT set = 0) const ;
00660
00673     BOOLEAN SetPhysicalPortService( UINT port, PortService  service,
00674                                                 INT physet = 0) ;
00675
00686     PortService GetPhysicalPortService(UINT port, INT physet = 0) const ;
00687
00700     INT GetNoOfAuthorizationSets() const ;
00701
00708     INT GetNoOfPortSets() const ;
00709
00716     INT GetNoOfPhysicalSets() const ;
00717
00728     INT GetNoOfPhysicalPortSets(INT physet = 0) const ;
00729
00739     INT GetNoOfAuthorizationSetsSupported() const ;
00740
00750     INT GetNoOfPortSetsSupported() const ;
00751
00761     INT GetNoOfPhysicalSetsSupported() const ;
00762
00776     INT GetNoOfPhysicalPortSetsSupported(INT physet = 0) const ;
00777
00778
00788     INT AddAuthorizationSet() ;
00789
00799     INT AddPortSet() ;
00800
00810     INT AddPhysicalSet() ;
00811
00825     INT AddPhysicalPortSet(INT physet = 0) ;
00826
00838     BOOLEAN RemoveAuthorizationSet(INT set = 0) ;
00839
00851     BOOLEAN RemovePortSet(INT set = 0) ;
00852
00865     BOOLEAN RemovePhysicalSet(INT set = 1) ;
00866
00882     BOOLEAN RemovePhysicalPortSet(INT physet = 0, INT set = 0) ;
00883
00884
00896     BOOLEAN SetActiveAuthorizationSet(INT set = 0) ;
00897
00905     INT GetActiveAuthorizationSet() const ;
00906
00918     BOOLEAN SetActivePortSet(INT set = 0) ;
00919
00928     INT GetActivePortSet() const ;
00929
00941     BOOLEAN SetActivePhysicalSet(INT set = 0) ;
00942
00951     INT GetActivePhysicalSet() const ;
00952
00968     BOOLEAN SetActivePhysicalPortSet(INT physet = 0, INT set = 0) ;
00969
00982     INT GetActivePhysicalPortSet(INT physet = 0) const ;
00983
00984
00998     WapProfileId GetProfileId() const ;
00999
01008     BOOLEAN SetProfileName(const CHAR* name) ;
01009
01018     const WCHAR* GetProfileName() const ;
01019
01020
01028     BOOLEAN SetProfileWriteable(BOOLEAN writeable) ;
01029
01035     BOOLEAN IsProfileWriteable() const ;
01036
01037
01038     /* WapProfileMgr is made friend here because Memory accessing methods have
01039         protected access and these methods are being used by the manager class
01040         to store or retrieve or delete profile from/to memory. These methods are
01041         protected because inherited class can in turn again override these. */
01042     friend class WapProfileMgr;
01043
01044     protected:
01045
01057     BOOLEAN SetProfileId(INT id) ;
01058
01059
01069     BOOLEAN Load(WapProfileId prof_id) ;
01070
01071
01078     BOOLEAN Save() ;
01079
01080
01090     static BOOLEAN Delete(WapProfileId prof_id);
01091
01103     static BOOLEAN LoadProfileName(WapProfileId prof_id, WString &prof_name);
01104
01105
01107     private:
01108
01109     /* Copy Constructor and Overloaded Assignment operator are made private in
01110         order to prevent copy/assignment access to the user */
01111     WapProfile(const WapProfile&);
01112     WapProfile& operator=(const WapProfile&);
01113
01128     PxLogicalCharacs::PxAuthInfoCharacs*
01129                                 GetAuthenticationSetPtr(INT set=0) const ;
01130     PxLogicalCharacs::PxPortCharacs* GetPortSetPtr(INT set=0) const ;
01131     PxLogicalCharacs::PxPhysicalCharacs* GetPhysicalSetPtr(INT set=0) const ;
01132     PxLogicalCharacs::PxPortCharacs*
01133                 GetPhysicalPortSetPtr(INT physet = 0, INT set=0) const ;
01134
01135
01151     BOOLEAN GetFreeAuthSetId(UINT8 &set_id) ;
01152     BOOLEAN GetFreePortSetId(UINT8 &set_id) ;
01153     BOOLEAN GetFreePhysicalId(UINT8 &set_id) ;
01154     BOOLEAN GetFreePhysicalPortSetId(UINT8 &set_id, INT physet = 0) ;
01155
01157     private:
01158
01159         WapProfileId m_profile_id   ;   // ID of this Wap Profile
01160         WString m_profile_name; // User Given Name of this profile
01161         BOOLEAN m_writeable;    // Whether the profile can be modified
01162
01163         /* Array to denote which set numbers are in use. If a set with set
01164             number 0 exists, then 0th element of this array will be filled
01165             with a '1' else a '0'*/
01166         UINT8 m_auth_setids[c_max_auth_set];
01167         UINT8 m_port_setids[c_max_port_set];
01168         UINT8 m_phy_setids[c_max_physical_set];
01169         UINT8 m_phy_port_setids[c_max_physical_set]
01170                                              [c_max_phy_port_set];
01171
01172         // This holds the set number of the active characteristic set
01173         UINT8 m_active_auth_set;
01174         UINT8 m_active_port_set;
01175         UINT8 m_active_phy_set;
01176         UINT8 m_active_phy_port_set[c_max_physical_set];
01177
01178         PxLogicalCharacs* m_px_logical;
01179
01180 };
01181
01183
01184 #endif  // WapProfile_hpp
01185
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.cpp File Reference

AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.cpp File Reference

#include "HttpWapProfileMgmtPreComp.hpp"
#include "WapProfileMgr.hpp"

Include dependency graph for WapProfileMgr.cpp:

Generated on Tue Jan 24 16:29:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp File Reference

AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp File Reference

#include <AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp>

Include dependency graph for WapProfileMgr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WapProfileMgr
struct | WapProfileMgr::WapProfileInfo

Defines

#define | WapProfileMgr_hpp

Define Documentation

#define WapProfileMgr_hpp

Generated on Tue Jan 24 16:30:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp Source File

AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(WapProfileMgr_hpp)
00010
00011 #define WapProfileMgr_hpp
00012
00015
00016 #include <AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp>
00017
00018
00032 class WapProfileMgr {
00033 public:
00034     struct WapProfileInfo : public Linkable<WapProfileInfo> {
00036     WapProfileId m_prof_id;
00038     WString m_prof_name;
00039     };
00040
00042     ~WapProfileMgr();
00043
00049     static WapProfileMgr& GetInstance()
00050     {
00051         return m_wap_prof_mgr;
00052     }   // GetInstance
00053
00054
00055
00063     BOOLEAN Init()
00064     {
00065         m_active_profile_id = WapProfile::c_invalid_id;
00066         return LoadProfileInfo();
00067     }   // Init
00068
00069
00077     const LinkedList<WapProfileInfo>& GetWapProfileInfo() const
00078     {
00079         return m_profileinfo_list;
00080     }   // GetWapProfileInfo
00081
00082
00094     BOOLEAN CreateWapProfile(WapProfile &profile);
00095
00096
00109     BOOLEAN GetWapProfile(WapProfileId prof_id, WapProfile &profile);
00110
00111
00121     BOOLEAN SaveWapProfile(WapProfile &profile);
00122
00123
00133     BOOLEAN DeleteWapProfile(WapProfileId prof_id);
00134
00135
00143     BOOLEAN SetActiveWapProfile(WapProfileId active_prof_id);
00144
00145
00151     WapProfileId GetActiveWapProfileId()
00152     {
00153         return m_active_profile_id;
00154     }   // GetActiveWapProfileId
00155
00156
00158 private:
00159
00161     WapProfileMgr();
00162
00164
00166     BOOLEAN LoadProfileInfo();
00167
00169     BOOLEAN AddProfileInfo(WapProfileId prof_id, WString prof_name);
00170
00172     BOOLEAN UpdateProfileInfo(WapProfileId prof_id, WString prof_name);
00173
00175     BOOLEAN RemoveProfileInfo(WapProfileId prof_id);
00176
00178     BOOLEAN IsProfileIdValid(WapProfileId prof_id);
00179
00180
00182 private:
00183
00185     BOOLEAN m_init;
00186
00188     static WapProfileMgr m_wap_prof_mgr;
00189
00191     UINT8 m_prof_id_gen_array[WapProfile::c_max_wap_profile_count];
00192
00194     WapProfileId m_active_profile_id;
00195
00197     LinkedList<WapProfileInfo> m_profileinfo_list;
00198
00199 }; // WapProfileMgr
00200
00202 #endif  // WapProfileMgr_hpp
00203
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/jpeglib/jmemnobs_APOXI.cpp File Reference

AddOns/jpeglib/jmemnobs_APOXI.cpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/Os/OsClass.hpp>
#include "jinclude.h"
#include "jpeglib.h"
#include "jmemsys.h"

Include dependency graph for jmemnobs_APOXI.cpp:

Defines

#define | JPEG_INTERNALS

Functions

void | jpeg_free_large (j_common_ptr cinfo, void FAR *object, size_t sizeofobject)
void | jpeg_free_small (j_common_ptr cinfo, void *object, size_t sizeofobject)
void FAR * | jpeg_get_large (j_common_ptr cinfo, size_t sizeofobject)
void * | jpeg_get_small (j_common_ptr cinfo, size_t sizeofobject)
long | jpeg_mem_available (j_common_ptr cinfo, long min_bytes_needed, long max_bytes_needed, long already_allocated)
long | jpeg_mem_init (j_common_ptr cinfo)
void | jpeg_mem_term (j_common_ptr cinfo)
void | jpeg_open_backing_store (j_common_ptr cinfo, backing_store_ptr info, long total_bytes_needed)

Define Documentation

#define JPEG_INTERNALS

Function Documentation

void jpeg_free_large | ( | j_common_ptr | cinfo,
 |  | void FAR * | object,
 |  | size_t | sizeofobject
 | ) |

void jpeg_free_small | ( | j_common_ptr | cinfo,
 |  | void * | object,
 |  | size_t | sizeofobject
 | ) |

void FAR* jpeg_get_large | ( | j_common_ptr | cinfo,
 |  | size_t | sizeofobject
 | ) |

void* jpeg_get_small | ( | j_common_ptr | cinfo,
 |  | size_t | sizeofobject
 | ) |

long jpeg_mem_available | ( | j_common_ptr | cinfo,
 |  | long | min_bytes_needed,
 |  | long | max_bytes_needed,
 |  | long | already_allocated
 | ) |

long jpeg_mem_init ( j_common_ptr cinfo )

void jpeg_mem_term ( j_common_ptr cinfo )

void jpeg_open_backing_store | ( | j_common_ptr | cinfo,
 |  | backing_store_ptr | info,
 |  | long | total_bytes_needed
 | ) |

Generated on Tue Jan 24 16:30:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsArgs.cpp File Reference

AddOns/Lcs/3GPP/LcsArgs.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsArgs.hpp"

Include dependency graph for LcsArgs.cpp:

Generated on Tue Jan 24 16:30:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsArgs.hpp File Reference

AddOns/Lcs/3GPP/LcsArgs.hpp File Reference

#include <Kernel/Message.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for LcsArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsMolrResultArg
class | LocationNotifInvokeArg

Defines

#define | AddOns_Lcs_3GPP_LcsArgs_hpp

Define Documentation

#define AddOns_Lcs_3GPP_LcsArgs_hpp

Generated on Tue Jan 24 16:30:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsArgs.hpp Source File

AddOns/Lcs/3GPP/LcsArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\3GPP\LcsArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_3GPP_LcsArgs_hpp)
00016 #define AddOns_Lcs_3GPP_LcsArgs_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class LocationNotifInvokeArg
00028     ====================================================================== */
00029
00031 class LocationNotifInvokeArg : public StackMsgArgument {
00032     friend class LcsStackMsgArgsDestroyTableNode;
00033     public:
00034         LocationNotifInvokeArg(const TI_PD& ti_pd, const LcsNotificationType& notif_type, const LocationType& location_type, const ClientInfo& client_info);
00035         LocationNotifInvokeArg();
00036         ~LocationNotifInvokeArg();
00037
00038         static const LocationNotifInvokeArg& Cast(const StackMsgArgument& arg);
00039         const TI_PD& GetTiPd() const { return m_ti_pd; }
00040         const LcsNotificationType& GetNotifType() const { return m_notif_type; }
00041         const LocationType& GetLocationType() const { return m_location_type; }
00042         const ClientInfo& GetClientInfo() const { return m_client_info; }
00043
00044         enum  {
00045             ID = 4215
00046             };
00047
00048     private:
00049
00050         static void Destroy(StackMsgArgument* arg) { delete ((LocationNotifInvokeArg*) arg); }
00051
00052         TI_PD m_ti_pd;
00053         LcsNotificationType m_notif_type;
00054         LocationType m_location_type;
00055         ClientInfo m_client_info;
00056
00057     };
00058
00059 // Inline definitions
00060 inline const LocationNotifInvokeArg& LocationNotifInvokeArg::Cast(const StackMsgArgument& arg) {
00061     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to LocationNotifInvokeArg!\n");
00062     return ((LocationNotifInvokeArg &) arg);
00063 }
00064
00065
00066
00067 /*  ======================================================================
00068     Class LcsMolrResultArg
00069     ====================================================================== */
00070
00072 class LcsMolrResultArg : public StackMsgArgument {
00073     friend class LcsStackMsgArgsDestroyTableNode;
00074     public:
00075         LcsMolrResultArg(BYTE ti_pd, const LocationEstimate& location_estimate);
00076         LcsMolrResultArg();
00077         ~LcsMolrResultArg();
00078
00079         static const LcsMolrResultArg& Cast(const StackMsgArgument& arg);
00080         BYTE GetTiPd() const { return m_ti_pd; }
00081         const LocationEstimate& GetLocationEstimate() const { return m_location_estimate; }
00082
00083         enum  {
00084             ID = 4216
00085             };
00086
00087     private:
00088
00089         static void Destroy(StackMsgArgument* arg) { delete ((LcsMolrResultArg*) arg); }
00090
00091         BYTE m_ti_pd;
00092         LocationEstimate m_location_estimate;
00093
00094     };
00095
00096 // Inline definitions
00097 inline const LcsMolrResultArg& LcsMolrResultArg::Cast(const StackMsgArgument& arg) {
00098     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to LcsMolrResultArg!\n");
00099     return ((LcsMolrResultArg &) arg);
00100 }
00101
00102
00103 #endif // AddOns_Lcs_3GPP_LcsArgs_hpp
00104
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsMsgProcessor.cpp File Reference

AddOns/Lcs/3GPP/LcsMsgProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsMsgProcessor.hpp"

Include dependency graph for LcsMsgProcessor.cpp:

Generated on Tue Jan 24 16:30:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsMsgProcessor.hpp File Reference

AddOns/Lcs/3GPP/LcsMsgProcessor.hpp File Reference

#include <Apc/SignalHandler/StackMsgProcessor.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>
#include <AddOns/Lcs/Common/LcsDecls.hpp>

Include dependency graph for LcsMsgProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsMsgProcessor
Forms SDL signal from the parameters sent and sends it to MN. More...

Defines

#define | AddOns_Lcs_3GPP_LcsMsgProcessor_hpp

Define Documentation

#define AddOns_Lcs_3GPP_LcsMsgProcessor_hpp

Generated on Tue Jan 24 16:30:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsMsgProcessor.hpp Source File

AddOns/Lcs/3GPP/LcsMsgProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_3GPP_LcsMsgProcessor_hpp)
00010 #define AddOns_Lcs_3GPP_LcsMsgProcessor_hpp
00011
00012 #include <Apc/SignalHandler/StackMsgProcessor.hpp>
00013 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00014 #include <AddOns/Lcs/Common/LcsDecls.hpp>
00015
00017 class LcsMsgProcessor : public StackMsgProcessor
00018 {
00020     public:
00021
00023         static void ProcessVerifResp(TI_PD ti_pd, VerificationResponse verif_resp);
00024
00026         static void ProcessMolrReq( TI_PD ti_pd,
00027                                     MolrType molr_type,
00028                                     LocationMethod location_method,
00029                                     const LcsQos& lcs_qos,
00030                                     const ClientId& client_id,
00031                                     const MlcNumber& mlc_number);
00032
00033 }; // LcsMsgProcessor
00034
00035 #endif // AddOns_Lcs_3GPP_LcsMsgProcessor_hpp
00036
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsProviderImpl.cpp File Reference

AddOns/Lcs/3GPP/LcsProviderImpl.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsProviderImpl.hpp"
#include "LcsMsgProcessor.hpp"
#include "LcsSignalMapTableNode.hpp"
#include "LcsArgs.hpp"
#include "LcsStackMsgArgs.hpp"
#include <AddOns/Lcs/Common/LcsCommonArgs.hpp>
#include <AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>
#include <AddOns/Lcs/Common/LcsReqProcessor.hpp>
#include <AddOns/Lcs/Common/LcsUtils.hpp>
#include <AddOns/Lcs/Common/LcsDecls.hpp>
#include <Apc/SsErrorCode.hpp>

Include dependency graph for LcsProviderImpl.cpp:

Generated on Tue Jan 24 16:30:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsProviderImpl.hpp File Reference

AddOns/Lcs/3GPP/LcsProviderImpl.hpp File Reference

#include <AddOns/Lcs/Common/LcsProviderImplBase.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for LcsProviderImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsProviderImpl
This class implements the 3GPP protocol specific methods. More...

Defines

#define | AddOns_Lcs_3GPP_LcsProviderImpl_hpp

Define Documentation

#define AddOns_Lcs_3GPP_LcsProviderImpl_hpp

Generated on Tue Jan 24 16:30:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsProviderImpl.hpp Source File

AddOns/Lcs/3GPP/LcsProviderImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_3GPP_LcsProviderImpl_hpp)
00010 #define AddOns_Lcs_3GPP_LcsProviderImpl_hpp
00011
00012 #include <AddOns/Lcs/Common/LcsProviderImplBase.hpp>
00013 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00014
00015 class SsErrorCode;
00016
00018 class LcsProviderImpl : public LcsProviderImplBase, public StackMsgDispatcher
00019 {
00020     typedef LcsProviderImplBase Base1;
00021     typedef StackMsgDispatcher Base2;
00022
00024     public:
00025
00027         virtual ~LcsProviderImpl();
00028
00030         static LcsProviderImpl* GetInstance();
00031
00033         static void ReleaseInstance();
00034
00036         virtual void Init();
00037
00039         virtual LcsErrorCode SendVerificationResult(UINT16 invoke_id, BOOLEAN user_response);
00040
00045         virtual LcsErrorCode TransferLocationReq(MolrType molr_type,
00046                                                 LocationMethod location_method,
00047                                                 const LcsMmiQos& lcs_mmi_qos,
00048                                                 const ClientId& client_id,
00049                                                 const MlcNumber& mlc_number,
00050                                                 INT32 repeat_interval);
00051
00053         virtual void OnTimeOut(LcsTimerType timer_type);
00054
00056         void SendEndReq();
00057
00058
00060     protected:
00061
00063         virtual BOOLEAN OnMessage(const Message& msg);
00064
00066         BOOLEAN OnLocationNotifInvoke(const StackMsgArgument& arg);
00067
00069         BOOLEAN OnLocationResponse(const StackMsgArgument& arg);
00070
00072 //      BOOLEAN OnSsFacilityRej(const StackMsgArgument& arg);
00073
00075         BOOLEAN OnSsError(const StackMsgArgument& arg);
00076
00078         virtual BOOLEAN OnAbortResponse(const StackMsgArgument& arg);
00079
00080
00082     private:
00083
00085         LcsProviderImpl();
00086
00088         void ProcessMolr(const MolrInfo* molr_info);
00089
00091         LcsErrorCode GetLcsError(const SsErrorCode& ss_err) const;
00092
00093
00095     private:
00096
00098         static LcsProviderImpl* m_lcs_impl;
00099
00101         BYTE m_ti_pd_molr;
00102
00104         static const StackMsgArgMap<LcsProviderImpl> m_arg_map[];
00105
00110         StackMsgArgMapContainer<LcsProviderImpl> m_arg_map_container;
00111
00112 }; // LcsProviderImpl
00113
00114 #endif // Apoxi_Lcs_LcsProviderImpl_hpp
00115
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsSignalMapTableNode.cpp File Reference

AddOns/Lcs/3GPP/LcsSignalMapTableNode.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsSignalMapTableNode.hpp"
#include "LcsSignalProcessor.hpp"

Include dependency graph for LcsSignalMapTableNode.cpp:

Generated on Tue Jan 24 16:31:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsSignalMapTableNode.hpp File Reference

AddOns/Lcs/3GPP/LcsSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for LcsSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsSignalMapTableNode

Defines

#define | AddOns_Lcs_3GPP_LcsSignalMapTable_hpp

Define Documentation

#define AddOns_Lcs_3GPP_LcsSignalMapTable_hpp

Generated on Tue Jan 24 16:31:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsSignalMapTableNode.hpp Source File

AddOns/Lcs/3GPP/LcsSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_3GPP_LcsSignalMapTable_hpp)
00010 #define AddOns_Lcs_3GPP_LcsSignalMapTable_hpp
00011
00012 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00013
00018 class LcsSignalMapTableNode : public SignalMapTableNode
00019 {
00020     typedef SignalMapTableNode Base;
00021
00023     public:
00024
00026         ~LcsSignalMapTableNode();
00027
00029         static LcsSignalMapTableNode* GetInstance();
00030
00032         static void ReleaseInstance();
00033
00034
00036     private:
00037
00039         LcsSignalMapTableNode();
00040
00041
00043     private:
00044
00046         static LcsSignalMapTableNode* m_node;
00047
00049         static const SignalMapTableEntry m_signal_map_table[];
00050
00051 }; // LcsSignalMapTableNode
00052
00053 #endif  // Apoxi_Lcs_LcsSignalMapTable_hpp
00054
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsSignalProcessor.cpp File Reference

AddOns/Lcs/3GPP/LcsSignalProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsSignalProcessor.hpp"
#include "LcsArgs.hpp"
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for LcsSignalProcessor.cpp:

Generated on Tue Jan 24 16:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsSignalProcessor.hpp File Reference

AddOns/Lcs/3GPP/LcsSignalProcessor.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsSignalProcessor

Defines

#define | AddOns_Lcs_3GPP_LcsSignalProcessor_hpp

Define Documentation

#define AddOns_Lcs_3GPP_LcsSignalProcessor_hpp

Generated on Tue Jan 24 16:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsSignalProcessor.hpp Source File

AddOns/Lcs/3GPP/LcsSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_3GPP_LcsSignalProcessor_hpp)
00010 #define AddOns_Lcs_3GPP_LcsSignalProcessor_hpp
00011
00016 class LcsSignalProcessor
00017 {
00019     public:
00020
00022         static void PostMtlrIndReceived(const ProcessPtr& process_ptr);
00023
00028         static void PostMolrResult(const ProcessPtr& process_ptr);
00029
00030 }; // LcsSignalProcessor
00031
00032 #endif // AddOns_Lcs_3GPP_LcsSignalProcessor_hpp
00033
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsStackMsgArgs.cpp File Reference

AddOns/Lcs/3GPP/LcsStackMsgArgs.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsStackMsgArgs.hpp"

Include dependency graph for LcsStackMsgArgs.cpp:

Generated on Tue Jan 24 16:31:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsStackMsgArgs.hpp File Reference

AddOns/Lcs/3GPP/LcsStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <AddOns/Lcs/3GPP/LcsArgs.hpp>

Include dependency graph for LcsStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsStackMsgArgsDestroyTableNode

Defines

#define | AddOns_Lcs_3GPP_LcsStackMsgArgs_hpp

Define Documentation

#define AddOns_Lcs_3GPP_LcsStackMsgArgs_hpp

Generated on Tue Jan 24 16:31:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/3GPP/LcsStackMsgArgs.hpp Source File

AddOns/Lcs/3GPP/LcsStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "APOXI_1.6.7-PRE\src\Apoxi\AddOns\Lcs\3GPP\LcsArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_3GPP_LcsStackMsgArgs_hpp)
00016 #define AddOns_Lcs_3GPP_LcsStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <AddOns/Lcs/3GPP/LcsArgs.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class LcsStackMsgArgsDestroyTableNode
00028     ====================================================================== */
00029
00030 class LcsStackMsgArgsDestroyTableNode : public StackMsgArgDestroyTableNode {
00031     public:
00032
00033         static LcsStackMsgArgsDestroyTableNode* GetInstance();
00034
00035     private:
00036         LcsStackMsgArgsDestroyTableNode();
00037
00038
00039         static LcsStackMsgArgsDestroyTableNode* m_node;
00040         static const ArgumentDestroyEntry m_destroy_table[];
00041
00042     };
00043
00044 #endif // AddOns_Lcs_3GPP_LcsStackMsgArgs_hpp
00045
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonArgs.cpp File Reference

AddOns/Lcs/Common/LcsCommonArgs.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsCommonArgs.hpp"

Include dependency graph for LcsCommonArgs.cpp:

Generated on Tue Jan 24 16:31:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonArgs.hpp File Reference

AddOns/Lcs/Common/LcsCommonArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for LcsCommonArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbortResArg

Defines

#define | AddOns_Lcs_Common_LcsCommonArgs_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsCommonArgs_hpp

Generated on Tue Jan 24 16:31:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonArgs.hpp Source File

AddOns/Lcs/Common/LcsCommonArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\Common\LcsCommonArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_Common_LcsCommonArgs_hpp)
00016 #define AddOns_Lcs_Common_LcsCommonArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class AbortResArg
00028     ====================================================================== */
00029
00031 class AbortResArg : public StackMsgArgument {
00032     friend class LcsCommonStackMsgArgsDestroyTableNode;
00033     public:
00034         AbortResArg();
00035         ~AbortResArg();
00036
00037         static const AbortResArg& Cast(const StackMsgArgument& arg);
00038
00039         enum  {
00040             ID = 4200
00041             };
00042
00043     private:
00044
00045         static void Destroy(StackMsgArgument* arg) { delete ((AbortResArg*) arg); }
00046
00047     };
00048
00049 // Inline definitions
00050 inline const AbortResArg& AbortResArg::Cast(const StackMsgArgument& arg) {
00051     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AbortResArg!\n");
00052     return ((AbortResArg &) arg);
00053 }
00054
00055
00056 #endif // AddOns_Lcs_Common_LcsCommonArgs_hpp
00057
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonMsgProcessor.cpp File Reference

AddOns/Lcs/Common/LcsCommonMsgProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsCommonMsgProcessor.hpp"

Include dependency graph for LcsCommonMsgProcessor.cpp:

Generated on Tue Jan 24 16:31:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonMsgProcessor.hpp File Reference

AddOns/Lcs/Common/LcsCommonMsgProcessor.hpp File Reference

#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for LcsCommonMsgProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsCommonMsgProcessor
This class sends the abortion request to Lcs stack. More...

Defines

#define | AddOns_Lcs_Common_LcsCommonMsgProcessor_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsCommonMsgProcessor_hpp

Generated on Tue Jan 24 16:31:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonMsgProcessor.hpp Source File

AddOns/Lcs/Common/LcsCommonMsgProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsCommonMsgProcessor_hpp)
00010 #define AddOns_Lcs_Common_LcsCommonMsgProcessor_hpp
00011
00012 #include <Apc/SignalHandler/StackMsgProcessor.hpp>
00013
00015 class LcsCommonMsgProcessor : public StackMsgProcessor
00016 {
00018     public:
00019
00021         static void ProcessAbortReq();
00022 };
00023
00024 #endif // AddOns_Lcs_Common_LcsCommonMsgProcessor_hpp
00025
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonMsgTypes.cpp File Reference

AddOns/Lcs/Common/LcsCommonMsgTypes.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsCommonMsgTypes.hpp"

Include dependency graph for LcsCommonMsgTypes.cpp:

Generated on Tue Jan 24 16:32:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonMsgTypes.hpp File Reference

AddOns/Lcs/Common/LcsCommonMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>
#include <AddOns/Lcs/Common/LcsProviderImplBase.hpp>

Include dependency graph for LcsCommonMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbortResMsg
class | LocationErrMsg
class | LocationNotifInvokeMsg
class | LocationResMsg
class | ProcessMolrMsg
class | ProviderChangedMsg

Defines

#define | AddOns_Lcs_Common_LcsCommonMsgTypes_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsCommonMsgTypes_hpp

Generated on Tue Jan 24 16:32:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonMsgTypes.hpp Source File

AddOns/Lcs/Common/LcsCommonMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\Common\LcsCommonMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_Common_LcsCommonMsgTypes_hpp)
00016 #define AddOns_Lcs_Common_LcsCommonMsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00020 #include <AddOns/Lcs/Common/LcsProviderImplBase.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class LocationNotifInvokeMsg
00029     ====================================================================== */
00030
00032 class LocationNotifInvokeMsg : public ContextMsg {
00033     public:
00034         LocationNotifInvokeMsg(ExecutionContext* context, UINT16 invoke_id, const LcsNotificationType& notif_type, const LocationType& location_type, const ClientInfo& client_info);
00035         virtual ~LocationNotifInvokeMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         UINT16 GetInvokeId() const { return m_invoke_id; }
00039         const LcsNotificationType& GetNotifType() const { return m_notif_type; }
00040         const LocationType& GetLocationType() const { return m_location_type; }
00041         const ClientInfo& GetClientInfo() const { return m_client_info; }
00042         virtual Message* Clone() const;
00043
00044         enum  {
00045             ID = 4205
00046             };
00047
00048     private:
00049         static const MsgMetaData m_meta_data;
00050         UINT16 m_invoke_id;
00051         LcsNotificationType m_notif_type;
00052         LocationType m_location_type;
00053         ClientInfo m_client_info;
00054
00055     };
00056
00057
00058 /*  ======================================================================
00059     Class LocationResMsg
00060     ====================================================================== */
00061
00063 class LocationResMsg : public ContextMsg {
00064     public:
00065         LocationResMsg(ExecutionContext* context, const LocationEstimate& location_estimate);
00066         virtual ~LocationResMsg();
00067
00068         virtual const MsgMetaData& GetMetaData() const;
00069         const LocationEstimate& GetLocationEstimate() const { return m_location_estimate; }
00070         virtual Message* Clone() const;
00071
00072         enum  {
00073             ID = 4206
00074             };
00075
00076     private:
00077         static const MsgMetaData m_meta_data;
00078         LocationEstimate m_location_estimate;
00079
00080     };
00081
00082
00083 /*  ======================================================================
00084     Class LocationErrMsg
00085     ====================================================================== */
00086
00088 class LocationErrMsg : public ContextMsg {
00089     public:
00090         LocationErrMsg(ExecutionContext* context, const LcsErrorCode& err_code);
00091         virtual ~LocationErrMsg();
00092
00093         virtual const MsgMetaData& GetMetaData() const;
00094         const LcsErrorCode& GetErrCode() const { return m_err_code; }
00095         virtual Message* Clone() const;
00096
00097         enum  {
00098             ID = 4207
00099             };
00100
00101     private:
00102         static const MsgMetaData m_meta_data;
00103         LcsErrorCode m_err_code;
00104
00105     };
00106
00107
00108 /*  ======================================================================
00109     Class AbortResMsg
00110     ====================================================================== */
00111
00113 class AbortResMsg : public ContextMsg {
00114     public:
00115         AbortResMsg(ExecutionContext* context);
00116         virtual ~AbortResMsg();
00117
00118         virtual const MsgMetaData& GetMetaData() const;
00119         virtual Message* Clone() const;
00120
00121         enum  {
00122             ID = 4208
00123             };
00124
00125     private:
00126         static const MsgMetaData m_meta_data;
00127
00128     };
00129
00130
00131 /*  ======================================================================
00132     Class ProviderChangedMsg
00133     ====================================================================== */
00134
00136 class ProviderChangedMsg : public Message {
00137     public:
00138         ProviderChangedMsg(const LcsTransportType& protocol, LcsProviderImplBase* provider);
00139         virtual ~ProviderChangedMsg();
00140
00141         virtual const MsgMetaData& GetMetaData() const;
00142         const LcsTransportType& GetProtocol() const { return m_protocol; }
00143         LcsProviderImplBase* GetProvider() const { return m_provider; }
00144         virtual Message* Clone() const;
00145
00146         enum  {
00147             ID = 4209
00148             };
00149
00150     private:
00151         static const MsgMetaData m_meta_data;
00152         LcsTransportType m_protocol;
00153         LcsProviderImplBase* m_provider;
00154
00155     };
00156
00157
00158 /*  ======================================================================
00159     Class ProcessMolrMsg
00160     ====================================================================== */
00161
00163 class ProcessMolrMsg : public Message {
00164     public:
00165         ProcessMolrMsg(MolrInfo* molr_info);
00166         virtual ~ProcessMolrMsg();
00167
00168         virtual const MsgMetaData& GetMetaData() const;
00169         MolrInfo* GetMolrInfo() const { return m_molr_info; }
00170         virtual Message* Clone() const;
00171
00172         enum  {
00173             ID = 4210
00174             };
00175
00176     private:
00177         static const MsgMetaData m_meta_data;
00178         MolrInfo* m_molr_info;
00179
00180     };
00181
00182 #endif // AddOns_Lcs_Common_LcsCommonMsgTypes_hpp
00183
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonSignalMapTableNode.cpp File Reference

AddOns/Lcs/Common/LcsCommonSignalMapTableNode.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsCommonSignalMapTableNode.hpp"
#include "LcsCommonSignalProcessor.hpp"

Include dependency graph for LcsCommonSignalMapTableNode.cpp:

Generated on Tue Jan 24 16:32:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonSignalMapTableNode.hpp File Reference

AddOns/Lcs/Common/LcsCommonSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for LcsCommonSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsCommonSignalMapTableNode

Defines

#define | AddOns_Lcs_Common_LcsCommonSignalMapTableNode_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsCommonSignalMapTableNode_hpp

Generated on Tue Jan 24 16:32:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonSignalMapTableNode.hpp Source File

AddOns/Lcs/Common/LcsCommonSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsCommonSignalMapTableNode_hpp)
00010 #define AddOns_Lcs_Common_LcsCommonSignalMapTableNode_hpp
00011
00012 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00013
00018 class LcsCommonSignalMapTableNode : public SignalMapTableNode
00019 {
00020     typedef SignalMapTableNode Base;
00021
00023     public:
00024
00026         ~LcsCommonSignalMapTableNode();
00027
00029         static LcsCommonSignalMapTableNode* GetInstance();
00030
00032         static void ReleaseInstance();
00033
00034
00036     private:
00037
00039         LcsCommonSignalMapTableNode();
00040
00041
00043     private:
00044
00046         static LcsCommonSignalMapTableNode* m_node;
00047
00049         static const SignalMapTableEntry m_signal_map_table[];
00050 };
00051
00052 #endif // AddOns_Lcs_Common_LcsCommonSignalMapTableNode_hpp
00053
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonSignalProcessor.cpp File Reference

AddOns/Lcs/Common/LcsCommonSignalProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsCommonSignalProcessor.hpp"
#include "LcsCommonArgs.hpp"

Include dependency graph for LcsCommonSignalProcessor.cpp:

Generated on Tue Jan 24 16:32:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonSignalProcessor.hpp File Reference

AddOns/Lcs/Common/LcsCommonSignalProcessor.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsCommonSignalProcessor

Defines

#define | AddOns_Lcs_Common_LcsCommonSignalProcessor_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsCommonSignalProcessor_hpp

Generated on Tue Jan 24 16:32:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonSignalProcessor.hpp Source File

AddOns/Lcs/Common/LcsCommonSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsCommonSignalProcessor_hpp)
00010 #define AddOns_Lcs_Common_LcsCommonSignalProcessor_hpp
00011
00016 class LcsCommonSignalProcessor
00017 {
00019     public:
00020
00022         static void PostAbortResponse(const ProcessPtr& process_ptr);
00023 };
00024
00025 #endif // AddOns_Lcs_Common_LcsCommonSignalProcessor_hpp
00026
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonStackMsgArgs.cpp File Reference

AddOns/Lcs/Common/LcsCommonStackMsgArgs.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsCommonStackMsgArgs.hpp"

Include dependency graph for LcsCommonStackMsgArgs.cpp:

Generated on Tue Jan 24 16:32:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonStackMsgArgs.hpp File Reference

AddOns/Lcs/Common/LcsCommonStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <AddOns/Lcs/Common/LcsCommonArgs.hpp>

Include dependency graph for LcsCommonStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsCommonStackMsgArgsDestroyTableNode

Defines

#define | AddOns_Lcs_Common_LcsCommonStackMsgArgs_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsCommonStackMsgArgs_hpp

Generated on Tue Jan 24 16:32:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsCommonStackMsgArgs.hpp Source File

AddOns/Lcs/Common/LcsCommonStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\Common\LcsCommonArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_Common_LcsCommonStackMsgArgs_hpp)
00016 #define AddOns_Lcs_Common_LcsCommonStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <AddOns/Lcs/Common/LcsCommonArgs.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class LcsCommonStackMsgArgsDestroyTableNode
00028     ====================================================================== */
00029
00030 class LcsCommonStackMsgArgsDestroyTableNode : public StackMsgArgDestroyTableNode {
00031     public:
00032
00033         static LcsCommonStackMsgArgsDestroyTableNode* GetInstance();
00034
00035     private:
00036         LcsCommonStackMsgArgsDestroyTableNode();
00037
00038
00039         static LcsCommonStackMsgArgsDestroyTableNode* m_node;
00040         static const ArgumentDestroyEntry m_destroy_table[];
00041
00042     };
00043
00044 #endif // AddOns_Lcs_Common_LcsCommonStackMsgArgs_hpp
00045
Generated on Tue Jan 24 14:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsDecls.hpp File Reference

AddOns/Lcs/Common/LcsDecls.hpp File Reference

#include "LcsTimer.hpp"
#include "LcsRepeatTimer.hpp"
#include "LcsTypes.hpp"

Include dependency graph for LcsDecls.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InvokeId
This class generates a new invoke id whenever it's instantiated. More...
struct | LcsQos
Structure containing the Qos in the format required to fill in the SDL signal. More...
struct | MolrInfo
class | MolrParams
This class is used to fill the MN_SS_LCS_MOLR_REQ SDL signal. More...
struct | MolrRepeatInfo
struct | MtlrInfo

Defines

#define | AddOns_Lcs_Common_LcsDecls_hpp

Enumerations

enum | LocationMethod { ms_based_eotd = MN_MS_BASED_EOTD, ms_assisted_eotd = MN_MS_ASSISTED_EOTD, assisted_gps = MN_ASSISTED_GPS }
Defines the type of location estimate methods to be used for location estimation. More...
enum | VerificationResponse { PermissionDenied = MTLR_PERMISSION_DENIED, PermissionGranted = MTLR_PERMISSION_GRANTED, NoResponseFromUser = MTLR_NO_RESPONSE }
The verification response to be sent in the MT-LR response. More...

Define Documentation

#define AddOns_Lcs_Common_LcsDecls_hpp

Enumeration Type Documentation

enum LocationMethod

Defines the type of location estimate methods to be used for location estimation.

Enumerator:
ms_based_eotd
ms_assisted_eotd
assisted_gps

enum VerificationResponse

The verification response to be sent in the MT-LR response.

Enumerator:
PermissionDenied
PermissionGranted
NoResponseFromUser

Generated on Tue Jan 24 16:32:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsDecls.hpp Source File

AddOns/Lcs/Common/LcsDecls.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsDecls_hpp)
00010 #define AddOns_Lcs_Common_LcsDecls_hpp
00011
00012 #include "LcsTimer.hpp"
00013 #include "LcsRepeatTimer.hpp"
00014 #include "LcsTypes.hpp"
00015
00016 class LcsProviderImplBase;
00017 class Application;
00018
00020 enum VerificationResponse
00021 {
00022     PermissionDenied = MTLR_PERMISSION_DENIED,
00023     PermissionGranted = MTLR_PERMISSION_GRANTED,
00024     NoResponseFromUser = MTLR_NO_RESPONSE
00025 };
00026
00028 enum LocationMethod
00029 {
00030     ms_based_eotd = MN_MS_BASED_EOTD,
00031     ms_assisted_eotd = MN_MS_ASSISTED_EOTD,
00032     assisted_gps = MN_ASSISTED_GPS
00033 };
00034
00036 struct LcsQos
00037 {
00039     BYTE                m_horiz_accuracy;
00040
00042     BYTE                m_vert_accuracy;
00043
00045     RespTimeCategory    m_rsp_time_cat;
00046 };
00047
00049 class MolrParams
00050 {
00052     public:
00053
00055         MolrParams( MolrType molr_type,
00056                     LocationMethod loc_method,
00057                     const LcsQos& lcs_qos,
00058                     const ClientId& client_id,
00059                     const MlcNumber& mlc_number)
00060         {
00061             m_molr_params.molr_type = (T_MN_MOLR_TYPE) molr_type;
00062             m_molr_params.loc_method = (T_MN_LOC_METHOD) loc_method;
00063             m_molr_params.lcs_qos.horiz_accuracy = (byte) lcs_qos.m_horiz_accuracy;
00064             m_molr_params.lcs_qos.vertic_accuracy = (byte) lcs_qos.m_vert_accuracy;
00065             m_molr_params.lcs_qos.rsp_time_cat = (T_MN_RESPONSE_TIME_CATEGORY) lcs_qos.m_rsp_time_cat;
00066             memcpy(m_molr_params.client_id.A, &client_id, sizeof(ClientId));
00067             memcpy(m_molr_params.mlc_number.A, &mlc_number, sizeof(MlcNumber));
00068         }
00069
00071         const T_MN_MOLR_REQ& GetMolrParams() const { return m_molr_params; }
00072
00073
00075     private:
00076
00078         MolrParams();
00079
00080
00082     private:
00083
00085         T_MN_MOLR_REQ m_molr_params;
00086
00087 }; // MolrParams
00088
00089
00090 /*  -------------------------------------------------
00091     Declarations used by the request processor
00092     -------------------------------------------------*/
00093
00095 class InvokeId
00096 {
00098     public:
00099
00101         InvokeId()
00102         {
00103             ++m_invoke_id;
00104             if(m_invoke_id == 0) // 0 is an invalid InvokeId
00105                 ++m_invoke_id;
00106         }
00107
00109         UINT16 GetInvokeId() const { return m_invoke_id; }
00110
00111
00113     private:
00114
00116         static UINT16 m_invoke_id;
00117
00118 }; // InvokeId
00119
00124 struct MolrInfo : public Linkable<MolrInfo>
00125 {
00127     MolrInfo(   MolrType molr_type,
00128                 LocationMethod location_method,
00129                 const LcsQos& lcs_qos,
00130                 const ClientId& client_id,
00131                 const MlcNumber& mlc_number,
00132                 INT32 repeat_interval,
00133                 const Application* app,
00134                 const LcsProviderImplBase* provider)
00135                 : m_molr_type(molr_type), m_location_method(location_method),
00136                 m_lcs_qos(lcs_qos), m_client_id(client_id), m_mlc_number(mlc_number),
00137                 m_repeat_interval(repeat_interval)
00138     {
00139         // Remove the constness
00140         m_app = (Application*) app;
00141         m_provider = (LcsProviderImplBase*) provider;
00142     }
00143
00145     virtual ~MolrInfo()
00146     {
00147     }
00148
00150     MolrType                m_molr_type;
00151     LocationMethod          m_location_method;
00152     LcsQos                  m_lcs_qos;
00153     ClientId                m_client_id;
00154     MlcNumber               m_mlc_number;
00155     INT32                   m_repeat_interval;
00156     Application*            m_app;
00157     LcsProviderImplBase*    m_provider;
00158
00159
00161 private:
00162
00164     MolrInfo();
00165
00166 }; // MolrInfo
00167
00172 struct MolrRepeatInfo : public MolrInfo
00173 {
00174     typedef MolrInfo Base;
00175
00177     MolrRepeatInfo( MolrType molr_type,
00178                     LocationMethod location_method,
00179                     const LcsQos& lcs_qos,
00180                     const ClientId& client_id,
00181                     const MlcNumber& mlc_number,
00182                     INT32 repeat_interval,
00183                     const Application* app,
00184                     const LcsProviderImplBase* provider)
00185                     : Base( molr_type, location_method, lcs_qos, client_id,
00186                             mlc_number, repeat_interval, app, provider)
00187     {
00188         // Assign a unique invoke id to this request
00189         m_invoke_id = InvokeId().GetInvokeId();
00190
00191         // Initialize the repeat MO-LR timer
00192         const UINT16 SEC_TO_MSEC = 1000;
00193         m_rep_timer.Init(m_invoke_id, m_repeat_interval * SEC_TO_MSEC);
00194     }
00195
00197     virtual ~MolrRepeatInfo()
00198     {
00199         m_rep_timer.Stop();
00200     }
00201
00203     UINT16 m_invoke_id;
00204     LcsRepeatTimer m_rep_timer; // To know when it's time to repeat the location request
00205
00206
00208 private:
00209
00211     MolrRepeatInfo();
00212
00213 }; // MolrRepeatInfo
00214
00219 struct MtlrInfo : public Linkable<MtlrInfo>
00220 {
00222     MtlrInfo(BYTE ti_pd, LcsNotificationType notif_type, const LcsProviderImplBase* provider)
00223             : m_ti_pd(ti_pd), m_notif_type(notif_type)
00224     {
00225         // Remove the constness
00226         m_provider = (LcsProviderImplBase*) provider;
00227
00228         // Assign a unique invoke id to this request
00229         m_invoke_id = InvokeId().GetInvokeId();
00230
00231         // Initialize the timer
00232         const UINT16 MTLR_TIMEOUT = 8400; // in msec
00233         m_lcs_timer.Init(MtlrTimer, MTLR_TIMEOUT, m_provider);
00234     }
00235
00237     virtual ~MtlrInfo()
00238     {
00239         m_lcs_timer.Stop();
00240     }
00241
00243     BYTE m_ti_pd;
00244     UINT16 m_invoke_id;
00245     LcsNotificationType m_notif_type;
00246     LcsTimer m_lcs_timer;
00247     LcsProviderImplBase* m_provider;
00248
00249
00251 private:
00252
00254     MtlrInfo();
00255
00256 };
00257
00258 #endif // AddOns_Lcs_Common_LcsDecls_hpp
00259
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsPreComp.cpp File Reference

AddOns/Lcs/Common/LcsPreComp.cpp File Reference

#include "LcsPreComp.hpp"

Include dependency graph for LcsPreComp.cpp:

Generated on Tue Jan 24 16:32:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsPreComp.hpp File Reference

AddOns/Lcs/Common/LcsPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for LcsPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:32:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsPreComp.hpp Source File

AddOns/Lcs/Common/LcsPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Asc/Lib.hpp>
00012
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsProvider.cpp File Reference

AddOns/Lcs/Common/LcsProvider.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsProvider.hpp"
#include "LcsDecls.hpp"
#include "LcsUtils.hpp"
#include "LcsProviderImplBase.hpp"
#include "LcsCommonSignalMapTableNode.hpp"
#include "LcsReqProcessor.hpp"
#include "LcsCommonStackMsgArgs.hpp"

Include dependency graph for LcsProvider.cpp:

Generated on Tue Jan 24 16:33:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsProvider.hpp File Reference

AddOns/Lcs/Common/LcsProvider.hpp File Reference

#include "LcsTypes.hpp"

Include dependency graph for LcsProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsProvider

Defines

#define | AddOns_Lcs_Common_LcsProvider_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsProvider_hpp

Generated on Tue Jan 24 16:33:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsProvider.hpp Source File

AddOns/Lcs/Common/LcsProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsProvider_hpp)
00010 #define AddOns_Lcs_Common_LcsProvider_hpp
00011
00012 #include "LcsTypes.hpp"
00013
00014 class LcsProviderImplBase;
00015
00020 class LcsProvider
00021 {
00023     public:
00024
00026         ~LcsProvider();
00027
00029         static LcsProvider* GetInstance();
00030
00032         LcsErrorCode SendVerificationResult(UINT16 invoke_id, BOOLEAN user_response);
00033
00039         LcsErrorCode SelfLocationReq(LcsCost lcs_cost = Low,
00040                                     const LcsMmiQos& lcs_mmi_qos = LcsMmiQos(),
00041                                     INT32 repeat_interval = -1);
00042
00047         LcsErrorCode TransferLocationReq(const LcsMmiQos& lcs_mmi_qos,
00048                                         const ClientId& client_id,
00049                                         const MlcNumber& mlc_number,
00050                                         INT32 repeat_interval = -1);
00051
00053         LcsErrorCode AbortSelfLocReq();
00054
00059         LastLocationEstimate GetLastKnownLocation() const;
00060
00066         BOOLEAN SetProtocol(LcsTransportType new_protocol);
00067
00072         LcsErrorCode RegisterForMtlr(const Application* app);
00073
00079         BOOLEAN SetNmeaUartSettings(BOOLEAN nmea_switch, const NmeaUartSettings& nmea_uart_settings);
00080
00081
00083     private:
00084
00086         LcsProvider();
00087
00089         void Init();
00090
00095         LcsProviderImplBase* SelectProvider(LcsCost lcs_cost, MolrType& molr_type);
00096
00098         void UnloadProtProvider();
00099
00100
00102     private:
00103
00105         static LcsProvider m_lcs_provider;
00106
00109         static BOOLEAN m_initialized;
00110
00112         LcsProviderImplBase* m_prot_provider;
00113
00115         LcsProviderImplBase* m_sa_provider;
00116
00117 }; // LcsProvider
00118
00119 #endif // AddOns_Lcs_Common_LcsProvider_hpp
00120
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsProviderImplBase.cpp File Reference

AddOns/Lcs/Common/LcsProviderImplBase.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsProviderImplBase.hpp"
#include "LcsDecls.hpp"
#include "LcsTypes.hpp"
#include "LcsUtils.hpp"
#include "LcsReqProcessor.hpp"
#include "LcsCommonMsgProcessor.hpp"
#include "LcsCommonMsgTypes.hpp"

Include dependency graph for LcsProviderImplBase.cpp:

Generated on Tue Jan 24 16:33:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsProviderImplBase.hpp File Reference

AddOns/Lcs/Common/LcsProviderImplBase.hpp File Reference

#include "LcsTypes.hpp"
#include "LcsDecls.hpp"
#include "LcsTimer.hpp"

Include dependency graph for LcsProviderImplBase.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsProviderImplBase
The abstract base class of all the provider implementations. More...

Defines

#define | AddOns_Lcs_Common_LcsProviderImplBase_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsProviderImplBase_hpp

Generated on Tue Jan 24 16:33:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsProviderImplBase.hpp Source File

AddOns/Lcs/Common/LcsProviderImplBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsProviderImplBase_hpp)
00010 #define AddOns_Lcs_Common_LcsProviderImplBase_hpp
00011
00012 #include "LcsTypes.hpp"
00013 #include "LcsDecls.hpp"
00014 #include "LcsTimer.hpp"
00015
00017 class LcsProviderImplBase
00018 {
00020     public:
00021
00023         explicit LcsProviderImplBase(LcsTransportType protocol);
00024
00026         virtual ~LcsProviderImplBase();
00027
00029         virtual LcsErrorCode TransferLocationReq(MolrType molr_type,
00030                                                 LocationMethod location_method,
00031                                                 const LcsMmiQos& lcs_mmi_qos,
00032                                                 const ClientId& client_id,
00033                                                 const MlcNumber& mlc_number,
00034                                                 INT32 repeat_interval) = 0;
00035
00037         virtual void OnTimeOut(LcsTimerType timer_type) = 0;
00038
00040         virtual void Init();
00041
00043         virtual LcsErrorCode SendVerificationResult(UINT16 invoke_id, BOOLEAN user_response);
00044
00049         LcsErrorCode SelfLocationReq(MolrType molr_type,
00050                                     LocationMethod location_method,
00051                                     const LcsMmiQos& lcs_mmi_qos,
00052                                     INT32 repeat_interval);
00053
00055         LcsTransportType GetProtocol() const { return m_protocol; }
00056
00058         BOOLEAN SetNmeaUartSettings(BOOLEAN nmea_switch, const NmeaUartSettings& nmea_uart_settings);
00059
00064         static LcsErrorCode RegisterForMtlr(const Application* app);
00065
00067         static LastLocationEstimate GetLastKnownLocation() { return m_last_loc_est; }
00068
00075         static LcsErrorCode AbortSelfLocReq();
00076
00077
00079     protected:
00080
00082         virtual BOOLEAN OnAbortResponse(const StackMsgArgument& arg);
00083
00085         void SendNmeaData();
00086
00087
00089     private:
00090
00092         LcsProviderImplBase();
00093
00095         BOOLEAN SendNmeaGGA(const LocationEstimate& loc_est);
00096
00098         BOOLEAN SendNmeaGSV(const GpsFixData& fix_data);
00099
00101         void AddNmeaChecksum(String& nmea_data);
00102
00103
00105     protected:
00106
00108         static LastLocationEstimate m_last_loc_est;
00109
00111         static Application* m_mtlr_app;
00112
00114         LcsTimer m_molr_timer;
00115
00116
00118     private:
00119
00121         LcsTransportType m_protocol;
00122
00124         BOOLEAN m_nmea_switch;
00125
00127         static INT32 m_uart_fd;
00128
00129 }; // LcsProviderImplBase
00130
00131 #endif // AddOns_Lcs_Common_LcsProviderImplBase_hpp
00132
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsRepeatTimer.cpp File Reference

AddOns/Lcs/Common/LcsRepeatTimer.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsRepeatTimer.hpp"
#include "LcsReqProcessor.hpp"

Include dependency graph for LcsRepeatTimer.cpp:

Generated on Tue Jan 24 16:33:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsRepeatTimer.hpp File Reference

AddOns/Lcs/Common/LcsRepeatTimer.hpp File Reference

#include <Kernel/Timer.hpp>

Include dependency graph for LcsRepeatTimer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsRepeatTimer
Timer used for repeated self location requests. More...

Defines

#define | AddOns_Lcs_Common_LcsRepeatTimer_hpp

Define Documentation

#define AddOns_Lcs_Common_LcsRepeatTimer_hpp

Generated on Tue Jan 24 16:33:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsRepeatTimer.hpp Source File

AddOns/Lcs/Common/LcsRepeatTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsRepeatTimer_hpp)
00010 #define AddOns_Lcs_Common_LcsRepeatTimer_hpp
00011
00012 #include <Kernel/Timer.hpp>
00013
00015 class LcsRepeatTimer : public Timer
00016 {
00017     typedef Timer Base;
00018
00020     public:
00021
00023         LcsRepeatTimer();
00024
00026         virtual ~LcsRepeatTimer();
00027
00029         void Init(UINT16 invoke_id, UINT32 timeout, BOOLEAN autotimer = FALSE);
00030
00032         void Start();
00033
00034
00036     protected:
00037
00039         virtual void OnTimer();
00040
00041
00043     private:
00044
00046         UINT16 m_invoke_id;
00047
00048 }; // LcsRepeatTimer
00049
00050 #endif // AddOns_Lcs_Common_LcsRepeatTimer_hpp
00051
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsReqProcessor.cpp File Reference

AddOns/Lcs/Common/LcsReqProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsReqProcessor.hpp"
#include "LcsDecls.hpp"
#include "LcsProviderImplBase.hpp"
#include "LcsCommonMsgTypes.hpp"

Include dependency graph for LcsReqProcessor.cpp:

Generated on Tue Jan 24 16:33:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsReqProcessor.hpp File Reference

AddOns/Lcs/Common/LcsReqProcessor.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsReqProcessor
The centralized storage for MO-LR and MT-LR requests from all providers. More...

Defines

#define | AddOns_Lcs_Common_LcsReqProcessor_hpp

Enumerations

enum | MolrStatus { NonExistent, Ongoing, Pending }

Define Documentation

#define AddOns_Lcs_Common_LcsReqProcessor_hpp

Enumeration Type Documentation

enum MolrStatus

Enumerator:
NonExistent
Ongoing
Pending

Generated on Tue Jan 24 16:33:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsReqProcessor.hpp Source File

AddOns/Lcs/Common/LcsReqProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsReqProcessor_hpp)
00010 #define AddOns_Lcs_Common_LcsReqProcessor_hpp
00011
00012 struct MolrInfo;
00013 struct MtlrInfo;
00014 struct MolrRepeatInfo;
00015 class Application;
00016 class LcsProviderImplBase;
00017
00018 enum MolrStatus
00019 {
00020     NonExistent,
00021     Ongoing,
00022     Pending
00023 };
00024
00026 class LcsReqProcessor
00027 {
00029     public:
00030
00032         ~LcsReqProcessor();
00033
00035         static LcsReqProcessor* GetInstance();
00036
00038         static void ReleaseInstance();
00039
00041         void StoreMolr(MolrInfo* molr_info);
00042
00044         MolrInfo* GetMolr() const;
00045
00047         void RemoveMolr(Application* app);
00048
00051         MolrStatus GetMolrStatus(Application* app);
00052
00058         void MolrProcessed(BOOLEAN remove_molr = FALSE);
00059
00061         void OnRepMolrTimeOut(UINT16 invoke_id);
00062
00064         void StoreMtlr(const MtlrInfo* mtlr_info);
00065
00067         MtlrInfo* GetMtlr();
00068
00070         MtlrInfo* RetrieveMtlr(UINT16 invoke_id);
00071
00073         BOOLEAN RequestExists(const LcsProviderImplBase* prov_impl) const;
00074
00075
00077     private:
00078
00080         LcsReqProcessor();
00081
00083         MolrInfo* FindMolr(const Application* app);
00084
00085
00087     private:
00088
00090         static LcsReqProcessor* m_self;
00091
00097         LinkedList<MolrInfo> m_molr_list;
00098
00105         LinkedList<MolrRepeatInfo> m_rep_molr_list;
00106
00111         LinkedList<MtlrInfo> m_mtlr_list;
00112
00114         BOOLEAN m_molr_ongoing;
00115
00116 }; // LcsReqProcessor
00117
00118 #endif // AddOns_Lcs_Common_LcsReqProcessor_hpp
00119
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsTimer.cpp File Reference

AddOns/Lcs/Common/LcsTimer.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsTimer.hpp"
#include "LcsProviderImplBase.hpp"

Include dependency graph for LcsTimer.cpp:

Generated on Tue Jan 24 16:34:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsTimer.hpp File Reference

AddOns/Lcs/Common/LcsTimer.hpp File Reference

#include <Kernel/Timer.hpp>

Include dependency graph for LcsTimer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsTimer
Timer class for MO-LR and MT-LR request timeouts. More...

Defines

#define | AddOns_Lcs_Common_LcsTimer_hpp

Enumerations

enum | LcsTimerType { MtlrTimer, MolrTimer, InvalidTimer }

Define Documentation

#define AddOns_Lcs_Common_LcsTimer_hpp

Enumeration Type Documentation

enum LcsTimerType

Enumerator:
MtlrTimer
MolrTimer
InvalidTimer

Generated on Tue Jan 24 16:34:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsTimer.hpp Source File

AddOns/Lcs/Common/LcsTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsTimer_hpp)
00010 #define AddOns_Lcs_Common_LcsTimer_hpp
00011
00012 #include <Kernel/Timer.hpp>
00013
00014 class LcsProviderImplBase;
00015
00016 enum LcsTimerType
00017 {
00018     MtlrTimer,
00019     MolrTimer,
00020     InvalidTimer
00021 };
00022
00024 class LcsTimer : public Timer
00025 {
00026     typedef Timer Base;
00027
00029     public:
00030
00032         LcsTimer();
00033
00035         virtual ~LcsTimer();
00036
00038         void Start();
00039
00041         void Init(  LcsTimerType timer_type, UINT32 timeout,
00042                     const LcsProviderImplBase* provider, BOOLEAN autotimer = FALSE);
00043
00044
00046     protected:
00047
00049         virtual void OnTimer();
00050
00051
00053     private:
00054
00056         LcsTimerType m_timer_type;
00057
00059         const LcsProviderImplBase* m_provider;
00060
00061 }; // LcsTimer
00062
00063 #endif // AddOns_Lcs_Common_LcsTimer_hpp
00064
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsTypes.hpp File Reference

AddOns/Lcs/Common/LcsTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ClientId
Stores the Client Id information. More...
struct | ClientInfo
struct | ClientName
Stores the client name. More...
struct | GpsFixData
class | LastLocationEstimate
Stores the last known location estimate along with the timestamp. More...
struct | LcsArc
Stores location estimate in 'point' format with uncertainty of type 'arc'. More...
struct | LcsMmiQos
The Qos structure to be filled by user inputs. More...
struct | LcsPoint
Stores location estimate in 'point' format. More...
struct | LcsPointAltitudeUncertEllipsoid
Stores location estimate in 'point' format with uncertainty of type 'ellpsoid'. More...
struct | LcsPointUncertCircle
Stores location estimate in 'point' format with uncertainty of type 'circle'. More...
struct | LcsPointUncertEllipse
Stores location estimate in 'point' format with uncertainty of type 'ellipse'. More...
struct | LocationEstimate
Contains the decoded location estimate. More...
struct | MlcNumber
Unique Number of the GMLC through which the transfer location is routed. More...
struct | NmeaUartSettings
UART Settings for NMEA data transfer. More...
struct | SatelliteInfo
Contains information about a visible (& possibly tracked) satellite. More...
struct | SignedValue
Structure for storing signed values. More...
struct | UnsignedValue
Structure for storing unsigned values. More...

Defines

#define | AddOns_Lcs_Common_LcsTypes_hpp

Typedefs

typedef BYTE | Dcs
typedef BYTE | TI_PD
TI_PD.

Enumerations

enum | LcsCost { None = 0, Low = 1, High = 2 }
The cost criteria available to the application for any MO-LR. More...
enum LcsErrorCode {
LcsSystemFailure, LcsUnexpectedDataValue, LcsDataMissing, LcsFacilityNotSupported,
LcsSsSubscriptionViolation, LcsPosMethodFailure, LcsNoError, LcsTimeOut,
LcsInternalError, LcsProviderNotAvailable, LcsInvalidInvokation, LcsGltpConnSetupFailure,
LcsGltpTimeOut, LcsGltpSendFailure, LcsGltpInvalidData, LcsGltpMolrInProgress
}
Defines all possible kinds of location errors. More...
enum | LcsNotificationType { Notify = MTLR_NOTIFY, VerifyLocAllowedNoResp = MTLR_VERIFY_LOC_ALLOWED_IF_NO_RSP, VerifyLocNotAllowedNoResp = MTLR_VERIFY_LOC_NOT_ALLOWED_IF_NO_RSP }
Defines the type of MT-LR received. More...
enum LcsShapeType {
LST_PointUncertCircle, LST_PointUncertEllipse, LST_PointAltitudeUncertEllipsoid, LST_Arc,
LST_Point, LST_NoLocation
}
Defines all type of shapes possible in location result. More...
enum LcsTransportType {
GPP = 0, WAP = 1, GLTP = 2, STAND_ALONE = 3,
MAX_TRANSPORTS = 4
}
The types of protocols supported. More...
enum | LocationType { CurrentLocation = MTLR_CURRENT_LOCATION, CurrentOrLastKnownLocation = MTLR_CURRENT_OR_LAST_KNOWN_LOCATION, InitialLocation = MTLR_INITIAL_LOCATION }
The type of location required. More...
enum | MolrType { location_estimate = LOCATION_ESTIMATE, assistance_data = MN_ASSISTANCE_DATA, stand_alone = MN_STAND_ALONE }
Defines the type of data required for MO-LR. More...
enum | RespTimeCategory { lcs_low_delay = LCS_LOW_DELAY, lcs_delay_tolerant = LCS_DELAY_TOLERANT }
enum UartBaudRate {
Ubd2400 = 2400, Ubd4800 = 4800, Ubd9600 = 9600, Ubd19200 = 19200,
Ubd38400 = 38400, Ubd57600 = 57600, Ubd115200 = 115200, Ubd230400 = 230400,
Ubd460800 = 460800, Ubd921600 = 921600
}
UART Baud Rate for NMEA data transfer. More...
enum | UartDataBits { UdbFive = 0x00, UdbSix = 0x04, UdbSeven = 0x08, UdbEight = 0x0c }
UART Data Bits for NMEA data transfer. More...
enum | UartFlowControl { UfcXonXoff = SIO_FCTL_SW, UfcHardware = SIO_FCTL_HW, UfcNone = SIO_FCTL_OFF }
UART Flow Control for NMEA data transfer. More...
enum | UartParity { ParityNone = 0, ParityEven = PARENB, ParityOdd = PARODD }
UART Parity for NMEA data transfer. More...
enum | UartStopBits { OneStopBit = 0, TwoStopBits = STOPB }
UART Stop Bits for NMEA data transfer. More...

Variables

const UINT8 | MAX_SATS = 14
Contains GPS data pertaining to the position fix.

Define Documentation

#define AddOns_Lcs_Common_LcsTypes_hpp

Typedef Documentation

typedef BYTE Dcs

typedef BYTE TI_PD

TI_PD.

Enumeration Type Documentation

enum LcsCost

The cost criteria available to the application for any MO-LR.

Enumerator:
None
Low
High

enum LcsErrorCode

Defines all possible kinds of location errors.

Enumerator:
LcsSystemFailure | Indicates a failure in the network.
LcsUnexpectedDataValue | Indicates that a parameter has an unexpected value, but type is OK.
LcsDataMissing | Indicates that an optional parameter that is required in this context is missing.
LcsFacilityNotSupported | Indicates that requested facility is not supported by the network.
LcsSsSubscriptionViolation | Indicates that requested Lcs SS violates the subscription restrictions.
LcsPosMethodFailure | Indicates that requested location information not obtained or assistance data transfer failed or Qos not met
LcsNoError | Indicates no error.
LcsTimeOut | Indicates that MO-LR is taking longer than the max response time.
LcsInternalError | Indicates that some internal error has occures.
LcsProviderNotAvailable | Indicates that no provider is available to service the given request.
LcsInvalidInvokation | Indicates one of the following: Application has sent an invalid invoke id in the MT-LR response The interface is not valid for the selected transport protocol The application is sending a 2nd MO-LR which is not allowed The application is trying to abort a non-existent self-location request
LcsGltpConnSetupFailure | Indicates a failure in setting up the GPRS connection to the GL server.
LcsGltpTimeOut | Indicates a time-out occurrence waiting for an acknowledgment from the GL server.
LcsGltpSendFailure | Indicates a failure to send the request to the GL server.
LcsGltpInvalidData | Indicates that invalid data received from the GL server or Lcs stack.
LcsGltpMolrInProgress | Indicates that a MO-LR is already in progress.

enum LcsNotificationType

Defines the type of MT-LR received.

Enumerator:
Notify
VerifyLocAllowedNoResp
VerifyLocNotAllowedNoResp

enum LcsShapeType

Defines all type of shapes possible in location result.

Enumerator:
LST_PointUncertCircle
LST_PointUncertEllipse
LST_PointAltitudeUncertEllipsoid
LST_Arc
LST_Point
LST_NoLocation

enum LcsTransportType

The types of protocols supported.

Enumerator:
GPP
WAP
GLTP
STAND_ALONE
MAX_TRANSPORTS

enum LocationType

The type of location required.

Enumerator:
CurrentLocation
CurrentOrLastKnownLocation
InitialLocation

enum MolrType

Defines the type of data required for MO-LR.

Enumerator:
location_estimate
assistance_data
stand_alone

enum RespTimeCategory

Defines the time constraints applied by the user on the time taken for location calculation by the network

Enumerator:
lcs_low_delay
lcs_delay_tolerant

enum UartBaudRate

UART Baud Rate for NMEA data transfer.

Enumerator:
Ubd2400
Ubd4800
Ubd9600
Ubd19200
Ubd38400
Ubd57600
Ubd115200
Ubd230400
Ubd460800
Ubd921600

enum UartDataBits

UART Data Bits for NMEA data transfer.

Enumerator:
UdbFive
UdbSix
UdbSeven
UdbEight

enum UartFlowControl

UART Flow Control for NMEA data transfer.

Enumerator:
UfcXonXoff
UfcHardware
UfcNone

enum UartParity

UART Parity for NMEA data transfer.

Enumerator:
ParityNone
ParityEven
ParityOdd

enum UartStopBits

UART Stop Bits for NMEA data transfer.

Enumerator:
OneStopBit
TwoStopBits

Variable Documentation

const UINT8 MAX_SATS = 14

Contains GPS data pertaining to the position fix.

Generated on Tue Jan 24 16:34:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsTypes.hpp Source File

AddOns/Lcs/Common/LcsTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsTypes_hpp)
00010 #define AddOns_Lcs_Common_LcsTypes_hpp
00011
00013 typedef BYTE TI_PD;
00014
00015 /*  ------------------------------------------------
00016     MT-LR Parameter Declarations
00017     ------------------------------------------------*/
00018
00020 enum LocationType
00021 {
00022     CurrentLocation = MTLR_CURRENT_LOCATION,
00023     CurrentOrLastKnownLocation = MTLR_CURRENT_OR_LAST_KNOWN_LOCATION,
00024     InitialLocation = MTLR_INITIAL_LOCATION
00025 };
00026
00028 enum LcsNotificationType
00029 {
00030     Notify = MTLR_NOTIFY,
00031     VerifyLocAllowedNoResp = MTLR_VERIFY_LOC_ALLOWED_IF_NO_RSP,
00032     VerifyLocNotAllowedNoResp = MTLR_VERIFY_LOC_NOT_ALLOWED_IF_NO_RSP
00033 };
00034
00035
00036 /*  ----------------------------------------------------------
00037     MO-LR Response Parameter Declarations
00038     Note:   Few of the data-types are wider than needed for
00039             the purpose of alignment at 16-bit boundaries
00040     ----------------------------------------------------------  */
00041
00043 struct UnsignedValue
00044 {
00046     void operator *=(const UnsignedValue& rhs)
00047     {
00048         m_mantissa *= rhs.m_mantissa;
00049         m_exponent += rhs.m_exponent;
00050     }
00051
00053     BOOLEAN operator ==(const UnsignedValue& rhs) const
00054     {
00055         return (m_mantissa == rhs.m_mantissa);
00056     }
00057
00059     BOOLEAN operator <(const UnsignedValue& rhs) const
00060     {
00061         return (m_mantissa < rhs.m_mantissa);
00062     }
00063
00065     BOOLEAN operator >(const UnsignedValue& rhs) const
00066     {
00067         return (m_mantissa > rhs.m_mantissa);
00068     }
00069
00071     UINT32  m_mantissa;
00072
00074     UINT16  m_exponent;
00075 };
00076
00078 struct SignedValue
00079 {
00081     void operator *=(const SignedValue& rhs)
00082     {
00083         m_mantissa *= rhs.m_mantissa;
00084         m_exponent += rhs.m_exponent;
00085     }
00086
00088     BOOLEAN operator ==(const SignedValue& rhs) const
00089     {
00090         return (m_mantissa == rhs.m_mantissa);
00091     }
00092
00094     BOOLEAN operator <(const SignedValue& rhs) const
00095     {
00096         return (m_mantissa < rhs.m_mantissa);
00097     }
00098
00100     BOOLEAN operator >(const SignedValue& rhs) const
00101     {
00102         return (m_mantissa > rhs.m_mantissa);
00103     }
00104
00106     SignedValue& operator -()
00107     {
00108         m_mantissa = -m_mantissa;
00109         return *this;
00110     }
00111
00113     INT32   m_mantissa;
00114
00116     UINT16  m_exponent;
00117 };
00118
00120 struct LcsPoint
00121 {
00123     SignedValue m_latitude;
00124
00126     SignedValue m_longitude;
00127 };
00128
00130 struct LcsPointUncertCircle
00131 {
00132     LcsPoint m_point;
00133
00135     UnsignedValue   m_uncert_radius;
00136 };
00137
00139 struct LcsPointUncertEllipse
00140 {
00141     LcsPoint        m_point;
00142     UnsignedValue   m_semi_major_axis;
00143     UnsignedValue   m_semi_minor_axis;
00144     UINT16          m_orientation_angle;
00145     UINT16          m_confidence; // UINT8 is sufficient!
00146 };
00147
00149 struct LcsPointAltitudeUncertEllipsoid
00150 {
00151     LcsPoint        m_point;
00152     SignedValue     m_altitude;
00153     UnsignedValue   m_semi_major_axis;
00154     UnsignedValue   m_semi_minor_axis;
00155     UINT16          m_orientation_angle;
00156     UnsignedValue   m_uncert_altitude;
00157     UINT16          m_confidence; // UINT8 is sufficient!
00158 };
00159
00161 struct LcsArc
00162 {
00163     LcsPoint        m_point;
00164     UINT32          m_inner_radius;
00165     UnsignedValue   m_uncert_radius;
00166     UINT16          m_offset_angle;
00167     UINT16          m_included_angle;
00168     UINT16          m_confidence; // UINT8 is sufficient!
00169 };
00170
00172 struct SatelliteInfo
00173 {
00175     SatelliteInfo() : m_tracked(0), m_sat_id(0), m_elevation(0), m_azimuth(0), m_snr(0),
00176                     m_sig_strength(0), m_int_time(0)
00177     {
00178     }
00179
00180     UINT8   m_tracked;
00181     UINT8   m_sat_id;
00183     INT16   m_elevation;
00185     INT16   m_azimuth;
00187     INT16   m_snr;
00189     INT16   m_sig_strength;
00191     UINT32  m_int_time;
00192 };
00193
00195 const UINT8 MAX_SATS = 14;
00196 struct GpsFixData
00197 {
00198     UINT16          m_gps_week;
00199     UINT32          m_gps_tow;
00200     UINT16          m_microsec;
00201     UINT8           m_speed_valid;
00203     UnsignedValue   m_speed;
00205     UnsignedValue   m_hdop;
00207     UINT32          m_time_tag_delta;
00209     UnsignedValue   m_loc_error;
00210     UINT8           m_num_sats;
00211     SatelliteInfo   m_sat_info[MAX_SATS];
00212 };
00213
00215 enum LcsShapeType
00216 {
00217     LST_PointUncertCircle,
00218     LST_PointUncertEllipse,
00219     LST_PointAltitudeUncertEllipsoid,
00220     LST_Arc,
00221     LST_Point,
00222     LST_NoLocation
00223 };
00224
00226 struct LocationEstimate
00227 {
00229     LocationEstimate() : m_lst(LST_NoLocation)
00230     {
00231     }
00232
00234     LcsShapeType m_lst;
00235     union
00236     {
00237         LcsPointUncertCircle                m_pt_uncert_circle;
00238         LcsPointUncertEllipse               m_pt_uncert_ellipse;
00239         LcsPointAltitudeUncertEllipsoid     m_pt_alt_ellipsoid;
00240         LcsArc                              m_pt_arc;
00241         LcsPoint                            m_point;
00242     };
00243     GpsFixData m_fix_data;
00244 };
00245
00247 class LastLocationEstimate : public LocationEstimate
00248 {
00249     typedef LocationEstimate Base;
00250
00252     public:
00253
00255         void operator =(const LocationEstimate& loc_est)
00256         {
00257             Base::operator =(loc_est);
00258             m_time_stamp = DateTime();
00259         }
00260
00261
00263     public:
00264
00266         DateTime m_time_stamp;
00267
00268 }; // LastLocationEstimate
00269
00270
00271 /*  ------------------------------------------------
00272     Declarations related to application inputs
00273     ------------------------------------------------*/
00274
00276 enum MolrType
00277 {
00278     location_estimate   = LOCATION_ESTIMATE,
00279     assistance_data     = MN_ASSISTANCE_DATA,
00280     stand_alone         = MN_STAND_ALONE
00281 };
00282
00284 enum LcsCost
00285 {
00286     None = 0,
00287     Low = 1,
00288     High = 2
00289 };
00290
00292 enum LcsTransportType
00293 {
00294     GPP = 0,
00295     WAP = 1,
00296     GLTP = 2,
00297     STAND_ALONE = 3,
00298     MAX_TRANSPORTS = 4
00299 };
00300
00305 enum RespTimeCategory
00306 {
00307     lcs_low_delay = LCS_LOW_DELAY,
00308     lcs_delay_tolerant = LCS_DELAY_TOLERANT
00309 };
00310
00312 struct LcsMmiQos
00313 {
00315     LcsMmiQos()
00316     {
00317         m_horiz_accuracy.m_mantissa = 5000; m_horiz_accuracy.m_exponent = 2;
00318         m_vert_accuracy.m_mantissa = 5000; m_vert_accuracy.m_exponent = 2;
00319         m_rsp_time_cat = lcs_low_delay;
00320     }
00321
00323     UnsignedValue       m_horiz_accuracy;
00324
00326     UnsignedValue       m_vert_accuracy;
00327
00329     RespTimeCategory    m_rsp_time_cat;
00330 };
00331
00332 typedef BYTE Dcs;
00333
00335 struct ClientId
00336 {
00338     ClientId()
00339     {
00340         memset(m_client_id, 0, MAX_SIZE);
00341     }
00342
00344     BOOLEAN IsValid()
00345     {
00346         for(INT idx = 0; idx < MAX_SIZE; ++idx)
00347             if(m_client_id[idx] != 0)
00348                 return TRUE;
00349         return FALSE;
00350     }
00351
00354     void ConvertToStr(String& client_id_str) const
00355     {
00356         // Client Id format:
00357         // m_client_id[0] = n - Size of client id
00358         // m_client_id[1] to m_client_id[n] - Client Id in BCD format
00359         // where each nibble is a binary-coded decimal digit
00360
00361         // Masks to extract the 2 nibbles of every byte
00362         const BYTE c_lower_nibble = 0x0F;
00363         const BYTE c_upper_nibble = 0xF0;
00364
00365         // Convert each nibble to a character in order to form the string
00366         BYTE val = 0;
00367         for(UINT16 idx = 1; idx <= m_client_id[0]; idx++)
00368         {
00369             // Extract the upper nibble of the byte
00370             val = m_client_id[idx] & c_upper_nibble;
00371             val = val >> 4;
00372             client_id_str << val;
00373
00374             // Extract the lower nibble of the byte
00375             client_id_str << (m_client_id[idx] & c_lower_nibble);
00376         }
00377     }
00378
00380     enum { MAX_SIZE = 23 };
00381
00383     BYTE m_client_id[MAX_SIZE];
00384 };
00385
00387 struct ClientName
00388 {
00390     ClientName()
00391     {
00392     }
00393
00395     ClientName(const BYTE* client_name, Dcs dcs)
00396     {
00397         // The received client name is encoded in 7-bit format and
00398         // packed using USSD packing as per the GSM 03.38 spec Sec 6.
00399         const BYTE c_dcs = 0x0F;
00400         if(dcs != c_dcs)
00401             return;
00402
00403         // mask
00404         const BYTE c_value_mask_ref = 0x7F;
00405         const BYTE c_carry_mask_ref = 0x80;
00406
00407         BYTE value_mask = c_value_mask_ref;
00408         BYTE carry_mask = c_carry_mask_ref;
00409         BYTE carry_val = 0;
00410         BYTE temp_val = 0;
00411         UINT16 shift_idx = 0;
00412
00413         for(UINT16 idx = 0; client_name[idx] != '\0'; idx++)
00414         {
00415             shift_idx = idx % 7;
00416
00417             temp_val = client_name[idx] & value_mask;
00418             temp_val = temp_val << shift_idx;
00419             temp_val = temp_val | carry_val;
00420
00421             // Append the value in the string
00422             m_client_name.Insert((m_client_name.GetLength() + 1), temp_val);
00423
00424             // Update the carry value from this byte
00425             carry_val = (client_name[idx] & carry_mask) >> (7 - shift_idx);
00426
00427             // Update the value of value mask and carry mask
00428             value_mask = value_mask >> 1;
00429             carry_mask = carry_mask | (carry_mask >> 1);
00430
00431             if((shift_idx == 0) && (idx != 0))
00432             {
00433                 temp_val = client_name[idx] & 0xFE;
00434                 temp_val = temp_val >> 1;
00435
00436                 // Append the value in the string
00437                 m_client_name.Insert((m_client_name.GetLength() + 1), temp_val);
00438
00439                 value_mask = c_value_mask_ref;
00440                 carry_mask = c_carry_mask_ref;
00441             }
00442         }
00443
00444     } // Argument Constructor
00445
00447     enum { MAX_SIZE = 63 };
00448
00450     String m_client_name;
00451 };
00452
00457 struct ClientInfo
00458 {
00460     ClientInfo()
00461     {
00462     }
00463
00465     ClientInfo(const ClientId& client_id, const ClientName& client_name) :
00466                 m_client_id(client_id), m_client_name(client_name)
00467     {
00468     }
00469
00471     ClientId    m_client_id;
00472
00474     ClientName  m_client_name;
00475 };
00476
00478 struct MlcNumber
00479 {
00481     MlcNumber()
00482     {
00483         memset(m_mlc_number, 0, MAX_SIZE);
00484     }
00485
00487     enum { MAX_SIZE = 10 };
00488
00490     BYTE m_mlc_number[MAX_SIZE];
00491 };
00492
00494 enum LcsErrorCode
00495 {
00496     /*****      GSM 04.80, Annex A      *****/
00498     LcsSystemFailure,
00499
00501     LcsUnexpectedDataValue,
00502
00504     LcsDataMissing,
00505
00507     LcsFacilityNotSupported,
00508
00510     LcsSsSubscriptionViolation,
00511
00516     LcsPosMethodFailure,
00517
00518     /*****      Lcs-defined errors      *****/
00519
00521     LcsNoError,
00522
00524     LcsTimeOut,
00525
00527     LcsInternalError,
00528
00530     LcsProviderNotAvailable,
00531
00539     LcsInvalidInvokation,
00540
00541     /*****      GLTP-specific errors    *****/
00542
00544     LcsGltpConnSetupFailure,
00545
00547     LcsGltpTimeOut,
00548
00550     LcsGltpSendFailure,
00551
00553     LcsGltpInvalidData,
00554
00556     LcsGltpMolrInProgress
00557 };
00558
00560 enum UartBaudRate {
00561     Ubd2400 = 2400,
00562     Ubd4800 = 4800,
00563     Ubd9600 = 9600,
00564     Ubd19200 = 19200,
00565     Ubd38400 = 38400,
00566     Ubd57600 = 57600,
00567     Ubd115200 = 115200,
00568     Ubd230400 = 230400,
00569     Ubd460800 = 460800,
00570     Ubd921600 = 921600
00571 };
00572
00574 enum UartDataBits {
00575     #ifdef APOXI_RTOS_WIN32
00576         UdbFive = 0x00, // Same as CS5
00577         UdbSix = 0x04, // Same as CS6
00578         UdbSeven = 0x08, // Same as CS7
00579         UdbEight = 0x0c // Same as CS8
00580     #else
00581         UdbFive = CS5,
00582         UdbSix = CS6,
00583         UdbSeven = CS7,
00584         UdbEight = CS8
00585     #endif
00586 };
00587
00589 enum UartParity {
00590     ParityNone = 0,
00591     ParityEven = PARENB,
00592     ParityOdd = PARODD
00593 };
00594
00596 enum UartStopBits {
00597     OneStopBit = 0,
00598     TwoStopBits = STOPB
00599 };
00600
00602 enum UartFlowControl {
00603     UfcXonXoff = SIO_FCTL_SW,
00604     UfcHardware = SIO_FCTL_HW,
00605     UfcNone = SIO_FCTL_OFF
00606 };
00607
00609 struct NmeaUartSettings
00610 {
00612     NmeaUartSettings() {
00613         m_baud_rate = Ubd115200;
00614         m_data_bits = UdbEight;
00615         m_parity = ParityNone;
00616         m_stop_bits = OneStopBit;
00617         m_flow_control = UfcHardware;
00618     }
00619
00620     UartBaudRate m_baud_rate;
00621     UartDataBits m_data_bits;
00622     UartParity m_parity;
00623     UartStopBits m_stop_bits;
00624     UartFlowControl m_flow_control;
00625 };
00626
00627 #endif // AddOns_Lcs_Common_LcsTypes_hpp
00628
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsUtils.cpp File Reference

AddOns/Lcs/Common/LcsUtils.cpp File Reference

#include "LcsPreComp.hpp"
#include "LcsUtils.hpp"
#include "LcsDecls.hpp"

Include dependency graph for LcsUtils.cpp:

Variables

const UINT8 | BASE_10 = 10
const UINT8 | MAX_EXPONENT = 6
const UINT32 | RAISE_2_23 = 0x00800000

Variable Documentation

const UINT8 BASE_10 = 10

const UINT8 MAX_EXPONENT = 6

const UINT32 RAISE_2_23 = 0x00800000

Generated on Tue Jan 24 16:34:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsUtils.hpp File Reference

AddOns/Lcs/Common/LcsUtils.hpp File Reference

#include "LcsTypes.hpp"

Include dependency graph for LcsUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsUtils
This is a utility Class,used by all providers for miscellaneous operations. More...
struct | UtcTime

Defines

#define | AddOns_Lcs_Common_LcsUtils_hpp

Variables

const UINT8 | MAX_K_VALUE = 128

Define Documentation

#define AddOns_Lcs_Common_LcsUtils_hpp

Variable Documentation

const UINT8 MAX_K_VALUE = 128

Generated on Tue Jan 24 16:34:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/Common/LcsUtils.hpp Source File

AddOns/Lcs/Common/LcsUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_Common_LcsUtils_hpp)
00010 #define AddOns_Lcs_Common_LcsUtils_hpp
00011
00012 #include "LcsTypes.hpp"
00013
00014 struct LcsQos;
00015
00016 const UINT8 MAX_K_VALUE = 128;
00017
00018 struct UtcTime {
00019     INT16 m_year;
00020     INT16 m_month;
00021     INT16 m_day;
00022     INT16 m_hour;
00023     INT16 m_min;
00024     INT16 m_sec;
00025     INT16 m_milli_sec;
00026 };
00027
00029 class LcsUtils
00030 {
00032     public:
00033
00035         ~LcsUtils();
00036
00038         static LcsUtils* GetInstance();
00039
00041         static void ReleaseInstance();
00042
00044         void DecodeLatitude(UINT32 coded_latitude, SignedValue& actual_latitude) const;
00045
00047         void DecodeLongitude(UINT32 coded_longitude, SignedValue& actual_longitude) const;
00048
00050         void DecodeAltitude(SignedValue& actual_altitude) const;
00051
00053         void FormQos(const LcsMmiQos& lcs_mmi_qos, LcsQos& lcs_qos) const;
00054
00056         UINT8 EncodeUncertRadius(const UnsignedValue& uncert_radius) const;
00057
00059         UnsignedValue DecodeUncertRadius(UINT8 k_value) const { return m_uncert_radius[k_value]; }
00060
00062         UINT16 DecodeAngle(UINT8 angle) const { return ((angle << 1) + ((angle + 1) << 1)) >> 1; }
00063
00065         UINT32 DecodeInnerRadius(UINT16 inner_radius) const { return 5 * inner_radius; }
00066
00068         void DecodeUncertAltitude(UINT8 k_value, UnsignedValue& uncert_altitude) const;
00069
00071         void DecodeLocEstimate(LocationEstimate& loc_estimate) const;
00072
00077         INT32 Power(INT16 number, UINT8 exponent);
00078
00080         void GpsToUtcTime(UINT16 gps_week, UINT32 gps_tow, UtcTime& utc_time);
00081
00082
00084     private:
00085
00087         LcsUtils();
00088
00090         void FillUncertRadiusMap();
00091
00092
00094     private:
00095
00097         static LcsUtils* m_lcs_utils;
00098
00100         UnsignedValue m_uncert_radius[MAX_K_VALUE];
00101
00102 }; // LcsUtils
00103
00104 #endif // AddOns_Lcs_Common_LcsUtils_hpp
00105
Generated on Tue Jan 24 14:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/AidDataRequests.cpp File Reference

AddOns/Lcs/GLTP/AidDataRequests.cpp File Reference

#include "LcsPreComp.hpp"
#include "AidDataRequests.hpp"
#include "GltpTypes.hpp"

Include dependency graph for AidDataRequests.cpp:

Generated on Tue Jan 24 16:34:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/AidDataRequests.hpp File Reference

AddOns/Lcs/GLTP/AidDataRequests.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpAidDataRequests
class | GltpAidingRequest
class | GltpHelloRequest
class | GltpMsmtRequest
class | GltpPositionRequest
class | GltpRequest

Defines

#define | AddOns_Lcs_GLTP_AidDataRequests_hpp

Define Documentation

#define AddOns_Lcs_GLTP_AidDataRequests_hpp

Generated on Tue Jan 24 16:34:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/AidDataRequests.hpp Source File

AddOns/Lcs/GLTP/AidDataRequests.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_GLTP_AidDataRequests_hpp)
00010 #define AddOns_Lcs_GLTP_AidDataRequests_hpp
00011
00012 class GltpRequest
00013 {
00015     public:
00016
00018         enum { HEADER_SIZE = 14 };
00019
00021         virtual ~GltpRequest();
00022
00024         virtual const BYTE* GetRequest() const = 0;
00025
00027         virtual INT GetSize() const = 0;
00028
00030         static UINT16 GetUnitId() { return m_unit_id; }
00031
00032
00034     protected:
00035
00037         GltpRequest();
00038
00040         BYTE* FillHeader(BYTE* buffer, UINT32 tag, UINT16 data_length);
00041
00042
00044     protected:
00045
00047         static UINT16 m_unit_id;
00048
00049 }; // GltpRequest
00050
00051
00052 class GltpHelloRequest : public GltpRequest
00053 {
00054     typedef GltpRequest Base;
00055
00057     public:
00058
00060         GltpHelloRequest();
00061
00063         virtual ~GltpHelloRequest();
00064
00066         virtual const BYTE* GetRequest() const { return m_hello_req; }
00067
00069         virtual INT GetSize() const { return HELLO_REQ_SIZE; }
00070
00072         void FormRequest(UINT16 unit_id);
00073
00074
00076     private:
00077
00078         enum
00079         {
00080             HELLO_DATA_SIZE = 18,
00081             HELLO_REQ_SIZE = Base::HEADER_SIZE + HELLO_DATA_SIZE
00082         };
00083
00085         BYTE m_hello_req[HELLO_REQ_SIZE];
00086
00087 }; // GltpHelloRequest
00088
00089
00090 class GltpAidingRequest : public GltpRequest
00091 {
00092     typedef GltpRequest Base;
00093
00095     public:
00096
00098         GltpAidingRequest();
00099
00101         virtual ~GltpAidingRequest();
00102
00104         virtual const BYTE* GetRequest() const { return m_aid_req; }
00105
00107         virtual INT GetSize() const { return AID_REQ_SIZE; }
00108
00110         void FormRequest(INT32 init_lat, INT32 init_long, BOOLEAN ms_mode);
00111
00112
00114     private:
00115
00116         enum
00117         {
00118             AIDING_REQ_LEN = 18,
00119             AID_REQ_SIZE = Base::HEADER_SIZE + AIDING_REQ_LEN
00120         };
00121
00123         BYTE m_aid_req[AID_REQ_SIZE];
00124
00125 }; // GltpAidingRequest
00126
00127
00128 class MeasurementData;
00129 class GltpMsmtRequest : public GltpRequest
00130 {
00131     typedef GltpRequest Base;
00132
00134     public:
00135
00137         GltpMsmtRequest();
00138
00140         virtual ~GltpMsmtRequest();
00141
00143         virtual const BYTE* GetRequest() const { return m_msr_req; }
00144
00146         virtual INT GetSize() const { return m_size; }
00147
00149         void FormRequest(const MeasurementData& msr_data);
00150
00151
00153     private:
00154
00156         BYTE* m_msr_req;
00157
00159         INT m_size;
00160
00161 }; // GltpMsmtRequest
00162
00163
00164 class GltpPositionRequest : public GltpRequest
00165 {
00166     typedef GltpRequest Base;
00167
00169     public:
00170
00172         GltpPositionRequest();
00173
00175         virtual ~GltpPositionRequest();
00176
00178         virtual const BYTE* GetRequest() const { return m_posn_req; }
00179
00181         virtual INT GetSize() const { return POSN_REQ_SIZE; }
00182
00184         void FormRequest(BYTE* posn_data);
00185
00186
00188     private:
00189
00191         BYTE* EncodePositionValue(UINT32* posn_data, BYTE* posn_value);
00192
00193
00195     private:
00196
00197         enum
00198         {
00199             POSN_DATA_SIZE = 84,
00200             POSN_REQ_SIZE = Base::HEADER_SIZE + POSN_DATA_SIZE
00201         };
00202
00204         BYTE m_posn_req[POSN_REQ_SIZE];
00205
00206 }; // GltpPositionRequest
00207
00208
00209 class GltpAidDataRequests
00210 {
00212     public:
00213
00215         GltpAidDataRequests();
00216
00218         ~GltpAidDataRequests();
00219
00221         // 'Hello' request to be sent to the GL server
00222         void SetUnitId(UINT16 unit_id);
00223
00226         void FormAidingRequest(INT32 init_lat, INT32 init_long, BOOLEAN ms_mode);
00227
00230         void FormPosnRequest(BYTE* posn_data);
00231
00234         void FormMsmtRequest(const MeasurementData& msr_data);
00235
00237         const GltpHelloRequest& GetHelloRequest() const { return m_hello_req; }
00238
00240         const GltpAidingRequest& GetAidingRequest() const { return m_aid_req; }
00241
00243         const GltpPositionRequest& GetPosnRequest() const { return m_posn_req; }
00244
00246         const GltpMsmtRequest& GetMsmtRequest() const { return m_msmt_req; }
00247
00248
00250     private:
00251
00253         GltpHelloRequest m_hello_req;
00254
00256         GltpAidingRequest m_aid_req;
00257
00259         GltpPositionRequest m_posn_req;
00260
00262         GltpMsmtRequest m_msmt_req;
00263
00264 }; // GltpAidDataRequests
00265
00266 #endif // AddOns_Lcs_GLTP_AidDataRequests_hpp
00267
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/AssistanceData.cpp File Reference

AddOns/Lcs/GLTP/AssistanceData.cpp File Reference

#include "LcsPreComp.hpp"
#include "AssistanceData.hpp"

Include dependency graph for AssistanceData.cpp:

Generated on Tue Jan 24 16:34:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/AssistanceData.hpp File Reference

AddOns/Lcs/GLTP/AssistanceData.hpp File Reference

#include "GltpTypes.hpp"

Include dependency graph for AssistanceData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpAssistanceData

Defines

#define | AddOns_Lcs_GLTP_AssistanceData_hpp

Define Documentation

#define AddOns_Lcs_GLTP_AssistanceData_hpp

Generated on Tue Jan 24 16:34:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/AssistanceData.hpp Source File

AddOns/Lcs/GLTP/AssistanceData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_GLTP_AssistanceData_hpp)
00010 #define AddOns_Lcs_GLTP_AssistanceData_hpp
00011
00012 #include "GltpTypes.hpp"
00013
00014 class GltpAssistanceData
00015 {
00017     public:
00018
00020         GltpAssistanceData();
00021
00023         ~GltpAssistanceData();
00024
00029         BOOLEAN Append(const BYTE* ad_buf, INT size);
00030
00035         const BYTE* GetBuffer() const { return m_ad_buf; }
00036
00038         INT GetSize() const { return m_buf_pos; }
00039
00041         void SetReferenceTime(const ReferenceTime& ref_time) { m_ref_time = ref_time; }
00042
00044         const ReferenceTime& GetReferenceTime() const { return m_ref_time; }
00045
00047         void SetReferenceLocation(const ReferenceLocation& ref_loc) { m_ref_loc = ref_loc; }
00048
00050         const ReferenceLocation& GetReferenceLocation() const { return m_ref_loc; }
00051
00053         BOOLEAN IsAidingStale() const { return m_is_stale; }
00054
00059         void SetAidingStale(BOOLEAN stale) { m_is_stale = stale; }
00060
00061
00063     private:
00064
00069         const BYTE* ValidateHeader(const BYTE* ad_buf, INT& size);
00070
00071
00073     private:
00074
00075         enum
00076         {
00081             ASSIST_DATA_SIZE = 2400
00082         };
00083
00085         BYTE m_ad_buf[ASSIST_DATA_SIZE];
00086
00091         INT m_buf_pos;
00092
00097         UINT8 m_total_packets;
00098
00100         UINT8 m_packet_count;
00101
00106         ReferenceTime m_ref_time;
00107
00112         ReferenceLocation m_ref_loc;
00113
00119         BOOLEAN m_is_stale;
00120
00121 }; // GltpAssistanceData
00122
00123 #endif // AddOns_Lcs_GLTP_AssistanceData_hpp
00124
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpArgs.cpp File Reference

AddOns/Lcs/GLTP/GltpArgs.cpp File Reference

#include "LcsPreComp.hpp"
#include "GltpArgs.hpp"

Include dependency graph for GltpArgs.cpp:

Generated on Tue Jan 24 16:34:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpArgs.hpp File Reference

AddOns/Lcs/GLTP/GltpArgs.hpp File Reference

#include <Kernel/Message.hpp>
#include <AddOns/Lcs/GLTP/GltpTypes.hpp>

Include dependency graph for GltpArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MeasurementDataArg

Defines

#define | AddOns_Lcs_GLTP_GltpArgs_hpp

Define Documentation

#define AddOns_Lcs_GLTP_GltpArgs_hpp

Generated on Tue Jan 24 16:34:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpArgs.hpp Source File

AddOns/Lcs/GLTP/GltpArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\GLTP\GltpArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_GLTP_GltpArgs_hpp)
00016 #define AddOns_Lcs_GLTP_GltpArgs_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <AddOns/Lcs/GLTP/GltpTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class MeasurementDataArg
00028     ====================================================================== */
00029
00031 class MeasurementDataArg : public StackMsgArgument {
00032     friend class GltpStackMsgArgsDestroyTableNode;
00033     public:
00034         MeasurementDataArg(const MeasurementData& msr_data);
00035         MeasurementDataArg();
00036         ~MeasurementDataArg();
00037
00038         static const MeasurementDataArg& Cast(const StackMsgArgument& arg);
00039         const MeasurementData& GetMsrData() const { return m_msr_data; }
00040
00041         enum  {
00042             ID = 4225
00043             };
00044
00045     private:
00046
00047         static void Destroy(StackMsgArgument* arg) { delete ((MeasurementDataArg*) arg); }
00048
00049         MeasurementData m_msr_data;
00050
00051     };
00052
00053 // Inline definitions
00054 inline const MeasurementDataArg& MeasurementDataArg::Cast(const StackMsgArgument& arg) {
00055     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MeasurementDataArg!\n");
00056     return ((MeasurementDataArg &) arg);
00057 }
00058
00059
00060 #endif // AddOns_Lcs_GLTP_GltpArgs_hpp
00061
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpMsgProcessor.cpp File Reference

AddOns/Lcs/GLTP/GltpMsgProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "GltpMsgProcessor.hpp"
#include "GltpTypes.hpp"

Include dependency graph for GltpMsgProcessor.cpp:

Generated on Tue Jan 24 16:35:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpMsgProcessor.hpp File Reference

AddOns/Lcs/GLTP/GltpMsgProcessor.hpp File Reference

#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for GltpMsgProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpMsgProcessor
This class sends the Gltp requests to the Lcs Stack. More...

Defines

#define | AddOns_Lcs_GLTP_MsgProcessor_hpp

Define Documentation

#define AddOns_Lcs_GLTP_MsgProcessor_hpp

Generated on Tue Jan 24 16:35:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpMsgProcessor.hpp Source File

AddOns/Lcs/GLTP/GltpMsgProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_GLTP_MsgProcessor_hpp)
00010 #define AddOns_Lcs_GLTP_MsgProcessor_hpp
00011
00012 #include <Apc/SignalHandler/StackMsgProcessor.hpp>
00013
00014 struct ReferenceLocation;
00015 struct ReferenceTime;
00016
00018 class GltpMsgProcessor : public StackMsgProcessor
00019 {
00021     public:
00022
00027         static void ProcessMeasurementDataReq(  const BYTE* ad_buf,
00028                                                 INT size,
00029                                                 BOOLEAN forced_fix = FALSE);
00030
00035         static void ProcessReferenceTimeReq(const ReferenceTime& ref_time);
00036
00041         static void ProcessRefLocReq(const ReferenceLocation& ref_loc);
00042
00043 };
00044
00045 #endif // AddOns_Lcs_GLTP_MsgProcessor_hpp
00046
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpMsgTypes.cpp File Reference

AddOns/Lcs/GLTP/GltpMsgTypes.cpp File Reference

#include "LcsPreComp.hpp"
#include "GltpMsgTypes.hpp"

Include dependency graph for GltpMsgTypes.cpp:

Generated on Tue Jan 24 16:35:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpMsgTypes.hpp File Reference

AddOns/Lcs/GLTP/GltpMsgTypes.hpp File Reference

#include <AddOns/Lcs/GLTP/GltpTypes.hpp>

Include dependency graph for GltpMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CloseDataConnMsg
class | GltpConnStatusMsg
class | SendRequestMsg
class | SetupDataConnMsg

Defines

#define | AddOns_Lcs_GLTP_GltpMsgTypes_hpp

Define Documentation

#define AddOns_Lcs_GLTP_GltpMsgTypes_hpp

Generated on Tue Jan 24 16:35:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpMsgTypes.hpp Source File

AddOns/Lcs/GLTP/GltpMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\GLTP\GltpMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(AddOns_Lcs_GLTP_GltpMsgTypes_hpp)
00014 #define AddOns_Lcs_GLTP_GltpMsgTypes_hpp
00015 #include <AddOns/Lcs/GLTP/GltpTypes.hpp>
00016 /* ----------------------------------------------------------------------
00017     Classes
00018     ---------------------------------------------------------------------- */
00019 /*  ======================================================================
00020     Class SetupDataConnMsg
00021     ====================================================================== */
00023 class SetupDataConnMsg : public ContextMsg {
00024     public:
00025         SetupDataConnMsg(ExecutionContext* context);
00026         virtual ~SetupDataConnMsg();
00027
00028         virtual const MsgMetaData& GetMetaData() const;
00029         virtual Message* Clone() const;
00030
00031         enum  {
00032             ID = 4230
00033             };
00034
00035     private:
00036         static const MsgMetaData m_meta_data;
00037
00038     };
00039 /*  ======================================================================
00040     Class SendRequestMsg
00041     ====================================================================== */
00043 class SendRequestMsg : public ContextMsg {
00044     public:
00045         SendRequestMsg(ExecutionContext* context, BYTE* request, INT size);
00046         virtual ~SendRequestMsg();
00047
00048         virtual const MsgMetaData& GetMetaData() const;
00049         BYTE* GetRequest() const { return m_request; }
00050         INT GetSize() const { return m_size; }
00051         virtual Message* Clone() const;
00052
00053         enum  {
00054             ID = 4231
00055             };
00056
00057     private:
00058         static const MsgMetaData m_meta_data;
00059         BYTE* m_request;
00060         INT m_size;
00061
00062     };
00063 /*  ======================================================================
00064     Class GltpConnStatusMsg
00065     ====================================================================== */
00067 class GltpConnStatusMsg : public ContextMsg {
00068     public:
00069         GltpConnStatusMsg(ExecutionContext* context, const GltpConnStatus& status);
00070         virtual ~GltpConnStatusMsg();
00071
00072         virtual const MsgMetaData& GetMetaData() const;
00073         const GltpConnStatus& GetStatus() const { return m_status; }
00074         virtual Message* Clone() const;
00075
00076         enum  {
00077             ID = 4232
00078             };
00079
00080     private:
00081         static const MsgMetaData m_meta_data;
00082         GltpConnStatus m_status;
00083
00084     };
00085 /*  ======================================================================
00086     Class CloseDataConnMsg
00087     ====================================================================== */
00089 class CloseDataConnMsg : public ContextMsg {
00090     public:
00091         CloseDataConnMsg(ExecutionContext* context);
00092         virtual ~CloseDataConnMsg();
00093
00094         virtual const MsgMetaData& GetMetaData() const;
00095         virtual Message* Clone() const;
00096
00097         enum  {
00098             ID = 4233
00099             };
00100
00101     private:
00102         static const MsgMetaData m_meta_data;
00103
00104     };
00105 #endif // AddOns_Lcs_GLTP_GltpMsgTypes_hpp
00106
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpProviderImpl.cpp File Reference

AddOns/Lcs/GLTP/GltpProviderImpl.cpp File Reference

#include "LcsPreComp.hpp"
#include "GltpProviderImpl.hpp"
#include "AidDataRequests.hpp"
#include "AssistanceData.hpp"
#include "GltpMsgTypes.hpp"
#include "GltpSignalMapTableNode.hpp"
#include "GltpMsgProcessor.hpp"
#include "GltpArgs.hpp"
#include "GltpStackMsgArgs.hpp"
#include <Afs/Ffs/FlsFile.hpp>
#include <AddOns/Lcs/Common/LcsUtils.hpp>
#include <AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>
#include <AddOns/Lcs/Common/LcsCommonArgs.hpp>
#include <AddOns/Lcs/Common/LcsDecls.hpp>
#include <AddOns/Lcs/Common/LcsReqProcessor.hpp>

Include dependency graph for GltpProviderImpl.cpp:

Variables

const CHAR * AID_DATA_FNAME = "AidDataConfig"

Variable Documentation

const CHAR* AID_DATA_FNAME = "AidDataConfig"

Generated on Tue Jan 24 16:35:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpProviderImpl.hpp File Reference

AddOns/Lcs/GLTP/GltpProviderImpl.hpp File Reference

#include <AddOns/Lcs/Common/LcsProviderImplBase.hpp>

Include dependency graph for GltpProviderImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpProviderImpl
The implementation of the GLTP protocol provider. More...

Defines

#define | AddOns_Lcs_GLTP_GltpProviderImpl_hpp

Define Documentation

#define AddOns_Lcs_GLTP_GltpProviderImpl_hpp

Generated on Tue Jan 24 16:35:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpProviderImpl.hpp Source File

AddOns/Lcs/GLTP/GltpProviderImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_GLTP_GltpProviderImpl_hpp)
00010 #define AddOns_Lcs_GLTP_GltpProviderImpl_hpp
00011
00012 #include <AddOns/Lcs/Common/LcsProviderImplBase.hpp>
00013
00014 class Application;
00015 class GltpAidDataRequests;
00016 class GltpAssistanceData;
00017 class MeasurementData;
00018 struct LocationEstimate;
00019
00021 class GltpProviderImpl : public LcsProviderImplBase, public StackMsgDispatcher
00022 {
00023     typedef LcsProviderImplBase Base1;
00024     typedef StackMsgDispatcher Base2;
00025
00027     public:
00028
00030         virtual ~GltpProviderImpl();
00031
00033         static GltpProviderImpl* GetInstance();
00034
00036         static void ReleaseInstance();
00037
00039         virtual void Init();
00040
00045         virtual LcsErrorCode TransferLocationReq(MolrType molr_type,
00046                                                 LocationMethod location_method,
00047                                                 const LcsMmiQos& lcs_mmi_qos,
00048                                                 const ClientId& client_id,
00049                                                 const MlcNumber& mlc_number,
00050                                                 INT32 repeat_interval);
00051
00053         virtual void OnTimeOut(LcsTimerType timer_type);
00054
00059         void RegisterConnApp(Application* conn_app)
00060         {
00061             ASSERT_DEBUG(conn_app != NULL);
00062             m_gltp_conn_app = conn_app;
00063         }
00064
00069         void SetDataConnResult(LcsErrorCode result, BYTE* ack_buff = NULL, INT size = 0);
00070
00075         void GetConfigValues(INT32& latitude, INT32& longitude, UINT32& unit_id) const;
00076
00081         void StoreConfigValues(INT32 latitude, INT32 longitude, UINT32 unit_id);
00082
00083
00085     protected:
00086
00088         virtual BOOLEAN OnMessage(const Message& msg);
00089
00094         BOOLEAN OnMeasurementResp(const StackMsgArgument& arg);
00095
00097         virtual BOOLEAN OnAbortResponse(const StackMsgArgument& arg);
00098
00099
00101     private:
00102
00104         GltpProviderImpl();
00105
00107         void ProcessMolr(const MolrInfo* molr_info);
00108
00110         void SetupDataConn();
00111
00113         void SendHello();
00114
00116         void ProcessHelloAck(const BYTE* hello_ack_buf, INT size);
00117
00119         void ProcessAidingAck(const BYTE* hello_ack_buf, INT size);
00120
00126         BOOLEAN ProcessPositionData(const BYTE* position_buf, INT size);
00127
00136         BOOLEAN ExtractLocationEstimate(const BYTE* head, LocationEstimate& loc_est);
00137
00142         const BYTE* DecodeLocationValue(const BYTE* pos_buf, BYTE* pos_value) const;
00143
00145         void TerminateMolr();
00146
00151         void LoadConfigValues() const;
00152
00157         BOOLEAN ValidateData(const BYTE* data, INT size) const;
00158
00159
00161     private:
00162
00164         static GltpProviderImpl* m_self;
00165
00167         static const StackMsgArgMap<GltpProviderImpl> m_arg_map[];
00168
00170         enum
00171         {
00172             Idle,
00173             SetupDataConnSent,
00174
00175             DataConnEstablished,
00176             HelloSent,
00177
00178             HelloAckRcvd,
00179             AidingReqSent,
00180
00181             AidingAckRcvd,
00182
00183             MeasurementSent,
00184
00185             PosDataSent
00186
00187         } m_molr_state;
00188
00190         Application* m_gltp_conn_app;
00191
00193         Application* m_lcs_app;
00194
00196         GltpAidDataRequests* m_ad_reqs;
00197
00199         GltpAssistanceData* m_assist_data;
00200
00202         BOOLEAN m_ms_based;
00203
00205         BOOLEAN m_is_inited;
00206
00208         INT m_num_attempts;
00209
00214         StackMsgArgMapContainer<GltpProviderImpl> m_arg_map_container;
00215
00216 };
00217
00218 #endif // AddOns_Lcs_GLTP_GltpProviderImpl_hpp
00219
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpSignalMapTableNode.cpp File Reference

AddOns/Lcs/GLTP/GltpSignalMapTableNode.cpp File Reference

#include "LcsPreComp.hpp"
#include "GltpSignalMapTableNode.hpp"
#include "GltpSignalProcessor.hpp"

Include dependency graph for GltpSignalMapTableNode.cpp:

Generated on Tue Jan 24 16:35:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpSignalMapTableNode.hpp File Reference

AddOns/Lcs/GLTP/GltpSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for GltpSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpSignalMapTableNode

Defines

#define | AddOns_Lcs_GLTP_GltpSignalMapTable_hpp

Define Documentation

#define AddOns_Lcs_GLTP_GltpSignalMapTable_hpp

Generated on Tue Jan 24 16:35:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpSignalMapTableNode.hpp Source File

AddOns/Lcs/GLTP/GltpSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_GLTP_GltpSignalMapTable_hpp)
00010 #define AddOns_Lcs_GLTP_GltpSignalMapTable_hpp
00011
00012 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00013
00017 class GltpSignalMapTableNode : public SignalMapTableNode
00018 {
00019     typedef SignalMapTableNode Base;
00020
00022     public:
00023
00025         ~GltpSignalMapTableNode();
00026
00028         static GltpSignalMapTableNode* GetInstance();
00029
00031         static void ReleaseInstance();
00032
00033
00035     private:
00036
00038         GltpSignalMapTableNode();
00039
00040
00042     private:
00043
00045         static GltpSignalMapTableNode* m_node;
00046
00048         static const SignalMapTableEntry m_signal_map_table[];
00049
00050 }; // GltpSignalMapTableNode
00051
00052 #endif  // AddOns_Lcs_GLTP_GltpSignalMapTable_hpp
00053
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpSignalProcessor.cpp File Reference

AddOns/Lcs/GLTP/GltpSignalProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "GltpSignalProcessor.hpp"
#include "GltpArgs.hpp"

Include dependency graph for GltpSignalProcessor.cpp:

Generated on Tue Jan 24 16:35:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpSignalProcessor.hpp File Reference

AddOns/Lcs/GLTP/GltpSignalProcessor.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpSignalProcessor

Defines

#define | AddOns_Lcs_GLTP_GltpSignalProcessor_hpp

Define Documentation

#define AddOns_Lcs_GLTP_GltpSignalProcessor_hpp

Generated on Tue Jan 24 16:35:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpSignalProcessor.hpp Source File

AddOns/Lcs/GLTP/GltpSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_GLTP_GltpSignalProcessor_hpp)
00010 #define AddOns_Lcs_GLTP_GltpSignalProcessor_hpp
00011
00016 class GltpSignalProcessor
00017 {
00019     public:
00020
00025         static void PostMeasurementData(const ProcessPtr& process_ptr);
00026
00027 }; // GltpSignalProcessor
00028
00029 #endif // AddOns_Lcs_GLTP_GltpSignalProcessor_hpp
00030
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpStackMsgArgs.cpp File Reference

AddOns/Lcs/GLTP/GltpStackMsgArgs.cpp File Reference

#include "LcsPreComp.hpp"
#include "GltpStackMsgArgs.hpp"

Include dependency graph for GltpStackMsgArgs.cpp:

Generated on Tue Jan 24 16:36:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpStackMsgArgs.hpp File Reference

AddOns/Lcs/GLTP/GltpStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <AddOns/Lcs/GLTP/GltpArgs.hpp>

Include dependency graph for GltpStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpStackMsgArgsDestroyTableNode

Defines

#define | AddOns_Lcs_GLTP_GltpStackMsgArgs_hpp

Define Documentation

#define AddOns_Lcs_GLTP_GltpStackMsgArgs_hpp

Generated on Tue Jan 24 16:36:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpStackMsgArgs.hpp Source File

AddOns/Lcs/GLTP/GltpStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\GLTP\GltpArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_GLTP_GltpStackMsgArgs_hpp)
00016 #define AddOns_Lcs_GLTP_GltpStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <AddOns/Lcs/GLTP/GltpArgs.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class GltpStackMsgArgsDestroyTableNode
00028     ====================================================================== */
00029
00030 class GltpStackMsgArgsDestroyTableNode : public StackMsgArgDestroyTableNode {
00031     public:
00032
00033         static GltpStackMsgArgsDestroyTableNode* GetInstance();
00034
00035     private:
00036         GltpStackMsgArgsDestroyTableNode();
00037
00038
00039         static GltpStackMsgArgsDestroyTableNode* m_node;
00040         static const ArgumentDestroyEntry m_destroy_table[];
00041
00042     };
00043
00044 #endif // AddOns_Lcs_GLTP_GltpStackMsgArgs_hpp
00045
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpTypes.hpp File Reference

AddOns/Lcs/GLTP/GltpTypes.hpp File Reference

#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for GltpTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AidingData
struct | GpsFixDataInt
This structure stores the GPS fix data for internal conversion later. More...
class | MeasurementData
struct | ReferenceLocation
struct | ReferenceTime

Defines

#define | AddOns_Lcs_GLTP_GltpTypes_hpp

Enumerations

enum GltpConnStatus {
PositionDataReceived = 0, MeasurementDataSent, AidingAckReceived, HelloAckRxed,
ConnectionReqSent, ConnectionError
}
GltpConnStatus. More...

Define Documentation

#define AddOns_Lcs_GLTP_GltpTypes_hpp

Enumeration Type Documentation

enum GltpConnStatus

GltpConnStatus.

Enumerator:
PositionDataReceived
MeasurementDataSent
AidingAckReceived
HelloAckRxed
ConnectionReqSent
ConnectionError

Generated on Tue Jan 24 16:36:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/GLTP/GltpTypes.hpp Source File

AddOns/Lcs/GLTP/GltpTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_GLTP_GltpTypes_hpp)
00010 #define AddOns_Lcs_GLTP_GltpTypes_hpp
00011
00012 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00013
00015 struct ReferenceTime
00016 {
00018     ReferenceTime() : m_gps_week(0), m_gps_tow(0), m_precision(0)
00019     {
00020     }
00021
00023     ReferenceTime(UINT16 gps_week, UINT32 gps_tow, UINT32 precision) :
00024                 m_gps_week(gps_week), m_gps_tow(gps_tow), m_precision(precision)
00025     {
00026     }
00027
00029     ReferenceTime(const ReferenceTime& rhs)
00030     {
00031         m_gps_week = rhs.m_gps_week;
00032         m_gps_tow = rhs.m_gps_tow;
00033         m_precision = rhs.m_precision;
00034     }
00035
00037     UINT16 m_gps_week;
00038     UINT32 m_gps_tow;
00039     UINT32 m_precision;
00040 };
00041
00043 struct ReferenceLocation
00044 {
00045     enum { InvalidValue = 0xFFFFFFFF };
00046
00048     ReferenceLocation() : m_altitude(InvalidValue)
00049     {
00050         const INT32 INIT_LAT = 49429090;
00051         m_latitude = INIT_LAT;
00052         const INT32 INIT_LONG = 11017610;
00053         m_longitude = INIT_LONG;
00054     }
00055
00057     ReferenceLocation(INT32 latitude, INT32 longitude, INT32 altitude = InvalidValue) :
00058                     m_latitude(latitude), m_longitude(longitude), m_altitude(altitude)
00059     {
00060     }
00061
00063     ReferenceLocation(const ReferenceLocation& rhs)
00064     {
00065         m_latitude = rhs.m_latitude;
00066         m_longitude = rhs.m_longitude;
00067         m_altitude = rhs.m_altitude;
00068     }
00069
00071     INT32 m_latitude;
00072     INT32 m_longitude;
00073     INT32 m_altitude;
00074 };
00075
00077 class AidingData
00078 {
00080     public:
00081
00083         AidingData(INT length, const BYTE* aid_data)
00084         {
00085             m_aid_data.length = (SdlInteger) length;
00086             m_aid_data.apdu_ptr = (T_APDU_DATA_PTR) aid_data;
00087         }
00088
00090         ~AidingData() { }
00091
00093         const T_BYTE_STR& GetAidingData() const { return m_aid_data; }
00094
00095
00097     private:
00098
00100         AidingData();
00101
00102
00104     private:
00105
00106         T_BYTE_STR m_aid_data;
00107
00108 }; // AidingData
00109
00111 struct GpsFixDataInt
00112 {
00113     UINT16          m_gps_week;
00114     UINT32          m_gps_tow;
00115     UINT16          m_microsec;
00116     UINT8           m_speed_valid;
00118     UINT32          m_speed;
00120     UINT32          m_hdop;
00122     UINT32          m_time_tag_delta;
00124     UINT32          m_loc_error;
00125     UINT8           m_num_sats;
00126     SatelliteInfo   m_sat_info[MAX_SATS];
00127
00129     void Convert(GpsFixData& fix_data) const
00130     {
00131         fix_data.m_gps_week = m_gps_week;
00132         fix_data.m_gps_tow = m_gps_tow;
00133         fix_data.m_microsec = m_microsec;
00134         fix_data.m_speed_valid = m_speed_valid;
00135         fix_data.m_speed.m_mantissa = m_speed;
00136         const UINT16 c_exponent = 3; // As defined within Lcs stack
00137         if(m_speed > 0)
00138         {
00139             // Set the exponent to the hard-coded value
00140             fix_data.m_speed.m_exponent = c_exponent;
00141
00142             // Convert the speed from knots to m/sec: 1 knot = 0.5144444444444 m/sec
00143             UnsignedValue conv_factor;
00144             conv_factor.m_mantissa = 5144; conv_factor.m_exponent = 4;
00145             fix_data.m_speed *= conv_factor;
00146         }
00147         else
00148         {
00149             fix_data.m_speed.m_exponent = 0;
00150         }
00151         fix_data.m_hdop.m_mantissa = m_hdop;
00152         fix_data.m_hdop.m_exponent = (m_hdop != 0) ? c_exponent : 0;
00153         fix_data.m_time_tag_delta = m_time_tag_delta;
00154         fix_data.m_loc_error.m_mantissa = m_loc_error;
00155         fix_data.m_loc_error.m_exponent = (m_loc_error != 0) ? c_exponent : 0;
00156         fix_data.m_num_sats = m_num_sats;
00157         memcpy(&fix_data.m_sat_info[0], &m_sat_info[0], sizeof(m_sat_info));
00158     }
00159
00160 }; // GpsFixDataInt
00161
00163 class MeasurementData
00164 {
00166     public:
00167
00169         MeasurementData() : m_status(0), m_length(0), m_msr_data(NULL)
00170         {
00171         }
00172
00174         MeasurementData(UINT8 status, INT size, const BYTE* buffer, const GpsFixDataInt& fix_data_int)
00175             : m_status(status)
00176         {
00177             SetMsrData(size, buffer);
00178             fix_data_int.Convert(m_fix_data);
00179         }
00180
00182         MeasurementData(const MeasurementData& rhs)
00183         {
00184             if(&rhs != this)
00185             {
00186                 SetMsrData(rhs.m_length, rhs.m_msr_data);
00187                 m_status = rhs.m_status;
00188                 m_fix_data = rhs.m_fix_data;
00189             }
00190         }
00191
00193         ~MeasurementData()
00194         {
00195             delete [] m_msr_data;
00196         }
00197
00199         UINT32 GetStatus() const { return m_status; }
00200
00202         INT GetLength() const { return m_length; }
00203
00205         BYTE* GetMsrData() const { return m_msr_data; }
00206
00208         const GpsFixData& GetGpsFixData() const { return m_fix_data; }
00209
00210
00212     private:
00213
00215         void SetMsrData(INT size, const BYTE* buffer)
00216         {
00217             m_length = size;
00218             if(buffer == NULL)
00219             {
00220                 m_msr_data = NULL;
00221                 return;
00222             }
00223             ASSERT_DEBUG(size > 0);
00224             m_msr_data = new BYTE[size];
00225             memcpy(m_msr_data, buffer, size);
00226         }
00227
00228
00230     private:
00231
00233         UINT8 m_status;
00234
00236         INT m_length;
00237
00239         BYTE* m_msr_data;
00240
00242         GpsFixData m_fix_data;
00243
00244 }; // MeasurementData
00245
00247 enum GltpConnStatus
00248 {
00249     PositionDataReceived = 0,
00250     MeasurementDataSent,
00251     AidingAckReceived,
00252     HelloAckRxed,
00253     ConnectionReqSent,
00254     ConnectionError
00255
00256 }; // GltpConnStatus
00257
00258 #endif // AddOns_Lcs_GLTP_GltpTypes_hpp
00259
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaArgs.cpp File Reference

AddOns/Lcs/StandAlone/SaArgs.cpp File Reference

#include "LcsPreComp.hpp"
#include "SaArgs.hpp"

Include dependency graph for SaArgs.cpp:

Generated on Tue Jan 24 16:36:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaArgs.hpp File Reference

AddOns/Lcs/StandAlone/SaArgs.hpp File Reference

#include <Kernel/Message.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for SaArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SaLocationErrArg
class | SaMolrResultArg

Defines

#define | AddOns_Lcs_StandAlone_SaArgs_hpp

Define Documentation

#define AddOns_Lcs_StandAlone_SaArgs_hpp

Generated on Tue Jan 24 16:36:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaArgs.hpp Source File

AddOns/Lcs/StandAlone/SaArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\StandAlone\SaArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_StandAlone_SaArgs_hpp)
00016 #define AddOns_Lcs_StandAlone_SaArgs_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class SaMolrResultArg
00028     ====================================================================== */
00029
00031 class SaMolrResultArg : public StackMsgArgument {
00032     friend class SaStackMsgArgsDestroyTableNode;
00033     public:
00034         SaMolrResultArg(BYTE ti_pd, const LocationEstimate& location_estimate);
00035         SaMolrResultArg();
00036         ~SaMolrResultArg();
00037
00038         static const SaMolrResultArg& Cast(const StackMsgArgument& arg);
00039         BYTE GetTiPd() const { return m_ti_pd; }
00040         const LocationEstimate& GetLocationEstimate() const { return m_location_estimate; }
00041
00042         enum  {
00043             ID = 4235
00044             };
00045
00046     private:
00047
00048         static void Destroy(StackMsgArgument* arg) { delete ((SaMolrResultArg*) arg); }
00049
00050         BYTE m_ti_pd;
00051         LocationEstimate m_location_estimate;
00052
00053     };
00054
00055 // Inline definitions
00056 inline const SaMolrResultArg& SaMolrResultArg::Cast(const StackMsgArgument& arg) {
00057     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SaMolrResultArg!\n");
00058     return ((SaMolrResultArg &) arg);
00059 }
00060
00061
00062
00063 /*  ======================================================================
00064     Class SaLocationErrArg
00065     ====================================================================== */
00066
00068 class SaLocationErrArg : public StackMsgArgument {
00069     friend class SaStackMsgArgsDestroyTableNode;
00070     public:
00071         SaLocationErrArg(BYTE err_cause);
00072         SaLocationErrArg();
00073         ~SaLocationErrArg();
00074
00075         static const SaLocationErrArg& Cast(const StackMsgArgument& arg);
00076         BYTE GetErrCause() const { return m_err_cause; }
00077
00078         enum  {
00079             ID = 4236
00080             };
00081
00082     private:
00083
00084         static void Destroy(StackMsgArgument* arg) { delete ((SaLocationErrArg*) arg); }
00085
00086         BYTE m_err_cause;
00087
00088     };
00089
00090 // Inline definitions
00091 inline const SaLocationErrArg& SaLocationErrArg::Cast(const StackMsgArgument& arg) {
00092     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SaLocationErrArg!\n");
00093     return ((SaLocationErrArg &) arg);
00094 }
00095
00096
00097 #endif // AddOns_Lcs_StandAlone_SaArgs_hpp
00098
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaMsgProcessor.cpp File Reference

AddOns/Lcs/StandAlone/SaMsgProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "SaMsgProcessor.hpp"

Include dependency graph for SaMsgProcessor.cpp:

Generated on Tue Jan 24 16:36:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaMsgProcessor.hpp File Reference

AddOns/Lcs/StandAlone/SaMsgProcessor.hpp File Reference

#include <Apc/SignalHandler/StackMsgProcessor.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>
#include <AddOns/Lcs/Common/LcsDecls.hpp>

Include dependency graph for SaMsgProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SaMsgProcessor

Defines

#define | AddOns_Lcs_StandAlone_SaMsgProcessor_hpp

Define Documentation

#define AddOns_Lcs_StandAlone_SaMsgProcessor_hpp

Generated on Tue Jan 24 16:36:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaMsgProcessor.hpp Source File

AddOns/Lcs/StandAlone/SaMsgProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_StandAlone_SaMsgProcessor_hpp)
00010 #define AddOns_Lcs_StandAlone_SaMsgProcessor_hpp
00011
00012 #include <Apc/SignalHandler/StackMsgProcessor.hpp>
00013 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00014 #include <AddOns/Lcs/Common/LcsDecls.hpp>
00015
00020 class SaMsgProcessor : public StackMsgProcessor
00021 {
00023     public:
00024
00026         static void ProcessMolrReq( TI_PD ti_pd,
00027                                     MolrType molr_type,
00028                                     LocationMethod location_method,
00029                                     const LcsQos& lcs_qos,
00030                                     const ClientId& client_id,
00031                                     const MlcNumber& mlc_number);
00032
00033
00034 }; // SaMsgProcessor
00035
00036 #endif // AddOns_Lcs_StandAlone_SaMsgProcessor_hpp
00037
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaProviderImpl.cpp File Reference

AddOns/Lcs/StandAlone/SaProviderImpl.cpp File Reference

#include "LcsPreComp.hpp"
#include "SaProviderImpl.hpp"
#include "SaSignalMapTableNode.hpp"
#include "SaMsgProcessor.hpp"
#include "SaArgs.hpp"
#include "SaStackMsgArgs.hpp"
#include <AddOns/Lcs/Common/LcsCommonArgs.hpp>
#include <AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>
#include <AddOns/Lcs/Common/LcsReqProcessor.hpp>
#include <AddOns/Lcs/Common/LcsUtils.hpp>
#include <AddOns/Lcs/Common/LcsDecls.hpp>

Include dependency graph for SaProviderImpl.cpp:

Generated on Tue Jan 24 16:36:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaProviderImpl.hpp File Reference

AddOns/Lcs/StandAlone/SaProviderImpl.hpp File Reference

#include <AddOns/Lcs/Common/LcsProviderImplBase.hpp>

Include dependency graph for SaProviderImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SaProviderImpl

Defines

#define | AddOns_Lcs_StandAlone_SaProviderImpl_hpp

Define Documentation

#define AddOns_Lcs_StandAlone_SaProviderImpl_hpp

Generated on Tue Jan 24 16:36:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaProviderImpl.hpp Source File

AddOns/Lcs/StandAlone/SaProviderImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_StandAlone_SaProviderImpl_hpp)
00010 #define AddOns_Lcs_StandAlone_SaProviderImpl_hpp
00011
00012 #include <AddOns/Lcs/Common/LcsProviderImplBase.hpp>
00013
00014 class SaProviderImpl : public LcsProviderImplBase, public StackMsgDispatcher
00015 {
00016     typedef LcsProviderImplBase Base1;
00017     typedef StackMsgDispatcher Base2;
00018
00020     public:
00021
00023         virtual ~SaProviderImpl();
00024
00026         static SaProviderImpl* GetInstance();
00027
00029         static void ReleaseInstance();
00030
00032         virtual void Init();
00033
00038         virtual LcsErrorCode TransferLocationReq(MolrType molr_type,
00039                                                 LocationMethod location_method,
00040                                                 const LcsMmiQos& lcs_mmi_qos,
00041                                                 const ClientId& client_id,
00042                                                 const MlcNumber& mlc_number,
00043                                                 INT32 repeat_interval);
00044
00046         virtual void OnTimeOut(LcsTimerType timer_type);
00047
00048
00050     protected:
00051
00053         virtual BOOLEAN OnMessage(const Message& msg);
00054
00056         BOOLEAN OnLocationResponse(const StackMsgArgument& arg);
00057
00059         BOOLEAN OnLocationError(const StackMsgArgument& arg);
00060
00062         virtual BOOLEAN OnAbortResponse(const StackMsgArgument& arg);
00063
00064
00066     private:
00067
00069         SaProviderImpl();
00070
00072         void ProcessMolr(const MolrInfo* molr_info);
00073
00074
00076     private:
00077
00079         static SaProviderImpl* m_self;
00080
00082         static const StackMsgArgMap<SaProviderImpl> m_arg_map[];
00083
00088         StackMsgArgMapContainer<SaProviderImpl> m_arg_map_container;
00089
00090 }; // SaProviderImpl
00091
00092 #endif // AddOns_Lcs_StandAlone_SaProviderImpl_hpp
00093
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaSignalMapTableNode.cpp File Reference

AddOns/Lcs/StandAlone/SaSignalMapTableNode.cpp File Reference

#include "LcsPreComp.hpp"
#include "SaSignalMapTableNode.hpp"
#include "SaSignalProcessor.hpp"

Include dependency graph for SaSignalMapTableNode.cpp:

Generated on Tue Jan 24 16:36:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaSignalMapTableNode.hpp File Reference

AddOns/Lcs/StandAlone/SaSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for SaSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SaSignalMapTableNode

Defines

#define | AddOns_Lcs_StandAlone_SaSignalMapTable_hpp

Define Documentation

#define AddOns_Lcs_StandAlone_SaSignalMapTable_hpp

Generated on Tue Jan 24 16:36:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaSignalMapTableNode.hpp Source File

AddOns/Lcs/StandAlone/SaSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_StandAlone_SaSignalMapTable_hpp)
00010 #define AddOns_Lcs_StandAlone_SaSignalMapTable_hpp
00011
00012 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00013
00019 class SaSignalMapTableNode : public SignalMapTableNode
00020 {
00021     typedef SignalMapTableNode Base;
00022
00024     public:
00025
00027         ~SaSignalMapTableNode();
00028
00030         static SaSignalMapTableNode* GetInstance();
00031
00033         static void ReleaseInstance();
00034
00035
00037     private:
00038
00040         SaSignalMapTableNode();
00041
00042
00044     private:
00045
00047         static SaSignalMapTableNode* m_node;
00048
00050         static const SignalMapTableEntry m_signal_map_table[];
00051
00052 }; // SaSignalMapTableNode
00053
00054 #endif  // AddOns_Lcs_StandAlone_SaSignalMapTable_hpp
00055
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaSignalProcessor.cpp File Reference

AddOns/Lcs/StandAlone/SaSignalProcessor.cpp File Reference

#include "LcsPreComp.hpp"
#include "SaSignalProcessor.hpp"
#include "SaArgs.hpp"
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for SaSignalProcessor.cpp:

Generated on Tue Jan 24 16:37:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaSignalProcessor.hpp File Reference

AddOns/Lcs/StandAlone/SaSignalProcessor.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SaSignalProcessor

Defines

#define | AddOns_Lcs_StandAlone_SaSignalProcessor_hpp

Define Documentation

#define AddOns_Lcs_StandAlone_SaSignalProcessor_hpp

Generated on Tue Jan 24 16:37:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaSignalProcessor.hpp Source File

AddOns/Lcs/StandAlone/SaSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_Lcs_StandAlone_SaSignalProcessor_hpp)
00010 #define AddOns_Lcs_StandAlone_SaSignalProcessor_hpp
00011
00016 class SaSignalProcessor
00017 {
00019     public:
00020
00025         static void PostMolrResult(const ProcessPtr& process_ptr);
00026
00031         static void PostLocationError(const ProcessPtr& process_ptr);
00032
00033 }; // SaSignalProcessor
00034
00035 #endif // AddOns_Lcs_StandAlone_SaSignalProcessor_hpp
00036
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaStackMsgArgs.cpp File Reference

AddOns/Lcs/StandAlone/SaStackMsgArgs.cpp File Reference

#include "LcsPreComp.hpp"
#include "SaStackMsgArgs.hpp"

Include dependency graph for SaStackMsgArgs.cpp:

Generated on Tue Jan 24 16:37:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaStackMsgArgs.hpp File Reference

AddOns/Lcs/StandAlone/SaStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <AddOns/Lcs/StandAlone/SaArgs.hpp>

Include dependency graph for SaStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SaStackMsgArgsDestroyTableNode

Defines

#define | AddOns_Lcs_StandAlone_SaStackMsgArgs_hpp

Define Documentation

#define AddOns_Lcs_StandAlone_SaStackMsgArgs_hpp

Generated on Tue Jan 24 16:37:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Lcs/StandAlone/SaStackMsgArgs.hpp Source File

AddOns/Lcs/StandAlone/SaStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\AddOns\Lcs\StandAlone\SaArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_Lcs_StandAlone_SaStackMsgArgs_hpp)
00016 #define AddOns_Lcs_StandAlone_SaStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <AddOns/Lcs/StandAlone/SaArgs.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class SaStackMsgArgsDestroyTableNode
00028     ====================================================================== */
00029
00030 class SaStackMsgArgsDestroyTableNode : public StackMsgArgDestroyTableNode {
00031     public:
00032
00033         static SaStackMsgArgsDestroyTableNode* GetInstance();
00034
00035     private:
00036         SaStackMsgArgsDestroyTableNode();
00037
00038
00039         static SaStackMsgArgsDestroyTableNode* m_node;
00040         static const ArgumentDestroyEntry m_destroy_table[];
00041
00042     };
00043
00044 #endif // AddOns_Lcs_StandAlone_SaStackMsgArgs_hpp
00045
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/DisplaySettings.hpp File Reference

AddOns/MediaFramework/DisplaySettings.hpp File Reference

#include <Gui/Rect.hpp>

Include dependency graph for DisplaySettings.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DisplaySettings

Defines

#define | Apoxi_DisplaySettings_hpp

Define Documentation

#define Apoxi_DisplaySettings_hpp

Generated on Tue Jan 24 16:38:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/DisplaySettings.hpp Source File

AddOns/MediaFramework/DisplaySettings.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : DisplaySettings.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 31st August 2004        Naveen Narayanan    Added private members
00022 ------------------------------------------------------------------------ */
00023
00024 #if !defined(Apoxi_DisplaySettings_hpp)
00025 #define Apoxi_DisplaySettings_hpp
00029
00030 #include <Gui/Rect.hpp>
00031
00036 class DisplaySettings {
00037     public:
00038
00039         enum VideoQuality {
00040             LowQuality,
00041             MediumQuality,
00042             HighQuality
00043         };
00044
00045
00050         enum ScaleType {
00057             DownscaleToBounds,
00065             ScaleToBounds,
00066         };
00067
00069         DisplaySettings();
00070
00086         DisplaySettings(const Rect& bounds,
00087                        ScaleType scale_type,
00088                        UINT8 display_index = 0,
00089                        BOOLEAN keep_aspect_ratio = TRUE,
00090                        BOOLEAN is_first_frame_rendered = FALSE);
00091
00092
00094         const Rect& GetBounds() const { return m_rect;}
00095
00097         ScaleType GetScaleType() const { return m_scale_type;}
00098
00100         BOOLEAN KeepAspectRatio() const { return m_keep_aspect_ratio;}
00101
00102     private:
00103         Rect m_rect;
00104         ScaleType m_scale_type;
00105         BOOLEAN m_keep_aspect_ratio;
00106
00107
00108 };
00110 #endif  //Apoxi_DisplaySettings_hpp
00111
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Media.hpp File Reference

AddOns/MediaFramework/Media.hpp File Reference

#include <Auxiliary/ObjectObtainer.hpp>
#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for Media.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Media
struct | Media::Parameters

Defines

#define | Apoxi_Media_hpp

Define Documentation

#define Apoxi_Media_hpp

Generated on Tue Jan 24 16:38:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Media.hpp Source File

AddOns/MediaFramework/Media.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : Media.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 28th October, 2004          Shyam Sanker P S    Initial Code
00022 *******************************************************************************
00023 */
00024
00025 #if !defined(Apoxi_Media_hpp)
00026 #define Apoxi_Media_hpp
00027
00028 #include <Auxiliary/ObjectObtainer.hpp>
00029 #include <Auxiliary/MimeTypeTable.hpp>
00030
00031 class Size;
00032 class BinData;
00033
00034
00035 class Media : public ObtainableObject{
00036
00037     typedef ObtainableObject Base;
00038
00039     public:
00040
00041         struct Parameters {
00042             Size resolution;
00045             UINT16 frame_rate_numerator;
00048             UINT16 frame_rate_denominator;
00049             /* Duration in milli seconds */
00050             UINT32 duration;
00051             MimeType mime_type;
00052         };
00053
00054         Media(BinData *bin_data, MimeType mime_type);
00055
00056         Media(BinData *bin_data, Parameters& params);
00057
00058         virtual ~Media() {m_bin_data_pointer->ReleaseInstance();}
00059
00060         virtual BinData* GetBinData();
00061
00062     //  virtual const BinData* GetBinData() const;
00063
00064         virtual Size GetResolution() ;
00065
00072         virtual void GetFrameRate(  UINT16& frame_rate_numerator,
00073                                     UINT16& frame_rate_denominator) ;
00074
00075         virtual UINT32 GetDuration() ;
00076
00077         virtual MimeType GetMimeType() ;
00078
00079     private :
00080
00081         Size m_resolution;
00084         UINT16 m_frame_rate_numerator;
00087         UINT16 m_frame_rate_denominator;
00088
00089         /* Duration in milli seconds */
00090         UINT32 m_duration;
00091
00092         MimeType m_mime_type;
00093
00094         BinData *m_bin_data_pointer;
00095
00096         friend class MediaObtainer;
00097 };//class media
00098
00099 #endif  // Apoxi_Media_hpp
00100
00101
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaBox.hpp File Reference

AddOns/MediaFramework/MediaBox.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Gui/DrawableObject.hpp>

Include dependency graph for MediaBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaBox
class | MediaBoxView

Generated on Tue Jan 24 16:38:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaBox.hpp Source File

AddOns/MediaFramework/MediaBox.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : MediaBox.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 31st August 2004        Naveen Narayanan    Added private members
00022 ------------------------------------------------------------------------ */
00023
00024
00025 #ifndef MediaBox_hpp
00026 #define MediaBox_hpp
00027
00028 class MediaInfo;
00029 class MediaPlayer;
00030 class MediaManager;
00031
00032 #include <Auxiliary/MimeTypeTable.hpp>
00033 #include <Gui/DrawableObject.hpp>
00034
00035 class BinData;
00036
00037 class MediaBoxView : public DrawableObjectView {
00038     public:
00039         MediaBoxView();
00040         virtual ~MediaBoxView();
00041         virtual void Draw(const Component& component, DeviceContext* dc,
00042             const Rect& repaint_rect) const;
00043 };
00044
00045 class MediaBox : public DrawableObject {
00046
00047     typedef DrawableObject Base;
00048     public:
00049         MediaBox();
00050         virtual void Init(Control* parent);
00051         virtual ~MediaBox();
00052         MediaPlayer* CreatePlayerInstance(BinData* media_source,
00053                                             MediaInfo& media_info,
00054                                             MimeType& media_mime_type,
00055                                             void *mesg_dispatcher,
00056                                             MediaManager::MmfResult& mmf_result);
00057
00058         MediaPlayer* CreatePlayerInstance(char* media_source,
00059                                             MediaInfo& media_info,
00060                                             MimeType& media_mime_type,
00061                                             void *mesg_dispatcher,
00062                                             MediaManager::MmfResult& mmf_result);
00063
00064         void DestroyPlayerInstance(MediaPlayer* media_player);
00065         MediaPlayer* GetPlayerInstance();
00066     private:
00067         static MediaBoxView m_view;
00068         MediaPlayer*    m_p_media_player;
00069 };
00070
00071 #endif //MediaBox_hpp
00072
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaFrameworkCaps.hpp File Reference

AddOns/MediaFramework/MediaFrameworkCaps.hpp File Reference

#include <MediaFramework/MediaInfo.hpp>

Include dependency graph for MediaFrameworkCaps.hpp:

Go to the source code of this file.

Data Structures

class | MediaFrameworkCaps

Defines

#define | Apoxi_MediaFrameworkCaps_hpp

Define Documentation

#define Apoxi_MediaFrameworkCaps_hpp

Generated on Tue Jan 24 16:38:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaFrameworkCaps.hpp Source File

AddOns/MediaFramework/MediaFrameworkCaps.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : MediaFrameworkCaps.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 31st August 2004        Naveen Narayanan    Added private members
00022 ------------------------------------------------------------------------ */
00023
00024 #if !defined(Apoxi_MediaFrameworkCaps_hpp)
00025 #define Apoxi_MediaFrameworkCaps_hpp
00029
00030 #include <MediaFramework/MediaInfo.hpp>
00031
00033 class MediaFrameworkCaps {
00034     public:
00035
00037         MediaFrameworkCaps();
00038
00042         const MediaFrameworkCaps* GetCapabilities() const;
00043
00050         BOOLEAN IsEncoderCodecSupported(MediaInfo::MediaCodec codec) const;
00051
00055         INT GetSupportedEncoderCodecsCount() const;
00056
00065         MediaInfo::MediaCodec GetEncoderCodec(INT index) const;
00066
00073         BOOLEAN IsDecoderCodecSupported(MediaInfo::MediaCodec codec) const;
00074
00078         INT GetSupportedDecoderCodecsCount() const;
00079
00088         MediaInfo::MediaCodec GetDecoderCodec(INT index) const;
00089
00090     private:
00091 };
00092
00093
00095 #endif  //Apoxi_MediaFrameworkCaps_hpp
00096
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaInfo.hpp File Reference

AddOns/MediaFramework/MediaInfo.hpp File Reference

#include "PreComp.hpp"

Include dependency graph for MediaInfo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaInfo
class | MediaInfo::AudioTrackInfo
class | MediaInfo::ClipInfo
class | MediaInfo::MediaTrackInfo
class | MediaInfo::VideoTrackInfo

Defines

#define | Apoxi_MediaInfo_hpp

Define Documentation

#define Apoxi_MediaInfo_hpp

Generated on Tue Jan 24 16:38:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaInfo.hpp Source File

AddOns/MediaFramework/MediaInfo.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : MediaInfo.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 31st August 2004        Naveen Narayanan    Added private members
00022 ------------------------------------------------------------------------ */
00023
00024 #if !defined(Apoxi_MediaInfo_hpp)
00025 #define Apoxi_MediaInfo_hpp
00029
00030 #include "PreComp.hpp"
00031
00032 class MediaInfo {
00033     public:
00035         enum MediaCodec {
00038             DefaultCodec,
00039             UnknownCodec,
00040             Mpeg4Sp,
00041             H263Bl,
00042             GsmAmrNb,
00043             Mpeg4Aac,
00044             Qcelp,
00045             Evrc,
00046             Mp3,
00047             Mpeg4AacPlusV1,
00048             Mpeg4AacPlusV2,
00049             H264Bp,
00050             EndOfCodecType
00051         };
00052
00053         class ClipInfo {
00054             public:
00055                 void Init();
00056                 void DeInit();
00057
00058                 /* Fields for 3gpp clip  */
00059                 UINT8*  m_p_title;
00060                 UINT8*  m_p_author;
00061                 UINT8*  m_p_copyright;
00062                 UINT8*  m_p_rating;
00063                 UINT8*  m_p_description;
00064
00065                 /* There are fields for Mp3 */
00066                 UINT16* m_p_song_name;
00067                 UINT16* m_p_artist;
00068                 UINT16* m_p_album;
00069                 UINT16* m_p_year;
00070                 UINT16* m_p_comment;
00071                 UINT16* m_p_genre;
00072                 UINT16* m_p_track;
00073                 UINT16* m_p_duration;
00074                 UINT16* m_p_composer;
00075                 UINT16* m_p_original_artist;
00076                 UINT16* m_p_url;
00077
00078         };
00079
00080
00083         class MediaTrackInfo {
00084             public:
00086                 MediaTrackInfo();
00087
00093                 MediaTrackInfo(MediaCodec codec_type, //needed???
00094                                 UINT32 duration,
00095                                 UINT32 track_id,
00096                                 UINT32 bitrate = 0); //needed???
00097
00099                 MediaCodec GetMediaCodec() const {return m_codec_type;}
00100
00102                 UINT32 GetDuration() const {return m_duration;}
00103
00105                 UINT32 GetTrackId() const {return m_track_id;}
00106
00108                 UINT32 GetBitrate() const {return m_bitrate;}
00109
00110             protected: // or private???
00112                 MediaCodec m_codec_type;
00114                 UINT32 m_duration;
00116                 UINT32 m_track_id;
00118                 UINT32 m_bitrate;
00119
00120         };
00121
00123         class AudioTrackInfo : public MediaTrackInfo {
00124             public:
00126                 AudioTrackInfo();
00127
00135                 AudioTrackInfo(MediaCodec codec_type, //needed???
00136                                 UINT32 duration,
00137                                 UINT32 track_id,
00138                                 UINT16 sample_freq, //needed???
00139                                 UINT16 channel_cnt, //needed???
00140                                 UINT32 bitrate = 0);
00141
00143                 UINT16 GetSampleFreq() const {return m_sample_freq;}
00144
00146                 UINT16 GetNumberOfChannels() const {return m_channel_cnt;}
00147
00148             private:
00150                 UINT16 m_sample_freq;
00152                 UINT16 m_channel_cnt;
00153         };
00154
00156         class VideoTrackInfo : public MediaTrackInfo {
00157             public:
00159                 VideoTrackInfo();
00160
00169                 VideoTrackInfo(MediaCodec codec_type, // needed???
00170                                 UINT32 duration,
00171                                 UINT32 track_id,
00172                                 XYDIM m_width,
00173                                 XYDIM m_height,
00174                                 UINT32 bitrate = 0);
00175
00177                 XYDIM GetWidth() const {return m_width;}
00178
00180                 XYDIM GetHeight() const {return m_height;}
00181
00182             private:
00184                 XYDIM m_width;
00186                 XYDIM m_height;
00187         };
00188
00189         /* Default constructor*/
00190         MediaInfo();
00191
00192         /* Default Destructor */
00193         ~MediaInfo();
00194
00202         BOOLEAN AddAudioInfo(const AudioTrackInfo& info);
00203
00210         BOOLEAN AddVideoInfo(const VideoTrackInfo& info);
00211
00214         INT GetAudioInfoCount() const{ return mAudTrackCnt;}
00215
00218         INT GetVideoInfoCount() const{ return mVidTrackCnt;}
00219
00226         const AudioTrackInfo* GetAudioInfo(INT index) const;
00227
00234         const VideoTrackInfo* GetVideoInfo(INT index) const;
00235
00238         BOOLEAN SetClipInfo(UINT8 *title, UINT8 *author, UINT8 *copyright, UINT8 *rating, UINT8 *description);
00239
00242         BOOLEAN MediaInfo::SetClipInfo(ClipInfo & clip_info);
00243
00246         const ClipInfo& GetClipInfo() const { return m_clip_info; }
00247
00248
00249         BOOLEAN ReInit();
00250
00251     private:
00252
00253         INT32 mAudTrackCnt;
00254         INT32 mVidTrackCnt;
00255
00256         VideoTrackInfo*     m_p_vid_track_info;
00257         AudioTrackInfo*     m_p_aud_track_info;
00258
00260
00261         ClipInfo            m_clip_info;
00262
00263         friend class        EmApoxiMediaInfo;
00264
00265 };
00266
00267
00269 #endif  //Apoxi_MediaInfo_hpp
00270
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaManager.hpp File Reference

AddOns/MediaFramework/MediaManager.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/MimeTypeTable.hpp>
#include "PreComp.hpp"

Include dependency graph for MediaManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaManager

Defines

#define | MediaManager_hpp

Define Documentation

#define MediaManager_hpp

Generated on Tue Jan 24 16:39:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaManager.hpp Source File

AddOns/MediaFramework/MediaManager.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : MediaManager.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 31st August 2004        Naveen Narayanan    Added Error resutls
00022 1st  October 2004       Nirmal U            Added messages for Streaming
00023 ------------------------------------------------------------------------ */
00024
00025 #if !defined(MediaManager_hpp)
00026 #define MediaManager_hpp
00030
00031 class BinData;
00032 class Stream;
00033 class MediaPlayer;
00034 class MediaRecorder;
00035 class MediaInfo;
00036 class MediaFrameworkCaps;
00037
00038 #include <Kernel/Types.hpp>
00039 #include <Auxiliary/MimeTypeTable.hpp>
00040 #include "PreComp.hpp"
00041
00045 class MediaManager {
00046     public:
00051         enum MmfResult {
00053             Success = 0,
00056             MediaTypeDifferent,
00058             MediaNotSupported,
00060             OutOfMemory,
00062             SmallBuffer,
00064             NullParameter,
00066             InvalidParameter,
00068             InvalidState,
00070             FeatureNotSupported,
00072             InvalidAudioTrack,
00074             InvalidVideoTrack,
00076             FileNotFound,
00078             EmptyFile,
00080             Invalid3gppFile,
00082             Incomplete3gppFile,
00084             OpenFileFailure,
00086             InvalidMp3File,
00088             CorruptMp3File,
00090             VidResNotSupported,
00092             AudSamplFreqNotSupported,
00093             // This FPS is not supported
00094             FpsNotSupported,
00096             GeneralError
00097         };
00098
00099         /* The Mmfr API completion messages are communicated to the upper layer
00100             through the message types mentioned below*/
00101         enum MmfMsgType {
00103             PauseApiCompletionMsg,
00105             PlayApiCompletionMsg,
00107             RecordApiCompletionMsg,
00109             RewindApiCompletionMsg,
00111             FastForwardApiCompletionMsg,
00113             StopApiCompletionMsg,
00115             InitCompletionMsg,
00117             UninitCompletionMsg,
00119             EofReachedMsg,
00121             CriticalErrorMsg,
00125             NetworkMsgRtcpByeReceived,
00127             MediaTypeNotSupportedMsg,
00129             SamplingFrequencyNotSupportedMsg,
00131             NetworkErrConnErr,
00133             NetworkErrConnLostErr,
00135             NetworkErrUnknown,
00137             NetworkErrConnectFailed,
00139             NetworkErrBandWidthTooHigh,
00141             NetworkErrUrlNotFound,
00143             NetworkErrUrlNotStreamable,
00145             NetworkErrSdpParseError,
00147             NetworkErrSdpFileOpenError,
00149             NetworkErrHTTPError,
00151             NetworkErrRtpDataError,
00153             NetworkErrUnknownServError,
00155             NetworkErrCriticalError,
00157             BufferingStart,
00159             BufferingComplete,
00161             MediaInfoObtainedMsg,
00163             UnknownErrorMsg
00164         };
00165
00168         static MediaManager& GetInstance();
00169
00188         MediaPlayer* CreateMediaPlayer(const BinData* media_source,
00189                                        MediaInfo& media_info,
00190                                        MimeType& media_mime_type,
00191                                        void *mesg_dispatcher,
00192                                        MmfResult& result);
00193
00212         MediaPlayer* CreateMediaPlayer(const char* media_source,
00213                                        MediaInfo& media_info,
00214                                        MimeType& media_mime_type,
00215                                        void *mesg_dispatcher,
00216                                        MmfResult& result);
00217
00221         void DestroyMediaPlayer(MediaPlayer* media_player);
00222
00231         MediaRecorder* CreateMediaRecorder(void *mesg_dispatcher, MmfResult& mmf_result);
00232
00236         void DestroyMediaRecorder(MediaRecorder* media_recorder);
00237
00241         const MediaFrameworkCaps* GetCapabilities() const;
00242
00243     private:
00244         static BOOLEAN m_initialized;
00245         static Semaphore m_sem;
00246         static BOOLEAN m_is_player_recorder_created;
00247
00248         MediaManager();
00249 };
00250
00252 #endif // MediaManager_hpp
00253
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaObtainer.hpp File Reference

AddOns/MediaFramework/MediaObtainer.hpp File Reference

#include <Gui/Size.hpp>
#include <Auxiliary/BinData.hpp>
#include "Media.hpp"

Include dependency graph for MediaObtainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaObtainer

Defines

#define | Apoxi_MediaObtainer_hpp

Define Documentation

#define Apoxi_MediaObtainer_hpp

Generated on Tue Jan 24 16:39:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaObtainer.hpp Source File

AddOns/MediaFramework/MediaObtainer.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : MediaObtainer.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 28th October, 2004          Shyam Sanker P S    Initial Code
00022 *******************************************************************************
00023 */
00024
00025 #if !defined(Apoxi_MediaObtainer_hpp)
00026 #define Apoxi_MediaObtainer_hpp
00027
00028 #include <Gui/Size.hpp>
00029 #include <Auxiliary/BinData.hpp>
00030
00031 #include "Media.hpp"
00032
00033
00034
00035 class MediaObtainer : public ObjectObtainer {
00036
00037     typedef ObjectObtainer Base;
00038
00039     public:
00040
00041         MediaObtainer(Media* media);
00042
00043         virtual ~MediaObtainer();
00044
00045         //Init(Media* media);
00046
00047         virtual Media* GetMedia() const;
00048
00049 //      virtual const Media* GetMedia() const;
00050
00051     private :
00052
00053 };//class MediaObtainer
00054
00055 #endif //Apoxi_MediaObtainer_hpp
00056
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaPlayer.hpp File Reference

AddOns/MediaFramework/MediaPlayer.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/MediaFramework/MediaManager.hpp>
#include <AddOns/MediaFramework/DisplaySettings.hpp>
#include "MediaInfo.hpp"

Include dependency graph for MediaPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaPlayer

Defines

#define | MediaPlayer_hpp

Define Documentation

#define MediaPlayer_hpp

Generated on Tue Jan 24 16:39:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaPlayer.hpp Source File

AddOns/MediaFramework/MediaPlayer.hpp

Go to the documentation of this file.
00001  /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : MediaPlayer.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 31st August 2004        Naveen Narayanan    Added private members
00022 ------------------------------------------------------------------------ */
00023
00024 #if !defined(MediaPlayer_hpp)
00025 #define MediaPlayer_hpp
00029
00030 #include <Kernel/Types.hpp>
00031 #include <AddOns/MediaFramework/MediaManager.hpp>
00032 #include <AddOns/MediaFramework/DisplaySettings.hpp>
00033
00034 #include "MediaInfo.hpp"
00035 #include "MediaManager.hpp"
00036
00037 class MediaPlayerImpl;
00038 class BinData;
00039 class AudioReference;
00040
00046 class  MediaPlayer {
00047     public:
00048         enum State {
00049             UnInitializedState,
00050             InsideDefaultSelectMedia,
00051             InitializedState,
00052             PlayingState,
00053             PausedState,
00054             RewindingState,
00055             FastForwardingState,
00056             AwaitingPlayRespState,
00057             AwaitingRewindRespState,
00058             AwaitingFastForwardRespState,
00059             AwaitingPauseRespState,
00060             AwaitingStopRespState,
00061             AwaitingInitResp,
00062             EofProcessing,
00063             BufferingCompleteState,
00064             BufferingStartState,
00065             ErrorProcessing,
00066             ErrorState,
00067             DestroyedState,
00068
00069             /* Impact of these states on streaming ?? */
00070             ReadyState,
00071             EofReceivedState
00072
00073         };
00074
00075         enum TrackSelection {
00076             AudioAndVideo,
00077             AudioOnly,
00078             VideoOnly
00079         };
00080
00082         virtual ~MediaPlayer();
00083
00098         virtual MediaManager::MmfResult SelectMediaTracks(TrackSelection track_selection,
00099                                     UINT audio_track_id,
00100                                     UINT video_track_id);
00101
00109         virtual MediaManager::MmfResult SetDisplaySettings(const DisplaySettings& display_settings);
00110
00121         virtual MediaManager::MmfResult Play();
00122
00127         virtual MediaManager::MmfResult Pause();
00128
00134         virtual MediaManager::MmfResult Stop();
00135
00146         virtual MediaManager::MmfResult Rewind(INT rate);
00147
00158         virtual MediaManager::MmfResult FastForward(INT rate);
00159
00166         virtual MediaManager::MmfResult GetState(MediaPlayer::State& state) const;
00167
00185         virtual MediaManager::MmfResult SetPosition(INT32 position);
00186
00195         virtual MediaManager::MmfResult GetPosition(UINT32& position) const;
00196
00211         virtual MediaManager::MmfResult SetDisplayLocation(INT x, INT y);
00212
00225         virtual MediaManager::MmfResult Zoom(BOOLEAN zoom_up);
00226
00241         virtual MediaManager::MmfResult Unzoom();
00242
00249         virtual MediaManager::MmfResult SetVolumeLevel(UINT volume_level);
00250
00256         virtual MediaManager::MmfResult SetBassLevel(UINT level);
00257
00263         virtual MediaManager::MmfResult SetTrebleLevel(UINT level);
00264
00271         virtual MediaManager::MmfResult SetBalanceLevel(UINT level);
00272
00279         virtual MediaManager::MmfResult SetPlaybackContrast(UINT level);
00280
00287         virtual MediaManager::MmfResult SetPlaybackVideoQuality(DisplaySettings::VideoQuality video_quality);
00288
00289         virtual MediaManager::MmfResult GetFirstVideoFrame(UINT8* buffer, UINT32& buffer_length);
00290
00296         virtual MediaManager::MmfResult SetRepeatCount(UINT16 repeat_count = 1) ;
00297
00303         virtual MediaManager::MmfResult SetContinue(BOOLEAN continue_flag = FALSE) ;
00304
00310         virtual MediaManager::MmfResult SetPriority(UINT32 priority = 0) ;
00311
00315         virtual UINT16 GetRepeatCount() const ;
00316
00320         virtual BOOLEAN GetContinue() const ;
00321
00325         virtual UINT32 GetPriority() const ;
00326
00330         virtual AudioReference* GetAudioReference(void) const;
00331
00332
00333 #ifdef ENABLE_STREAMING
00334
00338         virtual MediaManager::MmfResult GetBuffLevel(UINT32 &buff_level);
00339
00344         virtual MediaManager::MmfResult SetBufferingTime(UINT32 buff_level);
00345 #endif
00346     private:
00347
00348         MediaPlayer(const char* location,
00349                     MediaInfo& media_info,
00350                     MimeType& media_mime_type,
00351                     MediaManager::MmfResult& mmf_result,
00352                     void* msg_dispatcher,
00353                     UINT32 audio_priority_value=0,
00354                     MediaManager::MmfModeType mmf_mode=MediaManager::MmfModeAudioVideo);
00355
00356         MediaPlayer(const BinData* media_source,
00357                     MediaInfo& media_info,
00358                     MimeType& media_mime_type,
00359                     MediaManager::MmfResult& mmf_result,
00360                     void* msg_dispatcher,
00361                     UINT32 audio_priority_value=0,
00362                     MediaManager::MmfModeType mmf_mode=MediaManager::MmfModeAudioVideo);
00363
00369         void DestroyInstance();
00370
00371         MediaPlayerImpl* m_p_media_player_impl;
00372
00373         void* media_player_data;
00374
00375         friend class MediaManager;
00376 };
00377
00379 #endif // MediaPlayer_hpp
00380
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaRecorder.hpp File Reference

AddOns/MediaFramework/MediaRecorder.hpp File Reference

#include <Kernel/Types.hpp>
#include "PreComp.hpp"
#include <MediaFramework/MediaManager.hpp>
#include <MediaFramework/RecordSettings.hpp>

Include dependency graph for MediaRecorder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaRecorder

Defines

#define | MediaRecorder_hpp

Define Documentation

#define MediaRecorder_hpp

Generated on Tue Jan 24 16:39:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MediaRecorder.hpp Source File

AddOns/MediaFramework/MediaRecorder.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : MediaRecorder.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author          Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 31st August 2004        Naveen Narayanan    Added private members
00022 ------------------------------------------------------------------------ */
00023
00024 #if !defined(MediaRecorder_hpp)
00025 #define MediaRecorder_hpp
00029
00030 #include <Kernel/Types.hpp>
00031 #include "PreComp.hpp"
00032 #include <MediaFramework/MediaManager.hpp>
00033 #include <MediaFramework/RecordSettings.hpp>
00034
00035 class DisplaySettings;
00036 class MediaRecorderImpl;
00037
00043 class  MediaRecorder {
00044     public:
00045
00046         enum MediaRecorderState {
00047             UnInitializedState,
00048             InitalizedState,
00049             PreviewState,
00050             AwaitingRecordRespState,
00051             RecordingState,
00052             AwaitingPauseRespState,
00053             PausedState,
00054             AwaitingStopRespState,
00055             AwaitingInitResp,
00056             EofProcessing,
00057             ErrorProcessing,
00058             ErrorState,
00059             DestroyedState
00060         };
00061
00063          ~MediaRecorder();
00064
00072         virtual MediaManager::MmfResult SetDisplaySettings(const DisplaySettings& display_settings);
00073
00079         virtual MediaManager::MmfResult StartPreview();
00080
00085         virtual MediaManager::MmfResult StopPreview();
00086
00094         virtual MediaManager::MmfResult SetRecordSettings(const RecordSettings& record_settings);
00095
00103         virtual MediaManager::MmfResult SetDisplayAndRecordSettings(
00104                             const DisplaySettings& display_settings,
00105                             const RecordSettings& record_settings);
00106
00111         virtual MediaManager::MmfResult StartRecord ();
00112
00116         virtual MediaManager::MmfResult PauseRecord();
00117
00122         virtual MediaManager::MmfResult ResumeRecord();
00123
00128         virtual MediaManager::MmfResult StopRecord();
00129
00136         virtual MediaManager::MmfResult GetState(MediaRecorderState& state) const;
00137
00145         virtual MediaManager::MmfResult GetPosition(UINT32& position) const;
00146
00162         virtual MediaManager::MmfResult Zoom(BOOLEAN zoom_up);
00163
00182         virtual MediaManager::MmfResult Unzoom();
00183
00190         virtual MediaManager::MmfResult SetCameraNightMode(BOOLEAN night_mode_on);
00191
00198         virtual MediaManager::MmfResult SetCameraMirroring(BOOLEAN mirroring_on);
00199
00209         virtual MediaManager::MmfResult SetMute(BOOLEAN mute_on);
00210
00216         virtual MediaManager::MmfResult SetPriority(UINT32 priority = 0) ;
00217
00221         virtual UINT32 GetPriority() const ;
00222
00223     private:
00224         MediaRecorder (MediaManager::MmfResult& mmf_result,
00225                         void *msg_dispatcher,
00226                         UINT32 audio_priority_value=0,
00227                         MediaManager::MmfModeType mmf_mode=MediaManager::MmfModeAudioVideo);
00228
00232         void DestroyInstance();
00233
00234         MediaRecorderImpl *m_p_media_recorder_impl;
00235         friend class MediaManager;      // constructs the MediaRecorder object
00236
00237 };
00238
00240 #endif // MediaRecorder_hpp
00241
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MsgTypes.hpp File Reference

AddOns/MediaFramework/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/WString.hpp>
#include <AddOns/MediaFramework/MediaManager.hpp>
#include <Kernel/InputStream.hpp>
#include <Kernel/OutputStream.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MCServiceInterfaceMsg
class | MediaManagerMsg

Defines

#define | MsgTypes_hpp__ST_1122019187332

Define Documentation

#define MsgTypes_hpp__ST_1122019187332

Generated on Tue Jan 24 14:56:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MsgTypes.hpp Source File

AddOns/MediaFramework/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "APOXI\SDK\bin\MessageGenerator\samples\SampleMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(MsgTypes_hpp__ST_1122019187332)
00017 #define MsgTypes_hpp__ST_1122019187332
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Auxiliary/WString.hpp>
00021 #include <AddOns/MediaFramework/MediaManager.hpp>
00022 #include <Kernel/InputStream.hpp>
00023 #include <Kernel/OutputStream.hpp>
00024
00025
00026 /* ----------------------------------------------------------------------
00027     Classes
00028     ---------------------------------------------------------------------- */
00029
00030 /*  ======================================================================
00031     Class MediaManagerMsg
00032     ====================================================================== */
00033
00036 class MediaManagerMsg : public ContextMsg {
00037     public:
00038         MediaManagerMsg(ExecutionContext* application, const MediaManager::MmfMsgType& type, const MediaManager::MmfResult& mmfresult, void* instanceptr = 0);
00039         virtual ~MediaManagerMsg();
00040
00041         virtual const MsgMetaData& GetMetaData() const;
00042         void SetType(const MediaManager::MmfMsgType& type) { m_type = type; }
00043         const MediaManager::MmfMsgType& GetType() const { return m_type; }
00044         void SetMmfresult(const MediaManager::MmfResult& mmfresult) { m_mmfresult = mmfresult; }
00045         const MediaManager::MmfResult& GetMmfresult() const { return m_mmfresult; }
00046
00047         void SetInstanceptr(void* instanceptr) { m_p_instance = instanceptr; }
00048         void* GetInstanceptr() { return m_p_instance; }
00049
00050         virtual Message* Clone() const;
00051 #if !defined(APOXI_NOSTREAMING)
00052         friend OutputStream& operator << (OutputStream& ostr, const MediaManagerMsg& cls);
00053 #endif // APOXI_NOSTREAMING
00054 #if !defined(APOXI_NOSTREAMING)
00055         friend InputStream& operator >> (InputStream& istr, MediaManagerMsg& cls);
00056 #endif // APOXI_NOSTREAMING
00057
00058         enum {
00059             ID = 54000
00060             };
00061
00062     protected:
00063
00064 #if !defined(APOXI_NOSTREAMING)
00065         virtual void Dump(OutputStream& ostr) const;
00066 #endif // APOXI_NOSTREAMING
00067
00068     private:
00069         static const MsgMetaData m_meta_data;
00070         MediaManager::MmfMsgType m_type;
00071         MediaManager::MmfResult m_mmfresult;
00072         void*                   m_p_instance;
00073
00074     };
00075
00076 /*  ======================================================================
00077     Class MCServiceInterfaceMsg
00078     ====================================================================== */
00079
00081 class MCServiceInterfaceMsg : public ApplicationMsg {
00082     public:
00083         MCServiceInterfaceMsg(Application* application, INT32 type, const WString& pathname);
00084         virtual ~MCServiceInterfaceMsg();
00085
00086         virtual const MsgMetaData& GetMetaData() const;
00087         void SetType(INT32 type) { m_type = type; }
00088         INT32 GetType() const { return m_type; }
00089         void SetPathname(const WString& pathname) { m_pathname = pathname; }
00090         const WString& GetPathname() const { return m_pathname; }
00091         virtual Message* Clone() const;
00092 #if !defined(APOXI_NOSTREAMING)
00093         friend OutputStream& operator << (OutputStream& ostr, const MCServiceInterfaceMsg& cls);
00094 #endif // APOXI_NOSTREAMING
00095 #if !defined(APOXI_NOSTREAMING)
00096         friend InputStream& operator >> (InputStream& istr, MCServiceInterfaceMsg& cls);
00097 #endif // APOXI_NOSTREAMING
00098
00099         enum {
00100             ID = 54001
00101             };
00102
00103     protected:
00104
00105 #if !defined(APOXI_NOSTREAMING)
00106         virtual void Dump(OutputStream& ostr) const;
00107 #endif // APOXI_NOSTREAMING
00108
00109     private:
00110         static const MsgMetaData m_meta_data;
00111         INT32 m_type;
00112         WString m_pathname;
00113
00114     };
00115
00116
00117 #endif // MsgTypes_hpp__ST_1122019187332
00118
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/PreComp.hpp File Reference

AddOns/MediaFramework/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/PreComp.hpp Source File

AddOns/MediaFramework/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 //lint -e506
00010 //lint -e774
00011 //lint -e527
00012
00013 #include <Kernel/Lib.hpp>
00014 //#define ENABLE_H263_ONLY
00015
00016
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/RecordSettings.hpp File Reference

AddOns/MediaFramework/RecordSettings.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/DataSink.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Gui/Rect.hpp>
#include <AddOns/MediaFramework/MediaInfo.hpp>

Include dependency graph for RecordSettings.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RecordSettings

Defines

#define | Apoxi_RecordSettings_hpp

Define Documentation

#define Apoxi_RecordSettings_hpp

Generated on Tue Jan 24 16:41:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/RecordSettings.hpp Source File

AddOns/MediaFramework/RecordSettings.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : RecordSettings.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author              Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 13th Oct 2004           Naveen Narayanan        Integrated the proposal
00022 ------------------------------------------------------------------------ */
00023
00024
00025 #if !defined(Apoxi_RecordSettings_hpp)
00026 #define Apoxi_RecordSettings_hpp
00030
00031 #include <Kernel/Types.hpp>
00032 #include <Auxiliary/DataSink.hpp>
00033 #include <Afs/Rfs/Pathname.hpp>
00034 #include <Gui/Rect.hpp>
00035
00036 #include <AddOns/MediaFramework/MediaInfo.hpp>
00037
00040 class RecordSettings {
00041     public:
00043         enum MediaSinkType {
00045             FilePathname,
00047             DataSink
00048         };
00049
00051         enum MediaQuality {
00052             QualityLow = 1,
00053             QualityNormal,
00054             QualityHigh
00055         };
00056
00058         RecordSettings();
00059
00061         ~RecordSettings();
00062
00099         RecordSettings( INT frame_rate,
00100                         XYDIM width,
00101                         XYDIM height,
00102                         UINT8 camera_dev_id,
00103                         MediaQuality video_quality,
00104                         MediaQuality audio_quality,
00105                         MediaInfo::MediaCodec video_codec,
00106                         MediaInfo::MediaCodec audio_codec,
00107                         UINT32 max_file_size,
00108                         const char* media_sink);
00109
00146         RecordSettings( INT frame_rate,
00147                         XYDIM width,
00148                         XYDIM height,
00149                         UINT8 camera_dev_id,
00150                         MediaQuality video_quality,
00151                         MediaQuality audio_quality,
00152                         MediaInfo::MediaCodec video_codec,
00153                         MediaInfo::MediaCodec audio_codec,
00154                         UINT32 max_file_size,
00155                         class DataSink* media_sink);
00156
00185         RecordSettings( void* media_sink,
00186                         MediaSinkType media_sink_type,
00187                         MediaInfo::MediaCodec video_codec,
00188                         MediaQuality video_quality,
00189                         INT contrast,
00190                         INT brightness,
00191                         BOOLEAN camera_night_mode,
00192                         UINT32 max_file_size,
00193                         UINT32 max_recording_duration);
00194
00195         const MediaSinkType GetMediaSinkType() const { return m_sink_type; }
00196
00197         void SetMediaSinkType(MediaSinkType sink_type) { m_sink_type = sink_type; }
00198
00199         const void* GetMediaSink() const { return m_media_sink; }
00200
00201         void SetMediaSink(void* media_sink) { m_media_sink = media_sink; }
00202
00203         const MediaInfo::MediaCodec GetVideoCodec() const { return m_video_codec; }
00204
00205         void SetVideoCodec(MediaInfo::MediaCodec video_codec) { m_video_codec = video_codec; }
00206
00207         void SetAudioCodec(MediaInfo::MediaCodec audio_codec) { m_audio_codec = audio_codec; }
00208
00209         const INT   GetContrast() const { return m_contrast; }
00210
00211         const INT GetBrightness() const { return m_brightness; }
00212
00213         const BOOLEAN GetCameraNightMode() const { return m_camera_night_mode; }
00214
00215         const UINT32 GetMaxFileSize() const { return m_max_file_size; }
00216
00217         void SetMaxFileSize(UINT32 max_file_size) { m_max_file_size = max_file_size; }
00218
00219         const UINT32 GetMaxRecordingDuration() const { return m_max_recording_duration; }
00220
00221         void SetMaxRecordingDuration(UINT32 max_recording_duration) { m_max_recording_duration = max_recording_duration; }
00222
00223         const MediaQuality GetVideoQuality() const { return m_video_quality; }
00224
00225     private:
00228         INT m_frame_rate;
00231         XYDIM m_width;
00234         XYDIM m_height;
00237         MediaQuality m_video_quality;
00240         MediaQuality m_audio_quality;
00243         MediaInfo::MediaCodec m_video_codec;
00246         MediaInfo::MediaCodec m_audio_codec;
00249         UINT32 m_max_file_size;
00251         MediaSinkType m_sink_type;
00257         void* m_media_sink;
00258
00260         INT     m_contrast;
00261
00262         INT     m_brightness;
00263
00264         BOOLEAN m_camera_night_mode;
00265
00266         UINT32  m_max_recording_duration;
00267
00268         UINT8   m_camera_device_id;
00269
00271
00272         friend class MediaRecorder;
00273         friend class EmApoxiRecordSettings;
00274 };
00276 #endif  //Apoxi_RecordSettings_hpp
00277
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/VideoCaptureParameters.hpp File Reference

AddOns/MediaFramework/VideoCaptureParameters.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoCaptureParameters

Defines

#define | VideoCaptureParameters_hpp

Define Documentation

#define VideoCaptureParameters_hpp

Generated on Tue Jan 24 16:41:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/VideoCaptureParameters.hpp Source File

AddOns/MediaFramework/VideoCaptureParameters.hpp

Go to the documentation of this file.
00001 /*
00002 *******************************************************************************
00003                        Copyright eMuzed Inc., 2001-2004.
00004 All rights Reserved, Licensed Software Confidential and Proprietary Information
00005     of eMuzed Incorporation Made available under Non-Disclosure Agreement OR
00006                             License as applicable.
00007 *******************************************************************************
00008 */
00009
00010 /*
00011 *******************************************************************************
00012 Product     : MMFr and MM Apps on APOXI
00013 Module      : MMFr
00014 File        : VideoCaptureParameters.hpp
00015 Description :
00016
00017 Revision Record:
00018 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00019 Date            Id          Author              Comment
00020 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
00021 13th Oct 2004           Naveen Narayanan        Integrated the proposal
00022 ------------------------------------------------------------------------ */
00023 #if !defined(VideoCaptureParameters_hpp)
00024 #define VideoCaptureParameters_hpp
00025
00026 class VideoCaptureParameters{
00027
00028     public:
00029
00030         VideoCaptureParameters( Size max_resolution=0,
00031                                 UINT16 max_frame_rate_numerator=0,
00032                                 UINT16 max_frame_rate_denominator=0,
00033                                 UINT16 max_bit_rate=0,
00034                                 UINT32 max_duration=0,
00035                                 UINT32 max_media_length=0,
00036                                 BOOLEAN audio_flag=TRUE,
00037                                 MimeType pref_mime_type=c_mime_unknown);
00038
00039         virtual ~VideoCaptureParameters();
00040
00041         virtual Size GetMaxResolution() const;
00042
00043         virtual void GetMaxFramerate(   UINT16& max_frame_rate_numerator,
00044                                         UINT16& max_frame_rate_denominator) const;
00045
00046         virtual UINT16 GetMaxBitrate() const;
00047
00048         virtual UINT32 GetMaxDuration() const;
00049
00050         virtual UINT32 GetMaxMediaLength() const;
00051
00052         virtual BOOLEAN IsAudioEnabled() const;
00053
00054         virtual MimeType GetPrefMimeType() const;
00055
00056     private :
00057
00060         Size m_max_resolution;
00061
00067         UINT16 m_max_frame_rate_numerator;
00071         UINT16 m_max_frame_rate_denominator;
00072
00075         UINT16 m_max_bitrate;
00076
00079         UINT32 m_max_duration;
00080
00083         UINT32 m_max_media_length;
00084
00086         BOOLEAN m_audio_flag;
00087
00090         MimeType m_pref_mime_type;
00091 };
00092 #endif
00093
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EFOApoxiLayer.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EFOApoxiLayer.hpp File Reference

Go to the source code of this file.

Defines

#define EFOApoxiLayer_hpp

Define Documentation

#define EFOApoxiLayer_hpp

Generated on Tue Jan 24 16:37:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EFOApoxiLayer.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EFOApoxiLayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EFOApoxiLayer_hpp)
00010 #define EFOApoxiLayer_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal header file which should not be used by the MMI in a
00014     direct manner, and the interface may be changed in future releases.
00015
00016 */
00017
00018 typedef enum
00019 {
00020     kReadOnlyMode,
00021     kWriteOnlyMode,
00022     kReadAndWriteMode
00023 } EFOFileOpenMode;
00024
00025 typedef enum
00026 {
00027     kBinDataType,
00028     kFileType,
00029     kDataSinkType,
00030     kObjectTypeCount    // Number of Stream Types supported.
00031 } EFOFileStreamType;
00032
00033 #endif // DOXYGEN_SHOULD_SKIP_THIS
00034 #endif // EFOApoxiLayer_hpp
00035
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EFOBinData.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EFOBinData.hpp File Reference

Go to the source code of this file.

Defines

#define EFOBinData_hpp

Define Documentation

#define EFOBinData_hpp

Generated on Tue Jan 24 16:37:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EFOBinData.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EFOBinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EFOBinData_hpp)
00010 #define EFOBinData_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018 #include "EFOApoxiLayer.hpp"
00019
00020 class EmApoxiBinData;
00021
00029 EmApoxiUINT32 BinDataRead (void* p_object,
00030                     void* p_buffer,
00031                     EmApoxiUINT32  offset,
00032                     EmApoxiUINT32  bytes_to_read );
00033
00039 EmApoxiBOOLEAN BinDataGetSize (void* p_object, EmApoxiUINT32 &size);
00040
00041 #endif // DOXYGEN_SHOULD_SKIP_THIS
00042 #endif // EFOBinData_hpp
00043
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EFODataSink.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EFODataSink.hpp File Reference

Go to the source code of this file.

Defines

#define EFODataSink_hpp

Define Documentation

#define EFODataSink_hpp

Generated on Tue Jan 24 16:37:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EFODataSink.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EFODataSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (EFODataSink_hpp)
00010 #define EFODataSink_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EFOApoxiLayer.hpp"
00018 #include "EmApoxiDataTypes.hpp"
00019
00020 class EmApoxiDataSink;
00021
00030 EmApoxiUINT32 DataSinkWrite (   void* p_object,
00031                         void* p_buffer,
00032                         EmApoxiUINT32  offset,
00033                         EmApoxiUINT32  bytes_to_write );
00034
00040 EmApoxiBOOLEAN DataSinkGetSize (void* p_object, EmApoxiUINT32 &size);
00041
00042 #endif // DOXYGEN_SHOULD_SKIP_THIS
00043 #endif // EFODataSink_hpp
00044
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAllocLogs.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAllocLogs.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | EMAPOXI_DBG_ALLOC_LOG(x)
#define | EMAPOXI_DBG_FREE_LOG(x)

Define Documentation

#define EMAPOXI_DBG_ALLOC_LOG ( x )

#define EMAPOXI_DBG_FREE_LOG ( x )

Generated on Tue Jan 24 16:37:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAllocLogs.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAllocLogs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifndef EM_APOXI_ALLOC_LOGS_HPP
00010 #define EM_APOXI_ALLOC_LOGS_HPP
00011
00012     #define EMAPOXI_DBG_ALLOC_LOG(x)
00013     #define EMAPOXI_DBG_FREE_LOG(x)
00014
00015 #endif
00016
00017
00018
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDecoder.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDecoder.cpp File Reference

#include "EmApoxiCodecManager.hpp"
#include "EmApoxiAudioDecoder.hpp"
#include "EmApoxiCodecUtils.hpp"
#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>

Include dependency graph for EmApoxiAudioDecoder.cpp:

Functions

void sEmApoxiAudioDecoderFrameDecodedCb (int result, void *context, void *out_buf, unsigned int out_buf_len, unsigned int in_buf_used)

Function Documentation

void sEmApoxiAudioDecoderFrameDecodedCb | ( | int | result,
 |  | void * | context,
 |  | void * | out_buf,
 |  | unsigned int | out_buf_len,
 |  | unsigned int | in_buf_used
 | ) |

Generated on Tue Jan 24 16:37:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDecoder.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDecoder.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiAudioDecoderhpp

Define Documentation

#define EmApoxiAudioDecoderhpp

Generated on Tue Jan 24 16:37:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDecoder.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiAudioDecoderhpp)
00010 #define EmApoxiAudioDecoderhpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiDataTypes.hpp"
00019 #include "EmApoxiCodecManager.hpp"
00020 class AudioDecoder;
00021
00027 class EmApoxiAudioDecoder {
00028     public:
00031         enum ParameterType {
00039             QualityLevel,
00045             Format,
00046             EndOfParameterType
00047         };
00048
00050         enum DecodingFunctionType {
00051             DecodeBufferFct,
00052             DecodeFrameFct
00053         };
00054
00056         enum AacFormatType {
00058             AacRawFormat,
00061             AacAdifOrAdtsFormat,
00064             AacAdtsWithOneRawDataBlockFormat
00065         };
00066
00085         typedef void (*CbFrameDecoded)( EmApoxiCodecManager::ResultType result,
00086                                         void* context,
00087                                         const EmApoxiUINT8 HUGE* out_buf,
00088                                         EmApoxiUINT32 out_buf_len,
00089                                         EmApoxiUINT32 in_buf_used);
00090
00091
00118         EmApoxiCodecManager::ResultType AllocateOutputBuffers(
00119                                                     EmApoxiUINT8 HUGE** &out_buf_array,
00120                                                     EmApoxiUINT8& out_buf_count,
00121                                                     EmApoxiUINT32& out_buf_len,
00122                                                     DecodingFunctionType& dec_fct);
00123
00139         EmApoxiCodecManager::ResultType RegisterCallbackFunctions(void* context,
00140                                         CbFrameDecoded cb_frame_decoded);
00141
00160             EmApoxiCodecManager::ResultType DecodeBuffer(
00161                                                     const EmApoxiUINT8 HUGE* in_buf,
00162                                                     EmApoxiUINT32 in_buf_len,
00163                                                     const EmApoxiUINT8 HUGE* out_buf,
00164                                                     EmApoxiUINT32 out_buf_len);
00165
00183         EmApoxiCodecManager::ResultType DecodeFrame(const EmApoxiUINT8 HUGE* in_buf,
00184                                                     EmApoxiUINT32 in_buf_len,
00185                                                     const EmApoxiUINT8 HUGE* out_buf,
00186                                                     EmApoxiUINT32 out_buf_len);
00187
00218          EmApoxiCodecManager::ResultType Start( const EmApoxiUINT8* config_stream,
00219                                                 EmApoxiUINT32& config_len,
00220                                                 const EmApoxiCodecManager::AudioDecoderParameters& params,
00221                                                 EmApoxiCodecManager::AudioStreamInfo& stream_info) ;
00222
00228          void Stop() ;
00229
00230          EmApoxiCodecManager::ResultType Reset();
00231
00232         EmApoxiAudioDecoder();
00233
00234         ~EmApoxiAudioDecoder();
00235
00236     private:
00238         EmApoxiAudioDecoder(const EmApoxiAudioDecoder& decoder) {}
00239
00241         EmApoxiAudioDecoder& operator=(const EmApoxiAudioDecoder& decoder) { }
00242
00243         AudioDecoder*   m_AudioDecoder;
00244
00245         CbFrameDecoded m_DecodeCbFxn;
00246
00247         void *m_Context;
00248
00249         friend void sEmApoxiAudioDecoderFrameDecodedCb(int result,void* context,
00250                                         void* out_buf,
00251                                         unsigned int out_buf_len,
00252                                         unsigned int in_buf_used);
00253
00254
00255 };
00256
00258 #endif
00259 #endif // Apoxi_CodecManager_hpp
00260
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDefines.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDefines.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiAudioDefines_hpp

Define Documentation

#define EmApoxiAudioDefines_hpp

Generated on Tue Jan 24 16:37:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDefines.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDefines.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiAudioDefines_hpp)
00010 #define EmApoxiAudioDefines_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018
00019 #define EMAPOXI_DEFAULT_VOLUME  50
00020 #define EMAPOXI_MAX_VOLUME      100
00021 #define EMAPOXI_MIN_VOLUME      0
00022
00023 typedef void (*tEaadCallBackFxn)(EmApoxiUINT8** audio_buffer,EmApoxiUINT16* size,void *userdata);
00024 typedef void * tEmApxAudDeviceHdl;
00025
00026 typedef enum
00027 {
00028     Eaad8000PlaybackSampRate,
00029     Eaad11025PlaybackSampRate,
00030     Eaad12000PlaybackSampRate,
00031     Eaad16000PlaybackSampRate,
00032     Eaad22050PlaybackSampRate,
00033     Eaad24000PlaybackSampRate,
00034     Eaad32000PlaybackSampRate,
00035     Eaad44100PlaybackSampRate,
00036     Eaad48000PlaybackSampRate,
00037     EaadInvalidPlaybackSampRate
00038 }EaadPlayBackSamplingRate;
00039
00040 typedef enum
00041 {
00042     Eaad4_75RecordSampRate,
00043     Eaad5_15RecordSampRate,
00044     Eaad5_90RecordSampRate,
00045     Eaad6_70RecordSampRate,
00046     Eaad7_40RecordSampRate,
00047     Eaad7_95RecordSampRate,
00048     Eaad10_20RecordSampRate,
00049     Eaad12_20RecordSampRate,
00050     EaadFullRecordSampRate,
00051     EaadInvalidRecordSampRate,
00052 }EaadRecordSamplingRate;
00053
00054 typedef enum
00055 {
00056     EaadStereoMode,
00057     EaadMonoMode,
00058     EaadMonoReplicate,
00059     EaadInvalidNumChannels
00060 }EaadNumChannels;
00061
00062 typedef enum
00063 {
00064     EaadMediaAmrNb,
00065     EaadMediaPcm
00066 }EaadMediaType;
00067
00068 typedef enum
00069 {
00070     EaadAttributeSamplingRate,
00071     EaadAttributeNumChannels,
00072     EaadAttributeMediaType,
00073     EaadAttributeVolume,
00074     EaadAttributePriority,
00075     EaadAttributeRepeatCount,
00076     EaadAttributeContinue,
00077     EaadAttributeAudioReference,
00078     EaadNumAttributes,
00079     EaadAttributeLastBytes,
00080     EaadAttributeIgnorePriority
00081
00082 }EaadAttributes;
00083
00084 #endif // DOXYGEN_SHOULD_SKIP_THIS
00085 #endif // EmApoxiAudioDefines_hpp
00086
Generated on Tue Jan 24 14:45:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDeviceImpl.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDeviceImpl.cpp File Reference

#include <Auxiliary/Vector.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/AudioReference.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/StreamAudioPlayer.hpp>
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiDataTypes.hpp"
#include "EmApoxiAudioDeviceImpl.hpp"
#include "EmApoxiAudioUtils.hpp"

Include dependency graph for EmApoxiAudioDeviceImpl.cpp:

Typedefs

typedef EAADevice * | ptEAADevice
typedef EAADevice | tEAADevice
typedef enum _EmApoxi_Audio_State | tEmApoxiAudioState

Enumerations

enum | _EmApoxi_Audio_State { EmApoxiAudioStateIdle = 0, EmApoxiAudioStatePlaying, EmApoxiAudioStatePaused }

Functions

tEmApxAudDeviceHdl | EaadCreate (tEaadCallBackFxn cb_fxn, EaadMediaType media_type, void *user_data)
EmApoxiBOOLEAN | EaadDeInit ()
EmApoxiBOOLEAN | EaadDestroy (tEmApxAudDeviceHdl hndl)
tEmApxAudDeviceHdl | EaadDummyCreate (tEaadCallBackFxn cb_fxn)
EmApoxiBOOLEAN | EaadDummyDestroy (tEmApxAudDeviceHdl hndl)
EmApoxiBOOLEAN | EaadGetProperty (tEmApxAudDeviceHdl hndl, EaadAttributes attribute, EmApoxiUINT32 *val)
EmApoxiBOOLEAN | EaadInit ()
EmApoxiBOOLEAN | EaadResume (tEmApxAudDeviceHdl hndl)
EmApoxiBOOLEAN | EaadSetProperty (tEmApxAudDeviceHdl hndl, EaadAttributes attribute, EmApoxiUINT32 val)
EmApoxiBOOLEAN | EaadStartPlayBack (tEmApxAudDeviceHdl hndl)
EmApoxiBOOLEAN | EaadStartRecording (tEmApxAudDeviceHdl hndl)
EmApoxiBOOLEAN | EaadStopPlayBack (tEmApxAudDeviceHdl hndl)
EmApoxiBOOLEAN | EaadStopRecording (tEmApxAudDeviceHdl hndl)
EmApoxiBOOLEAN | EaadSuspend (tEmApxAudDeviceHdl hndl)

Typedef Documentation

typedef struct EAADevice* ptEAADevice

typedef struct EAADevice tEAADevice

typedef enum _EmApoxi_Audio_State tEmApoxiAudioState

Enumeration Type Documentation

enum _EmApoxi_Audio_State

Enumerator:
EmApoxiAudioStateIdle
EmApoxiAudioStatePlaying
EmApoxiAudioStatePaused

Function Documentation

tEmApxAudDeviceHdl EaadCreate | ( | tEaadCallBackFxn | cb_fxn,
 |  | EaadMediaType | media_type,
 |  | void * | user_data
 | ) |

EmApoxiBOOLEAN EaadDeInit ( )

EmApoxiBOOLEAN EaadDestroy ( tEmApxAudDeviceHdl hndl )

tEmApxAudDeviceHdl EaadDummyCreate ( tEaadCallBackFxn cb_fxn )

EmApoxiBOOLEAN EaadDummyDestroy ( tEmApxAudDeviceHdl hndl )

EmApoxiBOOLEAN EaadGetProperty | ( | tEmApxAudDeviceHdl | hndl,
 |  | EaadAttributes | attribute,
 |  | EmApoxiUINT32 * | val
 | ) |

EmApoxiBOOLEAN EaadInit ( )

EmApoxiBOOLEAN EaadResume ( tEmApxAudDeviceHdl hndl )

EmApoxiBOOLEAN EaadSetProperty | ( | tEmApxAudDeviceHdl | hndl,
 |  | EaadAttributes | attribute,
 |  | EmApoxiUINT32 | val
 | ) |

EmApoxiBOOLEAN EaadStartPlayBack ( tEmApxAudDeviceHdl hndl )

EmApoxiBOOLEAN EaadStartRecording ( tEmApxAudDeviceHdl hndl )

EmApoxiBOOLEAN EaadStopPlayBack ( tEmApxAudDeviceHdl hndl )

EmApoxiBOOLEAN EaadStopRecording ( tEmApxAudDeviceHdl hndl )

EmApoxiBOOLEAN EaadSuspend ( tEmApxAudDeviceHdl hndl )

Generated on Tue Jan 24 16:37:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDeviceImpl.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDeviceImpl.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiAudioDeviceImpl_hpp

Define Documentation

#define EmApoxiAudioDeviceImpl_hpp

Generated on Tue Jan 24 16:37:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDeviceImpl.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioDeviceImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiAudioDeviceImpl_hpp)
00010 #define EmApoxiAudioDeviceImpl_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiAudioDefines.hpp"
00018
00019 EmApoxiBOOLEAN EaadInit();
00020
00021 tEmApxAudDeviceHdl EaadCreate(tEaadCallBackFxn cb_fxn,
00022                              EaadMediaType media_type,void *user_data=0) ;
00023
00024 tEmApxAudDeviceHdl EaadDummyCreate(tEaadCallBackFxn cb_fxn);
00025
00026 EmApoxiBOOLEAN EaadDummyDestroy(tEmApxAudDeviceHdl hndl);
00027
00028 EmApoxiBOOLEAN EaadSetProperty(tEmApxAudDeviceHdl hndl,EaadAttributes attribute,
00029                          EmApoxiUINT32 val);
00030
00031 EmApoxiBOOLEAN EaadGetProperty(tEmApxAudDeviceHdl hndl,EaadAttributes attribute,
00032                          EmApoxiUINT32 *val);
00033
00034 EmApoxiBOOLEAN EaadStartPlayBack(tEmApxAudDeviceHdl hndl);
00035
00036 EmApoxiBOOLEAN EaadStartRecording(tEmApxAudDeviceHdl hndl);
00037
00038 EmApoxiBOOLEAN EaadStopPlayBack(tEmApxAudDeviceHdl hndl);
00039
00040 EmApoxiBOOLEAN EaadStopRecording(tEmApxAudDeviceHdl hndl);
00041
00042 EmApoxiBOOLEAN EaadSuspend(tEmApxAudDeviceHdl hndl);
00043
00044 EmApoxiBOOLEAN EaadResume(tEmApxAudDeviceHdl hndl);
00045
00046 EmApoxiBOOLEAN EaadDestroy(tEmApxAudDeviceHdl hndl);
00047
00048 EmApoxiBOOLEAN EaadDeInit();
00049
00050 #endif // DOXYGEN_SHOULD_SKIP_THIS
00051 #endif //EmApoxiAudioDeviceImpl_hpp
00052
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioUtils.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioUtils.cpp File Reference

#include <Kernel/Lib.hpp>
#include "EmApoxiDataTypes.hpp"
#include "EmApoxiAudioDefines.hpp"

Include dependency graph for EmApoxiAudioUtils.cpp:

Functions

EmApoxiBOOLEAN | EaadGetNumChannels (EaadNumChannels num_channels, EmApoxiUINT8 &monostereomode)
EmApoxiBOOLEAN | EaadGetPlaybackSampleRate (EaadPlayBackSamplingRate sample_rate, EmApoxiUINT8 &apoxisamplerate)
EmApoxiBOOLEAN | EaadGetRecordSamplingRate (EaadRecordSamplingRate sample_rate, EmApoxiUINT8 &apoxisamplerate)

Function Documentation

EmApoxiBOOLEAN EaadGetNumChannels | ( | EaadNumChannels | num_channels,
 |  | EmApoxiUINT8 & | monostereomode
 | ) |

EmApoxiBOOLEAN EaadGetPlaybackSampleRate | ( | EaadPlayBackSamplingRate | sample_rate,
 |  | EmApoxiUINT8 & | apoxisamplerate
 | ) |

EmApoxiBOOLEAN EaadGetRecordSamplingRate | ( | EaadRecordSamplingRate | sample_rate,
 |  | EmApoxiUINT8 & | apoxisamplerate
 | ) |

Generated on Tue Jan 24 16:37:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioUtils.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioUtils.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiAudioUtils_hpp

Define Documentation

#define EmApoxiAudioUtils_hpp

Generated on Tue Jan 24 16:37:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioUtils.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiAudioUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiAudioUtils_hpp)
00010 #define EmApoxiAudioUtils_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 EmApoxiBOOLEAN EaadGetPlaybackSampleRate (
00018         EaadPlayBackSamplingRate sample_rate,
00019         EmApoxiUINT8& apoxisamplerate );
00020
00021 EmApoxiBOOLEAN EaadGetRecordSamplingRate (
00022         EaadRecordSamplingRate sample_rate,
00023         EmApoxiUINT8&   apoxisamplerate );
00024
00025 EmApoxiBOOLEAN EaadGetNumChannels (
00026         EaadNumChannels num_channels,
00027         EmApoxiUINT8&   monosteromode );
00028
00029 #endif // DOXYGEN_SHOULD_SKIP_THIS
00030 #endif // EmApoxiAudioUtils_hpp
00031
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecManager.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecManager.cpp File Reference

#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include "EmApoxiDataTypes.hpp"
#include "EmApoxiCodecUtils.hpp"
#include "EmApoxiCodecManager.hpp"

Include dependency graph for EmApoxiCodecManager.cpp:

Generated on Tue Jan 24 16:37:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecManager.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecManager.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiCodecManagerhpp

Define Documentation

#define EmApoxiCodecManagerhpp

Generated on Tue Jan 24 16:37:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecManager.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiCodecManagerhpp)
00010 #define EmApoxiCodecManagerhpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /*
00015     This is an internal class which should not be used by the MMI in a direct
00016     manner, and the interface may be changed in future releases.
00017 */
00018
00019 #include "EmApoxiDataTypes.hpp"
00020
00024 class EmApoxiCodecManager {
00025
00026     public:
00029         enum ResultType {
00031             Success = 0,
00033             MediaNotSupported,
00034             OutOfMemory,
00036             SmallBuffer,
00037             NullParameter,
00038             InvalidParameter,
00039             InvalidFrameSize,
00041             FeatureNotSupported,
00043             GeneralError,
00046             MaxNumberOfCodersReached,
00049             MaxNumberOfOperationsReached,
00051             ArrayTooShort,
00052             InvalidState,
00053             EndOfResultType
00054         };
00055
00057         enum CodecType {
00060             DefaultCodec = 0,
00063             UnknownCodec,
00064             Mpeg4Sp,
00065             H263Bl,
00066             GsmAmrNb,
00067             Mpeg4Aac,
00068             Qcelp,
00069             Evrc,
00070             Mp3,
00071             Mpeg4AacPlusV1,
00072             Mpeg4AacPlusV2,
00073             H264Bp,
00074             EndOfCodecType
00075         };
00076
00080         enum ApplicationCategoriesFlagsType {
00081             StorageAppCatFlag = 0x1,
00082             StreamingAppCatFlag = 0x2,
00083             TelephonyAppCatFlag = 0x4,
00084             GreatestValueOfApplicationCategoriesFlagsType = TelephonyAppCatFlag
00085         };
00086
00089         enum LocationType {
00090             HostLocation,
00091             CompanionLocation,
00092             EndOfLocationType
00093         };
00094
00096         struct VideoStreamInfo {
00098             CodecType m_codec_type;
00101             EmApoxiUINT16 m_ext_width;
00104             EmApoxiUINT16 m_ext_height;
00106             EmApoxiUINT16 m_actual_width;
00108             EmApoxiUINT16 m_actual_height;
00110             EmApoxiUINT32 m_frame_length;
00114             EmApoxiUINT16 m_frame_rate_numerator;
00118             EmApoxiUINT16 m_frame_rate_denominator;
00124             EmApoxiINT m_top_offset;
00130             EmApoxiINT m_left_offset;
00131         };
00132
00134         struct VideoEncoderInfo {
00136             LocationType m_location;
00139             EmApoxiUINT32 m_in_buf_max_len;
00140         };
00141
00144         struct VideoEncoderParameters {
00146             CodecType m_video_codec;
00148             EmApoxiUINT16 m_width;
00150             EmApoxiUINT16 m_height;
00154             EmApoxiUINT16 m_frame_rate_numerator;
00158             EmApoxiUINT16 m_frame_rate_denominator;
00160             EmApoxiUINT32 m_bit_rate;
00164             EmApoxiUINT32 m_timer_resolution;
00174             EmApoxiUINT16 m_quality_level;
00181             EmApoxiUINT32 m_application_category;
00182         };
00183
00186         struct VideoDecoderParameters {
00196             CodecType m_video_codec;
00205             EmApoxiUINT16 m_quality_level;
00213             EmApoxiUINT16 m_width;
00221             EmApoxiUINT16 m_height;
00222         };
00223
00225         struct AudioStreamInfo {
00227             CodecType m_codec_type;
00229             EmApoxiUINT32 m_sampling_frequency;
00231             EmApoxiUINT32 m_num_of_channels;
00232         };
00233
00236         struct AudioDecoderParameters {
00246             CodecType m_audio_codec;
00253             EmApoxiUINT16 m_quality_level;
00259             EmApoxiINT m_format;
00260         };
00261
00262         static EmApoxiCodecManager::ResultType GetAudioStreamInfo( const EmApoxiUINT8* config_stream,
00263                                                     EmApoxiUINT32& config_len,
00264                                                     const EmApoxiCodecManager::AudioDecoderParameters& params,
00265                                                     EmApoxiCodecManager::AudioStreamInfo& stream_info);
00266
00267 };
00268
00270 #endif
00271
00272 #endif // Apoxi_CodecManager_hpp
00273
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecUtils.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecUtils.cpp File Reference

#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmApoxiDataTypes.hpp"
#include "EmApoxiCodecManager.hpp"
#include "EmApoxiCodecUtils.hpp"

Include dependency graph for EmApoxiCodecUtils.cpp:

Functions

AudioDecoder::AacFormatType | TranslateAacFormatType (EmApoxiAudioDecoder::AacFormatType aFormat)
CodecManager::ApplicationCategoriesFlagsType | TranslateApplicationCategoriesFlagsType (EmApoxiCodecManager::ApplicationCategoriesFlagsType aFlag)
EmApoxiAudioDecoder::DecodingFunctionType | TranslateAudioDecoderDecodingFctType (AudioDecoder::DecodingFunctionType aFct)
AudioDecoder::ParameterType | TranslateAudioDecoderParameterType (EmApoxiAudioDecoder::ParameterType aParam)
EmApoxiAudioDecoder::ParameterType | TranslateAudioDecoderParameterType (AudioDecoder::ParameterType aParam)
EmApoxiCodecManager::ResultType | TranslateCodecResultType (CodecManager::ResultType aResult)
CodecManager::CodecType | TranslateCodecType (EmApoxiCodecManager::CodecType aCodec)
EmApoxiCodecManager::CodecType | TranslateCodecType (CodecManager::CodecType aCodec)
CodecManager::LocationType | TranslateLocationType (EmApoxiCodecManager::LocationType aLocation)
EmApoxiCodecManager::LocationType | TranslateLocationType (CodecManager::LocationType aLocation)
EmApoxiVideoDecoder::FlagsType | TranslateVideoDecoderFlagsType (VideoDecoder::FlagsType aFlag)
VideoDecoder::ParameterType | TranslateVideoDecoderParameterType (EmApoxiVideoDecoder::ParameterType aParam)
EmApoxiVideoDecoder::ParameterType | TranslateVideoDecoderParameterType (VideoDecoder::ParameterType aParam)
EmApoxiVideoEncoder::FrameCodingType | TranslateVideoEncoderCodingType (VideoEncoder::FrameCodingType aType)
VideoEncoder::ParameterType | TranslateVideoEncoderParameterType (EmApoxiVideoEncoder::ParameterType aParam)
EmApoxiVideoEncoder::ParameterType | TranslateVideoEncoderParameterType (VideoEncoder::ParameterType aParam)

Function Documentation

AudioDecoder::AacFormatType TranslateAacFormatType ( EmApoxiAudioDecoder::AacFormatType aFormat )

CodecManager::ApplicationCategoriesFlagsType TranslateApplicationCategoriesFlagsType ( EmApoxiCodecManager::ApplicationCategoriesFlagsType aFlag )

EmApoxiAudioDecoder::DecodingFunctionType TranslateAudioDecoderDecodingFctType ( AudioDecoder::DecodingFunctionType aFct )

AudioDecoder::ParameterType TranslateAudioDecoderParameterType ( EmApoxiAudioDecoder::ParameterType aParam )

EmApoxiAudioDecoder::ParameterType TranslateAudioDecoderParameterType ( AudioDecoder::ParameterType aParam )

EmApoxiCodecManager::ResultType TranslateCodecResultType ( CodecManager::ResultType aResult )

CodecManager::CodecType TranslateCodecType ( EmApoxiCodecManager::CodecType aCodec )

EmApoxiCodecManager::CodecType TranslateCodecType ( CodecManager::CodecType aCodec )

CodecManager::LocationType TranslateLocationType ( EmApoxiCodecManager::LocationType aLocation )

EmApoxiCodecManager::LocationType TranslateLocationType ( CodecManager::LocationType aLocation )

EmApoxiVideoDecoder::FlagsType TranslateVideoDecoderFlagsType ( VideoDecoder::FlagsType aFlag )

VideoDecoder::ParameterType TranslateVideoDecoderParameterType ( EmApoxiVideoDecoder::ParameterType aParam )

EmApoxiVideoDecoder::ParameterType TranslateVideoDecoderParameterType ( VideoDecoder::ParameterType aParam )

EmApoxiVideoEncoder::FrameCodingType TranslateVideoEncoderCodingType ( VideoEncoder::FrameCodingType aType )

VideoEncoder::ParameterType TranslateVideoEncoderParameterType ( EmApoxiVideoEncoder::ParameterType aParam )

EmApoxiVideoEncoder::ParameterType TranslateVideoEncoderParameterType ( VideoEncoder::ParameterType aParam )

Generated on Tue Jan 24 16:37:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecUtils.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecUtils.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiCodecUtilshpp

Define Documentation

#define EmApoxiCodecUtilshpp

Generated on Tue Jan 24 16:37:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecUtils.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiCodecUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiCodecUtilshpp)
00010 #define EmApoxiCodecUtilshpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include "EmApoxiDataTypes.hpp"
00015 #include "EmApoxiCodecManager.hpp"
00016 #include "EmApoxiAudioDecoder.hpp"
00017 #include "EmApoxiVideoDecoder.hpp"
00018 #include "EmApoxiVideoEncoder.hpp"
00019
00020 #include <AddOns/CodecManager/CodecManager.hpp>
00021 #include <AddOns/CodecManager/AudioDecoder.hpp>
00022 #include <AddOns/CodecManager/VideoDecoder.hpp>
00023 #include <AddOns/CodecManager/VideoEncoder.hpp>
00024
00025 EmApoxiCodecManager::ResultType TranslateCodecResultType(CodecManager::ResultType aResult);
00026
00027 EmApoxiCodecManager::CodecType TranslateCodecType(CodecManager::CodecType aCodec);
00028
00029 CodecManager::CodecType TranslateCodecType(EmApoxiCodecManager::CodecType aCodec);
00030
00031 CodecManager::ApplicationCategoriesFlagsType TranslateApplicationCategoriesFlagsType
00032                                     (EmApoxiCodecManager::ApplicationCategoriesFlagsType aFlag);
00033
00034 EmApoxiCodecManager::LocationType TranslateLocationType(CodecManager::LocationType aLocation);
00035
00036 CodecManager::LocationType TranslateLocationType(EmApoxiCodecManager::LocationType aLocation);
00037
00038 EmApoxiAudioDecoder::ParameterType TranslateAudioDecoderParameterType(
00039                                                   AudioDecoder::ParameterType aParam);
00040
00041 AudioDecoder::ParameterType TranslateAudioDecoderParameterType(
00042                                                   EmApoxiAudioDecoder::ParameterType aParam);
00043
00044 EmApoxiAudioDecoder::DecodingFunctionType TranslateAudioDecoderDecodingFctType(
00045                                                        AudioDecoder::DecodingFunctionType aFct);
00046
00047 AudioDecoder::AacFormatType TranslateAacFormatType(EmApoxiAudioDecoder::AacFormatType aFormat);
00048
00049 EmApoxiVideoDecoder::ParameterType TranslateVideoDecoderParameterType
00050                                         (VideoDecoder::ParameterType aParam);
00051
00052 VideoDecoder::ParameterType TranslateVideoDecoderParameterType
00053                                     (EmApoxiVideoDecoder::ParameterType aParam);
00054
00055 EmApoxiVideoDecoder::FlagsType TranslateVideoDecoderFlagsType
00056                                 (VideoDecoder::FlagsType aFlag);
00057
00058 EmApoxiVideoEncoder::ParameterType TranslateVideoEncoderParameterType
00059                             (VideoEncoder::ParameterType aParam);
00060
00061 VideoEncoder::ParameterType TranslateVideoEncoderParameterType
00062                             (EmApoxiVideoEncoder::ParameterType aParam);
00063
00064 EmApoxiVideoEncoder::FrameCodingType TranslateVideoEncoderCodingType
00065                                     (VideoEncoder::FrameCodingType aType);
00066
00067 #endif
00068
00069 #endif
00070
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiFile.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiFile.cpp File Reference

#include <Afs/Rfs/File.hpp>
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiFile.hpp"

Include dependency graph for EmApoxiFile.cpp:

Functions

void | FileDataClose (void *p_object)
EmApoxiBOOLEAN | FileDataGetSize (void *p_object, EmApoxiUINT32 &size)
void * | FileDataOpen (const char *p_filename, EFOFileOpenMode openmode)
EmApoxiUINT32 | FileDataRead (void *p_object, void *p_buffer, EmApoxiUINT32 offset, EmApoxiUINT32 bytes_to_read)
EmApoxiUINT32 | FileDataWrite (void *p_object, void *p_buffer, EmApoxiUINT32 offset, EmApoxiUINT32 bytes_to_write)

Function Documentation

void FileDataClose ( void * p_object )

EmApoxiBOOLEAN FileDataGetSize | ( | void * | p_object,
 |  | EmApoxiUINT32 & | size
 | ) |

void* FileDataOpen | ( | const char * | p_filename,
 |  | EFOFileOpenMode | openmode
 | ) |

EmApoxiUINT32 FileDataRead | ( | void * | p_object,
 |  | void * | p_buffer,
 |  | EmApoxiUINT32 | offset,
 |  | EmApoxiUINT32 | bytes_to_read
 | ) |

EmApoxiUINT32 FileDataWrite | ( | void * | p_object,
 |  | void * | p_buffer,
 |  | EmApoxiUINT32 | offset,
 |  | EmApoxiUINT32 | bytes_to_write
 | ) |

Generated on Tue Jan 24 16:37:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiFile.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiFile.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiFile_hpp

Define Documentation

#define EmApoxiFile_hpp

Generated on Tue Jan 24 16:37:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiFile.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiFile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiFile_hpp)
00010 #define EmApoxiFile_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018 #include "EFOApoxiLayer.hpp"
00019
00020 class File;
00021
00027 void* FileDataOpen (const char* p_filename, EFOFileOpenMode openmode);
00028
00032 void FileDataClose ( void* p_object);
00033
00041 EmApoxiUINT32 FileDataRead (void* p_object,
00042                         void* p_buffer,
00043                         EmApoxiUINT32  offset,
00044                         EmApoxiUINT32  bytes_to_read );
00045
00053 EmApoxiUINT32 FileDataWrite (void* p_object,
00054                         void* p_buffer,
00055                         EmApoxiUINT32  offset,
00056                         EmApoxiUINT32  bytes_to_write );
00057
00063 EmApoxiBOOLEAN FileDataGetSize ( void* p_object, EmApoxiUINT32 &size);
00064
00065 #endif // DOXYGEN_SHOULD_SKIP_THIS
00066 #endif // EmApoxiFile_hpp
00067
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoCapture.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoCapture.cpp File Reference

#include <Kernel/Lib.hpp>
#include <Devices/VideoCamera.hpp>
#include <Devices/DeviceManager.hpp>
#include "EmApoxiVideoUtils.hpp"
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiVideoCaptureExp.hpp"

Include dependency graph for EmApoxiVideoCapture.cpp:

Generated on Tue Jan 24 16:37:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoCaptureExp.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoCaptureExp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiVideoCaptureExp_hpp

Define Documentation

#define EmApoxiVideoCaptureExp_hpp

Generated on Tue Jan 24 16:37:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoCaptureExp.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoCaptureExp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(EmApoxiVideoCaptureExp_hpp)
00009 #define EmApoxiVideoCaptureExp_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00011
00012 #include "EmApoxiVideoDefines.hpp"
00013
00014 typedef void (*tEmApoxiFrameCapturedCallback)(EmApoxiINT ret, void* context,
00015                 EmApoxiUINT8* buffer, EmApoxiUINT32 size, EmApoxiUINT32 stamp);
00016
00017 typedef void* (*tEmApoxiNotifyBufferStatus) (void *context,
00018                                              EmApoxiUINT8 free_buffer_count);
00019
00021 enum EmApoxiTwilightType {
00022     EmApoxiTwilightOff,
00023     EmApoxiTwilightOn,
00024     EmApoxiTwilightAuto
00025 };
00026
00029 enum EmApoxiImageSizeType {
00030     EmApoxiQqcifSize,           // 88x72
00031     EmApoxiSqcifSize,           // 128x96
00032     EmApoxiQqvgaSize,           // 160x120
00033     EmApoxiQcifSize,            // 176x144
00034     EmApoxiQsifSize,            // 276x120
00035     EmApoxiQvgaSize,            // 320x240
00036     EmApoxiCifSize,         // 352x288      0,3 mp
00037     EmApoxiVgaSize,         // 640x480
00038     EmApoxiSvgaSize,            // 800x600
00039     EmApoxiXgaSize,         // 1024x768
00040     EmApoxiSize1Mp,         // 1152x864     1,0 mp
00041     EmApoxiSize1_3Mp,           // 1280x960     1,3 mp
00042     EmApoxiSxgaSize,            // 1280x1024    1.3 mp
00043     EmApoxiUxgaSize,            // 1600x1200    2,0 mp
00044     EmApoxiSize2Mp,         // 1728x1152    2,0 mp
00045     EmApoxiSize3Mp,         // 2048x1536    3,0 mp
00046     EmApoxiEndOfImageSizeType
00047 };
00048
00050 enum EmApoxiFrameRateType {
00051     EmApoxiFps3_7_5 = 0,
00052     EmApoxiFps5,
00053     EmApoxiFps7_5,
00054     EmApoxiFps10,
00055     EmApoxiFps12,
00056     EmApoxiFps15,
00057     EmApoxiFps24,
00058     EmApoxiFps25,
00059     EmApoxiFps30,
00060     EmApoxiEndOfFpsType
00061 };
00062
00063 enum EmApoxiCameraError {
00064     EmApoxiNoError,
00065     EmApoxiCameraAlreadyLockedError,
00066     EmApoxiCameraNotReadyError,
00067     EmApoxiUnsupportedCameraFeature,
00068     EmApoxiCameraNotInitializedError,
00069     EmApoxiBufferNotAvailableError,
00070     EmApoxiBufferAllocationError,
00071     EmApoxiApplicationControlError,
00072     EmApoxiUnsupportedFrameRateError,
00073     EmApoxiInvalidCameraParameter,
00074     EmApoxiInvalidSizeError
00075 };
00076
00077 enum EmApoxiCameraState {
00078     CameraStateIdle = 0,
00079     CameraStateViewFinding,
00080     CameraStateRecording,
00081     CameraStatePaused
00082 };
00083
00084 enum EmApoxiActionType {
00085     EmApoxiDecrease,
00086     EmApoxiReset,
00087     EmApoxiIncrease
00088 };
00089
00090 class VideoCamera;
00091
00092 class EmApoxiVideoCapturer
00093 {
00094     public:
00095         EmApoxiVideoCapturer();
00096
00097         ~EmApoxiVideoCapturer();
00113         EmApoxiBOOLEAN  Init(
00114                         EmApoxiFrameRateType    frame_rate,
00115                         EmApoxiImageSizeType    image_size,
00116                         tEmApoxiFrameCapturedCallback   fr_captured_cb,
00117                         tEmApoxiNotifyBufferStatus      ntfy_bf_status_cb,
00118                         EmApoxiUINT             num_bfrs,
00119                         tEmApoxiVideoRect       capture_rect,
00120                         tEmApoxiContext         context,
00121                         EmApoxiUINT             camera_device_id = 0);
00122
00123
00124         tEmApoxiFrameCapturedCallback   GetFrameCapturedCb()
00125                                 { return m_fp_frame_captured_callback; };
00126
00127         tEmApoxiNotifyBufferStatus   GetEmApoxiNotifyBufferStatusCb()
00128                                 { return m_fp_notify_buffer_status; };
00129
00133         EmApoxiBOOLEAN EmApoxiEnableViewFinder();
00134
00138         EmApoxiBOOLEAN EmApoxiDisableViewFinder();
00139
00143         EmApoxiBOOLEAN EmApoxiEnableCapture();
00144
00148         EmApoxiBOOLEAN EmApoxiDisableCapture();
00149
00154         EmApoxiBOOLEAN EmApoxiPauseCapture();
00155
00162         EmApoxiBOOLEAN EmApoxiVideoCaptureSetRect
00163                             (tEmApoxiVideoRect capture_rect);
00164
00170         EmApoxiBOOLEAN EmApoxiVideoCaptureSetImageSize(
00171                             EmApoxiImageSizeType image_size);
00172
00177         EmApoxiBOOLEAN EmApoxiVideoCaptureSetFrameRate
00178                             (EmApoxiFrameRateType frame_rate);
00179
00180
00186         EmApoxiBOOLEAN EmApoxiVideoCaptureSetBrightness(EmApoxiINT value);
00187
00192         EmApoxiBOOLEAN EmApoxiVideoCaptureSetContrast(EmApoxiINT value);
00193
00200         EmApoxiBOOLEAN EmApoxiVideoCaptureSetZoom(EmApoxiActionType action,
00201                                         EmApoxiUINT8 step_size);
00202             EmApoxiBOOLEAN EmApoxiVideoCaptureSetTwilightMode
00207                                         (EmApoxiTwilightType twilight_mode);
00208
00209
00215         EmApoxiBOOLEAN ReleaseBuffer(EmApoxiUINT8 HUGE* buffer);
00216
00217         void* GetContext(){return m_context;}
00218
00219
00220     private:
00221
00222         /* Translation Functions for the Enums :
00223
00224         The functions translate the EmApoxi Enums
00225         (used by the capturer component) to
00226         the enums of the Camera Device.
00227         */
00228
00229         EmApoxiFrameRateType        m_frame_rate;
00230         EmApoxiImageSizeType        m_image_size;
00231         EmApoxiCameraState          m_state;
00232         EmApoxiUINT                 m_camera_device_id;
00233
00234         tEmApoxiVideoRect               m_capture_rect;
00235         VideoCamera*                    m_p_video_camera;
00236         tEmApoxiFrameCapturedCallback   m_fp_frame_captured_callback;
00237         tEmApoxiNotifyBufferStatus      m_fp_notify_buffer_status;
00238         void*                           m_context;
00239 };
00240
00241 #endif // DOXYGEN_SHOULD_SKIP_THIS
00242 #endif // EmApoxiVideoCaptureExp_hpp
00243
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDecoder.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDecoder.cpp File Reference

#include "EmApoxiCodecManager.hpp"
#include "EmApoxiVideoDecoder.hpp"
#include "EmApoxiCodecUtils.hpp"
#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>

Include dependency graph for EmApoxiVideoDecoder.cpp:

Functions

void | sEmApoxiInBufFreeCb (void *context, void *in_buf)
void | sEmApoxiVideoDecoderFrameDecodedCb (EmApoxiINT32 result, void *context, void *out_buf, EmApoxiUINT32 time_stamp)

Function Documentation

void sEmApoxiInBufFreeCb | ( | void * | context,
 |  | void * | in_buf
 | ) |

void sEmApoxiVideoDecoderFrameDecodedCb | ( | EmApoxiINT32 | result,
 |  | void * | context,
 |  | void * | out_buf,
 |  | EmApoxiUINT32 | time_stamp
 | ) |

Generated on Tue Jan 24 16:37:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDecoder.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDecoder.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiVideoDecoderhpp

Define Documentation

#define EmApoxiVideoDecoderhpp

Generated on Tue Jan 24 16:37:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDecoder.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiVideoDecoderhpp)
00010 #define EmApoxiVideoDecoderhpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiDataTypes.hpp"
00019 class VideoDecoder;
00020
00026 class EmApoxiVideoDecoder {
00027     public:
00028
00031         enum ParameterType {
00041             QualityLevel,
00042             EndOfParameterType
00043         };
00044
00049         enum FlagsType {
00050             LastFrameFlag = 1<<0,
00051             LastPacketInFrameFlag = 1<<1,
00052             GreatestValueOfFlagsType = LastPacketInFrameFlag
00053         };
00054
00073         typedef void (*CbFrameDecoded)( EmApoxiCodecManager::ResultType result,
00074                                         void* context,
00075                                         const EmApoxiUINT8 HUGE* out_buf,
00076                                         EmApoxiUINT32 time_stamp);
00077
00086         typedef void (*CbInBufferFree)( void* context,
00087                                         EmApoxiUINT8 HUGE* in_buf);
00088
00108         EmApoxiCodecManager::ResultType AllocateOutputBuffers(EmApoxiUINT8& out_buf_count,
00109                                                                 EmApoxiUINT32& out_buf_len);
00110
00117         EmApoxiCodecManager::ResultType GetNumberOfInitialDecodeOperations(EmApoxiUINT8& operations) ;
00118
00139         EmApoxiCodecManager::ResultType RegisterCallbackFunctions(  void* context,
00140                                                                     CbFrameDecoded cb_frame_decoded,
00141                                                                     CbInBufferFree cb_in_buf_free);
00142
00157         EmApoxiCodecManager::ResultType DecodeFrame(    const EmApoxiUINT8 HUGE* in_buf,
00158                                                         EmApoxiUINT32 in_buf_len,
00159                                                         EmApoxiUINT16 flags) ;
00160
00175          EmApoxiCodecManager::ResultType DecodePacket(  const EmApoxiUINT8 HUGE* in_buf,
00176                                                         EmApoxiUINT32 in_buf_len,
00177                                                         EmApoxiUINT16 flags) ;
00178
00191          EmApoxiCodecManager::ResultType ReleaseOutputBuffer(const EmApoxiUINT8 HUGE* out_buf) ;
00192
00205          EmApoxiCodecManager::ResultType NotifyOutputBufferReleased(const EmApoxiUINT8 HUGE* out_buf) ;
00206
00216          EmApoxiCodecManager::ResultType Flush() ;
00217
00235          EmApoxiCodecManager::ResultType SetParameters( const ParameterType* types_array,
00236                                                         const EmApoxiUINT32* values_array,
00237                                                         EmApoxiUINT8 array_count) ;
00238
00259          EmApoxiCodecManager::ResultType GetParameters( const ParameterType* types_array,
00260                                                         EmApoxiUINT32* values_array,
00261                                                         EmApoxiUINT8 array_count) ;
00292          EmApoxiCodecManager::ResultType Start( const EmApoxiUINT8* config_stream,
00293                                                 EmApoxiUINT32& config_len,
00294                                                 const EmApoxiCodecManager::VideoDecoderParameters& params,
00295                                                 EmApoxiCodecManager::VideoStreamInfo& stream_info) ;
00296
00302          void Stop() ;
00303
00304         EmApoxiVideoDecoder();
00305
00306         ~EmApoxiVideoDecoder();
00307
00308     private:
00310         EmApoxiVideoDecoder(const EmApoxiVideoDecoder& decoder) {}
00311
00313         EmApoxiVideoDecoder& operator=(const EmApoxiVideoDecoder& decoder) { }
00314
00315         VideoDecoder*   m_VideoDecoder;
00316
00317         CbFrameDecoded m_DecodeCbFxn;
00318
00319         CbInBufferFree m_InBufFreeCb;
00320
00321         void *m_Context;
00322
00323         friend void sEmApoxiVideoDecoderFrameDecodedCb(int result,
00324                                                     void* context,
00325                                             void *out_buf,
00326                                             unsigned int time_stamp);
00327         friend void sEmApoxiInBufFreeCb(void* context,void* in_buf);
00328
00329
00330 };
00331
00333 #endif
00334 #endif // Apoxi_CodecManager_hpp
00335
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDefines.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDefines.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiVideoDefines_hpp

Define Documentation

#define EmApoxiVideoDefines_hpp

Generated on Tue Jan 24 16:37:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDefines.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoDefines.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(EmApoxiVideoDefines_hpp)
00009 #define EmApoxiVideoDefines_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00011
00012 #include "EmApoxiDataTypes.hpp"
00013
00014 #define EMAPOXI_VGA_SIZE_X              640       // X size.
00015 #define EMAPOXI_VGA_SIZE_Y              480       // Y size.
00016 #define EMAPOXI_CIF_SIZE_X              352       // X size.
00017 #define EMAPOXI_CIF_SIZE_Y              288       // Y size.
00018 #define EMAPOXI_QVGA_SIZE_X             320       // X size.
00019 #define EMAPOXI_QVGA_SIZE_Y             240       // Y size.
00020 #define EMAPOXI_QCIF_SIZE_X             176       // X size.
00021 #define EMAPOXI_QCIF_SIZE_Y             144       // Y size.
00022 #define EMAPOXI_QQVGA_SIZE_X            160       // X size.
00023 #define EMAPOXI_QQVGA_SIZE_Y            120       // Y size.
00024 #define EMAPOXI_QQCIF_SIZE_X             88       // X size.
00025 #define EMAPOXI_QQCIF_SIZE_Y             72       // Y size.
00026 #define EMAPOXI_SQCIF_SIZE_X            128       // X size.
00027 #define EMAPOXI_SQCIF_SIZE_Y             96       // Y size.
00028 #define EMAPOXI_QSIF_SIZE_X             176       // X size.
00029 #define EMAPOXI_QSIF_SIZE_Y             112       // Y size.
00030 #define EMAPOXI_QSIFSP_SIZE_X           160       // X size.
00031 #define EMAPOXI_QSIFSP_SIZE_Y           112       // Y size.
00032
00033
00034 // Camera Brightness and Contrast Defines.
00035 #define EMAPOXI_CAM_BRIGHTNESS_MAX      10
00036 #define EMAPOXI_CAM_BRIGHTNESS_MIN      0
00037 #define EMAPOXI_CAM_CONTRAST_MAX        10
00038 #define EMAPOXI_CAM_CONTRAST_MIN        0
00039
00040 // LCD Contrast Defines.
00041 #define EMAPOXI_LCD_CONTRAST_MAX        10
00042 #define EMAPOXI_LCD_CONTRAST_MIN        0
00043
00044 typedef enum {
00045     EmApoxiCameraImageFormat_CIF        = 0,    //  GDD_CAM_CIF_FORMAT         = 0,
00046     EmApoxiCameraImageFormat_QCIF       = 1,    //  GDD_CAM_QCIF_FORMAT        = 1,
00047     EmApoxiCameraImageFormat_QQCIF      = 2,    //  GDD_CAM_QQCIF_FORMAT       = 2,
00048     EmApoxiCameraImageFormat_VGA        = 3,    //  GDD_CAM_VGA_FORMAT         = 3,
00049     EmApoxiCameraImageFormat_QVGA       = 4,    //  GDD_CAM_QVGA_FORMAT        = 4,
00050     EmApoxiCameraImageFormat_QQVGA      = 5,    //  GDD_CAM_QQVGA_FORMAT       = 5,
00051     EmApoxiCameraImageFormat_SQCIF      = 6,    //  GDD_CAM_SQCIF_FORMAT       = 6,
00052     EmApoxiCameraImageFormat_QSIF       = 7,    //  GDD_CAM_QSIF_FORMAT        = 7,
00053     EmApoxiCameraImageFormat_QSIFSP     = 8,    //  GDD_CAM_QSIFSP_FORMAT      = 8,
00054     EmApoxiCameraImageFormat_Count      = 9     //  GDD_CAM_NOF_IMAGE_FORMATS  = 9
00055 }tEmApoxiCameraImageFormat;
00056
00057 typedef enum {
00058     EmApoxiYUYVYUYV,    //  GDD_YUYVYUYV,
00059     EmApoxiRGB          //  GDD_RGB
00060 }tEmApoxiVideoDataFormat;
00061
00062 typedef enum {
00063     EmApoxiFPS_7_5,
00064     EmApoxiFPS_15
00065 } tEmApoxiCameraFrameRate;
00066
00067 typedef enum {
00068     EmApoxiLCDParamsContrast,
00069     EmApoxiLCDParamsCount
00070 }tEmApoxiLCDParams;
00071
00072 typedef enum {
00073     EmApoxiCameraParamsContrast,
00074     EmApoxiCameraParamsBrightness,
00075     EmApoxiCameraParamsNightMode,
00076     EmApoxiCameraParamsZoom,
00077     EmApoxiCameraParamsCount
00078 }tEmApoxiCameraParams;
00079
00080 typedef void * tEmApoxiContext;
00081
00082 typedef struct {
00083     EmApoxiUINT16 left;
00084     EmApoxiUINT16 top;
00085     EmApoxiUINT16 right;
00086     EmApoxiUINT16 bottom;
00087 } tEmApoxiVideoRect;
00088
00089 #endif // DOXYGEN_SHOULD_SKIP_THIS
00090 #endif //EmApoxiVideoDefines_hpp
00091
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoEncoder.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoEncoder.cpp File Reference

#include "EmApoxiCodecManager.hpp"
#include "EmApoxiVideoEncoder.hpp"
#include "EmApoxiCodecUtils.hpp"
#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoEncoder.hpp>

Include dependency graph for EmApoxiVideoEncoder.cpp:

Functions

void sEmApoxiVideoEncoderFrameEncodedCb (EmApoxiINT32 result, void *context, void *out_buf, EmApoxiUINT32 out_buf_len, EmApoxiINT32 frame_coding_type)

Function Documentation

void sEmApoxiVideoEncoderFrameEncodedCb | ( | EmApoxiINT32 | result,
 |  | void * | context,
 |  | void * | out_buf,
 |  | EmApoxiUINT32 | out_buf_len,
 |  | EmApoxiINT32 | frame_coding_type
 | ) |

Generated on Tue Jan 24 16:37:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoEncoder.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoEncoder.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiVideoEncoderhpp

Define Documentation

#define EmApoxiVideoEncoderhpp

Generated on Tue Jan 24 16:37:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoEncoder.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiVideoEncoderhpp)
00010 #define EmApoxiVideoEncoderhpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiDataTypes.hpp"
00019 class VideoEncoder;
00020
00026 class EmApoxiVideoEncoder {
00027     public:
00028
00031         enum ParameterType {
00033             BitRate,
00037             MaxOutputBufferLength,
00040             InputFrameLength,
00047             FrameRateNumerator,
00054             FrameRateDenominator,
00064             QualityLevel,
00069             ConfigStreamLength,
00070             EndOfParameterType
00071         };
00072
00074         enum FrameCodingType {
00075             IFrame,
00076             PFrame,
00077             EndOfFrameCodingType
00078         };
00079
00096         typedef void (*CbFrameEncoded)( EmApoxiCodecManager::ResultType result,
00097                                         void* context,
00098                                         EmApoxiUINT8 HUGE* out_buf,
00099                                         EmApoxiUINT32 out_buf_len,
00100                                         FrameCodingType frame_type);
00101
00122         EmApoxiCodecManager::ResultType AllocateOutputBuffers(
00123                                                     EmApoxiUINT8 HUGE** &out_buf_array,
00124                                                     EmApoxiUINT8& out_buf_count,
00125                                                     EmApoxiUINT32& out_buf_len) ;
00126
00140         EmApoxiCodecManager::ResultType RegisterCallbackFunctions(
00141                                         void* context,
00142                                         CbFrameEncoded cb_frame_encoded);
00143
00169         EmApoxiCodecManager::ResultType EncodeFrame(EmApoxiUINT8 HUGE* in_buf,
00170                                                     EmApoxiUINT32 time_stamp,
00171                                                     EmApoxiUINT32 key_frame_ind,
00172                                                     EmApoxiUINT8 HUGE* out_buf);
00173
00191         EmApoxiCodecManager::ResultType SetParameters(  const ParameterType* types_array,
00192                                                         const EmApoxiUINT32* values_array,
00193                                                         EmApoxiUINT8 array_count);
00194
00215         EmApoxiCodecManager::ResultType GetParameters(  const ParameterType* types_array,
00216                                                         EmApoxiUINT32* values_array,
00217                                                         EmApoxiUINT8 array_count);
00218
00233         EmApoxiCodecManager::ResultType GetConfigStream(EmApoxiUINT8 HUGE* out_buf,
00234                                                             EmApoxiUINT32& out_buf_len);
00235
00244         EmApoxiCodecManager::ResultType AssignCaptureBufferPool(
00245                                                 EmApoxiUINT32 buf_pool_handle);
00246
00247         EmApoxiCodecManager::ResultType StartVideoEncoder(const EmApoxiCodecManager::VideoEncoderParameters& params,
00248                                         EmApoxiCodecManager::VideoEncoderInfo& enc_info);
00249         void Stop();
00250
00251         EmApoxiVideoEncoder();
00252
00253         ~EmApoxiVideoEncoder();
00254
00255     private:
00257         EmApoxiVideoEncoder(const EmApoxiVideoEncoder& encoder) {}
00258
00260         EmApoxiVideoEncoder& operator=(const EmApoxiVideoEncoder& encoder) { }
00261
00262         VideoEncoder    *m_VideoEncoder;
00263
00264         CbFrameEncoded m_EncodeCbFxn;
00265
00266         void *m_Context;
00267
00268         friend void sEmApoxiVideoEncoderFrameEncodedCb(EmApoxiINT32 result,
00269                                                     void* context,
00270                                                     void *out_buf,
00271                                                     EmApoxiUINT32 out_buf_len,
00272                                                     EmApoxiINT32 frame_coding_type);
00273
00274
00275 };
00276
00278 #endif
00279 #endif // Apoxi_CodecManager_hpp
00280
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoRenderer.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoRenderer.cpp File Reference

#include <Kernel/Lib.hpp>
#include <Kernel/Timer.hpp>
#include "EmApoxiDataTypes.hpp"
#include "EmApoxiVideoRendererExp.hpp"
#include "EmApoxiVideoUtils.hpp"

Include dependency graph for EmApoxiVideoRenderer.cpp:

Typedefs

typedef tEmApoxiVideoRenderer | EmApoxiVideoRenderer

Functions

void | CbplaybackRenderFrame (EmApoxiINT result, void *context, EmApoxiUINT8 *src)
EmApoxiVideoRendererHandle | EmApoxiVideoRendererCreate (tEmApoxiVideoRect display_rect, tEmApoxiVideoDataFormat video_data_format, tEmApoxiCameraImageFormat image_format, tEmApoxiContext context, tFrameRenderCallback fp_frame_render_callback)
void | EmApoxiVideoRendererDelete (EmApoxiVideoRendererHandle video_renderer)
EmApoxiBOOLEAN | EmApoxiVideoRendererDisable (EmApoxiVideoRendererHandle video_renderer)
EmApoxiBOOLEAN | EmApoxiVideoRendererEnable (EmApoxiVideoRendererHandle video_renderer)
EmApoxiBOOLEAN | EmApoxiVideoRendererRenderFrame (EmApoxiVideoRendererHandle video_renderer, EmApoxiUINT8 *p_frame_buffer, EmApoxiUINT32 buffer_length)
EmApoxiBOOLEAN | EmApoxiVideoRendererSetImageFormat (EmApoxiVideoRendererHandle video_renderer, tEmApoxiCameraImageFormat image_format)
EmApoxiUINT32 | EmApoxiVideoRendererSetLCDParams (EmApoxiVideoRendererHandle video_renderer, tEmApoxiLCDParams lcd_param, EmApoxiUINT32 param_value)
EmApoxiBOOLEAN | EmApoxiVideoRendererSetRectangle (EmApoxiVideoRendererHandle video_renderer, tEmApoxiVideoRect display_rect)

Typedef Documentation

typedef struct tEmApoxiVideoRenderer EmApoxiVideoRenderer

Function Documentation

void CbplaybackRenderFrame | ( | EmApoxiINT | result,
 |  | void * | context,
 |  | EmApoxiUINT8 * | src
 | ) |

EmApoxiVideoRendererHandle EmApoxiVideoRendererCreate | ( | tEmApoxiVideoRect | display_rect,
 |  | tEmApoxiVideoDataFormat | video_data_format,
 |  | tEmApoxiCameraImageFormat | image_format,
 |  | tEmApoxiContext | context,
 |  | tFrameRenderCallback | fp_frame_render_callback
 | ) |

void EmApoxiVideoRendererDelete ( EmApoxiVideoRendererHandle video_renderer )

EmApoxiBOOLEAN EmApoxiVideoRendererDisable ( EmApoxiVideoRendererHandle video_renderer )

EmApoxiBOOLEAN EmApoxiVideoRendererEnable ( EmApoxiVideoRendererHandle video_renderer )

EmApoxiBOOLEAN EmApoxiVideoRendererRenderFrame | ( | EmApoxiVideoRendererHandle | video_renderer,
 |  | EmApoxiUINT8 * | p_frame_buffer,
 |  | EmApoxiUINT32 | buffer_length
 | ) |

EmApoxiBOOLEAN EmApoxiVideoRendererSetImageFormat | ( | EmApoxiVideoRendererHandle | video_renderer,
 |  | tEmApoxiCameraImageFormat | image_format
 | ) |

EmApoxiUINT32 EmApoxiVideoRendererSetLCDParams | ( | EmApoxiVideoRendererHandle | video_renderer,
 |  | tEmApoxiLCDParams | lcd_param,
 |  | EmApoxiUINT32 | param_value
 | ) |

EmApoxiBOOLEAN EmApoxiVideoRendererSetRectangle | ( | EmApoxiVideoRendererHandle | video_renderer,
 |  | tEmApoxiVideoRect | display_rect
 | ) |

Generated on Tue Jan 24 16:37:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoRendererExp.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoRendererExp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiVideoRendererExp_hpp

Define Documentation

#define EmApoxiVideoRendererExp_hpp

Generated on Tue Jan 24 16:37:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoRendererExp.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoRendererExp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiVideoRendererExp_hpp)
00010 #define EmApoxiVideoRendererExp_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiVideoDefines.hpp"
00018
00019 typedef void* EmApoxiVideoRendererHandle;
00020 typedef void (*tFrameRenderCallback)(EmApoxiUINT32 aResultCode,void *aContext,EmApoxiUINT8* aSrc);
00021 typedef void (*tCallback)(EmApoxiUINT32 aResultCode);
00022
00036 EmApoxiVideoRendererHandle EmApoxiVideoRendererCreate(
00037                     tEmApoxiVideoRect       display_rect,
00038                     tEmApoxiVideoDataFormat video_data_format,
00039                     tEmApoxiCameraImageFormat       image_format,
00040                     tEmApoxiContext         context,
00041                     tFrameRenderCallback    fp_frame_render_callback );
00042
00047 void EmApoxiVideoRendererDelete(
00048                     EmApoxiVideoRendererHandle video_renderer);
00049
00056 EmApoxiBOOLEAN EmApoxiVideoRendererEnable(
00057                     EmApoxiVideoRendererHandle video_renderer);
00058
00065 EmApoxiBOOLEAN EmApoxiVideoRendererDisable(
00066                     EmApoxiVideoRendererHandle video_renderer);
00067
00074 EmApoxiBOOLEAN EmApoxiVideoRendererSetImageFormat(
00075                     EmApoxiVideoRendererHandle video_renderer,
00076                     tEmApoxiCameraImageFormat image_format );
00077
00084 EmApoxiBOOLEAN EmApoxiVideoRendererSetRectangle(
00085                     EmApoxiVideoRendererHandle video_renderer,
00086                     tEmApoxiVideoRect display_rect );
00087
00094 EmApoxiBOOLEAN EmApoxiVideoRendererRenderFrame(
00095                     EmApoxiVideoRendererHandle video_renderer,
00096                     EmApoxiUINT8* p_frame_buffer,
00097                     EmApoxiUINT32 buffer_length);
00098
00105 EmApoxiUINT32 EmApoxiVideoRendererSetLCDParams (
00106                     EmApoxiVideoRendererHandle video_renderer,
00107                     tEmApoxiLCDParams   lcd_param,
00108                     EmApoxiUINT32       param_value );
00109
00110 #endif // DOXYGEN_SHOULD_SKIP_THIS
00111 #endif //EmApoxiVideoRendererExp_hpp
00112
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoUtils.cpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoUtils.cpp File Reference

#include <Kernel/Lib.hpp>
#include "EmApoxiVideoDefines.hpp"
#include "EmApoxiVideoUtils.hpp"

Include dependency graph for EmApoxiVideoUtils.cpp:

Functions

VideoCamera::ActionType | EmApoxiTranslate (EmApoxiActionType action_type)
VideoCamera::CameraError | EmApoxiTranslate (EmApoxiCameraError camera_error)
VideoCamera::FrameRateType | EmApoxiTranslate (EmApoxiFrameRateType frame_rate)
Camera::ImageSizeType | EmApoxiTranslate (EmApoxiImageSizeType image_size)
Camera::TwilightType | EmApoxiTranslate (EmApoxiTwilightType twilight_mode)
gdd_cam_fps_type | GDDCameraFrameRate (tEmApoxiCameraFrameRate camera_frame_rate)
gdd_cam_image_format_type | GDDCameraImageFormatType (tEmApoxiCameraImageFormat cam_image_format)
gdd_video_data_format_type | GDDVideoDataFormatType (tEmApoxiVideoDataFormat video_data_format)

Function Documentation

VideoCamera::ActionType EmApoxiTranslate ( EmApoxiActionType action_type )

VideoCamera::CameraError EmApoxiTranslate ( EmApoxiCameraError camera_error )

VideoCamera::FrameRateType EmApoxiTranslate ( EmApoxiFrameRateType frame_rate )

Camera::ImageSizeType EmApoxiTranslate ( EmApoxiImageSizeType image_size )

Camera::TwilightType EmApoxiTranslate ( EmApoxiTwilightType twilight_mode )

gdd_cam_fps_type GDDCameraFrameRate ( tEmApoxiCameraFrameRate camera_frame_rate )

gdd_cam_image_format_type GDDCameraImageFormatType ( tEmApoxiCameraImageFormat cam_image_format )

gdd_video_data_format_type GDDVideoDataFormatType ( tEmApoxiVideoDataFormat video_data_format )

Generated on Tue Jan 24 16:37:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoUtils.hpp File Reference

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoUtils.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiVideoUtils_hpp

Define Documentation

#define EmApoxiVideoUtils_hpp

Generated on Tue Jan 24 16:37:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoUtils.hpp Source File

AddOns/MediaFramework/ApoxiDeviceLayer/EmApoxiVideoUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiVideoUtils_hpp)
00010 #define EmApoxiVideoUtils_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012
00013 #include "EmApoxiVideoDefines.hpp"
00014 #include "EmApoxiVideoCaptureExp.hpp"
00015
00016 /*
00017 ********************IMPORTANT*********************************************
00018 This EmApoxiLayer HPP should not be included by any of the
00019 components as it has VideoCamera's enums.
00020 **************************************************************************
00021 */
00022
00023 gdd_cam_image_format_type GDDCameraImageFormatType (
00024                         tEmApoxiCameraImageFormat cam_image_format );
00025
00026 gdd_video_data_format_type GDDVideoDataFormatType (
00027                         tEmApoxiVideoDataFormat video_data_format);
00028
00029 gdd_cam_fps_type GDDCameraFrameRate (
00030                         tEmApoxiCameraFrameRate camera_frame_rate);
00031
00032 Camera::TwilightType EmApoxiTranslate(EmApoxiTwilightType twilight_mode);
00033 Camera::ImageSizeType EmApoxiTranslate(EmApoxiImageSizeType image_size);
00034 VideoCamera::CameraError EmApoxiTranslate(EmApoxiCameraError camera_error);
00035 VideoCamera::ActionType EmApoxiTranslate(EmApoxiActionType action_type);
00036 VideoCamera::FrameRateType EmApoxiTranslate(EmApoxiFrameRateType frame_rate);
00037
00038
00039 #endif // DOXYGEN_SHOULD_SKIP_THIS
00040 #endif //EmApoxiVideoUtils_hpp
00041
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiThread.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiThread.cpp File Reference

#include "EmApoxiSemaphore.hpp"
#include "EmApoxiAllocLogs.hpp"
#include "DerivedApoxiThread.hpp"

Include dependency graph for DerivedApoxiThread.cpp:

Generated on Tue Jan 24 16:37:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiThread.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiThread.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define DerivedApoxiThread_hpp

Define Documentation

#define DerivedApoxiThread_hpp

Generated on Tue Jan 24 16:37:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiThread.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (DerivedApoxiThread_hpp)
00010 #define DerivedApoxiThread_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include <Kernel/ServiceThread.hpp>
00018 #include "EmApoxiDataTypes.hpp"
00019
00020 class EmApoxiSemaphore;
00021
00022 class DerivedApoxiThread : public Thread
00023 {
00024
00025     public :
00026         DerivedApoxiThread(EmApoxiBOOLEAN* p_retValue=0);
00027
00028         ~DerivedApoxiThread();
00029
00031         virtual EmApoxiINT ThreadFn();
00032
00036         EmApoxiBOOLEAN ObtainSemaphore();
00037
00041         void ReleaseSemaphore();
00042
00045         void RegisterThreadFnPtr(EmApoxiINT ((*ap_ThreadFn)(void* )), void* context);
00046
00047     private:
00048         EmApoxiSemaphore *m_p_apoxi_semaphore;
00049         EmApoxiINT (*m_p_ThreadFn)(void* );
00050         void* m_p_context;
00051
00052 };
00053
00054 #endif // DOXYGEN_SHOULD_SKIP_THIS
00055 #endif //DerivedApoxiThread_hpp
00056
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiTimer.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiTimer.cpp File Reference

#include "DerivedApoxiTimer.hpp"

Include dependency graph for DerivedApoxiTimer.cpp:

Generated on Tue Jan 24 16:37:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiTimer.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiTimer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define DerivedApoxiTimer_hpp

Define Documentation

#define DerivedApoxiTimer_hpp

Generated on Tue Jan 24 16:38:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiTimer.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/DerivedApoxiTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (DerivedApoxiTimer_hpp)
00010 #define DerivedApoxiTimer_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include <Kernel/Types.hpp>
00018 #include <Kernel/Timer.hpp>
00019
00020 #include "EmApoxiDataTypes.hpp"
00021
00022 typedef EmApoxiINT (*EmApoxiTimerFunc)(void* context);
00023
00024 class DerivedApoxiTimer: public Timer
00025 {
00026     public:
00027         DerivedApoxiTimer();
00028
00029         ~DerivedApoxiTimer();
00033         virtual void OnTimer();
00034
00038         void RegisterTimerFunction(EmApoxiTimerFunc p_timer_function,void *context=0);
00039
00040     private:
00041         EmApoxiTimerFunc m_p_timer_function;
00042         void            *m_context;
00043
00044 };
00045
00046 #endif // DOXYGEN_SHOULD_SKIP_THIS
00047 #endif //DerivedApoxiTimer_hpp
00048
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiBinData.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiBinData.cpp File Reference

#include <Afs/Rfs/FileBinData.hpp>
#include <Auxiliary/BinData.hpp>
#include "EmApoxiBinData.hpp"

Include dependency graph for EmApoxiBinData.cpp:

Generated on Tue Jan 24 16:38:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiBinData.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiBinData.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiBinData_hpp

Define Documentation

#define EmApoxiBinData_hpp

Generated on Tue Jan 24 16:38:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiBinData.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiBinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiBinData_hpp)
00010 #define EmApoxiBinData_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00018 #include "EmApoxiDataTypes.hpp"
00019
00020 //Forward Declaration of APOXI class in EmApoxi Layer
00021 class BinData;
00022
00023 class EmApoxiBinData {
00024 public:
00025
00026         EmApoxiBinData(const BinData *p_bindata = 0);
00027
00028         ~EmApoxiBinData();
00029
00037         EmApoxiUINT32 Read(EmApoxiUINT32 idx, void *buffer, EmApoxiUINT32 nbytes);
00038
00041         EmApoxiUINT32 GetLength() ;
00042
00043 private:
00044
00046         BinData *m_p_bindata;
00047
00048 };
00049
00050 #endif // DOXYGEN_SHOULD_SKIP_THIS
00051 #endif //EmApoxiBinData_hpp
00052
00053
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataSink.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataSink.cpp File Reference

#include <Auxiliary/DataSink.hpp>
#include "EmApoxiDataSink.hpp"

Include dependency graph for EmApoxiDataSink.cpp:

Generated on Tue Jan 24 16:38:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataSink.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataSink.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiDataSink_hpp

Define Documentation

#define EmApoxiDataSink_hpp

Generated on Tue Jan 24 16:38:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataSink.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiDataSink_hpp)
00010 #define EmApoxiDataSink_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00018 #include "EmApoxiDataTypes.hpp"
00019
00020
00021 //Forward Declaration of APOXI enum in EmApoxi Layer
00022 class DataSink;
00023
00024
00025 class EmApoxiDataSink {
00026 public:
00027
00028         EmApoxiDataSink(void *p_sinkdata = 0);
00029
00030         ~EmApoxiDataSink();
00031
00038         EmApoxiUINT32 Write(EmApoxiUINT32  l_offset,
00039                             void *p_buffer,
00040                             EmApoxiUINT32  l_bytes_to_write );
00041
00047         EmApoxiUINT32 EmApoxiDataSink::Write( void *p_buffer,
00048                                       EmApoxiUINT32  l_bytes_to_write) ;
00049
00053         EmApoxiUINT32 GetLength();
00054
00055 private:
00056
00057         //A private member pointer to the APOXI class. "Pimple" method.
00058         DataSink *m_p_datasink;
00059
00060 };
00061 #endif // DOXYGEN_SHOULD_SKIP_THIS
00062 #endif //EmApoxiDataSink_hpp
00063
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataTypes.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiDataTypes_hpp

Define Documentation

#define EmApoxiDataTypes_hpp

Generated on Tue Jan 24 16:38:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataTypes.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiDataTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiDataTypes_hpp)
00010 #define EmApoxiDataTypes_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017 #include <Kernel/Types.hpp>
00018
00019 #define EmApoxiFALSE           0
00020 #define EmApoxiTRUE            !EmApoxiFALSE
00021
00022 typedef signed char          EmApoxiINT8 ;
00023 typedef unsigned char        EmApoxiUINT8;
00024 typedef short int            EmApoxiINT16;
00025 typedef unsigned short int   EmApoxiUINT16;
00026 typedef int                  EmApoxiINT32;
00027 typedef unsigned int         EmApoxiUINT32;
00028 typedef float                EmApoxiFLOAT;
00029 typedef double               EmApoxiDOUBLE;
00030 //typedef bool               EmApoxiBOOLEAN;
00031 typedef char                 EmApoxiBOOLEAN;
00032 typedef int                  EmApoxiINT;
00033 typedef unsigned int         EmApoxiUINT;
00034
00035 #define EmApoxi_SUCCESS            0
00036 #define EmApoxi_FAILURE            (-1)
00037
00038 #ifndef HUGE
00039 #define HUGE
00040 #endif
00041
00042
00043 #endif // DOXYGEN_SHOULD_SKIP_THIS
00044 #endif //EmApoxiDataTypes_hpp
00045
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiDisplaySettings.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiDisplaySettings.cpp File Reference

#include "EmApoxiDisplaySettings.hpp"

Include dependency graph for EmApoxiDisplaySettings.cpp:

Generated on Tue Jan 24 16:38:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiDisplaySettings.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiDisplaySettings.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiDisplaySettings_hpp

Define Documentation

#define EmApoxiDisplaySettings_hpp

Generated on Tue Jan 24 16:38:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiDisplaySettings.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiDisplaySettings.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiDisplaySettings_hpp)
00010 #define EmApoxiDisplaySettings_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018
00019 class DisplaySettings;
00020
00021 class EmApoxiDisplaySettings {
00022
00023     public:
00024         enum EmApoxiVideoQuality {
00025             EmApoxiLowQuality,
00026             EmApoxiMediumQuality,
00027             EmApoxiHighQuality
00028         };
00029
00033         enum EmApoxiScaleType {
00034             EmApoxiDownscaleToBounds,
00035             EmApoxiScaleToBounds,
00036         };
00037
00040         EmApoxiDisplaySettings(EmApoxiINT32 left, EmApoxiINT32 top, EmApoxiINT32 width, EmApoxiINT32 height);
00041
00043         ~EmApoxiDisplaySettings();
00044
00045         EmApoxiINT32  GetLeft() const { return m_left; }
00046
00047         EmApoxiINT32  GetTop() const { return m_top; }
00048
00049         EmApoxiINT32  GetWidth() const { return m_width; }
00050
00051         EmApoxiINT32  GetHeight() const { return m_height; }
00052
00053     private:
00054
00055         EmApoxiINT32  m_left;
00056
00057         EmApoxiINT32  m_top;
00058
00059         EmApoxiINT32  m_width;
00060
00061         EmApoxiINT32  m_height;
00062 };
00063
00064 #endif // DOXYGEN_SHOULD_SKIP_THIS
00065 #endif //EmApoxiDisplaySettings_hpp
00066
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMediaInfo.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMediaInfo.cpp File Reference

#include "MediaFramework/MediaInfo.hpp"
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiDataTypes.hpp"
#include "EmApoxiMediaInfo.hpp"

Include dependency graph for EmApoxiMediaInfo.cpp:

Defines

#define EmApoxiDELETE_ARRAY(X) if(X){EMAPOXI_DBG_FREE_LOG(X);delete[] (X); X = 0;}

Define Documentation

#define EmApoxiDELETE_ARRAY ( X ) if(X){EMAPOXI_DBG_FREE_LOG(X);delete[] (X); X = 0;}

Generated on Tue Jan 24 16:38:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMediaInfo.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMediaInfo.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiMediaInfo_hpp

Define Documentation

#define EmApoxiMediaInfo_hpp

Generated on Tue Jan 24 16:38:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMediaInfo.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMediaInfo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiMediaInfo_hpp)
00010 #define EmApoxiMediaInfo_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018
00020 class MediaInfo;
00021
00022 class EmApoxiMediaInfo
00023 {
00024
00025     public:
00026         enum EmApoxiMediaCodec {
00029             DefaultCodec,
00030             UnknownCodec,
00031             Mpeg4Sp,
00032             H263Bl,
00033             GsmAmrNb,
00034             Mpeg4Aac,
00035             Qcelp,
00036             Evrc,
00037             Mp3,
00038             Mpeg4AacPlusV1,
00039             Mpeg4AacPlusV2,
00040             H264Bp,
00041             EndOfCodecType
00042         };
00043
00044         class EmApoxiClipInfo {
00045             public:
00046                 void Init();
00047                 void DeInit();
00048                 /* Fields for 3gpp clip  */
00049                 EmApoxiUINT8*   m_p_title;
00050                 EmApoxiUINT8*   m_p_author;
00051                 EmApoxiUINT8*   m_p_copyright;
00052                 EmApoxiUINT8*   m_p_rating;
00053                 EmApoxiUINT8*   m_p_description;
00054
00055                 /* There are fields for Mp3 */
00056                 EmApoxiUINT16*  m_p_song_name;
00057                 EmApoxiUINT16* m_p_artist;
00058                 EmApoxiUINT16* m_p_album;
00059                 EmApoxiUINT16* m_p_year;
00060                 EmApoxiUINT16* m_p_comment;
00061                 EmApoxiUINT16* m_p_genre;
00062                 EmApoxiUINT16* m_p_track;
00063                 EmApoxiUINT16* m_p_duration;
00064                 EmApoxiUINT16* m_p_composer;
00065                 EmApoxiUINT16* m_p_original_artist;
00066                 EmApoxiUINT16* m_p_url;
00067                 EmApoxiClipInfo operator = (EmApoxiClipInfo);
00068
00069         };
00070
00071         class EmApoxiMediaTrackInfo {
00072             public:
00074                 EmApoxiMediaTrackInfo();
00075
00081                 EmApoxiMediaTrackInfo(EmApoxiMediaCodec codec_type, //needed???
00082                                 EmApoxiUINT32 duration,
00083                                 EmApoxiUINT32 track_id,
00084                                 EmApoxiUINT32 bitrate = 0);
00085
00087                 EmApoxiMediaCodec GetMediaCodec() const {return m_codec_type;}
00088
00090                 EmApoxiUINT32 GetDuration() const {return m_duration;}
00091
00093                 EmApoxiUINT32 GetTrackId() const {return m_track_id;}
00094
00096                 EmApoxiUINT32 GetBitrate() const {return m_bitrate;}
00097
00098             protected: // or private???
00100                 EmApoxiMediaCodec m_codec_type;
00102                 EmApoxiUINT32 m_duration;
00104                 EmApoxiUINT32 m_track_id;
00106                 EmApoxiUINT32 m_bitrate;
00107
00108         };
00109
00111         class EmApoxiAudioTrackInfo : public EmApoxiMediaTrackInfo {
00112             public:
00114                 EmApoxiAudioTrackInfo();
00115
00123                 EmApoxiAudioTrackInfo(EmApoxiMediaCodec codec_type, //needed???
00124                                 EmApoxiUINT32 duration,
00125                                 EmApoxiUINT32 track_id,
00126                                 EmApoxiUINT16 sample_freq, //needed???
00127                                 EmApoxiUINT16 channel_cnt, //needed???
00128                                 EmApoxiUINT32 bitrate = 0);
00129
00131                 EmApoxiUINT16 GetSampleFreq() const {return m_sample_freq;}
00132
00134                 EmApoxiUINT16 GetNumberOfChannels() const {return m_channel_cnt;}
00135
00136             private:
00138                 EmApoxiUINT16 m_sample_freq;
00140                 EmApoxiUINT16 m_channel_cnt;
00141         };
00142         class EmApoxiVideoTrackInfo : public EmApoxiMediaTrackInfo {
00143             public:
00145                 EmApoxiVideoTrackInfo();
00146
00155                 EmApoxiVideoTrackInfo(EmApoxiMediaCodec codec_type, // needed???
00156                                 EmApoxiUINT32 duration,
00157                                 EmApoxiUINT32 track_id,
00158                                 EmApoxiUINT16 m_width,
00159                                 EmApoxiUINT16 m_height,
00160                                 EmApoxiUINT32 bitrate = 0);
00161
00163                 EmApoxiUINT16 GetWidth() const {return m_width;}
00164
00166                 EmApoxiUINT16 GetHeight() const {return m_height;}
00167
00168             private:
00170                 EmApoxiUINT16 m_width;
00172                 EmApoxiUINT16 m_height;
00173         };
00174
00175         EmApoxiMediaInfo(MediaInfo *p_mediainfo = 0);
00176         ~EmApoxiMediaInfo();
00177
00178
00186         EmApoxiBOOLEAN AddAudioInfo(const EmApoxiAudioTrackInfo& info);
00187
00195         EmApoxiBOOLEAN AddVideoInfo(const EmApoxiVideoTrackInfo& info);
00196
00199         EmApoxiINT GetAudioInfoCount() const;
00200
00203         EmApoxiINT GetVideoInfoCount() const;
00204
00211         const EmApoxiAudioTrackInfo* GetAudioInfo(EmApoxiINT index) const;
00212
00219         const EmApoxiVideoTrackInfo* GetVideoInfo(EmApoxiINT index) const;
00220
00224         EmApoxiBOOLEAN SetClipInfo(EmApoxiUINT8 *title,
00225                                     EmApoxiUINT8 *author,
00226                                     EmApoxiUINT8 *copyright,
00227                                     EmApoxiUINT8 *rating,
00228                                     EmApoxiUINT8 *description);
00229
00233         EmApoxiBOOLEAN EmApoxiMediaInfo::SetClipInfo(EmApoxiClipInfo & clip_info);
00234
00237     //  const EmApoxiClipInfo& GetClipInfo() const { return m_clip_info; }
00238
00239
00240         EmApoxiBOOLEAN ReInit();
00241
00242
00243
00244     private:
00245
00246         /* Pimple Pointer */
00247         MediaInfo*                  m_p_mediainfo;
00248
00249 };
00250
00251 #endif // DOXYGEN_SHOULD_SKIP_THIS
00252 #endif //EmApoxiMediaInfo_hpp
00253
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMimeTypeTable.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMimeTypeTable.cpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include "EmApoxiMimeTypeTable.hpp"

Include dependency graph for EmApoxiMimeTypeTable.cpp:

Functions

EmApoxiMimeType TranslateMimeType (EmApoxiUINT32 media_mime_type)

Function Documentation

EmApoxiMimeType TranslateMimeType ( EmApoxiUINT32 media_mime_type )

Generated on Tue Jan 24 16:38:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMimeTypeTable.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMimeTypeTable.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiMimeTypeTable_hpp

Define Documentation

#define EmApoxiMimeTypeTable_hpp

Generated on Tue Jan 24 16:38:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMimeTypeTable.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMimeTypeTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiMimeTypeTable_hpp)
00010 #define EmApoxiMimeTypeTable_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018
00023 enum EmApoxiMimeType {
00024         EmApoxiMimeAudioRawAac,
00025         EmApoxiMimeAudioMpeg,
00026         EmApoxiMimeVideo3gpp,
00027         EmApoxiMimeAudio3gpp,
00028         EmApoxiMimeUnknown
00029  };
00030
00031 EmApoxiMimeType TranslateMimeType(EmApoxiUINT32 media_mime_type);
00032
00033 #endif // DOXYGEN_SHOULD_SKIP_THIS
00034 #endif  //EmApoxiMimeTypeTable_hpp
00035
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMsgDispatcher.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMsgDispatcher.cpp File Reference

#include <Kernel/Lib.hpp>
#include <MediaFramework/MsgTypes.hpp>
#include <MediaFramework/MediaManager.hpp>
#include "EmApoxiServiceThread.hpp"
#include "EmServThreadMsg.hpp"
#include "EmApoxiMsgDispatcher.hpp"

Include dependency graph for EmApoxiMsgDispatcher.cpp:

Functions

void | EmApoxiPostMessageToServiceThread (tEmApxAudDeviceHdl m_h_aud_device, tCallbackFnPtr m_cb_fn_ptr, void *m_cb_data, EmApoxiBOOLEAN m_is_audio_muted, EmApoxiBOOLEAN m_start_stop_audio)
void | SendMessageToDispatcherToApp (EmApoxiMmfMsgType msg_type, void *m_p_msgdispatcher, void *instance, EmApoxiMmfResult mmf_result)

Function Documentation

void EmApoxiPostMessageToServiceThread | ( | tEmApxAudDeviceHdl | m_h_aud_device,
 |  | tCallbackFnPtr | m_cb_fn_ptr,
 |  | void * | m_cb_data,
 |  | EmApoxiBOOLEAN | m_is_audio_muted,
 |  | EmApoxiBOOLEAN | m_start_stop_audio
 | ) |

void SendMessageToDispatcherToApp | ( | EmApoxiMmfMsgType | msg_type,
 |  | void * | m_p_msgdispatcher,
 |  | void * | instance,
 |  | EmApoxiMmfResult | mmf_result
 | ) |

Generated on Tue Jan 24 16:38:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMsgDispatcher.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMsgDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiMsgDispatcher_hpp

Define Documentation

#define EmApoxiMsgDispatcher_hpp

Generated on Tue Jan 24 16:38:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMsgDispatcher.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMsgDispatcher.hpp

Go to the documentation of this file.
00001 /*
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008 #if !defined (EmApoxiMsgDispatcher_hpp)
00009 #define EmApoxiMsgDispatcher_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00011 /*
00012     This is an internal class which should not be used by the MMI in a direct
00013     manner, and the interface may be changed in future releases.
00014 */
00015 #ifdef ENABLE_STREAMING
00016 #include "EmApoxiInterface.hpp"
00017 #endif
00018
00019 #include "EmApoxiAudioDeviceImpl.hpp"
00020 #include "EmApoxiPlayerEnum.hpp"
00021
00022 typedef EmApoxiUINT32 (*tCallbackFnPtr)(EmApoxiUINT32);
00023
00028 void SendMessageToDispatcherToApp(EmApoxiMmfMsgType msg_type,
00029                                   void *m_p_msgdispatcher,
00030                                   void* instance,
00031                                   EmApoxiMmfResult mmf_result = EmApoxiSuccess
00032                                   );
00033
00034 void EmApoxiPostMessageToServiceThread(tEmApxAudDeviceHdl  m_h_aud_device,
00035                                        tCallbackFnPtr      m_cb_fn_ptr,
00036                                        void*               m_cb_data,
00037                                        EmApoxiBOOLEAN      m_is_audio_muted,
00038                                        EmApoxiBOOLEAN      m_start_stop_audio);
00039
00040 #ifdef ENABLE_STREAMING
00041 void EmApoxiPostMessageToNetworkServiceThread(
00042     EmNetworkServiceThreadMsgType msg_type,
00043     EmNetworkExecCbFn *ap_cb_fn,
00044     void *ap_cb_fn_user_data);
00045 #endif
00046
00047 #endif // DOXYGEN_SHOULD_SKIP_THIS
00048 #endif  //EmApoxiMsgDispatcher_hpp
00049
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutex.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutex.cpp File Reference

#include <Kernel/Lib.hpp>
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiMutex.hpp"

Include dependency graph for EmApoxiMutex.cpp:

Generated on Tue Jan 24 16:38:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutex.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutex.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiMutex_hpp

Define Documentation

#define EmApoxiMutex_hpp

Generated on Tue Jan 24 16:38:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutex.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutex.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined (EmApoxiMutex_hpp)
00011 #define EmApoxiMutex_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiDataTypes.hpp"
00019
00020 //Forward Declaration of APOXI class in EmApoxi Layer
00021 class Mutex;
00022
00023
00024 class EmApoxiMutex {
00025     public:
00026
00027         EmApoxiMutex(EmApoxiINT32* l_p_result);
00028
00029         ~EmApoxiMutex();
00030
00035         EmApoxiBOOLEAN Create(EmApoxiBOOLEAN locked = EmApoxiTRUE);
00036
00040         EmApoxiBOOLEAN Obtain();
00041
00045         void Release();
00046     private:
00047
00049         Mutex *m_p_mutex;
00050
00051     friend class EmApoxiMutexObtainer;
00052
00053 };
00054
00055 #endif // DOXYGEN_SHOULD_SKIP_THIS
00056 #endif  //EmApoxiMutex_hpp
00057
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutexObtainer.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutexObtainer.cpp File Reference

#include <Kernel/Lib.hpp>
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiMutexObtainer.hpp"

Include dependency graph for EmApoxiMutexObtainer.cpp:

Generated on Tue Jan 24 16:38:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutexObtainer.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutexObtainer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiMutexObtainer_hpp

Define Documentation

#define EmApoxiMutexObtainer_hpp

Generated on Tue Jan 24 16:38:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutexObtainer.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiMutexObtainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined (EmApoxiMutexObtainer_hpp)
00011 #define EmApoxiMutexObtainer_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiDataTypes.hpp"
00019 #include "EmApoxiMutex.hpp"
00020
00021 //Forward Declaration of APOXI class in EmApoxi Layer
00022 class MutexObtainer;
00023
00024
00025 class EmApoxiMutexObtainer {
00026     public:
00027
00028     EmApoxiMutexObtainer(const EmApoxiMutex* mutex);
00029     ~EmApoxiMutexObtainer();
00030
00031     private:
00032
00034     MutexObtainer *m_p_mutex_obtainer;
00035
00036 };
00037
00038 #endif // DOXYGEN_SHOULD_SKIP_THIS
00039 #endif  //EmApoxiMutexObtainer
00040
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiOs.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiOs.cpp File Reference

#include <Kernel/Os/Os.hpp>
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiTicks.hpp"
#include "EmApoxiOs.hpp"

Include dependency graph for EmApoxiOs.cpp:

Functions

EmApoxiUINT32 EmApoxiFFS_get_raw_free_space_in_global_pool ()

Function Documentation

EmApoxiUINT32 EmApoxiFFS_get_raw_free_space_in_global_pool ( )

Generated on Tue Jan 24 16:38:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiOs.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiOs.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiOs_hpp

Define Documentation

#define EmApoxiOs_hpp

Generated on Tue Jan 24 16:38:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiOs.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiOs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiOs_hpp)
00010 #define EmApoxiOs_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018 #include "EmApoxiTicks.hpp"
00019
00020
00021 class EmApoxiTicks;
00022
00023
00024 class EmApoxiOs {
00025
00026     public:
00027         EmApoxiOs();
00028
00029         ~EmApoxiOs();
00030
00031         static EmApoxiTicks GetTicks();
00032
00036         static void Sleep(EmApoxiUINT32 timeout);
00037
00041         static void* Alloc(EmApoxiINT32 size, EmApoxiUINT32 heapid = 0 );
00042
00044         static void* Realloc(void* oldaddress, EmApoxiINT32 newsize,
00045                             EmApoxiBOOLEAN shallcopy = EmApoxiFALSE);
00046
00048         static void Free(void* p);
00049
00051         static void* HugeAlloc(EmApoxiUINT32 size, EmApoxiUINT32 heapid = 0 );
00052
00054         static void HugeFree(void* p);
00055
00056
00057
00058
00059 };
00060
00061 EmApoxiUINT32 EmApoxiFFS_get_raw_free_space_in_global_pool();
00062
00063 #endif // DOXYGEN_SHOULD_SKIP_THIS
00064 #endif // EmApoxiOs_hpp
00065
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiPlayerEnum.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiPlayerEnum.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiPlayerEnum_hpp

Define Documentation

#define EmApoxiPlayerEnum_hpp

Generated on Tue Jan 24 16:38:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiPlayerEnum.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiPlayerEnum.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008 #if !defined (EmApoxiPlayerEnum_hpp)
00009 #define EmApoxiPlayerEnum_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00011 /*
00012     This is an internal class which should not be used by the MMI in a direct
00013     manner, and the interface may be changed in future releases.
00014 */
00015
00016 enum EmApoxiMmfResult {
00018             EmApoxiSuccess,
00021             EmApoxiMediaTypeDifferent,
00023             EmApoxiMediaNotSupported,
00025             EmApoxiOutOfMemory,
00027             EmApoxiSmallBuffer,
00029             EmApoxiNullParameter,
00031             EmApoxiInvalidParameter,
00033             EmApoxiInvalidState,
00035             EmApoxiFeatureNotSupported,
00037             EmApoxiInvalidAudioTrack,
00039             EmApoxiInvalidVideoTrack,
00041             EmApoxiFileNotFound,
00043             EmApoxiEmptyFile,
00045             EmApoxiInvalid3gppFile,
00047             EmApoxiIncomplete3gppFile,
00049             EmApoxiOpenFileFailure,
00051             EmApoxiInvalidMp3File,
00053             EmApoxiCorruptMp3File,
00055             EmApoxiVidResNotSupported,
00057             EmApoxiAudSamplFreqNotSupported,
00058             // This FPS is not supported
00059             EmApoxiFpsNotSupported,
00061             EmApoxiNetworkErrConnErr,
00063             EmApoxiNetworkErrConnLostErr,
00065             EmApoxiNetworkErrConnectFailed,
00067             EmApoxiNetworkErrBandWidthTooHigh,
00069             EmApoxiNetworkErrUrlNotFound,
00071             EmApoxiNetworkErrUrlNotStreamable,
00073             EmApoxiNetworkErrSdpParseError,
00075             EmApoxiNetworkErrSdpFileOpenError,
00077             EmApoxiNetworkErrHTTPError,
00079             EmApoxiNetworkErrRtpDataError,
00081             EmApoxiNetworkErrUnknownServError,
00083             EmApoxiNetworkErrBufferingTimeoutError,
00085             EmApoxiGeneralError
00086         };
00087
00088         /* The Mmfr API completion messages are communicated to the upper layer
00089             through the message types mentioned below*/
00090         enum EmApoxiMmfMsgType {
00092             EmApoxiPauseApiCompletionMsg,
00094             EmApoxiPlayApiCompletionMsg,
00096             EmApoxiRecordApiCompletionMsg,
00098             EmApoxiRewindApiCompletionMsg,
00100             EmApoxiFastForwardApiCompletionMsg,
00102             EmApoxiStopApiCompletionMsg,
00104             EmApoxiInitCompletionMsg,
00106             EmApoxiUninitCompletionMsg,
00108             EmApoxiEofReachedMsg,
00110             EmApoxiCriticalErrorMsg,
00114             EmApoxiNetworkMsgRtcpByeReceived,
00116             EmApoxiBufferingStart,
00118             EmApoxiBufferingComplete,
00120             EmApoxiMediaInfoObtainedMsg,
00121             /* Message that communicates completion of destruction of first MediaPlayer */
00122             MediaPlayerDestroyed,
00123             /* Message that communicates completion of destruction of first MediaRecorder */
00124             MediaRecorderDestroyed,
00125
00126             /* This message is sent when a play is internally issued becuase of a repeat-count */
00127             EmApoxiPlayApiRepeatedMsg,
00128         };
00129
00130         enum EmApoxiMmfModeType {
00132             EmApoxiMmfModeUnspecific=0,
00134             EmApoxiMmfModePureAudio,
00136             EmApoxiMmfModeAudioVideo,
00138             EmApoxiMmfModeEnd
00139         };
00140
00141         enum EmApoxiPlayerState {
00142                 EmApoxiUnInitializedState,
00143                 EmApoxiInsideDefaultSelectMedia,
00144                 EmApoxiInitializedState,
00145                 EmApoxiPlayingState,
00146                 EmApoxiPausedState,
00147                 EmApoxiRewindingState,
00148                 EmApoxiFastForwardingState,
00149                 EmApoxiAwaitingPlayRespState,
00150                 EmApoxiAwaitingRewindRespState,
00151                 EmApoxiAwaitingFastForwardRespState,
00152                 EmApoxiAwaitingPauseRespState,
00153                 EmApoxiAwaitingStopRespState,
00154                 EmApoxiAwaitingInitResp,
00155                 EmApoxiEofProcessing,
00156                 EmApoxiBufferingCompleteState,
00157                 EmApoxiBufferingStartState,
00158                 EmApoxiErrorProcessing,
00159                 EmApoxiErrorState,
00160                 EmApoxiWaitingToDestroy,
00161
00162                 /* Impact of these states on streaming ?? */
00163                 EmApoxiReadyState,
00164                 EmApoxiEofReceivedState
00165
00166         };
00167
00168         enum EmApoxiTrackSelection {
00169                 EmApoxiAudioAndVideo,
00170                 EmApoxiAudioOnly,
00171                 EmApoxiVideoOnly
00172         };
00173
00174 #endif // DOXYGEN_SHOULD_SKIP_THIS
00175 #endif //EmApoxiPlayerEnum_hpp
00176
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecorderEnum.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecorderEnum.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiRecorderEnum_hpp

Define Documentation

#define EmApoxiRecorderEnum_hpp

Generated on Tue Jan 24 16:38:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecorderEnum.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecorderEnum.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008 #if !defined (EmApoxiRecorderEnum_hpp)
00009 #define EmApoxiRecorderEnum_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00011 /*
00012     This is an internal class which should not be used by the MMI in a direct
00013     manner, and the interface may be changed in future releases.
00014 */
00015
00016 /* The Rec Prefix to the states are added to avaoid clash with the Player enumeration */
00017         enum EmApoxiRecorderState {
00018             EmApoxiRecUnInitializedState = 0,
00019             EmApoxiRecInitalizedState,
00020             EmApoxiRecPreviewState,
00021             EmApoxiRecRecordingState,
00022             EmApoxiRecPausedState,
00023             EmApoxiRecAwaitingRecordRespState,
00024             EmApoxiRecAwaitingPauseRespState,
00025             EmApoxiRecAwaitingStopRespState,
00026             EmApoxiRecAwaitingInitResp,
00027             EmApoxiRecEofProcessing,
00028             EmApoxiRecErrorProcessing,
00029             EmApoxiRecErrorState,
00030             EmApoxiRecWaitingToDestroy
00031         };
00032
00033
00034 #endif // DOXYGEN_SHOULD_SKIP_THIS
00035 #endif //EmApoxiRecorderEnum_hpp
00036
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecordSettings.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecordSettings.cpp File Reference

#include "MediaFramework/RecordSettings.hpp"
#include "EmApoxiRecordSettings.hpp"

Include dependency graph for EmApoxiRecordSettings.cpp:

Defines

#define | EZD_DEFAULT_AUDIO_CODEC EmApoxiMediaInfo::GsmAmrNb
#define | EZD_DEFAULT_AUDIO_QUALITY EmApoxiRecordSettings::EmApoxiQualityLow
#define | EZD_DEFAULT_BRIGHTNESS 7
#define | EZD_DEFAULT_CAMERA_DEVICE_ID 0
#define | EZD_DEFAULT_CAMERA_HEIGHT 144
#define | EZD_DEFAULT_CAMERA_NIGHT_MODE EmApoxiFALSE
#define | EZD_DEFAULT_CAMERA_WIDTH 176
#define | EZD_DEFAULT_CONTRAST 5
#define | EZD_DEFAULT_DURATION 40 * 1000
#define | EZD_DEFAULT_FILE_SIZE 60 * 1024
#define | EZD_DEFAULT_FRAMERATE 15
#define | EZD_DEFAULT_SINK_TYPE EmApoxiFilePathname
#define | EZD_DEFAULT_VIDEO_CODEC EmApoxiMediaInfo::Mpeg4Sp
#define | EZD_DEFAULT_VIDEO_QUALITY EmApoxiRecordSettings::EmApoxiQualityLow
#define | MAX_FILE_NAME_LENGTH 80

Define Documentation

#define EZD_DEFAULT_AUDIO_CODEC EmApoxiMediaInfo::GsmAmrNb

#define EZD_DEFAULT_AUDIO_QUALITY EmApoxiRecordSettings::EmApoxiQualityLow

#define EZD_DEFAULT_BRIGHTNESS 7

#define EZD_DEFAULT_CAMERA_DEVICE_ID 0

#define EZD_DEFAULT_CAMERA_HEIGHT 144

#define EZD_DEFAULT_CAMERA_NIGHT_MODE EmApoxiFALSE

#define EZD_DEFAULT_CAMERA_WIDTH 176

#define EZD_DEFAULT_CONTRAST 5

#define EZD_DEFAULT_DURATION 40 * 1000

#define EZD_DEFAULT_FILE_SIZE 60 * 1024

#define EZD_DEFAULT_FRAMERATE 15

#define EZD_DEFAULT_SINK_TYPE EmApoxiFilePathname

#define EZD_DEFAULT_VIDEO_CODEC EmApoxiMediaInfo::Mpeg4Sp

#define EZD_DEFAULT_VIDEO_QUALITY EmApoxiRecordSettings::EmApoxiQualityLow

#define MAX_FILE_NAME_LENGTH 80

Generated on Tue Jan 24 16:38:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecordSettings.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecordSettings.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiRecordSettings_hpp

Define Documentation

#define EmApoxiRecordSettings_hpp

Generated on Tue Jan 24 16:38:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecordSettings.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiRecordSettings.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiRecordSettings_hpp)
00010 #define EmApoxiRecordSettings_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018 #include "EmApoxiPlayerEnum.hpp"
00019 #include "EmApoxiMediaInfo.hpp"
00020
00021 class RecordSettings;
00022
00023 class EmApoxiRecordSettings {
00024
00025 public:
00026
00027     enum EmApoxiMediaQuality {
00028             EmApoxiQualityLow = 1,
00029             EmApoxiQualityNormal,
00030             EmApoxiQualityHigh
00031     };
00032
00033     enum EmApoxiMediaSinkType {
00035             EmApoxiFilePathname,
00037             EmApoxiDataSink
00038     };
00039
00040
00041     EmApoxiRecordSettings();
00042
00043     EmApoxiRecordSettings (RecordSettings* p_settings);
00044
00045     ~EmApoxiRecordSettings();
00046
00047     const EmApoxiMediaSinkType GetMediaSinkType() const;
00048
00049     void SetMediaSinkType(EmApoxiMediaSinkType sink_type);
00050
00051     const void* GetMediaSink() const;
00052
00053     void SetMediaSink(void* media_sink);
00054
00055     const EmApoxiMediaInfo::EmApoxiMediaCodec GetVideoCodec() const;
00056
00057     const EmApoxiMediaInfo::EmApoxiMediaCodec GetAudioCodec() const;
00058
00059     void SetVideoCodec(EmApoxiMediaInfo::EmApoxiMediaCodec video_codec);
00060
00061     void SetAudioCodec(EmApoxiMediaInfo::EmApoxiMediaCodec audio_codec);
00062
00063     const EmApoxiINT GetContrast() const;
00064
00065     const EmApoxiINT GetBrightness() const;
00066
00067     const EmApoxiBOOLEAN GetCameraNightMode() const;
00068
00069     const EmApoxiUINT32 GetMaxFileSize() const;
00070
00071     void SetMaxFileSize(EmApoxiUINT32 max_file_size);
00072
00073     const EmApoxiUINT32 GetMaxRecordingDuration() const;
00074
00075     void SetMaxRecordingDuration(EmApoxiUINT32 max_recording_duration);
00076
00077     const EmApoxiMediaQuality GetVideoQuality() const;
00078
00079     const EmApoxiMediaQuality GetAudioQuality() const;
00080
00081     const EmApoxiINT GetFrameRate () const;
00082
00083     const EmApoxiUINT16 GetWidth () const;
00084
00085     const EmApoxiUINT16 GetHeight () const;
00086
00087     const EmApoxiUINT8 GetCameraDeviceId () const;
00088
00089 private:
00090     RecordSettings *m_p_record_setting;
00091 };
00092
00093 #endif // DOXYGEN_SHOULD_SKIP_THIS
00094 #endif //EmApoxiRecordSettings_hpp
00095
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiSemaphore.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiSemaphore.cpp File Reference

#include <Kernel/Lib.hpp>
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiSemaphore.hpp"

Include dependency graph for EmApoxiSemaphore.cpp:

Generated on Tue Jan 24 16:38:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiSemaphore.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiSemaphore.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiSemaphore_hpp

Define Documentation

#define EmApoxiSemaphore_hpp

Generated on Tue Jan 24 16:38:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiSemaphore.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiSemaphore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined (EmApoxiSemaphore_hpp)
00009 #define EmApoxiSemaphore_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00011 /*
00012     This is an internal class which should not be used by the MMI in a direct
00013     manner, and the interface may be changed in future releases.
00014 */
00015
00016 #include "EmApoxiDataTypes.hpp"
00017
00018 /* Forward Declaration for Apoxi Thread Class implementation using Pimple */
00019 class Semaphore;
00020
00021  class EmApoxiSemaphore  {
00022      public:
00023          EmApoxiSemaphore(EmApoxiINT32* l_p_result);
00024
00025          ~EmApoxiSemaphore();
00026
00039          EmApoxiBOOLEAN Create(EmApoxiINT init_val = 0,
00040                                 EmApoxiINT max_val = -1);
00041
00050          EmApoxiBOOLEAN Obtain();
00051
00055          void Release();
00056
00057      private:
00058          Semaphore *m_p_semaphore;
00059
00060  };
00061
00062 #endif // DOXYGEN_SHOULD_SKIP_THIS
00063 #endif  // EmApoxiSemaphore_hpp
00064
00065
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiServiceThread.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiServiceThread.cpp File Reference

#include <Kernel/Lib.hpp>
#include <Kernel/ServiceThreadStarter.hpp>
#include <Kernel/Timer.hpp>
#include <Kernel/MsgTypes.hpp>
#include "EmApoxiServiceThread.hpp"
#include "EmApoxiAudioDeviceImpl.hpp"

Include dependency graph for EmApoxiServiceThread.cpp:

Generated on Tue Jan 24 16:38:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiServiceThread.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiServiceThread.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiServiceThread_hpp

Define Documentation

#define EmApoxiServiceThread_hpp

Generated on Tue Jan 24 16:38:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiServiceThread.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiServiceThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiServiceThread_hpp)
00010 #define EmApoxiServiceThread_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include <Kernel/ServiceThread.hpp>
00015
00016 #include "EmServThreadMsg.hpp"
00017
00018 class EmApoxiServiceThread  : public ServiceThread {
00019
00020     typedef ServiceThread Base;
00022 public:
00024     static EmApoxiServiceThread& GetInstance();
00026     void OnPowerUp();
00028     void OnPowerDown();
00030     BOOLEAN OnMessage(const Message &msg);
00031
00033     void PostSelfMessage (EmServThreadMsg&);
00034
00035 };
00036
00037 #endif // DOXYGEN_SHOULD_SKIP_THIS
00038
00039 #endif //EmApoxiServiceThread_hpp
00040
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiThread.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiThread.cpp File Reference

#include "EmApoxiSemaphore.hpp"
#include "EmApoxiAllocLogs.hpp"
#include "DerivedApoxiThread.hpp"
#include "EmApoxiThread.hpp"

Include dependency graph for EmApoxiThread.cpp:

Generated on Tue Jan 24 16:38:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiThread.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiThread.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiThread_hpp

Define Documentation

#define EmApoxiThread_hpp

Generated on Tue Jan 24 16:38:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiThread.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiThread_hpp)
00010 #define EmApoxiThread_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 /* # define for setting the different Priority for Local Playback and Streaming */
00018 #define PLAYBACK_PRIORITY 102
00019 #define STREAMING_PRIORITY 141
00020
00021 /* Forward Declaration for Apoxi Thread Class implementation using Pimple */
00022 class DerivedApoxiThread;
00023
00024 class EmApoxiThread
00025 {
00026
00027     public :
00028         EmApoxiThread(EmApoxiUINT32* l_p_result = 0);
00029
00030         ~EmApoxiThread();
00031
00037         void RegisterThreadFnPtr(EmApoxiINT ((*ap_ThreadFn)(void* )), void* context);
00038
00047         EmApoxiBOOLEAN Run(EmApoxiUINT32  stacksize = 4096,  void *  stack = 0);
00048
00049         EmApoxiINT GetPriority();
00050
00058         EmApoxiBOOLEAN SetPriority(EmApoxiINT priority);
00059
00062         EmApoxiINT ObtainPlaybackPriority();
00063
00064         EmApoxiINT ObtainStreamingPriority();
00065
00069         EmApoxiBOOLEAN ObtainSemaphore();
00070
00074         void ReleaseSemaphore();
00075
00076     private:
00077         DerivedApoxiThread  *m_p_derived_apoxi_thread;
00078 };
00079
00080 #endif // DOXYGEN_SHOULD_SKIP_THIS
00081 #endif //EmApoxiThread_hpp
00082
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiTicks.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiTicks.cpp File Reference

#include <Kernel/Os/Ticks.hpp>
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiTicks.hpp"

Include dependency graph for EmApoxiTicks.cpp:

Generated on Tue Jan 24 16:38:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiTicks.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiTicks.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiTicks_hpp

Define Documentation

#define EmApoxiTicks_hpp

Generated on Tue Jan 24 16:38:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiTicks.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiTicks.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiTicks_hpp)
00010 #define EmApoxiTicks_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018 class Ticks;
00019
00020
00021 class EmApoxiTicks {
00022     public:
00023
00024         EmApoxiTicks(EmApoxiUINT32* l_p_result = 0);
00025
00026         ~EmApoxiTicks();
00027
00028         EmApoxiUINT32 GetExpiredTime();
00029
00030     private:
00031
00032         Ticks *m_p_ticks;
00033 };
00034
00035 #endif // DOXYGEN_SHOULD_SKIP_THIS
00036 #endif //EmApoxiTicks_hpp
00037
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiTimer.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiTimer.cpp File Reference

#include "DerivedApoxiTimer.hpp"
#include "EmApoxiAllocLogs.hpp"
#include "EmApoxiTimer.hpp"

Include dependency graph for EmApoxiTimer.cpp:

Generated on Tue Jan 24 16:38:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiTimer.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiTimer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiTimer_hpp

Define Documentation

#define EmApoxiTimer_hpp

Generated on Tue Jan 24 16:38:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiTimer.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiTimer_hpp)
00010 #define EmApoxiTimer_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018
00019 /* Forward Declaration for Apoxi Timer Class implementation using Pimple */
00020 class DerivedApoxiTimer;
00021
00022 typedef EmApoxiINT (*EmApoxiTimerFunc)(void *context);
00023
00024 class EmApoxiTimer
00025 {
00026     public :
00027         EmApoxiTimer(EmApoxiUINT32* l_p_result = 0);
00028
00029         ~EmApoxiTimer();
00030
00034         void Init(EmApoxiUINT32  timeout,
00035                 EmApoxiBOOLEAN  autotimer = EmApoxiFALSE);
00036
00038         void Start();
00039
00042         EmApoxiUINT32 Stop();
00043
00047         void SetTimeout(EmApoxiUINT32 timeout);
00048
00051         void RegisterTimerFunction(EmApoxiTimerFunc p_timer_function,void *context=0);
00052
00053         EmApoxiBOOLEAN IsActive();
00054
00055     private:
00056
00057         DerivedApoxiTimer *m_p_derived_timer;
00058
00059 };
00060
00061 #endif // DOXYGEN_SHOULD_SKIP_THIS
00062 #endif // EmApoxiTimer_hpp
00063
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiUtilities.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiUtilities.cpp File Reference

#include "EmApoxiPlayerEnum.hpp"
#include "EmApoxiRecorderEnum.hpp"
#include "MediaManager.hpp"
#include "MediaPlayer.hpp"
#include "MediaRecorder.hpp"
#include "EmApoxiUtilities.hpp"

Include dependency graph for EmApoxiUtilities.cpp:

Functions

EmApoxiMmfModeType | TranslateMmfModeType (EmApoxiUINT32 mmf_mode_type)
EmApoxiUINT32 | TranslatePlayerState (EmApoxiPlayerState mmf_player_state)
EmApoxiUINT32 | TranslateRecorderState (EmApoxiRecorderState mmf_recorder_state)

Function Documentation

EmApoxiMmfModeType TranslateMmfModeType ( EmApoxiUINT32 mmf_mode_type )

EmApoxiUINT32 TranslatePlayerState ( EmApoxiPlayerState mmf_player_state )

EmApoxiUINT32 TranslateRecorderState ( EmApoxiRecorderState mmf_recorder_state )

Generated on Tue Jan 24 16:38:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiUtilities.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmApoxiUtilities.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiUtilities_hpp

Define Documentation

#define EmApoxiUtilities_hpp

Generated on Tue Jan 24 16:38:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmApoxiUtilities.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmApoxiUtilities.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined (EmApoxiUtilities_hpp)
00010 #define EmApoxiUtilities_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018 #include "EmApoxiPlayerEnum.hpp"
00019 #include "EmApoxiRecorderEnum.hpp"
00020
00021 EmApoxiMmfModeType TranslateMmfModeType(EmApoxiUINT32 mmf_mode_type);
00022 EmApoxiUINT32 TranslatePlayerState(EmApoxiPlayerState mmf_player_state);
00023 EmApoxiUINT32 TranslateRecorderState(EmApoxiRecorderState mmf_recorder_state);
00024
00025 #endif // DOXYGEN_SHOULD_SKIP_THIS
00026 #endif  //EmApoxiUtilities_hpp
00027
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.cpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.cpp File Reference

#include "PreComp.hpp"
#include "EmServThreadMsg.hpp"

Include dependency graph for EmServThreadMsg.cpp:

Functions

OutputStream & | operator<< (OutputStream &ostr, const EmServThreadMsg &cls)
InputStream & | operator>> (InputStream &istr, EmServThreadMsg &cls)

Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const EmServThreadMsg & | cls
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | EmServThreadMsg & | cls
 | ) |

Generated on Tue Jan 24 16:38:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.hpp File Reference

AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/WString.hpp>
#include <EmApoxiDataTypes.hpp>
#include <EmApoxiAudioDeviceImpl.hpp>
#include <Kernel/InputStream.hpp>
#include <Kernel/OutputStream.hpp>

Include dependency graph for EmServThreadMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmServThreadMsg

Defines

#define | EmServThreadMsg_hpp__ST_1128926169290

Typedefs

typedef EmApoxiUINT32(* | tCallbackFnPtr )(EmApoxiUINT32)

Define Documentation

#define EmServThreadMsg_hpp__ST_1128926169290

Typedef Documentation

typedef EmApoxiUINT32(* tCallbackFnPtr)(EmApoxiUINT32)

Generated on Tue Jan 24 16:38:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.hpp Source File

AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "APOXI\SDK\bin\MessageGenerator\samples\SampleMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(EmServThreadMsg_hpp__ST_1128926169290)
00017 #define EmServThreadMsg_hpp__ST_1128926169290
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Auxiliary/WString.hpp>
00021 #include <EmApoxiDataTypes.hpp>
00022 #include <EmApoxiAudioDeviceImpl.hpp>
00023 #include <Kernel/InputStream.hpp>
00024 #include <Kernel/OutputStream.hpp>
00025
00026 typedef EmApoxiUINT32 (*tCallbackFnPtr)(EmApoxiUINT32);
00027
00028 /* ----------------------------------------------------------------------
00029     Classes
00030     ---------------------------------------------------------------------- */
00031
00032 /*  ======================================================================
00033     Class EmServThreadMsg
00034     ====================================================================== */
00035
00038 class EmServThreadMsg : public ContextMsg  {
00039
00040     public:
00041         EmServThreadMsg(ExecutionContext* application, const tEmApxAudDeviceHdl& m_h_aud_device, const tCallbackFnPtr& m_cb_fn_ptr, void * m_cb_data, const EmApoxiBOOLEAN& m_is_audio_muted, const EmApoxiBOOLEAN& m_start_stop_audio);
00042         virtual ~EmServThreadMsg();
00043
00044         virtual const MsgMetaData& GetMetaData() const;
00045         void SetMHAudDevice(const tEmApxAudDeviceHdl& m_h_aud_device) { m_m_h_aud_device = m_h_aud_device; }
00046         const tEmApxAudDeviceHdl& GetMHAudDevice() const { return m_m_h_aud_device; }
00047         void SetMCbFnPtr(const tCallbackFnPtr& m_cb_fn_ptr) { m_m_cb_fn_ptr = m_cb_fn_ptr; }
00048         const tCallbackFnPtr& GetMCbFnPtr() const { return m_m_cb_fn_ptr; }
00049         void SetMCbData(void * m_cb_data) { m_m_cb_data = m_cb_data; }
00050         void * GetMCbData() const { return m_m_cb_data; }
00051         void SetMIsAudioMuted(const EmApoxiBOOLEAN& m_is_audio_muted) { m_m_is_audio_muted = m_is_audio_muted; }
00052         const EmApoxiBOOLEAN& GetMIsAudioMuted() const { return m_m_is_audio_muted; }
00053         void SetMStartStopAudio(const EmApoxiBOOLEAN& m_start_stop_audio) { m_m_start_stop_audio = m_start_stop_audio; }
00054         const EmApoxiBOOLEAN& GetMStartStopAudio() const { return m_m_start_stop_audio; }
00055         virtual Message* Clone() const;
00056 #if !defined(APOXI_NOSTREAMING)
00057         friend OutputStream& operator << (OutputStream& ostr, const EmServThreadMsg& cls);
00058 #endif // APOXI_NOSTREAMING
00059 #if !defined(APOXI_NOSTREAMING)
00060         friend InputStream& operator >> (InputStream& istr, EmServThreadMsg& cls);
00061 #endif // APOXI_NOSTREAMING
00062
00063         enum {
00064             ID = 54002
00065         };
00066
00067     protected:
00068
00069 #if !defined(APOXI_NOSTREAMING)
00070         virtual void Dump(OutputStream& ostr) const;
00071 #endif // APOXI_NOSTREAMING
00072
00073     private:
00074         static const MsgMetaData m_meta_data;
00075         tEmApxAudDeviceHdl m_m_h_aud_device;
00076         tCallbackFnPtr m_m_cb_fn_ptr;
00077         void * m_m_cb_data;
00078         EmApoxiBOOLEAN m_m_is_audio_muted;
00079         EmApoxiBOOLEAN m_m_start_stop_audio;
00080
00081 };
00082
00083 #endif // EmServThreadMsg_hpp__ST_1128926169290
00084
Generated on Tue Jan 24 14:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/DisplaySettings.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/DisplaySettings.cpp File Reference

#include "DisplaySettings.hpp"

Include dependency graph for DisplaySettings.cpp:

Generated on Tue Jan 24 16:39:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/Media.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/Media.cpp File Reference

#include "PreComp.hpp"
#include <Gui/Size.hpp>
#include <Auxiliary/BinData.hpp>
#include "Media.hpp"

Include dependency graph for Media.cpp:

Generated on Tue Jan 24 16:39:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaBox.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaBox.cpp File Reference

#include "PreComp.hpp"
#include <Afs/Rfs/FileBinData.hpp>
#include <Auxiliary/MimeTypeTable.hpp>
#include "MediaInfo.hpp"
#include "DisplaySettings.hpp"
#include "MediaManager.hpp"
#include "MediaPlayer.hpp"
#include "MediaBox.hpp"

Include dependency graph for MediaBox.cpp:

Defines

#define | DISPLAY_DEFAULT_HEIGHT 144
#define | DISPLAY_DEFAULT_WIDTH 176
#define | DISPLAY_XOFFSET 0
#define | DISPLAY_YOFFSET 68

Define Documentation

#define DISPLAY_DEFAULT_HEIGHT 144

#define DISPLAY_DEFAULT_WIDTH 176

#define DISPLAY_XOFFSET 0

#define DISPLAY_YOFFSET 68

Generated on Tue Jan 24 16:39:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaFrameworkVersion.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaFrameworkVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>

Include dependency graph for MediaFrameworkVersion.cpp:

Functions

ApoxiDefVersionInfo (MediaFramework,"4.2.1.6", VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | MediaFramework | ,
 |  | "4.2.1.6" | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:40:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaInfo.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaInfo.cpp File Reference

#include "EmApoxiAllocLogs.hpp"
#include "MediaFramework/MediaInfo.hpp"

Include dependency graph for MediaInfo.cpp:

Defines

#define EmApoxiDELETE_ARRAY(pointer) if(pointer){ delete[](pointer); pointer = 0; }

Define Documentation

#define EmApoxiDELETE_ARRAY ( pointer ) if(pointer){ delete[](pointer); pointer = 0; }

Generated on Tue Jan 24 16:40:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaManager.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaManager.cpp File Reference

#include "PreComp.hpp"
#include "MediaRecorder.hpp"
#include "MediaPlayer.hpp"
#include "EmApoxiMsgDispatcher.hpp"
#include "MediaManager.hpp"
#include <Kernel/VersionInfo.hpp>

Include dependency graph for MediaManager.cpp:

Functions

ApoxiUseVersionInfo (MediaFramework)

Function Documentation

ApoxiUseVersionInfo ( MediaFramework )

Generated on Tue Jan 24 16:40:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaObtainer.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaObtainer.cpp File Reference

#include "PreComp.hpp"
#include "MediaObtainer.hpp"

Include dependency graph for MediaObtainer.cpp:

Generated on Tue Jan 24 16:40:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayer.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayer.cpp File Reference

#include "EmApoxiMimeTypeTable.hpp"
#include "EmApoxiBinData.hpp"
#include "EmApoxiPlayerEnum.hpp"
#include "EmApoxiDisplaySettings.hpp"
#include "EmApoxiMediaInfo.hpp"
#include "EmApoxiUtilities.hpp"
#include "MediaPlayerImpl.hpp"
#include "MediaFramework/MediaPlayer.hpp"

Include dependency graph for MediaPlayer.cpp:

Typedefs

typedef __player_data PlayerData

Typedef Documentation

typedef struct __player_data PlayerData

Generated on Tue Jan 24 16:40:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayerImpl.hpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayerImpl.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:40:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayerImpl.hpp Source File

AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayerImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef MediaPlayerImpl_hpp
00009 #define MediaPlayerImpl_hpp
00010
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiDataTypes.hpp"
00018 #include "EmApoxiDisplaySettings.hpp"
00019 #include "EmApoxiMutex.hpp"
00020
00021 class EmMediaPlayer;
00022 class EmApoxiBinData;
00023 class EmApoxiMediaInfo;
00024
00025 enum EmApoxiTrackSelection;
00026
00027
00028 class MediaPlayerImpl
00029 {
00030     public:
00031
00032         ~MediaPlayerImpl();
00033
00044         virtual EmApoxiMmfResult SelectMediaTracks (
00045                                     EmApoxiTrackSelection track_selection,
00046                                     EmApoxiUINT audio_track_id,
00047                                     EmApoxiUINT video_track_id);
00048
00053         virtual EmApoxiMmfResult SetDisplaySettings(
00054             const EmApoxiDisplaySettings& display_settings);
00055
00063         virtual EmApoxiMmfResult Play();
00064
00068         virtual EmApoxiMmfResult Pause();
00069
00074         virtual EmApoxiMmfResult Stop();
00075
00083         virtual EmApoxiMmfResult Rewind(EmApoxiINT rate);
00084
00094         virtual EmApoxiMmfResult FastForward(EmApoxiINT rate);
00095
00101         virtual EmApoxiMmfResult GetState(EmApoxiPlayerState& state) const;
00102
00118         virtual EmApoxiMmfResult SetPosition(EmApoxiINT32 position);
00119
00127         virtual EmApoxiMmfResult GetPosition(EmApoxiUINT32& position) const ;
00128
00149         virtual EmApoxiMmfResult SetDisplayLocation(EmApoxiINT x, EmApoxiINT y);
00150
00163         virtual EmApoxiMmfResult Zoom(EmApoxiBOOLEAN zoom_up);
00164
00179         virtual EmApoxiMmfResult Unzoom();
00180
00185         virtual EmApoxiMmfResult SetVolumeLevel(EmApoxiUINT volume_level);
00186
00191         virtual EmApoxiMmfResult SetBassLevel(EmApoxiUINT bass_level);
00192
00197         virtual EmApoxiMmfResult SetTrebleLevel(EmApoxiUINT treble_level);
00198
00203         virtual EmApoxiMmfResult SetBalanceLevel(EmApoxiUINT balance_level);
00204
00210         virtual EmApoxiMmfResult SetPlaybackContrast(EmApoxiUINT contrast_level);
00211
00212
00213         virtual EmApoxiMmfResult GetFirstVideoFrame
00214                             (EmApoxiUINT8 *buffer, EmApoxiUINT32& buffer_length);
00215
00220         EmApoxiMmfResult SetPlaybackVideoQuality
00221                             (EmApoxiDisplaySettings::EmApoxiVideoQuality video_quality);
00228         virtual EmApoxiMmfResult SetRepeatCount(EmApoxiUINT16 repeat_count = 1) ;
00229
00235         virtual EmApoxiMmfResult SetContinue(EmApoxiBOOLEAN continue_flag = EmApoxiFALSE) ;
00236
00242         virtual EmApoxiMmfResult SetPriority(EmApoxiUINT32 priority = 0) ;
00243
00247         virtual EmApoxiUINT16 GetRepeatCount() const ;
00248
00252         virtual EmApoxiBOOLEAN GetContinue() const ;
00253
00257         virtual EmApoxiUINT32 GetPriority() const ;
00258
00262         virtual void* GetAudioReference(void) const;
00263 #ifdef ENABLE_STREAMING
00264
00269         virtual EmApoxiMmfResult GetBuffLevel(EmApoxiUINT32 &buff_level);
00270
00275         virtual EmApoxiMmfResult SetBufferingTime(EmApoxiUINT32 buff_level);
00276 #endif
00277
00278     protected:
00279
00280
00281     private:
00282
00283         EmMediaPlayer           *m_p_media_player;
00284
00285         //Mutex to make a particular function wait,
00286         //if one is already being processed.
00287         EmApoxiMutex*           m_p_api_wait_mutex;
00288
00289         MediaPlayerImpl(const EmApoxiBinData* media_source,
00290                     EmApoxiMediaInfo& media_info,
00291                     EmApoxiMimeType& media_mime_type,
00292                     EmApoxiMmfResult& mmf_result,
00293                     void *msg_dispatcher,
00294                     void* msg_data,
00295                     EmApoxiUINT32 audio_priority_value=0,
00296                     EmApoxiMmfModeType mmf_mode=EmApoxiMmfModeAudioVideo);
00297
00298         MediaPlayerImpl(const char *location,
00299                     EmApoxiMediaInfo& media_info,
00300                     EmApoxiMimeType& media_mime_type,
00301                     EmApoxiMmfResult& mmf_result,
00302                     void *msg_dispatcher,
00303                     void* msg_data,
00304                     EmApoxiUINT32 audio_priority_value=0,
00305                     EmApoxiMmfModeType mmf_mode=EmApoxiMmfModeAudioVideo);
00306
00307         friend class MediaPlayer;
00308 };
00309
00310 #endif //DOXYGEN_SHOULD_SKIP_THIS
00311 #endif  //MediaPlayerImpl_hpp
00312
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorder.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorder.cpp File Reference

#include "MediaFramework/DisplaySettings.hpp"
#include "EmApoxiPlayerEnum.hpp"
#include "EmApoxiMediaInfo.hpp"
#include "EmApoxiUtilities.hpp"
#include "MediaRecorderImpl.hpp"
#include "MediaRecorder.hpp"

Include dependency graph for MediaRecorder.cpp:

Generated on Tue Jan 24 16:41:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorderImpl.hpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorderImpl.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define MediaRecorderImpl_hpp

Define Documentation

#define MediaRecorderImpl_hpp

Generated on Tue Jan 24 16:41:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorderImpl.hpp Source File

AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorderImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(MediaRecorderImpl_hpp)
00009 #define MediaRecorderImpl_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00011 /*
00012     This is an internal class which should not be used by the MMI in a direct
00013     manner, and the interface may be changed in future releases.
00014 */
00015
00016 #include "EmApoxiRecordSettings.hpp"
00017 #include "EmApoxiDisplaySettings.hpp"
00018 #include "EmApoxiPlayerEnum.hpp"
00019 #include "EmApoxiRecorderEnum.hpp"
00020 #include "EmApoxiMutex.hpp"
00021
00022 class EmMediaRecorder;
00023 class MediaRecorder;
00024
00026 class  MediaRecorderImpl {
00027     public:
00028
00029         virtual ~MediaRecorderImpl();
00030
00038         EmApoxiMmfResult SetDisplaySettings(
00039                             const EmApoxiDisplaySettings& display_settings);
00040
00048         EmApoxiMmfResult SetDisplayAndRecordSettings(
00049                             const EmApoxiDisplaySettings& display_settings,
00050                             const EmApoxiRecordSettings& record_settings);
00051
00055         EmApoxiMmfResult StartPreview();
00056
00060         EmApoxiMmfResult StopPreview();
00061
00069         EmApoxiMmfResult SetRecordSettings(
00070             const EmApoxiRecordSettings& record_settings);
00071
00075         EmApoxiMmfResult StartRecord();
00076
00080         EmApoxiMmfResult PauseRecord();
00081
00085         EmApoxiMmfResult ResumeRecord();
00086
00091         EmApoxiMmfResult StopRecord();
00092
00098         EmApoxiMmfResult GetState(EmApoxiRecorderState& state) const;
00099
00107         EmApoxiMmfResult GetPosition(EmApoxiUINT32& position) const;
00108
00124         virtual EmApoxiMmfResult Zoom(EmApoxiBOOLEAN zoom_up);
00125
00144         virtual EmApoxiMmfResult Unzoom();
00145
00152         EmApoxiMmfResult SetCameraNightMode(EmApoxiBOOLEAN night_mode_on);
00153
00160         EmApoxiMmfResult SetCameraMirroring(EmApoxiBOOLEAN mirroring_on);
00161
00171         EmApoxiMmfResult SetMute(EmApoxiBOOLEAN mute_on);
00172
00178         virtual EmApoxiMmfResult SetPriority(EmApoxiUINT32 priority = 0) ;
00179
00183         virtual EmApoxiUINT32 GetPriority() const ;
00184
00185     private:
00186         EmMediaRecorder*        m_p_media_recorder;
00187
00188         //Mutex to make a particular function wait,
00189         //if one is already being processed.
00190         EmApoxiMutex*           m_p_api_wait_mutex;
00191
00192         static EmApoxiBOOLEAN   m_recorder_exists;
00193
00197         MediaRecorderImpl(EmApoxiMmfResult& mmf_result,
00198                         void *msg_dispatcher,
00199                         void* msg_data,
00200                         EmApoxiUINT32 audio_priority_value=0,
00201                         EmApoxiMmfModeType mmf_mode=EmApoxiMmfModeAudioVideo);
00202
00203         friend class MediaRecorder;
00204
00205
00206 };
00207
00208 #endif //DOXYGEN_SHOULD_SKIP_THIS
00209 #endif // MediaRecorderImpl_hpp
00210
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/MsgTypes.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/MsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Functions

OutputStream & | operator<< (OutputStream &ostr, const MCServiceInterfaceMsg &cls)
OutputStream & | operator<< (OutputStream &ostr, const MediaManagerMsg &cls)
InputStream & | operator>> (InputStream &istr, MCServiceInterfaceMsg &cls)
InputStream & | operator>> (InputStream &istr, MediaManagerMsg &cls)

Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const MCServiceInterfaceMsg & | cls
 | ) |

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const MediaManagerMsg & | cls
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | MCServiceInterfaceMsg & | cls
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | MediaManagerMsg & | cls
 | ) |

Generated on Tue Jan 24 14:55:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/PreComp.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/RecordSettings.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/RecordSettings.cpp File Reference

#include "MediaFramework/RecordSettings.hpp"

Include dependency graph for RecordSettings.cpp:

Defines

#define | EZD_DEFAULT_BRIGHTNESS 7
#define | EZD_DEFAULT_CAMERA_DEV_ID 0
#define | EZD_DEFAULT_CAMERA_HEIGHT 144
#define | EZD_DEFAULT_CAMERA_WIDTH 176
#define | EZD_DEFAULT_CONTRAST 5
#define | EZD_DEFAULT_DURATION 40 * 1000
#define | EZD_DEFAULT_FILE_SIZE 60 * 1024
#define | EZD_DEFAULT_FRAMERATE 15
#define | MAX_FILE_NAME_LENGTH 80

Define Documentation

#define EZD_DEFAULT_BRIGHTNESS 7

#define EZD_DEFAULT_CAMERA_DEV_ID 0

#define EZD_DEFAULT_CAMERA_HEIGHT 144

#define EZD_DEFAULT_CAMERA_WIDTH 176

#define EZD_DEFAULT_CONTRAST 5

#define EZD_DEFAULT_DURATION 40 * 1000

#define EZD_DEFAULT_FILE_SIZE 60 * 1024

#define EZD_DEFAULT_FRAMERATE 15

#define MAX_FILE_NAME_LENGTH 80

Generated on Tue Jan 24 16:41:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/MMfrInterfaceImpl/VideoCaptureParameters.cpp File Reference

AddOns/MediaFramework/MMfrInterfaceImpl/VideoCaptureParameters.cpp File Reference

#include "PreComp.hpp"
#include <Auxiliary/MimeTypeTable.hpp>
#include "VideoCaptureParameters.hpp"

Include dependency graph for VideoCaptureParameters.cpp:

Generated on Tue Jan 24 16:41:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDataConnManager.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiDataConnManager.cpp File Reference

#include <Kernel/Lib.hpp>
#include <Socket/DataConnManager.hpp>
#include "EmApoxiDataConnManager.hpp"

Include dependency graph for EmApoxiDataConnManager.cpp:

Generated on Tue Jan 24 16:41:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDataConnManager.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiDataConnManager.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiDataConnManager_hpp

Define Documentation

#define EmApoxiDataConnManager_hpp

Generated on Tue Jan 24 16:41:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDataConnManager.hpp Source File

AddOns/MediaFramework/Network/EmApoxiDataConnManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiDataConnManager_hpp)
00010 #define EmApoxiDataConnManager_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiInterface.hpp"
00019
00020 class EmApoxiDataConnManager
00021 {
00022
00024     public:
00025
00027         ~EmApoxiDataConnManager();
00028
00030         static EmApoxiDataConnManager &Get();
00031
00033         EmApoxiBOOLEAN IsDataConnRegistered(EmApoxiDataConnProfileId id) const;
00034
00036         EmApoxiBOOLEAN RegisterDataConn(EmApoxiDataConnProfileId id);
00037
00039     protected:
00040
00041
00042
00043
00045     private:
00047         EmApoxiDataConnManager();
00048
00049
00050 }; // EmApoxiDataConnManager
00051
00052 #endif // DOXYGEN_SHOULD_SKIP_THIS
00053 #endif // EmApoxiDataConnManager_hpp
00054
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDataConnProfileManager.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiDataConnProfileManager.cpp File Reference

#include <Socket/DataConnProfileManager.hpp>
#include "EmApoxiDataConnProfileManager.hpp"

Include dependency graph for EmApoxiDataConnProfileManager.cpp:

Generated on Tue Jan 24 16:41:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDataConnProfileManager.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiDataConnProfileManager.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiDataConnProfileManager_hpp

Define Documentation

#define EmApoxiDataConnProfileManager_hpp

Generated on Tue Jan 24 16:41:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDataConnProfileManager.hpp Source File

AddOns/MediaFramework/Network/EmApoxiDataConnProfileManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(EmApoxiDataConnProfileManager_hpp)
00009 #define EmApoxiDataConnProfileManager_hpp
00010
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiInterface.hpp"
00018
00019 class EmApoxiDataConnProfileManager
00020 {
00021
00023     public:
00024
00026         ~EmApoxiDataConnProfileManager();
00027
00029         static EmApoxiDataConnProfileManager &Get();
00030
00032         EmApoxiDataConnProfileId GetDefProfileId() const;
00033
00034
00036     protected:
00037
00038
00039
00040
00042     private:
00044         EmApoxiDataConnProfileManager();
00045
00046
00047 }; // EmApoxiDataConnProfileManager
00048
00049 #endif // DOXYGEN_SHOULD_SKIP_THIS
00050 #endif // EmApoxiDataConnProfileManager_hpp
00051
Generated on Tue Jan 24 14:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDnsClient.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiDnsClient.cpp File Reference

#include <Socket/DnsClientTypes.hpp>
#include "ExtndDnsClient.hpp"
#include "EmApoxiDnsClient.hpp"

Include dependency graph for EmApoxiDnsClient.cpp:

Generated on Tue Jan 24 16:41:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDnsClient.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiDnsClient.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiDnsClient_hpp

Define Documentation

#define EmApoxiDnsClient_hpp

Generated on Tue Jan 24 16:41:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiDnsClient.hpp Source File

AddOns/MediaFramework/Network/EmApoxiDnsClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiDnsClient_hpp)
00010 #define EmApoxiDnsClient_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiInterface.hpp"
00019 #include "EmApoxiIpAddr.hpp"
00020
00021 class ExtndDnsClient;
00022
00023 class EmApoxiDnsClient
00024 {
00025
00027     public:
00028
00030         EmApoxiDnsClient();
00031
00033         static void Init();
00034
00036         EmApoxiBOOLEAN GetHostByName(char *a_name, EmApoxiIpAddr &a_ip_addr);
00037
00039         ~EmApoxiDnsClient();
00040
00041
00043     protected:
00044
00045
00047     private:
00048         ExtndDnsClient *mp_dns_client;
00049
00050 }; // EmApoxiDnsClient
00051
00052 #endif // DOXYGEN_SHOULD_SKIP_THIS
00053 #endif // EmApoxiDnsClient_hpp
00054
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiInetSocketAddr.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiInetSocketAddr.cpp File Reference

#include <Auxiliary/IpAddr.hpp>
#include <Socket/InetSocketAddr.hpp>
#include "EmApoxiInetSocketAddr.hpp"
#include "EmApoxiIpPortNo.hpp"
#include "EmApoxiIpAddr.hpp"

Include dependency graph for EmApoxiInetSocketAddr.cpp:

Generated on Tue Jan 24 16:41:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiInetSocketAddr.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiInetSocketAddr.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiInetSocketAddr_hpp

Define Documentation

#define EmApoxiInetSocketAddr_hpp

Generated on Tue Jan 24 16:41:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiInetSocketAddr.hpp Source File

AddOns/MediaFramework/Network/EmApoxiInetSocketAddr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiInetSocketAddr_hpp)
00010 #define EmApoxiInetSocketAddr_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiInterface.hpp"
00019 #include "EmApoxiIpAddr.hpp"
00020 #include "EmApoxiIpPortNo.hpp"
00021
00022 class InetSocketAddr;
00023
00024 class EmApoxiInetSocketAddr
00025 {
00026
00028     public:
00029
00031         EmApoxiInetSocketAddr(
00032             const EmApoxiIpAddr &ip = EmApoxiIpAddr(),
00033             const EmApoxiIpPortNo &port = EmApoxiIpPortNo());
00034
00036         ~EmApoxiInetSocketAddr();
00037
00039         void SetPortNo(const EmApoxiIpPortNo& port);
00040
00042         InetSocketAddr *GetInetSocketAddr() const {return mp_inet_socket_addr;}
00043
00044
00046     protected:
00047
00048
00050     private:
00051         InetSocketAddr *mp_inet_socket_addr;
00052
00053 }; // EmApoxiInetSocketAddr
00054
00055 #endif // DOXYGEN_SHOULD_SKIP_THIS
00056 #endif // EmApoxiInetSocketAddr_hpp
00057
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiInterface.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiInterface.hpp File Reference

Go to the source code of this file.

Defines

#define EmApoxiInterface_hpp

Define Documentation

#define EmApoxiInterface_hpp

Generated on Tue Jan 24 16:41:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiInterface.hpp Source File

AddOns/MediaFramework/Network/EmApoxiInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiInterface_hpp)
00010 #define EmApoxiInterface_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiDataTypes.hpp"
00019
00020 typedef enum
00021 {
00022     c_em_event_conn_req_pending,
00023     c_em_event_conn_closed,
00024     c_em_event_data_sent,
00025     c_em_event_data_received,
00026     c_em_event_bearer_lost
00027 }EmSockEvent;
00028
00029 typedef EmApoxiUINT8 EmApoxiDataConnProfileId;
00030
00031 typedef void (*EmSockEventCbFn(EmSockEvent a_sock_event, void *a_sock,
00032               void *a_user_data));
00033
00034 typedef void (*EmNetworkExecCbFn(EmApoxiUINT32 a_msg, void *a_user_data));
00035 typedef enum
00036 {
00037     c_em_network_exec_request,
00038     c_em_network_periodic_exec_request,
00039     c_em_network_response,
00040     c_em_network_timeout_registercb,
00041     c_em_release_socket_handler,
00042     c_em_init_socket_handler,
00043     c_em_start_buffering_timer,
00044     c_em_cancel_buffering_timer,
00045     c_em_start_network_timer,
00046     c_em_start_ff_rwd_network_timer,
00047     c_em_stop_ff_rwd_network_timer,
00048     c_em_create_network_instance,
00049     c_em_delete_network_instance
00050
00051 }EmNetworkServiceThreadMsgType;
00052
00053 #endif // DOXYGEN_SHOULD_SKIP_THIS
00054 #endif // EmApoxiInterface_hpp
00055
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiIpAddr.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiIpAddr.cpp File Reference

#include <Auxiliary/IpAddr.hpp>
#include "EmApoxiIpAddr.hpp"

Include dependency graph for EmApoxiIpAddr.cpp:

Generated on Tue Jan 24 16:41:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiIpAddr.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiIpAddr.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiIpAddr_hpp

Define Documentation

#define EmApoxiIpAddr_hpp

Generated on Tue Jan 24 16:41:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiIpAddr.hpp Source File

AddOns/MediaFramework/Network/EmApoxiIpAddr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiIpAddr_hpp)
00010 #define EmApoxiIpAddr_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiInterface.hpp"
00019
00020 class IpAddr;
00021
00022 class EmApoxiIpAddr
00023 {
00024
00026     public:
00027
00029         EmApoxiIpAddr(EmApoxiUINT32 addr = 0,
00030             EmApoxiBOOLEAN convert_from_native = EmApoxiFALSE);
00031
00033         ~EmApoxiIpAddr();
00034
00036         EmApoxiBOOLEAN InitFrom(const char *str, EmApoxiINT len=-1);
00037
00039         EmApoxiUINT32 GetAddr() const;
00040
00042         IpAddr *GetIpAddr() const {return mp_ip_addr;}
00043
00044
00046     protected:
00047
00048
00050     private:
00051         IpAddr *mp_ip_addr;
00052
00053 }; // EmApoxiIpAddr
00054
00055 #endif // DOXYGEN_SHOULD_SKIP_THIS
00056 #endif // EmApoxiIpAddr_hpp
00057
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiIpPortNo.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiIpPortNo.cpp File Reference

#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/IpPortNo.hpp>
#include "EmApoxiIpPortNo.hpp"

Include dependency graph for EmApoxiIpPortNo.cpp:

Generated on Tue Jan 24 16:41:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiIpPortNo.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiIpPortNo.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiIpPortNo_hpp

Define Documentation

#define EmApoxiIpPortNo_hpp

Generated on Tue Jan 24 16:41:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiIpPortNo.hpp Source File

AddOns/MediaFramework/Network/EmApoxiIpPortNo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmApoxiIpPortNo_hpp)
00010 #define EmApoxiIpPortNo_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 /*
00014     This is an internal class which should not be used by the MMI in a direct
00015     manner, and the interface may be changed in future releases.
00016 */
00017
00018 #include "EmApoxiInterface.hpp"
00019
00020 class IpPortNo;
00021
00022 class EmApoxiIpPortNo
00023 {
00024
00026     public:
00027
00029         EmApoxiIpPortNo(EmApoxiUINT16 port = 0,
00030             EmApoxiBOOLEAN convert_from_native = EmApoxiFALSE);
00031
00033         ~EmApoxiIpPortNo();
00034
00036         IpPortNo *GetIpPortNo() const {return mp_ip_port_no;}
00037
00038
00040     protected:
00041
00042
00044     private:
00045         IpPortNo *mp_ip_port_no;
00046
00047 }; // EmApoxiIpPortNo
00048
00049 #endif // DOXYGEN_SHOULD_SKIP_THIS
00050 #endif // EmApoxiIpPortNo_hpp
00051
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiSocketHandler.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiSocketHandler.cpp File Reference

#include <Socket/SocketHandler.hpp>
#include "EmApoxiSocketHandler.hpp"

Include dependency graph for EmApoxiSocketHandler.cpp:

Generated on Tue Jan 24 16:41:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiSocketHandler.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiSocketHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiSocketHandler_hpp

Define Documentation

#define EmApoxiSocketHandler_hpp

Generated on Tue Jan 24 16:41:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiSocketHandler.hpp Source File

AddOns/MediaFramework/Network/EmApoxiSocketHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(EmApoxiSocketHandler_hpp)
00009 #define EmApoxiSocketHandler_hpp
00010
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiInterface.hpp"
00018
00019 class SocketHandler;
00020
00021 class EmApoxiSocketHandler
00022 {
00023
00025     public:
00026
00028         EmApoxiSocketHandler();
00029
00031         void Init();
00032
00034         void Release();
00035
00037         ~EmApoxiSocketHandler();
00038
00039
00041     protected:
00042
00043
00045     private:
00046         SocketHandler *mp_socket_handler;
00047
00048 }; // EmApoxiSocketHandler
00049
00050 #endif // DOXYGEN_SHOULD_SKIP_THIS
00051 #endif // EmApoxiSocketHandler_hpp
00052
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiTcpSocket.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiTcpSocket.cpp File Reference

#include "ExtndTcpSocket.hpp"
#include "EmApoxiTcpSocket.hpp"

Include dependency graph for EmApoxiTcpSocket.cpp:

Generated on Tue Jan 24 16:41:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiTcpSocket.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiTcpSocket.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiTcpSocket_hpp

Define Documentation

#define EmApoxiTcpSocket_hpp

Generated on Tue Jan 24 16:41:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiTcpSocket.hpp Source File

AddOns/MediaFramework/Network/EmApoxiTcpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(EmApoxiTcpSocket_hpp)
00009 #define EmApoxiTcpSocket_hpp
00010
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include "EmApoxiInterface.hpp"
00018 #include "EmApoxiInetSocketAddr.hpp"
00019
00020 class ExtndTcpSocket;
00021
00022
00023 class EmApoxiTcpSocket
00024 {
00025
00027     public:
00028
00030         EmApoxiTcpSocket();
00031
00033         EmApoxiBOOLEAN Close();
00034
00036         EmApoxiBOOLEAN Open();
00037
00039         EmApoxiBOOLEAN Connect(EmApoxiInetSocketAddr &to);
00040
00043         EmApoxiINT32 Write(const void *buf, EmApoxiINT32 buflen);
00044
00046         ~EmApoxiTcpSocket();
00047
00049         void Init(EmSockEventCbFn a_sock_event_cb_fn, void *a_user_data);
00050
00052         static EmApoxiINT32 ReadFromSocket(void *a_sock,
00053             EmApoxiUINT8 *ap_buff, EmApoxiINT32 a_len);
00054
00057         EmApoxiBOOLEAN SetDataConnProfileId(EmApoxiDataConnProfileId prof_id);
00058
00059
00061     protected:
00062
00064     private:
00065         ExtndTcpSocket *mp_tcp_socket;
00066
00067 }; // EmApoxiTcpSocket
00068
00069 #endif // DOXYGEN_SHOULD_SKIP_THIS
00070 #endif // EmApoxiTcpSocket_hpp
00071
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiUdpSocket.cpp File Reference

AddOns/MediaFramework/Network/EmApoxiUdpSocket.cpp File Reference

#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/IpPortNo.hpp>
#include <Socket/InetSocketAddr.hpp>
#include "ExtndUdpSocket.hpp"
#include "EmApoxiUdpSocket.hpp"

Include dependency graph for EmApoxiUdpSocket.cpp:

Generated on Tue Jan 24 16:41:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiUdpSocket.hpp File Reference

AddOns/MediaFramework/Network/EmApoxiUdpSocket.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define EmApoxiUdpSocket_hpp

Define Documentation

#define EmApoxiUdpSocket_hpp

Generated on Tue Jan 24 16:41:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/EmApoxiUdpSocket.hpp Source File

AddOns/MediaFramework/Network/EmApoxiUdpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(EmApoxiUdpSocket_hpp)
00009 #define EmApoxiUdpSocket_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00011 /*
00012     This is an internal class which should not be used by the MMI in a direct
00013     manner, and the interface may be changed in future releases.
00014 */
00015 #include "EmApoxiInterface.hpp"
00016 #include "EmApoxiInetSocketAddr.hpp"
00017
00018 class ExtndUdpSocket;
00019
00020 class EmApoxiUdpSocket
00021 {
00022
00024     public:
00026         EmApoxiUdpSocket();
00027
00029         void Init(EmSockEventCbFn a_sock_event_cb_fn, void *a_user_data);
00030
00032         EmApoxiBOOLEAN Open(EmApoxiInetSocketAddr *local_addr = 0,
00033                         EmApoxiBOOLEAN may_reuse_addr = EmApoxiTRUE);
00034
00037         EmApoxiINT32 Write(const void *buf, EmApoxiINT32 buflen, EmApoxiInetSocketAddr *to=0);
00038
00040         static EmApoxiINT32 ReadFromSocket(void *a_sock,
00041             EmApoxiUINT8 *ap_buff, EmApoxiINT32 a_len);
00042
00044         ~EmApoxiUdpSocket();
00045
00046
00048     protected:
00049
00050
00052     private:
00053         ExtndUdpSocket *mp_udp_socket;
00054
00055 }; // EmApoxiUdpSocket
00056
00057 #endif // DOXYGEN_SHOULD_SKIP_THIS
00058 #endif // EmApoxiUdpSocket_hpp
00059
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndDnsClient.cpp File Reference

AddOns/MediaFramework/Network/ExtndDnsClient.cpp File Reference

#include "ExtndDnsClient.hpp"

Include dependency graph for ExtndDnsClient.cpp:

Generated on Tue Jan 24 16:41:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndDnsClient.hpp File Reference

AddOns/MediaFramework/Network/ExtndDnsClient.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define ExtndDnsClient_hpp

Define Documentation

#define ExtndDnsClient_hpp

Generated on Tue Jan 24 16:41:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndDnsClient.hpp Source File

AddOns/MediaFramework/Network/ExtndDnsClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ExtndDnsClient_hpp)
00010 #define ExtndDnsClient_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include <Socket/DnsClient.hpp>
00018
00019 #include "EmApoxiInterface.hpp"
00020
00021 class ExtndDnsClient : public DnsClient
00022 {
00023     typedef DnsClient Base;
00024
00026     public:
00028         void OnNameResponse(const String &name, UINT16 error_no);
00029
00031         void OnAddrResponse(const IpAddr &ip_addr, UINT16 error_no);
00032
00033
00034 }; // ExtndDnsClient
00035
00036 #endif // DOXYGEN_SHOULD_SKIP_THIS
00037 #endif // ExtndDnsClient_hpp
00038
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndServiceThreadForNetwork.cpp File Reference

AddOns/MediaFramework/Network/ExtndServiceThreadForNetwork.cpp File Reference

#include <Kernel/ServiceThreadStarter.hpp>
#include <Kernel/Timer.hpp>
#include <Kernel/MsgTypes.hpp>
#include "ExtndServiceThreadForNetwork.hpp"
#include "NetworkServiceThreadMsgTypes.hpp"

Include dependency graph for ExtndServiceThreadForNetwork.cpp:

Defines

#define Base ServiceThread

Define Documentation

#define Base ServiceThread

Generated on Tue Jan 24 16:41:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndServiceThreadForNetwork.hpp File Reference

AddOns/MediaFramework/Network/ExtndServiceThreadForNetwork.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define ServiceThreadExtn_hpp

Define Documentation

#define ServiceThreadExtn_hpp

Generated on Tue Jan 24 16:41:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndServiceThreadForNetwork.hpp Source File

AddOns/MediaFramework/Network/ExtndServiceThreadForNetwork.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ServiceThreadExtn_hpp)
00010 #define ServiceThreadExtn_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016 #include <Kernel/ServiceThread.hpp>
00017 #include <Socket/SocketHandler.hpp>
00018 #include "EmApoxiInterface.hpp"
00019
00020
00021 class ExtndServiceThreadForNetwork: public ServiceThread
00022 {
00023
00025 public:
00027     static ExtndServiceThreadForNetwork& GetInstance();
00029     void OnPowerUp();
00031     void OnPowerDown();
00033     BOOLEAN OnMessage(const Message &msg);
00034
00035
00037
00038
00039
00040 };
00041
00042 #endif // DOXYGEN_SHOULD_SKIP_THIS
00043 #endif // ServiceThreadExtn_hpp
00044
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndTcpSocket.cpp File Reference

AddOns/MediaFramework/Network/ExtndTcpSocket.cpp File Reference

#include "ExtndTcpSocket.hpp"

Include dependency graph for ExtndTcpSocket.cpp:

Generated on Tue Jan 24 16:41:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndTcpSocket.hpp File Reference

AddOns/MediaFramework/Network/ExtndTcpSocket.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define ExtndTcpSocket_hpp

Define Documentation

#define ExtndTcpSocket_hpp

Generated on Tue Jan 24 16:41:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndTcpSocket.hpp Source File

AddOns/MediaFramework/Network/ExtndTcpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ExtndTcpSocket_hpp)
00010 #define ExtndTcpSocket_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include <Socket/DataConnManager.hpp>
00018 #include <Socket/TcpSocket.hpp>
00019
00020 #include "EmApoxiInterface.hpp"
00021
00022 class ExtndTcpSocket : public TcpSocket
00023 {
00024     typedef TcpSocket Base;
00025
00027     public:
00028
00030         ExtndTcpSocket();
00031
00033         void Init(EmSockEventCbFn a_sock_event_cb_fn, void *a_user_data);
00034
00036         ~ExtndTcpSocket();
00037
00039     protected:
00040
00043         virtual void OnAsyncEvent(Event event);
00044
00045
00047     private:
00048         EmSockEventCbFn *m_sock_event_cb_fn;
00049         void *m_sock_event_user_data;
00050
00051 }; // ExtndTcpSocket
00052
00053 #endif // DOXYGEN_SHOULD_SKIP_THIS
00054 #endif // ExtndTcpSocket_hpp
00055
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndUdpSocket.cpp File Reference

AddOns/MediaFramework/Network/ExtndUdpSocket.cpp File Reference

#include "ExtndUdpSocket.hpp"

Include dependency graph for ExtndUdpSocket.cpp:

Generated on Tue Jan 24 16:41:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndUdpSocket.hpp File Reference

AddOns/MediaFramework/Network/ExtndUdpSocket.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define UdpSocketExtn_hpp

Define Documentation

#define UdpSocketExtn_hpp

Generated on Tue Jan 24 16:41:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/ExtndUdpSocket.hpp Source File

AddOns/MediaFramework/Network/ExtndUdpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(UdpSocketExtn_hpp)
00010 #define UdpSocketExtn_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012 /*
00013     This is an internal class which should not be used by the MMI in a direct
00014     manner, and the interface may be changed in future releases.
00015 */
00016
00017 #include <Socket/DataConnManager.hpp>
00018 #include <Socket/UdpSocket.hpp>
00019
00020 #include "EmApoxiInterface.hpp"
00021
00022 class ExtndUdpSocket : public UdpSocket
00023 {
00024     typedef UdpSocket Base;
00025
00027     public:
00028
00030         ExtndUdpSocket();
00031
00033         void Init(EmSockEventCbFn a_sock_event_cb_fn, void *a_user_data);
00034
00036         ~ExtndUdpSocket();
00037
00039     protected:
00040
00043         virtual void OnAsyncEvent(Event event);
00044
00045
00047     private:
00048         EmSockEventCbFn *m_sock_event_cb_fn;
00049         void *m_sock_event_user_data;
00050
00051 }; // ExtndUdpSocket
00052
00053 #endif // DOXYGEN_SHOULD_SKIP_THIS
00054 #endif // UdpSocketExtn_hpp
00055
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/NetworkServiceThreadMsgTypes.cpp File Reference

AddOns/MediaFramework/Network/NetworkServiceThreadMsgTypes.cpp File Reference

#include "NetworkServiceThreadMsgTypes.hpp"

Include dependency graph for NetworkServiceThreadMsgTypes.cpp:

Generated on Tue Jan 24 16:41:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/NetworkServiceThreadMsgTypes.hpp File Reference

AddOns/MediaFramework/Network/NetworkServiceThreadMsgTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Common_NetworkServiceThreadMsgTypes_hpp

Define Documentation

#define Common_NetworkServiceThreadMsgTypes_hpp

Generated on Tue Jan 24 16:41:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MediaFramework/Network/NetworkServiceThreadMsgTypes.hpp Source File

AddOns/MediaFramework/Network/NetworkServiceThreadMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "ap_str_BSR_03_14\03.14.02-1_delivery\lnz_apoxi\Apoxi\MediaFramework\BinaryCompatLayer\Network\ApoxiExtensions\NetworkServiceThreadMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Common_NetworkServiceThreadMsgTypes_hpp)
00016 #define Common_NetworkServiceThreadMsgTypes_hpp
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018 /*
00019     This is an internal class which should not be used by the MMI in a direct
00020     manner, and the interface may be changed in future releases.
00021 */
00022
00023 #include <Kernel/Message.hpp>
00024 #include "EmApoxiInterface.hpp"
00025
00026
00027 /* ----------------------------------------------------------------------
00028     Classes
00029     ---------------------------------------------------------------------- */
00030
00031 /*  ======================================================================
00032     Class NetworkServiceThreadMsg
00033     ====================================================================== */
00034
00037 class NetworkServiceThreadMsg : public ContextMsg {
00038     public:
00039         NetworkServiceThreadMsg(ExecutionContext* context,
00040             const EmNetworkServiceThreadMsgType& type,
00041             EmNetworkExecCbFn *cb_fn_ptr,
00042             void *cb_fn_param);
00043         virtual ~NetworkServiceThreadMsg();
00044
00045         virtual const MsgMetaData& GetMetaData() const;
00046         void SetType(const EmNetworkServiceThreadMsgType& type) { m_type = type; }
00047         const EmNetworkServiceThreadMsgType& GetType() const { return m_type; }
00048         const EmNetworkExecCbFn *GetCbFunction() const { return mp_cb_fn; }
00049         const void *GetCbFunctionParam() const { return mp_cb_fn_param; }
00050         virtual Message* Clone() const;
00051
00052         enum  {
00053             ID = 54001
00054             };
00055
00056     private:
00057         static const MsgMetaData m_meta_data;
00058         EmNetworkServiceThreadMsgType m_type;
00059         EmNetworkExecCbFn *mp_cb_fn;
00060         void *mp_cb_fn_param;
00061
00062     };
00063
00064 #endif // DOXYGEN_SHOULD_SKIP_THIS
00065 #endif // Common_NetworkServiceThreadMsgTypes_hpp
00066
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtCommand.cpp File Reference

AddOns/MmCall/AtCommand.cpp File Reference

#include "MmCallPreComp.hpp"
#include "AtResponseIterator.hpp"
#include "SerialTerminal.hpp"

Include dependency graph for AtCommand.cpp:

Generated on Tue Jan 24 16:41:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtCommand.hpp File Reference

AddOns/MmCall/AtCommand.hpp File Reference

#include <AddOns/MmCall/AtResponse.hpp>

Include dependency graph for AtCommand.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtCommand
struct | AtCommandData
struct | AtCommandInfoTable
struct | AtCommandMetaInfo

Defines

#define | Apoxi_AtCommand_hpp

Variables

const INT | c_max_at_cmd_params = 16
number of parameters an at command can have at most
const INT | c_max_specific_at_resp_params = 5
number of specific responses a command can have at most

Define Documentation

#define Apoxi_AtCommand_hpp

Variable Documentation

const INT c_max_at_cmd_params = 16

number of parameters an at command can have at most

const INT c_max_specific_at_resp_params = 5

number of specific responses a command can have at most

Generated on Tue Jan 24 16:41:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtCommand.hpp Source File

AddOns/MmCall/AtCommand.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AtCommand_hpp)
00010 #define Apoxi_AtCommand_hpp
00011
00012 #include <AddOns/MmCall/AtResponse.hpp>
00013
00015 const INT c_max_at_cmd_params = 16;
00017 const INT c_max_specific_at_resp_params = 5;
00018
00019 struct AtCommandMetaInfo;
00020
00025 class AtCommand
00026 {
00027     public:
00029         enum Type {
00031             At = 1,
00033             Atd,
00035             Ata,
00037             Ath,
00039             AtCops,
00041             AtCbst,
00043             AtCrc,
00045             AtChld,
00047             AtColp,
00049             AtClip,
00051             AtClir,
00053             AtCmee,
00055             AtCeer,
00057             AtClcc,
00059             AtXcallstat,
00061             AtXservice,
00063             AtXceer,
00065             AtXcallrefuse,
00067             AtXprogress,
00069             AtCgactQuery,
00071             AtCgact,
00073             AtXcaoc,
00075             AtTypeInvalid
00076         };
00077
00085         AtCommand(Type type, const String parameters[], UINT8 param_cnt);
00086
00087
00091         ~AtCommand();
00092
00094         Type GetType() const { return m_type; };
00095
00102         const String ToString() const;
00103
00108         static BOOLEAN IsTerminatingResponse(AtCommand::Type cmd, AtResponse::ResponseType resp);
00109
00110     private:
00112         AtCommand();
00113
00115         Type m_type;
00116
00118         String m_parameters[c_max_at_cmd_params];
00119
00121         UINT8 m_param_cnt;
00122
00124         static const AtCommandMetaInfo m_command_info_table[];
00125 };
00126
00130 struct AtCommandMetaInfo {
00131     AtCommand::Type             m_command_type;
00132     CHAR *                      m_str_presentation;
00133     INT                         m_specific_resp_cnt;
00134     AtResponse::ResponseType    m_specific_responses[c_max_specific_at_resp_params];
00135 };
00136
00140 struct AtCommandData {
00141     AtCommand::Type m_command_type;
00142     CHAR * m_parameters[c_max_at_cmd_params];
00143     INT m_number_of_params;
00144
00145 };
00146
00151 struct AtCommandInfoTable {
00152     public:
00153
00157         static INT GetNumberOfEntries() { return c_command_info_size; };
00158
00163         static const AtCommandMetaInfo *GetElementAt(INT index) { return &c_command_info_table[index]; };
00164
00165     private:
00167         static const AtCommandMetaInfo c_command_info_table[];
00168
00170         static UINT c_command_info_size;
00171 };
00172
00173 #endif /* Apoxi_AtResponseIterator_hpp */
00174
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtResponse.cpp File Reference

AddOns/MmCall/AtResponse.cpp File Reference

#include "MmCallPreComp.hpp"
#include "AtResponse.hpp"

Include dependency graph for AtResponse.cpp:

Generated on Tue Jan 24 16:41:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtResponse.hpp File Reference

AddOns/MmCall/AtResponse.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtResponse
struct | AtResponseInfoTable
struct | AtResponseMetaInfo
Structure to hold responses and their string representation. More...
struct | AtResponseParameter

Defines

#define | Apoxi_AtResponse_hpp

Variables

const INT | c_max_at_resp_params = 16
number of parameters a response can have at most

Define Documentation

#define Apoxi_AtResponse_hpp

Variable Documentation

const INT c_max_at_resp_params = 16

number of parameters a response can have at most

Generated on Tue Jan 24 16:41:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtResponse.hpp Source File

AddOns/MmCall/AtResponse.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AtResponse_hpp)
00010 #define Apoxi_AtResponse_hpp
00011
00013 const INT c_max_at_resp_params = 16;
00014
00015 class SerialTerminal;
00016 class AtResponseIterator;
00017 struct AtResponseMetaInfo;
00018
00024 struct AtResponseParameter
00025 {
00026     public:
00027
00029         enum  ParamType {
00031             PtNumeric,
00033             PtString,
00035             PtNoValue
00036         };
00037
00039         AtResponseParameter();
00040
00042         AtResponseParameter(const AtResponseParameter& parameter);
00043
00045         ~AtResponseParameter();
00046
00048         AtResponseParameter& operator = (const AtResponseParameter& parameter);
00050         INT32 GetIntegerValue() const { return m_int_val; };
00051
00053         const String &GetStringValue() const { return m_str_val; };
00054
00056         ParamType GetParameterType() const { return m_param_type; };
00057
00058         friend AtResponseIterator;
00059
00060     private:
00061
00063         INT32       m_int_val;
00065         String      m_str_val;
00066
00068         ParamType   m_param_type;
00069 };
00070
00076 class AtResponse
00077 {
00078     public:
00080         enum ResponseType {
00082             Ok,
00084             Connect,
00086             Ring,
00088             NoCarrier,
00090             Error,
00092             NoDialtone,
00094             Busy,
00096             NoAnswer,
00098             Calv,
00100             Ccwa,
00102             Ccwv,
00104             Cdev,
00106             Cdip,
00108             Ciev,
00110             Ckev,
00112             Clav,
00114             Clip,
00116             CmeError,
00118             Colp,
00120             Cr,
00122             Creg,
00124             Cring,
00126             Cssi,
00128             Cssu,
00130             Ctzv,
00132             Cusd,
00134             Clcc,
00136             Cuus1i,
00138             Cuus1u,
00140             Dr,
00142             Ilrr,
00144             Xcallstat,
00146             Xcallinfo,
00148             Xceer,
00150             Xcallrefuse,
00152             Xprogress,
00154             Cgact,
00156             Xcaoc,
00158             Xcharge,
00160             Xcccm,
00162             Xccharge,
00164             XaocService,
00165
00167             UnknownResponse,
00169             FatalError
00170         };
00171
00173         AtResponse();
00174
00176         AtResponse(const AtResponse& response);
00177
00179         ~AtResponse();
00180
00182         AtResponse& operator= (const AtResponse& response);
00183
00185         ResponseType GetResponseType() const { return m_response_type; };
00186
00188         void SetResponseType(ResponseType type) { m_response_type = type; };
00189
00190
00198         const AtResponseParameter& GetParameterAt(const UINT8 index) const {return m_parameter_list[index];};
00199
00201         INT GetNrOfParameters() const { return m_nr_of_parameters; };
00202
00204         static const String GetResponseString(AtResponse::ResponseType type);
00205
00206         friend AtResponseIterator;
00207
00208     private:
00210         ResponseType        m_response_type;
00212         AtResponseParameter m_parameter_list[c_max_at_resp_params];
00214         INT                 m_nr_of_parameters;
00215 };
00216
00217
00219 struct AtResponseMetaInfo {
00220     AtResponse::ResponseType    m_response_type;
00221     CHAR *                      m_str_presentation;
00222 };
00223
00228 struct AtResponseInfoTable {
00229     public:
00230
00234         static INT GetNumberOfEntries() { return c_response_info_size; };
00235
00240         static const AtResponseMetaInfo *GetElementAt(INT index) { return &c_response_info_table[index]; };
00241
00242     private:
00244         static const AtResponseMetaInfo c_response_info_table[];
00245
00247         static UINT c_response_info_size;
00248 };
00249
00250 #endif /* Apoxi_AtResponseIterator_hpp */
00251
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtResponseIterator.cpp File Reference

AddOns/MmCall/AtResponseIterator.cpp File Reference

#include "MmCallPreComp.hpp"
#include <Auxiliary/String.hpp>
#include "AtResponseIterator.hpp"
#include "SerialTerminal.hpp"

Include dependency graph for AtResponseIterator.cpp:

Generated on Tue Jan 24 16:41:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtResponseIterator.hpp File Reference

AddOns/MmCall/AtResponseIterator.hpp File Reference

#include <AddOns/MmCall/AtCommand.hpp>
#include <AddOns/MmCall/AtResponse.hpp>

Include dependency graph for AtResponseIterator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtResponseIterator

Defines

#define | Apoxi_AtResponseIterator_hpp

Variables

const INT | c_it_buffer_size = 128
size of buffer in at response iterator
const INT | c_it_read_size = 1
size of bytes to read while parsing in at response iterator

Define Documentation

#define Apoxi_AtResponseIterator_hpp

Variable Documentation

const INT c_it_buffer_size = 128

size of buffer in at response iterator

const INT c_it_read_size = 1

size of bytes to read while parsing in at response iterator

Generated on Tue Jan 24 16:41:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/AtResponseIterator.hpp Source File

AddOns/MmCall/AtResponseIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AtResponseIterator_hpp)
00010 #define Apoxi_AtResponseIterator_hpp
00011
00012 #include <AddOns/MmCall/AtCommand.hpp>
00013 #include <AddOns/MmCall/AtResponse.hpp>
00014
00016 const INT c_it_buffer_size = 128;
00018 const INT c_it_read_size = 1;
00019
00025 class AtResponseIterator
00026 {
00027     public:
00029         AtResponseIterator(SerialTerminal* terminal);
00030
00032         virtual ~AtResponseIterator();
00033
00037         BOOLEAN HasMoreResponses();
00038
00043         const AtResponse GetNextResponse();
00044
00045     private:
00052         static AtResponse::ResponseType ParseResponseType(const String &at_response);
00053
00061         static void ParseResponse(const String &at_response, AtResponse& structured_response);
00062
00063
00065         SerialTerminal* m_terminal;
00066
00068         AtResponse m_current_response;
00069
00074         BOOLEAN m_received_connect;
00075
00077         CHAR m_response_buffer[c_it_buffer_size];
00078
00080         UINT m_buffer_index;
00081
00083         UINT m_next_response_index;
00084
00086         BOOLEAN m_has_more_responses_called;
00087 };
00088
00089 #endif /* Apoxi_AtResponseIterator_hpp */
00090
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallDispatcher.cpp File Reference

AddOns/MmCall/MmCallDispatcher.cpp File Reference

#include "MmCallPreComp.hpp"
#include "MmCallDispatcher.hpp"
#include <Apc/Message.hpp>
#include "AtResponseIterator.hpp"
#include "MmCallHandler.hpp"
#include "SerialTerminalArg.hpp"

Include dependency graph for MmCallDispatcher.cpp:

Generated on Tue Jan 24 16:41:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallDispatcher.hpp File Reference

AddOns/MmCall/MmCallDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Message.hpp>
#include <Apc/StackMsgArgument.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for MmCallDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmCallDispatcher

Defines

#define | Apoxi_MmCallDispatcher_hpp

Define Documentation

#define Apoxi_MmCallDispatcher_hpp

Generated on Tue Jan 24 16:41:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallDispatcher.hpp Source File

AddOns/MmCall/MmCallDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_MmCallDispatcher_hpp)
00009 #define Apoxi_MmCallDispatcher_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Message.hpp>
00013 #include <Apc/StackMsgArgument.hpp>
00014 #include <Asc/StackMsgDispatcher.hpp>
00015
00016 class MmCallHandler;
00017
00020 class MmCallDispatcher : public StackMsgDispatcher {
00021
00022     typedef StackMsgDispatcher Base;
00023     public:
00024
00029         MmCallDispatcher(MmCallHandler* call_handler);
00030
00032         virtual ~MmCallDispatcher();
00033
00034     protected:
00035
00037         BOOLEAN OnTerminalEvent(const StackMsgArgument &arg);
00038
00039     private:
00041         MmCallHandler* m_call_handler;
00042
00046         static const StackMsgArgMap<MmCallDispatcher> m_arg_map[];
00047
00050         StackMsgArgMapContainer<MmCallDispatcher> m_arg_map_container;
00051
00052 };
00053
00054 #endif // Apoxi_MmCallDispatcher_hpp
00055
00056
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallHandler.cpp File Reference

AddOns/MmCall/MmCallHandler.cpp File Reference

#include "MmCallPreComp.hpp"
#include <Asc/MainHandler.hpp>
#include <Apc/SignalTypes.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include "MmCallHandler.hpp"
#include "AtResponseIterator.hpp"
#include "MmCallMessages.hpp"
#include "MmTypes.hpp"
#include "XCallInfoResponseParser.hpp"

Include dependency graph for MmCallHandler.cpp:

Generated on Tue Jan 24 16:41:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallHandler.hpp File Reference

AddOns/MmCall/MmCallHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/Types.hpp>
#include <Asc/BaseHandler.hpp>
#include <AddOns/MmCall/SerialTerminal.hpp>
#include <AddOns/MmCall/AtResponseIterator.hpp>
#include <AddOns/MmCall/MmTypes.hpp>
#include <AddOns/MmCall/MmCallInfo.hpp>
#include <AddOns/MmCall/MmCallDispatcher.hpp>
#include <AddOns/MmCall/MmCallSerialTerminalListener.hpp>

Include dependency graph for MmCallHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmCallHandler

Defines

#define | APOXI_CONFIG_MAX_MM_CALLS 2
#define | Apoxi_MmCallHandler_hpp

Variables

const UINT8 | c_mm_call_terminal_data_bits = 8
Default data bits for control and data terminal.
const UINT | c_mm_call_terminal_speed = 64000
Default connection speed for control and data terminal.
const UINT8 | c_mm_call_terminal_stop_bits = 1
Default stop bits for control and data terminal.

Define Documentation

#define APOXI_CONFIG_MAX_MM_CALLS 2

#define Apoxi_MmCallHandler_hpp

Variable Documentation

const UINT8 c_mm_call_terminal_data_bits = 8

Default data bits for control and data terminal.

const UINT c_mm_call_terminal_speed = 64000

Default connection speed for control and data terminal.

const UINT8 c_mm_call_terminal_stop_bits = 1

Default stop bits for control and data terminal.

Generated on Tue Jan 24 16:41:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallHandler.hpp Source File

AddOns/MmCall/MmCallHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_MmCallHandler_hpp)
00009 #define Apoxi_MmCallHandler_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Asc/Types.hpp>
00013 #include <Asc/BaseHandler.hpp>
00014 #include <AddOns/MmCall/SerialTerminal.hpp>
00015 #include <AddOns/MmCall/AtResponseIterator.hpp>
00016 #include <AddOns/MmCall/MmTypes.hpp>
00017 #include <AddOns/MmCall/MmCallInfo.hpp>
00018 #include <AddOns/MmCall/MmCallDispatcher.hpp>
00019 #include <AddOns/MmCall/MmCallSerialTerminalListener.hpp>
00020
00021
00022 #ifndef APOXI_CONFIG_MAX_MM_CALLS
00023     #define APOXI_CONFIG_MAX_MM_CALLS 2
00024 #endif
00025
00026
00028 const UINT  c_mm_call_terminal_speed = 64000;
00029
00031 const UINT8  c_mm_call_terminal_stop_bits = 1;
00032
00034 const UINT8  c_mm_call_terminal_data_bits = 8;
00035
00046 class MmCallHandler : public BaseHandler {
00047
00048     typedef BaseHandler Base;
00049     friend MmCallDispatcher;
00050     public:
00051
00053         MmCallHandler();
00055         virtual ~MmCallHandler();
00056
00058         virtual HandlerId GetHandlerId() const { return MmCallHandlerId; };
00059
00072         CallApiRc Setup(const CallIndex call_index, const PhoneNumber &phone_no, ClirMode clir_mode = DontCare);
00073
00084         CallApiRc Accept(const CallIndex call_index);
00085
00093         #if defined(APOXI_SYNC_RELEASE)
00094             CallApiRc Reject(const CallIndex call_index, ClearCause cause = SubscriberBusy, BOOLEAN wait_condition = TRUE);
00095         #else
00096             CallApiRc Reject(const CallIndex call_index, ClearCause cause = SubscriberBusy, BOOLEAN wait_condition = FALSE);
00097         #endif
00098
00104         CallApiRc RejectAllMtc(BOOLEAN activate);
00105
00119         #if defined(APOXI_SYNC_RELEASE)
00120             virtual CallApiRc Release(const CallIndex call_index, TimeSpan *calling_time = 0, BOOLEAN wait_condition = TRUE);
00121         #else
00122             virtual CallApiRc Release(const CallIndex call_index, TimeSpan *calling_time = 0, BOOLEAN wait_condition = FALSE);
00123         #endif
00124
00125
00133         void ReportCurrentCallMeter(BOOLEAN activate);
00134
00135
00143         void ReportCurrentCharge(BOOLEAN activate);
00144
00150         CallApiRc GetCurrentChargeData(const CallIndex call_index);
00151
00152
00159         CallApiRc GetCurrentCallMeter(const CallIndex call_index);
00160
00165         Socket *GetSocket(CallIndex call_index);
00166
00168         BOOLEAN IsMmCall(CallIndex call_index) const;
00169
00172         BOOLEAN IsMobileOriginated(CallIndex call_index) const;
00173
00174
00177         BOOLEAN IsMobileTerminated(CallIndex call_index) const;
00178
00184         BOOLEAN IsInOnlineMode(SerialTerminal *terminal);
00185
00191         void OnTerminalResponse(SerialTerminal *terminal, const AtResponse &response);
00192
00197         BOOLEAN IsPsdCallActive();
00198
00202         void DisconnectActivePsdCalls();
00203
00204     private:
00209         void OnXCallStat(UINT8 call_id, XCallStat call_stat_value);
00210
00215         void OnXCallInfo(const AtResponse &response);
00216
00217
00221         void OnXProgress(INT call_id, INT tones_available);
00222
00226         void OnCRing();
00227
00230         void OnColp(const CHAR *phonenumber);
00231
00236         void OnConnect(SerialTerminal *terminal);
00237
00242         void OnXcaoc(const String& accumulated_call_meter, const String& current_call_meter);
00243
00250         void OnXcharge(const String& accumulated_charge_data, const INT exponent_accumulated_charge_data,
00251                     const String& current_charge_data, const INT exponent_current_charge_data);
00252
00253
00260         void OnXcccm(const String& accumulated_call_meter, const String& current_call_meter);
00261
00270         void OnXccharge(const String& accumulated_charge_data, const INT exponent_accumulated_charge_data,
00271                     const String& current_charge_data, const INT exponent_current_charge_data);
00272
00276         void OnXaocService(const Tipd tipd, const INT service_state);
00277
00278
00282         void OnCgact();
00283
00287         void SendMmCurrentCallMeterMsg(const CallIndex call_index);
00288
00292         void SendMmCurrentChargeDataMsg(const CallIndex call_index);
00293
00300         virtual BOOLEAN Init(MainHandler *main_handler);
00301
00307         void SendCallEventMsg(CallEvent::Action action, CallIndex call_index);
00308
00318         CallApiRc CloseCall(CallIndex call_index,
00319                             UINT32 &call_duration,
00320                             CallErrorCause cause,
00321                             BOOLEAN wait_condition);
00322
00327         BOOLEAN InitControlTerminal();
00328
00334         BOOLEAN AddCallInfo(CallIndex call_index);
00335
00342         BOOLEAN InvalidateCallInfo(CallIndex call_index);
00343
00350         const MmCallInfo *GetCallInfo(CallIndex call_index) const;
00351
00355         MmCallInfo *GetCallInfo(CallIndex call_index);
00356
00362         INT16 GetCallIdForIndex(CallIndex call_index) const;
00363
00369         CallIndex GetCallIndexForId(UINT8 call_id) const;
00370
00376         CallIndex GetIndexForTerminal(SerialTerminal *terminal) const;
00377
00387         AtResponse WriteAtCmd(const AtCommand &command, SerialTerminal *terminal);
00388
00394         AtResponse WaitForAtResponse(SerialTerminal *terminal);
00395
00399         static UINT32 ConvertCccmValue(const String& hex_string);
00400
00402         AtResponse                          m_received_response;
00403
00405         SerialTerminal*                     m_control_terminal;
00406
00408         MmCallInfo                          m_call_info[APOXI_CONFIG_MAX_MM_CALLS];
00409
00411         // Hack to simulate missing "CONNECT" from stack
00412         BooleanCondition                    m_wait_for_data;
00413
00415         BOOLEAN                             m_waiting_for_data_term_resp;
00416
00418         BooleanCondition                    m_wait_for_control_data;
00419
00424         BooleanCondition                    m_wait_for_disconnect_conf;
00425
00427         BOOLEAN                             m_wait_for_disconnect;
00428
00430         MmCallDispatcher                    m_mm_call_dispatcher;
00431
00433         AtResponse                          m_last_call_setup_xcallinfo_response;
00434
00439         MmCallSerialTerminalListener        m_mm_call_st_listener;
00440
00442         UINT32                              m_current_call_meter;
00443
00445         UINT32                              m_accumulated_call_meter;
00446
00448         UINT32                              m_current_call_charge;
00449
00451         UINT32                              m_accumulated_charge;
00452
00454         INT                                 m_current_call_charge_exponent;
00455
00457         INT                                 m_accumulated_charge_exponent;
00458
00459         // TODO: Check number of PSD calls
00460         BOOLEAN                             m_is_psd_call_active;
00461
00462         static const AtCommandData          c_init_sequence[];
00463
00464         static const INT                    c_no_of_init_params;
00465
00466         static const INT                    c_no_of_response_checks;
00467 };
00468
00469
00470 #endif // Apoxi_MmCallDispatcher_hpp
00471
00472
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallHdl.cpp File Reference

AddOns/MmCall/MmCallHdl.cpp File Reference

#include "MmCallPreComp.hpp"
#include "MmCallHdl.hpp"
#include "MmCallHandler.hpp"
#include <Asc/StackControl.hpp>

Include dependency graph for MmCallHdl.cpp:

Generated on Tue Jan 24 16:41:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallHdl.hpp File Reference

AddOns/MmCall/MmCallHdl.hpp File Reference

#include <Asc/Types.hpp>
#include <Auxiliary/PhoneNumber.hpp>

Include dependency graph for MmCallHdl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmCallHdl
Class to establish and release Mm calls. Calls are identified by a call_index. More...

Defines

#define | Apoxi_AddOns_MmCallHdl_hpp

Define Documentation

#define Apoxi_AddOns_MmCallHdl_hpp

Generated on Tue Jan 24 16:41:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallHdl.hpp Source File

AddOns/MmCall/MmCallHdl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AddOns_MmCallHdl_hpp)
00009 #define Apoxi_AddOns_MmCallHdl_hpp
00010
00011 #include <Asc/Types.hpp>
00012 #include <Auxiliary/PhoneNumber.hpp>
00013 class Socket;
00014
00016 class MmCallHdl {
00017
00018     public:
00019
00020         //---------------------------------------------------------------------
00021         // Construction, destruction initialization
00022         //---------------------------------------------------------------------
00023
00028         MmCallHdl(CallIndex call_index = c_null_call_index);
00029
00031         virtual ~MmCallHdl();
00032
00033         // --------------------------------------------------------------------
00034         // call related operations on CallHdl
00035         // --------------------------------------------------------------------
00036
00037
00058         CallApiRc Setup(const PhoneNumber & phone_no,
00059                         ClirMode clir_mode = DontCare);
00060
00061
00071         CallApiRc Accept();
00072
00073
00085 #if defined(APOXI_SYNC_RELEASE)
00086         virtual CallApiRc Release(TimeSpan * calling_time = 0, BOOLEAN wait_condition = TRUE);
00087 #else
00088         virtual CallApiRc Release(TimeSpan * calling_time = 0, BOOLEAN wait_condition = FALSE);
00089 #endif
00090
00091
00098 #if defined(APOXI_SYNC_RELEASE)
00099         CallApiRc Reject(ClearCause cause = SubscriberBusy, BOOLEAN wait_condition = TRUE);
00100 #else
00101         CallApiRc Reject(ClearCause cause = SubscriberBusy, BOOLEAN wait_condition = FALSE);
00102 #endif
00103
00110         static void ReportCurrentCallMeter(BOOLEAN activate);
00111
00112
00120         static void ReportCurrentCharge(BOOLEAN activate);
00121
00127         CallApiRc GetCurrentCallMeter();
00128
00129
00136         CallApiRc GetCurrentChargeData();
00137
00138
00139         // --------------------------------------------------------------------
00140         // access to miscellaneous call data
00141         // --------------------------------------------------------------------
00142
00151         const PhoneNumber & GetPhoneNumber() const;
00152
00161         const PhoneNumber & GetConnectedToPhoneNumber() const;
00162
00163
00169         virtual DateTime GetStartTime() const;
00170
00171
00172         // --------------------------------------------------------------------
00173         // general information of call referred by a CallHdl
00174         // --------------------------------------------------------------------
00175
00178         virtual BOOLEAN IsActive() const;
00179
00180
00183         BOOLEAN IsInSetup() const;
00184
00185
00190         BOOLEAN operator==(const MmCallHdl & call) const;
00191
00192
00197         virtual BOOLEAN IsValid() const;
00198
00201         BOOLEAN IsMobileOriginated() const;
00202
00203
00206         BOOLEAN IsMobileTerminated() const;
00207
00208
00209         // --------------------------------------------------------------------
00210         // misc
00211         // --------------------------------------------------------------------
00212
00218         static CallApiRc RejectAllMtc(BOOLEAN activate);
00219
00221         BOOLEAN IsSetupPermitted() const;
00222
00224         BOOLEAN IsAcceptPermitted() const;
00225
00227         virtual void Invalidate() { m_call_index = c_null_call_index; }
00228
00230         virtual CallIndex GetCallIndex() const { return m_call_index; }
00231
00233         CallType GetCallType() const;
00234
00239         static BOOLEAN IsPsdCallActive();
00240
00244         static void DisconnectActivePsdCalls();
00245
00253         virtual TimeSpan GetCallDuration() const;
00254
00259         Socket* GetSocket() const;
00260
00262         ClirMode GetClirMode() const;
00263
00264     private:
00266         CallIndex   m_call_index;
00267 };
00268
00269 #endif // Apoxi_AddOns_MmCallHdl_hpp
00270
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallInfo.cpp File Reference

AddOns/MmCall/MmCallInfo.cpp File Reference

#include "MmCallPreComp.hpp"
#include "MmCallInfo.hpp"
#include <Asc/CallHandlingData.hpp>
#include <Asc/MainHandler.hpp>
#include <Asc/StackControl.hpp>
#include "MmCallHandler.hpp"

Include dependency graph for MmCallInfo.cpp:

Generated on Tue Jan 24 16:42:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallInfo.hpp File Reference

AddOns/MmCall/MmCallInfo.hpp File Reference

#include <Asc/Types.hpp>
#include "SerialTerminalSocket.hpp"
#include "SerialTerminal.hpp"

Include dependency graph for MmCallInfo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmCallInfo

Defines

#define | Apoxi_MmCallInfo_hpp

Define Documentation

#define Apoxi_MmCallInfo_hpp

Generated on Tue Jan 24 16:42:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallInfo.hpp Source File

AddOns/MmCall/MmCallInfo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_MmCallInfo_hpp)
00009 #define Apoxi_MmCallInfo_hpp
00010
00011 #include <Asc/Types.hpp>
00012 #include "SerialTerminalSocket.hpp"
00013 #include "SerialTerminal.hpp"
00014
00019 class MmCallInfo {
00020     public:
00022         enum CallState {
00024             InSetup,
00026             InAccept,
00028             InReject,
00030             InRelease,
00032             InCall,
00034             Closed
00035         };
00036
00038         enum CallDirection {
00040             MobileOriginatedCall,
00042             MobileTerminatedCall,
00044             NoCall
00045         };
00046
00048         MmCallInfo();
00049
00051         ~MmCallInfo();
00052
00054         void Invalidate();
00055
00057         void SetCallIndex(CallIndex call_index) {m_call_index = call_index;};
00058
00060         CallIndex GetCallIndex() const  {return m_call_index;};
00061
00063         void SetCallId(INT8 call_id) {m_call_id = call_id;};
00064
00066         INT8 GetCallId() const  {return m_call_id;};
00067
00069         void SetCallDirection(CallDirection call_dir) { m_calldir = call_dir; };
00070
00072         CallDirection GetCallDirection() const { return m_calldir; };
00073
00075         void SetCallState(CallState state) { m_call_state = state; };
00076
00078         CallState GetCallState() const { return m_call_state; };
00079
00081         void SetOnlineMode(BOOLEAN in_online_mode) { m_online_mode = in_online_mode; };
00082
00084         BOOLEAN IsInOnlineMode() const {return m_online_mode;};
00085
00089         SerialTerminalSocket* GetSocket() { return &m_data_socket; };
00090
00094         SerialTerminal* GetDataTerminal() const { return m_data_terminal;};
00095
00096     private:
00097
00099         void InitMmCallInfo();
00100
00102         CallIndex               m_call_index;
00104         INT8                    m_call_id;
00106         SerialTerminalSocket    m_data_socket;
00108         SerialTerminal *        m_data_terminal;
00110         BOOLEAN                 m_online_mode;
00112         CallDirection           m_calldir;
00114         CallState               m_call_state;
00115
00116 };
00117
00118 #endif
00119
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallMessages.cpp File Reference

AddOns/MmCall/MmCallMessages.cpp File Reference

#include "MmCallPreComp.hpp"
#include "MmCallMessages.hpp"

Include dependency graph for MmCallMessages.cpp:

Generated on Tue Jan 24 16:42:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallMessages.hpp File Reference

AddOns/MmCall/MmCallMessages.hpp File Reference

#include <Kernel/Message.hpp>
#include <Asc/Types.hpp>
#include <Apc/SignalTypes.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <AddOns/MmCall/MmTypes.hpp>

Include dependency graph for MmCallMessages.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmAocChargingStatusMsg
class | MmCallAcceptMsg
class | MmCallDisconnectingMsg
class | MmCallInfoMsg
class | MmCallNotifyMsg
class | MmCallReleaseMsg
class | MmCallSetupProgressMsg
class | MmCallStatusMsg
class | MmCurrentCallMeterMsg
class | MmCurrentChargeDataMsg
class | MmMocSetupAcceptMsg

Defines

#define | MmCallMessages_hpp__ST_1136454671281

Define Documentation

#define MmCallMessages_hpp__ST_1136454671281

Generated on Tue Jan 24 16:42:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallMessages.hpp Source File

AddOns/MmCall/MmCallMessages.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "hartmanw_mpeutest_sv\lnz_apoxi\Apoxi\AddOns\MmCall\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014 #if !defined(MmCallMessages_hpp__ST_1136454671281)
00015 #define MmCallMessages_hpp__ST_1136454671281
00016 #include <Kernel/Message.hpp>
00017 #include <Asc/Types.hpp>
00018 #include <Apc/SignalTypes.hpp>
00019 #include <Auxiliary/PhoneNumber.hpp>
00020 #include <AddOns/MmCall/MmTypes.hpp>
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024 /*  ======================================================================
00025     Class MmCallStatusMsg
00026     ====================================================================== */
00028 class MmCallStatusMsg : public ContextMsg {
00029     public:
00030         MmCallStatusMsg(ExecutionContext* context, const MmCallState& state, const CallIndex& call_index);
00031         virtual ~MmCallStatusMsg();
00032
00033         virtual const MsgMetaData& GetMetaData() const;
00034         const MmCallState& GetState() const { return m_state; }
00035         const CallIndex& GetCallIndex() const { return m_call_index; }
00036         virtual Message* Clone() const;
00037
00038         enum  {
00039             ID = 19110
00040             };
00041
00042     private:
00043         static const MsgMetaData m_meta_data;
00044         MmCallState m_state;
00045         CallIndex m_call_index;
00046
00047     };
00048 /*  ======================================================================
00049     Class MmCallDisconnectingMsg
00050     ====================================================================== */
00052 class MmCallDisconnectingMsg : public MmCallStatusMsg {
00053     public:
00054         MmCallDisconnectingMsg(ExecutionContext* context, const MmCallState& state, const CallIndex& call_index, const PhoneNumber& phone_number, const CallErrorCause& error_cause, UINT32 call_duration_in_secs);
00055         virtual ~MmCallDisconnectingMsg();
00056
00057         virtual const MsgMetaData& GetMetaData() const;
00058         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00059         const CallErrorCause& GetErrorCause() const { return m_error_cause; }
00060         UINT32 GetCallDurationInSecs() const { return m_call_duration_in_secs; }
00061         virtual Message* Clone() const;
00062
00063         enum  {
00064             ID = 19111
00065             };
00066
00067     private:
00068         static const MsgMetaData m_meta_data;
00069         PhoneNumber m_phone_number;
00070         CallErrorCause m_error_cause;
00071         UINT32 m_call_duration_in_secs;
00072
00073     };
00074 /*  ======================================================================
00075     Class MmMocSetupAcceptMsg
00076     ====================================================================== */
00078 class MmMocSetupAcceptMsg : public MmCallStatusMsg {
00079     public:
00080         MmMocSetupAcceptMsg(ExecutionContext* context, const MmCallState& state, const CallIndex& call_index, BOOLEAN est_cause_changed);
00081         virtual ~MmMocSetupAcceptMsg();
00082
00083         virtual const MsgMetaData& GetMetaData() const;
00084         BOOLEAN IsEstCauseChanged() const { return m_est_cause_changed; }
00085         virtual Message* Clone() const;
00086
00087         enum  {
00088             ID = 19112
00089             };
00090
00091     private:
00092         static const MsgMetaData m_meta_data;
00093         BOOLEAN m_est_cause_changed;
00094
00095     };
00096 /*  ======================================================================
00097     Class MmCallSetupProgressMsg
00098     ====================================================================== */
00100 class MmCallSetupProgressMsg : public MmCallStatusMsg {
00101     public:
00102         MmCallSetupProgressMsg(ExecutionContext* context, const MmCallState& state, const CallIndex& call_index, const CallProgressInd& progress_indication);
00103         virtual ~MmCallSetupProgressMsg();
00104
00105         virtual const MsgMetaData& GetMetaData() const;
00106         const CallProgressInd& GetProgressIndication() const { return m_progress_indication; }
00107         virtual Message* Clone() const;
00108
00109         enum  {
00110             ID = 19113
00111             };
00112
00113     private:
00114         static const MsgMetaData m_meta_data;
00115         CallProgressInd m_progress_indication;
00116
00117     };
00118 /*  ======================================================================
00119     Class MmCallInfoMsg
00120     ====================================================================== */
00122 class MmCallInfoMsg : public ContextMsg {
00123     public:
00124         MmCallInfoMsg(ExecutionContext* context, const CallIndex& call_index, const CallState& call_state, const CallType& call_type);
00125         virtual ~MmCallInfoMsg();
00126
00127         virtual const MsgMetaData& GetMetaData() const;
00128         const CallIndex& GetCallIndex() const { return m_call_index; }
00129         const CallState& GetCallState() const { return m_call_state; }
00130         const CallType& GetCallType() const { return m_call_type; }
00131         virtual Message* Clone() const;
00132
00133         enum  {
00134             ID = 19114
00135             };
00136
00137     private:
00138         static const MsgMetaData m_meta_data;
00139         CallIndex m_call_index;
00140         CallState m_call_state;
00141         CallType m_call_type;
00142
00143     };
00144 /*  ======================================================================
00145     Class MmCallNotifyMsg
00146     ====================================================================== */
00148 class MmCallNotifyMsg : public ContextMsg {
00149     public:
00150         MmCallNotifyMsg(ExecutionContext* context, const CallIndex& call_index, const NotificationDescription& notification_description);
00151         virtual ~MmCallNotifyMsg();
00152
00153         virtual const MsgMetaData& GetMetaData() const;
00154         const CallIndex& GetCallIndex() const { return m_call_index; }
00155         const NotificationDescription& GetNotificationDescription() const { return m_notification_description; }
00156         virtual Message* Clone() const;
00157
00158         enum  {
00159             ID = 19115
00160             };
00161
00162     private:
00163         static const MsgMetaData m_meta_data;
00164         CallIndex m_call_index;
00165         NotificationDescription m_notification_description;
00166
00167     };
00168 /*  ======================================================================
00169     Class MmCurrentChargeDataMsg
00170     ====================================================================== */
00172 class MmCurrentChargeDataMsg : public ContextMsg {
00173     public:
00174         MmCurrentChargeDataMsg(ExecutionContext* context, const CallIndex& call_index, const AocChargeData& current_call_charge, const AocChargeData& accumulated_call_charge);
00175         virtual ~MmCurrentChargeDataMsg();
00176
00177         virtual const MsgMetaData& GetMetaData() const;
00178         const CallIndex& GetCallIndex() const { return m_call_index; }
00179         const AocChargeData& GetCurrentCallCharge() const { return m_current_call_charge; }
00180         const AocChargeData& GetAccumulatedCallCharge() const { return m_accumulated_call_charge; }
00181         virtual Message* Clone() const;
00182
00183         enum  {
00184             ID = 19116
00185             };
00186
00187     private:
00188         static const MsgMetaData m_meta_data;
00189         CallIndex m_call_index;
00190         AocChargeData m_current_call_charge;
00191         AocChargeData m_accumulated_call_charge;
00192
00193     };
00194 /*  ======================================================================
00195     Class MmCurrentCallMeterMsg
00196     ====================================================================== */
00198 class MmCurrentCallMeterMsg : public ContextMsg {
00199     public:
00200         MmCurrentCallMeterMsg(ExecutionContext* context, const CallIndex& call_index, ULONG current_call_ccm, ULONG accumulated_call_ccm);
00201         virtual ~MmCurrentCallMeterMsg();
00202
00203         virtual const MsgMetaData& GetMetaData() const;
00204         const CallIndex& GetCallIndex() const { return m_call_index; }
00205         ULONG GetCurrentCallCcm() const { return m_current_call_ccm; }
00206         ULONG GetAccumulatedCallCcm() const { return m_accumulated_call_ccm; }
00207         virtual Message* Clone() const;
00208
00209         enum  {
00210             ID = 19117
00211             };
00212
00213     private:
00214         static const MsgMetaData m_meta_data;
00215         CallIndex m_call_index;
00216         ULONG m_current_call_ccm;
00217         ULONG m_accumulated_call_ccm;
00218
00219     };
00220 /*  ======================================================================
00221     Class MmAocChargingStatusMsg
00222     ====================================================================== */
00224 class MmAocChargingStatusMsg : public ContextMsg {
00225     public:
00226         MmAocChargingStatusMsg(ExecutionContext* context, const CallIndex& call_index, const AocChargingStatus& aoc_charging_status);
00227         virtual ~MmAocChargingStatusMsg();
00228
00229         virtual const MsgMetaData& GetMetaData() const;
00230         const CallIndex& GetCallIndex() const { return m_call_index; }
00231         const AocChargingStatus& GetAocChargingStatus() const { return m_aoc_charging_status; }
00232         virtual Message* Clone() const;
00233
00234         enum  {
00235             ID = 19118
00236             };
00237
00238     private:
00239         static const MsgMetaData m_meta_data;
00240         CallIndex m_call_index;
00241         AocChargingStatus m_aoc_charging_status;
00242
00243     };
00244 /*  ======================================================================
00245     Class MmCallAcceptMsg
00246     ====================================================================== */
00248 class MmCallAcceptMsg : public Message {
00249     public:
00250         MmCallAcceptMsg(const CallIndex& call_index);
00251         virtual ~MmCallAcceptMsg();
00252
00253         virtual const MsgMetaData& GetMetaData() const;
00254         const CallIndex& GetCallIndex() const { return m_call_index; }
00255         virtual Message* Clone() const;
00256
00257         enum  {
00258             ID = 19119
00259             };
00260
00261     private:
00262         static const MsgMetaData m_meta_data;
00263         CallIndex m_call_index;
00264
00265     };
00266 /*  ======================================================================
00267     Class MmCallReleaseMsg
00268     ====================================================================== */
00270 class MmCallReleaseMsg : public Message {
00271     public:
00272         MmCallReleaseMsg(const CallIndex& call_index);
00273         virtual ~MmCallReleaseMsg();
00274
00275         virtual const MsgMetaData& GetMetaData() const;
00276         const CallIndex& GetCallIndex() const { return m_call_index; }
00277         virtual Message* Clone() const;
00278
00279         enum  {
00280             ID = 19120
00281             };
00282
00283     private:
00284         static const MsgMetaData m_meta_data;
00285         CallIndex m_call_index;
00286
00287     };
00288 #endif // MmCallMessages_hpp__ST_1136454671281
00289
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallPreComp.cpp File Reference

AddOns/MmCall/MmCallPreComp.cpp File Reference

#include "MmCallPreComp.hpp"

Include dependency graph for MmCallPreComp.cpp:

Generated on Tue Jan 24 16:42:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallPreComp.hpp File Reference

AddOns/MmCall/MmCallPreComp.hpp File Reference

#include <Kernel/Lib.hpp>

Include dependency graph for MmCallPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:42:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallPreComp.hpp Source File

AddOns/MmCall/MmCallPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallSerialTerminalListener.cpp File Reference

AddOns/MmCall/MmCallSerialTerminalListener.cpp File Reference

#include "MmCallPreComp.hpp"
#include <Apc/Message.hpp>
#include "MmCallSerialTerminalListener.hpp"
#include "SerialTerminalArg.hpp"
#include "SerialTerminalMsgArgs.hpp"
#include "AtResponseIterator.hpp"

Include dependency graph for MmCallSerialTerminalListener.cpp:

Generated on Tue Jan 24 16:42:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallSerialTerminalListener.hpp File Reference

AddOns/MmCall/MmCallSerialTerminalListener.hpp File Reference

#include <AddOns/MmCall/SerialTerminalListener.hpp>

Include dependency graph for MmCallSerialTerminalListener.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmCallSerialTerminalListener

Defines

#define | Apoxi_MmCallSerialTerminalListener_hpp

Define Documentation

#define Apoxi_MmCallSerialTerminalListener_hpp

Generated on Tue Jan 24 16:42:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmCallSerialTerminalListener.hpp Source File

AddOns/MmCall/MmCallSerialTerminalListener.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MmCallSerialTerminalListener_hpp)
00010 #define Apoxi_MmCallSerialTerminalListener_hpp
00011
00012 #include <AddOns/MmCall/SerialTerminalListener.hpp>
00013
00017 class MmCallSerialTerminalListener : public SerialTerminalListener
00018 {
00019 public:
00020     typedef SerialTerminalListener Base;
00021
00023     MmCallSerialTerminalListener();
00024
00026     virtual ~MmCallSerialTerminalListener();
00027
00029     virtual void OnTerminalEvent(SerialTerminal& terminal, SerialTerminal::Event event);
00030
00031 };
00032 #endif /* Apoxi_MmCallSerialTerminalListener_hpp */
00033
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmTypes.hpp File Reference

AddOns/MmCall/MmTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | AddOn_MmCall_Types_hpp

Enumerations

enum MmCallState {
CalledPartyAlerting, MtcReady, MtcArrived, MmCallReleased,
MmCallOnHold, MmCallDisconnecting, MmCallDisconnectingByUser, MmCallDisconnectingByNetwork,
MmCallDisconnected, MmCallDisconnectedByUser, MmCallDisconnectedByNetwork, MmMocSetupAccept,
MmMocInSetup, MmCallProgressIndication, SetupConfirmation, AcceptConfirmation
}
This enumeration comprises types of MmCallEvents. More...
enum | XaocServiceState { XnoAoc = 0, XaocInformation = 1, XaocCharging = 2 }
Values received witin unsolited event XaocService. More...
enum XCallStat {
XCallStatActive = 0, XCallStatHold = 1, XCallStatDialling = 2, XCallStatMOAlerting = 3,
XCallStatMtRinging = 4, XCallStatMtWaiting = 5, XCallStatDisconnected = 6
}
Values received witin unsolited event. More...

Variables

const INT | c_invalid_call_id = -1
Invalid id for call (stack index equivalent to CallIndex of APOXI).

Define Documentation

#define AddOn_MmCall_Types_hpp

Enumeration Type Documentation

enum MmCallState

This enumeration comprises types of MmCallEvents.

See also:
MmCallStatusMsg.
Enumerator:
CalledPartyAlerting | An MOC is in setup and the called party is notified.
MtcReady | A MTC was accepted and the call is ready.
MtcArrived | A AT+CRING:MM was detected.
MmCallReleased | An Mm call was released (MTC or MOC).
MmCallOnHold | An active call was switched to hold.
MmCallDisconnecting | A call disconnection is ongoing.
MmCallDisconnectingByUser | A call disconnection initiated by the user is ongoing.
MmCallDisconnectingByNetwork | A call disconnection caused by the network or B-PArty is ongoing.
MmCallDisconnected | A call disconnection is finished.
MmCallDisconnectedByUser | A call disconnection initiated by the user is finished.
MmCallDisconnectedByNetwork | A call disconnection caused by the network or B-PArty is finished.
MmMocSetupAccept | Setting up an MOC is allowed.
MmMocInSetup | A MOC is in setup state.
MmCallProgressIndication | Call establishment progress has occured.
SetupConfirmation | Needed for confirmation that setup has been started.
AcceptConfirmation | Needed for confirmation that accepting the call has been started.

enum XaocServiceState

Values received witin unsolited event XaocService.

Enumerator:
XnoAoc
XaocInformation
XaocCharging

enum XCallStat

Values received witin unsolited event.

Enumerator:
XCallStatActive | Call is Active.
XCallStatHold | Call is on Hold.
XCallStatDialling | Call is dialing (in case of MOC).
XCallStatMOAlerting | Call is alerting at B-party (in case of MOC).
XCallStatMtRinging | Call is ringing (in case of MTC).
XCallStatMtWaiting | Call is waiting (in case of MTC).
XCallStatDisconnected | Call has been disconnected.

Variable Documentation

const INT c_invalid_call_id = -1

Invalid id for call (stack index equivalent to CallIndex of APOXI).

Generated on Tue Jan 24 16:42:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/MmTypes.hpp Source File

AddOns/MmCall/MmTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(AddOn_MmCall_Types_hpp)
00009 #define AddOn_MmCall_Types_hpp
00010
00012 const INT c_invalid_call_id = -1;
00013
00015 enum MmCallState {
00017     CalledPartyAlerting,
00019     MtcReady,
00021     MtcArrived,
00023     MmCallReleased,
00025     MmCallOnHold,
00027     MmCallDisconnecting,
00029     MmCallDisconnectingByUser,
00031     MmCallDisconnectingByNetwork,
00033     MmCallDisconnected,
00035     MmCallDisconnectedByUser,
00037     MmCallDisconnectedByNetwork,
00039     MmMocSetupAccept,
00041     MmMocInSetup,
00043     MmCallProgressIndication,
00044
00046     SetupConfirmation,
00048     AcceptConfirmation
00049 };
00050
00052 enum XCallStat {
00054     XCallStatActive = 0,
00056     XCallStatHold = 1,
00058     XCallStatDialling = 2,
00060     XCallStatMOAlerting = 3,
00062     XCallStatMtRinging = 4,
00064     XCallStatMtWaiting = 5,
00066     XCallStatDisconnected = 6
00067 };
00068
00069
00071 enum XaocServiceState {
00072     XnoAoc = 0,
00073     XaocInformation = 1,
00074     XaocCharging = 2
00075 };
00076
00077 #endif // AddOn_MmCall_Types_hpp
00078
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminal.cpp File Reference

AddOns/MmCall/SerialTerminal.cpp File Reference

#include "MmCallPreComp.hpp"
#include <Socket/Socket.hpp>
#include <Socket/SocketMsg.hpp>
#include <Socket/SocketTypes.hpp>
#include "SerialTerminal.hpp"
#include "SerialTerminalListener.hpp"
#include "SioGlueSignalListener.hpp"

Include dependency graph for SerialTerminal.cpp:

Generated on Tue Jan 24 16:42:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminal.hpp File Reference

AddOns/MmCall/SerialTerminal.hpp File Reference

#include <AddOns/MmCall/SioGlueWrapper.hpp>
#include <AddOns/MmCall/SioGlueSignalListener.hpp>

Include dependency graph for SerialTerminal.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialTerminal

Defines

#define | Apoxi_SerialTerminal_hpp

Variables

const INT | c_max_serial_terminals = 3

Define Documentation

#define Apoxi_SerialTerminal_hpp

Variable Documentation

const INT c_max_serial_terminals = 3

Set to the value of terminals defined by io_db_config.h. Names of terminals have to be set in SerialTerminal.cpp

Generated on Tue Jan 24 16:42:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminal.hpp Source File

AddOns/MmCall/SerialTerminal.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SerialTerminal_hpp)
00010 #define Apoxi_SerialTerminal_hpp
00011
00012 #include <AddOns/MmCall/SioGlueWrapper.hpp>
00013 #include <AddOns/MmCall/SioGlueSignalListener.hpp>
00014
00015 class Socket;
00016 class SerialTerminalListener;
00017
00021 const INT c_max_serial_terminals = 3;
00022
00026 class SerialTerminal
00027 {
00028 public:
00029
00031     enum Event {
00033         DataAvailable,
00035         DataSent
00036     };
00037
00039     enum Result {
00041         Ok,
00043         Error,
00045         NotConnected
00047     };
00048
00050     enum Parity
00051     {
00053         ParityNone = SioGlueWrapper::ParityNone,
00055         ParityOdd  = SioGlueWrapper::ParityOdd,
00057         ParityEven = SioGlueWrapper::ParityEvent,
00059         ParityMark = SioGlueWrapper::ParityMark,
00061         ParitySpace = SioGlueWrapper::ParitySpace
00062     };
00063
00064     friend class SioGlueSignalListener;
00065
00067     virtual ~SerialTerminal();
00068
00077     Result Connect(const String &connect_string, UINT32 speed, UINT8 stop_bits, UINT8 data_bits, Parity parity);
00078
00082     Result Disconnect();
00083
00086     BOOLEAN IsConnected() const { return m_connected; };
00087
00099     Result Read(void* buffer, UINT16 buffer_size, UINT16& bytes_read);
00100
00109     Result Write(const void* buffer, UINT16 buffer_size, UINT16& bytes_written);
00110
00111
00117     Result SetAtMode(BOOLEAN enable);
00118
00126     Result GetConnectionParameters(UINT32* speed, UINT8* stop_bits, UINT8* data_bits, Parity* parity) const;
00127
00131     static SerialTerminal* GetFreeSerialTerminal();
00132
00136     static void ReleaseSerialTerminal(SerialTerminal* terminal) {
00137         terminal->Release();
00138         terminal->m_is_in_use = FALSE;
00139     }
00140
00143     void SetListener(SerialTerminalListener* listener);
00144
00145 protected:
00151     void OnSignalChange(SioGlueWrapper::SignalType type, void* signal_parameter, void* user_parameter);
00152
00154     BOOLEAN m_is_in_use;
00155 private:
00156
00158     SerialTerminal(const String &device);
00159
00161     BOOLEAN Init();
00162
00164     BOOLEAN Release();
00165
00166     //must accord to the sio.config!
00167     static SerialTerminal m_terminals[c_max_serial_terminals];
00168
00170     const String m_device;
00171
00173     SioGlueWrapper::SioCommId m_commId;
00174
00178     SioGlueSignalListener m_sio_signal_listener;
00179
00181     BOOLEAN m_connected;
00182
00186     SerialTerminalListener* m_event_listener;
00187
00189     SioGlueWrapper::TermIos  m_term_ios;
00190 };
00191 #endif /* Apoxi_SerialTerminal_hpp */
00192
Generated on Tue Jan 24 14:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalArg.cpp File Reference

AddOns/MmCall/SerialTerminalArg.cpp File Reference

#include "MmCallPreComp.hpp"
#include "SerialTerminalArg.hpp"

Include dependency graph for SerialTerminalArg.cpp:

Generated on Tue Jan 24 16:42:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalArg.hpp File Reference

AddOns/MmCall/SerialTerminalArg.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <SerialTerminal.hpp>

Include dependency graph for SerialTerminalArg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialTerminalArg

Defines

#define | AddOns_MmCall_SerialTerminalArg_hpp

Define Documentation

#define AddOns_MmCall_SerialTerminalArg_hpp

Generated on Tue Jan 24 16:42:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalArg.hpp Source File

AddOns/MmCall/SerialTerminalArg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "swap\views\hartmanw_mpeu-host-bsy_sv\lnz_apoxi\Apoxi\AddOns\MmCall\SerialTerminalArg.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(AddOns_MmCall_SerialTerminalArg_hpp)
00014 #define AddOns_MmCall_SerialTerminalArg_hpp
00015 #include <Apc/StackMsgArgument.hpp>
00016 #include <Apc/SignalTypes.hpp>
00017 #include <SerialTerminal.hpp>
00018 /* ----------------------------------------------------------------------
00019     Classes
00020     ---------------------------------------------------------------------- */
00021 /*  ======================================================================
00022     Class SerialTerminalArg
00023     ====================================================================== */
00025 class SerialTerminalArg : public StackMsgArgument {
00026     friend class SerialTerminalMsgArgsDestroyTableNode;
00027     public:
00028         SerialTerminalArg();
00029
00030         static const SerialTerminalArg& Cast(const StackMsgArgument& arg);
00031         void SetEvent(const SerialTerminal::Event& event) { m_event = event; }
00032         const SerialTerminal::Event& GetEvent() const { return m_event; }
00033         void SetTerminal(SerialTerminal* terminal) { m_terminal = terminal; }
00034         SerialTerminal* GetTerminal() const { return m_terminal; }
00035
00036         enum  {
00037             ID = 9100
00038             };
00039
00040     private:
00041
00042         static void Destroy(StackMsgArgument* arg) { delete ((SerialTerminalArg*) arg); }
00043
00044         SerialTerminal::Event m_event;
00045         SerialTerminal* m_terminal;
00046
00047     };
00048 // Inline definitions
00049 inline const SerialTerminalArg& SerialTerminalArg::Cast(const StackMsgArgument& arg) {
00050     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SerialTerminalArg!\n");
00051     return ((SerialTerminalArg &) arg);
00052 }
00053 #endif // AddOns_MmCall_SerialTerminalArg_hpp
00054
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalListener.cpp File Reference

AddOns/MmCall/SerialTerminalListener.cpp File Reference

#include "MmCallPreComp.hpp"
#include "SerialTerminalListener.hpp"

Include dependency graph for SerialTerminalListener.cpp:

Generated on Tue Jan 24 16:42:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalListener.hpp File Reference

AddOns/MmCall/SerialTerminalListener.hpp File Reference

#include "SerialTerminal.hpp"

Include dependency graph for SerialTerminalListener.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialTerminalListener

Defines

#define | Apoxi_SerialTerminalListener_hpp

Define Documentation

#define Apoxi_SerialTerminalListener_hpp

Generated on Tue Jan 24 16:42:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalListener.hpp Source File

AddOns/MmCall/SerialTerminalListener.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SerialTerminalListener_hpp)
00010 #define Apoxi_SerialTerminalListener_hpp
00011
00012
00013 #include "SerialTerminal.hpp"
00014
00015
00019 class SerialTerminalListener
00020 {
00021 public:
00023     SerialTerminalListener();
00025     virtual ~SerialTerminalListener();
00031     virtual void OnTerminalEvent(SerialTerminal& terminal, SerialTerminal::Event event) = 0;
00032
00033 };
00034 #endif /* Apoxi_SerialTerminalListener_hpp */
00035
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalMsgArgs.cpp File Reference

AddOns/MmCall/SerialTerminalMsgArgs.cpp File Reference

#include "MmCallPreComp.hpp"
#include "SerialTerminal.hpp"
#include "SerialTerminalMsgArgs.hpp"

Include dependency graph for SerialTerminalMsgArgs.cpp:

Generated on Tue Jan 24 16:42:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalMsgArgs.hpp File Reference

AddOns/MmCall/SerialTerminalMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <AddOns/MmCall/SerialTerminalArg.hpp>

Include dependency graph for SerialTerminalMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialTerminalMsgArgsDestroyTableNode

Defines

#define | AddOns_MmCall_SerialTerminalMsgArgs_hpp

Define Documentation

#define AddOns_MmCall_SerialTerminalMsgArgs_hpp

Generated on Tue Jan 24 16:42:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalMsgArgs.hpp Source File

AddOns/MmCall/SerialTerminalMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "swap\views\hartmanw_mpeu-host-bsy_sv\lnz_apoxi\Apoxi\AddOns\MmCall\SerialTerminalArg.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(AddOns_MmCall_SerialTerminalMsgArgs_hpp)
00014 #define AddOns_MmCall_SerialTerminalMsgArgs_hpp
00015 #include <Apc/StackMsgArgument.hpp>
00016 #include <AddOns/MmCall/SerialTerminalArg.hpp>
00017 /* ----------------------------------------------------------------------
00018     Classes
00019     ---------------------------------------------------------------------- */
00020 /*  ======================================================================
00021     Class SerialTerminalMsgArgsDestroyTableNode
00022     ====================================================================== */
00023 class SerialTerminalMsgArgsDestroyTableNode : public StackMsgArgDestroyTableNode {
00024     public:
00025
00026         static SerialTerminalMsgArgsDestroyTableNode* GetInstance();
00027
00028     private:
00029         SerialTerminalMsgArgsDestroyTableNode();
00030
00031
00032         static SerialTerminalMsgArgsDestroyTableNode* m_node;
00033         static const ArgumentDestroyEntry m_destroy_table[];
00034
00035     };
00036 #endif // AddOns_MmCall_SerialTerminalMsgArgs_hpp
00037
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalSocket.cpp File Reference

AddOns/MmCall/SerialTerminalSocket.cpp File Reference

#include "MmCallPreComp.hpp"
#include <Kernel/ExecutionContext.hpp>
#include <Socket/SocketMsg.hpp>
#include "SerialTerminalSocket.hpp"

Include dependency graph for SerialTerminalSocket.cpp:

Generated on Tue Jan 24 16:42:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalSocket.hpp File Reference

AddOns/MmCall/SerialTerminalSocket.hpp File Reference

#include <Asc/Types.hpp>
#include <Socket/Socket.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <AddOns/MmCall/SerialTerminal.hpp>
#include <AddOns/MmCall/SocketSerialTerminalListener.hpp>

Include dependency graph for SerialTerminalSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialTerminalSocket

Defines

#define | Apoxi_SerialTerminalSocket_hpp

Define Documentation

#define Apoxi_SerialTerminalSocket_hpp

Generated on Tue Jan 24 16:42:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SerialTerminalSocket.hpp Source File

AddOns/MmCall/SerialTerminalSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SerialTerminalSocket_hpp)
00010 #define Apoxi_SerialTerminalSocket_hpp
00011
00012 #include <Asc/Types.hpp>
00013 #include <Socket/Socket.hpp>
00014 #include <Auxiliary/PhoneNumber.hpp>
00015
00016 #include <AddOns/MmCall/SerialTerminal.hpp>
00017 #include <AddOns/MmCall/SocketSerialTerminalListener.hpp>
00018
00022 class SerialTerminalSocket : public Socket
00023 {
00024 public:
00025     typedef Socket Base;
00026
00028     SerialTerminalSocket();
00029
00031     virtual ~SerialTerminalSocket();
00032
00038     virtual INT Read(void *buf, INT buflen);
00039
00045     virtual INT Write(const void *buf, INT buflen);
00046
00052     virtual void SetSocketEventListener(SocketEventListener* listener);
00053
00055     virtual BOOLEAN Open(void);
00056
00058     virtual BOOLEAN IsOpen(void) const;
00059
00061     virtual BOOLEAN Close();
00062
00064     virtual BOOLEAN IsBlocking() const;
00065
00067     virtual BOOLEAN SetBlocking(BOOLEAN block = 0);
00068
00076     void SetTerminal(SerialTerminal* terminal);
00077
00078 protected:
00082     SerialTerminal* GetTerminal() const { return m_terminal;};
00083
00084 private:
00085
00087     ExecutionContext *m_execution_context;
00088
00090     SerialTerminal *m_terminal;
00091
00093     SocketSerialTerminalListener m_terminal_listener;
00094 };
00095 #endif /* Apoxi_SerialTerminalSocket_hpp */
00096
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SioGlueSignalListener.cpp File Reference

AddOns/MmCall/SioGlueSignalListener.cpp File Reference

#include "MmCallPreComp.hpp"
#include "SioGlueSignalListener.hpp"
#include "SerialTerminal.hpp"

Include dependency graph for SioGlueSignalListener.cpp:

Generated on Tue Jan 24 16:42:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SioGlueSignalListener.hpp File Reference

AddOns/MmCall/SioGlueSignalListener.hpp File Reference

#include "SioGlueWrapper.hpp"

Include dependency graph for SioGlueSignalListener.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SioGlueSignalListener

Defines

#define | Apoxi_SioGlueSignalListener_hpp

Define Documentation

#define Apoxi_SioGlueSignalListener_hpp

Generated on Tue Jan 24 16:42:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SioGlueSignalListener.hpp Source File

AddOns/MmCall/SioGlueSignalListener.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SioGlueSignalListener_hpp)
00010 #define Apoxi_SioGlueSignalListener_hpp
00011
00012 #include "SioGlueWrapper.hpp"
00013
00014 class SerialTerminal;
00015
00019 class SioGlueSignalListener
00020 {
00021 public:
00023     SioGlueSignalListener();
00024
00026     virtual ~SioGlueSignalListener();
00027
00029     void Init(SerialTerminal* terminal) {
00030         m_terminal = terminal;
00031     }
00032
00042     void OnSignalChange(SioGlueWrapper::SignalType type, void* signal_parameter, void* user_parameter);
00043
00050     static void sio_glue_handler (glue_sig_t sig_code, void *sig_param, void *user_param);
00051
00052 private:
00053     SerialTerminal *m_terminal;
00054
00055 };
00056 #endif /* Apoxi_SioGlueSignalListener_hpp */
00057
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SioGlueWrapper.cpp File Reference

AddOns/MmCall/SioGlueWrapper.cpp File Reference

#include "MmCallPreComp.hpp"
#include "SioGlueWrapper.hpp"
#include "SioGlueSignalListener.hpp"

Include dependency graph for SioGlueWrapper.cpp:

Generated on Tue Jan 24 16:42:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SioGlueWrapper.hpp File Reference

AddOns/MmCall/SioGlueWrapper.hpp File Reference

#include <stack/extensions.h>

Include dependency graph for SioGlueWrapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SioGlueWrapper
struct | SioGlueWrapper::SioCommId
struct | SioGlueWrapper::TermIos

Defines

#define | Apoxi_SioGlueWrapper_hpp

Define Documentation

#define Apoxi_SioGlueWrapper_hpp

Generated on Tue Jan 24 16:42:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SioGlueWrapper.hpp Source File

AddOns/MmCall/SioGlueWrapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SioGlueWrapper_hpp)
00010 #define Apoxi_SioGlueWrapper_hpp
00011
00012 #include <stack/extensions.h>
00013
00014 //forward definition to avoid cyclic includes
00015 class SioGlueSignalListener;
00016
00021 class SioGlueWrapper
00022 {
00023 public:
00024
00027     enum Result {
00029         SioOk = SIO_STAT_OK,
00031         SioError = SIO_STAT_ERROR,
00033         SioEnoughBuffer = SIO_STAT_WATER_HIGH,
00035         SioBufferLow = SIO_STAT_WATER_LOW,
00037         SioAtBusy = SIO_STAT_AT_BUSY,
00039         SioAtComplete = SIO_STAT_AT_COMPL
00040     };
00041
00042
00045     enum LineState
00046     {
00048         SioLineOff = SIO_LINE_OFF,
00050         SioLineOn = SIO_LINE_ON,
00052         SioLineDontCare = SIO_LINE_ON+1
00053
00054     };
00055
00056
00059     enum Parity
00060     {
00061         ParityNone = SIO_PARITY_NONE,
00062         ParityOdd = SIO_PARITY_ODD,
00063         ParityEvent = SIO_PARITY_EVEN,
00064         ParityMark = SIO_PARITY_MARK,
00065         ParitySpace = SIO_PARITY_SPACE
00066     };
00067
00070     enum SignalType
00071     {
00073         SioDataReq = GLUE_SIG_DATAREQ,
00075         SioTermIos = GLUE_SIG_TERMIOS,
00077         SioExecMode = GLUE_SIG_EXECMODE,
00079         SioClose = GLUE_SIG_CLOSE,
00081         SioOpen = GLUE_SIG_OPEN,
00082
00083         SioLast = GLUE_SIG_LAST
00084     };
00085
00088     enum SignalStartStop
00089     {
00091         SioExecModeStart = GLUE_EXECMODE_START,
00093         SioExecModeKill = GLUE_EXECMODE_KILL,
00094
00095         SioSigvalLast = GLUE_SIGVAL_LAST
00096
00097     };
00098
00099     struct SioCommId {
00100         friend class SioGlueWrapper;
00101
00102         private:
00104             glue_fd_t  m_fd;
00105     };
00106
00109     struct TermIos {
00110
00111         public:
00112
00114             TermIos();
00115
00119             TermIos(sio_termios_t* sio_termios);
00120
00122             ~TermIos();
00123
00125             LineState GetDtr() const { return static_cast<LineState>(m_termios.dtr); }
00126
00128             LineState GetRts() const { return static_cast<LineState>(m_termios.rts); }
00129
00131             LineState GetDsr() const { return static_cast<LineState>(m_termios.dsr); }
00132
00134             void SetDsr(LineState state) { m_termios.dsr = (sio_line_t)state; }
00135
00137             LineState GetCts() const { return static_cast<LineState>(m_termios.cts); }
00138
00140             void SetCts(LineState state) { m_termios.cts = (sio_line_t)state; }
00141
00143             LineState GetDcd() const { return static_cast<LineState>(m_termios.dcd); }
00144
00146             void SetDcd(LineState state) { m_termios.dcd = (sio_line_t)state; }
00147
00149             LineState GetRi() const { return static_cast<LineState>(m_termios.ri); }
00150
00152             void SetRi(LineState state) { m_termios.ri = (sio_line_t)state; }
00153
00155             UINT32 GetSpeed() const { return m_termios.speed; }
00156
00158             void SetSpeed(UINT32 speed) { m_termios.speed = speed; }
00159
00161             UINT8 GetStopBits() const { return m_termios.stop_bits; }
00162
00164             void SetStopBits(UINT8 stop_bits) { m_termios.stop_bits = stop_bits; }
00165
00167             Parity GetParity() const { return static_cast<Parity>(m_termios.parity); }
00168
00170             void SetParity(Parity parity) { m_termios.parity = (sio_parity_t)parity; }
00171
00173             UINT8 GetDataBits() const { return m_termios.data_bits; }
00174
00176             void SetDataBits(UINT8 data_bits) { m_termios.data_bits = data_bits; }
00177
00178             friend SioGlueWrapper;
00179
00180         private:
00181             sio_termios_t m_termios;
00182
00183     };
00184
00192     static Result Close(const SioCommId &comm_id);
00193
00194
00203     static Result Open(const String &device_name, SioCommId& comm_id);
00204
00205     //corresponding methods to functions and parameters of sio_glue
00206     //typedef enum
00207     //{
00208     //  GLUE_OPT_SIGACT,  --> RegisterHandler() / UnregisterHandler()
00209     //  GLUE_OPT_TERMIOS, --> GetStatus() / SetStatus()
00210     //  GLUE_OPT_WRVAL,   --> GetBufferSizes()
00211     //  GLUE_OPT_AT,      --> SetAtMode()
00212     //} glue_opt_t;
00213
00220     static Result RegisterSignalListener(const SioCommId &comm_id, SioGlueSignalListener &listener);
00221
00228     static Result UnRegisterSignalListener(const SioCommId &comm_id, const SioGlueSignalListener &listener);
00229
00236     static Result SetAtMode(const SioCommId &comm_id, BOOLEAN at_mode);
00237
00246     static Result GetAtMode(const SioCommId &comm_id, BOOLEAN &at_mode);
00247
00255     static Result GetBufferSizes(const SioCommId &comm_id, UINT16 &free, UINT16 &size);
00256
00264     static Result SetStatus(const SioCommId &comm_id, const TermIos& state);
00265
00274     static Result GetStatus(const SioCommId &comm_id, TermIos& state);
00275
00286     static Result ReadData  (const SioCommId &comm_id, void *buffer,
00287                         UINT16   size,
00288                         UINT16&  read);
00289
00290
00302     static Result WriteData  (const SioCommId &comm_id, const void *buffer,
00303                         UINT16   size,
00304                         UINT16&  written);
00305
00306 private:
00310
00311     SioGlueWrapper();
00312
00314     ~SioGlueWrapper();
00315 };
00316
00317 #endif /* Apoxi_SioGlueWrapper_hpp */
00318
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SocketSerialTerminalListener.cpp File Reference

AddOns/MmCall/SocketSerialTerminalListener.cpp File Reference

#include "MmCallPreComp.hpp"
#include <Socket/Socket.hpp>
#include <Socket/SocketMsg.hpp>
#include <Socket/SocketTypes.hpp>
#include "SerialTerminalSocket.hpp"
#include "SocketSerialTerminalListener.hpp"

Include dependency graph for SocketSerialTerminalListener.cpp:

Generated on Tue Jan 24 16:42:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SocketSerialTerminalListener.hpp File Reference

AddOns/MmCall/SocketSerialTerminalListener.hpp File Reference

#include "SerialTerminalListener.hpp"

Include dependency graph for SocketSerialTerminalListener.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketSerialTerminalListener

Defines

#define | Apoxi_SocketSerialTerminalListener_hpp

Define Documentation

#define Apoxi_SocketSerialTerminalListener_hpp

Generated on Tue Jan 24 16:42:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/SocketSerialTerminalListener.hpp Source File

AddOns/MmCall/SocketSerialTerminalListener.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SocketSerialTerminalListener_hpp)
00010 #define Apoxi_SocketSerialTerminalListener_hpp
00011
00012
00013 #include "SerialTerminalListener.hpp"
00014
00015 class SerialTerminalSocket;
00016 class ExecutionContext;
00017
00021 class SocketSerialTerminalListener : public SerialTerminalListener
00022 {
00023 public:
00024     typedef SerialTerminalListener Base;
00025
00027     SocketSerialTerminalListener(SerialTerminalSocket& socket);
00028
00030     virtual ~SocketSerialTerminalListener();
00031
00033     virtual void OnTerminalEvent(SerialTerminal& terminal, SerialTerminal::Event event);
00034
00039     void SetSocketExecutionContext(ExecutionContext* context) {m_socket_execution_context = context;};
00040
00044     void SetActive(BOOLEAN active) { m_active = active; };
00045
00046 private:
00048     SerialTerminalSocket& m_socket;
00049
00051     ExecutionContext* m_socket_execution_context;
00052
00054     BOOLEAN m_active;
00055
00056 };
00057 #endif /* Apoxi_SocketSerialTerminalListener_hpp */
00058
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/XCallInfoResponseParser.cpp File Reference

AddOns/MmCall/XCallInfoResponseParser.cpp File Reference

#include "MmCallPreComp.hpp"
#include "XCallInfoResponseParser.hpp"

Include dependency graph for XCallInfoResponseParser.cpp:

Generated on Tue Jan 24 16:42:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/XCallInfoResponseParser.hpp File Reference

AddOns/MmCall/XCallInfoResponseParser.hpp File Reference

#include <AddOns/MmCall/AtResponseIterator.hpp>

Include dependency graph for XCallInfoResponseParser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | XCallInfoResponseParser

Defines

#define | Apoxi_CallInfoParser_hpp

Define Documentation

#define Apoxi_CallInfoParser_hpp

Generated on Tue Jan 24 16:42:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MmCall/XCallInfoResponseParser.hpp Source File

AddOns/MmCall/XCallInfoResponseParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CallInfoParser_hpp)
00010 #define Apoxi_CallInfoParser_hpp
00011
00012 #include <AddOns/MmCall/AtResponseIterator.hpp>
00013
00018 class XCallInfoResponseParser {
00019     public:
00020
00022         enum CallInfoType {
00024             CallInfoNotValid = 0,
00026             CallControlCallSetupInfo = 1,
00028             CallSetup = 2,
00030             CallClearing = 3,
00032             DualServiceCallModification = 4,
00034             CrssTransaction = 5
00035         };
00036
00038         enum CcPerformed {
00040             CCNotValid = 0,
00042             CCNotPerformed = 1,
00044             CCPerformed = 2
00045         };
00046
00048         enum SetupState {
00050             SetupStateNotValid = 0,
00052             MoCallRequested = 1,
00054             MoCallDialing = 2,
00056             MocRemoteUserAlerted = 3,
00058             MtcConfirmed = 4,
00060             MtcIndicated = 5,
00062             MtcBcNegotiated = 6,
00064             MtcAccepted = 7,
00066             CallActive = 8
00067         };
00068
00070         enum CallDirection {
00072             CdNotValid = 0,
00074             MOC = 1,
00076             MTC = 2
00077         };
00078
00079
00081         enum EstablishmentCause {
00083             EstCauseNotValid = 0,
00085             EmergencyCall = 1,
00087             NormalCall = 2
00088         };
00089
00091         enum CallType {
00093             CallTypeNotValid = 0,
00095             SingleVoiceCall = 1,
00097             SingleFaxCall = 2,
00099             SingleDataCall = 3,
00101             DualCall = 4
00102         };
00103
00105         enum CallMode {
00107             CallModeNotValid = 0,
00109             Voice = 1,
00111             Fax = 2,
00113             Data = 3
00114         };
00115
00117         enum SelectedLine {
00119             SelLineNotValid = 0,
00121             Speech = 1,
00123             AuxiliarySpeech = 3
00124         };
00125
00127         enum CtmStatus {
00129             CtmNotValid = 0,
00131             CtmCall = 1,
00133             AudioBasedCall = 2
00134         };
00135
00137         enum CliValidity {
00139             CliValid = 0,
00141             CliWithheldByOriginator = 1,
00143             CliNotAvailable = 2,
00145             CliInvalid
00146         };
00147
00149         enum ClearingState {
00151             ClearingStateNotValid = 0,
00153             MocSetupRejected = 1,
00155             Disconnected = 2,
00157             DisconnectIndicated = 3,
00159             Cleared = 4
00160         };
00161
00163         enum ModificationState {
00165             ModificationStateNotValid = 0,
00167             ModificationIndicated = 1,
00169             ModificationStarted = 2,
00171             ModificationRejected = 3,
00173             ModificationCompleted = 4
00174         };
00175
00177         enum CrssState {
00179             CrssNotValid = 0,
00181             CallHeldStarted = 1,
00183             CallHeldRejected = 2,
00185             CallHeldCompleted = 3,
00187             CallRetrieveStarted = 4,
00189             CallRetrieveRejected = 5,
00191             CallRetrieveCompleted = 6,
00193             MultiPartyStarted = 7,
00195             MultiPartyRejected = 8,
00197             MultiPartyCompleted = 9,
00199             MultiPartyHeldStarted = 10,
00201             MultiPartyHeldRejected = 11,
00203             MultiPartyHeldCompleted = 12,
00205             MultiPartyRetrieveStarted = 13,
00207             MultiPartyRetrieveRejected = 14,
00209             MultiPartyRetrieveCompleted = 15,
00211             MultiPartySplitStarted = 16,
00213             MultiPartySplitRejected = 17,
00215             MultiPartySplitCompleted = 18,
00217             ExplicitCallTransferStarted = 19,
00219             ExplicitCallTransferRejected = 20,
00221             ExplicitCallTransferCompleted = 21,
00223             CallDeflectionStarted = 22,
00225             CallDeflectionRejected = 23,
00227             CallDeflectionCompleted = 24
00228         };
00229
00233         XCallInfoResponseParser(const AtResponse &response);
00234
00236         ~XCallInfoResponseParser();
00237
00239         CallInfoType GetType() const;
00240
00242         INT GetCallId() const;
00243
00245         Tipd GetTipd() const;
00246
00248         CcPerformed GetCcPerformed() const;
00249
00251         INT GetSimResult() const;
00252
00254         const String GetAlpha() const;
00255
00257         SetupState GetSetupState() const;
00258
00260         CallDirection GetCallDirection() const;
00261
00263         EstablishmentCause GetEstCause() const;
00264
00266         INT GetEccCategory() const;
00267
00269         CallType GetCallType() const;
00270
00272         CallMode GetCallMode() const;
00273
00275         INT GetChannelMode() const;
00276
00278         SelectedLine GetSelectedLine() const;
00279
00281         CtmStatus GetCtmStatus() const;
00282
00284         const PhoneNumber GetPhoneNumber() const;
00285
00287         CliValidity GetCliValidity() const;
00288
00290         ClearingState GetClearingState() const;
00291
00293         INT GetClearingCause() const;
00294
00296         ModificationState GetModificationState() const;
00297
00299         CallMode GetCurrentCallMode() const;
00300
00302         CrssState GetCrssState() const;
00303
00304     private:
00306         AtResponse          m_response;
00308         CallInfoType        m_type;
00309
00310
00311 };
00312
00313
00314 #endif // Apoxi_CallInfoParser_hpp
00315
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/AbstractIMelodyParser.hpp File Reference

AddOns/MultiMedia/AbstractIMelodyParser.hpp File Reference

#include <Compat/AbstractIMelodyParser.hpp>

Include dependency graph for AbstractIMelodyParser.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 16:42:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/AbstractIMelodyParser.hpp Source File

AddOns/MultiMedia/AbstractIMelodyParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class AbstractIMelodyParser has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/AbstractIMelodyParser.hpp>
00014
00015
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/AudioContext.hpp File Reference

AddOns/MultiMedia/AudioContext.hpp File Reference

#include <Compat/AudioContext.hpp>

Include dependency graph for AudioContext.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:42:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/AudioContext.hpp Source File

AddOns/MultiMedia/AudioContext.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class AudioContext has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/AudioContext.hpp>
00014
00015
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/AudioItem.cpp File Reference

AddOns/MultiMedia/AudioItem.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "AudioItem.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for AudioItem.cpp:

Generated on Tue Jan 24 16:42:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/AudioItem.hpp File Reference

AddOns/MultiMedia/AudioItem.hpp File Reference

#include <Auxiliary/SharedPtr.hpp>
#include <AddOns/MultiMedia/BoundedItem.hpp>
#include <Audio/AudioReference.hpp>

Include dependency graph for AudioItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioItem

Defines

#define | Apoxi_AudioItem_hpp

Define Documentation

#define Apoxi_AudioItem_hpp

Generated on Tue Jan 24 16:42:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/AudioItem.hpp Source File

AddOns/MultiMedia/AudioItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioItem_hpp)
00011 #define Apoxi_AudioItem_hpp
00015
00016 #include <Auxiliary/SharedPtr.hpp>
00017 #include <AddOns/MultiMedia/BoundedItem.hpp>
00018 #include <Audio/AudioReference.hpp>
00019
00021 class AudioItem : public BoundedItem {
00022     typedef BoundedItem Base;
00023
00024     public:
00025         enum {
00026             ID = 15
00027         };
00028
00042         explicit AudioItem(SharedPtr<AudioReference> audio_ref);
00043         virtual ~AudioItem();
00044
00046         virtual INT GetId() const;
00047
00049         virtual XYDIM GetWidth() const;
00050
00052         virtual XYDIM GetHeight() const;
00053
00055         virtual void Draw(DeviceContext* dc, const Rect& bounds) const;
00056
00058         SharedPtr<AudioReference> GetAudioReference() const { return m_audio_ref; }
00059
00063         virtual AtomItem* Clone() const;
00064
00066         virtual BOOLEAN IsInstanceOf(INT id) const;
00067
00068     private:
00069         SharedPtr<AudioReference> m_audio_ref;
00070 };
00071
00073 #endif  // Apoxi_AudioItem_hpp
00074
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BmpDecoder.cpp File Reference

AddOns/MultiMedia/BmpDecoder.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <Devices/Device.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/BitmapDc.hpp>
#include <Gui/Bitmap.hpp>
#include <Config/DisplayConfig.hpp>
#include "BmpDecoder.hpp"

Include dependency graph for BmpDecoder.cpp:

Defines

#define | BMP_BITFIELD 3
#define | BMP_FILE_HEADER_SIZE 14
#define | BMP_INFO_HEADER_SIZE 40
#define | BMP_RGB 0
#define | BMP_RLE4 2
#define | BMP_RLE8 1
#define | INPUT_BYTE(V, action)
#define | MAKE_BYTE_AVAIL(action)
#define | RLE_COMMAND 0
#define | RLE_DELTA 2
#define | RLE_ENDOFBITMAP 1
#define | RLE_ENDOFLINE 0

Define Documentation

#define BMP_BITFIELD 3

#define BMP_FILE_HEADER_SIZE 14

#define BMP_INFO_HEADER_SIZE 40

#define BMP_RGB 0

#define BMP_RLE4 2

#define BMP_RLE8 1

#define INPUT_BYTE | ( | V,
 |  | action | )

Value:

MAKE_BYTE_AVAIL(action); \
    m_bytes_in_buffer--; \
    m_abs_offset++; \
    V = *m_next_input_byte++;

#define MAKE_BYTE_AVAIL ( action )

Value:

if (m_bytes_in_buffer == 0) {  \
    if (! FillInputBuffer())  \
{ action; }  \
    }

#define RLE_COMMAND 0

#define RLE_DELTA 2

#define RLE_ENDOFBITMAP 1

#define RLE_ENDOFLINE 0

Generated on Tue Jan 24 16:42:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BmpDecoder.hpp File Reference

AddOns/MultiMedia/BmpDecoder.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_BmpDecoder_hpp

Define Documentation

#define Apoxi_BmpDecoder_hpp

Generated on Tue Jan 24 16:42:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BmpDecoder.hpp Source File

AddOns/MultiMedia/BmpDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BmpDecoder_hpp)
00011 #define Apoxi_BmpDecoder_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00018
00019 #include <Gui/Image.hpp>
00020 #include <Gui/ImageDecoder.hpp>
00021 #include <Auxiliary/BinData.hpp>
00022
00023 #define INPUT_BUFFER_SIZE 4096
00024
00028 class BmpDecoder : public ImageDecoder {
00029     typedef ImageDecoder Base;
00030
00031     public:
00032         static BmpDecoder* GetInstance();
00033         virtual ~BmpDecoder();
00034
00036         virtual BOOLEAN GetMetaData(Image& image, Image::MetaData* meta_data);
00037
00039         virtual BOOLEAN BeginDecoding(const Image& image, INT frame_idx = 0);
00040
00042         virtual void EndDecoding(const Image& image, INT frame_idx = 0);
00043
00046         BOOLEAN DecodeScanline(INT scanline_idx, INT old_scanline_idx);
00047
00049         UINT8* GetScanlineBuffer() const { return m_scanline; }
00050
00051     private:
00052         BmpDecoder();
00053
00054         BOOLEAN Decode24BitRgb();
00055         BOOLEAN DecodeRgb();
00056         BOOLEAN Decode8BitRle();
00057         BOOLEAN Decode4BitRle();
00058
00059         BOOLEAN FillInputBuffer();
00060         BOOLEAN RelocateInputBuffer(UINT32 pos);
00061
00062         static BmpDecoder m_instance;
00063
00064         UINT8* m_scanline;
00065         INT m_scanline_byte_count;
00066         UINT8* m_colortable;
00067         INT m_decompressed_scanline_idx;
00068         UINT32 m_offset;
00069         UINT32 m_abs_offset;
00070         UINT32 m_bytes_in_buffer;
00071         const BinData* m_data;
00072
00073         UINT8* m_next_input_byte;
00074         UINT8 m_input_buffer[INPUT_BUFFER_SIZE];
00075
00076         typedef struct BitmapFileHeader {
00077             UINT8  m_bfType[2];
00078             UINT32 m_bfSize;
00079             UINT16 m_res1;
00080             UINT16 m_res2;
00081             UINT32 m_image_start;
00082         } BMPFILEHEADER;
00083
00084         typedef struct BitmapInfoHeader {
00085             UINT32 m_size;
00086             UINT32 m_width;
00087             UINT32 m_height;
00088             UINT16 m_planes;
00089             UINT16 m_bpp;
00090             UINT32 m_compression;
00091             UINT32 m_image_size;
00092             UINT32 m_xpels;
00093             UINT32 m_ypels;
00094             UINT32 m_clr_used;
00095             UINT32 m_clr_important;
00096
00097         } BMPINFOHEADER;
00098
00099         BMPFILEHEADER m_fileheader;
00100         BMPINFOHEADER m_infoheader;
00101 };
00102
00104 #endif // DOXYGEN_SHOULD_SKIP_THIS
00105 #endif  //Apoxi_BmpDecoder_hpp
00106
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BmpImage.cpp File Reference

AddOns/MultiMedia/BmpImage.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <Devices/Device.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/BitmapDc.hpp>
#include <Gui/Bitmap.hpp>
#include <Config/DisplayConfig.hpp>
#include "BmpImage.hpp"
#include "BmpDecoder.hpp"

Include dependency graph for BmpImage.cpp:

Generated on Tue Jan 24 16:42:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BmpImage.hpp File Reference

AddOns/MultiMedia/BmpImage.hpp File Reference

#include <Gui/Image.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for BmpImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BmpImage

Defines

#define | Apoxi_BmpImage_hpp

Define Documentation

#define Apoxi_BmpImage_hpp

Generated on Tue Jan 24 16:42:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BmpImage.hpp Source File

AddOns/MultiMedia/BmpImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BmpImage_hpp)
00011 #define Apoxi_BmpImage_hpp
00015
00016 #include <Gui/Image.hpp>
00017 #include <Auxiliary/BinData.hpp>
00018
00019
00020 class BmpImage : public Image {
00021     typedef Image Base;
00022
00023     public:
00024         enum {
00025             ID = 1
00026         };
00027
00030         BmpImage();
00031
00039         BmpImage(BinData* bin_data, BOOLEAN* success = 0);
00040
00042         virtual ~BmpImage();
00043
00051         void Init(BinData* bin_data, BOOLEAN* success = 0);
00052
00054         virtual BOOLEAN IsInstanceOf(INT id) const;
00055
00057         virtual const BinData* GetBinData() const;
00058
00060         virtual INT GetNextFrame(INT frame_idx) const;
00061
00063         virtual UINT32 GetFrameDelay(INT frame_idx) const;
00064
00065     protected:
00067         virtual void* BeginScanlineDrawing(INT frame_idx = 0) const;
00068
00070         virtual void EndScanlineDrawing(void* context) const;
00071
00073         virtual void DrawScanline(void* context,
00074                                   DeviceContext* dc,
00075                                   XYDIM x,
00076                                   XYDIM y,
00077                                   INT scanline_idx,
00078                                   INT old_scanline_idx) const;
00079
00081         virtual XYDIM GetScanlineDiff(void* context,
00082                                       INT scanline_idx,
00083                                       INT old_scanline_idx) const;
00084
00085
00087         virtual ColorValue GetTransparentColor(void* context) const;
00088
00091         virtual BOOLEAN IsFullTraversingEnabled(void* context) const;
00092
00093     private:
00094         BinData* m_bin_data;
00095 };
00096
00098 #endif  //Apoxi_GifImage_hpp
00099
00100
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BoundedItem.cpp File Reference

AddOns/MultiMedia/BoundedItem.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "BoundedItem.hpp"

Include dependency graph for BoundedItem.cpp:

Generated on Tue Jan 24 16:42:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BoundedItem.hpp File Reference

AddOns/MultiMedia/BoundedItem.hpp File Reference

#include <Gui/AtomItem.hpp>

Include dependency graph for BoundedItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BoundedItem

Defines

#define | Apoxi_BoundedItem_hpp

Define Documentation

#define Apoxi_BoundedItem_hpp

Generated on Tue Jan 24 16:42:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/BoundedItem.hpp Source File

AddOns/MultiMedia/BoundedItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BoundedItem_hpp)
00011 #define Apoxi_BoundedItem_hpp
00015
00016 #include <Gui/AtomItem.hpp>
00017
00020 class BoundedItem : public AtomItem {
00021     typedef AtomItem Base;
00022
00023     public:
00024         enum {
00025             ID = 3
00026         };
00027
00029         BoundedItem();
00030
00032         virtual ~BoundedItem();
00033
00035         virtual INT GetId() const;
00036
00038         virtual XYDIM GetWidth() const = 0;
00039
00041         virtual XYDIM GetHeight() const = 0;
00042
00044         virtual BOOLEAN IsInstanceOf(INT id) const;
00045 };
00046
00048 #endif  // Apoxi_BoundedItem_hpp
00049
00050
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/CompoundItemReferrer.cpp File Reference

AddOns/MultiMedia/CompoundItemReferrer.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "CompoundItemReferrer.hpp"

Include dependency graph for CompoundItemReferrer.cpp:

Generated on Tue Jan 24 16:42:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/CompoundItemReferrer.hpp File Reference

AddOns/MultiMedia/CompoundItemReferrer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CompoundItemReferrer

Defines

#define | Apoxi_CompoundItemReferrer_hpp

Define Documentation

#define Apoxi_CompoundItemReferrer_hpp

Generated on Tue Jan 24 16:42:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/CompoundItemReferrer.hpp Source File

AddOns/MultiMedia/CompoundItemReferrer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_CompoundItemReferrer_hpp)
00011 #define Apoxi_CompoundItemReferrer_hpp
00015
00016 class CompoundItem;
00017
00022 class CompoundItemReferrer {
00023     public:
00025         explicit CompoundItemReferrer(INT start_index = 0, CompoundItem* compound_item = 0);
00026
00028         void SetStartIndex(INT index) { m_start_index = index; }
00029
00031         INT GetStartIndex() const { return m_start_index; }
00032
00034         void SetCompoundItem(CompoundItem* compound_item) { m_compound_item = compound_item; }
00035
00037         CompoundItem* GetCompoundItem() const { return m_compound_item; }
00038
00040         INT GetCount() const { ASSERT_DEBUG(m_compound_item != 0); return m_compound_item->GetItemCount(); }
00041
00042     private:
00043         INT m_start_index;
00044         CompoundItem* m_compound_item;
00045 };
00046
00048 #endif  // Apoxi_CompoundItemReferrer_hpp
00049
00050
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GeneralCompoundItem.cpp File Reference

AddOns/MultiMedia/GeneralCompoundItem.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "GeneralCompoundItem.hpp"
#include <Gui/Font.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/Locale.hpp>
#include <Kernel/System.hpp>

Include dependency graph for GeneralCompoundItem.cpp:

Generated on Tue Jan 24 16:42:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GeneralCompoundItem.hpp File Reference

AddOns/MultiMedia/GeneralCompoundItem.hpp File Reference

#include <Gui/CompoundItem.hpp>
#include <Auxiliary/Vector.hpp>
#include <AddOns/MultiMedia/BoundedItem.hpp>

Include dependency graph for GeneralCompoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GeneralCompoundItem
Represents a simple container for Bounded-Editor-Items. More...

Defines

#define | Apoxi_GeneralCompoundItem_hpp

Define Documentation

#define Apoxi_GeneralCompoundItem_hpp

Generated on Tue Jan 24 16:42:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GeneralCompoundItem.hpp Source File

AddOns/MultiMedia/GeneralCompoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_GeneralCompoundItem_hpp)
00011 #define Apoxi_GeneralCompoundItem_hpp
00015
00016 #include <Gui/CompoundItem.hpp>
00017 #include <Auxiliary/Vector.hpp>
00018 #include <AddOns/MultiMedia/BoundedItem.hpp>
00019
00021 class GeneralCompoundItem : public CompoundItem {
00022     typedef CompoundItem Base;
00023
00024     public:
00025         enum {
00026             ID = 12
00027         };
00028
00030         static GeneralCompoundItem* CreateInstance();
00031
00033         virtual ~GeneralCompoundItem();
00034
00036         virtual INT GetId() const;
00037
00039         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00040
00042         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00043
00045         virtual BOOLEAN RemoveItem(INT index = -1);
00046
00049         virtual const AtomItem* GetItem(INT index) const;
00050
00052         virtual BOOLEAN Split(INT index, CompoundItem* *compound_item);
00053
00055         virtual BOOLEAN Merge(const CompoundItem& compound_item);
00056
00058         virtual CompoundItem* Clone() const;
00059
00061         virtual void Draw(DeviceContext* dc,
00062                           XYDIM x,
00063                           XYDIM y,
00064                           INT index,
00065                           INT count) const;
00066
00068         virtual INT WrapLine(INT index,
00069                              XYDIM width,
00070                              WrapPolicy wrap_policy = EditorDocument::WhitespaceWrap) const;
00071
00073         virtual XYDIM GetLineWidth(INT index, INT count) const;
00074
00076         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const;
00077
00079         virtual INT GetItemCount() const;
00080
00082         virtual void Clear();
00083
00085         virtual BOOLEAN IsInstanceOf(INT id) const;
00086
00087     protected:
00089         GeneralCompoundItem();
00090
00091     private:
00092         Vector<const BoundedItem*> m_editor_item_vector;
00093 };
00094
00096 #endif  // Apoxi_GeneralCompoundItem_hpp
00097
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GifDecoder.cpp File Reference

AddOns/MultiMedia/GifDecoder.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <Devices/Device.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/BitmapDc.hpp>
#include <Gui/Bitmap.hpp>
#include <Config/DisplayConfig.hpp>
#include "GifDecoder.hpp"
#include "GifImage.hpp"

Include dependency graph for GifDecoder.cpp:

Defines

#define | FIRST_CODE 4097
#define | FLUSH_OUTPUT 4096
#define | GIF_APP_EXT 0xFF
#define | GIF_COLOR_TABLE_SIZE 256
#define | GIF_COMMENT_EXT 0xFE
#define | GIF_EXTENSION 0x21
#define | GIF_GCE_SIZE 5
#define | GIF_GRAPHIC_EXT 0xF9
#define | GIF_HEADER_SIZE 6
#define | GIF_ID_SIZE 9
#define | GIF_IMAGE_DESC 0x2c
#define | GIF_LSD_SIZE 7
#define | GIF_TEXT_EXT 0x01
#define | GIF_TRAILER 0x3b
#define | INPUT_BYTE(V, action)
#define | LZ_BITS 12
#define | LZ_MAX_CODE 4095
#define | MAKE_BYTE_AVAIL(action)
#define | NO_SUCH_CODE 4098
#define | SKIP_BYTES(bytes)

Define Documentation

#define FIRST_CODE 4097

#define FLUSH_OUTPUT 4096

#define GIF_APP_EXT 0xFF

#define GIF_COLOR_TABLE_SIZE 256

#define GIF_COMMENT_EXT 0xFE

#define GIF_EXTENSION 0x21

#define GIF_GCE_SIZE 5

#define GIF_GRAPHIC_EXT 0xF9

#define GIF_HEADER_SIZE 6

#define GIF_ID_SIZE 9

#define GIF_IMAGE_DESC 0x2c

#define GIF_LSD_SIZE 7

#define GIF_TEXT_EXT 0x01

#define GIF_TRAILER 0x3b

#define INPUT_BYTE | ( | V,
 |  | action | )

Value:

MAKE_BYTE_AVAIL(action); \
    m_bytes_in_buffer--; \
    m_abs_offset++; \
    V = *m_next_input_byte++;

#define LZ_BITS 12

#define LZ_MAX_CODE 4095

#define MAKE_BYTE_AVAIL ( action )

Value:

if (m_bytes_in_buffer == 0) {  \
    if (! FillInputBuffer())  \
        { action; }  \
    }

#define NO_SUCH_CODE 4098

#define SKIP_BYTES ( bytes )

Value:

INT bcount = bytes; \
    while (bcount--) { \
        MAKE_BYTE_AVAIL(return FALSE;); \
        m_bytes_in_buffer--; \
        m_abs_offset++; \
        m_next_input_byte++; \
    };

Generated on Tue Jan 24 16:42:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GifDecoder.hpp File Reference

AddOns/MultiMedia/GifDecoder.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_GifDecoder_hpp

Define Documentation

#define Apoxi_GifDecoder_hpp

Generated on Tue Jan 24 16:42:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GifDecoder.hpp Source File

AddOns/MultiMedia/GifDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_GifDecoder_hpp)
00011 #define Apoxi_GifDecoder_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00018
00019 #include "GifImage.hpp"
00020 #include <Gui/Image.hpp>
00021 #include <Gui/ImageDecoder.hpp>
00022 #include <Auxiliary/BinData.hpp>
00023
00024 #define INPUT_BUFFER_SIZE   4096
00025
00029 class GifDecoder : public ImageDecoder {
00030     typedef ImageDecoder Base;
00031
00032     public:
00033         static GifDecoder* GetInstance();
00034
00036         virtual BOOLEAN GetMetaData(Image& image, Image::MetaData* meta_data);
00037
00039         virtual BOOLEAN BeginDecoding(const Image& image, INT frame_idx = 0);
00040
00042         virtual void EndDecoding(const Image& image, INT frame_idx = 0);
00043
00047         BOOLEAN IsInterlaced() const { return m_interlaced;}
00048
00051         UINT8* GetScanlineBuffer() const { return m_scanline_buffer; }
00052
00055         BOOLEAN DecodeScanline(INT scanline_idx, INT old_scanline_idx, UINT32 size);
00056
00059         ColorValue GetColor(INT index) const {  ASSERT_DEBUG_HOST(index >= 0);
00060                                                 ASSERT_DEBUG_HOST(index < 256);
00061                                                 ASSERT_DEBUG_HOST(m_color_table != 0);
00062                                                 return *(m_color_table + index);
00063                                             };
00064
00068         INT GetTransparentColorIndex() const { return m_transparent_color_idx; }
00069
00071         INT GetBackgroundColorIndex() const {return m_background_idx; }
00072
00074         ColorValue GetBackgroundColor() const {return m_background; }
00075
00076
00078         UINT8 GetDisposalMethod() const {return m_disposal_method; }
00079
00082         XYDIM GetFrameXPos() const {return m_frame_xpos;}
00083
00086         XYDIM GetFrameYPos() const {return m_frame_ypos;}
00087
00089         XYDIM GetFrameWidth() const {return m_frame_width;}
00090
00092         XYDIM GetFrameHeight() const {return m_frame_height;}
00093
00095         const ColorValue* GetColorTable() const { return m_color_table;}
00096
00097     private:
00098         BOOLEAN         m_user_input;
00099         BOOLEAN         m_interlaced;
00100         BOOLEAN         m_optimize_for_16bpp;
00101         BOOLEAN         m_global_color_table;
00102         UINT8           m_disposal_method;
00103         INT             m_background_idx;
00104         INT             m_frame_idx;
00105         INT             m_transparent_color_idx;
00106         XYDIM           m_frame_xpos;
00107         XYDIM           m_frame_ypos;
00108         XYDIM           m_frame_width;
00109         XYDIM           m_frame_height;
00110         INT             m_ct_size;
00111         INT             m_decompressed_scanline_idx;
00112         UINT32          m_offset;
00113         ColorValue      m_background;
00114
00115         UINT8* m_scanline_buffer;
00116
00117         ColorValue* m_color_table;
00118
00119         static GifDecoder m_decoder;
00120
00121         GifImage* m_image;
00122
00123         GifDecoder();
00124         BOOLEAN InitFrameData();
00125         BOOLEAN DecodeFrame(INT frame_idx);
00126         BOOLEAN GetFrameHandle(INT frame_idx);
00127
00128         BOOLEAN OverreadExtensionBlock();
00129         BOOLEAN OverreadImageBlock();
00130         BOOLEAN ParseGraphicControlExtension(UINT32& frame_delay);
00131         BOOLEAN ParseImageDescriptor();
00132         BOOLEAN ParseApplicationExtension(INT& repeat_value);
00133
00134         BOOLEAN DoubleTransparency();
00135         void ReplaceTransparent();
00136
00137         BOOLEAN FillInputBuffer();
00138         BOOLEAN RelocateInputBuffer(UINT32 offset);
00139
00140         // LZW decoding stuff
00141         BOOLEAN StartDecompress();
00142         void EndDecompress();
00143         BOOLEAN DecompressLine(UINT8 *line, UINT32 &line_len);
00144         BOOLEAN BufferedInput(UINT8 *next_byte);
00145         INT GetPrefixChar(INT lz_code, INT clear_code);
00146         INT DecompressInput(INT* lz_Code);
00147
00148         UINT8 m_lzw_bytes_left;
00149         UINT8 m_bits_per_pixel;         /* Bits per pixel (Codes uses at least this + 1). */
00150         UINT8 m_code_size;
00151         INT16 m_clear_code;             /* The CLEAR LZ code. */
00152         INT16 m_eof_code;               /* The EOF LZ code. */
00153         INT16 m_running_code;           /* The next code algorithm can generate. */
00154         INT16 m_running_bits;           /* The number of bits required to represent RunningCode. */
00155         INT16 m_max_code1;              /* 1 bigger than max. possible code, in RunningBits bits. */
00156         INT16 m_last_code;              /* The code before the current code. */
00157         INT m_crnt_code;                /* Current algorithm code. */
00158         INT m_stack_ptr;                /* For character stack (see below). */
00159         INT m_crnt_shift_state;         /* Number of bits in CrntShiftDWord. */
00160         UINT32 m_crnt_shift_dword;      /* For bytes decomposition into codes. */
00161
00162         INT m_bytes_in_buffer;
00163         UINT32 m_abs_offset;
00164         UINT8* m_next_input_byte;
00165         UINT8 m_input_buffer[INPUT_BUFFER_SIZE];
00166
00167         UINT8* m_buf;
00168         UINT8* m_stack;
00169         UINT8* m_suffix;
00170         UINT16* m_prefix;
00171 };
00172
00173
00175 #endif // DOXYGEN_SHOULD_SKIP_THIS
00176 #endif  //Apoxi_GifDecoder_hpp
00177
00178
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GifImage.cpp File Reference

AddOns/MultiMedia/GifImage.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <Devices/Device.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/BitmapDc.hpp>
#include <Gui/Bitmap.hpp>
#include <Config/DisplayConfig.hpp>
#include "GifImage.hpp"
#include "GifDecoder.hpp"

Include dependency graph for GifImage.cpp:

Generated on Tue Jan 24 16:42:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GifImage.hpp File Reference

AddOns/MultiMedia/GifImage.hpp File Reference

#include <Gui/Image.hpp>
#include <Auxiliary/BinData.hpp>
#include <Kernel/Threadlet.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for GifImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GifImage

Defines

#define | Apoxi_GifImage_hpp

Define Documentation

#define Apoxi_GifImage_hpp

Generated on Tue Jan 24 16:42:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/GifImage.hpp Source File

AddOns/MultiMedia/GifImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_GifImage_hpp)
00011 #define Apoxi_GifImage_hpp
00015
00016 #include <Gui/Image.hpp>
00017 #include <Auxiliary/BinData.hpp>
00018 #include <Kernel/Threadlet.hpp>
00019 #include <Auxiliary/Vector.hpp>
00020
00022 class GifImage : public Image {
00023     typedef Image Base;
00024
00025     public:
00026         enum {
00027             ID = 2
00028         };
00029
00032         GifImage();
00033
00041         GifImage(BinData* bin_data, BOOLEAN* success = 0);
00042
00043         virtual ~GifImage();
00044
00052         void Init(BinData* bin_data, BOOLEAN* success = 0);
00053
00055         virtual BOOLEAN IsInstanceOf(INT id) const;
00056
00058         virtual const BinData* GetBinData() const;
00059
00061         virtual INT GetNextFrame(INT frame_idx) const;
00062
00064         virtual UINT32 GetFrameDelay(INT frame_idx) const;
00065
00066     protected:
00068         virtual void* BeginScanlineDrawing(INT frame_idx = 0) const;
00069
00071         virtual void EndScanlineDrawing(void* context) const;
00072
00074         virtual void DrawScanline(void* context,
00075                                   DeviceContext* dc,
00076                                   XYDIM x,
00077                                   XYDIM y,
00078                                   INT scanline_idx,
00079                                   INT old_scanline_idx) const;
00080
00082         virtual XYDIM GetScanlineDiff(void* context,
00083                                       INT scanline_idx,
00084                                       INT old_scanline_idx) const;
00085
00087         virtual BOOLEAN IsTransparent(void* context) const;
00088
00090         virtual ColorValue GetTransparentColor(void* context) const;
00091
00094         virtual BOOLEAN IsFullTraversingEnabled(void* context) const;
00095
00097         virtual XYDIM GetFrameWidth(void* context) const;
00098
00100         virtual XYDIM GetFrameHeight(void* context) const;
00101
00103         virtual XYDIM GetFrameXPos(void* context) const;
00104
00105     private:
00106         void AddFrameHandle(UINT32 handle) {m_frame_offsets.PushBack(handle);}
00107
00108         UINT32 GetFrameHandle(INT frame_idx) const {ASSERT(frame_idx <= m_frame_offsets.GetSize());
00109                                                     return m_frame_offsets[frame_idx];}
00110
00111         void AddFrameDelay(UINT32 delay) {m_frame_delays.PushBack(delay);}
00112
00113         UINT32 GetStoredFrameDelay(INT frame_idx) const {ASSERT(frame_idx <= m_frame_delays.GetSize());
00114                                                         return m_frame_delays[frame_idx];}
00115
00116         BinData* m_bin_data;
00117         Vector<UINT32> m_frame_offsets;
00118         Vector<UINT32> m_frame_delays;
00119         mutable INT m_pass_count;
00120
00121         friend class GifDecoder;
00122 };
00123
00125 #endif  //Apoxi_GifImage_hpp
00126
00127
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ImageFactory.cpp File Reference

AddOns/MultiMedia/ImageFactory.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "ImageFactory.hpp"
#include "GifImage.hpp"
#include "JpegImage.hpp"
#include "PngImage.hpp"
#include "BmpImage.hpp"
#include "WbmpImage.hpp"
#include <Gui/Image.hpp>
#include <Gui/NativeImage.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for ImageFactory.cpp:

Generated on Tue Jan 24 16:42:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ImageFactory.hpp File Reference

AddOns/MultiMedia/ImageFactory.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageFactory

Defines

#define | Apoxi_ImageFactory_hpp

Define Documentation

#define Apoxi_ImageFactory_hpp

Generated on Tue Jan 24 16:42:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ImageFactory.hpp Source File

AddOns/MultiMedia/ImageFactory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageFactory_hpp)
00011 #define Apoxi_ImageFactory_hpp
00014
00015 class Image;
00016 class BinData;
00017
00019 class ImageFactory {
00020     public:
00027         static Image* CreateImage(BinData* data, BOOLEAN* success = 0);
00028
00032         static INT GetImageId(const BinData& data);
00033
00038         static void DestroyImage(Image* image);
00039 };
00040
00041
00043 #endif // Apoxi_ImageFactory_hpp
00044
00045
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ImageItem.cpp File Reference

AddOns/MultiMedia/ImageItem.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "ImageItem.hpp"
#include <Gui/PaintDc.hpp>
#include <Gui/Image.hpp>

Include dependency graph for ImageItem.cpp:

Generated on Tue Jan 24 16:42:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ImageItem.hpp File Reference

AddOns/MultiMedia/ImageItem.hpp File Reference

#include <Gui/ImageObtainer.hpp>
#include <AddOns/MultiMedia/BoundedItem.hpp>

Include dependency graph for ImageItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageItem

Defines

#define | Apoxi_ImageItem_hpp

Define Documentation

#define Apoxi_ImageItem_hpp

Generated on Tue Jan 24 16:42:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ImageItem.hpp Source File

AddOns/MultiMedia/ImageItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageItem_hpp)
00011 #define Apoxi_ImageItem_hpp
00015
00016 #include <Gui/ImageObtainer.hpp>
00017 #include <AddOns/MultiMedia/BoundedItem.hpp>
00018
00023 class ImageItem : public BoundedItem {
00024     typedef BoundedItem Base;
00025
00026     public:
00027         enum {
00028             ID = 4
00029         };
00030
00035         explicit ImageItem(const ImageObtainer& obtainer);
00036
00037         virtual ~ImageItem();
00038
00040         virtual INT GetId() const;
00041
00043         virtual XYDIM GetWidth() const;
00044
00046         virtual XYDIM GetHeight() const;
00047
00049         virtual void Draw(DeviceContext* dc, const Rect& bounds) const;
00050
00052         const ImageObtainer& GetImageObtainer() const { return m_obtainer; }
00053
00055         const Image* GetImage() const { return m_obtainer.GetImage(); }
00056
00060         virtual AtomItem* Clone() const;
00061
00063         virtual BOOLEAN IsInstanceOf(INT id) const;
00064
00065     private:
00066         ImageObtainer m_obtainer;
00067 };
00068
00070 #endif  // Apoxi_ImageItem_hpp
00071
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/IMelody.hpp File Reference

AddOns/MultiMedia/IMelody.hpp File Reference

#include <Compat/IMelody.hpp>

Include dependency graph for IMelody.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:43:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/IMelody.hpp Source File

AddOns/MultiMedia/IMelody.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class IMelody has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/IMelody.hpp>
00014
00015
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegDecoder.cpp File Reference

AddOns/MultiMedia/JpegDecoder.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "JpegDecoder.hpp"
#include <Auxiliary/BinData.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for JpegDecoder.cpp:

Defines

#define | INPUT_BUF_SIZE 4096
#define | JPEG_PIXEL_CHANNELS 3

Define Documentation

#define INPUT_BUF_SIZE 4096

#define JPEG_PIXEL_CHANNELS 3

Generated on Tue Jan 24 16:43:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegDecoder.hpp File Reference

AddOns/MultiMedia/JpegDecoder.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_JpegDecoder_hpp

Define Documentation

#define Apoxi_JpegDecoder_hpp

Generated on Tue Jan 24 16:43:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegDecoder.hpp Source File

AddOns/MultiMedia/JpegDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_JpegDecoder_hpp)
00011 #define Apoxi_JpegDecoder_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00018
00019 #include <AddOns/jpeglib/jpeglib.h>
00020
00021 class BinData;
00022
00026 class JpegDecoder {
00027     public:
00028         enum Error {
00029             NoError,
00030             DecoderInitError,
00031             ProgressiveJpegNotSupportedError,
00032             OutOfMemoryError,
00033             DecodingError
00034         };
00035
00036     protected:
00037         JpegDecoder();
00038         virtual ~JpegDecoder();
00039
00040     public:
00042         static JpegDecoder* GetInstance();
00043
00044         /*  TODO: rename this method in future releases. No releasing
00045             is done, just a cleanup of the decoder. */
00046         void ReleaseInstance();
00047
00057         BOOLEAN Attach(const BinData &data);
00058
00059         INT GetWidth() const;
00060         INT GetHeight() const;
00061
00063         BOOLEAN BeginDecoding(const BinData &data);
00064
00067         BOOLEAN DecodeNextScanline();
00068
00074         void InitPixelColorAccess();
00075
00078         Color GetNextPixelColor();
00079
00080         const UINT8* GetScanline() const {return (UINT8*)m_scanline[0];}
00081
00083         void EndDecoding();
00084
00089         Error GetLastError() const;
00090
00091     protected:
00093         void ConnectDataSourceManager(j_decompress_ptr cinfo,
00094             const BinData &data);
00095
00097         void CleanUp();
00098
00100         BOOLEAN InitDecoderLib(const BinData &data);
00102         void FreeJpeg();
00104         void SetErr(Error code, BOOLEAN cleanup = TRUE);
00105
00106     protected:
00109         struct ErrorMgr : public jpeg_error_mgr {
00111             static void ErrorExit(j_common_ptr cinfo);
00113             static void OutputMessage(j_common_ptr cinfo);
00114
00115             // Jmp buffer for return to caller.
00116             jmp_buf setjmp_buffer;
00117         };
00118
00120         struct BinDataSourceMgr : public jpeg_source_mgr {
00122             static void InitSource(j_decompress_ptr cinfo);
00123             static boolean FillInputBuffer(j_decompress_ptr cinfo);
00124             static void SkipInputData(j_decompress_ptr cinfo, long num_bytes);
00125             static void TermSource(j_decompress_ptr cinfo);
00126
00128             const BinData *m_data;
00130             UINT32 m_data_idx;
00132             JOCTET *m_buffer;
00133         };
00134
00135     protected:
00136         BOOLEAN m_optimize_for_16bpp;
00137
00140         jpeg_decompress_struct m_dinfo;
00141         ErrorMgr m_err_mgr;
00142         JSAMPARRAY m_scanline;
00143         JDIMENSION m_width;
00144         JDIMENSION m_height;
00145
00147         INT m_scanline_idx;
00148
00150         Error m_last_error;
00151
00153         static JpegDecoder *c_decoder;
00155         static BOOLEAN c_sem_created;
00156         static Semaphore c_sem;
00157 };
00158
00160 #endif // DOXYGEN_SHOULD_SKIP_THIS
00161 #endif  // Apoxi_JpegDecoder_hpp
00162
00163
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegEncoder.cpp File Reference

AddOns/MultiMedia/JpegEncoder.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/BitmapDc.hpp>
#include <Gui/MsgTypes.hpp>
#include <Auxiliary/RamData.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <Kernel/Application.hpp>
#include "JpegImage.hpp"
#include "JpegEncoder.hpp"
#include "JpegEncodingThreadlet.hpp"

Include dependency graph for JpegEncoder.cpp:

Defines

#define OUTPUT_BUF_SIZE 1024

Define Documentation

#define OUTPUT_BUF_SIZE 1024

Generated on Tue Jan 24 16:43:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegEncoder.hpp File Reference

AddOns/MultiMedia/JpegEncoder.hpp File Reference

#include <AddOns/jpeglib/jpeglib.h>
#include <Gui/ImageEncoder.hpp>

Include dependency graph for JpegEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | JpegEncoder
struct | JpegEncoder::DataDestinationMgr
Expanded data source object reading a BinData object.
class | JpegEncoder::EncodingParameters
struct | JpegEncoder::ErrorMgr

Defines

#define | Apoxi_JpegEncoder_hpp

Define Documentation

#define Apoxi_JpegEncoder_hpp

Generated on Tue Jan 24 16:43:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegEncoder.hpp Source File

AddOns/MultiMedia/JpegEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_JpegEncoder_hpp)
00011 #define Apoxi_JpegEncoder_hpp
00015
00016 class Threadlet;
00017 class BinData;
00018 class DataSink;
00019
00020 #include <AddOns/jpeglib/jpeglib.h>
00021 #include <Gui/ImageEncoder.hpp>
00022
00025 class JpegEncoder : public ImageEncoder {
00026     typedef ImageEncoder Base;
00027
00028     public:
00031         class EncodingParameters : public ImageEncoder::EncodingParameters {
00032             typedef ImageEncoder::EncodingParameters Base;
00033
00034             public:
00038                 enum EncodingFormat {
00039                     Yuv420,
00040                     Yuv422
00041                 };
00042
00047                 EncodingParameters(XYDIM width,
00048                                    XYDIM height,
00049                                    INT quality_level,
00050                                    EncodingFormat encoding_format = Yuv422) :
00051                     Base(width, height),
00052                     m_quality_level(quality_level),
00053                     m_encoding_format(encoding_format)
00054                 {};
00055
00058                 void SetQualityLevel(INT level) { m_quality_level = level; }
00059
00062                 INT GetQualityLevel() const { return m_quality_level; }
00063
00065                 void SetEncodingFormat(EncodingFormat format) { m_encoding_format = format; }
00066
00068                 EncodingFormat GetEncodingFormat() const { return m_encoding_format; }
00069
00070                 #if defined(APOXI_COMPAT_2_8_0)
00071
00072                     enum ImageColorFormatType {
00073                         Rgb565Format,
00074                         Yuv420pFormat,
00075                         Yuv422iFormat
00076                     };
00077
00081                     EncodingParameters(XYDIM width,
00082                                        XYDIM height,
00083                                        INT quality_level,
00084                                        ImageColorFormatType color_format) :
00085                         Base(width, height),
00086                         m_quality_level(quality_level),
00087                         m_encoding_format(Yuv422),
00088                         m_color_format(color_format)
00089                     {};
00090
00093                     void SetColorFormat(ImageColorFormatType color_format) { m_color_format = color_format; }
00094
00097                     ImageColorFormatType GetColorFormat() const { return m_color_format; }
00098                 #endif // APOXI_COMPAT_2_8_0
00099
00100             private:
00101                 INT m_quality_level;
00102                 EncodingFormat m_encoding_format;
00103
00104                 #if defined(APOXI_COMPAT_2_8_0)
00105                     ImageColorFormatType m_color_format;
00106                 #endif
00107         };
00108
00110         JpegEncoder(const EncodingParameters& param);
00111
00113         virtual ~JpegEncoder();
00114
00116         virtual BOOLEAN Encode(BinData& src,
00117                                const Image::MetaData& src_params,
00118                                DataSink& dest,
00119                                BOOLEAN block = TRUE,
00120                                void* context = 0,
00121                                Cb_ImageEncoded = 0
00122                                );
00123
00125         virtual BOOLEAN Encode(const Image& img,
00126                                DataSink& dest,
00127                                BOOLEAN block = TRUE);
00128
00129     protected:
00131         virtual BOOLEAN BeginEncoding(DataSink& dest);
00132
00134         virtual BOOLEAN EndEncoding(DataSink& dest);
00135
00137         virtual BOOLEAN EncodeSynchronously(BinData& src,
00138                                             const Image::MetaData& src_params,
00139                                             DataSink& dest);
00140
00142         virtual BOOLEAN EncodeSynchronously(const Image& img, DataSink& dest);
00143
00144     private:
00145         BOOLEAN TraverseScanlines(BinData& src, JSAMPLE* buffer);
00146
00147         BOOLEAN EncodeScanline(BinData& src, JSAMPLE* buffer);
00148
00150         BOOLEAN InitEncoderLib(DataSink &dest);
00151
00153         void CleanUp();
00154
00156         void FreeJpeg();
00157
00158         void SendCallback(DataSink& dest);
00159
00161         void ConnectDataDestinationManager(j_compress_ptr cinfo, DataSink &sink);
00162
00164         void SetErr(Error code, BOOLEAN cleanup = TRUE);
00165
00168         struct ErrorMgr : public jpeg_error_mgr {
00170             static void ErrorExit(j_common_ptr cinfo);
00172             static void OutputMessage(j_common_ptr cinfo);
00173
00174             // Jmp buffer for return to caller.
00175             jmp_buf setjmp_buffer;
00176         };
00177
00179         struct DataDestinationMgr : public jpeg_destination_mgr {
00181             static void InitDestination(j_compress_ptr cinfo);
00182             static boolean EmptyOutputBuffer(j_compress_ptr cinfo);
00183             static void TermSource(j_compress_ptr cinfo);
00184
00185             DataSink *m_destination;
00186
00188             JOCTET *m_buffer;
00189         };
00190
00191
00192         Cb_ImageEncoded m_callback;
00193
00194         void* m_callback_context;
00195
00196
00199         jpeg_compress_struct m_cinfo;
00200
00201         JSAMPROW m_scanline[1];
00202
00203         JDIMENSION m_width;
00204         JDIMENSION m_height;
00205         INT m_bits;
00206         JSAMPARRAY m_raw_data[3];
00207
00209         INT m_scanline_idx;
00210
00211         Image::MetaData::ColorSpace m_color_space;
00212         EncodingParameters::EncodingFormat m_encoding_format;
00213
00214         ErrorMgr m_err_mgr;
00215 };
00216
00218 #endif  // Apoxi_JpegEncoder_hpp
00219
00220
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegEncodingThreadlet.cpp File Reference

AddOns/MultiMedia/JpegEncodingThreadlet.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "JpegEncodingThreadlet.hpp"
#include "JpegEncoder.hpp"
#include "JpegImage.hpp"

Include dependency graph for JpegEncodingThreadlet.cpp:

Generated on Tue Jan 24 16:43:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegEncodingThreadlet.hpp File Reference

AddOns/MultiMedia/JpegEncodingThreadlet.hpp File Reference

#include <Gui/EncodingThreadlet.hpp>

Include dependency graph for JpegEncodingThreadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | JpegEncodingThreadlet

Defines

#define | Apoxi_JpegEncodingThreadlet_hpp

Define Documentation

#define Apoxi_JpegEncodingThreadlet_hpp

Generated on Tue Jan 24 16:43:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegEncodingThreadlet.hpp Source File

AddOns/MultiMedia/JpegEncodingThreadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_JpegEncodingThreadlet_hpp)
00011 #define Apoxi_JpegEncodingThreadlet_hpp
00014
00015 class JpegEncoder;
00016 class JpegImage;
00017 #include <Gui/EncodingThreadlet.hpp>
00018
00020 class JpegEncodingThreadlet : public EncodingThreadlet {
00021     typedef EncodingThreadlet Base;
00022
00023     public:
00024         virtual ~JpegEncodingThreadlet();
00025
00028         static JpegEncodingThreadlet* CreateInstance(JpegEncoder& encoder,
00029                                                      const Image& source,
00030                                                      DataSink& dest);
00031
00034         static JpegEncodingThreadlet* CreateInstance(JpegEncoder& encoder,
00035                                                      BinData& source,
00036                                                      const Image::MetaData& src_params,
00037                                                      DataSink& dest);
00038
00039     protected:
00040         JpegEncodingThreadlet(JpegEncoder& encoder,
00041                               const Image& source,
00042                               DataSink& dest);
00043
00044         JpegEncodingThreadlet(JpegEncoder& encoder,
00045                               BinData& source,
00046                               const Image::MetaData& src_params,
00047                               DataSink& dest);
00048
00049 };
00050
00052 #endif // Apoxi_JpegEncodingThreadlet_hpp
00053
00054
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegImage.cpp File Reference

AddOns/MultiMedia/JpegImage.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "JpegImage.hpp"
#include "JpegDecoder.hpp"
#include <Auxiliary/BinData.hpp>
#include <Devices/Display.hpp>
#include <Gui/PaintDc.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for JpegImage.cpp:

Generated on Tue Jan 24 16:43:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegImage.hpp File Reference

AddOns/MultiMedia/JpegImage.hpp File Reference

#include <Gui/Image.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for JpegImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | JpegImage
Class to contain, decompress and draw a JPEG compatible image. More...

Defines

#define | Apoxi_JpegImage_hpp

Define Documentation

#define Apoxi_JpegImage_hpp

Generated on Tue Jan 24 16:43:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/JpegImage.hpp Source File

AddOns/MultiMedia/JpegImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_JpegImage_hpp)
00011 #define Apoxi_JpegImage_hpp
00015
00016 #include <Gui/Image.hpp>
00017 #include <Auxiliary/BinData.hpp>
00018
00019 class PaintDc;
00020
00022 class JpegImage : public Image {
00023     typedef Image Base;
00024
00025     public:
00026         enum {
00027             ID = 3
00028         };
00029
00032         JpegImage();
00033
00041         JpegImage(BinData *data, BOOLEAN *success = 0);
00042
00045         virtual ~JpegImage();
00046
00048         virtual BOOLEAN IsInstanceOf(INT id) const;
00049
00057         void Init(BinData* jpeg_data, BOOLEAN* success = 0);
00058
00060         virtual INT GetNextFrame(INT frame_idx) const;
00061
00063         virtual UINT32 GetFrameDelay(INT frame_idx) const;
00064
00066         virtual const BinData* GetBinData() const;
00067
00068     protected:
00070         virtual void* BeginScanlineDrawing(INT frame_idx = 0) const;
00071
00073         virtual void EndScanlineDrawing(void *context) const;
00074
00076         virtual void DrawScanline(void *context,
00077                                   DeviceContext *dc,
00078                                   XYDIM x,
00079                                   XYDIM y,
00080                                   INT scanline_idx,
00081                                   INT old_scanline_idx) const;
00082
00084         void FreeImage();
00085
00086     protected:
00087         BinData *m_data;
00088 };
00089
00091 #endif  // Apoxi_JpegImage_hpp
00092
00093
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Melody.hpp File Reference

AddOns/MultiMedia/Melody.hpp File Reference

#include <Compat/Melody.hpp>

Include dependency graph for Melody.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:43:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Melody.hpp Source File

AddOns/MultiMedia/Melody.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class Melody has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/Melody.hpp>
00014
00015
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MidiSound.hpp File Reference

AddOns/MultiMedia/MidiSound.hpp File Reference

#include <Compat/MidiSound.hpp>

Include dependency graph for MidiSound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:43:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MidiSound.hpp Source File

AddOns/MultiMedia/MidiSound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class MidiSound has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/MidiSound.hpp>
00014
00015
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MultiMediaEditor.cpp File Reference

AddOns/MultiMedia/MultiMediaEditor.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/EditorLine.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Gui/InputMapper.hpp>
#include <Gui/Window.hpp>
#include <Gui/ClientDc.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Config/FontConfig.hpp>
#include "MultiMediaEditor.hpp"
#include "MultiMediaEditorDocument.hpp"
#include "RichTextCompoundItem.hpp"
#include "GeneralCompoundItem.hpp"
#include "ImageItem.hpp"
#include "ParagraphMarker.hpp"
#include "BoundedItem.hpp"

Include dependency graph for MultiMediaEditor.cpp:

Generated on Tue Jan 24 16:43:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MultiMediaEditor.hpp File Reference

AddOns/MultiMedia/MultiMediaEditor.hpp File Reference

#include <Gui/AbstractMultiLineEditor.hpp>
#include <Gui/ImageBox.hpp>

Include dependency graph for MultiMediaEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MultiMediaEditor

Defines

#define | Apoxi_MultiMediaEditor_hpp

Define Documentation

#define Apoxi_MultiMediaEditor_hpp

Generated on Tue Jan 24 16:43:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MultiMediaEditor.hpp Source File

AddOns/MultiMedia/MultiMediaEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MultiMediaEditor_hpp)
00011 #define Apoxi_MultiMediaEditor_hpp
00015
00016 class ParagraphCompoundItem;
00017 class MultiMediaEditorDocument;
00018 class BoundedEditorItem;
00019 class ImageItem;
00020
00021 #include <Gui/AbstractMultiLineEditor.hpp>
00022 #include <Gui/ImageBox.hpp>
00023
00032 class MultiMediaEditor : public AbstractMultiLineEditor {
00033     typedef AbstractMultiLineEditor Base;
00034
00035     public:
00036         enum {
00037             ID = 36
00038         };
00039
00041         MultiMediaEditor();
00042
00047         MultiMediaEditor(Control* parent,
00048                          INT input_mapper_id);
00049
00051         virtual ~MultiMediaEditor();
00052
00057         void Init(Control* parent,
00058                   INT input_mapper_id);
00059
00061         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00062
00064         virtual BOOLEAN IsInstanceOf(INT id) const;
00065
00067         virtual void SetReadOnly(BOOLEAN read_only);
00068
00072         virtual void OnItemMarked(const AbstractEditorItem* item);
00073
00075         virtual void Update();
00076
00078         void SetFont(const Font& font);
00079
00081         const Font& GetFont() const { ASSERT_DEBUG(m_font != 0); return* m_font; }
00082
00084         void SetTextAttr(TextAttr text_attr);
00085
00087         TextAttr GetTextAttr() const { return m_text_attr; }
00088
00090         void SetForegroundColor(const Color& color);
00091
00093         const Color& GetForegroundColor() const { return m_foregr_color; }
00094
00096         void SetBackgroundColor(const Color& color);
00097
00099         const Color& GetBackgroundColor() const { return m_backgr_color; }
00100
00102         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00103
00105         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00106
00108         virtual BOOLEAN RemoveItem(INT index = -1);
00109
00111         virtual BOOLEAN Backspace();
00112
00114         virtual BOOLEAN GetCharItem(INT index, WCHAR& chr) const;
00115
00119         void SetTopLineGap(UINT8 gap);
00120
00124         UINT8 GetTopLineGap() const;
00125
00129         void SetBottomLineGap(UINT8 gap);
00130
00134         UINT8 GetBottomLineGap() const;
00135
00137         virtual void SetFirstVisibleLineIndex(INT line_idx);
00138
00139     protected:
00141         virtual Model* CreateModel() const;
00142
00144         virtual BOOLEAN DestroyModel(Model* model);
00145
00147         virtual void Refresh(const Rect& rect);
00148
00150         virtual void Cleanup();
00151
00153         virtual void OnPaint(const Rect& repaint_rect);
00154
00156         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00157
00159         virtual void OnLayoutClient();
00160
00168         virtual void DrawMarkedItemSelection(DeviceContext* dc,
00169                                              const Rect& item_rect,
00170                                              INT item_index);
00171
00172         // Debugging-code (enabled only for HOST-environment)
00173         #if defined(_MSC)
00174             #if defined(_DEBUG)
00175                 INT DumpCompoundItem(const CompoundItem& comp_item, INT level = 0) const;
00176             #endif
00177         #endif
00178
00179     private:
00180         enum RefreshHint {
00181             UpdatedDocument,
00182             InsertedItem,
00183             ReplacedItem,
00184             RemovedItem
00185         };
00186
00187         BOOLEAN     m_use_rt_format;
00188         INT         m_sel_action_elem_idx;
00189         const Font* m_font;
00190         TextAttr    m_text_attr;
00191         Color       m_foregr_color;
00192         Color       m_backgr_color;
00193         Vector<INT> m_action_elem_idx;
00194         Vector<ImageBox*> m_img_box_vec;
00195
00196         MultiMediaEditorDocument* GetMyDocument() { return (MultiMediaEditorDocument*)GetModel(); } //lint !e1762
00197         const MultiMediaEditorDocument* GetMyDocument() const { return (MultiMediaEditorDocument*)GetModel(); }
00198
00199         void CreateActionElemIndices();
00200         INT AdjustSelectedActionElem(BOOLEAN& old_visible, BOOLEAN& new_visible, INT delta = 0);
00201         const AbstractEditorItem* GetItem(INT index) const;
00202
00203         void RefreshImageCache(RefreshHint hint);
00204         void CleanupImageCache();
00205         void UpdateImagePositions();
00206         ImageBox* InsertImageBox(const ImageItem& img_item);
00207         void DeleteImageBox(INT index);
00208         BOOLEAN GetCharItemForParagraph(const ParagraphCompoundItem& paragraph, INT index, WCHAR& chr) const;
00209 };
00210
00212 #endif  // Apoxi_MultiMediaEditor_hpp
00213
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MultiMediaEditorDocument.cpp File Reference

AddOns/MultiMedia/MultiMediaEditorDocument.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "MultiMediaEditorDocument.hpp"
#include "RichTextCompoundItem.hpp"
#include <Gui/BidiManager.hpp>
#include <Gui/Locale.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for MultiMediaEditorDocument.cpp:

Generated on Tue Jan 24 16:43:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MultiMediaEditorDocument.hpp File Reference

AddOns/MultiMedia/MultiMediaEditorDocument.hpp File Reference

#include <Gui/EditorDocument.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <Auxiliary/Vector.hpp>
#include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>

Include dependency graph for MultiMediaEditorDocument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CompoundItemIterator
struct | CompoundItemIterator::Node
class | MultiMediaEditorDocument
class | MultiMediaEditorDocument::TextManager

Defines

#define | Apoxi_MultiMediaEditorDocument_hpp
#define | c_max_level_count 4

Define Documentation

#define Apoxi_MultiMediaEditorDocument_hpp

Generated on Tue Jan 24 16:43:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MultiMediaEditorDocument.hpp Source File

AddOns/MultiMedia/MultiMediaEditorDocument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MultiMediaEditorDocument_hpp)
00011 #define Apoxi_MultiMediaEditorDocument_hpp
00015
00016 #include <Gui/EditorDocument.hpp>
00017 #include <Gui/CharItem.hpp>
00018 #include <Gui/TextCompoundItem.hpp>
00019 #include <Auxiliary/Vector.hpp>
00020 #include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>
00021
00022 class MultiMediaEditorDocument;
00023
00024 #define c_max_level_count 4         // const INT declaration on target not possible
00025
00027 class CompoundItemIterator {
00028     public:
00031         CompoundItemIterator(const MultiMediaEditorDocument* doc);
00032
00033         virtual ~CompoundItemIterator();
00034
00039         BOOLEAN Begin();
00040
00044         BOOLEAN Next();
00045
00051         const CompoundItem* Get(INT* start_index = 0) const;
00052
00053     private:
00054         struct Node {
00055             INT m_comp_item_index;
00056             INT m_start_index;
00057             const CompoundItem* m_comp_item;
00058         } m_node[c_max_level_count];
00059         INT m_level;
00060         const MultiMediaEditorDocument* m_doc;
00061
00062         BOOLEAN TraverseToLeaf();
00063 };
00064
00070 class MultiMediaEditorDocument : public EditorDocument {
00071     typedef EditorDocument Base;
00072
00073     public:
00086         class TextManager {
00087             public:
00092                 TextManager(MultiMediaEditorDocument& doc);
00093                 virtual ~TextManager();
00094
00114                 BOOLEAN InsertText(const WString& text,
00115                                    INT item_index = -1,
00116                                    TextAttr attr = TextFormat::Normal,
00117                                    const Font* font = 0,
00118                                    const Color* foreground_color = 0,
00119                                    const Color* background_color = 0);
00120
00127                 BOOLEAN SetFont(INT item_index, INT item_count, const Font& font);
00128
00139                 BOOLEAN SetTextAttr(INT item_index, INT item_count, TextAttr attr);
00140
00147                 BOOLEAN SetForegroundColor(INT item_index, INT item_count, const Color& color);
00148
00155                 BOOLEAN SetBackgroundColor(INT item_index, INT item_count, const Color& color);
00156
00157             private:
00158                 BOOLEAN SetFormat(INT item_index,
00159                                   INT item_count,
00160                                   const TextAttr* attr = 0,
00161                                   const Font* font = 0,
00162                                   const Color* foreground_color = 0,
00163                                   const Color* background_color = 0);
00164
00165                 const Font& GetDefaultFont() const;
00166
00167                 MultiMediaEditorDocument& m_doc;
00168         };
00169
00170         MultiMediaEditorDocument();
00171
00172         virtual ~MultiMediaEditorDocument();
00173
00175         virtual INT GetItemCount() const;
00176
00178         virtual INT GetMaxItemCount() const;
00179
00181         virtual BOOLEAN InsertItem(const AtomItem& item, INT item_index);
00182
00184         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT item_index);
00185
00187         virtual BOOLEAN RemoveItem(INT item_index);
00188
00190         virtual INT GetCompoundItemCount() const;
00191
00193         virtual BOOLEAN InsertCompoundItem(CompoundItem* compound_item, INT ci_index = -1);
00194
00196         virtual BOOLEAN InsertCompoundItemBeforeItem(CompoundItem* compound_item, INT item_index = -1);
00197
00199         virtual BOOLEAN RemoveCompoundItem(INT ci_index = -1);
00200
00202         virtual const CompoundItem& GetCompoundItem(INT ci_index, INT* start_item_index = 0) const;
00203
00207         INT GetCompoundItemIndex(INT item_index) const;
00208
00210         virtual void Draw(DeviceContext* dc,
00211                           XYDIM x,
00212                           XYDIM y,
00213                           INT item_index,
00214                           INT count) const;
00215
00217         virtual INT WrapLine(INT item_index,
00218                              XYDIM width,
00219                              WrapPolicy wrap_policy = WhitespaceWrap) const;
00220
00222         virtual XYDIM GetLineWidth(INT item_index, INT count) const;
00223
00225         virtual XYDIM GetLineHeight(INT item_index, INT count, XYDIM* baseline = 0) const;
00226
00229         void SetLineAlignment(LineAlignment alignment);
00230
00232         virtual LineAlignment GetLineAlignment(INT item_index, INT count) const;
00233
00235         virtual BOOLEAN IsEditableAfterLastItem() const;
00236
00238         virtual void GetItemScope(INT item_index,
00239                                   INT count,
00240                                   INT sub_index,
00241                                   XYDIM* x,
00242                                   XYDIM* width) const;
00243
00245         virtual BOOLEAN IsRightToLeftItem(INT item_index) const;
00246
00248         virtual void Clear();
00249
00251         virtual void OnChangedLayout(const Vector<EditorLine>& line, INT from = -1, INT count = 0);
00252
00255         void SetTopLineGap(UINT8 gap);
00256
00259         UINT8 GetTopLineGap() const;
00260
00263         void SetBottomLineGap(UINT8 gap);
00264
00267         UINT8 GetBottomLineGap() const;
00268
00269     private:
00270         ParagraphCompoundItem* m_paragraph;
00271
00274         BOOLEAN IsParagraphAtEnd() const;
00275
00276     friend class CompoundItemIterator;      // accesses to m_paragraph for easier iteration
00277 };
00278
00280 #endif  // Apoxi_MultiMediaEditorDocument_hpp
00281
00282
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/MultiMediaTemplates.cpp File Reference

AddOns/MultiMedia/MultiMediaTemplates.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <AddOns/MultiMedia/GeneralCompoundItem.hpp>
#include <AddOns/MultiMedia/GifImage.hpp>
#include <AddOns/MultiMedia/MultiMediaEditor.hpp>
#include <AddOns/MultiMedia/MultiMediaEditorDocument.hpp>

Include dependency graph for MultiMediaTemplates.cpp:

Generated on Tue Jan 24 16:43:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/NativeImage.hpp File Reference

AddOns/MultiMedia/NativeImage.hpp File Reference

#include <Gui/NativeImage.hpp>

Include dependency graph for NativeImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:43:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/NativeImage.hpp Source File

AddOns/MultiMedia/NativeImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class NativeImage has been moved to GUI.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6. */
00013 #include <Gui/NativeImage.hpp>
00014
00015
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ParagraphCompoundItem.cpp File Reference

AddOns/MultiMedia/ParagraphCompoundItem.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "RichTextCompoundItem.hpp"
#include "ParagraphCompoundItem.hpp"
#include "GeneralCompoundItem.hpp"
#include "ParagraphMarker.hpp"
#include <Gui/Font.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <Gui/BidiManager.hpp>
#include <Gui/Locale.hpp>
#include <Gui/AbstractTextRenderer.hpp>
#include <Kernel/System.hpp>
#include <Config/GuiEngineConfig.hpp>

Include dependency graph for ParagraphCompoundItem.cpp:

Variables

const WCHAR c_lf = 0xa

Variable Documentation

const WCHAR c_lf = 0xa

Generated on Tue Jan 24 16:43:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ParagraphCompoundItem.hpp File Reference

AddOns/MultiMedia/ParagraphCompoundItem.hpp File Reference

#include <Gui/CompoundItem.hpp>
#include <Gui/EditorDocument.hpp>
#include <Auxiliary/Vector.hpp>
#include <AddOns/MultiMedia/CompoundItemReferrer.hpp>

Include dependency graph for ParagraphCompoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ParagraphCompoundItem

Defines

#define | Apoxi_ParagraphCompoundItem_hpp

Define Documentation

#define Apoxi_ParagraphCompoundItem_hpp

Generated on Tue Jan 24 16:43:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ParagraphCompoundItem.hpp Source File

AddOns/MultiMedia/ParagraphCompoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ParagraphCompoundItem_hpp)
00011 #define Apoxi_ParagraphCompoundItem_hpp
00015
00016 #include <Gui/CompoundItem.hpp>
00017 #include <Gui/EditorDocument.hpp>
00018 #include <Auxiliary/Vector.hpp>
00019 #include <AddOns/MultiMedia/CompoundItemReferrer.hpp>
00020
00026 class ParagraphCompoundItem : public CompoundItem {
00027     typedef CompoundItem Base;
00028
00029     public:
00030         enum {
00031             ID = 11
00032         };
00033
00035         static ParagraphCompoundItem* CreateInstance(LineAlignment alignment = EditorDocument::DefaultAlign);
00036
00037         virtual ~ParagraphCompoundItem();
00038
00040         virtual INT GetId() const;
00041
00058         BOOLEAN InsertCompoundItem(CompoundItem* item, INT ci_index = -1);
00059
00077         virtual BOOLEAN InsertCompoundItemBeforeItem(CompoundItem* comp_item, INT item_index = -1);
00078
00082         BOOLEAN RemoveCompoundItem(INT ci_index = -1);
00083
00086         INT GetCompoundItemCount() const;
00087
00089         virtual void Draw(DeviceContext* dc,
00090                           XYDIM x,
00091                           XYDIM y,
00092                           INT index,
00093                           INT count) const;
00094
00096         virtual INT WrapLine(INT index,
00097                              XYDIM width,
00098                              WrapPolicy wrap_policy = EditorDocument::WhitespaceWrap) const;
00099
00101         virtual XYDIM GetLineWidth(INT index, INT count) const;
00102
00104         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const;
00105
00107         void SetLineAlignment(LineAlignment alignment) { m_alignment = alignment; }
00108
00110         LineAlignment GetLineAlignment(INT index, INT count) const;
00111
00113         virtual INT GetItemCount() const;
00114
00116         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00117
00119         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00120
00122         virtual BOOLEAN RemoveItem(INT index = -1);
00123
00130         const CompoundItem& GetCompoundItem(INT index, INT* start_index = 0) const;
00131
00135         INT GetCompoundItemIndex(INT item_index) const;
00136
00138         virtual BOOLEAN Split(INT index, CompoundItem* *compound_item);
00139
00141         virtual CompoundItem* Clone() const;
00142
00144         virtual void Clear();
00145
00147         virtual BOOLEAN IsInstanceOf(INT id) const;
00148
00151         void SetTopLineGap(UINT8 gap) { m_top_line_gap = gap; }
00152
00155         UINT8 GetTopLineGap() const { return m_top_line_gap; }
00156
00159         void SetBottomLineGap(UINT8 gap) { m_bottom_line_gap = gap; }
00160
00163         UINT8 GetBottomLineGap() const { return m_bottom_line_gap; }
00164
00167         void UpdateBidiBuffer() const;
00168
00171         void ConvertBidiLine(INT item_index, INT count) const;
00172
00173     protected:
00174         ParagraphCompoundItem(LineAlignment alignment = EditorDocument::DefaultAlign);
00175
00182         CompoundItem* GetCompoundItem(INT index, INT* start_item_index = 0);
00183
00184         BOOLEAN MoveToParagraph(ParagraphCompoundItem* paragraph);
00185
00188         void UpdateStartIndices(INT ci_index);
00189
00190         void BeginInternalUpdate() { m_internal_update = TRUE; }
00191         void EndInternalUpdate() { m_internal_update = FALSE; }
00192         BOOLEAN IsInternalUpdate() const { return m_internal_update; }
00193
00194     private:
00195         LineAlignment m_alignment;
00196         BOOLEAN m_internal_update;
00197         INT m_item_count;
00198         UINT8 m_top_line_gap;
00199         UINT8 m_bottom_line_gap;
00200         Vector<CompoundItemReferrer> m_comp_item_vector;
00201
00202         mutable WCHAR* m_bidi_text_buf;
00203         mutable INT* m_bidi_pos;
00204         mutable INT m_bidi_buffer_len;
00205         mutable INT m_bidi_text_len;
00206
00207         void InitProperties();
00208
00213         BOOLEAN SplitAndInsert(CompoundItem* comp_item,
00214                                CompoundItem* inserted_comp_item,
00215                                INT ci_index,
00216                                INT sub_index);
00217
00221         TextCompoundItem* CreateTextCompoundItem(INT ci_index);
00222
00236         INT WrapTextCompoundItemChain(INT start_index,
00237                                       EditorDocument::WrapPolicy wrap_policy,
00238                                       INT& ci_index,
00239                                       XYDIM& width,
00240                                       BOOLEAN& wrapped) const;
00241
00246         BOOLEAN InsertRootParagraph(ParagraphCompoundItem* paragraph, INT item_index);
00247
00248         BOOLEAN AlignBidiItems(INT item_index,
00249                                INT count,
00250                                DeviceContext* dc,
00251                                XYDIM x,
00252                                XYDIM y,
00253                                XYDIM baseline,
00254                                INT* out_item_index = 0,
00255                                XYDIM* out_x = 0,
00256                                XYDIM* out_width = 0,
00257                                BOOLEAN* out_is_rtl_item = 0) const;
00258
00263         BOOLEAN SearchRightToLeftChar(const WCHAR* text, INT index) const;
00264
00265         friend class MultiMediaEditorDocument;      // allow access to method InsertRootParagraph
00266 };
00267
00269 #endif  // Apoxi_ParagraphCompoundItem_hpp
00270
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ParagraphMarker.cpp File Reference

AddOns/MultiMedia/ParagraphMarker.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <Gui/PaintDc.hpp>
#include "ParagraphMarker.hpp"

Include dependency graph for ParagraphMarker.cpp:

Generated on Tue Jan 24 16:43:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ParagraphMarker.hpp File Reference

AddOns/MultiMedia/ParagraphMarker.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Gui/CompoundItem.hpp>

Include dependency graph for ParagraphMarker.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ParagraphMarker
Represents the marker at the end of each Paragraph. More...

Defines

#define | Apoxi_ParagraphMarker_hpp

Define Documentation

#define Apoxi_ParagraphMarker_hpp

Generated on Tue Jan 24 16:43:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/ParagraphMarker.hpp Source File

AddOns/MultiMedia/ParagraphMarker.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ParagraphMarker_hpp)
00011 #define Apoxi_ParagraphMarker_hpp
00015
00016 #include <Auxiliary/WString.hpp>
00017 #include <Gui/CompoundItem.hpp>
00018
00019 class Font;
00020
00022 class ParagraphMarker : public CompoundItem {
00023     typedef CompoundItem Base;
00024
00025     public:
00026         enum {
00027             ID = 13
00028         };
00029
00031         static ParagraphMarker* CreateInstance();
00032
00034         virtual ~ParagraphMarker();
00035
00037         virtual INT GetId() const;
00038
00040         virtual void Draw(DeviceContext* dc,
00041                           XYDIM x,
00042                           XYDIM y,
00043                           INT index,
00044                           INT count) const;
00045
00047         virtual INT WrapLine(INT index,
00048                              XYDIM width,
00049                              WrapPolicy wrap_policy = EditorDocument::WhitespaceWrap) const;
00050
00052         virtual XYDIM GetLineWidth(INT index, INT count) const;
00053
00055         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const;
00056
00058         virtual INT GetItemCount() const;
00059
00061         virtual BOOLEAN IsInstanceOf(INT id) const;
00062
00063     protected:
00065         ParagraphMarker();
00066 };
00067
00069 #endif  // Apoxi_ParagraphMarker_hpp
00070
00071
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngDecoder.cpp File Reference

AddOns/MultiMedia/PngDecoder.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "PngDecoder.hpp"
#include <Auxiliary/BinData.hpp>

Include dependency graph for PngDecoder.cpp:

Defines

#define PNG_SIGNATURE_SIZE 8

Define Documentation

#define PNG_SIGNATURE_SIZE 8

Generated on Tue Jan 24 16:43:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngDecoder.hpp File Reference

AddOns/MultiMedia/PngDecoder.hpp File Reference

#include <AddOns/libpng/png.h>

Include dependency graph for PngDecoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PngDecoder
Class for decoding PNG images. More...

Defines

#define | Apoxi_PngDecoder_hpp

Define Documentation

#define Apoxi_PngDecoder_hpp

Generated on Tue Jan 24 16:43:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngDecoder.hpp Source File

AddOns/MultiMedia/PngDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PngDecoder_hpp)
00011 #define Apoxi_PngDecoder_hpp
00015
00016 #include <AddOns/libpng/png.h>
00017
00018 class BinData;
00019
00021 class PngDecoder {
00022     public:
00023         enum Error {
00024             NoError,
00025             NoPngFormatError,
00026             DecoderInitError,
00027             OutOfMemoryError,
00028             DecodingError
00029         };
00030
00031     protected:
00032         PngDecoder();
00033         virtual ~PngDecoder();
00034
00035     public:
00038         static PngDecoder* GetInstance();
00041         void ReleaseInstance();
00042
00045         static BOOLEAN IsPng(const BinData &data);
00046
00056         BOOLEAN Attach(const BinData &data);
00057
00060         INT GetWidth() const;
00064         INT GetHeight() const;
00068         BOOLEAN IsInterlaced() const;
00069
00074         BOOLEAN BeginDecoding(const BinData &data);
00075
00079         BOOLEAN IsTransparent() const;
00080
00083         Color GetTransparentColor() const;
00084
00087 //      void GetTransparentColor(UINT8 &red, UINT8 &green, UINT8 &blue) const;
00088
00093         BOOLEAN HasNativeAlphaChannel() const;
00094
00097         BOOLEAN DecodeNextScanline();
00098
00108         void InitPixelColorAccess(INT scanline_idx = 0);
00109
00116         void GetNextPixelColor(UINT8 &red, UINT8 &green, UINT8 &blue, UINT8 &alpha);
00117
00119         void EndDecoding();
00120
00124         Error GetLastError() const;
00125
00126     protected:
00128         void CleanUp();
00129
00131         BOOLEAN InitDecoderLib();
00133         void FreePng();
00135         void SetErr(Error code, BOOLEAN cleanup = TRUE);
00136
00138         static void PngLibraryReadFunction(png_structp png_struct,
00139             png_bytep data, png_size_t length);
00142         static png_voidp PngLibraryMallocFunction(png_structp png_struct,
00143             png_size_t size);
00146         static void PngLibraryFreeFunction(png_structp png_struct,
00147             png_voidp ptr);
00148
00149     protected:
00150         const BinData *m_data;
00151
00154         png_structp m_png_ptr;
00155         png_infop m_info_ptr;
00156         png_bytep m_scanline;
00157         png_uint_32 m_width;
00158         png_uint_32 m_height;
00159         int m_bit_depth;
00160         int m_color_type;
00161         int m_interlace_type;
00162
00164         BOOLEAN m_is_transparent;
00166         Color m_transparent_color;
00167         UINT8 m_trns_red;
00168         UINT8 m_trns_green;
00169         UINT8 m_trns_blue;
00170
00172         BOOLEAN m_has_native_alpha_channel;
00173
00175         BOOLEAN m_background_specified;
00177         ColorValue m_background_color;
00178         UINT8 m_bkgd_red;
00179         UINT8 m_bkgd_green;
00180         UINT8 m_bkgd_blue;
00181
00183         UINT32 m_data_idx;
00185         INT m_scanline_idx;
00186
00188         Error m_last_error;
00189
00191         static PngDecoder *c_decoder;
00193         static BOOLEAN c_sem_created;
00194         static Semaphore c_sem;
00195
00197         static png_voidp m_huge_mem;
00198
00199         // The number of channels each pixel has, i.e. 4 (RGBA).
00200         static const INT c_pixel_channels;
00201 };
00202
00204 #endif  // Apoxi_PngDecoder_hpp
00205
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngEncoder.cpp File Reference

AddOns/MultiMedia/PngEncoder.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/BitmapDc.hpp>
#include <Gui/MsgTypes.hpp>
#include <Auxiliary/RamData.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <Kernel/Application.hpp>
#include "PngImage.hpp"
#include "PngEncoder.hpp"
#include "PngEncodingThreadlet.hpp"

Include dependency graph for PngEncoder.cpp:

Defines

#define OUTPUT_BUF_SIZE 1024

Define Documentation

#define OUTPUT_BUF_SIZE 1024

Generated on Tue Jan 24 16:43:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngEncoder.hpp File Reference

AddOns/MultiMedia/PngEncoder.hpp File Reference

#include <AddOns/libpng/png.h>
#include <Gui/ImageEncoder.hpp>

Include dependency graph for PngEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PngEncoder
class | PngEncoder::EncodingParameters

Defines

#define | Apoxi_PngEncoder_hpp

Define Documentation

#define Apoxi_PngEncoder_hpp

Generated on Tue Jan 24 16:43:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngEncoder.hpp Source File

AddOns/MultiMedia/PngEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PngEncoder_hpp)
00011 #define Apoxi_PngEncoder_hpp
00012
00015
00016 class Threadlet;
00017 class BinData;
00018 class DataSink;
00019
00020 #include <AddOns/libpng/png.h>
00021 #include <Gui/ImageEncoder.hpp>
00022
00024 class PngEncoder : public ImageEncoder {
00025     typedef ImageEncoder Base;
00026
00027     public:
00030         class EncodingParameters : public ImageEncoder::EncodingParameters {
00031             typedef ImageEncoder::EncodingParameters Base;
00032
00033             public:
00037                 enum EncodingFormat {
00038                     GrayScaleFormat,
00039                     RgbFormat,
00040                     PaletteFormat,
00041                     GrayScaleAlphaFormat,
00042                     RgbAlphaFormat
00043                 };
00044
00048                 EncodingParameters(XYDIM width, XYDIM height) :
00049                     Base(width, height),
00050                     m_encoding_format(RgbFormat)
00051                 {}
00052
00054                 void SetEncodingFormat(EncodingFormat format) { m_encoding_format = format; }
00055
00057                 EncodingFormat GetEncodingFormat() const { return m_encoding_format; }
00058
00059                 #if defined(APOXI_COMPAT_2_8_0)
00060
00061                     enum ImageColorFormatType {
00062                         Rgb565Format,
00063                         Rgb888Format,
00064                         Rgba8888Format
00065                     };
00066
00070                     EncodingParameters(XYDIM width, XYDIM height, ImageColorFormatType color_format) :
00071                         Base(width, height),
00072                         m_encoding_format(RgbFormat),
00073                         m_color_format(color_format)
00074                     {}
00075
00078                     void SetColorFormat(ImageColorFormatType color_format) { m_color_format = color_format; }
00079
00082                     ImageColorFormatType GetColorFormat() const { return m_color_format; }
00083                 #endif // APOXI_COMPAT_2_8_0
00084
00085             private:
00086                 EncodingFormat m_encoding_format;
00087
00088                 #if defined(APOXI_COMPAT_2_8_0)
00089                     ImageColorFormatType m_color_format;
00090                 #endif
00091         };
00092
00093
00096         PngEncoder(const EncodingParameters& param);
00097
00099         virtual ~PngEncoder();
00100
00102         virtual BOOLEAN Encode(BinData& src,
00103                                const Image::MetaData& src_params,
00104                                DataSink& dest,
00105                                BOOLEAN block = TRUE,
00106                                void* context = 0,
00107                                Cb_ImageEncoded = 0);
00108
00110         virtual BOOLEAN Encode(const Image& img,
00111                                DataSink& dest,
00112                                BOOLEAN block = TRUE);
00113
00114     protected:
00116         virtual BOOLEAN BeginEncoding(DataSink& dest);
00117
00119         virtual BOOLEAN EndEncoding(DataSink& dest);
00120
00122         virtual BOOLEAN EncodeSynchronously(BinData& src,
00123                                             const Image::MetaData& src_params,
00124                                             DataSink& dest);
00125
00127         virtual BOOLEAN EncodeSynchronously(const Image& img, DataSink& dest);
00128
00129     private:
00130         BOOLEAN TraverseScanlines(BinData& src, png_byte* buffer);
00131
00132         BOOLEAN EncodeScanline(BinData& src, png_byte* buffer);
00133
00135         BOOLEAN InitEncoderLib(DataSink &dest);
00136
00138         void CleanUp();
00139
00140         void SendCallback(DataSink& dest);
00141
00143         void SetError(Error code, BOOLEAN cleanup = TRUE);
00144
00146         static void PngLibraryWriteFunction(png_structp png_struct,
00147             png_bytep data, png_size_t length);
00148
00150         static png_voidp PngLibraryMallocFunction(png_structp png_struct,
00151             png_size_t size);
00152
00154         static void PngLibraryFreeFunction(png_structp png_struct,
00155             png_voidp ptr);
00156
00157         Cb_ImageEncoded m_callback;
00158
00159         void* m_callback_context;
00160
00162         png_structp m_png_ptr;
00163         png_infop m_info_ptr;
00164
00165         png_bytep m_scanline[1];
00166
00167         png_uint_32 m_width;
00168         png_uint_32 m_height;
00169         INT m_bits;
00170         INT m_bit_depth;
00171         Image::MetaData::ColorSpace m_color_format;
00172
00174         static png_voidp m_huge_mem;
00175 };
00176
00178 #endif  // Apoxi_PngEncoder_hpp
00179
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngEncodingThreadlet.cpp File Reference

AddOns/MultiMedia/PngEncodingThreadlet.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "PngEncodingThreadlet.hpp"
#include "PngEncoder.hpp"
#include "PngImage.hpp"

Include dependency graph for PngEncodingThreadlet.cpp:

Generated on Tue Jan 24 16:43:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngEncodingThreadlet.hpp File Reference

AddOns/MultiMedia/PngEncodingThreadlet.hpp File Reference

#include <Gui/EncodingThreadlet.hpp>

Include dependency graph for PngEncodingThreadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PngEncodingThreadlet

Defines

#define | Apoxi_PngEncodingThreadlet_hpp

Define Documentation

#define Apoxi_PngEncodingThreadlet_hpp

Generated on Tue Jan 24 16:43:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngEncodingThreadlet.hpp Source File

AddOns/MultiMedia/PngEncodingThreadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PngEncodingThreadlet_hpp)
00011 #define Apoxi_PngEncodingThreadlet_hpp
00012
00015
00016 class PngEncoder;
00017 class PngImage;
00018
00019 #include <Gui/EncodingThreadlet.hpp>
00020
00022 class PngEncodingThreadlet : public EncodingThreadlet {
00023     typedef EncodingThreadlet Base;
00024
00025     public:
00026         virtual ~PngEncodingThreadlet();
00027
00030         static PngEncodingThreadlet* CreateInstance(PngEncoder& encoder,
00031                                                      const Image& source,
00032                                                      DataSink& dest);
00033
00036         static PngEncodingThreadlet* CreateInstance(PngEncoder& encoder,
00037                                                      BinData& source,
00038                                                      const Image::MetaData& src_params,
00039                                                      DataSink& dest);
00040
00041     protected:
00042         PngEncodingThreadlet(PngEncoder& encoder,
00043                               const Image& source,
00044                               DataSink& dest);
00045
00046         PngEncodingThreadlet(PngEncoder& encoder,
00047                               BinData& source,
00048                               const Image::MetaData& src_params,
00049                               DataSink& dest);
00050
00051 };
00052
00054 #endif  // Apoxi_PngEncodingThreadlet_hpp
00055
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngImage.cpp File Reference

AddOns/MultiMedia/PngImage.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "PngImage.hpp"
#include "PngDecoder.hpp"
#include <Auxiliary/BinData.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/BitmapDc.hpp>
#include <Gui/Bitmap.hpp>
#include <Devices/VirtualDisplay.hpp>

Include dependency graph for PngImage.cpp:

Generated on Tue Jan 24 16:43:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngImage.hpp File Reference

AddOns/MultiMedia/PngImage.hpp File Reference

#include <Gui/Image.hpp>

Include dependency graph for PngImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PngImage
Class to contain, decompress and draw a PNG compatible image. More...

Defines

#define | Apoxi_PngImage_hpp

Define Documentation

#define Apoxi_PngImage_hpp

Generated on Tue Jan 24 16:43:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PngImage.hpp Source File

AddOns/MultiMedia/PngImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PngImage_hpp)
00011 #define Apoxi_PngImage_hpp
00015
00016 #include <Gui/Image.hpp>
00017
00018 class PngDecoder;
00019 class PaintDc;
00020
00022 class PngImage : public Image {
00023     typedef Image Base;
00024
00025     public:
00026         enum {
00027             ID = 4
00028         };
00029
00032         PngImage();
00033
00041         PngImage(BinData *data, BOOLEAN *success = 0);
00042
00045         virtual ~PngImage();
00046
00048         virtual BOOLEAN IsInstanceOf(INT id) const;
00049
00056         BOOLEAN Init(BinData *data);
00057
00070         virtual BOOLEAN Draw(DeviceContext *dc, XYDIM x, XYDIM y,
00071             INT frame_idx, XYDIM scaled_width = -1, XYDIM scaled_height = -1,
00072             const Rect &clip_rect = Rect()) const;
00073
00074         virtual INT GetNextFrame(INT frame_idx) const;
00075         virtual UINT32 GetFrameDelay(INT frame_idx) const;
00076         virtual const BinData* GetBinData() const;
00077
00078     protected:
00079         virtual BOOLEAN IsTransparent(void* context) const;
00080
00081         virtual ColorValue GetTransparentColor(void* context) const;
00082
00083         virtual BOOLEAN HasAlphaChannel(void* context) const;
00084
00086         PngDecoder* BeginDrawing() const;
00087
00089         void EndDrawing(PngDecoder &decoder) const;
00090
00093         void SetupDrawingMode(const PngDecoder &decoder, XYDIM &scaled_width,
00094             XYDIM &scaled_height, XYDIM x_origin, XYDIM y_origin,
00095             INT frame_idx) const;
00096
00099         inline void SmartDrawPixel(PngDecoder &decoder, PaintDc &pdc,
00100             const Rect &clip_rect, XYDIM x, XYDIM y) const;
00101
00105         inline void DrawPixel(PngDecoder &decoder, PaintDc &pdc,
00106             const Rect &clip_rect, XYDIM x, XYDIM y, const Color &color) const;
00107
00110         inline void DrawScaledPixel(PngDecoder &decoder, PaintDc &pdc,
00111             const Rect &clip_rect, XYDIM x, XYDIM y, const Color &color) const;
00112
00115         void SmartDrawScanline(PngDecoder &decoder, PaintDc &pdc,
00116             const Rect &clip_rect, XYDIM y) const;
00117
00126         virtual void DrawScanline(PngDecoder &decoder, PaintDc &pdc,
00127             const Rect &clip_rect, XYDIM y, UINT thickness = 1) const;
00128
00130         void DrawHeightScaledScanline(PngDecoder &decoder, PaintDc &pdc,
00131             const Rect &clip_rect, XYDIM y) const;
00132
00135         BOOLEAN DecodeNextScanline(DeviceContext *dc, PngDecoder &decoder,
00136             XYDIM x, XYDIM y, XYDIM scaled_width, XYDIM scaled_height) const;
00137
00139         void FreeImage();
00140
00141     protected:
00142         BinData *m_data;
00143         BOOLEAN m_is_interlaced;
00144
00145         mutable XYDIM m_x_origin;
00146         mutable XYDIM m_y_origin;
00147
00148         mutable BOOLEAN m_scaling_width;
00149         mutable BOOLEAN m_scaling_height;
00150         mutable UINT32 m_shifted_pixel_width;
00151         mutable UINT32 m_shifted_pixel_height;
00152         mutable BOOLEAN m_scaled_right_edge_cutted;
00153         mutable BOOLEAN m_scaled_bottom_edge_cutted;
00154         mutable XYDIM m_scaled_width;
00155         mutable XYDIM m_scaled_height;
00156         mutable XYDIM m_last_unscaled_width_idx;
00157         mutable XYDIM m_last_unscaled_height_idx;
00158
00159         static const UINT32 c_shift;
00160 };
00161
00163 #endif  // Apoxi_PngImage_hpp
00164
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PreComp.cpp File Reference

AddOns/MultiMedia/PreComp.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PreComp.hpp File Reference

AddOns/MultiMedia/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/System.hpp>
#include <Gui/AbstractMultiLineEditor.hpp>
#include <Gui/EditorDocument.hpp>
#include <Gui/CompoundItem.hpp>
#include <Gui/AtomItem.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PreComp.hpp Source File

AddOns/MultiMedia/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 //lint -e506
00010 //lint -e774
00011 //lint -e527
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Gui/AbstractMultiLineEditor.hpp>
00016 #include <Gui/EditorDocument.hpp>
00017 #include <Gui/CompoundItem.hpp>
00018 #include <Gui/AtomItem.hpp>
00019
00020
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PreparedSound.hpp File Reference

AddOns/MultiMedia/PreparedSound.hpp File Reference

#include <Compat/PreparedSound.hpp>

Include dependency graph for PreparedSound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:43:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/PreparedSound.hpp Source File

AddOns/MultiMedia/PreparedSound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class PreparedSound has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/PreparedSound.hpp>
00014
00015
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/RichTextCompoundItem.cpp File Reference

AddOns/MultiMedia/RichTextCompoundItem.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "RichTextCompoundItem.hpp"
#include <Gui/Font.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Kernel/System.hpp>
#include <Gui/Locale.hpp>

Include dependency graph for RichTextCompoundItem.cpp:

Generated on Tue Jan 24 16:43:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/RichTextCompoundItem.hpp File Reference

AddOns/MultiMedia/RichTextCompoundItem.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <Gui/Color.hpp>

Include dependency graph for RichTextCompoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RichTextCompoundItem

Defines

#define | Apoxi_RichTextCompoundItem_hpp

Define Documentation

#define Apoxi_RichTextCompoundItem_hpp

Generated on Tue Jan 24 16:43:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/RichTextCompoundItem.hpp Source File

AddOns/MultiMedia/RichTextCompoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RichTextCompoundItem_hpp)
00011 #define Apoxi_RichTextCompoundItem_hpp
00015
00016 #include <Auxiliary/WString.hpp>
00017 #include <Gui/TextCompoundItem.hpp>
00018 #include <Gui/Color.hpp>
00019
00022 class RichTextCompoundItem : public TextCompoundItem {
00023     typedef TextCompoundItem Base;
00024
00025     public:
00026         enum {
00027             ID = 10
00028         };
00029
00031         static RichTextCompoundItem* CreateInstance(const Font& font, const WCHAR* text = 0);
00032
00033         virtual ~RichTextCompoundItem();
00034
00036         virtual INT GetId() const;
00037
00039         void SetTextAttr(TextAttr text_attr) { m_text_attr = text_attr; }
00040
00042         virtual TextAttr GetTextAttr() const;
00043
00045         void SetForegroundColor(const Color& color);
00046
00048         const Color& GetForegroundColor() const { return m_foregr_color; }
00049
00051         void SetBackgroundColor(const Color& color) { m_backgr_color = color; }
00052
00054         const Color& GetBackgroundColor() const { return m_backgr_color; }
00055
00057         virtual void Draw(DeviceContext* dc,
00058                           XYDIM x,
00059                           XYDIM y,
00060                           INT index,
00061                           INT count) const;
00062
00064         virtual BOOLEAN Split(INT index, CompoundItem** compound_item);
00065
00070         virtual BOOLEAN Merge(const CompoundItem& compound_item);
00071
00073         virtual CompoundItem* Clone() const;
00074
00076         virtual BOOLEAN IsInstanceOf(INT id) const;
00077
00078     protected:
00079         RichTextCompoundItem(const Font& font, const WCHAR* text = 0);
00080
00081     private:
00082         TextAttr    m_text_attr;
00083         Color       m_foregr_color;
00084         Color       m_backgr_color;
00085 };
00086
00088 #endif  // Apoxi_RichTextCompoundItem_hpp
00089
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/SmafSound.hpp File Reference

AddOns/MultiMedia/SmafSound.hpp File Reference

#include <Compat/SmafSound.hpp>

Include dependency graph for SmafSound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:43:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/SmafSound.hpp Source File

AddOns/MultiMedia/SmafSound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class SmafSound has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/SmafSound.hpp>
00014
00015
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Sound.hpp File Reference

AddOns/MultiMedia/Sound.hpp File Reference

#include <Compat/Sound.hpp>

Include dependency graph for Sound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:43:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Sound.hpp Source File

AddOns/MultiMedia/Sound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class Sound has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/Sound.hpp>
00014
00015
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/SoundItem.hpp File Reference

AddOns/MultiMedia/SoundItem.hpp File Reference

#include <Compat/SoundItem.hpp>

Include dependency graph for SoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:43:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/SoundItem.hpp Source File

AddOns/MultiMedia/SoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class SoundItem has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.12 */
00013 #include <Compat/SoundItem.hpp>
00014
00015
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Unzip.hpp File Reference

AddOns/MultiMedia/Unzip.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | FileInfo_s
struct | FileInfoInternal_s
struct | JarFileGlobalInfo_s

Defines

#define | APOXI_UNZIP_BUFSIZE (256)
#define | Apoxi_Unzip_hpp
#define | BUFREADCOMMENT (0x400)
#define | MAX_UINT16 65535
#define | SIZECENTRALDIRITEM (0x2e)
#define | SIZEZIPLOCALHEADER (0x1e)
#define | UNZ_BADZIPFILE (-103)
#define | UNZ_CRCERROR (-105)
#define | UNZ_END_OF_LIST_OF_FILE (-100)
#define | UNZ_EOF (0)
#define | UNZ_ERRNO (Z_ERRNO)
#define | UNZ_INTERNALERROR (-104)
#define | UNZ_MAXFILENAMEINZIP (256)
#define | UNZ_OK (0)
#define | UNZ_PARAMERROR (-102)

Typedefs

typedef FileInfo_s | FileInfo
typedef FileInfoInternal_s | FileInfoInternal
typedef JarFileGlobalInfo_s | JarFileGlobalInfo

Define Documentation

#define Apoxi_Unzip_hpp

Generated on Tue Jan 24 16:43:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Unzip.hpp Source File

AddOns/MultiMedia/Unzip.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  ------------------------------------------------------------------------
00010     All C++ unzip-interfaces have to be redone in future releases. It is
00011     strongly recommended to use the zlib-C-interface directly until the new
00012     interfaces are available.
00013     ------------------------------------------------------------------------ */
00014
00015
00016
00017
00018
00019
00020
00021
00022
00023
00024
00025
00026
00027
00028
00029
00030
00031
00032
00033
00034
00035
00036
00037
00038
00039
00040
00041
00042
00043
00044
00045
00046
00047
00048
00049
00050
00051
00052
00053
00054
00055
00056
00057
00058
00059
00060
00061
00062
00063
00064
00065
00066
00067
00068 #if !defined(Apoxi_Unzip_hpp)
00069 #define Apoxi_Unzip_hpp
00073
00074 /* define the constants and status information */
00075 #define UNZ_OK                   (0)
00076 #define UNZ_END_OF_LIST_OF_FILE  (-100)
00077 #define UNZ_ERRNO                (Z_ERRNO)
00078 #define UNZ_EOF                  (0)
00079 #define UNZ_PARAMERROR           (-102)
00080 #define UNZ_BADZIPFILE           (-103)
00081 #define UNZ_INTERNALERROR        (-104)
00082 #define UNZ_CRCERROR             (-105)
00083
00084
00085 #define BUFREADCOMMENT (0x400)
00086 #define SIZECENTRALDIRITEM (0x2e)
00087 #define SIZEZIPLOCALHEADER (0x1e)
00088
00089 #define UNZ_MAXFILENAMEINZIP (256)
00090 #define APOXI_UNZIP_BUFSIZE (256)
00091
00092 /* define max and min values for Apoxi data types for save casts */
00093 #define MAX_UINT16 65535
00094
00095
00096 typedef struct JarFileGlobalInfo_s
00097 {
00098     UINT16 number_entry;         /* total number of entries in
00099                                     the central dir on this disk */
00100     UINT16 size_comment;         /* size of the global comment of the zipfile */
00101 } JarFileGlobalInfo;
00102
00103 typedef struct FileInfo_s
00104 {
00105     UINT16 version;              /* version made by                 2 bytes */
00106     UINT16 version_needed;       /* version needed to extract       2 bytes */
00107     UINT16 flag;                 /* general purpose bit flag        2 bytes */
00108     UINT16 compression_method;   /* compression method              2 bytes */
00109     UINT32 dosDate;              /* last mod file date in Dos fmt   4 bytes */
00110     UINT32 crc;                  /* crc-32                          4 bytes */
00111     UINT16 compressed_size;      /* compressed size                 2 bytes */
00112     UINT16 uncompressed_size;    /* uncompressed size               2 bytes */
00113     UINT16 size_filename;        /* filename length                 2 bytes */
00114     UINT16 size_file_extra;      /* extra field length              2 bytes */
00115     UINT16 size_file_comment;    /* file comment length             2 bytes */
00116
00117     UINT16 disk_num_start;       /* disk number start               2 bytes */
00118     UINT16 internal_fa;          /* internal file attributes        2 bytes */
00119     UINT32 external_fa;          /* external file attributes        4 bytes */
00120 } FileInfo;
00121
00122
00123
00124 /* unz_s contain internal information about the zipfile
00125 */
00126 typedef struct FileInfoInternal_s
00127 {
00128     UINT32 offset_curfile;/* relative offset of local header 4 bytes */
00129 } FileInfoInternal;
00130
00132 #endif //Apoxi_Unzip_hpp
00133
00134
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/UnzipBinData.cpp File Reference

AddOns/MultiMedia/UnzipBinData.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "UnzipBinData.hpp"
#include "Unzipper.hpp"
#include <Auxiliary/BinData.hpp>

Include dependency graph for UnzipBinData.cpp:

Functions

INT16 | CloseBinData (JarBinDataStatusInfo *jar_bindata_status_info)
INT16 | CloseCurrentFileBinData (JarBinDataStatusInfo *jar_bindata_status_info)
INT16 | GetCurrentFileInfoBinData (JarBinDataStatusInfo *jar_bindata_status_info, FileInfo *pfile_info, CHAR *file_name, UINT16 name_size, void *extra_field, UINT16 extra_size, CHAR *file_comment, UINT16 comment_size)
INT16 | LocateFileBinData (JarBinDataStatusInfo *jar_bindata_status_info, const CHAR *file_name)
INT16 | OpenBinData (JarBinDataStatusInfo *jar_bindata_status_info)
INT16 | OpenCurrentFileBinData (JarBinDataStatusInfo *jar_bindata_status_info)
INT16 | ReadCurrentFileBinData (JarBinDataStatusInfo *jar_bindata_status_info, void *buf, UINT16 len)
Generated on Tue Jan 24 16:43:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/UnzipBinData.hpp File Reference

AddOns/MultiMedia/UnzipBinData.hpp File Reference

#include <AddOns/zlib/zlib.h>
#include <AddOns/MultiMedia/Unzip.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for UnzipBinData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | BinDataInReadStatusInfo
struct | JarBinDataStatusInfo

Defines

#define | Apoxi_UnzipBinData_hpp

Functions

INT16 | CloseBinData (JarBinDataStatusInfo *jar_bindata_status_info)
INT16 | CloseCurrentFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo)
INT16 | GetCurrentFileInfoBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo, FileInfo *pfile_info, CHAR *file_name, UINT16 name_size, void *extra_field, UINT16 extra_size, CHAR *file_comment, UINT16 comment_size)
INT16 | LocateFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo, const CHAR *szFileName)
INT16 | OpenBinData (JarBinDataStatusInfo *jar_bindata_status_info)
INT16 | OpenCurrentFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo)
INT16 | ReadCurrentFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo, void *buf, UINT16 len)

Define Documentation

#define Apoxi_UnzipBinData_hpp

Generated on Tue Jan 24 16:43:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/UnzipBinData.hpp Source File

AddOns/MultiMedia/UnzipBinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  ------------------------------------------------------------------------
00010     All C++ unzip-interfaces have to be redone in future releases. It is
00011     strongly recommended to use the zlib-C-interface directly until the new
00012     interfaces are available.
00013     ------------------------------------------------------------------------ */
00014
00015
00016
00017
00018
00019
00020
00021
00022
00023
00024
00025
00026
00027
00028
00029
00030
00031
00032
00033
00034
00035
00036
00037
00038
00039
00040
00041
00042
00043
00044
00045
00046
00047
00048
00049
00050
00051
00052
00053
00054
00055
00056
00057
00058
00059
00060
00061
00062
00063
00064
00065
00066
00067 #if !defined(Apoxi_UnzipBinData_hpp)
00068 #define Apoxi_UnzipBinData_hpp
00072
00073 #include <AddOns/zlib/zlib.h>
00074 #include <AddOns/MultiMedia/Unzip.hpp>
00075 #include <Auxiliary/BinData.hpp>
00076
00077 /* file_in_zip_read_info_s contain internal information about a file in zipfile,
00078     when reading and decompress it */
00079 typedef struct {
00080     CHAR  *read_buffer;            /* internal buffer for compressed data */
00081     z_stream stream;               /* zLib stream structure for inflate */
00082
00083     UINT32 pos_in_zipfile;         /* position in byte on the zipfile, for fseek*/
00084     UINT32 stream_initialised;     /* flag set if stream structure is initialised*/
00085
00086     UINT32 offset_local_extrafield;/* offset of the local extra field */
00087     UINT  size_local_extrafield;   /* size of the local extra field */
00088     UINT32 pos_local_extrafield;   /* position in the local extra field in read*/
00089
00090     UINT32 crc32;                   /* crc32 of all data uncompressed */
00091     UINT32 crc32_wait;              /* crc32 we must obtain after decompress all */
00092     UINT32 rest_read_compressed;    /* number of byte to be decompressed */
00093     UINT32 rest_read_uncompressed;  /*number of byte to be obtained after decomp*/
00094
00095     BinData* jar_bin_data;
00096
00097     UINT32 compression_method;      /* compression method (0==store) */
00098     UINT32 byte_before_the_zipfile; /* byte before the zipfile, (>0 for sfx)*/
00099 } BinDataInReadStatusInfo;
00100
00101 typedef struct {
00102     BinData* jar_bin_data;      /* the binary data of the jar-file*/
00103     JarFileGlobalInfo gi;       /* public global information */
00104     UINT32 byte_before_the_zipfile;/* byte before the zipfile, (>0 for sfx)*/
00105     UINT32 num_file;             /* number of the current file in the zipfile*/
00106     UINT32 pos_in_central_dir;   /* pos of the current file in the central dir*/
00107     UINT32 current_file_ok;      /* flag about the usability of the current file*/
00108     UINT32 central_pos;          /* position of the beginning of the central dir*/
00109
00110     UINT32 size_central_dir;     /* size of the central directory  */
00111     UINT32 offset_central_dir;   /* offset of start of central directory with
00112                                    respect to the starting disk number */
00113
00114     FileInfo cur_file_info; /* public info about the current file in zip*/
00115     FileInfoInternal cur_file_info_internal; /* private info about it*/
00116     BinDataInReadStatusInfo* pfile_in_zip_read; /* structure about the current
00117                                         file if we are decompressing it */
00118 } JarBinDataStatusInfo;
00119
00120 /*
00121  * <em>OpenBinData</em> opens an archive.
00122  * @param jar_bindata_status_info       information about the jar-bindata status
00123  * @return                          UNZ_OK if the file is found. It becomes the current file.
00124                                     UNZ_END_OF_LIST_OF_FILE if the file is not found
00125  */
00126 extern INT16 OpenBinData (JarBinDataStatusInfo *jar_bindata_status_info);
00127
00128 /*
00129  * <em>CloseBinData</em> closes an archive.
00130  * @param jar_bindata_status_info       information about the jar-bindata status
00131  */
00132
00133 extern INT16 CloseBinData (JarBinDataStatusInfo *jar_bindata_status_info);
00134
00135 /*
00136  * <em>LocateFileBinData</em> finds searches a file in the archive
00137  * @param jar_file_status_info      the information about the jar archive
00138  * @param file_name                 the filename within the archive
00139  * @return                          UNZ_OK if the file is found. It becomes the current file.
00140                                     UNZ_END_OF_LIST_OF_FILE if the file is not found
00141 */
00142 extern INT16 LocateFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo,
00143                      const CHAR *szFileName);
00144
00145 /*
00146  * <em>OpenCurrentFileBinData</em> opens the current file in the archive (has to be searched by
00147  * LocateFile before)
00148  * @param jar_file_status_info      the information about the jar archive
00149  */
00150 extern INT16 OpenCurrentFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo);
00151
00152 /*
00153  * <em>CloseCurrentFile</em> closes the current file in the archive
00154  * @param jar_file_status_info      the information about the jar archive
00155  */
00156 extern INT16 CloseCurrentFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo);
00157
00158 /*
00159  * <em>ReadCurrentFileBinData</em> reads the local file content in the buffer
00160  * @param jar_file_status_info      the information about the jar archive
00161  * @param buf                       a void* buffer for the file content
00162  * @param len                       the buffersize
00163  */
00164 extern INT16 ReadCurrentFileBinData  (JarBinDataStatusInfo *jar_bin_data_statusinfo, void* buf, UINT16 len);
00165
00166 /*
00167  * <em>GetCurrentFileInfoBinData</em> gets the file information for the current file
00168  * within the archive
00169  * @param jar_file_status_info       the information about the jar archive
00170  * @param pfile_info                 the file information, set in this method
00171  * @param file_name                  the file name, set in this method
00172  * @param name_size                  the buffer size of file_name
00173  * @param extra_field                an extra field, set in this method
00174  * @param extra_size                 the buffer size of extra_field
00175  * @param file_comment               a comment, set in this method
00176  * @param comment_size               the buffer size of file_comment
00177  */
00178 extern INT16 GetCurrentFileInfoBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo,
00179                                 FileInfo *pfile_info,
00180                                 CHAR *file_name,
00181                                 UINT16 name_size,
00182                                 void* extra_field,
00183                                 UINT16 extra_size,
00184                                 CHAR* file_comment,
00185                                 UINT16 comment_size);
00186
00188 #endif // Apoxi_UnzipBinData_hpp
00189
00190
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/UnzipFfs.cpp File Reference

AddOns/MultiMedia/UnzipFfs.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "UnzipFfs.hpp"
#include "Unzipper.hpp"
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for UnzipFfs.cpp:

Functions

INT16 | CloseCurrentFileFfs (JarFileStatusInfo *jar_file_status_info)
INT16 | CloseFfs (JarFileStatusInfo *jar_file_status_info)
INT16 | GetCurrentFileInfoFfs (JarFileStatusInfo *jar_file_status_info, FileInfo *pfile_info, CHAR *file_name, UINT16 name_size, void *extra_field, UINT16 extra_size, CHAR *file_comment, UINT16 comment_size)
INT16 | LocateFileFfs (JarFileStatusInfo *jar_file_status_info, const CHAR *file_name)
INT16 | OpenCurrentFileFfs (JarFileStatusInfo *jar_file_status_info)
INT16 | OpenFfs (UINT16 jar_file_id, JarFileStatusInfo *jar_file_status_info)
INT16 | OpenFfs (const CHAR *jar_file_name, JarFileStatusInfo *jar_file_status_info)
INT16 | OpenFfs (JarFileStatusInfo *jar_file_status_info)
INT16 | ReadCurrentFileFfs (JarFileStatusInfo *jar_file_status_info, void *buf, UINT16 len)

Function Documentation

INT16 OpenFfs ( JarFileStatusInfo * jar_file_status_info )

Generated on Tue Jan 24 16:43:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/UnzipFfs.hpp File Reference

AddOns/MultiMedia/UnzipFfs.hpp File Reference

#include <Afs/Ffs/FfsTypes.hpp>
#include <AddOns/zlib/zlib.h>
#include <AddOns/MultiMedia/Unzip.hpp>

Include dependency graph for UnzipFfs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | FileInReadStatusInfo
struct | JarFileStatusInfo

Functions

INT16 | CloseCurrentFileFfs (JarFileStatusInfo *jarFileStatusInfo)
INT16 | CloseFfs (JarFileStatusInfo *jar_file_status_info)
INT16 | GetCurrentFileInfoFfs (JarFileStatusInfo *jar_file_status_info, FileInfo *pfile_info, CHAR *file_name, UINT16 name_size, void *extra_field, UINT16 extra_size, CHAR *file_comment, UINT16 comment_size)
INT16 | LocateFileFfs (JarFileStatusInfo *jarFileStatusInfo, const CHAR *szFileName)
INT16 | OpenCurrentFileFfs (JarFileStatusInfo *jarFileStatusInfo)
INT16 | OpenFfs (UINT16 jar_file_id, JarFileStatusInfo *jarFileStatusInfo)
INT16 | OpenFfs (const CHAR *jar_file_name, JarFileStatusInfo *jarFileStatusInfo)
INT16 | ReadCurrentFileFfs (JarFileStatusInfo *jarFileStatusInfo, void *buf, UINT16 len)

Generated on Tue Jan 24 16:43:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/UnzipFfs.hpp Source File

AddOns/MultiMedia/UnzipFfs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 /*  ------------------------------------------------------------------------
00011     All C++ unzip-interfaces have to be redone in future releases. It is
00012     strongly recommended to use the zlib-C-interface directly until the new
00013     interfaces are available.
00014     ------------------------------------------------------------------------ */
00015
00016 #ifndef _unzFFS_H
00017 #define _unzFFS_H
00021
00022 #include <Afs/Ffs/FfsTypes.hpp>
00023 #include <AddOns/zlib/zlib.h>
00024 #include <AddOns/MultiMedia/Unzip.hpp>
00025
00026 /* file_in_zip_read_info_s contain internal information about a file in zipfile,
00027     when reading and decompress it */
00028 typedef struct
00029 {
00030     CHAR  *read_buffer;            /* internal buffer for compressed data */
00031     z_stream stream;               /* zLib stream structure for inflate */
00032
00033     UINT32 pos_in_zipfile;         /* position in byte on the zipfile, for fseek*/
00034     UINT32 stream_initialised;     /* flag set if stream structure is initialised*/
00035
00036     UINT32 offset_local_extrafield;/* offset of the local extra field */
00037     UINT  size_local_extrafield;   /* size of the local extra field */
00038     UINT32 pos_local_extrafield;   /* position in the local extra field in read*/
00039
00040     UINT32 crc32;                   /* crc32 of all data uncompressed */
00041     UINT32 crc32_wait;              /* crc32 we must obtain after decompress all */
00042     UINT32 rest_read_compressed;    /* number of byte to be decompressed */
00043     UINT32 rest_read_uncompressed;  /*number of byte to be obtained after decomp*/
00044
00045     const CHAR* jar_file_name;
00046     FfsHandle jar_file_handle;
00047
00048     UINT32 compression_method;      /* compression method (0==store) */
00049     UINT32 byte_before_the_zipfile; /* byte before the zipfile, (>0 for sfx)*/
00050 } FileInReadStatusInfo;
00051
00052 typedef struct
00053 {
00054     CHAR*  jar_file_name;
00055     UINT16 jar_file_id;
00056     FfsHandle jar_file_handle;
00057     JarFileGlobalInfo gi;          /* public global information */
00058     UINT32 byte_before_the_zipfile;/* byte before the zipfile, (>0 for sfx)*/
00059     UINT32 num_file;               /* number of the current file in the zipfile*/
00060     UINT32 pos_in_central_dir;     /* pos of the current file in the central dir*/
00061     UINT32 current_file_ok;        /* flag about the usability of the current file*/
00062     UINT32 central_pos;            /* position of the beginning of the central dir*/
00063
00064     UINT32 size_central_dir;       /* size of the central directory  */
00065     UINT32 offset_central_dir;     /* offset of start of central directory with
00066                                       respect to the starting disk number */
00067
00068     FileInfo cur_file_info;                  /* public info about the current file in zip*/
00069     FileInfoInternal cur_file_info_internal; /* private info about it*/
00070     FileInReadStatusInfo* pfile_in_zip_read; /* structure about the current
00071                                                 file if we are decompressing it */
00072 } JarFileStatusInfo;
00073
00074
00075 /*
00076  * <em>Open</em> opens an archive.
00077  * @param jar_file_id               the (unique) id of the file
00078  * @param jar_file_status_info      information about the jar-file status
00079  * @return                          UNZ_OK if the file is found. It becomes the current file.
00080                                     UNZ_END_OF_LIST_OF_FILE if the file is not found
00081  */
00082 extern INT16 OpenFfs (const CHAR* jar_file_name, JarFileStatusInfo *jarFileStatusInfo);
00083
00084 /*
00085  * <em>Open</em> opens an archive.
00086  * @param jar_file_name             the filename including path information of the archive
00087   * @param jar_file_status_info     information about the jar-file status
00088  * @return                          UNZ_OK if the file is found. It becomes the current file.
00089                                     UNZ_END_OF_LIST_OF_FILE if the file is not found
00090  */
00091 extern INT16 OpenFfs (UINT16 jar_file_id, JarFileStatusInfo *jarFileStatusInfo);
00092
00093 /*
00094  * <em>Close</em> closes an archive.
00095  * @param jar_file_status_info      information about the jar-file status
00096  */
00097
00098 extern INT16 CloseFfs (JarFileStatusInfo *jar_file_status_info);
00099
00100 /*
00101  * <em>LocateFile</em> finds searches a file in the archive
00102  * @param jar_file_status_info      the information about the jar archive
00103  * @param file_name                 the filename within the archive
00104  * @return                          UNZ_OK if the file is found. It becomes the current file.
00105                                     UNZ_END_OF_LIST_OF_FILE if the file is not found
00106 */
00107 extern INT16 LocateFileFfs (JarFileStatusInfo *jarFileStatusInfo,
00108                      const CHAR *szFileName);
00109
00110 /*
00111  * <em>OpenCurrentFile</em> opens the current file in the archive (has to be searched by
00112  * LocateFile before.
00113  * @param jar_file_status_info      the information about the jar archive
00114  */
00115 extern INT16 OpenCurrentFileFfs (JarFileStatusInfo *jarFileStatusInfo);
00116
00117 /*
00118  * <em>CloseCurrentFile</em> closes the current file in the archive
00119  * @param jar_file_status_info      the information about the jar archive
00120  */
00121 extern INT16 CloseCurrentFileFfs (JarFileStatusInfo *jarFileStatusInfo);
00122
00123 /*
00124  * <em>ReadCurrentFile</em> reads the local file content in the buffer
00125  * @param jar_file_status_info      the information about the jar archive
00126  * @param buf                       a void* buffer for the file content
00127  * @param len                       the buffersize
00128  */
00129 extern INT16 ReadCurrentFileFfs  (JarFileStatusInfo *jarFileStatusInfo, void* buf, UINT16 len);
00130
00131 /*
00132  * <em>GetCurrentFileInfo</em> gets the file information for the current file
00133  * within the archive
00134  * @param jar_file_status_info       the information about the jar archive
00135  * @param pfile_info                 the file information, set in this method
00136  * @param file_name                  the file name, set in this method
00137  * @param name_size                  the buffer size of file_name
00138  * @param extra_field                an extra field, set in this method
00139  * @param extra_size                 the buffer size of extra_field
00140  * @param file_comment               a comment, set in this method
00141  * @param comment_size               the buffer size of file_comment
00142  */
00143 extern INT16 GetCurrentFileInfoFfs (JarFileStatusInfo *jar_file_status_info,
00144                                 FileInfo *pfile_info,
00145                                 CHAR *file_name,
00146                                 UINT16 name_size,
00147                                 void *extra_field,
00148                                 UINT16 extra_size,
00149                                 CHAR *file_comment,
00150                                 UINT16 comment_size);
00151
00153 #endif //_unzFFS_H
00154
00155
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Unzipper.cpp File Reference

AddOns/MultiMedia/Unzipper.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "Unzipper.hpp"
#include "UnzipFfs.hpp"
#include "UnzipBinData.hpp"
#include <Afs/Ffs/FfsTypes.hpp>

Include dependency graph for Unzipper.cpp:

Typedefs

typedef UINT8 | JarExtractId

Functions

void | JVMa_getFileFromJar (JarExtractId extractionId, BinData *bin_data, const CHAR *file_name)
void | JVMa_getFileFromJar (JarExtractId extractionId, UINT32 zip_file_id, const CHAR *file_name)
void | JVMa_getFileFromJar (JarExtractId extractionId, const CHAR *zip_file_name, const CHAR *file_name)
void | JVMc_getFileFromJarResponse (JarExtractId extrationId, void *fileData, UINT32 fileSize)

Typedef Documentation

typedef UINT8 JarExtractId

Function Documentation

void JVMa_getFileFromJar | ( | JarExtractId | extractionId,
 |  | UINT32 | zip_file_id,
 |  | const CHAR * | file_name
 | ) |

void JVMa_getFileFromJar | ( | JarExtractId | extractionId,
 |  | const CHAR * | zip_file_name,
 |  | const CHAR * | file_name
 | ) |

void JVMc_getFileFromJarResponse | ( | JarExtractId | extrationId,
 |  | void * | fileData,
 |  | UINT32 | fileSize
 | ) |

JVMc_getFileFromJarResponse is called to request extraction of a specific file from a JAR file. The answer to this function should be supplied in JVMc_getFileFromJarResponse. The memory supplied in the parameters must be copied if it will be used after this function has returned.

Parameters:
extractionId | This is the requested number from JVMa_getFileFromJar
fileData | The file itself. The memory area will be deleted when the function returns. If NULL, then an error has occurred.
fileSize | The size of the received file.

Generated on Tue Jan 24 16:44:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Unzipper.hpp File Reference

AddOns/MultiMedia/Unzipper.hpp File Reference

#include <Auxiliary/BinData.hpp>

Include dependency graph for Unzipper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Unzipper

Defines

#define | Apoxi_Unzipper_hpp

Typedefs

typedef UINT8 | JarExtractId

Functions

void | JVMa_getFileFromJar (JarExtractId extractionId, BinData *bin_data, const CHAR *fileName)
void | JVMa_getFileFromJar (JarExtractId extractionId, const char *jarFileName, const char *fileName)
void | JVMa_getFileFromJar (JarExtractId extractionId, UINT32 jarFileId, const char *fileName)

Define Documentation

#define Apoxi_Unzipper_hpp

Generated on Tue Jan 24 16:44:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/Unzipper.hpp Source File

AddOns/MultiMedia/Unzipper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  ------------------------------------------------------------------------
00010     All C++ unzip-interfaces have to be redone in future releases. It is
00011     strongly recommended to use the zlib-C-interface directly until the new
00012     interfaces are available.
00013     ------------------------------------------------------------------------ */
00014
00015
00016
00017
00018
00019
00020
00021
00022
00023
00024
00025
00026
00027
00028
00029
00030
00031
00032
00033
00034
00035
00036
00037
00038
00039
00040
00041
00042
00043
00044
00045
00046
00047
00048
00049
00050
00051
00052
00053
00054
00055
00056
00057
00058
00059
00060
00061
00062
00063
00064
00065
00066
00067
00068 /*  <em>JarZipUtil.hpp</em> contains functions for extracting a single file from a .jar or .zip archive.
00069     JarZipUtil provides functions for archives stored in the FlashFileSystem (access using filename or file-id)
00070     and archives represented in BinData-objects.
00071
00072     The uncompress algorithm is based on the zlib libray by Mark Adler. The algorithm and the source code
00073     of this library is used nearly unchanged, even we done some replacement of parameters and changed some
00074     data types for less memory usage.
00075     zlib is open source and free to use for anyone, for copyright please read "zlib.h" */
00076
00077 #if !defined(Apoxi_Unzipper_hpp)
00078 #define Apoxi_Unzipper_hpp
00082
00083 #include <Auxiliary/BinData.hpp>
00084 typedef UINT8 JarExtractId;
00085
00086 /*  <em>JVMa_getFileFromJar</em> extracts a file from a jar archive, which is specified by
00087     a file id, representing a file in the FlashFileSystem. The function calls JVMc_getFileFromJarResponse
00088     when finished with extracting.
00089     @param extractionId     an unique id for the request, which is used when calling JVMc_getFileFromJarResponse
00090     @param jarFileId        the id of the zip-file in the flash file system
00091     @param fileName         the file name of the file to be extracted */
00092 void JVMa_getFileFromJar (JarExtractId extractionId,
00093                           UINT32 jarFileId,
00094                           const char* fileName);
00095
00096
00097 /*  <em>JVMa_getFileFromJar</em> extracts a file from a jar archive, which is specified by
00098     a file id, representing a file in the FlashFileSystem. The function calls JVMc_getFileFromJarResponse
00099     when finished with extracting.
00100     @param extractionId     an unique id for the request, which is used when calling JVMc_getFileFromJarResponse
00101     @param jarFileName      the file name of the zip-file in the flash file system
00102     @param fileName         the file name of the file to be extracted */
00103 void JVMa_getFileFromJar (JarExtractId extractionId,
00104                           const char* jarFileName,
00105                           const char* fileName);
00106
00107 /*  <em>JVMa_getFileFromJar</em> extracts a file from a jar archive, which is held by a BinData object.
00108     The function calls JVMc_getFileFromJarResponse when finished with extracting.
00109     @param extractionId     an unique id for the request, which is used when calling JVMc_getFileFromJarResponse
00110     @param bin_data         a BinData object containing the binary data of a zip-file
00111     @param fileName         the file name of the file to be extracted */
00112 void JVMa_getFileFromJar (JarExtractId extractionId, BinData* bin_data, const CHAR* fileName);
00113
00115 class Unzipper {
00116     public:
00118         static BOOLEAN UnzipFfs(UINT32 zip_file_id, const CHAR* file_name, void* *extracted_buffer, UINT32* extracted_buffer_size);
00119
00121         static BOOLEAN UnzipFfs(const CHAR* zip_file_name, const CHAR* file_name, void* *extracted_buffer, UINT32* extracted_buffer_size);
00122
00124         static BOOLEAN UnzipBinData(BinData* bin_data, const CHAR* file_name, void* *extracted_buffer, UINT32* extracted_buffer_size);
00125 };
00126
00128 #endif  // Apoxi_Unzipper_hpp
00129
00130
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/VCardItem.cpp File Reference

AddOns/MultiMedia/VCardItem.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "VCardItem.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for VCardItem.cpp:

Generated on Tue Jan 24 16:44:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/VCardItem.hpp File Reference

AddOns/MultiMedia/VCardItem.hpp File Reference

#include <AddOns/MultiMedia/BoundedItem.hpp>
#include <Auxiliary/VCard.hpp>

Include dependency graph for VCardItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VCardItem

Defines

#define | Apoxi_VCardItem_hpp

Define Documentation

#define Apoxi_VCardItem_hpp

Generated on Tue Jan 24 16:44:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/VCardItem.hpp Source File

AddOns/MultiMedia/VCardItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_VCardItem_hpp)
00011 #define Apoxi_VCardItem_hpp
00015
00016 #include <AddOns/MultiMedia/BoundedItem.hpp>
00017 #include <Auxiliary/VCard.hpp>
00018
00023 class VCardItem : public BoundedItem {
00024     typedef BoundedItem Base;
00025
00026     public:
00027         enum {
00028             ID = 14
00029         };
00030
00035         explicit VCardItem(const VCard& vcard);
00036         virtual ~VCardItem();
00037
00039         virtual INT GetId() const;
00040
00042         virtual XYDIM GetWidth() const;
00043
00045         virtual XYDIM GetHeight() const;
00046
00048         virtual void Draw(DeviceContext* dc, const Rect& bounds) const;
00049
00051         const VCard& GetVCard() const { return m_vcard; }
00052
00056         virtual AtomItem* Clone() const;
00057
00059         virtual BOOLEAN IsInstanceOf(INT id) const;
00060
00061     private:
00062         VCard m_vcard;
00063 };
00064
00066 #endif  // Apoxi_VCardItem_hpp
00067
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/WbmpDecoder.cpp File Reference

AddOns/MultiMedia/WbmpDecoder.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "WbmpDecoder.hpp"
#include <Gui/PaintDc.hpp>
#include <Devices/Device.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for WbmpDecoder.cpp:

Generated on Tue Jan 24 16:44:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/WbmpDecoder.hpp File Reference

AddOns/MultiMedia/WbmpDecoder.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_WbmpDecoder_hpp

Define Documentation

#define Apoxi_WbmpDecoder_hpp

Generated on Tue Jan 24 16:44:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/WbmpDecoder.hpp Source File

AddOns/MultiMedia/WbmpDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_WbmpDecoder_hpp)
00011 #define Apoxi_WbmpDecoder_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00018
00019 #include <Auxiliary/BinData.hpp>
00020 #include <Gui/Image.hpp>
00021 #include <Gui/ImageDecoder.hpp>
00022
00023 #define BITMASK_EXT_HEADERS 0x01
00024 #define BITMASK_EXT_FIELD_TYPES 0x06
00025 #define BITMASK_NAME_LENGTH 0x0E
00026 #define BITMASK_VALUE_LENGTH 0xF0
00027 #define BITMASK_HAS_MORE_PARAMS 0x01
00028
00032 class WbmpDecoder : public ImageDecoder {
00033     typedef ImageDecoder Base;
00034
00035     public:
00036         static WbmpDecoder* GetInstance();
00037
00039         virtual BOOLEAN GetMetaData(Image& image, Image::MetaData* meta_data);
00040
00042         virtual BOOLEAN BeginDecoding(const Image& image, INT frame_idx = 0);
00043
00044         UINT32 GetDataIndex() const { return m_data_index; }
00045
00046     private:
00047         UINT32 m_data_index;
00048
00049         static WbmpDecoder m_decoder;
00050
00051         WbmpDecoder();
00052         BOOLEAN ReadHeader(const BinData& bin_data,
00053                            UINT32* parse_idx,
00054                            XYDIM* width = 0,
00055                            XYDIM* height = 0) const;
00056
00062         BOOLEAN UInt2Long(const BinData& bin_data, UINT32* parse_idx, INT32* return_val) const;
00063 };
00064
00066 #endif // DOXYGEN_SHOULD_SKIP_THIS
00067 #endif
00068
00069
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/WbmpImage.cpp File Reference

AddOns/MultiMedia/WbmpImage.cpp File Reference

#include <AddOns/MultiMedia/PreComp.hpp>
#include "WbmpImage.hpp"
#include "WbmpDecoder.hpp"
#include <Gui/PaintDc.hpp>
#include <Devices/Device.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for WbmpImage.cpp:

Generated on Tue Jan 24 16:44:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/WbmpImage.hpp File Reference

AddOns/MultiMedia/WbmpImage.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <Gui/Image.hpp>

Include dependency graph for WbmpImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WbmpImage

Defines

#define | Apoxi_WbmpImage_hpp

Define Documentation

#define Apoxi_WbmpImage_hpp

Generated on Tue Jan 24 16:44:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/MultiMedia/WbmpImage.hpp Source File

AddOns/MultiMedia/WbmpImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_WbmpImage_hpp)
00011 #define Apoxi_WbmpImage_hpp
00015
00016 #include <Auxiliary/BinData.hpp>
00017 #include <Gui/Image.hpp>
00018
00019
00020
00022 class WbmpImage : public Image {
00023     typedef Image Base;
00024
00025     public:
00026         enum {
00027             ID = 5
00028         };
00029
00031         WbmpImage();
00032
00040         WbmpImage(BinData* data, BOOLEAN* success = 0);
00041
00043         virtual ~WbmpImage();
00044
00046         virtual BOOLEAN IsInstanceOf(INT id) const;
00047
00055         void Init(BinData* data, BOOLEAN* success = 0);
00056
00058         virtual const BinData* GetBinData() const;
00059
00061         virtual INT GetNextFrame(INT frame_idx) const { return frame_idx; }
00062
00064         virtual UINT32 GetFrameDelay(INT frame_idx) const { return c_unlimited; }
00065
00066     protected:
00068         virtual void* BeginScanlineDrawing(INT frame_idx = 0) const;
00069
00071         virtual void EndScanlineDrawing(void* context) const;
00072
00074         virtual void DrawScanline(void* context,
00075                                   DeviceContext* dc,
00076                                   XYDIM x,
00077                                   XYDIM y,
00078                                   INT scanline_idx,
00079                                   INT old_scanline_idx) const;
00080
00082         virtual BOOLEAN IsTransparent(void* context) const;
00083
00085         virtual ColorValue GetTransparentColor(void* context) const;
00086
00087     private:
00088         BinData* m_bin_data;
00089 };
00090
00092 #endif
00093
00094
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/RfsObexFtpServer/PreComp.cpp File Reference

AddOns/RfsObexFtpServer/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/RfsObexFtpServer/PreComp.hpp File Reference

AddOns/RfsObexFtpServer/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/RfsObexFtpServer/PreComp.hpp Source File

AddOns/RfsObexFtpServer/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/RfsObexFtpServer/RfsObexFtpServer.cpp File Reference

AddOns/RfsObexFtpServer/RfsObexFtpServer.cpp File Reference

#include "PreComp.hpp"
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/FileDataSink.hpp>
#include <Afs/Rfs/FileDataSource.hpp>
#include "RfsObexFtpServer.hpp"

Include dependency graph for RfsObexFtpServer.cpp:

Defines

#define RfsObexFtpTrace(x)

Define Documentation

#define RfsObexFtpTrace ( x )

Generated on Tue Jan 24 16:44:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/RfsObexFtpServer/RfsObexFtpServer.hpp File Reference

AddOns/RfsObexFtpServer/RfsObexFtpServer.hpp File Reference

#include <Afs/Rfs/Path.hpp>
#include <Obex/ObexFtpServer.hpp>

Include dependency graph for RfsObexFtpServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RfsObexFtpServer
A basic OBEX FTP server for the root file system (RFS). More...

Defines

#define | RfsObexFtpServer_hpp

Define Documentation

#define RfsObexFtpServer_hpp

Generated on Tue Jan 24 16:44:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/RfsObexFtpServer/RfsObexFtpServer.hpp Source File

AddOns/RfsObexFtpServer/RfsObexFtpServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(RfsObexFtpServer_hpp)
00011 #define RfsObexFtpServer_hpp
00012
00013 #include <Afs/Rfs/Path.hpp>
00014 #include <Obex/ObexFtpServer.hpp>
00015
00022 class RfsObexFtpServer : public ObexFtpServer {
00023
00024     typedef ObexFtpServer Base;
00025
00026     public:
00031         RfsObexFtpServer();
00032
00044         RfsObexFtpServer(ExecutionContext* ctx_ptr, const Path& root_path);
00045
00047         virtual ~RfsObexFtpServer();
00048
00057         virtual void Init(ExecutionContext* ctx_ptr, const Path& root_path);
00058
00060         // Implementation of abstract base class methods.
00061         // See base class for details.
00063
00064         virtual void OnBind(const ObexAddrPtr& addr_ptr, ObexResult result);
00065         virtual void OnConnect(const ObexHeaderList& headers, UINT8 flags);
00066         virtual void OnDisconnected(ObexResult result);
00067         virtual void OnGetFolderListing(const WString& current_folder);
00068         virtual void OnProvideFolderListingEntries(
00069             const WString& current_folder);
00070         virtual void OnSetCurrentFolder(const WString& current_folder,
00071             const WString& new_current_folder, BOOLEAN create);
00072         virtual void OnDeleteObject(const WString& current_folder,
00073             const WString& object);
00074         virtual void OnFilePush(const WString& current_folder,
00075             const WString& filename, UINT32 size);
00076         virtual void OnFilePushRequestCompleted(ObexResult result);
00077         virtual void OnFilePull(const WString& current_folder,
00078             const WString& filename);
00079         virtual void OnFilePullRequestCompleted(ObexResult result);
00080
00081     protected:
00083         Path GetAbsolutePath(const WString& path, const WString& object = L"");
00084
00085         // Root path of the server.
00086         Path m_root_path;
00087
00088         // Directory iterator shared pointer, necessary for retrieving folder
00089         // listings.
00090         DirectoryIteratorPtr m_dir_itor_ptr;
00091 };
00092
00093 #endif  // RfsObexFtpServer_hpp
00094
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialClientSocket.cpp File Reference

AddOns/SerialSocket/SerialClientSocket.cpp File Reference

#include "SerialSocketsPreComp.hpp"
#include "SerialSocketDataLock.hpp"
#include "SerialClientSocket.hpp"

Include dependency graph for SerialClientSocket.cpp:

Generated on Tue Jan 24 16:44:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialClientSocket.hpp File Reference

AddOns/SerialSocket/SerialClientSocket.hpp File Reference

#include "SerialSocket.hpp"
#include "SockAddress.hpp"

Include dependency graph for SerialClientSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class SerialClientSocket

Generated on Tue Jan 24 16:44:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialClientSocket.hpp Source File

AddOns/SerialSocket/SerialClientSocket.hpp

Go to the documentation of this file.
00001 /* ============================================================================
00002 ** Copyright (C) 2004-2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** ============================================================================
00004 **
00005 ** This document contains proprietary information belonging to COMNEON.
00006 ** Passing on and copying of this document, use and communication of its
00007 ** contents is not permitted without prior written authorisation.
00008 **
00009 ** ============================================================================
00010 ** Revision Information :
00011 **    File name: SerialClientSocket.h
00012 **    Version:
00013 **    Date: 2005-08-31    14:48:26
00014 **
00015 ** ============================================================================
00016 **
00017 ** Project:     VenusU
00018 ** Block:       SerialClientSocket
00019 ** Process:
00020 ** File name:   SerialClientSocket.h
00021 **
00022 ** ============================================================================
00023 **
00024 **
00025 ** ============================================================================
00026 ** History:
00027 **
00028 ** Date       Author                Comment
00029 ** ----------------------------------------------------------------------------
00030 **
00031 ** 31.08.05   Murugan/Balan         created.
00032 ** ============================================================================
00033 */
00034
00035 #ifndef SERIAL_CLIENTSOCKET_H
00036 #define SERIAL_CLIENTSOCKET_H
00037
00038 #include "SerialSocket.hpp"
00039 #include "SockAddress.hpp"
00040
00041 class SerialServerSocket;
00042
00043 class SerialClientSocket : public SerialSocket
00044 {
00045     typedef SerialSocket Base;
00046 public:
00047     SerialClientSocket();
00048     virtual ~SerialClientSocket();
00049
00053     INT Bind(SocketAddr& sock_addr);
00054
00058     INT Connect(SocketAddr& serv_addr);
00059
00060 protected:
00061 //  SerialSocketData *m_sd;
00062
00063 friend SerialServerSocket;
00064 };
00065
00066
00067 #endif //SERIAL_CLIENTSOCKET_H
00068
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialIoAdapter.cpp File Reference

AddOns/SerialSocket/SerialIoAdapter.cpp File Reference

#include "SerialSocketsPreComp.hpp"
#include "SerialIoAdapter.hpp"
#include "SerialSocket.hpp"
#include "SerialSocketData.hpp"
#include <iodriver.h>
#include <iolib.h>

Include dependency graph for SerialIoAdapter.cpp:

Generated on Tue Jan 24 16:44:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialIoAdapter.hpp File Reference

AddOns/SerialSocket/SerialIoAdapter.hpp File Reference

#include <Socket/Socket.hpp>
#include <Kernel/Condition.hpp>
#include <sio_sock.h>
#include <sio_dev.h>
#include "SockAddress.hpp"
#include <iodriver.h>
#include <iolib.h>

Include dependency graph for SerialIoAdapter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialIoAdapter
struct | SerialIoAdapter::SioErrorDesc
class | SerialIoSet
Maintains fd set for the socket operations. More...

Defines

#define | SIO_SIGNAL_DATA_SENT SIO_SIGNAL_LAST_BIT_SENT
#define | SIO_USE_SOCKET_CONCEPT 1

Generated on Tue Jan 24 16:44:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialIoAdapter.hpp Source File

AddOns/SerialSocket/SerialIoAdapter.hpp

Go to the documentation of this file.
00001 /* ============================================================================
00002 ** Copyright (C) 2004-2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** ============================================================================
00004 **
00005 ** This document contains proprietary information belonging to COMNEON.
00006 ** Passing on and copying of this document, use and communication of its
00007 ** contents is not permitted without prior written authorisation.
00008 **
00009 ** ============================================================================
00010 ** Revision Information :
00011 **    File name: SerialIoAdapter.h
00012 **    Version:
00013 **    Date: 2005-08-31    14:48:26
00014 **
00015 ** ============================================================================
00016 **
00017 ** Project:     VenusU
00018 ** Block:       SerialIoAdapter
00019 ** Process:
00020 ** File name:   SerialIoAdapter.h
00021 **
00022 ** ============================================================================
00023 **
00024 **
00025 ** ============================================================================
00026 ** History:
00027 **
00028 ** Date       Author                Comment
00029 ** ----------------------------------------------------------------------------
00030 **
00031 ** 31.08.05   Murugan/Balan         created.
00032 ** ============================================================================
00033 */
00034
00035 #ifndef SERIALIO_ADAPTER_H
00036 #define SERIALIO_ADAPTER_H
00037
00040
00041 #define SIO_USE_SOCKET_CONCEPT 1
00042
00043 // TODO: remove this define after receiving write_fd support from SIO
00044 // #define SIO_STUB_SELECT_WRITE_SUPPORT
00045
00046 #include <Socket/Socket.hpp>
00047 #include <Kernel/Condition.hpp>
00048 #include <sio_sock.h>
00049 #include <sio_dev.h>
00050 #include "SockAddress.hpp"
00051 #include <iodriver.h>
00052 #include <iolib.h>
00053
00054 #if defined ( SIO_STUB_SELECT_WRITE_SUPPORT )
00055 #define SIO_SIGNAL_DATA_SENT    SIO_SIGNAL_LAST + 1
00056 #else
00057 #define SIO_SIGNAL_DATA_SENT    SIO_SIGNAL_LAST_BIT_SENT
00058 #endif
00059
00060 class SerialSocket;
00061 class SerialSocketData;
00063 class SerialIoSet
00064 {
00065 public:
00066     SerialIoSet ();
00067     ~SerialIoSet ();
00068
00069     enum SerialSocketEvent
00070     {
00071             NONE            /* No events */
00072         ,   ABORT           /* Event for the received ETX char. */
00073         ,   CLOSE_REQ       /* Close the descriptor. */
00074         ,   CONNECT_REQ     /* Signal to a server socket. */
00075         ,   CONNECT_SUCCESS /* Connect success. */
00076         ,   CONNECT_FAIL    /* Connect fail. */
00077         ,   DATA_RECEIVED   /* Received data from the serial device. */
00078         ,   DATA_SENT       /* Data is sent via the serial device. */
00079         ,   DISCONNECT_IND  /* Signal to a client socket. */
00080         ,   UNKNOWN         /* Unknown socket */
00081     };
00082
00083     BOOLEAN Init();
00084
00087     BOOLEAN Add( const SerialSocketData *s ) { BOOLEAN ret; ret = !AddToReadList ( s ); ret |= !AddToWriteList ( s ); return ( ret ); }
00088
00091     BOOLEAN Remove( const SerialSocketData *s ) { BOOLEAN ret; ret = !RemoveFromReadList ( s ); ret |= !RemoveFromWriteList ( s ); return ( ret ); }
00092
00095     INT AddToReadList(const SerialSocketData *sockdata);
00096
00099     INT RemoveFromReadList(const SerialSocketData *sockdata );
00100
00103     INT AddToWriteList(const SerialSocketData *sockdata);
00104
00107     INT RemoveFromWriteList(const SerialSocketData *sockdata );
00108
00111     INT Select( const Ticks *t_timeout );
00112
00115     BOOLEAN SignalSelect ();
00116
00119     BOOLEAN TestFor ( const SerialSocketData *sockdata ) const;
00120
00124 #if defined ( USE_STUB )
00125     SerialSocketEvent GetEvent ( const SerialSocketData *sockdata );
00126 #else
00127     SerialSocketEvent GetEvent ( const SerialSocketData *sockdata ) const;
00128 #endif
00129
00130 public:
00131 #if defined ( USE_STUB )
00132     SerialSocket    *m_sock1;
00133     SerialSocket    *m_sock2;
00134
00135     INT             m_signal1;
00136     INT             m_signal2;
00137 #else
00138     fd_set_t    m_read_fdset;
00139     fd_set_t    m_write_fdset;
00140     INT         m_selectid;
00141 #endif
00142 };
00143
00144
00145 class SerialIoAdapter
00146 {
00147 public:
00148     friend SerialSocket;
00149     friend SerialIoSet;
00150
00151     // Error structures
00152     enum ErrorCode
00153     {
00154         c_sio_err_none          =   SIO_ERR_NONE,
00155         c_sio_err_acces         =   SIO_ERR_ACCES,           /* 1   Permission denied. */
00156         c_sio_err_addrnnotvail  =   SIO_ERR_ADDRNOTAVAIL,    /* 2   Cannot assign requested address. */
00157         c_sio_err_afnosupport   =   SIO_ERR_AFNOSUPPORT,     /* 3   Address family not supported by protocol */
00158         c_sio_err_again         =   SIO_ERR_AGAIN,           /* 4   Try again. */
00159         c_sio_err__already      =   SIO_ERR_ALREADY,         /* 5   Operation already in progress. */
00160         c_sio_err_badf          =   SIO_ERR_BADF,            /* 6   Invalid file descriptor. */
00161         c_sio_err_busy          =   SIO_ERR_BUSY,            /* 7   Device or resource busy. */
00162         c_sio_err_connrefused   =   SIO_ERR_CONNREFUSED,     /* 8   Connection refused. */
00163         c_sio_err_fault         =   SIO_ERR_FAULT,           /* 9   Bad address. */
00164         c_sio_err_inprogress    =   SIO_ERR_INPROGRESS,      /* 10  Operation now in progress. */
00165         c_sio_err_inval         =   SIO_ERR_INVAL,           /* 11  Invalid argument. */
00166         c_sio_err_nametoolong   =   SIO_ERR_NAMETOOLONG,     /* 12  File name too long. */
00167         c_sio_err_nfile         =   SIO_ERR_NFILE,           /* 13  File table overflow. */
00168         c_sio_err_noact         =   SIO_ERR_NOACT,           /* 14  No device action handler. */
00169         c_sio_err_nodev         =   SIO_ERR_NODEV,           /* 15  No such device. */
00170         c_sio_err_nomem         =   SIO_ERR_NOMEM,           /* 16  Out of memory. */
00171         c_sio_err_noopt         =   SIO_ERR_NOOPT,           /* 17  Option not implemented. */
00172         c_sio_err_noprotoopt    =   SIO_ERR_NOPROTOOPT,      /* 18  Protocol not available. */
00173         c_sio_err_nosubdev      =   SIO_ERR_NOSUBDEV,        /* 19  No such device sub structure. */
00174         c_sio_err_nosys         =   SIO_ERR_NOSYS,           /* 20  Function not implemented. */
00175         c_sio_err_notsock       =   SIO_ERR_NOTSOCK,         /* 21  Argument descriptor is not a socket. */
00176         c_sio_err_nscan         =   SIO_ERR_NSCAN,           /* 22  Scanner list overflow. */
00177         c_sio_err_opnotsupp     =   SIO_ERR_OPNOTSUPP,       /* 23  Operation not supported. */
00178         c_sio_err_protonosupport    =   SIO_ERR_PROTONOSUPPORT,  /* 24  Protocol not supported. */
00179         c_sio_err_sockstate     =   SIO_ERR_SOCKSTATE,       /* 25  The  socket is in the wrong state. */
00180         c_sio_err_timeout       =   SIO_ERR_TIMEDOUT,        /* 26  Connection timed out. */
00181         c_sio_err_max           =   SIO_ERR_MAX
00182
00183     };
00184
00185     struct SioErrorDesc
00186     {
00187         ErrorCode   c_sio_errno;     /* Number of last error. */
00188         ErrorCode   c_global_errno;  /* Number of last error. */
00189         CHAR        *file_name;     /* Location of the error. */
00190         LONG        line_no;       /* Location of the error. */
00191     };
00192
00193     //maintain the order as present in Enum sock_pf_t in sio_sock.h
00194     enum SocketFamily
00195     {
00196         c_sock_pf_undef = 0,
00197         c_sock_pf_termio,           /* Modem terminal. */
00198         c_sock_pf_bt,               /* Bluetooth. */
00199         c_sock_pf_max               /* For now..  */
00200     };
00201
00202 #if defined ( USE_STUB )
00203     SerialIoAdapter ( SerialSocket *pSerialSocket );
00204 #else
00205     SerialIoAdapter();
00206 #endif
00207
00208     ~SerialIoAdapter();
00209
00214     INT Open (SocketFamily fam, INT protocol );
00215
00222     INT Accept(SerialSocket& clientSock, SocketAddr& sock_addr);
00223
00227     INT Bind(SocketAddr& sock_addr);
00228
00232     INT Connect(SocketAddr& serv_addr);
00233
00237     INT Close();
00238
00243     INT GetErrorNumber(SioErrorDesc& errorinfo);
00244
00245     INT IoCtl(INT requestcode, INT argument);
00246
00249     INT Listen(INT backlog);
00250
00256     INT OptGet(INT optname, void* optval, INT& optlen);
00257
00263     INT OptSet(INT optname, void* optval, INT optlen);
00264
00269     INT Read(void* buf, LONG length);
00270
00275     INT Write(const void* buf, LONG count);
00276
00277 private:
00278     LONG m_sd;
00279     LONG m_fd;
00280
00281 #if defined (USE_STUB )
00282     SerialSocket *m_remote_socket;
00283     //BOOLEAN        bConnected;
00284     static BooleanCondition m_connected_cond;
00285 #endif
00286
00287 };
00288
00289 #endif //SERIALIO_ADAPTER_H
00290
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialIoAdapterStub.cpp File Reference

AddOns/SerialSocket/SerialIoAdapterStub.cpp File Reference

#include "SerialSocketsPreComp.hpp"
#include "SerialIoAdapter.hpp"
#include "SerialSocket.hpp"
#include "SerialSocketData.hpp"
#include "SerialSocketThread.hpp"

Include dependency graph for SerialIoAdapterStub.cpp:

Generated on Tue Jan 24 16:44:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialServerSocket.cpp File Reference

AddOns/SerialSocket/SerialServerSocket.cpp File Reference

#include "SerialSocketsPreComp.hpp"
#include "SerialSocketDataLock.hpp"
#include "SerialServerSocket.hpp"
#include "SerialClientSocket.hpp"

Include dependency graph for SerialServerSocket.cpp:

Generated on Tue Jan 24 16:44:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialServerSocket.hpp File Reference

AddOns/SerialSocket/SerialServerSocket.hpp File Reference

#include "SerialSocket.hpp"
#include "SockAddress.hpp"

Include dependency graph for SerialServerSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class SerialServerSocket

Generated on Tue Jan 24 16:44:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialServerSocket.hpp Source File

AddOns/SerialSocket/SerialServerSocket.hpp

Go to the documentation of this file.
00001 /* ============================================================================
00002 ** Copyright (C) 2004-2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** ============================================================================
00004 **
00005 ** This document contains proprietary information belonging to COMNEON.
00006 ** Passing on and copying of this document, use and communication of its
00007 ** contents is not permitted without prior written authorisation.
00008 **
00009 ** ============================================================================
00010 ** Revision Information :
00011 **    File name: SerialServerSocket.h
00012 **    Version:
00013 **    Date: 2005-08-31    14:48:26
00014 **
00015 ** ============================================================================
00016 **
00017 ** Project:     VenusU
00018 ** Block:       SerialServerSocket
00019 ** Process:
00020 ** File name:   SerialServerSocket.h
00021 **
00022 ** ============================================================================
00023 **
00024 **
00025 ** ============================================================================
00026 ** History:
00027 **
00028 ** Date       Author                Comment
00029 ** ----------------------------------------------------------------------------
00030 **
00031 ** 31.08.05   Murugan/Balan         created.
00032 ** ============================================================================
00033 */
00034
00035 #ifndef SERIAL_SERVERSOCKET_H
00036 #define SERIAL_SERVERSOCKET_H
00037
00038 #include "SerialSocket.hpp"
00039 #include "SockAddress.hpp"
00040
00041 class SerialServerSocket : public SerialSocket
00042 {
00043     typedef SerialSocket Base;
00044 public:
00045     SerialServerSocket();
00046     virtual ~SerialServerSocket();
00047
00054     INT Accept(SerialSocket& clientSock, SocketAddr& addr);
00055
00059     INT Bind(SocketAddr& serv_addr);
00060
00064     INT Listen(INT backlog);
00065
00066 protected:
00067 //  SerialSocketData *m_sd;
00068 };
00069
00070
00071 #endif //SERIAL_SERVERSOCKET_H
00072
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocket.cpp File Reference

AddOns/SerialSocket/SerialSocket.cpp File Reference

#include "SerialSocketsPreComp.hpp"
#include "SerialSocket.hpp"
#include "SerialSocketDataLock.hpp"
#include <Socket/SocketMsg.hpp>

Include dependency graph for SerialSocket.cpp:

Generated on Tue Jan 24 16:44:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocket.hpp File Reference

AddOns/SerialSocket/SerialSocket.hpp File Reference

#include "SerialIoAdapter.hpp"

Include dependency graph for SerialSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialSocket

Defines

#define | DEBUG(__X__) ;

Define Documentation

#define DEBUG ( __X__ ) ;

Generated on Tue Jan 24 16:44:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocket.hpp Source File

AddOns/SerialSocket/SerialSocket.hpp

Go to the documentation of this file.
00001 /* ============================================================================
00002 ** Copyright (C) 2004-2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** ============================================================================
00004 **
00005 ** This document contains proprietary information belonging to COMNEON.
00006 ** Passing on and copying of this document, use and communication of its
00007 ** contents is not permitted without prior written authorisation.
00008 **
00009 ** ============================================================================
00010 ** Revision Information :
00011 **    File name: SerialSocket.h
00012 **    Version:
00013 **    Date: 2005-08-31    14:48:26
00014 **
00015 ** ============================================================================
00016 **
00017 ** Project:     VenusU
00018 ** Block:       SerialSocket Layer
00019 ** Process:
00020 ** File name:   SerialSocket.h
00021 **
00022 ** ============================================================================
00023 **
00024 **
00025 ** ============================================================================
00026 ** History:
00027 **
00028 ** Date       Author  Comment
00029 ** ----------------------------------------------------------------------------
00030 **
00031 ** 26.07.04   ges     created.
00032 ** ============================================================================
00033 */
00034
00035 #ifndef SERIAL_SOCK_H
00036 #define SERIAL_SOCK_H
00037
00038 #include "SerialIoAdapter.hpp"
00039 //class SerialIoAdapter;
00040
00041 // #define  DEBUG_SERIAL_SOCKET
00042
00043 #if defined ( DEBUG_SERIAL_SOCKET )
00044 #define DEBUG( __X__ ) printf __X__
00045 #else
00046 #define DEBUG( __X__ )  ;
00047 #endif  /* DEBUG_SERIAL_SOCKET ) */
00048
00049 class SerialSocket : public Socket
00050 {
00051     typedef Socket Base;
00052     friend class SerialIoAdapter;
00053     friend class SerialIoSet;
00054
00055 public:
00056     SerialSocket();
00057     virtual ~SerialSocket();
00058
00059     void OnControlMsg(const SocketControlMsg &msg);
00060
00065     BOOLEAN Open ( SerialIoAdapter::SocketFamily fam, INT protocol );
00066
00067
00068     //Functions implemented for the base class Socket
00071     virtual BOOLEAN IsOpen() const;
00072
00075     virtual BOOLEAN Close();
00076
00079     virtual BOOLEAN IsBlocking() const;
00080
00083     virtual BOOLEAN SetBlocking(BOOLEAN block = FALSE);
00084
00089     virtual INT Read(void *buf, INT buflen);
00090
00095     virtual INT Write(const void *buf, INT buflen);
00096
00097     // todo: comments
00098     INT IoCtl(INT requestcode, INT argument);
00099
00105     INT OptGet(INT optname, void* optval, INT& optlen);
00106
00112     INT OptSet(INT optname, const void* optval, INT optlen);
00113
00114 protected:
00115     SerialSocketData *m_sd;
00116     SerialIoAdapter m_serialio;
00117
00118 };
00119
00120 #endif //SERIAL_SOCK_H
00121
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketData.cpp File Reference

AddOns/SerialSocket/SerialSocketData.cpp File Reference

#include "SerialSocketsPreComp.hpp"
#include "SerialSocketData.hpp"
#include "SerialSocketThread.hpp"
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for SerialSocketData.cpp:

Generated on Tue Jan 24 16:44:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketData.hpp File Reference

AddOns/SerialSocket/SerialSocketData.hpp File Reference

#include <Socket/Sys/SysSocket.hpp>
#include <Socket/SocketData.hpp>
#include <Socket/DataConnProfile.hpp>
#include "SerialSocket.hpp"
#include <Kernel/Condition.hpp>

Include dependency graph for SerialSocketData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialSocketData

Defines

#define | Apoxi_SerialSocketData_hpp

Define Documentation

#define Apoxi_SerialSocketData_hpp

Generated on Tue Jan 24 16:44:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketData.hpp Source File

AddOns/SerialSocket/SerialSocketData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SerialSocketData_hpp)
00011 #define Apoxi_SerialSocketData_hpp
00014
00015 #include <Socket/Sys/SysSocket.hpp>
00016 #include <Socket/SocketData.hpp>
00017 #include <Socket/DataConnProfile.hpp>
00018 #include "SerialSocket.hpp"
00019 #include <Kernel/Condition.hpp>
00020
00021 class Socket;
00022 class ExecutionContext;
00023 class SerialIoSet;
00024
00026 /* This is derived from SocketData only to pass this object using SocketControlMsg */
00027 class SerialSocketData  : public SocketData
00028 {
00029     typedef SocketData Base;
00030
00031     friend class SerialSocket;
00032     friend class SerialClientSocket;
00033     friend class SerialServerSocket;
00034     friend class SerialSocketSubSystem;
00035
00036     public:
00037         SerialSocket* GetAttachedSerialSocket() const { return ( m_socket ); }
00038         ExecutionContext* GetContext() const { return m_context; }
00039
00040         BOOLEAN IsInUse() const { return m_socket != 0; }
00041
00042         SerialIoSet *GetSerialIoSet () const { return m_io_set; }
00043         void SetSerialIoSet ( SerialIoSet *set ) { m_io_set = set; }
00044
00045     private:
00046         SerialSocket *m_socket;
00047         ExecutionContext *m_context;
00048         SerialIoSet *m_io_set;
00049
00050         SerialSocketData();
00051
00052         void Attach(SerialSocket *s);
00053         void Detach(SerialSocket *s);
00054 };
00055
00057 #endif  // Apoxi_SocketData_hpp
00058
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketDataLock.hpp File Reference

AddOns/SerialSocket/SerialSocketDataLock.hpp File Reference

#include <SerialSocketSubSystem.hpp>
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for SerialSocketDataLock.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialSocketDataLock

Defines

#define | Apoxi_SocketDataLock_hpp

Define Documentation

#define Apoxi_SocketDataLock_hpp

Generated on Tue Jan 24 16:44:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketDataLock.hpp Source File

AddOns/SerialSocket/SerialSocketDataLock.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SocketDataLock_hpp)
00011 #define Apoxi_SocketDataLock_hpp
00014
00015 #include <SerialSocketSubSystem.hpp>
00016 #include <Kernel/Os/MutexObtainer.hpp>
00017
00020 class SerialSocketDataLock : public MutexObtainer
00021 {
00022     public:
00023         SerialSocketDataLock() : MutexObtainer(&SerialSocketSubSystem::m_mutex_socket)
00024             {}
00025 };
00026
00028 #endif  // Apoxi_SocketDataLock_hpp
00029
00030
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketsPreComp.cpp File Reference

AddOns/SerialSocket/SerialSocketsPreComp.cpp File Reference

#include "SerialSocketsPreComp.hpp"

Include dependency graph for SerialSocketsPreComp.cpp:

Generated on Tue Jan 24 16:44:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketsPreComp.hpp File Reference

AddOns/SerialSocket/SerialSocketsPreComp.hpp File Reference

#include <Kernel/Lib.hpp>

Include dependency graph for SerialSocketsPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:44:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketsPreComp.hpp Source File

AddOns/SerialSocket/SerialSocketsPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketSubSystem.cpp File Reference

AddOns/SerialSocket/SerialSocketSubSystem.cpp File Reference

#include "SerialSocketsPreComp.hpp"
#include "SerialSocketSubSystem.hpp"

Include dependency graph for SerialSocketSubSystem.cpp:

Generated on Tue Jan 24 16:44:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketSubSystem.hpp File Reference

AddOns/SerialSocket/SerialSocketSubSystem.hpp File Reference

#include <Kernel/Os/Mutex.hpp>
#include <Kernel/SubSystem.hpp>
#include "SerialSocketData.hpp"
#include "SerialSocketThread.hpp"

Include dependency graph for SerialSocketSubSystem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialSocketSubSystem

Defines

#define | Apoxi_SerialSocketSubSystem_hpp

Define Documentation

#define Apoxi_SerialSocketSubSystem_hpp

Generated on Tue Jan 24 16:44:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketSubSystem.hpp Source File

AddOns/SerialSocket/SerialSocketSubSystem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SerialSocketSubSystem_hpp)
00011 #define Apoxi_SerialSocketSubSystem_hpp
00014
00015 #include <Kernel/Os/Mutex.hpp>
00016 #include <Kernel/SubSystem.hpp>
00017 #include "SerialSocketData.hpp"
00018 #include "SerialSocketThread.hpp"
00019
00023 class SerialSocketSubSystem : public SubSystem
00024 {
00025     typedef SubSystem Base;
00026     friend class SerialSocket;
00027     friend class SerialSocketThread;
00028     friend class SerialSocketDataLock;
00029     friend class SerialClientSocket;
00030     friend class SerialServerSocket;
00031     friend class Os;
00032
00033     public:
00034         SerialSocketSubSystem();
00035
00036         static SerialSocketSubSystem* GetInstance() { return m_instance; }
00037
00038         virtual const WCHAR* GetName() const { return L"SERIALSOCK"; }
00039         virtual void OnPowerUp();
00040
00041         virtual BootSequenceState InvokeAt() const;
00042
00043     private:
00044         static SerialSocketSubSystem *m_instance;
00045         static SerialSocketThread m_thread;
00046         static Mutex m_mutex_socket;
00047         static SerialSocketData m_sd[c_max_inet_socket_count];
00048
00049         static SerialSocketData& GetSerialSocketData(UINT idx) {
00050             ASSERT(idx < c_max_inet_socket_count);
00051             return m_sd[idx];
00052         }
00053
00054         static SerialSocketData* GetFreeSerialSocketDataEntry();
00055 };
00056
00058 #endif  // Apoxi_SocketSubSystem_hpp
00059
00060
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketThread.cpp File Reference

AddOns/SerialSocket/SerialSocketThread.cpp File Reference

#include "SerialSocketsPreComp.hpp"
#include "SerialSocketThread.hpp"
#include "SerialSocketDataLock.hpp"
#include "Socket/SocketMsg.hpp"
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for SerialSocketThread.cpp:

Generated on Tue Jan 24 16:44:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketThread.hpp File Reference

AddOns/SerialSocket/SerialSocketThread.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Socket/Sys/SysSocket.hpp>
#include "SerialIoAdapter.hpp"

Include dependency graph for SerialSocketThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerialSocketThread

Defines

#define | Apoxi_SerialSocketThread_hpp

Define Documentation

#define Apoxi_SerialSocketThread_hpp

Generated on Tue Jan 24 16:44:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SerialSocketThread.hpp Source File

AddOns/SerialSocket/SerialSocketThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SerialSocketThread_hpp)
00011 #define Apoxi_SerialSocketThread_hpp
00014
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Socket/Sys/SysSocket.hpp>
00017 #include "SerialIoAdapter.hpp"
00018
00019 class SerialSocketData;
00020
00022 class SerialSocketThread : public Thread
00023 {
00024         typedef Thread Base;
00025
00026     public:
00027         SerialSocketThread ();
00028
00029         BOOLEAN Init();
00030
00033         static BOOLEAN NotifyOnData(const SerialSocketData *sd, BOOLEAN enable = TRUE);
00034
00037         static BOOLEAN StopNotifications(const SerialSocketData *sd);
00038
00041         static BOOLEAN Wakeup();
00042
00045         static BOOLEAN Shutdown();
00046
00049         static BOOLEAN AddToList(const SerialSocketData *sd, SerialIoSet &set);
00050
00053         static BOOLEAN RemoveFromList(const SerialSocketData *sd, SerialIoSet &set);
00054
00055         static SerialIoSet* GetIoSetInstance() { return &m_ioset; }
00056
00057     private:
00058         static BOOLEAN m_quit;
00059         static INT m_socket_count;
00060         static UINT32 m_msg_id;
00061         static Semaphore m_sem_wait;
00062         static SerialIoSet m_ioset;
00063
00064         virtual INT ThreadFn();
00065
00066         static void TraceFdSet();
00067
00068 };
00069
00071 #endif  // Apoxi_SocketRxThread_hpp
00072
00073
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SockAddress.hpp File Reference

AddOns/SerialSocket/SockAddress.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class SocketAddr

Generated on Tue Jan 24 16:44:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SerialSocket/SockAddress.hpp Source File

AddOns/SerialSocket/SockAddress.hpp

Go to the documentation of this file.
00001 /* ============================================================================
00002 ** Copyright (C) 2004-2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** ============================================================================
00004 **
00005 ** This document contains proprietary information belonging to COMNEON.
00006 ** Passing on and copying of this document, use and communication of its
00007 ** contents is not permitted without prior written authorisation.
00008 **
00009 ** ============================================================================
00010 ** Revision Information :
00011 **    File name: SockAddress.h
00012 **    Version:
00013 **    Date: 2005-10-24    14:48:26
00014 **
00015 ** ============================================================================
00016 **
00017 ** Project:     VenusU
00018 ** Block:       SockAddress
00019 ** Process:
00020 ** File name:   SockAddress.h
00021 **
00022 ** ============================================================================
00023 **
00024 **
00025 ** ============================================================================
00026 ** History:
00027 **
00028 ** Date       Author                Comment
00029 ** ----------------------------------------------------------------------------
00030 **
00031 ** 31.08.05   Murugan/Balan         created.
00032 ** ============================================================================
00033 */
00034
00035 #ifndef SERIAL_SOCKADDRESS_H
00036 #define SERIAL_SOCKADDRESS_H
00037
00038 //Socket address base class
00039 //Each sock address types are derived from this class
00040 class SocketAddr
00041 {
00042 public:
00044     SocketAddr(){}
00048     virtual void* GetSockAddr() = 0;
00049     virtual INT32 GetSockAddrSize() = 0;
00050
00053     virtual ~SocketAddr(){}
00054 private:
00055 };
00056
00057 #endif //SERIAL_SOCKADDRESS_H
00058
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/ApoxiServerVersion.cpp File Reference

AddOns/Server/ApoxiServerVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiServerVersion.cpp:

Functions

ApoxiDefVersionInfo (Server, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | Server | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:44:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/AuthProvider.cpp File Reference

AddOns/Server/AuthProvider.cpp File Reference

#include "PreComp.hpp"
#include "AuthProvider.hpp"

Include dependency graph for AuthProvider.cpp:

Generated on Tue Jan 24 16:44:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/AuthProvider.hpp File Reference

AddOns/Server/AuthProvider.hpp File Reference

#include <Auxiliary/NiSharedPtr.hpp>
#include <Afs/Rfs/Path.hpp>

Include dependency graph for AuthProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AuthProvider

Defines

#define | Apoxi_AddOns_Server_AuthProvider_hpp

Typedefs

typedef NiSharedPtr< AuthProvider > | AuthProviderPtr
Smart-pointer controlling a AuthProvider object.

Define Documentation

#define Apoxi_AddOns_Server_AuthProvider_hpp

Generated on Tue Jan 24 16:44:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/AuthProvider.hpp Source File

AddOns/Server/AuthProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_AuthProvider_hpp)
00011 #define Apoxi_AddOns_Server_AuthProvider_hpp
00014
00015 #include <Auxiliary/NiSharedPtr.hpp>
00016 #include <Afs/Rfs/Path.hpp>
00017
00018 class AuthProvider;
00019
00021 typedef NiSharedPtr<AuthProvider> AuthProviderPtr;
00022
00025 class AuthProvider
00026 {
00027     public:
00030         AuthProvider();
00031
00034         virtual ~AuthProvider();
00035
00040         virtual BOOLEAN AuthorizeUser(const String& username) = 0;
00041
00047         virtual BOOLEAN AuthorizeUserPassword(const String& username, const String& password) = 0;
00048
00054         virtual BOOLEAN IsAccessGranted(const String& username, const Path& path) = 0;
00055
00056 };
00057
00059 #endif  // Apoxi_AddOns_Server_AuthProvider_hpp
00060
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/PreComp.cpp File Reference

AddOns/Server/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/PreComp.hpp File Reference

AddOns/Server/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/PreComp.hpp Source File

AddOns/Server/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #include <Kernel/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012
00013
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/Server.cpp File Reference

AddOns/Server/Server.cpp File Reference

#include "PreComp.hpp"
#include <Socket/DataConnProfileManager.hpp>
#include "Server.hpp"

Include dependency graph for Server.cpp:

Generated on Tue Jan 24 16:45:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/Server.hpp File Reference

AddOns/Server/Server.hpp File Reference

#include <Kernel/ServiceThread.hpp>
#include <Socket/InetSocketAddr.hpp>
#include <Socket/DataConnProfile.hpp>
#include <AddOns/Server/AuthProvider.hpp>
#include <AddOns/Server/ServerConfig.hpp>
#include <AddOns/Server/ServerClient.hpp>

Include dependency graph for Server.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Server

Defines

#define | Apoxi_AddOns_Server_Server_hpp
#define | APOXI_SERVER_DEFAULT_BACKLOG 15
#define | APOXI_SERVER_DEFAULT_MAX_USERS 5
#define | SERVER_DBG_OUT_RANGE 35900

Typedefs

typedef NiSharedPtr< Server > | ServerPtr
Smart-pointer controlling a Server object.

Define Documentation

#define Apoxi_AddOns_Server_Server_hpp

Generated on Tue Jan 24 16:45:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/Server.hpp Source File

AddOns/Server/Server.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_Server_hpp)
00011 #define Apoxi_AddOns_Server_Server_hpp
00014
00015 #include <Kernel/ServiceThread.hpp>
00016 #include <Socket/InetSocketAddr.hpp>
00017 #include <Socket/DataConnProfile.hpp>
00018 #include <AddOns/Server/AuthProvider.hpp>
00019 #include <AddOns/Server/ServerConfig.hpp>
00020 #include <AddOns/Server/ServerClient.hpp>
00021
00022 #if defined(APOXI_SER_DATACONN_SUPPORT)
00023 #include <Socket/SerDataConnProfile.hpp>
00024 #endif
00025
00026 // define a DBG_OUT range for Server
00027 #define SERVER_DBG_OUT_RANGE 35900
00028
00029 // default value for backlog of the listening TcpServerSocket
00030 #define APOXI_SERVER_DEFAULT_BACKLOG 15
00031
00032 // default maximum of currently connected clients
00033 #define APOXI_SERVER_DEFAULT_MAX_USERS 5
00034
00035 class Server;
00036
00038 typedef NiSharedPtr<Server> ServerPtr;
00039
00042 class Server : public ServiceThread
00043 {
00044     typedef ServiceThread Base;
00045
00046     public:
00049         Server(AuthProvider* authProvider,
00050             ServerConfig* serverConfig,
00051             UINT maxUsers = APOXI_SERVER_DEFAULT_MAX_USERS,
00052             INT backlog = APOXI_SERVER_DEFAULT_BACKLOG);
00053
00056         virtual ~Server() = 0;
00057
00064         virtual void Start(const InetSocketAddr& localAddr, DataConnProfileId dataConnProfileId = c_invalid_data_conn_profile_id) = 0;
00065
00069         virtual void Stop() = 0;
00070
00076         virtual ServerClient* GetClient(UINT clientId);
00077
00082         virtual UINT GetClientCount();
00083
00088         virtual BOOLEAN IsRunning() { return m_running; }
00089
00090
00095         virtual UINT GetMaxUsers();
00096
00101         virtual void SetMaxUsers(UINT maxUsers);
00102
00107         virtual INT GetBacklog();
00108
00113         virtual void SetBacklog(INT backlog);
00114
00115
00116 #if defined(APOXI_SER_DATACONN_SUPPORT)
00117
00121         virtual DataConnProfileId GetTempSerDataConnProfileId()
00122         { return s_temp_serial_dcp.GetId(); }
00123
00128         virtual UINT8 GetTempSerDataConnProfileIdRefs()
00129             { return s_temp_serial_dcp_refs; }
00130
00135         virtual UINT8 IncreaseTempSerDataConnProfileIdRefs()
00136             { return ++s_temp_serial_dcp_refs; }
00137
00142         virtual UINT8 DecrementTempSerDataConnProfileIdRefs()
00143             { return (s_temp_serial_dcp_refs > 0) ? --s_temp_serial_dcp_refs : 0; }
00144
00150         virtual BOOLEAN IsSerialDeviceInUse();
00151 #endif
00152
00153     protected:
00156         virtual BOOLEAN AddClient(ServerClient* client);
00157
00160         virtual void Init() = 0;
00161
00164         virtual void Terminate() = 0;
00165
00168         virtual IpAddr GetHostIp() = 0;
00169
00172         virtual IpPortNo GetPort() = 0;
00173
00176         virtual AuthProviderPtr GetAuthProvider();
00177
00180         virtual void SetAuthProvider(AuthProviderPtr authProvider);
00181
00184         virtual ServerConfigPtr GetServerConfig();
00185
00188         virtual void SetServerConfig(ServerConfigPtr serverConfig);
00189
00190         AuthProviderPtr m_authProvider;
00191         ServerConfigPtr m_serverConfig;
00192         BOOLEAN m_running;
00193         SimpleMap<UINT, ServerClient*> m_clients;
00194
00195         // maximum of currently connected clients
00196         UINT m_maxUsers;
00197
00198         // value for backlog of the listening TcpServerSocket
00199         INT m_backlog;
00200
00201 #if defined(APOXI_SER_DATACONN_SUPPORT)
00202         // temporary default serial profile (needed if no CSD or GPRS profile is defined)
00203         static SerDataConnProfile s_temp_serial_dcp;
00204         // stores the number of clients using the serial data connection
00205         static UINT8 s_temp_serial_dcp_refs;
00206 #endif
00207 };
00208
00210 #endif  // Apoxi_AddOns_Server_Server_hpp
00211
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/ServerClient.cpp File Reference

AddOns/Server/ServerClient.cpp File Reference

#include "PreComp.hpp"
#include "ServerClient.hpp"

Include dependency graph for ServerClient.cpp:

Generated on Tue Jan 24 16:45:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/ServerClient.hpp File Reference

AddOns/Server/ServerClient.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ServerClient

Defines

#define | Apoxi_AddOns_Server_ServerClient_hpp

Typedefs

typedef NiSharedPtr< ServerClient > | ServerClientPtr
Smart-pointer controlling a ServerClient object.

Define Documentation

#define Apoxi_AddOns_Server_ServerClient_hpp

Generated on Tue Jan 24 16:45:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/ServerClient.hpp Source File

AddOns/Server/ServerClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_ServerClient_hpp)
00011 #define Apoxi_AddOns_Server_ServerClient_hpp
00014
00015 class ServerClient;
00016
00018 typedef NiSharedPtr<ServerClient> ServerClientPtr;
00019
00020 class Server;
00021
00022
00025 class ServerClient
00026 {
00027     friend class Server;
00028
00029     public:
00032         virtual ~ServerClient();
00033
00036         virtual UINT GetId();
00037
00038     protected:
00041         ServerClient(Server* server);
00042
00043         // Counts actually used instances.
00044         static UINT s_instance_cnt;
00045
00046         // parent server
00047         Server* m_server;
00048
00049         // id of the client (the following number of s_instance_cnt on initialization)
00050         UINT m_clientId;
00051
00052 };
00053
00055 #endif  // Apoxi_AddOns_Server_ServerClient_hpp
00056
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/ServerConfig.cpp File Reference

AddOns/Server/ServerConfig.cpp File Reference

#include "PreComp.hpp"
#include "ServerConfig.hpp"

Include dependency graph for ServerConfig.cpp:

Generated on Tue Jan 24 16:45:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/ServerConfig.hpp File Reference

AddOns/Server/ServerConfig.hpp File Reference

#include <Afs/Rfs/Pathname.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Socket/DataConnProfile.hpp>

Include dependency graph for ServerConfig.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ServerConfig

Defines

#define | Apoxi_AddOns_Server_ServerConfig_hpp

Typedefs

typedef NiSharedPtr< ServerConfig > | ServerConfigPtr
Smart-pointer controlling a ServerConfig object.

Define Documentation

#define Apoxi_AddOns_Server_ServerConfig_hpp

Generated on Tue Jan 24 16:45:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/ServerConfig.hpp Source File

AddOns/Server/ServerConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_ServerConfig_hpp)
00011 #define Apoxi_AddOns_Server_ServerConfig_hpp
00014
00015 #include <Afs/Rfs/Pathname.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017 #include <Socket/DataConnProfile.hpp>
00018
00019 class ServerConfig;
00020
00022 typedef NiSharedPtr<ServerConfig> ServerConfigPtr;
00023
00026 class ServerConfig
00027 {
00028     public:
00031         ServerConfig();
00032
00035         virtual ~ServerConfig();
00036
00041         virtual const Pathname& GetRootDir();
00042
00047         virtual void SetRootDir(Pathname rootDir);
00048
00053         virtual DataConnProfileId GetDataConnProfileId();
00054
00059         virtual void SetDataConnProfileId(DataConnProfileId dataConnProfileId);
00060
00065         virtual UINT GetMaxUsers();
00066
00071         virtual void SetMaxUsers(UINT maxUsers);
00072
00077         virtual INT GetBacklog();
00078
00083         virtual void SetBacklog(INT backlog);
00084
00085     protected:
00086         // location of root directory of the server
00087         Pathname m_rootDir;
00088
00089         // ID of the DataConnProfile to use for socket connections
00090         DataConnProfileId m_dataConnProfileId;
00091
00092         // maximum of currently connected clients
00093         UINT m_maxUsers;
00094
00095         // value for backlog of the listening TcpServerSocket
00096         INT m_backlog;
00097 };
00098
00100 #endif  // Apoxi_AddOns_Server_ServerConfig_hpp
00101
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/ApoxiFtpServerVersion.cpp File Reference

AddOns/Server/FtpServer/ApoxiFtpServerVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiFtpServerVersion.cpp:

Functions

ApoxiDefVersionInfo (FtpServer, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | FtpServer | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:44:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpAuthProvider.cpp File Reference

AddOns/Server/FtpServer/FtpAuthProvider.cpp File Reference

#include "PreComp.hpp"
#include "FtpAuthProvider.hpp"

Include dependency graph for FtpAuthProvider.cpp:

Generated on Tue Jan 24 16:44:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpAuthProvider.hpp File Reference

AddOns/Server/FtpServer/FtpAuthProvider.hpp File Reference

#include <AddOns/Server/AuthProvider.hpp>
#include <Afs/Rfs/Pathname.hpp>

Include dependency graph for FtpAuthProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpAuthProvider

Defines

#define | Apoxi_AddOns_Server_FtpAuthProvider_hpp

Typedefs

typedef NiSharedPtr< FtpAuthProvider > | FtpAuthProviderPtr
Smart-pointer controlling a FtpAuthProvider object.

Define Documentation

#define Apoxi_AddOns_Server_FtpAuthProvider_hpp

Generated on Tue Jan 24 16:44:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpAuthProvider.hpp Source File

AddOns/Server/FtpServer/FtpAuthProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpAuthProvider_hpp)
00011 #define Apoxi_AddOns_Server_FtpAuthProvider_hpp
00014
00015 #include <AddOns/Server/AuthProvider.hpp>
00016 #include <Afs/Rfs/Pathname.hpp>
00017
00018 class FtpAuthProvider;
00019
00021 typedef NiSharedPtr<FtpAuthProvider> FtpAuthProviderPtr;
00022
00025 class FtpAuthProvider : public AuthProvider
00026 {
00027     typedef AuthProvider Base;
00028
00029     public:
00032         FtpAuthProvider();
00033
00036         virtual ~FtpAuthProvider();
00037
00042         virtual BOOLEAN AuthorizeUser(const String& username);
00043
00049         virtual BOOLEAN AuthorizeUserPassword(const String& username, const String& password);
00050
00056         virtual BOOLEAN IsAccessGranted(const String& username, const Path& path);
00057
00063         virtual Pathname GetUserHome(const String& username) = 0;
00064
00065 };
00066
00068 #endif  // Apoxi_AddOns_Server_FtpAuthProvider_hpp
00069
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpClient.cpp File Reference

AddOns/Server/FtpServer/FtpClient.cpp File Reference

#include "PreComp.hpp"
#include "FtpClient.hpp"
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include <Kernel/System.hpp>
#include <Auxiliary/Date.hpp>
#include "FtpAuthProvider.hpp"
#include "FtpInTransfer.hpp"
#include "FtpOutTransfer.hpp"
#include "FtpServer.hpp"

Include dependency graph for FtpClient.cpp:

Generated on Tue Jan 24 16:44:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpClient.hpp File Reference

AddOns/Server/FtpServer/FtpClient.hpp File Reference

#include <Socket/InetSocketAddr.hpp>
#include <AddOns/Server/Server.hpp>
#include "FtpSocket.hpp"
#include "FtpDataSocket.hpp"
#include "FtpDataServerSocket.hpp"
#include "FtpTransfer.hpp"
#include "FtpRequest.hpp"
#include "MsgTypes.hpp"

Include dependency graph for FtpClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpClient

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpClient_hpp

Typedefs

typedef NiSharedPtr< FtpClient > | FtpClientPtr
Smart-pointer controlling a FtpClient object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpClient_hpp

Generated on Tue Jan 24 16:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpClient.hpp Source File

AddOns/Server/FtpServer/FtpClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpClient_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpClient_hpp
00014
00015 #include <Socket/InetSocketAddr.hpp>
00016 #include <AddOns/Server/Server.hpp>
00017 #include "FtpSocket.hpp"
00018 #include "FtpDataSocket.hpp"
00019 #include "FtpDataServerSocket.hpp"
00020 #include "FtpTransfer.hpp"
00021 #include "FtpRequest.hpp"
00022 #include "MsgTypes.hpp"
00023
00024 class FtpClient;
00025
00027 typedef NiSharedPtr<FtpClient> FtpClientPtr;
00028
00029
00032 class FtpClient : public ServerClient
00033 {
00034     friend class FtpServer;
00035     friend class FtpDataServerSocket;
00036
00037     typedef ServerClient Base;
00038
00039     public:
00040         enum State {
00041             c_state_not_logged_in,
00042             c_state_terminated,
00043             c_state_login_process,
00044             c_state_logged_in
00045         };
00046
00049         FtpClient(Server* server, Pathname homeDir, Pathname currentDir = Pathname(L"/"));
00050
00053         virtual ~FtpClient();
00054
00057         virtual UINT GetId();
00058
00061         virtual const String& GetUser();
00062
00065         virtual FtpSocketPtr GetFtpSocket();
00066
00069         virtual FtpDataSocketPtr GetFtpDataSocket();
00070
00073         virtual InetSocketAddr GetPeerDataSocketAddr();
00074
00077         virtual InetSocketAddr GetLocalDataSocketAddr();
00078
00081         virtual FtpDataConnectionType GetDataConnectionType();
00082
00083     protected:
00086         virtual void SetFtpSocket(FtpSocketPtr ftpSocket);
00087
00090         virtual void SetFtpDataSocket(FtpDataSocketPtr ftpDataSocket);
00091
00094         virtual void SetPeerDataSocketAddr(const InetSocketAddr& peerDataSocketAddr);
00095
00098         virtual void SetLocalDataSocketAddr(const InetSocketAddr& localDataSocketAddr);
00099
00102         virtual void SetDataConnectionType(FtpDataConnectionType dataConnType);
00103
00106         State GetState();
00107
00110         void SetState(State state);
00111
00118         BOOLEAN ReplyMessage(const String& replyCode, const String& text);
00119
00126         Pathname GetAbsolutePathname(const Pathname& pathname);
00127
00133         BOOLEAN EstablishDataConnection();
00134
00139         BOOLEAN CloseDataConnection();
00140
00146         String GetDirItemInformation(Pathname pathname);
00147
00154         virtual BOOLEAN ExecCmd(const FtpRequest& request);
00155
00163         virtual BOOLEAN ExecUserCmd(const FtpRequest& request, AuthProvider* ftpAuthProvider);
00164
00172         virtual BOOLEAN ExecPassCmd(const FtpRequest& request, AuthProvider* ftpAuthProvider);
00173
00180         virtual BOOLEAN ExecPwdCmd(const FtpRequest& request);
00181
00188         virtual BOOLEAN ExecPortCmd(const FtpRequest& request);
00189
00196         virtual BOOLEAN ExecTypeCmd(const FtpRequest& request);
00197
00204         virtual BOOLEAN ExecModeCmd(const FtpRequest& request);
00205
00212         virtual BOOLEAN ExecStruCmd(const FtpRequest& request);
00213
00220         virtual BOOLEAN ExecListCmd(const FtpRequest& request);
00221
00228         virtual BOOLEAN DoListCmd(const FtpRequest& request);
00229
00236         virtual BOOLEAN ExecCwdCmd(const FtpRequest& request);
00237
00244         virtual BOOLEAN ExecCdupCmd(const FtpRequest& request);
00245
00252         virtual BOOLEAN ExecRmdCmd(const FtpRequest& request);
00253
00260         virtual BOOLEAN ExecDeleCmd(const FtpRequest& request);
00261
00268         virtual BOOLEAN ExecMkdCmd(const FtpRequest& request);
00269
00276         virtual BOOLEAN ExecRetrCmd(const FtpRequest& request);
00277
00284         virtual BOOLEAN DoRetrCmd(const FtpRequest& request);
00285
00292         virtual BOOLEAN ExecStorCmd(const FtpRequest& request);
00293
00300         virtual BOOLEAN DoStorCmd(const FtpRequest& request);
00301
00308         virtual BOOLEAN ExecQuitCmd(const FtpRequest& request);
00309
00316         virtual BOOLEAN ExecNoopCmd(const FtpRequest& request);
00317
00324         virtual BOOLEAN ExecPasvCmd(const FtpRequest& request);
00325
00326     private:
00332         BOOLEAN EstablishActiveDataConnection();
00333
00341         BOOLEAN EstablishPassiveDataConnection();
00342
00343         // user name of the client
00344         String m_user;
00345         // current state of the client
00346         State m_state;
00347
00348         // control socket
00349         FtpSocketPtr m_ftpSocket;
00350         // (optionally, in passive mode listening) data connection server socket
00351         FtpDataServerSocketPtr m_ftpDataServerSocket;
00352         // data socket
00353         FtpDataSocketPtr m_ftpDataSocket;
00354         // local data socket address
00355         InetSocketAddr m_localDataSocketAddr;
00356         // peer data socket address
00357         InetSocketAddr m_peerDataSocketAddr;
00358
00359         // data connection mode
00360         FtpDataConnectionType m_dataConnType;
00361
00362         // transfer options
00363         FtpTransferMode m_transferMode;
00364         FtpTransferType m_transferType;
00365         FtpTransferStructure m_transferStructure;
00366
00367         // home directory
00368         Pathname m_homeDir;
00369         // current directory (relative path)
00370         Pathname m_currentDir;
00371
00372         // BooleanCondition for accepting passive data connections
00373         BooleanCondition m_acceptDoneCondition;
00374 };
00375
00377 #endif  // Apoxi_AddOns_Server_FtpServer_FtpClient_hpp
00378
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpDataServerSocket.cpp File Reference

AddOns/Server/FtpServer/FtpDataServerSocket.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/System.hpp>
#include "FtpTypes.hpp"
#include "FtpDataSocket.hpp"
#include "FtpClient.hpp"
#include "MsgTypes.hpp"
#include "FtpDataServerSocket.hpp"

Include dependency graph for FtpDataServerSocket.cpp:

Generated on Tue Jan 24 16:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpDataServerSocket.hpp File Reference

AddOns/Server/FtpServer/FtpDataServerSocket.hpp File Reference

#include <Socket/TcpServerSocket.hpp>
#include <AddOns/Server/Server.hpp>
#include "FtpRequest.hpp"

Include dependency graph for FtpDataServerSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpDataServerSocket

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpDataServerSocket_hpp

Typedefs

typedef NiSharedPtr< FtpDataServerSocket > | FtpDataServerSocketPtr
Smart-pointer controlling a FtpDataServerSocket object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpDataServerSocket_hpp

Generated on Tue Jan 24 16:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpDataServerSocket.hpp Source File

AddOns/Server/FtpServer/FtpDataServerSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpDataServerSocket_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpDataServerSocket_hpp
00014
00015 #include <Socket/TcpServerSocket.hpp>
00016 #include <AddOns/Server/Server.hpp>
00017 #include "FtpRequest.hpp"
00018
00019 class FtpDataServerSocket;
00020
00022 typedef NiSharedPtr<FtpDataServerSocket> FtpDataServerSocketPtr;
00023
00026 class FtpDataServerSocket : public TcpServerSocket
00027 {
00028     typedef TcpServerSocket Base;
00029
00030     friend class FtpClient;
00031
00032     friend class TcpServerSocket;
00033
00034     public:
00037         FtpDataServerSocket(Server* server, UINT clientId = 0);
00038
00041         virtual ~FtpDataServerSocket();
00042
00043     protected:
00046         virtual void OnAsyncEvent(Event event);
00047
00048     private:
00049         // parent server
00050         Server* m_server;
00051
00052         // ID of the corresponding client
00053         UINT m_clientId;
00054
00055 };
00056
00058 #endif  // Apoxi_AddOns_Server_FtpServer_FtpDataServerSocket_hpp
00059
Generated on Tue Jan 24 14:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpDataSocket.cpp File Reference

AddOns/Server/FtpServer/FtpDataSocket.cpp File Reference

#include "PreComp.hpp"
#include "FtpDataSocket.hpp"
#include <Kernel/System.hpp>
#include "MsgTypes.hpp"
#include "FtpClient.hpp"
#include "FtpOutTransfer.hpp"

Include dependency graph for FtpDataSocket.cpp:

Generated on Tue Jan 24 16:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpDataSocket.hpp File Reference

AddOns/Server/FtpServer/FtpDataSocket.hpp File Reference

#include <Socket/TcpSocket.hpp>
#include "FtpTypes.hpp"
#include "FtpInTransfer.hpp"
#include "FtpOutTransfer.hpp"

Include dependency graph for FtpDataSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpDataSocket

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpDataSocket_hpp

Typedefs

typedef NiSharedPtr< FtpDataSocket > | FtpDataSocketPtr
Smart-pointer controlling a FtpDataSocket object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpDataSocket_hpp

Generated on Tue Jan 24 16:44:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpDataSocket.hpp Source File

AddOns/Server/FtpServer/FtpDataSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpDataSocket_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpDataSocket_hpp
00014
00015 #include <Socket/TcpSocket.hpp>
00016 #include "FtpTypes.hpp"
00017 #include "FtpInTransfer.hpp"
00018 #include "FtpOutTransfer.hpp"
00019
00020 class FtpDataSocket;
00021
00023 typedef NiSharedPtr<FtpDataSocket> FtpDataSocketPtr;
00024
00027 class FtpDataSocket : public TcpSocket
00028 {
00029     typedef TcpSocket Base;
00030
00031     friend class FtpServer;
00032     friend class FtpClient;
00033     friend class FtpInTransfer;
00034     friend class FtpOutTransfer;
00035
00036     public:
00039         FtpDataSocket(FtpSocketPtr ftpSocket,
00040             UINT clientId = 0,
00041             FtpTransferMode mode = c_ftp_transfer_mode_block,
00042             FtpTransferType type = c_ftp_transfer_type_ascii,
00043             FtpTransferStructure structure = c_ftp_transfer_structure_file);
00044
00047         virtual ~FtpDataSocket();
00048
00049 protected:
00050
00053         virtual void SetMode(FtpTransferMode mode);
00054
00057         virtual void SetType(FtpTransferType type);
00058
00061         virtual void SetStructure(FtpTransferStructure structure);
00062
00065         virtual FtpSocketPtr GetFtpSocket();
00066
00069         virtual void SetFtpSocket(FtpSocketPtr ftpSocket);
00070
00073         virtual FtpInTransferPtr GetFtpInTransfer();
00074
00077         virtual void SetFtpInTransfer(FtpInTransferPtr ftpInTransfer);
00078
00081         virtual FtpTransferError ProgressFtpInTransfer(UINT32 bytes);
00082
00085         virtual FtpOutTransferPtr GetFtpOutTransfer();
00086
00089         virtual void SetFtpOutTransfer(FtpOutTransferPtr ftpOutTransfer);
00090
00093         virtual FtpTransferError ProgressFtpOutTransfer();
00094
00097         virtual void SetClientId(UINT clientId);
00098
00101         virtual void OnAsyncEvent(Event event);
00102
00103         Server* m_server;
00104         UINT m_clientId;
00105         FtpTransferMode m_mode;
00106         FtpTransferType m_type;
00107         FtpTransferStructure m_structure;
00108
00109         FtpSocketPtr    m_ftpSocket;
00110         FtpInTransferPtr    m_ftpInTransfer;
00111         FtpOutTransferPtr   m_ftpOutTransfer;
00112
00113         UINT8* m_data_in_buffer; // internal buffer for reading
00114
00115         UINT8* m_data_out_buffer; // internal buffer for writing
00116 };
00117
00119 #endif  // Apoxi_AddOns_Server_FtpServer_FtpDataSocket_hpp
00120
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpInTransfer.cpp File Reference

AddOns/Server/FtpServer/FtpInTransfer.cpp File Reference

#include "PreComp.hpp"
#include "FtpInTransfer.hpp"
#include <Auxiliary/Time.hpp>
#include <Kernel/System.hpp>
#include "MsgTypes.hpp"

Include dependency graph for FtpInTransfer.cpp:

Generated on Tue Jan 24 16:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpInTransfer.hpp File Reference

AddOns/Server/FtpServer/FtpInTransfer.hpp File Reference

#include "FtpTransfer.hpp"
#include "FtpSocket.hpp"
#include <Afs/Rfs/File.hpp>

Include dependency graph for FtpInTransfer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpInTransfer

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpInTransfer_hpp

Typedefs

typedef NiSharedPtr< FtpInTransfer > | FtpInTransferPtr
Smart-pointer controlling a FtpInTransfer object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpInTransfer_hpp

Generated on Tue Jan 24 16:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpInTransfer.hpp Source File

AddOns/Server/FtpServer/FtpInTransfer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpInTransfer_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpInTransfer_hpp
00014
00015 #include "FtpTransfer.hpp"
00016 #include "FtpSocket.hpp"
00017 #include <Afs/Rfs/File.hpp>
00018
00019 class FtpInTransfer;
00020
00022 typedef NiSharedPtr<FtpInTransfer> FtpInTransferPtr;
00023
00024
00027 class FtpInTransfer : public FtpTransfer
00028 {
00029     typedef FtpTransfer Base;
00030
00031     friend class FtpServer;
00032     friend class FtpDataSocket;
00033
00034     public:
00037         FtpInTransfer(FtpSocketPtr ftpSocket,
00038             FilePtr file,
00039             UINT32 offset = 0,
00040             BOOLEAN running = TRUE);
00041
00044         virtual ~FtpInTransfer();
00045
00046     protected:
00051         virtual FtpTransferError Start();
00052
00053 };
00054
00056 #endif  // Apoxi_AddOns_Server_FtpServer_FtpInTransfer_hpp
00057
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpOutTransfer.cpp File Reference

AddOns/Server/FtpServer/FtpOutTransfer.cpp File Reference

#include "PreComp.hpp"
#include "FtpOutTransfer.hpp"
#include <Kernel/System.hpp>
#include "MsgTypes.hpp"

Include dependency graph for FtpOutTransfer.cpp:

Generated on Tue Jan 24 16:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpOutTransfer.hpp File Reference

AddOns/Server/FtpServer/FtpOutTransfer.hpp File Reference

#include <Afs/Rfs/File.hpp>
#include "FtpTransfer.hpp"
#include "FtpSocket.hpp"

Include dependency graph for FtpOutTransfer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpOutTransfer

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpOutTransfer_hpp

Typedefs

typedef NiSharedPtr< FtpOutTransfer > | FtpOutTransferPtr
Smart-pointer controlling a FtpOutTransfer object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpOutTransfer_hpp

Generated on Tue Jan 24 16:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpOutTransfer.hpp Source File

AddOns/Server/FtpServer/FtpOutTransfer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpOutTransfer_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpOutTransfer_hpp
00014
00015 #include <Afs/Rfs/File.hpp>
00016 #include "FtpTransfer.hpp"
00017 #include "FtpSocket.hpp"
00018
00019 class FtpOutTransfer;
00020
00022 typedef NiSharedPtr<FtpOutTransfer> FtpOutTransferPtr;
00023
00024
00027 class FtpOutTransfer : public FtpTransfer
00028 {
00029     typedef FtpTransfer Base;
00030
00031     friend class FtpServer;
00032     friend class FtpDataSocket;
00033
00034     public:
00037         FtpOutTransfer(FtpSocketPtr ftpSocket,
00038             FilePtr file,
00039             UINT32 offset = 0,
00040             BOOLEAN running = TRUE);
00041
00044         virtual ~FtpOutTransfer();
00045
00046     protected:
00051         virtual FtpTransferError Start();
00052
00053 };
00054
00056 #endif  // Apoxi_AddOns_Server_FtpServer_FtpOutTransfer_hpp
00057
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpRequest.cpp File Reference

AddOns/Server/FtpServer/FtpRequest.cpp File Reference

#include "PreComp.hpp"
#include "FtpRequest.hpp"

Include dependency graph for FtpRequest.cpp:

Generated on Tue Jan 24 16:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpRequest.hpp File Reference

AddOns/Server/FtpServer/FtpRequest.hpp File Reference

#include <Socket/InetSocketAddr.hpp>

Include dependency graph for FtpRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpRequest

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpRequest_hpp

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpRequest_hpp

Generated on Tue Jan 24 16:44:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpRequest.hpp Source File

AddOns/Server/FtpServer/FtpRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpRequest_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpRequest_hpp
00012
00013 #include <Socket/InetSocketAddr.hpp>
00014
00017
00018 class FtpRequest;
00019
00022 class FtpRequest
00023 {
00024     public:
00025         FtpRequest(const InetSocketAddr& peerAddr, UINT clientId, const String& cmd, const String& params);
00026         virtual ~FtpRequest();
00027
00028         const InetSocketAddr& GetPeerAddr() const { return m_peerAddr; }
00029         UINT GetClientId() const { return m_clientId; }
00030         const String& GetCmd() const { return m_cmd; }
00031         const String& GetParams() const { return m_params; }
00032
00033     private:
00034         InetSocketAddr m_peerAddr;
00035         UINT m_clientId;
00036         String m_cmd;
00037         String m_params;
00038 };
00039
00041 #endif  // Apoxi_AddOns_Server_FtpServer_FtpRequest_hpp
00042
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServer.cpp File Reference

AddOns/Server/FtpServer/FtpServer.cpp File Reference

#include "PreComp.hpp"
#include "FtpServer.hpp"
#include <Kernel/System.hpp>

Include dependency graph for FtpServer.cpp:

Generated on Tue Jan 24 16:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServer.hpp File Reference

AddOns/Server/FtpServer/FtpServer.hpp File Reference

#include <Socket/SocketHandler.hpp>
#include <AddOns/Server/Server.hpp>
#include "FtpAuthProvider.hpp"
#include "FtpServerConfig.hpp"
#include "FtpServerSocket.hpp"
#include "FtpClient.hpp"
#include "FtpRequest.hpp"
#include "MsgTypes.hpp"

Include dependency graph for FtpServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpServer

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpServer_hpp

Typedefs

typedef NiSharedPtr< FtpServer > | FtpServerPtr
Smart-pointer controlling a FtpServer object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpServer_hpp

Generated on Tue Jan 24 16:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServer.hpp Source File

AddOns/Server/FtpServer/FtpServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpServer_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpServer_hpp
00014
00015 #include <Socket/SocketHandler.hpp>
00016 #include <AddOns/Server/Server.hpp>
00017 #include "FtpAuthProvider.hpp"
00018 #include "FtpServerConfig.hpp"
00019 #include "FtpServerSocket.hpp"
00020 #include "FtpClient.hpp"
00021 #include "FtpRequest.hpp"
00022 #include "MsgTypes.hpp"
00023
00024
00025 class FtpServer;
00026
00028 typedef NiSharedPtr<FtpServer> FtpServerPtr;
00029
00032 class FtpServer : public Server
00033 {
00034     typedef Server Base;
00035
00036     friend class FtpSocket;
00037     friend class FtpClient;
00038
00039     public:
00042         FtpServer(FtpServerConfig* serverConfig, FtpAuthProvider* authProvider);
00043
00046         virtual ~FtpServer();
00047
00054         virtual void Start(const InetSocketAddr& localAddr, DataConnProfileId dataConnProfileId = c_invalid_data_conn_profile_id);
00055
00059         virtual void Stop();
00060
00066         virtual FtpClient* GetClient(UINT clientId);
00067
00072         virtual IpAddr GetHostIp();
00073
00078         virtual IpPortNo GetPort();
00079
00080     protected:
00085         virtual void Init();
00086
00091         virtual void Terminate();
00092
00098         virtual BOOLEAN OnMessage(const Message& msg);
00099
00106         virtual BOOLEAN ConnectClient(const InetSocketAddr& peerAddr, const FtpSocketPtr& peerSocket);
00107
00113         virtual BOOLEAN DisconnectClient(UINT clientId);
00114
00120         virtual BOOLEAN HandleRequest(const FtpRequest& request);
00121
00128         virtual BOOLEAN ExecCmd(const FtpRequest& request);
00129
00130     private:
00133         virtual void InternalInit();
00134
00137         virtual void InternalTerminate();
00138
00141         virtual void InternalStart(const InetSocketAddr& localAddr, DataConnProfileId dataConnProfileId);
00142
00145         virtual void InternalStop(const InetSocketAddr& localAddr);
00146
00147         // (listening) control connection server socket
00148         FtpServerSocketPtr m_ftpServerSocket;
00149
00150         // needed to receive socket messages
00151         SocketHandler m_socketHandler;
00152 };
00153
00155 #endif  // Apoxi_AddOns_Server_FtpServer_FtpServer_hpp
00156
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServerConfig.cpp File Reference

AddOns/Server/FtpServer/FtpServerConfig.cpp File Reference

#include "PreComp.hpp"
#include "FtpServerConfig.hpp"

Include dependency graph for FtpServerConfig.cpp:

Generated on Tue Jan 24 16:44:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServerConfig.hpp File Reference

AddOns/Server/FtpServer/FtpServerConfig.hpp File Reference

#include <AddOns/Server/ServerConfig.hpp>
#include "FtpTypes.hpp"

Include dependency graph for FtpServerConfig.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpServerConfig

Defines

#define | Apoxi_AddOns_Server_FtpServerConfig_hpp

Typedefs

typedef NiSharedPtr< FtpServerConfig > | FtpServerConfigPtr
Smart-pointer controlling a FtpServerConfig object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServerConfig_hpp

Generated on Tue Jan 24 16:44:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServerConfig.hpp Source File

AddOns/Server/FtpServer/FtpServerConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServerConfig_hpp)
00011 #define Apoxi_AddOns_Server_FtpServerConfig_hpp
00014
00015 #include <AddOns/Server/ServerConfig.hpp>
00016 #include "FtpTypes.hpp"
00017
00018 class FtpServerConfig;
00019
00021 typedef NiSharedPtr<FtpServerConfig> FtpServerConfigPtr;
00022
00025 class FtpServerConfig : public ServerConfig
00026 {
00027     typedef ServerConfig Base;
00028
00029     public:
00032         FtpServerConfig();
00033
00036         virtual ~FtpServerConfig();
00037 };
00038
00040 #endif  // Apoxi_AddOns_Server_FtpServerConfig_hpp
00041
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServerSocket.cpp File Reference

AddOns/Server/FtpServer/FtpServerSocket.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/System.hpp>
#include "FtpTypes.hpp"
#include "FtpSocket.hpp"
#include "MsgTypes.hpp"
#include "FtpServerSocket.hpp"

Include dependency graph for FtpServerSocket.cpp:

Generated on Tue Jan 24 16:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServerSocket.hpp File Reference

AddOns/Server/FtpServer/FtpServerSocket.hpp File Reference

#include <Socket/TcpServerSocket.hpp>
#include <AddOns/Server/Server.hpp>

Include dependency graph for FtpServerSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpServerSocket

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpServerSocket_hpp

Typedefs

typedef NiSharedPtr< FtpServerSocket > | FtpServerSocketPtr
Smart-pointer controlling a FtpServerSocket object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpServerSocket_hpp

Generated on Tue Jan 24 16:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpServerSocket.hpp Source File

AddOns/Server/FtpServer/FtpServerSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpServerSocket_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpServerSocket_hpp
00014
00015 #include <Socket/TcpServerSocket.hpp>
00016 #include <AddOns/Server/Server.hpp>
00017
00018 class FtpServerSocket;
00019
00021 typedef NiSharedPtr<FtpServerSocket> FtpServerSocketPtr;
00022
00025 class FtpServerSocket : public TcpServerSocket
00026 {
00027     typedef TcpServerSocket Base;
00028
00029     public:
00032         FtpServerSocket(Server* server);
00033
00036         virtual ~FtpServerSocket();
00037
00038     protected:
00041         virtual void OnAsyncEvent(Event event);
00042
00043     private:
00044         // parent server
00045         Server* m_server;
00046
00047 };
00048
00050 #endif  // Apoxi_AddOns_Server_FtpServer_FtpServerSocket_hpp
00051
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpSocket.cpp File Reference

AddOns/Server/FtpServer/FtpSocket.cpp File Reference

#include "PreComp.hpp"
#include "FtpSocket.hpp"
#include <Kernel/System.hpp>
#include <Socket/InetSocketAddr.hpp>
#include "FtpRequest.hpp"
#include "FtpServer.hpp"
#include "MsgTypes.hpp"

Include dependency graph for FtpSocket.cpp:

Generated on Tue Jan 24 16:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpSocket.hpp File Reference

AddOns/Server/FtpServer/FtpSocket.hpp File Reference

#include <AddOns/Server/Server.hpp>
#include <Socket/TcpSocket.hpp>

Include dependency graph for FtpSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpSocket

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpSocket_hpp

Typedefs

typedef NiSharedPtr< FtpSocket > | FtpSocketPtr
Smart-pointer controlling a FtpSocket object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpSocket_hpp

Generated on Tue Jan 24 16:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpSocket.hpp Source File

AddOns/Server/FtpServer/FtpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpSocket_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpSocket_hpp
00014
00015 #include <AddOns/Server/Server.hpp>
00016 #include <Socket/TcpSocket.hpp>
00017
00018 class FtpSocket;
00019
00021 typedef NiSharedPtr<FtpSocket> FtpSocketPtr;
00022
00025 class FtpSocket : public TcpSocket
00026 {
00027     typedef TcpSocket Base;
00028
00029     friend class FtpServer;
00030     friend class FtpServerSocket;
00031     friend class FtpClient;
00032     friend class FtpDataSocket;
00033     friend class FtpInTransfer;
00034     friend class FtpOutTransfer;
00035
00036     public:
00039         FtpSocket(Server* server, UINT clientId = 0);
00040
00043         virtual ~FtpSocket();
00044
00045     protected:
00052         virtual BOOLEAN ReplyMessage(const String& code, const String& text);
00053
00056         virtual void SetClientId(UINT clientId);
00057
00060         virtual void OnAsyncEvent(Event event);
00061
00062         Server* m_server;
00063
00064     private:
00065         UINT m_clientId;
00066 };
00067
00069 #endif  // Apoxi_AddOns_Server_FtpServer_FtpSocket_hpp
00070
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpTransfer.cpp File Reference

AddOns/Server/FtpServer/FtpTransfer.cpp File Reference

#include "PreComp.hpp"
#include "FtpTransfer.hpp"
#include "MsgTypes.hpp"

Include dependency graph for FtpTransfer.cpp:

Generated on Tue Jan 24 16:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpTransfer.hpp File Reference

AddOns/Server/FtpServer/FtpTransfer.hpp File Reference

#include <Afs/Rfs/File.hpp>
#include "FtpTypes.hpp"
#include "FtpSocket.hpp"

Include dependency graph for FtpTransfer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpTransfer

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpTransfer_hpp

Typedefs

typedef NiSharedPtr< FtpTransfer > | FtpTransferPtr
Smart-pointer controlling a FtpTransfer object.

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpTransfer_hpp

Generated on Tue Jan 24 16:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpTransfer.hpp Source File

AddOns/Server/FtpServer/FtpTransfer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpTransfer_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpTransfer_hpp
00014
00015 #include <Afs/Rfs/File.hpp>
00016 #include "FtpTypes.hpp"
00017 #include "FtpSocket.hpp"
00018
00019 class FtpTransfer;
00020
00022 typedef NiSharedPtr<FtpTransfer> FtpTransferPtr;
00023
00024
00025 class FtpServer;
00026
00027
00030 class FtpTransfer
00031 {
00032     friend class FtpServer;
00033     friend class FtpClient;
00034     friend class FtpDataSocket;
00035
00036     public:
00039         virtual ~FtpTransfer();
00040
00045         virtual BOOLEAN IsRunning();
00046
00047 protected:
00057         FtpTransfer(
00058             UINT clientId,
00059             FtpSocketPtr ftpSocket,
00060             FilePtr file,
00061             UINT32 offset = 0,
00062             BOOLEAN running = TRUE);
00063
00068         virtual void SetRunning(BOOLEAN running);
00069
00074         virtual FtpTransferError Start() = 0;
00075
00076         UINT m_clientId;    // ID of the client
00077         FtpSocketPtr m_ftpSocket;   // socket for control connection
00078         FilePtr m_file;     // file to transfer
00079         UINT32 m_filesize;  // size of the file
00080         UINT32 m_offset;    // offset when reading/writing the file
00081         BOOLEAN m_running;  // whether the transfer is currently runnig or not
00082         BOOLEAN m_disconnect_on_complete;   // disconnect client when transfer is complete
00083 };
00084
00086 #endif  // Apoxi_AddOns_Server_FtpServer_FtpTransfer_hpp
00087
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpTypes.hpp File Reference

AddOns/Server/FtpServer/FtpTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_AddOns_Server_FtpServer_FtpTypes_hpp
#define | APOXI_FTPSERVER_REQUEST_LENGTH 1024
#define | FTPSERVER_DBG_OUT_RANGE 35910
#define | FTPSERVER_DBG_OUT_RANGE_CMD 35912
#define | FTPSERVER_DBG_OUT_RANGE_EXTENDED 35911
#define | FTPSERVER_DBG_OUT_RANGE_REPLY 35913

Enumerations

enum | FtpConnectionType { c_ftp_conn_type_control, c_ftp_conn_type_data }
enum | FtpDataConnectionType { c_ftp_data_conn_type_active, c_ftp_data_conn_type_passive }
enum | FtpServiceCommand { c_ftp_service_command_init, c_ftp_service_command_terminate, c_ftp_service_command_start, c_ftp_service_command_stop }
enum | FtpServiceCommandError { c_ftp_service_command_error_success, c_ftp_service_command_error_failed }
enum | FtpTransferDirection { c_ftp_transfer_direction_in, c_ftp_transfer_direction_out }
enum FtpTransferError {
c_ftp_transfer_error_created, c_ftp_transfer_error_started, c_ftp_transfer_error_progress, c_ftp_transfer_error_not_running,
c_ftp_transfer_error_aborted, c_ftp_transfer_error_failed, c_ftp_transfer_error_complete
}
enum | FtpTransferMode { c_ftp_transfer_mode_stream, c_ftp_transfer_mode_block, c_ftp_transfer_mode_compressed }
enum | FtpTransferStructure { c_ftp_transfer_structure_file, c_ftp_transfer_structure_record }
enum | FtpTransferType { c_ftp_transfer_type_ascii, c_ftp_transfer_type_image }

Define Documentation

#define Apoxi_AddOns_Server_FtpServer_FtpTypes_hpp

Generated on Tue Jan 24 16:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/FtpTypes.hpp Source File

AddOns/Server/FtpServer/FtpTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_FtpServer_FtpTypes_hpp)
00011 #define Apoxi_AddOns_Server_FtpServer_FtpTypes_hpp
00014
00015
00016 // DBG_OUT range for general FtpServer stuff
00017 #define FTPSERVER_DBG_OUT_RANGE 35910
00018 // DBG_OUT range for extended FtpServer stuff
00019 #define FTPSERVER_DBG_OUT_RANGE_EXTENDED 35911
00020 // DBG_OUT range for FTP commands
00021 #define FTPSERVER_DBG_OUT_RANGE_CMD 35912
00022 // DBG_OUT range for FTP replies
00023 #define FTPSERVER_DBG_OUT_RANGE_REPLY 35913
00024
00025
00026 // maximum length of an FTP request
00027 #define APOXI_FTPSERVER_REQUEST_LENGTH 1024
00028
00029
00030 #if defined(APOXI_TARGETSYSTEM_HOST)
00031
00032 // default size for transmitting data from or to clients
00033 #define APOXI_FTPSERVER_TRANSFER_DEFAULT_BLOCKLENGTH (128*1024)
00034 // default maximum of currently connected clients
00035 #define APOXI_FTPSERVER_DEFAULT_MAX_USERS 5
00036 // default value for backlog of FtpServerSocket when listening
00037 #define APOXI_FTPSERVER_DEFAULT_BACKLOG 25
00038
00039 #elif defined(APOXI_TARGETSYSTEM_HW)
00040
00041 // default size for transmitting data from or to clients
00042 #define APOXI_FTPSERVER_TRANSFER_DEFAULT_BLOCKLENGTH (8*1024)
00043 // default maximum of currently connected clients
00044 #define APOXI_FTPSERVER_DEFAULT_MAX_USERS 5
00045 // default value for backlog of FtpServerSocket when listening
00046 #define APOXI_FTPSERVER_DEFAULT_BACKLOG 15
00047
00048 #endif
00049
00050
00051 /* Commands used internally by FtpServer to keep public interface but
00052     initialize SocketHandler in the right ExecutionContext.
00053 */
00054 enum FtpServiceCommand {
00055     c_ftp_service_command_init,
00056     c_ftp_service_command_terminate,
00057     c_ftp_service_command_start,
00058     c_ftp_service_command_stop
00059 };
00060
00061 enum FtpServiceCommandError {
00062     c_ftp_service_command_error_success,
00063     c_ftp_service_command_error_failed
00064 };
00065
00066 /* Types of connections.
00067 */
00068 enum FtpConnectionType {
00069     c_ftp_conn_type_control,
00070     c_ftp_conn_type_data
00071 };
00072
00073 /* Types of modi for establishing the data connection (from the server's point of view).
00074 */
00075 enum FtpDataConnectionType {
00076     c_ftp_data_conn_type_active,
00077     c_ftp_data_conn_type_passive
00078 };
00079
00080 /* Types which are used defining the data connection.
00081 */
00082 enum FtpTransferMode {
00083     c_ftp_transfer_mode_stream,
00084     c_ftp_transfer_mode_block,
00085     c_ftp_transfer_mode_compressed
00086 };
00087
00088 enum FtpTransferType {
00089     c_ftp_transfer_type_ascii,
00090     c_ftp_transfer_type_image
00091 };
00092
00093 enum FtpTransferStructure {
00094     c_ftp_transfer_structure_file,
00095     c_ftp_transfer_structure_record,
00096     //  c_ftp_transfer_structure_page
00097 };
00098
00099 enum FtpTransferError {
00100     c_ftp_transfer_error_created,   // a new transfer was created
00101     c_ftp_transfer_error_started,   // a transfer was started
00102     c_ftp_transfer_error_progress,  // a transfer successfully progressed
00103     c_ftp_transfer_error_not_running,   // a transfer is not running (e.g. when trying to progress the transfer)
00104     c_ftp_transfer_error_aborted,   // a transfer was aborted by user intention
00105     c_ftp_transfer_error_failed,    // a transfer failed due to technical reasons
00106     c_ftp_transfer_error_complete   // a transfer was completed
00107 };
00108
00109 enum FtpTransferDirection {
00110     c_ftp_transfer_direction_in,    // ingoing transfer
00111     c_ftp_transfer_direction_out    // outgoing transfer
00112 };
00113
00115 #endif  // Apoxi_AddOns_Server_FtpServer_FtpTypes_hpp
00116
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/MsgTypes.cpp File Reference

AddOns/Server/FtpServer/MsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/MsgTypes.hpp File Reference

AddOns/Server/FtpServer/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Socket/InetSocketAddr.hpp>
#include <Socket/DataConnProfile.hpp>
#include <AddOns/Server/FtpServer/FtpTypes.hpp>
#include <AddOns/Server/FtpServer/FtpRequest.hpp>
#include <AddOns/Server/FtpServer/FtpSocket.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FtpConnectMessage
class | FtpDisconnectMessage
class | FtpErrorMessage
class | FtpRequestMessage
class | FtpServiceMessage
class | FtpTransferMessage

Defines

#define | AddOns_Server_FtpServer_MsgTypes_hpp

Define Documentation

#define AddOns_Server_FtpServer_MsgTypes_hpp

Generated on Tue Jan 24 14:56:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/MsgTypes.hpp Source File

AddOns/Server/FtpServer/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "working\_views\Oberhube_server_FTP_HTTP_sv\lnz_apoxi\Apoxi\AddOns\Server\FtpServer\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(AddOns_Server_FtpServer_MsgTypes_hpp)
00017 #define AddOns_Server_FtpServer_MsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Socket/InetSocketAddr.hpp>
00021 #include <Socket/DataConnProfile.hpp>
00022 #include <AddOns/Server/FtpServer/FtpTypes.hpp>
00023 #include <AddOns/Server/FtpServer/FtpRequest.hpp>
00024 #include <AddOns/Server/FtpServer/FtpSocket.hpp>
00025
00026
00027 /* ----------------------------------------------------------------------
00028     Classes
00029     ---------------------------------------------------------------------- */
00030
00031 /*  ======================================================================
00032     Class FtpServiceMessage
00033     ====================================================================== */
00034
00036 class FtpServiceMessage : public Message {
00037     public:
00038         FtpServiceMessage(const FtpServiceCommand& cmd, const InetSocketAddr& socketAddr = InetSocketAddr(), const DataConnProfileId& dataConnProfileId = c_invalid_data_conn_profile_id);
00039         virtual ~FtpServiceMessage();
00040
00041         virtual const MsgMetaData& GetMetaData() const;
00042         const FtpServiceCommand& GetCmd() const { return m_cmd; }
00043         const InetSocketAddr& GetSocketAddr() const { return m_socketAddr; }
00044         const DataConnProfileId& GetDataConnProfileId() const { return m_dataConnProfileId; }
00045         virtual Message* Clone() const;
00046
00047         enum  {
00048             ID = 4500
00049             };
00050
00051     private:
00052         static const MsgMetaData m_meta_data;
00053         FtpServiceCommand m_cmd;
00054         InetSocketAddr m_socketAddr;
00055         DataConnProfileId m_dataConnProfileId;
00056
00057     };
00058
00059
00060 /*  ======================================================================
00061     Class FtpErrorMessage
00062     ====================================================================== */
00063
00065 class FtpErrorMessage : public Message {
00066     public:
00067         FtpErrorMessage(const FtpServiceCommand& cmd, const FtpServiceCommandError& code);
00068         virtual ~FtpErrorMessage();
00069
00070         virtual const MsgMetaData& GetMetaData() const;
00071         const FtpServiceCommand& GetCmd() const { return m_cmd; }
00072         const FtpServiceCommandError& GetCode() const { return m_code; }
00073         virtual Message* Clone() const;
00074
00075         enum  {
00076             ID = 4501
00077             };
00078
00079     private:
00080         static const MsgMetaData m_meta_data;
00081         FtpServiceCommand m_cmd;
00082         FtpServiceCommandError m_code;
00083
00084     };
00085
00086
00087 /*  ======================================================================
00088     Class FtpTransferMessage
00089     ====================================================================== */
00090
00092 class FtpTransferMessage : public Message {
00093     public:
00094         FtpTransferMessage(UINT clientId, const FtpTransferDirection& direction, const FtpTransferError& error);
00095         virtual ~FtpTransferMessage();
00096
00097         virtual const MsgMetaData& GetMetaData() const;
00098         UINT GetClientId() const { return m_clientId; }
00099         const FtpTransferDirection& GetDirection() const { return m_direction; }
00100         const FtpTransferError& GetError() const { return m_error; }
00101         virtual Message* Clone() const;
00102
00103         enum  {
00104             ID = 4502
00105             };
00106
00107     private:
00108         static const MsgMetaData m_meta_data;
00109         UINT m_clientId;
00110         FtpTransferDirection m_direction;
00111         FtpTransferError m_error;
00112
00113     };
00114
00115
00116 /*  ======================================================================
00117     Class FtpRequestMessage
00118     ====================================================================== */
00119
00121 class FtpRequestMessage : public Message {
00122     public:
00123         FtpRequestMessage(const FtpRequest& ftpRequest);
00124         virtual ~FtpRequestMessage();
00125
00126         virtual const MsgMetaData& GetMetaData() const;
00127         const FtpRequest& GetFtpRequest() const { return m_ftpRequest; }
00128         virtual Message* Clone() const;
00129
00130         enum  {
00131             ID = 4503
00132             };
00133
00134     private:
00135         static const MsgMetaData m_meta_data;
00136         FtpRequest m_ftpRequest;
00137
00138     };
00139
00140
00141 /*  ======================================================================
00142     Class FtpConnectMessage
00143     ====================================================================== */
00144
00146 class FtpConnectMessage : public Message {
00147     public:
00148         FtpConnectMessage(const InetSocketAddr& peerAddr, const FtpSocketPtr& peerSocket);
00149         virtual ~FtpConnectMessage();
00150
00151         virtual const MsgMetaData& GetMetaData() const;
00152         const InetSocketAddr& GetPeerAddr() const { return m_peerAddr; }
00153         const FtpSocketPtr& GetPeerSocket() const { return m_peerSocket; }
00154         virtual Message* Clone() const;
00155
00156         enum  {
00157             ID = 4504
00158             };
00159
00160     private:
00161         static const MsgMetaData m_meta_data;
00162         InetSocketAddr m_peerAddr;
00163         FtpSocketPtr m_peerSocket;
00164
00165     };
00166
00167
00168 /*  ======================================================================
00169     Class FtpDisconnectMessage
00170     ====================================================================== */
00171
00173 class FtpDisconnectMessage : public Message {
00174     public:
00175         FtpDisconnectMessage(UINT clientId, const FtpConnectionType& connType = c_ftp_conn_type_control);
00176         virtual ~FtpDisconnectMessage();
00177
00178         virtual const MsgMetaData& GetMetaData() const;
00179         UINT GetClientId() const { return m_clientId; }
00180         const FtpConnectionType& GetConnType() const { return m_connType; }
00181         virtual Message* Clone() const;
00182
00183         enum  {
00184             ID = 4505
00185             };
00186
00187     private:
00188         static const MsgMetaData m_meta_data;
00189         UINT m_clientId;
00190         FtpConnectionType m_connType;
00191
00192     };
00193
00194 #endif // AddOns_Server_FtpServer_MsgTypes_hpp
00195
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/PreComp.cpp File Reference

AddOns/Server/FtpServer/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/PreComp.hpp File Reference

AddOns/Server/FtpServer/PreComp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/FtpServer/PreComp.hpp Source File

AddOns/Server/FtpServer/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/ApoxiHttpServerVersion.cpp File Reference

AddOns/Server/HttpServer/ApoxiHttpServerVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiHttpServerVersion.cpp:

Functions

ApoxiDefVersionInfo (HttpServer, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | HttpServer | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpApplication.cpp File Reference

AddOns/Server/HttpServer/HttpApplication.cpp File Reference

#include "PreComp.hpp"
#include "HttpApplication.hpp"
#include "HttpApplicationSupplier.hpp"

Include dependency graph for HttpApplication.cpp:

Generated on Tue Jan 24 16:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpApplication.hpp File Reference

AddOns/Server/HttpServer/HttpApplication.hpp File Reference

#include "HttpTypes.hpp"
#include "HttpRequest.hpp"
#include "HttpResponse.hpp"

Include dependency graph for HttpApplication.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpApplication

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpApplication_hpp

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpApplication_hpp

Generated on Tue Jan 24 16:45:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpApplication.hpp Source File

AddOns/Server/HttpServer/HttpApplication.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpApplication_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpApplication_hpp
00014
00015 #include "HttpTypes.hpp"
00016 #include "HttpRequest.hpp"
00017 #include "HttpResponse.hpp"
00018
00019 class HttpApplication;
00020
00023 class HttpApplication
00024 {
00025     friend class HttpServer;
00026     friend class HttpClient;
00027
00028     public:
00031         static HttpApplication* GetInstance();
00032
00035         virtual void ReleaseInstance();
00036
00039         virtual String GetId();
00040
00043         virtual String GetName();
00044
00047         virtual String GetDescription();
00048
00051         virtual HttpResponseCode OnHttpRequest(HttpRequest& request, HttpResponse& response) = 0;
00052
00055         virtual ~HttpApplication();
00056
00057     protected:
00060         HttpApplication(String appId, String appName, String appDescription);
00061
00064         virtual void Init();
00065
00068         virtual void Terminate();
00069
00070         static HttpApplication* s_instance;
00071         String m_appId;
00072         String m_appName;
00073         String m_appDescription;
00074 };
00075
00077 #endif  // Apoxi_AddOns_Server_HttpServer_HttpApplication_hpp
00078
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpApplicationSupplier.cpp File Reference

AddOns/Server/HttpServer/HttpApplicationSupplier.cpp File Reference

#include "PreComp.hpp"
#include "HttpApplicationSupplier.hpp"

Include dependency graph for HttpApplicationSupplier.cpp:

Generated on Tue Jan 24 16:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpApplicationSupplier.hpp File Reference

AddOns/Server/HttpServer/HttpApplicationSupplier.hpp File Reference

#include <Auxiliary/SimpleMap.hpp>
#include "HttpApplication.hpp"

Include dependency graph for HttpApplicationSupplier.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpApplicationSupplier

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpApplicationSupplier_hpp

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpApplicationSupplier_hpp

Generated on Tue Jan 24 16:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpApplicationSupplier.hpp Source File

AddOns/Server/HttpServer/HttpApplicationSupplier.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpApplicationSupplier_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpApplicationSupplier_hpp
00014
00015 #include <Auxiliary/SimpleMap.hpp>
00016 #include "HttpApplication.hpp"
00017
00018 class HttpApplicationSupplier;
00019
00022 class HttpApplicationSupplier
00023 {
00024     friend class HttpServer;
00025     friend class HttpClient;
00026
00027     public:
00030         static HttpApplicationSupplier* GetInstance();
00031
00034         virtual void ReleaseInstance();
00035
00038         virtual BOOLEAN RegisterApplication(HttpApplication* httpApplication);
00039
00042         virtual void DeregisterApplication(String appId);
00043
00046         virtual HttpApplication* GetApplication(String appId);
00047
00050         virtual UINT GetApplicationCount();
00051
00054         virtual ~HttpApplicationSupplier();
00055
00056     protected:
00057         // map of application with their keys
00058         SimpleMap<String, HttpApplication*> m_appList;
00059
00060     private:
00063         HttpApplicationSupplier();
00064
00067         void Init();
00068
00071         void Terminate();
00072
00073         static HttpApplicationSupplier* s_instance;
00074 };
00075
00077 #endif  // Apoxi_AddOns_Server_HttpServer_HttpApplicationSupplier_hpp
00078
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpAuthProvider.cpp File Reference

AddOns/Server/HttpServer/HttpAuthProvider.cpp File Reference

#include "PreComp.hpp"
#include "HttpAuthProvider.hpp"

Include dependency graph for HttpAuthProvider.cpp:

Generated on Tue Jan 24 16:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpAuthProvider.hpp File Reference

AddOns/Server/HttpServer/HttpAuthProvider.hpp File Reference

#include <AddOns/Server/AuthProvider.hpp>
#include <Afs/Rfs/Pathname.hpp>

Include dependency graph for HttpAuthProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpAuthProvider

Defines

#define | Apoxi_AddOns_Server_HttpAuthProvider_hpp

Typedefs

typedef NiSharedPtr< HttpAuthProvider > | HttpAuthProviderPtr
Smart-pointer controlling a HttpAuthProvider object.

Define Documentation

#define Apoxi_AddOns_Server_HttpAuthProvider_hpp

Generated on Tue Jan 24 16:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpAuthProvider.hpp Source File

AddOns/Server/HttpServer/HttpAuthProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpAuthProvider_hpp)
00011 #define Apoxi_AddOns_Server_HttpAuthProvider_hpp
00014
00015 #include <AddOns/Server/AuthProvider.hpp>
00016 #include <Afs/Rfs/Pathname.hpp>
00017
00018 class HttpAuthProvider;
00019
00021 typedef NiSharedPtr<HttpAuthProvider> HttpAuthProviderPtr;
00022
00025 class HttpAuthProvider : public AuthProvider
00026 {
00027     typedef AuthProvider Base;
00028
00029     public:
00032         HttpAuthProvider();
00033
00036         virtual ~HttpAuthProvider();
00037
00044         virtual BOOLEAN AuthorizeUser(const String& username);
00045
00053         virtual BOOLEAN AuthorizeUserPassword(const String& username, const String& password);
00054
00062         virtual BOOLEAN IsAccessGranted(const String& username, const Path& path);
00063
00064 };
00065
00067 #endif  // Apoxi_AddOns_Server_HttpAuthProvider_hpp
00068
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpClient.cpp File Reference

AddOns/Server/HttpServer/HttpClient.cpp File Reference

#include "PreComp.hpp"
#include "HttpClient.hpp"
#include <Auxiliary/SimpleMap.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include "HttpServer.hpp"
#include "HttpApplication.hpp"
#include "HttpApplicationSupplier.hpp"

Include dependency graph for HttpClient.cpp:

Generated on Tue Jan 24 16:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpClient.hpp File Reference

AddOns/Server/HttpServer/HttpClient.hpp File Reference

#include <Socket/InetSocketAddr.hpp>
#include <AddOns/Server/Server.hpp>
#include "HttpSocket.hpp"
#include "HttpRequest.hpp"
#include "HttpResponse.hpp"
#include "MsgTypes.hpp"

Include dependency graph for HttpClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpClient

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpClient_hpp

Typedefs

typedef NiSharedPtr< HttpClient > | HttpClientPtr
Smart-pointer controlling a HttpClient object.

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpClient_hpp

Generated on Tue Jan 24 16:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpClient.hpp Source File

AddOns/Server/HttpServer/HttpClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpClient_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpClient_hpp
00014
00015 #include <Socket/InetSocketAddr.hpp>
00016 #include <AddOns/Server/Server.hpp>
00017 #include "HttpSocket.hpp"
00018 #include "HttpRequest.hpp"
00019 #include "HttpResponse.hpp"
00020 #include "MsgTypes.hpp"
00021
00022 class HttpClient;
00023
00025 typedef NiSharedPtr<HttpClient> HttpClientPtr;
00026
00027
00030 class HttpClient : public ServerClient
00031 {
00032     friend class HttpServer;
00033
00034     typedef ServerClient Base;
00035
00036     public:
00041         HttpClient(Server* server);
00042
00045         virtual ~HttpClient();
00046
00051         virtual UINT GetId();
00052
00057         virtual HttpSocketPtr GetHttpSocket();
00058
00064         virtual BOOLEAN OnHttpRequest(HttpRequest& httpRequest);
00065
00071         virtual BOOLEAN OnHttpGetRequest(HttpRequest& httpRequest);
00072
00078         virtual BOOLEAN OnHttpPostRequest(HttpRequest& httpRequest);
00079
00086         virtual HttpResponseCode OnFileRequest(const Pathname& pathname, HttpResponse& httpResponse);
00087
00088     protected:
00093         virtual void SetHttpSocket(HttpSocketPtr httpSocket);
00094
00101         Pathname GetAbsolutePathname(const Pathname& pathname);
00102
00110         HttpResponseCode GetIndexPage(const HttpRequest& httpRequest, HttpResponse& httpResponse);
00111
00118         HttpResponseCode GetFavicon(HttpResponse& httpResponse);
00119
00126         HttpResponseCode GetStyleSheet(HttpResponse& httpResponse);
00127
00135         HttpResponseCode GetErrorPage(HttpResponse& httpResponse, HttpResponseCode errorCode, WString errorDescription = L"");
00136
00137     private:
00138         /*
00140         This method is needed within GetFavicon() when generating icon byte array.
00142         String UintToHex(UINT8 val);
00143         */
00144
00145         // communication socket
00146         HttpSocketPtr m_httpSocket;
00147 };
00148
00150 #endif  // Apoxi_AddOns_Server_HttpServer_HttpClient_hpp
00151
Generated on Tue Jan 24 14:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpRequest.cpp File Reference

AddOns/Server/HttpServer/HttpRequest.cpp File Reference

#include "PreComp.hpp"
#include "HttpRequest.hpp"

Include dependency graph for HttpRequest.cpp:

Generated on Tue Jan 24 16:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpRequest.hpp File Reference

AddOns/Server/HttpServer/HttpRequest.hpp File Reference

#include <AddOns/AfsRam/RamDataSink.hpp>

Include dependency graph for HttpRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpRequest
struct | HttpRequest::ParamPair

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpRequest_hpp

Typedefs

typedef Vector< String > | HttpRequestHeaders

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpRequest_hpp

Generated on Tue Jan 24 16:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpRequest.hpp Source File

AddOns/Server/HttpServer/HttpRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpRequest_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpRequest_hpp
00014
00015 #include <AddOns/AfsRam/RamDataSink.hpp>
00016
00017 // Defines the format of the contained headers.
00018 typedef Vector<String> HttpRequestHeaders;
00019
00020 class HttpRequest;
00021
00024 class HttpRequest
00025 {
00026     friend class HttpSocket;
00027     friend class HttpServer;
00028
00029     public:
00030         // Defines available types of the request method.
00031         enum HttpRequestMethodType {
00032             c_http_request_method_get,
00033             c_http_request_method_post
00034         };
00035
00036         // Defines one parameter name and value.
00037         typedef struct {
00038             String name;
00039             String value;
00040         } ParamPair;
00041         // Defines a list of parameters.
00042         typedef Vector<ParamPair> ParamPairList;
00043
00048         HttpRequest(HttpRequestMethodType type = c_http_request_method_get);
00049
00054         HttpRequestMethodType GetRequestMethodType();
00055
00060         String GetRequestTarget();
00061
00066         ParamPairList GetRequestParams();
00067
00072         String GetHttpVersion();
00073
00078         HttpRequestHeaders GetHeaders();
00079
00084         RamDataSinkPtr GetBody();
00085
00088         virtual ~HttpRequest();
00089
00090     protected:
00095         void SetBody(RamDataSinkPtr newBody);
00096
00097
00098         HttpRequestMethodType m_requestMethod;  // the request method
00099         String m_requestTarget; // the request target
00100         Vector<ParamPair> m_requestParams;  // the request parameters
00101         String m_httpVersion;   // the HTTP version
00102         HttpRequestHeaders m_headers;   // vector of received request headers
00103         RamDataSinkPtr m_body;  // (optionally) received body data
00104 };
00105
00107 #endif  // Apoxi_AddOns_Server_HttpServer_HttpRequest_hpp
00108
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpResponse.cpp File Reference

AddOns/Server/HttpServer/HttpResponse.cpp File Reference

#include "PreComp.hpp"
#include "HttpResponse.hpp"
#include <AddOns/AfsRam/RamDataSource.hpp>
#include "HttpTypes.hpp"

Include dependency graph for HttpResponse.cpp:

Generated on Tue Jan 24 16:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpResponse.hpp File Reference

AddOns/Server/HttpServer/HttpResponse.hpp File Reference

#include <AddOns/AfsRam/RamDataSink.hpp>

Include dependency graph for HttpResponse.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpResponse

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpResponse_hpp

Typedefs

typedef Vector< String > | HttpResponseHeaders

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpResponse_hpp

Generated on Tue Jan 24 16:45:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpResponse.hpp Source File

AddOns/Server/HttpServer/HttpResponse.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpResponse_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpResponse_hpp
00014
00015 #include <AddOns/AfsRam/RamDataSink.hpp>
00016
00017 // Defines the format of the contained headers.
00018 typedef Vector<String> HttpResponseHeaders;
00019
00020 class HttpResponse;
00021
00024 class HttpResponse
00025 {
00026     public:
00029         HttpResponse();
00030
00033         String GetStatusLine();
00034
00037         void SetStatusLine(String line);
00038
00041         HttpResponseHeaders GetHeaders();
00042
00045         FilePtr GetFile();
00046
00049         void SetFile(FilePtr file);
00050
00053         RamDataSinkPtr GetBody();
00054
00057         virtual ~HttpResponse();
00058
00061         BOOLEAN Append(HUGE void* data, UINT length);
00062
00065         BOOLEAN Append(String textStr);
00066
00069         BOOLEAN AppendHeader(String headerStr);
00070
00071     protected:
00072         // the status line
00073         String m_statusLine;
00074         // vector of response headers to send
00075         HttpResponseHeaders m_headers;
00076         // eventually file used for response
00077         FilePtr m_file;
00078         // body data to send
00079         RamDataSinkPtr m_body;
00080 };
00081
00083 #endif  // Apoxi_AddOns_Server_HttpServer_HttpResponse_hpp
00084
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServer.cpp File Reference

AddOns/Server/HttpServer/HttpServer.cpp File Reference

#include "PreComp.hpp"
#include "HttpServer.hpp"
#include "HttpApplicationSupplier.hpp"

Include dependency graph for HttpServer.cpp:

Generated on Tue Jan 24 16:45:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServer.hpp File Reference

AddOns/Server/HttpServer/HttpServer.hpp File Reference

#include <Socket/SocketHandler.hpp>
#include <AddOns/Server/Server.hpp>
#include "HttpAuthProvider.hpp"
#include "HttpServerConfig.hpp"
#include "HttpServerSocket.hpp"
#include "HttpRequest.hpp"
#include "HttpClient.hpp"
#include "HttpApplication.hpp"
#include "MsgTypes.hpp"

Include dependency graph for HttpServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpServer

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpServer_hpp

Typedefs

typedef NiSharedPtr< HttpServer > | HttpServerPtr
Smart-pointer controlling a HttpServer object.

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpServer_hpp

Generated on Tue Jan 24 16:45:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServer.hpp Source File

AddOns/Server/HttpServer/HttpServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpServer_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpServer_hpp
00014
00015 #include <Socket/SocketHandler.hpp>
00016 #include <AddOns/Server/Server.hpp>
00017 #include "HttpAuthProvider.hpp"
00018 #include "HttpServerConfig.hpp"
00019 #include "HttpServerSocket.hpp"
00020 #include "HttpRequest.hpp"
00021 #include "HttpClient.hpp"
00022 #include "HttpApplication.hpp"
00023 #include "MsgTypes.hpp"
00024
00025
00026 class HttpServer;
00027
00029 typedef NiSharedPtr<HttpServer> HttpServerPtr;
00030
00033 class HttpServer : public Server
00034 {
00035     typedef Server Base;
00036
00037     friend class HttpServerSocket;
00038     friend class HttpClient;
00039     friend class HttpSocket;
00040
00041     public:
00046         HttpServer(HttpServerConfig* serverConfig, HttpAuthProvider* authProvider = 0);
00047
00050         virtual ~HttpServer();
00051
00058         virtual void Start(const InetSocketAddr& localAddr, DataConnProfileId dataConnProfileId = c_invalid_data_conn_profile_id);
00059
00063         virtual void Stop();
00064
00069         virtual IpAddr GetHostIp();
00070
00075         virtual IpPortNo GetPort();
00076
00077     protected:
00082         virtual void Init();
00083
00088         virtual void Terminate();
00089
00095         virtual BOOLEAN OnMessage(const Message& msg);
00096
00103         virtual BOOLEAN ConnectClient(const InetSocketAddr& peerAddr, const HttpSocketPtr& peerSocket);
00104
00110         virtual BOOLEAN DisconnectClient(UINT clientId);
00111
00118         virtual BOOLEAN HandleRequest(UINT clientId, const HttpRequest& hr);
00119
00125         virtual HttpClient* GetClient(UINT clientId);
00126
00132         virtual HttpApplication* GetApplication(String appId);
00133
00138         virtual Pathname GetWwwDir();
00139
00140     private:
00143         virtual void InternalInit();
00144
00147         virtual void InternalTerminate();
00148
00151         virtual void InternalStart(const InetSocketAddr& localAddr, DataConnProfileId dataConnProfileId);
00152
00155         virtual void InternalStop(const InetSocketAddr& localAddr);
00156
00157         // listening server socket
00158         HttpServerSocketPtr m_httpServerSocket;
00159
00160         // socket handler
00161         SocketHandler m_socketHandler;
00162 };
00163
00165 #endif  // Apoxi_AddOns_Server_HttpServer_HttpServer_hpp
00166
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServerConfig.cpp File Reference

AddOns/Server/HttpServer/HttpServerConfig.cpp File Reference

#include "PreComp.hpp"
#include "HttpServerConfig.hpp"

Include dependency graph for HttpServerConfig.cpp:

Generated on Tue Jan 24 16:45:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServerConfig.hpp File Reference

AddOns/Server/HttpServer/HttpServerConfig.hpp File Reference

#include <AddOns/Server/ServerConfig.hpp>
#include "HttpTypes.hpp"

Include dependency graph for HttpServerConfig.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpServerConfig

Defines

#define | Apoxi_AddOns_Server_HttpServerConfig_hpp

Typedefs

typedef NiSharedPtr< HttpServerConfig > | HttpServerConfigPtr
Smart-pointer controlling a HttpServerConfig object.

Define Documentation

#define Apoxi_AddOns_Server_HttpServerConfig_hpp

Generated on Tue Jan 24 16:45:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServerConfig.hpp Source File

AddOns/Server/HttpServer/HttpServerConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServerConfig_hpp)
00011 #define Apoxi_AddOns_Server_HttpServerConfig_hpp
00014
00015 #include <AddOns/Server/ServerConfig.hpp>
00016 #include "HttpTypes.hpp"
00017
00018 class HttpServerConfig;
00019
00021 typedef NiSharedPtr<HttpServerConfig> HttpServerConfigPtr;
00022
00025 class HttpServerConfig : public ServerConfig
00026 {
00027     typedef ServerConfig Base;
00028
00029     public:
00032         HttpServerConfig();
00033
00036         virtual ~HttpServerConfig();
00037
00042         virtual const Pathname& GetWwwDir();
00043
00048         virtual void SetWwwDir(Pathname wwwDir);
00049
00050     protected:
00051         // location of www directory of the server
00052         Pathname m_wwwDir;
00053 };
00054
00056 #endif  // Apoxi_AddOns_Server_HttpServerConfig_hpp
00057
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServerSocket.cpp File Reference

AddOns/Server/HttpServer/HttpServerSocket.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/System.hpp>
#include "HttpTypes.hpp"
#include "HttpSocket.hpp"
#include "MsgTypes.hpp"
#include "HttpServerSocket.hpp"

Include dependency graph for HttpServerSocket.cpp:

Generated on Tue Jan 24 16:45:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServerSocket.hpp File Reference

AddOns/Server/HttpServer/HttpServerSocket.hpp File Reference

#include <Socket/TcpServerSocket.hpp>
#include <AddOns/Server/Server.hpp>

Include dependency graph for HttpServerSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpServerSocket

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpServerSocket_hpp

Typedefs

typedef NiSharedPtr< HttpServerSocket > | HttpServerSocketPtr
Smart-pointer controlling a HttpServerSocket object.

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpServerSocket_hpp

Generated on Tue Jan 24 16:45:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpServerSocket.hpp Source File

AddOns/Server/HttpServer/HttpServerSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpServerSocket_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpServerSocket_hpp
00014
00015 #include <Socket/TcpServerSocket.hpp>
00016 #include <AddOns/Server/Server.hpp>
00017
00018 class HttpServerSocket;
00019
00021 typedef NiSharedPtr<HttpServerSocket> HttpServerSocketPtr;
00022
00025 class HttpServerSocket : public TcpServerSocket
00026 {
00027     typedef TcpServerSocket Base;
00028
00029     public:
00032         HttpServerSocket(Server* server);
00033
00036         virtual ~HttpServerSocket();
00037
00038     protected:
00041         virtual void OnAsyncEvent(Event event);
00042
00043     private:
00044         // parent server
00045         Server* m_server;
00046
00047 };
00048
00050 #endif  // Apoxi_AddOns_Server_HttpServer_HttpServerSocket_hpp
00051
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpSocket.cpp File Reference

AddOns/Server/HttpServer/HttpSocket.cpp File Reference

#include "PreComp.hpp"
#include "HttpSocket.hpp"
#include <Kernel/System.hpp>
#include <Afs/Rfs/File.hpp>
#include <AddOns/AfsRam/RamDataSource.hpp>
#include "HttpRequest.hpp"
#include "HttpServer.hpp"
#include "MsgTypes.hpp"

Include dependency graph for HttpSocket.cpp:

Generated on Tue Jan 24 16:45:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpSocket.hpp File Reference

AddOns/Server/HttpServer/HttpSocket.hpp File Reference

#include <Auxiliary/Vector.hpp>
#include <Socket/TcpSocket.hpp>
#include <AddOns/Server/Server.hpp>
#include <AddOns/AfsRam/RamDataSource.hpp>
#include "HttpRequest.hpp"
#include "HttpResponse.hpp"

Include dependency graph for HttpSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpSocket

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpSocket_hpp

Typedefs

typedef NiSharedPtr< HttpSocket > | HttpSocketPtr
Smart-pointer controlling a HttpSocket object.

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpSocket_hpp

Generated on Tue Jan 24 16:45:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpSocket.hpp Source File

AddOns/Server/HttpServer/HttpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpSocket_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpSocket_hpp
00014
00015 #include <Auxiliary/Vector.hpp>
00016 #include <Socket/TcpSocket.hpp>
00017 #include <AddOns/Server/Server.hpp>
00018 #include <AddOns/AfsRam/RamDataSource.hpp>
00019 #include "HttpRequest.hpp"
00020 #include "HttpResponse.hpp"
00021
00022 class HttpSocket;
00023
00025 typedef NiSharedPtr<HttpSocket> HttpSocketPtr;
00026
00029 class HttpSocket : public TcpSocket
00030 {
00031     typedef TcpSocket Base;
00032
00033     friend class HttpServer;
00034     friend class HttpClient;
00035
00036     public:
00042         HttpSocket(Server* server, UINT clientId = 0);
00043
00046         virtual ~HttpSocket();
00047
00048     protected:
00053         virtual void SetClientId(UINT clientId);
00054
00059         virtual void OnAsyncEvent(Event event);
00060
00066         virtual BOOLEAN SendResponse(HttpResponse& httpResponse);
00067
00073         virtual String ConvertFromHtml(const String& str);
00074
00080         virtual INT8 HexCharToUInt8(CHAR ch);
00081
00082         // corresponding server
00083         Server* m_server;
00084
00085         // boolean condition which has to be fulfilled before requests can be handled
00086         BooleanCondition m_connected;
00087
00088     private:
00089         // enum specifying whether headers, file content or data sink data is sent
00090         enum HttpResponsePosition {
00091             c_http_response_position_status,
00092             c_http_response_position_headers,
00093             c_http_response_position_file,
00094             c_http_response_position_data
00095         };
00096
00099         virtual BOOLEAN SendStatusLine();
00100
00103         virtual BOOLEAN SendHeader();
00104
00107         virtual BOOLEAN SendFileBlock();
00108
00111         virtual BOOLEAN SendDataBlock();
00112
00115         virtual void ResumeNextResponse();
00116
00119         virtual BOOLEAN ProcessPost(RamDataSource body, HttpRequest& request);
00120
00123         virtual BOOLEAN ReadUrlParameters(RamDataSource& data_src, HttpRequest& request);
00124
00125
00126         // ID of the corresponding client
00127         UINT m_clientId;
00128
00129         // vector with all enqueued responses to send
00130         Vector<HttpResponse> m_responsesToSend;
00131         // pointer to current response to send
00132         HttpResponse* m_currentResponse;
00133
00134         // current position of data to be sent
00135         HttpResponsePosition m_position;
00136         // current offset of data to be sent
00137         UINT32 m_offset;
00138 };
00139
00141 #endif  // Apoxi_AddOns_Server_HttpServer_HttpSocket_hpp
00142
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpTypes.hpp File Reference

AddOns/Server/HttpServer/HttpTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_AddOns_Server_HttpServer_HttpTypes_hpp
#define | APOXI_HTTPSERVER_DEFAULT_BACKLOG 15
#define | APOXI_HTTPSERVER_DEFAULT_MAX_USERS 5
#define | HTTPSERVER_ASCII_AMP 38
#define | HTTPSERVER_ASCII_CR 13
#define | HTTPSERVER_ASCII_DOT 46
#define | HTTPSERVER_ASCII_EQU 61
#define | HTTPSERVER_ASCII_LF 10
#define | HTTPSERVER_ASCII_PER 37
#define | HTTPSERVER_ASCII_PL 43
#define | HTTPSERVER_ASCII_QM 63
#define | HTTPSERVER_ASCII_SL 47
#define | HTTPSERVER_ASCII_SP 32
#define | HTTPSERVER_DBG_OUT_RANGE 35920

Enumerations

enum | HttpResponseCode { c_http_response_code_200, c_http_response_code_400, c_http_response_code_404 }
enum | HttpServiceCommand { c_http_service_command_init, c_http_service_command_terminate, c_http_service_command_start, c_http_service_command_stop }
enum | HttpServiceCommandError { c_http_service_command_error_success, c_http_service_command_error_failed }

Define Documentation

#define Apoxi_AddOns_Server_HttpServer_HttpTypes_hpp

Generated on Tue Jan 24 16:45:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/HttpTypes.hpp Source File

AddOns/Server/HttpServer/HttpTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AddOns_Server_HttpServer_HttpTypes_hpp)
00011 #define Apoxi_AddOns_Server_HttpServer_HttpTypes_hpp
00014
00015
00016 // DBG_OUT Range
00017 #define HTTPSERVER_DBG_OUT_RANGE 35920
00018
00019 // default value for backlog of HttpServerSocket when listening
00020 #define APOXI_HTTPSERVER_DEFAULT_BACKLOG 15
00021
00022 // default maximum of currently connected clients
00023 #define APOXI_HTTPSERVER_DEFAULT_MAX_USERS 5
00024
00025 // default size for transmitting data from or to clients
00026 #if defined(APOXI_TARGETSYSTEM_HOST)
00027 #define HTTPSERVER_DEFAULT_TRANSMISSION_SIZE (128*1024)
00028 #elif defined(APOXI_TARGETSYSTEM_HW)
00029 #define HTTPSERVER_DEFAULT_TRANSMISSION_SIZE (8*1024)
00030 #endif
00031
00032 // used ASCII codes
00033 #define HTTPSERVER_ASCII_LF 10 // line feed
00034 #define HTTPSERVER_ASCII_CR 13 // carriage return
00035 #define HTTPSERVER_ASCII_SP 32 // blank space ' '
00036 #define HTTPSERVER_ASCII_QM 63 // question mark '?'
00037 #define HTTPSERVER_ASCII_EQU    61 // equals sign '='
00038 #define HTTPSERVER_ASCII_AMP    38 // ampersand '&'
00039 #define HTTPSERVER_ASCII_PER    37 // percent sign '%'
00040 #define HTTPSERVER_ASCII_DOT    46 // dot '.'
00041 #define HTTPSERVER_ASCII_SL 47 // forward slash '/'
00042 #define HTTPSERVER_ASCII_PL 43 // plus sign '+'
00043
00044 /* Commands used internally by HttpServer to keep public interface but
00045     initialize SocketHandler in the right ExecutionContext.
00046 */
00047 enum HttpServiceCommand {
00048     c_http_service_command_init,
00049     c_http_service_command_terminate,
00050     c_http_service_command_start,
00051     c_http_service_command_stop
00052 };
00053
00054 enum HttpServiceCommandError {
00055     c_http_service_command_error_success,
00056     c_http_service_command_error_failed
00057 };
00058
00059 // return codes for HttpRequest-handling methods
00060 enum HttpResponseCode {
00061     c_http_response_code_200,   // OK
00062     c_http_response_code_400,   // Bad request
00063     c_http_response_code_404    // Not found
00064 };
00065
00067 #endif  // Apoxi_AddOns_Server_HttpServer_HttpTypes_hpp
00068
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/MsgTypes.cpp File Reference

AddOns/Server/HttpServer/MsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/MsgTypes.hpp File Reference

AddOns/Server/HttpServer/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Socket/InetSocketAddr.hpp>
#include <Socket/DataConnProfile.hpp>
#include <AddOns/Server/HttpServer/HttpTypes.hpp>
#include <AddOns/Server/HttpServer/HttpRequest.hpp>
#include <AddOns/Server/HttpServer/HttpSocket.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HttpConnectMessage
class | HttpDisconnectMessage
class | HttpErrorMessage
class | HttpRequestMessage
class | HttpServiceMessage

Defines

#define | AddOns_Server_HttpServer_MsgTypes_hpp

Define Documentation

#define AddOns_Server_HttpServer_MsgTypes_hpp

Generated on Tue Jan 24 14:56:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/MsgTypes.hpp Source File

AddOns/Server/HttpServer/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "working\_views\Oberhube_server_FTP_HTTP_sv\lnz_apoxi\Apoxi\AddOns\Server\HttpServer\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(AddOns_Server_HttpServer_MsgTypes_hpp)
00017 #define AddOns_Server_HttpServer_MsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Socket/InetSocketAddr.hpp>
00021 #include <Socket/DataConnProfile.hpp>
00022 #include <AddOns/Server/HttpServer/HttpTypes.hpp>
00023 #include <AddOns/Server/HttpServer/HttpRequest.hpp>
00024 #include <AddOns/Server/HttpServer/HttpSocket.hpp>
00025
00026
00027 /* ----------------------------------------------------------------------
00028     Classes
00029     ---------------------------------------------------------------------- */
00030
00031 /*  ======================================================================
00032     Class HttpServiceMessage
00033     ====================================================================== */
00034
00036 class HttpServiceMessage : public Message {
00037     public:
00038         HttpServiceMessage(const HttpServiceCommand& cmd, const InetSocketAddr& socketAddr = InetSocketAddr(), const DataConnProfileId& dataConnProfileId = c_invalid_data_conn_profile_id);
00039         virtual ~HttpServiceMessage();
00040
00041         virtual const MsgMetaData& GetMetaData() const;
00042         const HttpServiceCommand& GetCmd() const { return m_cmd; }
00043         const InetSocketAddr& GetSocketAddr() const { return m_socketAddr; }
00044         const DataConnProfileId& GetDataConnProfileId() const { return m_dataConnProfileId; }
00045         virtual Message* Clone() const;
00046
00047         enum  {
00048             ID = 4510
00049             };
00050
00051     private:
00052         static const MsgMetaData m_meta_data;
00053         HttpServiceCommand m_cmd;
00054         InetSocketAddr m_socketAddr;
00055         DataConnProfileId m_dataConnProfileId;
00056
00057     };
00058
00059
00060 /*  ======================================================================
00061     Class HttpErrorMessage
00062     ====================================================================== */
00063
00065 class HttpErrorMessage : public Message {
00066     public:
00067         HttpErrorMessage(const HttpServiceCommand& cmd, const HttpServiceCommandError& code);
00068         virtual ~HttpErrorMessage();
00069
00070         virtual const MsgMetaData& GetMetaData() const;
00071         const HttpServiceCommand& GetCmd() const { return m_cmd; }
00072         const HttpServiceCommandError& GetCode() const { return m_code; }
00073         virtual Message* Clone() const;
00074
00075         enum  {
00076             ID = 4511
00077             };
00078
00079     private:
00080         static const MsgMetaData m_meta_data;
00081         HttpServiceCommand m_cmd;
00082         HttpServiceCommandError m_code;
00083
00084     };
00085
00086
00087 /*  ======================================================================
00088     Class HttpRequestMessage
00089     ====================================================================== */
00090
00092 class HttpRequestMessage : public Message {
00093     public:
00094         HttpRequestMessage(UINT clientId, const HttpRequest& httpRequest);
00095         virtual ~HttpRequestMessage();
00096
00097         virtual const MsgMetaData& GetMetaData() const;
00098         UINT GetClientId() const { return m_clientId; }
00099         const HttpRequest& GetHttpRequest() const { return m_httpRequest; }
00100         virtual Message* Clone() const;
00101
00102         enum  {
00103             ID = 4512
00104             };
00105
00106     private:
00107         static const MsgMetaData m_meta_data;
00108         UINT m_clientId;
00109         HttpRequest m_httpRequest;
00110
00111     };
00112
00113
00114 /*  ======================================================================
00115     Class HttpConnectMessage
00116     ====================================================================== */
00117
00119 class HttpConnectMessage : public Message {
00120     public:
00121         HttpConnectMessage(const InetSocketAddr& peerAddr, const HttpSocketPtr& peerSocket);
00122         virtual ~HttpConnectMessage();
00123
00124         virtual const MsgMetaData& GetMetaData() const;
00125         const InetSocketAddr& GetPeerAddr() const { return m_peerAddr; }
00126         const HttpSocketPtr& GetPeerSocket() const { return m_peerSocket; }
00127         virtual Message* Clone() const;
00128
00129         enum  {
00130             ID = 4513
00131             };
00132
00133     private:
00134         static const MsgMetaData m_meta_data;
00135         InetSocketAddr m_peerAddr;
00136         HttpSocketPtr m_peerSocket;
00137
00138     };
00139
00140
00141 /*  ======================================================================
00142     Class HttpDisconnectMessage
00143     ====================================================================== */
00144
00146 class HttpDisconnectMessage : public Message {
00147     public:
00148         HttpDisconnectMessage(UINT clientId);
00149         virtual ~HttpDisconnectMessage();
00150
00151         virtual const MsgMetaData& GetMetaData() const;
00152         UINT GetClientId() const { return m_clientId; }
00153         virtual Message* Clone() const;
00154
00155         enum  {
00156             ID = 4514
00157             };
00158
00159     private:
00160         static const MsgMetaData m_meta_data;
00161         UINT m_clientId;
00162
00163     };
00164
00165 #endif // AddOns_Server_HttpServer_MsgTypes_hpp
00166
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/PreComp.cpp File Reference

AddOns/Server/HttpServer/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/PreComp.hpp File Reference

AddOns/Server/HttpServer/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Server/HttpServer/PreComp.hpp Source File

AddOns/Server/HttpServer/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Services/Service.cpp File Reference

AddOns/Services/Service.cpp File Reference

#include <Kernel/Os/Os.hpp>
#include "Service.hpp"

Include dependency graph for Service.cpp:

Variables

const Guid Guid_NoGuid = DefGuid_NoGuid
Generated on Tue Jan 24 16:45:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Services/Service.hpp File Reference

AddOns/Services/Service.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/AppContainer.hpp>
#include <Auxiliary/HashTable.hpp>

Include dependency graph for Service.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Guid
class | Service
class | ServicePtr< T >

Defines

#define | DefGuid_NoGuid {0x0, 0x0, 0x0, {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}}
#define | Services_Service_hpp

Typedefs

typedef Service::ServiceResult | ServiceResult

Variables

const Guid | Guid_NoGuid

Define Documentation

#define Services_Service_hpp

Generated on Tue Jan 24 16:45:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Services/Service.hpp Source File

AddOns/Services/Service.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Services_Service_hpp)
00010 #define Services_Service_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/AppContainer.hpp>
00017 #include <Auxiliary/HashTable.hpp>
00018
00019 class Guid {
00020     public:
00021         UINT32 data1;
00022         UINT16 data2;
00023         UINT16 data3;
00024         UINT8  data4[8];
00025
00026         BOOLEAN operator == (const Guid& guid) const {
00027             return memcmp(this, &guid, sizeof(Guid)) == 0;
00028         }
00029
00030         BOOLEAN operator != (const Guid& guid) const {
00031             return memcmp(this, &guid, sizeof(Guid)) != 0;
00032         }
00033 };
00034
00035
00065 class Service : public Linkable<Service> {
00066     public:
00068         enum ServiceResult {
00070             ServResSuccess,
00072             ServResError
00073         };
00074
00076         Service(Guid guid);
00077
00079         virtual ~Service();
00080
00082         const Guid& GetGuid() const;
00083
00084     private:
00085         Guid m_guid;
00086 };
00087
00088 template<class T> class ServicePtr {
00089     public:
00090         ServicePtr() : m_p(0) {}
00091         ServicePtr(Service *serv_ptr) : m_p((T*)serv_ptr) {}
00092
00093         void Init(Service *serv_ptr) {
00094             m_p = (T*)serv_ptr;
00095         }
00096
00097         T* operator->() const {
00098             return m_p;
00099         }
00100
00101         ServicePtr<T> operator=(const Service *s) {
00102             m_p = (T*) s;
00103             return *this;
00104         }
00105
00106         BOOLEAN operator !=(const ServicePtr<T>& s) const {
00107             return m_p != s.m_p;
00108         }
00109
00110         BOOLEAN operator ==(const ServicePtr<T>& s) const {
00111             return m_p == s.m_p;
00112         }
00113
00114         T& operator*() {
00115             return *m_p;
00116         }
00117
00118     private:
00119         T *m_p;
00120 };
00121
00122 typedef Service::ServiceResult ServiceResult;
00123
00124 #define DefGuid_NoGuid {0x0, 0x0, 0x0, {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}}
00125 extern const Guid Guid_NoGuid;
00126
00128 #endif  // Services_Service_hpp
00129
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Services/ServiceBroker.cpp File Reference

AddOns/Services/ServiceBroker.cpp File Reference

#include <Kernel/Os/Os.hpp>
#include "ServiceBroker.hpp"
#include <Kernel/System.hpp>
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for ServiceBroker.cpp:

Generated on Tue Jan 24 16:45:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Services/ServiceBroker.hpp File Reference

AddOns/Services/ServiceBroker.hpp File Reference

#include <Auxiliary/HashTable.hpp>
#include <AddOns/Services/Service.hpp>
#include <Kernel/Os/Mutex.hpp>

Include dependency graph for ServiceBroker.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ServiceBroker
class | ServiceBroker::ServiceBrokerDestructor

Defines

#define | Services_ServiceBroker_hpp

Variables

const INT | c_broker_table_size = 10

Define Documentation

#define Services_ServiceBroker_hpp

Generated on Tue Jan 24 16:45:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Services/ServiceBroker.hpp Source File

AddOns/Services/ServiceBroker.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Services_ServiceBroker_hpp)
00010 #define Services_ServiceBroker_hpp
00014
00015 #include <Auxiliary/HashTable.hpp>
00016 #include <AddOns/Services/Service.hpp>
00017 #include <Kernel/Os/Mutex.hpp>
00018
00019 const INT c_broker_table_size = 10;
00020
00027 class ServiceBroker {
00028
00029     class ServiceBrokerDestructor {
00030         public:
00031             ServiceBrokerDestructor();
00032             virtual ~ServiceBrokerDestructor();
00033     };
00034
00035     public:
00036         friend class Service;
00037         typedef LinkedList<Service> ServiceList;
00038
00041         static ServiceBroker* GetBroker();
00042
00044         static void Release();
00045
00050         Service* GetService(const Guid& guid);
00051
00053         BOOLEAN IsServiceSupported(const Guid& guid);
00054
00056         void RegisterService(Service* service);
00057
00059         void UnregisterService(Service* service);
00060
00061     private:
00062         friend class ServiceBrokerDestructor;
00063
00065         ServiceBroker();    //lint !e1704
00066
00068         virtual ~ServiceBroker();
00069
00070         static ServiceBroker* m_broker;
00071         static ServiceBrokerDestructor m_destructor;
00072         static Mutex* m_mutex;
00073
00074         UINT16 Hash(const Guid &guid);
00075
00076         ServiceList m_service_root[c_broker_table_size];
00077
00078 };
00079
00081 #endif  // Services_ServiceBroker_hpp
00082
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Services/ServicesTemplates.cpp File Reference

AddOns/Services/ServicesTemplates.cpp File Reference

#include <AddOns/Services/ServiceBroker.hpp>

Include dependency graph for ServicesTemplates.cpp:

Generated on Tue Jan 24 16:45:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/IrSocketAddr.cpp File Reference

AddOns/SioSocketAdapter/IrSocketAddr.cpp File Reference

#include "PreComp.hpp"
#include "IrSocketAddr.hpp"
#include <msimport.h>
#include <scttypes.h>
#include <sio.h>
#include <sio_sock.h>
#include <sio_common.h>
#include <msexport.h>
#include <btapi_common.h>
#include <io_sockbt.h>
#include <sio_sockbt.h>

Include dependency graph for IrSocketAddr.cpp:

Generated on Tue Jan 24 16:45:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/IrSocketAddr.hpp File Reference

AddOns/SioSocketAdapter/IrSocketAddr.hpp File Reference

#include <AddOns/SerialSocket/SockAddress.hpp>

Include dependency graph for IrSocketAddr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class IrSocketAddr

Generated on Tue Jan 24 16:45:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/IrSocketAddr.hpp Source File

AddOns/SioSocketAdapter/IrSocketAddr.hpp

Go to the documentation of this file.
00001 /* ============================================================================
00002 ** Copyright (C) 2004-2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** ============================================================================
00004 **
00005 ** This document contains proprietary information belonging to COMNEON.
00006 ** Passing on and copying of this document, use and communication of its
00007 ** contents is not permitted without prior written authorisation.
00008 **
00009 ** ============================================================================
00010 ** Revision Information :
00011 **    File name: IrSocketAddr.hpp
00012 **    Version:
00013 **    Date: 2005-12-22    14:48:26
00014 **
00015 ** ============================================================================
00016 **
00017 ** Project:     VenusU
00018 ** Block:       IrSocketAddr
00019 ** Process:
00020 ** File name:   IrSocketAddr.hpp
00021 **
00022 ** ============================================================================
00023 **
00024 **
00025 ** ============================================================================
00026 ** History:
00027 **
00028 ** Date        Author               Comment
00029 ** ----------------------------------------------------------------------------
00030 **
00031 ** 2005-12-22  schwenke             created.
00032 ** ============================================================================
00033 */
00034
00035 #ifndef SERIAL_IRSOCKADDRESS_H
00036 #define SERIAL_IRSOCKADDRESS_H
00037
00038 #include <AddOns/SerialSocket/SockAddress.hpp>
00039 //#include <Bluetooth/BtDeviceAddress.hpp>
00040
00041 //enum BtProtocol
00042 //{
00043 //    c_bt_protocol_l2cap,
00044 //    c_bt_protocol_rfcomm
00045 //};
00046
00047 /*
00048 typedef UINT32 IrDeviceAddress; // from \3p_irda_esi\inc\irlmpttp.h  //IrDeviceAddr
00049
00050
00051 typedef struct sock_ir_socket_s //analog zu \ms-bt-src\src\bt-ctrl\sio_sockbt.h  sock_bt_rfcomm_t
00052 {
00053     sock_family_t       family;    // = BT
00054     sock_ir_protocol_t  protocol;  //enum // = L2CAP, RFCOMM
00055
00056     IrDeviceAddress      bdAddr;
00057     btapi_u8_t          server_channel;
00058
00059 } sock_ir_socket_t;
00060 */
00061
00062 /*
00063 #ifndef (SIO_SOCK_HEAD)
00064
00065 typedef unsigned short sock_family_t;
00066 typedef unsigned int sock_protocol_t;
00067
00068 //#define SIO_SOCK_HEAD \
00069 //    sock_family_t    family; \
00070 //    sock_protocol_t  protocol; \
00071 //  long             fd;
00072
00073
00074
00075 typedef struct sock_termio_s
00076 {
00077 //    SIO_SOCK_HEAD
00078     sock_family_t    family;
00079     sock_protocol_t  protocol;
00080     long             fd;
00081
00082     struct
00083     {
00084         CHAR  serv_addr[SIO_MAX_DEVICENAME_LENGTH + 1];
00085         CHAR  dev_addr[SIO_MAX_DEVICENAME_LENGTH + 1];
00086
00087     } sa;
00088
00089     long  *at_fd;  // AT default device descriptor.
00090
00091 }  sock_termio_t;
00092
00093 #endif
00094 */
00095 //Socket IR address
00096 class IrSocketAddr : public SocketAddr
00097 {
00098 public:
00100     IrSocketAddr(BOOLEAN is_server);
00105 //  IrSocketAddr(sock_termio_t& addr, UINT8 serverchannel);
00107     virtual ~IrSocketAddr();
00110     void* GetSockAddr();
00113     INT32 GetSockAddrSize();
00114
00118 //    void GetDeviceAddress(IrDeviceAddress &irDevAddr);
00119
00122 //  unsigned char GetServerChannel();
00123
00124 private:
00125     void* m_irSockAddr; // sock_termio_t
00126     INT32 m_AddrSize;
00127 };
00128
00129 #endif //SERIAL_IRSOCKADDRESS_H
00130
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/PreComp.cpp File Reference

AddOns/SioSocketAdapter/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/PreComp.hpp File Reference

AddOns/SioSocketAdapter/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/PreComp.hpp Source File

AddOns/SioSocketAdapter/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/SioSocketAdapter.cpp File Reference

AddOns/SioSocketAdapter/SioSocketAdapter.cpp File Reference

#include "PreComp.hpp"
#include "SioSocketAdapter.hpp"
#include <AddOns/SerialSocket/SerialServerSocket.hpp>
#include <AddOns/SerialSocket/SerialClientSocket.hpp>
#include <AddOns/BtSocket/BtSocketAddr.hpp>
#include <Irda/IrdaTransport.hpp>

Include dependency graph for SioSocketAdapter.cpp:

Generated on Tue Jan 24 16:45:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/SioSocketAdapter.hpp File Reference

AddOns/SioSocketAdapter/SioSocketAdapter.hpp File Reference

#include <AddOns/SerialSocket/SerialIoAdapter.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include "IrSocketAddr.hpp"

Include dependency graph for SioSocketAdapter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SioSocketAdapter
class | SioSocketAdapter::SerialClientSockEventListener
class | SioSocketAdapter::SerialServerSockEventListener
struct | SioSocketAdapter::SioSocketCallbacks

Defines

#define | Apoxi_SioSocketAdapter_hpp

Typedefs

typedef NiSharedPtr< SerialClientSocket > | SerialClientSocketPtr
Smart-pointer controlling a SerialClientSocket object.
typedef NiSharedPtr< SerialServerSocket > | SerialServerSocketPtr
Smart-pointer controlling a SerialServerSocket object.

Define Documentation

#define Apoxi_SioSocketAdapter_hpp

Typedef Documentation

typedef NiSharedPtr<SerialClientSocket> SerialClientSocketPtr

Smart-pointer controlling a SerialClientSocket object.

typedef NiSharedPtr<SerialServerSocket> SerialServerSocketPtr

Smart-pointer controlling a SerialServerSocket object.

Generated on Tue Jan 24 16:45:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SioSocketAdapter/SioSocketAdapter.hpp Source File

AddOns/SioSocketAdapter/SioSocketAdapter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SioSocketAdapter_hpp)
00010 #define Apoxi_SioSocketAdapter_hpp
00011
00012 #include <AddOns/SerialSocket/SerialIoAdapter.hpp>
00013 #include <Auxiliary/NiSharedPtr.hpp>
00014 #include "IrSocketAddr.hpp"
00015
00016 class SerialServerSocket;
00017 class SerialClientSocket;
00018
00020 typedef NiSharedPtr<SerialServerSocket> SerialServerSocketPtr;
00022 typedef NiSharedPtr<SerialClientSocket> SerialClientSocketPtr;
00023
00024 class SioSocketAdapter
00025 {
00026     private:
00027         enum {
00028             /* 0 .. (c_sioadapter_max_sockets - 1)                            -> server socket
00029                c_sioadapter_max_sockets .. (2 * c_sioadapter_max_sockets - 1) -> client socket
00030                else                                                           -> invalid
00031              */
00032             c_sioadapter_max_sockets = 8,
00033             c_sioadapter_invalid_sock_id = 2 * c_sioadapter_max_sockets
00034         };
00035
00036         class SerialServerSockEventListener : public SocketEventListener {
00037             virtual void OnSocketEvent(Socket::Event event, Socket *socket);
00038         };
00039
00040         class SerialClientSockEventListener : public SocketEventListener {
00041             virtual void OnSocketEvent(Socket::Event event, Socket *socket);
00042         };
00043
00044         friend class SioSocketAdapter::SerialClientSockEventListener;
00045         friend class SioSocketAdapter::SerialServerSockEventListener;
00046
00047         // Forbid construction.
00048         SioSocketAdapter();
00049         // Forbid destruction.
00050         ~SioSocketAdapter();
00051
00052     public:
00053         typedef INT8 SocketId;
00054         typedef UINT16 IrdaParams;
00055
00056         typedef void (*SimpleCb)(SocketId sock_id, INT32 result);
00057         typedef void (*AcceptCb)(SocketId sock_id, INT32 result, SocketId client_sock_id);
00058
00059         struct SioSocketCallbacks {
00060     //      SimpleCb m_close_cnf_cb;
00061     //      SimpleCb m_listen_cnf_cb;
00062     //???       AcceptCb m_accept_cnf_cb;
00063             SimpleCb m_connect_ind_cb;       //Server only
00064             SimpleCb m_disconnect_ind_cb;
00065             SimpleCb m_connect_cnf_cb;       //Client only
00066             SimpleCb m_write_cnf_cb;         //Data successfully written
00067     //      SimpleCb m_read_cnf_cb;
00068     //      SimpleCb m_send_data_cnf_cb;
00069             SimpleCb m_data_available_ind_cb;   //You can/shall read data now
00070         };
00071
00075         static void Init(const SioSocketCallbacks &callbacks);
00076
00082         static SocketId Create(SerialIoAdapter::SocketFamily fam, INT protocol,
00083             const SocketAddr *address = 0, BOOLEAN is_server = FALSE);
00084
00087         static void Close(SocketId sock_id);
00088
00093         static BOOLEAN Listen(SocketId sock_id, INT backlog);
00094
00101         static SocketId Accept(SocketId sock_id, SocketAddr &client_addr);
00102
00109         static BOOLEAN Connect(SocketId sock_id, SocketAddr &serv_addr);
00110
00111 // TO DO set these parameters before Connect()
00112 // !!!!!        UINT32 idType, const IrdaParams *pAttr = 0, const CHAR *pIas = 0, UINT32 iasLength = 0);
00113
00119         static UINT32 Write(SocketId sock_id, const UINT8 *pDataBuf, UINT32 dataSize);
00120
00125         static UINT32 Read(SocketId sock_id, UINT8 *pReadBuf, UINT32 readSize);
00126
00127         // todo: comments: really needed???
00128 //      static INT IoCtl(INT requestcode, INT argument);
00129
00135         static INT OptGet(INT optname, void *optval, INT &optlen);
00136
00142         static INT OptSet(INT optname, const void *optval, INT optlen);
00143
00144         // TO DO set these parameters before Connect()
00145         // !!!!!        UINT32 idType, const IrdaParams *pAttr = 0, const CHAR *pIas = 0, UINT32 iasLength = 0);
00146
00147
00148
00149     private:
00150         static SocketId GetSocketIdBySerialSocket(const Socket &socket);
00151         static SocketId GetNextFreeSocketId(BOOLEAN is_server);
00152
00153         static const SioSocketCallbacks *s_sock_cbs;
00154
00155         static SerialServerSocketPtr m_server_socket[c_sioadapter_max_sockets];
00156         static SerialClientSocketPtr m_client_socket[c_sioadapter_max_sockets];
00157         static SerialServerSockEventListener m_socket_event_listener;
00158 //      static IrdaSocketAddr *m_rfCommAddr;
00159 //      static L2CapSocketAddr *m_l2capAddr;
00160 };
00161
00162
00163
00164
00165 /* Instruction, how to set IrDA-Hint Bits, from Headerfile \Apoxi\Irda\IrdaTransport.hpp:
00166
00172 //      void SetHintBits(UINT byte_offset, UINT8 bit_mask) const;
00173
00179 //      void ClearHintBits(UINT byte_offset, UINT8 bit_mask) const;
00180
00181 /* Example Code:
00182   #include <Irda/IrdaTransport.hpp>
00183
00184   IrdaTransport::GetInstance().SetHintBits  (byte_offset, bit_mask); //byte_offset = 0..1
00185   IrdaTransport::GetInstance().ClearHintBits(byte_offset, bit_mask); //byte_offset = 0..1
00186
00187
00188
00189
00190 */
00191
00192
00193 // TODO: obsolete or into own headerfile:
00194 /*
00195 struct IrdaParams {
00196     UINT16 irda_hintbits;
00197 };
00198 */
00199
00206 //      void SetIrdaSocketParams(SocketId sock_id, IrdaParams *pAttr, const UINT8 *pIas, UINT32 iasLength);
00207
00208
00209
00210 #endif  //Apoxi_SioSocketAdapter_hpp
00211
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/apoxi_emcpp_OBEXAdapter.hpp File Reference

AddOns/StreamObex/apoxi_emcpp_OBEXAdapter.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | apoxi_emcpp_OBEXAdapter

Defines

#define | EMCPP_OBEX_CLIENT 0
#define | EMCPP_OBEX_SERVER 1

Define Documentation

#define EMCPP_OBEX_CLIENT 0

#define EMCPP_OBEX_SERVER 1

Generated on Tue Jan 24 16:45:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/apoxi_emcpp_OBEXAdapter.hpp Source File

AddOns/StreamObex/apoxi_emcpp_OBEXAdapter.hpp

Go to the documentation of this file.
00001 #ifndef emcpp_apoxi_emcpp_OBEXAdapter_HPP_FIRST
00002 #define emcpp_apoxi_emcpp_OBEXAdapter_HPP_FIRST
00003
00004 #ifndef EMCPP_OBEX_SERVER
00005 #define EMCPP_OBEX_SERVER 1
00006 #endif
00007
00008 #ifndef EMCPP_OBEX_CLIENT
00009 #define EMCPP_OBEX_CLIENT 0
00010 #endif
00011
00012 class ObexObject;
00013
00014 class emcpp_apoxi_OBEXAdapter;
00015 class apoxi_emcpp_OBEXAdapterPrivate;
00016
00017 class apoxi_emcpp_OBEXAdapter {
00018   typedef apoxi_emcpp_OBEXAdapterPrivate Private;
00019 public:
00020   apoxi_emcpp_OBEXAdapter(emcpp_apoxi_OBEXAdapter& back);
00021
00022   ~apoxi_emcpp_OBEXAdapter();
00023
00024 #if EMCPP_OBEX_SERVER
00025   int handle_response(unsigned char response_code,
00026                       const ObexObject& response);
00027 #endif
00028
00029 #if EMCPP_OBEX_CLIENT
00030   int handle_request(unsigned char request_code,
00031                      const ObexObject& request);
00032 #endif
00033   Private& private_implementation()
00034   { return *_private; }
00035
00036   const Private& private_implementation() const
00037   { return *_private; }
00038
00039 private:
00040   Private*           _private;
00041 };
00042
00043
00044 #endif
00045
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/emcpp_apoxi_OBEXAdapter.hpp File Reference

AddOns/StreamObex/emcpp_apoxi_OBEXAdapter.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class emcpp_apoxi_OBEXAdapter

Generated on Tue Jan 24 16:45:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/emcpp_apoxi_OBEXAdapter.hpp Source File

AddOns/StreamObex/emcpp_apoxi_OBEXAdapter.hpp

Go to the documentation of this file.
00001 #ifndef emcpp_apoxi_OBEXAdapter_HPP_FIRST
00002 #define emcpp_apoxi_OBEXAdapter_HPP_FIRST
00003
00004 class StreamObexImpl;
00005 class ObexChannel;
00006
00007 class emcpp_apoxi_OBEXAdapterPrivate;
00008
00009 class emcpp_apoxi_OBEXAdapter {
00010   typedef emcpp_apoxi_OBEXAdapterPrivate Private;
00011 public:
00012   emcpp_apoxi_OBEXAdapter(StreamObexImpl& obex_implementation,
00013                           const ObexChannel& obex_channel);
00014
00015   ~emcpp_apoxi_OBEXAdapter();
00016
00017   Private& private_implementation()
00018   { return *_private; }
00019
00020   const Private& private_implementation() const
00021   { return *_private; }
00022
00023   StreamObexImpl& obex_implementation()
00024   { return _obex_implementation; }
00025
00026   const ObexChannel& obex_channel() const
00027   { return _obex_channel; }
00028
00029 private:
00030   StreamObexImpl&    _obex_implementation;
00031   const ObexChannel& _obex_channel;
00032   Private*           _private;
00033 };
00034
00035
00036 #endif
00037
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexImpl.cpp File Reference

AddOns/StreamObex/StreamObexImpl.cpp File Reference

#include "StreamObexPreComp.hpp"
#include "StreamObexImpl.hpp"
#include "StreamObexTransport.hpp"
#include <Auxiliary/WString.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexHeader.hpp>
#include <Obex/ObexResult.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexOperationId.hpp>
#include <Obex/ObexMessages.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexBuffer.hpp>

Include dependency graph for StreamObexImpl.cpp:

Generated on Tue Jan 24 16:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexImpl.hpp File Reference

AddOns/StreamObex/StreamObexImpl.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/UserDispatcher.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Auxiliary/ByteBuffer.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexLayer.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexBuffer.hpp>
#include "apoxi_emcpp_OBEXAdapter.hpp"
#include "emcpp_apoxi_OBEXAdapter.hpp"

Include dependency graph for StreamObexImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamObexImpl

Defines

#define | AddOns_StreamObexImpl_hpp

Define Documentation

#define AddOns_StreamObexImpl_hpp

Generated on Tue Jan 24 16:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexImpl.hpp Source File

AddOns/StreamObex/StreamObexImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AddOns_StreamObexImpl_hpp)
00010 #define AddOns_StreamObexImpl_hpp
00011
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/UserDispatcher.hpp>
00015 #include <Kernel/Os/Mutex.hpp>
00016 #include <Auxiliary/ByteBuffer.hpp>
00017 #include <Obex/ObexObject.hpp>
00018 #include <Obex/ObexLayer.hpp>
00019 #include <Obex/ObexChannel.hpp>
00020 #include <Obex/ObexBuffer.hpp>
00021
00022 #include "apoxi_emcpp_OBEXAdapter.hpp"
00023 #include "emcpp_apoxi_OBEXAdapter.hpp"
00024
00025 class StreamObexTransport;
00026
00027
00029 class StreamObexImpl : public ObexLayer {
00030
00031         typedef ObexLayer Base;
00032
00033
00034     public:
00035
00036         enum Error { SUCCESS = 0, FAIL = 1 };
00037
00039         StreamObexImpl(StreamObexTransport& stream_obex_transport);
00040
00042         virtual ~StreamObexImpl();
00043
00045         void Init();
00046
00048         void Create();
00049
00051         void Destroy();
00052
00054         virtual void Connect(const ObexChannel& client_chan, ObexOperationId oper_id, const ObexObject& conn_req);
00055
00057         virtual void Get(const ObexChannel& client_chan, ObexOperationId oper_id, const ObexObject& conn_req);
00058
00060         virtual void Put(const ObexChannel& client_chan, ObexOperationId oper_id, const ObexObject& conn_req);
00061
00063         virtual void Abort(const ObexChannel& client_chan, ObexOperationId oper_id, const ObexObject& conn_req);
00064
00066         virtual void SetPath(const ObexChannel& client_chan, ObexOperationId oper_id, const ObexObject& conn_req);
00067
00069         virtual void Disconnect(const ObexChannel& client_chan, ObexOperationId oper_id, const ObexObject& conn_req);
00070
00072         virtual void ReturnResponse(const ObexChannel& client_chan, ObexOperationId oper_id, const ObexObject& conn_req);
00073
00075         virtual void DataProcessed(const ObexChannel& client_chan, ObexOperationId oper_id, ObexBuffer& buffer);
00076
00078         virtual ObexResult AcquireClientChannel(ObexChannel& result, const ObexAddrPtr& addr_ptr, BOOLEAN reserve);
00079
00081         virtual ObexResult AcquireServerChannel(ObexChannel& result, const ObexAddrPtr& addr_ptr, BOOLEAN reserve) ;
00082
00084         virtual ObexResult ReleaseChannel(ObexChannel& channel);
00085
00087         virtual void OpenClientChannel(const ObexChannel& client_chan, ObexOperationId oper_id, const ObexAddrPtr& addr_ptr);
00088
00090         virtual void BindServerChannel(const ObexChannel& server_chan, ObexOperationId oper_id, const ObexAddrPtr& addr_ptr);
00091
00093         virtual void CloseChannel(const ObexChannel& server_chan, ObexOperationId oper_id);
00094
00096         ObexOperationId GetOperationId(const ObexChannel& channel);
00097
00099         void HandlePut(const ObexChannel& channel, const ObexObject& object);
00100
00102         void HandleGet(const ObexChannel& channel, const ObexObject& object);
00103
00105         void HandleConnect(const ObexChannel& channel, const ObexObject& object);
00106
00108         void HandleDisconnect(const ObexChannel& channel, const ObexObject& object);
00109
00111         void HandleSetPath(const ObexChannel& channel, const ObexObject& object);
00112
00114         void HandleAbort(const ObexChannel& channel, const ObexObject& object);
00115
00117         void HandleTransportDisconnect(const ObexChannel& channel);
00118
00120         void GetRequestBuffer(const ObexChannel& channel, ObexBuffer& buffer);
00121
00123         void ReturnResponseBuffer(const ObexChannel& channel, ObexBuffer& buffer);
00124
00126         // stores OperationId per Channel internally
00127         Error BeginOperation(const ObexChannel& channel);
00128         Error EndOperation(const ObexChannel& channel, ObexResult::ErrorCode oper_result);
00129         INT   IsOperationActive(const ObexChannel& channel);
00130
00132         // if no buffer avail @return null
00133         ObexBuffer* CreateBuffer(const ObexChannel& channel, unsigned short expected_packet_size);
00134         void FinalizeBuffer(const ObexChannel& channel);
00135
00136         StreamObexTransport& GetTransport();
00137
00138
00139     private:
00140
00141         StreamObexTransport& m_stream_obex_transport;
00142         ObexChannel m_obex_channel;
00143
00144         ObexOperationId m_oper_id;
00145
00146         ObexBuffer m_obex_buffer;
00147
00148         emcpp_apoxi_OBEXAdapter* m_emcpp_apoxi_obex_adapter;
00149         apoxi_emcpp_OBEXAdapter* m_apoxi_emcpp_obex_adapter;
00150
00151         Mutex m_mutex;
00152
00153
00154 };
00155
00156 #endif
00157
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexPreComp.cpp File Reference

AddOns/StreamObex/StreamObexPreComp.cpp File Reference

#include "StreamObexPreComp.hpp"

Include dependency graph for StreamObexPreComp.cpp:

Generated on Tue Jan 24 16:46:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexPreComp.hpp File Reference

AddOns/StreamObex/StreamObexPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for StreamObexPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:46:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexPreComp.hpp Source File

AddOns/StreamObex/StreamObexPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Asc/Lib.hpp>
00012
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexTransport.cpp File Reference

AddOns/StreamObex/StreamObexTransport.cpp File Reference

#include "StreamObexPreComp.hpp"
#include "StreamObexTransport.hpp"
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexMessages.hpp>
#include <AddOns/Usb/UsbTransport.hpp>

Include dependency graph for StreamObexTransport.cpp:

Generated on Tue Jan 24 16:46:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexTransport.hpp File Reference

AddOns/StreamObex/StreamObexTransport.hpp File Reference

#include <Obex/ObexTransport.hpp>
#include "StreamObexImpl.hpp"

Include dependency graph for StreamObexTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamObexTransport

Defines

#define | Apoxi_StreamObexTransport_hpp

Define Documentation

#define Apoxi_StreamObexTransport_hpp

Generated on Tue Jan 24 16:46:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/StreamObex/StreamObexTransport.hpp Source File

AddOns/StreamObex/StreamObexTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_StreamObexTransport_hpp)
00010 #define Apoxi_StreamObexTransport_hpp
00011
00012 #include <Obex/ObexTransport.hpp>
00013 #include "StreamObexImpl.hpp"
00014
00015 class UsbTransport;
00016
00017 class StreamObexTransport : public ObexAbstractTransport {
00018
00019     typedef ObexAbstractTransport Base;
00020
00022     public:
00023
00025         virtual ~StreamObexTransport();
00026
00028         //static StreamObexTransport* GetInstance();
00029
00031         //static void ReleaseInstance();
00032
00034         void            Init(AbstractTransport &    device_abs,
00035                              const CHAR *           scheme_url);
00036
00037
00039         //virtual ObexProtocol* GetProtocol(ObexProtocolId level);
00040
00042         //virtual void ResolveServerAddr(const String &     server_url,
00043         //                                ObexProtocolId    prot_id,
00044         //                                BOOLEAN           sdb_autocreate,
00045         //                                ObexOperationId   job_id) ;
00047                             //virtual void ResolveClientAddr(const String & client_url,
00048                             //                                ObexProtocolId    prot_id,
00049                             //            ObexOperationId   job_id);
00050
00051
00052         inline StreamObexImpl& GetStreamObexImpl() { return m_obex_impl; }
00053
00055     protected:
00056
00058         StreamObexTransport();
00059
00060
00062     private:
00063
00065         static StreamObexTransport* m_obex_transport;
00066
00068         //ObexAddrPtr m_server_addr;
00069
00071         StreamObexImpl m_obex_impl;
00072
00073 };
00074
00075 #endif // Apoxi_StreamObexTransport_hpp
00076
Generated on Tue Jan 24 14:45:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/fonts.hpp File Reference

AddOns/Svg/fonts.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_fonts_hpp
#define | APOXI_SVG_FONT_SIZE 76614

Define Documentation

#define Apoxi_fonts_hpp

#define APOXI_SVG_FONT_SIZE 76614

Generated on Tue Jan 24 16:46:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/MsgTypes.cpp File Reference

AddOns/Svg/MsgTypes.cpp File Reference

#include "AddOns/Svg/PreComp.hpp"
#include "AddOns/Svg/SvgPlayer.hpp"
#include "Auxiliary/WString.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/MsgTypes.hpp File Reference

AddOns/Svg/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SvgDecodingFinishedMsg
class | SvgHyperlinkSelectMsg
class | SvgStatusMsg

Defines

#define | AddOns_Svg_MsgTypes_hpp

Define Documentation

#define AddOns_Svg_MsgTypes_hpp

Generated on Tue Jan 24 14:56:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/MsgTypes.hpp Source File

AddOns/Svg/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "Views\schrette_view\lnz_apoxi\Apoxi\AddOns\Svg\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(AddOns_Svg_MsgTypes_hpp)
00017 #define AddOns_Svg_MsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020
00021
00022 class SvgPlayer;
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class SvgDecodingFinishedMsg
00030     ====================================================================== */
00031
00034 class SvgDecodingFinishedMsg : public Message {
00035     public:
00036         SvgDecodingFinishedMsg(SvgPlayer* player, const Ticks& ticks);
00037         virtual ~SvgDecodingFinishedMsg();
00038
00039         virtual const MsgMetaData& GetMetaData() const;
00040         SvgPlayer* GetPlayer() const { return m_player; }
00041         const Ticks& GetTicks() const { return m_ticks; }
00042         virtual Message* Clone() const;
00043
00044         enum  {
00045             ID = 4400
00046             };
00047
00048     private:
00049         static const MsgMetaData m_meta_data;
00050         SvgPlayer* m_player;
00051         Ticks m_ticks;
00052
00053     };
00054
00055
00056 /*  ======================================================================
00057     Class SvgStatusMsg
00058     ====================================================================== */
00059
00062 class SvgStatusMsg : public ContextMsg {
00063     public:
00064         SvgStatusMsg(ExecutionContext* context, SvgPlayer* player, INT8 status);
00065         virtual ~SvgStatusMsg();
00066
00067         virtual const MsgMetaData& GetMetaData() const;
00068         SvgPlayer* GetPlayer() const { return m_player; }
00069         INT8 GetStatus() const { return m_status; }
00070         virtual Message* Clone() const;
00071
00072         enum  {
00073             ID = 4401
00074             };
00075
00076     private:
00077         static const MsgMetaData m_meta_data;
00078         SvgPlayer* m_player;
00079         INT8 m_status;
00080
00081     };
00082
00083
00084 /*  ======================================================================
00085     Class SvgHyperlinkSelectMsg
00086     ====================================================================== */
00087
00089 class SvgHyperlinkSelectMsg : public ContextMsg {
00090     public:
00091         SvgHyperlinkSelectMsg(ExecutionContext* context, SvgPlayer* player, const WString& hyperlink);
00092         virtual ~SvgHyperlinkSelectMsg();
00093
00094         virtual const MsgMetaData& GetMetaData() const;
00095         SvgPlayer* GetPlayer() const { return m_player; }
00096         const WString& GetHyperlink() const { return m_hyperlink; }
00097         virtual Message* Clone() const;
00098
00099         enum  {
00100             ID = 4402
00101             };
00102
00103     private:
00104         static const MsgMetaData m_meta_data;
00105         SvgPlayer* m_player;
00106         WString m_hyperlink;
00107
00108     };
00109
00110 #endif // AddOns_Svg_MsgTypes_hpp
00111
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/PreComp.cpp File Reference

AddOns/Svg/PreComp.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/PreComp.hpp File Reference

AddOns/Svg/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Os/Os.hpp>
#include "SvgConfig.hpp"

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/PreComp.hpp Source File

AddOns/Svg/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 //lint -e506
00010 //lint -e774
00011 //lint -e527
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include "SvgConfig.hpp"
00017
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgConfig.hpp File Reference

AddOns/Svg/SvgConfig.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_SvgConfig_hpp
#define | SVG_ANTI_ALIAS_LEVEL 2
#define | SVG_BYTES_PER_PIXEL 2
#define | SVG_DEBUG
#define | SVG_FONT_ANTI_ALIAS_LEVEL 3
#define | SVG_FONT_RESOURCE_FFS ((SVG_FONT_RESOURCE_INLINE) ^ 0x01)
#define | SVG_FONT_RESOURCE_FFS_FILENAME L"svg_font_file.svgz"
#define | SVG_FONT_RESOURCE_INLINE 0x01
#define | SVG_FONT_RESOURCE_INLINE_FILENAME "fonts.hpp"
#define | SVG_FONT_USE_SYSTEM_FONT 0
#define | SVG_LARGEST_IMAGE_SIZE 153600
#define | SVG_NUMBER_OF_ZOOMLEVELS 31
#define | SVG_PLAYER_DEFAULT_HEIGHT 128
#define | SVG_PLAYER_DEFAULT_WIDTH 128
#define | SVG_SMALLEST_PREFERED_MEM_CHUNK_SIZE 16384
#define | SVG_VIRTUAL_HEAP 0

Define Documentation

#define Apoxi_SvgConfig_hpp

#define SVG_ANTI_ALIAS_LEVEL 2

SVG_ANTI_ALIAS_LEVEL the number of samples used by the anti alias algorithm, 2 = 4 samples, 3 = 9 samples and so on. Lower values increase performance but makes less attractive results.

#define SVG_BYTES_PER_PIXEL 2

SVG_BYTES_PER_PIXEL is the number of bytes used to store a pixel in our native representation. This value cannot be altered just like that since it is platform dependent.

#define SVG_DEBUG

Uncomment SVG_DEBUG to enable debugging. A whole lot of debugging is controled in SvgDebug.hpp see that for mote details.

#define SVG_FONT_ANTI_ALIAS_LEVEL 3

#define SVG_FONT_RESOURCE_FFS ((SVG_FONT_RESOURCE_INLINE) ^ 0x01)

#define SVG_FONT_RESOURCE_FFS_FILENAME L"svg_font_file.svgz"

#define SVG_FONT_RESOURCE_INLINE 0x01

We are present two options when it comes to the storage of SVG font files. Either the SVG font data is stored on the flash files system (FFS) preferably as a .svgz file. The other alternative is to store the font file as a part of the program code.

To enable FFS storage, and disable code inline behaviour, set SVG_FONT_RESOURCE_INLINE to 0x00 To enable code inline, and disable FFS storage behaviour, set SVG_FONT_RESOURCE_INLINE to 0x01 There is no need to alter the value of SVG_FONT_RESOURCE_FFS since this value is the complement value to SVG_FONT_RESOURCE_INLINE. depending on what choice of resource you have made please define SVG_FONT_RESOURCE_INLINE_FILENAME and SVG_FONT_RESOURCE_FFS_FILENAME properly.

#define SVG_FONT_RESOURCE_INLINE_FILENAME "fonts.hpp"

#define SVG_FONT_USE_SYSTEM_FONT 0

#define SVG_LARGEST_IMAGE_SIZE 153600

In order save memory large inline images are scaled down before rendered if they contain more pixels than SVG_LARGEST_IMAGE_SIZE

#define SVG_NUMBER_OF_ZOOMLEVELS 31

#define SVG_PLAYER_DEFAULT_HEIGHT 128

#define SVG_PLAYER_DEFAULT_WIDTH 128

In some cases SVG documents have no width or height or these are of relative nature expressed as a percentage value. In such cases we use a default width and height. Alter these values to anything you like as long as they are greater than 0.

#define SVG_SMALLEST_PREFERED_MEM_CHUNK_SIZE 16384

This value is set to the smallest memory chunk we try to allocate on behalf of the SVG rendering engine. Don't alter this value unless you know what you are doing. In the current implemetaiton see: SvgDecoder::Callback_Malloc for more details.

#define SVG_VIRTUAL_HEAP 0

Generated on Tue Jan 24 16:46:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgConfig.hpp Source File

AddOns/Svg/SvgConfig.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgConfig_hpp)
00011 #define Apoxi_SvgConfig_hpp
00012
00017 #define SVG_DEBUG
00018
00024 #define SVG_BYTES_PER_PIXEL 2
00025
00031 #define SVG_ANTI_ALIAS_LEVEL 2
00032
00033 #define SVG_FONT_ANTI_ALIAS_LEVEL 3
00034
00041 #define SVG_SMALLEST_PREFERED_MEM_CHUNK_SIZE 16384
00042
00055 #define SVG_FONT_RESOURCE_INLINE      0x01
00056 #define SVG_FONT_RESOURCE_INLINE_FILENAME "fonts.hpp"
00057 #define SVG_FONT_RESOURCE_FFS       ((SVG_FONT_RESOURCE_INLINE) ^ 0x01)
00058 #define SVG_FONT_RESOURCE_FFS_FILENAME    L"svg_font_file.svgz"
00059
00060 #if defined(APOXI_ENABLE_SVG_SYSTEM_FONTS)
00061     #define SVG_FONT_USE_SYSTEM_FONT 1
00062 #else
00063     #define SVG_FONT_USE_SYSTEM_FONT 0
00064 #endif
00065
00070 #define SVG_LARGEST_IMAGE_SIZE 153600
00071
00072
00073 #define SVG_VIRTUAL_HEAP    0
00074
00075 #define SVG_NUMBER_OF_ZOOMLEVELS 31
00076
00082 #define SVG_PLAYER_DEFAULT_WIDTH  128
00083 #define SVG_PLAYER_DEFAULT_HEIGHT 128
00084
00085 #endif
00086
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgDebug.hpp File Reference

AddOns/Svg/SvgDebug.hpp File Reference

#include "SvgConfig.hpp"

Include dependency graph for SvgDebug.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_SvgPlayerDebug_hpp
#define | SVG_ASSERT(COND)
#define | SVG_DBG_OUT(SECTION, DATA)
#define | SVG_DBG_SECTION_CALLBACK 0x00000002
#define | SVG_DBG_SECTION_DECODER 0x00000001
#define | SVG_DBG_SECTION_FILEWRAPPER 0x00000010
#define | SVG_DBG_SECTION_FIXPOINT 0x00000200
#define | SVG_DBG_SECTION_GZ 0x00000400
#define | SVG_DBG_SECTION_IMAGE 0x00000008
#define | SVG_DBG_SECTION_MEMORY 0x00000020
#define | SVG_DBG_SECTION_MEMORY_PROF 0x00000040
#define | SVG_DBG_SECTION_MIME 0x00000080
#define | SVG_DBG_SECTION_PLAYER 0x00000004
#define | SVG_DBG_SECTION_SYSFONTS 0x00000800
#define | SVG_DBG_SECTION_TEST 0x00000100
#define | SVG_DBG_SECTIONS_USE_ALL 0
#define | SVG_DBG_USED_SECTIONS (SVG_DBG_SECTION_TEST | SVG_DBG_SECTION_IMAGE | SVG_DBG_SECTION_DECODER | SVG_DBG_SECTION_CALLBACK | SVG_DBG_SECTION_MEMORY_PROF)
#define | SVG_PRINT_IMAGE_ERROR(ERROR_CODE)

Define Documentation

#define Apoxi_SvgPlayerDebug_hpp

Generated on Tue Jan 24 16:46:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgDebug.hpp Source File

AddOns/Svg/SvgDebug.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgPlayerDebug_hpp)
00011 #define Apoxi_SvgPlayerDebug_hpp
00015
00016 #include "SvgConfig.hpp"
00017
00018 #define SVG_DBG_SECTION_DECODER     0x00000001
00019 #define SVG_DBG_SECTION_CALLBACK    0x00000002
00020 #define SVG_DBG_SECTION_PLAYER      0x00000004
00021 #define SVG_DBG_SECTION_IMAGE       0x00000008
00022 #define SVG_DBG_SECTION_FILEWRAPPER 0x00000010
00023 #define SVG_DBG_SECTION_MEMORY      0x00000020
00024 #define SVG_DBG_SECTION_MEMORY_PROF 0x00000040
00025 #define SVG_DBG_SECTION_MIME        0x00000080
00026 #define SVG_DBG_SECTION_TEST        0x00000100
00027 #define SVG_DBG_SECTION_FIXPOINT    0x00000200
00028 #define SVG_DBG_SECTION_GZ          0x00000400
00029 #define SVG_DBG_SECTION_SYSFONTS    0x00000800
00030
00031 #ifdef SVG_DEBUG
00032
00033 #define SVG_DBG_USED_SECTIONS (SVG_DBG_SECTION_TEST | SVG_DBG_SECTION_IMAGE | SVG_DBG_SECTION_DECODER | SVG_DBG_SECTION_CALLBACK | SVG_DBG_SECTION_MEMORY_PROF)
00034 #define SVG_DBG_SECTIONS_USE_ALL 0
00035
00036 #define SVG_DBG_OUT(SECTION, DATA) \
00037     if((SECTION & SVG_DBG_USED_SECTIONS) || SVG_DBG_SECTIONS_USE_ALL){ \
00038         DBG_OUT(DATA); \
00039     }
00040
00041 #define SVG_ASSERT(COND) \
00042     if(!(COND)){ \
00043         DBG_OUT((0, "ASSERTION \"" #COND "\" FAILED AT: \"%s:%d\"\n", __FILE__, __LINE__)); \
00044     }
00045
00046 #define SVG_PRINT_IMAGE_ERROR(ERROR_CODE) \
00047     switch(ERROR_CODE) \
00048     { \
00049         case Image::NoError: \
00050             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: NoError\n")); \
00051             break; \
00052         case Image::UnspecifiedError: \
00053             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: UnspecifiedError\n")); \
00054             break; \
00055         case Image::InvalidSizeError: \
00056             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: InvalidSizeError\n")); \
00057             break; \
00058         case Image::InitializationError: \
00059             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: InitializationError\n")); \
00060             break; \
00061         case Image::ScanlineBufferError: \
00062             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: ScanLineBufferError\n")); \
00063             break; \
00064         case Image::MissingDataError: \
00065             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: MissingDataError\n")); \
00066             break; \
00067         case Image::IsCurrentlyDecodedError: \
00068             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: IsCurrently>DecodedError\n")); \
00069             break; \
00070         case Image::CouldNotAllocateThreadletError: \
00071             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: CouldNotAllocateThreadletError\n")); \
00072             break; \
00073         case Image::ThreadletStoppedError: \
00074             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: ThreadletStoppedError\n")); \
00075             break; \
00076         case Image::OutOfMemoryError: \
00077             SVG_DBG_OUT(SVG_DBG_SECTION_DECODER, (0, "*** SVGPLAYER::Callback_OpenStream() : Jpeg init error: OutOfMemory\n")); \
00078             break; \
00079         default: \
00080             break; \
00081     }
00082
00083
00084 #else
00085
00088 #define SVG_DBG_OUT(SECTION, DATA)
00089 #define SVG_ASSERT(COND)
00090 #define SVG_PRINT_IMAGE_ERROR(ERROR_CODE)
00091
00092 #endif // SVG_DEBUG
00093
00094 #endif // SvgPlayerDebug_hpp
00095
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgDecoder.cpp File Reference

AddOns/Svg/SvgDecoder.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Gui/Image.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/BitmapDc.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <AddOns/MultiMedia/PngImage.hpp>
#include <AddOns/MultiMedia/GifImage.hpp>
#include <AddOns/MultiMedia/WbmpImage.hpp>
#include <Auxiliary/WString.hpp>
#include <Gui/FontManager.hpp>
#include <Gui/TextFormat.hpp>
#include <Config/FontConfig.hpp>
#include "SvgDecoder.hpp"
#include "SvgConfig.hpp"
#include "SvgMimeUtil.hpp"
#include "SvgFixPoint.hpp"
#include "SvgIoWrapper.hpp"
#include "SvgFileWrapper.hpp"
#include "SvgGzFileWrapper.hpp"
#include "SvgImageFileWrapper.hpp"
#include "zpchar8utilh.h"
#include "zpnativecolorh.h"
#include "fonts.hpp"

Include dependency graph for SvgDecoder.cpp:

Defines

#define | SVG_FILE_FONTS "svg_fonts.svg"
#define | SVG_FILE_SVG_DOCUMENT "svg_document.svg"
#define | SvgFontConfig UINT32
#define | SVGFONTCONFIG_GET_FONT_ATTR(SVGFC) (((SVGFC) >> 8) & 0x000000FF)
#define | SVGFONTCONFIG_GET_FONT_INDEX(SVGFC) ( (SVGFC) & 0x000000FF)
#define | SVGFONTCONFIG_SET_FONT_ATTR(SVGFC, ATTR) ((SVGFC) |= (0x0000FF00 & ((ATTR) << 8)));
#define | SVGFONTCONFIG_SET_FONT_INDEX(SVGFC, INDEX) ((SVGFC) |= (0x000000FF & (INDEX)));

Define Documentation

#define SVG_FILE_FONTS "svg_fonts.svg"

#define SVG_FILE_SVG_DOCUMENT "svg_document.svg"

#define SvgFontConfig UINT32

#define SVGFONTCONFIG_GET_FONT_ATTR ( SVGFC ) (((SVGFC) >> 8) & 0x000000FF)

#define SVGFONTCONFIG_GET_FONT_INDEX ( SVGFC ) ( (SVGFC) & 0x000000FF)

#define SVGFONTCONFIG_SET_FONT_ATTR | ( | SVGFC,
 |  | ATTR | ) | ((SVGFC) |= (0x0000FF00 & ((ATTR) << 8)));

#define SVGFONTCONFIG_SET_FONT_INDEX | ( | SVGFC,
 |  | INDEX | ) | ((SVGFC) |= (0x000000FF & (INDEX)));

Generated on Tue Jan 24 16:46:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgDecoder.hpp File Reference

AddOns/Svg/SvgDecoder.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_SvgDecoder_hpp

Define Documentation

#define Apoxi_SvgDecoder_hpp

Generated on Tue Jan 24 16:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgDecoder.hpp Source File

AddOns/Svg/SvgDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgDecoder_hpp)
00011 #define Apoxi_SvgDecoder_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00017
00018 #include <Kernel/Threadlet.hpp>
00019 #include "SvgConfig.hpp"
00020
00021 #include "zpplayerh.h"
00022 #include "zpdisplaybufferh.h"
00023
00024
00025 #ifdef APOXI_ENABLE_SVG_FONT_SERIALIZATION
00026     #include <Afs/Rfs/File.hpp>
00027     #include "zpwritecallbackh.h"
00028 #endif
00029
00030 #define SVG_METADATA_NO_SUCH_KEY          0
00031
00032 #define SVG_METADATA_TYPE_STRING          1
00033 #define SVG_METADATA_TYPE_INT             2
00034
00035 #define SVG_METADATA_PLAYER_NAME          1
00036 #define SVG_METADATA_PLAYER_VERSION       2
00037 #define SVG_METADATA_PRESENTATION_TITLE   3
00038 #define SVG_METADATA_PRESENTATION_DESC    4
00039
00040 #define SVG_DURATION_UNKNOWN              0xFFFFFFFF
00041
00042 typedef enum {
00043   SvgDecoderNoError = 0,
00044   SvgDecoderNoAnimationLoadedError = 2,
00045   SvgDecoderNoWidthSpecifiedError,
00046   SvgDecoderNoHeightSpecifiedError,
00047   SvgDecoderNoSuchMetadataKeyError,
00048   SvgDecoderDurationUnknownError,
00049   SvgDecoderAllocationError,
00050   SvgDecoderMethodNotImplementedError,
00051   SvgDecoderInitializationError,
00052   SvgDecoderInvalidInputParameterError,
00053   SvgDecoderNoLinkActivatedError,
00054   SvgDecoderNoSuchEventError
00055 } SvgDecoderError;
00056
00057 typedef enum {
00058   SvgDecoderNoEvent = 0,
00059   /* Normal Events */
00060   SvgDecoderActivateEvent,
00061   SvgDecoderClickEvent,
00062   SvgDecoderMouseUpEvent,
00063   SvgDecoderMouseDownEvent,
00064   SvgDecoderShowHyperlinksEvent,
00065   SvgDecoderHideHyperlinksEvent,
00066   SvgDecoderSelectNextHyperlinkEvent,
00067   SvgDecoderSelectPreviousHyperlinkEvent,
00068
00069   /* Special Root Element events */
00070   SvgDecoderFocusInEvent = 64,
00071   SvgDecoderFocusOutEvent,
00072   SvgDecoderUiActivateEvent,
00073
00074 } SvgDecoderInputEvent;
00075
00076 typedef enum {
00077   SvgDecoderNoChangeEvent = 0,
00078   SvgDecoderTimeHasChangedEvent,
00079   SvgDecoderExternalHyperlinkActivatedEvent,
00080   SvgDecoderHyperlinkListChangedEvent
00081 } SvgDecoderOutputEvent;
00082
00083 class SvgDecoder;
00084
00089 class SvgDecoderThreadlet : public Threadlet {
00090     typedef Threadlet Base;
00091
00092     public:
00093         virtual ~SvgDecoderThreadlet();
00094
00097         static SvgDecoderThreadlet* CreateInstance(SvgDecoder* decoder,
00098                                                    BinData* bindata);
00099
00101         virtual void ReleaseInstance();
00102
00104         virtual INT Fn();
00105
00106     private:
00107         SvgDecoder* m_decoder;
00108         BinData* m_bindata;
00109
00110         SvgDecoderThreadlet(SvgDecoder* decoder, BinData* bindata);
00111 };
00112
00116 class SvgDecoder {
00117   public:
00118     SvgDecoder(BOOLEAN *p_success = 0);
00119     BOOLEAN Init();
00120     ~SvgDecoder(void);
00121     SvgDecoderError GetError(void) const { return m_last_error_code; };
00122     UINT8 GetBytesPerPixel(void) const { return SVG_BYTES_PER_PIXEL; };
00123     BOOLEAN SetFrameBuffer(void *p_frame_buffer, UINT16 width, UINT16 height);
00124     BOOLEAN Load(BinData *p_bin_data, BOOLEAN blocking);
00125     BOOLEAN Unload(void);
00126     INT16 GetWidth(BOOLEAN *p_is_percent, UINT32 offset_millis = 0);
00127     INT16 GetHeight(BOOLEAN *p_is_percent, UINT32 offset_millis = 0);
00128     INT16 ScaleWidthHeight(INT16 *width, INT16 *height, UINT32 offset_millis = 0);
00129     INT8  GetMetaDataType(UINT16 key);
00130     INT16 GetMetaDataStringLength(UINT16 key);
00131     BOOLEAN GetMetaDataString(UINT16 key, WCHAR *p_buffer, INT16 buffer_length);
00132     INT32 GetMetaDataInteger(UINT16 key);
00133     UINT32 GetDuration(void);
00134     BOOLEAN SetTransformation(INT32 x_scale, INT32 y_scale, INT32 x_shear, INT32 y_shear, INT32 x_trans, INT32 y_trans);
00135     BOOLEAN RenderFrameAt(UINT32 offset_mills);
00136     BOOLEAN RenderFrameAtWithEvent(UINT32 offset_millis, SvgDecoderInputEvent input_event, SvgDecoderOutputEvent *p_output_event);
00137     INT16 GetLastSelectedHyperlinkLength(void) const { return m_last_selected_hyperlink_length; };
00138     BOOLEAN GetLastSelectedHyperlink(UINT8 *p_buffer, UINT32 time_offset = 0);
00139     BOOLEAN IsDocumentZoomAndPanAble() const;
00140     void ToUserSpace(INT32 viewportX, INT32 viewportY, INT32& userX, INT32& userY, XYDIM width, XYDIM height, BOOLEAN* visible, UINT32 time_offset);
00141     void ToViewportSpace(INT32 userX, INT32 userY, INT32& viewportX, INT32& viewportY, XYDIM width, XYDIM height, BOOLEAN* visible, UINT32 time_offset);
00142
00143     const BinData* GetBinData() const {
00144         return m_svg_data;
00145     };
00146
00147 #ifdef APOXI_ENABLE_SVG_FONT_SERIALIZATION
00148     BOOLEAN SerializeSvgFont(FilePtr file);
00149 #endif
00150
00151   private:
00152     /* framebuffer in which the frames are rendered */
00153     void *m_frame_buffer;
00154
00155     /* the last error that the player did */
00156     SvgDecoderError m_last_error_code;
00157
00158     /* zoomon player */
00159     ZPPlayer *m_player;
00160     ZPNativeGraphicsInfo m_display_info;
00161     ZPDisplayBuffer m_display_buffer;
00162     BOOLEAN* m_is_loading;
00163
00164     /* The string length of the last selected hyperlink */
00165     INT16 m_last_selected_hyperlink_length;
00166
00167     /* struct containing the callback pointers */
00168     ZPCallback m_callbacks;
00169
00170     /* Carries the SVG data */
00171     BinData *m_svg_data;
00172
00173     /* Callbacks used by the ZoomOn Player */
00174     static void*    Callback_Malloc(void *p_userdata, ZPUInt32 min_size, ZPUInt32 *p_allocated_size);
00175     static void     Callback_Free(void *p_userdata, void *p_memory);
00176     static ZPStatus Callback_OpenStream(void *p_userdata, const ZPChar8 *p_xml_base, const ZPChar8 *p_href, ZPMIMEContentType *p_content, void **pp_stream_handle);
00177     static ZPStatus Callback_ReadStream(void *p_userdata, void *p_stream_handle, void *p_buffer, const ZPSize buffer_size, ZPSize *p_bytes_read);
00178     static void     Callback_CloseStream(void *p_userdata, void *p_stream_handle);
00179     static ZPStatus Callback_OpenDecodeSession(void *p_userdata, void *p_stream_handle, const ZPMIMEContentType content, void **pp_decode_session_handle);
00180     static ZPStatus Callback_GetImageSize(void *p_userdata, void *p_decode_session_handle, ZPSize *p_width, ZPSize *p_height);
00181     static ZPStatus Callback_DecodeImage(void *p_userdata, void *p_decode_session_handle, ZPUInt8 *p_target_buffer, const ZPSize target_buffer_size);
00182     static void     Callback_CloseDecodeSession(void *p_userdata, void *p_decode_session_handle);
00183     static void*  Callback_IndexFont(void *p_userdata, const ZPChar16 **p_fontfamily_list, const ZPSize *p_fontfamily_list_length, ZPSize no_of_fontfamilies, ZPUInt8 weight, ZPBool italic);
00184     static void   Callback_RenderText(void *p_userdata, void *p_fontindex, const ZPChar16 *p_text, ZPSize no_of_glyphs, ZPTextPosition *p_text_position, ZPTextRenderGraphics *p_graphics, ZPRasterInt *p_left, ZPRasterInt *p_bottom, ZPRasterInt *p_width, ZPRasterInt *p_height, ZPRasterInt *p_text_advance);
00185 #ifdef APOXI_ENABLE_SVG_FONT_SERIALIZATION
00186     static ZPStatus Callback_WriteStream(void *pUserData, void *pOutStream, const ZPUInt8 *pData, ZPSize size);
00187     static ZPStatus Callback_SeekStream(void *pUserData, void *pOutStream, const ZPInt offset, ZPWriteCallbackSeekOrigin origin);
00188
00189     static UINT32 m_write_offset;
00190 #endif
00191 };
00192
00194 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00195 #endif  // Apoxi_SvgDecoder_hpp
00196
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgFileWrapper.cpp File Reference

AddOns/Svg/SvgFileWrapper.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include "SvgFileWrapper.hpp"

Include dependency graph for SvgFileWrapper.cpp:

Generated on Tue Jan 24 16:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgFileWrapper.hpp File Reference

AddOns/Svg/SvgFileWrapper.hpp File Reference

#include <Auxiliary/RamData.hpp>
#include "SvgIoWrapper.hpp"

Include dependency graph for SvgFileWrapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SvgFileWrapper

Defines

#define | Apoxi_SvgFileWrapper_hpp

Define Documentation

#define Apoxi_SvgFileWrapper_hpp

Generated on Tue Jan 24 16:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgFileWrapper.hpp Source File

AddOns/Svg/SvgFileWrapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgFileWrapper_hpp)
00011 #define Apoxi_SvgFileWrapper_hpp
00015
00016 #include <Auxiliary/RamData.hpp>
00017
00018 #include "SvgIoWrapper.hpp"
00019
00021 class SvgFileWrapper : public SvgIoWrapper
00022 {
00023     public:
00025         SvgFileWrapper();
00027         SvgFileWrapper(UINT8 *p_buffer, UINT32 buffer_length, BOOLEAN release_ramdata = FALSE);
00029         SvgFileWrapper(BinData *p_bin_data, BOOLEAN release_ramdata = FALSE);
00031         virtual ~SvgFileWrapper();
00033         virtual UINT32 Read(UINT8 *p_dst_buffer, UINT32 bytes_wanted);
00034
00035     private:
00036         BinData *m_bin_data;
00037         UINT32 m_buffer_offset;
00038     BOOLEAN m_realease_ramdata;
00039 };
00041 #endif
00042
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgFixPoint.cpp File Reference

AddOns/Svg/SvgFixPoint.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include <Auxiliary/Macros.hpp>
#include "SvgFixPoint.hpp"

Include dependency graph for SvgFixPoint.cpp:

Defines

#define | SVG_FP_CONST_0 0x00000000
#define | SVG_FP_CONST_1 0x00010000
#define | SVG_FP_CONST_90 0x005A0000
#define | SVG_FP_ENTRIES_PER_DEG 4
#define | SVG_FP_FIRST_QUADRANT 360
#define | SVG_FP_ONE_REVOLUTION 1440
#define | SVG_FP_SECOND_QUADRANT 720
#define | SVG_FP_THIRD_QUADRANT 1080
#define | SvgFixPoint_Bounded_Cos(ANG) SvgFixPoint_CosTable[ANG];

Functions

SvgFixPoint | SvgFixPoint_Scalar_Mul (const SvgFixPoint a, const SvgFixPoint b)
void | SvgFixPoint_Scalar_Print (SvgFixPoint a)
void | SvgFixPoint_Transform_Init (SvgFixPointTrans *a)
void | SvgFixPoint_Transform_Rotate (SvgFixPointTrans *a, const SvgFixPoint angle, const SvgFixPoint x_center, const SvgFixPoint y_center)
void | SvgFixPoint_Transform_Scale (SvgFixPointTrans *a, const SvgFixPoint scale_factor, const SvgFixPoint x_center, const SvgFixPoint y_center)
void | SvgFixPoint_Transform_Translate (SvgFixPointTrans *a, const SvgFixPoint xt, const SvgFixPoint yt)
void | SvgFixPoint_Transform_XY_Scale (SvgFixPointTrans *a, const SvgFixPoint xs, const SvgFixPoint ys, const SvgFixPoint x_center, const SvgFixPoint y_center)

Define Documentation

#define SVG_FP_CONST_0 0x00000000

#define SVG_FP_CONST_1 0x00010000

#define SVG_FP_CONST_90 0x005A0000

#define SVG_FP_ENTRIES_PER_DEG 4

#define SVG_FP_FIRST_QUADRANT 360

#define SVG_FP_ONE_REVOLUTION 1440

#define SVG_FP_SECOND_QUADRANT 720

#define SVG_FP_THIRD_QUADRANT 1080

#define SvgFixPoint_Bounded_Cos ( ANG ) SvgFixPoint_CosTable[ANG];

Generated on Tue Jan 24 16:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgFixPoint.hpp File Reference

AddOns/Svg/SvgFixPoint.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | S_SvgFixPointTrans

Defines

#define | Apoxi_SvgFixPoint_hpp
#define | SVG_FP_FP_TO_INT(V) ((V) >> 16)
#define | SVG_FP_INT_TO_FP(V) ((V) << 16)
#define | SVG_FP_TRANS_GET_X_SCALE(T) ((T)->x_scale)
#define | SVG_FP_TRANS_GET_X_SHEAR(T) ((T)->x_shear)
#define | SVG_FP_TRANS_GET_X_TRANS(T) ((T)->x_trans)
#define | SVG_FP_TRANS_GET_Y_SCALE(T) ((T)->y_scale)
#define | SVG_FP_TRANS_GET_Y_SHEAR(T) ((T)->y_shear)
#define | SVG_FP_TRANS_GET_Y_TRANS(T) ((T)->y_trans)
#define | SVG_FP_TRANS_SET_X_SCALE(T, V) (((T)->x_scale) = (V));
#define | SVG_FP_TRANS_SET_X_SHEAR(T, V) (((T)->x_shear) = (V));
#define | SVG_FP_TRANS_SET_X_TRANS(T, V) (((T)->x_trans) = (V));
#define | SVG_FP_TRANS_SET_Y_SCALE(T, V) (((T)->y_scale) = (V));
#define | SVG_FP_TRANS_SET_Y_SHEAR(T, V) (((T)->y_shear) = (V));
#define | SVG_FP_TRANS_SET_Y_TRANS(T, V) (((T)->y_trans) = (V));
#define | SvgFixPoint_Scalar_Add(A, B) ((A) + (B))
#define | SvgFixPoint_Scalar_Sub(A, B) ((A) - (B))

Typedefs

typedef INT32 | SvgFixPoint
typedef S_SvgFixPointTrans | SvgFixPointTrans

Functions

SvgFixPoint | SvgFixPoint_Scalar_Mul (const SvgFixPoint a, const SvgFixPoint b)
void | SvgFixPoint_Scalar_Print (SvgFixPoint a)
void | SvgFixPoint_Transform_Init (SvgFixPointTrans *a)
void | SvgFixPoint_Transform_Print (SvgFixPointTrans *a)
void | SvgFixPoint_Transform_Rotate (SvgFixPointTrans *a, const SvgFixPoint angle, const SvgFixPoint x_center, const SvgFixPoint y_center)
void | SvgFixPoint_Transform_Scale (SvgFixPointTrans *a, const SvgFixPoint scale_factor, const SvgFixPoint x_center, const SvgFixPoint y_center)
void | SvgFixPoint_Transform_Translate (SvgFixPointTrans *a, const SvgFixPoint x_trans, const SvgFixPoint y_trans)
void | SvgFixPoint_Transform_XY_Scale (SvgFixPointTrans *a, const SvgFixPoint xs, const SvgFixPoint ys, const SvgFixPoint x_center, const SvgFixPoint y_center)

Define Documentation

#define Apoxi_SvgFixPoint_hpp

Generated on Tue Jan 24 16:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgFixPoint.hpp Source File

AddOns/Svg/SvgFixPoint.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgFixPoint_hpp)
00011 #define Apoxi_SvgFixPoint_hpp
00015
00016 typedef INT32 SvgFixPoint;
00017
00018 struct S_SvgFixPointTrans
00019 {
00020     SvgFixPoint x_scale, y_scale;
00021     SvgFixPoint x_trans, y_trans;
00022     SvgFixPoint x_shear, y_shear;
00023 };
00024 typedef struct S_SvgFixPointTrans SvgFixPointTrans;
00025
00026 #define SVG_FP_TRANS_GET_X_SCALE(T) ((T)->x_scale)
00027 #define SVG_FP_TRANS_GET_Y_SCALE(T) ((T)->y_scale)
00028 #define SVG_FP_TRANS_GET_X_TRANS(T) ((T)->x_trans)
00029 #define SVG_FP_TRANS_GET_Y_TRANS(T) ((T)->y_trans)
00030 #define SVG_FP_TRANS_GET_X_SHEAR(T) ((T)->x_shear)
00031 #define SVG_FP_TRANS_GET_Y_SHEAR(T) ((T)->y_shear)
00032
00033 #define SVG_FP_TRANS_SET_X_SCALE(T, V) (((T)->x_scale) = (V));
00034 #define SVG_FP_TRANS_SET_Y_SCALE(T, V) (((T)->y_scale) = (V));
00035 #define SVG_FP_TRANS_SET_X_TRANS(T, V) (((T)->x_trans) = (V));
00036 #define SVG_FP_TRANS_SET_Y_TRANS(T, V) (((T)->y_trans) = (V));
00037 #define SVG_FP_TRANS_SET_X_SHEAR(T, V) (((T)->x_shear) = (V));
00038 #define SVG_FP_TRANS_SET_Y_SHEAR(T, V) (((T)->y_shear) = (V));
00039
00040 #define SVG_FP_INT_TO_FP(V) ((V) << 16)
00041 #define SVG_FP_FP_TO_INT(V) ((V) >> 16)
00042
00043 void SvgFixPoint_Transform_Print(SvgFixPointTrans *a);
00044 void SvgFixPoint_Transform_Init(SvgFixPointTrans *a);
00045 void SvgFixPoint_Transform_Scale(SvgFixPointTrans *a, const SvgFixPoint scale_factor, const SvgFixPoint x_center, const SvgFixPoint y_center);
00046 void SvgFixPoint_Transform_XY_Scale(SvgFixPointTrans *a, const SvgFixPoint xs, const SvgFixPoint ys, const SvgFixPoint x_center, const SvgFixPoint y_center);
00047 void SvgFixPoint_Transform_Translate(SvgFixPointTrans *a, const SvgFixPoint x_trans, const SvgFixPoint y_trans);
00048 void SvgFixPoint_Transform_Rotate(SvgFixPointTrans *a, const SvgFixPoint angle, const SvgFixPoint x_center, const SvgFixPoint y_center);
00049
00050 #define SvgFixPoint_Scalar_Add(A, B) ((A) + (B))
00051 #define SvgFixPoint_Scalar_Sub(A, B) ((A) - (B))
00052
00053 SvgFixPoint SvgFixPoint_Scalar_Mul(const SvgFixPoint a, const SvgFixPoint b);
00054 void SvgFixPoint_Scalar_Print(SvgFixPoint a);
00055
00057 #endif
00058
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgGzFileWrapper.cpp File Reference

AddOns/Svg/SvgGzFileWrapper.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include <Auxiliary/RamData.hpp>
#include "SvgGzFileWrapper.hpp"

Include dependency graph for SvgGzFileWrapper.cpp:

Defines

#define | SVG_GZ_FLAGS_COMMENT 0x10
#define | SVG_GZ_FLAGS_CRC16 0x02
#define | SVG_GZ_FLAGS_EXTRA 0x04
#define | SVG_GZ_FLAGS_ORIG_NAME 0x08
#define | SVG_GZ_MAGIC_1 0x1F
#define | SVG_GZ_MAGIC_2 0x8B
#define | SVG_GZ_MINIMAL_HEADER_LENGTH 4
#define | SVG_GZ_RESERVED 0xE0
#define | SVG_GZ_Z_DEFLATED 0x08

Define Documentation

#define SVG_GZ_FLAGS_COMMENT 0x10

#define SVG_GZ_FLAGS_CRC16 0x02

#define SVG_GZ_FLAGS_EXTRA 0x04

#define SVG_GZ_FLAGS_ORIG_NAME 0x08

#define SVG_GZ_MAGIC_1 0x1F

#define SVG_GZ_MAGIC_2 0x8B

#define SVG_GZ_MINIMAL_HEADER_LENGTH 4

#define SVG_GZ_RESERVED 0xE0

#define SVG_GZ_Z_DEFLATED 0x08

Generated on Tue Jan 24 16:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgGzFileWrapper.hpp File Reference

AddOns/Svg/SvgGzFileWrapper.hpp File Reference

#include <AddOns/zlib/zutil.h>
#include "SvgIoWrapper.hpp"

Include dependency graph for SvgGzFileWrapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SvgGzFileWrapper

Defines

#define | Apoxi_SvgGZFileWrapper_hpp
#define | SVG_GZ_INPUT_BUFFER_SIZE 1024

Define Documentation

#define Apoxi_SvgGZFileWrapper_hpp

Generated on Tue Jan 24 16:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgGzFileWrapper.hpp Source File

AddOns/Svg/SvgGzFileWrapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgGZFileWrapper_hpp)
00011 #define Apoxi_SvgGZFileWrapper_hpp
00015
00016 #include <AddOns/zlib/zutil.h>
00017
00018 #include "SvgIoWrapper.hpp"
00019
00020
00026 #define SVG_GZ_INPUT_BUFFER_SIZE 1024
00027
00028
00029 class BinData;
00030
00032 class SvgGzFileWrapper : public SvgIoWrapper
00033 {
00034     public:
00036         SvgGzFileWrapper();
00038         SvgGzFileWrapper(UINT8 *p_buffer, UINT32 buffer_length, BOOLEAN *p_success, BOOLEAN release_ramdata = FALSE);
00040         SvgGzFileWrapper(BinData *p_bin_data, BOOLEAN *p_success, BOOLEAN release_ramdata = FALSE);
00042         virtual ~SvgGzFileWrapper();
00044         virtual UINT32 Read(UINT8 *p_dst_buffer, UINT32 bytes_wanted);
00046         static BOOLEAN HasValidGzHeader(UINT8 *p_buffer, INT32 buffer_length);
00048         static BOOLEAN HasValidGzHeader(BinData *p_bin_data);
00049
00050     private:
00051         BOOLEAN InitializeGzStream();
00052
00053         BinData *m_bin_data;
00054         UINT32 m_buffer_offset;
00055         BOOLEAN m_release_ramdata;
00056         z_stream m_z_stream;
00057         void *m_input_buffer;
00058
00059         // static callbacks that zlib needs
00060         static void* Callback_Malloc(void *p_userdata, unsigned int num, unsigned int size);
00061         static void  Callback_Free(void *p_userdata, void *p_memory);
00062 };
00064 #endif
00065
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgImage.cpp File Reference

AddOns/Svg/SvgImage.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include <Auxiliary/BinData.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/BitmapDc.hpp>
#include <Devices/Device.hpp>
#include <Config/DisplayConfig.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/AppContainer.hpp>
#include "SvgImage.hpp"
#include "SvgDecoder.hpp"

Include dependency graph for SvgImage.cpp:

Defines

#define | SVG_ABS(a) (((a) > 0) ? (a) : -(a))
#define | SVG_IMAGE_FRAMES_PER_SECOND 50
#define | SVG_IMAGE_HEURISTIC_PAUSE 2000

Define Documentation

#define SVG_ABS ( a ) (((a) > 0) ? (a) : -(a))

#define SVG_IMAGE_FRAMES_PER_SECOND 50

#define SVG_IMAGE_HEURISTIC_PAUSE 2000

Generated on Tue Jan 24 16:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgImage.hpp File Reference

AddOns/Svg/SvgImage.hpp File Reference

#include <Gui/Image.hpp>
#include <Auxiliary/BinData.hpp>
#include <Kernel/Allocator.hpp>
#include <AddOns/Svg/SvgFixPoint.hpp>

Include dependency graph for SvgImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SvgImage

Defines

#define | Apoxi_SvgImage_hpp
#define | SVGIMAGE_DEFAULT_HEIGHT 128
#define | SVGIMAGE_DEFAULT_WIDTH 128

Define Documentation

#define Apoxi_SvgImage_hpp

Generated on Tue Jan 24 16:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgImage.hpp Source File

AddOns/Svg/SvgImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgImage_hpp)
00011 #define Apoxi_SvgImage_hpp
00015
00016 #include <Gui/Image.hpp>
00017 #include <Auxiliary/BinData.hpp>
00018 #include <Kernel/Allocator.hpp>
00019 #include <AddOns/Svg/SvgFixPoint.hpp>
00020
00021 #define SVGIMAGE_DEFAULT_WIDTH  128
00022 #define SVGIMAGE_DEFAULT_HEIGHT 128
00023
00024 class SvgDecoder;
00025
00027 class SvgImage : public Image {
00028         typedef Image Base;
00029
00030     public:
00031         enum {
00032             ID = 9
00033         };
00034
00038         SvgImage();
00039
00053         SvgImage(BinData* data, BOOLEAN* p_success = 0);
00054
00057         virtual ~SvgImage();
00058
00062         void Init();
00063
00076         BOOLEAN Init(BinData* data);
00077
00107         BOOLEAN Load(BinData* data);
00108
00110         virtual BOOLEAN Draw(DeviceContext *dc, XYDIM x, XYDIM y,
00111                          INT frame_idx,
00112                          XYDIM scaled_width = -1,
00113                          XYDIM scaled_height = -1,
00114                          const Rect &clip_rect = Rect()) const;
00115
00117         virtual BOOLEAN IsInstanceOf(INT id) const;
00118
00120         virtual INT GetNextFrame(INT frame_idx) const;
00121
00123         virtual UINT32 GetFrameDelay(INT frame_idx) const;
00124
00126         virtual const BinData* GetBinData() const;
00127
00129         virtual BOOLEAN DecodeSynchronously() const;
00130
00132         virtual BOOLEAN IsBufferingAllowed() const;
00133
00141         BOOLEAN Rotate(SvgFixPoint angle, SvgFixPoint x, SvgFixPoint y);
00142
00147         BOOLEAN SetZoomLevel(SvgFixPoint magnification);
00148
00154         BOOLEAN Pan(SvgFixPoint dx, SvgFixPoint dy);
00155
00157         void ResetTransformation();
00158
00166         BOOLEAN ToViewportSpace(SvgFixPoint user_x,
00167                                 SvgFixPoint user_y,
00168                                 XYDIM& viewport_x,
00169                                 XYDIM& viewport_y) const;
00170
00178         BOOLEAN ToUserSpace(XYDIM viewport_x,
00179                             XYDIM viewport_y,
00180                             SvgFixPoint& user_x,
00181                             SvgFixPoint& user_y) const;
00182
00184         BOOLEAN SetViewportSize(XYDIM width, XYDIM height);
00185
00186     protected:
00188         virtual BOOLEAN IsTransparent(void* context) const;
00189
00191         virtual ColorValue GetTransparentColor(void* context) const;
00192
00194         virtual BOOLEAN HasAlphaChannel(void* context) const;
00195
00196     // private: TODO: should be private!
00197         // Variable to track the correct time offset
00198         Ticks m_ticks;
00199         mutable UINT32 m_player_time_offset;
00200         mutable UINT32 m_normalized_time;
00201         mutable INT32 m_delta;
00202
00203         BinData* m_data;
00204         SvgDecoder* m_decoder;
00205         mutable INT m_set_frame_idx;
00206
00207         INT m_frames;
00208         INT8 m_previous_zoom_level;
00209
00210         SvgFixPointTrans m_trans;
00211
00212         mutable Bitmap* m_svg_bitmap;
00213         mutable XYDIM m_svg_width;
00214         mutable XYDIM m_svg_height;
00215         mutable struct {
00216             UINT memory_alloc_failure   : 1;
00217             UINT first_frame            : 1;
00218             UINT is_loading             : 1;
00219         } m_bits;
00220
00221     private:
00222         void InitProperties();
00223         BOOLEAN Load(BinData* data, BOOLEAN blocking);
00224 };
00225
00227 #endif  // Apoxi_SvgImage_hpp
00228
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgImageFileWrapper.cpp File Reference

AddOns/Svg/SvgImageFileWrapper.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include <Gui/Image.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <AddOns/MultiMedia/PngImage.hpp>
#include <AddOns/MultiMedia/GifImage.hpp>
#include <AddOns/MultiMedia/WbmpImage.hpp>
#include "SvgImage.hpp"
#include "SvgImageFileWrapper.hpp"
#include "SvgMimeUtil.hpp"
#include "zpchar8utilh.h"

Include dependency graph for SvgImageFileWrapper.cpp:

Generated on Tue Jan 24 16:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgImageFileWrapper.hpp File Reference

AddOns/Svg/SvgImageFileWrapper.hpp File Reference

#include "SvgIoWrapper.hpp"

Include dependency graph for SvgImageFileWrapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SvgImageFileWrapper

Defines

#define | Apoxi_SvgImageFileWrapper_hpp

Define Documentation

#define Apoxi_SvgImageFileWrapper_hpp

Generated on Tue Jan 24 16:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgImageFileWrapper.hpp Source File

AddOns/Svg/SvgImageFileWrapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgImageFileWrapper_hpp)
00011 #define Apoxi_SvgImageFileWrapper_hpp
00015
00016 #include "SvgIoWrapper.hpp"
00017
00018 class Image;
00020 class SvgImageFileWrapper : public SvgIoWrapper
00021 {
00022     public:
00024         SvgImageFileWrapper(UINT8 *p_img_data, UINT32 img_data_length, UINT8 content_type, BOOLEAN *success);
00026         virtual ~SvgImageFileWrapper();
00028         virtual UINT32 Read(UINT8 *p_dst_buffer, UINT32 bytes_wanted);
00030     Image* GetImage() const;
00031
00032     XYDIM GetWidth() const;
00033     XYDIM GetHeight() const;
00034
00035     private:
00036         Image *m_img;
00037         void *m_decoded_data;
00038         XYDIM m_width, m_height;
00039
00040         void ReSizeImage();
00041     INT32 Sqrt(INT32 n) const;
00042 };
00044 #endif
00045
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgIoWrapper.cpp File Reference

AddOns/Svg/SvgIoWrapper.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include "SvgIoWrapper.hpp"

Include dependency graph for SvgIoWrapper.cpp:

Generated on Tue Jan 24 16:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgIoWrapper.hpp File Reference

AddOns/Svg/SvgIoWrapper.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SvgIoWrapper

Defines

#define | Apoxi_SvgIOWrapper_hpp

Define Documentation

#define Apoxi_SvgIOWrapper_hpp

Generated on Tue Jan 24 16:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgIoWrapper.hpp Source File

AddOns/Svg/SvgIoWrapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgIOWrapper_hpp)
00011 #define Apoxi_SvgIOWrapper_hpp
00015
00016 class SvgIoWrapper
00017 {
00018     public:
00019         virtual ~SvgIoWrapper();
00020
00021         virtual UINT32 Read(UINT8 *p_dst_buffer, UINT32 bytes_wanted) = 0;
00022 };
00024 #endif
00025
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgMimeUtil.cpp File Reference

AddOns/Svg/SvgMimeUtil.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include <stdarg.h>
#include <Auxiliary/WStrUtil.hpp>
#include "SvgMimeUtil.hpp"

Include dependency graph for SvgMimeUtil.cpp:

Generated on Tue Jan 24 16:46:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgMimeUtil.hpp File Reference

AddOns/Svg/SvgMimeUtil.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SvgMimeUtil

Defines

#define | Apoxi_SvgPlayerMIMEUtil_hpp
#define | SVG_MIME_CONTENT_TYPE_IMAGE 0x80
#define | SVG_MIME_CONTENT_TYPE_IMAGE_GIF 0x83
#define | SVG_MIME_CONTENT_TYPE_IMAGE_JPEG 0x81
#define | SVG_MIME_CONTENT_TYPE_IMAGE_PNG 0x82
#define | SVG_MIME_CONTENT_TYPE_IMAGE_SVG 0x85
#define | SVG_MIME_CONTENT_TYPE_IMAGE_WBMP 0x84
#define | SVG_MIME_CONTENT_TYPE_IS_IMAGE(CT) ((CT) & SVG_MIME_CONTENT_TYPE_IMAGE)
#define | SVG_MIME_CONTENT_TYPE_NA 0

Define Documentation

#define Apoxi_SvgPlayerMIMEUtil_hpp

Generated on Tue Jan 24 16:46:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgMimeUtil.hpp Source File

AddOns/Svg/SvgMimeUtil.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgPlayerMIMEUtil_hpp)
00011 #define Apoxi_SvgPlayerMIMEUtil_hpp
00015
00016 #define SVG_MIME_CONTENT_TYPE_NA         0
00017
00018 // MIME types for images must have bit 7 set (0x80)
00019 #define SVG_MIME_CONTENT_TYPE_IMAGE      0x80
00020 #define SVG_MIME_CONTENT_TYPE_IMAGE_JPEG 0x81
00021 #define SVG_MIME_CONTENT_TYPE_IMAGE_PNG  0x82
00022 #define SVG_MIME_CONTENT_TYPE_IMAGE_GIF  0x83
00023 #define SVG_MIME_CONTENT_TYPE_IMAGE_WBMP 0x84
00024 #define SVG_MIME_CONTENT_TYPE_IMAGE_SVG  0x85
00025
00026 #define SVG_MIME_CONTENT_TYPE_IS_IMAGE(CT) ((CT) & SVG_MIME_CONTENT_TYPE_IMAGE)
00027
00028 class SvgMimeUtil
00029 {
00030   public:
00031     static UINT8 GetMimeContentType(const UINT8 *p_mime);
00032   private:
00033     static BOOLEAN StrCmp(const UINT8 *a, const UINT8 *b, UINT16 len);
00034     static UINT16 StrLen(const UINT8 *a, UINT16 max_length);
00035 };
00037 #endif
00038
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgPlayer.cpp File Reference

AddOns/Svg/SvgPlayer.cpp File Reference

#include <AddOns/Svg/PreComp.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/Image.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/NativeImage.hpp>
#include <Gui/BitmapDc.hpp>
#include <Gui/Window.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/AppContainer.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Kernel/Threadlet.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <stdlib.h>
#include "SvgPlayer.hpp"
#include "SvgDecoder.hpp"
#include "MsgTypes.hpp"

Include dependency graph for SvgPlayer.cpp:

Generated on Tue Jan 24 16:46:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgPlayer.hpp File Reference

AddOns/Svg/SvgPlayer.hpp File Reference

#include <Auxiliary/TriggerTimer.hpp>
#include <Kernel/Threadlet.hpp>
#include <Gui/DrawableObject.hpp>
#include "SvgFixPoint.hpp"
#include "SvgDebug.hpp"

Include dependency graph for SvgPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SvgPlayer

Defines

#define | Apoxi_SvgPlayer_hpp

Define Documentation

#define Apoxi_SvgPlayer_hpp

Generated on Tue Jan 24 16:46:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Svg/SvgPlayer.hpp Source File

AddOns/Svg/SvgPlayer.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SvgPlayer_hpp)
00011 #define Apoxi_SvgPlayer_hpp
00015
00016 #include <Auxiliary/TriggerTimer.hpp>
00017 #include <Kernel/Threadlet.hpp>
00018 #include <Gui/DrawableObject.hpp>
00019
00020 #include "SvgFixPoint.hpp"
00021
00022 #include "SvgDebug.hpp"
00023
00024 class SvgDecoder;
00025 class BinData;
00026 class Bitmap;
00027 class SvgPlayer;
00028
00029 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00030
00034 class SvgThreadlet : public Threadlet {
00035     typedef Threadlet Base;
00036
00037     public:
00038         virtual ~SvgThreadlet();
00039
00042         static SvgThreadlet* CreateInstance(SvgPlayer* player);
00043
00045         virtual void ReleaseInstance();
00046
00048         virtual INT Fn();
00049
00050     private:
00051         SvgThreadlet(SvgPlayer* player);
00052         SvgPlayer *m_player;
00053 };
00054 #endif // DOXYGEN_SHOULD_SKIP_THIS
00055
00058 class SvgPlayer : public DrawableObject {
00059     typedef DrawableObject Base;
00060
00061     public:
00062         /* The types of events that the player supports, note:
00063             * this list is still very much draft. */
00064         typedef enum {
00065             SvgFocusInEvent = 1,
00066             SvgFocusOutEvent,
00067             SvgUiActivateEvent,
00068             SvgActivateEvent,
00069             SvgClickEvent,
00070             SvgSelectPreviousHyperlinkEvent,
00071             SvgSelectNextHyperlinkEvent,
00072             SvgShowHyperlinksEvent,
00073             SvgHideHyperlinksEvent,
00074             SvgUndefinedEvent
00075         } SvgEventType;
00076
00077         /* Error codes that the SvgPlayer can generate */
00078         typedef enum {
00079             NoError = 0,
00080             OutOfMemoryError,
00081             InitializationError,
00082             AllocationError,
00083             AnimationLoadFailureError,
00084             SizeNotSetInDocument,
00085             IllegalZoomLevel,
00086             AlreadySet,
00087             UnspecifiedError,
00088             DecodingInterruptedError,
00089             SvgStatusEventHandled = 1
00090         } SvgErrorType;
00091
00095         SvgPlayer();
00096
00101         SvgPlayer(Control* parent);
00102
00115         SvgPlayer(Control* parent, BinData* p_bindata);
00116
00118         virtual ~SvgPlayer(void);
00119
00124         void Init(Control* parent);
00125
00138         BOOLEAN Init(Control* parent, BinData* data);
00139
00168         BOOLEAN Load(BinData* data);
00169
00174         void Play(UINT32 time = 0);
00175
00178         void Stop();
00179
00181         void Restart();
00182
00185         void SetTimePosition(UINT32 time = 0);
00186
00190         UINT32 GetTimePosition(void) const { return m_player_time_offset; };
00191
00196         BOOLEAN Rotate(INT16 angle);
00197
00202         BOOLEAN SetZoomLevel(INT8 level);
00203
00209         BOOLEAN Pan(XYDIM dx, XYDIM dy);
00210
00213         WCHAR *GetDocumentTitle(void);
00214
00217         WCHAR *GetDocumentDescription(void);
00218
00221         WCHAR *GetPlayerName(void);
00222
00225         WCHAR *GetPlayerVersion(void);
00226
00230         void SetEvent(SvgEventType event);
00231
00233         virtual XYDIM GetDefaultWidth(void) const;
00234
00236         virtual XYDIM GetDefaultHeight(void) const;
00237
00240         void SetWidth(XYDIM width);
00241
00244         void SetHeight(XYDIM height);
00245
00246         XYDIM GetWidth() const;
00247         XYDIM GetHeight() const;
00248
00249         void SetBaseURL(WCHAR *url);
00250
00251         BOOLEAN IsDocumentZoomable(void) const;
00252         BOOLEAN IsDocumentPanable(void) const;
00253
00257         SvgErrorType GetErrorCode (void) const { return m_error_code; };
00258
00260         BOOLEAN IsDecodingFinished() const { return (BOOLEAN)m_bits.finished_decoding; }
00261
00263         BOOLEAN IsDecoding() const { return (BOOLEAN)m_bits.is_decoding; }
00264
00265     protected:
00267         virtual BOOLEAN OnMessage(const Message& msg);
00268
00270         virtual void Cleanup();
00271
00272     private:
00273         enum {
00274             SvgStopped   = 0,
00275             SvgAutoStart = 1,
00276             SvgRunning   = 2,
00277             Finished     = 3
00278         };
00279
00283         void WaitUntilDecodingIsFinished() { WaitForDecoding(TRUE); }
00284
00285         void WaitForDecoding(BOOLEAN wait_until_finished);
00286
00287         void InitProperties();
00288
00289         void SetErrorCode(SvgErrorType error_code) { m_error_code = error_code; };
00290
00291         BOOLEAN IsInitialized() const { return (BOOLEAN)m_bits.initialized; };
00292
00293         void StartDecoding();
00294
00295         WCHAR* GetMetaDataString(UINT16 key);
00296
00297         void Halt();
00298
00299         void OnTimer();
00300
00301         void Render();
00302
00303         BOOLEAN Load(BinData* data, BOOLEAN blocking);
00304
00305         struct {
00306             UINT op_event_set      : 1;
00307             UINT finished_decoding : 1;
00308             UINT is_decoding       : 1;
00309             UINT stop_decoding     : 1;
00310             UINT initialized       : 1;
00311             UINT state             : 2;
00312             UINT first_frame       : 1;
00313             UINT subscribed        : 1;
00314         } m_bits;
00315
00316         SvgErrorType m_error_code;
00317
00318         BinData *m_bindata;
00319         Bitmap *m_bitmap;
00320
00321         SvgDecoder *m_decoder;
00322         Application *m_app;
00323
00324         SvgFixPointTrans m_trans;
00325         SvgFixPointTrans m_th_trans;
00326
00327         Ticks m_ticks;
00328         UINT32 m_player_time_offset;
00329         UINT32 m_user_time_offset;
00330         UINT32 m_normalized_time;
00331         INT32 m_delta;
00332
00333         XYDIM m_width, m_height;
00334         XYDIM m_new_width, m_new_height;
00335
00336         WCHAR *m_url;
00337
00338         /* Event handling */
00339         SvgEventType m_event_input;
00340         SvgEventType m_th_event_input;
00341
00342         INT8 m_previous_zoom_level;
00343
00344         /* Animation handling */
00345         TriggerTimer<SvgPlayer> m_anim_timer;
00346
00347         /* synchronization */
00348         Mutex m_paint_mutex;
00349
00350         /* Friends of this class */
00351         friend class TriggerTimer<SvgPlayer>;
00352         friend class SvgPlayerView;
00353         friend class SvgThreadlet;
00354         friend class LoadingFinishedCondition;
00355 };
00356
00357 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00358
00362 class SvgPlayerView : public DrawableObjectView {
00363     typedef DrawableObjectView Base;
00364
00365     public:
00366         virtual ~SvgPlayerView();
00367
00368     private:
00369         virtual void Draw(const Component& component,
00370                           DeviceContext* dc,
00371                           const Rect& repaint_rect) const;
00372
00373         void StartAnimTimer(SvgPlayer& svg_player, const Ticks& ticks) const;
00374 };
00375 #endif
00376
00378 #endif
00379
Generated on Tue Jan 24 14:45:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/DBService.hpp File Reference

AddOns/SyncML/DBService.hpp File Reference

#include <AddOns/Services/Service.hpp>

Include dependency graph for DBService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DBService
class | DBService::DBItemIterator
struct | SyncMLCTCap
struct | SyncMLCTParam
struct | SyncMLCTProp
struct | SyncMLCTTypeVerCT
struct | SyncMLCTValueDef
struct | SyncMLDataStoreProps
struct | SyncMLDynamicProps
struct | SyncMLItemMetaInfo

Defines

#define | _MSVC_CONST_FLAW const
#define | Apoxi_DBService_hpp

Enumerations

enum SyncMLSyncType {
TwoWaySync = 1, SlowTwoWaySync = 2, OneWaySyncFromClient = 3, RefreshSyncFromClient = 4,
OneWaySyncFromServer = 5, RefreshSyncFromServer = 6, ServerAlertedSync = 7
}

Define Documentation

#define _MSVC_CONST_FLAW const

#define Apoxi_DBService_hpp

Enumeration Type Documentation

enum SyncMLSyncType

Enumeration of the types of the supported synchronizations. Corresponds to the table of supported synchronizations in the SyncType element definition of the SyncML Device Information DTD.

Enumerator:
TwoWaySync | Two-way sync.
SlowTwoWaySync | Slow two-way sync.
OneWaySyncFromClient | One-way sync from client only.
RefreshSyncFromClient | Refresh sync from client only.
OneWaySyncFromServer | One-way sync from server only.
RefreshSyncFromServer | Refresh sync from server only.
ServerAlertedSync | Server alerted sync.

Generated on Tue Jan 24 16:46:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/DBService.hpp Source File

AddOns/SyncML/DBService.hpp

Go to the documentation of this file.
00001 /*----------------------------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DBService_hpp)
00011 #define Apoxi_DBService_hpp
00012
00013 #include <AddOns/Services/Service.hpp>
00014
00015 /* =============================================================================================
00016     Item meta information
00017    ============================================================================================= */
00018
00019 /* ---------------------------------------------------------------------------------------------
00020     SyncMLItemMetaInfo
00021    --------------------------------------------------------------------------------------------- */
00022
00025 struct SyncMLItemMetaInfo {
00029     UINT32         m_size;
00035     String         m_format;
00039     String         m_type;
00045     String         m_mark;
00049     String         m_version;
00050 };
00051
00052
00053 /* ---------------------------------------------------------------------------------------------
00054     SyncMLDynamicDBCharacteristics
00055    --------------------------------------------------------------------------------------------- */
00056
00058 struct SyncMLDynamicProps {
00059
00063     UINT32         m_free_id;
00066     UINT32         m_free_mem;
00067
00068 };
00069
00070 /* =============================================================================================
00071     Data store properties
00072    ============================================================================================= */
00073
00074 /* MS VC6++ is not able to successfully compile the constant structures, therefore the
00075    local define _MSVC_CONST_FLAW is necessary, which removes the const. */
00076
00077 #if defined(APOXI_COMPILER_MSVC)
00078     #define _MSVC_CONST_FLAW
00079 #else
00080     #define _MSVC_CONST_FLAW const
00081 #endif
00082
00086 enum SyncMLSyncType
00087 {
00089     TwoWaySync = 1,
00091     SlowTwoWaySync = 2,
00093     OneWaySyncFromClient = 3,
00095     RefreshSyncFromClient = 4,
00097     OneWaySyncFromServer = 5,
00099     RefreshSyncFromServer = 6,
00101     ServerAlertedSync = 7
00102 };
00103
00104
00105 /* ---------------------------------------------------------------------------------------------
00106     SyncMLCTTypeVer
00107    --------------------------------------------------------------------------------------------- */
00108
00110 struct SyncMLCTTypeVerCT {
00111
00114     const CHAR*    m_ct_type;
00117     const CHAR*    m_ver_ct;
00118 };
00119
00120
00121 /* ---------------------------------------------------------------------------------------------
00122     SyncMLCTValueDef
00123    --------------------------------------------------------------------------------------------- */
00124
00127 struct SyncMLCTValueDef {
00128
00131     const CHAR*    m_val_enum;
00134     const CHAR*    m_data_type;
00137     UINT32         m_size;
00140     const CHAR*    m_display_name;
00141 };
00142
00143
00144 /* ---------------------------------------------------------------------------------------------
00145     SyncMLCTParam
00146    --------------------------------------------------------------------------------------------- */
00147
00150 struct SyncMLCTParam {
00151
00154     const CHAR*              m_param_name;
00156     const SyncMLCTValueDef*  _MSVC_CONST_FLAW  m_value_def;
00158     UINT32                   m_value_def_count;
00159 };
00160
00161
00162 /* ---------------------------------------------------------------------------------------------
00163     SyncMLCTProp
00164    --------------------------------------------------------------------------------------------- */
00165
00167 struct SyncMLCTProp {
00168
00171     const CHAR*              m_prop_name;
00173     const SyncMLCTValueDef*  _MSVC_CONST_FLAW  m_value_def;
00175     UINT32                   m_value_def_count;
00177     const SyncMLCTParam*     _MSVC_CONST_FLAW  m_param;
00179     UINT32                   m_param_count;
00180
00181 };
00182
00183
00184 /* ---------------------------------------------------------------------------------------------
00185     SyncMLCTCap
00186    --------------------------------------------------------------------------------------------- */
00187
00190 struct SyncMLCTCap {
00191
00194     const CHAR*              m_ct_type;
00196     const SyncMLCTProp*      _MSVC_CONST_FLAW  m_prop;
00198     UINT32                   m_prop_count;
00199
00200 };
00201
00202 /* ---------------------------------------------------------------------------------------------
00203     SyncMLDataStoreProps
00204    --------------------------------------------------------------------------------------------- */
00205
00208 struct SyncMLDataStoreProps {
00209
00213     const CHAR*              m_source_ref;
00217     const CHAR*              m_display_name;
00221     UINT16                   m_max_guid_size;
00225     const SyncMLCTTypeVerCT* _MSVC_CONST_FLAW m_rx_pref;
00230     const SyncMLCTTypeVerCT* _MSVC_CONST_FLAW  m_rx;
00232     UINT16                   m_rx_count;
00236     const SyncMLCTTypeVerCT* _MSVC_CONST_FLAW m_tx_pref;
00241     const SyncMLCTTypeVerCT* _MSVC_CONST_FLAW  m_tx;
00243     UINT16                   m_tx_count;
00244
00249     const SyncMLSyncType* _MSVC_CONST_FLAW     m_sync_cap;
00251     UINT16                   m_sync_type_count;
00252
00255     BOOLEAN                  m_shared_mem;
00259     UINT32                   m_max_mem;
00263     UINT32                   m_max_id;
00266     BOOLEAN                  m_support_large_objects;
00267
00269     const SyncMLCTCap* _MSVC_CONST_FLAW        m_ct_cap;
00271     UINT32                   m_ct_cap_count;
00272 };
00273
00274 #undef _MSVC_CONST_FLAW
00275
00276 /* =============================================================================================
00277     DBService
00278    ============================================================================================= */
00279
00285 class DBService : public Service {
00286     typedef Service Base;
00287
00288 protected:
00289
00290     // Constructor
00291     DBService(const Guid &guid) : Service(guid) {}
00292
00293 public:
00294
00295     // Necessary forward declarations -------------------------------------------------------------
00296
00297     class DBItemIterator;
00298
00299     // Open, close --------------------------------------------------------------------------------
00300
00303     virtual BOOLEAN OpenDatabase() = 0;
00304
00307     virtual BOOLEAN CloseDatabase() = 0;
00308
00309
00310     // Making changes -----------------------------------------------------------------------------
00311
00320     virtual UINT16 AddItem(UINT32 &item_id, const void* item_data, UINT32 item_data_length, const SyncMLItemMetaInfo &item_meta_info) = 0;
00321
00326     virtual UINT16 DeleteItem(const UINT32 item_id) = 0;
00327
00335     virtual UINT16 UpdateItem(const UINT32 item_id, const void* item_data, UINT32 item_data_length, const SyncMLItemMetaInfo &item_meta_info) = 0;
00336
00344     virtual UINT16 CopyItem(const UINT32 item_id, const UINT16 target_location, UINT32 &copy_item_id) = 0;
00345
00346
00347     // Retrieving item information ----------------------------------------------------------------
00348
00359     virtual BOOLEAN GetItemData(const UINT32 item_id, void* item_data, UINT32 &item_data_length, SyncMLItemMetaInfo *item_meta_info = 0) = 0;
00360
00366     virtual BOOLEAN GetItemMetaInfo(const UINT32 item_id, SyncMLItemMetaInfo &item_meta_info) = 0;
00367
00368
00369     // Accessing the whole datastore --------------------------------------------------------------
00370
00374     virtual DBItemIterator* GetAllItems() = 0;
00375
00378     virtual BOOLEAN ClearDatabase() = 0;
00379
00380
00381     // Searching and filtering --------------------------------------------------------------------
00382
00388     virtual DBItemIterator* SearchDataItems(const String &search_grammar, const String &search_query) = 0;
00389
00390
00391     // Locking and unlocking ----------------------------------------------------------------------
00392
00395     virtual BOOLEAN LockDataStore() = 0;
00396
00399     virtual BOOLEAN UnlockDataStore() = 0;
00400
00401
00402     // Transactions -------------------------------------------------------------------------------
00403
00406     virtual BOOLEAN StartTransaction() = 0;
00407
00410     virtual BOOLEAN CommitTransaction() = 0;
00411
00414     virtual BOOLEAN Rollback() = 0;
00415
00416
00417     // Device information -------------------------------------------------------------------------
00418
00421     virtual const SyncMLDataStoreProps* GetStaticProperties() = 0;
00422
00426     virtual BOOLEAN GetDynamicProperties(SyncMLDynamicProps &dynamic_props) = 0;
00427
00428
00429     // Iterator -----------------------------------------------------------------------------------
00430
00432     class DBItemIterator {
00433
00434     public:
00435
00438         virtual BOOLEAN Release() = 0;
00439
00442         virtual BOOLEAN HasNext() = 0;
00443
00455         virtual BOOLEAN GetNextItem(UINT32 &item_id, void* item_data, UINT32 &item_data_length, SyncMLItemMetaInfo *item_meta_info = 0) = 0;
00456
00463         virtual BOOLEAN GetNextItemMetaInfo(UINT32 &item_id, SyncMLItemMetaInfo &item_meta_info) = 0;
00464
00465     };
00466 };
00467
00468 #endif // Apoxi_DBService_hpp
00469
00470
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/MsgTypes.cpp File Reference

AddOns/SyncML/MsgTypes.cpp File Reference

#include "SyncMLPreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/MsgTypes.hpp File Reference

AddOns/SyncML/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <AddOns/SyncML/SyncMLManager.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DBItemChangedMsg

Defines

#define | SyncML_MsgTypes_hpp

Define Documentation

#define SyncML_MsgTypes_hpp

Generated on Tue Jan 24 14:56:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/MsgTypes.hpp Source File

AddOns/SyncML/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\koglerm_snap_host\lnz_development\src\Apoxi\AddOns\SyncML\MsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(SyncML_MsgTypes_hpp)
00016 #define SyncML_MsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <AddOns/SyncML/SyncMLManager.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class DBItemChangedMsg
00028     ====================================================================== */
00029
00031 class DBItemChangedMsg : public ContextMsg {
00032     public:
00033         DBItemChangedMsg(ExecutionContext* context, UINT16 db_uri, UINT32 item_uri, const DateTime& time_stamp, const SyncMLChangeType& opcode);
00034         virtual ~DBItemChangedMsg();
00035
00036         virtual const MsgMetaData& GetMetaData() const;
00037         UINT16 GetDbUri() const { return m_db_uri; }
00038         UINT32 GetItemUri() const { return m_item_uri; }
00039         const DateTime& GetTimeStamp() const { return m_time_stamp; }
00040         const SyncMLChangeType& GetOpcode() const { return m_opcode; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 4100
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         UINT16 m_db_uri;
00050         UINT32 m_item_uri;
00051         DateTime m_time_stamp;
00052         SyncMLChangeType m_opcode;
00053
00054     };
00055
00056 #endif // SyncML_MsgTypes_hpp
00057
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/SyncMLManager.cpp File Reference

AddOns/SyncML/SyncMLManager.cpp File Reference

#include "SyncMLPreComp.hpp"
#include "SyncMLManager.hpp"
#include "MsgTypes.hpp"

Include dependency graph for SyncMLManager.cpp:

Generated on Tue Jan 24 16:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/SyncMLManager.hpp File Reference

AddOns/SyncML/SyncMLManager.hpp File Reference

#include <Config/SyncMLConfig.hpp>
#include <AddOns/Services/Service.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include "DBService.hpp"

Include dependency graph for SyncMLManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SyncMLManager
struct | SyncMLManager::DbGuidItem

Defines

#define | Apoxi_SyncMLManager_hpp
#define | SYNCML_DATABASE_MAX 15

Enumerations

enum | SyncMLChangeType { SyncMLItemAdded, SyncMLItemDeleted, SyncMLItemModified, SyncMLItemDeletedAll }

Variables

const INT | c_syncml_database_max = SYNCML_DATABASE_MAX

Define Documentation

#define Apoxi_SyncMLManager_hpp

#define SYNCML_DATABASE_MAX 15

Enumeration Type Documentation

enum SyncMLChangeType

Defines an enumeration for possible changes of items.

Enumerator:
SyncMLItemAdded | This operation code is used when a new item is added to the data store.
SyncMLItemDeleted | This operation code is used when an item is deleted from the data store.
SyncMLItemModified | This operation code is used when an item is modify in the data store.
SyncMLItemDeletedAll | This operation code is used when all items are deleted from the data store.

Variable Documentation

const INT c_syncml_database_max = SYNCML_DATABASE_MAX

Generated on Tue Jan 24 16:46:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/SyncMLManager.hpp Source File

AddOns/SyncML/SyncMLManager.hpp

Go to the documentation of this file.
00001 /*----------------------------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted withOut prior written authorisation.
00008 ------------------------------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SyncMLManager_hpp)
00011 #define Apoxi_SyncMLManager_hpp
00012
00013 #include <Config/SyncMLConfig.hpp>
00014
00015 #include <AddOns/Services/Service.hpp>
00016 #include <AddOns/Services/ServiceBroker.hpp>
00017
00018 #include "DBService.hpp"
00019
00020 #if !defined(SYNCML_DATABASE_MAX)
00021     #define SYNCML_DATABASE_MAX 15
00022 #endif
00023
00024 const INT c_syncml_database_max = SYNCML_DATABASE_MAX;
00025
00026 /* ---------------------------------------------------------------------------------------------
00027     SyncMLChangeType
00028    --------------------------------------------------------------------------------------------- */
00029
00031 enum SyncMLChangeType {
00032
00034     SyncMLItemAdded,
00036     SyncMLItemDeleted,
00038     SyncMLItemModified,
00040     SyncMLItemDeletedAll
00041 };
00042
00043 /* ---------------------------------------------------------------------------------------------
00044     SyncMLManager
00045    --------------------------------------------------------------------------------------------- */
00046
00058 class SyncMLManager
00059 {
00060 public:
00061
00063     ~SyncMLManager();
00064
00068     static SyncMLManager& GetInstance();
00069
00070     // Registration of data stores and SyncML application -----------------------------------------
00071
00079     BOOLEAN RegisterDataStore(const Guid &db_guid, UINT16 db_uri_id, const String &db_uri_string);
00080
00084     const Guid& GetServiceGuid(UINT16 db_uri) const;
00085
00089     DBService* GetDBServiceFromURI(UINT16 db_uri) const;
00090
00095     String GetDataStoreUri(UINT16 db_uri) const;
00096
00100     UINT16 GetDataStoreUri(const String& db_uri) const;
00101
00104     UINT16 GetNumOfDataStores() const;
00105
00112     BOOLEAN GetRegisteredDataStore(UINT16 idx, Guid &db_guid, UINT16 &db_uri_id, String &db_uri_string) const;
00113
00117     BOOLEAN RegisterSyncMLApplication(Application* syncml_app);
00118
00119     // Posting of change messages -----------------------------------------------------------------
00120
00129     BOOLEAN PostItemChangedMsg(UINT16 db_uri, UINT32 item_uri, const DateTime &time_stamp, SyncMLChangeType change_code) const;
00130
00131     // Retrieving device information --------------------------------------------------------------
00132
00136     BOOLEAN GetDeviceInfo(SyncMLDeviceInfo &device_info) const;
00137
00138     // private part -------------------------------------------------------------------------------
00139
00140 private:
00141
00143     struct DbGuidItem {
00144         Guid    m_datastore_guid;
00145         UINT16  m_datastore_id_uri;
00146         String  m_datastore_string_uri;
00147     };
00148
00150     SyncMLManager();
00151
00153     SyncMLManager(const SyncMLManager& obj);
00154
00156     void Init();
00157
00159     DbGuidItem  m_db_guid_tab[c_syncml_database_max];
00160
00162     UINT16 m_db_guid_tab_size;
00163
00165     Application *m_syncml_app;
00166
00168     static SyncMLManager m_instance;
00169
00171     static BOOLEAN m_is_initialized;
00172 };
00173
00174
00175 #endif    // Apoxi_SyncMLManager_hpp
00176
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/SyncMLPreComp.cpp File Reference

AddOns/SyncML/SyncMLPreComp.cpp File Reference

#include "SyncMLPreComp.hpp"

Include dependency graph for SyncMLPreComp.cpp:

Generated on Tue Jan 24 16:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/SyncMLPreComp.hpp File Reference

AddOns/SyncML/SyncMLPreComp.hpp File Reference

#include <Kernel/Lib.hpp>

Include dependency graph for SyncMLPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:46:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/SyncML/SyncMLPreComp.hpp Source File

AddOns/SyncML/SyncMLPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/ChineseT9InputMapper.cpp File Reference

AddOns/T9/ChineseT9InputMapper.cpp File Reference

#include "PreComp.hpp"
#include "ChineseT9InputMapper.hpp"
#include <Kernel/System.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for ChineseT9InputMapper.cpp:

Generated on Tue Jan 24 16:47:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/ChineseT9InputMapper.hpp File Reference

AddOns/T9/ChineseT9InputMapper.hpp File Reference

#include "EnglishT9InputMapper.hpp"
#include <AddOns/T9/ChineseT9Wrapper.hpp>

Include dependency graph for ChineseT9InputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ChineseT9InputMapper

Defines

#define | Apoxi_ChineseT9InputMapper_hpp

Define Documentation

#define Apoxi_ChineseT9InputMapper_hpp

Generated on Tue Jan 24 16:47:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/ChineseT9InputMapper.hpp Source File

AddOns/T9/ChineseT9InputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ChineseT9InputMapper_hpp)
00011 #define Apoxi_ChineseT9InputMapper_hpp
00012
00013 #include "EnglishT9InputMapper.hpp"
00014 #include <AddOns/T9/ChineseT9Wrapper.hpp>
00015
00016
00025 class ChineseT9InputMapper : public EnglishT9InputMapper {
00026     typedef EnglishT9InputMapper Base;
00027
00028     public:
00030         ChineseT9InputMapper(AbstractEditor *editor = 0);
00031
00033         virtual ~ChineseT9InputMapper();
00034
00035
00037         virtual const WCHAR* GetStatusInfo() const;
00038
00040         virtual const WCHAR* GetPhonetics(INT *selected_index = 0) const;
00041
00043         virtual const WCHAR* GetStrokes() const;
00044
00046         virtual const WCHAR* GetSelection() const;
00047
00048         virtual INT GetSelectedIndex() const;
00049
00051         virtual BOOLEAN SetMode(PredMode mode);
00052
00054         virtual PredMode GetMode() const;
00055
00057         virtual BOOLEAN IsModeSupported(PredMode mode);
00058
00060         virtual InputMapper::Alphabet GetAlphabet() const;
00061
00062     protected:
00064         virtual BOOLEAN OnShortKeyUp_T9(KeyCode apoxi_key_code);
00065
00067         virtual BOOLEAN OnLongKeyPress_T9(KeyCode apoxi_key_code);
00068
00070         virtual T9Wrapper* GetT9Wrapper();
00071
00073         virtual const T9Wrapper* GetT9Wrapper() const;
00074
00075     private:
00076         BOOLEAN OnShortKeyUp_PinYin(KeyCode apoxi_key_code);
00077         BOOLEAN OnShortKeyUp_Bopomofo(KeyCode apoxi_key_code);
00078         BOOLEAN OnShortKeyUp_Stroke(KeyCode apoxi_key_code);
00079
00080         BOOLEAN OnLongKeyPress_Stroke(KeyCode apoxi_key_code);
00081         BOOLEAN OnLongKeyPress_Bopomofo(KeyCode apoxi_key_code);
00082         BOOLEAN OnLongKeyPress_PinYin(KeyCode apoxi_key_code);
00083
00084
00085         typedef T9Wrapper::t9_symbol t9_symbol;
00086         t9_symbol MapKey_Pinyin(KeyCode apoxi_key_code, BOOLEAN allow_selection = TRUE);
00087         t9_symbol MapKey_Bopomofo(KeyCode apoxi_key_code, BOOLEAN allow_selection = TRUE);
00088         t9_symbol MapKey_Stroke(KeyCode apoxi_key_code);
00089
00091         t9_symbol MapKey_ChineseControl(KeyCode apoxi_key_code, BOOLEAN allow_selection = TRUE);
00092
00093
00094         UINT MapKey_PhoneticDigitSelect(KeyCode apoxi_key_code, BOOLEAN& found);
00095         UINT MapKey_StrokeDigitSelect(KeyCode apoxi_key_code, BOOLEAN& found);
00096
00098         BOOLEAN HandlePhoneticSelection(KeyCode apoxi_key_code);
00099
00100         ChineseT9Wrapper m_t9;
00101 };
00102
00103 #endif  // Apoxi_ChineseT9InputMapper_hpp
00104
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/ChineseT9Wrapper.cpp File Reference

AddOns/T9/ChineseT9Wrapper.cpp File Reference

#include "PreComp.hpp"
#include <string.h>
#include "ChineseT9Wrapper.hpp"

Include dependency graph for ChineseT9Wrapper.cpp:

Functions

T9STATUS FARCALL | T9HandleRequest_Chinese (T9FieldInfo *pFieldInfo, T9Request *pRequest)
T9NUM FARCALL | T9ReadLdbData_Chinese (T9FieldInfo *pFieldInfo, T9U32 dwOffset, T9U8 *pbDst, T9NUM nSize)

Variables

const T9NUM | c_t9_key_buf_len = 6
const T9NUM | c_t9_selectpage_buf_len = 6

Function Documentation

T9STATUS FARCALL T9HandleRequest_Chinese | ( | T9FieldInfo * | pFieldInfo,
 |  | T9Request * | pRequest
 | ) |

T9NUM FARCALL T9ReadLdbData_Chinese | ( | T9FieldInfo * | pFieldInfo,
 |  | T9U32 | dwOffset,
 |  | T9U8 * | pbDst,
 |  | T9NUM | nSize
 | ) |

Variable Documentation

const T9NUM c_t9_key_buf_len = 6

const T9NUM c_t9_selectpage_buf_len = 6

Generated on Tue Jan 24 16:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/ChineseT9Wrapper.hpp File Reference

AddOns/T9/ChineseT9Wrapper.hpp File Reference

#include "T9Wrapper.hpp"
#include <Config/Config.hpp>

Include dependency graph for ChineseT9Wrapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ChineseT9Wrapper

Functions

T9STATUS FARCALL | T9HandleRequest_Chinese (T9FieldInfo *pFieldInfo, T9Request *pRequest)

Function Documentation

T9STATUS FARCALL T9HandleRequest_Chinese | ( | T9FieldInfo * | pFieldInfo,
 |  | T9Request * | pRequest
 | ) |

Generated on Tue Jan 24 16:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/ChineseT9Wrapper.hpp Source File

AddOns/T9/ChineseT9Wrapper.hpp

Go to the documentation of this file.
00001 #ifndef Apoxi_ChineseT9Wrapper_hpp
00002 #define Apoxi_ChineseT9Wrapper_hpp
00003
00004 #ifdef _cplusplus
00005 extern "C"
00006 #endif
00007
00008 #include "T9Wrapper.hpp"
00009 #include <Config/Config.hpp>
00010
00011
00012 /************************************************************************/
00013 /*    T9 class interfaces with T9 core and Apoxi                        */
00014 /************************************************************************/
00015 class ChineseT9Wrapper : public T9Wrapper {
00016     typedef T9Wrapper Base;
00017
00018     public:
00019         ChineseT9Wrapper();
00020         virtual ~ChineseT9Wrapper();
00021
00022         virtual void Init();
00023         virtual void DestroyT9();
00024
00025         BOOLEAN GetChineseMode_IsAutoSpell() const;
00026         BOOLEAN GetChineseMode_IsComponents() const;
00027         BOOLEAN GetChineseMode_IsCUdbSearchOnly() const;
00028
00029         // Get different modes:
00030         BOOLEAN GetChineseMode_IsFuzzyPinyin() const;
00031         BOOLEAN GetChineseMode_IsAmbiguousPhonetic() const;
00032         BOOLEAN GetChineseMode_IsExplicitPhonetic() const;
00033         BOOLEAN GetChineseMode_IsExplicitPhoneticContinualSelection() const;
00034         BOOLEAN GetChineseMode_IsStroke() const;
00035
00036         // Set different modes
00037         BOOLEAN SetMode_PinYin();
00038         BOOLEAN SetMode_Bopomofo();
00039         BOOLEAN SetMode_SimplifiedChineseStroke();
00040         BOOLEAN SetMode_TraditionalChineseStroke();
00041
00043         const T9U16* GetChineseSelectPage() const;
00044
00046         T9NUM GetChineseSelectPageNum() const;
00047
00049         T9NUM GetChineseKeyBufLen() const;
00050
00052         T9U8 GetPhoneticIndex() const;
00053
00055         T9U8 GetPhoneticCount() const;
00056
00058         BOOLEAN SelectPhoneticChineseWord(UINT index);
00059         BOOLEAN SelectStrokeChineseWord(UINT index);
00060
00062         BOOLEAN ToggleComponentEntryMode();
00063
00065         BOOLEAN ChangePhoneticSelection(T9U8 phonetic_index);
00066
00068         const T9U8* GetPhoneticList() const;
00069         const WCHAR* GetBopomofoList() const;
00070
00072         void RefreshPhoneticList();
00073
00075         const T9U8* GetStrokeBuffer() const;
00076
00081         BOOLEAN IsLanguageSupported(t9_language language, T9MINOR mode);
00082
00083     private:
00084         int m_py_key_buf_origin_len;
00085
00087         T9MINOR m_cur_pred_mode;
00088
00090         T9U16 GetChineseMode() const;
00091
00092         // Internal function, used for T9 core initialization
00093         BOOLEAN AllocateT9(T9NUM nBufLenMax);
00094         BOOLEAN AllocateT9Chinese(T9NUM nKeyBufLenMax, T9NUM nSelectPageMax, T9NUM nSpellBufLenMax);
00095         BOOLEAN AllocateT9CUdb(T9U16 wDataSize, T9U16 wSymbolClass);
00096
00097         // Internal function, used for T9 core termination, and free the allocated space
00098         BOOLEAN DeallocateT9Chinese();
00099
00100         // Convert Bopomofo Single character to Unicode
00101         t9_symbol ConvertBopomofoSingleByteToUnicode(T9U8 cChar) const;
00102 };
00103
00104 T9STATUS  FARCALL   T9HandleRequest_Chinese(T9FieldInfo *pFieldInfo, T9Request *pRequest);
00105
00106 #ifdef _cplusplus
00107 }//end of extern "C"
00108 #endif
00109
00110 #endif
00111
00112
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/EnglishT9InputMapper.cpp File Reference

AddOns/T9/EnglishT9InputMapper.cpp File Reference

#include "PreComp.hpp"
#include "EnglishT9InputMapper.hpp"
#include <Kernel/System.hpp>
#include <Kernel/Application.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Config/T9InputConfig.hpp>

Include dependency graph for EnglishT9InputMapper.cpp:

Generated on Tue Jan 24 16:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/EnglishT9InputMapper.hpp File Reference

AddOns/T9/EnglishT9InputMapper.hpp File Reference

#include "T9InputMapper.hpp"
#include <AddOns/T9/T9Wrapper.hpp>

Include dependency graph for EnglishT9InputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EnglishT9InputMapper

Defines

#define | Apoxi_EnglishT9InputMapper_hpp

Define Documentation

#define Apoxi_EnglishT9InputMapper_hpp

Generated on Tue Jan 24 16:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/EnglishT9InputMapper.hpp Source File

AddOns/T9/EnglishT9InputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_EnglishT9InputMapper_hpp)
00011 #define Apoxi_EnglishT9InputMapper_hpp
00012
00013 #include "T9InputMapper.hpp"
00014 #include <AddOns/T9/T9Wrapper.hpp>
00015
00019 class EnglishT9InputMapper : public T9InputMapper {
00020     typedef T9InputMapper Base;
00021
00022     public:
00024         EnglishT9InputMapper(AbstractEditor *editor = 0);
00025
00027         virtual ~EnglishT9InputMapper();
00028
00030         virtual const WCHAR* GetStatusInfo() const;
00031
00033         virtual InputMapper::Alphabet GetAlphabet() const;
00034
00036         virtual BOOLEAN SetMode(PredMode mode);
00037
00039         virtual PredMode GetMode() const;
00040
00042         virtual BOOLEAN IsModeSupported(PredMode mode);
00043
00044     protected:
00045         T9NUM GetLdbNumForMode(PredMode mode) const;
00046
00048         virtual BOOLEAN OnShortKeyUp_T9(KeyCode key_code);
00049
00051         virtual BOOLEAN OnLongKeyPress_T9(KeyCode apoxi_key_code);
00052
00053         WCHAR MapKeyToCharacter_Numbers(KeyCode apoxi_key_code);
00054
00055         T9Wrapper::t9_symbol MapKey_English(KeyCode apoxi_key_code);
00056
00058         T9Wrapper::t9_symbol MapKey_English_Alphabetic(KeyCode apoxi_key_code);
00059
00061         virtual T9Wrapper* GetT9Wrapper();
00062
00064         virtual const T9Wrapper* GetT9Wrapper() const;
00065
00066
00067     private:
00068         //Member data:
00069         T9Wrapper   m_t9;
00070         BOOLEAN     m_thai_matrix_mode;
00071 };
00072
00073 #endif  // Apoxi_EnglishT9InputMapper_hpp
00074
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/PreComp.cpp File Reference

AddOns/T9/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/PreComp.hpp File Reference

AddOns/T9/PreComp.hpp File Reference

#include <Gui/Lib.hpp>
#include <Kernel/System.hpp>
#include <Gui/View.hpp>
#include <Gui/Control.hpp>
#include <Gui/PositionIndicator.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/PreComp.hpp Source File

AddOns/T9/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 //lint -e506
00010 //lint -e774
00011 //lint -e527
00012
00013 #include <Gui/Lib.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Gui/View.hpp>
00016 #include <Gui/Control.hpp>
00017 #include <Gui/PositionIndicator.hpp>
00018
00019
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/SelectionBox.cpp File Reference

AddOns/T9/SelectionBox.cpp File Reference

#include "PreComp.hpp"
#include "SelectionBox.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/FontConfig.hpp>
#include <Config/T9InputConfig.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>

Include dependency graph for SelectionBox.cpp:

Generated on Tue Jan 24 16:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/SelectionBox.hpp File Reference

AddOns/T9/SelectionBox.hpp File Reference

#include <Gui/DrawableObject.hpp>
#include <Gui/PredInputMapper.hpp>

Include dependency graph for SelectionBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SelectionBox
class | SelectionBoxView

Defines

#define | Apoxi_SelectionBox_hpp

Define Documentation

#define Apoxi_SelectionBox_hpp

Generated on Tue Jan 24 16:47:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/SelectionBox.hpp Source File

AddOns/T9/SelectionBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SelectionBox_hpp)
00010 #define Apoxi_SelectionBox_hpp
00014
00015 #include <Gui/DrawableObject.hpp>
00016 #include <Gui/PredInputMapper.hpp>
00018 class SelectionBoxView : public DrawableObjectView {
00019     typedef DrawableObjectView Base;
00020
00021     public:
00023         SelectionBoxView();
00024
00026         virtual ~SelectionBoxView();
00027
00029         void Init();
00030
00032         virtual void Draw(const Component& component,
00033                           DeviceContext* dc,
00034                           const Rect& repaint_rect) const;
00035 };
00036
00038 class SelectionBox : public DrawableObject {
00039     public:
00040         typedef DrawableObject Base;
00041
00043         SelectionBox();
00044
00046         SelectionBox(Control* control);
00047
00049         virtual ~SelectionBox();
00050
00052         void Init(Control* control);
00053
00055         void SetText(const WCHAR* text);
00056
00058         const WCHAR* GetText() const { return m_text; }
00059
00061         void SetSelectedIndex(INT selected_idx) { m_selected_idx = selected_idx; }
00062
00064         INT GetSelectedIndex() const { return m_selected_idx; }
00065
00067         virtual XYDIM GetDefaultHeight() const;
00068
00069     private:
00070         const WCHAR* m_text;
00071         INT m_selected_idx;
00072
00073         static SelectionBoxView m_view;
00074 };
00075
00077 #endif  // Apoxi_SelectionBox_hpp
00078
00079
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/StrokeBox.cpp File Reference

AddOns/T9/StrokeBox.cpp File Reference

#include "PreComp.hpp"
#include "StrokeBox.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/FontConfig.hpp>
#include <Config/T9InputConfig.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>

Include dependency graph for StrokeBox.cpp:

Generated on Tue Jan 24 16:47:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/StrokeBox.hpp File Reference

AddOns/T9/StrokeBox.hpp File Reference

#include <Gui/DrawableObject.hpp>

Include dependency graph for StrokeBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StrokeBox
class | StrokeBoxView

Defines

#define | Apoxi_StrokeBox_hpp

Define Documentation

#define Apoxi_StrokeBox_hpp

Generated on Tue Jan 24 16:47:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/StrokeBox.hpp Source File

AddOns/T9/StrokeBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_StrokeBox_hpp)
00010 #define Apoxi_StrokeBox_hpp
00014
00015 #include <Gui/DrawableObject.hpp>
00016
00018 class StrokeBoxView : public DrawableObjectView {
00019     typedef DrawableObjectView Base;
00020
00021     public:
00023         StrokeBoxView();
00024
00026         virtual ~StrokeBoxView();
00027
00029         void Init();
00030
00032         virtual void Draw(const Component& component,
00033                           DeviceContext* dc,
00034                           const Rect& repaint_rect) const;
00035 };
00036
00038 class StrokeBox : public DrawableObject {
00039     public:
00040         typedef DrawableObject Base;
00041
00042         StrokeBox();
00043
00045         StrokeBox(Control* control);
00046
00047         virtual ~StrokeBox();
00048
00050         void Init(Control* control);
00051
00053         void SetText(const WCHAR* text);
00054
00056         const WCHAR* GetText() const { return m_text; }
00057
00059         virtual XYDIM GetDefaultHeight() const;
00060
00061     private:
00062         const WCHAR* m_text;
00063         static StrokeBoxView m_view;
00064 };
00065
00067 #endif  // Apoxi_StrokeBox_hpp
00068
00069
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9InputMapper.cpp File Reference

AddOns/T9/T9InputMapper.cpp File Reference

#include "PreComp.hpp"
#include "T9InputMapper.hpp"
#include <Kernel/System.hpp>
#include <Gui/AbstractEditor.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <Config/T9InputConfig.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for T9InputMapper.cpp:

Generated on Tue Jan 24 16:47:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9InputMapper.hpp File Reference

AddOns/T9/T9InputMapper.hpp File Reference

#include <Gui/PredInputMapper.hpp>
#include <AddOns/T9/T9Wrapper.hpp>

Include dependency graph for T9InputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | T9InputMapper

Defines

#define | Apoxi_T9InputMapper_hpp

Define Documentation

#define Apoxi_T9InputMapper_hpp

Generated on Tue Jan 24 16:47:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9InputMapper.hpp Source File

AddOns/T9/T9InputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_T9InputMapper_hpp)
00011 #define Apoxi_T9InputMapper_hpp
00015
00016 #include <Gui/PredInputMapper.hpp>
00017 #include <AddOns/T9/T9Wrapper.hpp>
00018
00019
00021 class T9InputMapper : public PredInputMapper {
00022     typedef PredInputMapper Base;
00023
00024     public:
00026         T9InputMapper(AbstractEditor *editor = 0);
00027
00028         typedef T9Wrapper::enumConstants enumConstants;
00029
00031         virtual ~T9InputMapper();
00032
00034         virtual INT GetId() const;
00035
00037         virtual Type GetType() const;
00038
00040         virtual void SetEditor(AbstractEditor *editor);
00041
00043         virtual const WCHAR* GetStatusInfo() const;
00044
00046         virtual const WCHAR* GetPhonetics(INT *selected_idx = 0) const;
00047
00049         virtual const WCHAR* GetStrokes() const;
00050
00052         virtual const WCHAR* GetSelection() const;
00053
00055         virtual INT GetSelectedIndex() const;
00056
00058         virtual PredMode GetMode() const;
00059
00060         typedef T9Wrapper::t9_language t9_language;
00061
00067         BOOLEAN SetMode_T9_Latin(t9_language lang);
00068
00069         virtual BOOLEAN AddExplicitCharacter(const WCHAR chr);
00070
00072         BOOLEAN AddExplicitWord(const WString& word);
00073
00074         BOOLEAN AddNewWordToUdb(const WString& new_word);
00075
00077         BOOLEAN DeleteActiveWord();
00078
00079         virtual BOOLEAN Notify (NotificationType type, INT index = 0, const AtomItem* item = 0);
00080     protected:
00081
00082         KeyCode GetSpaceKeyCode() const;
00083
00085         virtual BOOLEAN OnLongKeyPress(KeyCode apoxi_key_code);
00086
00087         //This is a new virtual handler, for T9, because APOXI does not implement this logic:
00088         virtual BOOLEAN OnLongKeyPress_T9(KeyCode apoxi_key_code);
00089
00091         virtual BOOLEAN OnKeyUp(KeyCode apoxi_key_code, UINT32 duration);
00092
00093         //This is a new virtual handler, for T9, because APOXI does not implement this logic:
00094         virtual BOOLEAN OnShortKeyUp_T9(KeyCode apoxi_key_code);
00095
00096
00098         static KeyCode GetApoxiKeyCode_Hash();
00099
00101         static KeyCode GetApoxiKeyCode_Menu();
00102
00104         static KeyCode GetApoxiKeyCode_Star();
00105
00107         void SynchronizeBuffers_T9ToApoxi();
00108
00110         void SynchronizeBuffers_ApoxiToT9();
00111
00113         void UpdateTextEditorDocument();
00114
00116         void UpdateMultiMediaEditorDocument();
00117
00119         BOOLEAN IsTextEditorDocument() const;
00120
00122         virtual T9Wrapper* GetT9Wrapper() = 0;
00123
00129         virtual const T9Wrapper* GetT9Wrapper() const = 0;
00130
00131         // Debugging-code (enabled only for HOST-environment)
00132         #if defined(_MSC)
00133             #if defined(_DEBUG)
00134                 INT DumpCompoundItem(const CompoundItem& comp_item, INT level = 0) const;
00135                 void DumpDocument (WCHAR* method);
00136             #endif
00137         #endif
00138
00139     private:
00140         BOOLEAN m_longkeypress_processed;
00141         UINT m_old_t9_caret_pos;
00142 };
00143
00144 #endif  // Apoxi_T9InputMapper_hpp
00145
00146
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9Pack.cpp File Reference

AddOns/T9/T9Pack.cpp File Reference

#include "PreComp.hpp"
#include "T9Pack.hpp"

Include dependency graph for T9Pack.cpp:

Generated on Tue Jan 24 16:47:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9Pack.hpp File Reference

AddOns/T9/T9Pack.hpp File Reference

#include <Gui/AcacTypes.hpp>
#include <Gui/DataPack.hpp>

Include dependency graph for T9Pack.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | T9Pack

Defines

#define | Apoxi_T9Pack_hpp

Define Documentation

#define Apoxi_T9Pack_hpp

Generated on Tue Jan 24 16:47:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9Pack.hpp Source File

AddOns/T9/T9Pack.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_T9Pack_hpp)
00011 #define Apoxi_T9Pack_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014 #include <Gui/DataPack.hpp>
00015
00021 class T9Pack : public DataPack {
00022     typedef DataPack Base;
00023
00024     public:
00030         T9Pack(UINT8 *data);
00031
00035         virtual ~T9Pack();
00036
00042         UINT16 GetLdbId(UINT32 index);
00043
00049         INT32 GetIndex(UINT16 ldb_id);
00050
00056         const UINT8 *GetData(UINT16 index) const;
00057
00063         UINT32 GetSize(UINT16 index) const;
00064
00070         UINT32 GetLdbSize(UINT16 index) const;
00071
00072     private:
00074         T9PackData* m_t9_pack_data;
00075
00077         T9LdbData ** m_ldbs;
00078 };
00079 #endif //Apoxi_FontPack_hpp
00080
00081
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PackConnector.cpp File Reference

AddOns/T9/T9PackConnector.cpp File Reference

#include "PreComp.hpp"
#include "T9PackConnector.hpp"
#include <Gui/BasicPackConnector.hpp>

Include dependency graph for T9PackConnector.cpp:

Generated on Tue Jan 24 16:47:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PackConnector.hpp File Reference

AddOns/T9/T9PackConnector.hpp File Reference

#include <AddOns/T9/T9Pack.hpp>

Include dependency graph for T9PackConnector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | T9PackConnector

Defines

#define | Apoxi_T9PackConnector_hpp

Define Documentation

#define Apoxi_T9PackConnector_hpp

Generated on Tue Jan 24 16:47:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PackConnector.hpp Source File

AddOns/T9/T9PackConnector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_T9PackConnector_hpp)
00011 #define Apoxi_T9PackConnector_hpp
00012
00013 #include <AddOns/T9/T9Pack.hpp>
00014
00020 class T9PackConnector {
00021     public:
00026         static void Init();
00027
00031         static BOOLEAN IsT9PackAvailable();
00032
00038         static BOOLEAN SetActiveLdb(UINT16 id);
00039
00045         static UINT32 GetSizeOfLdb(UINT16 id = m_ldb_id);
00046
00054         static INT ReadLdbData(UINT32 offset, UINT8 *dst, INT size);
00055
00059         static INT16 GetNumberOfLdbs();
00060
00067         static BOOLEAN GetLdbIds(INT *ldb_ids, UINT16 size);
00068
00069     private:
00071         static T9Pack* m_t9_pack;
00072
00074         static INT32 m_ldb_id;
00075 };
00076
00077 #endif  // Apoxi_T9PackConnector_hpp
00078
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PinyinBox.cpp File Reference

AddOns/T9/T9PinyinBox.cpp File Reference

#include "PreComp.hpp"
#include "T9PinyinBox.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/FontConfig.hpp>
#include <Config/T9InputConfig.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>

Include dependency graph for T9PinyinBox.cpp:

Generated on Tue Jan 24 16:47:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PinyinBox.hpp File Reference

AddOns/T9/T9PinyinBox.hpp File Reference

#include <Gui/DrawableObject.hpp>

Include dependency graph for T9PinyinBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | T9PinyinBox
class | T9PinyinBoxView

Defines

#define | Apoxi_T9PinyinBox_hpp

Define Documentation

#define Apoxi_T9PinyinBox_hpp

Generated on Tue Jan 24 16:47:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PinyinBox.hpp Source File

AddOns/T9/T9PinyinBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_T9PinyinBox_hpp)
00010 #define Apoxi_T9PinyinBox_hpp
00014
00015 #include <Gui/DrawableObject.hpp>
00016
00018 class T9PinyinBoxView : public DrawableObjectView {
00019     typedef DrawableObjectView Base;
00020
00021     public:
00023         T9PinyinBoxView();
00024
00026         virtual ~T9PinyinBoxView();
00027
00029         void Init();
00030
00032         virtual void Draw(const Component& component,
00033                           DeviceContext* dc,
00034                           const Rect& repaint_rect) const;
00035 };
00036
00038 class T9PinyinBox : public DrawableObject {
00039     public:
00040         typedef DrawableObject Base;
00041
00042         T9PinyinBox();
00043
00045         T9PinyinBox(Control* control);
00046
00047         virtual ~T9PinyinBox();
00048
00050         void Init(Control* control);
00051
00053         void SetText(const WCHAR* text, INT selected_idx = -1);
00054
00056         const WCHAR* GetText(INT* selected_idx = 0) const;
00057
00059         virtual XYDIM GetDefaultHeight() const;
00060
00061     private:
00062         const WCHAR* m_text;
00063         INT         m_selected_idx;
00064
00065         static T9PinyinBoxView m_view;
00066 };
00067
00069 #endif  // Apoxi_T9PinyinBox_hpp
00070
00071
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PredictiveInputBox.cpp File Reference

AddOns/T9/T9PredictiveInputBox.cpp File Reference

#include "PreComp.hpp"
#include "T9PredictiveInputBox.hpp"
#include "T9InputMapper.hpp"
#include <Kernel/Application.hpp>

Include dependency graph for T9PredictiveInputBox.cpp:

Generated on Tue Jan 24 16:47:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PredictiveInputBox.hpp File Reference

AddOns/T9/T9PredictiveInputBox.hpp File Reference

#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
#include <AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp>
#include "T9PinyinBox.hpp"
#include "StrokeBox.hpp"
#include "SelectionBox.hpp"

Include dependency graph for T9PredictiveInputBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | T9PredictiveInputBox

Defines

#define | Apoxi_T9PredictiveInputBox_hpp

Define Documentation

#define Apoxi_T9PredictiveInputBox_hpp

Generated on Tue Jan 24 16:47:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9PredictiveInputBox.hpp Source File

AddOns/T9/T9PredictiveInputBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_T9PredictiveInputBox_hpp)
00012 #define Apoxi_T9PredictiveInputBox_hpp
00016
00017 #include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
00018 #include <AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp>
00019 #include "T9PinyinBox.hpp"
00020 #include "StrokeBox.hpp"
00021 #include "SelectionBox.hpp"
00022
00024 class T9PredictiveInputBox : public AbstractPredictiveInputBox {
00025     typedef AbstractPredictiveInputBox Base;
00026
00027     public:
00029         T9PredictiveInputBox();
00030
00032         T9PredictiveInputBox(Control* parent, AbstractMultiLineEditor* m_editor, Window* add_word_to_dict_win=0, Window* ext_punc_win=0);
00033
00035         virtual ~T9PredictiveInputBox();
00036
00038         void Init(Control* parent, AbstractMultiLineEditor* m_editor, Window* add_word_to_dict_win=0, Window* ext_punc_win=0);
00039
00041         virtual INT GetCapsStatus() const;
00042
00043         virtual BOOLEAN SetMode(PredInputMapper::PredMode mode);
00044
00045         virtual BOOLEAN AddNewWordToUdb(const WString& word);
00046
00047         virtual void SetThaiMatrixModeWindow (T9ThaiMatrixModeWindowInterface* matrix_mode_window) { m_thai_matrix_mode_window = matrix_mode_window; }
00048
00049     protected:
00051         virtual void OnLayoutClient();
00052
00053         virtual BOOLEAN OnLongKeyPress(KeyCode key_code);
00054
00056         virtual BOOLEAN OnMessage(const Message& msg);
00057
00058         virtual void UpdateDrawableObjects();
00059
00061         virtual BOOLEAN RouteMessage(const Message& msg);
00062
00063     private:
00064         T9PinyinBox     m_pinyin_box;
00065         StrokeBox       m_stroke_box;
00066         SelectionBox    m_selection_box;
00067         T9ThaiMatrixModeWindowInterface*    m_thai_matrix_mode_window;
00068 };
00069
00071 #endif  // Apoxi_T9PredictiveInputBox_hpp
00072
00073
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp File Reference

AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | T9ThaiMatrixModeWindowInterface

Defines

#define | T9ThaiMatrixModeWindowInterface_hpp

Define Documentation

#define T9ThaiMatrixModeWindowInterface_hpp

Generated on Tue Jan 24 16:47:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp Source File

AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(T9ThaiMatrixModeWindowInterface_hpp)
00010 #define T9ThaiMatrixModeWindowInterface_hpp
00011
00012 class T9ThaiMatrixModeWindowInterface {
00013     public:
00014         virtual INT OpenMatrixWindow(KeyCode key_code) = 0;
00015 };
00016
00017
00018 #endif  // T9ThaiMatrixModeWindowInterface_hpp
00019
00020
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9Wrapper.cpp File Reference

AddOns/T9/T9Wrapper.cpp File Reference

#include "PreComp.hpp"
#include <string.h>
#include "T9Wrapper.hpp"

Include dependency graph for T9Wrapper.cpp:

Functions

T9STATUS FARCALL T9HandleRequest (T9FieldInfo *pFieldInfo, T9Request *pRequest)

Function Documentation

T9STATUS FARCALL T9HandleRequest | ( | T9FieldInfo * | pFieldInfo,
 |  | T9Request * | pRequest
 | ) |

Generated on Tue Jan 24 16:47:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9Wrapper.hpp File Reference

AddOns/T9/T9Wrapper.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:47:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/T9/T9Wrapper.hpp Source File

AddOns/T9/T9Wrapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ----------------------------------------------------------------------- */
00008
00009 #ifndef Apoxi_T9Wrapper_hpp
00010 #define Apoxi_T9Wrapper_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00017
00018 #include <t9api.h>
00019 #include <Config/T9InputConfig.hpp>
00020
00021
00023 class T9EventWrapper : public T9Event //T9Event is a struct from the T9 C API.
00024 {
00025     public:
00026         T9EventWrapper();
00027 };
00028
00031 class T9Wrapper {
00032     public:
00033         T9Wrapper();
00034         virtual ~T9Wrapper();
00035
00036         typedef T9SYMB t9_symbol;
00037
00038         enum enumConstants
00039         {
00040             T9_KEY_MAP_INVALID = 0xff
00041         };
00042
00043         enum HandleKeyEventStatus {
00044             Error,
00045             Ok,
00046             WordNotFound
00047         };
00048
00049         virtual void Init();
00050         virtual void DestroyT9();
00051
00053         const t9_symbol* GetTextBuffer() const;
00054         T9NUM GetTextBufferLengthMax() const;
00055         T9NUM GetTextBufferLength() const;
00056         INT GetCursorPos() const;
00057
00059         virtual UINT8 HandleKeyEvent(t9_symbol T9Key);
00060
00062         T9NUM GetLdbNum() const;
00063
00065         T9U32 GetLdbMode() const;
00066
00068         BOOLEAN SetBuffer(INT cursor_pos, INT buf_len, const t9_symbol *symb_buffer);
00069
00070
00071         typedef T9NUM t9_language;
00072
00074         BOOLEAN SetT9EnglishMode();
00075
00078         BOOLEAN SetT9LatinMode(t9_language lang);
00079
00080         BOOLEAN AddExplicitCharacter(t9_symbol t9_key);
00081
00082         BOOLEAN DeleteActiveWord();
00083
00085         BOOLEAN RepositionCursor(INT cursor_pos);
00086         BOOLEAN RepositionCursor_Beginning();
00087         BOOLEAN RepositionCursor_End();
00088
00089         const WString GetActiveWord();
00090
00091         BOOLEAN AddExplicitWord(const WString& word);
00092
00093         BOOLEAN AddNewWordToUdb(const WString& new_word);
00094
00095         BOOLEAN SetWordLeftToCursorActive();
00096
00099         T9FieldInfo* GetT9FieldInfo();
00100
00103         const T9FieldInfo* GetT9FieldInfo() const;
00104
00109         BOOLEAN IsLanguageSupported(t9_language language);
00110
00111     protected:
00112
00113         // T9FieldInfo seems to be a general state structure for the T9 C API.
00114         T9FieldInfo m_field_info;
00115
00116         // Internal function, used for T9 core initialization
00117         BOOLEAN AllocateT9(T9NUM nBufLenMax);
00118         BOOLEAN InitializeT9Udb(T9U16 wSymbolClass);
00119         BOOLEAN InitializeT9(T9NUM nLdbNum);
00120
00121         // Internal function, used for T9 core termination, and to free the allocated space
00122         BOOLEAN TerminateT9();
00123         BOOLEAN DeallocateT9();
00124         BOOLEAN DeallocateT9Udb();
00125
00126 };
00127
00128
00129 T9STATUS  FARCALL   T9HandleRequest(T9FieldInfo *pFieldInfo, T9Request *pRequest);
00130
00131 // This is implemented in t9gen.c, but not declared in any header:
00132 // See "5.2.6 Implementing T9ReadLdbData with Internal LDBs" in the "T9 API Implementation Guide":
00133 extern "C" // It's a C function, not a C++ function.
00134 {
00135 T9NUM FARCALL T9ReadLdbData(T9FieldInfo *pFieldInfo,T9U32 dwOffset,T9U8 *pbDst,T9NUM nSize);
00136 }
00137
00139 #endif // DOXYGEN_SHOULD_SKIP_THIS
00140 #endif // Apoxi_T9Wrapper_hpp
00141
00142
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/EnumTranslationTable.cpp File Reference

AddOns/Translation/EnumTranslationTable.cpp File Reference

#include "AddOns/Translation/PreComp.hpp"
#include "EnumTranslationTable.hpp"

Include dependency graph for EnumTranslationTable.cpp:

Generated on Tue Jan 24 16:47:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/EnumTranslationTable.hpp File Reference

AddOns/Translation/EnumTranslationTable.hpp File Reference

#include <AddOns/Translation/ValueTextMap.hpp>

Include dependency graph for EnumTranslationTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EnumTranslationTable

Defines

#define | AddOns_Translation_EnumTranslationTable_hpp
#define | EnumTr(enum_translation_table, enum_value) ValueTextMap(EnumTranslationTable::enum_translation_table()).GetText(enum_value)

Define Documentation

#define AddOns_Translation_EnumTranslationTable_hpp

Generated on Tue Jan 24 16:47:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/EnumTranslationTable.hpp Source File

AddOns/Translation/EnumTranslationTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(AddOns_Translation_EnumTranslationTable_hpp)
00009 #define AddOns_Translation_EnumTranslationTable_hpp
00013
00014 #include <AddOns/Translation/ValueTextMap.hpp>
00015
00017 class EnumTranslationTable {
00018     public:
00020         static const ValueTextMap::Table* HandlerId() { return (m_handler_id); }
00022         static const ValueTextMap::Table* ChvNo() { return (m_chv_no); }
00024         static const ValueTextMap::Table* ChvStatus() { return (m_chv_status); }
00026         static const ValueTextMap::Table* RegisterStatus() { return (m_register_status); }
00028         static const ValueTextMap::Table* RegisterRejectCause() { return (m_register_reject_cause); }
00030         static const ValueTextMap::Table* AudioToneToneType() { return (m_audio_tone_tone_type); }
00032         static const ValueTextMap::Table* CallApiRc() { return (m_call_api_rc); }
00034         static const ValueTextMap::Table* CallErrorCause() { return (m_call_error_cause); }
00036         static const ValueTextMap::Table* SmsResult() { return (m_sms_result); }
00038         static const ValueTextMap::Table* SmsWarningLevel() { return (m_sms_warning_level); }
00040         static const ValueTextMap::Table* MessageClass() { return (m_dcs_message_class); }
00042         static const ValueTextMap::Table* TpduStatus() { return (m_tpdu_status); }
00044         static const ValueTextMap::Table* MessageTypeIndicator() { return (m_message_type_indicator); }
00046         static const ValueTextMap::Table* DcsGroupId() { return (m_dcs_group_id); }
00048         static const ValueTextMap::Table* SmsStorageType() { return (m_sms_storage_type); }
00050         static const ValueTextMap::Table* MessageStatus() { return (m_message_status); }
00052         static const ValueTextMap::Table* MessageResultReason() { return (m_message_result_reason); }
00054         static const ValueTextMap::Table* SimIndicator() { return (m_sim_indicator); }
00056         static const ValueTextMap::Table* SsErrorCode() { return (m_ss_error_code); }
00058         static const ValueTextMap::Table* Alphabet() { return (m_alphabet); }
00060         static const ValueTextMap::Table* Compression() { return (m_compression); }
00062         static const ValueTextMap::Table* WaitingMessageIndication() { return (m_waiting_message_indication); }
00064         static const ValueTextMap::Table* WaitingMessage() { return (m_waiting_message); }
00066         static const ValueTextMap::Table* PidInterworking() { return (m_interworking); }
00068         static const ValueTextMap::Table* TelematicDevice() { return (m_telematic_device); }
00070         static const ValueTextMap::Table* MessageType() { return (m_message_type); }
00072         static const ValueTextMap::Table* ValidityPeriodFormat() { return (m_validity_period_format); }
00074         static const ValueTextMap::Table* PdpContextManagerState() { return (m_pdp_context_manager_state); }
00076         static const ValueTextMap::Table* PdpContextErrorCause() { return (m_pdp_context_error_cause); }
00078         static const ValueTextMap::Table* PdpContextOrigin() { return (m_pdp_context_origin); }
00080         static const ValueTextMap::Table* PdpContextState() { return (m_pdp_context_state); }
00082         static const ValueTextMap::Table* AocChargingStatus() { return (m_aoc_charging_status); }
00084         static const ValueTextMap::Table* CallRelatedSsCode() { return (m_call_related_ss_code); }
00086         static const ValueTextMap::Table* SsOperationCode() { return (m_ss_operation_code); }
00088         static const ValueTextMap::Table* ServiceGroup() { return (m_service_group); }
00090         static const ValueTextMap::Table* ProblemCode() { return (m_problem_code); }
00092         static const ValueTextMap::Table* ProblemTag() { return (m_problem_tag); }
00094         static const ValueTextMap::Table* SecLockResult() { return (m_sec_lock_result); }
00096         static const ValueTextMap::Table* SsBaseHandlerReturnCode() { return (m_ss_base_hdl_rc); }
00097
00098     #if defined(APOXI_LIB_ADDON_VR)
00099
00100         static const ValueTextMap::Table* VrHandlerVrCommand() { return (m_vr_command); }
00102         static const ValueTextMap::Table* VrErrorCode() { return (m_vr_error_code); }
00104         static const ValueTextMap::Table* VrWarningCode() { return (m_vr_warning_code); }
00105     #endif
00106
00107     private:
00108         static const ValueTextMap::Table m_handler_id[];
00109         static const ValueTextMap::Table m_chv_no[];
00110         static const ValueTextMap::Table m_chv_status[];
00111         static const ValueTextMap::Table m_register_status[];
00112         static const ValueTextMap::Table m_register_reject_cause[];
00113         static const ValueTextMap::Table m_audio_tone_tone_type[];
00114         static const ValueTextMap::Table m_call_api_rc[];
00115         static const ValueTextMap::Table m_call_error_cause[];
00116         static const ValueTextMap::Table m_sms_result[];
00117         static const ValueTextMap::Table m_sms_warning_level[];
00118         static const ValueTextMap::Table m_dcs_message_class[];
00119         static const ValueTextMap::Table m_tpdu_status[];
00120         static const ValueTextMap::Table m_message_type_indicator[];
00121         static const ValueTextMap::Table m_dcs_group_id[];
00122         static const ValueTextMap::Table m_sms_storage_type[];
00123         static const ValueTextMap::Table m_message_status[];
00124         static const ValueTextMap::Table m_message_result_reason[];
00125         static const ValueTextMap::Table m_sim_indicator[];
00126         static const ValueTextMap::Table m_ss_error_code[];
00127         static const ValueTextMap::Table m_alphabet[];
00128         static const ValueTextMap::Table m_compression[];
00129         static const ValueTextMap::Table m_waiting_message_indication[];
00130         static const ValueTextMap::Table m_waiting_message[];
00131         static const ValueTextMap::Table m_interworking[];
00132         static const ValueTextMap::Table m_telematic_device[];
00133         static const ValueTextMap::Table m_message_type[];
00134         static const ValueTextMap::Table m_validity_period_format[];
00135         static const ValueTextMap::Table m_pdp_context_manager_state[];
00136         static const ValueTextMap::Table m_pdp_context_error_cause[];
00137         static const ValueTextMap::Table m_pdp_context_origin[];
00138         static const ValueTextMap::Table m_pdp_context_state[];
00139         static const ValueTextMap::Table m_aoc_charging_status[];
00140         static const ValueTextMap::Table m_call_related_ss_code[];
00141         static const ValueTextMap::Table m_ss_operation_code[];
00142         static const ValueTextMap::Table m_service_group[];
00143         static const ValueTextMap::Table m_problem_tag[];
00144         static const ValueTextMap::Table m_problem_code[];
00145         static const ValueTextMap::Table m_sec_lock_result[];
00146         static const ValueTextMap::Table m_ss_base_hdl_rc[];
00147     #if defined(APOXI_LIB_ADDON_VR)
00148         static const ValueTextMap::Table m_vr_command[];
00149         static const ValueTextMap::Table m_vr_error_code[];
00150         static const ValueTextMap::Table m_vr_warning_code[];
00151     #endif
00152 };
00153
00154 #define EnumTr(enum_translation_table, enum_value) \
00155     ValueTextMap(EnumTranslationTable::enum_translation_table()).GetText(enum_value)
00156
00158 #endif  // AddOns_Translation_EnumTranslationTable_hpp
00159
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/Lib.hpp File Reference

AddOns/Translation/Lib.hpp File Reference

#include <AddOns/Translation/EnumTranslationTable.hpp>
#include <AddOns/Translation/ValueTextMap.hpp>

Include dependency graph for Lib.hpp:

Go to the source code of this file.

Defines

#define AddOns_Translation_Lib_hpp

Define Documentation

#define AddOns_Translation_Lib_hpp

Generated on Tue Jan 24 14:53:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/Lib.hpp Source File

AddOns/Translation/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(AddOns_Translation_Lib_hpp)
00009 #define AddOns_Translation_Lib_hpp
00013
00014 #include <AddOns/Translation/EnumTranslationTable.hpp>
00015 #include <AddOns/Translation/ValueTextMap.hpp>
00016
00018 #endif
00019
00020
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/PreComp.cpp File Reference

AddOns/Translation/PreComp.cpp File Reference

#include "AddOns/Translation/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/PreComp.hpp File Reference

AddOns/Translation/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:17:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/PreComp.hpp Source File

AddOns/Translation/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Gui/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Apc/Lib.hpp>
00012 #include <Adc/Lib.hpp>
00013 #include <Asc/Lib.hpp>
00014
00015 #if defined(APOXI_LIB_ADDON_VR)
00016     #include <AddOns/VoiceRecognition/VrHandler.hpp>
00017 #endif
00018
00019
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/ValueTextMap.cpp File Reference

AddOns/Translation/ValueTextMap.cpp File Reference

#include "AddOns/Translation/PreComp.hpp"
#include "ValueTextMap.hpp"

Include dependency graph for ValueTextMap.cpp:

Generated on Tue Jan 24 16:48:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/ValueTextMap.hpp File Reference

AddOns/Translation/ValueTextMap.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ValueTextMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ValueTextMap
struct | ValueTextMap::Table

Defines

#define | AddOns_Translation_ValueTextMap_hpp

Define Documentation

#define AddOns_Translation_ValueTextMap_hpp

Generated on Tue Jan 24 16:48:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Translation/ValueTextMap.hpp Source File

AddOns/Translation/ValueTextMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(AddOns_Translation_ValueTextMap_hpp)
00009 #define AddOns_Translation_ValueTextMap_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00017 class ValueTextMap {
00018     public:
00019         struct Table {
00020             INT value;
00021             const WCHAR *text;
00022         };  // ValueTextMapStruct
00023
00025         explicit ValueTextMap(const Table *table_ref = 0);
00026
00028         ~ValueTextMap();
00029
00031         const WCHAR* GetText (INT value) const;
00032
00034         static INT InvalidValue() { return (m_invalid_value); }
00035
00037         static const WCHAR* InvalidText() { return (&m_invalid_char); }
00038
00039     private:
00040         static const INT m_invalid_value;
00041         static const WCHAR m_invalid_char;      // guaranteed invalid unicode character
00042         static const WCHAR *m_value_not_found;
00043         static const WCHAR *m_table_not_exists;
00044         const Table *m_table_ref;
00045 };  // ValueTextMap
00046
00048 #endif  // AddOns_Translation_ValueTextMap_hpp
00049
00050
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbMsgTypes.hpp File Reference

AddOns/Usb/UsbMsgTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:48:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbMsgTypes.hpp Source File

AddOns/Usb/UsbMsgTypes.hpp

Go to the documentation of this file.
Generated on Tue Jan 24 14:45:12 2006 for APOXI by

  doxygen  1.4.6-NO


APOXI: AddOns/Usb/UsbPreComp.cpp File Reference

AddOns/Usb/UsbPreComp.cpp File Reference

#include "UsbPreComp.hpp"

Include dependency graph for UsbPreComp.cpp:

Generated on Tue Jan 24 16:48:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbPreComp.hpp File Reference

AddOns/Usb/UsbPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for UsbPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbPreComp.hpp Source File

AddOns/Usb/UsbPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Asc/Lib.hpp>
00012
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbSubSystem.cpp File Reference

AddOns/Usb/UsbSubSystem.cpp File Reference

#include "UsbPreComp.hpp"
#include "UsbSubSystem.hpp"
#include <AddOns/StreamObex/StreamObexTransport.hpp>
#include <Kernel/SubSystemManager.hpp>

Include dependency graph for UsbSubSystem.cpp:

Generated on Tue Jan 24 16:49:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbSubSystem.hpp File Reference

AddOns/Usb/UsbSubSystem.hpp File Reference

#include <Kernel/SubSystem.hpp>
#include <Kernel/Os/Mutex.hpp>
#include "UsbTransport.hpp"

Include dependency graph for UsbSubSystem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UsbSubSystem

Defines

#define | AddOns_Usb_UsbSubSystem_hpp

Define Documentation

#define AddOns_Usb_UsbSubSystem_hpp

Generated on Tue Jan 24 16:49:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbSubSystem.hpp Source File

AddOns/Usb/UsbSubSystem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(AddOns_Usb_UsbSubSystem_hpp)
00012 #define AddOns_Usb_UsbSubSystem_hpp
00013
00014
00015 #include <Kernel/SubSystem.hpp>
00016 #include <Kernel/Os/Mutex.hpp>
00017 #include "UsbTransport.hpp"
00018
00019 class UsbObexTransport;
00020
00021
00026 class UsbSubSystem : public SubSystem
00027 {
00028     typedef SubSystem Base;
00029
00031     public:
00032
00034         static UsbSubSystem* GetInstance() { return &m_instance; }
00035
00037         virtual ~UsbSubSystem();
00038
00040         virtual const WCHAR* GetName() const { return L"USB"; }
00041
00043         virtual BootSequenceState InvokeAt() const;
00044
00047         virtual void OnPowerUp();
00048
00049
00052         virtual void OnPowerDown();
00053
00055         UsbTransport* GetUsbTransport() {
00056             return m_usb_transport;
00057         }
00058
00059
00061     private:
00062
00064         UsbSubSystem();
00065
00066
00068     private:
00069
00071         static UsbSubSystem m_instance;
00072
00074         UsbTransport* m_usb_transport;
00075         UsbObexTransport* m_usb_obex_transport;
00076
00077         Mutex m_mutex;
00078 };
00079
00080 #endif  // AddOns_Usb_UsbSubSystem_hpp
00081
Generated on Tue Jan 24 14:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbTransport.cpp File Reference

AddOns/Usb/UsbTransport.cpp File Reference

#include "UsbPreComp.hpp"
#include "UsbTransport.hpp"
#include "UsbSubSystem.hpp"

Include dependency graph for UsbTransport.cpp:

Generated on Tue Jan 24 16:49:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbTransport.hpp File Reference

AddOns/Usb/UsbTransport.hpp File Reference

#include <Devices/AbstractTransport.hpp>

Include dependency graph for UsbTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UsbTransport
struct | UsbTransport::UsbConnectionInfo
data structure that stores usb connection information

Defines

#define | AddOns_Usb_UsbTransport_hpp

Define Documentation

#define AddOns_Usb_UsbTransport_hpp

Generated on Tue Jan 24 16:49:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/UsbTransport.hpp Source File

AddOns/Usb/UsbTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(AddOns_Usb_UsbTransport_hpp)
00010 #define AddOns_Usb_UsbTransport_hpp
00011
00012 #include <Devices/AbstractTransport.hpp>
00013
00014 class UsbTransport : public AbstractTransport, public UserDispatcher {
00015
00016     typedef AbstractTransport BaseTransport;
00017     typedef UserDispatcher Base2;
00018
00020     public:
00021
00023         static struct UsbConnectionInfo {
00024
00026             enum ConnectionState {
00027                 Connected,
00028                 Usable,
00029                 UnknownDevice,
00030                 Disconnected
00031             } m_conn_state;
00032
00034             WString m_device_descr;
00035
00036         } m_usb_conn_info;
00037
00039         UsbTransport();
00040
00042         static UsbTransport*  GetInstance();
00043
00045         UsbConnectionInfo& GetConnectionInfo();
00046
00051         virtual void Enable();
00052
00054         virtual BaseTransport::AvState GetAvState() const;
00055
00056         static void TransportEvent(INT event);
00057
00059     protected:
00060
00062         virtual BOOLEAN OnMessage(const Message &msg);
00063
00064 };
00065
00066 #endif  // AddOns_Usb_UsbTransport_hpp
00067
Generated on Tue Jan 24 14:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/Obex/UsbObexServerAddress.cpp File Reference

AddOns/Usb/Obex/UsbObexServerAddress.cpp File Reference

#include "UsbPreComp.hpp"
#include "UsbObexServerAddress.hpp"
#include "UsbObexTransport.hpp"

Include dependency graph for UsbObexServerAddress.cpp:

Generated on Tue Jan 24 16:48:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/Obex/UsbObexServerAddress.hpp File Reference

AddOns/Usb/Obex/UsbObexServerAddress.hpp File Reference

#include <Obex/ObexAddress.hpp>

Include dependency graph for UsbObexServerAddress.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UsbObexServerAddr

Defines

#define | AddOns_Usb_UsbObexAddress_hpp

Define Documentation

#define AddOns_Usb_UsbObexAddress_hpp

Generated on Tue Jan 24 16:48:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/Obex/UsbObexServerAddress.hpp Source File

AddOns/Usb/Obex/UsbObexServerAddress.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined( AddOns_Usb_UsbObexAddress_hpp)
00010 #define AddOns_Usb_UsbObexAddress_hpp
00011
00012 #include <Obex/ObexAddress.hpp>
00013
00014
00015 class UsbObexTransport;
00016
00019 class UsbObexServerAddr : public ObexServerAddr {
00020
00021     typedef ObexServerAddr Base;
00022
00024     public:
00025
00027         UsbObexServerAddr(UsbObexTransport *obex_transport, String server_url);
00028
00029         virtual ObexResult ToString(String &  obex_url) const;
00030
00031     private:
00032
00033         String m_server_url;
00034
00035 };
00036
00037 #endif  // AddOns_Usb_UsbObexAddress_hpp
00038
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/Obex/UsbObexTransport.cpp File Reference

AddOns/Usb/Obex/UsbObexTransport.cpp File Reference

#include "UsbPreComp.hpp"
#include "UsbObexTransport.hpp"
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexMessages.hpp>
#include <AddOns/Usb/UsbTransport.hpp>

Include dependency graph for UsbObexTransport.cpp:

Generated on Tue Jan 24 16:48:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/Obex/UsbObexTransport.hpp File Reference

AddOns/Usb/Obex/UsbObexTransport.hpp File Reference

#include <Obex/ObexTransport.hpp>
#include <AddOns/StreamObex/StreamObexTransport.hpp>
#include <AddOns/StreamObex/StreamObexImpl.hpp>
#include "UsbObexServerAddress.hpp"

Include dependency graph for UsbObexTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UsbObexTransport

Defines

#define | Apoxi_UsbObexTransport_hpp

Define Documentation

#define Apoxi_UsbObexTransport_hpp

Generated on Tue Jan 24 16:48:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Usb/Obex/UsbObexTransport.hpp Source File

AddOns/Usb/Obex/UsbObexTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_UsbObexTransport_hpp)
00010 #define Apoxi_UsbObexTransport_hpp
00011
00012 #include <Obex/ObexTransport.hpp>
00013 #include <AddOns/StreamObex/StreamObexTransport.hpp>
00014 #include <AddOns/StreamObex/StreamObexImpl.hpp>
00015 #include "UsbObexServerAddress.hpp"
00016
00017 class UsbTransport;
00018
00019 class UsbObexTransport : public StreamObexTransport {
00020
00021     typedef StreamObexTransport Base;
00022
00024     public:
00025
00027         virtual ~UsbObexTransport();
00028
00030         void Init(UsbTransport& usb_transport);
00031
00033         virtual ObexProtocol* GetProtocol(ObexProtocolId level);
00034
00036         virtual void ResolveServerAddr(const String &   server_url,
00037                                           ObexProtocolId    prot_id,
00038                                           BOOLEAN           sdb_autocreate,
00039                                           ObexOperationId   job_id) ;
00041         virtual void ResolveClientAddr(const String &   client_url,
00042                                           ObexProtocolId    prot_id,
00043                                           ObexOperationId   job_id);
00044
00045
00047         UsbObexTransport();
00048
00049     protected:
00050         virtual void OnUpdate(ObservableObject *obs_obj);
00051
00053     private:
00054
00055
00057     private:
00058
00060         ObexAddrPtr m_server_addr;
00061
00063         //StreamObexImpl m_obex_impl;
00064
00065 };
00066
00067 #endif // Apoxi_UsbObexTransport_hpp
00068
Generated on Tue Jan 24 14:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/ApoxiVoiceRecognitionVersion.cpp File Reference

AddOns/VoiceRecognition/ApoxiVoiceRecognitionVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiVoiceRecognitionVersion.cpp:

Functions

ApoxiDefVersionInfo (VoiceRecognition, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | VoiceRecognition | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:49:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/DummyVrEngineParams.cpp File Reference

AddOns/VoiceRecognition/DummyVrEngineParams.cpp File Reference

#include "PreComp.hpp"
#include "DummyVrEngineParams.hpp"

Include dependency graph for DummyVrEngineParams.cpp:

Generated on Tue Jan 24 16:49:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/DummyVrEngineParams.hpp File Reference

AddOns/VoiceRecognition/DummyVrEngineParams.hpp File Reference

#include <stack/stack.h>
#include <stack/extensions.h>
#include "VrHandler.hpp"
#include "VrEngineParams.hpp"

Include dependency graph for DummyVrEngineParams.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DummyVrEngineParams

Defines

#define | AddOns_VoiceRecognition_DummyVrEngineParams_hpp

Define Documentation

#define AddOns_VoiceRecognition_DummyVrEngineParams_hpp

Generated on Tue Jan 24 16:49:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/DummyVrEngineParams.hpp Source File

AddOns/VoiceRecognition/DummyVrEngineParams.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(AddOns_VoiceRecognition_DummyVrEngineParams_hpp)
00012 #define AddOns_VoiceRecognition_DummyVrEngineParams_hpp
00013
00014 #include <stack/stack.h>
00015 #include <stack/extensions.h>
00016
00017 #include "VrHandler.hpp"
00018 #include "VrEngineParams.hpp"
00019
00020 class DummyVrEngineParams : public VrEngineParams
00021 {
00022     public:
00024         DummyVrEngineParams();
00025
00027         virtual BOOLEAN SetMaxRecognitionTime(UINT16 time);
00028
00030         virtual BOOLEAN SetMaxSilenceTime(UINT16 time);
00031
00033         virtual BOOLEAN SetRecognitionMode(VrHandler::VrRecognitionMode mode);
00034
00036         virtual void* GetNativeParams() { return 0; };
00037
00038     private:
00039 };
00040
00041 #endif // AddOns_VoiceRecognition_DummyVrEngineParams_hpp
00042
Generated on Tue Jan 24 14:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/MsgTypes.cpp File Reference

AddOns/VoiceRecognition/MsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/MsgTypes.hpp File Reference

AddOns/VoiceRecognition/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <AddOns/VoiceRecognition/VrHandler.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VrErrorMsg
class | VrPlaybackFinishedMsg
class | VrPromptMsg
class | VrRecognitionAbortedMsg
class | VrRecognitionFailedMsg
class | VrRecognitionStoppedMsg
class | VrResultMsg
class | VrTrainingAbortedMsg
class | VrTrainingFailedMsg
class | VrTrainingResultMsg
class | VrWarningMsg

Defines

#define | VoiceRecognition_MsgTypes_hpp

Define Documentation

#define VoiceRecognition_MsgTypes_hpp

Generated on Tue Jan 24 14:56:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/MsgTypes.hpp Source File

AddOns/VoiceRecognition/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "hauth_voicerec_dv\lnz_apoxi\Apoxi\AddOns\VoiceRecognition\MsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(VoiceRecognition_MsgTypes_hpp)
00016 #define VoiceRecognition_MsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <AddOns/VoiceRecognition/VrHandler.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class VrPromptMsg
00029     ====================================================================== */
00030
00032 class VrPromptMsg : public ContextMsg {
00033     public:
00034         VrPromptMsg(ExecutionContext* context);
00035         virtual ~VrPromptMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         virtual Message* Clone() const;
00039
00040         enum  {
00041             ID = 19000
00042             };
00043
00044     private:
00045         static const MsgMetaData m_meta_data;
00046
00047     };
00048
00049
00050 /*  ======================================================================
00051     Class VrResultMsg
00052     ====================================================================== */
00053
00055 class VrResultMsg : public ContextMsg {
00056     public:
00057         VrResultMsg(ExecutionContext* context, const VrHandler::VrCommand& command, UINT32 template_id, UINT32 quality, BOOLEAN last_result);
00058         virtual ~VrResultMsg();
00059
00060         virtual const MsgMetaData& GetMetaData() const;
00061         const VrHandler::VrCommand& GetCommand() const { return m_command; }
00062         UINT32 GetTemplateId() const { return m_template_id; }
00063         UINT32 GetQuality() const { return m_quality; }
00064         BOOLEAN IsLastResult() const { return m_last_result; }
00065         virtual Message* Clone() const;
00066
00067         enum  {
00068             ID = 19001
00069             };
00070
00071     private:
00072         static const MsgMetaData m_meta_data;
00073         VrHandler::VrCommand m_command;
00074         UINT32 m_template_id;
00075         UINT32 m_quality;
00076         BOOLEAN m_last_result;
00077
00078     };
00079
00080
00081 /*  ======================================================================
00082     Class VrErrorMsg
00083     ====================================================================== */
00084
00086 class VrErrorMsg : public ContextMsg {
00087     public:
00088         VrErrorMsg(ExecutionContext* context, const VrErrorCode& error_code);
00089         virtual ~VrErrorMsg();
00090
00091         virtual const MsgMetaData& GetMetaData() const;
00092         const VrErrorCode& GetErrorCode() const { return m_error_code; }
00093         virtual Message* Clone() const;
00094
00095         enum  {
00096             ID = 19002
00097             };
00098
00099     private:
00100         static const MsgMetaData m_meta_data;
00101         VrErrorCode m_error_code;
00102
00103     };
00104
00105
00106 /*  ======================================================================
00107     Class VrWarningMsg
00108     ====================================================================== */
00109
00111 class VrWarningMsg : public ContextMsg {
00112     public:
00113         VrWarningMsg(ExecutionContext* context, const VrWarningCode& warning_code);
00114         virtual ~VrWarningMsg();
00115
00116         virtual const MsgMetaData& GetMetaData() const;
00117         const VrWarningCode& GetWarningCode() const { return m_warning_code; }
00118         virtual Message* Clone() const;
00119
00120         enum  {
00121             ID = 19003
00122             };
00123
00124     private:
00125         static const MsgMetaData m_meta_data;
00126         VrWarningCode m_warning_code;
00127
00128     };
00129
00130
00131 /*  ======================================================================
00132     Class VrRecognitionAbortedMsg
00133     ====================================================================== */
00134
00136 class VrRecognitionAbortedMsg : public ContextMsg {
00137     public:
00138         VrRecognitionAbortedMsg(ExecutionContext* context);
00139         virtual ~VrRecognitionAbortedMsg();
00140
00141         virtual const MsgMetaData& GetMetaData() const;
00142         virtual Message* Clone() const;
00143
00144         enum  {
00145             ID = 19004
00146             };
00147
00148     private:
00149         static const MsgMetaData m_meta_data;
00150
00151     };
00152
00153
00154 /*  ======================================================================
00155     Class VrTrainingAbortedMsg
00156     ====================================================================== */
00157
00159 class VrTrainingAbortedMsg : public ContextMsg {
00160     public:
00161         VrTrainingAbortedMsg(ExecutionContext* context);
00162         virtual ~VrTrainingAbortedMsg();
00163
00164         virtual const MsgMetaData& GetMetaData() const;
00165         virtual Message* Clone() const;
00166
00167         enum  {
00168             ID = 19005
00169             };
00170
00171     private:
00172         static const MsgMetaData m_meta_data;
00173
00174     };
00175
00176
00177 /*  ======================================================================
00178     Class VrRecognitionStoppedMsg
00179     ====================================================================== */
00180
00182 class VrRecognitionStoppedMsg : public ContextMsg {
00183     public:
00184         VrRecognitionStoppedMsg(ExecutionContext* context);
00185         virtual ~VrRecognitionStoppedMsg();
00186
00187         virtual const MsgMetaData& GetMetaData() const;
00188         virtual Message* Clone() const;
00189
00190         enum  {
00191             ID = 19006
00192             };
00193
00194     private:
00195         static const MsgMetaData m_meta_data;
00196
00197     };
00198
00199
00200 /*  ======================================================================
00201     Class VrTrainingResultMsg
00202     ====================================================================== */
00203
00205 class VrTrainingResultMsg : public ContextMsg {
00206     public:
00207         VrTrainingResultMsg(ExecutionContext* context, UINT32 template_id);
00208         virtual ~VrTrainingResultMsg();
00209
00210         virtual const MsgMetaData& GetMetaData() const;
00211         UINT32 GetTemplateId() const { return m_template_id; }
00212         virtual Message* Clone() const;
00213
00214         enum  {
00215             ID = 19007
00216             };
00217
00218     private:
00219         static const MsgMetaData m_meta_data;
00220         UINT32 m_template_id;
00221
00222     };
00223
00224
00225 /*  ======================================================================
00226     Class VrPlaybackFinishedMsg
00227     ====================================================================== */
00228
00230 class VrPlaybackFinishedMsg : public ContextMsg {
00231     public:
00232         VrPlaybackFinishedMsg(ExecutionContext* context, UINT32 template_id);
00233         virtual ~VrPlaybackFinishedMsg();
00234
00235         virtual const MsgMetaData& GetMetaData() const;
00236         UINT32 GetTemplateId() const { return m_template_id; }
00237         virtual Message* Clone() const;
00238
00239         enum  {
00240             ID = 19008
00241             };
00242
00243     private:
00244         static const MsgMetaData m_meta_data;
00245         UINT32 m_template_id;
00246
00247     };
00248
00249
00250 /*  ======================================================================
00251     Class VrTrainingFailedMsg
00252     ====================================================================== */
00253
00255 class VrTrainingFailedMsg : public ContextMsg {
00256     public:
00257         VrTrainingFailedMsg(ExecutionContext* context);
00258         virtual ~VrTrainingFailedMsg();
00259
00260         virtual const MsgMetaData& GetMetaData() const;
00261         virtual Message* Clone() const;
00262
00263         enum  {
00264             ID = 19009
00265             };
00266
00267     private:
00268         static const MsgMetaData m_meta_data;
00269
00270     };
00271
00272
00273 /*  ======================================================================
00274     Class VrRecognitionFailedMsg
00275     ====================================================================== */
00276
00278 class VrRecognitionFailedMsg : public ContextMsg {
00279     public:
00280         VrRecognitionFailedMsg(ExecutionContext* context);
00281         virtual ~VrRecognitionFailedMsg();
00282
00283         virtual const MsgMetaData& GetMetaData() const;
00284         virtual Message* Clone() const;
00285
00286         enum  {
00287             ID = 19010
00288             };
00289
00290     private:
00291         static const MsgMetaData m_meta_data;
00292
00293     };
00294
00295 #endif // VoiceRecognition_MsgTypes_hpp
00296
Generated on Tue Jan 24 14:44:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/PreComp.cpp File Reference

AddOns/VoiceRecognition/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/PreComp.hpp File Reference

AddOns/VoiceRecognition/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/StackMsgArgument.hpp>
#include <Apc/Message.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/PreComp.hpp Source File

AddOns/VoiceRecognition/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Apc/StackMsgArgument.hpp>
00012 #include <Apc/Message.hpp>
00013
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/TelecaVrEngineParams.cpp File Reference

AddOns/VoiceRecognition/TelecaVrEngineParams.cpp File Reference

#include "PreComp.hpp"
#include "TelecaVrEngineParams.hpp"

Include dependency graph for TelecaVrEngineParams.cpp:

Generated on Tue Jan 24 16:49:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/TelecaVrEngineParams.hpp File Reference

AddOns/VoiceRecognition/TelecaVrEngineParams.hpp File Reference

#include <stack/stack.h>
#include <stack/extensions.h>
#include "VrHandler.hpp"
#include "VrEngineParams.hpp"

Include dependency graph for TelecaVrEngineParams.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TelecaVrEngineParams

Defines

#define | AddOns_VoiceRecognition_TelecaVrEngineParams_hpp

Define Documentation

#define AddOns_VoiceRecognition_TelecaVrEngineParams_hpp

Generated on Tue Jan 24 16:49:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/TelecaVrEngineParams.hpp Source File

AddOns/VoiceRecognition/TelecaVrEngineParams.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(AddOns_VoiceRecognition_TelecaVrEngineParams_hpp)
00012 #define AddOns_VoiceRecognition_TelecaVrEngineParams_hpp
00013
00014 #include <stack/stack.h>
00015 #include <stack/extensions.h>
00016
00017 #include "VrHandler.hpp"
00018 #include "VrEngineParams.hpp"
00019
00020 class TelecaVrEngineParams : public VrEngineParams
00021 {
00022     public:
00024         TelecaVrEngineParams();
00025
00027         virtual BOOLEAN SetMaxRecognitionTime(UINT16 time);
00028
00030         virtual BOOLEAN SetMaxSilenceTime(UINT16 time);
00031
00033         virtual BOOLEAN SetRecognitionMode(VrHandler::VrRecognitionMode mode);
00034
00036         virtual void* GetNativeParams() { return (void*)&m_params; };
00037
00038     private:
00039         ParamData   m_params;
00040 };
00041
00042 #endif // AddOns_VoiceRecognition_TelecaVrEngineParams_hpp
00043
Generated on Tue Jan 24 14:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrConfig.cpp File Reference

AddOns/VoiceRecognition/VrConfig.cpp File Reference

#include "PreComp.hpp"
#include "VrConfig.hpp"
#include "VrEngineParams.hpp"
#include "DummyVrEngineParams.hpp"

Include dependency graph for VrConfig.cpp:

Generated on Tue Jan 24 16:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrConfig.hpp File Reference

AddOns/VoiceRecognition/VrConfig.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define AddOns_VoiceRecognition_VrConfig_hpp

Define Documentation

#define AddOns_VoiceRecognition_VrConfig_hpp

Generated on Tue Jan 24 16:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrConfig.hpp Source File

AddOns/VoiceRecognition/VrConfig.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(AddOns_VoiceRecognition_VrConfig_hpp)
00011 #define AddOns_VoiceRecognition_VrConfig_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <stack/stack.h>
00016 #include <stack/extensions.h>
00017 #include <Kernel/Types.hpp>
00018
00019 class VrEngineParams;
00020
00021 class VrConfig  {
00022
00023  public:
00024     static VrEngineParams* GetVrEngineParams();
00025     static WString GetStoragePath();
00026
00027 };
00028
00029 #endif // DOXYGEN_SHOULD_SKIP_THIS
00030
00031 #endif // AddOns_VoiceRecognition_VrConfig_hpp
00032
00033
Generated on Tue Jan 24 14:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrData.cpp File Reference

AddOns/VoiceRecognition/VrData.cpp File Reference

#include "PreComp.hpp"
#include "VrData.hpp"
#include "VrConfig.hpp"
#include <Kernel/Os/SemObtainer.hpp>
#include <Adc/Pathname.hpp>
#include <Adc/RootFileSystem.hpp>
#include <Adc/File.hpp>

Include dependency graph for VrData.cpp:

Generated on Tue Jan 24 16:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrData.hpp File Reference

AddOns/VoiceRecognition/VrData.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define AddOns_VoiceRecognition_VrData_hpp

Define Documentation

#define AddOns_VoiceRecognition_VrData_hpp

Generated on Tue Jan 24 16:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrData.hpp Source File

AddOns/VoiceRecognition/VrData.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(AddOns_VoiceRecognition_VrData_hpp)
00011 #define AddOns_VoiceRecognition_VrData_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Semaphore.hpp>
00016
00017 #include <stack/extensions.h>
00018
00019 #include <Auxiliary/SimpleMap.hpp>
00020 #include <Auxiliary/Vector.hpp>
00021
00022 #include "VrHandler.hpp"
00023
00024 #define INVALID_COMMAND_ID 65535
00025 class VrTemplate;
00026
00028
00031 class VrData
00032 {
00033
00034  public:
00035
00036 //  typedef SimpleMap<WString, Vector<UINT16> > TemplateMap;
00038     enum VrState {
00039         Undefined,
00040         Idle,
00041         Recognition,
00042         Training,
00043         Playback
00044     };
00045
00046     static VrData* GetInstance();
00047
00049     virtual ~VrData();
00050
00052     static VrState GetVrState();
00053
00055     static void SetVrState(VrState vr_state);
00056
00058
00064     static BOOLEAN ChangeVrState(VrState from, VrState to);
00065
00067     static BOOLEAN IsRepeatedMode() { return FALSE; // repated mode not supported for now return m_repeated_mode;
00068     }
00069
00071     static void SetRepeatedMode(BOOLEAN repeated_mode) { m_repeated_mode = repeated_mode; }
00072
00074 //  static const ParamData& GetVrEngineParams() { return m_vr_engine_params; }
00075
00077     static VrHandler::VrApiRc GetNextTemplateId(UINT16& template_id);
00078
00080     static VrHandler::VrApiRc GetLastTemplateId(UINT16& template_id);
00081
00083     void Reset();
00084
00086     VrHandler::VrCommand GetCommand(UINT16 template_id);
00087
00088     // Add a template to template list
00089     void AddTemplate(VrTemplate* templ) { m_template_store.PushFront(templ); }
00090
00092     const UINT16* GetTemplateIdsPtr() { return m_template_ids; }
00093
00095     void SetTemplateIds(const Vector<UINT16>& id_set);
00096
00098 //  void SetAudResource(UINT8 handle) { m_aud_resource = handle; }
00099     void SetPlaybackActiveRef(SharedPtr<AudioActiveReference> ref, UINT32 template_id);
00100
00102 //  UINT8 GetAudResource() { return m_aud_resource; }
00103     SharedPtr<AudioActiveReference> GetPlaybackActiveRef() { return m_playback_active_ref; }
00104     UINT32 GetPlaybackTemplateId() { return m_playback_id; }
00105
00107     VrTemplate::VrFileIoRc StoreAppTemplateId(const WString& app_name, UINT16 template_id);
00108
00110     VrTemplate::VrFileIoRc RemoveAppTemplateId(const WString& app_name, UINT16 template_id);
00111
00113     VrTemplate::VrFileIoRc RemoveAllAppTemplateIds(const WString& app_name);
00114
00116     void SetPendingAppName(const WString& app_name) { m_pending_app_name = app_name; };
00117
00119     const WString& GetPendingAppName() { return m_pending_app_name; }
00120
00122     const Vector<UINT16>& GetAppTemplateIds(const WString& app_name);
00123
00125     void EmptyEngineProperties();
00126
00128     const Vector<VrProperty>& GetEngineProperties() { return m_engine_properties; }
00129
00131     void AddEngineProperty(VrProperty property) { m_engine_properties.PushBack(property); }
00132
00133  private:
00134
00136     VrData();
00137
00139     void CleanUpTemplateList();
00140
00142     VrTemplate::VrFileIoRc WriteAppTemplateData();
00143
00145     VrTemplate::VrFileIoRc LoadAppTemplateData();
00146
00148     void AddAppTemplateId(const WString& app_name, UINT16 template_id);
00149
00151     VrTemplate::VrFileIoRc EraseTemplateFiles(UINT16 template_id);
00152
00154     VrTemplate::VrFileIoRc EraseTemplateFile(const WString& file_name);
00155
00157 //  VrTemplate::VrFileIoRc LoadVrParameters();
00158
00160 //  VrTemplate::VrFileIoRc WriteVrParameters();
00161
00163     static VrData* m_instance;
00164
00166     static VrState m_vr_state;
00167
00169     static BOOLEAN m_repeated_mode;
00170
00172     static VrHandler::VrCommand m_fixed_commands[29];
00173
00175     static UINT16 m_next_template_id;
00176
00178     UINT16* m_template_ids;
00179
00181 //  UINT8       m_aud_resource;
00182     SharedPtr<AudioActiveReference> m_playback_active_ref;
00183     UINT32  m_playback_id;
00184
00186     LinkedList<VrTemplate> m_template_store;
00187
00189     SimpleMap<WString, Vector<UINT16> > m_app_templates;
00190 //  TemplateMap m_app_templates;
00191
00193     WString m_pending_app_name;
00194
00196     Vector<VrProperty> m_engine_properties;
00197
00199     Semaphore m_semaphore;
00200 };
00201
00202 #endif // DOXYGEN_SHOULD_SKIP_THIS
00203
00204 #endif // AddOns_VoiceRecognition_VrData_hpp
00205
00206
Generated on Tue Jan 24 14:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrDispatcher.cpp File Reference

AddOns/VoiceRecognition/VrDispatcher.cpp File Reference

#include "PreComp.hpp"
#include "VrDispatcher.hpp"
#include <Kernel/Trace.hpp>
#include <Asc/Lib.hpp>
#include <Adc/Pathname.hpp>
#include <Adc/File.hpp>
#include <Adc/RootFileSystem.hpp>
#include <Audio/AudioActiveReference.hpp>
#include <Audio/Messages/AudioStoppedMsg.hpp>
#include "VrHostController.hpp"
#include "VrTemplateData.hpp"
#include "VrHandler.hpp"
#include "MsgTypes.hpp"
#include "VrData.hpp"
#include "VrStackMsgArgs.hpp"

Include dependency graph for VrDispatcher.cpp:

Generated on Tue Jan 24 16:49:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrDispatcher.hpp File Reference

AddOns/VoiceRecognition/VrDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:49:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrDispatcher.hpp Source File

AddOns/VoiceRecognition/VrDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002   Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003   All rights reserved.
00004   ------------------------------------------------------------------------
00005   This document contains proprietary information belonging to COMNEON.
00006   Passing on and copying of this document, use and communication of its
00007   contents is not permitted without prior written authorisation.
00008   ------------------------------------------------------------------------ */
00009 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00010
00011 #if !defined(AddOns_VoiceRecognition_VrDispatcher_hpp)
00012 #define AddOns_VoiceRecognition_VrDispatcher_hpp
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Kernel/Message.hpp>
00018 #include <Asc/StackMsgDispatcher.hpp>
00019 #include <Auxiliary/LinkedList.hpp>
00020 #include <Auxiliary/Linkable.hpp>
00021
00022 #include "VrTemplateData.hpp"
00023
00024 class VrData;
00025 class VrHandler;
00026
00036 class VrDispatcher : public StackMsgDispatcher
00037 {
00040     typedef StackMsgDispatcher Base;
00041     friend VrHandler;
00042
00043  public:
00048     VrDispatcher();
00049
00050     virtual ~VrDispatcher();
00051
00052     void SetHandler(VrHandler* vr_handler) {
00053         m_vr_handler = vr_handler;
00054     }
00055
00056     BOOLEAN OnLoadTemplateReq(const StackMsgArgument &arg);
00057     BOOLEAN OnSayNameInd(const StackMsgArgument &arg);
00058     BOOLEAN OnErrorInd(const StackMsgArgument &arg);
00059     BOOLEAN OnWarningInd(const StackMsgArgument &arg);
00060     BOOLEAN OnVrIntrmRecogResultInd(const StackMsgArgument &arg);
00061     BOOLEAN OnVrRecogResultInd(const StackMsgArgument &arg);
00062     BOOLEAN OnVrAbortEngineInd(const StackMsgArgument &arg);
00063     BOOLEAN OnVrStoreTemplateReq(const StackMsgArgument &arg);
00064     BOOLEAN OnVrTrainResultInd(const StackMsgArgument &arg);
00065     BOOLEAN OnVrStopRecogIndArg(const StackMsgArgument &arg);
00066     BOOLEAN OnVrG2AResultInd(const StackMsgArgument &arg);
00067
00068     // audio callback for playback end
00069     static void OnAudioMessageCallback(const Message* message, void* pUserData);
00070
00071  private:
00072
00076     static const StackMsgArgMap<VrDispatcher> m_arg_map[];
00077
00080     StackMsgArgMapContainer<VrDispatcher> m_arg_map_container;
00081
00082     VrHandler*  m_vr_handler;
00083
00084     VrData*     m_vr_data;
00085
00086
00087 };
00088
00090 #endif // AddOns_VoiceRecognition_VrDispatcher_hpp
00091
00092 #endif // DOXYGEN_SHOULD_SKIP_THIS
00093
Generated on Tue Jan 24 14:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrEngineParams.cpp File Reference

AddOns/VoiceRecognition/VrEngineParams.cpp File Reference

Generated on Tue Jan 24 16:49:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrEngineParams.hpp File Reference

AddOns/VoiceRecognition/VrEngineParams.hpp File Reference

#include "VrHandler.hpp"

Include dependency graph for VrEngineParams.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VrEngineParams

Defines

#define | AddOns_VoiceRecognition_VrEngineParams_hpp

Define Documentation

#define AddOns_VoiceRecognition_VrEngineParams_hpp

Generated on Tue Jan 24 16:49:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrEngineParams.hpp Source File

AddOns/VoiceRecognition/VrEngineParams.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(AddOns_VoiceRecognition_VrEngineParams_hpp)
00012 #define AddOns_VoiceRecognition_VrEngineParams_hpp
00013
00014 #include "VrHandler.hpp"
00015
00016 class VrEngineParams
00017 {
00018     public:
00020         virtual BOOLEAN SetMaxRecognitionTime(UINT16 time) = 0;
00021
00023         virtual BOOLEAN SetMaxSilenceTime(UINT16 time) = 0;
00024
00026         virtual BOOLEAN SetRecognitionMode(VrHandler::VrRecognitionMode mode) = 0;
00027
00029         virtual void* GetNativeParams() = 0;
00030
00031 };
00032
00033 #endif // AddOns_VoiceRecognition_VrEngineParams_hpp
00034
Generated on Tue Jan 24 14:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrHandler.cpp File Reference

AddOns/VoiceRecognition/VrHandler.cpp File Reference

#include "PreComp.hpp"
#include <Asc/Lib.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <stack/driver.h>
#include "VrStackMsgArgs.hpp"
#include "VrHostController.hpp"
#include "VrHandler.hpp"
#include "VrTemplateData.hpp"
#include "MsgTypes.hpp"
#include "VrData.hpp"
#include "VrStackMsgArgTable.hpp"
#include "VrConfig.hpp"
#include "VrEngineParams.hpp"

Include dependency graph for VrHandler.cpp:

Generated on Tue Jan 24 16:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrHandler.hpp File Reference

AddOns/VoiceRecognition/VrHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/BaseHandler.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/StreamAudioPlayer.hpp>
#include <Audio/AudioActiveReference.hpp>
#include <stack/extensions.h>
#include "VrTypes.hpp"
#include "VrDispatcher.hpp"
#include "VrWaitDispatcher.hpp"

Include dependency graph for VrHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VrHandler
Interface for Apoxi VR usage. More...

Defines

#define | AddOns_VoiceRecognition_VrHandler_hpp

Define Documentation

#define AddOns_VoiceRecognition_VrHandler_hpp

Generated on Tue Jan 24 16:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrHandler.hpp Source File

AddOns/VoiceRecognition/VrHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(AddOns_VoiceRecognition_VrHandler_hpp)
00011 #define AddOns_VoiceRecognition_VrHandler_hpp
00012
00144
00145
00146 #include <Kernel/Types.hpp>
00147 #include <Asc/BaseHandler.hpp>
00148 #include <Audio/StreamAudioReference.hpp>
00149 #include <Audio/StreamAudioPlayer.hpp>
00150 #include <Audio/AudioActiveReference.hpp>
00151 #include <stack/extensions.h>
00152
00153 #include "VrTypes.hpp"
00154 #include "VrDispatcher.hpp"
00155 #include "VrWaitDispatcher.hpp"
00156
00157
00158 class VrData;
00159
00160
00167 class VrHandler : public BaseHandler {
00168
00171     typedef BaseHandler Base;
00172     friend VrDispatcher;
00173
00174  public:
00178     enum { ID = VrHandlerId };
00179
00181     enum VrApiRc {
00182         VrSuccess,
00183         VrFailed
00184     };
00185
00187     enum VrCommand {
00188         // keep order, range operations are done
00189         Digit0,
00190         Digit1,
00191         Digit2,
00192         Digit3,
00193         Digit4,
00194         Digit5,
00195         Digit6,
00196         Digit7,
00197         Digit8,
00198         Digit9,
00199         Dial,
00200         Cancel,
00201         Clear,
00202         TrainedCommand,
00203         InvalidCommand
00204     };
00205
00207
00211     enum VrRecognitionMode {
00212         IsolatedWord,
00213         ConnectedWord
00214     };
00215
00217
00222     enum VrCommandSet {
00223         Digits,         // only digits 0-9
00224         DigitDialing,   // digits 0-9, Dial, Cancel, Clear
00225         Complete        // all known commands
00226
00227 // perhaps coming sometime
00228 //      Characters      // all characters a-z, A-Z
00229 //      LowerCase       // all lowercase characters a-z
00230 //      UpperCase       // all uppercase characters A-Z
00231     };
00232
00237     VrHandler();
00238
00240     virtual ~VrHandler();
00241
00245     virtual HandlerId GetHandlerId() const;
00246
00250     static BOOLEAN Startup();
00251
00257     VrApiRc InitVr();
00258
00270     void StartRecognition(const Vector<UINT16>& id_set, VrRecognitionMode mode = ConnectedWord, UINT16 max_time = 700, UINT32 max_silence = 80);
00271
00277     void StartRecording();
00278
00280 //  void StopRepeatedRecognition();
00281
00288     VrApiRc StopRecognition();
00289
00295     VrApiRc Abort();
00296
00303     VrCommand GetCommand(UINT16 template_id);
00304
00317     VrApiRc PlayTemplate(UINT16 template_id);
00318
00328     VrApiRc GetAppTemplates(const WString& client_name, Vector<UINT16>& template_ids);
00329
00331
00340     VrApiRc GetCommandTemplates(VrCommandSet set, Vector<UINT16>& template_ids);
00341
00343
00351     VrApiRc RemoveTemplate(const WString& client_name, UINT16 template_id);
00352
00354
00360     VrApiRc RemoveAllTemplates(const WString& client_name);
00361
00363
00372     void StartTraining(const WString& client_name);
00373
00381     void CreateTemplate(const WString& client_name, const WString& text);
00382
00390     BOOLEAN IsSupported(VrProperty property);
00391
00392  protected:
00393     void Reset();
00394     VrApiRc Abort(BOOLEAN send_message);
00395     void Error(VrErrorCode error_code);
00396
00397
00398  private:
00399
00401     void StartTraining(const WString& app_name, VrCommand command);
00402
00404     VrHandler::VrApiRc SetParameters(void* params);
00405
00407
00409     VrHandler::VrApiRc GetProperties();
00410
00411     VrDispatcher        m_vr_dispatcher;
00412
00414     UINT16*             m_template_ids;
00415
00417     VrData*             m_vr_data;
00418
00420     SharedPtr<StreamAudioReference> m_audio_ref;
00421
00423     StreamAudioPlayer* m_audio_player;
00424
00426     SharedPtr<AudioActiveReference> m_player_ref;
00427 };
00428
00429 #endif // AddOns_VoiceRecognition_VrHandler_hpp
00430
00431
Generated on Tue Jan 24 14:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrHostController.cpp File Reference

AddOns/VoiceRecognition/VrHostController.cpp File Reference

#include "PreComp.hpp"
#include "VrStackMsgArgs.hpp"
#include "VrHostController.hpp"
#include <Auxiliary/ByteBuffer.hpp>
#include <Kernel/Trace.hpp>

Include dependency graph for VrHostController.cpp:

Generated on Tue Jan 24 16:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrHostController.hpp File Reference

AddOns/VoiceRecognition/VrHostController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define AddOns_VoiceRecognition_VrHostController_hpp

Define Documentation

#define AddOns_VoiceRecognition_VrHostController_hpp

Generated on Tue Jan 24 16:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrHostController.hpp Source File

AddOns/VoiceRecognition/VrHostController.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(AddOns_VoiceRecognition_VrHostController_hpp)
00011 #define AddOns_VoiceRecognition_VrHostController_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <stack/stack.h>
00016 #include <stack/extensions.h>
00017 #include <Kernel/Types.hpp>
00018
00019 class ByteBuffer;
00020
00021 class VrHostController  {
00022  public:
00023
00025
00027     static void VrInit();
00028
00030     static void VrSendEngineParams(void* params);
00031
00033     static void VrSendTemplate(UINT32 id, const UINT16* templ, BOOLEAN trained);
00034
00036     static void VrStartRecognition(const UINT16* templates);
00037
00039     static void VrStartRecording();
00040
00042     static void VrSetRepeatedMode();
00043
00045     static void VrQuitRepeatedMode();
00046
00048     static void VrStopRecognition();
00049
00051     static void VrAbort();
00052
00054     static void VrStartTraining();
00055
00057     static void VrCreateG2ATemplate(const WString& text);
00058
00060     static void VrFinishTraining();
00061
00063     static void VrRequestProperties();
00064
00065  private:
00066 /*typedef void (*VrCallbackFunc) (SDL_Pid ,         // sender ID
00067                 ax_vr_even_enum ,   // Signal from VR_host to APOXI
00068                 ubyte ,         // return code (not used)
00069                 UINT32 ,        // parameter 1
00070                                 UINT32 ,        // parameter 2
00071                                 UINT32 ,        // parameter 3
00072                                 UINT32 ,        // parameter 4
00073                                 UINT8 * ,       // pointer to data
00074                                 UINT8 * );      // pointer to PCM data*/
00075
00077
00080     static void VrHostCallback(SDL_Pid sdl_pid, UINT16 event, char rc,
00081                                UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4,
00082                                UINT8* ptr1, UINT8* ptr2);
00083
00084
00086     static SDL_Pid m_pid;
00087     static UINT16* m_ptemplate_ids;
00088 };
00089
00090 #endif // DOXYGEN_SHOULD_SKIP_THIS
00091
00092 #endif // AddOns_VoiceRecognition_VrHostController_hpp
00093
00094
Generated on Tue Jan 24 14:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrStackMsgArgs.cpp File Reference

AddOns/VoiceRecognition/VrStackMsgArgs.cpp File Reference

#include "PreComp.hpp"
#include "VrStackMsgArgs.hpp"

Include dependency graph for VrStackMsgArgs.cpp:

Generated on Tue Jan 24 16:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrStackMsgArgs.hpp File Reference

AddOns/VoiceRecognition/VrStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <AddOns/VoiceRecognition/VrHandler.hpp>

Include dependency graph for VrStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VrAbortEngineIndArg
class | VrErrorIndArg
class | VrG2AResultIndArg
class | VrInitCnfArg
class | VrIntrmRecResultIndArg
class | VrLoadTemplateReqArg
class | VrParamReqArg
class | VrPropertyResultIndArg
class | VrRecogResultIndArg
class | VrSayNameIndArg
class | VrStopRecogIndArg
class | VrStoreTemplateReqArg
class | VrTrainResultIndArg
class | VrWarningIndArg

Defines

#define | AddOns_VoiceRecognition_VrStackMsgArgs_hpp

Define Documentation

#define AddOns_VoiceRecognition_VrStackMsgArgs_hpp

Generated on Tue Jan 24 16:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrStackMsgArgs.hpp Source File

AddOns/VoiceRecognition/VrStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "hauth_voicerec_dv\lnz_apoxi\Apoxi\AddOns\VoiceRecognition\VrArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_VoiceRecognition_VrStackMsgArgs_hpp)
00016 #define AddOns_VoiceRecognition_VrStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <AddOns/VoiceRecognition/VrHandler.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class VrParamReqArg
00028     ====================================================================== */
00029
00031 class VrParamReqArg : public StackMsgArgument {
00032     friend class VrStackMsgArgTableDestroyTableNode;
00033     public:
00034         VrParamReqArg();
00035         ~VrParamReqArg();
00036
00037         static const VrParamReqArg& Cast(const StackMsgArgument& arg);
00038
00039         enum  {
00040             ID = 5000
00041             };
00042
00043     private:
00044
00045         static void Destroy(StackMsgArgument* arg) { delete ((VrParamReqArg*) arg); }
00046
00047     };
00048
00049 // Inline definitions
00050 inline const VrParamReqArg& VrParamReqArg::Cast(const StackMsgArgument& arg) {
00051     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrParamReqArg!\n");
00052     return ((VrParamReqArg &) arg);
00053 }
00054
00055
00056
00057 /*  ======================================================================
00058     Class VrInitCnfArg
00059     ====================================================================== */
00060
00062 class VrInitCnfArg : public StackMsgArgument {
00063     friend class VrStackMsgArgTableDestroyTableNode;
00064     public:
00065         VrInitCnfArg();
00066         ~VrInitCnfArg();
00067
00068         static const VrInitCnfArg& Cast(const StackMsgArgument& arg);
00069
00070         enum  {
00071             ID = 5001
00072             };
00073
00074     private:
00075
00076         static void Destroy(StackMsgArgument* arg) { delete ((VrInitCnfArg*) arg); }
00077
00078     };
00079
00080 // Inline definitions
00081 inline const VrInitCnfArg& VrInitCnfArg::Cast(const StackMsgArgument& arg) {
00082     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrInitCnfArg!\n");
00083     return ((VrInitCnfArg &) arg);
00084 }
00085
00086
00087
00088 /*  ======================================================================
00089     Class VrLoadTemplateReqArg
00090     ====================================================================== */
00091
00093 class VrLoadTemplateReqArg : public StackMsgArgument {
00094     friend class VrStackMsgArgTableDestroyTableNode;
00095     public:
00096         VrLoadTemplateReqArg(UINT32 template_id);
00097         VrLoadTemplateReqArg();
00098         ~VrLoadTemplateReqArg();
00099
00100         static const VrLoadTemplateReqArg& Cast(const StackMsgArgument& arg);
00101         UINT32 GetTemplateId() const { return m_template_id; }
00102
00103         enum  {
00104             ID = 5002
00105             };
00106
00107     private:
00108
00109         static void Destroy(StackMsgArgument* arg) { delete ((VrLoadTemplateReqArg*) arg); }
00110
00111         UINT32 m_template_id;
00112
00113     };
00114
00115 // Inline definitions
00116 inline const VrLoadTemplateReqArg& VrLoadTemplateReqArg::Cast(const StackMsgArgument& arg) {
00117     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrLoadTemplateReqArg!\n");
00118     return ((VrLoadTemplateReqArg &) arg);
00119 }
00120
00121
00122
00123 /*  ======================================================================
00124     Class VrSayNameIndArg
00125     ====================================================================== */
00126
00128 class VrSayNameIndArg : public StackMsgArgument {
00129     friend class VrStackMsgArgTableDestroyTableNode;
00130     public:
00131         VrSayNameIndArg();
00132         ~VrSayNameIndArg();
00133
00134         static const VrSayNameIndArg& Cast(const StackMsgArgument& arg);
00135
00136         enum  {
00137             ID = 5003
00138             };
00139
00140     private:
00141
00142         static void Destroy(StackMsgArgument* arg) { delete ((VrSayNameIndArg*) arg); }
00143
00144     };
00145
00146 // Inline definitions
00147 inline const VrSayNameIndArg& VrSayNameIndArg::Cast(const StackMsgArgument& arg) {
00148     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrSayNameIndArg!\n");
00149     return ((VrSayNameIndArg &) arg);
00150 }
00151
00152
00153
00154 /*  ======================================================================
00155     Class VrIntrmRecResultIndArg
00156     ====================================================================== */
00157
00159 class VrIntrmRecResultIndArg : public StackMsgArgument {
00160     friend class VrStackMsgArgTableDestroyTableNode;
00161     public:
00162         VrIntrmRecResultIndArg(UINT32 template_id, UINT32 quality);
00163         VrIntrmRecResultIndArg();
00164         ~VrIntrmRecResultIndArg();
00165
00166         static const VrIntrmRecResultIndArg& Cast(const StackMsgArgument& arg);
00167         UINT32 GetTemplateId() const { return m_template_id; }
00168         UINT32 GetQuality() const { return m_quality; }
00169
00170         enum  {
00171             ID = 5004
00172             };
00173
00174     private:
00175
00176         static void Destroy(StackMsgArgument* arg) { delete ((VrIntrmRecResultIndArg*) arg); }
00177
00178         UINT32 m_template_id;
00179         UINT32 m_quality;
00180
00181     };
00182
00183 // Inline definitions
00184 inline const VrIntrmRecResultIndArg& VrIntrmRecResultIndArg::Cast(const StackMsgArgument& arg) {
00185     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrIntrmRecResultIndArg!\n");
00186     return ((VrIntrmRecResultIndArg &) arg);
00187 }
00188
00189
00190
00191 /*  ======================================================================
00192     Class VrRecogResultIndArg
00193     ====================================================================== */
00194
00196 class VrRecogResultIndArg : public StackMsgArgument {
00197     friend class VrStackMsgArgTableDestroyTableNode;
00198     public:
00199         VrRecogResultIndArg(UINT32 template_id, UINT32 quality);
00200         VrRecogResultIndArg();
00201         ~VrRecogResultIndArg();
00202
00203         static const VrRecogResultIndArg& Cast(const StackMsgArgument& arg);
00204         UINT32 GetTemplateId() const { return m_template_id; }
00205         UINT32 GetQuality() const { return m_quality; }
00206
00207         enum  {
00208             ID = 5005
00209             };
00210
00211     private:
00212
00213         static void Destroy(StackMsgArgument* arg) { delete ((VrRecogResultIndArg*) arg); }
00214
00215         UINT32 m_template_id;
00216         UINT32 m_quality;
00217
00218     };
00219
00220 // Inline definitions
00221 inline const VrRecogResultIndArg& VrRecogResultIndArg::Cast(const StackMsgArgument& arg) {
00222     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrRecogResultIndArg!\n");
00223     return ((VrRecogResultIndArg &) arg);
00224 }
00225
00226
00227
00228 /*  ======================================================================
00229     Class VrTrainResultIndArg
00230     ====================================================================== */
00231
00233 class VrTrainResultIndArg : public StackMsgArgument {
00234     friend class VrStackMsgArgTableDestroyTableNode;
00235     public:
00236         VrTrainResultIndArg();
00237         ~VrTrainResultIndArg();
00238
00239         static const VrTrainResultIndArg& Cast(const StackMsgArgument& arg);
00240
00241         enum  {
00242             ID = 5006
00243             };
00244
00245     private:
00246
00247         static void Destroy(StackMsgArgument* arg) { delete ((VrTrainResultIndArg*) arg); }
00248
00249     };
00250
00251 // Inline definitions
00252 inline const VrTrainResultIndArg& VrTrainResultIndArg::Cast(const StackMsgArgument& arg) {
00253     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrTrainResultIndArg!\n");
00254     return ((VrTrainResultIndArg &) arg);
00255 }
00256
00257
00258
00259 /*  ======================================================================
00260     Class VrAbortEngineIndArg
00261     ====================================================================== */
00262
00264 class VrAbortEngineIndArg : public StackMsgArgument {
00265     friend class VrStackMsgArgTableDestroyTableNode;
00266     public:
00267         VrAbortEngineIndArg();
00268         ~VrAbortEngineIndArg();
00269
00270         static const VrAbortEngineIndArg& Cast(const StackMsgArgument& arg);
00271
00272         enum  {
00273             ID = 5007
00274             };
00275
00276     private:
00277
00278         static void Destroy(StackMsgArgument* arg) { delete ((VrAbortEngineIndArg*) arg); }
00279
00280     };
00281
00282 // Inline definitions
00283 inline const VrAbortEngineIndArg& VrAbortEngineIndArg::Cast(const StackMsgArgument& arg) {
00284     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrAbortEngineIndArg!\n");
00285     return ((VrAbortEngineIndArg &) arg);
00286 }
00287
00288
00289
00290 /*  ======================================================================
00291     Class VrStopRecogIndArg
00292     ====================================================================== */
00293
00295 class VrStopRecogIndArg : public StackMsgArgument {
00296     friend class VrStackMsgArgTableDestroyTableNode;
00297     public:
00298         VrStopRecogIndArg();
00299         ~VrStopRecogIndArg();
00300
00301         static const VrStopRecogIndArg& Cast(const StackMsgArgument& arg);
00302
00303         enum  {
00304             ID = 5008
00305             };
00306
00307     private:
00308
00309         static void Destroy(StackMsgArgument* arg) { delete ((VrStopRecogIndArg*) arg); }
00310
00311     };
00312
00313 // Inline definitions
00314 inline const VrStopRecogIndArg& VrStopRecogIndArg::Cast(const StackMsgArgument& arg) {
00315     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrStopRecogIndArg!\n");
00316     return ((VrStopRecogIndArg &) arg);
00317 }
00318
00319
00320
00321 /*  ======================================================================
00322     Class VrStoreTemplateReqArg
00323     ====================================================================== */
00324
00326 class VrStoreTemplateReqArg : public StackMsgArgument {
00327     friend class VrStackMsgArgTableDestroyTableNode;
00328     public:
00329         VrStoreTemplateReqArg(UINT16* template_data, UINT32 template_data_length, UINT8* playback_samples, UINT32 sample_data_length);
00330         VrStoreTemplateReqArg();
00331         ~VrStoreTemplateReqArg();
00332
00333         static const VrStoreTemplateReqArg& Cast(const StackMsgArgument& arg);
00334         UINT16* GetTemplateData() const { return m_template_data; }
00335         UINT32 GetTemplateDataLength() const { return m_template_data_length; }
00336         UINT8* GetPlaybackSamples() const { return m_playback_samples; }
00337         UINT32 GetSampleDataLength() const { return m_sample_data_length; }
00338
00339         enum  {
00340             ID = 5009
00341             };
00342
00343     private:
00344
00345         static void Destroy(StackMsgArgument* arg) { delete ((VrStoreTemplateReqArg*) arg); }
00346
00347         UINT16* m_template_data;
00348         UINT32 m_template_data_length;
00349         UINT8* m_playback_samples;
00350         UINT32 m_sample_data_length;
00351
00352     };
00353
00354 // Inline definitions
00355 inline const VrStoreTemplateReqArg& VrStoreTemplateReqArg::Cast(const StackMsgArgument& arg) {
00356     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrStoreTemplateReqArg!\n");
00357     return ((VrStoreTemplateReqArg &) arg);
00358 }
00359
00360
00361
00362 /*  ======================================================================
00363     Class VrG2AResultIndArg
00364     ====================================================================== */
00365
00367 class VrG2AResultIndArg : public StackMsgArgument {
00368     friend class VrStackMsgArgTableDestroyTableNode;
00369     public:
00370         VrG2AResultIndArg(UINT16* template_data, UINT32 template_data_length);
00371         VrG2AResultIndArg();
00372         ~VrG2AResultIndArg();
00373
00374         static const VrG2AResultIndArg& Cast(const StackMsgArgument& arg);
00375         UINT16* GetTemplateData() const { return m_template_data; }
00376         UINT32 GetTemplateDataLength() const { return m_template_data_length; }
00377
00378         enum  {
00379             ID = 5012
00380             };
00381
00382     private:
00383
00384         static void Destroy(StackMsgArgument* arg) { delete ((VrG2AResultIndArg*) arg); }
00385
00386         UINT16* m_template_data;
00387         UINT32 m_template_data_length;
00388
00389     };
00390
00391 // Inline definitions
00392 inline const VrG2AResultIndArg& VrG2AResultIndArg::Cast(const StackMsgArgument& arg) {
00393     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrG2AResultIndArg!\n");
00394     return ((VrG2AResultIndArg &) arg);
00395 }
00396
00397
00398
00399 /*  ======================================================================
00400     Class VrErrorIndArg
00401     ====================================================================== */
00402
00404 class VrErrorIndArg : public StackMsgArgument {
00405     friend class VrStackMsgArgTableDestroyTableNode;
00406     public:
00407         VrErrorIndArg(const VrErrorCode& error_code);
00408         VrErrorIndArg();
00409         ~VrErrorIndArg();
00410
00411         static const VrErrorIndArg& Cast(const StackMsgArgument& arg);
00412         const VrErrorCode& GetErrorCode() const { return m_error_code; }
00413
00414         enum  {
00415             ID = 5010
00416             };
00417
00418     private:
00419
00420         static void Destroy(StackMsgArgument* arg) { delete ((VrErrorIndArg*) arg); }
00421
00422         VrErrorCode m_error_code;
00423
00424     };
00425
00426 // Inline definitions
00427 inline const VrErrorIndArg& VrErrorIndArg::Cast(const StackMsgArgument& arg) {
00428     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrErrorIndArg!\n");
00429     return ((VrErrorIndArg &) arg);
00430 }
00431
00432
00433
00434 /*  ======================================================================
00435     Class VrWarningIndArg
00436     ====================================================================== */
00437
00439 class VrWarningIndArg : public StackMsgArgument {
00440     friend class VrStackMsgArgTableDestroyTableNode;
00441     public:
00442         VrWarningIndArg(const VrWarningCode& warning_code);
00443         VrWarningIndArg();
00444         ~VrWarningIndArg();
00445
00446         static const VrWarningIndArg& Cast(const StackMsgArgument& arg);
00447         const VrWarningCode& GetWarningCode() const { return m_warning_code; }
00448
00449         enum  {
00450             ID = 5011
00451             };
00452
00453     private:
00454
00455         static void Destroy(StackMsgArgument* arg) { delete ((VrWarningIndArg*) arg); }
00456
00457         VrWarningCode m_warning_code;
00458
00459     };
00460
00461 // Inline definitions
00462 inline const VrWarningIndArg& VrWarningIndArg::Cast(const StackMsgArgument& arg) {
00463     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrWarningIndArg!\n");
00464     return ((VrWarningIndArg &) arg);
00465 }
00466
00467
00468
00469 /*  ======================================================================
00470     Class VrPropertyResultIndArg
00471     ====================================================================== */
00472
00474 class VrPropertyResultIndArg : public StackMsgArgument {
00475     friend class VrStackMsgArgTableDestroyTableNode;
00476     public:
00477         VrPropertyResultIndArg(const VrProperty& property);
00478         VrPropertyResultIndArg();
00479         ~VrPropertyResultIndArg();
00480
00481         static const VrPropertyResultIndArg& Cast(const StackMsgArgument& arg);
00482         const VrProperty& GetProperty() const { return m_property; }
00483
00484         enum  {
00485             ID = 5013
00486             };
00487
00488     private:
00489
00490         static void Destroy(StackMsgArgument* arg) { delete ((VrPropertyResultIndArg*) arg); }
00491
00492         VrProperty m_property;
00493
00494     };
00495
00496 // Inline definitions
00497 inline const VrPropertyResultIndArg& VrPropertyResultIndArg::Cast(const StackMsgArgument& arg) {
00498     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to VrPropertyResultIndArg!\n");
00499     return ((VrPropertyResultIndArg &) arg);
00500 }
00501
00502
00503 #endif // AddOns_VoiceRecognition_VrStackMsgArgs_hpp
00504
Generated on Tue Jan 24 14:45:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrStackMsgArgTable.cpp File Reference

AddOns/VoiceRecognition/VrStackMsgArgTable.cpp File Reference

#include "PreComp.hpp"
#include "VrStackMsgArgTable.hpp"

Include dependency graph for VrStackMsgArgTable.cpp:

Generated on Tue Jan 24 16:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrStackMsgArgTable.hpp File Reference

AddOns/VoiceRecognition/VrStackMsgArgTable.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Include dependency graph for VrStackMsgArgTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VrStackMsgArgTableDestroyTableNode

Defines

#define | AddOns_VoiceRecognition_VrStackMsgArgTable_hpp

Define Documentation

#define AddOns_VoiceRecognition_VrStackMsgArgTable_hpp

Generated on Tue Jan 24 16:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrStackMsgArgTable.hpp Source File

AddOns/VoiceRecognition/VrStackMsgArgTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "hauth_voicerec_dv\lnz_apoxi\Apoxi\AddOns\VoiceRecognition\VrArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(AddOns_VoiceRecognition_VrStackMsgArgTable_hpp)
00016 #define AddOns_VoiceRecognition_VrStackMsgArgTable_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <AddOns/VoiceRecognition/VrStackMsgArgs.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class VrStackMsgArgTableDestroyTableNode
00028     ====================================================================== */
00029
00030 class VrStackMsgArgTableDestroyTableNode : public StackMsgArgDestroyTableNode {
00031     public:
00032
00033         static VrStackMsgArgTableDestroyTableNode* GetInstance();
00034
00035     private:
00036         VrStackMsgArgTableDestroyTableNode();
00037
00038
00039         static VrStackMsgArgTableDestroyTableNode* m_node;
00040         static const ArgumentDestroyEntry m_destroy_table[];
00041
00042     };
00043
00044 #endif // AddOns_VoiceRecognition_VrStackMsgArgTable_hpp
00045
Generated on Tue Jan 24 14:45:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrTemplateData.cpp File Reference

AddOns/VoiceRecognition/VrTemplateData.cpp File Reference

#include "PreComp.hpp"
#include <Asc/Lib.hpp>
#include <Adc/Pathname.hpp>
#include <Adc/File.hpp>
#include <Adc/RootFileSystem.hpp>
#include "VrTemplateData.hpp"
#include "VrData.hpp"

Include dependency graph for VrTemplateData.cpp:

Generated on Tue Jan 24 16:50:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrTemplateData.hpp File Reference

AddOns/VoiceRecognition/VrTemplateData.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:50:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrTemplateData.hpp Source File

AddOns/VoiceRecognition/VrTemplateData.hpp

Go to the documentation of this file.
00001 /*-----------------------------------------------------------------------
00002   Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003   -----------------------------------------------------------------------
00004   This document contains proprietary information belonging to COMNEON.
00005   Passing on and copying of this document, use and communication of its
00006   contents is not permitted without prior written authorisation.
00007   ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(AddOns_VoiceRecognition_VrTemplateData_hpp)
00011 #define AddOns_VoiceRecognition_VrTemplateData_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017 /* ========================================================================
00018    VrTemplateData
00019    ======================================================================== */
00021 class VrTemplate : public Linkable<VrTemplate>
00022 {
00023
00024 public:
00025     enum VrFileIoRc {
00026         Success,
00027         FileNotExists,
00028         WrongFileSize,
00029         ReadTooLess,
00030         FileExists,
00031         FileNotCreated,
00032         WriteError,
00033         MemoryProblem,
00034         DeleteError
00035     };
00036
00038     VrTemplate(UINT16 template_id, const WString& device_id = L"ffs");
00039
00041
00049     VrTemplate(UINT16 template_id, const UINT16* template_data, UINT32 size, const WString& device_id = L"ffs");
00050
00052     virtual ~VrTemplate();
00053
00055
00058     const UINT16* GetTemplatePtr();
00059
00061     VrFileIoRc GetInitResult() { return m_init_result; }
00062
00064     virtual VrFileIoRc StoreTemplate();
00065
00067     UINT16 GetTemplateId() { return m_template_id;  }
00068
00070     const WString& GetDeviceId() { return m_device_id; }
00071
00072 protected:
00073
00074     VrTemplate(const UINT16* template_data);
00075
00077     void SetInitResult(VrFileIoRc init_result) { m_init_result = init_result; }
00078
00080
00087     VrTemplate::VrFileIoRc SetData(UINT32 size, const UINT16* template_data);
00088
00090     VrFileIoRc LoadFromFile(const WString& filename, UINT16*& data, UINT32& size);
00091
00093     VrFileIoRc SaveToFile(const WString& filename, const UINT16* data, UINT32 size);
00094
00095 private:
00096
00098     VrFileIoRc LoadTemplate(const WString& device_id, UINT16 template_id);
00099
00100     UINT16      m_template_id;
00101     UINT32      m_size;
00102     UINT16*     m_data;
00103     WString     m_device_id;
00104
00105     VrFileIoRc  m_init_result;
00106 };
00107
00108 /* ========================================================================
00109    VrTrainedTemplateData
00110    ======================================================================== */
00111 class VrTrainedTemplate : public VrTemplate
00112 {
00113
00114     typedef VrTemplate Base;
00115 public:
00116
00118
00121     VrTrainedTemplate(UINT16 template_id, const UINT16* template_data, UINT32 template_size, const UINT8* sample_buffer, UINT32 sample_size, const WString& device_id = L"ffs");
00122
00124     VrTrainedTemplate(UINT16 template_id, const WString& device_id = L"ffs");
00125
00127     virtual ~VrTrainedTemplate();
00128
00130 //  VrFileIoRc PlayTemplate();
00131
00133
00136     VrFileIoRc GetAudioFileName(WString& file_name);
00137
00138 protected:
00139
00141
00143     VrTemplate::VrFileIoRc SetSampleData(UINT16 template_id, const WString& device_id, UINT32 sample_size, const UINT8* sample_data);
00144
00145 private:
00146 //  VrTemplate::VrFileIoRc LoadSamples(const WString& device_id, UINT16 template_id);
00147
00148     UINT32      m_sample_size;
00149 };
00151 #endif  // AddOns_VoiceRecognition_VrTemplateData_hpp
00152
00153 #endif // DOXYGEN_SHOULD_SKIP_THIS
00154
Generated on Tue Jan 24 14:45:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrTemplates.cpp File Reference

AddOns/VoiceRecognition/VrTemplates.cpp File Reference

#include "PreComp.hpp"
#include "VrData.hpp"
#include "VrTemplateData.hpp"
#include "VrTypes.hpp"

Include dependency graph for VrTemplates.cpp:

Generated on Tue Jan 24 16:50:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrTypes.hpp File Reference

AddOns/VoiceRecognition/VrTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | AddOns_VoiceRecognition_VrTypes_hpp

Enumerations

enum VrErrorCode {
VrTrainMemoryError, VrInvalidTrainParam, VrBufferOvervlow, VrStoreTimeout,
VrTrainPromptTimeOut, VrTrainAbort, VrRecogMemoryError, VrInvalidRecogParam,
VrRecogPromptTimeout, VrNoTemplate, VrTemplateResponseTimeout, VrUndiffTemplate,
VrRecogAbort, VrG2AInitMemoryError, VrG2AParamRangeError, VrG2AExecutionError,
VrG2AEmptyBufferError, VrLoadTemplateError = 100, VrBusy = 101, VrStoreTemplateError = 102,
VrAudioError = 103, VrSequenceError = 104
}
Error codes for Apoxi VR. More...
enum VrProperty {
IsolatedWordRecognition, ConnectedWordRecognition, SpeakerDependentTraining, G2ATraining,
SpeakerAdaption, InvalidProperty
}
enum | VrWarningCode { VrInitTimeout, VrRecogBuffer, VrRefExceed, VrInputTruncated }
Warning codes for Apoxi VR. More...

Define Documentation

#define AddOns_VoiceRecognition_VrTypes_hpp

Enumeration Type Documentation

enum VrErrorCode

Error codes for Apoxi VR.

Enumerator:
VrTrainMemoryError
VrInvalidTrainParam
VrBufferOvervlow
VrStoreTimeout
VrTrainPromptTimeOut
VrTrainAbort
VrRecogMemoryError
VrInvalidRecogParam
VrRecogPromptTimeout
VrNoTemplate
VrTemplateResponseTimeout
VrUndiffTemplate
VrRecogAbort
VrG2AInitMemoryError
VrG2AParamRangeError
VrG2AExecutionError
VrG2AEmptyBufferError
VrLoadTemplateError
VrBusy
VrStoreTemplateError
VrAudioError
VrSequenceError

enum VrProperty

Enumerator:
IsolatedWordRecognition | asr engine provides isolated word recognizer for speaker dependant / speaker independant recognition; in speaker dependant recognition RejectionValue in AsrRecResult_t can be used.
ConnectedWordRecognition | asr engine provides isolated word recognizer for speaker dependant / speaker independant recognition; in speaker dependant recognition
SpeakerDependentTraining | asr engine provides speaker dependant training
G2ATraining | asr engine provides G2A functions that allow to produce references from written character strings
SpeakerAdaption | asr engine provides speaker adaptation functions, that can be used to improve given references in order to get higher recognition rates in (e.g.) connected word recognition; the adaptation process works like that: the user talks some predefined words into the mobile; during that procedure the user voice is recorded and used to adapt the references that match the spoken words, i.e. the procedure is very similar to a normal (connected word) recognition.
InvalidProperty

enum VrWarningCode

Warning codes for Apoxi VR.

Enumerator:
VrInitTimeout
VrRecogBuffer
VrRefExceed
VrInputTruncated

Generated on Tue Jan 24 16:50:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrTypes.hpp Source File

AddOns/VoiceRecognition/VrTypes.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(AddOns_VoiceRecognition_VrTypes_hpp)
00011 #define AddOns_VoiceRecognition_VrTypes_hpp
00012
00013 enum VrErrorCode {
00014
00015 #if defined VR_ENABLED_STACK
00016     // training errors
00017     VrTrainMemoryError = VR_ERROR_TRAIN_MEM,
00018     VrInvalidTrainParam = VR_ERROR_TRAIN_PARAM,
00019     VrBufferOvervlow = VR_ERROR_TRAIN_BUF_OVERFLOW,
00020     VrStoreTimeout = VR_ERROR_TRAIN_STORE_TIMEOUT,
00021     VrTrainPromptTimeOut = VR_ERROR_TRAIN_PROMPT_TIMEOUT,
00022     VrTrainAbort = VR_ERROR_TRAIN_ABBORT,
00023
00024     // recognition errors
00025     VrRecogMemoryError = VR_ERROR_RECOG_MEM,
00026     VrInvalidRecogParam = VR_ERROR_RECOG_PARAM_RANGE,
00027     VrRecogPromptTimeout = VR_ERROR_RECOG_PROMPT_TIMEOUT,
00028     VrNoTemplate = VR_ERROR_RECOG_NO_TEMPLATE,
00029     VrTemplateResponseTimeout = VR_ERROR_RECOG_TEMP_RESP_TIMEOUT,
00030     VrUndiffTemplate = VR_ERROR_RECOG_UNDIFF_TEMPLATE,
00031     VrRecogAbort = VR_ERROR_REC_ABBORT,
00032
00033     VrG2AInitMemoryError = VR_ERROR_G2A_INIT_MEM,       //not enough memory during initialization of G2A
00034     VrG2AParamRangeError = VR_ERROR_G2A_PARAM_RANGE,    //bad parameter during initialization of G2A
00035     VrG2AExecutionError = VR_ERROR_G2A_EXEC,        //something went wrong during execution of G2A
00036     VrG2AEmptyBufferError = VR_ERROR_G2A_EMPTY_BUFF,    //no data from apoxi for G2A
00037 #else
00038     // training errors
00039     VrTrainMemoryError,
00040     VrInvalidTrainParam,
00041     VrBufferOvervlow,
00042     VrStoreTimeout,
00043     VrTrainPromptTimeOut,
00044     VrTrainAbort,
00045
00046     // recognition errors
00047     VrRecogMemoryError,
00048     VrInvalidRecogParam,
00049     VrRecogPromptTimeout,
00050     VrNoTemplate,
00051     VrTemplateResponseTimeout,
00052     VrUndiffTemplate,
00053     VrRecogAbort,
00054
00055     VrG2AInitMemoryError,       //not enough memory during initialization of G2A
00056     VrG2AParamRangeError,   //bad parameter during initialization of G2A
00057     VrG2AExecutionError,        //something went wrong during execution of G2A
00058     VrG2AEmptyBufferError,  //no data from apoxi for G2A
00059 #endif
00060
00061     // APOXI specific errors
00062     VrLoadTemplateError = 100,
00063     VrBusy = 101,
00064     VrStoreTemplateError = 102,
00065     VrAudioError = 103,
00066     VrSequenceError = 104
00067 };
00068
00070 enum VrWarningCode {
00071
00072 #if defined VR_ENABLED_STACK
00073     VrInitTimeout = VR_WARNING_INIT_TIMEOUT,
00074     VrRecogBuffer = VR_WARNING_RECOG_BUFFER,
00075     VrRefExceed = VR_WARNING_REFERENCES_EXCEED,
00076     VrInputTruncated = VR_WARNING_INPUT_TEXT_TRUNCATED_TO40
00077 #else
00078     VrInitTimeout,
00079     VrRecogBuffer,
00080     VrRefExceed,
00081     VrInputTruncated
00082 #endif
00083 };
00084
00085 enum VrProperty {
00086 #if defined VR_ENABLED_STACK
00087
00090     IsolatedWordRecognition = ISOLATED_WORD_RECOGNITION,
00093     ConnectedWordRecognition = CONNECTED_WORD_RECOGNITION,
00095     SpeakerDependentTraining = SPEAKER_DEPENDENT_TRAINING,
00098     G2ATraining = G2A_TRAINING,
00106     SpeakerAdaption = SPEAKER_ADAPTION,
00107     InvalidProperty = INVALID_PROPERTY
00108 #else
00109
00112     IsolatedWordRecognition,
00115     ConnectedWordRecognition,
00117     SpeakerDependentTraining,
00120     G2ATraining,
00128     SpeakerAdaption,
00129     InvalidProperty
00130 #endif
00131 };
00132
00133
00134 #endif // AddOns_VoiceRecognition_VrTypes_hpp
00135
Generated on Tue Jan 24 14:45:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrWaitDispatcher.cpp File Reference

AddOns/VoiceRecognition/VrWaitDispatcher.cpp File Reference

#include "PreComp.hpp"
#include "VrWaitDispatcher.hpp"
#include "VrStackMsgArgs.hpp"
#include "VrData.hpp"

Include dependency graph for VrWaitDispatcher.cpp:

Generated on Tue Jan 24 16:50:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrWaitDispatcher.hpp File Reference

AddOns/VoiceRecognition/VrWaitDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:50:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/VoiceRecognition/VrWaitDispatcher.hpp Source File

AddOns/VoiceRecognition/VrWaitDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002   Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003   ------------------------------------------------------------------------
00004   This document contains proprietary information belonging to COMNEON.
00005   Passing on and copying of this document, use and communication of its
00006   contents is not permitted without prior written authorisation.
00007   ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(AddOns_VoiceRecognition_VrWaitDispatcher_hpp)
00011 #define AddOns_VoiceRecognition_VrWaitDispatcher_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00017
00018 /* ========================================================================
00019    VrWaitDispatcher
00020    ======================================================================== */
00022 class VrWaitDispatcher : public StackMsgActiveWaitDispatcher {
00023     typedef StackMsgActiveWaitDispatcher Base;
00024  public:
00026     VrWaitDispatcher();
00028     virtual ~VrWaitDispatcher();
00029
00030     virtual void Reset();
00031     BOOLEAN IsTimedOut() { return m_timed_out; }
00032
00033
00035     const StackMsgArgument& GetLastArgument() { return m_last_arg; }
00036
00037  protected:
00039     BOOLEAN OnVrResultReceived(const StackMsgArgument &arg);
00040     BOOLEAN OnVrPropertyResultInd(const StackMsgArgument &arg);
00042
00043  private:
00044     StackMsgArgument m_last_arg;
00045     static const StackMsgArgMap<VrWaitDispatcher> m_arg_map[];
00046
00047     StackMsgArgMapContainer<VrWaitDispatcher> m_arg_map_container;
00048     BOOLEAN m_timed_out;
00049 };
00050
00052 #endif  // AddOns_VoiceRecognition_VrWaitDispatcher_hpp
00053
00054 #endif // DOXYGEN_SHOULD_SKIP_THIS
00055
Generated on Tue Jan 24 14:45:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/MinBasicString.cpp File Reference

AddOns/Wbxml/MinBasicString.cpp File Reference

#include "WbxmlPreComp.hpp"
#include "MinBasicString.h"

Include dependency graph for MinBasicString.cpp:

Generated on Tue Jan 24 16:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlParser.cpp File Reference

AddOns/Wbxml/WbxmlParser.cpp File Reference

#include "WbxmlPreComp.hpp"
#include "WbxmlParser.h"
#include "WbxmlParserInternalDefs.h"

Include dependency graph for WbxmlParser.cpp:

Variables

const SAXString | publicIdNull
const SAXString | saxStringNull

Variable Documentation

const SAXString publicIdNull

const SAXString saxStringNull

Generated on Tue Jan 24 16:50:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlParser2.cpp File Reference

AddOns/Wbxml/WbxmlParser2.cpp File Reference

#include "WbxmlPreComp.hpp"
#include "WbxmlParser.h"
#include "WbxmlParserInternalDefs.h"

Include dependency graph for WbxmlParser2.cpp:

Generated on Tue Jan 24 16:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlParser3.cpp File Reference

AddOns/Wbxml/WbxmlParser3.cpp File Reference

#include "WbxmlPreComp.hpp"
#include "WbxmlParser.h"
#include "WbxmlParserInternalDefs.h"

Include dependency graph for WbxmlParser3.cpp:

Generated on Tue Jan 24 16:50:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlPreComp.cpp File Reference

AddOns/Wbxml/WbxmlPreComp.cpp File Reference

#include "WbxmlPreComp.hpp"

Include dependency graph for WbxmlPreComp.cpp:

Generated on Tue Jan 24 16:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlPreComp.hpp File Reference

AddOns/Wbxml/WbxmlPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for WbxmlPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:50:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlPreComp.hpp Source File

AddOns/Wbxml/WbxmlPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011
Generated on Tue Jan 24 14:45:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlTemplates.cpp File Reference

AddOns/Wbxml/WbxmlTemplates.cpp File Reference

#include "WbxmlPreComp.hpp"
#include <Auxiliary/Vector.hpp>

Include dependency graph for WbxmlTemplates.cpp:

Generated on Tue Jan 24 16:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlVector.hpp File Reference

AddOns/Wbxml/WbxmlVector.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for WbxmlVector.hpp:

Go to the source code of this file.

Data Structures

class | WbxmlVector< T >

Defines

#define | Apoxi_Wbxml_Vector_hpp

Define Documentation

#define Apoxi_Wbxml_Vector_hpp

Generated on Tue Jan 24 16:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Wbxml/WbxmlVector.hpp Source File

AddOns/Wbxml/WbxmlVector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Wbxml_Vector_hpp)
00010 #define Apoxi_Wbxml_Vector_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Auxiliary/Vector.hpp>
00014
00015 template<class T> class WbxmlVector : public Vector<T> {
00016     public :
00017         typedef Vector<T> Base;
00018         typedef INT SizeType;
00019         typedef INT DifferenceType;
00020
00021         using Base::Iterator ;
00022         using Base::ReverseIterator ;
00023         typedef typename Vector<T>::Iterator iterator;
00024         typedef typename Vector<T>::ReverseIterator reverse_iterator;
00025
00026         WbxmlVector() { }
00027         SizeType size() { return Base::GetSize() ; }
00028         bool empty() const { return (Base::IsEmpty() ? TRUE:FALSE ) ; }
00029         T& front() { return Base::Front() ; }
00030         const T& front() const {return Base::Front() ;}
00031         T& back() { return Base::Back() ; }
00032         const T& back() const { return Base::Back() ; }
00033         void push_back(const T&  x) { Base::PushBack(x) ; }
00034         void clear() { Base::Erase(Base::Begin(), Base::End()) ; }
00035         void reserve(SizeType n) { Base::Reserve(n) ; }
00036
00037         iterator begin() { return Base::Begin() ; }
00038         iterator end() { return  Base::End() ; }    // The End() function returns an iterator past the last element. std::end() returns iterator to last element.
00039         reverse_iterator rbegin() { return Base::RBegin() ; }
00040         reverse_iterator rend() { return Base::REnd() ; }
00041
00042         iterator erase(const iterator &pos) {
00043             if(pos == end()) {
00044                 Base::Erase(pos) ;
00045                 return end() ;
00046             }
00047             else {
00048                 Base::Erase(pos) ;
00049                 return pos ;
00050             }
00051         }
00052
00053         iterator erase(const iterator &first, const iterator &last) {        // Need to check if end then return end.
00054             iterator temp = first ;
00055             if(last < temp) {
00056                 while(last <= temp){
00057                     erase(temp) ;
00058                     temp = temp + 1;
00059                 }
00060                 return temp ;
00061             }
00062             else {
00063                 Base::Erase(first,last) ;
00064                 return first ;
00065             }
00066         }
00067
00068         iterator insert(const iterator &pos, T& x) {
00069             Base::Insert(pos,1,x) ;
00070             if(pos == end())
00071                 return end() ;
00072             else
00073                 return pos ;
00074         }
00075
00076         void insert(const iterator &pos, SizeType n, const T&  x) { Base::Insert(pos,n,x) ;}
00077
00078         void resize(SizeType n) { // To check after changes.
00079         int length = size() ;
00080             if(length == 0)
00081                 Base::Insert(begin(),n) ;
00082             else if(length < n)
00083                 Base::Insert(end(),n) ;
00084             else if (n < length)
00085                 erase(begin() + n, end());
00086         }
00087 } ;
00088
00089 #endif // Apoxi_Wbxml_Vector_hpp
00090
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/bistream.cpp File Reference

AddOns/XmlParser/bistream.cpp File Reference

#include "bistream.h"

Include dependency graph for bistream.cpp:

Functions

void | BufferedIStream_Free (LPBUFFEREDISTREAM reader)
LPBUFFEREDISTREAM | BufferedIStream_Init (LPBUFFEREDISTREAM reader, s32 blocksize)
s32 | BufferedIStream_Peek (LPBUFFEREDISTREAM reader, const char *tok, s32 len, s32 offset)
s32 | BufferedIStream_Read (LPBUFFEREDISTREAM reader, const char *tok, s32 len, s32 offset, char *breakchar)
char * | BufferedIStream_ToString (LPBUFFEREDISTREAM reader, s32 startPos, s32 endPos)

Function Documentation

void BufferedIStream_Free ( LPBUFFEREDISTREAM reader )

LPBUFFEREDISTREAM BufferedIStream_Init | ( | LPBUFFEREDISTREAM | reader,
 |  | s32 | blocksize
 | ) |

s32 BufferedIStream_Peek | ( | LPBUFFEREDISTREAM | reader,
 |  | const char * | tok,
 |  | s32 | len,
 |  | s32 | offset
 | ) |

s32 BufferedIStream_Read | ( | LPBUFFEREDISTREAM | reader,
 |  | const char * | tok,
 |  | s32 | len,
 |  | s32 | offset,
 |  | char * | breakchar
 | ) |

char* BufferedIStream_ToString | ( | LPBUFFEREDISTREAM | reader,
 |  | s32 | startPos,
 |  | s32 | endPos
 | ) |

Generated on Tue Jan 24 16:50:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/hash.cpp File Reference

AddOns/XmlParser/hash.cpp File Reference

#include "hash.h"
#include "machdep.h"
#include "utils.h"
#include <stdlib.h>
#include <string.h>

Include dependency graph for hash.cpp:

Functions

void * | HashTable_Create (void *t, size_t size)
void | HashTable_Destroy (void *t, t_freefunc func)
void | HashTable_Enumerate (void *t, void(*func)(char *, void *, void *))
void * | HashTable_Insert (void *t, char *key, void *data)
void * | HashTable_Lookup (void *t, char *key)
void * | HashTable_Remove (void *t, char *key)

Function Documentation

void* HashTable_Create | ( | void * | t,
 |  | size_t | size
 | ) |

void HashTable_Destroy | ( | void * | t,
 |  | t_freefunc | func
 | ) |

void HashTable_Enumerate | ( | void * | t,
 |  | void(*)(char *, void *, void *) | func
 | ) |

void* HashTable_Insert | ( | void * | t,
 |  | char * | key,
 |  | void * | data
 | ) |

void* HashTable_Lookup | ( | void * | t,
 |  | char * | key
 | ) |

void* HashTable_Remove | ( | void * | t,
 |  | char * | key
 | ) |

Generated on Tue Jan 24 16:50:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/parsifal.cpp File Reference

AddOns/XmlParser/parsifal.cpp File Reference

#include "parsifal.h"
#include "stdarg.h"
#include "utils.h"

Include dependency graph for parsifal.cpp:

Defines

#define | _pp ((LPXMLPARSER)parser)
#define | ATTENUM ((LPRUNTIMEATT)*attEnum)
#define | CLEANUP_ATTS CLEANUP_ATTS_fn(parser)
#define | ISFATAL(ret) (((ret) < -2) ? (SetReaderFatal(((LPXMLPARSER)parser), (ret)), 1) : 0)
#define | ISILLchar(c) (ISMAPCH(illchar, (c)))
#define | ISMAPCH(map, char) ((map)[(char) >> 3] & (1 << ((char) & 7)))
#define | ISNULLSTR(str) ((char*)(str)==(char*)NULL)
#define | ISQNAME(tag, len) (qname((tag),(len)))
#define | ISQUOTE(c) ((c)=='\"' || (c)=='\'')
#define | isspace(c) (ISMAPCH(whitespace, (c)))
#define | ISWHITESPACE(buf, len) (isWS((buf),(len)))
#define | ISXMLNSPREFIX(s) ((ISXMLPREFIX((s)) && *((s)+3) == 'n' && *((s)+4) == 's'))
#define | ISXMLPREFIX(s) ((*(s) == 'x' && *((s)+1) == 'm' && *((s)+2) == 'l'))
#define | rt ((LPXMLPARSERRUNTIME)parser->prt)
#define | SAFE_FREESTR(s) if (!ISNULLSTR(s)) { xml_MemFree(s); s = (char*)NULL; }
#define | SEEKWS(buf, len) (SeekMap(whitespace,(buf),(len)))
#define | TOK_END_CDATA "]]>"
#define | TOK_END_COMMENT "--"
#define | TOK_END_DTD "]>"
#define | TOK_END_PI "?>"
#define | TOK_GT ">"
#define | TOK_LT "<"
#define | TOK_XMLNS "xmlns"

Typedefs

typedef tagSTDENTITIES | STDENTITIES

Enumerations

enum | { UTF8_2charS = 0xc0, UTF8_3charS = 0xe0, UTF8_4charS = 0xf0 }

Functions

void | CLEANUP_ATTS_fn (LPXMLPARSER parser)
s32 | EncodeIStreamBuffer (LPBUFFEREDISTREAM reader, s32 offset)
s32 | Latin1ToUtf8 (LPBUFFEREDISTREAM reader, char *bufp, s32 *cchars)
s32 | Utf8Validator (LPBUFFEREDISTREAM reader, char *bufp, s32 *cchars)
LPRUNTIMEATT XMLAPI | XMLParser_GetNamedItem (LPXMLPARSER parser, char *name)
LPXMLPARSER XMLAPI | XMLParser_MiniCreate (LPXMLPARSER parser)
void XMLAPI | XMLParser_MiniFree (LPXMLPARSER parser)
s32 XMLAPI | XMLParser_Parse (LPXMLPARSER parser, LPFNINPUTSRC inputSrc, void *inputData, const char *encoding)

Define Documentation

#define _pp ((LPXMLPARSER)parser)

#define ATTENUM ((LPRUNTIMEATT)*attEnum)

#define CLEANUP_ATTS CLEANUP_ATTS_fn(parser)

#define ISFATAL ( ret ) (((ret) < -2) ? (SetReaderFatal(((LPXMLPARSER)parser), (ret)), 1) : 0)

#define ISILLchar ( c ) (ISMAPCH(illchar, (c)))

#define ISMAPCH | ( | map,
 |  | char | ) | ((map)[(char) >> 3] & (1 << ((char) & 7)))

#define ISNULLSTR ( str ) ((char*)(str)==(char*)NULL)

#define ISQNAME | ( | tag,
 |  | len | ) | (qname((tag),(len)))

#define ISQUOTE ( c ) ((c)=='\"' || (c)=='\'')

#define isspace ( c ) (ISMAPCH(whitespace, (c)))

#define ISWHITESPACE | ( | buf,
 |  | len | ) | (isWS((buf),(len)))

#define ISXMLNSPREFIX ( s ) ((ISXMLPREFIX((s)) && *((s)+3) == 'n' && *((s)+4) == 's'))

#define ISXMLPREFIX ( s ) ((*(s) == 'x' && *((s)+1) == 'm' && *((s)+2) == 'l'))

#define rt ((LPXMLPARSERRUNTIME)parser->prt)

#define SAFE_FREESTR ( s ) if (!ISNULLSTR(s)) { xml_MemFree(s); s = (char*)NULL; }

#define SEEKWS | ( | buf,
 |  | len | ) | (SeekMap(whitespace,(buf),(len)))

#define TOK_END_CDATA "]]>"

#define TOK_END_COMMENT "--"

#define TOK_END_DTD "]>"

#define TOK_END_PI "?>"

#define TOK_GT ">"

#define TOK_LT "<"

#define TOK_XMLNS "xmlns"

Typedef Documentation

typedef struct tagSTDENTITIES STDENTITIES

Enumeration Type Documentation

anonymous enum

Enumerator:
UTF8_2charS
UTF8_3charS
UTF8_4charS

Function Documentation

void CLEANUP_ATTS_fn ( LPXMLPARSER parser )

s32 EncodeIStreamBuffer | ( | LPBUFFEREDISTREAM | reader,
 |  | s32 | offset
 | ) |

s32 Latin1ToUtf8 | ( | LPBUFFEREDISTREAM | reader,
 |  | char * | bufp,
 |  | s32 * | cchars
 | ) |

s32 Utf8Validator | ( | LPBUFFEREDISTREAM | reader,
 |  | char * | bufp,
 |  | s32 * | cchars
 | ) |

LPRUNTIMEATT XMLAPI XMLParser_GetNamedItem | ( | LPXMLPARSER | parser,
 |  | char * | name
 | ) |

LPXMLPARSER XMLAPI XMLParser_MiniCreate ( LPXMLPARSER parser )

void XMLAPI XMLParser_MiniFree ( LPXMLPARSER parser )

s32 XMLAPI XMLParser_Parse | ( | LPXMLPARSER | parser,
 |  | LPFNINPUTSRC | inputSrc,
 |  | void * | inputData,
 |  | const char * | encoding
 | ) |

Generated on Tue Jan 24 16:50:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/PreComp.cpp File Reference

AddOns/XmlParser/PreComp.cpp File Reference

#include "AddOns/XmlParser/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/PreComp.hpp File Reference

AddOns/XmlParser/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/PreComp.hpp Source File

AddOns/XmlParser/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Auxiliary/Lib.hpp>
00010
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/stk.cpp File Reference

AddOns/XmlParser/stk.cpp File Reference

#include <stdio.h>
#include <stdlib.h>
#include "utils.h"
#include "stk.h"

Include dependency graph for stk.cpp:

Functions

void | stkInit (Stk *pstack)
int | stkPop (void **ppdata, Stk *pstack)
int | stkPush (Stk *pstack, void *pdata)

Function Documentation

void stkInit ( Stk * pstack )

int stkPop | ( | void ** | ppdata,
 |  | Stk * | pstack
 | ) |

int stkPush | ( | Stk * | pstack,
 |  | void * | pdata
 | ) |

Generated on Tue Jan 24 16:50:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/utils.cpp File Reference

AddOns/XmlParser/utils.cpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/HeapManager.hpp>
#include <Config/MemoryConfig.hpp>
#include <Kernel/HeapVector.hpp>
#include "utils.h"

Include dependency graph for utils.cpp:

Functions

void * | enlarge_memory (void *ptr, size_t size)
void * | xml_MemAlloc (u32 uiItemSize, u32 uiItems)
void | xml_MemFree (void *pFreeMemAddress)
char * | xml_strdup (const char *str)

Function Documentation

void* enlarge_memory | ( | void * | ptr,
 |  | size_t | size
 | ) |

void* xml_MemAlloc | ( | u32 | uiItemSize,
 |  | u32 | uiItems
 | ) |

void xml_MemFree ( void * pFreeMemAddress )

char* xml_strdup ( const char * str )

Generated on Tue Jan 24 16:50:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/vector.cpp File Reference

AddOns/XmlParser/vector.cpp File Reference

#include "vector.h"
#include "utils.h"

Include dependency graph for vector.cpp:

Functions

s32 XMLAPI | Vector_Append (LPVECTOR vector, void *item)
LPVECTOR XMLAPI | Vector_Create (LPVECTOR *vector, s32 initialCapacity)
void XMLAPI | Vector_Free (LPVECTOR vector)
s32 XMLAPI | Vector_Resize (LPVECTOR vector, s32 newsize)

Function Documentation

s32 XMLAPI Vector_Append | ( | LPVECTOR | vector,
 |  | void * | item
 | ) |

LPVECTOR XMLAPI Vector_Create | ( | LPVECTOR * | vector,
 |  | s32 | initialCapacity
 | ) |

void XMLAPI Vector_Free ( LPVECTOR vector )

s32 XMLAPI Vector_Resize | ( | LPVECTOR | vector,
 |  | s32 | newsize
 | ) |

Generated on Tue Jan 24 16:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/xml_parser.cpp File Reference

AddOns/XmlParser/xml_parser.cpp File Reference

#include "PreComp.hpp"
#include "xml_parser.hpp"

Include dependency graph for xml_parser.cpp:

Generated on Tue Jan 24 16:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/xml_parser.hpp File Reference

AddOns/XmlParser/xml_parser.hpp File Reference

#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include "xml.h"
#include <Auxiliary/WString.hpp>

Include dependency graph for xml_parser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class XMLParser

Generated on Tue Jan 24 16:50:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/XmlParser/xml_parser.hpp Source File

AddOns/XmlParser/xml_parser.hpp

Go to the documentation of this file.
00001 #ifndef __XML_Parser_h
00002 #define __XML_Parser_h
00003
00004
00005 extern "C" {
00006 #include <string.h>
00007 #include <stdio.h>
00008 #include <stdlib.h>
00009 }
00010 #include "xml.h"
00011
00012 #include <Auxiliary/WString.hpp>
00013
00014 class XMLParser {
00015
00016     public:
00017         static char *strbuf;
00018         static int prev_readpos ;
00019         XMLParser(char *str);
00020         virtual ~XMLParser();
00021         s32 Parse();
00022
00023         virtual s32 XML_Error_Handler(int ErrorCode, int ErrorLine) { return 0;}
00024         virtual s32 XML_Start_Handler(void *UserData) { return 0;}
00025         virtual s32 XML_End_Handler(void *UserData) { return 0;}
00026         virtual s32 XML_StartElement_Handler(void *UserData, char *uri, char *localname, char *qName, LPVECTOR atts) { return 0; }
00027         virtual s32 XML_EndElement_Handler(void *UserData, char *uri, char *localname, char *qName) { return 0;}
00028         virtual s32 XML_Characters_Handler(void *UserData, char *Chars, s32 cbsize) { return 0;}
00029         virtual s32 XML_PI_Handler(void *UserData, char *Target, char *Data) { return 0;}
00030         virtual s32 XML_StartCData_Handler(void *UserData) { return 0;}
00031         virtual s32 XML_EndCData_Handler(void *UserData) { return 0; }
00032
00033         static void ErrorHandler(LPXMLPARSER parser);
00034         static s32 StartDocument(LPXMLPARSER parser, void *UserData);
00035         static s32 EndDocument(LPXMLPARSER parser, void *UserData);
00036         static s32 StartElement(LPXMLPARSER parser, void *UserData, char *uri, char *localName, char *qName, LPVECTOR atts);
00037         static s32 EndElement(LPXMLPARSER parser, void *UserData, char *uri, char *localName, char *qName);
00038         static s32 CharactersHandler(LPXMLPARSER parser, void *UserData, char *Chars, s32 cbSize);
00039         static s32 PIHandler(LPXMLPARSER parser, void *UserData, char *Target, char *Data);
00040         static s32 StartCDATAHandler(LPXMLPARSER parser, void *UserData);
00041         static s32 EndCDATAHandler(LPXMLPARSER parser, void *UserData);
00042         static s32 cstream(char *buf, s32 cBytes, s32 *cBytesActual, void *inputData);
00043
00044     private:
00045         XMLPARSER parser;
00046         int depth ;
00047 };
00048
00049 #endif
00050
00051
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/AudioMapiManager.cpp File Reference

AddOns/YamahaMapi/AudioMapiManager.cpp File Reference

#include "AudioMapiPreComp.hpp"
#include "AudioMapiManager.hpp"
#include <AddOns/YamahaMapi/MapiAudioPlayer.hpp>

Include dependency graph for AudioMapiManager.cpp:

Generated on Tue Jan 24 16:50:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/AudioMapiManager.hpp File Reference

AddOns/YamahaMapi/AudioMapiManager.hpp File Reference

#include <Audio/AudioReference.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for AudioMapiManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioMapiManager
struct | AudioMapiManager::MapiCommandType
struct | AudioMapiManager::RequestOutcomeType
Return type for IFX_MAPI(). More...

Defines

#define | Apoxi_AudioMapiManager_hpp

Define Documentation

#define Apoxi_AudioMapiManager_hpp

Generated on Tue Jan 24 16:51:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/AudioMapiManager.hpp Source File

AddOns/YamahaMapi/AudioMapiManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioMapiManager_hpp)
00011 #define Apoxi_AudioMapiManager_hpp
00012
00013 #include <Audio/AudioReference.hpp> // for PriorityType
00014 #include <Audio/AudioActiveReference.hpp>
00015
00016
00017 class AudioMapiManager
00018 {
00019     public:
00021         enum MapiCommandCodeType {
00022             CommandGetMode = 0,
00023             CommandSetMode = 1,// needs priority
00024             CommandResetMode = 2,// needs priority
00025             CommandInitialize = 3,// needs priority
00026             CommandTerminate = 4,
00027             CommandCheckLoad = 5,// needs priority
00028             CommandCheckUnload = 6,
00029             CommandGetContentsData = 7,
00030             CommandGetPhraseList = 8,
00031             CommandRealtimeMidiOpen = 9,// needs priority
00032             CommandRealtimeMidiSendCh = 10,
00033             CommandRealtimeStartTimer = 11,
00034             CommandRealtimeStopTimer = 12,
00035             CommandRealtimeMidiClose =13,
00036             CommandRealtimeMidiSendSysExMessage = 14,
00037             CommandRealtimeMidiSetApiVolume = 15,
00038             CommandRealtimeMidiGetChVolume = 16,
00039             CommandPhraseAudioLoad = 17,// needs priority
00040             CommandPhraseAudioOpen = 18,
00041             CommandPhraseAudioStandby = 19,
00042             CommandPhraseAudioControl = 20,
00043             CommandPhraseAudioStart = 21,
00044             CommandPhraseAudioStop = 22,
00045             CommandPhraseAudioClose = 23,
00046             CommandPhraseAudioUnload = 24,
00047             CommandPhraseGetPosition = 25,
00048             CommandPhraseSetEvHandler = 26,
00049             CommandPhraseGetLink = 27,
00050             CommandPhraseSetLink = 28,
00051             CommandPhraseKill = 29,
00052             CommandPhraseSetData = 30,// needs priority
00053             CommandPhraseSeek = 31,
00054             CommandPhraseGetLength = 32,
00055             CommandPhraseSetVolume = 33,
00056             CommandPhraseSetPanpot = 34,
00057             CommandPhrasePlay = 35,
00058             CommandPhraseStop = 36,
00059             CommandPhraseRemoveData = 37,
00060             CommandPhraseGetStatus = 38,
00061             CommandPhrasePause = 39,
00062             CommandPhraseRestart = 40,
00063             CommandMelodyControl = 41,
00064             CommandMelodyOpenArgInit = 42,
00065             CommandMelodyOpen = 43,
00066             CommandMelodyStandby = 44,
00067             CommandMelodyWaitReady = 45,
00068             CommandMelodyStart = 46,
00069             CommandMelodyStop = 47,
00070             CommandMelodySeek = 48,
00071             CommandMelodyClose = 49,
00072             CommandMelodyLoad = 50,// needs priority
00073             CommandMelodyUnload = 51,
00074             CommandDeviceControl = 52, // note: restricted use: only for (1) vibrator and (2) volume; usage (2) is allowed only for MapiAudioPlayer
00075             CommandInvalid = 0xff,
00076             CommandEnd
00077         };
00078
00079         struct MapiCommandType {
00080             MapiCommandCodeType command_code;
00081             UINT32 parm1;
00082             UINT32 parm2;
00083             UINT32 parm3;
00084             UINT32 parm4;
00085             UINT32 parm5;
00086             UINT32 parm6;
00087             UINT32 parm7;
00088         };
00089
00091         enum RequestAcceptanceType {
00092             RequestExecuted = 0, // request has been accepted and has been executed
00093             RequestRejected = 1, // the request has been rejected and has NOT been executed
00094             RequestUnexpectedCommand = 100, // the signal received belongs to a different command
00095             RequestTimeout = 101, // the request has been accepted and forwarded, but no result message has been received by the priority manager
00096             RequestAudMapiFailure = 102     // the return-code from AUD_mapi was not aud_rc_ok.
00097         };
00098
00099
00101         struct RequestOutcomeType {
00102             RequestAcceptanceType acceptance_outcome;
00103             INT32 mapi_return_value;                // the result of the mapi command
00104         };
00105
00113         static RequestOutcomeType IFX_MAPI(MapiCommandCodeType command_code, UINT32 parm1, UINT32 parm2, UINT32 parm3, UINT32 parm4, UINT32 parm5, UINT32 parm6, UINT32 parm7);
00114
00115         // callback registration
00116         static void SetStopCallback(BOOLEAN (*cb_stop)(const AudioActiveReference &active_ref) );
00117
00118     private:
00119         // class is actually a namespace workaround, not meant to be instantiated
00120         AudioMapiManager();
00121         ~AudioMapiManager();
00122 };
00123
00124 #endif  // Apoxi_AudioMapiManager_hpp
00125
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/AudioMapiPreComp.cpp File Reference

AddOns/YamahaMapi/AudioMapiPreComp.cpp File Reference

#include "AudioMapiPreComp.hpp"

Include dependency graph for AudioMapiPreComp.cpp:

Generated on Tue Jan 24 16:51:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/AudioMapiPreComp.hpp File Reference

AddOns/YamahaMapi/AudioMapiPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>

Include dependency graph for AudioMapiPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/AudioMapiPreComp.hpp Source File

AddOns/YamahaMapi/AudioMapiPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Apc/Lib.hpp>
00012 #include <Adc/Lib.hpp>
00013
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/MapiAudioPlayer.cpp File Reference

AddOns/YamahaMapi/MapiAudioPlayer.cpp File Reference

#include "AudioMapiPreComp.hpp"
#include "MapiAudioPlayer.hpp"
#include <AddOns/YamahaMapi/MapiAudioReference.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/audio_private.hpp>
#include <Config/AudioConfig.hpp>

Include dependency graph for MapiAudioPlayer.cpp:

Generated on Tue Jan 24 16:51:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/MapiAudioPlayer.hpp File Reference

AddOns/YamahaMapi/MapiAudioPlayer.hpp File Reference

#include <Audio/DwdPlayer.hpp>
#include <Audio/AudioPlayer.hpp>
#include <AddOns/YamahaMapi/AudioMapiManager.hpp>

Include dependency graph for MapiAudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MapiAudioPlayer

Defines

#define | Apoxi_MapiAudioPlayer_hpp

Define Documentation

#define Apoxi_MapiAudioPlayer_hpp

Generated on Tue Jan 24 16:51:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/MapiAudioPlayer.hpp Source File

AddOns/YamahaMapi/MapiAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MapiAudioPlayer_hpp)
00011 #define Apoxi_MapiAudioPlayer_hpp
00014
00015 #include <Audio/DwdPlayer.hpp>
00016 #include <Audio/AudioPlayer.hpp>
00017 #include <AddOns/YamahaMapi/AudioMapiManager.hpp>
00018
00019 class MapiAudioReference;
00020
00021 class MapiAudioPlayer: public DwdPlayer
00022 {
00023
00024     public:
00025
00026         friend class AudioMapiManager;
00027
00028
00029         virtual void Play(AudioActiveReference& active_reference);
00030         virtual void Stop(AudioActiveReference& active_reference);
00031         virtual BOOLEAN CanSuspend(const AudioActiveReference& active_reference) const;
00032         virtual BOOLEAN CanResume(const AudioActiveReference& active_reference) const;
00033
00037         virtual Vector<MimeTypeSupportInfo> GetMimeTypeSupportInfo() const;
00038
00039         virtual SharedPtr<AudioReference> CreateAudioReferenceFromExtensionSoundDataSource(MimeType mime_type, AudioReference::SoundDataSource sound_data_source);
00040
00041         void SetStopCallback(BOOLEAN (*cb_stop)(const AudioActiveReference &active_ref) );
00042
00043         static MapiAudioPlayer* GetInstance();
00044
00045         virtual UINT16 GetDeviceID() const;
00046         virtual AudioPlayer::AudioSourceType GetSource() const;
00047
00048
00049     protected:
00050
00051         virtual BOOLEAN OnSdlSignal(UINT16 func_id, UINT8 handle, UINT16 drv_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00052         virtual AudioMapiManager::RequestOutcomeType ForwardCommandToDriver(AudioMapiManager::MapiCommandType &command);
00053         virtual BOOLEAN Play_Allocate(AudioActiveReference &playing_ref);
00054
00055         BOOLEAN StopCallbackHaveBeenSet() const;
00056         BOOLEAN (*m_cb_stop)(const AudioActiveReference &active_ref);
00057         static void SetCommandExecutedCondition(UINT32 parm1, UINT32 parm2);
00058
00059     private:
00060         MapiAudioPlayer();
00061         virtual ~MapiAudioPlayer();
00062         static MapiAudioPlayer m_singleton_instance;
00063 };
00064
00065 #endif // Apoxi_MapiAudioPlayer_hpp
00066
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/MapiAudioReference.cpp File Reference

AddOns/YamahaMapi/MapiAudioReference.cpp File Reference

#include "AudioMapiPreComp.hpp"
#include <AddOns/YamahaMapi/MapiAudioReference.hpp>
#include <Audio/AudioPlayer.hpp>

Include dependency graph for MapiAudioReference.cpp:

Generated on Tue Jan 24 16:51:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/MapiAudioReference.hpp File Reference

AddOns/YamahaMapi/MapiAudioReference.hpp File Reference

#include <Audio/AudioReference.hpp>
#include <AddOns/YamahaMapi/AudioMapiManager.hpp>

Include dependency graph for MapiAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MapiAudioReference

Defines

#define | Apoxi_MapiAudioReference_hpp

Define Documentation

#define Apoxi_MapiAudioReference_hpp

Generated on Tue Jan 24 16:51:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/YamahaMapi/MapiAudioReference.hpp Source File

AddOns/YamahaMapi/MapiAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MapiAudioReference_hpp)
00011 #define Apoxi_MapiAudioReference_hpp
00012
00013 #include <Audio/AudioReference.hpp>
00014 #include <AddOns/YamahaMapi/AudioMapiManager.hpp>
00015
00016 class AudioPlayer;
00017
00018
00019 class MapiAudioReference: public AudioReference {
00020     public:
00021         virtual ~MapiAudioReference();
00022         static SharedPtr<MapiAudioReference> Create();
00023         virtual enumClassType GetClassType() const;
00024     protected:
00025         MapiAudioReference();
00026
00027     private:
00028
00029         friend class MapiAudioPlayer;
00030
00031 };
00032
00033 #endif // Apoxi_MapiAudioReference_hpp
00034
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8AlphabetBox.cpp File Reference

AddOns/Zi8/Zi8AlphabetBox.cpp File Reference

#include "Zi8PreComp.hpp"
#include <Gui/PaintDc.hpp>
#include <Gui/Font.hpp>
#include <Config/FontConfig.hpp>
#include <Config/Zi8InputConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include "Zi8AlphabetBox.hpp"

Include dependency graph for Zi8AlphabetBox.cpp:

Generated on Tue Jan 24 16:51:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8AlphabetBox.hpp File Reference

AddOns/Zi8/Zi8AlphabetBox.hpp File Reference

#include <Gui/DrawableObject.hpp>

Include dependency graph for Zi8AlphabetBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Zi8AlphabetBox
class | Zi8AlphabetBoxView

Defines

#define | Apoxi_Zi8AlphabetBox_hpp

Define Documentation

#define Apoxi_Zi8AlphabetBox_hpp

Generated on Tue Jan 24 16:51:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8AlphabetBox.hpp Source File

AddOns/Zi8/Zi8AlphabetBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     This document contains proprietary information belonging to COMNEON.
00003     Passing on and copying of this document, use and communication of its
00004     contents is not permitted without prior written authorisation.
00005     ------------------------------------------------------------------------ */
00006
00007 #if !defined(Apoxi_Zi8AlphabetBox_hpp)
00008 #define Apoxi_Zi8AlphabetBox_hpp
00009
00010 #include <Gui/DrawableObject.hpp>
00011
00013 class Zi8AlphabetBoxView : public DrawableObjectView {
00014     typedef DrawableObjectView Base;
00015
00016     public:
00018         Zi8AlphabetBoxView();
00019
00021         virtual ~Zi8AlphabetBoxView();
00022
00024         void Init();
00025
00027         virtual void Draw(const Component &component,
00028                           DeviceContext *dc,
00029                           const Rect &repaint_rect) const;
00030 };
00031
00032 class Zi8AlphabetBox : public DrawableObject {
00033     public:
00034         typedef DrawableObject Base;
00035
00036         Zi8AlphabetBox();
00037
00038         Zi8AlphabetBox(Control *control);
00039
00040         virtual ~Zi8AlphabetBox();
00041
00042         virtual XYDIM GetDefaultHeight() const;
00043
00044         void    Init(Control *control);
00045
00046         void    SetText(const WCHAR *text, INT selected_idx = -1, const INT caps_status = 0);
00047
00048         const   WCHAR* GetText(INT *selected_idx = 0, INT *caps_status = 0) const;
00049
00050         void    SetPageFlag(BOOLEAN prev_page, BOOLEAN next_page);
00051
00052         void    GetPageFlag(BOOLEAN *prev_page, BOOLEAN *next_page) const;
00053
00054         void    SetEleCount(INT ele_count);
00055
00056         INT     GetEleCount() const;
00057
00058         INT     GetShowCount(const WCHAR *text, INT font_id);
00059
00060         INT GetCenterXpos() const;
00061
00062     private:
00063         const WCHAR         *m_text;            //point to the english candidates
00064         INT                 m_selected_idx;     //the index of the selected word
00065         INT                 m_candidate_count;
00066         INT                 m_canddidate_offset;
00067         INT                 m_ele_count;
00068         INT                 m_center_xpos;
00069         BOOLEAN             m_caps_status;
00070         BOOLEAN             m_prev_page, m_next_page;
00071
00072         static Zi8AlphabetBoxView   m_view;
00073 };
00074
00075 #endif  // Apoxi_Zi8AlphabetBox_hpp
00076
00077
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8InputMapper.cpp File Reference

AddOns/Zi8/Zi8InputMapper.cpp File Reference

#include "Zi8PreComp.hpp"
#include <Kernel/Application.hpp>
#include <Gui/AbstractEditor.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <Gui/MessageBox.hpp>
#include <Gui/Alert.hpp>
#include <Gui/AbstractMultiLineEditor.hpp>
#include <Gui/TextEditorDocument.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Config/Zi8InputConfig.hpp>
#include <AddOns/MultiMedia/MultiMediaEditorDocument.hpp>
#include <AddOns/MultiMedia/RichTextCompoundItem.hpp>
#include <AddOns/MultiMedia/GeneralCompoundItem.hpp>
#include <AddOns/MultiMedia/ImageItem.hpp>
#include <AddOns/MultiMedia/ParagraphMarker.hpp>
#include <AddOns/MultiMedia/BoundedItem.hpp>
#include "Zi8InputMapper.hpp"

Include dependency graph for Zi8InputMapper.cpp:

Generated on Tue Jan 24 16:51:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8InputMapper.hpp File Reference

AddOns/Zi8/Zi8InputMapper.hpp File Reference

#include <Gui/PredInputMapper.hpp>
#include <AddOns/Zi8/Zi8Wrapper.hpp>

Include dependency graph for Zi8InputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Zi8InputMapper

Defines

#define | Apoxi_Zi8InputMapper_hpp

Define Documentation

#define Apoxi_Zi8InputMapper_hpp

Generated on Tue Jan 24 16:51:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8InputMapper.hpp Source File

AddOns/Zi8/Zi8InputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Zi8InputMapper_hpp)
00011 #define Apoxi_Zi8InputMapper_hpp
00012
00013 #include <Gui/PredInputMapper.hpp>
00014 #include <AddOns/Zi8/Zi8Wrapper.hpp>
00015
00016 class Zi8InputMapper : public PredInputMapper {
00017     typedef PredInputMapper Base;
00018
00019     public:
00021         Zi8InputMapper(AbstractEditor *editor = 0);
00022
00024         virtual ~Zi8InputMapper();
00025
00027         virtual INT GetId() const;
00028
00030         virtual Type GetType() const;
00031
00033         virtual void SetEditor(AbstractEditor *editor);
00034
00036         virtual const WCHAR* GetStatusInfo() const;
00037
00039         virtual const WCHAR* GetPhonetics(INT *selected_idx = 0) const;
00040
00042         virtual const WCHAR* GetStrokes() const;
00043
00045         virtual const WCHAR* GetSelection() const;
00046
00048         virtual INT GetSelectedIndex() const;
00049
00051         virtual BOOLEAN SetMode(PredMode mode);
00052
00054         virtual PredMode GetMode() const;
00055
00057         virtual BOOLEAN IsModeSupported(PredMode mode);
00058
00060         BOOLEAN HasPrevPage() const;
00061
00063         BOOLEAN HasNextPage() const;
00064
00066         INT GetElementCount() const;
00067
00069         INT GetCapsStatus() const;
00070
00072         BOOLEAN HasCandidate() const;
00073
00075         BOOLEAN AddNewWordToUdb(const WString& new_word);
00076
00078         void ReplaceWithNewWord(const WString& new_word);
00079
00081         void        ClearEditor();
00082
00083     protected:
00085         virtual BOOLEAN OnLongKeyPress(KeyCode key_code);
00086
00088         virtual BOOLEAN OnKeyUp(KeyCode key_code, UINT32 duration);
00089
00090         virtual BOOLEAN Notify (NotificationType type, INT index, const AtomItem* item = 0);
00091
00092     private:
00093
00095         void SynchronizeBuffers_Zi8ToApoxi(const WString& new_word=L"");
00096
00098         BOOLEAN     HandleZi8EnglishKeyDown(WCHAR key);
00099
00101         BOOLEAN     HandlePinYinKeyDown(WCHAR key);
00102
00104         BOOLEAN     HandleStrokeKeyDown(WCHAR key);
00105
00107         BOOLEAN     HandleToneKeyDown(WCHAR key);
00108
00109         INT         m_caret_idx;
00110
00111         INT         m_old_buff_length;
00112
00113         INT         m_caps_status;  //0=No Caps; 1=All Caps; 2=First Caps
00114
00115         BOOLEAN     m_insert_between, m_reset_write_pos;
00116
00117         BOOLEAN     m_left_key, m_right_key;
00118
00119         BOOLEAN     m_prev_page, m_next_page;
00120
00121         BOOLEAN     m_select_chinese;
00122
00123         Zi8Wrapper  m_zi8_wrapper;
00124
00125         // for storing the mode that was engaged before switching to symbol mode
00126         PredInputMapper::PredMode       m_old_mode;
00127
00128         #if defined(_MSC)
00129             #if defined(_DEBUG)
00130                 INT DumpCompoundItem(const CompoundItem& comp_item, INT level = 0) const;
00131                 void DumpDocument (WCHAR* method);
00132             #endif
00133         #endif
00134 };
00135
00136 #endif  // Apoxi_Zi8InputMapper_hpp
00137
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8PreComp.cpp File Reference

AddOns/Zi8/Zi8PreComp.cpp File Reference

#include "Zi8PreComp.hpp"

Include dependency graph for Zi8PreComp.cpp:

Generated on Tue Jan 24 16:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8PreComp.hpp File Reference

AddOns/Zi8/Zi8PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Kernel/System.hpp>

Include dependency graph for Zi8PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:51:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8PreComp.hpp Source File

AddOns/Zi8/Zi8PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/Lib.hpp>
00013 #include <Gui/Lib.hpp>
00014 #include <Kernel/System.hpp>
00015
00016
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8PredictiveInputBox.cpp File Reference

AddOns/Zi8/Zi8PredictiveInputBox.cpp File Reference

#include "Zi8PreComp.hpp"
#include "Zi8PredictiveInputBox.hpp"
#include <Gui/MessageBox.hpp>
#include <Kernel/Application.hpp>

Include dependency graph for Zi8PredictiveInputBox.cpp:

Generated on Tue Jan 24 16:51:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8PredictiveInputBox.hpp File Reference

AddOns/Zi8/Zi8PredictiveInputBox.hpp File Reference

#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
#include <AddOns/Zi8/Zi8InputMapper.hpp>
#include <AddOns/Zi8/Zi8AlphabetBox.hpp>
#include <AddOns/Zi8/Zi8StrokeBox.hpp>
#include <AddOns/Zi8/Zi8SelectionBox.hpp>

Include dependency graph for Zi8PredictiveInputBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Zi8PredictiveInputBox

Defines

#define | Apoxi_Zi8PredictiveInputBox_hpp

Define Documentation

#define Apoxi_Zi8PredictiveInputBox_hpp

Generated on Tue Jan 24 16:51:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8PredictiveInputBox.hpp Source File

AddOns/Zi8/Zi8PredictiveInputBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_Zi8PredictiveInputBox_hpp)
00012 #define Apoxi_Zi8PredictiveInputBox_hpp
00016
00017 #include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
00018 #include <AddOns/Zi8/Zi8InputMapper.hpp>
00019 #include <AddOns/Zi8/Zi8AlphabetBox.hpp>
00020 #include <AddOns/Zi8/Zi8StrokeBox.hpp>
00021 #include <AddOns/Zi8/Zi8SelectionBox.hpp>
00022
00024 class Zi8PredictiveInputBox : public AbstractPredictiveInputBox {
00025     typedef AbstractPredictiveInputBox Base;
00026
00027     public:
00029         Zi8PredictiveInputBox();
00030
00032         Zi8PredictiveInputBox(Control* parent,
00033                               AbstractMultiLineEditor* m_editor,
00034                               Window* add_word_to_dict_win = 0,
00035                               Window* ext_punc_win = 0);
00036
00038         virtual ~Zi8PredictiveInputBox();
00039
00041         void Init(Control* parent,
00042                   AbstractMultiLineEditor* m_editor,
00043                   Window* add_word_to_dict_win = 0,
00044                   Window* ext_punc_win= 0);
00045
00047         virtual INT GetCapsStatus() const;
00048
00050         virtual BOOLEAN SetMode(PredInputMapper::PredMode mode);
00051
00053         virtual BOOLEAN AddNewWordToUdb(const WString& word);
00054
00055     protected:
00057         virtual void OnLayoutClient();
00058
00060         virtual void UpdateDrawableObjects();
00061
00063         virtual BOOLEAN OnMessage(const Message& msg);
00064
00066         virtual BOOLEAN RouteMessage(const Message& msg);
00067
00068     private:
00069         Zi8AlphabetBox  m_zi8_alphabet_box;
00070         Zi8StrokeBox    m_zi8_stroke_box;
00071         Zi8SelectionBox m_zi8_selection_box;
00072 };
00073
00075 #endif  // Apoxi_Zi8PredictiveInputBox_hpp
00076
00077
Generated on Tue Jan 24 14:45:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8SelectionBox.cpp File Reference

AddOns/Zi8/Zi8SelectionBox.cpp File Reference

#include "Zi8PreComp.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/FontConfig.hpp>
#include <Config/Zi8InputConfig.hpp>
#include "Zi8SelectionBox.hpp"

Include dependency graph for Zi8SelectionBox.cpp:

Generated on Tue Jan 24 16:51:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8SelectionBox.hpp File Reference

AddOns/Zi8/Zi8SelectionBox.hpp File Reference

#include <Gui/DrawableObject.hpp>
#include <Gui/PredInputMapper.hpp>

Include dependency graph for Zi8SelectionBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Zi8SelectionBox
class | Zi8SelectionBoxView

Defines

#define | Apoxi_Zi8SelectionBox_hpp

Define Documentation

#define Apoxi_Zi8SelectionBox_hpp

Generated on Tue Jan 24 16:52:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8SelectionBox.hpp Source File

AddOns/Zi8/Zi8SelectionBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Zi8SelectionBox_hpp)
00010 #define Apoxi_Zi8SelectionBox_hpp
00011
00012 #include <Gui/DrawableObject.hpp>
00013 #include <Gui/PredInputMapper.hpp>
00014
00015 class Zi8SelectionBoxView : public DrawableObjectView {
00016     typedef DrawableObjectView Base;
00017
00018     public:
00020         Zi8SelectionBoxView();
00021
00023         virtual ~Zi8SelectionBoxView();
00024
00026         void Init();
00027
00029         virtual void Draw(const Component &component,
00030                           DeviceContext *dc,
00031                           const Rect &repaint_rect) const;
00032 };
00033
00035 class Zi8SelectionBox : public DrawableObject {
00036     public:
00037         typedef DrawableObject Base;
00038
00040         Zi8SelectionBox();
00041
00043         Zi8SelectionBox(Control *control);
00044
00046         virtual ~Zi8SelectionBox();
00047
00049         void Init(Control *control);
00050
00052         void SetText(const WCHAR *text);
00053
00055         const WCHAR* GetText() const;
00056
00058         void SetSelectedIndex(INT selected_idx) { m_selected_idx = selected_idx; }
00059
00061         INT GetSelectedIndex() const { return m_selected_idx; }
00062
00063         void SetPageFlag(BOOLEAN prev_page, BOOLEAN next_page);
00064
00065         void GetPageFlag(BOOLEAN *prev_page, BOOLEAN *next_page) const;
00066
00068         virtual XYDIM GetDefaultHeight() const;
00069
00070     private:
00071         INT                 m_selected_idx;
00072         BOOLEAN             m_prev_page, m_next_page;
00073         const WCHAR         *m_text;
00074
00075         static Zi8SelectionBoxView m_view;
00076 };
00077
00078
00079 #endif  // Apoxi_Zi8SelectionBox_hpp
00080
00081
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8StrokeBox.cpp File Reference

AddOns/Zi8/Zi8StrokeBox.cpp File Reference

#include "Zi8PreComp.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/FontConfig.hpp>
#include <Config/Zi8InputConfig.hpp>
#include "Zi8StrokeBox.hpp"

Include dependency graph for Zi8StrokeBox.cpp:

Generated on Tue Jan 24 16:52:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8StrokeBox.hpp File Reference

AddOns/Zi8/Zi8StrokeBox.hpp File Reference

#include <Gui/DrawableObject.hpp>

Include dependency graph for Zi8StrokeBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Zi8StrokeBox
class | Zi8StrokeBoxView

Defines

#define | Apoxi_Zi8StrokeBox_hpp
#define | MAX_STROKE_COUNT 20

Define Documentation

#define Apoxi_Zi8StrokeBox_hpp

#define MAX_STROKE_COUNT 20

Generated on Tue Jan 24 16:52:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8StrokeBox.hpp Source File

AddOns/Zi8/Zi8StrokeBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_Zi8StrokeBox_hpp)
00009 #define Apoxi_Zi8StrokeBox_hpp
00010
00011 #include <Gui/DrawableObject.hpp>
00012
00013 #define MAX_STROKE_COUNT 20
00014
00016 class Zi8StrokeBoxView : public DrawableObjectView {
00017     typedef DrawableObjectView Base;
00018
00019     public:
00021         Zi8StrokeBoxView();
00022
00024         virtual ~Zi8StrokeBoxView();
00025
00027         void Init();
00028
00030         virtual void Draw(const Component &component,
00031                           DeviceContext *dc,
00032                           const Rect &repaint_rect) const;
00033 };
00034
00036 class Zi8StrokeBox : public DrawableObject {
00037     public:
00038         typedef DrawableObject Base;
00039
00040         Zi8StrokeBox();
00041
00043         Zi8StrokeBox(Control *control);
00044
00045         virtual ~Zi8StrokeBox();
00046
00048         void Init(Control *control);
00049
00051         void SetText(const WCHAR *text);
00052
00054         const WCHAR* GetText() const { return m_text; }
00055
00057         virtual XYDIM GetDefaultHeight() const;
00058
00059     private:
00060         const WCHAR *m_text;
00061         static Zi8StrokeBoxView m_view;
00062 };
00063
00064 #endif  // Apoxi_Zi8StrokeBox_hpp
00065
00066
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8Wrapper.cpp File Reference

AddOns/Zi8/Zi8Wrapper.cpp File Reference

#include "Zi8PreComp.hpp"
#include <Config/Zi8InputConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include "Zi8Wrapper.hpp"
#include "zi8api.h"

Include dependency graph for Zi8Wrapper.cpp:

Generated on Tue Jan 24 16:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8Wrapper.hpp File Reference

AddOns/Zi8/Zi8Wrapper.hpp File Reference

#include "zi8api.h"
#include <Config/Config.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>

Include dependency graph for Zi8Wrapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Zi8Wrapper

Defines

#define | CAND_PAGE_INCR 10
#define | CHINESE_CAND_PAGE_INCR 6
#define | INPUT_BUF_SIZE 30
#define | MAX_CAND_BUFF_SIZE 30
#define | MAX_ELEM_BUFF_SIZE 30
#define | MAX_NUM_CANDIDATES 10
#define | MAX_NUM_CHINESE_CANDIDATES 6
#define | MAX_WORD_LENGTH_SIZE 80
#define | NULL_VALUE 0xCCCC

Define Documentation

#define CAND_PAGE_INCR 10

#define CHINESE_CAND_PAGE_INCR 6

#define INPUT_BUF_SIZE 30

#define MAX_CAND_BUFF_SIZE 30

#define MAX_ELEM_BUFF_SIZE 30

#define MAX_NUM_CANDIDATES 10

#define MAX_NUM_CHINESE_CANDIDATES 6

#define MAX_WORD_LENGTH_SIZE 80

#define NULL_VALUE 0xCCCC

Generated on Tue Jan 24 16:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddOns/Zi8/Zi8Wrapper.hpp Source File

AddOns/Zi8/Zi8Wrapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #ifndef Apoxi_Zi8Wrapper_hpp
00010 #define Apoxi_Zi8Wrapper_hpp
00011
00012 #ifdef _cplusplus
00013 extern "C"
00014 #endif
00015
00016 #include "zi8api.h"
00017 #include <Config/Config.hpp>
00018 #include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
00019
00020 /************************************************************************/
00021 /* Define values for zi8 core                                                                     */
00022 /************************************************************************/
00023 #define MAX_WORD_LENGTH_SIZE            80  /*Word buffer length*/
00024 #define MAX_CAND_BUFF_SIZE              30  /*Max buffer size of candidate*/
00025 #define MAX_ELEM_BUFF_SIZE              30  /*Max element buffer size */
00026 #define MAX_NUM_CHINESE_CANDIDATES       6  /*Max number of chinese candidate*/
00027 #define MAX_NUM_CANDIDATES              10  /*Max number of candidate*/
00028 #define CAND_PAGE_INCR                  10
00029 #define CHINESE_CAND_PAGE_INCR           6  /*Chinese Candidate page increment*/
00030 #define INPUT_BUF_SIZE                  30
00031 #define NULL_VALUE                      0xCCCC /* null value for the buffer*/
00032
00033 /************************************************************************/
00034 /*    Zi8 class interfaces with Zi8 core and Apoxi                        */
00035 /************************************************************************/
00036 class Zi8Wrapper {
00037     public:
00038
00039         Zi8Wrapper();
00040
00041         virtual ~Zi8Wrapper();
00042
00043         void    Init();
00044
00045         //Handle key down processing
00046         BOOLEAN         HandleEnglishKeyEvent(WCHAR key);
00047
00048         BOOLEAN         HandlePinYinKeyEvent(WCHAR key);
00049
00050         BOOLEAN         HandleStrokeKeyEvent(WCHAR key);
00051
00052         BOOLEAN         HandleToneKeyEvent(WCHAR key);
00053
00054         INT             GetMode() const;
00055
00056         ZI8BOOL         SetZi8EnglishMode();
00057
00058         ZI8BOOL         SetPinyinSpellingMode();
00059
00060         ZI8BOOL         SetPinYinMode();
00061
00062         ZI8BOOL         SetBpmfSpellingMode();
00063
00064         ZI8BOOL         SetBpmfMode();
00065
00066         ZI8BOOL         SetScStrokeMode();
00067
00068         ZI8BOOL         SetTcStrokeMode();
00069
00070         ZI8BOOL         SetZi8GermanMode();
00071
00072         ZI8BOOL         SetZi8SymbolMode();
00073
00074         ZI8BOOL         SetToneMode();
00075
00076         BOOLEAN         GetToneMode();
00077
00078         INT             SetCandidateSelection(BOOLEAN = FALSE, BOOLEAN = FALSE);
00079
00080         INT             SetChineseSelection(BOOLEAN = FALSE, BOOLEAN = FALSE);
00081
00082         const WCHAR*    GetSelectedCandidate()const {return (const WCHAR*)candidate;}
00083
00084         const WCHAR*    GetCandidatesBuffer()const ;
00085
00086         const ZI8WCHAR* GetPhonetics() const;
00087
00088         const ZI8WCHAR* GetStrokes() const;
00089
00090         const WCHAR*    GetChineseCandidate(INT idx);
00091
00092         INT             GetSelectedCandidateLength();
00093
00094         void            ClearBuffer();
00095
00096         void            SetCapsStatus(INT caps_status);
00097
00098         INT             GetSelectedIndex();
00099
00100         BOOLEAN         HasPrevPage();
00101
00102         BOOLEAN         HasNextPage();
00103
00104         BOOLEAN         HasNextCandidates();
00105
00106         BOOLEAN         HasPrevCandidates();
00107
00108         BOOLEAN         HasCandidate();
00109
00110         BOOLEAN         HasChineseCandidate();
00111
00112         BOOLEAN         IsComponent(const WCHAR *chr);
00113
00114         void            SelectComponent(const WCHAR *chr);
00115
00116         void            SetAssociatedCandidates(WCHAR chr);
00117
00118         INT             GetCandCharCount();
00119
00120         INT             GetElementCount();
00121
00122         BOOLEAN         AddWordToUdb(const WCHAR* new_word);
00123
00124         static INT      Zi8PinyinCompare(const WString* string1,const WString* string2);
00125         static INT      Zi8StrokeCompare(const WString* string1,const WString* string2);
00126         static INT      Zi8BopomofoCompare(const WString* string1,const WString* string2);
00127
00128         BOOLEAN         IsLanguageSupported(INT language_number) const;
00129
00130
00131     private:
00132
00133         INT             AddInputBuff(WCHAR key);
00134
00135         ZI8BOOL         Initialize();
00136
00137         ZI8BOOL         ProcessInput();
00138
00139         ZI8BOOL         ProcessPinYinInput();
00140
00141         ZI8BOOL         ProcessBpmfInput();
00142
00143         ZI8BOOL         ProcessStrokeInput();
00144
00145         INT             GetShowCount(const WCHAR *text, AbstractPredictiveInputBox::PredFontId font_id);
00146
00147         INT             m_inputBuff_count;
00148
00149         INT             m_iCandOffset, m_chinese_offset;
00150
00151         INT             m_page_num;
00152
00153         INT             m_selected_idx;
00154
00155         INT             m_count, m_totalCount, m_chinese_totalCount;
00156
00157         INT             m_caps_status;
00158
00159         WCHAR*          m_input_buff_ptr;
00160
00161         WCHAR           m_chinese_candidate;
00162
00163         BOOLEAN         m_next_page, m_prev_page;
00164
00165         BOOLEAN         m_scroll_chinese;
00166
00167         BOOLEAN         m_is_tone_mode;
00168
00169         INT             m_mode;
00170
00171         INT             m_cand_char_count;
00172
00173         ZI8GETPARAM     zi8param;
00174
00175         ZI8UCHAR        ucElemCount;
00176
00177         INT             m_offset[50];
00178
00179         WCHAR           m_input_buff[INPUT_BUF_SIZE];
00180
00181         //Buffer for EZiText prediction
00182         ZI8WCHAR        WordBuffer[MAX_WORD_LENGTH_SIZE];
00183
00184         ZI8WCHAR        elementBuffer[MAX_ELEM_BUFF_SIZE];
00185
00186         ZI8WCHAR        candidatesBuffer[MAX_CAND_BUFF_SIZE];
00187
00188         ZI8WCHAR        PhoneticBuffer[MAX_CAND_BUFF_SIZE];
00189
00190         ZI8WCHAR        StrokeBuffer[MAX_ELEM_BUFF_SIZE];
00191
00192         ZI8WCHAR        candidate[30];
00193
00194         ZI8UCHAR        m_cur_pdb; // Id of the current personal dictionary
00195 };
00196
00197 #ifdef _cplusplus
00198 }//end of extern "C"
00199 #endif
00200
00201 #endif
00202
00203
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/AfsMsgTypes.cpp File Reference

Afs/AfsMsgTypes.cpp File Reference

#include "Afs/PreComp.hpp"
#include "AfsMsgTypes.hpp"

Include dependency graph for AfsMsgTypes.cpp:

Generated on Tue Jan 24 16:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/AfsMsgTypes.hpp File Reference

Afs/AfsMsgTypes.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Application.hpp>
#include <Afs/Uri.hpp>

Include dependency graph for AfsMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegNotifyMsg

Defines

#define | Afs_AfsMsgTypes_hpp

Define Documentation

#define Afs_AfsMsgTypes_hpp

Generated on Tue Jan 24 16:52:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/AfsMsgTypes.hpp Source File

Afs/AfsMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "ayyalaso_apoxi_usb_rel_view\lnz_apoxi\Apoxi\Afs\AfsMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Afs_AfsMsgTypes_hpp)
00016 #define Afs_AfsMsgTypes_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Kernel/MsgTypes.hpp>
00021 #include <Kernel/Application.hpp>
00022 #include <Afs/Uri.hpp>
00023
00024
00025 /* ----------------------------------------------------------------------
00026     Classes
00027     ---------------------------------------------------------------------- */
00028
00029 /*  ======================================================================
00030     Class RegNotifyMsg
00031     ====================================================================== */
00032
00034 class RegNotifyMsg : public ContextMsg {
00035     public:
00036         RegNotifyMsg(ExecutionContext* context, const Uri& uri);
00037         virtual ~RegNotifyMsg();
00038
00039         virtual const MsgMetaData& GetMetaData() const;
00040         const Uri& GetUri() const { return m_uri; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 16000
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         Uri m_uri;
00050
00051     };
00052
00053 #endif // Afs_AfsMsgTypes_hpp
00054
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/ApoxiAfsVersion.cpp File Reference

Afs/ApoxiAfsVersion.cpp File Reference

#include "Afs/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiAfsVersion.cpp:

Functions

ApoxiDefVersionInfo (Afs, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | Afs | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:52:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/BackupFileHandler.cpp File Reference

Afs/BackupFileHandler.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Ffs/FlsFile.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Afs/BackupFileHandler.hpp>

Include dependency graph for BackupFileHandler.cpp:

Generated on Tue Jan 24 16:52:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/BackupFileHandler.hpp File Reference

Afs/BackupFileHandler.hpp File Reference

#include <Afs/RegDefines.hpp>
#include <Afs/RegNodeFile.hpp>

Include dependency graph for BackupFileHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BackupFileHandler
RegBackUp FileHandler. More...

Defines

#define | Apoxi_BackupFileHandler_hpp

Define Documentation

#define Apoxi_BackupFileHandler_hpp

Generated on Tue Jan 24 16:52:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/BackupFileHandler.hpp Source File

Afs/BackupFileHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BackupFileHandler_hpp)
00010 #define Apoxi_BackupFileHandler_hpp
00013 #include <Afs/RegDefines.hpp>
00014 #include <Afs/RegNodeFile.hpp>
00015
00016
00017 //RegBackUp File
00040
00041 class BackupFileHandler {
00042     public:
00044         static BOOLEAN RollBackTransaction(INT16 transaction_id);
00046         static BOOLEAN CreateBackupFile(INT16 org_file_id, INT16& backup_fileid, INT16 transaction_id);
00048         static BOOLEAN DeleteBackupFile(INT16 backup_file_id);
00049 };
00050
00052 #endif
00053
00054
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/DeletedNode.hpp File Reference

Afs/DeletedNode.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DeletedNode
class | DeletedNodeList

Defines

#define | Apoxi_DeletedNode_hpp

Define Documentation

#define Apoxi_DeletedNode_hpp

Generated on Tue Jan 24 16:52:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/DeletedNode.hpp Source File

Afs/DeletedNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DeletedNode_hpp)
00010 #define Apoxi_DeletedNode_hpp
00013
00014
00015 class DeletedNode {
00016
00017     public:
00018         DeletedNode() : m_file_id(0), m_next(0), m_prev(0)
00019         {}
00020
00021         DeletedNode(INT file_id) : m_file_id(file_id), m_next(0), m_prev(0)
00022         {}
00023
00024         ~DeletedNode(){}
00025
00026
00027
00028         INT GetFileId()
00029         {
00030             return m_file_id;
00031         }
00032
00033         void SetFileId(INT file_id)
00034         {
00035             m_file_id = file_id;
00036         }
00037
00038         DeletedNode* GetNext()
00039         {
00040             return m_next;
00041         }
00042
00043         void SetNext(DeletedNode* next)
00044         {
00045             m_next = next;
00046         }
00047
00048         DeletedNode* GetPrevious()
00049         {
00050             return m_prev;
00051         }
00052
00053         void SetPrevious(DeletedNode* prev)
00054         {
00055             m_prev = prev;
00056         }
00057
00058     private:
00059
00060         INT m_file_id;
00061         DeletedNode*    m_next;
00062         DeletedNode*    m_prev;
00063 };
00064
00065
00067 class DeletedNodeList {
00068
00069     public:
00070
00071         DeletedNodeList() : m_start(0), m_end(0)
00072         {}
00073
00074         ~DeletedNodeList()
00075         {
00076             DeletedNode* temp = m_start;
00077             while(temp)  {
00078                 temp = m_start->GetNext();
00079                 delete m_start;
00080             }
00081         }
00082
00083         DeletedNode* PopBack()
00084         {
00085             DeletedNode* ret_val = m_end;
00086             if(m_end)  {
00087                 if(m_start == m_end)  {
00088                     m_start = m_end = 0;
00089                     return ret_val;
00090                 }
00091                 m_end = m_end->GetPrevious();
00092                 m_end->SetNext(0);
00093
00094                 ret_val->SetPrevious(0);
00095             }
00096             return ret_val;
00097         }
00098
00099         void PushBack(DeletedNode* node)
00100         {
00101             if(!node)
00102                 return;
00103             if(!m_start)  {
00104                 m_start = m_end = node;
00105                 return;
00106             }
00107             m_end->SetNext(node);
00108             node->SetPrevious(m_end);
00109             m_end = node;
00110         }
00111
00112         DeletedNode* GetFirst()
00113         {
00114             return m_start;
00115         }
00116
00117     private:
00118         DeletedNode*    m_start;
00119         DeletedNode*    m_end;
00120 };
00121
00123 #endif
00124
00125
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/DirtyFileHandler.cpp File Reference

Afs/DirtyFileHandler.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Ffs/FlsFile.hpp>
#include <Afs/RegDefines.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/DirtyFileHandler.hpp>

Include dependency graph for DirtyFileHandler.cpp:

Generated on Tue Jan 24 16:52:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/DirtyFileHandler.hpp File Reference

Afs/DirtyFileHandler.hpp File Reference

#include <Afs/RegDefines.hpp>

Include dependency graph for DirtyFileHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DirtyFileHandler
struct | RegDirtyFile
structure of dirty file More...

Defines

#define | Apoxi_DirtyFileHandler_hpp

Define Documentation

#define Apoxi_DirtyFileHandler_hpp

Generated on Tue Jan 24 16:52:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/DirtyFileHandler.hpp Source File

Afs/DirtyFileHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DirtyFileHandler_hpp)
00010 #define Apoxi_DirtyFileHandler_hpp
00013 #include <Afs/RegDefines.hpp>
00014
00015 //Dirty file
00029
00030 struct RegDirtyFile {
00031     RegFileHeader   m_file_header;
00032     INT16           m_last_commited_transaction;
00033     BOOLEAN         m_dirty_flag;
00034 };
00035
00037 class DirtyFileHandler {
00038     public:
00039
00041         ~DirtyFileHandler() {}
00042
00044         static BOOLEAN Init();
00045
00047         static BOOLEAN GetDirtyFlag();
00048
00050         static INT16 GetLastTransaction();
00051
00053         static void SetDirtyFlag(BOOLEAN flag);
00054
00056         static void SetLastTransaction(INT16 last_commited_transaction);
00057
00059         static BOOLEAN FlushDirtyFile();
00060
00061     private:
00062
00064         DirtyFileHandler() {}
00065
00067         static RegDirtyFile m_dirty_file_buffer;
00068 };
00070 #endif
00071
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/GuidServiceTable.cpp File Reference

Afs/GuidServiceTable.cpp File Reference

#include <Afs/PreComp.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <Afs/GuidServiceTable.hpp>
#include <Afs/Uri.hpp>

Include dependency graph for GuidServiceTable.cpp:

Generated on Tue Jan 24 16:52:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/GuidServiceTable.hpp File Reference

Afs/GuidServiceTable.hpp File Reference

#include <AddOns/Services/Service.hpp>
#include <Afs/ObjectTreeService.hpp>

Include dependency graph for GuidServiceTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GuidServiceTable
struct | GuidUriTable

Defines

#define | Apoxi_GuidServiceTable_hpp
#define | APOXI_REG_MAX_ASOT 5

Define Documentation

#define Apoxi_GuidServiceTable_hpp

Generated on Tue Jan 24 16:52:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/GuidServiceTable.hpp Source File

Afs/GuidServiceTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_GuidServiceTable_hpp)
00009 #define Apoxi_GuidServiceTable_hpp
00012 #include <AddOns/Services/Service.hpp>
00013 #include <Afs/ObjectTreeService.hpp>
00014
00015 #if !defined(APOXI_REG_MAX_ASOT)
00016 #define APOXI_REG_MAX_ASOT 5
00017 #endif
00018
00020 struct GuidUriTable{
00021     Uri rooturi;
00022     ObjectTreeService* serviceptr;
00023 };
00024
00026 class GuidServiceTable {
00027     public:
00029         enum {
00030             c_asot_max = APOXI_REG_MAX_ASOT
00031         };
00032
00034         static ObjectTreeService* GetObjectTreeforURI(const Uri& reg_uri);
00035
00037         static BOOLEAN SetObjectTreeURI(const Uri& reg_uri, const Guid& guid);
00038
00039     private:
00040
00041         static GuidUriTable m_guid_uri_table[c_asot_max];
00042 };
00044 #endif
00045
00046
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LocalDataStore.cpp File Reference

Afs/LocalDataStore.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include <Afs/NodeFileHandler.hpp>
#include <Afs/UriMappingTable.hpp>
#include <Afs/Uri.hpp>
#include <Afs/DeletedNode.hpp>
#include <Afs/BackupFileHandler.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Afs/DirtyFileHandler.hpp>
#include <Afs/LocalDataStore.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for LocalDataStore.cpp:

Generated on Tue Jan 24 16:52:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LocalDataStore.hpp File Reference

Afs/LocalDataStore.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LocalDataStore

Defines

#define | Apoxi_LocalDataStore_hpp

Define Documentation

#define Apoxi_LocalDataStore_hpp

Generated on Tue Jan 24 16:52:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LocalDataStore.hpp Source File

Afs/LocalDataStore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_LocalDataStore_hpp)
00010 #define Apoxi_LocalDataStore_hpp
00013 class Uri;
00014 class String;
00015 class DataItem;
00016
00018 class LocalDataStore {
00019     public:
00021         static RegResult Get(const Uri& uri, DataItem& dataitem, INT16 transac_id);
00022
00024         static RegResult Set(const Uri& parent_uri, const String& node_name, const DataItem& dataitem, INT16 transac_id);
00025
00027         static RegResult Replace(const Uri& uri, const DataItem& dataitem, INT16 transac_id);
00029         static RegResult AddLeafNode(const Uri& parent_uri, const String& node_name, const DataItem& dataitem, INT16 transac_id);
00030
00032         static RegResult AddInteriorNode(const Uri& parent_uri, const Uri& node_uri, INT16 transac_id);
00033
00035         static RegResult Delete(const Uri& uri, INT16 transac_id);
00036
00038         static void RegCommitTransaction(INT16 transaction_id);
00039
00040
00041     private:
00043         static void DeleteInteriorRecord(INT file_id, INT16 transaction_id);
00044
00046         static BOOLEAN TakeBackup(INT16 file_id, INT16 transac_id);
00047
00048 };
00050 #endif
00051
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LockTable.cpp File Reference

Afs/LockTable.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/LockTable.hpp>

Include dependency graph for LockTable.cpp:

Generated on Tue Jan 24 16:52:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LockTable.hpp File Reference

Afs/LockTable.hpp File Reference

#include <Afs/Uri.hpp>
#include <Afs/RegistryTypes.hpp>

Include dependency graph for LockTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LockTable
struct | LockTableEntry
structure to store uri and application pointer that locked the uri More...

Defines

#define | Apoxi_LockTable_hpp
#define | APOXI_REG_MAX_URIS_IN_TABLE 256

Define Documentation

#define Apoxi_LockTable_hpp

Generated on Tue Jan 24 16:52:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LockTable.hpp Source File

Afs/LockTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_LockTable_hpp)
00010 #define Apoxi_LockTable_hpp
00013
00014 #include <Afs/Uri.hpp>
00015 #include <Afs/RegistryTypes.hpp>
00016
00017 #if !defined(APOXI_REG_MAX_URIS_IN_TABLE)
00018     #define APOXI_REG_MAX_URIS_IN_TABLE 256
00019 #endif
00020
00021 class Application;
00022
00024
00025 struct LockTableEntry{
00026     BOOLEAN transac_flag;
00027     Uri locked_object_uri;
00028     Application* lock_owner_id;
00029 };
00030
00032
00033 class LockTable {
00034     public:
00036         enum {
00037             c_max_uris_per_table = APOXI_REG_MAX_URIS_IN_TABLE,
00038             c_table_full = -1
00039         };
00040
00042         LockTable(INT16 locktableid);
00043
00045         ~LockTable();
00046
00048         INT16 AddUri(const Uri &lock_uri, Application* lock_owner, BOOLEAN transac_flag);
00049
00051         Application* SearchUri(const Uri &uri_to_search, INT16& lock_index, BOOLEAN& transac_flag);
00052
00054         Application* GetUri(INT16 lockid, Uri& locked_uri, BOOLEAN& transac_flag);
00055
00057         void RemoveUri(INT16 lockid);
00058
00060         LockTable* GetNextLockTable() { return m_next;}
00061
00063         void SetNextLockTable(LockTable* lck_tbl) {m_next = lck_tbl;}
00064
00066         INT16 GetLockTableId() { return lock_table_id; }
00067
00069         void SetLockTableId(INT16 id) { lock_table_id = id; }
00070
00072         RegResult HasAnyChildLocked(const Uri& uri_to_search );
00073
00075         RegResult IsDeletePossible(const Uri& uri_to_search );
00076
00077     private:
00078
00080         INT16 lock_table_id;
00081
00083         LockTable* m_next;
00084
00086         LockTableEntry m_lock_table_entry[c_max_uris_per_table];
00087 };
00089 #endif
00090
00091
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LockTableList.cpp File Reference

Afs/LockTableList.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/LockTableList.hpp>

Include dependency graph for LockTableList.cpp:

Generated on Tue Jan 24 16:52:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LockTableList.hpp File Reference

Afs/LockTableList.hpp File Reference

#include <Afs/LockTable.hpp>

Include dependency graph for LockTableList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LockTableList

Defines

#define | Apoxi_LockTableList_hpp

Define Documentation

#define Apoxi_LockTableList_hpp

Generated on Tue Jan 24 16:52:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/LockTableList.hpp Source File

Afs/LockTableList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_LockTableList_hpp)
00009 #define Apoxi_LockTableList_hpp
00012 #include <Afs/LockTable.hpp>
00013
00015
00016 class LockTableList {
00017
00018     public:
00019
00021         ~LockTableList();
00022
00024         static LockTableList* GetLockTableList();
00025
00027         INT16 AddLockUriInTable(const Uri& uri_string, Application* lock_owner, BOOLEAN transac_flag);
00028
00030         Application* FindUriFromTables(const Uri& given_uri, INT16& lockid, BOOLEAN& transac_flag);
00031
00033         Application* FindUriFromTables(INT16 lockid, Uri& uri, BOOLEAN& transac_flag);//it's an in/out parameter
00034
00036         RegResult HasAnyChildLocked(const Uri& given_uri);
00037
00039         RegResult IsDeletePossible(const Uri& given_uri);
00040
00042         void RemoveLockUriInTable(INT16 lockid);
00043
00044     protected:
00045
00047         BOOLEAN CreateLockTable();
00048
00050         void DeleteLockTable(INT16 locktableid);
00051
00053         LockTable* GetLockTable(INT16 locktableid);
00054
00055     private:
00056
00058         LockTableList();
00059
00060         static LockTableList m_lock_table_list;
00061
00063         LockTable* m_lock_table;
00064
00066         LockTable* m_start_of_table;
00067
00069         INT16 lock_table_count;
00070 };
00072 #endif
00073
00074
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/NodeFileHandler.cpp File Reference

Afs/NodeFileHandler.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Ffs/FlsFile.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Afs/RegNodeFile.hpp>
#include <Afs/UriMappingTable.hpp>
#include <Afs/NodeFileHandler.hpp>
#include <Afs/Uri.hpp>

Include dependency graph for NodeFileHandler.cpp:

Generated on Tue Jan 24 16:52:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/NodeFileHandler.hpp File Reference

Afs/NodeFileHandler.hpp File Reference

#include <Afs/RegistryTypes.hpp>

Include dependency graph for NodeFileHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NodeFileHandler

Defines

#define | Apoxi_NodeFileHandler_hpp

Define Documentation

#define Apoxi_NodeFileHandler_hpp

Generated on Tue Jan 24 16:52:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/NodeFileHandler.hpp Source File

Afs/NodeFileHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_NodeFileHandler_hpp)
00010 #define Apoxi_NodeFileHandler_hpp
00013
00014 #include <Afs/RegistryTypes.hpp>
00015
00016 class String;
00017 class RegBlobObject;
00018 class DataItem;
00019 class Uri;
00020
00022 class NodeFileHandler {
00023     public:
00024
00026         static RegResult AddNodeEntry(INT16 transaction_id, INT16 file_id, const String& node_name, const DataItem& dataitem, INT16& blob_file_id);
00027
00029         static RegResult AddInteriorNodeEntry(INT16 transaction_id, INT16 file_id, const Uri& uri, INT16 int_file_id);
00030
00032         static RegResult RemoveNodeEntry(INT16 transaction_id, INT16 file_id, const Uri& uri, INT16& blob_file_id);
00033
00035         static RegResult ReplaceNodeEntry(INT16 transaction_id, INT16 file_id, const String& node_name, const DataItem& dataitem, INT16& old_blob_id, INT16& new_file_id);
00036
00038         static RegResult GetNodeEntry(INT16 transaction_id, INT16 file_id, const Uri& uri, DataItem& dataitem);
00039
00041         static RegResult CreateInteriorNodeEntry(INT16& file_id);
00042
00044         static RegResult CreateInteriorNodeEntry(const Uri& abs_uri, INT16& file_id);
00046
00048         static RegResult RemoveInteriorNodeEntry(INT16 file_id);
00049
00050         static BOOLEAN IsNodeExisting(const Uri& passed_uri, INT16 parent_file_id);
00051
00052
00053     private:
00055         static BOOLEAN CreateBlobFile(RegBlobObject* blob_obj, INT16& file_id);
00056
00057 };
00059 #endif
00060
00061
00062
00063
00064
00065
00066
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/NotificationTable.cpp File Reference

Afs/NotificationTable.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/NotificationTable.hpp>
#include <Afs/Registry.hpp>
#include <Afs/AfsMsgTypes.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for NotificationTable.cpp:

Generated on Tue Jan 24 16:52:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/NotificationTable.hpp File Reference

Afs/NotificationTable.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Afs/Uri.hpp>

Include dependency graph for NotificationTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NotificationArray
class | NotificationTable
class | NotificationTableEntry
NotificationTableEntry contains the URI -> Callback/App_ptr mapping. More...
class | RegCbNotifyMsg

Defines

#define | Apoxi_NotificationTable_hpp
#define | APOXI_REGISTERED_TABLE_SIZE 10

Typedefs

typedef void(* | Cb_function_ptr )(const CHAR *)

Define Documentation

#define Apoxi_NotificationTable_hpp

Generated on Tue Jan 24 16:52:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/NotificationTable.hpp Source File

Afs/NotificationTable.hpp

Go to the documentation of this file.
00001 #if !defined(Apoxi_NotificationTable_hpp)
00002 #define Apoxi_NotificationTable_hpp
00003
00006
00007 #include <Auxiliary/Linkable.hpp>
00008 #include <Kernel/MsgTypes.hpp>
00009 #include <Afs/Uri.hpp>
00010
00011 #if !defined(APOXI_REGISTERED_TABLE_SIZE)
00012     #define APOXI_REGISTERED_TABLE_SIZE 10
00013 #endif
00014
00015 class ExecutionContext;
00016
00017 typedef void (* Cb_function_ptr) (const CHAR*);
00018
00019 /*  ======================================================================
00020     Class RegCbNotifyMsg
00021     ====================================================================== */
00022
00024 class RegCbNotifyMsg : public ContextExecuteMsg {
00025     public:
00027         RegCbNotifyMsg(ExecutionContext* context, void* callback, const Uri& uri);
00028
00030         virtual ~RegCbNotifyMsg();
00031
00033         virtual void Execute();
00034
00036         virtual Message* Clone() const;
00037
00038     private:
00039         static const MsgMetaData m_meta_data;
00040         void* m_callback;
00041         Uri m_uri;
00042
00043 };
00044
00045
00047 class NotificationTableEntry {
00048     public:
00049
00051         NotificationTableEntry() : m_cb_function_ptr(0), m_app_ptr(0)
00052         {}
00053
00055         NotificationTableEntry(Uri& uri, Cb_function_ptr cb_function_ptr, Application *app_ptr)
00056             : m_cb_function_ptr(cb_function_ptr), m_app_ptr(app_ptr), m_uri(uri)
00057         {}
00058
00060         NotificationTableEntry(NotificationTableEntry *rhs)
00061         {
00062             m_uri = rhs->GetUri();
00063             m_cb_function_ptr = rhs->GetCbFunction();
00064             m_app_ptr = rhs->GetAppPtr();
00065         }
00066
00068         ~NotificationTableEntry() {}
00069
00070         //Following are getter and setter functions
00072         Uri GetUri() const
00073         {
00074             return m_uri;
00075         }
00076
00078         void SetUri(const Uri& uri)
00079         {
00080             m_uri = uri;
00081         }
00082
00084         Cb_function_ptr GetCbFunction()
00085         {
00086             return m_cb_function_ptr;
00087         }
00088
00090         void SetCbFunction(Cb_function_ptr cb_function_ptr)
00091         {
00092             m_cb_function_ptr = cb_function_ptr;
00093         }
00094
00096         Application* GetAppPtr()
00097         {
00098             return m_app_ptr;
00099         }
00100
00102         void SetAppPtr(Application* app_ptr)
00103         {
00104             m_app_ptr = app_ptr;
00105         }
00106
00107
00108         //The following only checks if the this->URI is less than
00109         //rhs->URI
00110         BOOLEAN operator < (NotificationTableEntry& rhs) const;
00111
00113         BOOLEAN operator == (NotificationTableEntry& rhs) const;
00114
00115     private:
00116         Cb_function_ptr m_cb_function_ptr; //Callback function pointer
00117         Application* m_app_ptr; //Application function pointer
00118         Uri m_uri; //Uri pointer
00119 };
00120
00121
00126 class NotificationArray : public Linkable <NotificationArray> {
00127     public:
00128
00130         enum {
00131                 c_table_size = APOXI_REGISTERED_TABLE_SIZE,
00132                 c_table_full = -1
00133         };
00134
00136         INT16 AddUri(const Uri& uri, Cb_function_ptr cb_function_ptr, Application *app_ptr);
00137
00138         INT16 DeleteUri(const Uri& uri, Cb_function_ptr cb_function_ptr, Application *app_ptr);
00139         INT16 SearchUri(const Uri& uri, Cb_function_ptr cb_fn_ptr, Application *app_ptr);
00140
00142         void SendNotification(const Uri& uri);
00143
00144
00145     private:
00146
00148         NotificationTableEntry m_notification_table_entry[c_table_size];
00149
00150 };
00151
00152 //This class contains the List of NotificationArrays
00155 class NotificationTable {
00156     public:
00157
00160         ~NotificationTable()
00161         {
00162             NotificationArray* temp = 0;
00163             NotificationArray* notification_array_ptr = m_notification_list.GetFront();
00164             FOREVER
00165             {
00166                 if(notification_array_ptr == 0)
00167                     break;
00168                 temp = notification_array_ptr;
00169                 notification_array_ptr = notification_array_ptr->GetNext();
00170                 delete temp;
00171             }
00172         }
00173
00175         static NotificationTable* GetTable();
00176
00178         BOOLEAN AddRegistration(const Uri& uri, Cb_function_ptr cb_function_ptr, Application *app_ptr);
00179
00180         BOOLEAN DeleteRegistration(const Uri& uri, Cb_function_ptr cb_function_ptr, Application *app_ptr);
00181
00183         void SendNotificationsToApps(const Uri& uri) const;
00184
00185     private:
00186
00188         NotificationTable() {};
00189
00191         BOOLEAN CreateNotificationTable();
00192
00194         static void NotificationCallBack(Uri& uri, Application *app_ptr);
00195
00197         static NotificationTable m_notification_table;
00198
00200         LinkedList <NotificationArray> m_notification_list;
00201 };
00202
00203
00205 #endif
00206
00207
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/ObjectDataConverter.cpp File Reference

Afs/ObjectDataConverter.cpp File Reference

#include <Afs/PreComp.hpp>
#include <AddOns/AuxExtensions/MimeCoding.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Afs/ObjectDataConverter.hpp>
#include <stdio.h>

Include dependency graph for ObjectDataConverter.cpp:

Generated on Tue Jan 24 16:52:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/ObjectDataConverter.hpp File Reference

Afs/ObjectDataConverter.hpp File Reference

#include <Afs/RegistryTypes.hpp>

Include dependency graph for ObjectDataConverter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObjectDataConverter

Defines

#define | Apoxi_ObjectDataConverter_hpp

Define Documentation

#define Apoxi_ObjectDataConverter_hpp

Generated on Tue Jan 24 16:52:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/ObjectDataConverter.hpp Source File

Afs/ObjectDataConverter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ObjectDataConverter_hpp)
00010 #define Apoxi_ObjectDataConverter_hpp
00013
00014 #include <Afs/RegistryTypes.hpp>
00015
00016 class DataItem;
00017
00019 class ObjectDataConverter {
00020     public:
00021
00023         static void ConvertObjectDataToDataItem(const RegObjectData& object_data, DataItem& data_item);
00024
00026         static BOOLEAN ConvertDataItemToObjectData(const DataItem& data_item, RegObjectData& object_data);
00027
00028 };
00030 #endif
00031
00032
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/ObjectTreeService.cpp File Reference

Afs/ObjectTreeService.cpp File Reference

#include <AddOns/Services/Service.hpp>
#include <Afs/PreComp.hpp>
#include <Afs/ObjectTreeService.hpp>

Include dependency graph for ObjectTreeService.cpp:

Generated on Tue Jan 24 16:52:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/ObjectTreeService.hpp File Reference

Afs/ObjectTreeService.hpp File Reference

#include <AddOns/Services/Service.hpp>
#include <Afs/Registry.hpp>

Include dependency graph for ObjectTreeService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObjectTreeService

Defines

#define | Apoxi_ObjectTreeService_hpp

Define Documentation

#define Apoxi_ObjectTreeService_hpp

Generated on Tue Jan 24 16:52:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/ObjectTreeService.hpp Source File

Afs/ObjectTreeService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_ObjectTreeService_hpp)
00009 #define Apoxi_ObjectTreeService_hpp
00012 #include <AddOns/Services/Service.hpp>
00013 #include <Afs/Registry.hpp>
00014
00015
00017 class ObjectTreeService : public Service {
00018     public:
00019
00021         ObjectTreeService(const Guid& guid);
00022
00024         virtual ~ObjectTreeService();
00025
00026         // The following Interfaces are for Generic Applications (App -> Registry)
00027
00029         virtual RegResult Get(const CHAR* uri, RegObjectData& reg_data_object, INT16 bufsize) = 0;
00030
00032         virtual RegResult Replace(const CHAR* uri, const RegObjectData& reg_data_object) = 0;
00033
00035         virtual RegResult Add(const CHAR* uri, const RegObjectData& reg_data_object)= 0;
00036
00038         virtual RegResult Delete(const CHAR* uri) = 0;
00039
00041         virtual RegResult Lock(const CHAR* uri, INT16 lockid) = 0;
00042
00044         virtual RegResult Unlock(INT16 lockid) = 0;
00045
00046 };
00048 #endif
00049
00050
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/PreComp.cpp File Reference

Afs/PreComp.cpp File Reference

#include "Afs/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/PreComp.hpp File Reference

Afs/PreComp.hpp File Reference

#include <Afs/Ffs/FfsSim.hpp>
#include <AddOns/AuxExtensions/MimeCoding.hpp>
#include <AddOns/Services/Service.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <Afs/AfsMsgTypes.hpp>
#include <Afs/BackupFileHandler.hpp>
#include <Afs/DeletedNode.hpp>
#include <Afs/DirtyFileHandler.hpp>
#include <Afs/GuidServiceTable.hpp>
#include <Afs/LocalDataStore.hpp>
#include <Afs/LockTable.hpp>
#include <Afs/LockTableList.hpp>
#include <Afs/NodeFileHandler.hpp>
#include <Afs/NotificationTable.hpp>
#include <Afs/RegDefines.hpp>
#include <Afs/RegDeleteBuffer.hpp>
#include <Afs/Registry.hpp>
#include <Afs/RegistryTypes.hpp>
#include <Afs/RegIterator.hpp>
#include <Afs/RegManager.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Afs/RegNodeFile.hpp>
#include <Afs/ObjectDataConverter.hpp>
#include <Afs/ObjectTreeService.hpp>
#include <Afs/Uri.hpp>
#include <Afs/UriMappingTable.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Ffs/FfsMimeTypeMap.hpp>
#include <Afs/Ffs/FfsTypes.hpp>
#include <Afs/Ffs/FlsFile.hpp>
#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Afs/Rfs/FileChunkOperator.hpp>
#include <Afs/Rfs/FileDataSink.hpp>
#include <Afs/Rfs/FileDataSource.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include <Afs/Rfs/FileVisitor.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Rfs/PathProfile.hpp>
#include <Afs/Rfs/RfsMsgTypes.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/StorageDevice.hpp>
#include <Afs/Rfs/StorageDeviceFilter.hpp>
#include <Afs/Rfs/StorageDeviceIterator.hpp>
#include <Afs/Rfs/StorageDeviceVisitor.hpp>
#include <ApoxiVersion.hpp>
#include <Auxiliary/BinData.hpp>
#include <Auxiliary/BitVector.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/DataSink.hpp>
#include <Auxiliary/DataSource.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/Macros.hpp>
#include <Auxiliary/MimeTypeTable.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/Time.hpp>
#include <Auxiliary/WildcardStrncmp.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Config/FfsConfig.hpp>
#include <Devices/StartUp.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/SubSystem.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/VersionInfo.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/Os/OsClass.hpp>
#include <Kernel/Os/Semaphore.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include <stdio.h>
#include <string.h>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <direct.h>
#include <io.h>
#include <sys/stat.h>
#include <errno.h>
#include <share.h>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/PreComp.hpp Source File

Afs/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if defined(APOXI_RTOS_WIN32)
00010     // Host simulator for FFS.
00011     #include <Afs/Ffs/FfsSim.hpp>
00012 #elif !defined(FFS_PRESENT)
00013     #error The flash file system (FFS) is a prerequisite for an APOXI target build - please enable feature FFS!
00014 #else
00015     #include <stack/driver.h>
00016 #endif
00017
00018 #include <AddOns/AuxExtensions/MimeCoding.hpp>
00019
00020 #include <AddOns/Services/Service.hpp>
00021 #include <AddOns/Services/ServiceBroker.hpp>
00022
00023 #include <Afs/AfsMsgTypes.hpp>
00024 #include <Afs/BackupFileHandler.hpp>
00025 #include <Afs/DeletedNode.hpp>
00026 #include <Afs/DirtyFileHandler.hpp>
00027 #include <Afs/GuidServiceTable.hpp>
00028 #include <Afs/LocalDataStore.hpp>
00029 #include <Afs/LockTable.hpp>
00030 #include <Afs/LockTableList.hpp>
00031 #include <Afs/NodeFileHandler.hpp>
00032 #include <Afs/NotificationTable.hpp>
00033 #include <Afs/RegDefines.hpp>
00034 #include <Afs/RegDeleteBuffer.hpp>
00035 #include <Afs/Registry.hpp>
00036 #include <Afs/RegistryTypes.hpp>
00037 #include <Afs/RegIterator.hpp>
00038 #include <Afs/RegManager.hpp>
00039 #include <Afs/RegMemoryPool.hpp>
00040 #include <Afs/RegNodeFile.hpp>
00041 #include <Afs/ObjectDataConverter.hpp>
00042 #include <Afs/ObjectTreeService.hpp>
00043 #include <Afs/Uri.hpp>
00044 #include <Afs/UriMappingTable.hpp>
00045
00046 #include <Afs/Ffs/FfsHandler.hpp>
00047 #include <Afs/Ffs/FfsMimeTypeMap.hpp>
00048 #include <Afs/Ffs/FfsTypes.hpp>
00049 #include <Afs/Ffs/FlsFile.hpp>
00050
00051 #include <Afs/Rfs/DirectoryIterator.hpp>
00052 #include <Afs/Rfs/File.hpp>
00053 #include <Afs/Rfs/FileBinData.hpp>
00054 #include <Afs/Rfs/FileChunkOperator.hpp>
00055 #include <Afs/Rfs/FileDataSink.hpp>
00056 #include <Afs/Rfs/FileDataSource.hpp>
00057 #include <Afs/Rfs/FileFilter.hpp>
00058 #include <Afs/Rfs/FileVisitor.hpp>
00059 #include <Afs/Rfs/Path.hpp>
00060 #include <Afs/Rfs/Pathname.hpp>
00061 #include <Afs/Rfs/PathProfile.hpp>
00062 #include <Afs/Rfs/RfsMsgTypes.hpp>
00063 #include <Afs/Rfs/RootFileSystem.hpp>
00064 #include <Afs/Rfs/StorageDevice.hpp>
00065 #include <Afs/Rfs/StorageDeviceFilter.hpp>
00066 #include <Afs/Rfs/StorageDeviceIterator.hpp>
00067 #include <Afs/Rfs/StorageDeviceVisitor.hpp>
00068
00069 #include <ApoxiVersion.hpp>
00070
00071 #include <Auxiliary/BinData.hpp>
00072 #include <Auxiliary/BitVector.hpp>
00073 #include <Auxiliary/DataItem.hpp>
00074 #include <Auxiliary/DataSink.hpp>
00075 #include <Auxiliary/DataSource.hpp>
00076 #include <Auxiliary/Date.hpp>
00077 #include <Auxiliary/Linkable.hpp>
00078 #include <Auxiliary/Macros.hpp>
00079 #include <Auxiliary/MimeTypeTable.hpp>
00080 #include <Auxiliary/NiSharedPtr.hpp>
00081 #include <Auxiliary/RegBlobObject.hpp>
00082 #include <Auxiliary/SimpleMap.hpp>
00083 #include <Auxiliary/String.hpp>
00084 #include <Auxiliary/Time.hpp>
00085 #include <Auxiliary/WildcardStrncmp.hpp>
00086 #include <Auxiliary/WString.hpp>
00087 #include <Auxiliary/WStrUtil.hpp>
00088
00089 #include <Config/FfsConfig.hpp>
00090
00091 #include <Devices/StartUp.hpp>
00092
00093 #include <Kernel/Application.hpp>
00094 #include <Kernel/Condition.hpp>
00095 #include <Kernel/ExecutionContext.hpp>
00096 #include <Kernel/Message.hpp>
00097 #include <Kernel/MessageRouter.hpp>
00098 #include <Kernel/MsgTypes.hpp>
00099 #include <Kernel/SubSystem.hpp>
00100 #include <Kernel/System.hpp>
00101 #include <Kernel/Types.hpp>
00102 #include <Kernel/VersionInfo.hpp>
00103
00104 #include <Kernel/Os/Os.hpp>
00105 #include <Kernel/Os/OsClass.hpp>
00106 #include <Kernel/Os/Semaphore.hpp>
00107 #include <Kernel/Os/SemObtainer.hpp>
00108
00109 #include <stdio.h>
00110 #include <string.h>
00111
00112 #if defined(APOXI_RTOS_WIN32)
00113     #include <Auxiliary/Vector.hpp>
00114     #include <Auxiliary/DateTime.hpp>
00115     #include <Kernel/Os/Mutex.hpp>
00116     #include <Kernel/Os/MutexObtainer.hpp>
00117     #include <direct.h>
00118     #include <io.h>
00119     #include <sys/stat.h>
00120     #include <errno.h>
00121     #include <share.h>
00122 #endif
00123
00124 #ifdef APOXI_LIB_ADDON_AFSRFS
00125     #include <AddOns/AfsRfs/RootStorageDeviceImp.hpp>
00126 #endif
00127
00128 #ifdef APOXI_LIB_ADDON_AFSRAM
00129     #include <AddOns/AfsRam/RamStorageDeviceImp.hpp>
00130 #endif
00131
00132 #ifdef APOXI_LIB_ADDON_AFSFFS
00133     #include <AddOns/AfsFfs/FlashStorageDeviceImp.hpp>
00134 #endif
00135
00136 #ifdef APOXI_LIB_ADDON_AFSMMC
00137     #include <AddOns/AfsMmc/MmcStorageDeviceImp.hpp>
00138 #endif
00139
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegDefines.hpp File Reference

Afs/RegDefines.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for RegDefines.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | RegFileHeader
RegFileHeader. More...

Defines

#define | APOXI_REG_INVALID_FILE_ID -1
#define | APOXI_REG_INVALID_TRANSACTION_ID -1
#define | APOXI_REG_LARGE_BLOB_SIZE APOXI_SIZE_16_KILO_BYTE
#define | APOXI_REG_MAP_FILE_RECORDS_MAX 64
#define | APOXI_REG_MAX_POOL_BUFFERS 6
#define | APOXI_REG_MAX_RECURSION_DEPTH 3
#define | APOXI_REG_NODE_FILE_SIZE_MAX 1024
#define | APOXI_REG_NODE_NAME_SIZE_MAX 50
#define | APOXI_REG_SMALL_BLOB_SIZE_MAX 512
#define | APOXI_REG_URI_SIZE_MAX 255
#define | Apoxi_RegDefines_hpp
#define | APOXI_REGISTRY_VERSION 1
#define | APOXI_SIZE_16_KILO_BYTE 16384

Enumerations

enum RegFileType {
RegFileTypeDirty, RegFileTypeMap, RegFileTypeNode, RegFileTypeBlob,
RegFileTypeBackup, RegFileTypeRootFile
}
RegFileType. More...

Define Documentation

#define Apoxi_RegDefines_hpp

Contains Registry Interface declarations and global defines

Generated on Tue Jan 24 16:52:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegDefines.hpp Source File

Afs/RegDefines.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00011 #if !defined(Apoxi_RegDefines_hpp)
00012 #define Apoxi_RegDefines_hpp
00015
00016 #include <Kernel/Types.hpp>
00017
00018 #define APOXI_REGISTRY_VERSION 1
00019
00020 #define APOXI_SIZE_16_KILO_BYTE 16384
00021
00022 #if !defined(APOXI_REG_NODE_FILE_SIZE_MAX) // size of node file in bytes
00023     //#define APOXI_REG_NODE_FILE_SIZE_MAX 4096
00024     #define APOXI_REG_NODE_FILE_SIZE_MAX 1024
00025 #else
00026     //Size of Node File cannot exceed 16 KByte for 16-Bit Processor
00027     #if defined(APOXI_RTOS_OSE166) || defined (APOXI_RTOS_NUC16)
00028         #if APOXI_REG_NODE_FILE_SIZE_MAX > APOXI_SIZE_16_KILO_BYTE
00029             #pragma message("APOXI_REG_NODE_FILE_SIZE_MAX exceeds 16Kbyte")
00030             #pragma message("setting it to 4096 bytes")
00031             #undef APOXI_REG_NODE_FILE_SIZE_MAX
00032             #define APOXI_REG_NODE_FILE_SIZE_MAX 4096
00033         #endif
00034     #endif
00035 #endif
00036
00037 #if defined(APOXI_REG_LARGE_BLOB_SIZE)
00038     #if defined(APOXI_RTOS_OSE166) || defined (APOXI_RTOS_NUC16)
00039         #if (APOXI_REG_LARGE_BLOB_SIZE > APOXI_SIZE_16_KILO_BYTE)
00040             #pragma message("APOXI_REG_LARGE_BLOB_SIZE exceeds 16Kbyte")
00041             #pragma message("setting it to 16k bytes")
00042             #undef APOXI_REG_LARGE_BLOB_SIZE
00043             #define APOXI_REG_LARGE_BLOB_SIZE APOXI_SIZE_16_KILO_BYTE
00044         #endif
00045     #endif
00046 #else
00047         #define APOXI_REG_LARGE_BLOB_SIZE APOXI_SIZE_16_KILO_BYTE
00048 #endif
00049
00050 #if !defined(APOXI_REG_URI_SIZE_MAX)
00051     #define APOXI_REG_URI_SIZE_MAX 255
00052 #endif
00053
00054 #if !defined(APOXI_REG_NODE_NAME_SIZE_MAX)
00055     #define APOXI_REG_NODE_NAME_SIZE_MAX 50
00056 #endif
00057
00058 #if !defined(APOXI_REG_SMALL_BLOB_SIZE_MAX)
00059     #define APOXI_REG_SMALL_BLOB_SIZE_MAX 512
00060 #else
00061     #if APOXI_REG_SMALL_BLOB_SIZE_MAX > APOXI_REG_NODE_FILE_SIZE_MAX
00062         #error SMALL BLOB SIZE cannot exceed APOXI_REG_NODE_FILE_SIZE_MAX /
00063         Approprate size would be: less than half of APOXI_REG_NODE_FILE_SIZE_MAX
00064     #endif
00065 #endif
00066
00067 #if !defined(APOXI_REG_MAP_FILE_RECORDS_MAX)
00068     #define APOXI_REG_MAP_FILE_RECORDS_MAX 64 // MAP File Size approximately comes to 3586 Bytes Inlcluding Header
00069 #endif
00070
00071 //Calculate and set Memory Pool Buffers
00072 #if !defined(APOXI_REG_MAX_POOL_BUFFERS)
00073     #if defined(APOXI_RTOS_OSE166) || defined (APOXI_RTOS_NUC16)
00074             #define APOXI_REG_MAX_POOL_BUFFERS  (APOXI_SIZE_16_KILO_BYTE / APOXI_REG_NODE_FILE_SIZE_MAX)
00075     #else
00076         #define APOXI_REG_MAX_POOL_BUFFERS 6 //
00077     #endif
00078 #else
00079     #if defined(APOXI_RTOS_OSE166) || defined (APOXI_RTOS_NUC16)
00080         #if (APOXI_SIZE_16_KILO_BYTE / APOXI_REG_NODE_FILE_SIZE_MAX) >  APOXI_REG_MAX_POOL_BUFFERS
00081             #pragma message("Setting APOXI_REG_MAX_POOL_BUFFERS as specified")
00082         #else                                               //Cannot exceed (16 KiloBytes)
00083             #pragma message("Warning: APOXI_REG_MAX_POOL_BUFFERS exceeds 16Kbyte limit")
00084             #pragma message("         setting it to APPROPRIATE VALUE")
00085             #undef  APOXI_REG_MAX_POOL_BUFFERS
00086             #define APOXI_REG_MAX_POOL_BUFFERS  (APOXI_SIZE_16_KILO_BYTE / APOXI_REG_NODE_FILE_SIZE_MAX)
00087         #endif
00088     #endif
00089 #endif
00090
00091 //Need to find out which is invalid fileid
00092 #define APOXI_REG_INVALID_FILE_ID -1
00093 #define APOXI_REG_MAX_RECURSION_DEPTH 3
00094 #define APOXI_REG_INVALID_TRANSACTION_ID -1
00095
00096
00097 static const INT c_reg_version = APOXI_REGISTRY_VERSION;
00098
00099 static const INT c_reg_uri_size_max = APOXI_REG_URI_SIZE_MAX;
00100 static const INT c_reg_node_name_size_max = APOXI_REG_NODE_NAME_SIZE_MAX;
00101 static const INT c_reg_node_file_size_max = APOXI_REG_NODE_FILE_SIZE_MAX;
00102
00103
00104 static const INT c_reg_small_blob_size_max = APOXI_REG_SMALL_BLOB_SIZE_MAX;
00105 static const INT c_reg_large_blob_size_max = APOXI_REG_LARGE_BLOB_SIZE;
00106 static const INT c_reg_max_pool_buffers = APOXI_REG_MAX_POOL_BUFFERS;
00107 static const INT c_max_interior_node_records = APOXI_REG_MAP_FILE_RECORDS_MAX;
00108 static const INT16 c_reg_invalid_file_id = APOXI_REG_INVALID_FILE_ID;
00109 static const INT c_reg_max_recursion_depth = APOXI_REG_MAX_RECURSION_DEPTH;
00110 static const INT c_reg_invalid_transaction_id = APOXI_REG_INVALID_TRANSACTION_ID;
00111
00112
00113 static const CHAR*  c_reg_dirty_file   = "dirtyfile";
00114 static const CHAR*  c_reg_uri_map_file = "urimapfile";
00115 static const CHAR*  c_reg_root_file    = "rootfile";
00116
00117
00118
00134
00135 enum RegFileType {
00136     RegFileTypeDirty,   // 0x00
00137     RegFileTypeMap  ,   // 0x01
00138     RegFileTypeNode ,   // 0x02
00139     RegFileTypeBlob ,   // 0x03
00140     RegFileTypeBackup,   // 0x04
00141     RegFileTypeRootFile  // 0x05
00142 };
00143
00145 struct RegFileHeader {
00146            UINT8 m_version;      // the file layout version
00147            UINT8 m_file_type;    // type of file [see above table]
00148            UINT16 m_node_count;  // number of node records
00149 };
00150
00152 #endif
00153
00154
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegDeleteBuffer.cpp File Reference

Afs/RegDeleteBuffer.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Uri.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for RegDeleteBuffer.cpp:

Generated on Tue Jan 24 16:52:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegDeleteBuffer.hpp File Reference

Afs/RegDeleteBuffer.hpp File Reference

#include <Afs/RegDefines.hpp>

Include dependency graph for RegDeleteBuffer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegDeletionBufferEntry

Defines

#define | Apoxi_RegDeleteBuffer_hpp

Define Documentation

#define Apoxi_RegDeleteBuffer_hpp

Generated on Tue Jan 24 16:52:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegDeleteBuffer.hpp Source File

Afs/RegDeleteBuffer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 /* Contains Registry Interface declarations and global defines */
00009
00010 #if !defined(Apoxi_RegDeleteBuffer_hpp)
00011 #define Apoxi_RegDeleteBuffer_hpp
00014 #include <Afs/RegDefines.hpp>
00015
00016
00017 class RegDeletionBufferEntry {
00018
00019     public:
00020
00022         RegDeletionBufferEntry() {}
00023
00025         ~RegDeletionBufferEntry() {}
00026
00028         void ResetDeletionBuffer();
00029
00031         void Init(UINT8* raw_memory);
00032
00034         void FreeDeletionBuffer(INT16 transaction_id);
00035
00037         void MoveNextElements(INT16 index);
00038
00040         UINT GetDelBufCount();
00041
00043         void AddToDeleteBuffer(INT16 file_id, INT16 transac_id);
00044
00046         void IncrementDelBufCount();
00047
00049         void DecrementDelBufCount();
00050
00051     private:
00053         UINT m_del_count;
00054
00056         UINT8* m_reg_del_node_buffer;
00057 };
00058 #endif
00059
00060
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Registry.cpp File Reference

Afs/Registry.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Registry.hpp>
#include <Afs/GuidServiceTable.hpp>
#include <Afs/LockTableList.hpp>
#include <Afs/NotificationTable.hpp>
#include <Afs/Uri.hpp>
#include <Afs/ObjectTreeService.hpp>
#include <Afs/AfsMsgTypes.hpp>
#include <Afs/LocalDataStore.hpp>
#include <Afs/ObjectDataConverter.hpp>
#include <AddOns/Services/Service.hpp>
#include <Afs/RegDefines.hpp>
#include <Kernel/System.hpp>
#include <Auxiliary/DataItem.hpp>

Include dependency graph for Registry.cpp:

Defines

#define APOXI_REG_VERSION 1

Define Documentation

#define APOXI_REG_VERSION 1

Generated on Tue Jan 24 16:52:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Registry.hpp File Reference

Afs/Registry.hpp File Reference

#include <Afs/RegistryTypes.hpp>
#include <Afs/Uri.hpp>
#include <Kernel/Os/Semaphore.hpp>

Include dependency graph for Registry.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Registry

Defines

#define | Apoxi_Registry_hpp

Define Documentation

#define Apoxi_Registry_hpp

Generated on Tue Jan 24 16:52:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Registry.hpp Source File

Afs/Registry.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /* Contains Registry Interface declarations and global defines */
00010
00011 #if !defined(Apoxi_Registry_hpp)
00012 #define Apoxi_Registry_hpp
00015
00016 class Ticks;
00017 class Guid;
00018 class DataItem;
00019 class Application;
00020
00021 #include <Afs/RegistryTypes.hpp>
00022 #include <Afs/Uri.hpp>
00023 #include <Kernel/Os/Semaphore.hpp>
00024
00026 class Registry {
00027
00028     public:
00029
00035         static RegResult GetVersion (INT16& version, const Ticks& timeout);
00036
00038         static RegResult GetVersion(INT16& version);
00039
00043         static RegResult Get(const Uri& reg_uri, DataItem& item, const Ticks& timeout);
00044
00048         static RegResult Get(const Uri& reg_uri, DataItem& item);
00049
00053         static RegResult Set(const Uri& node_uri, const DataItem& item, const Ticks& timeout);
00054
00058         static RegResult Set(const Uri& node_uri, const DataItem& item);
00059
00062         static RegResult Delete(const Uri& uri, const Ticks& timeout);
00063
00066         static RegResult Delete(const Uri& uri);
00067
00070         static RegResult CreateInteriorNode(const Uri& uri, const Ticks& timeout);
00071
00074         static RegResult CreateInteriorNode(const Uri& uri);
00075
00077         static RegResult RegisterNotify(const Uri& uri, const Ticks& timeout);
00078
00080         static RegResult RegisterNotify(const Uri& uri);
00081
00082         static RegResult UnregisterNotify(const Uri& uri, const Ticks& timeout);
00083         static RegResult UnregisterNotify(const Uri& uri);
00084
00088         static RegResult Lock(const Uri& uri, INT16& lockid, const Ticks& timeout);
00089
00093         static RegResult Lock(const Uri& uri, INT16& lockid);
00094
00097         static RegResult Unlock(INT16 lockid, const Ticks& timeout);
00098
00101         static RegResult Unlock(INT16 lockid);
00102
00106         static RegResult EnableTransaction(const Uri& uri, INT16& transaction_id, const Ticks& timeout);
00107
00111         static RegResult EnableTransaction(const Uri& uri, INT16& transaction_id);
00112
00115         static RegResult CommitTransaction(INT16 transaction_id, const Ticks& timeout);
00116
00119         static RegResult CommitTransaction(INT16 transaction_id);
00120
00121
00122
00132         static RegResult Get(const CHAR* uri, RegObjectData& reg_data_object, INT16 bufsize, const Ticks& timeout) ;
00133
00137         static RegResult Get(const CHAR* uri, RegObjectData& reg_data_object, INT16 bufsize) ;
00138
00143         static RegResult Replace(const CHAR* uri, const RegObjectData& reg_data_object,const Ticks& timeout);
00144
00148         static RegResult Replace(const CHAR* uri, const RegObjectData& reg_data_object);
00149
00152         static RegResult Add(const CHAR* uri,const RegObjectData& reg_data_object,const Ticks& timeout);
00153
00155         static RegResult Add(const CHAR* uri,const RegObjectData& reg_data_object);
00156
00160         static RegResult Delete(const CHAR* uri,const Ticks& timeout);
00161
00164         static RegResult Delete(const CHAR* uri);
00165
00168         static RegResult RegisterNotify(const CHAR* uri, void (*fp_cbfunction) (const CHAR* changed_uri), const Ticks& timeout);
00169
00171         static RegResult RegisterNotify(const CHAR* uri, void (*fp_cbfunction) (const CHAR* changed_uri));
00172
00175         static RegResult RegisterNotify(const CHAR* uri, const Ticks& timeout);
00176
00178         static RegResult RegisterNotify(const CHAR* uri);
00179
00180
00181         static RegResult UnregisterNotify(const CHAR* uri, void (*fp_cbfunction) (const CHAR* changed_uri), const Ticks& timeout);
00182         static RegResult UnregisterNotify(const CHAR* uri, void (*fp_cbfunction) (const CHAR* changed_uri));
00183         static RegResult UnregisterNotify(const CHAR* uri, const Ticks& timeout);
00184         static RegResult UnregisterNotify(const CHAR* uri);
00185
00190         static RegResult Lock(const CHAR* uri, INT16& lockid,const Ticks& timeout);
00191
00195         static RegResult Lock(const CHAR* uri, INT16& lockid);
00196
00197
00201         //static RegResult Unlock(const INT16& lockid,const Ticks& timeout);
00202
00203
00204
00211         static RegResult RegisterRemoteObjectTree(const CHAR* object_tree_root_uri, const Guid& service_id,const Ticks& timeout);
00212
00214         static RegResult RegisterRemoteObjectTree(const CHAR* object_tree_root_uri, const Guid& service_id);
00215
00218         static void Notify(const CHAR* uri, const RegChangeType* c_type, const INT16 count, const Ticks& timeout);
00219
00221         static void Notify(const CHAR* uri, const RegChangeType* c_type, const INT16 count);
00222
00223
00224
00225
00226     private:
00228         Registry();
00230         ~Registry() ;
00231
00233         static const INT16 m_registry_version;
00234
00235         friend class RegManager;
00236
00237         friend class RegIterator;
00238
00240         static Semaphore m_sem_access;
00241         static BOOLEAN m_sem_initialized;
00242
00243         static BOOLEAN InitSemaphore();
00244
00246         static Application* GetCurrentApp();
00247
00249         static RegResult RegGetDataItem(const Uri &reg_uri, DataItem &item);
00250
00252         static RegResult RegSetDataItem(const Uri &node_uri, const DataItem &item);
00253
00255         static RegResult RegCreateInteriorNode(const Uri &reg_uri);
00256
00258         static RegResult RegGet(const Uri& reg_uri, RegObjectData& reg_data_object, INT16 bufsize);
00259
00261         static RegResult RegReplace(const Uri& reg_uri, const RegObjectData& reg_data_object);
00262
00264         static RegResult RegAdd(const Uri& reg_uri,const RegObjectData& reg_data_object);
00265
00267         static RegResult RegDelete(const Uri& reg_uri);
00268
00270         static RegResult RegRegisterNotify(const Uri& reg_uri, void (*fp_cbfunction) (const CHAR* changed_uri), Application* app);
00271
00272         static RegResult RegUnregisterNotify(const Uri& reg_uri, void (*fp_cbfunction) (const CHAR* changed_uri), Application* app);
00273
00275         static RegResult RegLock(const Uri& reg_uri, INT16& lockid, BOOLEAN transac_flag);
00276
00278         static RegResult RegUnlock(const INT16 lockid, BOOLEAN transac_flag);
00279
00281         static RegResult RegRegisterRemoteObjectTree(const Uri& object_tree_root_uri, const Guid& service_id);
00282
00284         static void RegNotify(const Uri& reg_uri, const RegChangeType* ctype, const INT16 count);
00285
00287         static BOOLEAN IsEnableTransactionPossible(const Uri& uri);
00288
00290         static RegResult IsCommitPossible(INT16 transaction_id);
00291
00292
00293         //Following two lines should be removed in future
00294         friend class NotificationArray;
00295
00296         static INT16 GetVersion() {
00297             return m_registry_version;
00298         } //GetVersion
00299
00300 };
00301
00303 #endif
00304
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegistryTypes.hpp File Reference

Afs/RegistryTypes.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for RegistryTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | RegObjectData
The object data structure. More...

Defines

#define | APOXI_REG_INVALID_LOCKID -1
the value of invalid lockid for applications
#define | Apoxi_RegistryTypes_hpp

Typedefs

typedef RegObjectData | Dmr_DMObjectData

Enumerations

enum RegChangeType {
RegChangeTypeAdd, RegChangeTypeDelete, RegChangeTypeSftDel, RegChangeTypeReplace,
RegChangeTypeUnknown
}
the changetype for notifications More...
enum RegDataFormat {
RegDataFormatBool, RegDataFormatB64, RegDataFormatChar, RegDataFormatInt,
RegDataFormatNode, RegDataFormatNull, RegDataFormatXml
}
the dataformat that is filled in RegObjectData structure More...
enum RegResult {
RegResSuccess, RegResError, RegResInsufficientBuffer, RegResNoData,
RegResLocked, RegResUnlocked, RegResNoService, RegResTypeNotSupported,
RegResNoGetOnInterior, RegResNodeAlreadyExists, RegResChildLocked
}
Registry result. More...

Define Documentation

#define Apoxi_RegistryTypes_hpp

Generated on Tue Jan 24 16:52:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegistryTypes.hpp Source File

Afs/RegistryTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /* Contains Registry Interface declarations and global defines */
00010
00011 #if !defined(Apoxi_RegistryTypes_hpp)
00012 #define Apoxi_RegistryTypes_hpp
00015
00016 #include <Kernel/Types.hpp>
00017
00019 #define APOXI_REG_INVALID_LOCKID -1
00020
00022 enum RegDataFormat {
00024     RegDataFormatBool,
00026     RegDataFormatB64,
00028     RegDataFormatChar,
00030     RegDataFormatInt,
00032     RegDataFormatNode,
00034     RegDataFormatNull,
00036     RegDataFormatXml
00037 };
00038
00040 enum RegChangeType {
00042     RegChangeTypeAdd,
00044     RegChangeTypeDelete,
00046     RegChangeTypeSftDel,
00048     RegChangeTypeReplace,
00050     RegChangeTypeUnknown
00051 };
00052
00054 struct RegObjectData {
00055     CHAR* data;
00056     INT32 datasize;
00057     RegDataFormat dataformat;
00058     const CHAR* datatype;
00059 };
00060
00062 enum RegResult {
00064     RegResSuccess,
00066     RegResError,
00068     RegResInsufficientBuffer,
00070     RegResNoData,
00072     RegResLocked,
00074     RegResUnlocked,
00076     RegResNoService,
00078     RegResTypeNotSupported,
00080     RegResNoGetOnInterior,
00082     RegResNodeAlreadyExists,
00083     //children locked
00084     RegResChildLocked
00085 };
00086
00087
00088
00089 typedef RegObjectData Dmr_DMObjectData;
00091 #endif
00092
00093
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegIterator.cpp File Reference

Afs/RegIterator.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Registry.hpp>
#include <Afs/LockTableList.hpp>
#include <Afs/NodeFileHandler.hpp>
#include <Afs/UriMappingTable.hpp>
#include <Afs/Uri.hpp>
#include <Afs/RegNodeFile.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include <Afs/RegIterator.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for RegIterator.cpp:

Generated on Tue Jan 24 16:52:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegIterator.hpp File Reference

Afs/RegIterator.hpp File Reference

#include <Afs/Uri.hpp>
#include <Afs/RegistryTypes.hpp>

Include dependency graph for RegIterator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegIterator
struct | RegIterator::InteriorMetaData
holds interior metadata More...
struct | RegIterator::LeafMetaData
holds leaf metadata More...

Defines

#define | Apoxi_RegIterator_hpp

Define Documentation

#define Apoxi_RegIterator_hpp

Generated on Tue Jan 24 16:52:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegIterator.hpp Source File

Afs/RegIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RegIterator_hpp)
00011 #define Apoxi_RegIterator_hpp
00014 #include <Afs/Uri.hpp>
00015 #include <Afs/RegistryTypes.hpp>
00016
00017
00019 class RegIterator{
00020
00021 public:
00022
00023     enum NodeType{
00024         InteriorType,
00025         LeafType
00026     };
00027
00029     enum LeafnodeType{
00030         BooleanNodeType,
00031         StringNodeType,
00032         BlobNodeType,
00033         IntegerNodeType,
00034         BlobFileType
00035     };
00037     struct LeafMetaData{
00038         LeafnodeType type;
00039         UINT32 size;
00040     };
00042     struct InteriorMetaData{
00043         UINT16 childcount;
00044     };
00045
00047     RegIterator() : m_file_id(-1), m_node_uri(".") {}
00048
00050     ~RegIterator() {};
00051
00053     RegResult Get(Uri& it_uri);
00054
00056     RegResult Set(const Uri& it_uri);
00057
00059     RegResult TraverseDown(NodeType& nodetype);
00060
00062     RegResult TraverseUp(NodeType& nodetype);
00063
00065     RegResult TraverseNext(NodeType& nodetype);
00066
00068     RegResult GetLeafMetaData(LeafMetaData& metadata);
00069
00071     RegResult GetInteriorMetaData(InteriorMetaData& metadata);
00072
00073     private:
00074
00076     INT16  m_file_id;
00077
00079     Uri m_node_uri;
00080 };//RegIterator
00081
00083 #endif  // Apoxi_PathIterator_hpp
00084
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegManager.cpp File Reference

Afs/RegManager.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/RegDefines.hpp>
#include <Afs/Registry.hpp>
#include <Afs/UriMappingTable.hpp>
#include <Afs/DirtyFileHandler.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Afs/RegNodeFile.hpp>
#include <Afs/BackupFileHandler.hpp>
#include <Afs/Ffs/FlsFile.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include <Auxiliary/Macros.hpp>
#include <Devices/StartUp.hpp>
#include "RegManager.hpp"

Include dependency graph for RegManager.cpp:

Generated on Tue Jan 24 16:53:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegManager.hpp File Reference

Afs/RegManager.hpp File Reference

#include <Kernel/SubSystem.hpp>

Include dependency graph for RegManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegManager

Defines

#define | Apoxi_RegManager_hpp

Define Documentation

#define Apoxi_RegManager_hpp

Generated on Tue Jan 24 16:53:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegManager.hpp Source File

Afs/RegManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_RegManager_hpp)
00009 #define Apoxi_RegManager_hpp
00012 //class RegNodeFile;
00013
00014
00015 #include <Kernel/SubSystem.hpp>
00016
00017 /*  ========================================================================
00018     RegManager
00019     ======================================================================== */
00021 class RegManager : public SubSystem {
00022
00023     public:
00024         RegManager();
00025
00026         static RegManager* GetInstance() { return m_instance; }
00027
00028         virtual const WCHAR* GetName() const { return L"APOXI RegManager"; }
00029
00031         virtual BootSequenceState InvokeAt() const { return (SubSystemManager::c_run_level_3); }
00032
00034         virtual UINT8 GetPriority() const { return (100); }
00035
00037         virtual void OnPowerUp();
00038
00040         virtual void OnPowerDown();
00041
00042     private:
00044         static BOOLEAN Rescan();
00045
00047         static INT16 GetRootFileId();
00048
00050         static void ConstructUriMapTable(INT16 file_id);
00051
00053         static void DeleteUnlinkedFiles();
00054
00055         static RegManager       *m_instance;
00056 };
00057
00059 #endif
00060
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegMemoryPool.cpp File Reference

Afs/RegMemoryPool.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/UriMappingTable.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Afs/Ffs/FlsFile.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for RegMemoryPool.cpp:

Generated on Tue Jan 24 16:53:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegMemoryPool.hpp File Reference

Afs/RegMemoryPool.hpp File Reference

#include <Afs/RegDefines.hpp>
#include <Afs/RegNodeFile.hpp>
#include <Afs/RegDeleteBuffer.hpp>
#include <Afs/RegManager.hpp>

Include dependency graph for RegMemoryPool.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | RegMemoryBuffer
class | RegMemoryPool
struct | Transaction

Defines

#define | Apoxi_RegMemoryPool_hpp

Typedefs

typedef Transaction | RegBackupHeader
typedef Transaction | RegDeletionBuffer

Define Documentation

#define Apoxi_RegMemoryPool_hpp

Generated on Tue Jan 24 16:53:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegMemoryPool.hpp Source File

Afs/RegMemoryPool.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 /* Contains Registry Interface declarations and global defines */
00009
00010 #if !defined(Apoxi_RegMemoryPool_hpp)
00011 #define Apoxi_RegMemoryPool_hpp
00014 #include <Afs/RegDefines.hpp>
00015 #include <Afs/RegNodeFile.hpp>
00016 #include <Afs/RegDeleteBuffer.hpp>
00017 #include <Afs/RegManager.hpp>
00018
00019
00021 struct RegMemoryBuffer{
00022             UINT16 m_lru_count;
00023             RegNodeBuffer m_node_buffer;
00024 };
00025
00026 typedef struct Transaction{
00027     INT16 m_file_id;
00028     INT16 m_transaction_id;
00029 }RegDeletionBuffer, RegBackupHeader;
00030
00032 class RegMemoryPool {
00033
00034     public:
00036         static BOOLEAN Init();
00037
00039         static void FreeNodeBuffer(INT16 file_id);
00040
00042         static RegNodeBuffer*  GetNodeBuffer(INT16 file_id);
00043
00045         static RegDeletionBufferEntry* GetDeletionBuffer();
00046
00048         static void FlushBuffers(INT16 transaction_id);
00049
00050
00051     private:
00052
00054         static INT GetLruBuffer();
00055
00057         static void IncrementLruCount(INT lru_index);
00058
00060         static void AdjustLruValues();
00061
00063         static void Sort(UINT16 array[]);
00064
00066         static UINT8 m_memory_pool[c_reg_max_pool_buffers * c_reg_node_file_size_max];
00067
00069         static RegMemoryBuffer  m_memory_buffer[c_reg_max_pool_buffers];
00070
00072         static UINT8 m_memory_deletion_pool[c_max_interior_node_records * sizeof(RegDeletionBuffer)];
00073
00075         static RegDeletionBufferEntry m_memory_deletion_entry;
00076
00078         static RegManager m_manager;
00079
00080
00081 };
00082
00084 #endif
00085
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegNodeFile.cpp File Reference

Afs/RegNodeFile.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include <Afs/Uri.hpp>
#include <Afs/RegNodeFile.hpp>
#include <Afs/Ffs/FlsFile.hpp>

Include dependency graph for RegNodeFile.cpp:

Generated on Tue Jan 24 16:53:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegNodeFile.hpp File Reference

Afs/RegNodeFile.hpp File Reference

#include <Afs/RegDefines.hpp>

Include dependency graph for RegNodeFile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegNodeBuffer
structure of reg node buffer More...
struct | RegNodeFileHeader
nodefile header structure More...
struct | RegNodeRecord
nodefile record structure More...

Defines

#define | Apoxi_RegNodeFile_hpp

Enumerations

enum RegPayloadType {
RegNoNode, RegBooleanNode, RegStringNode, RegIntegerNode,
RegBlobNode, RegBlobFileNode, RegInteriorNode
}
payload types More...

Define Documentation

#define Apoxi_RegNodeFile_hpp

Generated on Tue Jan 24 16:53:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/RegNodeFile.hpp Source File

Afs/RegNodeFile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /* Contains Registry Interface declarations and global defines */
00010
00011 #if !defined(Apoxi_RegNodeFile_hpp)
00012 #define Apoxi_RegNodeFile_hpp
00015
00016 #include <Afs/RegDefines.hpp>
00017
00036
00037 enum RegPayloadType {
00038     RegNoNode        ,
00039     RegBooleanNode   ,
00040     RegStringNode    ,
00041     RegIntegerNode   ,
00042     RegBlobNode      ,
00043     RegBlobFileNode  ,
00044     RegInteriorNode
00045 };
00046
00048 struct RegNodeFileHeader {
00049        RegFileHeader m_file_header;
00050        CHAR m_uri[c_reg_uri_size_max];
00051 };
00052
00054 struct RegNodeRecord {
00055        CHAR m_name[c_reg_node_name_size_max];
00056        struct {
00057            UINT16 m_payload_type; // mimetype of payload (see above table)
00058            UINT16 m_offset_node_payload; //offset of payload (max = 64 KB)
00059        } m_payload_bits;
00060 };
00061
00062 class Uri;
00063 class RegBlobObject;
00064 class String;
00065
00067
00070 /*
00071 @code
00072   +-->   +-------------------------------------------------------------------+
00073   |      | 0 1 2 3 4 5 6 7| 0 1 2 3 4 5 6 7| 0 1 2 3 4 5 6 7| 0 1 2 3 4 5 6 7|
00074   |      +----------------+----------------+----------------+----------------+
00075   |      |     Version    |    File Type   |         Node Count (n)          |
00076   |      +----------------+----------------+---------------------------------+
00077   |      |                         .                                         |
00078 Header   |                         .                                         |
00079   |      |                         URI (255 Bytes)                           |
00080   |      |                         .                                         |
00081   |      |                         .                                         |
00082   |      |                                                                   |
00083   |      |                                                  +----------------+
00084   |      |                                                  |                |
00085   +-->   +--------------------------------------------------+----------------+
00086   |      |                        .                                          |
00087   |      |                        Node Name (50 Bytes) (Node 1)              |
00088   |      |                        .        +---------------------------------+
00089   |      |                                 |                                 |
00090   |      +---------------------------------+---------------------------------+
00091   |      |          Payload Type           |         Payload Offset          |--------+
00092   |      +---------------------------------+---------------------------------+        |
00093  Node    |                           .                                       |        |
00094 Records  |                           .                                       |        |
00095   |      |                           .                                       |        |
00096   |      +-------------------------------------------------------------------+        |
00097   |      |                        .                                          |        |
00098   |      |                        Node Name (50 Bytes) (Node n)              |        |
00099   |      |                        .        +---------------------------------+        |
00100   |      |                                 |                                 |        |
00101   |      +---------------------------------+---------------------------------+        |
00102   |      |          Payload Type           |         Payload Offset          |-----+  |
00103   +-->   +-------------------------------------------------------------------+     |  |
00104   |      |                                                                   |     |  |
00105   |      |                           .                                       |     |  |
00106   |      |                                                                   |     |  |
00107   |      |                                                                   |     |  |
00108   |      |                                                                   |     |  |
00109   |      |                                                                   |     |  |
00110   |      |                                                          +--------+-----+  |
00111   |      |                                                          |        |        |
00112   |      |                                                          V        |        |
00113   |      +-------------------------------------------------------------------+        |
00114 Payload  |                           Payload n                               |        |
00115   |      |                                                                   |        |
00116   |      +-------------------------------------------------------------------+        |
00117   |      |   .                                                               |        |
00118   |      |   .                          +------------------------------------+--------+
00119   |      |   .                          |                                    |
00120   |      |   .                          V                                    |
00121   |      +-------------------------------------------------------------------+
00122   |      |                          Payload 1                                |
00123   |      |                                                                   |
00124   +-->   +-------------------------------------------------------------------+
00125 @endcode
00126 */
00127
00129 class RegNodeBuffer {
00130
00131     public:
00132
00134         RegNodeBuffer() {}
00135
00137         ~RegNodeBuffer() {}
00138
00139         void SetRootFileType();
00140
00142         void Init(UINT8* raw_memory);
00143
00145         BOOLEAN Read(UINT16 fileid);
00146
00148         BOOLEAN Write(UINT16 fileid);
00149
00151         void ResetFileId();
00152
00154         INT16 GetFileId();
00155
00156         //Misc Functions
00157
00159         void GetUri(Uri& uri);
00160
00162         void SetUri(Uri& uri);
00163
00165         BOOLEAN GetNodeIndex(String& node_name, UINT& idx);
00166
00168         BOOLEAN GetNodeRecord(UINT idx, RegNodeRecord* rec);
00169
00171         RegNodeRecord* GetNodeRecordPtr(UINT idx);
00172
00174         UINT GetNumOfNodeRecord();
00175
00177         void SetNumOfNodeRecord(UINT no_of_records);
00178
00180         BOOLEAN AddInteriorHeader(const Uri& node_uri);
00181
00183
00185         BOOLEAN GetBooleanPayload(BOOLEAN* val, UINT idx);
00187         BOOLEAN GetIntegerPayload(INT* val, UINT idx);
00189         BOOLEAN GetStringPayload(String* val, UINT idx);
00191         BOOLEAN GetBlobPayload(RegBlobObject* val, UINT idx);
00193         BOOLEAN GetInteriorPayload(INT16* val, UINT idx);
00195         BOOLEAN GetBlobFileNodePayload(INT16* val, UINT idx);
00196
00197         //Add Functions
00198
00200         BOOLEAN AddBooleanNode(BOOLEAN val, const String& node_name);
00202         BOOLEAN AddIntegerNode(INT val, const String& node_name);
00204         BOOLEAN AddStringNode(String* val, const String& node_name);
00206         BOOLEAN AddBlobNode(RegBlobObject* val, const String& node_name);
00208         BOOLEAN AddInteriorNode(INT16 val, const String& node_name);
00210         BOOLEAN AddBlobFileNode(INT16 val, const String& node_name);
00211
00212         //Set Functions
00213
00215         BOOLEAN SetBooleanNode(BOOLEAN val, UINT idx);
00217         BOOLEAN SetIntegerNode(INT val, UINT idx);
00219         BOOLEAN SetStringNode(String* val, UINT idx);
00221         BOOLEAN SetBlobNode(RegBlobObject* val, UINT idx);
00223         BOOLEAN SetInteriorNode(INT16 val, UINT idx);
00225         BOOLEAN SetBlobFileNode(INT16 val, UINT idx);
00226
00227         //Delete Functions
00228
00230         BOOLEAN DeleteNode(UINT idx);
00232         UINT8* GetNodeBufferRawMemory();
00233
00234
00235     private:
00236
00238         INT16 m_file_id;
00240         UINT8* m_reg_node_buffer; // SIZE = c_reg_node_file_size_max
00242         BOOLEAN m_update_necessary;
00244         BOOLEAN InsertPayloadPossible(UINT payload_size, INT no_of_nodes);
00246         BOOLEAN AddNode(const String& uri, void* payload_to_insert, UINT payload_size, RegPayloadType payload_type);
00248         BOOLEAN UpdateNode(void* val, UINT idx, UINT payload_size);
00250         BOOLEAN IsReplacePossible(UINT idx, UINT new_payload_size, UINT no_of_nodes, UINT&  existing_payload_size);
00252
00253 }; //RegNodeBuffer
00254
00256 #endif
00257
00258
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Uri.cpp File Reference

Afs/Uri.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Uri.hpp>
#include <Afs/RegDefines.hpp>

Include dependency graph for Uri.cpp:

Generated on Tue Jan 24 16:53:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Uri.hpp File Reference

Afs/Uri.hpp File Reference

#include <Auxiliary/String.hpp>

Include dependency graph for Uri.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Uri
Uri class defines the functionalities fo the class. More...

Defines

#define | Apoxi_Uri_hpp

Define Documentation

#define Apoxi_Uri_hpp

Generated on Tue Jan 24 16:53:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Uri.hpp Source File

Afs/Uri.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_Uri_hpp)
00009 #define Apoxi_Uri_hpp
00012 #include <Auxiliary/String.hpp>
00013
00015 class Uri : private String {
00016
00017     typedef String Base;
00018
00019     public:
00020
00022         Uri() {};
00023
00025         ~Uri() {};
00026
00028         Uri(const Uri& szCopy);
00029
00031         Uri(const Uri* szCopy);
00032
00034         Uri(const String& szCopy);
00035
00036         Uri(const CHAR* pchCopy);
00037
00039         Uri & operator =(const Uri & szCopy);
00040
00041
00042         using Base::find;
00043         using Base::compare;
00044         using Base::Compare;
00045         using Base::c_str;
00046         using Base::length;
00047         using Base::Clear;
00048         using Base::IsEmpty;
00049         //using Base::operator +;
00050
00051         Uri operator+ (const Uri & szConcat) const
00052         {
00053             return Base::operator + (szConcat);
00054         }
00055
00056         void operator += (const Uri & szConcat);
00057
00059         Uri & operator << (const Uri & right);
00060
00062         BOOLEAN operator == (const Uri & szcompare) const;
00063
00065         BOOLEAN operator != (const Uri & szcompare) const;
00066
00068         BOOLEAN endswith(const Uri & other) const;
00069
00071         BOOLEAN startswith(const Uri & other) const;
00072
00074         BOOLEAN ValidateUri() const;
00075
00077         void FormatUriHeader(Uri& return_string) const;
00078
00080         void GetUriHeader(Uri& return_string) const;
00081
00083         void FormatLockTableUri(Uri& return_string) const;
00084
00086         void TruncateUri(Uri& return_string) const;
00087
00089         BOOLEAN GetParentUri(Uri& return_uri) const;
00090
00091
00093         BOOLEAN GetChildName(String& node_name) const;
00094
00096         INT GetUriDepth() const;
00097
00098         using Base::empty;
00099
00101         using Base::ToWString;
00102
00103 };
00105 #endif
00106
Generated on Tue Jan 24 14:45:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/UriMappingTable.cpp File Reference

Afs/UriMappingTable.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Uri.hpp>
#include <Afs/RegNodeFile.hpp>
#include <Afs/RegMemoryPool.hpp>
#include <Afs/BackupFileHandler.hpp>
#include <Afs/UriMappingTable.hpp>
#include <Afs/Ffs/FlsFile.hpp>

Include dependency graph for UriMappingTable.cpp:

Generated on Tue Jan 24 16:53:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/UriMappingTable.hpp File Reference

Afs/UriMappingTable.hpp File Reference

#include <Afs/RegDefines.hpp>

Include dependency graph for UriMappingTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | InteriorNodeRecord
InteriorNodeRecord. More...
struct | RegUriMapFile
structure of urimapfile More...
class | UriMappingTable
UriMappingTable. More...

Defines

#define | Apoxi_UriMappingTable_hpp

Define Documentation

#define Apoxi_UriMappingTable_hpp

Generated on Tue Jan 24 16:53:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/UriMappingTable.hpp Source File

Afs/UriMappingTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_UriMappingTable_hpp)
00009 #define Apoxi_UriMappingTable_hpp
00012 #include <Afs/RegDefines.hpp>
00013
00015 struct InteriorNodeRecord {
00016     CHAR    m_tree_level;
00017     CHAR    m_flag; //for blob files
00018     CHAR    m_node_name[c_reg_node_name_size_max];
00019     INT16   m_file_id;
00020     INT16   m_parent_file_id;
00021     INT16   m_transaction_id;
00022     INT16   m_backup_file_id;
00023 };
00024
00026 struct RegUriMapFile {
00027     RegFileHeader           m_map_file_header;
00028     InteriorNodeRecord      m_interior_node_record[c_max_interior_node_records];
00029 };
00030
00031 class Uri;
00032
00077
00078 class UriMappingTable {
00079     public:
00080
00082         ~UriMappingTable() {};
00083
00085         BOOLEAN Init();
00086
00088         void Reset();
00089
00091         static UriMappingTable* GetTable();
00092
00094         INT16 GetFileId(const Uri& uri);
00095
00097         INT16 GetFileId(INT index);
00098
00100         INT GetFileIndex(INT16 file_id);
00101
00103         BOOLEAN InsertURIRecord(const Uri& uri, INT16 file_id);
00104
00106         BOOLEAN InsertURIRecord(const CHAR* node_name, INT16 file_id, INT16 parent_file_id, INT depth);
00107
00109         BOOLEAN InsertBlobRecord(INT16 blob_file_id, INT16 parent_file_id);
00110
00112         BOOLEAN RemoveURIRecord(const Uri& uri, INT16 file_id);
00113
00115         BOOLEAN RemoveURIRecord(INT16 file_id);
00116
00118         BOOLEAN RemoveBlobFileRecord(INT16 blob_file_id);
00119
00121         void ReplaceFileId(INT16 old_blob_id, INT16 new_blob_id);
00122
00124         INT16 GetChildFileId(INT16 parent_file_id, INT& index);
00125
00127         BOOLEAN FlushMapFile();
00128
00130         UINT GetNoOfNodes();
00131
00132         //to check for blob file
00133         BOOLEAN IsBlobFile(UINT index);
00134
00136         INT16 GetTransactionId(INT16 file_id);
00137
00139         BOOLEAN SetTransactionId(INT16 file_id, INT16 transaction_id);
00140
00141
00143         INT16 GetBackupFileId(INT16 file_id);
00144
00146         BOOLEAN SetBackupFileId(INT16 file_id, INT16 backup_file_id);
00147
00149         BOOLEAN RemoveBackupFiles(INT16 transaction_id);
00150
00152         BOOLEAN SearchFileId(INT16 file_id);
00153
00154         //to check any backup file id existing in map table
00155         BOOLEAN SearchBackupFileId();
00156
00157
00158     private:
00159
00161         RegUriMapFile m_reg_map_file;
00162
00164         static UriMappingTable m_map_table;
00165
00167         UriMappingTable() {};
00168
00170         INT ResolveFile(const Uri& passed_uri, INT first_index, INT second_index);
00171
00173         INT ResolveUsingParent(const Uri& passed_uri, INT first_index, INT second_index);
00174
00176         BOOLEAN OpenAndVerifyFileId(const Uri& uri, INT16 file_id);
00177
00179         const CHAR* GetNodeName(INT16 file_id, INT& file_index);
00180 };
00182 #endif
00183
00184
Generated on Tue Jan 24 14:45:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsHandler.cpp File Reference

Afs/Ffs/FfsHandler.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FfsHandler.hpp"
#include <Kernel/Os/OsClass.hpp>
#include <string.h>

Include dependency graph for FfsHandler.cpp:

Generated on Tue Jan 24 16:52:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsHandler.hpp File Reference

Afs/Ffs/FfsHandler.hpp File Reference

#include <Afs/Ffs/FfsTypes.hpp>

Include dependency graph for FfsHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsHandler

Defines

#define | Adc_FfsHandler_hpp

Define Documentation

#define Adc_FfsHandler_hpp

Generated on Tue Jan 24 14:53:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsHandler.hpp Source File

Afs/Ffs/FfsHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_FfsHandler_hpp)
00010 #define Adc_FfsHandler_hpp
00013
00014 #include <Afs/Ffs/FfsTypes.hpp>
00015
00071 class FfsHandler
00072 {
00073     public:
00077         static FfsError Open(FfsFileId id, FfsHandle *hp, FfsOpenMode mode,
00078                         FfsUserType user_id = FfsUserTypeMmi);
00082         static FfsError Open(const CHAR *filename, FfsHandle *hp, FfsOpenMode mode,
00083                         FfsUserType user_id = FfsUserTypeMmi);
00084
00087         static FfsError Close(FfsFileId id, FfsHandle h, FfsUserType user_id = FfsUserTypeMmi);
00090         static FfsError Close(const CHAR *filename, FfsHandle h, FfsUserType user_id = FfsUserTypeMmi);
00091
00094         static FfsError Read(FfsFileId id, FfsHandle h, UINT32 offset, void FFS_HUGE *dst,
00095                         UINT32 no_bytes, FfsUserType user_id = FfsUserTypeMmi,
00096                         void (callback_func)(FfsError result) = NULL);
00099         static FfsError Read(const CHAR *filename, FfsHandle h, UINT32 offset, void FFS_HUGE *dst,
00100                         UINT32 no_bytes, FfsUserType user_id = FfsUserTypeMmi,
00101                         void (callback_func)(FfsError result) = NULL);
00102
00106         static FfsError Create(FfsFileId id, FfsHandle *hp, FfsFileType type,
00107                         UINT32 size, FfsUserType user_id = FfsUserTypeMmi);
00111         static FfsError Create(const CHAR *filename, FfsHandle *hp, FfsFileType type,
00112                         UINT32 size, FfsUserType user_id = FfsUserTypeMmi);
00113
00116         static FfsError Write(FfsFileId id, FfsHandle h, const void FFS_HUGE *src, UINT32 offset,
00117                         UINT32 no_bytes, FfsUserType user_id = FfsUserTypeMmi,
00118                         void (callback_func)(FfsError result) = NULL);
00121         static FfsError Write(const CHAR *filename, FfsHandle h, const void FFS_HUGE *src, UINT32 offset,
00122                         UINT32 no_bytes, FfsUserType user_id = FfsUserTypeMmi,
00123                         void (callback_func)(FfsError result) = NULL);
00124
00127         static FfsError Modify(FfsFileId id, FfsHandle h, const void FFS_HUGE *src, UINT32 offset,
00128                         UINT32 no_bytes, FfsUserType user_id = FfsUserTypeMmi);
00132         static FfsError Modify(const CHAR *filename, FfsHandle h, const void FFS_HUGE *src, UINT32 offset,
00133                         UINT32 no_bytes, FfsUserType user_id = FfsUserTypeMmi);
00134
00137         static FfsError Delete(FfsFileId id, FfsUserType user_id = FfsUserTypeMmi);
00140         static FfsError Delete(const CHAR *filename, FfsUserType user_id = FfsUserTypeMmi);
00141
00145         static FfsError DeleteDir(const CHAR *dir_name, FfsUserType user_id = FfsUserTypeMmi);
00146
00150         static FfsError MakeDir(const CHAR *dir_name, FfsUserType user_id = FfsUserTypeMmi);
00151
00156         static FfsError ChangeDir(const CHAR *dir_name, FfsUserType user_id = FfsUserTypeMmi);
00157
00162         static FfsError GetCurrentDir(CHAR *current_dir, FfsUserType user_id = FfsUserTypeMmi);
00163
00166         static FfsError Append(FfsFileId id, FfsHandle h, const void FFS_HUGE *src,
00167                         UINT32 no_bytes, FfsUserType user_id = FfsUserTypeMmi);
00171         static FfsError Append(const CHAR *filename, FfsHandle h, const void FFS_HUGE *src,
00172                         UINT32 no_bytes, FfsUserType user_id = FfsUserTypeMmi);
00173
00175         static FfsError Truncate(FfsFileId id, UINT32 new_size, FfsUserType user_id = FfsUserTypeMmi);
00177         static FfsError Truncate(const CHAR *filename, UINT32 new_size, FfsUserType user_id = FfsUserTypeMmi);
00178
00182         static FfsError Copy(FfsFileId id, FfsFileId dst_id, FfsUserType user_id = FfsUserTypeMmi);
00183
00187         static FfsError Copy(const CHAR *filename, const CHAR *dst_filename, FfsUserType user_id = FfsUserTypeMmi);
00188
00193         static BOOLEAN IsDirectory(const CHAR *pathname, FfsUserType user_id = FfsUserTypeMmi);
00194
00198         static FfsError Rename(FfsFileId id, FfsFileId new_id,
00199                         FfsFileType new_type, FfsUserType user_id = FfsUserTypeMmi);
00203         static FfsError Rename(const CHAR *filename, const CHAR *new_filename,
00204                         FfsFileType new_type, FfsUserType user_id = FfsUserTypeMmi);
00205
00207         static BOOLEAN FileExist(FfsFileId id, FfsUserType user_id = FfsUserTypeMmi);
00209         static BOOLEAN FileExist(const CHAR *filename, FfsUserType user_id = FfsUserTypeMmi);
00210
00213         static FfsError GetFileInfo(FfsFileId id, FfsFileInfo *info,
00214                                 FfsUserType user_id = FfsUserTypeMmi);
00217         static FfsError GetFileInfo(const CHAR *filename, FfsFileInfo *info,
00218                                 FfsUserType user_id = FfsUserTypeMmi);
00219
00222         static FfsError GetFileName(CHAR *filename, FfsFileId id, FfsUserType user_id = FfsUserTypeMmi);
00223
00226         static FfsError GetFileId(FfsFileId *id, const CHAR *filename, FfsUserType user_id = FfsUserTypeMmi);
00227
00230         static FfsError SetDrmAttrib(FfsFileId id, const FfsDrmAttrib &attrib,
00231                                 FfsUserType user_id = FfsUserTypeMmi);
00234         static FfsError SetDrmAttrib(const CHAR *filename, const FfsDrmAttrib &attrib,
00235                                 FfsUserType user_id = FfsUserTypeMmi);
00236
00239         static FfsError GetDrmAttrib(FfsFileId id, FfsDrmAttrib &attrib,
00240                                 FfsUserType user_id = FfsUserTypeMmi);
00243         static FfsError GetDrmAttrib(const CHAR *filename, FfsDrmAttrib &attrib,
00244                                 FfsUserType user_id = FfsUserTypeMmi);
00245
00248         static BOOLEAN FindFirst(FfsFileId *id, FfsFileType type);
00252         static BOOLEAN FindFirst(CHAR *filename, const CHAR *name_spec, FfsFileType type,
00253                                 FfsUserType user_id = FfsUserTypeMmi);
00254
00258         static BOOLEAN FFindFirst(CHAR *filename, const CHAR *name_spec, FfsFileType type,
00259                                 FfsRefType *ref_type, FfsUserType user_id = FfsUserTypeMmi);
00260
00264         static BOOLEAN FFindNext(CHAR *filename, const CHAR *name_spec, FfsFileType type, FfsRefType *ref_type, FfsUserType user_id = FfsUserTypeMmi);
00265
00269         static BOOLEAN FindNext(FfsFileId last_id, FfsFileId *id, FfsFileType type);
00278         static BOOLEAN FindNext(CHAR *filename, const CHAR *name_spec, FfsFileType type,
00279                                 FfsUserType user_id = FfsUserTypeMmi);
00280
00283         static FfsFileId GetNextFreeId();
00284
00286         static UINT16 GetNofFiles();
00287
00289         static UINT16 GetNofFilesByType(FfsFileType type);
00290
00292         static UINT32 GetFreeFfsSpace();
00293
00296         static UINT32 GetFreeSpaceByType(FfsFileType type);
00297
00299         static UINT32 GetFreeSpaceInGlobalPool();
00300
00303         static UINT32 GetTotalSpace();
00304
00307         static UINT32 GetUsedSpace();
00308
00315         static UINT32 GetUsedSpaceByType(FfsFileType type);
00316
00320         static UINT32 GetReservedSpace(FfsFileType type);
00321
00323         static UINT32 GetReservedSpace();
00324
00326         static UINT32 GetUsedSpaceInGlobalPool();
00327
00329         static UINT32 CalcFileMemOvrhd(UINT32 size, BOOLEAN use_name);
00330
00331     private:
00332 #if defined(APOXI_FFS_USER_MAPPING)
00333         static FfsUserType FetchUserType(FfsUserType user_type);
00334 #endif
00335
00336 };
00337
00339 #endif  // Adc_FfsHandler_hpp
00340
00341
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsMimeTypeMap.cpp File Reference

Afs/Ffs/FfsMimeTypeMap.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FfsMimeTypeMap.hpp"
#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for FfsMimeTypeMap.cpp:

Generated on Tue Jan 24 16:52:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsMimeTypeMap.hpp File Reference

Afs/Ffs/FfsMimeTypeMap.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Afs/Ffs/FfsTypes.hpp>

Include dependency graph for FfsMimeTypeMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsMimeTypeMap
struct | FfsMimeTypeMapEntry

Defines

#define | FfsMimeTypeMap_hpp

Define Documentation

#define FfsMimeTypeMap_hpp

Generated on Tue Jan 24 14:53:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsMimeTypeMap.hpp Source File

Afs/Ffs/FfsMimeTypeMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(FfsMimeTypeMap_hpp)
00010 #define FfsMimeTypeMap_hpp
00013
00014 #if defined(APOXI_COMPAT_1_13_0)
00015     #include <Afs/Ffs/FfsHandler.hpp>
00016 #endif
00017
00018 #include <Auxiliary/MimeTypeTable.hpp>
00019 #include <Afs/Ffs/FfsTypes.hpp>
00020
00021 struct FfsMimeTypeMapEntry {
00022     MimeType    mime_type;
00023     FfsFileType ffs_type;
00024 };
00025
00030 class FfsMimeTypeMap {
00031     public:
00033         inline static   MimeType    GetMimeTypeByFileType(FfsFileType file_type){
00034             UINT8 idx = 0;
00035             return GetMimeTypeByFileType(file_type, idx);
00036         }
00038         static  const CHAR* GetMimeStrByFileType(FfsFileType file_type);
00040         static  FfsFileType GetFileTypeByExt(const CHAR *extension);
00042
00048         static  FfsFileType GetFileTypeByMimeType(MimeType mime_type, UINT8 offset = 0);
00050         static  FfsFileType GetFileTypeByMimeStr(const CHAR *mime_str);
00052         static  const CHAR* GetExtByFileType(FfsFileType file_type);
00054         static  INT         IsTextByFileType(FfsFileType file_type);
00056         static  INT         IsBinaryByFileType(FfsFileType file_type);
00057
00058     private:
00060         FfsMimeTypeMap();
00062         FfsMimeTypeMap(const FfsMimeTypeMap&);
00064         ~FfsMimeTypeMap();
00066         FfsMimeTypeMap& operator=(const FfsMimeTypeMap&);
00067
00073         static  MimeType    GetMimeTypeByFileType(FfsFileType file_type, UINT8 &offset);
00074
00075         static const UINT                   m_map_table_entries;
00076         static const UINT                   m_max_index;
00077         static const FfsMimeTypeMapEntry    m_map_table[];
00078 };
00079
00081 #endif  // FfsMimeTypeMap_hpp
00082
00083
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsSim.cpp File Reference

Afs/Ffs/FfsSim.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FfsSim.hpp"
#include <Auxiliary/SimpleMap.hpp>
#include <Afs/HostFsSim/HostCoreFsSim.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Auxiliary/WildcardStrncmp.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Afs/Ffs/FfsMimeTypeMap.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>
#include <fcntl.h>
#include <sys/stat.h>
#include <errno.h>
#include <io.h>
#include <share.h>

Include dependency graph for FfsSim.cpp:

Defines

#define | EMAXPATH 256

Typedefs

typedef SimpleMap< word, long > | HostFfsIterMap

Functions

ffs_error_code_type | FFS_append (ffs_user_type user_id, word id, ffs_handle_type h, byte *src, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_append_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, byte *src, ulong nof, void(*callback)(ffs_error_code_type result))
ulong | FFS_calculate_file_overhead (ulong filesize, BOOL use_filename)
ffs_error_code_type | FFS_close (ffs_user_type user_id, word id, ffs_handle_type h, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_close_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_copy (ffs_user_type user_id, word src_id, word dst_id, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_copy_fn (ffs_user_type user_id, char *src_name, char *dst_name, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_create (ffs_user_type user_id, word id, ffs_handle_type *hp, ffs_filetype_type type, ulong size, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_create_fn (ffs_user_type user_id, char *filename, ffs_handle_type *hp, ffs_filetype_type type, ulong size, void(*callback)(ffs_error_code_type result))
void | FFS_deactivate ()
ffs_error_code_type | FFS_delete (ffs_user_type user_id, word id, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_delete_fn (ffs_user_type user_id, char *filename, void(*callback)(ffs_error_code_type result))
BOOL | FFS_file_exists (word id)
BOOL | FFS_file_exists_fn (ffs_user_type user_id, char *filename)
BOOL | FFS_findfirst (word *id_ptr, ffs_filetype_type type)
BOOL | FFS_findfirst_fn (ffs_user_type user_id, char *filename_buffer, char *filespec, ffs_filetype_type type)
BOOL | FFS_findnext (word last_id, word *id_ptr, ffs_filetype_type type)
BOOL | FFS_findnext_fn (ffs_user_type user_id, char *filename_buffer, char *filespec, ffs_filetype_type type)
ffs_error_code_type | FFS_get_file_id (ffs_user_type user_id, char *filename_buffer, word *id)
ffs_error_code_type | FFS_get_file_info (ffs_user_type user_id, word id, ffs_file_info_type *info)
ffs_error_code_type | FFS_get_file_info_fn (ffs_user_type user_id, char *filename, ffs_file_info_type *info)
ffs_error_code_type | FFS_get_file_name (ffs_user_type user_id, word id, char *filename_buffer)
ulong FFS_get_free_space ()
ulong | FFS_get_free_space_by_type (ffs_filetype_type type)
ulong FFS_get_free_space_in_global_pool ()
word FFS_get_next_free_id ()
word FFS_get_nof_files ()
word | FFS_get_nof_files_by_type (ffs_filetype_type type)
ulong | FFS_get_raw_free_space_by_type (ffs_filetype_type type)
ulong FFS_get_raw_free_space_in_global_pool ()
ulong | FFS_get_reserved_space_by_type (ffs_filetype_type type)
ulong FFS_get_reserved_space_in_global_pool ()
ulong FFS_get_used_space ()
ulong | FFS_get_used_space_by_type (ffs_filetype_type type)
ulong FFS_get_used_space_in_global_pool ()
ffs_error_code_type FFS_initialize ()
ffs_error_code_type | FFS_modify (ffs_user_type user_id, word id, ffs_handle_type h, byte *src, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_modify_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, byte *src, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_open (ffs_user_type user_id, word id, ffs_handle_type *hp, ffs_open_file_mode_type mode)
ffs_error_code_type | FFS_open_fn (ffs_user_type user_id, char *filename, ffs_handle_type *hp, ffs_open_file_mode_type mode)
ffs_error_code_type | FFS_read (ffs_user_type user_id, word id, ffs_handle_type h, byte *dst, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_read_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, byte *dst, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type FFS_ready ()
ffs_error_code_type | FFS_rename (ffs_user_type user_id, word id, word new_id, ffs_filetype_type new_type, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_rename_fn (ffs_user_type user_id, char *filename, char *new_filename, ffs_filetype_type new_type, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_set_drm_attrib (ffs_user_type user_id, word id, ffs_drm_attrib_type *drm_attrib, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_set_drm_attrib_fn (ffs_user_type user_id, char *filename, ffs_drm_attrib_type *drm_attrib, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_truncate (ffs_user_type user_id, word id, ulong new_size, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_truncate_fn (ffs_user_type user_id, char *filename, ulong new_size, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_write (ffs_user_type user_id, word id, ffs_handle_type h, byte *src, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_write_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, byte *src, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FfsDelete (ffs_user_type user_id, word id, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FfsSetDrmAttrib (ffs_user_type user_id, word id, ffs_drm_attrib_type *drm_attrib, void(*callback)(ffs_error_code_type result))

Define Documentation

#define EMAXPATH 256

C166-like flash file system (FFS) simulator. C166 FFS does not allow file sharing, see file .c for reference. (Change _SH_DENYRW to _SH_DENYNO to allow file sharing.)

Typedef Documentation

typedef SimpleMap<word, long> HostFfsIterMap

Function Documentation

ffs_error_code_type FFS_append | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_append_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ulong FFS_calculate_file_overhead | ( | ulong | filesize,
 |  | BOOL | use_filename
 | ) |

ffs_error_code_type FFS_close | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_close_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_copy | ( | ffs_user_type | user_id,
 |  | word | src_id,
 |  | word | dst_id,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_copy_fn | ( | ffs_user_type | user_id,
 |  | char * | src_name,
 |  | char * | dst_name,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_create | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type * | hp,
 |  | ffs_filetype_type | type,
 |  | ulong | size,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_create_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type * | hp,
 |  | ffs_filetype_type | type,
 |  | ulong | size,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

void FFS_deactivate ( void )

ffs_error_code_type FFS_delete | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_delete_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

BOOL FFS_file_exists ( word id )

BOOL FFS_file_exists_fn | ( | ffs_user_type | user_id,
 |  | char * | filename
 | ) |

BOOL FFS_findfirst | ( | word * | id_ptr,
 |  | ffs_filetype_type | type
 | ) |

BOOL FFS_findfirst_fn | ( | ffs_user_type | user_id,
 |  | char * | filename_buffer,
 |  | char * | filespec,
 |  | ffs_filetype_type | type
 | ) |

BOOL FFS_findnext | ( | word | last_id,
 |  | word * | id_ptr,
 |  | ffs_filetype_type | type
 | ) |

BOOL FFS_findnext_fn | ( | ffs_user_type | user_id,
 |  | char * | filename_buffer,
 |  | char * | filespec,
 |  | ffs_filetype_type | type
 | ) |

ffs_error_code_type FFS_get_file_id | ( | ffs_user_type | user_id,
 |  | char * | filename_buffer,
 |  | word * | id
 | ) |

ffs_error_code_type FFS_get_file_info | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_file_info_type * | info
 | ) |

ffs_error_code_type FFS_get_file_info_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_file_info_type * | info
 | ) |

ffs_error_code_type FFS_get_file_name | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | char * | filename_buffer
 | ) |

ulong FFS_get_free_space ( void )

ulong FFS_get_free_space_by_type ( ffs_filetype_type type )

ulong FFS_get_free_space_in_global_pool ( void )

word FFS_get_next_free_id ( void )

word FFS_get_nof_files ( void )

word FFS_get_nof_files_by_type ( ffs_filetype_type type )

ulong FFS_get_raw_free_space_by_type ( ffs_filetype_type type )

ulong FFS_get_raw_free_space_in_global_pool ( void )

ulong FFS_get_reserved_space_by_type ( ffs_filetype_type type )

ulong FFS_get_reserved_space_in_global_pool ( void )

ulong FFS_get_used_space ( void )

ulong FFS_get_used_space_by_type ( ffs_filetype_type type )

ulong FFS_get_used_space_in_global_pool ( void )

ffs_error_code_type FFS_initialize ( void )

ffs_error_code_type FFS_modify | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_modify_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_open | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type * | hp,
 |  | ffs_open_file_mode_type | mode
 | ) |

ffs_error_code_type FFS_open_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type * | hp,
 |  | ffs_open_file_mode_type | mode
 | ) |

ffs_error_code_type FFS_read | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | byte * | dst,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_read_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | byte * | dst,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_ready ( void )

ffs_error_code_type FFS_rename | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | word | new_id,
 |  | ffs_filetype_type | new_type,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_rename_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | char * | new_filename,
 |  | ffs_filetype_type | new_type,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_set_drm_attrib | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_drm_attrib_type * | drm_attrib,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_set_drm_attrib_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_drm_attrib_type * | drm_attrib,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_truncate | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ulong | new_size,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_truncate_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ulong | new_size,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_write | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_write_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FfsDelete | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FfsSetDrmAttrib | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_drm_attrib_type * | drm_attrib,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

Generated on Tue Jan 24 16:52:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsSim.hpp File Reference

Afs/Ffs/FfsSim.hpp File Reference

#include <stdio.h>

Include dependency graph for FfsSim.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ffs_drm_attrib_type
struct | ffs_file_info_type
struct | ffs_ref_type
struct | ffs_time_record_type

Defines

#define | FFS_BLOCK_SIZE 0x10000L
#define | ffs_callback_type void(*)(ffs_error_code_type)
#define | FFS_FILE_ALREADY_CREATED FFS_EXISTS
#define | FFS_FILETYPE_SMS_POOL_SIZE_PHYSICAL 74752
#define | FFS_INVALID_FILENAME FFS_INVALID_NAME
#define | FFS_MAX_FILESIZE 0xFFFFF
#define | FFS_MAX_SOF_DIR_NAME 128
#define | FFS_MAX_SOF_FILENAME 48
#define | FFS_NOF_DYNAMIC_BLOCKS 42
#define | FFS_SECTOR_SIZE 1024
#define | FFS_SIM_hpp
#define | FFS_STREAMING (0xFEFEFEFE)

Typedefs

typedef int | BOOL
typedef unsigned char | byte
typedef word | dir_id_type
typedef FILE * | ffs_handle_type
typedef unsigned long | ulong
typedef unsigned short | word

Enumerations

enum ffs_error_code_type {
FFS_FALSE, FFS_TRUE, FFS_SUCCESS, FFS_INITIALIZING,
FFS_ALREADY_OPEN, FFS_NOT_OPEN, FFS_FILE_NOT_FOUND, FFS_EXISTS,
FFS_ILLIGAL_ID, FFS_ILLIGAL_FILE_HANDLE, FFS_ILLIGAL_TYPE, FFS_ILLIGAL_MODE,
FFS_FILE_RANGE_ERROR, FFS_OPERATION_NOT_POSSIBLE, FFS_WRITE_ERROR, FFS_USER_ID_ERROR,
FFS_INTERNAL_FATAL_ERROR, FFS_MEMORY_RES_ERROR, FFS_MAX_NOF_FILES_EXCEEDED, FFS_REQUESTED_MEM_NOT_AVAILABLE,
FFS_INVALID_NAME, FFS_STREAMING_NOT_ENABLED, FFS_OPERATION_NOT_ALLOWED_ON_STATIC_FILE, FFS_MEM_TABLES_INCONSISTENCY,
FFS_NOT_A_FACTORY_DEFAULT_FILE, FFS_REQUESTED_MEM_TEMP_NOT_AVAILABLE, FFS_ILLIGAL_DIR_OPERATION, FFS_DIR_SPACE_NOT_AVAILABLE
}
enum ffs_filetype_type {
FFS_GENERIC_FILETYPE, FFS_FILETYPE_APOXI_SETTING, FFS_FILETYPE_AVI, FFS_FILETYPE_BMP,
FFS_FILETYPE_GIF, FFS_FILETYPE_HTM, FFS_FILETYPE_HTML, FFS_FILETYPE_ICS,
FFS_FILETYPE_JAD, FFS_FILETYPE_JAR, FFS_FILETYPE_JRS, FFS_FILETYPE_JPG,
FFS_FILETYPE_JPE, FFS_FILETYPE_JPEG, FFS_FILETYPE_MIDI, FFS_FILETYPE_MMF,
FFS_FILETYPE_MMI_SETTING, FFS_FILETYPE_MOV, FFS_FILETYPE_MP3, FFS_FILETYPE_MPGA,
FFS_FILETYPE_MPE, FFS_FILETYPE_MPEG, FFS_FILETYPE_MPG, FFS_FILETYPE_PNG,
FFS_FILETYPE_TIF, FFS_FILETYPE_TXT, FFS_FILETYPE_VCF, FFS_FILETYPE_WAP_SETTING,
FFS_FILETYPE_WAV, FFS_FILETYPE_WBMP, FFS_FILETYPE_WML, FFS_FILETYPE_WMLS,
FFS_FILETYPE_XHTML, FFS_FILETYPE_XML, FFS_FILETYPE_AIM, FFS_FILETYPE_AAN,
FFS_FILETYPE_IMELODY, FFS_FILETYPE_AMR, FFS_FILETYPE_FR, FFS_FILETYPE_MMF_PHRASE,
FFS_FILETYPE_BROWSER_CACHE, FFS_FILETYPE_BROWSER_DATBASE, FFS_FILETYPE_SECURITY_CERTIFICATES, FFS_FILETYPE_PUSH_MESSAGES,
FFS_FILETYPE_JAM_BACKUP, FFS_FILETYPE_JAM_DEFAULT, FFS_FILETYPE_MMS_STORAGE, FFS_FILETYPE_MMS_REPORTS,
FFS_FILETYPE_MMS_NOTIFICATION, FFS_FILETYPE_MMS_BACKUP, FFS_FILETYPE_MMS_TEST, FFS_FILETYPE_MMS_APP_REPORT,
FFS_FILETYPE_MMT, FFS_FILETYPE_MYSTUFF, FFS_FILETYPE_SMS, FFS_FILETYPE_MMS_PRE,
FFS_FILETYPE_SETTINGS, FFS_FILETYPE_EMS_BMP, FFS_FILETYPE_SAF, FFS_FILETYPE_SPF,
FFS_FILETYPE_DRM_RO, FFS_FILETYPE_REGISTRY, FFS_FILETYPE_3GP, FFS_FILETYPE_SVG,
FFS_FILETYPE_SVGZ, FFS_FILETYPE_MMS, FFS_FILETYPE_DRM, FFS_FILETYPE_FRAME,
FFS_FILETYPE_AAC, FFS_FILETYPE_M4A, FFS_NOF_FILETYPES, FFS_FILETYPE_GARBAGE,
FFS_ALL_FILETYPES = 0xFF
}
enum | ffs_open_file_mode_type { FFS_FILE_OPEN_READ, FFS_FILE_OPEN_APPEND, FFS_FILE_OPEN_MODIFY, FFS_FILE_OPEN_READ_STREAMING }
enum | ffs_pit { FFS_NOF_RES_ID = 300 }
enum ffs_user_type {
FFS_INTERNAL, FFS_DWDIO, FFS_MP3, FFS_VR,
FFS_SMS, FFS_AUDIO, FFS_MMI, FFS_MMS,
FFS_JAVA, FFS_WAP, FFS_APCON01, FFS_APCON02,
FFS_APCON03, FFS_APCON04, FFS_APCON05, FFS_APCON06,
FFS_APCON07, FFS_APCON08, FFS_APCON09, FFS_APCON10,
FFS_APCON11, FFS_APCON12, FFS_APCON13, FFS_APCON14,
FFS_APCON15, FFS_ATC, FFS_NOF_USERS
}

Functions

ffs_error_code_type | FFS_append (ffs_user_type user_id, word id, ffs_handle_type h, byte *src, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_append_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, byte *src, ulong nof, void(*callback)(ffs_error_code_type result))
ulong | FFS_calculate_file_overhead (ulong filesize, BOOL use_filename)
ffs_error_code_type | FFS_close (ffs_user_type user_id, word id, ffs_handle_type h, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_close_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_copy (ffs_user_type user_id, word src_id, word dst_id, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_copy_fn (ffs_user_type user_id, char *src_name, char *dst_name, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_create (ffs_user_type user_id, word id, ffs_handle_type *hp, ffs_filetype_type type, ulong size, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_create_fn (ffs_user_type user_id, char *filename, ffs_handle_type *hp, ffs_filetype_type type, ulong size, void(*callback)(ffs_error_code_type result))
void | FFS_deactivate (void)
ffs_error_code_type | FFS_delete (ffs_user_type user_id, word id, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_delete_fn (ffs_user_type user_id, char *filename, void(*callback)(ffs_error_code_type result))
BOOL | FFS_file_exists (word id)
BOOL | FFS_file_exists_fn (ffs_user_type user_id, char *filename)
BOOL | FFS_findfirst (word *id_ptr, ffs_filetype_type type)
BOOL | FFS_findfirst_fn (ffs_user_type user_id, char *filename_buffer, char *filespec, ffs_filetype_type type)
BOOL | FFS_findnext (word last_id, word *id_ptr, ffs_filetype_type type)
BOOL | FFS_findnext_fn (ffs_user_type user_id, char *filename_buffer, char *filespec, ffs_filetype_type type)
ffs_error_code_type | FFS_get_file_id (ffs_user_type user_id, char *filename_buffer, word *id)
ffs_error_code_type | FFS_get_file_info (ffs_user_type user_id, word id, ffs_file_info_type *info)
ffs_error_code_type | FFS_get_file_info_fn (ffs_user_type user_id, char *filename, ffs_file_info_type *info)
ffs_error_code_type | FFS_get_file_name (ffs_user_type user_id, word id, char *filename_buffer)
ulong | FFS_get_free_space (void)
ulong | FFS_get_free_space_by_type (ffs_filetype_type type)
ulong | FFS_get_free_space_in_global_pool (void)
word | FFS_get_next_free_id (void)
word | FFS_get_nof_files (void)
word | FFS_get_nof_files_by_type (ffs_filetype_type type)
ulong | FFS_get_raw_free_space_by_type (ffs_filetype_type type)
ulong | FFS_get_raw_free_space_in_global_pool (void)
ulong | FFS_get_reserved_space_by_type (ffs_filetype_type type)
ulong | FFS_get_reserved_space_in_global_pool (void)
ulong | FFS_get_used_space (void)
ulong | FFS_get_used_space_by_type (ffs_filetype_type type)
ulong | FFS_get_used_space_in_global_pool (void)
ffs_error_code_type | FFS_initialize (void)
ffs_error_code_type | FFS_modify (ffs_user_type user_id, word id, ffs_handle_type h, byte *src, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_modify_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, byte *src, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_open (ffs_user_type user_id, word id, ffs_handle_type *hp, ffs_open_file_mode_type mode)
ffs_error_code_type | FFS_open_fn (ffs_user_type user_id, char *filename, ffs_handle_type *hp, ffs_open_file_mode_type mode)
ffs_error_code_type | FFS_read (ffs_user_type user_id, word id, ffs_handle_type h, byte *dst, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_read_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, byte *dst, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_ready (void)
ffs_error_code_type | FFS_rename (ffs_user_type user_id, word id, word new_id, ffs_filetype_type new_type, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_rename_fn (ffs_user_type user_id, char *filename, char *new_filename, ffs_filetype_type new_type, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_set_drm_attrib (ffs_user_type user_id, word id, ffs_drm_attrib_type *drm_attrib, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_set_drm_attrib_fn (ffs_user_type user_id, char *filename, ffs_drm_attrib_type *drm_attrib, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_truncate (ffs_user_type user_id, word id, ulong new_size, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_truncate_fn (ffs_user_type user_id, char *filename, ulong new_size, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_write (ffs_user_type user_id, word id, ffs_handle_type h, byte *src, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))
ffs_error_code_type | FFS_write_fn (ffs_user_type user_id, char *filename, ffs_handle_type h, byte *src, ulong offset, ulong nof, void(*callback)(ffs_error_code_type result))

Variables

const ulong | ffs_memory_pool_reservations [FFS_NOF_FILETYPES]

Define Documentation

#define FFS_BLOCK_SIZE 0x10000L

#define ffs_callback_type void(*)(ffs_error_code_type)

#define FFS_FILE_ALREADY_CREATED FFS_EXISTS

#define FFS_FILETYPE_SMS_POOL_SIZE_PHYSICAL 74752

#define FFS_INVALID_FILENAME FFS_INVALID_NAME

#define FFS_MAX_FILESIZE 0xFFFFF

#define FFS_MAX_SOF_DIR_NAME 128

#define FFS_MAX_SOF_FILENAME 48

#define FFS_NOF_DYNAMIC_BLOCKS 42

#define FFS_SECTOR_SIZE 1024

#define FFS_SIM_hpp

#define FFS_STREAMING (0xFEFEFEFE)

Typedef Documentation

typedef int BOOL

typedef unsigned char byte

typedef word dir_id_type

typedef FILE* ffs_handle_type

typedef unsigned long ulong

typedef unsigned short word

Enumeration Type Documentation

enum ffs_error_code_type

Enumerator:
FFS_FALSE
FFS_TRUE
FFS_SUCCESS
FFS_INITIALIZING
FFS_ALREADY_OPEN
FFS_NOT_OPEN
FFS_FILE_NOT_FOUND
FFS_EXISTS
FFS_ILLIGAL_ID
FFS_ILLIGAL_FILE_HANDLE
FFS_ILLIGAL_TYPE
FFS_ILLIGAL_MODE
FFS_FILE_RANGE_ERROR
FFS_OPERATION_NOT_POSSIBLE
FFS_WRITE_ERROR
FFS_USER_ID_ERROR
FFS_INTERNAL_FATAL_ERROR
FFS_MEMORY_RES_ERROR
FFS_MAX_NOF_FILES_EXCEEDED
FFS_REQUESTED_MEM_NOT_AVAILABLE
FFS_INVALID_NAME
FFS_STREAMING_NOT_ENABLED
FFS_OPERATION_NOT_ALLOWED_ON_STATIC_FILE
FFS_MEM_TABLES_INCONSISTENCY
FFS_NOT_A_FACTORY_DEFAULT_FILE
FFS_REQUESTED_MEM_TEMP_NOT_AVAILABLE
FFS_ILLIGAL_DIR_OPERATION
FFS_DIR_SPACE_NOT_AVAILABLE

enum ffs_filetype_type

Enumerator:
FFS_GENERIC_FILETYPE
FFS_FILETYPE_APOXI_SETTING
FFS_FILETYPE_AVI
FFS_FILETYPE_BMP
FFS_FILETYPE_GIF
FFS_FILETYPE_HTM
FFS_FILETYPE_HTML
FFS_FILETYPE_ICS
FFS_FILETYPE_JAD
FFS_FILETYPE_JAR
FFS_FILETYPE_JRS
FFS_FILETYPE_JPG
FFS_FILETYPE_JPE
FFS_FILETYPE_JPEG
FFS_FILETYPE_MIDI
FFS_FILETYPE_MMF
FFS_FILETYPE_MMI_SETTING
FFS_FILETYPE_MOV
FFS_FILETYPE_MP3
FFS_FILETYPE_MPGA
FFS_FILETYPE_MPE
FFS_FILETYPE_MPEG
FFS_FILETYPE_MPG
FFS_FILETYPE_PNG
FFS_FILETYPE_TIF
FFS_FILETYPE_TXT
FFS_FILETYPE_VCF
FFS_FILETYPE_WAP_SETTING
FFS_FILETYPE_WAV
FFS_FILETYPE_WBMP
FFS_FILETYPE_WML
FFS_FILETYPE_WMLS
FFS_FILETYPE_XHTML
FFS_FILETYPE_XML
FFS_FILETYPE_AIM
FFS_FILETYPE_AAN
FFS_FILETYPE_IMELODY
FFS_FILETYPE_AMR
FFS_FILETYPE_FR
FFS_FILETYPE_MMF_PHRASE
FFS_FILETYPE_BROWSER_CACHE
FFS_FILETYPE_BROWSER_DATBASE
FFS_FILETYPE_SECURITY_CERTIFICATES
FFS_FILETYPE_PUSH_MESSAGES
FFS_FILETYPE_JAM_BACKUP
FFS_FILETYPE_JAM_DEFAULT
FFS_FILETYPE_MMS_STORAGE
FFS_FILETYPE_MMS_REPORTS
FFS_FILETYPE_MMS_NOTIFICATION
FFS_FILETYPE_MMS_BACKUP
FFS_FILETYPE_MMS_TEST
FFS_FILETYPE_MMS_APP_REPORT
FFS_FILETYPE_MMT
FFS_FILETYPE_MYSTUFF
FFS_FILETYPE_SMS
FFS_FILETYPE_MMS_PRE
FFS_FILETYPE_SETTINGS
FFS_FILETYPE_EMS_BMP
FFS_FILETYPE_SAF
FFS_FILETYPE_SPF
FFS_FILETYPE_DRM_RO
FFS_FILETYPE_REGISTRY
FFS_FILETYPE_3GP
FFS_FILETYPE_SVG
FFS_FILETYPE_SVGZ
FFS_FILETYPE_MMS
FFS_FILETYPE_DRM
FFS_FILETYPE_FRAME
FFS_FILETYPE_AAC
FFS_FILETYPE_M4A
FFS_NOF_FILETYPES
FFS_FILETYPE_GARBAGE
FFS_ALL_FILETYPES

enum ffs_open_file_mode_type

Enumerator:
FFS_FILE_OPEN_READ
FFS_FILE_OPEN_APPEND
FFS_FILE_OPEN_MODIFY
FFS_FILE_OPEN_READ_STREAMING

enum ffs_pit

PIT (Pre-assigned ID Table) enumeration: In the PIT it's possible to reserve some file-IDs at compile-time. These IDs can be used for files that are downloaded during production.

Enumerator:
FFS_NOF_RES_ID

enum ffs_user_type

Enumerator:
FFS_INTERNAL
FFS_DWDIO
FFS_MP3
FFS_VR
FFS_SMS
FFS_AUDIO
FFS_MMI
FFS_MMS
FFS_JAVA
FFS_WAP
FFS_APCON01
FFS_APCON02
FFS_APCON03
FFS_APCON04
FFS_APCON05
FFS_APCON06
FFS_APCON07
FFS_APCON08
FFS_APCON09
FFS_APCON10
FFS_APCON11
FFS_APCON12
FFS_APCON13
FFS_APCON14
FFS_APCON15
FFS_ATC
FFS_NOF_USERS

Function Documentation

ffs_error_code_type FFS_append | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_append_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ulong FFS_calculate_file_overhead | ( | ulong | filesize,
 |  | BOOL | use_filename
 | ) |

ffs_error_code_type FFS_close | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_close_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_copy | ( | ffs_user_type | user_id,
 |  | word | src_id,
 |  | word | dst_id,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_copy_fn | ( | ffs_user_type | user_id,
 |  | char * | src_name,
 |  | char * | dst_name,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_create | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type * | hp,
 |  | ffs_filetype_type | type,
 |  | ulong | size,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_create_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type * | hp,
 |  | ffs_filetype_type | type,
 |  | ulong | size,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

void FFS_deactivate ( void )

ffs_error_code_type FFS_delete | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_delete_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

BOOL FFS_file_exists ( word id )

BOOL FFS_file_exists_fn | ( | ffs_user_type | user_id,
 |  | char * | filename
 | ) |

BOOL FFS_findfirst | ( | word * | id_ptr,
 |  | ffs_filetype_type | type
 | ) |

BOOL FFS_findfirst_fn | ( | ffs_user_type | user_id,
 |  | char * | filename_buffer,
 |  | char * | filespec,
 |  | ffs_filetype_type | type
 | ) |

BOOL FFS_findnext | ( | word | last_id,
 |  | word * | id_ptr,
 |  | ffs_filetype_type | type
 | ) |

BOOL FFS_findnext_fn | ( | ffs_user_type | user_id,
 |  | char * | filename_buffer,
 |  | char * | filespec,
 |  | ffs_filetype_type | type
 | ) |

ffs_error_code_type FFS_get_file_id | ( | ffs_user_type | user_id,
 |  | char * | filename_buffer,
 |  | word * | id
 | ) |

ffs_error_code_type FFS_get_file_info | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_file_info_type * | info
 | ) |

ffs_error_code_type FFS_get_file_info_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_file_info_type * | info
 | ) |

ffs_error_code_type FFS_get_file_name | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | char * | filename_buffer
 | ) |

ulong FFS_get_free_space ( void )

ulong FFS_get_free_space_by_type ( ffs_filetype_type type )

ulong FFS_get_free_space_in_global_pool ( void )

word FFS_get_next_free_id ( void )

word FFS_get_nof_files ( void )

word FFS_get_nof_files_by_type ( ffs_filetype_type type )

ulong FFS_get_raw_free_space_by_type ( ffs_filetype_type type )

ulong FFS_get_raw_free_space_in_global_pool ( void )

ulong FFS_get_reserved_space_by_type ( ffs_filetype_type type )

ulong FFS_get_reserved_space_in_global_pool ( void )

ulong FFS_get_used_space ( void )

ulong FFS_get_used_space_by_type ( ffs_filetype_type type )

ulong FFS_get_used_space_in_global_pool ( void )

ffs_error_code_type FFS_initialize ( void )

ffs_error_code_type FFS_modify | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_modify_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_open | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type * | hp,
 |  | ffs_open_file_mode_type | mode
 | ) |

ffs_error_code_type FFS_open_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type * | hp,
 |  | ffs_open_file_mode_type | mode
 | ) |

ffs_error_code_type FFS_read | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | byte * | dst,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_read_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | byte * | dst,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_ready ( void )

ffs_error_code_type FFS_rename | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | word | new_id,
 |  | ffs_filetype_type | new_type,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_rename_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | char * | new_filename,
 |  | ffs_filetype_type | new_type,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_set_drm_attrib | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_drm_attrib_type * | drm_attrib,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_set_drm_attrib_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_drm_attrib_type * | drm_attrib,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_truncate | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ulong | new_size,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_truncate_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ulong | new_size,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_write | ( | ffs_user_type | user_id,
 |  | word | id,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

ffs_error_code_type FFS_write_fn | ( | ffs_user_type | user_id,
 |  | char * | filename,
 |  | ffs_handle_type | h,
 |  | byte * | src,
 |  | ulong | offset,
 |  | ulong | nof,
 |  | void(*)(ffs_error_code_type result) | callback
 | ) |

Variable Documentation

const ulong ffs_memory_pool_reservations[FFS_NOF_FILETYPES]

Generated on Tue Jan 24 14:53:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsSim.hpp Source File

Afs/Ffs/FfsSim.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(FFS_SIM_hpp)
00010 #define FFS_SIM_hpp
00011
00012 #include <stdio.h>
00013
00014 #define FFS_MAX_SOF_FILENAME    48
00015 #define FFS_MAX_SOF_DIR_NAME    128
00016 #define FFS_BLOCK_SIZE          0x10000L    //64K (Byte size)
00017 #define FFS_SECTOR_SIZE         1024        //Byte size, must be an even number >= 56.
00018 #define FFS_NOF_DYNAMIC_BLOCKS  42
00019 #define FFS_FILETYPE_SMS_POOL_SIZE_PHYSICAL 74752   //Including FFS overhead
00020 #define FFS_MAX_FILESIZE 0xFFFFF   // 1 Mbytes-1
00021
00022 typedef unsigned char byte;
00023 typedef unsigned short word;
00024 typedef unsigned long ulong;
00025 typedef int BOOL;
00026 typedef FILE *ffs_handle_type;
00027
00028 #define FFS_STREAMING   (0xFEFEFEFE)    //Used as the "size" parameter when creating "streaming files"
00029
00030 // =============================================================================
00031 //  Error Codes
00032 // =============================================================================
00033 typedef enum {
00034   FFS_FALSE,
00035   FFS_TRUE,
00036   FFS_SUCCESS,
00037   FFS_INITIALIZING,
00038   FFS_ALREADY_OPEN,
00039   FFS_NOT_OPEN,
00040   FFS_FILE_NOT_FOUND,
00041   FFS_EXISTS,
00042   FFS_ILLIGAL_ID,
00043   FFS_ILLIGAL_FILE_HANDLE,
00044   FFS_ILLIGAL_TYPE,
00045   FFS_ILLIGAL_MODE,
00046   FFS_FILE_RANGE_ERROR,
00047   FFS_OPERATION_NOT_POSSIBLE,
00048   FFS_WRITE_ERROR,
00049   FFS_USER_ID_ERROR,
00050   FFS_INTERNAL_FATAL_ERROR,
00051   FFS_MEMORY_RES_ERROR,
00052   FFS_MAX_NOF_FILES_EXCEEDED,
00053   FFS_REQUESTED_MEM_NOT_AVAILABLE,
00054   FFS_INVALID_NAME,
00055   FFS_STREAMING_NOT_ENABLED,
00056   FFS_OPERATION_NOT_ALLOWED_ON_STATIC_FILE,
00057   FFS_MEM_TABLES_INCONSISTENCY,
00058   FFS_NOT_A_FACTORY_DEFAULT_FILE,
00059   FFS_REQUESTED_MEM_TEMP_NOT_AVAILABLE,
00060   FFS_ILLIGAL_DIR_OPERATION,
00061   FFS_DIR_SPACE_NOT_AVAILABLE
00062 } ffs_error_code_type;
00063
00064 //Define old errorcodes to ensure backward compatibility:
00065 #define FFS_FILE_ALREADY_CREATED   FFS_EXISTS
00066 #define FFS_INVALID_FILENAME       FFS_INVALID_NAME
00067
00068 // =============================================================================
00069 //  File Types
00070 // =============================================================================
00071 typedef enum {
00072     FFS_GENERIC_FILETYPE,         //For files with no specific type, or for temp-files.
00073     FFS_FILETYPE_APOXI_SETTING,
00074     FFS_FILETYPE_AVI,
00075     FFS_FILETYPE_BMP,
00076     FFS_FILETYPE_GIF,
00077     FFS_FILETYPE_HTM,
00078     FFS_FILETYPE_HTML,
00079     FFS_FILETYPE_ICS,             // vCalendar File
00080     FFS_FILETYPE_JAD,             // java application descriptor
00081     FFS_FILETYPE_JAR,             // java archive
00082     FFS_FILETYPE_JRS,             // java record store
00083     FFS_FILETYPE_JPG,
00084     FFS_FILETYPE_JPE,
00085     FFS_FILETYPE_JPEG,
00086     FFS_FILETYPE_MIDI,
00087     FFS_FILETYPE_MMF,             // For Polytone melodies.
00088     FFS_FILETYPE_MMI_SETTING,
00089     FFS_FILETYPE_MOV,
00090     FFS_FILETYPE_MP3,
00091     FFS_FILETYPE_MPGA,
00092     FFS_FILETYPE_MPE,
00093     FFS_FILETYPE_MPEG,
00094     FFS_FILETYPE_MPG,
00095     FFS_FILETYPE_PNG,
00096     FFS_FILETYPE_TIF,
00097     FFS_FILETYPE_TXT,
00098     FFS_FILETYPE_VCF,             // vCard File
00099     FFS_FILETYPE_WAP_SETTING,
00100     FFS_FILETYPE_WAV,
00101     FFS_FILETYPE_WBMP,            // wireless bmp
00102     FFS_FILETYPE_WML,
00103     FFS_FILETYPE_WMLS,            // WML Script
00104     FFS_FILETYPE_XHTML,
00105     FFS_FILETYPE_XML,
00106     FFS_FILETYPE_AIM,             // Apoxi native image
00107     FFS_FILETYPE_AAN,             // Apoxi animation format
00108     FFS_FILETYPE_IMELODY,
00109     FFS_FILETYPE_AMR,
00110     FFS_FILETYPE_FR,
00111     FFS_FILETYPE_MMF_PHRASE,
00112     FFS_FILETYPE_BROWSER_CACHE,
00113     FFS_FILETYPE_BROWSER_DATBASE,
00114     FFS_FILETYPE_SECURITY_CERTIFICATES,
00115     FFS_FILETYPE_PUSH_MESSAGES,
00116     FFS_FILETYPE_JAM_BACKUP,
00117     FFS_FILETYPE_JAM_DEFAULT,
00118     FFS_FILETYPE_MMS_STORAGE,
00119     FFS_FILETYPE_MMS_REPORTS,
00120     FFS_FILETYPE_MMS_NOTIFICATION,
00121     FFS_FILETYPE_MMS_BACKUP,
00122     FFS_FILETYPE_MMS_TEST,
00123     FFS_FILETYPE_MMS_APP_REPORT,
00124     FFS_FILETYPE_MMT,
00125     FFS_FILETYPE_MYSTUFF,
00126     FFS_FILETYPE_SMS,
00127     FFS_FILETYPE_MMS_PRE,
00128     FFS_FILETYPE_SETTINGS,
00129     FFS_FILETYPE_EMS_BMP,
00130     FFS_FILETYPE_SAF,
00131     FFS_FILETYPE_SPF,
00132     FFS_FILETYPE_DRM_RO,
00133     FFS_FILETYPE_REGISTRY,
00134     FFS_FILETYPE_3GP,
00135     FFS_FILETYPE_SVG,
00136     FFS_FILETYPE_SVGZ,
00137     FFS_FILETYPE_MMS,
00138     FFS_FILETYPE_DRM,
00139     FFS_FILETYPE_FRAME,
00140     FFS_FILETYPE_AAC,
00141     FFS_FILETYPE_M4A,
00142     // All new types shall be inserted above this line.
00143     FFS_NOF_FILETYPES,
00144     FFS_FILETYPE_GARBAGE,         // Special filetype for garbage collector ONLY.
00145     FFS_ALL_FILETYPES = 0xFF
00146 } ffs_filetype_type;
00147
00148 // =============================================================================
00149 //  FFS file ID reservations
00150 // =============================================================================
00154 typedef enum {
00155     // Dummy element = first ID returned by FfsHandler::GetNextFreeId()
00156     FFS_NOF_RES_ID = 300
00157 } ffs_pit;
00158
00159 // =============================================================================
00160 //  Memory Pool Reservations
00161 // =============================================================================
00162 const ulong ffs_memory_pool_reservations[FFS_NOF_FILETYPES] = {
00163  /* FFS_GENERIC_FILETYPE                */     10000,
00164  /* FFS_FILETYPE_APOXI_SETTING          */         0,
00165  /* FFS_FILETYPE_AVI                    */         0,
00166  /* FFS_FILETYPE_BMP                    */         0,
00167  /* FFS_FILETYPE_GIF                    */      4096,
00168  /* FFS_FILETYPE_HTM                    */         0,
00169  /* FFS_FILETYPE_HTML                   */         0,
00170  /* FFS_FILETYPE_ICS                    */         0,
00171  /* FFS_FILETYPE_JAD                    */         0,
00172  /* FFS_FILETYPE_JAR                    */         0,
00173  /* FFS_FILETYPE_JRS                    */         0,
00174  /* FFS_FILETYPE_JPG                    */         0,
00175  /* FFS_FILETYPE_JPE                    */         0,
00176  /* FFS_FILETYPE_JPEG                   */         0,
00177  /* FFS_FILETYPE_MIDI                   */         0,
00178  /* FFS_FILETYPE_MMF                    */      4096,
00179  /* FFS_FILETYPE_MMI_SETTING            */         0,
00180  /* FFS_FILETYPE_MOV                    */         0,
00181  /* FFS_FILETYPE_MP3                    */         0,
00182  /* FFS_FILETYPE_MPGA                   */      4096,
00183  /* FFS_FILETYPE_MPE                    */         0,
00184  /* FFS_FILETYPE_MPEG                   */         0,
00185  /* FFS_FILETYPE_MPG                    */         0,
00186  /* FFS_FILETYPE_PNG                    */         0,
00187  /* FFS_FILETYPE_TIF                    */         0,
00188  /* FFS_FILETYPE_TXT                    */         0,
00189  /* FFS_FILETYPE_VCF                    */         0,
00190  /* FFS_FILETYPE_WAP_SETTING            */         0,
00191  /* FFS_FILETYPE_WAV                    */         0,
00192  /* FFS_FILETYPE_WBMP                   */         0,
00193  /* FFS_FILETYPE_WML                    */         0,
00194  /* FFS_FILETYPE_WMLS                   */         0,
00195  /* FFS_FILETYPE_XHTML                  */         0,
00196  /* FFS_FILETYPE_XML                    */         0,
00197  /* FFS_FILETYPE_AIM                    */         0,
00198  /* FFS_FILETYPE_AAN                    */         0,
00199  /* FFS_FILETYPE_IMELODY                */         0,
00200  /* FFS_FILETYPE_AMR                    */         0,
00201  /* FFS_FILETYPE_FR                     */         0,
00202  /* FFS_FILETYPE_MMF_PHRASE             */         0,
00203  /* FFS_FILETYPE_BROWSER_CACHE,         */         0,
00204  /* FFS_FILETYPE_BROWSER_DATBASE,       */         0,
00205  /* FFS_FILETYPE_SECURITY_CERTIFICATES, */         0,
00206  /* FFS_FILETYPE_PUSH_MESSAGES,         */         0,
00207  /* FFS_FILETYPE_JAM_BACKUP,            */         0,
00208  /* FFS_FILETYPE_JAM_DEFAULT,           */         0,
00209  /* FFS_FILETYPE_MMS_STORAGE,           */         0,
00210  /* FFS_FILETYPE_MMS_REPORTS,           */         0,
00211  /* FFS_FILETYPE_MMS_NOTIFICATION,      */         0,
00212  /* FFS_FILETYPE_MMS_BACKUP,            */         0,
00213  /* FFS_FILETYPE_MMS_TEST,              */         0,
00214  /* FFS_FILETYPE_MMS_APP_REPORT,        */         0,
00215  /* FFS_FILETYPE_MMT,                   */         0,
00216  /* FFS_FILETYPE_MYSTUFF                */         0,
00217  /* FFS_FILETYPE_SMS                    */         FFS_FILETYPE_SMS_POOL_SIZE_PHYSICAL,
00218  /* FFS_FILETYPE_MMS_PRE                */         0,
00219  /* FFS_FILETYPE_SETTINGS               */         0,
00220  /* FFS_FILETYPE_EMS_BMP                */         0,
00221  /* FFS_FILETYPE_SAF                    */         0,
00222  /* FFS_FILETYPE_SPF                    */         0,
00223  /* FFS_FILETYPE_DRM_RO                 */         0,
00224  /* FFS_FILETYPE_REGISTRY               */         0,
00225  /* FFS_FILETYPE_3GP                    */         0,
00226  /* FFS_FILETYPE_SVG                    */         0,
00227  /* FFS_FILETYPE_SVGZ                   */         0,
00228  /* FFS_FILETYPE_MMS                    */         0,
00229  /* FFS_FILETYPE_DRM                    */         0,
00230  /* FFS_FILETYPE_FRAME                  */         0,
00231  /* FFS_FILETYPE_AAC                    */         0,
00232  /* FFS_FILETYPE_M4A                    */         0
00233 };
00234
00235 // =============================================================================
00236 //  Open File Modes
00237 // =============================================================================
00238 typedef enum {
00239   FFS_FILE_OPEN_READ,
00240   FFS_FILE_OPEN_APPEND,
00241   FFS_FILE_OPEN_MODIFY,
00242   FFS_FILE_OPEN_READ_STREAMING
00243 } ffs_open_file_mode_type;
00244
00245 // =============================================================================
00246 //  User Types
00247 // =============================================================================
00248 typedef enum {
00249   FFS_INTERNAL,
00250   FFS_DWDIO,
00251   FFS_MP3,
00252   FFS_VR,
00253   FFS_SMS,
00254   FFS_AUDIO,
00255   FFS_MMI,
00256   FFS_MMS,
00257   FFS_JAVA,
00258   FFS_WAP,
00259   FFS_APCON01,
00260   FFS_APCON02,
00261   FFS_APCON03,
00262   FFS_APCON04,
00263   FFS_APCON05,
00264   FFS_APCON06,
00265   FFS_APCON07,
00266   FFS_APCON08,
00267   FFS_APCON09,
00268   FFS_APCON10,
00269   FFS_APCON11,
00270   FFS_APCON12,
00271   FFS_APCON13,
00272   FFS_APCON14,
00273   FFS_APCON15,
00274   FFS_ATC,
00275   FFS_NOF_USERS       //Dummy element
00276 } ffs_user_type;
00277
00278 // =============================================================================
00279 //  Time record
00280 // =============================================================================
00281 typedef struct {
00282   word year;
00283   byte month;
00284   byte date;
00285   byte hour;
00286   byte min;
00287 } ffs_time_record_type;
00288
00289 // =============================================================================
00290 //  DRM attributes structure
00291 // =============================================================================
00292 typedef struct {
00293   word local_id;
00294   word mime_type;
00295 } ffs_drm_attrib_type;
00296
00297 // =============================================================================
00298 //  File info type
00299 // =============================================================================
00300 typedef struct {
00301   ffs_filetype_type     type;
00302   ulong                 size;
00303   ffs_time_record_type  timestamp;
00304   byte                  dynamic;
00305   byte                  reserved;
00306   ffs_drm_attrib_type   drm_attrib;
00307 #ifdef FFS_FACTORY_FILES
00308   word                  linked_id;
00309 #endif
00310 } ffs_file_info_type;
00311
00312 // =============================================================================
00313 //  Callback type
00314 // =============================================================================
00315 #ifdef FFS_EXTENDED_CALLBACK
00316   #define ffs_callback_type void (*)(ffs_error_code_type, void*)
00317 #else
00318   #define ffs_callback_type void(*)(ffs_error_code_type)
00319 #endif
00320
00321 // =============================================================================
00322 //  Directory support
00323 // =============================================================================
00324 //Directory Id type:
00325 typedef word dir_id_type;
00326
00327 typedef struct {
00328   word                   finding_dirs;
00329   dir_id_type            dir_id;
00330   word                   file_id;
00331   } ffs_ref_type;
00332
00333 ffs_error_code_type FFS_initialize (void);
00334
00335 ffs_error_code_type FFS_ready (void);
00336
00337 void FFS_deactivate (void);
00338
00339 ffs_error_code_type FFS_open (ffs_user_type user_id, word id, ffs_handle_type *hp,
00340                                 ffs_open_file_mode_type mode);
00341
00342 ffs_error_code_type FFS_open_fn (ffs_user_type user_id, char *filename, ffs_handle_type *hp,
00343                                 ffs_open_file_mode_type mode);
00344
00345 ffs_error_code_type FFS_close (ffs_user_type user_id, word id, ffs_handle_type h,
00346                                 void (*callback)(ffs_error_code_type result));
00347
00348 ffs_error_code_type FFS_close_fn (ffs_user_type user_id, char *filename, ffs_handle_type h,
00349                                 void (*callback)(ffs_error_code_type result));
00350
00351 ffs_error_code_type FFS_read (ffs_user_type user_id, word id, ffs_handle_type h,
00352                                 byte *dst, ulong offset, ulong nof,
00353                                 void (*callback)(ffs_error_code_type result));
00354
00355 ffs_error_code_type FFS_read_fn (ffs_user_type user_id, char *filename, ffs_handle_type h,
00356                                 byte *dst, ulong offset, ulong nof,
00357                                 void (*callback)(ffs_error_code_type result));
00358
00359 ffs_error_code_type FFS_create (ffs_user_type user_id, word id,
00360                                 ffs_handle_type *hp, ffs_filetype_type type, ulong size,
00361                                 void (*callback)(ffs_error_code_type result));
00362
00363 ffs_error_code_type FFS_create_fn (ffs_user_type user_id, char *filename,
00364                                     ffs_handle_type *hp, ffs_filetype_type type, ulong size,
00365                                     void (*callback)(ffs_error_code_type result));
00366
00367 ffs_error_code_type FFS_write (ffs_user_type user_id, word id, ffs_handle_type h,
00368                                 byte *src, ulong offset, ulong nof,
00369                                 void (*callback)(ffs_error_code_type result));
00370
00371 ffs_error_code_type FFS_write_fn (ffs_user_type user_id, char *filename, ffs_handle_type h,
00372                                 byte *src, ulong offset, ulong nof,
00373                                 void (*callback)(ffs_error_code_type result));
00374
00375 ffs_error_code_type FFS_modify (ffs_user_type user_id, word id, ffs_handle_type h,
00376                                 byte *src, ulong offset, ulong nof,
00377                                 void (*callback)(ffs_error_code_type result));
00378
00379 ffs_error_code_type FFS_modify_fn (ffs_user_type user_id, char *filename, ffs_handle_type h,
00380                                 byte *src, ulong offset, ulong nof,
00381                                 void (*callback)(ffs_error_code_type result));
00382
00383 ffs_error_code_type FFS_delete (ffs_user_type user_id, word id,
00384                                 void (*callback)(ffs_error_code_type result));
00385
00386 ffs_error_code_type FFS_delete_fn (ffs_user_type user_id, char *filename,
00387                                 void (*callback)(ffs_error_code_type result));
00388
00389 ffs_error_code_type FFS_append (ffs_user_type user_id, word id, ffs_handle_type h,
00390                                 byte *src, ulong nof,
00391                                 void (*callback)(ffs_error_code_type result));
00392
00393 ffs_error_code_type FFS_append_fn (ffs_user_type user_id, char *filename, ffs_handle_type h,
00394                                 byte *src, ulong nof,
00395                                 void (*callback)(ffs_error_code_type result));
00396
00397 ffs_error_code_type FFS_truncate(ffs_user_type user_id, word id, ulong new_size,
00398                                 void (*callback)(ffs_error_code_type result));
00399
00400 ffs_error_code_type FFS_truncate_fn(ffs_user_type user_id, char *filename, ulong new_size,
00401                                 void (*callback)(ffs_error_code_type result));
00402
00403 ffs_error_code_type FFS_rename (ffs_user_type user_id, word id, word new_id,
00404                                 ffs_filetype_type new_type,
00405                                 void (*callback)(ffs_error_code_type result));
00406
00407 ffs_error_code_type FFS_rename_fn (ffs_user_type user_id, char *filename, char *new_filename,
00408                                 ffs_filetype_type new_type,
00409                                 void (*callback)(ffs_error_code_type result));
00410
00411 ffs_error_code_type FFS_copy(ffs_user_type user_id, word src_id, word dst_id,
00412                                 void (*callback)(ffs_error_code_type result));
00413
00414 ffs_error_code_type FFS_copy_fn(ffs_user_type user_id, char *src_name, char *dst_name,
00415                                 void (*callback)(ffs_error_code_type result));
00416
00417 word FFS_get_next_free_id (void);
00418
00419 BOOL FFS_file_exists (word id);
00420
00421 BOOL FFS_file_exists_fn (ffs_user_type user_id, char *filename);
00422
00423 BOOL FFS_findfirst (word *id_ptr, ffs_filetype_type type);
00424
00425 BOOL FFS_findfirst_fn (ffs_user_type user_id, char *filename_buffer,
00426                         char *filespec, ffs_filetype_type type);
00427
00428 #if defined(FFS_DIR_SUPPORT)
00429 BOOL FFS_ffirst_fn(ffs_user_type        user_id,
00430                         char        *name_buffer,
00431                         char        *name_spec,
00432                         ffs_ref_type    *name_ref,
00433                         ffs_filetype_type type);
00434 #endif //FFS_DIR_SUPPORT
00435
00436 BOOL FFS_findnext (word last_id, word *id_ptr, ffs_filetype_type type);
00437
00438 BOOL FFS_findnext_fn (ffs_user_type user_id, char *filename_buffer,
00439                         char *filespec, ffs_filetype_type type);
00440
00441 #if defined(FFS_DIR_SUPPORT)
00442 BOOL FFS_fnext_fn(ffs_user_type     user_id,
00443                         char        *name_buffer,
00444                         char        *name_spec,
00445                         ffs_ref_type    *name_ref,
00446                         ffs_filetype_type type);
00447 #endif //FFS_DIR_SUPPORT
00448
00449 ffs_error_code_type FFS_set_drm_attrib (ffs_user_type user_id, word id,
00450                                     ffs_drm_attrib_type *drm_attrib,
00451                                     void (*callback)(ffs_error_code_type result));
00452
00453 ffs_error_code_type FFS_set_drm_attrib_fn (ffs_user_type user_id, char *filename,
00454                                     ffs_drm_attrib_type *drm_attrib,
00455                                     void (*callback)(ffs_error_code_type result));
00456
00457 ffs_error_code_type FFS_get_file_info (ffs_user_type user_id, word id, ffs_file_info_type *info);
00458
00459 ffs_error_code_type FFS_get_file_info_fn (ffs_user_type user_id, char *filename,
00460                                     ffs_file_info_type *info);
00461
00462 ffs_error_code_type FFS_get_file_name(ffs_user_type user_id, word id, char *filename_buffer);
00463
00464 ffs_error_code_type FFS_get_file_id(ffs_user_type user_id, char *filename_buffer, word *id);
00465
00466 word FFS_get_nof_files (void);
00467
00468 word FFS_get_nof_files_by_type (ffs_filetype_type type);
00469
00470 ulong FFS_get_free_space (void);
00471
00472 ulong FFS_get_free_space_by_type (ffs_filetype_type type);
00473
00474 ulong FFS_get_free_space_in_global_pool (void);
00475
00476 ulong FFS_get_raw_free_space_by_type(ffs_filetype_type type);
00477
00478 ulong FFS_get_raw_free_space_in_global_pool(void);
00479
00480 ulong FFS_get_reserved_space_by_type(ffs_filetype_type type);
00481
00482 ulong FFS_get_reserved_space_in_global_pool(void);
00483
00484 ulong FFS_get_used_space(void);
00485
00486 ulong FFS_get_used_space_by_type(ffs_filetype_type type);
00487
00488 ulong FFS_get_used_space_in_global_pool(void);
00489
00490 ulong FFS_calculate_file_overhead(ulong filesize, BOOL use_filename);
00491
00492 #if defined(FFS_DIR_SUPPORT)
00493 ffs_error_code_type FFS_mkdir(ffs_user_type user_id,
00494                 const char *path,
00495                 void (*callback)( ffs_error_code_type result));
00496
00497 ffs_error_code_type FFS_rmdir(ffs_user_type user_id,
00498                 const char *path,
00499                 void (*callback)( ffs_error_code_type result));
00500
00501 ffs_error_code_type FFS_getcwd(ffs_user_type user_id,
00502                 char *path,
00503                 void (*callback)( ffs_error_code_type result));
00504
00505 ffs_error_code_type FFS_setcwd(ffs_user_type user_id,
00506                 const char *path,
00507                 void (*callback)( ffs_error_code_type result));
00508
00509 ffs_error_code_type FFS_isdir(ffs_user_type user_id,
00510                 const char *path,
00511                 void (*callback)( ffs_error_code_type result));
00512 #endif //FFS_DIR_SUPPORT
00513
00514 #endif  // FFS_SIM_hpp
00515
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsTypes.hpp File Reference

Afs/Ffs/FfsTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Afs/Ffs/FfsSim.hpp>

Include dependency graph for FfsTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | FfsDrmAttrib
FfsDrmAttrib contains the digital rights management attribute. More...
struct | FfsFileInfo
struct | FfsRefType
struct | FfsTimeRecord
FfsTimeRecord is updated after every modification of a file. More...

Defines

#define | Apoxi_FfsTypes_hpp
#define | ExtFfsFileType(type_name) ((FfsFileType)FFS_FILETYPE_##type_name)
#define | ExtFfsPit(pit_name) ((FfsPit)FFS_##pit_name)
#define | ExtFfsUserType(type_name) ((FfsUserType)FFS_##type_name)

Typedefs

typedef word | FfsFileId
typedef ffs_handle_type | FfsHandle

Enumerations

enum FfsError {
FfsErrorFalse = FFS_FALSE, FfsErrorTrue = FFS_TRUE, FfsErrorSuccess = FFS_SUCCESS, FfsErrorInitializing = FFS_INITIALIZING,
FfsErrorAlreadyOpen = FFS_ALREADY_OPEN, FfsErrorNotOpen = FFS_NOT_OPEN, FfsErrorFileNotFound = FFS_FILE_NOT_FOUND, FfsErrorFileAlreadyCreated = FFS_EXISTS,
FfsErrorIllegalId = FFS_ILLIGAL_ID, FfsErrorIllegalFileHandle = FFS_ILLIGAL_FILE_HANDLE, FfsErrorIllegalType = FFS_ILLIGAL_TYPE, FfsErrorIllegalMode = FFS_ILLIGAL_MODE,
FfsErrorFileRangeError = FFS_FILE_RANGE_ERROR, FfsErrorNotPossible = FFS_OPERATION_NOT_POSSIBLE, FfsErrorWriteError = FFS_WRITE_ERROR, FfsErrorUserIdError = FFS_USER_ID_ERROR,
FfsErrorIntFatalError = FFS_INTERNAL_FATAL_ERROR, FfsErrorMemoryResError = FFS_MEMORY_RES_ERROR, FfsErrorMaxNrOfFilesExcceeded = FFS_MAX_NOF_FILES_EXCEEDED, FfsErrorReqMemNotAvailable = FFS_REQUESTED_MEM_NOT_AVAILABLE,
FfsErrorInvalidFilename = FFS_INVALID_NAME, FfsErrorStreamingNotEnabled = FFS_STREAMING_NOT_ENABLED, FfsErrorOpNotAllowedOnStatFile = FFS_OPERATION_NOT_ALLOWED_ON_STATIC_FILE, FfsErrorMemTablesInconsistent = FFS_MEM_TABLES_INCONSISTENCY,
FfsErrorNoFactoryDefaultFile = FFS_NOT_A_FACTORY_DEFAULT_FILE, FfsErrorReqMemTempNotAvailable = FFS_REQUESTED_MEM_TEMP_NOT_AVAILABLE
}
enum FfsFileType {
FfsFileTypeGeneric = FFS_GENERIC_FILETYPE, FfsFileTypeApoxiSetting = FFS_FILETYPE_APOXI_SETTING, FfsFileTypeAvi = FFS_FILETYPE_AVI, FfsFileTypeBmp = FFS_FILETYPE_BMP,
FfsFileTypeGif = FFS_FILETYPE_GIF, FfsFileTypeHtm = FFS_FILETYPE_HTM, FfsFileTypeHtml = FFS_FILETYPE_HTML, FfsFileTypeIcs = FFS_FILETYPE_ICS,
FfsFileTypeJad = FFS_FILETYPE_JAD, FfsFileTypeJar = FFS_FILETYPE_JAR, FfsFileTypeJrs = FFS_FILETYPE_JRS, FfsFileTypeJpg = FFS_FILETYPE_JPG,
FfsFileTypeJpe = FFS_FILETYPE_JPE, FfsFileTypeJpeg = FFS_FILETYPE_JPEG, FfsFileTypeMidi = FFS_FILETYPE_MIDI, FfsFileTypeMmf = FFS_FILETYPE_MMF,
FfsFileTypeMmiSetting = FFS_FILETYPE_MMI_SETTING, FfsFileTypeMov = FFS_FILETYPE_MOV, FfsFileTypeMp3 = FFS_FILETYPE_MP3, FfsFileTypeMpga = FFS_FILETYPE_MPGA,
FfsFileTypeMpe = FFS_FILETYPE_MPE, FfsFileTypeMpeg = FFS_FILETYPE_MPEG, FfsFileTypeMpg = FFS_FILETYPE_MPG, FfsFileTypePng = FFS_FILETYPE_PNG,
FfsFileTypeTif = FFS_FILETYPE_TIF, FfsFileTypeTxt = FFS_FILETYPE_TXT, FfsFileTypeVcf = FFS_FILETYPE_VCF, FfsFileTypeWapSetting = FFS_FILETYPE_WAP_SETTING,
FfsFileTypeWav = FFS_FILETYPE_WAV, FfsFileTypeWbmp = FFS_FILETYPE_WBMP, FfsFileTypeWml = FFS_FILETYPE_WML, FfsFileTypeWmls = FFS_FILETYPE_WMLS,
FfsFileTypeXhtml = FFS_FILETYPE_XHTML, FfsFileTypeXml = FFS_FILETYPE_XML, FfsFileTypeAim = FFS_FILETYPE_AIM, FfsFileTypeAan = FFS_FILETYPE_AAN,
FfsFileTypeIMelody = FFS_FILETYPE_IMELODY, FfsFileTypeAmr = FFS_FILETYPE_AMR, FfsFileTypeFr = FFS_FILETYPE_FR, FfsFileTypeMmfPhrase = FFS_FILETYPE_MMF_PHRASE,
FfsFileTypeBrowserCache = FFS_FILETYPE_BROWSER_CACHE, FfsFileTypeBrowserDatabase = FFS_FILETYPE_BROWSER_DATBASE, FfsFileTypeSecurityCertificates = FFS_FILETYPE_SECURITY_CERTIFICATES, FfsFileTypePushMessages = FFS_FILETYPE_PUSH_MESSAGES,
FfsFileTypeJamBackup = FFS_FILETYPE_JAM_BACKUP, FfsFileTypeJamDefault = FFS_FILETYPE_JAM_DEFAULT, FfsFileTypeMmsStorage = FFS_FILETYPE_MMS_STORAGE, FfsFileTypeMmsReports = FFS_FILETYPE_MMS_REPORTS,
FfsFileTypeMmsNotification = FFS_FILETYPE_MMS_NOTIFICATION, FfsFileTypeMmsBackup = FFS_FILETYPE_MMS_BACKUP, FfsFileTypeMmsTest = FFS_FILETYPE_MMS_TEST, FfsFileTypeMmsAppReport = FFS_FILETYPE_MMS_APP_REPORT,
FfsFileTypeMmt = FFS_FILETYPE_MMT, FfsFileTypeMyStuff = FFS_FILETYPE_MYSTUFF, FfsFileTypeSms = FFS_FILETYPE_SMS, FfsFileTypeMmsPre = FFS_FILETYPE_MMS_PRE,
FfsFileTypeSettings = FFS_FILETYPE_SETTINGS, FfsFileTypeEmsBmp = FFS_FILETYPE_EMS_BMP, FfsFileTypeSaf = FFS_FILETYPE_SAF, FfsFileTypeSpf = FFS_FILETYPE_SPF,
FfsFileTypeDrmRo = FFS_FILETYPE_DRM_RO, FfsFileTypeRegistry = FFS_FILETYPE_REGISTRY, FfsFileType3gp = FFS_FILETYPE_3GP, FfsFileTypeSvg = FFS_FILETYPE_SVG,
FfsFileTypeSvgz = FFS_FILETYPE_SVGZ, FfsFileTypeMms = FFS_FILETYPE_MMS, FfsFileTypeDrm = FFS_FILETYPE_DRM, FfsFileTypeFrame = FFS_FILETYPE_FRAME,
FfsFileTypeAac = FFS_FILETYPE_AAC, FfsFileTypeM4a = FFS_FILETYPE_M4A, FfsNofFileTypes = FFS_NOF_FILETYPES, FfsFileTypeGarbage = FFS_FILETYPE_GARBAGE,
FfsFileTypeAll = FFS_ALL_FILETYPES
}
enum | FfsOpenMode { FfsOpenModeRead = FFS_FILE_OPEN_READ, FfsOpenModeAppend = FFS_FILE_OPEN_APPEND, FfsOpenModeModify = FFS_FILE_OPEN_MODIFY, FfsOpenModeReadStr = FFS_FILE_OPEN_READ_STREAMING }
enum | FfsPit { FfsNofResId = FFS_NOF_RES_ID }
enum FfsUserType {
FfsUserTypeDwdIo = FFS_DWDIO, FfsUserTypeMp3 = FFS_MP3, FfsUserTypeVr = FFS_VR, FfsUserTypeSms = FFS_SMS,
FfsUserTypeAudio = FFS_AUDIO, FfsUserTypeMmi = FFS_MMI, FfsUserTypeMms = FFS_MMS, FfsUserTypeJava = FFS_JAVA,
FfsUserTypeWap = FFS_WAP, FfsUserTypeAppCon01 = FFS_APCON01, FfsUserTypeAppCon02 = FFS_APCON02, FfsUserTypeAppCon03 = FFS_APCON03,
FfsUserTypeAppCon04 = FFS_APCON04, FfsUserTypeAppCon05 = FFS_APCON05, FfsUserTypeAppCon06 = FFS_APCON06, FfsUserTypeAppCon07 = FFS_APCON07,
FfsUserTypeAppCon08 = FFS_APCON08, FfsUserTypeAppCon09 = FFS_APCON09, FfsUserTypeAppCon10 = FFS_APCON10, FfsUserTypeAppCon11 = FFS_APCON11,
FfsUserTypeAppCon12 = FFS_APCON12, FfsUserTypeAppCon13 = FFS_APCON13, FfsUserTypeAppCon14 = FFS_APCON14, FfsUserTypeAppCon15 = FFS_APCON15,
FfsUserTypeAtc = FFS_ATC, FfsNofUsers = FFS_NOF_USERS
}

Variables

const UINT | c_ffs_block_header_size = 3
const UINT32 | c_ffs_streaming = FFS_STREAMING
const UINT | c_max_filename_len = FFS_MAX_SOF_FILENAME
const UINT32 | c_max_total_ffs_memory
const FfsFileInfo | EmptyFfsFileInfo
EmptyFfsFileInfo should be used for initializing an FfsFileInfo.

Define Documentation

#define Apoxi_FfsTypes_hpp

Generated on Tue Jan 24 14:53:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FfsTypes.hpp Source File

Afs/Ffs/FfsTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FfsTypes_hpp)
00011 #define Apoxi_FfsTypes_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017 #if defined(APOXI_RTOS_WIN32)
00018     // Host simulator for FFS.
00019     #include <Afs/Ffs/FfsSim.hpp>
00020 #elif !defined(FFS_PRESENT)
00021     #error The flash file system (FFS) is a prerequisite for an APOXI target build - please enable feature FFS!
00022 #else
00023     #include <stack/driver.h>
00024 #endif
00025
00029 const UINT c_max_filename_len = FFS_MAX_SOF_FILENAME;
00030
00031 #if defined(FFS_DIR_SUPPORT)
00032
00035     const UINT c_max_dirname_len = FFS_MAX_SOF_DIR_NAME;
00036 #endif
00037
00042 typedef ffs_handle_type         FfsHandle;
00043
00045 typedef word                    FfsFileId;
00046
00048 const UINT32 c_ffs_streaming = FFS_STREAMING;
00049
00050 const UINT c_ffs_block_header_size = 3;
00051 const UINT32 c_max_total_ffs_memory =
00052     ((FFS_BLOCK_SIZE - c_ffs_block_header_size * 2) / FFS_SECTOR_SIZE) *
00053     FFS_SECTOR_SIZE * (FFS_NOF_DYNAMIC_BLOCKS - 1);
00054
00055 // =============================================================================
00056 //  Error Codes
00057 // =============================================================================
00058
00061 enum FfsError {
00063     FfsErrorFalse                   = FFS_FALSE,
00065     FfsErrorTrue                    = FFS_TRUE,
00067     FfsErrorSuccess                 = FFS_SUCCESS,
00069     FfsErrorInitializing            = FFS_INITIALIZING,
00071     FfsErrorAlreadyOpen             = FFS_ALREADY_OPEN,
00073     FfsErrorNotOpen                 = FFS_NOT_OPEN,
00075     FfsErrorFileNotFound            = FFS_FILE_NOT_FOUND,
00076 #if defined(APOXI_PLATFORM_BP30)
00077
00078     FfsErrorFileAlreadyCreated      = FFS_FILE_ALREADY_CREATED,
00079 #else
00080
00081     FfsErrorFileAlreadyCreated      = FFS_EXISTS,
00082 #endif
00083
00084     FfsErrorIllegalId               = FFS_ILLIGAL_ID,
00086     FfsErrorIllegalFileHandle       = FFS_ILLIGAL_FILE_HANDLE,
00088     FfsErrorIllegalType             = FFS_ILLIGAL_TYPE,
00090     FfsErrorIllegalMode             = FFS_ILLIGAL_MODE,
00092     FfsErrorFileRangeError          = FFS_FILE_RANGE_ERROR,
00094     FfsErrorNotPossible             = FFS_OPERATION_NOT_POSSIBLE,
00096     FfsErrorWriteError              = FFS_WRITE_ERROR,
00098     FfsErrorUserIdError             = FFS_USER_ID_ERROR,
00100     FfsErrorIntFatalError           = FFS_INTERNAL_FATAL_ERROR,
00102     FfsErrorMemoryResError          = FFS_MEMORY_RES_ERROR,
00104     FfsErrorMaxNrOfFilesExcceeded   = FFS_MAX_NOF_FILES_EXCEEDED,
00106     FfsErrorReqMemNotAvailable      = FFS_REQUESTED_MEM_NOT_AVAILABLE,
00108     FfsErrorInvalidFilename         = FFS_INVALID_NAME,
00110     FfsErrorStreamingNotEnabled     = FFS_STREAMING_NOT_ENABLED,
00112     FfsErrorOpNotAllowedOnStatFile  = FFS_OPERATION_NOT_ALLOWED_ON_STATIC_FILE,
00114     FfsErrorMemTablesInconsistent   = FFS_MEM_TABLES_INCONSISTENCY,
00116     FfsErrorNoFactoryDefaultFile    = FFS_NOT_A_FACTORY_DEFAULT_FILE,
00118     FfsErrorReqMemTempNotAvailable  = FFS_REQUESTED_MEM_TEMP_NOT_AVAILABLE,
00119
00120 #if defined(FFS_DIR_SUPPORT)
00121
00122     FfsErrorIllegalDirOperation     = FFS_ILLIGAL_DIR_OPERATION,
00124     FfsErrorDirSpaceNotAvailable    = FFS_DIR_SPACE_NOT_AVAILABLE
00125 #endif
00126
00127 };
00128
00129 // =============================================================================
00130 //  User Types
00131 // =============================================================================
00132
00135 enum FfsUserType {
00137     FfsUserTypeDwdIo    = FFS_DWDIO,
00139     FfsUserTypeMp3      = FFS_MP3,
00141     FfsUserTypeVr       = FFS_VR,
00143     FfsUserTypeSms      = FFS_SMS,
00145     FfsUserTypeAudio    = FFS_AUDIO,
00147     FfsUserTypeMmi      = FFS_MMI,
00149     FfsUserTypeMms      = FFS_MMS,
00151     FfsUserTypeJava     = FFS_JAVA,
00153     FfsUserTypeWap      = FFS_WAP,
00155     FfsUserTypeAppCon01 = FFS_APCON01,
00157     FfsUserTypeAppCon02 = FFS_APCON02,
00159     FfsUserTypeAppCon03 = FFS_APCON03,
00161     FfsUserTypeAppCon04 = FFS_APCON04,
00163     FfsUserTypeAppCon05 = FFS_APCON05,
00165     FfsUserTypeAppCon06 = FFS_APCON06,
00167     FfsUserTypeAppCon07 = FFS_APCON07,
00169     FfsUserTypeAppCon08 = FFS_APCON08,
00171     FfsUserTypeAppCon09 = FFS_APCON09,
00173     FfsUserTypeAppCon10 = FFS_APCON10,
00175     FfsUserTypeAppCon11 = FFS_APCON11,
00177     FfsUserTypeAppCon12 = FFS_APCON12,
00179     FfsUserTypeAppCon13 = FFS_APCON13,
00181     FfsUserTypeAppCon14 = FFS_APCON14,
00183     FfsUserTypeAppCon15 = FFS_APCON15,
00185     FfsUserTypeAtc      = FFS_ATC,
00187     FfsNofUsers         = FFS_NOF_USERS    // Dummy element
00188 };
00189
00231 #define ExtFfsUserType(type_name) ((FfsUserType)FFS_##type_name)
00232
00233 // =============================================================================
00234 //  File Types
00235 // =============================================================================
00236
00241 enum FfsFileType {
00243     FfsFileTypeGeneric              = FFS_GENERIC_FILETYPE,
00245     FfsFileTypeApoxiSetting         = FFS_FILETYPE_APOXI_SETTING,
00247     FfsFileTypeAvi                  = FFS_FILETYPE_AVI,
00249     FfsFileTypeBmp                  = FFS_FILETYPE_BMP,
00251     FfsFileTypeGif                  = FFS_FILETYPE_GIF,
00253     FfsFileTypeHtm                  = FFS_FILETYPE_HTM,
00255     FfsFileTypeHtml                 = FFS_FILETYPE_HTML,
00257     FfsFileTypeIcs                  = FFS_FILETYPE_ICS,
00259     FfsFileTypeJad                  = FFS_FILETYPE_JAD,
00261     FfsFileTypeJar                  = FFS_FILETYPE_JAR,
00263     FfsFileTypeJrs                  = FFS_FILETYPE_JRS,
00265     FfsFileTypeJpg                  = FFS_FILETYPE_JPG,
00267     FfsFileTypeJpe                  = FFS_FILETYPE_JPE,
00269     FfsFileTypeJpeg                 = FFS_FILETYPE_JPEG,
00271     FfsFileTypeMidi                 = FFS_FILETYPE_MIDI,
00273     FfsFileTypeMmf                  = FFS_FILETYPE_MMF,
00275     FfsFileTypeMmiSetting           = FFS_FILETYPE_MMI_SETTING,
00277     FfsFileTypeMov                  = FFS_FILETYPE_MOV,
00279     FfsFileTypeMp3                  = FFS_FILETYPE_MP3,
00281     FfsFileTypeMpga                 = FFS_FILETYPE_MPGA,
00283     FfsFileTypeMpe                  = FFS_FILETYPE_MPE,
00285     FfsFileTypeMpeg                 = FFS_FILETYPE_MPEG,
00287     FfsFileTypeMpg                  = FFS_FILETYPE_MPG,
00289     FfsFileTypePng                  = FFS_FILETYPE_PNG,
00291     FfsFileTypeTif                  = FFS_FILETYPE_TIF,
00293     FfsFileTypeTxt                  = FFS_FILETYPE_TXT,
00295     FfsFileTypeVcf                  = FFS_FILETYPE_VCF,
00297     FfsFileTypeWapSetting           = FFS_FILETYPE_WAP_SETTING,
00299     FfsFileTypeWav                  = FFS_FILETYPE_WAV,
00301     FfsFileTypeWbmp                 = FFS_FILETYPE_WBMP,
00303     FfsFileTypeWml                  = FFS_FILETYPE_WML,
00305     FfsFileTypeWmls                 = FFS_FILETYPE_WMLS,
00307     FfsFileTypeXhtml                = FFS_FILETYPE_XHTML,
00309     FfsFileTypeXml                  = FFS_FILETYPE_XML,
00311     FfsFileTypeAim                  = FFS_FILETYPE_AIM,
00313     FfsFileTypeAan                  = FFS_FILETYPE_AAN,
00315     FfsFileTypeIMelody              = FFS_FILETYPE_IMELODY,
00317     FfsFileTypeAmr                  = FFS_FILETYPE_AMR,
00319     FfsFileTypeFr                   = FFS_FILETYPE_FR,
00321     FfsFileTypeMmfPhrase            = FFS_FILETYPE_MMF_PHRASE,
00323     FfsFileTypeBrowserCache         = FFS_FILETYPE_BROWSER_CACHE,
00325     FfsFileTypeBrowserDatabase      = FFS_FILETYPE_BROWSER_DATBASE,
00327     FfsFileTypeSecurityCertificates = FFS_FILETYPE_SECURITY_CERTIFICATES,
00329     FfsFileTypePushMessages         = FFS_FILETYPE_PUSH_MESSAGES,
00331     FfsFileTypeJamBackup            = FFS_FILETYPE_JAM_BACKUP,
00333     FfsFileTypeJamDefault           = FFS_FILETYPE_JAM_DEFAULT,
00335     FfsFileTypeMmsStorage           = FFS_FILETYPE_MMS_STORAGE,
00337     FfsFileTypeMmsReports           = FFS_FILETYPE_MMS_REPORTS,
00339     FfsFileTypeMmsNotification      = FFS_FILETYPE_MMS_NOTIFICATION,
00341     FfsFileTypeMmsBackup            = FFS_FILETYPE_MMS_BACKUP,
00343     FfsFileTypeMmsTest              = FFS_FILETYPE_MMS_TEST,
00345     FfsFileTypeMmsAppReport         = FFS_FILETYPE_MMS_APP_REPORT,
00347     FfsFileTypeMmt                  = FFS_FILETYPE_MMT,
00349     FfsFileTypeMyStuff              = FFS_FILETYPE_MYSTUFF,
00351     FfsFileTypeSms                  = FFS_FILETYPE_SMS,
00353     FfsFileTypeMmsPre               = FFS_FILETYPE_MMS_PRE,
00355     FfsFileTypeSettings             = FFS_FILETYPE_SETTINGS,
00357     FfsFileTypeEmsBmp               = FFS_FILETYPE_EMS_BMP,
00359     FfsFileTypeSaf                  = FFS_FILETYPE_SAF,
00361     FfsFileTypeSpf                  = FFS_FILETYPE_SPF,
00363     FfsFileTypeDrmRo                = FFS_FILETYPE_DRM_RO,
00365     FfsFileTypeRegistry             = FFS_FILETYPE_REGISTRY,
00367     FfsFileType3gp                  = FFS_FILETYPE_3GP,
00368 #if !defined(APOXI_PLATFORM_BP30)
00369
00370     FfsFileTypeSvg                  = FFS_FILETYPE_SVG,
00372     FfsFileTypeSvgz                 = FFS_FILETYPE_SVGZ,
00374     FfsFileTypeMms                  = FFS_FILETYPE_MMS,
00376     FfsFileTypeDrm                  = FFS_FILETYPE_DRM,
00378     FfsFileTypeFrame                = FFS_FILETYPE_FRAME,
00380     FfsFileTypeAac                  = FFS_FILETYPE_AAC,
00382     FfsFileTypeM4a                  = FFS_FILETYPE_M4A,
00383 #endif
00384
00385     FfsNofFileTypes                 = FFS_NOF_FILETYPES,
00387     FfsFileTypeGarbage              = FFS_FILETYPE_GARBAGE,
00389     FfsFileTypeAll                  = FFS_ALL_FILETYPES
00390 };
00391
00392 // =============================================================================
00393 //  FFS file ID reservations
00394 // =============================================================================
00398 enum FfsPit {
00399     FfsNofResId = FFS_NOF_RES_ID    // Dummy element
00400 };
00401
00443 #define ExtFfsPit(pit_name) ((FfsPit)FFS_##pit_name)
00444
00487 #define ExtFfsFileType(type_name) ((FfsFileType)FFS_FILETYPE_##type_name)
00488
00489 // =============================================================================
00490 //  Open File Modes
00491 // =============================================================================
00492
00499 enum FfsOpenMode {
00501     FfsOpenModeRead         = FFS_FILE_OPEN_READ,
00503     FfsOpenModeAppend       = FFS_FILE_OPEN_APPEND,
00505     FfsOpenModeModify       = FFS_FILE_OPEN_MODIFY,
00507     FfsOpenModeReadStr      = FFS_FILE_OPEN_READ_STREAMING
00508 };
00509
00510 // =============================================================================
00511 //  Time Record
00512 // =============================================================================
00513
00515 struct FfsTimeRecord {
00517     UINT16  year;
00519     UINT8   month;
00521     UINT8   date;
00523     UINT8   hour;
00525     UINT8   min;
00526 };
00527
00528 // =============================================================================
00529 //  DRM Attribute Type
00530 // =============================================================================
00531
00533 struct FfsDrmAttrib {
00535     UINT16  local_id;
00537     UINT16  mime_type;
00538 };
00539
00540 // =============================================================================
00541 //  File Reference Type
00542 // =============================================================================
00543
00546 struct FfsRefType {
00548   UINT16        finding_dirs;
00550   UINT16        dir_id;
00552   UINT16        file_id;
00553 };
00554
00555 // =============================================================================
00556 //  File Info Type
00557 // =============================================================================
00558
00561 struct FfsFileInfo {
00563     FfsFileType         type;
00565     UINT32              size;
00567     FfsTimeRecord       timestamp;
00569     UINT8               dynamic;
00571     UINT8               reserved;
00573     FfsDrmAttrib        drm_attrib;
00574
00575 #ifdef FFS_FACTORY_FILES
00576
00577     UINT32              linked_id;
00578 #endif
00579
00580 };
00581
00583 const FfsFileInfo EmptyFfsFileInfo =
00584     { FfsFileTypeAll, 0, { 0, 0, 0, 0, 0 }, 0, 0, 0
00585 #ifdef FFS_FACTORY_FILES
00586         , 0
00587 #endif
00588     };
00589
00591 #endif  // Apoxi_FfsTypes_hpp
00592
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FlsFile.cpp File Reference

Afs/Ffs/FlsFile.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FfsHandler.hpp"
#include "FfsMimeTypeMap.hpp"
#include "FlsFile.hpp"
#include "AddOns/AfsFfs/FlashStorageDeviceImp.hpp"

Include dependency graph for FlsFile.cpp:

Generated on Tue Jan 24 16:52:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FlsFile.hpp File Reference

Afs/Ffs/FlsFile.hpp File Reference

#include <Afs/Ffs/FfsTypes.hpp>
#include <Afs/Rfs/File.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for FlsFile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FlsFile

Defines

#define | Apoxi_FlsFile_hpp

Define Documentation

#define Apoxi_FlsFile_hpp

Generated on Tue Jan 24 14:53:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Ffs/FlsFile.hpp Source File

Afs/Ffs/FlsFile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_FlsFile_hpp)
00010 #define Apoxi_FlsFile_hpp
00013
00014 #include <Afs/Ffs/FfsTypes.hpp>
00015 #include <Afs/Rfs/File.hpp>
00016 #include <Auxiliary/String.hpp>
00017
00150 class FlsFile
00151 {
00152     public:
00153
00155         FlsFile();
00157         FlsFile(FfsUserType user_id);
00159         ~FlsFile();
00160
00161         // callback functions for the streaming operations.
00162         static void StreamingDriverReadCallback(FfsError result, void *client_arg);
00163         static void StreamingDriverWriteCallback(FfsError result, void *client_arg);
00164
00167         BOOLEAN     IsInitialized() const { return m_is_initialized; }
00168
00170         BOOLEAN     AssureInitialized(const CHAR *filename);
00171
00174         BOOLEAN     Open(FfsFileId id, FfsFileType file_type);
00175
00180         BOOLEAN     Open(const CHAR *filename);
00181
00184         BOOLEAN     Open(const CHAR *filename, FfsFileType file_type);
00185
00188         BOOLEAN     OpenStreaming(const CHAR *filename);
00189
00192         BOOLEAN     Create(FfsFileId id, FfsFileType file_type, UINT32 size);
00193
00198         BOOLEAN     Create(const CHAR *filename, UINT32 size);
00199
00203         BOOLEAN     Create(const CHAR *filename, FfsFileType file_type,
00204             UINT32 size);
00205
00210         BOOLEAN     CreateStreaming(const CHAR *filename);
00211
00215         BOOLEAN     Copy(const CHAR *dest_filename);
00216
00219         BOOLEAN     Close();
00220
00223         BOOLEAN     Read(void FFS_HUGE *dst, UINT32 offset, UINT32 no_bytes)
00224             const;
00225
00239         BOOLEAN     Read(void FFS_HUGE *dst, UINT32 offset, UINT32 max_no_bytes,
00240             UINT32 &bytes_read) const;
00241
00257         BOOLEAN     ReadStreaming(void HUGE *buffer, UINT32 count, UINT32 bytes_read);
00258
00268         BOOLEAN     ReadStreamingAsync(void HUGE *buffer, UINT32 count,
00269                         void (callback_func)(File::Error result, UINT32 bytes_operated));
00270
00275         BOOLEAN     Write(const void FFS_HUGE *src, UINT32 offset,
00276             UINT32 no_bytes);
00277
00284         BOOLEAN     WriteStreaming(const void HUGE *buffer, UINT32 count);
00285
00292         BOOLEAN     WriteStreamingAsync(const void HUGE *buffer, UINT32 count,
00293                         void (callback_func)(File::Error result, UINT32 bytes_operated));
00294
00297         BOOLEAN     Delete();
00298
00301         BOOLEAN     Rename(FfsFileId new_id);
00302
00305         BOOLEAN     Rename(const CHAR *new_filename);
00306
00312         BOOLEAN     Resize(UINT32 new_size);
00313
00316         BOOLEAN     GetFileSize(UINT32 &file_size) const;
00317
00320         BOOLEAN     GetFileType(FfsFileType &file_type) const;
00321
00326         BOOLEAN     GetTimestamp(FfsTimeRecord &time_stamp) const;
00327
00331         FfsError    GetLastError() const { return m_last_error; }
00332
00334         BOOLEAN     IsOpen() const { return m_is_open; }
00335
00337         FfsUserType GetUserId() const { return m_user_id; }
00338
00342         BOOLEAN     SetUserId(FfsUserType user_id);
00343
00346         BOOLEAN     GetHandle(FfsHandle &file_handle) const;
00347
00352         BOOLEAN     SetDrmAttrib(const FfsDrmAttrib &attrib);
00353
00358         BOOLEAN     GetDrmAttrib(FfsDrmAttrib &attrib) const;
00359
00360     private:
00361         BOOLEAN     Open(FfsOpenMode mode);
00362         BOOLEAN     InternalOpen(FfsOpenMode mode);
00363         BOOLEAN     Create(UINT32 size);
00364         BOOLEAN     InternalWrite(const void FFS_HUGE *src, UINT32 offset,
00365             UINT32 nof);
00366         BOOLEAN     Modify(const void FFS_HUGE *src, UINT32 offset, UINT32 nof);
00367         BOOLEAN     Append(const void FFS_HUGE *src, UINT32 nof);
00368         BOOLEAN     GetFileInfo() const;
00369         const CHAR* GetFileExtension(const CHAR *filename) const;
00370         BOOLEAN     Upsize(UINT32 new_size);
00371         BOOLEAN     Downsize(UINT32 new_size);
00372
00373         mutable BOOLEAN     m_is_info_upd;
00374         BOOLEAN     m_is_initialized;
00375         BOOLEAN     m_has_filename;
00376         BOOLEAN     m_is_open;
00377         BOOLEAN     m_is_writeable;
00378         FfsFileId   m_file_id;
00379         FfsOpenMode m_open_mode;
00380         FfsUserType m_user_id;
00381         FfsFileType m_file_type;
00382         mutable FfsError    m_last_error;
00383         FfsHandle   m_filehandle;
00384         String      m_filename;
00385         mutable FfsFileInfo m_file_info;
00386
00387
00388         BOOLEAN m_is_streaming;
00389         UINT32 m_streaming_bytes_operated;
00390         UINT32 m_streaming_buf_size;
00391         File::StreamingCallback m_streaming_cb;
00392
00393 };
00394
00396 #endif  // Apoxi_FlsFile_hpp
00397
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/HostFsSim/HostCoreFsSim.cpp File Reference

Afs/HostFsSim/HostCoreFsSim.cpp File Reference

#include <Afs/PreComp.hpp>
#include "HostCoreFsSim.hpp"
#include <Auxiliary/Macros.hpp>
#include <Auxiliary/String.hpp>
#include <Kernel/Os/Win32/Win32.hpp>
#include <ApoxiVersion.hpp>
#include <stdio.h>
#include <direct.h>
#include <sys/stat.h>
#include <time.h>
#include <fcntl.h>
#include <io.h>
#include <share.h>

Include dependency graph for HostCoreFsSim.cpp:

Defines

#define | strcat SaveStrcat
#define | strcpy SaveStrcpy

Functions

BOOLEAN | DeleteDirRecursive (const CHAR *dir_name, const CHAR *base_dir)
INT16 | FindNotUsedHandlePos ()
UINT16 | GetOpenFilePos (INT32 fd)
BOOLEAN | Internal_change_dir (const CHAR *path)
BOOLEAN | Internal_close (INT32 fd)
BOOLEAN | Internal_copy (const CHAR *srcFilename, const CHAR *dstFilename)
BOOLEAN | Internal_delete (const CHAR *filename)
BOOLEAN | Internal_exists (const CHAR *path)
CHAR * | Internal_filename_to_full_path (CHAR *buf, const CHAR *filename, const CHAR *device)
void | Internal_finddone (HostIterStatType *statobj)
BOOLEAN | Internal_findfirst (HostIterStatType *statobj, const CHAR *pattern, const CHAR *device_id)
BOOLEAN | Internal_findnext (HostIterStatType *statobj)
BOOLEAN | Internal_format_device (const CHAR *device)
BOOLEAN | Internal_get_attributes (const CHAR *filename, UINT16 &pattributes)
BOOLEAN | Internal_get_cwd (CHAR *path)
BOOLEAN | Internal_get_file_info (const CHAR *filename, HostFileStatType &pstat)
const CHAR * | Internal_get_test_path (const CHAR *device, CHAR *full_device_spec)
BOOLEAN | Internal_is_dir (const CHAR *path)
BOOLEAN | Internal_make_dir (const CHAR *path)
INT32 | Internal_open (const CHAR *filename, UINT16 flag, UINT16 mode)
UINT32 | Internal_read (INT32 fd, UINT8 *buffer, UINT32 count)
BOOLEAN | Internal_remove_dir (const CHAR *path)
BOOLEAN | Internal_rename (const CHAR *old_filename, const CHAR *new_filename)
UINT32 | Internal_seek (INT32 fd, INT32 offset, INT16 origin, INT16 &err_flag)
BOOLEAN | Internal_set_attributes (const CHAR *filename, UINT16 attributes)
BOOLEAN | Internal_truncate (INT32 fd, UINT32 new_size)
UINT32 | Internal_write (INT32 fd, const UINT8 *buffer, UINT32 count)
BOOLEAN | MapFindData (HostIterStatType *statobj, _finddata_t *find_data, const CHAR *device)
const CHAR * | RecordFileSpec (CHAR *buf, const CHAR *filespec)

Define Documentation

#define strcat SaveStrcat

#define strcpy SaveStrcpy

Function Documentation

BOOLEAN DeleteDirRecursive | ( | const CHAR * | dir_name,
 |  | const CHAR * | base_dir
 | ) |

INT16 FindNotUsedHandlePos ( )

UINT16 GetOpenFilePos ( INT32 fd )

BOOLEAN Internal_change_dir ( const CHAR * path )

BOOLEAN Internal_close ( INT32 fd )

BOOLEAN Internal_copy | ( | const CHAR * | srcFilename,
 |  | const CHAR * | dstFilename
 | ) |

BOOLEAN Internal_delete ( const CHAR * filename )

BOOLEAN Internal_exists ( const CHAR * path )

CHAR* Internal_filename_to_full_path | ( | CHAR * | buf,
 |  | const CHAR * | filename,
 |  | const CHAR * | device
 | ) |

void Internal_finddone ( HostIterStatType * statobj )

BOOLEAN Internal_findfirst | ( | HostIterStatType * | statobj,
 |  | const CHAR * | pattern,
 |  | const CHAR * | device_id
 | ) |

BOOLEAN Internal_findnext ( HostIterStatType * statobj )

BOOLEAN Internal_format_device ( const CHAR * device )

BOOLEAN Internal_get_attributes | ( | const CHAR * | filename,
 |  | UINT16 & | pattributes
 | ) |

BOOLEAN Internal_get_cwd ( CHAR * path )

BOOLEAN Internal_get_file_info | ( | const CHAR * | filename,
 |  | HostFileStatType & | pstat
 | ) |

const CHAR* Internal_get_test_path | ( | const CHAR * | device,
 |  | CHAR * | full_device_spec
 | ) |

BOOLEAN Internal_is_dir ( const CHAR * path )

BOOLEAN Internal_make_dir ( const CHAR * path )

INT32 Internal_open | ( | const CHAR * | filename,
 |  | UINT16 | flag,
 |  | UINT16 | mode
 | ) |

UINT32 Internal_read | ( | INT32 | fd,
 |  | UINT8 * | buffer,
 |  | UINT32 | count
 | ) |

BOOLEAN Internal_remove_dir ( const CHAR * path )

BOOLEAN Internal_rename | ( | const CHAR * | old_filename,
 |  | const CHAR * | new_filename
 | ) |

UINT32 Internal_seek | ( | INT32 | fd,
 |  | INT32 | offset,
 |  | INT16 | origin,
 |  | INT16 & | err_flag
 | ) |

BOOLEAN Internal_set_attributes | ( | const CHAR * | filename,
 |  | UINT16 | attributes
 | ) |

BOOLEAN Internal_truncate | ( | INT32 | fd,
 |  | UINT32 | new_size
 | ) |

UINT32 Internal_write | ( | INT32 | fd,
 |  | const UINT8 * | buffer,
 |  | UINT32 | count
 | ) |

BOOLEAN MapFindData | ( | HostIterStatType * | statobj,
 |  | _finddata_t * | find_data,
 |  | const CHAR * | device
 | ) |

const CHAR* RecordFileSpec | ( | CHAR * | buf,
 |  | const CHAR * | filespec
 | ) |

Generated on Tue Jan 24 16:52:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/HostFsSim/HostCoreFsSim.hpp File Reference

Afs/HostFsSim/HostCoreFsSim.hpp File Reference

#include <Kernel/Os/Win32/Win32.hpp>
#include <Kernel/Types.hpp>

Include dependency graph for HostCoreFsSim.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | DateStr
struct | HostFileStatType
struct | HostIterStatType

Defines

#define | Apoxi_HostCoreFsSim_hpp
#define | MAX_NO_OPEN_FILES 100

Functions

BOOLEAN | Internal_change_dir (const CHAR *path)
BOOLEAN | Internal_close (INT32 fd)
BOOLEAN | Internal_copy (const CHAR *srcFilename, const CHAR *dstFilename)
BOOLEAN | Internal_delete (const CHAR *filename)
BOOLEAN | Internal_exists (const CHAR *path)
CHAR * | Internal_filename_to_full_path (CHAR *buf, const CHAR *filename, const CHAR *device)
void | Internal_finddone (HostIterStatType *statobj)
BOOLEAN | Internal_findfirst (HostIterStatType *statobj, const CHAR *pattern, const CHAR *device_id)
BOOLEAN | Internal_findnext (HostIterStatType *statobj)
BOOLEAN | Internal_format_device (const CHAR *device)
BOOLEAN | Internal_get_attributes (const CHAR *filename, UINT16 &pattributes)
BOOLEAN | Internal_get_cwd (CHAR *path)
BOOLEAN | Internal_get_file_info (const CHAR *filename, HostFileStatType &pstat)
const CHAR * | Internal_get_test_path (const CHAR *device, CHAR *full_device_spec)
BOOLEAN | Internal_is_dir (const CHAR *path)
BOOLEAN | Internal_make_dir (const CHAR *path)
INT32 | Internal_open (const CHAR *filename, UINT16 flag, UINT16 mode)
UINT32 | Internal_read (INT32 fd, UINT8 *buffer, UINT32 count)
BOOLEAN | Internal_remove_dir (const CHAR *path)
BOOLEAN | Internal_rename (const CHAR *old_filename, const CHAR *new_filename)
UINT32 | Internal_seek (INT32 fd, INT32 offset, INT16 origin, INT16 &err_flag)
BOOLEAN | Internal_set_attributes (const CHAR *filename, UINT16 attributes)
BOOLEAN | Internal_truncate (INT32 fd, UINT32 new_size)
UINT32 | Internal_write (INT32 fd, const UINT8 *buffer, UINT32 count)

Define Documentation

#define Apoxi_HostCoreFsSim_hpp

#define MAX_NO_OPEN_FILES 100

Function Documentation

BOOLEAN Internal_change_dir ( const CHAR * path )

BOOLEAN Internal_close ( INT32 fd )

BOOLEAN Internal_copy | ( | const CHAR * | srcFilename,
 |  | const CHAR * | dstFilename
 | ) |

BOOLEAN Internal_delete ( const CHAR * filename )

BOOLEAN Internal_exists ( const CHAR * path )

CHAR* Internal_filename_to_full_path | ( | CHAR * | buf,
 |  | const CHAR * | filename,
 |  | const CHAR * | device
 | ) |

void Internal_finddone ( HostIterStatType * statobj )

BOOLEAN Internal_findfirst | ( | HostIterStatType * | statobj,
 |  | const CHAR * | pattern,
 |  | const CHAR * | device_id
 | ) |

BOOLEAN Internal_findnext ( HostIterStatType * statobj )

BOOLEAN Internal_format_device ( const CHAR * device )

BOOLEAN Internal_get_attributes | ( | const CHAR * | filename,
 |  | UINT16 & | pattributes
 | ) |

BOOLEAN Internal_get_cwd ( CHAR * path )

BOOLEAN Internal_get_file_info | ( | const CHAR * | filename,
 |  | HostFileStatType & | pstat
 | ) |

const CHAR* Internal_get_test_path | ( | const CHAR * | device,
 |  | CHAR * | full_device_spec
 | ) |

BOOLEAN Internal_is_dir ( const CHAR * path )

BOOLEAN Internal_make_dir ( const CHAR * path )

INT32 Internal_open | ( | const CHAR * | filename,
 |  | UINT16 | flag,
 |  | UINT16 | mode
 | ) |

UINT32 Internal_read | ( | INT32 | fd,
 |  | UINT8 * | buffer,
 |  | UINT32 | count
 | ) |

BOOLEAN Internal_remove_dir ( const CHAR * path )

BOOLEAN Internal_rename | ( | const CHAR * | old_filename,
 |  | const CHAR * | new_filename
 | ) |

UINT32 Internal_seek | ( | INT32 | fd,
 |  | INT32 | offset,
 |  | INT16 | origin,
 |  | INT16 & | err_flag
 | ) |

BOOLEAN Internal_set_attributes | ( | const CHAR * | filename,
 |  | UINT16 | attributes
 | ) |

BOOLEAN Internal_truncate | ( | INT32 | fd,
 |  | UINT32 | new_size
 | ) |

UINT32 Internal_write | ( | INT32 | fd,
 |  | const UINT8 * | buffer,
 |  | UINT32 | count
 | ) |

Generated on Tue Jan 24 16:52:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/HostFsSim/HostCoreFsSim.hpp Source File

Afs/HostFsSim/HostCoreFsSim.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_HostCoreFsSim_hpp)
00011 #define Apoxi_HostCoreFsSim_hpp
00012
00013 #include <Kernel/Os/Win32/Win32.hpp>
00014 #include <Kernel/Types.hpp>
00015
00016 #define MAX_NO_OPEN_FILES 100
00017
00018 /* Structure for user to do recursive search for files in a selected drive */
00019 struct HostIterStatType {
00020     CHAR    fname[10];      /* Null terminated file and extension */
00021     CHAR    fext[4];
00022     UINT16  fattribute;     /* File attributes */
00023     UINT16  ftime;          /* Time & Date last modified. See date */
00024     UINT16  fdate;          /* and time handlers for getting info */
00025     UINT32  fsize;          /* File size */
00026     CHAR    path[MAX_PATH]; /* Null terminated directory path */
00027     CHAR    device_id[3];   /* device id */
00028     INT32   filehandle;
00029     CHAR    patternName[MAX_PATH];
00030     CHAR    longFileName[   MAX_PATH];
00031 };
00032
00033 /* Date stamp structure */
00034 struct DateStr {
00035     UINT16 date;            /* Current Date */
00036     UINT16 time;            /* Current time */
00037 };
00038
00039 struct HostFileStatType {
00040     UINT32   st_mode;               /* (see S_xxxx below) */
00041     UINT32   st_size;               /* file size, in bytes */
00042     DateStr st_accesstime;          /* last access (all times are the same) */
00043     DateStr st_modificationtime;    /* last modification */
00044     DateStr st_creationtime;        /* last file status change */
00045     INT16   st_deviceId;            /* (drive number, rtfs) */
00046     INT16   st_inode;               /* inode number (0) */
00047     INT16   st_nlink;               /* (always 1) */
00048     INT16   st_rdev;                /* (drive number, rtfs) */
00049     UINT16  fattribute;             /* File attributes - DOS attributes
00050                                        (non standard but useful) */
00051 };
00052
00053 INT32 Internal_open(const CHAR *filename, UINT16 flag, UINT16 mode);
00054 BOOLEAN Internal_close(INT32 fd);
00055 BOOLEAN Internal_exists(const CHAR *path);
00056
00057 UINT32 Internal_read(INT32 fd, UINT8 *buffer, UINT32 count);
00058 UINT32 Internal_write(INT32 fd, const UINT8 *buffer, UINT32 count);
00059 UINT32 Internal_seek(INT32 fd, INT32 offset, INT16 origin,
00060                     INT16 &err_flag);
00061 BOOLEAN Internal_truncate(INT32 fd, UINT32 new_size);
00062
00063 BOOLEAN Internal_rename(const CHAR *old_filename, const CHAR *new_filename);
00064 BOOLEAN Internal_delete(const CHAR *filename);
00065 BOOLEAN Internal_copy(const CHAR *srcFilename, const CHAR *dstFilename);
00066
00067 BOOLEAN Internal_get_attributes(const CHAR *filename, UINT16 &pattributes);
00068 BOOLEAN Internal_set_attributes(const CHAR *filename, UINT16 attributes);
00069 BOOLEAN Internal_get_file_info(const CHAR *filename, HostFileStatType &pstat);
00070
00071 BOOLEAN Internal_is_dir(const CHAR *path);
00072 BOOLEAN Internal_make_dir(const CHAR *path);
00073 BOOLEAN Internal_change_dir(const CHAR *path);
00074 BOOLEAN Internal_remove_dir(const CHAR *path);
00075 BOOLEAN Internal_get_cwd(CHAR *path);
00076
00077 BOOLEAN Internal_findfirst(HostIterStatType *statobj, const CHAR *pattern,
00078                         const CHAR *device_id);
00079 BOOLEAN Internal_findnext(HostIterStatType *statobj);
00080 void Internal_finddone(HostIterStatType *statobj);
00081
00082 BOOLEAN Internal_format_device(const CHAR *device);
00083
00084 const CHAR* Internal_get_test_path(const CHAR *device, CHAR *full_device_spec);
00085 CHAR* Internal_filename_to_full_path(CHAR *buf, const CHAR *filename,
00086                                      const CHAR *device);
00087
00088 #endif  // Apoxi_HostCoreFsSim_hpp
00089
Generated on Tue Jan 24 14:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/DirectoryIterator.cpp File Reference

Afs/Rfs/DirectoryIterator.cpp File Reference

#include <Afs/PreComp.hpp>
#include "DirectoryIterator.hpp"
#include "FileFilter.hpp"

Include dependency graph for DirectoryIterator.cpp:

Generated on Tue Jan 24 16:53:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/DirectoryIterator.hpp File Reference

Afs/Rfs/DirectoryIterator.hpp File Reference

#include <Afs/Rfs/Path.hpp>
#include <Afs/Rfs/File.hpp>

Include dependency graph for DirectoryIterator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DirectoryIterator
Client interface and base class for directory iterators. More...

Defines

#define | Apoxi_DirectoryIterator_hpp

Define Documentation

#define Apoxi_DirectoryIterator_hpp

Generated on Tue Jan 24 14:53:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/DirectoryIterator.hpp Source File

Afs/Rfs/DirectoryIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DirectoryIterator_hpp)
00011 #define Apoxi_DirectoryIterator_hpp
00014
00015 #include <Afs/Rfs/Path.hpp>
00016 #include <Afs/Rfs/File.hpp>
00017
00099 class DirectoryIterator
00100 {
00101     public:
00103         virtual ~DirectoryIterator();
00104
00114         BOOLEAN IsValid() const;
00115
00117         virtual File::Error GetLastError() const;
00118
00123         virtual const Pathname& GetPathname() const;
00124
00129         virtual const Path& GetPath() const;
00130
00136         virtual void Increment();
00137
00138     protected:
00154         explicit DirectoryIterator(const Pathname &dir_pathname,
00155             const FileFilterPtr &filter, const WString &device_Id);
00156
00164         void ApplyInitialFilter();
00165
00175         virtual DirectoryIterator& AtomicIncrement() = 0;
00176
00177     protected:
00179         const Pathname m_dir_pathname;
00180
00183         Path m_cur_path;
00184
00186         FileFilterPtr m_filter;
00187
00188         mutable File::Error m_last_error;
00189 };
00190
00192 #endif  // Apoxi_DirectoryIterator_hpp
00193
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/File.cpp File Reference

Afs/Rfs/File.cpp File Reference

#include <Afs/PreComp.hpp>
#include "File.hpp"
#include "Pathname.hpp"
#include "RootFileSystem.hpp"
#include "StorageDevice.hpp"
#include "FileVisitor.hpp"
#include "DirectoryIterator.hpp"
#include "FileFilter.hpp"
#include "FileChunkOperator.hpp"

Include dependency graph for File.cpp:

Defines

#define | RFS_CHUNK_ATOM_SIZE 4096

Functions

void | StreamingCallback (File::Error result, UINT32 bytes_operated)

Define Documentation

#define RFS_CHUNK_ATOM_SIZE 4096

Function Documentation

void StreamingCallback | ( | File::Error | result,
 |  | UINT32 | bytes_operated
 | ) |

Generated on Tue Jan 24 16:53:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/File.hpp File Reference

Afs/Rfs/File.hpp File Reference

#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Auxiliary/BitVector.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>

Include dependency graph for File.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | File
Client interface and base class for files. More...
class | File::Attributes
struct | File::FileState
Structure holding the state of the file. More...

Defines

#define | Apoxi_File_hpp

Define Documentation

#define Apoxi_File_hpp

Generated on Tue Jan 24 14:53:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/File.hpp Source File

Afs/Rfs/File.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_File_hpp)
00011 #define Apoxi_File_hpp
00014
00015 #include <Afs/Rfs/RootFileSystem.hpp>
00016 #include <Afs/Rfs/Path.hpp>
00017 #include <Auxiliary/BitVector.hpp>
00018 #include <Auxiliary/Date.hpp>
00019 #include <Auxiliary/Time.hpp>
00020
00021 class FileVisitor;
00022 class FileChunkOperator;
00023
00146 class File
00147 {
00148     public:
00150         enum Error {
00151             NoError,
00152             OperationFailedError,
00153             AccessDeniedError,
00154             AlreadyOpenError,
00155             OpeningError,
00156             OperationNotAllowedError,
00157             OperationCancelledError,
00158             NotOpenError,
00159             NotFoundError,
00160             AlreadyExistsError,
00161             InitializingError,
00162             IllegalModeError,
00163             RangeError,
00164             WriteError,
00165             BadFileError,
00166             SharingError,
00167             DeviceError,
00168             FatalError,
00169             MemoryError,
00170             TooManyFilesError,
00171             OutOfMemoryError,
00172             InvalidFileNameError,
00173             InternalError,
00174             TempFileCreationError,
00175             IllegalIdError,
00176             IllegalTypeError,
00177             IllegalUserIdError,
00178             StreamingError,
00179             StaticFileError,
00180             InconsistentMemTablesError,
00181             NoFactoryDefaultFileError,
00182             MemNotAvailableError,
00183             BadFormatError,
00184             IOError,
00185             UnknownError,
00186
00187             // Error codes specific for directory operations.
00188             IllegalDirOperationError,
00189             DirSpaceNotAvailableError,
00190
00191             EndOfDirectoryError,
00192
00193             // Error codes specific for files on removable medias.
00194             NoMediaError,
00195             BadMediaError,
00196             ChangedMediaError,
00197             MediaFailureError,
00198             EccError
00199         };
00200
00202         enum OpenMode {
00203             ReadOnlyMode,
00204             ReadAndWriteMode
00205         };
00206
00210         enum SeekOrigin {
00211             SeekSet,
00212             SeekCur,
00213             SeekEnd
00214         };
00215
00216         enum {
00219             c_copy_buf_size = 10 * 1024 // 10 KB.
00220         };
00221
00227         class Attributes {
00228         public:
00231             enum Type {
00232                 Directory = 0,
00233                 ReadOnly,
00234                 Hidden,
00235                 Size,
00236                 CreationDate,
00237                 CreationTime,
00238                 ModificationDate,
00239                 ModificationTime,
00240                 AccessDate,
00241                 AccessTime,
00242                 Archive
00243             };
00244
00245         private:
00246             // Enumeration to control all BOOLEAN attribute values in one bit
00247             // vector.
00248             enum BoolAttrib {
00249                 BoolDirectory = 0,
00250                 BoolReadOnly,
00251                 BoolHidden,
00252                 BoolArchive
00253             };
00254
00255             // Tells whether an attribute is defined.
00256             BitVector<Archive + 1> m_defined;
00257
00258             // Stores all BOOLEAN attribute values in one bit vector.
00259             BitVector<BoolArchive + 1> m_bool_attribs;
00260
00261             // All non-BOOLEAN attribute values.
00262             UINT32 m_size;
00263             Date m_creation_date;
00264             Time m_creation_time;
00265             Date m_modification_date;
00266             Time m_modification_time;
00267             Date m_access_date;
00268             Time m_access_time;
00269
00270         public:
00276             BOOLEAN IsDefined(Type attribute) const {
00277                 return m_defined.GetBit(attribute);
00278             }
00279
00282             BOOLEAN IsDirectory() const {
00283                 ASSERT_DEBUG(IsDefined(Directory));
00284                 return m_bool_attribs.GetBit(BoolDirectory);
00285             }
00286
00289             BOOLEAN IsReadOnly() const {
00290                 ASSERT_DEBUG(IsDefined(ReadOnly));
00291                 return m_bool_attribs.GetBit(BoolReadOnly);
00292             }
00293
00296             BOOLEAN IsHidden() const {
00297                 ASSERT_DEBUG(IsDefined(Hidden));
00298                 return m_bool_attribs.GetBit(BoolHidden);
00299             }
00300
00303             BOOLEAN IsArchive() const {
00304                 ASSERT_DEBUG(IsDefined(Archive));
00305                 return m_bool_attribs.GetBit(BoolArchive);
00306             }
00307
00310             UINT32 GetSize() const {
00311                 ASSERT_DEBUG(IsDefined(Size));
00312                 return m_size;
00313             }
00314
00317             Date GetCreationDate() const {
00318                 ASSERT_DEBUG(IsDefined(CreationDate));
00319                 return m_creation_date;
00320             }
00321
00324             Time GetCreationTime() const {
00325                 ASSERT_DEBUG(IsDefined(CreationTime));
00326                 return m_creation_time;
00327             }
00328
00331             Date GetModificationDate() const {
00332                 ASSERT_DEBUG(IsDefined(ModificationDate));
00333                 return m_modification_date;
00334             }
00335
00338             Time GetModificationTime() const {
00339                 ASSERT_DEBUG(IsDefined(ModificationTime));
00340                 return m_modification_time;
00341             }
00342
00345             Date GetAccessDate() const {
00346                 ASSERT_DEBUG(IsDefined(AccessDate));
00347                 return m_access_date;
00348             }
00349
00352             Time GetAccessTime() const {
00353                 ASSERT_DEBUG(IsDefined(AccessTime));
00354                 return m_access_time;
00355             }
00356
00358             void SetDirectory(BOOLEAN status = TRUE) {
00359                 m_defined.SetBit(Directory);
00360                 m_bool_attribs.SetBit(BoolDirectory, status);
00361             }
00362
00364             void SetReadOnly(BOOLEAN status = TRUE) {
00365                 m_defined.SetBit(ReadOnly);
00366                 m_bool_attribs.SetBit(BoolReadOnly, status);
00367             }
00368
00370             void SetHidden(BOOLEAN status = TRUE) {
00371                 m_defined.SetBit(Hidden);
00372                 m_bool_attribs.SetBit(BoolHidden, status);
00373             }
00374
00376             void SetArchive(BOOLEAN status = TRUE) {
00377                 m_defined.SetBit(Archive);
00378                 m_bool_attribs.SetBit(BoolArchive, status);
00379             }
00380
00382             void SetSize(UINT32 size) {
00383                 m_defined.SetBit(Size);
00384                 m_size = size;
00385             }
00386
00388             void SetCreationDate(const Date &date) {
00389                 m_defined.SetBit(CreationDate);
00390                 m_creation_date = date;
00391             }
00392
00394             void SetCreationTime(const Time &time) {
00395                 m_defined.SetBit(CreationTime);
00396                 m_creation_time = time;
00397             }
00398
00400             void SetModificationDate(const Date &date) {
00401                 m_defined.SetBit(ModificationDate);
00402                 m_modification_date = date;
00403             }
00404
00406             void SetModificationTime(const Time &time) {
00407                 m_defined.SetBit(ModificationTime);
00408                 m_modification_time = time;
00409             }
00410
00412             void SetAccessDate(const Date &date) {
00413                 m_defined.SetBit(AccessDate);
00414                 m_access_date = date;
00415             }
00416
00418             void SetAccessTime(const Time &time) {
00419                 m_defined.SetBit(AccessTime);
00420                 m_access_time = time;
00421             }
00422         };
00423
00424 #if !defined(_MSC_VER) || (defined(_MSC_VER) && (_MSC_VER >= 1300))
00425     // VC6 compiler has a problem with this protected keyword.
00426     protected:
00427 #endif
00428
00429         struct FileState {
00431             OpenMode m_open_mode;
00433             BOOLEAN m_temporary;
00436             UINT32 m_cur_file_pos;
00441             UINT8 m_chunk_size;
00444             BOOLEAN m_send_progress_messages;
00447             FileChunkOperator *m_chunk_operator;
00449             mutable Error m_last_error;
00450
00451             FileState() :
00452                 m_open_mode(ReadOnlyMode),
00453                 m_temporary(FALSE),
00454                 m_cur_file_pos(0),
00455                 m_chunk_size(0),
00456                 m_send_progress_messages(FALSE),
00457                 m_chunk_operator(0),
00458                 m_last_error(NoError)
00459             {}
00460         };
00461
00462     protected:
00468         File(const Pathname &pathname, const WString &device_Id);
00469
00470     public:
00472             typedef void (*StreamingCallback)(File::Error result, UINT32 bytes_operated);
00473
00474
00480         virtual ~File();
00481
00502         virtual BOOLEAN Open(OpenMode open_mode) = 0;
00503
00514         virtual BOOLEAN OpenStreaming(OpenMode open_mode) = 0;
00515
00517         BOOLEAN IsOpenInMode(OpenMode open_mode) const;
00518
00520         virtual BOOLEAN IsOpen() const = 0;
00521
00529         virtual BOOLEAN Close() = 0;
00530
00550         virtual BOOLEAN Create(UINT32 size) = 0;
00551
00564         virtual BOOLEAN CreateStreaming() = 0;
00565
00575         virtual BOOLEAN CreateDir() = 0;
00576
00594         virtual BOOLEAN Resize(UINT32 new_size,
00595             UINT32 copy_buf_size = c_copy_buf_size);
00596
00605         virtual BOOLEAN Delete() = 0;
00606
00616         virtual BOOLEAN Move(const Pathname &dest_pathname);
00617
00635         BOOLEAN Copy(const Path &dest_path,
00636             UINT32 copy_buf_size = c_copy_buf_size);
00637
00659         virtual BOOLEAN Copy(const Pathname &dest_pathname,
00660             const WString &dest_device_Id = L"rfs",
00661             UINT32 copy_buf_size = c_copy_buf_size);
00662
00685         virtual BOOLEAN Split(UINT32 offset, const Pathname &new_file,
00686             UINT32 copy_buf_size = c_copy_buf_size);
00687
00707         virtual BOOLEAN Rename(const WString &new_name) = 0;
00708
00713         BOOLEAN Exists() const;
00714
00719         virtual BOOLEAN SetReadOnly(BOOLEAN read_only) = 0;
00720
00723         virtual BOOLEAN IsReadOnly() const = 0;
00724
00728         virtual BOOLEAN SetHidden(BOOLEAN hidden) = 0;
00729
00732         virtual BOOLEAN IsHidden() const = 0;
00733
00737         virtual BOOLEAN SetArchive(BOOLEAN archive) = 0;
00738
00741         virtual BOOLEAN IsArchive() const = 0;
00742
00748         BOOLEAN IsDirectory() const;
00749
00751         const Pathname& GetPathname() const;
00752
00754         const Path& GetPath() const;
00755
00762         virtual BOOLEAN GetSize(UINT32 &size) const = 0;
00763
00765         WString GetName() const;
00766
00775         virtual BOOLEAN GetAttributes(Attributes &attributes) const
00776             { return FALSE; }
00777
00783         virtual BOOLEAN GetCreationDate(Date &date) const = 0;
00784
00791         virtual BOOLEAN GetModificationDate(Date &date) const = 0;
00792
00800         virtual BOOLEAN GetAccessDate(Date &date) const
00801         {
00802             MyState().m_last_error = OperationNotAllowedError;
00803             return FALSE;
00804         }
00805
00825         BOOLEAN Seek(INT32 offset, SeekOrigin origin);
00826
00829         UINT32 Tell();
00830
00845         BOOLEAN ReadCur(void HUGE *buffer, UINT32 count);
00846
00899         BOOLEAN ReadCur(void HUGE *buffer, UINT32 max_count,
00900             UINT32 &bytes_read);
00901
00917         BOOLEAN WriteCur(const void HUGE *buffer, UINT32 count);
00919
00941         BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 count);
00942
01001         BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 max_count,
01002             UINT32 &bytes_read);
01003
01009         BOOLEAN ReadStreaming(void HUGE *buffer, UINT32 count,
01010             UINT32 &bytes_read);
01011
01018         BOOLEAN ReadStreamingAsync(void HUGE *buffer, UINT32 count,
01019             StreamingCallback);
01020
01038         BOOLEAN Write(const void HUGE *buffer, UINT32 offset, UINT32 count);
01039
01045         BOOLEAN WriteStreaming(const void HUGE *buffer, UINT32 count);
01046
01053         BOOLEAN WriteStreamingAsync(const void HUGE *buffer, UINT32 count,
01054             StreamingCallback callback_func);
01056
01069         BOOLEAN Accept(FileVisitor &visitor);
01070
01072         BOOLEAN IsTemporary() const
01073             { return MyState().m_temporary; }
01074
01077         void MakePermanent();
01078
01081         virtual const WString& GetStorageDeviceId() const = 0;
01082
01084         const StorageDevicePtr GetStorageDevice() const;
01085
01088         WString GetNativeFilePathname() const;
01089
01093         WString GetNativeDirectoryPathname() const;
01094
01107         UINT8 GetChunkSize() const;
01108
01121         void SetChunkSize(UINT8 size, BOOLEAN send_progress_messages = FALSE);
01122
01134         BOOLEAN CancelOperation();
01135
01137         Error GetLastError() const;
01138
01157         virtual BOOLEAN SetNativeProperty(UINT prop_Id, const void *val)
01158             { return FALSE; }
01159
01179         virtual BOOLEAN GetNativeProperty(UINT prop_Id, void *val) const
01180             { return FALSE; }
01181
01182     protected:
01183         friend class FileChunkOperator;
01184
01186         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset, UINT32 count)
01187             = 0;
01188
01191         virtual BOOLEAN DoRead(void HUGE *buffer, UINT32 offset,
01192             UINT32 max_count, UINT32 &bytes_read) = 0;
01193
01195         virtual BOOLEAN DoWrite(const void HUGE *buffer, UINT32 offset,
01196             UINT32 count) = 0;
01197
01199         virtual BOOLEAN DoReadStreaming(void HUGE *buffer, UINT32 count,
01200             UINT32 &bytes_read) = 0;
01201
01203         virtual BOOLEAN DoReadStreamingAsync(void HUGE *buffer, UINT32 count,
01204             StreamingCallback) = 0;
01205
01207         virtual BOOLEAN DoWriteStreaming(const void HUGE *buffer, UINT32 count) = 0;
01208
01210         virtual BOOLEAN DoWriteStreamingAsync(const void HUGE *buffer, UINT32 count,
01211             StreamingCallback) = 0;
01212
01226         BOOLEAN CopyContentsTo(const FilePtr &dest_file, UINT32 copy_buf_size);
01227
01229         void SetTemporary();
01230
01232         virtual FileState& MyState() = 0;
01233
01235         virtual const FileState& MyState() const = 0;
01236
01242         BOOLEAN PrepareRename(const WString &new_name, String &new_native_name)
01243             const;
01244
01245         friend class RootFileSystem;
01246         friend class RootFileImp;
01247
01248     private:
01250         Path m_path;
01251 };
01252
01254 #endif  // Apoxi_File_hpp
01255
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileBinData.cpp File Reference

Afs/Rfs/FileBinData.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FileBinData.hpp"
#include "File.hpp"

Include dependency graph for FileBinData.cpp:

Generated on Tue Jan 24 16:53:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileBinData.hpp File Reference

Afs/Rfs/FileBinData.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for FileBinData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileBinData

Defines

#define | Apoxi_FileBinData_hpp

Typedefs

typedef NiSharedPtr< File > | FilePtr
Smart-pointer controlling a File object.

Define Documentation

#define Apoxi_FileBinData_hpp

Generated on Tue Jan 24 14:53:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileBinData.hpp Source File

Afs/Rfs/FileBinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileBinData_hpp)
00011 #define Apoxi_FileBinData_hpp
00014
00015 #include <Auxiliary/BinData.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017
00018 class Path;
00019 class File;
00020
00022 typedef NiSharedPtr<File> FilePtr;
00023
00026 class FileBinData : public BinData
00027 {
00028     typedef BinData Base;
00029
00030     public:
00041         static FileBinData* CreateInstance(const Path &file_path);
00042
00053         static FileBinData* CreateInstance(const FilePtr &file);
00054
00055         virtual BOOLEAN Read(UINT32 idx, UINT8& val) const;
00056         virtual UINT32 Read(UINT32 idx, void *buf, UINT32 nbytes) const;
00057         virtual UINT32 GetLength() const;
00058         virtual BinData* Clone() const;
00059         virtual MemMap* ObtainMemMap(UINT32 idx, UINT32 size) const;
00060         virtual void ReleaseMemMap(MemMap** h_map) const;
00061
00062     protected:
00063         FileBinData();
00064         virtual ~FileBinData();
00065
00067         FilePtr m_file;
00068 };
00069
00071 #endif  // Apoxi_FileBinData_hpp
00072
Generated on Tue Jan 24 14:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileChunkOperator.cpp File Reference

Afs/Rfs/FileChunkOperator.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/MsgTypes.hpp>
#include "FileChunkOperator.hpp"
#include "File.hpp"
#include "RfsMsgTypes.hpp"

Include dependency graph for FileChunkOperator.cpp:

Generated on Tue Jan 24 16:53:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileChunkOperator.hpp File Reference

Afs/Rfs/FileChunkOperator.hpp File Reference

#include <Kernel/Condition.hpp>

Include dependency graph for FileChunkOperator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileChunkOperator

Defines

#define | Apoxi_FileChunkOperator_hpp

Define Documentation

#define Apoxi_FileChunkOperator_hpp

Generated on Tue Jan 24 14:53:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileChunkOperator.hpp Source File

Afs/Rfs/FileChunkOperator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileChunkOperator_hpp)
00011 #define Apoxi_FileChunkOperator_hpp
00014
00015 #include <Kernel/Condition.hpp>
00016
00017 class File;
00018
00019 class FileChunkOperator
00020 {
00021     public:
00022         enum Operation {
00023             ReadOffsetExact,
00024             ReadOffsetMax,
00025             WriteOffsetExact
00026         };
00027
00028     public:
00029         FileChunkOperator(File &file, UINT32 chunk_size,
00030             BOOLEAN send_progress_messages);
00031
00032         BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 count);
00033         BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 max_count,
00034             UINT32 &bytes_read);
00035         BOOLEAN Write(const void HUGE *buffer, UINT32 offset, UINT32 count);
00036
00037         BOOLEAN Cancel();
00038
00039     private:
00040         BOOLEAN Operate();
00041
00042         static void OperateNextChunkCb(void *arg);
00043         void OperateNextChunk();
00044
00045         void SendProgressMsg() const;
00046         inline UINT CalcProgress() const;
00047
00048     private:
00049         File &m_file;
00050         const UINT32 m_chunk_size;
00051         const BOOLEAN m_send_progress_messages;
00052
00053         void HUGE *m_read_buffer;
00054         const void HUGE *m_write_buffer;
00055         BOOLEAN m_cancelled;
00056
00057         Operation m_operation;
00058         UINT32 m_offset;
00059         UINT32 m_count;
00060         UINT32 m_bytes_operated;
00061
00062         BooleanCondition m_chunk_cond;
00063 };
00064
00066 #endif  // Apoxi_FileChunkOperator_hpp
00067
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileDataSink.cpp File Reference

Afs/Rfs/FileDataSink.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FileDataSink.hpp"
#include "File.hpp"

Include dependency graph for FileDataSink.cpp:

Generated on Tue Jan 24 16:53:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileDataSink.hpp File Reference

Afs/Rfs/FileDataSink.hpp File Reference

#include <Auxiliary/DataSink.hpp>

Include dependency graph for FileDataSink.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileDataSink

Defines

#define | Apoxi_FileDataSink_hpp

Typedefs

typedef NiSharedPtr< FileDataSink > | FileDataSinkPtr
Smart-pointer controlling a FileDataSink object.
typedef NiSharedPtr< File > | FilePtr
Smart-pointer controlling a File object.

Define Documentation

#define Apoxi_FileDataSink_hpp

Generated on Tue Jan 24 14:53:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileDataSink.hpp Source File

Afs/Rfs/FileDataSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileDataSink_hpp)
00011 #define Apoxi_FileDataSink_hpp
00014
00015 #include <Auxiliary/DataSink.hpp>
00016
00017 class Path;
00018 class File;
00019 class FileDataSink;
00020
00022 typedef NiSharedPtr<File> FilePtr;
00024 typedef NiSharedPtr<FileDataSink> FileDataSinkPtr;
00025
00028 class FileDataSink : public DataSink
00029 {
00030     typedef DataSink Base;
00031
00032     public:
00046         FileDataSink(const Path &file_path, UINT32 initial_size = 0,
00047             BOOLEAN overwrite_existing_file = FALSE,
00048             DrmLocalId id = c_drm_invalid_local_id);
00049
00063         FileDataSink(const FilePtr &file, UINT32 initial_size = 0,
00064             BOOLEAN overwrite_existing_file = FALSE,
00065             DrmLocalId id = c_drm_invalid_local_id);
00066
00069         virtual ~FileDataSink();
00070
00078         virtual BOOLEAN Open();
00079
00080         virtual BOOLEAN Close();
00081         virtual BOOLEAN IsOpen() const;
00082         virtual UINT32 Write(const void HUGE *buf, UINT32 nbytes);
00083         virtual UINT32 Write(UINT32 offset, const void HUGE *buf, UINT32 nbytes);
00084         virtual BOOLEAN GetSize(UINT32 &size) const;
00085
00086     protected:
00087         FilePtr m_file;
00088         const UINT32 m_initial_size;
00089         const BOOLEAN m_overwrite_existing_file;
00090 };
00091
00093 #endif  // Apoxi_FileDataSink_hpp
00094
00095
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileDataSource.cpp File Reference

Afs/Rfs/FileDataSource.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FileDataSource.hpp"
#include "File.hpp"

Include dependency graph for FileDataSource.cpp:

Generated on Tue Jan 24 16:53:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileDataSource.hpp File Reference

Afs/Rfs/FileDataSource.hpp File Reference

#include <Auxiliary/DataSource.hpp>

Include dependency graph for FileDataSource.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileDataSource

Defines

#define | Apoxi_FileDataSource_hpp

Typedefs

typedef NiSharedPtr< FileDataSource > | FileDataSourcePtr
Smart-pointer controlling a FileDataSource object.
typedef NiSharedPtr< File > | FilePtr
Smart-pointer controlling a File object.

Define Documentation

#define Apoxi_FileDataSource_hpp

Generated on Tue Jan 24 14:53:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileDataSource.hpp Source File

Afs/Rfs/FileDataSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileDataSource_hpp)
00011 #define Apoxi_FileDataSource_hpp
00014
00015 #include <Auxiliary/DataSource.hpp>
00016
00017 class Path;
00018 class File;
00019 class FileDataSource;
00020
00022 typedef NiSharedPtr<File> FilePtr;
00024 typedef NiSharedPtr<FileDataSource> FileDataSourcePtr;
00025
00028 class FileDataSource : public DataSource
00029 {
00030     typedef DataSource Base;
00031
00032     public:
00043         FileDataSource(const Path &file_path,
00044             DrmLocalId id = c_drm_invalid_local_id);
00045
00056         FileDataSource(const FilePtr &file,
00057             DrmLocalId id = c_drm_invalid_local_id);
00058
00061         virtual ~FileDataSource();
00062
00066         virtual BOOLEAN Open();
00067
00068         virtual BOOLEAN Close();
00069         virtual BOOLEAN IsOpen() const;
00070         virtual BOOLEAN Read(void HUGE *buffer, UINT32 count);
00071         virtual BOOLEAN Read(void HUGE *buffer, UINT32 max_count,
00072             UINT32&bytes_read);
00073         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 count);
00074         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer,
00075             UINT32 max_count, UINT32 &bytes_read);
00076         virtual BOOLEAN GetSize(UINT32 &size) const;
00077
00078     protected:
00079         FilePtr m_file;
00080 };
00081
00083 #endif  // Apoxi_FileDataSource_hpp
00084
00085
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileFilter.cpp File Reference

Afs/Rfs/FileFilter.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FileFilter.hpp"
#include "Path.hpp"
#include <Auxiliary/WildcardStrncmp.hpp>

Include dependency graph for FileFilter.cpp:

Generated on Tue Jan 24 16:53:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileFilter.hpp File Reference

Afs/Rfs/FileFilter.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for FileFilter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileFilter
Base class for file filters. More...
class | ImageFileFilter
File filter filtering image files More...
class | NamePatternFileFilter
File filter filtering files by a name pattern More...
class | SoundFileFilter
File filter filtering sound files More...

Defines

#define | Apoxi_FileFilter_hpp

Define Documentation

#define Apoxi_FileFilter_hpp

Generated on Tue Jan 24 14:53:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileFilter.hpp Source File

Afs/Rfs/FileFilter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileFilter_hpp)
00011 #define Apoxi_FileFilter_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016 #include <Auxiliary/WString.hpp>
00017
00018 class Path;
00019
00027 class FileFilter
00028 {
00029     public:
00031         virtual ~FileFilter();
00032
00038         virtual BOOLEAN Complies(const Path &path) = 0;
00039
00040     protected:
00042         FileFilter();
00043 };
00044
00051 class NamePatternFileFilter : public FileFilter
00052 {
00053     public:
00064         NamePatternFileFilter(const WString &name_pattern,
00065             BOOLEAN case_sensitive = TRUE, BOOLEAN filter_dirs = FALSE);
00066
00074         virtual BOOLEAN Complies(const Path &path);
00075
00077         inline const WString& GetNamePattern() const
00078             { return m_name_pattern; }
00079
00080     protected:
00082         virtual ~NamePatternFileFilter();
00083
00084     protected:
00086         WString m_name_pattern;
00088         BOOLEAN m_case_sensitive;
00090         BOOLEAN m_filter_dirs;
00091 };
00092
00098 class ImageFileFilter : public FileFilter
00099 {
00100     public:
00105         ImageFileFilter(BOOLEAN filter_dirs = FALSE);
00106
00110         virtual BOOLEAN Complies(const Path &path);
00111
00112     protected:
00114         virtual ~ImageFileFilter();
00115
00117         BOOLEAN m_filter_dirs;
00118 };
00119
00125 class SoundFileFilter : public FileFilter
00126 {
00127     public:
00132         SoundFileFilter(BOOLEAN filter_dirs = FALSE);
00133
00137         virtual BOOLEAN Complies(const Path &path);
00138
00139     protected:
00141         virtual ~SoundFileFilter();
00142
00144         BOOLEAN m_filter_dirs;
00145 };
00146
00148 #endif  // Apoxi_FileFilter_hpp
00149
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileVisitor.cpp File Reference

Afs/Rfs/FileVisitor.cpp File Reference

#include <Afs/PreComp.hpp>
#include "FileVisitor.hpp"
#include "FileFilter.hpp"

Include dependency graph for FileVisitor.cpp:

Generated on Tue Jan 24 16:53:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileVisitor.hpp File Reference

Afs/Rfs/FileVisitor.hpp File Reference

#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for FileVisitor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileVisitor
Base class for file visitors. More...

Defines

#define | Apoxi_FileVisitor_hpp

Typedefs

typedef NiSharedPtr< FileFilter > | FileFilterPtr

Define Documentation

#define Apoxi_FileVisitor_hpp

Generated on Tue Jan 24 14:53:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/FileVisitor.hpp Source File

Afs/Rfs/FileVisitor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileVisitor_hpp)
00011 #define Apoxi_FileVisitor_hpp
00014
00015 #include <Auxiliary/NiSharedPtr.hpp>
00016
00017 class Path;
00018 class FileFilter;
00019
00020 typedef NiSharedPtr<FileFilter> FileFilterPtr;
00021
00030 class FileVisitor
00031 {
00032     public:
00034         virtual ~FileVisitor();
00035
00038         virtual BOOLEAN Visit(const Path &file) = 0;
00039
00042         inline FileFilterPtr GetIteratorFilter() const
00043             { return m_filter; }
00044
00047         inline BOOLEAN VisitDirectories() const
00048             { return m_visit_directories; }
00049
00050     protected:
00059         FileVisitor(const FileFilterPtr &filter,
00060             BOOLEAN visit_directories = FALSE);
00061
00062     protected:
00064         FileFilterPtr m_filter;
00065
00066     private:
00069         BOOLEAN m_visit_directories;
00070 };
00071
00073 #endif  // Apoxi_FileVisitor_hpp
00074
00075
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/Path.cpp File Reference

Afs/Rfs/Path.cpp File Reference

#include <Afs/PreComp.hpp>
#include "Path.hpp"
#include "PathProfile.hpp"

Include dependency graph for Path.cpp:

Generated on Tue Jan 24 16:53:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/Path.hpp File Reference

Afs/Rfs/Path.hpp File Reference

#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/Pathname.hpp>

Include dependency graph for Path.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Path
Path identifying a file throughout the system. More...

Defines

#define | Apoxi_Path_hpp

Define Documentation

#define Apoxi_Path_hpp

Generated on Tue Jan 24 14:56:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/Path.hpp Source File

Afs/Rfs/Path.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Path_hpp)
00011 #define Apoxi_Path_hpp
00014
00015 #include <Afs/Rfs/RootFileSystem.hpp>
00016 #include <Afs/Rfs/Pathname.hpp>
00017
00018 class PathProfile;
00019
00026 class Path
00027 {
00028 public:
00031     Path();
00032
00038     explicit Path(const Pathname &pathname, const WString &device_Id = L"rfs");
00039
00043     Path(const PathProfile &profile);
00044
00046     ~Path();
00047
00049     const WString& GetStorageDeviceId() const
00050         { return m_storage_device_Id; }
00051
00053     const Pathname& GetPathname() const
00054         { return m_pathname; }
00055
00057     Pathname& GetPathname()
00058         { return m_pathname; }
00059
00061     MimeType GetMimeType() const
00062         { return m_pathname.GetMimeType(); }
00063
00067     void WriteTo(PathProfile &profile) const;
00068
00072     void ReadFrom(const PathProfile &profile);
00073
00075     BOOLEAN operator==(const Path &rhs) const;
00076
00077 private:
00078     WString m_storage_device_Id;
00079     Pathname m_pathname;
00080 };
00081
00083 #endif  // Apoxi_Path_hpp
00084
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/Pathname.cpp File Reference

Afs/Rfs/Pathname.cpp File Reference

#include <Afs/PreComp.hpp>
#include "Pathname.hpp"
#include "PathProfile.hpp"

Include dependency graph for Pathname.cpp:

Generated on Tue Jan 24 16:53:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/Pathname.hpp File Reference

Afs/Rfs/Pathname.hpp File Reference

#include <Afs/Rfs/RfsConfig.hpp>
#include <Auxiliary/MimeTypeTable.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for Pathname.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Pathname
Pathname identifying a file relative to a storage device. More...
class | Pathname::Iterator
Iterates over segments of a pathname. More...
class | Pathname::ReverseIterator
Iterates over segments of a pathname in reverse order. More...

Defines

#define | Apoxi_Pathname_hpp

Define Documentation

#define Apoxi_Pathname_hpp

Generated on Tue Jan 24 14:56:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/Pathname.hpp Source File

Afs/Rfs/Pathname.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Pathname_hpp)
00011 #define Apoxi_Pathname_hpp
00014
00015 #include <Afs/Rfs/RfsConfig.hpp>
00016 #include <Auxiliary/MimeTypeTable.hpp>
00017 #include <Auxiliary/WString.hpp>
00018
00119 class Pathname
00120 {
00121     public:
00123         static const WCHAR s_separator;
00125         static const WCHAR s_extension_separator;
00127         static const WCHAR s_root_pathname;
00128
00129         enum {
00137             MAX_PATHNAME_LENGTH = APOXI_MAX_PATHNAME_LENGTH
00138         };
00139
00147         class Iterator
00148         {
00149             public:
00151                 Iterator();
00152
00154                 WString operator*() const;
00155
00161                 Iterator& operator++();
00162
00170                 Iterator operator++(INT);
00171
00174                 BOOLEAN operator==(const Iterator &itor) const;
00175
00178                 BOOLEAN operator!=(const Iterator &itor) const;
00179
00182                 BOOLEAN operator<(const Iterator &itor) const;
00183
00186                 BOOLEAN operator>(const Iterator &itor) const;
00187
00188             protected:
00191                 Iterator(const WString *str, UINT pos);
00192
00193                 friend class Pathname;
00194
00195             private:
00196                 const WString *m_str_pathname;
00197                 UINT m_pos;
00198         };
00199
00207         class ReverseIterator
00208         {
00209             public:
00211                 ReverseIterator();
00212
00214                 WString operator*() const;
00215
00221                 ReverseIterator& operator++();
00222
00230                 ReverseIterator operator++(INT);
00231
00234                 BOOLEAN operator==(const ReverseIterator &itor) const;
00235
00238                 BOOLEAN operator!=(const ReverseIterator &itor) const;
00239
00242                 BOOLEAN operator<(const ReverseIterator &itor) const;
00243
00246                 BOOLEAN operator>(const ReverseIterator &itor) const;
00247
00248             protected:
00251                 ReverseIterator(const WString *str, UINT pos);
00252
00253                 friend class Pathname;
00254
00255             private:
00256                 const WString *m_str_pathname;
00257                 UINT m_pos;
00258         };
00259
00261         Pathname();
00262
00269         Pathname(const WString &str);
00270
00272         Pathname(const Pathname &pathname);
00273
00275         ~Pathname();
00276
00278         void Init(const WString &str);
00279
00281         void Reset();
00282
00303         BOOLEAN Add(const WString &str);
00304
00307         BOOLEAN Add(const Pathname &pathname);
00308
00313         BOOLEAN RemoveHead();
00314
00319         BOOLEAN RemoveLeaf();
00320
00323         WString GetHead() const;
00324
00328         WString GetLeaf() const;
00329
00342         BOOLEAN AddFileExtension(const WString &file_extension);
00343
00352         BOOLEAN AddFileExtension(MimeType type);
00353
00362         BOOLEAN SetFileExtension(const WString &file_extension);
00363
00371         BOOLEAN SetFileExtension(MimeType type);
00372
00376         BOOLEAN RemoveFileExtension();
00377
00397         WString GetFileExtension() const;
00398
00401         WString GetStrippedFileName() const;
00402
00408         MimeType GetMimeType() const;
00409
00411         UINT GetSegmentCount() const;
00412
00421         WString GetSegmentAt(UINT segment_idx) const;
00422
00431         BOOLEAN IsValid() const;
00432
00435         BOOLEAN IsRoot() const;
00436
00438         BOOLEAN HasLeaf() const;
00439
00441         BOOLEAN HasExtension() const;
00442
00444         const WString& ToWString() const;
00445
00450         BOOLEAN operator==(const Pathname &rhs) const;
00451
00456         BOOLEAN operator!=(const Pathname &rhs) const {
00457             return !operator==(rhs);
00458         }
00459
00461         static WString GetSeparator();
00462
00464         static WString GetExtensionSeparator();
00465
00466         // Iterator methods
00467
00471         Iterator Begin() const;
00472
00477         Iterator End() const;
00478
00482         ReverseIterator ReverseBegin() const;
00483
00488         ReverseIterator ReverseEnd() const;
00489
00490     protected:
00493         void RemoveTrailingSeparators();
00494
00495     private:
00496         WString m_str_pathname;
00497 };
00498
00500 #endif  // Apoxi_Pathname_hpp
00501
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/PathProfile.cpp File Reference

Afs/Rfs/PathProfile.cpp File Reference

#include <Afs/PreComp.hpp>
#include "PathProfile.hpp"

Include dependency graph for PathProfile.cpp:

Generated on Tue Jan 24 16:53:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/PathProfile.hpp File Reference

Afs/Rfs/PathProfile.hpp File Reference

#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/Path.hpp>

Include dependency graph for PathProfile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PathProfile
Utility class to persist a path. More...
struct | PathProfile::Persist
The structure to persist a path profile. More...

Defines

#define | Apoxi_PathProfile_hpp

Define Documentation

#define Apoxi_PathProfile_hpp

Generated on Tue Jan 24 14:56:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/PathProfile.hpp Source File

Afs/Rfs/PathProfile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PathProfile_hpp)
00011 #define Apoxi_PathProfile_hpp
00014
00015 #include <Afs/Rfs/RootFileSystem.hpp>
00016 #include <Afs/Rfs/Path.hpp>
00017
00051 class PathProfile
00052 {
00053     protected:
00055         struct Persist {
00057             WCHAR m_Id[RootFileSystem::MAX_STORAGE_DEVICE_ID_LENGTH];
00059             WCHAR m_sPathname[Pathname::MAX_PATHNAME_LENGTH];
00060
00062             Persist();
00063         };
00064
00065     public:
00067         PathProfile();
00068
00070         virtual ~PathProfile();
00071
00072     protected:
00074         void SetStorageDeviceId(const WString &Id);
00076         WString GetStorageDeviceId() const;
00077
00079         void SetPathname(const Pathname &pathname);
00081         Pathname GetPathname() const;
00082
00084         void SetData(const Persist &data);
00085
00087         const Persist& GetData() const;
00088
00090         friend class Path;
00091
00092     private:
00093         Persist m_data;
00094 };
00095
00097 #endif  // Apoxi_PathProfile_hpp
00098
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RfsConfig.hpp File Reference

Afs/Rfs/RfsConfig.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_MAX_NET_FILENAME_LENGTH 255
#define | APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH 3
#define | APOXI_MAX_PATHNAME_LENGTH
#define | Apoxi_RfsConfig_hpp

Define Documentation

#define Apoxi_RfsConfig_hpp

Generated on Tue Jan 24 16:53:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RfsConfig.hpp Source File

Afs/Rfs/RfsConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RfsConfig_hpp)
00011 #define Apoxi_RfsConfig_hpp
00014
00015
00020 #if !defined(APOXI_MAX_NET_FILENAME_LENGTH)
00021     #define APOXI_MAX_NET_FILENAME_LENGTH 255
00022 #endif
00023
00028 #if !defined(APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH)
00029     #define APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH 3
00030 #endif
00031
00032 /* The pathname must be big enough to hold the longest filename. If the virtual
00033    root storage device is part of the system then the pathname must be big
00034    enough to also hold the starting storage device Id string with its
00035    surrounding separators, otherwise it must only also hold the leading
00036    separator. */
00037 #if defined(APOXI_LIB_ADDON_AFSRFS)
00038
00040     #define APOXI_MAX_PATHNAME_LENGTH (                                       \
00041         1 /* The starting separator. */ +                                     \
00042         APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH /* The storage device Id. */ + \
00043         1 /* The following separator. */ +                                    \
00044         APOXI_MAX_NET_FILENAME_LENGTH + /* The filename itself. */            \
00045         1 /* The terminating \c 0 character. */                               \
00046         )
00047 #else
00048
00050     #define APOXI_MAX_PATHNAME_LENGTH (                             \
00051         1 /* The starting separator. */ +                           \
00052         APOXI_MAX_NET_FILENAME_LENGTH + /* The filename itself. */  \
00053         1 /* The terminating \c 0 character. */                     \
00054         )
00055 #endif  // APOXI_LIB_ADDON_AFSRFS
00056
00058 #endif  // Apoxi_RfsConfig_hpp
00059
Generated on Tue Jan 24 14:45:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RfsMsgTypes.cpp File Reference

Afs/Rfs/RfsMsgTypes.cpp File Reference

#include "Afs/PreComp.hpp"
#include "RfsMsgTypes.hpp"

Include dependency graph for RfsMsgTypes.cpp:

Generated on Tue Jan 24 16:53:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RfsMsgTypes.hpp File Reference

Afs/Rfs/RfsMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for RfsMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileChunkOperationProgressMsg
class | RfsMediaAvailableStatusMsg
class | RfsStorageDeviceRegistrationStatusMsg

Defines

#define | RfsMsgTypes_hpp__ST_1128347704782

Define Documentation

#define RfsMsgTypes_hpp__ST_1128347704782

Generated on Tue Jan 24 15:26:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RfsMsgTypes.hpp Source File

Afs/Rfs/RfsMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "src\koglerm_snap_apoxi_tester\lnz_apoxi\Apoxi\Afs\Rfs\RfsMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(RfsMsgTypes_hpp__ST_1128347704782)
00017 #define RfsMsgTypes_hpp__ST_1128347704782
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Auxiliary/WString.hpp>
00021
00022
00023 class File;
00024 class StorageDevice;
00025
00026 /* ----------------------------------------------------------------------
00027     Classes
00028     ---------------------------------------------------------------------- */
00029
00030 /*  ======================================================================
00031     Class FileChunkOperationProgressMsg
00032     ====================================================================== */
00033
00037 class FileChunkOperationProgressMsg : public ContextMsg {
00038     public:
00039         FileChunkOperationProgressMsg(ExecutionContext* context, const File& file, UINT progress);
00040         virtual ~FileChunkOperationProgressMsg();
00041
00042         virtual const MsgMetaData& GetMetaData() const;
00043         const File& GetFile() const { return m_file; }
00044         UINT GetProgress() const { return m_progress; }
00045         virtual Message* Clone() const;
00046
00047         enum  {
00048             ID = 16050
00049             };
00050
00051     private:
00052         static const MsgMetaData m_meta_data;
00053         const File &m_file;
00054         UINT m_progress;
00055
00056     };
00057
00058
00059 /*  ======================================================================
00060     Class RfsMediaAvailableStatusMsg
00061     ====================================================================== */
00062
00066 class RfsMediaAvailableStatusMsg : public Message {
00067     public:
00068         RfsMediaAvailableStatusMsg(const WString& storage_device_id, BOOLEAN media_present);
00069         virtual ~RfsMediaAvailableStatusMsg();
00070
00071         virtual const MsgMetaData& GetMetaData() const;
00072         const WString& GetStorageDeviceId() const { return m_storage_device_id; }
00073         BOOLEAN IsMediaPresent() const { return m_media_present; }
00074         virtual Message* Clone() const;
00075
00076         enum  {
00077             ID = 16051
00078             };
00079
00080     private:
00081         static const MsgMetaData m_meta_data;
00082         WString m_storage_device_id;
00083         BOOLEAN m_media_present;
00084
00085     };
00086
00087
00088 /*  ======================================================================
00089     Class RfsStorageDeviceRegistrationStatusMsg
00090     ====================================================================== */
00091
00094 class RfsStorageDeviceRegistrationStatusMsg : public Message {
00095     public:
00096         RfsStorageDeviceRegistrationStatusMsg(const WString& storage_device_id, BOOLEAN device_registered);
00097         virtual ~RfsStorageDeviceRegistrationStatusMsg();
00098
00099         virtual const MsgMetaData& GetMetaData() const;
00100         const WString& GetStorageDeviceId() const { return m_storage_device_id; }
00101         BOOLEAN IsDeviceRegistered() const { return m_device_registered; }
00102         virtual Message* Clone() const;
00103
00104         enum  {
00105             ID = 16052
00106             };
00107
00108     private:
00109         static const MsgMetaData m_meta_data;
00110         WString m_storage_device_id;
00111         BOOLEAN m_device_registered;
00112
00113     };
00114
00115 #endif // RfsMsgTypes_hpp__ST_1128347704782
00116
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RfsTemplates.cpp File Reference

Afs/Rfs/RfsTemplates.cpp File Reference

#include <Afs/PreComp.hpp>
#include <Afs/Rfs/StorageDevice.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Rfs/StorageDeviceIterator.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include <Afs/Rfs/StorageDeviceFilter.hpp>

Include dependency graph for RfsTemplates.cpp:

Functions

template BOOLEAN operator== (const NiSharedPtr< StorageDevice > &lhs, const NiSharedPtr< StorageDevice > &rhs)

Function Documentation

template BOOLEAN operator== | ( | const NiSharedPtr< StorageDevice > & | lhs,
 |  | const NiSharedPtr< StorageDevice > & | rhs
 | ) |

Generated on Tue Jan 24 16:53:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RootFileSystem.cpp File Reference

Afs/Rfs/RootFileSystem.cpp File Reference

#include <Afs/PreComp.hpp>
#include "RootFileSystem.hpp"
#include "StorageDevice.hpp"
#include "File.hpp"
#include "DirectoryIterator.hpp"
#include "RfsMsgTypes.hpp"
#include <Kernel/System.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/MessageRouter.hpp>
#include "Path.hpp"
#include "StorageDeviceIterator.hpp"
#include "StorageDeviceFilter.hpp"
#include "FileFilter.hpp"

Include dependency graph for RootFileSystem.cpp:

Generated on Tue Jan 24 16:53:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RootFileSystem.hpp File Reference

Afs/Rfs/RootFileSystem.hpp File Reference

#include <Afs/Rfs/RfsConfig.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for RootFileSystem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RootFileSystem
Client interface for root file system access. More...

Defines

#define | Apoxi_RootFileSystem_hpp

Typedefs

typedef NiSharedPtr< DirectoryIterator > | DirectoryIteratorPtr
Smart-pointer controlling a DirectoryIterator object.
typedef NiSharedPtr< FileFilter > | FileFilterPtr
Smart-pointer controlling a FileFilter object.
typedef NiSharedPtr< File > | FilePtr
Smart-pointer controlling a File object.
typedef NiSharedPtr< StorageDeviceFilter > | StorageDeviceFilterPtr
Smart-pointer controlling a StorageDeviceFilter object.
typedef NiSharedPtr< StorageDeviceIterator > | StorageDeviceIteratorPtr
Smart-pointer controlling a StorageDeviceIterator object.
typedef NiSharedPtr< StorageDevice > | StorageDevicePtr
Smart-pointer controlling a StorageDevice object.

Define Documentation

#define Apoxi_RootFileSystem_hpp

Generated on Tue Jan 24 15:26:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/RootFileSystem.hpp Source File

Afs/Rfs/RootFileSystem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RootFileSystem_hpp)
00011 #define Apoxi_RootFileSystem_hpp
00012
00192
00193
00194 #include <Afs/Rfs/RfsConfig.hpp>
00195 #include <Auxiliary/NiSharedPtr.hpp>
00196 #include <Auxiliary/SimpleMap.hpp>
00197 #include <Auxiliary/WString.hpp>
00198
00199 class StorageDevice;
00200 class Pathname;
00201 class File;
00202 class DirectoryIterator;
00203 class Path;
00204 class StorageDeviceIterator;
00205 class FileFilter;
00206 class StorageDeviceFilter;
00207
00209 typedef NiSharedPtr<StorageDevice> StorageDevicePtr;
00211 typedef NiSharedPtr<File> FilePtr;
00213 typedef NiSharedPtr<DirectoryIterator> DirectoryIteratorPtr;
00215 typedef NiSharedPtr<StorageDeviceIterator> StorageDeviceIteratorPtr;
00217 typedef NiSharedPtr<FileFilter> FileFilterPtr;
00219 typedef NiSharedPtr<StorageDeviceFilter> StorageDeviceFilterPtr;
00220
00276 class RootFileSystem
00277 {
00278     public:
00279         enum {
00285             MAX_STORAGE_DEVICE_ID_LENGTH =
00286                 APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH + 1
00287         };
00288
00289     public:
00300         static FilePtr GetFile(const Pathname &pathname,
00301             const WString &device_Id = L"rfs");
00302
00304         static FilePtr GetFile(const Path &path);
00305
00312         static BOOLEAN Exists(const Pathname &pathname,
00313             const WString &device_Id = L"rfs");
00314
00316         static BOOLEAN Exists(const Path &path);
00317
00324         static BOOLEAN IsDirectory(const Pathname &pathname,
00325             const WString &device_Id = L"rfs");
00326
00328         static BOOLEAN IsDirectory(const Path &path);
00329
00348         static BOOLEAN MoveFile(const Pathname &from_file_pathname,
00349             const Pathname &to_pathname,
00350             const WString &from_device_Id = L"rfs",
00351             const WString &to_device_Id = L"rfs");
00352
00355         static BOOLEAN MoveFile(const Path &from_file_path,
00356             const Path &to_path);
00357
00362         static BOOLEAN DeleteFile(const Pathname &file_pathname,
00363             const WString &device_Id = L"rfs");
00364
00366         static BOOLEAN DeleteFile(const Path &filepath);
00367
00368         //
00369         // Iterator Operations
00370         //
00371
00400         static DirectoryIteratorPtr GetDirectoryIterator(
00401             const Pathname &dir_pathname, const FileFilterPtr &filter,
00402             const WString &device_Id = L"rfs");
00403
00406         static DirectoryIteratorPtr GetDirectoryIterator(const Path &filepath,
00407             const FileFilterPtr &filter);
00408
00412         static StorageDeviceIteratorPtr GetStorageDeviceIterator(
00413             const StorageDeviceFilterPtr &filter);
00414
00415         //
00416         // Storage Device Operations
00417         //
00418
00424         static StorageDevicePtr GetStorageDevice(const WString &device_Id);
00425
00427         static UINT GetStorageDeviceCount()
00428             { return m_storage_devices.GetSize(); }
00429
00453         static FilePtr CreateTempFile(const Pathname &base_pathname,
00454             UINT32 size, const WString &device_Id = L"rfs");
00455
00457         static FilePtr CreateTempFile(const Path &base_path, UINT32 size);
00458
00459     protected:
00474         static BOOLEAN RegisterStorageDevice(StorageDevicePtr device);
00475
00481         static BOOLEAN UnregisterStorageDevice(StorageDevicePtr device);
00482
00495         static void NotifyMediaAvailableStatus(const StorageDevice &device,
00496             BOOLEAN media_present);
00497
00498         friend class StorageDevice;
00499
00500     private:
00502         RootFileSystem();
00504         ~RootFileSystem();
00505
00507         static SimpleMap<WString, StorageDevicePtr> m_storage_devices;
00508
00514         static BOOLEAN SetupPermanentStorageDevices();
00516         static BOOLEAN s_initializer_helper;
00517
00518         friend class StorageDeviceIterator;
00519 };
00520
00522 #endif  // Apoxi_RootFileSystem_hpp
00523
Generated on Tue Jan 24 14:44:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDevice.cpp File Reference

Afs/Rfs/StorageDevice.cpp File Reference

#include <Afs/PreComp.hpp>
#include "StorageDevice.hpp"
#include "Pathname.hpp"

Include dependency graph for StorageDevice.cpp:

Generated on Tue Jan 24 16:53:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDevice.hpp File Reference

Afs/Rfs/StorageDevice.hpp File Reference

#include <Auxiliary/BitVector.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/File.hpp>

Include dependency graph for StorageDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StorageDevice
Client interface and base class for storage devices. More...

Defines

#define | Apoxi_StorageDevice_hpp

Define Documentation

#define Apoxi_StorageDevice_hpp

Generated on Tue Jan 24 15:27:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDevice.hpp Source File

Afs/Rfs/StorageDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StorageDevice_hpp)
00011 #define Apoxi_StorageDevice_hpp
00014
00015 #include <Auxiliary/BitVector.hpp>
00016 #include <Afs/Rfs/RootFileSystem.hpp>
00017 #include <Afs/Rfs/File.hpp>
00018
00062 class StorageDevice
00063 {
00064     public:
00067         enum DeviceCapability {
00069             DirectorySupport = 0,
00073             Removable = 1,
00075             ReadOnly = 2,
00078             ExchangeableMedia = 3,
00081             MediaAvailableStatusNotification = 4,
00084             DEVICE_CAPABILITY_COUNT = 5
00085         };
00086
00089         enum ScanResult {
00091             ScanOk,
00092
00094             ScanNotSupported,
00095
00098             ScanProblemDetected,
00100             ScanRepairableProblemDetected,
00102             ScanNonRepairableProblemDetected,
00103
00105             ScanProblemRepaired,
00106
00108             ScanRepairFailed,
00109
00112             ScanInternalError
00113         };
00114
00115     protected:
00121         StorageDevice(const WString &device_Id, const WString &name);
00122
00123     public:
00126         virtual ~StorageDevice();
00127
00129         const WString& GetId() const
00130             { return m_device_Id; }
00131
00133         const WString& GetName() const
00134             { return m_name; }
00135
00139         virtual BOOLEAN SetMediaName(const WString &name);
00140
00144         virtual BOOLEAN GetMediaName(WString &name) const;
00145
00154         virtual BOOLEAN GetMediaAvailableStatus(BOOLEAN &media_present) const
00155             { return FALSE; }
00156
00160         virtual UINT32 GetFreeVolumeSize() const = 0;
00161
00165         virtual UINT32 GetTotalVolumeSize() const = 0;
00166
00173         virtual UINT32 GetUsedVolumeSize() const = 0;
00174
00181         virtual BOOLEAN GetSectorSize(UINT32 &size) const
00182             { return FALSE; }
00183
00190         virtual BOOLEAN GetClusterSize(UINT32 &size) const
00191             { return FALSE; }
00192
00194         virtual BOOLEAN IsReady() const = 0;
00195
00199         BOOLEAN IsCapabilitySupported(DeviceCapability device_capability)
00200             const;
00201
00211         virtual BOOLEAN IsDirectory(const Pathname &pathname) const = 0;
00212
00215         virtual BOOLEAN Exists(const Pathname &pathname) const = 0;
00216
00222         virtual BOOLEAN Flush();
00223
00228         virtual BOOLEAN Format(BOOLEAN quick = FALSE) = 0;
00229
00236         virtual ScanResult ScanDisk(BOOLEAN do_repair = FALSE)
00237             { return ScanNotSupported; }
00238
00240         virtual File::Error GetLastError() const
00241             { return m_last_error; }
00242
00245         virtual WString GetNativeFilePathname(const Pathname &pathname) const
00246             = 0;
00247
00251         virtual WString GetNativeDirectoryPathname(const Pathname &pathname)
00252             const = 0;
00253
00259         virtual UINT8 GetDefaultChunkSize() const = 0;
00260
00279         virtual BOOLEAN SetNativeProperty(UINT prop_id, const void *val)
00280             { return FALSE; }
00281
00301         virtual BOOLEAN GetNativeProperty(UINT prop_id, void *val) const
00302             { return FALSE; }
00303
00305         virtual BOOLEAN GetOpenFilesCounter(UINT &counter) const;
00306
00307     protected:
00310         static BOOLEAN Register(StorageDevicePtr device);
00311
00316         void SetDeviceCapability(DeviceCapability device_capability,
00317             BOOLEAN value);
00318
00327         virtual void OnNotifyMediaAvailableStatus(BOOLEAN media_present)
00328             { }
00329
00344         void NotifyMediaAvailableStatus(BOOLEAN media_present);
00345
00352         virtual FilePtr CreateFileObject(const Pathname &pathname) const = 0;
00353
00363         virtual DirectoryIteratorPtr CreateDirectoryIterator(
00364             const Pathname &dir_pathname, const FileFilterPtr &filter) const
00365             = 0;
00366
00374         virtual BOOLEAN Shutdown();
00375
00377         void IncrementOpenFileCounter() {
00378             ++m_open_file_counter;
00379         }
00380
00382         void DecrementOpenFileCounter() {
00383             --m_open_file_counter;
00384         }
00385
00386         friend class RootFileSystem;
00387         friend class File;
00388
00389         // The last error returned by the driver
00390         mutable File::Error m_last_error;
00391
00392     private:
00394         const WString &m_device_Id;
00396         const WString &m_name;
00397
00399         UINT m_open_file_counter;
00400
00405         BitVector<DEVICE_CAPABILITY_COUNT> m_device_capabilities;
00406 };
00407
00409 #endif  // Apoxi_StorageDevice_hpp
00410
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceFilter.cpp File Reference

Afs/Rfs/StorageDeviceFilter.cpp File Reference

#include <Afs/PreComp.hpp>
#include "StorageDeviceFilter.hpp"
#include "StorageDevice.hpp"
#include <Auxiliary/WildcardStrncmp.hpp>

Include dependency graph for StorageDeviceFilter.cpp:

Generated on Tue Jan 24 16:53:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceFilter.hpp File Reference

Afs/Rfs/StorageDeviceFilter.hpp File Reference

#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for StorageDeviceFilter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NamePatternStorageDeviceFilter
Storage device filter filtering storage devices by a name pattern. More...
class | StorageDeviceFilter
Base class for storage device filters. More...

Defines

#define | Apoxi_StorageDeviceFilter_hpp

Typedefs

typedef NiSharedPtr< StorageDevice > | StorageDevicePtr

Define Documentation

#define Apoxi_StorageDeviceFilter_hpp

Generated on Tue Jan 24 15:27:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceFilter.hpp Source File

Afs/Rfs/StorageDeviceFilter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StorageDeviceFilter_hpp)
00011 #define Apoxi_StorageDeviceFilter_hpp
00014
00015 #include <Auxiliary/NiSharedPtr.hpp>
00016 #include <Auxiliary/WString.hpp>
00017
00018 class StorageDevice;
00019 typedef NiSharedPtr<StorageDevice> StorageDevicePtr;
00020
00029 class StorageDeviceFilter
00030 {
00031     public:
00033         virtual ~StorageDeviceFilter();
00034
00040         virtual BOOLEAN Complies(const StorageDevicePtr &device) = 0;
00041
00042     protected:
00044         StorageDeviceFilter();
00045 };
00046
00053 class NamePatternStorageDeviceFilter : public StorageDeviceFilter
00054 {
00055     public:
00062         NamePatternStorageDeviceFilter(const WString &name_pattern);
00063
00070         virtual BOOLEAN Complies(const StorageDevicePtr &device);
00071
00072     protected:
00074         virtual ~NamePatternStorageDeviceFilter();
00075
00076     protected:
00078         WString m_name_pattern;
00079 };
00080
00082 #endif  // Apoxi_StorageDeviceFilter_hpp
00083
00084
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceIterator.cpp File Reference

Afs/Rfs/StorageDeviceIterator.cpp File Reference

#include <Afs/PreComp.hpp>
#include "StorageDeviceIterator.hpp"
#include "StorageDevice.hpp"
#include "StorageDeviceFilter.hpp"
#include "StorageDeviceVisitor.hpp"

Include dependency graph for StorageDeviceIterator.cpp:

Generated on Tue Jan 24 16:53:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceIterator.hpp File Reference

Afs/Rfs/StorageDeviceIterator.hpp File Reference

#include <Afs/Rfs/RootFileSystem.hpp>

Include dependency graph for StorageDeviceIterator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RootStorageDeviceIterator
Device iterator implementation for virtual root storage device. More...
class | StorageDeviceIterator
Storage device iterator. More...

Defines

#define | Apoxi_StorageDeviceIterator_hpp

Typedefs

typedef NiSharedPtr< RootStorageDeviceIterator > | RootStorageDeviceIteratorPtr
Smart-pointer controlling a RootStorageDeviceIterator object.

Define Documentation

#define Apoxi_StorageDeviceIterator_hpp

Generated on Tue Jan 24 15:27:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceIterator.hpp Source File

Afs/Rfs/StorageDeviceIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StorageDeviceIterator_hpp)
00011 #define Apoxi_StorageDeviceIterator_hpp
00014
00015 #include <Afs/Rfs/RootFileSystem.hpp>
00016
00017 class StorageDeviceVisitor;
00018 class RootStorageDeviceIterator;
00019
00021 typedef NiSharedPtr<RootStorageDeviceIterator> RootStorageDeviceIteratorPtr;
00022
00028 class StorageDeviceIterator
00029 {
00030     public:
00031         // Destroys a storage device iterator.
00032         ~StorageDeviceIterator();
00033
00040         BOOLEAN IsValid() const;
00041
00046         StorageDevicePtr GetStorageDevice() const;
00047
00053         const WString& GetStorageDeviceId() const;
00054
00060         void Increment();
00061
00074         static BOOLEAN Accept(StorageDeviceVisitor &visitor);
00075
00076     protected:
00083         explicit StorageDeviceIterator(const StorageDeviceFilterPtr &filter);
00084
00094         StorageDeviceIterator& AtomicIncrement();
00095
00096         friend class RootFileSystem;
00097
00098     protected:
00100         StorageDeviceFilterPtr m_filter;
00101
00104         SimpleMap<WString, StorageDevicePtr>::Iterator m_cur_device_id;
00105 };
00106
00107
00108
00118 class RootStorageDeviceIterator : public StorageDeviceIterator {
00119     typedef StorageDeviceIterator Base;
00120
00121     public:
00128          RootStorageDeviceIterator(const StorageDeviceFilterPtr &filter);
00129
00130         // Destroys a root storage device iterator.
00131         ~RootStorageDeviceIterator();
00132
00139         virtual BOOLEAN IsValid() const;
00140
00141     protected:
00142
00152         virtual StorageDeviceIterator& AtomicIncrement();
00153
00154         friend class RootFileSystem;
00155
00156 };
00157
00158
00160 #endif  // Apoxi_StorageDeviceIterator_hpp
00161
00162
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceVisitor.cpp File Reference

Afs/Rfs/StorageDeviceVisitor.cpp File Reference

#include <Afs/PreComp.hpp>
#include "StorageDeviceVisitor.hpp"
#include "StorageDeviceFilter.hpp"

Include dependency graph for StorageDeviceVisitor.cpp:

Generated on Tue Jan 24 16:53:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceVisitor.hpp File Reference

Afs/Rfs/StorageDeviceVisitor.hpp File Reference

#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for StorageDeviceVisitor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StorageDeviceVisitor
Base class for storage device visitors. More...

Defines

#define | Apoxi_StorageDeviceVisitor_hpp

Typedefs

typedef NiSharedPtr< StorageDeviceFilter > | StorageDeviceFilterPtr
typedef NiSharedPtr< StorageDevice > | StorageDevicePtr

Define Documentation

#define Apoxi_StorageDeviceVisitor_hpp

Generated on Tue Jan 24 15:27:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Afs/Rfs/StorageDeviceVisitor.hpp Source File

Afs/Rfs/StorageDeviceVisitor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StorageDeviceVisitor_hpp)
00011 #define Apoxi_StorageDeviceVisitor_hpp
00014
00015 #include <Auxiliary/NiSharedPtr.hpp>
00016
00017 class StorageDevice;
00018 class StorageDeviceFilter;
00019
00020 typedef NiSharedPtr<StorageDevice> StorageDevicePtr;
00021 typedef NiSharedPtr<StorageDeviceFilter> StorageDeviceFilterPtr;
00022
00033 class StorageDeviceVisitor
00034 {
00035     public:
00036         virtual ~StorageDeviceVisitor();
00037
00040         virtual BOOLEAN Visit(const StorageDevicePtr &device) = 0;
00041
00044         inline StorageDeviceFilterPtr GetIteratorFilter() const
00045             { return m_filter; }
00046
00047     protected:
00053         StorageDeviceVisitor(const StorageDeviceFilterPtr &filter);
00054
00055     protected:
00058         StorageDeviceFilterPtr m_filter;
00059 };
00060
00062 #endif  // Apoxi_StorageDeviceVisitor_hpp
00063
00064
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Accessory.hpp File Reference

Apc/Accessory.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for Accessory.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Accessory
class | HeadSet

Defines

#define | Apc_Accessory_hpp

Define Documentation

#define Apc_Accessory_hpp

Generated on Tue Jan 24 16:53:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Accessory.hpp Source File

Apc/Accessory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Accessory_hpp)
00009 #define Apc_Accessory_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 /*  ------------------------------------------------------------------------
00014     Accessory
00015     ------------------------------------------------------------------------ */
00016 class Accessory
00017 {
00018     friend class HeadSet;
00019     public:
00020         //TODO: enum-values must be hold up-to-date with acc.h!!!
00021         enum Type {
00022             None            = 0x0000,
00023             HeadSet         = 0x0001,
00024             ServicePlug     = 0x0002,
00025             AcDcAdaptor     = 0x0004,
00026             GpsModule       = 0x0008,
00027             DataCable       = 0x0010,
00028             StereoHeadSet   = 0x0020,
00029             HandsFreeCarKit = 0x0040,
00030             Unknown         = 0x7FFF
00031         };
00032
00033         Accessory(UINT16 *data = 0) {
00034             if (data != 0) {
00035                 memcpy(m_data, data, sizeof(m_data));
00036
00037                 // override type sent from driver on attaching
00038                 if ((GetType() == HeadSet) && (GetParam(1) == 0x21)) {
00039                     SetType(StereoHeadSet);
00040                 }
00041             }
00042             else {
00043                 m_data[0] = (UINT16) Unknown;
00044             }
00045         }
00046
00047         Type GetType() const { return (Type) m_data[0]; };
00048         void SetType(Type type) { m_data[0] = (UINT16) type; };
00049
00050         UINT16 GetParam(INT i) const { return ((i >= 0 && i <= 7) ? m_data[i] : 0xffff); };
00051         void SetParam(INT i, UINT16 param) { if (i >= 0 && i <= 7) m_data[i] = param; };
00052
00053     private:
00054         UINT16 m_data[8];
00055 };
00056
00057 /*  ------------------------------------------------------------------------
00058     HeadSet
00059     ------------------------------------------------------------------------ */
00060 class HeadSet {
00061     public:
00062         HeadSet(Accessory *accessory) : m_accessory(accessory) {
00063             ASSERT_ALWAYS(accessory != 0 && ((accessory->GetType() == Accessory::HeadSet) || (accessory->GetType() == Accessory::StereoHeadSet)));
00064         }
00065         void SetAttached(BOOLEAN attached) { m_accessory->m_data[1] = (BOOLEAN) attached; }
00066         BOOLEAN IsAttached() const { return (m_accessory->m_data[1] != 0); }
00067         BOOLEAN IsMono() const { return (m_accessory->GetType() == Accessory::HeadSet); }
00068     private:
00069         Accessory *m_accessory;
00070 };
00071
00072
00073 #endif  // Apc_Accessory_hpp
00074
Generated on Tue Jan 24 14:45:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ApcTemplates.cpp File Reference

Apc/ApcTemplates.cpp File Reference

#include "Apc/PreComp.hpp"
#include <Apc/SimDataTypes.hpp>
#include <Apc/Cbs.hpp>
#include <Apc/PlmnScanList.hpp>
#include <Apc/SsStackMsgArgs.hpp>

Include dependency graph for ApcTemplates.cpp:

Generated on Tue Jan 24 16:53:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ApoxiApcVersion.cpp File Reference

Apc/ApoxiApcVersion.cpp File Reference

#include "Apc/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>
#include <sys_version.h>

Include dependency graph for ApoxiApcVersion.cpp:

Functions

ApoxiDefVersionInfo (AsUmtsVersion, get_sw_version(svsAS_UMTS_VERSION), VersionInfo::c_flag_add_to_trace_info)
ApoxiDefVersionInfo (GasEgprsVersion, get_sw_version(svsGAS_EGPRS_VERSION), VersionInfo::c_flag_add_to_trace_info)
ApoxiDefVersionInfo (GasDmAddonVersion, get_sw_version(svsGAS_DM_ADDON_VERSION), VersionInfo::c_flag_add_to_trace_info)
ApoxiDefVersionInfo (DriverVersion, get_sw_version(svsDRIVER_VERSION), VersionInfo::c_flag_add_to_trace_info)
ApoxiDefVersionInfo (StackVersion, get_sw_version(svsSTACK_VERSION), VersionInfo::c_flag_add_to_trace_info)
ApoxiDefVersionInfo (StackCustVersion, get_sw_version(CUSTOMER_SW_VERSION), VersionInfo::c_flag_add_to_trace_info)
ApoxiDefVersionInfo (Apc, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | AsUmtsVersion | ,
 |  | get_sw_version(svsAS_UMTS_VERSION) | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

ApoxiDefVersionInfo | ( | GasEgprsVersion | ,
 |  | get_sw_version(svsGAS_EGPRS_VERSION) | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

ApoxiDefVersionInfo | ( | GasDmAddonVersion | ,
 |  | get_sw_version(svsGAS_DM_ADDON_VERSION) | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

ApoxiDefVersionInfo | ( | DriverVersion | ,
 |  | get_sw_version(svsDRIVER_VERSION) | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

ApoxiDefVersionInfo | ( | StackVersion | ,
 |  | get_sw_version(svsSTACK_VERSION) | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

ApoxiDefVersionInfo | ( | StackCustVersion | ,
 |  | get_sw_version(CUSTOMER_SW_VERSION) | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

ApoxiDefVersionInfo | ( | Apc | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:53:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ApoxiStartUp.hpp File Reference

Apc/ApoxiStartUp.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 16:53:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ApoxiStartUp.hpp Source File

Apc/ApoxiStartUp.hpp

Go to the documentation of this file.
Generated on Tue Jan 24 14:45:57 2006 for APOXI by

  doxygen  1.4.6-NO


APOXI: Apc/AtcStackMsgArgs.cpp File Reference

Apc/AtcStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "AtcStackMsgArgs.hpp"

Include dependency graph for AtcStackMsgArgs.cpp:

Generated on Tue Jan 24 16:53:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AtcStackMsgArgs.hpp File Reference

Apc/AtcStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Apc/AtcTypes.hpp>
#include <Apc/Accessory.hpp>
#include <Apc/SimTkTypes.hpp>
#include <Devices/Device.hpp>

Include dependency graph for AtcStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtAccessoryNotificationIndArg
class | AtAccessoryRegisterCnfArg
class | AtAccessoryRegisterReqArg
class | AtAlphaTagCnfArg
class | AtAlphaTagReqArg
class | AtGenericCmdIndArg
class | AtGenericCmdReqArg
class | AtPbInfoIndArg
class | AtPbListCnfArg
class | AtPbListReqArg
class | AtPbSelectCnfArg
class | AtPbSelectReqArg

Defines

#define | Apc_AtcStackMsgArgs_hpp

Define Documentation

#define Apc_AtcStackMsgArgs_hpp

Generated on Tue Jan 24 16:53:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AtcStackMsgArgs.hpp Source File

Apc/AtcStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "dallaros_apoxitest_dv\lnz_apoxi\Apoxi\Apc\AtcArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_AtcStackMsgArgs_hpp)
00016 #define Apc_AtcStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Apc/NetworkTypes.hpp>
00021 #include <Apc/AtcTypes.hpp>
00022 #include <Apc/Accessory.hpp>
00023 #include <Apc/SimTkTypes.hpp>
00024 #include <Devices/Device.hpp>
00025
00026
00027 /* ----------------------------------------------------------------------
00028     Classes
00029     ---------------------------------------------------------------------- */
00030
00031 /*  ======================================================================
00032     Class AtAlphaTagReqArg
00033     ====================================================================== */
00034
00036 class AtAlphaTagReqArg : public StackMsgArgument {
00037     friend class CommonStackMsgArgsDestroyTableNode;
00038     public:
00039         AtAlphaTagReqArg();
00040
00041         static const AtAlphaTagReqArg& Cast(const StackMsgArgument& arg);
00042         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00043         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00044
00045         enum  {
00046             ID = 1150
00047             };
00048
00049     private:
00050
00051         static void Destroy(StackMsgArgument* arg) { delete ((AtAlphaTagReqArg*) arg); }
00052
00053         PhoneNumber m_phone_number;
00054
00055     };
00056
00057 // Inline definitions
00058 inline const AtAlphaTagReqArg& AtAlphaTagReqArg::Cast(const StackMsgArgument& arg) {
00059     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtAlphaTagReqArg!\n");
00060     return ((AtAlphaTagReqArg &) arg);
00061 }
00062
00063
00064
00065 /*  ======================================================================
00066     Class AtPbSelectReqArg
00067     ====================================================================== */
00068
00070 class AtPbSelectReqArg : public StackMsgArgument {
00071     friend class CommonStackMsgArgsDestroyTableNode;
00072     public:
00073         AtPbSelectReqArg();
00074
00075         static const AtPbSelectReqArg& Cast(const StackMsgArgument& arg);
00076         void SetMePhoneBookType(const MePhoneBookType& me_phone_book_type) { m_me_phone_book_type = me_phone_book_type; }
00077         const MePhoneBookType& GetMePhoneBookType() const { return m_me_phone_book_type; }
00078
00079         enum  {
00080             ID = 1151
00081             };
00082
00083     private:
00084
00085         static void Destroy(StackMsgArgument* arg) { delete ((AtPbSelectReqArg*) arg); }
00086
00087         MePhoneBookType m_me_phone_book_type;
00088
00089     };
00090
00091 // Inline definitions
00092 inline const AtPbSelectReqArg& AtPbSelectReqArg::Cast(const StackMsgArgument& arg) {
00093     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtPbSelectReqArg!\n");
00094     return ((AtPbSelectReqArg &) arg);
00095 }
00096
00097
00098
00099 /*  ======================================================================
00100     Class AtPbListReqArg
00101     ====================================================================== */
00102
00104 class AtPbListReqArg : public StackMsgArgument {
00105     friend class CommonStackMsgArgsDestroyTableNode;
00106     public:
00107         AtPbListReqArg();
00108
00109         static const AtPbListReqArg& Cast(const StackMsgArgument& arg);
00110         void SetMePhoneBookType(const MePhoneBookType& me_phone_book_type) { m_me_phone_book_type = me_phone_book_type; }
00111         const MePhoneBookType& GetMePhoneBookType() const { return m_me_phone_book_type; }
00112         void SetRecordNumber(INT record_number) { m_record_number = record_number; }
00113         INT GetRecordNumber() const { return m_record_number; }
00114
00115         enum  {
00116             ID = 1152
00117             };
00118
00119     private:
00120
00121         static void Destroy(StackMsgArgument* arg) { delete ((AtPbListReqArg*) arg); }
00122
00123         MePhoneBookType m_me_phone_book_type;
00124         INT m_record_number;
00125
00126     };
00127
00128 // Inline definitions
00129 inline const AtPbListReqArg& AtPbListReqArg::Cast(const StackMsgArgument& arg) {
00130     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtPbListReqArg!\n");
00131     return ((AtPbListReqArg &) arg);
00132 }
00133
00134
00135
00136 /*  ======================================================================
00137     Class AtGenericCmdReqArg
00138     ====================================================================== */
00139
00141 class AtGenericCmdReqArg : public StackMsgArgument {
00142     friend class CommonStackMsgArgsDestroyTableNode;
00143     public:
00144         AtGenericCmdReqArg();
00145
00146         static const AtGenericCmdReqArg& Cast(const StackMsgArgument& arg);
00147         void SetCmd(const AtGenericCmdType& cmd) { m_cmd = cmd; }
00148         const AtGenericCmdType& GetCmd() const { return m_cmd; }
00149
00150         enum  {
00151             ID = 1153
00152             };
00153
00154     private:
00155
00156         static void Destroy(StackMsgArgument* arg) { delete ((AtGenericCmdReqArg*) arg); }
00157
00158         AtGenericCmdType m_cmd;
00159
00160     };
00161
00162 // Inline definitions
00163 inline const AtGenericCmdReqArg& AtGenericCmdReqArg::Cast(const StackMsgArgument& arg) {
00164     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtGenericCmdReqArg!\n");
00165     return ((AtGenericCmdReqArg &) arg);
00166 }
00167
00168
00169
00170 /*  ======================================================================
00171     Class AtAccessoryRegisterReqArg
00172     ====================================================================== */
00173
00175 class AtAccessoryRegisterReqArg : public StackMsgArgument {
00176     friend class CommonStackMsgArgsDestroyTableNode;
00177     public:
00178         AtAccessoryRegisterReqArg(BOOLEAN enabled);
00179         AtAccessoryRegisterReqArg();
00180
00181         static const AtAccessoryRegisterReqArg& Cast(const StackMsgArgument& arg);
00182         void SetEnabled(BOOLEAN enabled) { m_enabled = enabled; }
00183         BOOLEAN IsEnabled() const { return m_enabled; }
00184
00185         enum  {
00186             ID = 1154
00187             };
00188
00189     private:
00190
00191         static void Destroy(StackMsgArgument* arg) { delete ((AtAccessoryRegisterReqArg*) arg); }
00192
00193         BOOLEAN m_enabled;
00194
00195     };
00196
00197 // Inline definitions
00198 inline const AtAccessoryRegisterReqArg& AtAccessoryRegisterReqArg::Cast(const StackMsgArgument& arg) {
00199     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtAccessoryRegisterReqArg!\n");
00200     return ((AtAccessoryRegisterReqArg &) arg);
00201 }
00202
00203
00204
00205 /*  ======================================================================
00206     Class AtAlphaTagCnfArg
00207     ====================================================================== */
00208
00210 class AtAlphaTagCnfArg : public StackMsgArgument {
00211     friend class CommonStackMsgArgsDestroyTableNode;
00212     public:
00213         AtAlphaTagCnfArg(const WString& alpha_id, const PhoneNumber& phone_number);
00214         AtAlphaTagCnfArg();
00215
00216         static const AtAlphaTagCnfArg& Cast(const StackMsgArgument& arg);
00217         void SetAlphaId(const WString& alpha_id) { m_alpha_id = alpha_id; }
00218         const WString& GetAlphaId() const { return m_alpha_id; }
00219         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00220         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00221
00222         enum  {
00223             ID = 2150
00224             };
00225
00226     private:
00227
00228         static void Destroy(StackMsgArgument* arg) { delete ((AtAlphaTagCnfArg*) arg); }
00229
00230         WString m_alpha_id;
00231         PhoneNumber m_phone_number;
00232
00233     };
00234
00235 // Inline definitions
00236 inline const AtAlphaTagCnfArg& AtAlphaTagCnfArg::Cast(const StackMsgArgument& arg) {
00237     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtAlphaTagCnfArg!\n");
00238     return ((AtAlphaTagCnfArg &) arg);
00239 }
00240
00241
00242
00243 /*  ======================================================================
00244     Class AtPbSelectCnfArg
00245     ====================================================================== */
00246
00248 class AtPbSelectCnfArg : public StackMsgArgument {
00249     friend class CommonStackMsgArgsDestroyTableNode;
00250     public:
00251         AtPbSelectCnfArg(const MePhoneBookStatus& status, const MePhoneBookType& me_phone_book_type, INT used_entries, INT total_entries, INT max_alpha_length);
00252         AtPbSelectCnfArg();
00253
00254         static const AtPbSelectCnfArg& Cast(const StackMsgArgument& arg);
00255         void SetStatus(const MePhoneBookStatus& status) { m_status = status; }
00256         const MePhoneBookStatus& GetStatus() const { return m_status; }
00257         void SetMePhoneBookType(const MePhoneBookType& me_phone_book_type) { m_me_phone_book_type = me_phone_book_type; }
00258         const MePhoneBookType& GetMePhoneBookType() const { return m_me_phone_book_type; }
00259         void SetUsedEntries(INT used_entries) { m_used_entries = used_entries; }
00260         INT GetUsedEntries() const { return m_used_entries; }
00261         void SetTotalEntries(INT total_entries) { m_total_entries = total_entries; }
00262         INT GetTotalEntries() const { return m_total_entries; }
00263         void SetMaxAlphaLength(INT max_alpha_length) { m_max_alpha_length = max_alpha_length; }
00264         INT GetMaxAlphaLength() const { return m_max_alpha_length; }
00265
00266         enum  {
00267             ID = 2151
00268             };
00269
00270     private:
00271
00272         static void Destroy(StackMsgArgument* arg) { delete ((AtPbSelectCnfArg*) arg); }
00273
00274         MePhoneBookStatus m_status;
00275         MePhoneBookType m_me_phone_book_type;
00276         INT m_used_entries;
00277         INT m_total_entries;
00278         INT m_max_alpha_length;
00279
00280     };
00281
00282 // Inline definitions
00283 inline const AtPbSelectCnfArg& AtPbSelectCnfArg::Cast(const StackMsgArgument& arg) {
00284     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtPbSelectCnfArg!\n");
00285     return ((AtPbSelectCnfArg &) arg);
00286 }
00287
00288
00289
00290 /*  ======================================================================
00291     Class AtPbListCnfArg
00292     ====================================================================== */
00293
00295 class AtPbListCnfArg : public StackMsgArgument {
00296     friend class CommonStackMsgArgsDestroyTableNode;
00297     public:
00298         AtPbListCnfArg(const MePhoneBookStatus& status, const MePhoneBookType& me_phone_book_type, INT record_number, const WString& alpha_identifier, const PhoneNumber& phone_number);
00299         AtPbListCnfArg();
00300
00301         static const AtPbListCnfArg& Cast(const StackMsgArgument& arg);
00302         void SetStatus(const MePhoneBookStatus& status) { m_status = status; }
00303         const MePhoneBookStatus& GetStatus() const { return m_status; }
00304         void SetMePhoneBookType(const MePhoneBookType& me_phone_book_type) { m_me_phone_book_type = me_phone_book_type; }
00305         const MePhoneBookType& GetMePhoneBookType() const { return m_me_phone_book_type; }
00306         void SetRecordNumber(INT record_number) { m_record_number = record_number; }
00307         INT GetRecordNumber() const { return m_record_number; }
00308         void SetAlphaIdentifier(const WString& alpha_identifier) { m_alpha_identifier = alpha_identifier; }
00309         const WString& GetAlphaIdentifier() const { return m_alpha_identifier; }
00310         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00311         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00312
00313         enum  {
00314             ID = 2152
00315             };
00316
00317     private:
00318
00319         static void Destroy(StackMsgArgument* arg) { delete ((AtPbListCnfArg*) arg); }
00320
00321         MePhoneBookStatus m_status;
00322         MePhoneBookType m_me_phone_book_type;
00323         INT m_record_number;
00324         WString m_alpha_identifier;
00325         PhoneNumber m_phone_number;
00326
00327     };
00328
00329 // Inline definitions
00330 inline const AtPbListCnfArg& AtPbListCnfArg::Cast(const StackMsgArgument& arg) {
00331     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtPbListCnfArg!\n");
00332     return ((AtPbListCnfArg &) arg);
00333 }
00334
00335
00336
00337 /*  ======================================================================
00338     Class AtPbInfoIndArg
00339     ====================================================================== */
00340
00342 class AtPbInfoIndArg : public StackMsgArgument {
00343     friend class CommonStackMsgArgsDestroyTableNode;
00344     public:
00345         AtPbInfoIndArg(const MePhonebookDescription& desc);
00346         AtPbInfoIndArg();
00347
00348         static const AtPbInfoIndArg& Cast(const StackMsgArgument& arg);
00349         void SetDesc(const MePhonebookDescription& desc) { m_desc = desc; }
00350         const MePhonebookDescription& GetDesc() const { return m_desc; }
00351
00352         enum  {
00353             ID = 2153
00354             };
00355
00356     private:
00357
00358         static void Destroy(StackMsgArgument* arg) { delete ((AtPbInfoIndArg*) arg); }
00359
00360         MePhonebookDescription m_desc;
00361
00362     };
00363
00364 // Inline definitions
00365 inline const AtPbInfoIndArg& AtPbInfoIndArg::Cast(const StackMsgArgument& arg) {
00366     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtPbInfoIndArg!\n");
00367     return ((AtPbInfoIndArg &) arg);
00368 }
00369
00370
00371
00372 /*  ======================================================================
00373     Class AtGenericCmdIndArg
00374     ====================================================================== */
00375
00377 class AtGenericCmdIndArg : public StackMsgArgument {
00378     friend class CommonStackMsgArgsDestroyTableNode;
00379     public:
00380         AtGenericCmdIndArg(const AtStatusType& status, BOOLEAN final, const AtGenericCmdType& cmd);
00381         AtGenericCmdIndArg();
00382
00383         static const AtGenericCmdIndArg& Cast(const StackMsgArgument& arg);
00384         void SetStatus(const AtStatusType& status) { m_status = status; }
00385         const AtStatusType& GetStatus() const { return m_status; }
00386         void SetFinal(BOOLEAN final) { m_final = final; }
00387         BOOLEAN IsFinal() const { return m_final; }
00388         void SetCmd(const AtGenericCmdType& cmd) { m_cmd = cmd; }
00389         const AtGenericCmdType& GetCmd() const { return m_cmd; }
00390
00391         enum  {
00392             ID = 2154
00393             };
00394
00395     private:
00396
00397         static void Destroy(StackMsgArgument* arg) { delete ((AtGenericCmdIndArg*) arg); }
00398
00399         AtStatusType m_status;
00400         BOOLEAN m_final;
00401         AtGenericCmdType m_cmd;
00402
00403     };
00404
00405 // Inline definitions
00406 inline const AtGenericCmdIndArg& AtGenericCmdIndArg::Cast(const StackMsgArgument& arg) {
00407     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtGenericCmdIndArg!\n");
00408     return ((AtGenericCmdIndArg &) arg);
00409 }
00410
00411
00412
00413 /*  ======================================================================
00414     Class AtAccessoryNotificationIndArg
00415     ====================================================================== */
00416
00418 class AtAccessoryNotificationIndArg : public StackMsgArgument {
00419     friend class CommonStackMsgArgsDestroyTableNode;
00420     public:
00421         AtAccessoryNotificationIndArg(const AtGenericCmdType& cmd);
00422         AtAccessoryNotificationIndArg();
00423
00424         static const AtAccessoryNotificationIndArg& Cast(const StackMsgArgument& arg);
00425         void SetCmd(const AtGenericCmdType& cmd) { m_cmd = cmd; }
00426         const AtGenericCmdType& GetCmd() const { return m_cmd; }
00427
00428         enum  {
00429             ID = 2155
00430             };
00431
00432     private:
00433
00434         static void Destroy(StackMsgArgument* arg) { delete ((AtAccessoryNotificationIndArg*) arg); }
00435
00436         AtGenericCmdType m_cmd;
00437
00438     };
00439
00440 // Inline definitions
00441 inline const AtAccessoryNotificationIndArg& AtAccessoryNotificationIndArg::Cast(const StackMsgArgument& arg) {
00442     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtAccessoryNotificationIndArg!\n");
00443     return ((AtAccessoryNotificationIndArg &) arg);
00444 }
00445
00446
00447
00448 /*  ======================================================================
00449     Class AtAccessoryRegisterCnfArg
00450     ====================================================================== */
00451
00453 class AtAccessoryRegisterCnfArg : public StackMsgArgument {
00454     friend class CommonStackMsgArgsDestroyTableNode;
00455     public:
00456         AtAccessoryRegisterCnfArg(const AtStatusType& status);
00457         AtAccessoryRegisterCnfArg();
00458
00459         static const AtAccessoryRegisterCnfArg& Cast(const StackMsgArgument& arg);
00460         void SetStatus(const AtStatusType& status) { m_status = status; }
00461         const AtStatusType& GetStatus() const { return m_status; }
00462
00463         enum  {
00464             ID = 2156
00465             };
00466
00467     private:
00468
00469         static void Destroy(StackMsgArgument* arg) { delete ((AtAccessoryRegisterCnfArg*) arg); }
00470
00471         AtStatusType m_status;
00472
00473     };
00474
00475 // Inline definitions
00476 inline const AtAccessoryRegisterCnfArg& AtAccessoryRegisterCnfArg::Cast(const StackMsgArgument& arg) {
00477     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AtAccessoryRegisterCnfArg!\n");
00478     return ((AtAccessoryRegisterCnfArg &) arg);
00479 }
00480
00481
00482 #endif // Apc_AtcStackMsgArgs_hpp
00483
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AtcTypes.hpp File Reference

Apc/AtcTypes.hpp File Reference

#include <Apc/SignalTypes.hpp>

Include dependency graph for AtcTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtGenericCmdType
class | MePhonebookDescription
class | MePhonebookDescriptor

Defines

#define | Apc_AtcTypes_hpp

Enumerations

enum AtStatusType {
AtStatusSuccess, AtStatusSuccessNoOutput, AtStatusError, AtStatusNoCarrier,
AtStatusNoAnswer, AtStatusBusy, AtStatusCommitSignal, AtStatusUnsolicitedResult,
AtStatusSignalNotHandled, AtStatusSignalNotExpected
}
enum | MePhoneBookStatus { MePbSuccessfull, MePbUnsuccessfull, MePbNotPresent, MePbInvalidIndex }
enum MePhoneBookType {
MePhoneBook, DcPhoneBook, McPhoneBook, RcPhoneBook,
MbPhoneBook, MdPhoneBook, MsPhoneBook, RdPhoneBook,
SdPhoneBook, BdPhoneBook, CdPhoneBook, CsPhoneBook,
InvalidPhoneBook
}
ME phonebook type. More...

Variables

const INT | c_max_at_req_alpha_id_size = c_max_phonebook_entry_len-c_max_bcd_number_size
const UINT | c_max_phonebook_descriptors = 12

Define Documentation

#define Apc_AtcTypes_hpp

Enumeration Type Documentation

enum AtStatusType

Enumerator:
AtStatusSuccess
AtStatusSuccessNoOutput
AtStatusError
AtStatusNoCarrier
AtStatusNoAnswer
AtStatusBusy
AtStatusCommitSignal
AtStatusUnsolicitedResult
AtStatusSignalNotHandled
AtStatusSignalNotExpected

enum MePhoneBookStatus

Enumerator:
MePbSuccessfull
MePbUnsuccessfull
MePbNotPresent
MePbInvalidIndex

enum MePhoneBookType

ME phonebook type.

Enumerator:
MePhoneBook
DcPhoneBook
McPhoneBook
RcPhoneBook
MbPhoneBook
MdPhoneBook
MsPhoneBook
RdPhoneBook
SdPhoneBook
BdPhoneBook
CdPhoneBook
CsPhoneBook
InvalidPhoneBook

Variable Documentation

const INT c_max_at_req_alpha_id_size = c_max_phonebook_entry_len-c_max_bcd_number_size

const UINT c_max_phonebook_descriptors = 12

em>MePhonebookDescriptor is the description class which contains the type of the phonebook its total number of entries and its maximum alpha identifier length. Instances of this class have to be appended to the MePhonebookDescription object.

Generated on Tue Jan 24 16:54:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AtcTypes.hpp Source File

Apc/AtcTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_AtcTypes_hpp)
00009 #define Apc_AtcTypes_hpp
00010
00011 #include <Apc/SignalTypes.hpp>
00012
00013 /*  ========================================================================
00014                                   MePhoneBookType
00015     ========================================================================*/
00016 // T_MI_PHB_ID
00017
00019 enum MePhoneBookType {
00020 #if defined(APOXI_ENABLE_ME_PHONEBOOK_REQUEST)
00021     MePhoneBook         = MI_PHB_ME,
00022     DcPhoneBook         = MI_PHB_DC,
00023     McPhoneBook         = MI_PHB_MC,
00024     RcPhoneBook         = MI_PHB_RC,
00025     MbPhoneBook         = MI_PHB_MB,
00026     MdPhoneBook         = MI_PHB_MD,
00027     MsPhoneBook         = MI_PHB_MS,
00028     RdPhoneBook         = MI_PHB_RD,
00029     SdPhoneBook         = MI_PHB_SD,
00030     BdPhoneBook         = MI_PHB_BD,
00031     CdPhoneBook         = MI_PHB_CD,
00032     CsPhoneBook         = MI_PHB_CS,
00033     InvalidPhoneBook
00034 #else
00035     MePhoneBook,
00036     DcPhoneBook,
00037     McPhoneBook,
00038     RcPhoneBook,
00039     MbPhoneBook,
00040     MdPhoneBook,
00041     MsPhoneBook,
00042     RdPhoneBook,
00043     SdPhoneBook,
00044     BdPhoneBook,
00045     CdPhoneBook,
00046     CsPhoneBook,
00047     InvalidPhoneBook
00048 #endif
00049 };
00050
00051 // T_MI_PB_STATUS
00052 enum MePhoneBookStatus {
00053 #if defined(APOXI_ENABLE_ME_PHONEBOOK_REQUEST)
00054     MePbSuccessfull     = MI_SUCCESSFUL,
00055     MePbUnsuccessfull   = MI_UNSUCCESSFUL,
00056     MePbNotPresent      = MI_PB_NOT_PRESENT,
00057     MePbInvalidIndex    = MI_INVALID_INDEX
00058 #else
00059     MePbSuccessfull,
00060     MePbUnsuccessfull,
00061     MePbNotPresent,
00062     MePbInvalidIndex
00063 #endif
00064 };
00065
00066 #if defined(APOXI_ENABLE_ME_PHONEBOOK_REQUEST)
00067 const UINT c_max_phonebook_descriptors = MIAT_MAX_NOF_PB;
00068 #else
00069 const UINT c_max_phonebook_descriptors = 12;
00070 #endif
00071
00072
00073
00078 class MePhonebookDescriptor {
00079     public:
00081         MePhonebookDescriptor(MePhoneBookType type, INT totalentries, INT maxalphalen) :
00082                     m_type(type), m_totalentries(totalentries), m_maxalphalen(maxalphalen) {}
00084         MePhonebookDescriptor() : m_type(InvalidPhoneBook), m_totalentries(0), m_maxalphalen(0) {}
00086         MePhonebookDescriptor(const MePhonebookDescriptor & desc)
00087                : m_type(desc.m_type),
00088                  m_totalentries(desc.m_totalentries),
00089                  m_maxalphalen(desc.m_maxalphalen) {}
00091         MePhonebookDescriptor & operator = (const MePhonebookDescriptor & desc) {
00092             if(&desc!=this) {
00093                 m_type = desc.m_type;
00094                 m_totalentries = desc.m_totalentries;
00095                 m_maxalphalen = desc.m_maxalphalen;
00096             }
00097             return *this;
00098         }
00100         MePhoneBookType GetMePhoneBookType() const { return m_type; }
00102         INT GetTotalEntries() const { return m_totalentries; }
00104         INT GetMaxAlphaLen() const { return m_maxalphalen; }
00105
00106     private:
00107         MePhoneBookType m_type;
00108         INT             m_totalentries;
00109         INT             m_maxalphalen;
00110
00111
00112 };
00113
00119 class MePhonebookDescription {
00120     public:
00122         MePhonebookDescription() : m_counter(0) { }
00123
00125         MePhonebookDescription(const MePhonebookDescription & desc) : m_counter(desc.m_counter)
00126         {
00127             for(UINT i=0; i<m_counter; i++) {
00128                 m_desc[i] = desc.m_desc[i];
00129             }
00130         }
00132         MePhonebookDescription & operator = (const MePhonebookDescription & desc) {
00133             if(&desc!=this) {
00134                 m_counter = desc.m_counter;
00135                 for(UINT i=0; i<m_counter; i++) {
00136                     m_desc[i] = desc.m_desc[i];
00137                 }
00138             }
00139             return *this;
00140         }
00141
00143         BOOLEAN AppendMePhonebookDescriptor(const MePhonebookDescriptor & desc) {
00144             if(m_counter<c_max_phonebook_descriptors-1) {
00145                 m_desc[m_counter] = desc;
00146                 m_counter++;
00147                 return TRUE;
00148             }
00149             return FALSE;
00150         }
00152         const MePhonebookDescriptor & Get(INT idx) const {
00153             ASSERT_DEBUG(idx<c_max_phonebook_descriptors);
00154             return m_desc[m_counter];
00155         }
00157         UINT GetCount() const { return m_counter; }
00158
00159     private:
00160         MePhonebookDescriptor m_desc[c_max_phonebook_descriptors];
00161         UINT m_counter;
00162 };
00163
00164
00165 const INT c_max_at_req_alpha_id_size = c_max_phonebook_entry_len-c_max_bcd_number_size;
00166
00167
00168 /*  ========================================================================
00169                              AT Generic Interface
00170     ========================================================================*/
00171
00172 // T_DATA
00173 class AtGenericCmdType {
00174
00175     public:
00176
00177         AtGenericCmdType() : m_length(0), m_data_ptr(0) { ; }
00178
00179         AtGenericCmdType(const AtGenericCmdType & cmd) : m_length(0), m_data_ptr(0) {
00180             if (cmd.m_length > 0) {
00181                 m_data_ptr = new UINT8[cmd.m_length];
00182                 if(m_data_ptr != 0) {
00183                     m_length = cmd.m_length;
00184                     memcpy(m_data_ptr, cmd.m_data_ptr, m_length);
00185                 }
00186             }
00187         }
00188
00189         ~AtGenericCmdType() {
00190             m_length = 0;
00191             delete[] m_data_ptr;
00192             m_data_ptr = 0;
00193         }
00194
00195         void Push(INT length, const UINT8 * data_ptr) {
00196             m_data_ptr = (length > 0) ? new UINT8[length] : 0;
00197             if (m_data_ptr != 0) {
00198                 m_length = length;
00199                 memcpy(m_data_ptr, data_ptr, length);
00200             }
00201         }
00202
00203         INT     m_length;
00204         UINT8 * m_data_ptr;
00205 };
00206
00207 // ATC_RESULT
00208 enum AtStatusType {
00209 #if defined(APOXI_ENABLE_GENERIC_AT_INTERFACE)
00210     AtStatusSuccess             = ATC_STATUS_SUCCESS,
00211     AtStatusSuccessNoOutput     = ATC_STATUS_SUCCESS_NO_OUTPUT,
00212     AtStatusError               = ATC_STATUS_ERROR,
00213     AtStatusNoCarrier           = ATC_STATUS_NO_CARRIER,
00214     AtStatusNoAnswer            = ATC_STATUS_NO_ANSWER,
00215     AtStatusBusy                = ATC_STATUS_BUSY,
00216     AtStatusCommitSignal        = ATC_STATUS_COMMIT_SIGNAL,
00217     AtStatusUnsolicitedResult   = ATC_STATUS_UNSOLICITED_RESULT,
00218     AtStatusSignalNotHandled    = ATC_STATUS_SIGNAL_NOT_HANDLED,
00219     AtStatusSignalNotExpected   = ATC_STATUS_SIGNAL_NOT_EXPECTED
00220
00221 #else
00222     AtStatusSuccess,
00223     AtStatusSuccessNoOutput,
00224     AtStatusError,
00225     AtStatusNoCarrier,
00226     AtStatusNoAnswer,
00227     AtStatusBusy,
00228     AtStatusCommitSignal,
00229     AtStatusUnsolicitedResult,
00230     AtStatusSignalNotHandled,
00231     AtStatusSignalNotExpected
00232 #endif
00233 };
00234
00235
00236 #endif  // Apc_AtcTypes_hpp
00237
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioErrorMsg.hpp File Reference

Apc/AudioErrorMsg.hpp File Reference

#include <Devices/Messages/AudioErrorMsg.hpp>

Include dependency graph for AudioErrorMsg.hpp:

Go to the source code of this file.

Defines

#define Apc_AudioErrorMsg_hpp

Define Documentation

#define Apc_AudioErrorMsg_hpp

Generated on Tue Jan 24 16:54:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioErrorMsg.hpp Source File

Apc/AudioErrorMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\Apc\Gprs\AudioArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_AudioErrorMsg_hpp)
00016 #define Apc_AudioErrorMsg_hpp
00017
00018 #include <Devices/Messages/AudioErrorMsg.hpp>
00019
00020 #endif // Apc_AudioErrorMsg_hpp
00021
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioMsg.hpp File Reference

Apc/AudioMsg.hpp File Reference

#include <Devices/Messages/AudioMsg.hpp>

Include dependency graph for AudioMsg.hpp:

Go to the source code of this file.

Defines

#define Apc_AudioMsg_hpp

Define Documentation

#define Apc_AudioMsg_hpp

Generated on Tue Jan 24 16:54:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioMsg.hpp Source File

Apc/AudioMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\Apc\Gprs\AudioArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_AudioMsg_hpp)
00016 #define Apc_AudioMsg_hpp
00017
00018 #include <Devices/Messages/AudioMsg.hpp>
00019
00020 #endif // Apc_AudioMsg_hpp
00021
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioStoppedMsg.hpp File Reference

Apc/AudioStoppedMsg.hpp File Reference

#include <Devices/Messages/AudioStoppedMsg.hpp>

Include dependency graph for AudioStoppedMsg.hpp:

Go to the source code of this file.

Defines

#define Apc_AudioStoppedMsg_hpp

Define Documentation

#define Apc_AudioStoppedMsg_hpp

Generated on Tue Jan 24 16:54:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioStoppedMsg.hpp Source File

Apc/AudioStoppedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "simonal_view_sgold_lite\lnz_apoxi\Apoxi\Apc\Gprs\AudioStoppedMsg.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Apc_AudioStoppedMsg_hpp)
00014 #define Apc_AudioStoppedMsg_hpp
00015
00016 #include <Devices/Messages/AudioStoppedMsg.hpp>
00017
00018 #endif // Apc_AudioStoppedMsg_hpp
00019
00020
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioSuspendedMsg.hpp File Reference

Apc/AudioSuspendedMsg.hpp File Reference

#include <Devices/Messages/AudioSuspendedMsg.hpp>

Include dependency graph for AudioSuspendedMsg.hpp:

Go to the source code of this file.

Defines

#define Apc_AudioSuspendedMsg_hpp

Define Documentation

#define Apc_AudioSuspendedMsg_hpp

Generated on Tue Jan 24 16:54:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioSuspendedMsg.hpp Source File

Apc/AudioSuspendedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\Apc\Gprs\AudioArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_AudioSuspendedMsg_hpp)
00016 #define Apc_AudioSuspendedMsg_hpp
00017
00018 #include <Devices/Messages/AudioSuspendedMsg.hpp>
00019
00020 #endif // Apc_AudioSuspendedMsg_hpp
00021
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioTypes.cpp File Reference

Apc/AudioTypes.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Kernel/Lib.hpp"
#include "AudioTypes.hpp"
#include <Devices/Device.hpp>
#include <Devices/AudioPresetStore.hpp>

Include dependency graph for AudioTypes.cpp:

Variables

const INT c_no_tonepairs = 12

Variable Documentation

const INT c_no_tonepairs = 12

Generated on Tue Jan 24 16:54:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioTypes.hpp File Reference

Apc/AudioTypes.hpp File Reference

#include <Apc/SignalTypes.hpp>
#include <Devices/PresetAudioReference.hpp>
#include <Audio/AudioPreset.hpp>

Include dependency graph for AudioTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioTone

Defines

#define | Apc_AudioTypes_hpp

Define Documentation

#define Apc_AudioTypes_hpp

Generated on Tue Jan 24 16:54:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioTypes.hpp Source File

Apc/AudioTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_AudioTypes_hpp)
00009 #define Apc_AudioTypes_hpp
00010
00011 #include <Apc/SignalTypes.hpp>
00012 #include <Devices/PresetAudioReference.hpp>
00013 #include <Audio/AudioPreset.hpp>
00014
00015
00016 /*  ========================================================================
00017     AudioTone
00018         audio tone type (GSM 02.40 - GSM 11.14)
00019     ======================================================================== */
00021 class AudioTone {
00022     public:
00024         AudioTone();
00026         AudioTone(const AudioToneType tone_type, const INT duration);
00028         AudioTone(const SdlByte sdl_tone_type, const T_DURATION &sdl_duration);
00029
00031         AudioPreset::AudioPresetSoundToneId GetAudioDeviceToneId() const;
00032
00034         AudioToneType GetToneType() const { return (m_tone_type); }
00035
00037         INT32 GetDuration() const { return (m_duration); }
00038
00040         const SharedPtr<PresetAudioReference> GetAudioDeviceToneRef() const;
00041
00042     private:
00043         enum DurationUnits {
00044             Minutes         = 0x00,
00045             Seconds         = 0x01,
00046             TenthOfSeconds  = 0x02
00047         };
00048
00049         AudioToneType      m_tone_type;
00050         INT32         m_duration;   // in milliseconds
00051 };
00052
00053
00054 #endif  // Apc_AudioTypes_hpp
00055
00056
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioVoiceMemoOutOfSpaceMsg.hpp File Reference

Apc/AudioVoiceMemoOutOfSpaceMsg.hpp File Reference

#include <Devices/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp>

Include dependency graph for AudioVoiceMemoOutOfSpaceMsg.hpp:

Go to the source code of this file.

Defines

#define Apc_AudioVoiceMemoOutOfSpaceMsg_hpp

Define Documentation

#define Apc_AudioVoiceMemoOutOfSpaceMsg_hpp

Generated on Tue Jan 24 16:54:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/AudioVoiceMemoOutOfSpaceMsg.hpp Source File

Apc/AudioVoiceMemoOutOfSpaceMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\Apc\Gprs\AudioVoiceMemoOutOfSpaceMsg.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_AudioVoiceMemoOutOfSpaceMsg_hpp)
00016 #define Apc_AudioVoiceMemoOutOfSpaceMsg_hpp
00017
00018 #include <Devices/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp>
00019
00020 #endif // Apc_AudioVoiceMemoOutOfSpaceMsg_hpp
00021
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/BaseInformationElement.cpp File Reference

Apc/BaseInformationElement.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/BaseInformationElement.hpp"

Include dependency graph for BaseInformationElement.cpp:

Generated on Tue Jan 24 16:54:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/BaseInformationElement.hpp File Reference

Apc/BaseInformationElement.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/WString.hpp>
#include <Apc/InformationElement.hpp>

Include dependency graph for BaseInformationElement.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BaseInformationElement

Defines

#define | Apc_BaseInformationElement_hpp

Define Documentation

#define Apc_BaseInformationElement_hpp

Generated on Tue Jan 24 16:54:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/BaseInformationElement.hpp Source File

Apc/BaseInformationElement.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_BaseInformationElement_hpp)
00009 #define Apc_BaseInformationElement_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 #include <Auxiliary/WString.hpp>
00014 #include <Apc/InformationElement.hpp>
00015
00016
00017 /*  ========================================================================
00018     BaseInformationElement
00019     ======================================================================== */
00021 class BaseInformationElement
00022 {
00023     public:
00024         enum Type {
00026             WStringIE,
00028             UserDataHeaderIE,
00030             MissingPduIE,
00032             EndOfPduIE,
00034             Invalid
00035         };
00036
00038         BaseInformationElement();
00040         BaseInformationElement(const BaseInformationElement & BaseInformationElement);
00042         BaseInformationElement(Type type);
00044         BaseInformationElement(const WString & wstr);
00046         BaseInformationElement(const InformationElement & udhie);
00048         BaseInformationElement(UINT8 * buffer);
00050         virtual ~BaseInformationElement();
00052         BOOLEAN IsValid() const { return m_type!=Invalid; }
00054         Type GetType() const { return m_type; }
00056         const WString & GetWString() const { return m_wstring; }
00058         const InformationElement & GetInformationElement() const { return m_udh_ie; }
00059
00061         BaseInformationElement & operator = (const BaseInformationElement & item);
00062
00063     private:
00064         Type                m_type;
00065         WString             m_wstring;
00066         InformationElement  m_udh_ie;
00067 };
00068
00069
00070
00071 #endif  // Apc_BaseInformationElement_hpp
00072
00073
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CallMiscStackMsgArgs.cpp File Reference

Apc/CallMiscStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "CallMiscStackMsgArgs.hpp"

Include dependency graph for CallMiscStackMsgArgs.cpp:

Generated on Tue Jan 24 16:54:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CallMiscStackMsgArgs.hpp File Reference

Apc/CallMiscStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Apc/SimTkTypes.hpp>

Include dependency graph for CallMiscStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallDiscIndArg
class | CallDiscReqArg
class | CallIndArg
class | CallIndCallControlInfoArg
class | CallProgressIndArg
class | CallRelCnfArg
class | CallRelIndArg
class | CallSetupBySimtTkReqArg
class | CtmInfoIndArg
class | DiagnosticIndArg
class | DtmfBufferClearedIndArg
class | MocSetupRejIndArg
class | NotifyIndArg
class | RedialQueryReqArg
class | RedialStatusIndArg
class | RejectCallsIndArg
class | StartDtmfCnfArg
class | StartDtmfRejArg
class | StartDtmfReqArg
class | StopDtmfCnfArg
class | StopDtmfReqArg

Defines

#define | Apc_CallMiscStackMsgArgs_hpp

Define Documentation

#define Apc_CallMiscStackMsgArgs_hpp

Generated on Tue Jan 24 16:54:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CallMiscStackMsgArgs.hpp Source File

Apc/CallMiscStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "hauth_mpeu_pu_dv\lnz_apoxi\Apoxi\Apc\CallMiscArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_CallMiscStackMsgArgs_hpp)
00016 #define Apc_CallMiscStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Auxiliary/PhoneNumber.hpp>
00021 #include <Apc/SimTkTypes.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class CallProgressIndArg
00030     ====================================================================== */
00031
00033 class CallProgressIndArg : public StackMsgArgument {
00034     friend class CommonStackMsgArgsDestroyTableNode;
00035     public:
00036         CallProgressIndArg();
00037
00038         static const CallProgressIndArg& Cast(const StackMsgArgument& arg);
00039         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00040         const Tipd& GetTipd() const { return m_tipd; }
00041         void SetCallProgressInd(const CallProgressInd& call_progress_ind) { m_call_progress_ind = call_progress_ind; }
00042         const CallProgressInd& GetCallProgressInd() const { return m_call_progress_ind; }
00043
00044         enum  {
00045             ID = 1120
00046             };
00047
00048     private:
00049
00050         static void Destroy(StackMsgArgument* arg) { delete ((CallProgressIndArg*) arg); }
00051
00052         Tipd m_tipd;
00053         CallProgressInd m_call_progress_ind;
00054
00055     };
00056
00057 // Inline definitions
00058 inline const CallProgressIndArg& CallProgressIndArg::Cast(const StackMsgArgument& arg) {
00059     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallProgressIndArg!\n");
00060     return ((CallProgressIndArg &) arg);
00061 }
00062
00063
00064
00065 /*  ======================================================================
00066     Class CallDiscIndArg
00067     ====================================================================== */
00068
00070 class CallDiscIndArg : public StackMsgArgument {
00071     friend class CommonStackMsgArgsDestroyTableNode;
00072     public:
00073         CallDiscIndArg();
00074
00075         static const CallDiscIndArg& Cast(const StackMsgArgument& arg);
00076         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00077         const Tipd& GetTipd() const { return m_tipd; }
00078         void SetCallDiscCause(const CallErrorCause& call_disc_cause) { m_call_disc_cause = call_disc_cause; }
00079         const CallErrorCause& GetCallDiscCause() const { return m_call_disc_cause; }
00080
00081         enum  {
00082             ID = 1121
00083             };
00084
00085     private:
00086
00087         static void Destroy(StackMsgArgument* arg) { delete ((CallDiscIndArg*) arg); }
00088
00089         Tipd m_tipd;
00090         CallErrorCause m_call_disc_cause;
00091
00092     };
00093
00094 // Inline definitions
00095 inline const CallDiscIndArg& CallDiscIndArg::Cast(const StackMsgArgument& arg) {
00096     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallDiscIndArg!\n");
00097     return ((CallDiscIndArg &) arg);
00098 }
00099
00100
00101
00102 /*  ======================================================================
00103     Class CallIndArg
00104     ====================================================================== */
00105
00107 class CallIndArg : public StackMsgArgument {
00108     friend class CommonStackMsgArgsDestroyTableNode;
00109     public:
00110         CallIndArg();
00111
00112         static const CallIndArg& Cast(const StackMsgArgument& arg);
00113         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00114         const Tipd& GetTipd() const { return m_tipd; }
00115         void SetCallState(const CallState& call_state) { m_call_state = call_state; }
00116         const CallState& GetCallState() const { return m_call_state; }
00117         void SetCallType(const CallType& call_type) { m_call_type = call_type; }
00118         const CallType& GetCallType() const { return m_call_type; }
00119         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00120         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00121         void SetCallErrorCause(const CallErrorCause& call_error_cause) { m_call_error_cause = call_error_cause; }
00122         const CallErrorCause& GetCallErrorCause() const { return m_call_error_cause; }
00123         void SetCallLine(const LineSelector& call_line) { m_call_line = call_line; }
00124         const LineSelector& GetCallLine() const { return m_call_line; }
00125         void SetCtm(BOOLEAN ctm) { m_ctm = ctm; }
00126         BOOLEAN IsCtm() const { return m_ctm; }
00127         void SetEstablishCause(const CallEstCause& establish_cause) { m_establish_cause = establish_cause; }
00128         const CallEstCause& GetEstablishCause() const { return m_establish_cause; }
00129         void SetEccCategory(const EccCategory& ecc_category) { m_ecc_category = ecc_category; }
00130         const EccCategory& GetEccCategory() const { return m_ecc_category; }
00131         void SetDataCallType(const DataCallType& data_call_type) { m_data_call_type = data_call_type; }
00132         const DataCallType& GetDataCallType() const { return m_data_call_type; }
00133
00134         enum  {
00135             ID = 1123
00136             };
00137
00138     private:
00139
00140         static void Destroy(StackMsgArgument* arg) { delete ((CallIndArg*) arg); }
00141
00142         Tipd m_tipd;
00143         CallState m_call_state;
00144         CallType m_call_type;
00145         PhoneNumber m_phone_number;
00146         CallErrorCause m_call_error_cause;
00147         LineSelector m_call_line;
00148         BOOLEAN m_ctm;
00149         CallEstCause m_establish_cause;
00150         EccCategory m_ecc_category;
00151         DataCallType m_data_call_type;
00152
00153     };
00154
00155 // Inline definitions
00156 inline const CallIndArg& CallIndArg::Cast(const StackMsgArgument& arg) {
00157     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallIndArg!\n");
00158     return ((CallIndArg &) arg);
00159 }
00160
00161
00162
00163 /*  ======================================================================
00164     Class StartDtmfCnfArg
00165     ====================================================================== */
00166
00168 class StartDtmfCnfArg : public StackMsgArgument {
00169     friend class CommonStackMsgArgsDestroyTableNode;
00170     public:
00171         StartDtmfCnfArg();
00172
00173         static const StartDtmfCnfArg& Cast(const StackMsgArgument& arg);
00174         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00175         const Tipd& GetTipd() const { return m_tipd; }
00176         void SetKey(const KeyCode& key) { m_key = key; }
00177         const KeyCode& GetKey() const { return m_key; }
00178
00179         enum  {
00180             ID = 1124
00181             };
00182
00183     private:
00184
00185         static void Destroy(StackMsgArgument* arg) { delete ((StartDtmfCnfArg*) arg); }
00186
00187         Tipd m_tipd;
00188         KeyCode m_key;
00189
00190     };
00191
00192 // Inline definitions
00193 inline const StartDtmfCnfArg& StartDtmfCnfArg::Cast(const StackMsgArgument& arg) {
00194     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to StartDtmfCnfArg!\n");
00195     return ((StartDtmfCnfArg &) arg);
00196 }
00197
00198
00199
00200 /*  ======================================================================
00201     Class StopDtmfCnfArg
00202     ====================================================================== */
00203
00205 class StopDtmfCnfArg : public StackMsgArgument {
00206     friend class CommonStackMsgArgsDestroyTableNode;
00207     public:
00208         StopDtmfCnfArg(const Tipd& tipd);
00209         StopDtmfCnfArg();
00210         ~StopDtmfCnfArg();
00211
00212         static const StopDtmfCnfArg& Cast(const StackMsgArgument& arg);
00213         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00214         const Tipd& GetTipd() const { return m_tipd; }
00215
00216         enum  {
00217             ID = 1125
00218             };
00219
00220     private:
00221
00222         static void Destroy(StackMsgArgument* arg) { delete ((StopDtmfCnfArg*) arg); }
00223
00224         Tipd m_tipd;
00225
00226     };
00227
00228 // Inline definitions
00229 inline const StopDtmfCnfArg& StopDtmfCnfArg::Cast(const StackMsgArgument& arg) {
00230     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to StopDtmfCnfArg!\n");
00231     return ((StopDtmfCnfArg &) arg);
00232 }
00233
00234
00235
00236 /*  ======================================================================
00237     Class StartDtmfRejArg
00238     ====================================================================== */
00239
00241 class StartDtmfRejArg : public StackMsgArgument {
00242     friend class CommonStackMsgArgsDestroyTableNode;
00243     public:
00244         StartDtmfRejArg();
00245
00246         static const StartDtmfRejArg& Cast(const StackMsgArgument& arg);
00247         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00248         const Tipd& GetTipd() const { return m_tipd; }
00249         void SetCause(const CallErrorCause& cause) { m_cause = cause; }
00250         const CallErrorCause& GetCause() const { return m_cause; }
00251
00252         enum  {
00253             ID = 1126
00254             };
00255
00256     private:
00257
00258         static void Destroy(StackMsgArgument* arg) { delete ((StartDtmfRejArg*) arg); }
00259
00260         Tipd m_tipd;
00261         CallErrorCause m_cause;
00262
00263     };
00264
00265 // Inline definitions
00266 inline const StartDtmfRejArg& StartDtmfRejArg::Cast(const StackMsgArgument& arg) {
00267     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to StartDtmfRejArg!\n");
00268     return ((StartDtmfRejArg &) arg);
00269 }
00270
00271
00272
00273 /*  ======================================================================
00274     Class DtmfBufferClearedIndArg
00275     ====================================================================== */
00276
00278 class DtmfBufferClearedIndArg : public StackMsgArgument {
00279     friend class CommonStackMsgArgsDestroyTableNode;
00280     public:
00281         DtmfBufferClearedIndArg();
00282
00283         static const DtmfBufferClearedIndArg& Cast(const StackMsgArgument& arg);
00284
00285         enum  {
00286             ID = 1127
00287             };
00288
00289     private:
00290
00291         static void Destroy(StackMsgArgument* arg) { delete ((DtmfBufferClearedIndArg*) arg); }
00292
00293     };
00294
00295 // Inline definitions
00296 inline const DtmfBufferClearedIndArg& DtmfBufferClearedIndArg::Cast(const StackMsgArgument& arg) {
00297     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DtmfBufferClearedIndArg!\n");
00298     return ((DtmfBufferClearedIndArg &) arg);
00299 }
00300
00301
00302
00303 /*  ======================================================================
00304     Class NotifyIndArg
00305     ====================================================================== */
00306
00308 class NotifyIndArg : public StackMsgArgument {
00309     friend class CommonStackMsgArgsDestroyTableNode;
00310     public:
00311         NotifyIndArg();
00312
00313         static const NotifyIndArg& Cast(const StackMsgArgument& arg);
00314         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00315         const Tipd& GetTipd() const { return m_tipd; }
00316         void SetDescription(const NotificationDescription& description) { m_description = description; }
00317         const NotificationDescription& GetDescription() const { return m_description; }
00318
00319         enum  {
00320             ID = 1128
00321             };
00322
00323     private:
00324
00325         static void Destroy(StackMsgArgument* arg) { delete ((NotifyIndArg*) arg); }
00326
00327         Tipd m_tipd;
00328         NotificationDescription m_description;
00329
00330     };
00331
00332 // Inline definitions
00333 inline const NotifyIndArg& NotifyIndArg::Cast(const StackMsgArgument& arg) {
00334     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to NotifyIndArg!\n");
00335     return ((NotifyIndArg &) arg);
00336 }
00337
00338
00339
00340 /*  ======================================================================
00341     Class CallRelCnfArg
00342     ====================================================================== */
00343
00345 class CallRelCnfArg : public StackMsgArgument {
00346     friend class CommonStackMsgArgsDestroyTableNode;
00347     public:
00348         CallRelCnfArg();
00349
00350         static const CallRelCnfArg& Cast(const StackMsgArgument& arg);
00351         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00352         const Tipd& GetTipd() const { return m_tipd; }
00353
00354         enum  {
00355             ID = 1129
00356             };
00357
00358     private:
00359
00360         static void Destroy(StackMsgArgument* arg) { delete ((CallRelCnfArg*) arg); }
00361
00362         Tipd m_tipd;
00363
00364     };
00365
00366 // Inline definitions
00367 inline const CallRelCnfArg& CallRelCnfArg::Cast(const StackMsgArgument& arg) {
00368     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallRelCnfArg!\n");
00369     return ((CallRelCnfArg &) arg);
00370 }
00371
00372
00373
00374 /*  ======================================================================
00375     Class CallRelIndArg
00376     ====================================================================== */
00377
00379 class CallRelIndArg : public StackMsgArgument {
00380     friend class CommonStackMsgArgsDestroyTableNode;
00381     public:
00382         CallRelIndArg();
00383
00384         static const CallRelIndArg& Cast(const StackMsgArgument& arg);
00385         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00386         const Tipd& GetTipd() const { return m_tipd; }
00387         void SetCallDiscCause(const CallErrorCause& call_disc_cause) { m_call_disc_cause = call_disc_cause; }
00388         const CallErrorCause& GetCallDiscCause() const { return m_call_disc_cause; }
00389
00390         enum  {
00391             ID = 1131
00392             };
00393
00394     private:
00395
00396         static void Destroy(StackMsgArgument* arg) { delete ((CallRelIndArg*) arg); }
00397
00398         Tipd m_tipd;
00399         CallErrorCause m_call_disc_cause;
00400
00401     };
00402
00403 // Inline definitions
00404 inline const CallRelIndArg& CallRelIndArg::Cast(const StackMsgArgument& arg) {
00405     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallRelIndArg!\n");
00406     return ((CallRelIndArg &) arg);
00407 }
00408
00409
00410
00411 /*  ======================================================================
00412     Class DiagnosticIndArg
00413     ====================================================================== */
00414
00416 class DiagnosticIndArg : public StackMsgArgument {
00417     friend class CommonStackMsgArgsDestroyTableNode;
00418     public:
00419         DiagnosticIndArg();
00420
00421         static const DiagnosticIndArg& Cast(const StackMsgArgument& arg);
00422         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00423         const Tipd& GetTipd() const { return m_tipd; }
00424         void SetDiagnosticCause(const DiagnosticCause& diagnostic_cause) { m_diagnostic_cause = diagnostic_cause; }
00425         const DiagnosticCause& GetDiagnosticCause() const { return m_diagnostic_cause; }
00426
00427         enum  {
00428             ID = 1132
00429             };
00430
00431     private:
00432
00433         static void Destroy(StackMsgArgument* arg) { delete ((DiagnosticIndArg*) arg); }
00434
00435         Tipd m_tipd;
00436         DiagnosticCause m_diagnostic_cause;
00437
00438     };
00439
00440 // Inline definitions
00441 inline const DiagnosticIndArg& DiagnosticIndArg::Cast(const StackMsgArgument& arg) {
00442     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DiagnosticIndArg!\n");
00443     return ((DiagnosticIndArg &) arg);
00444 }
00445
00446
00447
00448 /*  ======================================================================
00449     Class CtmInfoIndArg
00450     ====================================================================== */
00451
00453 class CtmInfoIndArg : public StackMsgArgument {
00454     friend class CommonStackMsgArgsDestroyTableNode;
00455     public:
00456         CtmInfoIndArg();
00457
00458         static const CtmInfoIndArg& Cast(const StackMsgArgument& arg);
00459         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00460         const Tipd& GetTipd() const { return m_tipd; }
00461         void SetCtm(BOOLEAN ctm) { m_ctm = ctm; }
00462         BOOLEAN IsCtm() const { return m_ctm; }
00463
00464         enum  {
00465             ID = 1133
00466             };
00467
00468     private:
00469
00470         static void Destroy(StackMsgArgument* arg) { delete ((CtmInfoIndArg*) arg); }
00471
00472         Tipd m_tipd;
00473         BOOLEAN m_ctm;
00474
00475     };
00476
00477 // Inline definitions
00478 inline const CtmInfoIndArg& CtmInfoIndArg::Cast(const StackMsgArgument& arg) {
00479     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CtmInfoIndArg!\n");
00480     return ((CtmInfoIndArg &) arg);
00481 }
00482
00483
00484
00485 /*  ======================================================================
00486     Class CallSetupBySimtTkReqArg
00487     ====================================================================== */
00488
00490 class CallSetupBySimtTkReqArg : public StackMsgArgument {
00491     friend class CommonStackMsgArgsDestroyTableNode;
00492     public:
00493         CallSetupBySimtTkReqArg();
00494
00495         static const CallSetupBySimtTkReqArg& Cast(const StackMsgArgument& arg);
00496         void SetCause(const ProactiveCause& cause) { m_cause = cause; }
00497         const ProactiveCause& GetCause() const { return m_cause; }
00498         void SetStkCallSetupNo(const PhoneNumber& stk_call_setup_no) { m_stk_call_setup_no = stk_call_setup_no; }
00499         const PhoneNumber& GetStkCallSetupNo() const { return m_stk_call_setup_no; }
00500         void SetSimCallSetupOption(UINT8 sim_call_setup_option) { m_sim_call_setup_option = sim_call_setup_option; }
00501         UINT8 GetSimCallSetupOption() const { return m_sim_call_setup_option; }
00502
00503         enum  {
00504             ID = 1134
00505             };
00506
00507     private:
00508
00509         static void Destroy(StackMsgArgument* arg) { delete ((CallSetupBySimtTkReqArg*) arg); }
00510
00511         ProactiveCause m_cause;
00512         PhoneNumber m_stk_call_setup_no;
00513         UINT8 m_sim_call_setup_option;
00514
00515     };
00516
00517 // Inline definitions
00518 inline const CallSetupBySimtTkReqArg& CallSetupBySimtTkReqArg::Cast(const StackMsgArgument& arg) {
00519     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallSetupBySimtTkReqArg!\n");
00520     return ((CallSetupBySimtTkReqArg &) arg);
00521 }
00522
00523
00524
00525 /*  ======================================================================
00526     Class RedialStatusIndArg
00527     ====================================================================== */
00528
00530 class RedialStatusIndArg : public StackMsgArgument {
00531     friend class CommonStackMsgArgsDestroyTableNode;
00532     public:
00533         RedialStatusIndArg();
00534
00535         static const RedialStatusIndArg& Cast(const StackMsgArgument& arg);
00536         void SetRedialStatus(BOOLEAN redial_status) { m_redial_status = redial_status; }
00537         BOOLEAN IsRedialStatus() const { return m_redial_status; }
00538
00539         enum  {
00540             ID = 1135
00541             };
00542
00543     private:
00544
00545         static void Destroy(StackMsgArgument* arg) { delete ((RedialStatusIndArg*) arg); }
00546
00547         BOOLEAN m_redial_status;
00548
00549     };
00550
00551 // Inline definitions
00552 inline const RedialStatusIndArg& RedialStatusIndArg::Cast(const StackMsgArgument& arg) {
00553     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RedialStatusIndArg!\n");
00554     return ((RedialStatusIndArg &) arg);
00555 }
00556
00557
00558
00559 /*  ======================================================================
00560     Class CallIndCallControlInfoArg
00561     ====================================================================== */
00562
00564 class CallIndCallControlInfoArg : public StackMsgArgument {
00565     friend class CommonStackMsgArgsDestroyTableNode;
00566     public:
00567         CallIndCallControlInfoArg();
00568
00569         static const CallIndCallControlInfoArg& Cast(const StackMsgArgument& arg);
00570         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00571         const Tipd& GetTipd() const { return m_tipd; }
00572         void SetCallControlPerformed(BOOLEAN call_control_performed) { m_call_control_performed = call_control_performed; }
00573         BOOLEAN IsCallControlPerformed() const { return m_call_control_performed; }
00574         void SetCallControlResult(const SimCallControlResult& call_control_result) { m_call_control_result = call_control_result; }
00575         const SimCallControlResult& GetCallControlResult() const { return m_call_control_result; }
00576         void SetAlphaIdentifier(const SimAlphaIdentifier& alpha_identifier) { m_alpha_identifier = alpha_identifier; }
00577         const SimAlphaIdentifier& GetAlphaIdentifier() const { return m_alpha_identifier; }
00578
00579         enum  {
00580             ID = 1136
00581             };
00582
00583     private:
00584
00585         static void Destroy(StackMsgArgument* arg) { delete ((CallIndCallControlInfoArg*) arg); }
00586
00587         Tipd m_tipd;
00588         BOOLEAN m_call_control_performed;
00589         SimCallControlResult m_call_control_result;
00590         SimAlphaIdentifier m_alpha_identifier;
00591
00592     };
00593
00594 // Inline definitions
00595 inline const CallIndCallControlInfoArg& CallIndCallControlInfoArg::Cast(const StackMsgArgument& arg) {
00596     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallIndCallControlInfoArg!\n");
00597     return ((CallIndCallControlInfoArg &) arg);
00598 }
00599
00600
00601
00602 /*  ======================================================================
00603     Class MocSetupRejIndArg
00604     ====================================================================== */
00605
00607 class MocSetupRejIndArg : public StackMsgArgument {
00608     friend class CommonStackMsgArgsDestroyTableNode;
00609     public:
00610         MocSetupRejIndArg();
00611
00612         static const MocSetupRejIndArg& Cast(const StackMsgArgument& arg);
00613         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00614         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00615         void SetCause(const CallErrorCause& cause) { m_cause = cause; }
00616         const CallErrorCause& GetCause() const { return m_cause; }
00617
00618         enum  {
00619             ID = 1137
00620             };
00621
00622     private:
00623
00624         static void Destroy(StackMsgArgument* arg) { delete ((MocSetupRejIndArg*) arg); }
00625
00626         PhoneNumber m_phone_number;
00627         CallErrorCause m_cause;
00628
00629     };
00630
00631 // Inline definitions
00632 inline const MocSetupRejIndArg& MocSetupRejIndArg::Cast(const StackMsgArgument& arg) {
00633     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MocSetupRejIndArg!\n");
00634     return ((MocSetupRejIndArg &) arg);
00635 }
00636
00637
00638
00639 /*  ======================================================================
00640     Class CallDiscReqArg
00641     ====================================================================== */
00642
00644 class CallDiscReqArg : public StackMsgArgument {
00645     friend class CommonStackMsgArgsDestroyTableNode;
00646     public:
00647         CallDiscReqArg(const Tipd& tipd, const CallErrorCause& call_disc_cause);
00648         CallDiscReqArg();
00649
00650         static const CallDiscReqArg& Cast(const StackMsgArgument& arg);
00651         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00652         const Tipd& GetTipd() const { return m_tipd; }
00653         void SetCallDiscCause(const CallErrorCause& call_disc_cause) { m_call_disc_cause = call_disc_cause; }
00654         const CallErrorCause& GetCallDiscCause() const { return m_call_disc_cause; }
00655
00656         enum  {
00657             ID = 2120
00658             };
00659
00660     private:
00661
00662         static void Destroy(StackMsgArgument* arg) { delete ((CallDiscReqArg*) arg); }
00663
00664         Tipd m_tipd;
00665         CallErrorCause m_call_disc_cause;
00666
00667     };
00668
00669 // Inline definitions
00670 inline const CallDiscReqArg& CallDiscReqArg::Cast(const StackMsgArgument& arg) {
00671     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallDiscReqArg!\n");
00672     return ((CallDiscReqArg &) arg);
00673 }
00674
00675
00676
00677 /*  ======================================================================
00678     Class StartDtmfReqArg
00679     ====================================================================== */
00680
00682 class StartDtmfReqArg : public StackMsgArgument {
00683     friend class CommonStackMsgArgsDestroyTableNode;
00684     public:
00685         StartDtmfReqArg(const Tipd& tipd, const KeyCode& key);
00686         StartDtmfReqArg();
00687
00688         static const StartDtmfReqArg& Cast(const StackMsgArgument& arg);
00689         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00690         const Tipd& GetTipd() const { return m_tipd; }
00691         void SetKey(const KeyCode& key) { m_key = key; }
00692         const KeyCode& GetKey() const { return m_key; }
00693
00694         enum  {
00695             ID = 2122
00696             };
00697
00698     private:
00699
00700         static void Destroy(StackMsgArgument* arg) { delete ((StartDtmfReqArg*) arg); }
00701
00702         Tipd m_tipd;
00703         KeyCode m_key;
00704
00705     };
00706
00707 // Inline definitions
00708 inline const StartDtmfReqArg& StartDtmfReqArg::Cast(const StackMsgArgument& arg) {
00709     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to StartDtmfReqArg!\n");
00710     return ((StartDtmfReqArg &) arg);
00711 }
00712
00713
00714
00715 /*  ======================================================================
00716     Class StopDtmfReqArg
00717     ====================================================================== */
00718
00720 class StopDtmfReqArg : public StackMsgArgument {
00721     friend class CommonStackMsgArgsDestroyTableNode;
00722     public:
00723         StopDtmfReqArg(const Tipd& tipd);
00724         StopDtmfReqArg();
00725
00726         static const StopDtmfReqArg& Cast(const StackMsgArgument& arg);
00727         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00728         const Tipd& GetTipd() const { return m_tipd; }
00729
00730         enum  {
00731             ID = 2123
00732             };
00733
00734     private:
00735
00736         static void Destroy(StackMsgArgument* arg) { delete ((StopDtmfReqArg*) arg); }
00737
00738         Tipd m_tipd;
00739
00740     };
00741
00742 // Inline definitions
00743 inline const StopDtmfReqArg& StopDtmfReqArg::Cast(const StackMsgArgument& arg) {
00744     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to StopDtmfReqArg!\n");
00745     return ((StopDtmfReqArg &) arg);
00746 }
00747
00748
00749
00750 /*  ======================================================================
00751     Class RejectCallsIndArg
00752     ====================================================================== */
00753
00755 class RejectCallsIndArg : public StackMsgArgument {
00756     friend class CommonStackMsgArgsDestroyTableNode;
00757     public:
00758         RejectCallsIndArg(BOOLEAN activated, const CallRefuseDirection& call_refuse_direction);
00759         RejectCallsIndArg();
00760
00761         static const RejectCallsIndArg& Cast(const StackMsgArgument& arg);
00762         void SetActivated(BOOLEAN activated) { m_activated = activated; }
00763         BOOLEAN IsActivated() const { return m_activated; }
00764         void SetCallRefuseDirection(const CallRefuseDirection& call_refuse_direction) { m_call_refuse_direction = call_refuse_direction; }
00765         const CallRefuseDirection& GetCallRefuseDirection() const { return m_call_refuse_direction; }
00766
00767         enum  {
00768             ID = 2124
00769             };
00770
00771     private:
00772
00773         static void Destroy(StackMsgArgument* arg) { delete ((RejectCallsIndArg*) arg); }
00774
00775         BOOLEAN m_activated;
00776         CallRefuseDirection m_call_refuse_direction;
00777
00778     };
00779
00780 // Inline definitions
00781 inline const RejectCallsIndArg& RejectCallsIndArg::Cast(const StackMsgArgument& arg) {
00782     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RejectCallsIndArg!\n");
00783     return ((RejectCallsIndArg &) arg);
00784 }
00785
00786
00787
00788 /*  ======================================================================
00789     Class RedialQueryReqArg
00790     ====================================================================== */
00791
00793 class RedialQueryReqArg : public StackMsgArgument {
00794     friend class CommonStackMsgArgsDestroyTableNode;
00795     public:
00796         RedialQueryReqArg();
00797
00798         static const RedialQueryReqArg& Cast(const StackMsgArgument& arg);
00799
00800         enum  {
00801             ID = 2125
00802             };
00803
00804     private:
00805
00806         static void Destroy(StackMsgArgument* arg) { delete ((RedialQueryReqArg*) arg); }
00807
00808     };
00809
00810 // Inline definitions
00811 inline const RedialQueryReqArg& RedialQueryReqArg::Cast(const StackMsgArgument& arg) {
00812     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RedialQueryReqArg!\n");
00813     return ((RedialQueryReqArg &) arg);
00814 }
00815
00816
00817 #endif // Apc_CallMiscStackMsgArgs_hpp
00818
Generated on Tue Jan 24 14:45:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Cbs.cpp File Reference

Apc/Cbs.cpp File Reference

#include "Apc/PreComp.hpp"
#include <Auxiliary/BitField.hpp>
#include "Cbs.hpp"
#include "SignalTypes.hpp"
#include "SimDataTypes.hpp"

Include dependency graph for Cbs.cpp:

Generated on Tue Jan 24 16:54:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Cbs.hpp File Reference

Apc/Cbs.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/BitField.hpp>
#include <Auxiliary/ElementList.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <Apc/MessageIdentifier.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for Cbs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Cbs
class | Cbs::Filter
class | Cbs::SerialNumber
Serial Number - 3GPP TS 23.041 V4.1.0 [9.4.1.2.1]. More...

Defines

#define | Apc_Cbs_hpp

Variables

const INT | c_cbs_default_active_timer = 0
const INT | c_cbs_default_sleep_timer = 0

Define Documentation

#define Apc_Cbs_hpp

Variable Documentation

const INT c_cbs_default_active_timer = 0

const INT c_cbs_default_sleep_timer = 0

Generated on Tue Jan 24 16:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Cbs.hpp Source File

Apc/Cbs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Cbs_hpp)
00009 #define Apc_Cbs_hpp
00010
00011 #include <Kernel/Os/Os.hpp>
00012 #include <Auxiliary/Linkable.hpp>
00013 #include <Auxiliary/BitField.hpp>
00014 #include <Auxiliary/ElementList.hpp>
00015
00016 #include <Apc/DataCodingScheme.hpp>
00017 #include <Apc/MessageIdentifier.hpp>
00018
00019 #include <Apc/SignalTypes.hpp>
00020
00021 #if ! defined(APOXI_CBS_DEFAULT_SLEEP_TIMER)
00022     const INT c_cbs_default_sleep_timer = 0;
00023 #else
00024     const INT c_cbs_default_sleep_timer = APOXI_CBS_DEFAULT_SLEEP_TIMER;
00025 #endif
00026
00027 #if ! defined(APOXI_CBS_DEFAULT_ACTIVE_TIMER)
00028     const INT c_cbs_default_active_timer = 0;
00029 #else
00030     const INT c_cbs_default_active_timer = APOXI_CBS_DEFAULT_ACTIVE_TIMER;
00031 #endif
00032
00033
00034 /*  ========================================================================
00035     Cbs: Cell Broadcast Service - 3GPP TS 23.041 V4.1.0 [9.4]
00036     ======================================================================== */
00039 class Cbs {
00040     public:
00041
00042         /*  ========================================================================
00043             Serial Number - 3GPP TS 23.041 V4.1.0 [9.4.1.2.1]
00044             ======================================================================== */
00046         class SerialNumber {
00047             public:
00049                 enum GeographicalScope {
00052                     CellWideImmediate,
00055                     PlmnWideNormal,
00061                     LocationAreaWideNormal,
00064                     CellWideNormal,
00066                     InvalidScope
00067                 };
00068
00070                 SerialNumber();
00072                 SerialNumber(UINT16 incoming_word);
00073
00075                 UINT16 Get() const { return (m_bit_field.Get()); }
00076
00078                 GeographicalScope GetGeographicalScope() const;
00080                 void SetGeographicalScope(GeographicalScope geographical_scope);
00081
00083                 UINT16 GetMessageCode() const;
00085                 void SetMessageCode(UINT16 serial_number);
00086
00088                 BOOLEAN IsIndex() const;
00089
00091                 UINT8 GetUpdateNumber() const;
00093                 void SetUpdateNumber(UINT8 update_number);
00094
00096                 void Clear() { m_bit_field.Clear(); }
00097
00098             private:
00099                 BitField16 m_bit_field;
00100         };
00101
00103         class Filter {
00104             public:
00106                 enum Mode {
00108                     Normal = 0,
00110                     Inverted = 1,
00111                 };
00112
00113                 enum {
00114                     c_max_stack_no_of_message_identifiers = MN_MAX_CB_MSG_ID_LIST_LENGTH,
00115                     c_max_stack_no_of_data_coding_schemes = MN_MAX_CB_DCS_LIST_LENGTH,
00116                     c_max_apoxi_no_of_message_identifiers = MessageIdentifierContainer::c_max_apoxi_no_of_message_identifiers
00117                 };
00118
00120                 Filter();
00122                 Filter(const Filter & filter);
00124                 Filter(BOOLEAN ignore_duplicates,
00125                        INT sleep_duration = c_cbs_default_sleep_timer,
00126                        UINT8 no_of_pages = MAX_SMS_CB_MAX_NBR_PAGES,//c_maximum_no_of_pages,
00127                        BOOLEAN dcs_list_filter_enabled = TRUE,
00128                        BOOLEAN mid_list_filter_enabled = TRUE,
00129                        Mode mode = Normal,
00130                        INT wake_duration = c_cbs_default_active_timer);
00132                 ~Filter();
00134                 Filter& operator =(const Filter &filter);
00135
00137                 Mode GetMode() const { return (m_mode); }
00139                 void SetMode(Mode mode) { m_mode = mode; }
00140
00142                 BOOLEAN Optimize();
00143
00145                 BOOLEAN MakeModeNormal();
00146
00148                 BOOLEAN IsDcsListFilterEnabled() const { return (m_dcs_list_filter_enabled); }
00150                 void EnableDcsListFilter(BOOLEAN dcs_list_filter_enabled = TRUE) { m_dcs_list_filter_enabled = dcs_list_filter_enabled; }
00151
00153                 BOOLEAN IsMidListFilterEnabled() const { return (m_mid_list_filter_enabled); }
00155                 void EnableMidListFilter(BOOLEAN mid_list_filter_enabled = TRUE) { m_mid_list_filter_enabled = mid_list_filter_enabled; }
00156
00158                 UINT8 GetNoOfPages() const { return (m_no_of_pages); }
00160                 void SetNoOfPages(UINT8 no_of_pages) { m_no_of_pages = no_of_pages; }
00161
00163                 BOOLEAN IgnoreDuplicates() const { return (m_ignore_duplicates); }
00165                 void IgnoreDuplicates(BOOLEAN ignore_duplicates) { m_ignore_duplicates = ignore_duplicates; }
00166
00168                 INT GetSleepDuration() const { return (m_sleep_duration); }
00170                 void SetSleepDuration(INT sleep_duration) { m_sleep_duration = sleep_duration; }
00172                 INT GetActiveDuration() const { return (m_active_duration); }
00174                 void SetActiveDuration(INT active_duration) { m_active_duration = active_duration; }
00175
00177                 static void EnableGlobalSleepDuration(INT duration);
00179                 static void DisableGlobalSleepDuration();
00181                 static void EnableGlobalActiveDuration(INT duration);
00183                 static void DisableGlobalActiveDuration();
00184
00186                 BOOLEAN Append(const MessageIdentifier &mid);
00188                 BOOLEAN Append(const MessageIdentifierRange &mid_range);
00189
00191                 BOOLEAN Append(const DataCodingScheme &dcs);
00193                 BOOLEAN Append(const DataCodingSchemeRange &dcs_range);
00195                 BOOLEAN MergeDataCodingSchemeRanges(const Filter & filter);
00196
00198                 BOOLEAN Exists(const DataCodingScheme &dcs) const;
00200                 BOOLEAN Exists(const DataCodingSchemeRange &dcs_range) const;
00201
00203                 BOOLEAN Exists(const MessageIdentifier &mid) const;
00205                 BOOLEAN Exists(const MessageIdentifierRange &mid_range) const;
00207                 BOOLEAN MergeMessageIdentifierRanges(const Filter & filter);
00208
00210                 void Remove(const MessageIdentifier &mid);
00212                 void Remove(const MessageIdentifierRange &mid_range);
00213
00215                 void Remove(const DataCodingScheme &dcs);
00217                 void Remove(const DataCodingSchemeRange &dcs_range);
00218
00220                 static INT GetMaxNoOfMidRanges() { return (c_max_apoxi_no_of_message_identifiers); }
00222                 static INT GetMaxNoOfDcsRanges() { return (c_max_stack_no_of_data_coding_schemes); }
00223
00225                 INT GetNoOfMidRanges() const { return (m_mid_range_list.GetSize()); }
00227                 INT GetNoOfDcsRanges() const { return (m_dcs_range_list.GetSize()); }
00228
00229
00231                 void ClearMessageIdentifierList();
00233                 void ClearDataCodingSchemeList();
00234
00236                 void Convert2SdlFilter(T_MN_SMS_CB_START_REQ &sdl_filter) const;
00238                 BOOLEAN IsMatching(const DataCodingScheme & dcs, const MessageIdentifier & mid) const;
00239
00240                 //
00241                 void DbgOut() const;
00242
00243                 UINT8 GetNextLowDcs(UINT8 dcs);
00244                 UINT8 GetNextHighDcs(UINT8 dcs);
00245                 UINT16 GetNextLowMid(UINT16 mid);
00246                 UINT16 GetNextHighMid(UINT16 mid);
00247
00248             private:
00249                 BOOLEAN m_ignore_duplicates;
00250                 INT m_sleep_duration;
00251                 INT m_active_duration;
00252                 UINT8 m_no_of_pages;
00253                 BOOLEAN m_dcs_list_filter_enabled;
00254                 BOOLEAN m_mid_list_filter_enabled;
00255                 Mode m_mode;
00256
00257                 MessageIdentifierContainer m_mid_range_list;
00258                 ElementList<DataCodingSchemeRange> m_dcs_range_list;
00259
00260                 static INT m_global_sleep_duration;
00261                 static INT m_global_active_duration;
00262                 static BOOLEAN m_global_sleep_duration_activated;
00263                 static BOOLEAN m_global_active_duration_activated;
00264
00265         };
00266
00268         Cbs();
00270         Cbs(const SerialNumber &serial_number, const MessageIdentifier &message_identifier = 0xffff,
00271             const DataCodingScheme &dcs = DataCodingScheme(), INT length = 0, const UINT8 *data = 0);
00273         Cbs(const T_SMS_CB_MESSAGE &sdl_cbs);
00275         ~Cbs();
00277         Cbs(const Cbs &cbs);
00279         Cbs& operator =(const Cbs &cbs);
00280
00282         const SerialNumber& GetSerialNumber() const { return (m_serial_number); }
00284         const MessageIdentifier& GetMessageIdentifier() const { return (m_message_identifier); }
00286         const DataCodingScheme& GetDataCodingScheme() const { return (m_dcs); }
00288         INT GetLength() const { return (m_length); }
00290         UINT8* GetData() const { return (m_data); }
00291
00293         BOOLEAN IsIndex() const { return (GetSerialNumber().IsIndex()); };
00294
00296         WString GetText() const;
00297
00299         void GetBlobObject(BlobObject & object) const;
00300
00302         INT GetMaxDataSize() const { return (sizeof(T_SMS_CB_MESSAGE_FIELD)); }
00303
00305         static INT GetMaxPages() { return (c_maximum_no_of_pages); }
00306
00308         INT ReallocateData(INT length);
00309
00311         INT ResizeData(INT length);
00312
00314         void CopyData(const UINT8 *data);
00315
00317         void ClearData();
00318
00320         void Clear();
00321
00322     private:
00323         static const INT c_maximum_no_of_pages;
00324
00325         SerialNumber m_serial_number;
00326         MessageIdentifier m_message_identifier;
00327         DataCodingScheme m_dcs;
00328         INT m_length;
00329         UINT8 *m_data;
00330
00331         void SetDataBuffer(INT length, const UINT8 *data);
00332
00333 };
00334
00335 #endif  // Apc_Cbs_hpp
00336
00337
Generated on Tue Jan 24 14:45:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CbsStackMsgArgs.cpp File Reference

Apc/CbsStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "CbsStackMsgArgs.hpp"

Include dependency graph for CbsStackMsgArgs.cpp:

Generated on Tue Jan 24 16:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CbsStackMsgArgs.hpp File Reference

Apc/CbsStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/Cbs.hpp>

Include dependency graph for CbsStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CbsLimitIndArg
class | CbsNewDataIndArg
class | CbsNewDataRejArg
class | CbsStartCnfArg
class | CbsStartRejArg
class | CbsStartReqArg
class | CbsStopCnfArg
class | CbsStopRejArg
class | CbsStopReqArg

Defines

#define | Apc_CbsStackMsgArgs_hpp

Define Documentation

#define Apc_CbsStackMsgArgs_hpp

Generated on Tue Jan 24 16:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CbsStackMsgArgs.hpp Source File

Apc/CbsStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Apc\CbsArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_CbsStackMsgArgs_hpp)
00016 #define Apc_CbsStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Apc/Cbs.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class CbsNewDataIndArg
00029     ====================================================================== */
00030
00032 class CbsNewDataIndArg : public StackMsgArgument {
00033     friend class CommonStackMsgArgsDestroyTableNode;
00034     public:
00035         CbsNewDataIndArg();
00036
00037         static const CbsNewDataIndArg& Cast(const StackMsgArgument& arg);
00038         void SetCbs(const Cbs& cbs) { m_cbs = cbs; }
00039         const Cbs& GetCbs() const { return m_cbs; }
00040
00041         enum  {
00042             ID = 1020
00043             };
00044
00045     private:
00046
00047         static void Destroy(StackMsgArgument* arg) { delete ((CbsNewDataIndArg*) arg); }
00048
00049         Cbs m_cbs;
00050
00051     };
00052
00053 // Inline definitions
00054 inline const CbsNewDataIndArg& CbsNewDataIndArg::Cast(const StackMsgArgument& arg) {
00055     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsNewDataIndArg!\n");
00056     return ((CbsNewDataIndArg &) arg);
00057 }
00058
00059
00060
00061 /*  ======================================================================
00062     Class CbsStartRejArg
00063     ====================================================================== */
00064
00066 class CbsStartRejArg : public StackMsgArgument {
00067     friend class CommonStackMsgArgsDestroyTableNode;
00068     public:
00069         CbsStartRejArg();
00070
00071         static const CbsStartRejArg& Cast(const StackMsgArgument& arg);
00072
00073         enum  {
00074             ID = 1021
00075             };
00076
00077     private:
00078
00079         static void Destroy(StackMsgArgument* arg) { delete ((CbsStartRejArg*) arg); }
00080
00081     };
00082
00083 // Inline definitions
00084 inline const CbsStartRejArg& CbsStartRejArg::Cast(const StackMsgArgument& arg) {
00085     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsStartRejArg!\n");
00086     return ((CbsStartRejArg &) arg);
00087 }
00088
00089
00090
00091 /*  ======================================================================
00092     Class CbsStopRejArg
00093     ====================================================================== */
00094
00096 class CbsStopRejArg : public StackMsgArgument {
00097     friend class CommonStackMsgArgsDestroyTableNode;
00098     public:
00099         CbsStopRejArg();
00100
00101         static const CbsStopRejArg& Cast(const StackMsgArgument& arg);
00102
00103         enum  {
00104             ID = 1022
00105             };
00106
00107     private:
00108
00109         static void Destroy(StackMsgArgument* arg) { delete ((CbsStopRejArg*) arg); }
00110
00111     };
00112
00113 // Inline definitions
00114 inline const CbsStopRejArg& CbsStopRejArg::Cast(const StackMsgArgument& arg) {
00115     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsStopRejArg!\n");
00116     return ((CbsStopRejArg &) arg);
00117 }
00118
00119
00120
00121 /*  ======================================================================
00122     Class CbsStartCnfArg
00123     ====================================================================== */
00124
00126 class CbsStartCnfArg : public StackMsgArgument {
00127     friend class CommonStackMsgArgsDestroyTableNode;
00128     public:
00129         CbsStartCnfArg();
00130
00131         static const CbsStartCnfArg& Cast(const StackMsgArgument& arg);
00132
00133         enum  {
00134             ID = 1023
00135             };
00136
00137     private:
00138
00139         static void Destroy(StackMsgArgument* arg) { delete ((CbsStartCnfArg*) arg); }
00140
00141     };
00142
00143 // Inline definitions
00144 inline const CbsStartCnfArg& CbsStartCnfArg::Cast(const StackMsgArgument& arg) {
00145     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsStartCnfArg!\n");
00146     return ((CbsStartCnfArg &) arg);
00147 }
00148
00149
00150
00151 /*  ======================================================================
00152     Class CbsStopCnfArg
00153     ====================================================================== */
00154
00156 class CbsStopCnfArg : public StackMsgArgument {
00157     friend class CommonStackMsgArgsDestroyTableNode;
00158     public:
00159         CbsStopCnfArg();
00160
00161         static const CbsStopCnfArg& Cast(const StackMsgArgument& arg);
00162
00163         enum  {
00164             ID = 1024
00165             };
00166
00167     private:
00168
00169         static void Destroy(StackMsgArgument* arg) { delete ((CbsStopCnfArg*) arg); }
00170
00171     };
00172
00173 // Inline definitions
00174 inline const CbsStopCnfArg& CbsStopCnfArg::Cast(const StackMsgArgument& arg) {
00175     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsStopCnfArg!\n");
00176     return ((CbsStopCnfArg &) arg);
00177 }
00178
00179
00180
00181 /*  ======================================================================
00182     Class CbsLimitIndArg
00183     ====================================================================== */
00184
00186 class CbsLimitIndArg : public StackMsgArgument {
00187     friend class CommonStackMsgArgsDestroyTableNode;
00188     public:
00189         CbsLimitIndArg();
00190
00191         static const CbsLimitIndArg& Cast(const StackMsgArgument& arg);
00192         void SetMaxMessageId(UINT16 max_message_id) { m_max_message_id = max_message_id; }
00193         UINT16 GetMaxMessageId() const { return m_max_message_id; }
00194
00195         enum  {
00196             ID = 1025
00197             };
00198
00199     private:
00200
00201         static void Destroy(StackMsgArgument* arg) { delete ((CbsLimitIndArg*) arg); }
00202
00203         UINT16 m_max_message_id;
00204
00205     };
00206
00207 // Inline definitions
00208 inline const CbsLimitIndArg& CbsLimitIndArg::Cast(const StackMsgArgument& arg) {
00209     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsLimitIndArg!\n");
00210     return ((CbsLimitIndArg &) arg);
00211 }
00212
00213
00214
00215 /*  ======================================================================
00216     Class CbsNewDataRejArg
00217     ====================================================================== */
00218
00220 class CbsNewDataRejArg : public StackMsgArgument {
00221     friend class CommonStackMsgArgsDestroyTableNode;
00222     public:
00223         CbsNewDataRejArg(const Cbs::SerialNumber& serial_number, const MessageIdentifier& message_identifier);
00224         CbsNewDataRejArg();
00225         ~CbsNewDataRejArg();
00226
00227         static const CbsNewDataRejArg& Cast(const StackMsgArgument& arg);
00228         void SetSerialNumber(const Cbs::SerialNumber& serial_number) { m_serial_number = serial_number; }
00229         const Cbs::SerialNumber& GetSerialNumber() const { return m_serial_number; }
00230         void SetMessageIdentifier(const MessageIdentifier& message_identifier) { m_message_identifier = message_identifier; }
00231         const MessageIdentifier& GetMessageIdentifier() const { return m_message_identifier; }
00232
00233         enum  {
00234             ID = 2020
00235             };
00236
00237     private:
00238
00239         static void Destroy(StackMsgArgument* arg) { delete ((CbsNewDataRejArg*) arg); }
00240
00241         Cbs::SerialNumber m_serial_number;
00242         MessageIdentifier m_message_identifier;
00243
00244     };
00245
00246 // Inline definitions
00247 inline const CbsNewDataRejArg& CbsNewDataRejArg::Cast(const StackMsgArgument& arg) {
00248     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsNewDataRejArg!\n");
00249     return ((CbsNewDataRejArg &) arg);
00250 }
00251
00252
00253
00254 /*  ======================================================================
00255     Class CbsStartReqArg
00256     ====================================================================== */
00257
00259 class CbsStartReqArg : public StackMsgArgument {
00260     friend class CommonStackMsgArgsDestroyTableNode;
00261     public:
00262         CbsStartReqArg(const Cbs::Filter& filter);
00263         CbsStartReqArg();
00264
00265         static const CbsStartReqArg& Cast(const StackMsgArgument& arg);
00266         void SetFilter(const Cbs::Filter& filter) { m_filter = filter; }
00267         const Cbs::Filter& GetFilter() const { return m_filter; }
00268
00269         enum  {
00270             ID = 2021
00271             };
00272
00273     private:
00274
00275         static void Destroy(StackMsgArgument* arg) { delete ((CbsStartReqArg*) arg); }
00276
00277         Cbs::Filter m_filter;
00278
00279     };
00280
00281 // Inline definitions
00282 inline const CbsStartReqArg& CbsStartReqArg::Cast(const StackMsgArgument& arg) {
00283     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsStartReqArg!\n");
00284     return ((CbsStartReqArg &) arg);
00285 }
00286
00287
00288
00289 /*  ======================================================================
00290     Class CbsStopReqArg
00291     ====================================================================== */
00292
00294 class CbsStopReqArg : public StackMsgArgument {
00295     friend class CommonStackMsgArgsDestroyTableNode;
00296     public:
00297         CbsStopReqArg();
00298
00299         static const CbsStopReqArg& Cast(const StackMsgArgument& arg);
00300
00301         enum  {
00302             ID = 2022
00303             };
00304
00305     private:
00306
00307         static void Destroy(StackMsgArgument* arg) { delete ((CbsStopReqArg*) arg); }
00308
00309     };
00310
00311 // Inline definitions
00312 inline const CbsStopReqArg& CbsStopReqArg::Cast(const StackMsgArgument& arg) {
00313     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CbsStopReqArg!\n");
00314     return ((CbsStopReqArg &) arg);
00315 }
00316
00317
00318 #endif // Apc_CbsStackMsgArgs_hpp
00319
Generated on Tue Jan 24 14:45:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CdStackMsgArgs.cpp File Reference

Apc/CdStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "CdStackMsgArgs.hpp"

Include dependency graph for CdStackMsgArgs.cpp:

Generated on Tue Jan 24 16:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CdStackMsgArgs.hpp File Reference

Apc/CdStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for CdStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallDeflectionIndArg
class | CallDeflectSsReqArg

Defines

#define | Apc_CdStackMsgArgs_hpp

Define Documentation

#define Apc_CdStackMsgArgs_hpp

Generated on Tue Jan 24 16:54:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CdStackMsgArgs.hpp Source File

Apc/CdStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\Apc\CdArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_CdStackMsgArgs_hpp)
00016 #define Apc_CdStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class CallDeflectionIndArg
00028     ====================================================================== */
00029
00031 class CallDeflectionIndArg : public StackMsgArgument {
00032     friend class CommonStackMsgArgsDestroyTableNode;
00033     public:
00034         CallDeflectionIndArg();
00035
00036         static const CallDeflectionIndArg& Cast(const StackMsgArgument& arg);
00037         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00038         const Tipd& GetTipd() const { return m_tipd; }
00039
00040         enum  {
00041             ID = 1069
00042             };
00043
00044     private:
00045
00046         static void Destroy(StackMsgArgument* arg) { delete ((CallDeflectionIndArg*) arg); }
00047
00048         Tipd m_tipd;
00049
00050     };
00051
00052 // Inline definitions
00053 inline const CallDeflectionIndArg& CallDeflectionIndArg::Cast(const StackMsgArgument& arg) {
00054     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallDeflectionIndArg!\n");
00055     return ((CallDeflectionIndArg &) arg);
00056 }
00057
00058
00059
00060 /*  ======================================================================
00061     Class CallDeflectSsReqArg
00062     ====================================================================== */
00063
00065 class CallDeflectSsReqArg : public StackMsgArgument {
00066     friend class CommonStackMsgArgsDestroyTableNode;
00067     public:
00068         CallDeflectSsReqArg(const Tipd& tipd, const CallRelatedSs& call_related_ss, const PhoneNumber& deflect_number);
00069         CallDeflectSsReqArg();
00070
00071         static const CallDeflectSsReqArg& Cast(const StackMsgArgument& arg);
00072         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00073         const Tipd& GetTipd() const { return m_tipd; }
00074         void SetCallRelatedSs(const CallRelatedSs& call_related_ss) { m_call_related_ss = call_related_ss; }
00075         const CallRelatedSs& GetCallRelatedSs() const { return m_call_related_ss; }
00076         void SetDeflectNumber(const PhoneNumber& deflect_number) { m_deflect_number = deflect_number; }
00077         const PhoneNumber& GetDeflectNumber() const { return m_deflect_number; }
00078
00079         enum  {
00080             ID = 2065
00081             };
00082
00083     private:
00084
00085         static void Destroy(StackMsgArgument* arg) { delete ((CallDeflectSsReqArg*) arg); }
00086
00087         Tipd m_tipd;
00088         CallRelatedSs m_call_related_ss;
00089         PhoneNumber m_deflect_number;
00090
00091     };
00092
00093 // Inline definitions
00094 inline const CallDeflectSsReqArg& CallDeflectSsReqArg::Cast(const StackMsgArgument& arg) {
00095     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallDeflectSsReqArg!\n");
00096     return ((CallDeflectSsReqArg &) arg);
00097 }
00098
00099
00100 #endif // Apc_CdStackMsgArgs_hpp
00101
Generated on Tue Jan 24 14:46:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ChvStackMsgArgs.cpp File Reference

Apc/ChvStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "ChvStackMsgArgs.hpp"

Include dependency graph for ChvStackMsgArgs.cpp:

Generated on Tue Jan 24 16:54:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ChvStackMsgArgs.hpp File Reference

Apc/ChvStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for ChvStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Chv1DisableIndArg
class | Chv1DisableReqArg
class | Chv1EnableIndArg
class | Chv1EnableReqArg
class | ChvChangeIndArg
class | ChvChangeReqArg
class | ChvRefreshIndArg
class | ChvUnblockIndArg
class | ChvUnblockReqArg
class | ChvVerifyIndArg
class | ChvVerifyReqArg
class | PinDisableIndArg
class | PinDisableReqArg
class | PinEnableIndArg
class | PinEnableReqArg

Defines

#define | Apc_ChvStackMsgArgs_hpp

Variables

const UINT8 | c_chv_padding_char = 0xff

Define Documentation

#define Apc_ChvStackMsgArgs_hpp

Variable Documentation

const UINT8 c_chv_padding_char = 0xff

Generated on Tue Jan 24 16:54:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ChvStackMsgArgs.hpp Source File

Apc/ChvStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\grossau_latest_sv\lnz_apoxi\Apoxi\Apc\ChvArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_ChvStackMsgArgs_hpp)
00016 #define Apc_ChvStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020
00021
00022 const UINT8 c_chv_padding_char  = 0xff;
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class ChvVerifyIndArg
00030     ====================================================================== */
00031
00033 class ChvVerifyIndArg : public StackMsgArgument {
00034     friend class CommonStackMsgArgsDestroyTableNode;
00035     public:
00036         ChvVerifyIndArg();
00037
00038         static const ChvVerifyIndArg& Cast(const StackMsgArgument& arg);
00039         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00040         const ChvNo& GetChvno() const { return m_chvno; }
00041         void SetStatus(const ChvStatus& status) { m_status = status; }
00042         const ChvStatus& GetStatus() const { return m_status; }
00043         void SetChvAttempts(const ChvAttemptsStruct& chv_attempts) { m_chv_attempts = chv_attempts; }
00044         const ChvAttemptsStruct& GetChvAttempts() const { return m_chv_attempts; }
00045
00046         enum  {
00047             ID = 1040
00048             };
00049
00050     private:
00051
00052         static void Destroy(StackMsgArgument* arg) { delete ((ChvVerifyIndArg*) arg); }
00053
00054         ChvNo m_chvno;
00055         ChvStatus m_status;
00056         ChvAttemptsStruct m_chv_attempts;
00057
00058     };
00059
00060 // Inline definitions
00061 inline const ChvVerifyIndArg& ChvVerifyIndArg::Cast(const StackMsgArgument& arg) {
00062     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChvVerifyIndArg!\n");
00063     return ((ChvVerifyIndArg &) arg);
00064 }
00065
00066
00067
00068 /*  ======================================================================
00069     Class ChvChangeIndArg
00070     ====================================================================== */
00071
00073 class ChvChangeIndArg : public StackMsgArgument {
00074     friend class CommonStackMsgArgsDestroyTableNode;
00075     public:
00076         ChvChangeIndArg();
00077
00078         static const ChvChangeIndArg& Cast(const StackMsgArgument& arg);
00079         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00080         const ChvNo& GetChvno() const { return m_chvno; }
00081         void SetStatus(const ChvStatus& status) { m_status = status; }
00082         const ChvStatus& GetStatus() const { return m_status; }
00083         void SetChvAttempts(const ChvAttemptsStruct& chv_attempts) { m_chv_attempts = chv_attempts; }
00084         const ChvAttemptsStruct& GetChvAttempts() const { return m_chv_attempts; }
00085
00086         enum  {
00087             ID = 1041
00088             };
00089
00090     private:
00091
00092         static void Destroy(StackMsgArgument* arg) { delete ((ChvChangeIndArg*) arg); }
00093
00094         ChvNo m_chvno;
00095         ChvStatus m_status;
00096         ChvAttemptsStruct m_chv_attempts;
00097
00098     };
00099
00100 // Inline definitions
00101 inline const ChvChangeIndArg& ChvChangeIndArg::Cast(const StackMsgArgument& arg) {
00102     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChvChangeIndArg!\n");
00103     return ((ChvChangeIndArg &) arg);
00104 }
00105
00106
00107
00108 /*  ======================================================================
00109     Class ChvUnblockIndArg
00110     ====================================================================== */
00111
00113 class ChvUnblockIndArg : public StackMsgArgument {
00114     friend class CommonStackMsgArgsDestroyTableNode;
00115     public:
00116         ChvUnblockIndArg();
00117
00118         static const ChvUnblockIndArg& Cast(const StackMsgArgument& arg);
00119         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00120         const ChvNo& GetChvno() const { return m_chvno; }
00121         void SetStatus(const ChvStatus& status) { m_status = status; }
00122         const ChvStatus& GetStatus() const { return m_status; }
00123         void SetChvAttempts(const ChvAttemptsStruct& chv_attempts) { m_chv_attempts = chv_attempts; }
00124         const ChvAttemptsStruct& GetChvAttempts() const { return m_chv_attempts; }
00125
00126         enum  {
00127             ID = 1042
00128             };
00129
00130     private:
00131
00132         static void Destroy(StackMsgArgument* arg) { delete ((ChvUnblockIndArg*) arg); }
00133
00134         ChvNo m_chvno;
00135         ChvStatus m_status;
00136         ChvAttemptsStruct m_chv_attempts;
00137
00138     };
00139
00140 // Inline definitions
00141 inline const ChvUnblockIndArg& ChvUnblockIndArg::Cast(const StackMsgArgument& arg) {
00142     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChvUnblockIndArg!\n");
00143     return ((ChvUnblockIndArg &) arg);
00144 }
00145
00146
00147
00148 /*  ======================================================================
00149     Class Chv1EnableIndArg
00150     ====================================================================== */
00151
00153 class Chv1EnableIndArg : public StackMsgArgument {
00154     friend class CommonStackMsgArgsDestroyTableNode;
00155     public:
00156         Chv1EnableIndArg();
00157
00158         static const Chv1EnableIndArg& Cast(const StackMsgArgument& arg);
00159         void SetStatus(const ChvStatus& status) { m_status = status; }
00160         const ChvStatus& GetStatus() const { return m_status; }
00161         void SetChvAttempts(const ChvAttemptsStruct& chv_attempts) { m_chv_attempts = chv_attempts; }
00162         const ChvAttemptsStruct& GetChvAttempts() const { return m_chv_attempts; }
00163
00164         enum  {
00165             ID = 1043
00166             };
00167
00168     private:
00169
00170         static void Destroy(StackMsgArgument* arg) { delete ((Chv1EnableIndArg*) arg); }
00171
00172         ChvStatus m_status;
00173         ChvAttemptsStruct m_chv_attempts;
00174
00175     };
00176
00177 // Inline definitions
00178 inline const Chv1EnableIndArg& Chv1EnableIndArg::Cast(const StackMsgArgument& arg) {
00179     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to Chv1EnableIndArg!\n");
00180     return ((Chv1EnableIndArg &) arg);
00181 }
00182
00183
00184
00185 /*  ======================================================================
00186     Class Chv1DisableIndArg
00187     ====================================================================== */
00188
00190 class Chv1DisableIndArg : public StackMsgArgument {
00191     friend class CommonStackMsgArgsDestroyTableNode;
00192     public:
00193         Chv1DisableIndArg();
00194
00195         static const Chv1DisableIndArg& Cast(const StackMsgArgument& arg);
00196         void SetStatus(const ChvStatus& status) { m_status = status; }
00197         const ChvStatus& GetStatus() const { return m_status; }
00198         void SetChvAttempts(const ChvAttemptsStruct& chv_attempts) { m_chv_attempts = chv_attempts; }
00199         const ChvAttemptsStruct& GetChvAttempts() const { return m_chv_attempts; }
00200
00201         enum  {
00202             ID = 1044
00203             };
00204
00205     private:
00206
00207         static void Destroy(StackMsgArgument* arg) { delete ((Chv1DisableIndArg*) arg); }
00208
00209         ChvStatus m_status;
00210         ChvAttemptsStruct m_chv_attempts;
00211
00212     };
00213
00214 // Inline definitions
00215 inline const Chv1DisableIndArg& Chv1DisableIndArg::Cast(const StackMsgArgument& arg) {
00216     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to Chv1DisableIndArg!\n");
00217     return ((Chv1DisableIndArg &) arg);
00218 }
00219
00220
00221
00222 /*  ======================================================================
00223     Class ChvRefreshIndArg
00224     ====================================================================== */
00225
00227 class ChvRefreshIndArg : public StackMsgArgument {
00228     friend class CommonStackMsgArgsDestroyTableNode;
00229     public:
00230         ChvRefreshIndArg();
00231
00232         static const ChvRefreshIndArg& Cast(const StackMsgArgument& arg);
00233         void SetChvAction(const ChvAction& chv_action) { m_chv_action = chv_action; }
00234         const ChvAction& GetChvAction() const { return m_chv_action; }
00235         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00236         const ChvNo& GetChvno() const { return m_chvno; }
00237         void SetStatus(const ChvStatus& status) { m_status = status; }
00238         const ChvStatus& GetStatus() const { return m_status; }
00239         void SetResult(BOOLEAN result) { m_result = result; }
00240         BOOLEAN IsResult() const { return m_result; }
00241         void SetChvAttempts(const ChvAttemptsStruct& chv_attempts) { m_chv_attempts = chv_attempts; }
00242         const ChvAttemptsStruct& GetChvAttempts() const { return m_chv_attempts; }
00243
00244         enum  {
00245             ID = 1045
00246             };
00247
00248     private:
00249
00250         static void Destroy(StackMsgArgument* arg) { delete ((ChvRefreshIndArg*) arg); }
00251
00252         ChvAction m_chv_action;
00253         ChvNo m_chvno;
00254         ChvStatus m_status;
00255         BOOLEAN m_result;
00256         ChvAttemptsStruct m_chv_attempts;
00257
00258     };
00259
00260 // Inline definitions
00261 inline const ChvRefreshIndArg& ChvRefreshIndArg::Cast(const StackMsgArgument& arg) {
00262     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChvRefreshIndArg!\n");
00263     return ((ChvRefreshIndArg &) arg);
00264 }
00265
00266
00267
00268 /*  ======================================================================
00269     Class PinEnableIndArg
00270     ====================================================================== */
00271
00273 class PinEnableIndArg : public StackMsgArgument {
00274     friend class CommonStackMsgArgsDestroyTableNode;
00275     public:
00276         PinEnableIndArg();
00277
00278         static const PinEnableIndArg& Cast(const StackMsgArgument& arg);
00279         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00280         const ChvNo& GetChvno() const { return m_chvno; }
00281         void SetResult(BOOLEAN result) { m_result = result; }
00282         BOOLEAN IsResult() const { return m_result; }
00283         void SetAddResult(INT8 add_result) { m_add_result = add_result; }
00284         INT8 GetAddResult() const { return m_add_result; }
00285
00286         enum  {
00287             ID = 1046
00288             };
00289
00290     private:
00291
00292         static void Destroy(StackMsgArgument* arg) { delete ((PinEnableIndArg*) arg); }
00293
00294         ChvNo m_chvno;
00295         BOOLEAN m_result;
00296         INT8 m_add_result;
00297
00298     };
00299
00300 // Inline definitions
00301 inline const PinEnableIndArg& PinEnableIndArg::Cast(const StackMsgArgument& arg) {
00302     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PinEnableIndArg!\n");
00303     return ((PinEnableIndArg &) arg);
00304 }
00305
00306
00307
00308 /*  ======================================================================
00309     Class PinDisableIndArg
00310     ====================================================================== */
00311
00313 class PinDisableIndArg : public StackMsgArgument {
00314     friend class CommonStackMsgArgsDestroyTableNode;
00315     public:
00316         PinDisableIndArg();
00317
00318         static const PinDisableIndArg& Cast(const StackMsgArgument& arg);
00319         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00320         const ChvNo& GetChvno() const { return m_chvno; }
00321         void SetResult(BOOLEAN result) { m_result = result; }
00322         BOOLEAN IsResult() const { return m_result; }
00323         void SetAddResult(INT8 add_result) { m_add_result = add_result; }
00324         INT8 GetAddResult() const { return m_add_result; }
00325
00326         enum  {
00327             ID = 1047
00328             };
00329
00330     private:
00331
00332         static void Destroy(StackMsgArgument* arg) { delete ((PinDisableIndArg*) arg); }
00333
00334         ChvNo m_chvno;
00335         BOOLEAN m_result;
00336         INT8 m_add_result;
00337
00338     };
00339
00340 // Inline definitions
00341 inline const PinDisableIndArg& PinDisableIndArg::Cast(const StackMsgArgument& arg) {
00342     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PinDisableIndArg!\n");
00343     return ((PinDisableIndArg &) arg);
00344 }
00345
00346
00347
00348 /*  ======================================================================
00349     Class ChvVerifyReqArg
00350     ====================================================================== */
00351
00353 class ChvVerifyReqArg : public StackMsgArgument {
00354     friend class CommonStackMsgArgsDestroyTableNode;
00355     public:
00356         ChvVerifyReqArg(const ChvNo& chvno, const CHAR* pin);
00357         ChvVerifyReqArg(const ChvNo& chvno, const T_SI_CHV& chv);
00358         ChvVerifyReqArg();
00359
00360         static const ChvVerifyReqArg& Cast(const StackMsgArgument& arg);
00361         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00362         const ChvNo& GetChvno() const { return m_chvno; }
00363         void SetChv(const T_SI_CHV& chv) { m_chv = chv; }
00364         const T_SI_CHV& GetChv() const { return m_chv; }
00365
00366         enum  {
00367             ID = 2040
00368             };
00369
00370     private:
00371
00372         static void Destroy(StackMsgArgument* arg) { delete ((ChvVerifyReqArg*) arg); }
00373
00374         ChvNo m_chvno;
00375         T_SI_CHV m_chv;
00376
00377     };
00378
00379 // Inline definitions
00380 inline const ChvVerifyReqArg& ChvVerifyReqArg::Cast(const StackMsgArgument& arg) {
00381     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChvVerifyReqArg!\n");
00382     return ((ChvVerifyReqArg &) arg);
00383 }
00384
00385
00386
00387 /*  ======================================================================
00388     Class ChvChangeReqArg
00389     ====================================================================== */
00390
00392 class ChvChangeReqArg : public StackMsgArgument {
00393     friend class CommonStackMsgArgsDestroyTableNode;
00394     public:
00395         ChvChangeReqArg(const ChvNo& chvno, const CHAR* oldpin, const CHAR* newpin);
00396         ChvChangeReqArg(const ChvNo& chvno, const T_SI_CHV& oldchv, const T_SI_CHV& newchv);
00397         ChvChangeReqArg();
00398
00399         static const ChvChangeReqArg& Cast(const StackMsgArgument& arg);
00400         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00401         const ChvNo& GetChvno() const { return m_chvno; }
00402         void SetOldchv(const T_SI_CHV& oldchv) { m_oldchv = oldchv; }
00403         const T_SI_CHV& GetOldchv() const { return m_oldchv; }
00404         void SetNewchv(const T_SI_CHV& newchv) { m_newchv = newchv; }
00405         const T_SI_CHV& GetNewchv() const { return m_newchv; }
00406
00407         enum  {
00408             ID = 2041
00409             };
00410
00411     private:
00412
00413         static void Destroy(StackMsgArgument* arg) { delete ((ChvChangeReqArg*) arg); }
00414
00415         ChvNo m_chvno;
00416         T_SI_CHV m_oldchv;
00417         T_SI_CHV m_newchv;
00418
00419     };
00420
00421 // Inline definitions
00422 inline const ChvChangeReqArg& ChvChangeReqArg::Cast(const StackMsgArgument& arg) {
00423     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChvChangeReqArg!\n");
00424     return ((ChvChangeReqArg &) arg);
00425 }
00426
00427
00428
00429 /*  ======================================================================
00430     Class ChvUnblockReqArg
00431     ====================================================================== */
00432
00434 class ChvUnblockReqArg : public StackMsgArgument {
00435     friend class CommonStackMsgArgsDestroyTableNode;
00436     public:
00437         ChvUnblockReqArg(const ChvNo& chvno, const CHAR* unblockpin, const CHAR* newpin);
00438         ChvUnblockReqArg(const ChvNo& chvno, const T_SI_CHV& unblockchv, const T_SI_CHV& newchv);
00439         ChvUnblockReqArg();
00440
00441         static const ChvUnblockReqArg& Cast(const StackMsgArgument& arg);
00442         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00443         const ChvNo& GetChvno() const { return m_chvno; }
00444         void SetUnblockchv(const T_SI_CHV& unblockchv) { m_unblockchv = unblockchv; }
00445         const T_SI_CHV& GetUnblockchv() const { return m_unblockchv; }
00446         void SetNewchv(const T_SI_CHV& newchv) { m_newchv = newchv; }
00447         const T_SI_CHV& GetNewchv() const { return m_newchv; }
00448
00449         enum  {
00450             ID = 2042
00451             };
00452
00453     private:
00454
00455         static void Destroy(StackMsgArgument* arg) { delete ((ChvUnblockReqArg*) arg); }
00456
00457         ChvNo m_chvno;
00458         T_SI_CHV m_unblockchv;
00459         T_SI_CHV m_newchv;
00460
00461     };
00462
00463 // Inline definitions
00464 inline const ChvUnblockReqArg& ChvUnblockReqArg::Cast(const StackMsgArgument& arg) {
00465     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChvUnblockReqArg!\n");
00466     return ((ChvUnblockReqArg &) arg);
00467 }
00468
00469
00470
00471 /*  ======================================================================
00472     Class Chv1EnableReqArg
00473     ====================================================================== */
00474
00476 class Chv1EnableReqArg : public StackMsgArgument {
00477     friend class CommonStackMsgArgsDestroyTableNode;
00478     public:
00479         Chv1EnableReqArg(const CHAR* pin);
00480         Chv1EnableReqArg(const T_SI_CHV& chv);
00481         Chv1EnableReqArg();
00482
00483         static const Chv1EnableReqArg& Cast(const StackMsgArgument& arg);
00484         void SetChv(const T_SI_CHV& chv) { m_chv = chv; }
00485         const T_SI_CHV& GetChv() const { return m_chv; }
00486
00487         enum  {
00488             ID = 2043
00489             };
00490
00491     private:
00492
00493         static void Destroy(StackMsgArgument* arg) { delete ((Chv1EnableReqArg*) arg); }
00494
00495         T_SI_CHV m_chv;
00496
00497     };
00498
00499 // Inline definitions
00500 inline const Chv1EnableReqArg& Chv1EnableReqArg::Cast(const StackMsgArgument& arg) {
00501     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to Chv1EnableReqArg!\n");
00502     return ((Chv1EnableReqArg &) arg);
00503 }
00504
00505
00506
00507 /*  ======================================================================
00508     Class Chv1DisableReqArg
00509     ====================================================================== */
00510
00512 class Chv1DisableReqArg : public StackMsgArgument {
00513     friend class CommonStackMsgArgsDestroyTableNode;
00514     public:
00515         Chv1DisableReqArg(const CHAR* pin);
00516         Chv1DisableReqArg(const T_SI_CHV& chv);
00517         Chv1DisableReqArg();
00518
00519         static const Chv1DisableReqArg& Cast(const StackMsgArgument& arg);
00520         void SetChv(const T_SI_CHV& chv) { m_chv = chv; }
00521         const T_SI_CHV& GetChv() const { return m_chv; }
00522
00523         enum  {
00524             ID = 2044
00525             };
00526
00527     private:
00528
00529         static void Destroy(StackMsgArgument* arg) { delete ((Chv1DisableReqArg*) arg); }
00530
00531         T_SI_CHV m_chv;
00532
00533     };
00534
00535 // Inline definitions
00536 inline const Chv1DisableReqArg& Chv1DisableReqArg::Cast(const StackMsgArgument& arg) {
00537     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to Chv1DisableReqArg!\n");
00538     return ((Chv1DisableReqArg &) arg);
00539 }
00540
00541
00542
00543 /*  ======================================================================
00544     Class PinEnableReqArg
00545     ====================================================================== */
00546
00548 class PinEnableReqArg : public StackMsgArgument {
00549     friend class CommonStackMsgArgsDestroyTableNode;
00550     public:
00551         PinEnableReqArg(const ChvNo& chvno, const CHAR* pin);
00552         PinEnableReqArg(const ChvNo& chvno, const T_SI_CHV& chv);
00553         PinEnableReqArg();
00554
00555         static const PinEnableReqArg& Cast(const StackMsgArgument& arg);
00556         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00557         const ChvNo& GetChvno() const { return m_chvno; }
00558         void SetChv(const T_SI_CHV& chv) { m_chv = chv; }
00559         const T_SI_CHV& GetChv() const { return m_chv; }
00560
00561         enum  {
00562             ID = 2045
00563             };
00564
00565     private:
00566
00567         static void Destroy(StackMsgArgument* arg) { delete ((PinEnableReqArg*) arg); }
00568
00569         ChvNo m_chvno;
00570         T_SI_CHV m_chv;
00571
00572     };
00573
00574 // Inline definitions
00575 inline const PinEnableReqArg& PinEnableReqArg::Cast(const StackMsgArgument& arg) {
00576     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PinEnableReqArg!\n");
00577     return ((PinEnableReqArg &) arg);
00578 }
00579
00580
00581
00582 /*  ======================================================================
00583     Class PinDisableReqArg
00584     ====================================================================== */
00585
00587 class PinDisableReqArg : public StackMsgArgument {
00588     friend class CommonStackMsgArgsDestroyTableNode;
00589     public:
00590         PinDisableReqArg(const ChvNo& chvno, const CHAR* pin);
00591         PinDisableReqArg(const ChvNo& chvno, const T_SI_CHV& chv);
00592         PinDisableReqArg();
00593
00594         static const PinDisableReqArg& Cast(const StackMsgArgument& arg);
00595         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00596         const ChvNo& GetChvno() const { return m_chvno; }
00597         void SetChv(const T_SI_CHV& chv) { m_chv = chv; }
00598         const T_SI_CHV& GetChv() const { return m_chv; }
00599
00600         enum  {
00601             ID = 2046
00602             };
00603
00604     private:
00605
00606         static void Destroy(StackMsgArgument* arg) { delete ((PinDisableReqArg*) arg); }
00607
00608         ChvNo m_chvno;
00609         T_SI_CHV m_chv;
00610
00611     };
00612
00613 // Inline definitions
00614 inline const PinDisableReqArg& PinDisableReqArg::Cast(const StackMsgArgument& arg) {
00615     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PinDisableReqArg!\n");
00616     return ((PinDisableReqArg &) arg);
00617 }
00618
00619
00620 #endif // Apc_ChvStackMsgArgs_hpp
00621
Generated on Tue Jan 24 14:46:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CommandType.cpp File Reference

Apc/CommandType.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/CommandType.hpp"

Include dependency graph for CommandType.cpp:

Generated on Tue Jan 24 16:54:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CommandType.hpp File Reference

Apc/CommandType.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for CommandType.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CommandType
3GPP TS 23.040 V5.1.0 [9.2.3.19] More...

Defines

#define | Apc_CommandType_hpp

Define Documentation

#define Apc_CommandType_hpp

Generated on Tue Jan 24 16:54:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CommandType.hpp Source File

Apc/CommandType.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_CommandType_hpp)
00009 #define Apc_CommandType_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014
00015 /*  ========================================================================
00016     TP-CT: Transfer Protocol - Command Type - 3GPP TS 23.040 V5.1.0 [9.2.3.19]
00017     ========================================================================*/
00019 class CommandType {
00020     public:
00022         enum Type { // please do not change order
00024             Enquiry = 0,
00026             CancelStatusReportRequest,
00028             Delete,
00030             EnableStatusReportRequest,
00032             ReservedType,
00034             ServiceCenterSpecificType,
00036             InvalidType,
00037         };
00038
00040         CommandType();
00042         CommandType(UINT8 incoming_byte);
00043
00045         UINT8 Get() const { return (m_bit_field.Get()); }
00046
00048         Type GetType() const;
00050         void SetType(Type type);
00051
00053         void Clear() { m_bit_field.Clear();}
00054
00055     private:
00056         BitField8 m_bit_field;
00057 };
00058
00059
00060 #endif  // Apc_CommandType_hpp
00061
00062
Generated on Tue Jan 24 14:46:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CommonStackMsgArgs.cpp File Reference

Apc/CommonStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "CommonStackMsgArgs.hpp"

Include dependency graph for CommonStackMsgArgs.cpp:

Generated on Tue Jan 24 16:54:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CommonStackMsgArgs.hpp File Reference

Apc/CommonStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/CallMiscStackMsgArgs.hpp>
#include <Apc/CbsStackMsgArgs.hpp>
#include <Apc/ChvStackMsgArgs.hpp>
#include <Apc/CrssStackMsgArgs.hpp>
#include <Apc/ImageStackMsgArgs.hpp>
#include <Apc/MiscStackMsgArgs.hpp>
#include <Apc/MocStackMsgArgs.hpp>
#include <Apc/MtcStackMsgArgs.hpp>
#include <Apc/NetworkStackMsgArgs.hpp>
#include <Apc/PhoneBookStackMsgArgs.hpp>
#include <Apc/PowerStackMsgArgs.hpp>
#include <Apc/SimMiscStackMsgArgs.hpp>
#include <Apc/SimTkStackMsgArgs.hpp>
#include <Apc/SmsStackMsgArgs.hpp>
#include <Apc/SsStackMsgArgs.hpp>
#include <Apc/PlmnStackMsgArgs.hpp>
#include <Apc/CdStackMsgArgs.hpp>
#include <Apc/OmStackMsgArgs.hpp>
#include <Apc/MdhSmsStackMsgArgs.hpp>
#include <Apc/AtcStackMsgArgs.hpp>

Include dependency graph for CommonStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CommonStackMsgArgsDestroyTableNode

Defines

#define | Apc_CommonStackMsgArgs_hpp

Define Documentation

#define Apc_CommonStackMsgArgs_hpp

Generated on Tue Jan 24 16:55:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CommonStackMsgArgs.hpp Source File

Apc/CommonStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Apc\SimMiscArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_CommonStackMsgArgs_hpp)
00016 #define Apc_CommonStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/CallMiscStackMsgArgs.hpp>
00020 #include <Apc/CbsStackMsgArgs.hpp>
00021 #include <Apc/ChvStackMsgArgs.hpp>
00022 #include <Apc/CrssStackMsgArgs.hpp>
00023 #include <Apc/ImageStackMsgArgs.hpp>
00024 #include <Apc/MiscStackMsgArgs.hpp>
00025 #include <Apc/MocStackMsgArgs.hpp>
00026 #include <Apc/MtcStackMsgArgs.hpp>
00027 #include <Apc/NetworkStackMsgArgs.hpp>
00028 #include <Apc/PhoneBookStackMsgArgs.hpp>
00029 #include <Apc/PowerStackMsgArgs.hpp>
00030 #include <Apc/SimMiscStackMsgArgs.hpp>
00031 #include <Apc/SimTkStackMsgArgs.hpp>
00032 #include <Apc/SmsStackMsgArgs.hpp>
00033 #include <Apc/SsStackMsgArgs.hpp>
00034 #include <Apc/PlmnStackMsgArgs.hpp>
00035 #include <Apc/CdStackMsgArgs.hpp>
00036 #include <Apc/OmStackMsgArgs.hpp>
00037 #include <Apc/MdhSmsStackMsgArgs.hpp>
00038 #include <Apc/AtcStackMsgArgs.hpp>
00039
00040
00041 /* ----------------------------------------------------------------------
00042     Classes
00043     ---------------------------------------------------------------------- */
00044
00045 /*  ======================================================================
00046     Class CommonStackMsgArgsDestroyTableNode
00047     ====================================================================== */
00048
00049 class CommonStackMsgArgsDestroyTableNode : public StackMsgArgDestroyTableNode {
00050     public:
00051
00052         static CommonStackMsgArgsDestroyTableNode* GetInstance();
00053
00054     private:
00055         CommonStackMsgArgsDestroyTableNode();
00056
00057
00058         static CommonStackMsgArgsDestroyTableNode* m_node;
00059         static const ArgumentDestroyEntry m_destroy_table[];
00060
00061     };
00062
00063 #endif // Apc_CommonStackMsgArgs_hpp
00064
Generated on Tue Jan 24 14:46:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CrssStackMsgArgs.cpp File Reference

Apc/CrssStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "CrssStackMsgArgs.hpp"

Include dependency graph for CrssStackMsgArgs.cpp:

Generated on Tue Jan 24 16:55:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CrssStackMsgArgs.hpp File Reference

Apc/CrssStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for CrssStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AocIndArg
class | CallHoldCnfArg
class | CallHoldRejArg
class | CallRelatedSsCnfArg
class | CallRelatedSsRejArg
class | CallRelatedSsReqArg
class | ChargeIndArg
class | ChargeReqArg
class | ChargeUnitsIndArg
class | ChargeUnitsReqArg
class | EctCnfArg
class | MptyCnfArg
class | SetAutoChargeArg
class | SetChargeUnitsArg

Defines

#define | Apc_CrssStackMsgArgs_hpp

Define Documentation

#define Apc_CrssStackMsgArgs_hpp

Generated on Tue Jan 24 16:55:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/CrssStackMsgArgs.hpp Source File

Apc/CrssStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\Apc\CrssArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_CrssStackMsgArgs_hpp)
00016 #define Apc_CrssStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class CallRelatedSsCnfArg
00028     ====================================================================== */
00029
00030 class CallRelatedSsCnfArg : public StackMsgArgument {
00031     friend class CommonStackMsgArgsDestroyTableNode;
00032     public:
00033         CallRelatedSsCnfArg();
00034
00035         static const CallRelatedSsCnfArg& Cast(const StackMsgArgument& arg);
00036         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00037         const Tipd& GetTipd() const { return m_tipd; }
00038
00039         enum  {
00040             ID = 1060
00041             };
00042
00043     private:
00044
00045         static void Destroy(StackMsgArgument* arg) { delete ((CallRelatedSsCnfArg*) arg); }
00046
00047         Tipd m_tipd;
00048
00049     };
00050
00051 // Inline definitions
00052 inline const CallRelatedSsCnfArg& CallRelatedSsCnfArg::Cast(const StackMsgArgument& arg) {
00053     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallRelatedSsCnfArg!\n");
00054     return ((CallRelatedSsCnfArg &) arg);
00055 }
00056
00057
00058
00059 /*  ======================================================================
00060     Class CallRelatedSsRejArg
00061     ====================================================================== */
00062
00063 class CallRelatedSsRejArg : public StackMsgArgument {
00064     friend class CommonStackMsgArgsDestroyTableNode;
00065     public:
00066         CallRelatedSsRejArg();
00067
00068         static const CallRelatedSsRejArg& Cast(const StackMsgArgument& arg);
00069         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00070         const Tipd& GetTipd() const { return m_tipd; }
00071
00072         enum  {
00073             ID = 1061
00074             };
00075
00076     private:
00077
00078         static void Destroy(StackMsgArgument* arg) { delete ((CallRelatedSsRejArg*) arg); }
00079
00080         Tipd m_tipd;
00081
00082     };
00083
00084 // Inline definitions
00085 inline const CallRelatedSsRejArg& CallRelatedSsRejArg::Cast(const StackMsgArgument& arg) {
00086     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallRelatedSsRejArg!\n");
00087     return ((CallRelatedSsRejArg &) arg);
00088 }
00089
00090
00091
00092 /*  ======================================================================
00093     Class CallHoldCnfArg
00094     ====================================================================== */
00095
00096 class CallHoldCnfArg : public StackMsgArgument {
00097     friend class CommonStackMsgArgsDestroyTableNode;
00098     public:
00099         CallHoldCnfArg();
00100
00101         static const CallHoldCnfArg& Cast(const StackMsgArgument& arg);
00102         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00103         const Tipd& GetTipd() const { return m_tipd; }
00104         void SetCrssState(const CallRelatedSsState& crss_state) { m_crss_state = crss_state; }
00105         const CallRelatedSsState& GetCrssState() const { return m_crss_state; }
00106
00107         enum  {
00108             ID = 1062
00109             };
00110
00111     private:
00112
00113         static void Destroy(StackMsgArgument* arg) { delete ((CallHoldCnfArg*) arg); }
00114
00115         Tipd m_tipd;
00116         CallRelatedSsState m_crss_state;
00117
00118     };
00119
00120 // Inline definitions
00121 inline const CallHoldCnfArg& CallHoldCnfArg::Cast(const StackMsgArgument& arg) {
00122     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallHoldCnfArg!\n");
00123     return ((CallHoldCnfArg &) arg);
00124 }
00125
00126
00127
00128 /*  ======================================================================
00129     Class CallHoldRejArg
00130     ====================================================================== */
00131
00133 class CallHoldRejArg : public StackMsgArgument {
00134     friend class CommonStackMsgArgsDestroyTableNode;
00135     public:
00136         CallHoldRejArg();
00137
00138         static const CallHoldRejArg& Cast(const StackMsgArgument& arg);
00139         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00140         const Tipd& GetTipd() const { return m_tipd; }
00141         void SetCrssState(const CallRelatedSsState& crss_state) { m_crss_state = crss_state; }
00142         const CallRelatedSsState& GetCrssState() const { return m_crss_state; }
00143         void SetCallDiscCause(const CallErrorCause& call_disc_cause) { m_call_disc_cause = call_disc_cause; }
00144         const CallErrorCause& GetCallDiscCause() const { return m_call_disc_cause; }
00145
00146         enum  {
00147             ID = 1063
00148             };
00149
00150     private:
00151
00152         static void Destroy(StackMsgArgument* arg) { delete ((CallHoldRejArg*) arg); }
00153
00154         Tipd m_tipd;
00155         CallRelatedSsState m_crss_state;
00156         CallErrorCause m_call_disc_cause;
00157
00158     };
00159
00160 // Inline definitions
00161 inline const CallHoldRejArg& CallHoldRejArg::Cast(const StackMsgArgument& arg) {
00162     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallHoldRejArg!\n");
00163     return ((CallHoldRejArg &) arg);
00164 }
00165
00166
00167
00168 /*  ======================================================================
00169     Class MptyCnfArg
00170     ====================================================================== */
00171
00173 class MptyCnfArg : public StackMsgArgument {
00174     friend class CommonStackMsgArgsDestroyTableNode;
00175     public:
00176         MptyCnfArg();
00177
00178         static const MptyCnfArg& Cast(const StackMsgArgument& arg);
00179         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00180         const Tipd& GetTipd() const { return m_tipd; }
00181         void SetCrss(const CallRelatedSs& crss) { m_crss = crss; }
00182         const CallRelatedSs& GetCrss() const { return m_crss; }
00183
00184         enum  {
00185             ID = 1064
00186             };
00187
00188     private:
00189
00190         static void Destroy(StackMsgArgument* arg) { delete ((MptyCnfArg*) arg); }
00191
00192         Tipd m_tipd;
00193         CallRelatedSs m_crss;
00194
00195     };
00196
00197 // Inline definitions
00198 inline const MptyCnfArg& MptyCnfArg::Cast(const StackMsgArgument& arg) {
00199     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MptyCnfArg!\n");
00200     return ((MptyCnfArg &) arg);
00201 }
00202
00203
00204
00205 /*  ======================================================================
00206     Class EctCnfArg
00207     ====================================================================== */
00208
00210 class EctCnfArg : public StackMsgArgument {
00211     friend class CommonStackMsgArgsDestroyTableNode;
00212     public:
00213         EctCnfArg();
00214
00215         static const EctCnfArg& Cast(const StackMsgArgument& arg);
00216         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00217         const Tipd& GetTipd() const { return m_tipd; }
00218
00219         enum  {
00220             ID = 1065
00221             };
00222
00223     private:
00224
00225         static void Destroy(StackMsgArgument* arg) { delete ((EctCnfArg*) arg); }
00226
00227         Tipd m_tipd;
00228
00229     };
00230
00231 // Inline definitions
00232 inline const EctCnfArg& EctCnfArg::Cast(const StackMsgArgument& arg) {
00233     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to EctCnfArg!\n");
00234     return ((EctCnfArg &) arg);
00235 }
00236
00237
00238
00239 /*  ======================================================================
00240     Class AocIndArg
00241     ====================================================================== */
00242
00244 class AocIndArg : public StackMsgArgument {
00245     friend class CommonStackMsgArgsDestroyTableNode;
00246     public:
00247         AocIndArg();
00248
00249         static const AocIndArg& Cast(const StackMsgArgument& arg);
00250         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00251         const Tipd& GetTipd() const { return m_tipd; }
00252         void SetStatus(const CallRelatedSsCode& status) { m_status = status; }
00253         const CallRelatedSsCode& GetStatus() const { return m_status; }
00254
00255         enum  {
00256             ID = 1066
00257             };
00258
00259     private:
00260
00261         static void Destroy(StackMsgArgument* arg) { delete ((AocIndArg*) arg); }
00262
00263         Tipd m_tipd;
00264         CallRelatedSsCode m_status;
00265
00266     };
00267
00268 // Inline definitions
00269 inline const AocIndArg& AocIndArg::Cast(const StackMsgArgument& arg) {
00270     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AocIndArg!\n");
00271     return ((AocIndArg &) arg);
00272 }
00273
00274
00275
00276 /*  ======================================================================
00277     Class ChargeIndArg
00278     ====================================================================== */
00279
00281 class ChargeIndArg : public StackMsgArgument {
00282     friend class CommonStackMsgArgsDestroyTableNode;
00283     public:
00284         ChargeIndArg();
00285
00286         static const ChargeIndArg& Cast(const StackMsgArgument& arg);
00287         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00288         const Tipd& GetTipd() const { return m_tipd; }
00289         void SetThisCallCharge(const AocChargeData& this_call_charge) { m_this_call_charge = this_call_charge; }
00290         const AocChargeData& GetThisCallCharge() const { return m_this_call_charge; }
00291         void SetAllCallsCharge(const AocChargeData& all_calls_charge) { m_all_calls_charge = all_calls_charge; }
00292         const AocChargeData& GetAllCallsCharge() const { return m_all_calls_charge; }
00293
00294         enum  {
00295             ID = 1067
00296             };
00297
00298     private:
00299
00300         static void Destroy(StackMsgArgument* arg) { delete ((ChargeIndArg*) arg); }
00301
00302         Tipd m_tipd;
00303         AocChargeData m_this_call_charge;
00304         AocChargeData m_all_calls_charge;
00305
00306     };
00307
00308 // Inline definitions
00309 inline const ChargeIndArg& ChargeIndArg::Cast(const StackMsgArgument& arg) {
00310     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChargeIndArg!\n");
00311     return ((ChargeIndArg &) arg);
00312 }
00313
00314
00315
00316 /*  ======================================================================
00317     Class ChargeUnitsIndArg
00318     ====================================================================== */
00319
00321 class ChargeUnitsIndArg : public StackMsgArgument {
00322     friend class CommonStackMsgArgsDestroyTableNode;
00323     public:
00324         ChargeUnitsIndArg();
00325
00326         static const ChargeUnitsIndArg& Cast(const StackMsgArgument& arg);
00327         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00328         const Tipd& GetTipd() const { return m_tipd; }
00329         void SetThisCallCcm(ULONG this_call_ccm) { m_this_call_ccm = this_call_ccm; }
00330         ULONG GetThisCallCcm() const { return m_this_call_ccm; }
00331         void SetAllCallsCcm(ULONG all_calls_ccm) { m_all_calls_ccm = all_calls_ccm; }
00332         ULONG GetAllCallsCcm() const { return m_all_calls_ccm; }
00333
00334         enum  {
00335             ID = 1068
00336             };
00337
00338     private:
00339
00340         static void Destroy(StackMsgArgument* arg) { delete ((ChargeUnitsIndArg*) arg); }
00341
00342         Tipd m_tipd;
00343         ULONG m_this_call_ccm;
00344         ULONG m_all_calls_ccm;
00345
00346     };
00347
00348 // Inline definitions
00349 inline const ChargeUnitsIndArg& ChargeUnitsIndArg::Cast(const StackMsgArgument& arg) {
00350     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChargeUnitsIndArg!\n");
00351     return ((ChargeUnitsIndArg &) arg);
00352 }
00353
00354
00355
00356 /*  ======================================================================
00357     Class CallRelatedSsReqArg
00358     ====================================================================== */
00359
00361 class CallRelatedSsReqArg : public StackMsgArgument {
00362     friend class CommonStackMsgArgsDestroyTableNode;
00363     public:
00364         CallRelatedSsReqArg(const Tipd& tipd, const CallRelatedSs& call_related_ss);
00365         CallRelatedSsReqArg();
00366
00367         static const CallRelatedSsReqArg& Cast(const StackMsgArgument& arg);
00368         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00369         const Tipd& GetTipd() const { return m_tipd; }
00370         void SetCallRelatedSs(const CallRelatedSs& call_related_ss) { m_call_related_ss = call_related_ss; }
00371         const CallRelatedSs& GetCallRelatedSs() const { return m_call_related_ss; }
00372
00373         enum  {
00374             ID = 2060
00375             };
00376
00377     private:
00378
00379         static void Destroy(StackMsgArgument* arg) { delete ((CallRelatedSsReqArg*) arg); }
00380
00381         Tipd m_tipd;
00382         CallRelatedSs m_call_related_ss;
00383
00384     };
00385
00386 // Inline definitions
00387 inline const CallRelatedSsReqArg& CallRelatedSsReqArg::Cast(const StackMsgArgument& arg) {
00388     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallRelatedSsReqArg!\n");
00389     return ((CallRelatedSsReqArg &) arg);
00390 }
00391
00392
00393
00394 /*  ======================================================================
00395     Class SetAutoChargeArg
00396     ====================================================================== */
00397
00399 class SetAutoChargeArg : public StackMsgArgument {
00400     friend class CommonStackMsgArgsDestroyTableNode;
00401     public:
00402         SetAutoChargeArg(BOOLEAN activate_reporting);
00403         SetAutoChargeArg();
00404
00405         static const SetAutoChargeArg& Cast(const StackMsgArgument& arg);
00406         void SetActivateReporting(BOOLEAN activate_reporting) { m_activate_reporting = activate_reporting; }
00407         BOOLEAN IsActivateReporting() const { return m_activate_reporting; }
00408
00409         enum  {
00410             ID = 2061
00411             };
00412
00413     private:
00414
00415         static void Destroy(StackMsgArgument* arg) { delete ((SetAutoChargeArg*) arg); }
00416
00417         BOOLEAN m_activate_reporting;
00418
00419     };
00420
00421 // Inline definitions
00422 inline const SetAutoChargeArg& SetAutoChargeArg::Cast(const StackMsgArgument& arg) {
00423     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SetAutoChargeArg!\n");
00424     return ((SetAutoChargeArg &) arg);
00425 }
00426
00427
00428
00429 /*  ======================================================================
00430     Class ChargeReqArg
00431     ====================================================================== */
00432
00434 class ChargeReqArg : public StackMsgArgument {
00435     friend class CommonStackMsgArgsDestroyTableNode;
00436     public:
00437         ChargeReqArg(const Tipd& tipd);
00438         ChargeReqArg();
00439
00440         static const ChargeReqArg& Cast(const StackMsgArgument& arg);
00441         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00442         const Tipd& GetTipd() const { return m_tipd; }
00443
00444         enum  {
00445             ID = 2062
00446             };
00447
00448     private:
00449
00450         static void Destroy(StackMsgArgument* arg) { delete ((ChargeReqArg*) arg); }
00451
00452         Tipd m_tipd;
00453
00454     };
00455
00456 // Inline definitions
00457 inline const ChargeReqArg& ChargeReqArg::Cast(const StackMsgArgument& arg) {
00458     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChargeReqArg!\n");
00459     return ((ChargeReqArg &) arg);
00460 }
00461
00462
00463
00464 /*  ======================================================================
00465     Class SetChargeUnitsArg
00466     ====================================================================== */
00467
00469 class SetChargeUnitsArg : public StackMsgArgument {
00470     friend class CommonStackMsgArgsDestroyTableNode;
00471     public:
00472         SetChargeUnitsArg(BOOLEAN activate_reporting);
00473         SetChargeUnitsArg();
00474
00475         static const SetChargeUnitsArg& Cast(const StackMsgArgument& arg);
00476         void SetActivateReporting(BOOLEAN activate_reporting) { m_activate_reporting = activate_reporting; }
00477         BOOLEAN IsActivateReporting() const { return m_activate_reporting; }
00478
00479         enum  {
00480             ID = 2063
00481             };
00482
00483     private:
00484
00485         static void Destroy(StackMsgArgument* arg) { delete ((SetChargeUnitsArg*) arg); }
00486
00487         BOOLEAN m_activate_reporting;
00488
00489     };
00490
00491 // Inline definitions
00492 inline const SetChargeUnitsArg& SetChargeUnitsArg::Cast(const StackMsgArgument& arg) {
00493     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SetChargeUnitsArg!\n");
00494     return ((SetChargeUnitsArg &) arg);
00495 }
00496
00497
00498
00499 /*  ======================================================================
00500     Class ChargeUnitsReqArg
00501     ====================================================================== */
00502
00504 class ChargeUnitsReqArg : public StackMsgArgument {
00505     friend class CommonStackMsgArgsDestroyTableNode;
00506     public:
00507         ChargeUnitsReqArg(const Tipd& tipd);
00508         ChargeUnitsReqArg();
00509
00510         static const ChargeUnitsReqArg& Cast(const StackMsgArgument& arg);
00511         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00512         const Tipd& GetTipd() const { return m_tipd; }
00513
00514         enum  {
00515             ID = 2064
00516             };
00517
00518     private:
00519
00520         static void Destroy(StackMsgArgument* arg) { delete ((ChargeUnitsReqArg*) arg); }
00521
00522         Tipd m_tipd;
00523
00524     };
00525
00526 // Inline definitions
00527 inline const ChargeUnitsReqArg& ChargeUnitsReqArg::Cast(const StackMsgArgument& arg) {
00528     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ChargeUnitsReqArg!\n");
00529     return ((ChargeUnitsReqArg &) arg);
00530 }
00531
00532
00533 #endif // Apc_CrssStackMsgArgs_hpp
00534
Generated on Tue Jan 24 14:46:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/DataCodingScheme.cpp File Reference

Apc/DataCodingScheme.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/DataCodingScheme.hpp"

Include dependency graph for DataCodingScheme.cpp:

Generated on Tue Jan 24 16:55:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/DataCodingScheme.hpp File Reference

Apc/DataCodingScheme.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for DataCodingScheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataCodingScheme
3GPP TS 23.038 V4.3.0 (2001-09) More...
class | DataCodingSchemeRange
used for cell broadcast filter More...

Defines

#define | Apc_DataCodingScheme_hpp

Define Documentation

#define Apc_DataCodingScheme_hpp

Generated on Tue Jan 24 16:55:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/DataCodingScheme.hpp Source File

Apc/DataCodingScheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_DataCodingScheme_hpp)
00009 #define Apc_DataCodingScheme_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014
00015 /*  ========================================================================
00016     Data Coding Scheme - 3GPP TS 23.038 V4.3.0 (2001-09)
00017     ========================================================================*/
00019 class DataCodingScheme {
00020     public:
00022         enum Type {
00024             Sms,
00026             Cbs,
00028             InvalidType,
00029         };
00030
00032         enum GroupId {
00034             GeneralDataCodingGroup,
00036             AutomaticDeletionGroup,
00038             ReservedCodingGroup,
00040             MsgWaitingIndDiscardGroup,
00042             MsgWaitingIndStoreDefaultGroup,
00044             MsgWaitingIndStoreUcs2Group,
00046             DataCodingMsgHandlingGroup,
00048             LanguageSelectionGroup,
00050             LanguageSelectionWithinMessageGroup,
00052             WapGroup,
00054             InvalidGroup
00055         };
00056
00058         enum LanguageGroupId { // do not change order
00060             LanguageGroup00 = 0,
00062             LanguageGroup01,
00064             LanguageGroup10,
00066             LanguageGroup11,
00068             InvalidLanguageGroup
00069         };
00070
00072         enum Alphabet { // do not change order
00074             DefaultAlphabet = 0, // PMI_DEFAULT_ALPHABET
00076             EightBitAlphabet,   // PMI_8_BIT_ALPHABET
00078             Ucs2Alphabet,       // PMI_UCS2_ALPHABET
00080             ReservedAlphabet,
00082             InvalidAlphabet,    // PMI_UNKNOWN_ALPHABET
00083         };
00084
00085         // sms class
00086         // (lookup in pmi_op20.h corresponding enum declaration - t_pmi_class)
00088         enum MessageClass { // do not change order
00090             Class0 = 0,     // PMI_CLASS_0
00092             Class1,         // PMI_CLASS_1
00094             Class2,         // PMI_CLASS_2
00096             Class3,         // PMI_CLASS_3
00098             NoClass,        // PMI_NO_CLASS
00100             InvalidClass,   // PMI_UNKNOWN_CLASS
00101         };
00102
00103         // text compression state
00104         // (lookup in pmi_op20.h corresponding enum declaration - t_pmi_compr_state)
00106         enum TextCompression {
00108             TextUncompressed,       // PMI_TEXT_UNCOMPRESSED
00110             TextCompressed,         // PMI_TEXT_COMPRESSED
00112             InvalidTextCompression, // PMI_UNKNOWN_COMPR_STATUS,
00113         };
00114
00115         // waiting message
00117         enum WaitingMessage { // do not change order
00119             VoiceMessage = 0,
00121             FaxMessage,
00123             EmailMessage,
00125             OtherMessage,
00127             InvalidMessage
00128         };
00129
00131         enum WaitingMessageIndication {
00133             MessageWaitingActive,
00135             MessageWaitingInactive,
00137             MessageWaitingInvalid
00138         };
00139
00141         enum Language   // do not change order !
00142         {
00144             German = 0,
00146             English,
00148             Italian,
00150             French,
00152             Spanish,
00154             Dutch,
00156             Swedish,
00158             Danish,
00160             Portuguese,
00162             Finnish,
00164             Norwegian,
00166             Greek,
00168             Turkish,
00170             Hungarian,
00172             Polish,
00174             UnspecifiedLanguage,
00175
00177             Czech,
00179             Hebrew,
00181             Arabic,
00183             Russian,
00185             Icelandic,
00186
00188             ReservedLanguage,
00190             InvalidLanguage
00191         };
00192
00193
00195         DataCodingScheme();
00197         DataCodingScheme(Type type, UINT8 incoming_byte = 0);
00198
00200         BOOLEAN operator == (const DataCodingScheme &dcs) const;
00201
00203         UINT8 Get() const { return (m_bit_field.Get()); }
00204
00206         Type GetType() const { return (Type)(m_type); }
00208         void SetType(Type type) { m_type = type; }
00209
00211         GroupId GetGroupId() const;
00213         void SetGroupId(GroupId group_id);
00214
00216         MessageClass GetMessageClass() const;
00218         void SetMessageClass(MessageClass msg_class);
00219
00221         Alphabet GetAlphabet() const;
00223         void SetAlphabet(Alphabet alphabet);
00224
00226         TextCompression GetTextCompression() const;
00228         void SetTextCompression(TextCompression msg_class);
00229
00231         WaitingMessage GetWaitingMessage() const;
00233         void SetWaitingMessage(WaitingMessage waiting_message);
00234
00236         WaitingMessageIndication GetWaitingMessageIndication() const;
00238         void SetWaitingMessageIndication(WaitingMessageIndication waiting_message_indication);
00239
00241         Language GetLanguage() const;
00243         void SetLanguage(Language language);
00244
00246         BOOLEAN IsInvalid() const { return (m_type == InvalidType); }
00247
00249         void Clear();
00250
00251     private:
00252         UINT8     m_type;
00253         BitField8 m_bit_field;
00254
00255         LanguageGroupId GetLanguageGroupId() const;
00256         void SetLanguageGroupId(LanguageGroupId language_group_id);
00257 };
00258
00259 /*  ========================================================================
00260     Data Coding Scheme Range
00261     ========================================================================*/
00263 class DataCodingSchemeRange : public Linkable<DataCodingSchemeRange> {
00264     public:
00266         DataCodingSchemeRange();
00268         DataCodingSchemeRange(const DataCodingScheme &begin, const DataCodingScheme &end = DataCodingScheme());
00269
00271         BOOLEAN operator == (const DataCodingSchemeRange &dcs_range) const;
00272
00274         const DataCodingScheme& Begin() const { return (m_begin); }
00276         void Begin(const DataCodingScheme &begin) { m_begin = begin; }
00278         const DataCodingScheme& End() const { return (m_end); }
00280         void End(const DataCodingScheme &end) { m_end = end; }
00282         BOOLEAN IsValid() { return (m_begin.Get() <= m_end.Get());}
00283
00284     private:
00285         DataCodingScheme m_begin;
00286         DataCodingScheme m_end;
00287 };
00288
00289
00290 #endif  // Apc_DataCodingScheme_hpp
00291
00292
Generated on Tue Jan 24 14:46:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ImageData.cpp File Reference

Apc/ImageData.cpp File Reference

#include "Apc/PreComp.hpp"
#include "ImageData.hpp"

Include dependency graph for ImageData.cpp:

Generated on Tue Jan 24 16:55:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ImageData.hpp File Reference

Apc/ImageData.hpp File Reference

#include <Apc/SignalTypes.hpp>

Include dependency graph for ImageData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimClutEntry
class | SimIconDescription
class | SimImage
class | SimImageDescriptor

Defines

#define | Apc_ImageData_hpp

Enumerations

enum | SimImageCodingScheme { SimBasicImageCoding = 0x11, SimColorImageCoding = 0x21 }
enum | SimImageRequestType { SimImageHeader = 0, SimImageHeaderBody = 1, SimImageHeaderBodyClut = 2, SimImageHeaderClut = 3 }

Define Documentation

#define Apc_ImageData_hpp

Generated on Tue Jan 24 16:55:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ImageData.hpp Source File

Apc/ImageData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_ImageData_hpp)
00009 #define Apc_ImageData_hpp
00012
00013 #include <Apc/SignalTypes.hpp>
00014
00015
00016 /*  ------------------------------------------------------------------------
00017      SimClutEntry
00018     ------------------------------------------------------------------------ */
00019
00020 class SimClutEntry {
00021     public:
00022         SimClutEntry() : red(0), green(0), blue(0) {};
00023
00024         UINT8 red;
00025         UINT8 green;
00026         UINT8 blue;
00027 };
00028
00029 /*  ------------------------------------------------------------------------
00030      SimImageCodingScheme
00031     ------------------------------------------------------------------------ */
00032
00033 enum SimImageCodingScheme {
00034     SimBasicImageCoding = 0x11,
00035     SimColorImageCoding = 0x21
00036 };
00037
00038 /*  ------------------------------------------------------------------------
00039      ImageRequestType    T_SI_IMAGE_REQ_TYPE
00040     ------------------------------------------------------------------------ */
00041
00042 enum SimImageRequestType {
00043     SimImageHeader = 0,
00044     SimImageHeaderBody = 1,
00045     SimImageHeaderBodyClut = 2,
00046     SimImageHeaderClut = 3,
00047 };
00048
00049 /*  ------------------------------------------------------------------------
00050     SimImageDescriptor T_SI_IMAGE_DESCRIPTOR
00051     ------------------------------------------------------------------------ */
00052
00055 class SimImageDescriptor {
00056     public:
00058         SimImageDescriptor();
00060         SimImageDescriptor(const SimImageDescriptor & desc);
00061
00062         void Fill(const T_SI_IMAGE_DESCRIPTOR * descriptor);
00063         void Get(T_SI_IMAGE_DESCRIPTOR * descriptor) const;
00064
00066         SimImageDescriptor & operator = (const SimImageDescriptor & desc);
00068         UINT8 s_width;
00070         UINT8 s_height;
00072         UINT8 s_coding_scheme_type;
00074         UINT8 s_file_id_high;
00076         UINT8 s_file_id_low;
00078         UINT8 s_file_instance_offset_high;
00080         UINT8 s_file_instance_offset_low;
00082         UINT8 s_file_instance_length_high;
00084         UINT8 s_file_instance_length_low;
00085
00086         void DbgOut() const;
00087
00088 };
00089
00090 /*  ========================================================================
00091     SimIconDescription T_SI_ICON_DESCRIPTOR
00092     ======================================================================== */
00093
00097 class SimIconDescription
00098 {
00099     public:
00101         SimIconDescription();
00103         SimIconDescription(const SimIconDescription & data);
00105         ~SimIconDescription();
00106
00107         void Fill(const T_SI_ICON_DESCRIPTOR * descriptor);
00109         const SimImageDescriptor & GetSimImageDescriptor(INT idx) const;
00111         UINT8 GetIconId() const { return (m_icon_id); }
00113         UINT8 GetNoImages() const { return (m_number_of_instances); }
00114
00115         UINT8 GetRfu() const { return (m_rfu); }
00117         SimIconDescription & operator = (const SimIconDescription & szCopy);
00118
00119         void DbgOut() const;
00120
00121     private:
00122         INT                     m_icon_id;
00123         UINT8                   m_number_of_instances;
00124         SimImageDescriptor *    m_image_descriptions_ptr;
00125         UINT8                   m_rfu;
00126 };
00127
00128 /*  ========================================================================
00129     SimImage T_SI_IMAGE_HEADER
00130         holds the data of an Image with dyn. alloc. mem
00131     ======================================================================== */
00132
00136 class SimImage
00137 {
00138     public:
00140         SimImage();
00142         SimImage(const SimImage & imagedata);
00144         ~SimImage();
00145
00146         void Fill(const T_SI_IMAGE_HEADER * imgheader);
00148         INT GetCoding() const { return (m_coding); }
00150         SimImageCodingScheme GetSimImageCodingScheme() const { return (SimImageCodingScheme)(m_coding); }
00152         INT GetWidth() const { return (m_width); }
00154         INT GetHeight() const { return (m_height); }
00156         INT GetBpp() const { return (m_bpp); }
00158         INT GetNrClutEntries() const { return (m_nr_clut_entries); }
00160         INT GetClutLocation() const { return (m_clut_location); }
00162         UINT8 * GetImageBuffer() const { return m_image_body; }
00164         INT  GetImageBufferLength() const;
00166         UINT8 * GetClutBuffer() const { return m_image_clut; }
00168         INT  GetClutBufferLength() const;
00170         SimClutEntry GetSimClutEntry(INT idx) const;
00171
00172         SimImage & operator = (const SimImage & szCopy);
00173
00175         void DbgOut() const;
00176
00177     private:
00178         INT     m_coding;
00179         INT     m_width;
00180         INT     m_height;
00181         INT     m_bpp;
00182         INT     m_nr_clut_entries;
00183         INT     m_clut_location;
00184         UINT8 * m_image_body;
00185         UINT8 * m_image_clut;
00186 };
00187
00189 #endif
00190
00191
Generated on Tue Jan 24 14:46:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ImageStackMsgArgs.cpp File Reference

Apc/ImageStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "ImageStackMsgArgs.hpp"

Include dependency graph for ImageStackMsgArgs.cpp:

Generated on Tue Jan 24 16:55:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ImageStackMsgArgs.hpp File Reference

Apc/ImageStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/ImageData.hpp>

Include dependency graph for ImageStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IconDescReadIndArg
class | IconDescReadReqArg
class | ImageReadIndArg
class | ImageReadReqArg

Defines

#define | Apc_ImageStackMsgArgs_hpp

Define Documentation

#define Apc_ImageStackMsgArgs_hpp

Generated on Tue Jan 24 16:55:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ImageStackMsgArgs.hpp Source File

Apc/ImageStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\Apc\ImageArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_ImageStackMsgArgs_hpp)
00016 #define Apc_ImageStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Apc/ImageData.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class ImageReadIndArg
00029     ====================================================================== */
00030
00032 class ImageReadIndArg : public StackMsgArgument {
00033     friend class CommonStackMsgArgsDestroyTableNode;
00034     public:
00035         ImageReadIndArg();
00036
00037         static const ImageReadIndArg& Cast(const StackMsgArgument& arg);
00038         void SetImage(const SimImage& image) { m_image = image; }
00039         const SimImage& GetImage() const { return m_image; }
00040
00041         enum  {
00042             ID = 1080
00043             };
00044
00045     private:
00046
00047         static void Destroy(StackMsgArgument* arg) { delete ((ImageReadIndArg*) arg); }
00048
00049         SimImage m_image;
00050
00051     };
00052
00053 // Inline definitions
00054 inline const ImageReadIndArg& ImageReadIndArg::Cast(const StackMsgArgument& arg) {
00055     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ImageReadIndArg!\n");
00056     return ((ImageReadIndArg &) arg);
00057 }
00058
00059
00060
00061 /*  ======================================================================
00062     Class IconDescReadIndArg
00063     ====================================================================== */
00064
00066 class IconDescReadIndArg : public StackMsgArgument {
00067     friend class CommonStackMsgArgsDestroyTableNode;
00068     public:
00069         IconDescReadIndArg();
00070
00071         static const IconDescReadIndArg& Cast(const StackMsgArgument& arg);
00072         void SetIcondesc(const SimIconDescription& icondesc) { m_icondesc = icondesc; }
00073         const SimIconDescription& GetIcondesc() const { return m_icondesc; }
00074
00075         enum  {
00076             ID = 1081
00077             };
00078
00079     private:
00080
00081         static void Destroy(StackMsgArgument* arg) { delete ((IconDescReadIndArg*) arg); }
00082
00083         SimIconDescription m_icondesc;
00084
00085     };
00086
00087 // Inline definitions
00088 inline const IconDescReadIndArg& IconDescReadIndArg::Cast(const StackMsgArgument& arg) {
00089     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to IconDescReadIndArg!\n");
00090     return ((IconDescReadIndArg &) arg);
00091 }
00092
00093
00094
00095 /*  ======================================================================
00096     Class ImageReadReqArg
00097     ====================================================================== */
00098
00100 class ImageReadReqArg : public StackMsgArgument {
00101     friend class CommonStackMsgArgsDestroyTableNode;
00102     public:
00103         ImageReadReqArg(const SimImageRequestType& img_request_type, const SimImageDescriptor& imgdescriptor);
00104         ImageReadReqArg();
00105
00106         static const ImageReadReqArg& Cast(const StackMsgArgument& arg);
00107         void SetImgRequestType(const SimImageRequestType& img_request_type) { m_img_request_type = img_request_type; }
00108         const SimImageRequestType& GetImgRequestType() const { return m_img_request_type; }
00109         void SetImgdescriptor(const SimImageDescriptor& imgdescriptor) { m_imgdescriptor = imgdescriptor; }
00110         const SimImageDescriptor& GetImgdescriptor() const { return m_imgdescriptor; }
00111
00112         enum  {
00113             ID = 2080
00114             };
00115
00116     private:
00117
00118         static void Destroy(StackMsgArgument* arg) { delete ((ImageReadReqArg*) arg); }
00119
00120         SimImageRequestType m_img_request_type;
00121         SimImageDescriptor m_imgdescriptor;
00122
00123     };
00124
00125 // Inline definitions
00126 inline const ImageReadReqArg& ImageReadReqArg::Cast(const StackMsgArgument& arg) {
00127     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ImageReadReqArg!\n");
00128     return ((ImageReadReqArg &) arg);
00129 }
00130
00131
00132
00133 /*  ======================================================================
00134     Class IconDescReadReqArg
00135     ====================================================================== */
00136
00138 class IconDescReadReqArg : public StackMsgArgument {
00139     friend class CommonStackMsgArgsDestroyTableNode;
00140     public:
00141         IconDescReadReqArg(INT recno = 0);
00142
00143         static const IconDescReadReqArg& Cast(const StackMsgArgument& arg);
00144         void SetRecno(INT recno) { m_recno = recno; }
00145         INT GetRecno() const { return m_recno; }
00146
00147         enum  {
00148             ID = 2081
00149             };
00150
00151     private:
00152
00153         static void Destroy(StackMsgArgument* arg) { delete ((IconDescReadReqArg*) arg); }
00154
00155         INT m_recno;
00156
00157     };
00158
00159 // Inline definitions
00160 inline const IconDescReadReqArg& IconDescReadReqArg::Cast(const StackMsgArgument& arg) {
00161     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to IconDescReadReqArg!\n");
00162     return ((IconDescReadReqArg &) arg);
00163 }
00164
00165
00166 #endif // Apc_ImageStackMsgArgs_hpp
00167
Generated on Tue Jan 24 14:46:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/InformationElement.cpp File Reference

Apc/InformationElement.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/InformationElement.hpp"

Include dependency graph for InformationElement.cpp:

Functions

BOOLEAN InfoElementTestSuite ()

Function Documentation

BOOLEAN InfoElementTestSuite ( )

Generated on Tue Jan 24 16:55:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/InformationElement.hpp File Reference

Apc/InformationElement.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for InformationElement.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InformationElement

Defines

#define | Apc_InformationElement_hpp

Typedefs

typedef UINT16 | SmsPortNo

Enumerations

enum | { InvalidSmsPortNo = 0x00 }

Functions

BOOLEAN | InfoElementTestSuite ()

Variables

const UINT8 | c_large_animation_size = 128
const UINT8 | c_large_picture_size = 128
const UINT8 | c_small_animation_size = 32
const UINT8 | c_small_picture_size = 32

Define Documentation

#define Apc_InformationElement_hpp

Typedef Documentation

typedef UINT16 SmsPortNo

Sms port definition

Enumeration Type Documentation

anonymous enum

Enumerator:
InvalidSmsPortNo

Function Documentation

BOOLEAN InfoElementTestSuite ( )

Variable Documentation

const UINT8 c_large_animation_size = 128

const UINT8 c_large_picture_size = 128

const UINT8 c_small_animation_size = 32

const UINT8 c_small_picture_size = 32

Generated on Tue Jan 24 16:55:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/InformationElement.hpp Source File

Apc/InformationElement.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_InformationElement_hpp)
00009 #define Apc_InformationElement_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 /*  ========================================================================
00014     InformationElement - 3GPP TS 23.040 V5.1.0 [9.2.3.24.1 - 9.2.3.24.12]
00015     ======================================================================== */
00016
00017 const UINT8 c_large_animation_size = 128;
00018 const UINT8 c_small_animation_size = 32;
00019 const UINT8 c_large_picture_size = 128;
00020 const UINT8 c_small_picture_size = 32;
00021
00023 typedef UINT16 SmsPortNo;
00024 enum { InvalidSmsPortNo = 0x00 };   // define an invalid port number
00025
00027 class InformationElement
00028 {
00029     public:
00031         enum Identifier {
00033             ConcatenatedSm8Bit = 0x00,
00035             SpecialSms = 0x01,
00037             ValueNotUsed = 0x03,
00039             AddressingScheme8Bit = 0x04,
00041             AddressingScheme16Bit = 0x05,
00043             SmscControl = 0x06,
00045             UdhSourceIndicator = 0x07,
00047             ConcatenatedSm16Bit = 0x08,
00049             WirelessControlMessageProtocol = 0x09,
00051             TextFormatting = 0x0a,
00053             PredefinedSound = 0x0b,
00055             UserDefinedSound = 0x0c,
00057             PredefinedAnimation = 0x0d,
00059             LargeAnimation = 0x0e,
00061             SmallAnimation = 0x0f,
00063             LargePicture = 0x10,
00065             SmallPicture = 0x11,
00067             VariablePicture = 0x12,
00069             UserPromptIndicator = 0x13,
00071             ExtendedObject = 0x14,
00073             ReusedExtendedObject = 0x15,
00075             CompressionControl = 0x16,
00077             ObjectDistributionIndicator = 0x17,
00079             Rfc822EmailHeader = 0x20,
00081             HyperlinkFormatElement = 0x21,
00082
00084             ReservedIdentifier,
00085
00087             InvalidIdentifier,
00088
00089             // Special Handling
00090             ContinuedExtendedObject = (ExtendedObject | 0x80)
00091         };
00092
00094         enum MessageType {
00096             VoiceMessage = 0,
00098             FaxMessage = 1,
00100             ElectronicMail = 2,
00102             OtherMessage = 3,
00103         };
00104
00106         enum PredefinedSoundType {
00108             ChimesHigh = 0,
00110             ChimesLow = 1,
00112             Ding = 2,
00114             TaDa = 3,
00116             Notify = 4,
00118             Drum = 5,
00120             Claps = 6,
00122             FanFar = 7,
00124             ChordHigh = 8,
00126             ChordLow = 9,
00127         };
00128
00130         enum PredefinedAnimationType {
00132             IAmIronic = 0,
00134             IAmGlad = 1,
00136             IAmSceptic = 2,
00138             IAmSad = 3,
00140             Wow = 4,
00142             IAmCrying = 5,
00144             IAmWinking = 6,
00146             IAmLaughing = 7,
00148             IAmIndifferent = 8,
00150             Kissing = 9,
00152             IAmConfused = 10,
00154             TongueHangingOut = 11,
00156             IAmAngry = 12,
00158             WearingGlasses = 13,
00160             Devil = 14,
00161         };
00162
00164         enum TextAlignment {
00166             Left = 0,
00168             Center = 1,
00170             Right = 2,
00172             LanguageDependend = 3,
00173         };
00175         enum FontSize {
00177             Default = 0,
00179             Large = 1,
00181             Small = 2,
00183             Reserved = 3,
00184         };
00186         enum TextColour {
00188             Black = 0,
00190             DarkGrey = 1,
00192             DarkRed = 2,
00194             DarkYellow = 3,
00196             DarkGreen = 4,
00198             DarkCyan = 5,
00200             DarkBlue = 6,
00202             DarkMagenta = 7,
00204             Grey = 8,
00206             White = 9,
00208             BrightRed = 10,
00210             BrightYellow = 11,
00212             BrightGreen = 12,
00214             BrightCyan = 13,
00216             BrightBlue = 14,
00218             BrightMagenta = 15,
00219         };
00221         enum ExtendedObjectType {
00223             EOPredefinedSound           = 0x00,
00225             EOiMelody                   = 0x01,
00227             EOBWBitmap                  = 0x02,
00229             EOTwoBitGrayScale           = 0x03,
00231             EOSixBitGrayScale           = 0x04,
00233             EOPredefinedAnimation       = 0x05,
00235             EOBWBitmapAnimation         = 0x06,
00237             EOTwoBitGrayScaleAnimation  = 0x07,
00239             EOSixBitGrayScaleAnimation  = 0x08,
00241             EOvCard                     = 0x09,
00243             EOvCalendar                 = 0x0A,
00245             EOStdWVGObject              = 0x0B,
00247             EOPolyphonicMelody          = 0x0C,
00251             EODataFormatDeliveryRequest = 0xFF
00252         };
00253
00254
00255
00257         InformationElement();
00258
00260         InformationElement(UINT8 *anchor);
00262         ~InformationElement();
00263
00265         static UINT16 GetSize(Identifier id, UINT16 additional = 0);
00266
00268         BOOLEAN IsValid() const;
00269
00271         BOOLEAN SetIdentifier (Identifier id);
00272
00274         Identifier GetIdentifier() const;
00275
00277         UINT8 GetLength() const;
00278
00280         UINT8* GetData() const;
00281
00283         UINT8* GetData(INT idx) const;
00284
00285         // Copies the whole information element into destination.
00286         void CopyTo(UINT8 *destination) const;
00287
00289         InformationElement& operator =(const InformationElement &ie);
00290
00291 // Access and creation methods for Information elements details
00292
00294
00295         BOOLEAN SetConcatenatedSmReferenceNumber(UINT16 refno);
00297         BOOLEAN SetConcatenatedSmMaximumNumber(UINT8 maxno);
00299         BOOLEAN SetConcatenatedSmSequenceNumber(UINT8 seqno);
00300
00301
00303
00304         BOOLEAN PutConcatenatedSm8Bit(UINT8 refno, UINT8 maxno, UINT8 seqno);
00306         UINT8 GetConcatenatedSm8BitReferenceNumber() const;
00308         UINT8 GetConcatenatedSm8BitMaximumNumber() const;
00310         UINT8 GetConcatenatedSm8BitSequenceNumber() const;
00311
00313
00314         BOOLEAN PutConcatenatedSm16Bit(UINT16 refno, UINT8 maxno, UINT8 seqno);
00316         UINT16 GetConcatenatedSm16BitReferenceNumber() const;
00318         UINT8 GetConcatenatedSm16BitMaximumNumber() const;
00320         UINT8 GetConcatenatedSm16BitSequenceNumber() const;
00321
00323
00324         BOOLEAN PutAddressingScheme8Bit(SmsPortNo destport, SmsPortNo orgport);
00326         SmsPortNo GetAddressingScheme8BitDestinationPort() const;
00328         SmsPortNo GetAddressingScheme8BitOriginatorPort() const;
00329
00331
00332         BOOLEAN PutAddressingScheme16Bit(SmsPortNo destport, SmsPortNo orgport);
00334         SmsPortNo GetAddressingScheme16BitDestinationPort() const;
00336         SmsPortNo GetAddressingScheme16BitOriginatorPort() const;
00337
00339
00340         UINT8 GetSpecialSmsMessageIndicationType() const;
00342         UINT8 GetSpecialSmsMessageCount() const;
00344         MessageType GetSpecialSmsMessageType() const;
00346         BOOLEAN ShallStoreMessage() const;
00347
00349
00350         BOOLEAN PutEmsRelativeStartPosition(UINT8 startpos);
00351
00353
00354         BOOLEAN PutTextFormatting(UINT8 startpos, UINT8 length, UINT8 mode, UINT8 colour);
00356         BOOLEAN PutTextFormatting(UINT8 startpos, UINT8 length,
00357                                   InformationElement::TextAlignment alignment,
00358                                   InformationElement::FontSize fontsize,
00359                                   BOOLEAN bold,
00360                                   BOOLEAN italic,
00361                                   BOOLEAN underlined,
00362                                   BOOLEAN strikethrough,
00363                                   InformationElement::TextColour foreground,
00364                                   InformationElement::TextColour background);
00366         UINT8 GetTextFormattingStartPosition() const;
00368         UINT8 GetTextFormattingLength() const;
00370         UINT8 GetTextFormattingMode() const;
00372         TextAlignment GetTextFormattingTextAlignment() const;
00374         FontSize GetTextFormattingFontSize() const;
00376         BOOLEAN IsBold() const;
00378         BOOLEAN IsItalic() const;
00380         BOOLEAN IsUnderlined() const;
00382         BOOLEAN IsStrikethrough() const;
00384         UINT8 GetTextFormattingColour() const;
00386         TextColour GetTextFormattingForegroundColour() const;
00388         TextColour GetTextFormattingBackgroundColour() const;
00389
00391         BOOLEAN PutPredefinedSound(UINT8 startpos, PredefinedSoundType sound);
00392
00393         UINT8 GetPredefinedSoundStartPosition() const;
00395         PredefinedSoundType GetPredefinedSoundType() const;
00396
00398         BOOLEAN PutUserDefinedSound(UINT8 startpos, UINT8 length, const UINT8 * sound);
00400         UINT8 GetUserDefinedSoundStartPosition() const;
00402         UINT8 * GetUserDefinedSoundBuffer() const;
00404         UINT8 GetUserDefinedSoundLength() const;
00405
00407
00408         BOOLEAN PutPredefinedAnimation(UINT8 startpos, PredefinedAnimationType animation);
00410         UINT8 GetPredefinedAnimationStartPosition() const;
00412         PredefinedAnimationType GetPredefinedAnimationType() const;
00413
00415         BOOLEAN PutLargeAnimation(UINT8 startpos, const UINT8 * animation);
00417         UINT8 GetLargeAnimationStartPosition() const;
00419         UINT8 * GetLargeAnimationBuffer() const;
00421         UINT8 GetLargeAnimationLength() const;
00422
00424         BOOLEAN PutSmallAnimation(UINT8 startpos, const UINT8 * animation);
00426         UINT8 GetSmallAnimationStartPosition() const;
00428         UINT8 * GetSmallAnimationBuffer() const;
00430         UINT8 GetSmallAnimationLength() const;
00431
00433         BOOLEAN PutLargePicture(UINT8 startpos, const UINT8 * picture);
00435         UINT8 GetLargePictureStartPosition() const;
00437         UINT8 * GetLargePictureBuffer() const;
00439         UINT8 GetLargePictureLength() const;
00440
00442         BOOLEAN PutSmallPicture(UINT8 startpos, const UINT8 * picture);
00444         UINT8 GetSmallPictureStartPosition() const;
00446         UINT8 * GetSmallPictureBuffer() const;
00448         UINT8 GetSmallPictureLength() const;
00449
00451         BOOLEAN PutVariablePicture(UINT8 startpos, UINT8 horiz, UINT8 vert, UINT8 length, const UINT8 * picture);
00453         UINT8 GetVariablePictureStartPosition() const;
00455         UINT8 * GetVariablePictureBuffer() const;
00457         UINT8 GetVariablePictureLength() const;
00459         UINT8 GetVariablePictureHorizontalDimension() const;
00461         UINT8 GetVariablePictureVerticalDimension() const;
00462
00464         UINT8 GetUserPromptIndicatorNumberCorrespondingObjects() const;
00465
00467         UINT8 * GetWirelessControlMessageProtocolBuffer() const;
00469         UINT8 GetWirelessControlMessageProtocolLength() const;
00470
00472         UINT8 GetRfc822EmailHeaderLength() const;
00473
00475         UINT16 GetHyperlinkFormatElementAbsolutStartPosition() const;
00477         UINT8 GetHyperlinkFormatElementTitelLength() const;
00479         UINT8 GetHyperlinkFormatElementUrlLength() const;
00480
00482         BOOLEAN PutExtendedObject(UINT16 startpos,
00483                                   UINT8 ref_no,
00484                                   BOOLEAN may_be_forw,
00485                                   BOOLEAN handled_as_user_prompt,
00486                                   InformationElement::ExtendedObjectType type,
00487                                   UINT8 length,
00488                                   UINT16 complete_length,
00489                                   const UINT8* extended_object_buffer);
00490
00491         BOOLEAN PutContinuedExtendedObject(UINT8 length,
00492                                            const UINT8* extended_object_buffer);
00493
00495         UINT8   GetExtendedObjectReferenceNumber() const;
00497         UINT16  GetExtendedObjectLength() const;
00499         BOOLEAN GetExtendedObjectControlDataMayBeForw() const;
00501         BOOLEAN GetExtendedObjectControlDataUserPrompt() const;
00503         InformationElement::ExtendedObjectType GetExtendedObjectType() const;
00505         UINT16  GetExtendedObjectPosition() const;
00507         UINT8*  GetExtendedObjectBuffer() const;
00509         BOOLEAN PutReusedExtendedObject(UINT16 startpos, UINT8 ref_no);
00511         UINT8   GetReusedExtendedObjectReferenceNumber() const;
00513         UINT16  GetReusedExtendedObjectPosition() const;
00514
00515     private:
00516         UINT8   *m_anchor;
00517 };
00518
00519 BOOLEAN InfoElementTestSuite();
00520
00521
00522 #endif  // Apc_InformationElement_hpp
00523
00524
Generated on Tue Jan 24 14:46:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Lib.hpp File Reference

Apc/Lib.hpp File Reference

#include <Apc/Message.hpp>
#include <Apc/StackMsgArgument.hpp>
#include <Apc/CommonStackMsgArgs.hpp>
#include <Apc/AudioTypes.hpp>
#include <Apc/Cbs.hpp>
#include <Apc/CommandType.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <Apc/ImageData.hpp>
#include <Apc/InformationElement.hpp>
#include <Apc/MessageIdentifier.hpp>
#include <Apc/MessageTypeIndicator.hpp>
#include <Apc/ParameterIndicator.hpp>
#include <Apc/PlmnScanList.hpp>
#include <Apc/ProtocolIdentifier.hpp>
#include <Apc/ShortMessageFailureCause.hpp>
#include <Apc/ShortMessageStatus.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/SimDataTypes.hpp>
#include <Apc/SimTkTypes.hpp>
#include <Apc/Sms.hpp>
#include <Apc/SsErrorCode.hpp>
#include <Apc/SsNotification.hpp>
#include <Apc/SsStatus.hpp>
#include <Apc/StackWrapper.hpp>
#include <Apc/TaggedProblemCode.hpp>
#include <Apc/Tlv.hpp>
#include <Apc/Tpdu.hpp>
#include <Apc/UserData.hpp>
#include <Apc/ValidityPeriod.hpp>
#include <Apc/LockTypes.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Apc/MdhTypes.hpp>
#include <Apc/SimLockTypes.hpp>
#include <Apc/SimMiscTypes.hpp>

Include dependency graph for Lib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apc_Lib_hpp

Define Documentation

#define Apc_Lib_hpp

Generated on Tue Jan 24 14:53:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Lib.hpp Source File

Apc/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Lib_hpp)
00009 #define Apc_Lib_hpp
00010
00011 #include <Apc/Message.hpp>
00012 #include <Apc/StackMsgArgument.hpp>
00013
00014 #include <Apc/CommonStackMsgArgs.hpp>
00015
00016 // types
00017 #include <Apc/AudioTypes.hpp>
00018 #include <Apc/Cbs.hpp>
00019 #include <Apc/CommandType.hpp>
00020 #include <Apc/DataCodingScheme.hpp>
00021 #include <Apc/ImageData.hpp>
00022 #include <Apc/InformationElement.hpp>
00023 #include <Apc/MessageIdentifier.hpp>
00024 #include <Apc/MessageTypeIndicator.hpp>
00025 #include <Apc/ParameterIndicator.hpp>
00026 #include <Apc/PlmnScanList.hpp>
00027 #include <Apc/ProtocolIdentifier.hpp>
00028 #include <Apc/ShortMessageFailureCause.hpp>
00029 #include <Apc/ShortMessageStatus.hpp>
00030 #include <Apc/SignalTypes.hpp>
00031 #include <Apc/SimDataTypes.hpp>
00032 #include <Apc/SimTkTypes.hpp>
00033 #include <Apc/Sms.hpp>
00034 #include <Apc/SsErrorCode.hpp>
00035 #include <Apc/SsNotification.hpp>
00036 #include <Apc/SsStatus.hpp>
00037 #include <Apc/StackWrapper.hpp>
00038 #include <Apc/TaggedProblemCode.hpp>
00039 #include <Apc/Tlv.hpp>
00040 #include <Apc/Tpdu.hpp>
00041 #include <Apc/UserData.hpp>
00042 #include <Apc/ValidityPeriod.hpp>
00043 #include <Apc/LockTypes.hpp>
00044 #include <Apc/NetworkTypes.hpp>
00045 #include <Apc/MdhTypes.hpp>
00046 #include <Apc/SimLockTypes.hpp>
00047 #include <Apc/SimMiscTypes.hpp>
00048
00049 #endif  // Apc_Lib_hpp
00050
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/LockTypes.hpp File Reference

Apc/LockTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for LockTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | SecLockCode
struct | SecLockCommand
struct | SecLockDescriptor
struct | SecLocks
struct | SecLockStates
struct | SecMmiConfigData

Defines

#define | Apc_LockTypes_hpp

Enumerations

enum SecLockAction {
SecUnlockAction = SI_LOCK_CMD_UNLOCK, SecChangePwdLock = SI_LOCK_CMD_CHANGE_PWD, SecStartupLock = SI_LOCK_CMD_STARTUP, SecRefreshLock = SI_LOCK_CMD_REFRESH,
SecDepersSmsLock = SI_LOCK_CMD_DEPERS_SMS, SecGetProfileLock = SI_LOCK_CMD_GET_PROFILE
}
enum SecLockCause {
SecSucceded = SI_SEC_SUCCEEDED, SecLockInvalid = SI_SEC_LOCK_INVALID, SecUnauthorisized = SI_SEC_UNAUTHORISIZED_ACTION, SecPersCodeError = SI_SEC_PERS_CODE_ERROR,
SecControlKeyError = SI_SEC_CONTROL_KEY_ERROR, SecStorageError = SI_SEC_STORAGE_ERROR, SecNoMoreTrials = SI_SEC_NO_MORE_TRIALS
}
enum SecLockResult {
SecContinueOperation = SI_SEC_CONTINUE_OPERATION, SecVerificationNeeded = SI_SEC_VERIFICATION_NEEDED, SecNoFurtherOperation = SI_SEC_NO_FURTHER_OPERATION, SecLockError = SI_SEC_LOCK_ERROR,
SecUnknownResult = SI_UNKNOWN_RES, SecProfileUpdate = SI_PROFILE_UPDATE, SecImeiInvalid = SI_SEC_IMEI_INVALID
}
enum SecLockStatus {
SecLockArmed = SI_LOCK_ARMED, SecLockActive = SI_LOCK_ACTIVE, SecLockPermanentActive = SI_LOCK_PERMANENT_ACTIVE, SecLockBlocked = SI_LOCK_BLOCKED,
SecLockDeactive = SI_LOCK_DEACTIVE, SecLockDisabled = SI_LOCK_DISABLED, SecLockAutoActivated = SI_LOCK_AUTOACTIVATED, SecLockLastState = SI_SEC_LAST_STATE,
SecLockLocked = SI_LOCKED, SecLockUnlocked = SI_UNLOCKED
}
enum SecLockType {
SecNetworkLock = SI_NETWORK_LOCK, SecNetworkSubsetLock = SI_NETWORK_SUBSET_LOCK, SecSpLock = SI_SP_LOCK, SecCorporateLock = SI_CORPORATE_LOCK,
SecSimLock = SI_SIM_LOCK, SecAtLock = SI_AT_LOCK, SecNofLock = SI_NOF_LOCKS, SecPfLock = SI_PF_LOCKS,
SecNofTypes = SI_NOF_TYPES
}

Variables

const INT | c_max_no_sec_locks = 6

Define Documentation

#define Apc_LockTypes_hpp

Enumeration Type Documentation

enum SecLockAction

Enumerator:
SecUnlockAction
SecChangePwdLock
SecStartupLock
SecRefreshLock
SecDepersSmsLock
SecGetProfileLock

enum SecLockCause

Enumerator:
SecSucceded
SecLockInvalid
SecUnauthorisized
SecPersCodeError
SecControlKeyError
SecStorageError
SecNoMoreTrials

enum SecLockResult

Enumerator:
SecContinueOperation
SecVerificationNeeded
SecNoFurtherOperation
SecLockError
SecUnknownResult
SecProfileUpdate
SecImeiInvalid

enum SecLockStatus

Enumerator:
SecLockArmed
SecLockActive
SecLockPermanentActive
SecLockBlocked
SecLockDeactive
SecLockDisabled
SecLockAutoActivated
SecLockLastState
SecLockLocked
SecLockUnlocked

enum SecLockType

Enumerator:
SecNetworkLock
SecNetworkSubsetLock
SecSpLock
SecCorporateLock
SecSimLock
SecAtLock
SecNofLock
SecPfLock
SecNofTypes

Variable Documentation

const INT c_max_no_sec_locks = 6

Generated on Tue Jan 24 16:55:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/LockTypes.hpp Source File

Apc/LockTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_LockTypes_hpp)
00009 #define Apc_LockTypes_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013
00014 #include <Apc/SignalTypes.hpp>
00015
00016 /*  ========================================================================
00017                                   SecLockAction
00018     ========================================================================*/
00019 // (ms.h: T_SI_LOCK_ACTION)
00021 enum SecLockAction {
00023     SecUnlockAction     = SI_LOCK_CMD_UNLOCK,
00025     SecChangePwdLock    = SI_LOCK_CMD_CHANGE_PWD,
00027     SecStartupLock      = SI_LOCK_CMD_STARTUP,
00029     SecRefreshLock      = SI_LOCK_CMD_REFRESH,
00031     SecDepersSmsLock    = SI_LOCK_CMD_DEPERS_SMS,
00033     SecGetProfileLock   = SI_LOCK_CMD_GET_PROFILE
00034 };
00035
00036 /*  ========================================================================
00037                                   SecLockTypes
00038     ========================================================================*/
00039 // (ms.h: T_SI_LOCK_TYPES)
00041 enum SecLockType {
00043     SecNetworkLock          = SI_NETWORK_LOCK ,
00045     SecNetworkSubsetLock    = SI_NETWORK_SUBSET_LOCK ,
00047     SecSpLock               = SI_SP_LOCK ,
00049     SecCorporateLock        = SI_CORPORATE_LOCK,
00051     SecSimLock              = SI_SIM_LOCK ,
00053     SecAtLock               = SI_AT_LOCK,
00055     SecNofLock              = SI_NOF_LOCKS,
00057     SecPfLock               = SI_PF_LOCKS,
00059     SecNofTypes             = SI_NOF_TYPES,
00060 };
00061
00062 /*  ========================================================================
00063                                   SecLockCauses
00064     ========================================================================*/
00065 // (ms.h: T_SI_LOCK_CAUSES)
00067 enum SecLockCause {
00069     SecSucceded         = SI_SEC_SUCCEEDED,
00071     SecLockInvalid      = SI_SEC_LOCK_INVALID,
00073     SecUnauthorisized   = SI_SEC_UNAUTHORISIZED_ACTION,
00075     SecPersCodeError    = SI_SEC_PERS_CODE_ERROR,
00077     SecControlKeyError  = SI_SEC_CONTROL_KEY_ERROR,
00079     SecStorageError     = SI_SEC_STORAGE_ERROR,
00081     SecNoMoreTrials     = SI_SEC_NO_MORE_TRIALS,
00082 };
00083
00084 /*  ========================================================================
00085                                   SecLockStatus
00086     ========================================================================*/
00087 // (ms.h: T_SI_LOCK_STATUS)
00089 enum SecLockStatus {
00091     SecLockArmed            = SI_LOCK_ARMED,
00093     SecLockActive           = SI_LOCK_ACTIVE,
00095     SecLockPermanentActive  = SI_LOCK_PERMANENT_ACTIVE,
00097     SecLockBlocked          = SI_LOCK_BLOCKED,
00099     SecLockDeactive         = SI_LOCK_DEACTIVE,
00101     SecLockDisabled         = SI_LOCK_DISABLED,
00103     SecLockAutoActivated    = SI_LOCK_AUTOACTIVATED,
00105     SecLockLastState        = SI_SEC_LAST_STATE,
00107     SecLockLocked           = SI_LOCKED,
00109     SecLockUnlocked         = SI_UNLOCKED,
00110 };
00111
00112 /*  ========================================================================
00113                                   SecLockResult
00114     ========================================================================*/
00115 // (ms.h: T_SI_LOCK_RESULT)
00117 enum SecLockResult {
00119     SecContinueOperation    = SI_SEC_CONTINUE_OPERATION,
00121     SecVerificationNeeded   = SI_SEC_VERIFICATION_NEEDED,
00123     SecNoFurtherOperation   = SI_SEC_NO_FURTHER_OPERATION,
00125     SecLockError            = SI_SEC_LOCK_ERROR,
00127     SecUnknownResult        = SI_UNKNOWN_RES,
00129     SecProfileUpdate        = SI_PROFILE_UPDATE,
00131     SecImeiInvalid          = SI_SEC_IMEI_INVALID,
00132
00133 };
00134
00135 /*  ========================================================================
00136                                   SecLockCode
00137     ========================================================================*/
00138 // (ms.h: T_SI_LOCK_CODE)
00139 struct SecLockCode {
00140     UINT8 val[17];
00141 };
00142
00143
00144 /*  ========================================================================
00145                                   SecMmiConfigData
00146     ========================================================================*/
00147 // (ms.h: T_SI_MMI_CONFIG_DATA)
00148 struct SecMmiConfigData {
00149     UINT8 val[2];
00150 };
00151
00152
00153 /*  ========================================================================
00154                                   SecLockCommand
00155     ========================================================================*/
00156 // (ms.h: T_SI_LOCK_CMD)
00157 struct SecLockCommand {
00158     SecLockAction action;
00159     SecLockType   type;
00160     SecLockCode   oldpwd;
00161     SecLockCode   newpwd;
00162 };
00163
00164 /*  ========================================================================
00165                                   SecLockDescriptor
00166     ========================================================================*/
00167 // (ms.h: T_SI_LOCK_DESCRIPTOR)
00168 struct SecLockDescriptor {
00169     SecLockType   lock_type;
00170     SecLockStatus lock_status;
00171     SecLockResult lock_result;
00172     UINT8         lock_dcp_sup;
00173     UINT8         lock_retrial_method;
00174     INT           lock_retrial_count;
00175     UINT32        lock_time;
00176     UINT8         lock_order;
00177 };
00178
00179 /*  ========================================================================
00180                                   SecLocks
00181     ========================================================================*/
00182 // (ms.h: T_SI_LOCKS)
00183
00184 const INT c_max_no_sec_locks = 6;
00185
00186 struct SecLocks {
00187     SecLockDescriptor val[c_max_no_sec_locks];
00188 };
00189
00190 /*  ========================================================================
00191                                   SecLockStates
00192     ========================================================================*/
00193 // (ms.h: T_SI_LOCK_STATES)
00194 struct SecLockStates {
00195     INT              no_locks;
00196     UINT8            no_rfiles;
00197     SecLockCause     lock_cause;
00198     SecLocks         locks;
00199     SecLockResult    lock_result;
00200     INT              tracediag;
00201     SecMmiConfigData mmi_configuration;
00202 };
00203
00204 #endif  // Apc_LockTypes_hpp
00205
00206
Generated on Tue Jan 24 14:46:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MdhSmsStackMsgArgs.cpp File Reference

Apc/MdhSmsStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "MdhSmsStackMsgArgs.hpp"

Include dependency graph for MdhSmsStackMsgArgs.cpp:

Generated on Tue Jan 24 16:55:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MdhSmsStackMsgArgs.hpp File Reference

Apc/MdhSmsStackMsgArgs.hpp File Reference

#include <Apc/MdhTypes.hpp>
#include <Apc/Tpdu.hpp>
#include <Apc/Sms.hpp>

Include dependency graph for MdhSmsStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MdhDeregistrationCnfArg
class | MdhDeregistrationReqArg
class | MdhMakeViewCnfArg
class | MdhMakeViewReqArg
class | MdhNewStatusReportIndArg
class | MdhRegistrationCnfArg
class | MdhRegistrationReqArg
class | MdhRemoveViewCnfArg
class | MdhRemoveViewReqArg
class | MdhSetConfigCnfArg
class | MdhSetConfigReqArg
class | MdhSetStorageCnfArg
class | MdhSetStorageReqArg
class | MdhSmsConcRefNumIndArg
class | MdhSmsConcRefNumReqArg
class | MdhSmsDeletionIndArg
class | MdhSmsDeletionReqArg
class | MdhSmsExtendedDataIndArg
class | MdhSmsExtendedDataReqArg
class | MdhSmsInitFinishedIndArg
class | MdhSmsNewMessageIndArg
class | MdhSmsReadIndArg
class | MdhSmsReadReqArg
class | MdhSmsRefreshIndArg
class | MdhSmsReportReadIndArg
class | MdhSmsReportReadReqArg
class | MdhSmsSetWaitingReqArg
class | MdhSmsStatusIndArg
class | MdhSmsStatusReqArg
class | MdhSmsStorageRefreshIndArg
class | MdhSmsTransmitAckArg
class | MdhSmsTransmitIndArg
class | MdhSmsTransmitStartAckArg
class | MdhSmsTransmitStartIndArg
class | MdhSmsTransmitStopIndArg
class | MdhSmsUpdStatusIndArg
class | MdhSmsUpdStatusRefreshIndArg
class | MdhSmsUpdStatusReqArg
class | MdhSmsWaitingIndArg
class | MdhSmsWriteCnfArg
class | MdhSmsWriteReqArg

Defines

#define | Apc_MdhSmsStackMsgArgs_hpp

Define Documentation

#define Apc_MdhSmsStackMsgArgs_hpp

Generated on Tue Jan 24 16:56:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MdhSmsStackMsgArgs.hpp Source File

Apc/MdhSmsStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "dallaros_stack_test_pu_dv\lnz_apoxi\Apoxi\Apc\MdhSmsArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_MdhSmsStackMsgArgs_hpp)
00016 #define Apc_MdhSmsStackMsgArgs_hpp
00017
00018 #include <Apc/MdhTypes.hpp>
00019 #include <Apc/Tpdu.hpp>
00020 #include <Apc/Sms.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class MdhDeregistrationCnfArg
00029     ====================================================================== */
00030
00032 class MdhDeregistrationCnfArg : public StackMsgArgument {
00033     friend class CommonStackMsgArgsDestroyTableNode;
00034     public:
00035         MdhDeregistrationCnfArg();
00036
00037         static const MdhDeregistrationCnfArg& Cast(const StackMsgArgument& arg);
00038         void SetResult(const MdhResult& result) { m_result = result; }
00039         const MdhResult& GetResult() const { return m_result; }
00040
00041         enum  {
00042             ID = 5439
00043             };
00044
00045     private:
00046
00047         static void Destroy(StackMsgArgument* arg) { delete ((MdhDeregistrationCnfArg*) arg); }
00048
00049         MdhResult m_result;
00050
00051     };
00052
00053 // Inline definitions
00054 inline const MdhDeregistrationCnfArg& MdhDeregistrationCnfArg::Cast(const StackMsgArgument& arg) {
00055     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhDeregistrationCnfArg!\n");
00056     return ((MdhDeregistrationCnfArg &) arg);
00057 }
00058
00059
00060
00061 /*  ======================================================================
00062     Class MdhRegistrationCnfArg
00063     ====================================================================== */
00064
00066 class MdhRegistrationCnfArg : public StackMsgArgument {
00067     friend class CommonStackMsgArgsDestroyTableNode;
00068     public:
00069         MdhRegistrationCnfArg();
00070
00071         static const MdhRegistrationCnfArg& Cast(const StackMsgArgument& arg);
00072         void SetResult(const MdhResult& result) { m_result = result; }
00073         const MdhResult& GetResult() const { return m_result; }
00074         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
00075         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
00076
00077         enum  {
00078             ID = 5441
00079             };
00080
00081     private:
00082
00083         static void Destroy(StackMsgArgument* arg) { delete ((MdhRegistrationCnfArg*) arg); }
00084
00085         MdhResult m_result;
00086         MdhViewHdl m_view_hdl;
00087
00088     };
00089
00090 // Inline definitions
00091 inline const MdhRegistrationCnfArg& MdhRegistrationCnfArg::Cast(const StackMsgArgument& arg) {
00092     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhRegistrationCnfArg!\n");
00093     return ((MdhRegistrationCnfArg &) arg);
00094 }
00095
00096
00097
00098 /*  ======================================================================
00099     Class MdhSmsStatusIndArg
00100     ====================================================================== */
00101
00103 class MdhSmsStatusIndArg : public StackMsgArgument {
00104     friend class CommonStackMsgArgsDestroyTableNode;
00105     public:
00106         MdhSmsStatusIndArg();
00107
00108         static const MdhSmsStatusIndArg& Cast(const StackMsgArgument& arg);
00109         void SetResult(const MdhResult& result) { m_result = result; }
00110         const MdhResult& GetResult() const { return m_result; }
00111         void SetLastUsed(UINT8 last_used) { m_last_used = last_used; }
00112         UINT8 GetLastUsed() const { return m_last_used; }
00113         void SetNotification(UINT8 notification) { m_notification = notification; }
00114         UINT8 GetNotification() const { return m_notification; }
00115
00116         enum  {
00117             ID = 5444
00118             };
00119
00120     private:
00121
00122         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsStatusIndArg*) arg); }
00123
00124         MdhResult m_result;
00125         UINT8 m_last_used;
00126         UINT8 m_notification;
00127
00128     };
00129
00130 // Inline definitions
00131 inline const MdhSmsStatusIndArg& MdhSmsStatusIndArg::Cast(const StackMsgArgument& arg) {
00132     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsStatusIndArg!\n");
00133     return ((MdhSmsStatusIndArg &) arg);
00134 }
00135
00136
00137
00138 /*  ======================================================================
00139     Class MdhSmsUpdStatusIndArg
00140     ====================================================================== */
00141
00143 class MdhSmsUpdStatusIndArg : public StackMsgArgument {
00144     friend class CommonStackMsgArgsDestroyTableNode;
00145     public:
00146         MdhSmsUpdStatusIndArg();
00147
00148         static const MdhSmsUpdStatusIndArg& Cast(const StackMsgArgument& arg);
00149         void SetResult(const MdhResult& result) { m_result = result; }
00150         const MdhResult& GetResult() const { return m_result; }
00151         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
00152         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
00153         void SetRecno(INT recno) { m_recno = recno; }
00154         INT GetRecno() const { return m_recno; }
00155
00156         enum  {
00157             ID = 5446
00158             };
00159
00160     private:
00161
00162         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsUpdStatusIndArg*) arg); }
00163
00164         MdhResult m_result;
00165         MdhViewHdl m_view_hdl;
00166         INT m_recno;
00167
00168     };
00169
00170 // Inline definitions
00171 inline const MdhSmsUpdStatusIndArg& MdhSmsUpdStatusIndArg::Cast(const StackMsgArgument& arg) {
00172     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsUpdStatusIndArg!\n");
00173     return ((MdhSmsUpdStatusIndArg &) arg);
00174 }
00175
00176
00177
00178 /*  ======================================================================
00179     Class MdhSetStorageCnfArg
00180     ====================================================================== */
00181
00183 class MdhSetStorageCnfArg : public StackMsgArgument {
00184     friend class CommonStackMsgArgsDestroyTableNode;
00185     public:
00186         MdhSetStorageCnfArg();
00187
00188         static const MdhSetStorageCnfArg& Cast(const StackMsgArgument& arg);
00189         void SetResult(const MdhResult& result) { m_result = result; }
00190         const MdhResult& GetResult() const { return m_result; }
00191
00192         enum  {
00193             ID = 5448
00194             };
00195
00196     private:
00197
00198         static void Destroy(StackMsgArgument* arg) { delete ((MdhSetStorageCnfArg*) arg); }
00199
00200         MdhResult m_result;
00201
00202     };
00203
00204 // Inline definitions
00205 inline const MdhSetStorageCnfArg& MdhSetStorageCnfArg::Cast(const StackMsgArgument& arg) {
00206     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSetStorageCnfArg!\n");
00207     return ((MdhSetStorageCnfArg &) arg);
00208 }
00209
00210
00211
00212 /*  ======================================================================
00213     Class MdhSmsReadIndArg
00214     ====================================================================== */
00215
00217 class MdhSmsReadIndArg : public StackMsgArgument {
00218     friend class CommonStackMsgArgsDestroyTableNode;
00219     public:
00220         MdhSmsReadIndArg();
00221
00222         static const MdhSmsReadIndArg& Cast(const StackMsgArgument& arg);
00223         void SetResult(const MdhResult& result) { m_result = result; }
00224         const MdhResult& GetResult() const { return m_result; }
00225         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
00226         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
00227         void SetSmsId(INT sms_id) { m_sms_id = sms_id; }
00228         INT GetSmsId() const { return m_sms_id; }
00229         void SetTpduConc(const TpduConc& tpdu_conc) { m_tpdu_conc = tpdu_conc; }
00230         const TpduConc& GetTpduConc() const { return m_tpdu_conc; }
00231         void SetTimeStamp(const MdhTimeStamp& time_stamp) { m_time_stamp = time_stamp; }
00232         const MdhTimeStamp& GetTimeStamp() const { return m_time_stamp; }
00233         void SetExtendedData(const MdhExtendedData& extended_data) { m_extended_data = extended_data; }
00234         const MdhExtendedData& GetExtendedData() const { return m_extended_data; }
00235
00236         enum  {
00237             ID = 5450
00238             };
00239
00240     private:
00241
00242         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsReadIndArg*) arg); }
00243
00244         MdhResult m_result;
00245         MdhViewHdl m_view_hdl;
00246         INT m_sms_id;
00247         TpduConc m_tpdu_conc;
00248         MdhTimeStamp m_time_stamp;
00249         MdhExtendedData m_extended_data;
00250
00251     };
00252
00253 // Inline definitions
00254 inline const MdhSmsReadIndArg& MdhSmsReadIndArg::Cast(const StackMsgArgument& arg) {
00255     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsReadIndArg!\n");
00256     return ((MdhSmsReadIndArg &) arg);
00257 }
00258
00259
00260
00261 /*  ======================================================================
00262     Class MdhSmsWriteCnfArg
00263     ====================================================================== */
00264
00266 class MdhSmsWriteCnfArg : public StackMsgArgument {
00267     friend class CommonStackMsgArgsDestroyTableNode;
00268     public:
00269         MdhSmsWriteCnfArg();
00270
00271         static const MdhSmsWriteCnfArg& Cast(const StackMsgArgument& arg);
00272         void SetResult(const MdhResult& result) { m_result = result; }
00273         const MdhResult& GetResult() const { return m_result; }
00274         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
00275         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
00276         void SetSmsId(INT sms_id) { m_sms_id = sms_id; }
00277         INT GetSmsId() const { return m_sms_id; }
00278         void SetNoOfSaved(UINT8 no_of_saved) { m_no_of_saved = no_of_saved; }
00279         UINT8 GetNoOfSaved() const { return m_no_of_saved; }
00280         void SetTimeStamp(const MdhTimeStamp& time_stamp) { m_time_stamp = time_stamp; }
00281         const MdhTimeStamp& GetTimeStamp() const { return m_time_stamp; }
00282
00283         enum  {
00284             ID = 5452
00285             };
00286
00287     private:
00288
00289         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsWriteCnfArg*) arg); }
00290
00291         MdhResult m_result;
00292         MdhViewHdl m_view_hdl;
00293         INT m_sms_id;
00294         UINT8 m_no_of_saved;
00295         MdhTimeStamp m_time_stamp;
00296
00297     };
00298
00299 // Inline definitions
00300 inline const MdhSmsWriteCnfArg& MdhSmsWriteCnfArg::Cast(const StackMsgArgument& arg) {
00301     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsWriteCnfArg!\n");
00302     return ((MdhSmsWriteCnfArg &) arg);
00303 }
00304
00305
00306
00307 /*  ======================================================================
00308     Class MdhSetConfigCnfArg
00309     ====================================================================== */
00310
00312 class MdhSetConfigCnfArg : public StackMsgArgument {
00313     friend class CommonStackMsgArgsDestroyTableNode;
00314     public:
00315         MdhSetConfigCnfArg();
00316
00317         static const MdhSetConfigCnfArg& Cast(const StackMsgArgument& arg);
00318         void SetResult(const MdhResult& result) { m_result = result; }
00319         const MdhResult& GetResult() const { return m_result; }
00320         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
00321         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
00322
00323         enum  {
00324             ID = 5456
00325             };
00326
00327     private:
00328
00329         static void Destroy(StackMsgArgument* arg) { delete ((MdhSetConfigCnfArg*) arg); }
00330
00331         MdhResult m_result;
00332         MdhViewHdl m_view_hdl;
00333
00334     };
00335
00336 // Inline definitions
00337 inline const MdhSetConfigCnfArg& MdhSetConfigCnfArg::Cast(const StackMsgArgument& arg) {
00338     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSetConfigCnfArg!\n");
00339     return ((MdhSetConfigCnfArg &) arg);
00340 }
00341
00342
00343
00344 /*  ======================================================================
00345     Class MdhMakeViewCnfArg
00346     ====================================================================== */
00347
00349 class MdhMakeViewCnfArg : public StackMsgArgument {
00350     friend class CommonStackMsgArgsDestroyTableNode;
00351     public:
00352         MdhMakeViewCnfArg();
00353
00354         static const MdhMakeViewCnfArg& Cast(const StackMsgArgument& arg);
00355         void SetResult(const MdhResult& result) { m_result = result; }
00356         const MdhResult& GetResult() const { return m_result; }
00357         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
00358         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
00359
00360         enum  {
00361             ID = 5458
00362             };
00363
00364     private:
00365
00366         static void Destroy(StackMsgArgument* arg) { delete ((MdhMakeViewCnfArg*) arg); }
00367
00368         MdhResult m_result;
00369         MdhViewHdl m_view_hdl;
00370
00371     };
00372
00373 // Inline definitions
00374 inline const MdhMakeViewCnfArg& MdhMakeViewCnfArg::Cast(const StackMsgArgument& arg) {
00375     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhMakeViewCnfArg!\n");
00376     return ((MdhMakeViewCnfArg &) arg);
00377 }
00378
00379
00380
00381 /*  ======================================================================
00382     Class MdhRemoveViewCnfArg
00383     ====================================================================== */
00384
00386 class MdhRemoveViewCnfArg : public StackMsgArgument {
00387     friend class CommonStackMsgArgsDestroyTableNode;
00388     public:
00389         MdhRemoveViewCnfArg();
00390
00391         static const MdhRemoveViewCnfArg& Cast(const StackMsgArgument& arg);
00392         void SetResult(const MdhResult& result) { m_result = result; }
00393         const MdhResult& GetResult() const { return m_result; }
00394         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
00395         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
00396
00397         enum  {
00398             ID = 5460
00399             };
00400
00401     private:
00402
00403         static void Destroy(StackMsgArgument* arg) { delete ((MdhRemoveViewCnfArg*) arg); }
00404
00405         MdhResult m_result;
00406         MdhViewHdl m_view_hdl;
00407
00408     };
00409
00410 // Inline definitions
00411 inline const MdhRemoveViewCnfArg& MdhRemoveViewCnfArg::Cast(const StackMsgArgument& arg) {
00412     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhRemoveViewCnfArg!\n");
00413     return ((MdhRemoveViewCnfArg &) arg);
00414 }
00415
00416
00417
00418 /*  ======================================================================
00419     Class MdhNewStatusReportIndArg
00420     ====================================================================== */
00421
00423 class MdhNewStatusReportIndArg : public StackMsgArgument {
00424     friend class CommonStackMsgArgsDestroyTableNode;
00425     public:
00426         MdhNewStatusReportIndArg();
00427
00428         static const MdhNewStatusReportIndArg& Cast(const StackMsgArgument& arg);
00429         void SetSmsrLocation(const MdhSmsrLocation& smsr_location) { m_smsr_location = smsr_location; }
00430         const MdhSmsrLocation& GetSmsrLocation() const { return m_smsr_location; }
00431         void SetLink(INT link) { m_link = link; }
00432         INT GetLink() const { return m_link; }
00433         void SetSrPos(INT sr_pos) { m_sr_pos = sr_pos; }
00434         INT GetSrPos() const { return m_sr_pos; }
00435         void SetSrStatus(UINT8 sr_status) { m_sr_status = sr_status; }
00436         UINT8 GetSrStatus() const { return m_sr_status; }
00437         void SetTpdu(const Tpdu& tpdu) { m_tpdu = tpdu; }
00438         const Tpdu& GetTpdu() const { return m_tpdu; }
00439
00440         enum  {
00441             ID = 5463
00442             };
00443
00444     private:
00445
00446         static void Destroy(StackMsgArgument* arg) { delete ((MdhNewStatusReportIndArg*) arg); }
00447
00448         MdhSmsrLocation m_smsr_location;
00449         INT m_link;
00450         INT m_sr_pos;
00451         UINT8 m_sr_status;
00452         Tpdu m_tpdu;
00453
00454     };
00455
00456 // Inline definitions
00457 inline const MdhNewStatusReportIndArg& MdhNewStatusReportIndArg::Cast(const StackMsgArgument& arg) {
00458     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhNewStatusReportIndArg!\n");
00459     return ((MdhNewStatusReportIndArg &) arg);
00460 }
00461
00462
00463
00464 /*  ======================================================================
00465     Class MdhSmsRefreshIndArg
00466     ====================================================================== */
00467
00469 class MdhSmsRefreshIndArg : public StackMsgArgument {
00470     friend class CommonStackMsgArgsDestroyTableNode;
00471     public:
00472         MdhSmsRefreshIndArg();
00473
00474         static const MdhSmsRefreshIndArg& Cast(const StackMsgArgument& arg);
00475         void SetStatus(UINT8 status) { m_status = status; }
00476         UINT8 GetStatus() const { return m_status; }
00477         void SetStoragePosition(INT storage_position) { m_storage_position = storage_position; }
00478         INT GetStoragePosition() const { return m_storage_position; }
00479         void SetTimeStamp(const MdhTimeStamp& time_stamp) { m_time_stamp = time_stamp; }
00480         const MdhTimeStamp& GetTimeStamp() const { return m_time_stamp; }
00481
00482         enum  {
00483             ID = 5464
00484             };
00485
00486     private:
00487
00488         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsRefreshIndArg*) arg); }
00489
00490         UINT8 m_status;
00491         INT m_storage_position;
00492         MdhTimeStamp m_time_stamp;
00493
00494     };
00495
00496 // Inline definitions
00497 inline const MdhSmsRefreshIndArg& MdhSmsRefreshIndArg::Cast(const StackMsgArgument& arg) {
00498     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsRefreshIndArg!\n");
00499     return ((MdhSmsRefreshIndArg &) arg);
00500 }
00501
00502
00503
00504 /*  ======================================================================
00505     Class MdhSmsStorageRefreshIndArg
00506     ====================================================================== */
00507
00509 class MdhSmsStorageRefreshIndArg : public StackMsgArgument {
00510     friend class CommonStackMsgArgsDestroyTableNode;
00511     public:
00512         MdhSmsStorageRefreshIndArg();
00513
00514         static const MdhSmsStorageRefreshIndArg& Cast(const StackMsgArgument& arg);
00515         void SetWorkMedia(const MdhWorkMedia& work_media) { m_work_media = work_media; }
00516         const MdhWorkMedia& GetWorkMedia() const { return m_work_media; }
00517
00518         enum  {
00519             ID = 5465
00520             };
00521
00522     private:
00523
00524         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsStorageRefreshIndArg*) arg); }
00525
00526         MdhWorkMedia m_work_media;
00527
00528     };
00529
00530 // Inline definitions
00531 inline const MdhSmsStorageRefreshIndArg& MdhSmsStorageRefreshIndArg::Cast(const StackMsgArgument& arg) {
00532     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsStorageRefreshIndArg!\n");
00533     return ((MdhSmsStorageRefreshIndArg &) arg);
00534 }
00535
00536
00537
00538 /*  ======================================================================
00539     Class MdhSmsUpdStatusRefreshIndArg
00540     ====================================================================== */
00541
00543 class MdhSmsUpdStatusRefreshIndArg : public StackMsgArgument {
00544     friend class CommonStackMsgArgsDestroyTableNode;
00545     public:
00546         MdhSmsUpdStatusRefreshIndArg();
00547
00548         static const MdhSmsUpdStatusRefreshIndArg& Cast(const StackMsgArgument& arg);
00549         void SetStatus(UINT8 status) { m_status = status; }
00550         UINT8 GetStatus() const { return m_status; }
00551         void SetStoragePosition(INT storage_position) { m_storage_position = storage_position; }
00552         INT GetStoragePosition() const { return m_storage_position; }
00553
00554         enum  {
00555             ID = 5466
00556             };
00557
00558     private:
00559
00560         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsUpdStatusRefreshIndArg*) arg); }
00561
00562         UINT8 m_status;
00563         INT m_storage_position;
00564
00565     };
00566
00567 // Inline definitions
00568 inline const MdhSmsUpdStatusRefreshIndArg& MdhSmsUpdStatusRefreshIndArg::Cast(const StackMsgArgument& arg) {
00569     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsUpdStatusRefreshIndArg!\n");
00570     return ((MdhSmsUpdStatusRefreshIndArg &) arg);
00571 }
00572
00573
00574
00575 /*  ======================================================================
00576     Class MdhSmsNewMessageIndArg
00577     ====================================================================== */
00578
00580 class MdhSmsNewMessageIndArg : public StackMsgArgument {
00581     friend class CommonStackMsgArgsDestroyTableNode;
00582     public:
00583         MdhSmsNewMessageIndArg();
00584
00585         static const MdhSmsNewMessageIndArg& Cast(const StackMsgArgument& arg);
00586         void SetStorageType(const Sms::StorageType& storage_type) { m_storage_type = storage_type; }
00587         const Sms::StorageType& GetStorageType() const { return m_storage_type; }
00588         void SetStoragePosition(INT storage_position) { m_storage_position = storage_position; }
00589         INT GetStoragePosition() const { return m_storage_position; }
00590         void SetProtocolIdentifier(const ProtocolIdentifier& protocol_identifier) { m_protocol_identifier = protocol_identifier; }
00591         const ProtocolIdentifier& GetProtocolIdentifier() const { return m_protocol_identifier; }
00592         void SetDataCodingScheme(const DataCodingScheme& data_coding_scheme) { m_data_coding_scheme = data_coding_scheme; }
00593         const DataCodingScheme& GetDataCodingScheme() const { return m_data_coding_scheme; }
00594         void SetUpdated(BOOLEAN updated) { m_updated = updated; }
00595         BOOLEAN IsUpdated() const { return m_updated; }
00596         void SetWaitIndicatorArray(const MdhWaitIndicatorArray& wait_indicator_array) { m_wait_indicator_array = wait_indicator_array; }
00597         const MdhWaitIndicatorArray& GetWaitIndicatorArray() const { return m_wait_indicator_array; }
00598         void SetTpdu(const Tpdu& tpdu) { m_tpdu = tpdu; }
00599         const Tpdu& GetTpdu() const { return m_tpdu; }
00600
00601         enum  {
00602             ID = 5467
00603             };
00604
00605     private:
00606
00607         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsNewMessageIndArg*) arg); }
00608
00609         Sms::StorageType m_storage_type;
00610         INT m_storage_position;
00611         ProtocolIdentifier m_protocol_identifier;
00612         DataCodingScheme m_data_coding_scheme;
00613         BOOLEAN m_updated;
00614         MdhWaitIndicatorArray m_wait_indicator_array;
00615         Tpdu m_tpdu;
00616
00617     };
00618
00619 // Inline definitions
00620 inline const MdhSmsNewMessageIndArg& MdhSmsNewMessageIndArg::Cast(const StackMsgArgument& arg) {
00621     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsNewMessageIndArg!\n");
00622     return ((MdhSmsNewMessageIndArg &) arg);
00623 }
00624
00625
00626
00627 /*  ======================================================================
00628     Class MdhSmsInitFinishedIndArg
00629     ====================================================================== */
00630
00632 class MdhSmsInitFinishedIndArg : public StackMsgArgument {
00633     friend class CommonStackMsgArgsDestroyTableNode;
00634     public:
00635         MdhSmsInitFinishedIndArg();
00636
00637         static const MdhSmsInitFinishedIndArg& Cast(const StackMsgArgument& arg);
00638         void SetUpdated(BOOLEAN updated) { m_updated = updated; }
00639         BOOLEAN IsUpdated() const { return m_updated; }
00640         void SetWaitIndicatorArray(const MdhWaitIndicatorArray& wait_indicator_array) { m_wait_indicator_array = wait_indicator_array; }
00641         const MdhWaitIndicatorArray& GetWaitIndicatorArray() const { return m_wait_indicator_array; }
00642
00643         enum  {
00644             ID = 5468
00645             };
00646
00647     private:
00648
00649         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsInitFinishedIndArg*) arg); }
00650
00651         BOOLEAN m_updated;
00652         MdhWaitIndicatorArray m_wait_indicator_array;
00653
00654     };
00655
00656 // Inline definitions
00657 inline const MdhSmsInitFinishedIndArg& MdhSmsInitFinishedIndArg::Cast(const StackMsgArgument& arg) {
00658     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsInitFinishedIndArg!\n");
00659     return ((MdhSmsInitFinishedIndArg &) arg);
00660 }
00661
00662
00663
00664 /*  ======================================================================
00665     Class MdhSmsWaitingIndArg
00666     ====================================================================== */
00667
00669 class MdhSmsWaitingIndArg : public StackMsgArgument {
00670     friend class CommonStackMsgArgsDestroyTableNode;
00671     public:
00672         MdhSmsWaitingIndArg();
00673
00674         static const MdhSmsWaitingIndArg& Cast(const StackMsgArgument& arg);
00675         void SetUpdated(BOOLEAN updated) { m_updated = updated; }
00676         BOOLEAN IsUpdated() const { return m_updated; }
00677         void SetWaitIndicatorArray(const MdhWaitIndicatorArray& wait_indicator_array) { m_wait_indicator_array = wait_indicator_array; }
00678         const MdhWaitIndicatorArray& GetWaitIndicatorArray() const { return m_wait_indicator_array; }
00679
00680         enum  {
00681             ID = 5469
00682             };
00683
00684     private:
00685
00686         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsWaitingIndArg*) arg); }
00687
00688         BOOLEAN m_updated;
00689         MdhWaitIndicatorArray m_wait_indicator_array;
00690
00691     };
00692
00693 // Inline definitions
00694 inline const MdhSmsWaitingIndArg& MdhSmsWaitingIndArg::Cast(const StackMsgArgument& arg) {
00695     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsWaitingIndArg!\n");
00696     return ((MdhSmsWaitingIndArg &) arg);
00697 }
00698
00699
00700
00701 /*  ======================================================================
00702     Class MdhSmsTransmitStartIndArg
00703     ====================================================================== */
00704
00706 class MdhSmsTransmitStartIndArg : public StackMsgArgument {
00707     friend class CommonStackMsgArgsDestroyTableNode;
00708     public:
00709         MdhSmsTransmitStartIndArg();
00710
00711         static const MdhSmsTransmitStartIndArg& Cast(const StackMsgArgument& arg);
00712         void SetView(UINT8 view) { m_view = view; }
00713         UINT8 GetView() const { return m_view; }
00714         void SetTransmitCause(const MdhTransmitCause& transmit_cause) { m_transmit_cause = transmit_cause; }
00715         const MdhTransmitCause& GetTransmitCause() const { return m_transmit_cause; }
00716         void SetNoNvramSms(INT no_nvram_sms) { m_no_nvram_sms = no_nvram_sms; }
00717         INT GetNoNvramSms() const { return m_no_nvram_sms; }
00718         void SetNoSimSms(INT no_sim_sms) { m_no_sim_sms = no_sim_sms; }
00719         INT GetNoSimSms() const { return m_no_sim_sms; }
00720
00721         enum  {
00722             ID = 5470
00723             };
00724
00725     private:
00726
00727         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsTransmitStartIndArg*) arg); }
00728
00729         UINT8 m_view;
00730         MdhTransmitCause m_transmit_cause;
00731         INT m_no_nvram_sms;
00732         INT m_no_sim_sms;
00733
00734     };
00735
00736 // Inline definitions
00737 inline const MdhSmsTransmitStartIndArg& MdhSmsTransmitStartIndArg::Cast(const StackMsgArgument& arg) {
00738     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsTransmitStartIndArg!\n");
00739     return ((MdhSmsTransmitStartIndArg &) arg);
00740 }
00741
00742
00743
00744 /*  ======================================================================
00745     Class MdhSmsTransmitIndArg
00746     ====================================================================== */
00747
00749 class MdhSmsTransmitIndArg : public StackMsgArgument {
00750     friend class CommonStackMsgArgsDestroyTableNode;
00751     public:
00752         MdhSmsTransmitIndArg();
00753
00754         static const MdhSmsTransmitIndArg& Cast(const StackMsgArgument& arg);
00755         void SetView(UINT8 view) { m_view = view; }
00756         UINT8 GetView() const { return m_view; }
00757         void SetPosition(INT position) { m_position = position; }
00758         INT GetPosition() const { return m_position; }
00759         void SetTpdu(const Tpdu& tpdu) { m_tpdu = tpdu; }
00760         const Tpdu& GetTpdu() const { return m_tpdu; }
00761         void SetWorkMedia(const MdhWorkMedia& work_media) { m_work_media = work_media; }
00762         const MdhWorkMedia& GetWorkMedia() const { return m_work_media; }
00763         void SetTimeStamp(const MdhTimeStamp& time_stamp) { m_time_stamp = time_stamp; }
00764         const MdhTimeStamp& GetTimeStamp() const { return m_time_stamp; }
00765         void SetExtendedData(const MdhExtendedData& extended_data) { m_extended_data = extended_data; }
00766         const MdhExtendedData& GetExtendedData() const { return m_extended_data; }
00767
00768         enum  {
00769             ID = 5471
00770             };
00771
00772     private:
00773
00774         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsTransmitIndArg*) arg); }
00775
00776         UINT8 m_view;
00777         INT m_position;
00778         Tpdu m_tpdu;
00779         MdhWorkMedia m_work_media;
00780         MdhTimeStamp m_time_stamp;
00781         MdhExtendedData m_extended_data;
00782
00783     };
00784
00785 // Inline definitions
00786 inline const MdhSmsTransmitIndArg& MdhSmsTransmitIndArg::Cast(const StackMsgArgument& arg) {
00787     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsTransmitIndArg!\n");
00788     return ((MdhSmsTransmitIndArg &) arg);
00789 }
00790
00791
00792
00793 /*  ======================================================================
00794     Class MdhSmsTransmitStopIndArg
00795     ====================================================================== */
00796
00798 class MdhSmsTransmitStopIndArg : public StackMsgArgument {
00799     friend class CommonStackMsgArgsDestroyTableNode;
00800     public:
00801         MdhSmsTransmitStopIndArg();
00802
00803         static const MdhSmsTransmitStopIndArg& Cast(const StackMsgArgument& arg);
00804         void SetView(UINT8 view) { m_view = view; }
00805         UINT8 GetView() const { return m_view; }
00806         void SetResult(const MdhResult& result) { m_result = result; }
00807         const MdhResult& GetResult() const { return m_result; }
00808
00809         enum  {
00810             ID = 5472
00811             };
00812
00813     private:
00814
00815         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsTransmitStopIndArg*) arg); }
00816
00817         UINT8 m_view;
00818         MdhResult m_result;
00819
00820     };
00821
00822 // Inline definitions
00823 inline const MdhSmsTransmitStopIndArg& MdhSmsTransmitStopIndArg::Cast(const StackMsgArgument& arg) {
00824     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsTransmitStopIndArg!\n");
00825     return ((MdhSmsTransmitStopIndArg &) arg);
00826 }
00827
00828
00829
00830 /*  ======================================================================
00831     Class MdhSmsReportReadIndArg
00832     ====================================================================== */
00833
00835 class MdhSmsReportReadIndArg : public StackMsgArgument {
00836     friend class CommonStackMsgArgsDestroyTableNode;
00837     public:
00838         MdhSmsReportReadIndArg();
00839
00840         static const MdhSmsReportReadIndArg& Cast(const StackMsgArgument& arg);
00841         void SetResult(const MdhResult& result) { m_result = result; }
00842         const MdhResult& GetResult() const { return m_result; }
00843         void SetView(UINT8 view) { m_view = view; }
00844         UINT8 GetView() const { return m_view; }
00845         void SetLinkRecNo(INT link_rec_no) { m_link_rec_no = link_rec_no; }
00846         INT GetLinkRecNo() const { return m_link_rec_no; }
00847         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
00848         INT GetRecNo() const { return m_rec_no; }
00849         void SetSmsrData(const SmsrData& smsr_data) { m_smsr_data = smsr_data; }
00850         const SmsrData& GetSmsrData() const { return m_smsr_data; }
00851         void SetLocation(const MdhSmsrLocation& location) { m_location = location; }
00852         const MdhSmsrLocation& GetLocation() const { return m_location; }
00853
00854         enum  {
00855             ID = 5473
00856             };
00857
00858     private:
00859
00860         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsReportReadIndArg*) arg); }
00861
00862         MdhResult m_result;
00863         UINT8 m_view;
00864         INT m_link_rec_no;
00865         INT m_rec_no;
00866         SmsrData m_smsr_data;
00867         MdhSmsrLocation m_location;
00868
00869     };
00870
00871 // Inline definitions
00872 inline const MdhSmsReportReadIndArg& MdhSmsReportReadIndArg::Cast(const StackMsgArgument& arg) {
00873     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsReportReadIndArg!\n");
00874     return ((MdhSmsReportReadIndArg &) arg);
00875 }
00876
00877
00878
00879 /*  ======================================================================
00880     Class MdhSmsConcRefNumIndArg
00881     ====================================================================== */
00882
00884 class MdhSmsConcRefNumIndArg : public StackMsgArgument {
00885     friend class CommonStackMsgArgsDestroyTableNode;
00886     public:
00887         MdhSmsConcRefNumIndArg();
00888
00889         static const MdhSmsConcRefNumIndArg& Cast(const StackMsgArgument& arg);
00890         void SetRefNo(UINT16 ref_no) { m_ref_no = ref_no; }
00891         UINT16 GetRefNo() const { return m_ref_no; }
00892
00893         enum  {
00894             ID = 5474
00895             };
00896
00897     private:
00898
00899         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsConcRefNumIndArg*) arg); }
00900
00901         UINT16 m_ref_no;
00902
00903     };
00904
00905 // Inline definitions
00906 inline const MdhSmsConcRefNumIndArg& MdhSmsConcRefNumIndArg::Cast(const StackMsgArgument& arg) {
00907     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsConcRefNumIndArg!\n");
00908     return ((MdhSmsConcRefNumIndArg &) arg);
00909 }
00910
00911
00912
00913 /*  ======================================================================
00914     Class MdhSmsDeletionIndArg
00915     ====================================================================== */
00916
00918 class MdhSmsDeletionIndArg : public StackMsgArgument {
00919     friend class CommonStackMsgArgsDestroyTableNode;
00920     public:
00921         MdhSmsDeletionIndArg();
00922
00923         static const MdhSmsDeletionIndArg& Cast(const StackMsgArgument& arg);
00924         void SetResult(const MdhResult& result) { m_result = result; }
00925         const MdhResult& GetResult() const { return m_result; }
00926         void SetView(UINT8 view) { m_view = view; }
00927         UINT8 GetView() const { return m_view; }
00928         void SetDeletionCmd(const MdhDeletionCmd& deletion_cmd) { m_deletion_cmd = deletion_cmd; }
00929         const MdhDeletionCmd& GetDeletionCmd() const { return m_deletion_cmd; }
00930         void SetPosition(INT position) { m_position = position; }
00931         INT GetPosition() const { return m_position; }
00932         void SetGors(const MdhGors& gors) { m_gors = gors; }
00933         const MdhGors& GetGors() const { return m_gors; }
00934
00935         enum  {
00936             ID = 5475
00937             };
00938
00939     private:
00940
00941         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsDeletionIndArg*) arg); }
00942
00943         MdhResult m_result;
00944         UINT8 m_view;
00945         MdhDeletionCmd m_deletion_cmd;
00946         INT m_position;
00947         MdhGors m_gors;
00948
00949     };
00950
00951 // Inline definitions
00952 inline const MdhSmsDeletionIndArg& MdhSmsDeletionIndArg::Cast(const StackMsgArgument& arg) {
00953     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsDeletionIndArg!\n");
00954     return ((MdhSmsDeletionIndArg &) arg);
00955 }
00956
00957
00958
00959 /*  ======================================================================
00960     Class MdhSmsExtendedDataIndArg
00961     ====================================================================== */
00962
00964 class MdhSmsExtendedDataIndArg : public StackMsgArgument {
00965     friend class CommonStackMsgArgsDestroyTableNode;
00966     public:
00967         MdhSmsExtendedDataIndArg();
00968
00969         static const MdhSmsExtendedDataIndArg& Cast(const StackMsgArgument& arg);
00970         void SetView(UINT8 view) { m_view = view; }
00971         UINT8 GetView() const { return m_view; }
00972         void SetResult(const MdhResult& result) { m_result = result; }
00973         const MdhResult& GetResult() const { return m_result; }
00974         void SetPosition(INT position) { m_position = position; }
00975         INT GetPosition() const { return m_position; }
00976
00977         enum  {
00978             ID = 5476
00979             };
00980
00981     private:
00982
00983         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsExtendedDataIndArg*) arg); }
00984
00985         UINT8 m_view;
00986         MdhResult m_result;
00987         INT m_position;
00988
00989     };
00990
00991 // Inline definitions
00992 inline const MdhSmsExtendedDataIndArg& MdhSmsExtendedDataIndArg::Cast(const StackMsgArgument& arg) {
00993     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsExtendedDataIndArg!\n");
00994     return ((MdhSmsExtendedDataIndArg &) arg);
00995 }
00996
00997
00998
00999 /*  ======================================================================
01000     Class MdhDeregistrationReqArg
01001     ====================================================================== */
01002
01004 class MdhDeregistrationReqArg : public StackMsgArgument {
01005     friend class CommonStackMsgArgsDestroyTableNode;
01006     public:
01007         MdhDeregistrationReqArg();
01008
01009         static const MdhDeregistrationReqArg& Cast(const StackMsgArgument& arg);
01010
01011         enum  {
01012             ID = 6438
01013             };
01014
01015     private:
01016
01017         static void Destroy(StackMsgArgument* arg) { delete ((MdhDeregistrationReqArg*) arg); }
01018
01019     };
01020
01021 // Inline definitions
01022 inline const MdhDeregistrationReqArg& MdhDeregistrationReqArg::Cast(const StackMsgArgument& arg) {
01023     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhDeregistrationReqArg!\n");
01024     return ((MdhDeregistrationReqArg &) arg);
01025 }
01026
01027
01028
01029 /*  ======================================================================
01030     Class MdhRegistrationReqArg
01031     ====================================================================== */
01032
01034 class MdhRegistrationReqArg : public StackMsgArgument {
01035     friend class CommonStackMsgArgsDestroyTableNode;
01036     public:
01037         MdhRegistrationReqArg();
01038
01039         static const MdhRegistrationReqArg& Cast(const StackMsgArgument& arg);
01040
01041         enum  {
01042             ID = 6440
01043             };
01044
01045     private:
01046
01047         static void Destroy(StackMsgArgument* arg) { delete ((MdhRegistrationReqArg*) arg); }
01048
01049     };
01050
01051 // Inline definitions
01052 inline const MdhRegistrationReqArg& MdhRegistrationReqArg::Cast(const StackMsgArgument& arg) {
01053     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhRegistrationReqArg!\n");
01054     return ((MdhRegistrationReqArg &) arg);
01055 }
01056
01057
01058
01059 /*  ======================================================================
01060     Class MdhSmsStatusReqArg
01061     ====================================================================== */
01062
01064 class MdhSmsStatusReqArg : public StackMsgArgument {
01065     friend class CommonStackMsgArgsDestroyTableNode;
01066     public:
01067         MdhSmsStatusReqArg();
01068
01069         static const MdhSmsStatusReqArg& Cast(const StackMsgArgument& arg);
01070
01071         enum  {
01072             ID = 6443
01073             };
01074
01075     private:
01076
01077         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsStatusReqArg*) arg); }
01078
01079     };
01080
01081 // Inline definitions
01082 inline const MdhSmsStatusReqArg& MdhSmsStatusReqArg::Cast(const StackMsgArgument& arg) {
01083     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsStatusReqArg!\n");
01084     return ((MdhSmsStatusReqArg &) arg);
01085 }
01086
01087
01088
01089 /*  ======================================================================
01090     Class MdhSmsUpdStatusReqArg
01091     ====================================================================== */
01092
01094 class MdhSmsUpdStatusReqArg : public StackMsgArgument {
01095     friend class CommonStackMsgArgsDestroyTableNode;
01096     public:
01097         MdhSmsUpdStatusReqArg(const MdhViewHdl& view_hdl, INT sms_id, UINT8 recstatus, UINT8 complete);
01098         MdhSmsUpdStatusReqArg();
01099
01100         static const MdhSmsUpdStatusReqArg& Cast(const StackMsgArgument& arg);
01101         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
01102         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
01103         void SetSmsId(INT sms_id) { m_sms_id = sms_id; }
01104         INT GetSmsId() const { return m_sms_id; }
01105         void SetRecstatus(UINT8 recstatus) { m_recstatus = recstatus; }
01106         UINT8 GetRecstatus() const { return m_recstatus; }
01107         void SetComplete(UINT8 complete) { m_complete = complete; }
01108         UINT8 GetComplete() const { return m_complete; }
01109
01110         enum  {
01111             ID = 6445
01112             };
01113
01114     private:
01115
01116         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsUpdStatusReqArg*) arg); }
01117
01118         MdhViewHdl m_view_hdl;
01119         INT m_sms_id;
01120         UINT8 m_recstatus;
01121         UINT8 m_complete;
01122
01123     };
01124
01125 // Inline definitions
01126 inline const MdhSmsUpdStatusReqArg& MdhSmsUpdStatusReqArg::Cast(const StackMsgArgument& arg) {
01127     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsUpdStatusReqArg!\n");
01128     return ((MdhSmsUpdStatusReqArg &) arg);
01129 }
01130
01131
01132
01133 /*  ======================================================================
01134     Class MdhSetStorageReqArg
01135     ====================================================================== */
01136
01138 class MdhSetStorageReqArg : public StackMsgArgument {
01139     friend class CommonStackMsgArgsDestroyTableNode;
01140     public:
01141         MdhSetStorageReqArg(const MdhWorkMedia& stor_media);
01142         MdhSetStorageReqArg();
01143
01144         static const MdhSetStorageReqArg& Cast(const StackMsgArgument& arg);
01145         void SetStorMedia(const MdhWorkMedia& stor_media) { m_stor_media = stor_media; }
01146         const MdhWorkMedia& GetStorMedia() const { return m_stor_media; }
01147
01148         enum  {
01149             ID = 6447
01150             };
01151
01152     private:
01153
01154         static void Destroy(StackMsgArgument* arg) { delete ((MdhSetStorageReqArg*) arg); }
01155
01156         MdhWorkMedia m_stor_media;
01157
01158     };
01159
01160 // Inline definitions
01161 inline const MdhSetStorageReqArg& MdhSetStorageReqArg::Cast(const StackMsgArgument& arg) {
01162     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSetStorageReqArg!\n");
01163     return ((MdhSetStorageReqArg &) arg);
01164 }
01165
01166
01167
01168 /*  ======================================================================
01169     Class MdhSmsReadReqArg
01170     ====================================================================== */
01171
01173 class MdhSmsReadReqArg : public StackMsgArgument {
01174     friend class CommonStackMsgArgsDestroyTableNode;
01175     public:
01176         MdhSmsReadReqArg(const MdhViewHdl& view_hdl, INT sms_id = 0);
01177         MdhSmsReadReqArg();
01178
01179         static const MdhSmsReadReqArg& Cast(const StackMsgArgument& arg);
01180         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
01181         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
01182         void SetSmsId(INT sms_id) { m_sms_id = sms_id; }
01183         INT GetSmsId() const { return m_sms_id; }
01184
01185         enum  {
01186             ID = 6449
01187             };
01188
01189     private:
01190
01191         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsReadReqArg*) arg); }
01192
01193         MdhViewHdl m_view_hdl;
01194         INT m_sms_id;
01195
01196     };
01197
01198 // Inline definitions
01199 inline const MdhSmsReadReqArg& MdhSmsReadReqArg::Cast(const StackMsgArgument& arg) {
01200     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsReadReqArg!\n");
01201     return ((MdhSmsReadReqArg &) arg);
01202 }
01203
01204
01205
01206 /*  ======================================================================
01207     Class MdhSmsWriteReqArg
01208     ====================================================================== */
01209
01211 class MdhSmsWriteReqArg : public StackMsgArgument {
01212     friend class CommonStackMsgArgsDestroyTableNode;
01213     public:
01214         MdhSmsWriteReqArg(const MdhViewHdl& view_hdl, INT sms_id, const TpduNode& pdu_node);
01215         MdhSmsWriteReqArg();
01216
01217         static const MdhSmsWriteReqArg& Cast(const StackMsgArgument& arg);
01218         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
01219         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
01220         void SetSmsId(INT sms_id) { m_sms_id = sms_id; }
01221         INT GetSmsId() const { return m_sms_id; }
01222         void SetPduNode(const TpduNode& pdu_node) { m_pdu_node = pdu_node; }
01223         const TpduNode& GetPduNode() const { return m_pdu_node; }
01224
01225         enum  {
01226             ID = 6451
01227             };
01228
01229     private:
01230
01231         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsWriteReqArg*) arg); }
01232
01233         MdhViewHdl m_view_hdl;
01234         INT m_sms_id;
01235         TpduNode m_pdu_node;
01236
01237     };
01238
01239 // Inline definitions
01240 inline const MdhSmsWriteReqArg& MdhSmsWriteReqArg::Cast(const StackMsgArgument& arg) {
01241     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsWriteReqArg!\n");
01242     return ((MdhSmsWriteReqArg &) arg);
01243 }
01244
01245
01246
01247 /*  ======================================================================
01248     Class MdhSetConfigReqArg
01249     ====================================================================== */
01250
01252 class MdhSetConfigReqArg : public StackMsgArgument {
01253     friend class CommonStackMsgArgsDestroyTableNode;
01254     public:
01255         MdhSetConfigReqArg(const MdhViewHdl& view_hdl, const MdhViewConfig& view_config);
01256         MdhSetConfigReqArg();
01257
01258         static const MdhSetConfigReqArg& Cast(const StackMsgArgument& arg);
01259         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
01260         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
01261         void SetViewConfig(const MdhViewConfig& view_config) { m_view_config = view_config; }
01262         const MdhViewConfig& GetViewConfig() const { return m_view_config; }
01263
01264         enum  {
01265             ID = 6455
01266             };
01267
01268     private:
01269
01270         static void Destroy(StackMsgArgument* arg) { delete ((MdhSetConfigReqArg*) arg); }
01271
01272         MdhViewHdl m_view_hdl;
01273         MdhViewConfig m_view_config;
01274
01275     };
01276
01277 // Inline definitions
01278 inline const MdhSetConfigReqArg& MdhSetConfigReqArg::Cast(const StackMsgArgument& arg) {
01279     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSetConfigReqArg!\n");
01280     return ((MdhSetConfigReqArg &) arg);
01281 }
01282
01283
01284
01285 /*  ======================================================================
01286     Class MdhMakeViewReqArg
01287     ====================================================================== */
01288
01290 class MdhMakeViewReqArg : public StackMsgArgument {
01291     friend class CommonStackMsgArgsDestroyTableNode;
01292     public:
01293         MdhMakeViewReqArg();
01294
01295         static const MdhMakeViewReqArg& Cast(const StackMsgArgument& arg);
01296
01297         enum  {
01298             ID = 6457
01299             };
01300
01301     private:
01302
01303         static void Destroy(StackMsgArgument* arg) { delete ((MdhMakeViewReqArg*) arg); }
01304
01305     };
01306
01307 // Inline definitions
01308 inline const MdhMakeViewReqArg& MdhMakeViewReqArg::Cast(const StackMsgArgument& arg) {
01309     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhMakeViewReqArg!\n");
01310     return ((MdhMakeViewReqArg &) arg);
01311 }
01312
01313
01314
01315 /*  ======================================================================
01316     Class MdhRemoveViewReqArg
01317     ====================================================================== */
01318
01320 class MdhRemoveViewReqArg : public StackMsgArgument {
01321     friend class CommonStackMsgArgsDestroyTableNode;
01322     public:
01323         MdhRemoveViewReqArg(const MdhViewHdl& view_hdl);
01324         MdhRemoveViewReqArg();
01325
01326         static const MdhRemoveViewReqArg& Cast(const StackMsgArgument& arg);
01327         void SetViewHdl(const MdhViewHdl& view_hdl) { m_view_hdl = view_hdl; }
01328         const MdhViewHdl& GetViewHdl() const { return m_view_hdl; }
01329
01330         enum  {
01331             ID = 6459
01332             };
01333
01334     private:
01335
01336         static void Destroy(StackMsgArgument* arg) { delete ((MdhRemoveViewReqArg*) arg); }
01337
01338         MdhViewHdl m_view_hdl;
01339
01340     };
01341
01342 // Inline definitions
01343 inline const MdhRemoveViewReqArg& MdhRemoveViewReqArg::Cast(const StackMsgArgument& arg) {
01344     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhRemoveViewReqArg!\n");
01345     return ((MdhRemoveViewReqArg &) arg);
01346 }
01347
01348
01349
01350 /*  ======================================================================
01351     Class MdhSmsSetWaitingReqArg
01352     ====================================================================== */
01353
01355 class MdhSmsSetWaitingReqArg : public StackMsgArgument {
01356     friend class CommonStackMsgArgsDestroyTableNode;
01357     public:
01358         MdhSmsSetWaitingReqArg(const MdhSetWaitIndicatorArray& set_wait_indicator_array);
01359         MdhSmsSetWaitingReqArg();
01360
01361         static const MdhSmsSetWaitingReqArg& Cast(const StackMsgArgument& arg);
01362         void SetSetWaitIndicatorArray(const MdhSetWaitIndicatorArray& set_wait_indicator_array) { m_set_wait_indicator_array = set_wait_indicator_array; }
01363         const MdhSetWaitIndicatorArray& GetSetWaitIndicatorArray() const { return m_set_wait_indicator_array; }
01364
01365         enum  {
01366             ID = 6462
01367             };
01368
01369     private:
01370
01371         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsSetWaitingReqArg*) arg); }
01372
01373         MdhSetWaitIndicatorArray m_set_wait_indicator_array;
01374
01375     };
01376
01377 // Inline definitions
01378 inline const MdhSmsSetWaitingReqArg& MdhSmsSetWaitingReqArg::Cast(const StackMsgArgument& arg) {
01379     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsSetWaitingReqArg!\n");
01380     return ((MdhSmsSetWaitingReqArg &) arg);
01381 }
01382
01383
01384
01385 /*  ======================================================================
01386     Class MdhSmsTransmitStartAckArg
01387     ====================================================================== */
01388
01390 class MdhSmsTransmitStartAckArg : public StackMsgArgument {
01391     friend class CommonStackMsgArgsDestroyTableNode;
01392     public:
01393         MdhSmsTransmitStartAckArg(UINT8 view, BOOLEAN shall_transmit);
01394         MdhSmsTransmitStartAckArg();
01395
01396         static const MdhSmsTransmitStartAckArg& Cast(const StackMsgArgument& arg);
01397         void SetView(UINT8 view) { m_view = view; }
01398         UINT8 GetView() const { return m_view; }
01399         void SetShallTransmit(BOOLEAN shall_transmit) { m_shall_transmit = shall_transmit; }
01400         BOOLEAN IsShallTransmit() const { return m_shall_transmit; }
01401
01402         enum  {
01403             ID = 6463
01404             };
01405
01406     private:
01407
01408         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsTransmitStartAckArg*) arg); }
01409
01410         UINT8 m_view;
01411         BOOLEAN m_shall_transmit;
01412
01413     };
01414
01415 // Inline definitions
01416 inline const MdhSmsTransmitStartAckArg& MdhSmsTransmitStartAckArg::Cast(const StackMsgArgument& arg) {
01417     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsTransmitStartAckArg!\n");
01418     return ((MdhSmsTransmitStartAckArg &) arg);
01419 }
01420
01421
01422
01423 /*  ======================================================================
01424     Class MdhSmsTransmitAckArg
01425     ====================================================================== */
01426
01428 class MdhSmsTransmitAckArg : public StackMsgArgument {
01429     friend class CommonStackMsgArgsDestroyTableNode;
01430     public:
01431         MdhSmsTransmitAckArg(UINT8 view, INT position, BOOLEAN shall_transmit);
01432         MdhSmsTransmitAckArg();
01433
01434         static const MdhSmsTransmitAckArg& Cast(const StackMsgArgument& arg);
01435         void SetView(UINT8 view) { m_view = view; }
01436         UINT8 GetView() const { return m_view; }
01437         void SetPosition(INT position) { m_position = position; }
01438         INT GetPosition() const { return m_position; }
01439         void SetShallTransmit(BOOLEAN shall_transmit) { m_shall_transmit = shall_transmit; }
01440         BOOLEAN IsShallTransmit() const { return m_shall_transmit; }
01441
01442         enum  {
01443             ID = 6464
01444             };
01445
01446     private:
01447
01448         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsTransmitAckArg*) arg); }
01449
01450         UINT8 m_view;
01451         INT m_position;
01452         BOOLEAN m_shall_transmit;
01453
01454     };
01455
01456 // Inline definitions
01457 inline const MdhSmsTransmitAckArg& MdhSmsTransmitAckArg::Cast(const StackMsgArgument& arg) {
01458     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsTransmitAckArg!\n");
01459     return ((MdhSmsTransmitAckArg &) arg);
01460 }
01461
01462
01463
01464 /*  ======================================================================
01465     Class MdhSmsReportReadReqArg
01466     ====================================================================== */
01467
01469 class MdhSmsReportReadReqArg : public StackMsgArgument {
01470     friend class CommonStackMsgArgsDestroyTableNode;
01471     public:
01472         MdhSmsReportReadReqArg(UINT8 view, INT position);
01473         MdhSmsReportReadReqArg();
01474
01475         static const MdhSmsReportReadReqArg& Cast(const StackMsgArgument& arg);
01476         void SetView(UINT8 view) { m_view = view; }
01477         UINT8 GetView() const { return m_view; }
01478         void SetPosition(INT position) { m_position = position; }
01479         INT GetPosition() const { return m_position; }
01480
01481         enum  {
01482             ID = 6465
01483             };
01484
01485     private:
01486
01487         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsReportReadReqArg*) arg); }
01488
01489         UINT8 m_view;
01490         INT m_position;
01491
01492     };
01493
01494 // Inline definitions
01495 inline const MdhSmsReportReadReqArg& MdhSmsReportReadReqArg::Cast(const StackMsgArgument& arg) {
01496     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsReportReadReqArg!\n");
01497     return ((MdhSmsReportReadReqArg &) arg);
01498 }
01499
01500
01501
01502 /*  ======================================================================
01503     Class MdhSmsConcRefNumReqArg
01504     ====================================================================== */
01505
01507 class MdhSmsConcRefNumReqArg : public StackMsgArgument {
01508     friend class CommonStackMsgArgsDestroyTableNode;
01509     public:
01510         MdhSmsConcRefNumReqArg();
01511
01512         static const MdhSmsConcRefNumReqArg& Cast(const StackMsgArgument& arg);
01513
01514         enum  {
01515             ID = 6466
01516             };
01517
01518     private:
01519
01520         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsConcRefNumReqArg*) arg); }
01521
01522     };
01523
01524 // Inline definitions
01525 inline const MdhSmsConcRefNumReqArg& MdhSmsConcRefNumReqArg::Cast(const StackMsgArgument& arg) {
01526     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsConcRefNumReqArg!\n");
01527     return ((MdhSmsConcRefNumReqArg &) arg);
01528 }
01529
01530
01531
01532 /*  ======================================================================
01533     Class MdhSmsDeletionReqArg
01534     ====================================================================== */
01535
01537 class MdhSmsDeletionReqArg : public StackMsgArgument {
01538     friend class CommonStackMsgArgsDestroyTableNode;
01539     public:
01540         MdhSmsDeletionReqArg(UINT8 view, const MdhDeletionCmd& deletion_cmd, INT position);
01541         MdhSmsDeletionReqArg();
01542
01543         static const MdhSmsDeletionReqArg& Cast(const StackMsgArgument& arg);
01544         void SetView(UINT8 view) { m_view = view; }
01545         UINT8 GetView() const { return m_view; }
01546         void SetDeletionCmd(const MdhDeletionCmd& deletion_cmd) { m_deletion_cmd = deletion_cmd; }
01547         const MdhDeletionCmd& GetDeletionCmd() const { return m_deletion_cmd; }
01548         void SetPosition(INT position) { m_position = position; }
01549         INT GetPosition() const { return m_position; }
01550
01551         enum  {
01552             ID = 6467
01553             };
01554
01555     private:
01556
01557         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsDeletionReqArg*) arg); }
01558
01559         UINT8 m_view;
01560         MdhDeletionCmd m_deletion_cmd;
01561         INT m_position;
01562
01563     };
01564
01565 // Inline definitions
01566 inline const MdhSmsDeletionReqArg& MdhSmsDeletionReqArg::Cast(const StackMsgArgument& arg) {
01567     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsDeletionReqArg!\n");
01568     return ((MdhSmsDeletionReqArg &) arg);
01569 }
01570
01571
01572
01573 /*  ======================================================================
01574     Class MdhSmsExtendedDataReqArg
01575     ====================================================================== */
01576
01578 class MdhSmsExtendedDataReqArg : public StackMsgArgument {
01579     friend class CommonStackMsgArgsDestroyTableNode;
01580     public:
01581         MdhSmsExtendedDataReqArg(UINT8 view, INT position, const MdhExtendedData& extended_data);
01582         MdhSmsExtendedDataReqArg();
01583
01584         static const MdhSmsExtendedDataReqArg& Cast(const StackMsgArgument& arg);
01585         void SetView(UINT8 view) { m_view = view; }
01586         UINT8 GetView() const { return m_view; }
01587         void SetPosition(INT position) { m_position = position; }
01588         INT GetPosition() const { return m_position; }
01589         void SetExtendedData(const MdhExtendedData& extended_data) { m_extended_data = extended_data; }
01590         const MdhExtendedData& GetExtendedData() const { return m_extended_data; }
01591
01592         enum  {
01593             ID = 6468
01594             };
01595
01596     private:
01597
01598         static void Destroy(StackMsgArgument* arg) { delete ((MdhSmsExtendedDataReqArg*) arg); }
01599
01600         UINT8 m_view;
01601         INT m_position;
01602         MdhExtendedData m_extended_data;
01603
01604     };
01605
01606 // Inline definitions
01607 inline const MdhSmsExtendedDataReqArg& MdhSmsExtendedDataReqArg::Cast(const StackMsgArgument& arg) {
01608     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MdhSmsExtendedDataReqArg!\n");
01609     return ((MdhSmsExtendedDataReqArg &) arg);
01610 }
01611
01612
01613 #endif // Apc_MdhSmsStackMsgArgs_hpp
01614
Generated on Tue Jan 24 14:46:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MdhTypes.hpp File Reference

Apc/MdhTypes.hpp File Reference

#include <Apc/SignalTypes.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for MdhTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MdhDeletionCmd
MdhDeletionCmd (ms.h: T_DR_DEL_CMD_FLAGS). More...
class | MdhExtendedData
class | MdhGors
MdhGors (ms.h: T_DATA Group Operation Result Set, internal use). More...
struct | MdhResult
MdhResult (ms.h: T_DR_RESULT). More...
struct | MdhSetWaitIndicator
MdhSetWaitIndicator (ms.h: T_DR_SET_WAIT_IND_RQ). More...
class | MdhSetWaitIndicatorArray
MdhSetWaitIndicatorArray (ms.h: T_DR_SET_WAIT_IND_REQ). More...
struct | MdhViewConfig
MdhViewConfig (ms.h: T_DR_SM_VIEW_CONFIG). More...
struct | MdhWaitIndicator
MdhWaitIndicator (ms.h: T_DR_WAIT_INDICATOR). More...
struct | MdhWaitIndicatorArray
MdhWaitIndicator (ms.h: T_DR_WAIT_INDICATOR_ARR). More...
struct | TpduConc
TpduConc (ms.h: T_PDU_CONCATENATED). More...
struct | TpduNode
TpduNode (ms.h: T_PDU_NODE). More...

Defines

#define | Apc_Gsm97_MdhTypes_hpp
#define | MdhInitExtendedData MdhExtendedData()
default initialize

Typedefs

typedef UINT32 | MdhTimeStamp
MdhTimeStamp.
typedef UINT8 | MdhViewHdl

Enumerations

enum MdhCause {
MdhNoCause = DR_NO_CAUSE, MdhFirstReached = DR_FIRST_REACHED, MdhLastReached = DR_LAST_REACHED, MdhNothingFound = DR_NOTHING_FOUND,
MdhSmsrNotSaved = DR_SMSR_NOT_SAVED, MdhErrSmsrLinkNotFound = DR_ERR_SMSR_LINK_NOT_FOUND, MdhErrSmsrNotAvailable = DR_ERR_SMSR_NOT_AVAILABLE, MdhWarnMemoryExceeded = DR_WARN_MEMORY_EXCEEDED,
MdhRejStartupInProgress = DR_REJ_STARTUP_IN_PROGRESS, MdhRejMemoryExceeded = DR_REJ_MEMORY_EXCEEDED, MdhRejSimIsFull = DR_REJ_SIM_IS_FULL, MdhRejSimIsNotInView = DR_REJ_SIM_IS_NOT_IN_VIEW,
MdhRejSimNoSms = DR_REJ_SIM_NO_SMS, MdhRejLastView = DR_REJ_LAST_VIEW, MdhErrClientWasNotRegistered = DR_ERR_CLIENT_WAS_NOT_REGISTERED, MdhErrNoEntriesFound = DR_ERR_NO_ENTRIES_FOUND,
MdhErrViewNotAvailable = DR_ERR_VIEW_NOT_AVAILABLE, MdhErrOutOfRange = DR_ERR_OUT_OF_RANGE, MdhErrOutOfView = DR_ERR_OUT_OF_VIEW, MdhErrMaxClients = DR_ERR_MAX_CLIENTS,
MdhErrMaxViews = DR_ERR_MAX_VIEWS, MdhErrIndexNotCreated = DR_ERR_INDEX_NOT_CREATED, MdhErrFilterIsNotSupported = DR_ERR_FILTER_IS_NOT_SUPPORTED, MdhErrStorageMedia = DR_ERR_STORAGE_MEDIA,
MdhErrNotEnoughMemory = DR_ERR_NOT_ENOUGH_MEMORY, MdhErrParameters = DR_ERR_PARAMETERS, MdhApplicationError = DR_APPLICATION_ERROR, MdhWarnSmStorageSimIsFull,
MdhSmStorageSimIsFree, MdhNothingToProcess
}
MdhCause (ms.h: T_DR_CAUSE). More...
enum MdhFilter {
MdhFilterUsed = DR_FTR_USED, MdhFilterFree = DR_FTR_FREE, MdhFilterAll = DR_FTR_ALL, MdhFilterAllDisplay = DR_FTR_ALL_DISPLAY,
MdhFilterToBeRead = DR_FTR_TO_BE_READ, MdhFilterRead = DR_FTR_READ, MdhFilterInbox = DR_FTR_INBOX, MdhFilterToBeSent = DR_FTR_TO_BE_SENT,
MdhFilterSent = DR_FTR_SENT, MdhFilterOutbox = DR_FTR_OUTBOX, MdhFilterUnknown = DR_FTR_UNKNOWN, MdhFilterVoiceMsgWaiting = DR_FTR_VOICE_MSG_WAITING,
MdhFilterFaxWaiting = DR_FTR_FAX_MSG_WAITING, MdhFilterEmailWaiting = DR_FTR_EMAIL_MSG_WAITING, MdhFilterOtherMsgWaiting = DR_FTR_OTHER_MSG_WAITING
}
MdhFilter (ms.h: T_DR_FILTER). More...
enum MdhSmsrLocation {
MdhSmsrNone = DR_SR_NONE, MdhSmsrEf = DR_SR_EF_SMSR, MdhNoSmsrEf = DR_SR_NOT_EF_SMSR, MdhSharedMemory = DR_SR_SHARED_MEM,
MdhRamBuffer = DR_SR_RAM_BUFF
}
MdhNavigation (ms.h: T_DR_SR_LOCATION_TAG). More...
enum | MdhSorting { MdhSortByPosition = DR_SORT_BY_POSITION, MdhSortByDate = DR_SORT_BY_DATE }
MdhSorting (ms.h: T_DR_SORTING). More...
enum | MdhStatus { MdhSuccessful = DR_SUCCESSFUL, MdhError = DR_ERROR, MdhUndefined }
MdhStatus (ms.h: T_DR_STATUS). More...
enum | MdhTransmitCause { MdhSmBoot = DR_SM_BOOT, MdhSmSimReset = DR_SM_SIM_RESET, MdhSmSimtkRefresh = DR_SM_SIMTK_REFRESH, MdhSmUnknown = DR_SM_UNKNOWN }
MdhTransmitCause (ms.h: DR_TRANSMIT_SAUSE). More...
enum MdhWaitIndicatorLevel {
MdhWaitLevel1 = DR_WAIT_LEVEL_1, MdhWaitLevel2 = DR_WAIT_LEVEL_2, MdhWaitLevel3 = DR_WAIT_LEVEL_3, MdhWaitLevelCphs = DR_WAIT_LEVEL_CPHS,
MdhWaitLevelClient = DR_WAIT_LEVEL_CLIENT, MdhWaitNoLevel = DR_WAIT_NOLEVEL
}
MdhWaitIndicatorLevel (ms.h: T_DR_WAIT_INDICATOR_LEVEL). More...
enum | MdhWaitIndicatorSetting { MdhWaitSetInactive = DR_WAIT_SET_INACTIVE, MdhWaitSetActive = DR_WAIT_SET_ACTIVE, MdhWaitSetUnknown = DR_WAIT_SET_UNKNOW }
MdhWaitIndicatorSetting (ms.h: T_DR_WAIT_INDICATOR_SETTING). More...
enum | MdhWaitIndicatorSmsType { MdhWaitSmsStore = DR_WAIT_SMS_STORE, MdhWaitSmsDiscard = DR_WAIT_SMS_DISCARD, MdhWaitSmsUnknown = DR_WAIT_SMS_UNKNOWN }
MdhWaitIndicatorSmsType (ms.h: T_DR_WAIT_INDICATOR_SMS). More...
enum MdhWaitType {
MdhVoiceMailMessage = DR_WAIT_VOICEMAIL, MdhFaxMessage = DR_WAIT_FAX, MdhEmailMessage = DR_WAIT_EMAIL, MdhOtherMessage = DR_WAIT_OTHER,
MdhVoiceMail2Message = DR_WAIT_VOICEMAIL_2, MdhNofMdhWaitTypes = DR_NU_WAIT_TYPES
}
MdhWaitType. More...
enum MdhWorkMedia {
MdhNoMedia = DR_NONE, MdhOnlySim = DR_ONLY_SIM, MdhOnlyNvram = DR_ONLY_NVRAM, MdhPrefferedSim = DR_PREFERRED_SIM,
MdhPrefferedNvram = DR_PREFERRED_NVRAM, MdhSharedMem = DR_SHARED_MEM
}
MdhWorkMedia (ms.h: T_DR_WORK_MEDIA). More...

Variables

const INT | c_mdh_max_ext_data = 4
const INT | c_undefined_pdu_pos = T_DR_UNDEFINED_POS
T_DR_UNDEFINED_POS defines a undefined position.
const MdhViewHdl | c_undefined_view_handle = 0xFF
const MdhTimeStamp | MdhInitTimeStamp = 0xFFFFFFFF

Define Documentation

#define Apc_Gsm97_MdhTypes_hpp

#define MdhInitExtendedData MdhExtendedData()

default initialize

Typedef Documentation

typedef UINT32 MdhTimeStamp

MdhTimeStamp.

typedef UINT8 MdhViewHdl

Enumeration Type Documentation

enum MdhCause

MdhCause (ms.h: T_DR_CAUSE).

Enumerator:
MdhNoCause
MdhFirstReached
MdhLastReached
MdhNothingFound
MdhSmsrNotSaved
MdhErrSmsrLinkNotFound
MdhErrSmsrNotAvailable
MdhWarnMemoryExceeded
MdhRejStartupInProgress
MdhRejMemoryExceeded
MdhRejSimIsFull
MdhRejSimIsNotInView
MdhRejSimNoSms
MdhRejLastView
MdhErrClientWasNotRegistered
MdhErrNoEntriesFound
MdhErrViewNotAvailable
MdhErrOutOfRange
MdhErrOutOfView
MdhErrMaxClients
MdhErrMaxViews
MdhErrIndexNotCreated
MdhErrFilterIsNotSupported
MdhErrStorageMedia
MdhErrNotEnoughMemory
MdhErrParameters
MdhApplicationError
MdhWarnSmStorageSimIsFull
MdhSmStorageSimIsFree
MdhNothingToProcess

enum MdhFilter

MdhFilter (ms.h: T_DR_FILTER).

Enumerator:
MdhFilterUsed
MdhFilterFree
MdhFilterAll
MdhFilterAllDisplay
MdhFilterToBeRead
MdhFilterRead
MdhFilterInbox
MdhFilterToBeSent
MdhFilterSent
MdhFilterOutbox
MdhFilterUnknown
MdhFilterVoiceMsgWaiting
MdhFilterFaxWaiting
MdhFilterEmailWaiting
MdhFilterOtherMsgWaiting

enum MdhSmsrLocation

MdhNavigation (ms.h: T_DR_SR_LOCATION_TAG).

Enumerator:
MdhSmsrNone
MdhSmsrEf
MdhNoSmsrEf
MdhSharedMemory
MdhRamBuffer

enum MdhSorting

MdhSorting (ms.h: T_DR_SORTING).

Enumerator:
MdhSortByPosition
MdhSortByDate

enum MdhStatus

MdhStatus (ms.h: T_DR_STATUS).

Enumerator:
MdhSuccessful
MdhError
MdhUndefined

enum MdhTransmitCause

MdhTransmitCause (ms.h: DR_TRANSMIT_SAUSE).

Enumerator:
MdhSmBoot
MdhSmSimReset
MdhSmSimtkRefresh
MdhSmUnknown

enum MdhWaitIndicatorLevel

MdhWaitIndicatorLevel (ms.h: T_DR_WAIT_INDICATOR_LEVEL).

Enumerator:
MdhWaitLevel1
MdhWaitLevel2
MdhWaitLevel3
MdhWaitLevelCphs
MdhWaitLevelClient
MdhWaitNoLevel

enum MdhWaitIndicatorSetting

MdhWaitIndicatorSetting (ms.h: T_DR_WAIT_INDICATOR_SETTING).

Enumerator:
MdhWaitSetInactive
MdhWaitSetActive
MdhWaitSetUnknown

enum MdhWaitIndicatorSmsType

MdhWaitIndicatorSmsType (ms.h: T_DR_WAIT_INDICATOR_SMS).

Enumerator:
MdhWaitSmsStore
MdhWaitSmsDiscard
MdhWaitSmsUnknown

enum MdhWaitType

MdhWaitType.

Enumerator:
MdhVoiceMailMessage
MdhFaxMessage
MdhEmailMessage
MdhOtherMessage
MdhVoiceMail2Message
MdhNofMdhWaitTypes

enum MdhWorkMedia

MdhWorkMedia (ms.h: T_DR_WORK_MEDIA).

Enumerator:
MdhNoMedia
MdhOnlySim
MdhOnlyNvram
MdhPrefferedSim
MdhPrefferedNvram
MdhSharedMem

Variable Documentation

const INT c_mdh_max_ext_data = 4

const INT c_undefined_pdu_pos = T_DR_UNDEFINED_POS

T_DR_UNDEFINED_POS defines a undefined position.

const MdhViewHdl c_undefined_view_handle = 0xFF

const MdhTimeStamp MdhInitTimeStamp = 0xFFFFFFFF

Generated on Tue Jan 24 16:56:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MdhTypes.hpp Source File

Apc/MdhTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Gsm97_MdhTypes_hpp)
00009 #define Apc_Gsm97_MdhTypes_hpp
00010
00011 #include <Apc/SignalTypes.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014
00015 typedef UINT8 MdhViewHdl;
00016
00017 #if defined(APOXI_SUPPORT_SMS_DELETION_CMD_GORS)
00018 const MdhViewHdl c_undefined_view_handle = (MdhViewHdl)DR_UNDEFINED_VIEW;
00019 #else
00020 const MdhViewHdl c_undefined_view_handle = 0xFF;
00021 #endif
00022
00023
00025 enum MdhWorkMedia {
00026     MdhNoMedia          = DR_NONE,
00027     MdhOnlySim          = DR_ONLY_SIM,
00028     MdhOnlyNvram        = DR_ONLY_NVRAM,
00029     MdhPrefferedSim     = DR_PREFERRED_SIM,
00030     MdhPrefferedNvram   = DR_PREFERRED_NVRAM,
00031     MdhSharedMem        = DR_SHARED_MEM
00032 };
00033
00035 enum MdhStatus {
00036     MdhSuccessful       = DR_SUCCESSFUL,
00037     MdhError            = DR_ERROR,
00038     MdhUndefined,
00039 };
00040
00042 enum MdhCause {
00043     MdhNoCause                      = DR_NO_CAUSE,
00044     MdhFirstReached                 = DR_FIRST_REACHED,
00045     MdhLastReached                  = DR_LAST_REACHED,
00046     MdhNothingFound                 = DR_NOTHING_FOUND,
00047     MdhSmsrNotSaved                 = DR_SMSR_NOT_SAVED,
00048     MdhErrSmsrLinkNotFound          = DR_ERR_SMSR_LINK_NOT_FOUND,
00049     MdhErrSmsrNotAvailable          = DR_ERR_SMSR_NOT_AVAILABLE,
00050     MdhWarnMemoryExceeded           = DR_WARN_MEMORY_EXCEEDED,
00051     MdhRejStartupInProgress         = DR_REJ_STARTUP_IN_PROGRESS,
00052     MdhRejMemoryExceeded            = DR_REJ_MEMORY_EXCEEDED,
00053     MdhRejSimIsFull                 = DR_REJ_SIM_IS_FULL,
00054     MdhRejSimIsNotInView            = DR_REJ_SIM_IS_NOT_IN_VIEW,
00055     MdhRejSimNoSms                  = DR_REJ_SIM_NO_SMS,
00056     MdhRejLastView                  = DR_REJ_LAST_VIEW,
00057     MdhErrClientWasNotRegistered    = DR_ERR_CLIENT_WAS_NOT_REGISTERED,
00058     MdhErrNoEntriesFound            = DR_ERR_NO_ENTRIES_FOUND,
00059     MdhErrViewNotAvailable          = DR_ERR_VIEW_NOT_AVAILABLE,
00060     MdhErrOutOfRange                = DR_ERR_OUT_OF_RANGE,
00061     MdhErrOutOfView                 = DR_ERR_OUT_OF_VIEW,
00062     MdhErrMaxClients                = DR_ERR_MAX_CLIENTS,
00063     MdhErrMaxViews                  = DR_ERR_MAX_VIEWS,
00064     MdhErrIndexNotCreated           = DR_ERR_INDEX_NOT_CREATED,
00065     MdhErrFilterIsNotSupported      = DR_ERR_FILTER_IS_NOT_SUPPORTED,
00066     MdhErrStorageMedia              = DR_ERR_STORAGE_MEDIA,
00067     MdhErrNotEnoughMemory           = DR_ERR_NOT_ENOUGH_MEMORY,
00068     MdhErrParameters                = DR_ERR_PARAMETERS,
00069     MdhApplicationError             = DR_APPLICATION_ERROR,
00070
00071 #if defined(DR_WARN_SM_STORAGE_SIM_IS_FULL)
00072     MdhWarnSmStorageSimIsFull       = DR_WARN_SM_STORAGE_SIM_IS_FULL,
00073 #else
00074     MdhWarnSmStorageSimIsFull,
00075 #endif
00076 #if defined(DR_SM_STORAGE_SIM_IS_FREE)
00077     MdhSmStorageSimIsFree           = DR_SM_STORAGE_SIM_IS_FREE,
00078 #else
00079     MdhSmStorageSimIsFree,
00080 #endif
00081
00082 #if defined(APOXI_SUPPORT_SMS_DELETION_CMD_GORS)
00083     MdhNothingToProcess             = DR_NOTHING_TO_PROCESS,
00084 #else
00085     MdhNothingToProcess,
00086 #endif
00087 };
00088
00090 struct MdhResult {
00091     MdhStatus   status;
00092     MdhCause    cause;
00093 };
00094
00096 struct TpduConc {
00097     T_PDU   pdu;
00098     UINT8   pdu_no;
00099     INT     next;
00100     INT     prev;
00101 };
00102
00104 struct TpduNode {
00105     T_PDU       pdu;
00106     TpduNode    *next;
00107 };
00108
00110 enum MdhSorting {
00111     MdhSortByPosition   = DR_SORT_BY_POSITION,
00112     MdhSortByDate       = DR_SORT_BY_DATE,
00113 };
00114
00116 enum MdhFilter {
00117     MdhFilterUsed               = DR_FTR_USED,
00118     MdhFilterFree               = DR_FTR_FREE,
00119     MdhFilterAll                = DR_FTR_ALL,
00120     MdhFilterAllDisplay         = DR_FTR_ALL_DISPLAY,
00121     MdhFilterToBeRead           = DR_FTR_TO_BE_READ,
00122     MdhFilterRead               = DR_FTR_READ,
00123     MdhFilterInbox              = DR_FTR_INBOX,
00124     MdhFilterToBeSent           = DR_FTR_TO_BE_SENT,
00125     MdhFilterSent               = DR_FTR_SENT,
00126     MdhFilterOutbox             = DR_FTR_OUTBOX,
00127     MdhFilterUnknown            = DR_FTR_UNKNOWN,
00128     MdhFilterVoiceMsgWaiting    = DR_FTR_VOICE_MSG_WAITING,
00129     MdhFilterFaxWaiting         = DR_FTR_FAX_MSG_WAITING,
00130     MdhFilterEmailWaiting       = DR_FTR_EMAIL_MSG_WAITING,
00131     MdhFilterOtherMsgWaiting    = DR_FTR_OTHER_MSG_WAITING,
00132 };
00133
00135 struct MdhViewConfig {
00136     MdhSorting      sort;
00137     MdhFilter       filter;
00138     MdhWorkMedia    storage;
00139 };
00140
00142 enum MdhTransmitCause {
00143     MdhSmBoot         = DR_SM_BOOT,
00144     MdhSmSimReset     = DR_SM_SIM_RESET,
00145     MdhSmSimtkRefresh = DR_SM_SIMTK_REFRESH,
00146     MdhSmUnknown      = DR_SM_UNKNOWN
00147 };
00149 enum MdhSmsrLocation {
00150     MdhSmsrNone     = DR_SR_NONE,
00151     MdhSmsrEf       = DR_SR_EF_SMSR,
00152     MdhNoSmsrEf     = DR_SR_NOT_EF_SMSR,
00153     MdhSharedMemory = DR_SR_SHARED_MEM,
00154     MdhRamBuffer    = DR_SR_RAM_BUFF
00155 };
00156
00158 enum MdhWaitIndicatorLevel {
00159     MdhWaitLevel1    = DR_WAIT_LEVEL_1,
00160     MdhWaitLevel2    = DR_WAIT_LEVEL_2,
00161     MdhWaitLevel3    = DR_WAIT_LEVEL_3,
00162     MdhWaitLevelCphs = DR_WAIT_LEVEL_CPHS,
00163     MdhWaitLevelClient  = DR_WAIT_LEVEL_CLIENT,
00164     MdhWaitNoLevel   = DR_WAIT_NOLEVEL
00165 };
00166
00168 enum MdhWaitIndicatorSetting {
00169     MdhWaitSetInactive = DR_WAIT_SET_INACTIVE,
00170     MdhWaitSetActive = DR_WAIT_SET_ACTIVE,
00171     MdhWaitSetUnknown = DR_WAIT_SET_UNKNOW,
00172 };
00173
00175 enum MdhWaitIndicatorSmsType {
00176     MdhWaitSmsStore =   DR_WAIT_SMS_STORE,
00177     MdhWaitSmsDiscard = DR_WAIT_SMS_DISCARD,
00178     MdhWaitSmsUnknown = DR_WAIT_SMS_UNKNOWN
00179 };
00180
00182 enum MdhWaitType {
00183     MdhVoiceMailMessage  = DR_WAIT_VOICEMAIL,
00184     MdhFaxMessage        = DR_WAIT_FAX,
00185     MdhEmailMessage      = DR_WAIT_EMAIL,
00186     MdhOtherMessage      = DR_WAIT_OTHER,
00187     MdhVoiceMail2Message = DR_WAIT_VOICEMAIL_2,
00188     MdhNofMdhWaitTypes   = DR_NU_WAIT_TYPES
00189 };
00190
00191
00193 struct MdhWaitIndicator {
00194     MdhWaitIndicatorLevel   level;
00195     UINT8                   count;
00196     MdhWaitIndicatorSetting setting;
00197     MdhWaitIndicatorSmsType smstype;
00198     BOOLEAN                 update;
00199     INT                     pos;
00200 };
00201
00203
00204 const INT c_undefined_pdu_pos = T_DR_UNDEFINED_POS;
00205
00207 struct MdhWaitIndicatorArray {
00208     MdhWaitIndicator val[MdhNofMdhWaitTypes];
00209 };
00210
00211
00213 struct MdhSetWaitIndicator {
00214     UINT8   count;
00215     BOOLEAN update;
00216 };
00217
00219 class MdhSetWaitIndicatorArray
00220 {
00221     public:
00222         MdhSetWaitIndicatorArray() { memset(val,0,sizeof(val)); }
00223         void SetIndicator(MdhWaitType type, BOOLEAN update, UINT8 count = 0) {
00224             if((INT)type >= (INT)MdhVoiceMailMessage && (INT)type < (INT)MdhNofMdhWaitTypes) {
00225                 val[type].update = update;
00226                 val[type].count = count;
00227             }
00228         }
00229     MdhSetWaitIndicator val[MdhNofMdhWaitTypes];
00230 };
00231
00233 #if defined(APOXI_SUPPORT_MOSMS_TIMESTAMP)
00234     typedef T_DR_TIME MdhTimeStamp;
00235     const MdhTimeStamp MdhInitTimeStamp = DR_INIT_MO_SM_TIME;
00236 #else
00237     typedef UINT32 MdhTimeStamp;
00238     const MdhTimeStamp MdhInitTimeStamp = 0xFFFFFFFF;
00239 #endif
00240
00241 // MdhExtendedData (ms.h T_DR_MMI_PROPERTY)
00242 #if defined(APOXI_ENABLE_SMS_EXTENDED_DATA)
00243     const INT c_mdh_max_ext_data = DR_MAX_MMI_PROPERTY;
00244 #else
00245     const INT c_mdh_max_ext_data = 4;
00246 #endif
00247
00248 class MdhExtendedData {
00249
00250     public:
00251
00252         MdhExtendedData() {
00253
00254         #if defined(APOXI_ENABLE_SMS_EXTENDED_DATA)
00255             INT i = 0;
00256             for(i; i < c_mdh_max_ext_data; i++) {
00257                 val[i] = DR_INIT_MMI_PROPERTY.A[i];
00258             }
00259         #else
00260             memset(val, 0, sizeof(val));
00261         #endif
00262         }
00263
00264         MdhExtendedData & operator =(const MdhExtendedData &ext_data) {
00265             // prevent from self assignment
00266             if (&ext_data != this) {
00267                 INT i = 0;
00268                 for(i; i < c_mdh_max_ext_data; i++) {
00269                     val[i] = ext_data.val[i];
00270                 }
00271             }
00272             return (*this);
00273         }
00274
00275         UINT32 GetExtData() const{
00276             UINT32 data = 0;
00277             INT i = 0;
00278             for(i; i < c_mdh_max_ext_data; i++) {
00279                 data |= val[i] << (8*i);
00280             }
00281             return data;
00282         }
00283
00284         void SetExtData(UINT32 ext_data) {
00285             INT i = 0;
00286             for(i; i < c_mdh_max_ext_data; i++) {
00287                 val[i] = (UINT8)(ext_data & 0xFF);
00288                 ext_data >>= 8;
00289             }
00290         }
00291
00292         UINT8 val[c_mdh_max_ext_data];
00293 };
00294
00296 #define MdhInitExtendedData MdhExtendedData()
00297
00298
00300 class MdhDeletionCmd
00301 {
00302     public:
00303         void SetRead(BOOLEAN value = TRUE) { val.SetBit(0,value); }
00304         void SetUnread(BOOLEAN value = TRUE) { val.SetBit(1,value); }
00305         void SetSent(BOOLEAN value = TRUE) { val.SetBit(2,value); }
00306         void SetUnsent(BOOLEAN value = TRUE) { val.SetBit(3,value); }
00307         void SetUnknown(BOOLEAN value = TRUE) { val.SetBit(4,value); }
00308         // bit 5 and 6 reserved
00309         void SetSmsr(BOOLEAN value = TRUE) { val.SetBit(7,value); }
00310
00311         UINT8 Get() const { return val.Get(); }
00312
00313         BitField8 val;
00314 };
00315
00317 class MdhGors
00318 {
00319     public:
00320         // default constructor
00321         MdhGors() : m_buffer(0), m_length(0) { }
00322
00323
00324         // copy constructor
00325         MdhGors(const MdhGors & gors) : m_buffer(0), m_length(0) {
00326             if(! gors.IsEmpty()) {
00327                 m_buffer = new UINT8[gors.m_length];
00328                 m_length = gors.m_length;
00329                 memcpy(m_buffer,gors.m_buffer,gors.m_length);
00330             }
00331         }
00332
00333         // destructor
00334         ~MdhGors() {
00335             delete[] m_buffer; m_length = 0;
00336         }
00337
00338         // assignment operator
00339         MdhGors & operator = (const MdhGors & gors) {
00340             if(&gors!=this) {
00341                 delete[] m_buffer;
00342                 m_length = 0;
00343                 if(! gors.IsEmpty()) {
00344                     m_buffer = new UINT8[gors.m_length];
00345                     m_length = gors.m_length;
00346                     memcpy(m_buffer,gors.m_buffer,gors.m_length);
00347                 }
00348             }
00349             return *this;
00350         }
00351
00352         // is the PDU deleted (starting from 0 position) ?
00353         BOOLEAN IsPduDeleted(INT tpdupos) const {
00354             INT bytepos = tpdupos / 8;
00355             if(bytepos<m_length && m_buffer!=0) {
00356                 BitField8 val(m_buffer[bytepos]);
00357                 return val.GetBit(tpdupos % 8);
00358             }
00359             return FALSE;
00360         }
00361
00362         // is the buffer empty ?
00363         BOOLEAN IsEmpty() const {
00364             return m_buffer==0 || m_length==0;
00365         }
00366
00367
00368         // copys data from buffer into object
00369         void Fill(const UINT8 * buffer, INT bufferlen) {
00370             delete[] m_buffer;
00371             m_length = 0;
00372             if(buffer!=0 && bufferlen>0) {
00373                 m_buffer = new UINT8[bufferlen];
00374                 m_length = bufferlen;
00375                 memcpy(m_buffer,buffer,bufferlen);
00376             }
00377         }
00378
00379     private:
00380         UINT8 * m_buffer;
00381         INT     m_length;
00382 };
00383
00384
00385 #endif
00386
00387
Generated on Tue Jan 24 14:46:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Message.hpp File Reference

Apc/Message.hpp File Reference

#include <Kernel/Message.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for Message.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FromStackMsg
class | ToStackMsg

Generated on Tue Jan 24 16:56:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Message.hpp Source File

Apc/Message.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef Apc_Message_hpp
00009 #define Apc_Message_hpp
00010
00011 #include <Kernel/Message.hpp>
00012 #include <Kernel/Types.hpp>
00013 #include <Kernel/Os/Os.hpp>
00014
00015
00016 class StackMsgArgument;
00017
00018 /*  ======================================================================
00019     FromStackMsg
00020     ====================================================================== */
00023 class FromStackMsg : public Message {
00024     public:
00025         FromStackMsg(StackMsgArgument *arg = 0);
00026         FromStackMsg(const FromStackMsg &msg);
00027         virtual ~FromStackMsg();
00028
00029         enum { ID = 15000 };
00030
00031         virtual const MsgMetaData& GetMetaData() const;
00032         virtual Message* Clone() const;
00033
00034         virtual FromStackMsg& operator =(const FromStackMsg &msg);
00035
00036         StackMsgArgument* GetArg() const { return m_arg; }
00037
00038     private:
00039         static MsgMetaData m_meta_data;
00040         StackMsgArgument *m_arg;
00041 };
00042
00043 /*  ======================================================================
00044     ToStackMsg
00045     ====================================================================== */
00048 class ToStackMsg : public Message {
00049     public:
00050         ToStackMsg(StackMsgArgument *arg = 0);
00051         ToStackMsg(const ToStackMsg &msg);
00052         virtual ~ToStackMsg();
00053
00054         enum { ID = 15001 };
00055
00056         virtual const MsgMetaData& GetMetaData() const;
00057         virtual Message* Clone() const;
00058
00059         virtual ToStackMsg& operator =(const ToStackMsg &msg);
00060
00061         StackMsgArgument* GetArg() const { return m_arg; }
00062
00063     private:
00064         static MsgMetaData m_meta_data;
00065         StackMsgArgument *m_arg;
00066 };
00067
00068
00069 #endif  // Apc_Message_hpp
00070
00071
Generated on Tue Jan 24 14:46:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MessageIdentifier.cpp File Reference

Apc/MessageIdentifier.cpp File Reference

#include "Apc/PreComp.hpp"
#include "MessageIdentifier.hpp"

Include dependency graph for MessageIdentifier.cpp:

Generated on Tue Jan 24 16:57:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MessageIdentifier.hpp File Reference

Apc/MessageIdentifier.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for MessageIdentifier.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MessageIdentifier
Message Identifier - 3GPP TS 23.041 V4.1.0 [9.4.1.2.2]. More...
class | MessageIdentifierContainer
used for cell broadcast filter, this class is only used internally. More...
class | MessageIdentifierContainer::MessageIdentifierPair
class | MessageIdentifierRange
used for cell broadcast filter. More...

Defines

#define | Apc_MessageIdentifier_hpp

Define Documentation

#define Apc_MessageIdentifier_hpp

Generated on Tue Jan 24 16:57:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MessageIdentifier.hpp Source File

Apc/MessageIdentifier.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_MessageIdentifier_hpp)
00009 #define Apc_MessageIdentifier_hpp
00010
00011 #include <Auxiliary/Linkable.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014 /*  ========================================================================
00015     Message Identifier - 3GPP TS 23.041 V4.1.0 [9.4.1.2.2]
00016     ========================================================================*/
00018 class MessageIdentifier {
00019     public:
00021         enum Range {
00023             PlmnOperatorAssociationsMessageBegin = 0x0000,
00025             PlmnOperatorAssociationsMessageEnd = 0x03e7,
00026
00028             LocationServicesRangeBegin = 0x03e8,
00030             LocationServicesRangeEnd = 0x03ec,
00031
00033             UnsecureCellBroadcastDataDownloadRangeBegin = 0x1000,
00035             UnsecureCellBroadcastDataDownloadRangeEnd = 0x107f,
00036
00038             SecureCellBroadcastDataDownloadRangeBegin = 0x1080,
00040             SecureCellBroadcastDataDownloadRangeEnd = 0x10ff,
00041
00043             PlmnOperatorSpecificRangeBegin = 0xa000,
00045             PlmnOperatorSpecificRangeEnd = 0xafff,
00046
00048             ForStandardizationInFutureVersionsRange1Begin = 0x03ec,
00050             ForStandardizationInFutureVersionsRange1End = 0x0fff,
00051
00053             ForStandardizationInFutureVersionsRange2Begin = 0x1100,
00055             ForStandardizationInFutureVersionsRange2End = 0x9fff,
00056
00058             ForPlmnOperatorSpecificInFutureVersionsRangeBegin = 0xb000,
00060             ForPlmnOperatorSpecificInFutureVersionsRangeEnd = 0xfffe,
00061         };
00062
00064         enum Type {
00071             InPlmnOperatorAssociationsRange = 0x0000,
00072
00074             LcsEOtdAssistanceDataMessage = 0x03e8,
00076             LcsDGpsCorrectionDataMessage = 0x03e9,
00078             LcsGpsEphemerisAndClockCorrectionDataMessage = 0x03ea,
00080             LcsGpsAlmanacAndOtherDataMessage = 0x03eb,
00081
00086             InUnsecureCellBroadcastDataDownloadRange = 0x1000,
00087
00092             InSecureCellBroadcastDataDownloadRange = 0x1080,
00093
00099             InPlmnOperatorSpecificRange = 0xa000,
00100
00105             InPlmnOperatorSpecificForFutureVersionsRange = 0x03ec,
00106
00107
00112             InReservedForFutureVersionsRange = 0xfffe,
00113
00119             InvalidType = 0xffff
00120         };
00121
00123         MessageIdentifier() : m_bit_field(0xffff) {};
00125         MessageIdentifier(UINT16 incoming_word) : m_bit_field(incoming_word) {};
00127         MessageIdentifier(const MessageIdentifier & mid) : m_bit_field(mid.m_bit_field) {};
00129         BOOLEAN operator == (const MessageIdentifier &mid) const {
00130                 return (m_bit_field == mid.m_bit_field);
00131         }
00132
00134         UINT16 Get() const { return (m_bit_field.Get()); }
00135
00137         Type GetType() const;
00139         void SetType(Type type);
00140
00142         void Clear() { m_bit_field.Clear(); }
00143
00144     private:
00145         BitField16 m_bit_field;
00146 };
00147
00148
00149 /*  ========================================================================
00150     Message Identifier Range
00151     ========================================================================*/
00153 class MessageIdentifierRange : public Linkable<MessageIdentifierRange> {
00154     public:
00156         MessageIdentifierRange();
00158         MessageIdentifierRange(const MessageIdentifier &begin, const MessageIdentifier &end = MessageIdentifier());
00160         MessageIdentifierRange(const MessageIdentifierRange & midrange)
00161             : m_begin(midrange.m_begin), m_end(midrange.m_end) {};
00163         BOOLEAN operator == (const MessageIdentifierRange &mid_range) const;
00164
00166         const MessageIdentifier& Begin() const { return (m_begin); }
00168         void Begin(const MessageIdentifier &begin) { m_begin = begin; }
00170         const MessageIdentifier& End() const { return (m_end); }
00172         void End(const MessageIdentifier &end) { m_end = end; }
00174         BOOLEAN IsValid() { return (m_begin.Get() <= m_end.Get());}
00175
00176     private:
00177         MessageIdentifier m_begin;
00178         MessageIdentifier m_end;
00179 };
00180
00181 /*  ========================================================================
00182     Message Identifier Container
00183     ========================================================================*/
00185 class MessageIdentifierContainer {
00186     public:
00187         enum {
00188             // defines the no of mid-ranges per allocation
00189             c_inrease_step = 32,
00190             // defines the maximum number of ranges per container
00191             c_max_apoxi_no_of_message_identifiers = 128
00192         };
00193
00194         // this class hold a pair of ids, as MessageIdentifierRange uses more memory
00195         class MessageIdentifierPair {
00196             public:
00197                 MessageIdentifierPair() : m_begin(0xFFFF), m_end(0xFFFF) {};
00198                 MessageIdentifierPair(MessageIdentifier begin, MessageIdentifier end) :
00199                     m_begin(begin.Get()), m_end(end.Get()) {};
00200                 MessageIdentifierPair(UINT16 begin, UINT16 end) :
00201                     m_begin(begin), m_end(end) {};
00202
00203                 MessageIdentifierPair(const MessageIdentifierPair & midpair) :
00204                     m_begin(midpair.m_begin), m_end(midpair.m_end) {};
00205                 MessageIdentifierPair(const MessageIdentifierRange & range) :
00206                     m_begin(range.Begin().Get()), m_end(range.End().Get()) {};
00207
00208                 BOOLEAN operator == (const MessageIdentifierPair &midpair) const {
00209                     return midpair.m_begin==m_begin && midpair.m_end==m_end;
00210                 }
00211                 BOOLEAN operator == (const MessageIdentifierRange &midrange) const {
00212                     return midrange.Begin()==m_begin && midrange.End()==m_end;
00213                 }
00214
00215                 UINT16 m_begin;
00216                 UINT16 m_end;
00217         };
00218
00219         MessageIdentifierContainer();
00220
00221         MessageIdentifierContainer(INT preallocsize);
00222
00223         MessageIdentifierContainer(const MessageIdentifierContainer &midcont);
00224
00225         ~MessageIdentifierContainer();
00226
00227         MessageIdentifierContainer& operator =(const MessageIdentifierContainer &midcont);
00228
00229         // appends a ranges distinct means, only a lookup if it exists is done, before appending
00230         BOOLEAN AppendDistinct(const MessageIdentifierRange & range);
00231         // returns if the range exactly exists, means the given range is inside the container
00232         BOOLEAN Exists(const MessageIdentifierRange & range) const;
00233         // clears the range, without deleting the container, means reusing memory
00234         BOOLEAN Clear() {
00235             m_no_of_pairs = 0;
00236             return TRUE;
00237         }
00238         // removes the range if it is existing as the given range
00239         BOOLEAN Remove(const MessageIdentifierRange & range);
00240         // operator []
00241         const MessageIdentifierRange operator [] (INT idx) const {
00242             return MessageIdentifierRange(m_pair[idx].m_begin,m_pair[idx].m_end);
00243         }
00244         // returns the number of MessageIdentifierRanges
00245         INT GetSize() const { return m_no_of_pairs; }
00246
00247         // merges a complete container with AppendMerged
00248         BOOLEAN Merge(const MessageIdentifierContainer &midcont) ;
00249         // optimize the complete container iterative, means that all overlapping ranges are merged
00250         BOOLEAN Optimize();
00251         // merges the container to a given maximum number of ranges
00252         BOOLEAN Limit(INT limit);
00253         // appends a pair at correct position with inserting
00254         BOOLEAN AppendSorted(const MessageIdentifierPair & pair);
00255
00256 #if defined(_DEBUG) && defined(APOXI_RTOS_WIN32)
00257         void DbgOut() const;
00258         void SelfTest() const;
00259         void FitTest(const MessageIdentifierContainer & cont) const;
00260 #endif
00261
00262     private:
00263         // allocates the array
00264         void Allocate(INT size);
00265         // assigns the buffer from cont to the object and clears buffer of cont
00266         void Assign(MessageIdentifierContainer & cont);
00267
00268         // appends a range merged, means that overlapping areas are taken into account
00269         BOOLEAN AppendMerged(const MessageIdentifierPair & pair);
00270         // appends a pair without check and merging
00271         BOOLEAN Append(const MessageIdentifierPair & pair);
00272
00273
00274         MessageIdentifierPair * m_pair;
00275         INT m_no_of_pairs;
00276         INT m_preallocsize;
00277 };
00278
00279
00280
00281
00282 #endif  // Apc_MessageIdentifier_hpp
00283
00284
Generated on Tue Jan 24 14:46:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MessageImpl.cpp File Reference

Apc/MessageImpl.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Message.hpp"
#include "StackMsgArgument.hpp"
#include <Kernel/VersionInfo.hpp>

Include dependency graph for MessageImpl.cpp:

Functions

ApoxiUseVersionInfo (Apc)

Function Documentation

ApoxiUseVersionInfo ( Apc )

Generated on Tue Jan 24 16:57:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MessageTypeIndicator.cpp File Reference

Apc/MessageTypeIndicator.cpp File Reference

#include "Apc/PreComp.hpp"
#include "MessageTypeIndicator.hpp"
#include <Auxiliary/BitField.hpp>

Include dependency graph for MessageTypeIndicator.cpp:

Generated on Tue Jan 24 16:57:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MessageTypeIndicator.hpp File Reference

Apc/MessageTypeIndicator.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for MessageTypeIndicator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MessageTypeIndicator

Defines

#define | Apc_MessageTypeIndicator_hpp

Define Documentation

#define Apc_MessageTypeIndicator_hpp

Generated on Tue Jan 24 16:57:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MessageTypeIndicator.hpp Source File

Apc/MessageTypeIndicator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_MessageTypeIndicator_hpp)
00009 #define Apc_MessageTypeIndicator_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013
00014 /*  ========================================================================
00015     MessageTypeIndicator - 3GPP 23.040 V5.1.0 [9.2.3.1]
00016     ======================================================================== */
00020 class MessageTypeIndicator {
00021     public:
00022         enum Usage {
00024             MobileOriginated,
00026             MobileTerminated,
00028             InvalidUsage,
00029         };
00030
00031         enum Type { // do not change oder of enums ! used as index
00033             DeliverReport = 0,
00035             Submit,
00037             Command,
00038
00040             Deliver,
00042             SubmitReport,
00044             StatusReport,
00045
00047             ReservedType,
00049             InvalidType,
00050         };
00051
00053         MessageTypeIndicator();
00055         MessageTypeIndicator(Usage usage, UINT8 *data = 0);
00056
00058         Type GetType() const;
00059
00061         void SetType(Type format);
00062
00063         Usage GetUsage() const { return (m_usage); }
00064         void SetUsage(Usage usage) { m_usage = usage; }
00065
00067         BOOLEAN IsInvalid() const;
00068
00070         void Clear();
00071
00072         Type GetOriginType() const;
00073
00074     private:
00075         Usage m_usage;
00076         // the format is stored within the bits 3 and 4 of one byte
00077         UINT8 *m_data;
00078 };
00079
00080
00081 #endif  // Apc_MessageTypeIndicator_hpp
00082
00083
Generated on Tue Jan 24 14:46:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MiscStackMsgArgs.cpp File Reference

Apc/MiscStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "MiscStackMsgArgs.hpp"

Include dependency graph for MiscStackMsgArgs.cpp:

Generated on Tue Jan 24 16:57:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MiscStackMsgArgs.hpp File Reference

Apc/MiscStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Apc/Accessory.hpp>
#include <Apc/SimTkTypes.hpp>

Include dependency graph for MiscStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AccessoryIndArg
class | BandSelectionReqArg
class | BootDispatchingArg
class | CfuDataIndArg
class | EccListIndArg
class | EngineeringModeControlRequestArg
class | EngineeringModeControlResponseArg
class | ImeiReadIndArg
class | ImeiReadReqArg
class | OmFactoryResetIndArg
class | OmGetTermProfileCnfArg
class | OmGetTermProfileReqArg
class | OmSetTermProfileCnfArg
class | OmSetTermProfileRejArg
class | OmSetTermProfileReqArg
class | SignalStrengthLevelIndArg
class | TestparamReqArg

Defines

#define | Apc_MiscStackMsgArgs_hpp

Define Documentation

#define Apc_MiscStackMsgArgs_hpp

Generated on Tue Jan 24 16:57:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MiscStackMsgArgs.hpp Source File

Apc/MiscStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Apc\MiscArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_MiscStackMsgArgs_hpp)
00016 #define Apc_MiscStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Apc/NetworkTypes.hpp>
00021 #include <Apc/Accessory.hpp>
00022 #include <Apc/SimTkTypes.hpp>
00023
00024
00025 /* ----------------------------------------------------------------------
00026     Classes
00027     ---------------------------------------------------------------------- */
00028
00029 /*  ======================================================================
00030     Class SignalStrengthLevelIndArg
00031     ====================================================================== */
00032
00034 class SignalStrengthLevelIndArg : public StackMsgArgument {
00035     friend class CommonStackMsgArgsDestroyTableNode;
00036     public:
00037         SignalStrengthLevelIndArg();
00038
00039         static const SignalStrengthLevelIndArg& Cast(const StackMsgArgument& arg);
00040         void SetLevel(const SignalStrengthLevel& level) { m_level = level; }
00041         const SignalStrengthLevel& GetLevel() const { return m_level; }
00042         void SetQualityValid(BOOLEAN quality_valid) { m_quality_valid = quality_valid; }
00043         BOOLEAN IsQualityValid() const { return m_quality_valid; }
00044         void SetQuality(const SignalQualityLevel& quality) { m_quality = quality; }
00045         const SignalQualityLevel& GetQuality() const { return m_quality; }
00046         void SetSignalStrengthMax(const SignalStrengthMax& signal_strength_max) { m_signal_strength_max = signal_strength_max; }
00047         const SignalStrengthMax& GetSignalStrengthMax() const { return m_signal_strength_max; }
00048         void SetSignalQualityMax(const SignalQualityMax& signal_quality_max) { m_signal_quality_max = signal_quality_max; }
00049         const SignalQualityMax& GetSignalQualityMax() const { return m_signal_quality_max; }
00050
00051         enum  {
00052             ID = 1100
00053             };
00054
00055     private:
00056
00057         static void Destroy(StackMsgArgument* arg) { delete ((SignalStrengthLevelIndArg*) arg); }
00058
00059         SignalStrengthLevel m_level;
00060         BOOLEAN m_quality_valid;
00061         SignalQualityLevel m_quality;
00062         SignalStrengthMax m_signal_strength_max;
00063         SignalQualityMax m_signal_quality_max;
00064
00065     };
00066
00067 // Inline definitions
00068 inline const SignalStrengthLevelIndArg& SignalStrengthLevelIndArg::Cast(const StackMsgArgument& arg) {
00069     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SignalStrengthLevelIndArg!\n");
00070     return ((SignalStrengthLevelIndArg &) arg);
00071 }
00072
00073
00074
00075 /*  ======================================================================
00076     Class ImeiReadIndArg
00077     ====================================================================== */
00078
00080 class ImeiReadIndArg : public StackMsgArgument {
00081     friend class CommonStackMsgArgsDestroyTableNode;
00082     public:
00083         ImeiReadIndArg();
00084
00085         static const ImeiReadIndArg& Cast(const StackMsgArgument& arg);
00086         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00087         const SimUpdateStatus& GetStatus() const { return m_status; }
00088         void SetImei1(const Imei& imei1) { m_imei1 = imei1; }
00089         const Imei& GetImei1() const { return m_imei1; }
00090         void SetImei2(const Imei& imei2) { m_imei2 = imei2; }
00091         const Imei& GetImei2() const { return m_imei2; }
00092
00093         enum  {
00094             ID = 1110
00095             };
00096
00097     private:
00098
00099         static void Destroy(StackMsgArgument* arg) { delete ((ImeiReadIndArg*) arg); }
00100
00101         SimUpdateStatus m_status;
00102         Imei m_imei1;
00103         Imei m_imei2;
00104
00105     };
00106
00107 // Inline definitions
00108 inline const ImeiReadIndArg& ImeiReadIndArg::Cast(const StackMsgArgument& arg) {
00109     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ImeiReadIndArg!\n");
00110     return ((ImeiReadIndArg &) arg);
00111 }
00112
00113
00114
00115 /*  ======================================================================
00116     Class AccessoryIndArg
00117     ====================================================================== */
00118
00120 class AccessoryIndArg : public StackMsgArgument {
00121     friend class CommonStackMsgArgsDestroyTableNode;
00122     public:
00123         AccessoryIndArg();
00124
00125         static const AccessoryIndArg& Cast(const StackMsgArgument& arg);
00126         void SetAccessory(const Accessory& accessory) { m_accessory = accessory; }
00127         const Accessory& GetAccessory() const { return m_accessory; }
00128
00129         enum  {
00130             ID = 1111
00131             };
00132
00133     private:
00134
00135         static void Destroy(StackMsgArgument* arg) { delete ((AccessoryIndArg*) arg); }
00136
00137         Accessory m_accessory;
00138
00139     };
00140
00141 // Inline definitions
00142 inline const AccessoryIndArg& AccessoryIndArg::Cast(const StackMsgArgument& arg) {
00143     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AccessoryIndArg!\n");
00144     return ((AccessoryIndArg &) arg);
00145 }
00146
00147
00148
00149 /*  ======================================================================
00150     Class OmGetTermProfileCnfArg
00151     ====================================================================== */
00152
00154 class OmGetTermProfileCnfArg : public StackMsgArgument {
00155     friend class CommonStackMsgArgsDestroyTableNode;
00156     public:
00157         OmGetTermProfileCnfArg();
00158
00159         static const OmGetTermProfileCnfArg& Cast(const StackMsgArgument& arg);
00160         void SetSimTkProfile(const SimTkProfile& sim_tk_profile) { m_sim_tk_profile = sim_tk_profile; }
00161         const SimTkProfile& GetSimTkProfile() const { return m_sim_tk_profile; }
00162
00163         enum  {
00164             ID = 1114
00165             };
00166
00167     private:
00168
00169         static void Destroy(StackMsgArgument* arg) { delete ((OmGetTermProfileCnfArg*) arg); }
00170
00171         SimTkProfile m_sim_tk_profile;
00172
00173     };
00174
00175 // Inline definitions
00176 inline const OmGetTermProfileCnfArg& OmGetTermProfileCnfArg::Cast(const StackMsgArgument& arg) {
00177     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmGetTermProfileCnfArg!\n");
00178     return ((OmGetTermProfileCnfArg &) arg);
00179 }
00180
00181
00182
00183 /*  ======================================================================
00184     Class OmSetTermProfileCnfArg
00185     ====================================================================== */
00186
00188 class OmSetTermProfileCnfArg : public StackMsgArgument {
00189     friend class CommonStackMsgArgsDestroyTableNode;
00190     public:
00191         OmSetTermProfileCnfArg();
00192
00193         static const OmSetTermProfileCnfArg& Cast(const StackMsgArgument& arg);
00194
00195         enum  {
00196             ID = 1115
00197             };
00198
00199     private:
00200
00201         static void Destroy(StackMsgArgument* arg) { delete ((OmSetTermProfileCnfArg*) arg); }
00202
00203     };
00204
00205 // Inline definitions
00206 inline const OmSetTermProfileCnfArg& OmSetTermProfileCnfArg::Cast(const StackMsgArgument& arg) {
00207     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmSetTermProfileCnfArg!\n");
00208     return ((OmSetTermProfileCnfArg &) arg);
00209 }
00210
00211
00212
00213 /*  ======================================================================
00214     Class OmSetTermProfileRejArg
00215     ====================================================================== */
00216
00218 class OmSetTermProfileRejArg : public StackMsgArgument {
00219     friend class CommonStackMsgArgsDestroyTableNode;
00220     public:
00221         OmSetTermProfileRejArg();
00222
00223         static const OmSetTermProfileRejArg& Cast(const StackMsgArgument& arg);
00224
00225         enum  {
00226             ID = 1116
00227             };
00228
00229     private:
00230
00231         static void Destroy(StackMsgArgument* arg) { delete ((OmSetTermProfileRejArg*) arg); }
00232
00233     };
00234
00235 // Inline definitions
00236 inline const OmSetTermProfileRejArg& OmSetTermProfileRejArg::Cast(const StackMsgArgument& arg) {
00237     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmSetTermProfileRejArg!\n");
00238     return ((OmSetTermProfileRejArg &) arg);
00239 }
00240
00241
00242
00243 /*  ======================================================================
00244     Class EngineeringModeControlResponseArg
00245     ====================================================================== */
00246
00248 class EngineeringModeControlResponseArg : public StackMsgArgument {
00249     friend class CommonStackMsgArgsDestroyTableNode;
00250     public:
00251         EngineeringModeControlResponseArg();
00252
00253         static const EngineeringModeControlResponseArg& Cast(const StackMsgArgument& arg);
00254         void SetFunction(INT function) { m_function = function; }
00255         INT GetFunction() const { return m_function; }
00256         void SetResult(INT result) { m_result = result; }
00257         INT GetResult() const { return m_result; }
00258
00259         enum  {
00260             ID = 1117
00261             };
00262
00263     private:
00264
00265         static void Destroy(StackMsgArgument* arg) { delete ((EngineeringModeControlResponseArg*) arg); }
00266
00267         INT m_function;
00268         INT m_result;
00269
00270     };
00271
00272 // Inline definitions
00273 inline const EngineeringModeControlResponseArg& EngineeringModeControlResponseArg::Cast(const StackMsgArgument& arg) {
00274     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to EngineeringModeControlResponseArg!\n");
00275     return ((EngineeringModeControlResponseArg &) arg);
00276 }
00277
00278
00279
00280 /*  ======================================================================
00281     Class CfuDataIndArg
00282     ====================================================================== */
00283
00285 class CfuDataIndArg : public StackMsgArgument {
00286     friend class CommonStackMsgArgsDestroyTableNode;
00287     public:
00288         CfuDataIndArg();
00289
00290         static const CfuDataIndArg& Cast(const StackMsgArgument& arg);
00291         void SetCfuServiceArray(const CfuServiceArray& cfu_service_array) { m_cfu_service_array = cfu_service_array; }
00292         const CfuServiceArray& GetCfuServiceArray() const { return m_cfu_service_array; }
00293
00294         enum  {
00295             ID = 1118
00296             };
00297
00298     private:
00299
00300         static void Destroy(StackMsgArgument* arg) { delete ((CfuDataIndArg*) arg); }
00301
00302         CfuServiceArray m_cfu_service_array;
00303
00304     };
00305
00306 // Inline definitions
00307 inline const CfuDataIndArg& CfuDataIndArg::Cast(const StackMsgArgument& arg) {
00308     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CfuDataIndArg!\n");
00309     return ((CfuDataIndArg &) arg);
00310 }
00311
00312
00313
00314 /*  ======================================================================
00315     Class EccListIndArg
00316     ====================================================================== */
00317
00319 class EccListIndArg : public StackMsgArgument {
00320     friend class CommonStackMsgArgsDestroyTableNode;
00321     public:
00322         EccListIndArg(const EccNetworkArray& ecc_network_array);
00323         EccListIndArg();
00324
00325         static const EccListIndArg& Cast(const StackMsgArgument& arg);
00326         void SetEccNetworkArray(const EccNetworkArray& ecc_network_array) { m_ecc_network_array = ecc_network_array; }
00327         const EccNetworkArray& GetEccNetworkArray() const { return m_ecc_network_array; }
00328
00329         enum  {
00330             ID = 1380
00331             };
00332
00333     private:
00334
00335         static void Destroy(StackMsgArgument* arg) { delete ((EccListIndArg*) arg); }
00336
00337         EccNetworkArray m_ecc_network_array;
00338
00339     };
00340
00341 // Inline definitions
00342 inline const EccListIndArg& EccListIndArg::Cast(const StackMsgArgument& arg) {
00343     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to EccListIndArg!\n");
00344     return ((EccListIndArg &) arg);
00345 }
00346
00347
00348
00349 /*  ======================================================================
00350     Class BootDispatchingArg
00351     ====================================================================== */
00352
00354 class BootDispatchingArg : public StackMsgArgument {
00355     friend class CommonStackMsgArgsDestroyTableNode;
00356     public:
00357         BootDispatchingArg();
00358
00359         static const BootDispatchingArg& Cast(const StackMsgArgument& arg);
00360         void SetSequence(INT sequence) { m_sequence = sequence; }
00361         INT GetSequence() const { return m_sequence; }
00362
00363         enum  {
00364             ID = 1381
00365             };
00366
00367     private:
00368
00369         static void Destroy(StackMsgArgument* arg) { delete ((BootDispatchingArg*) arg); }
00370
00371         INT m_sequence;
00372
00373     };
00374
00375 // Inline definitions
00376 inline const BootDispatchingArg& BootDispatchingArg::Cast(const StackMsgArgument& arg) {
00377     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BootDispatchingArg!\n");
00378     return ((BootDispatchingArg &) arg);
00379 }
00380
00381
00382
00383 /*  ======================================================================
00384     Class ImeiReadReqArg
00385     ====================================================================== */
00386
00388 class ImeiReadReqArg : public StackMsgArgument {
00389     friend class CommonStackMsgArgsDestroyTableNode;
00390     public:
00391         ImeiReadReqArg();
00392
00393         static const ImeiReadReqArg& Cast(const StackMsgArgument& arg);
00394
00395         enum  {
00396             ID = 2103
00397             };
00398
00399     private:
00400
00401         static void Destroy(StackMsgArgument* arg) { delete ((ImeiReadReqArg*) arg); }
00402
00403     };
00404
00405 // Inline definitions
00406 inline const ImeiReadReqArg& ImeiReadReqArg::Cast(const StackMsgArgument& arg) {
00407     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ImeiReadReqArg!\n");
00408     return ((ImeiReadReqArg &) arg);
00409 }
00410
00411
00412
00413 /*  ======================================================================
00414     Class TestparamReqArg
00415     ====================================================================== */
00416
00418 class TestparamReqArg : public StackMsgArgument {
00419     friend class CommonStackMsgArgsDestroyTableNode;
00420     public:
00421         TestparamReqArg(BOOLEAN test = FALSE);
00422
00423         static const TestparamReqArg& Cast(const StackMsgArgument& arg);
00424         void SetTest(BOOLEAN test) { m_test = test; }
00425         BOOLEAN IsTest() const { return m_test; }
00426
00427         enum  {
00428             ID = 2104
00429             };
00430
00431     private:
00432
00433         static void Destroy(StackMsgArgument* arg) { delete ((TestparamReqArg*) arg); }
00434
00435         BOOLEAN m_test;
00436
00437     };
00438
00439 // Inline definitions
00440 inline const TestparamReqArg& TestparamReqArg::Cast(const StackMsgArgument& arg) {
00441     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to TestparamReqArg!\n");
00442     return ((TestparamReqArg &) arg);
00443 }
00444
00445
00446
00447 /*  ======================================================================
00448     Class BandSelectionReqArg
00449     ====================================================================== */
00450
00452 class BandSelectionReqArg : public StackMsgArgument {
00453     friend class CommonStackMsgArgsDestroyTableNode;
00454     public:
00455         BandSelectionReqArg(const GsmBandList& gsm_band_list);
00456         BandSelectionReqArg();
00457
00458         static const BandSelectionReqArg& Cast(const StackMsgArgument& arg);
00459         void SetGsmBandList(const GsmBandList& gsm_band_list) { m_gsm_band_list = gsm_band_list; }
00460         const GsmBandList& GetGsmBandList() const { return m_gsm_band_list; }
00461
00462         enum  {
00463             ID = 2105
00464             };
00465
00466     private:
00467
00468         static void Destroy(StackMsgArgument* arg) { delete ((BandSelectionReqArg*) arg); }
00469
00470         GsmBandList m_gsm_band_list;
00471
00472     };
00473
00474 // Inline definitions
00475 inline const BandSelectionReqArg& BandSelectionReqArg::Cast(const StackMsgArgument& arg) {
00476     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BandSelectionReqArg!\n");
00477     return ((BandSelectionReqArg &) arg);
00478 }
00479
00480
00481
00482 /*  ======================================================================
00483     Class OmFactoryResetIndArg
00484     ====================================================================== */
00485
00487 class OmFactoryResetIndArg : public StackMsgArgument {
00488     friend class CommonStackMsgArgsDestroyTableNode;
00489     public:
00490         OmFactoryResetIndArg();
00491
00492         static const OmFactoryResetIndArg& Cast(const StackMsgArgument& arg);
00493
00494         enum  {
00495             ID = 2106
00496             };
00497
00498     private:
00499
00500         static void Destroy(StackMsgArgument* arg) { delete ((OmFactoryResetIndArg*) arg); }
00501
00502     };
00503
00504 // Inline definitions
00505 inline const OmFactoryResetIndArg& OmFactoryResetIndArg::Cast(const StackMsgArgument& arg) {
00506     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmFactoryResetIndArg!\n");
00507     return ((OmFactoryResetIndArg &) arg);
00508 }
00509
00510
00511
00512 /*  ======================================================================
00513     Class OmGetTermProfileReqArg
00514     ====================================================================== */
00515
00517 class OmGetTermProfileReqArg : public StackMsgArgument {
00518     friend class CommonStackMsgArgsDestroyTableNode;
00519     public:
00520         OmGetTermProfileReqArg();
00521
00522         static const OmGetTermProfileReqArg& Cast(const StackMsgArgument& arg);
00523
00524         enum  {
00525             ID = 2107
00526             };
00527
00528     private:
00529
00530         static void Destroy(StackMsgArgument* arg) { delete ((OmGetTermProfileReqArg*) arg); }
00531
00532     };
00533
00534 // Inline definitions
00535 inline const OmGetTermProfileReqArg& OmGetTermProfileReqArg::Cast(const StackMsgArgument& arg) {
00536     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmGetTermProfileReqArg!\n");
00537     return ((OmGetTermProfileReqArg &) arg);
00538 }
00539
00540
00541
00542 /*  ======================================================================
00543     Class OmSetTermProfileReqArg
00544     ====================================================================== */
00545
00547 class OmSetTermProfileReqArg : public StackMsgArgument {
00548     friend class CommonStackMsgArgsDestroyTableNode;
00549     public:
00550         OmSetTermProfileReqArg(const SimTkProfile& sim_tk_profile);
00551         OmSetTermProfileReqArg();
00552
00553         static const OmSetTermProfileReqArg& Cast(const StackMsgArgument& arg);
00554         void SetSimTkProfile(const SimTkProfile& sim_tk_profile) { m_sim_tk_profile = sim_tk_profile; }
00555         const SimTkProfile& GetSimTkProfile() const { return m_sim_tk_profile; }
00556
00557         enum  {
00558             ID = 2108
00559             };
00560
00561     private:
00562
00563         static void Destroy(StackMsgArgument* arg) { delete ((OmSetTermProfileReqArg*) arg); }
00564
00565         SimTkProfile m_sim_tk_profile;
00566
00567     };
00568
00569 // Inline definitions
00570 inline const OmSetTermProfileReqArg& OmSetTermProfileReqArg::Cast(const StackMsgArgument& arg) {
00571     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmSetTermProfileReqArg!\n");
00572     return ((OmSetTermProfileReqArg &) arg);
00573 }
00574
00575
00576
00577 /*  ======================================================================
00578     Class EngineeringModeControlRequestArg
00579     ====================================================================== */
00580
00582 class EngineeringModeControlRequestArg : public StackMsgArgument {
00583     friend class CommonStackMsgArgsDestroyTableNode;
00584     public:
00585         EngineeringModeControlRequestArg(const EngineeringModeControl& function, ULONG param = 0);
00586         EngineeringModeControlRequestArg();
00587
00588         static const EngineeringModeControlRequestArg& Cast(const StackMsgArgument& arg);
00589         void SetFunction(const EngineeringModeControl& function) { m_function = function; }
00590         const EngineeringModeControl& GetFunction() const { return m_function; }
00591         void SetParam(ULONG param) { m_param = param; }
00592         ULONG GetParam() const { return m_param; }
00593
00594         enum  {
00595             ID = 2109
00596             };
00597
00598     private:
00599
00600         static void Destroy(StackMsgArgument* arg) { delete ((EngineeringModeControlRequestArg*) arg); }
00601
00602         EngineeringModeControl m_function;
00603         ULONG m_param;
00604
00605     };
00606
00607 // Inline definitions
00608 inline const EngineeringModeControlRequestArg& EngineeringModeControlRequestArg::Cast(const StackMsgArgument& arg) {
00609     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to EngineeringModeControlRequestArg!\n");
00610     return ((EngineeringModeControlRequestArg &) arg);
00611 }
00612
00613
00614 #endif // Apc_MiscStackMsgArgs_hpp
00615
Generated on Tue Jan 24 14:46:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MocStackMsgArgs.cpp File Reference

Apc/MocStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "MocStackMsgArgs.hpp"

Include dependency graph for MocStackMsgArgs.cpp:

Generated on Tue Jan 24 16:57:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MocStackMsgArgs.hpp File Reference

Apc/MocStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for MocStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AutoCallRestrictIndArg
class | ClearBlackListCnfArg
class | ClearBlacklistReqArg
class | MocAlertIndArg
class | MocSetupAccArg
class | MocSetupCnfArg
class | MocSetupRejArg
class | MocSetupReqArg
class | RedialIndArg
class | RediallingDisabledIndArg
class | RedialRejArg
class | RedialSetupIndArg
class | RedialStopIndArg

Defines

#define | Apc_MocStackMsgArgs_hpp

Define Documentation

#define Apc_MocStackMsgArgs_hpp

Generated on Tue Jan 24 16:57:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MocStackMsgArgs.hpp Source File

Apc/MocStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "auzinger_view_latest\lnz_apoxi\Apoxi\Apc\MocArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_MocStackMsgArgs_hpp)
00016 #define Apc_MocStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class MocSetupRejArg
00028     ====================================================================== */
00029
00031 class MocSetupRejArg : public StackMsgArgument {
00032     friend class CommonStackMsgArgsDestroyTableNode;
00033     public:
00034         MocSetupRejArg();
00035
00036         static const MocSetupRejArg& Cast(const StackMsgArgument& arg);
00037         void SetRejectCause(const CallErrorCause& reject_cause) { m_reject_cause = reject_cause; }
00038         const CallErrorCause& GetRejectCause() const { return m_reject_cause; }
00039
00040         enum  {
00041             ID = 1140
00042             };
00043
00044     private:
00045
00046         static void Destroy(StackMsgArgument* arg) { delete ((MocSetupRejArg*) arg); }
00047
00048         CallErrorCause m_reject_cause;
00049
00050     };
00051
00052 // Inline definitions
00053 inline const MocSetupRejArg& MocSetupRejArg::Cast(const StackMsgArgument& arg) {
00054     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MocSetupRejArg!\n");
00055     return ((MocSetupRejArg &) arg);
00056 }
00057
00058
00059
00060 /*  ======================================================================
00061     Class MocSetupAccArg
00062     ====================================================================== */
00063
00065 class MocSetupAccArg : public StackMsgArgument {
00066     friend class CommonStackMsgArgsDestroyTableNode;
00067     public:
00068         MocSetupAccArg();
00069
00070         static const MocSetupAccArg& Cast(const StackMsgArgument& arg);
00071         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00072         const Tipd& GetTipd() const { return m_tipd; }
00073         void SetEstCause(const CallEstCause& est_cause) { m_est_cause = est_cause; }
00074         const CallEstCause& GetEstCause() const { return m_est_cause; }
00075         void SetEccCategory(const EccCategory& ecc_category) { m_ecc_category = ecc_category; }
00076         const EccCategory& GetEccCategory() const { return m_ecc_category; }
00077
00078         enum  {
00079             ID = 1141
00080             };
00081
00082     private:
00083
00084         static void Destroy(StackMsgArgument* arg) { delete ((MocSetupAccArg*) arg); }
00085
00086         Tipd m_tipd;
00087         CallEstCause m_est_cause;
00088         EccCategory m_ecc_category;
00089
00090     };
00091
00092 // Inline definitions
00093 inline const MocSetupAccArg& MocSetupAccArg::Cast(const StackMsgArgument& arg) {
00094     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MocSetupAccArg!\n");
00095     return ((MocSetupAccArg &) arg);
00096 }
00097
00098
00099
00100 /*  ======================================================================
00101     Class MocAlertIndArg
00102     ====================================================================== */
00103
00105 class MocAlertIndArg : public StackMsgArgument {
00106     friend class CommonStackMsgArgsDestroyTableNode;
00107     public:
00108         MocAlertIndArg();
00109
00110         static const MocAlertIndArg& Cast(const StackMsgArgument& arg);
00111         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00112         const Tipd& GetTipd() const { return m_tipd; }
00113
00114         enum  {
00115             ID = 1142
00116             };
00117
00118     private:
00119
00120         static void Destroy(StackMsgArgument* arg) { delete ((MocAlertIndArg*) arg); }
00121
00122         Tipd m_tipd;
00123
00124     };
00125
00126 // Inline definitions
00127 inline const MocAlertIndArg& MocAlertIndArg::Cast(const StackMsgArgument& arg) {
00128     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MocAlertIndArg!\n");
00129     return ((MocAlertIndArg &) arg);
00130 }
00131
00132
00133
00134 /*  ======================================================================
00135     Class MocSetupCnfArg
00136     ====================================================================== */
00137
00139 class MocSetupCnfArg : public StackMsgArgument {
00140     friend class CommonStackMsgArgsDestroyTableNode;
00141     public:
00142         MocSetupCnfArg();
00143
00144         static const MocSetupCnfArg& Cast(const StackMsgArgument& arg);
00145         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00146         const Tipd& GetTipd() const { return m_tipd; }
00147         void SetConnectedNo(const PhoneNumber& connected_no) { m_connected_no = connected_no; }
00148         const PhoneNumber& GetConnectedNo() const { return m_connected_no; }
00149         void SetCrssCode(const CallRelatedSsCode& crss_code) { m_crss_code = crss_code; }
00150         const CallRelatedSsCode& GetCrssCode() const { return m_crss_code; }
00151
00152         enum  {
00153             ID = 1143
00154             };
00155
00156     private:
00157
00158         static void Destroy(StackMsgArgument* arg) { delete ((MocSetupCnfArg*) arg); }
00159
00160         Tipd m_tipd;
00161         PhoneNumber m_connected_no;
00162         CallRelatedSsCode m_crss_code;
00163
00164     };
00165
00166 // Inline definitions
00167 inline const MocSetupCnfArg& MocSetupCnfArg::Cast(const StackMsgArgument& arg) {
00168     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MocSetupCnfArg!\n");
00169     return ((MocSetupCnfArg &) arg);
00170 }
00171
00172
00173
00174 /*  ======================================================================
00175     Class RedialIndArg
00176     ====================================================================== */
00177
00179 class RedialIndArg : public StackMsgArgument {
00180     friend class CommonStackMsgArgsDestroyTableNode;
00181     public:
00182         RedialIndArg();
00183
00184         static const RedialIndArg& Cast(const StackMsgArgument& arg);
00185
00186         enum  {
00187             ID = 1144
00188             };
00189
00190     private:
00191
00192         static void Destroy(StackMsgArgument* arg) { delete ((RedialIndArg*) arg); }
00193
00194     };
00195
00196 // Inline definitions
00197 inline const RedialIndArg& RedialIndArg::Cast(const StackMsgArgument& arg) {
00198     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RedialIndArg!\n");
00199     return ((RedialIndArg &) arg);
00200 }
00201
00202
00203
00204 /*  ======================================================================
00205     Class RedialSetupIndArg
00206     ====================================================================== */
00207
00209 class RedialSetupIndArg : public StackMsgArgument {
00210     friend class CommonStackMsgArgsDestroyTableNode;
00211     public:
00212         RedialSetupIndArg();
00213
00214         static const RedialSetupIndArg& Cast(const StackMsgArgument& arg);
00215         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00216         const Tipd& GetTipd() const { return m_tipd; }
00217         void SetCalledPartyNo(const PhoneNumber& called_party_no) { m_called_party_no = called_party_no; }
00218         const PhoneNumber& GetCalledPartyNo() const { return m_called_party_no; }
00219         void SetServedCallApp(const ServedCallApplication& served_call_app) { m_served_call_app = served_call_app; }
00220         const ServedCallApplication& GetServedCallApp() const { return m_served_call_app; }
00221         void SetEstCause(const CallEstCause& est_cause) { m_est_cause = est_cause; }
00222         const CallEstCause& GetEstCause() const { return m_est_cause; }
00223         void SetEccCategory(const EccCategory& ecc_category) { m_ecc_category = ecc_category; }
00224         const EccCategory& GetEccCategory() const { return m_ecc_category; }
00225
00226         enum  {
00227             ID = 1145
00228             };
00229
00230     private:
00231
00232         static void Destroy(StackMsgArgument* arg) { delete ((RedialSetupIndArg*) arg); }
00233
00234         Tipd m_tipd;
00235         PhoneNumber m_called_party_no;
00236         ServedCallApplication m_served_call_app;
00237         CallEstCause m_est_cause;
00238         EccCategory m_ecc_category;
00239
00240     };
00241
00242 // Inline definitions
00243 inline const RedialSetupIndArg& RedialSetupIndArg::Cast(const StackMsgArgument& arg) {
00244     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RedialSetupIndArg!\n");
00245     return ((RedialSetupIndArg &) arg);
00246 }
00247
00248
00249
00250 /*  ======================================================================
00251     Class RedialStopIndArg
00252     ====================================================================== */
00253
00255 class RedialStopIndArg : public StackMsgArgument {
00256     friend class CommonStackMsgArgsDestroyTableNode;
00257     public:
00258         RedialStopIndArg();
00259
00260         static const RedialStopIndArg& Cast(const StackMsgArgument& arg);
00261
00262         enum  {
00263             ID = 1146
00264             };
00265
00266     private:
00267
00268         static void Destroy(StackMsgArgument* arg) { delete ((RedialStopIndArg*) arg); }
00269
00270     };
00271
00272 // Inline definitions
00273 inline const RedialStopIndArg& RedialStopIndArg::Cast(const StackMsgArgument& arg) {
00274     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RedialStopIndArg!\n");
00275     return ((RedialStopIndArg &) arg);
00276 }
00277
00278
00279
00280 /*  ======================================================================
00281     Class AutoCallRestrictIndArg
00282     ====================================================================== */
00283
00285 class AutoCallRestrictIndArg : public StackMsgArgument {
00286     friend class CommonStackMsgArgsDestroyTableNode;
00287     public:
00288         AutoCallRestrictIndArg();
00289
00290         static const AutoCallRestrictIndArg& Cast(const StackMsgArgument& arg);
00291         void SetRestricted(BOOLEAN restricted) { m_restricted = restricted; }
00292         BOOLEAN IsRestricted() const { return m_restricted; }
00293
00294         enum  {
00295             ID = 1147
00296             };
00297
00298     private:
00299
00300         static void Destroy(StackMsgArgument* arg) { delete ((AutoCallRestrictIndArg*) arg); }
00301
00302         BOOLEAN m_restricted;
00303
00304     };
00305
00306 // Inline definitions
00307 inline const AutoCallRestrictIndArg& AutoCallRestrictIndArg::Cast(const StackMsgArgument& arg) {
00308     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AutoCallRestrictIndArg!\n");
00309     return ((AutoCallRestrictIndArg &) arg);
00310 }
00311
00312
00313
00314 /*  ======================================================================
00315     Class ClearBlackListCnfArg
00316     ====================================================================== */
00317
00319 class ClearBlackListCnfArg : public StackMsgArgument {
00320     friend class CommonStackMsgArgsDestroyTableNode;
00321     public:
00322         ClearBlackListCnfArg();
00323
00324         static const ClearBlackListCnfArg& Cast(const StackMsgArgument& arg);
00325
00326         enum  {
00327             ID = 1148
00328             };
00329
00330     private:
00331
00332         static void Destroy(StackMsgArgument* arg) { delete ((ClearBlackListCnfArg*) arg); }
00333
00334     };
00335
00336 // Inline definitions
00337 inline const ClearBlackListCnfArg& ClearBlackListCnfArg::Cast(const StackMsgArgument& arg) {
00338     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ClearBlackListCnfArg!\n");
00339     return ((ClearBlackListCnfArg &) arg);
00340 }
00341
00342
00343
00344 /*  ======================================================================
00345     Class MocSetupReqArg
00346     ====================================================================== */
00347
00349 class MocSetupReqArg : public StackMsgArgument {
00350     friend class CommonStackMsgArgsDestroyTableNode;
00351     public:
00352         MocSetupReqArg(const CallEstCause& call_est_cause, const PhoneNumber& phone_no, const ClirMode& clir_mode, const CugDescriptor& cug, BOOLEAN auto_call_setup, const LineSelector& call_line, BOOLEAN ctm, const EccCategory& ecc_category);
00353         MocSetupReqArg();
00354
00355         static const MocSetupReqArg& Cast(const StackMsgArgument& arg);
00356         void SetCallEstCause(const CallEstCause& call_est_cause) { m_call_est_cause = call_est_cause; }
00357         const CallEstCause& GetCallEstCause() const { return m_call_est_cause; }
00358         void SetPhoneNo(const PhoneNumber& phone_no) { m_phone_no = phone_no; }
00359         const PhoneNumber& GetPhoneNo() const { return m_phone_no; }
00360         void SetClirMode(const ClirMode& clir_mode) { m_clir_mode = clir_mode; }
00361         const ClirMode& GetClirMode() const { return m_clir_mode; }
00362         void SetCug(const CugDescriptor& cug) { m_cug = cug; }
00363         const CugDescriptor& GetCug() const { return m_cug; }
00364         void SetAutoCallSetup(BOOLEAN auto_call_setup) { m_auto_call_setup = auto_call_setup; }
00365         BOOLEAN IsAutoCallSetup() const { return m_auto_call_setup; }
00366         void SetCallLine(const LineSelector& call_line) { m_call_line = call_line; }
00367         const LineSelector& GetCallLine() const { return m_call_line; }
00368         void SetCtm(BOOLEAN ctm) { m_ctm = ctm; }
00369         BOOLEAN IsCtm() const { return m_ctm; }
00370         void SetEccCategory(const EccCategory& ecc_category) { m_ecc_category = ecc_category; }
00371         const EccCategory& GetEccCategory() const { return m_ecc_category; }
00372
00373         enum  {
00374             ID = 2140
00375             };
00376
00377     private:
00378
00379         static void Destroy(StackMsgArgument* arg) { delete ((MocSetupReqArg*) arg); }
00380
00381         CallEstCause m_call_est_cause;
00382         PhoneNumber m_phone_no;
00383         ClirMode m_clir_mode;
00384         CugDescriptor m_cug;
00385         BOOLEAN m_auto_call_setup;
00386         LineSelector m_call_line;
00387         BOOLEAN m_ctm;
00388         EccCategory m_ecc_category;
00389
00390     };
00391
00392 // Inline definitions
00393 inline const MocSetupReqArg& MocSetupReqArg::Cast(const StackMsgArgument& arg) {
00394     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MocSetupReqArg!\n");
00395     return ((MocSetupReqArg &) arg);
00396 }
00397
00398
00399
00400 /*  ======================================================================
00401     Class RedialRejArg
00402     ====================================================================== */
00403
00405 class RedialRejArg : public StackMsgArgument {
00406     friend class CommonStackMsgArgsDestroyTableNode;
00407     public:
00408         RedialRejArg();
00409
00410         static const RedialRejArg& Cast(const StackMsgArgument& arg);
00411
00412         enum  {
00413             ID = 2141
00414             };
00415
00416     private:
00417
00418         static void Destroy(StackMsgArgument* arg) { delete ((RedialRejArg*) arg); }
00419
00420     };
00421
00422 // Inline definitions
00423 inline const RedialRejArg& RedialRejArg::Cast(const StackMsgArgument& arg) {
00424     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RedialRejArg!\n");
00425     return ((RedialRejArg &) arg);
00426 }
00427
00428
00429
00430 /*  ======================================================================
00431     Class RediallingDisabledIndArg
00432     ====================================================================== */
00433
00435 class RediallingDisabledIndArg : public StackMsgArgument {
00436     friend class CommonStackMsgArgsDestroyTableNode;
00437     public:
00438         RediallingDisabledIndArg(BOOLEAN disable);
00439         RediallingDisabledIndArg();
00440
00441         static const RediallingDisabledIndArg& Cast(const StackMsgArgument& arg);
00442         void SetDisable(BOOLEAN disable) { m_disable = disable; }
00443         BOOLEAN IsDisable() const { return m_disable; }
00444
00445         enum  {
00446             ID = 2142
00447             };
00448
00449     private:
00450
00451         static void Destroy(StackMsgArgument* arg) { delete ((RediallingDisabledIndArg*) arg); }
00452
00453         BOOLEAN m_disable;
00454
00455     };
00456
00457 // Inline definitions
00458 inline const RediallingDisabledIndArg& RediallingDisabledIndArg::Cast(const StackMsgArgument& arg) {
00459     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RediallingDisabledIndArg!\n");
00460     return ((RediallingDisabledIndArg &) arg);
00461 }
00462
00463
00464
00465 /*  ======================================================================
00466     Class ClearBlacklistReqArg
00467     ====================================================================== */
00468
00470 class ClearBlacklistReqArg : public StackMsgArgument {
00471     friend class CommonStackMsgArgsDestroyTableNode;
00472     public:
00473         ClearBlacklistReqArg();
00474
00475         static const ClearBlacklistReqArg& Cast(const StackMsgArgument& arg);
00476
00477         enum  {
00478             ID = 2143
00479             };
00480
00481     private:
00482
00483         static void Destroy(StackMsgArgument* arg) { delete ((ClearBlacklistReqArg*) arg); }
00484
00485     };
00486
00487 // Inline definitions
00488 inline const ClearBlacklistReqArg& ClearBlacklistReqArg::Cast(const StackMsgArgument& arg) {
00489     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ClearBlacklistReqArg!\n");
00490     return ((ClearBlacklistReqArg &) arg);
00491 }
00492
00493
00494 #endif // Apc_MocStackMsgArgs_hpp
00495
Generated on Tue Jan 24 14:46:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MtcStackMsgArgs.cpp File Reference

Apc/MtcStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "MtcStackMsgArgs.hpp"

Include dependency graph for MtcStackMsgArgs.cpp:

Generated on Tue Jan 24 16:57:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MtcStackMsgArgs.hpp File Reference

Apc/MtcStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for MtcStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MtcAcceptArg
class | MtcAcceptRejArg
class | MtcAlertReqArg
class | MtcConfIndArg
class | MtcSetupComplArg
class | MtcSetupIndArg

Defines

#define | Apc_MtcStackMsgArgs_hpp

Define Documentation

#define Apc_MtcStackMsgArgs_hpp

Generated on Tue Jan 24 16:57:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/MtcStackMsgArgs.hpp Source File

Apc/MtcStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "auzinger_mpe_pu_dv\lnz_apoxi\Apoxi\Apc\MtcArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_MtcStackMsgArgs_hpp)
00016 #define Apc_MtcStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class MtcConfIndArg
00028     ====================================================================== */
00029
00030 class MtcConfIndArg : public StackMsgArgument {
00031     friend class CommonStackMsgArgsDestroyTableNode;
00032     public:
00033         MtcConfIndArg();
00034
00035         static const MtcConfIndArg& Cast(const StackMsgArgument& arg);
00036         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00037         const Tipd& GetTipd() const { return m_tipd; }
00038
00039         enum  {
00040             ID = 1160
00041             };
00042
00043     private:
00044
00045         static void Destroy(StackMsgArgument* arg) { delete ((MtcConfIndArg*) arg); }
00046
00047         Tipd m_tipd;
00048
00049     };
00050
00051 // Inline definitions
00052 inline const MtcConfIndArg& MtcConfIndArg::Cast(const StackMsgArgument& arg) {
00053     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MtcConfIndArg!\n");
00054     return ((MtcConfIndArg &) arg);
00055 }
00056
00057
00058
00059 /*  ======================================================================
00060     Class MtcSetupIndArg
00061     ====================================================================== */
00062
00063 class MtcSetupIndArg : public StackMsgArgument {
00064     friend class CommonStackMsgArgsDestroyTableNode;
00065     public:
00066         MtcSetupIndArg();
00067
00068         static const MtcSetupIndArg& Cast(const StackMsgArgument& arg);
00069         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00070         const Tipd& GetTipd() const { return m_tipd; }
00071         void SetConnectedNo(const PhoneNumber& connected_no) { m_connected_no = connected_no; }
00072         const PhoneNumber& GetConnectedNo() const { return m_connected_no; }
00073         void SetGsmSignal(const GsmSignal& gsm_signal) { m_gsm_signal = gsm_signal; }
00074         const GsmSignal& GetGsmSignal() const { return m_gsm_signal; }
00075         void SetCallLine(const LineSelector& call_line) { m_call_line = call_line; }
00076         const LineSelector& GetCallLine() const { return m_call_line; }
00077         void SetCtm(BOOLEAN ctm) { m_ctm = ctm; }
00078         BOOLEAN IsCtm() const { return m_ctm; }
00079         void SetCallType(const CallType& call_type) { m_call_type = call_type; }
00080         const CallType& GetCallType() const { return m_call_type; }
00081
00082         enum  {
00083             ID = 1161
00084             };
00085
00086     private:
00087
00088         static void Destroy(StackMsgArgument* arg) { delete ((MtcSetupIndArg*) arg); }
00089
00090         Tipd m_tipd;
00091         PhoneNumber m_connected_no;
00092         GsmSignal m_gsm_signal;
00093         LineSelector m_call_line;
00094         BOOLEAN m_ctm;
00095         CallType m_call_type;
00096
00097     };
00098
00099 // Inline definitions
00100 inline const MtcSetupIndArg& MtcSetupIndArg::Cast(const StackMsgArgument& arg) {
00101     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MtcSetupIndArg!\n");
00102     return ((MtcSetupIndArg &) arg);
00103 }
00104
00105
00106
00107 /*  ======================================================================
00108     Class MtcSetupComplArg
00109     ====================================================================== */
00110
00111 class MtcSetupComplArg : public StackMsgArgument {
00112     friend class CommonStackMsgArgsDestroyTableNode;
00113     public:
00114         MtcSetupComplArg();
00115
00116         static const MtcSetupComplArg& Cast(const StackMsgArgument& arg);
00117         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00118         const Tipd& GetTipd() const { return m_tipd; }
00119         void SetCrssCode(const CallRelatedSsCode& crss_code) { m_crss_code = crss_code; }
00120         const CallRelatedSsCode& GetCrssCode() const { return m_crss_code; }
00121         void SetCallType(const CallType& call_type) { m_call_type = call_type; }
00122         const CallType& GetCallType() const { return m_call_type; }
00123
00124         enum  {
00125             ID = 1162
00126             };
00127
00128     private:
00129
00130         static void Destroy(StackMsgArgument* arg) { delete ((MtcSetupComplArg*) arg); }
00131
00132         Tipd m_tipd;
00133         CallRelatedSsCode m_crss_code;
00134         CallType m_call_type;
00135
00136     };
00137
00138 // Inline definitions
00139 inline const MtcSetupComplArg& MtcSetupComplArg::Cast(const StackMsgArgument& arg) {
00140     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MtcSetupComplArg!\n");
00141     return ((MtcSetupComplArg &) arg);
00142 }
00143
00144
00145
00146 /*  ======================================================================
00147     Class MtcAcceptRejArg
00148     ====================================================================== */
00149
00150 class MtcAcceptRejArg : public StackMsgArgument {
00151     friend class CommonStackMsgArgsDestroyTableNode;
00152     public:
00153         MtcAcceptRejArg();
00154
00155         static const MtcAcceptRejArg& Cast(const StackMsgArgument& arg);
00156         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00157         const Tipd& GetTipd() const { return m_tipd; }
00158
00159         enum  {
00160             ID = 1163
00161             };
00162
00163     private:
00164
00165         static void Destroy(StackMsgArgument* arg) { delete ((MtcAcceptRejArg*) arg); }
00166
00167         Tipd m_tipd;
00168
00169     };
00170
00171 // Inline definitions
00172 inline const MtcAcceptRejArg& MtcAcceptRejArg::Cast(const StackMsgArgument& arg) {
00173     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MtcAcceptRejArg!\n");
00174     return ((MtcAcceptRejArg &) arg);
00175 }
00176
00177
00178
00179 /*  ======================================================================
00180     Class MtcAcceptArg
00181     ====================================================================== */
00182
00184 class MtcAcceptArg : public StackMsgArgument {
00185     friend class CommonStackMsgArgsDestroyTableNode;
00186     public:
00187         MtcAcceptArg(const Tipd& tipd);
00188         MtcAcceptArg();
00189
00190         static const MtcAcceptArg& Cast(const StackMsgArgument& arg);
00191         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00192         const Tipd& GetTipd() const { return m_tipd; }
00193
00194         enum  {
00195             ID = 2160
00196             };
00197
00198     private:
00199
00200         static void Destroy(StackMsgArgument* arg) { delete ((MtcAcceptArg*) arg); }
00201
00202         Tipd m_tipd;
00203
00204     };
00205
00206 // Inline definitions
00207 inline const MtcAcceptArg& MtcAcceptArg::Cast(const StackMsgArgument& arg) {
00208     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MtcAcceptArg!\n");
00209     return ((MtcAcceptArg &) arg);
00210 }
00211
00212
00213
00214 /*  ======================================================================
00215     Class MtcAlertReqArg
00216     ====================================================================== */
00217
00219 class MtcAlertReqArg : public StackMsgArgument {
00220     friend class CommonStackMsgArgsDestroyTableNode;
00221     public:
00222         MtcAlertReqArg(const Tipd& tipd);
00223         MtcAlertReqArg();
00224
00225         static const MtcAlertReqArg& Cast(const StackMsgArgument& arg);
00226         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00227         const Tipd& GetTipd() const { return m_tipd; }
00228
00229         enum  {
00230             ID = 2161
00231             };
00232
00233     private:
00234
00235         static void Destroy(StackMsgArgument* arg) { delete ((MtcAlertReqArg*) arg); }
00236
00237         Tipd m_tipd;
00238
00239     };
00240
00241 // Inline definitions
00242 inline const MtcAlertReqArg& MtcAlertReqArg::Cast(const StackMsgArgument& arg) {
00243     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MtcAlertReqArg!\n");
00244     return ((MtcAlertReqArg &) arg);
00245 }
00246
00247
00248 #endif // Apc_MtcStackMsgArgs_hpp
00249
Generated on Tue Jan 24 14:46:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/NetworkStackMsgArgs.cpp File Reference

Apc/NetworkStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "NetworkStackMsgArgs.hpp"

Include dependency graph for NetworkStackMsgArgs.cpp:

Generated on Tue Jan 24 16:57:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/NetworkStackMsgArgs.hpp File Reference

Apc/NetworkStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Auxiliary/DateTime.hpp>

Include dependency graph for NetworkStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BandSelectionIndArg
class | CellInfoIndArg
class | ConnectionIndArg
class | HomezoneIndArg
class | MnInformationIndArg
class | MnNetworkSearchModeReqArg
class | MnTriggerReqArg
class | TestparamReportArg

Defines

#define | Apc_NetworkStackMsgArgs_hpp

Define Documentation

#define Apc_NetworkStackMsgArgs_hpp

Generated on Tue Jan 24 16:57:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/NetworkStackMsgArgs.hpp Source File

Apc/NetworkStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\Schwenkr_LeoR16\lnz_apoxi\Apoxi\Apc\NetworkArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_NetworkStackMsgArgs_hpp)
00016 #define Apc_NetworkStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/NetworkTypes.hpp>
00020 #include <Auxiliary/DateTime.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class ConnectionIndArg
00029     ====================================================================== */
00030
00032 class ConnectionIndArg : public StackMsgArgument {
00033     friend class CommonStackMsgArgsDestroyTableNode;
00034     public:
00035         ConnectionIndArg();
00036
00037         static const ConnectionIndArg& Cast(const StackMsgArgument& arg);
00038         void SetConnected(BOOLEAN connected) { m_connected = connected; }
00039         BOOLEAN IsConnected() const { return m_connected; }
00040         void SetEnciphered(BOOLEAN enciphered) { m_enciphered = enciphered; }
00041         BOOLEAN IsEnciphered() const { return m_enciphered; }
00042
00043         enum  {
00044             ID = 2180
00045             };
00046
00047     private:
00048
00049         static void Destroy(StackMsgArgument* arg) { delete ((ConnectionIndArg*) arg); }
00050
00051         BOOLEAN m_connected;
00052         BOOLEAN m_enciphered;
00053
00054     };
00055
00056 // Inline definitions
00057 inline const ConnectionIndArg& ConnectionIndArg::Cast(const StackMsgArgument& arg) {
00058     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ConnectionIndArg!\n");
00059     return ((ConnectionIndArg &) arg);
00060 }
00061
00062
00063
00064 /*  ======================================================================
00065     Class CellInfoIndArg
00066     ====================================================================== */
00067
00069 class CellInfoIndArg : public StackMsgArgument {
00070     friend class CommonStackMsgArgsDestroyTableNode;
00071     public:
00072         CellInfoIndArg();
00073
00074         static const CellInfoIndArg& Cast(const StackMsgArgument& arg);
00075         void SetCellId(const CellId& cell_id) { m_cell_id = cell_id; }
00076         const CellId& GetCellId() const { return m_cell_id; }
00077         void SetLai(const Lai& lai) { m_lai = lai; }
00078         const Lai& GetLai() const { return m_lai; }
00079         void SetGprsAvailable(BOOLEAN gprs_available) { m_gprs_available = gprs_available; }
00080         BOOLEAN IsGprsAvailable() const { return m_gprs_available; }
00081
00082         enum  {
00083             ID = 2181
00084             };
00085
00086     private:
00087
00088         static void Destroy(StackMsgArgument* arg) { delete ((CellInfoIndArg*) arg); }
00089
00090         CellId m_cell_id;
00091         Lai m_lai;
00092         BOOLEAN m_gprs_available;
00093
00094     };
00095
00096 // Inline definitions
00097 inline const CellInfoIndArg& CellInfoIndArg::Cast(const StackMsgArgument& arg) {
00098     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CellInfoIndArg!\n");
00099     return ((CellInfoIndArg &) arg);
00100 }
00101
00102
00103
00104 /*  ======================================================================
00105     Class MnInformationIndArg
00106     ====================================================================== */
00107
00110 class MnInformationIndArg : public StackMsgArgument {
00111     friend class CommonStackMsgArgsDestroyTableNode;
00112     public:
00113         MnInformationIndArg();
00114
00115         static const MnInformationIndArg& Cast(const StackMsgArgument& arg);
00116         void SetGsmService(const GsmService& gsm_service) { m_gsm_service = gsm_service; }
00117         const GsmService& GetGsmService() const { return m_gsm_service; }
00118         void SetNetworkNameLong(const WString& network_name_long) { m_network_name_long = network_name_long; }
00119         const WString& GetNetworkNameLong() const { return m_network_name_long; }
00120         void SetNetworkNameShort(const WString& network_name_short) { m_network_name_short = network_name_short; }
00121         const WString& GetNetworkNameShort() const { return m_network_name_short; }
00122         void SetNetworkNameLongAddCi(BOOLEAN network_name_long_add_ci) { m_network_name_long_add_ci = network_name_long_add_ci; }
00123         BOOLEAN IsNetworkNameLongAddCi() const { return m_network_name_long_add_ci; }
00124         void SetNetworkNameShortAddCi(BOOLEAN network_name_short_add_ci) { m_network_name_short_add_ci = network_name_short_add_ci; }
00125         BOOLEAN IsNetworkNameShortAddCi() const { return m_network_name_short_add_ci; }
00126         void SetTimeZonePresent(BOOLEAN time_zone_present) { m_time_zone_present = time_zone_present; }
00127         BOOLEAN IsTimeZonePresent() const { return m_time_zone_present; }
00128         void SetDateTimePresent(BOOLEAN date_time_present) { m_date_time_present = date_time_present; }
00129         BOOLEAN IsDateTimePresent() const { return m_date_time_present; }
00130         void SetDaylightSavingTimePresent(BOOLEAN daylight_saving_time_present) { m_daylight_saving_time_present = daylight_saving_time_present; }
00131         BOOLEAN IsDaylightSavingTimePresent() const { return m_daylight_saving_time_present; }
00132         void SetTimeZone(INT time_zone) { m_time_zone = time_zone; }
00133         INT GetTimeZone() const { return m_time_zone; }
00134         void SetDaylightSavingTime(UINT8 daylight_saving_time) { m_daylight_saving_time = daylight_saving_time; }
00135         UINT8 GetDaylightSavingTime() const { return m_daylight_saving_time; }
00136         void SetDateTime(const DateTime& date_time) { m_date_time = date_time; }
00137         const DateTime& GetDateTime() const { return m_date_time; }
00138         void SetLsaIdentifierPresent(BOOLEAN lsa_identifier_present) { m_lsa_identifier_present = lsa_identifier_present; }
00139         BOOLEAN IsLsaIdentifierPresent() const { return m_lsa_identifier_present; }
00140         void SetLsaIdentifier(const LsaIdentifier& lsa_identifier) { m_lsa_identifier = lsa_identifier; }
00141         const LsaIdentifier& GetLsaIdentifier() const { return m_lsa_identifier; }
00142
00143         enum  {
00144             ID = 2182
00145             };
00146
00147     private:
00148
00149         static void Destroy(StackMsgArgument* arg) { delete ((MnInformationIndArg*) arg); }
00150
00151         GsmService m_gsm_service;
00152         WString m_network_name_long;
00153         WString m_network_name_short;
00154         BOOLEAN m_network_name_long_add_ci;
00155         BOOLEAN m_network_name_short_add_ci;
00156         BOOLEAN m_time_zone_present;
00157         BOOLEAN m_date_time_present;
00158         BOOLEAN m_daylight_saving_time_present;
00159         INT m_time_zone;
00160         UINT8 m_daylight_saving_time;
00161         DateTime m_date_time;
00162         BOOLEAN m_lsa_identifier_present;
00163         LsaIdentifier m_lsa_identifier;
00164
00165     };
00166
00167 // Inline definitions
00168 inline const MnInformationIndArg& MnInformationIndArg::Cast(const StackMsgArgument& arg) {
00169     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MnInformationIndArg!\n");
00170     return ((MnInformationIndArg &) arg);
00171 }
00172
00173
00174
00175 /*  ======================================================================
00176     Class TestparamReportArg
00177     ====================================================================== */
00178
00180 class TestparamReportArg : public StackMsgArgument {
00181     friend class CommonStackMsgArgsDestroyTableNode;
00182     public:
00183         TestparamReportArg();
00184
00185         static const TestparamReportArg& Cast(const StackMsgArgument& arg);
00186         void SetReport(const TestparamReport& report) { m_report = report; }
00187         const TestparamReport& GetReport() const { return m_report; }
00188
00189         enum  {
00190             ID = 2183
00191             };
00192
00193     private:
00194
00195         static void Destroy(StackMsgArgument* arg) { delete ((TestparamReportArg*) arg); }
00196
00197         TestparamReport m_report;
00198
00199     };
00200
00201 // Inline definitions
00202 inline const TestparamReportArg& TestparamReportArg::Cast(const StackMsgArgument& arg) {
00203     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to TestparamReportArg!\n");
00204     return ((TestparamReportArg &) arg);
00205 }
00206
00207
00208
00209 /*  ======================================================================
00210     Class BandSelectionIndArg
00211     ====================================================================== */
00212
00214 class BandSelectionIndArg : public StackMsgArgument {
00215     friend class CommonStackMsgArgsDestroyTableNode;
00216     public:
00217         BandSelectionIndArg();
00218
00219         static const BandSelectionIndArg& Cast(const StackMsgArgument& arg);
00220         void SetConfirmed(BOOLEAN confirmed) { m_confirmed = confirmed; }
00221         BOOLEAN IsConfirmed() const { return m_confirmed; }
00222
00223         enum  {
00224             ID = 2184
00225             };
00226
00227     private:
00228
00229         static void Destroy(StackMsgArgument* arg) { delete ((BandSelectionIndArg*) arg); }
00230
00231         BOOLEAN m_confirmed;
00232
00233     };
00234
00235 // Inline definitions
00236 inline const BandSelectionIndArg& BandSelectionIndArg::Cast(const StackMsgArgument& arg) {
00237     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BandSelectionIndArg!\n");
00238     return ((BandSelectionIndArg &) arg);
00239 }
00240
00241
00242
00243 /*  ======================================================================
00244     Class HomezoneIndArg
00245     ====================================================================== */
00246
00248 class HomezoneIndArg : public StackMsgArgument {
00249     friend class CommonStackMsgArgsDestroyTableNode;
00250     public:
00251         HomezoneIndArg();
00252
00253         static const HomezoneIndArg& Cast(const StackMsgArgument& arg);
00254         void SetLineSelector(const LineSelector& line_selector) { m_line_selector = line_selector; }
00255         const LineSelector& GetLineSelector() const { return m_line_selector; }
00256         void SetIndicator(const HomezoneIndicator& indicator) { m_indicator = indicator; }
00257         const HomezoneIndicator& GetIndicator() const { return m_indicator; }
00258         void SetText(const HomezoneText& text) { m_text = text; }
00259         const HomezoneText& GetText() const { return m_text; }
00260
00261         enum  {
00262             ID = 2185
00263             };
00264
00265     private:
00266
00267         static void Destroy(StackMsgArgument* arg) { delete ((HomezoneIndArg*) arg); }
00268
00269         LineSelector m_line_selector;
00270         HomezoneIndicator m_indicator;
00271         HomezoneText m_text;
00272
00273     };
00274
00275 // Inline definitions
00276 inline const HomezoneIndArg& HomezoneIndArg::Cast(const StackMsgArgument& arg) {
00277     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to HomezoneIndArg!\n");
00278     return ((HomezoneIndArg &) arg);
00279 }
00280
00281
00282
00283 /*  ======================================================================
00284     Class MnTriggerReqArg
00285     ====================================================================== */
00286
00288 class MnTriggerReqArg : public StackMsgArgument {
00289     friend class CommonStackMsgArgsDestroyTableNode;
00290     public:
00291         MnTriggerReqArg(BOOLEAN flip_open);
00292         MnTriggerReqArg();
00293
00294         static const MnTriggerReqArg& Cast(const StackMsgArgument& arg);
00295         BOOLEAN IsFlipOpen() const { return m_flip_open; }
00296
00297         enum  {
00298             ID = 2186
00299             };
00300
00301     private:
00302
00303         static void Destroy(StackMsgArgument* arg) { delete ((MnTriggerReqArg*) arg); }
00304
00305         BOOLEAN m_flip_open;
00306
00307     };
00308
00309 // Inline definitions
00310 inline const MnTriggerReqArg& MnTriggerReqArg::Cast(const StackMsgArgument& arg) {
00311     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MnTriggerReqArg!\n");
00312     return ((MnTriggerReqArg &) arg);
00313 }
00314
00315
00316
00317 /*  ======================================================================
00318     Class MnNetworkSearchModeReqArg
00319     ====================================================================== */
00320
00322 class MnNetworkSearchModeReqArg : public StackMsgArgument {
00323     friend class CommonStackMsgArgsDestroyTableNode;
00324     public:
00325         MnNetworkSearchModeReqArg(const NetworkSearchMode& network_search_mode);
00326         MnNetworkSearchModeReqArg();
00327
00328         static const MnNetworkSearchModeReqArg& Cast(const StackMsgArgument& arg);
00329         const NetworkSearchMode& GetNetworkSearchMode() const { return m_network_search_mode; }
00330
00331         enum  {
00332             ID = 2187
00333             };
00334
00335     private:
00336
00337         static void Destroy(StackMsgArgument* arg) { delete ((MnNetworkSearchModeReqArg*) arg); }
00338
00339         NetworkSearchMode m_network_search_mode;
00340
00341     };
00342
00343 // Inline definitions
00344 inline const MnNetworkSearchModeReqArg& MnNetworkSearchModeReqArg::Cast(const StackMsgArgument& arg) {
00345     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MnNetworkSearchModeReqArg!\n");
00346     return ((MnNetworkSearchModeReqArg &) arg);
00347 }
00348
00349
00350 #endif // Apc_NetworkStackMsgArgs_hpp
00351
Generated on Tue Jan 24 14:46:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/NetworkTypes.cpp File Reference

Apc/NetworkTypes.cpp File Reference

#include "Apc/PreComp.hpp"
#include "NetworkTypes.hpp"
#include <Apc/StackWrapper.hpp>

Include dependency graph for NetworkTypes.cpp:

Generated on Tue Jan 24 16:57:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/NetworkTypes.hpp File Reference

Apc/NetworkTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for NetworkTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | AckNackCnt
struct | AckNackParamList
struct | AckNackTestparamCnt
struct | AsTestparamDatabase
class | BcdPlmn
struct | BlerTrchInfo
struct | BlerTrchInfoList
struct | CellChangeCnts
struct | CellParam
struct | CiTestParam
struct | CiTestParamList
struct | COverIList
struct | DchReport
struct | EquivPlmnLists
struct | GmmParam
struct | GprsParam
struct | GsmBandList
struct | HomezoneText
struct | L1Param
struct | Lai
struct | LsaIdentifier
struct | LsaIdentifierArray
struct | MmCellChangeCnts
struct | MmCoordParam
struct | MmcsParam
struct | MultiSlotMode
struct | NeighbourCell
struct | NeighbourCellList
class | Plmn
struct | RrcParam
struct | RrcProcessState
struct | RrParam
struct | TestparamReport
struct | TimeZoneAndTime
struct | UmtsCellList
struct | UmtsMeasEvalParam
struct | UmtsMeasIdParam
struct | UmtsNcellParam
struct | UmtsNcellParamList
struct | UmtsRrcScellParam
struct | Uplmn
struct | UsimPlmn
struct | UsimPlmnList

Defines

#define | Apc_NetworkTypes_hpp
#define | InvalidBcdPlmn BcdPlmn()
#define | InvalidPlmn Plmn()
#define | USIMAP_PLMN_LIST_LEN 8

Typedefs

typedef UINT16 | BcdMcc
typedef UINT8 | BcdMnc
typedef UINT32 | CellId
typedef UINT16 | DlSc
typedef UINT16 | Lac
typedef UINT16 | Mcc
typedef UINT16 | Mnc
typedef INT | PlmnPlacementIndicator
typedef UINT16 | Uarfcn

Enumerations

enum | BdnState { BdnOn = MN_BDN_ON, BdnOff = MN_BDN_OFF, BdnNotPossible = MN_BDN_NOT_POSSIBLE }
BDN status (T_MN_BDN_IND_STATE). More...
enum EmCellType {
ActiveSet = EM_ACTIVE_SET, VirtualActiveSet = EM_VIRTUAL_ACTIVE_SET, Monitored = EM_MONITORED, Detected = EM_DETECTED,
UmtsCell = EM_UMTS_CELL, UmtsRanked = EM_UMTS_RANKED, UmtsNotRanked = EM_UMTS_NOT_RANKED
}
enum | EmControlRetValue { EmcFailed = 2, EmcSuccess = 1, EmcUnsuported = 0 }
enum | EmEventType { UrrcParamReq = EM_URRC_TESTPARAM_REQ, ReportingTimer = EM_REPORTING_TIMER, UrrcTestCountReq = EM_URRC_TEST_COUNT_REQ }
enum EmRankingStatus {
CellSuitable = EM_CELL_SUITABLE, NotMeasured = EM_NOT_MEASURED, CellBarred = EM_CELL_BARRED, WrongPlmn = EM_WRONG_PLMN,
HcsCriteriaPrio = EM_HCS_CRITERIA_PRIO, HcsHValue = EM_HCS_H_VALUE, SValue = EM_S_VALUE
}
enum | EngineeringModeControl { EmcLockSCell, EmcUnlockSCell, EmcTrigger3g2gHandover }
enum | FdnState { FdnOn = MN_FDN_ON, FdnOff = MN_FDN_OFF, FdnNotPossible = MN_FDN_NOT_POSSIBLE }
FDN status (T_MN_FDN_IND_STATE). More...
enum GprsClass {
GprsClassA = GPRS_CLASS_A, GprsClassB = GPRS_CLASS_B, GprsClassC = GPRS_CLASS_C, GprsClassCg = GPRS_CLASS_CG,
GprsClassCc = GPRS_CLASS_CC, GprsNoClass = GPRS_NO_CLASS, InvalidGprsClass = 0xff
}
user cause (ms.h: T_MS_CLASS) More...
enum GsmBand {
GsmBand900 = MS_GSM900, GsmBand900P = MS_GSM900_P, GsmBand900E = MS_GSM900_E, GsmBand1800 = MS_GSM1800,
GsmBand1900 = MS_GSM1900, GsmBand850 = MS_GSM850, GsmBand450 = MS_GSM450, GsmBand480 = MS_GSM480,
GsmBand900R = MS_GSM900_R, GsmMultiband = MS_MULTIBAND, InvalidGsmBand = INVALID_BAND
}
GsmBand (T_GSM_BAND). More...
enum GsmService {
CircuitSwitched = CIRCUIT_SWITCHED, PacketSwitched = PACKET_SWITCHED, CircuitSwitchedPreferred = CIRCUIT_SWITCHED_PREFERED, PacketSwitchedPreferred = PACKET_SWITCHED_PREFERED,
InvalidGsmService
}
GSM service (ms.h: T_GSM_SERVICE). More...
enum | HomezoneIndicator { NoTextNoIcon = ZONAL_INDICATOR_OFF, WithTextWithIcon = ZONAL_INDICATOR_ON_WITH_TEXT_AND_ICON, WithTextNoIcon = ZONAL_INDICATOR_ON_WITH_TEXT_NO_ICON, NoTextWithIcon = ZONAL_INDICATOR_ON_WITH_ICON_NO_TEXT }
enum MmRrReason {
No_cause = MMRR_NO_CAUSE, No_carrier = NO_CARRIER, No_cell = NO_CELL, Invalid_plmn = INVALID_PLMN,
Handover = HANDOVER, Chn_realase = CHN_RELEASE, Link_estab_fail = LINK_ESTAB_FAILURE, Ra_fail = RA_FAILURE,
Link_abortion = LINK_ABORTION, L2_l1_fail = L2_L1_FAILURE, Hplmn_search_fail = HPLMN_SEARCH_FAIL, Imm_ass_reject = IMM_ASS_REJECT,
Abnormal_release = ABNORMAL_RELEASE, Access_not_allowed = ACCESS_NOT_ALLOWED, MmRrcNormalEvent = MMRRC_NORMAL_EVENT, MmRrcNoCause = MMRRC_NO_CAUSE,
MmRrcPreEmtiveRelease = MMRRC_PRE_EMPTIVE_RELEASE, MmRrcCongestion = MMRRC_CONGESTION, MmRrcReEstablishmentReject = MMRRC_RE_ESTABLISHMENT_REJECT, MmRrcDirectedSigconnReEstablishment = MMRRC_DIRECTED_SIGCONN_RE_ESTABLISHMENT,
MmRrcUserInactivity = MMRRC_USER_INACTIVITY, MmRrcConnEstablished = MMRRC_CONN_ESTABLISHED, MmRrcConnRelease = MMRRC_CONN_RELEASE, MmRrcInterratHandover = MMRRC_INTERRAT_HANDOVER,
MmRrcCellBarred = MMRRC_CELL_BARRED, MmRrcnactive = INACTIVE, InvalidMmRrReason = 0xff
}
enum | MultiSlotCapability { DefaultMultiSlotCapability = NO_MULTI_SLOT_CAPABILITY }
enum NetType {
Gsm900 = NET_GSM900, Gsm1800 = NET_GSM1800, Gsm900_1800 = NET_GSM900_1800, Gsm1900 = NET_GSM1900,
Gsm900_1900 = NET_GSM900_1900, Gsm1800_1900 = NET_GSM1800_1900, Gsm900_1800_1900, ThirdGeneration
}
enum NetworkOpMode {
NoGprsCell = NO_GPRS_CELL, NwOpMode1 = NW_OP_MODE_1, NwOpMode2 = NW_OP_MODE_2, NwOpMode3 = NW_OP_MODE_3,
InvalidOpMode = 0xff
}
NetworkOpMode (T_NETWORK_OP_MODE). More...
enum | NetworkSearchMode { NormalSearchMode = NORMAL_SEARCH_MODE, FastSearchMode = FAST_SEARCH_MODE, InvalidSearchMode = 0xff }
network seach mode (ms.h: T_NETWORK_SEARCH_MODE) More...
enum | PlmnForbiddenIndicator { PlmnNotForbidden = PLMN_NOT_FORBIDDEN, PlmnForbidden = PLMN_FORBIDDEN }
plmn forbidden indicator (ms.h: T_FORBIDDEN_INDICATOR) More...
enum | PlmnIndicator { PlmnNotProvided = PLMN_NOT_PROVIDED, PlmnProvided = PLMN_PROVIDED }
plmn indicator (ms.h: T_PLMN_INDICATOR) More...
enum | PlmnScanMode { PlmnScanOff = PLMN_LIST_OFF, PlmnListScan = PLMN_LIST }
plmn list mode (ms.h: T_PLMN_LIST_MODE) More...
enum | PowerSavingMode { PowerSavingMode1 = POWER_SAVING_MODE_1 }
enum ProcessSource {
PsMmi = MN_MMI, PsAtc = MN_ATC, PsNet = MN_NET, PsOm = MN_OM,
PsInvalid
}
user cause (ms.h: T_SOURCE) More...
enum | RadioAccessTechnology { RatNotAvailable = RAT_NOT_AVAILABLE, RatGsm = RAT_GSM, RatUmts = RAT_UMTS }
enum | Rat { Gsm = 0, Fdd = 1 }
enum | RatChangeMode { RatChangeModeGsm = RAT_CHANGE_MODE_GSM, RatChangeModeUmts = RAT_CHANGE_MODE_UMTS, RatChangeModeDual = RAT_CHANGE_MODE_DUAL, InvalidRatChangeMode }
TODO remove comment for new stack. More...
enum | RegisterMode { Automatic = AUTOMATIC_MODE, Manual = MANUAL_MODE, RegisterModeUnavailable }
registration mode (ms.h: T_OPERATING_MODE) More...
enum RegisterRejectCause {
RrcNotRegistered = RC_NOT_REGISTERED, RrcInvalidSim = RC_INVALID_SIM, RrcNRegReq = RC_NREG_REQ, RrcNoCell = RC_NO_CELL,
RrcNoCarrier = RC_NO_CARRIER, RrcPlmnSearch = RC_PLMN_SEARCH, RrcPlmnSearchEnded = RC_PLMN_SEARCH_ENDED, RrcAuthFailure = RC_AUTH_FAILURE,
RrcPowerDown = RC_POWER_DOWN, RrcForbPlmn = RC_FORB_PLMN, RrcForbLai = RC_FORB_LAI, RrcDetached = RC_DETACHED,
RrcDisabled = RC_DISABLED, RrcInvalidParameter = RC_INVALID_PARAMETER, RrcRejByNetwork = RC_REJ_BY_NETWORK, RrcInternalFailure = RC_INTERNAL_FAILURE,
RrcAttachTempBarred = RC_ATTACH_TEMP_BARRED, RrcNoCause = RC_NO_CAUSE, RrcAttachNotAllowed = RC_ATTACH_NOT_ALLOWED
}
registration reject cause (ms.h: T_REG_REJECT_CAUSE) More...
enum RegisterStatus {
NormalService = NORMAL_SERVICE, RegistrationFailure = REGISTRATION_FAILURE, LimitedService = LIMITED_SERVICE, NoService = NO_SERVICE,
AtNotRegistered = AT_NOT_REGISTERED, ServiceDisabled = SERVICE_DISABLED, ServiceDetached = SERVICE_DETACHED
}
registration status (ms.h: T_REGISTRATION_STATE) More...
enum RegState {
Regst_user_attach_pending = REGST_USER_ATTACH_PENDING, Regst_user_detach_pending = REGST_USER_DETACH_PENDING, Regst_ps_suspended = REGST_PS_SUSPENDED, Regst_cs_connection = REGST_CS_CONNECTION,
Regst_indep_registration = REGST_INDEP_REGISTRATION, Regst_plmn_selection = REGST_PLMN_SELECTION, Regst_search_for_network = REGST_SEARCH_FOR_NETWORK, Invalid_reg_state = 0xff
}
enum RrCellReselReason {
ReselPlmnChange = RESEL_PLMN_CHANGE, MonReselServCellNotSuitable = MON_RESEL_SERV_CELL_NOT_SUITABLE, ReselBetterC2C32 = RESEL_BETTER_C2_C32, ReselDownlinkFail = RESEL_DOWNLINK_FAIL,
ReselRaFailure = RESEL_RA_FAILURE, ReselSiReceiptFailure = RESEL_SI_RECEIPT_FAILURE, ReselC1LessNull = RESEL_C1_LESS_NULL, ReselCallReestTimeout = RESEL_CALL_REEST_TIMEOUT,
ReselAbnormalResel = RESEL_ABNORMAL_RESEL, ReselCellChangeOrder = RESEL_CELL_CHANGE_ORDER, ReselNotOccurred = RESEL_NOT_OCCURRED
}
enum | RrMode { RrModeUmts = 0, RrModeGsm = 1 }
enum UserCause {
UcPowerDown = POWER_DOWN, UcInvalidSim = SIM_DETACH, UcNotAllowed = NOT_ALLOWED, UcAbortByUser = ABORT_BY_USER,
UcNotPossible = NOT_POSSIBLE, UcDisableService = DISABLE_SERVICE, UcDetachService = DETACH_SERVICE, UcAttachService = ATTACH_SERVICE,
UcEnableService = ENABLE_SERVICE, UcUserReselection = USER_RESELECTION
}
user cause (ms.h: T_USER_CAUSE) More...

Functions

UINT16 | TransformRatToUsimAct (RadioAccessTechnology rat)
RadioAccessTechnology | TransformUsimActToRat (UINT16 act)

Variables

const INT | c_maxno_usim_plmns = USIMAP_PLMN_LIST_LEN
const BcdMcc | InvalidBcdMcc = 0xffff
const BcdMnc | InvalidBcdMnc = 0xff
const CellId | InvalidCellId = 0xffff
const Lac | InvalidLac = 0xffff
const Mcc | InvalidMcc = 0xffff
const Mnc | InvalidMnc = 0xffff

Define Documentation

#define Apc_NetworkTypes_hpp

#define InvalidBcdPlmn BcdPlmn()

#define InvalidPlmn Plmn()

#define USIMAP_PLMN_LIST_LEN 8

Typedef Documentation

typedef UINT16 BcdMcc

typedef UINT8 BcdMnc

typedef UINT32 CellId

typedef UINT16 DlSc

typedef UINT16 Lac

typedef UINT16 Mcc

typedef UINT16 Mnc

typedef INT PlmnPlacementIndicator

typedef UINT16 Uarfcn

Enumeration Type Documentation

enum BdnState

BDN status (T_MN_BDN_IND_STATE).

Enumerator:
BdnOn
BdnOff
BdnNotPossible

enum EmCellType

Enumerator:
ActiveSet
VirtualActiveSet
Monitored
Detected
UmtsCell
UmtsRanked
UmtsNotRanked

enum EmControlRetValue

Enumerator:
EmcFailed
EmcSuccess
EmcUnsuported

enum EmEventType

Enumerator:
UrrcParamReq
ReportingTimer
UrrcTestCountReq

enum EmRankingStatus

Enumerator:
CellSuitable
NotMeasured
CellBarred
WrongPlmn
HcsCriteriaPrio
HcsHValue
SValue

enum EngineeringModeControl

Enumerator:
EmcLockSCell
EmcUnlockSCell
EmcTrigger3g2gHandover

enum FdnState

FDN status (T_MN_FDN_IND_STATE).

Enumerator:
FdnOn
FdnOff
FdnNotPossible

enum GprsClass

user cause (ms.h: T_MS_CLASS)

Enumerator:
GprsClassA
GprsClassB
GprsClassC
GprsClassCg
GprsClassCc
GprsNoClass
InvalidGprsClass

enum GsmBand

GsmBand (T_GSM_BAND).

Enumerator:
GsmBand900
GsmBand900P
GsmBand900E
GsmBand1800
GsmBand1900
GsmBand850
GsmBand450
GsmBand480
GsmBand900R
GsmMultiband
InvalidGsmBand

enum GsmService

GSM service (ms.h: T_GSM_SERVICE).

Enumerator:
CircuitSwitched
PacketSwitched
CircuitSwitchedPreferred
PacketSwitchedPreferred
InvalidGsmService

enum HomezoneIndicator

Enumerator:
NoTextNoIcon
WithTextWithIcon
WithTextNoIcon
NoTextWithIcon

enum MmRrReason

Enumerator:
No_cause
No_carrier
No_cell
Invalid_plmn
Handover
Chn_realase
Link_estab_fail
Ra_fail
Link_abortion
L2_l1_fail
Hplmn_search_fail
Imm_ass_reject
Abnormal_release
Access_not_allowed
MmRrcNormalEvent
MmRrcNoCause
MmRrcPreEmtiveRelease
MmRrcCongestion
MmRrcReEstablishmentReject
MmRrcDirectedSigconnReEstablishment
MmRrcUserInactivity
MmRrcConnEstablished
MmRrcConnRelease
MmRrcInterratHandover
MmRrcCellBarred
MmRrcnactive
InvalidMmRrReason

enum MultiSlotCapability

Enumerator:
DefaultMultiSlotCapability

enum NetType

Enumerator:
Gsm900
Gsm1800
Gsm900_1800
Gsm1900
Gsm900_1900
Gsm1800_1900
Gsm900_1800_1900
ThirdGeneration

enum NetworkOpMode

NetworkOpMode (T_NETWORK_OP_MODE).

Enumerator:
NoGprsCell
NwOpMode1
NwOpMode2
NwOpMode3
InvalidOpMode

enum NetworkSearchMode

network seach mode (ms.h: T_NETWORK_SEARCH_MODE)

Enumerator:
NormalSearchMode
FastSearchMode
InvalidSearchMode

enum PlmnForbiddenIndicator

plmn forbidden indicator (ms.h: T_FORBIDDEN_INDICATOR)

Enumerator:
PlmnNotForbidden
PlmnForbidden

enum PlmnIndicator

plmn indicator (ms.h: T_PLMN_INDICATOR)

Enumerator:
PlmnNotProvided
PlmnProvided

enum PlmnScanMode

plmn list mode (ms.h: T_PLMN_LIST_MODE)

Enumerator:
PlmnScanOff
PlmnListScan

enum PowerSavingMode

Enumerator:
PowerSavingMode1

enum ProcessSource

user cause (ms.h: T_SOURCE)

Enumerator:
PsMmi
PsAtc
PsNet
PsOm
PsInvalid

enum RadioAccessTechnology

Enumerator:
RatNotAvailable
RatGsm
RatUmts

enum Rat

Enumerator:
Gsm
Fdd

enum RatChangeMode

TODO remove comment for new stack.

Enumerator:
RatChangeModeGsm
RatChangeModeUmts
RatChangeModeDual
InvalidRatChangeMode

enum RegisterMode

registration mode (ms.h: T_OPERATING_MODE)

Enumerator:
Automatic
Manual
RegisterModeUnavailable

enum RegisterRejectCause

registration reject cause (ms.h: T_REG_REJECT_CAUSE)

Enumerator:
RrcNotRegistered
RrcInvalidSim
RrcNRegReq
RrcNoCell
RrcNoCarrier
RrcPlmnSearch
RrcPlmnSearchEnded
RrcAuthFailure
RrcPowerDown
RrcForbPlmn
RrcForbLai
RrcDetached
RrcDisabled
RrcInvalidParameter
RrcRejByNetwork
RrcInternalFailure
RrcAttachTempBarred
RrcNoCause
RrcAttachNotAllowed

enum RegisterStatus

registration status (ms.h: T_REGISTRATION_STATE)

Enumerator:
NormalService
RegistrationFailure
LimitedService
NoService
AtNotRegistered
ServiceDisabled
ServiceDetached

enum RegState

Enumerator:
Regst_user_attach_pending
Regst_user_detach_pending
Regst_ps_suspended
Regst_cs_connection
Regst_indep_registration
Regst_plmn_selection
Regst_search_for_network
Invalid_reg_state

enum RrCellReselReason

Enumerator:
ReselPlmnChange
MonReselServCellNotSuitable
ReselBetterC2C32
ReselDownlinkFail
ReselRaFailure
ReselSiReceiptFailure
ReselC1LessNull
ReselCallReestTimeout
ReselAbnormalResel
ReselCellChangeOrder
ReselNotOccurred

enum RrMode

Enumerator:
RrModeUmts
RrModeGsm

enum UserCause

user cause (ms.h: T_USER_CAUSE)

Enumerator:
UcPowerDown
UcInvalidSim
UcNotAllowed
UcAbortByUser
UcNotPossible
UcDisableService
UcDetachService
UcAttachService
UcEnableService
UcUserReselection

Function Documentation

UINT16 TransformRatToUsimAct ( RadioAccessTechnology rat ) [inline]

RadioAccessTechnology TransformUsimActToRat ( UINT16 act ) [inline]

Variable Documentation

const INT c_maxno_usim_plmns = USIMAP_PLMN_LIST_LEN

const BcdMcc InvalidBcdMcc = 0xffff

const BcdMnc InvalidBcdMnc = 0xff

const CellId InvalidCellId = 0xffff

const Lac InvalidLac = 0xffff

const Mcc InvalidMcc = 0xffff

const Mnc InvalidMnc = 0xffff

Generated on Tue Jan 24 16:57:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/NetworkTypes.hpp Source File

Apc/NetworkTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_NetworkTypes_hpp)
00009 #define Apc_NetworkTypes_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Apc/SignalTypes.hpp>
00013
00015 enum GsmService {
00016     CircuitSwitched = CIRCUIT_SWITCHED,
00017     PacketSwitched = PACKET_SWITCHED,
00018     CircuitSwitchedPreferred = CIRCUIT_SWITCHED_PREFERED,
00019     PacketSwitchedPreferred = PACKET_SWITCHED_PREFERED,
00020     InvalidGsmService
00021 };
00022
00024 enum RegisterStatus {
00025     NormalService       = NORMAL_SERVICE,       // able to place calls
00026     RegistrationFailure = REGISTRATION_FAILURE, // able to place calls, registration is needed before
00027     LimitedService      = LIMITED_SERVICE,      // emergency calls only
00028     NoService           = NO_SERVICE,           // no calls allowed (no network found)
00029     AtNotRegistered     = AT_NOT_REGISTERED,    // no calls allowed
00030     ServiceDisabled     = SERVICE_DISABLED,     // no PLMN search will be performed. equals to NoService
00031     ServiceDetached     = SERVICE_DETACHED,     // no PLMN search will be performed
00032 };
00033
00035 enum RegisterRejectCause {
00036     RrcNotRegistered      = RC_NOT_REGISTERED,    // not registered
00037     RrcInvalidSim         = RC_INVALID_SIM,       // sim invalid
00038     RrcNRegReq            = RC_NREG_REQ,          // deregistration (AT)
00039     RrcNoCell             = RC_NO_CELL,
00040     RrcNoCarrier          = RC_NO_CARRIER,
00041     RrcPlmnSearch         = RC_PLMN_SEARCH,
00042     RrcPlmnSearchEnded    = RC_PLMN_SEARCH_ENDED,
00043     RrcAuthFailure        = RC_AUTH_FAILURE,
00044     RrcPowerDown          = RC_POWER_DOWN,
00045     RrcForbPlmn           = RC_FORB_PLMN,
00046     RrcForbLai            = RC_FORB_LAI,
00047     RrcDetached           = RC_DETACHED,
00048     RrcDisabled           = RC_DISABLED,
00049     RrcInvalidParameter   = RC_INVALID_PARAMETER,
00050     RrcRejByNetwork       = RC_REJ_BY_NETWORK,
00051     RrcInternalFailure    = RC_INTERNAL_FAILURE,
00052     RrcAttachTempBarred   = RC_ATTACH_TEMP_BARRED,
00053     RrcNoCause            = RC_NO_CAUSE,        // initialization value (no cause)
00054 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00055     RrcAttachNotAllowed   = RC_ATTACH_NOT_ALLOWED,
00056 #else
00057     RrcAttachNotAllowed
00058 #endif
00059 };
00060
00062 enum UserCause {
00063     UcPowerDown       = POWER_DOWN,
00064     UcInvalidSim      = SIM_DETACH,
00065     UcNotAllowed      = NOT_ALLOWED,
00066     UcAbortByUser     = ABORT_BY_USER,
00067     UcNotPossible     = NOT_POSSIBLE,
00068     UcDisableService  = DISABLE_SERVICE,
00069     UcDetachService   = DETACH_SERVICE,
00070     UcAttachService   = ATTACH_SERVICE,
00071     UcEnableService   = ENABLE_SERVICE,
00072     UcUserReselection = USER_RESELECTION,
00073 };
00074
00076 enum PlmnScanMode {
00077     PlmnScanOff     = PLMN_LIST_OFF,
00078     PlmnListScan    = PLMN_LIST,
00079 };
00080
00081
00083 enum ProcessSource {
00084     PsMmi = MN_MMI,
00085     PsAtc = MN_ATC,
00086     PsNet = MN_NET,
00087     PsOm  = MN_OM,
00088     PsInvalid
00089 };
00090
00092 enum FdnState {
00093     FdnOn               = MN_FDN_ON,    // FDN activated
00094     FdnOff              = MN_FDN_OFF,   // FDN deactivated
00095     FdnNotPossible      = MN_FDN_NOT_POSSIBLE,  // No service on SIM
00096 };
00097
00099 enum BdnState {
00100     BdnOn               = MN_BDN_ON,    // BDN activated
00101     BdnOff              = MN_BDN_OFF,   // BDN deactivated
00102     BdnNotPossible      = MN_BDN_NOT_POSSIBLE,  // No service on SIM
00103 };
00104
00105
00106 /**************************************************************************/
00107 /*                                     Homezone                           */
00108 /**************************************************************************/
00109
00110
00111
00112 /* T_ZONAL_INDICATOR */
00113 enum HomezoneIndicator {
00114     NoTextNoIcon = ZONAL_INDICATOR_OFF,
00115     WithTextWithIcon = ZONAL_INDICATOR_ON_WITH_TEXT_AND_ICON,
00116     WithTextNoIcon = ZONAL_INDICATOR_ON_WITH_TEXT_NO_ICON,
00117     NoTextWithIcon = ZONAL_INDICATOR_ON_WITH_ICON_NO_TEXT,
00118 };
00119
00120
00121 /* T_ZONAL_TEXT */
00122 struct HomezoneText {
00123     UINT8 length;
00124     UINT8 label[15];
00125 };
00126
00127
00128 /**************************************************************************/
00129 /*                     TimeZoneAndTime  T_TIME_ZONE_AND_TIME                           */
00130 /**************************************************************************/
00131
00132 /* T_TIME_ZONE_AND_TIME */
00133 struct TimeZoneAndTime {
00134
00135     UINT8 A[SDL_INTEGER_LIT(6)+1];
00136 };
00137
00138
00139 /**************************************************************************/
00140 /*                     LsaIdentifier  T_LSA_IDENTIFIER                             */
00141 /**************************************************************************/
00142
00143
00144 typedef struct {
00145     byte  A[SDL_INTEGER_LIT(2)+1];
00146 } LsaIdentifierArray;
00147
00148
00149 /* T_LSA_IDENTIFIER */
00150 struct LsaIdentifier {
00151     SDL_Integer  length;
00152     LsaIdentifierArray  lsa_id;
00153 };
00154
00155
00156 enum MultiSlotCapability {
00157     DefaultMultiSlotCapability = NO_MULTI_SLOT_CAPABILITY    //0
00158     //Allowed values for HSCSD: 0..18
00159     //Allowed values for GPRS : 0..29
00160     //For currently allowed number of slots see oms_conf.h
00161 };
00162
00163 /*----------------------------------------------------------------------------*/
00164 /*               struct MultiSlot                                             */
00165 /*              (T_MULTI_SLOT, /ms-interface-src/pr/ms_signals_om.pr,69,11)   */
00166 /*----------------------------------------------------------------------------*/
00167
00168 struct MultiSlotMode {
00169     UINT8   multi_slot_class;
00170
00171     MultiSlotMode():
00172     multi_slot_class(0xff)
00173     {}
00174     MultiSlotMode operator =(T_MULTI_SLOT multi_slot);
00175 };//MultiSlotMode
00176
00177  /* -------------------------------------------------------------------- */
00178 /* -------- T _ M U L T I _ S L O T _ C L A S S ----------------------- */
00179 /* -------------------------------------------------------------------- */
00180 /*
00181
00182  Definitions for the Multi Slot Class as defined in GSM 05.02.
00183
00184
00185   SYNTYPE T_MULTI_SLOT_CLASS #NAME 'T_MULTI_SLOT_CLASS' = Byte
00186   ENDSYNTYPE;
00187
00188   Allowed values for HSCSD: 0..18
00189   Allowed values for GPRS : 0..29
00190
00191   SYNONYM NO_MULTI_SLOT_CAPABILITY #NAME 'NO_MULTI_SLOT_CAPABILITY' Integer = 0;
00192
00193  */
00194
00195 //T_MMRR_CAUSE in /vobs/ms-hosttest/mi/src/../../../stack-interface/globals/cause.pr,212,9)
00196 enum MmRrReason {
00197     //GSM
00198     No_cause =           MMRR_NO_CAUSE,
00199     No_carrier =         NO_CARRIER,
00200     No_cell =            NO_CELL,
00201     Invalid_plmn =       INVALID_PLMN ,
00202     Handover =           HANDOVER,
00203     Chn_realase =        CHN_RELEASE,
00204     Link_estab_fail =    LINK_ESTAB_FAILURE,
00205     Ra_fail =            RA_FAILURE,
00206     Link_abortion =      LINK_ABORTION,
00207     L2_l1_fail =         L2_L1_FAILURE,
00208     Hplmn_search_fail =  HPLMN_SEARCH_FAIL,
00209     Imm_ass_reject =     IMM_ASS_REJECT,
00210     Abnormal_release =   ABNORMAL_RELEASE,
00211     Access_not_allowed = ACCESS_NOT_ALLOWED,
00212
00213 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00214     MmRrcNormalEvent                    = MMRRC_NORMAL_EVENT,                       /*#NAME 'MMRRC_NORMAL_EVENT' */
00215     MmRrcNoCause                        = MMRRC_NO_CAUSE,                           /*#NAME 'MMRRC_NO_CAUSE'*/
00216     MmRrcPreEmtiveRelease               = MMRRC_PRE_EMPTIVE_RELEASE,                /*#NAME 'MMRRC_PRE_EMPTIVE_RELEASE' */
00217     MmRrcCongestion                     = MMRRC_CONGESTION,                         /*#NAME 'MMRRC_CONGESTION' */
00218     MmRrcReEstablishmentReject          = MMRRC_RE_ESTABLISHMENT_REJECT,            /*#NAME 'MMRRC_RE_ESTABLISHMENT_REJECT' */
00219     MmRrcDirectedSigconnReEstablishment = MMRRC_DIRECTED_SIGCONN_RE_ESTABLISHMENT,  /*#NAME 'MMRRC_DIRECTED_SIGCONN_RE_ESTABLISHMENT' */
00220     MmRrcUserInactivity                 = MMRRC_USER_INACTIVITY,                    /*#NAME 'MMRRC_USER_INACTIVITY' */
00221     MmRrcConnEstablished                = MMRRC_CONN_ESTABLISHED,                   /*#NAME 'MMRRC_CONN_ESTABLISHED' */
00222     MmRrcConnRelease                    = MMRRC_CONN_RELEASE,                       /*#NAME 'MMRRC_CONN_RELEASE' */
00223     MmRrcInterratHandover               = MMRRC_INTERRAT_HANDOVER,                  /*#NAME 'MMRRC_INTERRAT_HANDOVER' */
00224     MmRrcCellBarred                     = MMRRC_CELL_BARRED,                        /*#NAME 'MMRRC_CELL_BARRED' */
00225     MmRrcnactive                        = INACTIVE,                                 /*#NAME 'INACTIVE' */
00226 #else
00227     MmRrcNormalEvent,
00228     MmRrcNoCause,
00229     MmRrcPreEmtiveRelease,
00230     MmRrcCongestion,
00231     MmRrcReEstablishmentReject,
00232     MmRrcDirectedSigconnReEstablishment,
00233     MmRrcUserInactivity,
00234     MmRrcConnEstablished,
00235     MmRrcConnRelease,
00236     MmRrcInterratHandover,
00237     MmRrcCellBarred,
00238     MmRrcInactive,
00239 #endif
00240     InvalidMmRrReason = 0xff
00241 };//MmRrReason
00242
00243
00244 //T_DL_SC  in vobs/ms-hosttest/mi/src/../../../stack-interface/globals/radio_res.pr,66,11)
00245 typedef UINT16 DlSc;    // = ushort
00246
00247 //T_UARFCN in /vobs/ms-hosttest/mi/src/../../../stack-interface/globals/radio_res.pr,77,11
00248 typedef UINT16 Uarfcn;    //= ushort
00249
00250 //T_MMRR_CAUSE in /vobs/ms-hosttest/mi/src/../../../stack-interface/globals/cause.pr,212,9)
00251 //enum MmrrCause {
00252 //};
00253
00254 /*  ========================================================================
00255                                   Rat
00256     ========================================================================*/
00258 enum Rat {
00259     Gsm = 0,
00260     Fdd = 1
00261 };
00262
00263 /*  ========================================================================
00264                                   RrMode
00265     ========================================================================*/
00267 enum RrMode {
00268     RrModeUmts = 0, //rat_umts,
00269     RrModeGsm  = 1  //rat_gsm
00270 };
00271
00272 /*----------------------------------------------------------------------------*/
00273 /*                  UMTS enum's                                               */
00274 /*----------------------------------------------------------------------------*/
00275 //T_EM_EVENT /vobs/ms-hosttest/mi/src/../../../stack-interface/api/umts_testparam.pr,41,9
00276 enum EmEventType {
00277 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00278     UrrcParamReq        =   EM_URRC_TESTPARAM_REQ,   /*#NAME 'EM_URRC_TESTPARAM_REQ'*/
00279     ReportingTimer      =   EM_REPORTING_TIMER,      /*#NAME 'EM_REPORTING_TIMER'*/
00280     UrrcTestCountReq    =   EM_URRC_TEST_COUNT_REQ   /*#NAME 'EM_URRC_TEST_COUNT_REQ'*/
00281 #else
00282     UrrcParamReq,
00283     ReportingTimer,
00284     UrrcTestCountReq
00285 #endif
00286 };//EmEvent
00287
00288 //T_CELL_TYPE in /vobs/ms-hosttest/mi/src/../../../stack-interface/api/umts_testparam.pr,307,9
00289 enum EmCellType {
00290 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00291     ActiveSet           =   EM_ACTIVE_SET,              /* Cell belongs to the Active set (CELL_DCH)*/
00292     VirtualActiveSet    =   EM_VIRTUAL_ACTIVE_SET,      /* Cell belongs to the Virtual Active set (CELL_DCH)*/
00293     Monitored           =   EM_MONITORED,               /* Cells in the SIB 11/12 "BA"-list */
00294     Detected            =   EM_DETECTED,                /* Cell is a detected UMTS cell (CELL_DCH) */
00295     UmtsCell            =   EM_UMTS_CELL,               /* Cell is a UMTS neighbour cell in GSM mode */
00296     UmtsRanked          =   EM_UMTS_RANKED,             /* Cell is a UMTS neighbour cell (all states but CELL_DCH) */
00297     UmtsNotRanked       =   EM_UMTS_NOT_RANKED          /* Cell is a UMTS neighbour cell (all states but CELL_DCH) */
00298 #else
00299     ActiveSet,
00300     VirtualActiveSet,
00301     Monitored,
00302     Detected,
00303     UmtsCell,
00304     UmtsRanked,
00305     UmtsNotRanked
00306 #endif
00307 };//EmCellType
00308
00309 //T_RANKING_STATUS in /vobs/ms-hosttest/mi/src/../../../stack-interface/api/umts_testparam.pr,318,9
00310 enum EmRankingStatus {
00311 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00312     CellSuitable    =   EM_CELL_SUITABLE,     /* Cell is OK! */
00313     NotMeasured     =   EM_NOT_MEASURED,      /* No measurement results available */
00314     CellBarred      =   EM_CELL_BARRED,       /* Cell is barred )*/
00315     WrongPlmn       =   EM_WRONG_PLMN,        /* Wrong PLMN */
00316     HcsCriteriaPrio =   EM_HCS_CRITERIA_PRIO, /* Removed due to H criteria priority (HCS active)*/
00317     HcsHValue       =   EM_HCS_H_VALUE,       /* Removed due to HCS priority */
00318     SValue          =   EM_S_VALUE            /* Removed due to cell selection criteria */
00319 #else
00320     CellSuitable,
00321     NotMeasured,
00322     CellBarred,
00323     WrongPlmn,
00324     HcsCriteriaPrio,
00325     HcsHValue,
00326     SValue
00327 #endif
00328 };//EmRankingStatus
00329
00330
00331 //T_POWER_SAVING_MODE in /vobs/ms-hosttest/mi/src/../../../stack-interface/api/umts_testparam.pr,329,9
00332 enum PowerSavingMode {
00333 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00334     PowerSavingMode1 = POWER_SAVING_MODE_1
00335 #else
00336     PowerSavingMode1
00337 #endif
00338 };//PowerSavingMode
00339
00340
00341 /*----------------------------------------------------------------------------*/
00342 /*                       struct MmCellChangeCnts                              */
00343 /*                       (T_MM_CELL_CHANGE_CNTS in ms_testparam.pr)           */
00344 /*----------------------------------------------------------------------------*/
00345 struct MmCellChangeCnts {
00346     UINT8 ir_ho_attempt;    //Number of attemted inter rat HO or cell changes
00347     UINT8 ir_ho_success;    //Number of successfull inter rat HO or cell changes
00348     UINT8 ir_cr_attempt;    //Number of attemted inter rat cell reselections
00349     UINT8 ir_cr_success;    //Number of successfull inter rat cell reselections
00350     UINT8 cr_success;       //Total number of inter and intra rat cell reselections
00351 };//MmCellChangeCnts
00352
00353
00354 /**************************************************************************************************/
00355 /**************************** UMTS Related Type ***************************************************/
00356 /**************************************************************************************************/
00357 enum EngineeringModeControl {
00358 #if defined(APOXI_EM_CONTROL_ENABLED)
00359   EmcLockSCell           = EM_LOCK_SCELL,
00360   EmcUnlockSCell         = EM_UNLOCK_SCELL,
00361   EmcTrigger3g2gHandover = EM_TRIGGER_3G_2G_HANDOVER
00362 #else
00363   EmcLockSCell,
00364   EmcUnlockSCell,
00365   EmcTrigger3g2gHandover
00366 #endif
00367 };
00368
00369 enum EmControlRetValue {
00370 #if defined(APOXI_EM_CONTROL_ENABLED)
00371     EmcFailed       = E_EM_CTRL_FAILED,
00372     EmcSuccess      = 1, //E_EM_CTRL_SUCCESS, not available yet
00373     EmcUnsuported   = 0, //E_EM_CTRL_NOT_SUPPORT, not available yet
00374 #else
00375     EmcFailed       = 2,
00376     EmcSuccess      = 1,
00377     EmcUnsuported   = 0
00378 #endif
00379
00380 };
00381
00382
00383 /* --------------------------------------------------------------------- */
00384 /* ------------------ T _ B L E R _ T R C H _I N F O ------------------- */
00385 /* --------------------------------------------------------------------- */
00386 /*#NAME 'T_BLER_TRCH_INFO' */
00387 struct BlerTrchInfo {
00388     UINT8   trch_id;
00389     UINT8   meas_bler;
00390     UINT16  nof_crc_err;
00391     ULONG   tot_nof_blocks;
00392 };
00393
00394 /*
00395  *  T_BLER_TRCH_INFO_ARRAY
00396  */
00397 struct BlerTrchInfoList {
00398 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00399     enum {LengthOfBlerArray = MAX_TRCH};
00400 #else
00401     enum {LengthOfBlerArray = 8};
00402 #endif
00403
00404     INT     length;
00405     BlerTrchInfo    plmn_array[LengthOfBlerArray];
00406
00407     BOOLEAN IsEmpty();
00408     BlerTrchInfo& operator[](INT index);
00409 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00410     BlerTrchInfoList operator =(T_BLER_TRCH_INFO_ARRAY bler_array);
00411 #endif
00412 };
00413
00414 /*#NAME 'T_EM_DCH_REPORT' */
00415 struct DchReport {
00416       UINT32            meas_bler;      /* 0xFFFFFFFF if not present */
00417       INT16     target_sir;     /* 0xFFFF if not present */
00418       INT16     meas_sir;       /* 0xFFFF if not present */
00419
00420 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00421       DchReport operator =(T_EM_DCH_REPORT t_dch_report);
00422 #endif
00423 };
00424
00425 /*****
00426  * T_UPLMN
00427  * /ms-hosttest/mi/src/../../../stack-interface/globals/identity.pr,350,9)
00428 ******/
00429 struct Uplmn {
00430     UINT16  mcc;
00431     UINT16  mnc;
00432
00433     Uplmn() : mcc(0xffff), mnc(0xffff) {}
00434
00435 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00436     Uplmn operator =(T_UPLMN t_uplmn);
00437 #else
00438     Uplmn operator =(UINT8 val){return *this; }
00439 #endif
00440 };
00441
00442 /*----------------------------------------------------------------------------*/
00443 /*                       struct UmtsRrcScellParam                             */
00444 /*                       (T_UMTS_RRC_SCELL_PARAM in ms_testparam_umts.pr)         */
00445 /*----------------------------------------------------------------------------*/
00446 struct UmtsRrcScellParam {
00447     DlSc    p_sc;           //Primary scrambling code %d (0xFFFF)
00448     UINT16  lac;            //LAI/LAC (0xffff) %x
00449     UINT32  cell_identity;  //Cell identity 32bit (0xFFFFFFFF) % x
00450     Uarfcn  ul_uarfcn;      //UL UARFCN of serving cell (0xFFFF) %d
00451     Uarfcn  dl_uarfcn;      //DL UARFCN of serving cell (0xFFFF)
00452     Uplmn   plmn_id;         //PLMN ID w/ MCC and MNC.
00453         UINT16  cpich_rscp;     //RSCP (dBm - absolute value) of serving cell (0xFF) %d
00454     UINT8   cpich_ecn0;     //ECN0 (dB - absolute value) of servicing cell (0xFF) %d                            */
00455     BOOLEAN cipher_on;      //Ciphering: present if true
00456     BOOLEAN hcs_used;       //HCS is used: present if true
00457     BOOLEAN high_mobility;  //High mobilityis detected: present if true
00458         BOOLEAN limited_service;//Limited service camped (true) or normal service camped (false)
00459                             //only valid if dl_uarfcn is not INVALID_ARFCN
00460                             //reporting period
00461     BOOLEAN out_of_service; //present if out of service otherwise '-'.
00462
00463     UINT16 ranking_value;
00464
00465     /* GPRS parameters */
00466     UINT8   rac;            //RAC (0xFF)  %x
00467
00468     UmtsRrcScellParam() :
00469         p_sc(0xffff), lac(0xffff), cell_identity(0xffffffff), ul_uarfcn(0xffff), dl_uarfcn(0xffff),
00470         cpich_rscp(0xffff), cpich_ecn0(0xff), rac(0xff)
00471         {} //UmtsRrcScellParam
00472
00473 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00474     UmtsRrcScellParam operator =(T_UMTS_RRC_SCELL_PARAM umts_rrc_scell_param);
00475 #endif
00476
00477     BOOLEAN IsPScInvalid()          { return p_sc == 0xffff; }
00478     BOOLEAN IsLacInvalid()          { return lac == 0xfff; }
00479     BOOLEAN IsCellIdentityInvalid() { return cell_identity == 0xffffffff; }
00480     BOOLEAN IsUlUarfcnInvalid()     { return ul_uarfcn == 0xffff; }
00481     BOOLEAN IsDlUarfcnInvalid()     { return dl_uarfcn == 0xffff; }
00482     BOOLEAN IsCpichRscpInvalid()    { return cpich_rscp == 0xffff; }
00483     BOOLEAN IsCpichEcn0Invalid()    { return cpich_ecn0 == 0xff; }
00484     BOOLEAN IsRankingValueInvalid() { return ranking_value == 0xffff;}
00485     BOOLEAN IsRacInvalid()          { return rac == 0xff; }
00486 };//UmtsRrcScellParam
00487
00488 /*----------------------------------------------------------------------------*/
00489 /*                       struct UmtsMeasIdParam                               */
00490 /*                       (T_UMTS_MEAS_ID_PARAM_ARRAY in ms_testparam_umts.pr)     */
00491 /*----------------------------------------------------------------------------*/
00492 struct UmtsMeasIdParam {
00493 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00494     enum MaxDataElements{MaxDataElementsPerMeasId = MAX_DATA_ELEMENTS_PER_MEAS_ID};
00495 #else
00496     enum MaxDataElements{MaxDataElementsPerMeasId = 6};
00497 #endif
00498
00499     UINT8 meas_id;  //T_UMTS_MEAS_ID_PARAM_s
00500     UINT8 event_id; //T_UMTS_MEAS_ID_PARAM_s
00501     UINT8 data_elements[MaxDataElementsPerMeasId];
00502
00503     UmtsMeasIdParam() :
00504         meas_id(0xff),event_id(0xff)
00505         {}//UmtsMeasIdParam
00506
00507     BOOLEAN IsMeasIdInvalid()   { return meas_id  == 0xff; }
00508     BOOLEAN IsEventIdInvalid()  { return event_id == 0xff; }
00509
00510 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00511     UmtsMeasIdParam operator = (T_UMTS_MEAS_ID_PARAM umts_meas_id_param_array);
00512 #endif
00513 };//UmtsMeasIdParam
00514
00515 /*----------------------------------------------------------------------------*/
00516 /*                       struct UmtsMeasEvalParam                             */
00517 /*                       (T_UMTS_MEAS_EVAL_PARAM in ms_testparam_umts.pr)     */
00518 /*----------------------------------------------------------------------------*/
00519 struct UmtsMeasEvalParam {
00520 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00521     enum MaxDataElements{MaxMeas = MAXMEAS};
00522 #else
00523     enum MaxDataElements{MaxMeas = 16};
00524 #endif
00525
00526     UINT8 p1;       //T_GENERAL_MEAS_PARAMS_s
00527     UINT8 p2;       //T_GENERAL_MEAS_PARAMS_s
00528     UmtsMeasIdParam umts_meas_id_params[MaxMeas];
00529
00530     UmtsMeasEvalParam() :
00531         p1(0xff),p2(0xff)
00532         {}//UmtsMeasEvalParam
00533
00534     BOOLEAN IsP1Invalid()       { return p1       == 0xff; }
00535     BOOLEAN IsP2Invalid()       { return p2       == 0xff; }
00536
00537 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00538     UmtsMeasEvalParam operator = (T_UMTS_MEAS_EVAL_PARAM umts_meas_eval_param);
00539 #endif
00540 };//UmtsMeasEvalParam
00541
00542
00543
00544
00545 /*----------------------------------------------------------------------------*/
00546 /*                       struct UmtsNcellParam                                */
00547 /*                       (T_UMTS_NCELL_PARAM in ms_testparam_umts.pr)         */
00548 /*----------------------------------------------------------------------------*/
00549 struct UmtsNcellParam {
00550     EmCellType  cell_type;          //Kind of cell
00551     DlSc        cpich_sc;           //Primary scrambling code %d (0xFFFF)%d
00552     Uarfcn      dl_uarfcn;          //DL UARFCN (0xFFFF) %d
00553     UINT16      cpich_rscp;         //RSCP (dBm - positive value presented positive) of serving cell (0xff) %d
00554     UINT8       cpich_ecn0;         //EC2N0 (dBm - positive value presented positive) of serving cell (0xff) %d
00555     UINT8       rank_pos;           //Cell reselection ranking of the cell(0 for the best cell)
00556                                     //This value is used to order UMTS and GSM cells for the presentation - only in UMTS mode
00557     UINT16 ranking_value;           //The calculated ranking value %d - only in UMTS mode
00558     EmRankingStatus ranking_status; //Reason why the cell was not ranked %d - only in UMTS mode
00559
00560     UmtsNcellParam() :
00561         cpich_sc(0xffff), dl_uarfcn(0xffff), cpich_rscp(0xffff), cpich_ecn0(0xff), rank_pos(0xff), ranking_value(0xffff)
00562         {}//UmtsNcellParam
00563
00564     BOOLEAN IsCpichScInvalid()      { return cpich_sc == 0xffff; }
00565     BOOLEAN DlUarfcnInvalid()       { return dl_uarfcn == 0xffff; }
00566     BOOLEAN IsCpichRscpInvalid()    { return cpich_rscp == 0xffff; }
00567     BOOLEAN IsCpichEcn0Invalid()    { return cpich_ecn0 == 0xff; }
00568     BOOLEAN IsRankPosInvalid()      { return rank_pos == 0xff;}
00569     BOOLEAN IsRankingValueInvalid() { return ranking_value == 0xffff;}
00570
00571 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00572     UmtsNcellParam operator = (T_UMTS_NCELL_PARAM umts_ncell_param);
00573 #endif
00574 };//UmtsNcellParam
00575
00576
00577 /*----------------------------------------------------------------------------*/
00578 /*                       struct UmtsCellList                                  */
00579 /*                       (T_UMTS_CELL_LIST in ms_testparam_umts.pr)           */
00580 /*----------------------------------------------------------------------------*/
00581 struct UmtsCellList {
00582 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00583     enum {MaxTotalUmtsCells = EM_MAX_TOTAL_UMTS_CELLS};
00584 #else
00585     enum {MaxTotalUmtsCells = 24};
00586 #endif
00587
00588     UmtsNcellParam  umts_neighbour_cells[MaxTotalUmtsCells];
00589
00590     UmtsNcellParam& operator[](INT index) { return umts_neighbour_cells[index]; }
00591
00592 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00593     UmtsCellList operator = (T_UMTS_CELL_LIST umts_cell_list);
00594 #endif
00595 };//UmtsCellList
00596
00597
00598 /*----------------------------------------------------------------------------*/
00599 /*                       struct RrcProcessState                               */
00600 /*                       (T_RRC_PROCESS_STATE in ms_testparam_umts.pr)        */
00601 /*----------------------------------------------------------------------------*/
00602 struct RrcProcessState {
00603     UINT8   event;          //Bit map for RRC process event - zero means no event %x
00604     UINT8   process_state;  //RRC process SDL state %d
00605
00606 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00607     RrcProcessState operator = (T_RRC_PROCESS_STATE rrc_process_state);
00608 #endif
00609 };//RrcProcessState
00610
00611
00612 /* --------------------------------------------------------------------- */
00613 /* -------------    struct CellChangeCnts  ----------------------------- */
00614 /*                  T_CELL_CHANGE_CNTS in ms_testparam_umts.pr           */
00615 /* --------------------------------------------------------------------- */
00616 struct CellChangeCnts {
00617    UINT8    cr_cnt;         /* number of successful intra UMTS or GSM cell reselections */
00618    UINT8    cr_cnt_at;      /* number of attempted intra UMTS or GSM cell reselections  */
00619    UINT8    ir_cr_cnt_su;   /* number of successful UMTS to GSM cell reselections       */
00620    UINT8    ir_cr_cnt_at;   /* number of attempted UMTS to GSM cell reselections        */
00621    UINT8    ir_hocc_cnt_su; /* number of successful UMTS to GSM HO or cell changes      */
00622    UINT8    ir_hocc_cnt_at; /* number of attempted UMTS to GSM HO or cell changes       */
00623    BOOLEAN  reset_mm_cnt;   /* Reset counters in MM - parameter only used from RRC      */
00624
00625 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00626    CellChangeCnts operator = (T_CELL_CHANGE_CNTS cell_change_cnts);
00627 #endif
00628 };//CellChangeCnts
00629
00630
00631 /* --------------------------------------------------------------------- */
00632 /* ----------   struct UmtsNcellParamList                --------------- */
00633 /*              T_UMTS_NCELL_PARAM_LIST in ms_testparam_umts.pr          */
00634 /* --------------------------------------------------------------------- */
00635 struct UmtsNcellParamList {
00636    UINT8        no_active_set_cells;          /* Number of ACTIVE SET cells (CELL_DCH)*/
00637    UINT8        no_virtual_active_set_cells;  /* Number of VIRTUAL ACTIVE SET cells (CELL_DCH)*/
00638    UINT8        no_umts_cells;                /* Number of DETECTED UMTS cells (CELL_DCH) or
00639                                                  Number of UMTS neighbour cells (all states but CELL_DCH) */
00640    UmtsCellList umts_ncell_param_list;
00641
00642 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00643    UmtsNcellParamList operator = (T_UMTS_NCELL_PARAM_LIST umts_ncell_param_list);
00644 #endif
00645 };//UmtsNcellParamList
00646
00647
00648
00649
00650
00651 /* --------------------------------------------------------------------- */
00652 /* ----------   struct AsTestparamDatabase               --------------- */
00653 /*              T_AS_TESTPARAM_DATABASE in ms_testparam_umts.pr          */
00654 /* --------------------------------------------------------------------- */
00655 struct AsTestparamDatabase {
00656     BOOLEAN         reset_em;               /* Indication that MM shall reset cell change
00657                                                counters.                                 */
00658     RrcProcessState rrcdc_state;            /* State and present procedure run in URRCDC */
00659     RrcProcessState rrcbp_state;            /* State and present procedure run in URRCBP */
00660     RrcProcessState rrcm_state;             /* State and present procedure run in URRCM  */
00661
00662     MmRrReason      chn_rel_cause;          /* Channel release cause                     */
00663     BOOLEAN         cipher_on;              /* Ciphering: present if true                */
00664     BOOLEAN         ps_transfer;            /* Data has been transfered during the last  */
00665     PowerSavingMode power_saving_mode;      /* Inidcation about the powersaving mode     */
00666     UINT8           as_error_code;          /* Indication about error in UAS             */
00667     CellChangeCnts  cell_change_ind;        /* Indication that a cell change has taken
00668                                                place. The MM reads the info and merges info
00669                                                about started and successful cell changes
00670                                                from both GSM and UMTS                    */
00671     UINT8           ul_meas_cnt;            /* Number of measurements sent during the last
00672                                                reporting period                          */
00673     BOOLEAN         limited_service;        /* Limited service camped (true) or
00674                                                normal service camped (false)
00675                                                only valid if arfcn is not INVALID_ARFCN
00676                                                reporting period                          */
00677     BOOLEAN         out_of_service;         /* Out of service detected (present if true
00678                                                otherwise blank.                          */
00679
00680 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00681     AsTestparamDatabase operator = (T_AS_TESTPARAM_DATABASE as_testparam_database);
00682 #endif
00683 };//AsTestparamDatabase
00684
00685
00686
00687
00688 /***************************************************************************************************
00689                                     END OF UMTS SPEC TYPES
00690 ***************************************************************************************************/
00691
00692
00693 /*  ========================================================================
00694                                   NetType
00695     ========================================================================*/
00697 enum NetType
00698 {
00700     Gsm900              = NET_GSM900,
00702     Gsm1800             = NET_GSM1800,
00704     Gsm900_1800         = NET_GSM900_1800,
00706     Gsm1900             = NET_GSM1900,
00708     Gsm900_1900         = NET_GSM900_1900,
00710     Gsm1800_1900        = NET_GSM1800_1900,
00712     Gsm900_1800_1900,   // = NET_GSM900_1800_1900,
00714     ThirdGeneration     // = NET_3G
00715 };
00716
00717
00718 /*  ========================================================================
00719                                   NetworkSearchMode
00720     ========================================================================*/
00722 enum NetworkSearchMode {
00724     NormalSearchMode = NORMAL_SEARCH_MODE,
00726     FastSearchMode = FAST_SEARCH_MODE,
00728     InvalidSearchMode = 0xff
00729 };//NetworkSearchMode
00730
00731
00732
00733 /*  ========================================================================
00734                               Plmn
00735     ========================================================================*/
00737 enum RegisterMode {
00738     Automatic = AUTOMATIC_MODE,     // automatic registration
00739     Manual    = MANUAL_MODE,        // manual registration
00740     RegisterModeUnavailable     // undefined state
00741 };
00742
00743
00745 enum PlmnIndicator {
00746     PlmnNotProvided = PLMN_NOT_PROVIDED,
00747     PlmnProvided    = PLMN_PROVIDED
00748 };
00749
00750
00752 enum PlmnForbiddenIndicator {
00753     PlmnNotForbidden = PLMN_NOT_FORBIDDEN,
00754     PlmnForbidden    = PLMN_FORBIDDEN
00755 };
00756
00757
00758 typedef INT PlmnPlacementIndicator;
00759
00760 /*  -----------------------------------------------------------------------
00761     Plmn bcd coded
00762     ----------------------------------------------------------------------- */
00763 typedef UINT16 BcdMcc;
00764 typedef UINT8 BcdMnc;
00765
00766 const BcdMcc    InvalidBcdMcc = 0xffff;
00767 const BcdMnc    InvalidBcdMnc = 0xff;
00768
00769 class BcdPlmn {
00770     public:
00771         BcdPlmn() : mcc(0xffff), mnc(0xff) {}
00772         BcdPlmn(BcdMcc _mcc, BcdMnc _mnc) : mcc(_mcc), mnc(_mnc) {}
00773         BcdPlmn(const BcdPlmn & plmn) {
00774              mcc = plmn.mcc;
00775              mnc = plmn.mnc;
00776         }
00777         BcdPlmn(const T_PLMN & plmn) {
00778              mcc = plmn.mcc;
00779              mnc = plmn.mnc;
00780         }
00781
00782
00783         BOOLEAN IsInvalid() const { return (mcc == InvalidBcdMcc && mnc == InvalidBcdMnc); }
00784         void SetInvalid() { mcc = InvalidBcdMcc; mnc = InvalidBcdMnc; }
00785         void Init(BcdMcc _mcc, BcdMnc _mnc) { mcc = _mcc; mnc = _mnc; }
00786         BOOLEAN IsEqual(const BcdPlmn & plmn) const { return (mcc == plmn.mcc && mnc == plmn.mnc); }
00787
00788         BcdPlmn operator = (const BcdPlmn & plmn){
00789             mcc = plmn.mcc;
00790             mnc = plmn.mnc;
00791             return *this;
00792         }
00793         BcdPlmn operator = (const T_PLMN & plmn){
00794             mcc = plmn.mcc;
00795             mnc = plmn.mnc;
00796             return *this;
00797         }
00798
00799         BcdMcc  mcc;        // Mobile Country Code (3-digits, 2 bytes)
00800         BcdMnc  mnc;        // Mobile Network Code (3-digits, 1 byte)
00801
00802
00803 };
00804
00805 #define InvalidBcdPlmn BcdPlmn()
00806
00807 /*  -----------------------------------------------------------------------
00808     Plmn decimal coded
00809     ----------------------------------------------------------------------- */
00810 // plmn identification (ms.h: T_PLMN)
00811 typedef UINT16 Mcc;
00812 typedef UINT16 Mnc;
00813
00814 const Mcc       InvalidMcc = 0xffff;
00815 const Mnc       InvalidMnc = 0xffff;
00816
00818 class Plmn {
00819     public:
00821         Plmn() : mcc(0xffff), mnc(0xffff), threedigitmnc(FALSE) {}
00823         Plmn(Mcc _mcc, Mnc _mnc, BOOLEAN _threedigitmnc = FALSE)
00824             : mcc(_mcc), mnc(_mnc), threedigitmnc(_threedigitmnc) {}
00826         Plmn(const Plmn & plmn) {
00827              mcc = plmn.mcc;
00828              mnc = plmn.mnc;
00829              threedigitmnc = plmn.threedigitmnc;
00830         }
00832         BOOLEAN IsInvalid() const { return (mcc == InvalidMcc && mnc == InvalidMnc); }
00834         void SetInvalid() { mcc = InvalidMcc; mnc = InvalidMnc; threedigitmnc=FALSE; }
00836         void Init(Mcc _mcc, Mnc _mnc, BOOLEAN _threedigitmnc = FALSE) {
00837             mcc = _mcc; mnc = _mnc; threedigitmnc = _threedigitmnc;
00838         }
00840         BOOLEAN IsEqual(const Plmn & plmn) const {
00841             return (mcc == plmn.mcc && mnc == plmn.mnc && threedigitmnc==plmn.threedigitmnc);
00842         }
00844         Plmn operator = (const BcdPlmn & bcdplmn);
00845
00847         Mcc mcc;
00849         Mnc mnc;
00851         BOOLEAN threedigitmnc;
00852
00853 };
00854
00855 #define InvalidPlmn Plmn()
00856
00857 /*  -----------------------------------------------------------------------
00858     Usim Plmn
00859     ----------------------------------------------------------------------- */
00860 // T_USIMAP_PLMN_ELEM
00861 struct UsimPlmn {
00862     BcdPlmn m_plmn;
00863     UINT16  m_rat;
00864 };
00865
00866 /*  -----------------------------------------------------------------------
00867     Usim Plmn List
00868     ----------------------------------------------------------------------- */
00869 #if ! defined(USIMAP_PLMN_LIST_LEN)
00870     #define USIMAP_PLMN_LIST_LEN 8
00871 #endif
00872
00873 const INT c_maxno_usim_plmns = USIMAP_PLMN_LIST_LEN;
00874
00875 // T_USIMAP_PLMN_LIST
00876 struct UsimPlmnList {
00877     UsimPlmn val[c_maxno_usim_plmns];
00878 };
00879
00880 /*  ------------------------------------------------------------------------
00881     plmn array
00882     ------------------------------------------------------------------------ */
00883 // plmn orginal T_SI_DATA
00884 /*
00885 struct PlmnArray {
00886     UINT8 val[32];
00887     const BcdPlmn & GetPlmn(INT recno) const {
00888                     ASSERT(recno*3<sizeof(PlmnArray));
00889                     return *(BcdPlmn*)&val[recno*3];   // sizeof Plmn would deliver 4 under MSDEV
00890                 };
00891 };
00892 */
00893
00894 /*  ========================================================================
00895                               Connection info
00896     ========================================================================*/
00897 typedef UINT32  CellId;  //Cell Identity (attention: the corresponding stack type for gfs18 is still UINT16, while gfs20 is using UINT32)
00898 typedef UINT16  Lac;     //Location Area Code
00899
00900
00901 const CellId  InvalidCellId= 0xffff;
00902 const Lac     InvalidLac= 0xffff;
00903
00904
00905
00906
00907 struct Lai {
00908     Plmn plmn;
00909     Lac lac;
00910 };
00911
00912 /********************************************************/
00913 /*          RAT - Radio Access Technology (T_RAT)       */
00914 /********************************************************/
00915 enum RadioAccessTechnology {
00916 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00917     RatNotAvailable = RAT_NOT_AVAILABLE,
00918     RatGsm          = RAT_GSM,
00919     RatUmts         = RAT_UMTS
00920 #else
00921     RatNotAvailable,
00922     RatGsm,
00923     RatUmts
00924 #endif
00925 };//RadioAccessTechnology
00926
00927
00928 /********************************************************/
00929 /*           (T_RAT_CHANGE_MODE)                        */
00930 /********************************************************/
00932 enum RatChangeMode {
00933 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00934     RatChangeModeGsm    = RAT_CHANGE_MODE_GSM,
00935     RatChangeModeUmts   = RAT_CHANGE_MODE_UMTS,
00936     RatChangeModeDual   = RAT_CHANGE_MODE_DUAL,
00937 #else
00938     RatChangeModeGsm,
00939     RatChangeModeUmts,
00940     RatChangeModeDual,
00941 #endif
00942     InvalidRatChangeMode                        //for APOXI use only
00943 };
00944
00945 /********************************************************/
00946 /*           TransformRatToUsimAct                      */
00947 /********************************************************/
00948 inline UINT16 TransformRatToUsimAct(RadioAccessTechnology rat)
00949 {
00950     switch(rat) {
00951         case RatGsm: return  0x0080;    // b8 set of low byte
00952         case RatUmts: return 0x8000;    // b8 set of high byte
00953     }
00954     return 0x0000;
00955 }
00956
00957 /********************************************************/
00958 /*           TransformUsimActToRat                      */
00959 /********************************************************/
00960 inline RadioAccessTechnology TransformUsimActToRat(UINT16 act)
00961 {
00962     if((act & 0x8000)==0x8000) {
00963         return RatUmts;
00964     } else if((act & 0x0080)==0x0080) {
00965         return RatGsm;
00966     }
00967     return RatNotAvailable;
00968 }
00969
00970
00971 /********************************************************/
00972 /*           (T_GSM_BAND)                               */
00973 /********************************************************/
00975 enum GsmBand {
00976     GsmBand900 = MS_GSM900,
00977     GsmBand900P = MS_GSM900_P,
00978     GsmBand900E = MS_GSM900_E,
00979     GsmBand1800 = MS_GSM1800,
00980     GsmBand1900 = MS_GSM1900,
00981     GsmBand850 =  MS_GSM850,
00982     GsmBand450 = MS_GSM450,
00983     GsmBand480 = MS_GSM480,
00984     GsmBand900R = MS_GSM900_R,
00985     GsmMultiband = MS_MULTIBAND,
00986     InvalidGsmBand = INVALID_BAND
00987 };//GsmBand
00988
00989
00990
00991 /*----------------------------------------------------------------------------------------------*/
00992 /* struct GsmBandList                                                                           */
00993 /* (T_BAND_LIST in /ms-hosttest/mi/src/../../../ms-interface-src/pr/ms_gsm_multiband.pr,100,9)) */
00994 /*----------------------------------------------------------------------------------------------*/
00995 struct GsmBandList {
00996     enum {MaxGsmBands = BAND_LIST_LENGTH};
00997     GsmBand gsm_bands[MaxGsmBands];
00998     GsmBand& operator[](INT index) { return gsm_bands[index]; }
00999     GsmBandList operator = (T_BAND_LIST gsm_band_list);
01000 };//GsmBandList
01001
01002
01004 enum GprsClass {
01005     GprsClassA  = GPRS_CLASS_A,
01006     GprsClassB  = GPRS_CLASS_B,
01007     GprsClassC  = GPRS_CLASS_C,
01008     GprsClassCg = GPRS_CLASS_CG,
01009     GprsClassCc = GPRS_CLASS_CC,
01010     GprsNoClass = GPRS_NO_CLASS,
01011     InvalidGprsClass = 0xff
01012 };
01013
01014
01015
01016
01017 /**************************************************************************************************/
01018 /**************************************************************************************************/
01019 /**************************** Structures for Engineering Mode *************************************/
01020 /**************************************************************************************************/
01021 /**************************************************************************************************/
01022
01024 enum NetworkOpMode {
01025     NoGprsCell= NO_GPRS_CELL,
01026     NwOpMode1=  NW_OP_MODE_1,
01027     NwOpMode2=  NW_OP_MODE_2,
01028     NwOpMode3=  NW_OP_MODE_3,
01029     InvalidOpMode = 0xff
01030 };//enum NetworkOpMode
01031
01032 enum RegState {
01033     Regst_user_attach_pending = REGST_USER_ATTACH_PENDING,
01034     Regst_user_detach_pending = REGST_USER_DETACH_PENDING,
01035     Regst_ps_suspended        = REGST_PS_SUSPENDED,
01036     Regst_cs_connection       = REGST_CS_CONNECTION,
01037     Regst_indep_registration  = REGST_INDEP_REGISTRATION,
01038     Regst_plmn_selection      = REGST_PLMN_SELECTION,
01039     Regst_search_for_network  = REGST_SEARCH_FOR_NETWORK,
01040     Invalid_reg_state         = 0xff
01041 };//RegState
01042
01043 //T_RR_CELL_RESEL_REASON in ms_testparam_gsm.pr
01044 enum RrCellReselReason {
01045     ReselPlmnChange             =   RESEL_PLMN_CHANGE,              /*#NAME 'RESEL_PLMN_CHANGE' */
01046     MonReselServCellNotSuitable =   MON_RESEL_SERV_CELL_NOT_SUITABLE,/*#NAME 'MON_RESEL_SERV_CELL_NOT_SUITABLE' */
01047     ReselBetterC2C32            =   RESEL_BETTER_C2_C32,            /*#NAME 'RESEL_BETTER_C2_C32' */
01048     ReselDownlinkFail           =   RESEL_DOWNLINK_FAIL,            /*#NAME 'RESEL_DOWNLINK_FAIL' */
01049     ReselRaFailure              =   RESEL_RA_FAILURE,               /*#NAME 'RESEL_RA_FAILURE' */
01050     ReselSiReceiptFailure       =   RESEL_SI_RECEIPT_FAILURE,       /*#NAME 'RESEL_SI_RECEIPT_FAILURE' */
01051     ReselC1LessNull             =   RESEL_C1_LESS_NULL,             /*#NAME 'RESEL_C1_LESS_NULL' */
01052     ReselCallReestTimeout       =   RESEL_CALL_REEST_TIMEOUT,       /*#NAME 'RESEL_CALL_REEST_TIMEOUT' */
01053     ReselAbnormalResel          =   RESEL_ABNORMAL_RESEL,           /*#NAME 'RESEL_ABNORMAL_RESEL' */
01054     ReselCellChangeOrder        =   RESEL_CELL_CHANGE_ORDER,        /*#NAME 'RESEL_CELL_CHANGE_ORDER' */
01055     ReselNotOccurred            =   RESEL_NOT_OCCURRED              /*#NAME 'RESEL_NOT_OCCURRED' */
01056 };//RrCellReselReason
01057
01058 // T_C_OVER_I_LIST in gsm_testparam.pr
01059 struct COverIList {
01060 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01061     enum {LengthOfCOverIArray = TESTPARAM_CI_CS_COUNT};
01062 #else
01063     enum {LengthOfCOverIArray = 4};
01064 #endif
01065     INT length;
01066     SignalStrengthLevel c_over_i_array[LengthOfCOverIArray];
01067
01068     BOOLEAN IsEmpty();
01069     SignalStrengthLevel& operator[](INT index);
01070
01071 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01072     COverIList operator = (T_C_OVER_I_LIST c_over_i_list);
01073 #endif
01074 };
01075
01076 // T_ACK_NACK_CNT in gsm_testparam.pr
01077 struct AckNackCnt {
01078     INT ack_blocks;
01079     INT nack_blocks;
01080
01081     AckNackCnt() : ack_blocks(0xFFFF), nack_blocks(0xFFFF)  {}
01082
01083     BOOLEAN IsAckBlocksInvalid() { return ack_blocks == 0xFFFF; }
01084     BOOLEAN IsNackBlocksInvalid() { return nack_blocks == 0xFFFF; }
01085
01086 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01087     AckNackCnt operator =(T_ACK_NACK_CNT ack_nack_cnt);
01088 #endif
01089 };
01090
01091 // T_ACK_NACK_TESTPARAM_CNT in gsm_testparam.pr
01092 struct AckNackTestparamCnt {
01093     AckNackCnt dl_blocks;   /* ack/nack blocks in downlink */
01094     AckNackCnt ul_blocks;   /* ack/nack blocks in uplink */
01095
01096 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01097     AckNackTestparamCnt operator =(T_ACK_NACK_TESTPARAM_CNT ack_nack_testparam_cnt);
01098 #endif
01099 };
01100
01101 // T_ACK_NACK_PARAM_LIST) in gsm_testparam.pr
01102 struct AckNackParamList {
01103 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01104     enum {LengthOfAckNackTestParamCntArray = TESTPARAM_CI_CS_COUNT};
01105 #else
01106     enum {LengthOfAckNackTestParamCntArray = 4};
01107 #endif
01108     INT     length;
01109     AckNackTestparamCnt ack_nack_testparam_cnt_array[LengthOfAckNackTestParamCntArray];
01110
01111     BOOLEAN IsEmpty();
01112     AckNackTestparamCnt& operator[](INT index);
01113
01114 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01115     AckNackParamList operator = (T_ACK_NACK_PARAM_LIST ack_nack_param_list);
01116 #endif
01117 };
01118
01119 /*----------------------------------------------------------------------------*/
01120 /*                       struct GprsParam (for GPRS)                          */
01121 /*                       T_GPRS_PARAM is part of T_SCELL_PARAM                */
01122 /*----------------------------------------------------------------------------*/
01123 struct GprsParam {
01124     BOOLEAN gprs_sup;          //is GPRS supported
01125     BYTE rac;                  //Routing Area Code
01126     BOOLEAN split_pg_cycle;    //Split pg cycle on ccch by network
01127     INT nco;     // ??? SDL_Integer => INT not BYTE??
01128     NetworkOpMode net_op_mode; //Network Operation Mode
01129     UINT16 t3192;
01130     INT acc_burst_type;        //Access Burst Type
01131     BYTE drx_max;              //DRX Timer maximal
01132     BOOLEAN pbcch_present;     //PBCCH present
01133     INT emo;                   //extended measurement order
01134     BYTE psi1_repeat;          //PSI1 repeat period
01135     BYTE psi_count_lr;         //PSI count LR
01136     BYTE psi_count_hr;         //PSI count HR
01137     BYTE cr_hyst;              //cell reselect hysteresis
01138     INT  c31;                  //C31
01139     INT  c32;                  //C32
01140     BYTE acc_thr;              //Priority access THR
01141     BOOLEAN si13_present;      //SI13 present
01142     COverIList c_over_i;       //(Ccs - I) for coding scheme 1,2,3,4 (resolution acc. GSM05.08,8.1.4)
01143     AckNackParamList no_ack_nack_blocks; // number of received/lost RLC data blocks for coding scheme 1,2,3,4
01144
01145     GprsParam() :
01146         gprs_sup(FALSE), rac(0xff), split_pg_cycle(FALSE), nco(0), net_op_mode(InvalidOpMode),
01147         t3192(0xffff), acc_burst_type(0), drx_max(0xff), pbcch_present(FALSE), emo(0), psi1_repeat(0xff),
01148         psi_count_lr(0xff), psi_count_hr(0xff), cr_hyst(0xff), c31(0), c32(0), acc_thr(0xff), si13_present(FALSE)
01149     {} // GprsParam()
01150
01151     BOOLEAN IsGprsSupported()           { return gprs_sup; }
01152     BOOLEAN IsRacInvalid()              { return rac == 0xff; }
01153     BOOLEAN IsSplitPgCycle()            { return split_pg_cycle; }
01154     BOOLEAN IsNcoInvalid()              { return nco == 0; }
01155     BOOLEAN IsNetworkOpModeInvalid()    { return net_op_mode == InvalidOpMode; }
01156     BOOLEAN IsT3192Invalid()            { return t3192 == 0xffff; }
01157     BOOLEAN IsAccessBurstTypeInvalid()  { return acc_burst_type == 0; }
01158     BOOLEAN IsDrxMaxInvalid()           { return drx_max == 0xff; }
01159     BOOLEAN IsPbcchPresent()            { return pbcch_present; }
01160     BOOLEAN IsEmoInvalid()              { return emo == 0; }
01161     BOOLEAN IsPsi1RepeatPeriodInvalid() { return psi1_repeat == 0xff; }
01162     BOOLEAN IsPsiCountLrInvalid()       { return psi_count_lr == 0xff; }
01163     BOOLEAN IsPsiCountHrInvalid()       { return psi_count_hr == 0xff; }
01164     BOOLEAN IsCellReselectHystInvalid() { return cr_hyst == 0xff; }
01165     BOOLEAN IsC31Invalid()              { return c31 == 0; }
01166     BOOLEAN IsC32Invalid()              { return c32 == 0; }
01167     BOOLEAN IsAccThrInvalid()           { return acc_thr == 0xff; }
01168     BOOLEAN IsSi13Present()             { return si13_present; }
01169
01170     GprsParam operator = (T_GPRS_PARAM gprs_param);
01171 };//struct GprsParam
01172
01173
01174
01175 /*----------------------------------------------------------------------------*/
01176 /*                            struct MmcsParam (for GPRS, GSM97)              */
01177 /*                            T_MMCS_TESTPARAM                                */
01178 /*----------------------------------------------------------------------------*/
01179 struct MmcsParam {
01180     INT state;                  //State of Mobility Management
01181     INT update_status;      //Location update status
01182     INT service_state;     //Mobility Management Service State
01183     INT timer;               //Bitmap indicating active timers
01184
01185     MmcsParam() :
01186         state(0xff), update_status(0xff), service_state(0xff),
01187         timer(0xff)
01188     {}//MmcsParam()
01189
01190     BOOLEAN IsStateInvalid()        { return state == 0xff; }
01191     BOOLEAN IsUpdateStatusInvalid() { return update_status == 0xff; }
01192     BOOLEAN IsServiceStateInvalid() { return service_state == 0xff; }
01193     BOOLEAN IsTimerInvalid()        { return timer == 0xff; }
01194
01195     MmcsParam operator = (T_MMCS_TESTPARAM mmcs_testparam);
01196 };//MmcsParam
01197
01198
01199 /*----------------------------------------------------------------------------*/
01200 /*                            struct GmmParam (for GPRS)                      */
01201 /*                            T_GMM_TESTPARAM                                 */
01202 /*----------------------------------------------------------------------------*/
01203 struct GmmParam {
01204     INT state;               //State of Mobility Management
01205     INT update_status;   //Location update status
01206     INT service_state;   //Mobility Management Service State
01207     INT timer;            //Bitmap indicating active timers
01208     BOOLEAN ready_connected;     //Ready or PMM_Connected
01209
01210     GmmParam() :
01211         state(0xff), update_status(0xff), service_state(0xff),
01212         timer(0xff), ready_connected(FALSE)
01213     {}//GmmParam()
01214
01215     BOOLEAN IsStateInvalid()        { return state == 0xff; }
01216     BOOLEAN IsUpdateStatusInvalid() { return update_status == 0xff; }
01217     BOOLEAN IsServiceStateInvalid() { return service_state == 0xff; }
01218     BOOLEAN IsTimerInvalid()        { return timer == 0xff; }
01219
01220     GmmParam operator = (T_GMM_TESTPARAM gmm_testparam);
01221 };//GmmParam
01222
01223
01224 /*----------------------------------------------------------------------------*/
01225 /*                            struct MmCoordParam (for GPRS)                  */
01226 /*                            T_MMCOORD_TESTPARAM                             */
01227 /*----------------------------------------------------------------------------*/
01228 struct MmCoordParam {
01229     INT state;           //State of Mobility Management
01230     RegState reg_state;      //MM service state
01231     INT timer;        //Bitmap indicating active timers
01232     GprsClass gprs_class;    //GPRS class
01233     GsmBand gsm_band;        //GSM band
01234
01235     MmCoordParam() :
01236         state(0xff), reg_state(Invalid_reg_state), timer(0xff),
01237         gprs_class(InvalidGprsClass), gsm_band(InvalidGsmBand)
01238     {}//MMCoordParam
01239
01240     BOOLEAN IsStateInvalid()        { return state == 0xff; }
01241     BOOLEAN IsRegStateInvalid()        { return reg_state == Invalid_reg_state; }
01242     BOOLEAN IsTimerInvalid()        { return timer == 0xff; }
01243     BOOLEAN IsGprsClassInvalid()    { return gprs_class == InvalidGprsClass; }
01244     BOOLEAN IsGsmBandInvalid()      { return gsm_band == InvalidGsmBand; }
01245
01246     MmCoordParam operator = (T_MMCOORD_TESTPARAM mmcoord_testparam);
01247 };//MmCoordParam
01248
01249
01250 /*----------------------------------------------------------------------------*/
01251 /*                       struct NeighbourCell (for GPRS, GSM97, GSM97ds)      */
01252 /*                       T_NCELL_PARAM                                        */
01253 /*----------------------------------------------------------------------------*/
01254 struct NeighbourCell {                                                                 // GPRS GSM97 GSM97ds  UMTS
01255     UINT16 mcc;                 //Mobile Country Code                                       x   x              x
01256     UINT16  mnc;                //Mobile Network Code                                       x   x              x
01257     Plmn plmn;                  //Mobile Network code and mobile country cod + three digits
01258     UINT16 lac;                 //Location Area Code                                        x   x              x
01259     UINT16 cell_id;             //Cell Identity                                             x   x              x
01260     BYTE   bsic;                //Base Transceiver Station Identity Code                    x   x   x          x
01261     UINT16 arfcn;               //Absolut Radio Frequency Channel Number                    x   x   x          x
01262     SignalStrengthLevel  rxlev; //Received Signal Level                                     x   x   x          x
01263     INT c1;                     //C1 of neighbour cell                                      x   x              x
01264     INT c2;                     //C2 of neighbour cell                                      x   x              x
01265     INT c31;                    //C31 of neighbour cell                                     x                  x
01266     INT c32;                    //C32 of neighbour cell                                     x                  x
01267
01268     UINT8               rank_pos;       //Cell reselection ranking of the cell                                 x
01269                                         //(0 for the best cell)
01270                                         //This value is used to order UMTS and GSM cells
01271                                         //for the presentation - only in UMTS mode
01272     UINT16              ranking_value;  //The calculated ranking value %d - only in UMTS mode                  x
01273     EmRankingStatus     ranking_status; //Reason why the cell was not ranked %d - only in UMTS mode            x
01274
01275     NeighbourCell() :
01276         mcc(0xffff), mnc(0xffff), plmn(), lac(0xffff), cell_id(0xffff), bsic(0xff), arfcn(0xffff),
01277         rxlev(InvalidSignalStrengthLevel), c1(0xffff), c2(0xffff), c31(0xffff), c32(0xffff),
01278         rank_pos(0xff), ranking_value(0xffff)
01279     {}//NeighbourCell()
01280
01281     BOOLEAN IsMccInvalid()          { return mcc == 0xffff; }
01282     BOOLEAN IsMncInvalid()          { return mnc == 0xffff; }
01283     BOOLEAN IsPlmnInvalid()         { return plmn.IsInvalid(); }
01284     BOOLEAN IsLacInvalid()          { return lac     == 0xffff; }
01285     BOOLEAN IsCellIdInvalid()       { return cell_id == 0xffff; }
01286     BOOLEAN IsBsicInvalid()         { return bsic    == 0xff; }
01287     BOOLEAN IsArfcnInvalid()        { return arfcn   == 0xffff; }
01288     BOOLEAN IsRxlevInvalid()        { return rxlev   == InvalidSignalStrengthLevel; }
01289     BOOLEAN IsC1Invalid()           { return c1 == 0xffff; }
01290     BOOLEAN IsC2Invalid()           { return c2 == 0xffff; }
01291     BOOLEAN IsC31Invalid()          { return c31 == 0xffff; }
01292     BOOLEAN IsC32Invalid()          { return c32 == 0xffff; }
01293     BOOLEAN IsRankPosInvalid()      { return rank_pos == 0xff;}
01294     BOOLEAN IsRankingValueInvalid() { return ranking_value == 0xffff;}
01295
01296     NeighbourCell operator = (T_NCELL_PARAM ncell_param);
01297 }; //struct NeighbourCell
01298
01299
01300 /*----------------------------------------------------------------------------*/
01301 /*                       struct NeighbourCellList (for GPRS, GSM97, GSM97ds)  */
01302 /*                       T_GSM_NCELL_PARAM_LIST , T_NCELL_PARAM_LIST          */
01303 /*----------------------------------------------------------------------------*/
01304 struct NeighbourCellList {
01305     enum {MaxListSize= MAX_NCELL_PARAM};
01306     UINT8 nr_of_cells;
01307     NeighbourCell neighbour_cells[MaxListSize];
01308
01309     BOOLEAN IsEmpty()   { return nr_of_cells == 0;  }
01310     NeighbourCell& operator[](INT index) { return neighbour_cells[index]; }
01311
01312 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01313     NeighbourCellList operator = (T_GSM_NCELL_PARAM_LIST gsm_ncell_param_list);
01314 #else
01315     NeighbourCellList operator = (T_NCELL_PARAM_LIST gsm_ncell_param_list);
01316 #endif
01317 };//struct NeighbourCellList
01318
01319 /*----------------------------------------------------------------------------*/
01320 /*                       struct CellParam (for GPRS, GSM97, GSM97ds)          */
01321 /*                       T_SCELL_PARAM                                        */
01322 /*----------------------------------------------------------------------------*/
01323 struct CellParam {                                                                    // GPRS GSM97 GSM97ds
01324     UINT16 mcc;                     //Mobile Country Code                                   x   x   x
01325     UINT16 mnc;                     //Mobile Network Code                                   x   x   x
01326     Plmn plmn;                      //Mobile Network code and mobile country code + three digits
01327     UINT16 lac;                     //Location Area Code                                    x   x   x
01328     UINT16 cell_id;                 //Cell Identity                                         x   x   x
01329     BYTE   bsic;                    //Base Transceiver Station Identity Code                x   x
01330     BYTE   bsic_ncc;                //Base Transceiver Station Identity Code / NCC                  x
01331     BYTE   bsic_bcc;                //Base Transceiver Station Identity Code / BCC                  x
01332     UINT16  arfcn;                  //Absolut Radio Frequency Channel Number                x   x   x
01333     SignalStrengthLevel rxlev_serv; //RXLEV of serving cell                                 x   x
01334     INT no_rf_chans;                //Number of frequencies in MA                           x   x
01335     UINT16 arfcn_ded;               //Single absolut radio-frequency of dedicated channel   x   x
01336     SignalStrengthLevel rxlev_full; //Received Signal Strength Level Full                   x   x   x
01337     SignalStrengthLevel rxlev_sub;  //Received Signal Strength Level Sub                    x   x   x
01338     SignalQualityLevel rxqual_full; //Received Signal Quality Full                          x   x   x
01339     SignalQualityLevel rxqual_sub;  //Received Signal Quality Sub                           x   x   x
01340     BOOLEAN cipher_on;              //Ciphering off(=false) or on(=true)                    x   x
01341     BYTE ms_tx_power_max_cch;       //Ms transmit power max cch                             x   x   x
01342     BYTE rxlev_access_min;          //received signal level access minimum                  x   x   x
01343     BYTE cell_bar_qualify;          //cell bar qualify                                      x   x   x
01344     BYTE cell_bar_access;           //cell bar access                                       x   x   x
01345     BYTE c2_valid_params;           //CELL_RESELECT_PARAM_IND (invalid if no c2 params)     x   x   x
01346     BYTE cell_reselect_offset;      //Cell reselect offset                                  x   x   x
01347     BYTE tmp_offset;                //Temporary offset                                      x   x   x
01348     BYTE penalty_time;              //Penalty Time                                          x   x   x
01349     INT  c1;                        //C1                                                    x   x   x
01350     INT  c2;                        //C2                                                    x   x   x
01351     BYTE channel_type;              //Channel Type                                          x   x   x
01352     BYTE channel_mode;              //Channel Mode                                          x   x   x
01353     BYTE tx_power_level;            //Transmit power level                                  x   x   x
01354     BYTE dtx_used;                  //DTX used                                              x   x   x
01355     UINT16 t3212;                   //T3212                                                 x   x   x
01356     UINT16 access_control_class;    //Access control class                                  x   x   x
01357     BYTE timing_advance;            //Timing advance                                        x   x   x
01358     BYTE bs_pa_mfrms;               //BS_PA_MFRMS                                           x   x   x
01359     BYTE dsc;                       //Downlink Signal Counter                               x   x
01360     BYTE rll;                       //Radio Link Loss Counter (for GPRS)                    x
01361     INT  cell_change_cnt;           //Number of sucessful intra GSM cell changes            x
01362
01363
01364     CellParam()  :
01365         mcc(0xffff), mnc(0xffff), lac(0xffff), cell_id(0xffff), bsic(0xff), bsic_ncc(0xff),bsic_bcc(0xff), arfcn(0xffff),
01366         rxlev_serv(InvalidSignalStrengthLevel), no_rf_chans(0), arfcn_ded(0xffff), rxlev_full(InvalidSignalStrengthLevel),
01367         rxlev_sub(InvalidSignalStrengthLevel), rxqual_full(InvalidSignalStrengthLevel),
01368         rxqual_sub(InvalidSignalStrengthLevel), cipher_on(FALSE), ms_tx_power_max_cch(0xff),
01369         rxlev_access_min(0xff), cell_bar_qualify(0xff), cell_bar_access(0xff), c2_valid_params(0xff),
01370         cell_reselect_offset(0xff), tmp_offset(0xff), penalty_time(0xff), c1(0), c2(0), channel_type(0xff),
01371         channel_mode(0xff), tx_power_level(0xff), dtx_used(0xff), t3212(0xffff), access_control_class(0xffff),
01372         timing_advance(0xff), bs_pa_mfrms(0xff), dsc(0xff), rll(0xff), cell_change_cnt(0)
01373     {} //CellParam()
01374
01375
01376     BOOLEAN IsMccInvalid()    { return mcc == 0xffff; }
01377     BOOLEAN IsMncInvalid()    { return mnc == 0xffff; }
01378     BOOLEAN IsPlmnInvalid()    { return plmn.IsInvalid(); }
01379     BOOLEAN IsLacInvalid()    { return lac     == 0xffff; }
01380     BOOLEAN IsCellIdInvalid() { return cell_id == 0xffff; }
01381     BOOLEAN IsBsicInvalid()   { return bsic    == 0xff; }
01382     BOOLEAN IsBsicNccInvalid()   { return bsic_ncc    == 0xff; }
01383     BOOLEAN IsBsicBccInvalid()   { return bsic_bcc    == 0xff; }
01384     BOOLEAN IsArfcnInvalid()  { return arfcn   == 0xffff; }
01385     BOOLEAN IsRxlevServInvalid() { return rxlev_serv == InvalidSignalStrengthLevel; }
01386     BOOLEAN IsNoRfChansInvalid() { return no_rf_chans == 0; }
01387     BOOLEAN IsArfcnDedInvalid()  { return arfcn_ded == 0xffff; }
01388     BOOLEAN IsRxlevFullInvalid()  { return rxlev_full == InvalidSignalStrengthLevel; }
01389     BOOLEAN IsRxlevSubInvalid()  { return rxlev_sub == InvalidSignalStrengthLevel; }
01390     BOOLEAN IsRxqualFullInvalid()  { return rxqual_full == InvalidSignalQualityLevel; }
01391     BOOLEAN IsRxqualSubInvalid()  { return rxqual_sub == InvalidSignalQualityLevel; }
01392     BOOLEAN IsMsTxPowerMaxCchInvalid() { return ms_tx_power_max_cch == 0xff; }
01393     BOOLEAN IsRxlevAccessMinInvalid() { return rxlev_access_min == 0xff; }
01394     BOOLEAN IsCellBarQualifyInvalid() { return cell_bar_qualify == 0xff; }
01395     BOOLEAN IsCellBarAccessInvalid() { return cell_bar_access == 0xff; }
01396     BOOLEAN IsC2ValidParamsInvalid() { return c2_valid_params == 0xff; }
01397     BOOLEAN IsCellReselectOffsetInvalid() { return cell_reselect_offset == 0xff; }
01398     BOOLEAN IsTmpOffsetInvalid() { return tmp_offset == 0xff; }
01399     BOOLEAN IsPenaltyTimeInvalid() { return penalty_time == 0xff; }
01400     BOOLEAN IsC1Invalid() { return c1 == 0; }
01401     BOOLEAN IsC2Invalid() { return c2 == 0; }
01402     BOOLEAN IsChannelTypeInvalid() { return channel_type == 0xff; }
01403     BOOLEAN IsChannelModeInvalid() { return channel_mode == 0xff; }
01404     BOOLEAN IsTxPowerLevelInvalid() { return tx_power_level == 0xff; }
01405     BOOLEAN IsDtxUsedInvalid() { return dtx_used == 0xff; }
01406     BOOLEAN IsT3212Invalid() { return t3212 == 0xffff; }
01407     BOOLEAN IsAccessControlClassInvalid() { return access_control_class == 0xffff; }
01408     BOOLEAN IsTimingAdvanceInvalid() { return timing_advance == 0xff; }
01409     BOOLEAN IsBsPaMfrmsInvalid() { return bs_pa_mfrms == 0xff; }
01410     BOOLEAN IsDscInvalid() { return dsc == 0xff; }
01411     BOOLEAN IsRllInvalid() { return rll == 0xff; }
01412     BOOLEAN IsCellChangeCntInvalid() { return cell_change_cnt == 0; }
01413
01414     CellParam operator = (T_SCELL_PARAM scell_param);
01415 };//struct CellParam
01416
01417
01418 /*----------------------------------------------------------------------------*/
01419 /*                       struct RrParam (Radio Ressources)  (for GPRS, GSM97) */
01420 /*                       T_RR_TESTPARAM                                       */
01421 /*----------------------------------------------------------------------------*/
01422 struct RrParam {
01423     INT        state;                   //SDL state of GRR
01424     INT        cell_reselection_reason; //Cause of cell reselection
01425     MmRrReason channel_release_reason;  //Cause of channel release
01426     BOOLEAN    limited_service;         //Limited service campted (true), Normal service campted (false) ->only valid if invalid arfcn
01427                                         //Normal service campted (false)
01428                                         //->only valid if invalid arfcn
01429     RrParam() :
01430         state(0xff), cell_reselection_reason(0xff),
01431         channel_release_reason(InvalidMmRrReason), limited_service(FALSE)
01432     {}//RrParam()
01433
01434     BOOLEAN IsStateInvalid() { return state == 0xff; }
01435     BOOLEAN IsCellReselectionReasonInvalid() { return cell_reselection_reason == 0xff; }
01436     BOOLEAN IsChannelReleaseReasonInvalid() { return channel_release_reason == InvalidMmRrReason; }
01437
01438 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01439     RrParam operator = (T_RR_TESTPARAM *rr_testparam);
01440 #else
01441     RrParam operator = (T_RR_TESTPARAM rr_testparam);
01442 #endif
01443 };//RrParam
01444
01445 /*----------------------------------------------------------------------------*/
01446 /*                       struct RrcParam                                      */
01447 /*                       (T_RRC_TESTPARAM in ms_testparam_umts.pr)            */
01448 /*----------------------------------------------------------------------------*/
01449 struct RrcParam {
01450     UINT8               rrc_state;          /* RRC state                                 */
01451     RrcProcessState     rrcdc_state;        /* State and events in URRCDC                */
01452     RrcProcessState     rrcbp_state;        /* State and events in URRCBP                */
01453     RrcProcessState     rrcm_state;         /* State and events in URRCM                 */
01454
01455     PowerSavingMode     power_saving_mode;  /* Indication about the powersaving mode     */
01456
01457     MmRrReason          chn_rel_cause;      /* Channel release cause      %d             */
01458     BOOLEAN             ps_transfer;        /* Data has been transfered during the last
01459                                                report period, present if true.           */
01460     UINT8               as_error_code;      /* Indication about error in UAS      %d     */
01461     UINT8               ul_meas_cnt;        /* Number of measurements sent during the last
01462                                                reporting period %d                       */
01463     INT8                oos_cnt;             /* Number of times UE went out of service    */
01464     UINT8               tx_pwr;             /* Tx output power */
01465     DchReport           l1_data;             /* containing BLER and other L1 data */
01466
01467     UmtsRrcScellParam   umts_scell;         /* Parameters of UMTS serving cell                */
01468
01469     UmtsMeasEvalParam   umts_meas_eval_param; /* UMTS measurement evaluation parameters    */
01470
01471     RrcParam() :
01472         rrc_state(0xff), chn_rel_cause(InvalidMmRrReason), as_error_code(0xff), ul_meas_cnt(0xff)
01473     {}//RrcParam
01474
01475 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01476     RrcParam operator = (T_RRC_TESTPARAM *rrc_testparam);
01477 #endif
01478 };//RrcParam
01479
01480 /*
01481  *  T_EQUIV_PLMN_LIST, T_EQUIV_PLMN_ARRAY
01482  */
01483 struct EquivPlmnLists {
01484 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01485     enum {LengthOfPlmnArray = LENGTH_OF_PLMN_ARRAY};
01486 #else
01487     enum {LengthOfPlmnArray = 6};
01488 #endif
01489
01490     INT     length;
01491     Plmn    plmn_array[LengthOfPlmnArray];
01492
01493     BOOLEAN IsEmpty();
01494     Plmn& operator[](INT index);
01495
01496 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01497     EquivPlmnLists operator =(T_EQUIV_PLMN_LIST equiv_plmn_list);
01498 #endif
01499 };
01500
01501 /*----------------------------------------------------------------------------*/
01502 /*                       struct TestparamReport (for GPRS, GSM97, GSM97ds)    */
01503 /*                       T_TESTPARAM_REPORT                                   */
01504 /*----------------------------------------------------------------------------*/
01505 struct TestparamReport {
01506     //T_MM_TESTPARAM_s
01507
01508     MmcsParam cs_param;                 //data of circuit-switched MM (Mobility Management)) T_MMCS_TESTPARAM
01509     GmmParam ps_param;                  //data of packet-switched (Mobility Management)
01510     MmCoordParam coord_param;           //co-ordination parameter (Mobility Management)
01511     RrParam rr_param;                   //Radio Ressources
01512     GprsParam gprs;                     //Gprs related Params  T_GPRS_PARAM is part of T_SCELL_PARAM
01513
01514     //GSM
01515     CellParam serving_cell;             //Serving Cell for GSM
01516     NeighbourCellList neighbour_cells;  //Neighbour Cells for GSM
01517
01518     //UMTS
01519     UINT8               rat;
01520     CellChangeCnts      cell_change_cnts;
01521     EquivPlmnLists      eq_plmn_list;    // added to T_MM_TESTPARAM_s => also for GSM?
01522     NetworkOpMode       nom;             /* network operation mode                 */
01523
01524     RrMode              rr_mode;        //umts or gsm-parameters(RRC or RR)
01525
01526     RrcParam rrc_param;
01527     UmtsNcellParamList umts_ncell_param;//UmtsNeighbour Cells => member of T_RR_TESTPARAM
01528
01529     //UmtsNcellParamList in RR and RRC ???????????????
01530
01531     enum TestParamReportComponent {
01532         CsParam,
01533         PsParam,
01534         CoordParam,
01535         RrParam,
01536         Gprs,
01537         ServingCell,
01538         NeighbourCells,
01539
01540         Rat,
01541         EqUplmList,
01542         CellChangeCnts,
01543
01544         RrMode,
01545
01546         RrcParam,
01547         UmtsNeighbourCells
01548     };//TestParamReportComponent
01549
01550     BOOLEAN IsComponentSupported(TestParamReportComponent comp) const {
01551         return true;
01552     } // IsComponentSupported
01553 };// TestparamReport
01554
01555 /**************************************************************************************************/
01556 /**************************** Engineering Mode: L1 Reporting **************************************/
01557 /**************************************************************************************************/
01558
01559 // T_CI_TEST_PARAM in testparam.pr
01560 struct CiTestParam {
01561     UINT8 no_blocks;      // Number of received blocks
01562     INT   sum_c_over_i;   /* Sum of (Ccs - I) over no_blocks for respective coding scheme
01563                              (resolution according GSM 05.08, 8.1.4) */
01564     CiTestParam() : no_blocks(0xFF), sum_c_over_i(0xFFFF) {}
01565
01566     BOOLEAN IsNoBlocksInvalid() { return no_blocks == 0xFF; }
01567     BOOLEAN IsSumCOverIInvalid() { return sum_c_over_i == 0xFFFF; }
01568
01569 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01570     CiTestParam operator =(T_CI_TESTPARAM ci_testparam);
01571 #endif
01572 };
01573
01574 // T_CI_TESTPARAM_LIST in testparam.pr
01575 struct CiTestParamList {
01576 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01577     enum {LengthOfCiTestparamArray = TESTPARAM_CI_CS_COUNT};
01578 #else
01579     enum {LengthOfCiTestparamArray = 4};
01580 #endif
01581     INT     length;
01582     CiTestParam ci_testparam_array[LengthOfCiTestparamArray];
01583
01584     BOOLEAN IsEmpty();
01585     CiTestParam& operator[](INT index);
01586
01587 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01588     CiTestParamList operator =(T_CI_TESTPARAM_LIST ci_testparam_list);
01589 #endif
01590 };
01591
01592 /*----------------------------------------------------------------------------*/
01593 /*                       struct L1Param (for GPRS)                            */
01594 /*                       T_L1_TESTPARAM_s                                     */
01595 /*----------------------------------------------------------------------------*/
01596 struct L1Param {
01597     BYTE timing_advance;     //Timing advance
01598     BYTE tx_power_level;     //Transmit power level
01599     BYTE dsc_pch;            //Downlink Signal Counter for cs-paging
01600     UINT16 dsc_ppch;         //Downlink Signal Counter for ps-paging
01601     BYTE rll;                //Radiolink Signal Counter
01602     BYTE rxqual;             //RXQUAL in idle mode, otherwise undefined
01603     CiTestParamList ci_param;  //C over I results array
01604
01605     L1Param() :
01606         timing_advance(0xff), tx_power_level(0xff), dsc_pch(0xff),
01607         dsc_ppch(0xff), rll(0xff), rxqual(0xff)
01608     {} //L1Param
01609
01610     BOOLEAN IsTimingAdvanceInvalid() { return timing_advance == 0xff; }
01611     BOOLEAN IsTxPowerLevelInvalid()  { return tx_power_level == 0xff; }
01612     BOOLEAN IsDscPchInvalid()        { return dsc_pch == 0xff; }
01613     BOOLEAN IsDscPpchInvalid()       { return dsc_ppch == 0xff; }
01614     BOOLEAN IsRllInvalid()           { return rll == 0xff; }
01615     BOOLEAN IsRxqualInvalid()        { return rxqual == 0xff; }
01616
01617     L1Param operator = (T_L1_TESTPARAM_s l1_testparams);
01618 };//L1Param
01619
01620 #endif  // Apc_NetworkTypes_hpp
01621
01622
01623
Generated on Tue Jan 24 14:46:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/OmStackMsgArgs.cpp File Reference

Apc/OmStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "OmStackMsgArgs.hpp"

Include dependency graph for OmStackMsgArgs.cpp:

Generated on Tue Jan 24 16:57:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/OmStackMsgArgs.hpp File Reference

Apc/OmStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/NetworkTypes.hpp>

Include dependency graph for OmStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | OmBandStatusCnfArg
class | OmBandStatusReqArg
class | OmMultiSlotIndArg
class | OmMultiSlotReqArg
class | OmRatChangeCnfArg
class | OmRatChangeIndArg
class | OmRatChangeReqArg

Defines

#define | Apc_OmStackMsgArgs_hpp

Define Documentation

#define Apc_OmStackMsgArgs_hpp

Generated on Tue Jan 24 16:57:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/OmStackMsgArgs.hpp Source File

Apc/OmStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "auzinger_view_latest\lnz_apoxi\Apoxi\Apc\OmArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_OmStackMsgArgs_hpp)
00016 #define Apc_OmStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/NetworkTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class OmMultiSlotIndArg
00028     ====================================================================== */
00029
00031 class OmMultiSlotIndArg : public StackMsgArgument {
00032     friend class CommonStackMsgArgsDestroyTableNode;
00033     public:
00034         OmMultiSlotIndArg();
00035
00036         static const OmMultiSlotIndArg& Cast(const StackMsgArgument& arg);
00037         void SetSuccess(BOOLEAN success) { m_success = success; }
00038         BOOLEAN IsSuccess() const { return m_success; }
00039
00040         enum  {
00041             ID = 1600
00042             };
00043
00044     private:
00045
00046         static void Destroy(StackMsgArgument* arg) { delete ((OmMultiSlotIndArg*) arg); }
00047
00048         BOOLEAN m_success;
00049
00050     };
00051
00052 // Inline definitions
00053 inline const OmMultiSlotIndArg& OmMultiSlotIndArg::Cast(const StackMsgArgument& arg) {
00054     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmMultiSlotIndArg!\n");
00055     return ((OmMultiSlotIndArg &) arg);
00056 }
00057
00058
00059
00060 /*  ======================================================================
00061     Class OmBandStatusCnfArg
00062     ====================================================================== */
00063
00065 class OmBandStatusCnfArg : public StackMsgArgument {
00066     friend class CommonStackMsgArgsDestroyTableNode;
00067     public:
00068         OmBandStatusCnfArg();
00069
00070         static const OmBandStatusCnfArg& Cast(const StackMsgArgument& arg);
00071         void SetSupportedBandList(const GsmBandList& supported_band_list) { m_supported_band_list = supported_band_list; }
00072         const GsmBandList& GetSupportedBandList() const { return m_supported_band_list; }
00073         void SetUsedBandList(const GsmBandList& used_band_list) { m_used_band_list = used_band_list; }
00074         const GsmBandList& GetUsedBandList() const { return m_used_band_list; }
00075
00076         enum  {
00077             ID = 1601
00078             };
00079
00080     private:
00081
00082         static void Destroy(StackMsgArgument* arg) { delete ((OmBandStatusCnfArg*) arg); }
00083
00084         GsmBandList m_supported_band_list;
00085         GsmBandList m_used_band_list;
00086
00087     };
00088
00089 // Inline definitions
00090 inline const OmBandStatusCnfArg& OmBandStatusCnfArg::Cast(const StackMsgArgument& arg) {
00091     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmBandStatusCnfArg!\n");
00092     return ((OmBandStatusCnfArg &) arg);
00093 }
00094
00095
00096
00097 /*  ======================================================================
00098     Class OmRatChangeCnfArg
00099     ====================================================================== */
00100
00102 class OmRatChangeCnfArg : public StackMsgArgument {
00103     friend class CommonStackMsgArgsDestroyTableNode;
00104     public:
00105         OmRatChangeCnfArg();
00106
00107         static const OmRatChangeCnfArg& Cast(const StackMsgArgument& arg);
00108
00109         enum  {
00110             ID = 1602
00111             };
00112
00113     private:
00114
00115         static void Destroy(StackMsgArgument* arg) { delete ((OmRatChangeCnfArg*) arg); }
00116
00117     };
00118
00119 // Inline definitions
00120 inline const OmRatChangeCnfArg& OmRatChangeCnfArg::Cast(const StackMsgArgument& arg) {
00121     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmRatChangeCnfArg!\n");
00122     return ((OmRatChangeCnfArg &) arg);
00123 }
00124
00125
00126
00127 /*  ======================================================================
00128     Class OmRatChangeIndArg
00129     ====================================================================== */
00130
00132 class OmRatChangeIndArg : public StackMsgArgument {
00133     friend class CommonStackMsgArgsDestroyTableNode;
00134     public:
00135         OmRatChangeIndArg();
00136
00137         static const OmRatChangeIndArg& Cast(const StackMsgArgument& arg);
00138         void SetRatChangeMode(const RatChangeMode& rat_change_mode) { m_rat_change_mode = rat_change_mode; }
00139         const RatChangeMode& GetRatChangeMode() const { return m_rat_change_mode; }
00140
00141         enum  {
00142             ID = 1603
00143             };
00144
00145     private:
00146
00147         static void Destroy(StackMsgArgument* arg) { delete ((OmRatChangeIndArg*) arg); }
00148
00149         RatChangeMode m_rat_change_mode;
00150
00151     };
00152
00153 // Inline definitions
00154 inline const OmRatChangeIndArg& OmRatChangeIndArg::Cast(const StackMsgArgument& arg) {
00155     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmRatChangeIndArg!\n");
00156     return ((OmRatChangeIndArg &) arg);
00157 }
00158
00159
00160
00161 /*  ======================================================================
00162     Class OmMultiSlotReqArg
00163     ====================================================================== */
00164
00166 class OmMultiSlotReqArg : public StackMsgArgument {
00167     friend class CommonStackMsgArgsDestroyTableNode;
00168     public:
00169         OmMultiSlotReqArg(const MultiSlotMode& multi_slot_mode);
00170         OmMultiSlotReqArg();
00171
00172         static const OmMultiSlotReqArg& Cast(const StackMsgArgument& arg);
00173         void SetMultiSlotMode(const MultiSlotMode& multi_slot_mode) { m_multi_slot_mode = multi_slot_mode; }
00174         const MultiSlotMode& GetMultiSlotMode() const { return m_multi_slot_mode; }
00175
00176         enum  {
00177             ID = 2600
00178             };
00179
00180     private:
00181
00182         static void Destroy(StackMsgArgument* arg) { delete ((OmMultiSlotReqArg*) arg); }
00183
00184         MultiSlotMode m_multi_slot_mode;
00185
00186     };
00187
00188 // Inline definitions
00189 inline const OmMultiSlotReqArg& OmMultiSlotReqArg::Cast(const StackMsgArgument& arg) {
00190     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmMultiSlotReqArg!\n");
00191     return ((OmMultiSlotReqArg &) arg);
00192 }
00193
00194
00195
00196 /*  ======================================================================
00197     Class OmBandStatusReqArg
00198     ====================================================================== */
00199
00201 class OmBandStatusReqArg : public StackMsgArgument {
00202     friend class CommonStackMsgArgsDestroyTableNode;
00203     public:
00204         OmBandStatusReqArg();
00205
00206         static const OmBandStatusReqArg& Cast(const StackMsgArgument& arg);
00207
00208         enum  {
00209             ID = 2601
00210             };
00211
00212     private:
00213
00214         static void Destroy(StackMsgArgument* arg) { delete ((OmBandStatusReqArg*) arg); }
00215
00216     };
00217
00218 // Inline definitions
00219 inline const OmBandStatusReqArg& OmBandStatusReqArg::Cast(const StackMsgArgument& arg) {
00220     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmBandStatusReqArg!\n");
00221     return ((OmBandStatusReqArg &) arg);
00222 }
00223
00224
00225
00226 /*  ======================================================================
00227     Class OmRatChangeReqArg
00228     ====================================================================== */
00229
00231 class OmRatChangeReqArg : public StackMsgArgument {
00232     friend class CommonStackMsgArgsDestroyTableNode;
00233     public:
00234         OmRatChangeReqArg(const RatChangeMode& rat_change_mode);
00235         OmRatChangeReqArg();
00236
00237         static const OmRatChangeReqArg& Cast(const StackMsgArgument& arg);
00238         const RatChangeMode& GetRatChangeMode() const { return m_rat_change_mode; }
00239
00240         enum  {
00241             ID = 2602
00242             };
00243
00244     private:
00245
00246         static void Destroy(StackMsgArgument* arg) { delete ((OmRatChangeReqArg*) arg); }
00247
00248         RatChangeMode m_rat_change_mode;
00249
00250     };
00251
00252 // Inline definitions
00253 inline const OmRatChangeReqArg& OmRatChangeReqArg::Cast(const StackMsgArgument& arg) {
00254     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmRatChangeReqArg!\n");
00255     return ((OmRatChangeReqArg &) arg);
00256 }
00257
00258
00259 #endif // Apc_OmStackMsgArgs_hpp
00260
Generated on Tue Jan 24 14:46:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ParameterIndicator.cpp File Reference

Apc/ParameterIndicator.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/ParameterIndicator.hpp"

Include dependency graph for ParameterIndicator.cpp:

Generated on Tue Jan 24 16:57:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ParameterIndicator.hpp File Reference

Apc/ParameterIndicator.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for ParameterIndicator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ParameterIndicator
3GPP TS 23.040 V5.1.0 [9.2.3.27] More...

Defines

#define | Apc_ParameterIndicator_hpp

Define Documentation

#define Apc_ParameterIndicator_hpp

Generated on Tue Jan 24 16:58:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ParameterIndicator.hpp Source File

Apc/ParameterIndicator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_ParameterIndicator_hpp)
00009 #define Apc_ParameterIndicator_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014
00015 /*  ========================================================================
00016     TP-PI: Transfer Protocol - Parameter Indicator - 3GPP TS 23.040 V5.1.0 [9.2.3.27]
00017     ========================================================================*/
00019 class ParameterIndicator {
00020     public:
00022         ParameterIndicator();
00024         ParameterIndicator(UINT8 incoming_byte, BOOLEAN valid = FALSE);
00026         BOOLEAN IsValid() const { return (m_valid); }
00028         void SetValid(BOOLEAN valid = TRUE) { m_valid = valid; }
00030         UINT8 Get() const;
00032         BOOLEAN ExtensionExists() const;
00034         void SetExtension();
00036         BOOLEAN ProtocolIdentifierExists() const;
00038         void SetProtocolIdentifierExists();
00040         BOOLEAN DataCodingSchemeExists() const;
00042         void SetDataCodingSchemeExists();
00044         BOOLEAN UserDataExists() const;
00046         void SetUserDataExists();
00048         void Clear();
00049
00050     private:
00051         BitField8 m_bit_field;
00052         BOOLEAN m_valid;
00053 };
00054
00055
00056 #endif  // Apc_ParameterIndicator_hpp
00057
00058
Generated on Tue Jan 24 14:46:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PdpTypes.hpp File Reference

Apc/PdpTypes.hpp File Reference

#include <Apc/SignalTypes.hpp>

Include dependency graph for PdpTypes.hpp:

Go to the source code of this file.

Defines

#define | Apc_Gprs_PdpTypes_hpp

Typedefs

typedef T_PCH_REG_CLIENT | PchClient
typedef T_PDP_ADDRESS | PdpAddress
typedef T_PDP_ARRAY | PdpArray
typedef T_ATT_STATE | PdpAttachState
typedef T_AUTH | PdpAuthentification
typedef T_CID | PdpCid
typedef T_CID_ARRAY | PdpCidArray
typedef T_CID_STAT_ARRAY | PdpCidStatArray
typedef T_PDP_CONTEXT | PdpContextData
typedef T_PDP_QOS | PdpQos
typedef T_QOS_ARRAY | PdpQosArray
typedef T_QOS | Qos

Enumerations

enum L2Protocol {
L2Null = L2_NULL, L2Ppp = L2_PPP, L2Pad = L2_PAD, L2X25 = L2_X25,
L2Manuf = L2_MANUF, L2None = L2_NONE
}
enum | PchOrigin { PchNw = PCH_NW, PchMs = PCH_MS }
enum PdpType {
PdpX25Type = X25_TYPE, PdpIpType = IP_TYPE, PdpIpStaticType = IP_TYPE_STATIC, PdpIpDynamicType = IP_TYPE_DYNAMIC,
PdpOspihType = OSPIH_TYPE, PdpPppType = PPP_TYPE, PdpNoType = NO_TYPE
}

Define Documentation

#define Apc_Gprs_PdpTypes_hpp

Typedef Documentation

typedef T_PCH_REG_CLIENT PchClient

typedef T_PDP_ADDRESS PdpAddress

typedef T_PDP_ARRAY PdpArray

typedef T_ATT_STATE PdpAttachState

typedef T_AUTH PdpAuthentification

typedef T_CID PdpCid

typedef T_CID_ARRAY PdpCidArray

typedef T_CID_STAT_ARRAY PdpCidStatArray

typedef T_PDP_CONTEXT PdpContextData

typedef T_PDP_QOS PdpQos

typedef T_QOS_ARRAY PdpQosArray

typedef T_QOS Qos

Enumeration Type Documentation

enum L2Protocol

Enumerator:
L2Null
L2Ppp
L2Pad
L2X25
L2Manuf
L2None

enum PchOrigin

Enumerator:
PchNw
PchMs

enum PdpType

Enumerator:
PdpX25Type
PdpIpType
PdpIpStaticType
PdpIpDynamicType
PdpOspihType
PdpPppType
PdpNoType

Generated on Tue Jan 24 16:58:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PdpTypes.hpp Source File

Apc/PdpTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Gprs_PdpTypes_hpp)
00009 #define Apc_Gprs_PdpTypes_hpp
00010
00011 #include <Apc/SignalTypes.hpp>
00012
00013 typedef T_PCH_REG_CLIENT PchClient;
00014
00015 typedef T_CID PdpCid;
00016
00017 typedef T_ATT_STATE PdpAttachState;
00018
00019 enum L2Protocol {
00020     L2Null = L2_NULL,
00021     L2Ppp = L2_PPP,
00022     L2Pad = L2_PAD,
00023     L2X25 = L2_X25,
00024     L2Manuf = L2_MANUF,
00025     L2None = L2_NONE,
00026 };
00027
00028 typedef T_CID_STAT_ARRAY PdpCidStatArray; // fill up with context data or replace with existing structs (Sockets)
00029
00030 typedef T_CID_ARRAY PdpCidArray;    // fill up with context data or replace with existing structs (Sockets)
00031
00032 typedef T_PDP_CONTEXT PdpContextData;   // fill up with context data or replace with existing structs (Sockets)
00033
00034 typedef T_QOS Qos;  // fill up with context data or replace with existing structs (Sockets)
00035
00036 typedef T_PDP_QOS PdpQos;   // fill up with context data or replace with existing structs (Sockets)
00037
00038 typedef T_AUTH PdpAuthentification; // fill up with context data or replace with existing structs (Sockets)
00039
00040 typedef T_PDP_ARRAY PdpArray;   // fill up with context data or replace with existing structs (Sockets)
00041
00042 typedef T_QOS_ARRAY PdpQosArray;    // fill up with context data or replace with existing structs (Sockets)
00043
00044 enum PdpType {
00045     PdpX25Type = X25_TYPE,
00046     PdpIpType = IP_TYPE,
00047     PdpIpStaticType = IP_TYPE_STATIC,
00048     PdpIpDynamicType = IP_TYPE_DYNAMIC,
00049     PdpOspihType = OSPIH_TYPE,
00050     PdpPppType = PPP_TYPE,
00051     PdpNoType = NO_TYPE
00052 };
00053
00054 typedef T_PDP_ADDRESS PdpAddress;
00055
00056 enum PchOrigin {
00057     PchNw = PCH_NW,
00058     PchMs = PCH_MS
00059 };
00060
00061 #endif  // Apc_Gprs_PdpTypes_hpp
00062
Generated on Tue Jan 24 14:46:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PhoneBookStackMsgArgs.cpp File Reference

Apc/PhoneBookStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "PhoneBookStackMsgArgs.hpp"

Include dependency graph for PhoneBookStackMsgArgs.cpp:

Generated on Tue Jan 24 16:58:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PhoneBookStackMsgArgs.hpp File Reference

Apc/PhoneBookStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/UsimPbTypes.hpp>

Include dependency graph for PhoneBookStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbCountIndArg
class | PbCountReqArg
class | PbEntryReadIndArg
class | PbEntryReadReqArg
class | PbEntryUpdIndArg
class | PbEntryUpdReqArg
class | PbInfoReadIndArg
class | PbInfoReadReqArg
class | UsimPbFillStatusReqArg
class | UsimPbFillStatusResArg
class | UsimPbLocationIndArg
class | UsimPbLocationReqArg
class | UsimPbReadAsyncIndArg
class | UsimPbReadCnfArg
class | UsimPbReadDataAsyncIndArg
class | UsimPbReadDataReqArg
class | UsimPbReadDataResArg
class | UsimPbReadRefAsyncIndArg
class | UsimPbReadRefReqArg
class | UsimPbReadRefResArg
class | UsimPbReadReqArg
class | UsimPbReadResArg
class | UsimPbReadyIndArg
class | UsimPbSelectReqArg
class | UsimPbSelectResArg
class | UsimPbStopReqArg
class | UsimPbStopResArg
class | UsimPbUidRefreshIndArg
class | UsimPbUpdDataReqArg
class | UsimPbUpdDataResArg
class | UsimPbUpdRefReqArg
class | UsimPbUpdRefResArg
class | UsimPbUpdReqArg
class | UsimPbUpdResArg

Defines

#define | Apc_PhoneBookStackMsgArgs_hpp

Define Documentation

#define Apc_PhoneBookStackMsgArgs_hpp

Generated on Tue Jan 24 16:58:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PhoneBookStackMsgArgs.hpp Source File

Apc/PhoneBookStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\grossau_mp1ue_sv\lnz_apoxi\Apoxi\Apc\PhoneBookArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_PhoneBookStackMsgArgs_hpp)
00016 #define Apc_PhoneBookStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Apc/UsimPbTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class PbInfoReadIndArg
00029     ====================================================================== */
00030
00032 class PbInfoReadIndArg : public StackMsgArgument {
00033     friend class CommonStackMsgArgsDestroyTableNode;
00034     public:
00035         PbInfoReadIndArg();
00036
00037         static const PbInfoReadIndArg& Cast(const StackMsgArgument& arg);
00038         void SetInfo(const PhoneBookInfo& info) { m_info = info; }
00039         const PhoneBookInfo& GetInfo() const { return m_info; }
00040
00041         enum  {
00042             ID = 1200
00043             };
00044
00045     private:
00046
00047         static void Destroy(StackMsgArgument* arg) { delete ((PbInfoReadIndArg*) arg); }
00048
00049         PhoneBookInfo m_info;
00050
00051     };
00052
00053 // Inline definitions
00054 inline const PbInfoReadIndArg& PbInfoReadIndArg::Cast(const StackMsgArgument& arg) {
00055     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PbInfoReadIndArg!\n");
00056     return ((PbInfoReadIndArg &) arg);
00057 }
00058
00059
00060
00061 /*  ======================================================================
00062     Class PbEntryReadIndArg
00063     ====================================================================== */
00064
00065 class PbEntryReadIndArg : public StackMsgArgument {
00066     friend class CommonStackMsgArgsDestroyTableNode;
00067     public:
00068         PbEntryReadIndArg();
00069
00070         static const PbEntryReadIndArg& Cast(const StackMsgArgument& arg);
00071         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00072         const SimUpdateStatus& GetStatus() const { return m_status; }
00073         void SetPbtype(const PhoneBookType& pbtype) { m_pbtype = pbtype; }
00074         const PhoneBookType& GetPbtype() const { return m_pbtype; }
00075         void SetRecno(INT recno) { m_recno = recno; }
00076         INT GetRecno() const { return m_recno; }
00077         void SetAlphaLength(INT alpha_length) { m_alpha_length = alpha_length; }
00078         INT GetAlphaLength() const { return m_alpha_length; }
00079         void SetDataLength(INT data_length) { m_data_length = data_length; }
00080         INT GetDataLength() const { return m_data_length; }
00081         void SetEntry(const SimPhoneBookEntry& entry) { m_entry = entry; }
00082         const SimPhoneBookEntry& GetEntry() const { return m_entry; }
00083
00084         enum  {
00085             ID = 1201
00086             };
00087
00088     private:
00089
00090         static void Destroy(StackMsgArgument* arg) { delete ((PbEntryReadIndArg*) arg); }
00091
00092         SimUpdateStatus m_status;
00093         PhoneBookType m_pbtype;
00094         INT m_recno;
00095         INT m_alpha_length;
00096         INT m_data_length;
00097         SimPhoneBookEntry m_entry;
00098
00099     };
00100
00101 // Inline definitions
00102 inline const PbEntryReadIndArg& PbEntryReadIndArg::Cast(const StackMsgArgument& arg) {
00103     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PbEntryReadIndArg!\n");
00104     return ((PbEntryReadIndArg &) arg);
00105 }
00106
00107
00108
00109 /*  ======================================================================
00110     Class PbEntryUpdIndArg
00111     ====================================================================== */
00112
00114 class PbEntryUpdIndArg : public StackMsgArgument {
00115     friend class CommonStackMsgArgsDestroyTableNode;
00116     public:
00117         PbEntryUpdIndArg();
00118
00119         static const PbEntryUpdIndArg& Cast(const StackMsgArgument& arg);
00120         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00121         const SimUpdateStatus& GetStatus() const { return m_status; }
00122
00123         enum  {
00124             ID = 1202
00125             };
00126
00127     private:
00128
00129         static void Destroy(StackMsgArgument* arg) { delete ((PbEntryUpdIndArg*) arg); }
00130
00131         SimUpdateStatus m_status;
00132
00133     };
00134
00135 // Inline definitions
00136 inline const PbEntryUpdIndArg& PbEntryUpdIndArg::Cast(const StackMsgArgument& arg) {
00137     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PbEntryUpdIndArg!\n");
00138     return ((PbEntryUpdIndArg &) arg);
00139 }
00140
00141
00142
00143 /*  ======================================================================
00144     Class PbCountIndArg
00145     ====================================================================== */
00146
00148 class PbCountIndArg : public StackMsgArgument {
00149     friend class CommonStackMsgArgsDestroyTableNode;
00150     public:
00151         PbCountIndArg();
00152
00153         static const PbCountIndArg& Cast(const StackMsgArgument& arg);
00154         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00155         const SimUpdateStatus& GetStatus() const { return m_status; }
00156         void SetPbCntType(const PhoneBookCntType& pb_cnt_type) { m_pb_cnt_type = pb_cnt_type; }
00157         const PhoneBookCntType& GetPbCntType() const { return m_pb_cnt_type; }
00158         void SetCount(UINT8 count) { m_count = count; }
00159         UINT8 GetCount() const { return m_count; }
00160
00161         enum  {
00162             ID = 1203
00163             };
00164
00165     private:
00166
00167         static void Destroy(StackMsgArgument* arg) { delete ((PbCountIndArg*) arg); }
00168
00169         SimUpdateStatus m_status;
00170         PhoneBookCntType m_pb_cnt_type;
00171         UINT8 m_count;
00172
00173     };
00174
00175 // Inline definitions
00176 inline const PbCountIndArg& PbCountIndArg::Cast(const StackMsgArgument& arg) {
00177     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PbCountIndArg!\n");
00178     return ((PbCountIndArg &) arg);
00179 }
00180
00181
00182
00183 /*  ======================================================================
00184     Class UsimPbLocationIndArg
00185     ====================================================================== */
00186
00188 class UsimPbLocationIndArg : public StackMsgArgument {
00189     friend class CommonStackMsgArgsDestroyTableNode;
00190     public:
00191         UsimPbLocationIndArg();
00192
00193         static const UsimPbLocationIndArg& Cast(const StackMsgArgument& arg);
00194         void SetReport(const UsimPbLocReport& report) { m_report = report; }
00195         const UsimPbLocReport& GetReport() const { return m_report; }
00196
00197         enum  {
00198             ID = 1210
00199             };
00200
00201     private:
00202
00203         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbLocationIndArg*) arg); }
00204
00205         UsimPbLocReport m_report;
00206
00207     };
00208
00209 // Inline definitions
00210 inline const UsimPbLocationIndArg& UsimPbLocationIndArg::Cast(const StackMsgArgument& arg) {
00211     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbLocationIndArg!\n");
00212     return ((UsimPbLocationIndArg &) arg);
00213 }
00214
00215
00216
00217 /*  ======================================================================
00218     Class UsimPbSelectResArg
00219     ====================================================================== */
00220
00222 class UsimPbSelectResArg : public StackMsgArgument {
00223     friend class CommonStackMsgArgsDestroyTableNode;
00224     public:
00225         UsimPbSelectResArg();
00226
00227         static const UsimPbSelectResArg& Cast(const StackMsgArgument& arg);
00228         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00229         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00230         void SetPbSignalType(const UsimPbSignalType& pb_signal_type) { m_pb_signal_type = pb_signal_type; }
00231         const UsimPbSignalType& GetPbSignalType() const { return m_pb_signal_type; }
00232         void SetPbLocation(const UsimPbLocation& pb_location) { m_pb_location = pb_location; }
00233         const UsimPbLocation& GetPbLocation() const { return m_pb_location; }
00234         void SetPbDescriptor(const T_PB_DESCRIPTOR& pb_descriptor) { m_pb_descriptor = pb_descriptor; }
00235         const T_PB_DESCRIPTOR& GetPbDescriptor() const { return m_pb_descriptor; }
00236
00237         enum  {
00238             ID = 1211
00239             };
00240
00241     private:
00242
00243         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbSelectResArg*) arg); }
00244
00245         UsimPbResult m_pb_result;
00246         UsimPbSignalType m_pb_signal_type;
00247         UsimPbLocation m_pb_location;
00248         T_PB_DESCRIPTOR m_pb_descriptor;
00249
00250     };
00251
00252 // Inline definitions
00253 inline const UsimPbSelectResArg& UsimPbSelectResArg::Cast(const StackMsgArgument& arg) {
00254     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbSelectResArg!\n");
00255     return ((UsimPbSelectResArg &) arg);
00256 }
00257
00258
00259
00260 /*  ======================================================================
00261     Class UsimPbReadResArg
00262     ====================================================================== */
00263
00265 class UsimPbReadResArg : public StackMsgArgument {
00266     friend class CommonStackMsgArgsDestroyTableNode;
00267     public:
00268         UsimPbReadResArg();
00269
00270         static const UsimPbReadResArg& Cast(const StackMsgArgument& arg);
00271         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00272         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00273         void SetPbSignalType(const UsimPbSignalType& pb_signal_type) { m_pb_signal_type = pb_signal_type; }
00274         const UsimPbSignalType& GetPbSignalType() const { return m_pb_signal_type; }
00275         void SetRecno(INT recno) { m_recno = recno; }
00276         INT GetRecno() const { return m_recno; }
00277         void SetPbRwRecord(const UsimPbRwRecord& pb_rw_record) { m_pb_rw_record = pb_rw_record; }
00278         const UsimPbRwRecord& GetPbRwRecord() const { return m_pb_rw_record; }
00279         void SetPbRefRecord(const UsimPbRefRecord& pb_ref_record) { m_pb_ref_record = pb_ref_record; }
00280         const UsimPbRefRecord& GetPbRefRecord() const { return m_pb_ref_record; }
00281
00282         enum  {
00283             ID = 1212
00284             };
00285
00286     private:
00287
00288         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadResArg*) arg); }
00289
00290         UsimPbResult m_pb_result;
00291         UsimPbSignalType m_pb_signal_type;
00292         INT m_recno;
00293         UsimPbRwRecord m_pb_rw_record;
00294         UsimPbRefRecord m_pb_ref_record;
00295
00296     };
00297
00298 // Inline definitions
00299 inline const UsimPbReadResArg& UsimPbReadResArg::Cast(const StackMsgArgument& arg) {
00300     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadResArg!\n");
00301     return ((UsimPbReadResArg &) arg);
00302 }
00303
00304
00305
00306 /*  ======================================================================
00307     Class UsimPbReadAsyncIndArg
00308     ====================================================================== */
00309
00311 class UsimPbReadAsyncIndArg : public StackMsgArgument {
00312     friend class CommonStackMsgArgsDestroyTableNode;
00313     public:
00314         UsimPbReadAsyncIndArg();
00315
00316         static const UsimPbReadAsyncIndArg& Cast(const StackMsgArgument& arg);
00317         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00318         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00319         void SetPbSignalType(const UsimPbSignalType& pb_signal_type) { m_pb_signal_type = pb_signal_type; }
00320         const UsimPbSignalType& GetPbSignalType() const { return m_pb_signal_type; }
00321         void SetRecno(INT recno) { m_recno = recno; }
00322         INT GetRecno() const { return m_recno; }
00323         void SetPbRwRecord(const UsimPbRwRecord& pb_rw_record) { m_pb_rw_record = pb_rw_record; }
00324         const UsimPbRwRecord& GetPbRwRecord() const { return m_pb_rw_record; }
00325         void SetPbRefRecord(const UsimPbRefRecord& pb_ref_record) { m_pb_ref_record = pb_ref_record; }
00326         const UsimPbRefRecord& GetPbRefRecord() const { return m_pb_ref_record; }
00327
00328         enum  {
00329             ID = 1213
00330             };
00331
00332     private:
00333
00334         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadAsyncIndArg*) arg); }
00335
00336         UsimPbResult m_pb_result;
00337         UsimPbSignalType m_pb_signal_type;
00338         INT m_recno;
00339         UsimPbRwRecord m_pb_rw_record;
00340         UsimPbRefRecord m_pb_ref_record;
00341
00342     };
00343
00344 // Inline definitions
00345 inline const UsimPbReadAsyncIndArg& UsimPbReadAsyncIndArg::Cast(const StackMsgArgument& arg) {
00346     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadAsyncIndArg!\n");
00347     return ((UsimPbReadAsyncIndArg &) arg);
00348 }
00349
00350
00351
00352 /*  ======================================================================
00353     Class UsimPbReadRefResArg
00354     ====================================================================== */
00355
00357 class UsimPbReadRefResArg : public StackMsgArgument {
00358     friend class CommonStackMsgArgsDestroyTableNode;
00359     public:
00360         UsimPbReadRefResArg();
00361
00362         static const UsimPbReadRefResArg& Cast(const StackMsgArgument& arg);
00363         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00364         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00365         void SetPbSignalType(const UsimPbSignalType& pb_signal_type) { m_pb_signal_type = pb_signal_type; }
00366         const UsimPbSignalType& GetPbSignalType() const { return m_pb_signal_type; }
00367         void SetPbRefType(const UsimPbRefType& pb_ref_type) { m_pb_ref_type = pb_ref_type; }
00368         const UsimPbRefType& GetPbRefType() const { return m_pb_ref_type; }
00369         void SetRecno(INT recno) { m_recno = recno; }
00370         INT GetRecno() const { return m_recno; }
00371         void SetRefRecno(INT ref_recno) { m_ref_recno = ref_recno; }
00372         INT GetRefRecno() const { return m_ref_recno; }
00373         void SetHandle(INT handle) { m_handle = handle; }
00374         INT GetHandle() const { return m_handle; }
00375         void SetData(const T_DATA& data) { m_data = data; }
00376         const T_DATA& GetData() const { return m_data; }
00377
00378         enum  {
00379             ID = 1214
00380             };
00381
00382     private:
00383
00384         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadRefResArg*) arg); }
00385
00386         UsimPbResult m_pb_result;
00387         UsimPbSignalType m_pb_signal_type;
00388         UsimPbRefType m_pb_ref_type;
00389         INT m_recno;
00390         INT m_ref_recno;
00391         INT m_handle;
00392         T_DATA m_data;
00393
00394     };
00395
00396 // Inline definitions
00397 inline const UsimPbReadRefResArg& UsimPbReadRefResArg::Cast(const StackMsgArgument& arg) {
00398     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadRefResArg!\n");
00399     return ((UsimPbReadRefResArg &) arg);
00400 }
00401
00402
00403
00404 /*  ======================================================================
00405     Class UsimPbReadRefAsyncIndArg
00406     ====================================================================== */
00407
00409 class UsimPbReadRefAsyncIndArg : public StackMsgArgument {
00410     friend class CommonStackMsgArgsDestroyTableNode;
00411     public:
00412         UsimPbReadRefAsyncIndArg();
00413
00414         static const UsimPbReadRefAsyncIndArg& Cast(const StackMsgArgument& arg);
00415         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00416         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00417         void SetPbSignalType(const UsimPbSignalType& pb_signal_type) { m_pb_signal_type = pb_signal_type; }
00418         const UsimPbSignalType& GetPbSignalType() const { return m_pb_signal_type; }
00419         void SetPbRefType(const UsimPbRefType& pb_ref_type) { m_pb_ref_type = pb_ref_type; }
00420         const UsimPbRefType& GetPbRefType() const { return m_pb_ref_type; }
00421         void SetRecno(INT recno) { m_recno = recno; }
00422         INT GetRecno() const { return m_recno; }
00423         void SetRefRecno(INT ref_recno) { m_ref_recno = ref_recno; }
00424         INT GetRefRecno() const { return m_ref_recno; }
00425         void SetHandle(INT handle) { m_handle = handle; }
00426         INT GetHandle() const { return m_handle; }
00427         void SetData(const T_DATA& data) { m_data = data; }
00428         const T_DATA& GetData() const { return m_data; }
00429
00430         enum  {
00431             ID = 1215
00432             };
00433
00434     private:
00435
00436         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadRefAsyncIndArg*) arg); }
00437
00438         UsimPbResult m_pb_result;
00439         UsimPbSignalType m_pb_signal_type;
00440         UsimPbRefType m_pb_ref_type;
00441         INT m_recno;
00442         INT m_ref_recno;
00443         INT m_handle;
00444         T_DATA m_data;
00445
00446     };
00447
00448 // Inline definitions
00449 inline const UsimPbReadRefAsyncIndArg& UsimPbReadRefAsyncIndArg::Cast(const StackMsgArgument& arg) {
00450     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadRefAsyncIndArg!\n");
00451     return ((UsimPbReadRefAsyncIndArg &) arg);
00452 }
00453
00454
00455
00456 /*  ======================================================================
00457     Class UsimPbReadDataResArg
00458     ====================================================================== */
00459
00461 class UsimPbReadDataResArg : public StackMsgArgument {
00462     friend class CommonStackMsgArgsDestroyTableNode;
00463     public:
00464         UsimPbReadDataResArg();
00465
00466         static const UsimPbReadDataResArg& Cast(const StackMsgArgument& arg);
00467         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00468         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00469         void SetPbSignalType(const UsimPbSignalType& pb_signal_type) { m_pb_signal_type = pb_signal_type; }
00470         const UsimPbSignalType& GetPbSignalType() const { return m_pb_signal_type; }
00471         void SetPbAddType(const UsimPbAddType& pb_add_type) { m_pb_add_type = pb_add_type; }
00472         const UsimPbAddType& GetPbAddType() const { return m_pb_add_type; }
00473         void SetRecno(INT recno) { m_recno = recno; }
00474         INT GetRecno() const { return m_recno; }
00475         void SetHandle(INT handle) { m_handle = handle; }
00476         INT GetHandle() const { return m_handle; }
00477         void SetData(const T_DATA& data) { m_data = data; }
00478         const T_DATA& GetData() const { return m_data; }
00479
00480         enum  {
00481             ID = 1216
00482             };
00483
00484     private:
00485
00486         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadDataResArg*) arg); }
00487
00488         UsimPbResult m_pb_result;
00489         UsimPbSignalType m_pb_signal_type;
00490         UsimPbAddType m_pb_add_type;
00491         INT m_recno;
00492         INT m_handle;
00493         T_DATA m_data;
00494
00495     };
00496
00497 // Inline definitions
00498 inline const UsimPbReadDataResArg& UsimPbReadDataResArg::Cast(const StackMsgArgument& arg) {
00499     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadDataResArg!\n");
00500     return ((UsimPbReadDataResArg &) arg);
00501 }
00502
00503
00504
00505 /*  ======================================================================
00506     Class UsimPbReadDataAsyncIndArg
00507     ====================================================================== */
00508
00510 class UsimPbReadDataAsyncIndArg : public StackMsgArgument {
00511     friend class CommonStackMsgArgsDestroyTableNode;
00512     public:
00513         UsimPbReadDataAsyncIndArg();
00514
00515         static const UsimPbReadDataAsyncIndArg& Cast(const StackMsgArgument& arg);
00516         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00517         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00518         void SetPbSignalType(const UsimPbSignalType& pb_signal_type) { m_pb_signal_type = pb_signal_type; }
00519         const UsimPbSignalType& GetPbSignalType() const { return m_pb_signal_type; }
00520         void SetPbAddType(const UsimPbAddType& pb_add_type) { m_pb_add_type = pb_add_type; }
00521         const UsimPbAddType& GetPbAddType() const { return m_pb_add_type; }
00522         void SetRecno(INT recno) { m_recno = recno; }
00523         INT GetRecno() const { return m_recno; }
00524         void SetHandle(INT handle) { m_handle = handle; }
00525         INT GetHandle() const { return m_handle; }
00526         void SetData(const T_DATA& data) { m_data = data; }
00527         const T_DATA& GetData() const { return m_data; }
00528
00529         enum  {
00530             ID = 1217
00531             };
00532
00533     private:
00534
00535         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadDataAsyncIndArg*) arg); }
00536
00537         UsimPbResult m_pb_result;
00538         UsimPbSignalType m_pb_signal_type;
00539         UsimPbAddType m_pb_add_type;
00540         INT m_recno;
00541         INT m_handle;
00542         T_DATA m_data;
00543
00544     };
00545
00546 // Inline definitions
00547 inline const UsimPbReadDataAsyncIndArg& UsimPbReadDataAsyncIndArg::Cast(const StackMsgArgument& arg) {
00548     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadDataAsyncIndArg!\n");
00549     return ((UsimPbReadDataAsyncIndArg &) arg);
00550 }
00551
00552
00553
00554 /*  ======================================================================
00555     Class UsimPbUpdResArg
00556     ====================================================================== */
00557
00559 class UsimPbUpdResArg : public StackMsgArgument {
00560     friend class CommonStackMsgArgsDestroyTableNode;
00561     public:
00562         UsimPbUpdResArg();
00563
00564         static const UsimPbUpdResArg& Cast(const StackMsgArgument& arg);
00565         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00566         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00567         void SetRecno(INT recno) { m_recno = recno; }
00568         INT GetRecno() const { return m_recno; }
00569         void SetUid(UINT16 uid) { m_uid = uid; }
00570         UINT16 GetUid() const { return m_uid; }
00571
00572         enum  {
00573             ID = 1218
00574             };
00575
00576     private:
00577
00578         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbUpdResArg*) arg); }
00579
00580         UsimPbResult m_pb_result;
00581         INT m_recno;
00582         UINT16 m_uid;
00583
00584     };
00585
00586 // Inline definitions
00587 inline const UsimPbUpdResArg& UsimPbUpdResArg::Cast(const StackMsgArgument& arg) {
00588     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbUpdResArg!\n");
00589     return ((UsimPbUpdResArg &) arg);
00590 }
00591
00592
00593
00594 /*  ======================================================================
00595     Class UsimPbUpdRefResArg
00596     ====================================================================== */
00597
00599 class UsimPbUpdRefResArg : public StackMsgArgument {
00600     friend class CommonStackMsgArgsDestroyTableNode;
00601     public:
00602         UsimPbUpdRefResArg();
00603
00604         static const UsimPbUpdRefResArg& Cast(const StackMsgArgument& arg);
00605         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00606         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00607         void SetPbRefType(const UsimPbRefType& pb_ref_type) { m_pb_ref_type = pb_ref_type; }
00608         const UsimPbRefType& GetPbRefType() const { return m_pb_ref_type; }
00609         void SetRecno(INT recno) { m_recno = recno; }
00610         INT GetRecno() const { return m_recno; }
00611         void SetRefRecno(INT ref_recno) { m_ref_recno = ref_recno; }
00612         INT GetRefRecno() const { return m_ref_recno; }
00613         void SetHandle(INT handle) { m_handle = handle; }
00614         INT GetHandle() const { return m_handle; }
00615
00616         enum  {
00617             ID = 1219
00618             };
00619
00620     private:
00621
00622         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbUpdRefResArg*) arg); }
00623
00624         UsimPbResult m_pb_result;
00625         UsimPbRefType m_pb_ref_type;
00626         INT m_recno;
00627         INT m_ref_recno;
00628         INT m_handle;
00629
00630     };
00631
00632 // Inline definitions
00633 inline const UsimPbUpdRefResArg& UsimPbUpdRefResArg::Cast(const StackMsgArgument& arg) {
00634     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbUpdRefResArg!\n");
00635     return ((UsimPbUpdRefResArg &) arg);
00636 }
00637
00638
00639
00640 /*  ======================================================================
00641     Class UsimPbUpdDataResArg
00642     ====================================================================== */
00643
00645 class UsimPbUpdDataResArg : public StackMsgArgument {
00646     friend class CommonStackMsgArgsDestroyTableNode;
00647     public:
00648         UsimPbUpdDataResArg();
00649
00650         static const UsimPbUpdDataResArg& Cast(const StackMsgArgument& arg);
00651         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00652         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00653         void SetPbAddType(const UsimPbAddType& pb_add_type) { m_pb_add_type = pb_add_type; }
00654         const UsimPbAddType& GetPbAddType() const { return m_pb_add_type; }
00655         void SetHandle(INT handle) { m_handle = handle; }
00656         INT GetHandle() const { return m_handle; }
00657         void SetRecno(INT recno) { m_recno = recno; }
00658         INT GetRecno() const { return m_recno; }
00659
00660         enum  {
00661             ID = 1220
00662             };
00663
00664     private:
00665
00666         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbUpdDataResArg*) arg); }
00667
00668         UsimPbResult m_pb_result;
00669         UsimPbAddType m_pb_add_type;
00670         INT m_handle;
00671         INT m_recno;
00672
00673     };
00674
00675 // Inline definitions
00676 inline const UsimPbUpdDataResArg& UsimPbUpdDataResArg::Cast(const StackMsgArgument& arg) {
00677     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbUpdDataResArg!\n");
00678     return ((UsimPbUpdDataResArg &) arg);
00679 }
00680
00681
00682
00683 /*  ======================================================================
00684     Class UsimPbFillStatusResArg
00685     ====================================================================== */
00686
00688 class UsimPbFillStatusResArg : public StackMsgArgument {
00689     friend class CommonStackMsgArgsDestroyTableNode;
00690     public:
00691         UsimPbFillStatusResArg();
00692
00693         static const UsimPbFillStatusResArg& Cast(const StackMsgArgument& arg);
00694         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00695         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00696         void SetPbSignalType(const UsimPbSignalType& pb_signal_type) { m_pb_signal_type = pb_signal_type; }
00697         const UsimPbSignalType& GetPbSignalType() const { return m_pb_signal_type; }
00698         void SetPbFillStatus(const UsimPbFillStatus& pb_fill_status) { m_pb_fill_status = pb_fill_status; }
00699         const UsimPbFillStatus& GetPbFillStatus() const { return m_pb_fill_status; }
00700
00701         enum  {
00702             ID = 1221
00703             };
00704
00705     private:
00706
00707         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbFillStatusResArg*) arg); }
00708
00709         UsimPbResult m_pb_result;
00710         UsimPbSignalType m_pb_signal_type;
00711         UsimPbFillStatus m_pb_fill_status;
00712
00713     };
00714
00715 // Inline definitions
00716 inline const UsimPbFillStatusResArg& UsimPbFillStatusResArg::Cast(const StackMsgArgument& arg) {
00717     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbFillStatusResArg!\n");
00718     return ((UsimPbFillStatusResArg &) arg);
00719 }
00720
00721
00722
00723 /*  ======================================================================
00724     Class UsimPbStopResArg
00725     ====================================================================== */
00726
00728 class UsimPbStopResArg : public StackMsgArgument {
00729     friend class CommonStackMsgArgsDestroyTableNode;
00730     public:
00731         UsimPbStopResArg();
00732
00733         static const UsimPbStopResArg& Cast(const StackMsgArgument& arg);
00734         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00735         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00736
00737         enum  {
00738             ID = 1222
00739             };
00740
00741     private:
00742
00743         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbStopResArg*) arg); }
00744
00745         UsimPbResult m_pb_result;
00746
00747     };
00748
00749 // Inline definitions
00750 inline const UsimPbStopResArg& UsimPbStopResArg::Cast(const StackMsgArgument& arg) {
00751     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbStopResArg!\n");
00752     return ((UsimPbStopResArg &) arg);
00753 }
00754
00755
00756
00757 /*  ======================================================================
00758     Class UsimPbUidRefreshIndArg
00759     ====================================================================== */
00760
00762 class UsimPbUidRefreshIndArg : public StackMsgArgument {
00763     friend class CommonStackMsgArgsDestroyTableNode;
00764     public:
00765         UsimPbUidRefreshIndArg();
00766
00767         static const UsimPbUidRefreshIndArg& Cast(const StackMsgArgument& arg);
00768
00769         enum  {
00770             ID = 1223
00771             };
00772
00773     private:
00774
00775         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbUidRefreshIndArg*) arg); }
00776
00777     };
00778
00779 // Inline definitions
00780 inline const UsimPbUidRefreshIndArg& UsimPbUidRefreshIndArg::Cast(const StackMsgArgument& arg) {
00781     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbUidRefreshIndArg!\n");
00782     return ((UsimPbUidRefreshIndArg &) arg);
00783 }
00784
00785
00786
00787 /*  ======================================================================
00788     Class UsimPbReadyIndArg
00789     ====================================================================== */
00790
00792 class UsimPbReadyIndArg : public StackMsgArgument {
00793     friend class CommonStackMsgArgsDestroyTableNode;
00794     public:
00795         UsimPbReadyIndArg();
00796
00797         static const UsimPbReadyIndArg& Cast(const StackMsgArgument& arg);
00798         void SetPbResult(const UsimPbResult& pb_result) { m_pb_result = pb_result; }
00799         const UsimPbResult& GetPbResult() const { return m_pb_result; }
00800
00801         enum  {
00802             ID = 1224
00803             };
00804
00805     private:
00806
00807         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadyIndArg*) arg); }
00808
00809         UsimPbResult m_pb_result;
00810
00811     };
00812
00813 // Inline definitions
00814 inline const UsimPbReadyIndArg& UsimPbReadyIndArg::Cast(const StackMsgArgument& arg) {
00815     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadyIndArg!\n");
00816     return ((UsimPbReadyIndArg &) arg);
00817 }
00818
00819
00820
00821 /*  ======================================================================
00822     Class PbInfoReadReqArg
00823     ====================================================================== */
00824
00826 class PbInfoReadReqArg : public StackMsgArgument {
00827     friend class CommonStackMsgArgsDestroyTableNode;
00828     public:
00829         PbInfoReadReqArg();
00830
00831         static const PbInfoReadReqArg& Cast(const StackMsgArgument& arg);
00832
00833         enum  {
00834             ID = 2200
00835             };
00836
00837     private:
00838
00839         static void Destroy(StackMsgArgument* arg) { delete ((PbInfoReadReqArg*) arg); }
00840
00841     };
00842
00843 // Inline definitions
00844 inline const PbInfoReadReqArg& PbInfoReadReqArg::Cast(const StackMsgArgument& arg) {
00845     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PbInfoReadReqArg!\n");
00846     return ((PbInfoReadReqArg &) arg);
00847 }
00848
00849
00850
00851 /*  ======================================================================
00852     Class PbEntryReadReqArg
00853     ====================================================================== */
00854
00856 class PbEntryReadReqArg : public StackMsgArgument {
00857     friend class CommonStackMsgArgsDestroyTableNode;
00858     public:
00859         PbEntryReadReqArg(INT recno, const PhoneBookType& pbtype);
00860         PbEntryReadReqArg();
00861
00862         static const PbEntryReadReqArg& Cast(const StackMsgArgument& arg);
00863         void SetRecno(INT recno) { m_recno = recno; }
00864         INT GetRecno() const { return m_recno; }
00865         void SetPbtype(const PhoneBookType& pbtype) { m_pbtype = pbtype; }
00866         const PhoneBookType& GetPbtype() const { return m_pbtype; }
00867
00868         enum  {
00869             ID = 2201
00870             };
00871
00872     private:
00873
00874         static void Destroy(StackMsgArgument* arg) { delete ((PbEntryReadReqArg*) arg); }
00875
00876         INT m_recno;
00877         PhoneBookType m_pbtype;
00878
00879     };
00880
00881 // Inline definitions
00882 inline const PbEntryReadReqArg& PbEntryReadReqArg::Cast(const StackMsgArgument& arg) {
00883     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PbEntryReadReqArg!\n");
00884     return ((PbEntryReadReqArg &) arg);
00885 }
00886
00887
00888
00889 /*  ======================================================================
00890     Class PbEntryUpdReqArg
00891     ====================================================================== */
00892
00894 class PbEntryUpdReqArg : public StackMsgArgument {
00895     friend class CommonStackMsgArgsDestroyTableNode;
00896     public:
00897         PbEntryUpdReqArg(INT recno, const PhoneBookType& pbtype, INT length, const UINT8* pData);
00898         PbEntryUpdReqArg(INT recno, const PhoneBookType& pbtype, const T_DATA& data);
00899         PbEntryUpdReqArg();
00900
00901         static const PbEntryUpdReqArg& Cast(const StackMsgArgument& arg);
00902         void SetRecno(INT recno) { m_recno = recno; }
00903         INT GetRecno() const { return m_recno; }
00904         void SetPbtype(const PhoneBookType& pbtype) { m_pbtype = pbtype; }
00905         const PhoneBookType& GetPbtype() const { return m_pbtype; }
00906         void SetData(const T_DATA& data) { m_data = data; }
00907         const T_DATA& GetData() const { return m_data; }
00908
00909         enum  {
00910             ID = 2202
00911             };
00912
00913     private:
00914
00915         static void Destroy(StackMsgArgument* arg) { delete ((PbEntryUpdReqArg*) arg); }
00916
00917         INT m_recno;
00918         PhoneBookType m_pbtype;
00919         T_DATA m_data;
00920
00921     };
00922
00923 // Inline definitions
00924 inline const PbEntryUpdReqArg& PbEntryUpdReqArg::Cast(const StackMsgArgument& arg) {
00925     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PbEntryUpdReqArg!\n");
00926     return ((PbEntryUpdReqArg &) arg);
00927 }
00928
00929
00930
00931 /*  ======================================================================
00932     Class PbCountReqArg
00933     ====================================================================== */
00934
00936 class PbCountReqArg : public StackMsgArgument {
00937     friend class CommonStackMsgArgsDestroyTableNode;
00938     public:
00939         PbCountReqArg(const PhoneBookCntType& pb_cnt_type);
00940         PbCountReqArg();
00941
00942         static const PbCountReqArg& Cast(const StackMsgArgument& arg);
00943         void SetPbCntType(const PhoneBookCntType& pb_cnt_type) { m_pb_cnt_type = pb_cnt_type; }
00944         const PhoneBookCntType& GetPbCntType() const { return m_pb_cnt_type; }
00945
00946         enum  {
00947             ID = 2203
00948             };
00949
00950     private:
00951
00952         static void Destroy(StackMsgArgument* arg) { delete ((PbCountReqArg*) arg); }
00953
00954         PhoneBookCntType m_pb_cnt_type;
00955
00956     };
00957
00958 // Inline definitions
00959 inline const PbCountReqArg& PbCountReqArg::Cast(const StackMsgArgument& arg) {
00960     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PbCountReqArg!\n");
00961     return ((PbCountReqArg &) arg);
00962 }
00963
00964
00965
00966 /*  ======================================================================
00967     Class UsimPbLocationReqArg
00968     ====================================================================== */
00969
00971 class UsimPbLocationReqArg : public StackMsgArgument {
00972     friend class CommonStackMsgArgsDestroyTableNode;
00973     public:
00974         UsimPbLocationReqArg();
00975
00976         static const UsimPbLocationReqArg& Cast(const StackMsgArgument& arg);
00977
00978         enum  {
00979             ID = 2210
00980             };
00981
00982     private:
00983
00984         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbLocationReqArg*) arg); }
00985
00986     };
00987
00988 // Inline definitions
00989 inline const UsimPbLocationReqArg& UsimPbLocationReqArg::Cast(const StackMsgArgument& arg) {
00990     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbLocationReqArg!\n");
00991     return ((UsimPbLocationReqArg &) arg);
00992 }
00993
00994
00995
00996 /*  ======================================================================
00997     Class UsimPbSelectReqArg
00998     ====================================================================== */
00999
01001 class UsimPbSelectReqArg : public StackMsgArgument {
01002     friend class CommonStackMsgArgsDestroyTableNode;
01003     public:
01004         UsimPbSelectReqArg(const UsimPbLocation& pb_location, BOOLEAN cache_filling);
01005         UsimPbSelectReqArg();
01006
01007         static const UsimPbSelectReqArg& Cast(const StackMsgArgument& arg);
01008         void SetPbLocation(const UsimPbLocation& pb_location) { m_pb_location = pb_location; }
01009         const UsimPbLocation& GetPbLocation() const { return m_pb_location; }
01010         void SetCacheFilling(BOOLEAN cache_filling) { m_cache_filling = cache_filling; }
01011         BOOLEAN IsCacheFilling() const { return m_cache_filling; }
01012
01013         enum  {
01014             ID = 2211
01015             };
01016
01017     private:
01018
01019         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbSelectReqArg*) arg); }
01020
01021         UsimPbLocation m_pb_location;
01022         BOOLEAN m_cache_filling;
01023
01024     };
01025
01026 // Inline definitions
01027 inline const UsimPbSelectReqArg& UsimPbSelectReqArg::Cast(const StackMsgArgument& arg) {
01028     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbSelectReqArg!\n");
01029     return ((UsimPbSelectReqArg &) arg);
01030 }
01031
01032
01033
01034 /*  ======================================================================
01035     Class UsimPbReadReqArg
01036     ====================================================================== */
01037
01039 class UsimPbReadReqArg : public StackMsgArgument {
01040     friend class CommonStackMsgArgsDestroyTableNode;
01041     public:
01042         UsimPbReadReqArg(INT recno, const UsimPbRwRecord& pb_rw_record);
01043         UsimPbReadReqArg();
01044
01045         static const UsimPbReadReqArg& Cast(const StackMsgArgument& arg);
01046         void SetRecno(INT recno) { m_recno = recno; }
01047         INT GetRecno() const { return m_recno; }
01048         void SetPbRwRecord(const UsimPbRwRecord& pb_rw_record) { m_pb_rw_record = pb_rw_record; }
01049         const UsimPbRwRecord& GetPbRwRecord() const { return m_pb_rw_record; }
01050
01051         enum  {
01052             ID = 2212
01053             };
01054
01055     private:
01056
01057         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadReqArg*) arg); }
01058
01059         INT m_recno;
01060         UsimPbRwRecord m_pb_rw_record;
01061
01062     };
01063
01064 // Inline definitions
01065 inline const UsimPbReadReqArg& UsimPbReadReqArg::Cast(const StackMsgArgument& arg) {
01066     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadReqArg!\n");
01067     return ((UsimPbReadReqArg &) arg);
01068 }
01069
01070
01071
01072 /*  ======================================================================
01073     Class UsimPbReadRefReqArg
01074     ====================================================================== */
01075
01077 class UsimPbReadRefReqArg : public StackMsgArgument {
01078     friend class CommonStackMsgArgsDestroyTableNode;
01079     public:
01080         UsimPbReadRefReqArg(const UsimPbRefType& pb_ref_type, INT recno, INT ref_recno, INT handle, const T_DATA& data);
01081         UsimPbReadRefReqArg();
01082
01083         static const UsimPbReadRefReqArg& Cast(const StackMsgArgument& arg);
01084         void SetPbRefType(const UsimPbRefType& pb_ref_type) { m_pb_ref_type = pb_ref_type; }
01085         const UsimPbRefType& GetPbRefType() const { return m_pb_ref_type; }
01086         void SetRecno(INT recno) { m_recno = recno; }
01087         INT GetRecno() const { return m_recno; }
01088         void SetRefRecno(INT ref_recno) { m_ref_recno = ref_recno; }
01089         INT GetRefRecno() const { return m_ref_recno; }
01090         void SetHandle(INT handle) { m_handle = handle; }
01091         INT GetHandle() const { return m_handle; }
01092         void SetData(const T_DATA& data) { m_data = data; }
01093         const T_DATA& GetData() const { return m_data; }
01094
01095         enum  {
01096             ID = 2213
01097             };
01098
01099     private:
01100
01101         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadRefReqArg*) arg); }
01102
01103         UsimPbRefType m_pb_ref_type;
01104         INT m_recno;
01105         INT m_ref_recno;
01106         INT m_handle;
01107         T_DATA m_data;
01108
01109     };
01110
01111 // Inline definitions
01112 inline const UsimPbReadRefReqArg& UsimPbReadRefReqArg::Cast(const StackMsgArgument& arg) {
01113     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadRefReqArg!\n");
01114     return ((UsimPbReadRefReqArg &) arg);
01115 }
01116
01117
01118
01119 /*  ======================================================================
01120     Class UsimPbReadDataReqArg
01121     ====================================================================== */
01122
01124 class UsimPbReadDataReqArg : public StackMsgArgument {
01125     friend class CommonStackMsgArgsDestroyTableNode;
01126     public:
01127         UsimPbReadDataReqArg(const UsimPbAddType& pb_add_type, INT recno, INT handle, const T_DATA& data);
01128         UsimPbReadDataReqArg();
01129
01130         static const UsimPbReadDataReqArg& Cast(const StackMsgArgument& arg);
01131         void SetPbAddType(const UsimPbAddType& pb_add_type) { m_pb_add_type = pb_add_type; }
01132         const UsimPbAddType& GetPbAddType() const { return m_pb_add_type; }
01133         void SetRecno(INT recno) { m_recno = recno; }
01134         INT GetRecno() const { return m_recno; }
01135         void SetHandle(INT handle) { m_handle = handle; }
01136         INT GetHandle() const { return m_handle; }
01137         void SetData(const T_DATA& data) { m_data = data; }
01138         const T_DATA& GetData() const { return m_data; }
01139
01140         enum  {
01141             ID = 2214
01142             };
01143
01144     private:
01145
01146         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadDataReqArg*) arg); }
01147
01148         UsimPbAddType m_pb_add_type;
01149         INT m_recno;
01150         INT m_handle;
01151         T_DATA m_data;
01152
01153     };
01154
01155 // Inline definitions
01156 inline const UsimPbReadDataReqArg& UsimPbReadDataReqArg::Cast(const StackMsgArgument& arg) {
01157     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadDataReqArg!\n");
01158     return ((UsimPbReadDataReqArg &) arg);
01159 }
01160
01161
01162
01163 /*  ======================================================================
01164     Class UsimPbUpdReqArg
01165     ====================================================================== */
01166
01168 class UsimPbUpdReqArg : public StackMsgArgument {
01169     friend class CommonStackMsgArgsDestroyTableNode;
01170     public:
01171         UsimPbUpdReqArg(INT recno, INT start_recno, const UsimPbChangedField& pb_changed_field, const UsimPbRwRecord& pb_rw_record);
01172         UsimPbUpdReqArg();
01173
01174         static const UsimPbUpdReqArg& Cast(const StackMsgArgument& arg);
01175         void SetRecno(INT recno) { m_recno = recno; }
01176         INT GetRecno() const { return m_recno; }
01177         void SetStartRecno(INT start_recno) { m_start_recno = start_recno; }
01178         INT GetStartRecno() const { return m_start_recno; }
01179         void SetPbChangedField(const UsimPbChangedField& pb_changed_field) { m_pb_changed_field = pb_changed_field; }
01180         const UsimPbChangedField& GetPbChangedField() const { return m_pb_changed_field; }
01181         void SetPbRwRecord(const UsimPbRwRecord& pb_rw_record) { m_pb_rw_record = pb_rw_record; }
01182         const UsimPbRwRecord& GetPbRwRecord() const { return m_pb_rw_record; }
01183
01184         enum  {
01185             ID = 2215
01186             };
01187
01188     private:
01189
01190         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbUpdReqArg*) arg); }
01191
01192         INT m_recno;
01193         INT m_start_recno;
01194         UsimPbChangedField m_pb_changed_field;
01195         UsimPbRwRecord m_pb_rw_record;
01196
01197     };
01198
01199 // Inline definitions
01200 inline const UsimPbUpdReqArg& UsimPbUpdReqArg::Cast(const StackMsgArgument& arg) {
01201     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbUpdReqArg!\n");
01202     return ((UsimPbUpdReqArg &) arg);
01203 }
01204
01205
01206
01207 /*  ======================================================================
01208     Class UsimPbUpdRefReqArg
01209     ====================================================================== */
01210
01212 class UsimPbUpdRefReqArg : public StackMsgArgument {
01213     friend class CommonStackMsgArgsDestroyTableNode;
01214     public:
01215         UsimPbUpdRefReqArg(const UsimPbRefType& pb_ref_type, INT recno, INT ref_recno, INT handle, const T_DATA& data);
01216         UsimPbUpdRefReqArg();
01217
01218         static const UsimPbUpdRefReqArg& Cast(const StackMsgArgument& arg);
01219         void SetPbRefType(const UsimPbRefType& pb_ref_type) { m_pb_ref_type = pb_ref_type; }
01220         const UsimPbRefType& GetPbRefType() const { return m_pb_ref_type; }
01221         void SetRecno(INT recno) { m_recno = recno; }
01222         INT GetRecno() const { return m_recno; }
01223         void SetRefRecno(INT ref_recno) { m_ref_recno = ref_recno; }
01224         INT GetRefRecno() const { return m_ref_recno; }
01225         void SetHandle(INT handle) { m_handle = handle; }
01226         INT GetHandle() const { return m_handle; }
01227         void SetData(const T_DATA& data) { m_data = data; }
01228         const T_DATA& GetData() const { return m_data; }
01229
01230         enum  {
01231             ID = 2216
01232             };
01233
01234     private:
01235
01236         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbUpdRefReqArg*) arg); }
01237
01238         UsimPbRefType m_pb_ref_type;
01239         INT m_recno;
01240         INT m_ref_recno;
01241         INT m_handle;
01242         T_DATA m_data;
01243
01244     };
01245
01246 // Inline definitions
01247 inline const UsimPbUpdRefReqArg& UsimPbUpdRefReqArg::Cast(const StackMsgArgument& arg) {
01248     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbUpdRefReqArg!\n");
01249     return ((UsimPbUpdRefReqArg &) arg);
01250 }
01251
01252
01253
01254 /*  ======================================================================
01255     Class UsimPbUpdDataReqArg
01256     ====================================================================== */
01257
01259 class UsimPbUpdDataReqArg : public StackMsgArgument {
01260     friend class CommonStackMsgArgsDestroyTableNode;
01261     public:
01262         UsimPbUpdDataReqArg(const UsimPbAddType& pb_add_type, INT handle, INT recno, const T_DATA& data);
01263         UsimPbUpdDataReqArg();
01264
01265         static const UsimPbUpdDataReqArg& Cast(const StackMsgArgument& arg);
01266         void SetPbAddType(const UsimPbAddType& pb_add_type) { m_pb_add_type = pb_add_type; }
01267         const UsimPbAddType& GetPbAddType() const { return m_pb_add_type; }
01268         void SetHandle(INT handle) { m_handle = handle; }
01269         INT GetHandle() const { return m_handle; }
01270         void SetRecno(INT recno) { m_recno = recno; }
01271         INT GetRecno() const { return m_recno; }
01272         void SetData(const T_DATA& data) { m_data = data; }
01273         const T_DATA& GetData() const { return m_data; }
01274
01275         enum  {
01276             ID = 2217
01277             };
01278
01279     private:
01280
01281         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbUpdDataReqArg*) arg); }
01282
01283         UsimPbAddType m_pb_add_type;
01284         INT m_handle;
01285         INT m_recno;
01286         T_DATA m_data;
01287
01288     };
01289
01290 // Inline definitions
01291 inline const UsimPbUpdDataReqArg& UsimPbUpdDataReqArg::Cast(const StackMsgArgument& arg) {
01292     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbUpdDataReqArg!\n");
01293     return ((UsimPbUpdDataReqArg &) arg);
01294 }
01295
01296
01297
01298 /*  ======================================================================
01299     Class UsimPbFillStatusReqArg
01300     ====================================================================== */
01301
01303 class UsimPbFillStatusReqArg : public StackMsgArgument {
01304     friend class CommonStackMsgArgsDestroyTableNode;
01305     public:
01306         UsimPbFillStatusReqArg();
01307
01308         static const UsimPbFillStatusReqArg& Cast(const StackMsgArgument& arg);
01309
01310         enum  {
01311             ID = 2218
01312             };
01313
01314     private:
01315
01316         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbFillStatusReqArg*) arg); }
01317
01318     };
01319
01320 // Inline definitions
01321 inline const UsimPbFillStatusReqArg& UsimPbFillStatusReqArg::Cast(const StackMsgArgument& arg) {
01322     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbFillStatusReqArg!\n");
01323     return ((UsimPbFillStatusReqArg &) arg);
01324 }
01325
01326
01327
01328 /*  ======================================================================
01329     Class UsimPbStopReqArg
01330     ====================================================================== */
01331
01333 class UsimPbStopReqArg : public StackMsgArgument {
01334     friend class CommonStackMsgArgsDestroyTableNode;
01335     public:
01336         UsimPbStopReqArg();
01337
01338         static const UsimPbStopReqArg& Cast(const StackMsgArgument& arg);
01339
01340         enum  {
01341             ID = 2219
01342             };
01343
01344     private:
01345
01346         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbStopReqArg*) arg); }
01347
01348     };
01349
01350 // Inline definitions
01351 inline const UsimPbStopReqArg& UsimPbStopReqArg::Cast(const StackMsgArgument& arg) {
01352     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbStopReqArg!\n");
01353     return ((UsimPbStopReqArg &) arg);
01354 }
01355
01356
01357
01358 /*  ======================================================================
01359     Class UsimPbReadCnfArg
01360     ====================================================================== */
01361
01363 class UsimPbReadCnfArg : public StackMsgArgument {
01364     friend class CommonStackMsgArgsDestroyTableNode;
01365     public:
01366         UsimPbReadCnfArg();
01367
01368         static const UsimPbReadCnfArg& Cast(const StackMsgArgument& arg);
01369
01370         enum  {
01371             ID = 2220
01372             };
01373
01374     private:
01375
01376         static void Destroy(StackMsgArgument* arg) { delete ((UsimPbReadCnfArg*) arg); }
01377
01378     };
01379
01380 // Inline definitions
01381 inline const UsimPbReadCnfArg& UsimPbReadCnfArg::Cast(const StackMsgArgument& arg) {
01382     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPbReadCnfArg!\n");
01383     return ((UsimPbReadCnfArg &) arg);
01384 }
01385
01386
01387 #endif // Apc_PhoneBookStackMsgArgs_hpp
01388
Generated on Tue Jan 24 14:46:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PlmnScanList.cpp File Reference

Apc/PlmnScanList.cpp File Reference

#include "Apc/PreComp.hpp"
#include "PlmnScanList.hpp"

Include dependency graph for PlmnScanList.cpp:

Generated on Tue Jan 24 16:58:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PlmnScanList.hpp File Reference

Apc/PlmnScanList.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/ElementList.hpp>
#include <Apc/NetworkTypes.hpp>

Include dependency graph for PlmnScanList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PlmnListEntry
plmn list entry (ms.h: T_SEL_SINGLE_PLMN) More...

Defines

#define | Apc_PlmnScanList_hpp

Typedefs

typedef SortedElementList<
PlmnListEntry > 		PlmnScanList
plmn scan list (ms.h: T_SEL_PLMNS)

Define Documentation

#define Apc_PlmnScanList_hpp

Typedef Documentation

typedef SortedElementList<PlmnListEntry> PlmnScanList

plmn scan list (ms.h: T_SEL_PLMNS)

Generated on Tue Jan 24 16:58:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PlmnScanList.hpp Source File

Apc/PlmnScanList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_PlmnScanList_hpp)
00009 #define Apc_PlmnScanList_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/Linkable.hpp>
00013 #include <Auxiliary/ElementList.hpp>
00014
00015 #include <Apc/NetworkTypes.hpp>
00016
00017
00019 class PlmnListEntry : public Linkable<PlmnListEntry> {
00020     public:
00022         PlmnListEntry();
00024         virtual ~PlmnListEntry();
00026         BOOLEAN operator <(const PlmnListEntry &plmn_list_entry) const;
00028         BOOLEAN operator==(const PlmnListEntry &plmn_list_entry) const;
00030         void Init(const Plmn &plmn, PlmnForbiddenIndicator f_ind, PlmnPlacementIndicator p_ind, RadioAccessTechnology rat);
00032         const Plmn& GetPlmn() const { return (m_plmn); }
00034         RadioAccessTechnology GetRadioAccessTechnology() const { return (m_rat); }
00036         BOOLEAN IsForbidden() const { return (m_forbidden_indicator == PLMN_FORBIDDEN); }
00038         INT GetPos() const { return ((INT)  m_placement_indicator); }
00039
00040     private:
00041         Plmn                    m_plmn;
00042         PlmnForbiddenIndicator  m_forbidden_indicator;
00043         PlmnPlacementIndicator  m_placement_indicator;
00044         RadioAccessTechnology   m_rat;
00045 };
00046
00048 typedef SortedElementList<PlmnListEntry> PlmnScanList;
00049
00050
00051 #endif  // Apc_PlmnScanList_hpp
00052
00053
Generated on Tue Jan 24 14:46:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PlmnStackMsgArgs.cpp File Reference

Apc/PlmnStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "PlmnStackMsgArgs.hpp"

Include dependency graph for PlmnStackMsgArgs.cpp:

Generated on Tue Jan 24 16:58:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PlmnStackMsgArgs.hpp File Reference

Apc/PlmnStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Apc/PlmnScanList.hpp>

Include dependency graph for PlmnStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AttachAllowedIndArg
class | AttachCnfArg
class | AttachRejArg
class | AttachReqArg
class | DetachCnfArg
class | DetachReqArg
class | GprsClassIndArg
class | GprsClassReqArg
class | NRegStateIndArg
class | PlmnInfoReqArg
class | PlmnListAbortArg
class | PlmnListCnfArg
class | PlmnListRejArg
class | PlmnListReqArg
class | PrefPlmnChangeArg
class | PrefServiceSetReqArg
class | RegStateIndArg

Defines

#define | Apc_PlmnStackMsgArgs_hpp

Define Documentation

#define Apc_PlmnStackMsgArgs_hpp

Generated on Tue Jan 24 16:58:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PlmnStackMsgArgs.hpp Source File

Apc/PlmnStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "auzinger_view_latest\lnz_apoxi\Apoxi\Apc\PlmnArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_PlmnStackMsgArgs_hpp)
00016 #define Apc_PlmnStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/NetworkTypes.hpp>
00020 #include <Apc/PlmnScanList.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class PlmnListCnfArg
00029     ====================================================================== */
00030
00032 class PlmnListCnfArg : public StackMsgArgument {
00033     friend class CommonStackMsgArgsDestroyTableNode;
00034     public:
00035         PlmnListCnfArg();
00036
00037         static const PlmnListCnfArg& Cast(const StackMsgArgument& arg);
00038         void SetPlmnScanList(const PlmnScanList& plmn_scan_list) { m_plmn_scan_list = plmn_scan_list; }
00039         const PlmnScanList& GetPlmnScanList() const { return m_plmn_scan_list; }
00040
00041         enum  {
00042             ID = 1360
00043             };
00044
00045     private:
00046
00047         static void Destroy(StackMsgArgument* arg) { delete ((PlmnListCnfArg*) arg); }
00048
00049         PlmnScanList m_plmn_scan_list;
00050
00051     };
00052
00053 // Inline definitions
00054 inline const PlmnListCnfArg& PlmnListCnfArg::Cast(const StackMsgArgument& arg) {
00055     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PlmnListCnfArg!\n");
00056     return ((PlmnListCnfArg &) arg);
00057 }
00058
00059
00060
00061 /*  ======================================================================
00062     Class PlmnListRejArg
00063     ====================================================================== */
00064
00065 class PlmnListRejArg : public StackMsgArgument {
00066     friend class CommonStackMsgArgsDestroyTableNode;
00067     public:
00068         PlmnListRejArg();
00069
00070         static const PlmnListRejArg& Cast(const StackMsgArgument& arg);
00071
00072         enum  {
00073             ID = 1361
00074             };
00075
00076     private:
00077
00078         static void Destroy(StackMsgArgument* arg) { delete ((PlmnListRejArg*) arg); }
00079
00080     };
00081
00082 // Inline definitions
00083 inline const PlmnListRejArg& PlmnListRejArg::Cast(const StackMsgArgument& arg) {
00084     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PlmnListRejArg!\n");
00085     return ((PlmnListRejArg &) arg);
00086 }
00087
00088
00089
00090 /*  ======================================================================
00091     Class NRegStateIndArg
00092     ====================================================================== */
00093
00095 class NRegStateIndArg : public StackMsgArgument {
00096     friend class CommonStackMsgArgsDestroyTableNode;
00097     public:
00098         NRegStateIndArg();
00099
00100         static const NRegStateIndArg& Cast(const StackMsgArgument& arg);
00101         void SetStatus(const RegisterStatus& status) { m_status = status; }
00102         const RegisterStatus& GetStatus() const { return m_status; }
00103         void SetCause(const RegisterRejectCause& cause) { m_cause = cause; }
00104         const RegisterRejectCause& GetCause() const { return m_cause; }
00105         void SetGsmErrorCause(const GsmErrorCause& gsm_error_cause) { m_gsm_error_cause = gsm_error_cause; }
00106         const GsmErrorCause& GetGsmErrorCause() const { return m_gsm_error_cause; }
00107         void SetPlmnSearchActive(BOOLEAN plmn_search_active) { m_plmn_search_active = plmn_search_active; }
00108         BOOLEAN IsPlmnSearchActive() const { return m_plmn_search_active; }
00109         void SetRadioAccessTechnology(const RadioAccessTechnology& radio_access_technology) { m_radio_access_technology = radio_access_technology; }
00110         const RadioAccessTechnology& GetRadioAccessTechnology() const { return m_radio_access_technology; }
00111         void SetGsmBand(const GsmBand& gsm_band) { m_gsm_band = gsm_band; }
00112         const GsmBand& GetGsmBand() const { return m_gsm_band; }
00113         void SetPlmn(const Plmn& plmn) { m_plmn = plmn; }
00114         const Plmn& GetPlmn() const { return m_plmn; }
00115
00116         enum  {
00117             ID = 5360
00118             };
00119
00120     private:
00121
00122         static void Destroy(StackMsgArgument* arg) { delete ((NRegStateIndArg*) arg); }
00123
00124         RegisterStatus m_status;
00125         RegisterRejectCause m_cause;
00126         GsmErrorCause m_gsm_error_cause;
00127         BOOLEAN m_plmn_search_active;
00128         RadioAccessTechnology m_radio_access_technology;
00129         GsmBand m_gsm_band;
00130         Plmn m_plmn;
00131
00132     };
00133
00134 // Inline definitions
00135 inline const NRegStateIndArg& NRegStateIndArg::Cast(const StackMsgArgument& arg) {
00136     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to NRegStateIndArg!\n");
00137     return ((NRegStateIndArg &) arg);
00138 }
00139
00140
00141
00142 /*  ======================================================================
00143     Class RegStateIndArg
00144     ====================================================================== */
00145
00147 class RegStateIndArg : public StackMsgArgument {
00148     friend class CommonStackMsgArgsDestroyTableNode;
00149     public:
00150         RegStateIndArg();
00151
00152         static const RegStateIndArg& Cast(const StackMsgArgument& arg);
00153         void SetPlmn(const Plmn& plmn) { m_plmn = plmn; }
00154         const Plmn& GetPlmn() const { return m_plmn; }
00155         void SetMode(const RegisterMode& mode) { m_mode = mode; }
00156         const RegisterMode& GetMode() const { return m_mode; }
00157         void SetRadioAccessTechnology(const RadioAccessTechnology& radio_access_technology) { m_radio_access_technology = radio_access_technology; }
00158         const RadioAccessTechnology& GetRadioAccessTechnology() const { return m_radio_access_technology; }
00159         void SetGsmBand(const GsmBand& gsm_band) { m_gsm_band = gsm_band; }
00160         const GsmBand& GetGsmBand() const { return m_gsm_band; }
00161
00162         enum  {
00163             ID = 5361
00164             };
00165
00166     private:
00167
00168         static void Destroy(StackMsgArgument* arg) { delete ((RegStateIndArg*) arg); }
00169
00170         Plmn m_plmn;
00171         RegisterMode m_mode;
00172         RadioAccessTechnology m_radio_access_technology;
00173         GsmBand m_gsm_band;
00174
00175     };
00176
00177 // Inline definitions
00178 inline const RegStateIndArg& RegStateIndArg::Cast(const StackMsgArgument& arg) {
00179     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to RegStateIndArg!\n");
00180     return ((RegStateIndArg &) arg);
00181 }
00182
00183
00184
00185 /*  ======================================================================
00186     Class AttachCnfArg
00187     ====================================================================== */
00188
00190 class AttachCnfArg : public StackMsgArgument {
00191     friend class CommonStackMsgArgsDestroyTableNode;
00192     public:
00193         AttachCnfArg();
00194
00195         static const AttachCnfArg& Cast(const StackMsgArgument& arg);
00196         void SetPlmn(const Plmn& plmn) { m_plmn = plmn; }
00197         const Plmn& GetPlmn() const { return m_plmn; }
00198         void SetMode(const RegisterMode& mode) { m_mode = mode; }
00199         const RegisterMode& GetMode() const { return m_mode; }
00200         void SetRadioAccessTechnology(const RadioAccessTechnology& radio_access_technology) { m_radio_access_technology = radio_access_technology; }
00201         const RadioAccessTechnology& GetRadioAccessTechnology() const { return m_radio_access_technology; }
00202         void SetGsmBand(const GsmBand& gsm_band) { m_gsm_band = gsm_band; }
00203         const GsmBand& GetGsmBand() const { return m_gsm_band; }
00204
00205         enum  {
00206             ID = 5362
00207             };
00208
00209     private:
00210
00211         static void Destroy(StackMsgArgument* arg) { delete ((AttachCnfArg*) arg); }
00212
00213         Plmn m_plmn;
00214         RegisterMode m_mode;
00215         RadioAccessTechnology m_radio_access_technology;
00216         GsmBand m_gsm_band;
00217
00218     };
00219
00220 // Inline definitions
00221 inline const AttachCnfArg& AttachCnfArg::Cast(const StackMsgArgument& arg) {
00222     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AttachCnfArg!\n");
00223     return ((AttachCnfArg &) arg);
00224 }
00225
00226
00227
00228 /*  ======================================================================
00229     Class AttachRejArg
00230     ====================================================================== */
00231
00233 class AttachRejArg : public StackMsgArgument {
00234     friend class CommonStackMsgArgsDestroyTableNode;
00235     public:
00236         AttachRejArg();
00237
00238         static const AttachRejArg& Cast(const StackMsgArgument& arg);
00239         void SetCause(const RegisterRejectCause& cause) { m_cause = cause; }
00240         const RegisterRejectCause& GetCause() const { return m_cause; }
00241
00242         enum  {
00243             ID = 5363
00244             };
00245
00246     private:
00247
00248         static void Destroy(StackMsgArgument* arg) { delete ((AttachRejArg*) arg); }
00249
00250         RegisterRejectCause m_cause;
00251
00252     };
00253
00254 // Inline definitions
00255 inline const AttachRejArg& AttachRejArg::Cast(const StackMsgArgument& arg) {
00256     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AttachRejArg!\n");
00257     return ((AttachRejArg &) arg);
00258 }
00259
00260
00261
00262 /*  ======================================================================
00263     Class DetachCnfArg
00264     ====================================================================== */
00265
00267 class DetachCnfArg : public StackMsgArgument {
00268     friend class CommonStackMsgArgsDestroyTableNode;
00269     public:
00270         DetachCnfArg();
00271
00272         static const DetachCnfArg& Cast(const StackMsgArgument& arg);
00273         void SetStatus(const RegisterStatus& status) { m_status = status; }
00274         const RegisterStatus& GetStatus() const { return m_status; }
00275         void SetCause(const UserCause& cause) { m_cause = cause; }
00276         const UserCause& GetCause() const { return m_cause; }
00277
00278         enum  {
00279             ID = 5364
00280             };
00281
00282     private:
00283
00284         static void Destroy(StackMsgArgument* arg) { delete ((DetachCnfArg*) arg); }
00285
00286         RegisterStatus m_status;
00287         UserCause m_cause;
00288
00289     };
00290
00291 // Inline definitions
00292 inline const DetachCnfArg& DetachCnfArg::Cast(const StackMsgArgument& arg) {
00293     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DetachCnfArg!\n");
00294     return ((DetachCnfArg &) arg);
00295 }
00296
00297
00298
00299 /*  ======================================================================
00300     Class AttachAllowedIndArg
00301     ====================================================================== */
00302
00304 class AttachAllowedIndArg : public StackMsgArgument {
00305     friend class CommonStackMsgArgsDestroyTableNode;
00306     public:
00307         AttachAllowedIndArg();
00308
00309         static const AttachAllowedIndArg& Cast(const StackMsgArgument& arg);
00310         void SetAllowed(BOOLEAN allowed) { m_allowed = allowed; }
00311         BOOLEAN IsAllowed() const { return m_allowed; }
00312
00313         enum  {
00314             ID = 5365
00315             };
00316
00317     private:
00318
00319         static void Destroy(StackMsgArgument* arg) { delete ((AttachAllowedIndArg*) arg); }
00320
00321         BOOLEAN m_allowed;
00322
00323     };
00324
00325 // Inline definitions
00326 inline const AttachAllowedIndArg& AttachAllowedIndArg::Cast(const StackMsgArgument& arg) {
00327     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AttachAllowedIndArg!\n");
00328     return ((AttachAllowedIndArg &) arg);
00329 }
00330
00331
00332
00333 /*  ======================================================================
00334     Class GprsClassIndArg
00335     ====================================================================== */
00336
00338 class GprsClassIndArg : public StackMsgArgument {
00339     friend class CommonStackMsgArgsDestroyTableNode;
00340     public:
00341         GprsClassIndArg();
00342
00343         static const GprsClassIndArg& Cast(const StackMsgArgument& arg);
00344         void SetGprsClass(const GprsClass& gprs_class) { m_gprs_class = gprs_class; }
00345         const GprsClass& GetGprsClass() const { return m_gprs_class; }
00346         void SetProcessSource(const ProcessSource& process_source) { m_process_source = process_source; }
00347         const ProcessSource& GetProcessSource() const { return m_process_source; }
00348
00349         enum  {
00350             ID = 5366
00351             };
00352
00353     private:
00354
00355         static void Destroy(StackMsgArgument* arg) { delete ((GprsClassIndArg*) arg); }
00356
00357         GprsClass m_gprs_class;
00358         ProcessSource m_process_source;
00359
00360     };
00361
00362 // Inline definitions
00363 inline const GprsClassIndArg& GprsClassIndArg::Cast(const StackMsgArgument& arg) {
00364     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to GprsClassIndArg!\n");
00365     return ((GprsClassIndArg &) arg);
00366 }
00367
00368
00369
00370 /*  ======================================================================
00371     Class PlmnListAbortArg
00372     ====================================================================== */
00373
00375 class PlmnListAbortArg : public StackMsgArgument {
00376     friend class CommonStackMsgArgsDestroyTableNode;
00377     public:
00378         PlmnListAbortArg();
00379
00380         static const PlmnListAbortArg& Cast(const StackMsgArgument& arg);
00381
00382         enum  {
00383             ID = 2363
00384             };
00385
00386     private:
00387
00388         static void Destroy(StackMsgArgument* arg) { delete ((PlmnListAbortArg*) arg); }
00389
00390     };
00391
00392 // Inline definitions
00393 inline const PlmnListAbortArg& PlmnListAbortArg::Cast(const StackMsgArgument& arg) {
00394     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PlmnListAbortArg!\n");
00395     return ((PlmnListAbortArg &) arg);
00396 }
00397
00398
00399
00400 /*  ======================================================================
00401     Class PrefPlmnChangeArg
00402     ====================================================================== */
00403
00405 class PrefPlmnChangeArg : public StackMsgArgument {
00406     friend class CommonStackMsgArgsDestroyTableNode;
00407     public:
00408         PrefPlmnChangeArg();
00409
00410         static const PrefPlmnChangeArg& Cast(const StackMsgArgument& arg);
00411
00412         enum  {
00413             ID = 2364
00414             };
00415
00416     private:
00417
00418         static void Destroy(StackMsgArgument* arg) { delete ((PrefPlmnChangeArg*) arg); }
00419
00420     };
00421
00422 // Inline definitions
00423 inline const PrefPlmnChangeArg& PrefPlmnChangeArg::Cast(const StackMsgArgument& arg) {
00424     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PrefPlmnChangeArg!\n");
00425     return ((PrefPlmnChangeArg &) arg);
00426 }
00427
00428
00429
00430 /*  ======================================================================
00431     Class PrefServiceSetReqArg
00432     ====================================================================== */
00433
00435 class PrefServiceSetReqArg : public StackMsgArgument {
00436     friend class CommonStackMsgArgsDestroyTableNode;
00437     public:
00438         PrefServiceSetReqArg(const GsmService& gsm_service);
00439         PrefServiceSetReqArg();
00440
00441         static const PrefServiceSetReqArg& Cast(const StackMsgArgument& arg);
00442         const GsmService& GetGsmService() const { return m_gsm_service; }
00443
00444         enum  {
00445             ID = 2366
00446             };
00447
00448     private:
00449
00450         static void Destroy(StackMsgArgument* arg) { delete ((PrefServiceSetReqArg*) arg); }
00451
00452         GsmService m_gsm_service;
00453
00454     };
00455
00456 // Inline definitions
00457 inline const PrefServiceSetReqArg& PrefServiceSetReqArg::Cast(const StackMsgArgument& arg) {
00458     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PrefServiceSetReqArg!\n");
00459     return ((PrefServiceSetReqArg &) arg);
00460 }
00461
00462
00463
00464 /*  ======================================================================
00465     Class AttachReqArg
00466     ====================================================================== */
00467
00469 class AttachReqArg : public StackMsgArgument {
00470     friend class CommonStackMsgArgsDestroyTableNode;
00471     public:
00472         AttachReqArg(const RegisterMode& mode, const PlmnIndicator& indicator, const Plmn& plmn, const RadioAccessTechnology& rat);
00473         AttachReqArg();
00474
00475         static const AttachReqArg& Cast(const StackMsgArgument& arg);
00476         void SetMode(const RegisterMode& mode) { m_mode = mode; }
00477         const RegisterMode& GetMode() const { return m_mode; }
00478         void SetIndicator(const PlmnIndicator& indicator) { m_indicator = indicator; }
00479         const PlmnIndicator& GetIndicator() const { return m_indicator; }
00480         void SetPlmn(const Plmn& plmn) { m_plmn = plmn; }
00481         const Plmn& GetPlmn() const { return m_plmn; }
00482         void SetRat(const RadioAccessTechnology& rat) { m_rat = rat; }
00483         const RadioAccessTechnology& GetRat() const { return m_rat; }
00484
00485         enum  {
00486             ID = 6360
00487             };
00488
00489     private:
00490
00491         static void Destroy(StackMsgArgument* arg) { delete ((AttachReqArg*) arg); }
00492
00493         RegisterMode m_mode;
00494         PlmnIndicator m_indicator;
00495         Plmn m_plmn;
00496         RadioAccessTechnology m_rat;
00497
00498     };
00499
00500 // Inline definitions
00501 inline const AttachReqArg& AttachReqArg::Cast(const StackMsgArgument& arg) {
00502     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to AttachReqArg!\n");
00503     return ((AttachReqArg &) arg);
00504 }
00505
00506
00507
00508 /*  ======================================================================
00509     Class DetachReqArg
00510     ====================================================================== */
00511
00513 class DetachReqArg : public StackMsgArgument {
00514     friend class CommonStackMsgArgsDestroyTableNode;
00515     public:
00516         DetachReqArg();
00517
00518         static const DetachReqArg& Cast(const StackMsgArgument& arg);
00519
00520         enum  {
00521             ID = 6361
00522             };
00523
00524     private:
00525
00526         static void Destroy(StackMsgArgument* arg) { delete ((DetachReqArg*) arg); }
00527
00528     };
00529
00530 // Inline definitions
00531 inline const DetachReqArg& DetachReqArg::Cast(const StackMsgArgument& arg) {
00532     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DetachReqArg!\n");
00533     return ((DetachReqArg &) arg);
00534 }
00535
00536
00537
00538 /*  ======================================================================
00539     Class PlmnInfoReqArg
00540     ====================================================================== */
00541
00543 class PlmnInfoReqArg : public StackMsgArgument {
00544     friend class CommonStackMsgArgsDestroyTableNode;
00545     public:
00546         PlmnInfoReqArg(const RegisterMode& mode, const PlmnIndicator& indicator, const Plmn& plmn);
00547         PlmnInfoReqArg();
00548
00549         static const PlmnInfoReqArg& Cast(const StackMsgArgument& arg);
00550         void SetMode(const RegisterMode& mode) { m_mode = mode; }
00551         const RegisterMode& GetMode() const { return m_mode; }
00552         void SetIndicator(const PlmnIndicator& indicator) { m_indicator = indicator; }
00553         const PlmnIndicator& GetIndicator() const { return m_indicator; }
00554         void SetPlmn(const Plmn& plmn) { m_plmn = plmn; }
00555         const Plmn& GetPlmn() const { return m_plmn; }
00556
00557         enum  {
00558             ID = 6362
00559             };
00560
00561     private:
00562
00563         static void Destroy(StackMsgArgument* arg) { delete ((PlmnInfoReqArg*) arg); }
00564
00565         RegisterMode m_mode;
00566         PlmnIndicator m_indicator;
00567         Plmn m_plmn;
00568
00569     };
00570
00571 // Inline definitions
00572 inline const PlmnInfoReqArg& PlmnInfoReqArg::Cast(const StackMsgArgument& arg) {
00573     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PlmnInfoReqArg!\n");
00574     return ((PlmnInfoReqArg &) arg);
00575 }
00576
00577
00578
00579 /*  ======================================================================
00580     Class GprsClassReqArg
00581     ====================================================================== */
00582
00584 class GprsClassReqArg : public StackMsgArgument {
00585     friend class CommonStackMsgArgsDestroyTableNode;
00586     public:
00587         GprsClassReqArg(const GprsClass& gprs_class);
00588         GprsClassReqArg();
00589
00590         static const GprsClassReqArg& Cast(const StackMsgArgument& arg);
00591         void SetGprsClass(const GprsClass& gprs_class) { m_gprs_class = gprs_class; }
00592         const GprsClass& GetGprsClass() const { return m_gprs_class; }
00593
00594         enum  {
00595             ID = 6363
00596             };
00597
00598     private:
00599
00600         static void Destroy(StackMsgArgument* arg) { delete ((GprsClassReqArg*) arg); }
00601
00602         GprsClass m_gprs_class;
00603
00604     };
00605
00606 // Inline definitions
00607 inline const GprsClassReqArg& GprsClassReqArg::Cast(const StackMsgArgument& arg) {
00608     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to GprsClassReqArg!\n");
00609     return ((GprsClassReqArg &) arg);
00610 }
00611
00612
00613
00614 /*  ======================================================================
00615     Class PlmnListReqArg
00616     ====================================================================== */
00617
00619 class PlmnListReqArg : public StackMsgArgument {
00620     friend class CommonStackMsgArgsDestroyTableNode;
00621     public:
00622         PlmnListReqArg(const PlmnScanMode& mode);
00623         PlmnListReqArg();
00624
00625         static const PlmnListReqArg& Cast(const StackMsgArgument& arg);
00626         void SetMode(const PlmnScanMode& mode) { m_mode = mode; }
00627         const PlmnScanMode& GetMode() const { return m_mode; }
00628
00629         enum  {
00630             ID = 6365
00631             };
00632
00633     private:
00634
00635         static void Destroy(StackMsgArgument* arg) { delete ((PlmnListReqArg*) arg); }
00636
00637         PlmnScanMode m_mode;
00638
00639     };
00640
00641 // Inline definitions
00642 inline const PlmnListReqArg& PlmnListReqArg::Cast(const StackMsgArgument& arg) {
00643     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PlmnListReqArg!\n");
00644     return ((PlmnListReqArg &) arg);
00645 }
00646
00647
00648 #endif // Apc_PlmnStackMsgArgs_hpp
00649
Generated on Tue Jan 24 14:46:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PowerStackMsgArgs.cpp File Reference

Apc/PowerStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "PowerStackMsgArgs.hpp"

Include dependency graph for PowerStackMsgArgs.cpp:

Generated on Tue Jan 24 16:58:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PowerStackMsgArgs.hpp File Reference

Apc/PowerStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for PowerStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ClientDeregistrationArg
class | ClientRegistrationArg
class | ControlHwDataOnlyArg
class | OmControlIndArg
class | OmPowerUpArg
class | PowerDownCnfArg
class | PowerDownIndArg
class | PowerDownReqArg
class | StartSignalStrengthListeningArg
class | StopBatteryLoadListeningArg
class | StopSignalStrengthListeningArg

Defines

#define | Apc_PowerStackMsgArgs_hpp

Define Documentation

#define Apc_PowerStackMsgArgs_hpp

Generated on Tue Jan 24 16:58:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PowerStackMsgArgs.hpp Source File

Apc/PowerStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Apc\PowerArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_PowerStackMsgArgs_hpp)
00016 #define Apc_PowerStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class PowerDownCnfArg
00028     ====================================================================== */
00029
00031 class PowerDownCnfArg : public StackMsgArgument {
00032     friend class CommonStackMsgArgsDestroyTableNode;
00033     public:
00034         PowerDownCnfArg();
00035
00036         static const PowerDownCnfArg& Cast(const StackMsgArgument& arg);
00037
00038         enum  {
00039             ID = 1240
00040             };
00041
00042     private:
00043
00044         static void Destroy(StackMsgArgument* arg) { delete ((PowerDownCnfArg*) arg); }
00045
00046     };
00047
00048 // Inline definitions
00049 inline const PowerDownCnfArg& PowerDownCnfArg::Cast(const StackMsgArgument& arg) {
00050     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PowerDownCnfArg!\n");
00051     return ((PowerDownCnfArg &) arg);
00052 }
00053
00054
00055
00056 /*  ======================================================================
00057     Class OmControlIndArg
00058     ====================================================================== */
00059
00061 class OmControlIndArg : public StackMsgArgument {
00062     friend class CommonStackMsgArgsDestroyTableNode;
00063     public:
00064         OmControlIndArg(const PowerMode& power_mode);
00065         OmControlIndArg();
00066         ~OmControlIndArg();
00067
00068         static const OmControlIndArg& Cast(const StackMsgArgument& arg);
00069         void SetPowerMode(const PowerMode& power_mode) { m_power_mode = power_mode; }
00070         const PowerMode& GetPowerMode() const { return m_power_mode; }
00071
00072         enum  {
00073             ID = 1241
00074             };
00075
00076     private:
00077
00078         static void Destroy(StackMsgArgument* arg) { delete ((OmControlIndArg*) arg); }
00079
00080         PowerMode m_power_mode;
00081
00082     };
00083
00084 // Inline definitions
00085 inline const OmControlIndArg& OmControlIndArg::Cast(const StackMsgArgument& arg) {
00086     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmControlIndArg!\n");
00087     return ((OmControlIndArg &) arg);
00088 }
00089
00090
00091
00092 /*  ======================================================================
00093     Class PowerDownIndArg
00094     ====================================================================== */
00095
00097 class PowerDownIndArg : public StackMsgArgument {
00098     friend class CommonStackMsgArgsDestroyTableNode;
00099     public:
00100         PowerDownIndArg();
00101
00102         static const PowerDownIndArg& Cast(const StackMsgArgument& arg);
00103
00104         enum  {
00105             ID = 5240
00106             };
00107
00108     private:
00109
00110         static void Destroy(StackMsgArgument* arg) { delete ((PowerDownIndArg*) arg); }
00111
00112     };
00113
00114 // Inline definitions
00115 inline const PowerDownIndArg& PowerDownIndArg::Cast(const StackMsgArgument& arg) {
00116     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PowerDownIndArg!\n");
00117     return ((PowerDownIndArg &) arg);
00118 }
00119
00120
00121
00122 /*  ======================================================================
00123     Class OmPowerUpArg
00124     ====================================================================== */
00125
00127 class OmPowerUpArg : public StackMsgArgument {
00128     friend class CommonStackMsgArgsDestroyTableNode;
00129     public:
00130         OmPowerUpArg(const PowerMode& power_mode);
00131         OmPowerUpArg();
00132
00133         static const OmPowerUpArg& Cast(const StackMsgArgument& arg);
00134         void SetPowerMode(const PowerMode& power_mode) { m_power_mode = power_mode; }
00135         const PowerMode& GetPowerMode() const { return m_power_mode; }
00136
00137         enum  {
00138             ID = 2240
00139             };
00140
00141     private:
00142
00143         static void Destroy(StackMsgArgument* arg) { delete ((OmPowerUpArg*) arg); }
00144
00145         PowerMode m_power_mode;
00146
00147     };
00148
00149 // Inline definitions
00150 inline const OmPowerUpArg& OmPowerUpArg::Cast(const StackMsgArgument& arg) {
00151     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to OmPowerUpArg!\n");
00152     return ((OmPowerUpArg &) arg);
00153 }
00154
00155
00156
00157 /*  ======================================================================
00158     Class PowerDownReqArg
00159     ====================================================================== */
00160
00162 class PowerDownReqArg : public StackMsgArgument {
00163     friend class CommonStackMsgArgsDestroyTableNode;
00164     public:
00165         PowerDownReqArg();
00166
00167         static const PowerDownReqArg& Cast(const StackMsgArgument& arg);
00168
00169         enum  {
00170             ID = 2241
00171             };
00172
00173     private:
00174
00175         static void Destroy(StackMsgArgument* arg) { delete ((PowerDownReqArg*) arg); }
00176
00177     };
00178
00179 // Inline definitions
00180 inline const PowerDownReqArg& PowerDownReqArg::Cast(const StackMsgArgument& arg) {
00181     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PowerDownReqArg!\n");
00182     return ((PowerDownReqArg &) arg);
00183 }
00184
00185
00186
00187 /*  ======================================================================
00188     Class ClientRegistrationArg
00189     ====================================================================== */
00190
00192 class ClientRegistrationArg : public StackMsgArgument {
00193     friend class CommonStackMsgArgsDestroyTableNode;
00194     public:
00195         ClientRegistrationArg(const Client& client = MmiClient);
00196
00197         static const ClientRegistrationArg& Cast(const StackMsgArgument& arg);
00198         void SetClient(const Client& client) { m_client = client; }
00199         const Client& GetClient() const { return m_client; }
00200
00201         enum  {
00202             ID = 2242
00203             };
00204
00205     private:
00206
00207         static void Destroy(StackMsgArgument* arg) { delete ((ClientRegistrationArg*) arg); }
00208
00209         Client m_client;
00210
00211     };
00212
00213 // Inline definitions
00214 inline const ClientRegistrationArg& ClientRegistrationArg::Cast(const StackMsgArgument& arg) {
00215     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ClientRegistrationArg!\n");
00216     return ((ClientRegistrationArg &) arg);
00217 }
00218
00219
00220
00221 /*  ======================================================================
00222     Class ClientDeregistrationArg
00223     ====================================================================== */
00224
00226 class ClientDeregistrationArg : public StackMsgArgument {
00227     friend class CommonStackMsgArgsDestroyTableNode;
00228     public:
00229         ClientDeregistrationArg(const Client& client = MmiClient);
00230
00231         static const ClientDeregistrationArg& Cast(const StackMsgArgument& arg);
00232         void SetClient(const Client& client) { m_client = client; }
00233         const Client& GetClient() const { return m_client; }
00234
00235         enum  {
00236             ID = 2243
00237             };
00238
00239     private:
00240
00241         static void Destroy(StackMsgArgument* arg) { delete ((ClientDeregistrationArg*) arg); }
00242
00243         Client m_client;
00244
00245     };
00246
00247 // Inline definitions
00248 inline const ClientDeregistrationArg& ClientDeregistrationArg::Cast(const StackMsgArgument& arg) {
00249     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ClientDeregistrationArg!\n");
00250     return ((ClientDeregistrationArg &) arg);
00251 }
00252
00253
00254
00255 /*  ======================================================================
00256     Class StopBatteryLoadListeningArg
00257     ====================================================================== */
00258
00260 class StopBatteryLoadListeningArg : public StackMsgArgument {
00261     friend class CommonStackMsgArgsDestroyTableNode;
00262     public:
00263         StopBatteryLoadListeningArg();
00264
00265         static const StopBatteryLoadListeningArg& Cast(const StackMsgArgument& arg);
00266
00267         enum  {
00268             ID = 2245
00269             };
00270
00271     private:
00272
00273         static void Destroy(StackMsgArgument* arg) { delete ((StopBatteryLoadListeningArg*) arg); }
00274
00275     };
00276
00277 // Inline definitions
00278 inline const StopBatteryLoadListeningArg& StopBatteryLoadListeningArg::Cast(const StackMsgArgument& arg) {
00279     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to StopBatteryLoadListeningArg!\n");
00280     return ((StopBatteryLoadListeningArg &) arg);
00281 }
00282
00283
00284
00285 /*  ======================================================================
00286     Class StartSignalStrengthListeningArg
00287     ====================================================================== */
00288
00290 class StartSignalStrengthListeningArg : public StackMsgArgument {
00291     friend class CommonStackMsgArgsDestroyTableNode;
00292     public:
00293         StartSignalStrengthListeningArg(UINT threshold_percentage = 0);
00294
00295         static const StartSignalStrengthListeningArg& Cast(const StackMsgArgument& arg);
00296         void SetThresholdPercentage(UINT threshold_percentage) { m_threshold_percentage = threshold_percentage; }
00297         UINT GetThresholdPercentage() const { return m_threshold_percentage; }
00298
00299         enum  {
00300             ID = 2246
00301             };
00302
00303     private:
00304
00305         static void Destroy(StackMsgArgument* arg) { delete ((StartSignalStrengthListeningArg*) arg); }
00306
00307         UINT m_threshold_percentage;
00308
00309     };
00310
00311 // Inline definitions
00312 inline const StartSignalStrengthListeningArg& StartSignalStrengthListeningArg::Cast(const StackMsgArgument& arg) {
00313     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to StartSignalStrengthListeningArg!\n");
00314     return ((StartSignalStrengthListeningArg &) arg);
00315 }
00316
00317
00318
00319 /*  ======================================================================
00320     Class StopSignalStrengthListeningArg
00321     ====================================================================== */
00322
00324 class StopSignalStrengthListeningArg : public StackMsgArgument {
00325     friend class CommonStackMsgArgsDestroyTableNode;
00326     public:
00327         StopSignalStrengthListeningArg();
00328
00329         static const StopSignalStrengthListeningArg& Cast(const StackMsgArgument& arg);
00330
00331         enum  {
00332             ID = 2247
00333             };
00334
00335     private:
00336
00337         static void Destroy(StackMsgArgument* arg) { delete ((StopSignalStrengthListeningArg*) arg); }
00338
00339     };
00340
00341 // Inline definitions
00342 inline const StopSignalStrengthListeningArg& StopSignalStrengthListeningArg::Cast(const StackMsgArgument& arg) {
00343     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to StopSignalStrengthListeningArg!\n");
00344     return ((StopSignalStrengthListeningArg &) arg);
00345 }
00346
00347
00348
00349 /*  ======================================================================
00350     Class ControlHwDataOnlyArg
00351     ====================================================================== */
00352
00354 class ControlHwDataOnlyArg : public StackMsgArgument {
00355     friend class CommonStackMsgArgsDestroyTableNode;
00356     public:
00357         ControlHwDataOnlyArg();
00358
00359         static const ControlHwDataOnlyArg& Cast(const StackMsgArgument& arg);
00360
00361         enum  {
00362             ID = 2249
00363             };
00364
00365     private:
00366
00367         static void Destroy(StackMsgArgument* arg) { delete ((ControlHwDataOnlyArg*) arg); }
00368
00369     };
00370
00371 // Inline definitions
00372 inline const ControlHwDataOnlyArg& ControlHwDataOnlyArg::Cast(const StackMsgArgument& arg) {
00373     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ControlHwDataOnlyArg!\n");
00374     return ((ControlHwDataOnlyArg &) arg);
00375 }
00376
00377
00378 #endif // Apc_PowerStackMsgArgs_hpp
00379
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PreComp.cpp File Reference

Apc/PreComp.cpp File Reference

#include "Apc/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PreComp.hpp File Reference

Apc/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Message.hpp>
#include <Apc/StackMsgArgument.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/PreComp.hpp Source File

Apc/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Auxiliary/Lib.hpp>
00010
00011 #include <Apc/Message.hpp>
00012 #include <Apc/StackMsgArgument.hpp>
00013
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ProtocolIdentifier.cpp File Reference

Apc/ProtocolIdentifier.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/ProtocolIdentifier.hpp"

Include dependency graph for ProtocolIdentifier.cpp:

Generated on Tue Jan 24 16:58:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ProtocolIdentifier.hpp File Reference

Apc/ProtocolIdentifier.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for ProtocolIdentifier.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ProtocolIdentifier
3GPP TS 23.040 V5.1.0 [9.2.3.9] More...

Defines

#define | Apc_ProtocolIdentifier_hpp

Define Documentation

#define Apc_ProtocolIdentifier_hpp

Generated on Tue Jan 24 16:58:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ProtocolIdentifier.hpp Source File

Apc/ProtocolIdentifier.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_ProtocolIdentifier_hpp)
00009 #define Apc_ProtocolIdentifier_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014
00015 /*  ========================================================================
00016     TP-PID: Transfer Protocol - Protocol Identifier - 3GPP TS 23.040 V5.1.0 [9.2.3.9]
00017     ========================================================================*/
00019 class ProtocolIdentifier {
00020     public:
00021         // marks the invalidity of the protocol-identifier
00022         enum {
00024             InvalidPid = 0x80   // the use of the reserved (0x80) group setting leads to invalid return values.
00025         };
00026
00028         enum Usage {
00030             Normal,
00032             ReservedUsage,
00034             ServiceCenterSpecificUsage,
00036             InvalidUsage
00037         };
00038
00040         enum UsageGroup {
00042             Group00,
00044             Group01,
00046             InvalidGroup
00047         };
00048
00050         enum Interworking {
00052             SmeToSme,
00054             Telematic,
00056             InvalidInterworking
00057         };
00058
00060         enum TelematicDevice {  // do not change oder of enums ! used as index
00062             Implicit,
00064             Telex,
00066             Group3Telefax,
00068             Group4Telefax,
00070             VoiceTelephone,
00072             Ermes,
00074             NationalPagingSystem,
00076             Videotex,
00078             TeletexCarrierUnspecified,
00080             TeletexPspdn,
00082             TeletexCspdn,
00084             TeletexAnalogPstn,
00086             TeletexDigitalIsdn,
00088             Uci,
00090             MessageHandlingFacility,
00092             X400,
00094             InternetElectronicMail,
00095
00096
00098             ServiceCenterSpecificTelematicDevice,
00100             GsmUmts,
00102             ReservedTelematicDevice,
00104             InvalidTelematicDevice
00105         };
00106
00107         enum MessageType { // do not change oder of enums ! used as index
00109             ShortMessageType0 = 0,
00111             ReplaceShortMessageType1,
00113             ReplaceShortMessageType2,
00115             ReplaceShortMessageType3,
00117             ReplaceShortMessageType4,
00119             ReplaceShortMessageType5,
00121             ReplaceShortMessageType6,
00123             ReplaceShortMessageType7,
00125             EnhancedMessageType,
00127             ReturnCallMessage,
00129             Ansi136,
00131             MeDataDownload,
00133             MeDepersonalizationShortMessage,
00135             USimDataDownload,
00137             ReservedMessageType,
00139             InvalidMessageType
00140         };
00141
00142
00144         ProtocolIdentifier();
00146         ProtocolIdentifier(UINT8 incoming_byte);
00147
00149         UINT8 Get() const { return (m_bit_field.Get()); }
00150
00152         Usage GetUsage() const;
00154         void SetUsage(Usage usage);
00155
00157         Interworking GetInterworking() const;
00159         void SetInterworking(Interworking interworking);
00160
00162         TelematicDevice GetTelematicDevice() const;
00164         void SetTelematicDevice(TelematicDevice telematic_device);
00165
00167         MessageType GetMessageType() const;
00169         void SetMessageType(MessageType message_type);
00170
00172         BOOLEAN IsNormalUsage() const { return (GetUsage() == Normal); }
00174         BOOLEAN IsTelematicDevice() const { return (GetInterworking() == Telematic); }
00176         BOOLEAN IsInvalid() const { return (m_bit_field.Get() == InvalidPid); }
00177
00179         void Clear() { m_bit_field.Set(InvalidPid); }
00180
00181     private:
00182         BitField8 m_bit_field;
00183
00184         UsageGroup GetUsageGroup() const;
00185         void SetUsageGroup(UsageGroup usage_group);
00186 };
00187
00188
00189 #endif  // Apc_ProtocolIdentifier_hpp
00190
00191
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ShortMessageFailureCause.cpp File Reference

Apc/ShortMessageFailureCause.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/ShortMessageFailureCause.hpp"

Include dependency graph for ShortMessageFailureCause.cpp:

Generated on Tue Jan 24 16:58:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ShortMessageFailureCause.hpp File Reference

Apc/ShortMessageFailureCause.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for ShortMessageFailureCause.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ShortMessageFailureCause
3GPP TS 23.040 V5.1.0 [9.2.3.22] More...

Defines

#define | Apc_ShortMessageFailureCause_hpp

Define Documentation

#define Apc_ShortMessageFailureCause_hpp

Generated on Tue Jan 24 16:58:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ShortMessageFailureCause.hpp Source File

Apc/ShortMessageFailureCause.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_ShortMessageFailureCause_hpp)
00009 #define Apc_ShortMessageFailureCause_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014 /*  ========================================================================
00015     TP-FCS: Transfer Protocol - Failure Cause - 3GPP TS 23.040 V5.1.0 [9.2.3.22]
00016     ========================================================================*/
00018 class ShortMessageFailureCause {
00019     public:
00021         enum Usage {
00023             MobileOriginated,
00025             MobileTerminated,
00027             UndefinedUsage,
00028         };
00029
00031         enum Error {
00033             ReservedGeneralErrorBegin = 0x00,
00035             ReservedGeneralErrorEnd = 0x0f,
00036
00038             TelematicInterworkingNotSupported = 0x80,
00040             SmType0NotSupported = 0x81,
00042             CannotReplaceSm = 0x82,
00044             ReservedPidErrorBegin,
00046             ReservedPidErrorEnd = 0x8e,
00048             UnspecifiedPidError = 0x8f,
00049
00051             AlphabetNotSupported = 0x90,
00053             MessageClassNotSupported = 0x91,
00055             ReservedDcsErrorBegin,
00057             ReservedDcsErrorEnd = 0x9e,
00059             UnspecifiedDcsError = 0x9f,
00060
00062             CommandCannotBePerformed = 0xa0,
00064             CommandUnsupported = 0xa1,
00066             ReservedCommandErrorBegin,
00068             ReservedCommandErrorEnd = 0xae,
00070             UnspecifiedCommandError = 0xaf,
00071
00073             TpduNotSupported = 0xb0,
00075             ReservedTpduErrorBegin,
00077             ReservedTpduErrorEnd = 0xbf,
00078
00080             ScBusy = 0xc0,
00082             NoScSubscription = 0xc1,
00084             ScSystemFailure = 0xc2,
00086             InvalidSmeAddress = 0xc3,
00088             DestinationSmeBarred = 0xc4,
00090             SmRejectedDuplicateSm = 0xc5,
00092             VpfNotSupported = 0xc6,
00094             VpNotSupported = 0xc7,
00096             ReservedScErrorBegin,
00098             ReservedScErrorEnd = 0xcf,
00099
00101             USimSmsStorageFull = 0xd0,
00103             NoSmsStorageCapabilityInUSim = 0xd1,
00105             ErrorInMs = 0xd2,
00107             MemoryCapacityExceeded = 0xd3,
00109             USimApplicationToolkitBusy = 0xd4,
00111             USimDataDownloadError = 0xd5,
00113             ReservedUSimErrorBegin,
00115             ReservedUSimErrorEnd = 0xdf,
00116
00118             ReservedApplicationErrorBegin,
00120             ReservedApplicationErrorEnd = 0xfe,
00121
00123             UnspecifiedError = 0xff,
00124
00126             ReservedErrorValue,
00127
00129             InvalidErrorValue
00130         };
00131
00133         ShortMessageFailureCause();
00135         ShortMessageFailureCause(UINT8 incoming_byte);
00136
00138         UINT8 Get() const { return (m_bit_field.Get()); }
00139
00141         Error GetError() const;
00143         void SetError(Error error);
00144
00146         void Clear() { m_bit_field.Clear();}
00147
00148     private:
00149         BitField8 m_bit_field;
00150 };
00151
00152
00153 #endif  // Apc_ShortMessageFailureCause_hpp
00154
00155
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ShortMessageStatus.cpp File Reference

Apc/ShortMessageStatus.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/ShortMessageStatus.hpp"

Include dependency graph for ShortMessageStatus.cpp:

Generated on Tue Jan 24 16:58:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ShortMessageStatus.hpp File Reference

Apc/ShortMessageStatus.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for ShortMessageStatus.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ShortMessageStatus
3GPP TS 23.040 V5.1.0 [9.2.3.15] More...

Defines

#define | Apc_ShortMessageStatus_hpp

Define Documentation

#define Apc_ShortMessageStatus_hpp

Generated on Tue Jan 24 16:58:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ShortMessageStatus.hpp Source File

Apc/ShortMessageStatus.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_ShortMessageStatus_hpp)
00009 #define Apc_ShortMessageStatus_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014
00015 /*  ========================================================================
00016     TP-ST: Transfer Protocol - Status - 3GPP TS 23.040 V5.1.0 [9.2.3.15]
00017     ========================================================================*/
00019 class ShortMessageStatus {
00020     public:
00023         enum Status { // do not change order
00025             TransactionCompleted = 0,
00027             TemporaryErrorStillTrying,
00029             PermanentError,
00031             TemporaryError,
00033             ReservedStatus,
00035             InvalidStatus,
00036         };
00037
00038
00040         enum Reason { // do not change order
00042             SmDelivered = 0,
00045             SmDeliveredButUnableToConfirm,
00047             SmReplaced,
00048
00050             ReservedReason,
00052             ServiceCenterSpecificReason,
00053
00055             Congestion,
00057             SmeBusy,
00059             NoResponseFromSme,
00061             ServiceRejected,
00063             QualityOfServiceNotAvailable,
00065             ErrorInSme,
00066
00068             RemoteProcedureError,
00070             IncompatibleDestination,
00072             ConnectionRejectedBySme,
00074             NotObtainable,
00076             NoInterworkingAvailable,
00078             SmValidityPeriodExpired,
00080             SmDeletedByOriginatingSme,
00082             SmDeletedByScAdministration,
00084             SmDoesNotExist,
00085
00087             InvalidReason,
00088         };
00089
00091         ShortMessageStatus();
00092
00094         ShortMessageStatus(UINT8 incoming_byte);
00095
00097         UINT8 Get() const { return (m_bit_field.Get()); }
00098
00100         Status GetStatus() const;
00102         void SetStatus(Status status);
00103
00105         Reason GetReason() const;
00107         void SetReason(Reason reason);
00108
00110         void Clear() { m_bit_field.Clear();}
00111
00112     private:
00113         BitField8 m_bit_field;
00114 };
00115
00116
00117 #endif  // Apc_ShortMessageStatus_hpp
00118
00119
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalTypes.hpp File Reference

Apc/SignalTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/WString.hpp>
#include <Apc/SsStatus.hpp>
#include <Apc/SsNotification.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <stack/stack.h>

Include dependency graph for SignalTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | Acm
struct | AocChargeData
struct | AudioToneDuration
struct | CallBarringFeature
struct | CallBarringFeatureList
struct | CallBarringInfo
struct | CallingName
struct | CbmiData
struct | CbmiRange
struct | CcbsEntry
struct | CcbsList
struct | CcpData
class | CfuService
class | CfuServiceArray
struct | ChvAttemptsStruct
struct | ChvData
struct | CliRestrictionInfo
struct | CmiRecord
struct | CphsCfufArray
struct | CphsCspArray
struct | CphsIstArray
struct | CphsOnmName
struct | CphsOnsName
struct | CphsVmwfArray
struct | CugDescriptor
struct | CurrencyCode
struct | EccArray
class | EccCategory
struct | EccNetworkArray
struct | EccNetworkElement
struct | EccNetworkNumber
struct | EctIndicator
struct | EmlppPriority
struct | ExtLanguage
struct | ExtLanguageArray
struct | ForwardingFeature
struct | ForwardingFeatureList
struct | ForwardingInfo
struct | IccId
struct | Imei
struct | Imsi
struct | InterrogateCcbsResult
struct | InterrogateSsResult
struct | LanguageArray
struct | LociData
struct | NameIndicator
struct | NotifySsArg
struct | PhoneBookInfo
struct | PsLociData
struct | Puct
struct | Rdn
struct | ServiceProviderStruct
struct | SimApdu
struct | SimApduData
struct | SimData
struct | SimDfParameters
struct | SimEfOrangeParam
struct | SimEfParameters
class | SimPhoneBookEntry
struct | SimServiceTable
struct | SmsParamRecord
struct | SmsrData
struct | SmsStatus
struct | SsData
struct | SsGroup
struct | SsGroupList
struct | Subaddress
struct | UsimEccRecord
struct | UsimEst
struct | UsimFileProperty
struct | UsimLanguage
struct | UsimLanguageList
struct | UsimUst
struct | UusText

Defines

#define | Apc_SignalTypes_hpp
#define | USIMAP_ALPHA_LEN 32
#define | USIMAP_LANG_LIST_LEN 10
#define | USIMAP_SERVICE_TABLE_LEN 16

Typedefs

typedef UINT8 | BatteryLoadLevel
typedef INT | CcbsAction
typedef INT | CcbsStatus
typedef UINT8 | ChvAttempts
typedef CallErrorCause | DcError
typedef BOOLEAN | ExtIndicator
typedef UINT8 | Language
typedef CallErrorCause | MnCause
typedef SDL_PId | ProcessId
typedef BOOLEAN | ReleaseComplete
typedef SDL_Boolean | SdlBoolean
typedef byte | SdlByte
typedef SDL_Character | SdlCharacter
typedef SDL_Integer | SdlInteger
typedef ulong | SdlUlong
typedef word | SdlWord
typedef UINT8 | SignalQualityLevel
typedef UINT8 | SignalStrengthLevel
typedef INT | SimErrorCode
typedef UINT16 | SimFileId
typedef UINT8 | SimPhase
Sim phase (ms.h: T_SIM_PHASE).
typedef CallRelatedSsCode | SsCode
typedef SdlInteger | Tipd
typedef SdlInteger | Volume

Enumerations

enum | AcmSelector { Acm1 = SI_ACM_1, Acm2 = SI_ACM_2 }
Acm selection (ms.h: T_SI_ACM_SEL). More...
enum | AocChargingStatus { AocInformation = Aoci, AocCharging = Aocc, NoAoc = VoidSsCode, InvalidChargingStatus }
enum | AudioDevice { DeviceSpeaker, DeviceBuzzer, DeviceVibrator, DeviceRingBuzzerVibrator }
enum AudioToneType {
DefaultTone = DEFAULT_TONE, DialTone = DIAL_TONE, CalledSubscriberBusy = CALLED_SUBSCRIBER_BUSY, CongestionTone = CONGESTION_TONE,
RadioPathAck = RADIO_PATH_ACK, RadioPathNotAvail = RADIO_PATH_NOT_AVAIL, ErrorTone = ERROR_TONE, CallWaitingTone = CALL_WAITING_TONE,
RingingTone = RINGING_TONE, GeneralBeep = GENERAL_BEEP, PositiveAckTone = POSITIVE_ACK_TONE, NegativeAckTone = NEGATIVE_ACK_TONE
}
enum CallErrorCause {
UnassignedNumber = MN_UNASSIGNED_NUMBER, NoRoute = MN_NO_ROUTE, ChannelUnacceptable = MN_CHANNEL_UNACCEPTABLE, OperatorBarring = MN_OPERATOR_BARRING,
NormalCallClear = MN_NORMAL_CALL_CLEARING, UserBusy = MN_USER_BUSY, NoUserResponding = MN_NO_USER_RESPONDING, UserAlertingNoAnser = MN_USER_ALERTING_NO_ANSWER,
CallRejected = MN_CALL_REJECTED, NumberChanged = MN_NUMBER_CHANGED, NonSelectedUserClearing = MN_NON_SELECTED_USER_CLEARING, DestinationOutOfOrder = MN_DESTINATION_OUT_OF_ORDER,
InvalidNumberFormat = MN_INVALID_NUMBER_FORMAT, FacilityRejected = MN_FACILITY_REJECTED, ResponseToStatusEnquiry = MN_RESPONSE_TO_STATUS_ENQUIRY, NormalUnspecified = MN_NORMAL_UNSPECIFIED,
NoCircuitAvailable = MN_NO_CIRCUIT_AVAILABLE, NetworkOutOfOrder = MN_NETWORK_OUT_OF_ORDER, TemporaryFailure = MN_TEMPORARY_FAILURE, SwitchCongestion = MN_SWITCH_CONGESTION,
AccessInformationDiscarded = MN_ACCESS_INFORMATION_DISCARDED, ReqeustedCircuitNotAvailable = MN_REQUESTED_CIRCUIT_NOT_AVAILABLE, RessourcesUnavailable = MN_RESOURCES_UNAVAILABLE, QualityUnavailable = MN_QUALITY_UNAVAILABLE,
FacilityNotSubscribed = MN_FACILITY_NOT_SUBSCRIBED, IncomingCallsBarredInCug = MN_INCOMING_CALLS_BARRED_IN_CUG, BearerCapabilityNotAllowed = MN_BEARER_CAPABILITY_NOT_ALLOWED, BearerCapabilityNotAvailable = MN_BEARER_CAPABILITY_NOT_AVAILABLE,
ServiceNotAvailable = MN_SERVICE_NOT_AVAILABLE, AcmGreaterOrEqualToAcmmax = MN_ACM_GREATER_OR_EQUAL_TO_ACMMAX, BearerServiceNotImplemented = MN_BEARER_SERVICE_NOT_IMPLEMENTED, FacilityNotImplemented = MN_FACILITY_NOT_IMPLEMENTED,
OnlyRestrictedDigital = MN_ONLY_RESTRICTED_DIGITAL, ServiceNotImplemented = MN_SERVICE_NOT_IMPLEMENTED, InvalidTi = MN_INVALID_TI, UserNotInCug = MN_USER_NOT_IN_CUG,
IncompatibleDestination = MN_INCOMPATIBLE_DESTINATION, InvalidTransitNetwork = MN_INVALID_TRANSIT_NETWORK, SemanticsIncorrect = MN_SEMANTICS_INCORRECT, InvalidMandatoryInformation = MN_INVALID_MANATORY_INFORMATION,
UnknowMsgType1 = MN_UNKNOWN_MESSAGE_TYPE_1, UnexpectedMsgType = MN_UNEXPECTED_MESSAGE_TYPE, UnexpectedIe = MN_UNEXPECTED_IE, ConditionalIeError = MN_CONDITIONAL_IE_ERROR,
UnknownMsgType2 = MN_UNKNOWN_MESSAGE_TYPE_2, RecoveryOnTimerExpiry = MN_RECOVERY_ON_TIMER_EXPIRY, ProtocolError = MN_PROTOCOL_ERROR, Interworking = MN_INTERWORKING,
VoidCause = MN_VOID_CAUSE, OutofMemory = MN_OUT_OF_MEMORY, InvalidParam = MN_INVALID_PARAM, DataCallActive = MN_DATA_CALL_ACTIVE,
SpeechCallActive = MN_SPEECH_CALL_ACTIVE, DtmfRejDuringMocSetup = MN_DTMF_REJECTED_DURING_MO_CALL_SETUP, MocSetupRejMissingAcmInfoInd = MN_MOC_SETUP_REJ_DUE_TO_MISSING_ACM_INFO_IND, TempForbiddenCallAttempt = MN_TEMPORARY_FORBIDDEN_CALL_ATTEMPT,
CalledPartyBlacklisted = MN_CALLED_PARTY_IS_BLACKLISTED, BlacklistFullNoAutoCallAttempts = MN_BLACKLIST_IS_FULL_NO_AUTO_CALL_ATTEMPTS, TempForbiddenCallAttemptNoService = MN_TEMPORARY_FORBIDDEN_CALL_ATTEMPT_NO_SERVICE, TempForbiddenCallAttemptLimitedServe = MN_TEMPORARY_FORBIDDEN_CALL_ATTEMPT_LIMITED_SERVICE,
ClientTemporaryBarred = MN_CLIENT_TEMPORARY_BARRED, DualServiceCallActive = MN_DUAL_SERVICE_CALL_ACTIVE, AtcFclassNotSpeech = MN_ATC_FCLASS_NOT_SPEECH, SiUnknownError = MN_SI_UNKNOWN_ERROR,
DtmfRejCallHeldOrMparty = MN_DTMF_REJECTED_DUE_TO_CALL_HELD_OR_MPARTY, ClientNotRegistered = MN_CLIENT_NOT_REGISTRATED, ActiveClientGone = MN_ACTIVE_CLIENT_GONE, DtmfRejDataTransmission = MN_DTMF_REJECTED_DUE_TO_DATA_TRANSMISSION,
NoAppropriateDtmfEntry = MN_NO_APPROPRIATE_DTMF_ENTRY, SimStatusFailure = MN_SIM_STATUS_FAILURE, SimtkSetupModeNotSupported = MN_SIMTK_SETUP_MODE_NOT_SUPPORTED, MmiNotRegistered = MN_MMI_NOT_REGISTERED,
SimtkSetupRejMissingAcmInfoInd = MN_SIMTK_SETUP_REJ_DUE_TO_MISSING_ACM_INFO_IND, SimtkSetupRejByUser = MN_SIMTK_SETUP_REJECTED_BY_THE_USER, SimtkSetupRejTimeOut = MN_SIMTK_SETUP_REJECTED_TIME_OUT, SimtkCallConnected = MN_SIMTK_CALL_CONNECTED,
DisconnectDueToSimtkSetup = MN_DISCONNECT_DUE_TO_SIMTK_SETUP, SimtkSetupRejPendingSimtkSetup = MN_SIMTK_SETUP_REJ_DUE_TO_PENDING_SIMTK_SETUP, SimtkCallConnectedNoIconDisplay = MN_SIMTK_CALL_CONNECTED_NO_ICON_DISPLAY, PendingSimtkSetup = MN_PENDING_SIMTK_SETUP,
SimtkSimReset = MN_SIMTK_SIM_RESET, DtmfRejectedDueToSupTimerExpiry = MN_DTMF_REJECTED_DUE_TO_SUP_TIMER_EXPIRY, RejByCallControl = MN_REJ_BY_CALL_CONTROL, FdnFailed = MN_FDN_FAILED,
BdnFailed = MN_BDN_FAILED, OnlyError = MN_ONLY_ERROR, NotInSpeechCall = MN_NOT_IN_SPEECH_CALL, InvalidAlsLine = MN_INVALID_ALS_LINE,
LndOverflow = MN_LND_OVERFLOW, DtmfRejectedNoTchAvailable = MN_DTMF_REJECTED_NO_TCH_AVAILABLE, NwFailureUnspecified = MN_NW_FAILURE_UNSPECIFIED, MsNoService = MN_MS_NO_SERVICE,
MsAccessClassBarred = MN_MS_ACCESS_CLASS_BARRED, MsNoResource = MN_MS_NO_RESOURCE, MsServiceBusy = MN_MS_SERVICE_BUSY, MsFailureUnspecified = MN_MS_FAILURE_UNSPECIFIED,
ProactiveSimApplTerminatedByUser = MN_PROACTIVE_SIM_APPL_TERMINATED_BY_USER, CcbsPossible = MN_CCBS_POSSIBLE, ClientRejected = 995, UnknownErrorCause = 996,
CallChangedToSs = 997, CallChangedToUssd = 998, NoCallError = 999
}
enum CallEstCause {
EmergencyCall = EMERGENCY_CALL, CallReEst = CALL_REEST, FullTchNeeded = TCH_F_NEEDED, HalfTchSpeech = SPEECH_TCH_H,
HalfTchData = DATA_TCH_H, LocationUpdate = LOCATION_UPDATE, Other = OTHER, UndefinedCallEstCause
}
enum CallProgressInd {
NoProgress = MN_PROGRESS_NONE, Alerting = MN_ALERTING, MtcAccepted = MN_MT_CALL_ACCEPTED, InBandTonesAvailable = MN_IN_BAND_TONES_AVAILABLE,
InBandTonesNotAvailable = MN_IN_BAND_TONES_NOT_AVAILABLE, SpeechMtcAccepted = MN_TCH_SPEECH_MT_CALL_ACCEPTED, SpeechTonesAvailable = MN_TCH_SPEECH_TONES_AVAILABLE, SpeechTonesNotAvailable = MN_TCH_SPEECH_TONES_NOT_AVAILABLE,
Speech = MN_TCH_SPEECH, Data = MN_TCH_DATA, NotSpeech = MN_TCH_NOT_SPEECH
}
enum | CallRefuseDirection { IncommingRefuseDirection, OutgoingRefuseDirection }
enum CallRelatedSs {
RelAllHeldCalls = MN_REL_ALL_HELD_CALLS, RelAllActiveCalls = MN_REL_ALL_ACT_CALLS, RelSpecificActiveCall = MN_REL_SPECIFIC_ACT_CALL, HoldActiveCall = MN_HOLD_ACTIVE_CALL,
RetrieveCall = MN_RETRIEVE_CALL, BuildMparty = MN_BUILD_MPARTY, HoldMparty = MN_HOLD_MPARTY, RetrieveMparty = MN_RETRIEVE_MPARTY,
SplitMparty = MN_SPLIT_MPARTY, Ect = MN_ECT, ActivateCCBS = MN_ACTIVATE_CCBS, InvokeCallDeflection = MN_INVOKE_CALL_DEFLECTION,
InvalidCallRelatedSs
}
enum CallRelatedSsCode {
VoidSsCode = MN_VOID_SS_SERV_CODE, Clip = MN_CLIP, Clir = MN_CLIR, Colp = MN_COLP,
Colr = MN_COLR, AllForwardingSs = MN_ALL_FORWARDING_SS, Cfu = MN_CFU, AllCondForwardingSs = MN_ALL_COND_FORWARDING_SS,
Cfb = MN_CFB, Cfnry = MN_CFNRY, Cfnrc = MN_CFNRC, ExplicitCallTransfer = MN_EXPLICT_CALL_TRANSFER,
Cw = MN_CW, Hold = MN_HOLD, MultiParty = MN_MULTIPTY, Cug = MN_CUG,
Aoci = MN_AOCI, Aocc = MN_AOCC, AllCallRestrictionsSs = MN_ALL_CALL_RESTRICTIONS_SS, BarringOfOutgoingCalls = MN_BARRING_OF_OUTGOING_CALLS,
Baoc = MN_BAOC, Boic = MN_BOIC, BoicExHc = MN_BOIC_EX_HC, BarringOfIncomingCalls = MN_BARRING_OF_INCOMING_CALLS,
Baic = MN_BAIC, BicRoam = MN_BIC_ROAM, Cnap = MN_CNAP, Emlpp = MN_EMLPP,
UusService1 = 1000, UusService2, UusService3, AllUusServices,
Fm, Msp, Mc, Cd,
Ussd, AllSsServices, NoSsCode
}
enum | CallRelatedSsState { CallActive = MN_CALL_ACTIVE, CallHeld = MN_CALL_HELD, InvalidCallRelatedSsState }
enum CallState {
MocSetup = MN_MOC_CALL_SETUP, MocStarted = MN_MOC_CALL_STARTED, MocActive = MN_MOC_CALL_ACTIVE, MtcConfirmed = MN_MTC_CALL_CONFIRMED,
MtcSetup = MN_MTC_CALL_SETUP, MtcBcNegotiated = MN_MTC_BC_NEGOTIATED, MtcStarted = MN_MTC_CALL_STARTED, MtcActive = MN_MTC_CALL_ACTIVE,
MocAsCallSetup = MN_MOC_AS_CALL_SETUP, MtcAsCallSetup = MN_MTC_AS_CALL_SETUP, MtcRejected = MN_MTC_CALL_REJECTED, CallIsHeld = MN_CALL_IS_HELD,
CallIsRetrieved = MN_CALL_IS_RETRIEVED, MptyIsActive = MN_MPARTY_IS_ACTIVE, MptyIsHeld = MN_MPARTY_IS_HELD, MptyIsRetrieved = MN_MPARTY_IS_RETRIEVED,
MptyIsSplitted = MN_MPARTY_IS_SPLITTED, IsEct = MN_IS_ECT, CallDiscReq = MN_CALL_DISC_REQ, CallIsCleared = MN_CALL_IS_CLEARED,
CallModifyIndicated = MN_CALL_MODIFY_INDICATED, CallModifyStarted = MN_CALL_MODIFY_STARTED, CallModifyCompleted = MN_CALL_MODIFY_COMPLETED, CallModifyRejected = MN_CALL_MODIFY_REJECTED,
MocAlerted = MN_MOC_CALL_ALERTED, CallIsDisconnected = MN_CALL_IS_DISCONNECTED, CallIsDeflected = MN_CALL_IS_DEFLECTED, MptyStarted,
MptyRejected, MptyRetrievedStarted, MptyRetrieveRejected, MpartySplitStarted,
MptySplitRejected, MptyHeldStarted, MptyHeldRejected, CallDeflectionStarted,
CallDeflectionRejected, CallHeldStarted, CallHeldRejected, CallRetrieveStarted,
CallRetrieveRejected, EctStarted, EctRejected
}
enum CallType {
NoDataCall = MN_NO_DATA_CALL, FacsimileCall = MN_FACSIMILE_CALL, DataCall = MN_DATA_CALL, MmCall,
VoidCallType
}
enum CfuArrayIndex {
CfuTelephony = MN_CFU_TELEPHONY, CfuTelephonyLine2 = MN_CFU_TELEPHONY_L2, CfuFax = MN_CFU_FAX, CfuData = MN_CFU_DATA,
CfuArrayAccessMaxLines = MN_CFU_MAX_SERVICES
}
enum CfuDataSource {
CfuDataSourceInvalid = MN_CFU_SRC_VOID, CfuDataSourceCphs = MN_CFU_SRC_SIM_CPHS, CfuDataSourceCfis = MN_CFU_SRC_SIM_EF_CFIS, CfuDataSourceNvram = MN_CFU_SRC_NVRAM,
CfuDataSourceNetwork = MN_CFU_SRC_NETWORK
}
enum | CfuServiceCode { CfuInvalid = MN_CFU_OP_CODE_VOID, CfuActivated = MN_CFU_OP_CODE_SET, CfuDeactivated = MN_CFU_OP_CODE_RESET }
enum | ChargeEndReason { ChargeEndBatteryFull = 0, ChargeEndChargerDisconnected = 1 }
enum | ChargeShutdownReason { ChargeShutdownBatteryEmpty = 0, ChargeShutdownBatteryIdError = 1 }
enum ChvAction {
Chv1Enable = SI_CHV1_ENABLE_CMD, Chv1Disable = SI_CHV1_DISABLE_CMD, ChvVerify = SI_CHV_VERIFY_CMD, ChvUnblock = SI_CHV_UNBLOCK_CMD,
ChvChange = SI_CHV_CHANGE_CMD
}
Cardholder verification number (ms.h: T_SI_CHV_ACTION). More...
enum ChvNo {
Chv1 = SI_CHV1, Chv2 = SI_CHV2, Alw = SI_ALW, Rfu = SI_RFU,
Adm = SI_ADM, Nev = SI_NEV
}
Cardholder verification number (ms.h: T_SI_CHV_NO). More...
enum ChvStatus {
NotAvailable = SI_CHV_NOT_AVAILABLE, Needed = SI_CHV_NEEDED, NotNeeded = SI_CHV_NOT_NEEDED, Blocked = SI_CHV_BLOCKED,
UnblockingBlocked = SI_CHV_UNBL_BLOCKED, Verified = SI_CHV_VERIFIED, Rejected = SI_CHV_REJECTED, InContradictionWithChvStatus = SI_CHV_IN_CONTRADICTION_WITH_CHV_STATUS,
TransactionFailed, DataNotInitialized, TranscationNotSupported
}
Cardholder verification status (ms.h: T_SI_CHV_STATUS). More...
enum | Client { MmiClient = MN_CLIENT_MMI, AtcClient = MN_CLIENT_ATC, NoClient = MN_CLIENT_NONE }
Client (ms.h: T_MN_REG_CLIENT). More...
enum | CliRestrictionOption { Permanent = MN_PERMANENT, TemporaryDefaultRestricted = MN_TEMPORARY_DEFAULT_RESTRICTED, TemporaryDefaultAllowed = MN_TEMPORARY_DEFAULT_ALLOWED, VoidCliRestriction = MN_VOID_CLI_RESTRICTION }
enum | ClirMode { SuppressPhoneNumber = MN_CLIR_INVOKE, DisplayPhoneNumber = MN_CLIR_SUPPRESS, DontCare = MN_CLIR_NONE }
enum CnameChoice {
NamePresentationAllowed = MN_CNAME_NAME_PRES_ALLOWED, PresentationRestricted = MN_CNAME_PRESENTATION_RESTRICTED, NameUnavailable = MN_CNAME_NAME_UNAVAILABLE, NamePresentationRestricted = MN_CNAME_NAME_PRES_RESTRICTED,
CnameVoidChoice
}
enum | CugSelector { PreferedCug = MN_PREFERENTIAL_CUG, CugIndex = MN_CUG_INDEX, NoCug = MN_NO_CUG }
enum DataCallType {
CsdNone = CSD_NONE, CsdDataT = CSD_DATA_T, CsdDataNt = CSD_DATA_NT, CsdFax = CSD_FAX,
CsdVoice = CSD_VOICE, CsdMultimedia = CSD_MULTIMEDIA, CsdWap = CSD_WAP
}
enum DiagnosticCause {
VoidDiagnostic = MN_VOID_DIAGNOSTIC, OutgCallsBarredWithCug = MN_OUTG_CALLS_BARRED_WITHIN_CUG, NoCugSelected = MN_NO_CUG_SELECTED, UnknownCugIndex = MN_UNKNOWN_CUG_INDEX,
CugIndexIncompatible = MN_CUG_INDEX_INCOMPATIBLE, CugCallFailure = MN_CUG_CALL_FAILURE, ClirNotSubscribed = MN_CLIR_NOT_SUBSCRIBED, CcbsAllowed = MN_CCBS_ALLOWED,
CcbsNotAllowed = MN_CCBS_NOT_ALLOWED, UnknownDiagnosticCause
}
enum | EccSource { EccSourceSim, EccSourceNetwork, EccSourceBuiltin, EccSourceCustomized }
enum | EctCallState { EctAlerting = MN_ECT_ALERTING, EctActive = MN_ECT_ACTIVE, EctVoidCallState = MN_VOID_ECT_CALLSTATE }
enum EmlppPriorityLevel {
EmlppPriorityLevelA = 0, EmlppPriorityLevelB = 1, EmlppPriorityLevel0 = 2, EmlppPriorityLevel1 = 3,
EmlppPriorityLevel2 = 4, EmlppPriorityLevel3 = 5, EmlppPriorityLevel4 = 6, EmlppPriorityLevelVoid
}
enum GsmErrorCause {
ImsiUnknownInHlr = ERR_IMSI_UNKNOWN_IN_HLR, IllegalMs = ERR_ILLEGAL_MS, ImsiUnknownInVlr = ERR_IMSI_UNKNOWN_IN_VLR, ImeiNotAccepted = ERR_IMEI_NOT_ACCEPTED,
IllegalMe = ERR_ILLEGAL_ME, GprsNotAllowed = ERR_GPRS_NOT_ALLOWED, GprsGsmNotAllowed = ERR_GPRS_GSM_NOT_ALLOWED, MsIdentUnknown = ERR_MS_IDENT_UNKNOWN,
ImpDetached = ERR_IMP_DETACHED, PlmnNotAllowed = ERR_PLMN_NOT_ALLOWED, LaNotAllowed = ERR_LA_NOT_ALLOWED, NatRoamingNotAllowed = ERR_NAT_ROAMING_NOT_ALLOWED,
GprsPlmnNotAllowed = ERR_GPRS_PLMN_NOT_ALLOWED, NoSuitableCellsInLa = ERR_NO_SUITABLE_CELLS_IN_LA, MscNotReachable = ERR_MSC_NOT_REACHABLE, NetworkFailure = ERR_NETWORK_FAILURE,
Congestion = ERR_CONGESTION, ServiceNotSupported = ERR_SERVICE_NOT_SUPPORTED, ReqServNotDescr = ERR_REQ_SERV_NOT_DESCR, ServiceTempOutOfOrder = ERR_SERVICE_TEMP_OUT_OF_ORDER,
CallNotIdentified = ERR_CALL_NOT_IDENTIFIED, NoPdpContextActive = ERR_NO_PDP_CONTEXT_AKTIV, RetryOnNewCellBeg = ERR_RETRY_ON_NEW_CELL_BEG, RetryOnNewCellEnd = ERR_RETRY_ON_NEW_CELL_END,
SemIncorrMsg = ERR_SEM_INCORR_MSG, InvManIe = ERR_INV_MAN_IE, MsgtypNotExists = ERR_MSGTYP_NOT_EXIST, MsgtypNotCompatible = ERR_MSGTYP_NOT_COMPATIBLE,
InfElemNotExists = ERR_INF_ELEM_NOT_EXIST, ConIeErr = ERR_COND_IE_ERR, MsgNotCompatible = ERR_MSG_NOT_COMPATIBLE, ProtErrUnspecified = ERR_PROT_ERR_UNSPECIFIED,
MacFailure = ERR_MAC_FAILURE, SynchFailure = ERR_SYNCH_FAILURE, GsmAuthUnacceptable = ERR_GSM_AUTH_UNACCEPTABLE, GsmNoCause
}
GsmErrorCause => 3GPP TS 24.008 Annex G. More...
enum GsmSignal {
DialToneOn = MN_SIG_DIAL_TONE_ON, RingBackToneOn = MN_SIG_RING_BACK_TONE_ON, InterceptToneon = MN_SIG_INTERCEPT_TONE_ON, CongestionToneOn = MN_SIG_CONGESTION_TONE_ON,
BusyToneOn = MN_SIG_BUSY_TONE_ON, ConfirmToneOn = MN_SIG_CONFIRM_TONE_ON, AnswerToneOn = MN_SIG_ANSWER_TONE_ON, CallWaitToneOn = MN_SIG_CALL_WAIT_TONE_ON,
OffHookToneOn = MN_SIG_OFF_HOOK_TONE_ON, TonesOff = MN_SIG_TONES_OFF, AlertingOff = MN_SIG_ALERTING_OFF, IeMissing = MN_SIG_IE_MISSING
}
enum | HoldIndicator { CallRetrieved = MN_CALL_RETRIEVED, CallOnHold = MN_CALL_ON_HOLD, VoidHoldInd = MN_VOID_HOLD_INDICATOR }
enum InterrogateSsChoice {
SsStatusInterrogate = MN_SS_STATUS_INTERROGATE, SsForwardToNoInterrogate = MN_SS_FORW_TO_NO_INTERROGATE, SsBasicServiceGroupListInterrogate = MN_SS_BASIC_SERV_GROUP_LIST_INTERROGATE, SsForwwardFeatureListInterrogate = MN_SS_FORW_FEATURE_LIST_INTERROGATE,
SsCliRestrictInfoInterrogate = MN_SS_CLI_RESTRICT_INFO_INTERROGATE, SsVoidInterrogate = MN_SS_VOID_INTERROGATE
}
enum | LineSelector { Line1 = MN_SPEECH, Line2 = MN_AUXILIARY_SPEECH, InvalidLine }
Acm selection (ms.h: T_SI_LINE_SEL also T_MN_ALTERNATE_LINE). More...
enum LocationUpdateStatus {
LociUpdated = 0, LociNotUpdated = 1, LociPlmnNotAllowed = 2, LociLocAreaNotAllowed = 3,
LociReserved = 7
}
location update status More...
enum | NotificationDescription { UserSuspended = MN_USER_SUSPENDED, UserResumed = MN_USER_RESUMED, BearerChange = MN_BEARER_CHANGE }
enum | OverrideCategory { OverrideEnabled = MN_OVERRIDE_ENABLED, OverrideDisabled = MN_OVERRIDE_DISABLED, VoidOverride = MN_VOID_OVERRIDE }
enum | PbRequestBehaviour { PbRequestEmpty, PbRequestAutomatic, PbRequestMMI }
AT-request behaviour. More...
enum PhoneBookCntType {
AdnPhoneBookCnt = SI_PHB_ADN, FdnPhoneBookCnt = SI_PHB_FDN, LndPhoneBookCnt = SI_PHB_LND, MsisdnPhoneBookCnt = SI_PHB_MSISDN,
CphsMBoxPhoneBookCnt = SI_PHB_CPHS_MBOX, SdnPhoneBookCnt = SI_PHB_SDN, BdnPhoneBookCnt = SI_PHB_BDN, CphsInfoNoPhoneBookCnt = SI_PHB_CPHS_INFNUM,
MbdnPhoneBookCnt = SI_PHB_MBDN, CfisPhoneBookCnt = SI_PHB_CFIS, Ext1PhoneBookCnt = SI_PHB_EXT1, Ext2PhoneBookCnt = SI_PHB_EXT2,
Ext4PhoneBookCnt = SI_PHB_EXT4, Ext6PhoneBookCnt = SI_PHB_EXT6, Ext7PhoneBookCnt = SI_PHB_EXT7, InvalidPhoneBookCnt = -1
}
enum PhoneBookType {
AdnPhoneBook = SI_EF_ADN, FdnPhoneBook = SI_EF_FDN, LndPhoneBook = SI_EF_LND, MsisdnPhoneBook = SI_EF_MSISDN,
CphsMBoxPhoneBook = SI_EF_CPHS_MBOX, SdnPhoneBook = SI_EF_SDN, BdnPhoneBook = SI_EF_BDN, CphsInfoNoPhoneBook = SI_EF_CPHS_INFNUM,
MbdnPhoneBook = SI_EF_MBDN
}
enum | PlmnUpdateType { InsertPlmnAction = SI_INSERT, DeletePlmnAction = SI_DELETE, DeleteAllPlmnAction = SI_DELETE_ALL }
enum PowerMode {
PowerOffMode = OM_MODE_POWER_OFF, ChargerOnlyMode = OM_MODE_CHARGE_ONLY, NormalOnMode = OM_MODE_ON, SimulResetMode = OM_MODE_SIMUL_RESET,
AirplaneMode = OM_MODE_AIRPLANE, PtstMode = OM_MODE_PTST, SilentResetMode = OM_SILENT_RESET, RegistrationMode = OM_DEV_REGISTRATION
}
PowerMode (ms.h: T_POWER_MODE). More...
enum RdnChoice {
RdnPresentationAllowedAddr = MN_RDN_PRESENTATION_ALLOWED_ADDR, RdnPresentationRestricted = MN_RDN_PRESENTATION_RESTRICTED, RdnNumberNotAvailable = MN_RDN_NUMBER_NOT_AVAILABLE, RdnPresentationRestrictAddr = MN_RDN_PRESENTATION_RESTRICT_ADDR,
RdnVoidChoice = MN_VOID_RDN_CHOICE
}
enum ServedCallApplication {
AppUnknown = MN_APPL_UNKNOWN, AppSpeech = MN_APPL_SPEECH, AppData = MN_APPL_DATA, AppDual = MN_APPL_DUAL,
AppStkSpeech = MN_APPL_SIMTK_SPEECH
}
enum ServiceGroup {
UnknownSerivceGroup = MN_VOID_SERV_GROUP, AllTeleservices = MN_ALL_TELESERVICES, AllSpeechTransmissionServices = MN_ALL_SPEECH_TRANSMISSION_SERVICES, Telephony = MN_TELEPHONY,
EmergencyCalls = MN_EMERGENCY_CALLS, AllShortMessageServices = MN_ALL_SHORT_MESSAGE_SERVICES, ShortMessageMtPp = MN_SHORT_MESSAGE_MT_PP, ShortMessageMoPp = MN_SHORT_MESSAGE_MO_PP,
AllFacsimileTransmissionServices = MN_ALL_FACSIMILE_TRANSMISSION_SERVICES, FacsimileGroup3AndAlterSpeech = MN_FACSIMILE_GROUP3_AND_ALTER_SPEECH, AutomaticFacsimileGroup3 = MN_AUTOMATIC_FACSIMILE_GROUP3, FacsimileGroup4 = MN_FACSIMILE_GROUP4,
AllDataTeleservices = MN_ALL_DATA_TELESERVICES, AllTeleservicesExceptSms = MN_ALL_TELESERVICES_EXCEPT_SMS, AllPlmnSpecificTs = MN_ALL_PLMN_SPECIFIC_TS, PlmnSpecificTs1 = MN_PLMN_SPECIFIC_TS_1,
PlmnSpecificTs2 = MN_PLMN_SPECIFIC_TS_2, PlmnSpecificTs3 = MN_PLMN_SPECIFIC_TS_3, PlmnSpecificTs4 = MN_PLMN_SPECIFIC_TS_4, PlmnSpecificTs5 = MN_PLMN_SPECIFIC_TS_5,
PlmnSpecificTs6 = MN_PLMN_SPECIFIC_TS_6, PlmnSpecificTs7 = MN_PLMN_SPECIFIC_TS_7, PlmnSpecificTs8 = MN_PLMN_SPECIFIC_TS_8, PlmnSpecificTs9 = MN_PLMN_SPECIFIC_TS_9,
PlmnSpecificTsA = MN_PLMN_SPECIFIC_TS_A, PlmnSpecificTsB = MN_PLMN_SPECIFIC_TS_B, PlmnSpecificTsC = MN_PLMN_SPECIFIC_TS_C, PlmnSpecificTsD = MN_PLMN_SPECIFIC_TS_D,
PlmnSpecificTsE = MN_PLMN_SPECIFIC_TS_E, PlmnSpecificTsF = MN_PLMN_SPECIFIC_TS_F, AllBearerServices = MN_ALL_BEARER_SERVICES, AllDataCdaServices = MN_ALL_DATA_CDA_SERVICES,
DataCda300Bps = MN_DATA_CDA_300_BPS, DataCda1200Bps = MN_DATA_CDA_1200_BPS, DataCda1200_75Bps = MN_DATA_CDA_1200_75_BPS, DataCda2400_Bps = MN_DATA_CDA_2400_BPS,
DataCda4800_Bps = MN_DATA_CDA_4800_BPS, DataCda9600_Bps = MN_DATA_CDA_9600_BPS, AllDataCdsServices = MN_ALL_DATA_CDS_SERVICES, DataCds1200Bps = MN_DATA_CDS_1200_BPS,
DataCds2400Bps = MN_DATA_CDS_2400_BPS, DataCds4800Bps = MN_DATA_CDS_4800_BPS, DataCds9600Bps = MN_DATA_CDS_9600_BPS, AllPadAccessCaServices = MN_ALL_PAD_ACCESS_CA_SERVICES,
PadAccessCa300Bps = MN_PAD_ACCESS_CA_300_BPS, PadAccessCa1200Bps = MN_PAD_ACCESS_CA_1200_BPS, PadAccessCa1200_75Bps = MN_PAD_ACCESS_CA_1200_75_BPS, PadAccessCa2400Bps = MN_PAD_ACCESS_CA_2400_BPS,
PadAccessCa4800Bps = MN_PAD_ACCESS_CA_4800_BPS, PadAccessCa9600Bps = MN_PAD_ACCESS_CA_9600_BPS, AllDataPdsServices = MN_ALL_DATA_PDS_SERVICES, DataPds2400Bps = MN_DATA_PDS_2400_BPS,
DataPds4800Bps = MN_DATA_PDS_4800_BPS, DataPds9600Bps = MN_DATA_PDS_9600_BPS, AllAlternateSpeechDataCda = MN_ALL_ALTERNATE_SPEECH_DATA_CDA, AllAlternateSpeechDataCds = MN_ALL_ALTERNATE_SPEECH_DATA_CDS,
AllSpeechFollByDataCda = MN_ALL_SPEECH_FOLL_BY_DATA_CDA, AllSpeechFollByDataCds = MN_ALL_SPEECH_FOLL_BY_DATA_CDS, AllDataCircuitAsynchronous = MN_ALL_DATA_CIRCUIT_ASYNCHRONOUS, AllAsynchronousServices = MN_ALL_ASYNCHRONOUS_SERVICES,
AllDataCircuitSynchronous = MN_ALL_DATA_CIRCUIT_SYNCHRONOUS, AllSynchronousServices = MN_ALL_SYNCHRONOUS_SERVICES, AllPlmnSpecificBs = MN_ALL_PLMN_SPECIFIC_BS, PlmnSpecificBs1 = MN_PLMN_SPECIFIC_BS_1,
PlmnSpecificBs2 = MN_PLMN_SPECIFIC_BS_2, PlmnSpecificBs3 = MN_PLMN_SPECIFIC_BS_3, PlmnSpecificBs4 = MN_PLMN_SPECIFIC_BS_4, PlmnSpecificBs5 = MN_PLMN_SPECIFIC_BS_5,
PlmnSpecificBs6 = MN_PLMN_SPECIFIC_BS_6, PlmnSpecificBs7 = MN_PLMN_SPECIFIC_BS_7, PlmnSpecificBs8 = MN_PLMN_SPECIFIC_BS_8, PlmnSpecificBs9 = MN_PLMN_SPECIFIC_BS_9,
PlmnSpecificBsA = MN_PLMN_SPECIFIC_BS_A, PlmnSpecificBsB = MN_PLMN_SPECIFIC_BS_B, PlmnSpecificBsC = MN_PLMN_SPECIFIC_BS_C, PlmnSpecificBsD = MN_PLMN_SPECIFIC_BS_D,
PlmnSpecificBsE = MN_PLMN_SPECIFIC_BS_E, PlmnSpecificBsF = MN_PLMN_SPECIFIC_BS_F, AllVoiceGroupCallServices = MN_ALL_VOICE_GROUP_CALL_SERVICES, VoiceGroupCallService = MN_VOICE_GROUP_CALL,
VoiceBroadcastService = MN_VOICE_BROADCAST_CALL, AuxiliarySpeech = MN_ALL_AUXILIARY_SPEECH_SERVICES, AllServices, AllGPRSBearerServices
}
enum | SignalQualityMax { GsmSignalQualityMax = 7, UmtsSignalQualityMax = 49 }
enum | SignalStrengthMax { GsmSignalStrengthMax = 63, UmtsSignalStrengthMax = 91 }
enum SimCallControlResult {
CcAllowed = SI_CC_ALLOWED, CcNotAllowed = SI_CC_NOT_ALLOWED, CcAllowedModified = SI_CC_ALLOWED_MODIFIED, CcToolkitBusy = SI_CC_TK_BUSY,
CcSimError = SI_CC_SIM_ERROR
}
SIMTK call control result (ms.h: T_CC_RES). More...
enum | SimCardType { Sim2G = 0, Sim3G = 1 }
enum | SimFileType { TransparentFile = SI_TRANSPARENT, LinearFixedFile = SI_LINEAR_FIXED, CyclicFile = SI_CYCLIC }
Sim file type (ms.h: T_SI_FILE_STRUCTURE). More...
enum SimIndicator {
SimNotSet = SI_SIM_NOT_SET, SimNotPresent = SI_SIM_NOT_PRESENT, SimPresent = SI_SIM_PRESENT, SimError = SI_SIM_ERROR,
SimReady, SimFullAccess, SimSmsReady, SimUnblocked,
SimReadyForRegistration
}
Sim indicator (ms.h: T_SIM_INDICATOR). More...
enum | SimInitResult { NoOperation = SI_NO_OPERATION, RestrictedOperation = SI_RESTRICTED_OPERATION, UnrestrictedOperation = SI_UNRESTRICTED_OPERATION, UndefinedOperation }
Sim init result (ms.h: T_SI_INIT_RESULT). More...
enum SimRefreshType {
SmsRefresh = SI_SMS_REFRESH, PhoneBookRefresh = SI_PHONEBOOK_REFRESH, SmsParameterRefresh = SI_SMSP_REFRESH, CcpRefresh = SI_CCP_REFRESH,
EccpRefresh = SI_ECCP_REFRESH, FileRefresh = SI_FILE_REFRESH, PlmnRefresh = SI_PLMN_REFRESH, AocRefresh = SI_AOC_REFRESH,
UndefinedRefreshType
}
enum SimSsType {
SiSsType = SI_SS_TYPE, SiUssdTypeEarlyUsage = SI_USSD_TYPE_EARLY_USAGE, SiUssdType = SI_USSD_TYPE, SiNoSsType = SI_NO_SS_TYPE,
SiDtmfType = SI_DTMF_TYPE
}
SIMTK call control a parameter for SS indication (MN_SIMTK_SS_IND) (ms.h: T_SIM_SS_TYPE). More...
enum SimType {
NormalSim = NORMAL_SIM, NormalSpecialSim = NORMAL_SPECIAL_SIM, ApprovalSim = APPROVAL_SIM, ApprovalSpecialSim = APPROVAL_SPECIAL_SIM,
ServiceCardSim = SERVICE_CARD_SIM, CellTestSim = CELL_TEST_SIM, NoCard = NO_CARD
}
Sim type (ms.h: T_SIM_TYPE). More...
enum SimUpdateStatus {
Successfull = SI_SUCCESSFUL, Unsuccessfull = SI_UNSUCCESSFUL, SimMemRetrySuccess = SI_MEM_RETRY_SUCCESS, MemoryError = SI_MEMORY_ERROR,
SimToolkitBusy = SI_TOOLKIT_BUSY, SimNoEfChoosen = SI_NO_EF_CHOOSEN, SimInvalidAddress = SI_INVALID_ADDRESS, ReferenceError = SI_REFERENCE_ERROR,
SimInconsistentCmd = SI_INCONSISTENT_CMD, SimNoChvInitialized = SI_NO_CHV_INITIALIZED, SecurityError = SI_SECURITY_ERROR, SimContradictWithChvState = SI_CONTRADICT_CHV_STATE,
SimContradictInvalidState = SI_CONTRADICT_INVALID_STATE, SimNoAttemptLeft = SI_NO_ATTEMPT_LEFT, MaxValueReached = SI_MAX_VALUE_REACHED, SimToolkitResponeError = SI_TK_RESPONSE_ERROR,
SimApplicationErrorP3 = SI_APP_ERR_P3, SimApplicationErrorP1P2 = SI_APP_ERR_P1_P2, SimUnknownInstruction = SI_UNKNOWN_INSTRUCTION, SimWrongInstructionClass = SI_WRONG_INSTR_CLASS,
SimTechnicalProblem = SI_TECHNICAL_PROBLEM, ApplicationError = SI_APPLICATION_ERROR, NotActivated = SI_NOT_ACTIVATED, MemoryExceeded = SI_MEMORY_EXCEEDED,
SimExtMemoryExceeded = SI_EXT_MEMORY_EXCEEDED, CannotReplaceSms = SI_CANNOT_REPLACE_SMS, SimSuccessBeyondEnd = SI_SUCCESS_BEYOND_END, SuccessInvalidExt = SI_SUCCESS_INVALID_EXT,
Undefined
}
enum | SmsMoreMessageType { SmsDisableMoreMessages = DISABLE_MORE_MESSAGES, SmsEnableMoreMessagesUntilTimerExpiry = ENABLE_MORE_MESSAGES_UNTIL_TIMER_EXPIRY, SmsEnableMoreMessages = ENABLE_MORE_MESSAGES_PERMANENTLY, SmsUndefinedMoreMessages }
SmsMoreMessageType: type for sending more sms (ms.h: T_MN_MORE_MSG_STATUS). More...
enum | SsInd { UnkownServiceInd = MN_VOID_SERV_IND, TeleService = MN_TELESERVICE, BearerService = MN_BEARERSERVICE, TeleAndBearerServices }
enum SsOperationCode {
UnkownSsCode = MN_VOID_SS_OP_CODE, ScRegister = MN_REGISTER_SS, ScErase = MN_ERASE_SS, ScActivate = MN_ACTIVATE_SS,
ScDeactivate = MN_DEACTIVATE_SS, ScInterrogate = MN_INTERROGATE_SS, ScNotify = MN_NOTIFY_SS, ScRegisterPassword = MN_REGISTER_PASSWORD,
ScGetPassword = MN_GET_PASSWORD, ScProcessUssd = MN_PROCESS_UNSTRUCTURED_SS_DATA, ScForwardCheckIndication = MN_FORWARD_CHECK_SS_INDICATION, ScProcessUssdRequest = MN_PROCESS_UNSTRUCTURED_SS_REQUEST,
ScUssdRequest = MN_UNSTRUCTURED_SS_REQUEST, ScUssdNotify = MN_UNSTRUCTURED_SS_NOTIFY, ScForwardCugInfo = MN_FORWARD_CUG_INFO, ScSplitMpty = MN_SPLIT_MPTY,
ScRetrieveMpty = MN_RETRIEVE_MPTY, ScScHoldMpty = MN_HOLD_MPTY, ScBuildMpty = MN_BUILD_MPTY, ScForwardChargeAdvice = MN_FORWARD_CHARGE_ADVICE,
ScExplicitCt = MN_EXPLICIT_CT, ScSetupUusText
}
Call independent supplementary operation codes. More...
enum | UsimLangFileType { UsimLangDefault = 0 }
Language Request constants T_USIMAP_LANG_FILE. More...
enum | UsimReadType { UsimReadNull = 0 }
enum | UsimUpdateAction { UsimUpdateInsert = 0 }
enum UusInTextType {
ReceivedOnAnySetup = MN_UUS1_MSG_IN_SETUP, ReceivedOnAnyAlerting = MN_UUS1_MSG_IN_ALERTING, ReceivedOnProgress = MN_UUS1_MSG_IN_PROGRESS, ReceivedOnAnyConnect = MN_UUS1_MSG_IN_CONNECT,
ReceivedOnAnyDisconnect = MN_UUS1_MSG_IN_DISCONNECT, ReceivedOnAnyRelease = MN_UUS1_MSG_IN_RELEASE, ReceivedOnAnyReleaseComplete = MN_UUS1_MSG_IN_REL_COMPL
}
enum UusOutTextType {
SendOnAny = MN_UUS1_MSG_OUT_ANY, SendOnSetup = MN_UUS1_MSG_OUT_SETUP, SendOnAlerting = MN_UUS1_MSG_OUT_ALERTING, SendOnConnect = MN_UUS1_MSG_OUT_CONNECT,
SendOnDisconnect = MN_UUS1_MSG_OUT_DISCONNECT, SendOnRelease = MN_UUS1_MSG_OUT_RELEASE, SendOnReleaseComplete = MN_UUS1_MSG_OUT_REL_COMPL
}

Functions

BOOLEAN | IsSimMemoryError (SimErrorCode code)
BOOLEAN | IsSimSecretCodeLockedError (SimErrorCode code)
BOOLEAN | IsSimSecurityError (SimErrorCode code)
BOOLEAN | IsSimTechnicalProblemWithNoDiagnosticError (SimErrorCode code)

Variables

const INT | AdjustToneRpt = 1
const INT | AlarmToneRpt = 1
const INT | c_max_chvs = 6
const INT | c_max_cmi_alpha_id_size = 40
const INT | c_max_cname_string_len = 160
const INT | c_max_ecc_network_elements = 10
const INT | c_max_ecc_network_number_length = 6
const INT | c_max_no_basic_service_groups = MN_MAX_NUMBER_BASIC_SERVICE_GROUPS
const INT | c_max_phonebook_entry_len = 128
const INT | c_max_size_telephone_nr = MN_MAX_TEL_NUMBER
const INT | c_max_size_ussd_string = MN_MAX_USSD_STRING_LENGTH
const INT | c_max_smsparam_entry_len = 64
const INT | c_max_sst_services = sizeof(SimServiceTable) * 4
const INT | c_max_uus1_out_buffer_len = MAX_UUS1_OUT_BUFFER_LEN
const INT | c_maxno_usim_langs = USIMAP_LANG_LIST_LEN
const Tipd | c_mtc_mask = 0x80
const INT | c_no_of_extlanguages_array = 5
const INT | c_no_of_languages_array = 5
const SdlInteger | c_no_tipd = MN_NO_TI_PD
const SdlInteger | c_null_tipd = -1
const INT | c_password_len = 4
const SimErrorCode | c_sim_memory_error = (SimErrorCode)0x9240
const SimErrorCode | c_sim_secret_code_locked_error = (SimErrorCode)0x9804
const SimErrorCode | c_sim_security_error = (SimErrorCode)0x9804
const INT | c_size_of_orange_param = 37
const INT | c_sizeof_extlanguagearray = 10
const INT | c_sizeof_languagearray = 5
const INT | ClearToneRpt = 3
const INT | ErrorToneRpt = 3
const Acm | InvalidAcm = { 0xFF, 0xFF, 0xFF }
const CcpData | InvalidCcpData
const EccArray | InvalidEccArray = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 }
const ExtLanguage | InvalidExtLanguage = { 0xff, 0xff }
const UINT16 | InvalidExtLanguageVal = 0xffff
const Imei | InvalidImei = { 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF }
const Language | InvalidLanguage = 0xff
const Puct | InvalidPuct = { 0xFF, 0xFF, 0xFF, 0xFF, 0xFF }
const SignalQualityLevel | InvalidSignalQualityLevel = 0xff
const SignalStrengthLevel | InvalidSignalStrengthLevel = 0xff
const SimServiceTable | InvalidSimServiceTable = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 }
const ServiceProviderStruct | InvalidSpn = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 }
const INT | KeyToneRpt = 1
const INT | LowBattToneRpt = 2
const INT | MsgAlertRpt = 1
const INT | RingToneRpt = 1
const SdlBoolean | SdlFalse = SDL_False
const SdlBoolean | SdlTrue = SDL_True

Define Documentation

#define Apc_SignalTypes_hpp

#define USIMAP_ALPHA_LEN 32

#define USIMAP_LANG_LIST_LEN 10

#define USIMAP_SERVICE_TABLE_LEN 16

Typedef Documentation

typedef UINT8 BatteryLoadLevel

typedef INT CcbsAction

typedef INT CcbsStatus

typedef UINT8 ChvAttempts

typedef CallErrorCause DcError

typedef BOOLEAN ExtIndicator

typedef UINT8 Language

typedef CallErrorCause MnCause

typedef SDL_PId ProcessId

typedef BOOLEAN ReleaseComplete

typedef SDL_Boolean SdlBoolean

typedef byte SdlByte

typedef SDL_Character SdlCharacter

typedef SDL_Integer SdlInteger

typedef ulong SdlUlong

typedef word SdlWord

typedef UINT8 SignalQualityLevel

typedef UINT8 SignalStrengthLevel

typedef INT SimErrorCode

typedef UINT16 SimFileId

typedef UINT8 SimPhase

Sim phase (ms.h: T_SIM_PHASE).

typedef CallRelatedSsCode SsCode

typedef SdlInteger Tipd

typedef SdlInteger Volume

Enumeration Type Documentation

enum AcmSelector

Acm selection (ms.h: T_SI_ACM_SEL).

Enumerator:
Acm1
Acm2

enum AocChargingStatus

Enumerator:
AocInformation
AocCharging
NoAoc
InvalidChargingStatus

enum AudioDevice

Enumerator:
DeviceSpeaker
DeviceBuzzer
DeviceVibrator
DeviceRingBuzzerVibrator

enum AudioToneType

Enumerator:
DefaultTone
DialTone
CalledSubscriberBusy
CongestionTone
RadioPathAck
RadioPathNotAvail
ErrorTone
CallWaitingTone
RingingTone
GeneralBeep
PositiveAckTone
NegativeAckTone

enum CallErrorCause

Enumerator:
UnassignedNumber
NoRoute
ChannelUnacceptable
OperatorBarring
NormalCallClear
UserBusy
NoUserResponding
UserAlertingNoAnser
CallRejected
NumberChanged
NonSelectedUserClearing
DestinationOutOfOrder
InvalidNumberFormat
FacilityRejected
ResponseToStatusEnquiry
NormalUnspecified
NoCircuitAvailable
NetworkOutOfOrder
TemporaryFailure
SwitchCongestion
AccessInformationDiscarded
ReqeustedCircuitNotAvailable
RessourcesUnavailable
QualityUnavailable
FacilityNotSubscribed
IncomingCallsBarredInCug
BearerCapabilityNotAllowed
BearerCapabilityNotAvailable
ServiceNotAvailable
AcmGreaterOrEqualToAcmmax
BearerServiceNotImplemented
FacilityNotImplemented
OnlyRestrictedDigital
ServiceNotImplemented
InvalidTi
UserNotInCug
IncompatibleDestination
InvalidTransitNetwork
SemanticsIncorrect
InvalidMandatoryInformation
UnknowMsgType1
UnexpectedMsgType
UnexpectedIe
ConditionalIeError
UnknownMsgType2
RecoveryOnTimerExpiry
ProtocolError
Interworking
VoidCause
OutofMemory
InvalidParam
DataCallActive
SpeechCallActive
DtmfRejDuringMocSetup
MocSetupRejMissingAcmInfoInd
TempForbiddenCallAttempt
CalledPartyBlacklisted
BlacklistFullNoAutoCallAttempts
TempForbiddenCallAttemptNoService
TempForbiddenCallAttemptLimitedServe
ClientTemporaryBarred
DualServiceCallActive
AtcFclassNotSpeech
SiUnknownError
DtmfRejCallHeldOrMparty
ClientNotRegistered
ActiveClientGone
DtmfRejDataTransmission
NoAppropriateDtmfEntry
SimStatusFailure
SimtkSetupModeNotSupported
MmiNotRegistered
SimtkSetupRejMissingAcmInfoInd
SimtkSetupRejByUser
SimtkSetupRejTimeOut
SimtkCallConnected
DisconnectDueToSimtkSetup
SimtkSetupRejPendingSimtkSetup
SimtkCallConnectedNoIconDisplay
PendingSimtkSetup
SimtkSimReset
DtmfRejectedDueToSupTimerExpiry
RejByCallControl
FdnFailed
BdnFailed
OnlyError
NotInSpeechCall
InvalidAlsLine
LndOverflow
DtmfRejectedNoTchAvailable
NwFailureUnspecified
MsNoService
MsAccessClassBarred
MsNoResource
MsServiceBusy
MsFailureUnspecified
ProactiveSimApplTerminatedByUser
CcbsPossible
ClientRejected
UnknownErrorCause
CallChangedToSs
CallChangedToUssd
NoCallError

enum CallEstCause

Enumerator:
EmergencyCall
CallReEst
FullTchNeeded
HalfTchSpeech
HalfTchData
LocationUpdate
Other
UndefinedCallEstCause

enum CallProgressInd

Enumerator:
NoProgress
Alerting
MtcAccepted
InBandTonesAvailable
InBandTonesNotAvailable
SpeechMtcAccepted
SpeechTonesAvailable
SpeechTonesNotAvailable
Speech
Data
NotSpeech

enum CallRefuseDirection

Enumerator:
IncommingRefuseDirection
OutgoingRefuseDirection

enum CallRelatedSs

Enumerator:
RelAllHeldCalls
RelAllActiveCalls
RelSpecificActiveCall
HoldActiveCall
RetrieveCall
BuildMparty
HoldMparty
RetrieveMparty
SplitMparty
Ect
ActivateCCBS
InvokeCallDeflection
InvalidCallRelatedSs

enum CallRelatedSsCode

Enumerator:
VoidSsCode
Clip
Clir
Colp
Colr
AllForwardingSs
Cfu
AllCondForwardingSs
Cfb
Cfnry
Cfnrc
ExplicitCallTransfer
Cw
Hold
MultiParty
Cug
Aoci
Aocc
AllCallRestrictionsSs
BarringOfOutgoingCalls
Baoc
Boic
BoicExHc
BarringOfIncomingCalls
Baic
BicRoam
Cnap
Emlpp
UusService1
UusService2
UusService3
AllUusServices
Fm
Msp
Mc
Cd
Ussd
AllSsServices
NoSsCode

enum CallRelatedSsState

Enumerator:
CallActive
CallHeld
InvalidCallRelatedSsState

enum CallState

Enumerator:
MocSetup
MocStarted
MocActive
MtcConfirmed
MtcSetup
MtcBcNegotiated
MtcStarted
MtcActive
MocAsCallSetup
MtcAsCallSetup
MtcRejected
CallIsHeld
CallIsRetrieved
MptyIsActive
MptyIsHeld
MptyIsRetrieved
MptyIsSplitted
IsEct
CallDiscReq
CallIsCleared
CallModifyIndicated
CallModifyStarted
CallModifyCompleted
CallModifyRejected
MocAlerted
CallIsDisconnected
CallIsDeflected
MptyStarted
MptyRejected
MptyRetrievedStarted
MptyRetrieveRejected
MpartySplitStarted
MptySplitRejected
MptyHeldStarted
MptyHeldRejected
CallDeflectionStarted
CallDeflectionRejected
CallHeldStarted
CallHeldRejected
CallRetrieveStarted
CallRetrieveRejected
EctStarted
EctRejected

enum CallType

Enumerator:
NoDataCall
FacsimileCall
DataCall
MmCall
VoidCallType

enum CfuArrayIndex

Enumerator:
CfuTelephony | service code 11, equal to CPHS line-1
CfuTelephonyLine2 | CPHS line-2, service code 89.
CfuFax | service code 13
CfuData | service code 12
CfuArrayAccessMaxLines

enum CfuDataSource

Enumerator:
CfuDataSourceInvalid | the data source is invalid
CfuDataSourceCphs | the data is stored in the regarding CPHS file
CfuDataSourceCfis | the data is stored in the regarding Release 4 file
CfuDataSourceNvram | the data is stored inside NVRAM
CfuDataSourceNetwork | the data was sent by the network

enum CfuServiceCode

Enumerator:
CfuInvalid | status of the service is unkown
CfuActivated | service is activated
CfuDeactivated | service is deactivated

enum ChargeEndReason

Enumerator:
ChargeEndBatteryFull
ChargeEndChargerDisconnected

enum ChargeShutdownReason

Enumerator:
ChargeShutdownBatteryEmpty
ChargeShutdownBatteryIdError

enum ChvAction

Cardholder verification number (ms.h: T_SI_CHV_ACTION).

Enumerator:
Chv1Enable
Chv1Disable
ChvVerify
ChvUnblock
ChvChange

enum ChvNo

Cardholder verification number (ms.h: T_SI_CHV_NO).

Enumerator:
Chv1
Chv2
Alw
Rfu
Adm
Nev

enum ChvStatus

Cardholder verification status (ms.h: T_SI_CHV_STATUS).

Enumerator:
NotAvailable
Needed
NotNeeded
Blocked
UnblockingBlocked
Verified
Rejected
InContradictionWithChvStatus
TransactionFailed
DataNotInitialized
TranscationNotSupported

enum Client

Client (ms.h: T_MN_REG_CLIENT).

Enumerator:
MmiClient
AtcClient
NoClient

enum CliRestrictionOption

Enumerator:
Permanent
TemporaryDefaultRestricted
TemporaryDefaultAllowed
VoidCliRestriction

enum ClirMode

Enumerator:
SuppressPhoneNumber
DisplayPhoneNumber
DontCare

enum CnameChoice

Enumerator:
NamePresentationAllowed
PresentationRestricted
NameUnavailable
NamePresentationRestricted
CnameVoidChoice

enum CugSelector

Enumerator:
PreferedCug
CugIndex
NoCug

enum DataCallType

Enumerator:
CsdNone
CsdDataT
CsdDataNt
CsdFax
CsdVoice
CsdMultimedia
CsdWap

enum DiagnosticCause

Enumerator:
VoidDiagnostic
OutgCallsBarredWithCug
NoCugSelected
UnknownCugIndex
CugIndexIncompatible
CugCallFailure
ClirNotSubscribed
CcbsAllowed
CcbsNotAllowed
UnknownDiagnosticCause

enum EccSource

Enumerator:
EccSourceSim
EccSourceNetwork
EccSourceBuiltin
EccSourceCustomized

enum EctCallState

Enumerator:
EctAlerting
EctActive
EctVoidCallState

enum EmlppPriorityLevel

EmlppPriorityLevel DO NOT CHANGE ORDER

Enumerator:
EmlppPriorityLevelA
EmlppPriorityLevelB
EmlppPriorityLevel0
EmlppPriorityLevel1
EmlppPriorityLevel2
EmlppPriorityLevel3
EmlppPriorityLevel4
EmlppPriorityLevelVoid

enum GsmErrorCause

GsmErrorCause => 3GPP TS 24.008 Annex G.

Enumerator:
ImsiUnknownInHlr
IllegalMs
ImsiUnknownInVlr
ImeiNotAccepted
IllegalMe
GprsNotAllowed
GprsGsmNotAllowed
MsIdentUnknown
ImpDetached
PlmnNotAllowed
LaNotAllowed
NatRoamingNotAllowed
GprsPlmnNotAllowed
NoSuitableCellsInLa
MscNotReachable
NetworkFailure
Congestion
ServiceNotSupported
ReqServNotDescr
ServiceTempOutOfOrder
CallNotIdentified
NoPdpContextActive
RetryOnNewCellBeg
RetryOnNewCellEnd
SemIncorrMsg
InvManIe
MsgtypNotExists
MsgtypNotCompatible
InfElemNotExists
ConIeErr
MsgNotCompatible
ProtErrUnspecified
MacFailure
SynchFailure
GsmAuthUnacceptable
GsmNoCause

enum GsmSignal

Enumerator:
DialToneOn
RingBackToneOn
InterceptToneon
CongestionToneOn
BusyToneOn
ConfirmToneOn
AnswerToneOn
CallWaitToneOn
OffHookToneOn
TonesOff
AlertingOff
IeMissing

enum HoldIndicator

Enumerator:
CallRetrieved
CallOnHold
VoidHoldInd

enum InterrogateSsChoice

Enumerator:
SsStatusInterrogate
SsForwardToNoInterrogate
SsBasicServiceGroupListInterrogate
SsForwwardFeatureListInterrogate
SsCliRestrictInfoInterrogate
SsVoidInterrogate

enum LineSelector

Acm selection (ms.h: T_SI_LINE_SEL also T_MN_ALTERNATE_LINE).

Enumerator:
Line1
Line2
InvalidLine

enum LocationUpdateStatus

location update status

Enumerator:
LociUpdated
LociNotUpdated
LociPlmnNotAllowed
LociLocAreaNotAllowed
LociReserved

enum NotificationDescription

Enumerator:
UserSuspended
UserResumed
BearerChange

enum OverrideCategory

Enumerator:
OverrideEnabled
OverrideDisabled
VoidOverride

enum PbRequestBehaviour

AT-request behaviour.

Enumerator:
PbRequestEmpty | APOXI immediatly returns an empty name if AT request.
PbRequestAutomatic | APOXI immediatly returns but before have a lookup in the sim phonebook.
PbRequestMMI | APOXI posts a PbAlphaTagRequestMsg and the MMI shall have a lookup.

enum PhoneBookCntType

Enumerator:
AdnPhoneBookCnt
FdnPhoneBookCnt
LndPhoneBookCnt
MsisdnPhoneBookCnt
CphsMBoxPhoneBookCnt
SdnPhoneBookCnt
BdnPhoneBookCnt
CphsInfoNoPhoneBookCnt
MbdnPhoneBookCnt
CfisPhoneBookCnt
Ext1PhoneBookCnt
Ext2PhoneBookCnt
Ext4PhoneBookCnt
Ext6PhoneBookCnt
Ext7PhoneBookCnt
InvalidPhoneBookCnt

enum PhoneBookType

Enumerator:
AdnPhoneBook
FdnPhoneBook
LndPhoneBook
MsisdnPhoneBook
CphsMBoxPhoneBook
SdnPhoneBook
BdnPhoneBook
CphsInfoNoPhoneBook
MbdnPhoneBook

enum PlmnUpdateType

Enumerator:
InsertPlmnAction
DeletePlmnAction
DeleteAllPlmnAction

enum PowerMode

PowerMode (ms.h: T_POWER_MODE).

Enumerator:
PowerOffMode
ChargerOnlyMode
NormalOnMode
SimulResetMode
AirplaneMode
PtstMode
SilentResetMode
RegistrationMode

enum RdnChoice

Enumerator:
RdnPresentationAllowedAddr
RdnPresentationRestricted
RdnNumberNotAvailable
RdnPresentationRestrictAddr
RdnVoidChoice

enum ServedCallApplication

Enumerator:
AppUnknown
AppSpeech
AppData
AppDual
AppStkSpeech

enum ServiceGroup

Enumerator:
UnknownSerivceGroup
AllTeleservices
AllSpeechTransmissionServices
Telephony
EmergencyCalls
AllShortMessageServices
ShortMessageMtPp
ShortMessageMoPp
AllFacsimileTransmissionServices
FacsimileGroup3AndAlterSpeech
AutomaticFacsimileGroup3
FacsimileGroup4
AllDataTeleservices
AllTeleservicesExceptSms
AllPlmnSpecificTs
PlmnSpecificTs1
PlmnSpecificTs2
PlmnSpecificTs3
PlmnSpecificTs4
PlmnSpecificTs5
PlmnSpecificTs6
PlmnSpecificTs7
PlmnSpecificTs8
PlmnSpecificTs9
PlmnSpecificTsA
PlmnSpecificTsB
PlmnSpecificTsC
PlmnSpecificTsD
PlmnSpecificTsE
PlmnSpecificTsF
AllBearerServices
AllDataCdaServices
DataCda300Bps
DataCda1200Bps
DataCda1200_75Bps
DataCda2400_Bps
DataCda4800_Bps
DataCda9600_Bps
AllDataCdsServices
DataCds1200Bps
DataCds2400Bps
DataCds4800Bps
DataCds9600Bps
AllPadAccessCaServices
PadAccessCa300Bps
PadAccessCa1200Bps
PadAccessCa1200_75Bps
PadAccessCa2400Bps
PadAccessCa4800Bps
PadAccessCa9600Bps
AllDataPdsServices
DataPds2400Bps
DataPds4800Bps
DataPds9600Bps
AllAlternateSpeechDataCda
AllAlternateSpeechDataCds
AllSpeechFollByDataCda
AllSpeechFollByDataCds
AllDataCircuitAsynchronous
AllAsynchronousServices
AllDataCircuitSynchronous
AllSynchronousServices
AllPlmnSpecificBs
PlmnSpecificBs1
PlmnSpecificBs2
PlmnSpecificBs3
PlmnSpecificBs4
PlmnSpecificBs5
PlmnSpecificBs6
PlmnSpecificBs7
PlmnSpecificBs8
PlmnSpecificBs9
PlmnSpecificBsA
PlmnSpecificBsB
PlmnSpecificBsC
PlmnSpecificBsD
PlmnSpecificBsE
PlmnSpecificBsF
AllVoiceGroupCallServices
VoiceGroupCallService
VoiceBroadcastService
AuxiliarySpeech
AllServices
AllGPRSBearerServices

enum SignalQualityMax

Enumerator:
GsmSignalQualityMax
UmtsSignalQualityMax

enum SignalStrengthMax

Enumerator:
GsmSignalStrengthMax
UmtsSignalStrengthMax

enum SimCallControlResult

SIMTK call control result (ms.h: T_CC_RES).

Enumerator:
CcAllowed
CcNotAllowed
CcAllowedModified
CcToolkitBusy
CcSimError

enum SimCardType

Enumerator:
Sim2G
Sim3G

enum SimFileType

Sim file type (ms.h: T_SI_FILE_STRUCTURE).

Enumerator:
TransparentFile
LinearFixedFile
CyclicFile

enum SimIndicator

Sim indicator (ms.h: T_SIM_INDICATOR).

Enumerator:
SimNotSet | SIM is not used.
SimNotPresent | SIM is not present.
SimPresent | SIM is present, but not ready to use (CHV1 is not verified).
SimError | error with SIM occurred
SimReady | SIM is initialized (and CHV1 verified) and internal SIM data is loaded by APOXI.
SimFullAccess | SIM ready use - for common read processes.
SimSmsReady | SIM is initialized and sms are ready to read.
SimUnblocked
SimReadyForRegistration | SIM is initialized and network registration is allowed.

enum SimInitResult

Sim init result (ms.h: T_SI_INIT_RESULT).

Enumerator:
NoOperation
RestrictedOperation
UnrestrictedOperation
UndefinedOperation

enum SimRefreshType

Enumerator:
SmsRefresh
PhoneBookRefresh
SmsParameterRefresh
CcpRefresh
EccpRefresh
FileRefresh
PlmnRefresh
AocRefresh
UndefinedRefreshType

enum SimSsType

SIMTK call control a parameter for SS indication (MN_SIMTK_SS_IND) (ms.h: T_SIM_SS_TYPE).

Enumerator:
SiSsType
SiUssdTypeEarlyUsage
SiUssdType
SiNoSsType
SiDtmfType

enum SimType

Sim type (ms.h: T_SIM_TYPE).

Enumerator:
NormalSim
NormalSpecialSim
ApprovalSim
ApprovalSpecialSim
ServiceCardSim
CellTestSim
NoCard

enum SimUpdateStatus

Enumerator:
Successfull
Unsuccessfull
SimMemRetrySuccess
MemoryError
SimToolkitBusy
SimNoEfChoosen
SimInvalidAddress
ReferenceError
SimInconsistentCmd
SimNoChvInitialized
SecurityError
SimContradictWithChvState
SimContradictInvalidState
SimNoAttemptLeft
MaxValueReached
SimToolkitResponeError
SimApplicationErrorP3
SimApplicationErrorP1P2
SimUnknownInstruction
SimWrongInstructionClass
SimTechnicalProblem
ApplicationError
NotActivated
MemoryExceeded
SimExtMemoryExceeded
CannotReplaceSms
SimSuccessBeyondEnd
SuccessInvalidExt
Undefined

enum SmsMoreMessageType

SmsMoreMessageType: type for sending more sms (ms.h: T_MN_MORE_MSG_STATUS).

Enumerator:
SmsDisableMoreMessages
SmsEnableMoreMessagesUntilTimerExpiry
SmsEnableMoreMessages
SmsUndefinedMoreMessages

enum SsInd

Enumerator:
UnkownServiceInd
TeleService
BearerService
TeleAndBearerServices

enum SsOperationCode

Call independent supplementary operation codes.

Enumerator:
UnkownSsCode
ScRegister
ScErase
ScActivate
ScDeactivate
ScInterrogate
ScNotify
ScRegisterPassword
ScGetPassword
ScProcessUssd
ScForwardCheckIndication
ScProcessUssdRequest
ScUssdRequest
ScUssdNotify
ScForwardCugInfo
ScSplitMpty
ScRetrieveMpty
ScScHoldMpty
ScBuildMpty
ScForwardChargeAdvice
ScExplicitCt
ScSetupUusText

enum UsimLangFileType

Language Request constants T_USIMAP_LANG_FILE.

Enumerator:
UsimLangDefault

enum UsimReadType

Enumerator:
UsimReadNull

enum UsimUpdateAction

Enumerator:
UsimUpdateInsert

enum UusInTextType

Enumerator:
ReceivedOnAnySetup
ReceivedOnAnyAlerting
ReceivedOnProgress
ReceivedOnAnyConnect
ReceivedOnAnyDisconnect
ReceivedOnAnyRelease
ReceivedOnAnyReleaseComplete

enum UusOutTextType

Enumerator:
SendOnAny
SendOnSetup
SendOnAlerting
SendOnConnect
SendOnDisconnect
SendOnRelease
SendOnReleaseComplete

Function Documentation

BOOLEAN IsSimMemoryError ( SimErrorCode code ) [inline]

BOOLEAN IsSimSecretCodeLockedError ( SimErrorCode code ) [inline]

BOOLEAN IsSimSecurityError ( SimErrorCode code ) [inline]

BOOLEAN IsSimTechnicalProblemWithNoDiagnosticError ( SimErrorCode code ) [inline]

Variable Documentation

const INT AdjustToneRpt = 1

const INT AlarmToneRpt = 1

const INT c_max_chvs = 6

const INT c_max_cmi_alpha_id_size = 40

const INT c_max_cname_string_len = 160

const INT c_max_ecc_network_elements = 10

const INT c_max_ecc_network_number_length = 6

const INT c_max_no_basic_service_groups = MN_MAX_NUMBER_BASIC_SERVICE_GROUPS

const INT c_max_phonebook_entry_len = 128

const INT c_max_size_telephone_nr = MN_MAX_TEL_NUMBER

const INT c_max_size_ussd_string = MN_MAX_USSD_STRING_LENGTH

const INT c_max_smsparam_entry_len = 64

const INT c_max_sst_services = sizeof(SimServiceTable) * 4

const INT c_max_uus1_out_buffer_len = MAX_UUS1_OUT_BUFFER_LEN

const INT c_maxno_usim_langs = USIMAP_LANG_LIST_LEN

const Tipd c_mtc_mask = 0x80

const INT c_no_of_extlanguages_array = 5

const INT c_no_of_languages_array = 5

const SdlInteger c_no_tipd = MN_NO_TI_PD

const SdlInteger c_null_tipd = -1

const INT c_password_len = 4

const SimErrorCode c_sim_memory_error = (SimErrorCode)0x9240

const SimErrorCode c_sim_secret_code_locked_error = (SimErrorCode)0x9804

const SimErrorCode c_sim_security_error = (SimErrorCode)0x9804

const INT c_size_of_orange_param = 37

const INT c_sizeof_extlanguagearray = 10

const INT c_sizeof_languagearray = 5

const INT ClearToneRpt = 3

const INT ErrorToneRpt = 3

const Acm InvalidAcm = { 0xFF, 0xFF, 0xFF }

const CcpData InvalidCcpData

Initial value:

 { 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff,
                                 0xff, 0xff, 0xff, 0xff, 0xff, 0xff }

const EccArray InvalidEccArray = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 }

const ExtLanguage InvalidExtLanguage = { 0xff, 0xff }

const UINT16 InvalidExtLanguageVal = 0xffff

const Imei InvalidImei = { 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF }

const Language InvalidLanguage = 0xff

const Puct InvalidPuct = { 0xFF, 0xFF, 0xFF, 0xFF, 0xFF }

const SignalQualityLevel InvalidSignalQualityLevel = 0xff

const SignalStrengthLevel InvalidSignalStrengthLevel = 0xff

const SimServiceTable InvalidSimServiceTable = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 }

const ServiceProviderStruct InvalidSpn = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 }

const INT KeyToneRpt = 1

const INT LowBattToneRpt = 2

const INT MsgAlertRpt = 1

const INT RingToneRpt = 1

const SdlBoolean SdlFalse = SDL_False

const SdlBoolean SdlTrue = SDL_True

Generated on Tue Jan 24 17:06:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalTypes.hpp Source File

Apc/SignalTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalTypes_hpp)
00009 #define Apc_SignalTypes_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013
00014 #include <Auxiliary/PhoneNumber.hpp>
00015 #include <Auxiliary/WString.hpp>
00016
00017 #include <Apc/SsStatus.hpp>
00018 #include <Apc/SsNotification.hpp>
00019 #include <Apc/DataCodingScheme.hpp>
00020
00021 #include <stack/stack.h>
00022
00023 /*  ========================================================================
00024                                   SDL Types
00025     ========================================================================*/
00026 typedef SDL_Integer SdlInteger;
00027
00028 typedef SDL_Character SdlCharacter;
00029
00030 typedef byte SdlByte;
00031
00032 typedef word SdlWord;
00033
00034 typedef ulong SdlUlong;
00035
00036 typedef SDL_Boolean SdlBoolean;
00037 const SdlBoolean SdlTrue = SDL_True;
00038 const SdlBoolean SdlFalse = SDL_False;
00039
00040 typedef SDL_PId ProcessId;
00041
00042
00043 /*  ========================================================================
00044                                   Misc
00045     ========================================================================*/
00046 typedef UINT8 SignalStrengthLevel;
00047 typedef UINT8 SignalQualityLevel;
00048 typedef UINT8 BatteryLoadLevel;
00049
00050 // ChargeEndReason (ms.h: T_CHR_CHARGE_END)
00051 enum ChargeEndReason {
00052     ChargeEndBatteryFull = 0,
00053     ChargeEndChargerDisconnected = 1
00054 };
00055
00056 // ChargeShutdownReason (ms.h: T_CHR_SHUTDOWN)
00057 enum ChargeShutdownReason {
00058     ChargeShutdownBatteryEmpty = 0,
00059     ChargeShutdownBatteryIdError = 1
00060 };
00061
00062 // sim error code (ms.h: T_SIM_ERROR_CODE)
00063 typedef INT SimErrorCode;
00064 const SimErrorCode c_sim_memory_error = (SimErrorCode)0x9240;
00065 const SimErrorCode c_sim_security_error = (SimErrorCode)0x9804;
00066 const SimErrorCode c_sim_secret_code_locked_error = (SimErrorCode)0x9804;
00067
00068 inline BOOLEAN IsSimMemoryError(SimErrorCode code) { return code==c_sim_memory_error; }
00069 inline BOOLEAN IsSimSecurityError(SimErrorCode code) { return code==c_sim_security_error; }
00070 inline BOOLEAN IsSimSecretCodeLockedError(SimErrorCode code) { return code==c_sim_secret_code_locked_error; }
00071 inline BOOLEAN IsSimTechnicalProblemWithNoDiagnosticError(SimErrorCode code) { return ((UINT16)code & 0x6f00) == 0x6f00; }
00072
00073 const SignalStrengthLevel InvalidSignalStrengthLevel= 0xff;
00074 const SignalQualityLevel  InvalidSignalQualityLevel= 0xff;
00075
00076 /*  ========================================================================
00077                                   PowerMode
00078     ========================================================================*/
00080 enum PowerMode {
00081     PowerOffMode        = OM_MODE_POWER_OFF,
00082     ChargerOnlyMode     = OM_MODE_CHARGE_ONLY,
00083     NormalOnMode        = OM_MODE_ON,
00084     SimulResetMode      = OM_MODE_SIMUL_RESET,
00085 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00086     AirplaneMode        = OM_MODE_AIRPLANE,
00087     PtstMode            = OM_MODE_PTST,
00088     SilentResetMode     = OM_SILENT_RESET,
00089     RegistrationMode    = OM_DEV_REGISTRATION
00090 #else
00091     AirplaneMode,
00092     PtstMode,
00093     SilentResetMode,
00094     RegistrationMode
00095 #endif
00096 };
00097
00098 /*  ========================================================================
00099                                   Client
00100     ========================================================================*/
00101
00103 enum Client {
00104     MmiClient = MN_CLIENT_MMI,
00105     AtcClient = MN_CLIENT_ATC,
00106     NoClient  = MN_CLIENT_NONE
00107 };
00108
00110 //
00111 // SIM RELATED STUFF
00112 //
00114
00115 /*  ========================================================================
00116                                   SimIndicator
00117     ========================================================================*/
00118
00120 enum SimIndicator {
00122     SimNotSet     = SI_SIM_NOT_SET,
00124     SimNotPresent = SI_SIM_NOT_PRESENT,
00126     SimPresent    = SI_SIM_PRESENT,
00128     SimError      = SI_SIM_ERROR,
00130     SimReady,           // SI_INIT_IND received and after SIM stuff is loaded
00132     SimFullAccess,      // SI_FULL_ACCESS_IND received
00134     SimSmsReady,        // SI_SM_INIT_FINISHED_IND received
00136     SimUnblocked,       //SI_CHV_UNBLOCK_IND
00138     SimReadyForRegistration // SI_INIT_IND received
00139 };
00140
00141 /*  ========================================================================
00142                                   SimType
00143     ========================================================================*/
00144
00146 enum SimType {
00148     NormalSim          = NORMAL_SIM,
00150     NormalSpecialSim   = NORMAL_SPECIAL_SIM,
00152     ApprovalSim        = APPROVAL_SIM,
00154     ApprovalSpecialSim = APPROVAL_SPECIAL_SIM,
00156     ServiceCardSim     = SERVICE_CARD_SIM,
00158     CellTestSim        = CELL_TEST_SIM,
00160     NoCard             = NO_CARD
00161 };
00162
00163 /*  ========================================================================
00164                                   SimInitResult
00165     ========================================================================*/
00166
00168 enum SimInitResult {
00170     NoOperation             = SI_NO_OPERATION,
00172     RestrictedOperation     = SI_RESTRICTED_OPERATION,
00174     UnrestrictedOperation   = SI_UNRESTRICTED_OPERATION,
00176     UndefinedOperation
00177 };
00178
00179 /*  ========================================================================
00180                                   SimCallControlResult
00181     ========================================================================*/
00182
00184 enum SimCallControlResult {
00186     CcAllowed               = SI_CC_ALLOWED,
00188     CcNotAllowed            = SI_CC_NOT_ALLOWED,
00190     CcAllowedModified       = SI_CC_ALLOWED_MODIFIED,
00192     CcToolkitBusy           = SI_CC_TK_BUSY,
00194     CcSimError              = SI_CC_SIM_ERROR
00195 };
00196
00197 /*  ========================================================================
00198                                   SimSsType
00199     ========================================================================*/
00200
00202 enum SimSsType {
00204     SiSsType                = SI_SS_TYPE,
00206     SiUssdTypeEarlyUsage    = SI_USSD_TYPE_EARLY_USAGE,
00208     SiUssdType              = SI_USSD_TYPE,
00210     SiNoSsType              = SI_NO_SS_TYPE,
00212     SiDtmfType              = SI_DTMF_TYPE
00213 };
00214
00215 /*  ========================================================================
00216                                   SimPhase
00217     ========================================================================*/
00218
00220 typedef UINT8 SimPhase;
00221
00222 /*  ========================================================================
00223                                   SimFileType
00224     ========================================================================*/
00225
00227 enum SimFileType {
00229     TransparentFile = SI_TRANSPARENT,
00231     LinearFixedFile = SI_LINEAR_FIXED,
00233     CyclicFile = SI_CYCLIC,
00234 };
00235
00236 /*  ========================================================================
00237                                   SimUpdateStatus
00238     ========================================================================*/
00239
00240 // Sim read update status (ms.h: T_SI_RD_UPD_STATUS)
00241 enum SimUpdateStatus {
00242    Successfull                  = SI_SUCCESSFUL,            // 'SI_SUCCESSFUL'           OK
00243    Unsuccessfull                = SI_UNSUCCESSFUL,          // 'SI_UNSUCCESSFUL'         SI-detected
00244    SimMemRetrySuccess           = SI_MEM_RETRY_SUCCESS,     // 'SI_MEM_RETRY_SUCCESS'    92 0x
00245    MemoryError                  = SI_MEMORY_ERROR,          // 'SI_MEMORY_ERROR'         92 40
00246    SimToolkitBusy               = SI_TOOLKIT_BUSY,          // 'SI_TOOLKIT_BUSY'         93 00
00247    SimNoEfChoosen               = SI_NO_EF_CHOOSEN,         // 'SI_NO_EF_CHOOSEN'        94 00
00248    SimInvalidAddress            = SI_INVALID_ADDRESS,       // 'SI_INVALID_ADDRESS'      94 02
00249    ReferenceError               = SI_REFERENCE_ERROR,       // 'SI_REFERENCE_ERROR'      94 04
00250    SimInconsistentCmd           = SI_INCONSISTENT_CMD,      // 'SI_INCONSISTENT_CMD'     94 08
00251    SimNoChvInitialized          = SI_NO_CHV_INITIALIZED,    // 'SI_NO_CHV_INITIALIZED'   98 02
00252    SecurityError                = SI_SECURITY_ERROR,        // 'SI_SECURITY_ERROR'       98 04
00253    SimContradictWithChvState    = SI_CONTRADICT_CHV_STATE,  // 'SI_CONTRADICT_CHV_STATE' 98 08
00254    SimContradictInvalidState    = SI_CONTRADICT_INVALID_STATE,  // 'SI_CONTRADICT_INVALID_STATE' 98 10
00255    SimNoAttemptLeft             = SI_NO_ATTEMPT_LEFT,       // 'SI_NO_ATTEMPT_LEFT'      98 40
00256    MaxValueReached              = SI_MAX_VALUE_REACHED,     // 'SI_MAX_VALUE_REACHED'    98 50
00257    SimToolkitResponeError       = SI_TK_RESPONSE_ERROR,     // 'SI_TK_RESPONSE_ERROR'    9E XX
00258    SimApplicationErrorP3        = SI_APP_ERR_P3,            // 'SI_APP_ERR_P3'           67 XX
00259    SimApplicationErrorP1P2      = SI_APP_ERR_P1_P2,         // 'SI_APP_ERR_P1_P2'        6B XX
00260    SimUnknownInstruction        = SI_UNKNOWN_INSTRUCTION,   // 'SI_UNKNOWN_INSTRUCTION'  6D XX
00261    SimWrongInstructionClass     = SI_WRONG_INSTR_CLASS,     // 'SI_WRONG_INSTR_CLASS'    6E XX
00262    SimTechnicalProblem          = SI_TECHNICAL_PROBLEM,     // 'SI_TECHNICAL_PROBLEM'    6F XX
00263    ApplicationError             = SI_APPLICATION_ERROR,     // 'SI_APPLICATION_ERROR'    other SIM-error
00264    NotActivated                 = SI_NOT_ACTIVATED,         // 'SI_NOT_ACTIVATED'        unused
00265    MemoryExceeded               = SI_MEMORY_EXCEEDED,       // 'SI_MEMORY_EXCEEDED'      no free record
00266    SimExtMemoryExceeded         = SI_EXT_MEMORY_EXCEEDED,   // 'SI_EXT_MEMORY_EXCEEDED'  no free ext rec
00267    CannotReplaceSms             = SI_CANNOT_REPLACE_SMS,    // 'SI_CANNOT_REPLACE_SMS'   unused
00268 // When read beyond file end allowed by SI and happened e.g. for (IMG-data, SIM-lock data):
00269    SimSuccessBeyondEnd          = SI_SUCCESS_BEYOND_END,    // 'SI_SUCCESS_BEYOND_END'
00270 // no valid extension record id was found in the phonebook:
00271    SuccessInvalidExt            = SI_SUCCESS_INVALID_EXT,   // 'SI_SUCCESS_INVALID_EXT'
00272    Undefined,
00273 };
00274
00275 /*  ========================================================================
00276                                   SimRefreshType
00277     ========================================================================*/
00278
00279 // Sim refresh type (ms.h: T_SI_REFRESH_TYPE)
00280 enum SimRefreshType {
00281     SmsRefresh          = SI_SMS_REFRESH,
00282     PhoneBookRefresh    = SI_PHONEBOOK_REFRESH,
00283     SmsParameterRefresh = SI_SMSP_REFRESH,
00284     CcpRefresh          = SI_CCP_REFRESH,
00285     EccpRefresh         = SI_ECCP_REFRESH,
00286     FileRefresh         = SI_FILE_REFRESH,
00287     PlmnRefresh         = SI_PLMN_REFRESH,
00288     AocRefresh          = SI_AOC_REFRESH,
00289     UndefinedRefreshType,
00290 };
00291
00292 /*  ========================================================================
00293                                   PlmnUpdateType
00294     ========================================================================*/
00295
00296 // Plmn update command types (ms.h: T_SI_ACTION)
00297 enum PlmnUpdateType {
00298     InsertPlmnAction   = SI_INSERT,
00299     DeletePlmnAction   = SI_DELETE,
00300     DeleteAllPlmnAction = SI_DELETE_ALL
00301 };
00302
00303 /*  ========================================================================
00304                                   PhoneBookType
00305     ========================================================================*/
00306
00307 enum PhoneBookType {
00308     AdnPhoneBook        = SI_EF_ADN,
00309     FdnPhoneBook        = SI_EF_FDN,
00310     LndPhoneBook        = SI_EF_LND,
00311     MsisdnPhoneBook     = SI_EF_MSISDN,
00312     CphsMBoxPhoneBook   = SI_EF_CPHS_MBOX,
00313     SdnPhoneBook        = SI_EF_SDN,
00314     BdnPhoneBook        = SI_EF_BDN,
00315     CphsInfoNoPhoneBook = SI_EF_CPHS_INFNUM,
00316     MbdnPhoneBook       = SI_EF_MBDN
00317 };
00318
00319 /*  ========================================================================
00320                                   PhoneBookType
00321     ========================================================================*/
00322
00323 enum PhoneBookCntType {
00324     AdnPhoneBookCnt         = SI_PHB_ADN,
00325     FdnPhoneBookCnt         = SI_PHB_FDN,
00326     LndPhoneBookCnt         = SI_PHB_LND,
00327     MsisdnPhoneBookCnt      = SI_PHB_MSISDN,
00328     CphsMBoxPhoneBookCnt    = SI_PHB_CPHS_MBOX,
00329     SdnPhoneBookCnt         = SI_PHB_SDN,
00330     BdnPhoneBookCnt         = SI_PHB_BDN,
00331     CphsInfoNoPhoneBookCnt  = SI_PHB_CPHS_INFNUM,
00332     MbdnPhoneBookCnt        = SI_PHB_MBDN,
00333     CfisPhoneBookCnt        = SI_PHB_CFIS,
00334     Ext1PhoneBookCnt        = SI_PHB_EXT1,
00335     Ext2PhoneBookCnt        = SI_PHB_EXT2,
00336     Ext4PhoneBookCnt        = SI_PHB_EXT4,
00337     Ext6PhoneBookCnt        = SI_PHB_EXT6,
00338     Ext7PhoneBookCnt        = SI_PHB_EXT7,
00339     InvalidPhoneBookCnt     = -1
00340 };
00341
00342
00343 /*  ========================================================================
00344                                   PhoneBookInfo
00345     ========================================================================*/
00346
00347 struct PhoneBookInfo {
00348     INT adn_size;
00349     INT adn_tagsize;
00350     INT msisdn_size;
00351     INT msisdn_tagsize;
00352     INT fdn_size;
00353     INT fdn_tagsize;
00354     INT lnd_size;
00355     INT lnd_tagsize;
00356     INT cphs_mbox_size;
00357     INT cphs_mbox_tagsize;
00358     INT sdn_size;
00359     INT sdn_tagsize;
00360     INT bdn_size;
00361     INT bdn_tagsize;
00362     INT cphs_infono_size;
00363     INT cphs_infono_tagsize;
00364     INT mbdn_size;              // this is not delivered by info request -> fileinfo
00365     INT mbdn_tagsize;           // this is not delivered by info request -> fileinfo
00366 };
00367
00368 /*  ========================================================================
00369                                   SimPhoneBookEntry
00370     ========================================================================*/
00371
00372 const INT c_max_size_telephone_nr = MN_MAX_TEL_NUMBER;  // 23
00373
00374 const INT c_max_phonebook_entry_len = 128;
00375
00376 class SimPhoneBookEntry
00377 {
00378     public:
00379         SimPhoneBookEntry() : m_length(0), m_data(0) { }
00380
00381         SimPhoneBookEntry(const SimPhoneBookEntry & entry) : m_length(0), m_data(0) {
00382             if(entry.m_length>0) {
00383                 m_data = new UINT8[entry.m_length];
00384                 if(m_data!=0) {
00385                     m_length = entry.m_length;
00386                     memcpy(m_data,entry.m_data,m_length);
00387                 }
00388             }
00389         }
00390
00391         ~SimPhoneBookEntry() {
00392             m_length = 0;
00393             delete[] m_data;
00394             m_data = 0;
00395         }
00396
00397         void Push(INT length, const UINT8 * data) {
00398             m_data = new UINT8[length];
00399             if(m_data!=0) {
00400                 m_length = length;
00401                 memcpy(m_data,data,length);
00402             }
00403         }
00404
00405         INT     m_length;
00406         UINT8 * m_data;
00407 };
00408
00409 /*  ========================================================================
00410                                   SimCmiAlphaId
00411     ========================================================================*/
00412
00413 const INT c_max_cmi_alpha_id_size = 40;     // sizeof(T_SI_CMI_DATA);
00414
00415 struct CmiRecord {
00416     INT   alphaidlength;
00417     UINT8 alphaid[c_max_cmi_alpha_id_size];
00418     UINT8 cmi;
00419 };
00420
00421
00422 /*  ========================================================================
00423                                   SmsParamRecord
00424     ========================================================================*/
00425
00426 const INT c_max_smsparam_entry_len = 64;
00427
00428 struct SmsParamRecord {
00429     UINT8  val[c_max_smsparam_entry_len];
00430     INT    length;
00431 };
00432
00433 /*  ========================================================================
00434                                   SmsMoreMessageType
00435     ========================================================================*/
00436
00438 enum SmsMoreMessageType {
00440     SmsDisableMoreMessages                  = DISABLE_MORE_MESSAGES,
00442     SmsEnableMoreMessagesUntilTimerExpiry   = ENABLE_MORE_MESSAGES_UNTIL_TIMER_EXPIRY,
00444     SmsEnableMoreMessages                   = ENABLE_MORE_MESSAGES_PERMANENTLY,
00446     SmsUndefinedMoreMessages
00447 };
00448
00449
00450 /*  ========================================================================
00451                                   ChvStatus
00452     ========================================================================*/
00453
00455 enum ChvStatus {
00457     NotAvailable                    = SI_CHV_NOT_AVAILABLE,
00459     Needed                          = SI_CHV_NEEDED,
00461     NotNeeded                       = SI_CHV_NOT_NEEDED,
00463     Blocked                         = SI_CHV_BLOCKED,
00465     UnblockingBlocked               = SI_CHV_UNBL_BLOCKED,
00467     Verified                        = SI_CHV_VERIFIED,
00469     Rejected                        = SI_CHV_REJECTED,
00471     InContradictionWithChvStatus    = SI_CHV_IN_CONTRADICTION_WITH_CHV_STATUS,
00473     TransactionFailed,              // transaction failed (no respond message retrieved)
00475     DataNotInitialized ,            // chv data is not jet initialized
00477     TranscationNotSupported         // transaction is not supported for this chv
00478
00479 };
00480
00481 /*  ========================================================================
00482                                   ChvNo
00483     ========================================================================*/
00484
00486 enum ChvNo {
00488     Chv1 = SI_CHV1,
00490     Chv2 = SI_CHV2,
00492     Alw  = SI_ALW,
00494     Rfu  = SI_RFU,
00496     Adm  = SI_ADM,
00498     Nev  = SI_NEV,
00499 };
00500
00501
00502 const INT c_max_chvs = 6;   // must be identic to the number of enums of the type AdcChvNo
00503
00504 // cardholder verification attempts
00505 typedef UINT8 ChvAttempts;
00506
00507
00508 /*  ========================================================================
00509                                   ChvAttemptsStruct
00510     ========================================================================*/
00511 // attempts left (ms.h: T_SI_CHV_ATTEMPTS)
00512
00513 struct ChvAttemptsStruct {
00514     ChvAttempts  chv1AttemptsLeft;
00515     ChvAttempts  chv2AttemptsLeft;
00516     ChvAttempts  chv1UnblAttemptsLeft;
00517     ChvAttempts  chv2UnblAttemptsLeft;
00518 };
00519
00520 /*  ========================================================================
00521                                   ChvData
00522     ========================================================================*/
00523
00524 struct ChvData {
00525     ChvNo       no;
00526     ChvStatus   status;
00527     ChvAttempts attempts_left;
00528     ChvAttempts unblocking_attempts_left;
00529 };
00530
00531 /*  ========================================================================
00532                                   ChvAction
00533     ========================================================================*/
00534
00536 enum ChvAction {
00538     Chv1Enable = SI_CHV1_ENABLE_CMD,
00540     Chv1Disable = SI_CHV1_DISABLE_CMD,
00542     ChvVerify  = SI_CHV_VERIFY_CMD,
00544     ChvUnblock  = SI_CHV_UNBLOCK_CMD,
00546     ChvChange  = SI_CHV_CHANGE_CMD,
00547 };
00548
00549 /*  ========================================================================
00550                                   LociData
00551     ========================================================================*/
00552
00553 struct LociData {
00554     UINT8 val[11];
00555 };
00556
00557 /*  ========================================================================
00558                                   LocationUpdateStatus
00559     ========================================================================*/
00560
00562 enum LocationUpdateStatus {
00564     LociUpdated = 0,
00566     LociNotUpdated = 1,
00568     LociPlmnNotAllowed = 2,
00570     LociLocAreaNotAllowed  = 3,
00572     LociReserved = 7
00573 };
00574
00575 /*  ========================================================================
00576                                   CbmiData
00577     ========================================================================*/
00578 // (ms.h: T_SI_CBMI_DATA)
00579
00580 struct CbmiData {
00581     UINT8 val[2];
00582 };
00583
00584 /*  ========================================================================
00585                                   CbmiRange
00586     ========================================================================*/
00587 // (ms.h: T_SI_CBMI_RANGE)
00588
00589 struct CbmiRange {
00590     UINT16 low;
00591     UINT16 high;
00592 };
00593
00594 /*  ========================================================================
00595                                   Language
00596     ========================================================================*/
00597
00598 typedef UINT8 Language;
00599 const Language InvalidLanguage = 0xff;
00600
00601 // for internal use only
00602 const INT c_sizeof_languagearray = 5;
00603 const INT c_no_of_languages_array = 5;
00604
00605 // language orginal T_SI_LANG_LIST
00606 struct LanguageArray {
00607     UINT8 val[c_sizeof_languagearray];
00608 };
00609
00610 /*  ========================================================================
00611                                   ExtLanguage
00612     ========================================================================*/
00613
00614 // language orginal T_SI_EXT_LANG
00615 struct ExtLanguage {
00616     UINT8 val[2];
00617     WString GetWString() const {
00618         WCHAR temp[3] = { 0, 0, 0 };
00619         if(val[0]!=0xFF && val[1]!=0xFF) {
00620             temp[0] = val[0];
00621             temp[1] = val[1];
00622         }
00623         return WString(temp);
00624     }
00625     void Set(const WString & str) {
00626         if(str.GetLength()==2) {
00627             val[0] = ((UINT8)str[0]) & 0x7F;
00628             val[1] = (UINT8)str[1] & 0x7F;
00629         } else {
00630             val[0] = 0xFF;
00631             val[1] = 0xFF;
00632         }
00633     }
00634 };
00635
00636 const UINT16 InvalidExtLanguageVal = 0xffff;
00637 const ExtLanguage InvalidExtLanguage = { 0xff, 0xff };
00638
00639 // for internal use only
00640 const INT c_sizeof_extlanguagearray = 10;
00641 const INT c_no_of_extlanguages_array = 5;
00642
00643 // language orginal T_SI_EXT_LANG_LIST
00644 struct ExtLanguageArray {
00645     UINT8 val[c_sizeof_extlanguagearray];
00646 };
00647
00648 /*  ========================================================================
00649                                   IccId
00650     ========================================================================*/
00651
00652 struct IccId {
00653     UINT8 val[10];
00654 };
00655
00656 /*  ========================================================================
00657                                   SmsStatus
00658     ========================================================================*/
00659
00660 struct SmsStatus {
00661     UINT8 lastused;
00662     UINT8 notification;
00663 };
00664
00665 /*  ========================================================================
00666                                   AcmSelector
00667     ========================================================================*/
00669 enum AcmSelector {
00671     Acm1 = SI_ACM_1,
00673     Acm2 = SI_ACM_2,
00674 };
00675
00676 /*  ========================================================================
00677                                   Acm
00678     ========================================================================*/
00679
00680 // Acm (ms.h: T_SI_ARR_3)
00681 struct Acm {
00682     UINT8 val[3];
00683 };
00684
00685 const Acm InvalidAcm = { 0xFF, 0xFF, 0xFF };
00686
00687 /*  ========================================================================
00688                                   Puct
00689     ========================================================================*/
00690
00691 // Puct (ms.h: T_SI_PUCT_DATA)
00692 struct Puct {
00693     UINT8 val[5];
00694 };
00695
00696 const Puct InvalidPuct = { 0xFF, 0xFF, 0xFF, 0xFF, 0xFF };
00697
00698
00699 /*  ========================================================================
00700                                   Imsi
00701     ========================================================================*/
00702 // Imsi (ms.h: T_IMSI)
00703 struct Imsi {
00704     UINT8 val[9];
00705 };
00706
00707 /*  ========================================================================
00708                                   Imei
00709     ========================================================================*/
00710 // Imei (ms.h: T_IMEI)
00711 struct Imei {
00712     UINT8 val[10];
00713 };
00714
00715 const Imei InvalidImei = { 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF };
00716
00717 /*  ========================================================================
00718                                   EmlppPriorityLevel
00719     ========================================================================*/
00722 enum EmlppPriorityLevel {
00724     EmlppPriorityLevelA = 0,
00726     EmlppPriorityLevelB = 1,
00728     EmlppPriorityLevel0 = 2,
00730     EmlppPriorityLevel1 = 3,
00732     EmlppPriorityLevel2 = 4,
00734     EmlppPriorityLevel3 = 5,
00736     EmlppPriorityLevel4 = 6,
00738     EmlppPriorityLevelVoid
00739 };
00740
00741 /*  ========================================================================
00742                                   SimServiceTable
00743     ========================================================================*/
00744 // Sst (ms.h: T_SI_SST)
00745 struct SimServiceTable {
00746     UINT8 val[16];
00747 };
00748
00749
00750 const INT c_max_sst_services = sizeof(SimServiceTable) * 4;    // stack defined, per UINT8 4 services
00751
00752 const SimServiceTable InvalidSimServiceTable = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 };
00753
00754 /*  ========================================================================
00755                                   CcpData
00756     ========================================================================*/
00757
00758 // (ms.h: T_SI_CCP_DATA)
00759 struct CcpData {
00760     UINT8 val[14];
00761 };
00762
00763 const CcpData InvalidCcpData = { 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff,
00764                                  0xff, 0xff, 0xff, 0xff, 0xff, 0xff };
00765
00766
00767 /*  ========================================================================
00768                                   EccSource
00769     ========================================================================*/
00771 enum EccSource {
00773     EccSourceSim,
00775     EccSourceNetwork,
00777     EccSourceBuiltin,
00779     EccSourceCustomized
00780 };
00781
00782 /*  ========================================================================
00783                                   EccArray
00784     ========================================================================*/
00785
00786 // (ms.h: T_SI_ECC_ARRAY)
00787 struct EccArray {
00788     UINT8 length;
00789     UINT8 val[15];
00790 };
00791
00792 const EccArray InvalidEccArray = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 };
00793
00794 /*  ========================================================================
00795                                   Ecc Network Handling Types
00796     ========================================================================*/
00797
00798 const INT c_max_ecc_network_number_length = 6;
00799
00800 // (ms.h: T_MN_ECC_NW_NUMBER)
00801 struct EccNetworkNumber {
00802     UINT8 val[c_max_ecc_network_number_length];
00803 };
00804
00805 // (ms.h: T_MN_ECC_NW_LIST_NUMBERS_ELEMENT)
00806 struct EccNetworkElement {
00807     UINT8            m_category;
00808     EccNetworkNumber m_number;
00809 };
00810
00811 const INT c_max_ecc_network_elements = 10;
00812
00813 // derived from T_MN_ECC_NW_LIST
00814 struct EccNetworkArray {
00815     EccNetworkElement m_elements[c_max_ecc_network_elements];
00816     INT               m_number;
00817 };
00818
00819 /*  ========================================================================
00820                                   EccCategory
00821     ========================================================================*/
00823 class EccCategory
00824 {
00825     public:
00826         EccCategory() {};
00827         EccCategory(UINT8 value) : m_val(value) {};
00828         EccCategory(const EccCategory & cat) : m_val(cat.GetValue()) {};
00829
00831         BOOLEAN IsPolice() const { return m_val.GetBit(0); }
00833         BOOLEAN IsAmbulance() const { return m_val.GetBit(1); }
00835         BOOLEAN IsFireBrigade() const { return m_val.GetBit(2); }
00837         BOOLEAN IsMarineGuard() const { return m_val.GetBit(3); }
00839         BOOLEAN IsMountainRescue() const { return m_val.GetBit(4); }
00841         UINT8 GetValue() const { return m_val.Get(); }
00843         void SetValue(UINT8 value) { m_val.Set(value); }
00844
00845         EccCategory & operator =(const EccCategory &cat)
00846         {
00847             if (&cat != this) {     // guard from self assignment
00848                 m_val.Set(cat.GetValue());
00849             }
00850             return (*this);
00851         }
00852
00853     private:
00854         BitField8 m_val;
00855
00856 };
00857
00858 /*  ========================================================================
00859                                   ServiceProviderStruct
00860     ========================================================================*/
00861
00862 struct ServiceProviderStruct {
00863     UINT8 dsplcond;
00864     UINT8 name[16];
00865 };
00866
00867 const ServiceProviderStruct InvalidSpn = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 };
00868
00869 /*  ========================================================================
00870                                   SimData
00871     ========================================================================*/
00872 // (ms.h: T_SI_DATA)
00873
00874 struct SimData {
00875     UINT8 val[32];
00876 };
00877
00878 /*  ========================================================================
00879                                   SmsrData
00880     ========================================================================*/
00881 // (ms.h: T_SI_SMSR_DATA)
00882
00883 struct SmsrData {
00884     UINT8 val[29];
00885 };
00886
00887 typedef BOOLEAN ExtIndicator;
00888
00889 /*  ========================================================================
00890                                   SimFileId
00891     ========================================================================*/
00892
00893 typedef UINT16 SimFileId;
00894
00895 /*  ========================================================================
00896                                   SimApdu
00897     ========================================================================*/
00898
00899 struct SimApdu {
00900     UINT8 val[261];
00901 };
00902
00903 /*  ========================================================================
00904                                   SimApduData
00905     ========================================================================*/
00906
00907 struct SimApduData {
00908     SimApduData() : length(0) {}
00909
00910     INT     length;
00911     SimApdu apdu;
00912 };
00913
00914 /*  ========================================================================
00915                                   SimDfParameters
00916     ========================================================================*/
00917
00918 struct SimDfParameters {
00919     UINT8 val[36];
00920 };
00921
00922 /*  ========================================================================
00923                                   SimEfParameters
00924     ========================================================================*/
00925
00926 struct SimEfParameters {
00927     UINT8 val[17];
00928 };
00929
00930 /*  ========================================================================
00931                                   SimEfOrangeParam
00932     ========================================================================*/
00933
00934 struct SimEfOrangeParam {
00935     UINT8 val[37];
00936 };
00937
00938 const INT c_size_of_orange_param = 37;
00939
00940 /*  ========================================================================
00941                                   LineSelector
00942     ========================================================================*/
00943
00945 enum LineSelector {
00946 //
00947     Line1 = MN_SPEECH,
00948     //
00949     Line2 = MN_AUXILIARY_SPEECH,
00950     //
00951     InvalidLine
00952 };
00953
00954 /*  ========================================================================
00955                                   CphsIstArray
00956     ========================================================================*/
00957
00958 // T_SI_CPHS_IST_ARRAY
00959 struct CphsIstArray {
00960     UINT8 val[8];
00961 };
00962
00963 /*  ========================================================================
00964                                   CphsVmwfArray
00965     ========================================================================*/
00966
00967 // T_SI_CPHS_VMWF_ARRAY
00968 struct CphsVmwfArray {
00969     UINT8 val[2];
00970 };
00971
00972 /*  ========================================================================
00973                                   CphsCfufArray
00974     ========================================================================*/
00975
00976 // T_SI_CPHS_CFUF_ARRAY
00977 struct CphsCfufArray {
00978     UINT8 val[2];
00979 };
00980
00981 /*  ========================================================================
00982                                   CphsOnmName
00983     ========================================================================*/
00984
00985 // T_SI_CPHS_ONM_ARRAY
00986 struct CphsOnmName {
00987     UINT8 val[40];
00988 };
00989
00990 /*  ========================================================================
00991                                   CphsOnsName
00992     ========================================================================*/
00993
00994 // T_SI_CPHS_ONS_ARRAY
00995 struct CphsOnsName {
00996     UINT8 val[10];
00997 };
00998
00999 /*  ========================================================================
01000                                   CphsCspArray
01001     ========================================================================*/
01002
01003 // T_SI_CPHS_CSP_ARRAY
01004 struct CphsCspArray {
01005     UINT8 val[22];
01006 };
01007
01008
01009
01011 //
01012 // USIM RELATED STUFF
01013 //
01015
01016 /*  ========================================================================
01017                                  SimCardType
01018     ======================================================================== */
01019
01020 enum SimCardType {
01021     Sim2G   =   0,  // UICCAP_CARD_TYPE_2G
01022     Sim3G   =   1,  // UICCAP_CARD_TYPE_3G
01023 };
01024
01025 /*  ========================================================================
01026                                  UsimReadType
01027     ======================================================================== */
01028
01029 enum UsimReadType {
01030 #if defined(APOXI_ICC_USIM)
01031     UsimReadNull = USIMAP_READ_NULL,
01032     UsimReadCurrUsim = USIMAP_READ_CURR_USIM,
01033     UsimReadCardType = USIMAP_READ_CARD_TYPE,
01034     UsimReadImsi = USIMAP_READ_IMSI,
01035     UsimReadAcc = USIMAP_READ_ACC,
01036     UsimReadStartHfn = USIMAP_READ_START_HFN,
01037     UsimReadHfnThreshold = USIMAP_READ_HFN_THRESHOLD,
01038     UsimReadCpbcch = USIMAP_READ_CPBCCH,
01039     UsimReadInvScan = USIMAP_READ_INV_SCAN,
01040     UsimReadHplmnTmr = USIMAP_READ_HPLMN_TMR,
01041     UsimReadRplmnAct = USIMAP_READ_RPLMN_ACT,
01042     UsimReadFplmn = USIMAP_READ_FPLMN,
01043     UsimReadPlmn = USIMAP_READ_PLMN_LIST,
01044     UsimReadOplmn = USIMAP_READ_OPLMN_LIST,
01045     UsimReadHplmn = USIMAP_READ_HPLMN_LIST,
01046     UsimReadCsLoci = USIMAP_READ_CS_LOCI,
01047     UsimReadPsLoci = USIMAP_READ_PS_LOCI,
01048     UsimReadGsmCiphKey = USIMAP_READ_GSM_CIPH_KEY,
01049     UsimReadGprsCiphKey = USIMAP_READ_GPRS_CIPH_KEY,
01050     UsimReadCsCiphKey = USIMAP_READ_CS_CIPH_KEY,
01051     UsimReadPsCiphKey = USIMAP_READ_PS_CIPH_KEY,
01052     UsimReadAcmInfo = USIMAP_READ_ACM_INFO,
01053     UsimReadAcmMax = USIMAP_READ_ACM_MAX,
01054     UsimReadPuct = USIMAP_READ_PUCT,
01055     UsimReadSpn = USIMAP_READ_SPN,
01056     UsimReadDck = USIMAP_READ_DCK,
01057     UsimReadUst = USIMAP_READ_UST,
01058     UsimReadEst = USIMAP_READ_EST,
01059     UsimReadCbmi = USIMAP_READ_CBMI_LIST,
01060     UsimReadCbmid = USIMAP_READ_CBMID_LIST,
01061     UsimReadCbmir = USIMAP_READ_CBMIR_LIST,
01062     UsimReadCcp2 = USIMAP_READ_CCP2,
01063     UsimReadBcch =USIMAP_READ_BCCH,
01064     UsimReadPlmnSel = USIMAP_READ_PLMNSEL,
01065     UsimReadLangDefault = USIMAP_READ_LANG_DEFAULT,
01066     UsimReadLangPl = USIMAP_READ_LANG_PL,
01067     UsimReadLangLi = USIMAP_READ_LANG_LI,
01068     UsimReadLangElp = USIMAP_READ_LANG_ELP,
01069     UsimReadLangLp = USIMAP_READ_LANG_LP,
01070     UsimReadLangEcc = USIMAP_READ_ECC
01071 #else
01072     UsimReadNull = 0
01073 #endif
01074 };
01075
01076
01077 /*  ========================================================================
01078                                  UsimUpdateAction
01079     ======================================================================== */
01080 enum UsimUpdateAction {
01081 #if defined(APOXI_ICC_USIM)
01082     UsimUpdateInsert = USIMAP_UPDATE_INSERT,
01083     UsimUpdateOverwrite = USIMAP_UPDATE_OVERWRITE,
01084     UsimUpdateDelete = USIMAP_UPDATE_DELETE,
01085     UsimUpdateDeleteAll = USIMAP_UPDATE_DELETE_ALL,
01086 #else
01087     UsimUpdateInsert = 0
01088 #endif
01089 };
01090
01091 /*  ========================================================================
01092                                  UsimFileProperty
01093     ======================================================================== */
01094
01095 struct UsimFileProperty {
01096     SimFileType m_filetype;
01097     INT         m_filesize;
01098     INT         m_recordcount;
01099     INT         m_recordsize;
01100     ChvNo       m_readchv;
01101     ChvNo       m_updatechv;
01102 };
01103
01104 /*  ========================================================================
01105                                  UsimUst
01106     ======================================================================== */
01107
01108 #if ! defined(USIMAP_SERVICE_TABLE_LEN)
01109     #define USIMAP_SERVICE_TABLE_LEN 16
01110 #endif
01111
01112 struct UsimUst {
01113     UINT8 val[USIMAP_SERVICE_TABLE_LEN];
01114 };
01115
01116 /*  ========================================================================
01117                                  UsimEst
01118     ======================================================================== */
01119
01120 struct UsimEst {
01121     UINT8 val[USIMAP_SERVICE_TABLE_LEN];
01122 };
01123
01124
01125 /*  ========================================================================
01126                                  PsLociData
01127     ======================================================================== */
01128
01129 struct PsLociData {
01130     UINT8 val[14];
01131 };
01132
01133 /*  ========================================================================
01134                                  UsimLangFileType
01135     ======================================================================== */
01136
01138 enum UsimLangFileType {
01139 #if defined(APOXI_ICC_USIM)
01140     UsimLangDefault = LANG_FILE_DEFAULT,
01141     UsimLangPl      = LANG_FILE_PL,
01142     UsimLangLi      = LANG_FILE_LI,
01143     UsimLangElp     = LANG_FILE_ELP,
01144     UsimLangLp      = LANG_FILE_LP
01145 #else
01146     UsimLangDefault = 0
01147 #endif
01148
01149 };
01150
01151 /*  ========================================================================
01152                                  UsimLanguage
01153     ======================================================================== */
01154
01155 // language orginal T_USIMAP_LANG
01156 struct UsimLanguage {
01157     UINT8 val[2];
01158     WString GetWString() const {
01159         WCHAR temp[3] = { 0, 0, 0 };
01160         if(val[0]!=0xFF) {
01161             temp[0] = val[0];
01162             if(val[1]!=0xFF) {
01163                 temp[1] = val[1];
01164             }
01165         }
01166         return WString(temp);
01167     }
01168     void Set(const WString & str) {
01169         if(str.GetLength()>=1) {
01170             val[0] = ((UINT8)str[0]) & 0x7F;
01171             if(str.GetLength()>=2) {
01172                 val[1] = (UINT8)str[1] & 0x7F;
01173             } else {
01174                 val[1] = 0xFF;
01175             }
01176         } else {
01177             val[0] = 0xFF;
01178         }
01179     }
01180 };
01181
01182 #if ! defined(USIMAP_LANG_LIST_LEN)
01183     #define USIMAP_LANG_LIST_LEN 10
01184 #endif
01185
01186 const INT c_maxno_usim_langs = USIMAP_LANG_LIST_LEN;
01187
01188 // language request T_USIMAP_LANG_LIST
01189 struct UsimLanguageList {
01190     UsimLanguage val[c_maxno_usim_langs];
01191 };
01192
01193 /*  ========================================================================
01194                                  UsimEccRecord
01195     ======================================================================== */
01196
01197 #if ! defined(USIMAP_ALPHA_LEN)
01198     #define USIMAP_ALPHA_LEN 32
01199 #endif
01200
01201 // structure defined in SI_READ_ECC_CNF
01202 struct UsimEccRecord {
01203     UINT8  ecc[3];
01204     UINT16 length;
01205     UINT8  alphaid[USIMAP_ALPHA_LEN];
01206     UINT8  category;
01207 };
01208
01209 /*  ========================================================================
01210      CfuServices
01211     ======================================================================== */
01212 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01213
01214 enum CfuDataSource {    // T_MN_CFU_DATA_SOURCE
01216     CfuDataSourceInvalid = MN_CFU_SRC_VOID,
01218     CfuDataSourceCphs = MN_CFU_SRC_SIM_CPHS,
01220     CfuDataSourceCfis = MN_CFU_SRC_SIM_EF_CFIS,
01222     CfuDataSourceNvram = MN_CFU_SRC_NVRAM,
01224     CfuDataSourceNetwork = MN_CFU_SRC_NETWORK
01225 };
01226
01228 enum CfuServiceCode {   // T_MN_CFU_OP_CODE
01230     CfuInvalid = MN_CFU_OP_CODE_VOID,
01232     CfuActivated = MN_CFU_OP_CODE_SET,
01234     CfuDeactivated = MN_CFU_OP_CODE_RESET
01235 };
01236
01238 enum CfuArrayIndex {
01240     CfuTelephony = MN_CFU_TELEPHONY,
01242     CfuTelephonyLine2 = MN_CFU_TELEPHONY_L2,
01244     CfuFax = MN_CFU_FAX,
01246     CfuData = MN_CFU_DATA,
01247
01248     CfuArrayAccessMaxLines = MN_CFU_MAX_SERVICES    // == 4
01249 };
01250 #else
01251 enum CfuDataSource {
01252     CfuDataSourceInvalid,
01253     CfuDataSourceCphs,
01254     CfuDataSourceCfis,
01255     CfuDataSourceNvram,
01256     CfuDataSourceNetwork
01257 };
01258 enum CfuServiceCode {
01259     CfuInvalid,
01260     CfuActivated,
01261     CfuDeactivated
01262 };
01263 enum CfuArrayIndex {
01264     CfuTelephony,
01265     CfuTelephonyLine2,
01266     CfuFax,
01267     CfuData,
01268     CfuArrayAccessMaxLines  // == 4
01269 };
01270
01271 #endif
01272
01274 class CfuService
01275 {
01276     public:
01277         CfuService() : m_servicecode(CfuInvalid) {}
01278         CfuService(const CfuService & service)
01279             : m_servicecode(service.m_servicecode),
01280               m_forwardno(service.m_forwardno)  {}
01281
01282         CfuService & operator =(const CfuService &service)
01283         {
01284             if (&service != this) {     // guard from self assignment
01285                 m_servicecode = service.m_servicecode;
01286                 m_forwardno = service.m_forwardno;
01287             }
01288             return (*this);
01289         }
01290         void Set(CfuServiceCode servicecode, const PhoneNumber & phno) {
01291             m_servicecode = servicecode;
01292             m_forwardno = phno;
01293         }
01295         CfuServiceCode GetCfuServiceCode() const { return m_servicecode; }
01297         const PhoneNumber & GetForwardPhoneNumber() const { return m_forwardno; }
01298
01299     private:
01300         CfuServiceCode m_servicecode;
01301         PhoneNumber    m_forwardno;
01302 };
01303
01305 class CfuServiceArray
01306 {
01307     public:
01308         CfuServiceArray() : m_source(CfuDataSourceInvalid) { }
01309
01310         CfuServiceArray(const CfuServiceArray & array) {
01311             m_source = array.m_source;
01312             for(INT i=0; i<CfuArrayAccessMaxLines; i++) {
01313                 m_val[i] = array.m_val[i];
01314             }
01315         }
01316
01317         CfuServiceArray & operator =(const CfuServiceArray &array)
01318         {
01319             if (&array != this) {       // guard from self assignment
01320                 m_source = array.m_source;
01321                 for(INT i=0; i<CfuArrayAccessMaxLines; i++) {
01322                     m_val[i] = array.m_val[i];
01323                 }
01324             }
01325             return (*this);
01326         }
01327
01328         // merge the new array over the existing, means only changed values are set
01329         void Merge(const CfuServiceArray &array)
01330         {
01331             m_source = array.m_source;
01332             for(INT i=0; i<CfuArrayAccessMaxLines; i++) {
01333                 if(array.m_val[i].GetCfuServiceCode()!=CfuInvalid) {
01334                     m_val[i] = array.m_val[i];
01335                 }
01336             }
01337         }
01338
01339         // dumps out the content for debugging reasons
01340         void DbgOut() const
01341         {
01342 #if defined(_DEBUG)
01343             DBG_OUT((0," Source(%d) ",m_source));
01344             for(INT i=0; i<CfuArrayAccessMaxLines; i++) {
01345                 DBG_OUT((0,"%d=Code(%d) ",i,m_val[i].GetCfuServiceCode()));
01346             }
01347 #endif
01348         }
01349
01351         const CfuService & GetCfuService(CfuArrayIndex idx) const {
01352             ASSERT_DEBUG(idx<CfuArrayAccessMaxLines);
01353             return m_val[idx];
01354         }
01356         CfuDataSource GetCfuDataSource() const { return m_source; }
01357
01358         CfuDataSource  m_source;
01359         CfuService     m_val[CfuArrayAccessMaxLines];
01360 };
01361
01362
01363
01364
01366 //
01367 // AT RELATED STUFF
01368 //
01370
01371 /*  ========================================================================
01372                                   PbRequestBehaviour
01373     ========================================================================*/
01374
01376 enum PbRequestBehaviour  {
01378     PbRequestEmpty,
01380     PbRequestAutomatic,
01382     PbRequestMMI            ,
01383 };
01384
01385
01387 //
01388 // CALL RELATED STUFF
01389 //
01391
01392
01393
01394 /*  ========================================================================
01395                                     Call
01396     ========================================================================*/
01397 typedef SdlInteger Tipd;
01398 typedef SdlInteger Volume;
01399
01400 const SdlInteger    c_null_tipd = -1;           // NULL_TI_PD;
01401 const SdlInteger    c_no_tipd = MN_NO_TI_PD;
01402 const Tipd          c_mtc_mask = 0x80;          // msb of tipd set -> MTC
01403
01404 enum CallProgressInd {
01405     NoProgress              = MN_PROGRESS_NONE,
01406     Alerting                = MN_ALERTING,
01407     MtcAccepted             = MN_MT_CALL_ACCEPTED,
01408     InBandTonesAvailable    = MN_IN_BAND_TONES_AVAILABLE,
01409     InBandTonesNotAvailable = MN_IN_BAND_TONES_NOT_AVAILABLE,
01410     SpeechMtcAccepted       = MN_TCH_SPEECH_MT_CALL_ACCEPTED,
01411     SpeechTonesAvailable    = MN_TCH_SPEECH_TONES_AVAILABLE,
01412     SpeechTonesNotAvailable = MN_TCH_SPEECH_TONES_NOT_AVAILABLE,
01413     Speech                  = MN_TCH_SPEECH,
01414     Data                    = MN_TCH_DATA,
01415     NotSpeech               = MN_TCH_NOT_SPEECH,
01416     };
01417
01418
01419 enum CallErrorCause{ // gsm 4.08, v7.7.0 p 636 - 637
01420     // normal class
01421     UnassignedNumber                = MN_UNASSIGNED_NUMBER,
01422     NoRoute                         = MN_NO_ROUTE,
01423     ChannelUnacceptable             = MN_CHANNEL_UNACCEPTABLE,
01424     OperatorBarring                 = MN_OPERATOR_BARRING,
01425     NormalCallClear                 = MN_NORMAL_CALL_CLEARING,
01426     UserBusy                        = MN_USER_BUSY,
01427     NoUserResponding                = MN_NO_USER_RESPONDING,
01428     UserAlertingNoAnser             = MN_USER_ALERTING_NO_ANSWER,
01429     CallRejected                    = MN_CALL_REJECTED,
01430     NumberChanged                   = MN_NUMBER_CHANGED,
01431     NonSelectedUserClearing         = MN_NON_SELECTED_USER_CLEARING,
01432     DestinationOutOfOrder           = MN_DESTINATION_OUT_OF_ORDER,
01433     InvalidNumberFormat             = MN_INVALID_NUMBER_FORMAT,
01434     FacilityRejected                = MN_FACILITY_REJECTED,
01435     ResponseToStatusEnquiry         = MN_RESPONSE_TO_STATUS_ENQUIRY,
01436     NormalUnspecified               = MN_NORMAL_UNSPECIFIED,
01437     // resource unvailable class
01438     NoCircuitAvailable              = MN_NO_CIRCUIT_AVAILABLE,
01439     NetworkOutOfOrder               = MN_NETWORK_OUT_OF_ORDER,
01440     TemporaryFailure                = MN_TEMPORARY_FAILURE,
01441     SwitchCongestion                = MN_SWITCH_CONGESTION,
01442     AccessInformationDiscarded      = MN_ACCESS_INFORMATION_DISCARDED,
01443     ReqeustedCircuitNotAvailable    = MN_REQUESTED_CIRCUIT_NOT_AVAILABLE,
01444     RessourcesUnavailable           = MN_RESOURCES_UNAVAILABLE,
01445     // service or option class not available
01446     QualityUnavailable              = MN_QUALITY_UNAVAILABLE,
01447     FacilityNotSubscribed           = MN_FACILITY_NOT_SUBSCRIBED,
01448     IncomingCallsBarredInCug        = MN_INCOMING_CALLS_BARRED_IN_CUG,
01449     BearerCapabilityNotAllowed      = MN_BEARER_CAPABILITY_NOT_ALLOWED,
01450     BearerCapabilityNotAvailable    = MN_BEARER_CAPABILITY_NOT_AVAILABLE,
01451     ServiceNotAvailable             = MN_SERVICE_NOT_AVAILABLE,
01452     AcmGreaterOrEqualToAcmmax       = MN_ACM_GREATER_OR_EQUAL_TO_ACMMAX,
01453     // service or option not implemented
01454     BearerServiceNotImplemented     = MN_BEARER_SERVICE_NOT_IMPLEMENTED,
01455     FacilityNotImplemented          = MN_FACILITY_NOT_IMPLEMENTED,
01456     OnlyRestrictedDigital           = MN_ONLY_RESTRICTED_DIGITAL,
01457     ServiceNotImplemented           = MN_SERVICE_NOT_IMPLEMENTED,
01458     // Invalid message
01459     InvalidTi                       = MN_INVALID_TI,
01460     UserNotInCug                    = MN_USER_NOT_IN_CUG,
01461     IncompatibleDestination         = MN_INCOMPATIBLE_DESTINATION,
01462     InvalidTransitNetwork           = MN_INVALID_TRANSIT_NETWORK,
01463     SemanticsIncorrect              = MN_SEMANTICS_INCORRECT,
01464     // protocoll error
01465     InvalidMandatoryInformation     = MN_INVALID_MANATORY_INFORMATION,
01466     UnknowMsgType1                  = MN_UNKNOWN_MESSAGE_TYPE_1,
01467     UnexpectedMsgType               = MN_UNEXPECTED_MESSAGE_TYPE,
01468     UnexpectedIe                    = MN_UNEXPECTED_IE,
01469     ConditionalIeError              = MN_CONDITIONAL_IE_ERROR,
01470     UnknownMsgType2                 = MN_UNKNOWN_MESSAGE_TYPE_2,
01471     RecoveryOnTimerExpiry           = MN_RECOVERY_ON_TIMER_EXPIRY,
01472     ProtocolError                   = MN_PROTOCOL_ERROR,
01473     // interworking classes
01474     Interworking                    = MN_INTERWORKING,
01475
01476     // the following stuff is Comneon/MN specific
01477
01478     VoidCause                       = MN_VOID_CAUSE,
01479     OutofMemory                     = MN_OUT_OF_MEMORY,
01480     InvalidParam                    = MN_INVALID_PARAM,
01481     DataCallActive                  = MN_DATA_CALL_ACTIVE,
01482     SpeechCallActive                = MN_SPEECH_CALL_ACTIVE,
01483     DtmfRejDuringMocSetup           = MN_DTMF_REJECTED_DURING_MO_CALL_SETUP,
01484     MocSetupRejMissingAcmInfoInd    = MN_MOC_SETUP_REJ_DUE_TO_MISSING_ACM_INFO_IND,
01485     TempForbiddenCallAttempt        = MN_TEMPORARY_FORBIDDEN_CALL_ATTEMPT,
01486     CalledPartyBlacklisted          = MN_CALLED_PARTY_IS_BLACKLISTED,
01487     BlacklistFullNoAutoCallAttempts = MN_BLACKLIST_IS_FULL_NO_AUTO_CALL_ATTEMPTS,
01488     TempForbiddenCallAttemptNoService   = MN_TEMPORARY_FORBIDDEN_CALL_ATTEMPT_NO_SERVICE,
01489     TempForbiddenCallAttemptLimitedServe    = MN_TEMPORARY_FORBIDDEN_CALL_ATTEMPT_LIMITED_SERVICE,
01490     ClientTemporaryBarred           = MN_CLIENT_TEMPORARY_BARRED,
01491     DualServiceCallActive           = MN_DUAL_SERVICE_CALL_ACTIVE,
01492     AtcFclassNotSpeech              = MN_ATC_FCLASS_NOT_SPEECH,
01493     SiUnknownError                  = MN_SI_UNKNOWN_ERROR,
01494     DtmfRejCallHeldOrMparty         = MN_DTMF_REJECTED_DUE_TO_CALL_HELD_OR_MPARTY,
01495     ClientNotRegistered             = MN_CLIENT_NOT_REGISTRATED,
01496     ActiveClientGone                = MN_ACTIVE_CLIENT_GONE,
01497     DtmfRejDataTransmission         = MN_DTMF_REJECTED_DUE_TO_DATA_TRANSMISSION,
01498     NoAppropriateDtmfEntry          = MN_NO_APPROPRIATE_DTMF_ENTRY,
01499     SimStatusFailure                = MN_SIM_STATUS_FAILURE,
01500     // SIMTK specific stuff
01501     SimtkSetupModeNotSupported      = MN_SIMTK_SETUP_MODE_NOT_SUPPORTED,
01502     MmiNotRegistered                = MN_MMI_NOT_REGISTERED,
01503     SimtkSetupRejMissingAcmInfoInd  = MN_SIMTK_SETUP_REJ_DUE_TO_MISSING_ACM_INFO_IND,
01504     SimtkSetupRejByUser             = MN_SIMTK_SETUP_REJECTED_BY_THE_USER,
01505     SimtkSetupRejTimeOut            = MN_SIMTK_SETUP_REJECTED_TIME_OUT,
01506     SimtkCallConnected              = MN_SIMTK_CALL_CONNECTED,
01507     DisconnectDueToSimtkSetup       = MN_DISCONNECT_DUE_TO_SIMTK_SETUP,
01508     SimtkSetupRejPendingSimtkSetup  = MN_SIMTK_SETUP_REJ_DUE_TO_PENDING_SIMTK_SETUP,
01509     SimtkCallConnectedNoIconDisplay = MN_SIMTK_CALL_CONNECTED_NO_ICON_DISPLAY,
01510     PendingSimtkSetup               = MN_PENDING_SIMTK_SETUP,
01511     SimtkSimReset                   = MN_SIMTK_SIM_RESET,
01512 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01513     DtmfRejectedDueToSupTimerExpiry = MN_DTMF_REJECTED_DUE_TO_SUP_TIMER_EXPIRY,
01514 #else
01515     DtmfRejectedDueToSupTimerExpiry,
01516 #endif
01517
01518     RejByCallControl    = MN_REJ_BY_CALL_CONTROL,
01519     FdnFailed           = MN_FDN_FAILED,
01520     BdnFailed           = MN_BDN_FAILED,
01521     OnlyError           = MN_ONLY_ERROR,
01522     NotInSpeechCall     = MN_NOT_IN_SPEECH_CALL,
01523     InvalidAlsLine      = MN_INVALID_ALS_LINE,
01524     LndOverflow         = MN_LND_OVERFLOW,
01525
01526     DtmfRejectedNoTchAvailable  = MN_DTMF_REJECTED_NO_TCH_AVAILABLE,
01527     NwFailureUnspecified        = MN_NW_FAILURE_UNSPECIFIED,
01528     MsNoService                 = MN_MS_NO_SERVICE,
01529     MsAccessClassBarred         = MN_MS_ACCESS_CLASS_BARRED,
01530     MsNoResource                = MN_MS_NO_RESOURCE,
01531     MsServiceBusy               = MN_MS_SERVICE_BUSY,
01532     MsFailureUnspecified        = MN_MS_FAILURE_UNSPECIFIED,
01533
01534     ProactiveSimApplTerminatedByUser= MN_PROACTIVE_SIM_APPL_TERMINATED_BY_USER,
01535
01536     //SimtkDtmfTransmitted          = MN_SIMTK_DTMF_TRANSMITTED, //311
01537     //SimtkDtmfTransmittedNoIconDisplay     = MN_SIMTK_DTMF_TRANSMITTED_NO_ICON_DISPLAY,  //312
01538     //UserDidNotAcceptCallSetup         = MN_USER_DID_NOT_ACCEPT_CALL_SETUP,  //313
01539
01540     CcbsPossible            = MN_CCBS_POSSIBLE,  //283
01541
01542     // ASC specific stuff
01543     ClientRejected    = 995,
01544     UnknownErrorCause = 996, //zukunftssicher durch hohe werte?
01545     CallChangedToSs   = 997,
01546     CallChangedToUssd = 998,
01547     NoCallError       = 999
01548     };
01549
01550
01551 enum CallRelatedSsCode {
01552     VoidSsCode              = MN_VOID_SS_SERV_CODE,
01553     Clip                    = MN_CLIP,
01554     Clir                    = MN_CLIR,
01555     Colp                    = MN_COLP,
01556     Colr                    = MN_COLR,
01557     AllForwardingSs         = MN_ALL_FORWARDING_SS,
01558     Cfu                     = MN_CFU,
01559     AllCondForwardingSs     = MN_ALL_COND_FORWARDING_SS,
01560     Cfb                     = MN_CFB,
01561     Cfnry                   = MN_CFNRY,
01562     Cfnrc                   = MN_CFNRC,
01563     ExplicitCallTransfer    = MN_EXPLICT_CALL_TRANSFER,
01564     Cw                      = MN_CW,
01565     Hold                    = MN_HOLD,
01566     MultiParty              = MN_MULTIPTY,
01567     Cug                     = MN_CUG,
01568     Aoci                    = MN_AOCI,
01569     Aocc                    = MN_AOCC,
01570     AllCallRestrictionsSs   = MN_ALL_CALL_RESTRICTIONS_SS,
01571     BarringOfOutgoingCalls  = MN_BARRING_OF_OUTGOING_CALLS,
01572     Baoc                    = MN_BAOC,
01573     Boic                    = MN_BOIC,
01574     BoicExHc                = MN_BOIC_EX_HC,
01575     BarringOfIncomingCalls  = MN_BARRING_OF_INCOMING_CALLS,
01576     Baic                    = MN_BAIC,
01577     BicRoam                 = MN_BIC_ROAM,
01578 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01579     Cnap                    = MN_CNAP,
01580 #else
01581     Cnap,
01582
01583 #endif
01584     Emlpp                   = MN_EMLPP,
01585
01586
01587     // additions for ASC
01588     UusService1             = 1000,         // hopefully there will never be more than 999 Supplementary Services
01589     UusService2,
01590     UusService3,
01591     AllUusServices,
01592     Fm,
01593     Msp,
01594     Mc,
01595     Cd,
01596     Ussd,
01597     AllSsServices,
01598     NoSsCode
01599
01600 };
01601
01602 enum GsmSignal {
01603     DialToneOn              = MN_SIG_DIAL_TONE_ON,
01604     RingBackToneOn          = MN_SIG_RING_BACK_TONE_ON,
01605     InterceptToneon         = MN_SIG_INTERCEPT_TONE_ON,
01606     CongestionToneOn        = MN_SIG_CONGESTION_TONE_ON,
01607     BusyToneOn              = MN_SIG_BUSY_TONE_ON,
01608     ConfirmToneOn           = MN_SIG_CONFIRM_TONE_ON,
01609     AnswerToneOn            = MN_SIG_ANSWER_TONE_ON,
01610     CallWaitToneOn          = MN_SIG_CALL_WAIT_TONE_ON,
01611     OffHookToneOn           = MN_SIG_OFF_HOOK_TONE_ON,
01612     TonesOff                = MN_SIG_TONES_OFF,
01613     AlertingOff             = MN_SIG_ALERTING_OFF,
01614     IeMissing               = MN_SIG_IE_MISSING
01615     };
01616
01617 enum CallEstCause {
01618     EmergencyCall   = EMERGENCY_CALL,
01619     CallReEst       = CALL_REEST,
01620     FullTchNeeded   = TCH_F_NEEDED,
01621     HalfTchSpeech   = SPEECH_TCH_H,
01622     HalfTchData     = DATA_TCH_H,
01623     LocationUpdate  = LOCATION_UPDATE,
01624     Other           = OTHER,
01625     UndefinedCallEstCause
01626     };
01627
01628
01629 enum ClirMode{                              // GSM 02.81, 2.3.7
01630     SuppressPhoneNumber = MN_CLIR_INVOKE,   // restrict line identification
01631     DisplayPhoneNumber  = MN_CLIR_SUPPRESS, // do not restrict line identification
01632     DontCare            = MN_CLIR_NONE      // decision is done by network
01633     };
01634
01635
01636 enum CugSelector{                           // used to carry CUG information
01637     PreferedCug = MN_PREFERENTIAL_CUG,      // use preferential CUG index
01638     CugIndex    = MN_CUG_INDEX,             // use CUG index gvien in param
01639     NoCug       = MN_NO_CUG                 // use none of them
01640     };
01641
01642
01643 struct CugDescriptor {                      // GSM 02.85
01644     CugSelector selected_cug;               // carries CUG information
01645     INT         index;                      // CUG index, if given
01646     BOOLEAN     suppress_oa;                // suppress outgoing access
01647     };
01648
01649
01650 enum CallState {
01651     MocSetup            = MN_MOC_CALL_SETUP,
01652     MocStarted          = MN_MOC_CALL_STARTED,
01653     MocActive           = MN_MOC_CALL_ACTIVE,
01654     MtcConfirmed        = MN_MTC_CALL_CONFIRMED,
01655     MtcSetup            = MN_MTC_CALL_SETUP,
01656     MtcBcNegotiated     = MN_MTC_BC_NEGOTIATED,
01657     MtcStarted          = MN_MTC_CALL_STARTED,
01658     MtcActive           = MN_MTC_CALL_ACTIVE,
01659     MocAsCallSetup      = MN_MOC_AS_CALL_SETUP,
01660     MtcAsCallSetup      = MN_MTC_AS_CALL_SETUP,
01661     MtcRejected         = MN_MTC_CALL_REJECTED,
01662     CallIsHeld          = MN_CALL_IS_HELD,
01663     CallIsRetrieved     = MN_CALL_IS_RETRIEVED,
01664     MptyIsActive        = MN_MPARTY_IS_ACTIVE,
01665     MptyIsHeld          = MN_MPARTY_IS_HELD,
01666     MptyIsRetrieved     = MN_MPARTY_IS_RETRIEVED,
01667     MptyIsSplitted      = MN_MPARTY_IS_SPLITTED,
01668     IsEct               = MN_IS_ECT,
01669     CallDiscReq         = MN_CALL_DISC_REQ,
01670     CallIsCleared       = MN_CALL_IS_CLEARED,
01671     CallModifyIndicated = MN_CALL_MODIFY_INDICATED,
01672     CallModifyStarted   = MN_CALL_MODIFY_STARTED,
01673     CallModifyCompleted = MN_CALL_MODIFY_COMPLETED,
01674     CallModifyRejected  = MN_CALL_MODIFY_REJECTED,
01675 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01676     MocAlerted          = MN_MOC_CALL_ALERTED,
01677     CallIsDisconnected  = MN_CALL_IS_DISCONNECTED,
01678     CallIsDeflected     = MN_CALL_IS_DEFLECTED,
01679 #else
01680     MocAlerted,
01681     CallIsDisconnected,
01682     CallIsDeflected,
01683 #endif
01684
01685 #if defined(APOXI_3GPP_REL_4_5)
01686     MptyStarted             = MN_MPARTY_STARTED, /* Multi-Party built is started*/
01687     MptyRejected            = MN_MPARTY_REJECTED,/* Multi-Party built  was rejected from the network */
01688     MptyRetrievedStarted    = MN_MPARTY_RETRIEVE_STARTED,/* Multi-Party retrieved was started */
01689     MptyRetrieveRejected    = MN_MPARTY_RETRIEVE_REJECTED,/* Multi-Party retrieved was rejected from the network */
01690     MpartySplitStarted      = MN_MPARTY_SPLIT_STARTED,/* Multi-Party splited was started */
01691     MptySplitRejected       = MN_MPARTY_SPLIT_REJECTED,/* Multi-Party splitted was rejected from the network */
01692     MptyHeldStarted         = MN_MPARTY_HELD_STARTED,/* Multi-Party held was started */
01693     MptyHeldRejected        = MN_MPARTY_HELD_REJECTED,/* Multi-Party held was was rejected from the network */
01694     CallDeflectionStarted   = MN_CALL_DEFLECTION_STARTED,/* Call Deflection was started */
01695     CallDeflectionRejected  = MN_CALL_DEFLECTION_REJECTED,/* Call Deflection was rejected from the network */
01696     CallHeldStarted         = MN_CALL_HELD_STARTED,/* MO/MT Call held was started */
01697     CallHeldRejected        = MN_CALL_HELD_REJECTED,/* MO/MT Call held was rejected from the network */
01698     CallRetrieveStarted     = MN_CALL_RETRIEVE_STARTED,/* MO/MT Call retrieved was started */
01699     CallRetrieveRejected    = MN_CALL_RETRIEVE_REJECTED,/* MO/MT Call retrieved was rejected from the network */
01700     EctStarted              = MN_ECT_STARTED,/* Explicit call transfer was started */
01701     EctRejected             = MN_ECT_REJECTED/* Explicit call transfer was rejected from the network */
01702 #else
01703
01704     MptyStarted, /* Multi-Party built is started*/
01705     MptyRejected,/* Multi-Party built  was rejected from the network */
01706     MptyRetrievedStarted,/* Multi-Party retrieved was started */
01707     MptyRetrieveRejected,/* Multi-Party retrieved was rejected from the network */
01708     MpartySplitStarted,/* Multi-Party splited was started */
01709     MptySplitRejected,/* Multi-Party splitted was rejected from the network */
01710     MptyHeldStarted,/* Multi-Party held was started */
01711     MptyHeldRejected,/* Multi-Party held was was rejected from the network */
01712     CallDeflectionStarted,/* Call Deflection was started */
01713     CallDeflectionRejected,/* Call Deflection was rejected from the network */
01714     CallHeldStarted,/* MO/MT Call held was started */
01715     CallHeldRejected,/* MO/MT Call held was rejected from the network */
01716     CallRetrieveStarted,/* MO/MT Call retrieved was started */
01717     CallRetrieveRejected,/* MO/MT Call retrieved was rejected from the network */
01718     EctStarted,/* Explicit call transfer was started */
01719     EctRejected/* Explicit call transfer was rejected from the network */
01720 #endif
01721 };
01722
01723
01724 enum CallType {
01725     NoDataCall      = MN_NO_DATA_CALL,
01726     FacsimileCall   = MN_FACSIMILE_CALL,
01727     DataCall        = MN_DATA_CALL,
01728     MmCall,
01729     VoidCallType
01730 };
01731
01732 /*****
01733 * T_DATA_CALL_TYPE
01734 * /vobs/ms-hosttest/mi/src/../../../ms-interface-src/pr/msap_msg_mn_ds.pr,70,9
01735 ******/
01736
01737 #if defined(APOXI_3GPP_REL_99)
01738 enum DataCallType {
01739     CsdNone   = CSD_NONE,
01740     CsdDataT  = CSD_DATA_T,
01741     CsdDataNt = CSD_DATA_NT,
01742     CsdFax    = CSD_FAX,
01743     CsdWap    = CSD_WAP,
01744     CsdVoice,
01745     CsdMultimedia
01746 };
01747
01748 #else
01749 enum DataCallType {
01750     CsdNone   = CSD_NONE,
01751     CsdDataT  = CSD_DATA_T,
01752     CsdDataNt = CSD_DATA_NT,
01753     CsdFax    = CSD_FAX,
01754     CsdVoice  = CSD_VOICE,
01755     CsdMultimedia = CSD_MULTIMEDIA,
01756     CsdWap    = CSD_WAP
01757 };
01758 #endif
01759
01760 enum ServedCallApplication {
01761     AppUnknown  = MN_APPL_UNKNOWN,      // Application is unknown - default
01762     AppSpeech   = MN_APPL_SPEECH,       // Speech (MMI/ATC) is being served
01763     AppData     = MN_APPL_DATA,         // Data (Data Services) is being served
01764     AppDual     = MN_APPL_DUAL,         // Dual Services (DS and ATC) is being served
01765     AppStkSpeech= MN_APPL_SIMTK_SPEECH  // Speech (initiated by SIM-Toolkit, processed by MMI) is being served
01766 };
01767
01768 enum UusOutTextType {
01769     SendOnAny = MN_UUS1_MSG_OUT_ANY,
01770     SendOnSetup = MN_UUS1_MSG_OUT_SETUP,
01771     SendOnAlerting = MN_UUS1_MSG_OUT_ALERTING,
01772     SendOnConnect = MN_UUS1_MSG_OUT_CONNECT,
01773     SendOnDisconnect = MN_UUS1_MSG_OUT_DISCONNECT,
01774     SendOnRelease = MN_UUS1_MSG_OUT_RELEASE,
01775     SendOnReleaseComplete = MN_UUS1_MSG_OUT_REL_COMPL
01776 };
01777
01778 const INT c_max_uus1_out_buffer_len = MAX_UUS1_OUT_BUFFER_LEN;
01779
01780 enum UusInTextType {
01781     ReceivedOnAnySetup = MN_UUS1_MSG_IN_SETUP,
01782     ReceivedOnAnyAlerting = MN_UUS1_MSG_IN_ALERTING,
01783     ReceivedOnProgress = MN_UUS1_MSG_IN_PROGRESS,
01784     ReceivedOnAnyConnect = MN_UUS1_MSG_IN_CONNECT,
01785     ReceivedOnAnyDisconnect = MN_UUS1_MSG_IN_DISCONNECT,
01786     ReceivedOnAnyRelease = MN_UUS1_MSG_IN_RELEASE,
01787     ReceivedOnAnyReleaseComplete = MN_UUS1_MSG_IN_REL_COMPL
01788 };
01789
01790 struct UusText {
01791     UusOutTextType type;
01792     WString text;
01793 };
01794
01795 /*  ------------------------------------------------------------------------
01796     Call Related SS enum types for MN_CRSS_REQ
01797     ------------------------------------------------------------------------ */
01798 enum CallRelatedSs {
01799     RelAllHeldCalls         = MN_REL_ALL_HELD_CALLS,
01800     RelAllActiveCalls       = MN_REL_ALL_ACT_CALLS,
01801     RelSpecificActiveCall   = MN_REL_SPECIFIC_ACT_CALL,
01802     HoldActiveCall          = MN_HOLD_ACTIVE_CALL,
01803     RetrieveCall            = MN_RETRIEVE_CALL,
01804     BuildMparty             = MN_BUILD_MPARTY,
01805     HoldMparty              = MN_HOLD_MPARTY,
01806     RetrieveMparty          = MN_RETRIEVE_MPARTY,
01807     SplitMparty             = MN_SPLIT_MPARTY,
01808     Ect                     = MN_ECT,
01809     ActivateCCBS            =   MN_ACTIVATE_CCBS,           // Manik added 06-Aug-2003
01810     InvokeCallDeflection    =   MN_INVOKE_CALL_DEFLECTION,  // Manik added 06-Aug-2003
01811     InvalidCallRelatedSs
01812 };
01813
01814
01815 /*  ------------------------------------------------------------------------
01816     Call Related SS enum types for MN_HOLD_CNF
01817     ------------------------------------------------------------------------ */
01818
01819 enum CallRelatedSsState {
01820     CallActive      = MN_CALL_ACTIVE,
01821     CallHeld        = MN_CALL_HELD,
01822     InvalidCallRelatedSsState
01823 };
01824
01825 enum HoldIndicator {
01826     CallRetrieved   = MN_CALL_RETRIEVED,
01827     CallOnHold      = MN_CALL_ON_HOLD,
01828     VoidHoldInd     = MN_VOID_HOLD_INDICATOR
01829 };
01830
01831 enum EctCallState {
01832     EctAlerting         = MN_ECT_ALERTING,
01833     EctActive           = MN_ECT_ACTIVE,
01834     EctVoidCallState    = MN_VOID_ECT_CALLSTATE
01835 };
01836
01837 enum RdnChoice {
01838     RdnPresentationAllowedAddr  = MN_RDN_PRESENTATION_ALLOWED_ADDR,
01839     RdnPresentationRestricted   = MN_RDN_PRESENTATION_RESTRICTED,
01840     RdnNumberNotAvailable       = MN_RDN_NUMBER_NOT_AVAILABLE,
01841     RdnPresentationRestrictAddr = MN_RDN_PRESENTATION_RESTRICT_ADDR,
01842     RdnVoidChoice               = MN_VOID_RDN_CHOICE
01843 };
01844
01845 struct Subaddress {
01846     // TODO: Clariyfy sense of address (may change to PhoneNumber)
01847     BOOLEAN     available;
01848     PhoneNumber address;
01849 };
01850
01851 struct Rdn {
01852     // TODO: check subaddress (what is, sense etc)
01853     RdnChoice   selector;   // enum
01854     PhoneNumber phone_number;
01855     Subaddress  subaddress;
01856 };
01857
01858 struct EctIndicator {
01859     EctCallState    ect_callstate;
01860     Rdn             rdn;
01861 };
01862
01863 enum CnameChoice {
01864 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
01865     NamePresentationAllowed     = MN_CNAME_NAME_PRES_ALLOWED,
01866     PresentationRestricted      = MN_CNAME_PRESENTATION_RESTRICTED,
01867     NameUnavailable             = MN_CNAME_NAME_UNAVAILABLE,
01868     NamePresentationRestricted  = MN_CNAME_NAME_PRES_RESTRICTED,
01869 #else
01870     NamePresentationAllowed,
01871     PresentationRestricted,
01872     NameUnavailable,
01873     NamePresentationRestricted,
01874 #endif
01875     CnameVoidChoice
01876 };
01877
01878 const INT c_max_cname_string_len = 160;
01879
01880 struct CallingName {
01881     CnameChoice         cname_selector;
01882     DataCodingScheme    data_coding_scheme;
01883     WString             name_string;
01884 };
01885
01886 struct NameIndicator {
01887     BOOLEAN         name_indicator_present;
01888     CallingName     calling_name;
01889 };
01890
01891 struct NotifySsArg {
01892     CallRelatedSsCode   ss_code;            // which suppl. service (all services!!!)
01893     SsStatus            ss_status;          // quiescent, registered, activated
01894     SsNotification      ss_notification;    // call forwarded to calling,forwarding, forwared-to
01895     BOOLEAN             call_wait_indicator;// call waiting?
01896     HoldIndicator       call_hold_indicator;// call on hold or retrieved
01897     BOOLEAN             mpty_indicator;     // refers to mpty?
01898     INT                 cug_index;          // index of selected CUG
01899     BOOLEAN             clir_supp_rejected; // overrule category?
01900     EctIndicator        ect_indicator;      //
01901     NameIndicator       name_indicator;     // CNAP Name indicator
01902 };
01903
01904 enum NotificationDescription {
01905     UserSuspended = MN_USER_SUSPENDED,
01906     UserResumed =   MN_USER_RESUMED,
01907     BearerChange =  MN_BEARER_CHANGE,
01908 };
01909
01910
01911 enum AocChargingStatus {
01912     AocInformation          = Aoci,
01913     AocCharging             = Aocc,
01914     NoAoc                   = VoidSsCode,
01915     InvalidChargingStatus
01916     };
01917
01918 // CurrencyCode orginal T_SI_ARR_3
01919 struct CurrencyCode {
01920     UINT8  val[3];
01921 };
01922
01923 struct AocChargeData {
01924     ULONG   charge_value;
01925     INT     exponent;
01926 };
01927
01928
01929 /*  ------------------------------------------------------------------------
01930     Call Related SS enum types for MN_DIAGNOSTIC_IND
01931     ------------------------------------------------------------------------ */
01932 enum DiagnosticCause {
01933     VoidDiagnostic         = MN_VOID_DIAGNOSTIC,
01934     OutgCallsBarredWithCug = MN_OUTG_CALLS_BARRED_WITHIN_CUG,
01935     NoCugSelected          = MN_NO_CUG_SELECTED,
01936     UnknownCugIndex        = MN_UNKNOWN_CUG_INDEX,
01937     CugIndexIncompatible   = MN_CUG_INDEX_INCOMPATIBLE,
01938     CugCallFailure         = MN_CUG_CALL_FAILURE,
01939     ClirNotSubscribed      = MN_CLIR_NOT_SUBSCRIBED,
01940     CcbsAllowed            = MN_CCBS_ALLOWED,
01941     CcbsNotAllowed         = MN_CCBS_NOT_ALLOWED,
01942     UnknownDiagnosticCause
01943 };
01944
01945 /*  ========================================================================
01946                                     SS
01947     ======================================================================== */
01948 const INT c_max_size_ussd_string        = MN_MAX_USSD_STRING_LENGTH;            // 200
01949 const INT c_max_no_basic_service_groups = MN_MAX_NUMBER_BASIC_SERVICE_GROUPS;   // 13
01950 const INT c_password_len                = 4;
01951
01952 // typedef UINT8 SsErrorCode;
01953 // typedef UINT8 SsProblemTag;
01954 // typedef UINT8 SsProblemCode;
01955 // typedef UINT8 MnSsStatus;
01956 typedef CallRelatedSsCode SsCode;
01957 typedef CallErrorCause MnCause;
01958 typedef CallErrorCause DcError;
01959
01961 enum SsOperationCode {
01962     UnkownSsCode            = MN_VOID_SS_OP_CODE,
01963     ScRegister              = MN_REGISTER_SS,
01964     ScErase                 = MN_ERASE_SS,
01965     ScActivate              = MN_ACTIVATE_SS,
01966     ScDeactivate            = MN_DEACTIVATE_SS,
01967     ScInterrogate           = MN_INTERROGATE_SS,
01968     ScNotify                = MN_NOTIFY_SS,
01969     ScRegisterPassword      = MN_REGISTER_PASSWORD,
01970     ScGetPassword           = MN_GET_PASSWORD,
01971     ScProcessUssd           = MN_PROCESS_UNSTRUCTURED_SS_DATA,
01972     ScForwardCheckIndication = MN_FORWARD_CHECK_SS_INDICATION,
01973     ScProcessUssdRequest    = MN_PROCESS_UNSTRUCTURED_SS_REQUEST,
01974     ScUssdRequest           = MN_UNSTRUCTURED_SS_REQUEST,
01975     ScUssdNotify            = MN_UNSTRUCTURED_SS_NOTIFY,
01976     ScForwardCugInfo        = MN_FORWARD_CUG_INFO,
01977     ScSplitMpty             = MN_SPLIT_MPTY,
01978     ScRetrieveMpty          = MN_RETRIEVE_MPTY,
01979     ScScHoldMpty            = MN_HOLD_MPTY,
01980     ScBuildMpty             = MN_BUILD_MPTY,
01981     ScForwardChargeAdvice   = MN_FORWARD_CHARGE_ADVICE,
01982     ScExplicitCt            = MN_EXPLICIT_CT,
01983     ScSetupUusText
01984 };
01985
01986 /*  ------------------------------------------------------------------------
01987     Service Group Types
01988     ------------------------------------------------------------------------ */
01989 enum ServiceGroup {
01990     UnknownSerivceGroup                 = MN_VOID_SERV_GROUP,
01991     AllTeleservices                     = MN_ALL_TELESERVICES,
01992     AllSpeechTransmissionServices       = MN_ALL_SPEECH_TRANSMISSION_SERVICES,
01993     Telephony                           = MN_TELEPHONY,
01994     EmergencyCalls                      = MN_EMERGENCY_CALLS,
01995     AllShortMessageServices             = MN_ALL_SHORT_MESSAGE_SERVICES,
01996     ShortMessageMtPp                    = MN_SHORT_MESSAGE_MT_PP,
01997     ShortMessageMoPp                    = MN_SHORT_MESSAGE_MO_PP,
01998     AllFacsimileTransmissionServices    = MN_ALL_FACSIMILE_TRANSMISSION_SERVICES,
01999     FacsimileGroup3AndAlterSpeech       = MN_FACSIMILE_GROUP3_AND_ALTER_SPEECH,
02000     AutomaticFacsimileGroup3            = MN_AUTOMATIC_FACSIMILE_GROUP3,
02001     FacsimileGroup4                     = MN_FACSIMILE_GROUP4,
02002     AllDataTeleservices                 = MN_ALL_DATA_TELESERVICES,
02003     AllTeleservicesExceptSms            = MN_ALL_TELESERVICES_EXCEPT_SMS,
02004     AllPlmnSpecificTs                   = MN_ALL_PLMN_SPECIFIC_TS,
02005     PlmnSpecificTs1                     = MN_PLMN_SPECIFIC_TS_1,
02006     PlmnSpecificTs2                     = MN_PLMN_SPECIFIC_TS_2,
02007     PlmnSpecificTs3                     = MN_PLMN_SPECIFIC_TS_3,
02008     PlmnSpecificTs4                     = MN_PLMN_SPECIFIC_TS_4,
02009     PlmnSpecificTs5                     = MN_PLMN_SPECIFIC_TS_5,
02010     PlmnSpecificTs6                     = MN_PLMN_SPECIFIC_TS_6,
02011     PlmnSpecificTs7                     = MN_PLMN_SPECIFIC_TS_7,
02012     PlmnSpecificTs8                     = MN_PLMN_SPECIFIC_TS_8,
02013     PlmnSpecificTs9                     = MN_PLMN_SPECIFIC_TS_9,
02014     PlmnSpecificTsA                     = MN_PLMN_SPECIFIC_TS_A,
02015     PlmnSpecificTsB                     = MN_PLMN_SPECIFIC_TS_B,
02016     PlmnSpecificTsC                     = MN_PLMN_SPECIFIC_TS_C,
02017     PlmnSpecificTsD                     = MN_PLMN_SPECIFIC_TS_D,
02018     PlmnSpecificTsE                     = MN_PLMN_SPECIFIC_TS_E,
02019     PlmnSpecificTsF                     = MN_PLMN_SPECIFIC_TS_F,
02020     AllBearerServices                   = MN_ALL_BEARER_SERVICES,
02021     AllDataCdaServices                  = MN_ALL_DATA_CDA_SERVICES,
02022     DataCda300Bps                       = MN_DATA_CDA_300_BPS,
02023     DataCda1200Bps                      = MN_DATA_CDA_1200_BPS,
02024     DataCda1200_75Bps                   = MN_DATA_CDA_1200_75_BPS,
02025     DataCda2400_Bps                     = MN_DATA_CDA_2400_BPS,
02026     DataCda4800_Bps                     = MN_DATA_CDA_4800_BPS,
02027     DataCda9600_Bps                     = MN_DATA_CDA_9600_BPS,
02028     AllDataCdsServices                  = MN_ALL_DATA_CDS_SERVICES,
02029     DataCds1200Bps                      = MN_DATA_CDS_1200_BPS,
02030     DataCds2400Bps                      = MN_DATA_CDS_2400_BPS,
02031     DataCds4800Bps                      = MN_DATA_CDS_4800_BPS,
02032     DataCds9600Bps                      = MN_DATA_CDS_9600_BPS,
02033     AllPadAccessCaServices              = MN_ALL_PAD_ACCESS_CA_SERVICES,
02034     PadAccessCa300Bps                   = MN_PAD_ACCESS_CA_300_BPS,
02035     PadAccessCa1200Bps                  = MN_PAD_ACCESS_CA_1200_BPS,
02036     PadAccessCa1200_75Bps               = MN_PAD_ACCESS_CA_1200_75_BPS,
02037     PadAccessCa2400Bps                  = MN_PAD_ACCESS_CA_2400_BPS,
02038     PadAccessCa4800Bps                  = MN_PAD_ACCESS_CA_4800_BPS,
02039     PadAccessCa9600Bps                  = MN_PAD_ACCESS_CA_9600_BPS,
02040     AllDataPdsServices                  = MN_ALL_DATA_PDS_SERVICES,
02041     DataPds2400Bps                      = MN_DATA_PDS_2400_BPS,
02042     DataPds4800Bps                      = MN_DATA_PDS_4800_BPS,
02043     DataPds9600Bps                      = MN_DATA_PDS_9600_BPS,
02044     AllAlternateSpeechDataCda           = MN_ALL_ALTERNATE_SPEECH_DATA_CDA,
02045     AllAlternateSpeechDataCds           = MN_ALL_ALTERNATE_SPEECH_DATA_CDS,
02046     AllSpeechFollByDataCda              = MN_ALL_SPEECH_FOLL_BY_DATA_CDA,
02047     AllSpeechFollByDataCds              = MN_ALL_SPEECH_FOLL_BY_DATA_CDS,
02048     AllDataCircuitAsynchronous          = MN_ALL_DATA_CIRCUIT_ASYNCHRONOUS,
02049     AllAsynchronousServices             = MN_ALL_ASYNCHRONOUS_SERVICES,
02050     AllDataCircuitSynchronous           = MN_ALL_DATA_CIRCUIT_SYNCHRONOUS,
02051     AllSynchronousServices              = MN_ALL_SYNCHRONOUS_SERVICES,
02052     AllPlmnSpecificBs                   = MN_ALL_PLMN_SPECIFIC_BS,
02053     PlmnSpecificBs1                     = MN_PLMN_SPECIFIC_BS_1,
02054     PlmnSpecificBs2                     = MN_PLMN_SPECIFIC_BS_2,
02055     PlmnSpecificBs3                     = MN_PLMN_SPECIFIC_BS_3,
02056     PlmnSpecificBs4                     = MN_PLMN_SPECIFIC_BS_4,
02057     PlmnSpecificBs5                     = MN_PLMN_SPECIFIC_BS_5,
02058     PlmnSpecificBs6                     = MN_PLMN_SPECIFIC_BS_6,
02059     PlmnSpecificBs7                     = MN_PLMN_SPECIFIC_BS_7,
02060     PlmnSpecificBs8                     = MN_PLMN_SPECIFIC_BS_8,
02061     PlmnSpecificBs9                     = MN_PLMN_SPECIFIC_BS_9,
02062     PlmnSpecificBsA                     = MN_PLMN_SPECIFIC_BS_A,
02063     PlmnSpecificBsB                     = MN_PLMN_SPECIFIC_BS_B,
02064     PlmnSpecificBsC                     = MN_PLMN_SPECIFIC_BS_C,
02065     PlmnSpecificBsD                     = MN_PLMN_SPECIFIC_BS_D,
02066     PlmnSpecificBsE                     = MN_PLMN_SPECIFIC_BS_E,
02067     PlmnSpecificBsF                     = MN_PLMN_SPECIFIC_BS_F,
02068 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
02069     AllVoiceGroupCallServices           = MN_ALL_VOICE_GROUP_CALL_SERVICES,
02070     VoiceGroupCallService               = MN_VOICE_GROUP_CALL,
02071     VoiceBroadcastService               = MN_VOICE_BROADCAST_CALL,
02072 #else
02073     AllVoiceGroupCallServices,
02074     VoiceGroupCallService,
02075     VoiceBroadcastService,
02076 #endif
02077     AuxiliarySpeech                     = MN_ALL_AUXILIARY_SPEECH_SERVICES,
02078     // Addtions for ASC
02079     AllServices,
02080     AllGPRSBearerServices,
02081
02082 };
02083
02084 enum SsInd {
02085     UnkownServiceInd    = MN_VOID_SERV_IND,
02086     TeleService         = MN_TELESERVICE,
02087     BearerService       = MN_BEARERSERVICE,
02088     TeleAndBearerServices
02089 };
02090
02091 struct SsGroup {
02092     BOOLEAN present;
02093     SsInd ind;
02094     ServiceGroup value;
02095 };
02096
02097 /*  ------------------------------------------------------------------------
02098     Forwarding Types
02099     ------------------------------------------------------------------------ */
02100 struct ForwardingFeature {
02101     SsGroup basic_service;
02102     SsStatus ss_status;
02103     PhoneNumber forward_to_number;  // UINT8 forward_to_number[c_max_size_telephone_nr];
02104     UINT8 options;
02105     INT noreply_timer;
02106 };
02107
02108 struct ForwardingFeatureList {
02109     ForwardingFeature data[c_max_no_basic_service_groups];
02110 };
02111
02112 struct ForwardingInfo {
02113     SsCode sc;
02114     INT feature_list_size;
02115     ForwardingFeatureList feature_list;
02116 };
02117
02118 /*  ------------------------------------------------------------------------
02119     Call barring Types
02120     ------------------------------------------------------------------------ */
02121 struct CallBarringFeature {
02122     SsGroup basic_service;
02123     SsStatus ss_status;
02124 };
02125
02126 struct CallBarringFeatureList{
02127     CallBarringFeature data[c_max_no_basic_service_groups];
02128 };
02129
02130 struct CallBarringInfo {
02131     SsCode sc;
02132     INT feature_list_size;
02133     CallBarringFeatureList feature_list;
02134 };
02135
02136 enum InterrogateSsChoice {
02137     SsStatusInterrogate                 = MN_SS_STATUS_INTERROGATE,
02138     SsForwardToNoInterrogate            = MN_SS_FORW_TO_NO_INTERROGATE,
02139     SsBasicServiceGroupListInterrogate  = MN_SS_BASIC_SERV_GROUP_LIST_INTERROGATE,
02140     SsForwwardFeatureListInterrogate    = MN_SS_FORW_FEATURE_LIST_INTERROGATE,
02141     SsCliRestrictInfoInterrogate        = MN_SS_CLI_RESTRICT_INFO_INTERROGATE,
02142     SsVoidInterrogate                   = MN_SS_VOID_INTERROGATE
02143 };
02144
02145 struct SsGroupList {
02146     SsGroup data[c_max_no_basic_service_groups];
02147 };
02148
02149 struct EmlppPriority {
02150     BOOLEAN                 in_use;
02151     EmlppPriorityLevel      value;
02152 };
02153
02154 enum CliRestrictionOption {
02155     Permanent                   = MN_PERMANENT,
02156     TemporaryDefaultRestricted  = MN_TEMPORARY_DEFAULT_RESTRICTED,
02157     TemporaryDefaultAllowed     = MN_TEMPORARY_DEFAULT_ALLOWED,
02158     VoidCliRestriction          = MN_VOID_CLI_RESTRICTION
02159 };
02160
02161 struct CliRestrictionInfo {
02162     SsStatus ss_status;
02163     CliRestrictionOption option;
02164     EmlppPriority   max_entitled_priority;
02165     EmlppPriority   default_priority;
02166 };
02167
02168 struct InterrogateSsResult {
02169     InterrogateSsChoice     selector;
02170     SsStatus                ss_status;
02171     PhoneNumber             forward_to_number; // UINT8 forward_to_number[c_max_size_telephone_nr];
02172     INT                     basic_serv_group_list_size;
02173     SsGroup                 basic_serv_group_list[c_max_no_basic_service_groups];
02174     INT                     forward_feature_list_size;
02175     ForwardingFeature       forward_feature_list[c_max_no_basic_service_groups];
02176     CliRestrictionInfo      cli_restriction_info;
02177 };
02178
02179 enum OverrideCategory {
02180     OverrideEnabled     = MN_OVERRIDE_ENABLED,
02181     OverrideDisabled    = MN_OVERRIDE_DISABLED,
02182     VoidOverride        = MN_VOID_OVERRIDE
02183 };
02184
02185 struct SsData {
02186     SsCode ss_code;
02187     SsStatus ss_status;
02188     CliRestrictionOption cli_restriction_option;
02189     OverrideCategory override_category;
02190     SsGroupList basic_serv_group_list;
02191     EmlppPriority default_priority;
02192 };
02193
02194
02195 /*  ========================================================================
02196                                  Audio
02197     ======================================================================== */
02198 /*  ------------------------------------------------------------------------
02199     AudioToneType
02200         external audio tone type (GSM 11.14) - defined in ms.h
02201     ------------------------------------------------------------------------ */
02202 enum AudioToneType {
02203     DefaultTone          = DEFAULT_TONE,
02204     DialTone             = DIAL_TONE,
02205     CalledSubscriberBusy = CALLED_SUBSCRIBER_BUSY,
02206     CongestionTone       = CONGESTION_TONE,
02207     RadioPathAck         = RADIO_PATH_ACK,
02208     RadioPathNotAvail    = RADIO_PATH_NOT_AVAIL,
02209     ErrorTone            = ERROR_TONE,
02210     CallWaitingTone      = CALL_WAITING_TONE,
02211     RingingTone          = RINGING_TONE,
02212     GeneralBeep          = GENERAL_BEEP,
02213     PositiveAckTone      = POSITIVE_ACK_TONE,
02214     NegativeAckTone      = NEGATIVE_ACK_TONE,
02215 };
02216
02217 /*  ------------------------------------------------------------------------
02218     AudioToneId
02219         Strange stuff!
02220         Enums, typedefs etc. for L1 tone control messages. Must be removed
02221         upon availability of audio drivers / audio control handler or
02222         similar. Enum relies on same position as in aud_drv.h
02223     ------------------------------------------------------------------------ */
02224 /*
02225 enum AudioToneId {
02226     AudioToneDtmf0,                 // aud_tone_DTMF_0,
02227     AudioToneDtmf1,                 // aud_tone_DTMF_1,
02228     AudioToneDtmf2,                 // aud_tone_DTMF_2,
02229     AudioToneDtmf3,                 // aud_tone_DTMF_3,
02230     AudioToneDtmf4,                 // aud_tone_DTMF_4,
02231     AudioToneDtmf5,                 // aud_tone_DTMF_5,
02232     AudioToneDtmf6,                 // aud_tone_DTMF_6,
02233     AudioToneDtmf7,                 // aud_tone_DTMF_7,
02234     AudioToneDtmf8,                 // aud_tone_DTMF_8,
02235     AudioToneDtmf9,                 // aud_tone_DTMF_9,
02236     AudioToneDtmfHash,              // aud_tone_DTMF_hash,
02237     AudioToneDtmfAsterix,           // aud_tone_DTMF_asterix,
02238
02239     AudioToneSvSubscriberBusy,      // aud_tone_sv_subscriber_busy,
02240     AudioToneSvCongestion,          // aud_tone_sv_congestion,
02241     AudioToneSvRadioPathAck,        // aud_tone_sv_radio_path_ack,
02242     AudioToneSvRadioPathNotAvail,   // aud_tone_sv_radio_path_not_avail,
02243     AudioToneSvErrorInfo,           // aud_tone_sv_error_info,
02244     AudioToneSvCallWaiting,         // aud_tone_sv_call_waiting,
02245
02246     AudioToneInfoFreeTone,          // aud_tone_info_free_tone,
02247     AudioToneInfoLowBat,            // aud_tone_info_low_bat,
02248
02249     AudioToneKey1,                  // aud_tone_key_1,
02250     AudioToneKey2,                  // aud_tone_key_2,
02251     AudioToneKey3,                  // aud_tone_key_3,
02252     AudioToneKey4,                  // aud_tone_key_4,
02253
02254     AudioToneBroadcast1,            // aud_tone_broadcast_1,
02255     AudioToneBroadcast2,            // aud_tone_broadcast_2,
02256     AudioToneBroadcast3,            // aud_tone_broadcast_3,
02257     AudioToneBroadcast4,            // aud_tone_broadcast_4,
02258
02259     AudioToneMessage1,              // aud_tone_message_1,
02260     AudioToneMessage2,              // aud_tone_message_2,
02261     AudioToneMessage3,              // aud_tone_message_3,
02262     AudioToneMessage4,              // aud_tone_message_4,
02263
02264     AudioToneRinging1,              // aud_tone_ringing_1,
02265     AudioToneRinging2,              // aud_tone_ringing_2,
02266     AudioToneRinging3,              // aud_tone_ringing_3,
02267     AudioToneRinging4,              // aud_tone_ringing_4,
02268     AudioToneRinging5,              // aud_tone_ringing_5,
02269     AudioToneRinging6,              // aud_tone_ringing_6,
02270     AudioToneRinging7,              // aud_tone_ringing_7,
02271     AudioToneRinging8,              // aud_tone_ringing_8,
02272     AudioToneRinging9,              // aud_tone_ringing_9,
02273     AudioToneRinging10,             // aud_tone_ringing_10,
02274     AudioToneRinging11,             // aud_tone_ringing_11,
02275     AudioToneRinging12,             // aud_tone_ringing_12,
02276
02277     AudioToneAlarm1,                // aud_tone_alarm_1
02278
02279     AudioLastTone,                  // aud_last_tone
02280
02281     AudioInvalidTone                // indicates that tone is not valid (needed for conversion)
02282 };
02283 */
02284
02285 /*  ========================================================================
02286                                  CCBS
02287     ======================================================================== */
02288
02289 struct CcbsEntry {
02290     UINT8 ccbs_idx;
02291     PhoneNumber idle_subscriber_no;
02292     Subaddress  subaddress;
02293     ServiceGroup serv_group;
02294 };
02295
02296 typedef INT CcbsAction;
02297
02298 typedef INT CcbsStatus;
02299
02300 struct CcbsList{
02301     CcbsEntry ccbs_entry[5];
02302 };
02303
02304
02305 struct InterrogateCcbsResult{
02306     UINT8 ss_status;
02307     INT ccbs_que_length;
02308     CcbsList ccbs_list;
02309 };
02310
02311
02312 typedef BOOLEAN ReleaseComplete;
02313
02314
02315
02316
02317 /*  ------------------------------------------------------------------------
02318     AudioDevice
02319     ------------------------------------------------------------------------ */
02320 enum AudioDevice {
02321     DeviceSpeaker,                  // aud_ring_off -> turn off ring to activate speaker!!!
02322     DeviceBuzzer,                   // aud_ring_buzzer,
02323     DeviceVibrator,                 // aud_ring_vibrator,
02324     DeviceRingBuzzerVibrator,       // aud_ring_buzzer_vibrator
02325     };
02326
02327 struct AudioToneDuration {
02328     UINT8 units;
02329     UINT8 interval;
02330 };
02331
02332 /*  ========================================================================
02333                                  Constants
02334     ======================================================================== */
02335 const INT AdjustToneRpt     = 1;
02336 const INT ClearToneRpt      = 3;
02337 const INT KeyToneRpt        = 1;
02338 const INT RingToneRpt       = 1;
02339 const INT MsgAlertRpt       = 1;
02340 const INT ErrorToneRpt      = 3;
02341 const INT LowBattToneRpt    = 2;
02342 const INT AlarmToneRpt      = 1;
02343
02344
02345 /*****
02346 * T_CHANNEL_MODE_RAW
02347 * raw channel mode as received from network (GSM 04.08, 10.5.2.6)
02348 * /vobs/ms-hosttest/mi/src/../../../stack-interface/globals/radio_res.pr,419,9
02349 ******/
02350 /*
02351 enum ChannelModeRaw{
02352     SignalingOnly   = MODE_SIGNALLING_ONLY,
02353     SpeechFull      = MODE_SPEECH_FULL,
02354     SpeechHalf      = MODE_SPEECH_HALF,
02355     Data144         = MODE_DATA_144,
02356     Data96          = MODE_DATA_96,
02357     Data48Full      = MODE_DATA_48_FULL,
02358     Data48Half      = MODE_DATA_48_HALF,
02359     Data24Full      = MODE_DATA_24_FULL,
02360     Data24Half      = MODE_DATA_24_HALF,
02361     SpeechFullV2    = MODE_SPEECH_FULL_V2,
02362     SpeechFullV3    = MODE_SPEECH_FULL_V3,
02363     SpeechHalfV2    = MODE_SPEECH_HALF_V2,
02364     SpeechHalfV3    = MODE_SPEECH_HALF_V3
02365 };
02366 */
02367
02368 enum SignalStrengthMax{
02369     GsmSignalStrengthMax  = 63,
02370     UmtsSignalStrengthMax = 91
02371 };
02372
02373 enum SignalQualityMax{
02374     GsmSignalQualityMax  = 7,
02375     UmtsSignalQualityMax = 49
02376 };
02377
02379 //ms-interface-src/pr/ms_msg_mm_mn.pr,302,9)
02380 enum GsmErrorCause {
02381     ImsiUnknownInHlr = ERR_IMSI_UNKNOWN_IN_HLR,
02382     IllegalMs = ERR_ILLEGAL_MS,
02383     ImsiUnknownInVlr = ERR_IMSI_UNKNOWN_IN_VLR,
02384     ImeiNotAccepted = ERR_IMEI_NOT_ACCEPTED,
02385     IllegalMe = ERR_ILLEGAL_ME,
02386     GprsNotAllowed = ERR_GPRS_NOT_ALLOWED,
02387     GprsGsmNotAllowed = ERR_GPRS_GSM_NOT_ALLOWED,
02388     MsIdentUnknown = ERR_MS_IDENT_UNKNOWN,
02389     ImpDetached = ERR_IMP_DETACHED,
02390     PlmnNotAllowed = ERR_PLMN_NOT_ALLOWED,
02391     LaNotAllowed = ERR_LA_NOT_ALLOWED,
02392     NatRoamingNotAllowed = ERR_NAT_ROAMING_NOT_ALLOWED,
02393     GprsPlmnNotAllowed = ERR_GPRS_PLMN_NOT_ALLOWED,
02394     NoSuitableCellsInLa = ERR_NO_SUITABLE_CELLS_IN_LA,
02395     MscNotReachable = ERR_MSC_NOT_REACHABLE,
02396     NetworkFailure = ERR_NETWORK_FAILURE,
02397     Congestion = ERR_CONGESTION,
02398     ServiceNotSupported = ERR_SERVICE_NOT_SUPPORTED,
02399     ReqServNotDescr = ERR_REQ_SERV_NOT_DESCR,
02400     ServiceTempOutOfOrder = ERR_SERVICE_TEMP_OUT_OF_ORDER,
02401     CallNotIdentified = ERR_CALL_NOT_IDENTIFIED,
02402     NoPdpContextActive = ERR_NO_PDP_CONTEXT_AKTIV,
02403     RetryOnNewCellBeg = ERR_RETRY_ON_NEW_CELL_BEG,
02404     RetryOnNewCellEnd = ERR_RETRY_ON_NEW_CELL_END,
02405     SemIncorrMsg = ERR_SEM_INCORR_MSG,
02406     InvManIe = ERR_INV_MAN_IE,
02407     MsgtypNotExists = ERR_MSGTYP_NOT_EXIST,
02408     MsgtypNotCompatible = ERR_MSGTYP_NOT_COMPATIBLE,
02409     InfElemNotExists = ERR_INF_ELEM_NOT_EXIST,
02410     ConIeErr = ERR_COND_IE_ERR,
02411     MsgNotCompatible = ERR_MSG_NOT_COMPATIBLE,
02412     ProtErrUnspecified = ERR_PROT_ERR_UNSPECIFIED,
02413 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
02414     MacFailure = ERR_MAC_FAILURE,
02415     SynchFailure = ERR_SYNCH_FAILURE,
02416     GsmAuthUnacceptable = ERR_GSM_AUTH_UNACCEPTABLE,
02417 #else
02418     MacFailure,
02419     SynchFailure,
02420     GsmAuthUnacceptable,
02421 #endif
02422     GsmNoCause
02423 };
02424
02425 enum CallRefuseDirection {
02426 #if defined(APOXI_ENABLE_MOC_CALL_RESTRICTION)
02427     IncommingRefuseDirection = MN_REFUSE_DIR_INCOMING,
02428     OutgoingRefuseDirection = MN_REFUSE_DIR_OUTGOING
02429 #else
02430     IncommingRefuseDirection,
02431     OutgoingRefuseDirection
02432 #endif
02433 };
02434 #endif  // Apc_SignalTypes_hpp
02435
Generated on Tue Jan 24 14:46:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimDataTypes.cpp File Reference

Apc/SimDataTypes.cpp File Reference

#include "Apc/PreComp.hpp"
#include <Auxiliary/DataCoding.hpp>
#include "SimDataTypes.hpp"
#include "SignalTypes.hpp"

Include dependency graph for SimDataTypes.cpp:

Generated on Tue Jan 24 17:06:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimDataTypes.hpp File Reference

Apc/SimDataTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/ElementList.hpp>
#include <Auxiliary/BitField.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <Apc/Tlv.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/UserData.hpp>

Include dependency graph for SimDataTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimAlphaIdentifier
represents a tlv alpha identifier - GSM 11.14 [12.2] More...
class | SimAtom< T >
class | SimIconIdentifier
class | SimIconQualifier
represents the icon specific options More...
class | SimItemId
represents a plain sim item id More...
class | SimItemIdentifier
class | SimNextActionIdentifier
representing tlv items next action indicator - GSM 11.14 [12.24] More...
class | SimTextString
representing tlv text string - GSM 11.14 [12.15] More...

Defines

#define | Apc_SimDataTypes_hpp

Typedefs

typedef SimAtom< UINT8 > | SimDummy
typedef SimAtom< TlvAtom > | SimIconId
represents a plain sim icon id
typedef ElementList< SimItemIdentifier > | SimItemIdentifierList
typedef SimAtom< UINT8 > | SimReferenceNumber
referenz number (ms.h: T_REFERENZ_NUMBER)
typedef UINT8 | SmsReferenceNumber
sms referenz number

Define Documentation

#define Apc_SimDataTypes_hpp

Typedef Documentation

typedef SimAtom<UINT8> SimDummy

typedef SimAtom<TlvAtom> SimIconId

represents a plain sim icon id

typedef ElementList<SimItemIdentifier> SimItemIdentifierList

typedef SimAtom<UINT8> SimReferenceNumber

referenz number (ms.h: T_REFERENZ_NUMBER)

typedef UINT8 SmsReferenceNumber

sms referenz number

Generated on Tue Jan 24 17:07:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimDataTypes.hpp Source File

Apc/SimDataTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SimDataTypes_hpp)
00009 #define Apc_SimDataTypes_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/ElementList.hpp>
00016 #include <Auxiliary/BitField.hpp>
00017
00018 #include <Apc/DataCodingScheme.hpp>
00019 #include <Apc/Tlv.hpp>
00020
00021 #include <Apc/SignalTypes.hpp>
00022 #include <Apc/UserData.hpp>
00023
00024
00025 /*  ========================================================================
00026     SimAtom
00027     ========================================================================*/
00029 template <class T> class SimAtom {
00030     public:
00032         SimAtom(const T &elem = 0) : m_elem(elem) {}
00034         BOOLEAN operator ==(const SimAtom<T> &sim_elem) const {
00035             return (m_elem == sim_elem.m_elem);
00036         }
00038         BOOLEAN operator ==(const T &elem) const {
00039             return (m_elem == elem);
00040         }
00042         BOOLEAN operator <(const SimAtom<T> &sim_elem) const {
00043             return (m_elem < sim_elem.m_elem);
00044         }
00046         BOOLEAN operator <(const T &elem) const {
00047             return (m_elem < elem);
00048         }
00049
00051         const T& Get() const { return (m_elem); }
00053         void Clear(UINT8 set = 0x00) { memset(&m_elem, set, sizeof(T)); }
00055         BOOLEAN IsInvalid() const { return (m_elem == 0); }
00056
00057     private:
00058         T m_elem;
00059 };
00060
00061 /*  ========================================================================
00062     SimDummy
00063     ========================================================================*/
00065 typedef SimAtom<UINT8> SimDummy;
00066
00067 /*  ========================================================================
00068     SimReferenceNumber
00069     ========================================================================*/
00071 typedef SimAtom<UINT8> SimReferenceNumber;
00072
00073 /*  ========================================================================
00074     SmsReferenceNumber
00075     ========================================================================*/
00077 typedef UINT8 SmsReferenceNumber;
00078
00079 /*  ========================================================================
00080     SimIconId
00081     ========================================================================*/
00083 typedef SimAtom<TlvAtom> SimIconId;
00084
00085 /*  ========================================================================
00086     SimItemId
00087     ========================================================================*/
00089 class SimItemId : public SimAtom<TlvAtom> {
00090     public:
00091         typedef SimAtom<TlvAtom> Base;
00092         enum { InvalidId };
00094         SimItemId();
00096         SimItemId(const TlvAtom &id);
00098         ~SimItemId();
00099
00101         BOOLEAN operator < (const SimItemId &id) const { return Get() < id.Get();}
00103         BOOLEAN IsInvalid() const { return (Get() == (TlvAtom) InvalidId); }
00104 };
00105
00106 /*  ========================================================================
00107     SimIconQualifier
00108     ========================================================================*/
00110 class SimIconQualifier {
00111     public:
00113         SimIconQualifier();
00115         SimIconQualifier(TlvAtom bit_field);
00117         ~SimIconQualifier();
00118
00120         BOOLEAN IsSelfExplanatory() const { return (!m_bit_field.GetBit(0)); }
00121
00123         UINT8 Get() const { return (m_bit_field.Get()); }
00125         void Clear() { m_bit_field.Clear(); }
00126
00127     private:
00128         BitField<TlvAtom> m_bit_field;
00129 };
00130
00131
00132 /*  ========================================================================
00133     SimAlphaIdentifier
00134     ======================================================================== */
00136 class SimAlphaIdentifier {
00137     public:
00139         SimAlphaIdentifier();
00141         SimAlphaIdentifier(const TlvAtom *data_ptr, const INT len);
00143         SimAlphaIdentifier(const Tlv &tlv);
00145         SimAlphaIdentifier(const T_ALPHA_IDENTIFIER &sdl_alpha_id);
00147         SimAlphaIdentifier(const WString &text);
00149         ~SimAlphaIdentifier();
00150
00152         const WString& GetText() const { return (m_text); }
00153
00155         BOOLEAN IsValid() const { return (m_identifier_valid); }
00156
00158         void SetValid(BOOLEAN identifier_valid) { m_identifier_valid = identifier_valid; }
00159
00162         INT Convert2Buffer(UINT8 *buffer, INT &len) const;
00165         INT Convert2SdlAlpha(T_ALPHA_IDENTIFIER &sdl_alpha) const;
00167         void Clear() { m_text.Clear(); }
00168
00169     private:
00170         WString m_text;
00171         BOOLEAN m_identifier_valid;
00172 };
00173
00174 /*  ========================================================================
00175     SimItemIdentifier
00176     ======================================================================== */
00179 class SimItemIdentifier : public Linkable<SimItemIdentifier> {
00180     public:
00182         SimItemIdentifier();
00184         SimItemIdentifier(const TlvAtom *data_ptr, const INT len);
00186         SimItemIdentifier(const Tlv &tlv);
00188         virtual ~SimItemIdentifier();
00189
00190         BOOLEAN operator == (const SimItemIdentifier &id) const { return (m_id == id.m_id); }
00191         BOOLEAN operator <  (const SimItemIdentifier &id) const { return (m_id <  id.m_id); }
00192
00194         const SimItemId& GetId() const { return (m_id); }
00195
00197         const WString& GetText() const { return (m_text); }
00198
00200         BOOLEAN IsInvalid() const {  return (m_id.IsInvalid()); }
00201
00203         void Clear();
00204
00205     private:
00206         SimItemId m_id;
00207         WString m_text;
00208 };
00209
00210 /*  ========================================================================
00211     SimItemIdentifierList
00212     ======================================================================== */
00213 typedef ElementList<SimItemIdentifier>  SimItemIdentifierList;
00214
00215 /*  ========================================================================
00216     SimTextString
00217     ======================================================================== */
00219 class SimTextString {
00220     public:
00221         enum DataSource {
00222             TlvSource,          // used for sim toolkit, ... text transformations
00223             SmsDataSource,      // used for sms, ... text transformations
00224             CbsDataSource,      // used for cellbroadcast, ... text transformations
00225             UssdDataSource      // used for ussd, ... text transformations
00226         };
00227
00229         SimTextString();
00231         SimTextString(const UINT8 *buffer, const INT len, const DataCodingScheme &dcs = DataCodingScheme());
00233         SimTextString(const UINT8 *buffer, const INT len, const DataCodingScheme &dcs, DataSource datasource);
00235         SimTextString(const UserData &user_data, const DataCodingScheme &dcs);
00237         SimTextString(const Tlv &tlv);
00239         SimTextString(const T_SI_TEXT &sdl_si_text);
00241         SimTextString(const T_SI_TEXT_PTR &sdl_si_text_ptr);
00243         SimTextString(const WString &text, const DataCodingScheme &dcs);
00245         ~SimTextString();
00246
00248         const DataCodingScheme& GetDataCodingScheme() const { return (m_dcs); }
00249
00251         const WString& GetText() const { return (m_text); }
00252
00255         INT Convert2SdlText(T_SI_TEXT &sdl_si_text) const;
00258         INT Convert2UserData(UserData &user_data) const;
00259
00261         void Clear() { m_text.Clear(); }
00262
00263     private:
00264         DataCodingScheme m_dcs;
00265         WString m_text;
00266
00267         void ConvertBuffer2WString(const UINT8 *data_ptr, const INT data_len, const DataSource data_source, UINT8 padding = 0);
00268 };
00269
00270 /*  ========================================================================
00271     SimNextActionIdentifier
00272     ======================================================================== */
00274 class SimNextActionIdentifier {
00275     public:
00277         SimNextActionIdentifier();
00279         SimNextActionIdentifier(const TlvAtom *data_ptr, const INT len);
00281         SimNextActionIdentifier(const Tlv &tlv);
00283         SimNextActionIdentifier(const SimNextActionIdentifier &sim_items_nai);
00285         ~SimNextActionIdentifier();
00287         SimNextActionIdentifier& operator =(const SimNextActionIdentifier &sim_items_nai);
00288
00290         INT GetNoOfNai() const { return (m_no_of_nai); }
00291
00293         const Nai& GetNai(INT i) const {
00294             ASSERT(i >= 0 && i < m_no_of_nai && m_nai != 0);
00295             return (m_nai[i]);
00296         }
00297
00299         void Clear();
00300
00301     private:
00302         Nai *m_nai;
00303         INT m_no_of_nai;
00304 };
00305
00306 /*  ========================================================================
00307     SimIconIdentifier
00308     ======================================================================== */
00311 class  SimIconIdentifier {
00312     public:
00314         SimIconIdentifier();
00316         SimIconIdentifier(const TlvAtom *data_ptr, const INT len);
00318         SimIconIdentifier(const Tlv &tlv);
00320         SimIconIdentifier(const T_SI_ICON_ID &sdl_si_icon_id);
00322         SimIconIdentifier(const SimIconIdentifier &sim_icon);
00324         ~SimIconIdentifier();
00326         SimIconIdentifier& operator =(const SimIconIdentifier &sim_icon);
00327
00329         const SimIconQualifier& GetQualifier() const { return (m_qualifier); }
00331         const SimIconId& GetId(INT i = 0) const {
00332             ASSERT(i >= 0 && i < m_no_of_icons && m_id != 0);
00333             return (m_id[i]);
00334         }
00335
00337         INT GetNoOfIcons() const { return (m_no_of_icons); }
00338
00340         void Clear();
00341
00342     private:
00343         SimIconQualifier m_qualifier;
00344         SimIconId *m_id;
00345         INT m_no_of_icons;
00346
00347 };
00348
00349
00350 #endif  // Apc_SimDataTypes_hpp
00351
00352
Generated on Tue Jan 24 14:46:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimLockTypes.hpp File Reference

Apc/SimLockTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for SimLockTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | SimLockStates

Defines

#define | Apc_Gprs_SimLockTypes_hpp

Enumerations

enum | LockStatus { SimLocked = SI_LOCKED, SimUnlocked = SI_UNLOCKED }
lock status T_SI_LOCK_STATUS More...

Define Documentation

#define Apc_Gprs_SimLockTypes_hpp

Enumeration Type Documentation

enum LockStatus

lock status T_SI_LOCK_STATUS

Enumerator:
SimLocked
SimUnlocked

Generated on Tue Jan 24 17:07:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimLockTypes.hpp Source File

Apc/SimLockTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Gprs_SimLockTypes_hpp)
00009 #define Apc_Gprs_SimLockTypes_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 #include <Apc/SignalTypes.hpp>
00014
00016 enum LockStatus {
00018     SimLocked =  SI_LOCKED,
00020     SimUnlocked = SI_UNLOCKED,
00021     };
00022
00023 // T_SI_LOCK_STATES
00024 struct SimLockStates {
00025     LockStatus  network;
00026     LockStatus  sp;
00027     LockStatus  sim;
00028     LockStatus  corporate;
00029 };
00030
00031 #endif  // Apc_Gprs_SimLockTypes_hpp
00032
00033
Generated on Tue Jan 24 14:46:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimMiscStackMsgArgs.cpp File Reference

Apc/SimMiscStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "SimMiscStackMsgArgs.hpp"

Include dependency graph for SimMiscStackMsgArgs.cpp:

Generated on Tue Jan 24 17:07:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimMiscStackMsgArgs.hpp File Reference

Apc/SimMiscStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Apc/SimMiscTypes.hpp>
#include <Apc/LockTypes.hpp>

Include dependency graph for SimMiscStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BdnIndArg
class | BdnReqArg
class | CphsCfufReadIndArg
class | CphsCfufReadReqArg
class | CphsCfufUpdIndArg
class | CphsCfufUpdReqArg
class | CphsCspReadIndArg
class | CphsCspReadReqArg
class | CphsCspUpdIndArg
class | CphsCspUpdReqArg
class | CphsIstReadIndArg
class | CphsIstReadReqArg
class | CphsOnmReadIndArg
class | CphsOnmReadReqArg
class | CphsOnsReadIndArg
class | CphsOnsReadReqArg
class | CphsVmwfReadIndArg
class | CphsVmwfReadReqArg
class | CphsVmwfUpdIndArg
class | CphsVmwfUpdReqArg
class | FdnIndArg
class | FdnReqArg
class | SimAcmMaxReadIndArg
class | SimAcmMaxReadReqArg
class | SimAcmMaxUpdIndArg
class | SimAcmMaxUpdReqArg
class | SimAcmReadIndArg
class | SimAcmReadReqArg
class | SimAcmUpdIndArg
class | SimAcmUpdReqArg
class | SimCbmiReadIndArg
class | SimCbmiReadReqArg
class | SimCbmirReadIndArg
class | SimCbmirReadReqArg
class | SimCbmirUpdIndArg
class | SimCbmirUpdReqArg
class | SimCbmiUpdIndArg
class | SimCbmiUpdReqArg
class | SimCcpReadIndArg
class | SimCcpReadReqArg
class | SimCcpUpdIndArg
class | SimCcpUpdReqArg
class | SimCmiReadIndArg
class | SimCmiReadReqArg
class | SimErrorIndArg
class | SimExtLangReadIndArg
class | SimExtLangReadReqArg
class | SimExtLangUpdIndArg
class | SimExtLangUpdReqArg
class | SimFileInfoIndArg
class | SimFileInfoReqArg
class | SimFullAccessIndArg
class | SimGenericIndArg
class | SimGenericReqArg
class | SimInfoIndArg
class | SimInitIndArg
class | SimLangReadIndArg
class | SimLangReadReqArg
class | SimLangUpdIndArg
class | SimLangUpdReqArg
class | SimLockStatusIndArg
class | SimMccMncIndArg
class | SimModifyLockIndArg
class | SimModifyLockReqArg
class | SimMruPropertyRefreshIndArg
class | SimMruPropertyUpdCnfArg
class | SimMruPropertyUpdReqArg
class | SimODyn2ReadIndArg
class | SimODyn2ReadReqArg
class | SimODyn2UpdIndArg
class | SimODyn2UpdReqArg
class | SimODynReadIndArg
class | SimODynReadReqArg
class | SimODynUpdIndArg
class | SimODynUpdReqArg
class | SimPuctReadIndArg
class | SimPuctReadReqArg
class | SimPuctUpdIndArg
class | SimPuctUpdReqArg
class | SimRefreshIndArg
class | SimRefreshReqArg
class | SimSmsrReadIndArg
class | SimSmsrReadReqArg
class | SimSmsrUpdIndArg
class | SimSmsrUpdReqArg
class | SimSpnReadIndArg
class | SimSpnReadReqArg
class | SimSstReadIndArg
class | SimSstReadReqArg
class | UsimCardTypeReadIndArg
class | UsimCardTypeReadReqArg
class | UsimCsLociReadIndArg
class | UsimCsLociReadReqArg
class | UsimEccReadIndArg
class | UsimEccReadReqArg
class | UsimEstReadIndArg
class | UsimEstReadReqArg
class | UsimFilePropertyIndArg
class | UsimFilePropertyReqArg
class | UsimLangReadIndArg
class | UsimLangReadReqArg
class | UsimLangUpdIndArg
class | UsimLangUpdReqArg
class | UsimPlmnReadIndArg
class | UsimPlmnReadReqArg
class | UsimPlmnUpdIndArg
class | UsimPlmnUpdReqArg
class | UsimPsLociReadIndArg
class | UsimPsLociReadReqArg
class | UsimReadRecordRejArg
class | UsimReadRejArg
class | UsimSmsParamExtIndArg
class | UsimSmsParamReadIndArg
class | UsimSmsParamReadReqArg
class | UsimSmsParamUpdIndArg
class | UsimSmsParamUpdReqArg
class | UsimUpdCnfArg
class | UsimUpdRejArg
class | UsimUstReadIndArg
class | UsimUstReadReqArg

Defines

#define | Apc_SimMiscStackMsgArgs_hpp

Define Documentation

#define Apc_SimMiscStackMsgArgs_hpp

Generated on Tue Jan 24 17:07:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimMiscStackMsgArgs.hpp Source File

Apc/SimMiscStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\grossau_mp1ue_sv\lnz_apoxi\Apoxi\Apc\SimMiscArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_SimMiscStackMsgArgs_hpp)
00016 #define Apc_SimMiscStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Apc/NetworkTypes.hpp>
00021 #include <Apc/SimMiscTypes.hpp>
00022 #include <Apc/LockTypes.hpp>
00023
00024
00025 /* ----------------------------------------------------------------------
00026     Classes
00027     ---------------------------------------------------------------------- */
00028
00029 /*  ======================================================================
00030     Class SimErrorIndArg
00031     ====================================================================== */
00032
00034 class SimErrorIndArg : public StackMsgArgument {
00035     friend class CommonStackMsgArgsDestroyTableNode;
00036     public:
00037         SimErrorIndArg();
00038
00039         static const SimErrorIndArg& Cast(const StackMsgArgument& arg);
00040         void SetErrorCode(const SimErrorCode& error_code) { m_error_code = error_code; }
00041         const SimErrorCode& GetErrorCode() const { return m_error_code; }
00042
00043         enum  {
00044             ID = 1400
00045             };
00046
00047     private:
00048
00049         static void Destroy(StackMsgArgument* arg) { delete ((SimErrorIndArg*) arg); }
00050
00051         SimErrorCode m_error_code;
00052
00053     };
00054
00055 // Inline definitions
00056 inline const SimErrorIndArg& SimErrorIndArg::Cast(const StackMsgArgument& arg) {
00057     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimErrorIndArg!\n");
00058     return ((SimErrorIndArg &) arg);
00059 }
00060
00061
00062
00063 /*  ======================================================================
00064     Class SimRefreshIndArg
00065     ====================================================================== */
00066
00068 class SimRefreshIndArg : public StackMsgArgument {
00069     friend class CommonStackMsgArgsDestroyTableNode;
00070     public:
00071         SimRefreshIndArg();
00072
00073         static const SimRefreshIndArg& Cast(const StackMsgArgument& arg);
00074         void SetRefreshType(const SimRefreshType& refresh_type) { m_refresh_type = refresh_type; }
00075         const SimRefreshType& GetRefreshType() const { return m_refresh_type; }
00076         void SetSmsStatus(UINT8 sms_status) { m_sms_status = sms_status; }
00077         UINT8 GetSmsStatus() const { return m_sms_status; }
00078         void SetFileType(INT file_type) { m_file_type = file_type; }
00079         INT GetFileType() const { return m_file_type; }
00080         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
00081         INT GetRecNo() const { return m_rec_no; }
00082
00083         enum  {
00084             ID = 1401
00085             };
00086
00087     private:
00088
00089         static void Destroy(StackMsgArgument* arg) { delete ((SimRefreshIndArg*) arg); }
00090
00091         SimRefreshType m_refresh_type;
00092         UINT8 m_sms_status;
00093         INT m_file_type;
00094         INT m_rec_no;
00095
00096     };
00097
00098 // Inline definitions
00099 inline const SimRefreshIndArg& SimRefreshIndArg::Cast(const StackMsgArgument& arg) {
00100     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimRefreshIndArg!\n");
00101     return ((SimRefreshIndArg &) arg);
00102 }
00103
00104
00105
00106 /*  ======================================================================
00107     Class SimSstReadIndArg
00108     ====================================================================== */
00109
00111 class SimSstReadIndArg : public StackMsgArgument {
00112     friend class CommonStackMsgArgsDestroyTableNode;
00113     public:
00114         SimSstReadIndArg();
00115
00116         static const SimSstReadIndArg& Cast(const StackMsgArgument& arg);
00117         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00118         const SimUpdateStatus& GetStatus() const { return m_status; }
00119         void SetSst(const SimServiceTable& sst) { m_sst = sst; }
00120         const SimServiceTable& GetSst() const { return m_sst; }
00121
00122         enum  {
00123             ID = 1403
00124             };
00125
00126     private:
00127
00128         static void Destroy(StackMsgArgument* arg) { delete ((SimSstReadIndArg*) arg); }
00129
00130         SimUpdateStatus m_status;
00131         SimServiceTable m_sst;
00132
00133     };
00134
00135 // Inline definitions
00136 inline const SimSstReadIndArg& SimSstReadIndArg::Cast(const StackMsgArgument& arg) {
00137     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimSstReadIndArg!\n");
00138     return ((SimSstReadIndArg &) arg);
00139 }
00140
00141
00142
00143 /*  ======================================================================
00144     Class SimAcmReadIndArg
00145     ====================================================================== */
00146
00148 class SimAcmReadIndArg : public StackMsgArgument {
00149     friend class CommonStackMsgArgsDestroyTableNode;
00150     public:
00151         SimAcmReadIndArg();
00152
00153         static const SimAcmReadIndArg& Cast(const StackMsgArgument& arg);
00154         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00155         const SimUpdateStatus& GetStatus() const { return m_status; }
00156         void SetRecno(INT recno) { m_recno = recno; }
00157         INT GetRecno() const { return m_recno; }
00158         void SetAcm(const Acm& acm) { m_acm = acm; }
00159         const Acm& GetAcm() const { return m_acm; }
00160         void SetCount(INT count) { m_count = count; }
00161         INT GetCount() const { return m_count; }
00162         void SetSelector(const AcmSelector& selector) { m_selector = selector; }
00163         const AcmSelector& GetSelector() const { return m_selector; }
00164
00165         enum  {
00166             ID = 1404
00167             };
00168
00169     private:
00170
00171         static void Destroy(StackMsgArgument* arg) { delete ((SimAcmReadIndArg*) arg); }
00172
00173         SimUpdateStatus m_status;
00174         INT m_recno;
00175         Acm m_acm;
00176         INT m_count;
00177         AcmSelector m_selector;
00178
00179     };
00180
00181 // Inline definitions
00182 inline const SimAcmReadIndArg& SimAcmReadIndArg::Cast(const StackMsgArgument& arg) {
00183     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimAcmReadIndArg!\n");
00184     return ((SimAcmReadIndArg &) arg);
00185 }
00186
00187
00188
00189 /*  ======================================================================
00190     Class SimAcmUpdIndArg
00191     ====================================================================== */
00192
00194 class SimAcmUpdIndArg : public StackMsgArgument {
00195     friend class CommonStackMsgArgsDestroyTableNode;
00196     public:
00197         SimAcmUpdIndArg();
00198
00199         static const SimAcmUpdIndArg& Cast(const StackMsgArgument& arg);
00200         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00201         const SimUpdateStatus& GetStatus() const { return m_status; }
00202         void SetSelector(const AcmSelector& selector) { m_selector = selector; }
00203         const AcmSelector& GetSelector() const { return m_selector; }
00204
00205         enum  {
00206             ID = 1405
00207             };
00208
00209     private:
00210
00211         static void Destroy(StackMsgArgument* arg) { delete ((SimAcmUpdIndArg*) arg); }
00212
00213         SimUpdateStatus m_status;
00214         AcmSelector m_selector;
00215
00216     };
00217
00218 // Inline definitions
00219 inline const SimAcmUpdIndArg& SimAcmUpdIndArg::Cast(const StackMsgArgument& arg) {
00220     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimAcmUpdIndArg!\n");
00221     return ((SimAcmUpdIndArg &) arg);
00222 }
00223
00224
00225
00226 /*  ======================================================================
00227     Class SimAcmMaxReadIndArg
00228     ====================================================================== */
00229
00231 class SimAcmMaxReadIndArg : public StackMsgArgument {
00232     friend class CommonStackMsgArgsDestroyTableNode;
00233     public:
00234         SimAcmMaxReadIndArg();
00235
00236         static const SimAcmMaxReadIndArg& Cast(const StackMsgArgument& arg);
00237         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00238         const SimUpdateStatus& GetStatus() const { return m_status; }
00239         void SetAcm(const Acm& acm) { m_acm = acm; }
00240         const Acm& GetAcm() const { return m_acm; }
00241
00242         enum  {
00243             ID = 1406
00244             };
00245
00246     private:
00247
00248         static void Destroy(StackMsgArgument* arg) { delete ((SimAcmMaxReadIndArg*) arg); }
00249
00250         SimUpdateStatus m_status;
00251         Acm m_acm;
00252
00253     };
00254
00255 // Inline definitions
00256 inline const SimAcmMaxReadIndArg& SimAcmMaxReadIndArg::Cast(const StackMsgArgument& arg) {
00257     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimAcmMaxReadIndArg!\n");
00258     return ((SimAcmMaxReadIndArg &) arg);
00259 }
00260
00261
00262
00263 /*  ======================================================================
00264     Class SimAcmMaxUpdIndArg
00265     ====================================================================== */
00266
00268 class SimAcmMaxUpdIndArg : public StackMsgArgument {
00269     friend class CommonStackMsgArgsDestroyTableNode;
00270     public:
00271         SimAcmMaxUpdIndArg();
00272
00273         static const SimAcmMaxUpdIndArg& Cast(const StackMsgArgument& arg);
00274         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00275         const SimUpdateStatus& GetStatus() const { return m_status; }
00276
00277         enum  {
00278             ID = 1407
00279             };
00280
00281     private:
00282
00283         static void Destroy(StackMsgArgument* arg) { delete ((SimAcmMaxUpdIndArg*) arg); }
00284
00285         SimUpdateStatus m_status;
00286
00287     };
00288
00289 // Inline definitions
00290 inline const SimAcmMaxUpdIndArg& SimAcmMaxUpdIndArg::Cast(const StackMsgArgument& arg) {
00291     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimAcmMaxUpdIndArg!\n");
00292     return ((SimAcmMaxUpdIndArg &) arg);
00293 }
00294
00295
00296
00297 /*  ======================================================================
00298     Class SimPuctReadIndArg
00299     ====================================================================== */
00300
00302 class SimPuctReadIndArg : public StackMsgArgument {
00303     friend class CommonStackMsgArgsDestroyTableNode;
00304     public:
00305         SimPuctReadIndArg();
00306
00307         static const SimPuctReadIndArg& Cast(const StackMsgArgument& arg);
00308         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00309         const SimUpdateStatus& GetStatus() const { return m_status; }
00310         void SetPuct(const Puct& puct) { m_puct = puct; }
00311         const Puct& GetPuct() const { return m_puct; }
00312
00313         enum  {
00314             ID = 1408
00315             };
00316
00317     private:
00318
00319         static void Destroy(StackMsgArgument* arg) { delete ((SimPuctReadIndArg*) arg); }
00320
00321         SimUpdateStatus m_status;
00322         Puct m_puct;
00323
00324     };
00325
00326 // Inline definitions
00327 inline const SimPuctReadIndArg& SimPuctReadIndArg::Cast(const StackMsgArgument& arg) {
00328     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimPuctReadIndArg!\n");
00329     return ((SimPuctReadIndArg &) arg);
00330 }
00331
00332
00333
00334 /*  ======================================================================
00335     Class SimPuctUpdIndArg
00336     ====================================================================== */
00337
00339 class SimPuctUpdIndArg : public StackMsgArgument {
00340     friend class CommonStackMsgArgsDestroyTableNode;
00341     public:
00342         SimPuctUpdIndArg();
00343
00344         static const SimPuctUpdIndArg& Cast(const StackMsgArgument& arg);
00345         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00346         const SimUpdateStatus& GetStatus() const { return m_status; }
00347
00348         enum  {
00349             ID = 1409
00350             };
00351
00352     private:
00353
00354         static void Destroy(StackMsgArgument* arg) { delete ((SimPuctUpdIndArg*) arg); }
00355
00356         SimUpdateStatus m_status;
00357
00358     };
00359
00360 // Inline definitions
00361 inline const SimPuctUpdIndArg& SimPuctUpdIndArg::Cast(const StackMsgArgument& arg) {
00362     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimPuctUpdIndArg!\n");
00363     return ((SimPuctUpdIndArg &) arg);
00364 }
00365
00366
00367
00368 /*  ======================================================================
00369     Class SimGenericIndArg
00370     ====================================================================== */
00371
00373 class SimGenericIndArg : public StackMsgArgument {
00374     friend class CommonStackMsgArgsDestroyTableNode;
00375     public:
00376         SimGenericIndArg();
00377
00378         static const SimGenericIndArg& Cast(const StackMsgArgument& arg);
00379         void SetDfId(const SimFileId& df_id) { m_df_id = df_id; }
00380         const SimFileId& GetDfId() const { return m_df_id; }
00381         void SetDfLength(INT df_length) { m_df_length = df_length; }
00382         INT GetDfLength() const { return m_df_length; }
00383         void SetDfParams(const SimDfParameters& df_params) { m_df_params = df_params; }
00384         const SimDfParameters& GetDfParams() const { return m_df_params; }
00385         void SetEfId(const SimFileId& ef_id) { m_ef_id = ef_id; }
00386         const SimFileId& GetEfId() const { return m_ef_id; }
00387         void SetEfLength(INT ef_length) { m_ef_length = ef_length; }
00388         INT GetEfLength() const { return m_ef_length; }
00389         void SetEfParams(const SimEfParameters& ef_params) { m_ef_params = ef_params; }
00390         const SimEfParameters& GetEfParams() const { return m_ef_params; }
00391         void SetApduDataPtr(SimApduData * apdu_data_ptr) { m_apdu_data_ptr = apdu_data_ptr; }
00392         SimApduData * GetApduDataPtr() const { return m_apdu_data_ptr; }
00393
00394         enum  {
00395             ID = 1410
00396             };
00397
00398     private:
00399
00400         static void Destroy(StackMsgArgument* arg) { delete ((SimGenericIndArg*) arg); }
00401
00402         SimFileId m_df_id;
00403         INT m_df_length;
00404         SimDfParameters m_df_params;
00405         SimFileId m_ef_id;
00406         INT m_ef_length;
00407         SimEfParameters m_ef_params;
00408         SimApduData * m_apdu_data_ptr;
00409
00410     };
00411
00412 // Inline definitions
00413 inline const SimGenericIndArg& SimGenericIndArg::Cast(const StackMsgArgument& arg) {
00414     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimGenericIndArg!\n");
00415     return ((SimGenericIndArg &) arg);
00416 }
00417
00418
00419
00420 /*  ======================================================================
00421     Class SimLangReadIndArg
00422     ====================================================================== */
00423
00425 class SimLangReadIndArg : public StackMsgArgument {
00426     friend class CommonStackMsgArgsDestroyTableNode;
00427     public:
00428         SimLangReadIndArg();
00429
00430         static const SimLangReadIndArg& Cast(const StackMsgArgument& arg);
00431         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00432         const SimUpdateStatus& GetStatus() const { return m_status; }
00433         void SetLanguageArray(const LanguageArray& language_array) { m_language_array = language_array; }
00434         const LanguageArray& GetLanguageArray() const { return m_language_array; }
00435
00436         enum  {
00437             ID = 1411
00438             };
00439
00440     private:
00441
00442         static void Destroy(StackMsgArgument* arg) { delete ((SimLangReadIndArg*) arg); }
00443
00444         SimUpdateStatus m_status;
00445         LanguageArray m_language_array;
00446
00447     };
00448
00449 // Inline definitions
00450 inline const SimLangReadIndArg& SimLangReadIndArg::Cast(const StackMsgArgument& arg) {
00451     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimLangReadIndArg!\n");
00452     return ((SimLangReadIndArg &) arg);
00453 }
00454
00455
00456
00457 /*  ======================================================================
00458     Class SimLangUpdIndArg
00459     ====================================================================== */
00460
00462 class SimLangUpdIndArg : public StackMsgArgument {
00463     friend class CommonStackMsgArgsDestroyTableNode;
00464     public:
00465         SimLangUpdIndArg();
00466
00467         static const SimLangUpdIndArg& Cast(const StackMsgArgument& arg);
00468         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00469         const SimUpdateStatus& GetStatus() const { return m_status; }
00470
00471         enum  {
00472             ID = 1412
00473             };
00474
00475     private:
00476
00477         static void Destroy(StackMsgArgument* arg) { delete ((SimLangUpdIndArg*) arg); }
00478
00479         SimUpdateStatus m_status;
00480
00481     };
00482
00483 // Inline definitions
00484 inline const SimLangUpdIndArg& SimLangUpdIndArg::Cast(const StackMsgArgument& arg) {
00485     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimLangUpdIndArg!\n");
00486     return ((SimLangUpdIndArg &) arg);
00487 }
00488
00489
00490
00491 /*  ======================================================================
00492     Class SimExtLangReadIndArg
00493     ====================================================================== */
00494
00496 class SimExtLangReadIndArg : public StackMsgArgument {
00497     friend class CommonStackMsgArgsDestroyTableNode;
00498     public:
00499         SimExtLangReadIndArg();
00500
00501         static const SimExtLangReadIndArg& Cast(const StackMsgArgument& arg);
00502         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00503         const SimUpdateStatus& GetStatus() const { return m_status; }
00504         void SetLanguageArray(const ExtLanguageArray& language_array) { m_language_array = language_array; }
00505         const ExtLanguageArray& GetLanguageArray() const { return m_language_array; }
00506
00507         enum  {
00508             ID = 1413
00509             };
00510
00511     private:
00512
00513         static void Destroy(StackMsgArgument* arg) { delete ((SimExtLangReadIndArg*) arg); }
00514
00515         SimUpdateStatus m_status;
00516         ExtLanguageArray m_language_array;
00517
00518     };
00519
00520 // Inline definitions
00521 inline const SimExtLangReadIndArg& SimExtLangReadIndArg::Cast(const StackMsgArgument& arg) {
00522     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimExtLangReadIndArg!\n");
00523     return ((SimExtLangReadIndArg &) arg);
00524 }
00525
00526
00527
00528 /*  ======================================================================
00529     Class SimExtLangUpdIndArg
00530     ====================================================================== */
00531
00533 class SimExtLangUpdIndArg : public StackMsgArgument {
00534     friend class CommonStackMsgArgsDestroyTableNode;
00535     public:
00536         SimExtLangUpdIndArg();
00537
00538         static const SimExtLangUpdIndArg& Cast(const StackMsgArgument& arg);
00539         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00540         const SimUpdateStatus& GetStatus() const { return m_status; }
00541
00542         enum  {
00543             ID = 1414
00544             };
00545
00546     private:
00547
00548         static void Destroy(StackMsgArgument* arg) { delete ((SimExtLangUpdIndArg*) arg); }
00549
00550         SimUpdateStatus m_status;
00551
00552     };
00553
00554 // Inline definitions
00555 inline const SimExtLangUpdIndArg& SimExtLangUpdIndArg::Cast(const StackMsgArgument& arg) {
00556     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimExtLangUpdIndArg!\n");
00557     return ((SimExtLangUpdIndArg &) arg);
00558 }
00559
00560
00561
00562 /*  ======================================================================
00563     Class SimSpnReadIndArg
00564     ====================================================================== */
00565
00567 class SimSpnReadIndArg : public StackMsgArgument {
00568     friend class CommonStackMsgArgsDestroyTableNode;
00569     public:
00570         SimSpnReadIndArg();
00571
00572         static const SimSpnReadIndArg& Cast(const StackMsgArgument& arg);
00573         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00574         const SimUpdateStatus& GetStatus() const { return m_status; }
00575         void SetSpnStruct(const ServiceProviderStruct& spn_struct) { m_spn_struct = spn_struct; }
00576         const ServiceProviderStruct& GetSpnStruct() const { return m_spn_struct; }
00577
00578         enum  {
00579             ID = 1416
00580             };
00581
00582     private:
00583
00584         static void Destroy(StackMsgArgument* arg) { delete ((SimSpnReadIndArg*) arg); }
00585
00586         SimUpdateStatus m_status;
00587         ServiceProviderStruct m_spn_struct;
00588
00589     };
00590
00591 // Inline definitions
00592 inline const SimSpnReadIndArg& SimSpnReadIndArg::Cast(const StackMsgArgument& arg) {
00593     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimSpnReadIndArg!\n");
00594     return ((SimSpnReadIndArg &) arg);
00595 }
00596
00597
00598
00599 /*  ======================================================================
00600     Class SimFileInfoIndArg
00601     ====================================================================== */
00602
00604 class SimFileInfoIndArg : public StackMsgArgument {
00605     friend class CommonStackMsgArgsDestroyTableNode;
00606     public:
00607         SimFileInfoIndArg();
00608
00609         static const SimFileInfoIndArg& Cast(const StackMsgArgument& arg);
00610         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00611         const SimUpdateStatus& GetStatus() const { return m_status; }
00612         void SetFileId(INT file_id) { m_file_id = file_id; }
00613         INT GetFileId() const { return m_file_id; }
00614         void SetFileType(const SimFileType& file_type) { m_file_type = file_type; }
00615         const SimFileType& GetFileType() const { return m_file_type; }
00616         void SetChvNo(const ChvNo& chv_no) { m_chv_no = chv_no; }
00617         const ChvNo& GetChvNo() const { return m_chv_no; }
00618         void SetFileSize(UINT file_size) { m_file_size = file_size; }
00619         UINT GetFileSize() const { return m_file_size; }
00620         void SetRecordLength(UINT8 record_length) { m_record_length = record_length; }
00621         UINT8 GetRecordLength() const { return m_record_length; }
00622         void SetInvalidation(UINT8 invalidation) { m_invalidation = invalidation; }
00623         UINT8 GetInvalidation() const { return m_invalidation; }
00624
00625         enum  {
00626             ID = 1417
00627             };
00628
00629     private:
00630
00631         static void Destroy(StackMsgArgument* arg) { delete ((SimFileInfoIndArg*) arg); }
00632
00633         SimUpdateStatus m_status;
00634         INT m_file_id;
00635         SimFileType m_file_type;
00636         ChvNo m_chv_no;
00637         UINT m_file_size;
00638         UINT8 m_record_length;
00639         UINT8 m_invalidation;
00640
00641     };
00642
00643 // Inline definitions
00644 inline const SimFileInfoIndArg& SimFileInfoIndArg::Cast(const StackMsgArgument& arg) {
00645     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimFileInfoIndArg!\n");
00646     return ((SimFileInfoIndArg &) arg);
00647 }
00648
00649
00650
00651 /*  ======================================================================
00652     Class CphsIstReadIndArg
00653     ====================================================================== */
00654
00656 class CphsIstReadIndArg : public StackMsgArgument {
00657     friend class CommonStackMsgArgsDestroyTableNode;
00658     public:
00659         CphsIstReadIndArg();
00660
00661         static const CphsIstReadIndArg& Cast(const StackMsgArgument& arg);
00662         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00663         const SimUpdateStatus& GetStatus() const { return m_status; }
00664         void SetCphsIstArray(const CphsIstArray& cphs_ist_array) { m_cphs_ist_array = cphs_ist_array; }
00665         const CphsIstArray& GetCphsIstArray() const { return m_cphs_ist_array; }
00666
00667         enum  {
00668             ID = 1418
00669             };
00670
00671     private:
00672
00673         static void Destroy(StackMsgArgument* arg) { delete ((CphsIstReadIndArg*) arg); }
00674
00675         SimUpdateStatus m_status;
00676         CphsIstArray m_cphs_ist_array;
00677
00678     };
00679
00680 // Inline definitions
00681 inline const CphsIstReadIndArg& CphsIstReadIndArg::Cast(const StackMsgArgument& arg) {
00682     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsIstReadIndArg!\n");
00683     return ((CphsIstReadIndArg &) arg);
00684 }
00685
00686
00687
00688 /*  ======================================================================
00689     Class CphsVmwfReadIndArg
00690     ====================================================================== */
00691
00693 class CphsVmwfReadIndArg : public StackMsgArgument {
00694     friend class CommonStackMsgArgsDestroyTableNode;
00695     public:
00696         CphsVmwfReadIndArg();
00697
00698         static const CphsVmwfReadIndArg& Cast(const StackMsgArgument& arg);
00699         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00700         const SimUpdateStatus& GetStatus() const { return m_status; }
00701         void SetCphsVmwfArray(const CphsVmwfArray& cphs_vmwf_array) { m_cphs_vmwf_array = cphs_vmwf_array; }
00702         const CphsVmwfArray& GetCphsVmwfArray() const { return m_cphs_vmwf_array; }
00703
00704         enum  {
00705             ID = 1419
00706             };
00707
00708     private:
00709
00710         static void Destroy(StackMsgArgument* arg) { delete ((CphsVmwfReadIndArg*) arg); }
00711
00712         SimUpdateStatus m_status;
00713         CphsVmwfArray m_cphs_vmwf_array;
00714
00715     };
00716
00717 // Inline definitions
00718 inline const CphsVmwfReadIndArg& CphsVmwfReadIndArg::Cast(const StackMsgArgument& arg) {
00719     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsVmwfReadIndArg!\n");
00720     return ((CphsVmwfReadIndArg &) arg);
00721 }
00722
00723
00724
00725 /*  ======================================================================
00726     Class CphsCfufReadIndArg
00727     ====================================================================== */
00728
00730 class CphsCfufReadIndArg : public StackMsgArgument {
00731     friend class CommonStackMsgArgsDestroyTableNode;
00732     public:
00733         CphsCfufReadIndArg();
00734
00735         static const CphsCfufReadIndArg& Cast(const StackMsgArgument& arg);
00736         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00737         const SimUpdateStatus& GetStatus() const { return m_status; }
00738         void SetCphsCfufArray(const CphsCfufArray& cphs_cfuf_array) { m_cphs_cfuf_array = cphs_cfuf_array; }
00739         const CphsCfufArray& GetCphsCfufArray() const { return m_cphs_cfuf_array; }
00740
00741         enum  {
00742             ID = 1420
00743             };
00744
00745     private:
00746
00747         static void Destroy(StackMsgArgument* arg) { delete ((CphsCfufReadIndArg*) arg); }
00748
00749         SimUpdateStatus m_status;
00750         CphsCfufArray m_cphs_cfuf_array;
00751
00752     };
00753
00754 // Inline definitions
00755 inline const CphsCfufReadIndArg& CphsCfufReadIndArg::Cast(const StackMsgArgument& arg) {
00756     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsCfufReadIndArg!\n");
00757     return ((CphsCfufReadIndArg &) arg);
00758 }
00759
00760
00761
00762 /*  ======================================================================
00763     Class CphsOnmReadIndArg
00764     ====================================================================== */
00765
00767 class CphsOnmReadIndArg : public StackMsgArgument {
00768     friend class CommonStackMsgArgsDestroyTableNode;
00769     public:
00770         CphsOnmReadIndArg();
00771
00772         static const CphsOnmReadIndArg& Cast(const StackMsgArgument& arg);
00773         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00774         const SimUpdateStatus& GetStatus() const { return m_status; }
00775         void SetCphsOnmName(const CphsOnmName& cphs_onm_name) { m_cphs_onm_name = cphs_onm_name; }
00776         const CphsOnmName& GetCphsOnmName() const { return m_cphs_onm_name; }
00777
00778         enum  {
00779             ID = 1421
00780             };
00781
00782     private:
00783
00784         static void Destroy(StackMsgArgument* arg) { delete ((CphsOnmReadIndArg*) arg); }
00785
00786         SimUpdateStatus m_status;
00787         CphsOnmName m_cphs_onm_name;
00788
00789     };
00790
00791 // Inline definitions
00792 inline const CphsOnmReadIndArg& CphsOnmReadIndArg::Cast(const StackMsgArgument& arg) {
00793     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsOnmReadIndArg!\n");
00794     return ((CphsOnmReadIndArg &) arg);
00795 }
00796
00797
00798
00799 /*  ======================================================================
00800     Class CphsOnsReadIndArg
00801     ====================================================================== */
00802
00804 class CphsOnsReadIndArg : public StackMsgArgument {
00805     friend class CommonStackMsgArgsDestroyTableNode;
00806     public:
00807         CphsOnsReadIndArg();
00808
00809         static const CphsOnsReadIndArg& Cast(const StackMsgArgument& arg);
00810         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00811         const SimUpdateStatus& GetStatus() const { return m_status; }
00812         void SetCphsOnsName(const CphsOnsName& cphs_ons_name) { m_cphs_ons_name = cphs_ons_name; }
00813         const CphsOnsName& GetCphsOnsName() const { return m_cphs_ons_name; }
00814
00815         enum  {
00816             ID = 1422
00817             };
00818
00819     private:
00820
00821         static void Destroy(StackMsgArgument* arg) { delete ((CphsOnsReadIndArg*) arg); }
00822
00823         SimUpdateStatus m_status;
00824         CphsOnsName m_cphs_ons_name;
00825
00826     };
00827
00828 // Inline definitions
00829 inline const CphsOnsReadIndArg& CphsOnsReadIndArg::Cast(const StackMsgArgument& arg) {
00830     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsOnsReadIndArg!\n");
00831     return ((CphsOnsReadIndArg &) arg);
00832 }
00833
00834
00835
00836 /*  ======================================================================
00837     Class CphsVmwfUpdIndArg
00838     ====================================================================== */
00839
00841 class CphsVmwfUpdIndArg : public StackMsgArgument {
00842     friend class CommonStackMsgArgsDestroyTableNode;
00843     public:
00844         CphsVmwfUpdIndArg();
00845
00846         static const CphsVmwfUpdIndArg& Cast(const StackMsgArgument& arg);
00847         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00848         const SimUpdateStatus& GetStatus() const { return m_status; }
00849
00850         enum  {
00851             ID = 1423
00852             };
00853
00854     private:
00855
00856         static void Destroy(StackMsgArgument* arg) { delete ((CphsVmwfUpdIndArg*) arg); }
00857
00858         SimUpdateStatus m_status;
00859
00860     };
00861
00862 // Inline definitions
00863 inline const CphsVmwfUpdIndArg& CphsVmwfUpdIndArg::Cast(const StackMsgArgument& arg) {
00864     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsVmwfUpdIndArg!\n");
00865     return ((CphsVmwfUpdIndArg &) arg);
00866 }
00867
00868
00869
00870 /*  ======================================================================
00871     Class CphsCfufUpdIndArg
00872     ====================================================================== */
00873
00875 class CphsCfufUpdIndArg : public StackMsgArgument {
00876     friend class CommonStackMsgArgsDestroyTableNode;
00877     public:
00878         CphsCfufUpdIndArg();
00879
00880         static const CphsCfufUpdIndArg& Cast(const StackMsgArgument& arg);
00881         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00882         const SimUpdateStatus& GetStatus() const { return m_status; }
00883
00884         enum  {
00885             ID = 1424
00886             };
00887
00888     private:
00889
00890         static void Destroy(StackMsgArgument* arg) { delete ((CphsCfufUpdIndArg*) arg); }
00891
00892         SimUpdateStatus m_status;
00893
00894     };
00895
00896 // Inline definitions
00897 inline const CphsCfufUpdIndArg& CphsCfufUpdIndArg::Cast(const StackMsgArgument& arg) {
00898     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsCfufUpdIndArg!\n");
00899     return ((CphsCfufUpdIndArg &) arg);
00900 }
00901
00902
00903
00904 /*  ======================================================================
00905     Class CphsCspReadIndArg
00906     ====================================================================== */
00907
00909 class CphsCspReadIndArg : public StackMsgArgument {
00910     friend class CommonStackMsgArgsDestroyTableNode;
00911     public:
00912         CphsCspReadIndArg();
00913
00914         static const CphsCspReadIndArg& Cast(const StackMsgArgument& arg);
00915         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00916         const SimUpdateStatus& GetStatus() const { return m_status; }
00917         void SetLineSelector(const LineSelector& line_selector) { m_line_selector = line_selector; }
00918         const LineSelector& GetLineSelector() const { return m_line_selector; }
00919         void SetNoOfGroups(INT no_of_groups) { m_no_of_groups = no_of_groups; }
00920         INT GetNoOfGroups() const { return m_no_of_groups; }
00921         void SetCphsCspArray(const CphsCspArray& cphs_csp_array) { m_cphs_csp_array = cphs_csp_array; }
00922         const CphsCspArray& GetCphsCspArray() const { return m_cphs_csp_array; }
00923
00924         enum  {
00925             ID = 1425
00926             };
00927
00928     private:
00929
00930         static void Destroy(StackMsgArgument* arg) { delete ((CphsCspReadIndArg*) arg); }
00931
00932         SimUpdateStatus m_status;
00933         LineSelector m_line_selector;
00934         INT m_no_of_groups;
00935         CphsCspArray m_cphs_csp_array;
00936
00937     };
00938
00939 // Inline definitions
00940 inline const CphsCspReadIndArg& CphsCspReadIndArg::Cast(const StackMsgArgument& arg) {
00941     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsCspReadIndArg!\n");
00942     return ((CphsCspReadIndArg &) arg);
00943 }
00944
00945
00946
00947 /*  ======================================================================
00948     Class CphsCspUpdIndArg
00949     ====================================================================== */
00950
00952 class CphsCspUpdIndArg : public StackMsgArgument {
00953     friend class CommonStackMsgArgsDestroyTableNode;
00954     public:
00955         CphsCspUpdIndArg();
00956
00957         static const CphsCspUpdIndArg& Cast(const StackMsgArgument& arg);
00958         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00959         const SimUpdateStatus& GetStatus() const { return m_status; }
00960         void SetLineSelector(const LineSelector& line_selector) { m_line_selector = line_selector; }
00961         const LineSelector& GetLineSelector() const { return m_line_selector; }
00962
00963         enum  {
00964             ID = 1426
00965             };
00966
00967     private:
00968
00969         static void Destroy(StackMsgArgument* arg) { delete ((CphsCspUpdIndArg*) arg); }
00970
00971         SimUpdateStatus m_status;
00972         LineSelector m_line_selector;
00973
00974     };
00975
00976 // Inline definitions
00977 inline const CphsCspUpdIndArg& CphsCspUpdIndArg::Cast(const StackMsgArgument& arg) {
00978     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsCspUpdIndArg!\n");
00979     return ((CphsCspUpdIndArg &) arg);
00980 }
00981
00982
00983
00984 /*  ======================================================================
00985     Class SimCbmiReadIndArg
00986     ====================================================================== */
00987
00989 class SimCbmiReadIndArg : public StackMsgArgument {
00990     friend class CommonStackMsgArgsDestroyTableNode;
00991     public:
00992         SimCbmiReadIndArg();
00993
00994         static const SimCbmiReadIndArg& Cast(const StackMsgArgument& arg);
00995         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
00996         const SimUpdateStatus& GetStatus() const { return m_status; }
00997         void SetCbmiData(const CbmiData& cbmi_data) { m_cbmi_data = cbmi_data; }
00998         const CbmiData& GetCbmiData() const { return m_cbmi_data; }
00999
01000         enum  {
01001             ID = 1428
01002             };
01003
01004     private:
01005
01006         static void Destroy(StackMsgArgument* arg) { delete ((SimCbmiReadIndArg*) arg); }
01007
01008         SimUpdateStatus m_status;
01009         CbmiData m_cbmi_data;
01010
01011     };
01012
01013 // Inline definitions
01014 inline const SimCbmiReadIndArg& SimCbmiReadIndArg::Cast(const StackMsgArgument& arg) {
01015     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCbmiReadIndArg!\n");
01016     return ((SimCbmiReadIndArg &) arg);
01017 }
01018
01019
01020
01021 /*  ======================================================================
01022     Class SimCbmirReadIndArg
01023     ====================================================================== */
01024
01026 class SimCbmirReadIndArg : public StackMsgArgument {
01027     friend class CommonStackMsgArgsDestroyTableNode;
01028     public:
01029         SimCbmirReadIndArg();
01030
01031         static const SimCbmirReadIndArg& Cast(const StackMsgArgument& arg);
01032         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01033         const SimUpdateStatus& GetStatus() const { return m_status; }
01034         void SetCbmiRange(const CbmiRange& cbmi_range) { m_cbmi_range = cbmi_range; }
01035         const CbmiRange& GetCbmiRange() const { return m_cbmi_range; }
01036
01037         enum  {
01038             ID = 1429
01039             };
01040
01041     private:
01042
01043         static void Destroy(StackMsgArgument* arg) { delete ((SimCbmirReadIndArg*) arg); }
01044
01045         SimUpdateStatus m_status;
01046         CbmiRange m_cbmi_range;
01047
01048     };
01049
01050 // Inline definitions
01051 inline const SimCbmirReadIndArg& SimCbmirReadIndArg::Cast(const StackMsgArgument& arg) {
01052     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCbmirReadIndArg!\n");
01053     return ((SimCbmirReadIndArg &) arg);
01054 }
01055
01056
01057
01058 /*  ======================================================================
01059     Class SimCbmiUpdIndArg
01060     ====================================================================== */
01061
01063 class SimCbmiUpdIndArg : public StackMsgArgument {
01064     friend class CommonStackMsgArgsDestroyTableNode;
01065     public:
01066         SimCbmiUpdIndArg();
01067
01068         static const SimCbmiUpdIndArg& Cast(const StackMsgArgument& arg);
01069         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01070         const SimUpdateStatus& GetStatus() const { return m_status; }
01071
01072         enum  {
01073             ID = 1430
01074             };
01075
01076     private:
01077
01078         static void Destroy(StackMsgArgument* arg) { delete ((SimCbmiUpdIndArg*) arg); }
01079
01080         SimUpdateStatus m_status;
01081
01082     };
01083
01084 // Inline definitions
01085 inline const SimCbmiUpdIndArg& SimCbmiUpdIndArg::Cast(const StackMsgArgument& arg) {
01086     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCbmiUpdIndArg!\n");
01087     return ((SimCbmiUpdIndArg &) arg);
01088 }
01089
01090
01091
01092 /*  ======================================================================
01093     Class SimCbmirUpdIndArg
01094     ====================================================================== */
01095
01097 class SimCbmirUpdIndArg : public StackMsgArgument {
01098     friend class CommonStackMsgArgsDestroyTableNode;
01099     public:
01100         SimCbmirUpdIndArg();
01101
01102         static const SimCbmirUpdIndArg& Cast(const StackMsgArgument& arg);
01103         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01104         const SimUpdateStatus& GetStatus() const { return m_status; }
01105
01106         enum  {
01107             ID = 1431
01108             };
01109
01110     private:
01111
01112         static void Destroy(StackMsgArgument* arg) { delete ((SimCbmirUpdIndArg*) arg); }
01113
01114         SimUpdateStatus m_status;
01115
01116     };
01117
01118 // Inline definitions
01119 inline const SimCbmirUpdIndArg& SimCbmirUpdIndArg::Cast(const StackMsgArgument& arg) {
01120     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCbmirUpdIndArg!\n");
01121     return ((SimCbmirUpdIndArg &) arg);
01122 }
01123
01124
01125
01126 /*  ======================================================================
01127     Class SimCcpReadIndArg
01128     ====================================================================== */
01129
01131 class SimCcpReadIndArg : public StackMsgArgument {
01132     friend class CommonStackMsgArgsDestroyTableNode;
01133     public:
01134         SimCcpReadIndArg();
01135
01136         static const SimCcpReadIndArg& Cast(const StackMsgArgument& arg);
01137         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01138         const SimUpdateStatus& GetStatus() const { return m_status; }
01139         void SetCcpData(const CcpData& ccp_data) { m_ccp_data = ccp_data; }
01140         const CcpData& GetCcpData() const { return m_ccp_data; }
01141
01142         enum  {
01143             ID = 1432
01144             };
01145
01146     private:
01147
01148         static void Destroy(StackMsgArgument* arg) { delete ((SimCcpReadIndArg*) arg); }
01149
01150         SimUpdateStatus m_status;
01151         CcpData m_ccp_data;
01152
01153     };
01154
01155 // Inline definitions
01156 inline const SimCcpReadIndArg& SimCcpReadIndArg::Cast(const StackMsgArgument& arg) {
01157     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCcpReadIndArg!\n");
01158     return ((SimCcpReadIndArg &) arg);
01159 }
01160
01161
01162
01163 /*  ======================================================================
01164     Class SimCcpUpdIndArg
01165     ====================================================================== */
01166
01168 class SimCcpUpdIndArg : public StackMsgArgument {
01169     friend class CommonStackMsgArgsDestroyTableNode;
01170     public:
01171         SimCcpUpdIndArg();
01172
01173         static const SimCcpUpdIndArg& Cast(const StackMsgArgument& arg);
01174         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01175         const SimUpdateStatus& GetStatus() const { return m_status; }
01176
01177         enum  {
01178             ID = 1433
01179             };
01180
01181     private:
01182
01183         static void Destroy(StackMsgArgument* arg) { delete ((SimCcpUpdIndArg*) arg); }
01184
01185         SimUpdateStatus m_status;
01186
01187     };
01188
01189 // Inline definitions
01190 inline const SimCcpUpdIndArg& SimCcpUpdIndArg::Cast(const StackMsgArgument& arg) {
01191     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCcpUpdIndArg!\n");
01192     return ((SimCcpUpdIndArg &) arg);
01193 }
01194
01195
01196
01197 /*  ======================================================================
01198     Class SimSmsrReadIndArg
01199     ====================================================================== */
01200
01202 class SimSmsrReadIndArg : public StackMsgArgument {
01203     friend class CommonStackMsgArgsDestroyTableNode;
01204     public:
01205         SimSmsrReadIndArg();
01206
01207         static const SimSmsrReadIndArg& Cast(const StackMsgArgument& arg);
01208         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01209         const SimUpdateStatus& GetStatus() const { return m_status; }
01210         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
01211         INT GetRecNo() const { return m_rec_no; }
01212         void SetLink(UINT8 link) { m_link = link; }
01213         UINT8 GetLink() const { return m_link; }
01214         void SetSmsrData(const SmsrData& smsr_data) { m_smsr_data = smsr_data; }
01215         const SmsrData& GetSmsrData() const { return m_smsr_data; }
01216
01217         enum  {
01218             ID = 1434
01219             };
01220
01221     private:
01222
01223         static void Destroy(StackMsgArgument* arg) { delete ((SimSmsrReadIndArg*) arg); }
01224
01225         SimUpdateStatus m_status;
01226         INT m_rec_no;
01227         UINT8 m_link;
01228         SmsrData m_smsr_data;
01229
01230     };
01231
01232 // Inline definitions
01233 inline const SimSmsrReadIndArg& SimSmsrReadIndArg::Cast(const StackMsgArgument& arg) {
01234     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimSmsrReadIndArg!\n");
01235     return ((SimSmsrReadIndArg &) arg);
01236 }
01237
01238
01239
01240 /*  ======================================================================
01241     Class SimSmsrUpdIndArg
01242     ====================================================================== */
01243
01245 class SimSmsrUpdIndArg : public StackMsgArgument {
01246     friend class CommonStackMsgArgsDestroyTableNode;
01247     public:
01248         SimSmsrUpdIndArg();
01249
01250         static const SimSmsrUpdIndArg& Cast(const StackMsgArgument& arg);
01251         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01252         const SimUpdateStatus& GetStatus() const { return m_status; }
01253         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
01254         INT GetRecNo() const { return m_rec_no; }
01255
01256         enum  {
01257             ID = 1435
01258             };
01259
01260     private:
01261
01262         static void Destroy(StackMsgArgument* arg) { delete ((SimSmsrUpdIndArg*) arg); }
01263
01264         SimUpdateStatus m_status;
01265         INT m_rec_no;
01266
01267     };
01268
01269 // Inline definitions
01270 inline const SimSmsrUpdIndArg& SimSmsrUpdIndArg::Cast(const StackMsgArgument& arg) {
01271     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimSmsrUpdIndArg!\n");
01272     return ((SimSmsrUpdIndArg &) arg);
01273 }
01274
01275
01276
01277 /*  ======================================================================
01278     Class SimMccMncIndArg
01279     ====================================================================== */
01280
01282 class SimMccMncIndArg : public StackMsgArgument {
01283     friend class CommonStackMsgArgsDestroyTableNode;
01284     public:
01285         SimMccMncIndArg();
01286
01287         static const SimMccMncIndArg& Cast(const StackMsgArgument& arg);
01288         void SetBcdPlmn(const BcdPlmn& bcd_plmn) { m_bcd_plmn = bcd_plmn; }
01289         const BcdPlmn& GetBcdPlmn() const { return m_bcd_plmn; }
01290
01291         enum  {
01292             ID = 1436
01293             };
01294
01295     private:
01296
01297         static void Destroy(StackMsgArgument* arg) { delete ((SimMccMncIndArg*) arg); }
01298
01299         BcdPlmn m_bcd_plmn;
01300
01301     };
01302
01303 // Inline definitions
01304 inline const SimMccMncIndArg& SimMccMncIndArg::Cast(const StackMsgArgument& arg) {
01305     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimMccMncIndArg!\n");
01306     return ((SimMccMncIndArg &) arg);
01307 }
01308
01309
01310
01311 /*  ======================================================================
01312     Class UsimUstReadIndArg
01313     ====================================================================== */
01314
01316 class UsimUstReadIndArg : public StackMsgArgument {
01317     friend class CommonStackMsgArgsDestroyTableNode;
01318     public:
01319         UsimUstReadIndArg();
01320
01321         static const UsimUstReadIndArg& Cast(const StackMsgArgument& arg);
01322         void SetLength(INT length) { m_length = length; }
01323         INT GetLength() const { return m_length; }
01324         void SetUst(const UsimUst& ust) { m_ust = ust; }
01325         const UsimUst& GetUst() const { return m_ust; }
01326         void SetFlag(BOOLEAN flag) { m_flag = flag; }
01327         BOOLEAN IsFlag() const { return m_flag; }
01328         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01329         const SimUpdateStatus& GetStatus() const { return m_status; }
01330
01331         enum  {
01332             ID = 1437
01333             };
01334
01335     private:
01336
01337         static void Destroy(StackMsgArgument* arg) { delete ((UsimUstReadIndArg*) arg); }
01338
01339         INT m_length;
01340         UsimUst m_ust;
01341         BOOLEAN m_flag;
01342         SimUpdateStatus m_status;
01343
01344     };
01345
01346 // Inline definitions
01347 inline const UsimUstReadIndArg& UsimUstReadIndArg::Cast(const StackMsgArgument& arg) {
01348     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimUstReadIndArg!\n");
01349     return ((UsimUstReadIndArg &) arg);
01350 }
01351
01352
01353
01354 /*  ======================================================================
01355     Class UsimPlmnReadIndArg
01356     ====================================================================== */
01357
01359 class UsimPlmnReadIndArg : public StackMsgArgument {
01360     friend class CommonStackMsgArgsDestroyTableNode;
01361     public:
01362         UsimPlmnReadIndArg();
01363
01364         static const UsimPlmnReadIndArg& Cast(const StackMsgArgument& arg);
01365         void SetReadType(const UsimReadType& read_type) { m_read_type = read_type; }
01366         const UsimReadType& GetReadType() const { return m_read_type; }
01367         void SetLength(INT length) { m_length = length; }
01368         INT GetLength() const { return m_length; }
01369         void SetPlmnList(const UsimPlmnList& plmn_list) { m_plmn_list = plmn_list; }
01370         const UsimPlmnList& GetPlmnList() const { return m_plmn_list; }
01371         void SetEndReached(BOOLEAN end_reached) { m_end_reached = end_reached; }
01372         BOOLEAN IsEndReached() const { return m_end_reached; }
01373         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01374         const SimUpdateStatus& GetStatus() const { return m_status; }
01375
01376         enum  {
01377             ID = 1438
01378             };
01379
01380     private:
01381
01382         static void Destroy(StackMsgArgument* arg) { delete ((UsimPlmnReadIndArg*) arg); }
01383
01384         UsimReadType m_read_type;
01385         INT m_length;
01386         UsimPlmnList m_plmn_list;
01387         BOOLEAN m_end_reached;
01388         SimUpdateStatus m_status;
01389
01390     };
01391
01392 // Inline definitions
01393 inline const UsimPlmnReadIndArg& UsimPlmnReadIndArg::Cast(const StackMsgArgument& arg) {
01394     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPlmnReadIndArg!\n");
01395     return ((UsimPlmnReadIndArg &) arg);
01396 }
01397
01398
01399
01400 /*  ======================================================================
01401     Class UsimReadRejArg
01402     ====================================================================== */
01403
01405 class UsimReadRejArg : public StackMsgArgument {
01406     friend class CommonStackMsgArgsDestroyTableNode;
01407     public:
01408         UsimReadRejArg();
01409
01410         static const UsimReadRejArg& Cast(const StackMsgArgument& arg);
01411         void SetReadType(const UsimReadType& read_type) { m_read_type = read_type; }
01412         const UsimReadType& GetReadType() const { return m_read_type; }
01413         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01414         const SimUpdateStatus& GetStatus() const { return m_status; }
01415
01416         enum  {
01417             ID = 1439
01418             };
01419
01420     private:
01421
01422         static void Destroy(StackMsgArgument* arg) { delete ((UsimReadRejArg*) arg); }
01423
01424         UsimReadType m_read_type;
01425         SimUpdateStatus m_status;
01426
01427     };
01428
01429 // Inline definitions
01430 inline const UsimReadRejArg& UsimReadRejArg::Cast(const StackMsgArgument& arg) {
01431     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimReadRejArg!\n");
01432     return ((UsimReadRejArg &) arg);
01433 }
01434
01435
01436
01437 /*  ======================================================================
01438     Class UsimCsLociReadIndArg
01439     ====================================================================== */
01440
01442 class UsimCsLociReadIndArg : public StackMsgArgument {
01443     friend class CommonStackMsgArgsDestroyTableNode;
01444     public:
01445         UsimCsLociReadIndArg();
01446
01447         static const UsimCsLociReadIndArg& Cast(const StackMsgArgument& arg);
01448         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01449         const SimUpdateStatus& GetStatus() const { return m_status; }
01450         void SetLociData(const LociData& loci_data) { m_loci_data = loci_data; }
01451         const LociData& GetLociData() const { return m_loci_data; }
01452
01453         enum  {
01454             ID = 1440
01455             };
01456
01457     private:
01458
01459         static void Destroy(StackMsgArgument* arg) { delete ((UsimCsLociReadIndArg*) arg); }
01460
01461         SimUpdateStatus m_status;
01462         LociData m_loci_data;
01463
01464     };
01465
01466 // Inline definitions
01467 inline const UsimCsLociReadIndArg& UsimCsLociReadIndArg::Cast(const StackMsgArgument& arg) {
01468     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimCsLociReadIndArg!\n");
01469     return ((UsimCsLociReadIndArg &) arg);
01470 }
01471
01472
01473
01474 /*  ======================================================================
01475     Class UsimPsLociReadIndArg
01476     ====================================================================== */
01477
01479 class UsimPsLociReadIndArg : public StackMsgArgument {
01480     friend class CommonStackMsgArgsDestroyTableNode;
01481     public:
01482         UsimPsLociReadIndArg();
01483
01484         static const UsimPsLociReadIndArg& Cast(const StackMsgArgument& arg);
01485         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01486         const SimUpdateStatus& GetStatus() const { return m_status; }
01487         void SetPsLociData(const PsLociData& ps_loci_data) { m_ps_loci_data = ps_loci_data; }
01488         const PsLociData& GetPsLociData() const { return m_ps_loci_data; }
01489
01490         enum  {
01491             ID = 1441
01492             };
01493
01494     private:
01495
01496         static void Destroy(StackMsgArgument* arg) { delete ((UsimPsLociReadIndArg*) arg); }
01497
01498         SimUpdateStatus m_status;
01499         PsLociData m_ps_loci_data;
01500
01501     };
01502
01503 // Inline definitions
01504 inline const UsimPsLociReadIndArg& UsimPsLociReadIndArg::Cast(const StackMsgArgument& arg) {
01505     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPsLociReadIndArg!\n");
01506     return ((UsimPsLociReadIndArg &) arg);
01507 }
01508
01509
01510
01511 /*  ======================================================================
01512     Class UsimLangReadIndArg
01513     ====================================================================== */
01514
01516 class UsimLangReadIndArg : public StackMsgArgument {
01517     friend class CommonStackMsgArgsDestroyTableNode;
01518     public:
01519         UsimLangReadIndArg();
01520
01521         static const UsimLangReadIndArg& Cast(const StackMsgArgument& arg);
01522         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01523         const SimUpdateStatus& GetStatus() const { return m_status; }
01524         void SetLangFileType(const UsimLangFileType& lang_file_type) { m_lang_file_type = lang_file_type; }
01525         const UsimLangFileType& GetLangFileType() const { return m_lang_file_type; }
01526         void SetLength(INT length) { m_length = length; }
01527         INT GetLength() const { return m_length; }
01528         void SetLanguageList(const UsimLanguageList& language_list) { m_language_list = language_list; }
01529         const UsimLanguageList& GetLanguageList() const { return m_language_list; }
01530
01531         enum  {
01532             ID = 1442
01533             };
01534
01535     private:
01536
01537         static void Destroy(StackMsgArgument* arg) { delete ((UsimLangReadIndArg*) arg); }
01538
01539         SimUpdateStatus m_status;
01540         UsimLangFileType m_lang_file_type;
01541         INT m_length;
01542         UsimLanguageList m_language_list;
01543
01544     };
01545
01546 // Inline definitions
01547 inline const UsimLangReadIndArg& UsimLangReadIndArg::Cast(const StackMsgArgument& arg) {
01548     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimLangReadIndArg!\n");
01549     return ((UsimLangReadIndArg &) arg);
01550 }
01551
01552
01553
01554 /*  ======================================================================
01555     Class UsimEccReadIndArg
01556     ====================================================================== */
01557
01559 class UsimEccReadIndArg : public StackMsgArgument {
01560     friend class CommonStackMsgArgsDestroyTableNode;
01561     public:
01562         UsimEccReadIndArg();
01563
01564         static const UsimEccReadIndArg& Cast(const StackMsgArgument& arg);
01565         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01566         const SimUpdateStatus& GetStatus() const { return m_status; }
01567         void SetEccRecord(const UsimEccRecord& ecc_record) { m_ecc_record = ecc_record; }
01568         const UsimEccRecord& GetEccRecord() const { return m_ecc_record; }
01569
01570         enum  {
01571             ID = 1443
01572             };
01573
01574     private:
01575
01576         static void Destroy(StackMsgArgument* arg) { delete ((UsimEccReadIndArg*) arg); }
01577
01578         SimUpdateStatus m_status;
01579         UsimEccRecord m_ecc_record;
01580
01581     };
01582
01583 // Inline definitions
01584 inline const UsimEccReadIndArg& UsimEccReadIndArg::Cast(const StackMsgArgument& arg) {
01585     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimEccReadIndArg!\n");
01586     return ((UsimEccReadIndArg &) arg);
01587 }
01588
01589
01590
01591 /*  ======================================================================
01592     Class UsimReadRecordRejArg
01593     ====================================================================== */
01594
01596 class UsimReadRecordRejArg : public StackMsgArgument {
01597     friend class CommonStackMsgArgsDestroyTableNode;
01598     public:
01599         UsimReadRecordRejArg();
01600
01601         static const UsimReadRecordRejArg& Cast(const StackMsgArgument& arg);
01602         void SetReadType(const UsimReadType& read_type) { m_read_type = read_type; }
01603         const UsimReadType& GetReadType() const { return m_read_type; }
01604         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01605         const SimUpdateStatus& GetStatus() const { return m_status; }
01606
01607         enum  {
01608             ID = 1444
01609             };
01610
01611     private:
01612
01613         static void Destroy(StackMsgArgument* arg) { delete ((UsimReadRecordRejArg*) arg); }
01614
01615         UsimReadType m_read_type;
01616         SimUpdateStatus m_status;
01617
01618     };
01619
01620 // Inline definitions
01621 inline const UsimReadRecordRejArg& UsimReadRecordRejArg::Cast(const StackMsgArgument& arg) {
01622     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimReadRecordRejArg!\n");
01623     return ((UsimReadRecordRejArg &) arg);
01624 }
01625
01626
01627
01628 /*  ======================================================================
01629     Class UsimSmsParamReadIndArg
01630     ====================================================================== */
01631
01633 class UsimSmsParamReadIndArg : public StackMsgArgument {
01634     friend class CommonStackMsgArgsDestroyTableNode;
01635     public:
01636         UsimSmsParamReadIndArg();
01637
01638         static const UsimSmsParamReadIndArg& Cast(const StackMsgArgument& arg);
01639         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01640         const SimUpdateStatus& GetStatus() const { return m_status; }
01641         void SetRecno(INT recno) { m_recno = recno; }
01642         INT GetRecno() const { return m_recno; }
01643         void SetAlphaSize(INT alpha_size) { m_alpha_size = alpha_size; }
01644         INT GetAlphaSize() const { return m_alpha_size; }
01645         void SetData(const SimData& data) { m_data = data; }
01646         const SimData& GetData() const { return m_data; }
01647         void SetAddData(BOOLEAN add_data) { m_add_data = add_data; }
01648         BOOLEAN IsAddData() const { return m_add_data; }
01649
01650         enum  {
01651             ID = 1445
01652             };
01653
01654     private:
01655
01656         static void Destroy(StackMsgArgument* arg) { delete ((UsimSmsParamReadIndArg*) arg); }
01657
01658         SimUpdateStatus m_status;
01659         INT m_recno;
01660         INT m_alpha_size;
01661         SimData m_data;
01662         BOOLEAN m_add_data;
01663
01664     };
01665
01666 // Inline definitions
01667 inline const UsimSmsParamReadIndArg& UsimSmsParamReadIndArg::Cast(const StackMsgArgument& arg) {
01668     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimSmsParamReadIndArg!\n");
01669     return ((UsimSmsParamReadIndArg &) arg);
01670 }
01671
01672
01673
01674 /*  ======================================================================
01675     Class UsimSmsParamExtIndArg
01676     ====================================================================== */
01677
01679 class UsimSmsParamExtIndArg : public StackMsgArgument {
01680     friend class CommonStackMsgArgsDestroyTableNode;
01681     public:
01682         UsimSmsParamExtIndArg();
01683
01684         static const UsimSmsParamExtIndArg& Cast(const StackMsgArgument& arg);
01685         void SetRecno(INT recno) { m_recno = recno; }
01686         INT GetRecno() const { return m_recno; }
01687         void SetData(const SimData& data) { m_data = data; }
01688         const SimData& GetData() const { return m_data; }
01689         void SetAddData(BOOLEAN add_data) { m_add_data = add_data; }
01690         BOOLEAN IsAddData() const { return m_add_data; }
01691
01692         enum  {
01693             ID = 1446
01694             };
01695
01696     private:
01697
01698         static void Destroy(StackMsgArgument* arg) { delete ((UsimSmsParamExtIndArg*) arg); }
01699
01700         INT m_recno;
01701         SimData m_data;
01702         BOOLEAN m_add_data;
01703
01704     };
01705
01706 // Inline definitions
01707 inline const UsimSmsParamExtIndArg& UsimSmsParamExtIndArg::Cast(const StackMsgArgument& arg) {
01708     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimSmsParamExtIndArg!\n");
01709     return ((UsimSmsParamExtIndArg &) arg);
01710 }
01711
01712
01713
01714 /*  ======================================================================
01715     Class UsimUpdCnfArg
01716     ====================================================================== */
01717
01719 class UsimUpdCnfArg : public StackMsgArgument {
01720     friend class CommonStackMsgArgsDestroyTableNode;
01721     public:
01722         UsimUpdCnfArg();
01723
01724         static const UsimUpdCnfArg& Cast(const StackMsgArgument& arg);
01725         void SetReadType(const UsimReadType& read_type) { m_read_type = read_type; }
01726         const UsimReadType& GetReadType() const { return m_read_type; }
01727
01728         enum  {
01729             ID = 1447
01730             };
01731
01732     private:
01733
01734         static void Destroy(StackMsgArgument* arg) { delete ((UsimUpdCnfArg*) arg); }
01735
01736         UsimReadType m_read_type;
01737
01738     };
01739
01740 // Inline definitions
01741 inline const UsimUpdCnfArg& UsimUpdCnfArg::Cast(const StackMsgArgument& arg) {
01742     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimUpdCnfArg!\n");
01743     return ((UsimUpdCnfArg &) arg);
01744 }
01745
01746
01747
01748 /*  ======================================================================
01749     Class UsimUpdRejArg
01750     ====================================================================== */
01751
01753 class UsimUpdRejArg : public StackMsgArgument {
01754     friend class CommonStackMsgArgsDestroyTableNode;
01755     public:
01756         UsimUpdRejArg();
01757
01758         static const UsimUpdRejArg& Cast(const StackMsgArgument& arg);
01759         void SetReadType(const UsimReadType& read_type) { m_read_type = read_type; }
01760         const UsimReadType& GetReadType() const { return m_read_type; }
01761         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01762         const SimUpdateStatus& GetStatus() const { return m_status; }
01763
01764         enum  {
01765             ID = 1448
01766             };
01767
01768     private:
01769
01770         static void Destroy(StackMsgArgument* arg) { delete ((UsimUpdRejArg*) arg); }
01771
01772         UsimReadType m_read_type;
01773         SimUpdateStatus m_status;
01774
01775     };
01776
01777 // Inline definitions
01778 inline const UsimUpdRejArg& UsimUpdRejArg::Cast(const StackMsgArgument& arg) {
01779     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimUpdRejArg!\n");
01780     return ((UsimUpdRejArg &) arg);
01781 }
01782
01783
01784
01785 /*  ======================================================================
01786     Class UsimPlmnUpdIndArg
01787     ====================================================================== */
01788
01790 class UsimPlmnUpdIndArg : public StackMsgArgument {
01791     friend class CommonStackMsgArgsDestroyTableNode;
01792     public:
01793         UsimPlmnUpdIndArg();
01794
01795         static const UsimPlmnUpdIndArg& Cast(const StackMsgArgument& arg);
01796         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01797         const SimUpdateStatus& GetStatus() const { return m_status; }
01798
01799         enum  {
01800             ID = 1449
01801             };
01802
01803     private:
01804
01805         static void Destroy(StackMsgArgument* arg) { delete ((UsimPlmnUpdIndArg*) arg); }
01806
01807         SimUpdateStatus m_status;
01808
01809     };
01810
01811 // Inline definitions
01812 inline const UsimPlmnUpdIndArg& UsimPlmnUpdIndArg::Cast(const StackMsgArgument& arg) {
01813     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPlmnUpdIndArg!\n");
01814     return ((UsimPlmnUpdIndArg &) arg);
01815 }
01816
01817
01818
01819 /*  ======================================================================
01820     Class UsimCardTypeReadIndArg
01821     ====================================================================== */
01822
01824 class UsimCardTypeReadIndArg : public StackMsgArgument {
01825     friend class CommonStackMsgArgsDestroyTableNode;
01826     public:
01827         UsimCardTypeReadIndArg();
01828
01829         static const UsimCardTypeReadIndArg& Cast(const StackMsgArgument& arg);
01830         void SetCardType(const SimCardType& card_type) { m_card_type = card_type; }
01831         const SimCardType& GetCardType() const { return m_card_type; }
01832         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01833         const SimUpdateStatus& GetStatus() const { return m_status; }
01834
01835         enum  {
01836             ID = 1450
01837             };
01838
01839     private:
01840
01841         static void Destroy(StackMsgArgument* arg) { delete ((UsimCardTypeReadIndArg*) arg); }
01842
01843         SimCardType m_card_type;
01844         SimUpdateStatus m_status;
01845
01846     };
01847
01848 // Inline definitions
01849 inline const UsimCardTypeReadIndArg& UsimCardTypeReadIndArg::Cast(const StackMsgArgument& arg) {
01850     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimCardTypeReadIndArg!\n");
01851     return ((UsimCardTypeReadIndArg &) arg);
01852 }
01853
01854
01855
01856 /*  ======================================================================
01857     Class UsimSmsParamUpdIndArg
01858     ====================================================================== */
01859
01861 class UsimSmsParamUpdIndArg : public StackMsgArgument {
01862     friend class CommonStackMsgArgsDestroyTableNode;
01863     public:
01864         UsimSmsParamUpdIndArg();
01865
01866         static const UsimSmsParamUpdIndArg& Cast(const StackMsgArgument& arg);
01867         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01868         const SimUpdateStatus& GetStatus() const { return m_status; }
01869         void SetRecno(INT recno) { m_recno = recno; }
01870         INT GetRecno() const { return m_recno; }
01871
01872         enum  {
01873             ID = 1451
01874             };
01875
01876     private:
01877
01878         static void Destroy(StackMsgArgument* arg) { delete ((UsimSmsParamUpdIndArg*) arg); }
01879
01880         SimUpdateStatus m_status;
01881         INT m_recno;
01882
01883     };
01884
01885 // Inline definitions
01886 inline const UsimSmsParamUpdIndArg& UsimSmsParamUpdIndArg::Cast(const StackMsgArgument& arg) {
01887     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimSmsParamUpdIndArg!\n");
01888     return ((UsimSmsParamUpdIndArg &) arg);
01889 }
01890
01891
01892
01893 /*  ======================================================================
01894     Class UsimEstReadIndArg
01895     ====================================================================== */
01896
01898 class UsimEstReadIndArg : public StackMsgArgument {
01899     friend class CommonStackMsgArgsDestroyTableNode;
01900     public:
01901         UsimEstReadIndArg();
01902
01903         static const UsimEstReadIndArg& Cast(const StackMsgArgument& arg);
01904         void SetLength(INT length) { m_length = length; }
01905         INT GetLength() const { return m_length; }
01906         void SetEst(const UsimEst& est) { m_est = est; }
01907         const UsimEst& GetEst() const { return m_est; }
01908         void SetFlag(BOOLEAN flag) { m_flag = flag; }
01909         BOOLEAN IsFlag() const { return m_flag; }
01910         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01911         const SimUpdateStatus& GetStatus() const { return m_status; }
01912
01913         enum  {
01914             ID = 1452
01915             };
01916
01917     private:
01918
01919         static void Destroy(StackMsgArgument* arg) { delete ((UsimEstReadIndArg*) arg); }
01920
01921         INT m_length;
01922         UsimEst m_est;
01923         BOOLEAN m_flag;
01924         SimUpdateStatus m_status;
01925
01926     };
01927
01928 // Inline definitions
01929 inline const UsimEstReadIndArg& UsimEstReadIndArg::Cast(const StackMsgArgument& arg) {
01930     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimEstReadIndArg!\n");
01931     return ((UsimEstReadIndArg &) arg);
01932 }
01933
01934
01935
01936 /*  ======================================================================
01937     Class UsimLangUpdIndArg
01938     ====================================================================== */
01939
01941 class UsimLangUpdIndArg : public StackMsgArgument {
01942     friend class CommonStackMsgArgsDestroyTableNode;
01943     public:
01944         UsimLangUpdIndArg();
01945
01946         static const UsimLangUpdIndArg& Cast(const StackMsgArgument& arg);
01947         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01948         const SimUpdateStatus& GetStatus() const { return m_status; }
01949
01950         enum  {
01951             ID = 1453
01952             };
01953
01954     private:
01955
01956         static void Destroy(StackMsgArgument* arg) { delete ((UsimLangUpdIndArg*) arg); }
01957
01958         SimUpdateStatus m_status;
01959
01960     };
01961
01962 // Inline definitions
01963 inline const UsimLangUpdIndArg& UsimLangUpdIndArg::Cast(const StackMsgArgument& arg) {
01964     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimLangUpdIndArg!\n");
01965     return ((UsimLangUpdIndArg &) arg);
01966 }
01967
01968
01969
01970 /*  ======================================================================
01971     Class UsimFilePropertyIndArg
01972     ====================================================================== */
01973
01975 class UsimFilePropertyIndArg : public StackMsgArgument {
01976     friend class CommonStackMsgArgsDestroyTableNode;
01977     public:
01978         UsimFilePropertyIndArg();
01979
01980         static const UsimFilePropertyIndArg& Cast(const StackMsgArgument& arg);
01981         void SetProperty(const UsimFileProperty& property) { m_property = property; }
01982         const UsimFileProperty& GetProperty() const { return m_property; }
01983         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
01984         const SimUpdateStatus& GetStatus() const { return m_status; }
01985
01986         enum  {
01987             ID = 1454
01988             };
01989
01990     private:
01991
01992         static void Destroy(StackMsgArgument* arg) { delete ((UsimFilePropertyIndArg*) arg); }
01993
01994         UsimFileProperty m_property;
01995         SimUpdateStatus m_status;
01996
01997     };
01998
01999 // Inline definitions
02000 inline const UsimFilePropertyIndArg& UsimFilePropertyIndArg::Cast(const StackMsgArgument& arg) {
02001     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimFilePropertyIndArg!\n");
02002     return ((UsimFilePropertyIndArg &) arg);
02003 }
02004
02005
02006
02007 /*  ======================================================================
02008     Class SimCmiReadIndArg
02009     ====================================================================== */
02010
02012 class SimCmiReadIndArg : public StackMsgArgument {
02013     friend class CommonStackMsgArgsDestroyTableNode;
02014     public:
02015         SimCmiReadIndArg();
02016
02017         static const SimCmiReadIndArg& Cast(const StackMsgArgument& arg);
02018         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
02019         const SimUpdateStatus& GetStatus() const { return m_status; }
02020         void SetCmiRecord(const CmiRecord& cmi_record) { m_cmi_record = cmi_record; }
02021         const CmiRecord& GetCmiRecord() const { return m_cmi_record; }
02022
02023         enum  {
02024             ID = 1470
02025             };
02026
02027     private:
02028
02029         static void Destroy(StackMsgArgument* arg) { delete ((SimCmiReadIndArg*) arg); }
02030
02031         SimUpdateStatus m_status;
02032         CmiRecord m_cmi_record;
02033
02034     };
02035
02036 // Inline definitions
02037 inline const SimCmiReadIndArg& SimCmiReadIndArg::Cast(const StackMsgArgument& arg) {
02038     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCmiReadIndArg!\n");
02039     return ((SimCmiReadIndArg &) arg);
02040 }
02041
02042
02043
02044 /*  ======================================================================
02045     Class SimODynReadIndArg
02046     ====================================================================== */
02047
02049 class SimODynReadIndArg : public StackMsgArgument {
02050     friend class CommonStackMsgArgsDestroyTableNode;
02051     public:
02052         SimODynReadIndArg();
02053
02054         static const SimODynReadIndArg& Cast(const StackMsgArgument& arg);
02055         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
02056         const SimUpdateStatus& GetStatus() const { return m_status; }
02057         void SetFlag(UINT8 flag) { m_flag = flag; }
02058         UINT8 GetFlag() const { return m_flag; }
02059
02060         enum  {
02061             ID = 1471
02062             };
02063
02064     private:
02065
02066         static void Destroy(StackMsgArgument* arg) { delete ((SimODynReadIndArg*) arg); }
02067
02068         SimUpdateStatus m_status;
02069         UINT8 m_flag;
02070
02071     };
02072
02073 // Inline definitions
02074 inline const SimODynReadIndArg& SimODynReadIndArg::Cast(const StackMsgArgument& arg) {
02075     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimODynReadIndArg!\n");
02076     return ((SimODynReadIndArg &) arg);
02077 }
02078
02079
02080
02081 /*  ======================================================================
02082     Class SimODyn2ReadIndArg
02083     ====================================================================== */
02084
02086 class SimODyn2ReadIndArg : public StackMsgArgument {
02087     friend class CommonStackMsgArgsDestroyTableNode;
02088     public:
02089         SimODyn2ReadIndArg();
02090
02091         static const SimODyn2ReadIndArg& Cast(const StackMsgArgument& arg);
02092         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
02093         const SimUpdateStatus& GetStatus() const { return m_status; }
02094         void SetFlag(UINT8 flag) { m_flag = flag; }
02095         UINT8 GetFlag() const { return m_flag; }
02096
02097         enum  {
02098             ID = 1472
02099             };
02100
02101     private:
02102
02103         static void Destroy(StackMsgArgument* arg) { delete ((SimODyn2ReadIndArg*) arg); }
02104
02105         SimUpdateStatus m_status;
02106         UINT8 m_flag;
02107
02108     };
02109
02110 // Inline definitions
02111 inline const SimODyn2ReadIndArg& SimODyn2ReadIndArg::Cast(const StackMsgArgument& arg) {
02112     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimODyn2ReadIndArg!\n");
02113     return ((SimODyn2ReadIndArg &) arg);
02114 }
02115
02116
02117
02118 /*  ======================================================================
02119     Class SimODynUpdIndArg
02120     ====================================================================== */
02121
02123 class SimODynUpdIndArg : public StackMsgArgument {
02124     friend class CommonStackMsgArgsDestroyTableNode;
02125     public:
02126         SimODynUpdIndArg();
02127
02128         static const SimODynUpdIndArg& Cast(const StackMsgArgument& arg);
02129         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
02130         const SimUpdateStatus& GetStatus() const { return m_status; }
02131
02132         enum  {
02133             ID = 1473
02134             };
02135
02136     private:
02137
02138         static void Destroy(StackMsgArgument* arg) { delete ((SimODynUpdIndArg*) arg); }
02139
02140         SimUpdateStatus m_status;
02141
02142     };
02143
02144 // Inline definitions
02145 inline const SimODynUpdIndArg& SimODynUpdIndArg::Cast(const StackMsgArgument& arg) {
02146     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimODynUpdIndArg!\n");
02147     return ((SimODynUpdIndArg &) arg);
02148 }
02149
02150
02151
02152 /*  ======================================================================
02153     Class SimODyn2UpdIndArg
02154     ====================================================================== */
02155
02157 class SimODyn2UpdIndArg : public StackMsgArgument {
02158     friend class CommonStackMsgArgsDestroyTableNode;
02159     public:
02160         SimODyn2UpdIndArg();
02161
02162         static const SimODyn2UpdIndArg& Cast(const StackMsgArgument& arg);
02163         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
02164         const SimUpdateStatus& GetStatus() const { return m_status; }
02165
02166         enum  {
02167             ID = 1474
02168             };
02169
02170     private:
02171
02172         static void Destroy(StackMsgArgument* arg) { delete ((SimODyn2UpdIndArg*) arg); }
02173
02174         SimUpdateStatus m_status;
02175
02176     };
02177
02178 // Inline definitions
02179 inline const SimODyn2UpdIndArg& SimODyn2UpdIndArg::Cast(const StackMsgArgument& arg) {
02180     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimODyn2UpdIndArg!\n");
02181     return ((SimODyn2UpdIndArg &) arg);
02182 }
02183
02184
02185
02186 /*  ======================================================================
02187     Class SimMruPropertyUpdCnfArg
02188     ====================================================================== */
02189
02191 class SimMruPropertyUpdCnfArg : public StackMsgArgument {
02192     friend class CommonStackMsgArgsDestroyTableNode;
02193     public:
02194         SimMruPropertyUpdCnfArg();
02195
02196         static const SimMruPropertyUpdCnfArg& Cast(const StackMsgArgument& arg);
02197         void SetChangedState(const SimChangedState& changed_state) { m_changed_state = changed_state; }
02198         const SimChangedState& GetChangedState() const { return m_changed_state; }
02199
02200         enum  {
02201             ID = 1475
02202             };
02203
02204     private:
02205
02206         static void Destroy(StackMsgArgument* arg) { delete ((SimMruPropertyUpdCnfArg*) arg); }
02207
02208         SimChangedState m_changed_state;
02209
02210     };
02211
02212 // Inline definitions
02213 inline const SimMruPropertyUpdCnfArg& SimMruPropertyUpdCnfArg::Cast(const StackMsgArgument& arg) {
02214     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimMruPropertyUpdCnfArg!\n");
02215     return ((SimMruPropertyUpdCnfArg &) arg);
02216 }
02217
02218
02219
02220 /*  ======================================================================
02221     Class SimMruPropertyRefreshIndArg
02222     ====================================================================== */
02223
02225 class SimMruPropertyRefreshIndArg : public StackMsgArgument {
02226     friend class CommonStackMsgArgsDestroyTableNode;
02227     public:
02228         SimMruPropertyRefreshIndArg();
02229
02230         static const SimMruPropertyRefreshIndArg& Cast(const StackMsgArgument& arg);
02231         void SetType(UINT16 type) { m_type = type; }
02232         UINT16 GetType() const { return m_type; }
02233         void SetIndex(UINT8 index) { m_index = index; }
02234         UINT8 GetIndex() const { return m_index; }
02235         void SetBitNumber(UINT8 bit_number) { m_bit_number = bit_number; }
02236         UINT8 GetBitNumber() const { return m_bit_number; }
02237         void SetBitValue(UINT8 bit_value) { m_bit_value = bit_value; }
02238         UINT8 GetBitValue() const { return m_bit_value; }
02239
02240         enum  {
02241             ID = 1476
02242             };
02243
02244     private:
02245
02246         static void Destroy(StackMsgArgument* arg) { delete ((SimMruPropertyRefreshIndArg*) arg); }
02247
02248         UINT16 m_type;
02249         UINT8 m_index;
02250         UINT8 m_bit_number;
02251         UINT8 m_bit_value;
02252
02253     };
02254
02255 // Inline definitions
02256 inline const SimMruPropertyRefreshIndArg& SimMruPropertyRefreshIndArg::Cast(const StackMsgArgument& arg) {
02257     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimMruPropertyRefreshIndArg!\n");
02258     return ((SimMruPropertyRefreshIndArg &) arg);
02259 }
02260
02261
02262
02263 /*  ======================================================================
02264     Class SimInitIndArg
02265     ====================================================================== */
02266
02268 class SimInitIndArg : public StackMsgArgument {
02269     friend class CommonStackMsgArgsDestroyTableNode;
02270     public:
02271         SimInitIndArg();
02272
02273         static const SimInitIndArg& Cast(const StackMsgArgument& arg);
02274         void SetStatus(const SimUpdateStatus& status) { m_status = status; }
02275         const SimUpdateStatus& GetStatus() const { return m_status; }
02276         void SetInitResult(const SimInitResult& init_result) { m_init_result = init_result; }
02277         const SimInitResult& GetInitResult() const { return m_init_result; }
02278         void SetImsi(const Imsi& imsi) { m_imsi = imsi; }
02279         const Imsi& GetImsi() const { return m_imsi; }
02280         void SetAdnByte(UINT8 adn_byte) { m_adn_byte = adn_byte; }
02281         UINT8 GetAdnByte() const { return m_adn_byte; }
02282         void SetBdnByte(UINT8 bdn_byte) { m_bdn_byte = bdn_byte; }
02283         UINT8 GetBdnByte() const { return m_bdn_byte; }
02284
02285         enum  {
02286             ID = 1480
02287             };
02288
02289     private:
02290
02291         static void Destroy(StackMsgArgument* arg) { delete ((SimInitIndArg*) arg); }
02292
02293         SimUpdateStatus m_status;
02294         SimInitResult m_init_result;
02295         Imsi m_imsi;
02296         UINT8 m_adn_byte;
02297         UINT8 m_bdn_byte;
02298
02299     };
02300
02301 // Inline definitions
02302 inline const SimInitIndArg& SimInitIndArg::Cast(const StackMsgArgument& arg) {
02303     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimInitIndArg!\n");
02304     return ((SimInitIndArg &) arg);
02305 }
02306
02307
02308
02309 /*  ======================================================================
02310     Class SimInfoIndArg
02311     ====================================================================== */
02312
02314 class SimInfoIndArg : public StackMsgArgument {
02315     friend class CommonStackMsgArgsDestroyTableNode;
02316     public:
02317         SimInfoIndArg();
02318
02319         static const SimInfoIndArg& Cast(const StackMsgArgument& arg);
02320         void SetSimInfo(const SimInfo& sim_info) { m_sim_info = sim_info; }
02321         const SimInfo& GetSimInfo() const { return m_sim_info; }
02322
02323         enum  {
02324             ID = 1481
02325             };
02326
02327     private:
02328
02329         static void Destroy(StackMsgArgument* arg) { delete ((SimInfoIndArg*) arg); }
02330
02331         SimInfo m_sim_info;
02332
02333     };
02334
02335 // Inline definitions
02336 inline const SimInfoIndArg& SimInfoIndArg::Cast(const StackMsgArgument& arg) {
02337     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimInfoIndArg!\n");
02338     return ((SimInfoIndArg &) arg);
02339 }
02340
02341
02342
02343 /*  ======================================================================
02344     Class SimLockStatusIndArg
02345     ====================================================================== */
02346
02348 class SimLockStatusIndArg : public StackMsgArgument {
02349     friend class CommonStackMsgArgsDestroyTableNode;
02350     public:
02351         SimLockStatusIndArg();
02352
02353         static const SimLockStatusIndArg& Cast(const StackMsgArgument& arg);
02354         void SetLockStates(const SecLockStates& lock_states) { m_lock_states = lock_states; }
02355         const SecLockStates& GetLockStates() const { return m_lock_states; }
02356
02357         enum  {
02358             ID = 1482
02359             };
02360
02361     private:
02362
02363         static void Destroy(StackMsgArgument* arg) { delete ((SimLockStatusIndArg*) arg); }
02364
02365         SecLockStates m_lock_states;
02366
02367     };
02368
02369 // Inline definitions
02370 inline const SimLockStatusIndArg& SimLockStatusIndArg::Cast(const StackMsgArgument& arg) {
02371     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimLockStatusIndArg!\n");
02372     return ((SimLockStatusIndArg &) arg);
02373 }
02374
02375
02376
02377 /*  ======================================================================
02378     Class SimFullAccessIndArg
02379     ====================================================================== */
02380
02382 class SimFullAccessIndArg : public StackMsgArgument {
02383     friend class CommonStackMsgArgsDestroyTableNode;
02384     public:
02385         SimFullAccessIndArg();
02386
02387         static const SimFullAccessIndArg& Cast(const StackMsgArgument& arg);
02388
02389         enum  {
02390             ID = 1483
02391             };
02392
02393     private:
02394
02395         static void Destroy(StackMsgArgument* arg) { delete ((SimFullAccessIndArg*) arg); }
02396
02397     };
02398
02399 // Inline definitions
02400 inline const SimFullAccessIndArg& SimFullAccessIndArg::Cast(const StackMsgArgument& arg) {
02401     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimFullAccessIndArg!\n");
02402     return ((SimFullAccessIndArg &) arg);
02403 }
02404
02405
02406
02407 /*  ======================================================================
02408     Class FdnIndArg
02409     ====================================================================== */
02410
02412 class FdnIndArg : public StackMsgArgument {
02413     friend class CommonStackMsgArgsDestroyTableNode;
02414     public:
02415         FdnIndArg();
02416
02417         static const FdnIndArg& Cast(const StackMsgArgument& arg);
02418         void SetFdnState(const FdnState& fdn_state) { m_fdn_state = fdn_state; }
02419         const FdnState& GetFdnState() const { return m_fdn_state; }
02420         void SetSimUpdateStatus(const SimUpdateStatus& sim_update_status) { m_sim_update_status = sim_update_status; }
02421         const SimUpdateStatus& GetSimUpdateStatus() const { return m_sim_update_status; }
02422         void SetFileStatus(UINT8 file_status) { m_file_status = file_status; }
02423         UINT8 GetFileStatus() const { return m_file_status; }
02424
02425         enum  {
02426             ID = 1484
02427             };
02428
02429     private:
02430
02431         static void Destroy(StackMsgArgument* arg) { delete ((FdnIndArg*) arg); }
02432
02433         FdnState m_fdn_state;
02434         SimUpdateStatus m_sim_update_status;
02435         UINT8 m_file_status;
02436
02437     };
02438
02439 // Inline definitions
02440 inline const FdnIndArg& FdnIndArg::Cast(const StackMsgArgument& arg) {
02441     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to FdnIndArg!\n");
02442     return ((FdnIndArg &) arg);
02443 }
02444
02445
02446
02447 /*  ======================================================================
02448     Class BdnIndArg
02449     ====================================================================== */
02450
02452 class BdnIndArg : public StackMsgArgument {
02453     friend class CommonStackMsgArgsDestroyTableNode;
02454     public:
02455         BdnIndArg();
02456
02457         static const BdnIndArg& Cast(const StackMsgArgument& arg);
02458         void SetBdnState(const BdnState& bdn_state) { m_bdn_state = bdn_state; }
02459         const BdnState& GetBdnState() const { return m_bdn_state; }
02460         void SetSimUpdateStatus(const SimUpdateStatus& sim_update_status) { m_sim_update_status = sim_update_status; }
02461         const SimUpdateStatus& GetSimUpdateStatus() const { return m_sim_update_status; }
02462         void SetFileStatus(UINT8 file_status) { m_file_status = file_status; }
02463         UINT8 GetFileStatus() const { return m_file_status; }
02464
02465         enum  {
02466             ID = 1485
02467             };
02468
02469     private:
02470
02471         static void Destroy(StackMsgArgument* arg) { delete ((BdnIndArg*) arg); }
02472
02473         BdnState m_bdn_state;
02474         SimUpdateStatus m_sim_update_status;
02475         UINT8 m_file_status;
02476
02477     };
02478
02479 // Inline definitions
02480 inline const BdnIndArg& BdnIndArg::Cast(const StackMsgArgument& arg) {
02481     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BdnIndArg!\n");
02482     return ((BdnIndArg &) arg);
02483 }
02484
02485
02486
02487 /*  ======================================================================
02488     Class SimModifyLockIndArg
02489     ====================================================================== */
02490
02492 class SimModifyLockIndArg : public StackMsgArgument {
02493     friend class CommonStackMsgArgsDestroyTableNode;
02494     public:
02495         SimModifyLockIndArg();
02496
02497         static const SimModifyLockIndArg& Cast(const StackMsgArgument& arg);
02498         void SetLockStates(const SecLockStates& lock_states) { m_lock_states = lock_states; }
02499         const SecLockStates& GetLockStates() const { return m_lock_states; }
02500         void SetLockAction(const SecLockAction& lock_action) { m_lock_action = lock_action; }
02501         const SecLockAction& GetLockAction() const { return m_lock_action; }
02502
02503         enum  {
02504             ID = 1486
02505             };
02506
02507     private:
02508
02509         static void Destroy(StackMsgArgument* arg) { delete ((SimModifyLockIndArg*) arg); }
02510
02511         SecLockStates m_lock_states;
02512         SecLockAction m_lock_action;
02513
02514     };
02515
02516 // Inline definitions
02517 inline const SimModifyLockIndArg& SimModifyLockIndArg::Cast(const StackMsgArgument& arg) {
02518     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimModifyLockIndArg!\n");
02519     return ((SimModifyLockIndArg &) arg);
02520 }
02521
02522
02523
02524 /*  ======================================================================
02525     Class SimRefreshReqArg
02526     ====================================================================== */
02527
02529 class SimRefreshReqArg : public StackMsgArgument {
02530     friend class CommonStackMsgArgsDestroyTableNode;
02531     public:
02532         SimRefreshReqArg();
02533
02534         static const SimRefreshReqArg& Cast(const StackMsgArgument& arg);
02535
02536         enum  {
02537             ID = 2400
02538             };
02539
02540     private:
02541
02542         static void Destroy(StackMsgArgument* arg) { delete ((SimRefreshReqArg*) arg); }
02543
02544     };
02545
02546 // Inline definitions
02547 inline const SimRefreshReqArg& SimRefreshReqArg::Cast(const StackMsgArgument& arg) {
02548     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimRefreshReqArg!\n");
02549     return ((SimRefreshReqArg &) arg);
02550 }
02551
02552
02553
02554 /*  ======================================================================
02555     Class SimSstReadReqArg
02556     ====================================================================== */
02557
02559 class SimSstReadReqArg : public StackMsgArgument {
02560     friend class CommonStackMsgArgsDestroyTableNode;
02561     public:
02562         SimSstReadReqArg();
02563
02564         static const SimSstReadReqArg& Cast(const StackMsgArgument& arg);
02565
02566         enum  {
02567             ID = 2401
02568             };
02569
02570     private:
02571
02572         static void Destroy(StackMsgArgument* arg) { delete ((SimSstReadReqArg*) arg); }
02573
02574     };
02575
02576 // Inline definitions
02577 inline const SimSstReadReqArg& SimSstReadReqArg::Cast(const StackMsgArgument& arg) {
02578     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimSstReadReqArg!\n");
02579     return ((SimSstReadReqArg &) arg);
02580 }
02581
02582
02583
02584 /*  ======================================================================
02585     Class SimAcmReadReqArg
02586     ====================================================================== */
02587
02589 class SimAcmReadReqArg : public StackMsgArgument {
02590     friend class CommonStackMsgArgsDestroyTableNode;
02591     public:
02592         SimAcmReadReqArg(INT rec_no, const AcmSelector& selector);
02593         SimAcmReadReqArg();
02594
02595         static const SimAcmReadReqArg& Cast(const StackMsgArgument& arg);
02596         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
02597         INT GetRecNo() const { return m_rec_no; }
02598         void SetSelector(const AcmSelector& selector) { m_selector = selector; }
02599         const AcmSelector& GetSelector() const { return m_selector; }
02600
02601         enum  {
02602             ID = 2402
02603             };
02604
02605     private:
02606
02607         static void Destroy(StackMsgArgument* arg) { delete ((SimAcmReadReqArg*) arg); }
02608
02609         INT m_rec_no;
02610         AcmSelector m_selector;
02611
02612     };
02613
02614 // Inline definitions
02615 inline const SimAcmReadReqArg& SimAcmReadReqArg::Cast(const StackMsgArgument& arg) {
02616     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimAcmReadReqArg!\n");
02617     return ((SimAcmReadReqArg &) arg);
02618 }
02619
02620
02621
02622 /*  ======================================================================
02623     Class SimAcmUpdReqArg
02624     ====================================================================== */
02625
02627 class SimAcmUpdReqArg : public StackMsgArgument {
02628     friend class CommonStackMsgArgsDestroyTableNode;
02629     public:
02630         SimAcmUpdReqArg(INT rec_no, const Acm& acm, const AcmSelector& selector);
02631         SimAcmUpdReqArg();
02632
02633         static const SimAcmUpdReqArg& Cast(const StackMsgArgument& arg);
02634         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
02635         INT GetRecNo() const { return m_rec_no; }
02636         void SetAcm(const Acm& acm) { m_acm = acm; }
02637         const Acm& GetAcm() const { return m_acm; }
02638         void SetSelector(const AcmSelector& selector) { m_selector = selector; }
02639         const AcmSelector& GetSelector() const { return m_selector; }
02640
02641         enum  {
02642             ID = 2403
02643             };
02644
02645     private:
02646
02647         static void Destroy(StackMsgArgument* arg) { delete ((SimAcmUpdReqArg*) arg); }
02648
02649         INT m_rec_no;
02650         Acm m_acm;
02651         AcmSelector m_selector;
02652
02653     };
02654
02655 // Inline definitions
02656 inline const SimAcmUpdReqArg& SimAcmUpdReqArg::Cast(const StackMsgArgument& arg) {
02657     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimAcmUpdReqArg!\n");
02658     return ((SimAcmUpdReqArg &) arg);
02659 }
02660
02661
02662
02663 /*  ======================================================================
02664     Class SimAcmMaxReadReqArg
02665     ====================================================================== */
02666
02668 class SimAcmMaxReadReqArg : public StackMsgArgument {
02669     friend class CommonStackMsgArgsDestroyTableNode;
02670     public:
02671         SimAcmMaxReadReqArg();
02672
02673         static const SimAcmMaxReadReqArg& Cast(const StackMsgArgument& arg);
02674
02675         enum  {
02676             ID = 2404
02677             };
02678
02679     private:
02680
02681         static void Destroy(StackMsgArgument* arg) { delete ((SimAcmMaxReadReqArg*) arg); }
02682
02683     };
02684
02685 // Inline definitions
02686 inline const SimAcmMaxReadReqArg& SimAcmMaxReadReqArg::Cast(const StackMsgArgument& arg) {
02687     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimAcmMaxReadReqArg!\n");
02688     return ((SimAcmMaxReadReqArg &) arg);
02689 }
02690
02691
02692
02693 /*  ======================================================================
02694     Class SimAcmMaxUpdReqArg
02695     ====================================================================== */
02696
02698 class SimAcmMaxUpdReqArg : public StackMsgArgument {
02699     friend class CommonStackMsgArgsDestroyTableNode;
02700     public:
02701         SimAcmMaxUpdReqArg(const Acm& acm);
02702         SimAcmMaxUpdReqArg();
02703
02704         static const SimAcmMaxUpdReqArg& Cast(const StackMsgArgument& arg);
02705         void SetAcm(const Acm& acm) { m_acm = acm; }
02706         const Acm& GetAcm() const { return m_acm; }
02707
02708         enum  {
02709             ID = 2405
02710             };
02711
02712     private:
02713
02714         static void Destroy(StackMsgArgument* arg) { delete ((SimAcmMaxUpdReqArg*) arg); }
02715
02716         Acm m_acm;
02717
02718     };
02719
02720 // Inline definitions
02721 inline const SimAcmMaxUpdReqArg& SimAcmMaxUpdReqArg::Cast(const StackMsgArgument& arg) {
02722     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimAcmMaxUpdReqArg!\n");
02723     return ((SimAcmMaxUpdReqArg &) arg);
02724 }
02725
02726
02727
02728 /*  ======================================================================
02729     Class SimPuctReadReqArg
02730     ====================================================================== */
02731
02733 class SimPuctReadReqArg : public StackMsgArgument {
02734     friend class CommonStackMsgArgsDestroyTableNode;
02735     public:
02736         SimPuctReadReqArg();
02737
02738         static const SimPuctReadReqArg& Cast(const StackMsgArgument& arg);
02739
02740         enum  {
02741             ID = 2406
02742             };
02743
02744     private:
02745
02746         static void Destroy(StackMsgArgument* arg) { delete ((SimPuctReadReqArg*) arg); }
02747
02748     };
02749
02750 // Inline definitions
02751 inline const SimPuctReadReqArg& SimPuctReadReqArg::Cast(const StackMsgArgument& arg) {
02752     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimPuctReadReqArg!\n");
02753     return ((SimPuctReadReqArg &) arg);
02754 }
02755
02756
02757
02758 /*  ======================================================================
02759     Class SimPuctUpdReqArg
02760     ====================================================================== */
02761
02763 class SimPuctUpdReqArg : public StackMsgArgument {
02764     friend class CommonStackMsgArgsDestroyTableNode;
02765     public:
02766         SimPuctUpdReqArg(const Puct& puct);
02767         SimPuctUpdReqArg();
02768
02769         static const SimPuctUpdReqArg& Cast(const StackMsgArgument& arg);
02770         void SetPuct(const Puct& puct) { m_puct = puct; }
02771         const Puct& GetPuct() const { return m_puct; }
02772
02773         enum  {
02774             ID = 2407
02775             };
02776
02777     private:
02778
02779         static void Destroy(StackMsgArgument* arg) { delete ((SimPuctUpdReqArg*) arg); }
02780
02781         Puct m_puct;
02782
02783     };
02784
02785 // Inline definitions
02786 inline const SimPuctUpdReqArg& SimPuctUpdReqArg::Cast(const StackMsgArgument& arg) {
02787     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimPuctUpdReqArg!\n");
02788     return ((SimPuctUpdReqArg &) arg);
02789 }
02790
02791
02792
02793 /*  ======================================================================
02794     Class SimGenericReqArg
02795     ====================================================================== */
02796
02798 class SimGenericReqArg : public StackMsgArgument {
02799     friend class CommonStackMsgArgsDestroyTableNode;
02800     public:
02801         SimGenericReqArg(const SimFileId& df_id, BOOLEAN df_id_flag, const SimFileId& ef_id, BOOLEAN ef_id_flag, SimApduData* apdu_data_ptr);
02802         SimGenericReqArg();
02803
02804         static const SimGenericReqArg& Cast(const StackMsgArgument& arg);
02805         void SetDfId(const SimFileId& df_id) { m_df_id = df_id; }
02806         const SimFileId& GetDfId() const { return m_df_id; }
02807         void SetDfIdFlag(BOOLEAN df_id_flag) { m_df_id_flag = df_id_flag; }
02808         BOOLEAN IsDfIdFlag() const { return m_df_id_flag; }
02809         void SetEfId(const SimFileId& ef_id) { m_ef_id = ef_id; }
02810         const SimFileId& GetEfId() const { return m_ef_id; }
02811         void SetEfIdFlag(BOOLEAN ef_id_flag) { m_ef_id_flag = ef_id_flag; }
02812         BOOLEAN IsEfIdFlag() const { return m_ef_id_flag; }
02813         void SetApduDataPtr(SimApduData* apdu_data_ptr) { m_apdu_data_ptr = apdu_data_ptr; }
02814         SimApduData* GetApduDataPtr() const { return m_apdu_data_ptr; }
02815
02816         enum  {
02817             ID = 2408
02818             };
02819
02820     private:
02821
02822         static void Destroy(StackMsgArgument* arg) { delete ((SimGenericReqArg*) arg); }
02823
02824         SimFileId m_df_id;
02825         BOOLEAN m_df_id_flag;
02826         SimFileId m_ef_id;
02827         BOOLEAN m_ef_id_flag;
02828         SimApduData* m_apdu_data_ptr;
02829
02830     };
02831
02832 // Inline definitions
02833 inline const SimGenericReqArg& SimGenericReqArg::Cast(const StackMsgArgument& arg) {
02834     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimGenericReqArg!\n");
02835     return ((SimGenericReqArg &) arg);
02836 }
02837
02838
02839
02840 /*  ======================================================================
02841     Class SimLangReadReqArg
02842     ====================================================================== */
02843
02845 class SimLangReadReqArg : public StackMsgArgument {
02846     friend class CommonStackMsgArgsDestroyTableNode;
02847     public:
02848         SimLangReadReqArg(INT start_pos);
02849         SimLangReadReqArg();
02850
02851         static const SimLangReadReqArg& Cast(const StackMsgArgument& arg);
02852         void SetStartPos(INT start_pos) { m_start_pos = start_pos; }
02853         INT GetStartPos() const { return m_start_pos; }
02854
02855         enum  {
02856             ID = 2409
02857             };
02858
02859     private:
02860
02861         static void Destroy(StackMsgArgument* arg) { delete ((SimLangReadReqArg*) arg); }
02862
02863         INT m_start_pos;
02864
02865     };
02866
02867 // Inline definitions
02868 inline const SimLangReadReqArg& SimLangReadReqArg::Cast(const StackMsgArgument& arg) {
02869     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimLangReadReqArg!\n");
02870     return ((SimLangReadReqArg &) arg);
02871 }
02872
02873
02874
02875 /*  ======================================================================
02876     Class SimLangUpdReqArg
02877     ====================================================================== */
02878
02880 class SimLangUpdReqArg : public StackMsgArgument {
02881     friend class CommonStackMsgArgsDestroyTableNode;
02882     public:
02883         SimLangUpdReqArg(INT start_pos, const LanguageArray& language_array);
02884         SimLangUpdReqArg();
02885
02886         static const SimLangUpdReqArg& Cast(const StackMsgArgument& arg);
02887         void SetStartPos(INT start_pos) { m_start_pos = start_pos; }
02888         INT GetStartPos() const { return m_start_pos; }
02889         void SetLanguageArray(const LanguageArray& language_array) { m_language_array = language_array; }
02890         const LanguageArray& GetLanguageArray() const { return m_language_array; }
02891
02892         enum  {
02893             ID = 2410
02894             };
02895
02896     private:
02897
02898         static void Destroy(StackMsgArgument* arg) { delete ((SimLangUpdReqArg*) arg); }
02899
02900         INT m_start_pos;
02901         LanguageArray m_language_array;
02902
02903     };
02904
02905 // Inline definitions
02906 inline const SimLangUpdReqArg& SimLangUpdReqArg::Cast(const StackMsgArgument& arg) {
02907     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimLangUpdReqArg!\n");
02908     return ((SimLangUpdReqArg &) arg);
02909 }
02910
02911
02912
02913 /*  ======================================================================
02914     Class SimExtLangReadReqArg
02915     ====================================================================== */
02916
02918 class SimExtLangReadReqArg : public StackMsgArgument {
02919     friend class CommonStackMsgArgsDestroyTableNode;
02920     public:
02921         SimExtLangReadReqArg(INT start_pos);
02922         SimExtLangReadReqArg();
02923
02924         static const SimExtLangReadReqArg& Cast(const StackMsgArgument& arg);
02925         void SetStartPos(INT start_pos) { m_start_pos = start_pos; }
02926         INT GetStartPos() const { return m_start_pos; }
02927
02928         enum  {
02929             ID = 2411
02930             };
02931
02932     private:
02933
02934         static void Destroy(StackMsgArgument* arg) { delete ((SimExtLangReadReqArg*) arg); }
02935
02936         INT m_start_pos;
02937
02938     };
02939
02940 // Inline definitions
02941 inline const SimExtLangReadReqArg& SimExtLangReadReqArg::Cast(const StackMsgArgument& arg) {
02942     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimExtLangReadReqArg!\n");
02943     return ((SimExtLangReadReqArg &) arg);
02944 }
02945
02946
02947
02948 /*  ======================================================================
02949     Class SimExtLangUpdReqArg
02950     ====================================================================== */
02951
02953 class SimExtLangUpdReqArg : public StackMsgArgument {
02954     friend class CommonStackMsgArgsDestroyTableNode;
02955     public:
02956         SimExtLangUpdReqArg(INT start_pos, const ExtLanguageArray& language_array);
02957         SimExtLangUpdReqArg();
02958
02959         static const SimExtLangUpdReqArg& Cast(const StackMsgArgument& arg);
02960         void SetStartPos(INT start_pos) { m_start_pos = start_pos; }
02961         INT GetStartPos() const { return m_start_pos; }
02962         void SetLanguageArray(const ExtLanguageArray& language_array) { m_language_array = language_array; }
02963         const ExtLanguageArray& GetLanguageArray() const { return m_language_array; }
02964
02965         enum  {
02966             ID = 2412
02967             };
02968
02969     private:
02970
02971         static void Destroy(StackMsgArgument* arg) { delete ((SimExtLangUpdReqArg*) arg); }
02972
02973         INT m_start_pos;
02974         ExtLanguageArray m_language_array;
02975
02976     };
02977
02978 // Inline definitions
02979 inline const SimExtLangUpdReqArg& SimExtLangUpdReqArg::Cast(const StackMsgArgument& arg) {
02980     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimExtLangUpdReqArg!\n");
02981     return ((SimExtLangUpdReqArg &) arg);
02982 }
02983
02984
02985
02986 /*  ======================================================================
02987     Class SimSpnReadReqArg
02988     ====================================================================== */
02989
02991 class SimSpnReadReqArg : public StackMsgArgument {
02992     friend class CommonStackMsgArgsDestroyTableNode;
02993     public:
02994         SimSpnReadReqArg();
02995
02996         static const SimSpnReadReqArg& Cast(const StackMsgArgument& arg);
02997
02998         enum  {
02999             ID = 2414
03000             };
03001
03002     private:
03003
03004         static void Destroy(StackMsgArgument* arg) { delete ((SimSpnReadReqArg*) arg); }
03005
03006     };
03007
03008 // Inline definitions
03009 inline const SimSpnReadReqArg& SimSpnReadReqArg::Cast(const StackMsgArgument& arg) {
03010     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimSpnReadReqArg!\n");
03011     return ((SimSpnReadReqArg &) arg);
03012 }
03013
03014
03015
03016 /*  ======================================================================
03017     Class SimFileInfoReqArg
03018     ====================================================================== */
03019
03021 class SimFileInfoReqArg : public StackMsgArgument {
03022     friend class CommonStackMsgArgsDestroyTableNode;
03023     public:
03024         SimFileInfoReqArg(INT file_id);
03025         SimFileInfoReqArg();
03026
03027         static const SimFileInfoReqArg& Cast(const StackMsgArgument& arg);
03028         void SetFileId(INT file_id) { m_file_id = file_id; }
03029         INT GetFileId() const { return m_file_id; }
03030
03031         enum  {
03032             ID = 2415
03033             };
03034
03035     private:
03036
03037         static void Destroy(StackMsgArgument* arg) { delete ((SimFileInfoReqArg*) arg); }
03038
03039         INT m_file_id;
03040
03041     };
03042
03043 // Inline definitions
03044 inline const SimFileInfoReqArg& SimFileInfoReqArg::Cast(const StackMsgArgument& arg) {
03045     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimFileInfoReqArg!\n");
03046     return ((SimFileInfoReqArg &) arg);
03047 }
03048
03049
03050
03051 /*  ======================================================================
03052     Class CphsIstReadReqArg
03053     ====================================================================== */
03054
03056 class CphsIstReadReqArg : public StackMsgArgument {
03057     friend class CommonStackMsgArgsDestroyTableNode;
03058     public:
03059         CphsIstReadReqArg();
03060
03061         static const CphsIstReadReqArg& Cast(const StackMsgArgument& arg);
03062
03063         enum  {
03064             ID = 2416
03065             };
03066
03067     private:
03068
03069         static void Destroy(StackMsgArgument* arg) { delete ((CphsIstReadReqArg*) arg); }
03070
03071     };
03072
03073 // Inline definitions
03074 inline const CphsIstReadReqArg& CphsIstReadReqArg::Cast(const StackMsgArgument& arg) {
03075     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsIstReadReqArg!\n");
03076     return ((CphsIstReadReqArg &) arg);
03077 }
03078
03079
03080
03081 /*  ======================================================================
03082     Class CphsVmwfReadReqArg
03083     ====================================================================== */
03084
03086 class CphsVmwfReadReqArg : public StackMsgArgument {
03087     friend class CommonStackMsgArgsDestroyTableNode;
03088     public:
03089         CphsVmwfReadReqArg();
03090
03091         static const CphsVmwfReadReqArg& Cast(const StackMsgArgument& arg);
03092
03093         enum  {
03094             ID = 2417
03095             };
03096
03097     private:
03098
03099         static void Destroy(StackMsgArgument* arg) { delete ((CphsVmwfReadReqArg*) arg); }
03100
03101     };
03102
03103 // Inline definitions
03104 inline const CphsVmwfReadReqArg& CphsVmwfReadReqArg::Cast(const StackMsgArgument& arg) {
03105     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsVmwfReadReqArg!\n");
03106     return ((CphsVmwfReadReqArg &) arg);
03107 }
03108
03109
03110
03111 /*  ======================================================================
03112     Class CphsCfufReadReqArg
03113     ====================================================================== */
03114
03116 class CphsCfufReadReqArg : public StackMsgArgument {
03117     friend class CommonStackMsgArgsDestroyTableNode;
03118     public:
03119         CphsCfufReadReqArg();
03120
03121         static const CphsCfufReadReqArg& Cast(const StackMsgArgument& arg);
03122
03123         enum  {
03124             ID = 2418
03125             };
03126
03127     private:
03128
03129         static void Destroy(StackMsgArgument* arg) { delete ((CphsCfufReadReqArg*) arg); }
03130
03131     };
03132
03133 // Inline definitions
03134 inline const CphsCfufReadReqArg& CphsCfufReadReqArg::Cast(const StackMsgArgument& arg) {
03135     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsCfufReadReqArg!\n");
03136     return ((CphsCfufReadReqArg &) arg);
03137 }
03138
03139
03140
03141 /*  ======================================================================
03142     Class CphsOnmReadReqArg
03143     ====================================================================== */
03144
03146 class CphsOnmReadReqArg : public StackMsgArgument {
03147     friend class CommonStackMsgArgsDestroyTableNode;
03148     public:
03149         CphsOnmReadReqArg();
03150
03151         static const CphsOnmReadReqArg& Cast(const StackMsgArgument& arg);
03152
03153         enum  {
03154             ID = 2419
03155             };
03156
03157     private:
03158
03159         static void Destroy(StackMsgArgument* arg) { delete ((CphsOnmReadReqArg*) arg); }
03160
03161     };
03162
03163 // Inline definitions
03164 inline const CphsOnmReadReqArg& CphsOnmReadReqArg::Cast(const StackMsgArgument& arg) {
03165     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsOnmReadReqArg!\n");
03166     return ((CphsOnmReadReqArg &) arg);
03167 }
03168
03169
03170
03171 /*  ======================================================================
03172     Class CphsOnsReadReqArg
03173     ====================================================================== */
03174
03176 class CphsOnsReadReqArg : public StackMsgArgument {
03177     friend class CommonStackMsgArgsDestroyTableNode;
03178     public:
03179         CphsOnsReadReqArg();
03180
03181         static const CphsOnsReadReqArg& Cast(const StackMsgArgument& arg);
03182
03183         enum  {
03184             ID = 2420
03185             };
03186
03187     private:
03188
03189         static void Destroy(StackMsgArgument* arg) { delete ((CphsOnsReadReqArg*) arg); }
03190
03191     };
03192
03193 // Inline definitions
03194 inline const CphsOnsReadReqArg& CphsOnsReadReqArg::Cast(const StackMsgArgument& arg) {
03195     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsOnsReadReqArg!\n");
03196     return ((CphsOnsReadReqArg &) arg);
03197 }
03198
03199
03200
03201 /*  ======================================================================
03202     Class CphsVmwfUpdReqArg
03203     ====================================================================== */
03204
03206 class CphsVmwfUpdReqArg : public StackMsgArgument {
03207     friend class CommonStackMsgArgsDestroyTableNode;
03208     public:
03209         CphsVmwfUpdReqArg(const CphsVmwfArray& cphs_vmwf_array);
03210         CphsVmwfUpdReqArg();
03211
03212         static const CphsVmwfUpdReqArg& Cast(const StackMsgArgument& arg);
03213         void SetCphsVmwfArray(const CphsVmwfArray& cphs_vmwf_array) { m_cphs_vmwf_array = cphs_vmwf_array; }
03214         const CphsVmwfArray& GetCphsVmwfArray() const { return m_cphs_vmwf_array; }
03215
03216         enum  {
03217             ID = 2421
03218             };
03219
03220     private:
03221
03222         static void Destroy(StackMsgArgument* arg) { delete ((CphsVmwfUpdReqArg*) arg); }
03223
03224         CphsVmwfArray m_cphs_vmwf_array;
03225
03226     };
03227
03228 // Inline definitions
03229 inline const CphsVmwfUpdReqArg& CphsVmwfUpdReqArg::Cast(const StackMsgArgument& arg) {
03230     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsVmwfUpdReqArg!\n");
03231     return ((CphsVmwfUpdReqArg &) arg);
03232 }
03233
03234
03235
03236 /*  ======================================================================
03237     Class CphsCfufUpdReqArg
03238     ====================================================================== */
03239
03241 class CphsCfufUpdReqArg : public StackMsgArgument {
03242     friend class CommonStackMsgArgsDestroyTableNode;
03243     public:
03244         CphsCfufUpdReqArg(const CphsCfufArray& cphs_cfuf_array);
03245         CphsCfufUpdReqArg();
03246
03247         static const CphsCfufUpdReqArg& Cast(const StackMsgArgument& arg);
03248         void SetCphsCfufArray(const CphsCfufArray& cphs_cfuf_array) { m_cphs_cfuf_array = cphs_cfuf_array; }
03249         const CphsCfufArray& GetCphsCfufArray() const { return m_cphs_cfuf_array; }
03250
03251         enum  {
03252             ID = 2422
03253             };
03254
03255     private:
03256
03257         static void Destroy(StackMsgArgument* arg) { delete ((CphsCfufUpdReqArg*) arg); }
03258
03259         CphsCfufArray m_cphs_cfuf_array;
03260
03261     };
03262
03263 // Inline definitions
03264 inline const CphsCfufUpdReqArg& CphsCfufUpdReqArg::Cast(const StackMsgArgument& arg) {
03265     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsCfufUpdReqArg!\n");
03266     return ((CphsCfufUpdReqArg &) arg);
03267 }
03268
03269
03270
03271 /*  ======================================================================
03272     Class CphsCspReadReqArg
03273     ====================================================================== */
03274
03276 class CphsCspReadReqArg : public StackMsgArgument {
03277     friend class CommonStackMsgArgsDestroyTableNode;
03278     public:
03279         CphsCspReadReqArg(const LineSelector& line_selector, INT no_of_groups, const CphsCspArray& cphs_csp_array);
03280         CphsCspReadReqArg();
03281
03282         static const CphsCspReadReqArg& Cast(const StackMsgArgument& arg);
03283         void SetLineSelector(const LineSelector& line_selector) { m_line_selector = line_selector; }
03284         const LineSelector& GetLineSelector() const { return m_line_selector; }
03285         void SetNoOfGroups(INT no_of_groups) { m_no_of_groups = no_of_groups; }
03286         INT GetNoOfGroups() const { return m_no_of_groups; }
03287         void SetCphsCspArray(const CphsCspArray& cphs_csp_array) { m_cphs_csp_array = cphs_csp_array; }
03288         const CphsCspArray& GetCphsCspArray() const { return m_cphs_csp_array; }
03289
03290         enum  {
03291             ID = 2423
03292             };
03293
03294     private:
03295
03296         static void Destroy(StackMsgArgument* arg) { delete ((CphsCspReadReqArg*) arg); }
03297
03298         LineSelector m_line_selector;
03299         INT m_no_of_groups;
03300         CphsCspArray m_cphs_csp_array;
03301
03302     };
03303
03304 // Inline definitions
03305 inline const CphsCspReadReqArg& CphsCspReadReqArg::Cast(const StackMsgArgument& arg) {
03306     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsCspReadReqArg!\n");
03307     return ((CphsCspReadReqArg &) arg);
03308 }
03309
03310
03311
03312 /*  ======================================================================
03313     Class CphsCspUpdReqArg
03314     ====================================================================== */
03315
03317 class CphsCspUpdReqArg : public StackMsgArgument {
03318     friend class CommonStackMsgArgsDestroyTableNode;
03319     public:
03320         CphsCspUpdReqArg(const LineSelector& line_selector, INT no_of_groups, const CphsCspArray& cphs_csp_array);
03321         CphsCspUpdReqArg();
03322
03323         static const CphsCspUpdReqArg& Cast(const StackMsgArgument& arg);
03324         void SetLineSelector(const LineSelector& line_selector) { m_line_selector = line_selector; }
03325         const LineSelector& GetLineSelector() const { return m_line_selector; }
03326         void SetNoOfGroups(INT no_of_groups) { m_no_of_groups = no_of_groups; }
03327         INT GetNoOfGroups() const { return m_no_of_groups; }
03328         void SetCphsCspArray(const CphsCspArray& cphs_csp_array) { m_cphs_csp_array = cphs_csp_array; }
03329         const CphsCspArray& GetCphsCspArray() const { return m_cphs_csp_array; }
03330
03331         enum  {
03332             ID = 2424
03333             };
03334
03335     private:
03336
03337         static void Destroy(StackMsgArgument* arg) { delete ((CphsCspUpdReqArg*) arg); }
03338
03339         LineSelector m_line_selector;
03340         INT m_no_of_groups;
03341         CphsCspArray m_cphs_csp_array;
03342
03343     };
03344
03345 // Inline definitions
03346 inline const CphsCspUpdReqArg& CphsCspUpdReqArg::Cast(const StackMsgArgument& arg) {
03347     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CphsCspUpdReqArg!\n");
03348     return ((CphsCspUpdReqArg &) arg);
03349 }
03350
03351
03352
03353 /*  ======================================================================
03354     Class SimCbmiReadReqArg
03355     ====================================================================== */
03356
03358 class SimCbmiReadReqArg : public StackMsgArgument {
03359     friend class CommonStackMsgArgsDestroyTableNode;
03360     public:
03361         SimCbmiReadReqArg(INT rec_no);
03362         SimCbmiReadReqArg();
03363
03364         static const SimCbmiReadReqArg& Cast(const StackMsgArgument& arg);
03365         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
03366         INT GetRecNo() const { return m_rec_no; }
03367
03368         enum  {
03369             ID = 2426
03370             };
03371
03372     private:
03373
03374         static void Destroy(StackMsgArgument* arg) { delete ((SimCbmiReadReqArg*) arg); }
03375
03376         INT m_rec_no;
03377
03378     };
03379
03380 // Inline definitions
03381 inline const SimCbmiReadReqArg& SimCbmiReadReqArg::Cast(const StackMsgArgument& arg) {
03382     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCbmiReadReqArg!\n");
03383     return ((SimCbmiReadReqArg &) arg);
03384 }
03385
03386
03387
03388 /*  ======================================================================
03389     Class SimCbmirReadReqArg
03390     ====================================================================== */
03391
03393 class SimCbmirReadReqArg : public StackMsgArgument {
03394     friend class CommonStackMsgArgsDestroyTableNode;
03395     public:
03396         SimCbmirReadReqArg(INT rec_no);
03397         SimCbmirReadReqArg();
03398
03399         static const SimCbmirReadReqArg& Cast(const StackMsgArgument& arg);
03400         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
03401         INT GetRecNo() const { return m_rec_no; }
03402
03403         enum  {
03404             ID = 2427
03405             };
03406
03407     private:
03408
03409         static void Destroy(StackMsgArgument* arg) { delete ((SimCbmirReadReqArg*) arg); }
03410
03411         INT m_rec_no;
03412
03413     };
03414
03415 // Inline definitions
03416 inline const SimCbmirReadReqArg& SimCbmirReadReqArg::Cast(const StackMsgArgument& arg) {
03417     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCbmirReadReqArg!\n");
03418     return ((SimCbmirReadReqArg &) arg);
03419 }
03420
03421
03422
03423 /*  ======================================================================
03424     Class SimCbmiUpdReqArg
03425     ====================================================================== */
03426
03428 class SimCbmiUpdReqArg : public StackMsgArgument {
03429     friend class CommonStackMsgArgsDestroyTableNode;
03430     public:
03431         SimCbmiUpdReqArg(INT rec_no, const CbmiData& cbmi_data);
03432         SimCbmiUpdReqArg();
03433
03434         static const SimCbmiUpdReqArg& Cast(const StackMsgArgument& arg);
03435         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
03436         INT GetRecNo() const { return m_rec_no; }
03437         void SetCbmiData(const CbmiData& cbmi_data) { m_cbmi_data = cbmi_data; }
03438         const CbmiData& GetCbmiData() const { return m_cbmi_data; }
03439
03440         enum  {
03441             ID = 2428
03442             };
03443
03444     private:
03445
03446         static void Destroy(StackMsgArgument* arg) { delete ((SimCbmiUpdReqArg*) arg); }
03447
03448         INT m_rec_no;
03449         CbmiData m_cbmi_data;
03450
03451     };
03452
03453 // Inline definitions
03454 inline const SimCbmiUpdReqArg& SimCbmiUpdReqArg::Cast(const StackMsgArgument& arg) {
03455     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCbmiUpdReqArg!\n");
03456     return ((SimCbmiUpdReqArg &) arg);
03457 }
03458
03459
03460
03461 /*  ======================================================================
03462     Class SimCbmirUpdReqArg
03463     ====================================================================== */
03464
03466 class SimCbmirUpdReqArg : public StackMsgArgument {
03467     friend class CommonStackMsgArgsDestroyTableNode;
03468     public:
03469         SimCbmirUpdReqArg(INT rec_no, const CbmiRange& cbmi_range);
03470         SimCbmirUpdReqArg();
03471
03472         static const SimCbmirUpdReqArg& Cast(const StackMsgArgument& arg);
03473         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
03474         INT GetRecNo() const { return m_rec_no; }
03475         void SetCbmiRange(const CbmiRange& cbmi_range) { m_cbmi_range = cbmi_range; }
03476         const CbmiRange& GetCbmiRange() const { return m_cbmi_range; }
03477
03478         enum  {
03479             ID = 2429
03480             };
03481
03482     private:
03483
03484         static void Destroy(StackMsgArgument* arg) { delete ((SimCbmirUpdReqArg*) arg); }
03485
03486         INT m_rec_no;
03487         CbmiRange m_cbmi_range;
03488
03489     };
03490
03491 // Inline definitions
03492 inline const SimCbmirUpdReqArg& SimCbmirUpdReqArg::Cast(const StackMsgArgument& arg) {
03493     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCbmirUpdReqArg!\n");
03494     return ((SimCbmirUpdReqArg &) arg);
03495 }
03496
03497
03498
03499 /*  ======================================================================
03500     Class SimCcpReadReqArg
03501     ====================================================================== */
03502
03504 class SimCcpReadReqArg : public StackMsgArgument {
03505     friend class CommonStackMsgArgsDestroyTableNode;
03506     public:
03507         SimCcpReadReqArg(INT rec_no);
03508         SimCcpReadReqArg();
03509
03510         static const SimCcpReadReqArg& Cast(const StackMsgArgument& arg);
03511         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
03512         INT GetRecNo() const { return m_rec_no; }
03513
03514         enum  {
03515             ID = 2430
03516             };
03517
03518     private:
03519
03520         static void Destroy(StackMsgArgument* arg) { delete ((SimCcpReadReqArg*) arg); }
03521
03522         INT m_rec_no;
03523
03524     };
03525
03526 // Inline definitions
03527 inline const SimCcpReadReqArg& SimCcpReadReqArg::Cast(const StackMsgArgument& arg) {
03528     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCcpReadReqArg!\n");
03529     return ((SimCcpReadReqArg &) arg);
03530 }
03531
03532
03533
03534 /*  ======================================================================
03535     Class SimCcpUpdReqArg
03536     ====================================================================== */
03537
03539 class SimCcpUpdReqArg : public StackMsgArgument {
03540     friend class CommonStackMsgArgsDestroyTableNode;
03541     public:
03542         SimCcpUpdReqArg(INT rec_no, const CcpData& ccp_data);
03543         SimCcpUpdReqArg();
03544
03545         static const SimCcpUpdReqArg& Cast(const StackMsgArgument& arg);
03546         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
03547         INT GetRecNo() const { return m_rec_no; }
03548         void SetCcpData(const CcpData& ccp_data) { m_ccp_data = ccp_data; }
03549         const CcpData& GetCcpData() const { return m_ccp_data; }
03550
03551         enum  {
03552             ID = 2431
03553             };
03554
03555     private:
03556
03557         static void Destroy(StackMsgArgument* arg) { delete ((SimCcpUpdReqArg*) arg); }
03558
03559         INT m_rec_no;
03560         CcpData m_ccp_data;
03561
03562     };
03563
03564 // Inline definitions
03565 inline const SimCcpUpdReqArg& SimCcpUpdReqArg::Cast(const StackMsgArgument& arg) {
03566     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCcpUpdReqArg!\n");
03567     return ((SimCcpUpdReqArg &) arg);
03568 }
03569
03570
03571
03572 /*  ======================================================================
03573     Class SimSmsrReadReqArg
03574     ====================================================================== */
03575
03577 class SimSmsrReadReqArg : public StackMsgArgument {
03578     friend class CommonStackMsgArgsDestroyTableNode;
03579     public:
03580         SimSmsrReadReqArg(INT rec_no);
03581         SimSmsrReadReqArg();
03582
03583         static const SimSmsrReadReqArg& Cast(const StackMsgArgument& arg);
03584         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
03585         INT GetRecNo() const { return m_rec_no; }
03586
03587         enum  {
03588             ID = 2432
03589             };
03590
03591     private:
03592
03593         static void Destroy(StackMsgArgument* arg) { delete ((SimSmsrReadReqArg*) arg); }
03594
03595         INT m_rec_no;
03596
03597     };
03598
03599 // Inline definitions
03600 inline const SimSmsrReadReqArg& SimSmsrReadReqArg::Cast(const StackMsgArgument& arg) {
03601     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimSmsrReadReqArg!\n");
03602     return ((SimSmsrReadReqArg &) arg);
03603 }
03604
03605
03606
03607 /*  ======================================================================
03608     Class SimSmsrUpdReqArg
03609     ====================================================================== */
03610
03612 class SimSmsrUpdReqArg : public StackMsgArgument {
03613     friend class CommonStackMsgArgsDestroyTableNode;
03614     public:
03615         SimSmsrUpdReqArg(INT rec_no, UINT8 link, const SmsrData& smsr_data);
03616         SimSmsrUpdReqArg();
03617
03618         static const SimSmsrUpdReqArg& Cast(const StackMsgArgument& arg);
03619         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
03620         INT GetRecNo() const { return m_rec_no; }
03621         void SetLink(UINT8 link) { m_link = link; }
03622         UINT8 GetLink() const { return m_link; }
03623         void SetSmsrData(const SmsrData& smsr_data) { m_smsr_data = smsr_data; }
03624         const SmsrData& GetSmsrData() const { return m_smsr_data; }
03625
03626         enum  {
03627             ID = 2433
03628             };
03629
03630     private:
03631
03632         static void Destroy(StackMsgArgument* arg) { delete ((SimSmsrUpdReqArg*) arg); }
03633
03634         INT m_rec_no;
03635         UINT8 m_link;
03636         SmsrData m_smsr_data;
03637
03638     };
03639
03640 // Inline definitions
03641 inline const SimSmsrUpdReqArg& SimSmsrUpdReqArg::Cast(const StackMsgArgument& arg) {
03642     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimSmsrUpdReqArg!\n");
03643     return ((SimSmsrUpdReqArg &) arg);
03644 }
03645
03646
03647
03648 /*  ======================================================================
03649     Class UsimUstReadReqArg
03650     ====================================================================== */
03651
03653 class UsimUstReadReqArg : public StackMsgArgument {
03654     friend class CommonStackMsgArgsDestroyTableNode;
03655     public:
03656         UsimUstReadReqArg();
03657
03658         static const UsimUstReadReqArg& Cast(const StackMsgArgument& arg);
03659
03660         enum  {
03661             ID = 2434
03662             };
03663
03664     private:
03665
03666         static void Destroy(StackMsgArgument* arg) { delete ((UsimUstReadReqArg*) arg); }
03667
03668     };
03669
03670 // Inline definitions
03671 inline const UsimUstReadReqArg& UsimUstReadReqArg::Cast(const StackMsgArgument& arg) {
03672     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimUstReadReqArg!\n");
03673     return ((UsimUstReadReqArg &) arg);
03674 }
03675
03676
03677
03678 /*  ======================================================================
03679     Class UsimPlmnReadReqArg
03680     ====================================================================== */
03681
03683 class UsimPlmnReadReqArg : public StackMsgArgument {
03684     friend class CommonStackMsgArgsDestroyTableNode;
03685     public:
03686         UsimPlmnReadReqArg(const UsimReadType& read_type);
03687         UsimPlmnReadReqArg();
03688
03689         static const UsimPlmnReadReqArg& Cast(const StackMsgArgument& arg);
03690         void SetReadType(const UsimReadType& read_type) { m_read_type = read_type; }
03691         const UsimReadType& GetReadType() const { return m_read_type; }
03692
03693         enum  {
03694             ID = 2435
03695             };
03696
03697     private:
03698
03699         static void Destroy(StackMsgArgument* arg) { delete ((UsimPlmnReadReqArg*) arg); }
03700
03701         UsimReadType m_read_type;
03702
03703     };
03704
03705 // Inline definitions
03706 inline const UsimPlmnReadReqArg& UsimPlmnReadReqArg::Cast(const StackMsgArgument& arg) {
03707     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPlmnReadReqArg!\n");
03708     return ((UsimPlmnReadReqArg &) arg);
03709 }
03710
03711
03712
03713 /*  ======================================================================
03714     Class UsimCsLociReadReqArg
03715     ====================================================================== */
03716
03718 class UsimCsLociReadReqArg : public StackMsgArgument {
03719     friend class CommonStackMsgArgsDestroyTableNode;
03720     public:
03721         UsimCsLociReadReqArg();
03722
03723         static const UsimCsLociReadReqArg& Cast(const StackMsgArgument& arg);
03724
03725         enum  {
03726             ID = 2436
03727             };
03728
03729     private:
03730
03731         static void Destroy(StackMsgArgument* arg) { delete ((UsimCsLociReadReqArg*) arg); }
03732
03733     };
03734
03735 // Inline definitions
03736 inline const UsimCsLociReadReqArg& UsimCsLociReadReqArg::Cast(const StackMsgArgument& arg) {
03737     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimCsLociReadReqArg!\n");
03738     return ((UsimCsLociReadReqArg &) arg);
03739 }
03740
03741
03742
03743 /*  ======================================================================
03744     Class UsimPsLociReadReqArg
03745     ====================================================================== */
03746
03748 class UsimPsLociReadReqArg : public StackMsgArgument {
03749     friend class CommonStackMsgArgsDestroyTableNode;
03750     public:
03751         UsimPsLociReadReqArg();
03752
03753         static const UsimPsLociReadReqArg& Cast(const StackMsgArgument& arg);
03754
03755         enum  {
03756             ID = 2437
03757             };
03758
03759     private:
03760
03761         static void Destroy(StackMsgArgument* arg) { delete ((UsimPsLociReadReqArg*) arg); }
03762
03763     };
03764
03765 // Inline definitions
03766 inline const UsimPsLociReadReqArg& UsimPsLociReadReqArg::Cast(const StackMsgArgument& arg) {
03767     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPsLociReadReqArg!\n");
03768     return ((UsimPsLociReadReqArg &) arg);
03769 }
03770
03771
03772
03773 /*  ======================================================================
03774     Class UsimLangReadReqArg
03775     ====================================================================== */
03776
03778 class UsimLangReadReqArg : public StackMsgArgument {
03779     friend class CommonStackMsgArgsDestroyTableNode;
03780     public:
03781         UsimLangReadReqArg(const UsimLangFileType& lang_file_type, INT list_index);
03782         UsimLangReadReqArg();
03783
03784         static const UsimLangReadReqArg& Cast(const StackMsgArgument& arg);
03785         void SetLangFileType(const UsimLangFileType& lang_file_type) { m_lang_file_type = lang_file_type; }
03786         const UsimLangFileType& GetLangFileType() const { return m_lang_file_type; }
03787         void SetListIndex(INT list_index) { m_list_index = list_index; }
03788         INT GetListIndex() const { return m_list_index; }
03789
03790         enum  {
03791             ID = 2438
03792             };
03793
03794     private:
03795
03796         static void Destroy(StackMsgArgument* arg) { delete ((UsimLangReadReqArg*) arg); }
03797
03798         UsimLangFileType m_lang_file_type;
03799         INT m_list_index;
03800
03801     };
03802
03803 // Inline definitions
03804 inline const UsimLangReadReqArg& UsimLangReadReqArg::Cast(const StackMsgArgument& arg) {
03805     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimLangReadReqArg!\n");
03806     return ((UsimLangReadReqArg &) arg);
03807 }
03808
03809
03810
03811 /*  ======================================================================
03812     Class UsimEccReadReqArg
03813     ====================================================================== */
03814
03816 class UsimEccReadReqArg : public StackMsgArgument {
03817     friend class CommonStackMsgArgsDestroyTableNode;
03818     public:
03819         UsimEccReadReqArg(INT recno);
03820         UsimEccReadReqArg();
03821
03822         static const UsimEccReadReqArg& Cast(const StackMsgArgument& arg);
03823         void SetRecno(INT recno) { m_recno = recno; }
03824         INT GetRecno() const { return m_recno; }
03825
03826         enum  {
03827             ID = 2439
03828             };
03829
03830     private:
03831
03832         static void Destroy(StackMsgArgument* arg) { delete ((UsimEccReadReqArg*) arg); }
03833
03834         INT m_recno;
03835
03836     };
03837
03838 // Inline definitions
03839 inline const UsimEccReadReqArg& UsimEccReadReqArg::Cast(const StackMsgArgument& arg) {
03840     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimEccReadReqArg!\n");
03841     return ((UsimEccReadReqArg &) arg);
03842 }
03843
03844
03845
03846 /*  ======================================================================
03847     Class UsimSmsParamReadReqArg
03848     ====================================================================== */
03849
03851 class UsimSmsParamReadReqArg : public StackMsgArgument {
03852     friend class CommonStackMsgArgsDestroyTableNode;
03853     public:
03854         UsimSmsParamReadReqArg(INT recno);
03855         UsimSmsParamReadReqArg();
03856
03857         static const UsimSmsParamReadReqArg& Cast(const StackMsgArgument& arg);
03858         void SetRecno(INT recno) { m_recno = recno; }
03859         INT GetRecno() const { return m_recno; }
03860
03861         enum  {
03862             ID = 2440
03863             };
03864
03865     private:
03866
03867         static void Destroy(StackMsgArgument* arg) { delete ((UsimSmsParamReadReqArg*) arg); }
03868
03869         INT m_recno;
03870
03871     };
03872
03873 // Inline definitions
03874 inline const UsimSmsParamReadReqArg& UsimSmsParamReadReqArg::Cast(const StackMsgArgument& arg) {
03875     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimSmsParamReadReqArg!\n");
03876     return ((UsimSmsParamReadReqArg &) arg);
03877 }
03878
03879
03880
03881 /*  ======================================================================
03882     Class UsimPlmnUpdReqArg
03883     ====================================================================== */
03884
03886 class UsimPlmnUpdReqArg : public StackMsgArgument {
03887     friend class CommonStackMsgArgsDestroyTableNode;
03888     public:
03889         UsimPlmnUpdReqArg(INT recno, const UsimPlmn& plmn, const UsimUpdateAction& update_action);
03890         UsimPlmnUpdReqArg();
03891
03892         static const UsimPlmnUpdReqArg& Cast(const StackMsgArgument& arg);
03893         void SetRecno(INT recno) { m_recno = recno; }
03894         INT GetRecno() const { return m_recno; }
03895         void SetPlmn(const UsimPlmn& plmn) { m_plmn = plmn; }
03896         const UsimPlmn& GetPlmn() const { return m_plmn; }
03897         void SetUpdateAction(const UsimUpdateAction& update_action) { m_update_action = update_action; }
03898         const UsimUpdateAction& GetUpdateAction() const { return m_update_action; }
03899
03900         enum  {
03901             ID = 2441
03902             };
03903
03904     private:
03905
03906         static void Destroy(StackMsgArgument* arg) { delete ((UsimPlmnUpdReqArg*) arg); }
03907
03908         INT m_recno;
03909         UsimPlmn m_plmn;
03910         UsimUpdateAction m_update_action;
03911
03912     };
03913
03914 // Inline definitions
03915 inline const UsimPlmnUpdReqArg& UsimPlmnUpdReqArg::Cast(const StackMsgArgument& arg) {
03916     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimPlmnUpdReqArg!\n");
03917     return ((UsimPlmnUpdReqArg &) arg);
03918 }
03919
03920
03921
03922 /*  ======================================================================
03923     Class UsimCardTypeReadReqArg
03924     ====================================================================== */
03925
03927 class UsimCardTypeReadReqArg : public StackMsgArgument {
03928     friend class CommonStackMsgArgsDestroyTableNode;
03929     public:
03930         UsimCardTypeReadReqArg();
03931
03932         static const UsimCardTypeReadReqArg& Cast(const StackMsgArgument& arg);
03933
03934         enum  {
03935             ID = 2442
03936             };
03937
03938     private:
03939
03940         static void Destroy(StackMsgArgument* arg) { delete ((UsimCardTypeReadReqArg*) arg); }
03941
03942     };
03943
03944 // Inline definitions
03945 inline const UsimCardTypeReadReqArg& UsimCardTypeReadReqArg::Cast(const StackMsgArgument& arg) {
03946     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimCardTypeReadReqArg!\n");
03947     return ((UsimCardTypeReadReqArg &) arg);
03948 }
03949
03950
03951
03952 /*  ======================================================================
03953     Class UsimSmsParamUpdReqArg
03954     ====================================================================== */
03955
03957 class UsimSmsParamUpdReqArg : public StackMsgArgument {
03958     friend class CommonStackMsgArgsDestroyTableNode;
03959     public:
03960         UsimSmsParamUpdReqArg(INT recno, const SmsParamRecord& sms_param_record);
03961         UsimSmsParamUpdReqArg();
03962
03963         static const UsimSmsParamUpdReqArg& Cast(const StackMsgArgument& arg);
03964         void SetRecno(INT recno) { m_recno = recno; }
03965         INT GetRecno() const { return m_recno; }
03966         void SetSmsParamRecord(const SmsParamRecord& sms_param_record) { m_sms_param_record = sms_param_record; }
03967         const SmsParamRecord& GetSmsParamRecord() const { return m_sms_param_record; }
03968
03969         enum  {
03970             ID = 2443
03971             };
03972
03973     private:
03974
03975         static void Destroy(StackMsgArgument* arg) { delete ((UsimSmsParamUpdReqArg*) arg); }
03976
03977         INT m_recno;
03978         SmsParamRecord m_sms_param_record;
03979
03980     };
03981
03982 // Inline definitions
03983 inline const UsimSmsParamUpdReqArg& UsimSmsParamUpdReqArg::Cast(const StackMsgArgument& arg) {
03984     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimSmsParamUpdReqArg!\n");
03985     return ((UsimSmsParamUpdReqArg &) arg);
03986 }
03987
03988
03989
03990 /*  ======================================================================
03991     Class UsimEstReadReqArg
03992     ====================================================================== */
03993
03995 class UsimEstReadReqArg : public StackMsgArgument {
03996     friend class CommonStackMsgArgsDestroyTableNode;
03997     public:
03998         UsimEstReadReqArg();
03999
04000         static const UsimEstReadReqArg& Cast(const StackMsgArgument& arg);
04001
04002         enum  {
04003             ID = 2444
04004             };
04005
04006     private:
04007
04008         static void Destroy(StackMsgArgument* arg) { delete ((UsimEstReadReqArg*) arg); }
04009
04010     };
04011
04012 // Inline definitions
04013 inline const UsimEstReadReqArg& UsimEstReadReqArg::Cast(const StackMsgArgument& arg) {
04014     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimEstReadReqArg!\n");
04015     return ((UsimEstReadReqArg &) arg);
04016 }
04017
04018
04019
04020 /*  ======================================================================
04021     Class UsimLangUpdReqArg
04022     ====================================================================== */
04023
04025 class UsimLangUpdReqArg : public StackMsgArgument {
04026     friend class CommonStackMsgArgsDestroyTableNode;
04027     public:
04028         UsimLangUpdReqArg(const UsimLangFileType& lang_file_type, INT recno, const UsimLanguage& language, const UsimUpdateAction& update_action);
04029         UsimLangUpdReqArg();
04030
04031         static const UsimLangUpdReqArg& Cast(const StackMsgArgument& arg);
04032         void SetLangFileType(const UsimLangFileType& lang_file_type) { m_lang_file_type = lang_file_type; }
04033         const UsimLangFileType& GetLangFileType() const { return m_lang_file_type; }
04034         void SetRecno(INT recno) { m_recno = recno; }
04035         INT GetRecno() const { return m_recno; }
04036         void SetLanguage(const UsimLanguage& language) { m_language = language; }
04037         const UsimLanguage& GetLanguage() const { return m_language; }
04038         void SetUpdateAction(const UsimUpdateAction& update_action) { m_update_action = update_action; }
04039         const UsimUpdateAction& GetUpdateAction() const { return m_update_action; }
04040
04041         enum  {
04042             ID = 2445
04043             };
04044
04045     private:
04046
04047         static void Destroy(StackMsgArgument* arg) { delete ((UsimLangUpdReqArg*) arg); }
04048
04049         UsimLangFileType m_lang_file_type;
04050         INT m_recno;
04051         UsimLanguage m_language;
04052         UsimUpdateAction m_update_action;
04053
04054     };
04055
04056 // Inline definitions
04057 inline const UsimLangUpdReqArg& UsimLangUpdReqArg::Cast(const StackMsgArgument& arg) {
04058     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimLangUpdReqArg!\n");
04059     return ((UsimLangUpdReqArg &) arg);
04060 }
04061
04062
04063
04064 /*  ======================================================================
04065     Class UsimFilePropertyReqArg
04066     ====================================================================== */
04067
04069 class UsimFilePropertyReqArg : public StackMsgArgument {
04070     friend class CommonStackMsgArgsDestroyTableNode;
04071     public:
04072         UsimFilePropertyReqArg(const UsimReadType& read_type);
04073         UsimFilePropertyReqArg();
04074
04075         static const UsimFilePropertyReqArg& Cast(const StackMsgArgument& arg);
04076         void SetReadType(const UsimReadType& read_type) { m_read_type = read_type; }
04077         const UsimReadType& GetReadType() const { return m_read_type; }
04078
04079         enum  {
04080             ID = 2446
04081             };
04082
04083     private:
04084
04085         static void Destroy(StackMsgArgument* arg) { delete ((UsimFilePropertyReqArg*) arg); }
04086
04087         UsimReadType m_read_type;
04088
04089     };
04090
04091 // Inline definitions
04092 inline const UsimFilePropertyReqArg& UsimFilePropertyReqArg::Cast(const StackMsgArgument& arg) {
04093     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UsimFilePropertyReqArg!\n");
04094     return ((UsimFilePropertyReqArg &) arg);
04095 }
04096
04097
04098
04099 /*  ======================================================================
04100     Class SimCmiReadReqArg
04101     ====================================================================== */
04102
04104 class SimCmiReadReqArg : public StackMsgArgument {
04105     friend class CommonStackMsgArgsDestroyTableNode;
04106     public:
04107         SimCmiReadReqArg(INT rec_no);
04108         SimCmiReadReqArg();
04109
04110         static const SimCmiReadReqArg& Cast(const StackMsgArgument& arg);
04111         void SetRecNo(INT rec_no) { m_rec_no = rec_no; }
04112         INT GetRecNo() const { return m_rec_no; }
04113
04114         enum  {
04115             ID = 2460
04116             };
04117
04118     private:
04119
04120         static void Destroy(StackMsgArgument* arg) { delete ((SimCmiReadReqArg*) arg); }
04121
04122         INT m_rec_no;
04123
04124     };
04125
04126 // Inline definitions
04127 inline const SimCmiReadReqArg& SimCmiReadReqArg::Cast(const StackMsgArgument& arg) {
04128     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimCmiReadReqArg!\n");
04129     return ((SimCmiReadReqArg &) arg);
04130 }
04131
04132
04133
04134 /*  ======================================================================
04135     Class SimODynReadReqArg
04136     ====================================================================== */
04137
04139 class SimODynReadReqArg : public StackMsgArgument {
04140     friend class CommonStackMsgArgsDestroyTableNode;
04141     public:
04142         SimODynReadReqArg();
04143
04144         static const SimODynReadReqArg& Cast(const StackMsgArgument& arg);
04145
04146         enum  {
04147             ID = 2461
04148             };
04149
04150     private:
04151
04152         static void Destroy(StackMsgArgument* arg) { delete ((SimODynReadReqArg*) arg); }
04153
04154     };
04155
04156 // Inline definitions
04157 inline const SimODynReadReqArg& SimODynReadReqArg::Cast(const StackMsgArgument& arg) {
04158     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimODynReadReqArg!\n");
04159     return ((SimODynReadReqArg &) arg);
04160 }
04161
04162
04163
04164 /*  ======================================================================
04165     Class SimODyn2ReadReqArg
04166     ====================================================================== */
04167
04169 class SimODyn2ReadReqArg : public StackMsgArgument {
04170     friend class CommonStackMsgArgsDestroyTableNode;
04171     public:
04172         SimODyn2ReadReqArg();
04173
04174         static const SimODyn2ReadReqArg& Cast(const StackMsgArgument& arg);
04175
04176         enum  {
04177             ID = 2462
04178             };
04179
04180     private:
04181
04182         static void Destroy(StackMsgArgument* arg) { delete ((SimODyn2ReadReqArg*) arg); }
04183
04184     };
04185
04186 // Inline definitions
04187 inline const SimODyn2ReadReqArg& SimODyn2ReadReqArg::Cast(const StackMsgArgument& arg) {
04188     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimODyn2ReadReqArg!\n");
04189     return ((SimODyn2ReadReqArg &) arg);
04190 }
04191
04192
04193
04194 /*  ======================================================================
04195     Class SimODynUpdReqArg
04196     ====================================================================== */
04197
04199 class SimODynUpdReqArg : public StackMsgArgument {
04200     friend class CommonStackMsgArgsDestroyTableNode;
04201     public:
04202         SimODynUpdReqArg(UINT8 flag);
04203         SimODynUpdReqArg();
04204
04205         static const SimODynUpdReqArg& Cast(const StackMsgArgument& arg);
04206         void SetFlag(UINT8 flag) { m_flag = flag; }
04207         UINT8 GetFlag() const { return m_flag; }
04208
04209         enum  {
04210             ID = 2463
04211             };
04212
04213     private:
04214
04215         static void Destroy(StackMsgArgument* arg) { delete ((SimODynUpdReqArg*) arg); }
04216
04217         UINT8 m_flag;
04218
04219     };
04220
04221 // Inline definitions
04222 inline const SimODynUpdReqArg& SimODynUpdReqArg::Cast(const StackMsgArgument& arg) {
04223     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimODynUpdReqArg!\n");
04224     return ((SimODynUpdReqArg &) arg);
04225 }
04226
04227
04228
04229 /*  ======================================================================
04230     Class SimODyn2UpdReqArg
04231     ====================================================================== */
04232
04234 class SimODyn2UpdReqArg : public StackMsgArgument {
04235     friend class CommonStackMsgArgsDestroyTableNode;
04236     public:
04237         SimODyn2UpdReqArg(UINT8 flag);
04238         SimODyn2UpdReqArg();
04239
04240         static const SimODyn2UpdReqArg& Cast(const StackMsgArgument& arg);
04241         void SetFlag(UINT8 flag) { m_flag = flag; }
04242         UINT8 GetFlag() const { return m_flag; }
04243
04244         enum  {
04245             ID = 2464
04246             };
04247
04248     private:
04249
04250         static void Destroy(StackMsgArgument* arg) { delete ((SimODyn2UpdReqArg*) arg); }
04251
04252         UINT8 m_flag;
04253
04254     };
04255
04256 // Inline definitions
04257 inline const SimODyn2UpdReqArg& SimODyn2UpdReqArg::Cast(const StackMsgArgument& arg) {
04258     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimODyn2UpdReqArg!\n");
04259     return ((SimODyn2UpdReqArg &) arg);
04260 }
04261
04262
04263
04264 /*  ======================================================================
04265     Class SimMruPropertyUpdReqArg
04266     ====================================================================== */
04267
04269 class SimMruPropertyUpdReqArg : public StackMsgArgument {
04270     friend class CommonStackMsgArgsDestroyTableNode;
04271     public:
04272         SimMruPropertyUpdReqArg(UINT16 type, UINT8 index, UINT8 bit_number, UINT8 bit_value);
04273         SimMruPropertyUpdReqArg();
04274
04275         static const SimMruPropertyUpdReqArg& Cast(const StackMsgArgument& arg);
04276         void SetType(UINT16 type) { m_type = type; }
04277         UINT16 GetType() const { return m_type; }
04278         void SetIndex(UINT8 index) { m_index = index; }
04279         UINT8 GetIndex() const { return m_index; }
04280         void SetBitNumber(UINT8 bit_number) { m_bit_number = bit_number; }
04281         UINT8 GetBitNumber() const { return m_bit_number; }
04282         void SetBitValue(UINT8 bit_value) { m_bit_value = bit_value; }
04283         UINT8 GetBitValue() const { return m_bit_value; }
04284
04285         enum  {
04286             ID = 2465
04287             };
04288
04289     private:
04290
04291         static void Destroy(StackMsgArgument* arg) { delete ((SimMruPropertyUpdReqArg*) arg); }
04292
04293         UINT16 m_type;
04294         UINT8 m_index;
04295         UINT8 m_bit_number;
04296         UINT8 m_bit_value;
04297
04298     };
04299
04300 // Inline definitions
04301 inline const SimMruPropertyUpdReqArg& SimMruPropertyUpdReqArg::Cast(const StackMsgArgument& arg) {
04302     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimMruPropertyUpdReqArg!\n");
04303     return ((SimMruPropertyUpdReqArg &) arg);
04304 }
04305
04306
04307
04308 /*  ======================================================================
04309     Class FdnReqArg
04310     ====================================================================== */
04311
04313 class FdnReqArg : public StackMsgArgument {
04314     friend class CommonStackMsgArgsDestroyTableNode;
04315     public:
04316         FdnReqArg(const FdnState& fdn_state);
04317         FdnReqArg();
04318
04319         static const FdnReqArg& Cast(const StackMsgArgument& arg);
04320         void SetFdnState(const FdnState& fdn_state) { m_fdn_state = fdn_state; }
04321         const FdnState& GetFdnState() const { return m_fdn_state; }
04322
04323         enum  {
04324             ID = 2470
04325             };
04326
04327     private:
04328
04329         static void Destroy(StackMsgArgument* arg) { delete ((FdnReqArg*) arg); }
04330
04331         FdnState m_fdn_state;
04332
04333     };
04334
04335 // Inline definitions
04336 inline const FdnReqArg& FdnReqArg::Cast(const StackMsgArgument& arg) {
04337     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to FdnReqArg!\n");
04338     return ((FdnReqArg &) arg);
04339 }
04340
04341
04342
04343 /*  ======================================================================
04344     Class BdnReqArg
04345     ====================================================================== */
04346
04348 class BdnReqArg : public StackMsgArgument {
04349     friend class CommonStackMsgArgsDestroyTableNode;
04350     public:
04351         BdnReqArg(const BdnState& bdn_state);
04352         BdnReqArg();
04353
04354         static const BdnReqArg& Cast(const StackMsgArgument& arg);
04355         void SetBdnState(const BdnState& bdn_state) { m_bdn_state = bdn_state; }
04356         const BdnState& GetBdnState() const { return m_bdn_state; }
04357
04358         enum  {
04359             ID = 2471
04360             };
04361
04362     private:
04363
04364         static void Destroy(StackMsgArgument* arg) { delete ((BdnReqArg*) arg); }
04365
04366         BdnState m_bdn_state;
04367
04368     };
04369
04370 // Inline definitions
04371 inline const BdnReqArg& BdnReqArg::Cast(const StackMsgArgument& arg) {
04372     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BdnReqArg!\n");
04373     return ((BdnReqArg &) arg);
04374 }
04375
04376
04377
04378 /*  ======================================================================
04379     Class SimModifyLockReqArg
04380     ====================================================================== */
04381
04383 class SimModifyLockReqArg : public StackMsgArgument {
04384     friend class CommonStackMsgArgsDestroyTableNode;
04385     public:
04386         SimModifyLockReqArg(const SecLockStates& lock_states, const SecLockCommand& lock_command);
04387         SimModifyLockReqArg();
04388
04389         static const SimModifyLockReqArg& Cast(const StackMsgArgument& arg);
04390         void SetLockStates(const SecLockStates& lock_states) { m_lock_states = lock_states; }
04391         const SecLockStates& GetLockStates() const { return m_lock_states; }
04392         void SetLockCommand(const SecLockCommand& lock_command) { m_lock_command = lock_command; }
04393         const SecLockCommand& GetLockCommand() const { return m_lock_command; }
04394
04395         enum  {
04396             ID = 2472
04397             };
04398
04399     private:
04400
04401         static void Destroy(StackMsgArgument* arg) { delete ((SimModifyLockReqArg*) arg); }
04402
04403         SecLockStates m_lock_states;
04404         SecLockCommand m_lock_command;
04405
04406     };
04407
04408 // Inline definitions
04409 inline const SimModifyLockReqArg& SimModifyLockReqArg::Cast(const StackMsgArgument& arg) {
04410     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimModifyLockReqArg!\n");
04411     return ((SimModifyLockReqArg &) arg);
04412 }
04413
04414
04415 #endif // Apc_SimMiscStackMsgArgs_hpp
04416
Generated on Tue Jan 24 14:46:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimMiscTypes.hpp File Reference

Apc/SimMiscTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for SimMiscTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | AddInfo
struct | SimInfo

Defines

#define | Apc_Gprs_SimMiscTypes_hpp

Typedefs

typedef T_SI_SIM_CHANGED_STATE | SimChangedState

Define Documentation

#define Apc_Gprs_SimMiscTypes_hpp

Typedef Documentation

typedef T_SI_SIM_CHANGED_STATE SimChangedState

Generated on Tue Jan 24 17:07:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimMiscTypes.hpp Source File

Apc/SimMiscTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Gprs_SimMiscTypes_hpp)
00009 #define Apc_Gprs_SimMiscTypes_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 #include <Apc/SignalTypes.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     sim information structure
00017     ------------------------------------------------------------------------ */
00018
00019 struct AddInfo {
00020     UINT8 val[4];
00021 };
00022
00023 typedef T_SI_SIM_CHANGED_STATE SimChangedState;
00024
00025 struct SimInfo {
00026     SimIndicator            sim_indicator;
00027     IccId                   iccid;
00028     SimType                 sim_type;
00029     SimPhase                sim_phase;
00030     ChvStatus               chv1_status;
00031     ChvStatus               chv2_status;
00032     ChvAttemptsStruct       chv_attempts;
00033     Language                pref_language;
00034     AddInfo                 add_info;
00035     ExtLanguage             ext_pref_language;
00036     UINT8                   changed_indication; // 0x00 not changed, 0xff new, 0x01->0xfe new but used before
00037     SimChangedState         changed_state;
00038 };
00039
00040 #endif  // Apc_Gprs_SimMiscTypes_hpp
00041
00042
Generated on Tue Jan 24 14:46:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimTkStackMsgArgs.cpp File Reference

Apc/SimTkStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "SimTkStackMsgArgs.hpp"

Include dependency graph for SimTkStackMsgArgs.cpp:

Generated on Tue Jan 24 17:07:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimTkStackMsgArgs.hpp File Reference

Apc/SimTkStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/AudioTypes.hpp>
#include <Apc/SimTkTypes.hpp>

Include dependency graph for SimTkStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BrowserRegisterReqArg
class | BrowserTermEventArg
class | CallControlSetupIndArg
class | CallControlSsIndArg
class | CallControlUssdIndArg
class | DhChannelChangeStatusEventArg
class | DhChannelChangeStatusResArg
class | DhChannelCloseIndArg
class | DhChannelCloseReqArg
class | DhChannelDataAvailableResArg
class | DhChannelDataAvailEventArg
class | DhChannelOpenCnfArg
class | DhChannelOpenRejArg
class | DhChannelOpenReqArg
class | DhChannelReceiveIndArg
class | DhChannelReceiveReqArg
class | DhChannelSendIndArg
class | DhChannelSendReqArg
class | DisplayTextReqArg
class | DisplayTextRspArg
class | EndSimToolkitIndArg
class | ExtProactiveCmdCnfArg
class | ExtProactiveCmdIndArg
class | ExtProactiveCmdReqArg
class | GetInkeyReqArg
class | GetInkeyRspArg
class | GetInputReqArg
class | GetInputRspArg
class | IdleScreenAvailEventArg
class | LanguageSelectEventArg
class | LanguageSettingIndArg
class | LanguageSettingReqArg
class | LaunchBrowserIndArg
class | LaunchBrowserPromptIndArg
class | MenuSelectionRejArg
class | MenuSelectionReqArg
class | PlayToneReqArg
class | PlayToneRspArg
class | SelectItemReqArg
class | SelectItemRspArg
class | SetupEventCnfArg
class | SetupIdleModeTextReqArg
class | SetupIdleModeTextRspArg
class | SetupMenuReqArg
class | SetupMenuRspArg
class | SiChannelCloseInfoIndArg
class | SiChannelCloseInfoResArg
class | SiChannelCloseReqArg
class | SiChannelOpenPromptReqArg
class | SiChannelOpenPromptResArg
class | SiChannelReceiveInfoIndArg
class | SiChannelReceiveInfoResArg
class | SiChannelSendInfoIndArg
class | SiChannelSendInfoResArg
class | SimBrowserTermResArg
class | SimLaunchBrowserPromptReqArg
class | SimLaunchBrowserReqArg
class | SimTkCallSetupAccArg
class | SimTkCallSetupIndArg
class | SimTkCallSetupRejArg
class | SimTkInterfaceIndArg
class | SimTkLanguageNotificationIndArg
class | SimTkRefreshCnfIndArg
class | SimTkRefreshCnfReqArg
class | SimTkRefreshNewReqArg
class | SimTkRefreshNewRspArg
class | SimTkRefreshQueryReqArg
class | SimTkRefreshQueryResArg
class | SimTkRefreshReqArg
class | SimTkRefreshResetReqArg
class | SimTkRefreshResetRspArg
class | SimTkRefreshRspArg
class | SimTkResetCnfArg
class | SimTkResetCnfIndArg
class | SimTkResetCnfReqArg
class | SimTkRunAtCmdInfoIndArg
class | SimTkRunAtCmdInfoResArg
class | SimTkSendDtmfCnfArg
class | SimTkSendDtmfEndIndArg
class | SimTkSendDtmfIndArg
class | SimTkSetupEventReqArg
class | SimTkSmsPpIndArg
class | SimTkSmsPpRspArg
class | SimTkSsIndArg
class | SimTkSsRspArg
class | SimTkStopSendDtmfReqArg
class | SmsControlIndArg
class | TermRspCnfArg
class | UserActivityEventArg

Defines

#define | Apc_SimTkStackMsgArgs_hpp

Define Documentation

#define Apc_SimTkStackMsgArgs_hpp

Generated on Tue Jan 24 17:07:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimTkStackMsgArgs.hpp Source File

Apc/SimTkStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\grossau_mp1ue_sv\lnz_apoxi\Apoxi\Apc\SimTkArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_SimTkStackMsgArgs_hpp)
00016 #define Apc_SimTkStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Apc/AudioTypes.hpp>
00021 #include <Apc/SimTkTypes.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class SimTkCallSetupIndArg
00030     ====================================================================== */
00031
00033 class SimTkCallSetupIndArg : public StackMsgArgument {
00034     friend class CommonStackMsgArgsDestroyTableNode;
00035     public:
00036         SimTkCallSetupIndArg();
00037
00038         static const SimTkCallSetupIndArg& Cast(const StackMsgArgument& arg);
00039         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00040         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00041         void SetSubAddress(const SimSubAddress& sub_address) { m_sub_address = sub_address; }
00042         const SimSubAddress& GetSubAddress() const { return m_sub_address; }
00043         void SetDummy(const SimDummy& dummy) { m_dummy = dummy; }
00044         const SimDummy& GetDummy() const { return m_dummy; }
00045         void SetCallInfoAlpha(const SimAlphaIdentifier& call_info_alpha) { m_call_info_alpha = call_info_alpha; }
00046         const SimAlphaIdentifier& GetCallInfoAlpha() const { return m_call_info_alpha; }
00047         void SetCallInfoIcon(const SimIconIdentifier& call_info_icon) { m_call_info_icon = call_info_icon; }
00048         const SimIconIdentifier& GetCallInfoIcon() const { return m_call_info_icon; }
00049         void SetCallEstablishedInfoAlpha(const SimAlphaIdentifier& call_established_info_alpha) { m_call_established_info_alpha = call_established_info_alpha; }
00050         const SimAlphaIdentifier& GetCallEstablishedInfoAlpha() const { return m_call_established_info_alpha; }
00051         void SetCallEstablishedInfoIcon(const SimIconIdentifier& call_established_info_icon) { m_call_established_info_icon = call_established_info_icon; }
00052         const SimIconIdentifier& GetCallEstablishedInfoIcon() const { return m_call_established_info_icon; }
00053
00054         enum  {
00055             ID = 1300
00056             };
00057
00058     private:
00059
00060         static void Destroy(StackMsgArgument* arg) { delete ((SimTkCallSetupIndArg*) arg); }
00061
00062         PhoneNumber m_phone_number;
00063         SimSubAddress m_sub_address;
00064         SimDummy m_dummy;
00065         SimAlphaIdentifier m_call_info_alpha;
00066         SimIconIdentifier m_call_info_icon;
00067         SimAlphaIdentifier m_call_established_info_alpha;
00068         SimIconIdentifier m_call_established_info_icon;
00069
00070     };
00071
00072 // Inline definitions
00073 inline const SimTkCallSetupIndArg& SimTkCallSetupIndArg::Cast(const StackMsgArgument& arg) {
00074     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkCallSetupIndArg!\n");
00075     return ((SimTkCallSetupIndArg &) arg);
00076 }
00077
00078
00079
00080 /*  ======================================================================
00081     Class SimTkSmsPpIndArg
00082     ====================================================================== */
00083
00085 class SimTkSmsPpIndArg : public StackMsgArgument {
00086     friend class CommonStackMsgArgsDestroyTableNode;
00087     public:
00088         SimTkSmsPpIndArg();
00089
00090         static const SimTkSmsPpIndArg& Cast(const StackMsgArgument& arg);
00091         void SetSmsInfoAlpha(const SimAlphaIdentifier& sms_info_alpha) { m_sms_info_alpha = sms_info_alpha; }
00092         const SimAlphaIdentifier& GetSmsInfoAlpha() const { return m_sms_info_alpha; }
00093         void SetSmsInfoIcon(const SimIconIdentifier& sms_info_icon) { m_sms_info_icon = sms_info_icon; }
00094         const SimIconIdentifier& GetSmsInfoIcon() const { return m_sms_info_icon; }
00095         void SetReferenceNumber(const SimReferenceNumber& reference_number) { m_reference_number = reference_number; }
00096         const SimReferenceNumber& GetReferenceNumber() const { return m_reference_number; }
00097
00098         enum  {
00099             ID = 1301
00100             };
00101
00102     private:
00103
00104         static void Destroy(StackMsgArgument* arg) { delete ((SimTkSmsPpIndArg*) arg); }
00105
00106         SimAlphaIdentifier m_sms_info_alpha;
00107         SimIconIdentifier m_sms_info_icon;
00108         SimReferenceNumber m_reference_number;
00109
00110     };
00111
00112 // Inline definitions
00113 inline const SimTkSmsPpIndArg& SimTkSmsPpIndArg::Cast(const StackMsgArgument& arg) {
00114     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkSmsPpIndArg!\n");
00115     return ((SimTkSmsPpIndArg &) arg);
00116 }
00117
00118
00119
00120 /*  ======================================================================
00121     Class SimTkSsIndArg
00122     ====================================================================== */
00123
00125 class SimTkSsIndArg : public StackMsgArgument {
00126     friend class CommonStackMsgArgsDestroyTableNode;
00127     public:
00128         SimTkSsIndArg();
00129
00130         static const SimTkSsIndArg& Cast(const StackMsgArgument& arg);
00131         void SetSsInfoAlpha(const SimAlphaIdentifier& ss_info_alpha) { m_ss_info_alpha = ss_info_alpha; }
00132         const SimAlphaIdentifier& GetSsInfoAlpha() const { return m_ss_info_alpha; }
00133         void SetSsInfoIcon(const SimIconIdentifier& ss_info_icon) { m_ss_info_icon = ss_info_icon; }
00134         const SimIconIdentifier& GetSsInfoIcon() const { return m_ss_info_icon; }
00135         void SetReferenceNumber(const SimReferenceNumber& reference_number) { m_reference_number = reference_number; }
00136         const SimReferenceNumber& GetReferenceNumber() const { return m_reference_number; }
00137         void SetUserInput(const WString& user_input) { m_user_input = user_input; }
00138         const WString& GetUserInput() const { return m_user_input; }
00139         void SetUserInputLanguage(const DataCodingScheme::Language& user_input_language) { m_user_input_language = user_input_language; }
00140         const DataCodingScheme::Language& GetUserInputLanguage() const { return m_user_input_language; }
00141         void SetSimServiceType(const SimSsType& sim_service_type) { m_sim_service_type = sim_service_type; }
00142         const SimSsType& GetSimServiceType() const { return m_sim_service_type; }
00143         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00144         const Tipd& GetTipd() const { return m_tipd; }
00145
00146         enum  {
00147             ID = 1302
00148             };
00149
00150     private:
00151
00152         static void Destroy(StackMsgArgument* arg) { delete ((SimTkSsIndArg*) arg); }
00153
00154         SimAlphaIdentifier m_ss_info_alpha;
00155         SimIconIdentifier m_ss_info_icon;
00156         SimReferenceNumber m_reference_number;
00157         WString m_user_input;
00158         DataCodingScheme::Language m_user_input_language;
00159         SimSsType m_sim_service_type;
00160         Tipd m_tipd;
00161
00162     };
00163
00164 // Inline definitions
00165 inline const SimTkSsIndArg& SimTkSsIndArg::Cast(const StackMsgArgument& arg) {
00166     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkSsIndArg!\n");
00167     return ((SimTkSsIndArg &) arg);
00168 }
00169
00170
00171
00172 /*  ======================================================================
00173     Class SimTkRefreshReqArg
00174     ====================================================================== */
00175
00177 class SimTkRefreshReqArg : public StackMsgArgument {
00178     friend class CommonStackMsgArgsDestroyTableNode;
00179     public:
00180         SimTkRefreshReqArg();
00181
00182         static const SimTkRefreshReqArg& Cast(const StackMsgArgument& arg);
00183         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00184         const SimTkTransactionId& GetTid() const { return m_tid; }
00185         void SetEfRefresh(const SimEfRefresh& ef_refresh) { m_ef_refresh = ef_refresh; }
00186         const SimEfRefresh& GetEfRefresh() const { return m_ef_refresh; }
00187
00188         enum  {
00189             ID = 1303
00190             };
00191
00192     private:
00193
00194         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshReqArg*) arg); }
00195
00196         SimTkTransactionId m_tid;
00197         SimEfRefresh m_ef_refresh;
00198
00199     };
00200
00201 // Inline definitions
00202 inline const SimTkRefreshReqArg& SimTkRefreshReqArg::Cast(const StackMsgArgument& arg) {
00203     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshReqArg!\n");
00204     return ((SimTkRefreshReqArg &) arg);
00205 }
00206
00207
00208
00209 /*  ======================================================================
00210     Class SimTkRefreshResetReqArg
00211     ====================================================================== */
00212
00214 class SimTkRefreshResetReqArg : public StackMsgArgument {
00215     friend class CommonStackMsgArgsDestroyTableNode;
00216     public:
00217         SimTkRefreshResetReqArg();
00218
00219         static const SimTkRefreshResetReqArg& Cast(const StackMsgArgument& arg);
00220         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00221         const SimTkTransactionId& GetTid() const { return m_tid; }
00222
00223         enum  {
00224             ID = 1304
00225             };
00226
00227     private:
00228
00229         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshResetReqArg*) arg); }
00230
00231         SimTkTransactionId m_tid;
00232
00233     };
00234
00235 // Inline definitions
00236 inline const SimTkRefreshResetReqArg& SimTkRefreshResetReqArg::Cast(const StackMsgArgument& arg) {
00237     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshResetReqArg!\n");
00238     return ((SimTkRefreshResetReqArg &) arg);
00239 }
00240
00241
00242
00243 /*  ======================================================================
00244     Class SimTkResetCnfReqArg
00245     ====================================================================== */
00246
00248 class SimTkResetCnfReqArg : public StackMsgArgument {
00249     friend class CommonStackMsgArgsDestroyTableNode;
00250     public:
00251         SimTkResetCnfReqArg();
00252
00253         static const SimTkResetCnfReqArg& Cast(const StackMsgArgument& arg);
00254         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00255         const SimTkTransactionId& GetTid() const { return m_tid; }
00256         void SetRefreshPossible(BOOLEAN refresh_possible) { m_refresh_possible = refresh_possible; }
00257         BOOLEAN IsRefreshPossible() const { return m_refresh_possible; }
00258
00259         enum  {
00260             ID = 1305
00261             };
00262
00263     private:
00264
00265         static void Destroy(StackMsgArgument* arg) { delete ((SimTkResetCnfReqArg*) arg); }
00266
00267         SimTkTransactionId m_tid;
00268         BOOLEAN m_refresh_possible;
00269
00270     };
00271
00272 // Inline definitions
00273 inline const SimTkResetCnfReqArg& SimTkResetCnfReqArg::Cast(const StackMsgArgument& arg) {
00274     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkResetCnfReqArg!\n");
00275     return ((SimTkResetCnfReqArg &) arg);
00276 }
00277
00278
00279
00280 /*  ======================================================================
00281     Class SimTkResetCnfArg
00282     ====================================================================== */
00283
00285 class SimTkResetCnfArg : public StackMsgArgument {
00286     friend class CommonStackMsgArgsDestroyTableNode;
00287     public:
00288         SimTkResetCnfArg();
00289
00290         static const SimTkResetCnfArg& Cast(const StackMsgArgument& arg);
00291
00292         enum  {
00293             ID = 1306
00294             };
00295
00296     private:
00297
00298         static void Destroy(StackMsgArgument* arg) { delete ((SimTkResetCnfArg*) arg); }
00299
00300     };
00301
00302 // Inline definitions
00303 inline const SimTkResetCnfArg& SimTkResetCnfArg::Cast(const StackMsgArgument& arg) {
00304     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkResetCnfArg!\n");
00305     return ((SimTkResetCnfArg &) arg);
00306 }
00307
00308
00309
00310 /*  ======================================================================
00311     Class DisplayTextReqArg
00312     ====================================================================== */
00313
00315 class DisplayTextReqArg : public StackMsgArgument {
00316     friend class CommonStackMsgArgsDestroyTableNode;
00317     public:
00318         DisplayTextReqArg();
00319
00320         static const DisplayTextReqArg& Cast(const StackMsgArgument& arg);
00321         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00322         const SimTkTransactionId& GetTid() const { return m_tid; }
00323         void SetOptions(const SimDisplayTextOptions& options) { m_options = options; }
00324         const SimDisplayTextOptions& GetOptions() const { return m_options; }
00325         void SetTextString(const SimTextString& text_string) { m_text_string = text_string; }
00326         const SimTextString& GetTextString() const { return m_text_string; }
00327         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
00328         const SimIconIdentifier& GetIcon() const { return m_icon; }
00329         void SetImmediateResponse(BOOLEAN immediate_response) { m_immediate_response = immediate_response; }
00330         BOOLEAN IsImmediateResponse() const { return m_immediate_response; }
00331
00332         enum  {
00333             ID = 1307
00334             };
00335
00336     private:
00337
00338         static void Destroy(StackMsgArgument* arg) { delete ((DisplayTextReqArg*) arg); }
00339
00340         SimTkTransactionId m_tid;
00341         SimDisplayTextOptions m_options;
00342         SimTextString m_text_string;
00343         SimIconIdentifier m_icon;
00344         BOOLEAN m_immediate_response;
00345
00346     };
00347
00348 // Inline definitions
00349 inline const DisplayTextReqArg& DisplayTextReqArg::Cast(const StackMsgArgument& arg) {
00350     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DisplayTextReqArg!\n");
00351     return ((DisplayTextReqArg &) arg);
00352 }
00353
00354
00355
00356 /*  ======================================================================
00357     Class GetInputReqArg
00358     ====================================================================== */
00359
00361 class GetInputReqArg : public StackMsgArgument {
00362     friend class CommonStackMsgArgsDestroyTableNode;
00363     public:
00364         GetInputReqArg();
00365
00366         static const GetInputReqArg& Cast(const StackMsgArgument& arg);
00367         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00368         const SimTkTransactionId& GetTid() const { return m_tid; }
00369         void SetOptions(const SimGetInputOptions& options) { m_options = options; }
00370         const SimGetInputOptions& GetOptions() const { return m_options; }
00371         void SetTextString(const SimTextString& text_string) { m_text_string = text_string; }
00372         const SimTextString& GetTextString() const { return m_text_string; }
00373         void SetMinInputLen(INT min_input_len) { m_min_input_len = min_input_len; }
00374         INT GetMinInputLen() const { return m_min_input_len; }
00375         void SetMaxInputLen(INT max_input_len) { m_max_input_len = max_input_len; }
00376         INT GetMaxInputLen() const { return m_max_input_len; }
00377         void SetDefaultTextString(const SimTextString& default_text_string) { m_default_text_string = default_text_string; }
00378         const SimTextString& GetDefaultTextString() const { return m_default_text_string; }
00379         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
00380         const SimIconIdentifier& GetIcon() const { return m_icon; }
00381
00382         enum  {
00383             ID = 1308
00384             };
00385
00386     private:
00387
00388         static void Destroy(StackMsgArgument* arg) { delete ((GetInputReqArg*) arg); }
00389
00390         SimTkTransactionId m_tid;
00391         SimGetInputOptions m_options;
00392         SimTextString m_text_string;
00393         INT m_min_input_len;
00394         INT m_max_input_len;
00395         SimTextString m_default_text_string;
00396         SimIconIdentifier m_icon;
00397
00398     };
00399
00400 // Inline definitions
00401 inline const GetInputReqArg& GetInputReqArg::Cast(const StackMsgArgument& arg) {
00402     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to GetInputReqArg!\n");
00403     return ((GetInputReqArg &) arg);
00404 }
00405
00406
00407
00408 /*  ======================================================================
00409     Class GetInkeyReqArg
00410     ====================================================================== */
00411
00413 class GetInkeyReqArg : public StackMsgArgument {
00414     friend class CommonStackMsgArgsDestroyTableNode;
00415     public:
00416         GetInkeyReqArg();
00417
00418         static const GetInkeyReqArg& Cast(const StackMsgArgument& arg);
00419         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00420         const SimTkTransactionId& GetTid() const { return m_tid; }
00421         void SetOptions(const SimGetInkeyOptions& options) { m_options = options; }
00422         const SimGetInkeyOptions& GetOptions() const { return m_options; }
00423         void SetTextString(const SimTextString& text_string) { m_text_string = text_string; }
00424         const SimTextString& GetTextString() const { return m_text_string; }
00425         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
00426         const SimIconIdentifier& GetIcon() const { return m_icon; }
00427
00428         enum  {
00429             ID = 1309
00430             };
00431
00432     private:
00433
00434         static void Destroy(StackMsgArgument* arg) { delete ((GetInkeyReqArg*) arg); }
00435
00436         SimTkTransactionId m_tid;
00437         SimGetInkeyOptions m_options;
00438         SimTextString m_text_string;
00439         SimIconIdentifier m_icon;
00440
00441     };
00442
00443 // Inline definitions
00444 inline const GetInkeyReqArg& GetInkeyReqArg::Cast(const StackMsgArgument& arg) {
00445     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to GetInkeyReqArg!\n");
00446     return ((GetInkeyReqArg &) arg);
00447 }
00448
00449
00450
00451 /*  ======================================================================
00452     Class SelectItemReqArg
00453     ====================================================================== */
00454
00456 class SelectItemReqArg : public StackMsgArgument {
00457     friend class CommonStackMsgArgsDestroyTableNode;
00458     public:
00459         SelectItemReqArg();
00460
00461         static const SelectItemReqArg& Cast(const StackMsgArgument& arg);
00462         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00463         const SimTkTransactionId& GetTid() const { return m_tid; }
00464         void SetOptions(const SimSelectItemOptions& options) { m_options = options; }
00465         const SimSelectItemOptions& GetOptions() const { return m_options; }
00466         void SetDefaultItemId(const SimItemId& default_item_id) { m_default_item_id = default_item_id; }
00467         const SimItemId& GetDefaultItemId() const { return m_default_item_id; }
00468         void SetTitleAlpha(const SimAlphaIdentifier& title_alpha) { m_title_alpha = title_alpha; }
00469         const SimAlphaIdentifier& GetTitleAlpha() const { return m_title_alpha; }
00470         void SetItemList(const SimItemIdentifierList& item_list) { m_item_list = item_list; }
00471         const SimItemIdentifierList& GetItemList() const { return m_item_list; }
00472         void SetItemsNai(const SimNextActionIdentifier& items_nai) { m_items_nai = items_nai; }
00473         const SimNextActionIdentifier& GetItemsNai() const { return m_items_nai; }
00474         void SetTitleIcon(const SimIconIdentifier& title_icon) { m_title_icon = title_icon; }
00475         const SimIconIdentifier& GetTitleIcon() const { return m_title_icon; }
00476         void SetIconList(const SimIconIdentifier& icon_list) { m_icon_list = icon_list; }
00477         const SimIconIdentifier& GetIconList() const { return m_icon_list; }
00478
00479         enum  {
00480             ID = 1310
00481             };
00482
00483     private:
00484
00485         static void Destroy(StackMsgArgument* arg) { delete ((SelectItemReqArg*) arg); }
00486
00487         SimTkTransactionId m_tid;
00488         SimSelectItemOptions m_options;
00489         SimItemId m_default_item_id;
00490         SimAlphaIdentifier m_title_alpha;
00491         SimItemIdentifierList m_item_list;
00492         SimNextActionIdentifier m_items_nai;
00493         SimIconIdentifier m_title_icon;
00494         SimIconIdentifier m_icon_list;
00495
00496     };
00497
00498 // Inline definitions
00499 inline const SelectItemReqArg& SelectItemReqArg::Cast(const StackMsgArgument& arg) {
00500     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SelectItemReqArg!\n");
00501     return ((SelectItemReqArg &) arg);
00502 }
00503
00504
00505
00506 /*  ======================================================================
00507     Class SetupMenuReqArg
00508     ====================================================================== */
00509
00511 class SetupMenuReqArg : public StackMsgArgument {
00512     friend class CommonStackMsgArgsDestroyTableNode;
00513     public:
00514         SetupMenuReqArg();
00515
00516         static const SetupMenuReqArg& Cast(const StackMsgArgument& arg);
00517         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00518         const SimTkTransactionId& GetTid() const { return m_tid; }
00519         void SetOptions(const SimSetupMenuOptions& options) { m_options = options; }
00520         const SimSetupMenuOptions& GetOptions() const { return m_options; }
00521         void SetTitleAlpha(const SimAlphaIdentifier& title_alpha) { m_title_alpha = title_alpha; }
00522         const SimAlphaIdentifier& GetTitleAlpha() const { return m_title_alpha; }
00523         void SetItemList(const SimItemIdentifierList& item_list) { m_item_list = item_list; }
00524         const SimItemIdentifierList& GetItemList() const { return m_item_list; }
00525         void SetItemsNai(const SimNextActionIdentifier& items_nai) { m_items_nai = items_nai; }
00526         const SimNextActionIdentifier& GetItemsNai() const { return m_items_nai; }
00527         void SetTitleIcon(const SimIconIdentifier& title_icon) { m_title_icon = title_icon; }
00528         const SimIconIdentifier& GetTitleIcon() const { return m_title_icon; }
00529         void SetIconList(const SimIconIdentifier& icon_list) { m_icon_list = icon_list; }
00530         const SimIconIdentifier& GetIconList() const { return m_icon_list; }
00531
00532         enum  {
00533             ID = 1311
00534             };
00535
00536     private:
00537
00538         static void Destroy(StackMsgArgument* arg) { delete ((SetupMenuReqArg*) arg); }
00539
00540         SimTkTransactionId m_tid;
00541         SimSetupMenuOptions m_options;
00542         SimAlphaIdentifier m_title_alpha;
00543         SimItemIdentifierList m_item_list;
00544         SimNextActionIdentifier m_items_nai;
00545         SimIconIdentifier m_title_icon;
00546         SimIconIdentifier m_icon_list;
00547
00548     };
00549
00550 // Inline definitions
00551 inline const SetupMenuReqArg& SetupMenuReqArg::Cast(const StackMsgArgument& arg) {
00552     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SetupMenuReqArg!\n");
00553     return ((SetupMenuReqArg &) arg);
00554 }
00555
00556
00557
00558 /*  ======================================================================
00559     Class MenuSelectionRejArg
00560     ====================================================================== */
00561
00563 class MenuSelectionRejArg : public StackMsgArgument {
00564     friend class CommonStackMsgArgsDestroyTableNode;
00565     public:
00566         MenuSelectionRejArg();
00567
00568         static const MenuSelectionRejArg& Cast(const StackMsgArgument& arg);
00569
00570         enum  {
00571             ID = 1312
00572             };
00573
00574     private:
00575
00576         static void Destroy(StackMsgArgument* arg) { delete ((MenuSelectionRejArg*) arg); }
00577
00578     };
00579
00580 // Inline definitions
00581 inline const MenuSelectionRejArg& MenuSelectionRejArg::Cast(const StackMsgArgument& arg) {
00582     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MenuSelectionRejArg!\n");
00583     return ((MenuSelectionRejArg &) arg);
00584 }
00585
00586
00587
00588 /*  ======================================================================
00589     Class PlayToneReqArg
00590     ====================================================================== */
00591
00593 class PlayToneReqArg : public StackMsgArgument {
00594     friend class CommonStackMsgArgsDestroyTableNode;
00595     public:
00596         PlayToneReqArg();
00597
00598         static const PlayToneReqArg& Cast(const StackMsgArgument& arg);
00599         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00600         const SimTkTransactionId& GetTid() const { return m_tid; }
00601         void SetTone(const AudioTone& tone) { m_tone = tone; }
00602         const AudioTone& GetTone() const { return m_tone; }
00603         void SetInfoAlpha(const SimAlphaIdentifier& info_alpha) { m_info_alpha = info_alpha; }
00604         const SimAlphaIdentifier& GetInfoAlpha() const { return m_info_alpha; }
00605         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
00606         const SimIconIdentifier& GetIcon() const { return m_icon; }
00607
00608         enum  {
00609             ID = 1313
00610             };
00611
00612     private:
00613
00614         static void Destroy(StackMsgArgument* arg) { delete ((PlayToneReqArg*) arg); }
00615
00616         SimTkTransactionId m_tid;
00617         AudioTone m_tone;
00618         SimAlphaIdentifier m_info_alpha;
00619         SimIconIdentifier m_icon;
00620
00621     };
00622
00623 // Inline definitions
00624 inline const PlayToneReqArg& PlayToneReqArg::Cast(const StackMsgArgument& arg) {
00625     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PlayToneReqArg!\n");
00626     return ((PlayToneReqArg &) arg);
00627 }
00628
00629
00630
00631 /*  ======================================================================
00632     Class SetupIdleModeTextReqArg
00633     ====================================================================== */
00634
00636 class SetupIdleModeTextReqArg : public StackMsgArgument {
00637     friend class CommonStackMsgArgsDestroyTableNode;
00638     public:
00639         SetupIdleModeTextReqArg();
00640
00641         static const SetupIdleModeTextReqArg& Cast(const StackMsgArgument& arg);
00642         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00643         const SimTkTransactionId& GetTid() const { return m_tid; }
00644         void SetOptions(const SimSetupIdleModeTextOptions& options) { m_options = options; }
00645         const SimSetupIdleModeTextOptions& GetOptions() const { return m_options; }
00646         void SetTextString(const SimTextString& text_string) { m_text_string = text_string; }
00647         const SimTextString& GetTextString() const { return m_text_string; }
00648         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
00649         const SimIconIdentifier& GetIcon() const { return m_icon; }
00650
00651         enum  {
00652             ID = 1314
00653             };
00654
00655     private:
00656
00657         static void Destroy(StackMsgArgument* arg) { delete ((SetupIdleModeTextReqArg*) arg); }
00658
00659         SimTkTransactionId m_tid;
00660         SimSetupIdleModeTextOptions m_options;
00661         SimTextString m_text_string;
00662         SimIconIdentifier m_icon;
00663
00664     };
00665
00666 // Inline definitions
00667 inline const SetupIdleModeTextReqArg& SetupIdleModeTextReqArg::Cast(const StackMsgArgument& arg) {
00668     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SetupIdleModeTextReqArg!\n");
00669     return ((SetupIdleModeTextReqArg &) arg);
00670 }
00671
00672
00673
00674 /*  ======================================================================
00675     Class EndSimToolkitIndArg
00676     ====================================================================== */
00677
00679 class EndSimToolkitIndArg : public StackMsgArgument {
00680     friend class CommonStackMsgArgsDestroyTableNode;
00681     public:
00682         EndSimToolkitIndArg();
00683
00684         static const EndSimToolkitIndArg& Cast(const StackMsgArgument& arg);
00685
00686         enum  {
00687             ID = 1315
00688             };
00689
00690     private:
00691
00692         static void Destroy(StackMsgArgument* arg) { delete ((EndSimToolkitIndArg*) arg); }
00693
00694     };
00695
00696 // Inline definitions
00697 inline const EndSimToolkitIndArg& EndSimToolkitIndArg::Cast(const StackMsgArgument& arg) {
00698     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to EndSimToolkitIndArg!\n");
00699     return ((EndSimToolkitIndArg &) arg);
00700 }
00701
00702
00703
00704 /*  ======================================================================
00705     Class SimTkLanguageNotificationIndArg
00706     ====================================================================== */
00707
00709 class SimTkLanguageNotificationIndArg : public StackMsgArgument {
00710     friend class CommonStackMsgArgsDestroyTableNode;
00711     public:
00712         SimTkLanguageNotificationIndArg();
00713
00714         static const SimTkLanguageNotificationIndArg& Cast(const StackMsgArgument& arg);
00715         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00716         const SimTkTransactionId& GetTid() const { return m_tid; }
00717         void SetExtLanguage(const ExtLanguage& ext_language) { m_ext_language = ext_language; }
00718         const ExtLanguage& GetExtLanguage() const { return m_ext_language; }
00719
00720         enum  {
00721             ID = 1316
00722             };
00723
00724     private:
00725
00726         static void Destroy(StackMsgArgument* arg) { delete ((SimTkLanguageNotificationIndArg*) arg); }
00727
00728         SimTkTransactionId m_tid;
00729         ExtLanguage m_ext_language;
00730
00731     };
00732
00733 // Inline definitions
00734 inline const SimTkLanguageNotificationIndArg& SimTkLanguageNotificationIndArg::Cast(const StackMsgArgument& arg) {
00735     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkLanguageNotificationIndArg!\n");
00736     return ((SimTkLanguageNotificationIndArg &) arg);
00737 }
00738
00739
00740
00741 /*  ======================================================================
00742     Class SimTkSetupEventReqArg
00743     ====================================================================== */
00744
00746 class SimTkSetupEventReqArg : public StackMsgArgument {
00747     friend class CommonStackMsgArgsDestroyTableNode;
00748     public:
00749         SimTkSetupEventReqArg();
00750
00751         static const SimTkSetupEventReqArg& Cast(const StackMsgArgument& arg);
00752         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00753         const SimTkTransactionId& GetTid() const { return m_tid; }
00754         void SetEventList(const SimEventList& event_list) { m_event_list = event_list; }
00755         const SimEventList& GetEventList() const { return m_event_list; }
00756
00757         enum  {
00758             ID = 1317
00759             };
00760
00761     private:
00762
00763         static void Destroy(StackMsgArgument* arg) { delete ((SimTkSetupEventReqArg*) arg); }
00764
00765         SimTkTransactionId m_tid;
00766         SimEventList m_event_list;
00767
00768     };
00769
00770 // Inline definitions
00771 inline const SimTkSetupEventReqArg& SimTkSetupEventReqArg::Cast(const StackMsgArgument& arg) {
00772     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkSetupEventReqArg!\n");
00773     return ((SimTkSetupEventReqArg &) arg);
00774 }
00775
00776
00777
00778 /*  ======================================================================
00779     Class LanguageSettingReqArg
00780     ====================================================================== */
00781
00783 class LanguageSettingReqArg : public StackMsgArgument {
00784     friend class CommonStackMsgArgsDestroyTableNode;
00785     public:
00786         LanguageSettingReqArg();
00787
00788         static const LanguageSettingReqArg& Cast(const StackMsgArgument& arg);
00789         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00790         const SimTkTransactionId& GetTid() const { return m_tid; }
00791
00792         enum  {
00793             ID = 1318
00794             };
00795
00796     private:
00797
00798         static void Destroy(StackMsgArgument* arg) { delete ((LanguageSettingReqArg*) arg); }
00799
00800         SimTkTransactionId m_tid;
00801
00802     };
00803
00804 // Inline definitions
00805 inline const LanguageSettingReqArg& LanguageSettingReqArg::Cast(const StackMsgArgument& arg) {
00806     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to LanguageSettingReqArg!\n");
00807     return ((LanguageSettingReqArg &) arg);
00808 }
00809
00810
00811
00812 /*  ======================================================================
00813     Class ExtProactiveCmdReqArg
00814     ====================================================================== */
00815
00817 class ExtProactiveCmdReqArg : public StackMsgArgument {
00818     friend class CommonStackMsgArgsDestroyTableNode;
00819     public:
00820         ExtProactiveCmdReqArg(SimApduData * apdu_data_ptr);
00821         ExtProactiveCmdReqArg();
00822
00823         static const ExtProactiveCmdReqArg& Cast(const StackMsgArgument& arg);
00824         void SetApduDataPtr(SimApduData * apdu_data_ptr) { m_apdu_data_ptr = apdu_data_ptr; }
00825         SimApduData * GetApduDataPtr() const { return m_apdu_data_ptr; }
00826
00827         enum  {
00828             ID = 1319
00829             };
00830
00831     private:
00832
00833         static void Destroy(StackMsgArgument* arg) { delete ((ExtProactiveCmdReqArg*) arg); }
00834
00835         SimApduData * m_apdu_data_ptr;
00836
00837     };
00838
00839 // Inline definitions
00840 inline const ExtProactiveCmdReqArg& ExtProactiveCmdReqArg::Cast(const StackMsgArgument& arg) {
00841     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ExtProactiveCmdReqArg!\n");
00842     return ((ExtProactiveCmdReqArg &) arg);
00843 }
00844
00845
00846
00847 /*  ======================================================================
00848     Class ExtProactiveCmdCnfArg
00849     ====================================================================== */
00850
00852 class ExtProactiveCmdCnfArg : public StackMsgArgument {
00853     friend class CommonStackMsgArgsDestroyTableNode;
00854     public:
00855         ExtProactiveCmdCnfArg();
00856
00857         static const ExtProactiveCmdCnfArg& Cast(const StackMsgArgument& arg);
00858
00859         enum  {
00860             ID = 1320
00861             };
00862
00863     private:
00864
00865         static void Destroy(StackMsgArgument* arg) { delete ((ExtProactiveCmdCnfArg*) arg); }
00866
00867     };
00868
00869 // Inline definitions
00870 inline const ExtProactiveCmdCnfArg& ExtProactiveCmdCnfArg::Cast(const StackMsgArgument& arg) {
00871     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ExtProactiveCmdCnfArg!\n");
00872     return ((ExtProactiveCmdCnfArg &) arg);
00873 }
00874
00875
00876
00877 /*  ======================================================================
00878     Class TermRspCnfArg
00879     ====================================================================== */
00880
00882 class TermRspCnfArg : public StackMsgArgument {
00883     friend class CommonStackMsgArgsDestroyTableNode;
00884     public:
00885         TermRspCnfArg();
00886
00887         static const TermRspCnfArg& Cast(const StackMsgArgument& arg);
00888         void SetLastStatus(const SimStatusCondition& last_status) { m_last_status = last_status; }
00889         const SimStatusCondition& GetLastStatus() const { return m_last_status; }
00890         void SetFinishedCommand(const Toc& finished_command) { m_finished_command = finished_command; }
00891         const Toc& GetFinishedCommand() const { return m_finished_command; }
00892         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
00893         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
00894
00895         enum  {
00896             ID = 1321
00897             };
00898
00899     private:
00900
00901         static void Destroy(StackMsgArgument* arg) { delete ((TermRspCnfArg*) arg); }
00902
00903         SimStatusCondition m_last_status;
00904         Toc m_finished_command;
00905         ProactiveCause m_proactive_cause;
00906
00907     };
00908
00909 // Inline definitions
00910 inline const TermRspCnfArg& TermRspCnfArg::Cast(const StackMsgArgument& arg) {
00911     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to TermRspCnfArg!\n");
00912     return ((TermRspCnfArg &) arg);
00913 }
00914
00915
00916
00917 /*  ======================================================================
00918     Class SimTkRefreshQueryReqArg
00919     ====================================================================== */
00920
00922 class SimTkRefreshQueryReqArg : public StackMsgArgument {
00923     friend class CommonStackMsgArgsDestroyTableNode;
00924     public:
00925         SimTkRefreshQueryReqArg();
00926
00927         static const SimTkRefreshQueryReqArg& Cast(const StackMsgArgument& arg);
00928         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00929         const SimTkTransactionId& GetTid() const { return m_tid; }
00930         void SetRefreshIndicator(UINT8 refresh_indicator) { m_refresh_indicator = refresh_indicator; }
00931         UINT8 GetRefreshIndicator() const { return m_refresh_indicator; }
00932         void SetEfRefresh(const SimEfRefresh& ef_refresh) { m_ef_refresh = ef_refresh; }
00933         const SimEfRefresh& GetEfRefresh() const { return m_ef_refresh; }
00934
00935         enum  {
00936             ID = 1322
00937             };
00938
00939     private:
00940
00941         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshQueryReqArg*) arg); }
00942
00943         SimTkTransactionId m_tid;
00944         UINT8 m_refresh_indicator;
00945         SimEfRefresh m_ef_refresh;
00946
00947     };
00948
00949 // Inline definitions
00950 inline const SimTkRefreshQueryReqArg& SimTkRefreshQueryReqArg::Cast(const StackMsgArgument& arg) {
00951     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshQueryReqArg!\n");
00952     return ((SimTkRefreshQueryReqArg &) arg);
00953 }
00954
00955
00956
00957 /*  ======================================================================
00958     Class SimTkRefreshCnfReqArg
00959     ====================================================================== */
00960
00962 class SimTkRefreshCnfReqArg : public StackMsgArgument {
00963     friend class CommonStackMsgArgsDestroyTableNode;
00964     public:
00965         SimTkRefreshCnfReqArg();
00966
00967         static const SimTkRefreshCnfReqArg& Cast(const StackMsgArgument& arg);
00968         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00969         const SimTkTransactionId& GetTid() const { return m_tid; }
00970         void SetRefreshPossible(BOOLEAN refresh_possible) { m_refresh_possible = refresh_possible; }
00971         BOOLEAN IsRefreshPossible() const { return m_refresh_possible; }
00972
00973         enum  {
00974             ID = 1323
00975             };
00976
00977     private:
00978
00979         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshCnfReqArg*) arg); }
00980
00981         SimTkTransactionId m_tid;
00982         BOOLEAN m_refresh_possible;
00983
00984     };
00985
00986 // Inline definitions
00987 inline const SimTkRefreshCnfReqArg& SimTkRefreshCnfReqArg::Cast(const StackMsgArgument& arg) {
00988     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshCnfReqArg!\n");
00989     return ((SimTkRefreshCnfReqArg &) arg);
00990 }
00991
00992
00993
00994 /*  ======================================================================
00995     Class SimLaunchBrowserPromptReqArg
00996     ====================================================================== */
00997
00999 class SimLaunchBrowserPromptReqArg : public StackMsgArgument {
01000     friend class CommonStackMsgArgsDestroyTableNode;
01001     public:
01002         SimLaunchBrowserPromptReqArg();
01003
01004         static const SimLaunchBrowserPromptReqArg& Cast(const StackMsgArgument& arg);
01005         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01006         const SimTkTransactionId& GetTid() const { return m_tid; }
01007         void SetUrl(const WString& url) { m_url = url; }
01008         const WString& GetUrl() const { return m_url; }
01009         void SetTextString(const SimAlphaIdentifier& text_string) { m_text_string = text_string; }
01010         const SimAlphaIdentifier& GetTextString() const { return m_text_string; }
01011         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
01012         const SimIconIdentifier& GetIcon() const { return m_icon; }
01013
01014         enum  {
01015             ID = 1324
01016             };
01017
01018     private:
01019
01020         static void Destroy(StackMsgArgument* arg) { delete ((SimLaunchBrowserPromptReqArg*) arg); }
01021
01022         SimTkTransactionId m_tid;
01023         WString m_url;
01024         SimAlphaIdentifier m_text_string;
01025         SimIconIdentifier m_icon;
01026
01027     };
01028
01029 // Inline definitions
01030 inline const SimLaunchBrowserPromptReqArg& SimLaunchBrowserPromptReqArg::Cast(const StackMsgArgument& arg) {
01031     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimLaunchBrowserPromptReqArg!\n");
01032     return ((SimLaunchBrowserPromptReqArg &) arg);
01033 }
01034
01035
01036
01037 /*  ======================================================================
01038     Class SimLaunchBrowserReqArg
01039     ====================================================================== */
01040
01042 class SimLaunchBrowserReqArg : public StackMsgArgument {
01043     friend class CommonStackMsgArgsDestroyTableNode;
01044     public:
01045         SimLaunchBrowserReqArg();
01046
01047         static const SimLaunchBrowserReqArg& Cast(const StackMsgArgument& arg);
01048         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01049         const SimTkTransactionId& GetTid() const { return m_tid; }
01050         void SetCommandDetails(UINT8 command_details) { m_command_details = command_details; }
01051         UINT8 GetCommandDetails() const { return m_command_details; }
01052         void SetBearerList(const SiBearerList& bearer_list) { m_bearer_list = bearer_list; }
01053         const SiBearerList& GetBearerList() const { return m_bearer_list; }
01054         void SetProvisionFileRef(const SiProvFileRef& provision_file_ref) { m_provision_file_ref = provision_file_ref; }
01055         const SiProvFileRef& GetProvisionFileRef() const { return m_provision_file_ref; }
01056         void SetUrl(const WString& url) { m_url = url; }
01057         const WString& GetUrl() const { return m_url; }
01058         void SetGateway(const SimTextString& gateway) { m_gateway = gateway; }
01059         const SimTextString& GetGateway() const { return m_gateway; }
01060
01061         enum  {
01062             ID = 1325
01063             };
01064
01065     private:
01066
01067         static void Destroy(StackMsgArgument* arg) { delete ((SimLaunchBrowserReqArg*) arg); }
01068
01069         SimTkTransactionId m_tid;
01070         UINT8 m_command_details;
01071         SiBearerList m_bearer_list;
01072         SiProvFileRef m_provision_file_ref;
01073         WString m_url;
01074         SimTextString m_gateway;
01075
01076     };
01077
01078 // Inline definitions
01079 inline const SimLaunchBrowserReqArg& SimLaunchBrowserReqArg::Cast(const StackMsgArgument& arg) {
01080     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimLaunchBrowserReqArg!\n");
01081     return ((SimLaunchBrowserReqArg &) arg);
01082 }
01083
01084
01085
01086 /*  ======================================================================
01087     Class SimBrowserTermResArg
01088     ====================================================================== */
01089
01091 class SimBrowserTermResArg : public StackMsgArgument {
01092     friend class CommonStackMsgArgsDestroyTableNode;
01093     public:
01094         SimBrowserTermResArg();
01095
01096         static const SimBrowserTermResArg& Cast(const StackMsgArgument& arg);
01097         void SetSimResult(UINT8 sim_result) { m_sim_result = sim_result; }
01098         UINT8 GetSimResult() const { return m_sim_result; }
01099
01100         enum  {
01101             ID = 1326
01102             };
01103
01104     private:
01105
01106         static void Destroy(StackMsgArgument* arg) { delete ((SimBrowserTermResArg*) arg); }
01107
01108         UINT8 m_sim_result;
01109
01110     };
01111
01112 // Inline definitions
01113 inline const SimBrowserTermResArg& SimBrowserTermResArg::Cast(const StackMsgArgument& arg) {
01114     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimBrowserTermResArg!\n");
01115     return ((SimBrowserTermResArg &) arg);
01116 }
01117
01118
01119
01120 /*  ======================================================================
01121     Class SiChannelOpenPromptReqArg
01122     ====================================================================== */
01123
01125 class SiChannelOpenPromptReqArg : public StackMsgArgument {
01126     friend class CommonStackMsgArgsDestroyTableNode;
01127     public:
01128         SiChannelOpenPromptReqArg();
01129
01130         static const SiChannelOpenPromptReqArg& Cast(const StackMsgArgument& arg);
01131         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01132         const SimTkTransactionId& GetTid() const { return m_tid; }
01133         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01134         UINT8 GetCidx() const { return m_cidx; }
01135         void SetBearerType(const SiBearerType& bearer_type) { m_bearer_type = bearer_type; }
01136         const SiBearerType& GetBearerType() const { return m_bearer_type; }
01137         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
01138         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
01139         void SetSubAddr(const SimSubAddress& sub_addr) { m_sub_addr = sub_addr; }
01140         const SimSubAddress& GetSubAddr() const { return m_sub_addr; }
01141         void SetApn(const WString& apn) { m_apn = apn; }
01142         const WString& GetApn() const { return m_apn; }
01143         void SetText(const WString& text) { m_text = text; }
01144         const WString& GetText() const { return m_text; }
01145         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
01146         const SimIconIdentifier& GetIcon() const { return m_icon; }
01147
01148         enum  {
01149             ID = 1327
01150             };
01151
01152     private:
01153
01154         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelOpenPromptReqArg*) arg); }
01155
01156         SimTkTransactionId m_tid;
01157         UINT8 m_cidx;
01158         SiBearerType m_bearer_type;
01159         PhoneNumber m_phone_number;
01160         SimSubAddress m_sub_addr;
01161         WString m_apn;
01162         WString m_text;
01163         SimIconIdentifier m_icon;
01164
01165     };
01166
01167 // Inline definitions
01168 inline const SiChannelOpenPromptReqArg& SiChannelOpenPromptReqArg::Cast(const StackMsgArgument& arg) {
01169     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelOpenPromptReqArg!\n");
01170     return ((SiChannelOpenPromptReqArg &) arg);
01171 }
01172
01173
01174
01175 /*  ======================================================================
01176     Class SiChannelCloseInfoIndArg
01177     ====================================================================== */
01178
01180 class SiChannelCloseInfoIndArg : public StackMsgArgument {
01181     friend class CommonStackMsgArgsDestroyTableNode;
01182     public:
01183         SiChannelCloseInfoIndArg();
01184
01185         static const SiChannelCloseInfoIndArg& Cast(const StackMsgArgument& arg);
01186         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01187         const SimTkTransactionId& GetTid() const { return m_tid; }
01188         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01189         UINT8 GetCidx() const { return m_cidx; }
01190         void SetCloseCause(const SiChannelCloseCause& close_cause) { m_close_cause = close_cause; }
01191         const SiChannelCloseCause& GetCloseCause() const { return m_close_cause; }
01192         void SetText(const WString& text) { m_text = text; }
01193         const WString& GetText() const { return m_text; }
01194         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
01195         const SimIconIdentifier& GetIcon() const { return m_icon; }
01196
01197         enum  {
01198             ID = 1328
01199             };
01200
01201     private:
01202
01203         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelCloseInfoIndArg*) arg); }
01204
01205         SimTkTransactionId m_tid;
01206         UINT8 m_cidx;
01207         SiChannelCloseCause m_close_cause;
01208         WString m_text;
01209         SimIconIdentifier m_icon;
01210
01211     };
01212
01213 // Inline definitions
01214 inline const SiChannelCloseInfoIndArg& SiChannelCloseInfoIndArg::Cast(const StackMsgArgument& arg) {
01215     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelCloseInfoIndArg!\n");
01216     return ((SiChannelCloseInfoIndArg &) arg);
01217 }
01218
01219
01220
01221 /*  ======================================================================
01222     Class SiChannelSendInfoIndArg
01223     ====================================================================== */
01224
01226 class SiChannelSendInfoIndArg : public StackMsgArgument {
01227     friend class CommonStackMsgArgsDestroyTableNode;
01228     public:
01229         SiChannelSendInfoIndArg();
01230
01231         static const SiChannelSendInfoIndArg& Cast(const StackMsgArgument& arg);
01232         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01233         const SimTkTransactionId& GetTid() const { return m_tid; }
01234         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01235         UINT8 GetCidx() const { return m_cidx; }
01236         void SetChannelDataLength(UINT8 channel_data_length) { m_channel_data_length = channel_data_length; }
01237         UINT8 GetChannelDataLength() const { return m_channel_data_length; }
01238         void SetText(const SimAlphaIdentifier& text) { m_text = text; }
01239         const SimAlphaIdentifier& GetText() const { return m_text; }
01240         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
01241         const SimIconIdentifier& GetIcon() const { return m_icon; }
01242
01243         enum  {
01244             ID = 1329
01245             };
01246
01247     private:
01248
01249         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelSendInfoIndArg*) arg); }
01250
01251         SimTkTransactionId m_tid;
01252         UINT8 m_cidx;
01253         UINT8 m_channel_data_length;
01254         SimAlphaIdentifier m_text;
01255         SimIconIdentifier m_icon;
01256
01257     };
01258
01259 // Inline definitions
01260 inline const SiChannelSendInfoIndArg& SiChannelSendInfoIndArg::Cast(const StackMsgArgument& arg) {
01261     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelSendInfoIndArg!\n");
01262     return ((SiChannelSendInfoIndArg &) arg);
01263 }
01264
01265
01266
01267 /*  ======================================================================
01268     Class SiChannelReceiveInfoIndArg
01269     ====================================================================== */
01270
01272 class SiChannelReceiveInfoIndArg : public StackMsgArgument {
01273     friend class CommonStackMsgArgsDestroyTableNode;
01274     public:
01275         SiChannelReceiveInfoIndArg();
01276
01277         static const SiChannelReceiveInfoIndArg& Cast(const StackMsgArgument& arg);
01278         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01279         const SimTkTransactionId& GetTid() const { return m_tid; }
01280         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01281         UINT8 GetCidx() const { return m_cidx; }
01282         void SetChannelDataLength(UINT8 channel_data_length) { m_channel_data_length = channel_data_length; }
01283         UINT8 GetChannelDataLength() const { return m_channel_data_length; }
01284         void SetText(const SimAlphaIdentifier& text) { m_text = text; }
01285         const SimAlphaIdentifier& GetText() const { return m_text; }
01286         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
01287         const SimIconIdentifier& GetIcon() const { return m_icon; }
01288
01289         enum  {
01290             ID = 1330
01291             };
01292
01293     private:
01294
01295         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelReceiveInfoIndArg*) arg); }
01296
01297         SimTkTransactionId m_tid;
01298         UINT8 m_cidx;
01299         UINT8 m_channel_data_length;
01300         SimAlphaIdentifier m_text;
01301         SimIconIdentifier m_icon;
01302
01303     };
01304
01305 // Inline definitions
01306 inline const SiChannelReceiveInfoIndArg& SiChannelReceiveInfoIndArg::Cast(const StackMsgArgument& arg) {
01307     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelReceiveInfoIndArg!\n");
01308     return ((SiChannelReceiveInfoIndArg &) arg);
01309 }
01310
01311
01312
01313 /*  ======================================================================
01314     Class DhChannelOpenReqArg
01315     ====================================================================== */
01316
01318 class DhChannelOpenReqArg : public StackMsgArgument {
01319     friend class CommonStackMsgArgsDestroyTableNode;
01320     public:
01321         DhChannelOpenReqArg();
01322
01323         static const DhChannelOpenReqArg& Cast(const StackMsgArgument& arg);
01324         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01325         const SimTkTransactionId& GetTid() const { return m_tid; }
01326         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01327         UINT8 GetCidx() const { return m_cidx; }
01328         void SetBufferSize(UINT16 buffer_size) { m_buffer_size = buffer_size; }
01329         UINT16 GetBufferSize() const { return m_buffer_size; }
01330         void SetCmdQualifier(UINT8 cmd_qualifier) { m_cmd_qualifier = cmd_qualifier; }
01331         UINT8 GetCmdQualifier() const { return m_cmd_qualifier; }
01332         void SetTranspLayer(const SiTransportLayer& transp_layer) { m_transp_layer = transp_layer; }
01333         const SiTransportLayer& GetTranspLayer() const { return m_transp_layer; }
01334         void SetPort(UINT16 port) { m_port = port; }
01335         UINT16 GetPort() const { return m_port; }
01336         void SetBearerDesc(const SiBearerDesc& bearer_desc) { m_bearer_desc = bearer_desc; }
01337         const SiBearerDesc& GetBearerDesc() const { return m_bearer_desc; }
01338         void SetLocalIpAddr(const SiIpAddress& local_ip_addr) { m_local_ip_addr = local_ip_addr; }
01339         const SiIpAddress& GetLocalIpAddr() const { return m_local_ip_addr; }
01340         void SetDestIpAddr(const SiIpAddress& dest_ip_addr) { m_dest_ip_addr = dest_ip_addr; }
01341         const SiIpAddress& GetDestIpAddr() const { return m_dest_ip_addr; }
01342         void SetDuration1(const SiDuration& duration1) { m_duration1 = duration1; }
01343         const SiDuration& GetDuration1() const { return m_duration1; }
01344         void SetDuration2(const SiDuration& duration2) { m_duration2 = duration2; }
01345         const SiDuration& GetDuration2() const { return m_duration2; }
01346         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
01347         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
01348         void SetSubAddr(const SimSubAddress& sub_addr) { m_sub_addr = sub_addr; }
01349         const SimSubAddress& GetSubAddr() const { return m_sub_addr; }
01350         void SetUserLogin(const SimTextString& user_login) { m_user_login = user_login; }
01351         const SimTextString& GetUserLogin() const { return m_user_login; }
01352         void SetUserPassword(const SimTextString& user_password) { m_user_password = user_password; }
01353         const SimTextString& GetUserPassword() const { return m_user_password; }
01354         void SetEnablePassword(BOOLEAN enable_password) { m_enable_password = enable_password; }
01355         BOOLEAN IsEnablePassword() const { return m_enable_password; }
01356         void SetApn(const String& apn) { m_apn = apn; }
01357         const String& GetApn() const { return m_apn; }
01358
01359         enum  {
01360             ID = 1331
01361             };
01362
01363     private:
01364
01365         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelOpenReqArg*) arg); }
01366
01367         SimTkTransactionId m_tid;
01368         UINT8 m_cidx;
01369         UINT16 m_buffer_size;
01370         UINT8 m_cmd_qualifier;
01371         SiTransportLayer m_transp_layer;
01372         UINT16 m_port;
01373         SiBearerDesc m_bearer_desc;
01374         SiIpAddress m_local_ip_addr;
01375         SiIpAddress m_dest_ip_addr;
01376         SiDuration m_duration1;
01377         SiDuration m_duration2;
01378         PhoneNumber m_phone_number;
01379         SimSubAddress m_sub_addr;
01380         SimTextString m_user_login;
01381         SimTextString m_user_password;
01382         BOOLEAN m_enable_password;
01383         String m_apn;
01384
01385     };
01386
01387 // Inline definitions
01388 inline const DhChannelOpenReqArg& DhChannelOpenReqArg::Cast(const StackMsgArgument& arg) {
01389     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelOpenReqArg!\n");
01390     return ((DhChannelOpenReqArg &) arg);
01391 }
01392
01393
01394
01395 /*  ======================================================================
01396     Class DhChannelCloseReqArg
01397     ====================================================================== */
01398
01400 class DhChannelCloseReqArg : public StackMsgArgument {
01401     friend class CommonStackMsgArgsDestroyTableNode;
01402     public:
01403         DhChannelCloseReqArg();
01404
01405         static const DhChannelCloseReqArg& Cast(const StackMsgArgument& arg);
01406         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01407         const SimTkTransactionId& GetTid() const { return m_tid; }
01408         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01409         UINT8 GetCidx() const { return m_cidx; }
01410
01411         enum  {
01412             ID = 1332
01413             };
01414
01415     private:
01416
01417         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelCloseReqArg*) arg); }
01418
01419         SimTkTransactionId m_tid;
01420         UINT8 m_cidx;
01421
01422     };
01423
01424 // Inline definitions
01425 inline const DhChannelCloseReqArg& DhChannelCloseReqArg::Cast(const StackMsgArgument& arg) {
01426     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelCloseReqArg!\n");
01427     return ((DhChannelCloseReqArg &) arg);
01428 }
01429
01430
01431
01432 /*  ======================================================================
01433     Class DhChannelSendReqArg
01434     ====================================================================== */
01435
01437 class DhChannelSendReqArg : public StackMsgArgument {
01438     friend class CommonStackMsgArgsDestroyTableNode;
01439     public:
01440         DhChannelSendReqArg();
01441
01442         static const DhChannelSendReqArg& Cast(const StackMsgArgument& arg);
01443         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01444         const SimTkTransactionId& GetTid() const { return m_tid; }
01445         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01446         UINT8 GetCidx() const { return m_cidx; }
01447         void SetSendDataType(const SiSendDataType& send_data_type) { m_send_data_type = send_data_type; }
01448         const SiSendDataType& GetSendDataType() const { return m_send_data_type; }
01449         void SetChannelData(const ChannelData& channel_data) { m_channel_data = channel_data; }
01450         const ChannelData& GetChannelData() const { return m_channel_data; }
01451
01452         enum  {
01453             ID = 1333
01454             };
01455
01456     private:
01457
01458         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelSendReqArg*) arg); }
01459
01460         SimTkTransactionId m_tid;
01461         UINT8 m_cidx;
01462         SiSendDataType m_send_data_type;
01463         ChannelData m_channel_data;
01464
01465     };
01466
01467 // Inline definitions
01468 inline const DhChannelSendReqArg& DhChannelSendReqArg::Cast(const StackMsgArgument& arg) {
01469     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelSendReqArg!\n");
01470     return ((DhChannelSendReqArg &) arg);
01471 }
01472
01473
01474
01475 /*  ======================================================================
01476     Class DhChannelDataAvailableResArg
01477     ====================================================================== */
01478
01480 class DhChannelDataAvailableResArg : public StackMsgArgument {
01481     friend class CommonStackMsgArgsDestroyTableNode;
01482     public:
01483         DhChannelDataAvailableResArg();
01484
01485         static const DhChannelDataAvailableResArg& Cast(const StackMsgArgument& arg);
01486         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01487         const SimTkTransactionId& GetTid() const { return m_tid; }
01488         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01489         UINT8 GetCidx() const { return m_cidx; }
01490         void SetSimResult(UINT8 sim_result) { m_sim_result = sim_result; }
01491         UINT8 GetSimResult() const { return m_sim_result; }
01492
01493         enum  {
01494             ID = 1334
01495             };
01496
01497     private:
01498
01499         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelDataAvailableResArg*) arg); }
01500
01501         SimTkTransactionId m_tid;
01502         UINT8 m_cidx;
01503         UINT8 m_sim_result;
01504
01505     };
01506
01507 // Inline definitions
01508 inline const DhChannelDataAvailableResArg& DhChannelDataAvailableResArg::Cast(const StackMsgArgument& arg) {
01509     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelDataAvailableResArg!\n");
01510     return ((DhChannelDataAvailableResArg &) arg);
01511 }
01512
01513
01514
01515 /*  ======================================================================
01516     Class DhChannelReceiveReqArg
01517     ====================================================================== */
01518
01520 class DhChannelReceiveReqArg : public StackMsgArgument {
01521     friend class CommonStackMsgArgsDestroyTableNode;
01522     public:
01523         DhChannelReceiveReqArg();
01524
01525         static const DhChannelReceiveReqArg& Cast(const StackMsgArgument& arg);
01526         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01527         const SimTkTransactionId& GetTid() const { return m_tid; }
01528         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01529         UINT8 GetCidx() const { return m_cidx; }
01530         void SetChannelDataLength(UINT8 channel_data_length) { m_channel_data_length = channel_data_length; }
01531         UINT8 GetChannelDataLength() const { return m_channel_data_length; }
01532
01533         enum  {
01534             ID = 1335
01535             };
01536
01537     private:
01538
01539         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelReceiveReqArg*) arg); }
01540
01541         SimTkTransactionId m_tid;
01542         UINT8 m_cidx;
01543         UINT8 m_channel_data_length;
01544
01545     };
01546
01547 // Inline definitions
01548 inline const DhChannelReceiveReqArg& DhChannelReceiveReqArg::Cast(const StackMsgArgument& arg) {
01549     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelReceiveReqArg!\n");
01550     return ((DhChannelReceiveReqArg &) arg);
01551 }
01552
01553
01554
01555 /*  ======================================================================
01556     Class DhChannelChangeStatusResArg
01557     ====================================================================== */
01558
01560 class DhChannelChangeStatusResArg : public StackMsgArgument {
01561     friend class CommonStackMsgArgsDestroyTableNode;
01562     public:
01563         DhChannelChangeStatusResArg();
01564
01565         static const DhChannelChangeStatusResArg& Cast(const StackMsgArgument& arg);
01566         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01567         const SimTkTransactionId& GetTid() const { return m_tid; }
01568         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
01569         UINT8 GetCidx() const { return m_cidx; }
01570         void SetSimResult(UINT8 sim_result) { m_sim_result = sim_result; }
01571         UINT8 GetSimResult() const { return m_sim_result; }
01572
01573         enum  {
01574             ID = 1336
01575             };
01576
01577     private:
01578
01579         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelChangeStatusResArg*) arg); }
01580
01581         SimTkTransactionId m_tid;
01582         UINT8 m_cidx;
01583         UINT8 m_sim_result;
01584
01585     };
01586
01587 // Inline definitions
01588 inline const DhChannelChangeStatusResArg& DhChannelChangeStatusResArg::Cast(const StackMsgArgument& arg) {
01589     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelChangeStatusResArg!\n");
01590     return ((DhChannelChangeStatusResArg &) arg);
01591 }
01592
01593
01594
01595 /*  ======================================================================
01596     Class SimTkRunAtCmdInfoIndArg
01597     ====================================================================== */
01598
01600 class SimTkRunAtCmdInfoIndArg : public StackMsgArgument {
01601     friend class CommonStackMsgArgsDestroyTableNode;
01602     public:
01603         SimTkRunAtCmdInfoIndArg();
01604
01605         static const SimTkRunAtCmdInfoIndArg& Cast(const StackMsgArgument& arg);
01606         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01607         const SimTkTransactionId& GetTid() const { return m_tid; }
01608         void SetTextString(const SimAlphaIdentifier& text_string) { m_text_string = text_string; }
01609         const SimAlphaIdentifier& GetTextString() const { return m_text_string; }
01610         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
01611         const SimIconIdentifier& GetIcon() const { return m_icon; }
01612
01613         enum  {
01614             ID = 1340
01615             };
01616
01617     private:
01618
01619         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRunAtCmdInfoIndArg*) arg); }
01620
01621         SimTkTransactionId m_tid;
01622         SimAlphaIdentifier m_text_string;
01623         SimIconIdentifier m_icon;
01624
01625     };
01626
01627 // Inline definitions
01628 inline const SimTkRunAtCmdInfoIndArg& SimTkRunAtCmdInfoIndArg::Cast(const StackMsgArgument& arg) {
01629     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRunAtCmdInfoIndArg!\n");
01630     return ((SimTkRunAtCmdInfoIndArg &) arg);
01631 }
01632
01633
01634
01635 /*  ======================================================================
01636     Class SimTkSendDtmfIndArg
01637     ====================================================================== */
01638
01640 class SimTkSendDtmfIndArg : public StackMsgArgument {
01641     friend class CommonStackMsgArgsDestroyTableNode;
01642     public:
01643         SimTkSendDtmfIndArg();
01644
01645         static const SimTkSendDtmfIndArg& Cast(const StackMsgArgument& arg);
01646         void SetTextString(const SimAlphaIdentifier& text_string) { m_text_string = text_string; }
01647         const SimAlphaIdentifier& GetTextString() const { return m_text_string; }
01648         void SetIcon(const SimIconIdentifier& icon) { m_icon = icon; }
01649         const SimIconIdentifier& GetIcon() const { return m_icon; }
01650
01651         enum  {
01652             ID = 1341
01653             };
01654
01655     private:
01656
01657         static void Destroy(StackMsgArgument* arg) { delete ((SimTkSendDtmfIndArg*) arg); }
01658
01659         SimAlphaIdentifier m_text_string;
01660         SimIconIdentifier m_icon;
01661
01662     };
01663
01664 // Inline definitions
01665 inline const SimTkSendDtmfIndArg& SimTkSendDtmfIndArg::Cast(const StackMsgArgument& arg) {
01666     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkSendDtmfIndArg!\n");
01667     return ((SimTkSendDtmfIndArg &) arg);
01668 }
01669
01670
01671
01672 /*  ======================================================================
01673     Class SimTkSendDtmfEndIndArg
01674     ====================================================================== */
01675
01677 class SimTkSendDtmfEndIndArg : public StackMsgArgument {
01678     friend class CommonStackMsgArgsDestroyTableNode;
01679     public:
01680         SimTkSendDtmfEndIndArg();
01681
01682         static const SimTkSendDtmfEndIndArg& Cast(const StackMsgArgument& arg);
01683         void SetCause(const CallErrorCause& cause) { m_cause = cause; }
01684         const CallErrorCause& GetCause() const { return m_cause; }
01685
01686         enum  {
01687             ID = 1342
01688             };
01689
01690     private:
01691
01692         static void Destroy(StackMsgArgument* arg) { delete ((SimTkSendDtmfEndIndArg*) arg); }
01693
01694         CallErrorCause m_cause;
01695
01696     };
01697
01698 // Inline definitions
01699 inline const SimTkSendDtmfEndIndArg& SimTkSendDtmfEndIndArg::Cast(const StackMsgArgument& arg) {
01700     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkSendDtmfEndIndArg!\n");
01701     return ((SimTkSendDtmfEndIndArg &) arg);
01702 }
01703
01704
01705
01706 /*  ======================================================================
01707     Class SimTkInterfaceIndArg
01708     ====================================================================== */
01709
01711 class SimTkInterfaceIndArg : public StackMsgArgument {
01712     friend class CommonStackMsgArgsDestroyTableNode;
01713     public:
01714         SimTkInterfaceIndArg();
01715
01716         static const SimTkInterfaceIndArg& Cast(const StackMsgArgument& arg);
01717         void SetProcessId(const ProcessId& process_id) { m_process_id = process_id; }
01718         const ProcessId& GetProcessId() const { return m_process_id; }
01719
01720         enum  {
01721             ID = 5300
01722             };
01723
01724     private:
01725
01726         static void Destroy(StackMsgArgument* arg) { delete ((SimTkInterfaceIndArg*) arg); }
01727
01728         ProcessId m_process_id;
01729
01730     };
01731
01732 // Inline definitions
01733 inline const SimTkInterfaceIndArg& SimTkInterfaceIndArg::Cast(const StackMsgArgument& arg) {
01734     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkInterfaceIndArg!\n");
01735     return ((SimTkInterfaceIndArg &) arg);
01736 }
01737
01738
01739
01740 /*  ======================================================================
01741     Class SmsControlIndArg
01742     ====================================================================== */
01743
01745 class SmsControlIndArg : public StackMsgArgument {
01746     friend class CommonStackMsgArgsDestroyTableNode;
01747     public:
01748         SmsControlIndArg();
01749
01750         static const SmsControlIndArg& Cast(const StackMsgArgument& arg);
01751         void SetCallControlResult(const SimCallControlResult& call_control_result) { m_call_control_result = call_control_result; }
01752         const SimCallControlResult& GetCallControlResult() const { return m_call_control_result; }
01753         void SetTextInfoAlpha(const SimAlphaIdentifier& text_info_alpha) { m_text_info_alpha = text_info_alpha; }
01754         const SimAlphaIdentifier& GetTextInfoAlpha() const { return m_text_info_alpha; }
01755         void SetScNumber(const PhoneNumber& sc_number) { m_sc_number = sc_number; }
01756         const PhoneNumber& GetScNumber() const { return m_sc_number; }
01757         void SetDestinationNumber(const PhoneNumber& destination_number) { m_destination_number = destination_number; }
01758         const PhoneNumber& GetDestinationNumber() const { return m_destination_number; }
01759         void SetOrig1TextInfoAlpha(const SimAlphaIdentifier& orig_1_text_info_alpha) { m_orig_1_text_info_alpha = orig_1_text_info_alpha; }
01760         const SimAlphaIdentifier& GetOrig1TextInfoAlpha() const { return m_orig_1_text_info_alpha; }
01761         void SetSimtkRelated(BOOLEAN simtk_related) { m_simtk_related = simtk_related; }
01762         BOOLEAN IsSimtkRelated() const { return m_simtk_related; }
01763
01764         enum  {
01765             ID = 5301
01766             };
01767
01768     private:
01769
01770         static void Destroy(StackMsgArgument* arg) { delete ((SmsControlIndArg*) arg); }
01771
01772         SimCallControlResult m_call_control_result;
01773         SimAlphaIdentifier m_text_info_alpha;
01774         PhoneNumber m_sc_number;
01775         PhoneNumber m_destination_number;
01776         SimAlphaIdentifier m_orig_1_text_info_alpha;
01777         BOOLEAN m_simtk_related;
01778
01779     };
01780
01781 // Inline definitions
01782 inline const SmsControlIndArg& SmsControlIndArg::Cast(const StackMsgArgument& arg) {
01783     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsControlIndArg!\n");
01784     return ((SmsControlIndArg &) arg);
01785 }
01786
01787
01788
01789 /*  ======================================================================
01790     Class CallControlSetupIndArg
01791     ====================================================================== */
01792
01794 class CallControlSetupIndArg : public StackMsgArgument {
01795     friend class CommonStackMsgArgsDestroyTableNode;
01796     public:
01797         CallControlSetupIndArg();
01798
01799         static const CallControlSetupIndArg& Cast(const StackMsgArgument& arg);
01800         void SetCallControlResult(const SimCallControlResult& call_control_result) { m_call_control_result = call_control_result; }
01801         const SimCallControlResult& GetCallControlResult() const { return m_call_control_result; }
01802         void SetTextInfoAlpha(const SimAlphaIdentifier& text_info_alpha) { m_text_info_alpha = text_info_alpha; }
01803         const SimAlphaIdentifier& GetTextInfoAlpha() const { return m_text_info_alpha; }
01804         void SetCalledPartyNumber(const PhoneNumber& called_party_number) { m_called_party_number = called_party_number; }
01805         const PhoneNumber& GetCalledPartyNumber() const { return m_called_party_number; }
01806         void SetOrig1TextInfoAlpha(const SimAlphaIdentifier& orig_1_text_info_alpha) { m_orig_1_text_info_alpha = orig_1_text_info_alpha; }
01807         const SimAlphaIdentifier& GetOrig1TextInfoAlpha() const { return m_orig_1_text_info_alpha; }
01808         void SetOrig2TextInfoAlpha(const SimAlphaIdentifier& orig_2_text_info_alpha) { m_orig_2_text_info_alpha = orig_2_text_info_alpha; }
01809         const SimAlphaIdentifier& GetOrig2TextInfoAlpha() const { return m_orig_2_text_info_alpha; }
01810         void SetSimtkRelated(BOOLEAN simtk_related) { m_simtk_related = simtk_related; }
01811         BOOLEAN IsSimtkRelated() const { return m_simtk_related; }
01812
01813         enum  {
01814             ID = 5302
01815             };
01816
01817     private:
01818
01819         static void Destroy(StackMsgArgument* arg) { delete ((CallControlSetupIndArg*) arg); }
01820
01821         SimCallControlResult m_call_control_result;
01822         SimAlphaIdentifier m_text_info_alpha;
01823         PhoneNumber m_called_party_number;
01824         SimAlphaIdentifier m_orig_1_text_info_alpha;
01825         SimAlphaIdentifier m_orig_2_text_info_alpha;
01826         BOOLEAN m_simtk_related;
01827
01828     };
01829
01830 // Inline definitions
01831 inline const CallControlSetupIndArg& CallControlSetupIndArg::Cast(const StackMsgArgument& arg) {
01832     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallControlSetupIndArg!\n");
01833     return ((CallControlSetupIndArg &) arg);
01834 }
01835
01836
01837
01838 /*  ======================================================================
01839     Class CallControlSsIndArg
01840     ====================================================================== */
01841
01843 class CallControlSsIndArg : public StackMsgArgument {
01844     friend class CommonStackMsgArgsDestroyTableNode;
01845     public:
01846         CallControlSsIndArg();
01847
01848         static const CallControlSsIndArg& Cast(const StackMsgArgument& arg);
01849         void SetCallControlResult(const SimCallControlResult& call_control_result) { m_call_control_result = call_control_result; }
01850         const SimCallControlResult& GetCallControlResult() const { return m_call_control_result; }
01851         void SetTextInfoAlpha(const SimAlphaIdentifier& text_info_alpha) { m_text_info_alpha = text_info_alpha; }
01852         const SimAlphaIdentifier& GetTextInfoAlpha() const { return m_text_info_alpha; }
01853         void SetUserInput(const WString& user_input) { m_user_input = user_input; }
01854         const WString& GetUserInput() const { return m_user_input; }
01855         void SetUserInputLanguage(const DataCodingScheme::Language& user_input_language) { m_user_input_language = user_input_language; }
01856         const DataCodingScheme::Language& GetUserInputLanguage() const { return m_user_input_language; }
01857         void SetOrig1TextInfoAlpha(const SimAlphaIdentifier& orig_1_text_info_alpha) { m_orig_1_text_info_alpha = orig_1_text_info_alpha; }
01858         const SimAlphaIdentifier& GetOrig1TextInfoAlpha() const { return m_orig_1_text_info_alpha; }
01859         void SetSimtkRelated(BOOLEAN simtk_related) { m_simtk_related = simtk_related; }
01860         BOOLEAN IsSimtkRelated() const { return m_simtk_related; }
01861
01862         enum  {
01863             ID = 5303
01864             };
01865
01866     private:
01867
01868         static void Destroy(StackMsgArgument* arg) { delete ((CallControlSsIndArg*) arg); }
01869
01870         SimCallControlResult m_call_control_result;
01871         SimAlphaIdentifier m_text_info_alpha;
01872         WString m_user_input;
01873         DataCodingScheme::Language m_user_input_language;
01874         SimAlphaIdentifier m_orig_1_text_info_alpha;
01875         BOOLEAN m_simtk_related;
01876
01877     };
01878
01879 // Inline definitions
01880 inline const CallControlSsIndArg& CallControlSsIndArg::Cast(const StackMsgArgument& arg) {
01881     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallControlSsIndArg!\n");
01882     return ((CallControlSsIndArg &) arg);
01883 }
01884
01885
01886
01887 /*  ======================================================================
01888     Class CallControlUssdIndArg
01889     ====================================================================== */
01890
01892 class CallControlUssdIndArg : public StackMsgArgument {
01893     friend class CommonStackMsgArgsDestroyTableNode;
01894     public:
01895         CallControlUssdIndArg();
01896
01897         static const CallControlUssdIndArg& Cast(const StackMsgArgument& arg);
01898         void SetCallControlResult(const SimCallControlResult& call_control_result) { m_call_control_result = call_control_result; }
01899         const SimCallControlResult& GetCallControlResult() const { return m_call_control_result; }
01900         void SetTextInfoAlpha(const SimAlphaIdentifier& text_info_alpha) { m_text_info_alpha = text_info_alpha; }
01901         const SimAlphaIdentifier& GetTextInfoAlpha() const { return m_text_info_alpha; }
01902         void SetUserInput(const WString& user_input) { m_user_input = user_input; }
01903         const WString& GetUserInput() const { return m_user_input; }
01904         void SetUserInputLanguage(const DataCodingScheme::Language& user_input_language) { m_user_input_language = user_input_language; }
01905         const DataCodingScheme::Language& GetUserInputLanguage() const { return m_user_input_language; }
01906         void SetOrig1TextInfoAlpha(const SimAlphaIdentifier& orig_1_text_info_alpha) { m_orig_1_text_info_alpha = orig_1_text_info_alpha; }
01907         const SimAlphaIdentifier& GetOrig1TextInfoAlpha() const { return m_orig_1_text_info_alpha; }
01908         void SetSimtkRelated(BOOLEAN simtk_related) { m_simtk_related = simtk_related; }
01909         BOOLEAN IsSimtkRelated() const { return m_simtk_related; }
01910
01911         enum  {
01912             ID = 5304
01913             };
01914
01915     private:
01916
01917         static void Destroy(StackMsgArgument* arg) { delete ((CallControlUssdIndArg*) arg); }
01918
01919         SimCallControlResult m_call_control_result;
01920         SimAlphaIdentifier m_text_info_alpha;
01921         WString m_user_input;
01922         DataCodingScheme::Language m_user_input_language;
01923         SimAlphaIdentifier m_orig_1_text_info_alpha;
01924         BOOLEAN m_simtk_related;
01925
01926     };
01927
01928 // Inline definitions
01929 inline const CallControlUssdIndArg& CallControlUssdIndArg::Cast(const StackMsgArgument& arg) {
01930     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to CallControlUssdIndArg!\n");
01931     return ((CallControlUssdIndArg &) arg);
01932 }
01933
01934
01935
01936 /*  ======================================================================
01937     Class SimTkRefreshNewReqArg
01938     ====================================================================== */
01939
01941 class SimTkRefreshNewReqArg : public StackMsgArgument {
01942     friend class CommonStackMsgArgsDestroyTableNode;
01943     public:
01944         SimTkRefreshNewReqArg();
01945
01946         static const SimTkRefreshNewReqArg& Cast(const StackMsgArgument& arg);
01947         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01948         const SimTkTransactionId& GetTid() const { return m_tid; }
01949         void SetEfRefresh(const SimEfRefresh& ef_refresh) { m_ef_refresh = ef_refresh; }
01950         const SimEfRefresh& GetEfRefresh() const { return m_ef_refresh; }
01951
01952         enum  {
01953             ID = 5305
01954             };
01955
01956     private:
01957
01958         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshNewReqArg*) arg); }
01959
01960         SimTkTransactionId m_tid;
01961         SimEfRefresh m_ef_refresh;
01962
01963     };
01964
01965 // Inline definitions
01966 inline const SimTkRefreshNewReqArg& SimTkRefreshNewReqArg::Cast(const StackMsgArgument& arg) {
01967     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshNewReqArg!\n");
01968     return ((SimTkRefreshNewReqArg &) arg);
01969 }
01970
01971
01972
01973 /*  ======================================================================
01974     Class SimTkSmsPpRspArg
01975     ====================================================================== */
01976
01978 class SimTkSmsPpRspArg : public StackMsgArgument {
01979     friend class CommonStackMsgArgsDestroyTableNode;
01980     public:
01981         SimTkSmsPpRspArg(const ProactiveCause& proactive_cause, const SimReferenceNumber& reference_number);
01982         SimTkSmsPpRspArg();
01983
01984         static const SimTkSmsPpRspArg& Cast(const StackMsgArgument& arg);
01985         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
01986         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
01987         void SetReferenceNumber(const SimReferenceNumber& reference_number) { m_reference_number = reference_number; }
01988         const SimReferenceNumber& GetReferenceNumber() const { return m_reference_number; }
01989
01990         enum  {
01991             ID = 2300
01992             };
01993
01994     private:
01995
01996         static void Destroy(StackMsgArgument* arg) { delete ((SimTkSmsPpRspArg*) arg); }
01997
01998         ProactiveCause m_proactive_cause;
01999         SimReferenceNumber m_reference_number;
02000
02001     };
02002
02003 // Inline definitions
02004 inline const SimTkSmsPpRspArg& SimTkSmsPpRspArg::Cast(const StackMsgArgument& arg) {
02005     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkSmsPpRspArg!\n");
02006     return ((SimTkSmsPpRspArg &) arg);
02007 }
02008
02009
02010
02011 /*  ======================================================================
02012     Class SimTkSsRspArg
02013     ====================================================================== */
02014
02016 class SimTkSsRspArg : public StackMsgArgument {
02017     friend class CommonStackMsgArgsDestroyTableNode;
02018     public:
02019         SimTkSsRspArg(const ProactiveCause& proactive_cause, const SimReferenceNumber& reference_number);
02020         SimTkSsRspArg();
02021
02022         static const SimTkSsRspArg& Cast(const StackMsgArgument& arg);
02023         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02024         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02025         void SetReferenceNumber(const SimReferenceNumber& reference_number) { m_reference_number = reference_number; }
02026         const SimReferenceNumber& GetReferenceNumber() const { return m_reference_number; }
02027
02028         enum  {
02029             ID = 2301
02030             };
02031
02032     private:
02033
02034         static void Destroy(StackMsgArgument* arg) { delete ((SimTkSsRspArg*) arg); }
02035
02036         ProactiveCause m_proactive_cause;
02037         SimReferenceNumber m_reference_number;
02038
02039     };
02040
02041 // Inline definitions
02042 inline const SimTkSsRspArg& SimTkSsRspArg::Cast(const StackMsgArgument& arg) {
02043     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkSsRspArg!\n");
02044     return ((SimTkSsRspArg &) arg);
02045 }
02046
02047
02048
02049 /*  ======================================================================
02050     Class SimTkCallSetupAccArg
02051     ====================================================================== */
02052
02054 class SimTkCallSetupAccArg : public StackMsgArgument {
02055     friend class CommonStackMsgArgsDestroyTableNode;
02056     public:
02057         SimTkCallSetupAccArg(const ProactiveCause& proactive_cause, BOOLEAN ctm);
02058         SimTkCallSetupAccArg();
02059
02060         static const SimTkCallSetupAccArg& Cast(const StackMsgArgument& arg);
02061         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02062         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02063         void SetCtm(BOOLEAN ctm) { m_ctm = ctm; }
02064         BOOLEAN IsCtm() const { return m_ctm; }
02065
02066         enum  {
02067             ID = 2302
02068             };
02069
02070     private:
02071
02072         static void Destroy(StackMsgArgument* arg) { delete ((SimTkCallSetupAccArg*) arg); }
02073
02074         ProactiveCause m_proactive_cause;
02075         BOOLEAN m_ctm;
02076
02077     };
02078
02079 // Inline definitions
02080 inline const SimTkCallSetupAccArg& SimTkCallSetupAccArg::Cast(const StackMsgArgument& arg) {
02081     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkCallSetupAccArg!\n");
02082     return ((SimTkCallSetupAccArg &) arg);
02083 }
02084
02085
02086
02087 /*  ======================================================================
02088     Class SimTkCallSetupRejArg
02089     ====================================================================== */
02090
02092 class SimTkCallSetupRejArg : public StackMsgArgument {
02093     friend class CommonStackMsgArgsDestroyTableNode;
02094     public:
02095         SimTkCallSetupRejArg(const ProactiveCause& proactive_cause);
02096         SimTkCallSetupRejArg();
02097
02098         static const SimTkCallSetupRejArg& Cast(const StackMsgArgument& arg);
02099         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02100         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02101
02102         enum  {
02103             ID = 2303
02104             };
02105
02106     private:
02107
02108         static void Destroy(StackMsgArgument* arg) { delete ((SimTkCallSetupRejArg*) arg); }
02109
02110         ProactiveCause m_proactive_cause;
02111
02112     };
02113
02114 // Inline definitions
02115 inline const SimTkCallSetupRejArg& SimTkCallSetupRejArg::Cast(const StackMsgArgument& arg) {
02116     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkCallSetupRejArg!\n");
02117     return ((SimTkCallSetupRejArg &) arg);
02118 }
02119
02120
02121
02122 /*  ======================================================================
02123     Class SimTkRefreshRspArg
02124     ====================================================================== */
02125
02127 class SimTkRefreshRspArg : public StackMsgArgument {
02128     friend class CommonStackMsgArgsDestroyTableNode;
02129     public:
02130         SimTkRefreshRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
02131         SimTkRefreshRspArg();
02132
02133         static const SimTkRefreshRspArg& Cast(const StackMsgArgument& arg);
02134         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02135         const SimTkTransactionId& GetTid() const { return m_tid; }
02136         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02137         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02138
02139         enum  {
02140             ID = 2304
02141             };
02142
02143     private:
02144
02145         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshRspArg*) arg); }
02146
02147         SimTkTransactionId m_tid;
02148         ProactiveCause m_proactive_cause;
02149
02150     };
02151
02152 // Inline definitions
02153 inline const SimTkRefreshRspArg& SimTkRefreshRspArg::Cast(const StackMsgArgument& arg) {
02154     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshRspArg!\n");
02155     return ((SimTkRefreshRspArg &) arg);
02156 }
02157
02158
02159
02160 /*  ======================================================================
02161     Class SimTkRefreshResetRspArg
02162     ====================================================================== */
02163
02165 class SimTkRefreshResetRspArg : public StackMsgArgument {
02166     friend class CommonStackMsgArgsDestroyTableNode;
02167     public:
02168         SimTkRefreshResetRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
02169         SimTkRefreshResetRspArg();
02170
02171         static const SimTkRefreshResetRspArg& Cast(const StackMsgArgument& arg);
02172         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02173         const SimTkTransactionId& GetTid() const { return m_tid; }
02174         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02175         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02176
02177         enum  {
02178             ID = 2305
02179             };
02180
02181     private:
02182
02183         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshResetRspArg*) arg); }
02184
02185         SimTkTransactionId m_tid;
02186         ProactiveCause m_proactive_cause;
02187
02188     };
02189
02190 // Inline definitions
02191 inline const SimTkRefreshResetRspArg& SimTkRefreshResetRspArg::Cast(const StackMsgArgument& arg) {
02192     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshResetRspArg!\n");
02193     return ((SimTkRefreshResetRspArg &) arg);
02194 }
02195
02196
02197
02198 /*  ======================================================================
02199     Class SimTkResetCnfIndArg
02200     ====================================================================== */
02201
02203 class SimTkResetCnfIndArg : public StackMsgArgument {
02204     friend class CommonStackMsgArgsDestroyTableNode;
02205     public:
02206         SimTkResetCnfIndArg(const SimTkTransactionId& tid);
02207         SimTkResetCnfIndArg();
02208
02209         static const SimTkResetCnfIndArg& Cast(const StackMsgArgument& arg);
02210         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02211         const SimTkTransactionId& GetTid() const { return m_tid; }
02212
02213         enum  {
02214             ID = 2306
02215             };
02216
02217     private:
02218
02219         static void Destroy(StackMsgArgument* arg) { delete ((SimTkResetCnfIndArg*) arg); }
02220
02221         SimTkTransactionId m_tid;
02222
02223     };
02224
02225 // Inline definitions
02226 inline const SimTkResetCnfIndArg& SimTkResetCnfIndArg::Cast(const StackMsgArgument& arg) {
02227     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkResetCnfIndArg!\n");
02228     return ((SimTkResetCnfIndArg &) arg);
02229 }
02230
02231
02232
02233 /*  ======================================================================
02234     Class DisplayTextRspArg
02235     ====================================================================== */
02236
02238 class DisplayTextRspArg : public StackMsgArgument {
02239     friend class CommonStackMsgArgsDestroyTableNode;
02240     public:
02241         DisplayTextRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
02242         DisplayTextRspArg();
02243
02244         static const DisplayTextRspArg& Cast(const StackMsgArgument& arg);
02245         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02246         const SimTkTransactionId& GetTid() const { return m_tid; }
02247         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02248         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02249
02250         enum  {
02251             ID = 2307
02252             };
02253
02254     private:
02255
02256         static void Destroy(StackMsgArgument* arg) { delete ((DisplayTextRspArg*) arg); }
02257
02258         SimTkTransactionId m_tid;
02259         ProactiveCause m_proactive_cause;
02260
02261     };
02262
02263 // Inline definitions
02264 inline const DisplayTextRspArg& DisplayTextRspArg::Cast(const StackMsgArgument& arg) {
02265     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DisplayTextRspArg!\n");
02266     return ((DisplayTextRspArg &) arg);
02267 }
02268
02269
02270
02271 /*  ======================================================================
02272     Class GetInputRspArg
02273     ====================================================================== */
02274
02276 class GetInputRspArg : public StackMsgArgument {
02277     friend class CommonStackMsgArgsDestroyTableNode;
02278     public:
02279         GetInputRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause, const WString& text, const DataCodingScheme& dcs, BOOLEAN packed);
02280         GetInputRspArg();
02281
02282         static const GetInputRspArg& Cast(const StackMsgArgument& arg);
02283         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02284         const SimTkTransactionId& GetTid() const { return m_tid; }
02285         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02286         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02287         void SetText(const WString& text) { m_text = text; }
02288         const WString& GetText() const { return m_text; }
02289         void SetDcs(const DataCodingScheme& dcs) { m_dcs = dcs; }
02290         const DataCodingScheme& GetDcs() const { return m_dcs; }
02291         void SetPacked(BOOLEAN packed) { m_packed = packed; }
02292         BOOLEAN IsPacked() const { return m_packed; }
02293
02294         enum  {
02295             ID = 2308
02296             };
02297
02298     private:
02299
02300         static void Destroy(StackMsgArgument* arg) { delete ((GetInputRspArg*) arg); }
02301
02302         SimTkTransactionId m_tid;
02303         ProactiveCause m_proactive_cause;
02304         WString m_text;
02305         DataCodingScheme m_dcs;
02306         BOOLEAN m_packed;
02307
02308     };
02309
02310 // Inline definitions
02311 inline const GetInputRspArg& GetInputRspArg::Cast(const StackMsgArgument& arg) {
02312     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to GetInputRspArg!\n");
02313     return ((GetInputRspArg &) arg);
02314 }
02315
02316
02317
02318 /*  ======================================================================
02319     Class GetInkeyRspArg
02320     ====================================================================== */
02321
02323 class GetInkeyRspArg : public StackMsgArgument {
02324     friend class CommonStackMsgArgsDestroyTableNode;
02325     public:
02326         GetInkeyRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause, const WString& text, const DataCodingScheme& dcs, const SimKey& key = SimKeyInvalid);
02327         GetInkeyRspArg();
02328
02329         static const GetInkeyRspArg& Cast(const StackMsgArgument& arg);
02330         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02331         const SimTkTransactionId& GetTid() const { return m_tid; }
02332         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02333         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02334         void SetText(const WString& text) { m_text = text; }
02335         const WString& GetText() const { return m_text; }
02336         void SetDcs(const DataCodingScheme& dcs) { m_dcs = dcs; }
02337         const DataCodingScheme& GetDcs() const { return m_dcs; }
02338         void SetKey(const SimKey& key) { m_key = key; }
02339         const SimKey& GetKey() const { return m_key; }
02340
02341         enum  {
02342             ID = 2309
02343             };
02344
02345     private:
02346
02347         static void Destroy(StackMsgArgument* arg) { delete ((GetInkeyRspArg*) arg); }
02348
02349         SimTkTransactionId m_tid;
02350         ProactiveCause m_proactive_cause;
02351         WString m_text;
02352         DataCodingScheme m_dcs;
02353         SimKey m_key;
02354
02355     };
02356
02357 // Inline definitions
02358 inline const GetInkeyRspArg& GetInkeyRspArg::Cast(const StackMsgArgument& arg) {
02359     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to GetInkeyRspArg!\n");
02360     return ((GetInkeyRspArg &) arg);
02361 }
02362
02363
02364
02365 /*  ======================================================================
02366     Class SelectItemRspArg
02367     ====================================================================== */
02368
02370 class SelectItemRspArg : public StackMsgArgument {
02371     friend class CommonStackMsgArgsDestroyTableNode;
02372     public:
02373         SelectItemRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause, const SimItemId& item_id);
02374         SelectItemRspArg();
02375
02376         static const SelectItemRspArg& Cast(const StackMsgArgument& arg);
02377         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02378         const SimTkTransactionId& GetTid() const { return m_tid; }
02379         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02380         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02381         void SetItemId(const SimItemId& item_id) { m_item_id = item_id; }
02382         const SimItemId& GetItemId() const { return m_item_id; }
02383
02384         enum  {
02385             ID = 2310
02386             };
02387
02388     private:
02389
02390         static void Destroy(StackMsgArgument* arg) { delete ((SelectItemRspArg*) arg); }
02391
02392         SimTkTransactionId m_tid;
02393         ProactiveCause m_proactive_cause;
02394         SimItemId m_item_id;
02395
02396     };
02397
02398 // Inline definitions
02399 inline const SelectItemRspArg& SelectItemRspArg::Cast(const StackMsgArgument& arg) {
02400     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SelectItemRspArg!\n");
02401     return ((SelectItemRspArg &) arg);
02402 }
02403
02404
02405
02406 /*  ======================================================================
02407     Class SetupMenuRspArg
02408     ====================================================================== */
02409
02411 class SetupMenuRspArg : public StackMsgArgument {
02412     friend class CommonStackMsgArgsDestroyTableNode;
02413     public:
02414         SetupMenuRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
02415         SetupMenuRspArg();
02416
02417         static const SetupMenuRspArg& Cast(const StackMsgArgument& arg);
02418         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02419         const SimTkTransactionId& GetTid() const { return m_tid; }
02420         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02421         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02422
02423         enum  {
02424             ID = 2311
02425             };
02426
02427     private:
02428
02429         static void Destroy(StackMsgArgument* arg) { delete ((SetupMenuRspArg*) arg); }
02430
02431         SimTkTransactionId m_tid;
02432         ProactiveCause m_proactive_cause;
02433
02434     };
02435
02436 // Inline definitions
02437 inline const SetupMenuRspArg& SetupMenuRspArg::Cast(const StackMsgArgument& arg) {
02438     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SetupMenuRspArg!\n");
02439     return ((SetupMenuRspArg &) arg);
02440 }
02441
02442
02443
02444 /*  ======================================================================
02445     Class MenuSelectionReqArg
02446     ====================================================================== */
02447
02449 class MenuSelectionReqArg : public StackMsgArgument {
02450     friend class CommonStackMsgArgsDestroyTableNode;
02451     public:
02452         MenuSelectionReqArg(const SimItemId& item_id, BOOLEAN info_requested);
02453         MenuSelectionReqArg();
02454
02455         static const MenuSelectionReqArg& Cast(const StackMsgArgument& arg);
02456         void SetItemId(const SimItemId& item_id) { m_item_id = item_id; }
02457         const SimItemId& GetItemId() const { return m_item_id; }
02458         void SetInfoRequested(BOOLEAN info_requested) { m_info_requested = info_requested; }
02459         BOOLEAN IsInfoRequested() const { return m_info_requested; }
02460
02461         enum  {
02462             ID = 2312
02463             };
02464
02465     private:
02466
02467         static void Destroy(StackMsgArgument* arg) { delete ((MenuSelectionReqArg*) arg); }
02468
02469         SimItemId m_item_id;
02470         BOOLEAN m_info_requested;
02471
02472     };
02473
02474 // Inline definitions
02475 inline const MenuSelectionReqArg& MenuSelectionReqArg::Cast(const StackMsgArgument& arg) {
02476     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to MenuSelectionReqArg!\n");
02477     return ((MenuSelectionReqArg &) arg);
02478 }
02479
02480
02481
02482 /*  ======================================================================
02483     Class PlayToneRspArg
02484     ====================================================================== */
02485
02487 class PlayToneRspArg : public StackMsgArgument {
02488     friend class CommonStackMsgArgsDestroyTableNode;
02489     public:
02490         PlayToneRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
02491         PlayToneRspArg();
02492
02493         static const PlayToneRspArg& Cast(const StackMsgArgument& arg);
02494         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02495         const SimTkTransactionId& GetTid() const { return m_tid; }
02496         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02497         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02498
02499         enum  {
02500             ID = 2313
02501             };
02502
02503     private:
02504
02505         static void Destroy(StackMsgArgument* arg) { delete ((PlayToneRspArg*) arg); }
02506
02507         SimTkTransactionId m_tid;
02508         ProactiveCause m_proactive_cause;
02509
02510     };
02511
02512 // Inline definitions
02513 inline const PlayToneRspArg& PlayToneRspArg::Cast(const StackMsgArgument& arg) {
02514     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to PlayToneRspArg!\n");
02515     return ((PlayToneRspArg &) arg);
02516 }
02517
02518
02519
02520 /*  ======================================================================
02521     Class SetupIdleModeTextRspArg
02522     ====================================================================== */
02523
02525 class SetupIdleModeTextRspArg : public StackMsgArgument {
02526     friend class CommonStackMsgArgsDestroyTableNode;
02527     public:
02528         SetupIdleModeTextRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
02529         SetupIdleModeTextRspArg();
02530
02531         static const SetupIdleModeTextRspArg& Cast(const StackMsgArgument& arg);
02532         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02533         const SimTkTransactionId& GetTid() const { return m_tid; }
02534         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02535         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02536
02537         enum  {
02538             ID = 2314
02539             };
02540
02541     private:
02542
02543         static void Destroy(StackMsgArgument* arg) { delete ((SetupIdleModeTextRspArg*) arg); }
02544
02545         SimTkTransactionId m_tid;
02546         ProactiveCause m_proactive_cause;
02547
02548     };
02549
02550 // Inline definitions
02551 inline const SetupIdleModeTextRspArg& SetupIdleModeTextRspArg::Cast(const StackMsgArgument& arg) {
02552     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SetupIdleModeTextRspArg!\n");
02553     return ((SetupIdleModeTextRspArg &) arg);
02554 }
02555
02556
02557
02558 /*  ======================================================================
02559     Class SetupEventCnfArg
02560     ====================================================================== */
02561
02563 class SetupEventCnfArg : public StackMsgArgument {
02564     friend class CommonStackMsgArgsDestroyTableNode;
02565     public:
02566         SetupEventCnfArg(const SimTkTransactionId& tid, BOOLEAN accept);
02567         SetupEventCnfArg();
02568
02569         static const SetupEventCnfArg& Cast(const StackMsgArgument& arg);
02570         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02571         const SimTkTransactionId& GetTid() const { return m_tid; }
02572         void SetAccept(BOOLEAN accept) { m_accept = accept; }
02573         BOOLEAN IsAccept() const { return m_accept; }
02574
02575         enum  {
02576             ID = 2315
02577             };
02578
02579     private:
02580
02581         static void Destroy(StackMsgArgument* arg) { delete ((SetupEventCnfArg*) arg); }
02582
02583         SimTkTransactionId m_tid;
02584         BOOLEAN m_accept;
02585
02586     };
02587
02588 // Inline definitions
02589 inline const SetupEventCnfArg& SetupEventCnfArg::Cast(const StackMsgArgument& arg) {
02590     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SetupEventCnfArg!\n");
02591     return ((SetupEventCnfArg &) arg);
02592 }
02593
02594
02595
02596 /*  ======================================================================
02597     Class UserActivityEventArg
02598     ====================================================================== */
02599
02601 class UserActivityEventArg : public StackMsgArgument {
02602     friend class CommonStackMsgArgsDestroyTableNode;
02603     public:
02604         UserActivityEventArg();
02605
02606         static const UserActivityEventArg& Cast(const StackMsgArgument& arg);
02607
02608         enum  {
02609             ID = 2316
02610             };
02611
02612     private:
02613
02614         static void Destroy(StackMsgArgument* arg) { delete ((UserActivityEventArg*) arg); }
02615
02616     };
02617
02618 // Inline definitions
02619 inline const UserActivityEventArg& UserActivityEventArg::Cast(const StackMsgArgument& arg) {
02620     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UserActivityEventArg!\n");
02621     return ((UserActivityEventArg &) arg);
02622 }
02623
02624
02625
02626 /*  ======================================================================
02627     Class IdleScreenAvailEventArg
02628     ====================================================================== */
02629
02631 class IdleScreenAvailEventArg : public StackMsgArgument {
02632     friend class CommonStackMsgArgsDestroyTableNode;
02633     public:
02634         IdleScreenAvailEventArg();
02635
02636         static const IdleScreenAvailEventArg& Cast(const StackMsgArgument& arg);
02637
02638         enum  {
02639             ID = 2317
02640             };
02641
02642     private:
02643
02644         static void Destroy(StackMsgArgument* arg) { delete ((IdleScreenAvailEventArg*) arg); }
02645
02646     };
02647
02648 // Inline definitions
02649 inline const IdleScreenAvailEventArg& IdleScreenAvailEventArg::Cast(const StackMsgArgument& arg) {
02650     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to IdleScreenAvailEventArg!\n");
02651     return ((IdleScreenAvailEventArg &) arg);
02652 }
02653
02654
02655
02656 /*  ======================================================================
02657     Class LanguageSelectEventArg
02658     ====================================================================== */
02659
02661 class LanguageSelectEventArg : public StackMsgArgument {
02662     friend class CommonStackMsgArgsDestroyTableNode;
02663     public:
02664         LanguageSelectEventArg(const ExtLanguage& ext_language);
02665         LanguageSelectEventArg();
02666
02667         static const LanguageSelectEventArg& Cast(const StackMsgArgument& arg);
02668         void SetExtLanguage(const ExtLanguage& ext_language) { m_ext_language = ext_language; }
02669         const ExtLanguage& GetExtLanguage() const { return m_ext_language; }
02670
02671         enum  {
02672             ID = 2318
02673             };
02674
02675     private:
02676
02677         static void Destroy(StackMsgArgument* arg) { delete ((LanguageSelectEventArg*) arg); }
02678
02679         ExtLanguage m_ext_language;
02680
02681     };
02682
02683 // Inline definitions
02684 inline const LanguageSelectEventArg& LanguageSelectEventArg::Cast(const StackMsgArgument& arg) {
02685     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to LanguageSelectEventArg!\n");
02686     return ((LanguageSelectEventArg &) arg);
02687 }
02688
02689
02690
02691 /*  ======================================================================
02692     Class LanguageSettingIndArg
02693     ====================================================================== */
02694
02696 class LanguageSettingIndArg : public StackMsgArgument {
02697     friend class CommonStackMsgArgsDestroyTableNode;
02698     public:
02699         LanguageSettingIndArg(const ExtLanguage& ext_language);
02700         LanguageSettingIndArg();
02701
02702         static const LanguageSettingIndArg& Cast(const StackMsgArgument& arg);
02703         void SetExtLanguage(const ExtLanguage& ext_language) { m_ext_language = ext_language; }
02704         const ExtLanguage& GetExtLanguage() const { return m_ext_language; }
02705
02706         enum  {
02707             ID = 2319
02708             };
02709
02710     private:
02711
02712         static void Destroy(StackMsgArgument* arg) { delete ((LanguageSettingIndArg*) arg); }
02713
02714         ExtLanguage m_ext_language;
02715
02716     };
02717
02718 // Inline definitions
02719 inline const LanguageSettingIndArg& LanguageSettingIndArg::Cast(const StackMsgArgument& arg) {
02720     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to LanguageSettingIndArg!\n");
02721     return ((LanguageSettingIndArg &) arg);
02722 }
02723
02724
02725
02726 /*  ======================================================================
02727     Class ExtProactiveCmdIndArg
02728     ====================================================================== */
02729
02731 class ExtProactiveCmdIndArg : public StackMsgArgument {
02732     friend class CommonStackMsgArgsDestroyTableNode;
02733     public:
02734         ExtProactiveCmdIndArg(UINT8 result, SimApduData * apdu_data_ptr);
02735         ExtProactiveCmdIndArg();
02736
02737         static const ExtProactiveCmdIndArg& Cast(const StackMsgArgument& arg);
02738         void SetResult(UINT8 result) { m_result = result; }
02739         UINT8 GetResult() const { return m_result; }
02740         void SetApduDataPtr(SimApduData * apdu_data_ptr) { m_apdu_data_ptr = apdu_data_ptr; }
02741         SimApduData * GetApduDataPtr() const { return m_apdu_data_ptr; }
02742
02743         enum  {
02744             ID = 2320
02745             };
02746
02747     private:
02748
02749         static void Destroy(StackMsgArgument* arg) { delete ((ExtProactiveCmdIndArg*) arg); }
02750
02751         UINT8 m_result;
02752         SimApduData * m_apdu_data_ptr;
02753
02754     };
02755
02756 // Inline definitions
02757 inline const ExtProactiveCmdIndArg& ExtProactiveCmdIndArg::Cast(const StackMsgArgument& arg) {
02758     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to ExtProactiveCmdIndArg!\n");
02759     return ((ExtProactiveCmdIndArg &) arg);
02760 }
02761
02762
02763
02764 /*  ======================================================================
02765     Class SimTkRefreshQueryResArg
02766     ====================================================================== */
02767
02769 class SimTkRefreshQueryResArg : public StackMsgArgument {
02770     friend class CommonStackMsgArgsDestroyTableNode;
02771     public:
02772         SimTkRefreshQueryResArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause, UINT8 general_result, UINT8 additional_result);
02773         SimTkRefreshQueryResArg();
02774
02775         static const SimTkRefreshQueryResArg& Cast(const StackMsgArgument& arg);
02776         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02777         const SimTkTransactionId& GetTid() const { return m_tid; }
02778         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02779         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02780         void SetGeneralResult(UINT8 general_result) { m_general_result = general_result; }
02781         UINT8 GetGeneralResult() const { return m_general_result; }
02782         void SetAdditionalResult(UINT8 additional_result) { m_additional_result = additional_result; }
02783         UINT8 GetAdditionalResult() const { return m_additional_result; }
02784
02785         enum  {
02786             ID = 2321
02787             };
02788
02789     private:
02790
02791         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshQueryResArg*) arg); }
02792
02793         SimTkTransactionId m_tid;
02794         ProactiveCause m_proactive_cause;
02795         UINT8 m_general_result;
02796         UINT8 m_additional_result;
02797
02798     };
02799
02800 // Inline definitions
02801 inline const SimTkRefreshQueryResArg& SimTkRefreshQueryResArg::Cast(const StackMsgArgument& arg) {
02802     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshQueryResArg!\n");
02803     return ((SimTkRefreshQueryResArg &) arg);
02804 }
02805
02806
02807
02808 /*  ======================================================================
02809     Class SimTkRefreshCnfIndArg
02810     ====================================================================== */
02811
02813 class SimTkRefreshCnfIndArg : public StackMsgArgument {
02814     friend class CommonStackMsgArgsDestroyTableNode;
02815     public:
02816         SimTkRefreshCnfIndArg(const SimTkTransactionId& tid);
02817         SimTkRefreshCnfIndArg();
02818
02819         static const SimTkRefreshCnfIndArg& Cast(const StackMsgArgument& arg);
02820         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02821         const SimTkTransactionId& GetTid() const { return m_tid; }
02822
02823         enum  {
02824             ID = 2322
02825             };
02826
02827     private:
02828
02829         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshCnfIndArg*) arg); }
02830
02831         SimTkTransactionId m_tid;
02832
02833     };
02834
02835 // Inline definitions
02836 inline const SimTkRefreshCnfIndArg& SimTkRefreshCnfIndArg::Cast(const StackMsgArgument& arg) {
02837     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshCnfIndArg!\n");
02838     return ((SimTkRefreshCnfIndArg &) arg);
02839 }
02840
02841
02842
02843 /*  ======================================================================
02844     Class BrowserRegisterReqArg
02845     ====================================================================== */
02846
02848 class BrowserRegisterReqArg : public StackMsgArgument {
02849     friend class CommonStackMsgArgsDestroyTableNode;
02850     public:
02851         BrowserRegisterReqArg(const SiClientFlags& si_client_flags);
02852         BrowserRegisterReqArg();
02853
02854         static const BrowserRegisterReqArg& Cast(const StackMsgArgument& arg);
02855         void SetSiClientFlags(const SiClientFlags& si_client_flags) { m_si_client_flags = si_client_flags; }
02856         const SiClientFlags& GetSiClientFlags() const { return m_si_client_flags; }
02857
02858         enum  {
02859             ID = 2323
02860             };
02861
02862     private:
02863
02864         static void Destroy(StackMsgArgument* arg) { delete ((BrowserRegisterReqArg*) arg); }
02865
02866         SiClientFlags m_si_client_flags;
02867
02868     };
02869
02870 // Inline definitions
02871 inline const BrowserRegisterReqArg& BrowserRegisterReqArg::Cast(const StackMsgArgument& arg) {
02872     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BrowserRegisterReqArg!\n");
02873     return ((BrowserRegisterReqArg &) arg);
02874 }
02875
02876
02877
02878 /*  ======================================================================
02879     Class LaunchBrowserPromptIndArg
02880     ====================================================================== */
02881
02883 class LaunchBrowserPromptIndArg : public StackMsgArgument {
02884     friend class CommonStackMsgArgsDestroyTableNode;
02885     public:
02886         LaunchBrowserPromptIndArg(const SimTkTransactionId& tid, UINT8 general_result);
02887         LaunchBrowserPromptIndArg();
02888
02889         static const LaunchBrowserPromptIndArg& Cast(const StackMsgArgument& arg);
02890         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02891         const SimTkTransactionId& GetTid() const { return m_tid; }
02892         void SetGeneralResult(UINT8 general_result) { m_general_result = general_result; }
02893         UINT8 GetGeneralResult() const { return m_general_result; }
02894
02895         enum  {
02896             ID = 2324
02897             };
02898
02899     private:
02900
02901         static void Destroy(StackMsgArgument* arg) { delete ((LaunchBrowserPromptIndArg*) arg); }
02902
02903         SimTkTransactionId m_tid;
02904         UINT8 m_general_result;
02905
02906     };
02907
02908 // Inline definitions
02909 inline const LaunchBrowserPromptIndArg& LaunchBrowserPromptIndArg::Cast(const StackMsgArgument& arg) {
02910     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to LaunchBrowserPromptIndArg!\n");
02911     return ((LaunchBrowserPromptIndArg &) arg);
02912 }
02913
02914
02915
02916 /*  ======================================================================
02917     Class LaunchBrowserIndArg
02918     ====================================================================== */
02919
02921 class LaunchBrowserIndArg : public StackMsgArgument {
02922     friend class CommonStackMsgArgsDestroyTableNode;
02923     public:
02924         LaunchBrowserIndArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
02925         LaunchBrowserIndArg();
02926
02927         static const LaunchBrowserIndArg& Cast(const StackMsgArgument& arg);
02928         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
02929         const SimTkTransactionId& GetTid() const { return m_tid; }
02930         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
02931         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
02932
02933         enum  {
02934             ID = 2325
02935             };
02936
02937     private:
02938
02939         static void Destroy(StackMsgArgument* arg) { delete ((LaunchBrowserIndArg*) arg); }
02940
02941         SimTkTransactionId m_tid;
02942         ProactiveCause m_proactive_cause;
02943
02944     };
02945
02946 // Inline definitions
02947 inline const LaunchBrowserIndArg& LaunchBrowserIndArg::Cast(const StackMsgArgument& arg) {
02948     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to LaunchBrowserIndArg!\n");
02949     return ((LaunchBrowserIndArg &) arg);
02950 }
02951
02952
02953
02954 /*  ======================================================================
02955     Class BrowserTermEventArg
02956     ====================================================================== */
02957
02959 class BrowserTermEventArg : public StackMsgArgument {
02960     friend class CommonStackMsgArgsDestroyTableNode;
02961     public:
02962         BrowserTermEventArg(UINT8 term_cause);
02963         BrowserTermEventArg();
02964
02965         static const BrowserTermEventArg& Cast(const StackMsgArgument& arg);
02966         void SetTermCause(UINT8 term_cause) { m_term_cause = term_cause; }
02967         UINT8 GetTermCause() const { return m_term_cause; }
02968
02969         enum  {
02970             ID = 2326
02971             };
02972
02973     private:
02974
02975         static void Destroy(StackMsgArgument* arg) { delete ((BrowserTermEventArg*) arg); }
02976
02977         UINT8 m_term_cause;
02978
02979     };
02980
02981 // Inline definitions
02982 inline const BrowserTermEventArg& BrowserTermEventArg::Cast(const StackMsgArgument& arg) {
02983     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BrowserTermEventArg!\n");
02984     return ((BrowserTermEventArg &) arg);
02985 }
02986
02987
02988
02989 /*  ======================================================================
02990     Class SiChannelOpenPromptResArg
02991     ====================================================================== */
02992
02994 class SiChannelOpenPromptResArg : public StackMsgArgument {
02995     friend class CommonStackMsgArgsDestroyTableNode;
02996     public:
02997         SiChannelOpenPromptResArg(const SimTkTransactionId& tid, const GenResultCode& gen_result);
02998         SiChannelOpenPromptResArg();
02999
03000         static const SiChannelOpenPromptResArg& Cast(const StackMsgArgument& arg);
03001         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03002         const SimTkTransactionId& GetTid() const { return m_tid; }
03003         void SetGenResult(const GenResultCode& gen_result) { m_gen_result = gen_result; }
03004         const GenResultCode& GetGenResult() const { return m_gen_result; }
03005
03006         enum  {
03007             ID = 2327
03008             };
03009
03010     private:
03011
03012         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelOpenPromptResArg*) arg); }
03013
03014         SimTkTransactionId m_tid;
03015         GenResultCode m_gen_result;
03016
03017     };
03018
03019 // Inline definitions
03020 inline const SiChannelOpenPromptResArg& SiChannelOpenPromptResArg::Cast(const StackMsgArgument& arg) {
03021     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelOpenPromptResArg!\n");
03022     return ((SiChannelOpenPromptResArg &) arg);
03023 }
03024
03025
03026
03027 /*  ======================================================================
03028     Class SiChannelCloseReqArg
03029     ====================================================================== */
03030
03032 class SiChannelCloseReqArg : public StackMsgArgument {
03033     friend class CommonStackMsgArgsDestroyTableNode;
03034     public:
03035         SiChannelCloseReqArg(const SimTkTransactionId& tid, UINT8 cidx);
03036         SiChannelCloseReqArg();
03037
03038         static const SiChannelCloseReqArg& Cast(const StackMsgArgument& arg);
03039         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03040         const SimTkTransactionId& GetTid() const { return m_tid; }
03041         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03042         UINT8 GetCidx() const { return m_cidx; }
03043
03044         enum  {
03045             ID = 2328
03046             };
03047
03048     private:
03049
03050         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelCloseReqArg*) arg); }
03051
03052         SimTkTransactionId m_tid;
03053         UINT8 m_cidx;
03054
03055     };
03056
03057 // Inline definitions
03058 inline const SiChannelCloseReqArg& SiChannelCloseReqArg::Cast(const StackMsgArgument& arg) {
03059     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelCloseReqArg!\n");
03060     return ((SiChannelCloseReqArg &) arg);
03061 }
03062
03063
03064
03065 /*  ======================================================================
03066     Class SiChannelCloseInfoResArg
03067     ====================================================================== */
03068
03070 class SiChannelCloseInfoResArg : public StackMsgArgument {
03071     friend class CommonStackMsgArgsDestroyTableNode;
03072     public:
03073         SiChannelCloseInfoResArg(const SimTkTransactionId& tid, UINT8 cidx, const GenResultCode& gen_result);
03074         SiChannelCloseInfoResArg();
03075
03076         static const SiChannelCloseInfoResArg& Cast(const StackMsgArgument& arg);
03077         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03078         const SimTkTransactionId& GetTid() const { return m_tid; }
03079         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03080         UINT8 GetCidx() const { return m_cidx; }
03081         void SetGenResult(const GenResultCode& gen_result) { m_gen_result = gen_result; }
03082         const GenResultCode& GetGenResult() const { return m_gen_result; }
03083
03084         enum  {
03085             ID = 2329
03086             };
03087
03088     private:
03089
03090         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelCloseInfoResArg*) arg); }
03091
03092         SimTkTransactionId m_tid;
03093         UINT8 m_cidx;
03094         GenResultCode m_gen_result;
03095
03096     };
03097
03098 // Inline definitions
03099 inline const SiChannelCloseInfoResArg& SiChannelCloseInfoResArg::Cast(const StackMsgArgument& arg) {
03100     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelCloseInfoResArg!\n");
03101     return ((SiChannelCloseInfoResArg &) arg);
03102 }
03103
03104
03105
03106 /*  ======================================================================
03107     Class SiChannelSendInfoResArg
03108     ====================================================================== */
03109
03111 class SiChannelSendInfoResArg : public StackMsgArgument {
03112     friend class CommonStackMsgArgsDestroyTableNode;
03113     public:
03114         SiChannelSendInfoResArg(const SimTkTransactionId& tid, UINT8 cidx, const GenResultCode& gen_result);
03115         SiChannelSendInfoResArg();
03116
03117         static const SiChannelSendInfoResArg& Cast(const StackMsgArgument& arg);
03118         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03119         const SimTkTransactionId& GetTid() const { return m_tid; }
03120         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03121         UINT8 GetCidx() const { return m_cidx; }
03122         void SetGenResult(const GenResultCode& gen_result) { m_gen_result = gen_result; }
03123         const GenResultCode& GetGenResult() const { return m_gen_result; }
03124
03125         enum  {
03126             ID = 2330
03127             };
03128
03129     private:
03130
03131         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelSendInfoResArg*) arg); }
03132
03133         SimTkTransactionId m_tid;
03134         UINT8 m_cidx;
03135         GenResultCode m_gen_result;
03136
03137     };
03138
03139 // Inline definitions
03140 inline const SiChannelSendInfoResArg& SiChannelSendInfoResArg::Cast(const StackMsgArgument& arg) {
03141     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelSendInfoResArg!\n");
03142     return ((SiChannelSendInfoResArg &) arg);
03143 }
03144
03145
03146
03147 /*  ======================================================================
03148     Class SiChannelReceiveInfoResArg
03149     ====================================================================== */
03150
03152 class SiChannelReceiveInfoResArg : public StackMsgArgument {
03153     friend class CommonStackMsgArgsDestroyTableNode;
03154     public:
03155         SiChannelReceiveInfoResArg(const SimTkTransactionId& tid, UINT8 cidx, const GenResultCode& gen_result);
03156         SiChannelReceiveInfoResArg();
03157
03158         static const SiChannelReceiveInfoResArg& Cast(const StackMsgArgument& arg);
03159         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03160         const SimTkTransactionId& GetTid() const { return m_tid; }
03161         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03162         UINT8 GetCidx() const { return m_cidx; }
03163         void SetGenResult(const GenResultCode& gen_result) { m_gen_result = gen_result; }
03164         const GenResultCode& GetGenResult() const { return m_gen_result; }
03165
03166         enum  {
03167             ID = 2331
03168             };
03169
03170     private:
03171
03172         static void Destroy(StackMsgArgument* arg) { delete ((SiChannelReceiveInfoResArg*) arg); }
03173
03174         SimTkTransactionId m_tid;
03175         UINT8 m_cidx;
03176         GenResultCode m_gen_result;
03177
03178     };
03179
03180 // Inline definitions
03181 inline const SiChannelReceiveInfoResArg& SiChannelReceiveInfoResArg::Cast(const StackMsgArgument& arg) {
03182     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SiChannelReceiveInfoResArg!\n");
03183     return ((SiChannelReceiveInfoResArg &) arg);
03184 }
03185
03186
03187
03188 /*  ======================================================================
03189     Class DhChannelOpenCnfArg
03190     ====================================================================== */
03191
03193 class DhChannelOpenCnfArg : public StackMsgArgument {
03194     friend class CommonStackMsgArgsDestroyTableNode;
03195     public:
03196         DhChannelOpenCnfArg(const SimTkTransactionId& tid, UINT8 cidx, UINT16 buffer_size, const SiBearerDesc& bearer_desc, UINT8 gen_result, UINT8 adn_result);
03197         DhChannelOpenCnfArg();
03198
03199         static const DhChannelOpenCnfArg& Cast(const StackMsgArgument& arg);
03200         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03201         const SimTkTransactionId& GetTid() const { return m_tid; }
03202         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03203         UINT8 GetCidx() const { return m_cidx; }
03204         void SetBufferSize(UINT16 buffer_size) { m_buffer_size = buffer_size; }
03205         UINT16 GetBufferSize() const { return m_buffer_size; }
03206         void SetBearerDesc(const SiBearerDesc& bearer_desc) { m_bearer_desc = bearer_desc; }
03207         const SiBearerDesc& GetBearerDesc() const { return m_bearer_desc; }
03208         void SetGenResult(UINT8 gen_result) { m_gen_result = gen_result; }
03209         UINT8 GetGenResult() const { return m_gen_result; }
03210         void SetAdnResult(UINT8 adn_result) { m_adn_result = adn_result; }
03211         UINT8 GetAdnResult() const { return m_adn_result; }
03212
03213         enum  {
03214             ID = 2332
03215             };
03216
03217     private:
03218
03219         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelOpenCnfArg*) arg); }
03220
03221         SimTkTransactionId m_tid;
03222         UINT8 m_cidx;
03223         UINT16 m_buffer_size;
03224         SiBearerDesc m_bearer_desc;
03225         UINT8 m_gen_result;
03226         UINT8 m_adn_result;
03227
03228     };
03229
03230 // Inline definitions
03231 inline const DhChannelOpenCnfArg& DhChannelOpenCnfArg::Cast(const StackMsgArgument& arg) {
03232     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelOpenCnfArg!\n");
03233     return ((DhChannelOpenCnfArg &) arg);
03234 }
03235
03236
03237
03238 /*  ======================================================================
03239     Class DhChannelOpenRejArg
03240     ====================================================================== */
03241
03243 class DhChannelOpenRejArg : public StackMsgArgument {
03244     friend class CommonStackMsgArgsDestroyTableNode;
03245     public:
03246         DhChannelOpenRejArg(const SimTkTransactionId& tid, UINT8 cidx, UINT8 gen_result, UINT8 adn_result);
03247         DhChannelOpenRejArg();
03248
03249         static const DhChannelOpenRejArg& Cast(const StackMsgArgument& arg);
03250         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03251         const SimTkTransactionId& GetTid() const { return m_tid; }
03252         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03253         UINT8 GetCidx() const { return m_cidx; }
03254         void SetGenResult(UINT8 gen_result) { m_gen_result = gen_result; }
03255         UINT8 GetGenResult() const { return m_gen_result; }
03256         void SetAdnResult(UINT8 adn_result) { m_adn_result = adn_result; }
03257         UINT8 GetAdnResult() const { return m_adn_result; }
03258
03259         enum  {
03260             ID = 2333
03261             };
03262
03263     private:
03264
03265         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelOpenRejArg*) arg); }
03266
03267         SimTkTransactionId m_tid;
03268         UINT8 m_cidx;
03269         UINT8 m_gen_result;
03270         UINT8 m_adn_result;
03271
03272     };
03273
03274 // Inline definitions
03275 inline const DhChannelOpenRejArg& DhChannelOpenRejArg::Cast(const StackMsgArgument& arg) {
03276     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelOpenRejArg!\n");
03277     return ((DhChannelOpenRejArg &) arg);
03278 }
03279
03280
03281
03282 /*  ======================================================================
03283     Class DhChannelCloseIndArg
03284     ====================================================================== */
03285
03287 class DhChannelCloseIndArg : public StackMsgArgument {
03288     friend class CommonStackMsgArgsDestroyTableNode;
03289     public:
03290         DhChannelCloseIndArg(const SimTkTransactionId& tid, UINT8 cidx, UINT8 gen_result, UINT8 adn_result);
03291         DhChannelCloseIndArg();
03292
03293         static const DhChannelCloseIndArg& Cast(const StackMsgArgument& arg);
03294         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03295         const SimTkTransactionId& GetTid() const { return m_tid; }
03296         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03297         UINT8 GetCidx() const { return m_cidx; }
03298         void SetGenResult(UINT8 gen_result) { m_gen_result = gen_result; }
03299         UINT8 GetGenResult() const { return m_gen_result; }
03300         void SetAdnResult(UINT8 adn_result) { m_adn_result = adn_result; }
03301         UINT8 GetAdnResult() const { return m_adn_result; }
03302
03303         enum  {
03304             ID = 2334
03305             };
03306
03307     private:
03308
03309         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelCloseIndArg*) arg); }
03310
03311         SimTkTransactionId m_tid;
03312         UINT8 m_cidx;
03313         UINT8 m_gen_result;
03314         UINT8 m_adn_result;
03315
03316     };
03317
03318 // Inline definitions
03319 inline const DhChannelCloseIndArg& DhChannelCloseIndArg::Cast(const StackMsgArgument& arg) {
03320     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelCloseIndArg!\n");
03321     return ((DhChannelCloseIndArg &) arg);
03322 }
03323
03324
03325
03326 /*  ======================================================================
03327     Class DhChannelSendIndArg
03328     ====================================================================== */
03329
03331 class DhChannelSendIndArg : public StackMsgArgument {
03332     friend class CommonStackMsgArgsDestroyTableNode;
03333     public:
03334         DhChannelSendIndArg(const SimTkTransactionId& tid, UINT8 cidx, UINT16 empty_bytes_in_tx, UINT8 gen_result, UINT8 adn_result);
03335         DhChannelSendIndArg();
03336
03337         static const DhChannelSendIndArg& Cast(const StackMsgArgument& arg);
03338         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03339         const SimTkTransactionId& GetTid() const { return m_tid; }
03340         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03341         UINT8 GetCidx() const { return m_cidx; }
03342         void SetEmptyBytesInTx(UINT16 empty_bytes_in_tx) { m_empty_bytes_in_tx = empty_bytes_in_tx; }
03343         UINT16 GetEmptyBytesInTx() const { return m_empty_bytes_in_tx; }
03344         void SetGenResult(UINT8 gen_result) { m_gen_result = gen_result; }
03345         UINT8 GetGenResult() const { return m_gen_result; }
03346         void SetAdnResult(UINT8 adn_result) { m_adn_result = adn_result; }
03347         UINT8 GetAdnResult() const { return m_adn_result; }
03348
03349         enum  {
03350             ID = 2335
03351             };
03352
03353     private:
03354
03355         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelSendIndArg*) arg); }
03356
03357         SimTkTransactionId m_tid;
03358         UINT8 m_cidx;
03359         UINT16 m_empty_bytes_in_tx;
03360         UINT8 m_gen_result;
03361         UINT8 m_adn_result;
03362
03363     };
03364
03365 // Inline definitions
03366 inline const DhChannelSendIndArg& DhChannelSendIndArg::Cast(const StackMsgArgument& arg) {
03367     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelSendIndArg!\n");
03368     return ((DhChannelSendIndArg &) arg);
03369 }
03370
03371
03372
03373 /*  ======================================================================
03374     Class DhChannelDataAvailEventArg
03375     ====================================================================== */
03376
03378 class DhChannelDataAvailEventArg : public StackMsgArgument {
03379     friend class CommonStackMsgArgsDestroyTableNode;
03380     public:
03381         DhChannelDataAvailEventArg(const SimTkTransactionId& tid, UINT8 cidx, UINT16 channel_data_length, const SiChannelChangedState& changed_state);
03382         DhChannelDataAvailEventArg();
03383
03384         static const DhChannelDataAvailEventArg& Cast(const StackMsgArgument& arg);
03385         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03386         const SimTkTransactionId& GetTid() const { return m_tid; }
03387         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03388         UINT8 GetCidx() const { return m_cidx; }
03389         void SetChannelDataLength(UINT16 channel_data_length) { m_channel_data_length = channel_data_length; }
03390         UINT16 GetChannelDataLength() const { return m_channel_data_length; }
03391         void SetChangedState(const SiChannelChangedState& changed_state) { m_changed_state = changed_state; }
03392         const SiChannelChangedState& GetChangedState() const { return m_changed_state; }
03393
03394         enum  {
03395             ID = 2369
03396             };
03397
03398     private:
03399
03400         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelDataAvailEventArg*) arg); }
03401
03402         SimTkTransactionId m_tid;
03403         UINT8 m_cidx;
03404         UINT16 m_channel_data_length;
03405         SiChannelChangedState m_changed_state;
03406
03407     };
03408
03409 // Inline definitions
03410 inline const DhChannelDataAvailEventArg& DhChannelDataAvailEventArg::Cast(const StackMsgArgument& arg) {
03411     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelDataAvailEventArg!\n");
03412     return ((DhChannelDataAvailEventArg &) arg);
03413 }
03414
03415
03416
03417 /*  ======================================================================
03418     Class DhChannelReceiveIndArg
03419     ====================================================================== */
03420
03422 class DhChannelReceiveIndArg : public StackMsgArgument {
03423     friend class CommonStackMsgArgsDestroyTableNode;
03424     public:
03425         DhChannelReceiveIndArg(const SimTkTransactionId& tid, UINT8 cidx, UINT16 remaining_data_length, UINT8 gen_result, UINT8 adn_result, const ChannelData& channel_data);
03426         DhChannelReceiveIndArg();
03427
03428         static const DhChannelReceiveIndArg& Cast(const StackMsgArgument& arg);
03429         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03430         const SimTkTransactionId& GetTid() const { return m_tid; }
03431         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03432         UINT8 GetCidx() const { return m_cidx; }
03433         void SetRemainingDataLength(UINT16 remaining_data_length) { m_remaining_data_length = remaining_data_length; }
03434         UINT16 GetRemainingDataLength() const { return m_remaining_data_length; }
03435         void SetGenResult(UINT8 gen_result) { m_gen_result = gen_result; }
03436         UINT8 GetGenResult() const { return m_gen_result; }
03437         void SetAdnResult(UINT8 adn_result) { m_adn_result = adn_result; }
03438         UINT8 GetAdnResult() const { return m_adn_result; }
03439         void SetChannelData(const ChannelData& channel_data) { m_channel_data = channel_data; }
03440         const ChannelData& GetChannelData() const { return m_channel_data; }
03441
03442         enum  {
03443             ID = 2367
03444             };
03445
03446     private:
03447
03448         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelReceiveIndArg*) arg); }
03449
03450         SimTkTransactionId m_tid;
03451         UINT8 m_cidx;
03452         UINT16 m_remaining_data_length;
03453         UINT8 m_gen_result;
03454         UINT8 m_adn_result;
03455         ChannelData m_channel_data;
03456
03457     };
03458
03459 // Inline definitions
03460 inline const DhChannelReceiveIndArg& DhChannelReceiveIndArg::Cast(const StackMsgArgument& arg) {
03461     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelReceiveIndArg!\n");
03462     return ((DhChannelReceiveIndArg &) arg);
03463 }
03464
03465
03466
03467 /*  ======================================================================
03468     Class DhChannelChangeStatusEventArg
03469     ====================================================================== */
03470
03472 class DhChannelChangeStatusEventArg : public StackMsgArgument {
03473     friend class CommonStackMsgArgsDestroyTableNode;
03474     public:
03475         DhChannelChangeStatusEventArg(const SimTkTransactionId& tid, UINT8 cidx, const SiChannelChangedState& changed_state);
03476         DhChannelChangeStatusEventArg();
03477
03478         static const DhChannelChangeStatusEventArg& Cast(const StackMsgArgument& arg);
03479         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03480         const SimTkTransactionId& GetTid() const { return m_tid; }
03481         void SetCidx(UINT8 cidx) { m_cidx = cidx; }
03482         UINT8 GetCidx() const { return m_cidx; }
03483         void SetChangedState(const SiChannelChangedState& changed_state) { m_changed_state = changed_state; }
03484         const SiChannelChangedState& GetChangedState() const { return m_changed_state; }
03485
03486         enum  {
03487             ID = 2368
03488             };
03489
03490     private:
03491
03492         static void Destroy(StackMsgArgument* arg) { delete ((DhChannelChangeStatusEventArg*) arg); }
03493
03494         SimTkTransactionId m_tid;
03495         UINT8 m_cidx;
03496         SiChannelChangedState m_changed_state;
03497
03498     };
03499
03500 // Inline definitions
03501 inline const DhChannelChangeStatusEventArg& DhChannelChangeStatusEventArg::Cast(const StackMsgArgument& arg) {
03502     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to DhChannelChangeStatusEventArg!\n");
03503     return ((DhChannelChangeStatusEventArg &) arg);
03504 }
03505
03506
03507
03508 /*  ======================================================================
03509     Class SimTkRunAtCmdInfoResArg
03510     ====================================================================== */
03511
03513 class SimTkRunAtCmdInfoResArg : public StackMsgArgument {
03514     friend class CommonStackMsgArgsDestroyTableNode;
03515     public:
03516         SimTkRunAtCmdInfoResArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
03517         SimTkRunAtCmdInfoResArg();
03518
03519         static const SimTkRunAtCmdInfoResArg& Cast(const StackMsgArgument& arg);
03520         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03521         const SimTkTransactionId& GetTid() const { return m_tid; }
03522         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
03523         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
03524
03525         enum  {
03526             ID = 2380
03527             };
03528
03529     private:
03530
03531         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRunAtCmdInfoResArg*) arg); }
03532
03533         SimTkTransactionId m_tid;
03534         ProactiveCause m_proactive_cause;
03535
03536     };
03537
03538 // Inline definitions
03539 inline const SimTkRunAtCmdInfoResArg& SimTkRunAtCmdInfoResArg::Cast(const StackMsgArgument& arg) {
03540     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRunAtCmdInfoResArg!\n");
03541     return ((SimTkRunAtCmdInfoResArg &) arg);
03542 }
03543
03544
03545
03546 /*  ======================================================================
03547     Class SimTkSendDtmfCnfArg
03548     ====================================================================== */
03549
03551 class SimTkSendDtmfCnfArg : public StackMsgArgument {
03552     friend class CommonStackMsgArgsDestroyTableNode;
03553     public:
03554         SimTkSendDtmfCnfArg(const ProactiveCause& proactive_cause);
03555         SimTkSendDtmfCnfArg();
03556
03557         static const SimTkSendDtmfCnfArg& Cast(const StackMsgArgument& arg);
03558         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
03559         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
03560
03561         enum  {
03562             ID = 2381
03563             };
03564
03565     private:
03566
03567         static void Destroy(StackMsgArgument* arg) { delete ((SimTkSendDtmfCnfArg*) arg); }
03568
03569         ProactiveCause m_proactive_cause;
03570
03571     };
03572
03573 // Inline definitions
03574 inline const SimTkSendDtmfCnfArg& SimTkSendDtmfCnfArg::Cast(const StackMsgArgument& arg) {
03575     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkSendDtmfCnfArg!\n");
03576     return ((SimTkSendDtmfCnfArg &) arg);
03577 }
03578
03579
03580
03581 /*  ======================================================================
03582     Class SimTkStopSendDtmfReqArg
03583     ====================================================================== */
03584
03586 class SimTkStopSendDtmfReqArg : public StackMsgArgument {
03587     friend class CommonStackMsgArgsDestroyTableNode;
03588     public:
03589         SimTkStopSendDtmfReqArg();
03590
03591         static const SimTkStopSendDtmfReqArg& Cast(const StackMsgArgument& arg);
03592
03593         enum  {
03594             ID = 2382
03595             };
03596
03597     private:
03598
03599         static void Destroy(StackMsgArgument* arg) { delete ((SimTkStopSendDtmfReqArg*) arg); }
03600
03601     };
03602
03603 // Inline definitions
03604 inline const SimTkStopSendDtmfReqArg& SimTkStopSendDtmfReqArg::Cast(const StackMsgArgument& arg) {
03605     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkStopSendDtmfReqArg!\n");
03606     return ((SimTkStopSendDtmfReqArg &) arg);
03607 }
03608
03609
03610
03611 /*  ======================================================================
03612     Class SimTkRefreshNewRspArg
03613     ====================================================================== */
03614
03616 class SimTkRefreshNewRspArg : public StackMsgArgument {
03617     friend class CommonStackMsgArgsDestroyTableNode;
03618     public:
03619         SimTkRefreshNewRspArg(const SimTkTransactionId& tid, const ProactiveCause& proactive_cause);
03620         SimTkRefreshNewRspArg();
03621
03622         static const SimTkRefreshNewRspArg& Cast(const StackMsgArgument& arg);
03623         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
03624         const SimTkTransactionId& GetTid() const { return m_tid; }
03625         void SetProactiveCause(const ProactiveCause& proactive_cause) { m_proactive_cause = proactive_cause; }
03626         const ProactiveCause& GetProactiveCause() const { return m_proactive_cause; }
03627
03628         enum  {
03629             ID = 2383
03630             };
03631
03632     private:
03633
03634         static void Destroy(StackMsgArgument* arg) { delete ((SimTkRefreshNewRspArg*) arg); }
03635
03636         SimTkTransactionId m_tid;
03637         ProactiveCause m_proactive_cause;
03638
03639     };
03640
03641 // Inline definitions
03642 inline const SimTkRefreshNewRspArg& SimTkRefreshNewRspArg::Cast(const StackMsgArgument& arg) {
03643     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SimTkRefreshNewRspArg!\n");
03644     return ((SimTkRefreshNewRspArg &) arg);
03645 }
03646
03647
03648 #endif // Apc_SimTkStackMsgArgs_hpp
03649
Generated on Tue Jan 24 14:46:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimTkTypes.cpp File Reference

Apc/SimTkTypes.cpp File Reference

#include "Apc/PreComp.hpp"
#include "SimTkTypes.hpp"

Include dependency graph for SimTkTypes.cpp:

Generated on Tue Jan 24 17:07:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimTkTypes.hpp File Reference

Apc/SimTkTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/SimDataTypes.hpp>

Include dependency graph for SimTkTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ChannelData_s
struct | ChannelDataArray
struct | MsapPackedData_s
class | ProactiveCauseMapper
struct | SiBearerDesc_s
struct | SiBearerDescArray
struct | SiBearerList_s
struct | SiBearerListArray
struct | SiDuration_s
struct | SiIpAddress_s
struct | SiIpAddressArray
class | SimDisplayTextOptions
describes how the display string should be represented. More...
struct | SimEfRefresh
struct | SimEfRefreshTable
struct | SimEventList
class | SimGetInkeyOptions
class | SimGetInputOptions
struct | SimLaunchBrowserPromptReq_s
class | SimSelectItemOptions
class | SimSetupIdleModeTextOptions
class | SimSetupMenuOptions
struct | SimSubAddress
class | SimTkProfile
class | SimTkTransactionId
struct | SiProvFileRef_s
struct | SiProvFileRefArray
struct | SiText_s
struct | SiTextArray
struct | SiUrlArray
struct | T_STK_TRANSACTION_ID
struct | TAlphaIdentifier_s
struct | TAlphaIdentifierArray
struct | TMsapPackedDataArray
struct | TSiIconID_s
struct | TSiUrl_s

Defines

#define | Apc_SimTkTypes_hpp
#define | NET_SOCKET_TYPE_SMS 3
#define | NET_SOCKET_TYPE_TCP 2
#define | NET_SOCKET_TYPE_UDP 1
#define | SimtkSetSignalParam1(param) ApoxiSdlSetOutSignalParam(1,param)
#define | SimtkSetSignalParam10(param) ApoxiSdlSetOutSignalParam(10,param)
#define | SimtkSetSignalParam11(param) ApoxiSdlSetOutSignalParam(11,param)
#define | SimtkSetSignalParam2(param) ApoxiSdlSetOutSignalParam(2,param)
#define | SimtkSetSignalParam3(param) ApoxiSdlSetOutSignalParam(3,param)
#define | SimtkSetSignalParam4(param) ApoxiSdlSetOutSignalParam(4,param)
#define | SimtkSetSignalParam5(param) ApoxiSdlSetOutSignalParam(5,param)
#define | SimtkSetSignalParam6(param) ApoxiSdlSetOutSignalParam(6,param)
#define | SimtkSetSignalParam7(param) ApoxiSdlSetOutSignalParam(7,param)
#define | SimtkSetSignalParam8(param) ApoxiSdlSetOutSignalParam(8,param)
#define | SimtkSetSignalParam9(param) ApoxiSdlSetOutSignalParam(9,param)
#define | SimtkSetSignalTid(param)
#define | SimtkSignalParam1 ApoxiSdlSignalDataParam(1)
#define | SimtkSignalParam10 ApoxiSdlSignalDataParam(10)
#define | SimtkSignalParam11 ApoxiSdlSignalDataParam(11)
#define | SimtkSignalParam2 ApoxiSdlSignalDataParam(2)
#define | SimtkSignalParam3 ApoxiSdlSignalDataParam(3)
#define | SimtkSignalParam4 ApoxiSdlSignalDataParam(4)
#define | SimtkSignalParam5 ApoxiSdlSignalDataParam(5)
#define | SimtkSignalParam6 ApoxiSdlSignalDataParam(6)
#define | SimtkSignalParam7 ApoxiSdlSignalDataParam(7)
#define | SimtkSignalParam8 ApoxiSdlSignalDataParam(8)
#define | SimtkSignalParam9 ApoxiSdlSignalDataParam(9)
#define | SimtkSignalTid SimTkTransactionId()

Typedefs

typedef ChannelData_s | ChannelData
typedef MsapPackedData_s | MsapPackedData
typedef SiBearerDesc_s | SiBearerDesc
typedef SiBearerList_s | SiBearerList
typedef SiDuration_s | SiDuration
typedef SiIpAddress_s | SiIpAddress
typedef SimLaunchBrowserPromptReq_s | SimLaunchBrowserPromptReq
typedef SiProvFileRef_s | SiProvFileRef
typedef SiText_s | SiText
typedef TAlphaIdentifier_s | TAlphaIdentifier
typedef TSiIconID_s | TSiIconID
typedef TSiUrl_s | TSiUrl

Enumerations

enum ElementaryFilePos {
AcmEfPos = SIMI_EF_ACM_POS, AcmMaxEfPos = SIMI_EF_ACMMAX_POS, AdnEfPos = SIMI_EF_ADN_POS, FdnEfPos = SIMI_EF_FDN_POS,
LndEfPos = SIMI_EF_LND_POS, MsisdnEfPos = SIMI_EF_MSISDN_POS, PhaseEfPos = SIMI_EF_PHASE_POS, PuctEfPos = SIMI_EF_PUCT_POS,
SmsEfPos = SIMI_EF_SMS_POS, SmspEfPos = SIMI_EF_SMSP_POS, SmssEfPos = SIMI_EF_SMSS_POS, SstEfPos = SIMI_EF_SST_POS,
ImsiEfPos = SIMI_EF_IMSI_POS, LpEfPos = SIMI_EF_LP_POS, ElpEfPos = SIMI_EF_ELP_POS, PlmnEfPos = SIMI_EF_PLMNS_POS,
SpnEfPos = SIMI_EF_SPN_POS, CbmiEfPos = SIMI_EF_CBMI_POS, EccEfPos = SIMI_EF_ECC_POS, CbmirEfPos = SIMI_EF_CBMIR_POS,
BdnEfPos = SIMI_EF_BDN_POS, SmsrEfPos = SIMI_EF_SMSR_POS, GraphicsDfPos = SIMI_DF_GRAPHICS_POS, SdnEfPos = SIMI_EF_SDN_POS,
Ext1EfPos = SIMI_EF_EXT1_POS, Ext2EfPos = SIMI_EF_EXT2_POS, Ext3EfPos = SIMI_EF_EXT3_POS, Ext4EfPos = SIMI_EF_EXT4_POS,
NiaEfPos = SIMI_EF_NIA_POS, CmiEfPos = SIMI_EF_CMI_POS, CphsCsp2EfPos = SIMI_EF_CPHS_CSP2_POS, CphsAcm2EfPos = SIMI_EF_CPHS_ACM2_POS,
CcpEfPos = SIMI_EF_CCP_POS, OParamEfPos = SIMI_EF_O_PARAM_POS, OJcEfPos = SIMI_EF_O_JC_POS, ODynEfPos = SIMI_EF_O_DYN_POS,
ODyn2EfPos = SIMI_EF_O_DYN2_POS, OZon1EfPos = SIMI_EF_O_ZON1_POS, OZon2EfPos = SIMI_EF_O_ZON2_POS, OSct2EfPos = SIMI_EF_O_SCT_POS,
CphsVmwfEfPos = SIMI_EF_CPHS_VMWF_POS, CphsSrvstEfPos = SIMI_EF_CPHS_SRVST_POS, CphsCfufEfPos = SIMI_EF_CPHS_CFUF_POS, CphsOnmEfPos = SIMI_EF_CPHS_ONM_POS,
CphsCspEfPos = SIMI_EF_CPHS_CSP_POS, CphsIstEfPos = SIMI_EF_CPHS_IST_POS, CphsMboxEfPos = SIMI_EF_CPHS_MBOX_POS, CphsInfumEfPos = SIMI_EF_CPHS_INFNUM_POS,
ViHzParamEfPos = SIMI_EF_VI_HZ_PARAM_POS, ViHzCache1EfPos = SIMI_EF_VI_HZ_CACHE1_POS, ViHzCache2EfPos = SIMI_EF_VI_HZ_CACHE2_POS, ViHzCache3EfPos = SIMI_EF_VI_HZ_CACHE3_POS,
ViHzCache4EfPos = SIMI_EF_VI_HZ_CACHE4_POS, CphsOnsEfPos = SIMI_EF_CPHS_ONS_POS, VgcsEfPos, VgcssEfPos,
VbsEfPos, VbssEfPos, EmlppEfPos, AaemEfPos,
InvScanEfPos, EccpEfPos, PlmnWactEfPos, OplmnWactEfPos,
CpbcchEfPos, HplmnWact, NumberOfEfPos = SI_MI_NUMBER_OF_EF
}
enum GenResultCode {
gr_Command_performed_successfully = 0x00, gr_Command_performed_with_partial_comprehension = 0x01, gr_Command_performed_with_missing_information = 0x02, gr_Refresh_performed_with_add_EFs_read = 0x03,
gr_Command_performed_successfully_but_icon_not_disp = 0x04, gr_Command_performed_but_modified_by_SIM = 0x05, gr_Command_performed_successfully_but_limited_service = 0x06, gr_Command_performed_with_modification = 0x07,
gr_Proactive_SIM_Session_terminated_by_user = 0x10, gr_Backward_move_requested_by_user = 0x11, gr_No_response_from_user = 0x12, gr_Help_information_required_by_user = 0x13,
gr_ss_transaction_terminated_by_user = 0x14, gr_ME_currently_unable = 0x20, gr_Network_currently_unable = 0x21, gr_User_did_not_accept_proactive_command = 0x22,
gr_User_cleared_call_before_network_release = 0x23, gr_Action_in_contradiction_with_current_timer = 0x24, gr_Interaction_with_SIM_temporary_problem = 0x25, gr_Launch_browser_generic_error = 0x26,
gr_Command_beyond_ME_capabilities = 0x30, gr_Command_type_not_understood_by_ME = 0x31, gr_Command_data_not_understood_by_ME = 0x32, gr_Command_number_not_known_by_ME = 0x33,
gr_SS_return_error = 0x34, gr_SMS_rp_error = 0x35, gr_Error_required_values_missing = 0x36, gr_USSD_error = 0x37,
gr_MultipleCard_error = 0x38, gr_Interaction_with_SIM_permanent_problem = 0x39, gr_Bearer_independent_protocol_error = 0x3A
}
enum ProactiveCause {
SimTkSuccessful = 0x00ff, CommandPerformedWithPartialComprehension = 0x01ff, CommandPerformedWithMissingInformation = 0x02ff, RefreshPerformedWithAdditionalEFsRead = 0x03ff,
SuccessfulButIconNotDisplayed = 0x04ff, CommandPerformedWithButModifiedByCallControlBySim = 0x05ff, CommandPerformedSuccessfullyLimitedService = 0x06ff, CommandPerformedWithModification = 0x07ff,
TerminateByUser = 0x10ff, BackwardMove = 0x11ff, NoResponse = 0x12ff, HelpInfo = 0x13ff,
UssdOrSsTransactionTerminatedByUser = 0x14ff, CurrentlyUnable = 0x2000, ScreenBusy = 0x2001, BusyOnCall = 0x2002,
MeCurrentlyUnableBusyOnSsTransaction = 0x2003, MeCurrentlyUnableNoService = 0x2004, MeCurrentlyUnableAccessControlClassBar = 0x2005, MeCurrentlyUnableRadioResourceNotGranted = 0x2006,
MeCurrentlyUnableNotInSpeechCall = 0x2007, MeCurrentlyUnableBusyOnUssdTransaction = 0x2008, MeCurrentlyUnableBusyOnSendDtmfCommand = 0x2009, NetworkCurrentlyUnableToProcessCommand = 0x2100,
UserDidNotAcceptCallSetupRequest = 0x22ff, UserClearedDownCallBeforeConnectionOrNetworkRelease = 0x23ff, ActionInContradictionWithTheCurrentTimerState = 0x24ff, InteractionWithCallControlBySimTemporaryProblem = 0x25ff,
LaunchBrowserError = 0x2600, LaunchBrowserBearerUnavailable = 0x2601, LaunchBrowserBrowserUnavailable = 0x2602, LaunchBrowserMeUnableToReadProvisioningData = 0x2603,
CommandBeyondCapability = 0x30ff, CommandTypeNotUnderstoodByMe = 0x31ff, CommandDataNotUnderstoodByMe = 0x32ff, CommandNumberNotKnownByMe = 0x33ff,
SsReturnError = 0x3400, SmsRpError = 0x3500, RequiredValuesAreMissing = 0x36ff, UssdReturnError = 0x3700,
MultipleCardCommandsError = 0x3800, MultipleCardCommandsErrorCardReaderRemovedOrNotPresent = 0x3801, MultipleCardCommandsErrorCardRemovedOrNotPresent = 0x3802, MultipleCardCommandsErrorCardReaderBusy = 0x3803,
MultipleCardCommandsErrorCardPoweredOff = 0x3804, MultipleCardCommandsErrorCApduFormatError = 0x3805, MultipleCardCommandsErrorMuteCard = 0x3806, MultipleCardCommandsErrorTransmissionError = 0x3807,
MultipleCardCommandsErrorProtocolNotSupported = 0x3808, MultipleCardCommandsErrorSpecifiedReaderNotValid = 0x3808, CallControlMoSmsControlPermanentProblem = 0x3900, CallControlMoSmsControlPermanentProblemActionNotAllowed = 0x3901,
CallControlMoSmsControlPermanentProblemTypeOfRequestChanged = 0x3902, BearerIndependentProtocolError = 0x3a00, BearerIndependentProtocolErrorNoChannelAvailable = 0x3a01, BearerIndependentProtocolErrorChannelClosed = 0x3a02,
BearerIndependentProtocolErrorChannelIdentifierNotValid = 0x3a03, BearerIndependentProtocolErrorRequestedBufferSizeNotAvailable = 0x3a03
}
enum | SiBearerType { SiBearerUndef = SI_BEARER_UNDEF, SiBearerCsd = SI_BEARER_CSD, SiBearerGprs = SI_BEARER_GPRS, SiBearerDefault = SI_BEARER_DEFAULT }
enum SiChannelChangedState {
SiChannelChangedNoInfo = SI_CHANNEL_CHANGED_NO_INFO, SiChannelChanged1 = SI_CHANNEL_CHANGED_1, SiChannelChanged2 = SI_CHANNEL_CHANGED_2, SiChannelChanged3 = SI_CHANNEL_CHANGED_3,
SiChannelChanged4 = SI_CHANNEL_CHANGED_4, SiChannelChangedToDropped = SI_CHANNEL_CHANGED_TO_DROPPED
}
enum | SiChannelCloseCause { SiChannelCloseUndef = SI_CHANNEL_CLOSE_UNDEF, SiChannelCloseRej = SI_CHANNEL_CLOSE_REJ, SiChannelClosedBySat = SI_CHANNEL_CLOSED_BY_SAT, SiChannelClosedByUser = SI_CHANNEL_CLOSED_BY_USER }
enum | SiClientFlags { ClientFlagConfirmedRefresh = 0x01, ClientFlagLocationStatusReport = 0x02, ClientFlagMccOnStartInd = 0x04 }
sim toolkit Register Browser client flags (ms.h: T_SI_CLIENT_FLAGS) More...
enum | SimKey { SimKeyInvalid = -1, SimKeyYes = 1, SimKeyNo = 0 }
enum | SiSendDataType { SiSendDataImmediately = SI_SEND_DATA_IMMEDIATELY, SiSendDataStoreInBuffer = SI_SEND_DATA_STORE_IN_BUFFER }
enum | SiTransportLayer { SiTrLayerRaw = SI_TR_LAYER_RAW, SiTrLayerUdp = SI_TR_LAYER_UDP, SiTrLayerTcp = SI_TR_LAYER_TCP }

Define Documentation

#define Apc_SimTkTypes_hpp

#define NET_SOCKET_TYPE_SMS 3

#define NET_SOCKET_TYPE_TCP 2

#define NET_SOCKET_TYPE_UDP 1

#define SimtkSetSignalParam1 ( param ) ApoxiSdlSetOutSignalParam(1,param)

#define SimtkSetSignalParam10 ( param ) ApoxiSdlSetOutSignalParam(10,param)

#define SimtkSetSignalParam11 ( param ) ApoxiSdlSetOutSignalParam(11,param)

#define SimtkSetSignalParam2 ( param ) ApoxiSdlSetOutSignalParam(2,param)

#define SimtkSetSignalParam3 ( param ) ApoxiSdlSetOutSignalParam(3,param)

#define SimtkSetSignalParam4 ( param ) ApoxiSdlSetOutSignalParam(4,param)

#define SimtkSetSignalParam5 ( param ) ApoxiSdlSetOutSignalParam(5,param)

#define SimtkSetSignalParam6 ( param ) ApoxiSdlSetOutSignalParam(6,param)

#define SimtkSetSignalParam7 ( param ) ApoxiSdlSetOutSignalParam(7,param)

#define SimtkSetSignalParam8 ( param ) ApoxiSdlSetOutSignalParam(8,param)

#define SimtkSetSignalParam9 ( param ) ApoxiSdlSetOutSignalParam(9,param)

#define SimtkSetSignalTid ( param )

#define SimtkSignalParam1 ApoxiSdlSignalDataParam(1)

#define SimtkSignalParam10 ApoxiSdlSignalDataParam(10)

#define SimtkSignalParam11 ApoxiSdlSignalDataParam(11)

#define SimtkSignalParam2 ApoxiSdlSignalDataParam(2)

#define SimtkSignalParam3 ApoxiSdlSignalDataParam(3)

#define SimtkSignalParam4 ApoxiSdlSignalDataParam(4)

#define SimtkSignalParam5 ApoxiSdlSignalDataParam(5)

#define SimtkSignalParam6 ApoxiSdlSignalDataParam(6)

#define SimtkSignalParam7 ApoxiSdlSignalDataParam(7)

#define SimtkSignalParam8 ApoxiSdlSignalDataParam(8)

#define SimtkSignalParam9 ApoxiSdlSignalDataParam(9)

#define SimtkSignalTid SimTkTransactionId()

Typedef Documentation

typedef struct ChannelData_s ChannelData

typedef struct MsapPackedData_s MsapPackedData

typedef struct SiBearerDesc_s SiBearerDesc

typedef struct SiBearerList_s SiBearerList

typedef struct SiDuration_s SiDuration

typedef struct SiIpAddress_s SiIpAddress

typedef struct SimLaunchBrowserPromptReq_s SimLaunchBrowserPromptReq

typedef struct SiProvFileRef_s SiProvFileRef

typedef struct SiText_s SiText

typedef struct TAlphaIdentifier_s TAlphaIdentifier

typedef struct TSiIconID_s TSiIconID

typedef struct TSiUrl_s TSiUrl

Enumeration Type Documentation

enum ElementaryFilePos

Enumerator:
AcmEfPos
AcmMaxEfPos
AdnEfPos
FdnEfPos
LndEfPos
MsisdnEfPos
PhaseEfPos
PuctEfPos
SmsEfPos
SmspEfPos
SmssEfPos
SstEfPos
ImsiEfPos
LpEfPos
ElpEfPos
PlmnEfPos
SpnEfPos
CbmiEfPos
EccEfPos
CbmirEfPos
BdnEfPos
SmsrEfPos
GraphicsDfPos
SdnEfPos
Ext1EfPos
Ext2EfPos
Ext3EfPos
Ext4EfPos
NiaEfPos
CmiEfPos
CphsCsp2EfPos
CphsAcm2EfPos
CcpEfPos
OParamEfPos
OJcEfPos
ODynEfPos
ODyn2EfPos
OZon1EfPos
OZon2EfPos
OSct2EfPos
CphsVmwfEfPos
CphsSrvstEfPos
CphsCfufEfPos
CphsOnmEfPos
CphsCspEfPos
CphsIstEfPos
CphsMboxEfPos
CphsInfumEfPos
ViHzParamEfPos
ViHzCache1EfPos
ViHzCache2EfPos
ViHzCache3EfPos
ViHzCache4EfPos
CphsOnsEfPos
VgcsEfPos
VgcssEfPos
VbsEfPos
VbssEfPos
EmlppEfPos
AaemEfPos
InvScanEfPos
EccpEfPos
PlmnWactEfPos
OplmnWactEfPos
CpbcchEfPos
HplmnWact
NumberOfEfPos

enum GenResultCode

Enumerator:
gr_Command_performed_successfully
gr_Command_performed_with_partial_comprehension
gr_Command_performed_with_missing_information
gr_Refresh_performed_with_add_EFs_read
gr_Command_performed_successfully_but_icon_not_disp
gr_Command_performed_but_modified_by_SIM
gr_Command_performed_successfully_but_limited_service
gr_Command_performed_with_modification
gr_Proactive_SIM_Session_terminated_by_user
gr_Backward_move_requested_by_user
gr_No_response_from_user
gr_Help_information_required_by_user
gr_ss_transaction_terminated_by_user
gr_ME_currently_unable
gr_Network_currently_unable
gr_User_did_not_accept_proactive_command
gr_User_cleared_call_before_network_release
gr_Action_in_contradiction_with_current_timer
gr_Interaction_with_SIM_temporary_problem
gr_Launch_browser_generic_error
gr_Command_beyond_ME_capabilities
gr_Command_type_not_understood_by_ME
gr_Command_data_not_understood_by_ME
gr_Command_number_not_known_by_ME
gr_SS_return_error
gr_SMS_rp_error
gr_Error_required_values_missing
gr_USSD_error
gr_MultipleCard_error
gr_Interaction_with_SIM_permanent_problem
gr_Bearer_independent_protocol_error

enum ProactiveCause

Enumerator:
SimTkSuccessful
CommandPerformedWithPartialComprehension
CommandPerformedWithMissingInformation
RefreshPerformedWithAdditionalEFsRead
SuccessfulButIconNotDisplayed
CommandPerformedWithButModifiedByCallControlBySim
CommandPerformedSuccessfullyLimitedService
CommandPerformedWithModification
TerminateByUser
BackwardMove
NoResponse
HelpInfo
UssdOrSsTransactionTerminatedByUser
CurrentlyUnable
ScreenBusy
BusyOnCall
MeCurrentlyUnableBusyOnSsTransaction
MeCurrentlyUnableNoService
MeCurrentlyUnableAccessControlClassBar
MeCurrentlyUnableRadioResourceNotGranted
MeCurrentlyUnableNotInSpeechCall
MeCurrentlyUnableBusyOnUssdTransaction
MeCurrentlyUnableBusyOnSendDtmfCommand
NetworkCurrentlyUnableToProcessCommand
UserDidNotAcceptCallSetupRequest
UserClearedDownCallBeforeConnectionOrNetworkRelease
ActionInContradictionWithTheCurrentTimerState
InteractionWithCallControlBySimTemporaryProblem
LaunchBrowserError
LaunchBrowserBearerUnavailable
LaunchBrowserBrowserUnavailable
LaunchBrowserMeUnableToReadProvisioningData
CommandBeyondCapability
CommandTypeNotUnderstoodByMe
CommandDataNotUnderstoodByMe
CommandNumberNotKnownByMe
SsReturnError
SmsRpError
RequiredValuesAreMissing
UssdReturnError
MultipleCardCommandsError
MultipleCardCommandsErrorCardReaderRemovedOrNotPresent
MultipleCardCommandsErrorCardRemovedOrNotPresent
MultipleCardCommandsErrorCardReaderBusy
MultipleCardCommandsErrorCardPoweredOff
MultipleCardCommandsErrorCApduFormatError
MultipleCardCommandsErrorMuteCard
MultipleCardCommandsErrorTransmissionError
MultipleCardCommandsErrorProtocolNotSupported
MultipleCardCommandsErrorSpecifiedReaderNotValid
CallControlMoSmsControlPermanentProblem
CallControlMoSmsControlPermanentProblemActionNotAllowed
CallControlMoSmsControlPermanentProblemTypeOfRequestChanged
BearerIndependentProtocolError
BearerIndependentProtocolErrorNoChannelAvailable
BearerIndependentProtocolErrorChannelClosed
BearerIndependentProtocolErrorChannelIdentifierNotValid
BearerIndependentProtocolErrorRequestedBufferSizeNotAvailable

enum SiBearerType

Enumerator:
SiBearerUndef
SiBearerCsd
SiBearerGprs
SiBearerDefault

enum SiChannelChangedState

Enumerator:
SiChannelChangedNoInfo
SiChannelChanged1
SiChannelChanged2
SiChannelChanged3
SiChannelChanged4
SiChannelChangedToDropped

enum SiChannelCloseCause

Enumerator:
SiChannelCloseUndef
SiChannelCloseRej
SiChannelClosedBySat
SiChannelClosedByUser

enum SiClientFlags

sim toolkit Register Browser client flags (ms.h: T_SI_CLIENT_FLAGS)

Enumerator:
ClientFlagConfirmedRefresh
ClientFlagLocationStatusReport
ClientFlagMccOnStartInd

enum SimKey

Enumerator:
SimKeyInvalid
SimKeyYes
SimKeyNo

enum SiSendDataType

Enumerator:
SiSendDataImmediately
SiSendDataStoreInBuffer

enum SiTransportLayer

Enumerator:
SiTrLayerRaw
SiTrLayerUdp
SiTrLayerTcp

Generated on Tue Jan 24 17:07:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SimTkTypes.hpp Source File

Apc/SimTkTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SimTkTypes_hpp)
00009 #define Apc_SimTkTypes_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014 #include <Apc/SignalTypes.hpp>
00015 #include <Apc/SimDataTypes.hpp>
00016
00017
00018 /*  ========================================================================
00019                             Sim Toolkit Enums
00020     ========================================================================*/
00021 // sim toolkit proactive cause (ms.h: T_MI_PROACTIVE_CAUSE)
00022 enum ProactiveCause {
00023     // causes indicate, that command has been performed
00024     SimTkSuccessful                                                = 0x00ff,
00025     CommandPerformedWithPartialComprehension                       = 0x01ff,
00026     CommandPerformedWithMissingInformation                         = 0x02ff,
00027     RefreshPerformedWithAdditionalEFsRead                          = 0x03ff,
00028     SuccessfulButIconNotDisplayed                                  = 0x04ff,
00029     CommandPerformedWithButModifiedByCallControlBySim              = 0x05ff,
00030     CommandPerformedSuccessfullyLimitedService                     = 0x06ff,
00031     CommandPerformedWithModification                               = 0x07ff,
00032     TerminateByUser                                                = 0x10ff,
00033     BackwardMove                                                   = 0x11ff,
00034     NoResponse                                                     = 0x12ff,
00035     HelpInfo                                                       = 0x13ff,
00036     UssdOrSsTransactionTerminatedByUser                            = 0x14ff,
00037
00038     // causes indicate, that it may be worth re-trying the command at later opportunity
00039     CurrentlyUnable                                                = 0x2000,
00040     ScreenBusy                                                     = 0x2001,
00041     BusyOnCall                                                     = 0x2002,
00042     MeCurrentlyUnableBusyOnSsTransaction                           = 0x2003,
00043     MeCurrentlyUnableNoService                                     = 0x2004,
00044     MeCurrentlyUnableAccessControlClassBar                         = 0x2005,
00045     MeCurrentlyUnableRadioResourceNotGranted                       = 0x2006,
00046     MeCurrentlyUnableNotInSpeechCall                               = 0x2007,
00047     MeCurrentlyUnableBusyOnUssdTransaction                         = 0x2008,
00048     MeCurrentlyUnableBusyOnSendDtmfCommand                         = 0x2009,
00049     NetworkCurrentlyUnableToProcessCommand                         = 0x2100,
00050     UserDidNotAcceptCallSetupRequest                               = 0x22ff,
00051     UserClearedDownCallBeforeConnectionOrNetworkRelease            = 0x23ff,
00052     ActionInContradictionWithTheCurrentTimerState                  = 0x24ff,
00053     InteractionWithCallControlBySimTemporaryProblem                = 0x25ff,
00054     LaunchBrowserError                                             = 0x2600,
00055     LaunchBrowserBearerUnavailable                                 = 0x2601,
00056     LaunchBrowserBrowserUnavailable                                = 0x2602,
00057     LaunchBrowserMeUnableToReadProvisioningData                    = 0x2603,
00058
00059     // causes indicate, that's not worth re-trying with an identical command
00060     CommandBeyondCapability                                        = 0x30ff,
00061     CommandTypeNotUnderstoodByMe                                   = 0x31ff,
00062     CommandDataNotUnderstoodByMe                                   = 0x32ff,
00063     CommandNumberNotKnownByMe                                      = 0x33ff,
00064     SsReturnError                                                  = 0x3400,
00065     SmsRpError                                                     = 0x3500,
00066     RequiredValuesAreMissing                                       = 0x36ff,
00067     UssdReturnError                                                = 0x3700,
00068     MultipleCardCommandsError                                      = 0x3800,
00069     MultipleCardCommandsErrorCardReaderRemovedOrNotPresent         = 0x3801,
00070     MultipleCardCommandsErrorCardRemovedOrNotPresent               = 0x3802,
00071     MultipleCardCommandsErrorCardReaderBusy                        = 0x3803,
00072     MultipleCardCommandsErrorCardPoweredOff                        = 0x3804,
00073     MultipleCardCommandsErrorCApduFormatError                      = 0x3805,
00074     MultipleCardCommandsErrorMuteCard                              = 0x3806,
00075     MultipleCardCommandsErrorTransmissionError                     = 0x3807,
00076     MultipleCardCommandsErrorProtocolNotSupported                  = 0x3808,
00077     MultipleCardCommandsErrorSpecifiedReaderNotValid               = 0x3808,
00078     CallControlMoSmsControlPermanentProblem                        = 0x3900,
00079     CallControlMoSmsControlPermanentProblemActionNotAllowed        = 0x3901,
00080     CallControlMoSmsControlPermanentProblemTypeOfRequestChanged    = 0x3902,
00081     BearerIndependentProtocolError                                 = 0x3a00,
00082     BearerIndependentProtocolErrorNoChannelAvailable               = 0x3a01,
00083     BearerIndependentProtocolErrorChannelClosed                    = 0x3a02,
00084     BearerIndependentProtocolErrorChannelIdentifierNotValid        = 0x3a03,
00085     BearerIndependentProtocolErrorRequestedBufferSizeNotAvailable  = 0x3a03,
00086 };
00087
00088 enum SimKey {
00089     SimKeyInvalid = -1,
00090     SimKeyYes = 1,
00091     SimKeyNo = 0
00092 };
00093
00094 // sim toolkit proactive cause (ms.h: T_MI_PROACTIVE_CAUSE)
00095 enum ElementaryFilePos {
00096     AcmEfPos      = SIMI_EF_ACM_POS,
00097     AcmMaxEfPos   = SIMI_EF_ACMMAX_POS,
00098     AdnEfPos      = SIMI_EF_ADN_POS,
00099     FdnEfPos      = SIMI_EF_FDN_POS,
00100     LndEfPos      = SIMI_EF_LND_POS,
00101     MsisdnEfPos   = SIMI_EF_MSISDN_POS,
00102     PhaseEfPos    = SIMI_EF_PHASE_POS,
00103     PuctEfPos     = SIMI_EF_PUCT_POS,
00104     SmsEfPos      = SIMI_EF_SMS_POS,
00105     SmspEfPos     = SIMI_EF_SMSP_POS,
00106     SmssEfPos     = SIMI_EF_SMSS_POS,
00107     SstEfPos      = SIMI_EF_SST_POS,
00108     ImsiEfPos     = SIMI_EF_IMSI_POS,
00109     LpEfPos       = SIMI_EF_LP_POS,
00110     ElpEfPos      = SIMI_EF_ELP_POS,
00111     PlmnEfPos     = SIMI_EF_PLMNS_POS,
00112     SpnEfPos      = SIMI_EF_SPN_POS,
00113     CbmiEfPos     = SIMI_EF_CBMI_POS,
00114     EccEfPos      = SIMI_EF_ECC_POS,
00115     CbmirEfPos    = SIMI_EF_CBMIR_POS,
00116     BdnEfPos      = SIMI_EF_BDN_POS,
00117     SmsrEfPos     = SIMI_EF_SMSR_POS,
00118     GraphicsDfPos = SIMI_DF_GRAPHICS_POS,
00119     SdnEfPos      = SIMI_EF_SDN_POS,
00120     Ext1EfPos     = SIMI_EF_EXT1_POS,
00121     Ext2EfPos     = SIMI_EF_EXT2_POS,
00122     Ext3EfPos     = SIMI_EF_EXT3_POS,
00123     Ext4EfPos     = SIMI_EF_EXT4_POS,
00124     NiaEfPos      = SIMI_EF_NIA_POS,
00125     CmiEfPos      = SIMI_EF_CMI_POS,
00126     CphsCsp2EfPos = SIMI_EF_CPHS_CSP2_POS,
00127     CphsAcm2EfPos = SIMI_EF_CPHS_ACM2_POS,
00128     CcpEfPos      = SIMI_EF_CCP_POS,
00129     OParamEfPos   = SIMI_EF_O_PARAM_POS,
00130     OJcEfPos      = SIMI_EF_O_JC_POS,
00131     ODynEfPos     = SIMI_EF_O_DYN_POS,
00132     ODyn2EfPos    = SIMI_EF_O_DYN2_POS,
00133     OZon1EfPos    = SIMI_EF_O_ZON1_POS,
00134     OZon2EfPos    = SIMI_EF_O_ZON2_POS,
00135     OSct2EfPos    = SIMI_EF_O_SCT_POS,
00136     CphsVmwfEfPos   = SIMI_EF_CPHS_VMWF_POS,
00137     CphsSrvstEfPos  = SIMI_EF_CPHS_SRVST_POS,
00138     CphsCfufEfPos   = SIMI_EF_CPHS_CFUF_POS,
00139     CphsOnmEfPos    = SIMI_EF_CPHS_ONM_POS,
00140     CphsCspEfPos    = SIMI_EF_CPHS_CSP_POS,
00141     CphsIstEfPos    = SIMI_EF_CPHS_IST_POS,
00142     CphsMboxEfPos   = SIMI_EF_CPHS_MBOX_POS,
00143     CphsInfumEfPos  = SIMI_EF_CPHS_INFNUM_POS,
00144     ViHzParamEfPos  = SIMI_EF_VI_HZ_PARAM_POS,
00145     ViHzCache1EfPos = SIMI_EF_VI_HZ_CACHE1_POS,
00146     ViHzCache2EfPos = SIMI_EF_VI_HZ_CACHE2_POS,
00147     ViHzCache3EfPos = SIMI_EF_VI_HZ_CACHE3_POS,
00148     ViHzCache4EfPos = SIMI_EF_VI_HZ_CACHE4_POS,
00149     CphsOnsEfPos    = SIMI_EF_CPHS_ONS_POS,
00150     VgcsEfPos,      // #define SIMI_EF_VGCS_POS SDL_INTEGER_LIT(54)
00151     VgcssEfPos,     // #define SIMI_EF_VGCSS_POS SDL_INTEGER_LIT(55)
00152     VbsEfPos,       // #define SIMI_EF_VBS_POS SDL_INTEGER_LIT(56)
00153     VbssEfPos,      // #define SIMI_EF_VBSS_POS SDL_INTEGER_LIT(57)
00154     EmlppEfPos,     // #define SIMI_EF_EMLPP_POS SDL_INTEGER_LIT(58)
00155     AaemEfPos,      // #define SIMI_EF_AAEM_POS SDL_INTEGER_LIT(59)
00156     InvScanEfPos,   // #define SIMI_EF_INV_SCAN_POS SDL_INTEGER_LIT(60)
00157     EccpEfPos,      // #define SIMI_EF_ECCP_POS SDL_INTEGER_LIT(61)
00158     PlmnWactEfPos,  // #define SIMI_EF_PLMN_WACT_POS SDL_INTEGER_LIT(62)
00159     OplmnWactEfPos, // #define SIMI_EF_OPLMN_WACT_POS SDL_INTEGER_LIT(63)
00160     CpbcchEfPos,    // #define SIMI_EF_CPBCCH_POS SDL_INTEGER_LIT(64)
00161     HplmnWact,      // #define SIMI_EF_HPLMN_WACT_POS SDL_INTEGER_LIT(65)
00162
00163     NumberOfEfPos   = SI_MI_NUMBER_OF_EF
00164 };
00165
00166 /*  ========================================================================
00167     SimEventList
00168     ========================================================================*/
00169 // sim toolkit event List (ms.h: T_SI_EVENT_LIST)
00170 struct SimEventList {
00171     UINT8 val[2];
00172 };
00173
00174 /*  ========================================================================
00175     SimSubAddress
00176     ========================================================================*/
00177 // alpha identifier (ms.h: T_CALLED_SUBADDR)
00178 struct SimSubAddress {
00179     UINT8 val[22];
00180 };
00181
00182 /*  ========================================================================
00183     SimEfRefreshTable
00184     ========================================================================*/
00185 // refresh table for elementary files on sim card
00186 struct SimEfRefreshTable {
00187     BOOLEAN refresh[NumberOfEfPos];
00188 };
00189
00190 /*  ========================================================================
00191     SimEfRefresh
00192     ========================================================================*/
00193 // refresh option for elementary files on sim card
00194 struct SimEfRefresh {
00195     BOOLEAN full_refresh;
00196     SimEfRefreshTable table;
00197     BOOLEAN IsFullRefreshed() { return (full_refresh); }
00198     BOOLEAN IsRefreshed(UINT i) { ASSERT(i < NumberOfEfPos); return (full_refresh ? full_refresh : table.refresh[i]); }
00199 };
00200
00201
00202 /*  ========================================================================
00203     SimToolkitBrowser
00204     ========================================================================*/
00205 //  (ms.h: T_SI_URL_ARRAY)
00206 typedef struct {
00207     byte  val[244];
00208 }  SiUrlArray;
00209
00210 //  (ms.h: T_SI_URL)
00211 typedef struct TSiUrl_s {
00212     byte  length;
00213     SiUrlArray  data;
00214 } TSiUrl;
00215
00216 //  (ms.h: T_ALPHA_IDENTIFIER_ARRAY)
00217
00218 typedef struct {
00219     byte  val[SI_MAX_ALPHA_IDENTIFIER_SIZE];
00220 }  TAlphaIdentifierArray;
00221
00222 //  (ms.h: T_ALPHA_IDENTIFIER)
00223 typedef struct TAlphaIdentifier_s {
00224     SDL_Boolean  identifier_valid;
00225     byte  length;
00226     TAlphaIdentifierArray  data;
00227 } TAlphaIdentifier;
00228
00229 typedef struct TSiIconID_s {
00230     SDL_Boolean  exists;
00231     byte  qualifier;
00232     byte  id;
00233 } TSiIconID;
00234
00235 //  (ms.h: SI_LAUNCH_BROWSER_PROMPT_REQ)
00236 typedef struct SimLaunchBrowserPromptReq_s {
00237     TSiUrl  Param1;
00238     TAlphaIdentifier  Param2;
00239     TSiIconID  Param3;
00240 } SimLaunchBrowserPromptReq;
00241
00243 enum SiClientFlags{
00244     ClientFlagConfirmedRefresh     = 0x01,
00245     ClientFlagLocationStatusReport = 0x02,
00246     ClientFlagMccOnStartInd        = 0x04,
00247
00248 };
00249
00250 /*  ========================================================================
00251     BearerList
00252     ========================================================================*/
00253 //  (ms.h: SI_BEARER_LIST_ARRAY)
00254 typedef struct {
00255         UINT8 val[4];
00256 }  SiBearerListArray;
00257 //  (ms.h: SI_BEARER_LIST)
00258 typedef struct SiBearerList_s {
00259     byte  br_number;
00260     SiBearerListArray  data;
00261 } SiBearerList;
00262
00263 //  (ms.h: T_SI_BEARER_DESC_ARRAY)
00264 typedef struct {
00265         UINT8 val[6];
00266 }  SiBearerDescArray;
00267 //  (ms.h: T_SI_BEARER_DESC)
00268 typedef struct SiBearerDesc_s {
00269     byte  bearer_type;
00270     SiBearerDescArray  data;
00271 } SiBearerDesc;
00272
00273 // sim Provisioning File Reference (ms.h: T_SI_PROV_FILE_REF_ARRAY)
00274 typedef struct {
00275     UINT8  val[60];
00276 }  SiProvFileRefArray;
00277 // sim Provisioning File Reference (ms.h: T_SI_PROV_FILE_REF)
00278 typedef struct SiProvFileRef_s {
00279     byte  file_number;
00280     SiProvFileRefArray  data;
00281 } SiProvFileRef;
00282
00283
00284 //  (ms.h: MSAP_PACKED_DATA_REF)
00285 //unsigned long MsapPackedDataRef;
00286
00287 //  (ms.h: T_MSAP_PACKED_DATA_ARRAY)
00288 typedef struct {
00289     byte  val[256];
00290 }  TMsapPackedDataArray;
00291
00292 //  (ms.h: T_MSAP_PACKED_DATA)
00293 typedef struct MsapPackedData_s {
00294     byte  result;
00295     unsigned short  private_idx;
00296     TMsapPackedDataArray  data;
00297 } MsapPackedData;
00298
00299 //  (ms.h: T_SI_TEXT_ARRAY)
00300 typedef struct {
00301     byte  val[242];
00302 }  SiTextArray;
00303
00304 //  (ms.h: T_SI_TEXT)
00305 typedef struct SiText_s {
00306     byte  data_coding_scheme;
00307     byte  length;
00308     SiTextArray  text;
00309 } SiText;
00310
00311
00312 /*  ========================================================================
00313     SimToolkit Letter Class E
00314     ========================================================================*/
00315 enum GenResultCode { // TS 11.14 ch 12.12
00316     // command has been performed
00317     gr_Command_performed_successfully                     = 0x00,
00318     gr_Command_performed_with_partial_comprehension       = 0x01,
00319     gr_Command_performed_with_missing_information         = 0x02,
00320     gr_Refresh_performed_with_add_EFs_read                = 0x03,
00321     gr_Command_performed_successfully_but_icon_not_disp   = 0x04,
00322     gr_Command_performed_but_modified_by_SIM              = 0x05,
00323     gr_Command_performed_successfully_but_limited_service = 0x06,
00324     gr_Command_performed_with_modification                = 0x07,
00325     gr_Proactive_SIM_Session_terminated_by_user           = 0x10,
00326     gr_Backward_move_requested_by_user                    = 0x11,
00327     gr_No_response_from_user                              = 0x12,
00328     gr_Help_information_required_by_user                  = 0x13,
00329     gr_ss_transaction_terminated_by_user                  = 0x14,
00330
00331     // command failed, may be worth re-tried at a later time
00332     gr_ME_currently_unable                                = 0x20,
00333     gr_Network_currently_unable                           = 0x21,
00334     gr_User_did_not_accept_proactive_command              = 0x22,
00335     gr_User_cleared_call_before_network_release           = 0x23,
00336     gr_Action_in_contradiction_with_current_timer         = 0x24,
00337     gr_Interaction_with_SIM_temporary_problem             = 0x25,
00338     gr_Launch_browser_generic_error                       = 0x26,
00339
00340     // command failed, may not be worth re-tried at a later time
00341     gr_Command_beyond_ME_capabilities                     = 0x30,
00342     gr_Command_type_not_understood_by_ME                  = 0x31,
00343     gr_Command_data_not_understood_by_ME                  = 0x32,
00344     gr_Command_number_not_known_by_ME                     = 0x33,
00345     gr_SS_return_error                                    = 0x34,
00346     gr_SMS_rp_error                                       = 0x35,
00347     gr_Error_required_values_missing                      = 0x36,
00348     gr_USSD_error                                         = 0x37,
00349     gr_MultipleCard_error                                 = 0x38,
00350     gr_Interaction_with_SIM_permanent_problem             = 0x39,
00351     gr_Bearer_independent_protocol_error                  = 0x3A,
00352     };
00353
00354 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00355 //  (ms.h: T_SI_BEARER_TYPE)
00356 enum SiBearerType{
00357     SiBearerUndef   = SI_BEARER_UNDEF,
00358     SiBearerCsd     = SI_BEARER_CSD,
00359     SiBearerGprs    = SI_BEARER_GPRS,
00360     SiBearerDefault = SI_BEARER_DEFAULT,
00361 }  ;
00362
00363
00364 //  (ms.h: T_SI_CHANNEL_CLOSE_CAUSE)
00365 enum SiChannelCloseCause{
00366     SiChannelCloseUndef     = SI_CHANNEL_CLOSE_UNDEF,
00367     SiChannelCloseRej       = SI_CHANNEL_CLOSE_REJ,
00368     SiChannelClosedBySat    = SI_CHANNEL_CLOSED_BY_SAT,
00369     SiChannelClosedByUser   = SI_CHANNEL_CLOSED_BY_USER,
00370 }  ;
00371
00372 //  (ms.h: T_SI_TRANSPORT_LAYER)
00373 enum SiTransportLayer{
00374     SiTrLayerRaw        = SI_TR_LAYER_RAW,
00375     SiTrLayerUdp        = SI_TR_LAYER_UDP,
00376     SiTrLayerTcp        = SI_TR_LAYER_TCP,
00377 }  ;
00378 #else
00379 //  (ms.h: T_SI_BEARER_TYPE)
00380 enum SiBearerType{
00381     SiBearerUndef,
00382     SiBearerCsd,
00383     SiBearerGprs,
00384     SiBearerDefault,
00385 }  ;
00386
00387
00388 //  (ms.h: T_SI_CHANNEL_CLOSE_CAUSE)
00389 enum SiChannelCloseCause{
00390     SiChannelCloseUndef,
00391     SiChannelCloseRej,
00392     SiChannelClosedBySat,
00393     SiChannelClosedByUser,
00394 }  ;
00395
00396 //  (ms.h: T_SI_TRANSPORT_LAYER)
00397 enum SiTransportLayer{
00398     SiTrLayerRaw,
00399     SiTrLayerUdp,
00400     SiTrLayerTcp,
00401 }  ;
00402 #endif
00403
00404 //from Applications\Wap\Mic\include\aapinet.h
00405 #define NET_SOCKET_TYPE_UDP             1
00406 #define NET_SOCKET_TYPE_TCP             2
00407 #define NET_SOCKET_TYPE_SMS             3
00408 //----------------
00409
00410 //  (ms.h: T_SI_IP_ADDRESS_ARRAY)
00411 typedef struct {
00412     byte  val[16];
00413 }  SiIpAddressArray;
00414
00415 //  (ms.h: T_SI_IP_ADDRESS)
00416 typedef struct SiIpAddress_s {
00417     byte  ip_type;
00418     SiIpAddressArray  data;
00419 } SiIpAddress;
00420
00421 //  (ms.h: T_DURATION)
00422 typedef struct SiDuration_s {
00423     byte  time_units;
00424     byte  time_interval;
00425 } SiDuration;
00426
00427 //  (ms.h: T_SI_SEND_DATA_TYPE )
00428 enum SiSendDataType{
00429 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00430     SiSendDataImmediately       = SI_SEND_DATA_IMMEDIATELY,
00431     SiSendDataStoreInBuffer     = SI_SEND_DATA_STORE_IN_BUFFER,
00432 #else
00433     SiSendDataImmediately,
00434     SiSendDataStoreInBuffer
00435 #endif
00436 };
00437
00438 //  (ms.h: T_SI_CHANNEL_DATA_ARRAY )
00439 typedef struct {
00440     byte  A[244];  //more makes no sense due to T_SI_CHANNEL_DATA_ARRAY definition
00441 }  ChannelDataArray;
00442
00443 //  (ms.h: T_CHANNEL_DATA )
00444 typedef struct ChannelData_s {
00445     byte  length;
00446     ChannelDataArray  data;
00447 } ChannelData;
00448
00449 //  (ms.h: T_SI_CHANNEL_CHANGED_STATE )
00450 enum SiChannelChangedState{
00451 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00452     SiChannelChangedNoInfo      = SI_CHANNEL_CHANGED_NO_INFO,
00453     SiChannelChanged1           = SI_CHANNEL_CHANGED_1,
00454     SiChannelChanged2           = SI_CHANNEL_CHANGED_2,
00455     SiChannelChanged3           = SI_CHANNEL_CHANGED_3,
00456     SiChannelChanged4           = SI_CHANNEL_CHANGED_4,
00457     SiChannelChangedToDropped   = SI_CHANNEL_CHANGED_TO_DROPPED,
00458 #else
00459     SiChannelChangedNoInfo,
00460     SiChannelChanged1,
00461     SiChannelChanged2,
00462     SiChannelChanged3,
00463     SiChannelChanged4,
00464     SiChannelChangedToDropped
00465 #endif
00466 };
00467
00468
00469 /*  ========================================================================
00470                     Command Qualifier (GSM 11.14 [12.6])
00471     used for options for various sim toolkit commands
00472     ======================================================================== */
00473 /*  ========================================================================
00474     SimDisplayTextOptions
00475     ========================================================================*/
00477 class SimDisplayTextOptions {
00478     public:
00480         SimDisplayTextOptions(SdlByte bit_field = 0);
00482         ~SimDisplayTextOptions();
00483
00485         BOOLEAN HighPriority() const    { return ( m_bit_field.GetBit(0)); };
00487         BOOLEAN ClearAfterDelay() const { return (!m_bit_field.GetBit(7)); };
00488
00490         UINT8 Get() const { return (m_bit_field.Get()); }
00492         void Clear() { m_bit_field.Clear(); }
00493
00494     private:
00495         BitField<SdlByte> m_bit_field;
00496 };
00497
00498 /*  ========================================================================
00499     SimGetInputOptions
00500     ========================================================================*/
00502 class SimGetInputOptions {
00503     public:
00505         SimGetInputOptions(SdlByte bit_field = 0);
00507         ~SimGetInputOptions();
00508
00510         BOOLEAN DigitsOnly() const    { return (!m_bit_field.GetBit(0)); };
00512         BOOLEAN Ucs2() const          { return ( m_bit_field.GetBit(1)); };
00515         BOOLEAN HideUserInput() const { return ( m_bit_field.GetBit(2)); };
00517         BOOLEAN PackUserInput() const { return ( m_bit_field.GetBit(3)); };
00519         BOOLEAN HelpAvailable() const { return ( m_bit_field.GetBit(7)); };
00520
00522         UINT8 Get() const { return (m_bit_field.Get()); }
00524         void Clear() { m_bit_field.Clear(); }
00525
00526     private:
00527         BitField<SdlByte> m_bit_field;
00528 };
00529
00530 /*  ========================================================================
00531     SimGetInkeyOptions
00532     ========================================================================*/
00534 class SimGetInkeyOptions {
00535     public:
00537         SimGetInkeyOptions(SdlByte bit_field = 0);
00539         ~SimGetInkeyOptions();
00540
00542         BOOLEAN DigitsOnly() const    { return (!m_bit_field.GetBit(0)); };
00544         BOOLEAN Ucs2() const          { return ( m_bit_field.GetBit(1)); };
00547         BOOLEAN ActivateYesNo() const { return ( m_bit_field.GetBit(2)); };
00549         BOOLEAN HelpAvailable() const { return ( m_bit_field.GetBit(7)); };
00550
00552         UINT8 Get() const { return (m_bit_field.Get()); }
00554         void Clear() { m_bit_field.Clear(); }
00555
00556     private:
00557         BitField<SdlByte> m_bit_field;
00558 };
00559
00560 /*  ========================================================================
00561     SimSelectItemOptions
00562     ========================================================================*/
00564 class SimSelectItemOptions {
00565     public:
00567         SimSelectItemOptions(SdlByte bit_field = 0);
00569         ~SimSelectItemOptions();
00570
00572         BOOLEAN PresentationTypeAvailable() const       { return ( m_bit_field.GetBit(0)); };
00575         BOOLEAN PresentationAsNavigationOptions() const { return ( m_bit_field.GetBit(1)); };
00577         BOOLEAN SelectionByUsingSoftkey() const         { return ( m_bit_field.GetBit(2)); };
00579         BOOLEAN HelpAvailable() const                   { return ( m_bit_field.GetBit(7)); };
00580
00582         UINT8 Get() const { return (m_bit_field.Get()); }
00584         void Clear() { m_bit_field.Clear(); }
00585
00586     private:
00587         BitField<SdlByte> m_bit_field;
00588 };
00589
00590 /*  ========================================================================
00591     SimSetupMenuOptions
00592     ========================================================================*/
00594 class SimSetupMenuOptions {
00595     public:
00597         SimSetupMenuOptions(SdlByte bit_field = 0);
00599         ~SimSetupMenuOptions();
00600
00602         BOOLEAN SelectionByUsingSoftkey() const { return ( m_bit_field.GetBit(0)); };
00604         BOOLEAN HelpAvailable() const           { return ( m_bit_field.GetBit(7)); };
00605
00607         UINT8 Get() const { return (m_bit_field.Get()); }
00609         void Clear() { m_bit_field.Clear(); }
00610
00611     private:
00612         BitField<SdlByte> m_bit_field;
00613 };
00614
00615 /*  ========================================================================
00616     SimSetupIdleModeTextOptions
00617     ========================================================================*/
00619 class SimSetupIdleModeTextOptions {
00620     public:
00622         SimSetupIdleModeTextOptions(SdlByte bit_field = 0);
00624         ~SimSetupIdleModeTextOptions();
00625
00627         UINT8 Get() const { return (m_bit_field.Get()); }
00629         void Clear() { m_bit_field.Clear(); }
00630
00631     private:
00632         BitField<SdlByte> m_bit_field;
00633 };
00634
00635 /*  ========================================================================
00636     ProactiveCauseMapper
00637     ========================================================================*/
00639 class ProactiveCauseMapper {
00640     public:
00641
00643         static T_MI_PROACTIVE_CAUSE ToSdl(ProactiveCause pc, BOOLEAN return_default = TRUE);
00644
00646         static T_MI_PROACTIVE_CAUSE ToSdlExt(ProactiveCause pc, SdlByte &general_result, SdlByte &additional_result);
00647
00648     private:
00649
00650 }; // ProactiveCauseMapper
00651
00652 /*  ========================================================================
00653     SimTkTransactionId
00654     ========================================================================*/
00656 #if ! defined(APOXI_SIMTK_TRANSACTIONID_SUPPORT)
00657 struct T_STK_TRANSACTION_ID
00658 {
00659     SdlByte transaction_id;
00660     SdlByte cmd_number;
00661 };
00662 #endif
00663
00664 class SimTkTransactionId {
00665     public:
00666         SimTkTransactionId() { m_id.transaction_id = 0; m_id.cmd_number = 0; }
00667         SimTkTransactionId(const T_STK_TRANSACTION_ID & id) : m_id(id) {}
00668
00669         const T_STK_TRANSACTION_ID & GetId() const { return m_id; }
00670
00671     private:
00672         T_STK_TRANSACTION_ID m_id;
00673
00674 }; // SimTkTransactionId
00675
00676 /*  ========================================================================
00677     SimTkProfile
00678     ========================================================================*/
00679
00681 class SimTkProfile {
00682     public:
00684         enum Feature {              // (byte-1)*8 + (bitno-1)
00686             MenuSelection =         (1-1)*8 + (4-1),
00688             UCS2EntrySupported =    (2-1)*8 + (6-1),
00690             UCS2DisplaySupported =  (2-1)*8 + (7-1),
00692             DisplayExtensionText =  (2-1)*8 + (8-1),
00694             BinaryChoiceGetInkey =  (8-1)*8 + (4-1),
00696             ScreenSizingParameters =(14-1)*8 +(8-1),
00698             VariableSizeFontSupport=(15-1)*8 +(8-1),
00700             DisplayResizable =      (16-1)*8 +(1-1),
00702             TextWrapping =          (16-1)*8 +(2-1),
00704             TextScrolling =         (16-1)*8 +(3-1),
00706             WidthReductionInAMenu = (16-1)*8 +(8-1),
00707
00708             // to be continued on request
00709         };
00710
00711         SimTkProfile(const T_PROFILE & profile) : m_profile(profile) { }
00712
00713         SimTkProfile(const SimTkProfile & profile) : m_profile(profile.m_profile) { }
00714
00715         SimTkProfile() { memset((void*)&m_profile,0x00,sizeof(m_profile)); }
00716
00717         const T_PROFILE & GetProfile() const { return m_profile; }
00718
00719         void SetNumberOfCharsSupportedInDisplay(UINT8 no) {
00720             m_profile.data.A[13] = (m_profile.data.A[13] & 0xE0) + (no & 0x1F);
00721         }
00722
00723         void SetNumberOfCharsAcrossDisplay(UINT8 no) {
00724             m_profile.data.A[14] = (m_profile.data.A[14] & 0x80) + (no & 0x7F);
00725         }
00726
00727         void SetFeature(Feature no, BOOLEAN set = TRUE) {
00728             INT byteno = no / 8;
00729             UINT8 pbyte = m_profile.data.A[byteno];
00730             UINT8 mask = 1 << (no - (byteno*8));
00731             pbyte = set ? (pbyte | mask) : (pbyte & ~mask);
00732             m_profile.data.A[byteno] = pbyte;
00733         }
00734
00735     private:
00736         T_PROFILE m_profile;
00737
00738 }; // SimTkTransactionId
00739
00740
00741 /*  ========================================================================
00742     SimTk Parameter Macros
00743     ========================================================================*/
00744 //
00745 // These macros are necessary because nearly all simtoolkit signals for certain
00746 // stacks will contain an optional additional transactionid on first position of
00747 // the parameters. If compiling with the #define APOXI_SIMTK_TRANSACTIONID_SUPPORT
00748 // the order is without the first additional parameter
00749
00750 #if ! defined(APOXI_SIMTK_TRANSACTIONID_SUPPORT)
00751 // if no transaction id is supported by stack, return an empty object
00752     #define SimtkSignalTid     SimTkTransactionId()
00753     #define SimtkSignalParam1  ApoxiSdlSignalDataParam(1)
00754     #define SimtkSignalParam2  ApoxiSdlSignalDataParam(2)
00755     #define SimtkSignalParam3  ApoxiSdlSignalDataParam(3)
00756     #define SimtkSignalParam4  ApoxiSdlSignalDataParam(4)
00757     #define SimtkSignalParam5  ApoxiSdlSignalDataParam(5)
00758     #define SimtkSignalParam6  ApoxiSdlSignalDataParam(6)
00759     #define SimtkSignalParam7  ApoxiSdlSignalDataParam(7)
00760     #define SimtkSignalParam8  ApoxiSdlSignalDataParam(8)
00761     #define SimtkSignalParam9  ApoxiSdlSignalDataParam(9)
00762     #define SimtkSignalParam10  ApoxiSdlSignalDataParam(10)
00763     #define SimtkSignalParam11  ApoxiSdlSignalDataParam(11)
00764
00765 // if no transaction id is supported by stack, don³t expand the code
00766     #define SimtkSetSignalTid(param)
00767     #define SimtkSetSignalParam1(param)  ApoxiSdlSetOutSignalParam(1,param)
00768     #define SimtkSetSignalParam2(param)  ApoxiSdlSetOutSignalParam(2,param)
00769     #define SimtkSetSignalParam3(param)  ApoxiSdlSetOutSignalParam(3,param)
00770     #define SimtkSetSignalParam4(param)  ApoxiSdlSetOutSignalParam(4,param)
00771     #define SimtkSetSignalParam5(param)  ApoxiSdlSetOutSignalParam(5,param)
00772     #define SimtkSetSignalParam6(param)  ApoxiSdlSetOutSignalParam(6,param)
00773     #define SimtkSetSignalParam7(param)  ApoxiSdlSetOutSignalParam(7,param)
00774     #define SimtkSetSignalParam8(param)  ApoxiSdlSetOutSignalParam(8,param)
00775     #define SimtkSetSignalParam9(param)  ApoxiSdlSetOutSignalParam(9,param)
00776     #define SimtkSetSignalParam10(param)  ApoxiSdlSetOutSignalParam(10,param)
00777     #define SimtkSetSignalParam11(param)  ApoxiSdlSetOutSignalParam(11,param)
00778 #else
00779     #define SimtkSignalTid     ApoxiSdlSignalDataParam(1)
00780     #define SimtkSignalParam1  ApoxiSdlSignalDataParam(2)
00781     #define SimtkSignalParam2  ApoxiSdlSignalDataParam(3)
00782     #define SimtkSignalParam3  ApoxiSdlSignalDataParam(4)
00783     #define SimtkSignalParam4  ApoxiSdlSignalDataParam(5)
00784     #define SimtkSignalParam5  ApoxiSdlSignalDataParam(6)
00785     #define SimtkSignalParam6  ApoxiSdlSignalDataParam(7)
00786     #define SimtkSignalParam7  ApoxiSdlSignalDataParam(8)
00787     #define SimtkSignalParam8  ApoxiSdlSignalDataParam(9)
00788     #define SimtkSignalParam9  ApoxiSdlSignalDataParam(10)
00789     #define SimtkSignalParam10 ApoxiSdlSignalDataParam(11)
00790     #define SimtkSignalParam11 ApoxiSdlSignalDataParam(12)
00791
00792     #define SimtkSetSignalTid(param)     ApoxiSdlSetOutSignalParam(1,param.GetId())
00793     #define SimtkSetSignalParam1(param)  ApoxiSdlSetOutSignalParam(2,param)
00794     #define SimtkSetSignalParam2(param)  ApoxiSdlSetOutSignalParam(3,param)
00795     #define SimtkSetSignalParam3(param)  ApoxiSdlSetOutSignalParam(4,param)
00796     #define SimtkSetSignalParam4(param)  ApoxiSdlSetOutSignalParam(5,param)
00797     #define SimtkSetSignalParam5(param)  ApoxiSdlSetOutSignalParam(6,param)
00798     #define SimtkSetSignalParam6(param)  ApoxiSdlSetOutSignalParam(7,param)
00799     #define SimtkSetSignalParam7(param)  ApoxiSdlSetOutSignalParam(8,param)
00800     #define SimtkSetSignalParam8(param)  ApoxiSdlSetOutSignalParam(9,param)
00801     #define SimtkSetSignalParam9(param)  ApoxiSdlSetOutSignalParam(10,param)
00802     #define SimtkSetSignalParam10(param)  ApoxiSdlSetOutSignalParam(11,param)
00803     #define SimtkSetSignalParam11(param)  ApoxiSdlSetOutSignalParam(12,param)
00804 #endif
00805
00806
00807 #endif  // Apc_SimTkTypes_hpp
00808
00809
Generated on Tue Jan 24 14:46:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Sms.cpp File Reference

Apc/Sms.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Sms.hpp"

Include dependency graph for Sms.cpp:

Generated on Tue Jan 24 17:07:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Sms.hpp File Reference

Apc/Sms.hpp File Reference

#include <Auxiliary/PhoneNumber.hpp>
#include <Apc/CommandType.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <Apc/MessageTypeIndicator.hpp>
#include <Apc/ParameterIndicator.hpp>
#include <Apc/ProtocolIdentifier.hpp>
#include <Apc/ShortMessageFailureCause.hpp>
#include <Apc/ShortMessageStatus.hpp>
#include <Apc/ValidityPeriod.hpp>
#include <Apc/SimDataTypes.hpp>
#include <Apc/Tpdu.hpp>
#include <Apc/UserData.hpp>
#include <Apc/MdhTypes.hpp>

Include dependency graph for Sms.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Sms
class | SmsCommand
class | SmsDeliver
class | SmsStatusReport
class | SmsSubmit

Defines

#define | Apc_Sms_hpp

Define Documentation

#define Apc_Sms_hpp

Generated on Tue Jan 24 17:07:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Sms.hpp Source File

Apc/Sms.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Sms_hpp)
00009 #define Apc_Sms_hpp
00010
00011 #include <Auxiliary/PhoneNumber.hpp>
00012
00013 #include <Apc/CommandType.hpp>
00014 #include <Apc/DataCodingScheme.hpp>
00015 #include <Apc/MessageTypeIndicator.hpp>
00016 #include <Apc/ParameterIndicator.hpp>
00017 #include <Apc/ProtocolIdentifier.hpp>
00018 #include <Apc/ShortMessageFailureCause.hpp>
00019 #include <Apc/ShortMessageStatus.hpp>
00020 #include <Apc/ValidityPeriod.hpp>
00021
00022 #include <Apc/SimDataTypes.hpp>
00023 #include <Apc/Tpdu.hpp>
00024 #include <Apc/UserData.hpp>
00025 #include <Apc/MdhTypes.hpp>
00026
00027
00028
00029 /*  ========================================================================
00030     Sms - 3GPP TS 23.040 V5.1.0
00031     ======================================================================== */
00035 class Sms {
00036     public:
00038         enum StorageType {
00040             Sim = MN_SIM_STORAGE,
00042             Flash = MN_FLASH_STORAGE_MODE,
00044             None = MN_STORAGE_NONE,
00046             SimPreferred,
00048             FlashPreferred,
00050             SharedMemory,
00052             Preferred
00053         };
00054
00056         enum Result {
00058             UnassignedNumber            = MN_SMS_UNASSIGNED_NUMBER,
00060             OpDeterminedBarring         = MN_SMS_OP_DETERMINED_BARRING,
00062             CallBarred                  = MN_SMS_CALL_BARRED,
00064             CpNetworkFailure            = MN_SMS_CP_NETWORK_FAILURE,
00066             TransferRejected            = MN_SMS_TRANSFER_REJECTED,
00068             MemoryCapacityExceeded      = MN_SMS_MEMORY_CAPACITY_EXCEEDED,
00070             DestOutOfService            = MN_SMS_DEST_OUT_OF_SERVICE,
00072             UnidentifiedSubscriber      = MN_SMS_UNIDENTIFIED_SUBSCRIBER,
00074             FacilityRejected            = MN_SMS_FACILITY_REJECTED,
00076             UnknownSubscriber           = MN_SMS_UNKNOWN_SUBSCRIBER,
00078             NetworkOutOfOrder           = MN_SMS_NETWORK_OUT_OF_ORDER,
00080             TemporaryFailure            = MN_SMS_TEMPORARY_FAILURE,
00082             Congestion                  = MN_SMS_CONGESTION,
00084             ResourcesUnavailable        = MN_SMS_RESOURCES_UNAVAILABLE,
00086             FacilityNotSubscribed       = MN_SMS_FACILITY_NOT_SUBSCRIBED,
00088             ReqFaciltyNonImpl           = MN_SMS_REQ_FACILTY_NON_IMPL,
00090             InvalidReferenceValue       = MN_SMS_INVALID_REFERENCE_VALUE,
00092             SemantIncorrectMsg          = MN_SMS_SEMANT_INCORRECT_MSG,
00094             InvalidMandatoryInfo        = MN_SMS_INVALID_MANDATORY_INFO,
00096             MsgTypeNonExistent          = MN_SMS_MSG_TYPE_NON_EXISTENT,
00098             MsgNotCompatible            = MN_SMS_MSG_NOT_COMPATIBLE,
00100             IeNonExistent               = MN_SMS_IE_NON_EXISTENT,
00102             ProtocollError              = MN_SMS_PROTOCOLL_ERROR,
00104             Interworking                = MN_SMS_INTERWORKING,
00105
00107             RpAck                       = MN_SMS_RP_ACK,
00109             TimerExpired                = MN_SMS_TIMER_EXPIRED,
00111             ForwAvailFailed             = MN_SMS_FORW_AVAIL_FAILED,
00113             ForwAvailAborted            = MN_SMS_FORW_AVAIL_ABORTED,
00114
00116             TpInvalidMti                = MN_TP_INVALID_MTI,
00118             TpSrfNotInPhase1            = MN_TP_SRF_NOT_IN_PHASE1,
00120             TpRdfNotInPhase1            = MN_TP_RDF_NOT_IN_PHASE1,
00122             TpRpfNotInPhase1            = MN_TP_RPF_NOT_IN_PHASE1,
00124             TpUdhfNotInPhase1           = MN_TP_UDHF_NOT_IN_PHASE1,
00126             TpMissingValidityPeriod     = MN_TP_MISSING_VALIDITY_PERIOD,
00128             TpInvalidTimeStamp          = MN_TP_INVALID_TIME_STAMP,
00130             TpMissingDestAddress        = MN_TP_MISSING_DEST_ADDRESS,
00132             TpInvalidDestAddress        = MN_TP_INVALID_DEST_ADDRESS,
00134             TpMissingScAddress          = MN_TP_MISSING_SC_ADDRESS,
00136             TpInvalidScAddress          = MN_TP_INVALID_SC_ADDRESS,
00138             TpInvalidAlphabet           = MN_TP_INVALID_ALPHABET,
00140             TpInvalidUserDataLength     = MN_TP_INVALID_USER_DATA_LENGTH,
00142             TpMissingUserData           = MN_TP_MISSING_USER_DATA,
00144             TpUserDataTooLarge          = MN_TP_USER_DATA_TOO_LARGE,
00146             TpCmdReqNotInPhase1         = MN_TP_CMD_REQ_NOT_IN_PHASE1,
00148             TpInvalidDestAddrSpecCmds   = MN_TP_INVALID_DEST_ADDR_SPEC_CMDS,
00150             TpInvalidCmdDataLength      = MN_TP_INVALID_CMD_DATA_LENGTH,
00152             TpMissingCmdData            = MN_TP_MISSING_CMD_DATA,
00154             TpInvalidCmdData_Type       = MN_TP_INVALID_CMD_DATA_TYPE,
00156             TpCreationOfMnrFailed       = MN_TP_CREATION_OF_MNR_FAILED,
00158             TpMtConnectionLost          = MN_TP_MT_CONNECTION_LOST,
00160             TpPendingMoSms              = MN_TP_PENDING_MO_SMS,
00161
00163             NoError                     = MN_SMS_NO_ERROR,
00165             NoErrorNoIconDisplay        = MN_SMS_NO_ERROR_NO_ICON_DISPLAY,
00167             FdnFailed                   = MN_SMS_FDN_FAILED,
00169             BdnFailed                   = MN_SMS_BDN_FAILED,
00170
00172             PpUnspecified               = SMS_PP_UNSPECIFIED,
00173
00175             AssemblingError,
00176
00178             TpduDataMissing,
00179
00181             InvalidStoreLocation,
00182
00184             UndefinedResult
00185         };
00186
00188         enum WarningLevel {
00190             CapacityExceed  = MdhRejMemoryExceeded,
00192             SimIsFull       = MdhRejSimIsFull,
00194             SimNotUsed      = MdhRejSimIsNotInView,
00196             NoSmsOnSim      = MdhRejSimNoSms,
00198             WarningSimIsFull = MdhWarnSmStorageSimIsFull,
00200             SimStorageGetsFree = MdhSmStorageSimIsFree,
00202             MemoryFull
00203         };
00205         Sms(Tpdu *tpdu);
00207         ~Sms();
00208
00210         MessageTypeIndicator::Type GetType() const { return (m_sms_type); }
00212         PhoneNumber GetServiceCentreAddress() const;
00214         void SetServiceCentreAddress(const PhoneNumber &phone_number);
00216         UINT8* GetData() const { return (m_tp_data); }
00217
00218     protected:
00219         enum {
00221             c_tpdu_size = 164,
00222         };
00223
00224         Tpdu *m_tpdu;
00225         UINT8 *m_tp_data;
00226         MessageTypeIndicator::Type m_sms_type;
00227
00230         BOOLEAN GetBit(INT offset, UINT8 bit_no) const;
00233         void SetBit(INT offset, UINT8 bit_no, BOOLEAN flag);
00234
00236         void Init();
00237 };
00238
00239
00240 /*  ========================================================================
00241     SmsDeliver - 3GPP TS 23.040 V5.1.0 [9.2.2.1]
00242     ======================================================================== */
00246 class SmsDeliver : public Sms {
00247     public:
00248         typedef Sms Base;
00249
00250         enum { ID = MessageTypeIndicator::Deliver };
00251
00252         enum {
00254             c_max_guaranteed_user_data_size = 140
00255         };
00256
00258         SmsDeliver(Tpdu *tpdu);
00260         ~SmsDeliver();
00261
00263         BOOLEAN MoreMessagesToSend() const;
00264
00266         BOOLEAN ReturnReport() const;
00267
00269         BOOLEAN UserDataHeaderExists() const;
00270
00272         BOOLEAN ReplyPathExists() const;
00274         void SetReplyPathExists(BOOLEAN flag = TRUE);
00275
00277         PhoneNumber GetOriginatingAddress() const;
00278
00280         ProtocolIdentifier GetProtocolIdentifier() const;
00282         void SetProtocolIdentifier(ProtocolIdentifier protocol_identifier);
00283
00285         DataCodingScheme GetDataCodingScheme() const;
00286
00288         CodedTimeStamp GetServiceCentreTimeStamp() const;
00289
00291         UserData GetUserData() const;
00292
00294         WString GetText() const;
00295
00298         INT GetMaxUserDataSize() const;
00299
00300
00302         INT GetPayloadSize() const;
00304         INT GetPayloadOffset() const;
00306         UINT8* GetPayloadData() const;
00307
00308     private:
00310         INT AddressOffset() const { return (1); }
00311
00313         INT AfterAddressOffset() const;
00314
00317         INT DataOffset() const;
00318
00319 };  // class SmsDeliver
00320
00321
00322 /*  ========================================================================
00323     SmsSubmit - 3GPP TS 23.040 V5.1.0 [9.2.2.2]
00324     ======================================================================== */
00328 class SmsSubmit : public Sms {
00329     friend class SmsFactory;
00330     public:
00331         typedef Sms Base;
00332
00333         enum { ID = MessageTypeIndicator::Submit };
00334
00335         enum {
00337             c_max_guaranteed_user_data_size = 140
00338         };
00339
00341         SmsSubmit(Tpdu *tpdu);
00343         ~SmsSubmit();
00344
00346         BOOLEAN RejectDuplicates() const;
00348         void SetRejectDuplicates(BOOLEAN flag = TRUE);
00349
00351         ValidityPeriodFormat GetValidityPeriodFormat() const;
00353         void SetValidityPeriodFormat(const ValidityPeriodFormat &vpf);
00354
00356         BOOLEAN RequestReport() const;
00358         void SetRequestReport(BOOLEAN flag = TRUE);
00359
00361         BOOLEAN UserDataHeaderExists() const;
00363         void SetUserDataHeaderExists(BOOLEAN flag = TRUE);
00364
00366         BOOLEAN RequestReplyPath() const;
00368         void SetRequestReplyPath(BOOLEAN flag = TRUE);
00369
00371         SmsReferenceNumber GetMessageReference() const;
00373         void SetMessageReference(const SmsReferenceNumber &message_reference);
00374
00376         PhoneNumber GetDestinationAddress() const;
00378         void SetDestinationAddress(const PhoneNumber &phone_number);
00379
00381         ProtocolIdentifier GetProtocolIdentifier() const;
00383         void SetProtocolIdentifier(ProtocolIdentifier protocol_identifier);
00384
00386         DataCodingScheme GetDataCodingScheme() const;
00388         void SetDataCodingScheme(const DataCodingScheme &dcs);
00389
00391         ValidityPeriod GetValidityPeriod() const;
00393         void SetValidityPeriod(const ValidityPeriod &vp);
00394
00396         UserData GetUserData() const;
00397
00399         WString GetText() const;
00400
00402         INT Trim();
00403
00406         INT GetMaxUserDataSize() const;
00407
00408     private:
00410         INT AddressOffset() const { return (2); }
00411
00413         INT AfterAddressOffset() const;
00414
00417         INT DataOffset() const;
00418 };  // class SmsSubmit
00419
00420
00421 /*  ========================================================================
00422     SmsStatusReport - 3GPP TS 23.040 V5.1.0 [9.2.2.3]
00423     ======================================================================== */
00427 class SmsStatusReport : public Sms {
00428     public:
00429         typedef Sms Base;
00430
00431         enum { ID = MessageTypeIndicator::StatusReport };
00432
00433         enum {
00435             c_max_guaranteed_user_data_size = 131
00436         };
00437
00439         SmsStatusReport(Tpdu *tpdu);
00441         ~SmsStatusReport();
00442
00444         BOOLEAN MoreMessagesToSend() const;
00445
00447         MessageTypeIndicator::Type GetInitialType() const;
00448
00450         BOOLEAN UserDataHeaderExists() const;
00451
00453         SmsReferenceNumber GetMessageReference() const;
00454
00456         PhoneNumber GetRecipientAddress() const;
00457
00459         CodedTimeStamp GetServiceCentreTimeStamp() const;
00460
00462         CodedTimeStamp GetDischargeTime() const;
00463
00465         ShortMessageStatus GetResultStatus() const;
00466
00468         ParameterIndicator GetParameterIndicator() const;
00469
00471         ProtocolIdentifier GetProtocolIdentifier() const;
00472
00474         DataCodingScheme GetDataCodingScheme() const;
00475
00478         UserData GetUserData() const;
00479
00481         WString GetText() const;
00482
00485         INT GetMaxUserDataSize() const;
00486
00487     private:
00489         INT AddressOffset() const { return (2); }
00490
00492         INT AfterAddressOffset() const;
00493
00496         INT DataOffset() const;
00497
00498 };  // class SmsStatusReport
00499
00500
00501 /*  ========================================================================
00502     SmsCommand - 3GPP TS 23.040 V5.1.0 [9.2.2.4]
00503     ======================================================================== */
00507 class SmsCommand : public Sms {
00508     friend class SmsFactory;
00509     public:
00510         typedef Sms Base;
00511
00512         enum { ID = MessageTypeIndicator::Command };
00513
00514         enum {
00516             c_max_guaranteed_user_data_size = 146
00517         };
00518
00520         SmsCommand(Tpdu *tpdu);
00522         ~SmsCommand();
00523
00525         BOOLEAN RequestReport() const;
00527         void SetRequestReport(BOOLEAN flag = TRUE);
00528
00530         BOOLEAN UserDataHeaderExists() const;
00532         void SetUserDataHeaderExists(BOOLEAN flag = TRUE);
00533
00535         SmsReferenceNumber GetMessageReference() const;
00537         void SetMessageReference(const SmsReferenceNumber &message_reference);
00538
00540         ProtocolIdentifier GetProtocolIdentifier() const;
00542         void SetProtocolIdentifier(ProtocolIdentifier protocol_identifier);
00543
00545         CommandType GetCommandType() const;
00547         void SetCommandType(CommandType command_type);
00548
00550         SmsReferenceNumber GetMessageNumber() const;
00552         void SetMessageNumber(SmsReferenceNumber message_number);
00553
00555         PhoneNumber GetDestinationAddress() const;
00557         void SetDestinationAddress(const PhoneNumber &phone_number);
00558
00560         UserData GetCommandData() const;
00561
00563         INT Trim();
00564
00567         INT GetMaxUserDataSize() const;
00568
00569     private:
00571         INT AddressOffset() const { return (5); }
00572
00574         INT AfterAddressOffset() const;
00575
00578         INT DataOffset() const;
00579
00580 };  // class SmsCommand
00581
00582
00583 #endif  // Apc_Sms_hpp
00584
Generated on Tue Jan 24 14:46:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SmsStackMsgArgs.cpp File Reference

Apc/SmsStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "SmsStackMsgArgs.hpp"

Include dependency graph for SmsStackMsgArgs.cpp:

Generated on Tue Jan 24 17:08:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SmsStackMsgArgs.hpp File Reference

Apc/SmsStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/SimDataTypes.hpp>
#include <Apc/Sms.hpp>
#include <Apc/MdhTypes.hpp>
#include <Apc/SimTkTypes.hpp>

Include dependency graph for SmsStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsCapacityAvailableArg
class | SmsCapacityExceededArg
class | SmsConfigIndArg
class | SmsGetMoreMessageStatusIndArg
class | SmsGetMoreMessageStatusReqArg
class | SmsNewMessageIndArg
class | SmsNewStatusReportIndArg
class | SmsSendCnfArg
class | SmsSendRejArg
class | SmsSendReqArg
class | SmsSetMoreMessageReqArg

Defines

#define | Apc_SmsStackMsgArgs_hpp

Define Documentation

#define Apc_SmsStackMsgArgs_hpp

Generated on Tue Jan 24 17:08:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SmsStackMsgArgs.hpp Source File

Apc/SmsStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "auzinger_apoxi_test_dv\lnz_apoxi\Apoxi\Apc\SmsArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_SmsStackMsgArgs_hpp)
00016 #define Apc_SmsStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/NetworkTypes.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Apc/SimDataTypes.hpp>
00022 #include <Apc/Sms.hpp>
00023 #include <Apc/MdhTypes.hpp>
00024 #include <Apc/SimTkTypes.hpp>
00025
00026
00027 /* ----------------------------------------------------------------------
00028     Classes
00029     ---------------------------------------------------------------------- */
00030
00031 /*  ======================================================================
00032     Class SmsNewMessageIndArg
00033     ====================================================================== */
00034
00036 class SmsNewMessageIndArg : public StackMsgArgument {
00037     friend class CommonStackMsgArgsDestroyTableNode;
00038     public:
00039         SmsNewMessageIndArg();
00040
00041         static const SmsNewMessageIndArg& Cast(const StackMsgArgument& arg);
00042         void SetStorageType(const Sms::StorageType& storage_type) { m_storage_type = storage_type; }
00043         const Sms::StorageType& GetStorageType() const { return m_storage_type; }
00044         void SetStoragePosition(INT storage_position) { m_storage_position = storage_position; }
00045         INT GetStoragePosition() const { return m_storage_position; }
00046         void SetProtocolIdentifier(const ProtocolIdentifier& protocol_identifier) { m_protocol_identifier = protocol_identifier; }
00047         const ProtocolIdentifier& GetProtocolIdentifier() const { return m_protocol_identifier; }
00048         void SetDataCodingScheme(const DataCodingScheme& data_coding_scheme) { m_data_coding_scheme = data_coding_scheme; }
00049         const DataCodingScheme& GetDataCodingScheme() const { return m_data_coding_scheme; }
00050         void SetOaPhoneNumber(const PhoneNumber& oa_phone_number) { m_oa_phone_number = oa_phone_number; }
00051         const PhoneNumber& GetOaPhoneNumber() const { return m_oa_phone_number; }
00052
00053         enum  {
00054             ID = 2560
00055             };
00056
00057     private:
00058
00059         static void Destroy(StackMsgArgument* arg) { delete ((SmsNewMessageIndArg*) arg); }
00060
00061         Sms::StorageType m_storage_type;
00062         INT m_storage_position;
00063         ProtocolIdentifier m_protocol_identifier;
00064         DataCodingScheme m_data_coding_scheme;
00065         PhoneNumber m_oa_phone_number;
00066
00067     };
00068
00069 // Inline definitions
00070 inline const SmsNewMessageIndArg& SmsNewMessageIndArg::Cast(const StackMsgArgument& arg) {
00071     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsNewMessageIndArg!\n");
00072     return ((SmsNewMessageIndArg &) arg);
00073 }
00074
00075
00076
00077 /*  ======================================================================
00078     Class SmsNewStatusReportIndArg
00079     ====================================================================== */
00080
00082 class SmsNewStatusReportIndArg : public StackMsgArgument {
00083     friend class CommonStackMsgArgsDestroyTableNode;
00084     public:
00085         SmsNewStatusReportIndArg();
00086
00087         static const SmsNewStatusReportIndArg& Cast(const StackMsgArgument& arg);
00088         void SetStorageType(const Sms::StorageType& storage_type) { m_storage_type = storage_type; }
00089         const Sms::StorageType& GetStorageType() const { return m_storage_type; }
00090         void SetStoragePosition(INT storage_position) { m_storage_position = storage_position; }
00091         INT GetStoragePosition() const { return m_storage_position; }
00092         void SetReferenceNumber(const SmsReferenceNumber& reference_number) { m_reference_number = reference_number; }
00093         const SmsReferenceNumber& GetReferenceNumber() const { return m_reference_number; }
00094         void SetShortMessageStatus(const ShortMessageStatus& short_message_status) { m_short_message_status = short_message_status; }
00095         const ShortMessageStatus& GetShortMessageStatus() const { return m_short_message_status; }
00096         void SetSmsrLocation(const MdhSmsrLocation& smsr_location) { m_smsr_location = smsr_location; }
00097         const MdhSmsrLocation& GetSmsrLocation() const { return m_smsr_location; }
00098         void SetRecipientPhoneNumber(const PhoneNumber& recipient_phone_number) { m_recipient_phone_number = recipient_phone_number; }
00099         const PhoneNumber& GetRecipientPhoneNumber() const { return m_recipient_phone_number; }
00100
00101         enum  {
00102             ID = 2561
00103             };
00104
00105     private:
00106
00107         static void Destroy(StackMsgArgument* arg) { delete ((SmsNewStatusReportIndArg*) arg); }
00108
00109         Sms::StorageType m_storage_type;
00110         INT m_storage_position;
00111         SmsReferenceNumber m_reference_number;
00112         ShortMessageStatus m_short_message_status;
00113         MdhSmsrLocation m_smsr_location;
00114         PhoneNumber m_recipient_phone_number;
00115
00116     };
00117
00118 // Inline definitions
00119 inline const SmsNewStatusReportIndArg& SmsNewStatusReportIndArg::Cast(const StackMsgArgument& arg) {
00120     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsNewStatusReportIndArg!\n");
00121     return ((SmsNewStatusReportIndArg &) arg);
00122 }
00123
00124
00125
00126 /*  ======================================================================
00127     Class SmsSendCnfArg
00128     ====================================================================== */
00129
00131 class SmsSendCnfArg : public StackMsgArgument {
00132     friend class CommonStackMsgArgsDestroyTableNode;
00133     public:
00134         SmsSendCnfArg();
00135
00136         static const SmsSendCnfArg& Cast(const StackMsgArgument& arg);
00137         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00138         const SimTkTransactionId& GetTid() const { return m_tid; }
00139         void SetResult(const Sms::Result& result) { m_result = result; }
00140         const Sms::Result& GetResult() const { return m_result; }
00141         void SetShortMessageFailure(BOOLEAN short_message_failure) { m_short_message_failure = short_message_failure; }
00142         BOOLEAN IsShortMessageFailure() const { return m_short_message_failure; }
00143         void SetShortMessageFailureCause(const ShortMessageFailureCause& short_message_failure_cause) { m_short_message_failure_cause = short_message_failure_cause; }
00144         const ShortMessageFailureCause& GetShortMessageFailureCause() const { return m_short_message_failure_cause; }
00145         void SetReferenceNumber(const SmsReferenceNumber& reference_number) { m_reference_number = reference_number; }
00146         const SmsReferenceNumber& GetReferenceNumber() const { return m_reference_number; }
00147
00148         enum  {
00149             ID = 2562
00150             };
00151
00152     private:
00153
00154         static void Destroy(StackMsgArgument* arg) { delete ((SmsSendCnfArg*) arg); }
00155
00156         SimTkTransactionId m_tid;
00157         Sms::Result m_result;
00158         BOOLEAN m_short_message_failure;
00159         ShortMessageFailureCause m_short_message_failure_cause;
00160         SmsReferenceNumber m_reference_number;
00161
00162     };
00163
00164 // Inline definitions
00165 inline const SmsSendCnfArg& SmsSendCnfArg::Cast(const StackMsgArgument& arg) {
00166     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsSendCnfArg!\n");
00167     return ((SmsSendCnfArg &) arg);
00168 }
00169
00170
00171
00172 /*  ======================================================================
00173     Class SmsSendRejArg
00174     ====================================================================== */
00175
00177 class SmsSendRejArg : public StackMsgArgument {
00178     friend class CommonStackMsgArgsDestroyTableNode;
00179     public:
00180         SmsSendRejArg();
00181
00182         static const SmsSendRejArg& Cast(const StackMsgArgument& arg);
00183         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
00184         const SimTkTransactionId& GetTid() const { return m_tid; }
00185         void SetResult(const Sms::Result& result) { m_result = result; }
00186         const Sms::Result& GetResult() const { return m_result; }
00187
00188         enum  {
00189             ID = 2563
00190             };
00191
00192     private:
00193
00194         static void Destroy(StackMsgArgument* arg) { delete ((SmsSendRejArg*) arg); }
00195
00196         SimTkTransactionId m_tid;
00197         Sms::Result m_result;
00198
00199     };
00200
00201 // Inline definitions
00202 inline const SmsSendRejArg& SmsSendRejArg::Cast(const StackMsgArgument& arg) {
00203     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsSendRejArg!\n");
00204     return ((SmsSendRejArg &) arg);
00205 }
00206
00207
00208
00209 /*  ======================================================================
00210     Class SmsCapacityExceededArg
00211     ====================================================================== */
00212
00214 class SmsCapacityExceededArg : public StackMsgArgument {
00215     friend class CommonStackMsgArgsDestroyTableNode;
00216     public:
00217         SmsCapacityExceededArg();
00218
00219         static const SmsCapacityExceededArg& Cast(const StackMsgArgument& arg);
00220         void SetWarningLevel(const Sms::WarningLevel& warning_level) { m_warning_level = warning_level; }
00221         const Sms::WarningLevel& GetWarningLevel() const { return m_warning_level; }
00222
00223         enum  {
00224             ID = 2564
00225             };
00226
00227     private:
00228
00229         static void Destroy(StackMsgArgument* arg) { delete ((SmsCapacityExceededArg*) arg); }
00230
00231         Sms::WarningLevel m_warning_level;
00232
00233     };
00234
00235 // Inline definitions
00236 inline const SmsCapacityExceededArg& SmsCapacityExceededArg::Cast(const StackMsgArgument& arg) {
00237     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsCapacityExceededArg!\n");
00238     return ((SmsCapacityExceededArg &) arg);
00239 }
00240
00241
00242
00243 /*  ======================================================================
00244     Class SmsCapacityAvailableArg
00245     ====================================================================== */
00246
00248 class SmsCapacityAvailableArg : public StackMsgArgument {
00249     friend class CommonStackMsgArgsDestroyTableNode;
00250     public:
00251         SmsCapacityAvailableArg();
00252
00253         static const SmsCapacityAvailableArg& Cast(const StackMsgArgument& arg);
00254
00255         enum  {
00256             ID = 2565
00257             };
00258
00259     private:
00260
00261         static void Destroy(StackMsgArgument* arg) { delete ((SmsCapacityAvailableArg*) arg); }
00262
00263     };
00264
00265 // Inline definitions
00266 inline const SmsCapacityAvailableArg& SmsCapacityAvailableArg::Cast(const StackMsgArgument& arg) {
00267     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsCapacityAvailableArg!\n");
00268     return ((SmsCapacityAvailableArg &) arg);
00269 }
00270
00271
00272
00273 /*  ======================================================================
00274     Class SmsGetMoreMessageStatusIndArg
00275     ====================================================================== */
00276
00278 class SmsGetMoreMessageStatusIndArg : public StackMsgArgument {
00279     friend class CommonStackMsgArgsDestroyTableNode;
00280     public:
00281         SmsGetMoreMessageStatusIndArg();
00282
00283         static const SmsGetMoreMessageStatusIndArg& Cast(const StackMsgArgument& arg);
00284         void SetSmsMoreMessageType(const SmsMoreMessageType& sms_more_message_type) { m_sms_more_message_type = sms_more_message_type; }
00285         const SmsMoreMessageType& GetSmsMoreMessageType() const { return m_sms_more_message_type; }
00286
00287         enum  {
00288             ID = 2566
00289             };
00290
00291     private:
00292
00293         static void Destroy(StackMsgArgument* arg) { delete ((SmsGetMoreMessageStatusIndArg*) arg); }
00294
00295         SmsMoreMessageType m_sms_more_message_type;
00296
00297     };
00298
00299 // Inline definitions
00300 inline const SmsGetMoreMessageStatusIndArg& SmsGetMoreMessageStatusIndArg::Cast(const StackMsgArgument& arg) {
00301     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsGetMoreMessageStatusIndArg!\n");
00302     return ((SmsGetMoreMessageStatusIndArg &) arg);
00303 }
00304
00305
00306
00307 /*  ======================================================================
00308     Class SmsConfigIndArg
00309     ====================================================================== */
00310
00312 class SmsConfigIndArg : public StackMsgArgument {
00313     friend class CommonStackMsgArgsDestroyTableNode;
00314     public:
00315         SmsConfigIndArg(UINT32 timer);
00316         SmsConfigIndArg();
00317
00318         static const SmsConfigIndArg& Cast(const StackMsgArgument& arg);
00319         void SetTimer(UINT32 timer) { m_timer = timer; }
00320         UINT32 GetTimer() const { return m_timer; }
00321
00322         enum  {
00323             ID = 2508
00324             };
00325
00326     private:
00327
00328         static void Destroy(StackMsgArgument* arg) { delete ((SmsConfigIndArg*) arg); }
00329
00330         UINT32 m_timer;
00331
00332     };
00333
00334 // Inline definitions
00335 inline const SmsConfigIndArg& SmsConfigIndArg::Cast(const StackMsgArgument& arg) {
00336     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsConfigIndArg!\n");
00337     return ((SmsConfigIndArg &) arg);
00338 }
00339
00340
00341
00342 /*  ======================================================================
00343     Class SmsSendReqArg
00344     ====================================================================== */
00345
00347 class SmsSendReqArg : public StackMsgArgument {
00348     friend class CommonStackMsgArgsDestroyTableNode;
00349     public:
00350         SmsSendReqArg(const Tpdu& tpdu, const GsmService& service = InvalidGsmService);
00351         SmsSendReqArg();
00352
00353         static const SmsSendReqArg& Cast(const StackMsgArgument& arg);
00354         void SetTpdu(const Tpdu& tpdu) { m_tpdu = tpdu; }
00355         const Tpdu& GetTpdu() const { return m_tpdu; }
00356         void SetService(const GsmService& service) { m_service = service; }
00357         const GsmService& GetService() const { return m_service; }
00358
00359         enum  {
00360             ID = 2509
00361             };
00362
00363     private:
00364
00365         static void Destroy(StackMsgArgument* arg) { delete ((SmsSendReqArg*) arg); }
00366
00367         Tpdu m_tpdu;
00368         GsmService m_service;
00369
00370     };
00371
00372 // Inline definitions
00373 inline const SmsSendReqArg& SmsSendReqArg::Cast(const StackMsgArgument& arg) {
00374     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsSendReqArg!\n");
00375     return ((SmsSendReqArg &) arg);
00376 }
00377
00378
00379
00380 /*  ======================================================================
00381     Class SmsSetMoreMessageReqArg
00382     ====================================================================== */
00383
00385 class SmsSetMoreMessageReqArg : public StackMsgArgument {
00386     friend class CommonStackMsgArgsDestroyTableNode;
00387     public:
00388         SmsSetMoreMessageReqArg(const SmsMoreMessageType& sms_more_message_type);
00389         SmsSetMoreMessageReqArg();
00390
00391         static const SmsSetMoreMessageReqArg& Cast(const StackMsgArgument& arg);
00392         void SetSmsMoreMessageType(const SmsMoreMessageType& sms_more_message_type) { m_sms_more_message_type = sms_more_message_type; }
00393         const SmsMoreMessageType& GetSmsMoreMessageType() const { return m_sms_more_message_type; }
00394
00395         enum  {
00396             ID = 2510
00397             };
00398
00399     private:
00400
00401         static void Destroy(StackMsgArgument* arg) { delete ((SmsSetMoreMessageReqArg*) arg); }
00402
00403         SmsMoreMessageType m_sms_more_message_type;
00404
00405     };
00406
00407 // Inline definitions
00408 inline const SmsSetMoreMessageReqArg& SmsSetMoreMessageReqArg::Cast(const StackMsgArgument& arg) {
00409     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsSetMoreMessageReqArg!\n");
00410     return ((SmsSetMoreMessageReqArg &) arg);
00411 }
00412
00413
00414
00415 /*  ======================================================================
00416     Class SmsGetMoreMessageStatusReqArg
00417     ====================================================================== */
00418
00420 class SmsGetMoreMessageStatusReqArg : public StackMsgArgument {
00421     friend class CommonStackMsgArgsDestroyTableNode;
00422     public:
00423         SmsGetMoreMessageStatusReqArg();
00424
00425         static const SmsGetMoreMessageStatusReqArg& Cast(const StackMsgArgument& arg);
00426
00427         enum  {
00428             ID = 2511
00429             };
00430
00431     private:
00432
00433         static void Destroy(StackMsgArgument* arg) { delete ((SmsGetMoreMessageStatusReqArg*) arg); }
00434
00435     };
00436
00437 // Inline definitions
00438 inline const SmsGetMoreMessageStatusReqArg& SmsGetMoreMessageStatusReqArg::Cast(const StackMsgArgument& arg) {
00439     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SmsGetMoreMessageStatusReqArg!\n");
00440     return ((SmsGetMoreMessageStatusReqArg &) arg);
00441 }
00442
00443
00444 #endif // Apc_SmsStackMsgArgs_hpp
00445
Generated on Tue Jan 24 14:46:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsErrorCode.hpp File Reference

Apc/SsErrorCode.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for SsErrorCode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsErrorCode
Error Codes, [GSM 04.80, 4.5]. More...

Defines

#define | Apc_SsErrorCode_hpp

Define Documentation

#define Apc_SsErrorCode_hpp

Generated on Tue Jan 24 17:08:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsErrorCode.hpp Source File

Apc/SsErrorCode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights
00003     reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apc_SsErrorCode_hpp)
00010 #define Apc_SsErrorCode_hpp
00011
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/BitField.hpp>
00015
00016
00017 /*  ========================================================================
00018     This type conveys the Error Codes, [GSM 04.80, 4.5]
00019     Values taken from msap_msg_mn.pr line 1481 ff
00020     ========================================================================*/
00022 class SsErrorCode {
00023     public:
00025         enum Code {
00027             MsIntSsError                        = 0,
00029             MsIntSsTimeOut                      = 255,
00031             UnknownSubscriber                   = 1,
00033             IllegalSubscriber                   = 9,
00035             BearerServiceNotProvisioned         = 10,
00037             TeleserviceNotProvisioned           = 11,
00039             IllegalEquipment                    = 12,
00041             CallBarred                          = 13,
00043             IllegalSsOperation                  = 16,
00045             SsErrorStatus                       = 17,
00047             SsNotAvailable                      = 18,
00049             SsSubscriptionViolation             = 19,
00051             SsIncompatibility                   = 20,
00053             FacilityNotSupported                = 21,
00055             AbsentSubscriber                    = 27,
00057             SystemFailure                       = 34,
00059             DataMissing                         = 35,
00061             UnexpectedDataValue                 = 36,
00063             PwRegistrationFailure               = 37,
00065             NegativePwCheck                     = 38,
00067             NumberOfPwAttemptsViolation         = 43,
00069             PositionMethodError                 = 54,
00071             UnknownAlphabet                     = 71,
00073             UssdBusy                            = 72,
00075             MaxNumberOfMptyParticipantsExceeded = 126,
00077             ResourcesNotAvailable               = 127,
00079             TaggedError                         = 128,
00081             NoError
00082         };
00083
00085         SsErrorCode(UINT8 incoming_byte = 0) : m_code(incoming_byte) {}
00086
00088         UINT8 GetByte() const { return m_code; }
00089
00091         Code GetCode() const { return (Code)m_code; }
00093         void SetCode(Code code) { m_code = (UINT8)m_code; }
00094
00095     private:
00096         UINT8 m_code;
00097 };
00098
00099
00100 #endif  // Apc_SsErrorCode_hpp
00101
Generated on Tue Jan 24 14:46:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsNotification.hpp File Reference

Apc/SsNotification.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for SsNotification.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsNotification
Supplementary Service Status [GSM 09.02, 14.7.4]. More...

Defines

#define | Apc_SsNotification_hpp

Define Documentation

#define Apc_SsNotification_hpp

Generated on Tue Jan 24 17:08:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsNotification.hpp Source File

Apc/SsNotification.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights
00003     reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apc_SsNotification_hpp)
00010 #define Apc_SsNotification_hpp
00011
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/BitField.hpp>
00015
00016
00017 /*  ========================================================================
00018     Supplementary Service Status  [GSM 09.02, 14.7.4], (msap_msg_mn.pr: 966)
00019     SS-Notification containing the following information:
00020     bits 87654: 00000 unused
00021     bit 3: Call is forwarded indication to calling subscriber
00022     bit 2: Call is forwarded indication to forwarding subscriber
00023     bit 1: Call is forwarded indication to forwarded-to subscriber
00024     coding defined in [GSM 04.80, 4.4.2]
00025     ========================================================================*/
00027 class SsNotification {
00028     public:
00030         SsNotification(UINT8 incoming_byte = 0) : m_ss_notification(incoming_byte) {};
00031
00033         UINT8 GetByte() const { return m_ss_notification; }
00035         BOOLEAN IsForwardedToCallingSubscriber() const { return m_ss_notification & 0x04; }
00037         BOOLEAN IsForwardedToForwardingSubscriber() const { return m_ss_notification & 0x02; }
00039         BOOLEAN IsForwardedToForwardedToSubscriber() const { return m_ss_notification & 0x01; }
00040
00041     private:
00042         UINT8 m_ss_notification;
00043 };
00044
00045
00046 #endif  // Apc_SsNotification_hpp
00047
00048
Generated on Tue Jan 24 14:46:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsStackMsgArgs.cpp File Reference

Apc/SsStackMsgArgs.cpp File Reference

#include "Apc/PreComp.hpp"
#include "SsStackMsgArgs.hpp"

Include dependency graph for SsStackMsgArgs.cpp:

Generated on Tue Jan 24 17:08:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsStackMsgArgs.hpp File Reference

Apc/SsStackMsgArgs.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <Apc/TaggedProblemCode.hpp>
#include <Apc/SsErrorCode.hpp>
#include <Apc/SimTkTypes.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for SsStackMsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsBarringIndArg
class | SsBeginAccArg
class | SsCauseIndArg
class | SsCcbsInvokeArg
class | SsCcbsReCallIndArg
class | SsCcbsReCallRequestArg
class | SsCcbsRejectArg
class | SsCcbsResultIndArg
class | SsCcbsStatusIndArg
class | SsClientRejArg
class | SsDataIndArg
class | SsEndIndArg
class | SsErrIndArg
class | SsErrReqArg
class | SsFacilityIndArg
class | SsFacilityRejArg
class | SsForwardingIndArg
class | SsForwcheckIndArg
class | SsGetPasswordIndArg
class | SsGetPasswordRejArg
class | SsGetPasswordRspArg
class | SsInterrogateIndArg
class | SsNotifyIndArg
class | SsPasswordIndArg
class | SsRejArg
class | SsRejReqArg
class | SsRetResIndArg
class | SsSendEndReqArg
class | SsSendReqArg
class | SsUnstructIndArg
class | SsUssdIndArg
class | SsUssdReqArg
class | SsUssdResentIndArg
class | SsUus1IndArg
class | SsUus1QueryIndArg
class | SsUus1QueryRejArg
class | SsUus1QueryReqArg
class | SsUus1ReqArg
class | UssdAnswerIndArg

Defines

#define | Apc_SsStackMsgArgs_hpp

Define Documentation

#define Apc_SsStackMsgArgs_hpp

Generated on Tue Jan 24 17:08:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsStackMsgArgs.hpp Source File

Apc/SsStackMsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH &amp; Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "auzinger_apoxi_test_dv\lnz_apoxi\Apoxi\Apc\SsArgs.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apc_SsStackMsgArgs_hpp)
00016 #define Apc_SsStackMsgArgs_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Apc/SignalTypes.hpp>
00020 #include <Apc/DataCodingScheme.hpp>
00021 #include <Apc/TaggedProblemCode.hpp>
00022 #include <Apc/SsErrorCode.hpp>
00023 #include <Apc/SimTkTypes.hpp>
00024 #include <Auxiliary/Vector.hpp>
00025
00026
00027 /* ----------------------------------------------------------------------
00028     Classes
00029     ---------------------------------------------------------------------- */
00030
00031 /*  ======================================================================
00032     Class SsBeginAccArg
00033     ====================================================================== */
00034
00036 class SsBeginAccArg : public StackMsgArgument {
00037     friend class CommonStackMsgArgsDestroyTableNode;
00038     public:
00039         SsBeginAccArg();
00040
00041         static const SsBeginAccArg& Cast(const StackMsgArgument& arg);
00042         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00043         const Tipd& GetTipd() const { return m_tipd; }
00044
00045         enum  {
00046             ID = 1000
00047             };
00048
00049     private:
00050
00051         static void Destroy(StackMsgArgument* arg) { delete ((SsBeginAccArg*) arg); }
00052
00053         Tipd m_tipd;
00054
00055     };
00056
00057 // Inline definitions
00058 inline const SsBeginAccArg& SsBeginAccArg::Cast(const StackMsgArgument& arg) {
00059     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsBeginAccArg!\n");
00060     return ((SsBeginAccArg &) arg);
00061 }
00062
00063
00064
00065 /*  ======================================================================
00066     Class SsFacilityIndArg
00067     ====================================================================== */
00068
00070 class SsFacilityIndArg : public StackMsgArgument {
00071     friend class CommonStackMsgArgsDestroyTableNode;
00072     public:
00073         SsFacilityIndArg();
00074
00075         static const SsFacilityIndArg& Cast(const StackMsgArgument& arg);
00076         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00077         const Tipd& GetTipd() const { return m_tipd; }
00078         void SetSsSequence(const WString& ss_sequence) { m_ss_sequence = ss_sequence; }
00079         const WString& GetSsSequence() const { return m_ss_sequence; }
00080         void SetCallControlPerformed(BOOLEAN call_control_performed) { m_call_control_performed = call_control_performed; }
00081         BOOLEAN IsCallControlPerformed() const { return m_call_control_performed; }
00082         void SetCallControlResult(const SimCallControlResult& call_control_result) { m_call_control_result = call_control_result; }
00083         const SimCallControlResult& GetCallControlResult() const { return m_call_control_result; }
00084         void SetAlphaIdentifier(const SimAlphaIdentifier& alpha_identifier) { m_alpha_identifier = alpha_identifier; }
00085         const SimAlphaIdentifier& GetAlphaIdentifier() const { return m_alpha_identifier; }
00086
00087         enum  {
00088             ID = 1029
00089             };
00090
00091     private:
00092
00093         static void Destroy(StackMsgArgument* arg) { delete ((SsFacilityIndArg*) arg); }
00094
00095         Tipd m_tipd;
00096         WString m_ss_sequence;
00097         BOOLEAN m_call_control_performed;
00098         SimCallControlResult m_call_control_result;
00099         SimAlphaIdentifier m_alpha_identifier;
00100
00101     };
00102
00103 // Inline definitions
00104 inline const SsFacilityIndArg& SsFacilityIndArg::Cast(const StackMsgArgument& arg) {
00105     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsFacilityIndArg!\n");
00106     return ((SsFacilityIndArg &) arg);
00107 }
00108
00109
00110
00111 /*  ======================================================================
00112     Class SsFacilityRejArg
00113     ====================================================================== */
00114
00116 class SsFacilityRejArg : public StackMsgArgument {
00117     friend class CommonStackMsgArgsDestroyTableNode;
00118     public:
00119         SsFacilityRejArg();
00120
00121         static const SsFacilityRejArg& Cast(const StackMsgArgument& arg);
00122         void SetRejectCause(const MnCause& reject_cause) { m_reject_cause = reject_cause; }
00123         const MnCause& GetRejectCause() const { return m_reject_cause; }
00124
00125         enum  {
00126             ID = 1001
00127             };
00128
00129     private:
00130
00131         static void Destroy(StackMsgArgument* arg) { delete ((SsFacilityRejArg*) arg); }
00132
00133         MnCause m_reject_cause;
00134
00135     };
00136
00137 // Inline definitions
00138 inline const SsFacilityRejArg& SsFacilityRejArg::Cast(const StackMsgArgument& arg) {
00139     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsFacilityRejArg!\n");
00140     return ((SsFacilityRejArg &) arg);
00141 }
00142
00143
00144
00145 /*  ======================================================================
00146     Class SsForwardingIndArg
00147     ====================================================================== */
00148
00150 class SsForwardingIndArg : public StackMsgArgument {
00151     friend class CommonStackMsgArgsDestroyTableNode;
00152     public:
00153         SsForwardingIndArg();
00154
00155         static const SsForwardingIndArg& Cast(const StackMsgArgument& arg);
00156         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00157         const Tipd& GetTipd() const { return m_tipd; }
00158         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00159         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00160         void SetForwardingInfo(const ForwardingInfo& forwarding_info) { m_forwarding_info = forwarding_info; }
00161         const ForwardingInfo& GetForwardingInfo() const { return m_forwarding_info; }
00162         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00163         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00164
00165         enum  {
00166             ID = 1002
00167             };
00168
00169     private:
00170
00171         static void Destroy(StackMsgArgument* arg) { delete ((SsForwardingIndArg*) arg); }
00172
00173         Tipd m_tipd;
00174         SsOperationCode m_operation_code;
00175         ForwardingInfo m_forwarding_info;
00176         BOOLEAN m_release_complete;
00177
00178     };
00179
00180 // Inline definitions
00181 inline const SsForwardingIndArg& SsForwardingIndArg::Cast(const StackMsgArgument& arg) {
00182     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsForwardingIndArg!\n");
00183     return ((SsForwardingIndArg &) arg);
00184 }
00185
00186
00187
00188 /*  ======================================================================
00189     Class SsBarringIndArg
00190     ====================================================================== */
00191
00193 class SsBarringIndArg : public StackMsgArgument {
00194     friend class CommonStackMsgArgsDestroyTableNode;
00195     public:
00196         SsBarringIndArg();
00197
00198         static const SsBarringIndArg& Cast(const StackMsgArgument& arg);
00199         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00200         const Tipd& GetTipd() const { return m_tipd; }
00201         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00202         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00203         void SetCallBarringInfo(const CallBarringInfo& call_barring_info) { m_call_barring_info = call_barring_info; }
00204         const CallBarringInfo& GetCallBarringInfo() const { return m_call_barring_info; }
00205         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00206         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00207
00208         enum  {
00209             ID = 1003
00210             };
00211
00212     private:
00213
00214         static void Destroy(StackMsgArgument* arg) { delete ((SsBarringIndArg*) arg); }
00215
00216         Tipd m_tipd;
00217         SsOperationCode m_operation_code;
00218         CallBarringInfo m_call_barring_info;
00219         BOOLEAN m_release_complete;
00220
00221     };
00222
00223 // Inline definitions
00224 inline const SsBarringIndArg& SsBarringIndArg::Cast(const StackMsgArgument& arg) {
00225     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsBarringIndArg!\n");
00226     return ((SsBarringIndArg &) arg);
00227 }
00228
00229
00230
00231 /*  ======================================================================
00232     Class SsDataIndArg
00233     ====================================================================== */
00234
00236 class SsDataIndArg : public StackMsgArgument {
00237     friend class CommonStackMsgArgsDestroyTableNode;
00238     public:
00239         SsDataIndArg();
00240
00241         static const SsDataIndArg& Cast(const StackMsgArgument& arg);
00242         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00243         const Tipd& GetTipd() const { return m_tipd; }
00244         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00245         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00246         void SetSsData(const SsData& ss_data) { m_ss_data = ss_data; }
00247         const SsData& GetSsData() const { return m_ss_data; }
00248         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00249         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00250
00251         enum  {
00252             ID = 1004
00253             };
00254
00255     private:
00256
00257         static void Destroy(StackMsgArgument* arg) { delete ((SsDataIndArg*) arg); }
00258
00259         Tipd m_tipd;
00260         SsOperationCode m_operation_code;
00261         SsData m_ss_data;
00262         BOOLEAN m_release_complete;
00263
00264     };
00265
00266 // Inline definitions
00267 inline const SsDataIndArg& SsDataIndArg::Cast(const StackMsgArgument& arg) {
00268     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsDataIndArg!\n");
00269     return ((SsDataIndArg &) arg);
00270 }
00271
00272
00273
00274 /*  ======================================================================
00275     Class SsNotifyIndArg
00276     ====================================================================== */
00277
00279 class SsNotifyIndArg : public StackMsgArgument {
00280     friend class CommonStackMsgArgsDestroyTableNode;
00281     public:
00282         SsNotifyIndArg();
00283
00284         static const SsNotifyIndArg& Cast(const StackMsgArgument& arg);
00285         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00286         const Tipd& GetTipd() const { return m_tipd; }
00287         void SetSsOperationCode(const SsOperationCode& ss_operation_code) { m_ss_operation_code = ss_operation_code; }
00288         const SsOperationCode& GetSsOperationCode() const { return m_ss_operation_code; }
00289         void SetNotifySsArg(const NotifySsArg& notify_ss_arg) { m_notify_ss_arg = notify_ss_arg; }
00290         const NotifySsArg& GetNotifySsArg() const { return m_notify_ss_arg; }
00291
00292         enum  {
00293             ID = 1005
00294             };
00295
00296     private:
00297
00298         static void Destroy(StackMsgArgument* arg) { delete ((SsNotifyIndArg*) arg); }
00299
00300         Tipd m_tipd;
00301         SsOperationCode m_ss_operation_code;
00302         NotifySsArg m_notify_ss_arg;
00303
00304     };
00305
00306 // Inline definitions
00307 inline const SsNotifyIndArg& SsNotifyIndArg::Cast(const StackMsgArgument& arg) {
00308     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsNotifyIndArg!\n");
00309     return ((SsNotifyIndArg &) arg);
00310 }
00311
00312
00313
00314 /*  ======================================================================
00315     Class SsInterrogateIndArg
00316     ====================================================================== */
00317
00319 class SsInterrogateIndArg : public StackMsgArgument {
00320     friend class CommonStackMsgArgsDestroyTableNode;
00321     public:
00322         SsInterrogateIndArg();
00323
00324         static const SsInterrogateIndArg& Cast(const StackMsgArgument& arg);
00325         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00326         const Tipd& GetTipd() const { return m_tipd; }
00327         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00328         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00329         void SetResult(const InterrogateSsResult& result) { m_result = result; }
00330         const InterrogateSsResult& GetResult() const { return m_result; }
00331         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00332         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00333
00334         enum  {
00335             ID = 1006
00336             };
00337
00338     private:
00339
00340         static void Destroy(StackMsgArgument* arg) { delete ((SsInterrogateIndArg*) arg); }
00341
00342         Tipd m_tipd;
00343         SsOperationCode m_operation_code;
00344         InterrogateSsResult m_result;
00345         BOOLEAN m_release_complete;
00346
00347     };
00348
00349 // Inline definitions
00350 inline const SsInterrogateIndArg& SsInterrogateIndArg::Cast(const StackMsgArgument& arg) {
00351     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsInterrogateIndArg!\n");
00352     return ((SsInterrogateIndArg &) arg);
00353 }
00354
00355
00356
00357 /*  ======================================================================
00358     Class SsPasswordIndArg
00359     ====================================================================== */
00360
00362 class SsPasswordIndArg : public StackMsgArgument {
00363     friend class CommonStackMsgArgsDestroyTableNode;
00364     public:
00365         SsPasswordIndArg();
00366
00367         static const SsPasswordIndArg& Cast(const StackMsgArgument& arg);
00368         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00369         const Tipd& GetTipd() const { return m_tipd; }
00370         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00371         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00372         void SetPassword(const WString& password) { m_password = password; }
00373         const WString& GetPassword() const { return m_password; }
00374         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00375         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00376
00377         enum  {
00378             ID = 1007
00379             };
00380
00381     private:
00382
00383         static void Destroy(StackMsgArgument* arg) { delete ((SsPasswordIndArg*) arg); }
00384
00385         Tipd m_tipd;
00386         SsOperationCode m_operation_code;
00387         WString m_password;
00388         BOOLEAN m_release_complete;
00389
00390     };
00391
00392 // Inline definitions
00393 inline const SsPasswordIndArg& SsPasswordIndArg::Cast(const StackMsgArgument& arg) {
00394     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsPasswordIndArg!\n");
00395     return ((SsPasswordIndArg &) arg);
00396 }
00397
00398
00399
00400 /*  ======================================================================
00401     Class SsUnstructIndArg
00402     ====================================================================== */
00403
00405 class SsUnstructIndArg : public StackMsgArgument {
00406     friend class CommonStackMsgArgsDestroyTableNode;
00407     public:
00408         SsUnstructIndArg();
00409
00410         static const SsUnstructIndArg& Cast(const StackMsgArgument& arg);
00411         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00412         const Tipd& GetTipd() const { return m_tipd; }
00413         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00414         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00415         void SetCtrlInfoString(const WString& ctrl_info_string) { m_ctrl_info_string = ctrl_info_string; }
00416         const WString& GetCtrlInfoString() const { return m_ctrl_info_string; }
00417         void SetDcs(const DataCodingScheme& dcs) { m_dcs = dcs; }
00418         const DataCodingScheme& GetDcs() const { return m_dcs; }
00419         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00420         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00421
00422         enum  {
00423             ID = 1008
00424             };
00425
00426     private:
00427
00428         static void Destroy(StackMsgArgument* arg) { delete ((SsUnstructIndArg*) arg); }
00429
00430         Tipd m_tipd;
00431         SsOperationCode m_operation_code;
00432         WString m_ctrl_info_string;
00433         DataCodingScheme m_dcs;
00434         BOOLEAN m_release_complete;
00435
00436     };
00437
00438 // Inline definitions
00439 inline const SsUnstructIndArg& SsUnstructIndArg::Cast(const StackMsgArgument& arg) {
00440     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUnstructIndArg!\n");
00441     return ((SsUnstructIndArg &) arg);
00442 }
00443
00444
00445
00446 /*  ======================================================================
00447     Class SsForwcheckIndArg
00448     ====================================================================== */
00449
00451 class SsForwcheckIndArg : public StackMsgArgument {
00452     friend class CommonStackMsgArgsDestroyTableNode;
00453     public:
00454         SsForwcheckIndArg();
00455
00456         static const SsForwcheckIndArg& Cast(const StackMsgArgument& arg);
00457         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00458         const Tipd& GetTipd() const { return m_tipd; }
00459         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00460         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00461
00462         enum  {
00463             ID = 1009
00464             };
00465
00466     private:
00467
00468         static void Destroy(StackMsgArgument* arg) { delete ((SsForwcheckIndArg*) arg); }
00469
00470         Tipd m_tipd;
00471         SsOperationCode m_operation_code;
00472
00473     };
00474
00475 // Inline definitions
00476 inline const SsForwcheckIndArg& SsForwcheckIndArg::Cast(const StackMsgArgument& arg) {
00477     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsForwcheckIndArg!\n");
00478     return ((SsForwcheckIndArg &) arg);
00479 }
00480
00481
00482
00483 /*  ======================================================================
00484     Class SsRetResIndArg
00485     ====================================================================== */
00486
00488 class SsRetResIndArg : public StackMsgArgument {
00489     friend class CommonStackMsgArgsDestroyTableNode;
00490     public:
00491         SsRetResIndArg();
00492
00493         static const SsRetResIndArg& Cast(const StackMsgArgument& arg);
00494         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00495         const Tipd& GetTipd() const { return m_tipd; }
00496         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00497         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00498
00499         enum  {
00500             ID = 1010
00501             };
00502
00503     private:
00504
00505         static void Destroy(StackMsgArgument* arg) { delete ((SsRetResIndArg*) arg); }
00506
00507         Tipd m_tipd;
00508         BOOLEAN m_release_complete;
00509
00510     };
00511
00512 // Inline definitions
00513 inline const SsRetResIndArg& SsRetResIndArg::Cast(const StackMsgArgument& arg) {
00514     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsRetResIndArg!\n");
00515     return ((SsRetResIndArg &) arg);
00516 }
00517
00518
00519
00520 /*  ======================================================================
00521     Class SsEndIndArg
00522     ====================================================================== */
00523
00525 class SsEndIndArg : public StackMsgArgument {
00526     friend class CommonStackMsgArgsDestroyTableNode;
00527     public:
00528         SsEndIndArg();
00529
00530         static const SsEndIndArg& Cast(const StackMsgArgument& arg);
00531         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00532         const Tipd& GetTipd() const { return m_tipd; }
00533
00534         enum  {
00535             ID = 1011
00536             };
00537
00538     private:
00539
00540         static void Destroy(StackMsgArgument* arg) { delete ((SsEndIndArg*) arg); }
00541
00542         Tipd m_tipd;
00543
00544     };
00545
00546 // Inline definitions
00547 inline const SsEndIndArg& SsEndIndArg::Cast(const StackMsgArgument& arg) {
00548     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsEndIndArg!\n");
00549     return ((SsEndIndArg &) arg);
00550 }
00551
00552
00553
00554 /*  ======================================================================
00555     Class SsRejArg
00556     ====================================================================== */
00557
00559 class SsRejArg : public StackMsgArgument {
00560     friend class CommonStackMsgArgsDestroyTableNode;
00561     public:
00562         SsRejArg();
00563
00564         static const SsRejArg& Cast(const StackMsgArgument& arg);
00565         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00566         const Tipd& GetTipd() const { return m_tipd; }
00567         void SetTaggedProblemCode(const TaggedProblemCode& tagged_problem_code) { m_tagged_problem_code = tagged_problem_code; }
00568         const TaggedProblemCode& GetTaggedProblemCode() const { return m_tagged_problem_code; }
00569         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00570         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00571
00572         enum  {
00573             ID = 1012
00574             };
00575
00576     private:
00577
00578         static void Destroy(StackMsgArgument* arg) { delete ((SsRejArg*) arg); }
00579
00580         Tipd m_tipd;
00581         TaggedProblemCode m_tagged_problem_code;
00582         BOOLEAN m_release_complete;
00583
00584     };
00585
00586 // Inline definitions
00587 inline const SsRejArg& SsRejArg::Cast(const StackMsgArgument& arg) {
00588     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsRejArg!\n");
00589     return ((SsRejArg &) arg);
00590 }
00591
00592
00593
00594 /*  ======================================================================
00595     Class SsClientRejArg
00596     ====================================================================== */
00597
00599 class SsClientRejArg : public StackMsgArgument {
00600     friend class CommonStackMsgArgsDestroyTableNode;
00601     public:
00602         SsClientRejArg();
00603
00604         static const SsClientRejArg& Cast(const StackMsgArgument& arg);
00605         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00606         const Tipd& GetTipd() const { return m_tipd; }
00607
00608         enum  {
00609             ID = 1019
00610             };
00611
00612     private:
00613
00614         static void Destroy(StackMsgArgument* arg) { delete ((SsClientRejArg*) arg); }
00615
00616         Tipd m_tipd;
00617
00618     };
00619
00620 // Inline definitions
00621 inline const SsClientRejArg& SsClientRejArg::Cast(const StackMsgArgument& arg) {
00622     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsClientRejArg!\n");
00623     return ((SsClientRejArg &) arg);
00624 }
00625
00626
00627
00628 /*  ======================================================================
00629     Class SsErrIndArg
00630     ====================================================================== */
00631
00633 class SsErrIndArg : public StackMsgArgument {
00634     friend class CommonStackMsgArgsDestroyTableNode;
00635     public:
00636         SsErrIndArg();
00637
00638         static const SsErrIndArg& Cast(const StackMsgArgument& arg);
00639         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00640         const Tipd& GetTipd() const { return m_tipd; }
00641         void SetSsErrorCode(const SsErrorCode& ss_error_code) { m_ss_error_code = ss_error_code; }
00642         const SsErrorCode& GetSsErrorCode() const { return m_ss_error_code; }
00643         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00644         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00645
00646         enum  {
00647             ID = 1013
00648             };
00649
00650     private:
00651
00652         static void Destroy(StackMsgArgument* arg) { delete ((SsErrIndArg*) arg); }
00653
00654         Tipd m_tipd;
00655         SsErrorCode m_ss_error_code;
00656         BOOLEAN m_release_complete;
00657
00658     };
00659
00660 // Inline definitions
00661 inline const SsErrIndArg& SsErrIndArg::Cast(const StackMsgArgument& arg) {
00662     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsErrIndArg!\n");
00663     return ((SsErrIndArg &) arg);
00664 }
00665
00666
00667
00668 /*  ======================================================================
00669     Class SsGetPasswordIndArg
00670     ====================================================================== */
00671
00673 class SsGetPasswordIndArg : public StackMsgArgument {
00674     friend class CommonStackMsgArgsDestroyTableNode;
00675     public:
00676         SsGetPasswordIndArg();
00677
00678         static const SsGetPasswordIndArg& Cast(const StackMsgArgument& arg);
00679         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00680         const Tipd& GetTipd() const { return m_tipd; }
00681
00682         enum  {
00683             ID = 1014
00684             };
00685
00686     private:
00687
00688         static void Destroy(StackMsgArgument* arg) { delete ((SsGetPasswordIndArg*) arg); }
00689
00690         Tipd m_tipd;
00691
00692     };
00693
00694 // Inline definitions
00695 inline const SsGetPasswordIndArg& SsGetPasswordIndArg::Cast(const StackMsgArgument& arg) {
00696     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsGetPasswordIndArg!\n");
00697     return ((SsGetPasswordIndArg &) arg);
00698 }
00699
00700
00701
00702 /*  ======================================================================
00703     Class SsGetPasswordRejArg
00704     ====================================================================== */
00705
00707 class SsGetPasswordRejArg : public StackMsgArgument {
00708     friend class CommonStackMsgArgsDestroyTableNode;
00709     public:
00710         SsGetPasswordRejArg();
00711
00712         static const SsGetPasswordRejArg& Cast(const StackMsgArgument& arg);
00713         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00714         const Tipd& GetTipd() const { return m_tipd; }
00715         void SetRejectCause(const MnCause& reject_cause) { m_reject_cause = reject_cause; }
00716         const MnCause& GetRejectCause() const { return m_reject_cause; }
00717
00718         enum  {
00719             ID = 1015
00720             };
00721
00722     private:
00723
00724         static void Destroy(StackMsgArgument* arg) { delete ((SsGetPasswordRejArg*) arg); }
00725
00726         Tipd m_tipd;
00727         MnCause m_reject_cause;
00728
00729     };
00730
00731 // Inline definitions
00732 inline const SsGetPasswordRejArg& SsGetPasswordRejArg::Cast(const StackMsgArgument& arg) {
00733     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsGetPasswordRejArg!\n");
00734     return ((SsGetPasswordRejArg &) arg);
00735 }
00736
00737
00738
00739 /*  ======================================================================
00740     Class SsCauseIndArg
00741     ====================================================================== */
00742
00744 class SsCauseIndArg : public StackMsgArgument {
00745     friend class CommonStackMsgArgsDestroyTableNode;
00746     public:
00747         SsCauseIndArg();
00748
00749         static const SsCauseIndArg& Cast(const StackMsgArgument& arg);
00750         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00751         const Tipd& GetTipd() const { return m_tipd; }
00752         void SetRejectCause(const MnCause& reject_cause) { m_reject_cause = reject_cause; }
00753         const MnCause& GetRejectCause() const { return m_reject_cause; }
00754         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00755         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00756
00757         enum  {
00758             ID = 1018
00759             };
00760
00761     private:
00762
00763         static void Destroy(StackMsgArgument* arg) { delete ((SsCauseIndArg*) arg); }
00764
00765         Tipd m_tipd;
00766         MnCause m_reject_cause;
00767         BOOLEAN m_release_complete;
00768
00769     };
00770
00771 // Inline definitions
00772 inline const SsCauseIndArg& SsCauseIndArg::Cast(const StackMsgArgument& arg) {
00773     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsCauseIndArg!\n");
00774     return ((SsCauseIndArg &) arg);
00775 }
00776
00777
00778
00779 /*  ======================================================================
00780     Class SsUssdIndArg
00781     ====================================================================== */
00782
00784 class SsUssdIndArg : public StackMsgArgument {
00785     friend class CommonStackMsgArgsDestroyTableNode;
00786     public:
00787         SsUssdIndArg();
00788
00789         static const SsUssdIndArg& Cast(const StackMsgArgument& arg);
00790         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00791         const Tipd& GetTipd() const { return m_tipd; }
00792         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00793         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00794         void SetDcs(const DataCodingScheme& dcs) { m_dcs = dcs; }
00795         const DataCodingScheme& GetDcs() const { return m_dcs; }
00796         void SetCtrlInfoString(const WString& ctrl_info_string) { m_ctrl_info_string = ctrl_info_string; }
00797         const WString& GetCtrlInfoString() const { return m_ctrl_info_string; }
00798         void SetReleaseComplete(BOOLEAN release_complete) { m_release_complete = release_complete; }
00799         BOOLEAN IsReleaseComplete() const { return m_release_complete; }
00800
00801         enum  {
00802             ID = 1016
00803             };
00804
00805     private:
00806
00807         static void Destroy(StackMsgArgument* arg) { delete ((SsUssdIndArg*) arg); }
00808
00809         Tipd m_tipd;
00810         SsOperationCode m_operation_code;
00811         DataCodingScheme m_dcs;
00812         WString m_ctrl_info_string;
00813         BOOLEAN m_release_complete;
00814
00815     };
00816
00817 // Inline definitions
00818 inline const SsUssdIndArg& SsUssdIndArg::Cast(const StackMsgArgument& arg) {
00819     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUssdIndArg!\n");
00820     return ((SsUssdIndArg &) arg);
00821 }
00822
00823
00824
00825 /*  ======================================================================
00826     Class SsUssdResentIndArg
00827     ====================================================================== */
00828
00830 class SsUssdResentIndArg : public StackMsgArgument {
00831     friend class CommonStackMsgArgsDestroyTableNode;
00832     public:
00833         SsUssdResentIndArg();
00834
00835         static const SsUssdResentIndArg& Cast(const StackMsgArgument& arg);
00836         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00837         const Tipd& GetTipd() const { return m_tipd; }
00838
00839         enum  {
00840             ID = 1017
00841             };
00842
00843     private:
00844
00845         static void Destroy(StackMsgArgument* arg) { delete ((SsUssdResentIndArg*) arg); }
00846
00847         Tipd m_tipd;
00848
00849     };
00850
00851 // Inline definitions
00852 inline const SsUssdResentIndArg& SsUssdResentIndArg::Cast(const StackMsgArgument& arg) {
00853     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUssdResentIndArg!\n");
00854     return ((SsUssdResentIndArg &) arg);
00855 }
00856
00857
00858
00859 /*  ======================================================================
00860     Class UssdAnswerIndArg
00861     ====================================================================== */
00862
00864 class UssdAnswerIndArg : public StackMsgArgument {
00865     friend class CommonStackMsgArgsDestroyTableNode;
00866     public:
00867         UssdAnswerIndArg();
00868
00869         static const UssdAnswerIndArg& Cast(const StackMsgArgument& arg);
00870         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
00871         const Tipd& GetTipd() const { return m_tipd; }
00872         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
00873         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
00874         void SetDcs(const DataCodingScheme& dcs) { m_dcs = dcs; }
00875         const DataCodingScheme& GetDcs() const { return m_dcs; }
00876         void SetCtrlInfoString(const WString& ctrl_info_string) { m_ctrl_info_string = ctrl_info_string; }
00877         const WString& GetCtrlInfoString() const { return m_ctrl_info_string; }
00878
00879         enum  {
00880             ID = 1033
00881             };
00882
00883     private:
00884
00885         static void Destroy(StackMsgArgument* arg) { delete ((UssdAnswerIndArg*) arg); }
00886
00887         Tipd m_tipd;
00888         SsOperationCode m_operation_code;
00889         DataCodingScheme m_dcs;
00890         WString m_ctrl_info_string;
00891
00892     };
00893
00894 // Inline definitions
00895 inline const UssdAnswerIndArg& UssdAnswerIndArg::Cast(const StackMsgArgument& arg) {
00896     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to UssdAnswerIndArg!\n");
00897     return ((UssdAnswerIndArg &) arg);
00898 }
00899
00900
00901
00902 /*  ======================================================================
00903     Class SsUus1QueryIndArg
00904     ====================================================================== */
00905
00907 class SsUus1QueryIndArg : public StackMsgArgument {
00908     friend class CommonStackMsgArgsDestroyTableNode;
00909     public:
00910         SsUus1QueryIndArg();
00911
00912         static const SsUus1QueryIndArg& Cast(const StackMsgArgument& arg);
00913         void SetTextList(const Vector<UusText>& text_list) { m_text_list = text_list; }
00914         const Vector<UusText>& GetTextList() const { return m_text_list; }
00915
00916         enum  {
00917             ID = 1026
00918             };
00919
00920     private:
00921
00922         static void Destroy(StackMsgArgument* arg) { delete ((SsUus1QueryIndArg*) arg); }
00923
00924         Vector<UusText> m_text_list;
00925
00926     };
00927
00928 // Inline definitions
00929 inline const SsUus1QueryIndArg& SsUus1QueryIndArg::Cast(const StackMsgArgument& arg) {
00930     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUus1QueryIndArg!\n");
00931     return ((SsUus1QueryIndArg &) arg);
00932 }
00933
00934
00935
00936 /*  ======================================================================
00937     Class SsUus1QueryRejArg
00938     ====================================================================== */
00939
00941 class SsUus1QueryRejArg : public StackMsgArgument {
00942     friend class CommonStackMsgArgsDestroyTableNode;
00943     public:
00944         SsUus1QueryRejArg();
00945
00946         static const SsUus1QueryRejArg& Cast(const StackMsgArgument& arg);
00947
00948         enum  {
00949             ID = 1027
00950             };
00951
00952     private:
00953
00954         static void Destroy(StackMsgArgument* arg) { delete ((SsUus1QueryRejArg*) arg); }
00955
00956     };
00957
00958 // Inline definitions
00959 inline const SsUus1QueryRejArg& SsUus1QueryRejArg::Cast(const StackMsgArgument& arg) {
00960     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUus1QueryRejArg!\n");
00961     return ((SsUus1QueryRejArg &) arg);
00962 }
00963
00964
00965
00966 /*  ======================================================================
00967     Class SsUus1IndArg
00968     ====================================================================== */
00969
00971 class SsUus1IndArg : public StackMsgArgument {
00972     friend class CommonStackMsgArgsDestroyTableNode;
00973     public:
00974         SsUus1IndArg();
00975
00976         static const SsUus1IndArg& Cast(const StackMsgArgument& arg);
00977         void SetText(const WString& text) { m_text = text; }
00978         const WString& GetText() const { return m_text; }
00979         void SetType(const UusInTextType& type) { m_type = type; }
00980         const UusInTextType& GetType() const { return m_type; }
00981
00982         enum  {
00983             ID = 1028
00984             };
00985
00986     private:
00987
00988         static void Destroy(StackMsgArgument* arg) { delete ((SsUus1IndArg*) arg); }
00989
00990         WString m_text;
00991         UusInTextType m_type;
00992
00993     };
00994
00995 // Inline definitions
00996 inline const SsUus1IndArg& SsUus1IndArg::Cast(const StackMsgArgument& arg) {
00997     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUus1IndArg!\n");
00998     return ((SsUus1IndArg &) arg);
00999 }
01000
01001
01002
01003 /*  ======================================================================
01004     Class SsCcbsReCallIndArg
01005     ====================================================================== */
01006
01008 class SsCcbsReCallIndArg : public StackMsgArgument {
01009     friend class CommonStackMsgArgsDestroyTableNode;
01010     public:
01011         SsCcbsReCallIndArg();
01012
01013         static const SsCcbsReCallIndArg& Cast(const StackMsgArgument& arg);
01014         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01015         const Tipd& GetTipd() const { return m_tipd; }
01016         void SetCcbsEntry(const CcbsEntry& ccbs_entry) { m_ccbs_entry = ccbs_entry; }
01017         const CcbsEntry& GetCcbsEntry() const { return m_ccbs_entry; }
01018
01019         enum  {
01020             ID = 1030
01021             };
01022
01023     private:
01024
01025         static void Destroy(StackMsgArgument* arg) { delete ((SsCcbsReCallIndArg*) arg); }
01026
01027         Tipd m_tipd;
01028         CcbsEntry m_ccbs_entry;
01029
01030     };
01031
01032 // Inline definitions
01033 inline const SsCcbsReCallIndArg& SsCcbsReCallIndArg::Cast(const StackMsgArgument& arg) {
01034     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsCcbsReCallIndArg!\n");
01035     return ((SsCcbsReCallIndArg &) arg);
01036 }
01037
01038
01039
01040 /*  ======================================================================
01041     Class SsCcbsStatusIndArg
01042     ====================================================================== */
01043
01045 class SsCcbsStatusIndArg : public StackMsgArgument {
01046     friend class CommonStackMsgArgsDestroyTableNode;
01047     public:
01048         SsCcbsStatusIndArg();
01049
01050         static const SsCcbsStatusIndArg& Cast(const StackMsgArgument& arg);
01051         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01052         const Tipd& GetTipd() const { return m_tipd; }
01053         void SetCcbsStatus(const CcbsStatus& ccbs_status) { m_ccbs_status = ccbs_status; }
01054         const CcbsStatus& GetCcbsStatus() const { return m_ccbs_status; }
01055
01056         enum  {
01057             ID = 1031
01058             };
01059
01060     private:
01061
01062         static void Destroy(StackMsgArgument* arg) { delete ((SsCcbsStatusIndArg*) arg); }
01063
01064         Tipd m_tipd;
01065         CcbsStatus m_ccbs_status;
01066
01067     };
01068
01069 // Inline definitions
01070 inline const SsCcbsStatusIndArg& SsCcbsStatusIndArg::Cast(const StackMsgArgument& arg) {
01071     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsCcbsStatusIndArg!\n");
01072     return ((SsCcbsStatusIndArg &) arg);
01073 }
01074
01075
01076
01077 /*  ======================================================================
01078     Class SsCcbsResultIndArg
01079     ====================================================================== */
01080
01082 class SsCcbsResultIndArg : public StackMsgArgument {
01083     friend class CommonStackMsgArgsDestroyTableNode;
01084     public:
01085         SsCcbsResultIndArg();
01086
01087         static const SsCcbsResultIndArg& Cast(const StackMsgArgument& arg);
01088         void SetCcbsAction(const CcbsAction& ccbs_action) { m_ccbs_action = ccbs_action; }
01089         const CcbsAction& GetCcbsAction() const { return m_ccbs_action; }
01090         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01091         const Tipd& GetTipd() const { return m_tipd; }
01092         void SetCcbsStatus(const CcbsStatus& ccbs_status) { m_ccbs_status = ccbs_status; }
01093         const CcbsStatus& GetCcbsStatus() const { return m_ccbs_status; }
01094         void SetInterrogateCcbsResult(const InterrogateCcbsResult& interrogate_ccbs_result) { m_interrogate_ccbs_result = interrogate_ccbs_result; }
01095         const InterrogateCcbsResult& GetInterrogateCcbsResult() const { return m_interrogate_ccbs_result; }
01096         void SetReleaseComplete(const ReleaseComplete& release_complete) { m_release_complete = release_complete; }
01097         const ReleaseComplete& GetReleaseComplete() const { return m_release_complete; }
01098
01099         enum  {
01100             ID = 1032
01101             };
01102
01103     private:
01104
01105         static void Destroy(StackMsgArgument* arg) { delete ((SsCcbsResultIndArg*) arg); }
01106
01107         CcbsAction m_ccbs_action;
01108         Tipd m_tipd;
01109         CcbsStatus m_ccbs_status;
01110         InterrogateCcbsResult m_interrogate_ccbs_result;
01111         ReleaseComplete m_release_complete;
01112
01113     };
01114
01115 // Inline definitions
01116 inline const SsCcbsResultIndArg& SsCcbsResultIndArg::Cast(const StackMsgArgument& arg) {
01117     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsCcbsResultIndArg!\n");
01118     return ((SsCcbsResultIndArg &) arg);
01119 }
01120
01121
01122
01123 /*  ======================================================================
01124     Class SsSendReqArg
01125     ====================================================================== */
01126
01128 class SsSendReqArg : public StackMsgArgument {
01129     friend class CommonStackMsgArgsDestroyTableNode;
01130     public:
01131         SsSendReqArg(const Tipd& tipd, const WString& ctrl_info);
01132         SsSendReqArg();
01133
01134         static const SsSendReqArg& Cast(const StackMsgArgument& arg);
01135         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01136         const Tipd& GetTipd() const { return m_tipd; }
01137         void SetCtrlInfo(const WString& ctrl_info) { m_ctrl_info = ctrl_info; }
01138         const WString& GetCtrlInfo() const { return m_ctrl_info; }
01139
01140         enum  {
01141             ID = 2000
01142             };
01143
01144     private:
01145
01146         static void Destroy(StackMsgArgument* arg) { delete ((SsSendReqArg*) arg); }
01147
01148         Tipd m_tipd;
01149         WString m_ctrl_info;
01150
01151     };
01152
01153 // Inline definitions
01154 inline const SsSendReqArg& SsSendReqArg::Cast(const StackMsgArgument& arg) {
01155     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsSendReqArg!\n");
01156     return ((SsSendReqArg &) arg);
01157 }
01158
01159
01160
01161 /*  ======================================================================
01162     Class SsSendEndReqArg
01163     ====================================================================== */
01164
01166 class SsSendEndReqArg : public StackMsgArgument {
01167     friend class CommonStackMsgArgsDestroyTableNode;
01168     public:
01169         SsSendEndReqArg(const Tipd& tipd);
01170         SsSendEndReqArg();
01171
01172         static const SsSendEndReqArg& Cast(const StackMsgArgument& arg);
01173         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01174         const Tipd& GetTipd() const { return m_tipd; }
01175
01176         enum  {
01177             ID = 2001
01178             };
01179
01180     private:
01181
01182         static void Destroy(StackMsgArgument* arg) { delete ((SsSendEndReqArg*) arg); }
01183
01184         Tipd m_tipd;
01185
01186     };
01187
01188 // Inline definitions
01189 inline const SsSendEndReqArg& SsSendEndReqArg::Cast(const StackMsgArgument& arg) {
01190     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsSendEndReqArg!\n");
01191     return ((SsSendEndReqArg &) arg);
01192 }
01193
01194
01195
01196 /*  ======================================================================
01197     Class SsGetPasswordRspArg
01198     ====================================================================== */
01199
01201 class SsGetPasswordRspArg : public StackMsgArgument {
01202     friend class CommonStackMsgArgsDestroyTableNode;
01203     public:
01204         SsGetPasswordRspArg(const Tipd& tipd, const WString& password);
01205         SsGetPasswordRspArg();
01206
01207         static const SsGetPasswordRspArg& Cast(const StackMsgArgument& arg);
01208         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01209         const Tipd& GetTipd() const { return m_tipd; }
01210         void SetPassword(const WString& password) { m_password = password; }
01211         const WString& GetPassword() const { return m_password; }
01212
01213         enum  {
01214             ID = 2002
01215             };
01216
01217     private:
01218
01219         static void Destroy(StackMsgArgument* arg) { delete ((SsGetPasswordRspArg*) arg); }
01220
01221         Tipd m_tipd;
01222         WString m_password;
01223
01224     };
01225
01226 // Inline definitions
01227 inline const SsGetPasswordRspArg& SsGetPasswordRspArg::Cast(const StackMsgArgument& arg) {
01228     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsGetPasswordRspArg!\n");
01229     return ((SsGetPasswordRspArg &) arg);
01230 }
01231
01232
01233
01234 /*  ======================================================================
01235     Class SsErrReqArg
01236     ====================================================================== */
01237
01239 class SsErrReqArg : public StackMsgArgument {
01240     friend class CommonStackMsgArgsDestroyTableNode;
01241     public:
01242         SsErrReqArg(const Tipd& tipd, const SsErrorCode& error_code);
01243         SsErrReqArg();
01244
01245         static const SsErrReqArg& Cast(const StackMsgArgument& arg);
01246         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01247         const Tipd& GetTipd() const { return m_tipd; }
01248         void SetErrorCode(const SsErrorCode& error_code) { m_error_code = error_code; }
01249         const SsErrorCode& GetErrorCode() const { return m_error_code; }
01250
01251         enum  {
01252             ID = 2003
01253             };
01254
01255     private:
01256
01257         static void Destroy(StackMsgArgument* arg) { delete ((SsErrReqArg*) arg); }
01258
01259         Tipd m_tipd;
01260         SsErrorCode m_error_code;
01261
01262     };
01263
01264 // Inline definitions
01265 inline const SsErrReqArg& SsErrReqArg::Cast(const StackMsgArgument& arg) {
01266     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsErrReqArg!\n");
01267     return ((SsErrReqArg &) arg);
01268 }
01269
01270
01271
01272 /*  ======================================================================
01273     Class SsRejReqArg
01274     ====================================================================== */
01275
01277 class SsRejReqArg : public StackMsgArgument {
01278     friend class CommonStackMsgArgsDestroyTableNode;
01279     public:
01280         SsRejReqArg(const Tipd& tipd, const TaggedProblemCode& tagged_problem_code);
01281         SsRejReqArg();
01282
01283         static const SsRejReqArg& Cast(const StackMsgArgument& arg);
01284         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01285         const Tipd& GetTipd() const { return m_tipd; }
01286         void SetTaggedProblemCode(const TaggedProblemCode& tagged_problem_code) { m_tagged_problem_code = tagged_problem_code; }
01287         const TaggedProblemCode& GetTaggedProblemCode() const { return m_tagged_problem_code; }
01288
01289         enum  {
01290             ID = 2004
01291             };
01292
01293     private:
01294
01295         static void Destroy(StackMsgArgument* arg) { delete ((SsRejReqArg*) arg); }
01296
01297         Tipd m_tipd;
01298         TaggedProblemCode m_tagged_problem_code;
01299
01300     };
01301
01302 // Inline definitions
01303 inline const SsRejReqArg& SsRejReqArg::Cast(const StackMsgArgument& arg) {
01304     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsRejReqArg!\n");
01305     return ((SsRejReqArg &) arg);
01306 }
01307
01308
01309
01310 /*  ======================================================================
01311     Class SsUssdReqArg
01312     ====================================================================== */
01313
01315 class SsUssdReqArg : public StackMsgArgument {
01316     friend class CommonStackMsgArgsDestroyTableNode;
01317     public:
01318         SsUssdReqArg(const Tipd& tipd, const SsOperationCode& operation_code, const WString& ctrl_info);
01319         SsUssdReqArg();
01320
01321         static const SsUssdReqArg& Cast(const StackMsgArgument& arg);
01322         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01323         const Tipd& GetTipd() const { return m_tipd; }
01324         void SetOperationCode(const SsOperationCode& operation_code) { m_operation_code = operation_code; }
01325         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
01326         void SetCtrlInfo(const WString& ctrl_info) { m_ctrl_info = ctrl_info; }
01327         const WString& GetCtrlInfo() const { return m_ctrl_info; }
01328
01329         enum  {
01330             ID = 2005
01331             };
01332
01333     private:
01334
01335         static void Destroy(StackMsgArgument* arg) { delete ((SsUssdReqArg*) arg); }
01336
01337         Tipd m_tipd;
01338         SsOperationCode m_operation_code;
01339         WString m_ctrl_info;
01340
01341     };
01342
01343 // Inline definitions
01344 inline const SsUssdReqArg& SsUssdReqArg::Cast(const StackMsgArgument& arg) {
01345     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUssdReqArg!\n");
01346     return ((SsUssdReqArg &) arg);
01347 }
01348
01349
01350
01351 /*  ======================================================================
01352     Class SsCcbsInvokeArg
01353     ====================================================================== */
01354
01356 class SsCcbsInvokeArg : public StackMsgArgument {
01357     friend class CommonStackMsgArgsDestroyTableNode;
01358     public:
01359         SsCcbsInvokeArg(const Tipd& tipd);
01360         SsCcbsInvokeArg();
01361
01362         static const SsCcbsInvokeArg& Cast(const StackMsgArgument& arg);
01363         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01364         const Tipd& GetTipd() const { return m_tipd; }
01365
01366         enum  {
01367             ID = 2030
01368             };
01369
01370     private:
01371
01372         static void Destroy(StackMsgArgument* arg) { delete ((SsCcbsInvokeArg*) arg); }
01373
01374         Tipd m_tipd;
01375
01376     };
01377
01378 // Inline definitions
01379 inline const SsCcbsInvokeArg& SsCcbsInvokeArg::Cast(const StackMsgArgument& arg) {
01380     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsCcbsInvokeArg!\n");
01381     return ((SsCcbsInvokeArg &) arg);
01382 }
01383
01384
01385
01386 /*  ======================================================================
01387     Class SsCcbsRejectArg
01388     ====================================================================== */
01389
01391 class SsCcbsRejectArg : public StackMsgArgument {
01392     friend class CommonStackMsgArgsDestroyTableNode;
01393     public:
01394         SsCcbsRejectArg(const Tipd& tipd);
01395         SsCcbsRejectArg();
01396
01397         static const SsCcbsRejectArg& Cast(const StackMsgArgument& arg);
01398         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01399         const Tipd& GetTipd() const { return m_tipd; }
01400
01401         enum  {
01402             ID = 2031
01403             };
01404
01405     private:
01406
01407         static void Destroy(StackMsgArgument* arg) { delete ((SsCcbsRejectArg*) arg); }
01408
01409         Tipd m_tipd;
01410
01411     };
01412
01413 // Inline definitions
01414 inline const SsCcbsRejectArg& SsCcbsRejectArg::Cast(const StackMsgArgument& arg) {
01415     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsCcbsRejectArg!\n");
01416     return ((SsCcbsRejectArg &) arg);
01417 }
01418
01419
01420
01421 /*  ======================================================================
01422     Class SsCcbsReCallRequestArg
01423     ====================================================================== */
01424
01426 class SsCcbsReCallRequestArg : public StackMsgArgument {
01427     friend class CommonStackMsgArgsDestroyTableNode;
01428     public:
01429         SsCcbsReCallRequestArg(const Tipd& tipd);
01430         SsCcbsReCallRequestArg();
01431
01432         static const SsCcbsReCallRequestArg& Cast(const StackMsgArgument& arg);
01433         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
01434         const Tipd& GetTipd() const { return m_tipd; }
01435
01436         enum  {
01437             ID = 2032
01438             };
01439
01440     private:
01441
01442         static void Destroy(StackMsgArgument* arg) { delete ((SsCcbsReCallRequestArg*) arg); }
01443
01444         Tipd m_tipd;
01445
01446     };
01447
01448 // Inline definitions
01449 inline const SsCcbsReCallRequestArg& SsCcbsReCallRequestArg::Cast(const StackMsgArgument& arg) {
01450     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsCcbsReCallRequestArg!\n");
01451     return ((SsCcbsReCallRequestArg &) arg);
01452 }
01453
01454
01455
01456 /*  ======================================================================
01457     Class SsUus1ReqArg
01458     ====================================================================== */
01459
01461 class SsUus1ReqArg : public StackMsgArgument {
01462     friend class CommonStackMsgArgsDestroyTableNode;
01463     public:
01464         SsUus1ReqArg();
01465
01466         static const SsUus1ReqArg& Cast(const StackMsgArgument& arg);
01467         void SetText(const WString& text) { m_text = text; }
01468         const WString& GetText() const { return m_text; }
01469         void SetType(const UusOutTextType& type) { m_type = type; }
01470         const UusOutTextType& GetType() const { return m_type; }
01471
01472         enum  {
01473             ID = 2033
01474             };
01475
01476     private:
01477
01478         static void Destroy(StackMsgArgument* arg) { delete ((SsUus1ReqArg*) arg); }
01479
01480         WString m_text;
01481         UusOutTextType m_type;
01482
01483     };
01484
01485 // Inline definitions
01486 inline const SsUus1ReqArg& SsUus1ReqArg::Cast(const StackMsgArgument& arg) {
01487     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUus1ReqArg!\n");
01488     return ((SsUus1ReqArg &) arg);
01489 }
01490
01491
01492
01493 /*  ======================================================================
01494     Class SsUus1QueryReqArg
01495     ====================================================================== */
01496
01498 class SsUus1QueryReqArg : public StackMsgArgument {
01499     friend class CommonStackMsgArgsDestroyTableNode;
01500     public:
01501         SsUus1QueryReqArg();
01502
01503         static const SsUus1QueryReqArg& Cast(const StackMsgArgument& arg);
01504
01505         enum  {
01506             ID = 2035
01507             };
01508
01509     private:
01510
01511         static void Destroy(StackMsgArgument* arg) { delete ((SsUus1QueryReqArg*) arg); }
01512
01513     };
01514
01515 // Inline definitions
01516 inline const SsUus1QueryReqArg& SsUus1QueryReqArg::Cast(const StackMsgArgument& arg) {
01517     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to SsUus1QueryReqArg!\n");
01518     return ((SsUus1QueryReqArg &) arg);
01519 }
01520
01521
01522 #endif // Apc_SsStackMsgArgs_hpp
01523
Generated on Tue Jan 24 14:46:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsStackMsgArgument.cpp File Reference

Apc/SsStackMsgArgument.cpp File Reference

#include "Apc/PreComp.hpp"
#include <Apc/SsStackMsgArgs.hpp>
#include "SsStackMsgArgument.hpp"

Include dependency graph for SsStackMsgArgument.cpp:

Generated on Tue Jan 24 17:08:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsStackMsgArgument.hpp File Reference

Apc/SsStackMsgArgument.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_SsStackMsgArgument_hpp

Define Documentation

#define Asc_SsStackMsgArgument_hpp

Generated on Tue Jan 24 17:08:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsStackMsgArgument.hpp Source File

Apc/SsStackMsgArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_SsStackMsgArgument_hpp)
00011 #define Asc_SsStackMsgArgument_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014 #include <Apc/StackMsgArgument.hpp>
00015
00039 class SsStackMsgArgument {
00040
00041 public:
00042
00045     SsStackMsgArgument(const SsStackMsgArgument &arg);
00046
00054     SsStackMsgArgument(const StackMsgArgument &arg);
00055
00059     virtual ~SsStackMsgArgument();
00060
00065     StackMsgArgId Id() const;
00066
00070     Tipd GetTipd() const;
00071
00075     BOOLEAN IsReleaseComplete() const;
00076
00081     const StackMsgArgument& GetStackMsgArgument() const;
00082     static BOOLEAN IsReleaseComplete(const StackMsgArgument &arg);
00083     static Tipd GetTipd(const StackMsgArgument &arg);
00084
00085     SsStackMsgArgument& operator=(const SsStackMsgArgument& arg);
00086
00087 private:
00090     Tipd m_tipd;
00091
00094     BOOLEAN m_is_release_complete;
00095
00101     StackMsgArgument *m_arg;
00102 };
00103
00104 #endif // DOXYGEN_SHOULD_SKIP_THIS
00105 #endif  // Asc_SsStackMsgArgument_hpp
00106
00107
Generated on Tue Jan 24 14:46:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsStatus.hpp File Reference

Apc/SsStatus.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for SsStatus.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsStatus
Supplementary Service Status [GSM 09.02, 14.7.4]. More...

Defines

#define | Apc_SsStatus_hpp

Define Documentation

#define Apc_SsStatus_hpp

Generated on Tue Jan 24 17:09:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SsStatus.hpp Source File

Apc/SsStatus.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights
00003     reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apc_SsStatus_hpp)
00010 #define Apc_SsStatus_hpp
00011
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/BitField.hpp>
00015
00016
00017 /*  ========================================================================
00018     Supplementary Service Status  [GSM 09.02, 14.7.4], (msap_msg_mn.pr: 966)
00019     SS-Status, containing the following information:
00020     bits 8765: 0000 unused
00021     bit 4 : quiescent/operative indicator
00022     bit 3 : provision indicator
00023     bit 2 : registration indicator
00024     bit 1 : activation indicator
00025
00026     ========================================================================*/
00028 class SsStatus {
00029     public:
00031         SsStatus(UINT8 incoming_byte = 0) : m_ss_status(incoming_byte) {}
00032
00034         UINT8 GetByte() const { return m_ss_status; }
00035
00037         BOOLEAN IsQuiescentBitSet() const { return m_ss_status & 0x08; }        // bit 4
00039         BOOLEAN IsProvisionBitSet() const { return m_ss_status & 0x04; }        // bit 3
00041         BOOLEAN IsRegistrationBitSet() const { return m_ss_status & 0x02; } // bit 2
00043         BOOLEAN IsActivationBitSet() const { return m_ss_status & 0x01; }       // bit 1
00044
00045     private:
00046         UINT8 m_ss_status;
00047 };
00048
00049
00050 #endif  // Apc_SsStatus_hpp
00051
00052
Generated on Tue Jan 24 14:46:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackInterface.cpp File Reference

Apc/StackInterface.cpp File Reference

#include "Apc/PreComp.hpp"
#include "StackInterface.hpp"
#include <Apc/CommonStackMsgArgs.hpp>

Include dependency graph for StackInterface.cpp:

Generated on Tue Jan 24 17:09:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackInterface.hpp File Reference

Apc/StackInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackInterface

Defines

#define | Apc_StackInterface_hpp

Define Documentation

#define Apc_StackInterface_hpp

Generated on Tue Jan 24 17:09:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackInterface.hpp Source File

Apc/StackInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_StackInterface_hpp)
00009 #define Apc_StackInterface_hpp
00010
00011 /*  ========================================================================
00012     StackInterface
00013     ======================================================================== */
00016 class StackInterface {
00017     public:
00018         static void Init();
00019         static BOOLEAN IsFastSmsLoadingSupported();
00020         static BOOLEAN IsGroupDeletionNotificationSupported();
00021
00022 };
00023
00024
00025 #endif // Apc_StackInterface_hpp
00026
00027
Generated on Tue Jan 24 14:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackMsgArgument.cpp File Reference

Apc/StackMsgArgument.cpp File Reference

#include "Apc/PreComp.hpp"
#include "StackMsgArgument.hpp"

Include dependency graph for StackMsgArgument.cpp:

Generated on Tue Jan 24 17:09:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackMsgArgument.hpp File Reference

Apc/StackMsgArgument.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Auxiliary/BinarySearch.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for StackMsgArgument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractStackMsgArgMapContainer
struct | ArgumentDestroyEntry
struct | ArgumentDestroyEntryCompare
class | NoStackMsgArg
class | StackMsgArgDestroyTableNode
struct | StackMsgArgMap< T >
class | StackMsgArgMapContainer< T >
class | StackMsgArgument

Defines

#define | Apc_StackMsgArgument_hpp

Typedefs

typedef INT | StackMsgArgId

Define Documentation

#define Apc_StackMsgArgument_hpp

Typedef Documentation

typedef INT StackMsgArgId

Generated on Tue Jan 24 17:09:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackMsgArgument.hpp Source File

Apc/StackMsgArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_StackMsgArgument_hpp)
00009 #define Apc_StackMsgArgument_hpp
00010
00011 #include <Auxiliary/Macros.hpp>
00012 #include <Auxiliary/BinarySearch.hpp>
00013 #include <Kernel/Os/Os.hpp>
00014
00015 /*  ========================================================================
00016     StackMsgArgId
00017     ======================================================================== */
00018 typedef INT StackMsgArgId;
00019
00020 class StackMsgArgument;
00021 /*  ========================================================================
00022     StackMsgArgMap
00023     ======================================================================== */
00024 template<class T> struct StackMsgArgMap {
00025     StackMsgArgId arg_id;
00026     BOOLEAN (T::*OnArg)(const StackMsgArgument &arg);
00027 };
00028
00029 /*  ========================================================================
00030     ArgumentDestroyEntry
00031     ======================================================================== */
00032 struct ArgumentDestroyEntry {
00033     StackMsgArgId id;
00034     void (*destroy_func)(StackMsgArgument *arg);
00035 };
00036
00037 /*  ========================================================================
00038     ArgumentDestroyEntryCompare (for binary search)
00039     ======================================================================== */
00040 struct ArgumentDestroyEntryCompare {
00041     public:
00042         inline INT Compare(StackMsgArgId id, const ArgumentDestroyEntry &entry) const {
00043             return id < entry.id ? -1 : (id == entry.id ? 0 : 1); }
00044 };
00045
00046 /*  ========================================================================
00047     StackMsgArgDestroyTableNode
00048     ======================================================================== */
00049 class StackMsgArgDestroyTableNode {
00050     friend class StackMsgArgument;
00051     public:
00052         StackMsgArgDestroyTableNode(const ArgumentDestroyEntry * destroy_table, INT16 table_length);
00053         void DestroySelf();
00054         BOOLEAN Destroy(StackMsgArgument *arg);
00055
00056     protected:
00057         virtual void Dummy() {}
00058
00059     private:
00060         void SetNext(StackMsgArgDestroyTableNode *node);
00061         BOOLEAN DestroyArg(StackMsgArgument *arg);
00062
00063         static ArgumentDestroyEntryCompare m_compare;
00064         const CArray<ArgumentDestroyEntry> m_destroy_table;
00065
00066         StackMsgArgDestroyTableNode *m_next;
00067 };
00068
00069 /*  ========================================================================
00070     StackMsgArgument
00071     ======================================================================== */
00073 class StackMsgArgument {
00074     friend class FromStackMsg;
00075     friend class ToStackMsg;
00076     friend class StackMsgArgDestroyTableNode;
00077     friend class SsStackMsgArgument;
00078
00079     public:
00080
00081         StackMsgArgument(StackMsgArgId id = 0);
00082
00083         StackMsgArgId Id() const { return (m_id); }
00084
00085     private:
00086         INT m_ref_count;
00087         StackMsgArgId m_id;
00088         static StackMsgArgDestroyTableNode *m_anchor;
00089
00090         void AddRef(INT n = 1);
00091
00092         static void Attach(StackMsgArgDestroyTableNode *node);
00093 };
00094
00095 /*  ========================================================================
00096     NoStackMsgArg
00097     ======================================================================== */
00098 class NoStackMsgArg : public StackMsgArgument {
00099     friend class StackMsgArgument;
00100     public:
00101         NoStackMsgArg();
00102         ~NoStackMsgArg();
00103
00104         enum { ID = 0 };
00105
00106     private:
00107         static void Destroy(StackMsgArgument *arg) { delete ((NoStackMsgArg *) arg); }
00108 };
00109
00110
00111
00112 /*  ========================================================================
00113     AbstractStackMsgArgMapContainer
00114     ======================================================================== */
00115 class AbstractStackMsgArgMapContainer {
00116     public:
00117         virtual BOOLEAN Execute(const StackMsgArgument &arg) const = 0;
00118 };
00119
00120 /*  ========================================================================
00121     StackMsgArgMapContainer
00122     ======================================================================== */
00123 template<class T> class StackMsgArgMapContainer : public AbstractStackMsgArgMapContainer {
00124     public:
00125         StackMsgArgMapContainer(T *dispatcher = 0, const StackMsgArgMap<T> *arg_map = 0) :
00126           m_dispatcher(dispatcher), m_arg_map(arg_map) { }
00127
00128         virtual void Init(T *dispatcher, const StackMsgArgMap<T> *arg_map) {
00129             m_dispatcher = dispatcher;
00130             m_arg_map = arg_map;
00131         } // Init
00132
00133         virtual BOOLEAN Execute(const StackMsgArgument &arg) const {
00134 //          ASSERT_INFO(m_dispatcher != 0 && m_arg_map != 0, L"StackMsgArgMapContainer not initialized!\n");
00135             ASSERT_ALWAYS(m_dispatcher != 0 && m_arg_map != 0);
00136             StackMsgArgMap<T>* entry = (StackMsgArgMap<T>*)m_arg_map;
00137             while (entry->arg_id != NoStackMsgArg::ID) {
00138                 ASSERT_ALWAYS(entry->OnArg != 0);
00139                 if (entry->arg_id == arg.Id()) {
00140                     return ((m_dispatcher->*(entry->OnArg))(arg));
00141                 } // if
00142                 entry++;
00143             } // while
00144             return (FALSE);
00145         }   // Execute
00146
00147
00148     private:
00149         T *m_dispatcher;
00150         const StackMsgArgMap<T>* m_arg_map;
00151 };
00152
00153
00154 #endif // Apc_StackMsgArgument_hpp
00155
00156
Generated on Tue Jan 24 14:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackWrapper.cpp File Reference

Apc/StackWrapper.cpp File Reference

#include "Apc/PreComp.hpp"
#include "StackWrapper.hpp"
#include "Tpdu.hpp"

Include dependency graph for StackWrapper.cpp:

Generated on Tue Jan 24 17:09:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackWrapper.hpp File Reference

Apc/StackWrapper.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/NetworkTypes.hpp>

Include dependency graph for StackWrapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackWrapper

Defines

#define | Apc_StackWrapper_hpp

Define Documentation

#define Apc_StackWrapper_hpp

Generated on Tue Jan 24 17:09:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StackWrapper.hpp Source File

Apc/StackWrapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_StackWrapper_hpp)
00009 #define Apc_StackWrapper_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 #include <Apc/NetworkTypes.hpp>
00014
00015
00017 class Tpdu;
00018 class StackWrapper
00019 {
00020     public:
00021         // access methods to the built-in stack plmn table
00022         static INT GetCountryListLength();
00023         static Mcc GetCountryListMcc(INT idx);
00024         static INT GetCountryListCc(INT idx);
00025         static const CHAR * GetCountryListName(INT idx);
00026         static INT GetPlmnListLength();
00027         static Mnc GetPlmnListMnc(INT idx);
00028         static Mcc GetPlmnListMcc(INT idx);
00029         static INT GetPlmnListCc(INT idx);
00030         static const CHAR * GetPlmnListCountryName(INT idx);
00031         static const CHAR * GetPlmnListName(INT idx);
00032         static const CHAR * GetPlmnListShortName(INT idx);
00033         static INT GetPlmnListNetType(INT idx);
00034
00035         // returns -1 if no match was found, otherwise the index into the plmn-list
00036         static INT LookupPlmnEntryIndex(Mcc mcc, Mnc mnc);
00037
00038         // transformation methods
00039         static Plmn     TransformBcdPlmnToPlmn(const BcdPlmn & bcd_plmn);
00040         static BcdPlmn  TransformPlmnToBcdPlmn(const Plmn &plmn);
00041
00042         static BOOLEAN  IsBcdPlmnMatching(const BcdPlmn &plmn, UINT16 mcc, UINT8 mnc);
00043
00044
00045         /*  RETURN VALUES:
00046                 negative number         It was not possible to store the short message.
00047                 non negative number     The NVRAM position where the PDU has been stored. */
00048         static INT FlashWritePdu(const Tpdu &tpdu);
00049
00050         /*  RETURN VALUES:
00051                 negative number         error or no message to read
00052                 0 or positive number    NVRAM position to which the entry has been saved. */
00053         static INT FlashReadPdu(INT position, Tpdu &tpdu);
00054
00055         /*  RETURN VALUES:
00056                 negative number:        error or no message to remove
00057                 0 or positive number    NVRAM position from which the entry has been removed. */
00058         static INT FlashDeletePdu(INT position);
00059
00060 };
00061
00062
00063 #endif
00064
Generated on Tue Jan 24 14:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StreamOperators.cpp File Reference

Apc/StreamOperators.cpp File Reference

#include "Apc/PreComp.hpp"
#include "StreamOperators.hpp"

Include dependency graph for StreamOperators.cpp:

Generated on Tue Jan 24 17:09:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StreamOperators.hpp File Reference

Apc/StreamOperators.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apc_StreamOperators_hpp

Define Documentation

#define Apc_StreamOperators_hpp

Generated on Tue Jan 24 17:09:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/StreamOperators.hpp Source File

Apc/StreamOperators.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_StreamOperators_hpp)
00009 #define Apc_StreamOperators_hpp
00010
00011 #endif  // Apc_StreamOperators_hpp
00012
00013
Generated on Tue Jan 24 14:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/TaggedProblemCode.hpp File Reference

Apc/TaggedProblemCode.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for TaggedProblemCode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TaggedProblemCode
Supplementary Service Problem Tag [GSM 04.80, 3.6.7, Table 3.13]. More...

Defines

#define | Apc_TaggedProblemCode_hpp

Define Documentation

#define Apc_TaggedProblemCode_hpp

Generated on Tue Jan 24 17:09:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/TaggedProblemCode.hpp Source File

Apc/TaggedProblemCode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_TaggedProblemCode_hpp)
00009 #define Apc_TaggedProblemCode_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013
00014
00015 /*  ========================================================================
00016     Supplementary Service Problem Tag [GSM 04.80, 3.6.7, Table 3.13]
00017     (msap_msg_mn.pr: 1375)
00018     ========================================================================*/
00020 class TaggedProblemCode {
00021     public:
00023         enum ProblemTag {
00025             General = 0x00,         // tag = 0x80
00027             Invoke = 0x01,          // tag = 0x81
00029             ReturnResult = 0x02,    // tag = 0x82
00031             ReturnError = 0x03,     // tag = 0x83
00033             InvalidTag = 0x0f
00034         };
00035
00036         enum ProblemCode {
00037
00039             UnrecognizedComponent       = 0x00, // tag = 0x80, code = 0x00
00041             MistypedComponent           = 0x01, // tag = 0x80, code = 0x01
00043             BadlyStructuredComponent    = 0x02, // tag = 0x80, code = 0x02;
00044
00046             DuplicateInvokeId           = 0x10, // tag = 0x81, code = 0x00
00048             UnrecognizedOperation       = 0x11, // tag = 0x81, code = 0x01
00050             MistypedProParameter        = 0x12, // tag = 0x81, code = 0x02
00052             ResourceLimitation          = 0x13, // tag = 0x81, code = 0x03;
00054             InitiatingRelease           = 0x14, // tag = 0x81, code = 0x04;
00056             UnrecognizedLinkedId        = 0x15, // tag = 0x81, code = 0x05;
00058             LinkedResponseUnexpected    = 0x16, // tag = 0x81, code = 0x06;
00060             UnexpectedLinkedOperation   = 0x17, // tag = 0x81, code = 0x07;
00061
00063             UnrecognizedInvokeId        = 0x20, // tag = 0x82, code = 0x00;
00065             ReturnResultUnexpected      = 0x21, // tag = 0x82, code = 0x01;
00067             MistypedResParameter        = 0x22, // tag = 0x82, code = 0x02;
00068
00070             UnrecognizedErrorInvokeId   = 0x30, // tag = 0x83, code = 0x00;
00072             ReturnErrorUnexpected       = 0x31, // tag = 0x83, code = 0x01;
00074             UnrecognizedError           = 0x32, // tag = 0x83, code = 0x02;
00076             UnexpectedError             = 0x33, // tag = 0x83, code = 0x03;
00078             MistypedErrorParameter      = 0x34, // tag = 0x83, code = 0x04;
00079
00081             InvalidCode                 = 0x0f
00082         };
00083
00085         explicit TaggedProblemCode(UINT8 incoming_tag = InvalidTag, UINT8 incoming_code = InvalidCode)
00086             // msb of incoming tag is shifted away (identification done by lsb of incoming tag)
00087             : m_tagged_problem_code((incoming_tag << 4) | incoming_code) {};
00088
00090         TaggedProblemCode(const TaggedProblemCode & code)
00091             : m_tagged_problem_code(code.GetProblemCode()) {}
00092
00094         TaggedProblemCode(const ProblemCode code)
00095             : m_tagged_problem_code((UINT8)code) {}
00096
00098         UINT8 GetTagAsByte() const { return (m_tagged_problem_code >> 4) | 0x80; }
00100         UINT8 GetCodeAsByte() const { return m_tagged_problem_code & 0x0f; }
00101
00102
00104         ProblemTag GetProblemTag() const { return (ProblemTag)(m_tagged_problem_code >> 4); } // 0xff->0x0f InvalidTag;
00105
00106
00108         ProblemCode GetProblemCode() const { return (ProblemCode)m_tagged_problem_code; }
00109         void SetProblemCode(ProblemCode code) { m_tagged_problem_code = code; } // tag is set implicitly
00110
00111     private:
00112         UINT8 m_tagged_problem_code;
00113 };
00114
00115
00116 #endif  // Apc_TaggedProblemCode_hpp
00117
00118
Generated on Tue Jan 24 14:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Tlv.cpp File Reference

Apc/Tlv.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Tlv.hpp"

Include dependency graph for Tlv.cpp:

Generated on Tue Jan 24 17:09:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Tlv.hpp File Reference

Apc/Tlv.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for Tlv.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Tlv
Simple TLV (TagLengthValue) objects - GSM 11.14 [12]. More...

Defines

#define | Apc_Tlv_hpp

Typedefs

typedef UINT8 | TlvAtom

Enumerations

enum Nai {
NaiInvalid = 0x00, NaiSetupCall = 0x10, NaiSendSs = 0x11, NaiSendUssd = 0x12,
NaiSendShortMessage = 0x13, NaiLaunchBrowser = 0x15, NaiPlayTone = 0x20, NaiDisplayText = 0x21,
NaiGetInkey = 0x22, NaiGetInput = 0x23, NaiSelectItem = 0x24, NaiSetupMenu = 0x25,
NaiProvideLocalInformation = 0x26, NaiSetupIdleModeText = 0x28, NaiPerformCardApdu = 0x30, NaiPowerOnCard = 0x31,
NaiPowerOffCard = 0x32, NaiGetReaderStatus = 0x33, NaiOpenChannel = 0x40, NaiCloseChannel = 0x41,
NaiReceiveData = 0x42, NaiSendData = 0x43, NaiGetChannelStatus = 0x44, NaiEndOfProactiveSession = 0x81
}
next action indicator - GSM 11.14 [13.4] More...
enum SimStatusCondition {
SscNormalEnding = 0x90, SscNormalEndingExtra = 0x91, SscDataDownloadResponse = 0x9E, SscOtherResponse = 0x9F,
SscPostponedResponse = 0x93, SscMemoryManagementResponse = 0x92, SscReferencingManagementResponse = 0x94, SscSecurityManagementResponse = 0x98,
SscIncorrectParameterP3 = 0x67, SscIncorrectParameterP1_P2 = 0x6B, SscUnknownInstruction = 0x6D, SscWrongInstruction = 0x6E,
SscTechnicalProblem = 0x6F
}
Status conditions returned by the card, StatusWord1(SW1) - GSM 11.11 [9.4]. More...
enum Toc {
TocInvalid = 0x00, TocRefresh = 0x01, TocMoreTime = 0x02, TocPollIntervall = 0x03,
TocPollingOff = 0x04, TocSetUpEventList = 0x05, TocSetupCall = 0x10, TocSendSs = 0x11,
TocSendUssd = 0x12, TocSendShortMessage = 0x13, TocSendDtmf = 0x14, TocLaunchBrowser = 0x15,
TocPlayTone = 0x20, TocDisplayText = 0x21, TocGetInkey = 0x22, TocGetInput = 0x23,
TocSelectItem = 0x24, TocSetupMenu = 0x25, TocProvideLocalInformation = 0x26, TocTimerManagement = 0x27,
TocSetupIdleModeText = 0x28, TocPerformCardApdu = 0x30, TocPowerOnCard = 0x31, TocPowerOffCard = 0x32,
TocGetReaderStatus = 0x33, TocRunAtCommand = 0x34, TocLanguageNotification = 0x35, TocOpenChannel = 0x40,
TocCloseChannel = 0x41, TocReceiveData = 0x42, TocSendData = 0x43, TocGetChannelStatus = 0x44,
TocEndOfProactiveSession = 0x81
}
Type of Command - GSM 11.14 [13.4]. More...

Variables

const UINT8 | c_tlv_len_byte_mask = 0x80
const UINT8 | c_tlv_two_byte_len_sign = 0x81

Define Documentation

#define Apc_Tlv_hpp

Typedef Documentation

typedef UINT8 TlvAtom

Enumeration Type Documentation

enum Nai

next action indicator - GSM 11.14 [13.4]

Enumerator:
NaiInvalid
NaiSetupCall
NaiSendSs
NaiSendUssd
NaiSendShortMessage
NaiLaunchBrowser | this value is not marked in 11.14 chapter 13.4 as NAI
NaiPlayTone
NaiDisplayText
NaiGetInkey
NaiGetInput
NaiSelectItem
NaiSetupMenu
NaiProvideLocalInformation | this value is not marked in 11.14 but in test 11.10-4 chapter 27.22.4.9.2.4.2
NaiSetupIdleModeText
NaiPerformCardApdu | class "a" only
NaiPowerOnCard | class "a" only
NaiPowerOffCard | class "a" only
NaiGetReaderStatus | class "a" only
NaiOpenChannel | class "e" only
NaiCloseChannel | class "e" only
NaiReceiveData | class "e" only
NaiSendData | class "e" only
NaiGetChannelStatus | class "e" only
NaiEndOfProactiveSession | class "e" only

enum SimStatusCondition

Status conditions returned by the card, StatusWord1(SW1) - GSM 11.11 [9.4].

Enumerator:
SscNormalEnding | normal ending of the command
SscNormalEndingExtra | normal ending of the command, with extra information from the proactive SIM containing a command for the ME.
SscDataDownloadResponse
SscOtherResponse
SscPostponedResponse
SscMemoryManagementResponse
SscReferencingManagementResponse
SscSecurityManagementResponse
SscIncorrectParameterP3 | incorrect parameter P3
SscIncorrectParameterP1_P2 | incorrect Parameter P1 or P2
SscUnknownInstruction | unknown instruction code given in the command
SscWrongInstruction | wrong instruction given in the command
SscTechnicalProblem | technical problem with no diagnostic given

enum Toc

Type of Command - GSM 11.14 [13.4].

Enumerator:
TocInvalid
TocRefresh
TocMoreTime
TocPollIntervall
TocPollingOff
TocSetUpEventList
TocSetupCall
TocSendSs
TocSendUssd
TocSendShortMessage
TocSendDtmf
TocLaunchBrowser | class "c" only
TocPlayTone
TocDisplayText
TocGetInkey
TocGetInput
TocSelectItem
TocSetupMenu
TocProvideLocalInformation
TocTimerManagement
TocSetupIdleModeText
TocPerformCardApdu | class "a" only
TocPowerOnCard | class "a" only
TocPowerOffCard | class "a" only
TocGetReaderStatus | class "a" only
TocRunAtCommand | class "b" only
TocLanguageNotification
TocOpenChannel | class "e" only
TocCloseChannel | class "e" only
TocReceiveData | class "e" only
TocSendData | class "e" only
TocGetChannelStatus | class "e" only
TocEndOfProactiveSession | class "e" only

Variable Documentation

const UINT8 c_tlv_len_byte_mask = 0x80

const UINT8 c_tlv_two_byte_len_sign = 0x81

Generated on Tue Jan 24 17:09:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Tlv.hpp Source File

Apc/Tlv.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Tlv_hpp)
00009 #define Apc_Tlv_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 /*  ========================================================================
00014                                   types
00015     ======================================================================== */
00016 typedef UINT8 TlvAtom;
00017
00018 /*  ========================================================================
00019                                 constants
00020     ======================================================================== */
00021 const UINT8 c_tlv_len_byte_mask = 0x80;
00022 const UINT8 c_tlv_two_byte_len_sign = 0x81;
00023
00024 /*  ========================================================================
00025                                   enums
00026     ======================================================================== */
00028 enum Nai {
00030     NaiInvalid = 0x00,
00032     NaiSetupCall = 0x10,
00034     NaiSendSs = 0x11,
00036     NaiSendUssd = 0x12,
00038     NaiSendShortMessage = 0x13,
00040     NaiLaunchBrowser = 0x15,
00042     NaiPlayTone = 0x20,
00044     NaiDisplayText = 0x21,
00046     NaiGetInkey = 0x22,
00048     NaiGetInput = 0x23,
00050     NaiSelectItem = 0x24,
00052     NaiSetupMenu = 0x25,
00054     NaiProvideLocalInformation = 0x26,
00056     NaiSetupIdleModeText = 0x28,
00058     NaiPerformCardApdu = 0x30,
00060     NaiPowerOnCard = 0x31,
00062     NaiPowerOffCard = 0x32,
00064     NaiGetReaderStatus = 0x33,
00066     NaiOpenChannel = 0x40,
00068     NaiCloseChannel = 0x41,
00070     NaiReceiveData = 0x42,
00072     NaiSendData = 0x43,
00074     NaiGetChannelStatus = 0x44,
00076     NaiEndOfProactiveSession = 0x81,
00077 };
00078
00080 enum Toc {
00082     TocInvalid                  = 0x00,
00084     TocRefresh                  = 0x01,
00086     TocMoreTime                 = 0x02,
00088     TocPollIntervall            = 0x03,
00090     TocPollingOff               = 0x04,
00092     TocSetUpEventList           = 0x05,
00094     TocSetupCall                = 0x10,
00096     TocSendSs                   = 0x11,
00098     TocSendUssd                 = 0x12,
00100     TocSendShortMessage         = 0x13,
00102     TocSendDtmf                 = 0x14,
00104     TocLaunchBrowser            = 0x15,
00106     TocPlayTone                 = 0x20,
00108     TocDisplayText              = 0x21,
00110     TocGetInkey                 = 0x22,
00112     TocGetInput                 = 0x23,
00114     TocSelectItem               = 0x24,
00116     TocSetupMenu                = 0x25,
00118     TocProvideLocalInformation  = 0x26,
00120     TocTimerManagement          = 0x27,
00122     TocSetupIdleModeText        = 0x28,
00124     TocPerformCardApdu          = 0x30,
00126     TocPowerOnCard              = 0x31,
00128     TocPowerOffCard             = 0x32,
00130     TocGetReaderStatus          = 0x33,
00132     TocRunAtCommand             = 0x34,
00134     TocLanguageNotification     = 0x35,
00136     TocOpenChannel              = 0x40,
00138     TocCloseChannel             = 0x41,
00140     TocReceiveData              = 0x42,
00142     TocSendData                 = 0x43,
00144     TocGetChannelStatus         = 0x44,
00146     TocEndOfProactiveSession    = 0x81,
00147 };
00148
00150 enum SimStatusCondition {
00152     SscNormalEnding             = 0x90,
00155     SscNormalEndingExtra                = 0x91,
00157     SscDataDownloadResponse             = 0x9E,
00159     SscOtherResponse                    = 0x9F,
00161     SscPostponedResponse                = 0x93,
00163     SscMemoryManagementResponse         = 0x92,
00165     SscReferencingManagementResponse    = 0x94,
00167     SscSecurityManagementResponse       = 0x98,
00169     SscIncorrectParameterP3             = 0x67,
00171     SscIncorrectParameterP1_P2          = 0x6B,
00173     SscUnknownInstruction               = 0x6D,
00175     SscWrongInstruction                 = 0x6E,
00177     SscTechnicalProblem                 = 0x6F
00178 };
00179
00180 /*  ========================================================================
00181     Tlv
00182     ======================================================================== */
00184 class Tlv {
00185     public:
00187         enum LengthCoding {
00189             OneByte = 1,
00191             TwoByte = 2
00192         };
00193
00195         enum Tag {  // this list holds only the actual needed tags
00197             UndefinedTag = 0x00,
00199             AlphaIdentifierTag = 0x05,
00201             TextStringTag = 0x0D,
00203             ItemTag = 0x0F,
00205             ItemIdentifierTag = 0x10,
00207             ItemsNaiTag = 0x18,
00209             IconIdentifierTag = 0x1E,
00211             ItemIconIdentifierListTag = 0x1F,
00212         };
00213
00215         Tlv(const TlvAtom *byte_stream = 0, const LengthCoding len_coding = OneByte);
00217         Tlv(const Tag tag, const INT val_len = 0, const TlvAtom *val_data = 0);
00219         Tlv(const Tlv& tlv);
00221         Tlv& operator =(const Tlv &tlv);
00223         virtual ~Tlv();
00224
00226         Tag GetTag() const { return ((Tag) (m_tag & 0x7F)); }
00227
00229         INT GetStreamSize() const { return (m_stream_size); }
00230
00232         INT GetValLen() const { return (m_val_len); }
00234         const TlvAtom* GetValPtr() const { return (m_val_data); }
00235
00237         BOOLEAN IsComprehensionRequired() const { return ((m_tag & 0x80) == 0x80); }
00238
00239     private:
00240         Tag m_tag;
00241         INT m_val_len;
00242         TlvAtom *m_val_data;
00243         INT m_stream_size;
00244
00245         void Clear();
00246 };
00247
00248
00249 #endif  // Apc_Tlv_hpp
00250
Generated on Tue Jan 24 14:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Tpdu.cpp File Reference

Apc/Tpdu.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Tpdu.hpp"
#include "SignalTypes.hpp"

Include dependency graph for Tpdu.cpp:

Generated on Tue Jan 24 17:09:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Tpdu.hpp File Reference

Apc/Tpdu.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Apc/MessageTypeIndicator.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for Tpdu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Tpdu

Defines

#define | Apc_Tpdu_hpp

Functions

UINT8 | GetRawTpduStatus (UINT8 status)
BOOLEAN | IsTpduSentStatus (UINT8 status)

Define Documentation

#define Apc_Tpdu_hpp

Function Documentation

UINT8 GetRawTpduStatus ( UINT8 status ) [inline]

BOOLEAN IsTpduSentStatus ( UINT8 status ) [inline]

Generated on Tue Jan 24 17:09:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/Tpdu.hpp Source File

Apc/Tpdu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Tpdu_hpp)
00009 #define Apc_Tpdu_hpp
00010
00011 #include <Kernel/Os/Os.hpp>
00012 #include <Auxiliary/PhoneNumber.hpp>
00013
00014 #include <Apc/MessageTypeIndicator.hpp>
00015
00016 #include <Apc/SignalTypes.hpp>
00017
00018
00020
00021 inline BOOLEAN IsTpduSentStatus(UINT8 status)
00022 {
00023     return (status & 0x07) == 0x05;
00024 }
00025
00027
00028 inline UINT8 GetRawTpduStatus(UINT8 status)
00029 {
00030     return (status & 0x07);
00031 }
00032
00033 /*  ========================================================================
00034     TPDU: Transfer Protocol Data Unit - 3GPP TS 23.040 V5.1.0 [9]
00035     ======================================================================== */
00038 class Tpdu : public Linkable<Tpdu> {
00039     typedef Linkable<Tpdu> Base;
00040     public:
00042         enum Status {
00044             Empty           = SI_SM_STATUS_FREE,            // = 0000 0000
00046             Read            = SI_SM_STATUS_READ,            // = 0000 0001
00048             Unread          = SI_SM_STATUS_TO_BE_READ,      // = 0000 0011
00050             Sent            = SI_SM_STATUS_SENT,            // = 0000 0101 SMS sent
00052             SentSmsrReq     = 0x0d,                         // = 0000 1101 SMS sent and report requested
00054             SentSmsrNoSmsr  = 0x15,                         // = 0001 0101 SMS sent, report not stored in SMSR
00056             SentSmsrInSmsr  = 0x1d,                         // = 0001 1101 SMS sent, report stored in SMSR
00058             Unsent          = SI_SM_STATUS_TO_BE_SENT,      // = 0000 0111
00060             UndefinedStatus = SI_SM_STATUS_UNKNOWN          // = 1111 1111
00061         };
00062
00064         Tpdu();
00066         Tpdu(Status status, INT length = 0, const UINT8 *data = 0);
00068         Tpdu(const T_PDU &sdl_pdu);
00070         virtual ~Tpdu();
00072         Tpdu(const Tpdu &tpdu);
00074         Tpdu& operator =(const Tpdu &tpdu);
00076         BOOLEAN operator == (const Tpdu &tpdu) const;
00077
00079         void Convert2Pdu(T_PDU &sdl_pdu) const;
00080
00082         BOOLEAN IsValid() const;
00083
00085         void SetStatus(Status status) { m_status = status; }
00087         void SetDataBuffer(INT length, const UINT8 *data);
00088
00090         Status GetStatus() const { return (m_status); }
00092         INT GetLength() const { return (m_length); }
00094         UINT8* GetData() const { return (m_data); }
00095
00097         PhoneNumber GetServiceCentreAddress() const;
00099         void SetServiceCentreAddress(const PhoneNumber &phone_number);
00100
00102         MessageTypeIndicator GetMessageTypeIndicator() const;
00103
00105         BOOLEAN IsMobileTerminated() const { return (m_status == Read || m_status == Unread); }
00107         BOOLEAN IsMobileOriginated() const { return (IsTpduSentStatus(m_status) || m_status == Unsent); }
00108
00109
00111         static INT GetMaxDataSize();
00112
00114         INT GetTpOffset() const;
00115
00116         // returns the anchor of the real TPDU-data (starting with message type indicator).
00117         INT GetTpLength() const;
00118
00119         // returns the anchor of the real TPDU-data (starting with message type indicator).
00120         UINT8* GetTpData() const;
00121
00122
00124         INT ReallocateData(INT length);
00125
00127         INT ResizeData(INT length);
00128
00130         void CopyData(const UINT8 *data);
00131
00133         void ClearData();
00134
00136         void Clear();
00137
00139         void InitData(UINT8 fill_byte = 0x00);
00140
00141     private:
00142         Status m_status;
00143         INT m_length;
00144         UINT8 *m_data;
00145 };
00146
00147 #endif  // Apc_Tpdu_hpp
00148
00149
Generated on Tue Jan 24 14:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/UserData.cpp File Reference

Apc/UserData.cpp File Reference

#include "Apc/PreComp.hpp"
#include "UserData.hpp"
#include <Apc/InformationElement.hpp>
#include <Apc/SimDataTypes.hpp>
#include <Auxiliary/DataCoding.hpp>

Include dependency graph for UserData.cpp:

Generated on Tue Jan 24 17:09:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/UserData.hpp File Reference

Apc/UserData.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BlobObject.hpp>
#include <Auxiliary/WString.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <Apc/InformationElement.hpp>

Include dependency graph for UserData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UserData
class | UserDataHeader

Defines

#define | Apc_UserData_hpp

Define Documentation

#define Apc_UserData_hpp

Generated on Tue Jan 24 17:10:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/UserData.hpp Source File

Apc/UserData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_UserData_hpp)
00009 #define Apc_UserData_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BlobObject.hpp>
00013 #include <Auxiliary/WString.hpp>
00014
00015 #include <Apc/DataCodingScheme.hpp>
00016 #include <Apc/InformationElement.hpp>
00017
00018
00019 /*  ========================================================================
00020     UserDataHeader - 3GPP 23.040 V5.1.0 [9.2.3.24.1-12]
00021     ======================================================================== */
00024 class UserDataHeader {
00025     public:
00027         UserDataHeader();
00028
00030         UserDataHeader(UINT8 *data_header_anchor, INT max_size = -1);
00031
00033         void Init(UINT8 *data_header_anchor);
00034
00035         BOOLEAN IsValid() const { return m_data_header_anchor!=0; }
00036
00038         INT GetLength() const;
00040         void SetLength(INT length);
00042         const UINT8* GetData() const;
00044         UINT8* GetData();
00045
00047         UINT8 GetSize() const;
00049         const UINT8* GetStartAddress() const { return (m_data_header_anchor); }
00050
00052         InformationElement GetFirstInformationElement();
00053
00055         InformationElement GetNextInformationElement();
00056
00058         BOOLEAN HasMoreInformationElements() const;
00059
00061         INT GetRemainingSize() const;
00063         BOOLEAN Append(const InformationElement& information_element);
00064
00065
00066     private:
00067         UINT8 *m_data_header_anchor;
00068         INT m_iterator_idx;
00069         INT m_max_size;
00070 };
00071
00072
00073 /*  ========================================================================
00074     UserData - 3GPP 23.040 V5.1.0 [9.2.3.24]
00075     ======================================================================== */
00078 class UserData {
00079     public:
00080         //
00081         UserData();
00083         UserData(UINT8 *data_anchor, INT max_user_data_size = 0, BOOLEAN header_exists = FALSE, const DataCodingScheme &dcs = DataCodingScheme());
00085         ~UserData();
00087         void Init(UINT8 *data_anchor = 0, INT max_user_data_size = 0, BOOLEAN header_exists = FALSE, const DataCodingScheme &dcs = DataCodingScheme());
00088
00090         BOOLEAN HeaderExists() const;
00092         UserDataHeader GetUserDataHeader() const;
00093
00095         INT GetSize() const;
00097         const UINT8* GetStartAddress() const { return (m_data_anchor); }
00098
00101         INT GetLength() const;
00103         void SetLength(INT length);
00105         const UINT8* GetData() const;
00107         UINT8* GetData();
00108
00112         INT GetTextData(UINT8 *&text, UINT8 &padding) const;
00113
00115         INT GetTextDataLength() const;
00116
00118         INT GetPayloadSize() const;
00120         INT GetPayloadOffset() const;
00121
00123         void Read(WString &text) const;
00125         WString Read() const;
00126
00128         void ReadPayloadData(BlobObject &blob) const;
00130         BlobObject ReadPayloadData() const;
00131
00136         INT Write(const WString &text);
00137
00142         INT WritePayloadData(const BlobObject &blob);
00143
00145         void Reset();
00146
00148         INT GetRemainingSize() const;
00149
00154         BOOLEAN Append(const InformationElement &information_element);
00155
00156
00162         static INT CalculateUserDataSize(INT header_size, INT &data_length, const WString *text,
00163                                          INT text_length, DataCodingScheme::Alphabet alphabet);
00164
00165     private:
00166         UINT8 *m_data_anchor;
00167         INT m_max_size;
00168         BOOLEAN m_header_exists;
00169         DataCodingScheme m_dcs;
00170
00171         // Returns the correct length (septets or octets) depending on the alphabet.
00172         static INT CalculateLength(INT bytes, DataCodingScheme::Alphabet alphabet, UINT8 *padding = 0);
00173
00174         // Returns the correct size (in bytes) depending on the alphabet.
00175         static INT CalculateSize(INT length, DataCodingScheme::Alphabet alphabet);
00176 };
00177
00178
00179 #endif  // Apc_UserData_hpp
00180
00181
Generated on Tue Jan 24 14:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/UsimPbTypes.cpp File Reference

Apc/UsimPbTypes.cpp File Reference

#include "Apc/PreComp.hpp"
#include "UsimPbTypes.hpp"

Include dependency graph for UsimPbTypes.cpp:

Functions

const CHAR * | GetUsimPbAddTypeName (UsimPbAddType type)
const CHAR * | GetUsimPbLinkTypeName (UsimPbLinkType type)
const CHAR * | GetUsimPbRefTypeName (UsimPbRefType type)

Function Documentation

const CHAR* GetUsimPbAddTypeName ( UsimPbAddType type )

const CHAR* GetUsimPbLinkTypeName ( UsimPbLinkType type )

const CHAR* GetUsimPbRefTypeName ( UsimPbRefType type )

Generated on Tue Jan 24 17:10:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/UsimPbTypes.hpp File Reference

Apc/UsimPbTypes.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Apc/SignalTypes.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for UsimPbTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | T_PB_CHANGED_FIELD
struct | T_PB_CLIENT_FLAGS
struct | T_PB_DESCRIPTOR
struct | T_PB_FILE_A
struct | T_PB_FILE_DESC
struct | T_PB_FILE_IN_SLICE
struct | T_PB_FILL_STATUS
struct | T_PB_GROUP_NUMBER
struct | T_PB_GROUPING
struct | T_PB_LOC_REPORT
struct | T_PB_RECORD
struct | T_PB_REF_FILE
struct | T_PB_REF_FILE_FILL_STATUS
struct | T_PB_REF_FILE_FILL_STATUS_A
struct | T_PB_REF_RECORD
struct | T_PB_REFERENCE
struct | T_PB_STATE
struct | T_PB_UNIQUE_FILE
struct | T_PB_UNIQUE_FILE_FILL_STATUS
class | UsimPbChangedField
class | UsimPbFillStatus
class | UsimPbGroups
class | UsimPbLocReport
class | UsimPbRefRecord
class | UsimPbRwRecord

Defines

#define | Apc_UsimPbTypes_hpp
#define | PB_AAS_DATA 0
#define | PB_ANR_REF 0
#define | PB_APPL 3
#define | PB_BUFFER_IS_NULL 5
#define | PB_BUFFER_TO_SMALL 10
#define | PB_CCP1_DATA 2
#define | PB_CLIENT_FLAG_AUTOLOAD 0
#define | PB_DATA_TYPE_MISMATCH 7
#define | PB_EMAIL_REF 2
#define | PB_EXT1_DATA 3
#define | PB_GAS_DATA 1
#define | PB_GLOBAL 2
#define | PB_INDICATION 0
#define | PB_LINK_TYPE_1 0
#define | PB_LINK_TYPE_2 1
#define | PB_LINK_TYPE_3 2
#define | PB_MAX_FILE_TYPE_ENTITY 10
#define | PB_MAX_GROUP 10
#define | PB_MAX_SLICE 2
#define | PB_NO_FREE_RECORD 3
#define | PB_NOT_EXIST 15
#define | PB_NOT_LOADED 16
#define | PB_NOT_LOCATED 13
#define | PB_NOT_SEL 14
#define | PB_NOT_SELECTED 0
#define | PB_REF_REFRESH 3
#define | PB_REFRESH 2
#define | PB_RESPONSE 1
#define | PB_SIM 1
#define | PB_SKIPPED 2
#define | PB_SNE_REF 1
#define | PB_SUCCESSFUL 0
#define | PB_SUCCESSFUL_UID 1
#define | PB_TECHNICAL_PROBLEM 18
#define | PB_TO_FEW_FREE_EXT 4
#define | PB_WRONG_DATA_TYPE 8
#define | PB_WRONG_HANDLE 9
#define | PB_WRONG_LOCATION 17
#define | PB_WRONG_REC_NUMBER 11
#define | PB_WRONG_REF_REC 6
#define | PB_WRONG_STRUCTURE 12

Typedefs

typedef SDL_Integer | PB_RESULT
typedef SDL_Integer | T_PB_DATA
typedef SDL_Integer | T_PB_LINK_TYPE
typedef SDL_Integer | T_PB_LOCATION
typedef SDL_Integer | T_PB_REF
typedef SDL_Integer | T_PB_SIGNAL_TYPE

Enumerations

enum UsimPbAddType {
UsimPbAas = PB_AAS_DATA, UsimPbGas = PB_GAS_DATA, UsimPbCcp1 = PB_CCP1_DATA, UsimPbExt1 = PB_EXT1_DATA,
UsimPbInvalidAdd
}
enum | UsimPbLinkType { UsimPbType1 = PB_LINK_TYPE_1, UsimPbType2 = PB_LINK_TYPE_2, UsimPbType3 = PB_LINK_TYPE_3 }
enum | UsimPbLocation { UsimPbNotSelected = PB_NOT_SELECTED, UsimPbSim = PB_SIM, UsimPbGlobal = PB_GLOBAL, UsimPbApplication = PB_APPL }
enum | UsimPbRefType { UsimPbAnr = PB_ANR_REF, UsimPbSne = PB_SNE_REF, UsimPbEmail = PB_EMAIL_REF, UsimPbInvalidRef }
enum UsimPbResult {
UsimPbSuccessful = PB_SUCCESSFUL, UsimPbSuccessfulUid = PB_SUCCESSFUL_UID, UsimPbSkipped = PB_SKIPPED, UsimPbNoFreeRecord = PB_NO_FREE_RECORD,
UsimPbTooFewExtRecs = PB_TO_FEW_FREE_EXT, UsimPbBufferIsNull = PB_BUFFER_IS_NULL, UsimPbWrongRefRecord = PB_WRONG_REF_REC, UsimPbDataTypeMismatch = PB_DATA_TYPE_MISMATCH,
UsimPbWrongDataType = PB_WRONG_DATA_TYPE, UsimPbWrongHandle = PB_WRONG_HANDLE, UsimPbBufferTooSmall = PB_BUFFER_TO_SMALL, UsimPbWrongRecNumber = PB_WRONG_REC_NUMBER,
UsimPbWrongStructure = PB_WRONG_STRUCTURE, UsimPbNotLocated = PB_NOT_LOCATED, UsimPbNotSel = PB_NOT_SEL, UsimPbNotExisting = PB_NOT_EXIST,
UsimPbNotLoaded = PB_NOT_LOADED, UsimPbWrongLocation = PB_WRONG_LOCATION, UsimPbTechnicalProblem = PB_TECHNICAL_PROBLEM, UsimPbUndefined
}
enum | UsimPbSignalType { UsimPbIndication = PB_INDICATION, UsimPbResponse = PB_RESPONSE, UsimPbRefresh = PB_REFRESH, UsimPbRefRefresh = PB_REF_REFRESH }

Functions

const CHAR * | GetUsimPbAddTypeName (UsimPbAddType type)
const CHAR * | GetUsimPbLinkTypeName (UsimPbLinkType type)
const CHAR * | GetUsimPbRefTypeName (UsimPbRefType type)

Variables

const UINT8 | c_no_aas_record_value = 0x00
const UINT8 | c_no_group_value = 0x00
const INT | c_pb_client_autoload_flag = PB_CLIENT_FLAG_AUTOLOAD
const INT | c_pb_max_file_type_per_record = PB_MAX_FILE_TYPE_ENTITY
const INT | c_pb_max_groups = PB_MAX_GROUP
const INT | c_pb_max_slices = PB_MAX_SLICE

Define Documentation

#define Apc_UsimPbTypes_hpp

#define PB_AAS_DATA 0

#define PB_ANR_REF 0

#define PB_APPL 3

#define PB_BUFFER_IS_NULL 5

#define PB_BUFFER_TO_SMALL 10

#define PB_CCP1_DATA 2

#define PB_CLIENT_FLAG_AUTOLOAD 0

#define PB_DATA_TYPE_MISMATCH 7

#define PB_EMAIL_REF 2

#define PB_EXT1_DATA 3

#define PB_GAS_DATA 1

#define PB_GLOBAL 2

#define PB_INDICATION 0

#define PB_LINK_TYPE_1 0

#define PB_LINK_TYPE_2 1

#define PB_LINK_TYPE_3 2

#define PB_MAX_FILE_TYPE_ENTITY 10

#define PB_MAX_GROUP 10

#define PB_MAX_SLICE 2

#define PB_NO_FREE_RECORD 3

#define PB_NOT_EXIST 15

#define PB_NOT_LOADED 16

#define PB_NOT_LOCATED 13

#define PB_NOT_SEL 14

#define PB_NOT_SELECTED 0

#define PB_REF_REFRESH 3

#define PB_REFRESH 2

#define PB_RESPONSE 1

#define PB_SIM 1

#define PB_SKIPPED 2

#define PB_SNE_REF 1

#define PB_SUCCESSFUL 0

#define PB_SUCCESSFUL_UID 1

#define PB_TECHNICAL_PROBLEM 18

#define PB_TO_FEW_FREE_EXT 4

#define PB_WRONG_DATA_TYPE 8

#define PB_WRONG_HANDLE 9

#define PB_WRONG_LOCATION 17

#define PB_WRONG_REC_NUMBER 11

#define PB_WRONG_REF_REC 6

#define PB_WRONG_STRUCTURE 12

Typedef Documentation

typedef SDL_Integer PB_RESULT

typedef SDL_Integer T_PB_DATA

typedef SDL_Integer T_PB_LINK_TYPE

typedef SDL_Integer T_PB_LOCATION

typedef SDL_Integer T_PB_REF

typedef SDL_Integer T_PB_SIGNAL_TYPE

Enumeration Type Documentation

enum UsimPbAddType

Enumerator:
UsimPbAas
UsimPbGas
UsimPbCcp1
UsimPbExt1
UsimPbInvalidAdd

enum UsimPbLinkType

Enumerator:
UsimPbType1
UsimPbType2
UsimPbType3

enum UsimPbLocation

Enumerator:
UsimPbNotSelected
UsimPbSim
UsimPbGlobal
UsimPbApplication

enum UsimPbRefType

Enumerator:
UsimPbAnr
UsimPbSne
UsimPbEmail
UsimPbInvalidRef

enum UsimPbResult

Enumerator:
UsimPbSuccessful
UsimPbSuccessfulUid
UsimPbSkipped
UsimPbNoFreeRecord
UsimPbTooFewExtRecs
UsimPbBufferIsNull
UsimPbWrongRefRecord
UsimPbDataTypeMismatch
UsimPbWrongDataType
UsimPbWrongHandle
UsimPbBufferTooSmall
UsimPbWrongRecNumber
UsimPbWrongStructure
UsimPbNotLocated
UsimPbNotSel
UsimPbNotExisting
UsimPbNotLoaded
UsimPbWrongLocation
UsimPbTechnicalProblem
UsimPbUndefined

enum UsimPbSignalType

Enumerator:
UsimPbIndication
UsimPbResponse
UsimPbRefresh
UsimPbRefRefresh

Function Documentation

const CHAR* GetUsimPbAddTypeName ( UsimPbAddType type )

const CHAR* GetUsimPbLinkTypeName ( UsimPbLinkType type )

const CHAR* GetUsimPbRefTypeName ( UsimPbRefType type )

Variable Documentation

const UINT8 c_no_aas_record_value = 0x00

const UINT8 c_no_group_value = 0x00

const INT c_pb_client_autoload_flag = PB_CLIENT_FLAG_AUTOLOAD

const INT c_pb_max_file_type_per_record = PB_MAX_FILE_TYPE_ENTITY

const INT c_pb_max_groups = PB_MAX_GROUP

const INT c_pb_max_slices = PB_MAX_SLICE

Generated on Tue Jan 24 17:10:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/UsimPbTypes.hpp Source File

Apc/UsimPbTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_UsimPbTypes_hpp)
00009 #define Apc_UsimPbTypes_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013
00014 #include <Apc/SignalTypes.hpp>
00015 #include <Auxiliary/BitField.hpp>
00016
00017 /*  ========================================================================
00018                     Simulated structures from stack
00019     ========================================================================*/
00020
00021 // define types if stack does not support necessary symbols, then fake it, at least for simulation
00022
00023 #if ! defined(PB_MAX_SLICE)
00024
00025 #define PB_MAX_SLICE            2
00026 #define PB_MAX_FILE_TYPE_ENTITY 10
00027 #define PB_MAX_GROUP            10
00028
00029 #define PB_CLIENT_FLAG_AUTOLOAD 0
00030
00031 typedef SDL_Integer PB_RESULT;
00032 #define PB_SUCCESSFUL         0
00033 #define PB_SUCCESSFUL_UID     1
00034 #define PB_SKIPPED            2
00035 #define PB_NO_FREE_RECORD     3
00036 #define PB_TO_FEW_FREE_EXT    4
00037 #define PB_BUFFER_IS_NULL     5
00038 #define PB_WRONG_REF_REC      6
00039 #define PB_DATA_TYPE_MISMATCH 7
00040 #define PB_WRONG_DATA_TYPE    8
00041 #define PB_WRONG_HANDLE       9
00042 #define PB_BUFFER_TO_SMALL    10
00043 #define PB_WRONG_REC_NUMBER   11
00044 #define PB_WRONG_STRUCTURE    12
00045 #define PB_NOT_LOCATED        13
00046 #define PB_NOT_SEL            14
00047 #define PB_NOT_EXIST          15
00048 #define PB_NOT_LOADED         16
00049 #define PB_WRONG_LOCATION     17
00050 #define PB_TECHNICAL_PROBLEM  18
00051
00052 typedef SDL_Integer T_PB_LOCATION;
00053 #define  PB_NOT_SELECTED    0
00054 #define  PB_SIM             1
00055 #define  PB_GLOBAL          2
00056 #define  PB_APPL            3
00057
00058 typedef SDL_Integer T_PB_DATA;
00059 #define  PB_AAS_DATA        0
00060 #define  PB_GAS_DATA        1
00061 #define  PB_CCP1_DATA       2
00062 #define  PB_EXT1_DATA       3
00063
00064 typedef SDL_Integer T_PB_REF;
00065 #define  PB_ANR_REF         0
00066 #define  PB_SNE_REF         1
00067 #define  PB_EMAIL_REF       2
00068
00069 typedef SDL_Integer T_PB_SIGNAL_TYPE;
00070 #define  PB_INDICATION      0
00071 #define  PB_RESPONSE        1
00072 #define  PB_REFRESH         2
00073 #define  PB_REF_REFRESH     3
00074
00075 typedef SDL_Integer T_PB_LINK_TYPE;
00076 #define  PB_LINK_TYPE_1     0
00077 #define  PB_LINK_TYPE_2     1
00078 #define  PB_LINK_TYPE_3     2
00079
00080 typedef struct {
00081     SDL_Boolean exist;
00082     SDL_Boolean last_used;
00083 } T_PB_STATE;
00084
00085 typedef struct {
00086     T_PB_LOCATION current_loc;
00087     T_PB_STATE sim;
00088     T_PB_STATE usim_global;
00089     T_PB_STATE usim_appl;
00090 } T_PB_LOC_REPORT;
00091
00092 typedef struct {
00093     byte    l_type; // T_PB_LINK_TYPE
00094     byte    handle;
00095     byte    nof_rec;
00096     byte    len_rec;
00097 }  T_PB_FILE_DESC;
00098
00099 typedef struct {
00100     T_PB_FILE_DESC  A[PB_MAX_FILE_TYPE_ENTITY];
00101 }  T_PB_FILE_IN_SLICE;
00102
00103 typedef struct {
00104     T_PB_FILE_DESC  A[PB_MAX_SLICE];
00105 }  T_PB_UNIQUE_FILE;
00106
00107 typedef struct {
00108     T_PB_FILE_IN_SLICE  A[PB_MAX_SLICE];
00109 }  T_PB_FILE_A;
00110
00111 typedef struct {
00112     byte  A[PB_MAX_SLICE];
00113 }  T_PB_GROUP_NUMBER;
00114
00115 typedef struct {
00116     word        nof_entity;
00117     T_PB_FILE_A a;
00118 }  T_PB_REF_FILE;
00119
00120
00121 typedef struct {
00122     byte                nof_slice;
00123     T_PB_UNIQUE_FILE    adn;
00124     T_PB_UNIQUE_FILE    gas;
00125     T_PB_UNIQUE_FILE    aas;
00126     T_PB_UNIQUE_FILE    ccp1;
00127
00128     T_PB_REF_FILE       anr;
00129     T_PB_REF_FILE       sne;
00130     T_PB_REF_FILE       email;
00131
00132     SDL_Boolean         hidden_key_supported;
00133     SDL_Boolean         sync_supported;
00134     T_PB_GROUP_NUMBER   nof_group;
00135
00136 }  T_PB_DESCRIPTOR;
00137
00138 typedef struct {
00139     byte  A[PB_MAX_FILE_TYPE_ENTITY];
00140 }  T_PB_REFERENCE;
00141
00142 typedef struct {
00143     byte  A[PB_MAX_GROUP];
00144 }  T_PB_GROUPING;
00145
00146 typedef struct {
00147     SDL_Boolean adn_core;
00148     SDL_Boolean grouping;
00149     SDL_Boolean pbc_hidden_info;
00150 }  T_PB_CHANGED_FIELD;
00151
00152 typedef struct {
00153    T_DATA           adn_core;
00154    T_PB_GROUPING    grouping;
00155    byte             pbc_hidden_info;
00156    word             uid;
00157     T_PB_CHANGED_FIELD refresh_info;
00158 }  T_PB_RECORD;
00159
00160 typedef struct {
00161     T_PB_REFERENCE  anr_ref;
00162     T_PB_REFERENCE  sne_ref;
00163     T_PB_REFERENCE  email_ref;
00164 }  T_PB_REF_RECORD;
00165
00166 typedef struct {
00167     byte    A[PB_MAX_SLICE];
00168 }  T_PB_UNIQUE_FILE_FILL_STATUS;
00169
00170 typedef struct {
00171     byte    A[PB_MAX_FILE_TYPE_ENTITY];
00172 }  T_PB_REF_FILE_FILL_STATUS_A;
00173
00174 typedef struct {
00175     T_PB_REF_FILE_FILL_STATUS_A A[PB_MAX_SLICE];
00176 }  T_PB_REF_FILE_FILL_STATUS;
00177
00178 typedef struct {
00179     T_PB_UNIQUE_FILE_FILL_STATUS    adn;
00180     T_PB_UNIQUE_FILE_FILL_STATUS    gas;
00181     T_PB_UNIQUE_FILE_FILL_STATUS    aas;
00182     T_PB_UNIQUE_FILE_FILL_STATUS    ccp1;
00183     T_PB_UNIQUE_FILE_FILL_STATUS    ext1;
00184     T_PB_REF_FILE_FILL_STATUS       anr;
00185     T_PB_REF_FILE_FILL_STATUS       sne;
00186     T_PB_REF_FILE_FILL_STATUS       email;
00187 }  T_PB_FILL_STATUS;
00188
00189 typedef struct {
00190     byte A[1];
00191 } T_PB_CLIENT_FLAGS;
00192
00193 #endif
00194
00195 /*  ========================================================================
00196                                   Constants
00197     ========================================================================*/
00198
00199 // defines the maximum number of EF-ADNs per Phonebook
00200 const INT c_pb_max_slices = PB_MAX_SLICE;
00201
00202 // defines the maximum number of linked entries per ADN record
00203 const INT c_pb_max_file_type_per_record = PB_MAX_FILE_TYPE_ENTITY;
00204
00205 // defines the maximum number of groups per ADN record
00206 const INT c_pb_max_groups = PB_MAX_GROUP;
00207
00208 // defines an invalid group value as defined in 3GPP
00209 const UINT8 c_no_group_value = 0x00;
00210
00211 // defines an invalid aas index value as defined in 3GPP
00212 const UINT8 c_no_aas_record_value = 0x00;
00213
00214 // defines the bit used for client auto loading
00215 const INT c_pb_client_autoload_flag = PB_CLIENT_FLAG_AUTOLOAD;
00216
00217
00218 /*  ========================================================================
00219                                   UsimPbResult
00220     ========================================================================*/
00221 // (ms.h: T_PB_SIGNAL_TYPE)
00223 enum UsimPbSignalType {
00225     UsimPbIndication = PB_INDICATION,
00227     UsimPbResponse = PB_RESPONSE,
00229     UsimPbRefresh = PB_REFRESH,
00231     UsimPbRefRefresh = PB_REF_REFRESH
00232 };
00233
00234 /*  ========================================================================
00235                                   UsimPbResult
00236     ========================================================================*/
00237 // (ms.h: PB_RESULT)
00239 enum UsimPbResult {
00241     UsimPbSuccessful = PB_SUCCESSFUL,
00243     UsimPbSuccessfulUid = PB_SUCCESSFUL_UID,
00245     UsimPbSkipped = PB_SKIPPED,
00247     UsimPbNoFreeRecord = PB_NO_FREE_RECORD,
00249     UsimPbTooFewExtRecs = PB_TO_FEW_FREE_EXT,
00251     UsimPbBufferIsNull = PB_BUFFER_IS_NULL,
00253     UsimPbWrongRefRecord = PB_WRONG_REF_REC,
00255     UsimPbDataTypeMismatch = PB_DATA_TYPE_MISMATCH,
00257     UsimPbWrongDataType = PB_WRONG_DATA_TYPE,
00259     UsimPbWrongHandle = PB_WRONG_HANDLE,
00261     UsimPbBufferTooSmall = PB_BUFFER_TO_SMALL,
00263     UsimPbWrongRecNumber = PB_WRONG_REC_NUMBER,
00265     UsimPbWrongStructure = PB_WRONG_STRUCTURE,
00267     UsimPbNotLocated = PB_NOT_LOCATED,
00269     UsimPbNotSel = PB_NOT_SEL,
00271     UsimPbNotExisting = PB_NOT_EXIST,
00273     UsimPbNotLoaded = PB_NOT_LOADED,
00275     UsimPbWrongLocation = PB_WRONG_LOCATION,
00277     UsimPbTechnicalProblem = PB_TECHNICAL_PROBLEM,
00279     UsimPbUndefined
00280 };
00281
00282 /*  ========================================================================
00283                                   UsimPbLocation
00284     ========================================================================*/
00285 // (ms.h: T_PB_LOCATION)
00287 enum UsimPbLocation {
00289     UsimPbNotSelected   = PB_NOT_SELECTED,
00291     UsimPbSim           = PB_SIM,
00293     UsimPbGlobal        = PB_GLOBAL,
00295     UsimPbApplication   = PB_APPL
00296 };
00297
00298
00299 /*  ========================================================================
00300                                   UsimPbAddType
00301     ========================================================================*/
00302 // (ms.h: T_PB_DATA)
00304 enum UsimPbAddType {
00306     UsimPbAas       = PB_AAS_DATA,
00308     UsimPbGas       = PB_GAS_DATA,
00310     UsimPbCcp1      = PB_CCP1_DATA,
00312     UsimPbExt1      = PB_EXT1_DATA,
00314     UsimPbInvalidAdd
00315 };
00316
00317 /*  ========================================================================
00318                                   UsimPbRefType
00319     ========================================================================*/
00320 // (ms.h: T_PB_REF_FILE)
00322 enum UsimPbRefType {
00324     UsimPbAnr       = PB_ANR_REF,
00326     UsimPbSne       = PB_SNE_REF,
00328     UsimPbEmail     = PB_EMAIL_REF,
00330     UsimPbInvalidRef
00331 };
00332
00333 /*  ========================================================================
00334                                   UsimPbLinkType
00335     ========================================================================*/
00336 // (ms.h: T_PB_LINK_TYPE)
00338 enum UsimPbLinkType {
00340     UsimPbType1     = PB_LINK_TYPE_1,
00342     UsimPbType2     = PB_LINK_TYPE_2,
00344     UsimPbType3     = PB_LINK_TYPE_3,
00345 };
00346
00347
00348 /*  ========================================================================
00349                              mapping of enums to chars
00350     ========================================================================*/
00351
00352 const CHAR * GetUsimPbRefTypeName(UsimPbRefType type);
00353 const CHAR * GetUsimPbAddTypeName(UsimPbAddType type);
00354 const CHAR * GetUsimPbLinkTypeName(UsimPbLinkType type);
00355
00356 /*  ========================================================================
00357                                   UsimPbRwRecord
00358     ========================================================================*/
00359 // (ms.h: T_PB_RECORD)
00361 class UsimPbRwRecord {
00362     public:
00363         // default constructor
00364         UsimPbRwRecord();
00365
00366         // buffer must be allocated and deleted outside
00367         UsimPbRwRecord(INT length, UINT8 * buffer,
00368                        INT grplength = 0, UINT8 * groupvector = 0,
00369                        UINT8 hiddeninfo = 0x00);
00370
00371         ~UsimPbRwRecord() {
00372             Clear();
00373         }
00374
00375         void Clear();
00376
00377         const UINT8 * GetAdnBuffer() const { return (UINT8*)m_record.adn_core.data_ptr; }
00378         const UINT8 * GetGroupVector() const { return &m_record.grouping.A[0]; }
00379         UINT8 GetHiddenInfo() const { return m_record.pbc_hidden_info; }
00380         UINT16 GetUid() const { return m_record.uid; }
00381
00382         T_PB_RECORD m_record;
00383 };
00384
00385 /*  ========================================================================
00386                                   UsimPbRefRecord
00387     ========================================================================*/
00388 // (ms.h: T_PB_REF_RECORD)
00390 class UsimPbRefRecord {
00391     public:
00392         UsimPbRefRecord();
00393
00394         UsimPbRefRecord(const T_PB_REF_RECORD & record) {
00395             m_record = record;
00396         };
00397
00398         UsimPbRefRecord & operator = (const UsimPbRefRecord & record) {
00399             if(&record != this) {
00400                 m_record = record.m_record;
00401             }
00402             return *this;
00403         }
00404
00405         void Clear();
00406
00407         UINT8 GetAnrRecordNo(UINT idx) const { return m_record.anr_ref.A[idx]; }
00408         UINT8 GetSneRecordNo(UINT idx) const { return m_record.sne_ref.A[idx]; }
00409         UINT8 GetEmailRecordNo(UINT idx) const { return m_record.email_ref.A[idx]; }
00410
00411         T_PB_REF_RECORD m_record;
00412 };
00413
00414 /*  ========================================================================
00415                                   UsimPbChangedField
00416     ========================================================================*/
00417 // (ms.h: T_PB_CHANGED_FIELD)
00419 class UsimPbChangedField {
00420     public:
00421         UsimPbChangedField();
00422
00423         UsimPbChangedField(const UsimPbChangedField & field) {
00424             m_field = field.m_field;
00425         };
00426
00427         UsimPbChangedField(BOOLEAN adn, BOOLEAN groups = FALSE, BOOLEAN hiddeninfo = FALSE);
00428
00429         UsimPbChangedField(const T_PB_CHANGED_FIELD & field) {
00430             m_field = field;
00431         };
00432
00433         UsimPbChangedField & operator = (const UsimPbChangedField & field) {
00434             if(&field != this) {
00435                 m_field = field.m_field;
00436             }
00437         }
00438
00439         void Clear();
00440
00441         void SetAdnChanged(BOOLEAN change = TRUE) { m_field.adn_core = change; }
00442         void SetGroupsChanged(BOOLEAN change = TRUE) { m_field.grouping = change; }
00443         void SetHiddenInfoChanged(BOOLEAN change = TRUE) { m_field.pbc_hidden_info = change; }
00444
00445         T_PB_CHANGED_FIELD m_field;
00446 };
00447
00448 /*  ========================================================================
00449                                   UsimPbGroups
00450     ========================================================================*/
00451 // (ms.h: T_PB_GROUPING)
00453 class UsimPbGroups {
00454     public:
00455         UsimPbGroups() { Clear(); }
00456
00457         UsimPbGroups(const UsimPbGroups & groups) {
00458             m_groups = groups.m_groups;
00459             m_set = groups.m_set;
00460         };
00461
00462         UsimPbGroups(const T_PB_GROUPING & groups) {
00463             m_groups = groups;
00464             m_set.Clear();
00465         };
00466
00467         UsimPbGroups & operator = (const UsimPbGroups & groups) {
00468             if(&groups != this) {
00469                 m_groups = groups.m_groups;
00470                 m_set = groups.m_set;
00471             }
00472         }
00473
00474         void Clear() {
00475             memset(&m_groups,c_no_group_value,sizeof(m_groups));
00476             m_set.Clear();
00477         }
00478
00479         void SetGroup(UINT idx, UINT8 group) {
00480             m_groups.A[idx] = group;
00481             m_set.SetTrue(idx);
00482         }
00483         UINT8 GetGroup(UINT idx) const {
00484             return m_groups.A[idx];
00485         }
00486         BOOLEAN WasChanged(UINT idx) const {
00487             return m_set.GetBit(idx);
00488         }
00489         BOOLEAN IsUsed() const {
00490             return m_set.Get()!=0;
00491         }
00492
00493         T_PB_GROUPING m_groups;
00494         BitField16    m_set;
00495 };
00496
00497 /*  ========================================================================
00498                                   UsimPbLocReport
00499     ========================================================================*/
00500 // (ms.h: T_PB_LOC_REPORT)
00502 class UsimPbLocReport {
00503     public:
00504         UsimPbLocReport() { Clear(); }
00505
00506         UsimPbLocReport & operator = (const UsimPbLocReport & location_info) {
00507             if(&location_info != this) {
00508                 m_location_info = location_info.m_location_info;
00509             }
00510             return *this;
00511         }
00512
00514         UsimPbLocation GetCurrentSelectedPb() const { return (UsimPbLocation)m_location_info.current_loc; }
00516         BOOLEAN IsSimPbExisting() const { return m_location_info.sim.exist; }
00518         BOOLEAN WasSimPbLastUsed() const { return m_location_info.sim.last_used; }
00520         BOOLEAN IsGlobalUsimPbExisting() const { return m_location_info.usim_global.exist; }
00522         BOOLEAN WasGlobalUsimPbLastUsed() const { return m_location_info.usim_global.last_used; }
00524         BOOLEAN IsApplUsimPbExisting() const { return m_location_info.usim_appl.exist; }
00526         BOOLEAN WasApplUsimPbLastUsed() const { return m_location_info.usim_appl.last_used; }
00527
00528         void Clear() {
00529             memset(&m_location_info,0x00,sizeof(m_location_info));
00530             m_location_info.current_loc = (T_PB_LOCATION)UsimPbNotSelected;
00531         }
00532
00533         T_PB_LOC_REPORT m_location_info;
00534 };
00535
00536 /*  ========================================================================
00537                                   UsimPbFillStatus
00538     ========================================================================*/
00539 // (ms.h: T_PB_FILL_STATUS)
00541 class UsimPbFillStatus {
00542     public:
00543         UsimPbFillStatus() { Clear(); }
00544
00545         UsimPbFillStatus & operator = (const UsimPbFillStatus & status) {
00546             if(&status != this) {
00547                 m_status = status.m_status;
00548             }
00549             return *this;
00550         }
00551         void Clear() {
00552             memset(&m_status,0x00,sizeof(m_status));
00553         }
00554
00555         T_PB_FILL_STATUS m_status;
00556 };
00557
00558 #endif  // Apc_UsimPbTypes_hpp
00559
00560
Generated on Tue Jan 24 14:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ValidityPeriod.cpp File Reference

Apc/ValidityPeriod.cpp File Reference

#include "Apc/PreComp.hpp"
#include "Apc/ValidityPeriod.hpp"

Include dependency graph for ValidityPeriod.cpp:

Generated on Tue Jan 24 17:10:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ValidityPeriod.hpp File Reference

Apc/ValidityPeriod.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Auxiliary/TimeSpan.hpp>

Include dependency graph for ValidityPeriod.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CodedTimeStamp
(ServiceCentreTimeStamp) 3GPP 23.040 V5.1.0 [9.2.3.11] - More...
class | FunctionalityIndicator
3GPP 23.040 V5.1.0 [9.2.3.12.3] More...
class | PackedTimePeriod
3GPP 23.040 V5.1.0 [9.2.3.12.1] More...
class | ValidityPeriod
class | ValidityPeriodFormat
3GPP 23.040 V5.1.0 [9.2.3.3] More...

Defines

#define | Apc_ValidityPeriod_hpp

Functions

INT | BcdByteToInt (UINT8 bcd)
UINT8 | IntToBcdByte (INT val)

Define Documentation

#define Apc_ValidityPeriod_hpp

Function Documentation

INT BcdByteToInt ( UINT8 bcd ) [inline]

UINT8 IntToBcdByte ( INT val ) [inline]

Generated on Tue Jan 24 17:10:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/ValidityPeriod.hpp Source File

Apc/ValidityPeriod.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_ValidityPeriod_hpp)
00009 #define Apc_ValidityPeriod_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/BitField.hpp>
00013 #include <Auxiliary/DateTime.hpp>
00014 #include <Auxiliary/TimeSpan.hpp>
00015
00016
00017 /*  ========================================================================
00018     CodedTimeStamp - (ServiceCentreTimeStamp) 3GPP 23.040 V5.1.0 [9.2.3.11]
00019     ======================================================================== */
00021 class CodedTimeStamp {
00022     public:
00024         CodedTimeStamp();
00026         CodedTimeStamp(const UINT8 *data, BOOLEAN time_only = FALSE);
00027
00029         DateTime GetAbsoluteDateTime() const;
00031         void SetAbsoluteDateTime(const DateTime &date_time);
00032
00034         TimeSpan GetRelativeTime() const;
00036         void SetRelativeTime(const TimeSpan &time_span);
00037
00039         INT GetTimeZone() const;
00041         void SetTimeZone(INT time_zone);
00042
00044         void UpdateData(UINT8 *data) const;
00045
00046     private:
00047         BOOLEAN m_time_only;
00048         UINT8 m_data[7];
00049 };
00050
00051
00052 /*  ========================================================================
00053     PackedTimePeriod - 3GPP 23.040 V5.1.0 [9.2.3.12.1]
00054     ======================================================================== */
00056 class PackedTimePeriod {
00057     public:
00059         enum Unit {
00061             FiveMinutes = 5,
00063             HalfHourAfter12 = 30,
00065             Day = 1440,
00067             Week = 10080,
00068         };
00069
00071         PackedTimePeriod(UINT8 code = 0);
00073         PackedTimePeriod(const TimeSpan &time_span);
00075         PackedTimePeriod(UINT8 times, Unit unit);
00076
00078         UINT8 GetTimes() const { return (m_times); }
00080         Unit GetUnit() const { return (m_unit); }
00081
00083         TimeSpan GetTimeSpan() const;
00085         UINT8 GetCode() const;
00086
00087     private:
00088         UINT8   m_times;
00089         Unit    m_unit;
00090 };
00091
00092
00093 /*  ========================================================================
00094     ValidityPeriodFormat - 3GPP 23.040 V5.1.0 [9.2.3.3]
00095     ======================================================================== */
00097 class ValidityPeriodFormat {
00098     public:
00100         enum Format { // do not change order
00102             NotPresent = 0,
00104             Enhanced,
00106             Relative,
00108             Absolute
00109
00110         };
00111
00113         ValidityPeriodFormat();
00115         ValidityPeriodFormat(Format format);
00117         ValidityPeriodFormat(UINT8 bit_field);
00118
00120         Format GetFormat() const;
00122         void SetFormat(Format format);
00123
00125         void UpdateData(UINT8 *data) const;
00126
00127     private:
00128         // bitmask for relevant data (00011000)
00129         static const UINT8 m_mask;
00130         // the format is stored within the bits 3 and 4 of one byte
00131         BitField8 m_bit_field;
00132 };
00133
00134 /*  ========================================================================
00135     FunctionalityIndicator - 3GPP 23.040 V5.1.0 [9.2.3.12.3]
00136     ======================================================================== */
00138 class FunctionalityIndicator {
00139     public:
00141         enum TimeFormat {   // do not change order
00143             Unspecified = 0,
00145             Packed,
00147             Seconds,
00149             Relative,
00151             ReservedTimeFormat,
00152         };
00153
00155         FunctionalityIndicator();
00157         FunctionalityIndicator(UINT8 incoming_byte);
00158
00160         UINT8 Get() const { return (m_bit_field.Get()); }
00161
00163         BOOLEAN ExtensionExists() const { return (m_bit_field.GetBit(7)); }
00165         void SetExtensionExists(BOOLEAN flag) { m_bit_field.SetBit(7, flag); }
00166
00168         BOOLEAN IsSingleShot() const { return (m_bit_field.GetBit(6)); }
00170         void SetSingleShot(BOOLEAN flag) { m_bit_field.SetBit(6, flag); }
00171
00173         TimeFormat GetTimeFormat() const;
00175         void SetTimeFormat(TimeFormat time_format);
00176
00178         void Clear() { m_bit_field.Clear(); }
00179
00180     private:
00181         BitField8 m_bit_field;
00182 };
00183
00184 /*  ========================================================================
00185     ValidityPeriod - 3GPP 23.040 V5.1.0 [9.2.3.12]
00186     ======================================================================== */
00190 class ValidityPeriod {
00191     public:
00193         ValidityPeriod();
00195         ValidityPeriod(const ValidityPeriodFormat &format, const UINT8 *data);
00197         ValidityPeriod(UINT8 data);
00198
00200         BOOLEAN IsInvalid() const;
00203         BOOLEAN IsPacked() const;
00207         BOOLEAN IsInSeconds() const;
00210         BOOLEAN IsRelative() const;
00213         BOOLEAN IsAbsolute() const;
00214
00216         BOOLEAN IsSingleShot() const;
00217
00219         PackedTimePeriod GetPackedTime() const;
00221         void SetPackedTime(const PackedTimePeriod &packed_time_period);
00222
00224         UINT8 GetSeconds() const;
00226         void SetSeconds(UINT8 seconds);
00227
00229         TimeSpan GetRelativeTime() const;
00231         void SetRelativeTime(const TimeSpan &time_span);
00232
00234         DateTime GetAbsoluteTime() const;
00236         INT GetTimeZone() const;
00238         void SetAbsolutTime(const DateTime &date_time, INT time_zone = 0);
00239
00241         UINT8 GetSize() const;
00243         void UpdateData(UINT8 *period_format_data, UINT8 *period_data) const;
00245         void UpdateData(UINT8 *period_data) const;
00246
00248         ValidityPeriodFormat GetFormat() { return (m_format); }
00249
00250     private:
00251         ValidityPeriodFormat m_format;
00252         UINT8 m_data[7];
00253
00254         FunctionalityIndicator GetFunctionalityIndicator() const;
00255 };
00256
00257
00258
00259 inline INT BcdByteToInt(UINT8 bcd) { return ((((INT)((bcd) & 0xf0) >> 4)) + (INT)((bcd) & 0x0f) * 10); };
00260 inline UINT8 IntToBcdByte(INT val) { INT tmp = (val / 10) & 0x0f; return ((UINT8) (tmp | ((((val - tmp * 10) & 0x0f) << 4) & 0xf0))); };
00261
00262
00263 #endif  // Apc_ValidityPeriod_hpp
00264
00265
Generated on Tue Jan 24 14:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/ApoxiApcSignalHandlerVersion.cpp File Reference

Apc/SignalHandler/ApoxiApcSignalHandlerVersion.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiApcSignalHandlerVersion.cpp:

Functions

ApoxiDefVersionInfo (ApcSignalHandler, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | ApcSignalHandler | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 16:58:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/AtcSignalProcessor.cpp File Reference

Apc/SignalHandler/AtcSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/AtcStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"
#include <Asc/AtcDispatcher.hpp>
#include <Adc/DataHandler.hpp>
#include <Asc/AtBaseManager.hpp>

Include dependency graph for AtcSignalProcessor.cpp:

Generated on Tue Jan 24 16:59:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/AtcStackMsgProcessor.cpp File Reference

Apc/SignalHandler/AtcStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/AtcStackMsgArgs.hpp>
#include <Auxiliary/AlphaCoding.hpp>
#include <Auxiliary/DbgDump.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for AtcStackMsgProcessor.cpp:

Generated on Tue Jan 24 16:59:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/AtKeyParser.cpp File Reference

Apc/SignalHandler/AtKeyParser.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Config/KeyboardConfig.hpp>
#include "AtKeyParser.hpp"
#include "KeyMsgGenerator.hpp"

Include dependency graph for AtKeyParser.cpp:

Functions

void TestAtKeyParser ()
Generated on Tue Jan 24 16:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/AtKeyParser.hpp File Reference

Apc/SignalHandler/AtKeyParser.hpp File Reference

#include <Apc/SignalHandler/KeyMsgGenerator.hpp>

Include dependency graph for AtKeyParser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtKeyParser

Defines

#define | Apc_SignalHandler_AtKeyParser_hpp

Functions

void | TestAtKeyParser ()

Define Documentation

#define Apc_SignalHandler_AtKeyParser_hpp

Generated on Tue Jan 24 16:59:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/AtKeyParser.hpp Source File

Apc/SignalHandler/AtKeyParser.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Apc_SignalHandler_AtKeyParser_hpp)
00015 #define Apc_SignalHandler_AtKeyParser_hpp
00018
00019 #include <Apc/SignalHandler/KeyMsgGenerator.hpp>
00020
00022 class AtKeyParser
00023 {
00024     public:
00026         AtKeyParser(INT length, UINT8 * key_string, INT time, INT pause);
00027
00029         ~AtKeyParser();
00030
00032         BOOLEAN GetFirstKey(KeyMsgGenerator::Key & key);
00033
00035         BOOLEAN GetNextKey(KeyMsgGenerator::Key & key);
00036
00037
00038     private:
00039         BOOLEAN GetKey(KeyMsgGenerator::Key & key);
00040
00041         INT     m_length;
00042         UINT8 * m_key_string;
00043         INT     m_time;
00044         INT     m_pause;
00045         INT     m_str_idx;
00046
00047 };
00048
00049 void TestAtKeyParser();
00050
00052 #endif
00053
00054
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/AtSignalProcessor.cpp File Reference

Apc/SignalHandler/AtSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/PowerStackMsgArgs.hpp>
#include <Apc/SignalHandler/AtKeyParser.hpp>
#include <Apc/SignalHandler/KeyMsgGenerator.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Kernel/RuntimeConfigurator.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for AtSignalProcessor.cpp:

Generated on Tue Jan 24 16:59:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/AudioSignalProcessor.cpp File Reference

Apc/SignalHandler/AudioSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Devices/Messages/AudioMsg.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for AudioSignalProcessor.cpp:

Generated on Tue Jan 24 16:59:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CallMiscSignalProcessor.cpp File Reference

Apc/SignalHandler/CallMiscSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Auxiliary/Conversion.hpp>
#include <Apc/CallMiscStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Asc/MainHandler.hpp>

Include dependency graph for CallMiscSignalProcessor.cpp:

Functions

void | PostMtcConfIndArg (Tipd tipd)
void | PostMtcSetupIndArg (CallIndArg *arg)

Function Documentation

void PostMtcConfIndArg ( Tipd tipd )

void PostMtcSetupIndArg ( CallIndArg * arg )

Generated on Tue Jan 24 16:59:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CallMiscStackMsgProcessor.cpp File Reference

Apc/SignalHandler/CallMiscStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Auxiliary/Conversion.hpp>
#include <Apc/CallMiscStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for CallMiscStackMsgProcessor.cpp:

Generated on Tue Jan 24 16:59:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CbsSignalProcessor.cpp File Reference

Apc/SignalHandler/CbsSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/CbsStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for CbsSignalProcessor.cpp:

Generated on Tue Jan 24 16:59:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CbsStackMsgProcessor.cpp File Reference

Apc/SignalHandler/CbsStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/CbsStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for CbsStackMsgProcessor.cpp:

Generated on Tue Jan 24 16:59:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/ChvSignalProcessor.cpp File Reference

Apc/SignalHandler/ChvSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/ChvStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for ChvSignalProcessor.cpp:

Generated on Tue Jan 24 16:59:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/ChvStackMsgProcessor.cpp File Reference

Apc/SignalHandler/ChvStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/ChvStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for ChvStackMsgProcessor.cpp:

Generated on Tue Jan 24 16:59:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonSignalMapTableNode.cpp File Reference

Apc/SignalHandler/CommonSignalMapTableNode.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "CommonSignalMapTableNode.hpp"
#include "CommonSignalProcessor.hpp"

Include dependency graph for CommonSignalMapTableNode.cpp:

Generated on Tue Jan 24 16:59:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonSignalMapTableNode.hpp File Reference

Apc/SignalHandler/CommonSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for CommonSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CommonSignalMapTableNode

Defines

#define | Apc_SignalHandler_CommonSignalMapTable_hpp

Define Documentation

#define Apc_SignalHandler_CommonSignalMapTable_hpp

Generated on Tue Jan 24 16:59:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonSignalMapTableNode.hpp Source File

Apc/SignalHandler/CommonSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_CommonSignalMapTable_hpp)
00009 #define Apc_SignalHandler_CommonSignalMapTable_hpp
00012
00013 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00014
00015 /*  ======================================================================
00016     CommonSignalMapTableNode
00017     ====================================================================== */
00018 class CommonSignalMapTableNode : public SignalMapTableNode {
00019     public:
00020         static CommonSignalMapTableNode* GetInstance();
00021
00022     private:
00023         static CommonSignalMapTableNode *m_node;
00024         static const SignalMapTableEntry m_map_table[];
00025
00026         CommonSignalMapTableNode();
00027 };
00028
00030 #endif  // Apc_SignalHandler_CommonSignalMapTable_hpp
00031
00032
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonSignalProcessor.hpp File Reference

Apc/SignalHandler/CommonSignalProcessor.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CommonSignalProcessor

Defines

#define | Apc_SignalHandler_CommonSignalProcessor_hpp

Define Documentation

#define Apc_SignalHandler_CommonSignalProcessor_hpp

Generated on Tue Jan 24 16:59:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonSignalProcessor.hpp Source File

Apc/SignalHandler/CommonSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_CommonSignalProcessor_hpp)
00009 #define Apc_SignalHandler_CommonSignalProcessor_hpp
00010
00013
00014 /*  ========================================================================
00015     CommonSignalProcessor
00016     ======================================================================== */
00020 class CommonSignalProcessor {
00021     public:
00022         /*  ================================================================
00023             AT handling
00024             ================================================================ */
00025         static void PostAtAlphaTagReq(const ProcessPtr &process_ptr);
00026         static void PostAtPbSelectReq(const ProcessPtr &process_ptr);
00027         static void PostAtPbListReq(const ProcessPtr &process_ptr);
00028         static void PostAtGenericCmdReq(const ProcessPtr &process_ptr);
00029         static void PostAtAccessoryRegisterReq(const ProcessPtr &process_ptr);
00030
00031         /*  ================================================================
00032             Atc signal-transformation
00033             ================================================================ */
00034         static void PostAtKeyReq(const ProcessPtr &process_ptr);
00035
00036     #if defined(APOXI_ENABLE_RUNTIME_CONFIGURATION)
00037         static void PostAtApoxiReq(const ProcessPtr &process_ptr);
00038     #endif
00039
00040         /*  ================================================================
00041             Audio
00042             ================================================================ */
00043         static void PostAudDriverRsp(const ProcessPtr &process_ptr);
00044
00045         /*  ================================================================
00046             CallMisc signal-transformation
00047             ================================================================ */
00048         static void PostCallProgressInd(const ProcessPtr &process_ptr);
00049         static void PostCallDiscInd(const ProcessPtr &process_ptr);
00050         static void PostCallRelCnf(const ProcessPtr &process_ptr);
00051         static void PostCallRelInd(const ProcessPtr &process_ptr);
00052 #if defined(APOXI_AT_MMI_INTERWORKING_CALL)
00053         static void PostCallInd(const ProcessPtr &process_ptr);
00054 #endif
00055         static void PostStartDtmfCnf(const ProcessPtr &process_ptr);
00056         static void PostStopDtmfCnf(const ProcessPtr &process_ptr);
00057         static void PostStartDtmfRej(const ProcessPtr &process_ptr);
00058         static void PostDtmfBufferClearedInd(const ProcessPtr &process_ptr);
00059         static void PostNotifyInd(const ProcessPtr &process_ptr);
00060 #if defined(APOXI_3GPP_REL_97_DOWNGRADE)
00061         static void PostCallDiscCnf(const ProcessPtr &process_ptr);
00062         static void PostNwDiscStartInd(const ProcessPtr &process_ptr);
00063 #endif
00064         static void PostDiagnosticInd(const ProcessPtr &process_ptr);
00065
00066 #if defined(APOXI_CTM)
00067         static void PostCtmInfoInd(const ProcessPtr &process_ptr);
00068 #endif
00069         static void PostRedialStatusInd(const ProcessPtr &process_ptr);
00070         static void PostRedialQueryInd(const ProcessPtr &process_ptr);
00071 #if defined(APOXI_AT_MMI_INTERWORKING_SIMTK)
00072         static void PostCallIndCallControlInfo(const ProcessPtr &process_ptr);
00073 #endif
00074 #if defined(APOXI_AT_MMI_INTERWORKING_REJECT)
00075         static void PostMocSetupRejIndArg(const ProcessPtr &process_ptr);
00076 #endif
00077
00078         /*  ================================================================
00079             Cbs signal-transformation
00080             ================================================================ */
00081         static void PostCbsNewDataInd(const ProcessPtr &process_ptr);
00082         static void PostCbsStartRej(const ProcessPtr &process_ptr);
00083         static void PostCbsStopRej(const ProcessPtr &process_ptr);
00084         static void PostCbsStartCnf(const ProcessPtr &process_ptr);
00085         static void PostCbsStopCnf(const ProcessPtr &process_ptr);
00086         static void PostCbsLimitInd(const ProcessPtr &process_ptr);
00087
00088         /*  ================================================================
00089             CFU
00090             ================================================================ */
00091         static void PostCfuDataInd(const ProcessPtr &process_ptr);
00092
00093         /*  ================================================================
00094             Network Eccs
00095             ================================================================ */
00096         static void PostEccListInd(const ProcessPtr &process_ptr);
00097
00098         /*  ================================================================
00099             Chv signal-transformation
00100             ================================================================ */
00101         static void PostChvVerifyInd(const ProcessPtr &process_ptr);
00102         static void PostChvChangeInd(const ProcessPtr &process_ptr);
00103         static void PostChvUnblockInd(const ProcessPtr &process_ptr);
00104         static void PostPinEnableInd(const ProcessPtr &process_ptr);
00105         static void PostPinDisableInd(const ProcessPtr &process_ptr);
00106
00107         /*  ================================================================
00108             Crss signal-transformation
00109             ================================================================ */
00110         static void PostCallRelatedSsCnf(const ProcessPtr &process_ptr);
00111         static void PostCallRelatedSsRej(const ProcessPtr &process_ptr);
00112         static void PostCallHoldRej(const ProcessPtr &process_ptr);
00113         static void PostCallHoldCnf(const ProcessPtr &process_ptr);
00114         static void PostMptyCnf(const ProcessPtr &process_ptr);
00115         static void PostEctCnf(const ProcessPtr &process_ptr);
00116         static void PostAocInd(const ProcessPtr &process_ptr);
00117         static void PostChargeInd(const ProcessPtr &process_ptr);
00118         static void PostCallDeflectionInd(const ProcessPtr &process_ptr);//Manik added for CD 07-August-2003
00119         static void PostChargeUnitsInd(const ProcessPtr &process_ptr);
00120
00121         /*  ================================================================
00122             Image signal-transformation
00123             ================================================================ */
00124         static void PostIconDescReadInd(const ProcessPtr &process_ptr);
00125         static void PostImageReadInd(const ProcessPtr &process_ptr);
00126
00127         /*  ================================================================
00128             Mdh signal-transformation
00129             ================================================================ */
00130         static void PostMdhSmsInitFinishedInd(const ProcessPtr &process_ptr);
00131         static void PostMdhDeregistrationCnf(const ProcessPtr &process_ptr);
00132         static void PostMdhMakeViewCnf(const ProcessPtr &process_ptr);
00133         static void PostMdhNewMessageInd(const ProcessPtr &process_ptr);
00134         static void PostMdhNewStatusReportInd(const ProcessPtr &process_ptr);
00135         static void PostMdhRegistrationCnf(const ProcessPtr &process_ptr);
00136         static void PostMdhRemoveViewCnf(const ProcessPtr &process_ptr);
00137         static void PostMdhSetConfigCnf(const ProcessPtr &proess_ptr);
00138         static void PostMdhSetStorageCnf(const ProcessPtr &process_ptr);
00139         static void PostMdhSmsReadInd(const ProcessPtr &process_ptr);
00140         static void PostMdhSmsStatusInd(const ProcessPtr &process_ptr);
00141         static void PostMdhSmsUpdStatusInd(const ProcessPtr &process_ptr);
00142         static void PostMdhSmsWriteCnf(const ProcessPtr &process_ptr);
00143         static void PostMdhSmsRefreshInd(const ProcessPtr &process_ptr);
00144         static void PostMdhSmsStorageRefreshInd(const ProcessPtr &process_ptr);
00145         static void PostMdhSmsUpdStatusRefreshInd(const ProcessPtr &process_ptr);
00146         static void PostMdhSmsWaitingInd(const ProcessPtr &process_ptr);
00147         static void PostMdhSmsTransmitStartInd(const ProcessPtr &process_ptr);
00148         static void PostMdhSmsTransmitInd(const ProcessPtr &process_ptr);
00149         static void PostMdhSmsTransmitStopInd(const ProcessPtr &process_ptr);
00150         static void PostMdhSmsReportReadInd(const ProcessPtr &process_ptr);
00151         static void PostMdhSmsDeletionInd(const ProcessPtr &process_ptr);
00152         static void PostMdhSmsConcRefNumInd(const ProcessPtr &process_ptr);
00153         static void PostMdhSmsExtendedDataInd(const ProcessPtr &process_ptr);
00154
00155         /*  ================================================================
00156             Misc signal-transformation
00157             ================================================================ */
00158         static void PostKbdtControl(const ProcessPtr &process_ptr);
00159         static void PostSignalStrengthLevelInd(const ProcessPtr &process_ptr);
00160         static void PostUrrcSignalStrengthLevelInd(const ProcessPtr &process_ptr);
00161         static void PostImeiReadInd(const ProcessPtr &process_ptr);
00162         static void PostGetTermProfileCnfInd(const ProcessPtr &process_ptr);
00163         static void PostSetTermProfileCnfInd(const ProcessPtr &process_ptr);
00164         static void PostSetTermProfileRejInd(const ProcessPtr &process_ptr);
00165
00166         /*  ================================================================
00167             Moc signal-transformation
00168             ================================================================ */
00169         static void PostMocSetupRej(const ProcessPtr &process_ptr);
00170         static void PostMocSetupAcc(const ProcessPtr &process_ptr);
00171         static void PostMocAlertInd(const ProcessPtr &process_ptr);
00172         static void PostMocSetupCnf(const ProcessPtr &process_ptr);
00173         static void PostRedialInd(const ProcessPtr &process_ptr);
00174         static void PostRedialSetupInd(const ProcessPtr &process_ptr);
00175         static void PostRedialStopInd(const ProcessPtr &process_ptr);
00176         static void PostAutoCallRestrictInd(const ProcessPtr &process_ptr);
00177         static void PostClearBlacklistCnf(const ProcessPtr &process_ptr);
00178
00179         /*  ================================================================
00180             Mtc signal-transformation
00181             ================================================================ */
00182         static void PostMtcAcceptRej(const ProcessPtr &process_ptr);
00183         static void PostMtcConfInd(const ProcessPtr &process_ptr);
00184         static void PostMtcSetupInd(const ProcessPtr &process_ptr);
00185         static void PostMtcSetupCompl(const ProcessPtr &process_ptr);
00186
00187         /*  ================================================================
00188             Network signal-transformation
00189             ================================================================ */
00190         static void PostConnectionInd(const ProcessPtr &process_ptr);
00191         static void PostCellInfoInd(const ProcessPtr &process_ptr);
00192         static void PostHomezoneInd(const ProcessPtr &process_ptr);
00193         static void PostMnInformationInd(const ProcessPtr &process_ptr);
00194         static void PostEngineeringModeControlResponse(const ProcessPtr &process_ptr);
00195         static void PostTestparamInd(const ProcessPtr &process_ptr);
00196         static void PostBandCnf(const ProcessPtr &process_ptr);
00197         static void PostBandRej(const ProcessPtr &process_ptr);
00198
00199         /*  ================================================================
00200             Om signal-transformation
00201             ================================================================ */
00202         static void PostOmMultiSlotCnf(const ProcessPtr &process_ptr);
00203         static void PostOmMultiSlotRej(const ProcessPtr &process_ptr);
00204         static void PostOmBandStatusCnf(const ProcessPtr &process_ptr);
00205
00206         /*  ================================================================
00207             PhoneBook signal-transformation
00208             ================================================================ */
00209         static void PostPbEntryReadInd(const ProcessPtr &process_ptr);
00210         static void PostPbEntryUpdInd(const ProcessPtr &process_ptr);
00211         static void PostPbInfoReadInd(const ProcessPtr &process_ptr);
00212         static void PostFdnInd(const ProcessPtr &process_ptr);
00213         static void PostBdnInd(const ProcessPtr &process_ptr);
00214         static void PostPbCountInd(const ProcessPtr &process_ptr);
00215
00216         /*  ================================================================
00217             Plmn signal-transformation
00218             ================================================================ */
00219         static void PostPlmnListCnf(const ProcessPtr &process_ptr);
00220         static void PostPlmnListRej(const ProcessPtr &process_ptr);
00221         static void PostOmRatChangeCnf(const ProcessPtr &process_ptr);
00222         static void PostOmRatChangeInd(const ProcessPtr &process_ptr);
00223         static void PostNRegStateInd(const ProcessPtr &process_ptr);
00224         static void PostRegStateInd(const ProcessPtr &process_ptr);
00225         static void PostAttachCnf(const ProcessPtr &process_ptr);
00226         static void PostAttachRej(const ProcessPtr &process_ptr);
00227         static void PostAttachAllowedInd(const ProcessPtr &process_ptr);
00228         static void PostDetachCnf(const ProcessPtr &process_ptr);
00229         static void PostGprsClassInd(const ProcessPtr &process_ptr);
00230
00231         /*  ================================================================
00232             Plmn inside imsi sending
00233             ================================================================ */
00234         static void PostSimMccMncInd(const ProcessPtr &process_ptr);
00235
00236         /*  ================================================================
00237             Power signal-transformation
00238             ================================================================ */
00239         static void PostPowerDownCnf(const ProcessPtr &process_ptr);
00240         static void PostOmControlInd(const ProcessPtr &process_ptr);
00241         static void PostPowerDownInd(const ProcessPtr &process_ptr);
00242
00243         /*  ================================================================
00244             PrefPlmn signal-transformation
00245             ================================================================ */
00246 //      static void PostPrefPlmnUpdInd(const ProcessPtr &process_ptr);
00247 //      static void PostPrefPlmnReadInd(const ProcessPtr &process_ptr);
00248
00249         /*  ================================================================
00250             SimMisc signal-transformation
00251             ================================================================ */
00252         static void PostSimErrorInd(const ProcessPtr &process_ptr);
00253         static void PostSstReadInd(const ProcessPtr &process_ptr);
00254         static void PostSimGenericInd(const ProcessPtr &process_ptr);
00255         static void PostAcmReadInd(const ProcessPtr &process_ptr);
00256         static void PostAcmUpdInd(const ProcessPtr &process_ptr);
00257         static void PostAcmMaxReadInd(const ProcessPtr &process_ptr);
00258         static void PostAcmMaxUpdInd(const ProcessPtr &process_ptr);
00259
00260         static void PostCbmiReadInd(const ProcessPtr &process_ptr);
00261         static void PostCbmirReadInd(const ProcessPtr &process_ptr);
00262         static void PostCbmiUpdInd(const ProcessPtr &process_ptr);
00263         static void PostCbmirUpdInd(const ProcessPtr &process_ptr);
00264
00265         static void PostPuctReadInd(const ProcessPtr &process_ptr);
00266         static void PostPuctUpdInd(const ProcessPtr &process_ptr);
00267         static void PostPrefLangReadInd(const ProcessPtr &process_ptr);
00268         static void PostPrefLangUpdInd(const ProcessPtr &process_ptr);
00269         static void PostPrefExtLangReadInd(const ProcessPtr &process_ptr);
00270         static void PostPrefExtLangUpdInd(const ProcessPtr &process_ptr);
00271         static void PostSpnReadInd(const ProcessPtr &process_ptr);
00272         static void PostSimFileInfoInd(const ProcessPtr &process_ptr);
00273
00274         static void PostCphsIstReadInd(const ProcessPtr &process_ptr);
00275         static void PostCphsVmwfReadInd(const ProcessPtr &process_ptr);
00276         static void PostCphsVmwfUpdInd(const ProcessPtr &process_ptr);
00277         static void PostCphsCfufReadInd(const ProcessPtr &process_ptr);
00278         static void PostCphsCfufUpdInd(const ProcessPtr &process_ptr);
00279         static void PostCphsOnmReadInd(const ProcessPtr &process_ptr);
00280         static void PostCphsOnsReadInd(const ProcessPtr &process_ptr);
00281         static void PostCphsCspReadInd(const ProcessPtr &process_ptr);
00282         static void PostCphsCspUpdInd(const ProcessPtr &process_ptr);
00283
00284         static void PostODynReadInd(const ProcessPtr &process_ptr);
00285         static void PostODyn2ReadInd(const ProcessPtr &process_ptr);
00286         static void PostODynUpdInd(const ProcessPtr &process_ptr);
00287         static void PostODyn2UpdInd(const ProcessPtr &process_ptr);
00288         static void PostSimMruPropertyUpdCnf(const ProcessPtr &process_ptr);
00289         static void PostSimMruPropertyRefreshInd(const ProcessPtr &process_ptr);
00290
00291         static void PostCcpReadInd(const ProcessPtr &process_ptr);
00292         static void PostCcpUpdInd(const ProcessPtr &process_ptr);
00293
00294         static void PostSmsrReadInd(const ProcessPtr &process_ptr);
00295         static void PostSmsrUpdInd(const ProcessPtr &process_ptr);
00296         static void PostCmiReadInd(const ProcessPtr &process_ptr);
00297
00298         static void PostChv1EnableInd(const ProcessPtr &process_ptr);
00299         static void PostChv1DisableInd(const ProcessPtr &process_ptr);
00300         static void PostChvRefreshInd(const ProcessPtr &process_ptr);
00301         static void PostSimFullAccessInd(const ProcessPtr &process_ptr);
00302         static void PostSimInfoInd(const ProcessPtr &process_ptr);
00303         static void PostSimInitInd(const ProcessPtr &process_ptr);
00304         static void PostSimLockStatusInd(const ProcessPtr &process_ptr);
00305         static void PostSimModifyLockInd(const ProcessPtr &process_ptr);
00306         static void PostSimRefreshInd(const ProcessPtr &process_ptr);
00307
00308         /*  ================================================================
00309             Sms signal-transformation
00310             ================================================================ */
00311         static void PostSmsCapacityExceeded(const ProcessPtr &process_ptr);
00312         static void PostSmsCapacityAvailable(const ProcessPtr &process_ptr);
00313         static void PostSmsSendCnf(const ProcessPtr &process_ptr);
00314         static void PostSmsSendRej(const ProcessPtr &process_ptr);
00315         static void PostSmsGetMoreMessageStatusInd(const ProcessPtr &process_ptr);
00316
00317         /*  ================================================================
00318             Ss signal-transformation
00319             ================================================================ */
00320         static void PostSsBeginAcc(const ProcessPtr &process_ptr);
00321         static void PostSsFacilityRej(const ProcessPtr &process_ptr);
00322         static void PostSsForwardingInd(const ProcessPtr &process_ptr);
00323         static void PostSsBarringInd(const ProcessPtr &process_ptr);
00324         static void PostSsDataInd(const ProcessPtr &process_ptr);
00325         static void PostSsNotifyInd(const ProcessPtr &process_ptr);
00326         static void PostSsInterrogateInd(const ProcessPtr &process_ptr);
00327         static void PostSsPasswordInd(const ProcessPtr &process_ptr);
00328         static void PostSsUnstructInd(const ProcessPtr &process_ptr);
00329         static void PostSsForwcheckInd(const ProcessPtr &process_ptr);
00330         static void PostSsRetResInd(const ProcessPtr &process_ptr);
00331         static void PostSsEndInd(const ProcessPtr &process_ptr);
00332         static void PostSsRej(const ProcessPtr &process_ptr);
00333         static void PostSsErrInd(const ProcessPtr &process_ptr);
00334         static void PostSsGetPasswordInd(const ProcessPtr &process_ptr);
00335         static void PostSsGetPasswordRej(const ProcessPtr &process_ptr);
00336         static void PostSsUssdInd(const ProcessPtr &process_ptr);
00337         static void PostSsUssdResentInd(const ProcessPtr &process_ptr);
00338         static void PostSsCauseInd(const ProcessPtr &process_ptr);
00339 #if defined(APOXI_AT_MMI_INTERWORKING_USSD)
00340         static void PostUssdAnswerInd(const ProcessPtr &process_ptr);
00341 #endif
00342 #if defined(APOXI_AT_MMI_INTERWORKING_SS)
00343         static void PostSsFacilityInd(const ProcessPtr &process_ptr);
00344 #endif
00345         static void PostSsCcbsReCallInd(const ProcessPtr &process_ptr);
00346         static void PostSsClientRej(const ProcessPtr &process_ptr);
00347         static void PostSsCcbsResultInd(const ProcessPtr &process_ptr);
00348         static void PostSsCcbsStatusInd(const ProcessPtr &process_ptr);
00349
00350         /*  ================================================================
00351             SimTk signal-transformation
00352             ================================================================ */
00353         static void PostSimTkRefreshReq(const ProcessPtr &process_ptr);
00354         static void PostSimTkRefreshNewReq(const ProcessPtr &process_ptr);
00355         static void PostSimTkRefreshResetReq(const ProcessPtr &process_ptr);
00356         static void PostSimTkResetCnfReq(const ProcessPtr &process_ptr);
00357         static void PostSimTkResetCnf(const ProcessPtr &process_ptr);
00358         static void PostSimTkRefreshQueryReq(const ProcessPtr &process_ptr);
00359         static void PostSimTkRefreshCnfReq(const ProcessPtr &process_ptr);
00360
00361         static void PostDisplayTextReq(const ProcessPtr &process_ptr);
00362         static void PostGetInputReq(const ProcessPtr &process_ptr);
00363         static void PostGetInkeyReq(const ProcessPtr &process_ptr);
00364         static void PostSelectItemReq(const ProcessPtr &process_ptr);
00365         static void PostSetupMenuReq(const ProcessPtr &process_ptr);
00366         static void PostMenuSelectionRej(const ProcessPtr &process_ptr);
00367         static void PostPlayToneReq(const ProcessPtr &process_ptr);
00368         static void PostSetupIdleModeTextReq(const ProcessPtr &process_ptr);
00369         static void PostEndSimToolkitInd(const ProcessPtr &process_ptr);
00370         static void PostLanguageNotificationInd(const ProcessPtr &process_ptr);
00371         static void PostSetupEventReq(const ProcessPtr &process_ptr);
00372         static void PostLanguageSettingReq(const ProcessPtr &process_ptr);
00373
00374         static void PostExtProactiveCmdInd(const ProcessPtr &process_ptr);
00375
00376         static void PostTermRspCnf(const ProcessPtr &process_ptr);
00377
00378         static void PostLaunchBrowserReq(const ProcessPtr &process_ptr);
00379         static void PostLaunchBrowserPromptReq(const ProcessPtr &process_ptr);
00380         static void PostBrowserTermRes(const ProcessPtr &process_ptr);
00381
00382         static void PostSimTkRunAtCmdInfoInd(const ProcessPtr &process_ptr);
00383
00384         static void PostSimTkSendDtmfInd(const ProcessPtr &process_ptr);
00385         static void PostSimTkSendDtmfEndInd(const ProcessPtr &process_ptr);
00386
00387         static void PostSimTkInterfaceInd(const ProcessPtr &process_ptr);
00388         static void PostSimTkCallSetupInd(const ProcessPtr &process_ptr);
00389         static void PostSimTkSmsPpInd(const ProcessPtr &process_ptr);
00390         static void PostSimTkSsInd(const ProcessPtr &process_ptr);
00391
00392         /*  ================================================================
00393             SimTk call control signal-transformation
00394             ================================================================ */
00395         static void PostCallControlSetupInd(const ProcessPtr &process_ptr);
00396         static void PostCallControlSsInd(const ProcessPtr &process_ptr);
00397         static void PostCallControlUssdInd(const ProcessPtr &process_ptr);
00398         static void PostSmsControlInd(const ProcessPtr &process_ptr);
00399
00400         /*  ================================================================
00401             USIMAP
00402             ================================================================ */
00403 #if defined(APOXI_ICC_USIM)
00404         static void PostUsimReadRej(const ProcessPtr &process_ptr);
00405         static void PostUsimReadRecordRej(const ProcessPtr &process_ptr);
00406         static void PostUsimUpdCnfArg(const ProcessPtr &process_ptr);
00407         static void PostUsimUpdRejArg(const ProcessPtr &process_ptr);
00408
00409         static void PostUsimUstReadInd(const ProcessPtr &process_ptr);
00410         static void PostUsimEstReadInd(const ProcessPtr &process_ptr);
00411         static void PostUsimCsLociReadInd(const ProcessPtr &process_ptr);
00412         static void PostUsimPsLociReadInd(const ProcessPtr &process_ptr);
00413         static void PostUsimPlmnReadInd(const ProcessPtr &process_ptr);
00414         static void PostUsimLangReadInd(const ProcessPtr &process_ptr);
00415         static void PostUsimEccReadInd(const ProcessPtr &process_ptr);
00416         static void PostUsimSmsParamReadInd(const ProcessPtr &process_ptr);
00417         static void PostUsimSmsParamExtInd(const ProcessPtr &process_ptr);
00418         static void PostUsimCardTypeReadInd(const ProcessPtr &process_ptr);
00419
00420         static void PostUsimSmsParamUpdInd(const ProcessPtr &process_ptr);
00421         static void PostUsimFilePropertyInd(const ProcessPtr &process_ptr);
00422 #endif
00423
00424         /*  ================================================================
00425             USIM phonebook
00426             ================================================================ */
00427 #if defined(APOXI_ENABLE_USIM_PHONEBOOK) && ! defined(APOXI_USIM_PB_SIMULATION)
00428         static void PostUsimPbLocationInd(const ProcessPtr &process_ptr);
00429         static void PostUsimPbSelectRes(const ProcessPtr &process_ptr);
00430         static void PostUsimPbReadRes(const ProcessPtr &process_ptr);
00431         static void PostUsimPbReadRefRes(const ProcessPtr &process_ptr);
00432         static void PostUsimPbReadDataRes(const ProcessPtr &process_ptr);
00433         static void PostUsimPbUpdRes(const ProcessPtr &process_ptr);
00434         static void PostUsimPbUpdRefRes(const ProcessPtr &process_ptr);
00435         static void PostUsimPbUpdDataRes(const ProcessPtr &process_ptr);
00436         static void PostUsimPbFillStatusRes(const ProcessPtr &process_ptr);
00437         static void PostUsimPbStopRes(const ProcessPtr &process_ptr);
00438         static void PostUsimPbUidRefreshInd(const ProcessPtr &process_ptr);
00439         static void PostUsimPbReadyInd(const ProcessPtr &process_ptr);
00440 #endif
00441
00442 #ifdef APOXI_LETTERCLASSE_SUPPORT
00443         /*  ================================================================
00444             SimTk Letter Class E (Sim to Proactive Client)
00445             ================================================================ */
00446         static void PostSiChannelOpenPromptReq(const ProcessPtr &process_ptr);
00447         static void PostSiChannelCloseInfoInd(const ProcessPtr &process_ptr);
00448         static void PostSiChannelSendInfoInd(const ProcessPtr &process_ptr);
00449         static void PostSiChannelReceiveInfoInd(const ProcessPtr &process_ptr);
00450
00451         /*  ================================================================
00452             SimTk Letter Class E (Sim to IP-Stack)
00453             ================================================================ */
00454         static void PostDhChannelOpenReq(const ProcessPtr &process_ptr);
00455         static void PostDhChannelCloseReq(const ProcessPtr &process_ptr);
00456         static void PostDhChannelSendReq(const ProcessPtr &process_ptr);
00457         static void PostDhChannelDataAvailableRes(const ProcessPtr &process_ptr);
00458         static void PostDhChannelReceiveReq(const ProcessPtr &process_ptr);
00459         static void PostDhChannelChangeStatusRes(const ProcessPtr &process_ptr);
00460 #endif  // APOXI_LETTERCLASSE_SUPPORT
00461
00462 #ifdef APOXI_UUS_SUPPORT
00463
00464         /*  ================================================================
00465             User-to-User-Signaling (UUS)
00466             ================================================================ */
00467         static void PostUus1Ind(const ProcessPtr &process_ptr);
00468         static void PostUus1QueryInd(const ProcessPtr &process_ptr);
00469         static void PostUus1QueryRej(const ProcessPtr &process_ptr);
00470 #endif
00471     private:
00472         static Ticks m_duration;
00473         static KeyCode m_keycode;
00474
00475 };
00476
00478 #endif  // Apc_SignalHandler_CommonSignalProcessor_hpp
00479
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonStackMsgMapTableNode.cpp File Reference

Apc/SignalHandler/CommonStackMsgMapTableNode.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "CommonStackMsgMapTableNode.hpp"
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for CommonStackMsgMapTableNode.cpp:

Generated on Tue Jan 24 17:00:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonStackMsgMapTableNode.hpp File Reference

Apc/SignalHandler/CommonStackMsgMapTableNode.hpp File Reference

#include <Apc/SignalHandler/StackMsgMapTableNode.hpp>

Include dependency graph for CommonStackMsgMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CommonStackMsgMapTableNode

Defines

#define | Apc_SignalHandler_CommonStackMsgMapTable_hpp

Define Documentation

#define Apc_SignalHandler_CommonStackMsgMapTable_hpp

Generated on Tue Jan 24 17:00:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonStackMsgMapTableNode.hpp Source File

Apc/SignalHandler/CommonStackMsgMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_CommonStackMsgMapTable_hpp)
00009 #define Apc_SignalHandler_CommonStackMsgMapTable_hpp
00012
00013 #include <Apc/SignalHandler/StackMsgMapTableNode.hpp>
00014
00015 /*  ======================================================================
00016     CommonStackMsgMapTableNode
00017     ====================================================================== */
00018 class CommonStackMsgMapTableNode : public StackMsgMapTableNode {
00019     public:
00020         static CommonStackMsgMapTableNode* GetInstance();
00021
00022     private:
00023         static CommonStackMsgMapTableNode *m_node;
00024         static const StackMsgMapTableEntry m_map_table[];
00025
00026         CommonStackMsgMapTableNode();
00027 };
00028
00030 #endif  // Apc_SignalHandler_CommonStackMsgMapTable_hpp
00031
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonStackMsgProcessor.hpp File Reference

Apc/SignalHandler/CommonStackMsgProcessor.hpp File Reference

#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for CommonStackMsgProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CommonStackMsgProcessor

Defines

#define | Apc_SignalHandler_CommonStackMsgProcessor_hpp

Define Documentation

#define Apc_SignalHandler_CommonStackMsgProcessor_hpp

Generated on Tue Jan 24 17:00:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CommonStackMsgProcessor.hpp Source File

Apc/SignalHandler/CommonStackMsgProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_CommonStackMsgProcessor_hpp)
00009 #define Apc_SignalHandler_CommonStackMsgProcessor_hpp
00012
00013 #include <Apc/SignalHandler/StackMsgProcessor.hpp>
00014
00015 class StackMsgArgument;
00016
00017 /*  ========================================================================
00018     CommonStackMsgProcessor
00019     ======================================================================== */
00023 class CommonStackMsgProcessor : public StackMsgProcessor {
00024     public:
00025         /*  ================================================================
00026             AT confirmations
00027             ================================================================ */
00028         static void ProcessAtAlphaTagCnf(const StackMsgArgument &arg);
00029         static void ProcessAtPbSelectCnf(const StackMsgArgument &arg);
00030         static void ProcessAtPbListCnf(const StackMsgArgument &arg);
00031         static void ProcessAtPbInfoInd(const StackMsgArgument &arg);
00032         static void ProcessAtGenericCmdInd(const StackMsgArgument & arg);
00033         static void ProcessAtAccessoryNotificationInd(const StackMsgArgument &arg);
00034         static void ProcessAtAccessoryRegisterCnf(const StackMsgArgument &arg);
00035
00036         /*  ================================================================
00037             CallMisc argument-transformation
00038             ================================================================ */
00039         static void ProcessCallDiscReq(const StackMsgArgument &arg);
00040         static void ProcessStartDtmfReq(const StackMsgArgument &arg);
00041         static void ProcessStopDtmfReq(const StackMsgArgument &arg);
00042         static void ProcessRejectCallsInd(const StackMsgArgument &arg);
00043         static void ProcessRedialingQueryReq(const StackMsgArgument &arg);
00044
00045         /*  ================================================================
00046             Cbs argument-transformation
00047             ================================================================ */
00048         static void ProcessCbsStartReq(const StackMsgArgument &arg);
00049         static void ProcessCbsNewDataRej(const StackMsgArgument &arg);
00050         static void ProcessCbsStopReq(const StackMsgArgument &arg);
00051
00052         /*  ================================================================
00053             Chv argument-transformation
00054             ================================================================ */
00055         static void ProcessChvVerifyReq(const StackMsgArgument &arg);
00056         static void ProcessChvChangeReq(const StackMsgArgument &arg);
00057         static void ProcessChvUnblockReq(const StackMsgArgument &arg);
00058         static void ProcessChv1EnableReq(const StackMsgArgument &arg);
00059         static void ProcessChv1DisableReq(const StackMsgArgument &arg);
00060         static void ProcessPinEnableReq(const StackMsgArgument &arg);
00061         static void ProcessPinDisableReq(const StackMsgArgument &arg);
00062
00063
00064         /*  ================================================================
00065             Crss argument-transformation
00066             ================================================================ */
00067         static void ProcessCallRelatedSsReq(const StackMsgArgument &arg);
00068         static void ProcessCallDeflectSsReq(const StackMsgArgument &arg);
00069         static void ProcessSetAutoCharge(const StackMsgArgument &arg);
00070         static void ProcessChargeReq(const StackMsgArgument &arg);
00071         static void ProcessSetChargeUnits(const StackMsgArgument &arg);
00072         static void ProcessChargeUnitsReq(const StackMsgArgument &arg);
00073
00074         /*  ================================================================
00075             Image argument-transformation
00076             ================================================================ */
00077         static void ProcessImageReadReq(const StackMsgArgument &arg);
00078         static void ProcessIconDescReadReq(const StackMsgArgument &arg);
00079
00080         /*  ================================================================
00081             Mdh argument-transformation
00082             ================================================================ */
00083         static void ProcessMdhDeregistrationReq(const StackMsgArgument &arg);
00084         static void ProcessMdhMakeViewReq(const StackMsgArgument &arg);
00085         static void ProcessMdhRegistrationReq(const StackMsgArgument &arg);
00086         static void ProcessMdhRemoveViewReq(const StackMsgArgument &arg);
00087         static void ProcessMdhSetConfigReq(const StackMsgArgument &arg);
00088         static void ProcessMdhSetStorageReq(const StackMsgArgument &arg);
00089         static void ProcessMdhSmsStatusReq(const StackMsgArgument &arg);
00090         static void ProcessMdhSmsUpdStatusReq(const StackMsgArgument &arg);
00091         static void ProcessMdhSmsReadReq(const StackMsgArgument &arg);
00092         static void ProcessMdhSmsWriteReq(const StackMsgArgument &arg);
00093         static void ProcessMdhSmsSetWaitingReq(const StackMsgArgument &arg);
00094         static void ProcessMdhSmsTransmitStartAck(const StackMsgArgument &arg);
00095         static void ProcessMdhSmsTransmitAck(const StackMsgArgument &arg);
00096         static void ProcessMdhSmsReportReadReq(const StackMsgArgument &arg);
00097         static void ProcessMdhSmsDeletionReq(const StackMsgArgument &arg);
00098         static void ProcessMdhSmsConcRefNumReq(const StackMsgArgument &arg);
00099         static void ProcessMdhSmsExtendedDataReq(const StackMsgArgument &arg);
00100
00101         /*  ================================================================
00102             Misc argument-transformation
00103             ================================================================ */
00104         static void ProcessImeiReadReq(const StackMsgArgument &arg);
00105         static void ProcessTestparamReq(const StackMsgArgument &arg);
00106         static void ProcessBandSelectionReq(const StackMsgArgument &arg);
00107         static void ProcessSimModifyLockReq(const StackMsgArgument &arg);
00108         static void ProcessEngineeringModeControlRequest(const StackMsgArgument &arg);
00109
00110         /*  ================================================================
00111             Moc argument-transformation
00112             ================================================================ */
00113         static void ProcessRedialRej(const StackMsgArgument &arg);
00114         static void ProcessRediallingDisabledInd(const StackMsgArgument &arg);
00115         static void ProcessClearBlacklistReq(const StackMsgArgument &arg);
00116         static void ProcessMocSetupReq(const StackMsgArgument &arg);
00117
00118         /*  ================================================================
00119             Mtc argument-transformation
00120             ================================================================ */
00121         static void ProcessMtcAccept(const StackMsgArgument &arg);
00122         static void ProcessMtcAlertReq(const StackMsgArgument &arg);
00123
00124         /*  ================================================================
00125             Network argument-transformation
00126             ================================================================ */
00127         static void ProcessMnTriggerReq(const StackMsgArgument &arg);
00128         static void ProcessMnNetworkSearchModeReq(const StackMsgArgument &arg);
00129
00130         /*  ================================================================
00131             Om argument-transformation
00132             ================================================================ */
00133         static void ProcessOmMultiSlotReq(const StackMsgArgument &arg);
00134         static void ProcessOmBandStatusReq(const StackMsgArgument &arg);
00135
00136         /*  ================================================================
00137             PhoneBook argument-transformation
00138             ================================================================ */
00139         static void ProcessPbInfoReadReq(const StackMsgArgument &arg);
00140         static void ProcessPbEntryReadReq(const StackMsgArgument &arg);
00141         static void ProcessPbEntryUpdReq(const StackMsgArgument &arg);
00142         static void ProcessFdnReq(const StackMsgArgument &arg);
00143         static void ProcessBdnReq(const StackMsgArgument &arg);
00144         static void ProcessPbCountReq(const StackMsgArgument &arg);
00145
00146         /*  ================================================================
00147             Plmn argument-transformation
00148             ================================================================ */
00149         static void ProcessPlmnListAbort(const StackMsgArgument &arg);
00150         static void ProcessPlmnListReq(const StackMsgArgument &arg);
00151         static void ProcessPrefPlmnChange(const StackMsgArgument &arg);
00152         static void ProcessOmRatChangeReq(const StackMsgArgument &arg);
00153         static void ProcessPrefServiceSetReq(const StackMsgArgument &arg);
00154         static void ProcessAttachReq(const StackMsgArgument &arg);
00155         static void ProcessDetachReq(const StackMsgArgument &arg);
00156         static void ProcessPlmnInfoReq(const StackMsgArgument &arg);
00157         static void ProcessGprsClassReq(const StackMsgArgument &arg);
00158
00159         /*  ================================================================
00160             Power argument-transformation
00161             ================================================================ */
00162         static void ProcessOmPowerUp(const StackMsgArgument &arg);
00163
00164         static void ProcessClientRegistration(const StackMsgArgument &arg);
00165         static void ProcessClientDeregistration(const StackMsgArgument &arg);
00166         static void ProcessStartSignalStrengthListening(const StackMsgArgument &arg);
00167         static void ProcessControlHwDataOnlyReq(const StackMsgArgument &arg);
00168         static void ProcessStopBatteryLoadListening(const StackMsgArgument &arg);
00169         static void ProcessStopSignalStrengthListening(const StackMsgArgument &arg);
00170         static void ProcessPowerDownReq(const StackMsgArgument &arg);
00171
00172         /*  ================================================================
00173             SimMisc argument-transformation
00174             ================================================================ */
00175         static void ProcessSimGenericReq(const StackMsgArgument &arg);
00176         static void ProcessSstReadReq(const StackMsgArgument &arg);
00177         static void ProcessAcmReadReq(const StackMsgArgument &arg);
00178         static void ProcessAcmUpdReq(const StackMsgArgument &arg);
00179         static void ProcessAcmMaxReadReq(const StackMsgArgument &arg);
00180         static void ProcessAcmMaxUpdReq(const StackMsgArgument &arg);
00181         static void ProcessCbmiReadReq(const StackMsgArgument &arg);
00182         static void ProcessCbmirReadReq(const StackMsgArgument &arg);
00183         static void ProcessCbmiUpdReq(const StackMsgArgument &arg);
00184         static void ProcessCbmirUpdReq(const StackMsgArgument &arg);
00185
00186         static void ProcessPuctReadReq(const StackMsgArgument &arg);
00187         static void ProcessPuctUpdReq(const StackMsgArgument &arg);
00188         static void ProcessPrefLangReadReq(const StackMsgArgument &arg);
00189         static void ProcessPrefLangUpdReq(const StackMsgArgument &arg);
00190         static void ProcessPrefExtLangReadReq(const StackMsgArgument &arg);
00191         static void ProcessPrefExtLangUpdReq(const StackMsgArgument &arg);
00192         static void ProcessSpnReadReq(const StackMsgArgument &arg);
00193         static void ProcessSimFileInfoReq(const StackMsgArgument &arg);
00194         static void ProcessCcpReadReq(const StackMsgArgument &arg);
00195         static void ProcessCcpUpdReq(const StackMsgArgument &arg);
00196         static void ProcessSmsrReadReq(const StackMsgArgument &arg);
00197         static void ProcessSmsrUpdReq(const StackMsgArgument &arg);
00198
00199         static void ProcessCphsIstReadReq(const StackMsgArgument &arg);
00200         static void ProcessCphsVmwfReadReq(const StackMsgArgument &arg);
00201         static void ProcessCphsVmwfUpdReq(const StackMsgArgument &arg);
00202         static void ProcessCphsCfufReadReq(const StackMsgArgument &arg);
00203         static void ProcessCphsCfufUpdReq(const StackMsgArgument &arg);
00204         static void ProcessCphsOnmReadReq(const StackMsgArgument &arg);
00205         static void ProcessCphsOnsReadReq(const StackMsgArgument &arg);
00206         static void ProcessCphsCspReadReq(const StackMsgArgument &arg);
00207         static void ProcessCphsCspUpdReq(const StackMsgArgument &arg);
00208
00209         static void ProcessCmiReadReq(const StackMsgArgument &arg);
00210
00211         static void ProcessODynReadReq(const StackMsgArgument &arg);
00212         static void ProcessODyn2ReadReq(const StackMsgArgument &arg);
00213         static void ProcessODynUpdReq(const StackMsgArgument &arg);
00214         static void ProcessODyn2UpdReq(const StackMsgArgument &arg);
00215         static void ProcessSimMruPropertyUpdReq(const StackMsgArgument &arg);
00216
00217         /*  ================================================================
00218             SimTk argument-transformation
00219             ================================================================ */
00220         static void ProcessSimTkRefreshCnfInd(const StackMsgArgument &arg);
00221         static void ProcessSimTkRefreshQueryRes(const StackMsgArgument &arg);
00222         static void ProcessSimTkRefreshRsp(const StackMsgArgument &arg);
00223         static void ProcessSimTkRefreshNewRsp(const StackMsgArgument &arg);
00224         static void ProcessSimTkRefreshResetRsp(const StackMsgArgument &arg);
00225         static void ProcessSimTkResetCnfInd(const StackMsgArgument &arg);
00226
00227         static void ProcessDisplayTextRsp(const StackMsgArgument &arg);
00228         static void ProcessGetInputRsp(const StackMsgArgument &arg);
00229         static void ProcessGetInkeyRsp(const StackMsgArgument &arg);
00230         static void ProcessSelectItemRsp(const StackMsgArgument &arg);
00231         static void ProcessSetupMenuRsp(const StackMsgArgument &arg);
00232         static void ProcessMenuSelectionReq(const StackMsgArgument &arg);
00233         static void ProcessPlayToneRsp(const StackMsgArgument &arg);
00234         static void ProcessSetupIdleModeTextRsp(const StackMsgArgument &arg);
00235         static void ProcessSetupEventCnf(const StackMsgArgument &arg);
00236         static void ProcessUserActivityEvent(const StackMsgArgument &arg);
00237         static void ProcessIdleScreenAvailEvent(const StackMsgArgument &arg);
00238         static void ProcessLanguageSelectEvent(const StackMsgArgument &arg);
00239         static void ProcessLanguageSettingInd(const StackMsgArgument &arg);
00240
00241         static void ProcessExtProactiveCmdReq(const StackMsgArgument &arg);
00242         static void ProcessExtProactiveCmdCnf(const StackMsgArgument &arg);
00243
00244         static void ProcessSimTkRunAtCmdInfoRes(const StackMsgArgument &arg);
00245
00246         static void ProcessSimTkSendDtmfCnf(const StackMsgArgument &arg);
00247         static void ProcessSimTkStopSendDtmfReq(const StackMsgArgument &arg);
00248
00249         static void ProcessSimTkSmsPpRsp(const StackMsgArgument &arg);
00250         static void ProcessSimTkSsRsp(const StackMsgArgument &arg);
00251         static void ProcessSimTkCallSetupAcc(const StackMsgArgument &arg);
00252         static void ProcessSimTkCallSetupRej(const StackMsgArgument &arg);
00253
00254         /*  ================================================================
00255             SimTk launch Browser
00256             ================================================================ */
00257         static void ProcessBrowserRegisterReq(const StackMsgArgument &arg);
00258         static void ProcessLaunchBrowserPromptInd(const StackMsgArgument &arg);
00259         static void ProcessLaunchBrowserInd(const StackMsgArgument &arg);
00260         static void ProcessBrowserTermEvent(const StackMsgArgument &arg);
00261
00262         /*  ================================================================
00263             SimTk Letter Class E
00264             ================================================================ */
00265         //---------Proactive Client to SIM------------------------------------------
00266         static void ProcessSiChannelOpenPromptRes(const StackMsgArgument &arg);
00267         static void ProcessSiChannelCloseReq(const StackMsgArgument &arg);
00268         static void ProcessSiChannelCloseInfoRes(const StackMsgArgument &arg);
00269         static void ProcessSiChannelSendInfoRes(const StackMsgArgument &arg);
00270         static void ProcessSiChannelReceiveInfoRes(const StackMsgArgument &arg);
00271         //---------IP-Stack to SIM--------------------------------------------------
00272         static void ProcessDhChannelOpenCnf(const StackMsgArgument &arg);
00273         static void ProcessDhChannelOpenRej(const StackMsgArgument &arg);
00274         static void ProcessDhChannelCloseInd(const StackMsgArgument &arg);
00275         static void ProcessDhChannelSendInd(const StackMsgArgument &arg);
00276         static void ProcessDhChannelDataAvailEvent(const StackMsgArgument &arg);
00277         static void ProcessDhChannelReceiveInd(const StackMsgArgument &arg);
00278         static void ProcessDhChannelChangeStatusEvent(const StackMsgArgument &arg);
00279         //-------
00280
00281         /*  ================================================================
00282             Sms argument-transformation
00283             ================================================================ */
00284         static void ProcessSmsConfigIndArg(const StackMsgArgument &arg);
00285         static void ProcessSmsSendReq(const StackMsgArgument &arg);
00286         static void ProcessSmsSetMoreMessageReq(const StackMsgArgument &arg);
00287         static void ProcessSmsGetMoreMessageStatusReq(const StackMsgArgument &arg);
00288
00289         /*  ================================================================
00290             Ss argument-transformation
00291             ================================================================ */
00292         static void ProcessSsSendReq(const StackMsgArgument &arg);
00293         static void ProcessSsSendEndReq(const StackMsgArgument &arg);
00294         static void ProcessSsGetPasswordRsp(const StackMsgArgument &arg);
00295         static void ProcessSsErrReq(const StackMsgArgument &arg);
00296         static void ProcessSsRejReq(const StackMsgArgument &arg);
00297         static void ProcessSsUssdReq(const StackMsgArgument &arg);
00298
00299         static void ProcessSsCcbsInvoke(const StackMsgArgument &arg);
00300         static void ProcessSsCcbsReject(const StackMsgArgument &arg);
00301         static void ProcessSsCcbsReCallRequest(const StackMsgArgument &arg);
00302
00303         /*  ================================================================
00304             Status argument-transformation
00305             ================================================================ */
00306         static void ProcessOmFactoryResetInd(const StackMsgArgument &arg);
00307         static void ProcessOmGetTermProfileReq(const StackMsgArgument &arg);
00308         static void ProcessOmSetTermProfileReq(const StackMsgArgument &arg);
00309
00310         /*  ================================================================
00311             USIMAP
00312             ================================================================ */
00313 #if defined(APOXI_ICC_USIM)
00314         static StackMsgArgId GetLastUsimRequestId();
00315
00316         static void ProcessUsimUstReadReq(const StackMsgArgument &arg);
00317         static void ProcessUsimEstReadReq(const StackMsgArgument &arg);
00318         static void ProcessUsimCsLociReadReq(const StackMsgArgument &arg);
00319         static void ProcessUsimPsLociReadReq(const StackMsgArgument &arg);
00320         static void ProcessUsimPlmnReadReq(const StackMsgArgument &arg);
00321         static void ProcessUsimLangReadReq(const StackMsgArgument &arg);
00322         static void ProcessUsimEccReadReq(const StackMsgArgument &arg);
00323         static void ProcessUsimSmsParamReadReq(const StackMsgArgument &arg);
00324         static void ProcessUsimCardTypeReadReq(const StackMsgArgument &arg);
00325
00326         static void ProcessUsimPlmnUpdReq(const StackMsgArgument &arg);
00327         static void ProcessUsimLangUpdReq(const StackMsgArgument &arg);
00328         static void ProcessUsimSmsParamUpdReq(const StackMsgArgument &arg);
00329         static void ProcessUsimFilePropertyReq(const StackMsgArgument &arg);
00330 #endif
00331         /*  ================================================================
00332             USIM Phonebook
00333             ================================================================ */
00334 #if defined(APOXI_ENABLE_USIM_PHONEBOOK) && ! defined(APOXI_USIM_PB_SIMULATION)
00335         static void ProcessUsimPbLocationReq(const StackMsgArgument &arg);
00336         static void ProcessUsimPbSelectReq(const StackMsgArgument &arg);
00337         static void ProcessUsimPbReadReq(const StackMsgArgument &arg);
00338         static void ProcessUsimPbReadRefReq(const StackMsgArgument &arg);
00339         static void ProcessUsimPbReadDataReq(const StackMsgArgument &arg);
00340         static void ProcessUsimPbUpdReq(const StackMsgArgument &arg);
00341         static void ProcessUsimPbUpdRefReq(const StackMsgArgument &arg);
00342         static void ProcessUsimPbUpdDataReq(const StackMsgArgument &arg);
00343         static void ProcessUsimPbFillStatusReq(const StackMsgArgument &arg);
00344         static void ProcessUsimPbStopReq(const StackMsgArgument &arg);
00345         static void ProcessUsimPbReadCnf(const StackMsgArgument &arg);
00346 #endif
00347
00348
00349 #if defined(APOXI_UUS_SUPPORT)
00350         /*  ================================================================
00351             UUS
00352             ================================================================ */
00353         static void ProcessUus1Req(const StackMsgArgument &arg);
00354         static void ProcessUus1QueryReq(const StackMsgArgument &arg);
00355 #endif
00356
00357 };
00358
00360 #endif  // Apc_SignalHandler_CommonStackMsgProcessor_hpp
00361
Generated on Tue Jan 24 14:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CrssSignalProcessor.cpp File Reference

Apc/SignalHandler/CrssSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/CrssStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for CrssSignalProcessor.cpp:

Generated on Tue Jan 24 17:00:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/CrssStackMsgProcessor.cpp File Reference

Apc/SignalHandler/CrssStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/CrssStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for CrssStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:00:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/ImageSignalProcessor.cpp File Reference

Apc/SignalHandler/ImageSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/ImageStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for ImageSignalProcessor.cpp:

Generated on Tue Jan 24 17:00:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/ImageStackMsgProcessor.cpp File Reference

Apc/SignalHandler/ImageStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/ImageStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for ImageStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:00:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/KeyMsgGenerator.cpp File Reference

Apc/SignalHandler/KeyMsgGenerator.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "KeyMsgGenerator.hpp"

Include dependency graph for KeyMsgGenerator.cpp:

Generated on Tue Jan 24 17:00:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/KeyMsgGenerator.hpp File Reference

Apc/SignalHandler/KeyMsgGenerator.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/SubSystem.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Kernel/Os/SemObtainer.hpp>

Include dependency graph for KeyMsgGenerator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | KeyMsgGenerator
class | KeyMsgGenerator::Key
one key-object which is extracted by the AtKeyParser and used as input for the KeyMsgGenerator More...

Defines

#define | Apc_KeyMsgGenerator_hpp

Define Documentation

#define Apc_KeyMsgGenerator_hpp

Generated on Tue Jan 24 17:00:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/KeyMsgGenerator.hpp Source File

Apc/SignalHandler/KeyMsgGenerator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apc_KeyMsgGenerator_hpp)
00011 #define Apc_KeyMsgGenerator_hpp
00014
00015 #include <Auxiliary/Macros.hpp>
00016 #include <Auxiliary/Linkable.hpp>
00017 #include <Auxiliary/LinkedList.hpp>
00018 #include <Kernel/Types.hpp>
00019 #include <Kernel/SubSystem.hpp>
00020 #include <Kernel/Os/SystemTimer.hpp>
00021 #include <Kernel/Os/SemObtainer.hpp>
00022
00027 class KeyMsgGenerator : public SubSystem {
00028     public:
00030         class Key : public Linkable<Key> {
00031             friend class KeyMsgGenerator;
00032             public:
00034                 enum State {
00036                     Invalid,
00038                     Set,
00040                     InProcess
00041                 };
00042
00044                 Key() : m_key_code((KeyCode) -1), m_duration(0), m_pause(0), m_state(Invalid) {}
00046                 Key(KeyCode key_code, UINT32 duration) : m_key_code(key_code), m_duration(duration), m_pause(0), m_state(Set) {}
00048                 Key(UINT32 pause) : m_key_code((KeyCode) -1), m_duration(0), m_pause(pause), m_state(Set) {}
00049
00051                 KeyCode GetKeyCode() const { return (m_key_code); }
00053                 UINT32 GetDuration() const { return (m_duration); }
00055                 UINT32 GetPause() const { return (m_pause); }
00056
00057             private:
00058                 KeyCode m_key_code;
00059                 UINT32 m_duration;      // in milliseconds
00060                 UINT32 m_pause;         // in milliseconds
00061                 State m_state;
00062
00063                 State GetState() const { return (m_state); }
00064                 void SetState(State state) { m_state = state; }
00065         };
00066
00068         KeyMsgGenerator();
00069
00071         static KeyMsgGenerator* GetInstance() { return m_instance; }
00072
00074         virtual const WCHAR* GetName() const { return L"APOXI KeyMsgGenerator (Apc)"; }
00075
00077         virtual BootSequenceState InvokeAt() const { return (SubSystemManager::c_run_level_3); }
00078
00080         virtual UINT8 GetPriority() const { return (100); }
00081
00083         virtual void OnPowerUp();
00084
00086         virtual void OnPowerDown();
00087
00089         static BOOLEAN Enqueue(const Key &key);
00090
00091     private:
00092         static SystemTimer m_timer;
00093         static KeyMsgGenerator *m_instance;
00094         static Semaphore m_sem;
00095         static LinkedList<Key>  m_key_list;
00096         static Key *m_active_key;
00097
00098         static void SendNextKey();
00099
00100         // Callback function for key timer.
00101         static void OnTimeout(void *key);
00102 };
00103
00105 #endif  // Apc_KeyMsgGenerator_hpp
00106
00107
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/Lib.hpp File Reference

Apc/SignalHandler/Lib.hpp File Reference

#include <Apc/SignalHandler/SignalHandler.hpp>
#include <Apc/SignalHandler/ProcessNode.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>
#include <Apc/SignalHandler/CommonStackMsgMapTableNode.hpp>
#include <Apc/SignalHandler/CommonSignalMapTableNode.hpp>

Include dependency graph for Lib.hpp:

Go to the source code of this file.

Defines

#define Apc_SignalHandler_Lib_hpp

Define Documentation

#define Apc_SignalHandler_Lib_hpp

Generated on Tue Jan 24 14:53:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/Lib.hpp Source File

Apc/SignalHandler/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_Lib_hpp)
00009 #define Apc_SignalHandler_Lib_hpp
00012
00013
00014 #include <Apc/SignalHandler/SignalHandler.hpp>
00015 #include <Apc/SignalHandler/ProcessNode.hpp>
00016 #include <Apc/SignalHandler/StackMsgProcessor.hpp>
00017
00018 //  common includes
00019 #include <Apc/SignalHandler/CommonStackMsgMapTableNode.hpp>
00020 #include <Apc/SignalHandler/CommonSignalMapTableNode.hpp>
00021
00023 #endif  // Apc_SignalHandler_Lib_hpp
00024
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/MdhSignalProcessor.cpp File Reference

Apc/SignalHandler/MdhSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/MdhSmsStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"
#include <Adc/DataHandler.hpp>
#include <Adc/SimPduHandler.hpp>

Include dependency graph for MdhSignalProcessor.cpp:

Functions

void | OnTimer (void *arg)

Variables

const INT | c_sms_time_out = 50
const INT | c_wait_sms_range = 5
INT | m_currpos = -1
INT | m_lastpos = 0
INT | m_lastrange = 0
ProcessPtr m_process_ptr
INT | m_rangestart = 0
INT | m_smscount = 0
SystemTimer m_timer
UINT8 | m_view = 0

Function Documentation

void OnTimer ( void * arg )

Variable Documentation

const INT c_sms_time_out = 50

const INT c_wait_sms_range = 5

INT m_currpos = -1

INT m_lastpos = 0

INT m_lastrange = 0

ProcessPtr m_process_ptr

INT m_rangestart = 0

INT m_smscount = 0

SystemTimer m_timer

UINT8 m_view = 0

Generated on Tue Jan 24 17:00:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/MdhStackMsgProcessor.cpp File Reference

Apc/SignalHandler/MdhStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/MdhSmsStackMsgArgs.hpp>
#include <Apc/StackInterface.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for MdhStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:00:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/MiscSignalProcessor.cpp File Reference

Apc/SignalHandler/MiscSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/MiscStackMsgArgs.hpp>
#include <Apc/NetworkStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"
#include <Devices/StartUp.hpp>
#include <Devices/AudioPathManager.hpp>

Include dependency graph for MiscSignalProcessor.cpp:

Defines

#define | KEY_FLIP_CLOSE 13
#define | KEY_FLIP_OPEN 12
#define | KEY_RELEASE 0x22
#define | MAX_SIGNAL_LEVEL 63
#define | MAX_SIGNAL_QUALITY 8

Define Documentation

#define KEY_FLIP_CLOSE 13

#define KEY_FLIP_OPEN 12

#define KEY_RELEASE 0x22

#define MAX_SIGNAL_LEVEL 63

#define MAX_SIGNAL_QUALITY 8

Generated on Tue Jan 24 17:00:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/MiscStackMsgProcessor.cpp File Reference

Apc/SignalHandler/MiscStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/MiscStackMsgArgs.hpp>
#include <Auxiliary/AlphaCoding.hpp>
#include <Auxiliary/DbgDump.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for MiscStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:00:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/MocSignalProcessor.cpp File Reference

Apc/SignalHandler/MocSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/MocStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for MocSignalProcessor.cpp:

Generated on Tue Jan 24 17:01:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/MocStackMsgProcessor.cpp File Reference

Apc/SignalHandler/MocStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/MocStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for MocStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:01:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/MtcSignalProcessor.cpp File Reference

Apc/SignalHandler/MtcSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/MtcStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for MtcSignalProcessor.cpp:

Generated on Tue Jan 24 17:01:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/MtcStackMsgProcessor.cpp File Reference

Apc/SignalHandler/MtcStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/MtcStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for MtcStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:01:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/NetworkSignalProcessor.cpp File Reference

Apc/SignalHandler/NetworkSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/NetworkStackMsgArgs.hpp>
#include <Apc/StackWrapper.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for NetworkSignalProcessor.cpp:

Generated on Tue Jan 24 17:01:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/NetworkStackMsgProcessor.cpp File Reference

Apc/SignalHandler/NetworkStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/NetworkStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for NetworkStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:01:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/OmSignalProcessor.cpp File Reference

Apc/SignalHandler/OmSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/OmStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for OmSignalProcessor.cpp:

Generated on Tue Jan 24 17:01:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/OmStackMsgProcessor.cpp File Reference

Apc/SignalHandler/OmStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for OmStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:01:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PhoneBookSignalProcessor.cpp File Reference

Apc/SignalHandler/PhoneBookSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/PhoneBookStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"
#include <Adc/DataHandler.hpp>

Include dependency graph for PhoneBookSignalProcessor.cpp:

Generated on Tue Jan 24 17:01:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PhoneBookStackMsgProcessor.cpp File Reference

Apc/SignalHandler/PhoneBookStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/PhoneBookStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for PhoneBookStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:01:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PlmnSignalProcessor.cpp File Reference

Apc/SignalHandler/PlmnSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/PlmnStackMsgArgs.hpp>
#include <Apc/StackWrapper.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for PlmnSignalProcessor.cpp:

Generated on Tue Jan 24 17:01:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PlmnStackMsgProcessor.cpp File Reference

Apc/SignalHandler/PlmnStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/PlmnStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for PlmnStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:01:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PowerSignalProcessor.cpp File Reference

Apc/SignalHandler/PowerSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/PowerStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"
#include <Devices/ShutDown.hpp>

Include dependency graph for PowerSignalProcessor.cpp:

Generated on Tue Jan 24 17:02:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PowerStackMsgProcessor.cpp File Reference

Apc/SignalHandler/PowerStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/PowerStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for PowerStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:02:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PreComp.cpp File Reference

Apc/SignalHandler/PreComp.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:57:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PreComp.hpp File Reference

Apc/SignalHandler/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Apc/Lib.hpp>
#include <stack/stack.h>
#include <stack/sdl_macros.h>
#include <Apc/SignalHandler/ProcessNode.hpp>
#include <Apc/SignalHandler/CommonSignalProcessor.hpp>
#include <Apc/SignalHandler/CommonStackMsgProcessor.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/PreComp.hpp Source File

Apc/SignalHandler/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Apc/Lib.hpp>
00010
00011 #include <stack/stack.h>
00012 #include <stack/sdl_macros.h>
00013
00014 #include <Apc/SignalHandler/ProcessNode.hpp>
00015 #include <Apc/SignalHandler/CommonSignalProcessor.hpp>
00016 #include <Apc/SignalHandler/CommonStackMsgProcessor.hpp>
00017
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/ProcessNode.cpp File Reference

Apc/SignalHandler/ProcessNode.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "ProcessNode.hpp"
#include <Kernel/VersionInfo.hpp>

Include dependency graph for ProcessNode.cpp:

Functions

ApoxiUseVersionInfo (ApcSignalHandler)

Function Documentation

ApoxiUseVersionInfo ( ApcSignalHandler )

Generated on Tue Jan 24 17:02:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/ProcessNode.hpp File Reference

Apc/SignalHandler/ProcessNode.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/AbstractExternalData.hpp>
#include <Apc/SignalHandler/SignalMapTableEntry.hpp>

Include dependency graph for ProcessNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ProcessNode
ProcessNode maintains the global SDL process pointer. More...

Defines

#define | Apc_SignalHandler_ProcessNode_hpp

Define Documentation

#define Apc_SignalHandler_ProcessNode_hpp

Generated on Tue Jan 24 17:02:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/ProcessNode.hpp Source File

Apc/SignalHandler/ProcessNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_ProcessNode_hpp)
00009 #define Apc_SignalHandler_ProcessNode_hpp
00012
00013 #include <Auxiliary/Macros.hpp>
00014 #include <Kernel/AbstractExternalData.hpp>
00015
00016 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>
00017
00019 class ProcessNode : public AbstractExternalData {
00020     public:
00022         ProcessNode(const ProcessPtr process_ptr = 0);
00024         virtual ~ProcessNode();
00025
00027         void Init(const ProcessPtr process_ptr);
00028
00030         void Refresh(const ProcessPtr process_ptr);
00031
00033         ProcessPtr GetProcessPtr() const { return (m_process_ptr); }
00034
00036         BOOLEAN IsEqualSignal(const SignalMapTableEntry &signal) const;
00037
00039         static BOOLEAN IsSignalNameAvailable();
00040
00042         SdlSignalId GetSignalId() const;
00044         SdlSignalName GetSignalName() const;
00045
00046     private:
00047         ProcessPtr m_process_ptr;
00048 };
00049
00051 #endif  // Apc_SignalHandler_ProcessNode_hpp
00052
00053
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalHandler.cpp File Reference

Apc/SignalHandler/SignalHandler.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/StackInterface.hpp>
#include "SignalHandler.hpp"
#include "SignalMapTable.hpp"
#include "StackMsgMapTable.hpp"
#include "StackMsgProcessor.hpp"
#include "StackTranslator.hpp"
#include <Devices/StartUp.hpp>
#include <Devices/ShutDown.hpp>
#include <Devices/RtcMsgTypes.hpp>

Include dependency graph for SignalHandler.cpp:

Functions

void | apoxi_process_signal (ApoxiSdlProcessPtrParamDecl)
void | Apoxi_startup (t_startup_data *startup_data)

Function Documentation

void apoxi_process_signal ( ApoxiSdlProcessPtrParamDecl )

void Apoxi_startup ( t_startup_data * startup_data )

Generated on Tue Jan 24 17:02:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalHandler.hpp File Reference

Apc/SignalHandler/SignalHandler.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/ExternalCommunicationHandler.hpp>

Include dependency graph for SignalHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SignalHandler

Defines

#define | Apc_SignalHandler_SignalHandler_hpp

Define Documentation

#define Apc_SignalHandler_SignalHandler_hpp

Generated on Tue Jan 24 17:02:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalHandler.hpp Source File

Apc/SignalHandler/SignalHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_SignalHandler_hpp)
00009 #define Apc_SignalHandler_SignalHandler_hpp
00012
00013 #include <Auxiliary/Macros.hpp>
00014 #include <Kernel/ExternalCommunicationHandler.hpp>
00015
00018 class SignalHandler : public ExternalCommunicationHandler {
00019     typedef ExternalCommunicationHandler Base;
00020     public:
00022         static SignalHandler* GetInstance();
00023
00025         virtual ~SignalHandler();
00026
00028         virtual void Init(const AbstractExternalData *external_data);
00029
00032         virtual void RouteData(const AbstractExternalData &external_data);
00033
00036         virtual void PostMessage(const MessageReferrer &msg_ref);
00037
00039         virtual HandlerType GetHandlerType() const { return SignalHandlerType; }
00040
00041     private:
00042         static SignalHandler *m_signal_handler;
00043
00044         // hide constructor as SignalHandler should be a singleton
00045         SignalHandler();
00046 };
00047
00049 #endif  // Apc_SignalHandler_SignalHandler_hpp
00050
00051
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalMapTable.cpp File Reference

Apc/SignalHandler/SignalMapTable.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "SignalMapTableNode.hpp"
#include "SignalMapTable.hpp"

Include dependency graph for SignalMapTable.cpp:

Generated on Tue Jan 24 17:02:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalMapTable.hpp File Reference

Apc/SignalHandler/SignalMapTable.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SignalMapTable

Defines

#define | Apc_SignalHandler_SignalMapTable_hpp

Define Documentation

#define Apc_SignalHandler_SignalMapTable_hpp

Generated on Tue Jan 24 17:02:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalMapTable.hpp Source File

Apc/SignalHandler/SignalMapTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_SignalMapTable_hpp)
00009 #define Apc_SignalHandler_SignalMapTable_hpp
00012
00013 class ProcessNode;
00014 class SignalMapTableNode;
00015 /*  ========================================================================
00016     SignalMapTable
00017     ======================================================================== */
00018 class SignalMapTable {
00019     friend class SignalMapTableNode;
00020     public:
00021         static void PostMessage(const ProcessNode &process_node);
00022
00023     private:
00024         static SignalMapTableNode *m_anchor;
00025         static void Attach(SignalMapTableNode *node);
00026         static void Remove(SignalMapTableNode *node);
00027 };
00028
00030 #endif // Apc_SignalHandler_SignalMapTable_hpp
00031
00032
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalMapTableEntry.hpp File Reference

Apc/SignalHandler/SignalMapTableEntry.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/SignalTypes.hpp>
#include <stack/sdl_macros.h>

Include dependency graph for SignalMapTableEntry.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | SignalMapTableEntry

Defines

#define | Apc_SignalHandler_SignalMapTableEntry_hpp

Typedefs

typedef ApoxiSdlProcessPtrType | ProcessPtr
typedef ApoxiSdlSignalIdType | SdlSignalId
typedef ApoxiSdlSignalNameType | SdlSignalName

Define Documentation

#define Apc_SignalHandler_SignalMapTableEntry_hpp

Generated on Tue Jan 24 17:03:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalMapTableEntry.hpp Source File

Apc/SignalHandler/SignalMapTableEntry.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_SignalMapTableEntry_hpp)
00009 #define Apc_SignalHandler_SignalMapTableEntry_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Apc/SignalTypes.hpp>
00015
00016 #include <stack/sdl_macros.h>
00017
00018 typedef ApoxiSdlSignalIdType SdlSignalId;
00019 typedef ApoxiSdlSignalNameType SdlSignalName;
00020 typedef ApoxiSdlProcessPtrType ProcessPtr;
00021
00022 /*  ========================================================================
00023     SignalMapTableEntry
00024     ======================================================================== */
00025 struct SignalMapTableEntry {
00026     SdlSignalId   id;
00027 #if defined (APOXI_RTOS_WIN32)
00028     SdlSignalName name;         // host implementation
00029     static BOOLEAN IsNameAvailable() { return (TRUE); }
00030 #else
00031     static BOOLEAN IsNameAvailable() { return (FALSE); }
00032 #endif
00033     void (*post_message_func)(const ProcessPtr &);
00034 };
00035
00037 #endif // Apc_SignalHandler_SignalMapTableEntry_hpp
00038
00039
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalMapTableNode.cpp File Reference

Apc/SignalHandler/SignalMapTableNode.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "ProcessNode.hpp"
#include "SignalMapTableNode.hpp"
#include "SignalMapTable.hpp"

Include dependency graph for SignalMapTableNode.cpp:

Generated on Tue Jan 24 17:03:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalMapTableNode.hpp File Reference

Apc/SignalHandler/SignalMapTableNode.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/SignalHandler/SignalMapTableEntry.hpp>

Include dependency graph for SignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SignalMapTableNode

Defines

#define | Apc_SignalHandler_SignalMapTableNode_hpp

Define Documentation

#define Apc_SignalHandler_SignalMapTableNode_hpp

Generated on Tue Jan 24 17:03:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SignalMapTableNode.hpp Source File

Apc/SignalHandler/SignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_SignalMapTableNode_hpp)
00009 #define Apc_SignalHandler_SignalMapTableNode_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>
00015
00016 class ProcessNode;
00017 class SignalMapTable;
00018 /*  ========================================================================
00019     SignalMapTableNode
00020     ======================================================================== */
00021 //TODO: What is this? murrayc.
00022 class SignalMapTableNode {
00023     friend class SignalMapTable;
00024     public:
00025         //TODO: Please explain these parameters. For instance, last_entry seems to always be LAST_SIGNAL_CODE. muraryc.
00026         SignalMapTableNode(const SignalMapTableEntry *map_table, SdlSignalId last_entry, SignalMapTableNode **node = 0);
00027
00028         void Remove();
00029
00030     private:
00031         const SignalMapTableEntry *m_map_table;
00032         SdlSignalId m_last_entry;
00033
00034         SignalMapTableNode *m_next;
00035         SignalMapTableNode **m_node_ptr;
00036
00037         void SetNext(SignalMapTableNode *node);
00038         BOOLEAN PostMessage(const ProcessNode &process_node);
00039         BOOLEAN PostMessageWithinTable(const ProcessNode &process_node);
00040 };
00041
00043 #endif // Apc_SignalHandler_SignalMapTableNode_hpp
00044
00045
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SimMiscSignalProcessor.cpp File Reference

Apc/SignalHandler/SimMiscSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/SimMiscStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for SimMiscSignalProcessor.cpp:

Generated on Tue Jan 24 17:03:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SimMiscStackMsgProcessor.cpp File Reference

Apc/SignalHandler/SimMiscStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/SimMiscStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for SimMiscStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:03:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SimTkLetClassESignalProcessor.cpp File Reference

Apc/SignalHandler/SimTkLetClassESignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/Tlv.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/SimTkStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for SimTkLetClassESignalProcessor.cpp:

Generated on Tue Jan 24 17:03:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SimTkLetClassEStackMsgProcessor.cpp File Reference

Apc/SignalHandler/SimTkLetClassEStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/SimTkStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for SimTkLetClassEStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:03:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SimTkSignalProcessor.cpp File Reference

Apc/SignalHandler/SimTkSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/Tlv.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/SimTkStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for SimTkSignalProcessor.cpp:

Generated on Tue Jan 24 17:03:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SimTkStackMsgProcessor.cpp File Reference

Apc/SignalHandler/SimTkStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/SimTkStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for SimTkStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:03:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SmsSignalProcessor.cpp File Reference

Apc/SignalHandler/SmsSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/SmsStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for SmsSignalProcessor.cpp:

Generated on Tue Jan 24 17:03:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SmsStackMsgProcessor.cpp File Reference

Apc/SignalHandler/SmsStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/SmsStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for SmsStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:03:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SsCcbsSignalProcessor.cpp File Reference

Apc/SignalHandler/SsCcbsSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/DataCodingScheme.hpp>
#include <Apc/SimDataTypes.hpp>
#include <Apc/SsStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"

Include dependency graph for SsCcbsSignalProcessor.cpp:

Generated on Tue Jan 24 17:04:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SsCcbsStackMsgProcessor.cpp File Reference

Apc/SignalHandler/SsCcbsStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/DataCodingScheme.hpp>
#include <Apc/SsStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for SsCcbsStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:04:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SsSignalProcessor.cpp File Reference

Apc/SignalHandler/SsSignalProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/DataCodingScheme.hpp>
#include <Apc/SimDataTypes.hpp>
#include <Apc/SsStackMsgArgs.hpp>
#include "CommonSignalProcessor.hpp"
#include <Auxiliary/AlphaCoding.hpp>

Include dependency graph for SsSignalProcessor.cpp:

Generated on Tue Jan 24 17:04:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/SsStackMsgProcessor.cpp File Reference

Apc/SignalHandler/SsStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include <Apc/DataCodingScheme.hpp>
#include <Apc/SsStackMsgArgs.hpp>
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for SsStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:04:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgMapTable.cpp File Reference

Apc/SignalHandler/StackMsgMapTable.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "StackMsgMapTableNode.hpp"
#include "StackMsgMapTable.hpp"

Include dependency graph for StackMsgMapTable.cpp:

Generated on Tue Jan 24 17:04:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgMapTable.hpp File Reference

Apc/SignalHandler/StackMsgMapTable.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackMsgMapTable

Defines

#define | Apc_SignalHandler_StackMsgMapTable_hpp

Define Documentation

#define Apc_SignalHandler_StackMsgMapTable_hpp

Generated on Tue Jan 24 17:04:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgMapTable.hpp Source File

Apc/SignalHandler/StackMsgMapTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_StackMsgMapTable_hpp)
00009 #define Apc_SignalHandler_StackMsgMapTable_hpp
00012
00013 class StackMsgArgument;
00014 class StackMsgMapTableNode;
00015 /*  ========================================================================
00016     StackMsgMapTable
00017     ======================================================================== */
00018 class StackMsgMapTable {
00019     friend class StackMsgMapTableNode;
00020     public:
00021         static void SendSignal(const StackMsgArgument &arg);
00022
00023     private:
00024         static StackMsgMapTableNode *m_anchor;
00025         static void Attach(StackMsgMapTableNode *node);
00026         static void Remove(StackMsgMapTableNode *node);
00027 };
00028
00030 #endif // Apc_SignalHandler_StackMsgMapTable_hpp
00031
00032
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgMapTableEntry.hpp File Reference

Apc/SignalHandler/StackMsgMapTableEntry.hpp File Reference

#include <Apc/StackMsgArgument.hpp>

Include dependency graph for StackMsgMapTableEntry.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | StackMsgMapTableEntry

Defines

#define | Apc_SignalHandler_StackMsgMapTableEntry_hpp

Typedefs

typedef CHAR * | StackMsgArgName

Define Documentation

#define Apc_SignalHandler_StackMsgMapTableEntry_hpp

Generated on Tue Jan 24 17:04:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgMapTableEntry.hpp Source File

Apc/SignalHandler/StackMsgMapTableEntry.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_StackMsgMapTableEntry_hpp)
00009 #define Apc_SignalHandler_StackMsgMapTableEntry_hpp
00012
00013 #include <Apc/StackMsgArgument.hpp>
00014
00015 typedef CHAR* StackMsgArgName;
00016
00017 /*  ========================================================================
00018     StackMsgMapTableEntry
00019     ======================================================================== */
00020 struct StackMsgMapTableEntry {
00021     StackMsgArgId id;
00022 #if defined (APOXI_RTOS_WIN32)
00023     StackMsgArgName name;           // host implementation add on
00024     static BOOLEAN IsNameAvailable() { return (TRUE); }
00025 #else
00026     static BOOLEAN IsNameAvailable() { return (FALSE); }
00027 #endif
00028     void (*send_signal_func)(const StackMsgArgument &);
00029 };
00030
00032 #endif // Apc_SignalHandler_StackMsgMapTableEntry_hpp
00033
00034
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgMapTableNode.cpp File Reference

Apc/SignalHandler/StackMsgMapTableNode.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "ProcessNode.hpp"
#include "StackMsgMapTableNode.hpp"
#include "StackMsgMapTable.hpp"

Include dependency graph for StackMsgMapTableNode.cpp:

Generated on Tue Jan 24 17:04:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgMapTableNode.hpp File Reference

Apc/SignalHandler/StackMsgMapTableNode.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/SignalHandler/StackMsgMapTableEntry.hpp>

Include dependency graph for StackMsgMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackMsgMapTableNode

Defines

#define | Apc_SignalHandler_StackMsgMapTableNode_hpp

Define Documentation

#define Apc_SignalHandler_StackMsgMapTableNode_hpp

Generated on Tue Jan 24 17:04:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgMapTableNode.hpp Source File

Apc/SignalHandler/StackMsgMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_StackMsgMapTableNode_hpp)
00009 #define Apc_SignalHandler_StackMsgMapTableNode_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Apc/SignalHandler/StackMsgMapTableEntry.hpp>
00015
00016 class StackMsgMapTable;
00017 /*  ========================================================================
00018     StackMsgMapTableNode
00019     ======================================================================== */
00020 class StackMsgMapTableNode {
00021     friend class StackMsgMapTable;
00022     public:
00023         StackMsgMapTableNode(const StackMsgMapTableEntry *map_table, StackMsgArgId StackMsgArgId, StackMsgMapTableNode **node = 0);
00024
00025         void Remove();
00026
00027     private:
00028         const StackMsgMapTableEntry *m_map_table;
00029         StackMsgArgId m_last_entry;
00030
00031         StackMsgMapTableNode *m_next;
00032         StackMsgMapTableNode **m_node_ptr;
00033
00034         void SetNext(StackMsgMapTableNode *node);
00035         BOOLEAN SendSignal(const StackMsgArgument &arg);
00036         BOOLEAN SendSignalWithinTable(const StackMsgArgument &arg);
00037 };
00038
00040 #endif // Apc_SignalHandler_StackMsgMapTableNode_hpp
00041
00042
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgProcessor.cpp File Reference

Apc/SignalHandler/StackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "StackMsgProcessor.hpp"

Include dependency graph for StackMsgProcessor.cpp:

Generated on Tue Jan 24 17:04:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgProcessor.hpp File Reference

Apc/SignalHandler/StackMsgProcessor.hpp File Reference

#include <Apc/SignalHandler/ProcessNode.hpp>

Include dependency graph for StackMsgProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackMsgProcessor

Defines

#define | Apc_SignalHandler_StackMsgProcessor_hpp

Define Documentation

#define Apc_SignalHandler_StackMsgProcessor_hpp

Generated on Tue Jan 24 17:04:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackMsgProcessor.hpp Source File

Apc/SignalHandler/StackMsgProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_StackMsgProcessor_hpp)
00009 #define Apc_SignalHandler_StackMsgProcessor_hpp
00012
00013 #include <Apc/SignalHandler/ProcessNode.hpp>
00014
00015 class StackMsgArgument;
00016
00017 /*  ========================================================================
00018     StackMsgProcessor
00019     ======================================================================== */
00023 class StackMsgProcessor {
00024     public:
00026         static void Init(const ProcessNode &process_node);
00027
00029         static ProcessPtr GetProcessPtr() { return m_process_ptr; }
00030         static void PostFromStackMsg(StackMsgArgument * arg);
00031
00032     protected:
00033         static ProcessPtr m_process_ptr;
00034 };
00035
00037 #endif  // Apc_SignalHandler_StackMsgProcessor_hpp
00038
00039
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackTranslator.cpp File Reference

Apc/SignalHandler/StackTranslator.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "StackTranslator.hpp"
#include <Apc/SignalHandler/CommonSignalMapTableNode.hpp>
#include <Apc/SignalHandler/CommonStackMsgMapTableNode.hpp>

Include dependency graph for StackTranslator.cpp:

Generated on Tue Jan 24 17:04:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackTranslator.hpp File Reference

Apc/SignalHandler/StackTranslator.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackTranslator

Defines

#define | Apc_SignalHandler_StackTranslator_hpp

Define Documentation

#define Apc_SignalHandler_StackTranslator_hpp

Generated on Tue Jan 24 17:04:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StackTranslator.hpp Source File

Apc/SignalHandler/StackTranslator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_SignalHandler_StackTranslator_hpp)
00009 #define Apc_SignalHandler_StackTranslator_hpp
00012
00013
00015 class StackTranslator {
00016     public:
00017         static void Init();
00018 };
00019
00021 #endif // Apc_SignalHandler_StackTranslator_hpp
00022
00023
Generated on Tue Jan 24 14:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StatusHandlerProcessor.cpp File Reference

Apc/SignalHandler/StatusHandlerProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for StatusHandlerProcessor.cpp:

Generated on Tue Jan 24 17:04:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apc/SignalHandler/StatusStackMsgProcessor.cpp File Reference

Apc/SignalHandler/StatusStackMsgProcessor.cpp File Reference

#include "Apc/SignalHandler/PreComp.hpp"
#include "CommonStackMsgProcessor.hpp"

Include dependency graph for StatusStackMsgProcessor.cpp:

Generated on Tue Jan 24 17:04:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AccDispatcher.cpp File Reference

Asc/AccDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "AccDispatcher.hpp"
#include "StackIndicationMsgTypes.hpp"
#include <Apc/Accessory.hpp>

Include dependency graph for AccDispatcher.cpp:

Generated on Tue Jan 24 17:11:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AccDispatcher.hpp File Reference

Asc/AccDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for AccDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AccDispatcher

Defines

#define | Asc_AccDispatcher_hpp

Define Documentation

#define Asc_AccDispatcher_hpp

Generated on Tue Jan 24 17:11:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AccDispatcher.hpp Source File

Asc/AccDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_AccDispatcher_hpp)
00009 #define Asc_AccDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016
00018 class AccDispatcher : public StackMsgDispatcher {
00019     typedef StackMsgDispatcher Base;
00020     public:
00022         AccDispatcher();
00024         virtual ~AccDispatcher();
00025
00026     protected:
00028         BOOLEAN OnAccessoryInd(const StackMsgArgument &arg);
00029
00030     private:
00031         static const StackMsgArgMap<AccDispatcher> m_arg_map[];
00032         StackMsgArgMapContainer<AccDispatcher> m_arg_map_container;
00033 };
00034
00036 #endif // Asc_AccDispatcher_hpp
00037
00038
Generated on Tue Jan 24 14:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AccHandler.cpp File Reference

Asc/AccHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "AccHandler.hpp"

Include dependency graph for AccHandler.cpp:

Generated on Tue Jan 24 17:11:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AccHandler.hpp File Reference

Asc/AccHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/AccDispatcher.hpp>

Include dependency graph for AccHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AccHandler

Defines

#define | Asc_AccHandler_hpp

Define Documentation

#define Asc_AccHandler_hpp

Generated on Tue Jan 24 17:11:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AccHandler.hpp Source File

Asc/AccHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_AccHandler_hpp)
00009 #define Asc_AccHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/AccDispatcher.hpp>
00016
00019 class AccHandler : public BaseHandler {
00020     typedef BaseHandler Base;
00021     public:
00022         enum { ID = AccHandlerId };
00023
00025         AccHandler();
00027         virtual ~AccHandler();
00029         virtual HandlerId GetHandlerId() const;
00030
00031     private:
00032         AccDispatcher m_acc_dispatcher; // main dispatcher for retrieving asynchronous messages
00033 };
00034
00036 #endif // Asc_AccHandler_hpp
00037
00038
Generated on Tue Jan 24 14:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AdcInterface.cpp File Reference

Asc/AdcInterface.cpp File Reference

#include "Asc/PreComp.hpp"
#include "AdcInterface.hpp"

Include dependency graph for AdcInterface.cpp:

Functions

ClirMode GetClirSetting ()
CugDescriptor GetCugSetting ()
RegisterStatus GetRegistrationState ()
BOOLEAN IsRedialingActive ()
Generated on Tue Jan 24 17:11:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AdcInterface.hpp File Reference

Asc/AdcInterface.hpp File Reference

#include <Apc/NetworkTypes.hpp>

Include dependency graph for AdcInterface.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Asc_AdcInterface_hpp

Functions

ClirMode GetClirSetting ()
CugDescriptor GetCugSetting ()
RegisterStatus GetRegistrationState ()
BOOLEAN | IsRedialingActive ()

Define Documentation

#define Asc_AdcInterface_hpp

Generated on Tue Jan 24 17:11:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AdcInterface.hpp Source File

Asc/AdcInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of thi document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_AdcInterface_hpp)
00009 #define Asc_AdcInterface_hpp
00012
00013 #include <Apc/NetworkTypes.hpp>
00014
00015 RegisterStatus GetRegistrationState();
00016
00017 ClirMode GetClirSetting();
00018
00019 CugDescriptor GetCugSetting();
00020
00021 BOOLEAN IsRedialingActive();
00022
00024 #endif  // Asc_AdcInterface_hpp
00025
00026
Generated on Tue Jan 24 14:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AocDispatcher.cpp File Reference

Asc/AocDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "AocDispatcher.hpp"

Include dependency graph for AocDispatcher.cpp:

Generated on Tue Jan 24 17:11:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AocDispatcher.hpp File Reference

Asc/AocDispatcher.hpp File Reference

#include <Asc/StackMsgDispatcher.hpp>
#include "StackIndicationMsgTypes.hpp"

Include dependency graph for AocDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AocDispatcher

Defines

#define | Asc_AocDispatcher_hpp

Define Documentation

#define Asc_AocDispatcher_hpp

Generated on Tue Jan 24 17:12:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AocDispatcher.hpp Source File

Asc/AocDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_AocDispatcher_hpp)
00009 #define Asc_AocDispatcher_hpp
00012
00013 #include <Asc/StackMsgDispatcher.hpp>
00014 #include "StackIndicationMsgTypes.hpp"
00015
00017 class AocDispatcher : public StackMsgDispatcher {
00018     typedef StackMsgDispatcher Base;
00019     public:
00021         AocDispatcher();
00023         virtual ~AocDispatcher();
00024
00025     protected:
00027         BOOLEAN OnAocInd(const StackMsgArgument &arg);
00028
00030         BOOLEAN OnChargeUnitsInd(const StackMsgArgument &arg);
00031
00033         BOOLEAN OnChargeInd(const StackMsgArgument &arg);
00034
00035     private:
00036         static const StackMsgArgMap<AocDispatcher> m_arg_map[];
00037         StackMsgArgMapContainer<AocDispatcher> m_arg_map_container;
00038 };
00039
00041 #endif // Asc_AocDispatcher_hpp
00042
00043
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AocHandler.cpp File Reference

Asc/AocHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandler.hpp"
#include "AocDispatcher.hpp"
#include "AocHandler.hpp"

Include dependency graph for AocHandler.cpp:

Generated on Tue Jan 24 17:12:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AocHandler.hpp File Reference

Asc/AocHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/AocDispatcher.hpp>

Include dependency graph for AocHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AocHandler

Defines

#define | Asc_AocHandler_hpp

Define Documentation

#define Asc_AocHandler_hpp

Generated on Tue Jan 24 17:12:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AocHandler.hpp Source File

Asc/AocHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_AocHandler_hpp)
00009 #define Asc_AocHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/AocDispatcher.hpp>
00016
00017
00019 class AocHandler : public BaseHandler {
00020     typedef BaseHandler Base;
00021
00022     public:
00023         enum { ID = AocHandlerId };
00024
00026         AocHandler();
00028         virtual ~AocHandler();
00029
00031         virtual HandlerId GetHandlerId() const;
00032
00034         void ReportChargeUnits(BOOLEAN activate);
00035
00037         void ReportCurrentCharge(BOOLEAN activate);
00038
00040         CallApiRc RequestCurrentCharge(CallIndex call_index);
00041
00043         CallApiRc RequestChargeUnits(CallIndex call_index);
00044
00045
00046     private:
00047         CallApiRc CheckAocRequestRestrictions(CallIndex call_index, Tipd & tipd);
00048         AocDispatcher m_aoc_disp;
00049 };
00050
00052 #endif // Asc_AocHandler_hpp
00053
00054
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ApoxiAscVersion.cpp File Reference

Asc/ApoxiAscVersion.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiAscVersion.cpp:

Functions

ApoxiDefVersionInfo (Asc, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | Asc | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 17:12:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AscTemplates.cpp File Reference

Asc/AscTemplates.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/InputAnalyzer.hpp>
#include <Asc/SmsFactory.hpp>
#include <Asc/HandlerList.hpp>
#include <Asc/PdpContextManager.hpp>
#include <Asc/AtBaseManager.hpp>
#include <Socket/InetSocket.hpp>
#include <Asc/CallForwardingHandler.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>

Include dependency graph for AscTemplates.cpp:

Generated on Tue Jan 24 17:12:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtBaseManager.cpp File Reference

Asc/AtBaseManager.cpp File Reference

#include "Asc/PreComp.hpp"
#include "AtBaseManager.hpp"

Include dependency graph for AtBaseManager.cpp:

Generated on Tue Jan 24 17:12:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtBaseManager.hpp File Reference

Asc/AtBaseManager.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AtBaseManager_hpp

Define Documentation

#define Apoxi_AtBaseManager_hpp

Generated on Tue Jan 24 17:12:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtBaseManager.hpp Source File

Asc/AtBaseManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AtBaseManager_hpp)
00010 #define Apoxi_AtBaseManager_hpp
00013
00014 #if defined(APOXI_ENABLE_GENERIC_AT_INTERFACE)
00015
00016 #include <Apc/AtcTypes.hpp>
00017
00025 class AtBaseManager {
00026
00027     public:
00028
00030         static AtBaseManager& GetInstance();
00031
00032         /*  ----------------------------------------------------------------
00033                                 AT command specific
00034             ---------------------------------------------------------------- */
00035
00037         typedef BOOLEAN (*CallBackFn)(const String& str);
00039         struct CallBackItem {
00040             CallBackFn  fn;
00041             INT         timeout;
00042         };
00043
00048         BOOLEAN Parse(const String& str);
00049
00056         BOOLEAN SplitAtCommand(const String& str, const String& token,
00057                                String& cmd_str, String& arg_str);
00058
00065         BOOLEAN SendAtResponse(const String& str, const BOOLEAN final = TRUE);
00066
00075         BOOLEAN Register(const String& cmd_str, const INT timeout, CallBackFn fn = 0);
00076
00081         BOOLEAN Unregister(const String& cmd_str);
00082
00085         void SetCallBackFn(const CallBackFn fn) { m_fn = fn; }
00086
00088         void ResetCallBackFn() { m_fn = 0; }
00089
00090         /*  ----------------------------------------------------------------
00091                             accessory application specific
00092             ---------------------------------------------------------------- */
00093
00095         typedef BOOLEAN (*AccCallBackFn)(const BOOLEAN enable);
00096
00099         void SetAccessoryCallBackFn(const AccCallBackFn fn) { m_acc_fn = fn; }
00100
00102         void ResetAccessoryCallBackFn() { m_acc_fn = 0; }
00103
00107         void SendAccessoryRegistrationRequest(const BOOLEAN enable);
00108
00113         void SendAccessoryRegistrationResponse(const AtStatusType status,
00114             const BOOLEAN enable);
00115
00117         BOOLEAN IsAccessoryRegistrationEnabled() const { return m_acc_registered; }
00118
00122         BOOLEAN SendAccessoryCommand(const String& acc_str);
00123
00124     private:
00125
00127         static void OnTimeout(void *);
00128
00129         /* Extract command header from full string.
00130             @param str          AT command string
00131             @param cmd_str      extracted command header
00132             @param pass_through allow to assign str to cmd_str
00133                                 when splitting fails
00134             @return             TRUE, if successfully split */
00135         BOOLEAN ExtractCommandString(const String& str, String& cmd_str,
00136                                      const BOOLEAN pass_through = FALSE);
00138         void TrimAtCommand(String& str);
00140         BOOLEAN SendAtResponse(AtStatusType status, const String& str,
00141             const BOOLEAN final = TRUE);
00143         Semaphore m_sem;
00145         SimpleMap<String, CallBackItem> m_map;
00147         CallBackFn m_fn;
00149         SystemTimer m_timer;
00151         AccCallBackFn m_acc_fn;
00153         BOOLEAN m_acc_registered;
00154 };
00155
00156 #endif  // APOXI_ENABLE_GENERIC_AT_INTERFACE
00157
00159 #endif  // Apoxi_AtBaseManager_hpp
00160
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtcDispatcher.cpp File Reference

Asc/AtcDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "AtcDispatcher.hpp"
#include "AtcHandler.hpp"

Include dependency graph for AtcDispatcher.cpp:

Generated on Tue Jan 24 17:12:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtcDispatcher.hpp File Reference

Asc/AtcDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for AtcDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtcDispatcher

Defines

#define | Asc_AtcDispatcher_hpp

Define Documentation

#define Asc_AtcDispatcher_hpp

Generated on Tue Jan 24 17:13:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtcDispatcher.hpp Source File

Asc/AtcDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_AtcDispatcher_hpp)
00009 #define Asc_AtcDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Asc/StackMsgDispatcher.hpp>
00015
00016 /*  ========================================================================
00017     AtcDispatcher
00018     ======================================================================== */
00020 class AtcDispatcher : public StackMsgDispatcher {
00021     typedef StackMsgDispatcher Base;
00022
00023     friend class AtcHandler;
00024
00025     public:
00027         AtcDispatcher();
00029         virtual ~AtcDispatcher();
00030
00031         static PbRequestBehaviour GetPbAlphaTagRequestBehaviour() {
00032             return m_pbrequesttype;
00033         }
00034
00035     protected:
00037         BOOLEAN OnAtAlphaTagReq(const StackMsgArgument & arg);
00039         BOOLEAN OnAtPbSelectReq(const StackMsgArgument & arg);
00041         BOOLEAN OnAtPbListReq(const StackMsgArgument & arg);
00042
00043     private:
00044         static const StackMsgArgMap<AtcDispatcher> m_arg_map[];
00045         StackMsgArgMapContainer<AtcDispatcher> m_arg_map_container;
00046
00047         void SetPbAlphaTagRequestBehaviour(PbRequestBehaviour behaviour) {
00048             m_pbrequesttype = behaviour;
00049         }
00050
00051         BOOLEAN ConfirmPbAlphaTagRequest(
00052             const WString & alphatag, const PhoneNumber & phno,BOOLEAN apoxilookup);
00053
00054         void SetPbRecordRequestBehaviour(BOOLEAN mmicontrolled) {
00055             m_pbentry_mmicontrolled = mmicontrolled;
00056         }
00057
00058         BOOLEAN CommitPbInformation(const MePhonebookDescription & description);
00059         BOOLEAN ConfirmPbSizeRequest(BOOLEAN capable, MePhoneBookType type, INT usedrecords);
00060         BOOLEAN ConfirmPbEntryRequest(BOOLEAN capable, MePhoneBookType type, INT recordnumber,
00061                                       const WString & alphaidentifier, const PhoneNumber & phno);
00062
00063         static BOOLEAN m_pbentry_mmicontrolled;
00064         static BOOLEAN m_alphatag_req_pending;
00065         static PbRequestBehaviour m_pbrequesttype;
00066 };
00067
00068
00070 #endif  // Asc_AtcDispatcher_hpp
00071
00072
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtcHandler.cpp File Reference

Asc/AtcHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "AtcHandler.hpp"

Include dependency graph for AtcHandler.cpp:

Generated on Tue Jan 24 17:13:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtcHandler.hpp File Reference

Asc/AtcHandler.hpp File Reference

#include <Apc/SignalTypes.hpp>
#include <Asc/BaseHandler.hpp>
#include <Asc/AtcDispatcher.hpp>

Include dependency graph for AtcHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtcHandler

Defines

#define | Asc_AtcHandler_hpp

Define Documentation

#define Asc_AtcHandler_hpp

Generated on Tue Jan 24 17:13:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtcHandler.hpp Source File

Asc/AtcHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_AtcHandler_hpp)
00009 #define Asc_AtcHandler_hpp
00012
00013 #include <Apc/SignalTypes.hpp>
00014
00015 #include <Asc/BaseHandler.hpp>
00016 #include <Asc/AtcDispatcher.hpp>
00017
00018 /*  ========================================================================
00019     AtcHandler
00020     ======================================================================== */
00023 class AtcHandler : public BaseHandler {
00024     typedef BaseHandler Base;
00025
00026     public:
00027
00028         enum { ID = AtcHandlerId };
00029
00031         AtcHandler();
00033         virtual ~AtcHandler();
00034
00036         virtual HandlerId GetHandlerId() const;
00037
00039         void SetPbAlphaTagRequestBehaviour(PbRequestBehaviour behaviour) {
00040             m_atc_dispatcher.SetPbAlphaTagRequestBehaviour(behaviour);
00041         }
00045         BOOLEAN ConfirmPbAlphaTagRequest(
00046             const WString & alphatag, const PhoneNumber & phno, BOOLEAN apoxilookup = FALSE)
00047         {
00048             return m_atc_dispatcher.ConfirmPbAlphaTagRequest(alphatag,phno, apoxilookup);
00049         }
00050
00053         void SetPbRecordRequestBehaviour(BOOLEAN mmicontrolled) {
00054             m_atc_dispatcher.SetPbRecordRequestBehaviour(mmicontrolled);
00055         }
00056
00059         BOOLEAN CommitPbInformation(const MePhonebookDescription & description)
00060         {
00061             return m_atc_dispatcher.CommitPbInformation(description);
00062         }
00063
00066         BOOLEAN ConfirmPbSizeRequest(
00067             BOOLEAN capable,         // MMI has to set the value to TRUE if it is capable of detecting the size.
00068             MePhoneBookType type,    // the requested phonebook type as used in PbSizeRequestMsg
00069             INT usedrecords,         // used records inside the phonebook
00070             INT totalrecords = 0)    // obsolete parameter, as this is sent with CommitPbInformation
00071         {
00072             return m_atc_dispatcher.ConfirmPbSizeRequest(capable,type,usedrecords);
00073         }
00074
00077         BOOLEAN ConfirmPbEntryRequest(
00078             BOOLEAN capable,                    // MMI has to set the value to TRUE if it was capable of returning the entry correctly.
00079             MePhoneBookType type,               // the requested phonebook type as used in PbSizeRequestMsg
00080             INT recordnumber,                   // the record number requested by the AT via the message PbEntryRequestMsg
00081             const WString & alphaidentifier,    // it can be also be an empty string
00082             const PhoneNumber & phno)           // it can also be an empty phonenumber
00083         {
00084             return m_atc_dispatcher.ConfirmPbEntryRequest(capable,type,recordnumber,alphaidentifier,phno);
00085         }
00086
00087
00088     private:
00089         AtcDispatcher m_atc_dispatcher;     // main dispatcher for retrieving asynchronous messages
00090
00091 };
00092
00093
00095 #endif  // Asc_AtcHandler_hpp
00096
00097
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtManager.cpp File Reference

Asc/AtManager.cpp File Reference

#include "Asc/PreComp.hpp"
#include "AtManager.hpp"
#include "AtBaseManager.hpp"

Include dependency graph for AtManager.cpp:

Generated on Tue Jan 24 17:13:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtManager.hpp File Reference

Asc/AtManager.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AtManager_hpp

Define Documentation

#define Apoxi_AtManager_hpp

Generated on Tue Jan 24 17:13:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/AtManager.hpp Source File

Asc/AtManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AtManager_hpp)
00010 #define Apoxi_AtManager_hpp
00013
00014 #if defined(APOXI_ENABLE_GENERIC_AT_INTERFACE)
00015
00016 /*  AtManager is able to receive incoming command strings sent via AT. It will
00017     only exist once so it cannot be initialized a second time. If one aims to
00018     listen to a command string it has to register for it. The concept allows
00019     the OnAtCommand() method to be overridden. As a result the deriving object
00020     can handle forwarded AT command strings on its own. */
00021 class AtManager {
00022
00023     public:
00024
00026         BOOLEAN Init(AtManager * obj);
00028         BOOLEAN IsInitialized();
00030         void Reset();
00031
00033         BOOLEAN RegisterAtCommand(const String& str, const INT timeout = 0);
00035         BOOLEAN UnregisterAtCommand(const String& str);
00038         BOOLEAN SplitAtCommand(const String& str, const String& token,
00039             String& cmd_str, String& arg_str);
00041         BOOLEAN SendAtResponse(const String& str, const BOOLEAN final = TRUE);
00042
00044         void SetReceiveAccessoryCommandEnabled(const BOOLEAN enable);
00046         BOOLEAN IsAccessoryRegistrationEnabled();
00048         void SendAccessoryRegistrationResponse(const AtStatusType status,
00049             const BOOLEAN enable);
00051         BOOLEAN SendAccessoryCommand(const String& acc_str);
00052
00053     protected:
00054
00056         virtual BOOLEAN OnAtCommand(const String& str);
00058         virtual BOOLEAN OnAccessoryRegistrationRequest(const BOOLEAN enable);
00059
00060     private:
00061
00063         static BOOLEAN WrapAtCommand(const String& str);
00065         static BOOLEAN WrapAccessoryRegistrationRequest(const BOOLEAN enable);
00067         static AtManager * m_registered_manager;
00068
00069 };
00070
00071 #endif  // APOXI_ENABLE_GENERIC_AT_INTERFACE
00072
00074 #endif  // Apoxi_AtManager_hpp
00075
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BaseHandler.cpp File Reference

Asc/BaseHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "BaseHandler.hpp"
#include "StackMsgDispatcher.hpp"

Include dependency graph for BaseHandler.cpp:

Generated on Tue Jan 24 17:13:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BaseHandler.hpp File Reference

Asc/BaseHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:13:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BaseHandler.hpp Source File

Asc/BaseHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_BaseHandler_hpp)
00011 #define Asc_BaseHandler_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017 #include <Asc/HandlerId.hpp>
00018 #include <Asc/HandlerList.hpp>
00019
00020
00021 class StackMsgDispatcher;
00022 /*  ========================================================================
00023     BaseHandler
00024     ======================================================================== */
00026 class BaseHandler {
00027     friend class HandlerListEntry;
00028     public:
00031         BaseHandler(StackMsgDispatcher *dispatcher = 0);
00033         virtual ~BaseHandler();
00034
00036         virtual HandlerId GetHandlerId() const = 0;
00037
00038     protected:
00040         virtual BOOLEAN Init(MainHandler *main_handler);
00041
00042     private:
00044         BOOLEAN m_initialized;
00046         StackMsgDispatcher *m_dispatcher;       // main dispatcher for retrieving asynchronous messages
00047
00050         BOOLEAN Cleanup();
00051 };
00052
00053
00054 /*  ------------------------------------------------------------------------
00055     CastHandler
00056     ------------------------------------------------------------------------ */
00059 template<class DestHandler> inline void CastHandler(DestHandler &p_handler_to, const BaseHandler *p_handler_from)
00060 {
00061     ASSERT (p_handler_from != 0);
00062
00063     // reset destination handler
00064     p_handler_to = 0;
00065
00066     ASSERT(p_handler_from->GetHandlerId() == DestHandler()->ID);
00067     p_handler_to = (DestHandler) p_handler_from;
00068 }// CastHandler
00069
00070
00071
00072
00074 #endif // Asc_BaseHandler_hpp
00075
00076 #endif //DOXYGEN_SHOULD_SKIP_THIS
00077
00078
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BattHandler.hpp File Reference

Asc/BattHandler.hpp File Reference

#include <Compat/BattHandler.hpp>

Include dependency graph for BattHandler.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 17:13:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BattHandler.hpp Source File

Asc/BattHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ------------------------------------------------------------------------
00004 This document contains proprietary information belonging to COMNEON.
00005 Passing on and copying of this document, use and communication of its
00006 contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008 #if defined(APOXI_COMPILER_MSVC)
00009     #pragma message ("Reference to old BattHandler")
00010 #endif
00011 #include <Compat/BattHandler.hpp>
00012
00013
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BootDispatcher.cpp File Reference

Asc/BootDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "BootDispatcher.hpp"

Include dependency graph for BootDispatcher.cpp:

Generated on Tue Jan 24 17:13:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BootDispatcher.hpp File Reference

Asc/BootDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for BootDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BootDispatcher

Defines

#define | Asc_BootDispatcher_hpp

Define Documentation

#define Asc_BootDispatcher_hpp

Generated on Tue Jan 24 17:13:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BootDispatcher.hpp Source File

Asc/BootDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_BootDispatcher_hpp)
00009 #define Asc_BootDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     BootDispatcher
00019     ======================================================================== */
00021 class BootDispatcher : public StackMsgDispatcher {
00022     typedef StackMsgDispatcher Base;
00023
00024     public:
00026         BootDispatcher();
00028         virtual ~BootDispatcher();
00029
00030     protected:
00032         BOOLEAN OnBootDispatching(const StackMsgArgument &arg);
00033
00034     private:
00035         static const StackMsgArgMap<BootDispatcher> m_arg_map[];
00036         StackMsgArgMapContainer<BootDispatcher> m_arg_map_container;
00037 };
00038
00040 #endif // Asc_BootDispatcher_hpp
00041
00042
Generated on Tue Jan 24 14:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BootHandler.cpp File Reference

Asc/BootHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "BootHandler.hpp"

Include dependency graph for BootHandler.cpp:

Generated on Tue Jan 24 17:14:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BootHandler.hpp File Reference

Asc/BootHandler.hpp File Reference

#include <Apc/SignalTypes.hpp>
#include <Asc/BaseHandler.hpp>
#include <Asc/BootDispatcher.hpp>

Include dependency graph for BootHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BootHandler

Defines

#define | Asc_BootHandler_hpp

Define Documentation

#define Asc_BootHandler_hpp

Generated on Tue Jan 24 17:14:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/BootHandler.hpp Source File

Asc/BootHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_BootHandler_hpp)
00009 #define Asc_BootHandler_hpp
00010
00011 #include <Apc/SignalTypes.hpp>
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/BootDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     BootHandler
00019     ======================================================================== */
00022 class BootHandler : public BaseHandler {
00023     typedef BaseHandler Base;
00024     public:
00025         enum { ID = BootHandlerId };
00026
00028         BootHandler();
00030         virtual ~BootHandler();
00031
00033         virtual HandlerId GetHandlerId() const;
00034
00036         static void RequestOnStartup(INT providerid, BootNotification notification);
00037
00038     private:
00039         BootDispatcher m_boot_dispatcher;       // dispatcher for retrieving asynchronous messages
00040
00041 };
00042
00043 #endif // Asc_BootHandler_hpp
00044
00045
Generated on Tue Jan 24 14:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallBarringHandler.cpp File Reference

Asc/CallBarringHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Asc/InputParserTranslator.hpp>
#include "SsMainHandler.hpp"
#include "CallBarringHandler.hpp"

Include dependency graph for CallBarringHandler.cpp:

Generated on Tue Jan 24 17:14:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallBarringHandler.hpp File Reference

Asc/CallBarringHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/InputParser.hpp>
#include <Asc/SsBaseHandler.hpp>

Include dependency graph for CallBarringHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallBarringHandler
CallBarringHandler is a Supplementary Service handler responsible for activating, deactivating and interrogating the Call Waiting SS. More...

Defines

#define | Asc_CallBarringHandler_hpp

Define Documentation

#define Asc_CallBarringHandler_hpp

Generated on Tue Jan 24 17:14:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallBarringHandler.hpp Source File

Asc/CallBarringHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_CallBarringHandler_hpp)
00011 #define Asc_CallBarringHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/InputParser.hpp>
00016 #include <Asc/SsBaseHandler.hpp>
00017
00018
00039 class CallBarringHandler : public SsBaseHandler {
00042     typedef SsBaseHandler Base;
00043
00044 public:
00048     enum { ID = CallBarringHandlerId };
00049
00051         CallBarringHandler();
00053         virtual ~CallBarringHandler();
00054
00058     virtual HandlerId GetHandlerId() const;
00059
00060 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00061
00077     virtual ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument &arg);
00078 #endif // DOXYGEN_SHOULD_SKIP_THIS
00079
00093     SsApiRc Activate(SsCode ss_code, const WString& pw, ServiceGroup basic_service = AllServices, const WString& override_ss_sequence = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00094
00108     SsApiRc Deactivate(SsCode ss_code, const WString& pw, ServiceGroup basic_service = AllServices, const WString& override_ss_sequence = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00109
00122     SsApiRc RequestStatus(SsCode ss_code, ServiceGroup basic_service = AllServices, const WString& override_ss_sequence = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00123
00139     SsApiRc ChangePassword(const WString& old_pw, const WString& new_pw, const WString& conf_pw, const WString& override_ss_sequence = L"", BOOLEAN register_only = FALSE, BOOLEAN provide_ss_code = TRUE);
00140
00146     SsApiRc SendPassword(Tipd tipd, const WString& password);
00147
00152     SsApiRc AbortPasswordRequest(Tipd tipd);
00153
00154     private:
00155
00165     SsBaseHandler::ReturnCode CreateActivatedMsg(const StackMsgArgument &arg, SsMessage*& msg);
00166
00176     SsBaseHandler::ReturnCode CreateDeactivatedMsg(const StackMsgArgument &arg, SsMessage*& msg);
00177
00189     SsBaseHandler::ReturnCode CreateInterrogateResultMsg(const StackMsgArgument &arg, SsMessage*& msg);
00190
00200     SsBaseHandler::ReturnCode CreatePasswordRegisterMsg(const StackMsgArgument &arg, SsMessage*& msg);
00201
00202
00214     SsBaseHandler::ReturnCode CreateSuccessResultMsg(const SsRetResIndArg &arg, SsMessage*& msg);
00215
00222     SsBaseHandler::ReturnCode CreateGetPasswordMsg(const SsGetPasswordIndArg &arg, SsMessage*& msg);
00223
00235     SsApiRc CheckParameterCodes(InputParser::SsCode ss_code, InputParser::BasicServiceMmiCode mmi_code) const;
00236
00237
00257     SsApiRc ExecuteRequest(SsCode ss_code, SsOperationCode op_code, const WString& pw, ServiceGroup basic_service, const WString& override_ss_sequence, BOOLEAN register_only, LineSelector line = InvalidLine);
00258
00260     SsMessage* m_curr_msg;
00261
00264 //  SsCode m_param_ss_code;
00265
00268 //  ServiceGroup m_param_bs_code;
00269
00272     WString m_param_pw;
00273
00276     WString m_param_new_pw;
00277
00280     WString m_param_conf_pw;
00281 };
00282
00283 #endif // Asc_CallBarringHandler_hpp
00284
00285
Generated on Tue Jan 24 14:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallControlDispatcher.cpp File Reference

Asc/CallControlDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/CallHandlingData.hpp>
#include <Asc/MocVoiceHandler.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "CallControlDispatcher.hpp"

Include dependency graph for CallControlDispatcher.cpp:

Generated on Tue Jan 24 17:14:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallControlDispatcher.hpp File Reference

Asc/CallControlDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:14:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallControlDispatcher.hpp Source File

Asc/CallControlDispatcher.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00010
00011 #if !defined(Asc_CallControlDispatcher_hpp)
00012 #define Asc_CallControlDispatcher_hpp
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Kernel/Message.hpp>
00018
00019 #include <Asc/StackMsgDispatcher.hpp>
00020
00021 class CallControlDispatcher : public StackMsgDispatcher {
00024     typedef StackMsgDispatcher Base;
00025
00026  public:
00031     CallControlDispatcher();
00032
00033     virtual ~CallControlDispatcher();
00034
00035  protected:
00036
00037     BOOLEAN OnCallControlSetupInd(const StackMsgArgument &arg);
00038
00039  private:
00043     static const StackMsgArgMap<CallControlDispatcher> m_arg_map[];
00044
00047     StackMsgArgMapContainer<CallControlDispatcher> m_arg_map_container;
00048 };
00049
00051 #endif // Asc_CallControlDispatcher_hpp
00052
00053 #endif // DOXYGEN_SHOULD_SKIP_THIS
00054
Generated on Tue Jan 24 14:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallControlHandler.cpp File Reference

Asc/CallControlHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallControlHandler.hpp"

Include dependency graph for CallControlHandler.cpp:

Generated on Tue Jan 24 17:14:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallControlHandler.hpp File Reference

Asc/CallControlHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_CallControlHandler_hpp

Define Documentation

#define Asc_CallControlHandler_hpp

Generated on Tue Jan 24 17:14:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallControlHandler.hpp Source File

Asc/CallControlHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_CallControlHandler_hpp)
00011 #define Asc_CallControlHandler_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Asc/BaseHandler.hpp>
00016 #include <Asc/CallControlDispatcher.hpp>
00017
00018 class CallControlHandler : public BaseHandler {
00021     typedef BaseHandler Base;
00022  public:
00026     enum { ID = CallControlHandlerId };
00027
00033     CallControlHandler();
00035     virtual ~CallControlHandler();
00039     virtual HandlerId GetHandlerId() const;
00040
00041  private:
00042     CallControlDispatcher m_cc_dispatcher;
00043
00044 };
00045
00046 #endif // DOXYGEN_SHOULD_SKIP_THIS
00047
00048 #endif // Asc_CallControlHandler_hpp
00049
00050
Generated on Tue Jan 24 14:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDeflectionDispatcher.cpp File Reference

Asc/CallDeflectionDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallDeflectionDispatcher.hpp"
#include "StackIndicationMsgTypes.hpp"

Include dependency graph for CallDeflectionDispatcher.cpp:

Generated on Tue Jan 24 17:14:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDeflectionDispatcher.hpp File Reference

Asc/CallDeflectionDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:14:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDeflectionDispatcher.hpp Source File

Asc/CallDeflectionDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_CallDeflectionDispatcher_hpp)
00011 #define Asc_CallDeflectionDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016
00017 class CallDeflectionDispatcher : public StackMsgDispatcher {
00018     typedef StackMsgDispatcher Base;
00019
00020     public:
00022         CallDeflectionDispatcher();
00024         virtual ~CallDeflectionDispatcher();
00026         void SetDeflectionTipd(Tipd deflection_tipd){ m_Tipd = deflection_tipd; }
00028         Tipd GetDeflectionTipd(){ return m_Tipd; }
00029
00030     protected:
00032         BOOLEAN OnCallDeflectionCnf(const StackMsgArgument &arg);
00034         BOOLEAN OnCallDeflectErrInd(const StackMsgArgument &arg);
00036         BOOLEAN OnCallDeflectRejectInd(const StackMsgArgument &arg);
00037
00038     private:
00040         static const StackMsgArgMap<CallDeflectionDispatcher> m_arg_map[];
00042         StackMsgArgMapContainer<CallDeflectionDispatcher> m_arg_map_container;
00043
00045         Tipd        m_Tipd;
00046
00047 };
00048
00049
00050 #endif  // Asc_CallDeflectionCnfRejDispatcher_hpp
00051
00052 #endif // DOXYGEN_SHOULD_SKIP_THIS
00053
00054
Generated on Tue Jan 24 14:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDeflectionHandler.cpp File Reference

Asc/CallDeflectionHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandler.hpp"
#include "CallDeflectionDispatcher.hpp"
#include "CallDeflectionHandler.hpp"
#include "MtcVoiceDispatcher.hpp"

Include dependency graph for CallDeflectionHandler.cpp:

Generated on Tue Jan 24 17:15:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDeflectionHandler.hpp File Reference

Asc/CallDeflectionHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/CallDeflectionDispatcher.hpp>

Include dependency graph for CallDeflectionHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallDeflectionHandler

Defines

#define | Asc_CallDeflectionHandler_hpp

Define Documentation

#define Asc_CallDeflectionHandler_hpp

Generated on Tue Jan 24 17:15:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDeflectionHandler.hpp Source File

Asc/CallDeflectionHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CallDeflectionHandler_hpp)
00009 #define Asc_CallDeflectionHandler_hpp
00010
00011
00012 #include <Asc/BaseHandler.hpp>
00013 #include <Asc/CallDeflectionDispatcher.hpp>
00014
00015 class CallDeflectionHandler : public BaseHandler {
00016     typedef BaseHandler Base;
00017
00018     public:
00019         enum { ID = CallDeflectionHandlerId };
00020
00021         CallDeflectionHandler();
00022         virtual ~CallDeflectionHandler();
00023         virtual HandlerId GetHandlerId() const;
00024         CallApiRc ProcessCallDeflectRequest(PhoneNumber deflect_number);
00025
00026     private:
00027         CallDeflectionDispatcher m_cd_disp;
00028 };
00029
00030 #endif // Asc_CallDeflectionHandler_hpp
00031
00032
Generated on Tue Jan 24 14:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDispatcher.cpp File Reference

Asc/CallDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallDispatcher.hpp"
#include "CallHandler.hpp"
#include "CallHdl.hpp"
#include "MocVoiceDispatcher.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "TchInterface.hpp"
#include "MtcVoiceAcceptDispatcher.hpp"
#include <Devices/AudioPathManager.hpp>

Include dependency graph for CallDispatcher.cpp:

Generated on Tue Jan 24 17:15:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDispatcher.hpp File Reference

Asc/CallDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:15:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallDispatcher.hpp Source File

Asc/CallDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_CallDispatcher_hpp)
00011 #define Asc_CallDispatcher_hpp
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016 #include <Asc/TipdBasedActiveWaitDispatcher.hpp>
00017 #include <Audio/AudioActiveReference.hpp>
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Asc/Types.hpp>
00020
00027 class CallDispatcher : public StackMsgDispatcher {
00028     typedef StackMsgDispatcher Base;
00029     public:
00031         CallDispatcher();
00032
00034         virtual ~CallDispatcher();
00035
00036
00040         CallErrorCause GetDiscCause() const { return m_call_disc_cause; }
00041
00042
00044         void ResetDiscCause() { m_call_disc_cause = NoCallError; }
00045
00046
00050         BOOLEAN GetMtcIsReady() const { return m_mtc_is_ready; }
00051
00052
00054         void SetMtcReady() { m_mtc_is_ready = TRUE; }
00055
00056
00062         void RegisterActiveWaitDisp(TipdBasedActiveWaitDispatcher * disp) {m_wait_disp = disp;}
00063
00064
00067         void UnregisterActiveWaitDisp() { m_wait_disp = 0; }
00068
00069
00076         BOOLEAN RemoveDisconnectedCall(Tipd tipd, CallErrorCause cause, BOOLEAN msg_required, DisconnectingMode disconnecting_mode = NetWorkDisconnection);
00077
00080         void AbortWaitDispIfEqualTipd(Tipd tipd, TipdBasedActiveWaitDispatcher::AbortCause cause);
00081
00083         BOOLEAN IsEqualWaitDispTipd(Tipd tipd);
00084
00085
00086     protected:
00094         BOOLEAN OnCallDiscInd(const StackMsgArgument &arg);
00095
00096
00104         BOOLEAN OnCallDiscCnf(const StackMsgArgument &arg);
00105
00106
00109         BOOLEAN OnCallRelInd(const StackMsgArgument &arg);
00110
00113         BOOLEAN OnCallRelCnf(const StackMsgArgument &arg);
00114
00123         BOOLEAN OnCallProgressInd(const StackMsgArgument &arg);
00124
00125 #if defined(APOXI_AT_MMI_INTERWORKING_CALL)
00126
00130         BOOLEAN OnCallInd(const StackMsgArgument &arg);
00131 #endif
00132
00138         BOOLEAN OnCallNotify(const StackMsgArgument &arg);
00139
00140
00143         BOOLEAN OnAlertInd(const StackMsgArgument &arg);
00144
00145
00155         BOOLEAN OnMocSetupCnf(const StackMsgArgument &arg);
00156
00163         BOOLEAN OnMocSetupRej(const StackMsgArgument &arg);
00164
00165 #ifdef APOXI_CTM
00166
00167         BOOLEAN OnCtmInfoIndMsg(const StackMsgArgument &arg);
00168 #endif
00169
00170         BOOLEAN OnNwDiscStartInd(const StackMsgArgument &arg);
00171
00173         BOOLEAN OnDiagnosticInd(const StackMsgArgument &arg);
00174
00176         BOOLEAN OnRedialStatusInd(const StackMsgArgument &arg);
00177 #if defined(APOXI_AT_MMI_INTERWORKING_REJECT)
00178
00179         BOOLEAN OnMocSetupRejInd(const StackMsgArgument &arg);
00180 #endif
00181
00182 #if defined(APOXI_AT_MMI_INTERWORKING_SIMTK)
00183
00184         BOOLEAN OnCallIndCallControlInfo(const StackMsgArgument &arg);
00185 #endif
00186     private:
00187         void StopInfoTone();
00188         void StartInfoTone();
00189
00190
00191         static const StackMsgArgMap<CallDispatcher> m_arg_map[];
00192         StackMsgArgMapContainer<CallDispatcher> m_arg_map_container;
00193
00194         BOOLEAN                         m_mtc_is_ready;
00195         CallErrorCause                  m_call_disc_cause;
00196         TipdBasedActiveWaitDispatcher * m_wait_disp;
00197
00198         SharedPtr<AudioActiveReference> m_active_ref;
00199 };
00200
00201
00203 #endif // Asc_CallDispatcher_hpp
00204
00205 #endif //DOXYGEN_SHOULD_SKIP_THIS
00206
00207
Generated on Tue Jan 24 14:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallForwardingHandler.cpp File Reference

Asc/CallForwardingHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Asc/InputParserTranslator.hpp>
#include "CallForwardingHandler.hpp"
#include "SsMainHandler.hpp"

Include dependency graph for CallForwardingHandler.cpp:

Generated on Tue Jan 24 17:15:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallForwardingHandler.hpp File Reference

Asc/CallForwardingHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Asc/SsBaseHandler.hpp>
#include <Asc/InputParser.hpp>

Include dependency graph for CallForwardingHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallForwardingHandler

Defines

#define | Asc_CallForwardingHandler_hpp

Define Documentation

#define Asc_CallForwardingHandler_hpp

Generated on Tue Jan 24 17:15:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallForwardingHandler.hpp Source File

Asc/CallForwardingHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_CallForwardingHandler_hpp)
00011 #define Asc_CallForwardingHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Auxiliary/PhoneNumber.hpp>
00016
00017 #include <Asc/SsBaseHandler.hpp>
00018 #include <Asc/InputParser.hpp>
00019
00035 class CallForwardingHandler : public SsBaseHandler {
00038     typedef SsBaseHandler Base;
00039
00040  public:
00044     enum { ID = CallForwardingHandlerId };
00045
00048     CallForwardingHandler();
00049
00053     virtual HandlerId GetHandlerId() const;
00054
00067     SsApiRc Deactivate(SsCode ss_code, ServiceGroup basic_service = AllServices, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00068
00081     SsApiRc Register(SsCode ss_code, const PhoneNumber &number, UINT time_out = 0, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00082
00097     SsApiRc Register(SsCode ss_code, ServiceGroup basic_service, const PhoneNumber &number, UINT time_out = 0, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00098
00113     SsApiRc Activate(SsCode ss_code, ServiceGroup basic_service, const PhoneNumber &number, UINT time_out = 0, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00114
00127     SsApiRc Activate(SsCode ss_code, const PhoneNumber &number, UINT time_out = 0, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00128
00142     SsApiRc Activate(SsCode ss_code, ServiceGroup basic_service = AllServices, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00143
00156     SsApiRc Erase(SsCode ss_code, ServiceGroup basic_service = AllServices, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00157
00170     SsApiRc RequestStatus(SsCode ss_code, ServiceGroup basic_service = AllServices, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00171
00172
00173  protected:
00189     virtual ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument &arg);
00190
00191
00192  private:
00193
00211     SsApiRc CheckParameterCodes(InputParser::SsCode ss_code, InputParser::BasicServiceMmiCode mmi_code) const;
00212
00235     SsApiRc ExecuteRequest(SsOperationCode op_code, SsCode ss_code,
00236                            ServiceGroup basic_service, const PhoneNumber *number=0, UINT time_out=0, const WString override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00237
00250     SsBaseHandler::ReturnCode CreateRegisteredMsg(const SsForwardingIndArg &arg, SsMessage*& msg) const;
00251
00267     SsBaseHandler::ReturnCode CreateRegisteredMsg(const SsDataIndArg &arg, SsMessage*& msg) const;
00268
00281     SsBaseHandler::ReturnCode CreateErasedMsg(const SsForwardingIndArg &arg, SsMessage*& msg) const;
00282
00298     SsBaseHandler::ReturnCode CreateErasedMsg(const SsDataIndArg &arg, SsMessage*& msg) const;
00299
00312     SsBaseHandler::ReturnCode CreateActivatedMsg(const SsForwardingIndArg &arg, SsMessage*& msg) const;
00313
00328     SsBaseHandler::ReturnCode CreateActivatedMsg(const SsDataIndArg &arg, SsMessage*& msg) const;
00329
00342     SsBaseHandler::ReturnCode CreateDeactivatedMsg(const SsForwardingIndArg &arg, SsMessage*& msg) const;
00343
00358     SsBaseHandler::ReturnCode CreateDeactivatedMsg(const SsDataIndArg &arg, SsMessage*& msg) const;
00359
00372     SsBaseHandler::ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg) const;
00373
00385     SsBaseHandler::ReturnCode CreateSuccessResultMsg(const SsRetResIndArg &arg, SsMessage*& msg);
00386
00397 //    SsCode GetSsCode(Tipd tipd) const { return m_param_ss_code; }
00398
00409 //    ServiceGroup GetBasicServiceCode(Tipd tipd) const { return m_param_basic_service_code; }
00410
00421     const PhoneNumber& GetPhoneNumber(Tipd tipd) const;
00422
00433     UINT GetTimeOut(Tipd tipd) const;
00434
00440     BOOLEAN CheckStatus(const SsInterrogateIndArg &arg) const;
00441
00455     BOOLEAN CheckSsCode(const ForwardingInfo &info) const;
00456
00468     void FillList(const ForwardingInfo &info, Vector<ForwardingFeature> &tha_list, const UINT8 count) const;
00469
00479     INT CountList(const InterrogateSsResult &result, UINT8 status1, UINT8 status2) const;
00480
00488     INT CountList(const ForwardingInfo &info, UINT8 status) const;
00489
00492 //    SsCode m_param_ss_code;
00493
00496 //    ServiceGroup m_param_basic_service_code;
00497
00500     PhoneNumber m_phone_number;
00501
00504     UINT m_time_out;
00505 };
00506
00507 #endif // Asc_CallForwardingHandler_hpp
00508
00509
Generated on Tue Jan 24 14:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHandler.cpp File Reference

Asc/CallHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CrssDispatcher.hpp"
#include "CallHandler.hpp"
#include "CallReleaseDispatcher.hpp"

Include dependency graph for CallHandler.cpp:

Generated on Tue Jan 24 17:15:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHandler.hpp File Reference

Asc/CallHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/CallDispatcher.hpp>
#include <Asc/DtmfDispatcher.hpp>

Include dependency graph for CallHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallHandler

Defines

#define | Asc_CallHandler_hpp

Define Documentation

#define Asc_CallHandler_hpp

Generated on Tue Jan 24 17:15:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHandler.hpp Source File

Asc/CallHandler.hpp

Go to the documentation of this file.
00001     /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CallHandler_hpp)
00009 #define Asc_CallHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/CallDispatcher.hpp>
00016 #include <Asc/DtmfDispatcher.hpp>
00017
00018
00019 enum CallApiRc;
00020
00025 class CallHandler : public BaseHandler {
00026     typedef BaseHandler Base;
00027     public:
00028         enum { ID = CallHandlerId };
00029
00031         CallHandler();
00033         virtual ~CallHandler();
00034
00036         virtual HandlerId GetHandlerId() const;
00037
00042         CallDispatcher * GetCallDispatcher() { return &m_call_disp; }
00043
00044
00049         DtmfDispatcher * GetDtmfDispatcher() { return &m_dtmf_disp; }
00050
00051
00059 #if defined(APOXI_SYNC_RELEASE)
00060         CallApiRc Release(CallIndex call_index, UINT32 & call_duration, CallErrorCause cause, BOOLEAN wait_condition = TRUE);
00061 #else
00062         CallApiRc Release(CallIndex call_index, UINT32 & call_duration, CallErrorCause cause, BOOLEAN wait_condition = FALSE);
00063 #endif
00064
00065
00070         CallApiRc StartDtmfToneGeneration(CallIndex idx, KeyCode key);
00071
00072
00076         CallApiRc StopDtmfToneGeneration(CallIndex idx);
00077
00078
00084         static CallApiRc RejectAllMtc(BOOLEAN activate);
00085
00091         static CallApiRc RejectAllMoc(BOOLEAN activate);
00092
00094         static void ClearBlacklist();
00095
00096
00102         static void SetMnRediallingEnabled(BOOLEAN action);
00103
00106         static void RequestRedialStatus();
00107
00108 #if !defined(APOXI_PLATFORM_BP30)
00109
00110
00117         static BOOLEAN SetDefaultClirMode(ClirMode clir_mode);
00118
00120
00127         static BOOLEAN GetDefaultClirMode(ClirMode &clir_mode);
00128
00130
00137         static BOOLEAN SetDefaultCugInfo(const CugDescriptor& cug_desc);
00138
00140
00147         static BOOLEAN GetDefaultCugInfo(CugDescriptor& cug_desc);
00148
00149 #endif // !APOXI_PLATFORM_BP30
00150
00151     private:
00152         static CallApiRc RejectAllCalls(BOOLEAN activate, CallRefuseDirection direction);
00153
00154         CallDispatcher  m_call_disp;
00155         DtmfDispatcher  m_dtmf_disp;
00156 };
00157
00159 #endif // Asc_CallHandler_hpp
00160
00161
Generated on Tue Jan 24 14:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHandlingData.cpp File Reference

Asc/CallHandlingData.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandlingData.hpp"

Include dependency graph for CallHandlingData.cpp:

Generated on Tue Jan 24 17:15:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHandlingData.hpp File Reference

Asc/CallHandlingData.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_CallHandlingData_hpp

Define Documentation

#define Asc_CallHandlingData_hpp

Generated on Tue Jan 24 17:16:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHandlingData.hpp Source File

Asc/CallHandlingData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CallHandlingData_hpp)
00009 #define Asc_CallHandlingData_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Asc/Types.hpp>
00016 #include <Apc/SignalTypes.hpp>
00017 #include <Apc/SimDataTypes.hpp>
00018
00020 enum ChannelState {
00022     NoCall ,
00024     ActiveCall,
00026     HeldCall,
00028     SetupCall
00029     } ;
00030
00031
00037 class CallInstance {
00038     public:
00040         CallInstance();
00041
00043         ~CallInstance();
00044
00046         Tipd GetTipd() const { return m_tipd; }
00047
00049         void SetTipd(Tipd tipd) { m_tipd = tipd; }
00050
00052         CallType GetType() const { return m_type; }
00053
00055         void SetType(CallType type) { m_type = type; }
00056
00058         UINT32 GetStartTime() const { return m_start_time_in_sec; }
00059
00061         void SetStartTime(UINT32 abs_sec) { m_start_time_in_sec = abs_sec; }
00062
00064         void SetStartTic(Ticks start_tic) { m_start_tic = start_tic; }
00065
00067         const Ticks & GetStartTic() const { return m_start_tic; }
00068
00070         PhoneNumber & GetPhoneNo() { return m_dialled_phone_no; }
00071
00073         void SetPhoneNo(const PhoneNumber & phone_no) { m_dialled_phone_no = phone_no; }
00074
00076         // Author: rre (17.03.2003)
00077         LineSelector GetCallLine() const { return m_call_line; }
00078
00080         // Author: rre (17.03.2003)
00081         void SetCallLine(LineSelector call_line) { m_call_line = call_line; }
00082
00084         // Author: rre (12.09.2003)
00085         Application* GetRelatedApp() const { return m_related_app; }
00086
00088         // Author: rre (12.09.2003)
00089         void SetRelatedApp(Application* app) { m_related_app = app; }
00090
00092         CallRelatedSsCode GetSsCode() const { return m_ss_code; }
00093
00095         void SetSsCode (CallRelatedSsCode code) { m_ss_code = code; }
00096
00098         GsmSignal GetGsmSignal() const { return m_gsm_signal; }
00099
00101         void SetGsmSignal(GsmSignal signal) { m_gsm_signal = signal; }
00102
00104         const PhoneNumber * GetConnectedToNo() const { return m_connected_to_no_p; }
00106         void SetConnectedToNo(PhoneNumber * no_p) { m_connected_to_no_p = no_p; }
00107
00108 #ifdef APOXI_CTM
00109         void SetCtm(BOOLEAN ctm){ m_ctm = ctm;}
00110         BOOLEAN GetCtm(){return m_ctm;}
00111 #endif
00112
00113         void SetEstablishCause(CallEstCause est_cause){m_est_cause = est_cause;}
00114         CallEstCause GetEstablishCause(){ return m_est_cause;}
00115
00117         BOOLEAN GetDisconnectingSent() const {return m_disconnecting_sent; }
00118
00120         void SetDisconnectingSent(BOOLEAN disconnecting_sent) { m_disconnecting_sent = disconnecting_sent; }
00121
00123         void SetActiveRelease(BOOLEAN active_release) { m_active_release = active_release; }
00124
00125         BOOLEAN IsActiveRelease(){ return m_active_release; }
00126
00128         BOOLEAN GetSetupIndArrived(){ return m_setup_ind_arrived; }
00129
00131         void SetSetupIndArrived(BOOLEAN setup_ind_arrived = TRUE){ m_setup_ind_arrived = setup_ind_arrived; }
00132
00134         ClirMode GetClirMode() { return m_clir_mode; }
00135
00137         void SetClirMode(ClirMode clir_mode) { m_clir_mode = clir_mode; }
00138
00140         void SetEccCategory(EccCategory ecc_category) { m_ecc_category = ecc_category; }
00141
00143         EccCategory GetEccCategory() { return m_ecc_category; }
00144
00146         void SetCallControlPerformed(BOOLEAN call_control_performed) {m_call_control_performed = call_control_performed; }
00147
00149         BOOLEAN IsCallControlPerformed() { return m_call_control_performed; }
00150
00152         void SetCallControlResult(SimCallControlResult call_control_result) {m_call_control_result = call_control_result; }
00153
00155         SimCallControlResult GetCallControlResult() {return m_call_control_result; }
00156
00158         void SetAlphaIdentifier(SimAlphaIdentifier alpha_identifier) {m_alpha_identifier = alpha_identifier; }
00159
00161         SimAlphaIdentifier GetAlphaIdentifier() {return m_alpha_identifier; }
00162
00163
00164     private:
00165         Tipd                m_tipd;
00166         CallType            m_type;
00167         UINT32              m_start_time_in_sec;
00168         Ticks               m_start_tic;
00169         CallRelatedSsCode   m_ss_code;
00170         GsmSignal           m_gsm_signal;
00171         PhoneNumber         m_dialled_phone_no;
00172         PhoneNumber *       m_connected_to_no_p;
00173         // Author: rre (17.03.2003) value for speech line or auxiliary speech line
00174         LineSelector        m_call_line;
00175 #ifdef APOXI_CTM
00176         BOOLEAN         m_ctm;
00177 #endif
00178         Application *       m_related_app;
00179         BOOLEAN             m_disconnecting_sent;
00180
00181         CallEstCause        m_est_cause;
00182
00183         BOOLEAN             m_setup_ind_arrived;
00184         BOOLEAN             m_active_release;
00185
00186         ClirMode            m_clir_mode;
00187
00188         EccCategory         m_ecc_category;
00189
00190         BOOLEAN                 m_call_control_performed;
00191         SimCallControlResult    m_call_control_result;
00192         SimAlphaIdentifier      m_alpha_identifier;
00193 };
00194
00195
00203 class ChannelInstance {
00204     public:
00206         ChannelInstance();
00207
00209         ~ChannelInstance();
00210
00223         CallIndex GetCallIndex(INT pos) const { return m_call_indices[pos]; }
00224
00234         void SetCallIndex(INT pos, CallIndex call_index) { m_call_indices[pos] = call_index; }
00235
00237         ChannelState GetState() const { return m_state; }
00238
00240         void SetState(ChannelState state) { m_state = state; }
00241
00243         BOOLEAN GetMptyFlag() const { return m_is_mpty; }
00244
00246         void SetMptyFlag(BOOLEAN mpty) { m_is_mpty = mpty; }
00247
00248
00250         INT GetCallIndexPos(CallIndex call_index) const;
00251
00253         CallIndex const * GetCallIndices() const { return m_call_indices; }
00254
00256         CallIndex GetFirstCallIndex() const;
00257
00258     private:
00259         CallIndex       m_call_indices[c_max_mpty_members];
00260         ChannelState    m_state;
00261         BOOLEAN         m_is_mpty;
00262
00263 };
00264
00265 #endif // DOXYGEN_SHOULD_SKIP_THIS
00266
00274 class CallHandlingData {
00275     public:
00276
00277 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00278
00282         CallHandlingData();
00283
00285         virtual  ~CallHandlingData();
00286
00287
00288
00290         UINT32 GetMptyCallStartTime() { return m_mpty_call_start_time; }
00291
00292
00294         void SetMptyCallStartTime(UINT32 sec) { m_mpty_call_start_time = sec; }
00295
00297         void SetRequestedMocIndex(CallIndex idx) { m_requested_moc_index = idx; }
00298
00299
00304         CallIndex RequestNextMocIndex();
00305
00310         void InsertRequestedMoc(CallIndex call_index, Tipd tipd);
00311
00312
00316         void InsertWaitingMtc(Tipd tipd);
00317
00318
00325         void SetMtcWaiting(Tipd tipd);
00326
00327
00331         void SetCallActive(CallIndex call_index);
00332
00333
00337         void SetCallHold(CallIndex call_index);
00338
00339 #endif // DOXYGEN_SHOULD_SKIP_THIS
00340
00345         BOOLEAN IsActiveCall(CallIndex call_index) const;
00346
00347
00352         BOOLEAN IsHeldCall(CallIndex call_index) const;
00353
00354
00358         BOOLEAN IsInSetupCallIndex(CallIndex call_index) const;
00359
00360
00362         BOOLEAN IsMtc(CallIndex call_index) const;
00363
00364 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00365
00372         UINT32 CleanUpCallData(CallIndex call_index);
00373
00378         Tipd GetTipd(CallIndex call_index) const;
00379
00382         CallIndex GetCallIndexByTipd(Tipd tipd) const;
00383
00385         CallIndex GetActiveCallIndex() const;
00386
00388         CallIndex GetHeldCallIndex() const;
00389
00391         CallIndex GetSetupCallIndex() const;
00392
00394         CallIndex GetRequestedCallIndex() const { return m_requested_moc_index; };
00395
00397         ChannelNo GetMptyChannelNo() const;
00398
00400         CallIndex GetMptyCallIndex() const;
00401
00402 #endif // DOXYGEN_SHOULD_SKIP_THIS
00403
00408         BOOLEAN IsSpeechCall(CallIndex call_index) const;
00409
00410
00413         BOOLEAN IsMptyCall(CallIndex call_index) const;
00414
00415
00417         BOOLEAN IsActiveMpty(ChannelNo channel_no) const;
00418
00420         BOOLEAN IsHeldMpty(ChannelNo channel_no) const;
00421
00422 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00423
00424         INT CountMptyMembers(ChannelNo channel_no) const;
00425
00426
00428         const CallIndex* GetMptyMembers() const;
00429
00431         void SaveStartTime(CallIndex call_index);
00432
00433
00435         UINT32 GetCallConnectionTime(CallIndex call_index) const;
00436
00437
00442         CallInstance & GetCallInstance(CallIndex call_index) { return m_call_instances[call_index]; }
00443
00444
00452         void JoinCalls();
00453
00461         void SplitMpty(CallIndex call_index);
00462
00463
00464         // --------------------------------------------------------------------
00465         // PreAction checks
00466         // --------------------------------------------------------------------
00467
00469         CallApiRc CheckMocRestrictions() const;
00470
00472         CallApiRc CheckAcceptRestrictions(CallIndex call_index) const;
00473
00475         CallApiRc CheckHoldRestrictions(CallIndex call_index) const;
00476
00478         CallApiRc CheckRetrieveRestrictions(CallIndex call_index) const;
00479
00481         CallApiRc CheckSwapCallsRestrictions() const;
00482
00484         CallApiRc CheckJoinCallsRestrictions() const;
00485
00487         CallApiRc CheckSplitMptyRestrictions(CallIndex call_index) const;
00488
00490         CallApiRc CheckDtmfRestrictions(CallIndex call_index) const;
00491
00493         CallApiRc CheckEctRestrictions(CallIndex call_index) const;
00494
00496         CallApiRc CheckDataCallRestrictions() const;
00497 #endif // DOXYGEN_SHOULD_SKIP_THIS
00498
00500         BOOLEAN ActiveCallExists() const;
00501
00503         BOOLEAN HeldCallExists() const;
00504
00506         BOOLEAN CallInSetupExists() const;
00507
00509         Tipd GetSsTipd() const { return m_ss_tipd; }
00510
00511 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00512
00513         void SetSsTipd(Tipd tipd) { m_ss_tipd = tipd; }
00514
00516         BOOLEAN IsSsPending() { return m_ss_pending; }
00518         void SetSsPending(BOOLEAN pending) { m_ss_pending = pending; }
00519
00520         //
00521         BOOLEAN IsSimSsPending() { return m_sim_ss_pending; }
00523         void SetSimSsPending(BOOLEAN pending) { m_sim_ss_pending = pending; }
00524
00526         BOOLEAN IsDataCallActive() const { return m_data_call_active; }
00528         void SetDataCallActive(BOOLEAN active) { m_data_call_active = active; }
00529
00531         INT GetCallCount() const;
00532
00534         BOOLEAN IsDisconnectingSent(CallIndex call_index) { return m_call_instances[call_index].GetDisconnectingSent(); }
00535
00537         void SetDisconnectingSent(CallIndex call_index) { m_call_instances[call_index].SetDisconnectingSent(TRUE); }
00538
00540         void SetActiveRelease(CallIndex call_index) { m_call_instances[call_index].SetActiveRelease(TRUE); }
00541
00543         BOOLEAN IsActiveRelease(CallIndex call_index) { return m_call_instances[call_index].IsActiveRelease(); }
00544
00545
00546 #endif // DOXYGEN_SHOULD_SKIP_THIS
00547
00548         static CallErrorCause GetLastMnError() {return m_last_mn_error; }
00549 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00550
00551         static void SetLastMnError(CallErrorCause code) { m_last_mn_error = code; }
00552
00553 #if !defined(NO_CALL_DEBUG)
00554
00555         const ChannelInstance * GetChannels() const {return &m_channels[0]; }
00556 #endif // NO_CALL_DEBUG
00557
00559         void SetMptyStartTic(Ticks start_tic) { m_mpty_call_start_tic = start_tic; }
00560
00562         const Ticks & GetMptyStartTic() const { return m_mpty_call_start_tic; }
00563
00564     private:
00566         ChannelNo GetChannelNo(CallIndex call_index) const;
00568         ChannelNo GetActiveChannelNo() const;
00570         CallIndex GetNextFreeCallIndex(BOOLEAN mtc_call_index) const;
00572         CallIndex RequestNextMtcIndex();
00574         void InsertNewCall(CallIndex call_index, Tipd tipd);
00576         void CleanUpCallInstance(CallIndex call_index);
00578         void ClearChannel(ChannelNo channel_no);
00580         void RemoveCall(CallIndex call_index);
00581
00583         UINT32          m_mpty_call_start_time; // in absolute seconds
00585         CallIndex       m_requested_moc_index;
00587         CallIndex       m_waiting_mtc_index;
00589         CallInstance    m_call_instances[c_max_calls];
00591         ChannelInstance m_channels[c_max_channels];
00593         Tipd            m_ss_tipd;
00595         BOOLEAN         m_ss_pending;
00597         BOOLEAN         m_sim_ss_pending;
00599         BOOLEAN         m_data_call_active;
00601         static CallErrorCause   m_last_mn_error;
00602
00603         Ticks           m_mpty_call_start_tic;
00604 };
00605
00606 #endif // DOXYGEN_SHOULD_SKIP_THIS
00607
00609 #endif  // Asc_CallHandlingData_hpp
00610
Generated on Tue Jan 24 14:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHdl.cpp File Reference

Asc/CallHdl.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandler.hpp"
#include "Asc/CallHdl.hpp"
#include "CrssHandler.hpp"
#include "MocVoiceHandler.hpp"
#include "MtcVoiceHandler.hpp"
#include "AocHandler.hpp"

Include dependency graph for CallHdl.cpp:

Generated on Tue Jan 24 17:16:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHdl.hpp File Reference

Asc/CallHdl.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Asc/CallHdlBase.hpp>
#include <Apc/SimDataTypes.hpp>

Include dependency graph for CallHdl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallHdl

Defines

#define | Asc_CallHdl_hpp

Define Documentation

#define Asc_CallHdl_hpp

Generated on Tue Jan 24 17:16:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHdl.hpp Source File

Asc/CallHdl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CallHdl_hpp)
00009 #define Asc_CallHdl_hpp
00012
00013 #include <Kernel/Os/Os.hpp>
00014
00015 #include <Asc/CallHdlBase.hpp>
00016 #include <Apc/SimDataTypes.hpp>
00017
00018 class CallHandler;
00019 // enum CallApiRc;
00020 struct MptyMembers;
00021
00039 class CallHdl : public CallHdlBase {
00040     typedef CallHdlBase Base;
00041
00042     public:
00043
00044         //---------------------------------------------------------------------
00045         // Construction, destruction initialization
00046         //---------------------------------------------------------------------
00047
00052         explicit CallHdl(CallIndex call_index = c_null_call_index);
00053
00055         virtual ~CallHdl();
00056
00057         // --------------------------------------------------------------------
00058         // providing CallHdls for active, held and setup call
00059         // --------------------------------------------------------------------
00060
00065         static CallHdl GetActiveCallHdl();
00066
00067
00072         static CallHdl GetHeldCallHdl();
00073
00074
00078         static CallHdl GetSetupCallHdl();
00079
00080
00081         // --------------------------------------------------------------------
00082         // call related operations on CallHdl
00083         // --------------------------------------------------------------------
00084
00085
00122         CallApiRc Setup(const PhoneNumber & phone_no,
00123                         ClirMode clir_mode = DontCare,
00124                         BOOLEAN redial = FALSE,
00125                         const CugDescriptor * cug = 0,
00126                         LineSelector call_line = Line1,
00127                         BOOLEAN ctm = FALSE,
00128                         CallEstCause est_cause = HalfTchSpeech,
00129                         const EccCategory * ecc_category = 0);
00130
00131
00144         CallApiRc SetupAndRedial(const PhoneNumber & phone_no,
00145                                  ClirMode clir_mode = DontCare,
00146                                  const CugDescriptor * cug = 0,
00147                                  LineSelector call_line = Line1,
00148                                  BOOLEAN ctm = FALSE,
00149                                  CallEstCause est_cause = HalfTchSpeech,
00150                                  const EccCategory * ecc_category = 0);
00151
00152
00162         CallApiRc Accept();
00163
00164
00173         CallApiRc SendAlertInd();
00174
00175
00189 #if defined(APOXI_SYNC_RELEASE)
00190         virtual CallApiRc Release(TimeSpan * calling_time = 0, BOOLEAN wait_condition = TRUE);
00191 #else
00192         virtual CallApiRc Release(TimeSpan * calling_time = 0, BOOLEAN wait_condition = FALSE);
00193 #endif
00194
00201 #if defined(APOXI_SYNC_RELEASE)
00202         CallApiRc Reject(ClearCause cause = SubscriberBusy, BOOLEAN wait_condition = TRUE);
00203 #else
00204         CallApiRc Reject(ClearCause cause = SubscriberBusy, BOOLEAN wait_condition = FALSE);
00205 #endif
00206
00207
00216         virtual CallApiRc Hold();
00217
00218
00227         virtual CallApiRc Retrieve();
00228
00229
00238         virtual CallApiRc StartDtmfToneGeneration(KeyCode key);
00239
00240
00243         virtual CallApiRc StopDtmfToneGeneration();
00244
00245
00251         static void CancelRedialling();
00252
00253
00271         CallApiRc ExplicitCallTransfer();
00272
00273
00279         CallApiRc GetCurrentCallMeter();
00280
00281
00288         CallApiRc GetCurrentChargeData();
00289
00290
00291         // --------------------------------------------------------------------
00292         // access to miscellaneous call data
00293         // --------------------------------------------------------------------
00294
00303         const PhoneNumber & GetPhoneNumber() const;
00304
00313         const PhoneNumber & GetConnectedToPhoneNumber() const;
00314
00323         CallRelatedSsCode GetSsCode() const;
00324
00325
00334         GsmSignal GetGsmSignal() const;
00335
00336
00342         virtual DateTime GetStartTime() const;
00343
00344
00345         // --------------------------------------------------------------------
00346         // general information of call referred by a CallHdl
00347         // --------------------------------------------------------------------
00348
00351         virtual BOOLEAN IsActive() const;
00352
00353
00356         virtual BOOLEAN IsHeld() const;
00357
00358
00361         BOOLEAN IsInSetup() const;
00362
00363
00368         BOOLEAN IsSame(const CallHdl & call) const;
00369
00370
00375         virtual BOOLEAN IsValid() const { return m_call_index != c_null_call_index &&
00376                                                  m_call_index < (CallIndex)c_max_calls; }
00377
00378
00381         BOOLEAN IsMptyMember() const;
00382
00383
00386         BOOLEAN IsMobileOriginated() const;
00387
00388
00391         BOOLEAN IsMobileTerminated() const;
00392
00393
00394         // --------------------------------------------------------------------
00395         // misc
00396         // --------------------------------------------------------------------
00397
00399         BOOLEAN IsSetupPermitted() const;
00400
00402         BOOLEAN IsAcceptPermitted() const;
00403
00405         virtual BOOLEAN IsHoldPermitted()const;
00406
00408         virtual BOOLEAN IsRetrievePermitted() const;
00409
00413         BOOLEAN IsExplicitCallTransferPermitted() const;
00414
00416         BOOLEAN IsStartDtmfToneGenerationPermitted() const;
00417
00419         virtual void Invalidate() { m_call_index = c_null_call_index; }
00420
00422         virtual CallIndex GetCallIndex() const { return m_call_index; }
00423
00424         //Madhavi added for ALS on 1st Aug. 2003 begins
00425         LineSelector GetCallLine() const;
00426         //Madhavi added ends
00427
00429         CallType GetCallType() const;
00430
00438         virtual TimeSpan GetCallDuration() const;
00439
00440 #ifdef APOXI_CTM
00441
00442         BOOLEAN GetCtm() const;
00443 #endif
00444
00445         CallEstCause GetEstablishCause() const;
00446
00448         ClirMode GetClirMode() const;
00449
00451         EccCategory GetEccCategory() const;
00452
00454         BOOLEAN IsCallControlPerformed() const;
00455
00457         SimCallControlResult GetCallControlResult() const;
00458
00460         SimAlphaIdentifier GetAlphaIdentifier() const;
00461
00462     private:
00463         CallIndex   m_call_index;
00464 };
00465
00467 #endif // Asc_CallHdl_hpp
00468
Generated on Tue Jan 24 14:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHdlBase.cpp File Reference

Asc/CallHdlBase.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandler.hpp"
#include "CallHdlBase.hpp"
#include "CrssHandler.hpp"
#include "AocHandler.hpp"

Include dependency graph for CallHdlBase.cpp:

Generated on Tue Jan 24 17:16:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHdlBase.hpp File Reference

Asc/CallHdlBase.hpp File Reference

#include <Asc/Types.hpp>
#include <Auxiliary/TimeSpan.hpp>
#include <Auxiliary/DateTime.hpp>

Include dependency graph for CallHdlBase.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallHdlBase

Defines

#define | Asc_CallHdlBase_hpp

Define Documentation

#define Asc_CallHdlBase_hpp

Generated on Tue Jan 24 17:16:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallHdlBase.hpp Source File

Asc/CallHdlBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CallHdlBase_hpp)
00009 #define Asc_CallHdlBase_hpp
00012
00013
00014 // #define NO_CALL_DEBUG
00015
00016 #include <Asc/Types.hpp>
00017 #include <Auxiliary/TimeSpan.hpp>
00018 #include <Auxiliary/DateTime.hpp>
00019
00025 class CallHdlBase {
00026
00027     public:
00028
00029         //---------------------------------------------------------------------
00030         // Construction, destruction
00031         //---------------------------------------------------------------------
00032
00034         CallHdlBase();
00035
00037         virtual ~CallHdlBase();
00038
00039
00040         // --------------------------------------------------------------------
00041         // call related operations on CallHdl
00042         // --------------------------------------------------------------------
00043
00045 #if defined(APOXI_SYNC_RELEASE)
00046         virtual CallApiRc Release(TimeSpan * calling_time = 0, BOOLEAN wait_condition = TRUE) = 0;
00047 #else
00048         virtual CallApiRc Release(TimeSpan * calling_time = 0, BOOLEAN wait_condition = FALSE) = 0;
00049 #endif
00050
00051
00054         static CallApiRc ReleaseAllActiveCalls();
00055
00056
00059         static CallApiRc ReleaseAllHeldCalls();
00060
00061
00069         static void ReportCurrentCallMeter(BOOLEAN activate);
00070
00071
00079         static void ReportCurrentCharge(BOOLEAN activate);
00080
00081
00098         virtual CallApiRc Swap();
00099
00100
00111         virtual CallApiRc Join();
00112
00114         virtual BOOLEAN IsActive() const = 0;
00115
00117         virtual BOOLEAN IsHeld() const = 0;
00118
00120         virtual BOOLEAN IsValid() const = 0;
00121
00122
00127         virtual DateTime GetStartTime() const = 0;
00128
00137         virtual TimeSpan GetCallDuration() const = 0;
00138
00147         virtual CallApiRc StartDtmfToneGeneration(KeyCode key){return UnexpectedResult;}
00148
00151         virtual CallApiRc StopDtmfToneGeneration(){return UnexpectedResult;}
00152
00153         // --------------------------------------------------------------------
00154         // misc
00155         // --------------------------------------------------------------------
00156
00158         virtual BOOLEAN IsHoldPermitted() const = 0;
00159
00161         virtual BOOLEAN IsRetrievePermitted() const = 0;
00162
00164         BOOLEAN IsSwapPermitted() const;
00165
00167         BOOLEAN IsJoinPermitted() const;
00168
00176         static CallApiRc RejectAllMtc(BOOLEAN activate);
00177
00185         static CallApiRc RejectAllMoc(BOOLEAN activate);
00186
00190         static void ClearBlacklist();
00191
00195         static void SetRediallingEnable(BOOLEAN action);
00196
00198         virtual void Invalidate() = 0;
00199
00201         virtual CallIndex GetCallIndex() const = 0;
00202
00208         static INT GetCallCount();
00209
00210
00211
00212         static CallErrorCause ReadLastMnCause();
00213 #if !defined(NO_CALL_DEBUG)
00214         static WString & GetStatusString();
00215
00216         static WString m_status_string;
00217
00218 #endif // NO_CALL_DEBUG
00219
00220 };
00221
00223 #endif // Asc_CallHdlBase_hpp
00224
00225
Generated on Tue Jan 24 14:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallReleaseDispatcher.cpp File Reference

Asc/CallReleaseDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "TipdBasedActiveWaitDispatcher.hpp"
#include "CallReleaseDispatcher.hpp"

Include dependency graph for CallReleaseDispatcher.cpp:

Generated on Tue Jan 24 17:16:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallReleaseDispatcher.hpp File Reference

Asc/CallReleaseDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:16:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallReleaseDispatcher.hpp Source File

Asc/CallReleaseDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_CallReleaseDispatcher_hpp)
00011 #define Asc_CallReleaseDispatcher_hpp
00014
00015 // #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00016 #include <Asc/TipdBasedActiveWaitDispatcher.hpp>
00017 #include <Auxiliary/LinkedList.hpp>
00018 #include <Asc/CallDispatcher.hpp>
00019
00020
00021 /*  ========================================================================
00022     TipdList
00023     ======================================================================== */
00024 class LinkableTipd : public Linkable<LinkableTipd> {
00025     public:
00026         LinkableTipd(const Tipd tipd) : m_tipd(tipd) {}
00027         Tipd GetTipd() const { return m_tipd; }
00028     private:
00029         Tipd m_tipd;
00030 };
00031
00032 /*  ========================================================================
00033     TipdList
00034     ======================================================================== */
00035 typedef LinkedList<LinkableTipd> TipdList;
00036
00037
00043 class CallReleaseDispatcher : public TipdBasedActiveWaitDispatcher {
00044     typedef TipdBasedActiveWaitDispatcher Base;
00045     public:
00047         CallReleaseDispatcher(Tipd tipd, CallDispatcher* call_disp);
00048
00050         CallReleaseDispatcher(TipdList* tipd_list, CallDispatcher* call_disp);
00051
00053         virtual ~CallReleaseDispatcher();
00054
00055     protected:
00056
00064         BOOLEAN OnCallRelCnf(const StackMsgArgument &arg);
00065
00073         BOOLEAN OnCallDiscInd(const StackMsgArgument &arg);
00074
00077         BOOLEAN OnCallRelInd(const StackMsgArgument &arg);
00078
00079     private:
00080         static const StackMsgArgMap<CallReleaseDispatcher> m_arg_map[];
00081         StackMsgArgMapContainer<CallReleaseDispatcher> m_arg_map_container;
00082         CallDispatcher* m_call_disp;
00083         TipdList* m_tipd_list;
00084
00085 };
00086
00088 #endif  // Asc_CallReleaseDispatcher_hpp
00089
00090 #endif // DOXYGEN_SHOULD_SKIP_THIS
00091
00092
Generated on Tue Jan 24 14:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallWaitingHandler.cpp File Reference

Asc/CallWaitingHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Auxiliary/Vector.hpp>
#include <Asc/Types.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Asc/InputParserTranslator.hpp>
#include "SsMainHandler.hpp"
#include "CallWaitingHandler.hpp"

Include dependency graph for CallWaitingHandler.cpp:

Generated on Tue Jan 24 17:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallWaitingHandler.hpp File Reference

Asc/CallWaitingHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/SsBaseHandler.hpp>
#include <Asc/InputParser.hpp>

Include dependency graph for CallWaitingHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallWaitingHandler

Defines

#define | Asc_CallWaitingHandler_hpp

Define Documentation

#define Asc_CallWaitingHandler_hpp

Generated on Tue Jan 24 17:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CallWaitingHandler.hpp Source File

Asc/CallWaitingHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_CallWaitingHandler_hpp)
00011 #define Asc_CallWaitingHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/SsBaseHandler.hpp>
00016 #include <Asc/InputParser.hpp>
00017
00022 class CallWaitingHandler : public SsBaseHandler {
00025     typedef SsBaseHandler Base;
00026
00027 #ifdef TEST_SUPPLEMENTARY_SERVICES
00028
00030     friend class CallWaitingHandlerTest;
00031 #endif
00032
00033  public:
00037     enum { ID = CallWaitingHandlerId };
00038
00040     CallWaitingHandler();
00042     virtual ~CallWaitingHandler();
00043
00047     virtual HandlerId GetHandlerId() const;
00048
00049
00050 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00051
00066     virtual SsBaseHandler::ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument &arg);
00067 #endif // DOXYGEN_SHOULD_SKIP_THIS
00068
00082     SsApiRc Activate(ServiceGroup basic_service = AllServices, const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00083
00097     SsApiRc Deactivate(ServiceGroup basic_service = AllServices, const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00098
00112     SsApiRc RequestStatus(const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00113
00125     SsApiRc RequestStatus(ServiceGroup basic_service, const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE, LineSelector line = InvalidLine);
00126
00138     SsApiRc RequestStatus(ServiceGroup basic_service, const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00139
00140
00141  private:
00142
00158     SsApiRc ExecuteRequest(SsOperationCode op_code, ServiceGroup basic_service, const WString& override_ss_seq, BOOLEAN register_only, LineSelector line = InvalidLine);
00159
00169     SsBaseHandler::ReturnCode CreateActivatedMsg(const SsForwardingIndArg &arg, SsMessage*& msg);
00170
00180     SsBaseHandler::ReturnCode CreateActivatedMsg(const SsDataIndArg &arg, SsMessage*& msg);
00181
00191     SsBaseHandler::ReturnCode CreateDeactivatedMsg(const SsForwardingIndArg &arg, SsMessage*& msg);
00192
00202     SsBaseHandler::ReturnCode CreateDeactivatedMsg(const SsDataIndArg &arg, SsMessage*& msg);
00203
00214     SsBaseHandler::ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg);
00215
00227     SsBaseHandler::ReturnCode CreateSuccessResultMsg(const SsRetResIndArg &arg, SsMessage*& msg);
00228
00231     LineSelector m_line;
00232
00235 //    ServiceGroup m_param_bs_code;
00236 };
00237
00238 #endif // Asc_CallWaitingHandler_hpp
00239
00240
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsDispatcher.cpp File Reference

Asc/CbsDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "CbsDispatcher.hpp"

Include dependency graph for CbsDispatcher.cpp:

Generated on Tue Jan 24 17:16:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsDispatcher.hpp File Reference

Asc/CbsDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Message.hpp>
#include <Asc/StackMsgDispatcher.hpp>
#include <Asc/CbsFilterList.hpp>

Include dependency graph for CbsDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CbsDispatcher

Defines

#define | Asc_CbsDispatcher_hpp

Define Documentation

#define Asc_CbsDispatcher_hpp

Generated on Tue Jan 24 17:17:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsDispatcher.hpp Source File

Asc/CbsDispatcher.hpp

Go to the documentation of this file.
00001                                /*   ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CbsDispatcher_hpp)
00009 #define Asc_CbsDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/Message.hpp>
00015
00016 #include <Asc/StackMsgDispatcher.hpp>
00017 #include <Asc/CbsFilterList.hpp>
00018
00019 /*  ========================================================================
00020     CbsDispatcher
00021     ======================================================================== */
00023 class CbsDispatcher : public StackMsgDispatcher {
00024     typedef StackMsgDispatcher Base;
00025     public:
00027         CbsDispatcher();
00029         virtual ~CbsDispatcher();
00031         CbsFilterList & GetCbsFilterList() { return m_filterlist; }
00032
00033     protected:
00035         BOOLEAN OnCbsNewDataInd(const StackMsgArgument &arg);
00037         BOOLEAN OnCbsLimitInd(const StackMsgArgument &arg);
00038
00039
00040     private:
00041         static const StackMsgArgMap<CbsDispatcher> m_arg_map[];
00042         StackMsgArgMapContainer<CbsDispatcher> m_arg_map_container;
00043
00044         static CbsFilterList m_filterlist;  // global filter list
00045
00046 };
00047
00049 #endif // Asc_CbsDispatcher_hpp
00050
00051
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsFilterList.cpp File Reference

Asc/CbsFilterList.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CbsFilterList.hpp"

Include dependency graph for CbsFilterList.cpp:

Generated on Tue Jan 24 17:17:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsFilterList.hpp File Reference

Asc/CbsFilterList.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/Cbs.hpp>

Include dependency graph for CbsFilterList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CbsFilterList
struct | CbsFilterList::CbsFilterListEntry

Defines

#define | Asc_CbsFilterList_hpp

Define Documentation

#define Asc_CbsFilterList_hpp

Generated on Tue Jan 24 17:17:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsFilterList.hpp Source File

Asc/CbsFilterList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CbsFilterList_hpp)
00009 #define Asc_CbsFilterList_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Apc/Cbs.hpp>
00016
00017 /*  ========================================================================
00018     CbsFilterList
00019     ======================================================================== */
00020
00021 class CbsFilterList  {
00022     public:
00023         enum {
00024             c_max_cbs_applications = 10
00025         };
00026
00027         struct CbsFilterListEntry {
00028             Application * m_app;
00029             Cbs::Filter * m_filter;
00030
00031             void Init() {
00032                 m_app = 0;
00033                 m_filter = 0;
00034             }
00035             void Clear() {
00036                 m_app = 0;
00037                 delete m_filter;
00038                 m_filter = 0;
00039             }
00040         };
00041
00043         CbsFilterList();
00045         virtual ~CbsFilterList();
00046
00048         BOOLEAN IsEmpty() const;
00050         BOOLEAN PutFilter(Application * app, const Cbs::Filter & filter);
00052         BOOLEAN RemoveFilter(Application * app);
00054         const Cbs::Filter * GetFilter(Application * app) const;
00056         BOOLEAN MergeFilters();
00058         const Cbs::Filter & GetMergedFilter() const { return m_merge_filter; }
00060         BOOLEAN IsOfInterest(Application * app, const CbsNewDataIndArg & arg) const;
00061
00062     private:
00063         BOOLEAN MergeDcsFilter();
00064         BOOLEAN MergeMidFilter();
00065
00066
00067         CbsFilterListEntry m_entries[c_max_cbs_applications];
00068         Cbs::Filter        m_merge_filter;
00069
00070
00071 };
00072
00073
00075 #endif // Asc_CbsFilterList_hpp
00076
00077
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsHandler.cpp File Reference

Asc/CbsHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CbsHandler.hpp"
#include "CbsStartDispatcher.hpp"
#include "CbsStopDispatcher.hpp"

Include dependency graph for CbsHandler.cpp:

Generated on Tue Jan 24 17:17:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsHandler.hpp File Reference

Asc/CbsHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/Cbs.hpp>
#include <Asc/BaseHandler.hpp>
#include <Asc/CbsDispatcher.hpp>
#include <Asc/CbsFilterList.hpp>

Include dependency graph for CbsHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CbsHandler

Defines

#define | Asc_CbsHandler_hpp

Define Documentation

#define Asc_CbsHandler_hpp

Generated on Tue Jan 24 17:17:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsHandler.hpp Source File

Asc/CbsHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CbsHandler_hpp)
00009 #define Asc_CbsHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Apc/Cbs.hpp>
00016
00017 #include <Asc/BaseHandler.hpp>
00018
00019 #include <Asc/CbsDispatcher.hpp>
00020 #include <Asc/CbsFilterList.hpp>
00021
00022 /*  ========================================================================
00023     CbsHandler
00024     ======================================================================== */
00026 class CbsHandler : public BaseHandler {
00027     typedef BaseHandler Base;
00028     public:
00029         enum { ID = CbsHandlerId };
00030
00032         CbsHandler();
00034         virtual ~CbsHandler();
00035
00037         virtual HandlerId GetHandlerId() const;
00038
00040         BOOLEAN Start(const Cbs::Filter &filter);
00042         BOOLEAN Stop();
00044         CbsFilterList & GetCbsFilterList() { return m_cbs_dispatcher.GetCbsFilterList(); }
00045
00046     private:
00047         CbsDispatcher m_cbs_dispatcher;     // main dispatcher for retrieving asynchronous messages
00048
00049 };
00050
00052 #endif // Asc_PowerHandler_hpp
00053
00054
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsStartDispatcher.cpp File Reference

Asc/CbsStartDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CbsStartDispatcher.hpp"

Include dependency graph for CbsStartDispatcher.cpp:

Generated on Tue Jan 24 17:17:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsStartDispatcher.hpp File Reference

Asc/CbsStartDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>

Include dependency graph for CbsStartDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CbsStartDispatcher

Defines

#define | Asc_CbsStartDispatcher_hpp

Define Documentation

#define Asc_CbsStartDispatcher_hpp

Generated on Tue Jan 24 17:17:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsStartDispatcher.hpp Source File

Asc/CbsStartDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CbsStartDispatcher_hpp)
00009 #define Asc_CbsStartDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     CbsStartDispatcher
00019     ======================================================================== */
00021 class CbsStartDispatcher : public StackMsgActiveWaitDispatcher {
00022     typedef StackMsgActiveWaitDispatcher Base;
00023     public:
00025         CbsStartDispatcher();
00027         virtual ~CbsStartDispatcher();
00028
00030         BOOLEAN Succeded() const { return m_success; }
00031
00032     protected:
00034         BOOLEAN OnCbsStartCnf(const StackMsgArgument &arg);
00036         BOOLEAN OnCbsStartRej(const StackMsgArgument &arg);
00037
00038     private:
00039         static const StackMsgArgMap<CbsStartDispatcher> m_arg_map[];
00040         StackMsgArgMapContainer<CbsStartDispatcher> m_arg_map_container;
00041         BOOLEAN m_success;
00042 };
00043
00045 #endif  // Asc_CbsStartDispatcher_hpp
00046
00047
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsStopDispatcher.cpp File Reference

Asc/CbsStopDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CbsStopDispatcher.hpp"

Include dependency graph for CbsStopDispatcher.cpp:

Generated on Tue Jan 24 17:18:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsStopDispatcher.hpp File Reference

Asc/CbsStopDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>

Include dependency graph for CbsStopDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CbsStopDispatcher

Defines

#define | Asc_CbsStopDispatcher_hpp

Define Documentation

#define Asc_CbsStopDispatcher_hpp

Generated on Tue Jan 24 17:18:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CbsStopDispatcher.hpp Source File

Asc/CbsStopDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CbsStopDispatcher_hpp)
00009 #define Asc_CbsStopDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     CbsStopDispatcher
00019     ======================================================================== */
00021 class CbsStopDispatcher : public StackMsgActiveWaitDispatcher {
00022     typedef StackMsgActiveWaitDispatcher Base;
00023     public:
00025         CbsStopDispatcher();
00027         virtual ~CbsStopDispatcher();
00028
00030         BOOLEAN Succeded() const {return m_success;};
00031
00032     protected:
00034         BOOLEAN OnCbsStopRej(const StackMsgArgument &arg);
00036         BOOLEAN OnCbsStopCnf(const StackMsgArgument &arg);
00037
00038     private:
00039         static const StackMsgArgMap<CbsStopDispatcher> m_arg_map[];
00040         StackMsgArgMapContainer<CbsStopDispatcher> m_arg_map_container;
00041         INT m_success;
00042 };
00043
00045 #endif  // Asc_CbsStopDispatcher_hpp
00046
00047
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ChrHandler.hpp File Reference

Asc/ChrHandler.hpp File Reference

#include <Compat/ChrHandler.hpp>

Include dependency graph for ChrHandler.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 17:18:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ChrHandler.hpp Source File

Asc/ChrHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if defined(APOXI_COMPILER_MSVC)
00009     #pragma message ("Reference to old ChrHandler")
00010 #endif
00011 #include <Compat/ChrHandler.hpp>
00012
00013
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ClipHandler.cpp File Reference

Asc/ClipHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/InputParser.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "ClipHandler.hpp"
#include "SsMainHandler.hpp"

Include dependency graph for ClipHandler.cpp:

Generated on Tue Jan 24 17:18:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ClipHandler.hpp File Reference

Asc/ClipHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/SsClHandler.hpp>

Include dependency graph for ClipHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ClipHandler

Defines

#define | Asc_ClipHandler_hpp

Define Documentation

#define Asc_ClipHandler_hpp

Generated on Tue Jan 24 17:18:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ClipHandler.hpp Source File

Asc/ClipHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_ClipHandler_hpp)
00011 #define Asc_ClipHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/SsClHandler.hpp>
00016
00023 class ClipHandler : public SsClHandler {
00026     typedef SsClHandler Base;
00027
00028 public:
00032     enum { ID = ClipHandlerId };
00033
00037     virtual HandlerId GetHandlerId() const;
00038
00051     SsApiRc RequestStatus(const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00052
00053
00054 protected:
00062     virtual ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg) const;
00063 };
00064
00065 #endif // Asc_ClipHandler_hpp
00066
00067
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ClirHandler.cpp File Reference

Asc/ClirHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/InputParser.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "ClirHandler.hpp"
#include "SsMainHandler.hpp"

Include dependency graph for ClirHandler.cpp:

Generated on Tue Jan 24 17:18:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ClirHandler.hpp File Reference

Asc/ClirHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/SsClHandler.hpp>

Include dependency graph for ClirHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ClirHandler

Defines

#define | Asc_ClirHandler_hpp

Define Documentation

#define Asc_ClirHandler_hpp

Generated on Tue Jan 24 17:18:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ClirHandler.hpp Source File

Asc/ClirHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_ClirHandler_hpp)
00011 #define Asc_ClirHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/SsClHandler.hpp>
00016
00023 class ClirHandler : public SsClHandler {
00026     typedef SsClHandler Base;
00027
00028 public:
00032     enum { ID = ClirHandlerId };
00033
00037     virtual HandlerId GetHandlerId() const;
00038
00051     SsApiRc RequestStatus(const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00052
00053
00054 protected:
00062     virtual ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg) const;
00063
00069     virtual BOOLEAN CheckSelector(const SsInterrogateIndArg &arg) const;
00070 };
00071
00072 #endif // Asc_ClirHandler_hpp
00073
00074
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CnapHandler.cpp File Reference

Asc/CnapHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/InputParser.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "CnapHandler.hpp"
#include "SsMainHandler.hpp"

Include dependency graph for CnapHandler.cpp:

Generated on Tue Jan 24 17:18:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CnapHandler.hpp File Reference

Asc/CnapHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/SsClHandler.hpp>

Include dependency graph for CnapHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CnapHandler

Defines

#define | Asc_CnapHandler_hpp

Define Documentation

#define Asc_CnapHandler_hpp

Generated on Tue Jan 24 17:18:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CnapHandler.hpp Source File

Asc/CnapHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009 #if !defined(Asc_CnapHandler_hpp)
00010 #define Asc_CnapHandler_hpp
00011
00012 #include <Kernel/Types.hpp>
00013
00014 #include <Asc/SsClHandler.hpp>
00015
00022 class CnapHandler : public SsClHandler {
00025     typedef SsClHandler Base;
00026
00027 public:
00031     enum { ID = CnapHandlerId };
00032
00036     virtual HandlerId GetHandlerId() const;
00037
00050     SsApiRc RequestStatus(const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00051
00052
00053 protected:
00061     virtual ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg) const;
00062 };
00063
00064 #endif // Asc_CnapHandler_hpp
00065
00066
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ColpHandler.cpp File Reference

Asc/ColpHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/InputParser.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "ColpHandler.hpp"
#include "SsMainHandler.hpp"

Include dependency graph for ColpHandler.cpp:

Generated on Tue Jan 24 17:19:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ColpHandler.hpp File Reference

Asc/ColpHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/SsClHandler.hpp>

Include dependency graph for ColpHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ColpHandler

Defines

#define | Asc_ColpHandler_hpp

Define Documentation

#define Asc_ColpHandler_hpp

Generated on Tue Jan 24 17:19:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ColpHandler.hpp Source File

Asc/ColpHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_ColpHandler_hpp)
00011 #define Asc_ColpHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/SsClHandler.hpp>
00016
00023 class ColpHandler : public SsClHandler {
00026     typedef SsClHandler Base;
00027
00028 public:
00032     enum { ID = ColpHandlerId };
00033
00037     virtual HandlerId GetHandlerId() const;
00038
00051     SsApiRc RequestStatus(const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00052
00053
00054 protected:
00062     virtual ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg) const;
00063 };
00064
00065 #endif // Asc_ColpHandler_hpp
00066
00067
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ColrHandler.cpp File Reference

Asc/ColrHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/InputParser.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "ColrHandler.hpp"
#include "SsMainHandler.hpp"

Include dependency graph for ColrHandler.cpp:

Generated on Tue Jan 24 17:19:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ColrHandler.hpp File Reference

Asc/ColrHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/SsClHandler.hpp>

Include dependency graph for ColrHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ColrHandler

Defines

#define | Asc_ColrHandler_hpp

Define Documentation

#define Asc_ColrHandler_hpp

Generated on Tue Jan 24 17:19:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ColrHandler.hpp Source File

Asc/ColrHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_ColrHandler_hpp)
00011 #define Asc_ColrHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/SsClHandler.hpp>
00016
00023 class ColrHandler : public SsClHandler {
00026     typedef SsClHandler Base;
00027
00028 public:
00032     enum { ID = ColrHandlerId };
00033
00037     virtual HandlerId GetHandlerId() const;
00038
00051     SsApiRc RequestStatus(const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00052
00053
00054 protected:
00062     virtual ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg) const;
00063 };
00064
00065 #endif // Asc_ColrHandler_hpp
00066
00067
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CrssDispatcher.cpp File Reference

Asc/CrssDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CrssDispatcher.hpp"
#include <Apc/SsErrorCode.hpp>
#include "TchInterface.hpp"

Include dependency graph for CrssDispatcher.cpp:

Generated on Tue Jan 24 17:19:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CrssDispatcher.hpp File Reference

Asc/CrssDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:19:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CrssDispatcher.hpp Source File

Asc/CrssDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_CrssDispatcher_hpp)
00011 #define Asc_CrssDispatcher_hpp
00014
00015 // #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00016 #include <Asc/TipdBasedActiveWaitDispatcher.hpp>
00017
00028 //lint -esym(1712,CrssDispatcher)
00029 class CrssDispatcher : public TipdBasedActiveWaitDispatcher {
00030     public:
00031         typedef TipdBasedActiveWaitDispatcher Base;
00032
00037         explicit CrssDispatcher(Tipd tipd, Tipd swap_held_tipd = c_null_tipd);
00038
00040         virtual ~CrssDispatcher();
00041
00042
00047         BOOLEAN CrssRejReceived() const { return m_crss_rej_received; }
00048
00049
00055         SsErrorCode GetSsErrorCode() const { return m_error_code; }
00056
00057
00062         CallRelatedSsState GetStatus() const { return m_status; }
00063
00064
00070         CallErrorCause GetHoldRejCause() const { return m_hold_rej_cause; }
00071
00072
00079         CallApiRc GetSwapResult() const { return m_swap_result; }
00080
00081
00084         BOOLEAN OnCrssRej(const StackMsgArgument &arg);
00085
00086
00091         BOOLEAN OnHoldRej(const StackMsgArgument &arg);
00092
00093
00096         BOOLEAN OnHoldCnf(const StackMsgArgument &arg);
00097
00098
00102         BOOLEAN OnMptyCnf(const StackMsgArgument &arg);
00103
00104
00107         BOOLEAN OnSsErrInd(const StackMsgArgument &arg);
00108
00109
00113         BOOLEAN OnEctCnf(const StackMsgArgument &arg);
00114
00116         BOOLEAN OnSsRej(const StackMsgArgument &arg);
00117
00122         virtual void AbortIfEqualTipd(Tipd tipd, AbortCause cause = NotSpecified);
00123
00130         virtual BOOLEAN IsAborted();
00131
00132     private:
00134         static const StackMsgArgMap<CrssDispatcher> m_arg_map[];
00136         StackMsgArgMapContainer<CrssDispatcher> m_arg_map_container;
00138         Tipd                m_swap_held_tipd;
00140         BOOLEAN             m_execute_done; // signals the first part of m/swap already done
00142         BOOLEAN             m_crss_rej_received;
00144         BOOLEAN             m_disc_ind_received;
00146         SsErrorCode         m_error_code;
00147
00149         CallRelatedSsState  m_status;
00151         CallErrorCause      m_hold_rej_cause;
00153         CallRelatedSs       m_call_related_ss;
00155         CallApiRc           m_swap_result;
00156
00157         /*  Internal methods for checking if there is still an open response for an operation.
00158             In the moment it is just checking if there is a swap funciton where the current
00159             response is not the second response. Then it will return FALSE. In all other cases
00160             it will return TRUE. */
00161         BOOLEAN CheckDonePermission();
00162
00163         /*  This internal method must be called whenever there is a negativ response to a swap request.
00164             E.g.: from OnHoldRej, OnSsRej, OnCrssRej, OnSsErrInd, ..?
00165             If the request was a swap then this will be considered for the return value of swap.
00166             Return value will be TRUE if there is a swap in progress else FALSE */
00167         BOOLEAN SetSwapRejectResultForTipd(Tipd in_tipd);
00168 };
00169
00170
00171 // No action required for this method. Just a confirmation.
00172 //      BOOLEAN OnCrssCnf(const StackMsgArgument &arg) { return FALSE; };
00173
00175 #endif  // Asc_CrssCnfRejDispatcher_hpp
00176
00177 #endif // DOXYGEN_SHOULD_SKIP_THIS
00178
00179
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CrssHandler.cpp File Reference

Asc/CrssHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandler.hpp"
#include "CrssDispatcher.hpp"
#include "CallReleaseDispatcher.hpp"
#include "CrssHandler.hpp"

Include dependency graph for CrssHandler.cpp:

Generated on Tue Jan 24 17:19:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CrssHandler.hpp File Reference

Asc/CrssHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/CrssDispatcher.hpp>

Include dependency graph for CrssHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CrssHandler

Defines

#define | Asc_CrssHandler_hpp

Define Documentation

#define Asc_CrssHandler_hpp

Generated on Tue Jan 24 17:19:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/CrssHandler.hpp Source File

Asc/CrssHandler.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_CrssHandler_hpp)
00009 #define Asc_CrssHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/CrssDispatcher.hpp>
00016
00017 // class CallHandlingData;
00018 class CrssDispatcher;
00019
00020 // enum CallApiRc;
00021
00029 class CrssHandler : public BaseHandler {
00030     typedef BaseHandler Base;
00031     public:
00032         enum { ID = CrssHandlerId };
00033
00035         CrssHandler();
00037         virtual ~CrssHandler();
00038
00040         virtual HandlerId GetHandlerId() const;
00041
00042
00047         SsErrorCode GetLastErrorCode() const { return m_last_error_code; }
00048
00049
00057         CallApiRc Hold(CallIndex idx) ;
00058
00059
00067         CallApiRc Retrieve(CallIndex idx) ;
00068
00069
00076         CallApiRc SwapCalls() const;
00077
00078
00085         CallApiRc ReleaseAllHeldCalls() const;
00086
00087
00091         CallApiRc ReleaseAllActiveCalls() const;
00092
00093
00099         CallApiRc ReleaseActiveCall() const;
00100
00101
00105         CallApiRc JoinCalls();
00106
00112         CallApiRc SplitMpty(CallIndex call_index);
00113
00114
00119 #if defined(APOXI_SYNC_RELEASE)
00120         CallApiRc ReleaseMpty(UINT32 & duration, BOOLEAN wait_condition = TRUE) const;
00121 #else
00122         CallApiRc ReleaseMpty(UINT32 & duration, BOOLEAN wait_condition = FALSE) const;
00123 #endif
00124
00125
00132         CallApiRc ExplicitCallTransfer(CallIndex call_index);
00133
00134     private:
00135 #if defined(APOXI_SYNC_RELEASE)
00136         CallApiRc CrssRelease(CallIndex call_index, CallRelatedSs crss, BOOLEAN wait_condition = TRUE) const;
00137 #else
00138         CallApiRc CrssRelease(CallIndex call_index, CallRelatedSs crss, BOOLEAN wait_condition = FALSE) const;
00139 #endif
00140         CallApiRc ProcessCrssRequest(CallIndex call_index, CallRelatedSs crss);
00141         //CallApiRc SwapCallAndMpty(); Methode removed because of CN200007816
00142
00143         CrssDispatcher *m_crss_disp;
00144         SsErrorCode     m_last_error_code;
00145 };
00146
00148 #endif // Asc_CrssHandler_hpp
00149
00150
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCall.hpp File Reference

Asc/DataCall.hpp File Reference

#include <Asc/DataCallHdl.hpp>
#include <Asc/DataCallControl.hpp>

Include dependency graph for DataCall.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_DataCall_hpp

Define Documentation

#define Asc_DataCall_hpp

Generated on Tue Jan 24 17:19:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCall.hpp Source File

Asc/DataCall.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Asc_DataCall_hpp)
00010 #define Asc_DataCall_hpp
00013
00014 #include <Asc/DataCallHdl.hpp>
00015 #include <Asc/DataCallControl.hpp>
00016
00018 #endif // Asc_DataCall_hpp
00019
00020
00021
00022
00023
00024
00025
00026
00027
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallContext.cpp File Reference

Asc/DataCallContext.cpp File Reference

#include "Asc/PreComp.hpp"
#include "DataCallContext.hpp"

Include dependency graph for DataCallContext.cpp:

Generated on Tue Jan 24 17:20:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallContext.hpp File Reference

Asc/DataCallContext.hpp File Reference

#include <Apc/SignalTypes.hpp>

Include dependency graph for DataCallContext.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataCallContext

Defines

#define | Asc_DataCall_DataCallContext_hpp

Define Documentation

#define Asc_DataCall_DataCallContext_hpp

Generated on Tue Jan 24 17:20:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallContext.hpp Source File

Asc/DataCallContext.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2002 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Asc_DataCall_DataCallContext_hpp)
00010 #define Asc_DataCall_DataCallContext_hpp
00013
00014 #include <Apc/SignalTypes.hpp>
00015
00018 class DataCallContext {
00019     public:
00021         enum ConnectionElement {    // T_CONN_ELEMENT
00023             Transparent             = TRANSPARENT,
00025             NonTransparent          = NON_TRANSPARENT,
00027             TransparentPreferred    = TRANSPARENT_PREF,
00029             NonTransparentPreferred = NON_TRANSPARENT_PREF,
00031             ElementUndefined        = CONN_ELEMENT_UNDEFINED,
00033             InvalidConnectionElement
00034         };
00035
00037         DataCallContext();
00038
00040         ~DataCallContext();
00041
00043         void Reset();
00044
00046         void SetConnectionElement(ConnectionElement connection_element) { m_connection_element = connection_element; }
00047
00049         ConnectionElement GetConnectionElement() const { return (m_connection_element); }
00050
00051     private:
00052         ConnectionElement m_connection_element;
00053
00054 }; // class DataCallContext
00055
00056
00057 /* The following types are not needed yet.
00058
00059
00061         enum ServiceMode {  // T_SERVICE_MODE
00063             SingleData                          = SINGLE_DATA,
00065             SingleFax                           = SINGLE_FAX,
00067             SingleVoice                         = SINGLE_VOICE,
00069             DualBs61                            = DUAL_BS61,
00071             DualBs81                            = DUAL_BS81,
00073             DualTs61                            = DUAL_TS61,
00075             GprsData                            = GPRS_DATA,
00077             Data3gAsync                         = DATA_3G_ASYNC,
00079             Data3gSync                          = DATA_3G_SYNC,
00081             GprsDdata3gMultimediaTelephonyta    = GPRS_DDATA_3G_MULTIMEDIA_TELEPHONYTA,
00083             InvalidServiceMode
00084         };
00085
00087         enum SystemMode {   // T_SYSTEM_MODE
00089             Gem = GEM_MODE,
00091             Gsm = GSM_MODE,
00093             Umts = GSM_MODE,
00095             InvalidSystemMode
00096         };
00097
00099         enum DataRate {     // T_DATA_RATE
00101             AutoBauding         = D_AUTOBAUDING,
00103             V110V22Bis_2400     = D_2400_V110_V22BIS,
00105             V110V26Ter_2400     = D_2400_V110_V26TER,
00107             V110V32_4800        = D_4800_V110_V32,
00109             V110V32_9600        = D_9600_V110_V32,
00111             V110None_2400       = D_2400_V110_NONE,
00113             V110None_4800       = D_4800_V110_NONE,
00115             V110None_9600       = D_9600_V110_NONE,
00117             V34_28800           = D_28800_V34,
00119             V110_56000          = D_56000_V110,
00121             BitTransp_56000     = D_56000_BIT_TRANSP,
00123             BitTransp_64000     = D_64000_BIT_TRANSP,
00125             Mulitmedia_28000    = D_28000_MULTIMEDIA,
00127             Mulitmedia_32000    = D_32000_MULTIMEDIA,
00129             Mulitmedia_56000    = D_56000_MULTIMEDIA,
00131             Mulitmedia_64000    = D_64000_MULTIMEDIA,
00133             Piafs_32000         = D_32000_PIAFS,
00135             Piafs_64000         = D_64000_PIAFS,
00137             Ftm_56000           = D_56000_FTM,
00139             Ftm_64000           = D_64000_FTM,
00141             NoneTrans_64000     = D_64000_NONE_TRANS,
00143             InvalidDataRate
00144         };
00145
00147         enum SynchronType {     // T_SYNCHRON_TYPE
00149             AsynModem   = ASYN_MODEM,
00151             SynModem    = SYN_MODEM,
00153             InvalidSynchonType
00154         };
00155
00156 struct RlpPar { // T_RLP_PAR
00157     INT rlp_vers;
00158     INT rlp_kim;
00159     INT rlp_kmi;
00160     INT rlp_t1;
00161     INT rlp_n2;
00162     INT rlp_t2;
00163 };
00164
00165
00166 typedef INT DcDirection;
00167 // Value for T_DC_DIRECTION: Compression in neither direction (used for
00168 // V.25ter commands +DS and +DR and for XID parameter P0 in GSM 04.22)
00169 const INT DsDcNone = DS_DC_NONE;            // 0
00170
00171 // Value for T_DC_DIRECTION: Compression in transmit direction only (used for
00172 // V.25ter commands +DS and +DR and for XID parameter P0 in GSM 04.22)
00173 const INT DsDcV42bTd = DS_DC_V42B_TD;       // 1;
00174
00175 // Value for T_DC_DIRECTION: Compression in receive direction only (used for
00176 // V.25ter commands +DS and +DR and for XID parameter P0 in GSM 04.22)
00177 const INT DsDcV42bRd = DS_DC_V42B_RD;       // 2;
00178
00179 // Value for T_DC_DIRECTION: Compression in both directions (used for V.25ter
00180 // commands +DS and +DR and for XID parameter P0 in GSM 04.22)
00181 const INT DsDcV42bBd = DS_DC_V42B_BD;       // 3;
00182
00183 // Value for T_DC_DIRECTION: Error value (if DTN gets a value out of
00184 // the range 0-3)
00185 const INT DsDcDirError = DS_DC_DIR_ERROR;   // 255;
00186
00187 struct DcPar {  // T_DC_PAR
00188     DcDirection direction;
00189     ULONG       max_dict;
00190     INT         max_string;
00191 };
00192
00193
00194 INT DcNegotiation; // T_DC_NEGOTIATION; (0 or 1)
00195 const DcNotDisconnect   = DS_DC_NOT_DISCONNECT;     // 0;
00196 const DcDisconnect      = DS_DC_DISCONNECT          // 1;
00197
00198 struct T_ETBM {
00199     Integer pending_td;
00200     Integer pending_rd;
00201     Integer max_time;
00202 };
00203
00204
00205 enum AtCause {  // AT_CAUSE
00206     AtUserRel = AT_USER_REL,
00207     AtV24Failure = AT_V24_FAILURE,
00208     AtTimeOut = AT_TIMER_OUT
00209 };
00210
00211 */
00212
00214 #endif  // Asc_DataCall_DataCallContext_hpp
00215
00216
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallControl.hpp File Reference

Asc/DataCallControl.hpp File Reference

#include <Apc/SignalTypes.hpp>

Include dependency graph for DataCallControl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataCallControl

Defines

#define | AscDataCallControl

Define Documentation

#define AscDataCallControl

Generated on Tue Jan 24 17:20:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallControl.hpp Source File

Asc/DataCallControl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2002 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AscDataCallControl)
00010 #define AscDataCallControl
00013
00014 #include <Apc/SignalTypes.hpp>
00015
00019 class DataCallControl
00020 {
00021     public:
00023         DataCallControl() {};
00025         ~DataCallControl() {};
00026
00031         virtual void OnSetupCompleted(DcError error) = 0;
00032
00033
00040         virtual void OnReleaseCompleted(DcError error) = 0;
00041 };
00042
00044 #endif // AscDataCallControl
00045
00046
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallHdl.hpp File Reference

Asc/DataCallHdl.hpp File Reference

#include <Asc/Types.hpp>
#include <Asc/DataCallContext.hpp>

Include dependency graph for DataCallHdl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataCallHdl

Defines

#define | Asc_DataCall_DataCallHdl_hpp

Define Documentation

#define Asc_DataCall_DataCallHdl_hpp

Generated on Tue Jan 24 17:20:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallHdl.hpp Source File

Asc/DataCallHdl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_DataCall_DataCallHdl_hpp)
00011 #define Asc_DataCall_DataCallHdl_hpp
00014
00015 #include <Asc/Types.hpp>
00016 #include <Asc/DataCallContext.hpp>
00017
00018 class DataCallControl;
00019
00022 class DataCallHdl {
00023     friend class DataCallSignalProcessor;
00024     public:
00026         static void Init(const DataCallContext &context);
00027
00039         static CallApiRc Setup(const PhoneNumber &phone_no,
00040                                BOOLEAN isdn,
00041                                UINT data_rate,
00042                                DataCallControl *dcc_p);
00043
00049         static CallApiRc Release();
00050
00051     private:
00052         static DataCallContext m_context;
00053         static DataCallControl *m_dcc_p;    // connection to virtual routines
00054         static Tipd m_tipd;                 // tipd of csdata call
00055
00056         static void DataCallTerminated();
00057 };
00058
00060 #endif // Asc_DataCall_DataCallHdl_hpp
00061
00062
00063
00064
00065
00066
00067
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallTypes.hpp File Reference

Asc/DataCallTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_DataCall_DataCallTypes_hpp

Define Documentation

#define Asc_DataCall_DataCallTypes_hpp

Generated on Tue Jan 24 17:20:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DataCallTypes.hpp Source File

Asc/DataCallTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2002 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Asc_DataCall_DataCallTypes_hpp)
00010 #define Asc_DataCall_DataCallTypes_hpp
00013
00014
00016 #endif  // Asc_DataCall_DataCallTypes_hpp
00017
00018
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DtmfDispatcher.cpp File Reference

Asc/DtmfDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "DtmfDispatcher.hpp"
#include "StackIndicationMsgTypes.hpp"

Include dependency graph for DtmfDispatcher.cpp:

Generated on Tue Jan 24 17:20:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DtmfDispatcher.hpp File Reference

Asc/DtmfDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:20:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/DtmfDispatcher.hpp Source File

Asc/DtmfDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_DtmfDispatcher_hpp)
00011 #define Asc_DtmfDispatcher_hpp
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016 #include <Apc/StackMsgArgument.hpp>
00017
00019 class DtmfDispatcher : public StackMsgDispatcher {
00020     typedef StackMsgDispatcher Base;
00021     public:
00023         DtmfDispatcher();
00024
00026         virtual ~DtmfDispatcher();
00027
00029         void IncDtmfRequests() { m_n_dtmf_requests++; }
00030
00032         void DecDtmfRequests() { m_n_dtmf_requests--; }
00033
00035         INT CountDtmfRequests() { return m_n_dtmf_requests; }
00036
00038         Tipd GetTipd() { return m_tipd; }
00039
00041         void SetTipd(Tipd tipd) { m_tipd = tipd; }
00042
00045         BOOLEAN OnStartDtmfCnf(const StackMsgArgument &arg);
00046
00047
00050         BOOLEAN OnStopDtmfCnf(const StackMsgArgument &arg);
00051
00052
00055         BOOLEAN OnStartDtmfRej(const StackMsgArgument &arg);
00056
00057
00060         BOOLEAN OnDtmfBufferClearedInd(const StackMsgArgument &arg);
00061
00062     private:
00064         static const StackMsgArgMap<DtmfDispatcher> m_arg_map[];
00066         StackMsgArgMapContainer<DtmfDispatcher> m_arg_map_container;
00067
00069         Tipd    m_tipd;
00071         INT     m_n_dtmf_requests;
00072
00073 };
00074
00076 #endif // Asc_DtmfDispatcher_hpp
00077
00078 #endif // DOXYGEN_SHOULD_SKIP_THIS
00079
00080
Generated on Tue Jan 24 14:46:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/EmlppHandler.cpp File Reference

Asc/EmlppHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Auxiliary/Vector.hpp>
#include <Asc/Types.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Asc/InputParserTranslator.hpp>
#include "SsMainHandler.hpp"
#include "EmlppHandler.hpp"

Include dependency graph for EmlppHandler.cpp:

Generated on Tue Jan 24 17:20:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/EmlppHandler.hpp File Reference

Asc/EmlppHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/SsBaseHandler.hpp>
#include <Asc/InputParser.hpp>

Include dependency graph for EmlppHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmlppHandler

Defines

#define | Asc_EmlppHandler_hpp

Define Documentation

#define Asc_EmlppHandler_hpp

Generated on Tue Jan 24 17:20:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/EmlppHandler.hpp Source File

Asc/EmlppHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_EmlppHandler_hpp)
00011 #define Asc_EmlppHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/SsBaseHandler.hpp>
00016 #include <Asc/InputParser.hpp>
00017
00022 class EmlppHandler : public SsBaseHandler {
00025     typedef SsBaseHandler Base;
00026
00027 #ifdef TEST_SUPPLEMENTARY_SERVICES
00028
00030     friend class EmlppHandlerTest;
00031 #endif
00032
00033  public:
00037     enum { ID = EmlppHandlerId };
00038
00040     EmlppHandler();
00042     virtual ~EmlppHandler();
00043
00047     virtual HandlerId GetHandlerId() const;
00048
00049
00050 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00051
00066     virtual SsBaseHandler::ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument &arg);
00067 #endif // DOXYGEN_SHOULD_SKIP_THIS
00068
00080     SsApiRc Register(EmlppPriorityLevel priority, const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00081
00091     SsApiRc RequestStatus(const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00092
00093
00094  private:
00095
00111     SsApiRc ExecuteRequest(const SsOperationCode op_code, EmlppPriorityLevel priority, const WString& override_ss_seq, BOOLEAN register_only);
00112
00122     SsBaseHandler::ReturnCode CreateRegisteredMsg(const SsDataIndArg &arg, SsMessage*& msg);
00123
00134     SsBaseHandler::ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg);
00135
00147     SsBaseHandler::ReturnCode CreateSuccessResultMsg(const SsRetResIndArg &arg, SsMessage*& msg);
00148
00151     EmlppPriorityLevel m_param_priority;
00152 };
00153
00154 #endif // Asc_EmlppHandler_hpp
00155
00156
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ExternalPsdContextListener.cpp File Reference

Asc/ExternalPsdContextListener.cpp File Reference

#include "Asc/PreComp.hpp"
#include "ExternalPsdContextListener.hpp"
#include <Socket/Socket.hpp>
#include <Socket/SocketMsg.hpp>
#include <Socket/SocketTypes.hpp>

Include dependency graph for ExternalPsdContextListener.cpp:

Generated on Tue Jan 24 17:20:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ExternalPsdContextListener.hpp File Reference

Asc/ExternalPsdContextListener.hpp File Reference

#include <stack/extensions.h>

Include dependency graph for ExternalPsdContextListener.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ExtPsdContextListener_SerialTerminal
class | ExtPsdContextListener_SerialTerminalListener
class | ExtPsdContextListener_SioGlueSignalListener
class | ExtPsdContextListener_SioGlueWrapper
struct | ExtPsdContextListener_SioGlueWrapper::SioCommId
struct | ExtPsdContextListener_SioGlueWrapper::TermIos
class | ExtPsdContextListenerImpl_SerialTerminalListener

Defines

#define | Apoxi_ExternalPsdContextListener_hpp

Variables

const INT | c_max_serial_terminals = 3

Define Documentation

#define Apoxi_ExternalPsdContextListener_hpp

Variable Documentation

const INT c_max_serial_terminals = 3

Set to the value of terminals defined by io_db_config.h. Names of terminals have to be set in ExtPsdContextListener_SerialTerminal.cpp

Generated on Tue Jan 24 17:20:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ExternalPsdContextListener.hpp Source File

Asc/ExternalPsdContextListener.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ExternalPsdContextListener_hpp)
00011 #define Apoxi_ExternalPsdContextListener_hpp
00012
00013 #include <stack/extensions.h>
00014
00015 /***************************************************************************/
00016 /* - !!! - INTERNAL CLASSES - SUBJECT TO CHANGE - MUST NOT BE USED - !!! - */
00017 /***************************************************************************/
00018
00019 // Forward definition to avoid cyclic includes
00020 class Socket;
00021 class ExtPsdContextListener_SioGlueSignalListener;
00022 class ExtPsdContextListener_SerialTerminal;
00023 class ExtPsdContextListener_SerialTerminalListener;
00024
00029 class ExtPsdContextListener_SioGlueWrapper
00030 {
00031 public:
00032
00035     enum Result {
00037         SioOk = SIO_STAT_OK,
00039         SioError = SIO_STAT_ERROR,
00041         SioEnoughBuffer = SIO_STAT_WATER_HIGH,
00043         SioBufferLow = SIO_STAT_WATER_LOW,
00045         SioAtBusy = SIO_STAT_AT_BUSY,
00047         SioAtComplete = SIO_STAT_AT_COMPL
00048     };
00049
00050
00053     enum LineState
00054     {
00056         SioLineOff = SIO_LINE_OFF,
00058         SioLineOn = SIO_LINE_ON,
00060         SioLineDontCare = SIO_LINE_ON+1
00061
00062     };
00063
00064
00067     enum Parity
00068     {
00069         ParityNone = SIO_PARITY_NONE,
00070         ParityOdd = SIO_PARITY_ODD,
00071         ParityEvent = SIO_PARITY_EVEN,
00072         ParityMark = SIO_PARITY_MARK,
00073         ParitySpace = SIO_PARITY_SPACE
00074     };
00075
00078     enum SignalType
00079     {
00081         SioDataReq = GLUE_SIG_DATAREQ,
00083         SioTermIos = GLUE_SIG_TERMIOS,
00085         SioExecMode = GLUE_SIG_EXECMODE,
00087         SioClose = GLUE_SIG_CLOSE,
00089         SioOpen = GLUE_SIG_OPEN,
00090
00091         SioLast = GLUE_SIG_LAST
00092     };
00093
00096     enum SignalStartStop
00097     {
00099         SioExecModeStart = GLUE_EXECMODE_START,
00101         SioExecModeKill = GLUE_EXECMODE_KILL,
00102
00103         SioSigvalLast = GLUE_SIGVAL_LAST
00104
00105     };
00106
00107     struct SioCommId {
00108         friend class ExtPsdContextListener_SioGlueWrapper;
00109
00110         private:
00112             glue_fd_t  m_fd;
00113     };
00114
00117     struct TermIos {
00118
00119         public:
00120
00122             TermIos();
00123
00127             TermIos(sio_termios_t* sio_termios);
00128
00130             ~TermIos();
00131
00133             LineState GetDtr() const { return static_cast<LineState>(m_termios.dtr); }
00134
00136             LineState GetRts() const { return static_cast<LineState>(m_termios.rts); }
00137
00139             LineState GetDsr() const { return static_cast<LineState>(m_termios.dsr); }
00140
00142             void SetDsr(LineState state) { m_termios.dsr = (sio_line_t)state; }
00143
00145             LineState GetCts() const { return static_cast<LineState>(m_termios.cts); }
00146
00148             void SetCts(LineState state) { m_termios.cts = (sio_line_t)state; }
00149
00151             LineState GetDcd() const { return static_cast<LineState>(m_termios.dcd); }
00152
00154             void SetDcd(LineState state) { m_termios.dcd = (sio_line_t)state; }
00155
00157             LineState GetRi() const { return static_cast<LineState>(m_termios.ri); }
00158
00160             void SetRi(LineState state) { m_termios.ri = (sio_line_t)state; }
00161
00163             UINT32 GetSpeed() const { return m_termios.speed; }
00164
00166             void SetSpeed(UINT32 speed) { m_termios.speed = speed; }
00167
00169             UINT8 GetStopBits() const { return m_termios.stop_bits; }
00170
00172             void SetStopBits(UINT8 stop_bits) { m_termios.stop_bits = stop_bits; }
00173
00175             Parity GetParity() const { return static_cast<Parity>(m_termios.parity); }
00176
00178             void SetParity(Parity parity) { m_termios.parity = (sio_parity_t)parity; }
00179
00181             UINT8 GetDataBits() const { return m_termios.data_bits; }
00182
00184             void SetDataBits(UINT8 data_bits) { m_termios.data_bits = data_bits; }
00185
00186             friend ExtPsdContextListener_SioGlueWrapper;
00187
00188         private:
00189             sio_termios_t m_termios;
00190
00191     };
00192
00200     static Result Close(const SioCommId &comm_id);
00201
00202
00211     static Result Open(const String &device_name, SioCommId& comm_id);
00212
00213     //corresponding methods to functions and parameters of sio_glue
00214     //typedef enum
00215     //{
00216     //  GLUE_OPT_SIGACT,  --> RegisterHandler() / UnregisterHandler()
00217     //  GLUE_OPT_TERMIOS, --> GetStatus() / SetStatus()
00218     //  GLUE_OPT_WRVAL,   --> GetBufferSizes()
00219     //  GLUE_OPT_AT,      --> SetAtMode()
00220     //} glue_opt_t;
00221
00228     static Result RegisterSignalListener(const SioCommId &comm_id, ExtPsdContextListener_SioGlueSignalListener &listener);
00229
00236     static Result UnRegisterSignalListener(const SioCommId &comm_id, const ExtPsdContextListener_SioGlueSignalListener &listener);
00237
00244     static Result SetAtMode(const SioCommId &comm_id, BOOLEAN at_mode);
00245
00254     static Result GetAtMode(const SioCommId &comm_id, BOOLEAN &at_mode);
00255
00263     static Result GetBufferSizes(const SioCommId &comm_id, UINT16 &free, UINT16 &size);
00264
00272     static Result SetStatus(const SioCommId &comm_id, const TermIos& state);
00273
00282     static Result GetStatus(const SioCommId &comm_id, TermIos& state);
00283
00294     static Result ReadData  (const SioCommId &comm_id, void *buffer,
00295                         UINT16   size,
00296                         UINT16&  read);
00297
00298
00310     static Result WriteData  (const SioCommId &comm_id, const void *buffer,
00311                         UINT16   size,
00312                         UINT16&  written);
00313
00314 private:
00318
00319     ExtPsdContextListener_SioGlueWrapper();
00320
00322     ~ExtPsdContextListener_SioGlueWrapper();
00323 };
00324
00326
00330 class ExtPsdContextListener_SioGlueSignalListener
00331 {
00332 public:
00334     ExtPsdContextListener_SioGlueSignalListener();
00335
00337     virtual ~ExtPsdContextListener_SioGlueSignalListener();
00338
00340     void Init(ExtPsdContextListener_SerialTerminal* terminal) {
00341         m_terminal = terminal;
00342     }
00343
00353     void OnSignalChange(ExtPsdContextListener_SioGlueWrapper::SignalType type, void* signal_parameter, void* user_parameter);
00354
00361     static void sio_glue_handler (glue_sig_t sig_code, void *sig_param, void *user_param);
00362
00363 private:
00364     ExtPsdContextListener_SerialTerminal *m_terminal;
00365
00366 };
00367
00369
00370
00374 const INT c_max_serial_terminals = 3;
00375
00379 class ExtPsdContextListener_SerialTerminal
00380 {
00381 public:
00382
00384     enum Event {
00386         DataAvailable,
00388         DataSent
00389     };
00390
00392     enum Result {
00394         Ok,
00396         Error,
00398         NotConnected
00400     };
00401
00403     enum Parity
00404     {
00406         ParityNone = ExtPsdContextListener_SioGlueWrapper::ParityNone,
00408         ParityOdd  = ExtPsdContextListener_SioGlueWrapper::ParityOdd,
00410         ParityEven = ExtPsdContextListener_SioGlueWrapper::ParityEvent,
00412         ParityMark = ExtPsdContextListener_SioGlueWrapper::ParityMark,
00414         ParitySpace = ExtPsdContextListener_SioGlueWrapper::ParitySpace
00415     };
00416
00417     friend class ExtPsdContextListener_SioGlueSignalListener;
00418
00420     virtual ~ExtPsdContextListener_SerialTerminal();
00421
00430     Result Connect(const String &connect_string, UINT32 speed, UINT8 stop_bits, UINT8 data_bits, Parity parity);
00431
00435     Result Disconnect();
00436
00439     BOOLEAN IsConnected() const { return m_connected; };
00440
00452     Result Read(void* buffer, UINT16 buffer_size, UINT16& bytes_read);
00453
00462     Result Write(const void* buffer, UINT16 buffer_size, UINT16& bytes_written);
00463
00464
00470     Result SetAtMode(BOOLEAN enable);
00471
00479     Result GetConnectionParameters(UINT32* speed, UINT8* stop_bits, UINT8* data_bits, Parity* parity) const;
00480
00484     static ExtPsdContextListener_SerialTerminal* GetFreeSerialTerminal();
00485
00489     static void ReleaseSerialTerminal(ExtPsdContextListener_SerialTerminal* terminal) {
00490         terminal->Release();
00491         terminal->m_is_in_use = FALSE;
00492     }
00493
00496     void SetListener(ExtPsdContextListener_SerialTerminalListener* listener) {m_event_listener = listener;};
00497
00498 protected:
00504     void OnSignalChange(ExtPsdContextListener_SioGlueWrapper::SignalType type, void* signal_parameter, void* user_parameter);
00505
00507     BOOLEAN m_is_in_use;
00508 private:
00509
00511     ExtPsdContextListener_SerialTerminal(const String &device);
00512
00514     BOOLEAN Init();
00515
00517     BOOLEAN Release();
00518
00519     //must accord to the sio.config!
00520     static ExtPsdContextListener_SerialTerminal m_terminals[c_max_serial_terminals];
00521
00523     const String m_device;
00524
00526     ExtPsdContextListener_SioGlueWrapper::SioCommId m_commId;
00527
00531     ExtPsdContextListener_SioGlueSignalListener m_sio_signal_listener;
00532
00534     BOOLEAN m_connected;
00535
00539     ExtPsdContextListener_SerialTerminalListener* m_event_listener;
00540
00542     ExtPsdContextListener_SioGlueWrapper::TermIos  m_term_ios;
00543 };
00544
00546
00550 class ExtPsdContextListener_SerialTerminalListener
00551 {
00552 public:
00554     ExtPsdContextListener_SerialTerminalListener();
00556     virtual ~ExtPsdContextListener_SerialTerminalListener();
00562     virtual void OnTerminalEvent(ExtPsdContextListener_SerialTerminal& terminal, ExtPsdContextListener_SerialTerminal::Event event) = 0;
00563
00564 };
00565
00567
00572 class ExtPsdContextListenerImpl_SerialTerminalListener : public ExtPsdContextListener_SerialTerminalListener
00573 {
00574 public:
00575     typedef ExtPsdContextListener_SerialTerminalListener Base;
00576
00578     ExtPsdContextListenerImpl_SerialTerminalListener();
00579
00581     virtual ~ExtPsdContextListenerImpl_SerialTerminalListener();
00582
00584     virtual void OnTerminalEvent(ExtPsdContextListener_SerialTerminal& terminal, ExtPsdContextListener_SerialTerminal::Event event);
00585
00586     void TerminateExtPsdContext();
00587
00588 private:
00590     void OnDataAvailable(ExtPsdContextListener_SerialTerminal &terminal);
00591
00592     void OnResponseReceived(String response);
00593
00595     ExtPsdContextListener_SerialTerminal *m_terminal;
00596
00597     UINT8 m_ext_pdp_ctx_id;
00598     BOOLEAN m_service_init;
00599     String m_data;
00600 };
00601
00602 #endif /* Apoxi_ExternalPsdContextListener_hpp */
00603
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerData.cpp File Reference

Asc/HandlerData.cpp File Reference

#include "Asc/PreComp.hpp"
#include "HandlerData.hpp"

Include dependency graph for HandlerData.cpp:

Generated on Tue Jan 24 17:21:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerData.hpp File Reference

Asc/HandlerData.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Asc/HandlerId.hpp>

Include dependency graph for HandlerData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | HandlerData

Defines

#define | Asc_HandlerData_hpp

Define Documentation

#define Asc_HandlerData_hpp

Generated on Tue Jan 24 17:21:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerData.hpp Source File

Asc/HandlerData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_HandlerData_hpp)
00009 #define Asc_HandlerData_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/LinkedList.hpp>
00016
00017 #include <Asc/HandlerId.hpp>
00018
00019 class MainHandler;
00020 class BaseHandler;
00021 /*  ========================================================================
00022     HandlerData
00023     ======================================================================== */
00024 struct HandlerData {
00025     HandlerId m_id;
00026     BaseHandler* (*CreateHandler)();
00027     BOOLEAN m_is_exclusive;
00028     MainHandler *m_locked_by;
00029
00030     HandlerId Id() const { return (m_id); }
00031     BOOLEAN IsExclusive() const { return (m_is_exclusive); }
00032
00033     BOOLEAN Lock(MainHandler *main_handler);
00034     BOOLEAN Unlock(MainHandler *main_handler);
00035     BOOLEAN IsLocked() const;
00036 };
00037
00039 #endif  // Asc_HandlerData_hpp
00040
00041
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerFactory.hpp File Reference

Asc/HandlerFactory.hpp File Reference

#include <Asc/AccHandler.hpp>
#include <Asc/AocHandler.hpp>
#include <Asc/CallHandler.hpp>
#include <Asc/CbsHandler.hpp>
#include <Asc/CrssHandler.hpp>
#include <Asc/CallDeflectionHandler.hpp>
#include <Asc/MocVoiceHandler.hpp>
#include <Asc/MtcVoiceHandler.hpp>
#include <Asc/NetworkHandler.hpp>
#include <Asc/PlmnHandler.hpp>
#include <Asc/PowerHandler.hpp>
#include <Asc/RtcHandler.hpp>
#include <Asc/SigHandler.hpp>
#include <Asc/SimHandler.hpp>
#include <Asc/AtcHandler.hpp>
#include <Asc/SimTkHandler.hpp>
#include <Asc/SimTkLceHandler.hpp>
#include <Asc/SmsHandler.hpp>
#include <Asc/SsCcbsHandler.hpp>
#include <Asc/BootHandler.hpp>
#include <Asc/SsMainHandler.hpp>
#include <Asc/CallWaitingHandler.hpp>
#include <Asc/CallForwardingHandler.hpp>
#include <Asc/CallBarringHandler.hpp>
#include <Asc/EmlppHandler.hpp>
#include <Asc/ClipHandler.hpp>
#include <Asc/ClirHandler.hpp>
#include <Asc/ColpHandler.hpp>
#include <Asc/ColrHandler.hpp>
#include <Asc/CnapHandler.hpp>
#include <Asc/UssdHandler.hpp>
#include <Asc/MobileOriginatedUssdHandler.hpp>
#include <Asc/CallControlHandler.hpp>
#include <Asc/MultiSlotHandler.hpp>

Include dependency graph for HandlerFactory.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HandlerFactory

Defines

#define | Asc_HandlerFactory_hpp

Define Documentation

#define Asc_HandlerFactory_hpp

Generated on Tue Jan 24 17:21:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerFactory.hpp Source File

Asc/HandlerFactory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002   Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003   ------------------------------------------------------------------------
00004   This document contains proprietary information belonging to COMNEON.
00005   Passing on and copying of this document, use and communication of its
00006   contents is not permitted without prior written authorisation.
00007   ------------------------------------------------------------------------ */
00008 #if !defined(Asc_HandlerFactory_hpp)
00009 #define Asc_HandlerFactory_hpp
00012
00013 #include <Asc/AccHandler.hpp>
00014 #include <Asc/AocHandler.hpp>
00015 #if defined(APOXI_COMPAT_2_2_0)
00016 #include <Asc/BattHandler.hpp>
00017 #endif
00018 #include <Asc/CallHandler.hpp>
00019 #include <Asc/CbsHandler.hpp>
00020 #if defined(APOXI_COMPAT_2_2_0)
00021 #include <Asc/ChrHandler.hpp>
00022 #endif
00023 #include <Asc/CrssHandler.hpp>
00024 //Manik added for Call Deflection - Begin
00025 #include <Asc/CallDeflectionHandler.hpp>
00026 //Manik added for Call Deflection - End
00027 #include <Asc/MocVoiceHandler.hpp>
00028 #include <Asc/MtcVoiceHandler.hpp>
00029 #include <Asc/NetworkHandler.hpp>
00030 #include <Asc/PlmnHandler.hpp>
00031 #include <Asc/PowerHandler.hpp>
00032 #include <Asc/RtcHandler.hpp>
00033 #include <Asc/SigHandler.hpp>
00034 #include <Asc/SimHandler.hpp>
00035 #include <Asc/AtcHandler.hpp>
00036 #include <Asc/SimTkHandler.hpp>
00037 #include <Asc/SimTkLceHandler.hpp>
00038 #include <Asc/SmsHandler.hpp>
00039
00040 // obsolete moved to Compat
00041 #if defined(APOXI_COMPAT_1_7_0)
00042 #include <Asc/SsHandler.hpp>
00043 #endif
00044
00045 #include <Asc/SsCcbsHandler.hpp>
00046 #include <Asc/BootHandler.hpp>
00047
00048 #include <Asc/SsMainHandler.hpp>
00049 #include <Asc/CallWaitingHandler.hpp>
00050 #include <Asc/CallForwardingHandler.hpp>
00051 #include <Asc/CallBarringHandler.hpp>
00052 #include <Asc/EmlppHandler.hpp>
00053 #include <Asc/ClipHandler.hpp>
00054 #include <Asc/ClirHandler.hpp>
00055 #include <Asc/ColpHandler.hpp>
00056 #include <Asc/ColrHandler.hpp>
00057 #include <Asc/CnapHandler.hpp>
00058 #include <Asc/UssdHandler.hpp>
00059 #include <Asc/MobileOriginatedUssdHandler.hpp>
00060
00061 #ifdef APOXI_UUS_SUPPORT
00062     #include <Asc/UusHandler.hpp>
00063 #endif
00064
00065 #include <Asc/CallControlHandler.hpp>
00066
00067 #include <Asc/MultiSlotHandler.hpp>
00068
00069 #ifdef APOXI_COMPAT_2_0_0
00070     #include <Devices/RtcMsgTypes.hpp>
00071 #endif
00072
00073 #if defined APOXI_LIB_ADDON_VR
00074     #include <AddOns/VoiceRecognition/VrHandler.hpp>
00075 #endif
00076
00077 #if defined APOXI_LIB_ADDON_MMCALL
00078     #include <AddOns/MmCall/MmCallHandler.hpp>
00079 #endif
00080
00081
00082 #ifdef APOXI_COMPAT_2_2_0
00083     #include <Devices/ChargerMsgTypes.hpp>
00084 #endif
00085
00086 /* ========================================================================
00087    HandlerFactory
00088    ======================================================================== */
00089 class HandlerFactory {
00090     public:
00091         static BaseHandler* CreateAccHandler() { return (new AccHandler); }
00092         static BaseHandler* CreateAocHandler() { return (new AocHandler); }
00093 #if defined(APOXI_COMPAT_2_2_0)
00094         static BaseHandler* CreateBattHandler() {
00095             ExecutionContext& context = ExecutionContext::GetCurrentContext();
00096             context.RegisterMessage(BatteryLoadLevelMsg::ID);
00097             return (new BattHandler);
00098         }
00099 #endif
00100         static BaseHandler* CreateCallHandler() { return (new CallHandler); }
00101         static BaseHandler* CreateCbsHandler() { return (new CbsHandler); }
00102 #ifdef APOXI_COMPAT_2_2_0
00103         static BaseHandler* CreateChrHandler() {
00104             ExecutionContext& context = ExecutionContext::GetCurrentContext();
00105             context.RegisterMessage(BatteryChargerRemovedMsg::ID);
00106             context.RegisterMessage(BatteryChargingMsg::ID);
00107             context.RegisterMessage(BatteryChargingPausedMsg::ID);
00108             context.RegisterMessage(BatteryChargingResumedMsg::ID);
00109             context.RegisterMessage(BatteryLowMsg::ID);
00110             context.RegisterMessage(BatteryIdErrorMsg::ID);
00111             context.RegisterMessage(BatteryEmptyMsg::ID);
00112             context.RegisterMessage(BatteryStopChargingMsg::ID);
00113
00114             context.RegisterMessage(ChargerInfoMsg::ID);
00115             return (new ChrHandler);
00116         }
00117 #endif
00118
00119         static BaseHandler* CreateCrssHandler() { return (new CrssHandler); }
00120         static BaseHandler* CreateMocVoiceHandler() { return (new MocVoiceHandler); }
00121         static BaseHandler* CreateMtcVoiceHandler() { return (new MtcVoiceHandler); }
00122         static BaseHandler* CreateNetworkHandler() { return (new NetworkHandler); }
00123         static BaseHandler* CreatePlmnHandler() { return (new PlmnHandler); }
00124         static BaseHandler* CreatePowerHandler() { return (new PowerHandler); }
00125     #ifdef APOXI_COMPAT_2_0_0
00126         static BaseHandler* CreateRtcHandler() {
00127             ExecutionContext& context = ExecutionContext::GetCurrentContext();
00128             context.RegisterMessage(MinuteTickMsg::ID);
00129             context.RegisterMessage(AlarmMsg::ID);
00130             return (new RtcHandler);
00131         }
00132     #endif
00133         static BaseHandler* CreateSigHandler() { return (new SigHandler); }
00134         static BaseHandler* CreateSimHandler() { return (new SimHandler); }
00135         static BaseHandler* CreateSmsHandler() { return (new SmsHandler); }
00136         static BaseHandler* CreateAtcHandler() { return (new AtcHandler); }
00137
00138         // obsolete moved to Compat
00139         #if defined(APOXI_COMPAT_1_7_0)
00140             static BaseHandler* CreateSsHandler() { return (new SsHandler); }
00141         #endif
00142
00143         static BaseHandler* CreateSimTkHandler() { return (new SimTkHandler); }
00144 #ifdef  APOXI_LETTERCLASSE_SUPPORT
00145         static BaseHandler* CreateSimTkLceHandler() { return (new SimTkLceHandler); }
00146 #endif
00147
00148         static BaseHandler* CreateSsMainHandler() { return (new SsMainHandler); }
00149         static BaseHandler* CreateCallWaitingHandler() { return (new CallWaitingHandler); }
00150         static BaseHandler* CreateCallForwardingHandler() {return (new CallForwardingHandler); }
00151         static BaseHandler* CreateCallBarringHandler() {return (new CallBarringHandler); }
00152         static BaseHandler* CreateEmlppHandler() {return (new EmlppHandler); }
00153         static BaseHandler* CreateClipHandler() {return (new ClipHandler); }
00154         static BaseHandler* CreateClirHandler() {return (new ClirHandler); }
00155         static BaseHandler* CreateColpHandler() {return (new ColpHandler); }
00156         static BaseHandler* CreateColrHandler() {return (new ColrHandler); }
00157         static BaseHandler* CreateUssdHandler() {return (new UssdHandler); }
00158         static BaseHandler* CreateMoUssdHandler() {return (new MobileOriginatedUssdHandler); }
00159
00160         static BaseHandler* CreateCnapHandler() {return (new CnapHandler); }
00161         static BaseHandler* CreateCallControlHandler() {return (new CallControlHandler); }
00162         static BaseHandler* CreateCallDeflectionHandler() { return (new CallDeflectionHandler); }
00163         static BaseHandler* CreateBootHandler() { return (new BootHandler); }
00164         static BaseHandler* CreateMultiSlotHandler() { return (new MultiSlotHandler); }
00165         static BaseHandler* CreateSsCcbsHandler() { return (new SsCcbsHandler); }
00166
00167 #if defined(APOXI_LIB_ADDON_VR)
00168     static BaseHandler* CreateVrHandler() { return (new VrHandler); }
00169 #endif
00170
00171 #if defined(APOXI_UUS_SUPPORT)
00172     static BaseHandler* CreateUusHandler() { return (new UusHandler); }
00173 #endif
00174
00175 #if defined(APOXI_LIB_ADDON_MMCALL)
00176     static BaseHandler* CreateMmCallHandler() { return (new MmCallHandler); }
00177 #endif
00178 };
00179
00181 #endif  // Asc_HandlerFactory_hpp
00182
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerId.hpp File Reference

Asc/HandlerId.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for HandlerId.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_HandlerId_hpp

Enumerations

enum HandlerId {
AccHandlerId, AocHandlerId, CallHandlerId, CbsHandlerId,
CrssHandlerId, MocVoiceHandlerId, MtcVoiceHandlerId, NetworkHandlerId,
PlmnHandlerId, PowerHandlerId, SigHandlerId, SimHandlerId,
AtcHandlerId, SimTkHandlerId, SimTkLceHandlerId, SmsHandlerId,
SsHandlerId, SsMainHandlerId, SsBaseHandlerId, CallWaitingHandlerId,
CallForwardingHandlerId, CallBarringHandlerId, EmlppHandlerId, ClipHandlerId,
ClirHandlerId, ColpHandlerId, ColrHandlerId, UssdHandlerId,
MoUssdHandlerId, CallControlHandlerId, CallDeflectionHandlerId, BootHandlerId,
MultiSlotHandlerId, SsCcbsHandlerId, CnapHandlerId, MaxHandlerId
}
representes the unique identification of the various sub handler More...

Define Documentation

#define Asc_HandlerId_hpp

Generated on Tue Jan 24 17:21:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerId.hpp Source File

Asc/HandlerId.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_HandlerId_hpp)
00009 #define Asc_HandlerId_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016
00017
00018 /*  ========================================================================
00019     HandlerId
00020     ======================================================================== */
00022 enum HandlerId {
00024     AccHandlerId,
00026     AocHandlerId,
00027 #ifdef APOXI_COMPAT_2_2_0
00028
00029     BattHandlerId,
00030 #endif
00031
00032     CallHandlerId,
00034     CbsHandlerId,
00035 #ifdef APOXI_COMPAT_2_2_0
00036
00037     ChrHandlerId,
00038 #endif
00039
00040     CrssHandlerId,
00042     MocVoiceHandlerId,
00044     MtcVoiceHandlerId,
00046     NetworkHandlerId,
00048     PlmnHandlerId,
00050     PowerHandlerId,
00051 #ifdef APOXI_COMPAT_2_0_0
00052
00053     RtcHandlerId,
00054 #endif
00055
00056     SigHandlerId,
00058     SimHandlerId,
00060     AtcHandlerId,
00062     SimTkHandlerId,
00064     SimTkLceHandlerId,
00066     SmsHandlerId,
00069     SsHandlerId,
00072     SsMainHandlerId,
00073     // Base Handler for Supplementary Service handler
00074     SsBaseHandlerId,
00076     CallWaitingHandlerId,
00078     CallForwardingHandlerId,
00080     CallBarringHandlerId,
00082     EmlppHandlerId,
00084     ClipHandlerId,
00086     ClirHandlerId,
00088     ColpHandlerId,
00090     ColrHandlerId,
00092     UssdHandlerId,
00094     MoUssdHandlerId,
00096     CallControlHandlerId,
00098     CallDeflectionHandlerId,
00100     BootHandlerId,
00102     MultiSlotHandlerId,
00103
00105     SsCcbsHandlerId,
00107     CnapHandlerId,
00108
00109 #if defined(APOXI_LIB_ADDON_VR)
00110
00111     VrHandlerId,
00112 #endif
00113
00114 #if defined(APOXI_UUS_SUPPORT)
00115     UusHandlerId,
00116 #endif
00117
00118 #if defined(APOXI_LIB_ADDON_MMCALL)
00119     MmCallHandlerId,
00120 #endif
00121
00122     MaxHandlerId,
00123 };
00124
00126 #endif  // Asc_HandlerId_hpp
00127
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerList.cpp File Reference

Asc/HandlerList.cpp File Reference

#include "Asc/PreComp.hpp"
#include "HandlerList.hpp"

Include dependency graph for HandlerList.cpp:

Generated on Tue Jan 24 17:21:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerList.hpp File Reference

Asc/HandlerList.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Asc/HandlerData.hpp>

Include dependency graph for HandlerList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | HandlerListEntry

Defines

#define | Asc_HandlerList_hpp

Typedefs

typedef LinkedList< HandlerListEntry > | HandlerList

Define Documentation

#define Asc_HandlerList_hpp

Generated on Tue Jan 24 17:21:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerList.hpp Source File

Asc/HandlerList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_HandlerList_hpp)
00009 #define Asc_HandlerList_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/LinkedList.hpp>
00016
00017 #include <Asc/HandlerData.hpp>
00018
00019 class BaseHandler;
00020 class MainHandler;
00021
00022 /*  ========================================================================
00023     HandlerListEntry
00024     ======================================================================== */
00026 class HandlerListEntry : public Linkable<HandlerListEntry> {
00027     friend class MainHandler;
00028     typedef Linkable<HandlerListEntry> Base;
00029     public:
00031         HandlerListEntry(HandlerId m_id);
00033         virtual ~HandlerListEntry();
00034
00036         HandlerId Id() const { return (m_id); }
00037
00039         BaseHandler* GetHandler() const { return (m_handler); }
00040
00042         BOOLEAN Init(MainHandler *main_handler);
00044         BOOLEAN Cleanup(MainHandler *main_handler, BOOLEAN force = FALSE);
00045
00046     private:
00047         HandlerId m_id;
00048         INT m_ref_count;
00049         BaseHandler *m_handler;
00050
00051         static struct HandlerData m_handler_data_table[];
00052
00053         static HandlerData* GetHandlerData(HandlerId id);
00054
00055         INT RefCount() const { return (m_ref_count); }
00056         void AddRef(INT i) { m_ref_count += i; }
00057 };
00058
00059 /*  ========================================================================
00060     HandlerList
00061     ======================================================================== */
00062 typedef LinkedList<HandlerListEntry> HandlerList;
00063
00065 #endif  // Asc_HandlerList_hpp
00066
00067
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/HandlerListDataTable.cpp File Reference

Asc/HandlerListDataTable.cpp File Reference

#include "Asc/PreComp.hpp"
#include "HandlerList.hpp"
#include "HandlerFactory.hpp"

Include dependency graph for HandlerListDataTable.cpp:

Data Structures

struct HandlerListEntry
Generated on Tue Jan 24 17:21:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputAction.cpp File Reference

Asc/InputAction.cpp File Reference

#include "Asc/PreComp.hpp"
#include "InputAction.hpp"
#include "InputParser.hpp"
#include "InputAnalyzer.hpp"

Include dependency graph for InputAction.cpp:

Functions

void InputAnalyzerTest ()
Generated on Tue Jan 24 17:24:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputAction.hpp File Reference

Asc/InputAction.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Apc/SignalTypes.hpp>
#include <Asc/InputParser.hpp>

Include dependency graph for InputAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ApoxiCommandAction
class | BarringSsAction
class | CallSsAction
class | ClipAction
class | ClirAction
class | CnapAction
class | ColpAction
class | ColrAction
class | EmlppAction
class | EngModeAction
class | ForwardingSsAction
class | ImeiShowAction
class | InputAction
class | LanguageResetAction
class | MoCallAction
class | NumberIdentificationAction
class | PasswordChangeSsAction
class | PbEntryShowAction
class | PinAction
class | UndefinedSsAction
class | UnlockAction
class | UssdAction
class | WaitSsAction

Defines

#define | _Asc_InputAction_hpp

Enumerations

enum InputActionType {
PbEntryShowActionType = 10, ImeiShowActionType = 20, UnlockActionType = 25, EngModeActionType = 30,
ApoxiCommandActionType = 35, LanguageResetActionType = 37, CallSsActionType = 40, PinActionType = 50,
ClirActionType = 60, ClipActionType = 70, CnapActionType = 75, EmlppActionType = 77,
BarringSsActionType = 80, PasswordChangeSsActionType = 85, ColpActionType = 90, ColrActionType = 100,
ForwardingSsActionType = 110, WaitSsActionType = 120, UserDefinedActionType = 130, UssdActionType = 140,
UndefinedSsActionType = 150, MoCallActionType = 160, InvalidActionType = 1000
}

Functions

void | InputAnalyzerTest ()

Variables

const INT | c_invalid_parsed_number = -1

Define Documentation

#define _Asc_InputAction_hpp

Generated on Tue Jan 24 17:24:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputAction.hpp Source File

Asc/InputAction.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Asc_InputAction_hpp)
00015 #define _Asc_InputAction_hpp
00018
00019 #include <Kernel/Types.hpp>
00020 #include <Auxiliary/WString.hpp>
00021 #include <Auxiliary/PhoneNumber.hpp>
00022 #include <Apc/SignalTypes.hpp>
00023
00024 #include <Asc/InputParser.hpp>
00025
00027
00028 void InputAnalyzerTest();
00029
00031
00032 const INT c_invalid_parsed_number = -1;
00033
00035
00037 enum InputActionType {
00039     PbEntryShowActionType = 10,
00041     ImeiShowActionType = 20,
00043     UnlockActionType = 25,
00045     EngModeActionType = 30,
00047     ApoxiCommandActionType = 35,
00049     LanguageResetActionType = 37,
00051     CallSsActionType = 40,
00053     PinActionType = 50,
00055     ClirActionType = 60,
00057     ClipActionType = 70,
00059     CnapActionType = 75,
00061     EmlppActionType = 77,
00063     BarringSsActionType = 80,
00065     PasswordChangeSsActionType = 85,
00067     ColpActionType = 90,
00069     ColrActionType = 100,
00071     ForwardingSsActionType = 110,
00073     WaitSsActionType = 120,
00075     UserDefinedActionType = 130,
00077     UssdActionType = 140,
00079     UndefinedSsActionType = 150,
00081     MoCallActionType = 160,
00083     InvalidActionType = 1000
00084 };
00085
00087
00088 class InputContext;
00089
00093 class InputAction
00094 {
00095     public:
00097         InputAction();
00099         virtual ~InputAction();
00101         virtual BOOLEAN IsExecutionPossible();
00103         virtual BOOLEAN HasWrongSyntax();
00105         virtual BOOLEAN ShallExecuteImmediatly();
00107         virtual InputActionType GetActionType() const;
00109         virtual InputAction * Analyze(const WString & , const InputContext * );
00111         virtual BOOLEAN Execute();
00113         const WString & GetSourceString() const { return m_sourcestring; }
00114
00115         INT GetParsePriority() const { return (INT)GetActionType(); }
00116
00117     protected:
00118         static  INT ParseNumber(const WCHAR * str, INT maxdigits = 255);
00119         void    Clear() { m_sourcestring.Clear(); m_syntaxerror = FALSE; }
00120
00121         WString m_sourcestring;
00122         BOOLEAN m_syntaxerror;
00123
00124 };
00125
00127
00132 class PbEntryShowAction : public InputAction
00133 {
00134     public:
00136         PbEntryShowAction();
00138         explicit PbEntryShowAction(INT entrynr);
00140         virtual ~PbEntryShowAction();
00142         virtual BOOLEAN IsExecutionPossible();
00144         virtual BOOLEAN ShallExecuteImmediatly();
00146         virtual InputActionType GetActionType() const;
00148         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00150         INT GetEntryNr() const { return m_entrynr; }
00151
00152     private:
00153         INT m_entrynr;
00154
00155 };
00156
00158
00163 class UnlockAction : public InputAction
00164 {
00165     public:
00167         UnlockAction();
00169         virtual ~UnlockAction();
00172         virtual BOOLEAN IsExecutionPossible() = 0;
00177         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context) = 0;
00180         virtual BOOLEAN Execute() = 0;
00181
00183         virtual InputActionType GetActionType() const;
00184
00185 };
00186
00188
00193 class MoCallAction : public InputAction
00194 {
00195     public:
00197         enum Type {
00199             Default,
00201             DisplayPhoneNumber,
00203             SurpressPhoneNumber
00204         };
00205
00207         MoCallAction();
00209         explicit MoCallAction(const PhoneNumber & phnr);
00211         virtual ~MoCallAction();
00213         virtual BOOLEAN IsExecutionPossible();
00215         virtual InputActionType GetActionType() const;
00217         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00218
00220         const PhoneNumber & GetPhoneNumber() const { return m_phonenr; }
00221
00223         MoCallAction::Type GetMocType() const { return m_moc_type; }
00224
00225     private:
00226         PhoneNumber m_phonenr;
00227         Type        m_moc_type;
00228
00229 };
00230
00232
00237 class ImeiShowAction : public InputAction
00238 {
00239     public:
00241         ImeiShowAction();
00243         virtual ~ImeiShowAction();
00245         virtual BOOLEAN ShallExecuteImmediatly();
00247         virtual BOOLEAN IsExecutionPossible();
00249         virtual InputActionType GetActionType() const;
00251         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00252
00253 };
00254
00256
00261 class EngModeAction : public InputAction
00262 {
00263     public:
00265         EngModeAction();
00267         virtual ~EngModeAction();
00268
00270         virtual BOOLEAN ShallExecuteImmediatly();
00272         virtual BOOLEAN IsExecutionPossible();
00274         virtual InputActionType GetActionType() const;
00276         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00277
00278 };
00279
00281
00286 class CallSsAction : public InputAction
00287 {
00288     public:
00290         enum CallSsActionId {
00292             ReleaseAllHeldOrSetUdub,
00294             ReleaseAllActiveAndAcceptOther,
00296             ReleaseSpecificCall,
00298             PlaceAllActiveOnHold,
00300             PlaceAllActiveOnHoldExceptSpecificCall,
00302             AddHeldCall,
00304             ConnectTwoCallsAndDisconnectSubscriber,
00306             RedirectCall,
00308             ActivateCompletionOfCalls,
00310             Invalid
00311         };
00313         CallSsAction();
00315         virtual ~CallSsAction();
00316
00318         virtual BOOLEAN IsExecutionPossible();
00320         virtual InputActionType GetActionType() const;
00322         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00323
00325         CallSsActionId GetCallSsActionId() const { return m_type; }
00327         INT GetCallIdx() const { return m_callidx; }
00329         const PhoneNumber & GetPhoneNumber() const { return m_phonenr; }
00330
00331     private:
00332         CallSsActionId   m_type;
00333         INT              m_callidx;
00334         PhoneNumber      m_phonenr;
00335 };
00336
00338
00343 class PinAction : public InputAction
00344 {
00345     public:
00347         enum Type {
00349             ChangePin,
00351             UnblockPin,
00353             Invalid
00354         };
00355
00357         PinAction();
00359         virtual ~PinAction();
00360
00362         virtual BOOLEAN IsExecutionPossible();
00364         virtual BOOLEAN ShallExecuteImmediatly();
00366         virtual InputActionType GetActionType() const;
00368         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00369
00371         ChvNo           GetChvNo() const { return m_chvno; }
00373         PinAction::Type GetType() const { return m_type; }
00375         const WString & GetOldPin() const { ASSERT(m_type==ChangePin); return m_pin; }
00377         const WString & GetUnblockPin() const { ASSERT(m_type==UnblockPin); return m_pin; }
00379         const WString & GetNewPin() const { ASSERT(m_type!=Invalid); return m_newpin1; }
00381         const WString & GetNewPin2() const { ASSERT(m_type!=Invalid); return m_newpin2; }
00382
00383     private:
00384         ChvNo   m_chvno;
00385         Type    m_type;
00386         WString m_pin;
00387         WString m_newpin1;
00388         WString m_newpin2;
00389 };
00390
00392
00397 class ClirAction : public InputAction
00398 {
00399     public:
00401         ClirAction();
00403         virtual ~ClirAction();
00404
00406         virtual BOOLEAN IsExecutionPossible();
00408         virtual InputActionType GetActionType() const;
00410         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00411
00413         InputParser::SsProcedure GetSsProcedure() const { return m_procedure; }
00415         const PhoneNumber & GetClirPhoneNumber() const { return m_phonenr; }
00416
00417     private:
00418         InputParser::SsProcedure m_procedure;
00419         PhoneNumber              m_phonenr;
00420 };
00421
00422
00424
00428 class NumberIdentificationAction : public InputAction
00429 {
00430     public:
00432         NumberIdentificationAction();
00434         virtual ~NumberIdentificationAction();
00436         virtual BOOLEAN IsExecutionPossible();
00438         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00439
00441         InputParser::SsProcedure GetSsProcedure() const { return m_procedure; }
00442
00443     protected:
00444         virtual InputParser::SsCode GetSsCode() const = 0;
00445
00446     private:
00447         InputParser::SsProcedure m_procedure;
00448 };
00449
00451
00455 class ClipAction : public NumberIdentificationAction
00456 {
00457     public:
00459         virtual InputActionType GetActionType() const;
00460
00461     protected:
00462         virtual InputParser::SsCode GetSsCode() const;
00463
00464 };
00465
00467
00471 class CnapAction : public NumberIdentificationAction
00472 {
00473     public:
00475         virtual InputActionType GetActionType() const;
00476
00477     protected:
00478         virtual InputParser::SsCode GetSsCode() const;
00479
00480 };
00481
00483
00487 class ColpAction : public NumberIdentificationAction
00488 {
00489     public:
00491         virtual InputActionType GetActionType() const;
00492
00493     protected:
00494         virtual InputParser::SsCode GetSsCode() const;
00495
00496 };
00497
00499
00503 class ColrAction : public NumberIdentificationAction
00504 {
00505     public:
00507         virtual InputActionType GetActionType() const;
00508
00509     protected:
00510         virtual InputParser::SsCode GetSsCode() const;
00511
00512 };
00513
00514
00516
00521 class BarringSsAction : public InputAction
00522 {
00523     public:
00525         BarringSsAction();
00527         virtual ~BarringSsAction();
00528
00530         virtual BOOLEAN IsExecutionPossible();
00532         virtual InputActionType GetActionType() const;
00534         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00535
00537         InputParser::SsProcedure GetSsProcedure() const { return m_procedure; }
00539         InputParser::SsCode      GetSsCode() const { return m_code; }
00540
00542         const WString & GetPassword() const { return m_pw; }
00544         InputParser::BasicServiceMmiCode GetBasicServiceMmiCode() const { return m_bsg; }
00545
00546     private:
00547         InputParser::SsProcedure            m_procedure;
00548         InputParser::SsCode                 m_code;
00549         WString                             m_pw;
00550         InputParser::BasicServiceMmiCode    m_bsg;
00551 };
00552
00554
00558 class EmlppAction : public InputAction
00559 {
00560     public:
00562         EmlppAction();
00564         virtual ~EmlppAction();
00565
00567         virtual BOOLEAN IsExecutionPossible();
00569         virtual InputActionType GetActionType() const;
00571         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00572
00574         InputParser::SsProcedure GetSsProcedure() const { return m_procedure; }
00576         InputParser::SsCode      GetSsCode() const { return m_code; }
00578         INT                      GetPriority() const { return m_priority; }
00579
00580     private:
00581         InputParser::SsProcedure            m_procedure;
00582         InputParser::SsCode                 m_code;
00583         INT                                 m_priority;
00584 };
00585
00586
00588
00593 class PasswordChangeSsAction : public InputAction
00594 {
00595     public:
00597         PasswordChangeSsAction();
00599         virtual ~PasswordChangeSsAction();
00601         virtual BOOLEAN IsExecutionPossible();
00603         virtual InputActionType GetActionType() const;
00605         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00606
00608         InputParser::SsProcedure GetSsProcedure() const { return m_procedure; }
00610         InputParser::SsCode      GetSsCode() const { return m_code; }
00611
00613         const WString & GetOldPassword() const { return m_oldpw; }
00615         const WString & GetNewPassword() const { return m_newpw; }
00617         const WString & GetNewPassword2() const { return m_newpw2; }
00618
00619     private:
00620         InputParser::SsProcedure            m_procedure;
00621         InputParser::SsCode                 m_code;
00622         WString                             m_oldpw;
00623         WString                             m_newpw;
00624         WString                             m_newpw2;
00625 };
00626
00628
00633 class ForwardingSsAction : public InputAction
00634 {
00635     public:
00637         ForwardingSsAction();
00639         virtual ~ForwardingSsAction();
00640
00642         virtual BOOLEAN IsExecutionPossible();
00644         virtual InputActionType GetActionType() const;
00646         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00647
00649         InputParser::SsProcedure GetSsProcedure() const { return m_procedure; }
00651         InputParser::SsCode      GetSsCode() const { return m_code; }
00652
00654         const WString & GetPhoneNumber() const { return m_phonenr; }
00656         InputParser::BasicServiceMmiCode GetBasicServiceMmiCode() const { return m_bsg; }
00658         const WString & GetConditionTimer() const { return m_timer; }
00659
00660     private:
00661         InputParser::SsProcedure            m_procedure;
00662         InputParser::SsCode                 m_code;
00663         InputParser::BasicServiceMmiCode    m_bsg;
00664         WString                             m_phonenr;
00665         WString                             m_timer;
00666 };
00667
00669
00673 class WaitSsAction : public InputAction
00674 {
00675     public:
00677         WaitSsAction();
00679         virtual ~WaitSsAction();
00680
00682         virtual BOOLEAN IsExecutionPossible();
00684         virtual InputActionType GetActionType() const;
00686         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00688         InputParser::SsProcedure GetSsProcedure() const { return m_procedure; }
00690         InputParser::BasicServiceMmiCode GetBasicServiceMmiCode() const { return m_bsg; }
00691
00692     private:
00693         InputParser::SsProcedure            m_procedure;
00694         InputParser::BasicServiceMmiCode    m_bsg;
00695
00696 };
00697
00698
00700
00705 class UndefinedSsAction : public InputAction
00706 {
00707     public:
00709         UndefinedSsAction();
00711         virtual ~UndefinedSsAction();
00712
00714         virtual BOOLEAN IsExecutionPossible();
00716         virtual InputActionType GetActionType() const;
00718         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00719
00720     private:
00721         InputParser::SsProcedure m_procedure;
00722 };
00723
00725
00729 class UssdAction : public InputAction
00730 {
00731     public:
00733         UssdAction();
00735         virtual ~UssdAction();
00736
00738         virtual BOOLEAN IsExecutionPossible();
00740         virtual InputActionType GetActionType() const;
00742         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00743
00744     private:
00745 };
00746
00748
00752 class ApoxiCommandAction : public InputAction
00753 {
00754     public:
00756         ApoxiCommandAction();
00758         virtual ~ApoxiCommandAction();
00759
00761         virtual BOOLEAN IsExecutionPossible();
00763         virtual InputActionType GetActionType() const;
00765         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00767         UINT GetCommandId() const { return m_command_id; }
00769         const WString & GetCommandString() const { return m_command_str; }
00770
00771     private:
00772         UINT    m_command_id;
00773         WString m_command_str;
00774 };
00775
00777
00782 class LanguageResetAction : public InputAction
00783 {
00784     public:
00786         LanguageResetAction();
00788         virtual ~LanguageResetAction();
00790         virtual BOOLEAN IsExecutionPossible();
00792         virtual BOOLEAN ShallExecuteImmediatly();
00794         virtual InputActionType GetActionType() const;
00796         virtual InputAction * Analyze(const WString & actionstring, const InputContext * context);
00798         INT GetLanguageCode() const { return m_language_code; }
00799
00800     private:
00801         INT m_language_code;
00802 };
00803
00804
00806 #endif
00807
00808
Generated on Tue Jan 24 14:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputAnalyzer.cpp File Reference

Asc/InputAnalyzer.cpp File Reference

#include "Asc/PreComp.hpp"
#include "InputAnalyzer.hpp"
#include "InputAction.hpp"
#include "CallHandlingData.hpp"
#include "MainHandler.hpp"

Include dependency graph for InputAnalyzer.cpp:

Generated on Tue Jan 24 17:24:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputAnalyzer.hpp File Reference

Asc/InputAnalyzer.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/InputAction.hpp>
#include <Auxiliary/ElementList.hpp>

Include dependency graph for InputAnalyzer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InputActionList
class | InputActionPtr
class | InputAnalyzer
class | InputContext

Defines

#define | _Asc_InputAnalyzer_hpp

Define Documentation

#define _Asc_InputAnalyzer_hpp

Generated on Tue Jan 24 17:24:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputAnalyzer.hpp Source File

Asc/InputAnalyzer.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Asc_InputAnalyzer_hpp)
00015 #define _Asc_InputAnalyzer_hpp
00018
00019 #include <Kernel/Types.hpp>
00020
00021 #include <Asc/InputAction.hpp>
00022 #include <Auxiliary/ElementList.hpp>
00023
00025
00026
00027 class InputActionPtr : public Linkable<InputActionPtr>
00028 {
00029     public:
00030         InputActionPtr() : m_action(0) {}
00031         explicit InputActionPtr(InputAction * action) : m_action(action) { ASSERT(action!=0); }
00032
00033         BOOLEAN operator == (const InputActionPtr &ptr) const { return (m_action == ptr.m_action); }
00034
00035         InputAction * GetInputAction() { ASSERT(m_action!=0); return m_action; }
00036
00037         BOOLEAN operator < (const InputActionPtr &ptr) const {
00038             ASSERT(m_action!=0 && ptr.m_action!=0);
00039             return (m_action->GetParsePriority() < ptr.m_action->GetParsePriority());
00040         }
00041
00042
00043     private:
00044         InputAction * m_action;
00045
00046 };
00047
00049
00055 class InputActionList : public SortedElementList<InputActionPtr>
00056 {
00057     public:
00059         InputActionList() {}
00060
00062         void RegisterInputAction(InputAction * action);
00063 };
00064
00066
00069 class InputContext
00070 {
00071     public:
00072         InputContext();
00074         explicit InputContext(Application * application);
00075         // only for test purposes
00076         InputContext(Application * application, BOOLEAN msp, BOOLEAN ace,
00077                      BOOLEAN hce, BOOLEAN cse = FALSE);
00079         ~InputContext();
00080
00081         BOOLEAN IsMocSetupPermitted() const { return m_mocsetuppermitted; }
00082         BOOLEAN ActiveCallExists() const { return m_activecallexists; }
00083         BOOLEAN HeldCallExists() const { return m_heldcallexists; }
00084         BOOLEAN CallInSetupExists() const { return m_callinsetupexists; }
00085         BOOLEAN IsCingularActive() const { return m_cingularactive; }
00086
00087         void SetCingularActive(BOOLEAN active = TRUE) { m_cingularactive = active; }
00088
00089
00091         BOOLEAN Update();
00092
00093     private:
00094         BOOLEAN  m_mocsetuppermitted;
00095         BOOLEAN  m_activecallexists;
00096         BOOLEAN  m_heldcallexists;
00097         BOOLEAN  m_callinsetupexists;
00098         BOOLEAN  m_cingularactive;
00099 };
00100
00102
00107 class InputAnalyzer
00108 {
00109     public:
00110         InputAnalyzer() : m_actionlist(0) {}
00111
00113         explicit InputAnalyzer(const InputActionList * actionlist);
00115         ~InputAnalyzer();
00116
00117         void Init(const InputActionList * actionlist);
00118
00120         InputAction * GetFirstInputAction(const WString & actionstring, const InputContext * context = 0);
00121
00122         static BOOLEAN IsStorableMocPhoneNumber(const PhoneNumber & phno);
00123
00124     private:
00125         const InputActionList * m_actionlist;
00126 };
00127
00129
00131 #endif
00132
00133
Generated on Tue Jan 24 14:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputParser.cpp File Reference

Asc/InputParser.cpp File Reference

#include "Asc/PreComp.hpp"
#include "InputParser.hpp"
#include "InputAction.hpp"

Include dependency graph for InputParser.cpp:

Generated on Tue Jan 24 17:24:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputParser.hpp File Reference

Asc/InputParser.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for InputParser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InputParser
class | LexAnalyzer

Defines

#define | _Asc_InputParser_hpp

Enumerations

enum LexToken {
StarToken, HashToken, StringToken, EosToken,
InvalidToken
}

Define Documentation

#define _Asc_InputParser_hpp

Generated on Tue Jan 24 17:24:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputParser.hpp Source File

Asc/InputParser.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Asc_InputParser_hpp)
00015 #define _Asc_InputParser_hpp
00018
00019 #include <Kernel/Types.hpp>
00020
00021 #include <Auxiliary/WString.hpp>
00022
00024
00025 enum LexToken {
00026     StarToken,
00027     HashToken,
00028     StringToken,
00029     EosToken,
00030     InvalidToken
00031 };
00032
00033
00034 class LexAnalyzer
00035 {
00036     public:
00037         LexAnalyzer() : m_len(0), m_idx(0), m_startidx(0) {}
00038         explicit LexAnalyzer(const WString & ssstring);
00039         ~LexAnalyzer();
00040
00041         LexToken GetFirstLexToken(WString & retparam);
00042         LexToken GetNextLexToken(WString & retparam);
00043         void JumpBack();
00044         void GetRest(WString & rest);
00045
00046     private:
00047         const WString m_string;
00048         const INT m_len;
00049         INT   m_idx;
00050         INT   m_startidx;
00051
00052 };
00053
00055
00059 //lint -e{1712} suppress Info default constructor not defined for class 'InputParser'
00060 class InputParser
00061 {
00062     public:
00064         enum SsProcedure {   // dont change order, range operations are done
00066             Activation,
00068             Deactivation,
00070             Registration,
00072             Erasure,
00074             Interrogation,
00076             InvalidProcedure
00077         };
00078
00080         enum SsCode {   // dont change order, range operations are done on enums
00082             CLIP,                   // 30
00084             CLIR,                   // 31
00086             COLP,                   // 76
00088             COLR,                   // 77
00089
00090 // forwarding services must be in range -------------
00092             CFU,                    // 21
00094             CFBusy,                 // 67
00096             CFNoReply,              // 61
00098             CFNotReachable,         // 62
00100             AllCF,                  // 002
00102             AllConditionalCF,       // 004
00103 //---------------------------------------------------
00104
00105
00106 // barring services must be in range ----------------
00108             BAOC,                    // 33
00110             BAOIC,                   // 331
00112             BAOICexchome,            // 332
00114             BAIC,                    // 35
00116             BAICroaming,             // 351
00118             AllBarrServices,         // 330
00120             OutgBarrServices,        // 333
00122             IncBarrServices,         // 353
00123 // --------------------------------------------------
00124
00126             ChangePin,               // 04
00128             ChangePin2,              // 042
00130             UnblockPin,              // 05
00132             UnblockPin2,             // 052
00134             Wait,                   // 43
00136             UUSService1,            // 361
00138             UUSService2,            // 362
00140             UUSService3,            // 363
00142             AllUUSServices,         // 360
00144             ECT,                     // 96
00146             CCBS,                    // 37
00148             FM,                      // 214
00150             CNAP,                    // 300
00152             MSP,                     // 59n  where n=1-4
00154             MC,                      // 88
00156             RegisterNewPassword,     // 03
00158             EMLPP,                  // 75 or 75n n=0-4
00160             CD,                     // 66
00162             AllSsServices,          // <empty> for passwordchange
00164             InvalidSsCode
00165         };
00166
00168         enum BasicServiceMmiCode {
00170             AllServices,                // empty string
00172             AllTeleServices,            // 10
00174             Telephony,                  // 11
00176             AllDataServices,            // 12
00178             FacsimileServices,          // 13
00180             ShortMessageServices,       // 16
00182             AllTeleServicesExceptSMS,   // 19
00184             VoiceGroupCallService,      // 17
00186             VoiceBroadcastService,      // 18
00188             AllBearerServices,          // 20
00190             AllAsyncServices,           // 21
00192             AllSyncServices,            // 22
00194             AllDataCircuitSync,         // 24
00196             AllDataCircuitAsync,        // 25
00198             AuxiliarySpeech,            // 89   CPHS !!!
00200             AllGPRSBearerServices,      // 99
00202             InvalidServiceGroup
00203         };
00204
00205         InputParser() {}
00206         explicit InputParser(const WString & ssstring);
00207         ~InputParser();
00208
00209         SsProcedure GetSsProcedure();
00210         SsCode      GetSsCode(INT & additionaldigit);
00211         SsCode      GetSsCode(const WString & ssstring, INT & additionaldigit);
00212
00213         LexToken    GetNextToken(WString & parsedstring) {
00214             return m_lex.GetNextLexToken(parsedstring);
00215         }
00216         void GetRest(WString & parsedstring) {
00217             m_lex.GetRest(parsedstring);
00218         }
00219
00220         static const WCHAR * GetSSProcedureString(SsProcedure procedure);
00221         static const WCHAR * GetSSCodeString(SsCode code);
00222         static const WCHAR * GetBasicServiceMmiCodeString(InputParser::BasicServiceMmiCode code);
00223         static InputParser::BasicServiceMmiCode GetBasicServiceMmiCode(const WString & bsgstring);
00224
00225     private:
00226         LexAnalyzer m_lex;
00227
00228 };
00229
00231
00233 #endif
00234
00235
Generated on Tue Jan 24 14:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputParserTranslator.cpp File Reference

Asc/InputParserTranslator.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Apc/SignalTypes.hpp>
#include <Asc/InputParser.hpp>
#include "InputParserTranslator.hpp"

Include dependency graph for InputParserTranslator.cpp:

Generated on Tue Jan 24 17:25:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputParserTranslator.hpp File Reference

Asc/InputParserTranslator.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_InputParserTranslator_hpp

Define Documentation

#define Asc_InputParserTranslator_hpp

Generated on Tue Jan 24 17:25:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/InputParserTranslator.hpp Source File

Asc/InputParserTranslator.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_InputParserTranslator_hpp)
00011 #define Asc_InputParserTranslator_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Asc/InputParser.hpp>
00016
00017 class InputParserTranslator {
00018  public:
00024   static SsCode Ss2Ss(InputParser::SsCode ip_ss);
00025
00031   static InputParser::SsCode Ss2Ss(SsCode std_ss);
00032
00038   static const SsGroup& Bs2SsGroup(InputParser::BasicServiceMmiCode bs);
00039
00044   static InputParser::BasicServiceMmiCode SsGroup2Bs(SsGroup &sg);
00045
00046
00051   static ServiceGroup Bs2Sg(InputParser::BasicServiceMmiCode bs);
00052
00057  static InputParser::BasicServiceMmiCode Sg2Bs(ServiceGroup sg);
00058
00063   static void Sg2SsGroup(ServiceGroup sg, SsGroup& ss_group);
00064   static InputParser::SsProcedure SsOpcode2MmiProc(SsOperationCode op_code);
00065   static SsOperationCode MmiProc2SsOpcode(InputParser::SsProcedure mmi_proc);
00066
00067 };
00068
00069 #endif // DOXYGEN_SHOULD_SKIP_THIS
00070 #endif // Asc_InputParserTranslator_hpp
00071
Generated on Tue Jan 24 14:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Lib.hpp File Reference

Asc/Lib.hpp File Reference

#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Types.hpp>
#include <Asc/HandlerId.hpp>
#include <Asc/MainHandler.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Asc/StackControl.hpp>
#include <Asc/CallHandler.hpp>
#include <Asc/CallHdl.hpp>
#include <Asc/CbsHandler.hpp>
#include <Asc/CrssHandler.hpp>
#include <Asc/CallDeflectionHandler.hpp>
#include <Asc/MocVoiceHandler.hpp>
#include <Asc/MptyCallHdl.hpp>
#include <Asc/MtcVoiceHandler.hpp>
#include <Asc/NetworkHandler.hpp>
#include <Asc/PlmnHandler.hpp>
#include <Asc/PowerHandler.hpp>
#include <Asc/RtcHandler.hpp>
#include <Asc/SigHandler.hpp>
#include <Asc/SimHandler.hpp>
#include <Asc/AtcHandler.hpp>
#include <Asc/SmsHandler.hpp>
#include <Asc/SmsContext.hpp>
#include <Asc/SmsFactory.hpp>
#include <Asc/SmsSocket.hpp>
#include <Asc/SmsSocketListener.hpp>
#include <Asc/SsCcbsHandler.hpp>
#include <Asc/SimTkHandler.hpp>
#include <Asc/AocHandler.hpp>
#include <Asc/DataCall.hpp>
#include <Asc/PdpContextManager.hpp>

Include dependency graph for Lib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_Lib_hpp

Define Documentation

#define Asc_Lib_hpp

Generated on Tue Jan 24 14:53:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Lib.hpp Source File

Asc/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Lib_hpp)
00009 #define Asc_Lib_hpp
00012
00013 #include <Apc/Lib.hpp>
00014 #include <Adc/Lib.hpp>
00015
00016 #include <Asc/Types.hpp>
00017 #include <Asc/HandlerId.hpp>
00018 #include <Asc/MainHandler.hpp>
00019 #include <Asc/StackIndicationMsgTypes.hpp>
00020 #include <Asc/StackControl.hpp>
00021 #if defined(APOXI_COMPAT_2_2_0)
00022     #include <Asc/BattHandler.hpp>
00023 #endif
00024 #include <Asc/CallHandler.hpp>
00025 #include <Asc/CallHdl.hpp>
00026 #include <Asc/CbsHandler.hpp>
00027 #if defined(APOXI_COMPAT_2_2_0)
00028     #include <Asc/ChrHandler.hpp>
00029 #endif
00030 #include <Asc/CrssHandler.hpp>
00031 #include <Asc/CallDeflectionHandler.hpp>
00032 #include <Asc/MocVoiceHandler.hpp>
00033 #include <Asc/MptyCallHdl.hpp>
00034 #include <Asc/MtcVoiceHandler.hpp>
00035 #include <Asc/NetworkHandler.hpp>
00036 #include <Asc/PlmnHandler.hpp>
00037 #include <Asc/PowerHandler.hpp>
00038 #include <Asc/RtcHandler.hpp>
00039 #include <Asc/SigHandler.hpp>
00040 #include <Asc/SimHandler.hpp>
00041 #include <Asc/AtcHandler.hpp>
00042 #include <Asc/SmsHandler.hpp>
00043 #include <Asc/SmsContext.hpp>
00044 #include <Asc/SmsFactory.hpp>
00045 #include <Asc/SmsSocket.hpp>
00046 #include <Asc/SmsSocketListener.hpp>
00047 #include <Asc/SsCcbsHandler.hpp>
00048 #include <Asc/SimTkHandler.hpp>
00049 #include <Asc/AocHandler.hpp>
00050
00051 #include <Asc/DataCall.hpp>
00052 #include <Asc/PdpContextManager.hpp>
00053
00054 // obsolete moved to Compat
00055 #if defined(APOXI_COMPAT_1_7_0)
00056 #include <Asc/SsHandler.hpp>
00057 #endif
00058
00060 #endif  // Asc_Lib_hpp
00061
00062
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MainHandler.cpp File Reference

Asc/MainHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "MainHandler.hpp"
#include <Kernel/VersionInfo.hpp>

Include dependency graph for MainHandler.cpp:

Functions

ApoxiUseVersionInfo (Asc)

Function Documentation

ApoxiUseVersionInfo ( Asc )

Generated on Tue Jan 24 17:25:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MainHandler.hpp File Reference

Asc/MainHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/HandlerList.hpp>
#include <Asc/CallHandlingData.hpp>

Include dependency graph for MainHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MainHandler
The main handler is the entry point to the ASC library. More...
struct | MainHandler::HandlerDependency

Defines

#define | Asc_MainHandler_hpp

Typedefs

typedef LinkedList< MainHandler > | MainHandlerList

Define Documentation

#define Asc_MainHandler_hpp

Generated on Tue Jan 24 17:25:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MainHandler.hpp Source File

Asc/MainHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_MainHandler_hpp)
00009 #define Asc_MainHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/HandlerList.hpp>
00016 #include <Asc/CallHandlingData.hpp>
00017
00018 class Application;      // from Kernel
00019 class DataHandler;      // from Adc
00020 class MainProvider;     // from Adc
00021 class SimAccessor;      // from Adc
00022 class BaseHandler;
00023 class StackMsgArgument;
00024
00025 /*  ========================================================================
00026     MainHandler
00027     ======================================================================== */
00029 class MainHandler : public Linkable<MainHandler>{
00030     public:
00032         MainHandler();
00034         virtual ~MainHandler();
00035
00037         static BOOLEAN Startup();
00038
00040         BOOLEAN Init(ExecutionContext *context);
00042         BOOLEAN Mount(HandlerId id);
00044         BaseHandler* GetHandler(HandlerId id) const;
00046         BOOLEAN IsMounted(HandlerId id) const;
00048         BOOLEAN Unmount(HandlerId id);
00051         BOOLEAN Cleanup();
00052
00054         ExecutionContext* GetExecutionContext() const;
00055
00057         static CallHandlingData* GetCallHandlingData() { return &m_call_handling_data; }
00058
00060         static Mutex* GetCallDataMutex() { return &m_call_data_mutex; }
00061
00062         static void PostMsg(const Message & msg);
00063         static void PostToStackMsg(StackMsgArgument * arg);
00064
00065
00066     private:
00067         ExecutionContext *m_context;
00068         HandlerList m_handler_list;
00069
00070         static Mutex            m_call_data_mutex; //
00071         static CallHandlingData m_call_handling_data;
00072         static BOOLEAN          m_call_data_mutex_is_initialized;
00073         static const struct HandlerDependency {
00074             HandlerId trigger;
00075             HandlerId to_mount;
00076         } m_handler_dependency_table[];
00077
00078         void MountDependentHandler(HandlerId trigger);
00079         void UnmountDependentHandler(HandlerId trigger);
00080
00081         HandlerListEntry* GetHandlerListEntry(HandlerId id) const;
00082
00083         BOOLEAN IsInitialized() const { return (m_context != 0); }
00084 };
00085
00086 /*  ========================================================================
00087     HandlerList
00088     ======================================================================== */
00089 typedef LinkedList<MainHandler> MainHandlerList;
00090
00092 #endif
00093
00094
Generated on Tue Jan 24 14:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MainHandlerAccess.cpp File Reference

Asc/MainHandlerAccess.cpp File Reference

#include "Asc/PreComp.hpp"
#include "MainHandler.hpp"
#include "MainHandlerAccess.hpp"

Include dependency graph for MainHandlerAccess.cpp:

Generated on Tue Jan 24 17:25:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MainHandlerAccess.hpp File Reference

Asc/MainHandlerAccess.hpp File Reference

#include <Auxiliary/Macros.hpp>

Include dependency graph for MainHandlerAccess.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MainHandlerAccess

Defines

#define | Asc_MainHandlerAccess_hpp

Define Documentation

#define Asc_MainHandlerAccess_hpp

Generated on Tue Jan 24 17:25:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MainHandlerAccess.hpp Source File

Asc/MainHandlerAccess.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_MainHandlerAccess_hpp)
00009 #define Asc_MainHandlerAccess_hpp
00010
00011 #include <Auxiliary/Macros.hpp>
00012
00013
00014 class Application;
00015 class DataHandler;
00016 class MainHandler;
00017 class CallHandlingData;
00018 class Semaphore;
00019 class Mutex;
00020
00021 /*  ========================================================================
00022     MainHandlerAccess
00023     ======================================================================== */
00026 class MainHandlerAccess {
00027     public:
00029         MainHandlerAccess(MainHandler *main_handler = 0);
00031         ~MainHandlerAccess();
00032
00034         Application* GetApplication();
00035
00037         MainHandler* GetMainHandler() const { return (m_main_handler); };
00038
00039     private:
00041         MainHandler *m_main_handler;
00042 };
00043
00044 #endif // Asc_MainHandlerAccess_hpp
00045
00046
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MobileOriginatedUssdHandler.cpp File Reference

Asc/MobileOriginatedUssdHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Auxiliary/Vector.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "SsMainHandler.hpp"
#include "MobileOriginatedUssdHandler.hpp"
#include "SupplementaryServiceWaitDispatcher.hpp"

Include dependency graph for MobileOriginatedUssdHandler.cpp:

Generated on Tue Jan 24 17:25:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MobileOriginatedUssdHandler.hpp File Reference

Asc/MobileOriginatedUssdHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/UssdHandler.hpp>

Include dependency graph for MobileOriginatedUssdHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MobileOriginatedUssdHandler

Defines

#define | Asc_MobileOriginatedUssdHandler_hpp

Define Documentation

#define Asc_MobileOriginatedUssdHandler_hpp

Generated on Tue Jan 24 17:25:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MobileOriginatedUssdHandler.hpp Source File

Asc/MobileOriginatedUssdHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_MobileOriginatedUssdHandler_hpp)
00011 #define Asc_MobileOriginatedUssdHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/UssdHandler.hpp>
00016
00028 class MobileOriginatedUssdHandler : public UssdHandler {
00031     typedef UssdHandler Base;
00032
00033 #ifdef TEST_SUPPLEMENTARY_SERVICES
00034
00036     friend class MobileOriginatedUSSDHandlerTest;
00037 #endif
00038
00039 public:
00043     enum { ID = MoUssdHandlerId };
00044
00046     MobileOriginatedUssdHandler();
00048     virtual ~MobileOriginatedUssdHandler();
00049
00053     virtual HandlerId GetHandlerId() const;
00054
00069     virtual SsBaseHandler::ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument& arg);
00070
00083     SsApiRc SendUssdRequest(const WString& ss_ctrl_sequence, const DataCodingScheme& dcs, BOOLEAN register_only = FALSE);
00084
00094     SsApiRc TerminateUssdTransaction(Tipd tipd);
00095
00100     virtual void RegisterTransaction(Tipd tipd);
00101
00102 private:
00111     SsBaseHandler::ReturnCode CreateUssdAnswerMsg(const SsUnstructIndArg& arg, SsMessage*& msg);
00112
00126     SsBaseHandler::ReturnCode CreateResentMsg(const SsUssdResentIndArg& arg, SsMessage*& msg);
00127
00130     WString m_param_ctrl_sequence;
00131
00134     Tipd m_old_tipd;
00135
00138     BOOLEAN m_resent_pending;
00139 };
00140
00141 #endif // Asc_MobileOriginatedUssdHandler_hpp
00142
00143
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MocVoiceDispatcher.cpp File Reference

Asc/MocVoiceDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "TchInterface.hpp"
#include "MocVoiceDispatcher.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "MocVoiceHandler.hpp"

Include dependency graph for MocVoiceDispatcher.cpp:

Generated on Tue Jan 24 17:25:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MocVoiceDispatcher.hpp File Reference

Asc/MocVoiceDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:25:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MocVoiceDispatcher.hpp Source File

Asc/MocVoiceDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_MocVoiceDispatcher_hpp)
00011 #define Asc_MocVoiceDispatcher_hpp
00014
00015 // #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00016 #include <Asc/TipdBasedActiveWaitDispatcher.hpp>
00017 #include <Apc/StackMsgArgument.hpp>
00018
00027 class MocVoiceDispatcher : public TipdBasedActiveWaitDispatcher {
00028     typedef TipdBasedActiveWaitDispatcher Base;
00029     public:
00034         MocVoiceDispatcher();
00036         virtual ~MocVoiceDispatcher();
00037
00038
00044         CallErrorCause GetRejectCause() const { return m_rej_cause; }
00045
00047         void SetRejectCause(CallErrorCause rej_cause) { m_rej_cause = rej_cause; }
00048
00049
00052         BOOLEAN OnMocSetupRej(const StackMsgArgument &arg);
00053
00059         BOOLEAN OnMocSetupAcc(const StackMsgArgument &arg);
00060
00063         BOOLEAN OnHoldCnf(const StackMsgArgument &arg);
00064
00067         BOOLEAN OnHoldRej(const StackMsgArgument &arg);
00068
00071         BOOLEAN OnMptyCnf(const StackMsgArgument &arg);
00072
00075         BOOLEAN OnSsErrInd(const StackMsgArgument &arg);
00077         BOOLEAN OnSsControlIndMsg(const StackMsgArgument &arg);
00079         BOOLEAN OnUssdControlIndMsg(const StackMsgArgument &arg);
00081         BOOLEAN OnCallControlIndMsg(const StackMsgArgument &arg);
00083         BOOLEAN OnCallSetupBySimtTkReq(const StackMsgArgument &arg);
00084
00085         static void SetIsPhoneRinging(BOOLEAN activate) { m_is_phone_ringing = activate; }
00086         static BOOLEAN IsPhoneRinging() { return m_is_phone_ringing; }
00087
00088     private:
00089         static const StackMsgArgMap<MocVoiceDispatcher> m_arg_map[];
00090         StackMsgArgMapContainer<MocVoiceDispatcher> m_arg_map_container;
00091
00092         CallErrorCause  m_rej_cause;
00093         static BOOLEAN  m_is_phone_ringing;
00094 };
00095
00097 #endif  // Asc_MocVoiceDispatcher_hpp
00098
00099 #endif // DOXYGEN_SHOULD_SKIP_THIS
00100
00101
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MocVoiceHandler.cpp File Reference

Asc/MocVoiceHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "AdcInterface.hpp"
#include "CallHandler.hpp"
#include "MocVoiceHandler.hpp"
#include "RedialDispatcher.hpp"

Include dependency graph for MocVoiceHandler.cpp:

Generated on Tue Jan 24 17:26:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MocVoiceHandler.hpp File Reference

Asc/MocVoiceHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/MocVoiceDispatcher.hpp>
#include <Asc/RedialDispatcher.hpp>
#include <Asc/Types.hpp>
#include <Apc/SimTkTypes.hpp>

Include dependency graph for MocVoiceHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_MocVoiceHandler_hpp

Define Documentation

#define Asc_MocVoiceHandler_hpp

Generated on Tue Jan 24 17:26:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MocVoiceHandler.hpp Source File

Asc/MocVoiceHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_MocVoiceHandler_hpp)
00009 #define Asc_MocVoiceHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/MocVoiceDispatcher.hpp>
00016 #include <Asc/RedialDispatcher.hpp>
00017 #include <Asc/Types.hpp>
00018 #include <Apc/SimTkTypes.hpp>
00019
00020 class CallHandler;
00021
00024 class MocVoiceHandler : public BaseHandler {
00025 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00026     typedef BaseHandler Base;           // typedef if base class's name changes
00027 #ifdef APOXI_COMPAT_1_7_0
00028     friend class SsWaitDispatcher; // SsWaitDispatcher needs method PrepareCallData
00029 #endif
00030     friend class CallControlDispatcher; // CallDispatcher needs method PrepareCallData
00031     public:
00032         enum { ID = MocVoiceHandlerId };
00033
00035         MocVoiceHandler();
00037         virtual ~MocVoiceHandler();
00038
00040         virtual HandlerId GetHandlerId() const;
00041
00070         CallApiRc Setup(const PhoneNumber &phone_no,
00071                         CallIndex & call_index,
00072                         ClirMode clir_mode,
00073                         const CugDescriptor * cug,
00074                         BOOLEAN redial,
00075                         LineSelector call_line = Line1,
00076                         BOOLEAN ctm = FALSE,
00077                         CallEstCause est_cause = HalfTchSpeech,
00078                         const EccCategory * ecc_category = 0);
00079
00080
00085         //CTM - 4th param is added for CTM
00086         CallApiRc SimTkSetup(ProactiveCause cause,
00087                              const PhoneNumber & phone_no,
00088                              UINT8 sim_qualifier,
00089                              BOOLEAN ctm = FALSE);
00090
00091
00093         void CancelRedialling() const;
00094     protected:
00095         BOOLEAN PrepareCallData(PhoneNumber phnr,LineSelector call_line);
00096
00097     private:
00098         CallApiRc MocWaitForResponse(MocVoiceDispatcher &moc_voice_disp,
00099                                      CallHandler * ch,
00100                                      CallIndex &call_index,
00101                                      const PhoneNumber & phone_no);
00102
00103         // BOOLEAN m_tmp_redial_mode;
00104         RedialDispatcher m_redial_disp;
00105         BOOLEAN m_call_disconnected;
00106 };
00107 #endif // DOXYGEN_SHOULD_SKIP_THIS
00108
00110 #endif // Asc_MocVoiceHandler_hpp
00111
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MptyCallHdl.cpp File Reference

Asc/MptyCallHdl.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHdl.hpp"
#include "CrssHandler.hpp"
#include "MptyCallHdl.hpp"
#include "CallHandler.hpp"

Include dependency graph for MptyCallHdl.cpp:

Generated on Tue Jan 24 17:26:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MptyCallHdl.hpp File Reference

Asc/MptyCallHdl.hpp File Reference

#include <Asc/CallHdlBase.hpp>
#include <Asc/CallHandler.hpp>

Include dependency graph for MptyCallHdl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MptyCallHdl

Defines

#define | Asc_MptyCallHdl_hpp

Define Documentation

#define Asc_MptyCallHdl_hpp

Generated on Tue Jan 24 17:26:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MptyCallHdl.hpp Source File

Asc/MptyCallHdl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_MptyCallHdl_hpp)
00009 #define Asc_MptyCallHdl_hpp
00012
00013 #include <Asc/CallHdlBase.hpp>
00014
00015 #include <Asc/CallHandler.hpp>
00016
00017 class CallHdl;
00028 class MptyCallHdl :public CallHdlBase {
00029     typedef CallHdlBase Base;
00030
00031     public:
00032         //---------------------------------------------------------------------
00033         // Construction, destruction initialization
00034         //---------------------------------------------------------------------
00035
00037         explicit MptyCallHdl(ChannelNo channel_no = c_null_channel_no);
00038
00040         virtual ~MptyCallHdl();
00041
00042
00043         // --------------------------------------------------------------------
00044         // providing CallHdls for active, held and setup call
00045         // --------------------------------------------------------------------
00046
00051         static MptyCallHdl GetMptyCallHdl();
00052
00053
00054         // --------------------------------------------------------------------
00055         // call related operations on CallHdl
00056         // --------------------------------------------------------------------
00057
00068 #if defined(APOXI_SYNC_RELEASE)
00069         virtual CallApiRc Release(TimeSpan * calling_time = 0, BOOLEAN wait_condition = TRUE);
00070 #else
00071         virtual CallApiRc Release(TimeSpan * calling_time = 0, BOOLEAN wait_condition = FALSE);
00072 #endif
00073
00074
00081         virtual CallApiRc Hold();
00082
00083
00090         virtual CallApiRc Retrieve();
00091
00092
00101         CallApiRc Split(const CallHdl & active_call) const;
00102
00111         virtual CallApiRc StartDtmfToneGeneration(KeyCode key);
00112
00113
00116         virtual CallApiRc StopDtmfToneGeneration();
00117
00118         // --------------------------------------------------------------------
00119         // access to multi-party call data
00120         // --------------------------------------------------------------------
00121
00129         CallHdl GetMember(INT pos = 0) const;
00130
00131
00133         INT GetMemberCount() const;
00134
00135
00138         virtual DateTime GetStartTime() const ;
00139
00140
00141         // --------------------------------------------------------------------
00142         // general information of call referred by a CallHdl
00143         // --------------------------------------------------------------------
00144
00146         virtual BOOLEAN IsActive() const;
00147
00149         virtual BOOLEAN IsHeld() const;
00150
00152         virtual BOOLEAN IsSame(const MptyCallHdl & mpty_call) const;
00153
00155         virtual BOOLEAN IsValid() const { return m_mpty_channel_no != c_null_channel_no; }
00156
00157
00158         // --------------------------------------------------------------------
00159         // misc
00160         // --------------------------------------------------------------------
00161
00163         virtual BOOLEAN IsHoldPermitted() const;
00164
00166         virtual BOOLEAN IsRetrievePermitted() const;
00167
00169         BOOLEAN IsSplitPermitted(const CallHdl & call) const;
00170
00172         virtual void Invalidate() { m_mpty_channel_no = c_null_channel_no; }
00173
00175         ChannelNo GetMptyChannelNo() const { return m_mpty_channel_no; }
00176
00180         virtual CallIndex GetCallIndex() const { return c_mpty_indication; }
00181
00189         virtual TimeSpan GetCallDuration() const;
00190
00191     private:
00192         ChannelNo m_mpty_channel_no;
00193 };
00194
00196 #endif // Asc_MptyCallHdl_hpp
00197
00198
00199
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MsgArgs.cpp File Reference

Asc/MsgArgs.cpp File Reference

#include "Asc/PreComp.hpp"

Include dependency graph for MsgArgs.cpp:

Generated on Tue Jan 24 17:26:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MsgArgs.hpp File Reference

Asc/MsgArgs.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Asc/CallHdl.hpp>
#include <Apc/DataCodingScheme.hpp>

Include dependency graph for MsgArgs.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | BarringInfoReceivedArg
Contains data of the indication of received CallBarringInfo. More...
struct | CallDisconnectingArg
struct | CallInfoArg
Structure which will never be sent in this environment!!! More...
struct | CallSetupProgressArg
Structure indicating the progress during setup phase of a call. More...
struct | DtmfRejectArg
Structure keeping DTMF rejection cause and respective call index of the call. More...
struct | DtmfStartCnfArg
Structure keeping information for DTMF tone generation. More...
struct | ForwardingInfoReceivedArg
Contains the data related ForwardingInfoReceivedMsg. More...
struct | InterrogationResultArg
Contains the interrogation result, containing supplementary service status. More...
struct | PasswordReceivedArg
Indication of received password, echoed by the network. More...
struct | SsDataReceivedArg
Indication of received supplementary service data. More...
struct | SsNotificationArg
Indication of an executed supplementary service (also remote). More...
struct | UssDataArg
Indication of received unstrucured supplementary service data. More...

Defines

#define | Asc_MsgArgs_hpp

Enumerations

enum | RemotePartyActionArg { RemoteHold, RemoteRetrieve, RemoteMbuild, VoidAction }
Describes the action of the reomote party. More...

Define Documentation

#define Asc_MsgArgs_hpp

Generated on Tue Jan 24 17:26:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MsgArgs.hpp Source File

Asc/MsgArgs.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_MsgArgs_hpp)
00009 #define Asc_MsgArgs_hpp
00012
00013 #include <Kernel/Os/Os.hpp>
00014
00015 #include <Asc/CallHdl.hpp>
00016 #include <Apc/DataCodingScheme.hpp>
00017
00018
00021 struct CallDisconnectingArg {
00022     // A <em>CallHdl</em> object holding the <em>call_index</em> of the disconnected call.
00023     CallHdl         call;
00024     // The phone number of the call, since the <em>CallInstance</em> has already been deleted.
00025     PhoneNumber     phone_no;
00026     // The cause for the disconnect. Supplied by MN.
00027     CallErrorCause  cause;
00028     // The time span, since the call has been established.
00029     TimeSpan        call_duration;
00030 };
00031
00033 struct CallInfoArg {
00035     CallHdl     call;
00037     CallState   state;
00039     CallType    type;
00040 };
00041
00043 struct DtmfStartCnfArg {
00045     CallHdl call;
00047     KeyCode     key;
00048 };
00049
00050
00052 struct DtmfRejectArg {
00054     CallHdl call;
00056     CallErrorCause  cause;
00057 };
00058
00059
00061 struct CallSetupProgressArg {
00063     CallHdl call;
00065     CallProgressInd progress_ind;
00066 };
00067
00068
00070 enum RemotePartyActionArg {
00072     RemoteHold,
00074     RemoteRetrieve,
00076     RemoteMbuild,
00078     VoidAction
00079 };
00080
00081
00083 struct ForwardingInfoReceivedArg {
00085     SsOperationCode operation_code;
00087     ForwardingInfo  forwarding_info;
00088 };
00089
00090
00092 struct BarringInfoReceivedArg {
00094     SsOperationCode operation_code;
00096     CallBarringInfo barring_info;
00097 };
00098
00099
00101 struct SsDataReceivedArg {
00103     SsOperationCode operation_code;
00105     SsData          data;
00106 };
00107
00108
00110 struct SsNotificationArg {
00112     SsOperationCode operation_code;
00114     NotifySsArg notify_arg;
00115 };
00116
00117
00119 struct InterrogationResultArg {
00121     SsOperationCode operation_code;
00123     InterrogateSsResult result;
00124 };
00125
00126
00128 struct PasswordReceivedArg {
00130     SsOperationCode operation_code;
00132     WString password;
00133 };
00134
00135
00137 struct UssDataArg {
00139     SsOperationCode operation_code;
00141     WString uss_data;
00143     DataCodingScheme dcs;
00144 };
00145
00146
00147
00149 #endif  // Asc_MsgArgs_hpp
00150
00151
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceAcceptDispatcher.cpp File Reference

Asc/MtcVoiceAcceptDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "MtcVoiceAcceptDispatcher.hpp"
#include "TchInterface.hpp"
#include <Devices/AudioPathManager.hpp>

Include dependency graph for MtcVoiceAcceptDispatcher.cpp:

Generated on Tue Jan 24 17:26:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceAcceptDispatcher.hpp File Reference

Asc/MtcVoiceAcceptDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:26:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceAcceptDispatcher.hpp Source File

Asc/MtcVoiceAcceptDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_MtcVoiceAcceptDispatcher_hpp)
00011 #define Asc_MtcVoiceAcceptDispatcher_hpp
00014
00015 #include <Asc/TipdBasedActiveWaitDispatcher.hpp>
00016
00018 //lint -esym(1712,MtcVoiceAcceptDispatcher)
00019 class MtcVoiceAcceptDispatcher : public TipdBasedActiveWaitDispatcher {
00020     public:
00021         typedef TipdBasedActiveWaitDispatcher Base;
00022
00024         explicit MtcVoiceAcceptDispatcher(Tipd tipd);
00026         virtual ~MtcVoiceAcceptDispatcher();
00027
00034         BOOLEAN OnMtcSetupCompl(const StackMsgArgument &arg);
00035
00039         BOOLEAN OnMtcAcceptRej(const StackMsgArgument &arg) ;
00040
00043         BOOLEAN IsRejected(){return m_rejected;}
00044
00045     private:
00046         static const StackMsgArgMap<MtcVoiceAcceptDispatcher> m_arg_map[];
00047         StackMsgArgMapContainer<MtcVoiceAcceptDispatcher> m_arg_map_container;
00048
00049 //      Tipd                m_tipd;
00050         BOOLEAN             m_disconnected;
00051         BOOLEAN             m_rejected;
00052 };
00053
00055 #endif  // Asc_MtcVoiceAcceptDispatcher_hpp
00056
00057 #endif // DOXYGEN_SHOULD_SKIP_THIS
00058
00059
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceDispatcher.cpp File Reference

Asc/MtcVoiceDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandler.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "MtcVoiceDispatcher.hpp"
#include "MtcVoiceHandler.hpp"

Include dependency graph for MtcVoiceDispatcher.cpp:

Generated on Tue Jan 24 17:27:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceDispatcher.hpp File Reference

Asc/MtcVoiceDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:27:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceDispatcher.hpp Source File

Asc/MtcVoiceDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_MtcVoiceDispatcher_hpp)
00011 #define Asc_MtcVoiceDispatcher_hpp
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016
00022 class MtcVoiceDispatcher : public StackMsgDispatcher {
00023     typedef StackMsgDispatcher Base;
00024     public:
00025
00027         MtcVoiceDispatcher();
00029         virtual ~MtcVoiceDispatcher();
00030
00037         BOOLEAN OnMtcConfInd(const StackMsgArgument &arg);
00038
00039
00046         BOOLEAN OnMtcSetupInd(const StackMsgArgument &arg);
00047
00048     private:
00049         static const StackMsgArgMap<MtcVoiceDispatcher> m_arg_map[];
00050         StackMsgArgMapContainer<MtcVoiceDispatcher> m_arg_map_container;
00051 };
00052
00054 #endif // Asc_MtcVoiceDispatcher_hpp
00055
00056 #endif // DOXYGEN_SHOULD_SKIP_THIS
00057
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceHandler.cpp File Reference

Asc/MtcVoiceHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandler.hpp"
#include "MtcVoiceAcceptDispatcher.hpp"
#include "MtcVoiceHandler.hpp"

Include dependency graph for MtcVoiceHandler.cpp:

Generated on Tue Jan 24 17:27:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceHandler.hpp File Reference

Asc/MtcVoiceHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/MtcVoiceDispatcher.hpp>

Include dependency graph for MtcVoiceHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_MtcVoiceHandler_hpp

Define Documentation

#define Asc_MtcVoiceHandler_hpp

Generated on Tue Jan 24 17:27:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MtcVoiceHandler.hpp Source File

Asc/MtcVoiceHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_MtcVoiceHandler_hpp)
00009 #define Asc_MtcVoiceHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014 #include <Asc/MtcVoiceDispatcher.hpp>
00015
00016 class MainHandler;
00017 class CallHandlingData;
00018
00019 enum CallApiRc;
00020
00026 class MtcVoiceHandler : public BaseHandler {
00027 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00028     typedef BaseHandler Base;           // typedef if base class's name changes
00029     public:
00030         enum { ID = MtcVoiceHandlerId };
00031
00033         MtcVoiceHandler();
00035         virtual ~MtcVoiceHandler();
00036
00038         virtual HandlerId GetHandlerId() const;
00039
00048         CallApiRc Accept(CallIndex call_index) const;
00049
00054         CallApiRc SendAlertMessage(CallIndex call_index) const;
00055
00056     private:
00057         MtcVoiceDispatcher  m_mtc_voice_disp;
00058
00059 };
00060 #endif // DOXYGEN_SHOULD_SKIP_THIS
00061
00062 #endif // Asc_MtcVoiceHandler_hpp
00063
00064
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MultiSlotDispatcher.cpp File Reference

Asc/MultiSlotDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "MultiSlotDispatcher.hpp"

Include dependency graph for MultiSlotDispatcher.cpp:

Generated on Tue Jan 24 17:27:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MultiSlotDispatcher.hpp File Reference

Asc/MultiSlotDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>

Include dependency graph for MultiSlotDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MultiSlotDispatcher
Active Wait Dispatcher to catch the OmRatChangeCnf-Message-Arg. More...

Defines

#define | Asc_MultiSlotDispatcher_hpp

Define Documentation

#define Asc_MultiSlotDispatcher_hpp

Generated on Tue Jan 24 17:27:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MultiSlotDispatcher.hpp Source File

Asc/MultiSlotDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_MultiSlotDispatcher_hpp)
00009 #define Asc_MultiSlotDispatcher_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00014
00015 /*  ========================================================================
00016     MultiSlotDispatcher
00017     ======================================================================== */
00019 class MultiSlotDispatcher : public StackMsgActiveWaitDispatcher {
00020     typedef StackMsgActiveWaitDispatcher Base;
00021     public:
00023         MultiSlotDispatcher();
00025         virtual ~MultiSlotDispatcher();
00026
00027         BOOLEAN GetMultiModeSetResult(){ return m_multimode_success; }
00028
00029     protected:
00031         BOOLEAN OnOmMultiSlotInd(const StackMsgArgument &arg);
00032
00033     private:
00034         static const StackMsgArgMap<MultiSlotDispatcher> m_arg_map[];
00035         StackMsgArgMapContainer<MultiSlotDispatcher> m_arg_map_container;
00036         BOOLEAN m_multimode_success;
00037 };
00038
00039 #endif  // Asc_MultiSlotDispatcher_hpp
00040
00041
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MultiSlotHandler.cpp File Reference

Asc/MultiSlotHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "MultiSlotHandler.hpp"

Include dependency graph for MultiSlotHandler.cpp:

Generated on Tue Jan 24 17:28:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MultiSlotHandler.hpp File Reference

Asc/MultiSlotHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/MultiSlotDispatcher.hpp>

Include dependency graph for MultiSlotHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MultiSlotHandler

Defines

#define | Asc_MultiSlotHandler_hpp

Define Documentation

#define Asc_MultiSlotHandler_hpp

Generated on Tue Jan 24 17:28:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/MultiSlotHandler.hpp Source File

Asc/MultiSlotHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_MultiSlotHandler_hpp)
00009 #define Asc_MultiSlotHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/MultiSlotDispatcher.hpp>
00016
00019 class MultiSlotHandler : public BaseHandler {
00020     typedef BaseHandler Base;
00021     public:
00022         enum { ID = MultiSlotHandlerId };
00023
00025         MultiSlotHandler();
00027         virtual ~MultiSlotHandler();
00029         virtual HandlerId GetHandlerId() const;
00030
00032         BOOLEAN SetMultiSlot(MultiSlotMode multi_slot_mode);
00033
00034     private:
00035         MultiSlotDispatcher m_multislot_dispatcher; // main dispatcher for retrieving asynchronous messages
00036 };
00037
00039 #endif // Asc_MultiSlotHandler_hpp
00040
00041
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/NetworkDispatcher.cpp File Reference

Asc/NetworkDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "Apc/NetworkStackMsgArgs.hpp"
#include "NetworkDispatcher.hpp"

Include dependency graph for NetworkDispatcher.cpp:

Generated on Tue Jan 24 17:28:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/NetworkDispatcher.hpp File Reference

Asc/NetworkDispatcher.hpp File Reference

#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for NetworkDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NetworkDispatcher

Defines

#define | Asc_NetworkDispatcher_hpp

Define Documentation

#define Asc_NetworkDispatcher_hpp

Generated on Tue Jan 24 17:28:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/NetworkDispatcher.hpp Source File

Asc/NetworkDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_NetworkDispatcher_hpp)
00009 #define Asc_NetworkDispatcher_hpp
00012
00013 #include <Asc/StackMsgDispatcher.hpp>
00014
00015 /*  ========================================================================
00016     NetworkDispatcher
00017     ======================================================================== */
00019 class NetworkDispatcher : public StackMsgDispatcher {
00020     typedef StackMsgDispatcher Base;
00021     public:
00023         NetworkDispatcher();
00024
00026         virtual ~NetworkDispatcher();
00027
00028     protected:
00034         BOOLEAN OnConnectionInd(const StackMsgArgument &arg);
00035
00037         BOOLEAN OnCellInfoInd(const StackMsgArgument &arg);
00038
00040         BOOLEAN OnMnInformationInd(const StackMsgArgument &arg);
00041
00043         BOOLEAN OnTestparamInd(const StackMsgArgument &arg);
00044
00046         BOOLEAN OnBandSelectionInd(const StackMsgArgument &arg);
00047
00049         BOOLEAN OnHomezoneInd(const StackMsgArgument &arg);
00050
00052         BOOLEAN OnEngineeringModeControlResponse(const StackMsgArgument &arg);
00053
00055         BOOLEAN OnOmBandStatusCnf(const StackMsgArgument &arg);
00056     private:
00058         void ProcessLsaIdentifier(const MnInformationIndArg &arg);
00059         void ProcessNetworkInformation(const MnInformationIndArg &arg);
00060         void ProcessTimeZone(const MnInformationIndArg &arg);
00061
00062         static const StackMsgArgMap<NetworkDispatcher> m_arg_map[];
00063         StackMsgArgMapContainer<NetworkDispatcher> m_arg_map_container;
00064
00065         static TimeZone old_tz;
00066         static WString old_network_name_long;
00067         static WString old_network_name_short;
00068         static BOOLEAN old_network_name_long_add_ci;
00069         static BOOLEAN old_network_name_short_add_ci;
00070         static LsaIdentifier old_lsa_identifier;
00071         static SDL_Boolean old_is_lsa_identifier_present;
00072
00073 };
00074
00076 #endif // Asc_NetworkDispatcher_hpp
00077
00078
Generated on Tue Jan 24 14:46:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/NetworkHandler.cpp File Reference

Asc/NetworkHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "NetworkHandler.hpp"

Include dependency graph for NetworkHandler.cpp:

Generated on Tue Jan 24 17:28:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/NetworkHandler.hpp File Reference

Asc/NetworkHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/NetworkDispatcher.hpp>

Include dependency graph for NetworkHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NetworkHandler

Defines

#define | Asc_NetworkHandler_hpp

Define Documentation

#define Asc_NetworkHandler_hpp

Generated on Tue Jan 24 17:28:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/NetworkHandler.hpp Source File

Asc/NetworkHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_NetworkHandler_hpp)
00009 #define Asc_NetworkHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/NetworkDispatcher.hpp>
00016
00017
00018 /*  ========================================================================
00019     NetworkHandler
00020     ======================================================================== */
00023 class NetworkHandler : public BaseHandler {
00024     typedef BaseHandler Base;
00025     public:
00026         enum { ID = NetworkHandlerId };
00027
00029         NetworkHandler();
00031         virtual ~NetworkHandler();
00032
00034         virtual HandlerId GetHandlerId() const;
00035
00037         static BOOLEAN ReceiveEngineeringModeReport(BOOLEAN enable);
00038
00041         static BOOLEAN SendEngineeringModeControlRequest(EngineeringModeControl function, ULONG param = 0);
00042
00044         static BOOLEAN BandSelection(GsmBand first_band, GsmBand second_band);
00045
00047         static BOOLEAN BandSelection(GsmBandList gsm_band_list);
00048
00050         static BOOLEAN RequestBandConfig();
00051
00053         static BOOLEAN SetNetworkSearchMode(NetworkSearchMode network_search_mode);
00054
00055     private:
00056         NetworkDispatcher m_network_dispatcher; // main dispatcher for retrieving asynchronous messages
00057 };
00058
00060 #endif // Asc_NetworkHandler_hpp
00061
00062
Generated on Tue Jan 24 14:46:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContext.cpp File Reference

Asc/PdpContext.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PdpContext.hpp"
#include "PdpContextControl.hpp"
#include "PdpContextManager.hpp"

Include dependency graph for PdpContext.cpp:

Generated on Tue Jan 24 17:28:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContext.hpp File Reference

Asc/PdpContext.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/BitField.hpp>
#include <Auxiliary/IpPortNo.hpp>
#include <Asc/ValueMap.hpp>
#include <Asc/PppFrame.hpp>

Include dependency graph for PdpContext.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PdpContext
class | PdpContext::ActivationStatus
class | PdpContext::Address
class | PdpContext::Authentication
class | PdpContext::PacketFilter
PacketFilter, (see 3GPP TS 23.060). More...
union | PdpContext::PacketFilter::AddressAndMask
class | PdpContext::QualityOfService

Defines

#define | Asc_PdpContext_hpp

Define Documentation

#define Asc_PdpContext_hpp

Generated on Tue Jan 24 17:29:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContext.hpp Source File

Asc/PdpContext.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_PdpContext_hpp)
00011 #define Asc_PdpContext_hpp
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/IpAddr.hpp>
00017 #include <Auxiliary/String.hpp>
00018 #include <Auxiliary/BitField.hpp>
00019 #include <Auxiliary/IpPortNo.hpp>
00020 #include <Asc/ValueMap.hpp>
00021 #include <Asc/PppFrame.hpp>
00022
00024 class PdpContext : public Linkable<PdpContext>
00025 {
00026     friend class PdpContextSignalProcessor;
00027     friend class PdpContextManager;
00028
00029     public:
00031         typedef INT Id;
00032
00034         typedef UINT8 NsApi;
00035
00037         typedef UINT32 DataUnits;
00038
00040         enum DataCompression {
00041             NoDataCompression = 0,              // default if value is omitted
00042             PreferredDataCompression = 1,       // manufacturer preferred compression
00043             V42bis = 2,
00044             V44 = 3
00045         };
00046
00048         enum HeaderCompression {
00049             NoHeaderCompression = 0,            // default if value is omitted
00050             PreferredHeaderCompression = 1,     // manufacturer preferred compression
00051             Rfc1144 = 2,                        // applicable for SNDCP only
00052             Rfc2507 = 3,
00053             Rfc3095 = 4                     // applicable for PDCP only
00054         };
00055
00056         enum {
00058             ApoxiDefineScopeEntity(c_max_access_point_name_len, PdpContext)
00059         };
00060
00062         enum Type {
00063 //          ApoxiDefineScopeEntity(X25Type, PdpContext),
00064             ApoxiDefineScopeEntity(IpType, PdpContext),
00065             ApoxiDefineScopeEntity(IpStaticType, PdpContext),
00066             ApoxiDefineScopeEntity(IpDynamicType, PdpContext),
00067 //          ApoxiDefineScopeEntity(OspihType, PdpContext),
00068             ApoxiDefineScopeEntity(PppType, PdpContext),
00069             ApoxiDefineScopeEntity(NoType, PdpContext)
00070         };
00071
00073         enum Protocol {
00074             ApoxiDefineScopeEntity(NullProtocol, PdpContext),
00075             ApoxiDefineScopeEntity(PppProtocol, PdpContext),
00076             ApoxiDefineScopeEntity(PadProtocol, PdpContext),
00077             ApoxiDefineScopeEntity(X25Protocol, PdpContext),
00078 //          ApoxiDefineScopeEntity(ManufProtocol, PdpContext),
00079             ApoxiDefineScopeEntity(NoProtocol, PdpContext)
00080         };
00081
00083         enum Origin {
00084             ApoxiDefineScopeEntity(Network, PdpContext),
00085             ApoxiDefineScopeEntity(MobileStation, PdpContext),
00086             ApoxiDefineScopeEntity(UnknownOrigin, PdpContext)
00087         };
00088
00090         enum ErrorCause {       // should be mapped to an enum, for now value 0 indicates no error.
00091             ApoxiDefineScopeEntity(IllegalMs, PdpContext),
00092             ApoxiDefineScopeEntity(IllegalMe, PdpContext),
00093             ApoxiDefineScopeEntity(GprsServiceNotAllowed, PdpContext),
00094             ApoxiDefineScopeEntity(PlmnNotAllowed, PdpContext),
00095             ApoxiDefineScopeEntity(LaNotAllowed, PdpContext),
00096             ApoxiDefineScopeEntity(NationalRoamingNotAllowed, PdpContext),
00097
00098             ApoxiDefineScopeEntity(LlcOrSndcpFailure, PdpContext),
00099             ApoxiDefineScopeEntity(InsufficientRessources, PdpContext),
00100             ApoxiDefineScopeEntity(MissingOrUnknownApn, PdpContext),
00101             ApoxiDefineScopeEntity(UnknownPdpAddress, PdpContext),
00102             ApoxiDefineScopeEntity(AuthenticationFailure, PdpContext),
00103             ApoxiDefineScopeEntity(ActivationRejectedByGgsn, PdpContext),
00104             ApoxiDefineScopeEntity(UnspecifiedActivationRejection, PdpContext),
00105             ApoxiDefineScopeEntity(ServiceOptionNotSupported, PdpContext),
00106             ApoxiDefineScopeEntity(RequestedServiceOptionNotSubscribed, PdpContext),
00107             ApoxiDefineScopeEntity(ServiceOptionTemporaryOutOfOrder, PdpContext),
00108             ApoxiDefineScopeEntity(NsapiAlreadyUsed, PdpContext),
00109             ApoxiDefineScopeEntity(RegularDeactivation, PdpContext),
00110             ApoxiDefineScopeEntity(QosNotAccepted, PdpContext),
00111             ApoxiDefineScopeEntity(NetworkFailure, PdpContext),
00112             ApoxiDefineScopeEntity(ReactivationRequired, PdpContext),
00113             ApoxiDefineScopeEntity(InvalidTi, PdpContext),
00114             ApoxiDefineScopeEntity(SemanticIncorrectMsg, PdpContext),
00115             ApoxiDefineScopeEntity(InvalidMandatoryIe, PdpContext),
00116             ApoxiDefineScopeEntity(MsgTypeNotExistent, PdpContext),
00117             ApoxiDefineScopeEntity(MsgTypeNotCompatible, PdpContext),
00118             ApoxiDefineScopeEntity(IeNonExistent, PdpContext),
00119             ApoxiDefineScopeEntity(ConditionalIeError, PdpContext),
00120             ApoxiDefineScopeEntity(MsgNotCompatible, PdpContext),
00121             ApoxiDefineScopeEntity(UnspecifiedProtocolError, PdpContext),
00122
00123             ApoxiDefineScopeEntity(UndefinedError, PdpContext),
00124             ApoxiDefineScopeEntity(NoError, PdpContext)
00125         };
00126
00128         enum State {
00129             Undefined,
00130             Defined,
00131             Activated,
00132             Connected
00133         };
00134
00136         class Address {
00137             public:
00138                 enum {
00140                     ApoxiDefineScopeEntity(c_max_len, PdpContext_Address)
00141                 };
00142
00144                 Address(UINT8 *data = 0, INT len = c_max_len);
00145
00147                 Address(IpAddr ip_addr);
00148
00150                 IpAddr GetIpAddr() const;
00151
00153                 String GetIPv4String() const;
00154
00156                 const UINT8* GetData() const;
00157
00159                 UINT GetLength() const;
00160
00162                 BOOLEAN IsIPv4() const;
00163
00165                 BOOLEAN IsValid() const;
00166
00168                 void Reset();
00169
00170             private:
00171                 UINT8 m_buffer[c_max_len];
00172         };
00173
00175         class Authentication {
00176             public:
00177                 enum {
00178                     ApoxiDefineScopeEntity(c_max_account_len, PdpContext_Authentication),
00179                     ApoxiDefineScopeEntity(c_max_password_len, PdpContext_Authentication)
00180                 };
00181
00183                 enum Type {
00184                     ApoxiDefineScopeEntity(None, PdpContext_Authentication),
00185                     ApoxiDefineScopeEntity(Pap, PdpContext_Authentication),
00186                     ApoxiDefineScopeEntity(Chap, PdpContext_Authentication)
00187                 };
00188
00190                 Authentication(Type type = None, const String& account = String(), const String& password = String());
00191
00193                 ~Authentication();
00194
00196                 Type GetType() const { return (m_type); }
00198                 void SetType(Type type) { m_type = type; }
00199
00201                 const String& GetAccount() const { return (m_account); }
00203                 void SetAccount(const String& account) { m_account = account; }
00204
00206                 const String& GetPassword() const { return (m_password); }
00208                 void SetPassword(const String& password) { m_password = password; }
00209
00210             private:
00211                 Type m_type;
00212                 String m_account;
00213                 String m_password;
00214         };
00215
00217         class QualityOfService {
00218             public:
00220                 enum Precedence {
00221                     ApoxiDefineScopeEntity(PrecedenceSubscribed, PdpContext_QualityOfService),
00222                     ApoxiDefineScopeEntity(PrecedenceHigh, PdpContext_QualityOfService),
00223                     ApoxiDefineScopeEntity(PrecedenceNormal, PdpContext_QualityOfService),
00224                     ApoxiDefineScopeEntity(PrecedenceLow, PdpContext_QualityOfService),
00225                     ApoxiDefineScopeEntity(PrecedenceReserved, PdpContext_QualityOfService)
00226                 };
00227
00229                 enum Delay {
00230                     ApoxiDefineScopeEntity(DelaySubscribed, PdpContext_QualityOfService),
00231                     ApoxiDefineScopeEntity(DelayClass1, PdpContext_QualityOfService),
00232                     ApoxiDefineScopeEntity(DelayClass2, PdpContext_QualityOfService),
00233                     ApoxiDefineScopeEntity(DelayClass3, PdpContext_QualityOfService),
00234                     ApoxiDefineScopeEntity(DelayBestEffort, PdpContext_QualityOfService),
00235                     ApoxiDefineScopeEntity(DelayReserved, PdpContext_QualityOfService)
00236                 };
00237
00239                 enum Reliability {
00240                     ApoxiDefineScopeEntity(ReliabilitySubscribed, PdpContext_QualityOfService),
00241                     ApoxiDefineScopeEntity(ReliabilityClass1, PdpContext_QualityOfService),
00242                     ApoxiDefineScopeEntity(ReliabilityClass2, PdpContext_QualityOfService),
00243                     ApoxiDefineScopeEntity(ReliabilityClass3, PdpContext_QualityOfService),
00244                     ApoxiDefineScopeEntity(ReliabilityClass4, PdpContext_QualityOfService),
00245                     ApoxiDefineScopeEntity(ReliabilityClass5, PdpContext_QualityOfService),
00246                     ApoxiDefineScopeEntity(ReliabilityClass6, PdpContext_QualityOfService),
00247                     ApoxiDefineScopeEntity(ReliabilityReserved, PdpContext_QualityOfService)
00248                 };
00249
00251                 enum PeakRate {
00252                     ApoxiDefineScopeEntity(PeakRateSubscribed, PdpContext_QualityOfService),
00253                     ApoxiDefineScopeEntity(PeakRate1K, PdpContext_QualityOfService),
00254                     ApoxiDefineScopeEntity(PeakRate2K, PdpContext_QualityOfService),
00255                     ApoxiDefineScopeEntity(PeakRate4K, PdpContext_QualityOfService),
00256                     ApoxiDefineScopeEntity(PeakRate8K, PdpContext_QualityOfService),
00257                     ApoxiDefineScopeEntity(PeakRate16K, PdpContext_QualityOfService),
00258                     ApoxiDefineScopeEntity(PeakRate32K, PdpContext_QualityOfService),
00259                     ApoxiDefineScopeEntity(PeakRate64K, PdpContext_QualityOfService),
00260                     ApoxiDefineScopeEntity(PeakRate128K, PdpContext_QualityOfService),
00261                     ApoxiDefineScopeEntity(PeakRate256K, PdpContext_QualityOfService),
00262                     ApoxiDefineScopeEntity(PeakRateReserved, PdpContext_QualityOfService)
00263                 };
00264
00266                 enum MeanRate {
00267                     ApoxiDefineScopeEntity(MeanRateSubscribed, PdpContext_QualityOfService),
00268                     ApoxiDefineScopeEntity(MeanRate100, PdpContext_QualityOfService),
00269                     ApoxiDefineScopeEntity(MeanRate200, PdpContext_QualityOfService),
00270                     ApoxiDefineScopeEntity(MeanRate500, PdpContext_QualityOfService),
00271                     ApoxiDefineScopeEntity(MeanRate1K, PdpContext_QualityOfService),
00272                     ApoxiDefineScopeEntity(MeanRate2K, PdpContext_QualityOfService),
00273                     ApoxiDefineScopeEntity(MeanRate5K, PdpContext_QualityOfService),
00274                     ApoxiDefineScopeEntity(MeanRate10K, PdpContext_QualityOfService),
00275                     ApoxiDefineScopeEntity(MeanRate20K, PdpContext_QualityOfService),
00276                     ApoxiDefineScopeEntity(MeanRate50K, PdpContext_QualityOfService),
00277                     ApoxiDefineScopeEntity(MeanRate100K, PdpContext_QualityOfService),
00278                     ApoxiDefineScopeEntity(MeanRate200K, PdpContext_QualityOfService),
00279                     ApoxiDefineScopeEntity(MeanRate500K, PdpContext_QualityOfService),
00280                     ApoxiDefineScopeEntity(MeanRate1M, PdpContext_QualityOfService),
00281                     ApoxiDefineScopeEntity(MeanRate2M, PdpContext_QualityOfService),
00282                     ApoxiDefineScopeEntity(MeanRate5M, PdpContext_QualityOfService),
00283                     ApoxiDefineScopeEntity(MeanRate10M, PdpContext_QualityOfService),
00284                     ApoxiDefineScopeEntity(MeanRate20M, PdpContext_QualityOfService),
00285                     ApoxiDefineScopeEntity(MeanRate50M, PdpContext_QualityOfService),
00286                     ApoxiDefineScopeEntity(MeanRateReserved, PdpContext_QualityOfService),
00287                     ApoxiDefineScopeEntity(MeanRateBestEffort, PdpContext_QualityOfService)
00288                 };
00289
00291                 QualityOfService(Precedence precedence = PrecedenceSubscribed,
00292                                  Delay delay = DelaySubscribed,
00293                                  Reliability reliability = ReliabilitySubscribed,
00294                                  PeakRate peak_rate = PeakRateSubscribed,
00295                                  MeanRate mean_rate = MeanRateSubscribed
00296 #if defined(APOXI_RAT_UMTS) || defined(APOXI_RAT_DUAL)
00297                                  ,
00298                                  int present_3g = 0,
00299                                  int traffic_class = 0,
00300                                  int delivery_order = 0,
00301                                  int error_sdu_delivery = 0,
00302                                  int max_sdu_size = 0,
00303                                  int max_bit_rate_up = 0,
00304                                  int max_bit_rate_down = 0,
00305                                  int residual_ber = 0,
00306                                  int sdu_error_ratio = 0,
00307                                  int transfer_delay = 0,
00308                                  int traffic_priority = 0,
00309                                  int guaranteed_bit_rate_up = 0,
00310                                  int guaranteed_bit_rate_down = 0
00311 #endif  // APOXI_RAT_UMTS || APOXI_RAT_DUAL
00312                                  );
00313
00315                 ~QualityOfService();
00316
00318                 void Reset();
00319
00321                 Precedence GetPrecedence() const { return (m_precedence); }
00323                 void SetPrecedence(Precedence precedence) { m_precedence = precedence; }
00324
00326                 Delay GetDelay() const { return (m_delay); }
00328                 void SetDelay(Delay delay) { m_delay = delay; }
00329
00331                 Reliability GetReliability() const { return (m_reliability); }
00333                 void SetReliability(Reliability reliability) { m_reliability = reliability; }
00334
00336                 PeakRate GetPeakRate() const { return (m_peak_rate); }
00338                 void SetPeakRate(PeakRate peak_rate) { m_peak_rate = peak_rate; }
00339
00341                 MeanRate GetMeanRate() const { return (m_mean_rate); }
00343                 void SetMeanRate(MeanRate mean_rate) { m_mean_rate = mean_rate; }
00344
00345 #if defined(APOXI_RAT_UMTS) || defined(APOXI_RAT_DUAL)
00346                 int Get3GPresent() const { return (m_present_3g); }
00347                 void Set3GPresent(int present_3g) { m_present_3g = present_3g; }
00348
00349                 int GetTrafficClass() const { return (m_traffic_class); }
00350                 void SetTrafficClass(int traffic_class) { m_traffic_class = traffic_class; }
00351
00352                 int GetDeliveryOrder() const { return (m_delivery_order); }
00353                 void SetDeliveryOrder(int delivery_order) { m_delivery_order = delivery_order; }
00354
00355                 int GetErrorSduDelivery() const { return (m_error_sdu_delivery); }
00356                 void SetErrorSduDelivery(int error_sdu_delivery) { m_error_sdu_delivery = error_sdu_delivery; }
00357
00358                 int GetMaxSduSize() const { return (m_max_sdu_size); }
00359                 void SetMaxSduSize(int max_sdu_size) { m_max_sdu_size = max_sdu_size; }
00360
00361                 int GetBitRateUp() const { return (m_max_bit_rate_up); }
00362                 void SetBitRateUp(int max_bit_rate_up) { m_max_bit_rate_up = max_bit_rate_up; }
00363
00364                 int GetBitRateDown() const { return (m_max_bit_rate_down); }
00365                 void SetBitRateDown(int max_bit_rate_down) { m_max_bit_rate_down = max_bit_rate_down; }
00366
00367                 int GetResidualBer() const { return (m_residual_ber); }
00368                 void SetResidualBer(int residual_ber) { m_residual_ber = residual_ber; }
00369
00370                 int GetSduErrorRatio() const { return (m_sdu_error_ratio); }
00371                 void SetSduErrorRatio(int sdu_error_ratio) { m_sdu_error_ratio = sdu_error_ratio; }
00372
00373                 int GetTransferDelay() const { return (m_transfer_delay); }
00374                 void SetTransferDelay(int transfer_delay) { m_transfer_delay = transfer_delay; }
00375
00376                 int GetTrafficPriority() const { return (m_traffic_priority); }
00377                 void SetTrafficPriority(int traffic_priority) { m_traffic_priority = traffic_priority; }
00378
00379                 int GetGuaranteedBitRateUp() const { return (m_guaranteed_bit_rate_up); }
00380                 void SetGuaranteedBitRateUp(int guaranteed_bit_rate_up) { m_guaranteed_bit_rate_up = guaranteed_bit_rate_up; }
00381
00382                 int GetGuaranteedBitRateDown() const { return (m_guaranteed_bit_rate_down); }
00383                 void SetGuaranteedBitRateDown(int guaranteed_bit_rate_down) { m_guaranteed_bit_rate_down = guaranteed_bit_rate_down; }
00384 #endif  // APOXI_RAT_UMTS || APOXI_RAT_DUAL
00385
00386             private:
00387                 Precedence m_precedence;
00388                 Delay m_delay;
00389                 Reliability m_reliability;
00390                 PeakRate m_peak_rate;
00391                 MeanRate m_mean_rate;
00392 #if defined(APOXI_RAT_UMTS) || defined(APOXI_RAT_DUAL)
00393                 int m_present_3g;
00394                 int m_traffic_class;
00395                 int m_delivery_order;
00396                 int m_error_sdu_delivery;
00397                 int m_max_sdu_size;
00398                 int m_max_bit_rate_up;
00399                 int m_max_bit_rate_down;
00400                 int m_residual_ber;
00401                 int m_sdu_error_ratio;
00402                 int m_transfer_delay;
00403                 int m_traffic_priority;
00404                 int m_guaranteed_bit_rate_up;
00405                 int m_guaranteed_bit_rate_down;
00406 #endif  // APOXI_RAT_UMTS || APOXI_RAT_DUAL
00407         };
00408
00410         class ActivationStatus {
00411
00412             public:
00413
00415                 enum State {
00416                     ApoxiDefineScopeEntity(StateAccepted, PdpContext_ActivationStatus),
00417                     ApoxiDefineScopeEntity(StateRejected, PdpContext_ActivationStatus),
00418                     ApoxiDefineScopeEntity(StateFiveTimeT3380Expiry, PdpContext_ActivationStatus),
00419                     ApoxiDefineScopeEntity(StateUserInteruption, PdpContext_ActivationStatus),
00420                     ApoxiDefineScopeEntity(StateUnknownCause, PdpContext_ActivationStatus),
00421                 };
00422
00424                 enum RadioPriority {
00425                     ApoxiDefineScopeEntity(RadioPriorityLevel_1, PdpContext_ActivationStatus),
00426                     ApoxiDefineScopeEntity(RadioPriorityLevel_2, PdpContext_ActivationStatus),
00427                     ApoxiDefineScopeEntity(RadioPriorityLevel_3, PdpContext_ActivationStatus),
00428                     ApoxiDefineScopeEntity(RadioPriorityLevel_4, PdpContext_ActivationStatus),
00429                     ApoxiDefineScopeEntity(RadioPriorityLevel_Undefined, PdpContext_ActivationStatus),
00430                 };
00431
00433                 enum LlcSapi {
00434                     ApoxiDefineScopeEntity(LlcSapi_NotAssigned, PdpContext_ActivationStatus),
00435                     ApoxiDefineScopeEntity(LlcSapi_1, PdpContext_ActivationStatus),
00436                     ApoxiDefineScopeEntity(LlcSapi_3, PdpContext_ActivationStatus),
00437                     ApoxiDefineScopeEntity(LlcSapi_5, PdpContext_ActivationStatus),
00438                     ApoxiDefineScopeEntity(LlcSapi_7, PdpContext_ActivationStatus),
00439                     ApoxiDefineScopeEntity(LlcSapi_9, PdpContext_ActivationStatus),
00440                     ApoxiDefineScopeEntity(LlcSapi_11, PdpContext_ActivationStatus),
00441                     ApoxiDefineScopeEntity(LlcSapi_Invalid, PdpContext_ActivationStatus),
00442                 };
00443
00445                 ActivationStatus(State state = StateUnknownCause,
00446                                  INT reject_cause = 0,
00447                                  const QualityOfService& quality_of_service = QualityOfService(),
00448                                  LlcSapi llc_sapi = LlcSapi_NotAssigned,
00449                                  RadioPriority radio_priority = RadioPriorityLevel_Undefined,
00450                                  const Address& address = Address(),
00451                                  const String& apn = String(),
00452                                  INT t3380_expiries = 0);
00453
00455                 ~ActivationStatus();
00456
00458                 void Reset();
00459
00461                 State GetState() const { return (m_state); }
00462                 void SetState(State state) { m_state = state; }
00463
00465                 INT GetRejectCause() const { return (m_reject_cause); }
00466                 void SetRejectCause(INT reject_cause) { m_reject_cause = reject_cause; }
00467
00469                 const QualityOfService& GetQualityOfService() const { return m_quality_of_service; }
00470                 void SetQualityOfService(const QualityOfService& quality_of_service) { m_quality_of_service = quality_of_service; }
00471
00473                 LlcSapi GetLlcSapi() const { return (m_llc_sapi); }
00474                 void SetLlcSapi(LlcSapi llc_sapi) { m_llc_sapi = llc_sapi; }
00475
00477                 RadioPriority GetRadioPriority() const { return m_radio_priority; }
00478                 void SetRadioPriority(RadioPriority radio_priority) { m_radio_priority = radio_priority; }
00479
00481                 const Address& GetAddress() const { return m_address; }
00482                 void SetAddress(const Address& address) { m_address = address; }
00483
00485                 const String& GetAccessPointName() const { return m_apn; }
00486                 void SetAccessPointName(const String& apn) { m_apn = apn; }
00487
00489                 INT GetT3380Expiries() const { return m_t3380_expiries; }
00490                 void SetT3380Expiries(INT t3380_expiries) { m_t3380_expiries = t3380_expiries; }
00491
00492             private:
00493
00494                 State            m_state;
00495                 INT              m_reject_cause;
00496                 QualityOfService m_quality_of_service;
00497                 LlcSapi          m_llc_sapi;
00498                 RadioPriority    m_radio_priority;
00499                 Address          m_address;
00500                 String           m_apn;
00501                 INT              m_t3380_expiries;
00502         };
00503
00504
00506         class PacketFilter {
00507
00508             friend class PdpContext;
00509
00510             public:
00511
00512                 // Address and Mask (IPv4 or IPv6)
00513                 union AddressAndMask {
00514
00515                     AddressAndMask() {
00516                         memset(this, 0, sizeof(AddressAndMask));
00517                     }
00518
00520                     struct {
00521                         UINT8 m_address[4];
00522                         UINT8 m_subnet[4];
00523                     } m_ipv4_address_and_mask;
00524
00526                     struct {
00527                         UINT8 m_address[16];
00528                         UINT8 m_subnet[16];
00529                     } m_ipv6_address_and_mask;
00530                 };
00531
00533                 enum Type {
00534                     ApoxiDefineScopeEntity(Type_1, PdpContext_PacketFilter),
00535                     ApoxiDefineScopeEntity(Type_2, PdpContext_PacketFilter),
00536                     ApoxiDefineScopeEntity(Type_3, PdpContext_PacketFilter),
00537                     ApoxiDefineScopeEntity(Type_Unknown, PdpContext_PacketFilter),
00538                 };
00539
00541                 PacketFilter(UINT8 id,
00542                              UINT8 evaluation_precedence_index,
00543                              const AddressAndMask& src_addr_and_mask,
00544                              UINT8 prot_nbr_or_nxt_hdr,
00545                              const IpPortNo& lower_dst_port,
00546                              const IpPortNo& upper_dst_port,
00547                              const IpPortNo& lower_src_port,
00548                              const IpPortNo& upper_src_port,
00549                              UINT8 tos_or_traffic_class,
00550                              UINT8 tos_mask_or_traffic_class_mask);
00551
00553                 PacketFilter(UINT8 id,
00554                              UINT8 evaluation_precedence_index,
00555                              const AddressAndMask& src_addr_and_mask,
00556                              UINT8 prot_nbr_or_nxt_hdr,
00557                              UINT32 ipsec_security_param_idx,
00558                              UINT8 tos_or_traffic_class,
00559                              UINT8 tos_mask_or_traffic_class_mask);
00560
00562                 PacketFilter(UINT8 id,
00563                              UINT8 evaluation_precedence_index,
00564                              const AddressAndMask& src_addr_and_mask,
00565                              UINT8 tos_or_traffic_class,
00566                              UINT8 tos_mask_or_traffic_class_mask,
00567                              UINT32 flow_label);
00568
00569                 ~PacketFilter();
00570
00572                 Type GetType() const;
00573
00575                 UINT8 GetId() const { return m_id; }
00576
00578                 UINT8 GetEvaluationPrecedenceIndex() const { return m_evaluation_precedence_index; }
00579
00581                 BOOLEAN IsSourceAddressAndSubnetMaskPresent() const { return m_precedence.GetBit(0); }
00582
00584                 const AddressAndMask& GetSourceAddressAndSubnetMask() const { return m_source_address_and_subnet_mask; }
00585
00587                 BOOLEAN IsProtocolNumberOrNextHeaderPresent() const { return m_precedence.GetBit(1); }
00588
00590                 UINT8 GetProtocolNumberOrNextHeader() const { return m_protocol_number_or_next_header; }
00591
00593                 BOOLEAN IsDestinationPortRangePresent() const { return m_precedence.GetBit(2); }
00594
00596                 const IpPortNo& GetLowerDestinationPort() const { return m_lower_destination_port; }
00597
00599                 const IpPortNo& GetUpperDestinationPort() const { return m_upper_destination_port; }
00600
00602                 BOOLEAN IsSourcePortRangePresent() const { return m_precedence.GetBit(3); }
00603
00605                 const IpPortNo& GetLowerSourcePort() const { return m_lower_source_port; }
00606
00608                 const IpPortNo& GetUpperSourcePort() const { return m_upper_source_port; }
00609
00611                 BOOLEAN IsIpSecSecurityParameterIndexPresent() const { return m_precedence.GetBit(4); }
00612
00614                 UINT32 GetIpSecSecurityParameterIndex() const { return m_ipsec_security_parameter_index; }
00615
00617                 BOOLEAN IsTypeOfServiceAndMaskOrTrafficClassAndMaskPresent() const { return m_precedence.GetBit(5); }
00618
00620                 UINT8 GetTypeOfServiceOrTrafficClass() const { return m_tos_or_traffic_class; }
00621
00623                 UINT8 GetTypeOfServiceMaskOrTrafficClassMask() const { return m_tos_mask_or_traffic_class_mask; }
00624
00626                 BOOLEAN IsFlowLabelPresent() const { return m_precedence.GetBit(6); }
00627
00629                 UINT32 GetFlowLabel() const { return m_flow_label; }
00630
00631             private:
00632 #if !defined(APOXI_3GPP_REL_97_DOWNGRADE)
00633
00634                 PacketFilter(const T_PACKET_FILTER & packet_filter);
00635
00637                 operator T_PACKET_FILTER () const;
00638 #endif
00639
00641                 /*  Bit #0: Source Address and Subnet Mask
00642                     Bit #1: Protocol Number (IPv4) / Next Header (IPv6)
00643                     Bit #2: Destination Port Range
00644                     Bit #3: Source Port Range
00645                     Bit #4: IPSec Security Parameter Index (IPSec SPI)
00646                     Bit #5: Type of Service (TOS) (IPv4) / Traffic Class (IPv6) and Mask
00647                     Bit #6: Flow Label (IPv6)
00648                     Bit #7: <Not used yet> */
00649                 BitField8 m_precedence;
00650
00652                 UINT8 m_id;
00653
00655                 UINT8 m_evaluation_precedence_index;
00656
00658                 AddressAndMask m_source_address_and_subnet_mask;
00659
00661                 UINT8 m_protocol_number_or_next_header;
00662
00664                 IpPortNo m_lower_destination_port, m_upper_destination_port;
00665
00667                 IpPortNo m_lower_source_port, m_upper_source_port;
00668
00670                 UINT32 m_ipsec_security_parameter_index;
00671
00673                 UINT8 m_tos_or_traffic_class;
00674
00676                 UINT8 m_tos_mask_or_traffic_class_mask;
00677
00679                 UINT32 m_flow_label;
00680         };
00681
00682
00683     private:
00685         PdpContext(Id id, Id primary_id);
00687         PdpContext(Id id);
00689
00690         virtual ~PdpContext();
00691
00692     public:
00694         Id GetId() const { return (m_id); }
00695
00697         Id GetPrimaryId() const { return (m_primary_id); }
00698
00700         State GetState() const { return (m_state); }
00701
00703         BOOLEAN IsActive() const;
00704
00706         BOOLEAN IsAddressAllocatedDynamically() const { return (m_address_is_dynamically_allocated); }
00707
00709         Type GetType() const { return (m_type); }
00710
00712         const Address& GetAddress() const { return m_address; }
00713
00715         const String& GetAccessPointName() const { return m_access_point_name; }
00716
00718         DataCompression GetDataCompression() const { return m_data_compression; }
00719
00721         HeaderCompression GetHeaderCompression() const { return m_header_compression; }
00722
00724         BOOLEAN IsAuthenticated() const { return (m_authenticated); }
00725
00727         BOOLEAN IsSecondary() const { return (m_primary_id != 0); };
00728
00730         const PppFrame& GetPppFrame() const { return m_ppp_frame; }
00731
00733         const QualityOfService& GetQualityOfService() const { return m_quality_of_service; }
00734
00736         Protocol GetProtocol() const { return m_protocol; }
00737
00739         NsApi GetAccessPointId() const { return (m_access_point_id); }
00740
00742         const QualityOfService& GetMinimumQualityOfService() const { return m_minimum_quality_of_service; }
00743
00745         const ActivationStatus& GetActivationStatus() const { return m_activation_status; }
00746
00748         BOOLEAN Define(Type type, const Address &address = Address(), const String &access_point_name = String(),
00749             DataCompression data_compression = NoDataCompression, HeaderCompression header_compression = NoHeaderCompression);
00750
00752         BOOLEAN Define(DataCompression data_compression = NoDataCompression, HeaderCompression header_compression = NoHeaderCompression);
00753
00755         BOOLEAN Undefine();
00756
00758         BOOLEAN Authenticate(const Authentication &authentication);
00759
00762         BOOLEAN SetQualityOfService(const QualityOfService &quality_of_service);
00763
00766         BOOLEAN SetMinimumQualityOfService(const QualityOfService &quality_of_service);
00767
00769         BOOLEAN Activate();
00770
00775         BOOLEAN Activate(const PppFrame &ppp_frame);
00776
00779         BOOLEAN Accept(Type type = NoType, const Address &address = Address());
00780
00783         static void Reject();
00784
00786         BOOLEAN Deactivate();
00787
00790         BOOLEAN Connect(Protocol protocol);
00791
00793         BOOLEAN SetCounter(DataUnits bytes_sent = 0, DataUnits bytes_received = 0);
00794
00796         BOOLEAN ReadCounter();
00797
00799         BOOLEAN SetPacketFilter(const PacketFilter &packet_filter);
00800
00803         BOOLEAN UnsetPacketFilter(UINT8 packet_filter_id = 0);
00804
00811         BOOLEAN SetAutomaticDnsServerNegotiation(BOOLEAN enable);
00812
00817         BOOLEAN ReadNegotiatedDnsServerAddress();
00818
00819     private:
00820         State m_state;
00821
00822         Id m_id;
00823         Id m_primary_id;
00824         Type m_type;
00825         Address m_address;
00826         BOOLEAN m_address_is_dynamically_allocated;
00827         String m_access_point_name;
00828         DataCompression m_data_compression;
00829         HeaderCompression m_header_compression;
00830
00831         BOOLEAN m_authenticated;
00832         PppFrame m_ppp_frame;
00833
00834         QualityOfService m_quality_of_service;
00835         QualityOfService m_minimum_quality_of_service;
00836         QualityOfService m_temporary_quality_of_service;
00837
00838         ActivationStatus m_activation_status;
00839
00840         Protocol m_protocol;
00841         NsApi m_access_point_id;
00842
00843         void Reset();
00844         void ResetOnDeactivation();
00845
00846         // Sets the ActivationStatus and then posts a PdpContextActivationStatusMessage to inform applications about a context activation status update
00847         void SetActivationStatus(const ActivationStatus& activation_status);
00848
00849         // Callback needed for reading the data counters of a pdp context before undefining it
00850         void OnSilentReadCounterCompleted(PdpContext::ErrorCause cause);
00851 };
00852
00854 #endif  // Asc_PdpContext_hpp
00855
00856
Generated on Tue Jan 24 14:46:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContextControl.hpp File Reference

Asc/PdpContextControl.hpp File Reference

#include <Asc/PdpContext.hpp>

Include dependency graph for PdpContextControl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PdpContextControl

Defines

#define | Asc_PdpContextControl_hpp

Define Documentation

#define Asc_PdpContextControl_hpp

Generated on Tue Jan 24 17:29:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContextControl.hpp Source File

Asc/PdpContextControl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2002 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Asc_PdpContextControl_hpp)
00010 #define Asc_PdpContextControl_hpp
00013
00014 #include <Asc/PdpContext.hpp>
00015
00018 class PdpContextControl
00019 {
00020     friend class PdpContextManager;
00021
00022     private:
00023         PdpContext* m_pdp_context;
00024
00027         void AttachContext(PdpContext *pdp_context) {
00028             m_pdp_context = pdp_context;
00029         }
00030
00031     public:
00033         PdpContextControl() : m_pdp_context(0) { }
00035         virtual ~PdpContextControl() { }
00036
00039         PdpContext* GetContext() const {
00040             return m_pdp_context;
00041         }
00042
00048
00051         virtual void OnDefineCompleted(PdpContext::ErrorCause cause) { }
00052
00055         virtual void OnUndefineCompleted(PdpContext::ErrorCause cause) { }
00056
00059         virtual void OnAuthenticateCompleted(PdpContext::ErrorCause cause) { }
00060
00063         virtual void OnSetQualityOfServiceCompleted(
00064             PdpContext::ErrorCause cause) { }
00065
00068         virtual void OnSetMinimumQualityOfServiceCompleted(
00069             PdpContext::ErrorCause cause) { }
00070
00076         virtual void OnActivateCompleted(PdpContext::ErrorCause cause) { }
00077
00080         virtual void OnDeactivateCompleted(PdpContext::ErrorCause cause) { }
00081
00084         virtual void OnConnectCompleted(PdpContext::ErrorCause cause) { }
00085
00088         virtual void OnSetCounterCompleted(PdpContext::ErrorCause cause) { }
00089
00092         virtual void OnReadCounterCompleted(PdpContext::ErrorCause cause) { }
00093
00096         virtual void OnSetPacketFilterCompleted(PdpContext::ErrorCause cause)
00097             { }
00098
00101         virtual void OnUnsetPacketFilterCompleted(PdpContext::ErrorCause cause)
00102             { }
00103
00106         virtual void OnSetAutomaticDnsServerNegotiationCompleted(
00107             PdpContext::ErrorCause cause) { }
00108
00111         virtual void OnReadNegotiatedDnsServerAddressCompleted(
00112             PdpContext::ErrorCause cause) { }
00113
00115
00121
00124         virtual void OnReactivateIndication() { }
00125
00128         virtual void OnDeactivateIndication(PdpContext::ErrorCause cause,
00129             PdpContext::Origin origin = PdpContext::UnknownOrigin) { }
00130
00133         virtual void OnActivationStatusContextIndication() { }
00134
00136 };
00137
00139 #endif // Asc_PdpContextControl_hpp
00140
00141
Generated on Tue Jan 24 14:46:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContextManager.cpp File Reference

Asc/PdpContextManager.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PdpContextManager.hpp"
#include "PdpContextManagerControl.hpp"
#include "PdpContextControl.hpp"
#include "Target/PdpContextSignalMapTableNode.hpp"

Include dependency graph for PdpContextManager.cpp:

Generated on Tue Jan 24 17:29:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContextManager.hpp File Reference

Asc/PdpContextManager.hpp File Reference

#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Os/Semaphore.hpp>
#include <Kernel/Condition.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <Asc/PdpContext.hpp>

Include dependency graph for PdpContextManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PdpContextManager
class | PdpContextManager::AttachStatus
struct | PdpContextManager::DataCounters
struct | PdpContextManager::PdpContextInfo
Structure for storing a PDP context ID and its current usage state.

Defines

#define | Asc_PdpContextManager_hpp
#define | LOCK_PDP_CONTEXT_HANDLER PdpContextManager::GetSemaphore().Obtain();
#define | UNLOCK_PDP_CONTEXT_HANDLER PdpContextManager::GetSemaphore().Release();

Define Documentation

#define Asc_PdpContextManager_hpp

#define LOCK_PDP_CONTEXT_HANDLER PdpContextManager::GetSemaphore().Obtain();

Macros used to lock/unlock PDP context handler operations and data accesses.

#define UNLOCK_PDP_CONTEXT_HANDLER PdpContextManager::GetSemaphore().Release();

Generated on Tue Jan 24 17:29:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContextManager.hpp Source File

Asc/PdpContextManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_PdpContextManager_hpp)
00011 #define Asc_PdpContextManager_hpp
00012
00013 #include <Kernel/Os/Mutex.hpp>
00014 #include <Kernel/Os/Semaphore.hpp>
00015 #include <Kernel/Condition.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017 #include <Auxiliary/SimpleMap.hpp>
00018 #include <Asc/PdpContext.hpp>
00019
00020 class PdpContextManagerControl;
00021 class PdpContextControl;
00022
00023 #if defined(APOXI_EXTERNAL_PCH_CONTROL_SUPPORT)
00024
00025 class ExtPsdContextListenerImpl_SerialTerminalListener;
00026
00027 #endif // APOXI_EXTERNAL_PCH_CONTROL_SUPPORT
00028
00030 #define LOCK_PDP_CONTEXT_HANDLER PdpContextManager::GetSemaphore().Obtain();
00031 #define UNLOCK_PDP_CONTEXT_HANDLER PdpContextManager::GetSemaphore().Release();
00032
00035 class PdpContextManager {
00036     friend class PdpContext;
00037     friend class PdpContextSignalProcessor;
00038
00039     public:
00040         enum {
00041             ApoxiDefineScopeEntity(c_max_cid_array_len, PdpContextManager)
00042         };
00043
00045         enum State {
00047             Idle,
00049             AttachPending,
00051             DetachPending,
00053             ResetCountersPending,
00055             ReadCountersPending,
00057             PrimaryDefinePending,
00059             PrimaryUndefinePending,
00061             SecondaryDefinePending,
00063             SecondaryUndefinePending,
00065             AuthenticatePending,
00067             SetQualityOfServicePending,
00069             SetMinimumQualityOfServicePending,
00071             ActivatePending,
00073             NetworkRequestPending,
00075             DeactivatePending,
00077             ConnectPending,
00079             SetCounterPending,
00081             ReadCounterPending,
00083             SetPacketFilterPending,
00085             UnsetPacketFilterPending,
00087             SetAutomaticDnsServerNegotiationPending,
00089             ReadNegotiatedDnsServerAddressPending,
00090         };
00091
00093         enum ExternalContextState {
00095             c_ext_ctx_state_invalid = 0,
00097             c_ext_ctx_state_connecting = 1,
00099             c_ext_ctx_state_connected = 2,
00101             c_ext_ctx_state_disconnecting = 3,
00103             c_ext_ctx_state_disconnected = 4
00104         };
00105
00107         struct DataCounters {
00109             UINT32 m_session_sent;
00111             UINT32 m_session_received;
00113             UINT32 m_total_sent;
00115             UINT32 m_total_received;
00116
00117             void Reset() { m_session_sent = m_session_received = m_total_sent = m_total_received = 0; }
00118         };
00119
00121         class AttachStatus {
00122
00123             public:
00124
00126                 enum State {
00127                     ApoxiDefineScopeEntity(StateAccepted, PdpContextManager_AttachStatus),
00128                     ApoxiDefineScopeEntity(StateRejected, PdpContextManager_AttachStatus),
00129                     ApoxiDefineScopeEntity(StateFiveTimeT3310Expiry, PdpContextManager_AttachStatus),
00130                     ApoxiDefineScopeEntity(StateUserInteruption, PdpContextManager_AttachStatus),
00131                     ApoxiDefineScopeEntity(StateUnknownCause, PdpContextManager_AttachStatus),
00132                 };
00133
00135                 AttachStatus(State state = StateUnknownCause,
00136                              UINT8 ready_timer = 0,
00137                              UINT8 reject_cause = 0,
00138                              INT t3310_expiries = 0);
00139
00141                 ~AttachStatus();
00142
00144                 void Reset();
00145
00147                 State GetState() const { return (m_state); }
00149                 void SetState(State state) { m_state = state; }
00150
00152                 UINT8 GetReadyTimer() const { return (m_ready_timer); }
00154                 void SetReadyTimer(UINT8 ready_timer) { m_ready_timer = ready_timer; }
00155
00157                 UINT8 GetRejectCause() const { return (m_reject_cause); }
00159                 void SetRejectCause(UINT8 reject_cause) { m_reject_cause = reject_cause; }
00160
00162                 INT GetT3310Expiries() const { return m_t3310_expiries; }
00164                 void SetT3310Expiries(INT t3310_expiries) { m_t3310_expiries = t3310_expiries; }
00165
00166             private:
00167
00168                 State m_state;
00169                 UINT8 m_ready_timer;
00170                 UINT8 m_reject_cause;
00171                 INT m_t3310_expiries;
00172         };
00173
00176         static void Init();
00177
00182         static BOOLEAN AttachManagerControl(
00183             PdpContextManagerControl *context_manager_control = 0);
00184
00187         static PdpContextControl* GetContextControl(PdpContext *context) {
00188             ASSERT_DEBUG_INFO(s_pdp_contexts.Exists(context),
00189                 L"\nInvalid PDP context!\n");
00190             return s_pdp_contexts[context]->m_pdp_context_control;
00191         }
00192
00194         static PdpContextManagerControl* GetContextManagerControl() { return (m_context_manager_control); }
00195
00198         static void Register();
00199
00201         static void Attach();
00202
00204         static void Detach();
00205
00207         static BOOLEAN IsAttached() { return (m_attached); }
00208
00210         static const AttachStatus& GetAttachStatus() { return m_attach_status; }
00211
00214         static PdpContext* FindContext(PdpContext::Id id);
00215
00226         static PdpContext* CreateContext(PdpContextControl &context_control,
00227             PdpContext* primary_context = 0);
00228
00230         static State GetState() { return (m_state); }
00231
00236         static BOOLEAN GetDataCounters(UINT32 &sent, UINT32 &received);
00237
00240         static BOOLEAN ResetDataCounters();
00241
00244         static const DataCounters& GetLastStackDataCounters() { return (m_stack_data_counters); }
00245
00248         static void GetLastNegotiatedDnsServerAddresses(IpAddr &primary_dns, IpAddr &secondary_dns)
00249             { primary_dns = m_primary_dns_server; secondary_dns = m_secondary_dns_server; }
00250
00251 #if defined(APOXI_EXTERNAL_PCH_CONTROL_SUPPORT)
00252
00266         static void TerminateExternalContext();
00267
00268 #endif  // APOXI_EXTERNAL_PCH_CONTROL_SUPPORT
00269
00270     protected:
00271         static Semaphore& GetSemaphore() { return m_semaphore; }
00272
00273     private:
00274         static BOOLEAN m_initialized;
00275         static Mutex m_mutex;
00276         static PdpContextManagerControl *m_context_manager_control;
00277
00278         static State m_state;
00279         static PdpContext *m_pending_context;
00280         static BOOLEAN m_attached;
00281         static AttachStatus m_attach_status;
00282
00284         static PdpContext::ErrorCause m_last_error;
00285
00287         static IpAddr m_primary_dns_server, m_secondary_dns_server;
00288
00290         static UINT32 m_received_data_counter, m_sent_data_counter;
00291
00293         static DataCounters m_stack_data_counters;
00294
00297         static BooleanCondition m_data_counters_condition;
00298
00301         static PdpContext* GetPendingContext(State state);
00302
00304         static State GetPendingState();
00305
00308         static BOOLEAN SetPendingContext(State state, PdpContext *pending_context);
00309
00312         static void SetAttached(BOOLEAN attached);
00313
00316         static void SetAttachStatus(const AttachStatus &attach_status);
00317
00319         static void ResetState();
00320
00322         static BOOLEAN DeleteContext(PdpContext *context);
00323
00325         static void Reset();
00326
00327     private:
00329         struct PdpContextInfo {
00330             PdpContext::Id m_id;
00332             PdpContextControl* m_pdp_context_control;
00333
00334             PdpContextInfo() : m_id(-1), m_pdp_context_control(0) {}
00335
00336             PdpContextInfo(PdpContext::Id id,
00337                 PdpContextControl* pdp_context_control) :
00338                     m_id(id),
00339                     m_pdp_context_control(pdp_context_control) {}
00340         };
00341
00343         static Vector<PdpContextInfo> s_pdp_context_infos;
00344
00345         typedef SimpleMap<PdpContext*, PdpContextInfo*> PdpContextInfoMap;
00346
00348         static PdpContextInfoMap s_pdp_contexts;
00349
00353         static PdpContextInfo* FindUnusedContext();
00354
00356         static Semaphore m_semaphore;
00357
00358 #if defined(APOXI_EXTERNAL_PCH_CONTROL_SUPPORT)
00359
00360     private:
00361         static ExtPsdContextListenerImpl_SerialTerminalListener* m_extpsdcontext_listener;
00362
00363 #endif  // APOXI_EXTERNAL_PCH_CONTROL_SUPPORT
00364 };
00365
00366 #endif  // Asc_PdpContextManager_hpp
00367
Generated on Tue Jan 24 14:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContextManagerControl.hpp File Reference

Asc/PdpContextManagerControl.hpp File Reference

#include <Asc/PdpContext.hpp>

Include dependency graph for PdpContextManagerControl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PdpContextManagerControl

Defines

#define | Asc_PdpContextManagerControl_hpp

Define Documentation

#define Asc_PdpContextManagerControl_hpp

Generated on Tue Jan 24 17:29:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PdpContextManagerControl.hpp Source File

Asc/PdpContextManagerControl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2002 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Asc_PdpContextManagerControl_hpp)
00010 #define Asc_PdpContextManagerControl_hpp
00013
00014 #include <Asc/PdpContext.hpp>
00015
00018 class PdpContextManagerControl
00019 {
00020     public:
00022         PdpContextManagerControl() { }
00024         virtual ~PdpContextManagerControl() { }
00025
00031
00034         virtual void OnAttachCompleted(PdpContext::ErrorCause cause) { }
00035
00038         virtual void OnDetachCompleted(PdpContext::ErrorCause cause) { }
00039
00041
00047
00050         virtual void OnAttachRep(BOOLEAN attached) { }
00051
00054         virtual void OnAttachStatusIndication() { }
00055
00058         virtual void OnDetachIndication(PdpContext::ErrorCause cause,
00059             PdpContext::Origin origin = PdpContext::UnknownOrigin) { }
00060
00066         virtual void OnActivateContextIndication(PdpContext::Type type,
00067             PdpContext::Address address) { }
00068 };
00069
00071 #endif // Asc_PdpContextManagerControl_hpp
00072
00073
Generated on Tue Jan 24 14:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnDispatcher.cpp File Reference

Asc/PlmnDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/StackIndicationMsgTypes.hpp>
#include "PlmnDispatcher.hpp"
#include "PlmnRatDispatcher.hpp"

Include dependency graph for PlmnDispatcher.cpp:

Generated on Tue Jan 24 17:29:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnDispatcher.hpp File Reference

Asc/PlmnDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for PlmnDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PlmnDispatcher

Defines

#define | Asc_Gprs_PlmnDispatcher_gprs_hpp

Define Documentation

#define Asc_Gprs_PlmnDispatcher_gprs_hpp

Generated on Tue Jan 24 17:29:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnDispatcher.hpp Source File

Asc/PlmnDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Gprs_PlmnDispatcher_gprs_hpp)
00009 #define Asc_Gprs_PlmnDispatcher_gprs_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 #include <Asc/StackMsgDispatcher.hpp>
00014
00015 /*  ========================================================================
00016     PlmnDispatcher
00017     ======================================================================== */
00019 class PlmnDispatcher : public StackMsgDispatcher {
00020     typedef StackMsgDispatcher Base;
00021     public:
00023         PlmnDispatcher();
00025         virtual ~PlmnDispatcher();
00026
00028         void SetBlockingScan(BOOLEAN blocking_scan) { m_blocking_scan = blocking_scan; }
00030         BOOLEAN IsAttachAllowed() const { return (m_attach_allowed); }
00031
00033         void Register(const RegisterMode &mode, const Plmn &plmn, RadioAccessTechnology plmn_rat_mode,
00034                     RatChangeMode rat_change_mode = InvalidRatChangeMode,
00035                     RadioAccessTechnology rat_mode = RatNotAvailable,
00036                     GsmService gsm_service = InvalidGsmService) const;
00037
00039         void Detach() const;
00040
00042         void Detach(const GsmService gsm_service) const;
00043
00047         void Detach(const RatChangeMode rat_change_mode, RadioAccessTechnology rat_mode = RatNotAvailable) const;
00048
00052         void Detach(RadioAccessTechnology rat_mode) const;
00053
00054         //Check if rat-change is possible
00055         BOOLEAN IsRatChangePossible() const;
00056
00057     protected:
00059         BOOLEAN OnAttachCnf(const StackMsgArgument &arg);
00061         BOOLEAN OnAttachRej(const StackMsgArgument &arg);
00063         BOOLEAN OnAttachAllowedInd(const StackMsgArgument &arg);
00065         BOOLEAN OnDetachCnf(const StackMsgArgument &arg);
00067         BOOLEAN OnGprsClassInd(const StackMsgArgument &arg);
00069         BOOLEAN OnNRegStateInd(const StackMsgArgument &arg);
00071         BOOLEAN OnPlmnListCnf(const StackMsgArgument &arg);
00073         BOOLEAN OnPlmnListRej(const StackMsgArgument &arg);
00075         BOOLEAN OnRegStateInd(const StackMsgArgument &arg);
00077         BOOLEAN OnOmRatChangeInd(const StackMsgArgument &arg);
00078
00079     private:
00080         void ChangeGsmService(GsmService gsm_service) const;
00081         void ChangeRatMode(RatChangeMode rat_change_mode, RadioAccessTechnology rat_mode) const;
00082
00083         static const StackMsgArgMap<PlmnDispatcher> m_arg_map[];
00084         StackMsgArgMapContainer<PlmnDispatcher> m_arg_map_container;
00085
00086         BOOLEAN m_blocking_scan;
00087         PlmnScanList m_plmn_scan_list;
00088         BOOLEAN m_attach_allowed;
00089         static GsmService m_new_gsm_service;
00090         static RatChangeMode m_new_rat_change_mode;
00091         static RadioAccessTechnology m_new_radio_access_technology;
00092         static RegisterMode m_register_mode;
00093         static Plmn m_register_plmn;
00094         static RadioAccessTechnology m_register_rat;
00095 };
00096
00097
00098 #endif // Asc_Gprs_PlmnDispatcher_gprs_hpp
00099
Generated on Tue Jan 24 14:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnHandler.cpp File Reference

Asc/PlmnHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PlmnHandler.hpp"
#include "PlmnScanDispatcher.hpp"

Include dependency graph for PlmnHandler.cpp:

Generated on Tue Jan 24 17:29:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnHandler.hpp File Reference

Asc/PlmnHandler.hpp File Reference

#include <Apc/SignalTypes.hpp>
#include <Apc/PlmnScanList.hpp>
#include <Asc/BaseHandler.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Asc/PlmnDispatcher.hpp>
#include <Asc/PlmnScanDispatcher.hpp>

Include dependency graph for PlmnHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PlmnHandler

Defines

#define | Asc_PlmnHandler_hpp

Define Documentation

#define Asc_PlmnHandler_hpp

Generated on Tue Jan 24 17:29:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnHandler.hpp Source File

Asc/PlmnHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_PlmnHandler_hpp)
00009 #define Asc_PlmnHandler_hpp
00012
00013 #include <Apc/SignalTypes.hpp>
00014 #include <Apc/PlmnScanList.hpp>
00015
00016 #include <Asc/BaseHandler.hpp>
00017
00018 #include <Apc/NetworkTypes.hpp>
00019 #include <Asc/PlmnDispatcher.hpp>
00020 #include <Asc/PlmnScanDispatcher.hpp>
00021
00022 /*  ========================================================================
00023 PlmnHandler
00024 ======================================================================== */
00029 class PlmnHandler : public BaseHandler {
00030     typedef BaseHandler Base;
00031 public:
00032     enum { ID = PlmnHandlerId };
00033
00035     PlmnHandler();
00037     virtual ~PlmnHandler();
00038
00040     virtual HandlerId GetHandlerId() const;
00041
00046     BOOLEAN Scan(PlmnScanList &plmn_scan_list);
00047
00052     BOOLEAN Scan();
00053
00055     void InterruptScan() const;
00056
00064     void Register(const RegisterMode &mode, const Plmn &plmn = InvalidPlmn, RadioAccessTechnology plmn_rat_mode = RatNotAvailable) const;
00065
00067     BOOLEAN IsRegistrationAllowed() const;
00068
00075     BOOLEAN ChangeRatMode(RatChangeMode rat_change_mode, RadioAccessTechnology rat_mode = RatNotAvailable) const;
00076
00081     BOOLEAN ChangePreferedRatMode(RadioAccessTechnology rat_mode) const;
00082
00086     RadioAccessTechnology GetPreferedRatMode() const;
00087
00090     BOOLEAN IsRatChangePossible() const;
00091
00092 #if defined(DOWNSTRIP_TO_GSM)
00093 private:
00094 #endif
00095
00097     void Detach() const;
00098
00102     void ChangeGprsClass(const GprsClass &gprs_class) const;
00103
00109     BOOLEAN ChangePrefService(GsmService gsm_service) const;
00110
00114     GsmService GetPrefService() const;
00115
00119     BOOLEAN IsScanInProgress() const;
00120
00121 #if !defined(DOWNSTRIP_TO_GSM)
00122 private:
00123 #endif
00124     PlmnDispatcher m_plmn_dispatcher; // main dispatcher for retrieving asynchronous messages
00125     static PlmnScanDispatcher *m_plmn_scan_dispatcher;  // active scan dispatcher
00126 };
00127
00128
00130 #endif  // Asc_PlmnHandler_hpp
00131
Generated on Tue Jan 24 14:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnRatDispatcher.cpp File Reference

Asc/PlmnRatDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PlmnRatDispatcher.hpp"

Include dependency graph for PlmnRatDispatcher.cpp:

Generated on Tue Jan 24 17:30:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnRatDispatcher.hpp File Reference

Asc/PlmnRatDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>

Include dependency graph for PlmnRatDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PlmnRatDispatcher
Active Wait Dispatcher to catch the OmRatChangeCnf-Message-Arg. More...

Defines

#define | Asc_PlmnRatDispatcher_hpp

Define Documentation

#define Asc_PlmnRatDispatcher_hpp

Generated on Tue Jan 24 17:30:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnRatDispatcher.hpp Source File

Asc/PlmnRatDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_PlmnRatDispatcher_hpp)
00009 #define Asc_PlmnRatDispatcher_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00014
00015 /*  ========================================================================
00016     PlmnRatDispatcher
00017     ======================================================================== */
00019 class PlmnRatDispatcher : public StackMsgActiveWaitDispatcher {
00020     typedef StackMsgActiveWaitDispatcher Base;
00021     public:
00023         PlmnRatDispatcher();
00025         virtual ~PlmnRatDispatcher();
00026
00027     protected:
00031         BOOLEAN OnOmRatChangeCnf(const StackMsgArgument &arg);
00032
00033     private:
00035         static const StackMsgArgMap<PlmnRatDispatcher> m_arg_map[];
00037         StackMsgArgMapContainer<PlmnRatDispatcher> m_arg_map_container;
00038 };
00039
00040 #endif  // Asc_PlmnRatDispatcher_hpp
00041
Generated on Tue Jan 24 14:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnScanDispatcher.cpp File Reference

Asc/PlmnScanDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PlmnScanDispatcher.hpp"

Include dependency graph for PlmnScanDispatcher.cpp:

Generated on Tue Jan 24 17:30:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnScanDispatcher.hpp File Reference

Asc/PlmnScanDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/PlmnScanList.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>

Include dependency graph for PlmnScanDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PlmnScanDispatcher

Defines

#define | Asc_Gprs_PlmnScanDispatcher_gprs_hpp

Define Documentation

#define Asc_Gprs_PlmnScanDispatcher_gprs_hpp

Generated on Tue Jan 24 17:30:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PlmnScanDispatcher.hpp Source File

Asc/PlmnScanDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Gprs_PlmnScanDispatcher_gprs_hpp)
00009 #define Asc_Gprs_PlmnScanDispatcher_gprs_hpp
00010
00011 #include <Kernel/Types.hpp>
00012
00013 #include <Apc/PlmnScanList.hpp>
00014
00015 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     PlmnScanDispatcher
00019     ======================================================================== */
00021 class PlmnScanDispatcher : public StackMsgActiveWaitDispatcher {
00022     typedef StackMsgActiveWaitDispatcher Base;
00023     public:
00026         PlmnScanDispatcher(PlmnScanList &plmn_scan_list);
00028         virtual ~PlmnScanDispatcher();
00029
00030     protected:
00033         BOOLEAN OnPlmnListCnf(const StackMsgArgument &arg);
00036         BOOLEAN OnPlmnListRej(const StackMsgArgument &arg);
00037
00038     private:
00040         static const StackMsgArgMap<PlmnScanDispatcher> m_arg_map[];
00042         StackMsgArgMapContainer<PlmnScanDispatcher> m_arg_map_container;
00043
00045         PlmnScanList &m_plmn_scan_list;
00046 };
00047
00048 #endif  // Asc_Gprs_PlmnScanDispatcher_gprs_hpp
00049
Generated on Tue Jan 24 14:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PortHeaderInformation.cpp File Reference

Asc/PortHeaderInformation.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PortHeaderInformation.hpp"

Include dependency graph for PortHeaderInformation.cpp:

Generated on Tue Jan 24 17:30:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PortHeaderInformation.hpp File Reference

Asc/PortHeaderInformation.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Apc/InformationElement.hpp>

Include dependency graph for PortHeaderInformation.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PortHeaderInformation

Defines

#define | Asc_PortHeaderInformation_hpp

Define Documentation

#define Asc_PortHeaderInformation_hpp

Generated on Tue Jan 24 17:30:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PortHeaderInformation.hpp Source File

Asc/PortHeaderInformation.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_PortHeaderInformation_hpp)
00009 #define Asc_PortHeaderInformation_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/PhoneNumber.hpp>
00016 #include <Apc/InformationElement.hpp>
00017
00018 class Tpdu;
00019 /*  ========================================================================
00020     PortHeaderInformation
00021     ======================================================================== */
00023 class PortHeaderInformation : public Linkable <PortHeaderInformation>
00024 {
00025     public:
00026         PortHeaderInformation(Tpdu *tpdu = 0);
00027         virtual ~PortHeaderInformation();
00028
00030         const PhoneNumber&  GetPhoneNumber() const { return m_phnr; }
00032         UINT16 GetConcRefNo() const { return m_conc_ref_no; }
00034         UINT8 GetConcMaxNo() const { return m_conc_max_no; }
00036         UINT8 GetConcSeqNo() const { return m_conc_seq_no; }
00038         SmsPortNo GetSmsOriginatorPortNo() const { return m_sms_orig_port_no; }
00040         SmsPortNo GetSmsDestinationPortNo() const { return m_sms_dest_port_no; }
00042         UINT8 GetPayloadSize() const { return m_payload_size; }
00044         UINT8* GetPayloadData() const { return m_payload_data; }
00045
00047         BOOLEAN HasSmsPortNo() const { return m_sms_dest_port_no != InvalidSmsPortNo; }
00049         BOOLEAN IsConcateneted() const { return m_is_concateneted; }
00050
00051     private:
00052         UINT8 m_conc_max_no;
00053         UINT8 m_conc_seq_no;
00054         UINT8 m_payload_size;
00055         UINT8 m_payload_offset;
00056         UINT16 m_conc_ref_no;
00057         BOOLEAN m_is_concateneted;
00058         SmsPortNo m_sms_dest_port_no;
00059         SmsPortNo m_sms_orig_port_no;
00060         UINT8 *m_payload_data;
00061         Tpdu *m_tpdu;
00062         PhoneNumber m_phnr;
00063
00064 };
00065
00067 #endif  // Asc_PortHeaderInformation_hpp
00068
00069
Generated on Tue Jan 24 14:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerDispatcher.cpp File Reference

Asc/PowerDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "Apc/PowerStackMsgArgs.hpp"
#include "PowerDispatcher.hpp"

Include dependency graph for PowerDispatcher.cpp:

Generated on Tue Jan 24 17:30:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerDispatcher.hpp File Reference

Asc/PowerDispatcher.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for PowerDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PowerDispatcher

Defines

#define | Asc_PowerDispatcher_hpp

Define Documentation

#define Asc_PowerDispatcher_hpp

Generated on Tue Jan 24 17:30:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerDispatcher.hpp Source File

Asc/PowerDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_PowerDispatcher_hpp)
00009 #define Asc_PowerDispatcher_hpp
00012
00013 #include <Apc/StackMsgArgument.hpp>
00014 #include <Asc/StackMsgDispatcher.hpp>
00015
00016
00017 /*  ========================================================================
00018     PowerDispatcher
00019     ======================================================================== */
00021 class PowerDispatcher : public StackMsgDispatcher {
00022     typedef StackMsgDispatcher Base;
00023     public:
00025         PowerDispatcher();
00026
00028         virtual ~PowerDispatcher();
00029
00030     protected:
00031         BOOLEAN OnOmControlInd(const StackMsgArgument &arg);
00032
00033     private:
00034         static const StackMsgArgMap<PowerDispatcher> m_arg_map[];
00035         StackMsgArgMapContainer<PowerDispatcher> m_arg_map_container;
00036 };
00037
00039 #endif // Asc_PowerDispatcher_hpp
00040
00041
Generated on Tue Jan 24 14:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerDownDispatcher.cpp File Reference

Asc/PowerDownDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PowerDownDispatcher.hpp"

Include dependency graph for PowerDownDispatcher.cpp:

Generated on Tue Jan 24 17:31:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerDownDispatcher.hpp File Reference

Asc/PowerDownDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>

Include dependency graph for PowerDownDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PowerDownDispatcher

Defines

#define | Asc_PowerDownDispatcher_hpp

Define Documentation

#define Asc_PowerDownDispatcher_hpp

Generated on Tue Jan 24 17:31:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerDownDispatcher.hpp Source File

Asc/PowerDownDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_PowerDownDispatcher_hpp)
00009 #define Asc_PowerDownDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     PowerDownDispatcher
00019     ======================================================================== */
00021 class PowerDownDispatcher : public StackMsgActiveWaitDispatcher {
00022     typedef StackMsgActiveWaitDispatcher Base;
00023     public:
00025         PowerDownDispatcher();
00027         virtual ~PowerDownDispatcher();
00028
00029     protected:
00031         BOOLEAN OnPowerDownCnf(const StackMsgArgument &arg);
00032
00033     private:
00034         static const StackMsgArgMap<PowerDownDispatcher> m_arg_map[];
00035         StackMsgArgMapContainer<PowerDownDispatcher> m_arg_map_container;
00036 };
00037
00039 #endif // Asc_PowerDownDispatcher_hpp
00040
00041
Generated on Tue Jan 24 14:46:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerHandler.cpp File Reference

Asc/PowerHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/PowerHandler.hpp>
#include <Asc/PdpContextManager.hpp>
#include <Apc/StackInterface.hpp>

Include dependency graph for PowerHandler.cpp:

Functions

UINT8 | GetSimRegistrationMask ()
void | SendPowerUpArgs (PowerMode mode)

Function Documentation

UINT8 GetSimRegistrationMask ( ) [inline]

void SendPowerUpArgs ( PowerMode mode )

Generated on Tue Jan 24 17:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerHandler.hpp File Reference

Asc/PowerHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/BaseHandler.hpp>
#include <Apc/SignalHandler/SignalMapTableEntry.hpp>
#include <Asc/PowerDispatcher.hpp>

Include dependency graph for PowerHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PowerHandler

Defines

#define | Asc_PowerHandler_hpp

Define Documentation

#define Asc_PowerHandler_hpp

Generated on Tue Jan 24 17:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PowerHandler.hpp Source File

Asc/PowerHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_PowerHandler_hpp)
00009 #define Asc_PowerHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/BaseHandler.hpp>
00016 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>
00017 #include <Asc/PowerDispatcher.hpp>
00018
00019 /*  ========================================================================
00020     PowerHandler
00021     ======================================================================== */
00024 class PowerHandler : public BaseHandler {
00025     friend class ShutDown;
00026     public:
00027         typedef BaseHandler Base;
00028         enum { ID = PowerHandlerId };
00029
00031         PowerHandler();
00033         virtual ~PowerHandler();
00034
00036         virtual HandlerId GetHandlerId() const { return (PowerHandlerId); }
00037
00040         static void PowerUp(const ProcessPtr process_ptr = GetApoxiProcessPtr());
00041
00044         static void StartMobileNetwork(const ProcessPtr process_ptr = GetApoxiProcessPtr());
00045
00047         static BOOLEAN IsMobileNetworkStarted() { return m_is_mobile_network_started; }
00048
00051         static void StopMobileNetwork();
00052
00054         static void PowerDown();
00055
00057         static void StartSilentReset();
00058
00060         static void StartAirplaneMode(const ProcessPtr process_ptr = GetApoxiProcessPtr());
00061
00062     private:
00063         PowerDispatcher m_power_dispatcher;
00064         static BOOLEAN m_is_mobile_network_started;
00065
00066         // method simply sends the OM_CONTROL_REQ signal, to send a new (resp. change the) power mode
00067         static void SendPowerMode(PowerMode mode, const ProcessPtr process_ptr = GetApoxiProcessPtr());
00068 };
00069
00070
00072 #endif // Asc_PowerHandler_hpp
00073
00074
Generated on Tue Jan 24 14:46:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PppFrame.cpp File Reference

Asc/PppFrame.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PppFrame.hpp"

Include dependency graph for PppFrame.cpp:

Generated on Tue Jan 24 17:31:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PppFrame.hpp File Reference

Asc/PppFrame.hpp File Reference

#include <stack/stack.h>
#include <Auxiliary/ByteBuffer.hpp>

Include dependency graph for PppFrame.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PppFrame

Defines

#define | Asc_PppFrame_hpp

Define Documentation

#define Asc_PppFrame_hpp

Generated on Tue Jan 24 17:31:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PppFrame.hpp Source File

Asc/PppFrame.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_PppFrame_hpp)
00011 #define Asc_PppFrame_hpp
00012
00013 #include <stack/stack.h>                 // necessary for type "T_AUTH_PPP_FRAME"
00014 #include <Auxiliary/ByteBuffer.hpp>
00015
00016 class PppFrame : public ByteBuffer {
00017
00018     typedef ByteBuffer Base;
00019
00020     public:
00022         PppFrame()
00023             : Base() {  /* nothing to do here */ }
00024
00025         PppFrame(const T_AUTH_PPP_FRAME & ppp_frame)
00026             : Base((UINT8*) &ppp_frame, sizeof(T_AUTH_PPP_FRAME)) { /* nothing to do here */ }
00027
00028         PppFrame(const T_AUTH_PPP_FRAME * ppp_frame)
00029             : Base((UINT8*) ppp_frame, sizeof(T_AUTH_PPP_FRAME)) {  /* nothing to do here */ }
00030
00032         operator T_AUTH_PPP_FRAME () const;
00033
00035         PppFrame & operator = (const T_AUTH_PPP_FRAME & auth_ppp_frame);
00036 };
00037
00038 #endif
00039
00040
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PreComp.cpp File Reference

Asc/PreComp.cpp File Reference

#include "Asc/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PreComp.hpp File Reference

Asc/PreComp.hpp File Reference

#include <Kernel/Os/Win32/Win32.hpp>
#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Types.hpp>
#include <Asc/HandlerId.hpp>
#include <Asc/MainHandler.hpp>
#include <Asc/BaseHandler.hpp>
#include <Asc/SmsSocketListener.hpp>
#include <Asc/StackMsgDispatcher.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>
#include <Asc/StackControl.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/PreComp.hpp Source File

Asc/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if defined(APOXI_RTOS_WIN32)
00010     #include <Kernel/Os/Win32/Win32.hpp>
00011 #endif
00012
00013 #include <Kernel/Lib.hpp>
00014 #include <Auxiliary/Lib.hpp>
00015 #include <Apc/Lib.hpp>
00016 #include <Adc/Lib.hpp>
00017
00018 #include <Asc/Types.hpp>
00019 #include <Asc/HandlerId.hpp>
00020 #include <Asc/MainHandler.hpp>
00021 #include <Asc/BaseHandler.hpp>
00022 #include <Asc/SmsSocketListener.hpp>
00023 #include <Asc/StackMsgDispatcher.hpp>
00024 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00025 #include <Asc/StackControl.hpp>
00026 #include <Asc/StackIndicationMsgTypes.hpp>
00027
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/RedialDispatcher.cpp File Reference

Asc/RedialDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "RedialDispatcher.hpp"

Include dependency graph for RedialDispatcher.cpp:

Generated on Tue Jan 24 17:31:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/RedialDispatcher.hpp File Reference

Asc/RedialDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:31:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/RedialDispatcher.hpp Source File

Asc/RedialDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_RedialDispatcher_hpp)
00011 #define Asc_RedialDispatcher_hpp
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016
00017 class StackMsgActiveWaitDispatcher;
00018
00023 class RedialDispatcher : public StackMsgDispatcher {
00024     typedef StackMsgDispatcher Base;
00025     public:
00027         RedialDispatcher();
00028
00030         virtual ~RedialDispatcher();
00031
00032     protected:
00037         BOOLEAN OnRedialInd(const StackMsgArgument &arg);
00038
00039
00046         BOOLEAN OnRedialStopInd(const StackMsgArgument &arg);
00047
00048
00055         BOOLEAN OnRedialSetupInd(const StackMsgArgument &arg);
00056
00057
00058     private:
00059         static const StackMsgArgMap<RedialDispatcher> m_arg_map[];
00060         StackMsgArgMapContainer<RedialDispatcher> m_arg_map_container;
00061
00062 };
00063
00065 #endif // Asc_RedialDispatcher_hpp
00066
00067 #endif // DOXYGEN_SHOULD_SKIP_THIS
00068
00069
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/RtcHandler.hpp File Reference

Asc/RtcHandler.hpp File Reference

#include <Compat/RtcHandler.hpp>

Include dependency graph for RtcHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:31:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/RtcHandler.hpp Source File

Asc/RtcHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if defined(APOXI_COMPILER_MSVC)
00009     #pragma message ("Reference to old RtcHandler")
00010 #endif
00011 #include <Compat/RtcHandler.hpp>
00012
00013
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SigDispatcher.cpp File Reference

Asc/SigDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "SigDispatcher.hpp"

Include dependency graph for SigDispatcher.cpp:

Generated on Tue Jan 24 17:32:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SigDispatcher.hpp File Reference

Asc/SigDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for SigDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SigDispatcher

Defines

#define | Asc_SigDispatcher_hpp

Define Documentation

#define Asc_SigDispatcher_hpp

Generated on Tue Jan 24 17:32:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SigDispatcher.hpp Source File

Asc/SigDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SigDispatcher_hpp)
00009 #define Asc_SigDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     SigDispatcher
00019     ======================================================================== */
00021 class SigDispatcher : public StackMsgDispatcher {
00022     typedef StackMsgDispatcher Base;
00023     public:
00025         SigDispatcher();
00027         virtual ~SigDispatcher();
00028
00029     protected:
00031         BOOLEAN OnSignalStrengthLevelInd(const StackMsgArgument &arg);
00032
00033     private:
00034         static const StackMsgArgMap<SigDispatcher> m_arg_map[];
00035         StackMsgArgMapContainer<SigDispatcher> m_arg_map_container;
00036 };
00037
00039 #endif // Asc_SigDispatcher_hpp
00040
00041
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SigHandler.cpp File Reference

Asc/SigHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SigHandler.hpp"

Include dependency graph for SigHandler.cpp:

Generated on Tue Jan 24 17:32:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SigHandler.hpp File Reference

Asc/SigHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/SigDispatcher.hpp>

Include dependency graph for SigHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SigHandler

Defines

#define | Asc_SigHandler_hpp

Define Documentation

#define Asc_SigHandler_hpp

Generated on Tue Jan 24 17:32:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SigHandler.hpp Source File

Asc/SigHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SigHandler_hpp)
00009 #define Asc_SigHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/SigDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     SigHandler
00019     ======================================================================== */
00022 class SigHandler : public BaseHandler {
00023     typedef BaseHandler Base;
00024     public:
00025         enum { ID = SigHandlerId };
00026
00028         SigHandler();
00030         virtual ~SigHandler();
00031
00033         virtual HandlerId GetHandlerId() const;
00034
00035         /* Start receiving radio signal strength indication.
00036         @param treshold_db: Only if the new value received from network is more different
00037         as this dB-value, it is forwarded to mmi(reduces power-consumtion if percentage value is high).*/
00038         void Start(UINT threshold_db = 0) const;
00039
00041         void Stop() const;
00042
00043     private:
00044         SigDispatcher m_sig_dispatcher; // main dispatcher for retrieving asynchronous messages
00045 };
00046
00048 #endif // Asc_SigHandler_hpp
00049
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimDispatcher.cpp File Reference

Asc/SimDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "SimDispatcher.hpp"
#include "SimHandler.hpp"

Include dependency graph for SimDispatcher.cpp:

Generated on Tue Jan 24 17:32:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimDispatcher.hpp File Reference

Asc/SimDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for SimDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimDispatcher

Defines

#define | Asc_SimDispatcher_hpp

Define Documentation

#define Asc_SimDispatcher_hpp

Generated on Tue Jan 24 17:32:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimDispatcher.hpp Source File

Asc/SimDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SimDispatcher_hpp)
00009 #define Asc_SimDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     SimDispatcher
00019     ======================================================================== */
00021 class SimDispatcher : public StackMsgDispatcher {
00022     typedef StackMsgDispatcher Base;
00023
00024     friend class SimHandler;
00025
00026     public:
00028         SimDispatcher();
00030         virtual ~SimDispatcher();
00031
00032     protected:
00034         BOOLEAN OnSimInfoInd(const StackMsgArgument &arg);
00036         BOOLEAN OnSimInitInd(const StackMsgArgument &arg);
00038         BOOLEAN OnSimFullAccessInd(const StackMsgArgument &arg);
00040         BOOLEAN OnSimLockStatusInd(const StackMsgArgument &arg);
00042         BOOLEAN OnSimErrorInd(const StackMsgArgument &arg);
00044         BOOLEAN OnSimRefreshInd(const StackMsgArgument &arg);
00046         BOOLEAN OnSimChvRefreshInd(const StackMsgArgument &arg);
00048         BOOLEAN OnMdhSmsInitFinishedInd(const StackMsgArgument & arg);
00050         BOOLEAN OnSimMccMncInd(const StackMsgArgument & arg);
00052         BOOLEAN OnFdnInd(const StackMsgArgument & arg);
00054         BOOLEAN OnBdnInd(const StackMsgArgument & arg);
00056         BOOLEAN OnCfuDataInd(const StackMsgArgument & arg);
00058         BOOLEAN OnEccListInd(const StackMsgArgument & arg);
00060         BOOLEAN OnSimMruPropertyRefreshInd(const StackMsgArgument &arg);
00061
00062 #if defined(APOXI_ENABLE_USIM_PHONEBOOK)
00063
00064         BOOLEAN OnUsimPbReadyInd(const StackMsgArgument & arg);
00066         BOOLEAN OnUsimPbReadAsyncInd(const StackMsgArgument & arg);
00068         BOOLEAN OnUsimPbReadDataAsyncInd(const StackMsgArgument & arg);
00070         BOOLEAN OnUsimPbReadRefAsyncInd(const StackMsgArgument & arg);
00071 #endif
00072
00073     private:
00074         static const StackMsgArgMap<SimDispatcher> m_arg_map[];
00075         StackMsgArgMapContainer<SimDispatcher> m_arg_map_container;
00076
00077         static BOOLEAN m_init_ind_running;
00078         static BOOLEAN m_full_access_recv;
00079         static BOOLEAN m_alphatag_req_pending;
00080         static PbRequestBehaviour m_pbrequesttype;
00081         static BOOLEAN m_info_ind_running;
00082         static BOOLEAN m_init_ind_recv;
00083         static BOOLEAN m_dr_init_ind_recv;
00084         static SimInitIndArg m_sim_init_arg;
00085
00086
00087
00088 };
00089
00091 #endif // Asc_SimDispatcher_hpp
00092
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimHandler.cpp File Reference

Asc/SimHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SimHandler.hpp"

Include dependency graph for SimHandler.cpp:

Generated on Tue Jan 24 17:32:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimHandler.hpp File Reference

Asc/SimHandler.hpp File Reference

#include <Apc/SignalTypes.hpp>
#include <Asc/BaseHandler.hpp>
#include <Asc/SimDispatcher.hpp>

Include dependency graph for SimHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimHandler

Defines

#define | Asc_SimHandler_hpp

Define Documentation

#define Asc_SimHandler_hpp

Generated on Tue Jan 24 17:32:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimHandler.hpp Source File

Asc/SimHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SimHandler_hpp)
00009 #define Asc_SimHandler_hpp
00010
00011 #include <Apc/SignalTypes.hpp>
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/SimDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     SimHandler
00019     ======================================================================== */
00022 class SimHandler : public BaseHandler {
00023     typedef BaseHandler Base;
00024
00025     public:
00026         enum { ID = SimHandlerId };
00027
00029         SimHandler();
00031         virtual ~SimHandler();
00032
00034         virtual HandlerId GetHandlerId() const;
00035
00037         BOOLEAN ActivateFdn();
00039         BOOLEAN DeactivateFdn();
00040
00042         BOOLEAN ActivateBdn();
00044         BOOLEAN DeactivateBdn();
00045
00047         void SetPbAlphaTagRequestBehaviour(PbRequestBehaviour ) {
00048             DBG_OUT((0,"SimHandler::SetPbAlphaTagRequestBehaviour obsolete -> moved to AtcHandler\n"));
00049         }
00051         BOOLEAN ConfirmPbAlphaTagRequest(
00052             const WString & , const PhoneNumber & , BOOLEAN apoxilookup = FALSE)
00053         {
00054             DBG_OUT((0,"SimHandler::ConfirmPbAlphaTagRequest obsolete -> moved to AtcHandler\n"));
00055             return FALSE;
00056         }
00057
00058     private:
00059         SimDispatcher m_sim_dispatcher;     // main dispatcher for retrieving asynchronous messages
00060
00061 };
00062
00063 #endif // Asc_SimHandler_hpp
00064
00065
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkDispatcher.cpp File Reference

Asc/SimTkDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "SimTkDispatcher.hpp"

Include dependency graph for SimTkDispatcher.cpp:

Generated on Tue Jan 24 17:33:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkDispatcher.hpp File Reference

Asc/SimTkDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:33:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkDispatcher.hpp Source File

Asc/SimTkDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_SimTkDispatcher_hpp)
00011 #define Asc_SimTkDispatcher_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017 #include <Asc/StackMsgDispatcher.hpp>
00018
00019 /*  ========================================================================
00020     SimTkDispatcher
00021     ======================================================================== */
00023 class SimTkDispatcher : public StackMsgDispatcher {
00024     typedef StackMsgDispatcher Base;
00025
00026     friend class SimTkHandler;
00027     public:
00029         SimTkDispatcher();
00031         virtual ~SimTkDispatcher();
00032
00034         UINT8 GetSimCallSetupOption() const { return m_sim_command_qualifier; }
00036         const PhoneNumber & GetStkCallSetupNo() const { return m_stk_phone_no; }
00037
00038
00039     protected:
00041         BOOLEAN OnSimTkSmsPpInd(const StackMsgArgument &arg);
00043         BOOLEAN OnSimTkSsInd(const StackMsgArgument &arg);
00044
00046         BOOLEAN OnSimTkRefreshQueryReq(const StackMsgArgument &arg);
00048         BOOLEAN OnSimTkRefreshCnfReq(const StackMsgArgument &arg);
00050         BOOLEAN OnSimTkRefreshReq(const StackMsgArgument &arg);
00052         BOOLEAN OnSimTkRefreshNewReq(const StackMsgArgument &arg);
00054         BOOLEAN OnSimTkRefreshResetReq(const StackMsgArgument &arg);
00056         BOOLEAN OnSimTkResetCnfReq(const StackMsgArgument &arg);
00058         BOOLEAN OnSimTkResetCnf(const StackMsgArgument &arg);
00059
00061         BOOLEAN OnDisplayTextReq(const StackMsgArgument &arg);
00063         BOOLEAN OnGetInputReq(const StackMsgArgument &arg);
00065         BOOLEAN OnGetInkeyReq(const StackMsgArgument &arg);
00067         BOOLEAN OnSelectItemReq(const StackMsgArgument &arg);
00069         BOOLEAN OnSetupMenuReq(const StackMsgArgument &arg);            // menu is stored in ADC
00071         BOOLEAN OnMenuSelectionRej(const StackMsgArgument &arg);
00073         BOOLEAN OnPlayToneReq(const StackMsgArgument &arg);
00075         BOOLEAN OnSetupIdleModeTextReq(const StackMsgArgument &arg);
00077         BOOLEAN OnEndSimToolkitInd(const StackMsgArgument &arg);
00079         BOOLEAN OnSimTkCallSetupInd(const StackMsgArgument &arg);
00081         BOOLEAN OnSimTkSetupEventReq(const StackMsgArgument &arg);
00083         BOOLEAN OnSimTkLanguageNotificationInd(const StackMsgArgument &arg);
00085         BOOLEAN OnLanguageSettingReq(const StackMsgArgument &arg);
00087         BOOLEAN OnCallControlIndMsg(const StackMsgArgument &arg);
00089         BOOLEAN OnSsControlIndMsg(const StackMsgArgument &arg);
00091         BOOLEAN OnUssdControlIndMsg(const StackMsgArgument &arg);
00093         BOOLEAN OnSmsControlIndMsg(const StackMsgArgument &arg);
00095         BOOLEAN OnTermRspCnfMsg(const StackMsgArgument &arg);
00097         BOOLEAN OnSimLaunchBrowserReqMsg(const StackMsgArgument &arg);
00099         BOOLEAN OnSimLaunchBrowserPromptReqMsg(const StackMsgArgument &arg);
00101         BOOLEAN OnSimBrowserTermResMsg(const StackMsgArgument &arg);
00103         BOOLEAN OnSimTkRunAtCmdInfoIndMsg(const StackMsgArgument &arg);
00105         BOOLEAN OnSimTkSendDtmfIndMsg(const StackMsgArgument &arg);
00107         BOOLEAN OnSimTkSendDtmfEndIndMsg(const StackMsgArgument &arg);
00109         BOOLEAN OnGetTermProfileCnf(const StackMsgArgument &arg);
00111         BOOLEAN OnSetTermProfileCnf(const StackMsgArgument &arg);
00113         BOOLEAN OnSetTermProfileRej(const StackMsgArgument &arg);
00114
00115
00116     private:
00117         static const StackMsgArgMap<SimTkDispatcher> m_arg_map[];
00118         StackMsgArgMapContainer<SimTkDispatcher> m_arg_map_container;
00119         UINT8        m_sim_command_qualifier;
00120         BOOLEAN      m_events_present;
00121         PhoneNumber  m_stk_phone_no;
00122         SimEventList m_event_list;
00123
00124         BOOLEAN SendSimTkRefreshRsp();
00125         BOOLEAN IsAllowedPostSendingRefreshRsp(const SimEfRefresh & efrefresh);
00126
00127         SimTkTransactionId m_tid;
00128         ProactiveCause     m_cause;
00129         BOOLEAN            m_allow_post_sending_refresh_rsp;
00130 };
00131
00133 #endif // Asc_SimTkDispatcher_hpp
00134
00135 #endif // DOXYGEN_SHOULD_SKIP_THIS
00136
00137
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkHandler.cpp File Reference

Asc/SimTkHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Auxiliary/WString.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/ImageData.hpp>
#include "SimTkHandler.hpp"
#include "MocVoiceHandler.hpp"

Include dependency graph for SimTkHandler.cpp:

Functions

BOOLEAN | GetSimIconDescription (INT id, SimIconDescription &data)
BOOLEAN | GetSimImage (const SimImageDescriptor &imgdesc, SimImage &data)

Function Documentation

BOOLEAN GetSimIconDescription | ( | INT | id,
 |  | SimIconDescription & | data
 | ) |

BOOLEAN GetSimImage | ( | const SimImageDescriptor & | imgdesc,
 |  | SimImage & | data
 | ) |

Generated on Tue Jan 24 17:33:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkHandler.hpp File Reference

Asc/SimTkHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>
#include <Asc/SimTkDispatcher.hpp>

Include dependency graph for SimTkHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimTkHandler

Defines

#define | Asc_SimTkHandler_hpp

Define Documentation

#define Asc_SimTkHandler_hpp

Generated on Tue Jan 24 17:33:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkHandler.hpp Source File

Asc/SimTkHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SimTkHandler_hpp)
00009 #define Asc_SimTkHandler_hpp
00012
00013 #include <Asc/BaseHandler.hpp>
00014
00015 #include <Asc/SimTkDispatcher.hpp>
00016
00017 class SimIconDescription;
00018 class SimImage;
00019 class SimItemId;
00020 class WString;
00021
00022 /*  ========================================================================
00023     SimTkHandler
00024     ======================================================================== */
00030 class SimTkHandler : public BaseHandler {
00031     typedef BaseHandler Base;
00032     public:
00033         enum { ID = SimTkHandlerId };
00034
00036         SimTkHandler();
00038         virtual ~SimTkHandler();
00039
00041         virtual HandlerId GetHandlerId() const;
00042
00044         BOOLEAN SmsSetupResponse(const ProactiveCause &cause, const SimReferenceNumber &ref_no) const;
00046         BOOLEAN SsSetupResponse(const ProactiveCause &cause, const SimReferenceNumber &ref_no) const;
00047
00056         CallApiRc AcceptCallSetup(const ProactiveCause &cause, BOOLEAN ctm = FALSE) const;
00057
00058
00066         BOOLEAN RejectCallSetup(const ProactiveCause &cause = UserDidNotAcceptCallSetupRequest) const;
00067
00073         BOOLEAN TextDisplayed(const SimTkTransactionId & tid, const ProactiveCause &cause) const;
00075         BOOLEAN TextDisplayed(const ProactiveCause &cause) const;
00076
00086         BOOLEAN Input(const SimTkTransactionId & tid, const ProactiveCause &cause,
00087                       const WString &text, BOOLEAN ucs2_coding = FALSE, BOOLEAN packed = TRUE) const;
00089         BOOLEAN Input(const ProactiveCause &cause,
00090                       const WString &text, BOOLEAN ucs2_coding = FALSE, BOOLEAN packed = TRUE) const;
00091
00102         BOOLEAN Inkey(const SimTkTransactionId & tid, const ProactiveCause &cause,
00103                       const WString &text, BOOLEAN ucs2_coding = FALSE) const;
00105         BOOLEAN Inkey(const ProactiveCause &cause, const WString &text, BOOLEAN ucs2_coding = FALSE) const;
00107         BOOLEAN Inkey(const SimTkTransactionId & tid, const ProactiveCause &cause, SimKey key = SimKeyInvalid) const;
00109         BOOLEAN Inkey(const ProactiveCause &cause, SimKey key = SimKeyInvalid) const;
00110
00117         BOOLEAN ItemSelected(const SimTkTransactionId & tid, const ProactiveCause &cause, const SimItemId &item_id) const;
00119         BOOLEAN ItemSelected(const ProactiveCause &cause, const SimItemId &item_id) const;
00120
00126         BOOLEAN SetupMenuDone(const SimTkTransactionId & tid, const ProactiveCause &cause) const;
00128         BOOLEAN SetupMenuDone(const ProactiveCause &cause) const;
00129
00135         BOOLEAN MenuItemSelected(const SimItemId &item_id, BOOLEAN help_requested = FALSE) const;
00136
00142         BOOLEAN TonePlayed(const SimTkTransactionId & tid, const ProactiveCause &cause) const;
00144         BOOLEAN TonePlayed(const ProactiveCause &cause) const;
00145
00151         BOOLEAN SetupIdleModeTextDone(const SimTkTransactionId & tid, const ProactiveCause &cause) const;
00153         BOOLEAN SetupIdleModeTextDone(const ProactiveCause &cause) const;
00154
00157         BOOLEAN SendUserActivityEvent();
00158
00161         BOOLEAN SendIdleScreenAvailEvent();
00162
00167         BOOLEAN SendLanguageSelectEvent();
00168
00171         BOOLEAN SetActiveExtLanguage(const WString & language);
00172
00175         BOOLEAN SetSimResetPossible(BOOLEAN isresetable);
00176
00179         BOOLEAN SetSimRefreshPossible(BOOLEAN isrefreshable);
00180
00184         BOOLEAN SendSimTkRefreshRsp();
00185
00189         BOOLEAN GetSimIconDescription(INT id, SimIconDescription & data);
00190
00193         BOOLEAN GetSimImage(const SimImageDescriptor & imgdesc, SimImage & data);
00194
00197         BOOLEAN RegisterBrowser(SiClientFlags siclientflags);
00198
00201         BOOLEAN LaunchBrowser(const SimTkTransactionId & tid, SdlByte generalresult);
00203         BOOLEAN LaunchBrowser(SdlByte generalresult);
00204
00207         BOOLEAN BrowserLaunched(const SimTkTransactionId & tid, ProactiveCause proactivecause);
00209         BOOLEAN BrowserLaunched(ProactiveCause proactivecause);
00210
00213         BOOLEAN BrowserTerminated(UINT8 termcause );
00214
00217         BOOLEAN RunAtCommandResponse(const SimTkTransactionId & tid, ProactiveCause proactivecause);
00218
00221         BOOLEAN ConfirmDtmfSending(const ProactiveCause &icon_display_cause);
00222
00225         BOOLEAN StopDtmfSending();
00226
00229         void SimTkProfileFactoryReset() const;
00230
00233         void GetSimTkProfileReq() const;
00234
00238         void UpdateSimTkProfileReq(const SimTkProfile &profile_data) const;
00239
00242         static void EnableProactiveDtmfTones(BOOLEAN enable = TRUE);
00243
00244     //from protocol stack: is in Dispatcher
00245
00246     private:
00247         SimTkDispatcher m_stk_dispatcher;       // main dispatcher for retrieving asynchronous messages
00248
00249 };
00250
00252 #endif // Asc_SimTkHandler_hpp
00253
00254
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceDispatcher.cpp File Reference

Asc/SimTkLceDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"

Include dependency graph for SimTkLceDispatcher.cpp:

Generated on Tue Jan 24 17:33:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceDispatcher.hpp File Reference

Asc/SimTkLceDispatcher.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 17:33:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceDispatcher.hpp Source File

Asc/SimTkLceDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifdef APOXI_LETTERCLASSE_SUPPORT
00010
00011 #if !defined(Asc_SimTkLceDispatcher_hpp)
00012 #define Asc_SimTkLceDispatcher_hpp
00015
00016 #include <Kernel/Types.hpp>
00017
00018 #include <Asc/StackMsgDispatcher.hpp>
00019 #include <Apc/SimTkTypes.hpp>
00020
00021 #include <Socket/CsdDataConnProfile.hpp>
00022 #include <Socket/PsdDataConnProfile.hpp>
00023
00024 #include <Socket/SocketHandler.hpp>
00025 #include <Socket/NetAdapterHandler.hpp>
00026
00027 #define SIMTK_LCE_SOCKET_RECV_BUFFER_SIZE 1024
00028 #define SIMTK_LCE_SOCKET_SEND_BUFFER_SIZE 1024
00029 #define SIMTK_LCE_SIM_SEND_BUFFER_SIZE 1024
00030
00031 class SocketData;
00032
00033 class SiRxBuf {
00034     public:
00035         SiRxBuf(const INT len);
00036         ~SiRxBuf();
00037         UINT8 * m_data; // Takes the whole size of SIMTK_LCE_SOCKET_RECV_BUFFER_SIZE.
00038         ChannelData * chdata; // Takes only 244 bytes for delivery to SIM.
00039         INT filledbytes;
00040         BOOLEAN delivered;
00041         INT readposition;
00042         INT GetCapacity()  const { return m_capacity; }
00043         void SetCapacity(const UINT capacity) {  m_capacity = capacity; }
00044         BOOLEAN FillNextChanBufForSim(const INT NumBytes) ;
00045
00046     private:
00047         UINT m_capacity;
00048 };
00049
00050 class SiTxBuf {
00051     public:
00052         SiTxBuf(const INT len);
00053         ~SiTxBuf();
00054         UINT8 * m_data; // Takes the whole size of SIMTK_LCE_SIM_SEND_BUFFER_SIZE.
00055         ChannelData * chdata; // Takes only 244 bytes for receiving from SIM.
00056         //UINT filledbytes;
00057         BOOLEAN delivered;
00058         UINT readposition;
00059         UINT writeposition; //also used as filledbytes counter
00060         UINT GetCapacity()  const { return m_capacity; }
00061         void SetCapacity(const UINT capacity) {  m_capacity = capacity; }
00062         BOOLEAN IncReadPosition(const INT IncNumBytes) ;
00063         BOOLEAN FillNextChanBufFromSim() ;
00064         BOOLEAN ZeroReadWritePosition() { readposition = 0; writeposition = 0;   return TRUE; }
00065
00066     private:
00067         UINT m_capacity;
00068 };
00069
00070 /*  ========================================================================
00071     SimTkLceDispatcher
00072     ======================================================================== */
00074 class SimTkLceDispatcher : public StackMsgDispatcher {
00075     typedef StackMsgDispatcher Base;
00076
00077     friend class DataConn;
00078     friend class CsdDataConn;
00079     friend class PsdDataConn;
00080
00081     public:
00083         SimTkLceDispatcher();
00085         virtual ~SimTkLceDispatcher();
00086
00087         enum csd_speed {
00088 //CSD T_SI_BEARER_DESC parameters
00089 /*<speed>: GSM 27.007 */
00090             csd_autobauding = 0,        //(automatic selection of the speed; this setting is possible in case of 3.1 kHz modem and non-transparent service)
00091             csd_300_bps_V_21 = 1,
00092             csd_1200_bps_V_22 = 2,
00093             csd_1200_75_bps_V_23 = 3,
00094             csd_2400_bps_V_22bis = 4,
00095             csd_2400_bps_V_26ter = 5,
00096             csd_4800_bps_V_32 = 6,
00097             csd_9600_bps_V_32 = 7,
00098             csd_9600_bps_V_34 = 12,
00099             csd_14400_bps_V_34 = 14,
00100             csd_19200_bps_V_34 = 15,
00101             csd_28800_bps_V_34 = 16,
00102             csd_33600_bps_V_34 = 17,
00103             csd_1200_bps_V_120 = 34,
00104             csd_2400_bps_V_120 = 36,
00105             csd_4800_bps_V_120 = 38,
00106             csd_9600_bps_V_120 = 39,
00107             csd_14400_bps_V_120 = 43,
00108             csd_19200_bps_V_120 = 47,
00109             csd_28800_bps_V_120 = 48,
00110             csd_38400_bps_V_120 = 49,
00111             csd_48000_bps_V_120 = 50,
00112             csd_56000_bps_V_120 = 51,
00113             csd_300_bps_V_110 = 65,
00114             csd_1200_bps_V_110 = 66,
00115             csd_2400_bps_V_110_or_X31_flag_stuffing = 68,
00116             csd_4800_bps_V_110_or_X31_flag_stuffing = 70,
00117             csd_9600_bps_V_110_or_X31_flag_stuffing = 71,
00118             csd_14400_bps_V_110_or_X31_flag_stuffing = 75,
00119             csd_19200_bps_V_110_or_X31_flag_stuffing = 79,
00120             csd_28800_bps_V_110_or_X31_flag_stuffing = 80,
00121             csd_38400_bps_V_110_or_X31_flag_stuffing = 81,
00122             csd_48000_bps_V_110_or_X31_flag_stuffing = 82,
00123             csd_56000_bps_V_110_or_X31_flag_stuffing = 83,
00124             csd_64000_bps_X31_flag_stuffing = 84,
00125             csd_56000_bps_bit_transparent = 115,
00126             csd_64000_bps_bit_transparent = 116,
00127             csd_32000_bps_PIAFS32k = 120,
00128             csd_64000_bps_PIAFS64k = 121,
00129             csd_28800_bps_multimedia = 130,
00130             csd_32000_bps_multimedia = 131,
00131             csd_33600_bps_multimedia = 132,
00132             csd_56000_bps_multimedia = 133,
00133             csd_64000_bps_multimedia = 134,
00134
00135         };
00136
00137 //<name>:
00138         enum csd_name {
00139             data_circuit_asynchronous_UDI_or_31kHz_modem = 0,
00140             data_circuit_synchronous_UDI_or_31kHz_modem = 1,
00141             PAD_Access_asynchronous_UDI = 2,
00142             Packet_Access_synchronous_UDI = 3,
00143             data_circuit_asynchronous_RDI = 4,
00144             data_circuit_synchronous_RDI = 5,
00145             PAD_Access_asynchronous_RDI = 6,
00146             Packet_Access_synchronous_RDI = 7,
00147         };
00148
00149         enum connectionelement {
00150 //<ce>:
00151             transparent = 0,
00152             non_transparent = 1,
00153             both_transparent_preferred = 2,
00154             both_non_transparent_preferred = 3,
00155
00156         };
00157
00158 //PSD T_SI_BEARER_DESC parameters
00159 /* QoS: GSM 23.107 ,  9.1.2.3 Table 7:  Determining R97/98 attributes from R99 attributes*/
00160 /*NEWTYPE T_QOS //#NAME 'T_QOS'
00161     STRUCT
00162   // 2G parameters
00163       delay_class               Byte;
00164       reliability_class         Byte;
00165       precedence_class          Byte;
00166       peak_throughput           Byte;
00167       mean_throughput           Byte;
00168   // 3G parameters
00169       present_3g        Boolean;
00170       traffic_class             Byte;
00171       delivery_order            Byte;
00172       error_sdu_delivery        Byte;
00173       max_sdu_size              Byte;
00174       max_bit_rate_up           Byte;
00175       max_bit_rate_down         Byte;
00176       residual_ber              Byte;
00177       sdu_error_ratio           Byte;
00178       transfer_delay            Byte;
00179       traffic_priority          Byte;
00180       guaranteed_bit_rate_up    Byte;
00181       guaranteed_bit_rate_down  Byte;
00182   ENDNEWTYPE;
00183 */
00184
00185         enum qos_traffic_delay_class {
00186            delayclass_subscribed  = 0,
00187            delayclass1  = 1,
00188            delayclass2  = 2,
00189            delayclass3  = 3,
00190            delayclass4  = 4,
00191            delayclassreserved  = 7,
00192         };
00193         enum qos_reliability_class {
00194             reliabilitysubscribed = 0,
00195             reliabilityclass1 = 1,
00196             reliabilityclass2 = 2,
00197             reliabilityclass3 = 3,
00198             reliabilityclass4 = 4,
00199             reliabilityclass5 = 5,
00200             reliabilityclass6 = 6,
00201             reliabilityreserved = 7,
00202         };
00203         enum qos_precedence_class {
00204             precedencesubscribed    = 0,
00205             precedencehigh          = 1,
00206             precedencenormal        = 2,
00207             precedencelow           = 3,
00208             precedencereserved      = 7,
00209         };
00210         enum qos_peak_throughput_class  {
00211 //          peakrateundef = 0,
00212             peakratesubscribed  = 0,
00213             peakrate1K  = 1,
00214             peakrate2K  = 2,
00215             peakrate4K  = 3,
00216             peakrate8K  = 4,
00217             peakrate16K     = 5,
00218             peakrate32K     = 6,
00219             peakrate64K     = 7,
00220             peakrate128K    = 8,
00221             peakrate256K    = 9,
00222             peakratereserved = 15,
00223         };
00224
00225         enum qos_mean_throughput_class {
00226             MeanRateSubscribed = 0,
00227             MeanRate100 = 1,
00228             MeanRate200 = 2,
00229             MeanRate500 = 3,
00230             MeanRate1K = 4,
00231             MeanRate2K = 5,
00232             MeanRate5K = 6,
00233             MeanRate10K = 7,
00234             MeanRate20K = 8,
00235             MeanRate50K = 9,
00236             MeanRate100K = 10,
00237             MeanRate200K = 11,
00238             MeanRate500K = 12,
00239             MeanRate1M = 13,
00240             MeanRate2M = 14,
00241             MeanRate5M = 15,
00242             MeanRate10M = 16,
00243             MeanRate20M = 17,
00244             MeanRate50M = 18,
00245             MeanRateReserved = 30,
00246             MeanRateBestEffort = 31, //always_set_to_31 = 31, // 0x1F
00247         };
00248
00249 /*GSM 11.14, 12.52.2    Bearer parameters for GPRS  packet service*/
00250         enum qos_pd_protocol_type {
00251             internet_protocol_IETF_STD_5 = 2,
00252         };
00253
00255         UINT8 GetSimCallSetupOption() const { return m_sim_command_qualifier; };
00257         const PhoneNumber & GetStkCallSetupNo() const { return m_stk_phone_no; };
00258
00259         SimTkTransactionId stktransid;
00260
00261         //regular messages: SIM -> Proactive Client
00262         BOOLEAN OnSiChannelOpenPromptReq(const StackMsgArgument &arg);
00263         BOOLEAN OnSiChannelCloseInfoInd(const StackMsgArgument &arg);
00264         BOOLEAN OnSiChannelSendInfoInd(const StackMsgArgument &arg);
00265         BOOLEAN OnSiChannelReceiveInfoInd(const StackMsgArgument &arg);
00266
00267         //messages: SIM -> IP-Socket
00268         BOOLEAN OnDhChannelOpenReq(const StackMsgArgument &arg);
00269         BOOLEAN OnDhChannelCloseReq(const StackMsgArgument &arg);
00270         BOOLEAN OnDhChannelSendReq(const StackMsgArgument &arg);
00271         BOOLEAN OnDhChannelDataAvailableRes(const StackMsgArgument &arg);
00272         BOOLEAN OnDhChannelReceiveReq(const StackMsgArgument &arg);
00273         BOOLEAN OnDhChannelChangeStatusRes(const StackMsgArgument &arg);
00274
00275         //some commands, could be moved to another class
00276         BOOLEAN OpenBearerUndefChan();
00277         BOOLEAN OpenBearerCsdChan(UINT8 csd_speed, UINT8 csd_name, UINT8 csd_connectionelement);
00278         BOOLEAN OpenBearerPsdChan(qos_precedence_class precedence, qos_traffic_delay_class delay, qos_reliability_class reliability, qos_peak_throughput_class peakthroughput, qos_mean_throughput_class meanthroughput, qos_pd_protocol_type pdprotocoltype);
00279         BOOLEAN OpenBearerDefaultChan();
00280 #if defined(APOXI_SER_DATACONN_SUPPORT)
00281         BOOLEAN OpenBearerSerChan(); //not an option in SiBearerList
00282 #endif
00283
00284         BOOLEAN NewProfile(DataConnProfile::ProfileType type);
00285             //Helpers for NewProfile():
00286             BOOLEAN LoadProfile(DataConnProfile::ProfileType type, DataConnProfileId profile_id);
00287             INT     ProfileCount();
00288             DataConnProfile* GetProfile(DataConnProfile::ProfileType type);
00289
00290         void EditBasicEntry(DataConnProfile* profile);
00291         void EditCsdEntry(UINT8 csd_speed, UINT8 csd_name, UINT8 csd_connectionelement);
00292         void EditSerEntry();
00293         void EditPsdEntry(qos_precedence_class precedence, qos_traffic_delay_class delay, qos_reliability_class reliability, qos_peak_throughput_class peakthroughput, qos_mean_throughput_class meanthroughput, qos_pd_protocol_type pdprotocoltype);
00294
00295         //Notification, if Buffer was received
00296         void OnFillRecvBuf(INT id, UINT8*  BufferRecv, INT dataLen);
00297         //Notification, if Buffer was sent
00298         void OnSendBufSent(INT id, INT dataLen);
00299
00300         // Callback invoked on NetAdapter events.
00301         static void LceNetAdapterCallBackHandler(void* client_arg, NetAdapterHandler &handler, NetAdapter &net_adapter, NetAdapter::Event event, const NetAdapter::EventArgs &event_args);
00302
00304
00313         BOOLEAN LceDhChannelOpenCnf(const UINT8 cidx, const UINT16 buffer_size, const SiBearerDesc bearer_desc,  const GenResultCode gen_result,  const UINT8 adn_result ) const;
00314
00321         BOOLEAN LceDhChannelOpenRej(const UINT8 cidx, const GenResultCode gen_result,  const UINT8 adn_result ) const;
00322
00329         BOOLEAN LceDhChannelCloseInd(const UINT8 cidx, const GenResultCode gen_result,  const UINT8 adn_result ) const;
00330
00338         BOOLEAN LceDhChannelSendInd(const UINT8 cidx, const UINT16 empty_bytes_in_tx, const UINT8 gen_result,  const UINT8 adn_result ) const;
00339
00346         BOOLEAN LceDhChannelDataAvailEvent(const UINT8 cidx, const UINT16 channel_data_length,  const SiChannelChangedState changed_state ) const;
00347
00356         BOOLEAN LceDhChannelReceiveInd(const UINT8 cidx, const UINT16 remaining_data_length, const GenResultCode gen_result,  const UINT8 adn_result, const ChannelData& channel_data ) const;
00357
00363         BOOLEAN LceDhChannelChangeStatusEvent(UINT8 cidx, const SiChannelChangedState& changed_state) const;
00364
00365     private:
00366         static const StackMsgArgMap<SimTkLceDispatcher> m_arg_map[];
00367         StackMsgArgMapContainer<SimTkLceDispatcher> m_arg_map_container;
00368         UINT8        m_sim_command_qualifier;
00369         BOOLEAN      m_events_present;
00370         PhoneNumber  m_stk_phone_no;
00371         SimEventList m_event_list;
00372
00373
00374         //Data keepers:
00375         mutable UINT16 keep_channel_data_length_for_resending;
00376         UINT8 channelId ;
00377         mutable UINT8   keep_cidx_for_resending;
00378         mutable SiChannelChangedState keep_changed_state_for_resending;
00379         UINT16 buffersize ;
00380         UINT8 cmdqualifier ;
00381         SiTransportLayer transportlayer ;
00382         SiBearerDesc bearerdesc ;
00383         SiIpAddress  localipaddr ;
00384         SiIpAddress destipaddr ;
00385         UINT16 destPort ;
00386         UINT16 localPort;
00387         SiDuration duration1 ;
00388         SiDuration duration2 ;
00389         PhoneNumber  phonenumber ;
00390         SimSubAddress subaddress ;
00391         SimTextString userlogin ;
00392         SimTextString password ;
00393         BOOLEAN enablepasswd;
00394         BOOLEAN immediate_link_establishment; //TRUE=immediate link establishment, FALSE=on demand link establishment
00395         BOOLEAN automatic_reconnection; //TRUE=automatic reconnection, FALSE=no automatic reconnection
00396         BOOLEAN link_establishment_now;
00397
00398         IpAddr serverAddress;
00399         String apn;
00400
00401         INT addressLen ; //currently only 4 = IP4
00402
00403         CsdDataConnProfile m_csd_profile;
00404         PsdDataConnProfile m_psd_profile;
00405
00406         DataConnProfileId m_dc_id;
00407
00408         SocketHandler m_socket_handler; // Handler needed to receive for socket events.
00409
00410         NetAdapterHandler* m_lce_net_adapter_handler;
00411         NetAdapter::Id     m_lce_net_adapter_id;
00412         NetAdapter::Type   m_lce_net_adapter_type;
00413
00414         UINT32 m_last_send_request; // Amount of bytes passed to the last NetAdapterHandler::Send() method call.
00415
00416         SiRxBuf * siRxBuf;
00417         SiTxBuf * siTxBuf;
00418 };
00419
00421 #endif  // Asc_SimTkLceDispatcher_hpp
00422
00423 #endif  // APOXI_LETTERCLASSE_SUPPORT
00424
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceHandler.cpp File Reference

Asc/SimTkLceHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Auxiliary/WString.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/ImageData.hpp>
#include "SimTkLceHandler.hpp"
#include "MocVoiceHandler.hpp"

Include dependency graph for SimTkLceHandler.cpp:

Generated on Tue Jan 24 17:34:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceHandler.hpp File Reference

Asc/SimTkLceHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:34:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceHandler.hpp Source File

Asc/SimTkLceHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifdef  APOXI_LETTERCLASSE_SUPPORT
00010 #if !defined(Asc_SimTkLceHandler_hpp)
00011 #define Asc_SimTkLceHandler_hpp
00014
00015 #include <Asc/BaseHandler.hpp>
00016
00017 #include <Asc/SimTkLceDispatcher.hpp>
00018
00019 class SimIconDescription;
00020 class SimImage;
00021 class SimItemId;
00022 class WString;
00023
00024 /*  ========================================================================
00025     SimTkLceHandler
00026     ======================================================================== */
00030 class SimTkLceHandler : public BaseHandler {
00031     typedef BaseHandler Base;
00032     friend class BattDispatcher; //for testing purposes only
00033     public:
00034         enum { ID = SimTkLceHandlerId };
00035
00037         SimTkLceHandler();
00039         virtual ~SimTkLceHandler();
00040
00042         virtual HandlerId GetHandlerId() const;
00043
00045
00046
00051         BOOLEAN LceChannelOpenPromptRes(const GenResultCode gen_result) const;
00052
00056         BOOLEAN LceChannelCloseReq(const UINT8 cidx) const;
00057
00063         BOOLEAN LceChannelCloseInfoRes(const UINT8 cidx, const GenResultCode gen_result) const;
00064
00070         BOOLEAN LceChannelSendInfoRes(const UINT8 cidx, const GenResultCode gen_result) const;
00071
00077         BOOLEAN LceChannelReceiveInfoRes(const UINT8 cidx, const GenResultCode gen_result) const;
00078
00079
00080
00082
00091         BOOLEAN LceDhChannelOpenCnf(const UINT8 cidx, const UINT16 buffer_size, const SiBearerDesc bearer_desc,  const GenResultCode gen_result,  const UINT8 adn_result ) const;
00092
00099         BOOLEAN LceDhChannelOpenRej(const UINT8 cidx, const GenResultCode gen_result,  const UINT8 adn_result ) const;
00100
00107         BOOLEAN LceDhChannelCloseInd(const UINT8 cidx, const GenResultCode gen_result,  const UINT8 adn_result ) const;
00108
00109
00110     private:
00111         SimTkLceDispatcher m_stkletclasse_dispatcher;       // main dispatcher for retrieving asynchronous messages
00112
00113         friend class BattDispatcher;
00114 };
00115
00117 #endif // Asc_SimTkLceHandler_hpp
00118 #endif // APOXI_LETTERCLASSE_SUPPORT
00119
00120
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceService.cpp File Reference

Asc/SimTkLceService.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SimTkLceService.hpp"

Include dependency graph for SimTkLceService.cpp:

Generated on Tue Jan 24 17:34:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceService.hpp File Reference

Asc/SimTkLceService.hpp File Reference

#include <Kernel/ServiceThread.hpp>

Include dependency graph for SimTkLceService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimTkLceService

Defines

#define | Apoxi_SimTkLceService_hpp

Define Documentation

#define Apoxi_SimTkLceService_hpp

Generated on Tue Jan 24 17:34:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SimTkLceService.hpp Source File

Asc/SimTkLceService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SimTkLceService_hpp)
00010 #define Apoxi_SimTkLceService_hpp
00011
00012 #include <Kernel/ServiceThread.hpp>
00013
00014 class SimTkLceService : public ServiceThread {
00015     typedef ServiceThread Base;
00016
00017     public:
00018         virtual ~SimTkLceService();
00019
00020         static SimTkLceService& GetInstance();
00021
00022     protected:
00023         virtual void OnPowerUp();
00024
00025         virtual void OnPowerDown();
00026
00027         virtual BOOLEAN OnMessage(const Message& msg);
00028
00029     private:
00030         SimTkLceService();
00031         SimTkLceService(const SimTkLceService&);
00032 };
00033
00034 #endif  // Apoxi_SimTkLceService_hpp
00035
00036
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsContext.cpp File Reference

Asc/SmsContext.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SmsContext.hpp"

Include dependency graph for SmsContext.cpp:

Generated on Tue Jan 24 17:34:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsContext.hpp File Reference

Asc/SmsContext.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Apc/ProtocolIdentifier.hpp>
#include <Apc/DataCodingScheme.hpp>
#include <Apc/ValidityPeriod.hpp>
#include <Apc/InformationElement.hpp>
#include <Apc/MessageTypeIndicator.hpp>
#include <Apc/SimDataTypes.hpp>
#include <Apc/CommandType.hpp>

Include dependency graph for SmsContext.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsContext

Defines

#define | Asc_SmsContext_hpp

Define Documentation

#define Asc_SmsContext_hpp

Generated on Tue Jan 24 17:34:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsContext.hpp Source File

Asc/SmsContext.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsContext_hpp)
00009 #define Asc_SmsContext_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Auxiliary/PhoneNumber.hpp>
00016 #include <Apc/ProtocolIdentifier.hpp>
00017 #include <Apc/DataCodingScheme.hpp>
00018 #include <Apc/ValidityPeriod.hpp>
00019 #include <Apc/InformationElement.hpp>
00020 #include <Apc/MessageTypeIndicator.hpp>
00021 #include <Apc/SimDataTypes.hpp>
00022 #include <Apc/CommandType.hpp>
00023
00024 /*  ========================================================================
00025     SmsContext -
00026     ======================================================================== */
00028 class SmsContext {
00029     public:
00031         SmsContext(MessageTypeIndicator::Type mt = MessageTypeIndicator::InvalidType);
00033         ~SmsContext();
00034
00036         void Clear();
00037
00039         BOOLEAN ReadSmsProfile(INT profile_number = 0);
00040
00042         BOOLEAN IsValid() const;
00043
00047         void SetSubmitParameter(const PhoneNumber &service_center_address,
00048                                 const PhoneNumber &destination_address,
00049                                 const ProtocolIdentifier &protocol_identifier,
00050                                 const DataCodingScheme &data_coding_scheme,
00051                                 const ValidityPeriod &valitity_period,
00052                                 BOOLEAN status_report_request,
00053                                 BOOLEAN reply_path,
00054                                 BOOLEAN reject_duplicates);
00055
00059         void SetCommandParameter(const PhoneNumber &service_center_address,
00060                                  const PhoneNumber &destination_address,
00061                                  const ProtocolIdentifier &protocol_identifier,
00062                                  SmsReferenceNumber message_number,
00063                                  const CommandType &command_type,
00064                                  BOOLEAN status_report_request);
00065
00067         void SetMessageType(MessageTypeIndicator::Type mt) { m_mt = mt; }
00068
00070         void SetServiceCenterAddress(const PhoneNumber &sca);
00072         void SetDestinationAddress(const PhoneNumber &da);
00074         void SetProtocolIdentifier(const ProtocolIdentifier &pid) { m_pid = pid; }
00076         void SetRequestStatusReport(BOOLEAN srr)  { m_srr = srr; }
00078         void SetSmsReferenceNumber(SmsReferenceNumber mr)  { m_mr = mr; }
00079
00081         void SetDataCodingScheme(const DataCodingScheme &dcs) { m_dcs = dcs; }
00083         void SetValidityPeriod(const ValidityPeriod &vp)  { m_vp = vp; }
00085         void SetRequestReplyPath(BOOLEAN rp)  { m_rp = rp; }
00087         void SetRejectDuplicates(BOOLEAN rd)  { m_rd = rd; }
00088
00090         void SetCommandType(const CommandType &ct)  { m_ct = ct; }
00092         void SetMessageNumber(SmsReferenceNumber mn)  { m_mn = mn; }
00093
00098         void SetConcatenatedReferenceNoType(InformationElement::Identifier conc_refno_type);
00103         void SetDestinationApplicationPortAddress(SmsPortNo destination_port_no) { m_destination_port_no = destination_port_no; }
00108         void SetOriginatorApplicationPortAddress(SmsPortNo originator_port_no) { m_originator_port_no = originator_port_no; }
00109
00111         void SetSingleSrrPerSmsEnabled(BOOLEAN single_srr) { m_single_srr = single_srr; }
00112
00114         MessageTypeIndicator::Type GetMessageType() const { return m_mt; }
00115
00117         const PhoneNumber& GetServiceCenterAddress() const { return m_sca; }
00119         const PhoneNumber& GetDestinationAddress() const { return m_da; }
00121         ProtocolIdentifier GetProtocolIdentifier() const { return m_pid; }
00123         BOOLEAN GetRequestStatusReport() const { return m_srr; }
00125         SmsReferenceNumber GetSmsReferenceNumber() const { return m_mr; }
00126
00128         DataCodingScheme GetDataCodingScheme() const { return m_dcs; }
00130         const ValidityPeriod& GetValidityPeriod() const { return m_vp; }
00132         BOOLEAN GetRequestReplyPath() const { return m_rp; }
00134         BOOLEAN GetRejectDuplicates() const { return m_rd; }
00136         BOOLEAN IsSingleSrrPerSmsEnabled() const { return m_single_srr; }
00137
00139         CommandType GetCommandType() const { return m_ct; }
00141         SmsReferenceNumber GetMessageNumber() const { return m_mn; }
00142
00144         InformationElement::Identifier GetConcatenatedReferenceNoType() const;
00147         SmsPortNo GetDestinationApplicationPortAddress() const { return (m_destination_port_no); }
00150         SmsPortNo GetOriginatorApplicationPortAddress() const { return (m_originator_port_no); }
00151
00153         BOOLEAN ShallRequestStatusReport() const { DBG_OUT((0, L"\nObsolete: SmsContext::ShallRequestStatusReport(): Use SmsContext::GetRequestStatusReport() instead!!!\n")); return GetRequestStatusReport(); }
00155         BOOLEAN ShallRequestReplyPath() const { DBG_OUT((0, L"\nObsolete: SmsContext::ShallRequestReplyPath(): Use SmsContext::GetRequestReplyPath() instead!!!\n")); return GetRequestReplyPath(); }
00157         BOOLEAN ShallRejectDuplicates() const { DBG_OUT((0, L"\nObsolete: SmsContext::ShallRejectDuplicates(): Use SmsContext::GetRejectDuplicates() instead!!!\n")); return GetRejectDuplicates(); }
00158
00159     private:
00160         // common
00161         MessageTypeIndicator::Type m_mt; // TP-MTI: TP-Message-Type-Indicator - 3GPP 23.040 V5.1.0 [9.2.3.1]
00162         PhoneNumber  m_sca;              // service center address
00163         PhoneNumber  m_da;               // TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8])
00164         ProtocolIdentifier m_pid;        // TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9])
00165         BOOLEAN m_srr;                   // TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5])
00166
00167         SmsReferenceNumber m_mr;         // TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6])
00168
00169         // SMS submit type only
00170         DataCodingScheme m_dcs;          // TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10])
00171         ValidityPeriod m_vp;             // TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12])
00172         BOOLEAN  m_rp;                   // TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17])
00173         BOOLEAN m_rd;                    // TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25])
00174         BOOLEAN m_single_srr;
00175
00176         // SMS command type only
00177         CommandType m_ct;                // TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19])
00178         SmsReferenceNumber m_mn;         // TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18])
00179
00180         // UDH specific settings
00181         InformationElement::Identifier  m_conc_refno_type; // part of TP-UDH - type of concatenated reference number (8bit or 16bit)
00182         SmsPortNo m_destination_port_no; // part of TP-UDH - define application port ID
00183         SmsPortNo m_originator_port_no;  // part of TP-UDH - define application port ID
00184 };
00185
00187 #endif  // Asc_SmsContext_hpp
00188
00189
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsDispatcher.cpp File Reference

Asc/SmsDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "SmsDispatcher.hpp"
#include "SmsHandler.hpp"
#include "Apc/StackInterface.hpp"

Include dependency graph for SmsDispatcher.cpp:

Generated on Tue Jan 24 17:34:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsDispatcher.hpp File Reference

Asc/SmsDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgDispatcher.hpp>
#include <Adc/DataHandler.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include "SmsSendProtector.hpp"

Include dependency graph for SmsDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsDispatcher

Defines

#define | Asc_SmsDispatcher_hpp

Define Documentation

#define Asc_SmsDispatcher_hpp

Generated on Tue Jan 24 17:34:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsDispatcher.hpp Source File

Asc/SmsDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsDispatcher_hpp)
00009 #define Asc_SmsDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016 #include <Adc/DataHandler.hpp>          // include this header for MDH - check
00017 #include <Kernel/Os/SystemTimer.hpp>    // include this header for MDH - check
00018
00019 #include "SmsSendProtector.hpp"
00020
00021
00022 /*  ========================================================================
00023     SmsDispatcher
00024     ======================================================================== */
00026 class SmsDispatcher : public StackMsgDispatcher {
00027     typedef StackMsgDispatcher Base;
00028     public:
00030         SmsDispatcher();
00032         virtual ~SmsDispatcher();
00033
00035         void SetBlockingSend(BOOLEAN blocking_send) { m_blocking_send = blocking_send; }
00036
00038         static SmsSendProtector& GetProtector() { return (m_protector); }
00039
00040     protected:
00042         BOOLEAN OnMdhSmsNewMessageInd(const StackMsgArgument &arg);
00044         BOOLEAN OnMdhNewStatusReportInd(const StackMsgArgument &arg);
00046         BOOLEAN OnMdhSmsRefreshInd(const StackMsgArgument &arg);
00048         BOOLEAN OnMdhSmsStorageRefreshInd(const StackMsgArgument &arg);
00050         BOOLEAN OnMdhSmsUpdStatusRefreshInd(const StackMsgArgument &arg);
00052         BOOLEAN OnMdhSmsWaitingInd(const StackMsgArgument &arg);
00054         BOOLEAN OnSmsCapacityExceeded(const StackMsgArgument &arg);
00056         BOOLEAN OnSmsCapacityAvailable(const StackMsgArgument &arg);
00058         BOOLEAN OnSmsSendCnf(const StackMsgArgument &arg);
00060         BOOLEAN OnSmsSendRej(const StackMsgArgument &arg);
00062         BOOLEAN OnMdhSmsDeletionInd(const StackMsgArgument &arg);
00063
00064     private:
00065         static const StackMsgArgMap<SmsDispatcher> m_arg_map[];
00066         StackMsgArgMapContainer<SmsDispatcher> m_arg_map_container;
00067
00068         static SmsSendProtector m_protector;    // protector for multiple sender protection
00069
00070         BOOLEAN m_blocking_send;
00071
00072 };
00073
00075 #endif // Asc_SmsDispatcher_hpp
00076
00077
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsFactory.cpp File Reference

Asc/SmsFactory.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SmsFactory.hpp"
#include "SmsHandler.hpp"

Include dependency graph for SmsFactory.cpp:

Generated on Tue Jan 24 17:34:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsFactory.hpp File Reference

Asc/SmsFactory.hpp File Reference

#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/TimeSpan.hpp>
#include <Apc/BaseInformationElement.hpp>
#include <Apc/Sms.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Asc/SmsContext.hpp>
#include <Adc/SimPduHandler.hpp>

Include dependency graph for SmsFactory.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsFactory

Defines

#define | Asc_SmsFactory_hpp

Define Documentation

#define Asc_SmsFactory_hpp

Generated on Tue Jan 24 17:35:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsFactory.hpp Source File

Asc/SmsFactory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsFactory_hpp)
00009 #define Asc_SmsFactory_hpp
00012
00013 #include <Auxiliary/PhoneNumber.hpp>
00014 #include <Auxiliary/TimeSpan.hpp>
00015
00016 #include <Apc/BaseInformationElement.hpp>
00017 #include <Apc/Sms.hpp>
00018 #include <Apc/NetworkTypes.hpp>
00019 #include <Asc/SmsContext.hpp>
00020 #include <Adc/SimPduHandler.hpp>
00021
00022 /*  ========================================================================
00023     SmsFactory -
00024     ======================================================================== */
00026 class SmsFactory {
00027     public:
00028
00030         SmsFactory();
00032         ~SmsFactory();
00033
00035         BOOLEAN Init(const SmsContext &context);
00037         void Reset(BOOLEAN reallocate = TRUE);
00038
00039
00041         BOOLEAN Append(const BaseInformationElement &data_ptr);
00043         BOOLEAN Append(const WString &text);
00045         BOOLEAN Append(const UINT8 *data_ptr, INT len);
00047         BOOLEAN Append(const BlobObject &blob);
00048
00050         Sms::Result Assemble();
00051
00053         Sms::Result Store(const Sms::StorageType storage_type);
00054
00058         Sms::Result Store();
00059
00069 #if !defined(DOWNSTRIP_TO_GSM)
00070         Sms::Result Send(BOOLEAN wait_for_response = TRUE, GsmService service = CircuitSwitched);
00071 #else
00072         Sms::Result Send(BOOLEAN wait_for_response = TRUE);
00073 #endif
00074
00083         INT SetSendingResult(Sms::Result last_sending_result, Sms::Result &subsequent_sending_result, SmsReferenceNumber reference_number = 0xFF);
00084
00086         INT GetNoOfTpdus() const;
00087
00089         const Tpdu& GetTpdu(INT i = 0) const;
00090
00091
00092         // -------------------------------------------------------------------------------
00093         // ATTENTION: the remove of the following obsolete methods is planned in APOXI_2.1
00094         // -------------------------------------------------------------------------------
00101         INT SetSendingResult(Sms::Result result, const SmsReferenceNumber &reference_number = 0xFF);
00102
00103         // -------------------------------------------------------------------------------
00104         // ATTENTION: the remove of the following obsolete methods is planned in APOXI_1.4
00105         // -------------------------------------------------------------------------------
00107         SmsFactory(const PhoneNumber &service_centre_address, INT sms_profile_id);
00109         void Init(const PhoneNumber &service_centre_address = PhoneNumber(), INT sms_profile_id = 0);
00111         BOOLEAN InitSmsCommand(SmsReferenceNumber message_number,
00112                                const PhoneNumber &destination_address = PhoneNumber(),
00113                                const CommandType &command_type = CommandType(),
00114                                const ProtocolIdentifier &protocol_identifier = ProtocolIdentifier(),
00115                                BOOLEAN request_status_report = TRUE);
00117         BOOLEAN InitSmsSubmit(const PhoneNumber &destination_address = PhoneNumber(),
00118                               const ValidityPeriod &validity_period = ValidityPeriod(),
00119                               const ProtocolIdentifier &protocol_identifier = ProtocolIdentifier(),
00120                               BOOLEAN request_reply_path = TRUE,
00121                               BOOLEAN request_status_report = TRUE,
00122                               BOOLEAN reject_duplicates = TRUE,
00123                               const DataCodingScheme &data_coding_scheme = DataCodingScheme());
00124
00125
00126
00127     private:
00128         // defines, how the user-data is filled up (using Append method)
00129         enum AppendMode {
00130             BaseInformationElementOnly,     // user-data filled up by using BaseInformation elements only
00131             TextOnly,                       // text mode for writing user-data (SmsSubmit)
00132             DirectDataAccessOnly,           // direct user-data access (SmsCommand only)
00133             Undefined
00134         };
00135
00136         SmsContext m_context;
00137
00138         Tpdu m_active_tpdu;                 // used as base tpdu, holds whole shared header data.
00139         ElementList<Tpdu> m_tpdu_list;
00140         AppendMode m_append_mode;
00141
00142         WString m_text; // data storage for text-payload
00143         BlobObject m_data;  // data storage for binary payload
00144
00145         UINT16 m_conc_ref_no;
00146         BOOLEAN m_valid_conc_ref_no;
00147
00148         BOOLEAN m_is_assembled;
00149         BOOLEAN m_is_sending;
00150         INT m_no_of_tpdus_to_send;
00151         Tpdu *m_pending_tpdu;   // points to the actual (sent) tpdu in non-blocking sending mode
00152
00153         GsmService m_service;
00154
00155         // Resets the UserData of the active tpdu m_active_tpdu
00156         void ResetActiveTpduData();
00157
00158         // retrieve new concatenation reference number
00159         UINT16 RequestNewConcatenationReferenceNumber();
00160
00161         // trims the active tpdu (m_active_tpdu)
00162         INT TrimActiveTpdu();
00163
00164         // -------------------------------------------------------------------------------
00165         // ATTENTION: the remove of the following obsolete methods is planned in APOXI_1.4
00166         // -------------------------------------------------------------------------------
00167         INT m_sms_profile_id;                   // the remove of this member is planned in APOXI_1.4
00168         PhoneNumber m_service_center_address;
00169 };
00170
00172 #endif  // Asc_SmsFactory_hpp
00173
00174
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsHandler.cpp File Reference

Asc/SmsHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SmsHandler.hpp"
#include "SmsSendDispatcher.hpp"

Include dependency graph for SmsHandler.cpp:

Generated on Tue Jan 24 17:35:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsHandler.hpp File Reference

Asc/SmsHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/MdhTypes.hpp>
#include <Apc/Tpdu.hpp>
#include <Asc/BaseHandler.hpp>
#include <Asc/SmsDispatcher.hpp>

Include dependency graph for SmsHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsHandler

Defines

#define | Asc_SmsHandler_hpp

Define Documentation

#define Asc_SmsHandler_hpp

Generated on Tue Jan 24 17:35:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsHandler.hpp Source File

Asc/SmsHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsHandler_hpp)
00009 #define Asc_SmsHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Apc/MdhTypes.hpp>
00016 #include <Apc/Tpdu.hpp>
00017 #include <Asc/BaseHandler.hpp>
00018 #include <Asc/SmsDispatcher.hpp>
00019
00020 /*  ========================================================================
00021     SmsHandler
00022     ======================================================================== */
00024 class SmsHandler : public BaseHandler {
00025     typedef BaseHandler Base;
00026     public:
00027         enum { ID = SmsHandlerId };
00028
00030         SmsHandler();
00032         virtual ~SmsHandler();
00033
00035         virtual HandlerId GetHandlerId() const;
00036
00042 #if !defined(DOWNSTRIP_TO_GSM)
00043         Sms::Result SendSms(Tpdu &tpdu, BOOLEAN wait_for_response = TRUE, GsmService service = CircuitSwitched);
00044 #else
00045         Sms::Result SendSms(Tpdu &tpdu, BOOLEAN wait_for_response = TRUE);
00046 #endif
00047
00049         Sms::Result StoreSms(const Tpdu &tpdu, const Sms::StorageType storage_type) const;
00050
00054         Sms::Result StoreSms(const Tpdu &tpdu) const;
00055
00057         void SetSendingResult(Tpdu &tpdu, Sms::Result result, const SmsReferenceNumber &reference_number = 0xFF);
00059         BOOLEAN ChangePreferredStorageMedia(Sms::StorageType storagetype);
00060
00071         BOOLEAN EnableResendingSmsOverCs(UINT32 timer);
00072
00074         BOOLEAN SetMessageWaitIndicators(const MdhSetWaitIndicatorArray & wia);
00075
00081         BOOLEAN SetSmsMoreMessageType(const SmsMoreMessageType & type);
00082
00084         SmsMoreMessageType QuerySmsMoreMessageType();
00085
00086     private:
00087         SmsDispatcher m_sms_dispatcher; // main dispatcher for retrieving asynchronous messages
00088 };
00089
00091 #endif // Asc_SmsHandler_hpp
00092
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSendDispatcher.cpp File Reference

Asc/SmsSendDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SmsSendDispatcher.hpp"

Include dependency graph for SmsSendDispatcher.cpp:

Generated on Tue Jan 24 17:35:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSendDispatcher.hpp File Reference

Asc/SmsSendDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/Sms.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>

Include dependency graph for SmsSendDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsSendDispatcher

Defines

#define | Asc_SmsSendDispatcher_hpp

Define Documentation

#define Asc_SmsSendDispatcher_hpp

Generated on Tue Jan 24 17:35:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSendDispatcher.hpp Source File

Asc/SmsSendDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsSendDispatcher_hpp)
00009 #define Asc_SmsSendDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Apc/Sms.hpp>
00016
00017 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00018
00019 /*  ========================================================================
00020     SmsSendDispatcher
00021     ======================================================================== */
00023 class SmsSendDispatcher : public StackMsgActiveWaitDispatcher {
00024     typedef StackMsgActiveWaitDispatcher Base;
00025     public:
00027         SmsSendDispatcher();
00029         virtual ~SmsSendDispatcher();
00030
00032         const Sms::Result& GetResult() const { return (m_result); }
00034         BOOLEAN ShortMessageFailureExists() const { return (m_short_message_failure_exists); }
00036         const ShortMessageFailureCause& GetShortMessageFailureCause() const { return (m_short_message_failure_cause); }
00038         const SmsReferenceNumber& GetReferenceNumber() const { return (m_reference_number); }
00039
00040     protected:
00042         BOOLEAN OnSmsSendCnf(const StackMsgArgument &arg);
00044         BOOLEAN OnSmsSendRej(const StackMsgArgument &arg);
00045
00046     private:
00047         static const StackMsgArgMap<SmsSendDispatcher> m_arg_map[];
00048         StackMsgArgMapContainer<SmsSendDispatcher> m_arg_map_container;
00049
00050         Sms::Result m_result;
00051         BOOLEAN m_short_message_failure_exists;
00052         ShortMessageFailureCause m_short_message_failure_cause;
00053         SmsReferenceNumber m_reference_number;
00054 };
00055
00057 #endif  // Asc_SmsSendDispatcher_hpp
00058
00059
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSendProtector.cpp File Reference

Asc/SmsSendProtector.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SmsSendProtector.hpp"

Include dependency graph for SmsSendProtector.cpp:

Generated on Tue Jan 24 17:35:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSendProtector.hpp File Reference

Asc/SmsSendProtector.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_SmsSendProtector_hpp

Define Documentation

#define Asc_SmsSendProtector_hpp

Generated on Tue Jan 24 17:35:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSendProtector.hpp Source File

Asc/SmsSendProtector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsSendProtector_hpp)
00009 #define Asc_SmsSendProtector_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include <Kernel/Types.hpp>
00015
00016 class ExecutionContext;
00017
00018 /*  ========================================================================
00019     SmsSendProtector
00020     ======================================================================== */
00022 class SmsSendProtector
00023 {
00024     public:
00026         SmsSendProtector();
00027
00029         virtual ~SmsSendProtector();
00030
00032         BOOLEAN Lock();
00033
00035         BOOLEAN Unlock();
00036
00038         BOOLEAN IsAllowed() const;
00039
00040     private:
00041         ExecutionContext *m_pending_context;
00042 }; // class
00043
00044
00046 #endif // DOXYGEN_SHOULD_SKIP_THIS
00047 #endif // Asc_SmsSendProtector_hpp
00048
00049
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocket.cpp File Reference

Asc/SmsSocket.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SmsSocket.hpp"

Include dependency graph for SmsSocket.cpp:

Generated on Tue Jan 24 17:35:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocket.hpp File Reference

Asc/SmsSocket.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BlobObject.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Apc/InformationElement.hpp>
#include <Apc/Tpdu.hpp>
#include "PortHeaderInformation.hpp"

Include dependency graph for SmsSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsSocket
class | SmsSocket::PortTpdu

Defines

#define | Asc_SmsSocket_hpp

Define Documentation

#define Asc_SmsSocket_hpp

Generated on Tue Jan 24 17:35:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocket.hpp Source File

Asc/SmsSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsSocket_hpp)
00009 #define Asc_SmsSocket_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/BlobObject.hpp>
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/LinkedList.hpp>
00017 #include <Apc/InformationElement.hpp>
00018 #include <Apc/Tpdu.hpp>
00019
00020 #include "PortHeaderInformation.hpp"
00021
00022 class ExecutionContext;
00023 class SmsSocketListener;
00024 /*  ========================================================================
00025     SmsSocket
00026     ======================================================================== */
00028 class SmsSocket : public Linkable <SmsSocket> {
00029     friend class SmsSocketListener;
00030     public:
00032         SmsSocket(SmsPortNo sms_port_no = InvalidSmsPortNo);
00034         virtual ~SmsSocket();
00035
00040         BOOLEAN Init(SmsPortNo sms_port_no, BOOLEAN force = FALSE);
00041
00043         SmsPortNo GetPortNo() const { return (m_sms_port_no); }
00044
00047         ExecutionContext* GetExecutionContext() const { return (m_context); }
00048
00050         BOOLEAN IsActive() const { return (m_context != 0); }
00051
00056         BOOLEAN Read(BlobObject &blob, INT no_of_bytes_to_read = -1);
00057
00062         BOOLEAN Read(WString &wstr);
00063
00064
00065     private:
00066         // class for storing Tpdu data, incl. its PortHeaderInformation
00067         class PortTpdu : public Linkable<PortTpdu> {
00068             public:
00069                 PortTpdu(const Tpdu& tpdu) : m_tpdu(tpdu), m_phi(&m_tpdu) {}
00070                 const PortHeaderInformation& GetPortHeaderInformation() const { return (m_phi); }
00071                 Tpdu * GetTpdu() { return (&m_tpdu); }
00072
00073             private:
00074                 Tpdu m_tpdu;
00075                 PortHeaderInformation m_phi;
00076         };
00077
00078         SmsPortNo        m_sms_port_no;
00079
00080         SmsPortNo        m_last_sms_orig_port_no;
00081         PhoneNumber      m_last_oa_address;
00082         PhoneNumber      m_last_sca;
00083         DateTime         m_last_rev_datetime;
00084         DataCodingScheme m_last_dcs;
00085
00086         ExecutionContext *m_context;
00087         ExecutionContext *m_prev_context;
00088         BlobObject m_data;
00089         WString    m_wstr;
00090         LinkedList<PortTpdu> m_port_tpdu_list;
00091
00092         // looks for a port tpdu, which matches the given phi and the seq_no
00093         PortTpdu* FindPortTpdu(const PortHeaderInformation& phi, UINT8 seq_no) const;
00094
00095         // Stores the tpdu - data in the socket, and returns TRUE, if new data is available to read out
00096         BOOLEAN PushTpdu(const Tpdu &tpdu, BOOLEAN avoidnotification = FALSE);
00097
00098         /* Activates the well defined sms socket. The method fails, if it was not initialized, or port is already in use. */
00099         BOOLEAN Activate();
00100
00101         // Deactivates the sms socket
00102         BOOLEAN Deactivate();
00103
00104         //
00105         void ResetData();
00106
00107 };
00108
00110 #endif  // Asc_SmsSocket_hpp
00111
00112
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocketListener.cpp File Reference

Asc/SmsSocketListener.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SmsSocket.hpp"
#include "SmsSocketListener.hpp"
#include "SmsSocketSignalMapTableNode.hpp"

Include dependency graph for SmsSocketListener.cpp:

Generated on Tue Jan 24 17:36:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocketListener.hpp File Reference

Asc/SmsSocketListener.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Apc/InformationElement.hpp>
#include <Apc/SignalHandler/SignalMapTableEntry.hpp>
#include "SmsSocket.hpp"

Include dependency graph for SmsSocketListener.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsSocketListener
provides registration of SMS sockets to the system and manages all registered SMS sockets More...
struct | SmsSocketListener::ConfirmInfo
class | SmsSocketListener::Lock

Defines

#define | APOXI_SMSSOCKET_MAX_CACHED_TPDUS 12
#define | APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS 2
#define | Asc_SmsSocketListener_hpp

Define Documentation

#define Asc_SmsSocketListener_hpp

Generated on Tue Jan 24 17:36:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocketListener.hpp Source File

Asc/SmsSocketListener.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsSocketListener_hpp)
00009 #define Asc_SmsSocketListener_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/Os/MutexObtainer.hpp>
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/LinkedList.hpp>
00017
00018 #include <Apc/InformationElement.hpp>
00019 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>
00020
00021 #include "SmsSocket.hpp"
00022
00023 #if ! defined(APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS)
00024     #define APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS 2
00025 #endif
00026
00027 #if ! defined(APOXI_SMSSOCKET_MAX_CACHED_TPDUS)
00028     #define APOXI_SMSSOCKET_MAX_CACHED_TPDUS 12
00029 #endif
00030
00031
00032 class SmsSocketSignalMapTableNode;
00033 /*  ========================================================================
00034     SmsSocketListener
00035     ======================================================================== */
00037 class SmsSocketListener {
00038     enum {
00039         c_max_subscribed_contexts = APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS,
00040         c_max_cached_tpdus = APOXI_SMSSOCKET_MAX_CACHED_TPDUS,
00041         c_max_confirm_info = c_max_subscribed_contexts * c_max_cached_tpdus
00042     };
00043
00044     friend class SmsSocket;
00045     friend class SmsSocketSignalMapTableNode;
00046     public:
00047         // one time initialization method (called in init method of referring system - StackControl::OnPowerUp())
00048         static void Startup();
00049
00053         static BOOLEAN Register(SmsSocket *sms_socket);
00054
00057         static SmsSocket* GetSocket(SmsPortNo sms_port_no);
00058
00060         static BOOLEAN Unregister(SmsSocket *sms_socket);
00061
00063         static BOOLEAN IsInUse(SmsPortNo sms_port_no);
00064
00066         static BOOLEAN HasPorts(ExecutionContext *context = 0);
00067
00069         static BOOLEAN Subscribe(ExecutionContext *context);
00070
00072         static BOOLEAN Unsubscribe(ExecutionContext *context);
00073
00076         static BOOLEAN Confirm(ExecutionContext *context, SmsPortNo portno, BOOLEAN accept);
00077
00079         static BOOLEAN EmptyCache(SmsPortNo portno);
00080
00081         // dump debug info
00082         static void DumpTables();
00083
00084     private:
00085         struct ConfirmInfo {
00086             ExecutionContext* m_context;
00087             Tpdu *        m_tpdu;
00088             SmsPortNo     m_portno;
00089             BOOLEAN       m_confirmed;
00090             BOOLEAN       m_confirmed_state;
00091         };
00092
00093         class Lock : public MutexObtainer {
00094             public:
00095                 Lock() : MutexObtainer(&SmsSocketListener::m_mutex) { };
00096         };
00097         friend class Lock;
00098
00099         static BOOLEAN m_initialized;
00100         static Mutex m_mutex;
00101         static LinkedList<SmsSocket>   m_sms_socket_list;
00102         static ExecutionContext* m_subscribed_contexts[c_max_subscribed_contexts];
00103         static Tpdu *                  m_cached_tpdus[c_max_cached_tpdus];
00104         static ConfirmInfo             m_confirm_info[c_max_confirm_info];
00105
00106
00107         // Processes new incoming signal, stored socket info and sends back acknowledge to stack
00108         static void ProcessIncomingPortSms(const ProcessPtr &process_ptr);
00109
00110         /* Returns the next socket found for the given context, starting the search
00111             (in global list) with *sms_socket. Locking, if needed, must be done from calling instance. */
00112         static SmsSocket* SearchSocket(ExecutionContext *context, SmsSocket *sms_socket = 0);
00113
00114         /* Returns the next socket with the port number sms_port_no, starting the search
00115             (in global list) with *sms_socket. Normally there exists only one socket for one port number!
00116             Locking, if needed, must be done from calling instance. */
00117         static SmsSocket* SearchSocket(SmsPortNo sms_port_no, SmsSocket *sms_socket = 0);
00118
00119         // Checks if an context is subscribed
00120         static BOOLEAN IsSubscribed(ExecutionContext *context);
00121         // Checks if any context is subscribed
00122         static BOOLEAN HasSubscription();
00123
00124         // puts Tpdu into the cache
00125         static BOOLEAN PutIntoCache(Tpdu * tpdu);
00126         // remove Tpdu from cache
00127         static BOOLEAN RemoveFromCache(Tpdu * tpdu);
00128         // insert the confirmation information
00129         static BOOLEAN InsertConfirmInfo(ExecutionContext* context, Tpdu* tpdu, SmsPortNo smsportno);
00130         // checks if a tpdu with a certain portno can be deleted out of the cache, when
00131         // all contexts have confirmed and no context was interested
00132         static BOOLEAN CheckTpduDeletion(SmsPortNo portno);
00135         static BOOLEAN PushTpdus(SmsSocket * socket);
00136
00138         static void DeleteConfirmInfo(Tpdu * tpdu);
00139
00140
00141 };
00142
00144 #endif  // Asc_SmsSocketListener_hpp
00145
00146
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocketSignalMapTableNode.cpp File Reference

Asc/SmsSocketSignalMapTableNode.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SmsSocketListener.hpp"
#include "SmsSocketSignalMapTableNode.hpp"

Include dependency graph for SmsSocketSignalMapTableNode.cpp:

Generated on Tue Jan 24 17:36:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocketSignalMapTableNode.hpp File Reference

Asc/SmsSocketSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for SmsSocketSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsSocketSignalMapTableNode

Defines

#define | Asc_SmsSocketSignalMapTable_hpp

Define Documentation

#define Asc_SmsSocketSignalMapTable_hpp

Generated on Tue Jan 24 17:36:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SmsSocketSignalMapTableNode.hpp Source File

Asc/SmsSocketSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SmsSocketSignalMapTable_hpp)
00009 #define Asc_SmsSocketSignalMapTable_hpp
00012
00013 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00014
00015 /*  ======================================================================
00016     SmsSocketSignalMapTableNode
00017     ====================================================================== */
00018 class SmsSocketSignalMapTableNode : public SignalMapTableNode {
00019     public:
00020         static SmsSocketSignalMapTableNode* GetInstance();
00021
00022     private:
00023         static SmsSocketSignalMapTableNode *m_node;
00024         static const SignalMapTableEntry m_sms_socket_signal_map_table[];
00025
00026         SmsSocketSignalMapTableNode();
00027 };
00028
00030 #endif  // Asc_SmsSocketSignalMapTable_hpp
00031
00032
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsBaseHandler.cpp File Reference

Asc/SsBaseHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/AdcInterface.hpp>
#include <Asc/CallHandler.hpp>
#include <Asc/SsMainHandler.hpp>
#include <Asc/SupplementaryServiceWaitDispatcher.hpp>
#include <Asc/InputParserTranslator.hpp>
#include "SsBaseHandler.hpp"

Include dependency graph for SsBaseHandler.cpp:

Generated on Tue Jan 24 17:36:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsBaseHandler.hpp File Reference

Asc/SsBaseHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_SsBaseHandler_hpp

Define Documentation

#define Asc_SsBaseHandler_hpp

Generated on Tue Jan 24 17:36:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsBaseHandler.hpp Source File

Asc/SsBaseHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_SsBaseHandler_hpp)
00011 #define Asc_SsBaseHandler_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014 #include <Kernel/Types.hpp>
00015
00016 #include <Apc/SignalTypes.hpp>
00017 #include <Apc/SsErrorCode.hpp>
00018 #include <Apc/TaggedProblemCode.hpp>
00019 #include <Apc/SsStackMsgArgument.hpp>
00020
00021 #include <Asc/BaseHandler.hpp>
00022 #include <Asc/InputParser.hpp>
00023 #include <Asc/SsMessage.hpp>
00024
00033 class SsBaseHandler : public BaseHandler {
00036     typedef BaseHandler Base;
00037
00040     friend class SupplementaryServiceDispatcher;
00041     friend class SsMainHandler;
00042
00043 #ifdef TEST_SUPPLEMENTARY_SERVICES
00044     friend class CallWaitingHandlerTest;
00045 #endif
00046
00047  public:
00052     enum ReturnCode {
00054         OkNoMessage,
00056         OkMessageReady,
00058         OutOfMemory,
00060         TipdMismatch,
00062         OperationCodeMismatch,
00064         UnexpectedArgument,
00066         UnexpectedSelector,
00068         UnexpectedStatus,
00070         UnexpectedSsCode,
00072         UnexpectedOperationCode,
00074     IllegalUsedFlag,
00076         IllegalListSize,
00078         IllegalNotificationFlags,
00080         IllegalCallHoldIndicator,
00082         IllegalRdnSelector,
00084         IllegalEctCallstate,
00086         IllegalNotificationData,
00088         IllegalMptyIndicator,
00090         IllegalCallWaitIndicator,
00092         IllegalCugIndex,
00094         IllegalClirSuprRejectIndicator,
00096         AmbiguousData,
00098         PasswordMismatch,
00100         UssdResentFailed
00101     };
00102
00105     SsBaseHandler();
00106
00110     virtual ~SsBaseHandler();
00111
00117     virtual void RegisterTransaction(Tipd tipd);
00118
00119  protected:
00120
00125     Tipd m_tipd;
00126
00130     BOOLEAN m_message_ready;
00131
00136     SsMessage* m_current_message;
00137
00142     SsOperationCode m_op_code;
00143
00148     SsCode  m_ss_code;
00149
00154     ServiceGroup m_basic_service;
00155
00158     LineSelector m_line;
00159
00173     virtual ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument &argument) = 0;
00174
00181     SsMessage* GetMessage();
00182
00188     virtual ReturnCode EndTransaction(const Tipd tipd);
00189
00195     void Error(const Tipd tipd, const SsErrorCode &error_code);
00196
00202     void Error(const Tipd tipd, const MnCause &error_cause);
00203
00209     void Reject(const Tipd tipd, const TaggedProblemCode &tagged_problem_code);
00210
00217     void Reset();
00218
00223     void SetTipd(const Tipd tipd);
00224
00228     Tipd GetTipd() const;
00229
00236     BOOLEAN CheckTipd(const Tipd tipd) const;
00237
00246     BOOLEAN CheckOperationCode(const SsOperationCode ss_op_code, const Tipd tipd) const;
00247
00255     SsOperationCode GetOperationCode(const Tipd tipd) const;
00256
00264     void SetOperationCode(const SsOperationCode ss_op_code);
00265
00266     SsCode GetSsCode(const Tipd tipd) const;
00267     void SetSsCode(const SsCode ss_code);
00268
00269     ServiceGroup GetBasicService(const Tipd tipd) const;
00270     void SetBasicService(const ServiceGroup basic_service);
00271
00272     LineSelector GetSelectedLine(const Tipd tipd) const;
00273     void SetSelectedLine(const LineSelector line);
00274
00279     void SetMessage(SsMessage *msg);
00280
00285     void SetMessageReady();
00286
00298     SsApiRc SendRejectMsg(SsApiRc result, SsCode ss_code, ServiceGroup basic_service,
00299                   SsOperationCode ss_opcode, const WString& param1, const WString& param2, const WString& param3,
00300               CallErrorCause cause) const;
00301
00315     SsApiRc SendRequest(const WString& ss_ctrl_seq, BOOLEAN register_only, SsCode ss_code,
00316                                    SsOperationCode op_code, ServiceGroup basic_service, const WString& p1 = L"",
00317                                    const WString& p2 = L"", const WString& p3 = L"");
00318
00325     SsOperationCode ParseOpCode(const WString& ss_ctrl_seq);
00326
00327
00328 };
00329 #endif // DOXYGEN_SHOULD_SKIP_THIS
00330
00331 #endif // Asc_SsBaseHandler_hpp
00332
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsCcbsDispatcher.cpp File Reference

Asc/SsCcbsDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"
#include "SsCcbsDispatcher.hpp"

Include dependency graph for SsCcbsDispatcher.cpp:

Generated on Tue Jan 24 17:36:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsCcbsDispatcher.hpp File Reference

Asc/SsCcbsDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Message.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for SsCcbsDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsCcbsDispatcher

Defines

#define | Asc_SsCcbsDispatcher_hpp

Define Documentation

#define Asc_SsCcbsDispatcher_hpp

Generated on Tue Jan 24 17:37:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsCcbsDispatcher.hpp Source File

Asc/SsCcbsDispatcher.hpp

Go to the documentation of this file.
00001           /*    ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SsCcbsDispatcher_hpp)
00009 #define Asc_SsCcbsDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/Message.hpp>
00015
00016 #include <Asc/StackMsgDispatcher.hpp>
00017
00018 /*  ========================================================================
00019     SsCcbsDispatcher
00020     ======================================================================== */
00022 class SsCcbsDispatcher : public StackMsgDispatcher {
00023     typedef StackMsgDispatcher Base;
00024     public:
00026         SsCcbsDispatcher();
00028         virtual ~SsCcbsDispatcher();
00029
00030     protected:
00031
00032         BOOLEAN OnSsCcbsReCallInd(const StackMsgArgument &arg);
00033         BOOLEAN OnSsCcbsStatusInd(const StackMsgArgument &arg);
00034         BOOLEAN OnSsCcbsResultInd(const StackMsgArgument &arg);
00035
00036
00037     private:
00038         static const StackMsgArgMap<SsCcbsDispatcher> m_arg_map[];
00039         StackMsgArgMapContainer<SsCcbsDispatcher> m_arg_map_container;
00040 };
00041
00043 #endif // Asc_SsCcbsDispatcher_hpp
00044
00045
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsCcbsHandler.cpp File Reference

Asc/SsCcbsHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include "CallHandler.hpp"
#include "SsCcbsHandler.hpp"
#include "Asc/AdcInterface.hpp"

Include dependency graph for SsCcbsHandler.cpp:

Generated on Tue Jan 24 17:37:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsCcbsHandler.hpp File Reference

Asc/SsCcbsHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/InputParser.hpp>
#include <Asc/SsCcbsDispatcher.hpp>

Include dependency graph for SsCcbsHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsCcbsHandler

Defines

#define | Asc_SsCcbsHandler_hpp

Define Documentation

#define Asc_SsCcbsHandler_hpp

Generated on Tue Jan 24 17:37:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsCcbsHandler.hpp Source File

Asc/SsCcbsHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SsCcbsHandler_hpp)
00009 #define Asc_SsCcbsHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/InputParser.hpp>
00016 #include <Asc/SsCcbsDispatcher.hpp>
00017
00018 /*  ========================================================================
00019     SsCcbsHandler
00020     ======================================================================== */
00022 class SsCcbsHandler : public BaseHandler {
00023     typedef BaseHandler Base;
00024     public:
00025         enum { ID = SsCcbsHandlerId };
00026
00028         SsCcbsHandler();
00030         virtual ~SsCcbsHandler();
00031
00033         virtual HandlerId GetHandlerId() const;
00034
00035         SsApiRc SendCcbsInvoke() const;
00036
00037         SsApiRc SendCcbsReject() const;
00038
00039         SsApiRc SendCcbsReCallRequest() const;
00040
00041
00042     private:
00043         SsCcbsDispatcher m_ss_dispatcher; // main dispatcher for retrieving asynchronous messages
00044         BOOLEAN m_rejected;
00045 };
00046
00048 #endif // Asc_SsCcbsHandler_hpp
00049
00050
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsClHandler.cpp File Reference

Asc/SsClHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Apc/SignalTypes.hpp>
#include <Asc/InputParser.hpp>
#include <Asc/InputParserTranslator.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "SsClHandler.hpp"
#include "SsMainHandler.hpp"

Include dependency graph for SsClHandler.cpp:

Generated on Tue Jan 24 17:37:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsClHandler.hpp File Reference

Asc/SsClHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_SsClHandler_hpp

Define Documentation

#define Asc_SsClHandler_hpp

Generated on Tue Jan 24 17:37:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsClHandler.hpp Source File

Asc/SsClHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_SsClHandler_hpp)
00011 #define Asc_SsClHandler_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014 #include <Kernel/Types.hpp>
00015
00016 #include <Asc/SsBaseHandler.hpp>
00017
00028 class SsClHandler : public SsBaseHandler {
00031     typedef SsBaseHandler Base;
00032
00033 protected:
00052     SsApiRc Interrogate(const InputParser::SsCode mmi_ss_code, const WString& override_ss_seq = L"", BOOLEAN register_only = FALSE);
00053
00063     virtual ReturnCode CreateInterrogateResultMsg(const SsInterrogateIndArg &arg, SsMessage*& msg) const = 0;
00064
00081     virtual ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument &arg);
00082
00088     virtual BOOLEAN CheckSelector(const SsInterrogateIndArg &arg) const;
00089 };
00090 #endif // DOXYGEN_SHOULD_SKIP_THIS
00091
00092 #endif // Asc_SsClHandler_hpp
00093
00094
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsDispatcher.hpp File Reference

Asc/SsDispatcher.hpp File Reference

#include <Compat/SsDispatcher.hpp>

Include dependency graph for SsDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:37:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsDispatcher.hpp Source File

Asc/SsDispatcher.hpp

Go to the documentation of this file.
00001   /*    ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #pragma message ("Reference to old SsDispatcher")
00010
00011 // SsDispatcher is obsolete, use SupplementaryServiceDispatcher instead
00012 // Old SsDispatcher moved to CompatLib
00013 #include <Compat/SsDispatcher.hpp>
00014
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsHandler.hpp File Reference

Asc/SsHandler.hpp File Reference

#include <Compat/SsHandler.hpp>

Include dependency graph for SsHandler.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 17:37:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsHandler.hpp Source File

Asc/SsHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message ("Reference to old SsHandler")
00010
00011
00012 // SsHandler is obsolete, use the various Supplementary Service handlers now.
00013 // SsHandler has been moved to Compat lib.
00014 #include <Compat/SsHandler.hpp>
00015
00016
00017
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsMainHandler.cpp File Reference

Asc/SsMainHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/CallHandler.hpp>
#include <Asc/AdcInterface.hpp>
#include "SsMainHandler.hpp"
#include "SupplementaryServiceWaitDispatcher.hpp"
#include "MobileOriginatedUssdHandler.hpp"

Include dependency graph for SsMainHandler.cpp:

Generated on Tue Jan 24 17:37:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsMainHandler.hpp File Reference

Asc/SsMainHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_SsMainHandler_hpp

Define Documentation

#define Asc_SsMainHandler_hpp

Generated on Tue Jan 24 17:37:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsMainHandler.hpp Source File

Asc/SsMainHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_SsMainHandler_hpp)
00011 #define Asc_SsMainHandler_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014 #include <Kernel/Types.hpp>
00015
00016 #include <Apc/TaggedProblemCode.hpp>
00017
00018 #include <Asc/BaseHandler.hpp>
00019 #include <Asc/InputParser.hpp>
00020
00021 #include <Asc/SupplementaryServiceAction.hpp>
00022 #include <Asc/SupplementaryServiceDispatcher.hpp>
00023 #include <Asc/SupplementaryServiceWaitDispatcher.hpp>
00024 #include <Asc/SsBaseHandler.hpp>
00025
00038 class SsMainHandler : public BaseHandler {
00041     typedef BaseHandler Base;
00042  public:
00046     enum { ID = SsMainHandlerId };
00047
00053     SsMainHandler();
00055     virtual ~SsMainHandler();
00059     virtual HandlerId GetHandlerId() const;
00060
00066     SsBaseHandler* GetHandlerByTiPd(Tipd tipd) const;
00067
00089     SsApiRc BeginTransaction(const WString &ss_ctrl_sequence, SsBaseHandler *ss_handler, BOOLEAN register_only,
00090                              SsCode ss_code, SsOperationCode op_code, ServiceGroup basic_service,
00091                              const WString &p1 = L"", const WString &p2 = L"", const WString &p3 = L"");
00092
00110     SsApiRc ReSetupTransaction(Tipd tipd, SsBaseHandler* ss_handler, SsCode ss_code, SsOperationCode op_code,
00111                                ServiceGroup basic_service, const WString &p1 = L"", const WString &p2 = L"",
00112                                const WString &p3 = L"");
00113
00118     void CompleteTransactionSetup(const SsBeginAccArg& arg);
00119
00124     void AbortTransactionSetup(const SsFacilityRejArg& arg);
00125
00131     void CallControlTransactionSetup(const StackMsgArgument& arg);
00132
00145     SsApiRc EndTransaction(Tipd tipd);
00146
00156     SsApiRc RegisterTransaction(SsBaseHandler *ss_handler, Tipd tipd);
00157
00169     SsApiRc PostArgument(StackMsgArgument *arg, SsBaseHandler *ss_handler) const;
00170
00179     void ReleaseTransaction(Tipd tipd);
00180
00184     static BOOLEAN IsSsPending() { return m_ss_transaction_pending; }
00185
00189     static BOOLEAN Startup();
00190
00194     static Mutex* GetSsTransactionStateMutex() { return &m_ss_state_mutex; }
00195
00198     static BOOLEAN ObtainSsPending();
00199
00202     static void ClearSsPending();
00203
00204  private:
00205
00211     void StoreTipdHandler(Tipd tipd, SsBaseHandler* ss_handler);
00212
00217     void SetupCallControlTransaction(const WString& user_input);
00218
00221     void ResetData();
00222
00226     static void ResetStaticData();
00227
00230     Tipd m_tipd;
00231
00234     SsBaseHandler *m_ss_handler;
00235
00238     MnCause m_reject_cause;
00239
00242     static Mutex m_ss_state_mutex;
00243
00246     static BOOLEAN m_ss_transaction_pending;
00247
00250     SsBaseHandler *m_current_pending_handler;
00251
00254     SsCode m_pending_ss_code;
00255
00258     SsOperationCode m_pending_op_code;
00259
00262     ServiceGroup m_pending_basic_service;
00263
00266     WString m_pending_p1;
00267
00270     WString m_pending_p2;
00271
00274     WString m_pending_p3;
00275
00278     WString m_ss_control_sequence;
00279
00283     SupplementaryServiceDispatcher m_ss_dispatcher;
00284
00287     InputActionList m_action_list;
00288
00291     SsCallBarringActionImpl m_barring_action;
00292
00295     SsCallForwardingActionImpl m_forwarding_action;
00296
00299     SsCallWaitingActionImpl m_wait_action;
00300
00303     SsClipActionImpl m_clip_action;
00304
00307     SsClirActionImpl m_clir_action;
00308
00311     SsColpActionImpl m_colp_action;
00312
00315     SsColrActionImpl m_colr_action;
00316
00319     SsCnapActionImpl m_cnap_action;
00320
00323     SsEmlppActionImpl m_emlpp_action;
00324
00327     SsPasswordChangeActionImpl m_password_action;
00328
00331     SsUssdActionImpl m_ussd_action;
00332
00333
00334     friend SupplementaryServiceDispatcher;
00335
00336
00337 };
00338
00339 #endif // DOXYGEN_SHOULD_SKIP_THIS
00340
00341 #endif // Asc_SsMainHandler_hpp
00342
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsMessage.cpp File Reference

Asc/SsMessage.cpp File Reference

#include "Asc/PreComp.hpp"
#include "SsMessage.hpp"

Include dependency graph for SsMessage.cpp:

Generated on Tue Jan 24 17:37:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsMessage.hpp File Reference

Asc/SsMessage.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/LockTypes.hpp>
#include <Asc/Types.hpp>
#include <Asc/CallHdl.hpp>
#include <Asc/MsgArgs.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/TimeZone.hpp>

Include dependency graph for SsMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsMessage

Defines

#define | Asc_SsMessage_hpp

Define Documentation

#define Asc_SsMessage_hpp

Generated on Tue Jan 24 17:37:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsMessage.hpp Source File

Asc/SsMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\koglerm_snap_host\lnz_development\src\Apoxi\Asc\SsMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Asc_SsMessage_hpp)
00016 #define Asc_SsMessage_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Apc/LockTypes.hpp>
00022 #include <Asc/Types.hpp>
00023 #include <Asc/CallHdl.hpp>
00024 #include <Asc/MsgArgs.hpp>
00025 #include <Auxiliary/WString.hpp>
00026 #include <Auxiliary/TimeZone.hpp>
00027
00028
00029 /* ----------------------------------------------------------------------
00030     Classes
00031     ---------------------------------------------------------------------- */
00032
00033 /*  ======================================================================
00034     Class SsMessage
00035     ====================================================================== */
00036
00038 class SsMessage : public ContextMsg {
00039     public:
00040         SsMessage(ExecutionContext* context);
00041         virtual ~SsMessage();
00042
00043         virtual const MsgMetaData& GetMetaData() const;
00044         virtual Message* Clone() const;
00045
00046         enum  {
00047             ID = 18499
00048             };
00049
00050     private:
00051         static const MsgMetaData m_meta_data;
00052
00053     };
00054
00055 #endif // Asc_SsMessage_hpp
00056
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsWaitDispatcher.hpp File Reference

Asc/SsWaitDispatcher.hpp File Reference

#include <Compat/SsWaitDispatcher.hpp>

Include dependency graph for SsWaitDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:37:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SsWaitDispatcher.hpp Source File

Asc/SsWaitDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #pragma message ("Reference to old SsWaitDispatcher")
00009
00010 // SsWaitDispatcher is obsolete, use SupplementaryServiceWaitDispatcher instead
00011 // SsWaitDispatcher was moved to Compat lib
00012 #include <Compat/SsWaitDispatcher.hpp>
00013
00014
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackControl.cpp File Reference

Asc/StackControl.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackControl.hpp"
#include "PdpContextManager.hpp"
#include "SsMainHandler.hpp"
#include "Target/DataCallSignalMapTableNode.hpp"

Include dependency graph for StackControl.cpp:

Generated on Tue Jan 24 17:38:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackControl.hpp File Reference

Asc/StackControl.hpp File Reference

#include <Kernel/SubSystem.hpp>
#include <Asc/MainHandler.hpp>

Include dependency graph for StackControl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackControl

Defines

#define | Asc_StackControl_hpp

Define Documentation

#define Asc_StackControl_hpp

Generated on Tue Jan 24 17:38:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackControl.hpp Source File

Asc/StackControl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_StackControl_hpp)
00009 #define Asc_StackControl_hpp
00012
00013 #include <Kernel/SubSystem.hpp>
00014 #include <Asc/MainHandler.hpp>
00015
00016 class BaseHandler;
00017
00018 /*  ========================================================================
00019     StackControl
00020     ======================================================================== */
00022 class StackControl : public SubSystem {
00023     public:
00024         StackControl();
00025
00026         static StackControl* GetInstance() { return m_instance; }
00027
00028         virtual const WCHAR* GetName() const { return L"APOXI StackControl"; }
00029
00031         virtual BootSequenceState InvokeAt() const { return (SubSystemManager::c_run_level_1); }
00032
00034         virtual UINT8 GetPriority() const { return (100); }
00035
00037         virtual void OnPowerUp();
00038
00040         virtual void OnPowerDown();
00041
00043         static BOOLEAN Subscribe(HandlerId id);
00044
00048         static BaseHandler* GetHandler(HandlerId id);
00049
00051         static BOOLEAN Unsubscribe(HandlerId id);
00052
00053     private:
00054         static StackControl     *m_instance;
00055         static MainHandlerList  m_main_handler_list;
00056
00057         // returns the MainHandler of the active application context
00058         static MainHandler* GetActiveMainHandler();
00059 };
00060
00062 #endif  // Asc_StackControl_hpp
00063
00064
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackIndicationMsgTypes.cpp File Reference

Asc/StackIndicationMsgTypes.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackIndicationMsgTypes.hpp"

Include dependency graph for StackIndicationMsgTypes.cpp:

Generated on Tue Jan 24 17:38:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackIndicationMsgTypes.hpp File Reference

Asc/StackIndicationMsgTypes.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/Accessory.hpp>
#include <Apc/SignalTypes.hpp>
#include <Apc/LockTypes.hpp>
#include <Apc/AtcTypes.hpp>
#include <Asc/Types.hpp>
#include <Asc/CallHdl.hpp>
#include <Asc/MptyCallHdl.hpp>
#include <Asc/MsgArgs.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/TimeZone.hpp>
#include <Asc/SsMessage.hpp>
#include <Asc/InputParser.hpp>
#include <Auxiliary/Vector.hpp>
#include <Asc/SsBaseHandler.hpp>
#include <Asc/UssdHandler.hpp>
#include <Asc/CallBarringHandler.hpp>
#include <Asc/StackControl.hpp>
#include <Asc/PdpContextManager.hpp>
#include <Asc/PdpContext.hpp>
#include <Apc/SimTkStackMsgArgs.hpp>
#include <Apc/NetworkTypes.hpp>
#include <Apc/PlmnScanList.hpp>
#include <Apc/MiscStackMsgArgs.hpp>
#include <Apc/NetworkStackMsgArgs.hpp>
#include <Apc/SmsStackMsgArgs.hpp>
#include <Apc/CbsStackMsgArgs.hpp>
#include <Apc/CdStackMsgArgs.hpp>

Include dependency graph for StackIndicationMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AccessoryIndMsg
class | AlarmMsg
class | AocChargingStatusMsg
class | BandSelectionMsg
class | BandStatusMsg
class | BarringInfoReceivedMsg
class | CallAcceptMsg
class | CallBarredMsg
class | CallBarringActivatedMsg
class | CallBarringDeactivatedMsg
class | CallBarringPasswordChangedMsg
class | CallBarringStatusMsg
class | CallControlIndMsg
class | CallControlInfoMsg
class | CallDeflectionErrIndicationMsg
class | CallDeflectionIndMsg
class | CallDeflectionRejectedMsg
class | CallDisconnectedMsg
class | CallDisconnectingMsg
class | CalledPartyAlertingMsg
class | CallEventMsg
class | CallForwardingActivatedMsg
class | CallForwardingActiveMsg
class | CallForwardingDeactivatedMsg
class | CallForwardingErasedMsg
class | CallForwardingRegisteredMsg
class | CallForwardingStatusMsg
class | CallHeldMsg
class | CallHoldRejectedMsg
class | CallInfoMsg
class | CallIsWaitingMsg
class | CallNotifyMsg
class | CallOnHoldMsg
class | CallReleaseMsg
class | CallRetrievedMsg
class | CallSetupProgressMsg
class | CallWaitingActivatedMsg
class | CallWaitingDeactivatedMsg
class | CallWaitingStatusMsg
class | CbsLimitMsg
class | CbsNewDataMsg
class | CcbsRecallMsg
class | CcbsResultMsg
class | CcbsStatusMsg
class | CellInfoMsg
class | CfuStatusMsg
class | ChvChangedMsg
class | ClipStatusMsg
class | ClirNotSurpressedMsg
class | ClirStatusMsg
class | CnapInfoReceivedMsg
class | CnapStatusMsg
class | ColpStatusMsg
class | ColrStatusMsg
class | ConnectionStatusMsg
class | CtmInfoIndMsg
class | CugCallMsg
class | CurrentCallMeterMsg
class | CurrentChargeDataMsg
class | DhChannelChangeStatusResMsg
class | DhChannelCloseReqMsg
class | DhChannelDataAvailableResMsg
class | DhChannelOpenReqMsg
class | DhChannelReceiveReqMsg
class | DhChannelSendReqMsg
class | DiagnosticIndMsg
class | DtmfBufferCleanedMsg
class | DtmfRejectMsg
class | DtmfStartCnfMsg
class | DtmfStopCnfMsg
class | EctActiveMsg
class | EctAlertingMsg
class | EmlppRegisteredMsg
class | EmlppStatusMsg
class | EngineeringModeControlResponseMsg
class | EngineeringReportMsg
class | ExternalPdpContextInfoMsg
class | ForwardedCallIncomingMsg
class | ForwardingInfoReceivedMsg
class | GetPasswordMsg
class | GprsAttachStatusMsg
class | GprsStatusMsg
class | GsmBandStateMsg
class | HlrDataCorruptedMsg
class | HlrSsDataCorruptMsg
class | HomezoneMsg
class | IncomingCallForwardedMsg
class | InterrogationResultMsg
class | LsaIdentityMsg
class | MinuteTickMsg
class | MocSetupAcceptMsg
class | MocSetupRejectIndMsg
class | MptyCallReleaseMsg
class | MptyHoldRejectedMsg
class | MptyOnHoldMsg
class | MtcArrivedMsg
class | MtcReadyMsg
class | MultiPartyCallInvokedMsg
class | NetworkInformationMsg
class | NetworkSsErrorMsg
class | NetworkSsRejectedMsg
class | NwDiscStartIndMsg
class | OmMultiSlotIndMsg
class | OutgoingCallForwardedMsg
class | PasswordInquiryMsg
class | PasswordReceivedMsg
class | PasswordRejectedMsg
class | PbAlphaTagRequestMsg
class | PbEntryRequestMsg
class | PbSizeRequestMsg
class | PdpContextActivationStatusMsg
class | PlmnScanFinishedMsg
class | PowerModeIndMsg
class | RatChangeModeChangedMsg
class | RatStateMsg
class | RedialSetupMsg
class | RedialStartedMsg
class | RedialStatusMsg
class | RedialStoppedMsg
class | RedialSuccessMsg
class | RegistrationAllowedMsg
class | RegistrationChangeMsg
class | RegistrationSuccessMsg
class | RemotePartyActionMsg
class | SiChannelCloseInfoIndMsg
class | SiChannelOpenPromptReqMsg
class | SiChannelReceiveInfoIndMsg
class | SiChannelSendInfoIndMsg
class | SignalQualityLevelMsg
class | SignalStrengthLevelMsg
class | SimBrowserTermResMsg
class | SimCallSetupMsg
class | SimCallSetupRejectedMsg
class | SimDisplayTextMsg
class | SimEndTransactionMsg
class | SimErrorMsg
class | SimGetInkeyMsg
class | SimGetInputMsg
class | SimLaunchBrowserPromptReqMsg
class | SimLaunchBrowserReqMsg
class | SimLockStatusMsg
class | SimMenuItemSelectionFailedMsg
class | SimPlayToneMsg
class | SimRefreshMsg
class | SimRefreshResetMsg
class | SimResetConfirmationMsg
class | SimResetDoneMsg
class | SimSelectItemMsg
class | SimSetupIdleModeTextMsg
class | SimSetupMenuMsg
class | SimSmsSentMsg
class | SimSsSentMsg
class | SimStateChangedMsg
class | SimTkLanguageNotificationMsg
class | SimTkProfileGetCnfMsg
class | SimTkProfileSetCnfMsg
class | SimTkProfileSetRejMsg
class | SimTkRefreshStartMsg
class | SimTkRunAtCmdInfoIndMsg
class | SimTkSendDtmfEndIndMsg
class | SimTkSendDtmfIndMsg
class | SimTkSetupEventMsg
class | SmsControlIndMsg
class | SmsMessageWaitingChangedMsg
class | SmsNewMessageMsg
class | SmsNewSocketDataMsg
class | SmsNewStatusReportMsg
class | SmsPortDataRecvMsg
class | SmsPrefStorageMediaChangedMsg
class | SmsSendConfirmMsg
class | SmsSendRejectMsg
class | SmsSpaceAvailableMsg
class | SmsSpaceExceededMsg
class | SsControlIndMsg
class | SsDataReceivedMsg
class | SsEndMsg
class | SsErrIndicationMsg
class | SsErrorMsg
class | SsFacilityRejectedMsg
class | SsInfoMsg
class | SsNotificationMsg
class | SsRejectedMsg
class | SsRequestAcceptedMsg
class | SsRequestRejectedMsg
class | SsRequestSentMsg
class | SsSuccessMsg
class | StackSsRejectedMsg
class | TermRspCnfMsg
class | TimeZoneMsg
class | UssdAnswerMsg
class | UssDataReceivedMsg
class | UssdBeginMsg
class | UssdControlIndMsg
class | UssdDataMsg
class | UssdEndMsg
class | UssdIndicationMsg
class | UssdNotifyMsg
class | UssdRequestMsg
class | UssdRequestResentMsg
class | UssdResentMsg
class | UusErasedMsg
class | UusNotificationMsg
class | UusQueryRejectedMsg
class | UusRegisteredMsg
class | UusStatusMsg

Defines

#define | Asc_StackIndicationMsgTypes_hpp

Define Documentation

#define Asc_StackIndicationMsgTypes_hpp

Generated on Tue Jan 24 17:38:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackIndicationMsgTypes.hpp Source File

Asc/StackIndicationMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\grossau_latest_sv\lnz_apoxi\Apoxi\Asc\StackIndicationMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Asc_StackIndicationMsgTypes_hpp)
00016 #define Asc_StackIndicationMsgTypes_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/Accessory.hpp>
00021 #include <Apc/SignalTypes.hpp>
00022 #include <Apc/LockTypes.hpp>
00023 #include <Apc/AtcTypes.hpp>
00024 #include <Asc/Types.hpp>
00025 #include <Asc/CallHdl.hpp>
00026 #include <Asc/MptyCallHdl.hpp>
00027 #include <Asc/MsgArgs.hpp>
00028 #include <Auxiliary/WString.hpp>
00029 #include <Auxiliary/TimeZone.hpp>
00030 #include <Asc/SsMessage.hpp>
00031 #include <Asc/InputParser.hpp>
00032 #include <Auxiliary/Vector.hpp>
00033 #include <Asc/SsBaseHandler.hpp>
00034 #include <Asc/UssdHandler.hpp>
00035 #include <Asc/CallBarringHandler.hpp>
00036 #include <Asc/StackControl.hpp>
00037 #include <Asc/PdpContextManager.hpp>
00038 #include <Asc/PdpContext.hpp>
00039 #include <Apc/SimTkStackMsgArgs.hpp>
00040 #include <Apc/NetworkTypes.hpp>
00041 #include <Apc/PlmnScanList.hpp>
00042 #include <Apc/MiscStackMsgArgs.hpp>
00043 #include <Apc/NetworkStackMsgArgs.hpp>
00044 #include <Apc/SmsStackMsgArgs.hpp>
00045 #include <Apc/CbsStackMsgArgs.hpp>
00046 #include <Apc/CdStackMsgArgs.hpp>
00047
00048
00049 /* ----------------------------------------------------------------------
00050     Classes
00051     ---------------------------------------------------------------------- */
00052
00053 /*  ======================================================================
00054     Class SimStateChangedMsg
00055     ====================================================================== */
00056
00058 class SimStateChangedMsg : public Message {
00059     public:
00060         SimStateChangedMsg(const SimIndicator& sim_indicator);
00061         virtual ~SimStateChangedMsg();
00062
00063         virtual const MsgMetaData& GetMetaData() const;
00064         void SetSimIndicator(const SimIndicator& sim_indicator) { m_sim_indicator = sim_indicator; }
00065         const SimIndicator& GetSimIndicator() const { return m_sim_indicator; }
00066         virtual Message* Clone() const;
00067
00068         enum  {
00069             ID = 18700
00070             };
00071
00072     private:
00073         static const MsgMetaData m_meta_data;
00074         SimIndicator m_sim_indicator;
00075
00076     };
00077
00078
00079 /*  ======================================================================
00080     Class SimLockStatusMsg
00081     ====================================================================== */
00082
00084 class SimLockStatusMsg : public Message {
00085     public:
00086         SimLockStatusMsg(const SecLockResult& lock_result);
00087         virtual ~SimLockStatusMsg();
00088
00089         virtual const MsgMetaData& GetMetaData() const;
00090         void SetLockResult(const SecLockResult& lock_result) { m_lock_result = lock_result; }
00091         const SecLockResult& GetLockResult() const { return m_lock_result; }
00092         virtual Message* Clone() const;
00093
00094         enum  {
00095             ID = 18701
00096             };
00097
00098     private:
00099         static const MsgMetaData m_meta_data;
00100         SecLockResult m_lock_result;
00101
00102     };
00103
00104
00105 /*  ======================================================================
00106     Class GprsStatusMsg
00107     ====================================================================== */
00108
00110 class GprsStatusMsg : public Message {
00111     public:
00112         GprsStatusMsg(BOOLEAN attached);
00113         virtual ~GprsStatusMsg();
00114
00115         virtual const MsgMetaData& GetMetaData() const;
00116         void SetAttached(BOOLEAN attached) { m_attached = attached; }
00117         BOOLEAN IsAttached() const { return m_attached; }
00118         virtual Message* Clone() const;
00119
00120         enum  {
00121             ID = 18702
00122             };
00123
00124     private:
00125         static const MsgMetaData m_meta_data;
00126         BOOLEAN m_attached;
00127
00128     };
00129
00130
00131 /*  ======================================================================
00132     Class CallEventMsg
00133     ====================================================================== */
00134
00136 class CallEventMsg : public Message {
00137     public:
00138         CallEventMsg(const CallEvent& event);
00139         virtual ~CallEventMsg();
00140
00141         virtual const MsgMetaData& GetMetaData() const;
00142         void SetEvent(const CallEvent& event) { m_event = event; }
00143         const CallEvent& GetEvent() const { return m_event; }
00144         virtual Message* Clone() const;
00145
00146         enum  {
00147             ID = 18703
00148             };
00149
00150     private:
00151         static const MsgMetaData m_meta_data;
00152         CallEvent m_event;
00153
00154     };
00155
00156
00157 /*  ======================================================================
00158     Class CallControlIndMsg
00159     ====================================================================== */
00160
00162 class CallControlIndMsg : public Message {
00163     public:
00164         CallControlIndMsg(const CallControlSetupIndArg& arg);
00165         virtual ~CallControlIndMsg();
00166
00167         virtual const MsgMetaData& GetMetaData() const;
00168         void SetArg(const CallControlSetupIndArg& arg) { m_arg = arg; }
00169         const CallControlSetupIndArg& GetArg() const { return m_arg; }
00170         virtual Message* Clone() const;
00171
00172         enum  {
00173             ID = 18704
00174             };
00175
00176     private:
00177         static const MsgMetaData m_meta_data;
00178         CallControlSetupIndArg m_arg;
00179
00180     };
00181
00182
00183 /*  ======================================================================
00184     Class SsControlIndMsg
00185     ====================================================================== */
00186
00188 class SsControlIndMsg : public Message {
00189     public:
00190         SsControlIndMsg(const CallControlSsIndArg& arg);
00191         virtual ~SsControlIndMsg();
00192
00193         virtual const MsgMetaData& GetMetaData() const;
00194         void SetArg(const CallControlSsIndArg& arg) { m_arg = arg; }
00195         const CallControlSsIndArg& GetArg() const { return m_arg; }
00196         virtual Message* Clone() const;
00197
00198         enum  {
00199             ID = 18705
00200             };
00201
00202     private:
00203         static const MsgMetaData m_meta_data;
00204         CallControlSsIndArg m_arg;
00205
00206     };
00207
00208
00209 /*  ======================================================================
00210     Class UssdControlIndMsg
00211     ====================================================================== */
00212
00214 class UssdControlIndMsg : public Message {
00215     public:
00216         UssdControlIndMsg(const CallControlUssdIndArg& arg);
00217         virtual ~UssdControlIndMsg();
00218
00219         virtual const MsgMetaData& GetMetaData() const;
00220         void SetArg(const CallControlUssdIndArg& arg) { m_arg = arg; }
00221         const CallControlUssdIndArg& GetArg() const { return m_arg; }
00222         virtual Message* Clone() const;
00223
00224         enum  {
00225             ID = 18706
00226             };
00227
00228     private:
00229         static const MsgMetaData m_meta_data;
00230         CallControlUssdIndArg m_arg;
00231
00232     };
00233
00234
00235 /*  ======================================================================
00236     Class SmsControlIndMsg
00237     ====================================================================== */
00238
00240 class SmsControlIndMsg : public Message {
00241     public:
00242         SmsControlIndMsg(const SmsControlIndArg& arg);
00243         virtual ~SmsControlIndMsg();
00244
00245         virtual const MsgMetaData& GetMetaData() const;
00246         void SetArg(const SmsControlIndArg& arg) { m_arg = arg; }
00247         const SmsControlIndArg& GetArg() const { return m_arg; }
00248         virtual Message* Clone() const;
00249
00250         enum  {
00251             ID = 18707
00252             };
00253
00254     private:
00255         static const MsgMetaData m_meta_data;
00256         SmsControlIndArg m_arg;
00257
00258     };
00259
00260
00261 /*  ======================================================================
00262     Class ChvChangedMsg
00263     ====================================================================== */
00264
00266 class ChvChangedMsg : public Message {
00267     public:
00268         ChvChangedMsg(const ChvAction& chv_action, const ChvNo& chvno, const ChvStatus& status);
00269         virtual ~ChvChangedMsg();
00270
00271         virtual const MsgMetaData& GetMetaData() const;
00272         void SetChvAction(const ChvAction& chv_action) { m_chv_action = chv_action; }
00273         const ChvAction& GetChvAction() const { return m_chv_action; }
00274         void SetChvno(const ChvNo& chvno) { m_chvno = chvno; }
00275         const ChvNo& GetChvno() const { return m_chvno; }
00276         void SetStatus(const ChvStatus& status) { m_status = status; }
00277         const ChvStatus& GetStatus() const { return m_status; }
00278         virtual Message* Clone() const;
00279
00280         enum  {
00281             ID = 18708
00282             };
00283
00284     private:
00285         static const MsgMetaData m_meta_data;
00286         ChvAction m_chv_action;
00287         ChvNo m_chvno;
00288         ChvStatus m_status;
00289
00290     };
00291
00292
00293 /*  ======================================================================
00294     Class PdpContextActivationStatusMsg
00295     ====================================================================== */
00296
00298 class PdpContextActivationStatusMsg : public Message {
00299     public:
00300         PdpContextActivationStatusMsg(INT contextId, const PdpContext::ActivationStatus& activationStatus);
00301         virtual ~PdpContextActivationStatusMsg();
00302
00303         virtual const MsgMetaData& GetMetaData() const;
00304         void SetContextId(INT contextId) { m_contextId = contextId; }
00305         INT GetContextId() const { return m_contextId; }
00306         void SetActivationStatus(const PdpContext::ActivationStatus& activationStatus) { m_activationStatus = activationStatus; }
00307         const PdpContext::ActivationStatus& GetActivationStatus() const { return m_activationStatus; }
00308         virtual Message* Clone() const;
00309
00310         enum  {
00311             ID = 18709
00312             };
00313
00314     private:
00315         static const MsgMetaData m_meta_data;
00316         INT m_contextId;
00317         PdpContext::ActivationStatus m_activationStatus;
00318
00319     };
00320
00321
00322 /*  ======================================================================
00323     Class GprsAttachStatusMsg
00324     ====================================================================== */
00325
00327 class GprsAttachStatusMsg : public Message {
00328     public:
00329         GprsAttachStatusMsg(const PdpContextManager::AttachStatus& attachStatus);
00330         virtual ~GprsAttachStatusMsg();
00331
00332         virtual const MsgMetaData& GetMetaData() const;
00333         void SetAttachStatus(const PdpContextManager::AttachStatus& attachStatus) { m_attachStatus = attachStatus; }
00334         const PdpContextManager::AttachStatus& GetAttachStatus() const { return m_attachStatus; }
00335         virtual Message* Clone() const;
00336
00337         enum  {
00338             ID = 18710
00339             };
00340
00341     private:
00342         static const MsgMetaData m_meta_data;
00343         PdpContextManager::AttachStatus m_attachStatus;
00344
00345     };
00346
00347
00348 /*  ======================================================================
00349     Class ExternalPdpContextInfoMsg
00350     ====================================================================== */
00351
00353 class ExternalPdpContextInfoMsg : public Message {
00354     public:
00355         ExternalPdpContextInfoMsg(const PdpContext::Id& contextId, const PdpContextManager::ExternalContextState& contextState);
00356         virtual ~ExternalPdpContextInfoMsg();
00357
00358         virtual const MsgMetaData& GetMetaData() const;
00359         const PdpContext::Id& GetContextId() const { return m_contextId; }
00360         const PdpContextManager::ExternalContextState& GetContextState() const { return m_contextState; }
00361         virtual Message* Clone() const;
00362
00363         enum  {
00364             ID = 18711
00365             };
00366
00367     private:
00368         static const MsgMetaData m_meta_data;
00369         PdpContext::Id m_contextId;
00370         PdpContextManager::ExternalContextState m_contextState;
00371
00372     };
00373
00374
00375 /*  ======================================================================
00376     Class CallAcceptMsg
00377     ====================================================================== */
00378
00380 class CallAcceptMsg : public Message {
00381     public:
00382         CallAcceptMsg(const CallHdl& call_hdl);
00383         virtual ~CallAcceptMsg();
00384
00385         virtual const MsgMetaData& GetMetaData() const;
00386         const CallHdl& GetCallHdl() const { return m_call_hdl; }
00387         virtual Message* Clone() const;
00388
00389         enum  {
00390             ID = 18712
00391             };
00392
00393     private:
00394         static const MsgMetaData m_meta_data;
00395         CallHdl m_call_hdl;
00396
00397     };
00398
00399
00400 /*  ======================================================================
00401     Class CallReleaseMsg
00402     ====================================================================== */
00403
00405 class CallReleaseMsg : public Message {
00406     public:
00407         CallReleaseMsg(const CallHdl& call_hdl);
00408         virtual ~CallReleaseMsg();
00409
00410         virtual const MsgMetaData& GetMetaData() const;
00411         const CallHdl& GetCallHdl() const { return m_call_hdl; }
00412         virtual Message* Clone() const;
00413
00414         enum  {
00415             ID = 18713
00416             };
00417
00418     private:
00419         static const MsgMetaData m_meta_data;
00420         CallHdl m_call_hdl;
00421
00422     };
00423
00424
00425 /*  ======================================================================
00426     Class MptyCallReleaseMsg
00427     ====================================================================== */
00428
00430 class MptyCallReleaseMsg : public Message {
00431     public:
00432         MptyCallReleaseMsg(const MptyCallHdl& call_hdl);
00433         virtual ~MptyCallReleaseMsg();
00434
00435         virtual const MsgMetaData& GetMetaData() const;
00436         const MptyCallHdl& GetCallHdl() const { return m_call_hdl; }
00437         virtual Message* Clone() const;
00438
00439         enum  {
00440             ID = 18714
00441             };
00442
00443     private:
00444         static const MsgMetaData m_meta_data;
00445         MptyCallHdl m_call_hdl;
00446
00447     };
00448
00449
00450 /*  ======================================================================
00451     Class CfuStatusMsg
00452     ====================================================================== */
00453
00455 class CfuStatusMsg : public Message {
00456     public:
00457         CfuStatusMsg(const CfuServiceArray& cfu_service_array);
00458         virtual ~CfuStatusMsg();
00459
00460         virtual const MsgMetaData& GetMetaData() const;
00461         const CfuServiceArray& GetCfuServiceArray() const { return m_cfu_service_array; }
00462         virtual Message* Clone() const;
00463
00464         enum  {
00465             ID = 18715
00466             };
00467
00468     private:
00469         static const MsgMetaData m_meta_data;
00470         CfuServiceArray m_cfu_service_array;
00471
00472     };
00473
00474
00475 /*  ======================================================================
00476     Class SimErrorMsg
00477     ====================================================================== */
00478
00480 class SimErrorMsg : public Message {
00481     public:
00482         SimErrorMsg(const SimErrorCode& error_code);
00483         virtual ~SimErrorMsg();
00484
00485         virtual const MsgMetaData& GetMetaData() const;
00486         void SetErrorCode(const SimErrorCode& error_code) { m_error_code = error_code; }
00487         const SimErrorCode& GetErrorCode() const { return m_error_code; }
00488         virtual Message* Clone() const;
00489
00490         enum  {
00491             ID = 18716
00492             };
00493
00494     private:
00495         static const MsgMetaData m_meta_data;
00496         SimErrorCode m_error_code;
00497
00498     };
00499
00500
00501 /*  ======================================================================
00502     Class NetworkInformationMsg
00503     ====================================================================== */
00504
00506 class NetworkInformationMsg : public Message {
00507     public:
00508         NetworkInformationMsg(const WString& network_name_long, const WString& network_name_short, BOOLEAN network_name_long_add_ci, BOOLEAN network_name_short_add_ci);
00509         virtual ~NetworkInformationMsg();
00510
00511         virtual const MsgMetaData& GetMetaData() const;
00512         void SetNetworkNameLong(const WString& network_name_long) { m_network_name_long = network_name_long; }
00513         const WString& GetNetworkNameLong() const { return m_network_name_long; }
00514         void SetNetworkNameShort(const WString& network_name_short) { m_network_name_short = network_name_short; }
00515         const WString& GetNetworkNameShort() const { return m_network_name_short; }
00516         void SetNetworkNameLongAddCi(BOOLEAN network_name_long_add_ci) { m_network_name_long_add_ci = network_name_long_add_ci; }
00517         BOOLEAN IsNetworkNameLongAddCi() const { return m_network_name_long_add_ci; }
00518         void SetNetworkNameShortAddCi(BOOLEAN network_name_short_add_ci) { m_network_name_short_add_ci = network_name_short_add_ci; }
00519         BOOLEAN IsNetworkNameShortAddCi() const { return m_network_name_short_add_ci; }
00520         virtual Message* Clone() const;
00521
00522         enum  {
00523             ID = 18601
00524             };
00525
00526     private:
00527         static const MsgMetaData m_meta_data;
00528         WString m_network_name_long;
00529         WString m_network_name_short;
00530         BOOLEAN m_network_name_long_add_ci;
00531         BOOLEAN m_network_name_short_add_ci;
00532
00533     };
00534
00535
00536 /*  ======================================================================
00537     Class TimeZoneMsg
00538     ====================================================================== */
00539
00541 class TimeZoneMsg : public Message {
00542     public:
00543         TimeZoneMsg(const DateTime& datetime);
00544         virtual ~TimeZoneMsg();
00545
00546         virtual const MsgMetaData& GetMetaData() const;
00547         void SetDatetime(const DateTime& datetime) { m_datetime = datetime; }
00548         const DateTime& GetDatetime() const { return m_datetime; }
00549         virtual Message* Clone() const;
00550
00551         enum  {
00552             ID = 18602
00553             };
00554
00555     private:
00556         static const MsgMetaData m_meta_data;
00557         DateTime m_datetime;
00558
00559     };
00560
00561
00562 /*  ======================================================================
00563     Class LsaIdentityMsg
00564     ====================================================================== */
00565
00567 class LsaIdentityMsg : public Message {
00568     public:
00569         LsaIdentityMsg(BOOLEAN lsa_identifier_present, const LsaIdentifier& lsa_identifier);
00570         virtual ~LsaIdentityMsg();
00571
00572         virtual const MsgMetaData& GetMetaData() const;
00573         void SetLsaIdentifierPresent(BOOLEAN lsa_identifier_present) { m_lsa_identifier_present = lsa_identifier_present; }
00574         BOOLEAN IsLsaIdentifierPresent() const { return m_lsa_identifier_present; }
00575         void SetLsaIdentifier(const LsaIdentifier& lsa_identifier) { m_lsa_identifier = lsa_identifier; }
00576         const LsaIdentifier& GetLsaIdentifier() const { return m_lsa_identifier; }
00577         virtual Message* Clone() const;
00578
00579         enum  {
00580             ID = 18609
00581             };
00582
00583     private:
00584         static const MsgMetaData m_meta_data;
00585         BOOLEAN m_lsa_identifier_present;
00586         LsaIdentifier m_lsa_identifier;
00587
00588     };
00589
00590
00591 /*  ======================================================================
00592     Class SiChannelOpenPromptReqMsg
00593     ====================================================================== */
00594
00596 class SiChannelOpenPromptReqMsg : public Message {
00597     public:
00598         SiChannelOpenPromptReqMsg(const SiChannelOpenPromptReqArg& arg);
00599         virtual ~SiChannelOpenPromptReqMsg();
00600
00601         virtual const MsgMetaData& GetMetaData() const;
00602         void SetArg(const SiChannelOpenPromptReqArg& arg) { m_arg = arg; }
00603         const SiChannelOpenPromptReqArg& GetArg() const { return m_arg; }
00604         virtual Message* Clone() const;
00605
00606         enum  {
00607             ID = 18335
00608             };
00609
00610     private:
00611         static const MsgMetaData m_meta_data;
00612         SiChannelOpenPromptReqArg m_arg;
00613
00614     };
00615
00616
00617 /*  ======================================================================
00618     Class SiChannelCloseInfoIndMsg
00619     ====================================================================== */
00620
00622 class SiChannelCloseInfoIndMsg : public Message {
00623     public:
00624         SiChannelCloseInfoIndMsg(const SiChannelCloseInfoIndArg& arg);
00625         virtual ~SiChannelCloseInfoIndMsg();
00626
00627         virtual const MsgMetaData& GetMetaData() const;
00628         void SetArg(const SiChannelCloseInfoIndArg& arg) { m_arg = arg; }
00629         const SiChannelCloseInfoIndArg& GetArg() const { return m_arg; }
00630         virtual Message* Clone() const;
00631
00632         enum  {
00633             ID = 18336
00634             };
00635
00636     private:
00637         static const MsgMetaData m_meta_data;
00638         SiChannelCloseInfoIndArg m_arg;
00639
00640     };
00641
00642
00643 /*  ======================================================================
00644     Class SiChannelSendInfoIndMsg
00645     ====================================================================== */
00646
00648 class SiChannelSendInfoIndMsg : public Message {
00649     public:
00650         SiChannelSendInfoIndMsg(const SiChannelSendInfoIndArg& arg);
00651         virtual ~SiChannelSendInfoIndMsg();
00652
00653         virtual const MsgMetaData& GetMetaData() const;
00654         void SetArg(const SiChannelSendInfoIndArg& arg) { m_arg = arg; }
00655         const SiChannelSendInfoIndArg& GetArg() const { return m_arg; }
00656         virtual Message* Clone() const;
00657
00658         enum  {
00659             ID = 18337
00660             };
00661
00662     private:
00663         static const MsgMetaData m_meta_data;
00664         SiChannelSendInfoIndArg m_arg;
00665
00666     };
00667
00668
00669 /*  ======================================================================
00670     Class SiChannelReceiveInfoIndMsg
00671     ====================================================================== */
00672
00674 class SiChannelReceiveInfoIndMsg : public Message {
00675     public:
00676         SiChannelReceiveInfoIndMsg(const SiChannelReceiveInfoIndArg& arg);
00677         virtual ~SiChannelReceiveInfoIndMsg();
00678
00679         virtual const MsgMetaData& GetMetaData() const;
00680         void SetArg(const SiChannelReceiveInfoIndArg& arg) { m_arg = arg; }
00681         const SiChannelReceiveInfoIndArg& GetArg() const { return m_arg; }
00682         virtual Message* Clone() const;
00683
00684         enum  {
00685             ID = 18338
00686             };
00687
00688     private:
00689         static const MsgMetaData m_meta_data;
00690         SiChannelReceiveInfoIndArg m_arg;
00691
00692     };
00693
00694
00695 #ifdef APOXI_COMPAT_2_2_0
00696
00697
00698 /*  ======================================================================
00699     Class BatteryChargingMsg
00700     ====================================================================== */
00701
00703 class BatteryChargingMsg : public Message {
00704     public:
00705         BatteryChargingMsg();
00706         virtual ~BatteryChargingMsg();
00707
00708         virtual const MsgMetaData& GetMetaData() const;
00709         virtual Message* Clone() const;
00710
00711         enum  {
00712             ID = 18011
00713             };
00714
00715     private:
00716         static const MsgMetaData m_meta_data;
00717
00718     };
00719
00720 #endif //APOXI_COMPAT_2_2_0
00721
00722
00723 #ifdef APOXI_COMPAT_2_2_0
00724
00725
00726 /*  ======================================================================
00727     Class BatteryLowMsg
00728     ====================================================================== */
00729
00731 class BatteryLowMsg : public Message {
00732     public:
00733         BatteryLowMsg();
00734         virtual ~BatteryLowMsg();
00735
00736         virtual const MsgMetaData& GetMetaData() const;
00737         virtual Message* Clone() const;
00738
00739         enum  {
00740             ID = 18012
00741             };
00742
00743     private:
00744         static const MsgMetaData m_meta_data;
00745
00746     };
00747
00748 #endif //APOXI_COMPAT_2_2_0
00749
00750
00751 #ifdef APOXI_COMPAT_2_2_0
00752
00753
00754 /*  ======================================================================
00755     Class BatteryEmptyMsg
00756     ====================================================================== */
00757
00759 class BatteryEmptyMsg : public Message {
00760     public:
00761         BatteryEmptyMsg();
00762         virtual ~BatteryEmptyMsg();
00763
00764         virtual const MsgMetaData& GetMetaData() const;
00765         virtual Message* Clone() const;
00766
00767         enum  {
00768             ID = 18013
00769             };
00770
00771     private:
00772         static const MsgMetaData m_meta_data;
00773
00774     };
00775
00776 #endif //APOXI_COMPAT_2_2_0
00777
00778
00779 #ifdef APOXI_COMPAT_2_2_0
00780
00781
00782 /*  ======================================================================
00783     Class BatteryStopChargingMsg
00784     ====================================================================== */
00785
00787 class BatteryStopChargingMsg : public Message {
00788     public:
00789         BatteryStopChargingMsg(const ChargeEndReason& reason);
00790         virtual ~BatteryStopChargingMsg();
00791
00792         virtual const MsgMetaData& GetMetaData() const;
00793         void SetReason(const ChargeEndReason& reason) { m_reason = reason; }
00794         const ChargeEndReason& GetReason() const { return m_reason; }
00795         virtual Message* Clone() const;
00796
00797         enum  {
00798             ID = 18014
00799             };
00800
00801     private:
00802         static const MsgMetaData m_meta_data;
00803         ChargeEndReason m_reason;
00804
00805     };
00806
00807 #endif //APOXI_COMPAT_2_2_0
00808
00809
00810 #ifdef APOXI_COMPAT_2_2_0
00811
00812
00813 /*  ======================================================================
00814     Class BatteryChargerRemovedMsg
00815     ====================================================================== */
00816
00818 class BatteryChargerRemovedMsg : public Message {
00819     public:
00820         BatteryChargerRemovedMsg();
00821         virtual ~BatteryChargerRemovedMsg();
00822
00823         virtual const MsgMetaData& GetMetaData() const;
00824         virtual Message* Clone() const;
00825
00826         enum  {
00827             ID = 18015
00828             };
00829
00830     private:
00831         static const MsgMetaData m_meta_data;
00832
00833     };
00834
00835 #endif //APOXI_COMPAT_2_2_0
00836
00837
00838 #ifdef APOXI_COMPAT_2_2_0
00839
00840
00841 /*  ======================================================================
00842     Class BatteryIdErrorMsg
00843     ====================================================================== */
00844
00846 class BatteryIdErrorMsg : public Message {
00847     public:
00848         BatteryIdErrorMsg();
00849         virtual ~BatteryIdErrorMsg();
00850
00851         virtual const MsgMetaData& GetMetaData() const;
00852         virtual Message* Clone() const;
00853
00854         enum  {
00855             ID = 18016
00856             };
00857
00858     private:
00859         static const MsgMetaData m_meta_data;
00860
00861     };
00862
00863 #endif //APOXI_COMPAT_2_2_0
00864
00865
00866 #ifdef APOXI_COMPAT_2_2_0
00867
00868
00869 /*  ======================================================================
00870     Class BatteryChargingPausedMsg
00871     ====================================================================== */
00872
00874 class BatteryChargingPausedMsg : public Message {
00875     public:
00876         BatteryChargingPausedMsg();
00877         virtual ~BatteryChargingPausedMsg();
00878
00879         virtual const MsgMetaData& GetMetaData() const;
00880         virtual Message* Clone() const;
00881
00882         enum  {
00883             ID = 18017
00884             };
00885
00886     private:
00887         static const MsgMetaData m_meta_data;
00888
00889     };
00890
00891 #endif //APOXI_COMPAT_2_2_0
00892
00893
00894 #ifdef APOXI_COMPAT_2_2_0
00895
00896
00897 /*  ======================================================================
00898     Class BatteryChargingResumedMsg
00899     ====================================================================== */
00900
00902 class BatteryChargingResumedMsg : public Message {
00903     public:
00904         BatteryChargingResumedMsg();
00905         virtual ~BatteryChargingResumedMsg();
00906
00907         virtual const MsgMetaData& GetMetaData() const;
00908         virtual Message* Clone() const;
00909
00910         enum  {
00911             ID = 18018
00912             };
00913
00914     private:
00915         static const MsgMetaData m_meta_data;
00916
00917     };
00918
00919 #endif //APOXI_COMPAT_2_2_0
00920
00921
00922 /*  ======================================================================
00923     Class AlarmMsg
00924     ====================================================================== */
00925
00927 class AlarmMsg : public Message {
00928     public:
00929         AlarmMsg();
00930         virtual ~AlarmMsg();
00931
00932         virtual const MsgMetaData& GetMetaData() const;
00933         virtual Message* Clone() const;
00934
00935         enum  {
00936             ID = 18020
00937             };
00938
00939     private:
00940         static const MsgMetaData m_meta_data;
00941
00942     };
00943
00944
00945 /*  ======================================================================
00946     Class MinuteTickMsg
00947     ====================================================================== */
00948
00950 class MinuteTickMsg : public Message {
00951     public:
00952         MinuteTickMsg();
00953         virtual ~MinuteTickMsg();
00954
00955         virtual const MsgMetaData& GetMetaData() const;
00956         virtual Message* Clone() const;
00957
00958         enum  {
00959             ID = 18021
00960             };
00961
00962     private:
00963         static const MsgMetaData m_meta_data;
00964
00965     };
00966
00967
00968 /*  ======================================================================
00969     Class SignalStrengthLevelMsg
00970     ====================================================================== */
00971
00973 class SignalStrengthLevelMsg : public ContextMsg {
00974     public:
00975         SignalStrengthLevelMsg(ExecutionContext* context, const SignalStrengthLevel& signal_strength_level, const SignalStrengthMax& signal_strength_max);
00976         virtual ~SignalStrengthLevelMsg();
00977
00978         virtual const MsgMetaData& GetMetaData() const;
00979         void SetSignalStrengthLevel(const SignalStrengthLevel& signal_strength_level) { m_signal_strength_level = signal_strength_level; }
00980         const SignalStrengthLevel& GetSignalStrengthLevel() const { return m_signal_strength_level; }
00981         void SetSignalStrengthMax(const SignalStrengthMax& signal_strength_max) { m_signal_strength_max = signal_strength_max; }
00982         const SignalStrengthMax& GetSignalStrengthMax() const { return m_signal_strength_max; }
00983         virtual Message* Clone() const;
00984
00985         enum  {
00986             ID = 18000
00987             };
00988
00989     private:
00990         static const MsgMetaData m_meta_data;
00991         SignalStrengthLevel m_signal_strength_level;
00992         SignalStrengthMax m_signal_strength_max;
00993
00994     };
00995
00996
00997 /*  ======================================================================
00998     Class SignalQualityLevelMsg
00999     ====================================================================== */
01000
01002 class SignalQualityLevelMsg : public ContextMsg {
01003     public:
01004         SignalQualityLevelMsg(ExecutionContext* context, const SignalQualityLevel& signal_quality_level, const SignalQualityMax& signal_quality_max);
01005         virtual ~SignalQualityLevelMsg();
01006
01007         virtual const MsgMetaData& GetMetaData() const;
01008         void SetSignalQualityLevel(const SignalQualityLevel& signal_quality_level) { m_signal_quality_level = signal_quality_level; }
01009         const SignalQualityLevel& GetSignalQualityLevel() const { return m_signal_quality_level; }
01010         void SetSignalQualityMax(const SignalQualityMax& signal_quality_max) { m_signal_quality_max = signal_quality_max; }
01011         const SignalQualityMax& GetSignalQualityMax() const { return m_signal_quality_max; }
01012         virtual Message* Clone() const;
01013
01014         enum  {
01015             ID = 18001
01016             };
01017
01018     private:
01019         static const MsgMetaData m_meta_data;
01020         SignalQualityLevel m_signal_quality_level;
01021         SignalQualityMax m_signal_quality_max;
01022
01023     };
01024
01025
01026 /*  ======================================================================
01027     Class AccessoryIndMsg
01028     ====================================================================== */
01029
01031 class AccessoryIndMsg : public ContextMsg {
01032     public:
01033         AccessoryIndMsg(ExecutionContext* context, const Accessory& accessory);
01034         virtual ~AccessoryIndMsg();
01035
01036         virtual const MsgMetaData& GetMetaData() const;
01037         void SetAccessory(const Accessory& accessory) { m_accessory = accessory; }
01038         const Accessory& GetAccessory() const { return m_accessory; }
01039         virtual Message* Clone() const;
01040
01041         enum  {
01042             ID = 18005
01043             };
01044
01045     private:
01046         static const MsgMetaData m_meta_data;
01047         Accessory m_accessory;
01048
01049     };
01050
01051
01052 /*  ======================================================================
01053     Class RegistrationSuccessMsg
01054     ====================================================================== */
01055
01057 class RegistrationSuccessMsg : public ContextMsg {
01058     public:
01059         RegistrationSuccessMsg(ExecutionContext* context, const Plmn& plmn);
01060         virtual ~RegistrationSuccessMsg();
01061
01062         virtual const MsgMetaData& GetMetaData() const;
01063         void SetPlmn(const Plmn& plmn) { m_plmn = plmn; }
01064         const Plmn& GetPlmn() const { return m_plmn; }
01065         virtual Message* Clone() const;
01066
01067         enum  {
01068             ID = 18200
01069             };
01070
01071     private:
01072         static const MsgMetaData m_meta_data;
01073         Plmn m_plmn;
01074
01075     };
01076
01077
01078 /*  ======================================================================
01079     Class RegistrationChangeMsg
01080     ====================================================================== */
01081
01083 class RegistrationChangeMsg : public ContextMsg {
01084     public:
01085         RegistrationChangeMsg(ExecutionContext* context, const RegisterStatus& status, const RegisterRejectCause& reject_cause, BOOLEAN scan_active, const Plmn& plmn, const GsmErrorCause& gsm_error_cause);
01086         virtual ~RegistrationChangeMsg();
01087
01088         virtual const MsgMetaData& GetMetaData() const;
01089         void SetStatus(const RegisterStatus& status) { m_status = status; }
01090         const RegisterStatus& GetStatus() const { return m_status; }
01091         void SetRejectCause(const RegisterRejectCause& reject_cause) { m_reject_cause = reject_cause; }
01092         const RegisterRejectCause& GetRejectCause() const { return m_reject_cause; }
01093         void SetScanActive(BOOLEAN scan_active) { m_scan_active = scan_active; }
01094         BOOLEAN IsScanActive() const { return m_scan_active; }
01095         void SetPlmn(const Plmn& plmn) { m_plmn = plmn; }
01096         const Plmn& GetPlmn() const { return m_plmn; }
01097         void SetGsmErrorCause(const GsmErrorCause& gsm_error_cause) { m_gsm_error_cause = gsm_error_cause; }
01098         const GsmErrorCause& GetGsmErrorCause() const { return m_gsm_error_cause; }
01099         virtual Message* Clone() const;
01100
01101         enum  {
01102             ID = 18201
01103             };
01104
01105     private:
01106         static const MsgMetaData m_meta_data;
01107         RegisterStatus m_status;
01108         RegisterRejectCause m_reject_cause;
01109         BOOLEAN m_scan_active;
01110         Plmn m_plmn;
01111         GsmErrorCause m_gsm_error_cause;
01112
01113     };
01114
01115
01116 /*  ======================================================================
01117     Class PlmnScanFinishedMsg
01118     ====================================================================== */
01119
01121 class PlmnScanFinishedMsg : public ContextMsg {
01122     public:
01123         PlmnScanFinishedMsg(ExecutionContext* context, BOOLEAN rejected, const PlmnScanList& plmn_scan_list);
01124         virtual ~PlmnScanFinishedMsg();
01125
01126         virtual const MsgMetaData& GetMetaData() const;
01127         void SetRejected(BOOLEAN rejected) { m_rejected = rejected; }
01128         BOOLEAN IsRejected() const { return m_rejected; }
01129         void SetPlmnScanList(const PlmnScanList& plmn_scan_list) { m_plmn_scan_list = plmn_scan_list; }
01130         const PlmnScanList& GetPlmnScanList() const { return m_plmn_scan_list; }
01131         virtual Message* Clone() const;
01132
01133         enum  {
01134             ID = 18202
01135             };
01136
01137     private:
01138         static const MsgMetaData m_meta_data;
01139         BOOLEAN m_rejected;
01140         PlmnScanList m_plmn_scan_list;
01141
01142     };
01143
01144
01145 /*  ======================================================================
01146     Class RegistrationAllowedMsg
01147     ====================================================================== */
01148
01150 class RegistrationAllowedMsg : public ContextMsg {
01151     public:
01152         RegistrationAllowedMsg(ExecutionContext* context, BOOLEAN allowed);
01153         virtual ~RegistrationAllowedMsg();
01154
01155         virtual const MsgMetaData& GetMetaData() const;
01156         void SetAllowed(BOOLEAN allowed) { m_allowed = allowed; }
01157         BOOLEAN IsAllowed() const { return m_allowed; }
01158         virtual Message* Clone() const;
01159
01160         enum  {
01161             ID = 18203
01162             };
01163
01164     private:
01165         static const MsgMetaData m_meta_data;
01166         BOOLEAN m_allowed;
01167
01168     };
01169
01170
01171 /*  ======================================================================
01172     Class SimCallSetupMsg
01173     ====================================================================== */
01174
01176 class SimCallSetupMsg : public ContextMsg {
01177     public:
01178         SimCallSetupMsg(ExecutionContext* context, const SimTkCallSetupIndArg& arg);
01179         virtual ~SimCallSetupMsg();
01180
01181         virtual const MsgMetaData& GetMetaData() const;
01182         void SetArg(const SimTkCallSetupIndArg& arg) { m_arg = arg; }
01183         const SimTkCallSetupIndArg& GetArg() const { return m_arg; }
01184         virtual Message* Clone() const;
01185
01186         enum  {
01187             ID = 18301
01188             };
01189
01190     private:
01191         static const MsgMetaData m_meta_data;
01192         SimTkCallSetupIndArg m_arg;
01193
01194     };
01195
01196
01197 /*  ======================================================================
01198     Class SimSmsSentMsg
01199     ====================================================================== */
01200
01202 class SimSmsSentMsg : public ContextMsg {
01203     public:
01204         SimSmsSentMsg(ExecutionContext* context, const SimTkSmsPpIndArg& arg);
01205         virtual ~SimSmsSentMsg();
01206
01207         virtual const MsgMetaData& GetMetaData() const;
01208         void SetArg(const SimTkSmsPpIndArg& arg) { m_arg = arg; }
01209         const SimTkSmsPpIndArg& GetArg() const { return m_arg; }
01210         virtual Message* Clone() const;
01211
01212         enum  {
01213             ID = 18302
01214             };
01215
01216     private:
01217         static const MsgMetaData m_meta_data;
01218         SimTkSmsPpIndArg m_arg;
01219
01220     };
01221
01222
01223 /*  ======================================================================
01224     Class SimSsSentMsg
01225     ====================================================================== */
01226
01228 class SimSsSentMsg : public ContextMsg {
01229     public:
01230         SimSsSentMsg(ExecutionContext* context, const SimTkSsIndArg& arg);
01231         virtual ~SimSsSentMsg();
01232
01233         virtual const MsgMetaData& GetMetaData() const;
01234         void SetArg(const SimTkSsIndArg& arg) { m_arg = arg; }
01235         const SimTkSsIndArg& GetArg() const { return m_arg; }
01236         virtual Message* Clone() const;
01237
01238         enum  {
01239             ID = 18303
01240             };
01241
01242     private:
01243         static const MsgMetaData m_meta_data;
01244         SimTkSsIndArg m_arg;
01245
01246     };
01247
01248
01249 /*  ======================================================================
01250     Class SimRefreshMsg
01251     ====================================================================== */
01252
01254 class SimRefreshMsg : public ContextMsg {
01255     public:
01256         SimRefreshMsg(ExecutionContext* context, const SimTkRefreshReqArg& arg);
01257         virtual ~SimRefreshMsg();
01258
01259         virtual const MsgMetaData& GetMetaData() const;
01260         void SetArg(const SimTkRefreshReqArg& arg) { m_arg = arg; }
01261         const SimTkRefreshReqArg& GetArg() const { return m_arg; }
01262         virtual Message* Clone() const;
01263
01264         enum  {
01265             ID = 18304
01266             };
01267
01268     private:
01269         static const MsgMetaData m_meta_data;
01270         SimTkRefreshReqArg m_arg;
01271
01272     };
01273
01274
01275 /*  ======================================================================
01276     Class SimRefreshResetMsg
01277     ====================================================================== */
01278
01280 class SimRefreshResetMsg : public ContextMsg {
01281     public:
01282         SimRefreshResetMsg(ExecutionContext* context);
01283         virtual ~SimRefreshResetMsg();
01284
01285         virtual const MsgMetaData& GetMetaData() const;
01286         virtual Message* Clone() const;
01287
01288         enum  {
01289             ID = 18305
01290             };
01291
01292     private:
01293         static const MsgMetaData m_meta_data;
01294
01295     };
01296
01297
01298 /*  ======================================================================
01299     Class SimResetConfirmationMsg
01300     ====================================================================== */
01301
01303 class SimResetConfirmationMsg : public ContextMsg {
01304     public:
01305         SimResetConfirmationMsg(ExecutionContext* context, const SimTkResetCnfReqArg& arg);
01306         virtual ~SimResetConfirmationMsg();
01307
01308         virtual const MsgMetaData& GetMetaData() const;
01309         void SetArg(const SimTkResetCnfReqArg& arg) { m_arg = arg; }
01310         const SimTkResetCnfReqArg& GetArg() const { return m_arg; }
01311         virtual Message* Clone() const;
01312
01313         enum  {
01314             ID = 18306
01315             };
01316
01317     private:
01318         static const MsgMetaData m_meta_data;
01319         SimTkResetCnfReqArg m_arg;
01320
01321     };
01322
01323
01324 /*  ======================================================================
01325     Class SimResetDoneMsg
01326     ====================================================================== */
01327
01329 class SimResetDoneMsg : public ContextMsg {
01330     public:
01331         SimResetDoneMsg(ExecutionContext* context);
01332         virtual ~SimResetDoneMsg();
01333
01334         virtual const MsgMetaData& GetMetaData() const;
01335         virtual Message* Clone() const;
01336
01337         enum  {
01338             ID = 18307
01339             };
01340
01341     private:
01342         static const MsgMetaData m_meta_data;
01343
01344     };
01345
01346
01347 /*  ======================================================================
01348     Class SimDisplayTextMsg
01349     ====================================================================== */
01350
01352 class SimDisplayTextMsg : public ContextMsg {
01353     public:
01354         SimDisplayTextMsg(ExecutionContext* context, const DisplayTextReqArg& arg);
01355         virtual ~SimDisplayTextMsg();
01356
01357         virtual const MsgMetaData& GetMetaData() const;
01358         void SetArg(const DisplayTextReqArg& arg) { m_arg = arg; }
01359         const DisplayTextReqArg& GetArg() const { return m_arg; }
01360         virtual Message* Clone() const;
01361
01362         enum  {
01363             ID = 18310
01364             };
01365
01366     private:
01367         static const MsgMetaData m_meta_data;
01368         DisplayTextReqArg m_arg;
01369
01370     };
01371
01372
01373 /*  ======================================================================
01374     Class SimGetInputMsg
01375     ====================================================================== */
01376
01378 class SimGetInputMsg : public ContextMsg {
01379     public:
01380         SimGetInputMsg(ExecutionContext* context, const GetInputReqArg& arg);
01381         virtual ~SimGetInputMsg();
01382
01383         virtual const MsgMetaData& GetMetaData() const;
01384         void SetArg(const GetInputReqArg& arg) { m_arg = arg; }
01385         const GetInputReqArg& GetArg() const { return m_arg; }
01386         virtual Message* Clone() const;
01387
01388         enum  {
01389             ID = 18311
01390             };
01391
01392     private:
01393         static const MsgMetaData m_meta_data;
01394         GetInputReqArg m_arg;
01395
01396     };
01397
01398
01399 /*  ======================================================================
01400     Class SimGetInkeyMsg
01401     ====================================================================== */
01402
01404 class SimGetInkeyMsg : public ContextMsg {
01405     public:
01406         SimGetInkeyMsg(ExecutionContext* context, const GetInkeyReqArg& arg);
01407         virtual ~SimGetInkeyMsg();
01408
01409         virtual const MsgMetaData& GetMetaData() const;
01410         void SetArg(const GetInkeyReqArg& arg) { m_arg = arg; }
01411         const GetInkeyReqArg& GetArg() const { return m_arg; }
01412         virtual Message* Clone() const;
01413
01414         enum  {
01415             ID = 18312
01416             };
01417
01418     private:
01419         static const MsgMetaData m_meta_data;
01420         GetInkeyReqArg m_arg;
01421
01422     };
01423
01424
01425 /*  ======================================================================
01426     Class SimSelectItemMsg
01427     ====================================================================== */
01428
01430 class SimSelectItemMsg : public ContextMsg {
01431     public:
01432         SimSelectItemMsg(ExecutionContext* context, const SelectItemReqArg& arg);
01433         virtual ~SimSelectItemMsg();
01434
01435         virtual const MsgMetaData& GetMetaData() const;
01436         void SetArg(const SelectItemReqArg& arg) { m_arg = arg; }
01437         const SelectItemReqArg& GetArg() const { return m_arg; }
01438         virtual Message* Clone() const;
01439
01440         enum  {
01441             ID = 18313
01442             };
01443
01444     private:
01445         static const MsgMetaData m_meta_data;
01446         SelectItemReqArg m_arg;
01447
01448     };
01449
01450
01451 /*  ======================================================================
01452     Class SimSetupMenuMsg
01453     ====================================================================== */
01454
01456 class SimSetupMenuMsg : public ContextMsg {
01457     public:
01458         SimSetupMenuMsg(ExecutionContext* context, const SimTkTransactionId& tid);
01459         virtual ~SimSetupMenuMsg();
01460
01461         virtual const MsgMetaData& GetMetaData() const;
01462         void SetTid(const SimTkTransactionId& tid) { m_tid = tid; }
01463         const SimTkTransactionId& GetTid() const { return m_tid; }
01464         virtual Message* Clone() const;
01465
01466         enum  {
01467             ID = 18314
01468             };
01469
01470     private:
01471         static const MsgMetaData m_meta_data;
01472         SimTkTransactionId m_tid;
01473
01474     };
01475
01476
01477 /*  ======================================================================
01478     Class SimMenuItemSelectionFailedMsg
01479     ====================================================================== */
01480
01482 class SimMenuItemSelectionFailedMsg : public ContextMsg {
01483     public:
01484         SimMenuItemSelectionFailedMsg(ExecutionContext* context);
01485         virtual ~SimMenuItemSelectionFailedMsg();
01486
01487         virtual const MsgMetaData& GetMetaData() const;
01488         virtual Message* Clone() const;
01489
01490         enum  {
01491             ID = 18315
01492             };
01493
01494     private:
01495         static const MsgMetaData m_meta_data;
01496
01497     };
01498
01499
01500 /*  ======================================================================
01501     Class SimPlayToneMsg
01502     ====================================================================== */
01503
01505 class SimPlayToneMsg : public ContextMsg {
01506     public:
01507         SimPlayToneMsg(ExecutionContext* context, const PlayToneReqArg& arg);
01508         virtual ~SimPlayToneMsg();
01509
01510         virtual const MsgMetaData& GetMetaData() const;
01511         void SetArg(const PlayToneReqArg& arg) { m_arg = arg; }
01512         const PlayToneReqArg& GetArg() const { return m_arg; }
01513         virtual Message* Clone() const;
01514
01515         enum  {
01516             ID = 18316
01517             };
01518
01519     private:
01520         static const MsgMetaData m_meta_data;
01521         PlayToneReqArg m_arg;
01522
01523     };
01524
01525
01526 /*  ======================================================================
01527     Class SimSetupIdleModeTextMsg
01528     ====================================================================== */
01529
01531 class SimSetupIdleModeTextMsg : public ContextMsg {
01532     public:
01533         SimSetupIdleModeTextMsg(ExecutionContext* context, const SetupIdleModeTextReqArg& arg);
01534         virtual ~SimSetupIdleModeTextMsg();
01535
01536         virtual const MsgMetaData& GetMetaData() const;
01537         void SetArg(const SetupIdleModeTextReqArg& arg) { m_arg = arg; }
01538         const SetupIdleModeTextReqArg& GetArg() const { return m_arg; }
01539         virtual Message* Clone() const;
01540
01541         enum  {
01542             ID = 18317
01543             };
01544
01545     private:
01546         static const MsgMetaData m_meta_data;
01547         SetupIdleModeTextReqArg m_arg;
01548
01549     };
01550
01551
01552 /*  ======================================================================
01553     Class SimEndTransactionMsg
01554     ====================================================================== */
01555
01557 class SimEndTransactionMsg : public ContextMsg {
01558     public:
01559         SimEndTransactionMsg(ExecutionContext* context);
01560         virtual ~SimEndTransactionMsg();
01561
01562         virtual const MsgMetaData& GetMetaData() const;
01563         virtual Message* Clone() const;
01564
01565         enum  {
01566             ID = 18318
01567             };
01568
01569     private:
01570         static const MsgMetaData m_meta_data;
01571
01572     };
01573
01574
01575 /*  ======================================================================
01576     Class SimCallSetupRejectedMsg
01577     ====================================================================== */
01578
01580 class SimCallSetupRejectedMsg : public ContextMsg {
01581     public:
01582         SimCallSetupRejectedMsg(ExecutionContext* context, const CallErrorCause& cause);
01583         virtual ~SimCallSetupRejectedMsg();
01584
01585         virtual const MsgMetaData& GetMetaData() const;
01586         void SetCause(const CallErrorCause& cause) { m_cause = cause; }
01587         const CallErrorCause& GetCause() const { return m_cause; }
01588         virtual Message* Clone() const;
01589
01590         enum  {
01591             ID = 18319
01592             };
01593
01594     private:
01595         static const MsgMetaData m_meta_data;
01596         CallErrorCause m_cause;
01597
01598     };
01599
01600
01601 /*  ======================================================================
01602     Class CallOnHoldMsg
01603     ====================================================================== */
01604
01606 class CallOnHoldMsg : public ContextMsg {
01607     public:
01608         CallOnHoldMsg(ExecutionContext* context, const CallHdl& call);
01609         virtual ~CallOnHoldMsg();
01610
01611         virtual const MsgMetaData& GetMetaData() const;
01612         void SetCall(const CallHdl& call) { m_call = call; }
01613         const CallHdl& GetCall() const { return m_call; }
01614         virtual Message* Clone() const;
01615
01616         enum  {
01617             ID = 18320
01618             };
01619
01620     private:
01621         static const MsgMetaData m_meta_data;
01622         CallHdl m_call;
01623
01624     };
01625
01626
01627 /*  ======================================================================
01628     Class CallHoldRejectedMsg
01629     ====================================================================== */
01630
01632 class CallHoldRejectedMsg : public ContextMsg {
01633     public:
01634         CallHoldRejectedMsg(ExecutionContext* context, const CallHdl& call, const CallErrorCause& cause);
01635         virtual ~CallHoldRejectedMsg();
01636
01637         virtual const MsgMetaData& GetMetaData() const;
01638         void SetCall(const CallHdl& call) { m_call = call; }
01639         const CallHdl& GetCall() const { return m_call; }
01640         void SetCause(const CallErrorCause& cause) { m_cause = cause; }
01641         const CallErrorCause& GetCause() const { return m_cause; }
01642         virtual Message* Clone() const;
01643
01644         enum  {
01645             ID = 18321
01646             };
01647
01648     private:
01649         static const MsgMetaData m_meta_data;
01650         CallHdl m_call;
01651         CallErrorCause m_cause;
01652
01653     };
01654
01655
01656 /*  ======================================================================
01657     Class MptyOnHoldMsg
01658     ====================================================================== */
01659
01661 class MptyOnHoldMsg : public ContextMsg {
01662     public:
01663         MptyOnHoldMsg(ExecutionContext* context);
01664         virtual ~MptyOnHoldMsg();
01665
01666         virtual const MsgMetaData& GetMetaData() const;
01667         virtual Message* Clone() const;
01668
01669         enum  {
01670             ID = 18322
01671             };
01672
01673     private:
01674         static const MsgMetaData m_meta_data;
01675
01676     };
01677
01678
01679 /*  ======================================================================
01680     Class MptyHoldRejectedMsg
01681     ====================================================================== */
01682
01684 class MptyHoldRejectedMsg : public ContextMsg {
01685     public:
01686         MptyHoldRejectedMsg(ExecutionContext* context, const SsErrorCode& error_code);
01687         virtual ~MptyHoldRejectedMsg();
01688
01689         virtual const MsgMetaData& GetMetaData() const;
01690         void SetErrorCode(const SsErrorCode& error_code) { m_error_code = error_code; }
01691         const SsErrorCode& GetErrorCode() const { return m_error_code; }
01692         virtual Message* Clone() const;
01693
01694         enum  {
01695             ID = 18323
01696             };
01697
01698     private:
01699         static const MsgMetaData m_meta_data;
01700         SsErrorCode m_error_code;
01701
01702     };
01703
01704
01705 /*  ======================================================================
01706     Class SimTkLanguageNotificationMsg
01707     ====================================================================== */
01708
01710 class SimTkLanguageNotificationMsg : public ContextMsg {
01711     public:
01712         SimTkLanguageNotificationMsg(ExecutionContext* context, const WString& ext_language);
01713         virtual ~SimTkLanguageNotificationMsg();
01714
01715         virtual const MsgMetaData& GetMetaData() const;
01716         void SetExtLanguage(const WString& ext_language) { m_ext_language = ext_language; }
01717         const WString& GetExtLanguage() const { return m_ext_language; }
01718         virtual Message* Clone() const;
01719
01720         enum  {
01721             ID = 18324
01722             };
01723
01724     private:
01725         static const MsgMetaData m_meta_data;
01726         WString m_ext_language;
01727
01728     };
01729
01730
01731 /*  ======================================================================
01732     Class SimTkSetupEventMsg
01733     ====================================================================== */
01734
01736 class SimTkSetupEventMsg : public ContextMsg {
01737     public:
01738         SimTkSetupEventMsg(ExecutionContext* context);
01739         virtual ~SimTkSetupEventMsg();
01740
01741         virtual const MsgMetaData& GetMetaData() const;
01742         virtual Message* Clone() const;
01743
01744         enum  {
01745             ID = 18325
01746             };
01747
01748     private:
01749         static const MsgMetaData m_meta_data;
01750
01751     };
01752
01753
01754 /*  ======================================================================
01755     Class TermRspCnfMsg
01756     ====================================================================== */
01757
01759 class TermRspCnfMsg : public ContextMsg {
01760     public:
01761         TermRspCnfMsg(ExecutionContext* context, const TermRspCnfArg& arg);
01762         virtual ~TermRspCnfMsg();
01763
01764         virtual const MsgMetaData& GetMetaData() const;
01765         void SetArg(const TermRspCnfArg& arg) { m_arg = arg; }
01766         const TermRspCnfArg& GetArg() const { return m_arg; }
01767         virtual Message* Clone() const;
01768
01769         enum  {
01770             ID = 18326
01771             };
01772
01773     private:
01774         static const MsgMetaData m_meta_data;
01775         TermRspCnfArg m_arg;
01776
01777     };
01778
01779
01780 /*  ======================================================================
01781     Class SimTkRefreshStartMsg
01782     ====================================================================== */
01783
01785 class SimTkRefreshStartMsg : public ContextMsg {
01786     public:
01787         SimTkRefreshStartMsg(ExecutionContext* context);
01788         virtual ~SimTkRefreshStartMsg();
01789
01790         virtual const MsgMetaData& GetMetaData() const;
01791         virtual Message* Clone() const;
01792
01793         enum  {
01794             ID = 18327
01795             };
01796
01797     private:
01798         static const MsgMetaData m_meta_data;
01799
01800     };
01801
01802
01803 /*  ======================================================================
01804     Class SimTkProfileGetCnfMsg
01805     ====================================================================== */
01806
01808 class SimTkProfileGetCnfMsg : public ContextMsg {
01809     public:
01810         SimTkProfileGetCnfMsg(ExecutionContext* context, const SimTkProfile& sim_tk_profile);
01811         virtual ~SimTkProfileGetCnfMsg();
01812
01813         virtual const MsgMetaData& GetMetaData() const;
01814         void SetSimTkProfile(const SimTkProfile& sim_tk_profile) { m_sim_tk_profile = sim_tk_profile; }
01815         const SimTkProfile& GetSimTkProfile() const { return m_sim_tk_profile; }
01816         virtual Message* Clone() const;
01817
01818         enum  {
01819             ID = 18328
01820             };
01821
01822     private:
01823         static const MsgMetaData m_meta_data;
01824         SimTkProfile m_sim_tk_profile;
01825
01826     };
01827
01828
01829 /*  ======================================================================
01830     Class SimTkProfileSetCnfMsg
01831     ====================================================================== */
01832
01834 class SimTkProfileSetCnfMsg : public ContextMsg {
01835     public:
01836         SimTkProfileSetCnfMsg(ExecutionContext* context);
01837         virtual ~SimTkProfileSetCnfMsg();
01838
01839         virtual const MsgMetaData& GetMetaData() const;
01840         virtual Message* Clone() const;
01841
01842         enum  {
01843             ID = 18329
01844             };
01845
01846     private:
01847         static const MsgMetaData m_meta_data;
01848
01849     };
01850
01851
01852 /*  ======================================================================
01853     Class SimTkProfileSetRejMsg
01854     ====================================================================== */
01855
01857 class SimTkProfileSetRejMsg : public ContextMsg {
01858     public:
01859         SimTkProfileSetRejMsg(ExecutionContext* context);
01860         virtual ~SimTkProfileSetRejMsg();
01861
01862         virtual const MsgMetaData& GetMetaData() const;
01863         virtual Message* Clone() const;
01864
01865         enum  {
01866             ID = 18330
01867             };
01868
01869     private:
01870         static const MsgMetaData m_meta_data;
01871
01872     };
01873
01874
01875 /*  ======================================================================
01876     Class SimLaunchBrowserReqMsg
01877     ====================================================================== */
01878
01880 class SimLaunchBrowserReqMsg : public ContextMsg {
01881     public:
01882         SimLaunchBrowserReqMsg(ExecutionContext* context, const SimLaunchBrowserReqArg& arg);
01883         virtual ~SimLaunchBrowserReqMsg();
01884
01885         virtual const MsgMetaData& GetMetaData() const;
01886         void SetArg(const SimLaunchBrowserReqArg& arg) { m_arg = arg; }
01887         const SimLaunchBrowserReqArg& GetArg() const { return m_arg; }
01888         virtual Message* Clone() const;
01889
01890         enum  {
01891             ID = 18331
01892             };
01893
01894     private:
01895         static const MsgMetaData m_meta_data;
01896         SimLaunchBrowserReqArg m_arg;
01897
01898     };
01899
01900
01901 /*  ======================================================================
01902     Class SimLaunchBrowserPromptReqMsg
01903     ====================================================================== */
01904
01906 class SimLaunchBrowserPromptReqMsg : public ContextMsg {
01907     public:
01908         SimLaunchBrowserPromptReqMsg(ExecutionContext* context, const SimLaunchBrowserPromptReqArg& arg);
01909         virtual ~SimLaunchBrowserPromptReqMsg();
01910
01911         virtual const MsgMetaData& GetMetaData() const;
01912         void SetArg(const SimLaunchBrowserPromptReqArg& arg) { m_arg = arg; }
01913         const SimLaunchBrowserPromptReqArg& GetArg() const { return m_arg; }
01914         virtual Message* Clone() const;
01915
01916         enum  {
01917             ID = 18332
01918             };
01919
01920     private:
01921         static const MsgMetaData m_meta_data;
01922         SimLaunchBrowserPromptReqArg m_arg;
01923
01924     };
01925
01926
01927 /*  ======================================================================
01928     Class SimBrowserTermResMsg
01929     ====================================================================== */
01930
01932 class SimBrowserTermResMsg : public ContextMsg {
01933     public:
01934         SimBrowserTermResMsg(ExecutionContext* context, const SimBrowserTermResArg& arg);
01935         virtual ~SimBrowserTermResMsg();
01936
01937         virtual const MsgMetaData& GetMetaData() const;
01938         void SetArg(const SimBrowserTermResArg& arg) { m_arg = arg; }
01939         const SimBrowserTermResArg& GetArg() const { return m_arg; }
01940         virtual Message* Clone() const;
01941
01942         enum  {
01943             ID = 18333
01944             };
01945
01946     private:
01947         static const MsgMetaData m_meta_data;
01948         SimBrowserTermResArg m_arg;
01949
01950     };
01951
01952
01953 /*  ======================================================================
01954     Class OmMultiSlotIndMsg
01955     ====================================================================== */
01956
01958 class OmMultiSlotIndMsg : public ContextMsg {
01959     public:
01960         OmMultiSlotIndMsg(ExecutionContext* context, BOOLEAN success);
01961         virtual ~OmMultiSlotIndMsg();
01962
01963         virtual const MsgMetaData& GetMetaData() const;
01964         void SetSuccess(BOOLEAN success) { m_success = success; }
01965         BOOLEAN IsSuccess() const { return m_success; }
01966         virtual Message* Clone() const;
01967
01968         enum  {
01969             ID = 18334
01970             };
01971
01972     private:
01973         static const MsgMetaData m_meta_data;
01974         BOOLEAN m_success;
01975
01976     };
01977
01978
01979 /*  ======================================================================
01980     Class DhChannelOpenReqMsg
01981     ====================================================================== */
01982
01984 class DhChannelOpenReqMsg : public ContextMsg {
01985     public:
01986         DhChannelOpenReqMsg(ExecutionContext* context, const DhChannelOpenReqArg& arg);
01987         virtual ~DhChannelOpenReqMsg();
01988
01989         virtual const MsgMetaData& GetMetaData() const;
01990         void SetArg(const DhChannelOpenReqArg& arg) { m_arg = arg; }
01991         const DhChannelOpenReqArg& GetArg() const { return m_arg; }
01992         virtual Message* Clone() const;
01993
01994         enum  {
01995             ID = 18339
01996             };
01997
01998     private:
01999         static const MsgMetaData m_meta_data;
02000         DhChannelOpenReqArg m_arg;
02001
02002     };
02003
02004
02005 /*  ======================================================================
02006     Class DhChannelCloseReqMsg
02007     ====================================================================== */
02008
02010 class DhChannelCloseReqMsg : public ContextMsg {
02011     public:
02012         DhChannelCloseReqMsg(ExecutionContext* context, const DhChannelCloseReqArg& arg);
02013         virtual ~DhChannelCloseReqMsg();
02014
02015         virtual const MsgMetaData& GetMetaData() const;
02016         void SetArg(const DhChannelCloseReqArg& arg) { m_arg = arg; }
02017         const DhChannelCloseReqArg& GetArg() const { return m_arg; }
02018         virtual Message* Clone() const;
02019
02020         enum  {
02021             ID = 18340
02022             };
02023
02024     private:
02025         static const MsgMetaData m_meta_data;
02026         DhChannelCloseReqArg m_arg;
02027
02028     };
02029
02030
02031 /*  ======================================================================
02032     Class DhChannelSendReqMsg
02033     ====================================================================== */
02034
02036 class DhChannelSendReqMsg : public ContextMsg {
02037     public:
02038         DhChannelSendReqMsg(ExecutionContext* context, const DhChannelSendReqArg& arg);
02039         virtual ~DhChannelSendReqMsg();
02040
02041         virtual const MsgMetaData& GetMetaData() const;
02042         void SetArg(const DhChannelSendReqArg& arg) { m_arg = arg; }
02043         const DhChannelSendReqArg& GetArg() const { return m_arg; }
02044         virtual Message* Clone() const;
02045
02046         enum  {
02047             ID = 18341
02048             };
02049
02050     private:
02051         static const MsgMetaData m_meta_data;
02052         DhChannelSendReqArg m_arg;
02053
02054     };
02055
02056
02057 /*  ======================================================================
02058     Class DhChannelDataAvailableResMsg
02059     ====================================================================== */
02060
02062 class DhChannelDataAvailableResMsg : public ContextMsg {
02063     public:
02064         DhChannelDataAvailableResMsg(ExecutionContext* context, const DhChannelDataAvailableResArg& arg);
02065         virtual ~DhChannelDataAvailableResMsg();
02066
02067         virtual const MsgMetaData& GetMetaData() const;
02068         void SetArg(const DhChannelDataAvailableResArg& arg) { m_arg = arg; }
02069         const DhChannelDataAvailableResArg& GetArg() const { return m_arg; }
02070         virtual Message* Clone() const;
02071
02072         enum  {
02073             ID = 18342
02074             };
02075
02076     private:
02077         static const MsgMetaData m_meta_data;
02078         DhChannelDataAvailableResArg m_arg;
02079
02080     };
02081
02082
02083 /*  ======================================================================
02084     Class DhChannelReceiveReqMsg
02085     ====================================================================== */
02086
02088 class DhChannelReceiveReqMsg : public ContextMsg {
02089     public:
02090         DhChannelReceiveReqMsg(ExecutionContext* context, const DhChannelReceiveReqArg& arg);
02091         virtual ~DhChannelReceiveReqMsg();
02092
02093         virtual const MsgMetaData& GetMetaData() const;
02094         void SetArg(const DhChannelReceiveReqArg& arg) { m_arg = arg; }
02095         const DhChannelReceiveReqArg& GetArg() const { return m_arg; }
02096         virtual Message* Clone() const;
02097
02098         enum  {
02099             ID = 18343
02100             };
02101
02102     private:
02103         static const MsgMetaData m_meta_data;
02104         DhChannelReceiveReqArg m_arg;
02105
02106     };
02107
02108
02109 /*  ======================================================================
02110     Class DhChannelChangeStatusResMsg
02111     ====================================================================== */
02112
02114 class DhChannelChangeStatusResMsg : public ContextMsg {
02115     public:
02116         DhChannelChangeStatusResMsg(ExecutionContext* context, const DhChannelChangeStatusResArg& arg);
02117         virtual ~DhChannelChangeStatusResMsg();
02118
02119         virtual const MsgMetaData& GetMetaData() const;
02120         void SetArg(const DhChannelChangeStatusResArg& arg) { m_arg = arg; }
02121         const DhChannelChangeStatusResArg& GetArg() const { return m_arg; }
02122         virtual Message* Clone() const;
02123
02124         enum  {
02125             ID = 18344
02126             };
02127
02128     private:
02129         static const MsgMetaData m_meta_data;
02130         DhChannelChangeStatusResArg m_arg;
02131
02132     };
02133
02134
02135 /*  ======================================================================
02136     Class SimTkRunAtCmdInfoIndMsg
02137     ====================================================================== */
02138
02140 class SimTkRunAtCmdInfoIndMsg : public ContextMsg {
02141     public:
02142         SimTkRunAtCmdInfoIndMsg(ExecutionContext* context, const SimTkRunAtCmdInfoIndArg& arg);
02143         virtual ~SimTkRunAtCmdInfoIndMsg();
02144
02145         virtual const MsgMetaData& GetMetaData() const;
02146         void SetArg(const SimTkRunAtCmdInfoIndArg& arg) { m_arg = arg; }
02147         const SimTkRunAtCmdInfoIndArg& GetArg() const { return m_arg; }
02148         virtual Message* Clone() const;
02149
02150         enum  {
02151             ID = 18345
02152             };
02153
02154     private:
02155         static const MsgMetaData m_meta_data;
02156         SimTkRunAtCmdInfoIndArg m_arg;
02157
02158     };
02159
02160
02161 /*  ======================================================================
02162     Class SimTkSendDtmfIndMsg
02163     ====================================================================== */
02164
02166 class SimTkSendDtmfIndMsg : public ContextMsg {
02167     public:
02168         SimTkSendDtmfIndMsg(ExecutionContext* context, const SimTkSendDtmfIndArg& arg);
02169         virtual ~SimTkSendDtmfIndMsg();
02170
02171         virtual const MsgMetaData& GetMetaData() const;
02172         void SetArg(const SimTkSendDtmfIndArg& arg) { m_arg = arg; }
02173         const SimTkSendDtmfIndArg& GetArg() const { return m_arg; }
02174         virtual Message* Clone() const;
02175
02176         enum  {
02177             ID = 18346
02178             };
02179
02180     private:
02181         static const MsgMetaData m_meta_data;
02182         SimTkSendDtmfIndArg m_arg;
02183
02184     };
02185
02186
02187 /*  ======================================================================
02188     Class SimTkSendDtmfEndIndMsg
02189     ====================================================================== */
02190
02192 class SimTkSendDtmfEndIndMsg : public ContextMsg {
02193     public:
02194         SimTkSendDtmfEndIndMsg(ExecutionContext* context, const SimTkSendDtmfEndIndArg& arg);
02195         virtual ~SimTkSendDtmfEndIndMsg();
02196
02197         virtual const MsgMetaData& GetMetaData() const;
02198         void SetArg(const SimTkSendDtmfEndIndArg& arg) { m_arg = arg; }
02199         const SimTkSendDtmfEndIndArg& GetArg() const { return m_arg; }
02200         virtual Message* Clone() const;
02201
02202         enum  {
02203             ID = 18347
02204             };
02205
02206     private:
02207         static const MsgMetaData m_meta_data;
02208         SimTkSendDtmfEndIndArg m_arg;
02209
02210     };
02211
02212
02213 /*  ======================================================================
02214     Class PowerModeIndMsg
02215     ====================================================================== */
02216
02218 class PowerModeIndMsg : public ContextMsg {
02219     public:
02220         PowerModeIndMsg(ExecutionContext* context, const PowerMode& power_mode);
02221         virtual ~PowerModeIndMsg();
02222
02223         virtual const MsgMetaData& GetMetaData() const;
02224         void SetPowerMode(const PowerMode& power_mode) { m_power_mode = power_mode; }
02225         const PowerMode& GetPowerMode() const { return m_power_mode; }
02226         virtual Message* Clone() const;
02227
02228         enum  {
02229             ID = 18390
02230             };
02231
02232     private:
02233         static const MsgMetaData m_meta_data;
02234         PowerMode m_power_mode;
02235
02236     };
02237
02238
02239 /*  ======================================================================
02240     Class MocSetupAcceptMsg
02241     ====================================================================== */
02242
02244 class MocSetupAcceptMsg : public ContextMsg {
02245     public:
02246         MocSetupAcceptMsg(ExecutionContext* context, const CallHdl& arg, BOOLEAN est_cause_changed = FALSE);
02247         virtual ~MocSetupAcceptMsg();
02248
02249         virtual const MsgMetaData& GetMetaData() const;
02250         void SetArg(const CallHdl& arg) { m_arg = arg; }
02251         const CallHdl& GetArg() const { return m_arg; }
02252         void SetEstCauseChanged(BOOLEAN est_cause_changed) { m_est_cause_changed = est_cause_changed; }
02253         BOOLEAN IsEstCauseChanged() const { return m_est_cause_changed; }
02254         virtual Message* Clone() const;
02255
02256         enum  {
02257             ID = 18400
02258             };
02259
02260     private:
02261         static const MsgMetaData m_meta_data;
02262         CallHdl m_arg;
02263         BOOLEAN m_est_cause_changed;
02264
02265     };
02266
02267
02268 /*  ======================================================================
02269     Class CalledPartyAlertingMsg
02270     ====================================================================== */
02271
02273 class CalledPartyAlertingMsg : public ContextMsg {
02274     public:
02275         CalledPartyAlertingMsg(ExecutionContext* context, const CallHdl& arg);
02276         virtual ~CalledPartyAlertingMsg();
02277
02278         virtual const MsgMetaData& GetMetaData() const;
02279         void SetArg(const CallHdl& arg) { m_arg = arg; }
02280         const CallHdl& GetArg() const { return m_arg; }
02281         virtual Message* Clone() const;
02282
02283         enum  {
02284             ID = 18401
02285             };
02286
02287     private:
02288         static const MsgMetaData m_meta_data;
02289         CallHdl m_arg;
02290
02291     };
02292
02293
02294 /*  ======================================================================
02295     Class MtcArrivedMsg
02296     ====================================================================== */
02297
02299 class MtcArrivedMsg : public ContextMsg {
02300     public:
02301         MtcArrivedMsg(ExecutionContext* context, const CallHdl& arg);
02302         virtual ~MtcArrivedMsg();
02303
02304         virtual const MsgMetaData& GetMetaData() const;
02305         void SetArg(const CallHdl& arg) { m_arg = arg; }
02306         const CallHdl& GetArg() const { return m_arg; }
02307         virtual Message* Clone() const;
02308
02309         enum  {
02310             ID = 18402
02311             };
02312
02313     private:
02314         static const MsgMetaData m_meta_data;
02315         CallHdl m_arg;
02316
02317     };
02318
02319
02320 /*  ======================================================================
02321     Class MtcReadyMsg
02322     ====================================================================== */
02323
02325 class MtcReadyMsg : public ContextMsg {
02326     public:
02327         MtcReadyMsg(ExecutionContext* context, const CallHdl& arg);
02328         virtual ~MtcReadyMsg();
02329
02330         virtual const MsgMetaData& GetMetaData() const;
02331         void SetArg(const CallHdl& arg) { m_arg = arg; }
02332         const CallHdl& GetArg() const { return m_arg; }
02333         virtual Message* Clone() const;
02334
02335         enum  {
02336             ID = 18403
02337             };
02338
02339     private:
02340         static const MsgMetaData m_meta_data;
02341         CallHdl m_arg;
02342
02343     };
02344
02345
02346 /*  ======================================================================
02347     Class CallSetupProgressMsg
02348     ====================================================================== */
02349
02351 class CallSetupProgressMsg : public ContextMsg {
02352     public:
02353         CallSetupProgressMsg(ExecutionContext* context, const CallSetupProgressArg& arg);
02354         virtual ~CallSetupProgressMsg();
02355
02356         virtual const MsgMetaData& GetMetaData() const;
02357         void SetArg(const CallSetupProgressArg& arg) { m_arg = arg; }
02358         const CallSetupProgressArg& GetArg() const { return m_arg; }
02359         virtual Message* Clone() const;
02360
02361         enum  {
02362             ID = 18404
02363             };
02364
02365     private:
02366         static const MsgMetaData m_meta_data;
02367         CallSetupProgressArg m_arg;
02368
02369     };
02370
02371
02372 /*  ======================================================================
02373     Class CallDisconnectingMsg
02374     ====================================================================== */
02375
02377 class CallDisconnectingMsg : public ContextMsg {
02378     public:
02379         CallDisconnectingMsg(ExecutionContext* context, const CallDisconnectingArg& arg, const DisconnectingMode& disconnecting_mode);
02380         virtual ~CallDisconnectingMsg();
02381
02382         virtual const MsgMetaData& GetMetaData() const;
02383         void SetArg(const CallDisconnectingArg& arg) { m_arg = arg; }
02384         const CallDisconnectingArg& GetArg() const { return m_arg; }
02385         void SetDisconnectingMode(const DisconnectingMode& disconnecting_mode) { m_disconnecting_mode = disconnecting_mode; }
02386         const DisconnectingMode& GetDisconnectingMode() const { return m_disconnecting_mode; }
02387         virtual Message* Clone() const;
02388
02389         enum  {
02390             ID = 18405
02391             };
02392
02393     private:
02394         static const MsgMetaData m_meta_data;
02395         CallDisconnectingArg m_arg;
02396         DisconnectingMode m_disconnecting_mode;
02397
02398     };
02399
02400
02401 /*  ======================================================================
02402     Class CallDisconnectedMsg
02403     ====================================================================== */
02404
02406 class CallDisconnectedMsg : public ContextMsg {
02407     public:
02408         CallDisconnectedMsg(ExecutionContext* context, const CallHdl& arg, const DisconnectingMode& disconnecting_mode);
02409         virtual ~CallDisconnectedMsg();
02410
02411         virtual const MsgMetaData& GetMetaData() const;
02412         void SetArg(const CallHdl& arg) { m_arg = arg; }
02413         const CallHdl& GetArg() const { return m_arg; }
02414         void SetDisconnectingMode(const DisconnectingMode& disconnecting_mode) { m_disconnecting_mode = disconnecting_mode; }
02415         const DisconnectingMode& GetDisconnectingMode() const { return m_disconnecting_mode; }
02416         virtual Message* Clone() const;
02417
02418         enum  {
02419             ID = 18406
02420             };
02421
02422     private:
02423         static const MsgMetaData m_meta_data;
02424         CallHdl m_arg;
02425         DisconnectingMode m_disconnecting_mode;
02426
02427     };
02428
02429
02430 /*  ======================================================================
02431     Class CallInfoMsg
02432     ====================================================================== */
02433
02435 class CallInfoMsg : public ContextMsg {
02436     public:
02437         CallInfoMsg(ExecutionContext* context, const CallInfoArg& arg);
02438         virtual ~CallInfoMsg();
02439
02440         virtual const MsgMetaData& GetMetaData() const;
02441         void SetArg(const CallInfoArg& arg) { m_arg = arg; }
02442         const CallInfoArg& GetArg() const { return m_arg; }
02443         virtual Message* Clone() const;
02444
02445         enum  {
02446             ID = 18407
02447             };
02448
02449     private:
02450         static const MsgMetaData m_meta_data;
02451         CallInfoArg m_arg;
02452
02453     };
02454
02455
02456 /*  ======================================================================
02457     Class DtmfStartCnfMsg
02458     ====================================================================== */
02459
02461 class DtmfStartCnfMsg : public ContextMsg {
02462     public:
02463         DtmfStartCnfMsg(ExecutionContext* context, const DtmfStartCnfArg& arg);
02464         virtual ~DtmfStartCnfMsg();
02465
02466         virtual const MsgMetaData& GetMetaData() const;
02467         void SetArg(const DtmfStartCnfArg& arg) { m_arg = arg; }
02468         const DtmfStartCnfArg& GetArg() const { return m_arg; }
02469         virtual Message* Clone() const;
02470
02471         enum  {
02472             ID = 18408
02473             };
02474
02475     private:
02476         static const MsgMetaData m_meta_data;
02477         DtmfStartCnfArg m_arg;
02478
02479     };
02480
02481
02482 /*  ======================================================================
02483     Class DtmfStopCnfMsg
02484     ====================================================================== */
02485
02487 class DtmfStopCnfMsg : public ContextMsg {
02488     public:
02489         DtmfStopCnfMsg(ExecutionContext* context, const CallHdl& arg);
02490         virtual ~DtmfStopCnfMsg();
02491
02492         virtual const MsgMetaData& GetMetaData() const;
02493         void SetArg(const CallHdl& arg) { m_arg = arg; }
02494         const CallHdl& GetArg() const { return m_arg; }
02495         virtual Message* Clone() const;
02496
02497         enum  {
02498             ID = 18409
02499             };
02500
02501     private:
02502         static const MsgMetaData m_meta_data;
02503         CallHdl m_arg;
02504
02505     };
02506
02507
02508 /*  ======================================================================
02509     Class DtmfRejectMsg
02510     ====================================================================== */
02511
02513 class DtmfRejectMsg : public ContextMsg {
02514     public:
02515         DtmfRejectMsg(ExecutionContext* context, const DtmfRejectArg& arg);
02516         virtual ~DtmfRejectMsg();
02517
02518         virtual const MsgMetaData& GetMetaData() const;
02519         void SetArg(const DtmfRejectArg& arg) { m_arg = arg; }
02520         const DtmfRejectArg& GetArg() const { return m_arg; }
02521         virtual Message* Clone() const;
02522
02523         enum  {
02524             ID = 18410
02525             };
02526
02527     private:
02528         static const MsgMetaData m_meta_data;
02529         DtmfRejectArg m_arg;
02530
02531     };
02532
02533
02534 /*  ======================================================================
02535     Class DtmfBufferCleanedMsg
02536     ====================================================================== */
02537
02539 class DtmfBufferCleanedMsg : public ContextMsg {
02540     public:
02541         DtmfBufferCleanedMsg(ExecutionContext* context);
02542         virtual ~DtmfBufferCleanedMsg();
02543
02544         virtual const MsgMetaData& GetMetaData() const;
02545         virtual Message* Clone() const;
02546
02547         enum  {
02548             ID = 18411
02549             };
02550
02551     private:
02552         static const MsgMetaData m_meta_data;
02553
02554     };
02555
02556
02557 /*  ======================================================================
02558     Class RemotePartyActionMsg
02559     ====================================================================== */
02560
02562 class RemotePartyActionMsg : public ContextMsg {
02563     public:
02564         RemotePartyActionMsg(ExecutionContext* context, const RemotePartyActionArg& arg);
02565         virtual ~RemotePartyActionMsg();
02566
02567         virtual const MsgMetaData& GetMetaData() const;
02568         void SetArg(const RemotePartyActionArg& arg) { m_arg = arg; }
02569         const RemotePartyActionArg& GetArg() const { return m_arg; }
02570         virtual Message* Clone() const;
02571
02572         enum  {
02573             ID = 18412
02574             };
02575
02576     private:
02577         static const MsgMetaData m_meta_data;
02578         RemotePartyActionArg m_arg;
02579
02580     };
02581
02582
02583 /*  ======================================================================
02584     Class ConnectionStatusMsg
02585     ====================================================================== */
02586
02588 class ConnectionStatusMsg : public ContextMsg {
02589     public:
02590         ConnectionStatusMsg(ExecutionContext* context, const ConnectionIndArg& arg);
02591         virtual ~ConnectionStatusMsg();
02592
02593         virtual const MsgMetaData& GetMetaData() const;
02594         void SetArg(const ConnectionIndArg& arg) { m_arg = arg; }
02595         const ConnectionIndArg& GetArg() const { return m_arg; }
02596         virtual Message* Clone() const;
02597
02598         enum  {
02599             ID = 18413
02600             };
02601
02602     private:
02603         static const MsgMetaData m_meta_data;
02604         ConnectionIndArg m_arg;
02605
02606     };
02607
02608
02609 /*  ======================================================================
02610     Class CallNotifyMsg
02611     ====================================================================== */
02612
02614 class CallNotifyMsg : public ContextMsg {
02615     public:
02616         CallNotifyMsg(ExecutionContext* context, const CallHdl& call_hdl, const NotificationDescription& description);
02617         virtual ~CallNotifyMsg();
02618
02619         virtual const MsgMetaData& GetMetaData() const;
02620         void SetCallHdl(const CallHdl& call_hdl) { m_call_hdl = call_hdl; }
02621         const CallHdl& GetCallHdl() const { return m_call_hdl; }
02622         void SetDescription(const NotificationDescription& description) { m_description = description; }
02623         const NotificationDescription& GetDescription() const { return m_description; }
02624         virtual Message* Clone() const;
02625
02626         enum  {
02627             ID = 18414
02628             };
02629
02630     private:
02631         static const MsgMetaData m_meta_data;
02632         CallHdl m_call_hdl;
02633         NotificationDescription m_description;
02634
02635     };
02636
02637
02638 /*  ======================================================================
02639     Class RedialStartedMsg
02640     ====================================================================== */
02641
02643 class RedialStartedMsg : public ContextMsg {
02644     public:
02645         RedialStartedMsg(ExecutionContext* context);
02646         virtual ~RedialStartedMsg();
02647
02648         virtual const MsgMetaData& GetMetaData() const;
02649         virtual Message* Clone() const;
02650
02651         enum  {
02652             ID = 18415
02653             };
02654
02655     private:
02656         static const MsgMetaData m_meta_data;
02657
02658     };
02659
02660
02661 /*  ======================================================================
02662     Class RedialStoppedMsg
02663     ====================================================================== */
02664
02666 class RedialStoppedMsg : public ContextMsg {
02667     public:
02668         RedialStoppedMsg(ExecutionContext* context);
02669         virtual ~RedialStoppedMsg();
02670
02671         virtual const MsgMetaData& GetMetaData() const;
02672         virtual Message* Clone() const;
02673
02674         enum  {
02675             ID = 18416
02676             };
02677
02678     private:
02679         static const MsgMetaData m_meta_data;
02680
02681     };
02682
02683
02684 /*  ======================================================================
02685     Class RedialSetupMsg
02686     ====================================================================== */
02687
02689 class RedialSetupMsg : public ContextMsg {
02690     public:
02691         RedialSetupMsg(ExecutionContext* context, const CallHdl& call_hdl, const PhoneNumber& phone_no, const ServedCallApplication& served_call_application);
02692         virtual ~RedialSetupMsg();
02693
02694         virtual const MsgMetaData& GetMetaData() const;
02695         void SetCallHdl(const CallHdl& call_hdl) { m_call_hdl = call_hdl; }
02696         const CallHdl& GetCallHdl() const { return m_call_hdl; }
02697         void SetPhoneNo(const PhoneNumber& phone_no) { m_phone_no = phone_no; }
02698         const PhoneNumber& GetPhoneNo() const { return m_phone_no; }
02699         void SetServedCallApplication(const ServedCallApplication& served_call_application) { m_served_call_application = served_call_application; }
02700         const ServedCallApplication& GetServedCallApplication() const { return m_served_call_application; }
02701         virtual Message* Clone() const;
02702
02703         enum  {
02704             ID = 18417
02705             };
02706
02707     private:
02708         static const MsgMetaData m_meta_data;
02709         CallHdl m_call_hdl;
02710         PhoneNumber m_phone_no;
02711         ServedCallApplication m_served_call_application;
02712
02713     };
02714
02715
02716 /*  ======================================================================
02717     Class RedialSuccessMsg
02718     ====================================================================== */
02719
02721 class RedialSuccessMsg : public ContextMsg {
02722     public:
02723         RedialSuccessMsg(ExecutionContext* context, const CallHdl& call_hdl);
02724         virtual ~RedialSuccessMsg();
02725
02726         virtual const MsgMetaData& GetMetaData() const;
02727         void SetCallHdl(const CallHdl& call_hdl) { m_call_hdl = call_hdl; }
02728         const CallHdl& GetCallHdl() const { return m_call_hdl; }
02729         virtual Message* Clone() const;
02730
02731         enum  {
02732             ID = 18418
02733             };
02734
02735     private:
02736         static const MsgMetaData m_meta_data;
02737         CallHdl m_call_hdl;
02738
02739     };
02740
02741
02742 /*  ======================================================================
02743     Class AocChargingStatusMsg
02744     ====================================================================== */
02745
02747 class AocChargingStatusMsg : public ContextMsg {
02748     public:
02749         AocChargingStatusMsg(ExecutionContext* context, const CallHdl& call_hdl, const AocChargingStatus& status);
02750         virtual ~AocChargingStatusMsg();
02751
02752         virtual const MsgMetaData& GetMetaData() const;
02753         void SetCallHdl(const CallHdl& call_hdl) { m_call_hdl = call_hdl; }
02754         const CallHdl& GetCallHdl() const { return m_call_hdl; }
02755         void SetStatus(const AocChargingStatus& status) { m_status = status; }
02756         const AocChargingStatus& GetStatus() const { return m_status; }
02757         virtual Message* Clone() const;
02758
02759         enum  {
02760             ID = 18419
02761             };
02762
02763     private:
02764         static const MsgMetaData m_meta_data;
02765         CallHdl m_call_hdl;
02766         AocChargingStatus m_status;
02767
02768     };
02769
02770
02771 /*  ======================================================================
02772     Class CurrentCallMeterMsg
02773     ====================================================================== */
02774
02776 class CurrentCallMeterMsg : public ContextMsg {
02777     public:
02778         CurrentCallMeterMsg(ExecutionContext* context, const CallHdl& call_hdl, ULONG this_call_ccm, ULONG all_calls_ccm);
02779         virtual ~CurrentCallMeterMsg();
02780
02781         virtual const MsgMetaData& GetMetaData() const;
02782         void SetCallHdl(const CallHdl& call_hdl) { m_call_hdl = call_hdl; }
02783         const CallHdl& GetCallHdl() const { return m_call_hdl; }
02784         void SetThisCallCcm(ULONG this_call_ccm) { m_this_call_ccm = this_call_ccm; }
02785         ULONG GetThisCallCcm() const { return m_this_call_ccm; }
02786         void SetAllCallsCcm(ULONG all_calls_ccm) { m_all_calls_ccm = all_calls_ccm; }
02787         ULONG GetAllCallsCcm() const { return m_all_calls_ccm; }
02788         virtual Message* Clone() const;
02789
02790         enum  {
02791             ID = 18420
02792             };
02793
02794     private:
02795         static const MsgMetaData m_meta_data;
02796         CallHdl m_call_hdl;
02797         ULONG m_this_call_ccm;
02798         ULONG m_all_calls_ccm;
02799
02800     };
02801
02802
02803 /*  ======================================================================
02804     Class CurrentChargeDataMsg
02805     ====================================================================== */
02806
02808 class CurrentChargeDataMsg : public ContextMsg {
02809     public:
02810         CurrentChargeDataMsg(ExecutionContext* context, const CallHdl& call_hdl, const AocChargeData& this_call_charge, const AocChargeData& all_calls_charge);
02811         virtual ~CurrentChargeDataMsg();
02812
02813         virtual const MsgMetaData& GetMetaData() const;
02814         void SetCallHdl(const CallHdl& call_hdl) { m_call_hdl = call_hdl; }
02815         const CallHdl& GetCallHdl() const { return m_call_hdl; }
02816         void SetThisCallCharge(const AocChargeData& this_call_charge) { m_this_call_charge = this_call_charge; }
02817         const AocChargeData& GetThisCallCharge() const { return m_this_call_charge; }
02818         void SetAllCallsCharge(const AocChargeData& all_calls_charge) { m_all_calls_charge = all_calls_charge; }
02819         const AocChargeData& GetAllCallsCharge() const { return m_all_calls_charge; }
02820         virtual Message* Clone() const;
02821
02822         enum  {
02823             ID = 18421
02824             };
02825
02826     private:
02827         static const MsgMetaData m_meta_data;
02828         CallHdl m_call_hdl;
02829         AocChargeData m_this_call_charge;
02830         AocChargeData m_all_calls_charge;
02831
02832     };
02833
02834
02835 /*  ======================================================================
02836     Class DiagnosticIndMsg
02837     ====================================================================== */
02838
02840 class DiagnosticIndMsg : public ContextMsg {
02841     public:
02842         DiagnosticIndMsg(ExecutionContext* context, const Tipd& tipd, const DiagnosticCause& diagnostic_cause);
02843         virtual ~DiagnosticIndMsg();
02844
02845         virtual const MsgMetaData& GetMetaData() const;
02846         const Tipd& GetTipd() const { return m_tipd; }
02847         const DiagnosticCause& GetDiagnosticCause() const { return m_diagnostic_cause; }
02848         virtual Message* Clone() const;
02849
02850         enum  {
02851             ID = 18422
02852             };
02853
02854     private:
02855         static const MsgMetaData m_meta_data;
02856         Tipd m_tipd;
02857         DiagnosticCause m_diagnostic_cause;
02858
02859     };
02860
02861
02862 /*  ======================================================================
02863     Class RedialStatusMsg
02864     ====================================================================== */
02865
02867 class RedialStatusMsg : public ContextMsg {
02868     public:
02869         RedialStatusMsg(ExecutionContext* context, BOOLEAN redial_status);
02870         virtual ~RedialStatusMsg();
02871
02872         virtual const MsgMetaData& GetMetaData() const;
02873         BOOLEAN IsRedialStatus() const { return m_redial_status; }
02874         virtual Message* Clone() const;
02875
02876         enum  {
02877             ID = 18423
02878             };
02879
02880     private:
02881         static const MsgMetaData m_meta_data;
02882         BOOLEAN m_redial_status;
02883
02884     };
02885
02886
02887 /*  ======================================================================
02888     Class CallControlInfoMsg
02889     ====================================================================== */
02890
02892 class CallControlInfoMsg : public ContextMsg {
02893     public:
02894         CallControlInfoMsg(ExecutionContext* context, const CallHdl& call_hdl);
02895         virtual ~CallControlInfoMsg();
02896
02897         virtual const MsgMetaData& GetMetaData() const;
02898         const CallHdl& GetCallHdl() const { return m_call_hdl; }
02899         virtual Message* Clone() const;
02900
02901         enum  {
02902             ID = 18424
02903             };
02904
02905     private:
02906         static const MsgMetaData m_meta_data;
02907         CallHdl m_call_hdl;
02908
02909     };
02910
02911
02912 /*  ======================================================================
02913     Class MocSetupRejectIndMsg
02914     ====================================================================== */
02915
02917 class MocSetupRejectIndMsg : public ContextMsg {
02918     public:
02919         MocSetupRejectIndMsg(ExecutionContext* context, const PhoneNumber& phone_number, const CallErrorCause& cause);
02920         virtual ~MocSetupRejectIndMsg();
02921
02922         virtual const MsgMetaData& GetMetaData() const;
02923         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
02924         const CallErrorCause& GetCause() const { return m_cause; }
02925         virtual Message* Clone() const;
02926
02927         enum  {
02928             ID = 18425
02929             };
02930
02931     private:
02932         static const MsgMetaData m_meta_data;
02933         PhoneNumber m_phone_number;
02934         CallErrorCause m_cause;
02935
02936     };
02937
02938
02939 /*  ======================================================================
02940     Class ForwardingInfoReceivedMsg
02941     ====================================================================== */
02942
02944 class ForwardingInfoReceivedMsg : public ContextMsg {
02945     public:
02946         ForwardingInfoReceivedMsg(ExecutionContext* context, const ForwardingInfoReceivedArg& arg);
02947         virtual ~ForwardingInfoReceivedMsg();
02948
02949         virtual const MsgMetaData& GetMetaData() const;
02950         void SetArg(const ForwardingInfoReceivedArg& arg) { m_arg = arg; }
02951         const ForwardingInfoReceivedArg& GetArg() const { return m_arg; }
02952         virtual Message* Clone() const;
02953
02954         enum  {
02955             ID = 18500
02956             };
02957
02958     private:
02959         static const MsgMetaData m_meta_data;
02960         ForwardingInfoReceivedArg m_arg;
02961
02962     };
02963
02964
02965 /*  ======================================================================
02966     Class BarringInfoReceivedMsg
02967     ====================================================================== */
02968
02970 class BarringInfoReceivedMsg : public ContextMsg {
02971     public:
02972         BarringInfoReceivedMsg(ExecutionContext* context, const BarringInfoReceivedArg& arg);
02973         virtual ~BarringInfoReceivedMsg();
02974
02975         virtual const MsgMetaData& GetMetaData() const;
02976         void SetArg(const BarringInfoReceivedArg& arg) { m_arg = arg; }
02977         const BarringInfoReceivedArg& GetArg() const { return m_arg; }
02978         virtual Message* Clone() const;
02979
02980         enum  {
02981             ID = 18501
02982             };
02983
02984     private:
02985         static const MsgMetaData m_meta_data;
02986         BarringInfoReceivedArg m_arg;
02987
02988     };
02989
02990
02991 /*  ======================================================================
02992     Class SsDataReceivedMsg
02993     ====================================================================== */
02994
02996 class SsDataReceivedMsg : public ContextMsg {
02997     public:
02998         SsDataReceivedMsg(ExecutionContext* context, const SsDataReceivedArg& arg);
02999         virtual ~SsDataReceivedMsg();
03000
03001         virtual const MsgMetaData& GetMetaData() const;
03002         void SetArg(const SsDataReceivedArg& arg) { m_arg = arg; }
03003         const SsDataReceivedArg& GetArg() const { return m_arg; }
03004         virtual Message* Clone() const;
03005
03006         enum  {
03007             ID = 18502
03008             };
03009
03010     private:
03011         static const MsgMetaData m_meta_data;
03012         SsDataReceivedArg m_arg;
03013
03014     };
03015
03016
03017 /*  ======================================================================
03018     Class SsNotificationMsg
03019     ====================================================================== */
03020
03022 class SsNotificationMsg : public ContextMsg {
03023     public:
03024         SsNotificationMsg(ExecutionContext* context, const SsNotificationArg& arg);
03025         virtual ~SsNotificationMsg();
03026
03027         virtual const MsgMetaData& GetMetaData() const;
03028         void SetArg(const SsNotificationArg& arg) { m_arg = arg; }
03029         const SsNotificationArg& GetArg() const { return m_arg; }
03030         virtual Message* Clone() const;
03031
03032         enum  {
03033             ID = 18503
03034             };
03035
03036     private:
03037         static const MsgMetaData m_meta_data;
03038         SsNotificationArg m_arg;
03039
03040     };
03041
03042
03043 /*  ======================================================================
03044     Class InterrogationResultMsg
03045     ====================================================================== */
03046
03048 class InterrogationResultMsg : public ContextMsg {
03049     public:
03050         InterrogationResultMsg(ExecutionContext* context, const InterrogationResultArg& arg);
03051         virtual ~InterrogationResultMsg();
03052
03053         virtual const MsgMetaData& GetMetaData() const;
03054         void SetArg(const InterrogationResultArg& arg) { m_arg = arg; }
03055         const InterrogationResultArg& GetArg() const { return m_arg; }
03056         virtual Message* Clone() const;
03057
03058         enum  {
03059             ID = 18504
03060             };
03061
03062     private:
03063         static const MsgMetaData m_meta_data;
03064         InterrogationResultArg m_arg;
03065
03066     };
03067
03068
03069 /*  ======================================================================
03070     Class PasswordReceivedMsg
03071     ====================================================================== */
03072
03074 class PasswordReceivedMsg : public ContextMsg {
03075     public:
03076         PasswordReceivedMsg(ExecutionContext* context, const PasswordReceivedArg& arg);
03077         virtual ~PasswordReceivedMsg();
03078
03079         virtual const MsgMetaData& GetMetaData() const;
03080         void SetArg(const PasswordReceivedArg& arg) { m_arg = arg; }
03081         const PasswordReceivedArg& GetArg() const { return m_arg; }
03082         virtual Message* Clone() const;
03083
03084         enum  {
03085             ID = 18505
03086             };
03087
03088     private:
03089         static const MsgMetaData m_meta_data;
03090         PasswordReceivedArg m_arg;
03091
03092     };
03093
03094
03095 /*  ======================================================================
03096     Class UssDataReceivedMsg
03097     ====================================================================== */
03098
03100 class UssDataReceivedMsg : public ContextMsg {
03101     public:
03102         UssDataReceivedMsg(ExecutionContext* context, const UssDataArg& arg);
03103         virtual ~UssDataReceivedMsg();
03104
03105         virtual const MsgMetaData& GetMetaData() const;
03106         void SetArg(const UssDataArg& arg) { m_arg = arg; }
03107         const UssDataArg& GetArg() const { return m_arg; }
03108         virtual Message* Clone() const;
03109
03110         enum  {
03111             ID = 18506
03112             };
03113
03114     private:
03115         static const MsgMetaData m_meta_data;
03116         UssDataArg m_arg;
03117
03118     };
03119
03120
03121 /*  ======================================================================
03122     Class HlrSsDataCorruptMsg
03123     ====================================================================== */
03124
03126 class HlrSsDataCorruptMsg : public ContextMsg {
03127     public:
03128         HlrSsDataCorruptMsg(ExecutionContext* context, const SsOperationCode& arg);
03129         virtual ~HlrSsDataCorruptMsg();
03130
03131         virtual const MsgMetaData& GetMetaData() const;
03132         void SetArg(const SsOperationCode& arg) { m_arg = arg; }
03133         const SsOperationCode& GetArg() const { return m_arg; }
03134         virtual Message* Clone() const;
03135
03136         enum  {
03137             ID = 18507
03138             };
03139
03140     private:
03141         static const MsgMetaData m_meta_data;
03142         SsOperationCode m_arg;
03143
03144     };
03145
03146
03147 /*  ======================================================================
03148     Class SsSuccessMsg
03149     ====================================================================== */
03150
03152 class SsSuccessMsg : public ContextMsg {
03153     public:
03154         SsSuccessMsg(ExecutionContext* context, BOOLEAN arg);
03155         virtual ~SsSuccessMsg();
03156
03157         virtual const MsgMetaData& GetMetaData() const;
03158         void SetArg(BOOLEAN arg) { m_arg = arg; }
03159         BOOLEAN IsArg() const { return m_arg; }
03160         virtual Message* Clone() const;
03161
03162         enum  {
03163             ID = 18508
03164             };
03165
03166     private:
03167         static const MsgMetaData m_meta_data;
03168         BOOLEAN m_arg;
03169
03170     };
03171
03172
03173 /*  ======================================================================
03174     Class SsEndMsg
03175     ====================================================================== */
03176
03178 class SsEndMsg : public ContextMsg {
03179     public:
03180         SsEndMsg(ExecutionContext* context);
03181         virtual ~SsEndMsg();
03182
03183         virtual const MsgMetaData& GetMetaData() const;
03184         virtual Message* Clone() const;
03185
03186         enum  {
03187             ID = 18509
03188             };
03189
03190     private:
03191         static const MsgMetaData m_meta_data;
03192
03193     };
03194
03195
03196 /*  ======================================================================
03197     Class SsRejectedMsg
03198     ====================================================================== */
03199
03201 class SsRejectedMsg : public ContextMsg {
03202     public:
03203         SsRejectedMsg(ExecutionContext* context, const TaggedProblemCode& arg);
03204         virtual ~SsRejectedMsg();
03205
03206         virtual const MsgMetaData& GetMetaData() const;
03207         void SetArg(const TaggedProblemCode& arg) { m_arg = arg; }
03208         const TaggedProblemCode& GetArg() const { return m_arg; }
03209         virtual Message* Clone() const;
03210
03211         enum  {
03212             ID = 18510
03213             };
03214
03215     private:
03216         static const MsgMetaData m_meta_data;
03217         TaggedProblemCode m_arg;
03218
03219     };
03220
03221
03222 /*  ======================================================================
03223     Class SsErrIndicationMsg
03224     ====================================================================== */
03225
03227 class SsErrIndicationMsg : public ContextMsg {
03228     public:
03229         SsErrIndicationMsg(ExecutionContext* context, const SsErrorCode& arg);
03230         virtual ~SsErrIndicationMsg();
03231
03232         virtual const MsgMetaData& GetMetaData() const;
03233         void SetArg(const SsErrorCode& arg) { m_arg = arg; }
03234         const SsErrorCode& GetArg() const { return m_arg; }
03235         virtual Message* Clone() const;
03236
03237         enum  {
03238             ID = 18511
03239             };
03240
03241     private:
03242         static const MsgMetaData m_meta_data;
03243         SsErrorCode m_arg;
03244
03245     };
03246
03247
03248 /*  ======================================================================
03249     Class PasswordInquiryMsg
03250     ====================================================================== */
03251
03253 class PasswordInquiryMsg : public ContextMsg {
03254     public:
03255         PasswordInquiryMsg(ExecutionContext* context);
03256         virtual ~PasswordInquiryMsg();
03257
03258         virtual const MsgMetaData& GetMetaData() const;
03259         virtual Message* Clone() const;
03260
03261         enum  {
03262             ID = 18512
03263             };
03264
03265     private:
03266         static const MsgMetaData m_meta_data;
03267
03268     };
03269
03270
03271 /*  ======================================================================
03272     Class PasswordRejectedMsg
03273     ====================================================================== */
03274
03276 class PasswordRejectedMsg : public ContextMsg {
03277     public:
03278         PasswordRejectedMsg(ExecutionContext* context);
03279         virtual ~PasswordRejectedMsg();
03280
03281         virtual const MsgMetaData& GetMetaData() const;
03282         virtual Message* Clone() const;
03283
03284         enum  {
03285             ID = 18513
03286             };
03287
03288     private:
03289         static const MsgMetaData m_meta_data;
03290
03291     };
03292
03293
03294 /*  ======================================================================
03295     Class UssdIndicationMsg
03296     ====================================================================== */
03297
03299 class UssdIndicationMsg : public ContextMsg {
03300     public:
03301         UssdIndicationMsg(ExecutionContext* context, const UssDataArg& arg);
03302         virtual ~UssdIndicationMsg();
03303
03304         virtual const MsgMetaData& GetMetaData() const;
03305         void SetArg(const UssDataArg& arg) { m_arg = arg; }
03306         const UssDataArg& GetArg() const { return m_arg; }
03307         virtual Message* Clone() const;
03308
03309         enum  {
03310             ID = 18514
03311             };
03312
03313     private:
03314         static const MsgMetaData m_meta_data;
03315         UssDataArg m_arg;
03316
03317     };
03318
03319
03320 /*  ======================================================================
03321     Class UssdResentMsg
03322     ====================================================================== */
03323
03325 class UssdResentMsg : public ContextMsg {
03326     public:
03327         UssdResentMsg(ExecutionContext* context);
03328         virtual ~UssdResentMsg();
03329
03330         virtual const MsgMetaData& GetMetaData() const;
03331         virtual Message* Clone() const;
03332
03333         enum  {
03334             ID = 18515
03335             };
03336
03337     private:
03338         static const MsgMetaData m_meta_data;
03339
03340     };
03341
03342
03343 /*  ======================================================================
03344     Class SsFacilityRejectedMsg
03345     ====================================================================== */
03346
03348 class SsFacilityRejectedMsg : public ContextMsg {
03349     public:
03350         SsFacilityRejectedMsg(ExecutionContext* context, const MnCause& cause);
03351         virtual ~SsFacilityRejectedMsg();
03352
03353         virtual const MsgMetaData& GetMetaData() const;
03354         void SetCause(const MnCause& cause) { m_cause = cause; }
03355         const MnCause& GetCause() const { return m_cause; }
03356         virtual Message* Clone() const;
03357
03358         enum  {
03359             ID = 18516
03360             };
03361
03362     private:
03363         static const MsgMetaData m_meta_data;
03364         MnCause m_cause;
03365
03366     };
03367
03368
03369 /*  ======================================================================
03370     Class SsInfoMsg
03371     ====================================================================== */
03372
03374 class SsInfoMsg : public ContextMsg {
03375     public:
03376         SsInfoMsg(ExecutionContext* context, const Tipd& tipd, const WString& ss_sequence, BOOLEAN call_control_performed, const SimCallControlResult& call_control_result, const SimAlphaIdentifier& alpha_identifier);
03377         virtual ~SsInfoMsg();
03378
03379         virtual const MsgMetaData& GetMetaData() const;
03380         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
03381         const Tipd& GetTipd() const { return m_tipd; }
03382         void SetSsSequence(const WString& ss_sequence) { m_ss_sequence = ss_sequence; }
03383         const WString& GetSsSequence() const { return m_ss_sequence; }
03384         void SetCallControlPerformed(BOOLEAN call_control_performed) { m_call_control_performed = call_control_performed; }
03385         BOOLEAN IsCallControlPerformed() const { return m_call_control_performed; }
03386         void SetCallControlResult(const SimCallControlResult& call_control_result) { m_call_control_result = call_control_result; }
03387         const SimCallControlResult& GetCallControlResult() const { return m_call_control_result; }
03388         void SetAlphaIdentifier(const SimAlphaIdentifier& alpha_identifier) { m_alpha_identifier = alpha_identifier; }
03389         const SimAlphaIdentifier& GetAlphaIdentifier() const { return m_alpha_identifier; }
03390         virtual Message* Clone() const;
03391
03392         enum  {
03393             ID = 18573
03394             };
03395
03396     private:
03397         static const MsgMetaData m_meta_data;
03398         Tipd m_tipd;
03399         WString m_ss_sequence;
03400         BOOLEAN m_call_control_performed;
03401         SimCallControlResult m_call_control_result;
03402         SimAlphaIdentifier m_alpha_identifier;
03403
03404     };
03405
03406
03407 /*  ======================================================================
03408     Class CcbsRecallMsg
03409     ====================================================================== */
03410
03412 class CcbsRecallMsg : public ContextMsg {
03413     public:
03414         CcbsRecallMsg(ExecutionContext* context, const PhoneNumber& phone_number);
03415         virtual ~CcbsRecallMsg();
03416
03417         virtual const MsgMetaData& GetMetaData() const;
03418         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
03419         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
03420         virtual Message* Clone() const;
03421
03422         enum  {
03423             ID = 18570
03424             };
03425
03426     private:
03427         static const MsgMetaData m_meta_data;
03428         PhoneNumber m_phone_number;
03429
03430     };
03431
03432
03433 /*  ======================================================================
03434     Class CcbsStatusMsg
03435     ====================================================================== */
03436
03438 class CcbsStatusMsg : public ContextMsg {
03439     public:
03440         CcbsStatusMsg(ExecutionContext* context, const CcbsStatus& ccbs_status);
03441         virtual ~CcbsStatusMsg();
03442
03443         virtual const MsgMetaData& GetMetaData() const;
03444         void SetCcbsStatus(const CcbsStatus& ccbs_status) { m_ccbs_status = ccbs_status; }
03445         const CcbsStatus& GetCcbsStatus() const { return m_ccbs_status; }
03446         virtual Message* Clone() const;
03447
03448         enum  {
03449             ID = 18561
03450             };
03451
03452     private:
03453         static const MsgMetaData m_meta_data;
03454         CcbsStatus m_ccbs_status;
03455
03456     };
03457
03458
03459 /*  ======================================================================
03460     Class CcbsResultMsg
03461     ====================================================================== */
03462
03464 class CcbsResultMsg : public ContextMsg {
03465     public:
03466         CcbsResultMsg(ExecutionContext* context, const InterrogateCcbsResult& interrogate_ccbs_result);
03467         virtual ~CcbsResultMsg();
03468
03469         virtual const MsgMetaData& GetMetaData() const;
03470         void SetInterrogateCcbsResult(const InterrogateCcbsResult& interrogate_ccbs_result) { m_interrogate_ccbs_result = interrogate_ccbs_result; }
03471         const InterrogateCcbsResult& GetInterrogateCcbsResult() const { return m_interrogate_ccbs_result; }
03472         virtual Message* Clone() const;
03473
03474         enum  {
03475             ID = 18562
03476             };
03477
03478     private:
03479         static const MsgMetaData m_meta_data;
03480         InterrogateCcbsResult m_interrogate_ccbs_result;
03481
03482     };
03483
03484
03485 /*  ======================================================================
03486     Class UssdAnswerMsg
03487     ====================================================================== */
03488
03490 class UssdAnswerMsg : public ContextMsg {
03491     public:
03492         UssdAnswerMsg(ExecutionContext* context, const Tipd& tipd, const SsOperationCode& ss_opeartion_code, const WString& control_info_string);
03493         virtual ~UssdAnswerMsg();
03494
03495         virtual const MsgMetaData& GetMetaData() const;
03496         void SetTipd(const Tipd& tipd) { m_tipd = tipd; }
03497         const Tipd& GetTipd() const { return m_tipd; }
03498         void SetSsOpeartionCode(const SsOperationCode& ss_opeartion_code) { m_ss_opeartion_code = ss_opeartion_code; }
03499         const SsOperationCode& GetSsOpeartionCode() const { return m_ss_opeartion_code; }
03500         void SetControlInfoString(const WString& control_info_string) { m_control_info_string = control_info_string; }
03501         const WString& GetControlInfoString() const { return m_control_info_string; }
03502         virtual Message* Clone() const;
03503
03504         enum  {
03505             ID = 18574
03506             };
03507
03508     private:
03509         static const MsgMetaData m_meta_data;
03510         Tipd m_tipd;
03511         SsOperationCode m_ss_opeartion_code;
03512         WString m_control_info_string;
03513
03514     };
03515
03516
03517 /*  ======================================================================
03518     Class EngineeringReportMsg
03519     ====================================================================== */
03520
03522 class EngineeringReportMsg : public ContextMsg {
03523     public:
03524         EngineeringReportMsg(ExecutionContext* context, const TestparamReportArg& report_arg);
03525         virtual ~EngineeringReportMsg();
03526
03527         virtual const MsgMetaData& GetMetaData() const;
03528         void SetReportArg(const TestparamReportArg& report_arg) { m_report_arg = report_arg; }
03529         const TestparamReportArg& GetReportArg() const { return m_report_arg; }
03530         virtual Message* Clone() const;
03531
03532         enum  {
03533             ID = 18603
03534             };
03535
03536     private:
03537         static const MsgMetaData m_meta_data;
03538         TestparamReportArg m_report_arg;
03539
03540     };
03541
03542
03543 /*  ======================================================================
03544     Class BandSelectionMsg
03545     ====================================================================== */
03546
03548 class BandSelectionMsg : public ContextMsg {
03549     public:
03550         BandSelectionMsg(ExecutionContext* context, BOOLEAN confirmed);
03551         virtual ~BandSelectionMsg();
03552
03553         virtual const MsgMetaData& GetMetaData() const;
03554         void SetConfirmed(BOOLEAN confirmed) { m_confirmed = confirmed; }
03555         BOOLEAN IsConfirmed() const { return m_confirmed; }
03556         virtual Message* Clone() const;
03557
03558         enum  {
03559             ID = 18604
03560             };
03561
03562     private:
03563         static const MsgMetaData m_meta_data;
03564         BOOLEAN m_confirmed;
03565
03566     };
03567
03568
03569 /*  ======================================================================
03570     Class HomezoneMsg
03571     ====================================================================== */
03572
03574 class HomezoneMsg : public ContextMsg {
03575     public:
03576         HomezoneMsg(ExecutionContext* context, const LineSelector& line_selector, const HomezoneIndicator& indicator, const WString& text);
03577         virtual ~HomezoneMsg();
03578
03579         virtual const MsgMetaData& GetMetaData() const;
03580         void SetLineSelector(const LineSelector& line_selector) { m_line_selector = line_selector; }
03581         const LineSelector& GetLineSelector() const { return m_line_selector; }
03582         void SetIndicator(const HomezoneIndicator& indicator) { m_indicator = indicator; }
03583         const HomezoneIndicator& GetIndicator() const { return m_indicator; }
03584         void SetText(const WString& text) { m_text = text; }
03585         const WString& GetText() const { return m_text; }
03586         virtual Message* Clone() const;
03587
03588         enum  {
03589             ID = 18605
03590             };
03591
03592     private:
03593         static const MsgMetaData m_meta_data;
03594         LineSelector m_line_selector;
03595         HomezoneIndicator m_indicator;
03596         WString m_text;
03597
03598     };
03599
03600
03601 /*  ======================================================================
03602     Class NwDiscStartIndMsg
03603     ====================================================================== */
03604
03606 class NwDiscStartIndMsg : public ContextMsg {
03607     public:
03608         NwDiscStartIndMsg(ExecutionContext* context, const CallHdl& call_hdl, const MnCause& call_clearing_cause);
03609         virtual ~NwDiscStartIndMsg();
03610
03611         virtual const MsgMetaData& GetMetaData() const;
03612         void SetCallHdl(const CallHdl& call_hdl) { m_call_hdl = call_hdl; }
03613         const CallHdl& GetCallHdl() const { return m_call_hdl; }
03614         void SetCallClearingCause(const MnCause& call_clearing_cause) { m_call_clearing_cause = call_clearing_cause; }
03615         const MnCause& GetCallClearingCause() const { return m_call_clearing_cause; }
03616         virtual Message* Clone() const;
03617
03618         enum  {
03619             ID = 18606
03620             };
03621
03622     private:
03623         static const MsgMetaData m_meta_data;
03624         CallHdl m_call_hdl;
03625         MnCause m_call_clearing_cause;
03626
03627     };
03628
03629
03630 /*  ======================================================================
03631     Class RatStateMsg
03632     ====================================================================== */
03633
03635 class RatStateMsg : public ContextMsg {
03636     public:
03637         RatStateMsg(ExecutionContext* context, const RadioAccessTechnology& radio_access_technology);
03638         virtual ~RatStateMsg();
03639
03640         virtual const MsgMetaData& GetMetaData() const;
03641         void SetRadioAccessTechnology(const RadioAccessTechnology& radio_access_technology) { m_radio_access_technology = radio_access_technology; }
03642         const RadioAccessTechnology& GetRadioAccessTechnology() const { return m_radio_access_technology; }
03643         virtual Message* Clone() const;
03644
03645         enum  {
03646             ID = 18607
03647             };
03648
03649     private:
03650         static const MsgMetaData m_meta_data;
03651         RadioAccessTechnology m_radio_access_technology;
03652
03653     };
03654
03655
03656 /*  ======================================================================
03657     Class GsmBandStateMsg
03658     ====================================================================== */
03659
03661 class GsmBandStateMsg : public ContextMsg {
03662     public:
03663         GsmBandStateMsg(ExecutionContext* context, const GsmBand& gsm_band);
03664         virtual ~GsmBandStateMsg();
03665
03666         virtual const MsgMetaData& GetMetaData() const;
03667         void SetGsmBand(const GsmBand& gsm_band) { m_gsm_band = gsm_band; }
03668         const GsmBand& GetGsmBand() const { return m_gsm_band; }
03669         virtual Message* Clone() const;
03670
03671         enum  {
03672             ID = 18608
03673             };
03674
03675     private:
03676         static const MsgMetaData m_meta_data;
03677         GsmBand m_gsm_band;
03678
03679     };
03680
03681
03682 /*  ======================================================================
03683     Class BandStatusMsg
03684     ====================================================================== */
03685
03687 class BandStatusMsg : public ContextMsg {
03688     public:
03689         BandStatusMsg(ExecutionContext* context, const GsmBandList& supported_band_list, const GsmBandList& used_band_list);
03690         virtual ~BandStatusMsg();
03691
03692         virtual const MsgMetaData& GetMetaData() const;
03693         void SetSupportedBandList(const GsmBandList& supported_band_list) { m_supported_band_list = supported_band_list; }
03694         const GsmBandList& GetSupportedBandList() const { return m_supported_band_list; }
03695         void SetUsedBandList(const GsmBandList& used_band_list) { m_used_band_list = used_band_list; }
03696         const GsmBandList& GetUsedBandList() const { return m_used_band_list; }
03697         virtual Message* Clone() const;
03698
03699         enum  {
03700             ID = 18610
03701             };
03702
03703     private:
03704         static const MsgMetaData m_meta_data;
03705         GsmBandList m_supported_band_list;
03706         GsmBandList m_used_band_list;
03707
03708     };
03709
03710
03711 /*  ======================================================================
03712     Class EngineeringModeControlResponseMsg
03713     ====================================================================== */
03714
03716 class EngineeringModeControlResponseMsg : public ContextMsg {
03717     public:
03718         EngineeringModeControlResponseMsg(ExecutionContext* context, const EngineeringModeControlResponseArg& cnf_arg);
03719         virtual ~EngineeringModeControlResponseMsg();
03720
03721         virtual const MsgMetaData& GetMetaData() const;
03722         void SetCnfArg(const EngineeringModeControlResponseArg& cnf_arg) { m_cnf_arg = cnf_arg; }
03723         const EngineeringModeControlResponseArg& GetCnfArg() const { return m_cnf_arg; }
03724         virtual Message* Clone() const;
03725
03726         enum  {
03727             ID = 18611
03728             };
03729
03730     private:
03731         static const MsgMetaData m_meta_data;
03732         EngineeringModeControlResponseArg m_cnf_arg;
03733
03734     };
03735
03736
03737 /*  ======================================================================
03738     Class RatChangeModeChangedMsg
03739     ====================================================================== */
03740
03742 class RatChangeModeChangedMsg : public ContextMsg {
03743     public:
03744         RatChangeModeChangedMsg(ExecutionContext* context, const RatChangeMode& rat_change_mode);
03745         virtual ~RatChangeModeChangedMsg();
03746
03747         virtual const MsgMetaData& GetMetaData() const;
03748         void SetRatChangeMode(const RatChangeMode& rat_change_mode) { m_rat_change_mode = rat_change_mode; }
03749         const RatChangeMode& GetRatChangeMode() const { return m_rat_change_mode; }
03750         virtual Message* Clone() const;
03751
03752         enum  {
03753             ID = 18612
03754             };
03755
03756     private:
03757         static const MsgMetaData m_meta_data;
03758         RatChangeMode m_rat_change_mode;
03759
03760     };
03761
03762
03763 /*  ======================================================================
03764     Class CellInfoMsg
03765     ====================================================================== */
03766
03768 class CellInfoMsg : public ContextMsg {
03769     public:
03770         CellInfoMsg(ExecutionContext* context, const CellInfoIndArg& arg);
03771         virtual ~CellInfoMsg();
03772
03773         virtual const MsgMetaData& GetMetaData() const;
03774         void SetArg(const CellInfoIndArg& arg) { m_arg = arg; }
03775         const CellInfoIndArg& GetArg() const { return m_arg; }
03776         virtual Message* Clone() const;
03777
03778         enum  {
03779             ID = 18801
03780             };
03781
03782     private:
03783         static const MsgMetaData m_meta_data;
03784         CellInfoIndArg m_arg;
03785
03786     };
03787
03788
03789 /*  ======================================================================
03790     Class SmsNewMessageMsg
03791     ====================================================================== */
03792
03794 class SmsNewMessageMsg : public ContextMsg {
03795     public:
03796         SmsNewMessageMsg(ExecutionContext* context, const SmsNewMessageIndArg& arg);
03797         virtual ~SmsNewMessageMsg();
03798
03799         virtual const MsgMetaData& GetMetaData() const;
03800         void SetArg(const SmsNewMessageIndArg& arg) { m_arg = arg; }
03801         const SmsNewMessageIndArg& GetArg() const { return m_arg; }
03802         virtual Message* Clone() const;
03803
03804         enum  {
03805             ID = 18900
03806             };
03807
03808     private:
03809         static const MsgMetaData m_meta_data;
03810         SmsNewMessageIndArg m_arg;
03811
03812     };
03813
03814
03815 /*  ======================================================================
03816     Class SmsNewStatusReportMsg
03817     ====================================================================== */
03818
03820 class SmsNewStatusReportMsg : public ContextMsg {
03821     public:
03822         SmsNewStatusReportMsg(ExecutionContext* context, const SmsNewStatusReportIndArg& arg);
03823         virtual ~SmsNewStatusReportMsg();
03824
03825         virtual const MsgMetaData& GetMetaData() const;
03826         void SetArg(const SmsNewStatusReportIndArg& arg) { m_arg = arg; }
03827         const SmsNewStatusReportIndArg& GetArg() const { return m_arg; }
03828         virtual Message* Clone() const;
03829
03830         enum  {
03831             ID = 18901
03832             };
03833
03834     private:
03835         static const MsgMetaData m_meta_data;
03836         SmsNewStatusReportIndArg m_arg;
03837
03838     };
03839
03840
03841 /*  ======================================================================
03842     Class SmsNewSocketDataMsg
03843     ====================================================================== */
03844
03846 class SmsNewSocketDataMsg : public ContextMsg {
03847     public:
03848         SmsNewSocketDataMsg(ExecutionContext* context, const SmsPortNo& sms_port_no, const PhoneNumber& sender_phonenumber, const DateTime& date_time, const DataCodingScheme& dcs, const SmsPortNo& sender_port_no, const PhoneNumber& sca);
03849         virtual ~SmsNewSocketDataMsg();
03850
03851         virtual const MsgMetaData& GetMetaData() const;
03852         void SetSmsPortNo(const SmsPortNo& sms_port_no) { m_sms_port_no = sms_port_no; }
03853         const SmsPortNo& GetSmsPortNo() const { return m_sms_port_no; }
03854         void SetSenderPhonenumber(const PhoneNumber& sender_phonenumber) { m_sender_phonenumber = sender_phonenumber; }
03855         const PhoneNumber& GetSenderPhonenumber() const { return m_sender_phonenumber; }
03856         void SetDateTime(const DateTime& date_time) { m_date_time = date_time; }
03857         const DateTime& GetDateTime() const { return m_date_time; }
03858         void SetDcs(const DataCodingScheme& dcs) { m_dcs = dcs; }
03859         const DataCodingScheme& GetDcs() const { return m_dcs; }
03860         void SetSenderPortNo(const SmsPortNo& sender_port_no) { m_sender_port_no = sender_port_no; }
03861         const SmsPortNo& GetSenderPortNo() const { return m_sender_port_no; }
03862         void SetSca(const PhoneNumber& sca) { m_sca = sca; }
03863         const PhoneNumber& GetSca() const { return m_sca; }
03864         virtual Message* Clone() const;
03865
03866         enum  {
03867             ID = 18902
03868             };
03869
03870     private:
03871         static const MsgMetaData m_meta_data;
03872         SmsPortNo m_sms_port_no;
03873         PhoneNumber m_sender_phonenumber;
03874         DateTime m_date_time;
03875         DataCodingScheme m_dcs;
03876         SmsPortNo m_sender_port_no;
03877         PhoneNumber m_sca;
03878
03879     };
03880
03881
03882 /*  ======================================================================
03883     Class SmsPortDataRecvMsg
03884     ====================================================================== */
03885
03887 class SmsPortDataRecvMsg : public ContextMsg {
03888     public:
03889         SmsPortDataRecvMsg(ExecutionContext* context, const SmsPortNo& sms_port_no, const PhoneNumber& sender_phonenumber);
03890         virtual ~SmsPortDataRecvMsg();
03891
03892         virtual const MsgMetaData& GetMetaData() const;
03893         void SetSmsPortNo(const SmsPortNo& sms_port_no) { m_sms_port_no = sms_port_no; }
03894         const SmsPortNo& GetSmsPortNo() const { return m_sms_port_no; }
03895         void SetSenderPhonenumber(const PhoneNumber& sender_phonenumber) { m_sender_phonenumber = sender_phonenumber; }
03896         const PhoneNumber& GetSenderPhonenumber() const { return m_sender_phonenumber; }
03897         virtual Message* Clone() const;
03898
03899         enum  {
03900             ID = 18903
03901             };
03902
03903     private:
03904         static const MsgMetaData m_meta_data;
03905         SmsPortNo m_sms_port_no;
03906         PhoneNumber m_sender_phonenumber;
03907
03908     };
03909
03910
03911 /*  ======================================================================
03912     Class SmsSendConfirmMsg
03913     ====================================================================== */
03914
03916 class SmsSendConfirmMsg : public ContextMsg {
03917     public:
03918         SmsSendConfirmMsg(ExecutionContext* context, const SmsSendCnfArg& arg);
03919         virtual ~SmsSendConfirmMsg();
03920
03921         virtual const MsgMetaData& GetMetaData() const;
03922         void SetArg(const SmsSendCnfArg& arg) { m_arg = arg; }
03923         const SmsSendCnfArg& GetArg() const { return m_arg; }
03924         virtual Message* Clone() const;
03925
03926         enum  {
03927             ID = 18910
03928             };
03929
03930     private:
03931         static const MsgMetaData m_meta_data;
03932         SmsSendCnfArg m_arg;
03933
03934     };
03935
03936
03937 /*  ======================================================================
03938     Class SmsSendRejectMsg
03939     ====================================================================== */
03940
03942 class SmsSendRejectMsg : public ContextMsg {
03943     public:
03944         SmsSendRejectMsg(ExecutionContext* context, const SmsSendRejArg& arg);
03945         virtual ~SmsSendRejectMsg();
03946
03947         virtual const MsgMetaData& GetMetaData() const;
03948         void SetArg(const SmsSendRejArg& arg) { m_arg = arg; }
03949         const SmsSendRejArg& GetArg() const { return m_arg; }
03950         virtual Message* Clone() const;
03951
03952         enum  {
03953             ID = 18911
03954             };
03955
03956     private:
03957         static const MsgMetaData m_meta_data;
03958         SmsSendRejArg m_arg;
03959
03960     };
03961
03962
03963 /*  ======================================================================
03964     Class SmsSpaceExceededMsg
03965     ====================================================================== */
03966
03968 class SmsSpaceExceededMsg : public ContextMsg {
03969     public:
03970         SmsSpaceExceededMsg(ExecutionContext* context, const Sms::WarningLevel& arg);
03971         virtual ~SmsSpaceExceededMsg();
03972
03973         virtual const MsgMetaData& GetMetaData() const;
03974         void SetArg(const Sms::WarningLevel& arg) { m_arg = arg; }
03975         const Sms::WarningLevel& GetArg() const { return m_arg; }
03976         virtual Message* Clone() const;
03977
03978         enum  {
03979             ID = 18920
03980             };
03981
03982     private:
03983         static const MsgMetaData m_meta_data;
03984         Sms::WarningLevel m_arg;
03985
03986     };
03987
03988
03989 /*  ======================================================================
03990     Class SmsSpaceAvailableMsg
03991     ====================================================================== */
03992
03994 class SmsSpaceAvailableMsg : public ContextMsg {
03995     public:
03996         SmsSpaceAvailableMsg(ExecutionContext* context);
03997         virtual ~SmsSpaceAvailableMsg();
03998
03999         virtual const MsgMetaData& GetMetaData() const;
04000         virtual Message* Clone() const;
04001
04002         enum  {
04003             ID = 18921
04004             };
04005
04006     private:
04007         static const MsgMetaData m_meta_data;
04008
04009     };
04010
04011
04012 /*  ======================================================================
04013     Class CbsNewDataMsg
04014     ====================================================================== */
04015
04017 class CbsNewDataMsg : public ContextMsg {
04018     public:
04019         CbsNewDataMsg(ExecutionContext* context, const CbsNewDataIndArg& arg);
04020         virtual ~CbsNewDataMsg();
04021
04022         virtual const MsgMetaData& GetMetaData() const;
04023         void SetArg(const CbsNewDataIndArg& arg) { m_arg = arg; }
04024         const CbsNewDataIndArg& GetArg() const { return m_arg; }
04025         virtual Message* Clone() const;
04026
04027         enum  {
04028             ID = 18922
04029             };
04030
04031     private:
04032         static const MsgMetaData m_meta_data;
04033         CbsNewDataIndArg m_arg;
04034
04035     };
04036
04037
04038 /*  ======================================================================
04039     Class SmsPrefStorageMediaChangedMsg
04040     ====================================================================== */
04041
04043 class SmsPrefStorageMediaChangedMsg : public ContextMsg {
04044     public:
04045         SmsPrefStorageMediaChangedMsg(ExecutionContext* context, const Sms::StorageType& arg);
04046         virtual ~SmsPrefStorageMediaChangedMsg();
04047
04048         virtual const MsgMetaData& GetMetaData() const;
04049         void SetArg(const Sms::StorageType& arg) { m_arg = arg; }
04050         const Sms::StorageType& GetArg() const { return m_arg; }
04051         virtual Message* Clone() const;
04052
04053         enum  {
04054             ID = 18923
04055             };
04056
04057     private:
04058         static const MsgMetaData m_meta_data;
04059         Sms::StorageType m_arg;
04060
04061     };
04062
04063
04064 /*  ======================================================================
04065     Class SmsMessageWaitingChangedMsg
04066     ====================================================================== */
04067
04069 class SmsMessageWaitingChangedMsg : public ContextMsg {
04070     public:
04071         SmsMessageWaitingChangedMsg(ExecutionContext* context);
04072         virtual ~SmsMessageWaitingChangedMsg();
04073
04074         virtual const MsgMetaData& GetMetaData() const;
04075         virtual Message* Clone() const;
04076
04077         enum  {
04078             ID = 18924
04079             };
04080
04081     private:
04082         static const MsgMetaData m_meta_data;
04083
04084     };
04085
04086
04087 /*  ======================================================================
04088     Class CbsLimitMsg
04089     ====================================================================== */
04090
04092 class CbsLimitMsg : public ContextMsg {
04093     public:
04094         CbsLimitMsg(ExecutionContext* context, UINT16 max_message_id);
04095         virtual ~CbsLimitMsg();
04096
04097         virtual const MsgMetaData& GetMetaData() const;
04098         void SetMaxMessageId(UINT16 max_message_id) { m_max_message_id = max_message_id; }
04099         UINT16 GetMaxMessageId() const { return m_max_message_id; }
04100         virtual Message* Clone() const;
04101
04102         enum  {
04103             ID = 18925
04104             };
04105
04106     private:
04107         static const MsgMetaData m_meta_data;
04108         UINT16 m_max_message_id;
04109
04110     };
04111
04112
04113 /*  ======================================================================
04114     Class PbSizeRequestMsg
04115     ====================================================================== */
04116
04118 class PbSizeRequestMsg : public ContextMsg {
04119     public:
04120         PbSizeRequestMsg(ExecutionContext* context, const MePhoneBookType& me_phone_book_type);
04121         virtual ~PbSizeRequestMsg();
04122
04123         virtual const MsgMetaData& GetMetaData() const;
04124         void SetMePhoneBookType(const MePhoneBookType& me_phone_book_type) { m_me_phone_book_type = me_phone_book_type; }
04125         const MePhoneBookType& GetMePhoneBookType() const { return m_me_phone_book_type; }
04126         virtual Message* Clone() const;
04127
04128         enum  {
04129             ID = 18926
04130             };
04131
04132     private:
04133         static const MsgMetaData m_meta_data;
04134         MePhoneBookType m_me_phone_book_type;
04135
04136     };
04137
04138
04139 /*  ======================================================================
04140     Class PbEntryRequestMsg
04141     ====================================================================== */
04142
04144 class PbEntryRequestMsg : public ContextMsg {
04145     public:
04146         PbEntryRequestMsg(ExecutionContext* context, const MePhoneBookType& me_phone_book_type, INT record_number);
04147         virtual ~PbEntryRequestMsg();
04148
04149         virtual const MsgMetaData& GetMetaData() const;
04150         void SetMePhoneBookType(const MePhoneBookType& me_phone_book_type) { m_me_phone_book_type = me_phone_book_type; }
04151         const MePhoneBookType& GetMePhoneBookType() const { return m_me_phone_book_type; }
04152         void SetRecordNumber(INT record_number) { m_record_number = record_number; }
04153         INT GetRecordNumber() const { return m_record_number; }
04154         virtual Message* Clone() const;
04155
04156         enum  {
04157             ID = 18927
04158             };
04159
04160     private:
04161         static const MsgMetaData m_meta_data;
04162         MePhoneBookType m_me_phone_book_type;
04163         INT m_record_number;
04164
04165     };
04166
04167
04168 /*  ======================================================================
04169     Class PbAlphaTagRequestMsg
04170     ====================================================================== */
04171
04173 class PbAlphaTagRequestMsg : public ContextMsg {
04174     public:
04175         PbAlphaTagRequestMsg(ExecutionContext* context, const PhoneNumber& phone_number);
04176         virtual ~PbAlphaTagRequestMsg();
04177
04178         virtual const MsgMetaData& GetMetaData() const;
04179         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
04180         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
04181         virtual Message* Clone() const;
04182
04183         enum  {
04184             ID = 18928
04185             };
04186
04187     private:
04188         static const MsgMetaData m_meta_data;
04189         PhoneNumber m_phone_number;
04190
04191     };
04192
04193
04194 /*  ======================================================================
04195     Class CallDeflectionIndMsg
04196     ====================================================================== */
04197
04199 class CallDeflectionIndMsg : public ContextMsg {
04200     public:
04201         CallDeflectionIndMsg(ExecutionContext* context, const CallDeflectionIndArg& arg);
04202         virtual ~CallDeflectionIndMsg();
04203
04204         virtual const MsgMetaData& GetMetaData() const;
04205         void SetArg(const CallDeflectionIndArg& arg) { m_arg = arg; }
04206         const CallDeflectionIndArg& GetArg() const { return m_arg; }
04207         virtual Message* Clone() const;
04208
04209         enum  {
04210             ID = 18953
04211             };
04212
04213     private:
04214         static const MsgMetaData m_meta_data;
04215         CallDeflectionIndArg m_arg;
04216
04217     };
04218
04219
04220 /*  ======================================================================
04221     Class CallDeflectionErrIndicationMsg
04222     ====================================================================== */
04223
04225 class CallDeflectionErrIndicationMsg : public ContextMsg {
04226     public:
04227         CallDeflectionErrIndicationMsg(ExecutionContext* context, const SsErrIndArg& arg);
04228         virtual ~CallDeflectionErrIndicationMsg();
04229
04230         virtual const MsgMetaData& GetMetaData() const;
04231         void SetArg(const SsErrIndArg& arg) { m_arg = arg; }
04232         const SsErrIndArg& GetArg() const { return m_arg; }
04233         virtual Message* Clone() const;
04234
04235         enum  {
04236             ID = 18954
04237             };
04238
04239     private:
04240         static const MsgMetaData m_meta_data;
04241         SsErrIndArg m_arg;
04242
04243     };
04244
04245
04246 /*  ======================================================================
04247     Class CallDeflectionRejectedMsg
04248     ====================================================================== */
04249
04251 class CallDeflectionRejectedMsg : public ContextMsg {
04252     public:
04253         CallDeflectionRejectedMsg(ExecutionContext* context, const SsRejArg& arg);
04254         virtual ~CallDeflectionRejectedMsg();
04255
04256         virtual const MsgMetaData& GetMetaData() const;
04257         void SetArg(const SsRejArg& arg) { m_arg = arg; }
04258         const SsRejArg& GetArg() const { return m_arg; }
04259         virtual Message* Clone() const;
04260
04261         enum  {
04262             ID = 18955
04263             };
04264
04265     private:
04266         static const MsgMetaData m_meta_data;
04267         SsRejArg m_arg;
04268
04269     };
04270
04271
04272 /*  ======================================================================
04273     Class CtmInfoIndMsg
04274     ====================================================================== */
04275
04277 class CtmInfoIndMsg : public ContextMsg {
04278     public:
04279         CtmInfoIndMsg(ExecutionContext* context, const CallHdl& call_hdl, BOOLEAN ctm);
04280         virtual ~CtmInfoIndMsg();
04281
04282         virtual const MsgMetaData& GetMetaData() const;
04283         void SetCallHdl(const CallHdl& call_hdl) { m_call_hdl = call_hdl; }
04284         const CallHdl& GetCallHdl() const { return m_call_hdl; }
04285         void SetCtm(BOOLEAN ctm) { m_ctm = ctm; }
04286         BOOLEAN IsCtm() const { return m_ctm; }
04287         virtual Message* Clone() const;
04288
04289         enum  {
04290             ID = 18956
04291             };
04292
04293     private:
04294         static const MsgMetaData m_meta_data;
04295         CallHdl m_call_hdl;
04296         BOOLEAN m_ctm;
04297
04298     };
04299
04300
04301 /*  ======================================================================
04302     Class SsRequestSentMsg
04303     ====================================================================== */
04304
04306 class SsRequestSentMsg : public SsMessage {
04307     public:
04308         SsRequestSentMsg(ExecutionContext* context, const WString& ss_control_seq, const SsCode& ss_code, const ServiceGroup& basic_service, const SsOperationCode& operation_code, const WString& parameter1, const WString& parameter2, const WString& parameter3);
04309         virtual ~SsRequestSentMsg();
04310
04311         virtual const MsgMetaData& GetMetaData() const;
04312         const WString& GetSsControlSeq() const { return m_ss_control_seq; }
04313         const SsCode& GetSsCode() const { return m_ss_code; }
04314         const ServiceGroup& GetBasicService() const { return m_basic_service; }
04315         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
04316         const WString& GetParameter1() const { return m_parameter1; }
04317         const WString& GetParameter2() const { return m_parameter2; }
04318         const WString& GetParameter3() const { return m_parameter3; }
04319         virtual Message* Clone() const;
04320
04321         enum  {
04322             ID = 18557
04323             };
04324
04325     private:
04326         static const MsgMetaData m_meta_data;
04327         WString m_ss_control_seq;
04328         SsCode m_ss_code;
04329         ServiceGroup m_basic_service;
04330         SsOperationCode m_operation_code;
04331         WString m_parameter1;
04332         WString m_parameter2;
04333         WString m_parameter3;
04334
04335     };
04336
04337
04338 /*  ======================================================================
04339     Class SsRequestAcceptedMsg
04340     ====================================================================== */
04341
04343 class SsRequestAcceptedMsg : public SsMessage {
04344     public:
04345         SsRequestAcceptedMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code, const ServiceGroup& basic_service, const SsOperationCode& operation_code, const WString& parameter1, const WString& parameter2, const WString& parameter3, const WString& ss_control_seq);
04346         virtual ~SsRequestAcceptedMsg();
04347
04348         virtual const MsgMetaData& GetMetaData() const;
04349         const Tipd& GetTipd() const { return m_tipd; }
04350         const SsCode& GetSsCode() const { return m_ss_code; }
04351         const ServiceGroup& GetBasicService() const { return m_basic_service; }
04352         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
04353         const WString& GetParameter1() const { return m_parameter1; }
04354         const WString& GetParameter2() const { return m_parameter2; }
04355         const WString& GetParameter3() const { return m_parameter3; }
04356         const WString& GetSsControlSeq() const { return m_ss_control_seq; }
04357         virtual Message* Clone() const;
04358
04359         enum  {
04360             ID = 18517
04361             };
04362
04363     private:
04364         static const MsgMetaData m_meta_data;
04365         Tipd m_tipd;
04366         SsCode m_ss_code;
04367         ServiceGroup m_basic_service;
04368         SsOperationCode m_operation_code;
04369         WString m_parameter1;
04370         WString m_parameter2;
04371         WString m_parameter3;
04372         WString m_ss_control_seq;
04373
04374     };
04375
04376
04377 /*  ======================================================================
04378     Class SsRequestRejectedMsg
04379     ====================================================================== */
04380
04382 class SsRequestRejectedMsg : public SsMessage {
04383     public:
04384         SsRequestRejectedMsg(ExecutionContext* context, const SsApiRc& error_code, const SsCode& ss_code, const ServiceGroup& basic_service, const SsOperationCode& operation_code, const WString& parameter1, const WString& parameter2, const WString& parameter3, const CallErrorCause& cause);
04385         virtual ~SsRequestRejectedMsg();
04386
04387         virtual const MsgMetaData& GetMetaData() const;
04388         const SsApiRc& GetErrorCode() const { return m_error_code; }
04389         const SsCode& GetSsCode() const { return m_ss_code; }
04390         const ServiceGroup& GetBasicService() const { return m_basic_service; }
04391         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
04392         const WString& GetParameter1() const { return m_parameter1; }
04393         const WString& GetParameter2() const { return m_parameter2; }
04394         const WString& GetParameter3() const { return m_parameter3; }
04395         const CallErrorCause& GetCause() const { return m_cause; }
04396         virtual Message* Clone() const;
04397
04398         enum  {
04399             ID = 18518
04400             };
04401
04402     private:
04403         static const MsgMetaData m_meta_data;
04404         SsApiRc m_error_code;
04405         SsCode m_ss_code;
04406         ServiceGroup m_basic_service;
04407         SsOperationCode m_operation_code;
04408         WString m_parameter1;
04409         WString m_parameter2;
04410         WString m_parameter3;
04411         CallErrorCause m_cause;
04412
04413     };
04414
04415
04416 /*  ======================================================================
04417     Class CallWaitingActivatedMsg
04418     ====================================================================== */
04419
04421 class CallWaitingActivatedMsg : public SsMessage {
04422     public:
04423         CallWaitingActivatedMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status, const Vector<SsGroup>& basic_service_list, const ServiceGroup& param_basic_service);
04424         virtual ~CallWaitingActivatedMsg();
04425
04426         virtual const MsgMetaData& GetMetaData() const;
04427         const Tipd& GetTipd() const { return m_tipd; }
04428         const SsStatus& GetSsStatus() const { return m_ss_status; }
04429         const Vector<SsGroup>& GetBasicServiceList() const { return m_basic_service_list; }
04430         const ServiceGroup& GetParamBasicService() const { return m_param_basic_service; }
04431         virtual Message* Clone() const;
04432
04433         enum  {
04434             ID = 18519
04435             };
04436
04437     private:
04438         static const MsgMetaData m_meta_data;
04439         Tipd m_tipd;
04440         SsStatus m_ss_status;
04441         Vector<SsGroup> m_basic_service_list;
04442         ServiceGroup m_param_basic_service;
04443
04444     };
04445
04446
04447 /*  ======================================================================
04448     Class CallWaitingDeactivatedMsg
04449     ====================================================================== */
04450
04452 class CallWaitingDeactivatedMsg : public SsMessage {
04453     public:
04454         CallWaitingDeactivatedMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status, const Vector<SsGroup>& basic_service_list, const ServiceGroup& param_basic_service);
04455         virtual ~CallWaitingDeactivatedMsg();
04456
04457         virtual const MsgMetaData& GetMetaData() const;
04458         const Tipd& GetTipd() const { return m_tipd; }
04459         const SsStatus& GetSsStatus() const { return m_ss_status; }
04460         const Vector<SsGroup>& GetBasicServiceList() const { return m_basic_service_list; }
04461         const ServiceGroup& GetParamBasicService() const { return m_param_basic_service; }
04462         virtual Message* Clone() const;
04463
04464         enum  {
04465             ID = 18520
04466             };
04467
04468     private:
04469         static const MsgMetaData m_meta_data;
04470         Tipd m_tipd;
04471         SsStatus m_ss_status;
04472         Vector<SsGroup> m_basic_service_list;
04473         ServiceGroup m_param_basic_service;
04474
04475     };
04476
04477
04478 /*  ======================================================================
04479     Class CallWaitingStatusMsg
04480     ====================================================================== */
04481
04483 class CallWaitingStatusMsg : public SsMessage {
04484     public:
04485         CallWaitingStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status, const Vector<SsGroup>& basic_service_list);
04486         virtual ~CallWaitingStatusMsg();
04487
04488         virtual const MsgMetaData& GetMetaData() const;
04489         const Tipd& GetTipd() const { return m_tipd; }
04490         const SsStatus& GetSsStatus() const { return m_ss_status; }
04491         const Vector<SsGroup>& GetBasicServiceList() const { return m_basic_service_list; }
04492         virtual Message* Clone() const;
04493
04494         enum  {
04495             ID = 18521
04496             };
04497
04498     private:
04499         static const MsgMetaData m_meta_data;
04500         Tipd m_tipd;
04501         SsStatus m_ss_status;
04502         Vector<SsGroup> m_basic_service_list;
04503
04504     };
04505
04506
04507 /*  ======================================================================
04508     Class EmlppRegisteredMsg
04509     ====================================================================== */
04510
04512 class EmlppRegisteredMsg : public SsMessage {
04513     public:
04514         EmlppRegisteredMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status, const EmlppPriorityLevel& default_priority);
04515         virtual ~EmlppRegisteredMsg();
04516
04517         virtual const MsgMetaData& GetMetaData() const;
04518         const Tipd& GetTipd() const { return m_tipd; }
04519         const SsStatus& GetSsStatus() const { return m_ss_status; }
04520         const EmlppPriorityLevel& GetDefaultPriority() const { return m_default_priority; }
04521         virtual Message* Clone() const;
04522
04523         enum  {
04524             ID = 18565
04525             };
04526
04527     private:
04528         static const MsgMetaData m_meta_data;
04529         Tipd m_tipd;
04530         SsStatus m_ss_status;
04531         EmlppPriorityLevel m_default_priority;
04532
04533     };
04534
04535
04536 /*  ======================================================================
04537     Class EmlppStatusMsg
04538     ====================================================================== */
04539
04541 class EmlppStatusMsg : public SsMessage {
04542     public:
04543         EmlppStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status, const EmlppPriorityLevel& default_priority, const EmlppPriorityLevel& max_entitled_priority);
04544         virtual ~EmlppStatusMsg();
04545
04546         virtual const MsgMetaData& GetMetaData() const;
04547         const Tipd& GetTipd() const { return m_tipd; }
04548         const SsStatus& GetSsStatus() const { return m_ss_status; }
04549         const EmlppPriorityLevel& GetDefaultPriority() const { return m_default_priority; }
04550         const EmlppPriorityLevel& GetMaxEntitledPriority() const { return m_max_entitled_priority; }
04551         virtual Message* Clone() const;
04552
04553         enum  {
04554             ID = 18566
04555             };
04556
04557     private:
04558         static const MsgMetaData m_meta_data;
04559         Tipd m_tipd;
04560         SsStatus m_ss_status;
04561         EmlppPriorityLevel m_default_priority;
04562         EmlppPriorityLevel m_max_entitled_priority;
04563
04564     };
04565
04566
04567 /*  ======================================================================
04568     Class NetworkSsErrorMsg
04569     ====================================================================== */
04570
04572 class NetworkSsErrorMsg : public SsMessage {
04573     public:
04574         NetworkSsErrorMsg(ExecutionContext* context, const Tipd& tipd, const SsErrorCode& error_code, const SsCode& ss_code, const ServiceGroup& basic_service, const SsOperationCode& operation_code);
04575         virtual ~NetworkSsErrorMsg();
04576
04577         virtual const MsgMetaData& GetMetaData() const;
04578         const Tipd& GetTipd() const { return m_tipd; }
04579         const SsErrorCode& GetErrorCode() const { return m_error_code; }
04580         const SsCode& GetSsCode() const { return m_ss_code; }
04581         const ServiceGroup& GetBasicService() const { return m_basic_service; }
04582         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
04583         virtual Message* Clone() const;
04584
04585         enum  {
04586             ID = 18522
04587             };
04588
04589     private:
04590         static const MsgMetaData m_meta_data;
04591         Tipd m_tipd;
04592         SsErrorCode m_error_code;
04593         SsCode m_ss_code;
04594         ServiceGroup m_basic_service;
04595         SsOperationCode m_operation_code;
04596
04597     };
04598
04599
04600 /*  ======================================================================
04601     Class NetworkSsRejectedMsg
04602     ====================================================================== */
04603
04605 class NetworkSsRejectedMsg : public SsMessage {
04606     public:
04607         NetworkSsRejectedMsg(ExecutionContext* context, const Tipd& tipd, const TaggedProblemCode& tagged_problem_code, const SsCode& ss_code, const ServiceGroup& basic_service, const SsOperationCode& operation_code);
04608         virtual ~NetworkSsRejectedMsg();
04609
04610         virtual const MsgMetaData& GetMetaData() const;
04611         const Tipd& GetTipd() const { return m_tipd; }
04612         const TaggedProblemCode& GetTaggedProblemCode() const { return m_tagged_problem_code; }
04613         const SsCode& GetSsCode() const { return m_ss_code; }
04614         const ServiceGroup& GetBasicService() const { return m_basic_service; }
04615         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
04616         virtual Message* Clone() const;
04617
04618         enum  {
04619             ID = 18523
04620             };
04621
04622     private:
04623         static const MsgMetaData m_meta_data;
04624         Tipd m_tipd;
04625         TaggedProblemCode m_tagged_problem_code;
04626         SsCode m_ss_code;
04627         ServiceGroup m_basic_service;
04628         SsOperationCode m_operation_code;
04629
04630     };
04631
04632
04633 /*  ======================================================================
04634     Class StackSsRejectedMsg
04635     ====================================================================== */
04636
04638 class StackSsRejectedMsg : public SsMessage {
04639     public:
04640         StackSsRejectedMsg(ExecutionContext* context, const Tipd& tipd, const CallErrorCause& cause, const SsCode& ss_code, const ServiceGroup& basic_service, const SsOperationCode& operation_code);
04641         virtual ~StackSsRejectedMsg();
04642
04643         virtual const MsgMetaData& GetMetaData() const;
04644         const Tipd& GetTipd() const { return m_tipd; }
04645         const CallErrorCause& GetCause() const { return m_cause; }
04646         const SsCode& GetSsCode() const { return m_ss_code; }
04647         const ServiceGroup& GetBasicService() const { return m_basic_service; }
04648         const SsOperationCode& GetOperationCode() const { return m_operation_code; }
04649         virtual Message* Clone() const;
04650
04651         enum  {
04652             ID = 18558
04653             };
04654
04655     private:
04656         static const MsgMetaData m_meta_data;
04657         Tipd m_tipd;
04658         CallErrorCause m_cause;
04659         SsCode m_ss_code;
04660         ServiceGroup m_basic_service;
04661         SsOperationCode m_operation_code;
04662
04663     };
04664
04665
04666 /*  ======================================================================
04667     Class ClirNotSurpressedMsg
04668     ====================================================================== */
04669
04671 class ClirNotSurpressedMsg : public SsMessage {
04672     public:
04673         ClirNotSurpressedMsg(ExecutionContext* context, const Tipd& tipd);
04674         virtual ~ClirNotSurpressedMsg();
04675
04676         virtual const MsgMetaData& GetMetaData() const;
04677         const Tipd& GetTipd() const { return m_tipd; }
04678         virtual Message* Clone() const;
04679
04680         enum  {
04681             ID = 18524
04682             };
04683
04684     private:
04685         static const MsgMetaData m_meta_data;
04686         Tipd m_tipd;
04687
04688     };
04689
04690
04691 /*  ======================================================================
04692     Class CallForwardingActiveMsg
04693     ====================================================================== */
04694
04696 class CallForwardingActiveMsg : public SsMessage {
04697     public:
04698         CallForwardingActiveMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code);
04699         virtual ~CallForwardingActiveMsg();
04700
04701         virtual const MsgMetaData& GetMetaData() const;
04702         const Tipd& GetTipd() const { return m_tipd; }
04703         const SsCode& GetSsCode() const { return m_ss_code; }
04704         virtual Message* Clone() const;
04705
04706         enum  {
04707             ID = 18525
04708             };
04709
04710     private:
04711         static const MsgMetaData m_meta_data;
04712         Tipd m_tipd;
04713         SsCode m_ss_code;
04714
04715     };
04716
04717
04718 /*  ======================================================================
04719     Class CallHeldMsg
04720     ====================================================================== */
04721
04723 class CallHeldMsg : public SsMessage {
04724     public:
04725         CallHeldMsg(ExecutionContext* context, const Tipd& tipd);
04726         virtual ~CallHeldMsg();
04727
04728         virtual const MsgMetaData& GetMetaData() const;
04729         const Tipd& GetTipd() const { return m_tipd; }
04730         virtual Message* Clone() const;
04731
04732         enum  {
04733             ID = 18526
04734             };
04735
04736     private:
04737         static const MsgMetaData m_meta_data;
04738         Tipd m_tipd;
04739
04740     };
04741
04742
04743 /*  ======================================================================
04744     Class CallRetrievedMsg
04745     ====================================================================== */
04746
04748 class CallRetrievedMsg : public SsMessage {
04749     public:
04750         CallRetrievedMsg(ExecutionContext* context, const Tipd& tipd);
04751         virtual ~CallRetrievedMsg();
04752
04753         virtual const MsgMetaData& GetMetaData() const;
04754         const Tipd& GetTipd() const { return m_tipd; }
04755         virtual Message* Clone() const;
04756
04757         enum  {
04758             ID = 18527
04759             };
04760
04761     private:
04762         static const MsgMetaData m_meta_data;
04763         Tipd m_tipd;
04764
04765     };
04766
04767
04768 /*  ======================================================================
04769     Class CallIsWaitingMsg
04770     ====================================================================== */
04771
04773 class CallIsWaitingMsg : public SsMessage {
04774     public:
04775         CallIsWaitingMsg(ExecutionContext* context, const Tipd& tipd);
04776         virtual ~CallIsWaitingMsg();
04777
04778         virtual const MsgMetaData& GetMetaData() const;
04779         const Tipd& GetTipd() const { return m_tipd; }
04780         virtual Message* Clone() const;
04781
04782         enum  {
04783             ID = 18528
04784             };
04785
04786     private:
04787         static const MsgMetaData m_meta_data;
04788         Tipd m_tipd;
04789
04790     };
04791
04792
04793 /*  ======================================================================
04794     Class CallBarredMsg
04795     ====================================================================== */
04796
04798 class CallBarredMsg : public SsMessage {
04799     public:
04800         CallBarredMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code, const SsStatus& ss_status);
04801         virtual ~CallBarredMsg();
04802
04803         virtual const MsgMetaData& GetMetaData() const;
04804         const Tipd& GetTipd() const { return m_tipd; }
04805         const SsCode& GetSsCode() const { return m_ss_code; }
04806         const SsStatus& GetSsStatus() const { return m_ss_status; }
04807         virtual Message* Clone() const;
04808
04809         enum  {
04810             ID = 18560
04811             };
04812
04813     private:
04814         static const MsgMetaData m_meta_data;
04815         Tipd m_tipd;
04816         SsCode m_ss_code;
04817         SsStatus m_ss_status;
04818
04819     };
04820
04821
04822 /*  ======================================================================
04823     Class ForwardedCallIncomingMsg
04824     ====================================================================== */
04825
04827 class ForwardedCallIncomingMsg : public SsMessage {
04828     public:
04829         ForwardedCallIncomingMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code);
04830         virtual ~ForwardedCallIncomingMsg();
04831
04832         virtual const MsgMetaData& GetMetaData() const;
04833         const Tipd& GetTipd() const { return m_tipd; }
04834         const SsCode& GetSsCode() const { return m_ss_code; }
04835         virtual Message* Clone() const;
04836
04837         enum  {
04838             ID = 18529
04839             };
04840
04841     private:
04842         static const MsgMetaData m_meta_data;
04843         Tipd m_tipd;
04844         SsCode m_ss_code;
04845
04846     };
04847
04848
04849 /*  ======================================================================
04850     Class HlrDataCorruptedMsg
04851     ====================================================================== */
04852
04854 class HlrDataCorruptedMsg : public SsMessage {
04855     public:
04856         HlrDataCorruptedMsg(ExecutionContext* context, const Tipd& tipd);
04857         virtual ~HlrDataCorruptedMsg();
04858
04859         virtual const MsgMetaData& GetMetaData() const;
04860         const Tipd& GetTipd() const { return m_tipd; }
04861         virtual Message* Clone() const;
04862
04863         enum  {
04864             ID = 18530
04865             };
04866
04867     private:
04868         static const MsgMetaData m_meta_data;
04869         Tipd m_tipd;
04870
04871     };
04872
04873
04874 /*  ======================================================================
04875     Class CugCallMsg
04876     ====================================================================== */
04877
04879 class CugCallMsg : public SsMessage {
04880     public:
04881         CugCallMsg(ExecutionContext* context, const Tipd& tipd, INT cug_index);
04882         virtual ~CugCallMsg();
04883
04884         virtual const MsgMetaData& GetMetaData() const;
04885         const Tipd& GetTipd() const { return m_tipd; }
04886         INT GetCugIndex() const { return m_cug_index; }
04887         virtual Message* Clone() const;
04888
04889         enum  {
04890             ID = 18531
04891             };
04892
04893     private:
04894         static const MsgMetaData m_meta_data;
04895         Tipd m_tipd;
04896         INT m_cug_index;
04897
04898     };
04899
04900
04901 /*  ======================================================================
04902     Class OutgoingCallForwardedMsg
04903     ====================================================================== */
04904
04906 class OutgoingCallForwardedMsg : public SsMessage {
04907     public:
04908         OutgoingCallForwardedMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code);
04909         virtual ~OutgoingCallForwardedMsg();
04910
04911         virtual const MsgMetaData& GetMetaData() const;
04912         const Tipd& GetTipd() const { return m_tipd; }
04913         const SsCode& GetSsCode() const { return m_ss_code; }
04914         virtual Message* Clone() const;
04915
04916         enum  {
04917             ID = 18532
04918             };
04919
04920     private:
04921         static const MsgMetaData m_meta_data;
04922         Tipd m_tipd;
04923         SsCode m_ss_code;
04924
04925     };
04926
04927
04928 /*  ======================================================================
04929     Class IncomingCallForwardedMsg
04930     ====================================================================== */
04931
04933 class IncomingCallForwardedMsg : public SsMessage {
04934     public:
04935         IncomingCallForwardedMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code);
04936         virtual ~IncomingCallForwardedMsg();
04937
04938         virtual const MsgMetaData& GetMetaData() const;
04939         const Tipd& GetTipd() const { return m_tipd; }
04940         const SsCode& GetSsCode() const { return m_ss_code; }
04941         virtual Message* Clone() const;
04942
04943         enum  {
04944             ID = 18533
04945             };
04946
04947     private:
04948         static const MsgMetaData m_meta_data;
04949         Tipd m_tipd;
04950         SsCode m_ss_code;
04951
04952     };
04953
04954
04955 /*  ======================================================================
04956     Class MultiPartyCallInvokedMsg
04957     ====================================================================== */
04958
04960 class MultiPartyCallInvokedMsg : public SsMessage {
04961     public:
04962         MultiPartyCallInvokedMsg(ExecutionContext* context, const Tipd& tipd);
04963         virtual ~MultiPartyCallInvokedMsg();
04964
04965         virtual const MsgMetaData& GetMetaData() const;
04966         const Tipd& GetTipd() const { return m_tipd; }
04967         virtual Message* Clone() const;
04968
04969         enum  {
04970             ID = 18534
04971             };
04972
04973     private:
04974         static const MsgMetaData m_meta_data;
04975         Tipd m_tipd;
04976
04977     };
04978
04979
04980 /*  ======================================================================
04981     Class EctActiveMsg
04982     ====================================================================== */
04983
04985 class EctActiveMsg : public SsMessage {
04986     public:
04987         EctActiveMsg(ExecutionContext* context, const Tipd& tipd, const RdnChoice& rdn_selector, const PhoneNumber& address, const PhoneNumber& sub_address);
04988         virtual ~EctActiveMsg();
04989
04990         virtual const MsgMetaData& GetMetaData() const;
04991         const Tipd& GetTipd() const { return m_tipd; }
04992         const RdnChoice& GetRdnSelector() const { return m_rdn_selector; }
04993         const PhoneNumber& GetAddress() const { return m_address; }
04994         const PhoneNumber& GetSubAddress() const { return m_sub_address; }
04995         virtual Message* Clone() const;
04996
04997         enum  {
04998             ID = 18535
04999             };
05000
05001     private:
05002         static const MsgMetaData m_meta_data;
05003         Tipd m_tipd;
05004         RdnChoice m_rdn_selector;
05005         PhoneNumber m_address;
05006         PhoneNumber m_sub_address;
05007
05008     };
05009
05010
05011 /*  ======================================================================
05012     Class EctAlertingMsg
05013     ====================================================================== */
05014
05016 class EctAlertingMsg : public SsMessage {
05017     public:
05018         EctAlertingMsg(ExecutionContext* context, const Tipd& tipd);
05019         virtual ~EctAlertingMsg();
05020
05021         virtual const MsgMetaData& GetMetaData() const;
05022         const Tipd& GetTipd() const { return m_tipd; }
05023         virtual Message* Clone() const;
05024
05025         enum  {
05026             ID = 18536
05027             };
05028
05029     private:
05030         static const MsgMetaData m_meta_data;
05031         Tipd m_tipd;
05032
05033     };
05034
05035
05036 /*  ======================================================================
05037     Class CnapInfoReceivedMsg
05038     ====================================================================== */
05039
05041 class CnapInfoReceivedMsg : public SsMessage {
05042     public:
05043         CnapInfoReceivedMsg(ExecutionContext* context, const Tipd& tipd, const WString& cnap_name, const CnameChoice& presentation_indicator, const DataCodingScheme& data_coding_scheme);
05044         virtual ~CnapInfoReceivedMsg();
05045
05046         virtual const MsgMetaData& GetMetaData() const;
05047         const Tipd& GetTipd() const { return m_tipd; }
05048         const WString& GetCnapName() const { return m_cnap_name; }
05049         const CnameChoice& GetPresentationIndicator() const { return m_presentation_indicator; }
05050         const DataCodingScheme& GetDataCodingScheme() const { return m_data_coding_scheme; }
05051         virtual Message* Clone() const;
05052
05053         enum  {
05054             ID = 18564
05055             };
05056
05057     private:
05058         static const MsgMetaData m_meta_data;
05059         Tipd m_tipd;
05060         WString m_cnap_name;
05061         CnameChoice m_presentation_indicator;
05062         DataCodingScheme m_data_coding_scheme;
05063
05064     };
05065
05066
05067 /*  ======================================================================
05068     Class CallForwardingActivatedMsg
05069     ====================================================================== */
05070
05072 class CallForwardingActivatedMsg : public SsMessage {
05073     public:
05074         CallForwardingActivatedMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code, const Vector<ForwardingFeature>& forwarding_features, const SsCode& parameter_ss_code, const ServiceGroup& parameter_basic_service, const PhoneNumber& parameter_phonenumber, UINT parameter_time_out);
05075         virtual ~CallForwardingActivatedMsg();
05076
05077         virtual const MsgMetaData& GetMetaData() const;
05078         const Tipd& GetTipd() const { return m_tipd; }
05079         const SsCode& GetSsCode() const { return m_ss_code; }
05080         const Vector<ForwardingFeature>& GetForwardingFeatures() const { return m_forwarding_features; }
05081         const SsCode& GetParameterSsCode() const { return m_parameter_ss_code; }
05082         const ServiceGroup& GetParameterBasicService() const { return m_parameter_basic_service; }
05083         const PhoneNumber& GetParameterPhonenumber() const { return m_parameter_phonenumber; }
05084         UINT GetParameterTimeOut() const { return m_parameter_time_out; }
05085         virtual Message* Clone() const;
05086
05087         enum  {
05088             ID = 18537
05089             };
05090
05091     private:
05092         static const MsgMetaData m_meta_data;
05093         Tipd m_tipd;
05094         SsCode m_ss_code;
05095         Vector<ForwardingFeature> m_forwarding_features;
05096         SsCode m_parameter_ss_code;
05097         ServiceGroup m_parameter_basic_service;
05098         PhoneNumber m_parameter_phonenumber;
05099         UINT m_parameter_time_out;
05100
05101     };
05102
05103
05104 /*  ======================================================================
05105     Class CallForwardingDeactivatedMsg
05106     ====================================================================== */
05107
05109 class CallForwardingDeactivatedMsg : public SsMessage {
05110     public:
05111         CallForwardingDeactivatedMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code, const Vector<ForwardingFeature>& forwarding_features, const SsCode& parameter_ss_code, const ServiceGroup& parameter_basic_service);
05112         virtual ~CallForwardingDeactivatedMsg();
05113
05114         virtual const MsgMetaData& GetMetaData() const;
05115         const Tipd& GetTipd() const { return m_tipd; }
05116         const SsCode& GetSsCode() const { return m_ss_code; }
05117         const Vector<ForwardingFeature>& GetForwardingFeatures() const { return m_forwarding_features; }
05118         const SsCode& GetParameterSsCode() const { return m_parameter_ss_code; }
05119         const ServiceGroup& GetParameterBasicService() const { return m_parameter_basic_service; }
05120         virtual Message* Clone() const;
05121
05122         enum  {
05123             ID = 18538
05124             };
05125
05126     private:
05127         static const MsgMetaData m_meta_data;
05128         Tipd m_tipd;
05129         SsCode m_ss_code;
05130         Vector<ForwardingFeature> m_forwarding_features;
05131         SsCode m_parameter_ss_code;
05132         ServiceGroup m_parameter_basic_service;
05133
05134     };
05135
05136
05137 /*  ======================================================================
05138     Class CallForwardingStatusMsg
05139     ====================================================================== */
05140
05142 class CallForwardingStatusMsg : public SsMessage {
05143     public:
05144         CallForwardingStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status, const Vector<ForwardingFeature>& forwarding_features, const SsCode& parameter_ss_code, const ServiceGroup& parameter_basic_service);
05145         virtual ~CallForwardingStatusMsg();
05146
05147         virtual const MsgMetaData& GetMetaData() const;
05148         const Tipd& GetTipd() const { return m_tipd; }
05149         const SsStatus& GetSsStatus() const { return m_ss_status; }
05150         const Vector<ForwardingFeature>& GetForwardingFeatures() const { return m_forwarding_features; }
05151         const SsCode& GetParameterSsCode() const { return m_parameter_ss_code; }
05152         const ServiceGroup& GetParameterBasicService() const { return m_parameter_basic_service; }
05153         virtual Message* Clone() const;
05154
05155         enum  {
05156             ID = 18539
05157             };
05158
05159     private:
05160         static const MsgMetaData m_meta_data;
05161         Tipd m_tipd;
05162         SsStatus m_ss_status;
05163         Vector<ForwardingFeature> m_forwarding_features;
05164         SsCode m_parameter_ss_code;
05165         ServiceGroup m_parameter_basic_service;
05166
05167     };
05168
05169
05170 /*  ======================================================================
05171     Class CallForwardingRegisteredMsg
05172     ====================================================================== */
05173
05175 class CallForwardingRegisteredMsg : public SsMessage {
05176     public:
05177         CallForwardingRegisteredMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code, const Vector<ForwardingFeature>& forwarding_features, const SsCode& parameter_ss_code, const ServiceGroup& parameter_basic_service, const PhoneNumber& parameter_phonenumber, UINT parameter_time_out);
05178         virtual ~CallForwardingRegisteredMsg();
05179
05180         virtual const MsgMetaData& GetMetaData() const;
05181         const Tipd& GetTipd() const { return m_tipd; }
05182         const SsCode& GetSsCode() const { return m_ss_code; }
05183         const Vector<ForwardingFeature>& GetForwardingFeatures() const { return m_forwarding_features; }
05184         const SsCode& GetParameterSsCode() const { return m_parameter_ss_code; }
05185         const ServiceGroup& GetParameterBasicService() const { return m_parameter_basic_service; }
05186         const PhoneNumber& GetParameterPhonenumber() const { return m_parameter_phonenumber; }
05187         UINT GetParameterTimeOut() const { return m_parameter_time_out; }
05188         virtual Message* Clone() const;
05189
05190         enum  {
05191             ID = 18540
05192             };
05193
05194     private:
05195         static const MsgMetaData m_meta_data;
05196         Tipd m_tipd;
05197         SsCode m_ss_code;
05198         Vector<ForwardingFeature> m_forwarding_features;
05199         SsCode m_parameter_ss_code;
05200         ServiceGroup m_parameter_basic_service;
05201         PhoneNumber m_parameter_phonenumber;
05202         UINT m_parameter_time_out;
05203
05204     };
05205
05206
05207 /*  ======================================================================
05208     Class CallForwardingErasedMsg
05209     ====================================================================== */
05210
05212 class CallForwardingErasedMsg : public SsMessage {
05213     public:
05214         CallForwardingErasedMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code, const Vector<ForwardingFeature>& forwarding_features, const SsCode& parameter_ss_code, const ServiceGroup& parameter_basic_service);
05215         virtual ~CallForwardingErasedMsg();
05216
05217         virtual const MsgMetaData& GetMetaData() const;
05218         const Tipd& GetTipd() const { return m_tipd; }
05219         const SsCode& GetSsCode() const { return m_ss_code; }
05220         const Vector<ForwardingFeature>& GetForwardingFeatures() const { return m_forwarding_features; }
05221         const SsCode& GetParameterSsCode() const { return m_parameter_ss_code; }
05222         const ServiceGroup& GetParameterBasicService() const { return m_parameter_basic_service; }
05223         virtual Message* Clone() const;
05224
05225         enum  {
05226             ID = 18541
05227             };
05228
05229     private:
05230         static const MsgMetaData m_meta_data;
05231         Tipd m_tipd;
05232         SsCode m_ss_code;
05233         Vector<ForwardingFeature> m_forwarding_features;
05234         SsCode m_parameter_ss_code;
05235         ServiceGroup m_parameter_basic_service;
05236
05237     };
05238
05239
05240 /*  ======================================================================
05241     Class CallBarringActivatedMsg
05242     ====================================================================== */
05243
05245 class CallBarringActivatedMsg : public SsMessage {
05246     public:
05247         CallBarringActivatedMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code, const Vector<CallBarringFeature>& call_barring_features, const SsCode& parameter_ss_code, const ServiceGroup& parameter_basic_service);
05248         virtual ~CallBarringActivatedMsg();
05249
05250         virtual const MsgMetaData& GetMetaData() const;
05251         const Tipd& GetTipd() const { return m_tipd; }
05252         const SsCode& GetSsCode() const { return m_ss_code; }
05253         const Vector<CallBarringFeature>& GetCallBarringFeatures() const { return m_call_barring_features; }
05254         const SsCode& GetParameterSsCode() const { return m_parameter_ss_code; }
05255         const ServiceGroup& GetParameterBasicService() const { return m_parameter_basic_service; }
05256         virtual Message* Clone() const;
05257
05258         enum  {
05259             ID = 18542
05260             };
05261
05262     private:
05263         static const MsgMetaData m_meta_data;
05264         Tipd m_tipd;
05265         SsCode m_ss_code;
05266         Vector<CallBarringFeature> m_call_barring_features;
05267         SsCode m_parameter_ss_code;
05268         ServiceGroup m_parameter_basic_service;
05269
05270     };
05271
05272
05273 /*  ======================================================================
05274     Class CallBarringDeactivatedMsg
05275     ====================================================================== */
05276
05278 class CallBarringDeactivatedMsg : public SsMessage {
05279     public:
05280         CallBarringDeactivatedMsg(ExecutionContext* context, const Tipd& tipd, const SsCode& ss_code, const Vector<CallBarringFeature>& call_barring_features, const SsCode& parameter_ss_code, const ServiceGroup& parameter_basic_service);
05281         virtual ~CallBarringDeactivatedMsg();
05282
05283         virtual const MsgMetaData& GetMetaData() const;
05284         const Tipd& GetTipd() const { return m_tipd; }
05285         const SsCode& GetSsCode() const { return m_ss_code; }
05286         const Vector<CallBarringFeature>& GetCallBarringFeatures() const { return m_call_barring_features; }
05287         const SsCode& GetParameterSsCode() const { return m_parameter_ss_code; }
05288         const ServiceGroup& GetParameterBasicService() const { return m_parameter_basic_service; }
05289         virtual Message* Clone() const;
05290
05291         enum  {
05292             ID = 18543
05293             };
05294
05295     private:
05296         static const MsgMetaData m_meta_data;
05297         Tipd m_tipd;
05298         SsCode m_ss_code;
05299         Vector<CallBarringFeature> m_call_barring_features;
05300         SsCode m_parameter_ss_code;
05301         ServiceGroup m_parameter_basic_service;
05302
05303     };
05304
05305
05306 /*  ======================================================================
05307     Class CallBarringStatusMsg
05308     ====================================================================== */
05309
05311 class CallBarringStatusMsg : public SsMessage {
05312     public:
05313         CallBarringStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status, const Vector<SsGroup>& basic_service_list, const SsCode& parameter_ss_code, const ServiceGroup& parameter_basic_service);
05314         virtual ~CallBarringStatusMsg();
05315
05316         virtual const MsgMetaData& GetMetaData() const;
05317         const Tipd& GetTipd() const { return m_tipd; }
05318         const SsStatus& GetSsStatus() const { return m_ss_status; }
05319         const Vector<SsGroup>& GetBasicServiceList() const { return m_basic_service_list; }
05320         const SsCode& GetParameterSsCode() const { return m_parameter_ss_code; }
05321         const ServiceGroup& GetParameterBasicService() const { return m_parameter_basic_service; }
05322         virtual Message* Clone() const;
05323
05324         enum  {
05325             ID = 18544
05326             };
05327
05328     private:
05329         static const MsgMetaData m_meta_data;
05330         Tipd m_tipd;
05331         SsStatus m_ss_status;
05332         Vector<SsGroup> m_basic_service_list;
05333         SsCode m_parameter_ss_code;
05334         ServiceGroup m_parameter_basic_service;
05335
05336     };
05337
05338
05339 /*  ======================================================================
05340     Class ClipStatusMsg
05341     ====================================================================== */
05342
05344 class ClipStatusMsg : public SsMessage {
05345     public:
05346         ClipStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status);
05347         virtual ~ClipStatusMsg();
05348
05349         virtual const MsgMetaData& GetMetaData() const;
05350         const Tipd& GetTipd() const { return m_tipd; }
05351         const SsStatus& GetSsStatus() const { return m_ss_status; }
05352         virtual Message* Clone() const;
05353
05354         enum  {
05355             ID = 18545
05356             };
05357
05358     private:
05359         static const MsgMetaData m_meta_data;
05360         Tipd m_tipd;
05361         SsStatus m_ss_status;
05362
05363     };
05364
05365
05366 /*  ======================================================================
05367     Class ColpStatusMsg
05368     ====================================================================== */
05369
05371 class ColpStatusMsg : public SsMessage {
05372     public:
05373         ColpStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status);
05374         virtual ~ColpStatusMsg();
05375
05376         virtual const MsgMetaData& GetMetaData() const;
05377         const Tipd& GetTipd() const { return m_tipd; }
05378         const SsStatus& GetSsStatus() const { return m_ss_status; }
05379         virtual Message* Clone() const;
05380
05381         enum  {
05382             ID = 18546
05383             };
05384
05385     private:
05386         static const MsgMetaData m_meta_data;
05387         Tipd m_tipd;
05388         SsStatus m_ss_status;
05389
05390     };
05391
05392
05393 /*  ======================================================================
05394     Class ColrStatusMsg
05395     ====================================================================== */
05396
05398 class ColrStatusMsg : public SsMessage {
05399     public:
05400         ColrStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status);
05401         virtual ~ColrStatusMsg();
05402
05403         virtual const MsgMetaData& GetMetaData() const;
05404         const Tipd& GetTipd() const { return m_tipd; }
05405         const SsStatus& GetSsStatus() const { return m_ss_status; }
05406         virtual Message* Clone() const;
05407
05408         enum  {
05409             ID = 18547
05410             };
05411
05412     private:
05413         static const MsgMetaData m_meta_data;
05414         Tipd m_tipd;
05415         SsStatus m_ss_status;
05416
05417     };
05418
05419
05420 /*  ======================================================================
05421     Class CnapStatusMsg
05422     ====================================================================== */
05423
05425 class CnapStatusMsg : public SsMessage {
05426     public:
05427         CnapStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status);
05428         virtual ~CnapStatusMsg();
05429
05430         virtual const MsgMetaData& GetMetaData() const;
05431         const Tipd& GetTipd() const { return m_tipd; }
05432         const SsStatus& GetSsStatus() const { return m_ss_status; }
05433         virtual Message* Clone() const;
05434
05435         enum  {
05436             ID = 18563
05437             };
05438
05439     private:
05440         static const MsgMetaData m_meta_data;
05441         Tipd m_tipd;
05442         SsStatus m_ss_status;
05443
05444     };
05445
05446
05447 /*  ======================================================================
05448     Class ClirStatusMsg
05449     ====================================================================== */
05450
05452 class ClirStatusMsg : public SsMessage {
05453     public:
05454         ClirStatusMsg(ExecutionContext* context, const Tipd& tipd, const SsStatus& ss_status, const CliRestrictionOption& cli_restriction_option);
05455         virtual ~ClirStatusMsg();
05456
05457         virtual const MsgMetaData& GetMetaData() const;
05458         const Tipd& GetTipd() const { return m_tipd; }
05459         const SsStatus& GetSsStatus() const { return m_ss_status; }
05460         const CliRestrictionOption& GetCliRestrictionOption() const { return m_cli_restriction_option; }
05461         virtual Message* Clone() const;
05462
05463         enum  {
05464             ID = 18548
05465             };
05466
05467     private:
05468         static const MsgMetaData m_meta_data;
05469         Tipd m_tipd;
05470         SsStatus m_ss_status;
05471         CliRestrictionOption m_cli_restriction_option;
05472
05473     };
05474
05475
05476 /*  ======================================================================
05477     Class CallBarringPasswordChangedMsg
05478     ====================================================================== */
05479
05481 class CallBarringPasswordChangedMsg : public SsMessage {
05482     public:
05483         CallBarringPasswordChangedMsg(ExecutionContext* context, const Tipd& tipd, const WString& new_password, const SsCode& param_ss_code, const WString& param_old_password, const WString& param_new_password, const WString& param_conf_password);
05484         virtual ~CallBarringPasswordChangedMsg();
05485
05486         virtual const MsgMetaData& GetMetaData() const;
05487         const Tipd& GetTipd() const { return m_tipd; }
05488         const WString& GetNewPassword() const { return m_new_password; }
05489         const SsCode& GetParamSsCode() const { return m_param_ss_code; }
05490         const WString& GetParamOldPassword() const { return m_param_old_password; }
05491         const WString& GetParamNewPassword() const { return m_param_new_password; }
05492         const WString& GetParamConfPassword() const { return m_param_conf_password; }
05493         virtual Message* Clone() const;
05494
05495         enum  {
05496             ID = 18549
05497             };
05498
05499     private:
05500         static const MsgMetaData m_meta_data;
05501         Tipd m_tipd;
05502         WString m_new_password;
05503         SsCode m_param_ss_code;
05504         WString m_param_old_password;
05505         WString m_param_new_password;
05506         WString m_param_conf_password;
05507
05508     };
05509
05510
05511 /*  ======================================================================
05512     Class SsErrorMsg
05513     ====================================================================== */
05514
05516 class SsErrorMsg : public SsMessage {
05517     public:
05518         SsErrorMsg(ExecutionContext* context, const Tipd& tipd, const SsBaseHandler::ReturnCode& error_code, const WString& error_text);
05519         virtual ~SsErrorMsg();
05520
05521         virtual const MsgMetaData& GetMetaData() const;
05522         const Tipd& GetTipd() const { return m_tipd; }
05523         const SsBaseHandler::ReturnCode& GetErrorCode() const { return m_error_code; }
05524         const WString& GetErrorText() const { return m_error_text; }
05525         virtual Message* Clone() const;
05526
05527         enum  {
05528             ID = 18550
05529             };
05530
05531     private:
05532         static const MsgMetaData m_meta_data;
05533         Tipd m_tipd;
05534         SsBaseHandler::ReturnCode m_error_code;
05535         WString m_error_text;
05536
05537     };
05538
05539
05540 /*  ======================================================================
05541     Class UssdRequestMsg
05542     ====================================================================== */
05543
05545 class UssdRequestMsg : public SsMessage {
05546     public:
05547         UssdRequestMsg(ExecutionContext* context, const Tipd& tipd, const WString& control_info, const DataCodingScheme& data_coding_scheme);
05548         virtual ~UssdRequestMsg();
05549
05550         virtual const MsgMetaData& GetMetaData() const;
05551         const Tipd& GetTipd() const { return m_tipd; }
05552         const WString& GetControlInfo() const { return m_control_info; }
05553         const DataCodingScheme& GetDataCodingScheme() const { return m_data_coding_scheme; }
05554         virtual Message* Clone() const;
05555
05556         enum  {
05557             ID = 18551
05558             };
05559
05560     private:
05561         static const MsgMetaData m_meta_data;
05562         Tipd m_tipd;
05563         WString m_control_info;
05564         DataCodingScheme m_data_coding_scheme;
05565
05566     };
05567
05568
05569 /*  ======================================================================
05570     Class UssdNotifyMsg
05571     ====================================================================== */
05572
05574 class UssdNotifyMsg : public SsMessage {
05575     public:
05576         UssdNotifyMsg(ExecutionContext* context, const Tipd& tipd, const WString& control_info, const DataCodingScheme& data_coding_scheme);
05577         virtual ~UssdNotifyMsg();
05578
05579         virtual const MsgMetaData& GetMetaData() const;
05580         const Tipd& GetTipd() const { return m_tipd; }
05581         const WString& GetControlInfo() const { return m_control_info; }
05582         const DataCodingScheme& GetDataCodingScheme() const { return m_data_coding_scheme; }
05583         virtual Message* Clone() const;
05584
05585         enum  {
05586             ID = 18552
05587             };
05588
05589     private:
05590         static const MsgMetaData m_meta_data;
05591         Tipd m_tipd;
05592         WString m_control_info;
05593         DataCodingScheme m_data_coding_scheme;
05594
05595     };
05596
05597
05598 /*  ======================================================================
05599     Class UssdEndMsg
05600     ====================================================================== */
05601
05603 class UssdEndMsg : public SsMessage {
05604     public:
05605         UssdEndMsg(ExecutionContext* context, const Tipd& tipd);
05606         virtual ~UssdEndMsg();
05607
05608         virtual const MsgMetaData& GetMetaData() const;
05609         const Tipd& GetTipd() const { return m_tipd; }
05610         virtual Message* Clone() const;
05611
05612         enum  {
05613             ID = 18553
05614             };
05615
05616     private:
05617         static const MsgMetaData m_meta_data;
05618         Tipd m_tipd;
05619
05620     };
05621
05622
05623 /*  ======================================================================
05624     Class UssdDataMsg
05625     ====================================================================== */
05626
05628 class UssdDataMsg : public SsMessage {
05629     public:
05630         UssdDataMsg(ExecutionContext* context, const Tipd& tipd, const WString& data, const DataCodingScheme& data_coding_scheme);
05631         virtual ~UssdDataMsg();
05632
05633         virtual const MsgMetaData& GetMetaData() const;
05634         const Tipd& GetTipd() const { return m_tipd; }
05635         const WString& GetData() const { return m_data; }
05636         const DataCodingScheme& GetDataCodingScheme() const { return m_data_coding_scheme; }
05637         virtual Message* Clone() const;
05638
05639         enum  {
05640             ID = 18555
05641             };
05642
05643     private:
05644         static const MsgMetaData m_meta_data;
05645         Tipd m_tipd;
05646         WString m_data;
05647         DataCodingScheme m_data_coding_scheme;
05648
05649     };
05650
05651
05652 /*  ======================================================================
05653     Class UssdRequestResentMsg
05654     ====================================================================== */
05655
05657 class UssdRequestResentMsg : public SsMessage {
05658     public:
05659         UssdRequestResentMsg(ExecutionContext* context, const Tipd& new_tipd, const Tipd& old_tipd);
05660         virtual ~UssdRequestResentMsg();
05661
05662         virtual const MsgMetaData& GetMetaData() const;
05663         const Tipd& GetNewTipd() const { return m_new_tipd; }
05664         const Tipd& GetOldTipd() const { return m_old_tipd; }
05665         virtual Message* Clone() const;
05666
05667         enum  {
05668             ID = 18556
05669             };
05670
05671     private:
05672         static const MsgMetaData m_meta_data;
05673         Tipd m_new_tipd;
05674         Tipd m_old_tipd;
05675
05676     };
05677
05678
05679 /*  ======================================================================
05680     Class GetPasswordMsg
05681     ====================================================================== */
05682
05684 class GetPasswordMsg : public SsMessage {
05685     public:
05686         GetPasswordMsg(ExecutionContext* context, const Tipd& tipd, CallBarringHandler* handler);
05687         virtual ~GetPasswordMsg();
05688
05689         virtual const MsgMetaData& GetMetaData() const;
05690         const Tipd& GetTipd() const { return m_tipd; }
05691         CallBarringHandler* GetHandler() const { return m_handler; }
05692         void SendPassword(const WString& password) { GetHandler()->SendPassword(GetTipd(), password); }
05693         void Abort() { GetHandler()->AbortPasswordRequest(GetTipd()); }
05694         virtual Message* Clone() const;
05695
05696         enum  {
05697             ID = 18559
05698             };
05699
05700     private:
05701         static const MsgMetaData m_meta_data;
05702         Tipd m_tipd;
05703         CallBarringHandler* m_handler;
05704
05705     };
05706
05707
05708 /*  ======================================================================
05709     Class UusStatusMsg
05710     ====================================================================== */
05711
05713 class UusStatusMsg : public SsMessage {
05714     public:
05715         UusStatusMsg(ExecutionContext* context, const SsCode& ss_code, const Vector<UusText>& text_list);
05716         virtual ~UusStatusMsg();
05717
05718         virtual const MsgMetaData& GetMetaData() const;
05719         const SsCode& GetSsCode() const { return m_ss_code; }
05720         const Vector<UusText>& GetTextList() const { return m_text_list; }
05721         virtual Message* Clone() const;
05722
05723         enum  {
05724             ID = 18567
05725             };
05726
05727     private:
05728         static const MsgMetaData m_meta_data;
05729         SsCode m_ss_code;
05730         Vector<UusText> m_text_list;
05731
05732     };
05733
05734
05735 /*  ======================================================================
05736     Class UusQueryRejectedMsg
05737     ====================================================================== */
05738
05740 class UusQueryRejectedMsg : public SsMessage {
05741     public:
05742         UusQueryRejectedMsg(ExecutionContext* context);
05743         virtual ~UusQueryRejectedMsg();
05744
05745         virtual const MsgMetaData& GetMetaData() const;
05746         virtual Message* Clone() const;
05747
05748         enum  {
05749             ID = 18569
05750             };
05751
05752     private:
05753         static const MsgMetaData m_meta_data;
05754
05755     };
05756
05757
05758 /*  ======================================================================
05759     Class UusNotificationMsg
05760     ====================================================================== */
05761
05763 class UusNotificationMsg : public SsMessage {
05764     public:
05765         UusNotificationMsg(ExecutionContext* context, const SsCode& ss_code, const WString& text, const UusInTextType& type);
05766         virtual ~UusNotificationMsg();
05767
05768         virtual const MsgMetaData& GetMetaData() const;
05769         const SsCode& GetSsCode() const { return m_ss_code; }
05770         const WString& GetText() const { return m_text; }
05771         const UusInTextType& GetType() const { return m_type; }
05772         virtual Message* Clone() const;
05773
05774         enum  {
05775             ID = 18568
05776             };
05777
05778     private:
05779         static const MsgMetaData m_meta_data;
05780         SsCode m_ss_code;
05781         WString m_text;
05782         UusInTextType m_type;
05783
05784     };
05785
05786
05787 /*  ======================================================================
05788     Class UusRegisteredMsg
05789     ====================================================================== */
05790
05792 class UusRegisteredMsg : public SsMessage {
05793     public:
05794         UusRegisteredMsg(ExecutionContext* context, const SsCode& ss_code, const WString& text, const UusOutTextType& type);
05795         virtual ~UusRegisteredMsg();
05796
05797         virtual const MsgMetaData& GetMetaData() const;
05798         const SsCode& GetSsCode() const { return m_ss_code; }
05799         const WString& GetText() const { return m_text; }
05800         const UusOutTextType& GetType() const { return m_type; }
05801         virtual Message* Clone() const;
05802
05803         enum  {
05804             ID = 18571
05805             };
05806
05807     private:
05808         static const MsgMetaData m_meta_data;
05809         SsCode m_ss_code;
05810         WString m_text;
05811         UusOutTextType m_type;
05812
05813     };
05814
05815
05816 /*  ======================================================================
05817     Class UusErasedMsg
05818     ====================================================================== */
05819
05821 class UusErasedMsg : public SsMessage {
05822     public:
05823         UusErasedMsg(ExecutionContext* context, const SsCode& ss_code, const UusOutTextType& type);
05824         virtual ~UusErasedMsg();
05825
05826         virtual const MsgMetaData& GetMetaData() const;
05827         const SsCode& GetSsCode() const { return m_ss_code; }
05828         const UusOutTextType& GetType() const { return m_type; }
05829         virtual Message* Clone() const;
05830
05831         enum  {
05832             ID = 18572
05833             };
05834
05835     private:
05836         static const MsgMetaData m_meta_data;
05837         SsCode m_ss_code;
05838         UusOutTextType m_type;
05839
05840     };
05841
05842
05843 /*  ======================================================================
05844     Class UssdBeginMsg
05845     ====================================================================== */
05846
05848 class UssdBeginMsg : public Message {
05849     public:
05850         UssdBeginMsg(const Tipd& tipd, const SsStackMsgArgument& argument);
05851         virtual ~UssdBeginMsg();
05852
05853         virtual const MsgMetaData& GetMetaData() const;
05854         const Tipd& GetTipd() const { return m_tipd; }
05855         SsApiRc BeginTransaction();
05856         virtual Message* Clone() const;
05857
05858         enum  {
05859             ID = 18554
05860             };
05861
05862     private:
05863         static const MsgMetaData m_meta_data;
05864         Tipd m_tipd;
05865         SsStackMsgArgument m_argument;
05866
05867     };
05868
05869 #endif // Asc_StackIndicationMsgTypes_hpp
05870
Generated on Tue Jan 24 14:47:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackMsgActiveWaitDispatcher.cpp File Reference

Asc/StackMsgActiveWaitDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackMsgActiveWaitDispatcher.hpp"

Include dependency graph for StackMsgActiveWaitDispatcher.cpp:

Generated on Tue Jan 24 17:38:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackMsgActiveWaitDispatcher.hpp File Reference

Asc/StackMsgActiveWaitDispatcher.hpp File Reference

#include <Kernel/ActiveWaitDispatcher.hpp>
#include <Kernel/MessageMap.hpp>

Include dependency graph for StackMsgActiveWaitDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackMsgActiveWaitDispatcher

Defines

#define | Asc_StackMsgActiveWaitDispatcher_hpp

Define Documentation

#define Asc_StackMsgActiveWaitDispatcher_hpp

Generated on Tue Jan 24 17:38:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackMsgActiveWaitDispatcher.hpp Source File

Asc/StackMsgActiveWaitDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Asc_StackMsgActiveWaitDispatcher_hpp)
00010 #define Asc_StackMsgActiveWaitDispatcher_hpp
00013
00014 #include <Kernel/ActiveWaitDispatcher.hpp>
00015 #include <Kernel/MessageMap.hpp>
00016
00017 class AbstractStackMsgArgMapContainer;
00018
00019 /*  ========================================================================
00020     StackMsgActiveWaitDispatcher
00021     ======================================================================== */
00024 class StackMsgActiveWaitDispatcher : public ActiveWaitDispatcher {
00025     typedef ActiveWaitDispatcher Base;
00026     public:
00029         StackMsgActiveWaitDispatcher(const AbstractStackMsgArgMapContainer *arg_map_container = 0);
00031         virtual ~StackMsgActiveWaitDispatcher() {}
00032
00034         virtual void Reset();
00035
00042         virtual BOOLEAN IsAborted() { return m_aborted; }
00043
00044
00051         void Abort() { m_aborted = TRUE; Done(); }
00052
00053     protected:
00054         void Init(const AbstractStackMsgArgMapContainer *arg_map_container) { m_arg_map_container = arg_map_container; }
00055
00056     private:
00057         static const MessageMap<StackMsgActiveWaitDispatcher> m_msg_map[];
00058         MessageMapContainer<StackMsgActiveWaitDispatcher> m_msg_map_container;
00059
00060         const AbstractStackMsgArgMapContainer *m_arg_map_container;
00061
00062         BOOLEAN m_aborted;
00063
00064         BOOLEAN OnStackMsg(const Message &msg);
00065 };
00066
00068 #endif // Asc_StackMsgActiveWaitDispatcher_hpp
00069
00070
Generated on Tue Jan 24 14:47:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackMsgDispatcher.cpp File Reference

Asc/StackMsgDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StackMsgDispatcher.hpp"

Include dependency graph for StackMsgDispatcher.cpp:

Generated on Tue Jan 24 17:38:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackMsgDispatcher.hpp File Reference

Asc/StackMsgDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/UserDispatcher.hpp>

Include dependency graph for StackMsgDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StackMsgDispatcher
is the base for all normal dispatchers, which are used in ASC. More...

Defines

#define | Asc_StackMsgDispatcher_hpp

Define Documentation

#define Asc_StackMsgDispatcher_hpp

Generated on Tue Jan 24 17:38:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StackMsgDispatcher.hpp Source File

Asc/StackMsgDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_StackMsgDispatcher_hpp)
00009 #define Asc_StackMsgDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/UserDispatcher.hpp>
00015
00016 class AbstractStackMsgArgMapContainer;
00017 class ExecutionContext;
00018 class Message;
00019
00020 /*  ========================================================================
00021     StackMsgDispatcher
00022     ======================================================================== */
00024 class StackMsgDispatcher : public UserDispatcher {
00025     friend class BaseHandler;
00026     typedef UserDispatcher Base;
00027     public:
00030         StackMsgDispatcher(const AbstractStackMsgArgMapContainer *arg_map_container = 0);
00031
00033         virtual ~StackMsgDispatcher();
00034
00035     protected:
00036         void Init(const AbstractStackMsgArgMapContainer *arg_map_container) { m_arg_map_container_ptr = arg_map_container; }
00037
00038         BOOLEAN Activate(ExecutionContext *context = 0);
00039         BOOLEAN Deactivate(ExecutionContext *context = 0);
00040
00042         virtual BOOLEAN OnMessage(const Message &msg);
00043
00044     private:
00045         const AbstractStackMsgArgMapContainer *m_arg_map_container_ptr;
00046
00047 };
00048
00050 #endif // Asc_StackMsgDispatcher_hpp
00051
00052
Generated on Tue Jan 24 14:47:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StatusDispatcher.cpp File Reference

Asc/StatusDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "StatusDispatcher.hpp"
#include <Apc/MiscStackMsgArgs.hpp>

Include dependency graph for StatusDispatcher.cpp:

Generated on Tue Jan 24 17:39:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StatusDispatcher.hpp File Reference

Asc/StatusDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for StatusDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StatusDispatcher

Defines

#define | Asc_StatusDispatcher_hpp

Define Documentation

#define Asc_StatusDispatcher_hpp

Generated on Tue Jan 24 17:39:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/StatusDispatcher.hpp Source File

Asc/StatusDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SatusDispatcher_hpp)
00009 #define Asc_StatusDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgDispatcher.hpp>
00016
00018 class StatusDispatcher : public StackMsgDispatcher {
00019     typedef StackMsgDispatcher Base;
00020     public:
00022         StatusDispatcher();
00024         virtual ~StatusDispatcher();
00025
00026     protected:
00028
00029     private:
00030         static const StackMsgArgMap<StatusDispatcher> m_arg_map[];
00031         StackMsgArgMapContainer<StatusDispatcher> m_arg_map_container;
00032 };
00033
00035 #endif // Asc_StatusDispatcher_hpp
00036
00037
Generated on Tue Jan 24 14:47:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceAction.cpp File Reference

Asc/SupplementaryServiceAction.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/Types.hpp>
#include <Asc/StackControl.hpp>
#include <Asc/CallBarringHandler.hpp>
#include <Asc/CallForwardingHandler.hpp>
#include <Asc/CallWaitingHandler.hpp>
#include <Asc/ClipHandler.hpp>
#include <Asc/ClirHandler.hpp>
#include <Asc/ColpHandler.hpp>
#include <Asc/ColrHandler.hpp>
#include <Asc/CnapHandler.hpp>
#include <Asc/MobileOriginatedUssdHandler.hpp>
#include <Asc/EmlppHandler.hpp>
#include <Asc/InputParser.hpp>
#include <Asc/InputParserTranslator.hpp>
#include "SupplementaryServiceAction.hpp"

Include dependency graph for SupplementaryServiceAction.cpp:

Generated on Tue Jan 24 17:39:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceAction.hpp File Reference

Asc/SupplementaryServiceAction.hpp File Reference

#include <Asc/InputAction.hpp>

Include dependency graph for SupplementaryServiceAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SelectedLineRetriever
class | SsCallBarringActionImpl
class | SsCallForwardingActionImpl
class | SsCallWaitingActionImpl
class | SsClipActionImpl
class | SsClirActionImpl
class | SsCnapActionImpl
class | SsColpActionImpl
class | SsColrActionImpl
class | SsEmlppActionImpl
class | SsPasswordChangeActionImpl
class | SsUssdActionImpl

Defines

#define | Asc_SupplementaryServiceAction_hpp

Define Documentation

#define Asc_SupplementaryServiceAction_hpp

Generated on Tue Jan 24 17:39:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceAction.hpp Source File

Asc/SupplementaryServiceAction.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003    ------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted without prior written authorisation.
00007    ------------------------------------------------------------------------ */
00008
00009 #if !defined(Asc_SupplementaryServiceAction_hpp)
00010 #define Asc_SupplementaryServiceAction_hpp
00013
00014 #include <Asc/InputAction.hpp>
00015
00016 class SelectedLineRetriever
00017 {
00018 public:
00019     virtual LineSelector GetSelectedLine() const = 0;
00020 };
00021
00023 class SsPasswordChangeActionImpl : public PasswordChangeSsAction {
00024     typedef PasswordChangeSsAction Base;
00025
00026  public:
00027     SsPasswordChangeActionImpl();
00028     virtual ~SsPasswordChangeActionImpl();
00029
00030     void Init(BOOLEAN registerOnly = FALSE) {
00031         m_register_only = registerOnly;
00032     }
00033
00034     virtual BOOLEAN Execute();
00035
00036  private:
00037     BOOLEAN m_register_only;
00038 };
00039
00041 class SsCallBarringActionImpl : public BarringSsAction {
00042     typedef BarringSsAction Base;
00043
00044  public:
00045     SsCallBarringActionImpl();
00046     virtual ~SsCallBarringActionImpl();
00047
00048     void Init(BOOLEAN registerOnly = FALSE, const SelectedLineRetriever* line_retriever = 0);
00049
00050     virtual BOOLEAN Execute();
00051
00052  private:
00053     BOOLEAN m_register_only;
00054     const SelectedLineRetriever*    m_line_retriever;
00055 };
00056
00058 class SsCallForwardingActionImpl : public ForwardingSsAction {
00059     typedef ForwardingSsAction Base;
00060  public:
00061     SsCallForwardingActionImpl();
00062     virtual ~SsCallForwardingActionImpl();
00063     void Init(BOOLEAN registerOnly = FALSE, const SelectedLineRetriever* line_retriever = 0);
00064
00065     virtual BOOLEAN Execute();
00066
00067  private:
00068     BOOLEAN m_register_only;
00069     const SelectedLineRetriever*    m_line_retriever;
00070 };
00071
00073 class SsCallWaitingActionImpl : public WaitSsAction {
00074     typedef WaitSsAction Base;
00075  public:
00076     SsCallWaitingActionImpl();
00077     virtual ~SsCallWaitingActionImpl();
00078     void Init(BOOLEAN registerOnly = FALSE, const SelectedLineRetriever* line_retriever = 0);
00079
00080     virtual BOOLEAN Execute();
00081
00082  private:
00083     BOOLEAN m_register_only;
00084     const SelectedLineRetriever*    m_line_retriever;
00085 };
00086
00088 class SsClirActionImpl : public ClirAction {
00089     typedef ClirAction Base;
00090  public:
00091     SsClirActionImpl();
00092     virtual ~SsClirActionImpl();
00093     void Init(BOOLEAN registerOnly = FALSE) {
00094         m_register_only = registerOnly;
00095     }
00096     virtual BOOLEAN Execute();
00097
00098  private:
00099     BOOLEAN m_register_only;
00100 };
00101
00103 class SsClipActionImpl : public ClipAction {
00104     typedef ClipAction Base;
00105  public:
00106     SsClipActionImpl();
00107     virtual ~SsClipActionImpl();
00108     void Init(BOOLEAN registerOnly = FALSE) {
00109         m_register_only = registerOnly;
00110     }
00111     virtual BOOLEAN Execute();
00112
00113  private:
00114     BOOLEAN m_register_only;
00115 };
00116
00118 class SsColrActionImpl : public ColrAction {
00119     typedef ColrAction Base;
00120  public:
00121     SsColrActionImpl();
00122     virtual ~SsColrActionImpl();
00123     void Init(BOOLEAN registerOnly = FALSE) {
00124         m_register_only = registerOnly;
00125     }
00126     virtual BOOLEAN Execute();
00127
00128  private:
00129     BOOLEAN m_register_only;
00130 };
00131
00133 class SsColpActionImpl : public ColpAction {
00134     typedef ColpAction Base;
00135  public:
00136     SsColpActionImpl();
00137     virtual ~SsColpActionImpl();
00138     void Init(BOOLEAN registerOnly = FALSE) {
00139         m_register_only = registerOnly;
00140     }
00141     virtual BOOLEAN Execute();
00142
00143  private:
00144     BOOLEAN m_register_only;
00145 };
00146
00147
00149 class SsCnapActionImpl : public CnapAction {
00150     typedef CnapAction Base;
00151  public:
00152     SsCnapActionImpl();
00153     virtual ~SsCnapActionImpl();
00154     void Init(BOOLEAN registerOnly = FALSE) {
00155         m_register_only = registerOnly;
00156     }
00157     virtual BOOLEAN Execute();
00158
00159  private:
00160     BOOLEAN m_register_only;
00161 };
00162
00164 class SsUssdActionImpl : public UssdAction {
00165     typedef UssdAction Base;
00166  public:
00167     SsUssdActionImpl();
00168     virtual ~SsUssdActionImpl();
00169     void Init(BOOLEAN registerOnly = FALSE) {
00170         m_register_only = registerOnly;
00171     }
00172     virtual BOOLEAN Execute();
00173
00174  private:
00175     BOOLEAN m_register_only;
00176 };
00177
00178
00180 class SsEmlppActionImpl : public EmlppAction {
00181     typedef EmlppAction Base;
00182  public:
00183     SsEmlppActionImpl();
00184     virtual ~SsEmlppActionImpl();
00185     void Init(BOOLEAN registerOnly = FALSE) {
00186         m_register_only = registerOnly;
00187     }
00188     virtual BOOLEAN Execute();
00189
00190  private:
00191     BOOLEAN m_register_only;
00192 };
00193
00194
00196 #endif  // Asc_SupplementaryServiceAction_hpp
00197
00198
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceDispatcher.cpp File Reference

Asc/SupplementaryServiceDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Asc/SsBaseHandler.hpp>
#include <Asc/SsMainHandler.hpp>
#include <Asc/UssdHandler.hpp>
#include "SupplementaryServiceDispatcher.hpp"

Include dependency graph for SupplementaryServiceDispatcher.cpp:

Generated on Tue Jan 24 17:39:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceDispatcher.hpp File Reference

Asc/SupplementaryServiceDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:39:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceDispatcher.hpp Source File

Asc/SupplementaryServiceDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002   Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003   All rights reserved.
00004   ------------------------------------------------------------------------
00005   This document contains proprietary information belonging to COMNEON.
00006   Passing on and copying of this document, use and communication of its
00007   contents is not permitted without prior written authorisation.
00008   ------------------------------------------------------------------------ */
00009 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00010
00011 #if !defined(Asc_SupplementaryServiceDispatcher_hpp)
00012 #define Asc_SupplementaryServiceDispatcher_hpp
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Kernel/Message.hpp>
00018
00019 #include <Asc/InputAnalyzer.hpp>
00020
00021 #include <Asc/StackMsgDispatcher.hpp>
00022 #include <Asc/SsBaseHandler.hpp>
00023 #include <Asc/SupplementaryServiceAction.hpp>
00024
00025 class SsMainHandler;
00026
00035 class SupplementaryServiceDispatcher : public StackMsgDispatcher {
00038     typedef StackMsgDispatcher Base;
00039
00040  public:
00045     SupplementaryServiceDispatcher();
00046
00047     virtual ~SupplementaryServiceDispatcher();
00048
00052     void SetSsMainHandler(SsMainHandler * ss_main_handler) {
00053         m_ss_main_handler = ss_main_handler;
00054     }
00055
00056  protected:
00057
00064     BOOLEAN OnSsForwcheckInd(const StackMsgArgument &arg);
00065
00066
00073     BOOLEAN OnSsFacilityRej(const StackMsgArgument &arg);
00074
00075
00082     BOOLEAN OnSsBeginAcc(const StackMsgArgument &arg);
00083
00100     BOOLEAN OnSsResultInd(const StackMsgArgument &arg);
00101
00112     BOOLEAN OnSsRej(const StackMsgArgument &arg);
00113
00124     BOOLEAN OnSsErrInd(const StackMsgArgument &arg);
00125
00136     BOOLEAN OnSsCauseInd(const StackMsgArgument &arg);
00137
00138
00145     BOOLEAN OnSsNotifyInd(const StackMsgArgument &arg);
00146
00154     BOOLEAN OnSsEndInd(const StackMsgArgument &arg);
00155
00163     BOOLEAN OnSsClientRej(const StackMsgArgument &arg);
00164
00171     BOOLEAN OnCallControlInd(const StackMsgArgument &arg);
00172
00173     BOOLEAN OnUus1QueryInd(const StackMsgArgument &arg);
00174     BOOLEAN OnUus1QueryRej(const StackMsgArgument &arg);
00175     BOOLEAN OnUus1Ind(const StackMsgArgument &arg);
00176 #if defined(APOXI_AT_MMI_INTERWORKING_SS)
00177     BOOLEAN OnFacilityInd(const StackMsgArgument &arg);
00178 #endif
00179 #if defined(APOXI_AT_MMI_INTERWORKING_USSD)
00180     BOOLEAN OnUssdAnswerInd(const StackMsgArgument &arg);
00181 #endif
00182
00183  private:
00190     void SendMessage(Tipd tipd, const Message &msg);
00191
00198     void SendErrorMessage(Tipd tipd, SsBaseHandler::ReturnCode error_code, const WCHAR* error_text);
00199
00202     void CheckReleaseComplete(BOOLEAN release_complete) const;
00203
00209     BOOLEAN CheckNotificationFlags(const SsNotification &flags);
00210
00218     void EndTransaction(SsBaseHandler &ss_handler, Tipd tipd);
00219
00222     SsMainHandler * m_ss_main_handler;
00223
00227     static const StackMsgArgMap<SupplementaryServiceDispatcher> m_arg_map[];
00228
00231     StackMsgArgMapContainer<SupplementaryServiceDispatcher> m_arg_map_container;
00232
00233 };
00234
00236 #endif // Asc_SupplementaryServiceDispatcher_hpp
00237
00238 #endif // DOXYGEN_SHOULD_SKIP_THIS
00239
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceWaitDispatcher.cpp File Reference

Asc/SupplementaryServiceWaitDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "MocVoiceHandler.hpp"
#include "SsMainHandler.hpp"
#include "SupplementaryServiceWaitDispatcher.hpp"

Include dependency graph for SupplementaryServiceWaitDispatcher.cpp:

Generated on Tue Jan 24 17:39:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceWaitDispatcher.hpp File Reference

Asc/SupplementaryServiceWaitDispatcher.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:39:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/SupplementaryServiceWaitDispatcher.hpp Source File

Asc/SupplementaryServiceWaitDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002   Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003   ------------------------------------------------------------------------
00004   This document contains proprietary information belonging to COMNEON.
00005   Passing on and copying of this document, use and communication of its
00006   contents is not permitted without prior written authorisation.
00007   ------------------------------------------------------------------------ */
00008 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00009
00010 #if !defined(Asc_SupplementaryServiceWaitDispatcher_hpp)
00011 #define Asc_SupplementaryServiceWaitDispatcher_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00018
00019 /* ========================================================================
00020    SupplementaryServiceWaitDispatcher
00021    ======================================================================== */
00023 class SupplementaryServiceWaitDispatcher : public StackMsgActiveWaitDispatcher {
00024     typedef StackMsgActiveWaitDispatcher Base;
00025  public:
00027     SupplementaryServiceWaitDispatcher();
00029     virtual ~SupplementaryServiceWaitDispatcher();
00030
00032     BOOLEAN WasRejected() { return m_rejected; }
00034     BOOLEAN WasChangedToMoc() { return m_changed_to_moc; }
00036     BOOLEAN WasChangedToSs() { return m_changed_to_ss; }
00038     BOOLEAN WasChangedToUssd() { return m_changed_to_ussd; }
00039
00040     const PhoneNumber& GetCalledPartyNumber() { return m_called_phone_number; }
00041     const WString& GetUserInput() { return m_user_input; }
00042     DataCodingScheme::Language GetUserLanguage() { return m_user_language; }
00043
00044
00045     Tipd GetTipd() { return m_tipd; }
00046     CallErrorCause GetCause() { return m_cause; }
00047
00048     void ChangeToSsIndication(const WString& user_input, DataCodingScheme::Language user_language);
00049     void ChangeToUssdIndication(const WString& user_input, DataCodingScheme::Language user_language);
00050     void ChangeToMocIndication(const PhoneNumber& called_phone_number);
00051
00052  protected:
00054     BOOLEAN OnSsBeginAcc(const StackMsgArgument &arg);
00056     BOOLEAN OnSsFacilityRej(const StackMsgArgument &arg);
00058     BOOLEAN OnCallControlSetupInd(const StackMsgArgument &arg);
00060     BOOLEAN OnCallControlSsInd(const StackMsgArgument &arg);
00062     BOOLEAN OnCallControlUssdInd(const StackMsgArgument &arg);
00063
00064  private:
00065     static const StackMsgArgMap<SupplementaryServiceWaitDispatcher> m_arg_map[];
00066     StackMsgArgMapContainer<SupplementaryServiceWaitDispatcher> m_arg_map_container;
00067
00068     Tipd m_tipd;
00069     BOOLEAN m_rejected;
00070
00071     CallErrorCause m_cause;
00072
00073     BOOLEAN m_changed_to_moc;
00074     BOOLEAN m_changed_to_ss;
00075     BOOLEAN m_changed_to_ussd;
00076
00077     WString m_user_input;
00078     DataCodingScheme::Language m_user_language;
00079     PhoneNumber m_called_phone_number;
00080 };
00081
00083 #endif  // Asc_SupplementaryServiceWaitDispatcher_hpp
00084
00085 #endif // DOXYGEN_SHOULD_SKIP_THIS
00086
00087
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TchInterface.cpp File Reference

Asc/TchInterface.cpp File Reference

#include "Asc/PreComp.hpp"
#include "TchInterface.hpp"
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioPathManager.hpp>

Include dependency graph for TchInterface.cpp:

Functions

void | CloseDownlink ()
Close downlink of speech-channel keep status of uplink.
void | CloseTch ()
Close up- and downlink of speech-channel.
void | CloseUplink ()
Close uplink of speech-channel keep status of downlink.
BOOLEAN | IsDownlinkConnected ()
Check if downlink is connected.
BOOLEAN | IsTchConnected ()
Check if up- and downlink is connected.
BOOLEAN | IsUplinkConnected ()
Check if uplink is connected.
void | OpenDownlink ()
Open downlink of speech-channel keep status of uplink.
void | OpenTch ()
Open up- and downlink of speech-channel.
void | OpenUplink ()
Open uplink of speech-channel keep status of downlink.
void | SendTchStatusUpdateToMn (BOOLEAN connect_uplink, BOOLEAN connect_downlink)

Function Documentation

void CloseDownlink ( )

Close downlink of speech-channel keep status of uplink.

void CloseTch ( )

Close up- and downlink of speech-channel.

void CloseUplink ( )

Close uplink of speech-channel keep status of downlink.

BOOLEAN IsDownlinkConnected ( )

Check if downlink is connected.

BOOLEAN IsTchConnected ( )

Check if up- and downlink is connected.

BOOLEAN IsUplinkConnected ( )

Check if uplink is connected.

void OpenDownlink ( )

Open downlink of speech-channel keep status of uplink.

void OpenTch ( )

Open up- and downlink of speech-channel.

void OpenUplink ( )

Open uplink of speech-channel keep status of downlink.

void SendTchStatusUpdateToMn | ( | BOOLEAN | connect_uplink,
 |  | BOOLEAN | connect_downlink
 | ) |

Sends the current status of the two static variables representing the status of the traffic channel to the MN.

Generated on Tue Jan 24 17:40:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TchInterface.hpp File Reference

Asc/TchInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:40:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TchInterface.hpp Source File

Asc/TchInterface.hpp

Go to the documentation of this file.
00001 // ****************************************************************************
00002 // Copyright (C) 2001 COMNEON GmbH & Co. OHG. All rights reserved.
00003 // ****************************************************************************
00004 //
00005 // ****************************************************************************
00006 //
00007 // This document contains proprietary information belonging to COMNEON.
00008 // Passing on and copying of this document, use and communication of its
00009 // contents is not permitted without prior written authorisation.
00010 //
00011 // ****************************************************************************
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #if !defined(Asc_TchInterface_hpp)
00015 #define Asc_TchInterface_hpp
00018
00019
00020 extern void OpenDownlink();
00021
00023 extern void OpenUplink();
00024
00026 extern void CloseDownlink();
00027
00029 extern void CloseUplink();
00030
00032 extern void OpenTch();
00033
00035 extern void CloseTch();
00036
00038 extern BOOLEAN IsUplinkConnected();
00039
00041 extern BOOLEAN IsDownlinkConnected();
00042
00044 extern BOOLEAN IsTchConnected();
00045
00047 #endif  // _ASC_TchInterface_hpp
00048
00049 #endif // DOXYGEN_SHOULD_SKIP_THIS
00050
00051
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TipdBasedActiveWaitDispatcher.cpp File Reference

Asc/TipdBasedActiveWaitDispatcher.cpp File Reference

#include "Asc/PreComp.hpp"
#include "TipdBasedActiveWaitDispatcher.hpp"

Include dependency graph for TipdBasedActiveWaitDispatcher.cpp:

Generated on Tue Jan 24 17:41:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TipdBasedActiveWaitDispatcher.hpp File Reference

Asc/TipdBasedActiveWaitDispatcher.hpp File Reference

#include <Asc/StackMsgActiveWaitDispatcher.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for TipdBasedActiveWaitDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TipdBasedActiveWaitDispatcher

Defines

#define | Asc_TipdBasedActiveWaitDispatcher_hpp

Define Documentation

#define Asc_TipdBasedActiveWaitDispatcher_hpp

Generated on Tue Jan 24 17:41:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TipdBasedActiveWaitDispatcher.hpp Source File

Asc/TipdBasedActiveWaitDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_TipdBasedActiveWaitDispatcher_hpp)
00009 #define Asc_TipdBasedActiveWaitDispatcher_hpp
00012
00013 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00014 #include <Apc/SignalTypes.hpp>
00015
00019 class TipdBasedActiveWaitDispatcher : public StackMsgActiveWaitDispatcher {
00020
00021     typedef StackMsgActiveWaitDispatcher Base;
00022
00023     public:
00024         enum AbortCause {
00025             UserAbort,      // the user aborted the active wait loop
00026             RemoteAbort,    // a remote event aborted the active wait loop
00027             NotSpecified    // the cause for the abort is not specified
00028         };
00029
00031         TipdBasedActiveWaitDispatcher(Tipd tipd);
00032
00034         virtual ~TipdBasedActiveWaitDispatcher() {}
00035
00038         BOOLEAN IsEqualTipd(Tipd tipd) const { return m_tipd == tipd; }
00039
00043         virtual void AbortIfEqualTipd(Tipd tipd, AbortCause cause = NotSpecified);
00044
00046         AbortCause GetAbortCause() const { return m_cause; }
00047
00048     protected:
00050         Tipd GetTipd() const { return m_tipd; }
00051
00053         void SetTipd(Tipd tipd) { m_tipd = tipd; }
00054
00055     private:
00056         Tipd m_tipd;
00057         AbortCause m_cause;
00058
00059 };
00060
00062 #endif // Asc_TipdBasedActiveWaitDispatcher_hpp
00063
00064
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TtyInterface.cpp File Reference

Asc/TtyInterface.cpp File Reference

#include "Asc/PreComp.hpp"
#include "TtyInterface.hpp"

Include dependency graph for TtyInterface.cpp:

Generated on Tue Jan 24 17:41:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TtyInterface.hpp File Reference

Asc/TtyInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TtyInterface

Defines

#define | Asc_TtyInterface_hpp

Define Documentation

#define Asc_TtyInterface_hpp

Generated on Tue Jan 24 17:41:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/TtyInterface.hpp Source File

Asc/TtyInterface.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_TtyInterface_hpp)
00009 #define Asc_TtyInterface_hpp
00012
00015 class TtyInterface {
00016     public:
00017
00019         TtyInterface() {}
00020
00022         virtual ~TtyInterface() {}
00023
00027         BOOLEAN TtySupported(BOOLEAN & supported);
00028
00031         BOOLEAN TtySupported();
00032
00036         BOOLEAN GetTtyMode(TtyMode & mode);
00037
00040         TtyMode GetTtyMode();
00041
00045         BOOLEAN SetTtyMode(TtyMode mode);
00046
00050         BOOLEAN GetTtySpeed(TtySpeed & speed);
00051
00054         TtySpeed GetTtySpeed();
00055
00056
00060         BOOLEAN SetTtySpeed(TtySpeed speed);
00061 };
00062
00064 #endif // Asc_TtyInterface_hpp
00065
00066
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Types.hpp File Reference

Asc/Types.hpp File Reference

#include <Apc/SignalTypes.hpp>

Include dependency graph for Types.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | CallEvent
A simple structure providing information on an event happened to a particular call. More...

Defines

#define | Asc_Types_hpp

Typedefs

typedef INT | CallIndex
typedef INT | ChannelNo

Enumerations

enum CallApiRc {
NoError, CallDataLocked, NoNetwork, ActiveCallDetected,
ActiveCallRequired, HeldCallDetected, HeldCallRequired, SetupCallDetected,
SpeechCallRequired, MaxCallCountExceeded, CallSetupRejected, HoldRequestRejected,
RetrieveRequestRejected, JoinCallsRejected, InvalidCallIndex, VoidCallIndex,
MptyCallRequired, MptyCallDetected, ActiveMptyRequired, MaxMptyMemberCountExceeded,
InvalidMptyMemberCount, CallNotMptyMember, CallDisconnected, SupplementaryServiceFailed,
SecondCallMissing, UnexpectedResult, SimToolkitCallSetupFailed, DataCallDetected,
DataCallRequired, MocChangedToSupplementaryService, MocChangedToUssd, SwapRequestRejected,
CallAcceptForbidden, NotSupported
}
This structure comprises all call handling related errors. More...
enum | ClearCause { SubscriberBusy = UserBusy, RejectCall = CallRejected }
This structure comprises the causes for a call rejection. More...
enum | DisconnectingMode { UserDisconnetion, NetWorkDisconnection, NotSpecified }
This enum comprises the modes of disconnection. More...
enum SsApiRc {
UnspecifedRc, Success, SupplementaryServicePending, SupplementaryServiceNotPending,
InvalidTipd, InvalidServiceCode, InvalidMmiServiceGroup, InvalidBasicService,
InvalidTimeOut, InvalidPhoneNumber, SupplementaryServiceDenied, NormalServiceRequired,
SsDataLocked, ConfPasswordMismatch, SupplementaryServiceChangedToMoc, SupplementaryServiceChangedToSs,
SupplementaryServiceChangedToUssd, UssdTransactionError, InvalidPriority, SupplementaryServiceNotSupported
}
This enum comprises the causes for a supplementary service rejection by MN. More...
enum TtyMode {
TtyOff = 0, TtyAuto = 1, TtyVco = 2, TtyHco = 3,
TtyModeUnknown = 4
}
maps the stack parameter T_TTY_DEVICE_MODE More...
enum | TtySpeed { Tty45_5 = 0, Tty50_0 = 1, TtySpeedUnknown = 2 }
maps the stack parameter T_TTY_DEVICE_SPEED More...

Variables

const INT | c_max_calls = 14
const ChannelNo | c_max_channels = (ChannelNo)2
const INT | c_max_mpty_members = 5
const CallIndex | c_mpty_indication = (CallIndex)c_max_calls + 1
const UINT32 | c_mutex_timeout = 500
const CallIndex | c_null_call_index = (CallIndex)-1
const ChannelNo | c_null_channel_no = (ChannelNo)-1
const UINT32 | c_sem_obtain_timeout = 500

Define Documentation

#define Asc_Types_hpp

Generated on Tue Jan 24 15:27:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Types.hpp Source File

Asc/Types.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Types_hpp)
00009 #define Asc_Types_hpp
00012
00013 #include <Apc/SignalTypes.hpp>
00014
00015 typedef INT CallIndex;
00016 typedef INT ChannelNo;
00017
00018 const INT c_max_mpty_members = 5;
00019 const INT c_max_calls = 14;
00020
00021 const ChannelNo c_max_channels = (ChannelNo)2;
00022 const ChannelNo c_null_channel_no = (ChannelNo)-1;
00023 const CallIndex c_null_call_index = (CallIndex)-1;
00024 const CallIndex c_mpty_indication = (CallIndex)c_max_calls + 1;
00025
00026 const UINT32 c_sem_obtain_timeout = 500;    // 500 ms UINT32 instead of Ticks!!!
00027 const UINT32 c_mutex_timeout = 500;         // 500 ms
00028
00029
00031 enum CallApiRc {
00033     NoError,
00035     CallDataLocked,
00037     NoNetwork,
00039     ActiveCallDetected,
00041     ActiveCallRequired,
00043     HeldCallDetected,
00045     HeldCallRequired,
00047     SetupCallDetected,
00049     SpeechCallRequired,
00051     MaxCallCountExceeded,
00053     CallSetupRejected,
00055     HoldRequestRejected,
00057     RetrieveRequestRejected,
00059     JoinCallsRejected,
00061     InvalidCallIndex,
00063     VoidCallIndex,
00065     MptyCallRequired,
00067     MptyCallDetected,
00069     ActiveMptyRequired,
00071     MaxMptyMemberCountExceeded,
00073     InvalidMptyMemberCount,
00075     CallNotMptyMember,
00077     CallDisconnected,
00079     SupplementaryServiceFailed,
00081     SecondCallMissing,
00083     UnexpectedResult,
00085     SimToolkitCallSetupFailed,
00087     DataCallDetected,
00089     DataCallRequired,
00091     MocChangedToSupplementaryService,
00093     MocChangedToUssd,
00095     SwapRequestRejected,
00097     CallAcceptForbidden,
00099     NotSupported
00100 };
00101
00102
00104 enum ClearCause {
00108     SubscriberBusy = UserBusy,
00109     // This cause indicates that the equipment sending this cause does not wish
00110     // to accept this call, although it could have accepted the call because
00111     // the equipment sending this cause is neither busy nor incompatible.
00112     RejectCall = CallRejected   // obsolete
00113 };
00114
00115
00117 enum SsApiRc {
00119     UnspecifedRc,
00121     Success,
00123     SupplementaryServicePending,
00125     SupplementaryServiceNotPending,
00127     InvalidTipd,
00129     InvalidServiceCode,
00131     InvalidMmiServiceGroup,
00134     InvalidBasicService,
00136     InvalidTimeOut,
00138     InvalidPhoneNumber,
00140     SupplementaryServiceDenied,
00142     NormalServiceRequired,
00144     SsDataLocked,
00146     ConfPasswordMismatch,
00148     SupplementaryServiceChangedToMoc,
00150     SupplementaryServiceChangedToSs,
00152     SupplementaryServiceChangedToUssd,
00154     UssdTransactionError,
00156     InvalidPriority,
00158     SupplementaryServiceNotSupported
00159 };
00160
00161
00163 struct CallEvent {
00164
00165     enum Action {
00166         MocInSetup,
00167         MocEstablished,     // an moc has been successfully established
00168         MocRejected,        // an moc has been rejected
00169         MtcIsWaiting,       // an mtc has arrived and waits to be accepted/rejected
00170         // MtcAccepted,
00171         // MtcRejected,     // waiting mtc has been rejected by user
00172         MtcEstablished,     // waiting mtc has ben sucessfully established
00173         CallReleased,       // call released by user
00174         CallDisconnected,   // call disconnected by remote party
00175         CallIsHeld,         // active call has been put on hold
00176         CallRetrieved,      // held call has been retrieved
00177         EctAccomplished,    // ect procedure started disconnnect msgs will follow-up
00178         MultipartyJoin,
00179         MultiPartyOnHold,
00180         MultiPartyRetrieved,
00181         MultiPartyReleased,
00182         MultiPartySplitted,
00183
00184         // For MM Calls
00185         MmMocInSetup,
00186         MmMocEstablished,
00187         MmMocRejected,
00188         MmMtcIsWaiting,
00189         MmMtcEstablished,
00190         MmCallReleased,
00191         MmCallDisconnected
00192     } ;
00193
00194     Action action;          // what happened
00195     CallIndex call_index;   // which call was affected/c_null_call_index
00196 };
00197
00198 /*
00199     MocSetup            = MN_MOC_CALL_SETUP,
00200     MocStarted          = MN_MOC_CALL_STARTED,
00201     MocActive           = MN_MOC_CALL_ACTIVE,
00202     MtcConfirmed        = MN_MTC_CALL_CONFIRMED,
00203     MtcSetup            = MN_MTC_CALL_SETUP,
00204     MtcBcNegotiated     = MN_MTC_BC_NEGOTIATED,
00205     MtcStarted          = MN_MTC_CALL_STARTED,
00206     MtcActive           = MN_MTC_CALL_ACTIVE,
00207     MocAsCallSetup      = MN_MOC_AS_CALL_SETUP,
00208     MtcAsCallSetup      = MN_MTC_AS_CALL_SETUP,
00209     MtcRejected         = MN_MTC_CALL_REJECTED,
00210     CallIsHeld          = MN_CALL_IS_HELD,
00211     CallIsRetrieved     = MN_CALL_IS_RETRIEVED,
00212     MptyIsActive        = MN_MPARTY_IS_ACTIVE,
00213     MptyIsHeld          = MN_MPARTY_IS_HELD,
00214     MptyIsRetrieved     = MN_MPARTY_IS_RETRIEVED,
00215     MptyIsSplitted      = MN_MPARTY_IS_SPLITTED,
00216     IsEct               = MN_IS_ECT,
00217     CallIsCleared       = MN_CALL_IS_CLEARED,
00218     CallModifyIndicated = MN_CALL_MODIFY_INDICATED,
00219     CallModifyStarted   = MN_CALL_MODIFY_STARTED,
00220     CallModifyCompleted = MN_CALL_MODIFY_COMPLETED,
00221     CallModifyRejected  = MN_CALL_MODIFY_REJECTED
00222 */
00223
00225 enum DisconnectingMode {
00227     UserDisconnetion,
00229     NetWorkDisconnection,
00231     NotSpecified
00232 };
00233
00234
00236 enum TtyMode {
00237 #if defined APOXI_CTM
00238     TtyOff     = TTY_MODE_OFF,
00239     TtyAuto    = TTY_MODE_AUTO,
00240     TtyVco     = TTY_MODE_VCO,
00241     TtyHco     = TTY_MODE_HCO,
00242 #else
00243     TtyOff  = 0,
00244     TtyAuto = 1,
00245     TtyVco  = 2,
00246     TtyHco  = 3,
00247 #endif
00248     TtyModeUnknown = 4
00249 };
00250
00252 enum TtySpeed {
00253 #if defined APOXI_CTM
00254     Tty45_5 = TTY_45_5_BAUDOT,
00255     Tty50_0 = TTY_50_0_BAUDOT,
00256 #else
00257     Tty45_5 = 0,
00258     Tty50_0 = 1,
00259 #endif
00260     TtySpeedUnknown = 2
00261 };
00262
00264 #endif  // Asc_Types_hpp
00265
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/UssdHandler.cpp File Reference

Asc/UssdHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include "UssdHandler.hpp"
#include "SsMainHandler.hpp"
#include "MobileOriginatedUssdHandler.hpp"

Include dependency graph for UssdHandler.cpp:

Generated on Tue Jan 24 17:41:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/UssdHandler.hpp File Reference

Asc/UssdHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/SsStackMsgArgs.hpp>
#include <Asc/SsBaseHandler.hpp>

Include dependency graph for UssdHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UssdHandler

Defines

#define | Asc_UssdHandler_hpp

Define Documentation

#define Asc_UssdHandler_hpp

Generated on Tue Jan 24 17:41:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/UssdHandler.hpp Source File

Asc/UssdHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_UssdHandler_hpp)
00011 #define Asc_UssdHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Apc/SsStackMsgArgs.hpp>
00016
00017 #include <Asc/SsBaseHandler.hpp>
00018
00019
00020 class UssdBeginMsg;
00021 class UssdNotifyMsg;
00022 class UssdRequestMsg;
00023
00024
00051 class UssdHandler : public SsBaseHandler {
00055     friend class UssdBeginMsg;
00056
00059     typedef SsBaseHandler Base;
00060
00061 public:
00065     enum { ID = UssdHandlerId };
00066     UssdHandler();
00067
00071     virtual HandlerId GetHandlerId() const;
00072
00073     // SCCH - TBD
00074     // Do we need to be able to send SSEndReqInds?
00075
00076
00089     virtual SsApiRc Acknowledge(const UssdNotifyMsg& msg);
00090
00102     virtual SsApiRc Acknowledge(Tipd tipd);
00103
00114     virtual SsApiRc Reply(const UssdRequestMsg& msg, const WString& ctrl_info, const DataCodingScheme& dcs);
00115
00125     virtual SsApiRc Reply(Tipd tipd, const WString& ctrl_info, const DataCodingScheme& dcs);
00126
00137     virtual SsApiRc SendError(Tipd tipd, SsErrorCode error_code);
00138
00149     virtual SsApiRc SendRejection(Tipd tipd, TaggedProblemCode code = TaggedProblemCode::ResourceLimitation);
00150
00151 protected:
00168     virtual ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument& arg);
00169
00184     SsApiRc BeginTransaction(const SsStackMsgArgument& arg);
00185
00196     virtual ReturnCode EndTransaction(const Tipd tipd);
00197
00198 private:
00207     ReturnCode CreateRequestMsg(const SsUssdIndArg& arg, SsMessage*& msg) const;
00208
00217     ReturnCode CreateNotifyMsg(const SsUssdIndArg& arg, SsMessage*& msg) const;
00218 };
00219
00220 #endif // Asc_UssdHandler_hpp
00221
00222
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/UusHandler.cpp File Reference

Asc/UusHandler.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Auxiliary/Vector.hpp>
#include <Asc/Types.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Asc/InputParserTranslator.hpp>
#include "SsMainHandler.hpp"
#include "UusHandler.hpp"

Include dependency graph for UusHandler.cpp:

Generated on Tue Jan 24 17:41:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/UusHandler.hpp File Reference

Asc/UusHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/SsBaseHandler.hpp>
#include <Asc/InputParser.hpp>

Include dependency graph for UusHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UusHandler

Defines

#define | Asc_UusHandler_hpp

Define Documentation

#define Asc_UusHandler_hpp

Generated on Tue Jan 24 17:41:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/UusHandler.hpp Source File

Asc/UusHandler.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG.
00003    All rights reserved.
00004    ------------------------------------------------------------------------
00005    This document contains proprietary information belonging to COMNEON.
00006    Passing on and copying of this document, use and communication of its
00007    contents is not permitted without prior written authorisation.
00008    ------------------------------------------------------------------------ */
00009
00010 #if !defined(Asc_UusHandler_hpp)
00011 #define Asc_UusHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/SsBaseHandler.hpp>
00016 #include <Asc/InputParser.hpp>
00017
00022 class UusHandler : public SsBaseHandler {
00025     typedef SsBaseHandler Base;
00026
00027  public:
00031     enum { ID = UusHandlerId };
00032
00034     UusHandler();
00036     virtual ~UusHandler();
00037
00041     virtual HandlerId GetHandlerId() const;
00042
00062     SsApiRc Register(SsCode ss_code, const WString& uus_text, UusOutTextType type);
00063
00079     SsApiRc Erase(SsCode ss_code, UusOutTextType type);
00080
00092     SsApiRc RequestStatus(SsCode ss_code);
00093
00094  protected:
00095     // not needed in this handler (at least for now)
00096     virtual ReturnCode ProcessStackMsgArgument(const SsStackMsgArgument &argument) { return OkNoMessage; }
00097
00098  private:
00099
00100     SsApiRc SendUusRequest(SsCode ss_code, SsOperationCode op_code, StackMsgArgument* arg) ;
00101
00104     LineSelector m_line;
00105
00108 //    ServiceGroup m_param_bs_code;
00109 };
00110
00111 #endif // Asc_UusHandler_hpp
00112
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ValueMap.hpp File Reference

Asc/ValueMap.hpp File Reference

#include <Asc/Target/ValueMap.hpp>

Include dependency graph for ValueMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | ApoxiDefineEntity(val) APOXI_DEFINE_ENTITY_##val
#define | ApoxiDefineScopeEntity(val, scope) APOXI_DEFINE_SCOPE_ENTITY_##scope##_##val
#define | Asc_ValueMap_hpp

Define Documentation

#define Asc_ValueMap_hpp

Generated on Tue Jan 24 17:24:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/ValueMap.hpp Source File

Asc/ValueMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_ValueMap_hpp)
00009 #define Asc_ValueMap_hpp
00012
00013 /*  ------------------------------------------------------------------------
00014     This file is used to support value mapping macros to supply the use of
00015     configuration independent definition of constants and enums.
00016     The values of the so-defined constants and enums are assinged within the
00017     various configuration dependant ValueMap.hpp files.
00018     If a new class-scope is used, then an accordingly configuration independant
00019     scope macro must be defined.
00020     ------------------------------------------------------------------------ */
00021
00022 /*  ------------------------------------------------------------------------
00023     macros for configuration independent definition of constants and enums.
00024     these macros form the programmer's interface.
00025     ------------------------------------------------------------------------ */
00026 // general macros for configuration independent value definitions
00027 #define ApoxiDefineEntity(val) APOXI_DEFINE_ENTITY_##val
00028
00029
00030 // general assignement macro for configuration independent value definitions using a scope qualifier
00031 #define ApoxiDefineScopeEntity(val, scope) APOXI_DEFINE_SCOPE_ENTITY_##scope##_##val
00032
00033
00034 /*  ------------------------------------------------------------------------
00035     configuration dependent ValueMap.hpp's
00036     ------------------------------------------------------------------------ */
00037 #include <Asc/Target/ValueMap.hpp>
00038
00040 #endif  // Asc_ValueMap_hpp
00041
Generated on Tue Jan 24 14:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/DataCallHdl.cpp File Reference

Asc/Host/DataCallHdl.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/DataCallHdl.hpp>
#include <Asc/DataCallControl.hpp>
#include <Asc/DataCallTypes.hpp>
#include "DataCallSignalProcessor.hpp"

Include dependency graph for DataCallHdl.cpp:

Generated on Tue Jan 24 17:22:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/DataCallSignalProcessor.cpp File Reference

Asc/Host/DataCallSignalProcessor.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/DataCallHdl.hpp>
#include <Asc/DataCallControl.hpp>
#include "DataCallSignalProcessor.hpp"

Include dependency graph for DataCallSignalProcessor.cpp:

Generated on Tue Jan 24 17:22:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/DataCallSignalProcessor.hpp File Reference

Asc/Host/DataCallSignalProcessor.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataCallSignalProcessor

Defines

#define | Asc_Host_DataCallSignalProcessor_hpp

Define Documentation

#define Asc_Host_DataCallSignalProcessor_hpp

Generated on Tue Jan 24 17:22:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/DataCallSignalProcessor.hpp Source File

Asc/Host/DataCallSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Host_DataCallSignalProcessor_hpp)
00009 #define Asc_Host_DataCallSignalProcessor_hpp
00010
00011 /*  ========================================================================
00012     DataCallSignalProcessor
00013     ======================================================================== */
00015 class DataCallSignalProcessor {
00016     public:
00017         /*  ================================================================
00018             Circuit switched data call signal-transformation
00019             ================================================================ */
00020         static void PostIpdsSetupCnf();
00021         static void PostIpdsSetupRej();
00022         static void PostIpdsReleaseInd();
00023         static void PostIpdsReleaseCnf();
00024 };
00025
00026 #endif  // Asc_Host_DataCallSignalProcessor_hpp
00027
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/PdpContext.host.cpp File Reference

Asc/Host/PdpContext.host.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Kernel/Os/Win32/Win32.hpp>
#include "../PdpContext.hpp"
#include "../PdpContextControl.hpp"
#include "../PdpContextManager.hpp"

Include dependency graph for PdpContext.host.cpp:

Typedefs

typedef void(PdpContextControl::* CallbackMethod )(PdpContext::ErrorCause)

Typedef Documentation

typedef void(PdpContextControl::* CallbackMethod)(PdpContext::ErrorCause)

Generated on Tue Jan 24 17:22:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/PdpContextManager.host.cpp File Reference

Asc/Host/PdpContextManager.host.cpp File Reference

#include "Asc/PreComp.hpp"
#include "../PdpContext.hpp"
#include "../PdpContextManagerControl.hpp"
#include "../PdpContextManager.hpp"

Include dependency graph for PdpContextManager.host.cpp:

Typedefs

typedef void(PdpContextManagerControl::* | CallbackMethod )(PdpContext::ErrorCause)
typedef void(* | ResetStateFunc )()

Typedef Documentation

typedef void(PdpContextManagerControl::* CallbackMethod)(PdpContext::ErrorCause)

typedef void(* ResetStateFunc)()

Generated on Tue Jan 24 17:23:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/PreComp.cpp File Reference

Asc/Host/PreComp.cpp File Reference

#include "Asc/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/ValueMap.hpp File Reference

Asc/Host/ValueMap.hpp File Reference

Go to the source code of this file.

Defines

#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationRejectedByGgsn ActivationRejectedByGgsn = 30
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_1 LlcSapi_1 = 1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_11 LlcSapi_11 = 11
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_3 LlcSapi_3 = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_5 LlcSapi_5 = 5
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_7 LlcSapi_7 = 7
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_9 LlcSapi_9 = 9
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_Invalid LlcSapi_Invalid = 255
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_NotAssigned LlcSapi_NotAssigned = 0
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_1 RadioPriorityLevel_1 = 1
enum RadioPriority
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_2 RadioPriorityLevel_2 = 2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_3 RadioPriorityLevel_3 = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_4 RadioPriorityLevel_4 = 4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_Undefined RadioPriorityLevel_Undefined = 0
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateAccepted StateAccepted = 0
enum State
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateFiveTimeT3380Expiry StateFiveTimeT3380Expiry = 2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateRejected StateRejected = 1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUnknownCause StateUnknownCause = 4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUserInteruption StateUserInteruption = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Address_c_max_len c_max_len = 19
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_account_len c_max_account_len = 20
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_password_len c_max_password_len = 10
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Chap Chap
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_None None
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Pap Pap
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_AuthenticationFailure AuthenticationFailure = 29
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_c_max_access_point_name_len c_max_access_point_name_len = 101
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ConditionalIeError ConditionalIeError = 100
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_GprsServiceNotAllowed GprsServiceNotAllowed = 7
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IeNonExistent IeNonExistent = 99
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMe IllegalMe = 6
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMs IllegalMs = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InsufficientRessources InsufficientRessources = 26
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidMandatoryIe InvalidMandatoryIe = 96
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidTi InvalidTi = 81
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpDynamicType IpDynamicType
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpStaticType IpStaticType
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpType IpType
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LaNotAllowed LaNotAllowed = 12
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LlcOrSndcpFailure LlcOrSndcpFailure = 25
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ManufProtocol ManufProtocol
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MissingOrUnknownApn MissingOrUnknownApn = 27
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MobileStation MobileStation
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgNotCompatible MsgNotCompatible = 101
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotCompatible MsgTypeNotCompatible = 98
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotExistent MsgTypeNotExistent = 97
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NationalRoamingNotAllowed NationalRoamingNotAllowed = 13
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Network Network
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NetworkFailure NetworkFailure = 38
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoError NoError
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoProtocol NoProtocol
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoType NoType
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NsapiAlreadyUsed NsapiAlreadyUsed = 35
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NullProtocol NullProtocol
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_OspihType OspihType
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_1 Type_1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_2 Type_2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_3 Type_3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_Unknown Type_Unknown
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PadProtocol PadProtocol
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PlmnNotAllowed PlmnNotAllowed = 11
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppProtocol PppProtocol
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppType PppType
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QosNotAccepted QosNotAccepted = 37
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayBestEffort DelayBestEffort
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass1 DelayClass1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass2 DelayClass2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass3 DelayClass3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayReserved DelayReserved
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelaySubscribed DelaySubscribed
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100 MeanRate100
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100K MeanRate100K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10K MeanRate10K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10M MeanRate10M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1K MeanRate1K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1M MeanRate1M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200 MeanRate200
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200K MeanRate200K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20K MeanRate20K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20M MeanRate20M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2K MeanRate2K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2M MeanRate2M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500 MeanRate500
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500K MeanRate500K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50K MeanRate50K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50M MeanRate50M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5K MeanRate5K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5M MeanRate5M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateBestEffort MeanRateBestEffort
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateReserved MeanRateReserved
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateSubscribed MeanRateSubscribed
enum MeanRate
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate128K PeakRate128K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate16K PeakRate16K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate1K PeakRate1K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate256K PeakRate256K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate2K PeakRate2K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate32K PeakRate32K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate4K PeakRate4K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate64K PeakRate64K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate8K PeakRate8K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateReserved PeakRateReserved
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateSubscribed PeakRateSubscribed
enum PeakRate
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceHigh PrecedenceHigh
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceLow PrecedenceLow
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceNormal PrecedenceNormal
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceReserved PrecedenceReserved
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceSubscribed PrecedenceSubscribed
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass1 ReliabilityClass1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass2 ReliabilityClass2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass3 ReliabilityClass3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass4 ReliabilityClass4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass5 ReliabilityClass5
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass6 ReliabilityClass6
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityReserved ReliabilityReserved
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilitySubscribed ReliabilitySubscribed
enum Reliability
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ReactivationRequired ReactivationRequired = 39
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RegularDeactivation RegularDeactivation = 36
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RequestedServiceOptionNotSubscribed RequestedServiceOptionNotSubscribed = 33
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_SemanticIncorrectMsg SemanticIncorrectMsg = 95
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionNotSupported ServiceOptionNotSupported = 32
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionTemporaryOutOfOrder ServiceOptionTemporaryOutOfOrder = 34
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UndefinedError UndefinedError
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownOrigin UnknownOrigin
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownPdpAddress UnknownPdpAddress = 28
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedActivationRejection UnspecifiedActivationRejection = 31
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedProtocolError UnspecifiedProtocolError = 111
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Protocol X25Protocol
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Type X25Type
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateAccepted StateAccepted = 0
enum State
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateFiveTimeT3310Expiry StateFiveTimeT3310Expiry = 2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateRejected StateRejected = 1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUnknownCause StateUnknownCause = 4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUserInteruption StateUserInteruption = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_c_max_cid_array_len c_max_cid_array_len = 11
#define | Asc_Host_ValueMap_hpp

Define Documentation

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationRejectedByGgsn ActivationRejectedByGgsn = 30

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_1 LlcSapi_1 = 1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_11 LlcSapi_11 = 11

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_3 LlcSapi_3 = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_5 LlcSapi_5 = 5

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_7 LlcSapi_7 = 7

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_9 LlcSapi_9 = 9

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_Invalid LlcSapi_Invalid = 255

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_NotAssigned LlcSapi_NotAssigned = 0

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_1 RadioPriorityLevel_1 = 1

enum RadioPriority

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_2 RadioPriorityLevel_2 = 2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_3 RadioPriorityLevel_3 = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_4 RadioPriorityLevel_4 = 4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_Undefined RadioPriorityLevel_Undefined = 0

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateAccepted StateAccepted = 0

enum State

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateFiveTimeT3380Expiry StateFiveTimeT3380Expiry = 2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateRejected StateRejected = 1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUnknownCause StateUnknownCause = 4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUserInteruption StateUserInteruption = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Address_c_max_len c_max_len = 19

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_account_len c_max_account_len = 20

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_password_len c_max_password_len = 10

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Chap Chap

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_None None

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Pap Pap

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_AuthenticationFailure AuthenticationFailure = 29

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_c_max_access_point_name_len c_max_access_point_name_len = 101

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ConditionalIeError ConditionalIeError = 100

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_GprsServiceNotAllowed GprsServiceNotAllowed = 7

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IeNonExistent IeNonExistent = 99

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMe IllegalMe = 6

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMs IllegalMs = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InsufficientRessources InsufficientRessources = 26

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidMandatoryIe InvalidMandatoryIe = 96

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidTi InvalidTi = 81

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpDynamicType IpDynamicType

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpStaticType IpStaticType

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpType IpType

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LaNotAllowed LaNotAllowed = 12

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LlcOrSndcpFailure LlcOrSndcpFailure = 25

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ManufProtocol ManufProtocol

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MissingOrUnknownApn MissingOrUnknownApn = 27

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MobileStation MobileStation

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgNotCompatible MsgNotCompatible = 101

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotCompatible MsgTypeNotCompatible = 98

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotExistent MsgTypeNotExistent = 97

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NationalRoamingNotAllowed NationalRoamingNotAllowed = 13

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Network Network

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NetworkFailure NetworkFailure = 38

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoError NoError

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoProtocol NoProtocol

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoType NoType

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NsapiAlreadyUsed NsapiAlreadyUsed = 35

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NullProtocol NullProtocol

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_OspihType OspihType

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_1 Type_1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_2 Type_2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_3 Type_3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_Unknown Type_Unknown

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PadProtocol PadProtocol

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PlmnNotAllowed PlmnNotAllowed = 11

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppProtocol PppProtocol

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppType PppType

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QosNotAccepted QosNotAccepted = 37

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayBestEffort DelayBestEffort

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass1 DelayClass1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass2 DelayClass2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass3 DelayClass3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayReserved DelayReserved

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelaySubscribed DelaySubscribed

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100 MeanRate100

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100K MeanRate100K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10K MeanRate10K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10M MeanRate10M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1K MeanRate1K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1M MeanRate1M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200 MeanRate200

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200K MeanRate200K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20K MeanRate20K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20M MeanRate20M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2K MeanRate2K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2M MeanRate2M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500 MeanRate500

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500K MeanRate500K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50K MeanRate50K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50M MeanRate50M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5K MeanRate5K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5M MeanRate5M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateBestEffort MeanRateBestEffort

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateReserved MeanRateReserved

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateSubscribed MeanRateSubscribed

enum MeanRate

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate128K PeakRate128K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate16K PeakRate16K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate1K PeakRate1K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate256K PeakRate256K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate2K PeakRate2K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate32K PeakRate32K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate4K PeakRate4K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate64K PeakRate64K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate8K PeakRate8K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateReserved PeakRateReserved

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateSubscribed PeakRateSubscribed

enum PeakRate

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceHigh PrecedenceHigh

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceLow PrecedenceLow

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceNormal PrecedenceNormal

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceReserved PrecedenceReserved

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceSubscribed PrecedenceSubscribed

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass1 ReliabilityClass1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass2 ReliabilityClass2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass3 ReliabilityClass3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass4 ReliabilityClass4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass5 ReliabilityClass5

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass6 ReliabilityClass6

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityReserved ReliabilityReserved

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilitySubscribed ReliabilitySubscribed

enum Reliability

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ReactivationRequired ReactivationRequired = 39

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RegularDeactivation RegularDeactivation = 36

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RequestedServiceOptionNotSubscribed RequestedServiceOptionNotSubscribed = 33

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_SemanticIncorrectMsg SemanticIncorrectMsg = 95

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionNotSupported ServiceOptionNotSupported = 32

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionTemporaryOutOfOrder ServiceOptionTemporaryOutOfOrder = 34

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UndefinedError UndefinedError

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownOrigin UnknownOrigin

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownPdpAddress UnknownPdpAddress = 28

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedActivationRejection UnspecifiedActivationRejection = 31

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedProtocolError UnspecifiedProtocolError = 111

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Protocol X25Protocol

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Type X25Type

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateAccepted StateAccepted = 0

enum State

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateFiveTimeT3310Expiry StateFiveTimeT3310Expiry = 2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateRejected StateRejected = 1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUnknownCause StateUnknownCause = 4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUserInteruption StateUserInteruption = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_c_max_cid_array_len c_max_cid_array_len = 11

#define Asc_Host_ValueMap_hpp

Generated on Tue Jan 24 17:23:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Host/ValueMap.hpp Source File

Asc/Host/ValueMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Host_ValueMap_hpp)
00009 #define Asc_Host_ValueMap_hpp
00010
00011 /*  ------------------------------------------------------------------------
00012     This file is used to map enums and constants to configuration dependent
00013     (e.g. different protocol stacks, different build mode, ...) values.
00014     If a class-scope is used, then a configuration independent scope macro
00015     must be defined in file <Asc/ValueMap.hpp>.
00016     ------------------------------------------------------------------------ */
00017
00018
00019 /*  ------------------------------------------------------------------------
00020     PdpContextManager <Asc/PdpContextManager.hpp>
00021     ------------------------------------------------------------------------ */
00022
00023 // constants
00024 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_c_max_cid_array_len c_max_cid_array_len = 11
00025
00026 /*  ------------------------------------------------------------------------
00027     PdpContextManager::AttachStatus <Asc/PdpContextManager.hpp>
00028     ------------------------------------------------------------------------ */
00029
00031 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateAccepted StateAccepted = 0
00032 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateRejected StateRejected = 1
00033 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateFiveTimeT3310Expiry StateFiveTimeT3310Expiry = 2
00034 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUserInteruption StateUserInteruption = 3
00035 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUnknownCause StateUnknownCause = 4
00036
00037 /*  ------------------------------------------------------------------------
00038     PdpContext <Asc/PdpContext.hpp>
00039     ------------------------------------------------------------------------ */
00040 // constants
00041 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_c_max_access_point_name_len c_max_access_point_name_len = 101
00042
00043 // enum Type
00044 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Type X25Type
00045 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpType IpType
00046 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpStaticType IpStaticType
00047 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpDynamicType IpDynamicType
00048 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_OspihType OspihType
00049 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppType PppType
00050 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoType NoType
00051
00052 // enum Protocol
00053 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NullProtocol NullProtocol
00054 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppProtocol PppProtocol
00055 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PadProtocol PadProtocol
00056 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Protocol X25Protocol
00057 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ManufProtocol ManufProtocol
00058 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoProtocol NoProtocol
00059
00060 // enum Origin
00061 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Network Network
00062 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MobileStation MobileStation
00063 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownOrigin UnknownOrigin
00064
00065 // enum ErrorCause
00066 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMs IllegalMs = 3
00067 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMe IllegalMe = 6
00068 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_GprsServiceNotAllowed GprsServiceNotAllowed = 7
00069 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PlmnNotAllowed PlmnNotAllowed = 11
00070 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LaNotAllowed LaNotAllowed = 12
00071 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NationalRoamingNotAllowed NationalRoamingNotAllowed = 13
00072
00073 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LlcOrSndcpFailure LlcOrSndcpFailure = 25
00074 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InsufficientRessources InsufficientRessources = 26
00075 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MissingOrUnknownApn MissingOrUnknownApn = 27
00076 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownPdpAddress UnknownPdpAddress = 28
00077 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_AuthenticationFailure AuthenticationFailure = 29
00078 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationRejectedByGgsn ActivationRejectedByGgsn = 30
00079 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedActivationRejection UnspecifiedActivationRejection = 31
00080 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionNotSupported ServiceOptionNotSupported = 32
00081 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RequestedServiceOptionNotSubscribed RequestedServiceOptionNotSubscribed = 33
00082 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionTemporaryOutOfOrder ServiceOptionTemporaryOutOfOrder = 34
00083 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NsapiAlreadyUsed NsapiAlreadyUsed = 35
00084 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RegularDeactivation RegularDeactivation = 36
00085 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QosNotAccepted QosNotAccepted = 37
00086 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NetworkFailure NetworkFailure = 38
00087 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ReactivationRequired ReactivationRequired = 39
00088 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidTi InvalidTi = 81
00089 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_SemanticIncorrectMsg SemanticIncorrectMsg = 95
00090 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidMandatoryIe InvalidMandatoryIe = 96
00091 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotExistent MsgTypeNotExistent = 97
00092 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotCompatible MsgTypeNotCompatible = 98
00093 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IeNonExistent IeNonExistent = 99
00094 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ConditionalIeError ConditionalIeError = 100
00095 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgNotCompatible MsgNotCompatible = 101
00096 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedProtocolError UnspecifiedProtocolError = 111
00097
00098 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UndefinedError UndefinedError
00099 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoError NoError
00100
00101
00102 /*  ------------------------------------------------------------------------
00103     PdpContext::Address <Asc/PdpContext.hpp>
00104     ------------------------------------------------------------------------ */
00105 // constants
00106 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Address_c_max_len c_max_len = 19
00107
00108 /*  ------------------------------------------------------------------------
00109     PdpContext::Authentication <Asc/PdpContext.hpp>
00110     ------------------------------------------------------------------------ */
00111 // constants
00112 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_account_len c_max_account_len = 20
00113 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_password_len c_max_password_len = 10
00114
00115 // enum Type
00116 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_None None
00117 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Pap Pap
00118 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Chap Chap
00119
00120 /*  ------------------------------------------------------------------------
00121     PdpContext::QualityOfService <Asc/PdpContext.hpp>
00122     ------------------------------------------------------------------------ */
00123 // enum Precedence
00124 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceSubscribed PrecedenceSubscribed
00125 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceHigh PrecedenceHigh
00126 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceNormal PrecedenceNormal
00127 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceLow PrecedenceLow
00128 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceReserved PrecedenceReserved
00129
00130
00131 // enum Delay
00132 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelaySubscribed DelaySubscribed
00133 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass1 DelayClass1
00134 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass2 DelayClass2
00135 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass3 DelayClass3
00136 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayBestEffort DelayBestEffort
00137 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayReserved DelayReserved
00138
00140 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilitySubscribed ReliabilitySubscribed
00141 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass1 ReliabilityClass1
00142 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass2 ReliabilityClass2
00143 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass3 ReliabilityClass3
00144 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass4 ReliabilityClass4
00145 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass5 ReliabilityClass5
00146 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass6 ReliabilityClass6
00147 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityReserved ReliabilityReserved
00148
00150 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateSubscribed PeakRateSubscribed
00151 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate1K PeakRate1K
00152 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate2K PeakRate2K
00153 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate4K PeakRate4K
00154 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate8K PeakRate8K
00155 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate16K PeakRate16K
00156 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate32K PeakRate32K
00157 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate64K PeakRate64K
00158 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate128K PeakRate128K
00159 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate256K PeakRate256K
00160 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateReserved PeakRateReserved
00161
00163 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateSubscribed MeanRateSubscribed
00164 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100 MeanRate100
00165 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200 MeanRate200
00166 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500 MeanRate500
00167 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1K MeanRate1K
00168 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2K MeanRate2K
00169 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5K MeanRate5K
00170 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10K MeanRate10K
00171 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20K MeanRate20K
00172 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50K MeanRate50K
00173 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100K MeanRate100K
00174 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200K MeanRate200K
00175 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500K MeanRate500K
00176 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1M MeanRate1M
00177 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2M MeanRate2M
00178 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5M MeanRate5M
00179 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10M MeanRate10M
00180 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20M MeanRate20M
00181 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50M MeanRate50M
00182 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateReserved MeanRateReserved
00183 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateBestEffort MeanRateBestEffort
00184
00185 /*  ------------------------------------------------------------------------
00186     PdpContext::ActivationStatus <Asc/PdpContext.hpp>
00187     ------------------------------------------------------------------------ */
00188
00190 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateAccepted StateAccepted = 0
00191 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateRejected StateRejected = 1
00192 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateFiveTimeT3380Expiry StateFiveTimeT3380Expiry = 2
00193 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUserInteruption StateUserInteruption = 3
00194 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUnknownCause StateUnknownCause = 4
00195
00197 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_1 RadioPriorityLevel_1 = 1
00198 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_2 RadioPriorityLevel_2 = 2
00199 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_3 RadioPriorityLevel_3 = 3
00200 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_4 RadioPriorityLevel_4 = 4
00201 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_Undefined RadioPriorityLevel_Undefined = 0
00202
00203 // enum LlcSapi
00204 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_NotAssigned LlcSapi_NotAssigned = 0
00205 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_1 LlcSapi_1 = 1
00206 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_3 LlcSapi_3 = 3
00207 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_5 LlcSapi_5 = 5
00208 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_7 LlcSapi_7 = 7
00209 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_9 LlcSapi_9 = 9
00210 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_11 LlcSapi_11 = 11
00211 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_Invalid LlcSapi_Invalid = 255
00212
00213 /*  ------------------------------------------------------------------------
00214     PdpContext::PacketFilter <Asc/PdpContext.hpp>
00215     ------------------------------------------------------------------------ */
00216 // enum Type
00217 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_1 Type_1
00218 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_2 Type_2
00219 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_3 Type_3
00220 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_Unknown Type_Unknown
00221
00222 #endif  // Asc_Host_ValueMap_hpp
00223
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/DataCallHdl.cpp File Reference

Asc/Target/DataCallHdl.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/DataCallHdl.hpp>
#include <Asc/DataCallControl.hpp>
#include <Asc/DataCallTypes.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for DataCallHdl.cpp:

Generated on Tue Jan 24 17:22:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/DataCallSignalMapTableNode.cpp File Reference

Asc/Target/DataCallSignalMapTableNode.cpp File Reference

#include "Asc/PreComp.hpp"
#include "DataCallSignalProcessor.hpp"
#include "DataCallSignalMapTableNode.hpp"

Include dependency graph for DataCallSignalMapTableNode.cpp:

Generated on Tue Jan 24 17:39:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/DataCallSignalMapTableNode.hpp File Reference

Asc/Target/DataCallSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for DataCallSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataCallSignalMapTableNode

Defines

#define | Asc_Target_DataCallSignalMapTable_hpp

Define Documentation

#define Asc_Target_DataCallSignalMapTable_hpp

Generated on Tue Jan 24 17:39:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/DataCallSignalMapTableNode.hpp Source File

Asc/Target/DataCallSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Target_DataCallSignalMapTable_hpp)
00009 #define Asc_Target_DataCallSignalMapTable_hpp
00010
00011 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00012
00013 /*  ======================================================================
00014     DataCallSignalMapTableNode
00015     ====================================================================== */
00016 class DataCallSignalMapTableNode : public SignalMapTableNode {
00017     public:
00018         static DataCallSignalMapTableNode* GetInstance();
00019
00020     private:
00021         static DataCallSignalMapTableNode *m_node;
00022         static const SignalMapTableEntry m_data_call_signal_map_table[];
00023
00024         DataCallSignalMapTableNode();
00025 };
00026
00027 #endif  // Asc_Target_DataCallSignalMapTable_hpp
00028
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/DataCallSignalProcessor.cpp File Reference

Asc/Target/DataCallSignalProcessor.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/DataCallHdl.hpp>
#include <Asc/DataCallControl.hpp>
#include "DataCallSignalProcessor.hpp"

Include dependency graph for DataCallSignalProcessor.cpp:

Generated on Tue Jan 24 17:22:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/DataCallSignalProcessor.hpp File Reference

Asc/Target/DataCallSignalProcessor.hpp File Reference

#include <Apc/SignalHandler/ProcessNode.hpp>

Include dependency graph for DataCallSignalProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataCallSignalProcessor

Defines

#define | Asc_Target_DataCallSignalProcessor_hpp

Define Documentation

#define Asc_Target_DataCallSignalProcessor_hpp

Generated on Tue Jan 24 17:22:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/DataCallSignalProcessor.hpp Source File

Asc/Target/DataCallSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Target_DataCallSignalProcessor_hpp)
00009 #define Asc_Target_DataCallSignalProcessor_hpp
00010
00011 #include <Apc/SignalHandler/ProcessNode.hpp>
00012
00013 /*  ========================================================================
00014     DataCallSignalProcessor
00015     ======================================================================== */
00017 class DataCallSignalProcessor {
00018     public:
00019         /*  ================================================================
00020             Circuit switched data call signal-transformation
00021             ================================================================ */
00022         static void PostIpdsSetupCnf(const ProcessPtr &process_ptr);
00023         static void PostIpdsSetupRej(const ProcessPtr &process_ptr);
00024         static void PostIpdsReleaseInd(const ProcessPtr &process_ptr);
00025         static void PostIpdsReleaseCnf(const ProcessPtr &process_ptr);
00026 };
00027
00028 #endif  // Asc_Target_DataCallSignalProcessor_hpp
00029
Generated on Tue Jan 24 14:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PdpContext.target.cpp File Reference

Asc/Target/PdpContext.target.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/PdpContext.hpp>
#include <Asc/PdpContextManager.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for PdpContext.target.cpp:

Generated on Tue Jan 24 17:40:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PdpContextManager.target.cpp File Reference

Asc/Target/PdpContextManager.target.cpp File Reference

#include "Asc/PreComp.hpp"
#include <Asc/PdpContext.hpp>
#include <Asc/PdpContextManager.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for PdpContextManager.target.cpp:

Generated on Tue Jan 24 17:40:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PdpContextSignalMapTableNode.cpp File Reference

Asc/Target/PdpContextSignalMapTableNode.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PdpContextSignalProcessor.hpp"
#include "PdpContextSignalMapTableNode.hpp"

Include dependency graph for PdpContextSignalMapTableNode.cpp:

Generated on Tue Jan 24 17:40:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PdpContextSignalMapTableNode.hpp File Reference

Asc/Target/PdpContextSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for PdpContextSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PdpContextSignalMapTableNode

Defines

#define | Asc_Target_PdpContextSignalMapTable_hpp

Define Documentation

#define Asc_Target_PdpContextSignalMapTable_hpp

Generated on Tue Jan 24 17:40:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PdpContextSignalMapTableNode.hpp Source File

Asc/Target/PdpContextSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Target_PdpContextSignalMapTable_hpp)
00009 #define Asc_Target_PdpContextSignalMapTable_hpp
00010
00011 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00012
00013 /*  ======================================================================
00014     PdpContextSignalMapTableNode
00015     ====================================================================== */
00016 class PdpContextSignalMapTableNode : public SignalMapTableNode {
00017     public:
00018         static PdpContextSignalMapTableNode* GetInstance();
00019
00020     private:
00021         static PdpContextSignalMapTableNode *m_node;
00022         static const SignalMapTableEntry m_pdp_context_signal_map_table[];
00023
00024         PdpContextSignalMapTableNode();
00025 };
00026
00027 #endif  // Asc_Target_PdpContextSignalMapTable_hpp
00028
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PdpContextSignalProcessor.cpp File Reference

Asc/Target/PdpContextSignalProcessor.cpp File Reference

#include "Asc/PreComp.hpp"
#include "PdpContextSignalProcessor.hpp"
#include <Asc/PdpContextManager.hpp>
#include <Asc/PdpContextManagerControl.hpp>
#include <Asc/PdpContextControl.hpp>

Include dependency graph for PdpContextSignalProcessor.cpp:

Generated on Tue Jan 24 17:40:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PdpContextSignalProcessor.hpp File Reference

Asc/Target/PdpContextSignalProcessor.hpp File Reference

#include <Apc/SignalHandler/ProcessNode.hpp>

Include dependency graph for PdpContextSignalProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PdpContextSignalProcessor

Defines

#define | Asc_Target_PdpContextSignalProcessor_hpp

Define Documentation

#define Asc_Target_PdpContextSignalProcessor_hpp

Generated on Tue Jan 24 17:40:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PdpContextSignalProcessor.hpp Source File

Asc/Target/PdpContextSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Asc_Target_PdpContextSignalProcessor_hpp)
00010 #define Asc_Target_PdpContextSignalProcessor_hpp
00011
00012 #include <Apc/SignalHandler/ProcessNode.hpp>
00013
00014 /*  ========================================================================
00015     PdpContextSignalProcessor
00016     ======================================================================== */
00018 class PdpContextSignalProcessor {
00019     public:
00020         /*  ================================================================
00021             Packet data protocol context signal-transformation
00022             ================================================================ */
00023         // attach
00024         static void ProcessPchAttachCnf(const ProcessPtr &process_ptr);
00025         static void ProcessPchAttachRej(const ProcessPtr &process_ptr);
00026         static void ProcessPchAttachRep(const ProcessPtr &process_ptr);
00027
00028         // detach
00029         static void ProcessPchDetachCnf(const ProcessPtr &process_ptr);
00030         static void ProcessPchDetachInd(const ProcessPtr &process_ptr);
00031
00032         // attach status indication
00033         static void ProcessMnAttachStatusInd(const ProcessPtr &process_ptr);
00034
00035         // primary context definition
00036         static void ProcessPchDefContCnf(const ProcessPtr &process_ptr);
00037         static void ProcessPchDefContRej(const ProcessPtr &process_ptr);
00038
00039         // secondary context definition
00040         static void ProcessPchCgdsContCnf(const ProcessPtr &process_ptr);
00041         static void ProcessPchCgdsContRej(const ProcessPtr &process_ptr);
00042
00043         // authentication
00044         static void ProcessPchAuthCnf(const ProcessPtr &process_ptr);
00045         static void ProcessPchAuthRej(const ProcessPtr &process_ptr);
00046
00047         // request quality of service
00048         static void ProcessPchSetQosCnf(const ProcessPtr &process_ptr);
00049         static void ProcessPchSetQosRej(const ProcessPtr &process_ptr);
00050
00051         // set minimum quality of service
00052         static void ProcessPchSetQosMinCnf(const ProcessPtr &process_ptr);
00053         static void ProcessPchSetQosMinRej(const ProcessPtr &process_ptr);
00054
00055         // mobile originated context activation
00056         static void ProcessPchActivateCnf(const ProcessPtr &process_ptr);
00057         static void ProcessPchActivateRej(const ProcessPtr &process_ptr);
00058
00059         static void ProcessPchPppActCnf(const ProcessPtr &process_ptr);
00060
00061         // mobile terminated context activation
00062         static void ProcessPchActivateInd(const ProcessPtr &process_ptr);
00063         static void ProcessPchActCompleteInd(const ProcessPtr &process_ptr);
00064         static void ProcessPchActFailedInd(const ProcessPtr &process_ptr);
00065
00066         static void ProcessPchReactivateInd(const ProcessPtr &process_ptr);
00067
00068         // status indication for successful/unsuccessful context activation
00069         static void ProcessPchActivateStatusInd(const ProcessPtr &process_ptr);
00070
00071         // context deactivation
00072         static void ProcessPchDeactivateCnf(const ProcessPtr &process_ptr);
00073         static void ProcessPchDeactivateInd(const ProcessPtr &process_ptr);
00074
00075         // context connection establishment
00076         static void ProcessPchDataStateCnf(const ProcessPtr &process_ptr);
00077         static void ProcessPchDataStateRej(const ProcessPtr &process_ptr);
00078
00079         // set data counters
00080         static void ProcessPchSetCntCnf(const ProcessPtr &process_ptr);
00081         static void ProcessPchSetCntRej(const ProcessPtr &process_ptr);
00082
00083         // read data counters
00084         static void ProcessPchReadCntInd(const ProcessPtr &process_ptr);
00085         static void ProcessPchReadCntRej(const ProcessPtr &process_ptr);
00086
00087         // Traffic Flow Template
00088         static void ProcessPchCgTftCnf(const ProcessPtr &process_ptr);
00089         static void ProcessPchCgTftRej(const ProcessPtr &process_ptr);
00090
00091         // DNS server address
00092         static void ProcessPchSetDnsRej(const ProcessPtr &process_ptr);
00093         static void ProcessPchSetDnsCnf(const ProcessPtr &process_ptr);
00094         static void ProcessPchReadDnsRej(const ProcessPtr &process_ptr);
00095         static void ProcessPchReadDnsCnf(const ProcessPtr &process_ptr);
00096 };
00097
00098 #endif  // Asc_Target_PdpContextSignalProcessor_hpp
00099
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/PreComp.cpp File Reference

Asc/Target/PreComp.cpp File Reference

#include "Asc/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/ValueMap.hpp File Reference

Asc/Target/ValueMap.hpp File Reference

#include <Apc/SignalTypes.hpp>

Include dependency graph for ValueMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationRejectedByGgsn ActivationRejectedByGgsn = SM_ACTIVATION_REJECTED_BY_GGSN
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_1 LlcSapi_1 = 1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_11 LlcSapi_11 = 11
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_3 LlcSapi_3 = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_5 LlcSapi_5 = 5
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_7 LlcSapi_7 = 7
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_9 LlcSapi_9 = 9
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_Invalid LlcSapi_Invalid = 255
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_NotAssigned LlcSapi_NotAssigned = 0
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_1 RadioPriorityLevel_1 = 1
enum RadioPriority
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_2 RadioPriorityLevel_2 = 2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_3 RadioPriorityLevel_3 = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_4 RadioPriorityLevel_4 = 4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_Undefined RadioPriorityLevel_Undefined = 0
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateAccepted StateAccepted = 0
enum State
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateFiveTimeT3380Expiry StateFiveTimeT3380Expiry = 2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateRejected StateRejected = 1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUnknownCause StateUnknownCause = 4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUserInteruption StateUserInteruption = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Address_c_max_len c_max_len = PDP_ADDRESS_LEN
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_account_len c_max_account_len = AUTH_USERNAME_LEN
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_password_len c_max_password_len = AUTH_PASSWORD_LEN
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Chap Chap = PCH_AUTH_CHAP
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_None None = PCH_AUTH_NONE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Pap Pap = PCH_AUTH_PAP
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_AuthenticationFailure AuthenticationFailure = SM_USER_AUTH_FAILED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_c_max_access_point_name_len c_max_access_point_name_len = APN_LEN
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ConditionalIeError ConditionalIeError = SM_CONDITIONAL_IE_ERROR
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_GprsServiceNotAllowed GprsServiceNotAllowed = ERR_GPRS_NOT_ALLOWED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IeNonExistent IeNonExistent = SM_IE_NON_EXISTENT
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMe IllegalMe = ERR_ILLEGAL_ME
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMs IllegalMs = ERR_ILLEGAL_MS
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InsufficientRessources InsufficientRessources = SM_INSUFFICIENT_RESOURCES
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidMandatoryIe InvalidMandatoryIe = SM_INV_MANDATORY_IE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidTi InvalidTi = SM_INVALID_TI
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpDynamicType IpDynamicType = IP_TYPE_DYNAMIC
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpStaticType IpStaticType = IP_TYPE_STATIC
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpType IpType = IP_TYPE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LaNotAllowed LaNotAllowed = ERR_LA_NOT_ALLOWED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LlcOrSndcpFailure LlcOrSndcpFailure = SM_LLC_OR_SNDCP_FAILURE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ManufProtocol ManufProtocol = L2_MANUF
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MissingOrUnknownApn MissingOrUnknownApn = SM_MISSING_OR_UNKNOWN_APN
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MobileStation MobileStation = PCH_MS
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgNotCompatible MsgNotCompatible = SM_MSG_NOT_COMPATIBLE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotCompatible MsgTypeNotCompatible = SM_MSG_TYPE_NOT_COMPATIBLE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotExistent MsgTypeNotExistent = SM_MSG_TYPE_NOT_EXISTENT
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NationalRoamingNotAllowed NationalRoamingNotAllowed = ERR_NAT_ROAMING_NOT_ALLOWED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Network Network = PCH_NW
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NetworkFailure NetworkFailure = SM_NETWORK_FAILURE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoError NoError
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoProtocol NoProtocol = L2_NONE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoType NoType = NO_TYPE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NsapiAlreadyUsed NsapiAlreadyUsed = SM_NSAPI_ALREADY_USED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NullProtocol NullProtocol = L2_NULL
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_OspihType OspihType = OSPIH_TYPE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_1 Type_1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_2 Type_2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_3 Type_3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_Unknown Type_Unknown
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PadProtocol PadProtocol = L2_PAD
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PlmnNotAllowed PlmnNotAllowed = ERR_PLMN_NOT_ALLOWED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppProtocol PppProtocol = L2_PPP
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppType PppType = PPP_TYPE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QosNotAccepted QosNotAccepted = SM_QOS_NOT_ACCEPTED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayBestEffort DelayBestEffort = DELAY_CLASS_4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass1 DelayClass1 = DELAY_CLASS_1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass2 DelayClass2 = DELAY_CLASS_2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass3 DelayClass3 = DELAY_CLASS_3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayReserved DelayReserved = DELAY_CLASS_R
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelaySubscribed DelaySubscribed = DELAY_CLASS_S
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100 MeanRate100 = MEAN_THP_100
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100K MeanRate100K = MEAN_THP_100K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10K MeanRate10K = MEAN_THP_10K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10M MeanRate10M = MEAN_THP_10M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1K MeanRate1K = MEAN_THP_1K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1M MeanRate1M = MEAN_THP_1M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200 MeanRate200 = MEAN_THP_200
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200K MeanRate200K = MEAN_THP_200K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20K MeanRate20K = MEAN_THP_20K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20M MeanRate20M = MEAN_THP_20M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2K MeanRate2K = MEAN_THP_2K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2M MeanRate2M = MEAN_THP_2M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500 MeanRate500 = MEAN_THP_500
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500K MeanRate500K = MEAN_THP_500K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50K MeanRate50K = MEAN_THP_50K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50M MeanRate50M = MEAN_THP_50M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5K MeanRate5K = MEAN_THP_5K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5M MeanRate5M = MEAN_THP_5M
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateBestEffort MeanRateBestEffort = MEAN_THP_BE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateReserved MeanRateReserved = MEAN_THP_R
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateSubscribed MeanRateSubscribed = MEAN_THP_S
enum MeanRate
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate128K PeakRate128K = PEAK_THP_128K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate16K PeakRate16K = PEAK_THP_16K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate1K PeakRate1K = PEAK_THP_1K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate256K PeakRate256K = PEAK_THP_256K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate2K PeakRate2K = PEAK_THP_2K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate32K PeakRate32K = PEAK_THP_32K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate4K PeakRate4K = PEAK_THP_4K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate64K PeakRate64K = PEAK_THP_64K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate8K PeakRate8K = PEAK_THP_8K
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateReserved PeakRateReserved = PEAK_THP_R
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateSubscribed PeakRateSubscribed = PEAK_THP_S
enum PeakRate
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceHigh PrecedenceHigh = PRECEDENCE_CLASS_H
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceLow PrecedenceLow = PRECEDENCE_CLASS_L
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceNormal PrecedenceNormal = PRECEDENCE_CLASS_N
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceReserved PrecedenceReserved = PRECEDENCE_CLASS_R
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceSubscribed PrecedenceSubscribed = PRECEDENCE_CLASS_S
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass1 ReliabilityClass1 = RELIABILITY_CLASS_1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass2 ReliabilityClass2 = RELIABILITY_CLASS_2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass3 ReliabilityClass3 = RELIABILITY_CLASS_3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass4 ReliabilityClass4 = RELIABILITY_CLASS_4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass5 ReliabilityClass5 = RELIABILITY_CLASS_5
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass6 ReliabilityClass6 = RELIABILITY_CLASS_6
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityReserved ReliabilityReserved = RELIABILITY_CLASS_R
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilitySubscribed ReliabilitySubscribed = RELIABILITY_CLASS_S
enum Reliability
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ReactivationRequired ReactivationRequired = SM_REACTIVATION_REQUIRED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RegularDeactivation RegularDeactivation = SM_REGULAR_DEACTIVATION
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RequestedServiceOptionNotSubscribed RequestedServiceOptionNotSubscribed = SM_REQ_SERVICE_NOT_SUBSCRIBED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_SemanticIncorrectMsg SemanticIncorrectMsg = SM_SEMANT_INCORRECT_MSG
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionNotSupported ServiceOptionNotSupported = SM_SERVICE_OPT_NOT_SUPPORTED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionTemporaryOutOfOrder ServiceOptionTemporaryOutOfOrder = SM_SERVICE_TEMP_OUT_OF_ORDER
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UndefinedError UndefinedError
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownOrigin UnknownOrigin
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownPdpAddress UnknownPdpAddress = SM_UNKNOWN_PDP_ADDRESS
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedActivationRejection UnspecifiedActivationRejection = SM_ACTIVATION_REJECTED_UNSPECIFIED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedProtocolError UnspecifiedProtocolError = SM_PROTOCOL_ERROR_UNSPECIFIED
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Protocol X25Protocol = L2_X25
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Type X25Type = X25_TYPE
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateAccepted StateAccepted = 0
enum State
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateFiveTimeT3310Expiry StateFiveTimeT3310Expiry = 2
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateRejected StateRejected = 1
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUnknownCause StateUnknownCause = 4
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUserInteruption StateUserInteruption = 3
#define | APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_c_max_cid_array_len c_max_cid_array_len = MAX_CID_ARRAY_LENGTH
#define | Asc_Target_TypeDef_hpp

Define Documentation

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationRejectedByGgsn ActivationRejectedByGgsn = SM_ACTIVATION_REJECTED_BY_GGSN

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_1 LlcSapi_1 = 1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_11 LlcSapi_11 = 11

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_3 LlcSapi_3 = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_5 LlcSapi_5 = 5

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_7 LlcSapi_7 = 7

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_9 LlcSapi_9 = 9

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_Invalid LlcSapi_Invalid = 255

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_NotAssigned LlcSapi_NotAssigned = 0

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_1 RadioPriorityLevel_1 = 1

enum RadioPriority

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_2 RadioPriorityLevel_2 = 2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_3 RadioPriorityLevel_3 = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_4 RadioPriorityLevel_4 = 4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_Undefined RadioPriorityLevel_Undefined = 0

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateAccepted StateAccepted = 0

enum State

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateFiveTimeT3380Expiry StateFiveTimeT3380Expiry = 2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateRejected StateRejected = 1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUnknownCause StateUnknownCause = 4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUserInteruption StateUserInteruption = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Address_c_max_len c_max_len = PDP_ADDRESS_LEN

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_account_len c_max_account_len = AUTH_USERNAME_LEN

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_password_len c_max_password_len = AUTH_PASSWORD_LEN

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Chap Chap = PCH_AUTH_CHAP

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_None None = PCH_AUTH_NONE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Pap Pap = PCH_AUTH_PAP

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_AuthenticationFailure AuthenticationFailure = SM_USER_AUTH_FAILED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_c_max_access_point_name_len c_max_access_point_name_len = APN_LEN

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ConditionalIeError ConditionalIeError = SM_CONDITIONAL_IE_ERROR

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_GprsServiceNotAllowed GprsServiceNotAllowed = ERR_GPRS_NOT_ALLOWED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IeNonExistent IeNonExistent = SM_IE_NON_EXISTENT

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMe IllegalMe = ERR_ILLEGAL_ME

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMs IllegalMs = ERR_ILLEGAL_MS

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InsufficientRessources InsufficientRessources = SM_INSUFFICIENT_RESOURCES

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidMandatoryIe InvalidMandatoryIe = SM_INV_MANDATORY_IE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidTi InvalidTi = SM_INVALID_TI

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpDynamicType IpDynamicType = IP_TYPE_DYNAMIC

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpStaticType IpStaticType = IP_TYPE_STATIC

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpType IpType = IP_TYPE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LaNotAllowed LaNotAllowed = ERR_LA_NOT_ALLOWED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LlcOrSndcpFailure LlcOrSndcpFailure = SM_LLC_OR_SNDCP_FAILURE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ManufProtocol ManufProtocol = L2_MANUF

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MissingOrUnknownApn MissingOrUnknownApn = SM_MISSING_OR_UNKNOWN_APN

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MobileStation MobileStation = PCH_MS

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgNotCompatible MsgNotCompatible = SM_MSG_NOT_COMPATIBLE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotCompatible MsgTypeNotCompatible = SM_MSG_TYPE_NOT_COMPATIBLE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotExistent MsgTypeNotExistent = SM_MSG_TYPE_NOT_EXISTENT

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NationalRoamingNotAllowed NationalRoamingNotAllowed = ERR_NAT_ROAMING_NOT_ALLOWED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Network Network = PCH_NW

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NetworkFailure NetworkFailure = SM_NETWORK_FAILURE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoError NoError

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoProtocol NoProtocol = L2_NONE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoType NoType = NO_TYPE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NsapiAlreadyUsed NsapiAlreadyUsed = SM_NSAPI_ALREADY_USED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NullProtocol NullProtocol = L2_NULL

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_OspihType OspihType = OSPIH_TYPE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_1 Type_1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_2 Type_2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_3 Type_3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_Unknown Type_Unknown

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PadProtocol PadProtocol = L2_PAD

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PlmnNotAllowed PlmnNotAllowed = ERR_PLMN_NOT_ALLOWED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppProtocol PppProtocol = L2_PPP

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppType PppType = PPP_TYPE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QosNotAccepted QosNotAccepted = SM_QOS_NOT_ACCEPTED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayBestEffort DelayBestEffort = DELAY_CLASS_4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass1 DelayClass1 = DELAY_CLASS_1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass2 DelayClass2 = DELAY_CLASS_2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass3 DelayClass3 = DELAY_CLASS_3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayReserved DelayReserved = DELAY_CLASS_R

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelaySubscribed DelaySubscribed = DELAY_CLASS_S

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100 MeanRate100 = MEAN_THP_100

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100K MeanRate100K = MEAN_THP_100K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10K MeanRate10K = MEAN_THP_10K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10M MeanRate10M = MEAN_THP_10M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1K MeanRate1K = MEAN_THP_1K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1M MeanRate1M = MEAN_THP_1M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200 MeanRate200 = MEAN_THP_200

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200K MeanRate200K = MEAN_THP_200K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20K MeanRate20K = MEAN_THP_20K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20M MeanRate20M = MEAN_THP_20M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2K MeanRate2K = MEAN_THP_2K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2M MeanRate2M = MEAN_THP_2M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500 MeanRate500 = MEAN_THP_500

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500K MeanRate500K = MEAN_THP_500K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50K MeanRate50K = MEAN_THP_50K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50M MeanRate50M = MEAN_THP_50M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5K MeanRate5K = MEAN_THP_5K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5M MeanRate5M = MEAN_THP_5M

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateBestEffort MeanRateBestEffort = MEAN_THP_BE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateReserved MeanRateReserved = MEAN_THP_R

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateSubscribed MeanRateSubscribed = MEAN_THP_S

enum MeanRate

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate128K PeakRate128K = PEAK_THP_128K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate16K PeakRate16K = PEAK_THP_16K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate1K PeakRate1K = PEAK_THP_1K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate256K PeakRate256K = PEAK_THP_256K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate2K PeakRate2K = PEAK_THP_2K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate32K PeakRate32K = PEAK_THP_32K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate4K PeakRate4K = PEAK_THP_4K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate64K PeakRate64K = PEAK_THP_64K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate8K PeakRate8K = PEAK_THP_8K

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateReserved PeakRateReserved = PEAK_THP_R

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateSubscribed PeakRateSubscribed = PEAK_THP_S

enum PeakRate

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceHigh PrecedenceHigh = PRECEDENCE_CLASS_H

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceLow PrecedenceLow = PRECEDENCE_CLASS_L

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceNormal PrecedenceNormal = PRECEDENCE_CLASS_N

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceReserved PrecedenceReserved = PRECEDENCE_CLASS_R

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceSubscribed PrecedenceSubscribed = PRECEDENCE_CLASS_S

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass1 ReliabilityClass1 = RELIABILITY_CLASS_1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass2 ReliabilityClass2 = RELIABILITY_CLASS_2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass3 ReliabilityClass3 = RELIABILITY_CLASS_3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass4 ReliabilityClass4 = RELIABILITY_CLASS_4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass5 ReliabilityClass5 = RELIABILITY_CLASS_5

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass6 ReliabilityClass6 = RELIABILITY_CLASS_6

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityReserved ReliabilityReserved = RELIABILITY_CLASS_R

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilitySubscribed ReliabilitySubscribed = RELIABILITY_CLASS_S

enum Reliability

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ReactivationRequired ReactivationRequired = SM_REACTIVATION_REQUIRED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RegularDeactivation RegularDeactivation = SM_REGULAR_DEACTIVATION

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RequestedServiceOptionNotSubscribed RequestedServiceOptionNotSubscribed = SM_REQ_SERVICE_NOT_SUBSCRIBED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_SemanticIncorrectMsg SemanticIncorrectMsg = SM_SEMANT_INCORRECT_MSG

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionNotSupported ServiceOptionNotSupported = SM_SERVICE_OPT_NOT_SUPPORTED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionTemporaryOutOfOrder ServiceOptionTemporaryOutOfOrder = SM_SERVICE_TEMP_OUT_OF_ORDER

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UndefinedError UndefinedError

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownOrigin UnknownOrigin

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownPdpAddress UnknownPdpAddress = SM_UNKNOWN_PDP_ADDRESS

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedActivationRejection UnspecifiedActivationRejection = SM_ACTIVATION_REJECTED_UNSPECIFIED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedProtocolError UnspecifiedProtocolError = SM_PROTOCOL_ERROR_UNSPECIFIED

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Protocol X25Protocol = L2_X25

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Type X25Type = X25_TYPE

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateAccepted StateAccepted = 0

enum State

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateFiveTimeT3310Expiry StateFiveTimeT3310Expiry = 2

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateRejected StateRejected = 1

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUnknownCause StateUnknownCause = 4

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUserInteruption StateUserInteruption = 3

#define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_c_max_cid_array_len c_max_cid_array_len = MAX_CID_ARRAY_LENGTH

#define Asc_Target_TypeDef_hpp

Generated on Tue Jan 24 17:24:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc/Target/ValueMap.hpp Source File

Asc/Target/ValueMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Target_TypeDef_hpp)
00009 #define Asc_Target_TypeDef_hpp
00010
00011 /*  ------------------------------------------------------------------------
00012     This file is used to map enums and constants to configuration dependent
00013     (e.g. different protocol stacks, different build mode, ...) values.
00014     If a class-scope is used, then a configuration independent scope macro
00015     must be defined in file <Asc/ValueMap.hpp>.
00016     ------------------------------------------------------------------------ */
00017
00018
00019 #include <Apc/SignalTypes.hpp>
00020
00021 /*  ------------------------------------------------------------------------
00022     PdpContextManager <Asc/PdpContextManager.hpp>
00023     ------------------------------------------------------------------------ */
00024
00025 // constants
00026 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_c_max_cid_array_len c_max_cid_array_len = MAX_CID_ARRAY_LENGTH
00027
00028 /*  ------------------------------------------------------------------------
00029     PdpContextManager::AttachStatus <Asc/PdpContextManager.hpp>
00030     ------------------------------------------------------------------------ */
00031
00033 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateAccepted StateAccepted = 0
00034 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateRejected StateRejected = 1
00035 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateFiveTimeT3310Expiry StateFiveTimeT3310Expiry = 2
00036 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUserInteruption StateUserInteruption = 3
00037 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUnknownCause StateUnknownCause = 4
00038
00039 /*  ------------------------------------------------------------------------
00040     PdpContext <Asc/PdpContext.hpp>
00041     ------------------------------------------------------------------------ */
00042 // constants
00043 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_c_max_access_point_name_len c_max_access_point_name_len = APN_LEN
00044
00045 // enum Type
00046 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Type X25Type = X25_TYPE
00047 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpType IpType = IP_TYPE
00048 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpStaticType IpStaticType = IP_TYPE_STATIC
00049 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpDynamicType IpDynamicType = IP_TYPE_DYNAMIC
00050 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_OspihType OspihType = OSPIH_TYPE
00051 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppType PppType = PPP_TYPE
00052 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoType NoType = NO_TYPE
00053
00054 // enum Protocol
00055 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NullProtocol NullProtocol = L2_NULL
00056 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppProtocol PppProtocol = L2_PPP
00057 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PadProtocol PadProtocol = L2_PAD
00058 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Protocol X25Protocol = L2_X25
00059 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ManufProtocol ManufProtocol = L2_MANUF
00060 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoProtocol NoProtocol = L2_NONE
00061
00062 // enum Origin
00063 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Network Network = PCH_NW
00064 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MobileStation MobileStation = PCH_MS
00065 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownOrigin UnknownOrigin
00066
00067 // enum ErrorCause
00068 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMs IllegalMs =  ERR_ILLEGAL_MS
00069 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMe IllegalMe =  ERR_ILLEGAL_ME
00070 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_GprsServiceNotAllowed GprsServiceNotAllowed = ERR_GPRS_NOT_ALLOWED
00071 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PlmnNotAllowed PlmnNotAllowed = ERR_PLMN_NOT_ALLOWED
00072 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LaNotAllowed LaNotAllowed = ERR_LA_NOT_ALLOWED
00073 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NationalRoamingNotAllowed NationalRoamingNotAllowed = ERR_NAT_ROAMING_NOT_ALLOWED
00074
00075 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionNotSupported ServiceOptionNotSupported = SM_SERVICE_OPT_NOT_SUPPORTED
00076 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RequestedServiceOptionNotSubscribed RequestedServiceOptionNotSubscribed = SM_REQ_SERVICE_NOT_SUBSCRIBED
00077 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionTemporaryOutOfOrder ServiceOptionTemporaryOutOfOrder = SM_SERVICE_TEMP_OUT_OF_ORDER
00078 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NsapiAlreadyUsed NsapiAlreadyUsed = SM_NSAPI_ALREADY_USED
00079
00080 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedProtocolError UnspecifiedProtocolError = SM_PROTOCOL_ERROR_UNSPECIFIED
00081 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_AuthenticationFailure AuthenticationFailure = SM_USER_AUTH_FAILED
00082
00083 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LlcOrSndcpFailure LlcOrSndcpFailure = SM_LLC_OR_SNDCP_FAILURE
00084 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InsufficientRessources InsufficientRessources = SM_INSUFFICIENT_RESOURCES
00085 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MissingOrUnknownApn MissingOrUnknownApn = SM_MISSING_OR_UNKNOWN_APN
00086 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownPdpAddress UnknownPdpAddress = SM_UNKNOWN_PDP_ADDRESS
00087 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationRejectedByGgsn ActivationRejectedByGgsn = SM_ACTIVATION_REJECTED_BY_GGSN
00088 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedActivationRejection UnspecifiedActivationRejection = SM_ACTIVATION_REJECTED_UNSPECIFIED
00089 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RegularDeactivation RegularDeactivation = SM_REGULAR_DEACTIVATION
00090 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QosNotAccepted QosNotAccepted = SM_QOS_NOT_ACCEPTED
00091 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NetworkFailure NetworkFailure = SM_NETWORK_FAILURE
00092 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ReactivationRequired ReactivationRequired = SM_REACTIVATION_REQUIRED
00093 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidTi InvalidTi = SM_INVALID_TI
00094 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_SemanticIncorrectMsg SemanticIncorrectMsg = SM_SEMANT_INCORRECT_MSG
00095 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidMandatoryIe InvalidMandatoryIe = SM_INV_MANDATORY_IE
00096 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotExistent MsgTypeNotExistent = SM_MSG_TYPE_NOT_EXISTENT
00097 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotCompatible MsgTypeNotCompatible = SM_MSG_TYPE_NOT_COMPATIBLE
00098 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IeNonExistent IeNonExistent = SM_IE_NON_EXISTENT
00099 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ConditionalIeError ConditionalIeError = SM_CONDITIONAL_IE_ERROR
00100 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgNotCompatible MsgNotCompatible = SM_MSG_NOT_COMPATIBLE
00101
00102 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UndefinedError UndefinedError
00103 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoError NoError
00104
00105
00106 /*  ------------------------------------------------------------------------
00107     PdpContext::Address <Asc/PdpContext.hpp>
00108     ------------------------------------------------------------------------ */
00109 // constants
00110 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Address_c_max_len c_max_len = PDP_ADDRESS_LEN
00111
00112 /*  ------------------------------------------------------------------------
00113     PdpContext::Authentication <Asc/PdpContext.hpp>
00114     ------------------------------------------------------------------------ */
00115 // constants
00116 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_account_len c_max_account_len = AUTH_USERNAME_LEN
00117 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_password_len c_max_password_len = AUTH_PASSWORD_LEN
00118
00119 // enum Type
00120 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_None None = PCH_AUTH_NONE
00121 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Pap Pap = PCH_AUTH_PAP
00122 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Chap Chap = PCH_AUTH_CHAP
00123
00124 /*  ------------------------------------------------------------------------
00125     PdpContext::QualityOfService <Asc/PdpContext.hpp>
00126     ------------------------------------------------------------------------ */
00127 // enum Precedence
00128 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceSubscribed PrecedenceSubscribed = PRECEDENCE_CLASS_S
00129 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceHigh PrecedenceHigh = PRECEDENCE_CLASS_H
00130 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceNormal PrecedenceNormal = PRECEDENCE_CLASS_N
00131 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceLow PrecedenceLow = PRECEDENCE_CLASS_L
00132 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceReserved PrecedenceReserved = PRECEDENCE_CLASS_R
00133
00134 // enum Delay
00135 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelaySubscribed DelaySubscribed = DELAY_CLASS_S
00136 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass1 DelayClass1 = DELAY_CLASS_1
00137 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass2 DelayClass2 = DELAY_CLASS_2
00138 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass3 DelayClass3 = DELAY_CLASS_3
00139 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayBestEffort DelayBestEffort = DELAY_CLASS_4
00140 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayReserved DelayReserved = DELAY_CLASS_R
00141
00143 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilitySubscribed ReliabilitySubscribed = RELIABILITY_CLASS_S
00144 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass1 ReliabilityClass1 = RELIABILITY_CLASS_1
00145 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass2 ReliabilityClass2 = RELIABILITY_CLASS_2
00146 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass3 ReliabilityClass3 = RELIABILITY_CLASS_3
00147 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass4 ReliabilityClass4 = RELIABILITY_CLASS_4
00148 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass5 ReliabilityClass5 = RELIABILITY_CLASS_5
00149 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass6 ReliabilityClass6 = RELIABILITY_CLASS_6
00150 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityReserved ReliabilityReserved = RELIABILITY_CLASS_R
00151
00153 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateSubscribed PeakRateSubscribed = PEAK_THP_S
00154 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate1K PeakRate1K = PEAK_THP_1K
00155 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate2K PeakRate2K = PEAK_THP_2K
00156 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate4K PeakRate4K = PEAK_THP_4K
00157 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate8K PeakRate8K = PEAK_THP_8K
00158 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate16K PeakRate16K = PEAK_THP_16K
00159 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate32K PeakRate32K = PEAK_THP_32K
00160 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate64K PeakRate64K = PEAK_THP_64K
00161 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate128K PeakRate128K = PEAK_THP_128K
00162 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate256K PeakRate256K = PEAK_THP_256K
00163 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateReserved PeakRateReserved = PEAK_THP_R
00164
00166 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateSubscribed MeanRateSubscribed = MEAN_THP_S
00167 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100 MeanRate100 = MEAN_THP_100
00168 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200 MeanRate200 = MEAN_THP_200
00169 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500 MeanRate500 = MEAN_THP_500
00170 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1K MeanRate1K = MEAN_THP_1K
00171 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2K MeanRate2K = MEAN_THP_2K
00172 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5K MeanRate5K = MEAN_THP_5K
00173 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10K MeanRate10K = MEAN_THP_10K
00174 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20K MeanRate20K = MEAN_THP_20K
00175 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50K MeanRate50K = MEAN_THP_50K
00176 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100K MeanRate100K = MEAN_THP_100K
00177 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200K MeanRate200K = MEAN_THP_200K
00178 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500K MeanRate500K = MEAN_THP_500K
00179 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1M MeanRate1M = MEAN_THP_1M
00180 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2M MeanRate2M = MEAN_THP_2M
00181 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5M MeanRate5M = MEAN_THP_5M
00182 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10M MeanRate10M = MEAN_THP_10M
00183 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20M MeanRate20M = MEAN_THP_20M
00184 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50M MeanRate50M = MEAN_THP_50M
00185 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateReserved MeanRateReserved = MEAN_THP_R
00186 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateBestEffort MeanRateBestEffort = MEAN_THP_BE
00187
00188 /*  ------------------------------------------------------------------------
00189     PdpContext::ActivationStatus <Asc/PdpContext.hpp>
00190     ------------------------------------------------------------------------ */
00191
00193 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateAccepted StateAccepted = 0
00194 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateRejected StateRejected = 1
00195 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateFiveTimeT3380Expiry StateFiveTimeT3380Expiry = 2
00196 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUserInteruption StateUserInteruption = 3
00197 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUnknownCause StateUnknownCause = 4
00198
00200 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_1 RadioPriorityLevel_1 = 1
00201 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_2 RadioPriorityLevel_2 = 2
00202 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_3 RadioPriorityLevel_3 = 3
00203 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_4 RadioPriorityLevel_4 = 4
00204 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_Undefined RadioPriorityLevel_Undefined = 0
00205
00206 // enum LlcSapi
00207 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_NotAssigned LlcSapi_NotAssigned = 0
00208 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_1 LlcSapi_1 = 1
00209 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_3 LlcSapi_3 = 3
00210 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_5 LlcSapi_5 = 5
00211 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_7 LlcSapi_7 = 7
00212 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_9 LlcSapi_9 = 9
00213 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_11 LlcSapi_11 = 11
00214 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_Invalid LlcSapi_Invalid = 255
00215
00216 /*  ------------------------------------------------------------------------
00217     PdpContext::PacketFilter <Asc/PdpContext.hpp>
00218     ------------------------------------------------------------------------ */
00219 // enum Type
00220 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_1 Type_1
00221 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_2 Type_2
00222 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_3 Type_3
00223 #define APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_Unknown Type_Unknown
00224
00225 #endif  // Asc_Target_TypeDef_hpp
00226
Generated on Tue Jan 24 14:46:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplication.cpp File Reference

Atl/AtlApplication.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioPresetStore.hpp>
#include <Gui/Panel.hpp>
#include <Gui/MsgTypes.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/System.hpp>
#include <Atl/AtlApplicationPlugin.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/Context/ContextManager.hpp>
#include <Atl/Context/KeyManager.hpp>
#include <Atl/Context/MenuDesc.hpp>
#include <Atl/Context/MenuProperties.hpp>
#include <Atl/Features/ContextFeatureItem.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Features/FeatureItem.hpp>
#include <Atl/Features/FeatureItemContainer.hpp>
#include <Atl/Features/MenuIdObj.hpp>
#include <Atl/Gui/AtlItemMenuWindow.hpp>
#include <Atl/Properties/PropertyItem.hpp>
#include <Atl/Properties/PropertyEditorFactory.hpp>
#include <Config/KeyboardConfig.hpp>
#include "AtlApplication.hpp"

Include dependency graph for AtlApplication.cpp:

Generated on Tue Jan 24 17:42:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplication.hpp File Reference

Atl/AtlApplication.hpp File Reference

#include <Auxiliary/Vector.hpp>
#include <Kernel/Application.hpp>
#include <Atl/Features/FeatureID.hpp>
#include <Atl/Features/MenuID.hpp>
#include <Atl/Features/FeaturePool.hpp>
#include <Atl/Features/ApplicationID.hpp>
#include <Atl/Context/ContextID.hpp>
#include <Atl/Context/ContextManager.hpp>
#include <Atl/Properties/Property.hpp>

Include dependency graph for AtlApplication.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlApplication
Baseclass for a ReferenceMmi Application. More...
class | UserActivityListener

Defines

#define | Atl_AtlApplication_hpp

Define Documentation

#define Atl_AtlApplication_hpp

Generated on Tue Jan 24 17:42:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplication.hpp Source File

Atl/AtlApplication.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Atl_AtlApplication_hpp)
00011 #define Atl_AtlApplication_hpp
00012
00013 #include <Auxiliary/Vector.hpp>
00016
00017 #include <Kernel/Application.hpp>
00018
00019 #include <Atl/Features/FeatureID.hpp>
00020 #include <Atl/Features/MenuID.hpp>
00021 #include <Atl/Features/FeaturePool.hpp>
00022 #include <Atl/Features/ApplicationID.hpp>
00023 #include <Atl/Context/ContextID.hpp>
00024 #include <Atl/Context/ContextManager.hpp>
00025 #include <Atl/Properties/Property.hpp>
00026
00027 #if defined(APOXI_COMPAT_2_7_0)
00028     #include <Atl/Gui/AtlItemMenuWindow.hpp>
00029 #endif  // APOXI_COMPAT_2_7_0
00030
00031 class AtlApplicationPlugin;
00032 class AtlItemMenuWindow;
00033 class ContextFeature;
00034 class ContextFeatureItem;
00035 class FeatureItem;
00036 class FeatureItemContainer;
00037 class PropertyItem;
00038
00039
00041 class UserActivityListener {
00042     public:
00044         UserActivityListener(){}
00045         ~UserActivityListener(){}
00047         virtual void OnUserActivity() = 0;
00048 };
00049
00050
00052 class AtlApplication : public Application {
00053     typedef Application Base;
00054
00055     friend class KeyManager;
00056     friend class AtlApplicationPlugin;
00057
00058
00059     public:
00060         AtlApplication(const WCHAR* app_name,
00061                        UINT stacksize = 0);
00062
00063         virtual ~AtlApplication();
00064
00066         virtual ApplicationID GetID() const;
00067
00069         virtual void OnStartup();
00070
00071
00073         FeaturePool* GetFeaturePool();
00074
00079         void TriggerFeatureItemUpdate(FeatureItem* item);
00080
00082         void OnOpenMenu(FeatureItemContainer* item_cont);
00083
00093         virtual BOOLEAN OnPropertyNotification(const Property::Notification notification,
00094                                                const Property* property,
00095                                                const DataItem& value);
00096
00099         virtual DataItem GetContextDataItem(ContextFeature* feature);
00100
00101     protected:
00103         AtlApplication();
00104
00106         virtual BOOLEAN RouteMessage(const Message& msg);
00107
00108         static void RegisterUserActivityListener(UserActivityListener* useractivity);
00109         static void UnregisterUserActivityListener(UserActivityListener* useractivity);
00110         static void PropagateUserActivity();
00111
00113         virtual void OnOpen();
00114
00116         virtual void OnClose();
00117
00124         virtual BOOLEAN OnMessage(const Message &msg);
00125
00128         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00129
00133         virtual BOOLEAN OnContextFeatureTriggered (const FeatureID& feature_id,
00134                                                    const DataItem& context_item);
00135
00137         virtual void UpdateContextItem(ContextFeatureItem* item);
00138
00141         virtual BOOLEAN UpdateItem(Item* item);
00142
00144         const ContextID* GetContextId() { return ContextManager::GetInstance().GetContextId(); }
00145
00147
00149         void AttachAtlApplicationPlugin(AtlApplicationPlugin* plugin);
00150
00151     private:
00152         void TriggerSoftkey(INT idx);
00153         AtlItemMenuWindow* GetMenuWin(const MenuID& menu_id);
00154
00155         static Vector<UserActivityListener*> m_useractivity_listener;
00156
00157         FeaturePool m_features;
00158         Vector<AtlItemMenuWindow*> m_menu_vec;
00159         Vector<AtlApplicationPlugin*> m_app_plugins;
00160 };
00161
00163 #endif  // Atl_AtlApplication_hpp
00164
Generated on Tue Jan 24 14:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplicationPlugin.cpp File Reference

Atl/AtlApplicationPlugin.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/MsgTypes.hpp>
#include "AtlApplicationPlugin.hpp"
#include <Atl/AtlApplication.hpp>
#include <Atl/AtlMsgTypes.hpp>

Include dependency graph for AtlApplicationPlugin.cpp:

Generated on Tue Jan 24 17:42:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplicationPlugin.hpp File Reference

Atl/AtlApplicationPlugin.hpp File Reference

#include <Kernel/UserDispatcher.hpp>
#include <Atl/Features/FeatureID.hpp>
#include <Atl/Properties/Property.hpp>

Include dependency graph for AtlApplicationPlugin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlApplicationPlugin

Defines

#define | AtlApplicationPlugin_hpp

Define Documentation

#define AtlApplicationPlugin_hpp

Generated on Tue Jan 24 17:42:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplicationPlugin.hpp Source File

Atl/AtlApplicationPlugin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtlApplicationPlugin_hpp)
00010 #define AtlApplicationPlugin_hpp
00013
00014 #include <Kernel/UserDispatcher.hpp>
00015 #include <Atl/Features/FeatureID.hpp>
00016 #include <Atl/Properties/Property.hpp>
00017
00018 #if defined(APOXI_COMPAT_2_7_0)
00019 #include <Atl/Features/ContextFeatureItem.hpp>
00020 #endif  // APOXI_COMPAT_2_7_0
00021
00022 class Application;
00023 class ContextFeatureItem;
00024 class Action;
00025 class Item;
00026
00028 class AtlApplicationPlugin : public UserDispatcher
00029 {
00030       typedef UserDispatcher Base;
00031
00032
00033    public:
00034
00036       virtual ~AtlApplicationPlugin();
00037
00039       virtual void Init(Application *host_application);
00040
00042       void Attach();
00043
00045       void Detach();
00046
00048       Application *GetApplication() { return m_app; }
00049
00051       const WCHAR* GetPluginName() const { return m_plugin_name; }
00052
00054       void SetPluginName(const WCHAR* plugin_name) { m_plugin_name = plugin_name; }
00055
00057       virtual void OnUpdateContextItem(ContextFeatureItem* item);
00058
00060       virtual BOOLEAN OnPropertyNotification(const Property::Notification notification,
00061                                              const Property* property,
00062                                              const DataItem& value);
00063
00064    protected:
00066       AtlApplicationPlugin();
00067
00070       virtual BOOLEAN OnMessage(const Message &msg);
00071
00074       virtual BOOLEAN OnKeyDown(KeyCode key_code);
00075
00078       virtual BOOLEAN OnKeyUp(KeyCode key_code, UINT32 duration);
00079
00083       virtual BOOLEAN OnLongKeyPress(KeyCode key_code);
00084
00088       virtual BOOLEAN OnVeryLongKeyPress(KeyCode key_code);
00089
00091       virtual BOOLEAN OnKeyAutoRepeat(KeyCode key_code);
00092
00094       virtual BOOLEAN OnInputChar(WCHAR chr);
00095
00097       virtual BOOLEAN OnTimeout(const Timer& timer);
00098
00100       virtual void OnThemeChanged();
00101
00103       virtual void OnLanguageChanged();
00104
00106       virtual void OnAppGetFocus();
00107
00109       virtual void OnAppLoseFocus();
00110
00112       virtual void OnAppOpen();
00113
00115       virtual void OnAppClose();
00116
00118       virtual BOOLEAN OnActionExecuted (Action *action);
00119
00122       virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00123
00127       virtual BOOLEAN OnContextFeatureTriggered(const FeatureID& feature_id,
00128                                                 const DataItem& item);
00129
00132       virtual BOOLEAN UpdateItem(Item* item);
00133
00135       const WCHAR *m_plugin_name;
00136       Application *m_app;
00137 };
00138
00140 #endif
00141
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplicationPluginStartup.cpp File Reference

Atl/AtlApplicationPluginStartup.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "AtlApplicationPlugin.hpp"
#include "AtlApplication.hpp"
#include "AtlApplicationPluginStartup.hpp"

Include dependency graph for AtlApplicationPluginStartup.cpp:

Generated on Tue Jan 24 17:43:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplicationPluginStartup.hpp File Reference

Atl/AtlApplicationPluginStartup.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlApplicationPluginStartup
struct | AtlApplicationPluginStartup::Table

Defines

#define | AtlApplicationPluginStartup_hpp

Define Documentation

#define AtlApplicationPluginStartup_hpp

Generated on Tue Jan 24 17:43:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlApplicationPluginStartup.hpp Source File

Atl/AtlApplicationPluginStartup.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtlApplicationPluginStartup_hpp)
00010 #define AtlApplicationPluginStartup_hpp
00011
00012 #if defined(APOXI_COMPAT_2_7_0)
00013 #include <Atl/AtlApplication.hpp>
00014 #include <Atl/AtlApplicationPlugin.hpp>
00015 #endif  // APOXI_COMPAT_2_7_0
00016
00017 class AtlApplication;
00018 class AtlApplicationPlugin;
00019
00020 class AtlApplicationPluginStartup {
00021
00022     public:
00023         struct Table {
00024                 AtlApplication* app;
00025                 AtlApplicationPlugin* plugin;
00026         };
00027
00028         static void InitPlugins(const Table*);
00029 };
00030 #endif
00031
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlMsgTypes.cpp File Reference

Atl/AtlMsgTypes.cpp File Reference

#include "Atl/AtlPreComp.hpp"
#include "Atl/Features/FeatureItem.hpp"
#include "Atl/Features/ContextFeatureItem.hpp"
#include "Atl/Properties/PropertyItem.hpp"
#include "AtlMsgTypes.hpp"

Include dependency graph for AtlMsgTypes.cpp:

Generated on Tue Jan 24 17:43:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlMsgTypes.hpp File Reference

Atl/AtlMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Atl/Features/FeatureID.hpp>
#include <Atl/Features/Feature.hpp>
#include <Config/AtlConfig.hpp>
#include <Gui/Item.hpp>

Include dependency graph for AtlMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CloseAllMsg
class | ContextFeatureTriggerMsg
class | DisabledFeatureTriggeredMsg
class | FeatureChangedMsg
class | FeatureTriggerMsg
class | IndicatorBarUpdateMsg
class | PropertyTriggerMsg
class | UpdateContextItemMsg
class | UpdateItemMsg

Defines

#define | Atl_AtlMsgTypes_hpp

Define Documentation

#define Atl_AtlMsgTypes_hpp

Generated on Tue Jan 24 17:43:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlMsgTypes.hpp Source File

Atl/AtlMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "igelpasc_apoxitest_sv\lnz_apoxi\Apoxi\Atl\AtlMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Atl_AtlMsgTypes_hpp)
00016 #define Atl_AtlMsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Auxiliary/DataItem.hpp>
00020 #include <Atl/Features/FeatureID.hpp>
00021 #include <Atl/Features/Feature.hpp>
00022 #include <Config/AtlConfig.hpp>
00023 #include <Gui/Item.hpp>
00024
00025
00026 class Feature;
00027 class FeatureItem;
00028 class PropertyItem;
00029 class ContextFeatureItem;
00030
00031 /* ----------------------------------------------------------------------
00032     Classes
00033     ---------------------------------------------------------------------- */
00034
00035 /*  ======================================================================
00036     Class IndicatorBarUpdateMsg
00037     ====================================================================== */
00038
00041 class IndicatorBarUpdateMsg : public Message {
00042     public:
00043         IndicatorBarUpdateMsg();
00044         virtual ~IndicatorBarUpdateMsg();
00045
00046         virtual const MsgMetaData& GetMetaData() const;
00047         virtual Message* Clone() const;
00048
00049         enum  {
00050             ID = 13000
00051             };
00052
00053     private:
00054         static const MsgMetaData m_meta_data;
00055
00056     };
00057
00058
00059 /*  ======================================================================
00060     Class CloseAllMsg
00061     ====================================================================== */
00062
00064 class CloseAllMsg : public Message {
00065     public:
00066         CloseAllMsg(const AtlConfig::BeforeClosingAction& action = AtlConfig::DoNothing);
00067         virtual ~CloseAllMsg();
00068
00069         virtual const MsgMetaData& GetMetaData() const;
00070         void SetAction(const AtlConfig::BeforeClosingAction& action) { m_action = action; }
00071         const AtlConfig::BeforeClosingAction& GetAction() const { return m_action; }
00072         virtual Message* Clone() const;
00073
00074         enum  {
00075             ID = 13001
00076             };
00077
00078     private:
00079         static const MsgMetaData m_meta_data;
00080         AtlConfig::BeforeClosingAction m_action;
00081
00082     };
00083
00084
00085 /*  ======================================================================
00086     Class UpdateContextItemMsg
00087     ====================================================================== */
00088
00090 class UpdateContextItemMsg : public Message {
00091     public:
00092         UpdateContextItemMsg(ContextFeatureItem* context_item);
00093         virtual ~UpdateContextItemMsg();
00094
00095         virtual const MsgMetaData& GetMetaData() const;
00096         ContextFeatureItem* GetContextItem() const { return m_context_item; }
00097         virtual Message* Clone() const;
00098
00099         enum  {
00100             ID = 13002
00101             };
00102
00103     private:
00104         static const MsgMetaData m_meta_data;
00105         ContextFeatureItem* m_context_item;
00106
00107     };
00108
00109
00110 /*  ======================================================================
00111     Class FeatureChangedMsg
00112     ====================================================================== */
00113
00115 class FeatureChangedMsg : public Message {
00116     public:
00117         FeatureChangedMsg(Feature* feature, INT property_id = Feature::UnspecifiedAttributeId);
00118         virtual ~FeatureChangedMsg();
00119
00120         virtual const MsgMetaData& GetMetaData() const;
00121         Feature* GetFeature() const { return m_feature; }
00122         INT GetPropertyId() const { return m_property_id; }
00123         virtual Message* Clone() const;
00124
00125         enum  {
00126             ID = 13003
00127             };
00128
00129     private:
00130         static const MsgMetaData m_meta_data;
00131         Feature* m_feature;
00132         INT m_property_id;
00133
00134     };
00135
00136
00137 /*  ======================================================================
00138     Class PropertyTriggerMsg
00139     ====================================================================== */
00140
00142 class PropertyTriggerMsg : public ContextMsg {
00143     public:
00144         PropertyTriggerMsg(ExecutionContext* context, PropertyItem* property_item);
00145         virtual ~PropertyTriggerMsg();
00146
00147         virtual const MsgMetaData& GetMetaData() const;
00148         void SetPropertyItem(PropertyItem* property_item) { m_property_item = property_item; }
00149         PropertyItem* GetPropertyItem() const { return m_property_item; }
00150         virtual Message* Clone() const;
00151
00152         enum  {
00153             ID = 13004
00154             };
00155
00156     private:
00157         static const MsgMetaData m_meta_data;
00158         PropertyItem* m_property_item;
00159
00160     };
00161
00162
00163 /*  ======================================================================
00164     Class FeatureTriggerMsg
00165     ====================================================================== */
00166
00168 class FeatureTriggerMsg : public ContextMsg {
00169     public:
00170         FeatureTriggerMsg(ExecutionContext* context, const FeatureID& feature_id);
00171         virtual ~FeatureTriggerMsg();
00172
00173         virtual const MsgMetaData& GetMetaData() const;
00174         void SetFeatureId(const FeatureID& feature_id) { m_feature_id = feature_id; }
00175         const FeatureID& GetFeatureId() const { return m_feature_id; }
00176         virtual Message* Clone() const;
00177
00178         enum  {
00179             ID = 13005
00180             };
00181
00182     private:
00183         static const MsgMetaData m_meta_data;
00184         FeatureID m_feature_id;
00185
00186     };
00187
00188
00189 /*  ======================================================================
00190     Class ContextFeatureTriggerMsg
00191     ====================================================================== */
00192
00194 class ContextFeatureTriggerMsg : public ContextMsg {
00195     public:
00196         ContextFeatureTriggerMsg(ExecutionContext* context, const FeatureID& feature_id, const DataItem& context_item);
00197         virtual ~ContextFeatureTriggerMsg();
00198
00199         virtual const MsgMetaData& GetMetaData() const;
00200         void SetFeatureId(const FeatureID& feature_id) { m_feature_id = feature_id; }
00201         const FeatureID& GetFeatureId() const { return m_feature_id; }
00202         void SetContextItem(const DataItem& context_item) { m_context_item = context_item; }
00203         const DataItem& GetContextItem() const { return m_context_item; }
00204         virtual Message* Clone() const;
00205
00206         enum  {
00207             ID = 13006
00208             };
00209
00210     private:
00211         static const MsgMetaData m_meta_data;
00212         FeatureID m_feature_id;
00213         DataItem m_context_item;
00214
00215     };
00216
00217
00218 /*  ======================================================================
00219     Class UpdateItemMsg
00220     ====================================================================== */
00221
00223 class UpdateItemMsg : public ContextMsg {
00224     public:
00225         UpdateItemMsg(ExecutionContext* context, Item* item);
00226         virtual ~UpdateItemMsg();
00227
00228         virtual const MsgMetaData& GetMetaData() const;
00229         Item* GetItem() const { return m_item; }
00230         virtual Message* Clone() const;
00231
00232         enum  {
00233             ID = 13007
00234             };
00235
00236     private:
00237         static const MsgMetaData m_meta_data;
00238         Item* m_item;
00239
00240     };
00241
00242
00243 /*  ======================================================================
00244     Class DisabledFeatureTriggeredMsg
00245     ====================================================================== */
00246
00248 class DisabledFeatureTriggeredMsg : public ContextMsg {
00249     public:
00250         DisabledFeatureTriggeredMsg(ExecutionContext* context, const FeatureID& feature_id);
00251         virtual ~DisabledFeatureTriggeredMsg();
00252
00253         virtual const MsgMetaData& GetMetaData() const;
00254         void SetFeatureId(const FeatureID& feature_id) { m_feature_id = feature_id; }
00255         const FeatureID& GetFeatureId() const { return m_feature_id; }
00256         virtual Message* Clone() const;
00257
00258         enum  {
00259             ID = 13008
00260             };
00261
00262     private:
00263         static const MsgMetaData m_meta_data;
00264         FeatureID m_feature_id;
00265
00266     };
00267
00268 #endif // Atl_AtlMsgTypes_hpp
00269
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlPreComp.cpp File Reference

Atl/AtlPreComp.cpp File Reference

#include <Atl/AtlPreComp.hpp>

Include dependency graph for AtlPreComp.cpp:

Generated on Tue Jan 24 17:43:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlPreComp.hpp File Reference

Atl/AtlPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Atl/AtlMsgTypes.hpp>

Include dependency graph for AtlPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:44:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlPreComp.hpp Source File

Atl/AtlPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Apc/Lib.hpp>
00013 #include <Adc/Lib.hpp>
00014 #include <Asc/Lib.hpp>
00015 #include <Atl/AtlMsgTypes.hpp>
00016
00017
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlTemplates.cpp File Reference

Atl/AtlTemplates.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Config/MenuResourceTable.hpp>
#include "Atl/Context/KeyMapping.hpp"
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Features/FeaturePool.hpp>
#include <Auxiliary/Map.hpp>
#include <Auxiliary/Vector.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Context/KeySequence.hpp>
#include <Atl/Config/DynamicMenuPool.hpp>
#include <Atl/Features/MenuPool.hpp>
#include <Gui/Item.hpp>
#include <Atl/Properties/TextIconPairArray.hpp>
#include <Atl/Properties/ValueMappingPropertyDescriptor.hpp>

Include dependency graph for AtlTemplates.cpp:

Generated on Tue Jan 24 17:44:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlWindow.cpp File Reference

Atl/AtlWindow.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Devices/Display.hpp>
#include <Gui/Desktop.hpp>
#include <Gui/Panel.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/AbstractItemContainer.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/Context/ContextManager.hpp>
#include <Atl/Features/FeatureItem.hpp>
#include <Atl/Properties/Property.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/KeyboardConfig.hpp>
#include "AtlWindow.hpp"

Include dependency graph for AtlWindow.cpp:

Generated on Tue Jan 24 17:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlWindow.hpp File Reference

Atl/AtlWindow.hpp File Reference

#include <Auxiliary/Observer.hpp>
#include <Gui/Window.hpp>
#include <Atl/Context/ContextID.hpp>
#include <Atl/Properties/SubstitutedText.hpp>

Include dependency graph for AtlWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlWindow

Defines

#define | Atl_AtlWindow_hpp

Define Documentation

#define Atl_AtlWindow_hpp

Generated on Tue Jan 24 17:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/AtlWindow.hpp Source File

Atl/AtlWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_AtlWindow_hpp)
00010 #define Atl_AtlWindow_hpp
00013
00014 #include <Auxiliary/Observer.hpp>
00015 #include <Gui/Window.hpp>
00016
00017 #include <Atl/Context/ContextID.hpp>
00018 #include <Atl/Properties/SubstitutedText.hpp>
00019
00020 #if defined(APOXI_COMPAT_2_7_0)
00021     #include <Atl/Features/FeatureID.hpp>
00022 #endif  // APOXI_COMPAT_2_7_0
00023
00024 class Feature;
00025
00028 class AtlWindow : public Window, public Observer {
00029     typedef Window Base;
00030
00031     public:
00032          enum {
00033             ID = 39
00034          };
00035
00037         AtlWindow();
00038
00040         virtual ~AtlWindow();
00041
00044         void Init(Dispatcher* dispatcher = 0);
00045
00047         virtual BOOLEAN IsInstanceOf(INT id) const;
00048
00049         // @param id    context id which is set to the window
00050         void SetContextId(const ContextID& id);
00051
00052         // @param id    context id which is set to the window
00053         void SetContextId(const CHAR * id);
00054
00059         virtual const ContextID& GetContextId() const { return m_context_id; }
00060
00062         void SetDispatcher(Dispatcher* dispatcher) { m_dispatcher = dispatcher; }
00063
00065         Dispatcher* GetDispatcher() { return m_dispatcher; }
00066
00068         virtual void SetTitle(const WCHAR* title);
00069
00071         virtual void SetSoftkey(INT index, Action* action);
00072
00074         virtual void SetDefaultSize();
00075
00078         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00079
00080     protected:
00082         virtual BOOLEAN OnMessage(const Message &msg);
00083
00085         virtual void OnOpen();
00086
00088         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00089
00091         virtual void OnGetFocus();
00092
00094         virtual void OnLoseFocus();
00095
00097         virtual void OnActionExecuted(Action *action);
00098
00100         virtual void OnLanguageChanged();
00101
00103         virtual void OnThemeChanged();
00104
00106         virtual BOOLEAN OnConfirm();
00107
00109         virtual BOOLEAN OnCancel();
00110
00112         virtual void OnContextSwitched();
00113
00114
00115     private:
00116         BOOLEAN SoftkeyUpdateNeeded(Feature* feature, INT property_id) const;
00117         BOOLEAN TitleAffected(Feature* feature, INT property_id) const;
00118         BOOLEAN SoftkeysAffected(Feature* feature, INT property_id) const;
00119
00120         ContextID m_context_id;
00121         Dispatcher* m_dispatcher;
00122         SubstitutedText m_substituted_title;
00123
00125         void AdjustBoundaries();
00126 };
00127
00129 #endif  // Atl_AtlWindow_hpp
00130
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/EnumTextMap.cpp File Reference

Atl/EnumTextMap.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "EnumTextMap.hpp"
#include <Gui/LanguageManager.hpp>

Include dependency graph for EnumTextMap.cpp:

Generated on Tue Jan 24 17:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/EnumTextMap.hpp File Reference

Atl/EnumTextMap.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for EnumTextMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EnumTextMap
struct | EnumTextTableEntry

Defines

#define | Mmi_EnumTextMap_hpp

Typedefs

typedef EnumTextTableEntry | EnumTextTable []

Define Documentation

#define Mmi_EnumTextMap_hpp

Generated on Tue Jan 24 17:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/EnumTextMap.hpp Source File

Atl/EnumTextMap.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003    ------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted without prior written authorisation.
00007    ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_EnumTextMap_hpp)
00010 #define Mmi_EnumTextMap_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00017 struct EnumTextTableEntry {
00018     INT     code;
00019     const WCHAR*    text;
00020 };
00021
00022 typedef EnumTextTableEntry EnumTextTable[];
00023
00025 class EnumTextMap {
00026     public:
00027         static const WCHAR* GetText(const EnumTextTable table, const UINT size, const INT value);
00028 };
00029
00031 #endif  //Mmi_EnumTextMap_hpp
00032
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Fraction.cpp File Reference

Atl/Fraction.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/Lib.hpp>
#include "Fraction.hpp"
#include <Gui/Locale.hpp>
#include <Auxiliary/Latin.hpp>

Include dependency graph for Fraction.cpp:

Functions

INT32 | Abs (INT32 val)
INT32 | GetGcd (INT32 val1, INT32 val2)

Function Documentation

INT32 Abs ( INT32 val )

INT32 GetGcd | ( | INT32 | val1,
 |  | INT32 | val2
 | ) |

Generated on Tue Jan 24 17:56:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Fraction.hpp File Reference

Atl/Fraction.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Fraction

Defines

#define | Apoxi_Fraction_hpp

Define Documentation

#define Apoxi_Fraction_hpp

Generated on Tue Jan 24 17:56:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Fraction.hpp Source File

Atl/Fraction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Fraction_hpp)
00011 #define Apoxi_Fraction_hpp
00014
00015
00016 class Fraction {
00017     public:
00019         Fraction();
00021         Fraction(const Fraction &frac);
00023         Fraction(INT32 num, INT32 denom = 1);
00024
00026         virtual ~Fraction();
00027
00029         void Set(INT32 num, INT32 denom = 1);
00031         void SetNumerator(INT32 num) { m_numerator = num; };
00033         void SetDenominator (INT32 denom) { m_denominator = denom; };
00034
00036         INT32 GetNumerator() const { return m_numerator; }
00038         INT32 GetDenominator() const { return m_denominator; }
00039
00041         BOOLEAN SetDecimalString(const WCHAR *str);
00043         WString GetDecimalString(INT digits = 0) const;
00045         BOOLEAN SetFractionString(const WCHAR *str);
00047         WString GetFractionString() const;
00048
00050         BOOLEAN IsValid() const;
00052         void Simplify();
00054         Fraction Reciprocal();
00055
00057         Fraction& operator += (const Fraction &frac);
00059         Fraction& operator -= (const Fraction &frac);
00061         Fraction& operator *= (const Fraction &frac);
00063         Fraction& operator /= (const Fraction &frac);
00064
00066         Fraction operator + (const Fraction &fraction) const;
00068         Fraction operator - (const Fraction &fraction) const;
00070         Fraction operator * (const Fraction &fraction) const;
00072         Fraction operator / (const Fraction &fraction) const;
00073
00074     private:
00075
00076         BOOLEAN TestMultiplyOverflow(const INT32& i, const INT32& j) const;
00077         BOOLEAN TestDivideOverflow(const INT32& i, const INT32& j)   const;
00078         BOOLEAN TestAdditionOverflow(const INT32& i, const INT32& j) const;
00079         BOOLEAN TestSubtractOverflow(const INT32& i, const INT32& j) const;
00080
00081         INT32   m_numerator;
00082         INT32   m_denominator;
00083 };
00084
00086 #endif  // Apoxi_Fraction_hpp
00087
00088
00089
Generated on Tue Jan 24 14:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/IdentifierHandler.cpp File Reference

Atl/IdentifierHandler.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Features/Feature.hpp>
#include <Atl/Properties/Property.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Gui/ImgObtObj.hpp>
#include <Config/GuiEngineConfig.hpp>
#include "IdentifierHandler.hpp"

Include dependency graph for IdentifierHandler.cpp:

Generated on Tue Jan 24 18:00:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/IdentifierHandler.hpp File Reference

Atl/IdentifierHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IdentifierHandler

Defines

#define | Atl_IdentifierHandler_hpp

Define Documentation

#define Atl_IdentifierHandler_hpp

Generated on Tue Jan 24 18:00:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/IdentifierHandler.hpp Source File

Atl/IdentifierHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_IdentifierHandler_hpp)
00010 #define Atl_IdentifierHandler_hpp
00013
00014 class Feature;
00015 class Property;
00016
00023 class IdentifierHandler  {
00024
00025 public:
00029     static WString      GetIdentifier(Feature* feature);
00033     static Feature*     GetFeature(const WString& identifier);
00037     static Property*    GetProperty(const WString& identifier);
00038
00039 #if defined(APOXI_COMPAT_2_7_0)
00040
00044     static ImageObtainer GetImage(const WString& uri);
00045 #endif
00046
00047 private:
00049     static Feature*     LookupById(const WString& identifier);
00050
00051 };
00052
00054 #endif  // Atl_IdentifierHandler_hpp
00055
00056
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/InputMapperFactory.cpp File Reference

Atl/InputMapperFactory.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/InputMapper.hpp>
#include "InputMapperFactory.hpp"

Include dependency graph for InputMapperFactory.cpp:

Generated on Tue Jan 24 18:00:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/InputMapperFactory.hpp File Reference

Atl/InputMapperFactory.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InputMapperFactory

Defines

#define | GuiExtensions_InputMapperFactory_hpp

Define Documentation

#define GuiExtensions_InputMapperFactory_hpp

Generated on Tue Jan 24 18:00:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/InputMapperFactory.hpp Source File

Atl/InputMapperFactory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(GuiExtensions_InputMapperFactory_hpp)
00011 #define GuiExtensions_InputMapperFactory_hpp
00014
00015 class InputMapper;
00016
00018 class InputMapperFactory {
00019     public:
00020
00022         InputMapperFactory();
00023
00025         virtual ~InputMapperFactory();
00026
00028         virtual void Init() =0;
00029
00031         virtual InputMapper* CreateInstance() = 0;
00032
00034         virtual INT GetId() const = 0;
00035 };
00036 #endif  // GuiExtensions_InputMapperFactory_hpp
00037
00038
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/PhoneNumberMatchRule.cpp File Reference

Atl/PhoneNumberMatchRule.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "PhoneNumberMatchRule.hpp"

Include dependency graph for PhoneNumberMatchRule.cpp:

Generated on Tue Jan 24 18:01:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/PhoneNumberMatchRule.hpp File Reference

Atl/PhoneNumberMatchRule.hpp File Reference

#include <Auxiliary/FilterRule.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/PhoneNumber.hpp>

Include dependency graph for PhoneNumberMatchRule.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PhoneNumberMatchRule
PhoneNumberMatchRule: Compares two PhoneNumbers by using the PhoneNumber::IsMatching method. More...

Defines

#define | Mmi_PhoneNumberMatchRule_hpp

Define Documentation

#define Mmi_PhoneNumberMatchRule_hpp

Generated on Tue Jan 24 18:01:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/PhoneNumberMatchRule.hpp Source File

Atl/PhoneNumberMatchRule.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_PhoneNumberMatchRule_hpp)
00011 #define Mmi_PhoneNumberMatchRule_hpp
00014
00015 #include <Auxiliary/FilterRule.hpp>
00016 #include <Auxiliary/DataItem.hpp>
00017 #include <Auxiliary/PhoneNumber.hpp>
00018
00020 class PhoneNumberMatchRule : public FilterRule {
00021     typedef FilterRule Base;
00022
00023     public:
00026         PhoneNumberMatchRule();
00027
00029         PhoneNumberMatchRule(const DataItem & ruleitem);
00030
00032         virtual ~PhoneNumberMatchRule();
00033
00035         void Init(const DataItem & ruleitem);
00036
00041         virtual BOOLEAN ExecuteRule(const DataItem & dataitem);
00042     private:
00043         CHAR m_phoneno[c_max_bcd_number_size*2+1];
00044
00045 };
00046
00048 #endif  // Mmi_PhoneNumberMatchRule_hpp
00049
00050
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/ResourceID.cpp File Reference

Atl/ResourceID.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "ResourceID.hpp"

Include dependency graph for ResourceID.cpp:

Generated on Tue Jan 24 18:05:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/ResourceID.hpp File Reference

Atl/ResourceID.hpp File Reference

#include <Auxiliary/String.hpp>

Include dependency graph for ResourceID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ResourceID

Defines

#define | ResourceID_hpp

Functions

BOOLEAN | operator!= (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator< (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator== (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator> (const ResourceID &lhs, const ResourceID &rhs)

Define Documentation

#define ResourceID_hpp

Generated on Tue Jan 24 18:05:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/ResourceID.hpp Source File

Atl/ResourceID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ResourceID_hpp)
00011 #define ResourceID_hpp
00014
00015
00016
00017 #include <Auxiliary/String.hpp>
00018
00019 class ResourceID {
00020    public:
00021
00023       ResourceID ();
00024
00026       ResourceID (const String& resourceID);
00027
00028
00029       ResourceID (const CHAR* id);
00030
00032       ~ResourceID();
00033
00035       void SetID(const String& id);
00036
00038       const String& ToString() const  {return m_id; };
00039
00041       BOOLEAN IsEmpty() const  {return m_id.IsEmpty(); };
00042
00043       friend inline BOOLEAN operator == (const ResourceID& lhs, const ResourceID& rhs);
00044       friend inline BOOLEAN operator != (const ResourceID& lhs, const ResourceID& rhs);
00045       friend inline BOOLEAN operator < (const ResourceID& lhs, const ResourceID& rhs);
00046       friend inline BOOLEAN operator > (const ResourceID& lhs, const ResourceID& rhs);
00047
00048    private:
00049       String m_id;
00051       inline const String& GetID() const { return m_id; }
00052
00053
00054 };
00055
00056
00057 /*  ------------------------------------------------------------------------
00058     Operator ==
00059     ------------------------------------------------------------------------ */
00060 inline BOOLEAN operator == (const ResourceID& lhs, const ResourceID& rhs)
00061 {
00062    return lhs.GetID() == rhs.GetID();
00063 }
00064
00065 /*  ------------------------------------------------------------------------
00066     Operator !=
00067     ------------------------------------------------------------------------ */
00068 inline BOOLEAN operator != (const ResourceID& lhs, const ResourceID& rhs)
00069 {
00070    return !(lhs.GetID() == rhs.GetID());
00071 }
00072
00073 /*  ------------------------------------------------------------------------
00074     Operator >
00075     ------------------------------------------------------------------------ */
00076 inline BOOLEAN operator > (const ResourceID& lhs, const ResourceID& rhs)
00077 {
00078    return (lhs.GetID() > rhs.GetID());
00079 }
00080
00081
00082 /*  ------------------------------------------------------------------------
00083     Operator <
00084     ------------------------------------------------------------------------ */
00085 inline BOOLEAN operator < (const ResourceID& lhs, const ResourceID& rhs)
00086 {
00087    return (lhs.GetID() < rhs.GetID());
00088 }
00089
00090
00091
00092 #endif /* ResourceID_hpp */
00093
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/SettingsProvider.cpp File Reference

Atl/SettingsProvider.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Config/Config.hpp>
#include "SettingsProvider.hpp"

Include dependency graph for SettingsProvider.cpp:

Generated on Tue Jan 24 18:06:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/SettingsProvider.hpp File Reference

Atl/SettingsProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>

Include dependency graph for SettingsProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SettingsProvider

Defines

#define | Mmi_SettingsProvider_hpp

Define Documentation

#define Mmi_SettingsProvider_hpp

Generated on Tue Jan 24 18:06:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/SettingsProvider.hpp Source File

Atl/SettingsProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_SettingsProvider_hpp)
00009 #define Mmi_SettingsProvider_hpp
00012
00013 #include <Auxiliary/Provider.hpp>
00014
00016 class SettingsProvider : public Provider , public Linkable<SettingsProvider> {
00017         typedef Provider Base;
00018     public:
00020         virtual Provider::Status GetStatus() const { return Provider::updated; }
00021
00023         virtual INT RowCount();
00024
00026         virtual void RestoreFactorySettings() = 0 ;
00027
00029         virtual BOOLEAN Update(ProviderListener * listener = 0);
00030
00031 };
00033 #endif  // Mmi_SettingsProvider_hpp
00034
00035
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Config/DynamicMenuPool.cpp File Reference

Atl/Config/DynamicMenuPool.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "DynamicMenuPool.hpp"

Include dependency graph for DynamicMenuPool.cpp:

Generated on Tue Jan 24 17:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Config/DynamicMenuPool.hpp File Reference

Atl/Config/DynamicMenuPool.hpp File Reference

#include <Atl/Features/MenuPool.hpp>
#include <Atl/Features/MenuID.hpp>
#include <Atl/Config/MenuResourceTable.hpp>

Include dependency graph for DynamicMenuPool.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DynamicMenuPool

Defines

#define | Mmi_Dynamic_MenuPool_hpp

Define Documentation

#define Mmi_Dynamic_MenuPool_hpp

Generated on Tue Jan 24 17:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Config/DynamicMenuPool.hpp Source File

Atl/Config/DynamicMenuPool.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_Dynamic_MenuPool_hpp)
00011 #define Mmi_Dynamic_MenuPool_hpp
00014
00015 #include <Atl/Features/MenuPool.hpp>
00016 #include <Atl/Features/MenuID.hpp>
00017 #include <Atl/Config/MenuResourceTable.hpp>
00018 class Feature;
00019
00021 class DynamicMenuPool: public MenuPool {
00022
00023     typedef MenuPool Base;
00024
00025 public:
00026
00028     DynamicMenuPool();
00029
00031     virtual ~DynamicMenuPool();
00032 };
00033
00035 #endif  // Mmi_Dynamic_MenuPool_hpp
00036
00037
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Config/MenuResourceTable.hpp File Reference

Atl/Config/MenuResourceTable.hpp File Reference

#include <Auxiliary/SimpleMap.hpp>
#include <Atl/Features/MenuID.hpp>

Include dependency graph for MenuResourceTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Menu_Resource_Table_hpp

Typedefs

typedef SimpleMap< MenuID,
UINT16 > 		MenuResourceTable

Define Documentation

#define Menu_Resource_Table_hpp

Typedef Documentation

typedef SimpleMap<MenuID,UINT16> MenuResourceTable

Generated on Tue Jan 24 17:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Config/MenuResourceTable.hpp Source File

Atl/Config/MenuResourceTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Menu_Resource_Table_hpp)
00011 #define Menu_Resource_Table_hpp
00012
00013 #include <Auxiliary/SimpleMap.hpp>
00014 #include <Atl/Features/MenuID.hpp>
00015
00016 typedef SimpleMap<MenuID,UINT16> MenuResourceTable;
00017
00018
00019 #endif
00020
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextDescription.cpp File Reference

Atl/Context/ContextDescription.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "ContextDescription.hpp"

Include dependency graph for ContextDescription.cpp:

Generated on Tue Jan 24 17:45:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextDescription.hpp File Reference

Atl/Context/ContextDescription.hpp File Reference

#include <Atl/Context/ContextID.hpp>
#include <Atl/Context/SoftkeyDesc.hpp>
#include <Atl/Context/KeyMapping.hpp>

Include dependency graph for ContextDescription.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextDescription

Defines

#define | Atl_Context_ContextDescription_hpp

Define Documentation

#define Atl_Context_ContextDescription_hpp

Generated on Tue Jan 24 17:45:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextDescription.hpp Source File

Atl/Context/ContextDescription.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_ContextDescription_hpp)
00011 #define Atl_Context_ContextDescription_hpp
00014
00015 #include <Atl/Context/ContextID.hpp>
00016 #include <Atl/Context/SoftkeyDesc.hpp>
00017 #include <Atl/Context/KeyMapping.hpp>
00018
00019 #if defined(APOXI_COMPAT_2_7_0)
00020 #include <Config/KeyboardConfig.hpp>
00021 #include <Config/Config.hpp>
00022 #endif  // APOXI_COMPAT_2_7_0
00023
00024 #if defined(APOXI_COMPAT_2_6_0)
00025 #include <Atl/Gui/IndicatorDescription.hpp>
00026 typedef Vector<IndicatorDescription*> IndicatorDescriptionContainer;
00027 typedef Vector<IndicatorDescription*>::Iterator IndicatorDescriptionContainerIterator;
00028 typedef Vector<IndicatorDescription*>::ConstIterator IndicatorDescriptionContainerConstIterator;
00029 #endif
00030
00039 class ContextDescription {
00040     public:
00042         ContextDescription();
00043
00045         ~ContextDescription();
00046
00048         void Init(const ContextID& context_id) { m_context_id = context_id; }
00049
00051         void Init(const ContextID& context_id,
00052                   const WString& window_title) { Init(context_id), m_window_title = window_title; }
00053
00057         void SetSoftkeyDesc(INT sk_index,
00058                             SoftkeyDesc sk_desc) { m_sk_desc[sk_index] = sk_desc; }
00059
00063         const SoftkeyDesc& GetSoftkeyDesc(INT sk_index) { return m_sk_desc[sk_index]; }
00064
00066         void SetWindowTitle(const WString& title) { m_window_title = title; }
00067
00069         const WString& GetWindowTitle() { return m_window_title; }
00070
00072         const ContextID& GetContextId() { return m_context_id; }
00073
00075         KeyMapping& GetKeyMap() { return m_key_mapping;}
00076
00077 #if defined(APOXI_COMPAT_2_6_0)
00078
00079         void AddIndicatorDescription(IndicatorDescription* desc);
00080
00082         void RemoveIndicatorDescription(IndicatorDescription* desc);
00083
00085         IndicatorDescriptionContainerIterator GetIndicatorDescriptionsBeginIterator();
00086
00088         IndicatorDescriptionContainerIterator GetIndicatorDescriptionsEndIterator();
00089 #endif
00090
00091     private:
00092         ContextID m_context_id;
00093         SoftkeyDesc m_sk_desc[APOXI_MAX_SOFTKEY_COUNT];
00094         WString m_window_title;
00095         KeyMapping  m_key_mapping;
00096
00097 #if defined(APOXI_COMPAT_2_6_0)
00098         IndicatorDescriptionContainerIterator FindIndicatorDescription(IndicatorDescription* desc);
00099         IndicatorDescriptionContainer m_indicators;
00100 #endif
00101 };
00102
00104 #endif // Atl_Context_ContextDescription_hpp
00105
00106
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextDescriptionTypes.hpp File Reference

Atl/Context/ContextDescriptionTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ContextTableEntry
struct | KeymapTableEntry
struct | SoftkeyDescTableEntry

Defines

#define | ContextDescriptionTypes_hpp

Enumerations

enum KeymapType {
keymapNone, keymapVKey, keymapVKeyFeature, keymapVKeyLongFeature,
keymapVKeyVeryLongFeature
}

Define Documentation

#define ContextDescriptionTypes_hpp

Enumeration Type Documentation

enum KeymapType

Enumerator:
keymapNone
keymapVKey
keymapVKeyFeature
keymapVKeyLongFeature
keymapVKeyVeryLongFeature

Generated on Tue Jan 24 17:45:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextDescriptionTypes.hpp Source File

Atl/Context/ContextDescriptionTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ContextDescriptionTypes_hpp)
00011 #define ContextDescriptionTypes_hpp
00012
00013 class FeatureHandle;
00014
00015 struct SoftkeyDescTableEntry {
00016     const CHAR* app_menu_id;
00017     const CHAR* feature_id;
00018     const CHAR* text;
00019     const CHAR* icon_id;
00020 };
00021
00022 enum KeymapType {
00023     keymapNone,
00024     keymapVKey,
00025     keymapVKeyFeature,
00026     keymapVKeyLongFeature,
00027     keymapVKeyVeryLongFeature
00028 };
00029
00030 struct KeymapTableEntry {
00031     UINT8                   keymap_type;
00032     KeyCode                 key_code;
00033     KeyCode                 to_key_code;
00034     const FeatureHandle*    feature_handle;
00035 };
00036
00037 struct ContextTableEntry {
00038     const CHAR*             context_id;
00039     const CHAR*             title;
00040     SoftkeyDescTableEntry   softkey_descriptions[APOXI_MAX_SOFTKEY_COUNT];
00041     const KeymapTableEntry* keymap;
00042 };
00043
00044 #endif /* ContextDescriptionTypes_hpp */
00045
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextFeatureHandle.cpp File Reference

Atl/Context/ContextFeatureHandle.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Features/Feature.hpp>
#include <Atl/Features/ContextFeature.hpp>
#include <Atl/Features/ContextFeatureItem.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include "ContextFeatureHandle.hpp"

Include dependency graph for ContextFeatureHandle.cpp:

Generated on Tue Jan 24 17:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextFeatureHandle.hpp File Reference

Atl/Context/ContextFeatureHandle.hpp File Reference

#include <Atl/Features/FeatureHandle.hpp>

Include dependency graph for ContextFeatureHandle.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextFeatureHandle

Defines

#define | Atl_Context_ContextFeatureHandle_hpp

Define Documentation

#define Atl_Context_ContextFeatureHandle_hpp

Generated on Tue Jan 24 17:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextFeatureHandle.hpp Source File

Atl/Context/ContextFeatureHandle.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_ContextFeatureHandle_hpp)
00011 #define Atl_Context_ContextFeatureHandle_hpp
00014
00015 #include <Atl/Features/FeatureHandle.hpp>
00016
00020 class ContextFeatureHandle: public FeatureHandle{
00021     public:
00023         ContextFeatureHandle(const AppFeatureID& id,
00024                              const DataItem& contextitem,
00025                              BOOLEAN fixed_context);
00026
00028         virtual ~ContextFeatureHandle();
00029
00035         virtual void Execute(AtlApplication* context_app = 0) const;
00036
00037     private:
00038         const DataItem& GetContextItem();
00039
00040         DataItem m_context_item;
00041         BOOLEAN  m_fixed_context;
00042 };
00043
00044
00046 #endif // Atl_Context_ContextFeatureHandle_hpp
00047
00048
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextID.hpp File Reference

Atl/Context/ContextID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for ContextID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | ContextID_hpp

Typedefs

typedef ResourceID | ContextID

Define Documentation

#define ContextID_hpp

Typedef Documentation

typedef ResourceID ContextID

Generated on Tue Jan 24 17:45:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextID.hpp Source File

Atl/Context/ContextID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ContextID_hpp)
00011 #define ContextID_hpp
00012
00013
00014
00015 #include <Atl/ResourceID.hpp>
00016
00017 typedef ResourceID ContextID;
00018
00019
00020 #endif
00021
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextManager.cpp File Reference

Atl/Context/ContextManager.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/System.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/AtlWindow.hpp>
#include <Atl/Context/ContextTable.hpp>
#include <Atl/Context/ContextTableNode.hpp>
#include <Atl/Context/ContextDescriptionTypes.hpp>
#include <Config/AtlConfig.hpp>
#include "ContextManager.hpp"

Include dependency graph for ContextManager.cpp:

Generated on Tue Jan 24 17:46:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextManager.hpp File Reference

Atl/Context/ContextManager.hpp File Reference

#include <Kernel/Os/Mutex.hpp>
#include <Atl/AtlWindow.hpp>
#include <Atl/Context/KeyMapping.hpp>
#include <Atl/Context/ContextID.hpp>
#include <Atl/Context/ContextDescription.hpp>
#include <Atl/Context/ContextDescriptionTypes.hpp>

Include dependency graph for ContextManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextManager
This singleton handles context switches and applies context descriptions to new contexts. More...

Defines

#define | Atl_Context_ContextManager_hpp

Define Documentation

#define Atl_Context_ContextManager_hpp

Generated on Tue Jan 24 17:46:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextManager.hpp Source File

Atl/Context/ContextManager.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_ContextManager_hpp)
00011 #define Atl_Context_ContextManager_hpp
00014
00015 #include <Kernel/Os/Mutex.hpp>
00016 #include <Atl/AtlWindow.hpp>
00017 #include <Atl/Context/KeyMapping.hpp>
00018 #include <Atl/Context/ContextID.hpp>
00019 #include <Atl/Context/ContextDescription.hpp>
00020 #include <Atl/Context/ContextDescriptionTypes.hpp>
00021
00022 #if defined(APOXI_COMPAT_2_7_0)
00023 #include <Config/AtlConfig.hpp>
00024 #endif  // APOXI_COMPAT_2_7_0
00025
00026 #if defined(APOXI_COMPAT_2_6_0)
00027 #include <Atl/Gui/IndicatorPaneObject.hpp>
00028 #endif  // APOXI_COMPAT_2_6_0
00029
00030 class ContextDescription;
00032 class ContextManager {
00033     friend class AtlWindow;
00034     public:
00035
00037         static ContextManager& GetInstance() { return m_instance; }
00038
00040         virtual ~ContextManager();
00041
00046         void NotifyContextSwitch(AtlWindow* win,
00047                                  const ContextID& context_id);
00048
00052         void NotifyContextItemSwitch();
00053
00055         const ContextID* GetContextId();
00056
00058         Dispatcher* GetDispatcher() const { return m_dispatcher; }
00059
00061         KeyMapping& GetKeyMap();
00062
00065         ContextDescription* GetContextDesc(const ContextID& context_id);
00066
00067     protected:
00072         void UpdateSoftkeys(AtlWindow* win,
00073             const ContextID& context_id);
00074
00075     private:
00076         ContextManager();
00077         void Init();
00078
00080         void CreateContextDescriptions();
00081         void SetSoftkeyDescToContextDesc(ContextDescription& desc, const ContextTableEntry* entry);
00082         void SetKeyMapToContextDesc(ContextDescription& desc, const ContextTableEntry* entry);
00083
00084         static ContextManager m_instance;
00085
00086         typedef Vector<ContextDescription*> ContextDescVec;
00087         static ContextDescVec m_context_descriptions;
00088
00089         ContextDescription* m_context_desc;
00090 #if defined(APOXI_COMPAT_2_7_0)
00091         ContextDescription m_default_context;
00092 #endif  //APOXI_2_7_0)
00093         Dispatcher* m_dispatcher;
00094         Mutex m_mutex;
00095         ContextID m_last_context_id;
00096         BOOLEAN m_initialized;
00097
00098 #if defined(APOXI_COMPAT_2_6_0)
00099         void SetIndicatorEnvironment(AtlWindow* win);
00100         Vector<IndicatorPaneObject*> m_pane_objects;
00101         IndicatorDescriptionContainer m_lost_indicator_descriptions;
00102 #endif
00103 };
00104
00106 #endif // Atl_Context_ContextManager_hpp
00107
00108
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextTable.cpp File Reference

Atl/Context/ContextTable.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "ContextTableNode.hpp"
#include "ContextTable.hpp"

Include dependency graph for ContextTable.cpp:

Generated on Tue Jan 24 17:46:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextTable.hpp File Reference

Atl/Context/ContextTable.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ContextTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextTable

Defines

#define | Atl_Context_ContextTable_hpp

Define Documentation

#define Atl_Context_ContextTable_hpp

Generated on Tue Jan 24 17:46:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextTable.hpp Source File

Atl/Context/ContextTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Atl_Context_ContextTable_hpp)
00009 #define Atl_Context_ContextTable_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 class ContextTableNode;
00016
00017 class ContextTable {
00018     friend class ContextTableNode;
00019     public:
00021         static const ContextTableNode* GetRoot() { return m_root; }
00022
00024         static INT GetSize();
00025
00026     private:
00028         static void Attach(ContextTableNode* node);
00029
00030         static const ContextTableNode* m_root;
00031 };
00032
00034 #endif // Atl_Context_ContextTable_hpp
00035
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextTableNode.cpp File Reference

Atl/Context/ContextTableNode.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "ContextTable.hpp"
#include "ContextTableNode.hpp"

Include dependency graph for ContextTableNode.cpp:

Generated on Tue Jan 24 17:46:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextTableNode.hpp File Reference

Atl/Context/ContextTableNode.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextTableNode

Defines

#define | Atl_Context_ContextTableNode_hpp

Define Documentation

#define Atl_Context_ContextTableNode_hpp

Generated on Tue Jan 24 17:46:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/ContextTableNode.hpp Source File

Atl/Context/ContextTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Atl_Context_ContextTableNode_hpp)
00009 #define Atl_Context_ContextTableNode_hpp
00012
00013 struct ContextTableEntry;
00014 class ContextTable;
00015
00016 class ContextTableNode {
00017     friend class ContextTable;
00018     public:
00022         ContextTableNode(const ContextTableEntry* entry);
00023
00025         virtual ~ContextTableNode();
00026
00029         const ContextTableNode* GetNext() const { return m_next; }
00030
00033         const ContextTableEntry* GetEntry() const { return m_entry; }
00034
00035     private:
00037         void SetNext(const ContextTableNode* node);
00038
00039         const ContextTableEntry* m_entry;
00040         const ContextTableNode* m_next;
00041 };
00042
00044 #endif // Atl_Context_ContextTableNode_hpp
00045
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeyManager.cpp File Reference

Atl/Context/KeyManager.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/Display.hpp>
#include <Devices/Keyboard.hpp>
#include <Gui/MsgTypes.hpp>
#include "KeyManager.hpp"
#include <Atl/Context/ContextManager.hpp>
#include <Atl/Context/ContextFeatureHandle.hpp>
#include <Atl/Features/FeatureHandle.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeatureBroker.hpp>

Include dependency graph for KeyManager.cpp:

Generated on Tue Jan 24 17:47:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeyManager.hpp File Reference

Atl/Context/KeyManager.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | KeyManager

Defines

#define | Atl_Context_KeyManager_hpp

Define Documentation

#define Atl_Context_KeyManager_hpp

Generated on Tue Jan 24 17:47:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeyManager.hpp Source File

Atl/Context/KeyManager.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_KeyManager_hpp)
00011 #define Atl_Context_KeyManager_hpp
00014
00015 #if defined(APOXI_COMPAT_2_7_0)
00016 #include <Auxiliary/LinkedList.hpp>
00017 #include <Atl/Context/KeySequence.hpp>
00018 #endif  // APOXI_COMPAT_2_7_0
00019
00020 class FeatureHandle;
00021 class AtlApplication;
00022
00025 class KeyManager {
00026    public:
00028       ~KeyManager();
00029
00031       static KeyManager& GetInstance() { return m_instance; }
00032
00036       static void SwallowKey(KeyCode key_code) { m_swallow_key = key_code; }
00037
00046       BOOLEAN HandleMessage(const Message &msg, AtlApplication* parent);
00047
00048
00049    private:
00051       KeyManager();
00052
00053       static KeyManager m_instance;
00054
00055       static KeyCode m_swallow_key;
00056
00057       const FeatureHandle*  m_longkey_feature;
00058       const FeatureHandle*  m_verylong_feature;
00059
00060
00061 };
00062
00064 #endif // Atl_Context_KeyManager_hpp
00065
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeyMapping.cpp File Reference

Atl/Context/KeyMapping.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Context/KeySequence.hpp>
#include <Config/Config.hpp>
#include "KeyMapping.hpp"

Include dependency graph for KeyMapping.cpp:

Generated on Tue Jan 24 17:47:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeyMapping.hpp File Reference

Atl/Context/KeyMapping.hpp File Reference

#include <Auxiliary/SimpleMap.hpp>
#include <Auxiliary/Map.hpp>

Include dependency graph for KeyMapping.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | KeyMapping

Defines

#define | Atl_Context_KeyMapping_hpp

Define Documentation

#define Atl_Context_KeyMapping_hpp

Generated on Tue Jan 24 17:47:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeyMapping.hpp Source File

Atl/Context/KeyMapping.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_KeyMapping_hpp)
00011 #define Atl_Context_KeyMapping_hpp
00014
00015 #include <Auxiliary/SimpleMap.hpp>
00016 #include <Auxiliary/Map.hpp>
00017
00018 #if defined(APOXI_COMPAT_2_7_0)
00019 #include <Atl/Features/FeatureHandle.hpp>
00020 #include <Atl/Context/KeySequence.hpp>
00021 #include <Auxiliary/LinkedList.hpp>
00022 #endif  // APOXI_COMPAT_2_7_0
00023
00024 class FeatureHandle;
00025 class KeySequence;
00026 class KeySequenceCandidate;
00039 class KeyMapping {
00040
00041     friend class KeyManager;
00042
00043     public:
00044
00046         KeyMapping();
00047
00049         ~KeyMapping();
00050
00055         void            AddVKey(KeyCode hw_key, KeyCode v_key);
00056
00060         KeyCode         GetVKey(KeyCode hw_key) const;
00061
00067         void            AddVKeyFeature(KeyCode key, const FeatureHandle* feature_handle);
00068
00072         const FeatureHandle*    GetFeature(KeyCode key) const;
00073
00078         void            AddVKeyLongFeature(KeyCode key, const FeatureHandle* feature_handle);
00079
00084         const FeatureHandle*    GetLongFeature(KeyCode key) const;
00085
00086
00092         void            AddKeySequenceFeature(KeySequence* sequence, const FeatureHandle* feature_handle);
00093
00103         const FeatureHandle*  GetSequenceFeature(KeyCode key, BOOLEAN& consume_last_key);
00104
00109         void            AddVKeyVeryLongFeature(KeyCode key, const FeatureHandle* feature_handle);
00110
00115         const FeatureHandle*    GetVeryLongFeature(KeyCode key) const;
00116
00117
00118     protected:
00119
00123         static void UpdateExpireTime();
00124
00125     private:
00126
00127         typedef Map <KeyCode, KeyCode>               VKeyMapping;
00128         typedef Map <KeyCode, const FeatureHandle*>      VKeyFeatureMap;
00129         typedef Map <KeySequence*, const FeatureHandle*>   KeySequenceFeatureMap;
00130         typedef Map <KeySequence*, KeyCode>          KeySequenceVKeyMap;
00131
00132         typedef SimpleMap  <KeySequenceCandidate*,const FeatureHandle* >  KeySequenceFeatureCandidates;
00133         typedef SimpleMap  <KeySequenceCandidate*, KeyCode >  KeySequenceVKeyCandidates;
00134
00135
00136         VKeyMapping     m_vkey_keys;
00137         VKeyFeatureMap  m_feature_keys;
00138         VKeyFeatureMap  m_vkey_long_feature_keys;
00139         VKeyFeatureMap  m_very_long_feature_keys;
00140
00141         KeySequenceFeatureMap*  m_keysequence_features;
00142
00143         static void           AddSequenceFeatureCandidate(KeySequenceFeatureMap::Iterator iter);
00144         static const FeatureHandle* GetSequenceFeatureCandidate(KeyCode key, BOOLEAN& consume_last_key);
00145
00146         static void    AddSequenceVKeyCandidate(KeySequenceVKeyMap::Iterator iter);
00147         static KeyCode GetSequenceVKeyCandidate(KeyCode key, BOOLEAN& consume_last_key);
00148
00149         static void FlushCandidates();
00150
00151
00152         static Ticks  m_last_key_pressed;
00153         static KeySequenceFeatureCandidates s_keysequence_feature_candidates;
00154         static KeySequenceVKeyCandidates    s_keysequence_vKey_candidates;
00155
00156
00157
00158 };
00159
00161 #endif // Atl_Context_KeyMapping_hpp
00162
00163
00164
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeySequence.cpp File Reference

Atl/Context/KeySequence.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "KeySequence.hpp"

Include dependency graph for KeySequence.cpp:

Generated on Tue Jan 24 17:47:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeySequence.hpp File Reference

Atl/Context/KeySequence.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | KeySequence
class | KeySequenceCandidate

Defines

#define | Atl_Context_KeySequence_hpp

Define Documentation

#define Atl_Context_KeySequence_hpp

Generated on Tue Jan 24 17:47:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/KeySequence.hpp Source File

Atl/Context/KeySequence.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_KeySequence_hpp)
00011 #define Atl_Context_KeySequence_hpp
00014
00015 #if defined(APOXI_COMPAT_2_7_0)
00016 #include <Auxiliary/Vector.hpp>
00017 #include <Atl/Features/FeatureHandle.hpp>
00018 #endif  // APOXI_COMPAT_2_7_0
00019 class AtlApplication;
00020
00022 class KeySequence {
00023         friend class KeySequenceCandidate;
00024         friend class KeyMapping;
00025
00026     public:
00027
00029         KeySequence(const KeyCode* keys, INT length, BOOLEAN consume_last_key);
00030
00032         ~KeySequence();
00033
00035         BOOLEAN GetConsumeLastKey() const;
00036
00038         BOOLEAN HasKeyAtPos(const KeyCode& key_code, INT pos) const;
00039
00041         INT GetLength() const;
00042
00043     protected:
00045         BOOLEAN IsStartOfSequence(const KeyCode& key) const;
00046
00047
00048     private:
00049         const KeyCode* GetKeys() const;
00050
00051         /* List of keys */
00052         const KeyCode* m_keys;
00053         const INT m_length;
00054         const BOOLEAN m_consume_last_key;
00055
00056 };
00057
00058 class KeySequenceCandidate
00059 {
00060     public:
00061
00063         KeySequenceCandidate(const KeySequence* sequence);
00064
00066         KeySequenceCandidate(const KeySequenceCandidate& candidate);
00067
00069         BOOLEAN IsValidSequence(const KeyCode& key);
00070
00072         BOOLEAN GetConsumeLastKey() const;
00073
00075         BOOLEAN IsFinished() const;
00076
00077
00078
00079     private:
00080         INT m_currentTriggeredKey;
00081         const KeySequence* m_sequence;
00082         BOOLEAN m_isFinished;
00083         BOOLEAN m_isValid;
00084
00085 };
00086
00087
00088 #endif // Atl_Context_KeySequence_hpp
00089
00090
00091
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuDesc.cpp File Reference

Atl/Context/MenuDesc.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/GuiObjectIterator.hpp>
#include <Gui/ResourceManager.hpp>
#include "MenuDesc.hpp"

Include dependency graph for MenuDesc.cpp:

Generated on Tue Jan 24 17:48:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuDesc.hpp File Reference

Atl/Context/MenuDesc.hpp File Reference

#include <Gui/ResourceParser.hpp>
#include <Config/GuiObjectFactory.hpp>

Include dependency graph for MenuDesc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuDesc

Defines

#define | Atl_Context_MenuDesc_hpp

Define Documentation

#define Atl_Context_MenuDesc_hpp

Generated on Tue Jan 24 17:48:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuDesc.hpp Source File

Atl/Context/MenuDesc.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_MenuDesc_hpp)
00011 #define Atl_Context_MenuDesc_hpp
00014
00015 #if defined(APOXI_COMPAT_2_7_0)
00016 #include <Atl/Features/MenuID.hpp>
00017 #include <Atl/Context/MenuProperties.hpp>
00018 #include <Atl/Features/FeatureItemContainer.hpp>
00019 #endif  // APOXI_COMPAT_2_7_0
00020
00021 #include <Gui/ResourceParser.hpp>
00022 #include <Config/GuiObjectFactory.hpp>
00023
00024 class FeatureItemContainer;
00025 class MenuProperties;
00026
00031 class MenuDesc {
00032     public:
00034         MenuDesc();
00035
00037         MenuDesc(FeatureItemContainer* container,
00038                  const MenuProperties* menu_properties);
00039
00041         virtual ~MenuDesc();
00042
00044         BOOLEAN SetProperty(ResourceParser& parser,
00045                             const GuiObjectFactory::PropertyId prop_id);
00046
00048         void Init(FeatureItemContainer* container,
00049                   const MenuProperties* menu_properties);
00050
00052         FeatureItemContainer* GetItemContainer() const { return m_item_container; }
00053
00055         const MenuProperties* GetMenuProperties() const { return m_menu_properties; }
00056
00057     private:
00058         FeatureItemContainer* m_item_container;
00059         const MenuProperties*  m_menu_properties;
00060     };
00061
00063 #endif /* Atl_Context_MenuDesc_hpp */
00064
00065
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuDescObj.cpp File Reference

Atl/Context/MenuDescObj.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Context/MenuDescObj.hpp>

Include dependency graph for MenuDescObj.cpp:

Generated on Tue Jan 24 17:49:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuDescObj.hpp File Reference

Atl/Context/MenuDescObj.hpp File Reference

#include <Auxiliary/GenericObject.hpp>
#include <Atl/Context/MenuDesc.hpp>

Include dependency graph for MenuDescObj.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuDescObj

Defines

#define | Atl_Context_MenuDescObj_hpp

Variables

const GenericTypeId | c_menu_desc_ptr_type = c_user_base_gentypes + 4800

Define Documentation

#define Atl_Context_MenuDescObj_hpp

Generated on Tue Jan 24 17:49:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuDescObj.hpp Source File

Atl/Context/MenuDescObj.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Atl_Context_MenuDescObj_hpp)
00015 #define Atl_Context_MenuDescObj_hpp
00018
00019 #include <Auxiliary/GenericObject.hpp>
00020 #include <Atl/Context/MenuDesc.hpp>
00021
00022 const GenericTypeId c_menu_desc_ptr_type = c_user_base_gentypes + 4800;
00023
00025 class MenuDescObj : public GenericObject
00026 {
00027     public:
00029         MenuDescObj(const MenuDesc& menu_desc);
00030
00032         virtual ~MenuDescObj();
00033
00035         virtual GenericObject* Copy() const;
00036
00038         virtual BOOLEAN IsEqual(GenericObject* object);
00039
00041         virtual GenericTypeId GetTypeId();
00042
00044         void SetMenuDesc(const MenuDesc& menu_desc) { m_menu_desc = menu_desc; }
00045
00047         const MenuDesc& GetMenuDesc() {return m_menu_desc;}
00048
00049
00050     private:
00051         MenuDesc m_menu_desc;
00052
00053 };
00054
00055 #endif
00056
00057
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuProperties.cpp File Reference

Atl/Context/MenuProperties.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "MenuProperties.hpp"
#include <Gui/ResourceParser.hpp>

Include dependency graph for MenuProperties.cpp:

Generated on Tue Jan 24 17:49:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuProperties.hpp File Reference

Atl/Context/MenuProperties.hpp File Reference

#include <Config/GuiObjectFactory.hpp>
#include <Gui/Point.hpp>

Include dependency graph for MenuProperties.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuProperties

Defines

#define | Atl_Context_MenuProperties_hpp

Define Documentation

#define Atl_Context_MenuProperties_hpp

Generated on Tue Jan 24 17:49:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/MenuProperties.hpp Source File

Atl/Context/MenuProperties.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_MenuProperties_hpp)
00011 #define Atl_Context_MenuProperties_hpp
00014
00015 #include <Config/GuiObjectFactory.hpp>
00016 #include <Gui/Point.hpp>
00017
00018 class ResourceParser;
00019
00028 class MenuProperties {
00029     public:
00030         enum Corner {
00032             TopLeft,
00034             TopRight,
00036             BottomLeft,
00038             BottomRight
00039         };
00040
00041         enum MenuType
00042         {
00044             FullSize,
00046             PopUp
00047         };
00048
00058         enum TitleTextType
00059         {
00060              NoTitle,
00061              ItemContainerText,
00062              ItemText,
00063              ParentItemText,
00064              ContextDependantTitle,
00065              UndefinedTitleText
00066         };
00067
00073         MenuProperties(MenuType = FullSize,
00074                        BOOLEAN close_after_trigger = FALSE,
00075                        TitleTextType = UndefinedTitleText);
00076
00078         virtual ~MenuProperties();
00079
00081         BOOLEAN SetProperty(ResourceParser& parser,
00082                             const GuiObjectFactory::PropertyId prop_id);
00083
00085         MenuType GetMenuType() const { return m_menu_type; }
00086
00088         void SetMenuType(MenuType menu_type) { m_menu_type = menu_type; }
00089
00091         Corner GetCorner() const { return m_corner; }
00092
00094         void SetCorner(Corner corner) { m_corner = corner; }
00095
00097         const Point& GetPos() const { return m_pos; }
00098
00100         void SetPos(const Point& pos) { m_pos = pos; }
00101
00103         void SetCloseAfterTrigger(BOOLEAN flag) { m_close_after_trigger = flag; }
00104
00106         BOOLEAN CloseAfterTrigger() const { return m_close_after_trigger; }
00107
00109         void SetTitleTextType (TitleTextType title_text) { m_title_type = title_text; }
00110
00112         TitleTextType GetTitleTextType () const { return m_title_type; }
00113
00114     private:
00115         MenuType m_menu_type;
00116         Corner m_corner;
00117         Point m_pos;
00118         BOOLEAN m_close_after_trigger;
00119         TitleTextType m_title_type;
00120 };
00121
00123 #endif /* Atl_Context_MenuProperties_hpp */
00124
00125
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/SoftkeyDesc.cpp File Reference

Atl/Context/SoftkeyDesc.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/System.hpp>
#include <Atl/Context/MenuDesc.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Features/FeatureItemContainer.hpp>
#include <Atl/Features/MenuIdObj.hpp>
#include "SoftkeyDesc.hpp"

Include dependency graph for SoftkeyDesc.cpp:

Generated on Tue Jan 24 17:49:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/SoftkeyDesc.hpp File Reference

Atl/Context/SoftkeyDesc.hpp File Reference

#include <Gui/Window.hpp>
#include <Atl/Features/AppFeatureID.hpp>
#include <Atl/Features/MenuID.hpp>
#include <Atl/Features/ContextFeatureItem.hpp>

Include dependency graph for SoftkeyDesc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoftkeyDesc

Defines

#define | Atl_Context_SoftkeyDesc_hpp

Define Documentation

#define Atl_Context_SoftkeyDesc_hpp

Generated on Tue Jan 24 17:49:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Context/SoftkeyDesc.hpp Source File

Atl/Context/SoftkeyDesc.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Context_SoftkeyDesc_hpp)
00011 #define Atl_Context_SoftkeyDesc_hpp
00014
00015 #if defined(APOXI_COMPAT_2_7_0)
00016 #include <Config/KeyboardConfig.hpp>
00017 #endif  // APOXI_COMPAT_2_7_0
00018
00019 #include <Gui/Window.hpp>
00020
00021 #include <Atl/Features/AppFeatureID.hpp>
00022 #include <Atl/Features/MenuID.hpp>
00023 #include <Atl/Features/ContextFeatureItem.hpp>
00024
00033 class SoftkeyDesc {
00034     public:
00036         SoftkeyDesc();
00037
00038
00040         SoftkeyDesc(const AppFeatureID& feature_id) {
00041             m_feature_id = feature_id;
00042         }
00043
00047         SoftkeyDesc(const AppFeatureID& feature_id,
00048                     const WString& text) {
00049             m_feature_id = feature_id;
00050             m_sk_text = text;
00051         }
00052
00054         SoftkeyDesc(const MenuID& menu_id) {
00055             m_menu_id = menu_id;
00056         }
00057
00061         SoftkeyDesc(const MenuID& menu_id,
00062                     const WString& text) {
00063             m_menu_id = menu_id;
00064             m_sk_text = text;
00065         }
00066
00068         ~SoftkeyDesc();
00069
00075         FeatureItem* GetSoftkeyFeatureItem(INT sk_id) const;
00076
00078         void SetFeatureId(const AppFeatureID& id) { m_feature_id = id; }
00079
00081         const AppFeatureID& GetFeatureId() const { return m_feature_id; }
00082
00084         void SetMenuId(const MenuID& id) { m_menu_id = id; }
00085
00087         const MenuID& GetMenuId() const { return m_menu_id; }
00088
00090         const WString& GetSkText() const { return m_sk_text; }
00091
00093         void SetSkText(const WString& text) { m_sk_text = text; }
00094
00096         void SetSkText(const WCHAR* text) { m_sk_text = text; }
00097
00099         void SetSkIcon(const ImageObtainer& icon) { m_sk_icon = icon; }
00100
00102         const ImageObtainer& GetSkIcon() const { return m_sk_icon; }
00103
00104     private:
00105         AppFeatureID m_feature_id;
00106         MenuID m_menu_id;
00107         mutable WString m_sk_text;
00108         mutable ImageObtainer m_sk_icon;
00109         mutable INT m_language_id;
00110
00111         static ContextFeatureItem m_open_menu[APOXI_MAX_SOFTKEY_COUNT];
00112         static FeatureItem        m_softkey_feature_items[APOXI_MAX_SOFTKEY_COUNT];
00113         static ContextFeature     m_open_menu_context_feature;
00114
00115 };
00116
00118 #endif // Atl_Context_SoftkeyDesc_hpp
00119
00120
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/AppFeatureID.cpp File Reference

Atl/Features/AppFeatureID.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "AppFeatureID.hpp"

Include dependency graph for AppFeatureID.cpp:

Generated on Tue Jan 24 17:50:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/AppFeatureID.hpp File Reference

Atl/Features/AppFeatureID.hpp File Reference

#include <Atl/Features/ApplicationID.hpp>
#include <Atl/Features/FeatureID.hpp>

Include dependency graph for AppFeatureID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | AppFeatureID

Defines

#define | Atl_Features_AppFeatureID_hpp

Define Documentation

#define Atl_Features_AppFeatureID_hpp

Generated on Tue Jan 24 17:50:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/AppFeatureID.hpp Source File

Atl/Features/AppFeatureID.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Features_AppFeatureID_hpp)
00011 #define Atl_Features_AppFeatureID_hpp
00012
00013
00014 #include <Atl/Features/ApplicationID.hpp>
00015 #include <Atl/Features/FeatureID.hpp>
00016
00017 struct AppFeatureID {
00018     AppFeatureID();
00019     AppFeatureID(ApplicationID app_id, FeatureID feature_id);
00020     explicit AppFeatureID(const CHAR* app_id, const CHAR* feature_id);
00021
00022 #if defined(_DEBUG)
00023     String ToString();
00024 #endif
00025
00026     ApplicationID m_app_id;
00027     FeatureID m_feature_id;
00028 };
00029
00030 #endif
00031
00032
Generated on Tue Jan 24 14:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ApplicationID.hpp File Reference

Atl/Features/ApplicationID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for ApplicationID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | ApplicationID_hpp

Typedefs

typedef ResourceID | ApplicationID

Define Documentation

#define ApplicationID_hpp

Typedef Documentation

typedef ResourceID ApplicationID

Generated on Tue Jan 24 17:50:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ApplicationID.hpp Source File

Atl/Features/ApplicationID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApplicationID_hpp)
00011 #define ApplicationID_hpp
00012
00013
00014
00015 #include <Atl/ResourceID.hpp>
00016
00017 typedef ResourceID ApplicationID;
00018 #endif /* ApplicationID_hpp */
00019
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/BackToIdleFeature.cpp File Reference

Atl/Features/BackToIdleFeature.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/System.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include "BackToIdleFeature.hpp"

Include dependency graph for BackToIdleFeature.cpp:

Generated on Tue Jan 24 17:50:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/BackToIdleFeature.hpp File Reference

Atl/Features/BackToIdleFeature.hpp File Reference

#include <Atl/Features/Feature.hpp>

Include dependency graph for BackToIdleFeature.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BackToIdleFeature
Platform feature "BackToIdleScreen". More...

Defines

#define | BackToIdleFeature_hpp

Define Documentation

#define BackToIdleFeature_hpp

Generated on Tue Jan 24 17:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/BackToIdleFeature.hpp Source File

Atl/Features/BackToIdleFeature.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(BackToIdleFeature_hpp)
00011 #define BackToIdleFeature_hpp
00014
00015 #include <Atl/Features/Feature.hpp>
00016
00018 class BackToIdleFeature : public Feature {
00019     typedef Feature Base;
00020 public:
00021
00022     enum {
00023         ID = 106
00024     };
00025
00027     BackToIdleFeature();
00028
00030     virtual ~BackToIdleFeature();
00031
00033     void Init();
00034
00036     virtual INT GetID() const;
00037
00039     virtual BOOLEAN IsInstanceOf(INT id) const;
00040
00042     virtual BOOLEAN Execute();
00043
00045     virtual BOOLEAN IsEqual(const Feature& feature) const;
00046 };
00047
00049 #endif /* BackToIdleFeature_hpp */
00050
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ContextFeature.cpp File Reference

Atl/Features/ContextFeature.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/System.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include "ContextFeature.hpp"

Include dependency graph for ContextFeature.cpp:

Generated on Tue Jan 24 17:51:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ContextFeature.hpp File Reference

Atl/Features/ContextFeature.hpp File Reference

#include <Atl/Features/Feature.hpp>

Include dependency graph for ContextFeature.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextFeature
Special feature, which requires a context item as feature invocation argument. More...

Defines

#define | ContextFeature_hpp

Define Documentation

#define ContextFeature_hpp

Generated on Tue Jan 24 17:51:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ContextFeature.hpp Source File

Atl/Features/ContextFeature.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ContextFeature_hpp)
00011 #define ContextFeature_hpp
00014
00015 #include <Atl/Features/Feature.hpp>
00016
00017 #if defined(APOXI_COMPAT_2_7_0)
00018 #include <Auxiliary/DataItem.hpp>
00019 #endif  // APOXI_COMPAT_2_7_0
00020 class DataItem;
00021
00023 class ContextFeature : public Feature {
00024     typedef Feature Base;
00025 public:
00026
00027     enum {
00028          ID = 2
00029     };
00030
00031     enum ContextType {
00033         WStringType,
00035         NumberType,
00037         ItemTextType,
00039         PhoneNumberType,
00041         ItemType,
00043         ProviderType,
00045         ContainerType,
00047         UndefinedType
00048     };
00049
00051     ContextFeature();
00052
00054     ContextFeature(AtlApplication* app,
00055                    const FeatureID& id);
00056
00058     virtual ~ContextFeature();
00059
00061     void Init(AtlApplication* app,
00062               const FeatureID& id,
00063               ContextType contextType = ItemType);
00064
00065     // TODO: Remove
00066     virtual INT GetID() const;
00067
00069     virtual BOOLEAN IsInstanceOf(INT id) const;
00070
00072     virtual BOOLEAN IsEqual(const Feature& feature) const;
00073
00075     virtual BOOLEAN Execute();
00076
00080     virtual BOOLEAN Execute(const DataItem& data_item);
00081
00083     void        SetContextType(ContextType type) { m_context_type = type; }
00084
00086     ContextType GetContextType() const { return m_context_type; }
00087
00088 private:
00089     ContextFeature(const ContextFeature& orig);
00090     ContextFeature& operator = (const ContextFeature& rhs);
00091
00092     ContextType m_context_type;
00093 };
00094
00095 #endif /* ContextFeature_hpp */
00096
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ContextFeatureItem.cpp File Reference

Atl/Features/ContextFeatureItem.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/Features/ContextFeature.hpp>
#include <Gui/ResourceParser.hpp>
#include "ContextFeatureItem.hpp"

Include dependency graph for ContextFeatureItem.cpp:

Generated on Tue Jan 24 17:51:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ContextFeatureItem.hpp File Reference

Atl/Features/ContextFeatureItem.hpp File Reference

#include <Atl/Features/FeatureItem.hpp>
#include <Atl/Features/ContextFeature.hpp>
#include <Auxiliary/DataItem.hpp>

Include dependency graph for ContextFeatureItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextFeatureItem

Defines

#define | ContextFeatureItem_hpp

Define Documentation

#define ContextFeatureItem_hpp

Generated on Tue Jan 24 17:51:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ContextFeatureItem.hpp Source File

Atl/Features/ContextFeatureItem.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(ContextFeatureItem_hpp)
00011 #define ContextFeatureItem_hpp
00014
00015 #include <Atl/Features/FeatureItem.hpp>
00016 #include <Atl/Features/ContextFeature.hpp>
00017 #include <Auxiliary/DataItem.hpp>
00018
00019 class AtlApplication;
00020
00026 class ContextFeatureItem : public FeatureItem {
00027     public:
00028
00029         typedef FeatureItem Base;
00030
00031         enum {
00032             ID = 101
00033         };
00034
00036         ContextFeatureItem();
00037
00039         ContextFeatureItem(ContextFeature* feature,
00040                            const WString& text = "",
00041                            BOOLEAN fixed_context = FALSE);
00042
00044         ContextFeatureItem(ContextFeature* feature,
00045                            const WString& text = "",
00046                            const ImageObtainer& icon = ImageObtainer(),
00047                            BOOLEAN fixed_context = FALSE);
00048
00050         virtual ~ContextFeatureItem();
00051
00053         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00054
00055         // TODO: Remove
00056         virtual INT GetID() const;
00057
00059         virtual BOOLEAN IsInstanceOf(INT id) const;
00060
00062         void Init(ContextFeature* feature,
00063                   const WString& text = "",
00064                   BOOLEAN fixed_context = FALSE);
00065
00067         void Init(ContextFeature* feature,
00068                   const WString& text = "",
00069                   const ImageObtainer& icon = ImageObtainer(),
00070                   BOOLEAN fixed_context = FALSE);
00071
00075         void SetContextItem(const DataItem& item) { m_context_item = item; };
00076
00078         const DataItem& GetContextItem() const { return m_context_item; };
00079
00084         virtual BOOLEAN Execute();
00085
00087         ContextFeature::ContextType GetContextType() const;
00088
00093         virtual BOOLEAN IsFixedContext() { return m_fixed_context;}
00094
00095     private:
00096         DataItem m_context_item;
00097         BOOLEAN  m_fixed_context;
00098 };
00099
00101 #endif /* ContextFeatureItem_hpp*/
00102
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/Feature.cpp File Reference

Atl/Features/Feature.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/System.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include "Feature.hpp"

Include dependency graph for Feature.cpp:

Generated on Tue Jan 24 17:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/Feature.hpp File Reference

Atl/Features/Feature.hpp File Reference

#include <Atl/Features/FeatureID.hpp>

Include dependency graph for Feature.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Feature
Represents pure functionality, will be wrapped by a feature item. More...

Defines

#define | Feature_hpp

Define Documentation

#define Feature_hpp

Generated on Tue Jan 24 17:51:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/Feature.hpp Source File

Atl/Features/Feature.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Feature_hpp)
00011 #define Feature_hpp
00014
00015 #include <Atl/Features/FeatureID.hpp>
00016
00017 class AtlApplication;
00018
00020 class Feature {
00021
00022     public:
00023
00024       enum {
00025          ID = 3
00026       };
00027
00036       enum FeatureAttributeId {
00039           UnspecifiedAttributeId    = -1,
00041           AvailableAttributeId          = 0,
00043           EnabledAttributeId            = 1,
00045           CustomAttributeId     = 99
00046       };
00047
00049       Feature();
00050
00052       Feature(AtlApplication* app,
00053               const FeatureID& id);
00054
00056       virtual ~Feature();
00057
00059       void Init(AtlApplication* app,
00060                 const FeatureID& id);
00061
00063       void Init(AtlApplication* app,
00064                 const FeatureID& id,
00065                 BOOLEAN available,
00066                 BOOLEAN enabled);
00067
00068       // TODO: Remove
00069       virtual INT GetID() const;
00070
00072       virtual BOOLEAN IsInstanceOf(INT id) const;
00073
00075       virtual BOOLEAN IsEqual(const Feature& feature) const;
00076
00078       inline const FeatureID& GetFeatureId() const { return m_feature_id; }
00079
00081       inline void SetApplication(AtlApplication* app) { m_app = app; }
00082
00084       inline AtlApplication* GetApplication() const { return m_app; }
00085
00087       virtual BOOLEAN Execute();
00088
00090       void      SetEnabled(BOOLEAN enabled);
00091
00093       BOOLEAN   IsEnabled() const { return m_bits.is_enabled; }
00094
00096       void      SetAvailable(BOOLEAN available);
00097
00099       BOOLEAN   IsAvailable() const { return m_bits.is_available; }
00100
00105       void      BlockNotification(BOOLEAN block) { m_bits.block_notification = block; }
00106
00108       BOOLEAN   IsNotificationBlocked() const { return m_bits.block_notification; }
00109
00110
00111 protected:
00112
00117       void NotifyFeatureChange(INT property_id = UnspecifiedAttributeId);
00118
00120       FeatureID         m_feature_id;
00121
00123       AtlApplication*   m_app;
00124
00125    private:
00126       Feature(const Feature& orig);
00127       Feature& operator = (const Feature& rhs);
00128
00129         struct {
00130             UINT is_enabled : 1;
00131             UINT is_available : 1;
00132             UINT block_notification : 1;
00133          } m_bits;
00134 };
00135
00136 #endif /* Feature_hpp */
00137
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureBroker.cpp File Reference

Atl/Features/FeatureBroker.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Features/ApplicationID.hpp>
#include <Atl/Context/MenuDesc.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeaturePool.hpp>
#include <Config/AtlConfig.hpp>
#include "FeatureBroker.hpp"

Include dependency graph for FeatureBroker.cpp:

Generated on Tue Jan 24 17:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureBroker.hpp File Reference

Atl/Features/FeatureBroker.hpp File Reference

#include <Auxiliary/SimpleMap.hpp>
#include <Atl/Features/AppFeatureID.hpp>
#include <Atl/Features/FeatureID.hpp>
#include <Atl/Features/MenuID.hpp>

Include dependency graph for FeatureBroker.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FeatureBroker

Defines

#define | Atl_Features_FeatureBroker_hpp

Define Documentation

#define Atl_Features_FeatureBroker_hpp

Generated on Tue Jan 24 17:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureBroker.hpp Source File

Atl/Features/FeatureBroker.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Features_FeatureBroker_hpp)
00011 #define Atl_Features_FeatureBroker_hpp
00014
00015 #include <Auxiliary/SimpleMap.hpp>
00016
00017 #include <Atl/Features/AppFeatureID.hpp>
00018 #include <Atl/Features/FeatureID.hpp>
00019 #include <Atl/Features/MenuID.hpp>
00020
00021
00022 class AtlApplication;
00023 class Feature;
00024 class MenuDesc;
00025
00029 class FeatureBroker {
00030
00031     friend class Feature;
00032     friend class Property;
00033
00034     public:
00035
00037         static FeatureBroker* GetInstance() { return &m_instance; }
00038
00040         virtual ~FeatureBroker();
00041
00045         BOOLEAN RegisterApplication(AtlApplication* app) ;
00046
00048         Feature * GetFeature(const ApplicationID& appID,
00049                              const FeatureID& feature) const ;
00050
00052         Feature * GetFeature(const AppFeatureID& id) const { return GetFeature(id.m_app_id, id.m_feature_id); }
00053
00055         BOOLEAN OnFeatureAdded(Feature* feature);
00056
00058         virtual MenuDesc* GetMenu(const MenuID& id);
00059
00061         void    OnFeatureStatusChanged(Feature* feature);
00062
00063     protected:
00065         BOOLEAN IsMenuInitialized();
00066
00067     private:
00069         FeatureBroker();
00070
00072         void InitMenus();
00073
00074         typedef SimpleMap<ApplicationID,AtlApplication*> ApplicationsContainer;
00075
00076         ApplicationsContainer m_applications;
00077
00078         BOOLEAN m_menu_initialized;
00079
00080         static FeatureBroker m_instance;
00081 };
00083 #endif // Atl_Features_FeatureBroker_hpp
00084
00085
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureHandle.cpp File Reference

Atl/Features/FeatureHandle.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "FeatureHandle.hpp"
#include <Atl/Features/Feature.hpp>
#include <Atl/Features/FeatureBroker.hpp>

Include dependency graph for FeatureHandle.cpp:

Generated on Tue Jan 24 17:52:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureHandle.hpp File Reference

Atl/Features/FeatureHandle.hpp File Reference

#include <Atl/Features/AppFeatureID.hpp>

Include dependency graph for FeatureHandle.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FeatureHandle

Defines

#define | Atl_Features_FeatureHandle_hpp

Define Documentation

#define Atl_Features_FeatureHandle_hpp

Generated on Tue Jan 24 17:52:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureHandle.hpp Source File

Atl/Features/FeatureHandle.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_Features_FeatureHandle_hpp)
00011 #define Atl_Features_FeatureHandle_hpp
00014
00015 #include <Atl/Features/AppFeatureID.hpp>
00016
00017 class AtlApplication;
00018
00022 class FeatureHandle
00023 {
00024     public:
00026         FeatureHandle(const AppFeatureID& id);
00027
00029         ~FeatureHandle();
00030
00034         virtual  void           Execute(AtlApplication* context_app = 0) const;
00035
00037         const AppFeatureID&     GetAppFeatureID() const { return m_featureID;}
00038
00039     protected:
00040         AppFeatureID m_featureID;
00041 };
00042
00043
00045 #endif // Atl_Features_FeatureHandle_hpp
00046
00047
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureID.hpp File Reference

Atl/Features/FeatureID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for FeatureID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | FeatureID_hpp

Typedefs

typedef ResourceID | FeatureID

Define Documentation

#define FeatureID_hpp

Typedef Documentation

typedef ResourceID FeatureID

Generated on Tue Jan 24 17:52:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureID.hpp Source File

Atl/Features/FeatureID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(FeatureID_hpp)
00011 #define FeatureID_hpp
00012
00013
00014 #include <Atl/ResourceID.hpp>
00015
00016 typedef ResourceID FeatureID;
00017
00018
00019 #endif
00020
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureItem.cpp File Reference

Atl/Features/FeatureItem.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Gui/ResourceParser.hpp>
#include <Gui/LanguageManager.hpp>
#include "FeatureItem.hpp"

Include dependency graph for FeatureItem.cpp:

Generated on Tue Jan 24 17:52:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureItem.hpp File Reference

Atl/Features/FeatureItem.hpp File Reference

#include <Gui/Action.hpp>
#include <Atl/Features/FeatureID.hpp>
#include <Atl/Properties/SubstitutedText.hpp>
#include <Atl/Features/Feature.hpp>
#include <Atl/Context/ContextID.hpp>

Include dependency graph for FeatureItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FeatureItem

Defines

#define | FeatureItem_hpp

Define Documentation

#define FeatureItem_hpp

Generated on Tue Jan 24 17:52:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureItem.hpp Source File

Atl/Features/FeatureItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(FeatureItem_hpp)
00011 #define FeatureItem_hpp
00014
00015 #include <Gui/Action.hpp>
00016
00017 #include <Atl/Features/FeatureID.hpp>
00018 #include <Atl/Properties/SubstitutedText.hpp>
00019 #include <Atl/Features/Feature.hpp>
00020 #include <Atl/Context/ContextID.hpp>
00021
00022 class AtlApplication;
00023 class Property;
00024
00032 class FeatureItem : public Action {
00033       typedef Action Base;
00034    public:
00035
00036       enum {
00037          ID = 100
00038       };
00039
00042       enum FeatureItemPropertyId {
00043           FeaturePropertyId = 5,
00044           ContextPropertyId = 6
00045       };
00046
00049       FeatureItem();
00050
00052       FeatureItem(Feature* feature);
00053
00057       FeatureItem(Feature* feature, const WString& text);
00058
00063       FeatureItem(Feature* feature, const WString& text, const ImageObtainer& icon);
00064
00066       virtual ~FeatureItem();
00067
00069       void Init(Feature* feature = 0);
00070
00074       void Init(Feature* feature, const WString& text);
00075
00080       void Init(Feature* feature, const WString& text, const ImageObtainer& icon);
00081
00083       void SetContextId(const ContextID& id);
00084
00086       void SetContextId(const CHAR * id);
00087
00089       const ContextID& GetContextId() const { return m_context_id; }
00090
00092       BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00093
00095       virtual INT GetID() const;
00096
00098       virtual BOOLEAN IsInstanceOf(INT id) const;
00099
00103       virtual BOOLEAN IsEqual(const Item& item) const;
00104
00106       inline FeatureID GetFeatureId() const { return m_feature ? m_feature->GetFeatureId() : FeatureID();}
00107
00109       virtual void SetText(const WString& text);
00110
00112       virtual const WString& GetText() const;
00113
00117       virtual BOOLEAN Execute();
00118
00120       virtual void SetEnabled(BOOLEAN enabled);
00121
00123       virtual BOOLEAN IsEnabled() const;
00124
00126       Feature*          GetFeature() { return m_feature;}
00127
00129       const Feature*    GetFeature() const { return m_feature;}
00130
00132       void SetFeature(Feature* feature);
00133
00134 #if defined(APOXI_COMPAT_2_7_0)
00135
00136       void      SetIconURI(const WString& icon_uri) {m_icon_uri = icon_uri;}
00137
00139       WString   GetIconURI() const { return m_icon_uri;}
00140
00146       virtual const ImageObtainer& GetIcon(const IconState& icon_state) const;
00147
00148 #endif
00149
00151       virtual void OnLanguageChanged();
00152
00154       virtual void Update();
00155
00158       BOOLEAN IsAttachedToProperty(Property* property) const;
00159
00160    protected:
00162       Feature*          m_feature;
00163
00165       SubstitutedText   m_substituted_text;
00166
00167 #if defined(APOXI_COMPAT_2_7_0)
00168
00169       WString           m_icon_uri;
00170 #endif
00171
00172    private:
00173       FeatureItem(const FeatureItem& orig);
00174       FeatureItem& operator = (const FeatureItem& rhs);
00175
00176       ContextID m_context_id;
00177 };
00178
00179 #endif /* FeatureItem_hpp */
00180
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureItemContainer.cpp File Reference

Atl/Features/FeatureItemContainer.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Atl/Features/FeatureItem.hpp>
#include "FeatureItemContainer.hpp"

Include dependency graph for FeatureItemContainer.cpp:

Generated on Tue Jan 24 17:53:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureItemContainer.hpp File Reference

Atl/Features/FeatureItemContainer.hpp File Reference

#include <Gui/ItemContainer.hpp>
#include <Atl/Features/FeatureItemContainerID.hpp>
#include <Atl/Context/ContextID.hpp>

Include dependency graph for FeatureItemContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FeatureItemContainer

Defines

#define | FeatureItemContainer_hpp

Define Documentation

#define FeatureItemContainer_hpp

Generated on Tue Jan 24 17:53:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureItemContainer.hpp Source File

Atl/Features/FeatureItemContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(FeatureItemContainer_hpp)
00011 #define FeatureItemContainer_hpp
00014
00015 #include <Gui/ItemContainer.hpp>
00016 #include <Atl/Features/FeatureItemContainerID.hpp>
00017 #if defined(APOXI_COMPAT_2_7_0)
00018 #include <Atl/Features/Feature.hpp>
00019 #include <Atl/Properties/SubstitutedText.hpp>
00020 #endif  // APOXI_COMPAT_2_7_0
00021 #include <Atl/Context/ContextID.hpp>
00022
00023 class Feature;
00029 class FeatureItemContainer : public ItemContainer {
00030     public:
00031         typedef ItemContainer Base;
00032
00033         enum Identifier
00034         {
00035             ID = 106
00036         };
00037
00040         enum FeatureItemContainerPropertyId {
00041             ContextPropertyId = 5
00042         };
00043
00044
00047         FeatureItemContainer(BOOLEAN ignore_unavailable_features = TRUE);
00048
00051         FeatureItemContainer(FeatureItemContainerID container_id, BOOLEAN ignore_unavailable_features = TRUE);
00052
00054         virtual ~FeatureItemContainer();
00055
00057         BOOLEAN SetProperty(ResourceParser& parser,
00058                             const GuiObjectFactory::PropertyId prop_id,
00059                             UINT16 object_id);
00060
00062         virtual INT GetID() const;
00063
00065         virtual BOOLEAN IsInstanceOf(INT id) const;
00066
00068         virtual BOOLEAN IsEqual (const Item& item) const;
00069
00072         void Init(FeatureItemContainerID container_id, BOOLEAN ignore_unavailable_features = TRUE);
00073
00077         void Init(FeatureItemContainerID container_id,
00078                 const WString& text, BOOLEAN ignore_unavailable_features = TRUE);
00079
00081         void SetContextId(const ContextID& id);
00082
00084         void SetContextId(const CHAR * id);
00085
00087         const ContextID& GetContextId() const { return m_context_id; }
00088
00090         void SetContainerId(FeatureItemContainerID container_id) { m_container_id = container_id; }
00091
00093         FeatureItemContainerID GetContainerId() const { return m_container_id; }
00094
00095
00099         virtual BOOLEAN AddItem(Item* item);
00100
00104         virtual BOOLEAN InsertItem(INT index, Item* item);
00105
00109         virtual BOOLEAN RemoveItem(INT index);
00110
00114         virtual BOOLEAN RemoveAllItems();
00115
00117         virtual Item* GetItem(INT index) const;
00118
00121         virtual INT GetItemIndex(const Item& item) const;
00122
00124         virtual INT GetItemCount() const;
00125
00128         BOOLEAN IsAvailable() const;
00129
00132         BOOLEAN ContainsFeature(Feature* feature);
00133
00135         void    Invalidate();
00136
00140         void IgnoreUnavailableFeatures(BOOLEAN flag) { m_ignore_unavailable_features = flag; }
00141
00143         BOOLEAN UnavailableFeaturesIgnored() const { return m_ignore_unavailable_features; }
00144
00145
00146    private:
00147         INT LookupIndex(INT i) const { return (!m_index_table) ? i : m_index_table[i]; }
00148
00149         void BuildIndexTable() const;
00150
00151         FeatureItemContainerID  m_container_id;
00152         mutable BOOLEAN                 m_invalid;
00153         BOOLEAN                 m_ignore_unavailable_features;
00154         mutable INT             *m_index_table;
00155         mutable INT             m_index_table_size;
00156
00157         static Mutex                m_mutex;
00158         static BOOLEAN          m_initialized;
00159
00160         ContextID m_context_id;
00161 };
00162
00163 #endif /* FeatureItemContainer_hpp */
00164
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureItemContainerID.hpp File Reference

Atl/Features/FeatureItemContainerID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for FeatureItemContainerID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | FeatureItemContainerID_hpp

Typedefs

typedef ResourceID | FeatureItemContainerID

Define Documentation

#define FeatureItemContainerID_hpp

Typedef Documentation

typedef ResourceID FeatureItemContainerID

Generated on Tue Jan 24 17:53:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeatureItemContainerID.hpp Source File

Atl/Features/FeatureItemContainerID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(FeatureItemContainerID_hpp)
00011 #define FeatureItemContainerID_hpp
00012
00013 #include <Atl/ResourceID.hpp>
00014
00015 typedef ResourceID FeatureItemContainerID;
00016
00017
00018 #endif /* FeatureItemContainerID_hpp */
00019
00020
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeaturePool.cpp File Reference

Atl/Features/FeaturePool.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Features/Feature.hpp>
#include "FeaturePool.hpp"

Include dependency graph for FeaturePool.cpp:

Generated on Tue Jan 24 17:53:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeaturePool.hpp File Reference

Atl/Features/FeaturePool.hpp File Reference

#include <Atl/Features/FeatureID.hpp>
#include <Auxiliary/SimpleMap.hpp>

Include dependency graph for FeaturePool.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FeaturePool

Defines

#define | Atl_Features_FeaturePool_hpp

Define Documentation

#define Atl_Features_FeaturePool_hpp

Generated on Tue Jan 24 17:53:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/FeaturePool.hpp Source File

Atl/Features/FeaturePool.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Atl_Features_FeaturePool_hpp)
00011 #define Atl_Features_FeaturePool_hpp
00014
00015 #include <Atl/Features/FeatureID.hpp>
00016 #include <Auxiliary/SimpleMap.hpp>
00017
00018 class Feature;
00019
00021 class FeaturePool {
00022    public:
00023
00025       virtual Feature* GetFeature(const FeatureID& id) const;
00026
00028       virtual BOOLEAN AddFeature(Feature* feature);
00029
00031       virtual BOOLEAN AddFeatures(Feature features[], INT size);
00032
00033    protected:
00034       typedef SimpleMap<FeatureID,Feature*> FeaturePoolF;
00035
00036    private:
00038       FeaturePoolF m_features;
00039 };
00040
00042 #endif  // Atl_Features_FeaturePool_hpp
00043
00044
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/IndicatorItem.cpp File Reference

Atl/Features/IndicatorItem.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/ResourceParser.hpp>
#include <Atl/Properties/Property.hpp>
#include <Atl/Properties/PropertyDescriptor.hpp>
#include "IndicatorItem.hpp"

Include dependency graph for IndicatorItem.cpp:

Generated on Tue Jan 24 17:53:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/IndicatorItem.hpp File Reference

Atl/Features/IndicatorItem.hpp File Reference

#include <Atl/Features/FeatureItem.hpp>

Include dependency graph for IndicatorItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class IndicatorItem

Generated on Tue Jan 24 17:53:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/IndicatorItem.hpp Source File

Atl/Features/IndicatorItem.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #ifndef Atl_IndicatorItem_hpp
00011 #define Atl_IndicatorItem_hpp
00014
00015 #include <Atl/Features/FeatureItem.hpp>
00016
00017 #if defined(APOXI_COMPAT_2_7_0)
00018 #include <Atl/Properties/PropertyID.hpp>
00019 #include <Atl/Properties/PropertyEditorID.hpp>
00020 #include <Atl/Properties/PropertyDescriptor.hpp>
00021 #endif  // APOXI_COMPAT_2_7_0
00022
00023 class AtlApplication;
00024 class ImageObtainer;
00025 class Property;
00026 class PropertyDescriptor;
00027
00031 class IndicatorItem: public FeatureItem {
00032     typedef FeatureItem Base;
00033
00034 public:
00035
00036     enum {
00037         ID = 102
00038     };
00039
00041     IndicatorItem();
00042
00044     IndicatorItem(Property* property);
00045
00047     IndicatorItem(Property* property, PropertyDescriptor* descriptor);
00048
00050     IndicatorItem(Property* property,
00051         const WString& text,
00052         const ImageObtainer& icon);
00053
00055     virtual ~IndicatorItem();
00056
00058     void Init(Property* property,
00059         const WString& text = "",
00060         const ImageObtainer& icon = ImageObtainer());
00061
00063     virtual void Update();
00064
00066     BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00067
00069     virtual BOOLEAN IsInstanceOf(INT id) const;
00070
00072     void SetDescriptor(PropertyDescriptor* descriptor);
00073
00075     const PropertyDescriptor* GetDescriptor() const;
00076
00078     virtual BOOLEAN Execute();
00079
00080 private:
00081     IndicatorItem(const IndicatorItem&) {};
00082     IndicatorItem& operator = (const IndicatorItem& rhs);
00083
00084     const PropertyDescriptor* m_descriptor;
00085 };
00086
00088 #endif  // Atl_IndicatorItem_hpp
00089
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ItemObj.cpp File Reference

Atl/Features/ItemObj.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/Item.hpp>
#include <Atl/Features/ProviderProxyItem.hpp>
#include <Atl/Features/TriggerKeyFeature.hpp>
#include <Atl/Features/FeatureItem.hpp>
#include <Atl/Features/ItemObj.hpp>

Include dependency graph for ItemObj.cpp:

Generated on Tue Jan 24 17:54:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ItemObj.hpp File Reference

Atl/Features/ItemObj.hpp File Reference

#include <Auxiliary/GenericObject.hpp>

Include dependency graph for ItemObj.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ItemObj

Defines

#define | Atl_Features_ItemObj_hpp

Variables

const GenericTypeId | c_item_ptr_type = c_user_base_gentypes + 4801

Define Documentation

#define Atl_Features_ItemObj_hpp

Generated on Tue Jan 24 17:54:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ItemObj.hpp Source File

Atl/Features/ItemObj.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Atl_Features_ItemObj_hpp)
00015 #define Atl_Features_ItemObj_hpp
00018
00019 #include <Auxiliary/GenericObject.hpp>
00020 #if defined(APOXI_COMPAT_2_7_0)
00021 #include <Atl/Context/MenuDesc.hpp>
00022 #endif  // APOXI_COMPAT_2_7_0
00023
00024 const GenericTypeId c_item_ptr_type = c_user_base_gentypes + 4801;
00025
00026 class Item;
00027
00029 class ItemObj : public GenericObject
00030 {
00031     public:
00033         ItemObj(Item* item);
00034
00036         virtual ~ItemObj();
00037
00039         virtual GenericObject* Copy() const;
00040
00042         virtual BOOLEAN IsEqual(GenericObject* object);
00043
00045         virtual GenericTypeId GetTypeId();
00046
00048         void SetItem(Item* item);
00049
00051         Item* GetItem() const { return m_item; }
00052
00053     private:
00054         Item* m_item;
00055 };
00056
00058 #endif
00059
00060
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuID.hpp File Reference

Atl/Features/MenuID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for MenuID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | MenuID_hpp

Typedefs

typedef ResourceID | MenuID

Define Documentation

#define MenuID_hpp

Generated on Tue Jan 24 17:54:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuID.hpp Source File

Atl/Features/MenuID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(MenuID_hpp)
00011 #define MenuID_hpp
00015
00016
00017 #include <Atl/ResourceID.hpp>
00018
00019 typedef ResourceID MenuID;
00020
00021
00022 #endif /* MenuID_hpp */
00023
00024
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuIdObj.cpp File Reference

Atl/Features/MenuIdObj.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "MenuIdObj.hpp"

Include dependency graph for MenuIdObj.cpp:

Generated on Tue Jan 24 17:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuIdObj.hpp File Reference

Atl/Features/MenuIdObj.hpp File Reference

#include <Auxiliary/GenericObject.hpp>
#include <Atl/Features/MenuID.hpp>

Include dependency graph for MenuIdObj.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuIdObj

Defines

#define | Atl_Features_MenuIdObj_hpp

Variables

const GenericTypeId | c_menu_id_ptr_type = c_user_base_gentypes + 4800

Define Documentation

#define Atl_Features_MenuIdObj_hpp

Generated on Tue Jan 24 17:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuIdObj.hpp Source File

Atl/Features/MenuIdObj.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Atl_Features_MenuIdObj_hpp)
00015 #define Atl_Features_MenuIdObj_hpp
00018
00019 #include <Auxiliary/GenericObject.hpp>
00020 #include <Atl/Features/MenuID.hpp>
00021
00022 const GenericTypeId c_menu_id_ptr_type = c_user_base_gentypes + 4800;
00023
00025 class MenuIdObj : public GenericObject
00026 {
00027     public:
00028         // Constructor of MenuAccessorPtr
00029         MenuIdObj(const MenuID& menu_id);
00030
00031         // Destructor of MenuAccessorPtr
00032         virtual ~MenuIdObj();
00033
00035         virtual GenericObject* Copy() const;
00036
00038         //instance itself
00039         virtual BOOLEAN IsEqual(GenericObject* object);
00040
00042         virtual GenericTypeId GetTypeId();
00043
00044         void SetMenuID(const MenuID& menu_id) { m_menu_id = menu_id; }
00045
00046         const MenuID& GetMenuId() {return m_menu_id;}
00047
00048
00049     private:
00050         MenuID m_menu_id;
00051
00052 };
00053
00055 #endif
00056
00057
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuPool.cpp File Reference

Atl/Features/MenuPool.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/IdentifierHandler.hpp>
#include <Atl/Features/ContextFeature.hpp>
#include <Atl/Features/ContextFeatureItem.hpp>
#include <Atl/Features/Feature.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Features/MenuID.hpp>
#include <Atl/Features/MenuTable.hpp>
#include <Atl/Features/MenuTableNode.hpp>
#include <Atl/Properties/Property.hpp>
#include <Atl/Properties/PropertyItem.hpp>
#include <Atl/Features/FeatureItemContainer.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Config/AtlConfig.hpp>
#include "MenuPool.hpp"

Include dependency graph for MenuPool.cpp:

Generated on Tue Jan 24 17:54:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuPool.hpp File Reference

Atl/Features/MenuPool.hpp File Reference

#include <Atl/Features/MenuID.hpp>
#include <Atl/Features/FeatureItemContainerID.hpp>
#include <Atl/Context/MenuDesc.hpp>
#include <Atl/Config/MenuResourceTable.hpp>

Include dependency graph for MenuPool.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuPool
struct | MenuPool::FeatureItemContainerContentTableEntry
struct | MenuPool::FeatureItemContainerTableEntry
class | MenuPool::MenuMapItem
struct | MenuPool::MenuTableEntry

Defines

#define | Atl_MenuPool_hpp

Define Documentation

#define Atl_MenuPool_hpp

Generated on Tue Jan 24 17:54:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuPool.hpp Source File

Atl/Features/MenuPool.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Atl_MenuPool_hpp)
00011 #define Atl_MenuPool_hpp
00014 #include <Atl/Features/MenuID.hpp>
00015 #include <Atl/Features/FeatureItemContainerID.hpp>
00016 #include <Atl/Context/MenuDesc.hpp>
00017 #include <Atl/Config/MenuResourceTable.hpp>
00018 #if defined(APOXI_COMPAT_2_7_0)
00019 #include <Atl/Features/FeatureItem.hpp>
00020 #endif  // APOXI_COMPAT_2_7_0
00021
00022 class MenuProperties;
00023 class FeatureItemContainer;
00024 class ItemRendererProperties;
00025 class Feature;
00026
00027
00045 class MenuPool
00046 {
00047 public:
00048
00049     struct FeatureItemContainerTableEntry;
00050
00051     enum itemType {
00052         itemTypeNone = 0,
00053         itemTypeFeatureItem,
00054         itemTypeContextFeatureItem,
00055         itemTypeFixedContextFeatureItem,
00056         itemTypePropertyItem,
00057         itemTypeFeatureItemContainer
00058     };
00059
00064     struct MenuTableEntry {
00065         const FeatureItemContainerTableEntry HUGE_64K*  container_table_entry;
00066         const CHAR*     menu_id;
00067         const MenuProperties* menu_properties;
00068     };
00069
00080     struct FeatureItemContainerContentTableEntry {
00081         UINT8           item_type;
00082         const FeatureItemContainerTableEntry HUGE_64K*  container_table_entry;
00083         const CHAR*     application_id;
00084         const CHAR*     feature_id;
00085         const CHAR*     text;
00086         const CHAR*     icon_id;
00087         const void*     datum; // pointer to DataItem or pointer to PropertyDescriptor
00088         const CHAR*     property_editor_id;
00089         const CHAR*     context_id;
00090     };
00091
00098     struct FeatureItemContainerTableEntry {
00099         const FeatureItemContainerContentTableEntry HUGE_64K*   container_content_table_entry;
00100         const CHAR*                     container_id;
00101         const CHAR*                     text;
00102         const CHAR*                     icon_id;
00103         const ItemRendererProperties*   render_properties;
00104         const CHAR*                     context_id;
00105     };
00106
00108     MenuPool();
00109
00111     virtual ~MenuPool();
00112
00115     virtual void InitMenus();
00116
00119     virtual MenuDesc* GetMenu(const MenuID& id);
00120
00122     virtual void OnFeatureAdded(Feature* feature);
00123
00126     virtual void OnFeatureStatusChanged(Feature* feature);
00127
00130     BOOLEAN MenuFileExists() const;
00131
00132 private:
00133     class MenuMapItem
00134     {
00135         public:
00136             MenuMapItem();
00137             MenuMapItem(const MenuID& id, const MenuDesc&  menu) : m_id(id), m_menu(menu) {};
00138
00139             MenuID& GetMenuID() { return m_id; }
00140             MenuDesc& GetMenu() { return m_menu; }
00141
00142         private:
00143             MenuID m_id;
00144             MenuDesc m_menu;
00145     };
00146
00149     BOOLEAN IsIconSet(const String& name) const;
00150
00152     const MenuTableEntry* GetMenuTableEntry(const MenuID& id) const;
00153
00156     FeatureItemContainer* GetFeatureItemContainer(FeatureItemContainerID container_id) const;
00157
00160     FeatureItemContainer* ConstructFeatureItemContainer(const HUGE_64K FeatureItemContainerTableEntry* container_table_entry, BOOLEAN recursive = FALSE);
00161
00164     BOOLEAN ConstructMenu(const MenuID& id);
00165
00169     void UpdateContainerItems(FeatureItemContainer* container, Feature* feature);
00170
00171     Vector<MenuMapItem> m_menus;
00172     Vector< FeatureItemContainer* > m_containers;
00173     MenuResourceTable* m_menu_resource_table;
00174
00175 };
00176
00178 #endif  // Atl_MenuPool_hpp
00179
00180
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuTable.cpp File Reference

Atl/Features/MenuTable.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "MenuTableNode.hpp"
#include "MenuTable.hpp"

Include dependency graph for MenuTable.cpp:

Generated on Tue Jan 24 17:55:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuTable.hpp File Reference

Atl/Features/MenuTable.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuTable

Defines

#define | Atl_MenuTable_hpp

Define Documentation

#define Atl_MenuTable_hpp

Generated on Tue Jan 24 17:55:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuTable.hpp Source File

Atl/Features/MenuTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Atl_MenuTable_hpp)
00009 #define Atl_MenuTable_hpp
00012
00013 class MenuTableNode;
00014
00015 class MenuTable {
00016     friend class MenuTableNode;
00017     public:
00019         static const MenuTableNode* GetRoot() { return m_root; }
00020
00022         static INT GetSize();
00023
00024     private:
00026         static void Attach(MenuTableNode* node);
00027
00028         static const MenuTableNode* m_root;
00029 };
00030
00032 #endif // Atl_MenuTable_hpp
00033
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuTableNode.cpp File Reference

Atl/Features/MenuTableNode.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "MenuTable.hpp"
#include "MenuTableNode.hpp"

Include dependency graph for MenuTableNode.cpp:

Generated on Tue Jan 24 17:55:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuTableNode.hpp File Reference

Atl/Features/MenuTableNode.hpp File Reference

#include <Atl/Features/MenuPool.hpp>

Include dependency graph for MenuTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuTableNode

Defines

#define | Atl_MenuTableNode_hpp

Define Documentation

#define Atl_MenuTableNode_hpp

Generated on Tue Jan 24 17:55:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/MenuTableNode.hpp Source File

Atl/Features/MenuTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Atl_MenuTableNode_hpp)
00009 #define Atl_MenuTableNode_hpp
00012
00013 #include <Atl/Features/MenuPool.hpp>
00014
00015 class MenuTable;
00016
00017 class MenuTableNode {
00018     friend class MenuTable;
00019     public:
00023         MenuTableNode(const MenuPool::MenuTableEntry* entry);
00024
00026         virtual ~MenuTableNode();
00027
00030         const MenuTableNode* GetNext() const { return m_next; }
00031
00034         const MenuPool::MenuTableEntry* GetEntry() const { return m_entry; }
00035
00036     private:
00038         void SetNext(const MenuTableNode* node);
00039
00040         const MenuPool::MenuTableEntry* m_entry;
00041
00042         const MenuTableNode*    m_next;
00043 };
00044
00046 #endif // Atl_Context_ContextTableNode_hpp
00047
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ProviderProxyContainer.cpp File Reference

Atl/Features/ProviderProxyContainer.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Features/ProviderProxyItem.hpp>
#include "ProviderProxyContainer.hpp"

Include dependency graph for ProviderProxyContainer.cpp:

Generated on Tue Jan 24 17:55:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ProviderProxyContainer.hpp File Reference

Atl/Features/ProviderProxyContainer.hpp File Reference

#include <Gui/ItemContainer.hpp>
#include <Auxiliary/Provider.hpp>

Include dependency graph for ProviderProxyContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ProviderProxyContainer

Defines

#define | ProviderProxyContainer_hpp

Define Documentation

#define ProviderProxyContainer_hpp

Generated on Tue Jan 24 17:55:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ProviderProxyContainer.hpp Source File

Atl/Features/ProviderProxyContainer.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(ProviderProxyContainer_hpp)
00011 #define ProviderProxyContainer_hpp
00014
00015 #include <Gui/ItemContainer.hpp>
00016 #include <Auxiliary/Provider.hpp>
00017
00018 #if defined(APOXI_COMPAT_2_7_0)
00019     #include <Atl/Features/ProviderProxyItem.hpp>
00020 #endif  // APOXI_COMPAT_2_7_0
00021
00022 class Provider;
00023 class ProviderProxyItem;
00024
00030 class ProviderProxyContainer : public ItemContainer, public Observer
00031 {
00032     typedef ItemContainer Base;
00033
00034     public:
00035         enum {
00036             ID = 105
00037         };
00038
00041         ProviderProxyContainer();
00042
00047         ProviderProxyContainer(Dispatcher* disp,
00048                                Provider* provider,
00049                                INT text_col_id,
00050                                INT icon_col_id = c_invalid_colid);
00051
00053         virtual ~ProviderProxyContainer();
00054
00059         void Init(Dispatcher* disp,
00060                   Provider* provider,
00061                   INT text_col_id,
00062                   INT icon_col_id = c_invalid_colid);
00063
00069         void Init(Dispatcher* disp,
00070                   Provider* provider,
00071                   const WString& text,
00072                   INT text_col_id,
00073                   INT icon_col_id = c_invalid_colid);
00074
00081         void Init(Dispatcher* disp,
00082                   Provider* provider,
00083                   const WString& text,
00084                   const ImageObtainer& img_obt,
00085                   INT text_col_id,
00086                   INT icon_col_id = c_invalid_colid);
00087
00089         virtual BOOLEAN IsInstanceOf(INT id) const;
00090
00092         BOOLEAN SetProvider(Provider* provider);
00093
00095         Provider* GetProvider() { return m_provider; }
00096
00098         INT GetTextColumnId() const { return m_text_col_id; }
00099
00101         void SetTextColumnId(INT text_col_id) { m_text_col_id = text_col_id; }
00102
00104         INT GetIconColumnId() const { return m_icon_col_id; }
00105
00107         void SetIconColumnId(INT icon_col_id) { m_icon_col_id = icon_col_id; }
00108
00110         virtual BOOLEAN AddItem(Item* item);
00111
00113         virtual BOOLEAN InsertItem(INT index, Item* item);
00114
00116         virtual BOOLEAN RemoveItem(INT index);
00117
00119         virtual BOOLEAN RemoveAllItems();
00120
00122         virtual BOOLEAN SetParentContainer(AbstractItemContainer* container);
00123
00125         virtual AbstractItemContainer* GetParentContainer();
00126
00130         virtual void OnUpdate(ObservableObject* obs_obj);
00131
00132     private:
00133         void UpdateItems();
00134         void DeleteItems();
00135         void InvalidateItem(ProviderProxyItem* item) const;
00136
00137         Provider* m_provider;
00138
00139         INT m_text_col_id;
00140         INT m_icon_col_id;
00141 };
00142
00144 #endif /* ProviderProxyContainer_hpp */
00145
Generated on Tue Jan 24 14:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ProviderProxyItem.cpp File Reference

Atl/Features/ProviderProxyItem.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Auxiliary/Provider.hpp>
#include <Atl/Gui/ImgObtObj.hpp>
#include "ProviderProxyItem.hpp"

Include dependency graph for ProviderProxyItem.cpp:

Generated on Tue Jan 24 17:56:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ProviderProxyItem.hpp File Reference

Atl/Features/ProviderProxyItem.hpp File Reference

#include <Gui/Item.hpp>
#include <Auxiliary/Observer.hpp>
#include <Auxiliary/Provider.hpp>

Include dependency graph for ProviderProxyItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ProviderProxyItem

Defines

#define | ProviderProxyItem_hpp

Define Documentation

#define ProviderProxyItem_hpp

Generated on Tue Jan 24 17:56:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ProviderProxyItem.hpp Source File

Atl/Features/ProviderProxyItem.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(ProviderProxyItem_hpp)
00011 #define ProviderProxyItem_hpp
00014
00015 #include <Gui/Item.hpp>
00016 #include <Auxiliary/Observer.hpp>
00017 #include <Auxiliary/Provider.hpp>
00018
00019 class DataItem;
00032 class ProviderProxyItem : public Item, public Observer
00033 {
00034     typedef Item Base;
00035
00036     public:
00037     enum {
00038         ID = 106
00039     };
00040
00043     ProviderProxyItem();
00044
00052     ProviderProxyItem(Provider* provider,
00053                     INT row = c_no_row,
00054                     INT text_id = c_invalid_colid,
00055                     INT icon_id = c_invalid_colid,
00056                     BOOLEAN obs_prov = TRUE);
00057
00066     ProviderProxyItem(Dispatcher* disp,
00067                     Provider* m_provider,
00068                     INT row = c_no_row,
00069                     INT text_id = c_invalid_colid,
00070                     INT icon_id = c_invalid_colid,
00071                     BOOLEAN obs_prov = TRUE);
00072
00074     ProviderProxyItem(const ProviderProxyItem &ppi);
00075
00077     virtual ~ProviderProxyItem();
00078
00086     void Init(Provider* provider,
00087             INT row = c_no_row,
00088             INT text_id = c_invalid_colid,
00089             INT icon_id = c_invalid_colid,
00090             BOOLEAN obs_prov = TRUE);
00091
00100     void Init(Dispatcher* disp,
00101             Provider* m_container,
00102             INT row = c_no_row,
00103             INT text_id = c_invalid_colid,
00104             INT icon_id = c_invalid_colid,
00105             BOOLEAN obs_prov = TRUE);
00106
00110     virtual const WString& GetText() const;
00111
00116     virtual const ImageObtainer& GetIcon(const IconState& icon_state) const;
00117
00120     BOOLEAN GetData(INT data_id, DataItem& data_item) const;
00121
00124     void SetData(INT data_id, DataItem& data_item);
00125
00127     BOOLEAN IsInvalid() const { return m_invalid; }
00128
00130     void SetInvalid();
00131
00134     void SetItemColumnIds(INT text_id, INT icon_id);
00135
00137     INT GetItemColumnTextId() { return m_text_col_id; }
00138
00140     INT GetItemColumnIconId(void) { return m_icon_col_id; }
00141
00143     void SetProvider(Provider* provider) { m_provider = provider; }
00144
00146     Provider* GetProvider() { return m_provider; }
00147
00150     virtual void OnUpdate(ObservableObject *obs_obj);
00151
00153     virtual BOOLEAN IsEqual(const Item& item) const;
00154
00156     virtual BOOLEAN IsInstanceOf(INT id) const;
00157
00159     void SetProviderRow(INT row);
00160
00162     INT GetProviderRow() const { return m_row; }
00163
00165     ProviderProxyItem& operator = (const ProviderProxyItem& ppi);
00166
00168     void ObserveProvider(BOOLEAN flag);
00169
00171     void InvalidateText();
00172
00174     void InvalidateIcon();
00175
00176 private:
00177
00178     Provider* m_provider;
00179     INT m_row;
00180     INT m_text_col_id;
00181     INT m_icon_col_id;
00182
00183     BOOLEAN m_invalid;
00184     mutable BOOLEAN m_valid_text;
00185     mutable BOOLEAN m_valid_icon;
00186 };
00187
00189 #endif /* ProviderProxyItem_hpp */
00190
Generated on Tue Jan 24 14:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/TriggerKeyFeature.cpp File Reference

Atl/Features/TriggerKeyFeature.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/System.hpp>
#include <Gui/MsgTypes.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/Context/KeyManager.hpp>
#include "TriggerKeyFeature.hpp"

Include dependency graph for TriggerKeyFeature.cpp:

Generated on Tue Jan 24 17:56:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/TriggerKeyFeature.hpp File Reference

Atl/Features/TriggerKeyFeature.hpp File Reference

#include <Atl/Features/Feature.hpp>

Include dependency graph for TriggerKeyFeature.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TriggerKeyFeature
This features posts a key down message with a given key code. It can be used to send key events from a menu item, since this feature can be used in a menu. More...

Defines

#define | TriggerKeyFeature_hpp

Define Documentation

#define TriggerKeyFeature_hpp

Generated on Tue Jan 24 17:56:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/TriggerKeyFeature.hpp Source File

Atl/Features/TriggerKeyFeature.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(TriggerKeyFeature_hpp)
00011 #define TriggerKeyFeature_hpp
00014
00015 #include <Atl/Features/Feature.hpp>
00016
00017
00019 class TriggerKeyFeature : public Feature {
00020     typedef Feature Base;
00021 public:
00022
00023     enum {
00024         ID = 5
00025     };
00026
00028     TriggerKeyFeature();
00029
00031     virtual ~TriggerKeyFeature();
00032
00036     void Init(const FeatureID& feature_id, KeyCode key_code);
00037
00039     void SetKeyCode(KeyCode key_code) { m_key_code = key_code; }
00040
00042     KeyCode GetKeyCode() const { return m_key_code; }
00043
00045     virtual INT GetID() const;
00046
00048     virtual BOOLEAN IsInstanceOf(INT id) const;
00049
00051     virtual BOOLEAN Execute();
00052
00054     virtual BOOLEAN IsEqual(const Feature& feature) const;
00055
00056 private:
00057     TriggerKeyFeature(const TriggerKeyFeature& orig);
00058     TriggerKeyFeature& operator = (const TriggerKeyFeature& rhs);
00059
00060     KeyCode m_key_code;
00061 };
00062
00064 #endif /* TriggerKeyFeature_hpp */
00065
Generated on Tue Jan 24 14:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ValueItem.hpp File Reference

Atl/Features/ValueItem.hpp File Reference

#include <Atl/Features/IndicatorItem.hpp>

Include dependency graph for ValueItem.hpp:

Go to the source code of this file.

Defines

#define | IndicatorItem_hpp

Typedefs

typedef IndicatorItem | ValueItem

Define Documentation

#define IndicatorItem_hpp

Typedef Documentation

typedef IndicatorItem ValueItem

Generated on Tue Jan 24 17:56:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Features/ValueItem.hpp Source File

Atl/Features/ValueItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 #if !defined(IndicatorItem_hpp)
00011 #define IndicatorItem_hpp
00012
00013
00014
00015 #include <Atl/Features/IndicatorItem.hpp>
00016
00017 typedef IndicatorItem ValueItem;
00018
00019
00020 #endif
00021
Generated on Tue Jan 24 14:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemBox.cpp File Reference

Atl/Gui/AtlItemBox.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Application.hpp>
#include <Atl/Features/FeatureItem.hpp>
#include <Atl/Properties/Property.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include "AtlItemBox.hpp"

Include dependency graph for AtlItemBox.cpp:

Generated on Tue Jan 24 17:57:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemBox.hpp File Reference

Atl/Gui/AtlItemBox.hpp File Reference

#include <Gui/ItemBox.hpp>
#include <Kernel/UserDispatcher.hpp>

Include dependency graph for AtlItemBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlItemBox
class | AtlItemBox::FeatureListener

Defines

#define | Apoxi_AtlItemBox_hpp

Define Documentation

#define Apoxi_AtlItemBox_hpp

Generated on Tue Jan 24 17:57:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemBox.hpp Source File

Atl/Gui/AtlItemBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003 ------------------------------------------------------------------------
00004 This document contains proprietary information belonging to COMNEON.
00005 Passing on and copying of this document, use and communication of its
00006 contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AtlItemBox_hpp)
00010 #define Apoxi_AtlItemBox_hpp
00014
00015 #include <Gui/ItemBox.hpp>
00016 #include <Kernel/UserDispatcher.hpp>
00017
00018 #if defined(APOXI_COMPAT_2_7_0)
00019 #include <Atl/Properties/Property.hpp>
00020 #endif  // APOXI_COMPAT_2_7_0
00021
00022 class Item;
00023 class Feature;
00026 class AtlItemBox : public ItemBox {
00027     typedef ItemBox Base;
00028
00029     class FeatureListener : public UserDispatcher {
00030
00031         public:
00032             FeatureListener();
00033             virtual ~FeatureListener();
00034             void Init(AtlItemBox* box);
00035
00036         protected:
00037
00039             virtual BOOLEAN OnMessage(const Message& msg);
00040
00041         private:
00042             AtlItemBox* m_box;
00043     };
00044
00045     public:
00046         enum {
00047             ID = 101
00048         };
00049
00051         AtlItemBox();
00052
00054         AtlItemBox(Control* control, Item* item);
00055
00057         virtual ~AtlItemBox();
00058
00060         void Init(Control* control, Item* item);
00061
00062     protected:
00064         virtual BOOLEAN OnMessage(const Message& msg);
00065
00072         virtual void OnFeatureChanged(Feature* changed_feature, INT property_id);
00073
00075         virtual void Refresh(const Rect& rect = Rect());
00076
00077     private:
00078         void AddToParent();
00079         void RemoveFromParent();
00080
00081         void CheckAvailability(Feature* changed_feature);
00082
00083         FeatureListener m_feature_listener;
00084         Control* m_box_parent;
00085
00086     friend class FeatureListener;
00087 };
00089 #endif  // Apoxi_AtlItemBox_hpp
00090
Generated on Tue Jan 24 14:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemGrid.hpp File Reference

Atl/Gui/AtlItemGrid.hpp File Reference

#include <Compat/AtlItemGrid.hpp>

Include dependency graph for AtlItemGrid.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 17:57:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemGrid.hpp Source File

Atl/Gui/AtlItemGrid.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  The class AbstractListBox has been moved to Compat.
00010 This header-file assures backward-compatibility for
00011 applications written with APOXI-versions smaller than 2.6.0.*/
00012 #include <Compat/AtlItemGrid.hpp>
00013
Generated on Tue Jan 24 14:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemGridWindow.cpp File Reference

Atl/Gui/AtlItemGridWindow.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/System.hpp>
#include <Gui/ItemRendererProperties.hpp>
#include <Gui/AbstractItemRenderer.hpp>
#include <Gui/MsgTypes.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Context/MenuDesc.hpp>
#include <Atl/Context/MenuProperties.hpp>
#include <Atl/Features/ContextFeatureItem.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Features/FeatureItemContainer.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/Context/ContextManager.hpp>
#include "AtlItemGridWindow.hpp"

Include dependency graph for AtlItemGridWindow.cpp:

Generated on Tue Jan 24 17:57:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemGridWindow.hpp File Reference

Atl/Gui/AtlItemGridWindow.hpp File Reference

#include <Gui/ItemMenu.hpp>
#include <Atl/Context/ContextID.hpp>
#include <Atl/AtlWindow.hpp>

Include dependency graph for AtlItemGridWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlItemGridWindow

Defines

#define | Atl_Gui_AtlItemGridWindow_hpp

Define Documentation

#define Atl_Gui_AtlItemGridWindow_hpp

Generated on Tue Jan 24 17:57:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemGridWindow.hpp Source File

Atl/Gui/AtlItemGridWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_Gui_AtlItemGridWindow_hpp)
00010 #define Atl_Gui_AtlItemGridWindow_hpp
00013
00014 #include <Gui/ItemMenu.hpp>
00015 #include <Atl/Context/ContextID.hpp>
00016 #include <Atl/AtlWindow.hpp>
00017
00023 class AtlItemGridWindow : public AtlWindow {
00024     typedef AtlWindow Base;
00025
00026     public:
00027
00028         enum {
00029             ID = 42
00030         };
00031
00034         AtlItemGridWindow();
00035
00039         AtlItemGridWindow(ItemGrid* item_grid);
00040
00042         virtual ~AtlItemGridWindow();
00043
00046         void Init(ItemGrid* item_grid = 0);
00047
00049         virtual BOOLEAN IsInstanceOf(INT id) const;
00050
00052         Item* GetSelectedItem() const { return m_item_grid->GetSelectedItem(); }
00053
00055         INT GetSelectedIndex() const { return m_item_grid->GetSelectedIndex(); }
00056
00059         void SetSelectedIndex(INT idx);
00060
00062         virtual const ContextID& GetContextId() const;
00063
00064     protected:
00065
00067         virtual void OnOpen();
00068
00069
00071         virtual void OnClose();
00072
00073
00077         virtual void OnGetFocus();
00078
00080         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00081
00083         virtual BOOLEAN OnMessage(const Message& msg);
00084
00086         virtual void OnSelectionChanged();
00087
00091         virtual void ApplyContext();
00092
00094         INT GetCurrentDisplayType();
00095
00097         const ContextID& GetWindowContextId() const { return Base::GetContextId(); }
00098
00099
00100     private:
00101
00102         void TriggerSelectedItem();
00103         BOOLEAN ContextAffected(const Item* changed_item, INT property_id) const;
00104
00105         ItemGrid*   m_item_grid;
00106         INT         m_predefined_selection;
00107 };
00108
00110 #endif  // Atl_Gui_AtlItemGridWindow_hpp
00111
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemListWindow.cpp File Reference

Atl/Gui/AtlItemListWindow.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Gui/AbstractItemContainer.hpp>
#include <Gui/MsgTypes.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Context/ContextManager.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include "AtlItemListWindow.hpp"

Include dependency graph for AtlItemListWindow.cpp:

Generated on Tue Jan 24 17:58:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemListWindow.hpp File Reference

Atl/Gui/AtlItemListWindow.hpp File Reference

#include <Gui/ItemGrid.hpp>
#include <Atl/Gui/AtlItemGridWindow.hpp>

Include dependency graph for AtlItemListWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlItemListWindow

Defines

#define | Atl_Gui_AtlItemListWindow_hpp

Define Documentation

#define Atl_Gui_AtlItemListWindow_hpp

Generated on Tue Jan 24 17:58:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemListWindow.hpp Source File

Atl/Gui/AtlItemListWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_Gui_AtlItemListWindow_hpp)
00010 #define Atl_Gui_AtlItemListWindow_hpp
00013
00014 #include <Gui/ItemGrid.hpp>
00015 #include <Atl/Gui/AtlItemGridWindow.hpp>
00016
00022 class AtlItemListWindow : public AtlItemGridWindow {
00023     typedef AtlItemGridWindow Base;
00024
00025     public:
00026          enum {
00027             ID = 41
00028          };
00029
00032         AtlItemListWindow();
00033
00036         AtlItemListWindow(AbstractItemContainer* item_container);
00037
00039         virtual ~AtlItemListWindow();
00040
00043         void Init(AbstractItemContainer* item_container = 0);
00044
00046         virtual BOOLEAN IsInstanceOf(INT id) const;
00047
00049         void SetItemContainer(AbstractItemContainer* item_container);
00050
00052         AbstractItemContainer* GetItemContainer() const { return m_item_list.GetItemContainer(); }
00053
00056         void SetSelectedRow(INT idx);
00057
00059         INT GetSelectedRow() const { return GetSelectedIndex(); }
00060
00062         ItemGrid& GetList() { return m_item_list; }
00063
00064     protected:
00066         virtual void OnOpen();
00067
00069         virtual void OnSelectionChanged();
00070
00071     private:
00072         void UpdateContainerItems(const ItemContainer* item_cont);
00073         ItemGrid        m_item_list;
00074 };
00075
00077 #endif  // Atl_Gui_AtlItemListWindow_hpp
00078
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemMenu.hpp File Reference

Atl/Gui/AtlItemMenu.hpp File Reference

#include <Compat/AtlItemMenu.hpp>

Include dependency graph for AtlItemMenu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:58:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemMenu.hpp Source File

Atl/Gui/AtlItemMenu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  The class AbstractListBox has been moved to Compat.
00010 This header-file assures backward-compatibility for
00011 applications written with APOXI-versions smaller than 2.6.0.*/
00012 #include <Compat/AtlItemMenu.hpp>
00013
00014
00015
00016
00017
00018
00019
00020
00021
00022
00023
00024
00025
00026
00027
00028
00029
00030
00031
00032
00033
00034
00035
00036
00037
00038
00039
00040
00041
00042
00043
00044
00045
00046
00047
00048
00049
00050
00051
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemMenuWindow.cpp File Reference

Atl/Gui/AtlItemMenuWindow.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/System.hpp>
#include <Gui/ItemRendererProperties.hpp>
#include <Gui/AbstractItemRenderer.hpp>
#include <Gui/MsgTypes.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Context/MenuDesc.hpp>
#include <Atl/Context/MenuProperties.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Features/FeatureItemContainer.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/Context/ContextManager.hpp>
#include <Atl/Gui/AtlItemListWindow.hpp>
#include "AtlItemMenuWindow.hpp"

Include dependency graph for AtlItemMenuWindow.cpp:

Generated on Tue Jan 24 17:58:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemMenuWindow.hpp File Reference

Atl/Gui/AtlItemMenuWindow.hpp File Reference

#include <Gui/ItemMenu.hpp>
#include <Atl/Context/ContextID.hpp>
#include <Atl/Features/MenuID.hpp>
#include <Atl/Gui/AtlItemGridWindow.hpp>
#include <Atl/Context/MenuProperties.hpp>

Include dependency graph for AtlItemMenuWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlItemMenuWindow

Defines

#define | Atl_Gui_AtlItemMenuWindow_hpp

Define Documentation

#define Atl_Gui_AtlItemMenuWindow_hpp

Generated on Tue Jan 24 17:58:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemMenuWindow.hpp Source File

Atl/Gui/AtlItemMenuWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_Gui_AtlItemMenuWindow_hpp)
00010 #define Atl_Gui_AtlItemMenuWindow_hpp
00013
00014 #include <Gui/ItemMenu.hpp>
00015 #include <Atl/Context/ContextID.hpp>
00016 #include <Atl/Features/MenuID.hpp>
00017 #include <Atl/Gui/AtlItemGridWindow.hpp>
00018 #include <Atl/Context/MenuProperties.hpp>
00019
00020 #if defined(APOXI_COMPAT_2_7_0)
00021 #include <Atl/Features/TriggerKeyFeature.hpp>
00022 #include <Atl/Context/MenuDesc.hpp>
00023 #endif  // APOXI_COMPAT_2_7_0
00024
00032 class AtlItemMenuWindow : public AtlItemGridWindow {
00033     typedef AtlItemGridWindow Base;
00034
00035     public:
00036
00037         enum {
00038             ID = 40
00039         };
00040
00042         AtlItemMenuWindow();
00043
00046         AtlItemMenuWindow(const MenuID& menu_id);
00047
00049         virtual ~AtlItemMenuWindow();
00050
00052         void Init();
00053
00056         void Init(const MenuID& menu_id);
00057
00059         virtual BOOLEAN IsInstanceOf(INT id) const;
00060
00062         void SetMenuID(const MenuID& menu_id);
00063
00065         const MenuID& GetMenuID() { return m_menu_id; }
00066
00068         void SetParentWindow(Window* win) { m_parent_win = win; }
00069
00071         INT GetMenuType() {return m_menu_type;}
00072
00073
00074     protected:
00075
00076
00078         virtual void OnOpen();
00079
00084         virtual void OnLoseFocus();
00085
00087         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00088
00090         virtual BOOLEAN OnMessage(const Message& msg);
00091
00093         virtual void OnSelectionChanged();
00094
00096         virtual void OnContextSwitched();
00097
00099         ItemMenu* GetMenu() { return &m_item_menu; }
00100
00103         void TriggerMenuItem(INT idx);
00104
00106         virtual void ApplyContext();
00107
00108     private:
00109         void UpdateMenuProperties();
00110         void CalcPopupWindowSize();
00111         INT GetPressedNumber(KeyCode key_code);
00112
00113         BOOLEAN ItemContainerAffected(const Item* changed_item, INT property_id) const;
00114         void CheckTitle();
00115         void VerifyItemContainerTitle();
00116
00117
00118         MenuID      m_menu_id;
00119         Window*     m_parent_win;
00120
00121         ItemMenu    m_item_menu;
00122
00123         MenuProperties::MenuType    m_menu_type;
00124         MenuProperties::TitleTextType m_title_type;
00125
00126         BOOLEAN     m_close_after_trigger;
00127 };
00128
00130 #endif  // Atl_Gui_AtlItemMenuWindow_hpp
00131
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemRenderer.hpp File Reference

Atl/Gui/AtlItemRenderer.hpp File Reference

#include <Compat/AtlItemRenderer.hpp>

Include dependency graph for AtlItemRenderer.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 17:58:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlItemRenderer.hpp Source File

Atl/Gui/AtlItemRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 /*  The class IndicatorBar has been moved to Compat.
00011 This header-file assures backward-compatibility for
00012 applications written with APOXI-versions smaller than 2.6*/
00013
00014 #include <Compat/AtlItemRenderer.hpp>
00015
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlLabelListWindow.cpp File Reference

Atl/Gui/AtlLabelListWindow.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Gui/ItemRendererProperties.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/Layouter.hpp>
#include <Gui/AbstractItemContainer.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Context/ContextManager.hpp>
#include <Config/GuiEngineConfig.hpp>
#include "AtlLabelListWindow.hpp"

Include dependency graph for AtlLabelListWindow.cpp:

Generated on Tue Jan 24 17:59:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlLabelListWindow.hpp File Reference

Atl/Gui/AtlLabelListWindow.hpp File Reference

#include <Atl/Gui/AtlItemListWindow.hpp>
#include <Atl/Gui/ItemLabel.hpp>

Include dependency graph for AtlLabelListWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlLabelListWindow

Defines

#define | Atl_Gui_AtlLabelListWindow_hpp

Define Documentation

#define Atl_Gui_AtlLabelListWindow_hpp

Generated on Tue Jan 24 17:59:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/AtlLabelListWindow.hpp Source File

Atl/Gui/AtlLabelListWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_Gui_AtlLabelListWindow_hpp)
00010 #define Atl_Gui_AtlLabelListWindow_hpp
00013
00014 #include <Atl/Gui/AtlItemListWindow.hpp>
00015 #include <Atl/Gui/ItemLabel.hpp>
00016
00017 class ItemRendererProperties;
00018
00026 class AtlLabelListWindow : public AtlItemListWindow {
00027     typedef AtlItemListWindow Base;
00028
00029     public:
00031         AtlLabelListWindow();
00032
00034         AtlLabelListWindow(AbstractItemContainer* item_container, const Item& label, BOOLEAN is_numbered = TRUE);
00035
00037         virtual ~AtlLabelListWindow();
00038
00040         void Init(AbstractItemContainer* item_container, const Item& label, BOOLEAN is_numbered = TRUE);
00041
00043         void SetLabel(const Item& label);
00044
00046         const Item& GetLabel() { return m_label.GetItem(); }
00047
00048     protected:
00050         virtual void OnOpen();
00052         virtual BOOLEAN OnMessage(const Message& msg);
00054         virtual void OnLayoutClient();
00055
00057         virtual void OnSelectionChanged();
00058
00059     private:
00060         void SetFullScreenPerItem();
00061
00062         ItemLabel m_label;
00063         WString m_label_txt;
00064         BOOLEAN m_is_numbered;
00065         ItemRendererProperties* m_cont_prop;
00066 };
00067
00069 #endif  // Atl_Gui_AtlLabelListWindow_hpp
00070
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/ImgObtObj.cpp File Reference

Atl/Gui/ImgObtObj.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "ImgObtObj.hpp"

Include dependency graph for ImgObtObj.cpp:

Generated on Tue Jan 24 17:59:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/ImgObtObj.hpp File Reference

Atl/Gui/ImgObtObj.hpp File Reference

#include <Auxiliary/GenericObject.hpp>
#include <Gui/ImageObtainer.hpp>

Include dependency graph for ImgObtObj.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImgObtObj

Defines

#define | Atl_Gui_ImgObtObj_hpp

Variables

const GenericTypeId | c_img_obt_type = c_user_base_gentypes + 4802

Define Documentation

#define Atl_Gui_ImgObtObj_hpp

Generated on Tue Jan 24 17:59:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/ImgObtObj.hpp Source File

Atl/Gui/ImgObtObj.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Atl_Gui_ImgObtObj_hpp)
00015 #define Atl_Gui_ImgObtObj_hpp
00018
00019
00020 #include <Auxiliary/GenericObject.hpp>
00021 #include <Gui/ImageObtainer.hpp>
00022
00023 const GenericTypeId c_img_obt_type = c_user_base_gentypes + 4802;
00024
00026 class ImgObtObj : public GenericObject{
00027     public:
00028         typedef GenericObject Base;
00029
00031         ImgObtObj(const ImageObtainer& img_obt);
00032
00033         // Destructor of the class BitmapRes
00034         virtual ~ImgObtObj();
00035
00037         virtual GenericObject* Copy() const;
00038
00040         //instance itself
00041         virtual BOOLEAN IsEqual(GenericObject* object);
00042
00044         virtual GenericTypeId GetTypeId();
00045
00046         void SetImgObt(const ImageObtainer& img_obt) { m_img_obt = img_obt; }
00047
00048         const ImageObtainer& GetImgObt() const { return m_img_obt; }
00049
00050     private:
00051         ImageObtainer m_img_obt;
00052
00053 };
00054
00056 #endif
00057
00058
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/Indicator.hpp File Reference

Atl/Gui/Indicator.hpp File Reference

#include <Compat/Indicator.hpp>

Include dependency graph for Indicator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:59:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/Indicator.hpp Source File

Atl/Gui/Indicator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 /*  The class Indicator has been moved to Compat.
00011 This header-file assures backward-compatibility for
00012 applications written with APOXI-versions smaller than 2.5*/
00013 #include <Compat/Indicator.hpp>
00014
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorBar.hpp File Reference

Atl/Gui/IndicatorBar.hpp File Reference

#include <Compat/IndicatorBar.hpp>

Include dependency graph for IndicatorBar.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:59:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorBar.hpp Source File

Atl/Gui/IndicatorBar.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 /*  The class IndicatorBar has been moved to Compat.
00011 This header-file assures backward-compatibility for
00012 applications written with APOXI-versions smaller than 2.5*/
00013 #include <Compat/IndicatorBar.hpp>
00014
00015
00016
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorBarID.hpp File Reference

Atl/Gui/IndicatorBarID.hpp File Reference

#include <Compat/IndicatorBarID.hpp>

Include dependency graph for IndicatorBarID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:59:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorBarID.hpp Source File

Atl/Gui/IndicatorBarID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 /*  The class IndicatorBarID has been moved to Compat.
00011 This header-file assures backward-compatibility for
00012 applications written with APOXI-versions smaller than 2.5*/
00013 #include <Compat/IndicatorBarID.hpp>
00014
00015
00016
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorDescription.hpp File Reference

Atl/Gui/IndicatorDescription.hpp File Reference

#include <Compat/IndicatorDescription.hpp>

Include dependency graph for IndicatorDescription.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:59:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorDescription.hpp Source File

Atl/Gui/IndicatorDescription.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 /*  The class IndicatorDescription has been moved to Compat.
00011 This header-file assures backward-compatibility for
00012 applications written with APOXI-versions smaller than 2.5*/
00013 #include <Compat/IndicatorDescription.hpp>
00014
00015
00016
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorID.hpp File Reference

Atl/Gui/IndicatorID.hpp File Reference

#include <Compat/IndicatorID.hpp>

Include dependency graph for IndicatorID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 17:59:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorID.hpp Source File

Atl/Gui/IndicatorID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 /*  The class IndicatorID has been moved to Compat.
00011 This header-file assures backward-compatibility for
00012 applications written with APOXI-versions smaller than 2.5*/
00013 #include <Compat/IndicatorID.hpp>
00014
00015
00016
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorPaneObject.hpp File Reference

Atl/Gui/IndicatorPaneObject.hpp File Reference

#include <Compat/IndicatorPaneObject.hpp>

Include dependency graph for IndicatorPaneObject.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 17:59:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/IndicatorPaneObject.hpp Source File

Atl/Gui/IndicatorPaneObject.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 /*  The class IndicatorPaneObject has been moved to Compat.
00011 This header-file assures backward-compatibility for
00012 applications written with APOXI-versions smaller than 2.5*/
00013 #include <Compat/IndicatorPaneObject.hpp>
00014
00015
00016
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/ItemLabel.cpp File Reference

Atl/Gui/ItemLabel.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/DefaultItemRenderer.hpp>
#include <Config/GuiEngineConfig.hpp>
#include "ItemLabel.hpp"

Include dependency graph for ItemLabel.cpp:

Generated on Tue Jan 24 17:59:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/ItemLabel.hpp File Reference

Atl/Gui/ItemLabel.hpp File Reference

#include <Gui/DrawableObject.hpp>

Include dependency graph for ItemLabel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ItemLabel
DrawableObject, which shows text. More...
class | ItemLabelView

Defines

#define | Atl_Gui_ItemLabel_hpp

Define Documentation

#define Atl_Gui_ItemLabel_hpp

Generated on Tue Jan 24 17:59:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/ItemLabel.hpp Source File

Atl/Gui/ItemLabel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_Gui_ItemLabel_hpp)
00010 #define Atl_Gui_ItemLabel_hpp
00013
00014 #include <Gui/DrawableObject.hpp>
00015
00016 #if defined(APOXI_COMPAT_2_7_0)
00017 #include <Gui/Color.hpp>
00018 #include <Gui/ImageBox.hpp>
00019 #endif  // APOXI_COMPAT_2_7_0
00020
00021 class ItemRendererProperties;
00022 class AbstractItemRenderer;
00023
00028
00029 class ItemLabel : public DrawableObject {
00030     typedef DrawableObject Base;
00031
00032     public:
00034         ItemLabel();
00035
00037         ItemLabel(Control *control, const Item& item, BOOLEAN auto_draw = TRUE);
00038
00040         virtual ~ItemLabel();
00041
00043         void Init(Control *control);
00044
00046         void Init(Control *control, const Item& item, BOOLEAN auto_draw = TRUE);
00047
00049         void SetItem(const Item& item) { m_item = item; };
00050
00052         const Item& GetItem() const { return m_item; }
00053
00055         void SetRenderer(const ItemRendererProperties* properties = 0);
00056
00058         AbstractItemRenderer* GetRenderer() const { return m_renderer; }
00059
00060     private:
00061         void SetDefaults();
00062
00063         Item m_item;
00064
00065         AbstractItemRenderer* m_renderer;
00066         const ItemRendererProperties* m_renderer_properties;
00067 };
00068
00069 class ItemLabelView : public DrawableObjectView {
00070
00071     typedef DrawableObjectView Base;
00072
00073     public:
00075         ItemLabelView();
00076         virtual ~ItemLabelView();
00077
00079         virtual void Draw(const Component &component,
00080                           DeviceContext *dc,
00081                           const Rect &repaint_rect) const;
00082 };
00083
00085 #endif  // Atl_Gui_ItemLabel_hpp
00086
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/MainDesktop.cpp File Reference

Atl/Gui/MainDesktop.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "MainDesktop.hpp"
#include <Config/IndicatorConfig.hpp>

Include dependency graph for MainDesktop.cpp:

Generated on Tue Jan 24 18:00:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/MainDesktop.hpp File Reference

Atl/Gui/MainDesktop.hpp File Reference

#include <Gui/Desktop.hpp>

Include dependency graph for MainDesktop.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MainDesktop
Default desktop which displays indicators inside the desktop sections. More...

Defines

#define | Main_Desktop_hpp

Define Documentation

#define Main_Desktop_hpp

Generated on Tue Jan 24 18:00:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Gui/MainDesktop.hpp Source File

Atl/Gui/MainDesktop.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Main_Desktop_hpp)
00010 #define Main_Desktop_hpp
00013
00014 #include <Gui/Desktop.hpp>
00015
00016
00018 class MainDesktop : public Desktop {
00019     typedef Desktop Base;
00020
00021     public:
00022         static Desktop* CreateInstance(PanelAlignment panel_align = PanelOnBottom,
00023                                        SectionAlignment section_align = HorizBorderAlign);
00024
00025     protected:
00026         virtual Component* CreateSection(SectionType section_type);
00027
00028         MainDesktop(PanelAlignment panel_align,
00029                     SectionAlignment section_align);
00030 };
00031
00033 #endif  // Main_Desktop_hpp
00034
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/AtlPropertyEditor.hpp File Reference

Atl/Properties/AtlPropertyEditor.hpp File Reference

#include <Atl/Properties/PropertyEditor.hpp>

Include dependency graph for AtlPropertyEditor.hpp:

Go to the source code of this file.

Defines

#define | Atl_AtlPropertyEditor_hpp

Typedefs

typedef PropertyEditor | AtlPropertyEditor

Define Documentation

#define Atl_AtlPropertyEditor_hpp

Typedef Documentation

typedef PropertyEditor AtlPropertyEditor

Generated on Tue Jan 24 18:01:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/AtlPropertyEditor.hpp Source File

Atl/Properties/AtlPropertyEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_AtlPropertyEditor_hpp)
00010 #define Atl_AtlPropertyEditor_hpp
00011
00012 #include <Atl/Properties/PropertyEditor.hpp>
00013
00014 typedef PropertyEditor AtlPropertyEditor;
00015
00016 #endif  // Atl_AtlPropertyEditor_hpp
00017
00018
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/ListPropertyDescriptor.cpp File Reference

Atl/Properties/ListPropertyDescriptor.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include "ListPropertyDescriptor.hpp"

Include dependency graph for ListPropertyDescriptor.cpp:

Generated on Tue Jan 24 18:01:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/ListPropertyDescriptor.hpp File Reference

Atl/Properties/ListPropertyDescriptor.hpp File Reference

#include "PropertyDescriptor.hpp"

Include dependency graph for ListPropertyDescriptor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class ListPropertyDescriptor

Generated on Tue Jan 24 18:01:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/ListPropertyDescriptor.hpp Source File

Atl/Properties/ListPropertyDescriptor.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #ifndef Atl_ListPropertyDescriptor_hpp
00011 #define Atl_ListPropertyDescriptor_hpp
00014
00015 #include "PropertyDescriptor.hpp"
00016
00017
00027 class ListPropertyDescriptor : public PropertyDescriptor {
00028     typedef PropertyDescriptor Base;
00029
00030     public:
00031         enum {
00032             ID = 2
00033         };
00034
00037         ListPropertyDescriptor();
00038
00040         virtual ~ListPropertyDescriptor();
00041
00043         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00044
00047         virtual BOOLEAN IsInstanceOf(const INT id) const;
00048
00051         virtual WString GetText(INT index) const = 0;
00052
00055         virtual ImageObtainer GetIcon(INT index) const = 0;
00056
00061         virtual DataItem GetValue(INT index) const;
00062
00066         virtual INT GetItemCount() const;
00067 };
00068
00070 #endif  // Atl_ListPropertyDescriptor_hpp
00071
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/MappingPolicy.cpp File Reference

Atl/Properties/MappingPolicy.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/ResourceParser.hpp>
#include "MappingPolicy.hpp"

Include dependency graph for MappingPolicy.cpp:

Generated on Tue Jan 24 18:01:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/MappingPolicy.hpp File Reference

Atl/Properties/MappingPolicy.hpp File Reference

#include <Auxiliary/DataItem.hpp>

Include dependency graph for MappingPolicy.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MappingPolicy
class | RangeMappingPolicy

Generated on Tue Jan 24 18:01:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/MappingPolicy.hpp Source File

Atl/Properties/MappingPolicy.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010
00011 #ifndef Atl_MappingPolicy_hpp
00012 #define Atl_MappingPolicy_hpp
00015
00016 #include <Auxiliary/DataItem.hpp>
00017
00020 class MappingPolicy {
00021     public:
00023         MappingPolicy();
00024
00026         virtual ~MappingPolicy();
00027
00031         virtual INT GetIndex(const DataItem& value) const;
00032
00036         virtual DataItem GetValue(INT index) const { return DataItem((Number)index); }
00037
00040         BOOLEAN SetProperty(ResourceParser& parser, GuiObjectFactory::PropertyId property_id, INT object_id);
00041 };
00042
00046 class RangeMappingPolicy : public MappingPolicy {
00047     typedef MappingPolicy Base;
00048     public:
00050         RangeMappingPolicy();
00051
00054         RangeMappingPolicy(INT range_count);
00055
00057         virtual ~RangeMappingPolicy();
00058
00061         void SetRangeCount(INT range_count) { m_range_count = range_count; }
00062
00064         virtual INT GetIndex(const DataItem& value) const;
00065
00067         virtual DataItem GetValue(INT index) const;
00068
00074         BOOLEAN SetProperty(ResourceParser& parser, GuiObjectFactory::PropertyId property_id, INT object_id);
00075
00076     private:
00077         INT m_range_count;
00078 };
00080 #endif  // Atl_MappingPolicy_hpp
00081
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/Property.cpp File Reference

Atl/Properties/Property.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/Locale.hpp>
#include <Gui/LanguageManager.hpp>
#include <Atl/Properties/PropertyDescriptor.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include "Property.hpp"

Include dependency graph for Property.cpp:

Generated on Tue Jan 24 18:02:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/Property.hpp File Reference

Atl/Properties/Property.hpp File Reference

#include <Auxiliary/DataItem.hpp>
#include <Atl/Features/Feature.hpp>

Include dependency graph for Property.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class Property

Generated on Tue Jan 24 18:02:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/Property.hpp Source File

Atl/Properties/Property.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010
00011 #ifndef Atl_Property_hpp
00012 #define Atl_Property_hpp
00015
00016 #include <Auxiliary/DataItem.hpp>
00017 #include <Atl/Features/Feature.hpp>
00018
00019 #if defined(APOXI_COMPAT_2_7_0)
00020 #include <Kernel/MessageRouter.hpp>
00021 #endif  // APOXI_COMPAT_2_7_0
00022
00023 class PropertyDescriptor;
00024
00025
00030 class Property : public Feature{
00031     typedef Feature Base;
00032
00033     public:
00034         enum {
00035             ID = 4
00036         };
00037
00038         enum PropertyAttributeId {
00039             ValueAttributeId = 2
00040         };
00041
00042         enum Notification{
00044             NotifyNever = 0,
00046             NotifyValidateSet = 1,
00048             NotifyPreviewChanged = 2,
00050             NotifySet = 4,
00052             NotifyCanceled = 8
00053         };
00054
00056         Property();
00057
00059         Property(AtlApplication* app,
00060                 const FeatureID& id);
00061
00063         Property(AtlApplication* app,
00064                 const FeatureID& id,
00065                 const DataItem& value);
00066
00068         Property(AtlApplication* app,
00069                 const FeatureID& id,
00070                 const UINT8 notification_rule,
00071                 const DataItem& value);
00072
00074         virtual ~Property();
00075
00077         void Init(AtlApplication* app,
00078                   const FeatureID& id,
00079                   const DataItem& value);
00080
00082         void Init(AtlApplication* app,
00083                   const FeatureID& id);
00084
00086         void Init(AtlApplication* app,
00087                   const FeatureID& id,
00088                   const UINT8 notification_rule);
00089
00091         void Init(AtlApplication* app,
00092                   const FeatureID& id,
00093                   const UINT8 notification_rule,
00094                   const DataItem& value);
00095
00097         void Init(AtlApplication* app,
00098                   const FeatureID& id,
00099                   const DataItem& value,
00100                   BOOLEAN available,
00101                   BOOLEAN enabled);
00102
00104         void Init(AtlApplication* app,
00105                   const FeatureID& id,
00106                   const UINT8 notification_rule,
00107                   const DataItem& value,
00108                   BOOLEAN available,
00109                   BOOLEAN enabled);
00110
00112         virtual BOOLEAN IsInstanceOf(INT id) const;
00113
00115         const DataItem& GetDataItem() const { return m_value; }
00116
00118         void            SetDataItem(const DataItem& value);
00119
00121         Number      GetNumber() const { return m_value.GetNumber(); }
00122
00124         String      GetString() const { return m_value.GetString(); }
00125
00127         WString     GetWString() const { return m_value.GetWString(); }
00128
00130         PhoneNumber GetPhoneNumber() const { return m_value.GetPhoneNumber(); }
00131
00133         Date        GetDate() const { return m_value.GetDate(); }
00134
00136         Time        GetTime() const { return m_value.GetTime(); }
00137
00139         DateTime    GetDateTime() const { return m_value.GetDateTime(); }
00140
00142         BOOLEAN GetString(String & strdata) const { return m_value.GetString(strdata); }
00143
00145         BOOLEAN GetWString(WString & strdata) const { return m_value.GetWString(strdata); }
00146
00148         BOOLEAN GetPhoneNumber(PhoneNumber & bcdnr) const { return m_value.GetPhoneNumber(bcdnr); }
00149
00151         BOOLEAN GetDate(Date & date) const { return m_value.GetDate(date); }
00152
00154         BOOLEAN GetTime(Time & time) const { return m_value.GetTime(time); }
00155
00157         BOOLEAN GetDateTime(DateTime & date) const { return m_value.GetDateTime(date); }
00158
00160         GenericObject * GetGenericObject() const { return m_value.GetGenericObject(); }
00161
00163         const GenericObject * GetGenericObjectPtr() const { return m_value.GetGenericObjectPtr(); }
00164
00166         BOOLEAN GetBoolean() const { return m_value.GetBoolean(); }
00167
00169         void SetProvider(Provider * provider);
00170
00172         void SetNumber(const Number data);
00173
00175         void SetString(const String & strdata);
00176
00178         void SetString(const CHAR * strdata);
00179
00181         void SetWString(const WString & strdata);
00182
00184         void SetWString(const WCHAR * strdata);
00185
00187         void SetPhoneNumber(const PhoneNumber & bcdnr);
00188
00190         void SetDate(const Date & date);
00191
00193         void SetTime(const Time & time);
00194
00196         void SetDateTime(const DateTime & date);
00197
00199         void SetDateTime(const DateTime::Persist & date);
00200
00202         void SetGenericObject(const GenericObject * const genobject);
00203
00205         void SetBoolean(const BOOLEAN data);
00206
00209         BOOLEAN HasNotification(const Notification rule) const { return ((m_notification_rule & rule) == rule); }
00210
00214         virtual void GetAsWString(WString& text) const;
00215
00217         const PropertyDescriptor* GetDefaultDescriptor() const {return m_descriptor;}
00218
00220         void  SetDefaultDescriptor(PropertyDescriptor* descriptor) {m_descriptor = descriptor;}
00221
00222     protected:
00223         DataItem m_value;
00224         UINT8 m_notification_rule;
00225         PropertyDescriptor* m_descriptor;
00226
00227     private:
00228         Property(const Property& value);
00229 };
00230
00232 #endif  // Atl_Property_hpp
00233
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyDescriptor.cpp File Reference

Atl/Properties/PropertyDescriptor.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Auxiliary/ChildBinData.hpp>
#include <Gui/ImageFactory.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Atl/Properties/Property.hpp>
#include "PropertyDescriptor.hpp"

Include dependency graph for PropertyDescriptor.cpp:

Generated on Tue Jan 24 18:02:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyDescriptor.hpp File Reference

Atl/Properties/PropertyDescriptor.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Config/GuiObjectFactory.hpp>
#include <Atl/Context/ContextID.hpp>

Include dependency graph for PropertyDescriptor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class PropertyDescriptor

Generated on Tue Jan 24 18:02:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyDescriptor.hpp Source File

Atl/Properties/PropertyDescriptor.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #ifndef Atl_PropertyDescriptor_hpp
00011 #define Atl_PropertyDescriptor_hpp
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Auxiliary/DataItem.hpp>
00017
00018 #include <Gui/ImageObtainer.hpp>
00019 #include <Config/GuiObjectFactory.hpp>
00020
00021 #if defined(APOXI_COMPAT_2_7_0)
00022 #include <Gui/ResourceParser.hpp>
00023 #include <Atl/Properties/Property.hpp>
00024 #endif  // APOXI_COMPAT_2_7_0
00025
00026 #include <Atl/Context/ContextID.hpp>
00027
00028 class Property;
00029 class ResourceParser;
00030
00035 class PropertyDescriptor {
00036
00037     public:
00038         enum {
00039             ID = 1
00040         };
00041
00044         PropertyDescriptor();
00045
00047         PropertyDescriptor(const WString& title);
00048
00051         PropertyDescriptor(const WString& title, const WString& label);
00052
00055         PropertyDescriptor(const WCHAR* title, const WCHAR* label = 0);
00056
00061         PropertyDescriptor(const ContextID& context_id, const WString& label);
00062
00067         PropertyDescriptor(const CHAR* context_id, const WCHAR* label = 0);
00068
00070         virtual ~PropertyDescriptor();
00071
00073         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00074
00077         void Init(const WString& title, const WString& label);
00078
00081         void Init(const WCHAR* title, const WCHAR* label = 0);
00082
00087         void Init(const ContextID& context_id, const WString& label);
00088
00093         void Init(const CHAR* context_id, const WCHAR* label = 0);
00094
00097         virtual BOOLEAN IsInstanceOf(const INT id) const;
00098
00100         const WString& GetLabel() const { return m_label; }
00101
00103         const WString& GetTitle() const { return m_title; }
00104
00109         virtual WString GetText(const Property* property) const;
00110
00112         virtual WString GetText(const DataItem& item) const;
00113
00118         virtual ImageObtainer GetIcon(const Property* property) const;
00119
00121         virtual ImageObtainer GetIcon(const DataItem& item) const;
00122
00124         void SetLabel(const WString& label) { m_label = label; }
00125
00127         void SetTitle(const WString& title) { m_title = title; }
00128
00130         const ContextID& GetContextId() const { return m_context_id; }
00131
00132 #if defined(APOXI_COMPAT_2_6_0)
00133
00135         virtual void GetRepresentation(const Property* property, WString& representation) const;
00136
00139         virtual void GetRepresentation(const Property* property, ImageObtainer& icon) const;
00140 #endif
00141
00142     protected:
00143         WString m_title;
00144         WString m_label;
00145         ContextID m_context_id;
00146
00147 };
00148
00150 #endif  // Atl_PropertyDescriptor_hpp
00151
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyEditor.cpp File Reference

Atl/Properties/PropertyEditor.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Properties/PropertyDescriptor.hpp>
#include <Atl/Properties/PropertyItem.hpp>
#include <Config/KeyboardConfig.hpp>
#include "PropertyEditor.hpp"

Include dependency graph for PropertyEditor.cpp:

Generated on Tue Jan 24 18:02:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyEditor.hpp File Reference

Atl/Properties/PropertyEditor.hpp File Reference

#include <Atl/Properties/PropertyEditorID.hpp>
#include <Atl/Properties/Property.hpp>
#include <Atl/AtlWindow.hpp>

Include dependency graph for PropertyEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PropertyEditor
Interface for property editors. More...

Defines

#define | Atl_PropertyEditor_hpp

Define Documentation

#define Atl_PropertyEditor_hpp

Generated on Tue Jan 24 18:02:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyEditor.hpp Source File

Atl/Properties/PropertyEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_PropertyEditor_hpp)
00010 #define Atl_PropertyEditor_hpp
00013
00014 #include <Atl/Properties/PropertyEditorID.hpp>
00015 #include <Atl/Properties/Property.hpp>
00016 #include <Atl/AtlWindow.hpp>
00017
00018 #if defined(APOXI_COMPAT_2_7_0)
00019 #include <Atl/Properties/PropertyItem.hpp>
00020 #endif  // APOXI_COMPAT_2_7_0
00021
00022 class PropertyItem;
00024 class PropertyEditor: public AtlWindow {
00025     typedef AtlWindow Base;
00026
00027     public:
00029         PropertyEditor(const PropertyEditorID& id);
00030
00032         PropertyEditor(const PropertyEditorID& id,
00033                        ContextID& context);
00034
00036         virtual ~PropertyEditor();
00037
00039         const virtual PropertyEditorID& GetID() const {return m_editor_id;}
00040
00043         virtual BOOLEAN EditProperty(PropertyItem& item);
00044
00046         virtual void GetNewPropertyValue(DataItem& value) = 0;
00047
00048     protected:
00051         void    SetPropertyItem(PropertyItem& item) {m_property_item = &item;}
00052
00055         const PropertyItem* GetPropertyItem() {return m_property_item;}
00056
00059         void    SetDescriptor(const PropertyDescriptor* descriptor);
00060
00063         const PropertyDescriptor*   GetDescriptor() {return m_descriptor;}
00064
00066         virtual BOOLEAN CanEdit();
00067
00069         virtual void Init();
00070
00073         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00074
00078         BOOLEAN SendNotification(const Property::Notification notification, BOOLEAN new_data = TRUE);
00079
00081         virtual BOOLEAN OnCancel();
00082
00083     private:
00085         PropertyItem                *m_property_item;
00086         const PropertyDescriptor    *m_descriptor;
00087
00088         PropertyEditorID m_editor_id;
00089 };
00090
00092 #endif  // Atl_PropertyEditor_hpp
00093
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyEditorFactory.cpp File Reference

Atl/Properties/PropertyEditorFactory.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Config/AtlConfig.hpp>
#include <Atl/Properties/PropertyEditor.hpp>
#include <Atl/Properties/PropertyItem.hpp>
#include "PropertyEditorFactory.hpp"

Include dependency graph for PropertyEditorFactory.cpp:

Generated on Tue Jan 24 18:03:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyEditorFactory.hpp File Reference

Atl/Properties/PropertyEditorFactory.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PropertyEditorFactory
Singleton class for handling property editors. More...

Defines

#define | Atl_PropertyEditorFactory_hpp

Define Documentation

#define Atl_PropertyEditorFactory_hpp

Generated on Tue Jan 24 18:03:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyEditorFactory.hpp Source File

Atl/Properties/PropertyEditorFactory.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Atl_PropertyEditorFactory_hpp)
00011 #define Atl_PropertyEditorFactory_hpp
00014
00015 class PropertyItem;
00017 class PropertyEditorFactory {
00018     public:
00019
00021         static PropertyEditorFactory* GetInstance() { return &m_instance; }
00022
00024         virtual ~PropertyEditorFactory();
00025
00028         BOOLEAN Edit(PropertyItem* property);
00029
00030     private:
00031         PropertyEditorFactory() {};
00032
00033         static PropertyEditorFactory m_instance;
00034 };
00035
00037 #endif // Atl_PropertyEditorFactory_hpp
00038
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyEditorID.hpp File Reference

Atl/Properties/PropertyEditorID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for PropertyEditorID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | PropertyEditorID_hpp

Typedefs

typedef ResourceID | PropertyEditorID

Define Documentation

#define PropertyEditorID_hpp

Typedef Documentation

typedef ResourceID PropertyEditorID

Generated on Tue Jan 24 18:03:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyEditorID.hpp Source File

Atl/Properties/PropertyEditorID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(PropertyEditorID_hpp)
00011 #define PropertyEditorID_hpp
00012
00013
00014 #include <Atl/ResourceID.hpp>
00015
00016 typedef ResourceID PropertyEditorID;
00017
00018
00019 #endif
00020
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyID.hpp File Reference

Atl/Properties/PropertyID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for PropertyID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | PropertyID_hpp

Typedefs

typedef ResourceID | PropertyID

Define Documentation

#define PropertyID_hpp

Typedef Documentation

typedef ResourceID PropertyID

Generated on Tue Jan 24 18:03:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyID.hpp Source File

Atl/Properties/PropertyID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(PropertyID_hpp)
00011 #define PropertyID_hpp
00012
00013
00014 #include <Atl/ResourceID.hpp>
00015
00016
00017 typedef ResourceID PropertyID;
00018
00019
00020 #endif
00021
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyItem.cpp File Reference

Atl/Properties/PropertyItem.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Kernel/System.hpp>
#include <Atl/Properties/PropertyDescriptor.hpp>
#include <Atl/AtlApplication.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include "PropertyItem.hpp"

Include dependency graph for PropertyItem.cpp:

Generated on Tue Jan 24 18:03:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyItem.hpp File Reference

Atl/Properties/PropertyItem.hpp File Reference

#include <Atl/Features/FeatureItem.hpp>
#include <Atl/Properties/PropertyEditorID.hpp>

Include dependency graph for PropertyItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class PropertyItem
Encapsulates a property. The PropertyItem can be used for GUI controls. More...

Generated on Tue Jan 24 18:03:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/PropertyItem.hpp Source File

Atl/Properties/PropertyItem.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #ifndef Atl_PropertyItem_hpp
00011 #define Atl_PropertyItem_hpp
00014
00015 #include <Atl/Features/FeatureItem.hpp>
00016 #include <Atl/Properties/PropertyEditorID.hpp>
00017
00018 #if defined(APOXI_COMPAT_2_7_0)
00019 #include <Atl/Properties/PropertyID.hpp>
00020 #include <Atl/Properties/PropertyDescriptor.hpp>
00021 #endif  // APOXI_COMPAT_2_7_0
00022
00023
00024 class PropertyDescriptor;
00025 class AtlApplication;
00026
00028 class PropertyItem : public FeatureItem {
00029     typedef FeatureItem Base;
00030
00031     public:
00032
00033         enum {
00034             ID = 104
00035         };
00036
00038         PropertyItem();
00039
00041         PropertyItem(Property* property,
00042                     const WString& text = "",
00043                     const ImageObtainer& icon = ImageObtainer());
00044
00046         virtual ~PropertyItem();
00047
00049         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00050
00052         void Init(Property* property,
00053                     const WString& text = "",
00054                     const ImageObtainer& icon = ImageObtainer());
00055
00057         virtual BOOLEAN IsInstanceOf(INT id) const;
00058
00060         void SetPropertyEditorID(const PropertyEditorID& id);
00061
00063         const PropertyEditorID& GetPropertyEditorID() const;
00064
00067         virtual BOOLEAN Execute();
00068
00070         void SetDescriptor(PropertyDescriptor* descriptor);
00071
00073         const PropertyDescriptor* GetDescriptor() const;
00074
00076         virtual void Update();
00077
00078     private:
00079         PropertyItem(const PropertyItem&) {};
00080
00081         PropertyEditorID m_editor;
00082         const PropertyDescriptor* m_descriptor;
00083         BOOLEAN m_item_icon_configured;
00084 };
00085
00087 #endif  // Atl_PropertyItem_hpp
00088
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/SubstitutedText.cpp File Reference

Atl/Properties/SubstitutedText.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Atl/Properties/Property.hpp>
#include <Atl/Properties/PropertyItem.hpp>
#include <Atl/Properties/PropertyDescriptor.hpp>
#include <Atl/Features/FeatureItem.hpp>
#include <Atl/IdentifierHandler.hpp>
#include "SubstitutedText.hpp"

Include dependency graph for SubstitutedText.cpp:

Generated on Tue Jan 24 18:03:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/SubstitutedText.hpp File Reference

Atl/Properties/SubstitutedText.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class SubstitutedText

Generated on Tue Jan 24 18:03:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/SubstitutedText.hpp Source File

Atl/Properties/SubstitutedText.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010
00011 #ifndef Atl_SubstitutedText_hpp
00012 #define Atl_SubstitutedText_hpp
00015
00016
00017 class FeatureItem;
00018 class Property;
00019
00021 class SubstitutedText{
00022     public:
00023         SubstitutedText();
00024
00026         void Init(const WString& pattern,
00027                   const FeatureItem* item);
00028
00030         void SetText(const WString& pattern);
00031
00033         const WString& GetText() const;
00034
00036         WString GetSubstitutedText() const;
00037
00039         static BOOLEAN IsSubstitutionNeeded(const WString& pattern_text);
00041         BOOLEAN ContainsProperty(Property* property) const;
00042
00043     private:
00045         void Update(WString& subst_text) const;
00047         WString GetValue(const WString& identifier) const;
00048
00049         WString     m_original_text;
00050         const FeatureItem*  m_feature_item;
00051
00052 };
00053
00055 #endif  // Atl_SubstitutedText_hpp
00056
00057
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/TextIconPairArray.cpp File Reference

Atl/Properties/TextIconPairArray.cpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/ImageObtainer.hpp>
#include "TextIconPairArray.hpp"

Include dependency graph for TextIconPairArray.cpp:

Generated on Tue Jan 24 18:05:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/TextIconPairArray.hpp File Reference

Atl/Properties/TextIconPairArray.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextIconPairArray
class | TextIconPairArray::TextIconPair

Defines

#define | Apoxi_TextIconPairArray_hpp

Define Documentation

#define Apoxi_TextIconPairArray_hpp

Generated on Tue Jan 24 18:05:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/TextIconPairArray.hpp Source File

Atl/Properties/TextIconPairArray.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TextIconPairArray_hpp)
00011 #define Apoxi_TextIconPairArray_hpp
00014
00015 class ImageObtainer;
00016
00019 class TextIconPairArray {
00020     public:
00021         class TextIconPair {
00022             public:
00023                 const WCHAR* GetText() const { return m_text; }
00024                 ImageObtainer GetIcon() const;
00025                 const WCHAR*        m_text;
00026                 const BitmapRes*    m_icon;
00027         };
00028
00030         TextIconPairArray();
00031
00034         TextIconPairArray(const TextIconPair* pair, INT size);
00035
00037         virtual ~TextIconPairArray();
00038
00042         virtual void Init(const TextIconPair* pair, INT size);
00043
00047         void SetTextIconPair(const TextIconPair* pair, INT size);
00048
00052         const TextIconPair* operator[](INT index) const {
00053             ASSERT_DEBUG(index >= 0 && index < GetSize());
00054             return (&m_pair[index]);
00055         }
00056
00058         INT GetSize() const { return m_size; }
00059
00063         void PushBack(TextIconPair pair) {}
00064
00068         void PopBack() {}
00069
00070     private:
00071         const TextIconPair *m_pair;
00072         INT m_size;
00073 };
00074 #endif  // Apoxi_TextIconPairArray_hpp
00075
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/ValueMappingPropertyDescriptor.hpp File Reference

Atl/Properties/ValueMappingPropertyDescriptor.hpp File Reference

#include <Atl/AtlPreComp.hpp>
#include <Gui/GuiObjectIterator.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Atl/Properties/MappingPolicy.hpp>
#include <Atl/Properties/ListPropertyDescriptor.hpp>
#include <Atl/Properties/TextIconPairArray.hpp>
#include <Atl/Properties/Property.hpp>

Include dependency graph for ValueMappingPropertyDescriptor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ValueMappingPropertyDescriptor< T_Container >

Defines

#define | Apoxi_ValueMappingPropertyDescriptor_hpp

Typedefs

typedef ValueMappingPropertyDescriptor<
TextIconPairArray > 		StaticValueMappingPropertyDescriptor

Define Documentation

#define Apoxi_ValueMappingPropertyDescriptor_hpp

Generated on Tue Jan 24 18:05:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Atl/Properties/ValueMappingPropertyDescriptor.hpp Source File

Atl/Properties/ValueMappingPropertyDescriptor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003 ------------------------------------------------------------------------
00004 This document contains proprietary information belonging to COMNEON.
00005 Passing on and copying of this document, use and communication of its
00006 contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ValueMappingPropertyDescriptor_hpp)
00010 #define Apoxi_ValueMappingPropertyDescriptor_hpp
00013
00014 #include <Atl/AtlPreComp.hpp>
00015
00016 #include <Gui/GuiObjectIterator.hpp>
00017 #include <Gui/ImageObtainer.hpp>
00018 #include <Atl/Properties/MappingPolicy.hpp>
00019 #include <Atl/Properties/ListPropertyDescriptor.hpp>
00020 #include <Atl/Properties/TextIconPairArray.hpp>
00021 #include <Atl/Properties/Property.hpp>
00022
00023 #ifdef APOXI_ARAGON_SUPPORT
00024     #include <AddOns/MultiMedia/ImageFactory.hpp>   // Aragon requires the addon MultiMedia
00025     #include <Gui/ResourceManager.hpp>
00026 #endif
00027
00032 template<class T_Container> class ValueMappingPropertyDescriptor : public ListPropertyDescriptor {
00033     typedef ListPropertyDescriptor Base;
00034
00035     public:
00036         enum {
00037             ID = 3
00038         };
00039
00043         ValueMappingPropertyDescriptor() : m_dyn_policy(FALSE) { }
00044
00052         ValueMappingPropertyDescriptor(const T_Container& pairs,
00053                                        const MappingPolicy* policy = 0,
00054                                        const CHAR* context_id = 0);
00055
00062         ValueMappingPropertyDescriptor(const WCHAR* title,
00063                                        const T_Container& pairs,
00064                                        const MappingPolicy* policy = 0);
00065
00072         ValueMappingPropertyDescriptor(const WString& title,
00073                                        const T_Container& pairs,
00074                                        const MappingPolicy* policy = 0);
00075
00077         virtual ~ValueMappingPropertyDescriptor();
00078
00085         virtual void Init(const T_Container& pairs,
00086                           const MappingPolicy* policy = 0,
00087                           const CHAR* context_id = 0);
00088
00096         virtual void Init(const WCHAR* title,
00097                           const T_Container& pairs,
00098                           const MappingPolicy* policy = 0);
00099
00107         virtual void Init(const WString& title,
00108                           const T_Container& pairs,
00109                           const MappingPolicy* policy = 0);
00110
00115         virtual BOOLEAN IsInstanceOf(const INT id) const;
00116
00118         INT GetTextCount() const { return m_text_icon_pairs.GetSize(); }
00119
00125         const MappingPolicy* GetMappingPolicy() const { return m_policy; }
00126
00131         BOOLEAN SetProperty(ResourceParser& parser, GuiObjectFactory::PropertyId property_id);
00132
00135         virtual ImageObtainer GetIcon(const Property* property) const;
00136
00138         virtual ImageObtainer GetIcon(const DataItem& value) const;
00139
00143         virtual ImageObtainer GetIcon(INT index) const;
00144
00147         virtual WString GetText(const Property* property) const;
00148
00150         virtual WString GetText(const DataItem& value) const;
00151
00155         virtual WString GetText(INT index) const;
00156
00161         virtual DataItem GetValue(INT index) const;
00162
00166         virtual INT GetItemCount() const { return m_text_icon_pairs.GetSize(); }
00167
00168     private:
00169         T_Container m_text_icon_pairs;
00170         const MappingPolicy* m_policy;
00171         BOOLEAN m_dyn_policy;
00172 };
00173
00174
00175 /*  ------------------------------------------------------------------------
00176     ValueMappingPropertyDescriptor
00177     ------------------------------------------------------------------------ */
00178 template<class T_Container> ValueMappingPropertyDescriptor<T_Container>::
00179 	ValueMappingPropertyDescriptor(const T_Container& pairs,
00180                                const MappingPolicy* policy,
00181                                const CHAR* context_id):
00182     m_dyn_policy(FALSE)
00183 {
00184     Init(pairs, policy, context_id);
00185 }
00186
00187 /*  ------------------------------------------------------------------------
00188     ValueMappingPropertyDescriptor
00189 ------------------------------------------------------------------------ */
00190 template<class T_Container> ValueMappingPropertyDescriptor<T_Container>::
00191 	ValueMappingPropertyDescriptor(const WCHAR* title,
00192                                 const T_Container& pairs,
00193                                 const MappingPolicy* policy):
00194     m_dyn_policy(FALSE)
00195 {
00196     Init(title, pairs, policy);
00197 }
00198
00199 /*  ------------------------------------------------------------------------
00200     ValueMappingPropertyDescriptor
00201     ------------------------------------------------------------------------ */
00202 template<class T_Container> ValueMappingPropertyDescriptor<T_Container>::
00203 	ValueMappingPropertyDescriptor(const WString& title,
00204                                    const T_Container& pairs,
00205                                    const MappingPolicy* policy):
00206     m_dyn_policy(FALSE)
00207 {
00208     Init(title, pairs, policy);
00209 }
00210
00211 /*  ------------------------------------------------------------------------
00212     ~ValueMappingPropertyDescriptor
00213     ------------------------------------------------------------------------ */
00214 template<class T_Container> ValueMappingPropertyDescriptor<T_Container>::
00215 	~ValueMappingPropertyDescriptor()
00216 {
00217     if (m_dyn_policy) {
00218         delete m_policy;
00219     }
00220     m_policy = 0;
00221 }
00222
00223 /*  ------------------------------------------------------------------------
00224     Init
00225     ------------------------------------------------------------------------ */
00226 template<class T_Container> void ValueMappingPropertyDescriptor<T_Container>::
00227 	Init(const T_Container& pairs, const MappingPolicy* policy, const CHAR* context_id)
00228 {
00229     m_text_icon_pairs = pairs;
00230
00231     if (policy == 0) {
00232         m_policy = new MappingPolicy();
00233         m_dyn_policy = TRUE;
00234     }
00235     else {
00236         m_policy = policy;
00237     }
00238     if (context_id != 0) {
00239         Base::Init(context_id);
00240     }
00241 }
00242
00243 /*  ------------------------------------------------------------------------
00244     Init
00245     ------------------------------------------------------------------------ */
00246 template<class T_Container> void ValueMappingPropertyDescriptor<T_Container>::
00247 	Init(const WCHAR* title, const T_Container& pairs, const MappingPolicy* policy)
00248 {
00249     Init(pairs, policy);
00250     SetTitle(title);
00251 }
00252
00253 /*  ------------------------------------------------------------------------
00254     Init
00255     ------------------------------------------------------------------------ */
00256 template<class T_Container> void ValueMappingPropertyDescriptor<T_Container>::
00257 	Init(const WString& title, const T_Container& pairs, const MappingPolicy* policy)
00258 {
00259     Init(pairs, policy);
00260     SetTitle(title);
00261 }
00262
00263 /*  ------------------------------------------------------------------------
00264     IsInstanceOf
00265     ------------------------------------------------------------------------ */
00266 template<class T_Container> BOOLEAN ValueMappingPropertyDescriptor<T_Container>::
00267 	IsInstanceOf(const INT id) const
00268 {
00269     return ValueMappingPropertyDescriptor::ID == id || Base::IsInstanceOf(id);
00270 }   // IsInstanceOf
00271
00272 /*  ------------------------------------------------------------------------
00273     SetProperty
00274     ------------------------------------------------------------------------ */
00275 template<class T_Container> BOOLEAN ValueMappingPropertyDescriptor<T_Container>::
00276 SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId property_id)
00277 {
00278 #ifdef APOXI_ARAGON_SUPPORT
00279     BOOLEAN success = FALSE;
00280
00281     switch (property_id) {
00282         case GuiObjectFactory::TextIconPairProp: {
00283             INT count = 0;
00284             success = parser.GetPropertyValue(GuiObjectFactory::TextIconPairCountProp, (void*) &count);
00285             if (success) {
00286                 GuiObjectFactory::ParseType parse_type = GuiObjectFactory::MapPropertyIdToParseType(property_id);
00287                 if (parse_type == GuiObjectFactory::TextIconPairType) {
00288                     WString text;
00289                     WString image_uri;
00290                     Image* img;
00291                     for (INT i = 0; i < count; i++) {
00292                         img = 0;
00293                         text = parser.ReadWString();
00294                         image_uri = parser.ReadWString();
00295                         if (!image_uri.IsEmpty()) {
00296                             ChildBinData* data = ResourceManager::GetInstance().GetData(image_uri, parser.GetResourceUri());
00297                             if (data != 0) {
00298                                 img = ImageFactory::CreateImage(data, &success);
00299                             }
00300                         }
00301                         if (text.IsEmpty() && img == 0) {
00302                             DBG_OUT((35700, "ValueMappingPropertyDescriptor::SetProperty: No text and no icon defined a value.\n"));
00303                         }
00304                         Item* item = new Item(0, text, ImageObtainer(img));
00305                         if (item != 0) {
00306                             m_text_icon_pairs.PushBack(item);
00307                         }
00308                     }
00309                     success = m_text_icon_pairs.GetSize() > 0;
00310                 }
00311             }
00312             break;
00313         }
00314         case GuiObjectFactory::MappingPolicyProp: {
00315             GuiObjectIterator iterator(parser);
00316             if (iterator.HasNext()) {
00317                 m_policy = (MappingPolicy*) GuiObjectFactory::Create(parser, iterator.GetNext());
00318                 success = m_policy != 0;
00319             }
00320             break;
00321         }
00322         case GuiObjectFactory::ItemProp: {
00323             GuiObjectIterator item_it(parser);
00324             while (item_it.HasNext()) {
00325                 Item* item = (Item*) GuiObjectFactory::Create(parser, item_it.GetNext());
00326                 if (item != 0)
00327                     m_text_icon_pairs.PushBack(item);
00328             }
00329             item_it.Release();
00330             break;
00331         }
00332         default: {
00333             success = Base::SetProperty(parser, property_id);
00334             break;
00335         }
00336     }
00337     return success;
00338 #else //APOXI_ARAGON_SUPPORT
00339     return FALSE;
00340 #endif //APOXI_ARAGON_SUPPORT
00341 }   // SetProperty
00342
00343 /*  ------------------------------------------------------------------------
00344     GetIcon
00345     ------------------------------------------------------------------------ */
00346 template<class T_Container> ImageObtainer ValueMappingPropertyDescriptor<T_Container>::
00347 	GetIcon(const Property* property) const {
00348     ImageObtainer icon;
00349     if (property != 0) {
00350         if (property->IsInstanceOf(Property::ID)) {
00351             ASSERT_DEBUG(property->GetDataItem().GetDataType() == BooleanType ||
00352                 property->GetDataItem().GetDataType() == NumberType);
00353             ASSERT_DEBUG(m_policy != 0);
00354             INT size = m_text_icon_pairs.GetSize();
00355             if (size > 0) {
00356                 INT idx = m_policy->GetIndex(property->GetDataItem());
00357                 if (idx >= 0 && idx < size && m_text_icon_pairs[idx] != 0) {
00358                     icon = m_text_icon_pairs[idx]->GetIcon();
00359                 }
00360             }
00361         }
00362     }
00363     return icon;
00364 }   // GetIcon
00365
00366 /*  ------------------------------------------------------------------------
00367     GetIcon
00368     ------------------------------------------------------------------------ */
00369 template<class T_Container> ImageObtainer ValueMappingPropertyDescriptor<T_Container>::
00370 	GetIcon(const DataItem& value) const {
00371     DBG_OUT((5003, L"Obsolete - Please retrieve the icon with the property.\n"));
00372     ImageObtainer icon;
00373     ASSERT_DEBUG(m_policy != 0);
00374     INT size = m_text_icon_pairs.GetSize();
00375     if (size > 0) {
00376         INT idx = m_policy->GetIndex(value);
00377         if (idx >= 0 && idx < size && m_text_icon_pairs[idx] != 0) {
00378             icon = m_text_icon_pairs[idx]->GetIcon();
00379         }
00380     }
00381     return icon;
00382 }   // GetIcon
00383
00384 /*  ------------------------------------------------------------------------
00385     GetIcon
00386     ------------------------------------------------------------------------ */
00387 template<class T_Container> ImageObtainer ValueMappingPropertyDescriptor<T_Container>::
00388 	GetIcon(INT index) const {
00389     ImageObtainer icon;
00390     if (index < m_text_icon_pairs.GetSize()) {
00391         m_text_icon_pairs[index]->GetIcon();
00392     }
00393     return icon;
00394 }   // GetIcon
00395
00396 /*  ------------------------------------------------------------------------
00397     GetText
00398     ------------------------------------------------------------------------ */
00399 template<class T_Container> WString ValueMappingPropertyDescriptor<T_Container>::
00400 	GetText(const Property* property) const {
00401     WString text;
00402     if (property != 0) {
00403         if (property->IsInstanceOf(Property::ID)) {
00404             ASSERT_DEBUG(property->GetDataItem().GetDataType() == BooleanType ||
00405                 property->GetDataItem().GetDataType() == NumberType);
00406             ASSERT_DEBUG(m_policy != 0);
00407             INT size = m_text_icon_pairs.GetSize();
00408             if (size > 0) {
00409                 INT idx = m_policy->GetIndex(property->GetDataItem());
00410                 if (idx >= 0 && idx < size && m_text_icon_pairs[idx] != 0) {
00411                     text = m_text_icon_pairs[idx]->GetText();
00412                 }
00413             }
00414         }
00415     }
00416     return text;
00417 }   // GetText
00418
00419 /*  ------------------------------------------------------------------------
00420     GetText
00421     ------------------------------------------------------------------------ */
00422 template<class T_Container> WString ValueMappingPropertyDescriptor<T_Container>::
00423 	GetText(const DataItem& value) const {
00424     DBG_OUT((5003, L"Obsolete - Please retrieve the text with the property.\n"));
00425     WString text;
00426     ASSERT_DEBUG(m_policy != 0);
00427     INT size = m_text_icon_pairs.GetSize();
00428     if (size > 0) {
00429         INT idx = m_policy->GetIndex(value);
00430         if (idx >= 0 && idx < size && m_text_icon_pairs[idx] != 0) {
00431             text = m_text_icon_pairs[idx]->GetText();
00432         }
00433     }
00434     return text;
00435 }   // GetText
00436
00437 /*  ------------------------------------------------------------------------
00438     GetText
00439     ------------------------------------------------------------------------ */
00440 template<class T_Container> WString ValueMappingPropertyDescriptor<T_Container>::
00441 	GetText(INT index) const {
00442     WString text;
00443     if (index < m_text_icon_pairs.GetSize()) {
00444         text = m_text_icon_pairs[index]->GetText();
00445     }
00446     return text;
00447 }   // GetText
00448
00449 /*  ------------------------------------------------------------------------
00450     GetValue
00451     ------------------------------------------------------------------------ */
00452 template<class T_Container> DataItem ValueMappingPropertyDescriptor<T_Container>::
00453 	GetValue(INT index) const
00454 {
00455     ASSERT_DEBUG(m_policy != 0);
00456     return m_policy->GetValue(index);
00457 }   // GetValue
00458
00459 #ifdef APOXI_ARAGON_SUPPORT
00460 typedef ValueMappingPropertyDescriptor< Vector<Item*> > DynamicValueMappingPropertyDescriptor;
00461
00462 #endif  // APOXI_ARAGON_SUPPORT
00463 typedef ValueMappingPropertyDescriptor<TextIconPairArray> StaticValueMappingPropertyDescriptor;
00464
00465 #endif  // Apoxi_ValueMappingPropertyDescriptor_hpp
00466
00467
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/audio_private.cpp File Reference

Audio/audio_private.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/audio_private.hpp>

Include dependency graph for audio_private.cpp:

Functions

Mutex & AudioGetMutex ()
UINT32 | native2percent (UINT32 vol_native, UINT32 volMin, UINT32 volMax)
UINT32 | percent2native (UINT32 vol, UINT32 volMin, UINT32 volMax)

Variables

Mutex g_AudioMutex

Function Documentation

Mutex& AudioGetMutex ( )

UINT32 native2percent | ( | UINT32 | vol_native,
 |  | UINT32 | volMin,
 |  | UINT32 | volMax
 | ) |

Transforms the given 'native' volume into the corresponding percent value.

Parameters:
vol | Volume in 'native' units
volMin | minimum 'native' volume value
volMax | maximum 'native' volume value
Returns:
percent volume value or 0 if volume setting is not supported.

UINT32 percent2native | ( | UINT32 | vol,
 |  | UINT32 | volMin,
 |  | UINT32 | volMax
 | ) |

Transforms the given percent volume into the corresponding 'native' value

Parameters:
vol | Volume in percent
volMin | minimum 'native' volume value
volMax | maximum 'native' volume value
Returns:
'native' volume value

Variable Documentation

Mutex g_AudioMutex

Generated on Tue Jan 24 18:06:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/audio_private.hpp File Reference

Audio/audio_private.hpp File Reference

#include <Devices/Win32/aud_drv.h>

Include dependency graph for audio_private.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_AudioPrivate_hpp
#define | APOXI_RINGER_DEVICE_PRESENT

Functions

Mutex & AudioGetMutex ()
UINT32 | native2percent (UINT32 vol_native, UINT32 volMin, UINT32 volMax)
UINT32 | percent2native (UINT32 vol, UINT32 volMin, UINT32 volMax)

Define Documentation

#define Apoxi_AudioPrivate_hpp

#define APOXI_RINGER_DEVICE_PRESENT

Function Documentation

Mutex& AudioGetMutex ( )

UINT32 native2percent | ( | UINT32 | vol_native,
 |  | UINT32 | volMin,
 |  | UINT32 | volMax
 | ) |

Transforms the given 'native' volume into the corresponding percent value.

Parameters:
vol | Volume in 'native' units
volMin | minimum 'native' volume value
volMax | maximum 'native' volume value
Returns:
percent volume value or 0 if volume setting is not supported.

UINT32 percent2native | ( | UINT32 | vol,
 |  | UINT32 | volMin,
 |  | UINT32 | volMax
 | ) |

Transforms the given percent volume into the corresponding 'native' value

Parameters:
vol | Volume in percent
volMin | minimum 'native' volume value
volMax | maximum 'native' volume value
Returns:
'native' volume value

Generated on Tue Jan 24 18:06:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/audio_private.hpp Source File

Audio/audio_private.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioPrivate_hpp)
00011 #define Apoxi_AudioPrivate_hpp
00012
00013
00014 // xxx
00017 //#define huge
00018 //#define RINGER_PRESENT 1; //ifdef used in aud_drv.h
00019 #if defined(APOXI_RTOS_WIN32)
00020 #include <Devices/Win32/aud_drv.h>
00021 #else
00022 // xxx
00023 //#include <stack/driver.h>
00024 #endif
00025
00026 class Mutex;
00027
00028 // xxx
00029 #if !defined(SGOLD) && !defined(SGOLDLITE)
00030 //This is a temporary workaround. In future DWD expect to provide a version of aud_drv.h for SGOLD that declares the ringer functions.
00031 #define APOXI_RINGER_DEVICE_PRESENT
00032 #endif
00033
00034
00035 Mutex& AudioGetMutex();
00036
00037 UINT32 percent2native(UINT32 vol, UINT32 volMin, UINT32 volMax);
00038 UINT32 native2percent(UINT32 vol_native, UINT32 volMin, UINT32 volMax);
00039
00040 #endif  // Apoxi_AudioPrivate_hpp
00041
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioAccessoryDetails.cpp File Reference

Audio/AudioAccessoryDetails.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioAccessoryDetails.hpp>
#include <Audio/audio_private.hpp>
#include <Asc/Types.hpp>
#include <Asc/TtyInterface.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioAccessoryStore.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/Messages/AudioMessages.hpp>

Include dependency graph for AudioAccessoryDetails.cpp:

Generated on Tue Jan 24 18:06:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioAccessoryDetails.hpp File Reference

Audio/AudioAccessoryDetails.hpp File Reference

#include <Audio/AudioPlayer.hpp>
#include <Audio/AudioDeviceBase.hpp>
#include <Audio/AudioPath.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for AudioAccessoryDetails.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioAccessoryDetails

Defines

#define | Apoxi_AudioNewAPI_AudioAccessoryDetails_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AudioAccessoryDetails_hpp

Generated on Tue Jan 24 18:06:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioAccessoryDetails.hpp Source File

Audio/AudioAccessoryDetails.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioAccessoryDetails_hpp)
00011 #define Apoxi_AudioNewAPI_AudioAccessoryDetails_hpp
00014
00015 #include <Audio/AudioPlayer.hpp>
00016 #include <Audio/AudioDeviceBase.hpp>
00017 #include <Audio/AudioPath.hpp>
00018 #include <Auxiliary/WString.hpp>
00019
00020
00061 class AudioAccessoryDetails : public Linkable<AudioAccessoryDetails>
00062 {
00063     public:
00064
00066         enum AudioAccessoryConfigurationType
00067         {
00071             AudioAccessoryCfgNormal = 0x1,
00073             AudioAccessoryCfgHeadset = 0x2,
00075             AudioAccessoryCfgStereoPhones = 0x4,
00079             AudioAccessoryCfgBackspeaker_NormalMic = 0x8,
00081             AudioAccessoryCfgBluetoothHeadset = 0x10,
00083             AudioAccessoryCfgBluetoothHandsfree = 0x20,
00085             AudioAccessoryCfgTTY = 0x40,
00087             AudioAccessoryCfgCarKit = 0x80,
00089             AudioAccessoryCfgBluetoothHeadsetRinger = 0x100,
00091             AudioAccessoryCfgExtRingerHeadset = 0x200,
00093             AudioAccessoryCfgExtRingerStereoPhones = 0x400,
00095             AudioAccessoryCfgExtRingerBackspeaker = 0x800,
00098             AudioAccessoryCfgRecordingNormal  = 0x1000,
00101             AudioAccessoryCfgRecordingBackspeaker  = 0x2000,
00103             AudioAccessoryCfgUserDefined1  = 0x4000,
00104             AudioAccessoryCfgUserDefined2  = 0x8000,
00105             AudioAccessoryCfgUserDefined3  = 0x10000,
00106             AudioAccessoryCfgUserDefined4  = 0x20000,
00107             AudioAccessoryCfgUserDefined5  = 0x40000,
00108             AudioAccessoryCfgUserDefined6  = 0x80000,
00109             AudioAccessoryCfgUserDefined7  = 0x100000,
00110             AudioAccessoryCfgUserDefined8  = 0x200000,
00111             AudioAccessoryCfgUserDefined9  = 0x400000,
00112             AudioAccessoryCfgUserDefined11 = 0x800000,
00113             AudioAccessoryCfgUserDefined12 = 0x1000000,
00114             AudioAccessoryCfgUserDefined13 = 0x2000000,
00115             AudioAccessoryCfgUserDefined14 = 0x4000000,
00116             AudioAccessoryCfgUserDefined15 = 0x8000000,
00117             AudioAccessoryCfgUserDefined16 = 0x10000000,
00118             AudioAccessoryCfgUserDefined17 = 0x20000000,
00119             AudioAccessoryCfgUserDefined18 = 0x40000000,
00120             AudioAccessoryCfgUserDefined19 = 0x80000000,
00121             CompatibleWithEverything = 0xFFFFFFFF
00122         };
00123
00134         AudioAccessoryDetails(const AudioAccessoryConfigurationType configuration,
00135                         const AudioPath& uplink,
00136                         const AudioPath& downlink,
00137                         BOOLEAN active,
00138                         const UINT compat_setting,
00139                         const WString &type_name,
00140                         const WString &actual_name = "");
00141
00143         AudioAccessoryDetails::AudioAccessoryConfigurationType GetConfigurationType() const;
00144
00145
00147         AudioPath& GetUplinkPath() const;
00148
00150         AudioPath& GetDownlinkPath() const;
00151
00153         UINT GetCompatibilitySettings() const;
00154
00156         WString GetName() const;
00157
00159         void SetActualName(const WString &actual_name);
00160
00162         WString GetActualName() const;
00163
00171         void SetConnected(BOOLEAN connected, BOOLEAN update_path = TRUE);
00172         BOOLEAN GetConnected() const;
00173         void SetConnectedOld(BOOLEAN connected, BOOLEAN update_path = TRUE, AudioDeviceBase::AudioSourceType audio_source = AudioDeviceBase::DspAudioSource);
00174
00175         typedef UINT32 ConnectedAccessoriesType;
00176         static ConnectedAccessoriesType GetConnectedAccessories();
00177
00178
00180         BOOLEAN IsActive() const;
00181
00183         virtual void SetVolume(AudioDeviceBase::VolumeLevel val);
00184
00186         virtual AudioDeviceBase::VolumeLevel GetVolume() const;
00187
00191         virtual void TurnVolume(BOOLEAN turn_up);
00192
00197         void UpdateConfiguration();
00198
00203         BOOLEAN GetUpdatePath() const;
00204
00212         BOOLEAN CanActivateAudioPaths() const;
00213
00216         void EnableEcNr(BOOLEAN ecnr) {
00217             m_enable_ecnr = ecnr;
00218         }
00219
00222         BOOLEAN IsEcNrActive() {
00223             return m_enable_ecnr;
00224         }
00225
00226 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00227
00229         BOOLEAN GetActivePathStatus();
00230
00233         void SetActivePathStatus(BOOLEAN status);
00234
00241         virtual void OnAudioPathConnected(BOOLEAN connected, BOOLEAN update_path);
00242
00243         void SetSelected(BOOLEAN selected);
00244 #endif
00245 protected:
00246
00247         WString m_type_name, m_actual_name;
00248         AudioAccessoryConfigurationType m_accessory_id;
00249         BOOLEAN m_active;//Indicates if the accessory is connected
00250         BOOLEAN m_paths_active;//Indicates if the accessory paths are connected
00251         AudioPath m_uplinkPath;
00252         AudioPath m_downlinkPath;
00253         UINT m_compat_setting; // AudioAccessoryConfigurationType's that can work in parallel with this one
00254         BOOLEAN m_update_path; // indicates that for this accessory the audio paths have to be updated once the AudioPathManager::UpdateAudioPaths() is called
00255         BOOLEAN m_enable_ecnr; // flag to indicate if echo cancelation/noise reduction should be enabled for this accessory
00256
00257 private:
00258         static ConnectedAccessoriesType m_connected_accessories;
00259         BOOLEAN m_is_selected;
00260 };
00261
00263 #endif  // Apoxi_AudioNewAPI_AudioAccessoryDetails_hpp
00264
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioAccessoryStore.cpp File Reference

Audio/AudioAccessoryStore.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioAccessoryStore.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for AudioAccessoryStore.cpp:

Generated on Tue Jan 24 18:06:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioAccessoryStore.hpp File Reference

Audio/AudioAccessoryStore.hpp File Reference

#include <Audio/AudioAccessoryDetails.hpp>

Include dependency graph for AudioAccessoryStore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioAccessoryStore

Defines

#define | Apoxi_AudioAccessoryStore_hpp

Define Documentation

#define Apoxi_AudioAccessoryStore_hpp

Generated on Tue Jan 24 18:06:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioAccessoryStore.hpp Source File

Audio/AudioAccessoryStore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioAccessoryStore_hpp)
00011 #define Apoxi_AudioAccessoryStore_hpp
00014
00015 #include <Audio/AudioAccessoryDetails.hpp>
00016
00021 class AudioAccessoryStore
00022 {
00023     protected:
00024         AudioAccessoryStore();
00025
00026     public:
00027         virtual ~AudioAccessoryStore(); //This should be private, but an MSVC++ bug prevents that.
00028
00029         // override
00030         virtual const WCHAR* GetName() const;
00031
00032         static AudioAccessoryStore* GetInstance();
00033
00035         typedef LinkedList<AudioAccessoryDetails> AccessoryList;
00036         const AccessoryList& GetAccessoryList() const;
00037
00041         void AddItem(const AudioAccessoryDetails::AudioAccessoryConfigurationType configuration,
00042                     const AudioPath::UplinkPathType uplinkPath,
00043                     const AudioPath::DownlinkPathType downlinkPath,
00044                     BOOLEAN active,
00045                     const UINT compat_setting,
00046                     const WString &type_name,
00047                     const WString &actual_name = "");
00048
00049
00058         BOOLEAN UseAccessory (AudioAccessoryDetails *accessory);
00059
00061         const AudioAccessoryDetails* GetActiveAccessory_HighestPriority() const;
00062
00065         AudioAccessoryDetails* GetAccessoryByName(const WString &accessory_type_name, const WString &accessory_actual_name = "") const;
00066
00069         AudioAccessoryDetails* GetAccessoryByCfgType(const AudioAccessoryDetails::AudioAccessoryConfigurationType configuration) const;
00070
00071     protected:
00072         AccessoryList m_accessory_list;
00073         static AudioAccessoryStore m_instance;
00074
00075 };
00076
00078 #endif  // Apoxi_AudioAccessoryStore_hpp
00079
00080
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioActiveReference.cpp File Reference

Audio/AudioActiveReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioActiveReference.hpp>
#include <Audio/AudioDeviceBase.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioPlayer.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/Messages/AudioStoppedMsg.hpp>

Include dependency graph for AudioActiveReference.cpp:

Generated on Tue Jan 24 18:06:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioActiveReference.hpp File Reference

Audio/AudioActiveReference.hpp File Reference

#include <Audio/AudioReference.hpp>
#include <Auxiliary/ObjectReferrer.hpp>
#include <Kernel/Timer.hpp>

Include dependency graph for AudioActiveReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioActiveReference

Defines

#define | Apoxi_AudioActiveReference_hpp

Define Documentation

#define Apoxi_AudioActiveReference_hpp

Generated on Tue Jan 24 18:06:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioActiveReference.hpp Source File

Audio/AudioActiveReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioActiveReference_hpp)
00011 #define Apoxi_AudioActiveReference_hpp
00014
00015 #include <Audio/AudioReference.hpp>
00016 #include <Auxiliary/ObjectReferrer.hpp> //For ReferableObject
00017 #include <Kernel/Timer.hpp>
00018
00019 class AudioDeviceBase;
00020
00023 class AudioActiveReference : public ReferableObject, private Timer
00024 {
00025 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00026     protected:
00027         AudioActiveReference();
00028 #endif //DOXYGEN_SHOULD_SKIP_THIS
00029     public:
00030         virtual ~AudioActiveReference();
00031         static SharedPtr<AudioActiveReference> Create();
00032         bool operator==(const AudioActiveReference& other) const;
00033
00035         enum enumClassType
00036         {
00037             ClassType_AudioActiveReference
00038             //When you add to this, you will have to search for all uses of the enums,
00039             //because this is not a complete subsitute for dynamic_cast<> - it can not check base classes.
00040         };
00041
00042 // change xxx
00043
00045         virtual enumClassType GetClassType() const;
00046
00047         void SetReference(AudioReference& audio_ref);
00048 //      SharedPtr<AudioReference> GetReference();
00049         SharedPtr<const AudioReference> GetReference() const;
00050         const AudioReference* GetAudioReference() const;
00051
00052         void SetDevice(AudioDeviceBase* audio_player);
00053         AudioDeviceBase* GetDevice();
00054         const AudioDeviceBase* GetDevice() const;
00055
00056         // @todo comment
00057         void Stop();
00058
00060         BOOLEAN Suspend();
00061
00063         BOOLEAN Resume();
00064
00065         typedef AudioReference::VolumeLevel VolumeLevel;
00066
00071         BOOLEAN SetVolume(VolumeLevel val);
00072
00073         // @todo rename, comment
00076         BOOLEAN GetVolumeSet() const {
00077             return m_mmi_volume_has_been_set;
00078         }
00079
00081         VolumeLevel GetVolume() const {
00082             return m_mmi_volume;
00083         }
00084
00085         // @todo check if removable
00086         BOOLEAN SetChannelVolume(VolumeLevel val);
00087
00088 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00089     // @todo check if removable
00090         BOOLEAN GetSuspended() const;// kept only so legacy code works without changes
00091         BOOLEAN GetWaiting() const;// kept only so legacy code works without changes
00092
00093         // @todo check if removable
00095         BOOLEAN IsActive();
00096
00097         // @todo internal
00098         enum PlaybackState {
00099             InitialState,
00100             WaitingState,
00101             PlayingState,
00102             SuspendedState,
00103             StoppedState
00104         };
00105
00106         PlaybackState GetPlaybackState() const {
00107             return m_playback_state;
00108         }
00109
00110         void SetPlaybackState(PlaybackState s) {
00111             m_playback_state = s;
00112         }
00113
00114         typedef UINT32 HandleInsidePlayer;
00115
00116         HandleInsidePlayer GetHandleInsidePlayer() const {
00117             return m_handle_inside_player;
00118         }
00119
00120         void SetHandleInsidePlayer(HandleInsidePlayer handle_inside_player) {
00121             m_handle_inside_player = handle_inside_player;
00122         }
00123
00125         void EnableTimeout();
00126
00127         BOOLEAN TimeoutHasOccurred() const {
00128             return m_timeout_has_occurred;
00129         }
00130
00131         void SetHasBeenStoppedVoluntarily() {
00132             m_has_been_stopped_voluntarily = TRUE;
00133         }
00134
00135         BOOLEAN GetHasBeenStoppedVoluntarily() const {
00136             return m_has_been_stopped_voluntarily;
00137         }
00138
00139         void SetIsInVoluntarySuspension(BOOLEAN b) {
00140             m_is_in_voluntary_suspension = b;
00141         }
00142
00143         BOOLEAN GetIsInVoluntarySuspension() const {
00144             return m_is_in_voluntary_suspension;
00145         }
00146
00147         void SetExclusionGroup(INT exclusion_group) {
00148             m_exclusion_group = exclusion_group;
00149         }
00150
00151         INT GetExclusionGroup() const {
00152             return m_exclusion_group;
00153         }
00154
00155         // having a true/false setter does not make sense
00156         void SetInnerRef() {
00157             m_is_inner_ref = TRUE;
00158         }
00159
00160         BOOLEAN IsInnerRef() const {
00161             return m_is_inner_ref;
00162         }
00163
00165         virtual void OnStopped();
00166
00167         // todo internal
00168         void SetDriverVolume(VolumeLevel volume) {
00169             m_driver_volume = volume;
00170         }
00171
00173         // todo internal
00174         VolumeLevel GetDriverVolume() const {
00175             return m_driver_volume;
00176         }
00177
00179
00183         BOOLEAN SetPlayPosition(UINT32 startPosition);
00184
00189         BOOLEAN GetPlayPosition();
00190
00196         BOOLEAN SetPitch(INT32 pitch);
00197
00202         INT32 GetPitch() const;
00203
00210         void GetPitchRange(INT32 &minPitch, INT32 &maxPitch) const;
00211
00217         BOOLEAN SetTempo(INT32 tempo);
00218
00223         INT32 GetTempo() const;
00224
00230         BOOLEAN SetRate(INT32 rate);
00231
00236         INT32 GetRate() const;
00237
00244         void GetRateRange(INT32 &minRate, INT32 &maxRate) const;
00245
00253         BOOLEAN GetTotalPlayTime(UINT32 &total1,
00254                                  UINT32 &total2,
00255                                  UINT32 &total3,
00256                                  UINT32 &total4);
00257
00258     protected:
00260         virtual void OnTimer();
00261
00262     protected:
00263         BOOLEAN m_is_in_voluntary_suspension;
00264         BOOLEAN m_has_been_stopped_voluntarily;
00265         AudioDeviceBase* m_device;
00266         VolumeLevel m_mmi_volume;
00267         VolumeLevel m_driver_volume;
00268         BOOLEAN m_mmi_volume_has_been_set; //xxx Otherwise use player's default volume.
00269
00270         BOOLEAN m_timeout_has_occurred;
00271
00272         SharedPtr<AudioReference> m_audio_reference;
00273         PlaybackState m_playback_state;
00274
00275         HandleInsidePlayer m_handle_inside_player;
00276
00277     private:
00278         INT m_exclusion_group;
00279         BOOLEAN m_is_inner_ref;
00280
00281         //friend class AudioPriorityManager;
00282
00283 #endif //DOXYGEN_SHOULD_SKIP_THIS
00284 };
00285
00287 #endif  // Apoxi_AudioActiveReference_hpp
00288
00289
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioDeviceBase.cpp File Reference

Audio/AudioDeviceBase.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioDeviceBase.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioUtility.hpp>
#include <Audio/AudioReference.hpp>
#include <Audio/AudioActiveReference.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioError.hpp>

Include dependency graph for AudioDeviceBase.cpp:

Generated on Tue Jan 24 18:06:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioDeviceBase.hpp File Reference

Audio/AudioDeviceBase.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Audio/AudioReference.hpp>

Include dependency graph for AudioDeviceBase.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioDeviceBase
class | NonCopyable

Defines

#define | Apoxi_AudioDeviceBase_hpp

Define Documentation

#define Apoxi_AudioDeviceBase_hpp

Generated on Tue Jan 24 18:07:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioDeviceBase.hpp Source File

Audio/AudioDeviceBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioDeviceBase_hpp)
00011 #define Apoxi_AudioDeviceBase_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016 #include <Audio/AudioReference.hpp>
00017
00018 class AudioActiveReference;
00019 class AudioReference;
00020 class GenericObject;
00021 class Mutex;
00022
00023 //@TODO move to its own file
00024 class NonCopyable
00025 {
00026  protected:
00027     NonCopyable() {}
00028     ~NonCopyable() {}
00029  private:
00030     NonCopyable( const NonCopyable& );
00031     const NonCopyable& operator=( const NonCopyable& );
00032 };
00033
00037 class AudioDeviceBase : public NonCopyable
00038 {
00039     public:
00040         AudioDeviceBase();
00041         virtual ~AudioDeviceBase();
00042
00044         enum PredefinedFeature {
00045             SetTimeFeature,
00046             GetTimeFeature,
00047             MmfSuspendFeature,
00048             MmfResumeFeature,
00049
00068             GenericFastForward,
00069
00088             GenericRewind,
00089
00103             GenericGetTrackInfo,
00104
00119             MmfGetAudioTrackInfo,
00120
00129             FmRadioSeekStationFeature,
00130
00138             FmRadioSetStationFeature,
00139
00153             FmRadioRssiLevelFeature,
00154
00166             FmRadioRdsFeature,
00167
00182             FmRadioRdsStationNameFeature,
00183
00198             FmRadioRdsRadioTextFeature,
00199
00215             FmRadioRdsRawDataFeature,
00216
00233             FmRadioRdsAlternativeFrequenciesFeature,
00234
00235             PredefinedFeatureEnd
00236         };
00237
00241         typedef INT Feature;
00242
00249         virtual BOOLEAN IsFeatureSupported(Feature feature, MimeType mime_type = c_mime_unknown, AudioReference::SoundDataSource sound_data_source = AudioReference::InvalidSoundDataSource) const {return FALSE;}
00250
00258         virtual BOOLEAN ExecuteFeature(Feature feature, GenericObject* data = 0) {return FALSE;}
00259
00261         typedef AudioReference::VolumeLevel VolumeLevel;
00262
00263         enum MuteDirection
00264         {
00265             UplinkDirection,
00266             DownlinkDirection,
00267             UpDownlinkDirection,
00268         };
00269
00271         VolumeLevel GetVolume() const;
00272
00274         BOOLEAN SetVolume(VolumeLevel volume);
00275
00280         BOOLEAN SetMasterVolume(VolumeLevel volume);
00281
00282         VolumeLevel GetMasterVolume() const {
00283             return m_master_volume;
00284         }
00285
00286
00287
00292         BOOLEAN SetDeviceVolume(VolumeLevel volume);
00293
00294         VolumeLevel GetDeviceVolume() const {
00295             return m_device_volume;
00296         }
00297
00304         virtual BOOLEAN SetMute(BOOLEAN enable = TRUE, MuteDirection direction = UpDownlinkDirection);
00305
00307         // @todo this should go to the SimpleDevices
00308         typedef enum {
00310             StatusEnabled,
00312             StatusDisabled
00313         } AudioDeviceStatus;
00314
00317         enum AudioErrorType {
00319             NoErrorType = 0,
00321             FileOperationErrorType,
00323             InvalidFormatErrorType,
00325             GeneralErrorType
00326         };
00327
00330         enum StopCause {
00331             InvalidCause = 0, //< if an application gets this, something is wrong
00332             DriverCause, //< the driver stopped the sound because 1. playback finished to completion, or 2. some unspecified driver problem occurred
00333             VoluntaryCause, //< the application stopped the sound
00334             PriorityManagementCause, //< APOXI priority management stopped the sound in order to make room for another one
00335             TimerCause //< the active reference's timer has timed out
00336         };
00337
00339         virtual UINT16 GetDeviceID() const = 0;
00340
00341 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00342
00344         enum PredefinedAudioSource
00345         {
00346             InvalidAudioSource = 0,
00347             DspAudioSource,
00348             RingerAudioSource,
00349             FmRadioAudioSource
00350         };
00351
00355         typedef INT AudioSource;
00356         typedef AudioSource AudioSourceType;
00357
00362         virtual AudioSource GetSource() const = 0;
00363
00364 #endif //DOXYGEN_SHOULD_SKIP_THIS
00365
00366         // xxx internal
00367         //BOOLEAN UpdateReferenceVolume(const AudioActiveReference& active_reference, VolumeLevel reference_volume);
00368         virtual BOOLEAN UpdateReferenceVolume(const AudioActiveReference& active_reference);
00369     private:
00370         VolumeLevel m_master_volume;
00371         VolumeLevel m_device_volume;
00372
00373 #if 1 // todo: remove
00374
00375     protected:
00376         virtual BOOLEAN ApplyDeviceVolume();
00377         virtual BOOLEAN ApplyMasterVolume();
00378
00380         //VolumeLevel m_volume;
00382         //VolumeLevel m_playing_volume;
00383         BOOLEAN m_mute;
00384
00385
00386
00388         VolumeLevel GetVolume_Specific(const AudioReference &audio_ref);
00389
00390         static Mutex* GetMutex();
00391
00392 #endif
00393
00394 };
00395
00397 #endif  // Apoxi_AudioDeviceBase_hpp
00398
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioDeviceManager.cpp File Reference

Audio/AudioDeviceManager.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/CustomRingerAudioReference.hpp>
#include <Audio/CustomSmafPhraseAudioReference.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Audio/SpeechSimpleAudioDevice.hpp>
#include <Config/AudioConfig.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Ffs/FfsTypes.hpp>
#include <Auxiliary/BinData.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>
#include <Audio/RingerAudioPlayer.hpp>
#include <Audio/RingerAudioInternalMidiPlayer.hpp>
#include <Audio/ToneAudioPlayer.hpp>
#include <Audio/VoiceMemoAudioPlayer.hpp>
#include <Audio/PcmAudioPlayer.hpp>
#include <Audio/AudioPlayerStore.hpp>

Include dependency graph for AudioDeviceManager.cpp:

Defines

#define aud_rc_user_message 1

Define Documentation

#define aud_rc_user_message 1

Generated on Tue Jan 24 18:07:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioDeviceManager.hpp File Reference

Audio/AudioDeviceManager.hpp File Reference

#include <Audio/AudioAccessoryStore.hpp>
#include <Audio/AudioDeviceBase.hpp>
#include <Audio/AudioPlayer.hpp>
#include <Audio/AudioVibratorDevice.hpp>
#include <Audio/SpeechSimpleAudioDevice.hpp>
#include <Audio/AudioPreset.hpp>

Include dependency graph for AudioDeviceManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioDeviceManager

Defines

#define | Apoxi_AudioDeviceManager_hpp

Define Documentation

#define Apoxi_AudioDeviceManager_hpp

Generated on Tue Jan 24 18:07:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioDeviceManager.hpp Source File

Audio/AudioDeviceManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioDeviceManager_hpp)
00011 #define Apoxi_AudioDeviceManager_hpp
00014
00015
00016
00017 #include <Audio/AudioAccessoryStore.hpp>
00018 #include <Audio/AudioDeviceBase.hpp>
00019 #include <Audio/AudioPlayer.hpp>
00020
00021 #include <Audio/AudioVibratorDevice.hpp>
00022 #include <Audio/SpeechSimpleAudioDevice.hpp>
00023
00024 #include <Audio/AudioPreset.hpp>
00025
00026 class Path;
00027 class BinData;
00028
00029 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00030 class AudioCallback;
00031 #endif //DOXYGEN_SHOULD_SKIP_THIS
00032
00033
00037 class AudioDeviceManager
00038 {
00039     private:
00040         //Use GetInstance() instead.
00041         AudioDeviceManager();
00042
00043     public:
00044         virtual ~AudioDeviceManager();
00045         static AudioDeviceManager& GetInstance();
00046
00048         typedef enum {
00049
00050             ToneDeviceID,
00051             RingerDeviceID,
00052             MIDIRingerDeviceID,
00053             VoiceMemoDeviceID,
00054             PCMDeviceID,
00055             MP3DeviceID,
00056             SpeechDeviceID,
00057             VibratorDeviceID,
00058             RadioDeviceID,
00059             YamahaMapiId,
00060
00061             AudioDeviceEndId
00062         } AudioDeviceID;
00063
00076         AudioDeviceBase* GetDevice(AudioDeviceID device);
00077
00084         AudioPlayer* GetAudioPlayer(const AudioReference &file_reference);
00085
00090         SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type,  AudioPlayer::Buffer buffer, UINT32 buffer_size);
00091
00096         SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type,  AudioPlayer::ConstBuffer buffer, UINT32 buffer_size);
00097
00102         SharedPtr<AudioReference> CreateAudioReferenceFromStream(MimeType mime_type, AudioPlayer::GetAudioBufferFunction func, void* user_data = 0);
00103
00108         SharedPtr<AudioReference> CreateAudioReferenceFromPreset(MimeType mime_type, AudioPreset::AudioPresetSoundToneId tone_id);
00109
00116         SharedPtr<AudioReference> CreateAudioReferenceFromBinData(MimeType mime_type, BinData* bin_data);
00117
00123         SharedPtr<AudioReference> CreateAudioReferenceFromExtensionSoundDataSource(MimeType mime_type, AudioReference::SoundDataSource sound_data_source);
00124
00131         SharedPtr<AudioReference> CreateAudioReferenceFromFFS(const String& filename);
00132
00164         SharedPtr<AudioReference> CreateAudioReferenceFromRFS(const Path& path);
00165
00166
00190         static SharedPtr<AudioActiveReference> Play(const AudioReference &file_reference);
00191
00193         static void SuspendAllPlayingSounds();
00194
00196         static void StopAllSounds();
00197
00203         static SharedPtr<AudioActiveReference> StartRecording(const AudioReference &audio_ref);
00204
00208         static void StopRecording(AudioActiveReference &active_reference);
00209
00214         static BOOLEAN SetMasterVolume(AudioDeviceBase::VolumeLevel volume);
00215
00219         static AudioDeviceBase::VolumeLevel GetMasterVolume();
00220
00221 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00222
00226         static void EnableEcNr(BOOLEAN enable);
00227 #endif
00228
00234         static BOOLEAN EnableMasterMute(BOOLEAN enable = TRUE);
00235
00239         static BOOLEAN GetMasterMute();
00240
00241         typedef AudioPlayer::AudioSourceType SourceType; //DSP, Ringer/PolyphonicChip
00242
00244         BOOLEAN LinkAccessory(SourceType source, AudioAccessoryDetails &accessory);
00245
00248         AudioAccessoryDetails::AudioAccessoryConfigurationType GetLinkedAccessory(SourceType source) const;
00249
00250         typedef AudioAccessoryStore::AccessoryList AccessoryList;
00251         // Gets the list of accessories. Convenience method for AudioAccessoryStore::GetAccessoryList
00252         const AccessoryList GetAccessoryList() const;
00253
00259         typedef void (*OnAudioMessageCallback)(const Message* message, void* pUserData);
00260
00269         void SubscribeAudioMessageCallback(OnAudioMessageCallback func, void* pUserData = 0);
00270
00275         void UnsubscribeAudioMessageCallback(OnAudioMessageCallback func, void* pUserData = 0);
00276
00287         static void PostAudioUserDefinedMessage (UINT8 messageID, UINT16 senderID = 0, UINT32 param1 = 0, UINT32 param2 = 0, UINT32 param3 = 0, UINT32 param4 = 0);
00288
00289                 static void MapAndUpdateVolumes();
00290
00291 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00292
00295         void PostAudioMessage (const Message& message) const;
00296 #endif // DOXYGEN_SHOULD_SKIP_THIS
00297
00298     protected:
00299         // singleton instance
00300         static AudioDeviceManager m_Instance;
00301
00302         //master volume
00303         static AudioDeviceBase::VolumeLevel m_master_volume;
00304
00305         //master mute
00306         static BOOLEAN m_master_mute;
00307
00308         //state of echo cancelation and noise reduction
00309         static BOOLEAN m_ecnr_state;
00310
00311         AudioAccessoryDetails::AudioAccessoryConfigurationType m_accessory; // See comment in GetLinkedAccessory() implementation.
00312
00313         // Simple Devices available:
00314         // xxx @todo
00315         AudioVibratorDevice m_device_vibrator;
00316
00317 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00318         typedef LinkedList<AudioCallback> CallbackRegistrationList;
00319         // list of registered callback functions to be called when APOXI message has been sent
00320         CallbackRegistrationList m_callbackRegistrationList;
00321 #endif
00322 };
00323
00325 #endif  // Apoxi_AudioDeviceManager_hpp
00326
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioError.cpp File Reference

Audio/AudioError.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioReference.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for AudioError.cpp:

Generated on Tue Jan 24 18:07:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioError.hpp File Reference

Audio/AudioError.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>

Include dependency graph for AudioError.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioError

Defines

#define | Apoxi_AudioNewAPI_AudioError_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AudioError_hpp

Generated on Tue Jan 24 18:07:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioError.hpp Source File

Audio/AudioError.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioError_hpp)
00011 #define Apoxi_AudioNewAPI_AudioError_hpp
00014
00015 #include <Auxiliary/NonCloneable.hpp>
00016 class AudioReference;
00017
00018 //There is no real implementation in this class,
00019 //but I am waiting (just feeling) new requirements soon, (simonal)
00020 class AudioError : public NonCloneable
00021 {
00022     public:
00023         virtual ~AudioError();
00024
00025         static AudioError& GetInstance();
00026
00030         enum ErrorType
00031         {
00033             ErrorUnknown,
00035             ErrorResourceInUse,
00037             ErrorResourceConflict,
00039             ErrorHandleNotUsed,
00041             ErrorNoHwSupport,
00043             ErrorSharingViolation,
00045             ErrorParameterOutOfRange,
00047             ErrorFormatNotSupported,
00049             ErrorAudioDriverDisabled,
00051             ErrorRingerToneError,
00053             ErrorVmFFSProblems,
00055             ErrorVmPerformanceProblems,
00057             ErrorRingerSuspendresumeError,
00059             ErrorMissingDspResource,
00061             ErrorUnknownPosition,
00063             ErrorNoPlayback,
00065             ErrorNoPlaytime,
00066             ErrorPerformanceProblems
00067         };
00068
00069         typedef INT8 AudReturnCode;
00070
00071 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00072
00073         static void SendAudioErrorMsg(AudioReference& audio_reference, const AudReturnCode return_code);
00074
00075         // Map the driver defined error to the APOXI error type
00076         AudioError::ErrorType DriverError2ApoxiError(AudReturnCode return_code);
00077 protected:
00078     AudioError();
00079
00080 protected:
00081     static AudioError m_instance;
00082
00083 #endif // DOXYGEN_SHOULD_SKIP_THIS
00084 };
00085
00087 #endif  // Apoxi_AudioNewAPI_AudioError_hpp
00088
00089
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioMsgProcessor.cpp File Reference

Audio/AudioMsgProcessor.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioMsgProcessor.hpp>

Include dependency graph for AudioMsgProcessor.cpp:

Generated on Tue Jan 24 18:07:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioMsgProcessor.hpp File Reference

Audio/AudioMsgProcessor.hpp File Reference

#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for AudioMsgProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_AudioMsgProcessor_hpp

Define Documentation

#define Apoxi_Devices_AudioMsgProcessor_hpp

Generated on Tue Jan 24 18:07:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioMsgProcessor.hpp Source File

Audio/AudioMsgProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_AudioMsgProcessor_hpp)
00010 #define Apoxi_Devices_AudioMsgProcessor_hpp
00013
00014 #include <Apc/SignalHandler/StackMsgProcessor.hpp>
00015
00016 /*  ========================================================================
00017     AudioMsgProcessor
00018     ======================================================================== */
00021 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00022 class AudioMsgProcessor : public StackMsgProcessor
00023 {
00025     public:
00026         static void ProcessAudioSpeechCtrlRequest(INT ControlType, INT link_path, BOOLEAN mute, INT volume);
00027
00028 }; // AudioMsgProcessor
00029 #endif // DOXYGEN_SHOULD_SKIP_THIS
00030
00031 #endif // Apoxi_Devices_AudioMsgProcessor_hpp
00032
00033
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPath.cpp File Reference

Audio/AudioPath.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioPath.hpp>

Include dependency graph for AudioPath.cpp:

Generated on Tue Jan 24 18:07:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPath.hpp File Reference

Audio/AudioPath.hpp File Reference

#include "AudioDeviceBase.hpp"

Include dependency graph for AudioPath.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioPath

Defines

#define | Apoxi_AudioNewAPI_AudioPath_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AudioPath_hpp

Generated on Tue Jan 24 18:07:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPath.hpp Source File

Audio/AudioPath.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioPath_hpp)
00011 #define Apoxi_AudioNewAPI_AudioPath_hpp
00012
00013 #include "AudioDeviceBase.hpp" // for AudioSourceType
00014
00017
00018 class AudioPath : public Linkable<AudioPath>
00019 {
00020     public:
00023         enum AudioPathType
00024         {
00026             AudioPathDownlink,
00028             AudioPathUplink
00029         };
00030
00031     /*The enum values should not be changed because path manager uses
00032      these values as there currently are
00033     */
00034
00036         enum UplinkPathType
00037         {
00039             UplinkPathHandsetMic = 0x1,
00041             UplinkPathHeadsetMic = 0x2,
00042             //HF car kit mic
00043             UplinkCarKit = 0x4,
00045             UplinkPathI2S1_Rx = 0x8,
00047             UplinkPathTTY = 0x10,
00049             UplinkPathRecordingHandsetMic = 0x20,
00050             // this path has special settings that avoid some echo canceling issues
00051             UplinkPathDthfMic = 0x40,
00052             // Bluetooth inband ringing
00053             UplinkPathI2S1InbandRx = 0x80,
00055             UplinkPathNone = 0x0
00056         };
00057
00059         enum DownlinkPathType
00060         {
00062             DownlinkPathEarpiece = 0x1,
00064             DownlinkPathMonoHeadset = 0x2,
00066             DownlinkPathStereoHeadset = 0x4,
00068             DownlinkPathBackspeaker = 0x8,
00070             DownlinkPathI2S1_Tx = 0x10,
00072             DownlinkPathTTY = 0x20,
00074             DownlinkCarKit = 0x40,
00076             DownlinkPathExtRingerMonoHeadset = 0x80,
00078             DownlinkPathExtRingerStereoHeadset = 0x100,
00080             DownlinkPathExtRingerBackspeaker = 0x200,
00082             DownlinkPathExtRingerI2S1_Tx = 0x400,
00084             DownlinkPathBackspeakerStereo = 0x800,
00086             DownlinkPathFmRadioBackspeaker = 0x1000,
00088             DownlinkPathFmRadioHeadset = 0x2000,
00090             DownlinkPathNone = 0x0
00091         };
00092
00094         AudioPath(const AudioPath& path);
00095
00097         AudioPath(const UplinkPathType uplinkPath);
00098
00100         AudioPath(const DownlinkPathType downlinkPath);
00101
00105         AudioPath::AudioPathType GetAudioPathType() const;
00106
00108         UINT16 GetPath() const;
00109
00110         AudioDeviceBase::AudioSourceType GetAudioSourceType() const;
00111
00112         BOOLEAN operator==(const AudioPath& path) const;
00113
00114         AudioPath & operator = (const AudioPath::UplinkPathType path);
00115
00116         AudioPath & operator = (const AudioPath::DownlinkPathType path);
00117     private:
00119         UINT16 m_audio_path;
00121         AudioPathType m_path_type;
00122 };
00123
00125 #endif  // Apoxi_AudioNewAPI_AudioPath_hpp
00126
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPathManager.cpp File Reference

Audio/AudioPathManager.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioPathManager.hpp>
#include <Audio/AudioAccessoryStore.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Apc/Message.hpp>
#include <Apc/MiscStackMsgArgs.hpp>
#include <Asc/Types.hpp>
#include <Asc/TtyInterface.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/SpeechSimpleAudioDevice.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Devices/Charger.hpp>
#include <Devices/ChargerMsgTypes.hpp>

Include dependency graph for AudioPathManager.cpp:

Generated on Tue Jan 24 18:07:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPathManager.hpp File Reference

Audio/AudioPathManager.hpp File Reference

#include <Kernel/MessageHook.hpp>
#include <Audio/AudioPath.hpp>
#include <Audio/AudioAccessoryDetails.hpp>
#include <Apc/SignalHandler/SignalMapTableEntry.hpp>
#include <Apc/Accessory.hpp>

Include dependency graph for AudioPathManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioPathManager

Defines

#define | Apoxi_AudioNewAPI_AudioPathManager_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AudioPathManager_hpp

Generated on Tue Jan 24 18:07:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPathManager.hpp Source File

Audio/AudioPathManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioPathManager_hpp)
00011 #define Apoxi_AudioNewAPI_AudioPathManager_hpp
00012
00013 #include <Kernel/MessageHook.hpp>
00014 #include <Audio/AudioPath.hpp>
00015 #include <Audio/AudioAccessoryDetails.hpp>
00016 #include <Apc/SignalHandler/SignalMapTableEntry.hpp> // For ProcessPtr
00017 #include <Apc/Accessory.hpp>
00018
00021
00022 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00023
00024 class AudioMessageHook : public MessageHook
00025 {
00026     public:
00027         virtual BOOLEAN OnMessage(Message& message);
00028 };
00029 #endif
00030
00046 class AudioPathManager
00047 {
00048     protected:
00049         //Use GetInstance() instead.
00050         AudioPathManager();
00051
00052     public:
00053         virtual ~AudioPathManager();
00054         static AudioPathManager* GetInstance();
00055
00056
00057 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00058
00059         static void OnSdlSignal_AccessoryInd(const ProcessPtr &process_ptr);
00060 #endif //DOXYGEN_SHOULD_SKIP_THIS
00061
00066         BOOLEAN CanLinkAudioPath(AudioPath& path);
00067
00072         BOOLEAN IsPathActive(AudioPath& path);
00073
00081         BOOLEAN AddAudioPath(AudioPath& path);
00082
00087         BOOLEAN RemoveAudioPath(AudioPath& path);
00088
00093         void RemoveAllAudioPaths(BOOLEAN upLink = TRUE, BOOLEAN downLink = TRUE);
00094
00101         BOOLEAN LinkAccessory(const AudioDeviceBase::AudioSourceType source, AudioAccessoryDetails& accessory);
00102
00104         void UpdateAudioPaths(AudioDeviceBase::AudioSourceType requester_audio_source = AudioDeviceBase::DspAudioSource);
00105
00111         void EnableUplinkAudioPaths(BOOLEAN enable = TRUE);
00112
00118         BOOLEAN Enable3dSound(BOOLEAN enable = TRUE);
00119
00121         BOOLEAN IsCallActive();
00122
00123 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00124
00125         static void OnCallBegin();
00126
00128         static void OnCallEnd();
00129
00131         static void OnRecordingBegin();
00132
00134         static void OnRecordingEnd();
00135
00137         static void OnFlipStatusChanged(BOOLEAN flipOpen);
00138
00140         static void OnChargerConnected(BOOLEAN connected);
00141
00143         static void UpdateFlipStatus();
00144
00145         //Initialize audio paths and message hooks
00146         void Initialize();
00147     protected:
00151         void AddPath_Implementation(AudioPath& path);
00152
00156         void RemovePath_Implementation(AudioPath& path);
00157
00158         enum UplinkMaskType
00159         {
00161             UplinkMaskActiveCall = 0x1,
00163             UplinkMaskRecording = 0x2,
00165             UplinkMaskFlipOpen = 0x4
00166         };
00167
00168         enum CarkitMaskType
00169         {
00171             CarKitConnected = 0x1,
00173             ChargerConnected = 0x2
00174         };
00175
00176     //Helper functions
00177     private:
00178         typedef LinkedList<AudioPath> ActivePathList;
00179
00181         AudioPath* FindPathInActiveList(AudioPath& path);
00183         void InitPathList(ActivePathList& pathList);
00185         static UINT16 Map_UplinkPath_APOXI2Drv (const AudioPath::UplinkPathType uplinkPath);
00187         static UINT16 Map_DownlinkPath_APOXI2Drv (const AudioPath::DownlinkPathType downlinkPath);
00188
00196         Accessory::Type On_HeadsetStatusChanged(const HeadSet& headset);
00197
00199         BOOLEAN IsTTYActive();
00200     private:
00202         AudioMessageHook m_charger_message_hook;
00203
00205         AudioMessageHook m_flip_message_hook;
00206
00208         static AudioPathManager* m_instance;
00209
00211         ActivePathList m_activePathList;
00212
00213         //Indicates whether uplink paths are enabled or disabled
00214         BOOLEAN m_uplink_paths_enabled;
00215
00223         static UINT8 m_uplink_mask;
00224
00226         BOOLEAN m_active_call;
00227
00233         static UINT8 m_hf_carkit_mask;
00234
00235 #endif //DOXYGEN_SHOULD_SKIP_THIS
00236 };
00237
00239 #endif  // Apoxi_AudioNewAPI_AudioPathManager_hpp
00240
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPlayer.cpp File Reference

Audio/AudioPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioPlayer.hpp>
#include <Audio/AudioActiveReference.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for AudioPlayer.cpp:

Generated on Tue Jan 24 18:07:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPlayer.hpp File Reference

Audio/AudioPlayer.hpp File Reference

#include <Audio/AudioDeviceBase.hpp>
#include <Audio/AudioPreset.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/SharedPtr.hpp>

Include dependency graph for AudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioPlayer

Defines

#define | Apoxi_AudioPlayer_hpp

Define Documentation

#define Apoxi_AudioPlayer_hpp

Generated on Tue Jan 24 18:07:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPlayer.hpp Source File

Audio/AudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioPlayer_hpp)
00011 #define Apoxi_AudioPlayer_hpp
00014
00015 #include <Audio/AudioDeviceBase.hpp>
00016 #include <Audio/AudioPreset.hpp>
00017 #include <Auxiliary/Vector.hpp>
00018 #include <Auxiliary/SharedPtr.hpp>
00019
00020 // class AudioReference; would be enough with a different shared pointer
00021 // AudioReference would be enough but the typedef of the callback function for streaming is defined there
00022
00023 class AudioActiveReference;
00024 class Path;// from RFS
00025 class BinData;
00026
00030 class AudioPlayer : public AudioDeviceBase
00031 {
00032     public:
00033         AudioPlayer();
00034         virtual ~AudioPlayer();
00035
00036         // No application-public interface. Players are used only by APOXI.
00037         // (However, they may be used as AudioDevices by an application, eg SetVolume.)
00038
00039                 // Reponsibilities of AudioPlayer (that cannot be expressed as functions to override):
00040                 // Please consult the DSpec on this.
00041                 // + Notification in case of error (in additionto the notifications following a playback command)
00042                 // + Repeat count and AudioRestartedMsg
00043
00044
00045 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00046
00052         virtual BOOLEAN SetPlayPosition(AudioActiveReference &active_reference);
00053
00060         virtual BOOLEAN GetPlayPosition(AudioActiveReference &active_reference);
00061
00068         virtual BOOLEAN GetTotalPlayTime(AudioActiveReference &active_reference);
00069
00077         virtual BOOLEAN SetPitch(AudioActiveReference &active_reference);
00078
00086         virtual BOOLEAN SetRate(AudioActiveReference &active_reference);
00087
00095         virtual BOOLEAN SetTempo(AudioActiveReference &active_reference);
00096
00097
00098
00102         virtual void Play(AudioActiveReference& active_reference) = 0;
00103
00107         virtual void Stop(AudioActiveReference& active_reference) = 0;
00108
00112         //@todo virtual BOOLEAN CanPlay(AudioActiveReference& active_reference) const = 0;
00113         virtual BOOLEAN CanPlay(const AudioActiveReference& active_reference) const { return TRUE; }
00114
00119         virtual BOOLEAN CanSuspend(const AudioActiveReference& active_reference) const;
00120
00124         virtual BOOLEAN CanResume(const AudioActiveReference& active_reference) const;
00125
00129         virtual void Suspend(AudioActiveReference& active_reference);
00130
00134         virtual void ResumeSuspended(AudioActiveReference& active_reference);
00135
00139         virtual void StopSuspended(AudioActiveReference& active_reference);
00140
00145         virtual SharedPtr<AudioActiveReference> StartRecording(const AudioReference &audio_ref);
00146
00151         virtual void StopRecording(AudioActiveReference &active_reference);
00152
00154         struct MimeTypeSupportInfo {
00156             MimeType m_mime_type;
00157
00159             AudioReference::SoundDataSource m_sound_data_source;
00160
00162             BOOLEAN m_is_playback_supported;
00163
00165             UINT m_number_of_parallel_playbacks;
00166
00168             BOOLEAN m_is_recording_supported;
00169         };
00170
00174         virtual Vector<MimeTypeSupportInfo> GetMimeTypeSupportInfo() const {
00175             Vector<MimeTypeSupportInfo> empty;
00176             return empty;
00177         }
00178
00182         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRfsFile(MimeType mime_type, const Path& path);
00183
00184         typedef const UINT16 HUGE* ConstBuffer;
00185         typedef UINT16 HUGE* Buffer;
00189         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, Buffer buffer, UINT32 buffer_size);
00190
00194         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, ConstBuffer buffer, UINT32 buffer_size);
00195
00196         //moved the definition of the call back function GetAudioBufferFunction from StreamAudioReference to here.
00197         typedef void (*GetAudioBufferFunction)( /* audiobuffer */ UINT8 ** , /*size */UINT16 *, /* application data */void* pUserData);
00201         virtual SharedPtr<AudioReference> CreateAudioReferenceFromStream(MimeType mime_type, GetAudioBufferFunction func, void* user_data = 0);
00202
00203
00207         virtual SharedPtr<AudioReference> CreateAudioReferenceFromPreset(MimeType mime_type, AudioPreset::AudioPresetSoundToneId tone_id);
00208
00212         virtual SharedPtr<AudioReference> CreateAudioReferenceFromBinData(MimeType mime_type, BinData* bin_data);
00213
00217         virtual SharedPtr<AudioReference> CreateAudioReferenceFromExtensionSoundDataSource(MimeType mime_type, AudioReference::SoundDataSource sound_data_source);
00218
00219 #endif //DOXYGEN_SHOULD_SKIP_THIS
00220
00221 };
00222
00224 #endif  // Apoxi_AudioPlayer_hpp
00225
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPlayerEvent.hpp File Reference

Audio/AudioPlayerEvent.hpp File Reference

#include <Audio/AudioActiveReference.hpp>
#include <Audio/AudioError.hpp>

Include dependency graph for AudioPlayerEvent.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | AudioPlayerEvent

Defines

#define | Apoxi_AudioPlayerEvent_hpp

Define Documentation

#define Apoxi_AudioPlayerEvent_hpp

Generated on Tue Jan 24 18:07:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPlayerEvent.hpp Source File

Audio/AudioPlayerEvent.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioPlayerEvent_hpp)
00011 #define Apoxi_AudioPlayerEvent_hpp
00014
00015 #include <Audio/AudioActiveReference.hpp>
00016 #include <Audio/AudioError.hpp>
00017 class AudioPlayer;
00018
00019 struct AudioPlayerEvent {
00020
00021     AudioPlayerEvent():
00022         m_player(0),
00023         m_handle(0),
00024         m_playback_state(AudioActiveReference::InitialState),
00025         m_reason(InvalidReason),
00026         m_send_error_message(FALSE),
00027         m_error_code(0)
00028         {}
00029
00031     AudioPlayer* m_player;
00032
00034     AudioActiveReference::HandleInsidePlayer m_handle;
00035
00039     AudioActiveReference::PlaybackState m_playback_state;
00040
00042     enum Reason {
00043         InvalidReason = 0,
00044         CommandReason,
00045         NaturalReason, // e.g. finish after EOF
00046         DriverReason
00047     };
00048
00050     Reason m_reason;
00051
00053     BOOLEAN m_send_error_message;
00054
00056     AudioError::AudReturnCode m_error_code;
00057 };
00058
00060 #endif //Apoxi_AudioPlayerEvent_hpp
00061
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPlayerStore.cpp File Reference

Audio/AudioPlayerStore.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioPlayerStore.hpp>
#include <Audio/VoiceMemoAudioPlayer.hpp>
#include <Kernel/Lib.hpp>

Include dependency graph for AudioPlayerStore.cpp:

Generated on Tue Jan 24 18:07:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPlayerStore.hpp File Reference

Audio/AudioPlayerStore.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <Audio/AudioPlayer.hpp>

Include dependency graph for AudioPlayerStore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioPlayerStore
struct | AudioPlayerStore::DataFormatDataSource

Defines

#define | Apoxi_AudioPlayerStore_hpp

Define Documentation

#define Apoxi_AudioPlayerStore_hpp

Generated on Tue Jan 24 18:07:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPlayerStore.hpp Source File

Audio/AudioPlayerStore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioPlayerStore_hpp)
00011 #define Apoxi_AudioPlayerStore_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017 #include <Auxiliary/SimpleMap.hpp>
00018
00019 #include <Audio/AudioPlayer.hpp>
00020
00025 class AudioPlayerStore
00026 {
00027     protected:
00028         AudioPlayerStore();
00029
00030     public:
00031         ~AudioPlayerStore();
00032
00033         static AudioPlayerStore* GetInstance();
00034
00041         BOOLEAN AddPlayer(AudioPlayer *player);
00042
00052         BOOLEAN PrioritizePlayer(AudioPlayer *player, MimeType type, AudioReference::SoundDataSource source);
00053
00063         BOOLEAN ExcludePlayer(AudioPlayer *player, MimeType type, AudioReference::SoundDataSource source);
00064
00065 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00066
00072         AudioPlayer* FindPlayer(MimeType type) const;
00073
00085         Vector<AudioPlayer*> GetPrioritizedPlayers(MimeType type, AudioReference::SoundDataSource source, BOOLEAN for_playback, BOOLEAN for_recording) const;
00086
00087 #endif //DOXYGEN_SHOULD_SKIP_THIS
00088
00089 protected:
00090         struct DataFormatDataSource {
00092             MimeType mime_type;
00093             AudioReference::SoundDataSource source;
00094
00095             BOOLEAN operator== (const DataFormatDataSource& other) {
00096                 return mime_type == other.mime_type && source == other.source;
00097             }
00098         };
00099
00100         SimpleMap<DataFormatDataSource, Vector<AudioPlayer*> > m_mime_to_source_to_players;
00101         static AudioPlayerStore m_instance;
00102 };
00103
00105 #endif  // Apoxi_AudioPlayerStore_hpp
00106
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPreComp.cpp File Reference

Audio/AudioPreComp.cpp File Reference

#include "Audio/AudioPreComp.hpp"

Include dependency graph for AudioPreComp.cpp:

Generated on Tue Jan 24 18:07:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPreComp.hpp File Reference

Audio/AudioPreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <stack/driver.h>

Include dependency graph for AudioPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:07:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPreComp.hpp Source File

Audio/AudioPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Types.hpp>
00009 #include <Kernel/Os/MutexObtainer.hpp>
00010 #include <Kernel/System.hpp>
00011 #include <Kernel/MessageRouter.hpp>
00012 #include <Auxiliary/SharedPtr.hpp>
00013 #include <stack/driver.h>
00014
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPreset.cpp File Reference

Audio/AudioPreset.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioPreset.hpp>

Include dependency graph for AudioPreset.cpp:

Generated on Tue Jan 24 18:07:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPreset.hpp File Reference

Audio/AudioPreset.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for AudioPreset.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioPreset

Defines

#define | Apoxi_AudioNewAPI_AudioPreset_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AudioPreset_hpp

Generated on Tue Jan 24 18:08:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPreset.hpp Source File

Audio/AudioPreset.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioPreset_hpp)
00011 #define Apoxi_AudioNewAPI_AudioPreset_hpp
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/WString.hpp>
00017
00020 class AudioPreset : public Linkable<AudioPreset> //Items in a LinkedList need to inherit from Linkable. I don't know why. murrayc.
00021 {
00022     public:
00023         typedef UINT ToneID;
00024
00025         AudioPreset();
00026
00027         enum PresetToneType
00028         {
00029             NoToneType,
00030             ToneType,
00031             RingerType
00032         };
00033
00034         enum AudioPresetSoundToneId
00035         {
00036             PresetSoundToneDTMF0,
00037             PresetSoundToneDTMF1,
00038             PresetSoundToneDTMF2,
00039             PresetSoundToneDTMF3,
00040             PresetSoundToneDTMF4,
00041             PresetSoundToneDTMF5,
00042             PresetSoundToneDTMF6,
00043             PresetSoundToneDTMF7,
00044             PresetSoundToneDTMF8,
00045             PresetSoundToneDTMF9,
00046             PresetSoundToneDTMFHash,
00047             PresetSoundToneDTMFAsterix,
00048
00049             PresetSoundToneKeyTone1,
00050             PresetSoundToneKeyTone2,
00051             PresetSoundToneKeyTone3,
00052             PresetSoundToneKeyTone4,
00053             PresetSoundToneKeyTone5,
00054
00055             PresetSoundToneSvSubscriberBusy,
00056             PresetSoundToneSvCongestion,
00057             PresetSoundToneSvRadioPatAck,
00058             PresetSoundToneSvRadioPathNotAvail,
00059             PresetSoundToneSvErrorInfo,
00060             PresetSoundToneSvCallWaiting,
00061
00062             PresetSoundToneInfoFreeTone,
00063             PresetSoundToneInfoConnection,
00064             PresetSoundToneInfoDisconnect,
00065             PresetSoundToneInfoDeviceIn,
00066             PresetSoundToneInfoDeviceOut,
00067             PresetSoundToneInfoMsgFull,
00068             PresetSoundToneInfoUssd,
00069             PresetSoundToneInfoMinutteMinder,
00070             PresetSoundToneInfoError1,
00071             PresetSoundToneInfoError2,
00072             PresetSoundToneInfoSmsInCall,
00073             PresetSoundToneInfoBroadcastInCall,
00074             PresetSoundToneInfoAlarmInCall,
00075             PresetSoundToneInfoLowBatInCall,
00076             PresetSoundToneInfoPowerOff,
00077             PresetSoundToneInfoPowerOn,
00078             PresetSoundToneInfoSingleBeep,
00079             PresetSoundToneInfoPositiveAcknowledgement,
00080             PresetSoundToneInfoNegativeAcknowledgement,
00081             PresetSoundToneInfoAutoRedial,
00082             PresetSoundToneInfoNetworkAttention,
00083             PresetSoundToneInfoDialTone,
00084             PresetSoundToneInfoLowBat,
00085             PresetSoundToneRinger1,
00087             PresetSoundToneUnknown
00088         };
00089
00090         AudioPreset(const WString &name, ToneID tone_id, PresetToneType tone_type, BOOLEAN ignore_management = FALSE, AudioPresetSoundToneId apoxi_tone_id = PresetSoundToneUnknown);
00091         virtual ~AudioPreset();
00092
00093         ToneID GetToneID() const;
00094
00095         AudioPresetSoundToneId GetApoxiToneID() const;
00096
00097         WString GetName() const;
00098
00099         PresetToneType GetToneType() const;
00100
00102         BOOLEAN GetIgnoreManagement() const;
00103
00104
00105     protected:
00106         ToneID m_tone_id;
00107         AudioPresetSoundToneId m_apoxi_tone_id;
00108         WString m_name;
00109         PresetToneType m_tone_type;
00110         BOOLEAN m_ignore_management; //See AudioReference::SetIgnoreManagement().
00111 };
00112
00114 #endif  // Apoxi_AudioNewAPI_AudioPreset_hpp
00115
00116
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPresetStore.cpp File Reference

Audio/AudioPresetStore.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioPresetStore.hpp>
#include <Audio/ToneAudioReference.hpp>
#include <Audio/RingerAudioReference.hpp>
#include <Audio/AudioSignalMapTableNode.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Config/AudioConfig.hpp>
#include <Config/AudioPresetsRegistration.hpp>
#include <Audio/AudioPlayerStore.hpp>

Include dependency graph for AudioPresetStore.cpp:

Variables

const WCHAR * | c_free_tone = L"Info - Free Tone"
const WCHAR * | c_single_beep = L"Info - Single Beep"
const WCHAR * | c_tone_supervisory_call_waiting = L"Supervision - Call waiting"
const WCHAR * | c_tone_supervisory_subsciber_busy = L"Supervision - Subscriber busy"
Generated on Tue Jan 24 18:08:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPresetStore.hpp File Reference

Audio/AudioPresetStore.hpp File Reference

#include <Kernel/SubSystem.hpp>
#include <Audio/AudioPreset.hpp>
#include <Auxiliary/SharedPtr.hpp>

Include dependency graph for AudioPresetStore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioPresetStore

Defines

#define | Apoxi_AudioNewAPI_AudioPresetStore_hpp

Variables

const WCHAR * | c_free_tone
const WCHAR * | c_single_beep
const WCHAR * | c_tone_supervisory_call_waiting
const WCHAR * | c_tone_supervisory_subsciber_busy

Define Documentation

#define Apoxi_AudioNewAPI_AudioPresetStore_hpp

Generated on Tue Jan 24 18:08:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPresetStore.hpp Source File

Audio/AudioPresetStore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioPresetStore_hpp)
00011 #define Apoxi_AudioNewAPI_AudioPresetStore_hpp
00014
00015 #include <Kernel/SubSystem.hpp>
00016
00017 #include <Audio/AudioPreset.hpp>
00018 #include <Auxiliary/SharedPtr.hpp>
00019
00020
00021 class PresetAudioReference;
00022
00023 // this is only for backup, it will delete in the future
00024 extern const WCHAR* c_single_beep;
00025 extern const WCHAR* c_tone_supervisory_subsciber_busy;
00026 extern const WCHAR* c_free_tone;
00027 extern const WCHAR* c_tone_supervisory_call_waiting;
00028
00044 class AudioPresetStore : public SubSystem //Inherit from SubSystem because this is a singleton.
00045 {
00046     protected:
00047         AudioPresetStore();
00048
00049     public:
00050         virtual ~AudioPresetStore();
00051
00053         virtual const WCHAR* GetName() const;
00054
00056         virtual BootSequenceState InvokeAt() const;
00057
00059         virtual void OnPowerUp();
00060
00061         static AudioPresetStore* GetInstance();
00062
00064         typedef LinkedList<AudioPreset> PresetList;
00065         const PresetList& GetPresetList() const;
00066
00071         SharedPtr<PresetAudioReference> CreateReference(const WString &preset_name) const;
00072         SharedPtr<PresetAudioReference> CreateReference(AudioPreset::AudioPresetSoundToneId apoxi_tone_id) const;
00073
00074         typedef AudioPreset::PresetToneType PresetToneType;
00075         typedef AudioPreset::ToneID ToneID;
00076
00080         void AddItem(const WString &name, ToneID tone_id, PresetToneType tone_type, BOOLEAN ignore_mangement = FALSE);
00081
00085         void AddItem(const WString &name, AudioPreset::AudioPresetSoundToneId apoxi_tone_id, ToneID tone_id, PresetToneType tone_type, BOOLEAN ignore_mangement = FALSE);
00086
00090         WString GetPresetName(const PresetAudioReference& file_reference) const;
00091
00092     protected:
00093         PresetList m_preset_list;
00094         static AudioPresetStore m_instance;
00095
00096         const AudioPreset* GetPresetForName(const WString &preset_name) const;
00097         const AudioPreset* GetPresetByID(AudioPreset::AudioPresetSoundToneId preset_ID) const;
00098 };
00099
00101 #endif  // Apoxi_AudioNewAPI_AudioPresetStore_hpp
00102
00103
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPriorityManager.cpp File Reference

Audio/AudioPriorityManager.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioPlayer.hpp>
#include <Audio/AudioPlayerStore.hpp>
#include <Audio/Messages/AudioStoppedMsg.hpp>
#include <Audio/Messages/AudioSuspendedMsg.hpp>
#include <Audio/Messages/AudioStartedMsg.hpp>
#include <Audio/Messages/AudioResumedMsg.hpp>
#include <Audio/AudioUtility.hpp>
#include <Audio/AudioDeviceBase.hpp>
#include <Audio/AudioReference.hpp>
#include <Audio/SimpleAudioReference.hpp>
#include <Audio/AudioError.hpp>
#include <Kernel/ApoxiThread.hpp>
#include <Kernel/Threadlet.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/Os/Ticks.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioAccessoryStore.hpp>
#include <Audio/AudioAccessoryDetails.hpp>
#include <Config/AudioAccessoriesRegistration.hpp>
#include <Config/AudioConfig.hpp>

Include dependency graph for AudioPriorityManager.cpp:

Defines

#define | AUDIO_DBG_CRIT(x) DBG_OUT(x)
#define | AUDIO_DBG_EVT(x) DBG_OUT(x)
#define | AUDIO_DBG_PM_LOGIC(x) DBG_OUT(x)
#define | TRACE_APOXI_AUDIO_CRITICAL_SECTION
#define | TRACE_APOXI_AUDIO_EVENT_HANDLING
#define | TRACE_APOXI_AUDIO_PM_LOGIC

Functions

void | AudioPmAutomaticResume (AudioReference::PriorityGroupType priority_group)
AudioActiveReference::PlaybackState | GetPlaybackState (const AudioActiveReference &active_ref)
SharedPtr< AudioActiveReference > | GetSurvivorRef (AudioActiveReference *active_ref)
void | SetPlaybackState (AudioActiveReference &active_ref, AudioActiveReference::PlaybackState state)

Define Documentation

#define AUDIO_DBG_CRIT ( x ) DBG_OUT(x)

#define AUDIO_DBG_EVT ( x ) DBG_OUT(x)

#define AUDIO_DBG_PM_LOGIC ( x ) DBG_OUT(x)

#define TRACE_APOXI_AUDIO_CRITICAL_SECTION

#define TRACE_APOXI_AUDIO_EVENT_HANDLING

#define TRACE_APOXI_AUDIO_PM_LOGIC

Function Documentation

void AudioPmAutomaticResume ( AudioReference::PriorityGroupType priority_group )

AudioActiveReference::PlaybackState GetPlaybackState ( const AudioActiveReference & active_ref )

SharedPtr<AudioActiveReference> GetSurvivorRef ( AudioActiveReference * active_ref )

void SetPlaybackState | ( | AudioActiveReference & | active_ref,
 |  | AudioActiveReference::PlaybackState | state
 | ) |

Generated on Tue Jan 24 18:08:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPriorityManager.hpp File Reference

Audio/AudioPriorityManager.hpp File Reference

#include <Kernel/SubSystem.hpp>
#include <Audio/AudioActiveReference.hpp>
#include <Audio/AudioPlayerEvent.hpp>

Include dependency graph for AudioPriorityManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioPriorityManager_hpp

Define Documentation

#define Apoxi_AudioPriorityManager_hpp

Generated on Tue Jan 24 18:08:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioPriorityManager.hpp Source File

Audio/AudioPriorityManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioPriorityManager_hpp)
00011 #define Apoxi_AudioPriorityManager_hpp
00014
00015 #include <Kernel/SubSystem.hpp>
00016 #include <Audio/AudioActiveReference.hpp>
00017 //#include <Audio/AudioError.hpp>
00018 #include <Audio/AudioPlayerEvent.hpp>
00019
00020 class AudioReference;
00021
00022 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00023
00024
00027 class AudioPriorityManager : public SubSystem
00028 {
00029 protected:
00030     AudioPriorityManager();
00031
00032 public:
00033     virtual ~AudioPriorityManager();
00034     virtual const WCHAR* GetName() const;
00035     virtual BootSequenceState InvokeAt() const;
00036     virtual void OnPowerUp();
00037
00038     static AudioPriorityManager* GetInstance();
00039
00040     SharedPtr<AudioActiveReference> Play(const AudioReference& audio_ref);
00041     void Stop(AudioActiveReference& active_ref);
00042     BOOLEAN Suspend(AudioActiveReference& active_ref);
00043     BOOLEAN Resume(AudioActiveReference& active_ref);
00044
00046     // regardless of their priorities.
00047     // xxx param
00048     void SuspendAllPlayingSounds(const AudioActiveReference& suspended_by);
00049
00051     // xxx resume policy
00052     void ResumeSuspendedBy(const AudioActiveReference& suspended_by);
00053
00054     void StopAllSounds();
00055
00056     // xxx @todo
00058     static void OnCallEnd();
00059
00060 private:
00061     enum PlaybackRequestOutcome {
00062         PlaybackRequestRejected,
00063         PlaybackRequestAcceptedForLater,
00064         PlaybackRequestAcceptedForImmediatePlayback,
00065     };
00066
00077     AudioPriorityManager::PlaybackRequestOutcome RequestPlayback(const AudioReference& audio_ref,
00078             SharedPtr<AudioActiveReference>& low_same_group_ref) const;
00079
00080         void SuspendExcludedRefs(const AudioReference& audio_ref);
00081
00082     void RemoveFromSuspendedRefs(AudioActiveReference& active_ref);
00083     void RemoveFromWaitingRefs(AudioActiveReference& active_ref);
00084     void RemoveFromPlayingRefs(AudioActiveReference& active_ref);
00085
00086     void AcknowledgePlaybackStopped(AudioActiveReference& active_ref, AudioPlayerEvent::Reason reason);
00087     void AcknowledgePlaybackStarted(AudioActiveReference& active_ref);
00088     void AcknowledgePlaybackSuspended(AudioActiveReference& active_ref);
00089
00090     void StopOrSuspendAndWait(AudioActiveReference& active_ref, BOOLEAN stop);
00091     void SuspendAndWait(AudioActiveReference& active_ref);
00092     void StopAndWait(AudioActiveReference& active_ref);
00093
00094     static AudioPriorityManager m_instance;
00095
00096     typedef Vector<AudioActiveReference* > ActiveRefList;
00097     ActiveRefList m_playing_refs;
00098     ActiveRefList m_suspended_refs;
00099     ActiveRefList m_waiting_refs;
00100     void RemoveRefFromCollection(AudioActiveReference* active_ref, ActiveRefList& collection);
00101
00102 public:
00103     void ApplyPathControlTable(const AudioActiveReference& active_ref, BOOLEAN force_update = FALSE);
00104     void OnAccessoryAvailabilityChanged(BOOLEAN force_update = FALSE);
00105
00106     void ReceivePlayerEvent(const AudioPlayerEvent& event);
00107     SharedPtr<AudioActiveReference> GetActiveReference(AudioReference* audio_ref) const;
00108
00109     void UpdatePlayingVolumes();
00110     void UpdatePlayingRefVolume(AudioActiveReference& active_ref);
00111 private:
00112     friend void AudioPmEventHandler();
00113     //This class is defined in the AudioPriorityManager.cpp and uses private members of the AudioPriorityManager, therefore I defined it as friend.
00114     friend class AudioPmResumeThreadlet;
00115
00116     AudioActiveReference* m_ref_to_wait_for;
00117     AudioActiveReference* m_inner_ref_to_wait_for;
00118     BOOLEAN IsConditionSatisfied(BOOLEAN inner) const;
00119     BOOLEAN IsConditionEmpty() const;
00120     BOOLEAN IsInnerConditionEmpty() const;
00121     BOOLEAN m_suspend_is_acceptable_in_wait;
00122     BOOLEAN WaitForPlayer(AudioActiveReference& active_ref, UINT32 timeout);
00123
00124     AudioActiveReference* FindManagedRef(const AudioPlayer* player, AudioActiveReference::HandleInsidePlayer handle) const;
00125     BOOLEAN IsManagedRef(const AudioActiveReference* active_ref) const;
00126
00127     friend void AudioPmAutomaticResume(AudioReference::PriorityGroupType priority_group);
00128     void AutomaticResume(AudioReference::PriorityGroupType priority_group);
00129
00130     // play: TRUE means play, FALSE means resume
00131     void PlayOrResumeUnconditionally(AudioActiveReference& active_ref, BOOLEAN play);
00132     void PlayUnconditionally(AudioActiveReference& active_ref);
00133     void ResumeUnconditionally(AudioActiveReference& active_ref);
00134     AudioPlayer* GetPlayerWithRoom(const SharedPtr<AudioActiveReference>& new_arrival_ref, SharedPtr<AudioActiveReference>& low_same_group_ref);
00135     BOOLEAN GetPlayerAndPlay(SharedPtr<AudioActiveReference>& new_arrival_ref, SharedPtr<AudioActiveReference>& low_same_group_ref);
00136
00137     BOOLEAN StartManagingReference(AudioActiveReference* active_ref);
00138     void StopManagingReference(AudioActiveReference* active_ref);
00139     LinkedList<SharedPtr<AudioActiveReference> > m_managed_refs;
00140
00141     AudioActiveReference* GetPathControlRelevantRef() const;
00142
00143     // Moved from the cpp-file to here, because of linker errors.
00144     enum AudioPmEventType {
00145         PlayerAudioPmEventType,
00146         ResumeRequestAudioPmEventType
00147     };
00148
00149     struct AudioPmTypeSelectorEvent {
00150         INT m_event_type;
00151     };
00152
00153     struct AudioPmResumeRequestEvent {
00154         INT m_event_type;
00155         UINT m_priority_group;
00156         UINT32 m_desired_resume_time_ms;
00157     };
00158
00159     // cf. AudioPlayerEvent; redefined for use in union
00160     struct AudioPmPlayerEvent {
00161         INT m_event_type;
00162         AudioPlayer* m_player;
00163         AudioActiveReference::HandleInsidePlayer m_handle;
00164         AudioActiveReference::PlaybackState m_playback_state;
00165         AudioPlayerEvent::Reason m_reason;
00166         BOOLEAN m_send_error_message;
00167         AudioError::AudReturnCode m_error_code;
00168     };
00169
00170 public:
00171     union AudioPmEvent {
00172         AudioPmTypeSelectorEvent type_selector;
00173         AudioPmPlayerEvent audio_player_event;
00174         AudioPmResumeRequestEvent resume_request_event;
00175     };
00176 };
00177 #endif //DOXYGEN_SHOULD_SKIP_THIS
00178
00180 #endif  // Apoxi_AudioPriorityManager_hpp
00181
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioReference.cpp File Reference

Audio/AudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioReference.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include "Audio/audio_private.hpp"
#include <Kernel/Os/Semaphore.hpp>
#include <Kernel/Os/SemObtainer.hpp>

Include dependency graph for AudioReference.cpp:

Generated on Tue Jan 24 18:08:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioReference.hpp File Reference

Audio/AudioReference.hpp File Reference

#include <Auxiliary/ObjectReferrer.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Auxiliary/MimeTypeTable.hpp>
#include <Kernel/Condition.hpp>
#include <Config/AudioAccessoriesRegistration.hpp>

Include dependency graph for AudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioReference
class | AudioReference::TotalPlayTimeContainer
Total play time container. More...

Defines

#define | Apoxi_AudioReference_hpp

Define Documentation

#define Apoxi_AudioReference_hpp

Generated on Tue Jan 24 18:08:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioReference.hpp Source File

Audio/AudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioReference_hpp)
00011 #define Apoxi_AudioReference_hpp
00014
00015 // @TODO check if neeeded
00016 #include <Auxiliary/ObjectReferrer.hpp> //For ReferableObject
00017
00018 #include <Auxiliary/SharedPtr.hpp>
00019 #include <Auxiliary/MimeTypeTable.hpp> // for MimeType
00020
00021 //@TODO remove, along with condition member and impl in cpp;
00022 // note: this has unbelievable dependencies
00023 #include <Kernel/Condition.hpp>
00024
00025 #include <Config/AudioAccessoriesRegistration.hpp> //project-specific, in Config directory. For AudioPathControlModeType
00026
00027 class BinData;
00028 class Semaphore;
00029
00030 class AudioReference : public ReferableObject
00031 {
00032     public:
00033         AudioReference();
00034         virtual ~AudioReference();
00035
00037         enum enumClassType
00038         {
00039             ClassType_AudioReference,
00040             ClassType_CustomRingerAudioReference,
00041             ClassType_CustomSmafPhraseAudioReference,
00042             ClassType_CustomSmafMelodyAudioReference,
00043             ClassType_CustomToneAudioReference,
00044             ClassType_PresetAudioReference,
00045             ClassType_RingerAudioReference,
00046             ClassType_SimpleAudioReference,
00047             ClassType_ToneAudioReference,
00048             ClassType_VoiceMemoAudioReference,
00049             ClassType_PCMAudioReference,
00050             ClassType_CustomIMelodyAudioReference,
00051             ClassType_MP3AudioReference,
00052 #ifdef APOXI_YAMAHA_MAPI_SUPPORT
00053             ClassType_MapiAudioReference,
00054             ClassType_InitCommandMapiAudioReference,
00055 #endif
00056 //#ifdef APOXI_LIB_MEDIAFRAMEWORK
00057             ClassType_CombinedDeviceAudioReference,
00058 //#endif
00059             ClassType_End
00060         };
00061
00062         virtual enumClassType GetClassType() const = 0;
00063
00065         enum PredefinedSoundDataSource {
00067             InvalidSoundDataSource = 0,
00069             FileSoundDataSource,
00071             RamSoundDataSource,
00073             StreamSoundDataSource,
00075             PresetSoundDataSource,
00077             BinDataSoundDataSource,
00079             UnknownSoundDataSource,
00081             FmRadioSoundDataSource,
00083             PredefinedSoundDataSourceEnd
00084         };
00085
00089         typedef INT SoundDataSource;
00090
00092         class TotalPlayTimeContainer
00093         {
00094         public:
00095             UINT32 m_total_play_time_1;
00096             UINT32 m_total_play_time_2;
00097             UINT32 m_total_play_time_3;
00098             UINT32 m_total_play_time_4;
00099         };
00100
00101         friend class AudioPriorityManager;
00102         friend class RingerAudioPlayer;
00103         friend class ToneAudioPlayer;
00104
00110         void SetRepeatCount(UINT16 repeat_count = 0)
00111         {
00112             m_repeat_count = repeat_count;
00113         }
00114
00116         UINT16 GetRepeatCount() const
00117         {
00118             return m_repeat_count;
00119         }
00120
00121         BOOLEAN GetRepeatable() const;
00122
00123         virtual BOOLEAN CanPlayTogetherWith(const AudioReference &audio_ref) const;
00124
00125                 void SetExclusionGroup(INT exclusion_group) {
00126             m_exclusion_group = exclusion_group;
00127         }
00128
00129         INT GetExclusionGroup() const {
00130             return m_exclusion_group;
00131         }
00132
00137         void SetContinue(BOOLEAN val = TRUE)
00138         {
00139             m_continue = val;
00140         }
00141
00143         BOOLEAN GetContinue() const
00144         {
00145             return m_continue;
00146         }
00147
00148
00149 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00150
00154         void LockProperties(BOOLEAN lock = TRUE);
00155 #endif //DOXYGEN_SHOULD_SKIP_THIS
00156
00157         typedef UINT VolumeLevel;
00158
00163         void SetVolume(VolumeLevel val);
00164
00168         VolumeLevel GetVolume() const;
00169
00172         BOOLEAN GetVolumeSet() const;
00173
00174         typedef UINT PriorityType;
00175         typedef UINT PriorityGroupType;
00176
00178         void SetPriority(PriorityType val);
00179         PriorityType GetPriority() const;
00180
00198         void SetPriorityGroup(PriorityGroupType group);
00199         PriorityGroupType GetPriorityGroup() const;
00200
00205         void SetIgnoreManagement(BOOLEAN val = TRUE)
00206         {
00207             m_ignore_management = val;
00208         }
00209
00211         BOOLEAN GetIgnoreManagement() const
00212         {
00213             return  m_ignore_management;
00214         }
00215
00216
00217         typedef UINT8 ChannelNumber;
00218
00222         void SetChannel(ChannelNumber val);
00223
00225         ChannelNumber GetChannel() const;
00226
00227
00231         virtual ChannelNumber GetNumberOfChannels() const;
00232
00234         virtual VolumeLevel GetChannelVolume() const;
00235
00237         virtual void SetChannelVolume(VolumeLevel val);
00238
00239         typedef INT16 BalanceLevel;
00240
00246         virtual BalanceLevel GetBalance() const;
00247
00250         virtual void SetBalance(BalanceLevel value);
00251
00252         typedef INT16 ToneLevel;
00253
00255         virtual ToneLevel GetTone() const;
00256
00258         virtual void SetTone(ToneLevel value);
00259
00264         void SetTimeout(UINT32 timeout);
00265
00267         UINT32 GetTimeout() const;
00268
00270
00274         void SetStartPosition(const UINT32 startPosition);
00275
00280         UINT32 GetStartPosition() const;
00281
00290         BOOLEAN GetTotalPlayTime(UINT32 &total1,
00291                                  UINT32 &total2,
00292                                  UINT32 &total3,
00293                                  UINT32 &total4);
00294
00299         void SetPitch(const INT32 pitch);
00300
00305         INT32 GetPitch() const;
00306
00313         void GetPitchRange(INT32 &minPitch, INT32 &maxPitch) const;
00314
00319         void SetTempo(const INT32 tempo);
00320
00325         INT32 GetTempo() const;
00326
00331         void SetRate(const INT32 rate);
00332
00337         INT32 GetRate() const;
00338
00345         void GetRateRange(INT32 &minRate, INT32 &maxRate) const;
00346
00348         AudioPathControl::AudioPathControlModeType GetPathControlMode() const;
00350         void SetPathControlMode(AudioPathControl::AudioPathControlModeType mode);
00351
00359         void SetGetTotalPlayTimeWaitCondition(const UINT32 totalPlayTime1,
00360                                                      const UINT32 totalPlayTime2,
00361                                                      const UINT32 totalPlayTime3,
00362                                                      const UINT32 totalPlayTime4,
00363                                                      BOOLEAN val = TRUE);
00364
00370         void InitGetTotalPlayTimeWaitCondition(UINT32 time);
00371
00376         BOOLEAN InProgress() const;
00377
00378 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00379     protected:
00380         UINT16 m_repeat_count;
00381         BOOLEAN m_continue;
00382
00383         VolumeLevel m_volume;
00384         BOOLEAN m_volume_set; //Otherwise use player's default volume.
00385         BOOLEAN m_ignore_management; //See SetIgnoreManagement().
00386
00387         PriorityType m_priority;
00388         PriorityGroupType m_priority_group;
00389         BalanceLevel m_balance;
00390         ToneLevel m_tone;
00391
00392         ChannelNumber m_channel;
00393
00394         UINT32 m_timeout;
00395
00396         BOOLEAN m_properties_lock;
00397
00398         UINT32 m_start_position;
00399
00400
00401         INT32 m_pitch;
00402         INT32 m_tempo;
00403         INT32 m_rate;
00404
00405     public:
00406         // @todo tota_play_time stuff:
00407         // 1: should not be public
00408         // 2: shoul be improved (4 play times; progress; etc)
00410         Semaphore* m_total_play_time_wait;
00411         TotalPlayTimeContainer m_total_play_times;
00412         BOOLEAN m_get_total_play_time_progress;
00413
00414         MimeType GetMimeType() const {
00415             return m_mime_type;
00416         }
00417
00418         void SetMimeType(MimeType mime_type) {
00419             m_mime_type = mime_type;
00420         }
00421
00422         SoundDataSource GetSoundDataSource() const {
00423             return m_sound_data_source;
00424         }
00425
00426         void SetSoundDataSource(SoundDataSource sound_data_source) {
00427             m_sound_data_source = sound_data_source;
00428         }
00429
00430         void SetBinData(BinData* bin_data) {
00431             m_bin_data = bin_data;
00432         }
00433
00434         BinData* GetBinData() const {
00435             return m_bin_data;
00436         }
00437
00438 #endif //DOXYGEN_SHOULD_SKIP_THIS
00439
00440     private:
00441         AudioPathControl::AudioPathControlModeType m_path_control_mode;
00442         MimeType m_mime_type;
00443         SoundDataSource m_sound_data_source;
00444         BinData* m_bin_data;
00445                 INT m_exclusion_group;
00446 };
00447
00449 #endif  // Apoxi_AudioReference_hpp
00450
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioSignalMapTableNode.cpp File Reference

Audio/AudioSignalMapTableNode.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/DwdPlayer.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Audio/SpeechSimpleAudioDevice.hpp>
#include <Apc/SignalHandler/SignalMapTableEntry.hpp>
#include <Audio/AudioSignalMapTableNode.hpp>

Include dependency graph for AudioSignalMapTableNode.cpp:

Generated on Tue Jan 24 18:08:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioSignalMapTableNode.hpp File Reference

Audio/AudioSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for AudioSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_Target_Gprs_AudioSignalMapTable_hpp

Define Documentation

#define Asc_Target_Gprs_AudioSignalMapTable_hpp

Generated on Tue Jan 24 18:08:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioSignalMapTableNode.hpp Source File

Audio/AudioSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_Target_Gprs_AudioSignalMapTable_hpp)
00009 #define Asc_Target_Gprs_AudioSignalMapTable_hpp
00012
00013 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00014
00015 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00016
00021 class AudioSignalMapTableNode : public SignalMapTableNode {
00022     public:
00023         static AudioSignalMapTableNode* GetInstance();
00024
00025     private:
00026         static AudioSignalMapTableNode *m_node;
00027         static const SignalMapTableEntry m_signal_map_table_entry[];
00028
00029         AudioSignalMapTableNode();
00030 };
00031
00032 #endif //DOXYGEN_SHOULD_SKIP_THIS
00033
00035 #endif  // Asc_Target_Gprs_AudioSignalMapTable_hpp
00036
00037
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioSuspendedDetails.cpp File Reference

Audio/AudioSuspendedDetails.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioSuspendedDetails.hpp>

Include dependency graph for AudioSuspendedDetails.cpp:

Generated on Tue Jan 24 18:08:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioSuspendedDetails.hpp File Reference

Audio/AudioSuspendedDetails.hpp File Reference

#include <Audio/AudioActiveReference.hpp>

Include dependency graph for AudioSuspendedDetails.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_AudioSuspendedDetails_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AudioSuspendedDetails_hpp

Generated on Tue Jan 24 18:08:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioSuspendedDetails.hpp Source File

Audio/AudioSuspendedDetails.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioSuspendedDetails_hpp)
00011 #define Apoxi_AudioNewAPI_AudioSuspendedDetails_hpp
00014
00015 #include <Audio/AudioActiveReference.hpp>
00016
00017 class AudioReference;
00018 //class AudioActiveReference;
00019
00020 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00021
00023 class AudioSuspendedDetails : public Linkable<AudioSuspendedDetails>
00024 {
00025 public:
00026     explicit AudioSuspendedDetails(AudioActiveReference& suspended);
00027     AudioSuspendedDetails(AudioActiveReference& suspended, AudioActiveReference& suspended_by);
00028     virtual ~AudioSuspendedDetails();
00029
00030     SharedPtr<AudioActiveReference> GetSuspendedSound();
00031     SharedPtr<const AudioActiveReference> GetSuspendedSound() const;
00032
00033     void SetSuspendedSound(AudioActiveReference& active_reference);
00034
00035     SharedPtr<const AudioActiveReference> GetSuspendedBy() const;
00036
00037     void SetSuspendedBy(const AudioActiveReference& active_reference);
00038
00039 protected:
00040     SharedPtr<AudioActiveReference> m_active_reference; //The suspended sound
00041     SharedPtr<const AudioActiveReference> m_suspended_by; //This sound that played instead.
00042 };
00043
00044 #endif //DOXYGEN_SHOULD_SKIP_THIS
00045
00047 #endif  // Apoxi_AudioNewAPI_AudioSuspendedDetails_hpp
00048
00049
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioTemplates.cpp File Reference

Audio/AudioTemplates.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioActiveReference.hpp>
#include <Audio/CustomRingerAudioReference.hpp>
#include <Audio/CustomToneAudioReference.hpp>
#include <Audio/CustomSmafPhraseAudioReference.hpp>
#include <Audio/AudioReference.hpp>
#include <Audio/PresetAudioReference.hpp>
#include <Audio/RingerAudioReference.hpp>
#include <Audio/SimpleAudioReference.hpp>
#include <Audio/ToneAudioReference.hpp>
#include <Audio/VoiceMemoAudioReference.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioPlayerStore.hpp>
#include <Audio/DwdDevice.hpp>

Include dependency graph for AudioTemplates.cpp:

Generated on Tue Jan 24 18:08:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioUtility.cpp File Reference

Audio/AudioUtility.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "SpeechSimpleAudioDevice.hpp"
#include <Config/AudioConfig.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/File.hpp>
#include <Auxiliary/Macros.hpp>
#include <Audio/AudioUtility.hpp>
#include <Audio/AudioPathManager.hpp>

Include dependency graph for AudioUtility.cpp:

Generated on Tue Jan 24 18:08:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioUtility.hpp File Reference

Audio/AudioUtility.hpp File Reference

#include <Afs/Rfs/Path.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for AudioUtility.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioUtility

Defines

#define | Apoxi_AudioNewAPI_AudioUtility_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AudioUtility_hpp

Generated on Tue Jan 24 18:08:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioUtility.hpp Source File

Audio/AudioUtility.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioUtility_hpp)
00011 #define Apoxi_AudioNewAPI_AudioUtility_hpp
00014
00015 #include <Afs/Rfs/Path.hpp>
00016 #include <Auxiliary/BinData.hpp>
00017
00018
00021 class AudioUtility
00022 {
00023     public:
00025         enum AudioDataType
00026         {
00028             AudioDataTypeMidi = 0,
00030             AudioDataTypeMp3,
00032             AudioDataTypeSmaf,
00034             AudioDataTypeSmafPhrase,
00036             AudioDataTypeImelody,
00038             AudioDataTypeUnknown
00039         };
00040
00043         virtual ~AudioUtility() = 0;
00044
00054         static BOOLEAN ValidateAudioData(const UINT8 *buffer,
00055                                          const AudioDataType audioDataType);
00056
00066         static BOOLEAN ValidateAudioData(const Path& path,
00067                                          const AudioDataType audioDataType);
00068
00077         static BOOLEAN FindAudioDataOffset(const Path& path,
00078                                            const AudioDataType audioDataType,
00079                                            UINT32 &offset);
00080
00090         static BOOLEAN FindAudioDataOffset(const UINT8 *buffer,
00091                                            const UINT32 bufferSize,
00092                                            const AudioDataType audioDataType,
00093                                            UINT32 &offset);
00094
00107         static UINT16 GetCallVolume(const UINT16 &volume);
00108
00117         static BOOLEAN GetNumbersOfFrames(const Path& path,
00118                                           const AudioDataType audioDataType,
00119                                           const UINT32 offset,
00120                                           UINT32 &numberOfFrames);
00121
00131         static BOOLEAN GetNumbersOfFrames(const UINT8 *buffer,
00132                                           const UINT32 bufferSize,
00133                                           const AudioDataType audioDataType,
00134                                           const UINT32 offset,
00135                                           UINT32 &numberOfFrames);
00136
00137
00144         static UINT32 CalculatePlayTime(BinData* bin_data,
00145                                         MimeType mime_type);
00146
00147         static UINT32 GetUint32FromUint8Array(const UINT8 *data);
00148
00149
00150 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00151     protected:
00154         AudioUtility();
00155
00163         static INT8 FindMp3Offset(const Path& path,
00164                                   UINT32 &offset);
00165
00174         static INT8 FindMp3Offset(const UINT8 *buffer,
00175                                   const UINT32 bufferSize,
00176                                   UINT32 &offset);
00177
00187         static INT8 FindMp3Frame(const UINT8 *buffer,
00188                                  const UINT32 bufferSize,
00189                                  UINT32 &frameHeader,
00190                                  UINT32 &offset);
00191
00197         static INT8 GetFrameLength(const UINT32 &frameHeader,
00198                                    UINT32 &frameLength);
00199
00206         static INT8 GetMp3NumberOfFrames(const Path& path,
00207                                          const UINT32 offset,
00208                                          UINT32 &numberOfFrames);
00209
00217         static INT8 GetMp3NumberOfFrames(const UINT8 *buffer,
00218                                          const UINT32 bufferSize,
00219                                          const UINT32 offset,
00220                                          UINT32 &numberOfFrames);
00221
00222     private:
00224         static const UINT32 m_checkAudioTypePattern [5];
00225
00227         static const UINT32 m_samplingRateFrequency [3][3];
00228
00230         static const UINT16 m_bitRate [16][5];
00231
00233         static const UINT32 m_readBufferSize;
00234 #endif //DOXYGEN_SHOULD_SKIP_THIS
00235 };
00236
00238 #endif  // Apoxi_AudioNewAPI_AudioUtility_hpp
00239
00240
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioVibratorDevice.cpp File Reference

Audio/AudioVibratorDevice.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioVibratorDevice.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Kernel/Os/Os.hpp>
#include <Audio/AudioActiveReference.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for AudioVibratorDevice.cpp:

Generated on Tue Jan 24 18:09:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioVibratorDevice.hpp File Reference

Audio/AudioVibratorDevice.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Audio/AudioDeviceBase.hpp>
#include <Audio/DwdDevice.hpp>

Include dependency graph for AudioVibratorDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioVibratorDevice

Defines

#define | Apoxi_AudioNewAPI_AudioVibratorDevice_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AudioVibratorDevice_hpp

Generated on Tue Jan 24 18:09:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/AudioVibratorDevice.hpp Source File

Audio/AudioVibratorDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AudioVibratorDevice_hpp)
00011 #define Apoxi_AudioNewAPI_AudioVibratorDevice_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 //#include <Apoxi/Auxiliary/NonCloneable.hpp>
00017 #include <Auxiliary/SharedPtr.hpp>
00018 #include <Audio/AudioDeviceBase.hpp>
00019 #include <Audio/DwdDevice.hpp>
00020
00021 /*** AudioVibratorDevice class is used to control Vibrator only for E-Gold based platforms
00022  * On all other platforms use the VibratorDevice class.
00023  * VibratorDevice class unlike the AudioVibratorDevice class is not part of ApoxiAudio.
00024  * Refer to Vibrator device reference manual
00025  */
00026 class AudioVibratorDevice : public AudioDeviceBase, public DwdDevice
00027 {
00028     public:
00029
00034         enum VibratorMode
00035         {
00037             VibratorModeAsync1,
00041             VibratorModeAsync2,
00043             VibratorModeSync1,
00045             VibratorModeSync2
00046         };
00047
00048         //TODO: Are these sensible default values? Murray.
00057         BOOLEAN StartVibrator(VibratorMode mode = VibratorModeAsync2,  INT16 on = -1, INT16 off = 0);
00058
00062         void StopVibrator();
00063
00065         BOOLEAN IsVibratorOn();
00066
00067         virtual AudioSourceType GetSource() const; //override
00068
00069         virtual BOOLEAN Play_Allocate(AudioActiveReference &active_reference);
00070
00071     protected:
00072
00073         typedef INT8 AudReturnCode;
00074
00075         SharedPtr<AudioActiveReference> m_active_ref;
00076
00077         virtual UINT16 GetDeviceID() const; //overwrite
00078 };
00079
00081
00082 #endif  // Apoxi_AudioNewAPI_VibratorDevice_hpp
00083
00084
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CombinedDeviceAudioReference.cpp File Reference

Audio/CombinedDeviceAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/CombinedDeviceAudioReference.hpp>

Include dependency graph for CombinedDeviceAudioReference.cpp:

Generated on Tue Jan 24 18:09:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CombinedDeviceAudioReference.hpp File Reference

Audio/CombinedDeviceAudioReference.hpp File Reference

#include <Audio/StreamAudioReference.hpp>

Include dependency graph for CombinedDeviceAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_CombinedDeviceAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_CombinedDeviceAudioReference_hpp

Generated on Tue Jan 24 18:09:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CombinedDeviceAudioReference.hpp Source File

Audio/CombinedDeviceAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_CombinedDeviceAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_CombinedDeviceAudioReference_hpp
00014
00015 #include <Audio/StreamAudioReference.hpp>
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00021 class CombinedDeviceAudioReference : public StreamAudioReference
00022 {
00023     public:
00024
00028         CombinedDeviceAudioReference(MimeType mime_type, SoundDataSource sound_data_source);
00029
00033         CombinedDeviceAudioReference(BufferType buffer_handle, BufferByteType buffer_size, MimeType mime_type, SoundDataSource sound_data_source);
00034
00035         virtual ~CombinedDeviceAudioReference();
00036
00037         virtual enumClassType GetClassType() const;
00038
00039         typedef INT32 HandleType;
00040
00041         typedef UINT32 TimeStampType;
00042
00049         void SetDriverHandle(HandleType handle);
00050
00055         void SetTime(TimeStampType time);
00056
00061         HandleType GetDriverHandle() const;
00062
00067         TimeStampType GetTime() const;
00068
00069     protected:
00070
00072         HandleType m_handle;
00073
00075         TimeStampType m_time;
00076 };
00077 #endif //DOXYGEN_SHOULD_SKIP_THIS
00078
00080 #endif  // Apoxi_AudioNewAPI_CombinedDeviceAudioReference_hpp
00081
00082
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomIMelodyAudioReference.cpp File Reference

Audio/CustomIMelodyAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/CustomIMelodyAudioReference.hpp>
#include <Config/AudioCapabilities.hpp>
#include <Audio/RingerAudioPlayer.hpp>
#include <Audio/audio_private.hpp>
#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for CustomIMelodyAudioReference.cpp:

Generated on Tue Jan 24 18:09:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomIMelodyAudioReference.hpp File Reference

Audio/CustomIMelodyAudioReference.hpp File Reference

#include <Audio/CustomRingerAudioReference.hpp>

Include dependency graph for CustomIMelodyAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_CustomIMelodyAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_CustomIMelodyAudioReference_hpp

Generated on Tue Jan 24 18:09:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomIMelodyAudioReference.hpp Source File

Audio/CustomIMelodyAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_CustomIMelodyAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_CustomIMelodyAudioReference_hpp
00014
00015 #include <Audio/CustomRingerAudioReference.hpp>
00016
00017
00018 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00019
00021 class CustomIMelodyAudioReference : public CustomRingerAudioReference
00022 {
00023     friend class CustomRingerAudioReference;
00024
00025     public:
00026         virtual ~CustomIMelodyAudioReference();
00027
00028         virtual enumClassType GetClassType() const;
00029
00030     protected:
00031         CustomIMelodyAudioReference(AudioPlayer::ConstBuffer buffer, UINT32 buffer_size);
00032         CustomIMelodyAudioReference(AudioPlayer::Buffer buffer, UINT32 buffer_size, BOOLEAN take_ownership);
00033
00034 };
00035 #endif //DOXYGEN_SHOULD_SKIP_THIS
00036
00037 #endif  // Apoxi_AudioNewAPI_CustomIMelodyAudioReference_hpp
00038
00039
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomRingerAudioReference.cpp File Reference

Audio/CustomRingerAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/CustomRingerAudioReference.hpp>
#include <Audio/CustomIMelodyAudioReference.hpp>
#include <Audio/RingerAudioPlayer.hpp>
#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for CustomRingerAudioReference.cpp:

Generated on Tue Jan 24 18:09:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomRingerAudioReference.hpp File Reference

Audio/CustomRingerAudioReference.hpp File Reference

#include <Audio/AudioReference.hpp>
#include <Audio/AudioPlayer.hpp>

Include dependency graph for CustomRingerAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CustomRingerAudioReference

Defines

#define | Apoxi_AudioNewAPI_CustomRingerAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_CustomRingerAudioReference_hpp

Generated on Tue Jan 24 18:09:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomRingerAudioReference.hpp Source File

Audio/CustomRingerAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_CustomRingerAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_CustomRingerAudioReference_hpp
00014
00015 #include <Audio/AudioReference.hpp>
00016 #include <Audio/AudioPlayer.hpp>
00017
00021 class CustomRingerAudioReference : public AudioReference
00022 {
00023     public:
00024         virtual ~CustomRingerAudioReference();
00025
00027         enum Format {
00029             FormatSmaf,
00031             FormatMidi,
00033             FormatRmd,
00035             FormatImelody,
00037             FormatBuzzer,
00039             FormatSmafPhrase,
00040         };
00041
00042
00051         static SharedPtr<CustomRingerAudioReference> Create(AudioPlayer::ConstBuffer buffer, UINT32 buffer_size, Format format);
00052
00062         static SharedPtr<CustomRingerAudioReference> Create(AudioPlayer::Buffer buffer, UINT32 buffer_size, Format format, BOOLEAN take_ownership);
00063
00064
00065         virtual enumClassType GetClassType() const;
00066
00067         AudioPlayer::ConstBuffer GetBuffer() const;
00068         UINT32 GetBufferSize() const;
00069         Format GetFormat() const;
00070
00071     protected:
00072         CustomRingerAudioReference(AudioPlayer::ConstBuffer buffer, UINT32 buffer_size, Format format);
00073         CustomRingerAudioReference(AudioPlayer::Buffer buffer, UINT32 buffer_size, Format format, BOOLEAN take_ownership);
00074
00075     protected:
00076         AudioPlayer::ConstBuffer m_buffer;
00077         UINT32 m_buffer_size;
00078         Format m_format;
00079         BOOLEAN m_data_owned;
00080 };
00081
00083 #endif  // Apoxi_AudioNewAPI_CustomRingerAudioReference_hpp
00084
00085
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomSmafPhraseAudioReference.cpp File Reference

Audio/CustomSmafPhraseAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/CustomSmafPhraseAudioReference.hpp>
#include <Config/AudioCapabilities.hpp>
#include <Audio/RingerAudioPlayer.hpp>
#include <Audio/audio_private.hpp>
#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for CustomSmafPhraseAudioReference.cpp:

Generated on Tue Jan 24 18:09:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomSmafPhraseAudioReference.hpp File Reference

Audio/CustomSmafPhraseAudioReference.hpp File Reference

#include <Audio/CustomRingerAudioReference.hpp>

Include dependency graph for CustomSmafPhraseAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CustomSmafPhraseAudioReference

Defines

#define | Apoxi_AudioNewAPI_CustomSmafPhraseAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_CustomSmafPhraseAudioReference_hpp

Generated on Tue Jan 24 18:09:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomSmafPhraseAudioReference.hpp Source File

Audio/CustomSmafPhraseAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_CustomSmafPhraseAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_CustomSmafPhraseAudioReference_hpp
00014
00015 #include <Audio/CustomRingerAudioReference.hpp>
00016
00017
00021 class CustomSmafPhraseAudioReference : public CustomRingerAudioReference
00022 {
00023     public:
00024         virtual ~CustomSmafPhraseAudioReference();
00025
00030         static SharedPtr<CustomSmafPhraseAudioReference> Create(AudioPlayer::ConstBuffer buffer, UINT32 buffer_size);
00031
00037         static SharedPtr<CustomSmafPhraseAudioReference> Create(AudioPlayer::Buffer buffer, UINT32 buffer_size, BOOLEAN take_ownership);
00038
00039
00040         virtual enumClassType GetClassType() const;
00041
00045         virtual ChannelNumber GetNumberOfChannels() const;
00046
00047         virtual VolumeLevel GetChannelVolume() const;
00048
00049         virtual void SetChannelVolume(VolumeLevel val);
00050
00051         virtual BOOLEAN CanPlayTogetherWith(const AudioReference &audio_ref) const;
00052
00053     protected:
00054         VolumeLevel m_channelVolume;
00055
00056         CustomSmafPhraseAudioReference(AudioPlayer::ConstBuffer buffer, UINT32 buffer_size);
00057         CustomSmafPhraseAudioReference(AudioPlayer::Buffer buffer, UINT32 buffer_size, BOOLEAN take_ownership);
00058
00059 };
00060
00062 #endif  // Apoxi_AudioNewAPI_CustomSmafPhraseAudioReference_hpp
00063
00064
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomToneAudioReference.cpp File Reference

Audio/CustomToneAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/CustomToneAudioReference.hpp>
#include <Audio/ToneAudioPlayer.hpp>
#include <Config/AudioConfig.hpp>

Include dependency graph for CustomToneAudioReference.cpp:

Generated on Tue Jan 24 18:09:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomToneAudioReference.hpp File Reference

Audio/CustomToneAudioReference.hpp File Reference

#include <Audio/AudioReference.hpp>

Include dependency graph for CustomToneAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CustomToneAudioReference

Defines

#define | Apoxi_AudioNewAPI_CustomToneAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_CustomToneAudioReference_hpp

Generated on Tue Jan 24 18:09:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/CustomToneAudioReference.hpp Source File

Audio/CustomToneAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_CustomToneAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_CustomToneAudioReference_hpp
00014
00015 #include <Audio/AudioReference.hpp>
00016
00017
00021 class CustomToneAudioReference : public AudioReference
00022 {
00023     public:
00024         virtual ~CustomToneAudioReference();
00025
00027         enum ToneType {
00029             NormalTone,
00031             DualTone,
00033             TripleTone
00034         };
00035
00036         typedef INT16 DefaultAmplitude;
00037
00090         static SharedPtr<CustomToneAudioReference> Create(const void *tone_data, ToneType tone_type, UINT32 no_of_tones);
00091
00092         virtual enumClassType GetClassType() const;
00093
00095         const void* GetBuffer() const;
00096
00098         static CustomToneAudioReference::DefaultAmplitude GetDefaultAmplitude();
00099
00100         ToneType GetToneType() const;
00101         void SetToneType(CustomToneAudioReference::ToneType type);
00102
00103         UINT32 GetNumberOfTones() const;
00104         void SetNumberOfTones(UINT32 no_of_tones);
00105
00106     protected:
00107         CustomToneAudioReference(const void *tone_data, ToneType tone_type, UINT32 no_of_tones);
00108
00109     protected:
00110         const void *m_tone_data;
00111         ToneType m_tone_type;
00112         UINT32 m_no_of_tones;
00113 };
00114
00116 #endif  // Apoxi_AudioNewAPI_CustomToneAudioReference_hpp
00117
00118
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/DwdDevice.cpp File Reference

Audio/DwdDevice.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/DwdDevice.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for DwdDevice.cpp:

Generated on Tue Jan 24 18:09:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/DwdDevice.hpp File Reference

Audio/DwdDevice.hpp File Reference

#include <Audio/AudioDeviceBase.hpp>
#include <Audio/AudioError.hpp>
#include <Auxiliary/SimpleMap.hpp>

Include dependency graph for DwdDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DwdDevice

Defines

#define | Apoxi_DwdDevice_hpp

Define Documentation

#define Apoxi_DwdDevice_hpp

Generated on Tue Jan 24 18:09:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/DwdDevice.hpp Source File

Audio/DwdDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DwdDevice_hpp)
00011 #define Apoxi_DwdDevice_hpp
00014
00015 #include <Audio/AudioDeviceBase.hpp>
00016 #include <Audio/AudioError.hpp>
00017
00018 #include <Auxiliary/SimpleMap.hpp>
00019
00023 class DwdDevice
00024 {
00025     public:
00026         DwdDevice();
00027         virtual ~DwdDevice();
00028
00029     protected:
00030
00031         BOOLEAN HandleAudReturnCode(const AudioReference& audio_reference, const AudioError::AudReturnCode return_code);
00032
00033         typedef UINT16 DwdIDType;
00034         typedef UINT8 DwdHandleType; //TODO: Avoid duplication in AudioDeviceBase.
00035
00036         //These are allocated, refcount, reused and released when no longer used:
00037         //DwdIDType m_dwd_handle_id; //The ID has a 1-to-1 relationship with the handle.
00038         DwdHandleType m_dwd_handle;
00039         //UINT m_dwd_handle_refcount, m_dwd_handle_id_refcount; //The ID lives longer than the handle, so we refcount it separately.
00040
00041         typedef INT AudResource; //It's really an enum, but this allows us to hide the aud header.
00042
00043         void GenerateHandleId(AudioActiveReference &active_reference);
00044
00045         BOOLEAN Play_Allocate_DWD(AudioActiveReference &active_reference, AudResource aud_resource);
00046
00047         //Accessed by active reference that is why it is public.
00048         void DeAllocateDwd(AudioActiveReference &audio_ref);
00049
00050         //Accessed by active reference that is why it is public.
00051         void DeAllocateDwdID(AudioActiveReference &audio_ref);
00052
00053         static void AddReferenceMapping(AudioActiveReference &active_reference, INT32 handle_id);
00054         static void RemoveReferenceMapping(UINT32 handle_id);
00055         static SharedPtr<AudioActiveReference> FindReference(INT32 handle_id);
00056
00057         //Accessed by active reference that is why it is public.
00058         virtual BOOLEAN Play_Allocate(AudioActiveReference &audio_ref) = 0;
00059
00060                 //void SetVolume_Implementation(AudioDeviceBase::VolumeLevel volume);
00061     private:
00062
00063         static INT32 m_ref_count;
00064         static SimpleMap<INT32, AudioActiveReference*> m_id_to_ref_map;
00065
00066 };
00067
00069 #endif  // Apoxi_DwdPlayer_hpp
00070
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/DwdPlayer.cpp File Reference

Audio/DwdPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/DwdPlayer.hpp>
#include <Kernel/System.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioAccessoryDetails.hpp>
#include <Audio/Messages/AudioMsg.hpp>
#include <Audio/Messages/AudioMessages.hpp>
#include <Audio/Messages/AudioGetPlayPositionMsg.hpp>
#include <Audio/Messages/AudioStreamingSyncMsg.hpp>
#include <Audio/Messages/AudioRestartedMsg.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioPlayerEvent.hpp>
#include <Audio/AudioUtility.hpp>

Include dependency graph for DwdPlayer.cpp:

Generated on Tue Jan 24 18:09:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/DwdPlayer.hpp File Reference

Audio/DwdPlayer.hpp File Reference

#include <Audio/AudioPlayer.hpp>
#include <Audio/DwdDevice.hpp>
#include <Apc/SignalHandler/SignalMapTableEntry.hpp>

Include dependency graph for DwdPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DwdPlayer

Defines

#define | Apoxi_DwdPlayer_hpp

Variables

const UINT8 | c_max_slots = 5

Define Documentation

#define Apoxi_DwdPlayer_hpp

Generated on Tue Jan 24 18:09:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/DwdPlayer.hpp Source File

Audio/DwdPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DwdPlayer_hpp)
00011 #define Apoxi_DwdPlayer_hpp
00014
00015 #include <Audio/AudioPlayer.hpp>
00016 #include <Audio/DwdDevice.hpp>
00017 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>    // For ProcessPtr
00018
00019 const UINT8 c_max_slots = 5;//The maximum number of suspend slot for each player
00020
00024 class DwdPlayer : public AudioPlayer, public DwdDevice
00025 {
00026     public:
00027         DwdPlayer();
00028         virtual ~DwdPlayer();
00029
00030         virtual BOOLEAN CanPlay(const AudioActiveReference& active_reference) const;
00031         virtual BOOLEAN CanSuspend(const AudioActiveReference& active_reference) const;
00032         virtual BOOLEAN CanResume(const AudioActiveReference& active_reference) const;
00033
00034 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00035         // from AudioDeviceBase
00036         virtual BOOLEAN ApplyDeviceVolume();
00037         virtual BOOLEAN ApplyMasterVolume();
00038         virtual BOOLEAN UpdateReferenceVolume(const AudioActiveReference& active_reference, VolumeLevel volume);
00039
00040         virtual BOOLEAN SetMute(BOOLEAN enable = TRUE, MuteDirection direction = UpDownlinkDirection);
00041
00045         static void OnSdlSignal_Audio(const ProcessPtr &process_ptr);
00046
00047 #endif //DOXYGEN_SHOULD_SKIP_THIS
00048
00049     protected:
00050
00051         virtual BOOLEAN OnSdlSignal(UINT16 func_id, UINT8 handle, UINT16 drv_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00052
00053         typedef UINT8 SuspendSlotType;
00054
00056         void AllocateSuspendSlot(SuspendSlotType suspendSlot, AudioActiveReference* ref_ptr);
00057
00059         void ReleaseSuspendSlot(AudioActiveReference* ref_ptr);
00060
00061         void AllocateSuspendSlot(SuspendSlotType suspend_slot);
00062         void ReleaseSuspendSlot(DwdPlayer::SuspendSlotType suspend_slot);
00063
00068         BOOLEAN GetAvailableSuspendSlot(SuspendSlotType &suspend_slot);
00069         BOOLEAN GetAllocatedSuspendSlot(AudioActiveReference* ref_ptr, SuspendSlotType &suspend_slot);
00070
00071         virtual BOOLEAN SetVolume_Implementation(VolumeLevel volume);
00072
00073     private:
00074         AudioActiveReference* m_suspend_slot_info[c_max_slots];
00075
00076 };
00077
00079 #endif  // Apoxi_DwdPlayer_hpp
00080
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/FlagCaretaker.cpp File Reference

Audio/FlagCaretaker.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/FlagCaretaker.hpp>

Include dependency graph for FlagCaretaker.cpp:

Generated on Tue Jan 24 18:09:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/FlagCaretaker.hpp File Reference

Audio/FlagCaretaker.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class FlagCaretaker

Generated on Tue Jan 24 18:09:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/FlagCaretaker.hpp Source File

Audio/FlagCaretaker.hpp

Go to the documentation of this file.
00001 #ifndef FlagCaretaker_hpp
00002 #define FlagCaretaker_hpp
00003
00004
00005 class FlagCaretaker {
00006 public:
00007     FlagCaretaker(BOOLEAN &flag, BOOLEAN value_to_set);
00008     ~FlagCaretaker();
00009 private:
00010     BOOLEAN &m_flag;
00011     BOOLEAN m_value_to_set;
00012 };
00013
00014 #endif
00015
00016
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/FmRadioAudioPlayer.cpp File Reference

Audio/FmRadioAudioPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/FmRadioAudioPlayer.hpp>
#include <Audio/Messages/AudioMessages.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/SimpleAudioReference.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/GenericFeatureData.hpp>
#include <Config/AudioConfig.hpp>

Include dependency graph for FmRadioAudioPlayer.cpp:

Defines

#define | FREQUENCY_BEGIN 87600000
#define | RDS_VALIDATE_LIMIT 4

Define Documentation

#define FREQUENCY_BEGIN 87600000

#define RDS_VALIDATE_LIMIT 4

Generated on Tue Jan 24 18:09:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/FmRadioAudioPlayer.hpp File Reference

Audio/FmRadioAudioPlayer.hpp File Reference

#include <Audio/DwdPlayer.hpp>

Include dependency graph for FmRadioAudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_FmRadioAudioPlayer_hpp

Define Documentation

#define Apoxi_FmRadioAudioPlayer_hpp

Generated on Tue Jan 24 18:09:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/FmRadioAudioPlayer.hpp Source File

Audio/FmRadioAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FmRadioAudioPlayer_hpp)
00011 #define Apoxi_FmRadioAudioPlayer_hpp
00014
00015 #include <Audio/DwdPlayer.hpp>
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00019 class GenericFeatureData;
00020
00025 class FmRadioAudioPlayer : public DwdPlayer
00026 {
00027     public:
00028         static AudioDeviceBase* GetInstance();
00029         virtual AudioSourceType GetSource() const;
00030         virtual Vector<MimeTypeSupportInfo> GetMimeTypeSupportInfo() const;
00031
00033         virtual BOOLEAN CanSuspend(const AudioActiveReference& active_reference) const;
00034         virtual BOOLEAN CanResume(const AudioActiveReference& active_reference) const;
00035
00037         virtual void Play(AudioActiveReference& active_reference);
00038
00040         virtual void Stop(AudioActiveReference& active_reference);
00041
00043         virtual BOOLEAN IsFeatureSupported(Feature feature, MimeType mime_type = c_mime_unknown,
00044             AudioReference::SoundDataSource sound_data_source = AudioReference::InvalidSoundDataSource) const;
00045         virtual BOOLEAN ExecuteFeature(Feature feature, GenericObject* data = 0);
00046
00047         virtual SharedPtr<AudioReference> CreateAudioReferenceFromExtensionSoundDataSource(
00048             MimeType mime_type, AudioReference::SoundDataSource sound_data_source);
00049
00050     protected:
00051
00052             struct rds_group_0_type {
00053                     // Block A
00054                     UINT16 pi;
00055                     // Block B - LSB first
00056                     UINT16 segment_address  : 2;
00057                     UINT16 decoder_id  : 1;
00058                     UINT16 music_speech_switch  : 1;
00059                     UINT16 traffic_announcement  : 1;
00060                     UINT16 program_type  : 5;
00061                     UINT16 traffic_pi  : 1;
00062                     UINT16 ab_version  : 1;
00063                     UINT16 group_type  : 4;
00064                     // Block C
00065                     UINT16 alt_freq_or_pi;
00066                     // Block D - LSB first
00067                     UINT16 program_service_name_2  : 8;
00068                     UINT16 program_service_name_1  : 8;
00069             };
00070
00071             struct rds_group_2_type {
00072                     // Block A
00073                     UINT16 pi;
00074                     // Block B - LSB first
00075                     UINT16 segment_address  : 4;
00076                     UINT16 ab_text  : 1;
00077                     UINT16 program_type  : 5;
00078                     UINT16 traffic_pi  : 1;
00079                     UINT16 ab_version  : 1;
00080                     UINT16 group_type  : 4;
00081                     // Block C - LSB first
00082                     UINT16 radiotext_2  : 8;
00083                     UINT16 radiotext_1  : 8;
00084                     // Block D - LSB first
00085                     UINT16 radiotext_4  : 8;
00086                     UINT16 radiotext_3  : 8;
00087             };
00088
00089             virtual UINT16 GetDeviceID() const;
00090
00091       virtual BOOLEAN Play_Allocate(AudioActiveReference &active_reference);
00092       virtual BOOLEAN Play_Implementation(AudioActiveReference &active_reference);
00093       virtual BOOLEAN Stop_Implementation(AudioActiveReference &active_reference);
00094
00095       virtual BOOLEAN OnSdlSignal(UINT16 func_id, UINT8 handle, UINT16 drv_id,
00096           INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00097
00099       BOOLEAN SeekStationFeature(GenericFeatureData* data);
00100       BOOLEAN SetStationFeature(GenericFeatureData* data);
00101       BOOLEAN RssiLevelFeature(GenericFeatureData* data);
00102             BOOLEAN RdsFeature(GenericFeatureData* data);
00103             BOOLEAN RdsStationNameFeature(GenericFeatureData* data);
00104             BOOLEAN RdsRadioTextFeature(GenericFeatureData* data);
00105             BOOLEAN RdsRawDataFeature(GenericFeatureData* data);
00106             BOOLEAN RdsAlternativeFreqFeature(GenericFeatureData* data);
00107
00108             static void OnRdsTimer(void* client_args);
00109             void DecodeRdsData();
00110             void UpdatePi(rds_group_0_type* rds_data);
00111             void UpdatePty(rds_group_0_type* rds_data);
00112             void UpdateTrafficProgram(rds_group_0_type* rds_data);
00113             void UpdateTrafficAnnouncement(rds_group_0_type* rds_data);
00114             void UpdateStationName(rds_group_0_type* rds_data);
00115             void UpdateRadioText(rds_group_2_type* rds_data);
00116             void UpdateAlternativeFrequencies(rds_group_0_type* rds_data);
00117
00118             static void GetRdsData(UINT8* buffer, UINT16 buffer_size);
00119
00120     private:
00122       FmRadioAudioPlayer();
00123
00125       FmRadioAudioPlayer(const FmRadioAudioPlayer& obj);
00126
00128       virtual ~FmRadioAudioPlayer();
00129
00131       static FmRadioAudioPlayer m_singleton_instance;
00132
00133             static UINT8* m_rds_buffer;
00134             static UINT16 m_buffer_size;
00135
00136             SystemTimer m_rds_timer;
00137
00138             BOOLEAN m_decode_station_name;
00139             BOOLEAN m_decode_radio_text;
00140             BOOLEAN m_send_raw_data;
00141             BOOLEAN m_send_alternative_freq;
00142       BOOLEAN m_is_decoding;
00143
00144             BOOLEAN m_pi_changed;
00145             BOOLEAN m_station_name_complete;
00146             BOOLEAN m_radio_text_complete;
00147             BOOLEAN m_alt_freq_complete;
00148             BOOLEAN m_traffic_program;
00149             BOOLEAN m_traffic_announcement;
00150             BOOLEAN m_is_group_a;
00151             UINT16 m_program_identifier;
00152             UINT16 m_program_type;
00153             char m_station_name[9];
00154             char m_radio_text[65];
00155             UINT32* m_alt_freq;
00156             UINT32 m_nr_of_alt_freq;
00157 };
00158
00159 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00160
00162 #endif  // Apoxi_FmRadioAudioPlayer_hpp
00163
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/GenericFeatureData.cpp File Reference

Audio/GenericFeatureData.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/GenericFeatureData.hpp>

Include dependency graph for GenericFeatureData.cpp:

Generated on Tue Jan 24 18:09:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/GenericFeatureData.hpp File Reference

Audio/GenericFeatureData.hpp File Reference

#include <Auxiliary/GenericObject.hpp>
#include <Auxiliary/WString.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for GenericFeatureData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GenericFeatureData
struct | GenericFeatureData::GenericTrackInfo
This structure is used for setting/getting the track information of a sound. More...

Defines

#define | Apoxi_GenericFeatureData_hpp

Define Documentation

#define Apoxi_GenericFeatureData_hpp

Generated on Tue Jan 24 18:09:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/GenericFeatureData.hpp Source File

Audio/GenericFeatureData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_GenericFeatureData_hpp)
00011 #define Apoxi_GenericFeatureData_hpp
00014
00015 #include <Auxiliary/GenericObject.hpp>
00016 #include <Auxiliary/WString.hpp>
00017 #include <Audio/AudioActiveReference.hpp>
00018
00022 class GenericFeatureData : public GenericObject
00023 {
00024     public:
00026     GenericFeatureData();
00027
00028         GenericFeatureData(const GenericFeatureData&);
00029
00031     virtual ~GenericFeatureData();
00032
00034     virtual GenericObject* Copy() const;
00036     virtual BOOLEAN IsEqual(GenericObject * object);
00038     virtual GenericTypeId GetTypeId();
00039
00041         struct GenericTrackInfo {
00042             WString m_title;
00043             WString m_author;
00044             WString m_copyright;
00045             WString m_rating;
00046             WString m_description;
00047             WString m_song_name;
00048             WString m_artist;
00049             WString m_album;
00050             WString m_year;
00051             WString m_comment;
00052             WString m_genre;
00053             WString m_track;
00054             WString m_duration;
00055             WString m_composer;
00056             WString m_original_artist;
00057             WString m_url;
00058         };
00059
00061         void SetDataPtr(void* data);
00063         void SetNumber(UINT32 data);
00065         void SetGenericTrackInfo(const GenericFeatureData::GenericTrackInfo& track_info);
00067         void SetActiveReference(const AudioActiveReference* active_ref);
00068
00070         void* GetDataPtr() const;
00072         UINT32 GetNumber() const;
00074         const GenericFeatureData::GenericTrackInfo* GetGenericTrackInfo() const;
00076         const AudioActiveReference* GetActiveReference() const;
00077
00078     private:
00079         void* m_void_ptr;
00080         UINT32 m_number;
00081         GenericTrackInfo* m_track_info;
00082         const AudioActiveReference* m_active_ref;
00083
00084         void CopyGenericTrackInfo(const GenericFeatureData::GenericTrackInfo& track_info);
00085 };
00086
00087 #endif
00088
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/MmfPlayer.cpp File Reference

Audio/MmfPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/MmfPlayer.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioUtility.hpp>
#include <Audio/AudioReference.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/Messages/AudioGetPlayPositionMsg.hpp>
#include <Audio/Messages/AudioMessages.hpp>
#include <Audio/Messages/AudioRestartedMsg.hpp>
#include <AddOns/MediaFramework/MediaPlayer.hpp>
#include <AddOns/MediaFramework/MsgTypes.hpp>
#include <Audio/Mp3AudioReference.hpp>
#include <Audio/VoiceMemoAudioReference.hpp>
#include <Audio/GenericFeatureData.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Auxiliary/RamData.hpp>
#include <Kernel/ServiceThread.hpp>
#include <Kernel/ServiceThreadStarter.hpp>

Include dependency graph for MmfPlayer.cpp:

Generated on Tue Jan 24 18:10:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/MmfPlayer.hpp File Reference

Audio/MmfPlayer.hpp File Reference

#include <Audio/AudioPlayer.hpp>
#include <Kernel/MessageHook.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <AddOns/MediaFramework/MediaManager.hpp>
#include <AddOns/MediaFramework/MediaInfo.hpp>

Include dependency graph for MmfPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmfPlayer
struct | MmfPlayer::MediaPlayerInstanceData

Defines

#define | Apoxi_MmfPlayer_hpp

Define Documentation

#define Apoxi_MmfPlayer_hpp

Generated on Tue Jan 24 18:10:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/MmfPlayer.hpp Source File

Audio/MmfPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MmfPlayer_hpp)
00011 #define Apoxi_MmfPlayer_hpp
00014
00015 #include <Audio/AudioPlayer.hpp>
00016 #include <Kernel/MessageHook.hpp>
00017 #include <Auxiliary/SimpleMap.hpp>
00018 #include <AddOns/MediaFramework/MediaManager.hpp>
00019 #include <AddOns/MediaFramework/MediaInfo.hpp>
00020
00021 class GenericFeatureData;
00022
00025 class MmfPlayer : public AudioPlayer
00026 {
00027     public:
00028         virtual BOOLEAN IsFeatureSupported(Feature feature, MimeType mime_type = c_mime_unknown, AudioReference::SoundDataSource sound_data_source = AudioReference::InvalidSoundDataSource) const;
00029         virtual BOOLEAN ExecuteFeature(Feature feature, GenericObject* data = 0);
00030
00031         virtual BOOLEAN GetTotalPlayTime(AudioActiveReference &active_reference);
00032         virtual BOOLEAN GetPlayPosition(AudioActiveReference &active_reference);
00033
00034         virtual void Play(AudioActiveReference& active_reference);
00035         virtual void Stop(AudioActiveReference& active_reference);
00036         virtual BOOLEAN CanPlay(const AudioActiveReference& active_reference) const;
00037         virtual BOOLEAN CanSuspend(const AudioActiveReference& active_reference) const;
00038         virtual BOOLEAN CanResume(const AudioActiveReference& active_reference) const;
00039         virtual void Suspend(AudioActiveReference& active_reference);
00040         virtual void ResumeSuspended(AudioActiveReference& active_reference);
00041         virtual void StopSuspended(AudioActiveReference& active_reference);
00042
00043         virtual Vector<MimeTypeSupportInfo> GetMimeTypeSupportInfo() const;
00044
00045         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRfsFile(MimeType mime_type, const Path& path);
00046         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, ConstBuffer buffer, UINT32 buffer_size);
00047         virtual SharedPtr<AudioReference> CreateAudioReferenceFromBinData(MimeType mime_type, BinData* bin_data);
00048
00049         BOOLEAN OnMessage(const Message &message);
00050         static AudioDeviceBase* GetInstance();
00051
00052         virtual AudioSource GetSource() const { return AudioDeviceBase::DspAudioSource; }
00053         virtual UINT16 GetDeviceID() const { return 0; }
00054
00055     protected:
00056         virtual BOOLEAN ApplyDeviceVolume();
00057
00058         BOOLEAN FastForward(GenericFeatureData* data);
00059         BOOLEAN Rewind(GenericFeatureData* data);
00060         BOOLEAN GetTrackInfo(GenericFeatureData* data);
00061         BOOLEAN GetAudioTrackInfo(GenericFeatureData* data);
00062
00063         struct MediaPlayerInstanceData {
00064             MediaInfo* info;
00065             MediaPlayer* m_media_player;
00066             BinData* m_bin_data;
00067             BOOLEAN m_bin_data_provided;
00068             AudioActiveReference* m_active_ref;
00069         };
00070
00071         void AddDataMapping(MmfPlayer::MediaPlayerInstanceData& instance_data, MediaPlayer* media_player);
00072         void RemoveDataMapping(MediaPlayer* media_player);
00073         MmfPlayer::MediaPlayerInstanceData FindData(MediaPlayer* media_player);
00074
00075     private:
00077         MmfPlayer();
00078
00080         virtual ~MmfPlayer();
00081
00083         MmfPlayer(const MmfPlayer& obj);
00084
00085         void OnPlaybackStopped(MediaPlayer* media_player);
00086
00087         // this has to be avoided as soon as possible
00088         // it is just not to violate the current pulic interfaces
00089         friend class AudioActiveReference;
00090         void SetActiveReference(const AudioActiveReference* active_ref);
00091         const AudioActiveReference* m_temp_active_ref;
00092
00093         static MmfPlayer m_singleton_instance;
00094         //MediaInfo info;
00095         //MediaPlayer* m_media_player;
00096         //BinData* m_bin_data;
00097         //BOOLEAN m_bin_data_provided;
00098
00099         SimpleMap<MediaPlayer*, MediaPlayerInstanceData> m_media_player_to_data_map;
00100
00101 };
00102
00104 #endif  // Apoxi_MmfPlayer_hpp
00105
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Mp3AudioPlayer.cpp File Reference

Audio/Mp3AudioPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioDeviceBase.hpp>
#include <Audio/Mp3AudioPlayer.hpp>
#include <Audio/Mp3AudioReference.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/AudioUtility.hpp>
#include <Audio/audio_private.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Rfs/File.hpp>
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for Mp3AudioPlayer.cpp:

Generated on Tue Jan 24 18:10:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MP3AudioPlayer.hpp File Reference

Devices/MP3AudioPlayer.hpp File Reference

#include <Audio/Mp3AudioPlayer.hpp>

Include dependency graph for MP3AudioPlayer.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:29:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MP3AudioPlayer.hpp Source File

Devices/MP3AudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/Mp3AudioPlayer.hpp>
00010
00011
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Mp3AudioReference.cpp File Reference

Audio/Mp3AudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/Mp3AudioReference.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Afs/Rfs/Pathname.hpp>

Include dependency graph for Mp3AudioReference.cpp:

Generated on Tue Jan 24 18:10:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MP3AudioReference.hpp File Reference

Devices/MP3AudioReference.hpp File Reference

#include <Audio/Mp3AudioReference.hpp>

Include dependency graph for MP3AudioReference.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:29:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MP3AudioReference.hpp Source File

Devices/MP3AudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/Mp3AudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/PcmAudioPlayer.cpp File Reference

Audio/PcmAudioPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/PcmAudioPlayer.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/PcmAudioReference.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Rfs/File.hpp>
#include <Kernel/System.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Config/AudioConfig.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for PcmAudioPlayer.cpp:

Generated on Tue Jan 24 18:10:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/PCMAudioPlayer.hpp File Reference

Devices/PCMAudioPlayer.hpp File Reference

#include <Audio/PcmAudioPlayer.hpp>

Include dependency graph for PCMAudioPlayer.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:32:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/PCMAudioPlayer.hpp Source File

Devices/PCMAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/PcmAudioPlayer.hpp>
00010
00011
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/PcmAudioReference.cpp File Reference

Audio/PcmAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/PcmAudioReference.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Rfs/File.hpp>
#include <Config/AudioConfig.hpp>
#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for PcmAudioReference.cpp:

Generated on Tue Jan 24 18:10:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/PCMAudioReference.hpp File Reference

Devices/PCMAudioReference.hpp File Reference

#include <Audio/PcmAudioReference.hpp>

Include dependency graph for PCMAudioReference.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:32:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/PCMAudioReference.hpp Source File

Devices/PCMAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/PcmAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/PresetAudioReference.cpp File Reference

Audio/PresetAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/PresetAudioReference.hpp>
#include <Audio/AudioPresetStore.hpp>

Include dependency graph for PresetAudioReference.cpp:

Generated on Tue Jan 24 18:10:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/PresetAudioReference.hpp File Reference

Audio/PresetAudioReference.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Audio/AudioReference.hpp>

Include dependency graph for PresetAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PresetAudioReference

Defines

#define | Apoxi_AudioNewAPI_PresetAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_PresetAudioReference_hpp

Generated on Tue Jan 24 18:10:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/PresetAudioReference.hpp Source File

Audio/PresetAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_PresetAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_PresetAudioReference_hpp
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Audio/AudioReference.hpp>
00017
00020 class PresetAudioReference : public AudioReference
00021 {
00022     public:
00023         virtual ~PresetAudioReference();
00024
00025         typedef UINT ToneID;
00026
00027     protected:
00028         PresetAudioReference(ToneID tone_id);
00029
00030
00031     public:
00035         WString GetPresetName() const;
00036         virtual enumClassType GetClassType() const;
00037
00038         ToneID GetToneID() const;
00039         void SetToneID(ToneID val);
00040
00041     protected:
00042         ToneID m_tone_id;
00043 };
00044
00046 #endif  // Apoxi_AudioNewAPI_PresetAudioReference_hpp
00047
00048
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RadioAudioDevice.cpp File Reference

Audio/RadioAudioDevice.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/RadioAudioDevice.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/Messages/AudioDeviceStatusMsg.hpp>
#include <Audio/Messages/AudioRadioDeviceNotificationMsg.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/SimpleAudioReference.hpp>
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for RadioAudioDevice.cpp:

Generated on Tue Jan 24 18:10:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RadioAudioDevice.hpp File Reference

Audio/RadioAudioDevice.hpp File Reference

#include <Audio/DwdPlayer.hpp>
#include <Audio/RadioAudioDevice.hpp>
#include <Audio/SimpleAudioDevice.hpp>
#include <Audio/DwdDevice.hpp>
#include <Audio/audio_private.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for RadioAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RadioAudioDevice
APOXI interface to FM Radio device. More...
struct | RadioAudioDevice::StationInfo
Structure for info about a station. More...

Defines

#define | Apoxi_AudioNewAPI_RadioAudioDevice_hpp

Define Documentation

#define Apoxi_AudioNewAPI_RadioAudioDevice_hpp

Generated on Tue Jan 24 18:10:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RadioAudioDevice.hpp Source File

Audio/RadioAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_RadioAudioDevice_hpp)
00011 #define Apoxi_AudioNewAPI_RadioAudioDevice_hpp
00014
00015 #include <Audio/DwdPlayer.hpp>
00016 #include <Audio/RadioAudioDevice.hpp>
00017 #include <Audio/SimpleAudioDevice.hpp>
00018 #include <Audio/DwdDevice.hpp>
00019 #include <Audio/audio_private.hpp>
00020 #include <Auxiliary/WString.hpp>
00021
00023
00029 class RadioAudioDevice : public SimpleAudioDevice,  public DwdDevice
00030 {
00031     friend class DwdPlayer;
00032
00033     public:
00034
00036         enum NotificationType
00037         {
00038             NotificationTypeStationFound,
00039             NotificationTypeBandLimitsReached,
00040         };
00041
00043         enum StereoMode
00044         {
00045             ModeStereo = 0,
00046             ModeMono = 1
00047         };
00048
00050         enum AudioChannel
00051         {
00052             AudioChannelLeft,
00053             AudioChannelRight,
00054             AudioChannelBoth
00055         };
00056
00058         enum BandLimits
00059         {
00060             BandLimitsEuropeUs = 0, // Default
00061             BandLimitsJapan = 1
00062         };
00063
00065         enum SeekMode
00066         {
00067             SeekModeAuto,
00068             SeekModeManual
00069         };
00070
00072         enum SeekDirection
00073         {
00074             SeekDirectionUp,
00075             SeekDirectionDown
00076         };
00077
00079         enum SearchStopLevel
00080         {
00081             SearchStopLevelLow,     // Default
00082             SearchStopLevelMid,
00083             SearchStopLevelHigh
00084         };
00085
00087         struct StationInfo {
00088
00090             WString         m_sender_name;
00091
00093             UINT32          m_frequency;
00094
00096             UINT8           m_level;
00097
00099             StereoMode      m_stereo_mode;
00100         };
00101
00102     public:
00104         virtual ~RadioAudioDevice();
00105
00107
00112         static RadioAudioDevice& GetInstance();
00113
00115
00123         virtual BOOLEAN Enable(BOOLEAN suspend_all_others = FALSE);
00124
00126
00134         virtual BOOLEAN Disable();
00135
00137
00147         BOOLEAN SetStereoMode(RadioAudioDevice::StereoMode mode = RadioAudioDevice::ModeStereo);
00148
00150
00154         RadioAudioDevice::StereoMode GetStereoMode() const;
00155
00157
00165         BOOLEAN SelectMuteChannel(RadioAudioDevice::AudioChannel channel = RadioAudioDevice::AudioChannelBoth);
00166
00168
00173         RadioAudioDevice::AudioChannel GetSelectedMuteChannel() const;
00174
00176
00194         virtual BOOLEAN SetMute(BOOLEAN enable = TRUE, MuteDirection direction = UpDownlinkDirection);
00195
00197
00203         BOOLEAN GetChannelMuteState(RadioAudioDevice::AudioChannel channel = RadioAudioDevice::AudioChannelBoth) const;
00204
00206
00224         BOOLEAN SetBandLimits(RadioAudioDevice::BandLimits limits);
00225
00227
00233         RadioAudioDevice::BandLimits GetBandLimits() const;
00234
00236
00244         BOOLEAN SetHighCutControl(BOOLEAN hcc_on = TRUE);
00245
00247
00249         BOOLEAN GetHighCutControl() const;
00250
00252
00260         BOOLEAN SetHighLowSideLoInjection(BOOLEAN high = TRUE);
00261
00263
00265         BOOLEAN GetHighLowSideLoInjection() const;
00266
00268
00276         BOOLEAN SetSearchStopLevel(RadioAudioDevice::SearchStopLevel level);
00277
00279
00281         RadioAudioDevice::SearchStopLevel GetSearchStopLevel() const;
00282
00284
00308         BOOLEAN SeekStation(RadioAudioDevice::SeekDirection direction, RadioAudioDevice::SeekMode mode);
00309
00311
00324         BOOLEAN SetStation(UINT32 frequency);
00325
00327
00337         BOOLEAN GetStationInfo(RadioAudioDevice::StationInfo& info);
00338
00340
00342         virtual AudioSourceType GetSource() const;
00343
00344 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00345         //If new volume concept than use the AudioDeviceBase::SetVolume
00346         //otherwise overwrite the existing function to use the old functions
00348
00353         //virtual BOOLEAN SetVolume(VolumeLevel volume);
00355         virtual BOOLEAN ApplyDeviceVolume();
00356
00357         virtual BOOLEAN Play_Allocate(AudioActiveReference &playing_reference);
00358
00359     protected:
00360         virtual UINT16 GetDeviceID() const; //overwrite
00361
00362     private:
00363
00365
00367         RadioAudioDevice();
00368
00370
00372         RadioAudioDevice(const RadioAudioDevice& obj);
00373
00375
00379         BOOLEAN InitDevice();
00380
00382         BOOLEAN SetCurrentConfiguration();
00383
00385         void OnAudioSdlSignal(UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00386
00388         BandLimits m_bandlimits;
00389
00391         aud_radio_config_data_type m_config;
00392
00394         StationInfo m_station_info;
00395
00397         AudioChannel m_mute_channel;
00398
00400         BooleanCondition m_read_status_wait_condition;
00401
00403         static RadioAudioDevice m_instance;
00404
00406         static BOOLEAN m_is_initialized;
00407
00408 #endif // DOXYGEN_SHOULD_SKIP_THIS
00409
00410 }; // class RadioAudioDevice
00411
00413 #endif  // Apoxi_AudioNewAPI_RadioAudioDevice_hpp
00414
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioInternalMidiPlayer.cpp File Reference

Audio/RingerAudioInternalMidiPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/RingerAudioInternalMidiPlayer.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for RingerAudioInternalMidiPlayer.cpp:

Generated on Tue Jan 24 18:10:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioInternalMidiPlayer.hpp File Reference

Audio/RingerAudioInternalMidiPlayer.hpp File Reference

#include <Audio/RingerAudioPlayer.hpp>

Include dependency graph for RingerAudioInternalMidiPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_RingerAudioInternalMIDIPlayer_hpp

Define Documentation

#define Apoxi_AudioNewAPI_RingerAudioInternalMIDIPlayer_hpp

Generated on Tue Jan 24 18:10:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioInternalMidiPlayer.hpp Source File

Audio/RingerAudioInternalMidiPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_RingerAudioInternalMIDIPlayer_hpp)
00011 #define Apoxi_AudioNewAPI_RingerAudioInternalMIDIPlayer_hpp
00014
00015 #include <Audio/RingerAudioPlayer.hpp>
00016
00017
00018 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00019
00024 class RingerAudioInternalMIDIPlayer : public RingerAudioPlayer
00025 {
00026     public:
00027         virtual ~RingerAudioInternalMIDIPlayer();
00028
00029         virtual AudioSourceType GetSource() const; //override
00030
00031         static AudioDeviceBase* GetInstance();
00032         virtual Vector<MimeTypeSupportInfo> GetMimeTypeSupportInfo() const;
00033         virtual BOOLEAN CanPlay(const AudioActiveReference& active_reference) const;
00034     protected:
00035         virtual UINT16 GetDeviceID() const; //overwrite
00036         virtual BOOLEAN Play_Allocate(AudioActiveReference &playing_ref);
00037     private:
00039     RingerAudioInternalMIDIPlayer();
00040
00042     RingerAudioInternalMIDIPlayer(const RingerAudioInternalMIDIPlayer& obj);
00043
00044
00045         static RingerAudioInternalMIDIPlayer m_singleton_instance;
00046 };
00047 #endif //DOXYGEN_SHOULD_SKIP_THIS
00048
00050 #endif  // Apoxi_AudioNewAPI_RingerAudioInternalMIDIPlayer_hpp
00051
00052
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioPlayer.cpp File Reference

Audio/RingerAudioPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/RingerAudioPlayer.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/RingerAudioReference.hpp>
#include <Audio/CustomRingerAudioReference.hpp>
#include <Audio/CustomSmafPhraseAudioReference.hpp>
#include <Audio/PresetAudioReference.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/AudioUtility.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioPresetStore.hpp>
#include <Afs/Rfs/File.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Config/AudioConfig.hpp>

Include dependency graph for RingerAudioPlayer.cpp:

Generated on Tue Jan 24 18:10:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioPlayer.hpp File Reference

Audio/RingerAudioPlayer.hpp File Reference

#include <Audio/DwdPlayer.hpp>
#include <Config/AudioCapabilities.hpp>
#include <Audio/AudioPreset.hpp>
#include <Audio/CustomRingerAudioReference.hpp>
#include <Auxiliary/WString.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for RingerAudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_RingerAudioPlayer_hpp

Define Documentation

#define Apoxi_RingerAudioPlayer_hpp

Generated on Tue Jan 24 18:10:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioPlayer.hpp Source File

Audio/RingerAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RingerAudioPlayer_hpp)
00011 #define Apoxi_RingerAudioPlayer_hpp
00014
00015 #include <Audio/DwdPlayer.hpp>
00016 #include <Config/AudioCapabilities.hpp> //project-specific, in Config directory.
00017 #include <Audio/AudioPreset.hpp>
00018 #include <Audio/CustomRingerAudioReference.hpp>
00019 #include <Auxiliary/WString.hpp>
00020 #include <Audio/audio_private.hpp>
00021
00022 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00023
00026 class RingerAudioPlayer : public DwdPlayer
00027 {
00028     public:
00029         virtual ~RingerAudioPlayer();
00030
00031         virtual AudioSourceType GetSource() const; //override
00032
00033         virtual void Play(AudioActiveReference& active_reference);
00034         virtual void Stop(AudioActiveReference& active_reference);
00035         virtual void Suspend(AudioActiveReference& active_reference);
00036         virtual void ResumeSuspended(AudioActiveReference& active_reference);
00037         virtual void StopSuspended(AudioActiveReference& active_reference);
00038         virtual BOOLEAN CanPlay(const AudioActiveReference& active_reference) const;
00039
00041
00045         virtual BOOLEAN SetPlayPosition(AudioActiveReference &playing_reference);
00046
00051         virtual BOOLEAN GetPlayPosition(AudioActiveReference &playing_reference);
00052
00057         virtual BOOLEAN GetTotalPlayTime(AudioActiveReference &playing_reference);
00058
00059         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRfsFile(MimeType mime_type, const Path& path);
00060         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, ConstBuffer buffer, UINT32 buffer_size);
00061         virtual SharedPtr<AudioReference> CreateAudioReferenceFromPreset(MimeType mime_type, AudioPreset::AudioPresetSoundToneId tone_id);
00062
00063         static AudioDeviceBase* GetInstance();
00064         virtual Vector<MimeTypeSupportInfo> GetMimeTypeSupportInfo() const;
00065     protected:
00067     RingerAudioPlayer();
00068
00070     RingerAudioPlayer(const RingerAudioPlayer& obj);
00071
00072
00073         virtual BOOLEAN Play_Allocate(AudioActiveReference &playing_ref);
00074         virtual BOOLEAN Play_Implementation(AudioActiveReference &playing_ref);
00075         virtual BOOLEAN Stop_Implementation(AudioActiveReference &playing_reference);
00076         virtual BOOLEAN Suspend_Implementation(AudioActiveReference &playing_reference);
00077         virtual BOOLEAN Resume_Implementation(AudioActiveReference &playing_reference);
00078         virtual BOOLEAN StopSuspend_Implementation(AudioActiveReference &playing_reference);
00079
00080
00081         // from AudioDeviceBase
00082         virtual BOOLEAN SetVolume_Implementation(VolumeLevel volume);
00083
00084     #if 0
00085
00086         virtual BOOLEAN SetChannelVolume(AudioActiveReference &active_reference, VolumeLevel volume);
00088         virtual BOOLEAN SetChannelVolume_Implementation(AudioActiveReference &active_reference, VolumeLevel volume);
00089     #endif
00090
00091         virtual BOOLEAN OnSdlSignal(UINT16 func_id, UINT8 handle, UINT16 drv_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00092
00093         VolumeLevel m_channel_volume[5];
00094
00095         virtual UINT16 GetDeviceID() const; //overwrite
00096         INT MapFormat(CustomRingerAudioReference::Format format);
00097     private:
00098
00099         enum Constants
00100         {
00101             c_max_channels = 4
00102         };
00103
00104         static RingerAudioPlayer m_singleton_instance;
00105
00106         // The reason for c_max_channels+1 is that the driver counts the channels from 1 to 4.
00107         // Otherwise the handle cannot be set in case of channel 4 because the list goes only to from index 0 to 3.
00108         INT32 m_channel_used_by_handle[c_max_channels+1];
00109 };
00110 #endif //DOXYGEN_SHOULD_SKIP_THIS
00111
00113 #endif  // Apoxi_AudioNewAPI_RingerAudioPlayer_hpp
00114
00115
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioReference.cpp File Reference

Audio/RingerAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/RingerAudioReference.hpp>
#include <Audio/RingerAudioPlayer.hpp>

Include dependency graph for RingerAudioReference.cpp:

Generated on Tue Jan 24 18:10:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioReference.hpp File Reference

Audio/RingerAudioReference.hpp File Reference

#include <Audio/PresetAudioReference.hpp>

Include dependency graph for RingerAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_RingerAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_RingerAudioReference_hpp

Generated on Tue Jan 24 18:10:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RingerAudioReference.hpp Source File

Audio/RingerAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_RingerAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_RingerAudioReference_hpp
00014
00015 #include <Audio/PresetAudioReference.hpp>
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00021 class RingerAudioReference : public PresetAudioReference
00022 {
00023     public:
00024         virtual ~RingerAudioReference();
00025
00026         static SharedPtr<RingerAudioReference> Create(ToneID key_tone_id);
00027
00028         virtual enumClassType GetClassType() const;
00029
00030     public:
00031         RingerAudioReference(ToneID key_tone_id);
00032 };
00033 #endif //DOXYGEN_SHOULD_SKIP_THIS
00034
00036 #endif  // Apoxi_AudioNewAPI_RingerAudioReference_hpp
00037
00038
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SimpleAudioDevice.cpp File Reference

Audio/SimpleAudioDevice.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/SimpleAudioDevice.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for SimpleAudioDevice.cpp:

Generated on Tue Jan 24 18:11:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SimpleAudioDevice.hpp File Reference

Audio/SimpleAudioDevice.hpp File Reference

#include <Audio/AudioDeviceBase.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for SimpleAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimpleAudioDevice

Defines

#define | Apoxi_AudioNewAPI_SimpleAudioDevice_hpp

Define Documentation

#define Apoxi_AudioNewAPI_SimpleAudioDevice_hpp

Generated on Tue Jan 24 18:11:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SimpleAudioDevice.hpp Source File

Audio/SimpleAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_SimpleAudioDevice_hpp)
00011 #define Apoxi_AudioNewAPI_SimpleAudioDevice_hpp
00014
00015 #include <Audio/AudioDeviceBase.hpp>
00016 #include <Audio/AudioActiveReference.hpp>
00017
00018 class AudioManager;
00019
00020 class SimpleAudioDevice : public AudioDeviceBase
00021 {
00022     public:
00023         SimpleAudioDevice();
00024         virtual ~SimpleAudioDevice();
00025
00030         virtual BOOLEAN Enable(BOOLEAN suspend_all_others = FALSE) = 0;
00031
00038         virtual BOOLEAN Disable() = 0;
00039
00040         BOOLEAN IsEnabled() const;
00041
00042     protected:
00043         //Only one of these devices can be active at once.
00044         //so we store an AudioActiveReference here, to keep the resources allocated.
00045         //TODO: Maybe only one of the SimpleAudioDevices can be active at once
00046         // if so then we need to remember which one is active and prevent another one becoming active.
00047         void SetStatus(BOOLEAN enable);
00048
00049         SharedPtr<AudioActiveReference> m_active_reference;
00050         BOOLEAN m_enabled;
00051 };
00052
00054 #endif  // Apoxi_AudioNewAPI_SimpleAudioDevice_hpp
00055
00056
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SimpleAudioReference.cpp File Reference

Audio/SimpleAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/SimpleAudioReference.hpp>

Include dependency graph for SimpleAudioReference.cpp:

Generated on Tue Jan 24 18:11:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SimpleAudioReference.hpp File Reference

Audio/SimpleAudioReference.hpp File Reference

#include <Audio/AudioReference.hpp>

Include dependency graph for SimpleAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_SimpleAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_SimpleAudioReference_hpp

Generated on Tue Jan 24 18:11:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SimpleAudioReference.hpp Source File

Audio/SimpleAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_SimpleAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_SimpleAudioReference_hpp
00014
00015 #include <Audio/AudioReference.hpp>
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00021 class SimpleAudioReference : public AudioReference
00022 {
00023     public:
00024         virtual ~SimpleAudioReference();
00025
00026         static SharedPtr<SimpleAudioReference> Create();
00027
00028         virtual enumClassType GetClassType() const;
00029
00030     protected:
00031         SimpleAudioReference();
00032
00033     protected:
00034 };
00035 #endif //DOXYGEN_SHOULD_SKIP_THIS
00036
00038 #endif  // Apoxi_AudioNewAPI_SimpleAudioReference_hpp
00039
00040
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SpeechSimpleAudioDevice.cpp File Reference

Audio/SpeechSimpleAudioDevice.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/SpeechSimpleAudioDevice.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Audio/SimpleAudioReference.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/AudioMsgProcessor.hpp>
#include <Audio/Messages/AudioDeviceStatusMsg.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for SpeechSimpleAudioDevice.cpp:

Generated on Tue Jan 24 18:11:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SpeechSimpleAudioDevice.hpp File Reference

Audio/SpeechSimpleAudioDevice.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableEntry.hpp>
#include <Audio/SimpleAudioDevice.hpp>
#include <Audio/DwdDevice.hpp>

Include dependency graph for SpeechSimpleAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SpeechSimpleAudioDevice

Defines

#define | Apoxi_AudioNewAPI_SpeechSimpleAudioDevice_hpp

Define Documentation

#define Apoxi_AudioNewAPI_SpeechSimpleAudioDevice_hpp

Generated on Tue Jan 24 18:11:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/SpeechSimpleAudioDevice.hpp Source File

Audio/SpeechSimpleAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_SpeechSimpleAudioDevice_hpp)
00011 #define Apoxi_AudioNewAPI_SpeechSimpleAudioDevice_hpp
00014 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>    // For ProcessPtr
00015 #include <Audio/SimpleAudioDevice.hpp>
00016 #include <Audio/DwdDevice.hpp>
00017
00022 class SpeechSimpleAudioDevice : public SimpleAudioDevice, public DwdDevice
00023 {
00024     private:
00025         //Use GetInstance() instead.
00026         SpeechSimpleAudioDevice();
00027
00028     public:
00029         virtual ~SpeechSimpleAudioDevice();
00030         static SpeechSimpleAudioDevice* GetInstance();
00031
00036         virtual BOOLEAN Enable(BOOLEAN suspend_all_others = FALSE);
00037
00043         virtual BOOLEAN Disable();
00044
00046         virtual BOOLEAN ApplyDeviceVolume();
00047
00049         UINT16 GetNativeVolumeMin();
00050
00052         UINT16 GetNativeVolumeMax();
00053
00059         BOOLEAN SetMute(BOOLEAN uplink, BOOLEAN enable = TRUE);
00060
00065         BOOLEAN GetMute(BOOLEAN uplink) const;
00066
00067         virtual AudioSourceType GetSource() const; //override
00068
00069 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00070         //overwrite the AudioDeviceBase function
00071         virtual BOOLEAN SetMute(BOOLEAN enable = TRUE, MuteDirection direction = UpDownlinkDirection);
00072
00073         virtual BOOLEAN Play_Allocate(AudioActiveReference &playing_reference);
00074
00075         //Callback function handling the MN_SPEECH_STATUS_IND signal
00076         static void OnSdlSignal_AudioSpeechStatusInd(const ProcessPtr &process_ptr);
00077
00078     protected:
00079         BOOLEAN m_mute_uplink_enabled, m_mute_downlink_enabled;
00080
00081         //The only instance of the speech device
00082         static SpeechSimpleAudioDevice* m_instance;
00083
00084         virtual UINT16 GetDeviceID() const; //overwrite
00085 #endif  //DOXYGEN_SHOULD_SKIP_THIS
00086 };
00087
00089 #endif  // Apoxi_AudioNewAPI_SpeechSimpleAudioDevice_hpp
00090
00091
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/StreamAudioPlayer.cpp File Reference

Audio/StreamAudioPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/StreamAudioPlayer.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/AudioError.hpp>
#include <Kernel/System.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp>
#include <Audio/Messages/AudioMessages.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for StreamAudioPlayer.cpp:

Defines

#define | aud_rc_ram_buffer_used -94
#define | aud_rc_recording_finish -95

Define Documentation

#define aud_rc_ram_buffer_used -94

#define aud_rc_recording_finish -95

Generated on Tue Jan 24 18:11:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/StreamAudioPlayer.hpp File Reference

Audio/StreamAudioPlayer.hpp File Reference

#include <Audio/DwdPlayer.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Kernel/Condition.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for StreamAudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamAudioPlayer

Defines

#define | Apoxi_AudioNewAPI_StreamAudioPlayer_hpp

Define Documentation

#define Apoxi_AudioNewAPI_StreamAudioPlayer_hpp

Generated on Tue Jan 24 18:11:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/StreamAudioPlayer.hpp Source File

Audio/StreamAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_StreamAudioPlayer_hpp)
00011 #define Apoxi_AudioNewAPI_StreamAudioPlayer_hpp
00014
00015
00016 #include <Audio/DwdPlayer.hpp>
00017 #include <Audio/StreamAudioReference.hpp>
00018 #include <Kernel/Condition.hpp>
00019 #include <Audio/audio_private.hpp>
00020 #include <Audio/AudioActiveReference.hpp>
00021
00024 class StreamAudioPlayer : public DwdPlayer
00025 {
00026     public:
00027         StreamAudioPlayer();
00028         virtual ~StreamAudioPlayer();
00029
00030                 typedef DwdPlayer Base;
00031
00046         virtual SharedPtr<AudioActiveReference> Record(const AudioReference &audio_ref);
00047
00053         virtual void StopRecord(AudioActiveReference &active_reference);
00054
00055         virtual AudioSourceType GetSource() const; //override
00056
00061         void SetRecordingDelay(UINT32 delay);
00062
00063         //Get the recording delay. See SetRecordingDelay()
00064         UINT32 GetRecordingDelay() const;
00065
00068         BOOLEAN IsRecording();
00069
00070                 virtual BOOLEAN CanPlay(const AudioActiveReference& active_reference) const;
00071         virtual BOOLEAN CanSuspend(const AudioActiveReference& active_reference) const;
00072         virtual BOOLEAN CanResume(const AudioActiveReference& active_reference) const;
00073
00074
00075 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00076
00077         void SetRecordedSize(StreamAudioReference::BufferByteType rec_size);
00078 #endif //DOXYGEN_SHOULD_SKIP_THIS
00079
00080     protected:
00081
00082         virtual void OnRecordingFinished(INT8 return_code, UINT32 param);
00083
00084         //These methods are used by AudioPriorityManager (a friend class), because we must handle the SDL signal outside of this class:
00085         SharedPtr<AudioActiveReference> GetRecordingReference();
00086         SharedPtr<const AudioActiveReference> GetRecordingReference() const;
00088         void ForgetRecordingReference();
00089
00091         virtual BOOLEAN StopSuspend_Implementation(AudioActiveReference &playing_reference);
00092
00093         //These methods are used by AudioPriorityManager (a friend class), because we must handle the SDL signal outside of this class:
00094         void SetRecordingWaitCondition(BOOLEAN val = TRUE);
00095         TimeoutCondition *m_recording_wait_condition; //See StopRecord() implementation.
00096
00101         void ReconstructRecordingWaitCondition();
00102
00103         UINT32 m_delay; //the recording delay
00104
00105         INT MapMedia (StreamAudioReference::Media media);
00106
00107 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00108
00109         SharedPtr<AudioActiveReference> m_p_record_ref;
00110         DwdHandleType m_recording_dwd_handle;
00111 #endif //DOXYGEN_SHOULD_SKIP_THIS
00112 };
00113
00115 #endif  // Apoxi_AudioNewAPI_StreamAudioPlayer_hpp
00116
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/StreamAudioReference.cpp File Reference

Audio/StreamAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/VoiceMemoAudioReference.hpp>
#include <Audio/PcmAudioReference.hpp>
#include <Audio/Mp3AudioReference.hpp>
#include <Audio/AudioUtility.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <AddOns/AfsFfs/FlashFileImp.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Config/AudioConfig.hpp>

Include dependency graph for StreamAudioReference.cpp:

Generated on Tue Jan 24 18:11:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/StreamAudioReference.hpp File Reference

Audio/StreamAudioReference.hpp File Reference

#include <Audio/AudioReference.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Audio/AudioPlayer.hpp>

Include dependency graph for StreamAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamAudioReference

Defines

#define | Apoxi_AudioNewAPI_StreamAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_StreamAudioReference_hpp

Generated on Tue Jan 24 18:11:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/StreamAudioReference.hpp Source File

Audio/StreamAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_StreamAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_StreamAudioReference_hpp
00014
00015
00016 #include <Audio/AudioReference.hpp>
00017 #include <Afs/Rfs/RootFileSystem.hpp>
00018 #include <Afs/Rfs/Path.hpp>
00019 #include <Audio/AudioPlayer.hpp>
00020
00021
00024 class StreamAudioReference : public AudioReference
00025 {
00026     public:
00027         friend class AudioPriorityManager;
00028         friend class StreamAudioPlayer;
00029         friend class VoiceMemoAudioPlayer;
00030         friend class PCMAudioPlayer;
00031         friend class MP3AudioPlayer;
00033         enum Mode {
00035             StandbyMode,
00037             TchMode
00038         };
00039
00041         enum Media {
00043             FfsMedia,
00045             MmcMedia,
00047             RamMedia,
00049             RfsMedia,
00051             MmfMedia,
00052 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00053
00054             VrMedia
00055 #endif
00056         };
00057
00059         enum DspFormat {
00061             PcmDspFormat,
00063             AdpcmDspFormat,
00065             WaveDspFormat,
00067             FrDspFormat,
00069             AmrDspFormat,
00071             MP3DspFormat,
00073             A2dpFormat
00074         };
00075
00076
00077         typedef UINT32              BufferByteType;
00078         // Now we have one central definition for Buffer and ConstBuffer in the AudioPlayer.
00079         // Buffer should used for playback and ConstBuffer should used for recording.
00080         typedef AudioPlayer::Buffer BufferType;
00081         typedef AudioPlayer::ConstBuffer ConstBufferType;
00082
00083         virtual ~StreamAudioReference();
00084
00086         typedef UINT8 SampleRateType;
00087
00088         typedef UINT8 MonoStereoType;
00089
00090
00091
00101         static SharedPtr<StreamAudioReference> CreateRam(BufferType buffer, BufferByteType buffer_size, Mode mode, DspFormat format);
00102
00112         static SharedPtr<StreamAudioReference> CreateRam(ConstBufferType buffer, BufferByteType buffer_size, Mode mode, DspFormat format);
00113
00114
00121         static SharedPtr<StreamAudioReference> CreateFFS(const String& filename, Mode mode, DspFormat format);
00122
00133         static SharedPtr<StreamAudioReference> CreateFile(const Path& filename, Mode mode, DspFormat format);
00134
00167         //typedef void (*GetAudioBufferFunction)( /* audiobuffer */ UINT8 ** , /*size */UINT16 *, /* application data */void* pUserData);
00168         typedef AudioPlayer::GetAudioBufferFunction GetAudioBufferFunction;
00169
00211         static SharedPtr<StreamAudioReference> CreateStream(Mode mode, DspFormat format, GetAudioBufferFunction func, void* user_data = 0);
00212
00222         static SharedPtr<StreamAudioReference> MmfCreateStream(Mode mode, DspFormat format, GetAudioBufferFunction func, void* user_data = 0, BOOLEAN has_audio = TRUE);
00223
00227         BOOLEAN HasAudio() const;
00228
00274         static SharedPtr<StreamAudioReference> CreateVoiceRecognition();
00275
00276         virtual enumClassType GetClassType() const;
00277
00285         static UINT32 CalculateBufferSize(UINT32 seconds, DspFormat format, SampleRateType rec_rate);
00286
00287         ConstBufferType GetBuffer(BufferByteType& size) const;
00288         BufferType GetBuffer(BufferByteType& size);
00289
00290         const Path& GetPath() const { return m_path; }
00291
00293         virtual UINT16 GetDelay(void) const;
00294
00295         Mode GetMode() const;
00296         Media GetMediaType() const;
00297         DspFormat GetDspFormat() const;
00298
00302         BufferByteType GetRecordedSize();
00303
00305         MonoStereoType GetMonoStereoMode() const;
00306
00308         SampleRateType GetSampleRate() const;
00309
00312         void SetRecordingRate(SampleRateType val);
00364         void SetSampleRate(SampleRateType val);
00365
00381         void SetMonoStereoMode(MonoStereoType val);
00382
00383 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00384
00385         UINT32 GetDataOffset() const;
00386 #endif
00387
00388     protected:
00389
00391         StreamAudioReference(const Path& filename, Mode mode, DspFormat format);
00393         StreamAudioReference(BufferType buffer_handle, BufferByteType buffer_size, Mode mode,  DspFormat format);
00395         StreamAudioReference(const String& filename, Mode mode, DspFormat format);
00397         StreamAudioReference(Mode mode, DspFormat format);
00398
00400         StreamAudioReference();
00401
00403         static SharedPtr<StreamAudioReference> Create(Mode mode, Media media_type, DspFormat format);
00404
00405         // Called by AudioPriorityManager, which is a friend class.
00406         // stores actual size
00407         void SetRecordedSize(BufferByteType rec_size);
00408
00409         //Initialize the offset to the raw audio data. It has to be called after the path is set up!!!
00410         void InitDataOffset();
00411
00412         static SharedPtr<StreamAudioReference> Create(const String& fName, BufferType buffer, BufferByteType buffer_size, Mode mode, Media media_type, DspFormat format);
00413
00414 //      StreamAudioReference(const Path& filename, Mode mode, DspFormat format);
00415
00416     protected:
00417         //Called by StreamAudioPlayer, which is a friend class.
00418         BOOLEAN CreateFile();
00419         BOOLEAN OpenFile();
00420         void CloseFile();
00421
00422         BufferType m_buffer;
00423         BufferByteType m_buffer_size;
00424
00426         Mode m_mode;
00427
00429         Media m_media_type;
00430
00432         DspFormat m_format;
00433
00435         SampleRateType m_sample_rate;
00436
00438         MonoStereoType m_mono_stereo_mode;
00439
00441         UINT32 m_data_offset;
00442
00444         Path m_path;
00445
00447         FilePtr m_file_handle;
00448
00449         BOOLEAN m_has_audio;
00450
00451 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00452
00453         static int StreamingGetBuffer(UINT8** audiobuffer,UINT16* size, void* user_data);
00454         //The MMF callback function
00455         GetAudioBufferFunction ptr_MMFCallaback;
00456         void* m_pUserData;
00457 #endif
00458 };
00459
00461 #endif // Apoxi_AudioNewAPI_StreamAudioReference_hpp
00462
00463
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/TimeFeatureObject.cpp File Reference

Audio/TimeFeatureObject.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "Audio/TimeFeatureObject.hpp"

Include dependency graph for TimeFeatureObject.cpp:

Generated on Tue Jan 24 18:12:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/TimeFeatureObject.hpp File Reference

Audio/TimeFeatureObject.hpp File Reference

#include <Auxiliary/GenericObject.hpp>

Include dependency graph for TimeFeatureObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TimeFeatureObject

Defines

#define | Apoxi_TimeFeatureObject_hpp

Define Documentation

#define Apoxi_TimeFeatureObject_hpp

Generated on Tue Jan 24 18:12:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/TimeFeatureObject.hpp Source File

Audio/TimeFeatureObject.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TimeFeatureObject_hpp)
00011 #define Apoxi_TimeFeatureObject_hpp
00014
00015 #include <Auxiliary/GenericObject.hpp>
00016
00017 class TimeFeatureObject// : public GenericObject
00018 {
00019     public:
00021         TimeFeatureObject();
00022
00023         TimeFeatureObject(const TimeFeatureObject &obj);
00024
00025         static const GenericTypeId  c_time_feature_object_id;
00026
00028         virtual ~TimeFeatureObject();
00029
00031         virtual TimeFeatureObject * Copy() const;
00033         virtual BOOLEAN         IsEqual(TimeFeatureObject * object);
00035         virtual GenericTypeId   GetTypeId();
00036
00038         UINT32 GetTimeStamp() const;
00039
00041         INT32 GetChannelId() const;
00042
00044         void SetTimeStamp(UINT32 time);
00045
00047         void SetChannelId(INT32 channel);
00048
00049     protected:
00051         UINT32 m_time;
00052
00054         INT32 m_channel;
00055 };
00057 #endif // Apoxi_TimeFeatureObject_hpp
00058
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/ToneAudioPlayer.cpp File Reference

Audio/ToneAudioPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/ToneAudioPlayer.hpp>
#include <Audio/ToneAudioReference.hpp>
#include <Audio/CustomToneAudioReference.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/audio_private.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/AudioUtility.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/AudioPresetStore.hpp>
#include <Config/AudioConfig.hpp>
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for ToneAudioPlayer.cpp:

Generated on Tue Jan 24 18:12:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/ToneAudioPlayer.hpp File Reference

Audio/ToneAudioPlayer.hpp File Reference

#include <Audio/DwdPlayer.hpp>
#include <Audio/ToneAudioReference.hpp>

Include dependency graph for ToneAudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_ToneAudioPlayer_hpp

Define Documentation

#define Apoxi_AudioNewAPI_ToneAudioPlayer_hpp

Generated on Tue Jan 24 18:12:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/ToneAudioPlayer.hpp Source File

Audio/ToneAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_ToneAudioPlayer_hpp)
00011 #define Apoxi_AudioNewAPI_ToneAudioPlayer_hpp
00014
00015 #include <Audio/DwdPlayer.hpp>
00016 #include <Audio/ToneAudioReference.hpp>
00017
00018 class AudioManager;
00019 class AudioActiveReference;
00020
00021 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00022
00025 class ToneAudioPlayer : public DwdPlayer
00026 {
00027     public:
00028
00029         virtual ~ToneAudioPlayer();
00030
00031         virtual AudioSourceType GetSource() const; //override.
00032
00033         virtual void Play(AudioActiveReference& active_reference);
00034         virtual void Stop(AudioActiveReference& active_reference);
00035         virtual void Suspend(AudioActiveReference& active_reference);
00036         virtual void ResumeSuspended(AudioActiveReference& active_reference);
00037         virtual void StopSuspended(AudioActiveReference& active_reference);
00038
00039
00041
00045         virtual BOOLEAN SetPlayPosition(AudioActiveReference &playing_reference);
00046
00051         virtual BOOLEAN GetPlayPosition(AudioActiveReference &playing_reference);
00052
00057         virtual BOOLEAN GetTotalPlayTime(AudioActiveReference &playing_reference);
00058
00059         static AudioDeviceBase* GetInstance();
00060         virtual Vector<MimeTypeSupportInfo> GetMimeTypeSupportInfo() const;
00061
00062     protected:
00063         virtual UINT16 GetDeviceID() const; //overwrite
00064
00065         virtual BOOLEAN Play_Allocate(AudioActiveReference &audio_ref);
00066         virtual BOOLEAN Play_Implementation(AudioActiveReference &playing_ref);
00067         virtual BOOLEAN Stop_Implementation(AudioActiveReference &playing_reference);
00068         virtual BOOLEAN Suspend_Implementation(AudioActiveReference &playing_reference);
00069         virtual BOOLEAN Resume_Implementation(AudioActiveReference &playing_reference);
00070
00071         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, ConstBuffer buffer, UINT32 buffer_size);
00072         virtual SharedPtr<AudioReference> CreateAudioReferenceFromPreset(MimeType mime_type, AudioPreset::AudioPresetSoundToneId tone_id);
00073
00074 private:
00076     ToneAudioPlayer();
00077
00079     ToneAudioPlayer(const ToneAudioPlayer& obj);
00080
00081
00082         static ToneAudioPlayer m_singleton_instance;
00083
00084 };
00085 #endif //DOXYGEN_SHOULD_SKIP_THIS
00086
00088 #endif  // Apoxi_AudioNewAPI_ToneAudioPlayer_hpp
00089
00090
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/ToneAudioReference.cpp File Reference

Audio/ToneAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/ToneAudioReference.hpp>
#include <Audio/ToneAudioPlayer.hpp>
#include <Config/AudioConfig.hpp>

Include dependency graph for ToneAudioReference.cpp:

Generated on Tue Jan 24 18:12:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/ToneAudioReference.hpp File Reference

Audio/ToneAudioReference.hpp File Reference

#include <Audio/PresetAudioReference.hpp>

Include dependency graph for ToneAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_ToneAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_ToneAudioReference_hpp

Generated on Tue Jan 24 18:12:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/ToneAudioReference.hpp Source File

Audio/ToneAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_ToneAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_ToneAudioReference_hpp
00014
00015 #include <Audio/PresetAudioReference.hpp>
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00020 class ToneAudioReference : public PresetAudioReference
00021 {
00022     public:
00023         virtual ~ToneAudioReference();
00024
00025         static SharedPtr<ToneAudioReference> Create(ToneID key_tone_id);
00026
00027         virtual enumClassType GetClassType() const;
00028
00029     protected:
00030         ToneAudioReference(ToneID key_tone_id);
00031
00032 };
00033 #endif //DOXYGEN_SHOULD_SKIP_THIS
00034
00036 #endif  // Apoxi_AudioNewAPI_ToneAudioReference_hpp
00037
00038
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/VoiceMemoAudioPlayer.cpp File Reference

Audio/VoiceMemoAudioPlayer.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/VoiceMemoAudioPlayer.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/VoiceMemoAudioReference.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/AudioError.hpp>
#include <Audio/AudioDeviceManager.hpp>
#include <Audio/Messages/AudioStreamingSyncMsg.hpp>
#include <Kernel/System.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Rfs/File.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Audio/audio_private.hpp>

Include dependency graph for VoiceMemoAudioPlayer.cpp:

Generated on Tue Jan 24 18:12:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/VoiceMemoAudioPlayer.hpp File Reference

Audio/VoiceMemoAudioPlayer.hpp File Reference

#include <Audio/StreamAudioPlayer.hpp>

Include dependency graph for VoiceMemoAudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_VoiceMemoAudioPlayer_hpp

Define Documentation

#define Apoxi_AudioNewAPI_VoiceMemoAudioPlayer_hpp

Generated on Tue Jan 24 18:12:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/VoiceMemoAudioPlayer.hpp Source File

Audio/VoiceMemoAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_VoiceMemoAudioPlayer_hpp)
00011 #define Apoxi_AudioNewAPI_VoiceMemoAudioPlayer_hpp
00014
00015 #include <Audio/StreamAudioPlayer.hpp>
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00022 class VoiceMemoAudioPlayer : public StreamAudioPlayer
00023 {
00024     typedef StreamAudioPlayer Base;
00025     public:
00026
00027         virtual ~VoiceMemoAudioPlayer();
00028
00029         virtual void Play(AudioActiveReference& active_reference);
00030         virtual void Stop(AudioActiveReference& active_reference);
00031         virtual void Suspend(AudioActiveReference& active_reference);
00032         virtual void ResumeSuspended(AudioActiveReference& active_reference);
00033         virtual void StopSuspended(AudioActiveReference& active_reference);
00034         virtual SharedPtr<AudioActiveReference> StartRecording(const AudioReference &audio_ref);
00035         virtual void StopRecording(AudioActiveReference &active_reference);
00036
00037         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRfsFile(MimeType mime_type, const Path& path);
00038         // This function should be used in case of playback
00039         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, ConstBuffer buffer, UINT32 buffer_size);
00040         // This function should be used in case of recording
00041         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, Buffer buffer, UINT32 buffer_size);
00042         virtual SharedPtr<AudioReference> CreateAudioReferenceFromStream(MimeType mime_type, AudioPlayer::GetAudioBufferFunction func, void* user_data = 0);
00043
00051         virtual SharedPtr<AudioActiveReference> Record(const AudioReference &audio_ref);
00052
00053         /* Stop recording.
00054          * See Record(). If RAM has been set as media then StreamAudioReference::GetRecordedSize can be used to get the recorded buffer size
00055          * @param active_reference A reference to the active recording.
00056          */
00057         virtual void StopRecord(AudioActiveReference &active_reference);
00058
00059         virtual AudioSourceType GetSource() const; //override
00060
00062
00066         virtual BOOLEAN SetPlayPosition(AudioActiveReference &playing_reference);
00067
00072         virtual BOOLEAN GetPlayPosition(AudioActiveReference &playing_reference);
00073
00078         virtual BOOLEAN GetTotalPlayTime(AudioActiveReference &playing_reference);
00079
00080         static AudioDeviceBase* GetInstance();
00081         virtual Vector<AudioPlayer::MimeTypeSupportInfo> GetMimeTypeSupportInfo() const;
00082
00083     protected:
00084         virtual BOOLEAN Play_Allocate(AudioActiveReference &audio_ref);
00085         virtual BOOLEAN Play_Implementation(AudioActiveReference &playing_ref);
00086         virtual BOOLEAN Stop_Implementation(AudioActiveReference &active_reference);
00087         virtual BOOLEAN Suspend_Implementation(AudioActiveReference &playing_reference);
00088         virtual BOOLEAN Resume_Implementation(AudioActiveReference &playing_reference);
00089
00090         virtual BOOLEAN OnSdlSignal(UINT16 func_id, UINT8 handle, UINT16 drv_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00091         virtual void OnRecordingFinished(INT8 return_code, UINT32 param);
00092
00093         virtual UINT16 GetDeviceID() const; //override
00094     private:
00096     VoiceMemoAudioPlayer();
00097
00099     VoiceMemoAudioPlayer(const VoiceMemoAudioPlayer& obj);
00100
00101
00102         static VoiceMemoAudioPlayer m_singleton_instance;
00103         INT MapFormat( StreamAudioReference::DspFormat format);
00104         INT MapMode (StreamAudioReference::Mode mode);
00105
00106 };
00107 #endif //DOXYGEN_SHOULD_SKIP_THIS
00108
00110 #endif  // Apoxi_AudioNewAPI_VoiceMemoAudioPlayer_hpp
00111
00112
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/VoiceMemoAudioReference.cpp File Reference

Audio/VoiceMemoAudioReference.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include <Audio/VoiceMemoAudioReference.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Afs/Rfs/Pathname.hpp>

Include dependency graph for VoiceMemoAudioReference.cpp:

Generated on Tue Jan 24 18:12:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/VoiceMemoAudioReference.hpp File Reference

Audio/VoiceMemoAudioReference.hpp File Reference

#include <Audio/StreamAudioReference.hpp>

Include dependency graph for VoiceMemoAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_VoiceMemoAudioReference_hpp

Define Documentation

#define Apoxi_AudioNewAPI_VoiceMemoAudioReference_hpp

Generated on Tue Jan 24 18:13:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/VoiceMemoAudioReference.hpp Source File

Audio/VoiceMemoAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_VoiceMemoAudioReference_hpp)
00011 #define Apoxi_AudioNewAPI_VoiceMemoAudioReference_hpp
00014
00015 #include <Audio/StreamAudioReference.hpp>
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00023 class VoiceMemoAudioReference : public StreamAudioReference
00024 {
00025     public:
00035         VoiceMemoAudioReference(const Path& filename, Mode mode, DspFormat format);
00036
00046         VoiceMemoAudioReference(BufferType buffer_handle, BufferByteType buffer_size, Mode mode,  DspFormat format);
00047
00056         VoiceMemoAudioReference(const String& filename, Mode mode, DspFormat format);
00057
00063         VoiceMemoAudioReference(Mode mode, DspFormat format);
00064
00068         virtual ~VoiceMemoAudioReference();
00069
00073         virtual enumClassType GetClassType() const;
00074
00079         virtual UINT16 GetDelay(void) const;
00080 };
00081 #endif //DOXYGEN_SHOULD_SKIP_THIS
00082
00083 #endif  // Apoxi_AudioNewAPI_VoiceMemoAudioReference_hpp
00084
00085
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioDeviceStatusMsg.cpp File Reference

Audio/Messages/AudioDeviceStatusMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioDeviceStatusMsg.hpp"

Include dependency graph for AudioDeviceStatusMsg.cpp:

Generated on Tue Jan 24 18:09:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioDeviceStatusMsg.hpp File Reference

Audio/Messages/AudioDeviceStatusMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Audio/AudioDeviceManager.hpp>

Include dependency graph for AudioDeviceStatusMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioDeviceStatusMsg

Defines

#define | Apoxi_Audio_AudioDeviceStatusMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioDeviceStatusMsg_hpp

Generated on Tue Jan 24 18:09:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioDeviceStatusMsg.hpp Source File

Audio/Messages/AudioDeviceStatusMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioDeviceStatusMsg_hpp)
00016 #define Apoxi_Audio_AudioDeviceStatusMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Audio/AudioDeviceManager.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class AudioDeviceStatusMsg
00029     ====================================================================== */
00030
00032 class AudioDeviceStatusMsg : public Message {
00033     public:
00034         AudioDeviceStatusMsg(const AudioDeviceManager::AudioDeviceID& device_id, const AudioDeviceBase::AudioDeviceStatus& device_status);
00035         virtual ~AudioDeviceStatusMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         void SetDeviceId(const AudioDeviceManager::AudioDeviceID& device_id) { m_device_id = device_id; }
00039         const AudioDeviceManager::AudioDeviceID& GetDeviceId() const { return m_device_id; }
00040         void SetDeviceStatus(const AudioDeviceBase::AudioDeviceStatus& device_status) { m_device_status = device_status; }
00041         const AudioDeviceBase::AudioDeviceStatus& GetDeviceStatus() const { return m_device_status; }
00042         virtual Message* Clone() const;
00043
00044         enum  {
00045             ID = 9005
00046             };
00047
00048     private:
00049         static const MsgMetaData m_meta_data;
00050         AudioDeviceManager::AudioDeviceID m_device_id;
00051         AudioDeviceBase::AudioDeviceStatus m_device_status;
00052
00053     };
00054
00055 #endif // Apoxi_Audio_AudioDeviceStatusMsg_hpp
00056
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioErrorMsg.cpp File Reference

Audio/Messages/AudioErrorMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "Audio/AudioReference.hpp"
#include "Audio/AudioError.hpp"
#include "AudioErrorMsg.hpp"

Include dependency graph for AudioErrorMsg.cpp:

Generated on Tue Jan 24 18:09:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioErrorMsg.hpp File Reference

Audio/Messages/AudioErrorMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Audio/AudioError.hpp>

Include dependency graph for AudioErrorMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioErrorMsg

Defines

#define | Apoxi_Audio_AudioErrorMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioErrorMsg_hpp

Generated on Tue Jan 24 16:54:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioErrorMsg.hpp Source File

Audio/Messages/AudioErrorMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioErrorMsg_hpp)
00016 #define Apoxi_Audio_AudioErrorMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Auxiliary/SharedPtr.hpp>
00022 #include <Audio/AudioError.hpp>
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class AudioErrorMsg
00030     ====================================================================== */
00031
00033 class AudioErrorMsg : public Message {
00034     public:
00035         AudioErrorMsg(const SharedPtr<AudioReference>& audio_reference, const AudioError::ErrorType& audio_error);
00036         virtual ~AudioErrorMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         void SetAudioReference(const SharedPtr<AudioReference>& audio_reference) { m_audio_reference = audio_reference; }
00040         const SharedPtr<AudioReference>& GetAudioReference() const { return m_audio_reference; }
00041         void SetAudioError(const AudioError::ErrorType& audio_error) { m_audio_error = audio_error; }
00042         const AudioError::ErrorType& GetAudioError() const { return m_audio_error; }
00043         virtual Message* Clone() const;
00044
00045         enum  {
00046             ID = 9004
00047             };
00048
00049     private:
00050         static const MsgMetaData m_meta_data;
00051         SharedPtr<AudioReference> m_audio_reference;
00052         AudioError::ErrorType m_audio_error;
00053
00054     };
00055
00056 #endif // Apoxi_Audio_AudioErrorMsg_hpp
00057
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioGetPlayPositionMsg.cpp File Reference

Audio/Messages/AudioGetPlayPositionMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioGetPlayPositionMsg.hpp"

Include dependency graph for AudioGetPlayPositionMsg.cpp:

Generated on Tue Jan 24 18:09:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioGetPlayPositionMsg.hpp File Reference

Audio/Messages/AudioGetPlayPositionMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for AudioGetPlayPositionMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioGetPlayPositionMsg

Defines

#define | Apoxi_Audio_AudioGetPlayPositionMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioGetPlayPositionMsg_hpp

Generated on Tue Jan 24 18:09:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioGetPlayPositionMsg.hpp Source File

Audio/Messages/AudioGetPlayPositionMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioGetPlayPositionMsg_hpp)
00016 #define Apoxi_Audio_AudioGetPlayPositionMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Audio/AudioActiveReference.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class AudioGetPlayPositionMsg
00030     ====================================================================== */
00031
00033 class AudioGetPlayPositionMsg : public Message {
00034     public:
00035         AudioGetPlayPositionMsg(const SharedPtr<AudioActiveReference>& active_reference, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00036         virtual ~AudioGetPlayPositionMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00040         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00041         void SetParam1(UINT32 param1) { m_param1 = param1; }
00042         UINT32 GetParam1() const { return m_param1; }
00043         void SetParam2(UINT32 param2) { m_param2 = param2; }
00044         UINT32 GetParam2() const { return m_param2; }
00045         void SetParam3(UINT32 param3) { m_param3 = param3; }
00046         UINT32 GetParam3() const { return m_param3; }
00047         void SetParam4(UINT32 param4) { m_param4 = param4; }
00048         UINT32 GetParam4() const { return m_param4; }
00049         virtual Message* Clone() const;
00050
00051         enum  {
00052             ID = 9011
00053             };
00054
00055     private:
00056         static const MsgMetaData m_meta_data;
00057         SharedPtr<AudioActiveReference> m_active_reference;
00058         UINT32 m_param1;
00059         UINT32 m_param2;
00060         UINT32 m_param3;
00061         UINT32 m_param4;
00062
00063     };
00064
00065 #endif // Apoxi_Audio_AudioGetPlayPositionMsg_hpp
00066
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioMessages.cpp File Reference

Audio/Messages/AudioMessages.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "Audio/AudioActiveReference.hpp"
#include "Audio/AudioAccessoryDetails.hpp"
#include "AudioMessages.hpp"

Include dependency graph for AudioMessages.cpp:

Generated on Tue Jan 24 18:09:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioMessages.hpp File Reference

Audio/Messages/AudioMessages.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Audio/AudioAccessoryDetails.hpp>

Include dependency graph for AudioMessages.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioAccessoryConnectedMsg
class | AudioFastForwardStartedMsg
class | AudioFmRadioRdsAlternativeFrequenciesMsg
class | AudioFmRadioRdsInfoMsg
class | AudioFmRadioRdsRadioTextMsg
class | AudioFmRadioRdsRawDataMsg
class | AudioFmRadioRdsStationNameMsg
class | AudioFmRadioRssiMsg
class | AudioFmRadioSeekMsg
class | AudioRecordingStoppedMsg
class | AudioRewindStartedMsg
class | AudioUserDefinedMsg

Defines

#define | Apoxi_Audio_AudioMessages_hpp

Define Documentation

#define Apoxi_Audio_AudioMessages_hpp

Generated on Tue Jan 24 18:09:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioMessages.hpp Source File

Audio/Messages/AudioMessages.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "neudorfe_mmfr_pu_dv\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Apoxi_Audio_AudioMessages_hpp)
00014 #define Apoxi_Audio_AudioMessages_hpp
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Kernel/Message.hpp>
00017 #include <Apc/SignalTypes.hpp>
00018 #include <Audio/AudioAccessoryDetails.hpp>
00019 /* ----------------------------------------------------------------------
00020     Classes
00021     ---------------------------------------------------------------------- */
00022 /*  ======================================================================
00023     Class AudioUserDefinedMsg
00024     ====================================================================== */
00026 class AudioUserDefinedMsg : public Message {
00027     public:
00028         AudioUserDefinedMsg(UINT8 messageID, UINT16 senderID, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00029         virtual ~AudioUserDefinedMsg();
00030
00031         virtual const MsgMetaData& GetMetaData() const;
00032         void SetMessageID(UINT8 messageID) { m_messageID = messageID; }
00033         UINT8 GetMessageID() const { return m_messageID; }
00034         void SetSenderID(UINT16 senderID) { m_senderID = senderID; }
00035         UINT16 GetSenderID() const { return m_senderID; }
00036         void SetParam1(UINT32 param1) { m_param1 = param1; }
00037         UINT32 GetParam1() const { return m_param1; }
00038         void SetParam2(UINT32 param2) { m_param2 = param2; }
00039         UINT32 GetParam2() const { return m_param2; }
00040         void SetParam3(UINT32 param3) { m_param3 = param3; }
00041         UINT32 GetParam3() const { return m_param3; }
00042         void SetParam4(UINT32 param4) { m_param4 = param4; }
00043         UINT32 GetParam4() const { return m_param4; }
00044         virtual Message* Clone() const;
00045
00046         enum  {
00047             ID = 9012
00048             };
00049
00050     private:
00051         static const MsgMetaData m_meta_data;
00052         UINT8 m_messageID;
00053         UINT16 m_senderID;
00054         UINT32 m_param1;
00055         UINT32 m_param2;
00056         UINT32 m_param3;
00057         UINT32 m_param4;
00058
00059     };
00060 /*  ======================================================================
00061     Class AudioRecordingStoppedMsg
00062     ====================================================================== */
00064 class AudioRecordingStoppedMsg : public Message {
00065     public:
00066         AudioRecordingStoppedMsg(const SharedPtr<AudioActiveReference>& active_reference);
00067         virtual ~AudioRecordingStoppedMsg();
00068
00069         virtual const MsgMetaData& GetMetaData() const;
00070         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00071         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00072         virtual Message* Clone() const;
00073
00074         enum  {
00075             ID = 9013
00076             };
00077
00078     private:
00079         static const MsgMetaData m_meta_data;
00080         SharedPtr<AudioActiveReference> m_active_reference;
00081
00082     };
00083 /*  ======================================================================
00084     Class AudioAccessoryConnectedMsg
00085     ====================================================================== */
00087 class AudioAccessoryConnectedMsg : public Message {
00088     public:
00089         AudioAccessoryConnectedMsg(const AudioAccessoryDetails::AudioAccessoryConfigurationType& accessory_configuration_type, BOOLEAN connected);
00090         virtual ~AudioAccessoryConnectedMsg();
00091
00092         virtual const MsgMetaData& GetMetaData() const;
00093         void SetAccessoryConfigurationType(const AudioAccessoryDetails::AudioAccessoryConfigurationType& accessory_configuration_type) { m_accessory_configuration_type = accessory_configuration_type; }
00094         const AudioAccessoryDetails::AudioAccessoryConfigurationType& GetAccessoryConfigurationType() const { return m_accessory_configuration_type; }
00095         void SetConnected(BOOLEAN connected) { m_connected = connected; }
00096         BOOLEAN IsConnected() const { return m_connected; }
00097         virtual Message* Clone() const;
00098
00099         enum  {
00100             ID = 9014
00101             };
00102
00103     private:
00104         static const MsgMetaData m_meta_data;
00105         AudioAccessoryDetails::AudioAccessoryConfigurationType m_accessory_configuration_type;
00106         BOOLEAN m_connected;
00107
00108     };
00109 /*  ======================================================================
00110     Class AudioFmRadioSeekMsg
00111     ====================================================================== */
00113 class AudioFmRadioSeekMsg : public Message {
00114     public:
00115         AudioFmRadioSeekMsg(BOOLEAN success, UINT32 frequency);
00116         virtual ~AudioFmRadioSeekMsg();
00117
00118         virtual const MsgMetaData& GetMetaData() const;
00119         BOOLEAN IsSuccess() const { return m_success; }
00120         UINT32 GetFrequency() const { return m_frequency; }
00121         virtual Message* Clone() const;
00122
00123         enum  {
00124             ID = 9015
00125             };
00126
00127     private:
00128         static const MsgMetaData m_meta_data;
00129         BOOLEAN m_success;
00130         UINT32 m_frequency;
00131
00132     };
00133 /*  ======================================================================
00134     Class AudioFmRadioRssiMsg
00135     ====================================================================== */
00137 class AudioFmRadioRssiMsg : public Message {
00138     public:
00139         AudioFmRadioRssiMsg(UINT8 signalLevel, BOOLEAN stereo);
00140         virtual ~AudioFmRadioRssiMsg();
00141
00142         virtual const MsgMetaData& GetMetaData() const;
00143         UINT8 GetSignalLevel() const { return m_signalLevel; }
00144         BOOLEAN IsStereo() const { return m_stereo; }
00145         virtual Message* Clone() const;
00146
00147         enum  {
00148             ID = 9016
00149             };
00150
00151     private:
00152         static const MsgMetaData m_meta_data;
00153         UINT8 m_signalLevel;
00154         BOOLEAN m_stereo;
00155
00156     };
00157 /*  ======================================================================
00158     Class AudioFmRadioRdsRawDataMsg
00159     ====================================================================== */
00162 class AudioFmRadioRdsRawDataMsg : public Message {
00163     public:
00164         AudioFmRadioRdsRawDataMsg(UINT8* buffer, UINT16 buffer_size);
00165         virtual ~AudioFmRadioRdsRawDataMsg();
00166
00167         virtual const MsgMetaData& GetMetaData() const;
00168         UINT8* GetBuffer() const { return m_buffer; }
00169         UINT16 GetBufferSize() const { return m_buffer_size; }
00170         virtual Message* Clone() const;
00171
00172         enum  {
00173             ID = 9017
00174             };
00175
00176     private:
00177         static const MsgMetaData m_meta_data;
00178         UINT8* m_buffer;
00179         UINT16 m_buffer_size;
00180
00181     };
00182 /*  ======================================================================
00183     Class AudioFmRadioRdsStationNameMsg
00184     ====================================================================== */
00187 class AudioFmRadioRdsStationNameMsg : public Message {
00188     public:
00189         AudioFmRadioRdsStationNameMsg(const WString& stationName, BOOLEAN trafficAnnouncementSet);
00190         virtual ~AudioFmRadioRdsStationNameMsg();
00191
00192         virtual const MsgMetaData& GetMetaData() const;
00193         const WString& GetStationName() const { return m_stationName; }
00194         BOOLEAN IsTrafficAnnouncementSet() const { return m_trafficAnnouncementSet; }
00195         virtual Message* Clone() const;
00196
00197         enum  {
00198             ID = 9018
00199             };
00200
00201     private:
00202         static const MsgMetaData m_meta_data;
00203         WString m_stationName;
00204         BOOLEAN m_trafficAnnouncementSet;
00205
00206     };
00207 /*  ======================================================================
00208     Class AudioFmRadioRdsRadioTextMsg
00209     ====================================================================== */
00212 class AudioFmRadioRdsRadioTextMsg : public Message {
00213     public:
00214         AudioFmRadioRdsRadioTextMsg(const WString& radioText);
00215         virtual ~AudioFmRadioRdsRadioTextMsg();
00216
00217         virtual const MsgMetaData& GetMetaData() const;
00218         const WString& GetRadioText() const { return m_radioText; }
00219         virtual Message* Clone() const;
00220
00221         enum  {
00222             ID = 9019
00223             };
00224
00225     private:
00226         static const MsgMetaData m_meta_data;
00227         WString m_radioText;
00228
00229     };
00230 /*  ======================================================================
00231     Class AudioFmRadioRdsInfoMsg
00232     ====================================================================== */
00235 class AudioFmRadioRdsInfoMsg : public Message {
00236     public:
00237         AudioFmRadioRdsInfoMsg(UINT16 programIdentifier, UINT8 programType, BOOLEAN trafficProgramSet);
00238         virtual ~AudioFmRadioRdsInfoMsg();
00239
00240         virtual const MsgMetaData& GetMetaData() const;
00241         UINT16 GetProgramIdentifier() const { return m_programIdentifier; }
00242         UINT8 GetProgramType() const { return m_programType; }
00243         BOOLEAN IsTrafficProgramSet() const { return m_trafficProgramSet; }
00244         virtual Message* Clone() const;
00245
00246         enum  {
00247             ID = 9020
00248             };
00249
00250     private:
00251         static const MsgMetaData m_meta_data;
00252         UINT16 m_programIdentifier;
00253         UINT8 m_programType;
00254         BOOLEAN m_trafficProgramSet;
00255
00256     };
00257 /*  ======================================================================
00258     Class AudioFmRadioRdsAlternativeFrequenciesMsg
00259     ====================================================================== */
00262 class AudioFmRadioRdsAlternativeFrequenciesMsg : public Message {
00263     public:
00264         AudioFmRadioRdsAlternativeFrequenciesMsg(UINT8 numberOfFrequencies, UINT32* frequencies);
00265         virtual ~AudioFmRadioRdsAlternativeFrequenciesMsg();
00266
00267         virtual const MsgMetaData& GetMetaData() const;
00268         UINT8 GetNumberOfFrequencies() const { return m_numberOfFrequencies; }
00269         UINT32* GetFrequencies() const { return m_frequencies; }
00270         virtual Message* Clone() const;
00271
00272         enum  {
00273             ID = 9021
00274             };
00275
00276     private:
00277         static const MsgMetaData m_meta_data;
00278         UINT8 m_numberOfFrequencies;
00279         UINT32* m_frequencies;
00280
00281     };
00282 /*  ======================================================================
00283     Class AudioFastForwardStartedMsg
00284     ====================================================================== */
00286 class AudioFastForwardStartedMsg : public Message {
00287     public:
00288         AudioFastForwardStartedMsg(const SharedPtr<AudioActiveReference>& active_reference);
00289         virtual ~AudioFastForwardStartedMsg();
00290
00291         virtual const MsgMetaData& GetMetaData() const;
00292         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00293         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00294         virtual Message* Clone() const;
00295
00296         enum  {
00297             ID = 9022
00298             };
00299
00300     private:
00301         static const MsgMetaData m_meta_data;
00302         SharedPtr<AudioActiveReference> m_active_reference;
00303
00304     };
00305 /*  ======================================================================
00306     Class AudioRewindStartedMsg
00307     ====================================================================== */
00309 class AudioRewindStartedMsg : public Message {
00310     public:
00311         AudioRewindStartedMsg(const SharedPtr<AudioActiveReference>& active_reference);
00312         virtual ~AudioRewindStartedMsg();
00313
00314         virtual const MsgMetaData& GetMetaData() const;
00315         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00316         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00317         virtual Message* Clone() const;
00318
00319         enum  {
00320             ID = 9023
00321             };
00322
00323     private:
00324         static const MsgMetaData m_meta_data;
00325         SharedPtr<AudioActiveReference> m_active_reference;
00326
00327     };
00328 #endif // Apoxi_Audio_AudioMessages_hpp
00329
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioMsg.cpp File Reference

Audio/Messages/AudioMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioMsg.hpp"

Include dependency graph for AudioMsg.cpp:

Generated on Tue Jan 24 18:09:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioMsg.hpp File Reference

Audio/Messages/AudioMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for AudioMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioMsg

Defines

#define | Apoxi_Audio_AudioMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioMsg_hpp

Generated on Tue Jan 24 16:54:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioMsg.hpp Source File

Audio/Messages/AudioMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioMsg_hpp)
00016 #define Apoxi_Audio_AudioMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class AudioMsg
00029     ====================================================================== */
00030
00032 class AudioMsg : public Message {
00033     public:
00034         AudioMsg(UINT8 handle, UINT16 drv_id, UINT16 funk_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4);
00035         virtual ~AudioMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         void SetHandle(UINT8 handle) { m_handle = handle; }
00039         UINT8 GetHandle() const { return m_handle; }
00040         void SetDrvId(UINT16 drv_id) { m_drv_id = drv_id; }
00041         UINT16 GetDrvId() const { return m_drv_id; }
00042         void SetFunkId(UINT16 funk_id) { m_funk_id = funk_id; }
00043         UINT16 GetFunkId() const { return m_funk_id; }
00044         void SetReturnCode(INT8 return_code) { m_return_code = return_code; }
00045         INT8 GetReturnCode() const { return m_return_code; }
00046         void SetParam1(UINT32 param1) { m_param1 = param1; }
00047         UINT32 GetParam1() const { return m_param1; }
00048         void SetParam2(UINT32 param2) { m_param2 = param2; }
00049         UINT32 GetParam2() const { return m_param2; }
00050         void SetParam3(UINT32 param3) { m_param3 = param3; }
00051         UINT32 GetParam3() const { return m_param3; }
00052         void SetParam4(UINT32 param4) { m_param4 = param4; }
00053         UINT32 GetParam4() const { return m_param4; }
00054         virtual Message* Clone() const;
00055
00056         enum  {
00057             ID = 9000
00058             };
00059
00060     private:
00061         static const MsgMetaData m_meta_data;
00062         UINT8 m_handle;
00063         UINT16 m_drv_id;
00064         UINT16 m_funk_id;
00065         INT8 m_return_code;
00066         UINT32 m_param1;
00067         UINT32 m_param2;
00068         UINT32 m_param3;
00069         UINT32 m_param4;
00070
00071     };
00072
00073 #endif // Apoxi_Audio_AudioMsg_hpp
00074
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioPlayTimeMsg.cpp File Reference

Audio/Messages/AudioPlayTimeMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioPlayTimeMsg.hpp"

Include dependency graph for AudioPlayTimeMsg.cpp:

Generated on Tue Jan 24 18:10:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioPlayTimeMsg.hpp File Reference

Audio/Messages/AudioPlayTimeMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for AudioPlayTimeMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioPlayTimeMsg

Defines

#define | Apoxi_Devices_AudioPlayTimeMsg_hpp

Define Documentation

#define Apoxi_Devices_AudioPlayTimeMsg_hpp

Generated on Tue Jan 24 18:10:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioPlayTimeMsg.hpp Source File

Audio/Messages/AudioPlayTimeMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "simonal_view_sgold_lite\lnz_apoxi\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Apoxi_Devices_AudioPlayTimeMsg_hpp)
00014 #define Apoxi_Devices_AudioPlayTimeMsg_hpp
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Kernel/Message.hpp>
00017 #include <Apc/SignalTypes.hpp>
00018 /* ----------------------------------------------------------------------
00019     Classes
00020     ---------------------------------------------------------------------- */
00021 /*  ======================================================================
00022     Class AudioPlayTimeMsg
00023     ====================================================================== */
00025 class AudioPlayTimeMsg : public Message {
00026     public:
00027         AudioPlayTimeMsg(UINT32 play_time);
00028         virtual ~AudioPlayTimeMsg();
00029
00030         virtual const MsgMetaData& GetMetaData() const;
00031         void SetPlayTime(UINT32 play_time) { m_play_time = play_time; }
00032         UINT32 GetPlayTime() const { return m_play_time; }
00033         virtual Message* Clone() const;
00034
00035         enum  {
00036             ID = 9009
00037             };
00038
00039     private:
00040         static const MsgMetaData m_meta_data;
00041         UINT32 m_play_time;
00042
00043     };
00044 #endif // Apoxi_Devices_AudioPlayTimeMsg_hpp
00045
00046
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioRadioDeviceNotificationMsg.cpp File Reference

Audio/Messages/AudioRadioDeviceNotificationMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioRadioDeviceNotificationMsg.hpp"

Include dependency graph for AudioRadioDeviceNotificationMsg.cpp:

Generated on Tue Jan 24 18:10:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioRadioDeviceNotificationMsg.hpp File Reference

Audio/Messages/AudioRadioDeviceNotificationMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Audio/RadioAudioDevice.hpp>

Include dependency graph for AudioRadioDeviceNotificationMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioRadioDeviceNotificationMsg

Defines

#define | Apoxi_Audio_AudioRadioDeviceNotificationMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioRadioDeviceNotificationMsg_hpp

Generated on Tue Jan 24 18:10:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioRadioDeviceNotificationMsg.hpp Source File

Audio/Messages/AudioRadioDeviceNotificationMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioRadioDeviceNotificationMsg_hpp)
00016 #define Apoxi_Audio_AudioRadioDeviceNotificationMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Audio/RadioAudioDevice.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class AudioRadioDeviceNotificationMsg
00029     ====================================================================== */
00030
00032 class AudioRadioDeviceNotificationMsg : public Message {
00033     public:
00034         AudioRadioDeviceNotificationMsg(const RadioAudioDevice::NotificationType& type);
00035         virtual ~AudioRadioDeviceNotificationMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         const RadioAudioDevice::NotificationType& GetType() const { return m_type; }
00039         virtual Message* Clone() const;
00040
00041         enum  {
00042             ID = 9007
00043             };
00044
00045     private:
00046         static const MsgMetaData m_meta_data;
00047         RadioAudioDevice::NotificationType m_type;
00048
00049     };
00050
00051 #endif // Apoxi_Audio_AudioRadioDeviceNotificationMsg_hpp
00052
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioRestartedMsg.cpp File Reference

Audio/Messages/AudioRestartedMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioRestartedMsg.hpp"

Include dependency graph for AudioRestartedMsg.cpp:

Generated on Tue Jan 24 18:10:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioRestartedMsg.hpp File Reference

Audio/Messages/AudioRestartedMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for AudioRestartedMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioRestartedMsg

Defines

#define | Apoxi_Audio_AudioRestartedMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioRestartedMsg_hpp

Generated on Tue Jan 24 18:10:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioRestartedMsg.hpp Source File

Audio/Messages/AudioRestartedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioRestartedMsg_hpp)
00016 #define Apoxi_Audio_AudioRestartedMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Audio/AudioActiveReference.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class AudioRestartedMsg
00030     ====================================================================== */
00031
00033 class AudioRestartedMsg : public Message {
00034     public:
00035         AudioRestartedMsg(const SharedPtr<AudioActiveReference>& active_reference);
00036         virtual ~AudioRestartedMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00040         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 9006
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         SharedPtr<AudioActiveReference> m_active_reference;
00050
00051     };
00052
00053 #endif // Apoxi_Audio_AudioRestartedMsg_hpp
00054
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioResumedMsg.cpp File Reference

Audio/Messages/AudioResumedMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioResumedMsg.hpp"

Include dependency graph for AudioResumedMsg.cpp:

Generated on Tue Jan 24 18:10:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioResumedMsg.hpp File Reference

Audio/Messages/AudioResumedMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for AudioResumedMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioResumedMsg

Defines

#define | Apoxi_Audio_AudioResumedMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioResumedMsg_hpp

Generated on Tue Jan 24 18:10:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioResumedMsg.hpp Source File

Audio/Messages/AudioResumedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioResumedMsg_hpp)
00016 #define Apoxi_Audio_AudioResumedMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Audio/AudioActiveReference.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class AudioResumedMsg
00030     ====================================================================== */
00031
00033 class AudioResumedMsg : public Message {
00034     public:
00035         AudioResumedMsg(const SharedPtr<AudioActiveReference>& active_reference);
00036         virtual ~AudioResumedMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00040         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 9010
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         SharedPtr<AudioActiveReference> m_active_reference;
00050
00051     };
00052
00053 #endif // Apoxi_Audio_AudioResumedMsg_hpp
00054
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStartedMsg.cpp File Reference

Audio/Messages/AudioStartedMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioStartedMsg.hpp"

Include dependency graph for AudioStartedMsg.cpp:

Generated on Tue Jan 24 18:10:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStartedMsg.hpp File Reference

Audio/Messages/AudioStartedMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for AudioStartedMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioStartedMsg

Defines

#define | Apoxi_Audio_AudioStartedMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioStartedMsg_hpp

Generated on Tue Jan 24 18:10:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStartedMsg.hpp Source File

Audio/Messages/AudioStartedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioStartedMsg_hpp)
00016 #define Apoxi_Audio_AudioStartedMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Audio/AudioActiveReference.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class AudioStartedMsg
00030     ====================================================================== */
00031
00033 class AudioStartedMsg : public Message {
00034     public:
00035         AudioStartedMsg(const SharedPtr<AudioActiveReference>& active_reference);
00036         virtual ~AudioStartedMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00040         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 9009
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         SharedPtr<AudioActiveReference> m_active_reference;
00050
00051     };
00052
00053 #endif // Apoxi_Audio_AudioStartedMsg_hpp
00054
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStoppedMsg.cpp File Reference

Audio/Messages/AudioStoppedMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioStoppedMsg.hpp"

Include dependency graph for AudioStoppedMsg.cpp:

Generated on Tue Jan 24 18:10:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStoppedMsg.hpp File Reference

Audio/Messages/AudioStoppedMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Audio/AudioDeviceBase.hpp>
#include <Audio/AudioActiveReference.hpp>

Include dependency graph for AudioStoppedMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioStoppedMsg

Defines

#define | Apoxi_Audio_AudioStoppedMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioStoppedMsg_hpp

Generated on Tue Jan 24 16:54:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStoppedMsg.hpp Source File

Audio/Messages/AudioStoppedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Apoxi_Audio_AudioStoppedMsg_hpp)
00014 #define Apoxi_Audio_AudioStoppedMsg_hpp
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Kernel/Message.hpp>
00017 #include <Apc/SignalTypes.hpp>
00018 #include <Auxiliary/SharedPtr.hpp>
00019 #include <Audio/AudioDeviceBase.hpp>
00020 #include <Audio/AudioActiveReference.hpp>
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024 /*  ======================================================================
00025     Class AudioStoppedMsg
00026     ====================================================================== */
00028 class AudioStoppedMsg : public Message {
00029     public:
00030         AudioStoppedMsg(const SharedPtr<AudioActiveReference>& active_reference, BOOLEAN auto_stopped, const AudioDeviceBase::StopCause& stop_cause, const AudioDeviceBase::AudioErrorType& audio_error_type);
00031         virtual ~AudioStoppedMsg();
00032
00033         virtual const MsgMetaData& GetMetaData() const;
00034         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00035         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00036         void SetAutoStopped(BOOLEAN auto_stopped) { m_auto_stopped = auto_stopped; }
00037         BOOLEAN IsAutoStopped() const { return m_auto_stopped; }
00038         void SetStopCause(const AudioDeviceBase::StopCause& stop_cause) { m_stop_cause = stop_cause; }
00039         const AudioDeviceBase::StopCause& GetStopCause() const { return m_stop_cause; }
00040         void SetAudioErrorType(const AudioDeviceBase::AudioErrorType& audio_error_type) { m_audio_error_type = audio_error_type; }
00041         const AudioDeviceBase::AudioErrorType& GetAudioErrorType() const { return m_audio_error_type; }
00042         virtual Message* Clone() const;
00043
00044         enum  {
00045             ID = 9001
00046             };
00047
00048     private:
00049         static const MsgMetaData m_meta_data;
00050         SharedPtr<AudioActiveReference> m_active_reference;
00051         BOOLEAN m_auto_stopped;
00052         AudioDeviceBase::StopCause m_stop_cause;
00053         AudioDeviceBase::AudioErrorType m_audio_error_type;
00054
00055     };
00056 #endif // Apoxi_Audio_AudioStoppedMsg_hpp
00057
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStreamingSyncMsg.cpp File Reference

Audio/Messages/AudioStreamingSyncMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AudioStreamingSyncMsg.hpp"

Include dependency graph for AudioStreamingSyncMsg.cpp:

Generated on Tue Jan 24 18:10:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStreamingSyncMsg.hpp File Reference

Audio/Messages/AudioStreamingSyncMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for AudioStreamingSyncMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioStreamingSyncMsg

Defines

#define | Apoxi_Audio_AudioStreamingSyncMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioStreamingSyncMsg_hpp

Generated on Tue Jan 24 18:10:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioStreamingSyncMsg.hpp Source File

Audio/Messages/AudioStreamingSyncMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioStreamingSyncMsg_hpp)
00016 #define Apoxi_Audio_AudioStreamingSyncMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class AudioStreamingSyncMsg
00029     ====================================================================== */
00030
00032 class AudioStreamingSyncMsg : public Message {
00033     public:
00034         AudioStreamingSyncMsg();
00035         virtual ~AudioStreamingSyncMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         virtual Message* Clone() const;
00039
00040         enum  {
00041             ID = 9008
00042             };
00043
00044     private:
00045         static const MsgMetaData m_meta_data;
00046
00047     };
00048
00049 #endif // Apoxi_Audio_AudioStreamingSyncMsg_hpp
00050
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioSuspendedMsg.cpp File Reference

Audio/Messages/AudioSuspendedMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "Audio/AudioActiveReference.hpp"
#include "AudioSuspendedMsg.hpp"

Include dependency graph for AudioSuspendedMsg.cpp:

Generated on Tue Jan 24 18:10:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioSuspendedMsg.hpp File Reference

Audio/Messages/AudioSuspendedMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for AudioSuspendedMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioSuspendedMsg

Defines

#define | Apoxi_Audio_AudioSuspendedMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioSuspendedMsg_hpp

Generated on Tue Jan 24 16:54:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioSuspendedMsg.hpp Source File

Audio/Messages/AudioSuspendedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioSuspendedMsg_hpp)
00016 #define Apoxi_Audio_AudioSuspendedMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class AudioSuspendedMsg
00029     ====================================================================== */
00030
00032 class AudioSuspendedMsg : public Message {
00033     public:
00034         AudioSuspendedMsg(const SharedPtr<AudioActiveReference>& active_reference);
00035         virtual ~AudioSuspendedMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00039         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00040         virtual Message* Clone() const;
00041
00042         enum  {
00043             ID = 9003
00044             };
00045
00046     private:
00047         static const MsgMetaData m_meta_data;
00048         SharedPtr<AudioActiveReference> m_active_reference;
00049
00050     };
00051
00052 #endif // Apoxi_Audio_AudioSuspendedMsg_hpp
00053
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.cpp File Reference

Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "Audio/AudioActiveReference.hpp"
#include "AudioVoiceMemoOutOfSpaceMsg.hpp"

Include dependency graph for AudioVoiceMemoOutOfSpaceMsg.cpp:

Generated on Tue Jan 24 18:10:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp File Reference

Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>

Include dependency graph for AudioVoiceMemoOutOfSpaceMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioVoiceMemoOutOfSpaceMsg

Defines

#define | Apoxi_Audio_AudioVoiceMemoOutOfSpaceMsg_hpp

Define Documentation

#define Apoxi_Audio_AudioVoiceMemoOutOfSpaceMsg_hpp

Generated on Tue Jan 24 16:54:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp Source File

Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Audio\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Audio_AudioVoiceMemoOutOfSpaceMsg_hpp)
00016 #define Apoxi_Audio_AudioVoiceMemoOutOfSpaceMsg_hpp
00017
00018 #include <Kernel/Os/Os.hpp>
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class AudioVoiceMemoOutOfSpaceMsg
00029     ====================================================================== */
00030
00033 class AudioVoiceMemoOutOfSpaceMsg : public Message {
00034     public:
00035         AudioVoiceMemoOutOfSpaceMsg(const SharedPtr<AudioActiveReference>& active_reference);
00036         virtual ~AudioVoiceMemoOutOfSpaceMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         void SetActiveReference(const SharedPtr<AudioActiveReference>& active_reference) { m_active_reference = active_reference; }
00040         const SharedPtr<AudioActiveReference>& GetActiveReference() const { return m_active_reference; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 9002
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         SharedPtr<AudioActiveReference> m_active_reference;
00050
00051     };
00052
00053 #endif // Apoxi_Audio_AudioVoiceMemoOutOfSpaceMsg_hpp
00054
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/DataSourceRtStreamingSource.cpp File Reference

Audio/RtStreaming/DataSourceRtStreamingSource.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "DataSourceRtStreamingSource.hpp"
#include <Kernel/ApoxiThread.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/Os/Semaphore.hpp>

Include dependency graph for DataSourceRtStreamingSource.cpp:

Generated on Tue Jan 24 18:10:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/DataSourceRtStreamingSource.hpp File Reference

Audio/RtStreaming/DataSourceRtStreamingSource.hpp File Reference

#include <Audio/RtStreaming/RtStreamingEndPoint.hpp>
#include <Audio/RtStreaming/RtStreamingSource.hpp>
#include <Audio/RtStreaming/RtStreamingBuffer.hpp>
#include <Afs/Rfs/FileDataSource.hpp>
#include <Kernel/Os/Semaphore.hpp>

Include dependency graph for DataSourceRtStreamingSource.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataSourceRtStreamingSource

Defines

#define | Apoxi_DataSourceRtStreamingSource_hpp

Define Documentation

#define Apoxi_DataSourceRtStreamingSource_hpp

Generated on Tue Jan 24 18:10:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/DataSourceRtStreamingSource.hpp Source File

Audio/RtStreaming/DataSourceRtStreamingSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_DataSourceRtStreamingSource_hpp)
00010 #define Apoxi_DataSourceRtStreamingSource_hpp
00011
00012 #include <Audio/RtStreaming/RtStreamingEndPoint.hpp>
00013 #include <Audio/RtStreaming/RtStreamingSource.hpp>
00014 #include <Audio/RtStreaming/RtStreamingBuffer.hpp>
00015 #include <Afs/Rfs/FileDataSource.hpp>
00016 #include <Kernel/Os/Semaphore.hpp>
00017
00018 class RtStreamingConn;
00019 class RtStreamingBuffer;
00020 class DataSourceRtStreamingBufferFillThread;
00021
00022
00024 class DataSourceRtStreamingSource : public RtStreamingSource {
00025
00026 friend DataSourceRtStreamingBufferFillThread;
00027
00028 public:
00029     DataSourceRtStreamingSource(DataSourcePtr ds);
00030
00031 protected:
00032     virtual BOOLEAN OpenAction();
00033     virtual BOOLEAN StartAction(const BufferInfo & buf_info);
00034     virtual BOOLEAN StopAction();
00035     virtual BOOLEAN CloseAction();
00036     virtual void    OnBufferSwitch(RtStreamingBuffer &buffer);
00037
00038     UINT8 m_no_of_buffers;
00039     UINT32 m_buf_size;
00040     UINT32 m_cur_file_offset;
00041     INT8 m_cur_buffer_returned;
00042     BOOLEAN m_stop_requested_by_conn;
00043     DataSourcePtr m_cur_src;
00044     Semaphore m_fill_semaphore;
00045
00046     RtStreamingBuffer * buffers;
00047
00048 private:
00049
00050     DataSourceRtStreamingBufferFillThread  * m_buf_thread;
00051 };
00052
00053 #endif  // Apoxi_DataSourceRtStreamingSource_hpp
00054
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingBuffer.cpp File Reference

Audio/RtStreaming/RtStreamingBuffer.cpp File Reference

#include <Audio/AudioPreComp.hpp>
#include "RtStreamingBuffer.hpp"

Include dependency graph for RtStreamingBuffer.cpp:

Generated on Tue Jan 24 18:10:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingBuffer.hpp File Reference

Audio/RtStreaming/RtStreamingBuffer.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for RtStreamingBuffer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RtStreamingBuffer
Assignable data buffer with transfer-of-ownership semantics. More...

Defines

#define | Apoxi_RtStreamingBuffer_hpp

Define Documentation

#define Apoxi_RtStreamingBuffer_hpp

Generated on Tue Jan 24 18:10:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingBuffer.hpp Source File

Audio/RtStreaming/RtStreamingBuffer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_RtStreamingBuffer_hpp)
00010 #define Apoxi_RtStreamingBuffer_hpp
00011
00012 #include <Kernel/Types.hpp>
00013
00015 class RtStreamingBuffer {
00016
00017     public:
00019         RtStreamingBuffer(UINT32    capacity = 0);
00020
00022         ~RtStreamingBuffer();
00023
00025         RtStreamingBuffer &     operator=(RtStreamingBuffer &  rhs);
00026
00027         inline  BOOLEAN         IsValid() const {return( m_buffer_ptr != 0 );}
00028
00029         inline  UINT8 *         GetDataPtr();
00030         inline  const UINT8 *   GetDataPtr() const;
00031
00032         inline  UINT32          GetSize() const;
00033         inline  void            SetSize(UINT32  size);
00034
00035         inline  UINT32          GetCapacity() const;
00036
00037         inline  BOOLEAN         IsEndOfData() const;
00038         inline  void            SetEndOfData();
00039
00041         inline  void            Clear();
00042
00043         void                    Release();
00044
00045     private:
00047         RtStreamingBuffer(const RtStreamingBuffer &);
00048
00049         inline  void            Reset();
00050         void                    Dispose();
00051
00052         UINT8 *     m_buffer_ptr;
00053         UINT32      m_capacity;
00054         UINT32      m_size;
00055         BOOLEAN     m_is_end_of_data;
00056 };
00057 /*  ------------------------------------------------------------------------
00058     GetDataPtr
00059     ------------------------------------------------------------------------ */
00060 UINT8 *     RtStreamingBuffer::GetDataPtr()
00061 {
00062     return m_buffer_ptr;
00063 } // GetDataPtr
00064
00065 /*  ------------------------------------------------------------------------
00066     GetDataPtr
00067     ------------------------------------------------------------------------ */
00068 const UINT8 * RtStreamingBuffer::GetDataPtr()
00069 const
00070 {
00071     return m_buffer_ptr;
00072 } // GetDataPtr
00073
00074 /*  ------------------------------------------------------------------------
00075     GetSize
00076     ------------------------------------------------------------------------ */
00077 UINT32 RtStreamingBuffer::GetSize()
00078 const
00079 {
00080     return m_size;
00081 } // GetSize
00082
00083 /*  ------------------------------------------------------------------------
00084     SetSize
00085     ------------------------------------------------------------------------ */
00086 void RtStreamingBuffer::SetSize(UINT32 size)
00087 {
00088     ASSERT_DEBUG(size <= m_capacity);
00089     m_size = size;
00090 } // SetSize
00091
00092 /*  ------------------------------------------------------------------------
00093 GetCapacity
00094 ------------------------------------------------------------------------ */
00095 UINT32 RtStreamingBuffer::GetCapacity()
00096 const
00097 {
00098     return m_capacity;
00099 } // GetCapacity
00100
00101 /*  ------------------------------------------------------------------------
00102     IsEndOfData
00103     ------------------------------------------------------------------------ */
00104 BOOLEAN RtStreamingBuffer::IsEndOfData()
00105 const
00106 {
00107     return m_is_end_of_data;
00108 } // IsEndOfData
00109
00110 /*  ------------------------------------------------------------------------
00111     SetEndOfData
00112     ------------------------------------------------------------------------ */
00113 void RtStreamingBuffer::SetEndOfData()
00114 {
00115     m_is_end_of_data = TRUE;
00116 } // SetEndOfData
00117
00118 /*  ------------------------------------------------------------------------
00119     Clear
00120     ------------------------------------------------------------------------ */
00121 void RtStreamingBuffer::Clear()
00122 {
00123     SetSize(0);
00124     m_is_end_of_data = FALSE;
00125 } // Clear
00126
00127 /*  ------------------------------------------------------------------------
00128     Reset
00129     ------------------------------------------------------------------------ */
00130 void RtStreamingBuffer::Reset()
00131 {
00132     Clear();
00133     m_buffer_ptr = 0;
00134     m_capacity   = 0;
00135 } // Reset
00136
00137 #endif  // Apoxi_RtStreamingBuffer_hpp
00138
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingConn.cpp File Reference

Audio/RtStreaming/RtStreamingConn.cpp File Reference

#include <Audio/AudioPreComp.hpp>
#include "RtStreamingBuffer.hpp"
#include "RtStreamingSource.hpp"
#include "RtStreamingSink.hpp"
#include "RtStreamingConn.hpp"

Include dependency graph for RtStreamingConn.cpp:

Generated on Tue Jan 24 18:11:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingConn.hpp File Reference

Audio/RtStreaming/RtStreamingConn.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for RtStreamingConn.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RtStreamingConn

Defines

#define | Apoxi_RtStreamingConn_hpp

Define Documentation

#define Apoxi_RtStreamingConn_hpp

Generated on Tue Jan 24 18:11:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingConn.hpp Source File

Audio/RtStreaming/RtStreamingConn.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_RtStreamingConn_hpp)
00010 #define Apoxi_RtStreamingConn_hpp
00011
00012 #include <Kernel/Types.hpp>
00013
00014 //  Forward declarations of classes
00015 class RtStreamingSink;
00016 class RtStreamingSource;
00017 class RtStreamingBuffer;
00018
00020 class RtStreamingConn {
00021
00022     friend class RtStreamingEndPoint;
00023     friend class RtStreamingSink;
00024     friend class RtStreamingSource;
00025
00026     public:
00028         enum StopCause {
00029             StOnEndOfData,
00030             StOnCommand,
00031             StOnSrcError,
00032             StOnSnkError
00033         };
00034
00036         RtStreamingConn();
00037
00039         virtual ~RtStreamingConn();
00040
00047         BOOLEAN                 Start();
00048
00054         BOOLEAN                 Stop();
00055
00056     protected:
00057
00058         virtual BOOLEAN         StopAction();
00059
00061         virtual void            OnStarted() {};
00062
00066         virtual void            OnStopped(StopCause cause) {};
00067
00068         void                    Attach(RtStreamingSink &        sink);
00069         void                    Attach(RtStreamingSource &      source);
00070
00071     private:
00072         enum StreamingState {
00073             StmgInitial,
00074             StmgReady,
00075             StmgStart,
00076             StmgStarted,
00077             StmgActive,
00078             StmgStopped
00079         };
00080
00081         StreamingState          m_stm_state;
00082         StopCause               m_end_cause;
00083         INT                     m_buf_cnt;
00084         RtStreamingSource *     m_src_ptr;
00085         RtStreamingSink *       m_snk_ptr;
00086
00087         inline  BOOLEAN         IsInState(StreamingState    s) const;
00088         void                    SetStreamingState(StreamingState    s);
00089
00090         void                    CheckStateAfterAttach();
00091         void                    CheckStateAfterDetach();
00092
00093         void                    Detach(RtStreamingSink &        sink);
00094         void                    Detach(RtStreamingSource &      source);
00095
00096         void                    HandleDataReady();
00097         void                    HandleError();
00098         void                    HandleStoppedOnCause(RtStreamingConn::StopCause cause);
00099
00100         void                    HandleBufferSwitch(RtStreamingBuffer &  buffer);
00101 };
00102
00103 /*  ------------------------------------------------------------------------
00104     IsInState
00105     ------------------------------------------------------------------------ */
00106 BOOLEAN RtStreamingConn::IsInState(StreamingState   s) const
00107 {
00108     return (s == m_stm_state);
00109 }// IsInState
00110
00111 #endif  // Apoxi_RtStreamingConn_hpp
00112
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingEndPoint.cpp File Reference

Audio/RtStreaming/RtStreamingEndPoint.cpp File Reference

#include <Audio/AudioPreComp.hpp>
#include "RtStreamingEndPoint.hpp"

Include dependency graph for RtStreamingEndPoint.cpp:

Generated on Tue Jan 24 18:11:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingEndPoint.hpp File Reference

Audio/RtStreaming/RtStreamingEndPoint.hpp File Reference

#include "RtStreamingConn.hpp"
#include "RtStreamingBuffer.hpp"

Include dependency graph for RtStreamingEndPoint.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RtStreamingEndPoint
Base class for RtStreamingSource and RtStreamingSink. More...
struct | RtStreamingEndPoint::BufferInfo
Contains parameters required for proper buffering. More...

Defines

#define | Apoxi_RtStreamingEndPoint_hpp

Define Documentation

#define Apoxi_RtStreamingEndPoint_hpp

Generated on Tue Jan 24 18:11:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingEndPoint.hpp Source File

Audio/RtStreaming/RtStreamingEndPoint.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_RtStreamingEndPoint_hpp)
00010 #define Apoxi_RtStreamingEndPoint_hpp
00011
00012 #include "RtStreamingConn.hpp"
00013 #include "RtStreamingBuffer.hpp"
00014
00016 class RtStreamingEndPoint {
00017
00018     public:
00020         struct  BufferInfo {
00021             UINT32  latency_ms;
00022             UINT32  buffer_size;
00023         };
00024
00026         RtStreamingEndPoint();
00027
00032         virtual ~RtStreamingEndPoint();
00033
00041         BOOLEAN             Open(RtStreamingConn &  conn);
00042
00045         BOOLEAN             Close();
00046
00047     protected:
00049         virtual BOOLEAN     OpenAction() = 0;
00050
00052         virtual BOOLEAN     CloseAction() = 0;
00053
00054         virtual void        Attach() = 0;
00055         virtual void        Detach() = 0;
00056
00058         void                NotifyError();
00059
00061         void                NotifyStoppedOnCause(RtStreamingConn::StopCause cause);
00062
00063         // Sets the Conn Pointer
00064         void SetConn(RtStreamingConn &  conn) {m_conn_ptr = &conn;}
00065
00066         RtStreamingConn &   GetConn()
00067         {
00068             ASSERT(m_conn_ptr != 0);
00069             return  *m_conn_ptr;
00070         }
00071
00072     private:
00073         RtStreamingConn *   m_conn_ptr;
00074 };
00075
00076 #endif  // Apoxi_RtStreamingEndPoint_hpp
00077
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingSink.cpp File Reference

Audio/RtStreaming/RtStreamingSink.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "RtStreamingConn.hpp"
#include "RtStreamingSink.hpp"

Include dependency graph for RtStreamingSink.cpp:

Generated on Tue Jan 24 18:11:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingSink.hpp File Reference

Audio/RtStreaming/RtStreamingSink.hpp File Reference

#include <Audio/RtStreaming/RtStreamingConn.hpp>
#include <Audio/RtStreaming/RtStreamingEndPoint.hpp>
#include <Audio/RtStreaming/RtStreamingBuffer.hpp>

Include dependency graph for RtStreamingSink.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RtStreamingSink

Defines

#define | Apoxi_RtStreamingSink_hpp

Define Documentation

#define Apoxi_RtStreamingSink_hpp

Generated on Tue Jan 24 18:11:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingSink.hpp Source File

Audio/RtStreaming/RtStreamingSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_RtStreamingSink_hpp)
00010 #define Apoxi_RtStreamingSink_hpp
00011
00012 #include    <Audio/RtStreaming/RtStreamingConn.hpp>
00013 #include    <Audio/RtStreaming/RtStreamingEndPoint.hpp>
00014 #include    <Audio/RtStreaming/RtStreamingBuffer.hpp>
00015
00016 class RtStreamingSink : public RtStreamingEndPoint {
00017
00018     friend class RtStreamingConn;
00019
00020 public:
00021     RtStreamingSink();
00022
00023 protected:
00024     virtual void StopOnCause (RtStreamingConn::StopCause cause) = 0;
00025
00026     virtual void GetBufferInfo(BufferInfo & buf_info) const = 0;
00027
00028     virtual BOOLEAN StartAction() = 0;
00029
00030     virtual BOOLEAN StopAction(RtStreamingConn::StopCause cause) = 0;
00031
00032     void SwitchBuffer(RtStreamingBuffer &   buffer);
00033
00034     virtual void    Attach();
00035     virtual void    Detach();
00036 };
00037
00038 #endif  // Apoxi_RtStreamingSink_hpp
00039
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingSource.cpp File Reference

Audio/RtStreaming/RtStreamingSource.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "RtStreamingConn.hpp"
#include "RtStreamingSource.hpp"

Include dependency graph for RtStreamingSource.cpp:

Generated on Tue Jan 24 18:11:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingSource.hpp File Reference

Audio/RtStreaming/RtStreamingSource.hpp File Reference

#include <Audio/RtStreaming/RtStreamingEndPoint.hpp>

Include dependency graph for RtStreamingSource.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RtStreamingSource

Defines

#define | Apoxi_RtStreamingSource_hpp

Define Documentation

#define Apoxi_RtStreamingSource_hpp

Generated on Tue Jan 24 18:11:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio/RtStreaming/RtStreamingSource.hpp Source File

Audio/RtStreaming/RtStreamingSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_RtStreamingSource_hpp)
00010 #define Apoxi_RtStreamingSource_hpp
00011
00012 #include <Audio/RtStreaming/RtStreamingEndPoint.hpp>
00013
00014 class RtStreamingConn;
00015 class RtStreamingBuffer;
00016
00017
00019 class RtStreamingSource : public RtStreamingEndPoint {
00020
00021     friend class RtStreamingConn;
00022
00023     public:
00024         RtStreamingSource();
00025
00026
00027     protected:
00031         void    NotifyDataReady();
00032
00034         virtual BOOLEAN     StartAction(const BufferInfo &  buf_info) = 0;
00035
00041         virtual BOOLEAN     StopAction() = 0;
00042
00050         virtual void    OnBufferSwitch(RtStreamingBuffer &  buffer) = 0;
00051
00052         virtual void    Attach();
00053         virtual void    Detach();
00054 };
00055
00056 #endif  // Apoxi_RtStreamingSource_hpp
00057
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/AbstractDelegationProvider.cpp File Reference

Auxiliary/AbstractDelegationProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "AbstractDelegationProvider.hpp"

Include dependency graph for AbstractDelegationProvider.cpp:

Generated on Tue Jan 24 18:13:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/AbstractDelegationProvider.hpp File Reference

Auxiliary/AbstractDelegationProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>
#include <Auxiliary/Observer.hpp>
#include <Auxiliary/IndexTable.hpp>

Include dependency graph for AbstractDelegationProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractDelegationProvider
class | DelegationProviderListener

Defines

#define | _Auxiliary_AbstractDelegationProvider_hpp

Define Documentation

#define _Auxiliary_AbstractDelegationProvider_hpp

Generated on Tue Jan 24 18:13:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/AbstractDelegationProvider.hpp Source File

Auxiliary/AbstractDelegationProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Auxiliary_AbstractDelegationProvider_hpp)
00015 #define _Auxiliary_AbstractDelegationProvider_hpp
00016
00017 #include <Auxiliary/Provider.hpp>
00018 #include <Auxiliary/Observer.hpp>
00019 #include <Auxiliary/IndexTable.hpp>
00020
00021 class DataItem;
00022
00026 class AbstractDelegationProvider : public Provider, public Observer
00027 {
00028     public:
00029         typedef Provider Base;
00030
00033         AbstractDelegationProvider();
00034
00038         AbstractDelegationProvider(Provider * child_provider);
00040         virtual ~AbstractDelegationProvider();
00041
00043         Provider* GetChildProvider() const { return m_child_provider; }
00044
00046         virtual INT GetProviderId() const;
00047
00049         void Init(Provider * child_provider);
00050
00053         virtual INT RowCount();
00054
00057         virtual INT MaxRowCount();
00058
00061         virtual INT ColumnCount() const;
00062
00065         virtual const ColumnInfo * GetColumnInfo(INT id);
00066
00068         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item) = 0;
00069
00072         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00073
00076         virtual BOOLEAN SelectRow(INT row);
00077
00080         virtual BOOLEAN CommitRow(INT row);
00081
00084         virtual BOOLEAN DeleteRow(INT row);
00085
00088         virtual BOOLEAN AppendRow();
00089
00092         virtual BOOLEAN InsertRow(INT row);
00093
00096         virtual BOOLEAN ToggleRow(INT row);
00097
00100         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00101
00104         virtual BOOLEAN Update(ProviderListener * listener = 0);
00105
00108         virtual INT GetProgress();
00109
00111         virtual BOOLEAN GetChildRow(INT & childrow, INT row) = 0;
00112
00115         virtual INT GetBaseRow(INT row);
00116
00119 //      virtual INT GetColumnId(INT column);
00120
00123 //      virtual const ColumnInfo * GetColumnInfoPerId(INT id);
00124
00127         virtual BOOLEAN SetParameter(const DataItem &item);
00128
00130         virtual BOOLEAN Lock();
00131
00133         virtual BOOLEAN Unlock();
00134
00138         virtual void OnExecutingListener(Provider* provider = 0);
00139
00141         virtual BOOLEAN IsWStringDataCached() const;
00142
00144         virtual INT GetSortedColumnId() const;
00145
00147         INT GetNewChildRow() const { return (m_child_provider != 0) ? m_child_provider->GetModifiedRow() : c_no_row; }
00148
00149     protected:
00151         virtual void SetProgress (INT progress);
00152
00156         virtual BOOLEAN GetMappedRow(INT & mappedrow, INT row);
00157
00159         void SetChildProvider(Provider* child_provider);
00160
00162         virtual void OnUpdate(ObservableObject *obs_obj);
00163
00165         virtual void OnChildProviderModification(Provider* provider, const Provider::Modification& modification);
00166
00167         void ShiftIndexTableUp(IndexTable<INT>* idx_table, INT start, INT end);
00168         void ShiftIndexTableDown(IndexTable<INT>* idx_table, INT start, INT end);
00169         void ShiftIndexTableValues(IndexTable<INT>* idx_table, INT threshold, BOOLEAN up);
00170
00171         INT GetIndexTableIndex(IndexTable<INT>* table, INT child_row);
00172
00173         BOOLEAN UpdateChildProvider();
00174
00175     private:
00176         Provider *   m_child_provider;
00177         INT          m_progress;
00178 };
00179
00185 class DelegationProviderListener : public ProviderListener {
00186     public:
00188         DelegationProviderListener(AbstractDelegationProvider * provider, ProviderListener * child_listener);
00189
00191         virtual ~DelegationProviderListener();
00192
00195         virtual void OnExecuting();
00196
00197     private:
00198         AbstractDelegationProvider * m_provider;
00199         ProviderListener * m_child_listener;
00200
00201 };
00202
00203 #endif  // _Auxiliary_AbstractDelegationProvider_hpp
00204
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/AlphaCoding.cpp File Reference

Auxiliary/AlphaCoding.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "AlphaCoding.hpp"
#include "DataCoding.hpp"
#include "Macros.hpp"

Include dependency graph for AlphaCoding.cpp:

Functions

BOOLEAN Is7BitChar (WCHAR inchar)

Function Documentation

BOOLEAN Is7BitChar ( WCHAR inchar ) [inline]

Generated on Tue Jan 24 18:13:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/AlphaCoding.hpp File Reference

Auxiliary/AlphaCoding.hpp File Reference

#include <Auxiliary/WString.hpp>

Include dependency graph for AlphaCoding.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AlphaCoding

Defines

#define | Adc_AlphaCoding_hpp
em>AlphaCoding implements string coding and decoding as defined in GSM 11.11 Annex B.

Define Documentation

#define Adc_AlphaCoding_hpp

em>AlphaCoding implements string coding and decoding as defined in GSM 11.11 Annex B.

Generated on Tue Jan 24 18:13:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/AlphaCoding.hpp Source File

Auxiliary/AlphaCoding.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_AlphaCoding_hpp)
00010 #define Adc_AlphaCoding_hpp
00011
00012 #include <Auxiliary/WString.hpp>
00013
00014
00015
00017 class AlphaCoding
00018 {
00019     public:
00020         AlphaCoding();
00021         ~AlphaCoding(); // destructor not virtual !!!
00022
00028         static void EnableUsagePureUcs2Encoding(BOOLEAN enable = TRUE);
00029
00032         static INT GetCodedAlphaFieldLen(const WString & wstr);
00033
00037         static BOOLEAN EncodeAlphaField(const WString & str, UINT8 * buffer, INT len);
00039         static BOOLEAN EncodeAlphaField(const WString & str, UINT8 * buffer, INT len,
00040                                         INT & strlen, INT & efflen);
00041
00044         static WString DecodeAlphaField(const UINT8 * buffer, const INT len, const INT prealloclen = 0);
00045
00046     private:
00047
00049         static BOOLEAN Encode7bit(const WString & wstr, UINT8 * buffer, INT len);
00050
00052         static BOOLEAN EncodeUcs80(const WString & wstr, UINT8 * buffer, INT len);
00053
00055         static BOOLEAN EncodeUcs81(const WString & wstr, UINT8 * buffer, INT len, UINT8 offset);
00056
00058         static BOOLEAN EncodeUcs82(const WString & wstr, UINT8 * buffer, INT len, WCHAR offset);
00059
00061         static INT Get7BitLen(const WString & wstr);
00062
00064         static INT GetUcs80Len(const WString & wstr);
00065
00067         static INT GetUcs81Len(const WString & wstr, UINT8 & offset);
00068
00070         static INT GetUcs82Len(const WString & wstr, WCHAR & offset);
00071
00073         static void FindHighAndLow(const WString & wstr, WCHAR & lowest, WCHAR & highest);
00074
00076         static WString Decode7bit(const UINT8 * buffer, const INT len, const INT prealloclen);
00077
00079         static WString DecodeUcs80(const UINT8 * buffer, const INT len, const INT prealloclen);
00080
00082         static WString DecodeUcs81(const UINT8 * buffer, const INT prealloclen);
00083
00085         static WString DecodeUcs82(const UINT8 * buffer, const INT prealloclen);
00086
00087     private:
00088         static WCHAR * m_wchar_buffer;
00089         static INT     m_buffer_len;
00090         static BOOLEAN m_pure_ucs2_encoding;
00091
00092         static void ResizeWCharBuffer(INT size);
00093
00094 };
00095
00096
00097 #endif
00098
00099
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ApoxiAuxiliaryVersion.cpp File Reference

Auxiliary/ApoxiAuxiliaryVersion.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiAuxiliaryVersion.cpp:

Functions

ApoxiDefVersionInfo (Auxiliary, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | Auxiliary | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 18:13:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/AuxiliaryTemplates.cpp File Reference

Auxiliary/AuxiliaryTemplates.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "MainProvider.hpp"
#include "WildcardStrncmp.hpp"
#include "IndexTable.hpp"
#include "HashTable.hpp"

Include dependency graph for AuxiliaryTemplates.cpp:

Functions

template INT | wc_strncmp< CHAR > (const CHAR *, const CHAR *, INT, INT, INT)
template INT | wc_strncmp< WCHAR > (const WCHAR *, const WCHAR *, INT, INT, INT)

Function Documentation

template INT wc_strncmp< CHAR > | ( | const CHAR * | ,
 |  | const CHAR * | ,
 |  | INT | ,
 |  | INT | ,
 |  | INT |
 | ) |

template INT wc_strncmp< WCHAR > | ( | const WCHAR * | ,
 |  | const WCHAR * | ,
 |  | INT | ,
 |  | INT | ,
 |  | INT |
 | ) |

Generated on Tue Jan 24 18:13:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinarySearch.hpp File Reference

Auxiliary/BinarySearch.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CArray< T >

Defines

#define | Apoxi_BinarySearch_hpp

Functions

template<class Collection, class Key, class Pred>
INT | BinarySearch (const Collection &arr, const Key &key, const Pred &pred, INT *insert)
template<class Collection, class Key, class Pred>
INT | BinarySearch (const Collection &arr, const Key &key, const Pred &pred)
template<class Collection, class Key, class Pred>
INT | BinarySearch (const Collection &arr, const Key &key)

Define Documentation

#define Apoxi_BinarySearch_hpp

Generated on Tue Jan 24 18:14:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinarySearch.hpp Source File

Auxiliary/BinarySearch.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BinarySearch_hpp)
00010 #define Apoxi_BinarySearch_hpp
00013
00014
00015
00016 /*template<class T1,class T2> class Less {
00017     public:
00018         inline INT Compare(const T1 &e1, const T2 &e2) const { return e1 < e2 ? -1 : (e1 == e2 ? 0 : 1); }
00019 };
00020 */
00021
00022 template<class T> class CArray {
00023     public:
00024         typedef T ElemType;
00025
00026         inline CArray(const T *arr, INT size) : m_size(size), m_arr(arr) {};
00027
00028         inline INT Size() const { return m_size; };
00029         inline const T& operator[](INT i) const { return m_arr[i]; };
00030
00031     private:
00032         INT m_size;
00033         const T *m_arr;
00034 };
00035
00036
00037 /*  ------------------------------------------------------------------------
00038     BinarySearch
00039     ------------------------------------------------------------------------ */
00040 template<class Collection, class Key, class Pred> inline
00041     INT BinarySearch(const Collection &arr, const Key &key)
00042 {
00043     return BinarySearch(arr, key, Pred(), 0);
00044 }   // BinarySearch
00045
00046
00047 /*  ------------------------------------------------------------------------
00048     BinarySearch
00049     ------------------------------------------------------------------------ */
00050 template<class Collection, class Key, class Pred> inline
00051     INT BinarySearch(const Collection &arr, const Key &key, const Pred &pred)
00052 {
00053     return BinarySearch(arr, key, pred, 0);
00054 }   // BinarySearch
00055
00056
00057 /*  ------------------------------------------------------------------------
00058     BinarySearch
00059     ------------------------------------------------------------------------ */
00060 template<class Collection, class Key, class Pred> inline
00061     INT BinarySearch(const Collection &arr, const Key &key, const Pred &pred, INT *insert)
00062 {
00063     INT left = 0;
00064     INT right = arr.Size() - 1;
00065     INT middle = 0;
00066
00067     while (right >= left) {
00068         middle = (left + right) / 2;
00069         INT result = pred.Compare(key, arr[middle]);
00070
00071         if (result == 0)
00072             return middle;
00073
00074         if (result < 0)
00075             right = middle - 1;
00076         else
00077             left = middle + 1;
00078     }
00079
00080     if (insert != 0)
00081         *insert = middle;
00082
00083     return -1;
00084 }   // BinarySearch
00085
00087 #endif  // Apoxi_BinarySearch_hpp
00088
00089
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinData.cpp File Reference

Auxiliary/BinData.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "BinData.hpp"

Include dependency graph for BinData.cpp:

Generated on Tue Jan 24 18:14:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinData.hpp File Reference

Auxiliary/BinData.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/DrmAsset.hpp>

Include dependency graph for BinData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BinData
class | MemMap

Defines

#define | Auxiliary_BinData_hpp

Define Documentation

#define Auxiliary_BinData_hpp

Generated on Tue Jan 24 18:14:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinData.hpp Source File

Auxiliary/BinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_BinData_hpp)
00011 #define Auxiliary_BinData_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/DrmAsset.hpp>
00017
00019 class MemMap {
00020     friend class BinData;
00021     typedef void HUGE* BufPtr;
00022     typedef UINT8 HUGE* Uint8BufPtr;
00023
00024     public:
00029         MemMap(void *ptr, UINT32 len, INT id);
00030
00031         virtual ~MemMap();
00032
00036         BOOLEAN Read(UINT32 idx, UINT8& val) const;
00037
00040         UINT32 Read(UINT32 idx, void* buf, UINT32 byte_count) const;
00041
00043         UINT32 GetLength() const { return m_length; }
00044
00047         const UINT8* GetHandle(UINT32 idx = 0) const;
00048
00049     private:
00050         INT m_id;
00051         UINT32 m_length;
00052         Uint8BufPtr m_buf;
00053 };
00054
00055
00063 class BinData {
00064     public:
00065         typedef void HUGE* BufPtr;
00066         typedef UINT8 HUGE* Uint8BufPtr;
00067
00071         virtual BOOLEAN Read(UINT32 idx, UINT8& val) const = 0;
00072
00076         virtual UINT32 Read(UINT32 idx, void* buf, UINT32 byte_count) const = 0;
00077
00079         virtual UINT32 GetLength() const = 0;
00080
00083         const DrmAsset& GetDrmAsset() const { return m_drm_asset; }
00084
00087         virtual void ReleaseInstance();
00088
00093         virtual BinData* Clone() const;
00094
00098         virtual MemMap* ObtainMemMap(UINT32 idx, UINT32 size) const;
00099
00101         virtual void ReleaseMemMap(MemMap** h_map) const;
00102
00104         MemMap* GetMemMap(UINT32 idx, UINT32 size) const { return ObtainMemMap(idx, size); }
00105
00106     protected:
00107         BinData(DrmLocalId id = c_drm_invalid_local_id);
00108         virtual ~BinData();
00109
00110     private:
00111         DrmAsset m_drm_asset;
00112 };
00113
00115 #endif  // Auxiliary_BinData_hpp
00116
00117
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinDataDataSource.cpp File Reference

Auxiliary/BinDataDataSource.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "BinDataDataSource.hpp"
#include <Gui/Color.hpp>
#include <Gui/Image.hpp>

Include dependency graph for BinDataDataSource.cpp:

Generated on Tue Jan 24 18:14:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinDataDataSource.hpp File Reference

Auxiliary/BinDataDataSource.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <Auxiliary/BinDataOwner.hpp>
#include <Auxiliary/DataSource.hpp>

Include dependency graph for BinDataDataSource.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BinDataDataSource

Defines

#define | Auxiliary_BinDataDataSource_hpp

Define Documentation

#define Auxiliary_BinDataDataSource_hpp

Generated on Tue Jan 24 18:14:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinDataDataSource.hpp Source File

Auxiliary/BinDataDataSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_BinDataDataSource_hpp)
00011 #define Auxiliary_BinDataDataSource_hpp
00012
00013 #include <Auxiliary/BinData.hpp>
00014 #include <Auxiliary/BinDataOwner.hpp>
00015 #include <Auxiliary/DataSource.hpp>
00016
00020 class BinDataDataSource : public DataSource
00021 {
00022     typedef DataSource Base;
00023
00024     public:
00031         BinDataDataSource(const BinDataPtr bin_data);
00032
00034         virtual ~BinDataDataSource();
00035
00036         virtual BOOLEAN Open();
00037         virtual BOOLEAN Close();
00038
00039         virtual BOOLEAN IsOpen() const;
00040
00041         virtual BOOLEAN Read(void HUGE *buffer, UINT32 count);
00042         virtual BOOLEAN Read(void HUGE *buffer, UINT32 max_count, UINT32&bytes_read);
00043         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 count);
00044         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read);
00045         virtual BOOLEAN GetSize(UINT32 &size) const;
00046
00047     protected:
00048         // The data source that is read from.
00049         BinDataPtr m_bin_data;
00050
00051         BOOLEAN m_is_open;
00052         UINT32  m_offset;
00053 };
00054
00055 #endif  // Auxiliary_DataSourceBinData_hpp
00056
00057
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinDataOwner.hpp File Reference

Auxiliary/BinDataOwner.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/DataSource.hpp>

Include dependency graph for BinDataOwner.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Auxiliary_BinDataOwner_hpp

Define Documentation

#define Auxiliary_BinDataOwner_hpp

Generated on Tue Jan 24 18:14:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BinDataOwner.hpp Source File

Auxiliary/BinDataOwner.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_BinDataOwner_hpp)
00011 #define Auxiliary_BinDataOwner_hpp
00012
00013 #include <Auxiliary/BinData.hpp>
00014 #include <Auxiliary/NiSharedPtr.hpp>
00015 #include <Auxiliary/DataSource.hpp>
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00025 class BinDataOwner
00026 {
00027 public:
00028
00030
00034     inline BinDataOwner(BinData* bin_data);
00035
00037
00039     inline ~BinDataOwner();
00040
00042
00045     inline BOOLEAN Read(UINT32 idx, UINT8 &val) const;
00046
00048
00050     inline UINT32 Read(UINT32 idx, void *buf, UINT32 nbytes) const;
00051
00053
00055     inline UINT32 GetLength() const;
00056
00058
00060     inline const DrmAsset& GetDrmAsset() const;
00061
00062     inline const BinData* GetBinData();
00063
00064 private:
00065     BinData*    m_bin_data;
00066 };
00067
00068 typedef NiSharedPtr<BinDataOwner> BinDataPtr;
00069
00070 /*  ------------------------------------------------------------------------
00071     BinDataOwner
00072     ------------------------------------------------------------------------ */
00073 BinDataOwner::BinDataOwner(BinData* bin_data) : m_bin_data(bin_data) {
00074 }
00075
00076 /*  ------------------------------------------------------------------------
00077     ~BinDataOwner
00078     ------------------------------------------------------------------------ */
00079 BinDataOwner::~BinDataOwner() {
00080     m_bin_data->ReleaseInstance();
00081 }
00082
00083 /*  ------------------------------------------------------------------------
00084     Read
00085     ------------------------------------------------------------------------ */
00086 BOOLEAN BinDataOwner::Read(UINT32 idx, UINT8 &val) const
00087 {
00088     return m_bin_data->Read(idx, val);
00089 }
00090
00091 /*  ------------------------------------------------------------------------
00092     Read
00093     ------------------------------------------------------------------------ */
00094 UINT32 BinDataOwner::Read(UINT32 idx, void *buf, UINT32 nbytes) const
00095 {
00096     return m_bin_data->Read(idx, buf, nbytes);
00097 }
00098
00099 /*  ------------------------------------------------------------------------
00100     GetLength
00101     ------------------------------------------------------------------------ */
00102 UINT32 BinDataOwner::GetLength() const
00103 {
00104     return m_bin_data->GetLength();
00105 }
00106
00107 /*  ------------------------------------------------------------------------
00108     GetDrmAsset
00109     ------------------------------------------------------------------------ */
00110 const DrmAsset& BinDataOwner::GetDrmAsset() const
00111 {
00112     return m_bin_data->GetDrmAsset();
00113 }
00114
00115 /*  ------------------------------------------------------------------------
00116     GetBinData
00117     ------------------------------------------------------------------------ */
00118 const BinData* BinDataOwner::GetBinData()
00119 {
00120     return m_bin_data;
00121 }
00122
00123 #endif // DOXYGEN_SHOULD_SKIP_THIS
00124
00125 #endif //Auxiliary_BinDataOwner_hpp
00126
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BitField.hpp File Reference

Auxiliary/BitField.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for BitField.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BitField< T >

Defines

#define | Auxiliary_BitField_hpp

Typedefs

typedef BitField< UINT16 > | BitField16
typedef BitField< UINT32 > | BitField32
typedef BitField< UINT8 > | BitField8

Define Documentation

#define Auxiliary_BitField_hpp

Typedef Documentation

typedef BitField<UINT16> BitField16

typedef BitField<UINT32> BitField32

typedef BitField<UINT8> BitField8

Generated on Tue Jan 24 18:17:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BitField.hpp Source File

Auxiliary/BitField.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Auxiliary_BitField_hpp)
00009 #define Auxiliary_BitField_hpp
00010
00011 #include <Kernel/Types.hpp>
00012 #include <Auxiliary/Macros.hpp>
00013
00016 template <class T> class BitField {
00017     public:
00018         enum { NrOfBits = sizeof(T) * 8 };
00019
00021         BitField(const T& bit_field = 0) : m_bit_field(bit_field) {};
00022
00024         BitField& operator <<(INT shift_pos) {
00025             ASSERT_DEBUG(shift_pos >= 0 && shift_pos < NrOfBits);
00026             m_bit_field = m_bit_field << shift_pos;
00027             return (*this);
00028         }
00029
00031         BitField& operator >>(INT n_shifts) {
00032             ASSERT_DEBUG(n_shifts >= 0 && n_shifts < NrOfBits);
00033             m_bit_field = m_bit_field >> n_shifts;
00034             return (*this);
00035         }
00036
00038         BOOLEAN operator == (const BitField &bit_field) const {
00039             return (m_bit_field == bit_field.m_bit_field);
00040         }
00041
00043         void Set(T bit_field, T mask) {
00044             m_bit_field = (m_bit_field & ~mask) | (bit_field & mask);
00045         }
00046
00048         void Set(T bit_field) {
00049             m_bit_field = bit_field;
00050         }
00051
00054         void SetBit(INT bit_index, BOOLEAN set) {
00055             if (set) {
00056                 m_bit_field |= BitMask(bit_index);
00057             } // if
00058             else {
00059                 m_bit_field &= ~BitMask(bit_index);
00060             } // else
00061         };
00063         void SetBit(INT bit_index) {
00064             m_bit_field |= BitMask(bit_index);
00065         };
00066
00068         void SetTrue(INT bit_index) {
00069             m_bit_field |= BitMask(bit_index);
00070         };
00071
00073         void SetFalse(INT bit_index) {
00074             m_bit_field &= ~BitMask(bit_index);
00075         };
00076
00078         void Clear() { m_bit_field = 0; }
00079
00081         INT GetNrOfBits() const { return (NrOfBits); }
00082
00084         T Get(const T &mask) const { return (m_bit_field & mask); }
00085
00087         T Get() const { return (m_bit_field); }
00088
00090         BOOLEAN GetBit(INT bit_index) const { return ((m_bit_field & BitMask(bit_index)) != 0); };
00091
00094         BOOLEAN IsSet(const T &bit_field) const { return ((~(m_bit_field | ~bit_field)) == 0); };
00095
00096
00098         T Mask(const T &mask) const { return (m_bit_field & mask); };
00099
00101         BOOLEAN IsEqual(const T &bit_field, const T &mask) const {
00102             return ((bit_field & mask) == Get(mask));
00103         };
00104
00106         BOOLEAN IsEqual(const BitField<T> &bit_field) const {
00107             return (m_bit_field == bit_field.m_bit_field);
00108         };
00109
00110     private:
00111         T m_bit_field;
00112
00113         T BitMask(INT bit_index) const {
00114             ASSERT_DEBUG(bit_index >= 0 && bit_index < NrOfBits);
00115             return (T(1) << bit_index);
00116         }
00117
00118 };
00119
00120 typedef BitField<UINT8>  BitField8;
00121 typedef BitField<UINT16> BitField16;
00122 typedef BitField<UINT32> BitField32;
00123
00124
00125
00126 #endif  // Auxiliary_BitField_hpp
00127
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BitVector.hpp File Reference

Auxiliary/BitVector.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for BitVector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BitVector< N >

Defines

#define | Apoxi_BitVector_hpp

Define Documentation

#define Apoxi_BitVector_hpp

Generated on Tue Jan 24 18:17:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BitVector.hpp Source File

Auxiliary/BitVector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BitVector_hpp)
00010 #define Apoxi_BitVector_hpp
00013
00014
00017 #include <Kernel/Types.hpp>
00018 #include <Auxiliary/Macros.hpp>
00019
00020 template<INT N> class BitVector {
00021     private:
00022         enum {
00023             BITS_PER_UINT = sizeof(UINT) * 8,
00024             UINT_COUNT = (N + BITS_PER_UINT - 1) / BITS_PER_UINT
00025         };
00026
00027         UINT bits[UINT_COUNT];
00028
00029         inline UINT& Atom(INT bitidx) {
00030             ASSERT_DEBUG(bitidx >= 0 && bitidx < N);
00031             return(bits[bitidx / BITS_PER_UINT]);
00032         }
00033
00034         inline UINT Atom(INT bitidx) const {
00035             ASSERT_DEBUG(bitidx >= 0 && bitidx < N);
00036             return(bits[bitidx / BITS_PER_UINT]);
00037         }
00038
00039         inline UINT BitMask(INT bitidx) const {
00040             ASSERT_DEBUG(bitidx >= 0 && bitidx < N);
00041             return(1U << (bitidx % BITS_PER_UINT));
00042         }
00043
00044     public:
00046         inline BitVector() {
00047             memset(bits,0,sizeof(bits));
00048         }
00050         inline BOOLEAN GetBit(INT idx) const {
00051             return((Atom(idx) & BitMask(idx)) != 0);
00052         }
00054         inline void SetBit(INT idx,BOOLEAN set) {
00055             if (set)
00056                 Atom(idx) |= BitMask(idx);
00057             else
00058                 Atom(idx) &= ~BitMask(idx);
00059         }
00060
00061         inline void SetBit(INT idx) {
00062             SetBit(idx,TRUE);
00063         }
00064 };
00065
00066
00068 #endif  // Apoxi_BitVector_hpp
00069
00070
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BlobObject.cpp File Reference

Auxiliary/BlobObject.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "BlobObject.hpp"
#include "Macros.hpp"
#include <string.h>

Include dependency graph for BlobObject.cpp:

Generated on Tue Jan 24 18:17:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BlobObject.hpp File Reference

Auxiliary/BlobObject.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BlobPtr.hpp>

Include dependency graph for BlobObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlobObject

Defines

#define | _Adc_BlobObject_hpp

Variables

const GenericTypeId | c_blobobject_type = c_apoxi_base_gentypes + 2

Define Documentation

#define _Adc_BlobObject_hpp

Generated on Tue Jan 24 18:17:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BlobObject.hpp Source File

Auxiliary/BlobObject.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_BlobObject_hpp)
00015 #define _Adc_BlobObject_hpp
00018
00019 #include <Kernel/Types.hpp>
00020
00021 #include <Auxiliary/BlobPtr.hpp>
00022
00023 const GenericTypeId c_blobobject_type = c_apoxi_base_gentypes + 2;
00024
00031 class BlobObject : public BlobPtr
00032 {
00033     public:
00034         typedef BlobPtr Base;
00035
00037         BlobObject();
00039         BlobObject(const UINT8 * data, INT length);
00041         BlobObject(const BlobObject & obj);
00042
00044         virtual ~BlobObject();
00045
00047         BlobObject & operator = (const BlobObject & szCopy);
00048
00050         virtual GenericObject * Copy() const;
00052         virtual BOOLEAN         IsEqual(GenericObject * object);
00054         virtual GenericTypeId   GetTypeId();
00055
00057         void Update(const UINT8 *data, INT length);
00058
00060         void Clear();
00061
00063         void Allocate(INT length);
00064
00066         void Reallocate(INT length);
00067
00069         void Append(const UINT8 *data, INT length);
00070
00072         void CutOff(INT length);
00073
00077         INT  Poke(INT offset, const UINT8 *data, INT length);
00078
00082         INT Peek(INT offset, UINT8 *&data, INT length);
00083
00085         BOOLEAN IsEmpty() const { return (m_data == 0 || m_length == 0); }
00086
00087     private:
00088
00089 };
00090
00092 #endif
00093
00094
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BlobPtr.cpp File Reference

Auxiliary/BlobPtr.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "BlobPtr.hpp"

Include dependency graph for BlobPtr.cpp:

Generated on Tue Jan 24 18:17:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BlobPtr.hpp File Reference

Auxiliary/BlobPtr.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/GenericObject.hpp>

Include dependency graph for BlobPtr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlobPtr

Defines

#define | _Adc_BlobPtr_hpp

Variables

const GenericTypeId | c_blobptr_type = c_apoxi_base_gentypes + 1

Define Documentation

#define _Adc_BlobPtr_hpp

Generated on Tue Jan 24 18:18:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BlobPtr.hpp Source File

Auxiliary/BlobPtr.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_BlobPtr_hpp)
00015 #define _Adc_BlobPtr_hpp
00018
00019 #include <Kernel/Types.hpp>
00020
00021 #include <Auxiliary/GenericObject.hpp>
00022
00023 const GenericTypeId c_blobptr_type = c_apoxi_base_gentypes + 1;
00024
00029 class BlobPtr : public GenericObject
00030 {
00031     public:
00032         typedef GenericObject Base;
00033
00035         BlobPtr();
00037         BlobPtr(UINT8 * data, INT length);
00039         BlobPtr(const BlobPtr & obj);
00040
00041         virtual ~BlobPtr();
00042
00044         BlobPtr & operator = (const BlobPtr & szCopy);
00045
00047         virtual GenericObject * Copy() const;
00049         virtual BOOLEAN         IsEqual(GenericObject * object);
00051         virtual GenericTypeId   GetTypeId();
00052
00054         UINT8 * GetDataPtr() const { return m_data; };
00056         INT GetLength() const { return m_length; };
00057
00058     protected:
00059         UINT8 *  m_data;
00060         INT    m_length;
00061
00062 };
00063
00065 #endif
00066
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BubbleSortProvider.cpp File Reference

Auxiliary/BubbleSortProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "BubbleSortProvider.hpp"
#include "DataItem.hpp"
#include "FilterRule.hpp"

Include dependency graph for BubbleSortProvider.cpp:

Generated on Tue Jan 24 18:18:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BubbleSortProvider.hpp File Reference

Auxiliary/BubbleSortProvider.hpp File Reference

#include <Auxiliary/SortProvider.hpp>

Include dependency graph for BubbleSortProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BubbleSortProvider

Defines

#define | _Adc_BubbleSortProvider_hpp

Define Documentation

#define _Adc_BubbleSortProvider_hpp

Generated on Tue Jan 24 18:18:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BubbleSortProvider.hpp Source File

Auxiliary/BubbleSortProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_BubbleSortProvider_hpp)
00015 #define _Adc_BubbleSortProvider_hpp
00016
00017 #include <Auxiliary/SortProvider.hpp>
00018
00019 class DataItem;
00020 class FilterRule;
00021
00024 class BubbleSortProvider : public SortProvider
00025 {
00026     public:
00027         typedef SortProvider Base;
00028
00031         BubbleSortProvider();
00032
00037         BubbleSortProvider(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00038
00040         virtual ~BubbleSortProvider();
00041
00043         void Init(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00044
00046         virtual BOOLEAN Update(ProviderListener * listener = 0);
00047 };
00048
00049 #endif
00050
00051
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BufferedData.cpp File Reference

Auxiliary/BufferedData.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "BufferedData.hpp"

Include dependency graph for BufferedData.cpp:

Generated on Tue Jan 24 18:18:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BufferedData.hpp File Reference

Auxiliary/BufferedData.hpp File Reference

#include <Auxiliary/RamData.hpp>

Include dependency graph for BufferedData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BufferedData

Defines

#define | Auxiliary_BufferedData_hpp

Define Documentation

#define Auxiliary_BufferedData_hpp

Generated on Tue Jan 24 18:18:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BufferedData.hpp Source File

Auxiliary/BufferedData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_BufferedData_hpp)
00011 #define Auxiliary_BufferedData_hpp
00014
00015 #include <Auxiliary/RamData.hpp>
00016
00024 class BufferedData : public RamData
00025 {
00026     typedef RamData Base;
00027     public:
00031         static BufferedData* CreateInstance(UINT8 HUGE* buffer,
00032                                             UINT32 length,
00033                                             DrmLocalId id = c_drm_invalid_local_id);
00034
00037         virtual void ReleaseInstance();
00038
00040         virtual BinData* Clone() const;
00041
00042     protected:
00043         BufferedData(void HUGE* buffer, UINT32 length, DrmLocalId id = c_drm_invalid_local_id);
00044
00047         virtual ~BufferedData();
00048
00049     private:
00050         UINT8 HUGE* m_internal_data;
00051 };
00052
00054 #endif  // Auxiliary_BufferedData_hpp
00055
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BufferPoolManager.cpp File Reference

Auxiliary/BufferPoolManager.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "BufferPoolManager.hpp"

Include dependency graph for BufferPoolManager.cpp:

Defines

#define BUFFERPOOLMANAGER_BUFFER_ADMIN_SIZE 20

Define Documentation

#define BUFFERPOOLMANAGER_BUFFER_ADMIN_SIZE 20

Generated on Tue Jan 24 18:18:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BufferPoolManager.hpp File Reference

Auxiliary/BufferPoolManager.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/DynamicBitVector.hpp>

Include dependency graph for BufferPoolManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BufferPoolManager
struct | BufferPoolManager::Buffer
struct | BufferPoolManager::Pool

Defines

#define | Apoxi_BufferPoolManager_hpp
#define | MAX_POOL_COUNT 10
#define | MEM_POOL 0

Define Documentation

#define Apoxi_BufferPoolManager_hpp

Generated on Tue Jan 24 18:18:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/BufferPoolManager.hpp Source File

Auxiliary/BufferPoolManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BufferPoolManager_hpp)
00010 #define Apoxi_BufferPoolManager_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/DynamicBitVector.hpp>
00016
00017 #define MAX_POOL_COUNT 10
00018 #define MEM_POOL 0
00019
00023 class BufferPoolManager {
00024     public:
00025
00026         enum ResultType {
00027             NoError,
00028             BufferPoolNotAvailableError,
00029             BufferNotExistentError,
00030             BufferAdjustedWarning,
00031             NoBufferFreeError,
00032             OutOfMemoryError
00033         };
00034
00035
00036         static BufferPoolManager* GetInstance();
00037
00048         BufferPoolManager::ResultType CreateBufferPool(UINT8& buff_count,
00049                                                        UINT32 buff_len,
00050                                                        UINT32& pool_handle);
00051
00060         BufferPoolManager::ResultType DeleteBufferPool(UINT32& pool_handle);
00061
00066         BufferPoolManager::ResultType GetBufferPoolStatus(UINT32 pool_handle,
00067                                                           UINT8& free_buff_count);
00073         BufferPoolManager::ResultType GetBuffer(UINT32 pool_handle, UINT8 HUGE* &buff_ptr);
00074
00082         BufferPoolManager::ResultType ReleaseBuffer(UINT8 HUGE* &buff_ptr);
00083
00084     private:
00085
00086         // private constructor for singleton
00087         BufferPoolManager();
00088
00089         //methods for allocating and freeing memory
00090         void* MemAlloc(UINT32 nr_of_bytes);
00091         void MemFree(void* object);
00092
00093         // just to keep structure of one buffer in a pool in mind
00094         struct Buffer {
00095             UINT32      m_pool_id;          // + offset 0
00096             UINT32      m_buff_id;          // + offset 4
00097             UINT32      m_buff_len;         // + offset 8
00098             UINT32      m_buff_act_len;     // + offset 12
00099             UINT8 HUGE* m_buff;             // + offset 16
00100         };
00101
00102         struct Pool {
00103             UINT8 m_count;
00104             UINT8 m_free;
00105             UINT8 m_last_returned;
00106         };
00107
00108
00109 /* needed for singleton */
00110
00111         static BufferPoolManager m_instance;
00112
00113         Pool* m_pools[MAX_POOL_COUNT];      //array of pool pointers
00114         Buffer** m_buffers[MAX_POOL_COUNT]; //for each pool there is an array of Buffers
00115         DynamicBitVector* m_buffer_status[MAX_POOL_COUNT]; //array of bit vectors to indicate free buffers
00116         UINT8 m_new_pool;                   //current position in pool array
00117         UINT8 m_pool_filled;                //number of filled pools
00118
00119 };
00120
00122 #endif  // Apoxi_BufferPoolManager_hpp
00123
00124
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ByteBuffer.cpp File Reference

Auxiliary/ByteBuffer.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ByteBuffer.hpp"
#include "Macros.hpp"
#include <string.h>

Include dependency graph for ByteBuffer.cpp:

Functions

void | ByteBufferAccessOperatorTest ()
void | ByteBufferAssignmentOperators ()
void | ByteBufferConstructorTest ()
void | ByteBufferMiscMethodsTest ()
void | ByteBufferTest ()

Function Documentation

void ByteBufferAccessOperatorTest ( )

void ByteBufferAssignmentOperators ( )

void ByteBufferConstructorTest ( )

void ByteBufferMiscMethodsTest ( )

void ByteBufferTest ( )

Generated on Tue Jan 24 18:18:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ByteBuffer.hpp File Reference

Auxiliary/ByteBuffer.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ByteBuffer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ByteBuffer

Defines

#define | APOXI_BYTEBUFFER_TEST_SUITE
#define | Auxiliary_ByteBuffer_hpp

Functions

void | ByteBufferTest ()
BOOLEAN | operator!= (const ByteBuffer &lhs, const ByteBuffer &rhs)
BOOLEAN | operator== (const ByteBuffer &lhs, const ByteBuffer &rhs)

Define Documentation

#define APOXI_BYTEBUFFER_TEST_SUITE

#define Auxiliary_ByteBuffer_hpp

Function Documentation

void ByteBufferTest ( )

BOOLEAN operator!= | ( | const ByteBuffer & | lhs,
 |  | const ByteBuffer & | rhs
 | ) | [inline]

BOOLEAN operator== | ( | const ByteBuffer & | lhs,
 |  | const ByteBuffer & | rhs
 | ) | [inline]

Generated on Tue Jan 24 18:18:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ByteBuffer.hpp Source File

Auxiliary/ByteBuffer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_ByteBuffer_hpp)
00011 #define Auxiliary_ByteBuffer_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 class ByteBuffer {
00016
00017     public:
00019         ByteBuffer();
00020
00022         ByteBuffer(INT len, INT capacity = 0);
00023
00025         ByteBuffer(const ByteBuffer& bbCopy);
00026
00028         ByteBuffer(const ByteBuffer* bbCopy);
00029
00031         ByteBuffer(const UINT8* buffer, INT len, INT capacity = 0);
00032
00034         virtual ~ByteBuffer();
00035
00037         ByteBuffer &    operator = (const ByteBuffer & bbCopy);
00038
00040         UINT8 &         operator [] (INT idx);
00041
00043         virtual BOOLEAN Append(UINT8    octet);
00044
00046         virtual INT     GetLength() const { return m_buffer_len; }
00047
00049         virtual UINT8*  GetData() const { return m_buffer; }
00050
00052         virtual BOOLEAN IsEmpty() const { return m_buffer == 0; }
00053
00055         virtual BOOLEAN IsEqualTo(const ByteBuffer &    rhs) const;
00056
00058         virtual void    Swap(ByteBuffer &   swap_with);
00059
00071         virtual BOOLEAN PreAlloc(INT    length,
00072                                  INT    capacity = 0);
00073
00075         inline  INT     GetCapacity() const { return m_buffer_cap; }
00076
00077         /*  @brief  Adjusts usable length of the buffer.
00078
00079             When length is greater than the capacity of the buffer,
00080             a larger internal buffer will be allocated, otherwise
00081             just the length is adjusted and the capacity remains
00082             unchanged.
00083
00084             @return \c 'TRUE' in case of success, \c 'FALSE' when
00085                     memory allocation failed - in this case the
00086                     object is not modified */
00087         virtual BOOLEAN SetLength(INT   length);
00088
00098         inline  BOOLEAN Reserve(INT     capacity);
00099
00100     protected:
00101         BOOLEAN         Allocate(INT  length, INT capacity = 0);
00102         BOOLEAN         Reallocate(INT  length, INT capacity);
00103         void            Free();
00104
00105     private:
00106         UINT8 *         m_buffer;
00107         INT             m_buffer_len;
00108         INT             m_buffer_cap;
00109 };
00110
00111 /*  ----------------------------------------------------------------------
00112     Reserve
00113     ---------------------------------------------------------------------- */
00114 BOOLEAN ByteBuffer::Reserve(INT     capacity)
00115 {
00116     return  PreAlloc( GetLength(), capacity );
00117 }// Reserve
00118
00119 /*  ----------------------------------------------------------------------
00120     operator==()
00121     ---------------------------------------------------------------------- */
00122 inline  BOOLEAN operator==(const ByteBuffer &   lhs,
00123                            const ByteBuffer &   rhs)
00124 {
00125     return  lhs.IsEqualTo(rhs);
00126 }
00127
00128 /*  ----------------------------------------------------------------------
00129     operator!=()
00130     ---------------------------------------------------------------------- */
00131 inline  BOOLEAN operator!=(const ByteBuffer &   lhs,
00132                            const ByteBuffer &   rhs)
00133 {
00134     return  ! lhs.IsEqualTo(rhs);
00135 }
00136
00137 #if !defined(APOXI_BYTEBUFFER_TEST_SUITE) && defined(APOXI_RTOS_WIN32)
00138 #define APOXI_BYTEBUFFER_TEST_SUITE
00139
00140 // Call for ByteBuffer test suite, only for WIN32 platform
00141 void ByteBufferTest();
00142
00143 #endif
00144
00145 #endif  // Auxiliary_ByteBuffer_hpp
00146
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/CachingSortProvider.cpp File Reference

Auxiliary/CachingSortProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "CachingSortProvider.hpp"

Include dependency graph for CachingSortProvider.cpp:

Generated on Tue Jan 24 18:18:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/CachingSortProvider.hpp File Reference

Auxiliary/CachingSortProvider.hpp File Reference

#include <Auxiliary/QuickSortProvider.hpp>

Include dependency graph for CachingSortProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CachingSortProvider

Defines

#define | Auxiliary_CachingSortProvider_hpp

Define Documentation

#define Auxiliary_CachingSortProvider_hpp

Generated on Tue Jan 24 18:18:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/CachingSortProvider.hpp Source File

Auxiliary/CachingSortProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Auxiliary_CachingSortProvider_hpp)
00010 #define Auxiliary_CachingSortProvider_hpp
00013
00014 #include <Auxiliary/QuickSortProvider.hpp>
00015
00023 class CachingSortProvider : public QuickSortProvider
00024 {
00025     public:
00026         typedef QuickSortProvider Base;
00027
00030         CachingSortProvider();
00031
00037         CachingSortProvider(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00038
00040         virtual ~CachingSortProvider();
00041
00043         void Init(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00044
00046         virtual BOOLEAN Update(ProviderListener * listener = 0);
00047
00048     private:
00050         BOOLEAN CachedQuickSort(INT row_count);
00051         void MergeSortCacheIndizes(DataItem* cache, INT low, INT high, INT cache_offset);
00052 };
00053
00055 #endif  // Auxiliary_CachingSortProvider_hpp
00056
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ChildBinData.cpp File Reference

Auxiliary/ChildBinData.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ChildBinData.hpp"

Include dependency graph for ChildBinData.cpp:

Generated on Tue Jan 24 18:18:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ChildBinData.hpp File Reference

Auxiliary/ChildBinData.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for ChildBinData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ChildBinData

Defines

#define | Auxiliary_ChildBinData_hpp

Define Documentation

#define Auxiliary_ChildBinData_hpp

Generated on Tue Jan 24 18:18:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ChildBinData.hpp Source File

Auxiliary/ChildBinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_ChildBinData_hpp)
00011 #define Auxiliary_ChildBinData_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/BinData.hpp>
00017
00020 class ChildBinData : public BinData {
00021     typedef BinData Base;
00022     public:
00030         static ChildBinData* CreateInstance(const BinData& parent_data,
00031                                             UINT32 start_offset);
00032
00034         virtual BOOLEAN Read(UINT32 idx, UINT8& val) const;
00035
00037         virtual UINT32 Read(UINT32 idx, void *val, UINT32 nbytes) const;
00038
00040         virtual UINT32 GetLength() const;
00041
00042     protected:
00043         ChildBinData(const BinData& parent_data,
00044                      UINT32 start_offset);
00045         virtual ~ChildBinData();
00046
00047     private:
00048         const BinData& m_parent_data;
00049         UINT32 m_start_offset;
00050 };
00051
00053 #endif  // Auxiliary_ChildBinData_hpp
00054
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ChineseQuickSortProvider.cpp File Reference

Auxiliary/ChineseQuickSortProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ChineseQuickSortProvider.hpp"
#include "Provider.hpp"
#include "ProviderListener.hpp"
#include "DataItem.hpp"

Include dependency graph for ChineseQuickSortProvider.cpp:

Generated on Tue Jan 24 18:18:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ChineseQuickSortProvider.hpp File Reference

Auxiliary/ChineseQuickSortProvider.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/QuickSortProvider.hpp>

Include dependency graph for ChineseQuickSortProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ChineseQuickSortProvider

Defines

#define | Auxiliary_ChineseQuickSortProvider_hpp

Define Documentation

#define Auxiliary_ChineseQuickSortProvider_hpp

Generated on Tue Jan 24 18:18:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ChineseQuickSortProvider.hpp Source File

Auxiliary/ChineseQuickSortProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Auxiliary_ChineseQuickSortProvider_hpp)
00015 #define Auxiliary_ChineseQuickSortProvider_hpp
00016
00017 #include <Kernel/Types.hpp>
00018 #include <Auxiliary/QuickSortProvider.hpp>
00019
00020 class Provider;
00021 class ProviderListener;
00022
00025 class ChineseQuickSortProvider : public QuickSortProvider
00026 {
00027     public:
00028         typedef QuickSortProvider Base;
00029
00030         enum SortMode {
00031             normal = 0,
00032             pinyin,
00033             stroke,
00034             bopomofo
00035         };
00036
00039         ChineseQuickSortProvider();
00044         ChineseQuickSortProvider(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00046         virtual ~ChineseQuickSortProvider();
00047
00048         virtual BOOLEAN Update(ProviderListener * listener = 0);
00049
00050         SortMode GetSortMode();
00051         void    SetSortMode(SortMode sort_mode);
00052         INT  SortCompare(WString* x1, WString* x2);
00053
00054     protected:
00055         virtual void QuickSort(INT left, INT right, INT & depth);
00056
00057     private:
00058         SortMode m_sort_mode;
00059         SortMode m_sorted_mode;
00060 };
00061
00062 #endif
00063
00064
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Conversion.cpp File Reference

Auxiliary/Conversion.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include <Config/KeyboardConfig.hpp>
#include "Conversion.hpp"

Include dependency graph for Conversion.cpp:

Generated on Tue Jan 24 18:18:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Conversion.hpp File Reference

Auxiliary/Conversion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Conversion

Defines

#define | Apc_Common_Conversion_hpp

Define Documentation

#define Apc_Common_Conversion_hpp

Generated on Tue Jan 24 18:18:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Conversion.hpp Source File

Auxiliary/Conversion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apc_Common_Conversion_hpp)
00009 #define Apc_Common_Conversion_hpp
00010
00011 /*  ========================================================================
00012     Conversion
00013     ======================================================================== */
00014 class Conversion {
00015     public:
00016         // Converts APOXI_KEY_0 .. 9, STAR, HASH to the corresponding IA5 code.
00017         // Returns 0x00 if invoked with other KeyCode.
00018         static UINT8 KeyCode2IA5(const KeyCode key);
00019
00020         // Converts IA5 code 0x30 - 9x39, 0x2a, 0x23 code to an corresponding
00021         // APOXI KeyCode. Returns APOXI_KEY_NONE if invoked with other key value.
00022         static KeyCode IA52KeyCode(const UINT8 key);
00023
00024 }; // Conversion
00025
00026
00027 #endif  // Apc_SignalTypes_hpp
00028
00029
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/CountryCodes.hpp File Reference

Auxiliary/CountryCodes.hpp File Reference

Go to the source code of this file.

Defines

#define | Apoxi_CountryCodes_hpp
#define | ApoxiMakeCountryCode(a, b) ((((UINT) a) << 8U) | ((UINT) b))

Enumerations

enum CountryCodes {
CountryAF = ApoxiMakeCountryCode(A,F), CountryAL = ApoxiMakeCountryCode(A,L), CountryDZ = ApoxiMakeCountryCode(D,Z), CountryAS = ApoxiMakeCountryCode(A,S),
CountryAD = ApoxiMakeCountryCode(A,D), CountryAO = ApoxiMakeCountryCode(A,O), CountryAI = ApoxiMakeCountryCode(A,I), CountryAQ = ApoxiMakeCountryCode(A,Q),
CountryAG = ApoxiMakeCountryCode(A,G), CountryAR = ApoxiMakeCountryCode(A,R), CountryAM = ApoxiMakeCountryCode(A,M), CountryAW = ApoxiMakeCountryCode(A,W),
CountryAU = ApoxiMakeCountryCode(A,U), CountryAT = ApoxiMakeCountryCode(A,T), CountryAZ = ApoxiMakeCountryCode(A,Z), CountryBS = ApoxiMakeCountryCode(B,S),
CountryBH = ApoxiMakeCountryCode(B,H), CountryBD = ApoxiMakeCountryCode(B,D), CountryBB = ApoxiMakeCountryCode(B,B), CountryBY = ApoxiMakeCountryCode(B,Y),
CountryBE = ApoxiMakeCountryCode(B,E), CountryBZ = ApoxiMakeCountryCode(B,Z), CountryBJ = ApoxiMakeCountryCode(B,J), CountryBM = ApoxiMakeCountryCode(B,M),
CountryBT = ApoxiMakeCountryCode(B,T), CountryBO = ApoxiMakeCountryCode(B,O), CountryBA = ApoxiMakeCountryCode(B,A), CountryBW = ApoxiMakeCountryCode(B,W),
CountryBV = ApoxiMakeCountryCode(B,V), CountryBR = ApoxiMakeCountryCode(B,R), CountryIO = ApoxiMakeCountryCode(I,O), CountryBN = ApoxiMakeCountryCode(B,N),
CountryBG = ApoxiMakeCountryCode(B,G), CountryBF = ApoxiMakeCountryCode(B,F), CountryBI = ApoxiMakeCountryCode(B,I), CountryKH = ApoxiMakeCountryCode(K,H),
CountryCM = ApoxiMakeCountryCode(C,M), CountryCA = ApoxiMakeCountryCode(C,A), CountryCV = ApoxiMakeCountryCode(C,V), CountryKY = ApoxiMakeCountryCode(K,Y),
CountryCF = ApoxiMakeCountryCode(C,F), CountryTD = ApoxiMakeCountryCode(T,D), CountryCL = ApoxiMakeCountryCode(C,L), CountryCN = ApoxiMakeCountryCode(C,N),
CountryCX = ApoxiMakeCountryCode(C,X), CountryCC = ApoxiMakeCountryCode(C,C), CountryCO = ApoxiMakeCountryCode(C,O), CountryKM = ApoxiMakeCountryCode(K,M),
CountryCG = ApoxiMakeCountryCode(C,G), CountryCK = ApoxiMakeCountryCode(C,K), CountryCR = ApoxiMakeCountryCode(C,R), CountryCI = ApoxiMakeCountryCode(C,I),
CountryHR = ApoxiMakeCountryCode(H,R), CountryCU = ApoxiMakeCountryCode(C,U), CountryCY = ApoxiMakeCountryCode(C,Y), CountryCZ = ApoxiMakeCountryCode(C,Z),
CountryDK = ApoxiMakeCountryCode(D,K), CountryDJ = ApoxiMakeCountryCode(D,J), CountryDM = ApoxiMakeCountryCode(D,M), CountryDO = ApoxiMakeCountryCode(D,O),
CountryTP = ApoxiMakeCountryCode(T,P), CountryEC = ApoxiMakeCountryCode(E,C), CountryEG = ApoxiMakeCountryCode(E,G), CountrySV = ApoxiMakeCountryCode(S,V),
CountryGQ = ApoxiMakeCountryCode(G,Q), CountryER = ApoxiMakeCountryCode(E,R), CountryEE = ApoxiMakeCountryCode(E,E), CountryET = ApoxiMakeCountryCode(E,T),
CountryFK = ApoxiMakeCountryCode(F,K), CountryFO = ApoxiMakeCountryCode(F,O), CountryFJ = ApoxiMakeCountryCode(F,J), CountryFI = ApoxiMakeCountryCode(F,I),
CountryFR = ApoxiMakeCountryCode(F,R), CountryFX = ApoxiMakeCountryCode(F,X), CountryGF = ApoxiMakeCountryCode(G,F), CountryPF = ApoxiMakeCountryCode(P,F),
CountryTF = ApoxiMakeCountryCode(T,F), CountryGA = ApoxiMakeCountryCode(G,A), CountryGM = ApoxiMakeCountryCode(G,M), CountryGE = ApoxiMakeCountryCode(G,E),
CountryDE = ApoxiMakeCountryCode(D,E), CountryGH = ApoxiMakeCountryCode(G,H), CountryGI = ApoxiMakeCountryCode(G,I), CountryGR = ApoxiMakeCountryCode(G,R),
CountryGL = ApoxiMakeCountryCode(G,L), CountryGD = ApoxiMakeCountryCode(G,D), CountryGP = ApoxiMakeCountryCode(G,P), CountryGU = ApoxiMakeCountryCode(G,U),
CountryGT = ApoxiMakeCountryCode(G,T), CountryGN = ApoxiMakeCountryCode(G,N), CountryGW = ApoxiMakeCountryCode(G,W), CountryGY = ApoxiMakeCountryCode(G,Y),
CountryHT = ApoxiMakeCountryCode(H,T), CountryHM = ApoxiMakeCountryCode(H,M), CountryHN = ApoxiMakeCountryCode(H,N), CountryHK = ApoxiMakeCountryCode(H,K),
CountryHU = ApoxiMakeCountryCode(H,U), CountryIS = ApoxiMakeCountryCode(I,S), CountryIN = ApoxiMakeCountryCode(I,N), CountryID = ApoxiMakeCountryCode(I,D),
CountryIR = ApoxiMakeCountryCode(I,R), CountryIQ = ApoxiMakeCountryCode(I,Q), CountryIE = ApoxiMakeCountryCode(I,E), CountryIL = ApoxiMakeCountryCode(I,L),
CountryIT = ApoxiMakeCountryCode(I,T), CountryJM = ApoxiMakeCountryCode(J,M), CountryJP = ApoxiMakeCountryCode(J,P), CountryJO = ApoxiMakeCountryCode(J,O),
CountryKZ = ApoxiMakeCountryCode(K,Z), CountryKE = ApoxiMakeCountryCode(K,E), CountryKI = ApoxiMakeCountryCode(K,I), CountryKP = ApoxiMakeCountryCode(K,P),
CountryKR = ApoxiMakeCountryCode(K,R), CountryKW = ApoxiMakeCountryCode(K,W), CountryKG = ApoxiMakeCountryCode(K,G), CountryLA = ApoxiMakeCountryCode(L,A),
CountryLV = ApoxiMakeCountryCode(L,V), CountryLB = ApoxiMakeCountryCode(L,B), CountryLS = ApoxiMakeCountryCode(L,S), CountryLR = ApoxiMakeCountryCode(L,R),
CountryLY = ApoxiMakeCountryCode(L,Y), CountryLI = ApoxiMakeCountryCode(L,I), CountryLT = ApoxiMakeCountryCode(L,T), CountryLU = ApoxiMakeCountryCode(L,U),
CountryMO = ApoxiMakeCountryCode(M,O), CountryMK = ApoxiMakeCountryCode(M,K), CountryMG = ApoxiMakeCountryCode(M,G), CountryMW = ApoxiMakeCountryCode(M,W),
CountryMY = ApoxiMakeCountryCode(M,Y), CountryMV = ApoxiMakeCountryCode(M,V), CountryML = ApoxiMakeCountryCode(M,L), CountryMT = ApoxiMakeCountryCode(M,T),
CountryMH = ApoxiMakeCountryCode(M,H), CountryMQ = ApoxiMakeCountryCode(M,Q), CountryMR = ApoxiMakeCountryCode(M,R), CountryMU = ApoxiMakeCountryCode(M,U),
CountryYT = ApoxiMakeCountryCode(Y,T), CountryMX = ApoxiMakeCountryCode(M,X), CountryFM = ApoxiMakeCountryCode(F,M), CountryMD = ApoxiMakeCountryCode(M,D),
CountryMC = ApoxiMakeCountryCode(M,C), CountryMN = ApoxiMakeCountryCode(M,N), CountryMS = ApoxiMakeCountryCode(M,S), CountryMA = ApoxiMakeCountryCode(M,A),
CountryMZ = ApoxiMakeCountryCode(M,Z), CountryMM = ApoxiMakeCountryCode(M,M), CountryNA = ApoxiMakeCountryCode(N,A), CountryNR = ApoxiMakeCountryCode(N,R),
CountryNP = ApoxiMakeCountryCode(N,P), CountryNL = ApoxiMakeCountryCode(N,L), CountryAN = ApoxiMakeCountryCode(A,N), CountryNC = ApoxiMakeCountryCode(N,C),
CountryNZ = ApoxiMakeCountryCode(N,Z), CountryNI = ApoxiMakeCountryCode(N,I), CountryNE = ApoxiMakeCountryCode(N,E), CountryNG = ApoxiMakeCountryCode(N,G),
CountryNU = ApoxiMakeCountryCode(N,U), CountryNF = ApoxiMakeCountryCode(N,F), CountryMP = ApoxiMakeCountryCode(M,P), CountryNO = ApoxiMakeCountryCode(N,O),
CountryOM = ApoxiMakeCountryCode(O,M), CountryPK = ApoxiMakeCountryCode(P,K), CountryPW = ApoxiMakeCountryCode(P,W), CountryPA = ApoxiMakeCountryCode(P,A),
CountryPG = ApoxiMakeCountryCode(P,G), CountryPY = ApoxiMakeCountryCode(P,Y), CountryPE = ApoxiMakeCountryCode(P,E), CountryPH = ApoxiMakeCountryCode(P,H),
CountryPN = ApoxiMakeCountryCode(P,N), CountryPL = ApoxiMakeCountryCode(P,L), CountryPT = ApoxiMakeCountryCode(P,T), CountryPR = ApoxiMakeCountryCode(P,R),
CountryQA = ApoxiMakeCountryCode(Q,A), CountryRE = ApoxiMakeCountryCode(R,E), CountryRO = ApoxiMakeCountryCode(R,O), CountryRU = ApoxiMakeCountryCode(R,U),
CountryRW = ApoxiMakeCountryCode(R,W), CountryKN = ApoxiMakeCountryCode(K,N), CountryLC = ApoxiMakeCountryCode(L,C), CountryVC = ApoxiMakeCountryCode(V,C),
CountryWS = ApoxiMakeCountryCode(W,S), CountrySM = ApoxiMakeCountryCode(S,M), CountryST = ApoxiMakeCountryCode(S,T), CountrySA = ApoxiMakeCountryCode(S,A),
CountrySN = ApoxiMakeCountryCode(S,N), CountrySC = ApoxiMakeCountryCode(S,C), CountrySL = ApoxiMakeCountryCode(S,L), CountrySG = ApoxiMakeCountryCode(S,G),
CountrySK = ApoxiMakeCountryCode(S,K), CountrySI = ApoxiMakeCountryCode(S,I), CountrySB = ApoxiMakeCountryCode(S,B), CountrySO = ApoxiMakeCountryCode(S,O),
CountryZA = ApoxiMakeCountryCode(Z,A), CountryGS = ApoxiMakeCountryCode(G,S), CountryES = ApoxiMakeCountryCode(E,S), CountryLK = ApoxiMakeCountryCode(L,K),
CountrySH = ApoxiMakeCountryCode(S,H), CountryPM = ApoxiMakeCountryCode(P,M), CountrySD = ApoxiMakeCountryCode(S,D), CountrySR = ApoxiMakeCountryCode(S,R),
CountrySJ = ApoxiMakeCountryCode(S,J), CountrySZ = ApoxiMakeCountryCode(S,Z), CountrySE = ApoxiMakeCountryCode(S,E), CountryCH = ApoxiMakeCountryCode(C,H),
CountrySY = ApoxiMakeCountryCode(S,Y), CountryTW = ApoxiMakeCountryCode(T,W), CountryTJ = ApoxiMakeCountryCode(T,J), CountryTZ = ApoxiMakeCountryCode(T,Z),
CountryTH = ApoxiMakeCountryCode(T,H), CountryTG = ApoxiMakeCountryCode(T,G), CountryTK = ApoxiMakeCountryCode(T,K), CountryTO = ApoxiMakeCountryCode(T,O),
CountryTT = ApoxiMakeCountryCode(T,T), CountryTN = ApoxiMakeCountryCode(T,N), CountryTR = ApoxiMakeCountryCode(T,R), CountryTM = ApoxiMakeCountryCode(T,M),
CountryTC = ApoxiMakeCountryCode(T,C), CountryTV = ApoxiMakeCountryCode(T,V), CountryUG = ApoxiMakeCountryCode(U,G), CountryUA = ApoxiMakeCountryCode(U,A),
CountryAE = ApoxiMakeCountryCode(A,E), CountryGB = ApoxiMakeCountryCode(G,B), CountryUS = ApoxiMakeCountryCode(U,S), CountryUM = ApoxiMakeCountryCode(U,M),
CountryUY = ApoxiMakeCountryCode(U,Y), CountryUZ = ApoxiMakeCountryCode(U,Z), CountryVU = ApoxiMakeCountryCode(V,U), CountryVA = ApoxiMakeCountryCode(V,A),
CountryVE = ApoxiMakeCountryCode(V,E), CountryVN = ApoxiMakeCountryCode(V,N), CountryVG = ApoxiMakeCountryCode(V,G), CountryVI = ApoxiMakeCountryCode(V,I),
CountryWF = ApoxiMakeCountryCode(W,F), CountryEH = ApoxiMakeCountryCode(E,H), CountryYE = ApoxiMakeCountryCode(Y,E), CountryYU = ApoxiMakeCountryCode(Y,U),
CountryZR = ApoxiMakeCountryCode(Z,R), CountryZM = ApoxiMakeCountryCode(Z,M), CountryZW = ApoxiMakeCountryCode(Z,W), CountryInvalid = ApoxiMakeCountryCode(0,0)
}

Define Documentation

#define Apoxi_CountryCodes_hpp

Generated on Tue Jan 24 18:18:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/CountryCodes.hpp Source File

Auxiliary/CountryCodes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------
00008     ISO 3166 Country Codes
00009     Do not manualy modify this file.
00010     ------------------------------------------------------------------------ */
00011
00012 #if !defined(Apoxi_CountryCodes_hpp)
00013 #define Apoxi_CountryCodes_hpp
00016
00017 #if defined(APOXI_LITTLE_ENDIAN)
00018 #define ApoxiMakeCountryCode(a,b)   ((((UINT) b) << 8U) | ((UINT) a))
00019 #else
00020 #define ApoxiMakeCountryCode(a,b)   ((((UINT) a) << 8U) | ((UINT) b))
00021 #endif
00022
00023 enum CountryCodes {
00024     CountryAF = ApoxiMakeCountryCode(A,F),  // AFGHANISTAN
00025     CountryAL = ApoxiMakeCountryCode(A,L),  // ALBANIA
00026     CountryDZ = ApoxiMakeCountryCode(D,Z),  // ALGERIA
00027     CountryAS = ApoxiMakeCountryCode(A,S),  // AMERICAN SAMOA
00028     CountryAD = ApoxiMakeCountryCode(A,D),  // ANDORRA
00029     CountryAO = ApoxiMakeCountryCode(A,O),  // ANGOLA
00030     CountryAI = ApoxiMakeCountryCode(A,I),  // ANGUILLA
00031     CountryAQ = ApoxiMakeCountryCode(A,Q),  // ANTARCTICA
00032     CountryAG = ApoxiMakeCountryCode(A,G),  // ANTIGUA AND BARBUDA
00033     CountryAR = ApoxiMakeCountryCode(A,R),  // ARGENTINA
00034     CountryAM = ApoxiMakeCountryCode(A,M),  // ARMENIA
00035     CountryAW = ApoxiMakeCountryCode(A,W),  // ARUBA
00036     CountryAU = ApoxiMakeCountryCode(A,U),  // AUSTRALIA
00037     CountryAT = ApoxiMakeCountryCode(A,T),  // AUSTRIA
00038     CountryAZ = ApoxiMakeCountryCode(A,Z),  // AZERBAIJAN
00039     CountryBS = ApoxiMakeCountryCode(B,S),  // BAHAMAS
00040     CountryBH = ApoxiMakeCountryCode(B,H),  // BAHRAIN
00041     CountryBD = ApoxiMakeCountryCode(B,D),  // BANGLADESH
00042     CountryBB = ApoxiMakeCountryCode(B,B),  // BARBADOS
00043     CountryBY = ApoxiMakeCountryCode(B,Y),  // BELARUS
00044     CountryBE = ApoxiMakeCountryCode(B,E),  // BELGIUM
00045     CountryBZ = ApoxiMakeCountryCode(B,Z),  // BELIZE
00046     CountryBJ = ApoxiMakeCountryCode(B,J),  // BENIN
00047     CountryBM = ApoxiMakeCountryCode(B,M),  // BERMUDA
00048     CountryBT = ApoxiMakeCountryCode(B,T),  // BHUTAN
00049     CountryBO = ApoxiMakeCountryCode(B,O),  // BOLIVIA
00050     CountryBA = ApoxiMakeCountryCode(B,A),  // BOSNIA AND HERZEGOWINA
00051     CountryBW = ApoxiMakeCountryCode(B,W),  // BOTSWANA
00052     CountryBV = ApoxiMakeCountryCode(B,V),  // BOUVET ISLAND
00053     CountryBR = ApoxiMakeCountryCode(B,R),  // BRAZIL
00054     CountryIO = ApoxiMakeCountryCode(I,O),  // BRITISH INDIAN OCEAN TERRITORY
00055     CountryBN = ApoxiMakeCountryCode(B,N),  // BRUNEI DARUSSALAM
00056     CountryBG = ApoxiMakeCountryCode(B,G),  // BULGARIA
00057     CountryBF = ApoxiMakeCountryCode(B,F),  // BURKINA FASO
00058     CountryBI = ApoxiMakeCountryCode(B,I),  // BURUNDI
00059     CountryKH = ApoxiMakeCountryCode(K,H),  // CAMBODIA
00060     CountryCM = ApoxiMakeCountryCode(C,M),  // CAMEROON
00061     CountryCA = ApoxiMakeCountryCode(C,A),  // CANADA
00062     CountryCV = ApoxiMakeCountryCode(C,V),  // CAPE VERDE
00063     CountryKY = ApoxiMakeCountryCode(K,Y),  // CAYMAN ISLANDS
00064     CountryCF = ApoxiMakeCountryCode(C,F),  // CENTRAL AFRICAN REPUBLIC
00065     CountryTD = ApoxiMakeCountryCode(T,D),  // CHAD
00066     CountryCL = ApoxiMakeCountryCode(C,L),  // CHILE
00067     CountryCN = ApoxiMakeCountryCode(C,N),  // CHINA
00068     CountryCX = ApoxiMakeCountryCode(C,X),  // CHRISTMAS ISLAND
00069     CountryCC = ApoxiMakeCountryCode(C,C),  // COCOS (KEELING) ISLANDS
00070     CountryCO = ApoxiMakeCountryCode(C,O),  // COLOMBIA
00071     CountryKM = ApoxiMakeCountryCode(K,M),  // COMOROS
00072     CountryCG = ApoxiMakeCountryCode(C,G),  // CONGO
00073     CountryCK = ApoxiMakeCountryCode(C,K),  // COOK ISLANDS
00074     CountryCR = ApoxiMakeCountryCode(C,R),  // COSTA RICA
00075     CountryCI = ApoxiMakeCountryCode(C,I),  // COTE D'IVOIRE
00076     CountryHR = ApoxiMakeCountryCode(H,R),  // CROATIA (local name: Hrvatska)
00077     CountryCU = ApoxiMakeCountryCode(C,U),  // CUBA
00078     CountryCY = ApoxiMakeCountryCode(C,Y),  // CYPRUS
00079     CountryCZ = ApoxiMakeCountryCode(C,Z),  // CZECH REPUBLIC
00080     CountryDK = ApoxiMakeCountryCode(D,K),  // DENMARK
00081     CountryDJ = ApoxiMakeCountryCode(D,J),  // DJIBOUTI
00082     CountryDM = ApoxiMakeCountryCode(D,M),  // DOMINICA
00083     CountryDO = ApoxiMakeCountryCode(D,O),  // DOMINICAN REPUBLIC
00084     CountryTP = ApoxiMakeCountryCode(T,P),  // EAST TIMOR
00085     CountryEC = ApoxiMakeCountryCode(E,C),  // ECUADOR
00086     CountryEG = ApoxiMakeCountryCode(E,G),  // EGYPT
00087     CountrySV = ApoxiMakeCountryCode(S,V),  // EL SALVADOR
00088     CountryGQ = ApoxiMakeCountryCode(G,Q),  // EQUATORIAL GUINEA
00089     CountryER = ApoxiMakeCountryCode(E,R),  // ERITREA
00090     CountryEE = ApoxiMakeCountryCode(E,E),  // ESTONIA
00091     CountryET = ApoxiMakeCountryCode(E,T),  // ETHIOPIA
00092     CountryFK = ApoxiMakeCountryCode(F,K),  // FALKLAND ISLANDS (MALVINAS)
00093     CountryFO = ApoxiMakeCountryCode(F,O),  // FAROE ISLANDS
00094     CountryFJ = ApoxiMakeCountryCode(F,J),  // FIJI
00095     CountryFI = ApoxiMakeCountryCode(F,I),  // FINLAND
00096     CountryFR = ApoxiMakeCountryCode(F,R),  // FRANCE
00097     CountryFX = ApoxiMakeCountryCode(F,X),  // FRANCE, METROPOLITAN
00098     CountryGF = ApoxiMakeCountryCode(G,F),  // FRENCH GUIANA
00099     CountryPF = ApoxiMakeCountryCode(P,F),  // FRENCH POLYNESIA
00100     CountryTF = ApoxiMakeCountryCode(T,F),  // FRENCH SOUTHERN TERRITORIES
00101     CountryGA = ApoxiMakeCountryCode(G,A),  // GABON
00102     CountryGM = ApoxiMakeCountryCode(G,M),  // GAMBIA
00103     CountryGE = ApoxiMakeCountryCode(G,E),  // GEORGIA
00104     CountryDE = ApoxiMakeCountryCode(D,E),  // GERMANY
00105     CountryGH = ApoxiMakeCountryCode(G,H),  // GHANA
00106     CountryGI = ApoxiMakeCountryCode(G,I),  // GIBRALTAR
00107     CountryGR = ApoxiMakeCountryCode(G,R),  // GREECE
00108     CountryGL = ApoxiMakeCountryCode(G,L),  // GREENLAND
00109     CountryGD = ApoxiMakeCountryCode(G,D),  // GRENADA
00110     CountryGP = ApoxiMakeCountryCode(G,P),  // GUADELOUPE
00111     CountryGU = ApoxiMakeCountryCode(G,U),  // GUAM
00112     CountryGT = ApoxiMakeCountryCode(G,T),  // GUATEMALA
00113     CountryGN = ApoxiMakeCountryCode(G,N),  // GUINEA
00114     CountryGW = ApoxiMakeCountryCode(G,W),  // GUINEA-BISSAU
00115     CountryGY = ApoxiMakeCountryCode(G,Y),  // GUYANA
00116     CountryHT = ApoxiMakeCountryCode(H,T),  // HAITI
00117     CountryHM = ApoxiMakeCountryCode(H,M),  // HEARD AND MC DONALD ISLANDS
00118     CountryHN = ApoxiMakeCountryCode(H,N),  // HONDURAS
00119     CountryHK = ApoxiMakeCountryCode(H,K),  // HONG KONG
00120     CountryHU = ApoxiMakeCountryCode(H,U),  // HUNGARY
00121     CountryIS = ApoxiMakeCountryCode(I,S),  // ICELAND
00122     CountryIN = ApoxiMakeCountryCode(I,N),  // INDIA
00123     CountryID = ApoxiMakeCountryCode(I,D),  // INDONESIA
00124     CountryIR = ApoxiMakeCountryCode(I,R),  // IRAN (ISLAMIC REPUBLIC OF)
00125     CountryIQ = ApoxiMakeCountryCode(I,Q),  // IRAQ
00126     CountryIE = ApoxiMakeCountryCode(I,E),  // IRELAND
00127     CountryIL = ApoxiMakeCountryCode(I,L),  // ISRAEL
00128     CountryIT = ApoxiMakeCountryCode(I,T),  // ITALY
00129     CountryJM = ApoxiMakeCountryCode(J,M),  // JAMAICA
00130     CountryJP = ApoxiMakeCountryCode(J,P),  // JAPAN
00131     CountryJO = ApoxiMakeCountryCode(J,O),  // JORDAN
00132     CountryKZ = ApoxiMakeCountryCode(K,Z),  // KAZAKHSTAN
00133     CountryKE = ApoxiMakeCountryCode(K,E),  // KENYA
00134     CountryKI = ApoxiMakeCountryCode(K,I),  // KIRIBATI
00135     CountryKP = ApoxiMakeCountryCode(K,P),  // KOREA, DEMOCRATIC PEOPLE'S REPUBLIC OF
00136     CountryKR = ApoxiMakeCountryCode(K,R),  // KOREA, REPUBLIC OF
00137     CountryKW = ApoxiMakeCountryCode(K,W),  // KUWAIT
00138     CountryKG = ApoxiMakeCountryCode(K,G),  // KYRGYZSTAN
00139     CountryLA = ApoxiMakeCountryCode(L,A),  // LAO PEOPLE'S DEMOCRATIC REPUBLIC
00140     CountryLV = ApoxiMakeCountryCode(L,V),  // LATVIA
00141     CountryLB = ApoxiMakeCountryCode(L,B),  // LEBANON
00142     CountryLS = ApoxiMakeCountryCode(L,S),  // LESOTHO
00143     CountryLR = ApoxiMakeCountryCode(L,R),  // LIBERIA
00144     CountryLY = ApoxiMakeCountryCode(L,Y),  // LIBYAN ARAB JAMAHIRIYA
00145     CountryLI = ApoxiMakeCountryCode(L,I),  // LIECHTENSTEIN
00146     CountryLT = ApoxiMakeCountryCode(L,T),  // LITHUANIA
00147     CountryLU = ApoxiMakeCountryCode(L,U),  // LUXEMBOURG
00148     CountryMO = ApoxiMakeCountryCode(M,O),  // MACAU
00149     CountryMK = ApoxiMakeCountryCode(M,K),  // MACEDONIA, THE FORMER YUGOSLAV REPUBLIC OF
00150     CountryMG = ApoxiMakeCountryCode(M,G),  // MADAGASCAR
00151     CountryMW = ApoxiMakeCountryCode(M,W),  // MALAWI
00152     CountryMY = ApoxiMakeCountryCode(M,Y),  // MALAYSIA
00153     CountryMV = ApoxiMakeCountryCode(M,V),  // MALDIVES
00154     CountryML = ApoxiMakeCountryCode(M,L),  // MALI
00155     CountryMT = ApoxiMakeCountryCode(M,T),  // MALTA
00156     CountryMH = ApoxiMakeCountryCode(M,H),  // MARSHALL ISLANDS
00157     CountryMQ = ApoxiMakeCountryCode(M,Q),  // MARTINIQUE
00158     CountryMR = ApoxiMakeCountryCode(M,R),  // MAURITANIA
00159     CountryMU = ApoxiMakeCountryCode(M,U),  // MAURITIUS
00160     CountryYT = ApoxiMakeCountryCode(Y,T),  // MAYOTTE
00161     CountryMX = ApoxiMakeCountryCode(M,X),  // MEXICO
00162     CountryFM = ApoxiMakeCountryCode(F,M),  // MICRONESIA, FEDERATED STATES OF
00163     CountryMD = ApoxiMakeCountryCode(M,D),  // MOLDOVA, REPUBLIC OF
00164     CountryMC = ApoxiMakeCountryCode(M,C),  // MONACO
00165     CountryMN = ApoxiMakeCountryCode(M,N),  // MONGOLIA
00166     CountryMS = ApoxiMakeCountryCode(M,S),  // MONTSERRAT
00167     CountryMA = ApoxiMakeCountryCode(M,A),  // MOROCCO
00168     CountryMZ = ApoxiMakeCountryCode(M,Z),  // MOZAMBIQUE
00169     CountryMM = ApoxiMakeCountryCode(M,M),  // MYANMAR
00170     CountryNA = ApoxiMakeCountryCode(N,A),  // NAMIBIA
00171     CountryNR = ApoxiMakeCountryCode(N,R),  // NAURU
00172     CountryNP = ApoxiMakeCountryCode(N,P),  // NEPAL
00173     CountryNL = ApoxiMakeCountryCode(N,L),  // NETHERLANDS
00174     CountryAN = ApoxiMakeCountryCode(A,N),  // NETHERLANDS ANTILLES
00175     CountryNC = ApoxiMakeCountryCode(N,C),  // NEW CALEDONIA
00176     CountryNZ = ApoxiMakeCountryCode(N,Z),  // NEW ZEALAND
00177     CountryNI = ApoxiMakeCountryCode(N,I),  // NICARAGUA
00178     CountryNE = ApoxiMakeCountryCode(N,E),  // NIGER
00179     CountryNG = ApoxiMakeCountryCode(N,G),  // NIGERIA
00180     CountryNU = ApoxiMakeCountryCode(N,U),  // NIUE
00181     CountryNF = ApoxiMakeCountryCode(N,F),  // NORFOLK ISLAND
00182     CountryMP = ApoxiMakeCountryCode(M,P),  // NORTHERN MARIANA ISLANDS
00183     CountryNO = ApoxiMakeCountryCode(N,O),  // NORWAY
00184     CountryOM = ApoxiMakeCountryCode(O,M),  // OMAN
00185     CountryPK = ApoxiMakeCountryCode(P,K),  // PAKISTAN
00186     CountryPW = ApoxiMakeCountryCode(P,W),  // PALAU
00187     CountryPA = ApoxiMakeCountryCode(P,A),  // PANAMA
00188     CountryPG = ApoxiMakeCountryCode(P,G),  // PAPUA NEW GUINEA
00189     CountryPY = ApoxiMakeCountryCode(P,Y),  // PARAGUAY
00190     CountryPE = ApoxiMakeCountryCode(P,E),  // PERU
00191     CountryPH = ApoxiMakeCountryCode(P,H),  // PHILIPPINES
00192     CountryPN = ApoxiMakeCountryCode(P,N),  // PITCAIRN
00193     CountryPL = ApoxiMakeCountryCode(P,L),  // POLAND
00194     CountryPT = ApoxiMakeCountryCode(P,T),  // PORTUGAL
00195     CountryPR = ApoxiMakeCountryCode(P,R),  // PUERTO RICO
00196     CountryQA = ApoxiMakeCountryCode(Q,A),  // QATAR
00197     CountryRE = ApoxiMakeCountryCode(R,E),  // REUNION
00198     CountryRO = ApoxiMakeCountryCode(R,O),  // ROMANIA
00199     CountryRU = ApoxiMakeCountryCode(R,U),  // RUSSIAN FEDERATION
00200     CountryRW = ApoxiMakeCountryCode(R,W),  // RWANDA
00201     CountryKN = ApoxiMakeCountryCode(K,N),  // SAINT KITTS AND NEVIS
00202     CountryLC = ApoxiMakeCountryCode(L,C),  // SAINT LUCIA
00203     CountryVC = ApoxiMakeCountryCode(V,C),  // SAINT VINCENT AND THE GRENADINES
00204     CountryWS = ApoxiMakeCountryCode(W,S),  // SAMOA
00205     CountrySM = ApoxiMakeCountryCode(S,M),  // SAN MARINO
00206     CountryST = ApoxiMakeCountryCode(S,T),  // SAO TOME AND PRINCIPE
00207     CountrySA = ApoxiMakeCountryCode(S,A),  // SAUDI ARABIA
00208     CountrySN = ApoxiMakeCountryCode(S,N),  // SENEGAL
00209     CountrySC = ApoxiMakeCountryCode(S,C),  // SEYCHELLES
00210     CountrySL = ApoxiMakeCountryCode(S,L),  // SIERRA LEONE
00211     CountrySG = ApoxiMakeCountryCode(S,G),  // SINGAPORE
00212     CountrySK = ApoxiMakeCountryCode(S,K),  // SLOVAKIA (Slovak Republic)
00213     CountrySI = ApoxiMakeCountryCode(S,I),  // SLOVENIA
00214     CountrySB = ApoxiMakeCountryCode(S,B),  // SOLOMON ISLANDS
00215     CountrySO = ApoxiMakeCountryCode(S,O),  // SOMALIA
00216     CountryZA = ApoxiMakeCountryCode(Z,A),  // SOUTH AFRICA
00217     CountryGS = ApoxiMakeCountryCode(G,S),  // SOUTH GEORGIA AND THE SOUTH SANDWICH ISLANDS
00218     CountryES = ApoxiMakeCountryCode(E,S),  // SPAIN
00219     CountryLK = ApoxiMakeCountryCode(L,K),  // SRI LANKA
00220     CountrySH = ApoxiMakeCountryCode(S,H),  // ST. HELENA
00221     CountryPM = ApoxiMakeCountryCode(P,M),  // ST. PIERRE AND MIQUELON
00222     CountrySD = ApoxiMakeCountryCode(S,D),  // SUDAN
00223     CountrySR = ApoxiMakeCountryCode(S,R),  // SURINAME
00224     CountrySJ = ApoxiMakeCountryCode(S,J),  // SVALBARD AND JAN MAYEN ISLANDS
00225     CountrySZ = ApoxiMakeCountryCode(S,Z),  // SWAZILAND
00226     CountrySE = ApoxiMakeCountryCode(S,E),  // SWEDEN
00227     CountryCH = ApoxiMakeCountryCode(C,H),  // SWITZERLAND
00228     CountrySY = ApoxiMakeCountryCode(S,Y),  // SYRIAN ARAB REPUBLIC
00229     CountryTW = ApoxiMakeCountryCode(T,W),  // TAIWAN
00230     CountryTJ = ApoxiMakeCountryCode(T,J),  // TAJIKISTAN
00231     CountryTZ = ApoxiMakeCountryCode(T,Z),  // TANZANIA, UNITED REPUBLIC OF
00232     CountryTH = ApoxiMakeCountryCode(T,H),  // THAILAND
00233     CountryTG = ApoxiMakeCountryCode(T,G),  // TOGO
00234     CountryTK = ApoxiMakeCountryCode(T,K),  // TOKELAU
00235     CountryTO = ApoxiMakeCountryCode(T,O),  // TONGA
00236     CountryTT = ApoxiMakeCountryCode(T,T),  // TRINIDAD AND TOBAGO
00237     CountryTN = ApoxiMakeCountryCode(T,N),  // TUNISIA
00238     CountryTR = ApoxiMakeCountryCode(T,R),  // TURKEY
00239     CountryTM = ApoxiMakeCountryCode(T,M),  // TURKMENISTAN
00240     CountryTC = ApoxiMakeCountryCode(T,C),  // TURKS AND CAICOS ISLANDS
00241     CountryTV = ApoxiMakeCountryCode(T,V),  // TUVALU
00242     CountryUG = ApoxiMakeCountryCode(U,G),  // UGANDA
00243     CountryUA = ApoxiMakeCountryCode(U,A),  // UKRAINE
00244     CountryAE = ApoxiMakeCountryCode(A,E),  // UNITED ARAB EMIRATES
00245     CountryGB = ApoxiMakeCountryCode(G,B),  // UNITED KINGDOM
00246     CountryUS = ApoxiMakeCountryCode(U,S),  // UNITED STATES
00247     CountryUM = ApoxiMakeCountryCode(U,M),  // UNITED STATES MINOR OUTLYING ISLANDS
00248     CountryUY = ApoxiMakeCountryCode(U,Y),  // URUGUAY
00249     CountryUZ = ApoxiMakeCountryCode(U,Z),  // UZBEKISTAN
00250     CountryVU = ApoxiMakeCountryCode(V,U),  // VANUATU
00251     CountryVA = ApoxiMakeCountryCode(V,A),  // VATICAN CITY STATE (HOLY SEE)
00252     CountryVE = ApoxiMakeCountryCode(V,E),  // VENEZUELA
00253     CountryVN = ApoxiMakeCountryCode(V,N),  // VIET NAM
00254     CountryVG = ApoxiMakeCountryCode(V,G),  // VIRGIN ISLANDS (BRITISH)
00255     CountryVI = ApoxiMakeCountryCode(V,I),  // VIRGIN ISLANDS (U.S.)
00256     CountryWF = ApoxiMakeCountryCode(W,F),  // WALLIS AND FUTUNA ISLANDS
00257     CountryEH = ApoxiMakeCountryCode(E,H),  // WESTERN SAHARA
00258     CountryYE = ApoxiMakeCountryCode(Y,E),  // YEMEN
00259     CountryYU = ApoxiMakeCountryCode(Y,U),  // YUGOSLAVIA
00260     CountryZR = ApoxiMakeCountryCode(Z,R),  // ZAIRE
00261     CountryZM = ApoxiMakeCountryCode(Z,M),  // ZAMBIA
00262     CountryZW = ApoxiMakeCountryCode(Z,W),  // ZIMBABWE
00263     CountryInvalid = ApoxiMakeCountryCode(0,0)
00264 };   // 239 countries generated
00265
00267 #endif // Apoxi_CountryCode_hpp
00268
00269
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataCoding.cpp File Reference

Auxiliary/DataCoding.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DataCoding.hpp"
#include "WStrUtil.hpp"
#include "Macros.hpp"

Include dependency graph for DataCoding.cpp:

Generated on Tue Jan 24 18:18:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataCoding.hpp File Reference

Auxiliary/DataCoding.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for DataCoding.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataCoding

Defines

#define | Apc_DataCoding_hpp
#define | GsmInternalCodingAt 0x81
em>DataCoding implements SMS coding and decoding as defined in GSM 03.38.

Define Documentation

#define Apc_DataCoding_hpp

#define GsmInternalCodingAt 0x81

em>DataCoding implements SMS coding and decoding as defined in GSM 03.38.

Generated on Tue Jan 24 18:18:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataCoding.hpp Source File

Auxiliary/DataCoding.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apc_DataCoding_hpp)
00010 #define Apc_DataCoding_hpp
00011
00012
00013
00014 #include <Kernel/Types.hpp>
00015
00017
00018 #define GsmInternalCodingAt 0x81 // representation of "@" in GsmInternalCoding

00020 class DataCoding
{
    public:
        DataCoding();
        ~DataCoding(); // destructor not virtual !!!

00022         static BOOLEAN UnpackSeptetsToWchars(const UINT8 * in7bitbuffer, INT nofwcharchrs, WCHAR * outbuffer, UINT8 step = 0);

00024         static BOOLEAN UnpackCbsSeptetsToWchars(const UINT8 * in7bitbuffer, INT nofbytes, WCHAR * outbuffer, BOOLEAN haslengthbyte = FALSE);

00026         static INT GetWchars(INT nofbytes, const UINT8 * buffer, BOOLEAN checkeos = FALSE);

00028         static INT GetCbsWchars(INT nofbytes, const UINT8 * buffer, BOOLEAN haslengthbyte = FALSE);

00030         static INT GetEffectiveWchars(INT nofseptets, const UINT8 * buffer, UINT8 step = 0);

00033         static INT PackWcharsToSeptets(const WCHAR * inbuffer, INT nofwcharchrs, UINT8 * outbuffer, UINT8 step = 0);
00036         static INT PackWcharsToSeptets(const WCHAR * inbuffer, INT nofwcharchrs, UINT8 * outbuffer, INT size_of_outbuffer, UINT8 step);

00038         static INT GetSeptets(INT nofwcharchrs, const WCHAR * string);

00040         static INT GetBufferLength(INT nofwcharchrs, const WCHAR * string);

00042         static INT GetUnicodeStringToGsm7DefaultStringLength(const WCHAR * src, INT len);

00044         static void UnicodeStringToGsm7DefaultString(const WCHAR * src, CHAR * dest, INT len);

00046         static void Gsm7DefaultStringToUnicodeString(const CHAR * src, WCHAR * dest, INT len);

00049         static INT MoveUnicodeBufferAndAdjustBytes(const UINT8 * src, UINT8 * dest, INT bufferlen);

00053         static INT CopyCbsUnicodeBufferAndAdjustBytes(const UINT8 * src, UINT8 * dest, INT bufferlen, BOOLEAN haslengthbyte = FALSE);

00055         static BOOLEAN IsWCharToGsm7Possible(WCHAR src);

00057         static BOOLEAN HasOnly7bitChars(const WCHAR * string);

00059         static BOOLEAN ForceWcharsTo7bitWchars(const WCHAR * source, WCHAR * dest, INT len);

    private:

        static INT FindTerminatingCRSequence(const WCHAR * buffer, INT bufferlen);

        static WCHAR Gsm7DefaultExtendedToUnicode(UINT8 src);
        static WCHAR Gsm7DefaultToUnicode(UINT8 src);

        static UINT8 UnicodeToGsm7DefaultNormal(WCHAR src);
        static UINT8 UnicodeToGsm7DefaultExtended(WCHAR src);
        static UINT8 UnicodeToGsm7Default(WCHAR src, BOOLEAN & shallexpand);

};

#endif
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataItem.cpp File Reference

Auxiliary/DataItem.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DataItem.hpp"

Include dependency graph for DataItem.cpp:

Functions

BOOLEAN DataItemTestSuite ()
Generated on Tue Jan 24 18:18:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataItem.hpp File Reference

Auxiliary/DataItem.hpp File Reference

#include <Auxiliary/String.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/GenericObject.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>
#include <Auxiliary/DateTime.hpp>

Include dependency graph for DataItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataItem

Defines

#define | _Adc_DataItem_hpp

Typedefs

typedef INT(* | CompareFunction )(void **, void **)
typedef void *(* | CreateFunction )(const void *)
typedef void(* | DeleteFunction )(const void *)
typedef INT32 | Number

Enumerations

enum DataType {
UndefinedType = 0, NumberType = 1, WStringType = 2, StringType = 3,
PhoneNumberType = 4, ProviderType = 5, DateType = 6, TimeType = 7,
DateTimeType = 8, GenericType = 9, BooleanType = 10
}
Allowed types of DataItem DataItem. More...

Functions

BOOLEAN | DataItemTestSuite ()

Define Documentation

#define _Adc_DataItem_hpp

Generated on Tue Jan 24 18:19:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataItem.hpp Source File

Auxiliary/DataItem.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_DataItem_hpp)
00015 #define _Adc_DataItem_hpp
00018
00019 #include <Auxiliary/String.hpp>
00020 #include <Auxiliary/WString.hpp>
00021 #include <Auxiliary/PhoneNumber.hpp>
00022 #include <Auxiliary/GenericObject.hpp>
00023 #include <Auxiliary/Date.hpp>
00024 #include <Auxiliary/Time.hpp>
00025 #include <Auxiliary/DateTime.hpp>
00026
00027
00029 enum DataType {
00031     UndefinedType = 0,
00033     NumberType = 1,
00035     WStringType = 2,
00037     StringType = 3,
00039     PhoneNumberType = 4,
00041     ProviderType = 5,
00043     DateType = 6,
00045     TimeType = 7,
00047     DateTimeType = 8,
00049     GenericType = 9,
00051     BooleanType = 10
00052 };
00053
00054 typedef INT32 Number;
00055
00056 class Provider;
00057
00063 class DataItem
00064 {
00065     public:
00067         DataItem();
00069         DataItem(DataType type);
00071         DataItem(Number val);
00073         DataItem(const String & stringdata);
00075         DataItem(const WString & wstringdata);
00077         DataItem(const PhoneNumber & PhoneNumber);
00079         DataItem(const Date & date);
00081         DataItem(const Time & time);
00083         DataItem(const DateTime & datetime);
00085         DataItem(const DateTime::Persist & datetime);
00087         DataItem(const GenericObject * const object);
00089         DataItem(const DataItem &data_item);
00090
00092         ~DataItem();
00093
00095         void SetDataType(DataType type);
00096
00098         DataType GetDataType() const { return m_type; }
00099
00101         Provider  * GetProvider() const;
00102
00104         Number      GetNumber() const;
00105
00107         String      GetString() const;
00108
00110         WString     GetWString() const;
00111
00113         PhoneNumber GetPhoneNumber() const;
00114
00116         Date        GetDate() const;
00117
00119         Time        GetTime() const;
00120
00122         DateTime    GetDateTime() const;
00123
00125         BOOLEAN GetString(String & strdata) const;
00126
00128         BOOLEAN GetWString(WString & strdata) const;
00129
00131         BOOLEAN GetPhoneNumber(PhoneNumber & bcdnr) const;
00132
00134         BOOLEAN GetDate(Date & date) const;
00135
00137         BOOLEAN GetTime(Time & time) const;
00138
00140         BOOLEAN GetDateTime(DateTime & date) const;
00141
00143         GenericObject * GetGenericObject() const;
00144
00146         const GenericObject * GetGenericObjectPtr() const;
00147
00149         BOOLEAN GetBoolean() const;
00150
00152         void SetProvider(Provider * provider);
00153
00155         void SetNumber(const Number data);
00156
00158         void SetString(const String & strdata);
00159
00161         void SetString(const CHAR * strdata);
00162
00164         void SetWString(const WString & strdata);
00165
00167         void SetWString(const WCHAR * strdata);
00168
00170         void SetPhoneNumber(const PhoneNumber & bcdnr);
00171
00173         void SetDate(const Date & date);
00174
00176         void SetTime(const Time & time);
00177
00179         void SetDateTime(const DateTime & date);
00180
00182         void SetDateTime(const DateTime::Persist & date);
00183
00185         void SetGenericObject(const GenericObject * const genobject);
00186
00188         void SetBoolean(const BOOLEAN data);
00189
00191         BOOLEAN IsEqual(const DataItem & item) const;
00193         BOOLEAN IsNotEqual(const DataItem & item) const { return ! IsEqual(item); }
00195         BOOLEAN IsLess(const DataItem & item) const;
00197         BOOLEAN IsGreater(const DataItem & item) const;
00199         BOOLEAN IsLessEqual(const DataItem & item) const { return ! IsGreater(item); }
00201         BOOLEAN IsGreaterEqual(const DataItem & item) const { return ! IsLess(item); }
00203         BOOLEAN IsInRange(const DataItem & item1, const DataItem & item2) const;
00204
00206         BOOLEAN operator == (DataItem & item) const { return IsEqual(item); }
00208         BOOLEAN operator != (DataItem & item) const { return IsNotEqual(item); }
00210         BOOLEAN operator < (DataItem & item) const { return IsLess(item); }
00212         BOOLEAN operator > (DataItem & item) const { return IsGreater(item); }
00214         BOOLEAN operator <= (DataItem & item) const { return IsLessEqual(item); }
00216         BOOLEAN operator >= (DataItem & item) const { return IsGreaterEqual(item); }
00217
00219         DataItem & operator = (const DataItem & item);
00220     private:
00221         void DeleteChildObject();
00222         // union has now 64 bits, because of clear area, necessary cause of Persist structs
00223         union {
00224             void *            m_void;
00225             Number            m_number;
00226             Time::Persist     m_time;
00227             Date::Persist     m_date;
00228             DateTime::Persist m_datetime;
00229             struct {
00230                 UINT32 m_del1;
00231                 UINT32 m_del2;
00232             } m_clear;  // clear area for the 64 bits used
00233         } m_val;
00234
00235     protected:
00236         DataType m_type;
00237
00238 };
00239
00240 typedef INT (*CompareFunction)(void **, void **);
00241 typedef void * (*CreateFunction)(const void *);
00242 typedef void (*DeleteFunction)(const void *);
00243
00244
00245 BOOLEAN DataItemTestSuite();
00246
00248 #endif
00249
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSink.cpp File Reference

Auxiliary/DataSink.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DataSink.hpp"

Include dependency graph for DataSink.cpp:

Generated on Tue Jan 24 18:19:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSink.hpp File Reference

Auxiliary/DataSink.hpp File Reference

#include <Auxiliary/DrmAsset.hpp>
#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for DataSink.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataSink

Defines

#define | Auxiliary_DataSink_hpp

Typedefs

typedef NiSharedPtr< DataSink > | DataSinkPtr
Smart-pointer controlling a DataSink object.

Define Documentation

#define Auxiliary_DataSink_hpp

Generated on Tue Jan 24 18:20:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSink.hpp Source File

Auxiliary/DataSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_DataSink_hpp)
00011 #define Auxiliary_DataSink_hpp
00014
00015 #include <Auxiliary/DrmAsset.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017
00018 class DataSink;
00019
00021 typedef NiSharedPtr<DataSink> DataSinkPtr;
00022
00025 class DataSink
00026 {
00027     public:
00029         virtual ~DataSink();
00030
00037         virtual BOOLEAN Open() = 0;
00038
00044         virtual BOOLEAN Close() = 0;
00045
00050         virtual BOOLEAN IsOpen() const = 0;
00051
00060         virtual UINT32 Write(const void HUGE *buf, UINT32 nbytes) = 0;
00061
00075         virtual UINT32 Write(UINT32 offset, const void HUGE *buf,
00076             UINT32 nbytes) = 0;
00077
00085         virtual BOOLEAN GetSize(UINT32 &size) const = 0;
00086
00092         const DrmAsset& GetDrmAsset() const { return m_drm_asset; }
00093
00094     protected:
00095         DataSink(DrmLocalId id);
00096
00097         const DrmAsset m_drm_asset;
00098 };
00099
00101 #endif  // Auxiliary_DataSink_hpp
00102
00103
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSource.cpp File Reference

Auxiliary/DataSource.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DataSource.hpp"

Include dependency graph for DataSource.cpp:

Generated on Tue Jan 24 18:20:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSource.hpp File Reference

Auxiliary/DataSource.hpp File Reference

#include <Auxiliary/DrmAsset.hpp>
#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for DataSource.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataSource

Defines

#define | Auxiliary_DataSource_hpp

Typedefs

typedef NiSharedPtr< DataSource > | DataSourcePtr
Smart-pointer controlling a DataSource object.

Define Documentation

#define Auxiliary_DataSource_hpp

Generated on Tue Jan 24 18:20:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSource.hpp Source File

Auxiliary/DataSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_DataSource_hpp)
00011 #define Auxiliary_DataSource_hpp
00014
00015 #include <Auxiliary/DrmAsset.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017
00018 class DataSource;
00019
00021 typedef NiSharedPtr<DataSource> DataSourcePtr;
00022
00025 class DataSource
00026 {
00027     public:
00029         virtual ~DataSource();
00030
00039         virtual BOOLEAN Open() = 0;
00040
00046         virtual BOOLEAN Close() = 0;
00047
00052         virtual BOOLEAN IsOpen() const = 0;
00053
00065         virtual BOOLEAN Read(void HUGE *buffer, UINT32 count) = 0;
00066
00115         virtual BOOLEAN Read(void HUGE *buffer, UINT32 max_count,
00116             UINT32 &bytes_read) = 0;
00117
00131         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 count)
00132             = 0;
00133
00188         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer,
00189             UINT32 max_count, UINT32 &bytes_read) = 0;
00190
00196         virtual BOOLEAN GetSize(UINT32 &size) const = 0;
00197
00203         const DrmAsset& GetDrmAsset() const { return m_drm_asset; }
00204
00205     protected:
00206         DataSource(DrmLocalId id);
00207
00208         const DrmAsset m_drm_asset;
00209 };
00210
00212 #endif  // Auxiliary_DataSource_hpp
00213
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSourceBinData.cpp File Reference

Auxiliary/DataSourceBinData.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DataSourceBinData.hpp"
#include "DataSource.hpp"

Include dependency graph for DataSourceBinData.cpp:

Generated on Tue Jan 24 18:20:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSourceBinData.hpp File Reference

Auxiliary/DataSourceBinData.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for DataSourceBinData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataSourceBinData

Defines

#define | Auxiliary_DataSourceBinData_hpp

Typedefs

typedef NiSharedPtr< DataSource > | DataSourcePtr
Smart-pointer controlling a DataSource object.

Define Documentation

#define Auxiliary_DataSourceBinData_hpp

Typedef Documentation

typedef NiSharedPtr<DataSource> DataSourcePtr

Smart-pointer controlling a DataSource object.

Generated on Tue Jan 24 18:20:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DataSourceBinData.hpp Source File

Auxiliary/DataSourceBinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_DataSourceBinData_hpp)
00011 #define Auxiliary_DataSourceBinData_hpp
00012
00013 #include <Auxiliary/BinData.hpp>
00014 #include <Auxiliary/NiSharedPtr.hpp>
00015
00016 class DataSource;
00017
00019 typedef NiSharedPtr<DataSource> DataSourcePtr;
00020
00024 class DataSourceBinData : public BinData
00025 {
00026     typedef BinData Base;
00027
00028     public:
00037         static DataSourceBinData* CreateInstance(
00038             const DataSourcePtr &data_source);
00039
00040         virtual BOOLEAN Read(UINT32 idx, UINT8 &val) const;
00041         virtual UINT32 Read(UINT32 idx, void *buf, UINT32 nbytes) const;
00042         virtual UINT32 GetLength() const;
00043         virtual MemMap* ObtainMemMap(UINT32 idx, UINT32 size) const;
00044         virtual void ReleaseMemMap(MemMap **h_map) const;
00045
00046     protected:
00047         DataSourceBinData(const DataSourcePtr &data_source);
00048         virtual ~DataSourceBinData();
00049
00050         // The data source that is read from.
00051         DataSourcePtr m_data_source;
00052 };
00053
00054 #endif  // Auxiliary_DataSourceBinData_hpp
00055
00056
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Date.cpp File Reference

Auxiliary/Date.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Date.hpp"
#include <Kernel/System.hpp>
#include <Devices/Device.hpp>
#include <Gui/Locale.hpp>

Include dependency graph for Date.cpp:

Generated on Tue Jan 24 18:20:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Date.hpp File Reference

Auxiliary/Date.hpp File Reference

#include <Auxiliary/WString.hpp>

Include dependency graph for Date.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Date
Date is used to represent a single date. More...
struct | Date::Persist

Defines

#define | Apoxi_Date_h

Typedefs

typedef Date::Format | DateFormat
DateFormat type is identical to the Format type inside the time class.

Define Documentation

#define Apoxi_Date_h

Generated on Tue Jan 24 18:29:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Date.hpp Source File

Auxiliary/Date.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Date_h)
00011 #define Apoxi_Date_h
00014
00015 #include <Auxiliary/WString.hpp>
00016
00018 class Date {
00019     public:
00021         enum Format {
00023             ShortDateDM,
00025             ShortDateWDM,
00027             ShortDateDMY,
00029             ShortDateWDMY,
00031             LongDateDM,
00033             LongDateWDM,
00035             LongDateDMY,
00037             LongDateWDMY,
00038         };
00039
00041         enum Day {
00043             Monday = 0,
00045             Tuesday = 1,
00047             Wednesday = 2,
00049             Thursday = 3,
00051             Friday = 4,
00053             Saturday = 5,
00055             Sunday = 6
00056         };
00057
00059         enum Month {
00061             January = 1,
00063             February = 2,
00065             March = 3,
00067             April = 4,
00069             May = 5,
00071             June = 6,
00073             July = 7,
00075             August = 8,
00077             September = 9,
00079             October = 10,
00081             November = 11,
00083             December = 12
00084         };
00085
00087         enum PresetDate {
00089             Today,
00091             Tomorrow,
00093             TheDayAfterTomorrow,
00095             Yesterday,
00097             TheDayBeforeYesterday
00098         };
00099
00100         // struct must not be larger then 32 bit because of DataItem usage
00101         struct Persist {
00102             UINT8  m_day;
00103             UINT8  m_month;
00104             UINT16 m_year;
00105         };
00106
00108         Date();
00110         Date(PresetDate pd);
00112         Date(INT day,INT month,INT year);
00113
00115         Date(const Persist & dstruct);
00116
00118         BOOLEAN IsZero() const;
00119
00121         BOOLEAN IsValid(const BOOLEAN accept_zeroed_date = TRUE) const;
00122
00124         INT GetDay() const { return m_day; }
00126         INT GetMonth() const { return m_month; }
00128         INT GetYear() const { return m_year; }              // YYYY Format
00130         INT GetYearYY() const;                              // YY Format
00132         INT GetYearYYYY() const { return m_year; }          // YYYY Format
00133
00135         void SetDay(INT day) { m_day = day; }
00137         void SetMonth(INT month) { m_month = month; }
00139         void SetYear(INT year) { m_year = year; }           // YYYY Format
00140
00142         const WCHAR* MonthName() const { return MonthName(m_month); }
00144         const WCHAR* ShortMonthName() const { return ShortMonthName(m_month); }
00146         const WCHAR* DayName() const { return DayName(DayOfWeek()); }
00148         const WCHAR* ShortDayName() const { return ShortDayName(DayOfWeek()); }
00149
00151         WString GetWString(Format date_format) const;
00153         WString GetWString(const WCHAR *format) const;
00154
00156         BOOLEAN IsLeapYear() const { return IsLeapYear(m_year); }
00157
00159         INT DayOfYear() const;
00161         INT WeekOfYear() const;
00163         Day DayOfWeek() const;
00164
00166         INT DaysInMonth() const;
00167
00169         INT DaysInYear() const  { return DaysInYear(m_year); }
00170
00172         void AddDays(INT ndays);
00173
00175         BOOLEAN operator==(const Date &date) const;
00176
00178         BOOLEAN operator!=(const Date &date) const;
00179
00181         BOOLEAN operator<(const Date &date) const;
00182
00184         BOOLEAN operator<=(const Date &date) const;
00185
00187         BOOLEAN operator>(const Date &date) const;
00188
00190         BOOLEAN operator>=(const Date &date) const;
00191
00192         static INT Compare(const Date::Persist & t1, const Date::Persist & t2);
00193
00195         void operator<<(const Date::Persist & date);
00197         void operator>>(Date::Persist & date) const;
00198
00199         static const WCHAR* MonthName(INT month);
00200         static const WCHAR* ShortMonthName(INT month);
00201         static const WCHAR* DayName(Day day);
00202         static const WCHAR* ShortDayName(Day day);
00203         static INT Compare(const Date &d1,const Date &d2);
00204         static BOOLEAN IsLeapYear(UINT16 year);
00205         static UINT16 DaysInYear(UINT16 year);
00206
00207     protected:
00208         UINT8 m_day;
00209         UINT8 m_month;
00210         UINT16 m_year;
00211
00212         static const UINT8 days_in_month[12];
00213         static const WCHAR *day_name[7];
00214         static const WCHAR *short_day_name[7];
00215         static const WCHAR *month_name[13];
00216         static const WCHAR *short_month_name[13];
00217
00218     private:
00219         template <class T>
00220         T AdjustRange(T value, T range) {
00221             if (value < 0)
00222                 value = 0;
00223             else if (value > range)
00224                 value = range;
00225
00226             return value;
00227         }
00228 };
00229
00231 typedef Date::Format DateFormat;
00232
00234 #endif  // Apoxi_Date_h
00235
00236
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DateTime.cpp File Reference

Auxiliary/DateTime.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DateTime.hpp"
#include <Devices/RealTimeClock.hpp>
#include <Gui/LanguageManager.hpp>
#include <stdlib.h>

Include dependency graph for DateTime.cpp:

Generated on Tue Jan 24 18:29:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DateTime.hpp File Reference

Auxiliary/DateTime.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>
#include <Auxiliary/TimeSpan.hpp>
#include <Auxiliary/TimeZone.hpp>

Include dependency graph for DateTime.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DateTime
struct | DateTime::Persist
struct | DateTime::tm

Defines

#define | Apoxi_DateTime_h

Define Documentation

#define Apoxi_DateTime_h

Generated on Tue Jan 24 18:31:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DateTime.hpp Source File

Auxiliary/DateTime.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_DateTime_h)
00011 #define Apoxi_DateTime_h
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Auxiliary/Date.hpp>
00017 #include <Auxiliary/Time.hpp>
00018 #include <Auxiliary/TimeSpan.hpp>
00019 #include <Auxiliary/TimeZone.hpp>
00020
00021 /*  ------------------------------------------------------------------------
00022                                 Types
00023     ------------------------------------------------------------------------ */
00027 class DateTime : public Date
00028 {
00029     public:
00030         typedef Date Base;
00031
00032         enum {
00034             RelativeBaseYear = 1970
00035         };
00036
00037         enum Alignment{
00038             Zero,             //DateTime is not related to any TimeZone
00039             UniversalTime,    //DateTime is related to UT, equal to GMT(00:00) DST: 0 (Std.Time)
00040             LocalTime         //DateTime is related to LocalTime, except temporary TimeZone is set valid
00041         };//Alignment
00042
00043         // struct must not be larger then 32 bit because of DataItem usage
00044         struct Persist {
00045             struct {
00046                 UINT16 m_month  : 4;
00047                 UINT16 m_minute : 6;
00048                 UINT16 m_second : 6;
00049             } m_data1;
00050             struct {
00051                 UINT16 m_day    : 5;
00052                 UINT16 m_hour   : 5;
00053             } m_data2;
00054             struct {
00055                 UINT16 m_year;
00056             } m_data3;
00057
00058             void Reset() {
00059                 m_data1.m_month  = 0;
00060                 m_data1.m_minute = 0;
00061                 m_data1.m_second = 0;
00062                 m_data2.m_day    = 0;
00063                 m_data2.m_hour   = 0;
00064                 m_data3.m_year   = 0;
00065             }
00066             BOOLEAN IsZero() const {
00067                 return m_data1.m_month==0 || m_data2.m_day==0 || m_data3.m_year==0;
00068             }
00069             BOOLEAN IsLater(const Persist & datetime) const {
00070                 if(m_data3.m_year>datetime.m_data3.m_year) return TRUE;
00071                 if(m_data1.m_month>datetime.m_data1.m_month) return TRUE;
00072                 if(m_data2.m_day>datetime.m_data2.m_day) return TRUE;
00073                 if(m_data2.m_hour>datetime.m_data2.m_hour) return TRUE;
00074                 if(m_data1.m_minute>datetime.m_data1.m_minute) return TRUE;
00075                 if(m_data1.m_second>datetime.m_data1.m_second) return TRUE;
00076                 return FALSE;
00077             }
00078         };
00079
00081         DateTime(Alignment alignment);
00082
00084         DateTime(PresetDate pd = Today);
00085
00087         DateTime(const DateTime& date_time);
00088
00090         DateTime(INT day,INT month,INT year);
00091
00094         DateTime(INT day, INT month, INT year,
00095                  INT hour, INT minute, INT second = 0, INT millisecond = 0,
00096                  Alignment alignment= Zero);
00097
00099         DateTime(const Persist & dstruct);
00100
00103         DateTime(INT day,INT month,INT year, const Time &timeval, Alignment alignment= Zero);
00104
00107         DateTime(UINT32 absoluteseconds, Alignment alignment= Zero);
00108
00110         UINT32 GetAbsoluteDay() const;
00112         UINT32 GetAbsoluteSeconds() const;
00113
00114     #if !defined(APOXI_RTOS_OSE166)
00115
00116         UINT64 GetAbsoluteMilliseconds() const;
00117     #endif
00118
00120         void AddTimeSpan(const TimeSpan & timespan);
00122         void SubTimeSpan(const TimeSpan & timespan);
00123
00125         void SetDate(const Date & dateval);
00127         void SetTime(const Time & timeval) {
00128             m_time = timeval;
00129         }
00131         void SetDateTime(const Date & dateval, const Time & timeval);
00132
00134         const Time& GetTime() const {
00135             return m_time;
00136         }
00137
00139         Time GetTime() {
00140             return m_time;
00141         }
00142
00144         Date GetDate() const;
00145
00147         void SetHour(INT hour) {
00148             m_time.SetHour(hour);
00149         }
00151         INT  GetHour() const {
00152             return m_time.GetHour();
00153         }
00155         void SetMinute(INT minute) {
00156             m_time.SetMinute(minute);
00157         }
00159         INT  GetMinute() const {
00160             return m_time.GetMinute();
00161         }
00163         void SetSecond(INT second)  {
00164             m_time.SetSecond(second);
00165         }
00167         INT  GetSecond() const {
00168             return m_time.GetSecond();
00169         }
00171         void SetMillisecond(INT millisecond)  {
00172             m_time.SetMillisecond(millisecond);
00173         }
00175         INT  GetMillisecond() const {
00176             return m_time.GetMillisecond();
00177         }
00178
00180         Alignment GetAlignment() const { return m_alignment; }
00181
00183         BOOLEAN operator==(const DateTime &datetime) const;
00184
00186         BOOLEAN operator!=(const DateTime &datetime) const;
00187
00189         BOOLEAN operator<(const DateTime &datetime) const;
00190
00192         BOOLEAN operator<=(const DateTime &datetime) const;
00193
00195         BOOLEAN operator>(const DateTime &datetime) const;
00196
00198         BOOLEAN operator>=(const DateTime &datetime) const;
00199
00201         DateTime & operator += (const TimeSpan & timespan);
00202
00204         DateTime operator + (const TimeSpan & timespan) const;
00205
00207         DateTime & operator -= (const TimeSpan & timespan);
00208
00210         DateTime operator - (const TimeSpan & timespan) const;
00211
00213         TimeSpan GetInterval(const DateTime & datetime);
00214
00217         WString Format(const WCHAR *format) const;
00218
00220         void operator<<(const DateTime::Persist & time);
00222         void operator>>(DateTime::Persist & time) const;
00223
00225         static INT Compare(const DateTime &d1,const DateTime &d2);
00226
00228         static INT Compare(const DateTime::Persist & d1, const DateTime::Persist & d2);
00229
00232         static void SetLocalTimeZone(const TimeZone& tz) { m_local_tz= tz; }
00233
00235         static const TimeZone& GetLocalTimeZone() { return m_local_tz; }
00236
00239         static void SetTemporaryLocalTimeZone(const TimeZone& tz) { m_temp_tz= tz; }
00240
00243         static const TimeZone& GetTemporaryLocalTimeZone() { return m_temp_tz; }
00244
00247         static const TimeZone& GetCurrentLocalTimeZone() { return m_temp_tz.IsOffsetInvalid() ? m_local_tz : m_temp_tz; }
00248
00249     private:
00251         Time m_time;
00252
00254         Alignment m_alignment;
00255
00258         static TimeZone m_local_tz; //persistent
00259
00262         static TimeZone m_temp_tz;  //transient
00263
00264
00265         // ANSI C
00266         struct tm {
00267             INT tm_sec;     /* seconds after the minute - [0,59] */
00268             INT tm_min;     /* minutes after the hour - [0,59] */
00269             INT tm_hour;    /* hours since midnight - [0,23] */
00270             INT tm_mday;    /* day of the month - [1,31] */
00271             INT tm_mon;     /* months since January - [0,11] */
00272             INT tm_year;    /* years since 1900 */
00273             INT tm_wday;    /* days since Sunday - [0,6] */
00274             INT tm_yday;    /* days since January 1 - [0,365] */
00275         };//struct tm
00276
00278         BOOLEAN ShiftRelativeToLocalTimeZone(const TimeZone &tz);
00280         INT WStrFTime(WCHAR *s, INT maxsize, const WCHAR *format, const struct tm *t) const;
00282         WCHAR* WStrNum(WCHAR *s, INT value, INT length) const;
00283
00284 };//class DateTime
00285
00287 #endif
00288
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DbgDump.cpp File Reference

Auxiliary/DbgDump.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DbgDump.hpp"
#include <stdio.h>

Include dependency graph for DbgDump.cpp:

Generated on Tue Jan 24 18:31:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DbgDump.hpp File Reference

Auxiliary/DbgDump.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for DbgDump.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DbgDump

Defines

#define | Auxiliary_DbgDataDump_hpp
#define | DBG_DUMP(params)

Define Documentation

#define Auxiliary_DbgDataDump_hpp

#define DBG_DUMP ( params )

Generated on Tue Jan 24 18:32:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DbgDump.hpp Source File

Auxiliary/DbgDump.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Auxiliary_DbgDataDump_hpp)
00010 #define Auxiliary_DbgDataDump_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Auxiliary/Macros.hpp>
00014 #include <Auxiliary/WString.hpp>
00015
00016
00018
00019 class DbgDump
00020 {
00021     public:
00022         static WString CreateHexCodes(const UINT8 * buffer, INT len);
00023
00024 #ifdef _DEBUG
00025         static void DbgOutHexAndAscii(INT code, const UINT8 * buffer, INT len);
00026 #endif
00027
00028 };
00029
00030
00031 #ifdef _DEBUG
00032     #define DBG_DUMP(params)    DbgDump::DbgOutHexAndAscii params
00033 #else
00034     #define DBG_DUMP(params)
00035 #endif
00036
00037
00038 #endif // EOF
00039
00040
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DistinctProvider.cpp File Reference

Auxiliary/DistinctProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DistinctProvider.hpp"

Include dependency graph for DistinctProvider.cpp:

Generated on Tue Jan 24 18:32:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DistinctProvider.hpp File Reference

Auxiliary/DistinctProvider.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/FilterProvider.hpp>
#include <Auxiliary/FilterRule.hpp>
#include <Auxiliary/QuickSortProvider.hpp>

Include dependency graph for DistinctProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DistinctProvider
class | DistinctRule

Defines

#define | Mmi_DistinctProvider_hpp

Define Documentation

#define Mmi_DistinctProvider_hpp

Generated on Tue Jan 24 18:32:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DistinctProvider.hpp Source File

Auxiliary/DistinctProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_DistinctProvider_hpp)
00015 #define Mmi_DistinctProvider_hpp
00016
00017 #include <Kernel/Types.hpp>
00018 #include <Auxiliary/DataItem.hpp>
00019 #include <Auxiliary/FilterProvider.hpp>
00020 #include <Auxiliary/FilterRule.hpp>
00021 #include <Auxiliary/QuickSortProvider.hpp>
00022
00023 class Provider;
00024 class ProviderListener;
00025
00026 class DistinctRule : public NotEqualsRule
00027 {
00028     public:
00029         typedef NotEqualsRule Base;
00030
00031         DistinctRule();
00032         DistinctRule(const DataItem & ruleitem);
00033
00034         virtual ~DistinctRule();
00035
00036         virtual BOOLEAN ExecuteRule(const DataItem & dataitem);
00037
00038 };
00039
00043 class DistinctProvider : public FilterProvider
00044 {
00045     public:
00046         typedef FilterProvider Base;
00047
00050         DistinctProvider();
00051
00055         DistinctProvider(Provider * provider, INT columnid = 0);
00056
00057         virtual ~DistinctProvider();
00058
00060         void Init(Provider * provider, INT columnid = 0);
00061
00063         virtual void SetFilterColumn(INT filtercolumn);
00064
00065         virtual BOOLEAN GetDataItem(INT column,
00066                                     INT row,
00067                                     DataItem & item);
00068
00070         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00071
00073         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00074
00077         virtual BOOLEAN CommitRow(INT row);
00078
00080         virtual BOOLEAN DeleteRow(INT row);
00081
00083         virtual BOOLEAN Update(ProviderListener * listener = 0);
00084
00085     protected:
00087         virtual BOOLEAN GetMappedRow(INT & mapped_row, INT row);
00088
00089     private:
00090         QuickSortProvider   m_sort_prov;
00091         DistinctRule        m_distinct_rule;
00092         INT                 m_distinct_column;
00093         DataItem            m_new_dist_item;
00094
00095 };
00096
00097
00098
00099 #endif
00100
00101
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DrmAsset.cpp File Reference

Auxiliary/DrmAsset.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Date.hpp"
#include "TimeSpan.hpp"
#include "DrmAsset.hpp"

Include dependency graph for DrmAsset.cpp:

Generated on Tue Jan 24 18:32:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DrmAsset.hpp File Reference

Auxiliary/DrmAsset.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/DrmCore.hpp>

Include dependency graph for DrmAsset.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmAsset

Defines

#define | Apoxi_Drm_Asset_hpp

Define Documentation

#define Apoxi_Drm_Asset_hpp

Generated on Tue Jan 24 18:32:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DrmAsset.hpp Source File

Auxiliary/DrmAsset.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_Drm_Asset_hpp)
00009 #define Apoxi_Drm_Asset_hpp
00010
00013
00014 class DrmRightsObjectContainer;
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Auxiliary/Vector.hpp>
00018 #include <Auxiliary/DateTime.hpp>
00019
00020 #include <Auxiliary/String.hpp>
00021 #include <Auxiliary/DrmCore.hpp>
00022
00025 class DrmAsset {
00026     public:
00028         DrmAsset(DrmLocalId id = c_drm_invalid_local_id);
00029
00032         void SetLocalDrmId(DrmLocalId id);
00033
00036         DrmLocalId GetDrmLocalId() const;
00037
00041         DrmStatus ValidateAsset(DrmOperation op) const;
00042
00052         BOOLEAN OnContentConsumedStart(DrmOperation op) const;
00053
00063         BOOLEAN OnContentConsumedEnd(DrmOperation op) const;
00064
00070         BOOLEAN OnRollback(DrmOperation op) const;
00071
00081         DrmStatus GetCount(DrmOperation op,INT32& cnt) const;
00082 #if defined(APOXI_COMPAT_2_6_0)
00083         INT32 GetCount(DrmOperation op) const;
00084 #endif
00085
00093         DrmStatus GetStartDate(DrmOperation op, Date& start_date) const;
00094
00102         DrmStatus GetEndDate(DrmOperation op, Date& end_date) const;
00103
00111         DrmStatus GetValidityPeriod(DrmOperation op, TimeSpan& validity_period) const;
00112
00122         DrmStatus IncrementRefCount();
00123
00124
00127         DrmStatus DeleteDrmRights() const;
00128
00132         DrmUid GetUid(DrmStatus &status) const;
00133
00134     protected:
00138         DrmStatus CreateContainer(DrmOperation op, DrmRightsObjectContainer &ro_holder) const;
00139
00140     private:
00141         DrmLocalId m_id;
00142
00143 };
00144
00146
00147 #endif  // Apoxi_Drm_Asset_hpp
00148
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DrmCore.hpp File Reference

Auxiliary/DrmCore.hpp File Reference

#include <limits.h>
#include <Auxiliary/MimeTypeTable.hpp>
#include <Config/DrmConfig.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for DrmCore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | DRM_KEY_SIZE 16
128 bit key for AES
#define | DRM_RO_DEBUG
#define | DrmCore_hpp
#define | MAX_COUNT INT_MAX
#define | MAX_DATE UINT_MAX
#define | MAX_INTERVAL UINT_MAX
#define | MIN_DATE 0

Typedefs

typedef UINT8 | DrmKey [DRM_KEY_SIZE]
typedef INT16 | DrmLocalId
Device local id of rights object. Avoids memory intensive handling of DrmUid.
typedef String | DrmUid
UID according to OMA DRM.

Enumerations

enum DrmConstraintDefValues {
DrmAllDefault = 0, DrmDatetimeDefault, DrmStartDefault, DrmEndDefault,
DrmNoDefault
}
Used to store kind of constraints for a permission. This enumeration is used internally in DRM. More...
enum DrmMimeType {
DrmNone = 0, DrmForwardLock = 1, DrmCombinedDelivery = 2, DrmDcf = 3,
DrmRoXml = 4, DrmRoWbxml = 5, DrmForwardLockDcf = 6
}
Drm Mime Types. More...
enum DrmOperation {
DrmOpPlay = 0, DrmOpDisplay = 1, DrmOpExecute = 2, DrmOpPrint = 3,
DrmOpRewind = 4, DrmOpCount
}
enum DrmStatus {
DrmSuccess = 0, DrmDefaultConstraints, DrmInvalidOperation = -101, DrmInvalidLocalId,
DrmInvalidAsset, DrmCorruptMessage, DrmInvalidXmlFormat, DrmInvalidContainer,
DrmAesDecryptionFail, DrmNoRightsAvailable, DrmInvalidParams, DrmUnknown
}
Status of the Drm operation. More...

Variables

const DrmLocalId | c_drm_invalid_local_id = 0
c_drm_invalid_local_id denotes a illegal local ID of an asset.
const DrmLocalId | DefaultLocalId = APOXI_DRM_RIGHTS_OBJECT_MAX + 1
Default Local Id for Forward Lock.

Define Documentation

#define DrmCore_hpp

Generated on Tue Jan 24 18:32:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DrmCore.hpp Source File

Auxiliary/DrmCore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(DrmCore_hpp)
00009 #define DrmCore_hpp
00010
00013
00014 #include <limits.h>
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016 #include <Config/DrmConfig.hpp>
00017
00018 #include <Auxiliary/String.hpp>
00019
00021 #define DRM_KEY_SIZE 16
00022 typedef UINT8 DrmKey[DRM_KEY_SIZE];
00023
00025 typedef String DrmUid;
00026
00028 typedef INT16 DrmLocalId;
00029
00031 const DrmLocalId DefaultLocalId = APOXI_DRM_RIGHTS_OBJECT_MAX + 1 ;
00032
00034 const DrmLocalId c_drm_invalid_local_id = 0;
00035
00036 #define MAX_COUNT    INT_MAX    // Some defines for REL Parser and DrmAsset
00037 #define MIN_DATE     0
00038 #define MAX_DATE     UINT_MAX
00039 #define MAX_INTERVAL UINT_MAX
00040
00041 #define DRM_RO_DEBUG
00042
00044 enum DrmStatus {
00045     DrmSuccess = 0,
00046     DrmDefaultConstraints,  // to indicate that constraint is not found in XML rights.
00047     DrmInvalidOperation = -101 ,
00048     DrmInvalidLocalId,
00049     DrmInvalidAsset,
00050     DrmCorruptMessage,
00051     DrmInvalidXmlFormat,
00052     DrmInvalidContainer,
00053     DrmAesDecryptionFail,
00054     DrmNoRightsAvailable,
00055     DrmInvalidParams,
00056     DrmUnknown
00057 };
00058
00060 enum DrmMimeType {
00062     DrmNone = 0,
00064     DrmForwardLock = 1,
00066     DrmCombinedDelivery = 2,
00068     DrmDcf = 3,
00070     DrmRoXml = 4,
00072     DrmRoWbxml = 5,
00074     DrmForwardLockDcf = 6,
00075 #ifdef APOXI_INCLUDE_DRM_V2
00076     DrmDcfv2 = 7,
00077     // DRM2.0 DCF
00078     DrmForwardLockDcfv2 = 8,
00079     // DRM2.0 Forward Locked DCF
00080     DrmPdcf = 9,
00081     // DRM2.0 PDCF
00082     DrmRov2Xml = 10,
00083     // DRM2.0 Rights Object XML
00084     DrmForwardLockBinary = 11,
00085     // DRM1.0 Forward Lock (Binary format)
00086     DrmCombinedDeliveryBinary = 12,
00087     // DRM1.0 Combined Delivery (Binary format)
00088     DrmDcfBinary = 13,
00089     // DRM1.0 DCF (Binary format)
00090     DrmForwardLockDcfBinary = 14,
00091     // DRM1.0 Forward Locked DCF (Binary format)
00092     DrmForwardLockDcfObject = 15,
00093     // DRM1.0 intermediate data from FL DCF
00094     DrmDcfv2Binary = 16,
00095     // DRM2.0 DCF (Binary format)
00096     DrmForwardLockDcfv2Binary = 17,
00097     // DRM2.0 Forward Locked DCF (Binary format)
00098     DrmForwardLockDcfv2Object = 18,
00099     // DRM2.0 intermediate data from FL DCFv2
00100     DrmPdcfBinary = 19,
00101     // DRM2.0 PDCF (Binary format)
00102     DrmOtherForwardLock = 20,
00103     // other Forward-Lock content e.g. SMAF
00104  #endif
00105 };
00106
00108 enum DrmConstraintDefValues {
00110     DrmAllDefault = 0,
00112     DrmDatetimeDefault,
00114     DrmStartDefault,
00116     DrmEndDefault,
00117     // to indicate atleast one or all constraints present in rights XML
00118     DrmNoDefault // must be last
00119 };
00120
00126 enum DrmOperation {
00128     DrmOpPlay = 0,
00130     DrmOpDisplay = 1,
00132     DrmOpExecute = 2,
00134     DrmOpPrint = 3,
00136     DrmOpRewind = 4,
00137
00138     DrmOpCount  // must be last
00139 };
00140
00141 #ifdef APOXI_INCLUDE_DRM_V2
00142
00143 enum DrmDcfMessageType {
00144     DrmDcfIcon,
00145     DrmDcfPreview,
00146     DrmDcfContent,
00147 };
00148
00150 enum DrmEncMethod   {
00151     DrmAES128CBC = 0,
00152     DrmAES128CTR = 1,
00153     DrmEncNull              // must be last
00154 };
00155
00157 enum DrmPaddingScheme {
00158     DrmRfc2630 = 0,
00159     DrmNoPadding        // must be last
00160 };
00161 #endif
00162
00164
00165 #endif // DrmCore_hpp
00166
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DrmInfo.cpp File Reference

Auxiliary/DrmInfo.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DrmInfo.hpp"
#include "Macros.hpp"

Include dependency graph for DrmInfo.cpp:

Generated on Tue Jan 24 18:32:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DrmInfo.hpp File Reference

Auxiliary/DrmInfo.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Types.hpp>

Include dependency graph for DrmInfo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrmInfo
struct | DrmInfoPersistStructure

Defines

#define | Apoxi_DrmInfo_hpp

Define Documentation

#define Apoxi_DrmInfo_hpp

Generated on Tue Jan 24 18:32:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DrmInfo.hpp Source File

Auxiliary/DrmInfo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2003 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DrmInfo_hpp)
00010 #define Apoxi_DrmInfo_hpp
00011
00014
00015 #include <Auxiliary/NonCloneable.hpp>
00016 #include <Kernel/Types.hpp>
00017
00061 struct DrmInfoPersistStructure {
00062     UINT16 m_permissions;
00063 };
00064
00065 class DrmInfo : public NonCloneable {
00066
00067     public:
00068
00074         enum Operation {
00075             c_none =    0,
00076             c_play =    1,
00077             c_display = 2,
00078             c_execute = 4,
00079             c_print =   8,
00080             c_forward = 16,
00081
00082             c_no_lock = 32,
00083             c_forward_lock = 64,
00084             c_combined_delivery = 128,
00085             c_separate_delivery = 256
00086         };
00087
00088
00089         DrmInfo();
00090         virtual ~DrmInfo();
00091
00098         void Init(UINT16 drm_method);
00099
00105         void ReadFrom(const DrmInfoPersistStructure &persist_structure);
00110         void WriteTo(DrmInfoPersistStructure *persist_structure) const;
00111
00112
00115         BOOLEAN IsForwardLocked();
00116
00119         BOOLEAN IsCombinedDelivered();
00120
00123         BOOLEAN IsSeparateDelivered();
00124
00125
00130         BOOLEAN IsPlayable();
00131
00136         BOOLEAN IsDisplayable();
00137
00142         BOOLEAN IsExecutable();
00143
00148         BOOLEAN IsPrintable();
00149
00154         BOOLEAN IsForwardable();
00155
00156     private:
00157         UINT16 m_permissions;
00158 };
00159
00161
00162 #endif //Apoxi_DrmInfo_hpp
00163
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DynamicBitVector.hpp File Reference

Auxiliary/DynamicBitVector.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <string.h>

Include dependency graph for DynamicBitVector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DynamicBitVector

Defines

#define | Apoxi_DynamicBitVector_hpp

Define Documentation

#define Apoxi_DynamicBitVector_hpp

Generated on Tue Jan 24 18:33:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/DynamicBitVector.hpp Source File

Auxiliary/DynamicBitVector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DynamicBitVector_hpp)
00010 #define Apoxi_DynamicBitVector_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Auxiliary/Macros.hpp>
00014 #include <string.h> // for memset()
00015
00018 class DynamicBitVector
00019 {
00020     private:
00021         enum {
00022             BITS_PER_UINT = sizeof(UINT) * 8,
00023         };
00024
00025     public:
00027         inline DynamicBitVector() : m_bits(0),
00028                                     m_nrofbits(0)
00029         {
00030         }
00031
00033         inline DynamicBitVector(INT nrofbits) : m_bits(0),
00034                                                 m_nrofbits(0)
00035         {
00036             UINT noofuints = BitsToAtoms(nrofbits);
00037
00038             if ( (m_bits = Allocate(noofuints)) != 0 ) {
00039                 memset( (UINT8*) &m_bits[0], 0, noofuints * sizeof(UINT) );
00040                 m_nrofbits = nrofbits;
00041             }
00042         }
00043
00045         inline DynamicBitVector(const DynamicBitVector &  from) : m_bits(0),
00046                                                                   m_nrofbits(0)
00047         {
00048             Copy(from);
00049         }
00050
00052         inline ~DynamicBitVector()
00053         {
00054             Free();
00055         }
00056
00058         inline DynamicBitVector &   operator=(const DynamicBitVector &  from)
00059         {
00060             if ( &from != this ) {
00061
00062                 Free();
00063                 Copy(from);
00064             }
00065             return  *this;
00066         }
00067
00069         inline UINT     GetLength() const
00070         {
00071             return  m_nrofbits;
00072         }
00073
00075         inline BOOLEAN  GetBit(INT idx) const
00076         {
00077             return ( (Atom(idx) & BitMask(idx)) != 0 );
00078         }
00079
00081         inline void     SetBit(INT idx,BOOLEAN set = TRUE)
00082         {
00083             if (set)
00084                 Atom(idx) |= BitMask(idx);
00085             else
00086                 Atom(idx) &= ~BitMask(idx);
00087         }
00088
00090         inline BOOLEAN  Intersects(const DynamicBitVector &  rhs) const
00091         {
00092             UINT    lhs_atoms = BitsToAtoms(m_nrofbits);
00093             UINT    rhs_atoms = BitsToAtoms(rhs.m_nrofbits);
00094             UINT    int_atoms = Minimum(lhs_atoms, rhs_atoms);
00095
00096             for ( UINT  i = 0; i < int_atoms; i++ ) {
00097                 if ( (m_bits[i] & rhs.m_bits[i]) != 0 ) {
00098                     return TRUE;
00099                 }
00100             }
00101             return FALSE;
00102         }
00103
00104     private:
00105         inline UINT &   Atom(INT bitidx)
00106         {
00107             ASSERT_DEBUG(bitidx >= 0 && bitidx < m_nrofbits);
00108             return(m_bits[bitidx / BITS_PER_UINT]);
00109         }
00110
00111         inline UINT     Atom(INT bitidx) const
00112         {
00113             ASSERT_DEBUG(bitidx >= 0 && bitidx < m_nrofbits);
00114             return(m_bits[bitidx / BITS_PER_UINT]);
00115         }
00116
00117         inline UINT     BitMask(INT bitidx) const {
00118             ASSERT_DEBUG(bitidx >= 0 && bitidx < m_nrofbits);
00119             return(1U << (bitidx % BITS_PER_UINT));
00120         }
00121
00122         inline UINT     BitsToAtoms(UINT    nrofbits) const
00123         {
00124             return ( (nrofbits + BITS_PER_UINT - 1) / BITS_PER_UINT );
00125         }
00126
00127         inline void     Copy(const DynamicBitVector &   from)
00128         {
00129             UINT    noofuints = BitsToAtoms(from.m_nrofbits);
00130
00131             ASSERT_DEBUG( m_bits == 0 );
00132             ASSERT_DEBUG( m_nrofbits == 0 );
00133
00134             if ( (m_bits = Allocate(noofuints)) != 0 ) {
00135                 memcpy( (UINT8*) m_bits, (UINT8*) from.m_bits, noofuints * sizeof(UINT) );
00136                 m_nrofbits = from.m_nrofbits;
00137             }
00138         }
00139
00140         inline UINT *   Allocate(UINT   noofuints)
00141         {
00142             return ( noofuints != 0 )
00143                    ? new UINT[noofuints]
00144                    : 0;
00145         }
00146
00147         inline void Free()
00148         {
00149             delete [] m_bits;
00150
00151             m_bits     = 0;
00152             m_nrofbits = 0;
00153         }
00154
00155         UINT * m_bits;
00156         INT    m_nrofbits;
00157 };
00158
00159 #endif  // Apoxi_DynamicBitVector_hpp
00160
Generated on Tue Jan 24 14:47:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ElementList.cpp File Reference

Auxiliary/ElementList.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ElementList.hpp"
#include "Linkable.hpp"

Include dependency graph for ElementList.cpp:

Generated on Tue Jan 24 18:33:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ElementList.hpp File Reference

Auxiliary/ElementList.hpp File Reference

#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for ElementList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ElementList< T >
class | ElementListBase
class | SortedElementList< T >

Defines

#define | Auxiliary_ElementList_hpp

Define Documentation

#define Auxiliary_ElementList_hpp

Generated on Tue Jan 24 18:33:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ElementList.hpp Source File

Auxiliary/ElementList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Auxiliary_ElementList_hpp)
00010 #define Auxiliary_ElementList_hpp
00013
00014 #include <Auxiliary/LinkedList.hpp>
00015 #include <Auxiliary/Macros.hpp>
00016
00018 class ElementListBase : private LinkedListBase {
00019     typedef LinkedListBase Base;
00020
00021     public:
00023         ElementListBase();
00025         virtual ~ElementListBase();
00026
00027         using Base::GetSize;
00028         using Base::GetFront;
00029         using Base::IsEmpty;
00030
00032         LinkableBase* GetAt(INT idx) const;
00033
00036         const LinkableBase& operator [](INT i) const;
00039         LinkableBase& operator [](INT i);
00040
00041     protected:
00042         using Base::PushFront;
00043         using Base::PopFront;
00044         using Base::PushBack;
00045         using Base::Remove;
00046
00047     private:
00048 };
00049
00052 template<class T> class ElementList : public ElementListBase {
00053     typedef ElementListBase Base;
00054
00055     public:
00057         ElementList();
00059         ElementList(const ElementList<T> &list);
00061         virtual ~ElementList();
00062
00063         using Base::IsEmpty;
00064
00066         void Append(T *entry);
00068         void Append(const T &entry) { Append((T*)&entry); }
00069
00071         BOOLEAN AppendDistinct(T *entry);
00073         BOOLEAN AppendDistinct(const T &entry) { return (AppendDistinct((T*)&entry)); }
00074
00076         BOOLEAN Exists(T *entry) const;
00078         BOOLEAN Exists(const T &entry) const { return (Exists((T*)&entry)); }
00079
00081         INT Remove(T *entry);
00083         INT Remove(const T &entry) { return (Remove((T*)&entry)); }
00084
00086         void Clear();
00087
00090         T* GetFront() const { return (T*)Base::GetFront(); }
00091
00093         T* GetAt(INT idx) const {return (T*)Base::GetAt(idx); }
00094
00096         ElementList& operator =(const ElementList<T> &list);
00097
00100         const T& operator [](INT i) const { return (const T&)Base::operator[](i); }
00103         T& operator [](INT i) { return (T&)Base::operator[](i); }
00104 };
00105
00106 /*  ========================================================================
00107     SortedElementList
00108     ======================================================================== */
00111 template<class T> class SortedElementList : private ElementList<T> {
00112     typedef ElementList<T> Base;
00113
00114     public:
00116         SortedElementList();
00118         SortedElementList(const SortedElementList<T> &list);
00119
00120         using Base::GetSize;
00121         using Base::Clear;
00122
00123         T* GetFront() const {
00124             return (T*)Base::GetFront();
00125         }
00126
00127         T* GetAt(INT idx) const {
00128             return (T*)Base::GetAt(idx);
00129         }
00131         void Insert(T *entry);
00133         void Insert(const T &entry) { Insert((T*) &entry); };
00134
00136         SortedElementList& operator =(const SortedElementList<T> &list);
00137 };
00138
00139 /*  ========================================================================
00140     ElementList template methods
00141     ======================================================================== */
00142 /*  ------------------------------------------------------------------------
00143     ElementList
00144     ------------------------------------------------------------------------ */
00145 template <class T> ElementList<T>::ElementList()
00146 {
00147 }   // ElementList
00148
00149 /*  ------------------------------------------------------------------------
00150     ElementList
00151     ------------------------------------------------------------------------ */
00152 template <class T> ElementList<T>::ElementList(const ElementList<T> &list)
00153 {
00154     *this = list;
00155 }   // ElementList
00156
00157 /*  ------------------------------------------------------------------------
00158     ElementList
00159     ------------------------------------------------------------------------ */
00160 template <class T> ElementList<T>::~ElementList()
00161 {
00162     Clear();
00163 }   // ElementList
00164
00165 /*  ------------------------------------------------------------------------
00166     Insert
00167     ------------------------------------------------------------------------ */
00168 template <class T> void ElementList<T>::Append(T *entry)
00169 {
00170     T *new_entry = new T(*entry);
00171     new_entry->SetNext(0);
00172     PushBack(new_entry);
00173 }   // Insert
00174
00175 /*  ------------------------------------------------------------------------
00176     AppendDistinct
00177     ------------------------------------------------------------------------ */
00178 template<class T> BOOLEAN ElementList<T>::AppendDistinct(T *entry)
00179 {
00180     BOOLEAN add_entry = !Exists(entry);
00181     if (add_entry) {
00182         T *new_entry = new T(*entry);
00183         new_entry->SetNext(0);
00184         PushBack(new_entry);
00185     } // if
00186     return (add_entry);
00187 }   // AppendDistinct
00188
00189 /*  ------------------------------------------------------------------------
00190     Exists
00191     ------------------------------------------------------------------------ */
00192 template<class T> BOOLEAN ElementList<T>::Exists(T *entry) const
00193 {
00194     BOOLEAN exists = FALSE;
00195     if (entry != 0) {
00196         T *list_entry = (T*)GetFront();
00197         while (list_entry != 0 && !exists) {
00198             exists = (*entry == *list_entry);
00199             list_entry = list_entry->GetNext();
00200         } // while
00201     } // if
00202     return (exists);
00203 }   // Exists
00204
00205 /*  ------------------------------------------------------------------------
00206     Remove
00207     ------------------------------------------------------------------------ */
00208 template<class T> INT ElementList<T>::Remove(T *entry)
00209 {
00210     BOOLEAN removed_entries = 0;
00211     if (entry != 0) {
00212         T *list_entry = (T*)GetFront();
00213         T *next_list_entry = 0;
00214         while (list_entry != 0) {
00215             next_list_entry = list_entry->GetNext();
00216             if (*entry == *list_entry) {
00217                 removed_entries++;
00218                 Base::Remove(list_entry);
00219                 SaveDelete(list_entry);
00220             }
00221             list_entry = next_list_entry;
00222         } // while
00223     } // if
00224     return (removed_entries);
00225 }   // Remove
00226
00227 /*  ------------------------------------------------------------------------
00228     Clear
00229     ------------------------------------------------------------------------ */
00230 template<class T> void ElementList<T>::Clear()
00231 {
00232     // clean up existing plmn list
00233     T *entry;
00234     while (!IsEmpty()) {
00235         entry = GetFront();
00236         PopFront();
00237         SaveDelete(entry);
00238     } // end while
00239 }   // Clear
00240
00241 /*  ------------------------------------------------------------------------
00242     operator =
00243     ------------------------------------------------------------------------ */
00244 template <class T> ElementList<T>& ElementList<T>::operator =(const ElementList<T> &list)
00245 {
00246     if (&list != this) {        // guard from self assignment
00247         Clear();
00248         // assign new plmn list
00249         T *entry = list.GetFront();
00250         while (entry != 0) {
00251             Append(entry);
00252             entry = entry->GetNext();
00253         } // while
00254     } // if
00255     return (*this);
00256 }   // operator =
00257
00258 /*  ========================================================================
00259     SortedElementList template methods
00260     ======================================================================== */
00261 /*  ------------------------------------------------------------------------
00262     SortedElementList
00263     ------------------------------------------------------------------------ */
00264 template<class T> SortedElementList<T>::SortedElementList()
00265 {
00266 }   // SortedElementListBase
00267
00268 /*  ------------------------------------------------------------------------
00269     SortedElementList
00270     ------------------------------------------------------------------------ */
00271 template<class T> SortedElementList<T>::SortedElementList(const SortedElementList<T> &list)
00272 {
00273     *this = list;
00274 }   // SortedElementList
00275
00276 /*  ------------------------------------------------------------------------
00277     ~SortedElementList
00278     ------------------------------------------------------------------------ */
00279 /*template<class T> SortedElementList<T>::~SortedElementList()
00280 {
00281     Clear();
00282 }   // ~SortedElementList
00283 */
00284 /*  ------------------------------------------------------------------------
00285     Insert
00286     ------------------------------------------------------------------------ */
00287 template<class T> void SortedElementList<T>::Insert(T *entry)
00288 {
00289     T *new_entry = new T;
00290     *new_entry = *entry;
00291     new_entry->SetNext(0);
00292
00293     T *t = (T*)GetFront();
00294     T *prev = 0;
00295
00296     while(t != 0 && *t < *new_entry) {
00297         prev = t;
00298         t = (T*)t->GetNext();
00299     }
00300
00301     if (GetFront() == 0 || prev == 0)
00302         this->PushFront(new_entry);
00303     else {
00304         prev->SetNext(new_entry);
00305         new_entry->SetNext(t);
00306     }
00307 }   // Insert
00308
00309 /*  ------------------------------------------------------------------------
00310     GetAt
00311     ------------------------------------------------------------------------ */
00312 /*template<class T> T* SortedElementList<T>::GetAt(INT idx) const
00313 {
00314     T *entry = m_list.GetFront();
00315     INT count = 0;
00316     while (entry != 0 && count != idx) {
00317         count++;
00318         entry = entry->GetNext();
00319     } // while
00320     return entry;
00321 }   // GetAt
00322 */
00323 /*  ------------------------------------------------------------------------
00324     operator []
00325     ------------------------------------------------------------------------ */
00326 /*template<class T> const T& SortedElementList<T>::operator [](INT i) const
00327 {
00328     T *elem = GetAt(i);
00329     ASSERT (elem != 0);
00330     return (*elem);
00331 }   // operator []
00332 */
00333 /*  ------------------------------------------------------------------------
00334     operator =
00335     ------------------------------------------------------------------------ */
00336 template<class T> SortedElementList<T>& SortedElementList<T>::operator =(const SortedElementList<T> &list)
00337 {
00338     if (&list != this) {        // guard from self assignment
00339         Clear();
00340         // assign new plmn list
00341         T *entry = list.GetFront();
00342         while (entry != 0) {
00343             Insert(entry);
00344             entry = entry->GetNext();
00345         } // while
00346     } // if
00347     return (*this);
00348 }   // operator =
00349
00351 #endif  // Auxiliary_ElementList_hpp
00352
Generated on Tue Jan 24 14:48:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/EventData.hpp File Reference

Auxiliary/EventData.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EventData

Defines

#define | Apoxi_EventData_hpp

Define Documentation

#define Apoxi_EventData_hpp

Generated on Tue Jan 24 18:33:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/EventData.hpp Source File

Auxiliary/EventData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_EventData_hpp)
00010 #define Apoxi_EventData_hpp
00011
00017 class EventData
00018 {
00019 public:
00020     virtual ~EventData() {};
00021 };
00022
00023 #endif  // Apoxi_EventData_hpp
00024
00025
Generated on Tue Jan 24 14:48:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FifoLinkedList.hpp File Reference

Auxiliary/FifoLinkedList.hpp File Reference

#include <Auxiliary/LinkedList.hpp>

Include dependency graph for FifoLinkedList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FifoLinkedList< T >

Defines

#define | Apoxi_FifoLinkedList_hpp

Define Documentation

#define Apoxi_FifoLinkedList_hpp

Generated on Tue Jan 24 18:34:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FifoLinkedList.hpp Source File

Auxiliary/FifoLinkedList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_FifoLinkedList_hpp)
00011 #define Apoxi_FifoLinkedList_hpp
00014
00015 #include <Auxiliary/LinkedList.hpp>
00016
00020 template<class T> class FifoLinkedList : private LinkedList<T> {
00021     typedef LinkedList<T> Base;
00022     public:
00024         inline FifoLinkedList() : m_back(0) { }
00025
00027         inline void Push(T *elem) {
00028             if (m_back != 0) {
00029                 m_back->SetNext(elem);
00030                 elem->SetNext(0);
00031             }
00032             else
00033                 LinkedListBase::PushFront(elem);
00034             m_back = elem;
00035         }
00036
00038         inline void Pop() {
00039             LinkedListBase::PopFront();
00040             if (LinkedListBase::m_anchor == 0)
00041                 m_back = 0;
00042         }
00043
00045         inline void Remove(T *elem) {
00046             Base::Remove(elem);
00047             if (elem == m_back) {
00048                 m_back = (T *) Base::GetBack();
00049             } // if
00050         }
00051
00052         using LinkedList<T>::GetFront;
00053         using LinkedList<T>::IsEmpty;
00054     private:
00055         T *m_back;
00056 };
00057
00058
00060 #endif  // Apoxi_FifoLinkedList_hpp
00061
00062
Generated on Tue Jan 24 14:48:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FileBinData.hpp File Reference

Auxiliary/FileBinData.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 14:53:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FileBinData.hpp Source File

Auxiliary/FileBinData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("Reference to old Auxiliary/FileBinData.hpp. Please use " \
00010     "Afs/Rfs/FileBinData.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_2_0)
00013     #include <Afs/Rfs/FileBinData.hpp>
00014 #else
00015     #error Auxiliary/FileBinData.hpp was moved to Afs/Rfs. Nevertheless, to use it from here define APOXI_COMPAT_2_2_0.
00016 #endif
00017
00018
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FilterProvider.cpp File Reference

Auxiliary/FilterProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "FilterProvider.hpp"
#include "ProviderListener.hpp"
#include "DataItem.hpp"
#include "FilterRule.hpp"

Include dependency graph for FilterProvider.cpp:

Generated on Tue Jan 24 18:34:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FilterProvider.hpp File Reference

Auxiliary/FilterProvider.hpp File Reference

#include <Auxiliary/AbstractDelegationProvider.hpp>
#include <Auxiliary/IndexTable.hpp>

Include dependency graph for FilterProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FilterProvider

Defines

#define | _Adc_FilterProvider_hpp

Define Documentation

#define _Adc_FilterProvider_hpp

Generated on Tue Jan 24 18:34:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FilterProvider.hpp Source File

Auxiliary/FilterProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_FilterProvider_hpp)
00015 #define _Adc_FilterProvider_hpp
00018
00019 #include <Auxiliary/AbstractDelegationProvider.hpp>
00020 #include <Auxiliary/IndexTable.hpp>
00021
00022
00023 class DataItem;
00024 class FilterRule;
00025
00029 /* NOTE: No writing is possible on a FilterProvider. Use <em>GetChildRow</em> to get
00030 the row of the child provider and update the child provider directly.
00031 See also: <em>Provider, DataItem, FilterRule</em>.*/
00032 class FilterProvider : public AbstractDelegationProvider
00033 {
00034     public:
00035         typedef AbstractDelegationProvider Base;
00036
00039         FilterProvider();
00040
00046         FilterProvider(Provider * provider, FilterRule * rule, INT columnid = 0, BOOLEAN negation = FALSE);
00047
00049         virtual ~FilterProvider();
00050
00052         void Init(Provider * provider, FilterRule * rule, INT columnid = 0, BOOLEAN negation = FALSE);
00053
00055         void SetNegation(BOOLEAN negation) { m_negation = negation; }
00056
00058         void SetFilterColumn(INT filtercolumn) { m_column = filtercolumn; }
00059
00061         void SetFilterRule(FilterRule * rule) { m_rule = rule; }
00062
00064         virtual INT RowCount();
00065
00067         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00068
00070         virtual BOOLEAN InsertRow(INT row);
00071
00074         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00075
00077         virtual BOOLEAN Update(ProviderListener * listener = 0);
00078
00080         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00081
00083         virtual BOOLEAN SetParameter(const DataItem &item);
00084
00087         virtual void OnExecutingListener(Provider* provider = 0);
00088
00089     protected:
00095         virtual BOOLEAN IsRowFiltered(Provider* base_provider, INT row, BOOLEAN negate);
00096
00097         virtual void OnChildProviderModification(Provider* provider, const Provider::Modification &modification);
00098
00099     private:
00100         virtual BOOLEAN UpdateIndexTable(ModificationType type, INT row);
00101
00102         virtual INT FindFilteredRow(INT child_row);
00103
00104         BOOLEAN      m_negation;
00105         INT          m_FilteredCnt;
00106         INT          m_column;
00107         FilterRule * m_rule;
00108
00109         IndexTable<INT> m_FilteredRows;
00110 };
00111
00113 #endif
00114
00115
Generated on Tue Jan 24 14:48:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FilterRule.cpp File Reference

Auxiliary/FilterRule.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "FilterRule.hpp"
#include "DataItem.hpp"

Include dependency graph for FilterRule.cpp:

Generated on Tue Jan 24 18:34:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FilterRule.hpp File Reference

Auxiliary/FilterRule.hpp File Reference

#include <Auxiliary/DataItem.hpp>

Include dependency graph for FilterRule.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EqualsRule
EqualsRule checks whether data item equal to rule item More...
class | FilterRule
class | GreaterRule
IsGreaterRule checks whether data item is larger than the rule item More...
class | LessRule
RangeRule checks whether data item is less than the rule item More...
class | NotEqualsRule
NotEqualsRule checks whether data item is not equal to rule item More...
class | RangeRule
RangeRule checks whether data item is between rule item and rule2item More...

Defines

#define | _Adc_FilterRule_hpp

Define Documentation

#define _Adc_FilterRule_hpp

Generated on Tue Jan 24 18:35:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FilterRule.hpp Source File

Auxiliary/FilterRule.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_FilterRule_hpp)
00015 #define _Adc_FilterRule_hpp
00018
00019 #include <Auxiliary/DataItem.hpp>
00020
00021
00022
00023 class DataItem;
00024
00027 class FilterRule
00028 {
00029     public:
00032         FilterRule();
00034         FilterRule(const DataItem & ruleitem);
00036         FilterRule(const DataItem & ruleitem, const DataItem & rule2item);
00038         virtual ~FilterRule();
00040         void Init(const DataItem & ruleitem) { m_ruleitem = ruleitem; }
00042         void Init(const DataItem & ruleitem, const DataItem & rule2item);
00043
00046         virtual BOOLEAN ExecuteRule(const DataItem & dataitem) = 0;
00047
00048     protected:
00049         DataItem m_ruleitem;
00050         DataItem m_rule2item;
00051 };
00052
00053
00055 class EqualsRule : public FilterRule
00056 {
00057     public:
00058         typedef FilterRule Base;
00060         EqualsRule();
00062         EqualsRule(const DataItem & ruleitem);
00064         virtual ~EqualsRule();
00066         virtual BOOLEAN ExecuteRule(const DataItem & dataitem);
00067
00068 };
00069
00071 class NotEqualsRule : public FilterRule
00072 {
00073     public:
00074         typedef FilterRule Base;
00076         NotEqualsRule();
00078         NotEqualsRule(const DataItem & ruleitem);
00080         virtual ~NotEqualsRule();
00082         virtual BOOLEAN ExecuteRule(const DataItem & dataitem);
00083
00084 };
00085
00087 class RangeRule : public FilterRule
00088 {
00089     public:
00090         typedef FilterRule Base;
00092         RangeRule();
00094         RangeRule(const DataItem & ruleitem, const DataItem & rule2item);
00096         virtual ~RangeRule();
00098         virtual BOOLEAN ExecuteRule(const DataItem & dataitem);
00099 };
00100
00102 class LessRule : public FilterRule
00103 {
00104     public:
00105         typedef FilterRule Base;
00107         LessRule();
00109         LessRule(const DataItem & ruleitem);
00111         virtual ~LessRule();
00113         virtual BOOLEAN ExecuteRule(const DataItem & dataitem);
00114
00115 };
00116
00118 class GreaterRule : public FilterRule
00119 {
00120     public:
00121         typedef FilterRule Base;
00122
00124         GreaterRule();
00126         GreaterRule(const DataItem & ruleitem);
00128         virtual ~GreaterRule();
00130         virtual BOOLEAN ExecuteRule(const DataItem & dataitem);
00131
00132 };
00133
00134
00136 #endif
00137
00138
Generated on Tue Jan 24 14:48:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Find2Provider.cpp File Reference

Auxiliary/Find2Provider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Find2Provider.hpp"
#include "DataItem.hpp"
#include "FilterRule.hpp"

Include dependency graph for Find2Provider.cpp:

Generated on Tue Jan 24 18:35:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Find2Provider.hpp File Reference

Auxiliary/Find2Provider.hpp File Reference

#include <Auxiliary/FindProvider.hpp>

Include dependency graph for Find2Provider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Find2Provider

Defines

#define | _Adc_Find2Provider_hpp

Define Documentation

#define _Adc_Find2Provider_hpp

Generated on Tue Jan 24 18:35:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Find2Provider.hpp Source File

Auxiliary/Find2Provider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_Find2Provider_hpp)
00015 #define _Adc_Find2Provider_hpp
00018
00019 #include <Auxiliary/FindProvider.hpp>
00020
00021
00022
00023 class DataItem;
00024 class FilterRule;
00025
00032 class Find2Provider : public FindProvider
00033 {
00034     public:
00035         typedef FindProvider Base;
00037         Find2Provider();
00039         Find2Provider(Provider * provider, FilterRule * rule, INT column, FilterRule * rule2, INT column2);
00041         virtual ~Find2Provider();
00042
00044         void Init(Provider * provider, FilterRule * rule, INT column, FilterRule * rule2, INT column2);
00045
00047         virtual BOOLEAN Update(ProviderListener * listener = 0);
00048
00049     private:
00050         INT          m_column2;
00051         FilterRule * m_rule2;
00052 };
00053
00055 #endif
00056
00057
Generated on Tue Jan 24 14:48:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FindProvider.cpp File Reference

Auxiliary/FindProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "FindProvider.hpp"
#include "DataItem.hpp"
#include "FilterRule.hpp"

Include dependency graph for FindProvider.cpp:

Generated on Tue Jan 24 18:35:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FindProvider.hpp File Reference

Auxiliary/FindProvider.hpp File Reference

#include <Auxiliary/AbstractDelegationProvider.hpp>

Include dependency graph for FindProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FindProvider

Defines

#define | _Adc_FindProvider_hpp

Define Documentation

#define _Adc_FindProvider_hpp

Generated on Tue Jan 24 18:35:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FindProvider.hpp Source File

Auxiliary/FindProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_FindProvider_hpp)
00015 #define _Adc_FindProvider_hpp
00018
00019 #include <Auxiliary/AbstractDelegationProvider.hpp>
00020
00021
00022
00023 class DataItem;
00024 class FilterRule;
00025
00028 /*
00029 NOTE: No writing is possible on a FindProvider. Use <em>GetChildRow</em> to get
00030 the row of the child provider and update the child provider directly.
00031 See also: <em>Provider, FilterProvider, Find2Provider, DataItem, FilterRule</em>.*/
00032 class FindProvider : public AbstractDelegationProvider
00033 {
00034     public:
00035         typedef AbstractDelegationProvider Base;
00037         FindProvider();
00038
00043         FindProvider(Provider * provider, FilterRule * rule, INT columnid = 0);
00045         virtual ~FindProvider();
00046
00048         void Init(Provider * provider, FilterRule * rule, INT columnid = 0);
00049
00051         virtual INT RowCount();
00052
00054         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00055
00057         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00058
00061         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00062
00064         virtual BOOLEAN Update(ProviderListener * listener = 0);
00065
00068         virtual void OnExecutingListener(Provider* provider = 0);
00069
00070     protected:
00071         virtual void OnChildProviderModification(Provider* provider, const Provider::Modification& modification);
00072
00073         INT          m_FindRow;
00074         INT          m_column;
00075         FilterRule * m_rule;
00076 };
00077
00079 #endif
00080
00081
Generated on Tue Jan 24 14:48:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FixedPtrArray.hpp File Reference

Auxiliary/FixedPtrArray.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for FixedPtrArray.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FixedPtrArray< T >

Defines

#define | _Adc_FixedPtrArray_hpp

Define Documentation

#define _Adc_FixedPtrArray_hpp

Generated on Tue Jan 24 18:36:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/FixedPtrArray.hpp Source File

Auxiliary/FixedPtrArray.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_FixedPtrArray_hpp)
00015 #define _Adc_FixedPtrArray_hpp
00016
00017 #include <Kernel/Types.hpp>
00018
00022 template<class T> class FixedPtrArray
00023 {
00024     public:
00026         typedef T * PtrT;
00028         FixedPtrArray() : m_ptr_array(0), m_count(0), m_size(0) {};
00030         FixedPtrArray(INT count) : m_count(0), m_size(0) {
00031             m_ptr_array = new PtrT[count];
00032             if(m_ptr_array!=0) {
00033                 m_count = count;
00034                 m_size = count;
00035             }
00036         }
00038         ~FixedPtrArray() { delete[] m_ptr_array; };
00039
00043         BOOLEAN Resize(INT count, T * pattern) {
00044             if(m_size<count) {
00045                 delete[] m_ptr_array;
00046                 m_ptr_array = new PtrT[count];
00047                 if(m_ptr_array!=0) {
00048                     m_size = count;
00049                 } else {
00050                     m_count = 0;
00051                     m_size = 0;
00052                     return FALSE;
00053                 }
00054             }
00055             m_count = count;
00056             for(INT i=0; i<count; i++) {
00057                 SetPtr(i,pattern);
00058             }
00059             return TRUE;
00060         }
00061
00062         BOOLEAN Resize(INT count) {
00063             return Resize(count, 0);
00064         }
00065
00067         void SetPtr(INT idx, PtrT ptr) { m_ptr_array[idx] = ptr; }
00069         PtrT GetPtr(INT idx) const { return m_ptr_array[idx]; }
00070
00072         void DeletePtrObj(INT idx) const { delete m_ptr_array[idx]; m_ptr_array[idx] = 0; }
00073
00075         PtrT operator [] (INT idx) const { return m_ptr_array[idx]; }
00076
00078         PtrT operator [] (INT idx) { return m_ptr_array[idx]; }
00079
00081         inline INT  GetCount() const { return m_count; }
00082
00083     private:
00084         PtrT  * m_ptr_array;
00085         INT   m_count;
00086         INT   m_size;
00087 };
00088
00089
00090
00091
00092 #endif
00093
00094
Generated on Tue Jan 24 14:48:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/GenericObject.cpp File Reference

Auxiliary/GenericObject.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "GenericObject.hpp"

Include dependency graph for GenericObject.cpp:

Generated on Tue Jan 24 18:36:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/GenericObject.hpp File Reference

Auxiliary/GenericObject.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for GenericObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GenericObject

Defines

#define | _Adc_GenericObject_hpp

Typedefs

typedef INT | GenericTypeId

Variables

const GenericTypeId | c_apoxi_base_gentypes = 0
const GenericTypeId | c_user_base_gentypes = 1000

Define Documentation

#define _Adc_GenericObject_hpp

Typedef Documentation

typedef INT GenericTypeId

Variable Documentation

const GenericTypeId c_apoxi_base_gentypes = 0

const GenericTypeId c_user_base_gentypes = 1000

Generated on Tue Jan 24 18:38:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/GenericObject.hpp Source File

Auxiliary/GenericObject.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_GenericObject_hpp)
00015 #define _Adc_GenericObject_hpp
00016
00017 #include <Kernel/Types.hpp>
00018
00019
00020
00021 typedef INT GenericTypeId;
00022
00023 const GenericTypeId c_apoxi_base_gentypes = 0;
00024 const GenericTypeId c_user_base_gentypes  = 1000;
00025
00030 class GenericObject
00031 {
00032     public:
00034         GenericObject();
00035
00036         GenericObject(const GenericObject &);
00037
00039         virtual ~GenericObject();
00040
00042         virtual GenericObject * Copy() const = 0;
00044         virtual BOOLEAN         IsEqual(GenericObject * object) = 0;
00046         virtual GenericTypeId   GetTypeId() = 0;
00048         BOOLEAN IsSameType(GenericObject * object);
00049 };
00050
00051
00052 #endif
00053
00054
Generated on Tue Jan 24 14:48:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HashTable.cpp File Reference

Auxiliary/HashTable.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "HashTable.hpp"
#include "Macros.hpp"

Include dependency graph for HashTable.cpp:

Generated on Tue Jan 24 18:38:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HashTable.hpp File Reference

Auxiliary/HashTable.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>

Include dependency graph for HashTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Hashable
class | HashTable

Defines

#define | _Apoxi_HashTable_hpp

Typedefs

typedef UINT16 | HashKey

Define Documentation

#define _Apoxi_HashTable_hpp

Generated on Tue Jan 24 18:39:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HashTable.hpp Source File

Auxiliary/HashTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(_Apoxi_HashTable_hpp)
00009 #define _Apoxi_HashTable_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/LinkedList.hpp>
00016
00017
00018 typedef UINT16 HashKey;     // wide range key
00019
00023 class Hashable : public Linkable<Hashable> {
00024     public:
00026         Hashable(HashKey key = 0) : m_key(key) {}
00028         virtual HashKey GetKey() const { return m_key; }
00029
00030     private:
00031         HashKey m_key;
00032 };
00033
00036 class HashTable {
00037     public:
00039         HashTable(UINT16 init_size);
00041         virtual ~HashTable() { delete [] m_vector; }
00043         virtual INT GetSize() const { return m_size; }
00045         virtual BOOLEAN AddElem(Hashable *elem);
00047         virtual void RemoveElem(HashKey key);
00049         virtual Hashable* GetElem(HashKey key) const;
00050
00051     protected:
00053         virtual HashKey Hash(HashKey key) const;
00054
00055     private:
00056         const UINT16 m_size;
00057         LinkedList<Hashable> *m_vector;
00058 };
00059
00061 #endif
00062
00063
Generated on Tue Jan 24 14:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HeapDataSink.cpp File Reference

Auxiliary/HeapDataSink.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "HeapDataSink.hpp"

Include dependency graph for HeapDataSink.cpp:

Defines

#define | HEAP_DATASINK_CLOSED 0x02
#define | HEAP_DATASINK_INIT 0x00
#define | HEAP_DATASINK_OPENED 0x01

Define Documentation

#define HEAP_DATASINK_CLOSED 0x02

#define HEAP_DATASINK_INIT 0x00

#define HEAP_DATASINK_OPENED 0x01

Generated on Tue Jan 24 18:39:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HeapDataSink.hpp File Reference

Auxiliary/HeapDataSink.hpp File Reference

#include <Auxiliary/DataSink.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for HeapDataSink.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HeapDataSink

Defines

#define | Apoxi_HeapDataSink_hpp

Typedefs

typedef NiSharedPtr< HeapDataSink > | HeapDataSinkPtr
Smart-pointer controlling a HeapDataSink object.

Define Documentation

#define Apoxi_HeapDataSink_hpp

Typedef Documentation

typedef NiSharedPtr<HeapDataSink> HeapDataSinkPtr

Smart-pointer controlling a HeapDataSink object.

Generated on Tue Jan 24 18:39:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HeapDataSink.hpp Source File

Auxiliary/HeapDataSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_HeapDataSink_hpp)
00011 #define Apoxi_HeapDataSink_hpp
00012
00013 #include <Auxiliary/DataSink.hpp>
00014 #include <Auxiliary/Vector.hpp>
00015
00016 class HeapDataSink;
00017
00019 typedef NiSharedPtr<HeapDataSink> HeapDataSinkPtr;
00020
00023 class HeapDataSink : public DataSink
00024 {
00025     typedef DataSink Base;
00026
00027     friend class HeapDataSource;
00028
00029     public:
00039         HeapDataSink(UINT32 block_size,
00040             DrmLocalId id = c_drm_invalid_local_id);
00041
00043         virtual ~HeapDataSink();
00044
00050         virtual BOOLEAN Open();
00051
00056         virtual BOOLEAN Close();
00057
00061         virtual BOOLEAN IsOpen() const;
00062
00070         virtual UINT32 Write(const void HUGE *buf, UINT32 nbytes);
00071
00084         virtual UINT32 Write(UINT32 offset, const void HUGE *buf,
00085             UINT32 nbytes);
00086
00093         virtual BOOLEAN GetSize(UINT32 &size) const;
00094
00095     private:
00105             BOOLEAN Read(void HUGE *buffer, UINT32 offset, UINT32 count);
00106
00108
00109         UINT8 m_open_state;
00110         Vector<UINT8*> m_blocks;
00111         UINT32 m_data_length;
00112         const UINT32 m_block_size;
00113 };
00114
00115 #endif  // Apoxi_HeapDataSink_hpp
00116
Generated on Tue Jan 24 14:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HeapDataSource.cpp File Reference

Auxiliary/HeapDataSource.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "HeapDataSource.hpp"
#include "HeapDataSink.hpp"

Include dependency graph for HeapDataSource.cpp:

Generated on Tue Jan 24 18:39:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HeapDataSource.hpp File Reference

Auxiliary/HeapDataSource.hpp File Reference

#include <Auxiliary/DataSource.hpp>

Include dependency graph for HeapDataSource.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HeapDataSource

Defines

#define | Auxiliary_HeapDataSource_hpp

Typedefs

typedef NiSharedPtr< HeapDataSink > | HeapDataSinkPtr
Smart-pointer controlling a HeapDataSink object.
typedef NiSharedPtr< HeapDataSource > | HeapDataSourcePtr
Smart-pointer controlling a HeapDataSource object.

Define Documentation

#define Auxiliary_HeapDataSource_hpp

Typedef Documentation

typedef NiSharedPtr<HeapDataSink> HeapDataSinkPtr

Smart-pointer controlling a HeapDataSink object.

typedef NiSharedPtr<HeapDataSource> HeapDataSourcePtr

Smart-pointer controlling a HeapDataSource object.

Generated on Tue Jan 24 18:39:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HeapDataSource.hpp Source File

Auxiliary/HeapDataSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_HeapDataSource_hpp)
00011 #define Auxiliary_HeapDataSource_hpp
00012
00013 #include <Auxiliary/DataSource.hpp>
00014
00015 class HeapDataSink;
00016 class HeapDataSource;
00017
00019 typedef NiSharedPtr<HeapDataSink> HeapDataSinkPtr;
00020
00022 typedef NiSharedPtr<HeapDataSource> HeapDataSourcePtr;
00023
00026 class HeapDataSource : public DataSource
00027 {
00028     typedef DataSource Base;
00029
00030     public:
00039         HeapDataSource(const HeapDataSinkPtr &sink);
00040
00042         virtual ~HeapDataSource();
00043
00044         virtual BOOLEAN Open();
00045         virtual BOOLEAN Close();
00046         virtual BOOLEAN IsOpen() const;
00047         virtual BOOLEAN Read(void HUGE *buffer, UINT32 count);
00048         virtual BOOLEAN Read(void HUGE *buffer, UINT32 max_count,
00049             UINT32&bytes_read);
00050         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 count);
00051         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer,
00052             UINT32 max_count, UINT32 &bytes_read);
00053         virtual BOOLEAN GetSize(UINT32 &size) const;
00054
00055     private:
00056         HeapDataSinkPtr m_sink;
00057         BOOLEAN m_open;
00058         UINT32 m_cur_pos;
00059 };
00060
00061 #endif  // Auxiliary_HeapDataSource_hpp
00062
Generated on Tue Jan 24 14:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HeapObject.hpp File Reference

Auxiliary/HeapObject.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Auxiliary/NonCloneable.hpp>

Include dependency graph for HeapObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HeapArrayObject< T >
class | HeapObject< T >

Defines

#define | Apoxi_HeapObject_hpp

Define Documentation

#define Apoxi_HeapObject_hpp

Generated on Tue Jan 24 18:40:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HeapObject.hpp Source File

Auxiliary/HeapObject.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_HeapObject_hpp)
00010 #define Apoxi_HeapObject_hpp
00013
00014 #include <Auxiliary/Macros.hpp>
00015 #include <Auxiliary/NonCloneable.hpp>
00016
00018 template<class T> class HeapObject : public NonCloneable {
00019     public:
00021         inline HeapObject(T *data) : m_data(data) { }
00022         inline HeapObject() : m_data(0) { }
00023         virtual inline ~HeapObject() { delete m_data; }
00024
00026         inline void Attach(T *data) { delete m_data; m_data = data; };
00027
00029         inline T* operator()() const { return m_data; }
00030
00031     private:
00032         T *m_data;
00033 };
00034
00036 template<class T> class HeapArrayObject {
00037     public:
00039         inline HeapArrayObject(T *data) : m_data(data) { }
00040         inline HeapArrayObject() : m_data(0) { }
00041         inline ~HeapArrayObject() { delete [] m_data; }
00042
00044         inline void Attach(T * data) { delete [] m_data; m_data = data; };
00045
00047         inline T* operator()() const { return m_data; }
00048
00049     private:
00050         T *m_data;
00051
00052         inline HeapArrayObject(const HeapObject<T> &heap_object) { ASSERT_DEBUG(FALSE); };
00053         inline HeapArrayObject& operator=(const HeapObject<T> &heap_object) { ASSERT_DEBUG(FALSE); return *this; };
00054 };
00055
00057 #endif  // Apoxi_HeapObject_hpp
00058
00059
Generated on Tue Jan 24 14:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HostDebugTimeStamp.cpp File Reference

Auxiliary/HostDebugTimeStamp.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "HostDebugTimeStamp.hpp"
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for HostDebugTimeStamp.cpp:

Generated on Tue Jan 24 18:40:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HostDebugTimeStamp.hpp File Reference

Auxiliary/HostDebugTimeStamp.hpp File Reference

#include <Auxiliary/String.hpp>

Include dependency graph for HostDebugTimeStamp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HostDebugTimeStamp

Defines

#define | Apoxi_HostDebugTimeStamp_hpp

Define Documentation

#define Apoxi_HostDebugTimeStamp_hpp

Generated on Tue Jan 24 18:40:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HostDebugTimeStamp.hpp Source File

Auxiliary/HostDebugTimeStamp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011
00012 #if !defined(Apoxi_HostDebugTimeStamp_hpp)
00013 #define Apoxi_HostDebugTimeStamp_hpp
00016
00017
00018 #if defined(APOXI_RTOS_WIN32)
00019
00020 #include <Auxiliary/String.hpp>
00021
00022 /*  -------------------------------------------------------------------------
00023                                 Types
00024     ------------------------------------------------------------------------- */
00025
00026
00032 class HostDebugTimeStamp {
00033     public:
00034
00038         HostDebugTimeStamp();
00039         ~HostDebugTimeStamp();
00040
00041
00042
00046         String GetTimeStamp();
00047
00048
00049 };
00050
00051 #endif // #if defined(APOXI_RTOS_WIN32)
00052
00054
00055
00056
00057 #endif  // Apoxi_HostDebugTimeStamp_hpp
00058
00059
00060
Generated on Tue Jan 24 14:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HostIniFile.cpp File Reference

Auxiliary/HostIniFile.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "HostIniFile.hpp"
#include <Auxiliary/Macros.hpp>
#include <Kernel/Os/Win32/WinInc.hpp>
#include <SHLOBJ.H>

Include dependency graph for HostIniFile.cpp:

Generated on Tue Jan 24 18:40:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HostIniFile.hpp File Reference

Auxiliary/HostIniFile.hpp File Reference

#include <Auxiliary/String.hpp>

Include dependency graph for HostIniFile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HostIniFile

Defines

#define | Apoxi_HostIniFile_hpp

Define Documentation

#define Apoxi_HostIniFile_hpp

Generated on Tue Jan 24 18:40:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/HostIniFile.hpp Source File

Auxiliary/HostIniFile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_HostIniFile_hpp)
00011 #define Apoxi_HostIniFile_hpp
00014
00015 #include <Auxiliary/String.hpp>
00016
00025 class HostIniFile {
00026     public:
00034         HostIniFile(String inifilename, BOOLEAN on_desktop = FALSE);
00035         ~HostIniFile();
00036
00042         BOOLEAN ReadString(CHAR * section, CHAR * keyname, CHAR * keyvalueMax80);
00043
00050         BOOLEAN WriteString(CHAR * section, CHAR * keyname, CHAR * keyvalueMax80);
00051
00056         INT ReadInteger(CHAR * section, CHAR * keyname);
00057
00063         BOOLEAN WriteInteger(CHAR * section, CHAR * keyname, INT keyvalue);
00064
00069         BOOLEAN ReadBool(CHAR * section, CHAR * keyname);
00070
00076         BOOLEAN WriteBool(CHAR * section, CHAR * keyname, BOOLEAN keyvalue);
00077
00078     private:
00079         static String GetModulePath();
00080         static String GetSpecialDirectory(int type);
00081
00082         String m_inifilename;
00083 };
00084
00086 #endif  // Apoxi_HostIniFile_hpp
00087
Generated on Tue Jan 24 14:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Iana.hpp File Reference

Auxiliary/Iana.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for Iana.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Iana

Defines

#define | Apoxi_Iana_hpp

Define Documentation

#define Apoxi_Iana_hpp

Generated on Tue Jan 24 18:40:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Iana.hpp Source File

Auxiliary/Iana.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Iana_hpp)
00011 #define Apoxi_Iana_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00020 class Iana {
00021     public:
00022         enum PortNumber {
00023             c_ftp_data_tcp                 = (INT)    20,   //  File Transfer [Default Data]
00024             c_ftp_data_udp                 = (INT)    20,   //  File Transfer [Default Data]
00025             c_ftp_tcp                      = (INT)    21,   //  File Transfer [Control]
00026             c_ftp_udp                      = (INT)    21,   //  File Transfer [Control]
00027             c_ssh_tcp                      = (INT)    22,   //  SSH Remote Login Protocol
00028             c_ssh_udp                      = (INT)    22,   //  SSH Remote Login Protocol
00029             c_telnet_tcp                   = (INT)    23,   //  Telnet
00030             c_telnet_udp                   = (INT)    23,   //  Telnet
00031             c_smtp_tcp                     = (INT)    25,   //  Simple Mail Transfer
00032             c_smtp_udp                     = (INT)    25,   //  Simple Mail Transfer
00033
00034             c_name_tcp                     = (INT)    42,   //  Host Name Server
00035             c_name_udp                     = (INT)    42,   //  Host Name Server
00036             c_nameserver_tcp               = (INT)    42,   //  Host Name Server
00037             c_nameserver_udp               = (INT)    42,   //  Host Name Server
00038
00039             c_tftp_tcp                     = (INT)    69,   //  Trivial File Transfer
00040             c_tftp_udp                     = (INT)    69,   //  Trivial File Transfer
00041
00042             c_http_tcp                     = (INT)    80,   //  World Wide Web HTTP
00043             c_http_udp                     = (INT)    80,   //  World Wide Web HTTP
00044             c_www_tcp                      = (INT)    80,   //  World Wide Web HTTP
00045             c_www_udp                      = (INT)    80,   //  World Wide Web HTTP
00046             c_www_http_tcp                 = (INT)    80,   //  World Wide Web HTTP
00047             c_www_http_udp                 = (INT)    80,   //  World Wide Web HTTP
00048
00049             c_pop3_tcp                     = (INT)   110,   //  Post Office Protocol - Version 3
00050             c_pop3_udp                     = (INT)   110,   //  Post Office Protocol - Version 3
00051
00052             c_auth_tcp                     = (INT)   113,   //  Authentication Service
00053             c_auth_udp                     = (INT)   113,   //  Authentication Service
00054
00055             c_nntp_tcp                     = (INT)   119,   //  Network News Transfer Protocol
00056             c_nntp_udp                     = (INT)   119,   //  Network News Transfer Protocol
00057
00058             c_imap_tcp                     = (INT)   143,   //  Internet Message Access Protocol
00059             c_imap_udp                     = (INT)   143,   //  Internet Message Access Protocol
00060
00061             c_irc_tcp                      = (INT)   194,   //  Internet Relay Chat Protocol
00062             c_irc_udp                      = (INT)   194,   //  Internet Relay Chat Protocol
00063
00064             c_imap3_tcp                    = (INT)   220,   //  Interactive Mail Access Protocol v3
00065             c_imap3_udp                    = (INT)   220,   //  Interactive Mail Access Protocol v3
00066
00067             c_set_tcp                      = (INT)   257,   //  Secure Electronic Transaction
00068             c_set_udp                      = (INT)   257,   //  Secure Electronic Transaction
00069
00070
00071             c_ldap_tcp                     = (INT)   389,   //  Lightweight Directory Access Protocol
00072             c_ldap_udp                     = (INT)   389,   //  Lightweight Directory Access Protocol
00073
00074
00075             c_https_tcp                    = (INT)   443,   //  http protocol over TLS/SSL
00076             c_https_udp                    = (INT)   443,   //  http protocol over TLS/SSL
00077
00078             c_conference_tcp               = (INT)   531,   //  chat
00079             c_conference_udp               = (INT)   531,   //  chat
00080             c_netnews_tcp                  = (INT)   532,   //  readnews
00081             c_netnews_udp                  = (INT)   532,   //  readnews
00082
00083             c_ftps_data_tcp                = (INT)   989,   //  ftp protocol, data, over TLS/SSL
00084             c_ftps_data_udp                = (INT)   989,   //  ftp protocol, data, over TLS/SSL
00085             c_ftps_tcp                     = (INT)   990,   //  ftp protocol, control, over TLS/SSL
00086             c_ftps_udp                     = (INT)   990,   //  ftp protocol, control, over TLS/SSL
00087
00088             c_telnets_tcp                  = (INT)   992,   //  telnet protocol over TLS/SSL
00089             c_telnets_udp                  = (INT)   992,   //  telnet protocol over TLS/SSL
00090             c_imaps_tcp                    = (INT)   993,   //  imap4 protocol over TLS/SSL
00091             c_imaps_udp                    = (INT)   993,   //  imap4 protocol over TLS/SSL
00092             c_ircs_tcp                     = (INT)   994,   //  irc protocol over TLS/SSL
00093             c_ircs_udp                     = (INT)   994,   //  irc protocol over TLS/SSL
00094             c_pop3s_tcp                    = (INT)   995,   //  pop3 protocol over TLS/SSL (was spop3)
00095             c_pop3s_udp                    = (INT)   995,   //  pop3 protocol over TLS/SSL (was spop3)
00096
00097             c_wap_push_tcp                 = (INT)  2948,   //  WAP PUSH
00098             c_wap_push_udp                 = (INT)  2948,   //  WAP PUSH
00099             c_wap_pushsecure_tcp           = (INT)  2949,   //  WAP PUSH SECURE
00100             c_wap_pushsecure_udp           = (INT)  2949,   //  WAP PUSH SECURE
00101
00102             c_wimd_tcp                     = (INT)  2980,   //  Instant Messaging Service
00103             c_wimd_udp                     = (INT)  2980,   //  Instant Messaging Service
00104
00105             c_wap_push_http_tcp            = (INT)  4035,   //  WAP Push OTA-HTTP port
00106             c_wap_push_http_udp            = (INT)  4035,   //  WAP Push OTA-HTTP port
00107             c_wap_push_https_tcp           = (INT)  4036,   //  WAP Push OTA-HTTP secure
00108             c_wap_push_https_udp           = (INT)  4036,   //  WAP Push OTA-HTTP secure
00109
00110             c_wap_wsp_tcp                  = (INT)  9200,   //  WAP connectionless session service
00111             c_wap_wsp_udp                  = (INT)  9200,   //  WAP connectionless session service
00112             c_wap_wsp_wtp_tcp              = (INT)  9201,   //  WAP session service
00113             c_wap_wsp_wtp_udp              = (INT)  9201,   //  WAP session service
00114             c_wap_wsp_s_tcp                = (INT)  9202,   //  WAP secure connectionless session service
00115             c_wap_wsp_s_udp                = (INT)  9202,   //  WAP secure connectionless session service
00116             c_wap_wsp_wtp_s_tcp            = (INT)  9203,   //  WAP secure session service
00117             c_wap_wsp_wtp_s_udp            = (INT)  9203,   //  WAP secure session service
00118             c_wap_vcard_tcp                = (INT)  9204,   //  WAP vCard
00119             c_wap_vcard_udp                = (INT)  9204,   //  WAP vCard
00120             c_wap_vcal_tcp                 = (INT)  9205,   //  WAP vCal
00121             c_wap_vcal_udp                 = (INT)  9205,   //  WAP vCal
00122             c_wap_vcard_s_tcp              = (INT)  9206,   //  WAP vCard Secure
00123             c_wap_vcard_s_udp              = (INT)  9206,   //  WAP vCard Secure
00124             c_wap_vcal_s_tcp               = (INT)  9207,   //  WAP vCal Secure
00125             c_wap_vcal_s_udp               = (INT)  9207,   //  WAP vCal Secure
00126
00127             c_iana_private_ports_begin     = (INT) 49152,   //  Begin of IANA dynamic / private port range
00128             c_iana_private_ports_end       = (INT) 65535,   //  End of IANA dynamic / private port range
00129
00130 #if defined(APOXI_IANA_ALL_PORT_NUMBERS)
00131             c_tcpmux_tcp                   = (INT)     1,   //  TCP Port Service Multiplexer
00132             c_tcpmux_udp                   = (INT)     1,   //  TCP Port Service Multiplexer
00133             c_compressnet_tcp              = (INT)     2,   //  Management Utility
00134             c_compressnet_udp              = (INT)     2,   //  Management Utility
00135             c_compressnet_1_tcp            = (INT)     3,   //  Compression Process
00136             c_compressnet_1_udp            = (INT)     3,   //  Compression Process
00137             c_rje_tcp                      = (INT)     5,   //  Remote Job Entry
00138             c_rje_udp                      = (INT)     5,   //  Remote Job Entry
00139             c_echo_tcp                     = (INT)     7,   //  Echo
00140             c_echo_udp                     = (INT)     7,   //  Echo
00141             c_discard_tcp                  = (INT)     9,   //  Discard
00142             c_discard_udp                  = (INT)     9,   //  Discard
00143             c_systat_tcp                   = (INT)    11,   //  Active Users
00144             c_systat_udp                   = (INT)    11,   //  Active Users
00145             c_daytime_tcp                  = (INT)    13,   //  Daytime (RFC 867)
00146             c_daytime_udp                  = (INT)    13,   //  Daytime (RFC 867)
00147             c_qotd_tcp                     = (INT)    17,   //  Quote of the Day
00148             c_qotd_udp                     = (INT)    17,   //  Quote of the Day
00149             c_msp_tcp                      = (INT)    18,   //  Message Send Protocol
00150             c_msp_udp                      = (INT)    18,   //  Message Send Protocol
00151             c_chargen_tcp                  = (INT)    19,   //  Character Generator
00152             c_chargen_udp                  = (INT)    19,   //  Character Generator
00153
00154             c_nsw_fe_tcp                   = (INT)    27,   //  NSW User System FE
00155             c_nsw_fe_udp                   = (INT)    27,   //  NSW User System FE
00156             c_msg_icp_tcp                  = (INT)    29,   //  MSG ICP
00157             c_msg_icp_udp                  = (INT)    29,   //  MSG ICP
00158             c_msg_auth_tcp                 = (INT)    31,   //  MSG Authentication
00159             c_msg_auth_udp                 = (INT)    31,   //  MSG Authentication
00160             c_dsp_tcp                      = (INT)    33,   //  Display Support Protocol
00161             c_dsp_udp                      = (INT)    33,   //  Display Support Protocol
00162             c_time_tcp                     = (INT)    37,   //  Time
00163             c_time_udp                     = (INT)    37,   //  Time
00164             c_rap_tcp                      = (INT)    38,   //  Route Access Protocol
00165             c_rap_udp                      = (INT)    38,   //  Route Access Protocol
00166             c_rlp_tcp                      = (INT)    39,   //  Resource Location Protocol
00167             c_rlp_udp                      = (INT)    39,   //  Resource Location Protocol
00168             c_graphics_tcp                 = (INT)    41,   //  Graphics
00169             c_graphics_udp                 = (INT)    41,   //  Graphics
00170
00171             c_nicname_tcp                  = (INT)    43,   //  Who Is
00172             c_nicname_udp                  = (INT)    43,   //  Who Is
00173             c_mpm_flags_tcp                = (INT)    44,   //  MPM FLAGS Protocol
00174             c_mpm_flags_udp                = (INT)    44,   //  MPM FLAGS Protocol
00175             c_mpm_tcp                      = (INT)    45,   //  Message Processing Module [recv]
00176             c_mpm_udp                      = (INT)    45,   //  Message Processing Module [recv]
00177             c_mpm_snd_tcp                  = (INT)    46,   //  MPM [default send]
00178             c_mpm_snd_udp                  = (INT)    46,   //  MPM [default send]
00179             c_ni_ftp_tcp                   = (INT)    47,   //  NI FTP
00180             c_ni_ftp_udp                   = (INT)    47,   //  NI FTP
00181             c_auditd_tcp                   = (INT)    48,   //  Digital Audit Daemon
00182             c_auditd_udp                   = (INT)    48,   //  Digital Audit Daemon
00183             c_tacacs_tcp                   = (INT)    49,   //  Login Host Protocol (TACACS)
00184             c_tacacs_udp                   = (INT)    49,   //  Login Host Protocol (TACACS)
00185             c_re_mail_ck_tcp               = (INT)    50,   //  Remote Mail Checking Protocol
00186             c_re_mail_ck_udp               = (INT)    50,   //  Remote Mail Checking Protocol
00187             c_la_maint_tcp                 = (INT)    51,   //  IMP Logical Address Maintenance
00188             c_la_maint_udp                 = (INT)    51,   //  IMP Logical Address Maintenance
00189             c_xns_time_tcp                 = (INT)    52,   //  XNS Time Protocol
00190             c_xns_time_udp                 = (INT)    52,   //  XNS Time Protocol
00191             c_domain_tcp                   = (INT)    53,   //  Domain Name Server
00192             c_domain_udp                   = (INT)    53,   //  Domain Name Server
00193             c_xns_ch_tcp                   = (INT)    54,   //  XNS Clearinghouse
00194             c_xns_ch_udp                   = (INT)    54,   //  XNS Clearinghouse
00195             c_isi_gl_tcp                   = (INT)    55,   //  ISI Graphics Language
00196             c_isi_gl_udp                   = (INT)    55,   //  ISI Graphics Language
00197             c_xns_auth_tcp                 = (INT)    56,   //  XNS Authentication
00198             c_xns_auth_udp                 = (INT)    56,   //  XNS Authentication
00199             c_xns_mail_tcp                 = (INT)    58,   //  XNS Mail
00200             c_xns_mail_udp                 = (INT)    58,   //  XNS Mail
00201             c_ni_mail_tcp                  = (INT)    61,   //  NI MAIL
00202             c_ni_mail_udp                  = (INT)    61,   //  NI MAIL
00203             c_acas_tcp                     = (INT)    62,   //  ACA Services
00204             c_acas_udp                     = (INT)    62,   //  ACA Services
00205             c_covia_tcp                    = (INT)    64,   //  Communications Integrator (CI)
00206             c_covia_udp                    = (INT)    64,   //  Communications Integrator (CI)
00207             c_tacacs_ds_tcp                = (INT)    65,   //  TACACS-Database Service
00208             c_tacacs_ds_udp                = (INT)    65,   //  TACACS-Database Service
00209             c_bootps_tcp                   = (INT)    67,   //  Bootstrap Protocol Server
00210             c_bootps_udp                   = (INT)    67,   //  Bootstrap Protocol Server
00211             c_bootpc_tcp                   = (INT)    68,   //  Bootstrap Protocol Client
00212             c_bootpc_udp                   = (INT)    68,   //  Bootstrap Protocol Client
00213             c_gopher_tcp                   = (INT)    70,   //  Gopher
00214             c_gopher_udp                   = (INT)    70,   //  Gopher
00215             c_netrjs_1_tcp                 = (INT)    71,   //  Remote Job Service
00216             c_netrjs_1_udp                 = (INT)    71,   //  Remote Job Service
00217             c_netrjs_2_tcp                 = (INT)    72,   //  Remote Job Service
00218             c_netrjs_2_udp                 = (INT)    72,   //  Remote Job Service
00219             c_netrjs_3_tcp                 = (INT)    73,   //  Remote Job Service
00220             c_netrjs_3_udp                 = (INT)    73,   //  Remote Job Service
00221             c_netrjs_4_tcp                 = (INT)    74,   //  Remote Job Service
00222             c_netrjs_4_udp                 = (INT)    74,   //  Remote Job Service
00223             c_deos_tcp                     = (INT)    76,   //  Distributed External Object Store
00224             c_deos_udp                     = (INT)    76,   //  Distributed External Object Store
00225             c_vettcp_tcp                   = (INT)    78,   //  vettcp
00226             c_vettcp_udp                   = (INT)    78,   //  vettcp
00227             c_finger_tcp                   = (INT)    79,   //  Finger
00228             c_finger_udp                   = (INT)    79,   //  Finger
00229
00230             c_hosts2_ns_tcp                = (INT)    81,   //  HOSTS2 Name Server
00231             c_hosts2_ns_udp                = (INT)    81,   //  HOSTS2 Name Server
00232             c_xfer_tcp                     = (INT)    82,   //  XFER Utility
00233             c_xfer_udp                     = (INT)    82,   //  XFER Utility
00234             c_mit_ml_dev_tcp               = (INT)    83,   //  MIT ML Device
00235             c_mit_ml_dev_udp               = (INT)    83,   //  MIT ML Device
00236             c_ctf_tcp                      = (INT)    84,   //  Common Trace Facility
00237             c_ctf_udp                      = (INT)    84,   //  Common Trace Facility
00238             c_mit_ml_dev_1_tcp             = (INT)    85,   //  MIT ML Device
00239             c_mit_ml_dev_1_udp             = (INT)    85,   //  MIT ML Device
00240             c_mfcobol_tcp                  = (INT)    86,   //  Micro Focus Cobol
00241             c_mfcobol_udp                  = (INT)    86,   //  Micro Focus Cobol
00242             c_kerberos_tcp                 = (INT)    88,   //  Kerberos
00243             c_kerberos_udp                 = (INT)    88,   //  Kerberos
00244             c_su_mit_tg_tcp                = (INT)    89,   //  SU/MIT Telnet Gateway
00245             c_su_mit_tg_udp                = (INT)    89,   //  SU/MIT Telnet Gateway
00246             c_dnsix_tcp                    = (INT)    90,   //  DNSIX Securit Attribute Token Map
00247             c_dnsix_udp                    = (INT)    90,   //  DNSIX Securit Attribute Token Map
00248             c_mit_dov_tcp                  = (INT)    91,   //  MIT Dover Spooler
00249             c_mit_dov_udp                  = (INT)    91,   //  MIT Dover Spooler
00250             c_npp_tcp                      = (INT)    92,   //  Network Printing Protocol
00251             c_npp_udp                      = (INT)    92,   //  Network Printing Protocol
00252             c_dcp_tcp                      = (INT)    93,   //  Device Control Protocol
00253             c_dcp_udp                      = (INT)    93,   //  Device Control Protocol
00254             c_objcall_tcp                  = (INT)    94,   //  Tivoli Object Dispatcher
00255             c_objcall_udp                  = (INT)    94,   //  Tivoli Object Dispatcher
00256             c_supdup_tcp                   = (INT)    95,   //  SUPDUP
00257             c_supdup_udp                   = (INT)    95,   //  SUPDUP
00258             c_dixie_tcp                    = (INT)    96,   //  DIXIE Protocol Specification
00259             c_dixie_udp                    = (INT)    96,   //  DIXIE Protocol Specification
00260             c_swift_rvf_tcp                = (INT)    97,   //  Swift Remote Virtural File Protocol
00261             c_swift_rvf_udp                = (INT)    97,   //  Swift Remote Virtural File Protocol
00262             c_tacnews_tcp                  = (INT)    98,   //  TAC News
00263             c_tacnews_udp                  = (INT)    98,   //  TAC News
00264             c_metagram_tcp                 = (INT)    99,   //  Metagram Relay
00265             c_metagram_udp                 = (INT)    99,   //  Metagram Relay
00266             c_newacct_tcp                  = (INT)   100,   //  [unauthorized use]
00267             c_hostname_tcp                 = (INT)   101,   //  NIC Host Name Server
00268             c_hostname_udp                 = (INT)   101,   //  NIC Host Name Server
00269             c_iso_tsap_tcp                 = (INT)   102,   //  ISO-TSAP Class 0
00270             c_iso_tsap_udp                 = (INT)   102,   //  ISO-TSAP Class 0
00271             c_gppitnp_tcp                  = (INT)   103,   //  Genesis Point-to-Point Trans Net
00272             c_gppitnp_udp                  = (INT)   103,   //  Genesis Point-to-Point Trans Net
00273             c_acr_nema_tcp                 = (INT)   104,   //  ACR-NEMA Digital Imag. & Comm. 300
00274             c_acr_nema_udp                 = (INT)   104,   //  ACR-NEMA Digital Imag. & Comm. 300
00275             c_cso_tcp                      = (INT)   105,   //  CCSO name server protocol
00276             c_cso_udp                      = (INT)   105,   //  CCSO name server protocol
00277             c_csnet_ns_tcp                 = (INT)   105,   //  Mailbox Name Nameserver
00278             c_csnet_ns_udp                 = (INT)   105,   //  Mailbox Name Nameserver
00279             c_3com_tsmux_tcp               = (INT)   106,   //  3COM-TSMUX
00280             c_3com_tsmux_udp               = (INT)   106,   //  3COM-TSMUX
00281             c_rtelnet_tcp                  = (INT)   107,   //  Remote Telnet Service
00282             c_rtelnet_udp                  = (INT)   107,   //  Remote Telnet Service
00283             c_snagas_tcp                   = (INT)   108,   //  SNA Gateway Access Server
00284             c_snagas_udp                   = (INT)   108,   //  SNA Gateway Access Server
00285             c_pop2_tcp                     = (INT)   109,   //  Post Office Protocol - Version 2
00286             c_pop2_udp                     = (INT)   109,   //  Post Office Protocol - Version 2
00287
00288             c_sunrpc_tcp                   = (INT)   111,   //  SUN Remote Procedure Call
00289             c_sunrpc_udp                   = (INT)   111,   //  SUN Remote Procedure Call
00290             c_mcidas_tcp                   = (INT)   112,   //  McIDAS Data Transmission Protocol
00291             c_mcidas_udp                   = (INT)   112,   //  McIDAS Data Transmission Protocol
00292             c_ident_tcp                    = (INT)   113,   //
00293
00294             c_audionews_tcp                = (INT)   114,   //  Audio News Multicast
00295             c_audionews_udp                = (INT)   114,   //  Audio News Multicast
00296             c_sftp_tcp                     = (INT)   115,   //  Simple File Transfer Protocol
00297             c_sftp_udp                     = (INT)   115,   //  Simple File Transfer Protocol
00298             c_ansanotify_tcp               = (INT)   116,   //  ANSA REX Notify
00299             c_ansanotify_udp               = (INT)   116,   //  ANSA REX Notify
00300             c_uucp_path_tcp                = (INT)   117,   //  UUCP Path Service
00301             c_uucp_path_udp                = (INT)   117,   //  UUCP Path Service
00302             c_sqlserv_tcp                  = (INT)   118,   //  SQL Services
00303             c_sqlserv_udp                  = (INT)   118,   //  SQL Services
00304
00305             c_cfdptkt_tcp                  = (INT)   120,   //  CFDPTKT
00306             c_cfdptkt_udp                  = (INT)   120,   //  CFDPTKT
00307             c_erpc_tcp                     = (INT)   121,   //  Encore Expedited Remote Pro.Call
00308             c_erpc_udp                     = (INT)   121,   //  Encore Expedited Remote Pro.Call
00309             c_smakynet_tcp                 = (INT)   122,   //  SMAKYNET
00310             c_smakynet_udp                 = (INT)   122,   //  SMAKYNET
00311             c_ntp_tcp                      = (INT)   123,   //  Network Time Protocol
00312             c_ntp_udp                      = (INT)   123,   //  Network Time Protocol
00313             c_ansatrader_tcp               = (INT)   124,   //  ANSA REX Trader
00314             c_ansatrader_udp               = (INT)   124,   //  ANSA REX Trader
00315             c_locus_map_tcp                = (INT)   125,   //  Locus PC-Interface Net Map Ser
00316             c_locus_map_udp                = (INT)   125,   //  Locus PC-Interface Net Map Ser
00317             c_nxedit_tcp                   = (INT)   126,   //  NXEdit
00318             c_nxedit_udp                   = (INT)   126,   //  NXEdit
00319             c_locus_con_tcp                = (INT)   127,   //  Locus PC-Interface Conn Server
00320             c_locus_con_udp                = (INT)   127,   //  Locus PC-Interface Conn Server
00321             c_gss_xlicen_tcp               = (INT)   128,   //  GSS X License Verification
00322             c_gss_xlicen_udp               = (INT)   128,   //  GSS X License Verification
00323             c_pwdgen_tcp                   = (INT)   129,   //  Password Generator Protocol
00324             c_pwdgen_udp                   = (INT)   129,   //  Password Generator Protocol
00325             c_cisco_fna_tcp                = (INT)   130,   //  cisco FNATIVE
00326             c_cisco_fna_udp                = (INT)   130,   //  cisco FNATIVE
00327             c_cisco_tna_tcp                = (INT)   131,   //  cisco TNATIVE
00328             c_cisco_tna_udp                = (INT)   131,   //  cisco TNATIVE
00329             c_cisco_sys_tcp                = (INT)   132,   //  cisco SYSMAINT
00330             c_cisco_sys_udp                = (INT)   132,   //  cisco SYSMAINT
00331             c_statsrv_tcp                  = (INT)   133,   //  Statistics Service
00332             c_statsrv_udp                  = (INT)   133,   //  Statistics Service
00333             c_ingres_net_tcp               = (INT)   134,   //  INGRES-NET Service
00334             c_ingres_net_udp               = (INT)   134,   //  INGRES-NET Service
00335             c_epmap_tcp                    = (INT)   135,   //  DCE endpoint resolution
00336             c_epmap_udp                    = (INT)   135,   //  DCE endpoint resolution
00337             c_profile_tcp                  = (INT)   136,   //  PROFILE Naming System
00338             c_profile_udp                  = (INT)   136,   //  PROFILE Naming System
00339             c_netbios_ns_tcp               = (INT)   137,   //  NETBIOS Name Service
00340             c_netbios_ns_udp               = (INT)   137,   //  NETBIOS Name Service
00341             c_netbios_dgm_tcp              = (INT)   138,   //  NETBIOS Datagram Service
00342             c_netbios_dgm_udp              = (INT)   138,   //  NETBIOS Datagram Service
00343             c_netbios_ssn_tcp              = (INT)   139,   //  NETBIOS Session Service
00344             c_netbios_ssn_udp              = (INT)   139,   //  NETBIOS Session Service
00345             c_emfis_data_tcp               = (INT)   140,   //  EMFIS Data Service
00346             c_emfis_data_udp               = (INT)   140,   //  EMFIS Data Service
00347             c_emfis_cntl_tcp               = (INT)   141,   //  EMFIS Control Service
00348             c_emfis_cntl_udp               = (INT)   141,   //  EMFIS Control Service
00349             c_bl_idm_tcp                   = (INT)   142,   //  Britton-Lee IDM
00350             c_bl_idm_udp                   = (INT)   142,   //  Britton-Lee IDM
00351
00352             c_uma_tcp                      = (INT)   144,   //  Universal Management Architecture
00353             c_uma_udp                      = (INT)   144,   //  Universal Management Architecture
00354             c_uaac_tcp                     = (INT)   145,   //  UAAC Protocol
00355             c_uaac_udp                     = (INT)   145,   //  UAAC Protocol
00356             c_iso_tp0_tcp                  = (INT)   146,   //  ISO-IP0
00357             c_iso_tp0_udp                  = (INT)   146,   //  ISO-IP0
00358             c_iso_ip_tcp                   = (INT)   147,   //  ISO-IP
00359             c_iso_ip_udp                   = (INT)   147,   //  ISO-IP
00360             c_jargon_tcp                   = (INT)   148,   //  Jargon
00361             c_jargon_udp                   = (INT)   148,   //  Jargon
00362             c_aed_512_tcp                  = (INT)   149,   //  AED 512 Emulation Service
00363             c_aed_512_udp                  = (INT)   149,   //  AED 512 Emulation Service
00364             c_sql_net_tcp                  = (INT)   150,   //  SQL-NET
00365             c_sql_net_udp                  = (INT)   150,   //  SQL-NET
00366             c_hems_tcp                     = (INT)   151,   //  HEMS
00367             c_hems_udp                     = (INT)   151,   //  HEMS
00368             c_bftp_tcp                     = (INT)   152,   //  Background File Transfer Program
00369             c_bftp_udp                     = (INT)   152,   //  Background File Transfer Program
00370             c_sgmp_tcp                     = (INT)   153,   //  SGMP
00371             c_sgmp_udp                     = (INT)   153,   //  SGMP
00372             c_netsc_prod_tcp               = (INT)   154,   //  NETSC
00373             c_netsc_prod_udp               = (INT)   154,   //  NETSC
00374             c_netsc_dev_tcp                = (INT)   155,   //  NETSC
00375             c_netsc_dev_udp                = (INT)   155,   //  NETSC
00376             c_sqlsrv_tcp                   = (INT)   156,   //  SQL Service
00377             c_sqlsrv_udp                   = (INT)   156,   //  SQL Service
00378             c_knet_cmp_tcp                 = (INT)   157,   //  KNET/VM Command/Message Protocol
00379             c_knet_cmp_udp                 = (INT)   157,   //  KNET/VM Command/Message Protocol
00380             c_pcmail_srv_tcp               = (INT)   158,   //  PCMail Server
00381             c_pcmail_srv_udp               = (INT)   158,   //  PCMail Server
00382             c_nss_routing_tcp              = (INT)   159,   //  NSS-Routing
00383             c_nss_routing_udp              = (INT)   159,   //  NSS-Routing
00384             c_sgmp_traps_tcp               = (INT)   160,   //  SGMP-TRAPS
00385             c_sgmp_traps_udp               = (INT)   160,   //  SGMP-TRAPS
00386             c_snmp_tcp                     = (INT)   161,   //  SNMP
00387             c_snmp_udp                     = (INT)   161,   //  SNMP
00388             c_snmptrap_tcp                 = (INT)   162,   //  SNMPTRAP
00389             c_snmptrap_udp                 = (INT)   162,   //  SNMPTRAP
00390             c_cmip_man_tcp                 = (INT)   163,   //  CMIP/TCP Manager
00391             c_cmip_man_udp                 = (INT)   163,   //  CMIP/TCP Manager
00392             c_cmip_agent_tcp               = (INT)   164,   //  CMIP/TCP Agent
00393             c_cmip_agent_udp               = (INT)   164,   //  CMIP/TCP Agent
00394             c_xns_courier_tcp              = (INT)   165,   //  Xerox
00395             c_xns_courier_udp              = (INT)   165,   //  Xerox
00396             c_s_net_tcp                    = (INT)   166,   //  Sirius Systems
00397             c_s_net_udp                    = (INT)   166,   //  Sirius Systems
00398             c_namp_tcp                     = (INT)   167,   //  NAMP
00399             c_namp_udp                     = (INT)   167,   //  NAMP
00400             c_rsvd_tcp                     = (INT)   168,   //  RSVD
00401             c_rsvd_udp                     = (INT)   168,   //  RSVD
00402             c_send_tcp                     = (INT)   169,   //  SEND
00403             c_send_udp                     = (INT)   169,   //  SEND
00404             c_print_srv_tcp                = (INT)   170,   //  Network PostScript
00405             c_print_srv_udp                = (INT)   170,   //  Network PostScript
00406             c_multiplex_tcp                = (INT)   171,   //  Network Innovations Multiplex
00407             c_multiplex_udp                = (INT)   171,   //  Network Innovations Multiplex
00408             c_xyplex_mux_tcp               = (INT)   173,   //  Xyplex
00409             c_xyplex_mux_udp               = (INT)   173,   //  Xyplex
00410             c_mailq_tcp                    = (INT)   174,   //  MAILQ
00411             c_mailq_udp                    = (INT)   174,   //  MAILQ
00412             c_vmnet_tcp                    = (INT)   175,   //  VMNET
00413             c_vmnet_udp                    = (INT)   175,   //  VMNET
00414             c_genrad_mux_tcp               = (INT)   176,   //  GENRAD-MUX
00415             c_genrad_mux_udp               = (INT)   176,   //  GENRAD-MUX
00416             c_xdmcp_tcp                    = (INT)   177,   //  X Display Manager Control Protocol
00417             c_xdmcp_udp                    = (INT)   177,   //  X Display Manager Control Protocol
00418             c_nextstep_tcp                 = (INT)   178,   //  NextStep Window Server
00419             c_nextstep_udp                 = (INT)   178,   //  NextStep Window Server
00420             c_bgp_tcp                      = (INT)   179,   //  Border Gateway Protocol
00421             c_bgp_udp                      = (INT)   179,   //  Border Gateway Protocol
00422             c_ris_tcp                      = (INT)   180,   //  Intergraph
00423             c_ris_udp                      = (INT)   180,   //  Intergraph
00424             c_unify_tcp                    = (INT)   181,   //  Unify
00425             c_unify_udp                    = (INT)   181,   //  Unify
00426             c_audit_tcp                    = (INT)   182,   //  Unisys Audit SITP
00427             c_audit_udp                    = (INT)   182,   //  Unisys Audit SITP
00428             c_ocbinder_tcp                 = (INT)   183,   //  OCBinder
00429             c_ocbinder_udp                 = (INT)   183,   //  OCBinder
00430             c_ocserver_tcp                 = (INT)   184,   //  OCServer
00431             c_ocserver_udp                 = (INT)   184,   //  OCServer
00432             c_remote_kis_tcp               = (INT)   185,   //  Remote-KIS
00433             c_remote_kis_udp               = (INT)   185,   //  Remote-KIS
00434             c_kis_tcp                      = (INT)   186,   //  KIS Protocol
00435             c_kis_udp                      = (INT)   186,   //  KIS Protocol
00436             c_aci_tcp                      = (INT)   187,   //  Application Communication Interface
00437             c_aci_udp                      = (INT)   187,   //  Application Communication Interface
00438             c_mumps_tcp                    = (INT)   188,   //  Plus Five's MUMPS
00439             c_mumps_udp                    = (INT)   188,   //  Plus Five's MUMPS
00440             c_qft_tcp                      = (INT)   189,   //  Queued File Transport
00441             c_qft_udp                      = (INT)   189,   //  Queued File Transport
00442             c_gacp_tcp                     = (INT)   190,   //  Gateway Access Control Protocol
00443             c_gacp_udp                     = (INT)   190,   //  Gateway Access Control Protocol
00444             c_prospero_tcp                 = (INT)   191,   //  Prospero Directory Service
00445             c_prospero_udp                 = (INT)   191,   //  Prospero Directory Service
00446             c_osu_nms_tcp                  = (INT)   192,   //  OSU Network Monitoring System
00447             c_osu_nms_udp                  = (INT)   192,   //  OSU Network Monitoring System
00448             c_srmp_tcp                     = (INT)   193,   //  Spider Remote Monitoring Protocol
00449             c_srmp_udp                     = (INT)   193,   //  Spider Remote Monitoring Protocol
00450
00451             c_dn6_nlm_aud_tcp              = (INT)   195,   //  DNSIX Network Level Module Audit
00452             c_dn6_nlm_aud_udp              = (INT)   195,   //  DNSIX Network Level Module Audit
00453             c_dn6_smm_red_tcp              = (INT)   196,   //  DNSIX Session Mgt Module Audit Redir
00454             c_dn6_smm_red_udp              = (INT)   196,   //  DNSIX Session Mgt Module Audit Redir
00455             c_dls_tcp                      = (INT)   197,   //  Directory Location Service
00456             c_dls_udp                      = (INT)   197,   //  Directory Location Service
00457             c_dls_mon_tcp                  = (INT)   198,   //  Directory Location Service Monitor
00458             c_dls_mon_udp                  = (INT)   198,   //  Directory Location Service Monitor
00459             c_smux_tcp                     = (INT)   199,   //  SMUX
00460             c_smux_udp                     = (INT)   199,   //  SMUX
00461             c_src_tcp                      = (INT)   200,   //  IBM System Resource Controller
00462             c_src_udp                      = (INT)   200,   //  IBM System Resource Controller
00463             c_at_rtmp_tcp                  = (INT)   201,   //  AppleTalk Routing Maintenance
00464             c_at_rtmp_udp                  = (INT)   201,   //  AppleTalk Routing Maintenance
00465             c_at_nbp_tcp                   = (INT)   202,   //  AppleTalk Name Binding
00466             c_at_nbp_udp                   = (INT)   202,   //  AppleTalk Name Binding
00467             c_at_3_tcp                     = (INT)   203,   //  AppleTalk Unused
00468             c_at_3_udp                     = (INT)   203,   //  AppleTalk Unused
00469             c_at_echo_tcp                  = (INT)   204,   //  AppleTalk Echo
00470             c_at_echo_udp                  = (INT)   204,   //  AppleTalk Echo
00471             c_at_5_tcp                     = (INT)   205,   //  AppleTalk Unused
00472             c_at_5_udp                     = (INT)   205,   //  AppleTalk Unused
00473             c_at_zis_tcp                   = (INT)   206,   //  AppleTalk Zone Information
00474             c_at_zis_udp                   = (INT)   206,   //  AppleTalk Zone Information
00475             c_at_7_tcp                     = (INT)   207,   //  AppleTalk Unused
00476             c_at_7_udp                     = (INT)   207,   //  AppleTalk Unused
00477             c_at_8_tcp                     = (INT)   208,   //  AppleTalk Unused
00478             c_at_8_udp                     = (INT)   208,   //  AppleTalk Unused
00479             c_qmtp_tcp                     = (INT)   209,   //  The Quick Mail Transfer Protocol
00480             c_qmtp_udp                     = (INT)   209,   //  The Quick Mail Transfer Protocol
00481             c_anet_tcp                     = (INT)   212,   //  ATEXSSTR
00482             c_anet_udp                     = (INT)   212,   //  ATEXSSTR
00483             c_ipx_tcp                      = (INT)   213,   //  IPX
00484             c_ipx_udp                      = (INT)   213,   //  IPX
00485             c_vmpwscs_tcp                  = (INT)   214,   //  VM PWSCS
00486             c_vmpwscs_udp                  = (INT)   214,   //  VM PWSCS
00487             c_softpc_tcp                   = (INT)   215,   //  Insignia Solutions
00488             c_softpc_udp                   = (INT)   215,   //  Insignia Solutions
00489             c_dbase_tcp                    = (INT)   217,   //  dBASE Unix
00490             c_dbase_udp                    = (INT)   217,   //  dBASE Unix
00491             c_mpp_tcp                      = (INT)   218,   //  Netix Message Posting Protocol
00492             c_mpp_udp                      = (INT)   218,   //  Netix Message Posting Protocol
00493             c_uarps_tcp                    = (INT)   219,   //  Unisys ARPs
00494             c_uarps_udp                    = (INT)   219,   //  Unisys ARPs
00495
00496             c_fln_spx_tcp                  = (INT)   221,   //  Berkeley rlogind with SPX auth
00497             c_fln_spx_udp                  = (INT)   221,   //  Berkeley rlogind with SPX auth
00498             c_rsh_spx_tcp                  = (INT)   222,   //  Berkeley rshd with SPX auth
00499             c_rsh_spx_udp                  = (INT)   222,   //  Berkeley rshd with SPX auth
00500             c_cdc_tcp                      = (INT)   223,   //  Certificate Distribution Center
00501             c_cdc_udp                      = (INT)   223,   //  Certificate Distribution Center
00502             c_masqdialer_tcp               = (INT)   224,   //  masqdialer
00503             c_masqdialer_udp               = (INT)   224,   //  masqdialer
00504             c_direct_tcp                   = (INT)   242,   //  Direct
00505             c_direct_udp                   = (INT)   242,   //  Direct
00506             c_sur_meas_tcp                 = (INT)   243,   //  Survey Measurement
00507             c_sur_meas_udp                 = (INT)   243,   //  Survey Measurement
00508             c_inbusiness_tcp               = (INT)   244,   //  inbusiness
00509             c_inbusiness_udp               = (INT)   244,   //  inbusiness
00510             c_link_tcp                     = (INT)   245,   //  LINK
00511             c_link_udp                     = (INT)   245,   //  LINK
00512             c_dsp3270_tcp                  = (INT)   246,   //  Display Systems Protocol
00513             c_dsp3270_udp                  = (INT)   246,   //  Display Systems Protocol
00514             c_bhfhs_tcp                    = (INT)   248,   //  bhfhs
00515             c_bhfhs_udp                    = (INT)   248,   //  bhfhs
00516             c_rap_1_tcp                    = (INT)   256,   //  RAP
00517             c_rap_1_udp                    = (INT)   256,   //  RAP
00518
00519             c_yak_chat_tcp                 = (INT)   258,   //  Yak Winsock Personal Chat
00520             c_yak_chat_udp                 = (INT)   258,   //  Yak Winsock Personal Chat
00521             c_esro_gen_tcp                 = (INT)   259,   //  Efficient Short Remote Operations
00522             c_esro_gen_udp                 = (INT)   259,   //  Efficient Short Remote Operations
00523             c_openport_tcp                 = (INT)   260,   //  Openport
00524             c_openport_udp                 = (INT)   260,   //  Openport
00525             c_nsiiops_tcp                  = (INT)   261,   //  IIOP Name Service over TLS/SSL
00526             c_nsiiops_udp                  = (INT)   261,   //  IIOP Name Service over TLS/SSL
00527             c_arcisdms_tcp                 = (INT)   262,   //  Arcisdms
00528             c_arcisdms_udp                 = (INT)   262,   //  Arcisdms
00529             c_hdap_tcp                     = (INT)   263,   //  HDAP
00530             c_hdap_udp                     = (INT)   263,   //  HDAP
00531             c_bgmp_tcp                     = (INT)   264,   //  BGMP
00532             c_bgmp_udp                     = (INT)   264,   //  BGMP
00533             c_x_bone_ctl_tcp               = (INT)   265,   //  X-Bone CTL
00534             c_x_bone_ctl_udp               = (INT)   265,   //  X-Bone CTL
00535             c_sst_tcp                      = (INT)   266,   //  SCSI on ST
00536             c_sst_udp                      = (INT)   266,   //  SCSI on ST
00537             c_td_service_tcp               = (INT)   267,   //  Tobit David Service Layer
00538             c_td_service_udp               = (INT)   267,   //  Tobit David Service Layer
00539             c_td_replica_tcp               = (INT)   268,   //  Tobit David Replica
00540             c_td_replica_udp               = (INT)   268,   //  Tobit David Replica
00541             c_http_mgmt_tcp                = (INT)   280,   //  http-mgmt
00542             c_http_mgmt_udp                = (INT)   280,   //  http-mgmt
00543             c_personal_link_tcp            = (INT)   281,   //  Personal Link
00544             c_personal_link_udp            = (INT)   281,   //  Personal Link
00545             c_cableport_ax_tcp             = (INT)   282,   //  Cable Port A/X
00546             c_cableport_ax_udp             = (INT)   282,   //  Cable Port A/X
00547             c_rescap_tcp                   = (INT)   283,   //  rescap
00548             c_rescap_udp                   = (INT)   283,   //  rescap
00549             c_corerjd_tcp                  = (INT)   284,   //  corerjd
00550             c_corerjd_udp                  = (INT)   284,   //  corerjd
00551             c_fxp_1_tcp                    = (INT)   286,   //  FXP-1
00552             c_fxp_1_udp                    = (INT)   286,   //  FXP-1
00553             c_k_block_tcp                  = (INT)   287,   //  K-BLOCK
00554             c_k_block_udp                  = (INT)   287,   //  K-BLOCK
00555             c_novastorbakcup_tcp           = (INT)   308,   //  Novastor Backup
00556             c_novastorbakcup_udp           = (INT)   308,   //  Novastor Backup
00557             c_entrusttime_tcp              = (INT)   309,   //  EntrustTime
00558             c_entrusttime_udp              = (INT)   309,   //  EntrustTime
00559             c_bhmds_tcp                    = (INT)   310,   //  bhmds
00560             c_bhmds_udp                    = (INT)   310,   //  bhmds
00561             c_asip_webadmin_tcp            = (INT)   311,   //  AppleShare IP WebAdmin
00562             c_asip_webadmin_udp            = (INT)   311,   //  AppleShare IP WebAdmin
00563             c_vslmp_tcp                    = (INT)   312,   //  VSLMP
00564             c_vslmp_udp                    = (INT)   312,   //  VSLMP
00565             c_magenta_logic_tcp            = (INT)   313,   //  Magenta Logic
00566             c_magenta_logic_udp            = (INT)   313,   //  Magenta Logic
00567             c_opalis_robot_tcp             = (INT)   314,   //  Opalis Robot
00568             c_opalis_robot_udp             = (INT)   314,   //  Opalis Robot
00569             c_dpsi_tcp                     = (INT)   315,   //  DPSI
00570             c_dpsi_udp                     = (INT)   315,   //  DPSI
00571             c_decauth_tcp                  = (INT)   316,   //  decAuth
00572             c_decauth_udp                  = (INT)   316,   //  decAuth
00573             c_zannet_tcp                   = (INT)   317,   //  Zannet
00574             c_zannet_udp                   = (INT)   317,   //  Zannet
00575             c_pkix_timestamp_tcp           = (INT)   318,   //  PKIX TimeStamp
00576             c_pkix_timestamp_udp           = (INT)   318,   //  PKIX TimeStamp
00577             c_ptp_event_tcp                = (INT)   319,   //  PTP Event
00578             c_ptp_event_udp                = (INT)   319,   //  PTP Event
00579             c_ptp_general_tcp              = (INT)   320,   //  PTP General
00580             c_ptp_general_udp              = (INT)   320,   //  PTP General
00581             c_pip_tcp                      = (INT)   321,   //  PIP
00582             c_pip_udp                      = (INT)   321,   //  PIP
00583             c_rtsps_tcp                    = (INT)   322,   //  RTSPS
00584             c_rtsps_udp                    = (INT)   322,   //  RTSPS
00585             c_texar_tcp                    = (INT)   333,   //  Texar Security Port
00586             c_texar_udp                    = (INT)   333,   //  Texar Security Port
00587             c_pdap_tcp                     = (INT)   344,   //  Prospero Data Access Protocol
00588             c_pdap_udp                     = (INT)   344,   //  Prospero Data Access Protocol
00589             c_pawserv_tcp                  = (INT)   345,   //  Perf Analysis Workbench
00590             c_pawserv_udp                  = (INT)   345,   //  Perf Analysis Workbench
00591             c_zserv_tcp                    = (INT)   346,   //  Zebra server
00592             c_zserv_udp                    = (INT)   346,   //  Zebra server
00593             c_fatserv_tcp                  = (INT)   347,   //  Fatmen Server
00594             c_fatserv_udp                  = (INT)   347,   //  Fatmen Server
00595             c_csi_sgwp_tcp                 = (INT)   348,   //  Cabletron Management Protocol
00596             c_csi_sgwp_udp                 = (INT)   348,   //  Cabletron Management Protocol
00597             c_mftp_tcp                     = (INT)   349,   //  mftp
00598             c_mftp_udp                     = (INT)   349,   //  mftp
00599             c_matip_type_a_tcp             = (INT)   350,   //  MATIP Type A
00600             c_matip_type_a_udp             = (INT)   350,   //  MATIP Type A
00601             c_matip_type_b_tcp             = (INT)   351,   //  MATIP Type B
00602             c_matip_type_b_udp             = (INT)   351,   //  MATIP Type B
00603             c_bhoetty_tcp                  = (INT)   351,   //  bhoetty (added 5/21/97)
00604             c_bhoetty_udp                  = (INT)   351,   //  bhoetty
00605             c_dtag_ste_sb_tcp              = (INT)   352,   //  DTAG (assigned long ago)
00606             c_dtag_ste_sb_udp              = (INT)   352,   //  DTAG
00607             c_bhoedap4_tcp                 = (INT)   352,   //  bhoedap4 (added 5/21/97)
00608             c_bhoedap4_udp                 = (INT)   352,   //  bhoedap4
00609             c_ndsauth_tcp                  = (INT)   353,   //  NDSAUTH
00610             c_ndsauth_udp                  = (INT)   353,   //  NDSAUTH
00611             c_bh611_tcp                    = (INT)   354,   //  bh611
00612             c_bh611_udp                    = (INT)   354,   //  bh611
00613             c_datex_asn_tcp                = (INT)   355,   //  DATEX-ASN
00614             c_datex_asn_udp                = (INT)   355,   //  DATEX-ASN
00615             c_cloanto_net_1_tcp            = (INT)   356,   //  Cloanto Net 1
00616             c_cloanto_net_1_udp            = (INT)   356,   //  Cloanto Net 1
00617             c_bhevent_tcp                  = (INT)   357,   //  bhevent
00618             c_bhevent_udp                  = (INT)   357,   //  bhevent
00619             c_shrinkwrap_tcp               = (INT)   358,   //  Shrinkwrap
00620             c_shrinkwrap_udp               = (INT)   358,   //  Shrinkwrap
00621             c_nsrmp_tcp                    = (INT)   359,   //  Network Security Risk Management Protocol
00622             c_nsrmp_udp                    = (INT)   359,   //  Network Security Risk Management Protocol
00623             c_scoi2odialog_tcp             = (INT)   360,   //  scoi2odialog
00624             c_scoi2odialog_udp             = (INT)   360,   //  scoi2odialog
00625             c_semantix_tcp                 = (INT)   361,   //  Semantix
00626             c_semantix_udp                 = (INT)   361,   //  Semantix
00627             c_srssend_tcp                  = (INT)   362,   //  SRS Send
00628             c_srssend_udp                  = (INT)   362,   //  SRS Send
00629             c_aurora_cmgr_tcp              = (INT)   364,   //  Aurora CMGR
00630             c_aurora_cmgr_udp              = (INT)   364,   //  Aurora CMGR
00631             c_dtk_tcp                      = (INT)   365,   //  DTK
00632             c_dtk_udp                      = (INT)   365,   //  DTK
00633             c_odmr_tcp                     = (INT)   366,   //  ODMR
00634             c_odmr_udp                     = (INT)   366,   //  ODMR
00635             c_mortgageware_tcp             = (INT)   367,   //  MortgageWare
00636             c_mortgageware_udp             = (INT)   367,   //  MortgageWare
00637             c_qbikgdp_tcp                  = (INT)   368,   //  QbikGDP
00638             c_qbikgdp_udp                  = (INT)   368,   //  QbikGDP
00639             c_rpc2portmap_tcp              = (INT)   369,   //  rpc2portmap
00640             c_rpc2portmap_udp              = (INT)   369,   //  rpc2portmap
00641             c_codaauth2_tcp                = (INT)   370,   //  codaauth2
00642             c_codaauth2_udp                = (INT)   370,   //  codaauth2
00643             c_clearcase_tcp                = (INT)   371,   //  Clearcase
00644             c_clearcase_udp                = (INT)   371,   //  Clearcase
00645             c_ulistproc_tcp                = (INT)   372,   //  ListProcessor
00646             c_ulistproc_udp                = (INT)   372,   //  ListProcessor
00647             c_legent_1_tcp                 = (INT)   373,   //  Legent Corporation
00648             c_legent_1_udp                 = (INT)   373,   //  Legent Corporation
00649             c_legent_2_tcp                 = (INT)   374,   //  Legent Corporation
00650             c_legent_2_udp                 = (INT)   374,   //  Legent Corporation
00651             c_hassle_tcp                   = (INT)   375,   //  Hassle
00652             c_hassle_udp                   = (INT)   375,   //  Hassle
00653             c_nip_tcp                      = (INT)   376,   //  Amiga Envoy Network Inquiry Proto
00654             c_nip_udp                      = (INT)   376,   //  Amiga Envoy Network Inquiry Proto
00655             c_is99c_tcp                    = (INT)   379,   //  TIA/EIA/IS-99 modem client
00656             c_is99c_udp                    = (INT)   379,   //  TIA/EIA/IS-99 modem client
00657             c_is99s_tcp                    = (INT)   380,   //  TIA/EIA/IS-99 modem server
00658             c_is99s_udp                    = (INT)   380,   //  TIA/EIA/IS-99 modem server
00659             c_hp_collector_tcp             = (INT)   381,   //  hp performance data collector
00660             c_hp_collector_udp             = (INT)   381,   //  hp performance data collector
00661             c_hp_managed_node_tcp          = (INT)   382,   //  hp performance data managed node
00662             c_hp_managed_node_udp          = (INT)   382,   //  hp performance data managed node
00663             c_hp_alarm_mgr_tcp             = (INT)   383,   //  hp performance data alarm manager
00664             c_hp_alarm_mgr_udp             = (INT)   383,   //  hp performance data alarm manager
00665             c_arns_tcp                     = (INT)   384,   //  A Remote Network Server System
00666             c_arns_udp                     = (INT)   384,   //  A Remote Network Server System
00667             c_ibm_app_tcp                  = (INT)   385,   //  IBM Application
00668             c_ibm_app_udp                  = (INT)   385,   //  IBM Application
00669             c_asa_tcp                      = (INT)   386,   //  ASA Message Router Object Def.
00670             c_asa_udp                      = (INT)   386,   //  ASA Message Router Object Def.
00671             c_aurp_tcp                     = (INT)   387,   //  Appletalk Update-Based Routing Pro.
00672             c_aurp_udp                     = (INT)   387,   //  Appletalk Update-Based Routing Pro.
00673             c_unidata_ldm_tcp              = (INT)   388,   //  Unidata LDM
00674             c_unidata_ldm_udp              = (INT)   388,   //  Unidata LDM
00675
00676             c_uis_tcp                      = (INT)   390,   //  UIS
00677             c_uis_udp                      = (INT)   390,   //  UIS
00678             c_synotics_relay_tcp           = (INT)   391,   //  SynOptics SNMP Relay Port
00679             c_synotics_relay_udp           = (INT)   391,   //  SynOptics SNMP Relay Port
00680             c_synotics_broker_tcp          = (INT)   392,   //  SynOptics Port Broker Port
00681             c_synotics_broker_udp          = (INT)   392,   //  SynOptics Port Broker Port
00682             c_meta5_tcp                    = (INT)   393,   //  Meta5
00683             c_meta5_udp                    = (INT)   393,   //  Meta5
00684             c_embl_ndt_tcp                 = (INT)   394,   //  EMBL Nucleic Data Transfer
00685             c_embl_ndt_udp                 = (INT)   394,   //  EMBL Nucleic Data Transfer
00686             c_netcp_tcp                    = (INT)   395,   //  NETscout Control Protocol
00687             c_netcp_udp                    = (INT)   395,   //  NETscout Control Protocol
00688             c_netware_ip_tcp               = (INT)   396,   //  Novell Netware over IP
00689             c_netware_ip_udp               = (INT)   396,   //  Novell Netware over IP
00690             c_mptn_tcp                     = (INT)   397,   //  Multi Protocol Trans. Net.
00691             c_mptn_udp                     = (INT)   397,   //  Multi Protocol Trans. Net.
00692             c_kryptolan_tcp                = (INT)   398,   //  Kryptolan
00693             c_kryptolan_udp                = (INT)   398,   //  Kryptolan
00694             c_iso_tsap_c2_tcp              = (INT)   399,   //  ISO Transport Class 2 Non-Control over TCP
00695             c_iso_tsap_c2_udp              = (INT)   399,   //  ISO Transport Class 2 Non-Control over TCP
00696             c_work_sol_tcp                 = (INT)   400,   //  Workstation Solutions
00697             c_work_sol_udp                 = (INT)   400,   //  Workstation Solutions
00698             c_ups_tcp                      = (INT)   401,   //  Uninterruptible Power Supply
00699             c_ups_udp                      = (INT)   401,   //  Uninterruptible Power Supply
00700             c_genie_tcp                    = (INT)   402,   //  Genie Protocol
00701             c_genie_udp                    = (INT)   402,   //  Genie Protocol
00702             c_decap_tcp                    = (INT)   403,   //  decap
00703             c_decap_udp                    = (INT)   403,   //  decap
00704             c_nced_tcp                     = (INT)   404,   //  nced
00705             c_nced_udp                     = (INT)   404,   //  nced
00706             c_ncld_tcp                     = (INT)   405,   //  ncld
00707             c_ncld_udp                     = (INT)   405,   //  ncld
00708             c_imsp_tcp                     = (INT)   406,   //  Interactive Mail Support Protocol
00709             c_imsp_udp                     = (INT)   406,   //  Interactive Mail Support Protocol
00710             c_timbuktu_tcp                 = (INT)   407,   //  Timbuktu
00711             c_timbuktu_udp                 = (INT)   407,   //  Timbuktu
00712             c_prm_sm_tcp                   = (INT)   408,   //  Prospero Resource Manager Sys. Man.
00713             c_prm_sm_udp                   = (INT)   408,   //  Prospero Resource Manager Sys. Man.
00714             c_prm_nm_tcp                   = (INT)   409,   //  Prospero Resource Manager Node Man.
00715             c_prm_nm_udp                   = (INT)   409,   //  Prospero Resource Manager Node Man.
00716             c_decladebug_tcp               = (INT)   410,   //  DECLadebug Remote Debug Protocol
00717             c_decladebug_udp               = (INT)   410,   //  DECLadebug Remote Debug Protocol
00718             c_rmt_tcp                      = (INT)   411,   //  Remote MT Protocol
00719             c_rmt_udp                      = (INT)   411,   //  Remote MT Protocol
00720             c_synoptics_trap_tcp           = (INT)   412,   //  Trap Convention Port
00721             c_synoptics_trap_udp           = (INT)   412,   //  Trap Convention Port
00722             c_smsp_tcp                     = (INT)   413,   //  Storage Management Services Protocol
00723             c_smsp_udp                     = (INT)   413,   //  Storage Management Services Protocol
00724             c_infoseek_tcp                 = (INT)   414,   //  InfoSeek
00725             c_infoseek_udp                 = (INT)   414,   //  InfoSeek
00726             c_bnet_tcp                     = (INT)   415,   //  BNet
00727             c_bnet_udp                     = (INT)   415,   //  BNet
00728             c_silverplatter_tcp            = (INT)   416,   //  Silverplatter
00729             c_silverplatter_udp            = (INT)   416,   //  Silverplatter
00730             c_onmux_tcp                    = (INT)   417,   //  Onmux
00731             c_onmux_udp                    = (INT)   417,   //  Onmux
00732             c_hyper_g_tcp                  = (INT)   418,   //  Hyper-G
00733             c_hyper_g_udp                  = (INT)   418,   //  Hyper-G
00734             c_ariel1_tcp                   = (INT)   419,   //  Ariel
00735             c_ariel1_udp                   = (INT)   419,   //  Ariel
00736             c_smpte_tcp                    = (INT)   420,   //  SMPTE
00737             c_smpte_udp                    = (INT)   420,   //  SMPTE
00738             c_ariel2_tcp                   = (INT)   421,   //  Ariel
00739             c_ariel2_udp                   = (INT)   421,   //  Ariel
00740             c_ariel3_tcp                   = (INT)   422,   //  Ariel
00741             c_ariel3_udp                   = (INT)   422,   //  Ariel
00742             c_opc_job_start_tcp            = (INT)   423,   //  IBM Operations Planning and Control Start
00743             c_opc_job_start_udp            = (INT)   423,   //  IBM Operations Planning and Control Start
00744             c_opc_job_track_tcp            = (INT)   424,   //  IBM Operations Planning and Control Track
00745             c_opc_job_track_udp            = (INT)   424,   //  IBM Operations Planning and Control Track
00746             c_icad_el_tcp                  = (INT)   425,   //  ICAD
00747             c_icad_el_udp                  = (INT)   425,   //  ICAD
00748             c_smartsdp_tcp                 = (INT)   426,   //  smartsdp
00749             c_smartsdp_udp                 = (INT)   426,   //  smartsdp
00750             c_svrloc_tcp                   = (INT)   427,   //  Server Location
00751             c_svrloc_udp                   = (INT)   427,   //  Server Location
00752             c_utmpsd_tcp                   = (INT)   430,   //  UTMPSD
00753             c_utmpsd_udp                   = (INT)   430,   //  UTMPSD
00754             c_utmpcd_tcp                   = (INT)   431,   //  UTMPCD
00755             c_utmpcd_udp                   = (INT)   431,   //  UTMPCD
00756             c_iasd_tcp                     = (INT)   432,   //  IASD
00757             c_iasd_udp                     = (INT)   432,   //  IASD
00758             c_nnsp_tcp                     = (INT)   433,   //  NNSP
00759             c_nnsp_udp                     = (INT)   433,   //  NNSP
00760             c_mobileip_agent_tcp           = (INT)   434,   //  MobileIP-Agent
00761             c_mobileip_agent_udp           = (INT)   434,   //  MobileIP-Agent
00762             c_mobilip_mn_tcp               = (INT)   435,   //  MobilIP-MN
00763             c_mobilip_mn_udp               = (INT)   435,   //  MobilIP-MN
00764             c_dna_cml_tcp                  = (INT)   436,   //  DNA-CML
00765             c_dna_cml_udp                  = (INT)   436,   //  DNA-CML
00766             c_comscm_tcp                   = (INT)   437,   //  comscm
00767             c_comscm_udp                   = (INT)   437,   //  comscm
00768             c_dsfgw_tcp                    = (INT)   438,   //  dsfgw
00769             c_dsfgw_udp                    = (INT)   438,   //  dsfgw
00770             c_dasp_tcp                     = (INT)   439,   //  dasp Thomas Obermair
00771             c_dasp_udp                     = (INT)   439,   //  dasp tommy@inlab.m.eunet.de
00772             c_sgcp_tcp                     = (INT)   440,   //  sgcp
00773             c_sgcp_udp                     = (INT)   440,   //  sgcp
00774             c_decvms_sysmgt_tcp            = (INT)   441,   //  decvms-sysmgt
00775             c_decvms_sysmgt_udp            = (INT)   441,   //  decvms-sysmgt
00776
00777             c_snpp_tcp                     = (INT)   444,   //  Simple Network Paging Protocol
00778             c_snpp_udp                     = (INT)   444,   //  Simple Network Paging Protocol
00779             c_microsoft_ds_tcp             = (INT)   445,   //  Microsoft-DS
00780             c_microsoft_ds_udp             = (INT)   445,   //  Microsoft-DS
00781             c_ddm_rdb_tcp                  = (INT)   446,   //  DDM-RDB
00782             c_ddm_rdb_udp                  = (INT)   446,   //  DDM-RDB
00783             c_ddm_dfm_tcp                  = (INT)   447,   //  DDM-RFM
00784             c_ddm_dfm_udp                  = (INT)   447,   //  DDM-RFM
00785             c_ddm_ssl_tcp                  = (INT)   448,   //  DDM-SSL
00786             c_ddm_ssl_udp                  = (INT)   448,   //  DDM-SSL
00787             c_as_servermap_tcp             = (INT)   449,   //  AS Server Mapper
00788             c_as_servermap_udp             = (INT)   449,   //  AS Server Mapper
00789             c_tserver_tcp                  = (INT)   450,   //  TServer
00790             c_tserver_udp                  = (INT)   450,   //  TServer
00791             c_sfs_smp_net_tcp              = (INT)   451,   //  Cray Network Semaphore server
00792             c_sfs_smp_net_udp              = (INT)   451,   //  Cray Network Semaphore server
00793             c_sfs_config_tcp               = (INT)   452,   //  Cray SFS config server
00794             c_sfs_config_udp               = (INT)   452,   //  Cray SFS config server
00795             c_creativeserver_tcp           = (INT)   453,   //  CreativeServer
00796             c_creativeserver_udp           = (INT)   453,   //  CreativeServer
00797             c_contentserver_tcp            = (INT)   454,   //  ContentServer
00798             c_contentserver_udp            = (INT)   454,   //  ContentServer
00799             c_creativepartnr_tcp           = (INT)   455,   //  CreativePartnr
00800             c_creativepartnr_udp           = (INT)   455,   //  CreativePartnr
00801             c_macon_tcp_tcp                = (INT)   456,   //  macon-tcp
00802             c_macon_udp_udp                = (INT)   456,   //  macon-udp
00803             c_scohelp_tcp                  = (INT)   457,   //  scohelp
00804             c_scohelp_udp                  = (INT)   457,   //  scohelp
00805             c_appleqtc_tcp                 = (INT)   458,   //  apple quick time
00806             c_appleqtc_udp                 = (INT)   458,   //  apple quick time
00807             c_ampr_rcmd_tcp                = (INT)   459,   //  ampr-rcmd
00808             c_ampr_rcmd_udp                = (INT)   459,   //  ampr-rcmd
00809             c_skronk_tcp                   = (INT)   460,   //  skronk
00810             c_skronk_udp                   = (INT)   460,   //  skronk
00811             c_datasurfsrv_tcp              = (INT)   461,   //  DataRampSrv
00812             c_datasurfsrv_udp              = (INT)   461,   //  DataRampSrv
00813             c_datasurfsrvsec_tcp           = (INT)   462,   //  DataRampSrvSec
00814             c_datasurfsrvsec_udp           = (INT)   462,   //  DataRampSrvSec
00815             c_alpes_tcp                    = (INT)   463,   //  alpes
00816             c_alpes_udp                    = (INT)   463,   //  alpes
00817             c_kpasswd_tcp                  = (INT)   464,   //  kpasswd
00818             c_kpasswd_udp                  = (INT)   464,   //  kpasswd
00819             c_urd_tcp                      = (INT)   465,   //  URL Rendesvous Directory for SSM
00820             c_igmpv3lite_udp               = (INT)   465,   //  IGMP over UDP for SSM
00821             c_digital_vrc_tcp              = (INT)   466,   //  digital-vrc
00822             c_digital_vrc_udp              = (INT)   466,   //  digital-vrc
00823             c_mylex_mapd_tcp               = (INT)   467,   //  mylex-mapd
00824             c_mylex_mapd_udp               = (INT)   467,   //  mylex-mapd
00825             c_photuris_tcp                 = (INT)   468,   //  proturis
00826             c_photuris_udp                 = (INT)   468,   //  proturis
00827             c_rcp_tcp                      = (INT)   469,   //  Radio Control Protocol
00828             c_rcp_udp                      = (INT)   469,   //  Radio Control Protocol
00829             c_scx_proxy_tcp                = (INT)   470,   //  scx-proxy
00830             c_scx_proxy_udp                = (INT)   470,   //  scx-proxy
00831             c_mondex_tcp                   = (INT)   471,   //  Mondex
00832             c_mondex_udp                   = (INT)   471,   //  Mondex
00833             c_ljk_login_tcp                = (INT)   472,   //  ljk-login
00834             c_ljk_login_udp                = (INT)   472,   //  ljk-login
00835             c_hybrid_pop_tcp               = (INT)   473,   //  hybrid-pop
00836             c_hybrid_pop_udp               = (INT)   473,   //  hybrid-pop
00837             c_tn_tl_w1_tcp                 = (INT)   474,   //  tn-tl-w1
00838             c_tn_tl_w2_udp                 = (INT)   474,   //  tn-tl-w2
00839             c_tcpnethaspsrv_tcp            = (INT)   475,   //  tcpnethaspsrv
00840             c_tcpnethaspsrv_udp            = (INT)   475,   //  tcpnethaspsrv
00841             c_tn_tl_fd1_tcp                = (INT)   476,   //  tn-tl-fd1
00842             c_tn_tl_fd1_udp                = (INT)   476,   //  tn-tl-fd1
00843             c_ss7ns_tcp                    = (INT)   477,   //  ss7ns
00844             c_ss7ns_udp                    = (INT)   477,   //  ss7ns
00845             c_spsc_tcp                     = (INT)   478,   //  spsc
00846             c_spsc_udp                     = (INT)   478,   //  spsc
00847             c_iafserver_tcp                = (INT)   479,   //  iafserver
00848             c_iafserver_udp                = (INT)   479,   //  iafserver
00849             c_iafdbase_tcp                 = (INT)   480,   //  iafdbase
00850             c_iafdbase_udp                 = (INT)   480,   //  iafdbase
00851             c_ph_tcp                       = (INT)   481,   //  Ph service
00852             c_ph_udp                       = (INT)   481,   //  Ph service
00853             c_bgs_nsi_tcp                  = (INT)   482,   //  bgs-nsi
00854             c_bgs_nsi_udp                  = (INT)   482,   //  bgs-nsi
00855             c_ulpnet_tcp                   = (INT)   483,   //  ulpnet
00856             c_ulpnet_udp                   = (INT)   483,   //  ulpnet
00857             c_integra_sme_tcp              = (INT)   484,   //  Integra Software Management Environment
00858             c_integra_sme_udp              = (INT)   484,   //  Integra Software Management Environment
00859             c_powerburst_tcp               = (INT)   485,   //  Air Soft Power Burst
00860             c_powerburst_udp               = (INT)   485,   //  Air Soft Power Burst
00861             c_avian_tcp                    = (INT)   486,   //  avian
00862             c_avian_udp                    = (INT)   486,   //  avian
00863             c_saft_tcp                     = (INT)   487,   //  saft Simple Asynchronous File Transfer
00864             c_saft_udp                     = (INT)   487,   //  saft Simple Asynchronous File Transfer
00865             c_gss_http_tcp                 = (INT)   488,   //  gss-http
00866             c_gss_http_udp                 = (INT)   488,   //  gss-http
00867             c_nest_protocol_tcp            = (INT)   489,   //  nest-protocol
00868             c_nest_protocol_udp            = (INT)   489,   //  nest-protocol
00869             c_micom_pfs_tcp                = (INT)   490,   //  micom-pfs
00870             c_micom_pfs_udp                = (INT)   490,   //  micom-pfs
00871             c_go_login_tcp                 = (INT)   491,   //  go-login
00872             c_go_login_udp                 = (INT)   491,   //  go-login
00873             c_ticf_1_tcp                   = (INT)   492,   //  Transport Independent Convergence for FNA
00874             c_ticf_1_udp                   = (INT)   492,   //  Transport Independent Convergence for FNA
00875             c_ticf_2_tcp                   = (INT)   493,   //  Transport Independent Convergence for FNA
00876             c_ticf_2_udp                   = (INT)   493,   //  Transport Independent Convergence for FNA
00877             c_pov_ray_tcp                  = (INT)   494,   //  POV-Ray
00878             c_pov_ray_udp                  = (INT)   494,   //  POV-Ray
00879             c_intecourier_tcp              = (INT)   495,   //  intecourier
00880             c_intecourier_udp              = (INT)   495,   //  intecourier
00881             c_pim_rp_disc_tcp              = (INT)   496,   //  PIM-RP-DISC
00882             c_pim_rp_disc_udp              = (INT)   496,   //  PIM-RP-DISC
00883             c_dantz_tcp                    = (INT)   497,   //  dantz
00884             c_dantz_udp                    = (INT)   497,   //  dantz
00885             c_siam_tcp                     = (INT)   498,   //  siam
00886             c_siam_udp                     = (INT)   498,   //  siam
00887             c_iso_ill_tcp                  = (INT)   499,   //  ISO ILL Protocol
00888             c_iso_ill_udp                  = (INT)   499,   //  ISO ILL Protocol
00889             c_isakmp_tcp                   = (INT)   500,   //  isakmp
00890             c_isakmp_udp                   = (INT)   500,   //  isakmp
00891             c_stmf_tcp                     = (INT)   501,   //  STMF
00892             c_stmf_udp                     = (INT)   501,   //  STMF
00893             c_asa_appl_proto_tcp           = (INT)   502,   //  asa-appl-proto
00894             c_asa_appl_proto_udp           = (INT)   502,   //  asa-appl-proto
00895             c_intrinsa_tcp                 = (INT)   503,   //  Intrinsa
00896             c_intrinsa_udp                 = (INT)   503,   //  Intrinsa
00897             c_citadel_tcp                  = (INT)   504,   //  citadel
00898             c_citadel_udp                  = (INT)   504,   //  citadel
00899             c_mailbox_lm_tcp               = (INT)   505,   //  mailbox-lm
00900             c_mailbox_lm_udp               = (INT)   505,   //  mailbox-lm
00901             c_ohimsrv_tcp                  = (INT)   506,   //  ohimsrv
00902             c_ohimsrv_udp                  = (INT)   506,   //  ohimsrv
00903             c_crs_tcp                      = (INT)   507,   //  crs
00904             c_crs_udp                      = (INT)   507,   //  crs
00905             c_xvttp_tcp                    = (INT)   508,   //  xvttp
00906             c_xvttp_udp                    = (INT)   508,   //  xvttp
00907             c_snare_tcp                    = (INT)   509,   //  snare
00908             c_snare_udp                    = (INT)   509,   //  snare
00909             c_fcp_tcp                      = (INT)   510,   //  FirstClass Protocol
00910             c_fcp_udp                      = (INT)   510,   //  FirstClass Protocol
00911             c_passgo_tcp                   = (INT)   511,   //  PassGo
00912             c_passgo_udp                   = (INT)   511,   //  PassGo
00913             c_exec_tcp                     = (INT)   512,   //  remote process execution;
00914             c_comsat_udp                   = (INT)   512,   //
00915             c_biff_udp                     = (INT)   512,   //  used by mail system to notify users
00916             c_login_tcp                    = (INT)   513,   //  remote login a la telnet;
00917             c_who_udp                      = (INT)   513,   //  maintains data bases showing who's
00918             c_shell_tcp                    = (INT)   514,   //  cmd
00919             c_syslog_udp                   = (INT)   514,   //
00920             c_printer_tcp                  = (INT)   515,   //  spooler
00921             c_printer_udp                  = (INT)   515,   //  spooler
00922             c_videotex_tcp                 = (INT)   516,   //  videotex
00923             c_videotex_udp                 = (INT)   516,   //  videotex
00924             c_talk_tcp                     = (INT)   517,   //  like tenex link, but across
00925             c_talk_udp                     = (INT)   517,   //  like tenex link, but across
00926             c_ntalk_tcp                    = (INT)   518,   //
00927             c_ntalk_udp                    = (INT)   518,   //
00928             c_utime_tcp                    = (INT)   519,   //  unixtime
00929             c_utime_udp                    = (INT)   519,   //  unixtime
00930             c_efs_tcp                      = (INT)   520,   //  extended file name server
00931             c_router_udp                   = (INT)   520,   //  local routing process (on site);
00932             c_ripng_tcp                    = (INT)   521,   //  ripng
00933             c_ripng_udp                    = (INT)   521,   //  ripng
00934             c_ulp_tcp                      = (INT)   522,   //  ULP
00935             c_ulp_udp                      = (INT)   522,   //  ULP
00936             c_ibm_db2_tcp                  = (INT)   523,   //  IBM-DB2
00937             c_ibm_db2_udp                  = (INT)   523,   //  IBM-DB2
00938             c_ncp_tcp                      = (INT)   524,   //  NCP
00939             c_ncp_udp                      = (INT)   524,   //  NCP
00940             c_timed_tcp                    = (INT)   525,   //  timeserver
00941             c_timed_udp                    = (INT)   525,   //  timeserver
00942             c_tempo_tcp                    = (INT)   526,   //  newdate
00943             c_tempo_udp                    = (INT)   526,   //  newdate
00944             c_stx_tcp                      = (INT)   527,   //  Stock IXChange
00945             c_stx_udp                      = (INT)   527,   //  Stock IXChange
00946             c_custix_tcp                   = (INT)   528,   //  Customer IXChange
00947             c_custix_udp                   = (INT)   528,   //  Customer IXChange
00948             c_irc_serv_tcp                 = (INT)   529,   //  IRC-SERV
00949             c_irc_serv_udp                 = (INT)   529,   //  IRC-SERV
00950             c_courier_tcp                  = (INT)   530,   //  rpc
00951             c_courier_udp                  = (INT)   530,   //  rpc
00952
00953             c_netwall_tcp                  = (INT)   533,   //  for emergency broadcasts
00954             c_netwall_udp                  = (INT)   533,   //  for emergency broadcasts
00955             c_mm_admin_tcp                 = (INT)   534,   //  MegaMedia Admin
00956             c_mm_admin_udp                 = (INT)   534,   //  MegaMedia Admin
00957             c_iiop_tcp                     = (INT)   535,   //  iiop
00958             c_iiop_udp                     = (INT)   535,   //  iiop
00959             c_opalis_rdv_tcp               = (INT)   536,   //  opalis-rdv
00960             c_opalis_rdv_udp               = (INT)   536,   //  opalis-rdv
00961             c_nmsp_tcp                     = (INT)   537,   //  Networked Media Streaming Protocol
00962             c_nmsp_udp                     = (INT)   537,   //  Networked Media Streaming Protocol
00963             c_gdomap_tcp                   = (INT)   538,   //  gdomap
00964             c_gdomap_udp                   = (INT)   538,   //  gdomap
00965             c_apertus_ldp_tcp              = (INT)   539,   //  Apertus Technologies Load Determination
00966             c_apertus_ldp_udp              = (INT)   539,   //  Apertus Technologies Load Determination
00967             c_uucp_tcp                     = (INT)   540,   //  uucpd
00968             c_uucp_udp                     = (INT)   540,   //  uucpd
00969             c_uucp_rlogin_tcp              = (INT)   541,   //  uucp-rlogin
00970             c_uucp_rlogin_udp              = (INT)   541,   //  uucp-rlogin
00971             c_commerce_tcp                 = (INT)   542,   //  commerce
00972             c_commerce_udp                 = (INT)   542,   //  commerce
00973             c_klogin_tcp                   = (INT)   543,   //
00974             c_klogin_udp                   = (INT)   543,   //
00975             c_kshell_tcp                   = (INT)   544,   //  krcmd
00976             c_kshell_udp                   = (INT)   544,   //  krcmd
00977             c_appleqtcsrvr_tcp             = (INT)   545,   //  appleqtcsrvr
00978             c_appleqtcsrvr_udp             = (INT)   545,   //  appleqtcsrvr
00979             c_dhcpv6_client_tcp            = (INT)   546,   //  DHCPv6 Client
00980             c_dhcpv6_client_udp            = (INT)   546,   //  DHCPv6 Client
00981             c_dhcpv6_server_tcp            = (INT)   547,   //  DHCPv6 Server
00982             c_dhcpv6_server_udp            = (INT)   547,   //  DHCPv6 Server
00983             c_afpovertcp_tcp               = (INT)   548,   //  AFP over TCP
00984             c_afpovertcp_udp               = (INT)   548,   //  AFP over TCP
00985             c_idfp_tcp                     = (INT)   549,   //  IDFP
00986             c_idfp_udp                     = (INT)   549,   //  IDFP
00987             c_new_rwho_tcp                 = (INT)   550,   //  new-who
00988             c_new_rwho_udp                 = (INT)   550,   //  new-who
00989             c_cybercash_tcp                = (INT)   551,   //  cybercash
00990             c_cybercash_udp                = (INT)   551,   //  cybercash
00991             c_deviceshare_tcp              = (INT)   552,   //  deviceshare
00992             c_deviceshare_udp              = (INT)   552,   //  deviceshare
00993             c_pirp_tcp                     = (INT)   553,   //  pirp
00994             c_pirp_udp                     = (INT)   553,   //  pirp
00995             c_rtsp_tcp                     = (INT)   554,   //  Real Time Stream Control Protocol
00996             c_rtsp_udp                     = (INT)   554,   //  Real Time Stream Control Protocol
00997             c_dsf_tcp                      = (INT)   555,   //
00998             c_dsf_udp                      = (INT)   555,   //
00999             c_remotefs_tcp                 = (INT)   556,   //  rfs server
01000             c_remotefs_udp                 = (INT)   556,   //  rfs server
01001             c_openvms_sysipc_tcp           = (INT)   557,   //  openvms-sysipc
01002             c_openvms_sysipc_udp           = (INT)   557,   //  openvms-sysipc
01003             c_sdnskmp_tcp                  = (INT)   558,   //  SDNSKMP
01004             c_sdnskmp_udp                  = (INT)   558,   //  SDNSKMP
01005             c_teedtap_tcp                  = (INT)   559,   //  TEEDTAP
01006             c_teedtap_udp                  = (INT)   559,   //  TEEDTAP
01007             c_rmonitor_tcp                 = (INT)   560,   //  rmonitord
01008             c_rmonitor_udp                 = (INT)   560,   //  rmonitord
01009             c_monitor_tcp                  = (INT)   561,   //
01010             c_monitor_udp                  = (INT)   561,   //
01011             c_chshell_tcp                  = (INT)   562,   //  chcmd
01012             c_chshell_udp                  = (INT)   562,   //  chcmd
01013             c_nntps_tcp                    = (INT)   563,   //  nntp protocol over TLS/SSL (was snntp)
01014             c_nntps_udp                    = (INT)   563,   //  nntp protocol over TLS/SSL (was snntp)
01015             c_9pfs_tcp                     = (INT)   564,   //  plan 9 file service
01016             c_9pfs_udp                     = (INT)   564,   //  plan 9 file service
01017             c_whoami_tcp                   = (INT)   565,   //  whoami
01018             c_whoami_udp                   = (INT)   565,   //  whoami
01019             c_streettalk_tcp               = (INT)   566,   //  streettalk
01020             c_streettalk_udp               = (INT)   566,   //  streettalk
01021             c_banyan_rpc_tcp               = (INT)   567,   //  banyan-rpc
01022             c_banyan_rpc_udp               = (INT)   567,   //  banyan-rpc
01023             c_ms_shuttle_tcp               = (INT)   568,   //  microsoft shuttle
01024             c_ms_shuttle_udp               = (INT)   568,   //  microsoft shuttle
01025             c_ms_rome_tcp                  = (INT)   569,   //  microsoft rome
01026             c_ms_rome_udp                  = (INT)   569,   //  microsoft rome
01027             c_meter_tcp                    = (INT)   570,   //  demon
01028             c_meter_udp                    = (INT)   570,   //  demon
01029             c_meter_1_tcp                  = (INT)   571,   //  udemon
01030             c_meter_1_udp                  = (INT)   571,   //  udemon
01031             c_sonar_tcp                    = (INT)   572,   //  sonar
01032             c_sonar_udp                    = (INT)   572,   //  sonar
01033             c_banyan_vip_tcp               = (INT)   573,   //  banyan-vip
01034             c_banyan_vip_udp               = (INT)   573,   //  banyan-vip
01035             c_ftp_agent_tcp                = (INT)   574,   //  FTP Software Agent System
01036             c_ftp_agent_udp                = (INT)   574,   //  FTP Software Agent System
01037             c_vemmi_tcp                    = (INT)   575,   //  VEMMI
01038             c_vemmi_udp                    = (INT)   575,   //  VEMMI
01039             c_ipcd_tcp                     = (INT)   576,   //  ipcd
01040             c_ipcd_udp                     = (INT)   576,   //  ipcd
01041             c_vnas_tcp                     = (INT)   577,   //  vnas
01042             c_vnas_udp                     = (INT)   577,   //  vnas
01043             c_ipdd_tcp                     = (INT)   578,   //  ipdd
01044             c_ipdd_udp                     = (INT)   578,   //  ipdd
01045             c_decbsrv_tcp                  = (INT)   579,   //  decbsrv
01046             c_decbsrv_udp                  = (INT)   579,   //  decbsrv
01047             c_sntp_heartbeat_tcp           = (INT)   580,   //  SNTP HEARTBEAT
01048             c_sntp_heartbeat_udp           = (INT)   580,   //  SNTP HEARTBEAT
01049             c_bdp_tcp                      = (INT)   581,   //  Bundle Discovery Protocol
01050             c_bdp_udp                      = (INT)   581,   //  Bundle Discovery Protocol
01051             c_scc_security_tcp             = (INT)   582,   //  SCC Security
01052             c_scc_security_udp             = (INT)   582,   //  SCC Security
01053             c_philips_vc_tcp               = (INT)   583,   //  Philips Video-Conferencing
01054             c_philips_vc_udp               = (INT)   583,   //  Philips Video-Conferencing
01055             c_keyserver_tcp                = (INT)   584,   //  Key Server
01056             c_keyserver_udp                = (INT)   584,   //  Key Server
01057             c_imap4_ssl_tcp                = (INT)   585,   //  IMAP4+SSL (use 993 instead)
01058             c_imap4_ssl_udp                = (INT)   585,   //  IMAP4+SSL (use 993 instead)
01059             c_password_chg_tcp             = (INT)   586,   //  Password Change
01060             c_password_chg_udp             = (INT)   586,   //  Password Change
01061             c_submission_tcp               = (INT)   587,   //  Submission
01062             c_submission_udp               = (INT)   587,   //  Submission
01063             c_cal_tcp                      = (INT)   588,   //  CAL
01064             c_cal_udp                      = (INT)   588,   //  CAL
01065             c_eyelink_tcp                  = (INT)   589,   //  EyeLink
01066             c_eyelink_udp                  = (INT)   589,   //  EyeLink
01067             c_tns_cml_tcp                  = (INT)   590,   //  TNS CML
01068             c_tns_cml_udp                  = (INT)   590,   //  TNS CML
01069             c_http_alt_tcp                 = (INT)   591,   //  FileMaker, Inc. - HTTP Alternate (see Port 80)
01070             c_http_alt_udp                 = (INT)   591,   //  FileMaker, Inc. - HTTP Alternate (see Port 80)
01071             c_eudora_set_tcp               = (INT)   592,   //  Eudora Set
01072             c_eudora_set_udp               = (INT)   592,   //  Eudora Set
01073             c_http_rpc_epmap_tcp           = (INT)   593,   //  HTTP RPC Ep Map
01074             c_http_rpc_epmap_udp           = (INT)   593,   //  HTTP RPC Ep Map
01075             c_tpip_tcp                     = (INT)   594,   //  TPIP
01076             c_tpip_udp                     = (INT)   594,   //  TPIP
01077             c_cab_protocol_tcp             = (INT)   595,   //  CAB Protocol
01078             c_cab_protocol_udp             = (INT)   595,   //  CAB Protocol
01079             c_smsd_tcp                     = (INT)   596,   //  SMSD
01080             c_smsd_udp                     = (INT)   596,   //  SMSD
01081             c_ptcnameservice_tcp           = (INT)   597,   //  PTC Name Service
01082             c_ptcnameservice_udp           = (INT)   597,   //  PTC Name Service
01083             c_sco_websrvrmg3_tcp           = (INT)   598,   //  SCO Web Server Manager 3
01084             c_sco_websrvrmg3_udp           = (INT)   598,   //  SCO Web Server Manager 3
01085             c_acp_tcp                      = (INT)   599,   //  Aeolon Core Protocol
01086             c_acp_udp                      = (INT)   599,   //  Aeolon Core Protocol
01087             c_ipcserver_tcp                = (INT)   600,   //  Sun IPC server
01088             c_ipcserver_udp                = (INT)   600,   //  Sun IPC server
01089             c_syslog_conn_tcp              = (INT)   601,   //  Reliable Syslog Service
01090             c_syslog_conn_udp              = (INT)   601,   //  Reliable Syslog Service
01091             c_soap_beep_tcp                = (INT)   605,   //  SOAP over BEEP
01092             c_soap_beep_udp                = (INT)   605,   //  SOAP over BEEP
01093             c_urm_tcp                      = (INT)   606,   //  Cray Unified Resource Manager
01094             c_urm_udp                      = (INT)   606,   //  Cray Unified Resource Manager
01095             c_nqs_tcp                      = (INT)   607,   //  nqs
01096             c_nqs_udp                      = (INT)   607,   //  nqs
01097             c_sift_uft_tcp                 = (INT)   608,   //  Sender-Initiated/Unsolicited File Transfer
01098             c_sift_uft_udp                 = (INT)   608,   //  Sender-Initiated/Unsolicited File Transfer
01099             c_npmp_trap_tcp                = (INT)   609,   //  npmp-trap
01100             c_npmp_trap_udp                = (INT)   609,   //  npmp-trap
01101             c_npmp_local_tcp               = (INT)   610,   //  npmp-local
01102             c_npmp_local_udp               = (INT)   610,   //  npmp-local
01103             c_npmp_gui_tcp                 = (INT)   611,   //  npmp-gui
01104             c_npmp_gui_udp                 = (INT)   611,   //  npmp-gui
01105             c_hmmp_ind_tcp                 = (INT)   612,   //  HMMP Indication
01106             c_hmmp_ind_udp                 = (INT)   612,   //  HMMP Indication
01107             c_hmmp_op_tcp                  = (INT)   613,   //  HMMP Operation
01108             c_hmmp_op_udp                  = (INT)   613,   //  HMMP Operation
01109             c_sshell_tcp                   = (INT)   614,   //  SSLshell
01110             c_sshell_udp                   = (INT)   614,   //  SSLshell
01111             c_sco_inetmgr_tcp              = (INT)   615,   //  Internet Configuration Manager
01112             c_sco_inetmgr_udp              = (INT)   615,   //  Internet Configuration Manager
01113             c_sco_sysmgr_tcp               = (INT)   616,   //  SCO System Administration Server
01114             c_sco_sysmgr_udp               = (INT)   616,   //  SCO System Administration Server
01115             c_sco_dtmgr_tcp                = (INT)   617,   //  SCO Desktop Administration Server
01116             c_sco_dtmgr_udp                = (INT)   617,   //  SCO Desktop Administration Server
01117             c_dei_icda_tcp                 = (INT)   618,   //  DEI-ICDA
01118             c_dei_icda_udp                 = (INT)   618,   //  DEI-ICDA
01119             c_compaq_evm_tcp               = (INT)   619,   //  Compaq EVM
01120             c_compaq_evm_udp               = (INT)   619,   //  Compaq EVM
01121             c_sco_websrvrmgr_tcp           = (INT)   620,   //  SCO WebServer Manager
01122             c_sco_websrvrmgr_udp           = (INT)   620,   //  SCO WebServer Manager
01123             c_escp_ip_tcp                  = (INT)   621,   //  ESCP
01124             c_escp_ip_udp                  = (INT)   621,   //  ESCP
01125             c_collaborator_tcp             = (INT)   622,   //  Collaborator
01126             c_collaborator_udp             = (INT)   622,   //  Collaborator
01127             c_cryptoadmin_tcp              = (INT)   624,   //  Crypto Admin
01128             c_cryptoadmin_udp              = (INT)   624,   //  Crypto Admin
01129             c_asia_tcp                     = (INT)   626,   //  ASIA
01130             c_asia_udp                     = (INT)   626,   //  ASIA
01131             c_passgo_tivoli_tcp            = (INT)   627,   //  PassGo Tivoli
01132             c_passgo_tivoli_udp            = (INT)   627,   //  PassGo Tivoli
01133             c_qmqp_tcp                     = (INT)   628,   //  QMQP
01134             c_qmqp_udp                     = (INT)   628,   //  QMQP
01135             c_3com_amp3_tcp                = (INT)   629,   //  3Com AMP3
01136             c_3com_amp3_udp                = (INT)   629,   //  3Com AMP3
01137             c_rda_tcp                      = (INT)   630,   //  RDA
01138             c_rda_udp                      = (INT)   630,   //  RDA
01139             c_ipp_tcp                      = (INT)   631,   //  IPP (Internet Printing Protocol)
01140             c_ipp_udp                      = (INT)   631,   //  IPP (Internet Printing Protocol)
01141             c_bmpp_tcp                     = (INT)   632,   //  bmpp
01142             c_bmpp_udp                     = (INT)   632,   //  bmpp
01143             c_servstat_tcp                 = (INT)   633,   //  Service Status update (Sterling Software)
01144             c_servstat_udp                 = (INT)   633,   //  Service Status update (Sterling Software)
01145             c_ginad_tcp                    = (INT)   634,   //  ginad
01146             c_ginad_udp                    = (INT)   634,   //  ginad
01147             c_rlzdbase_tcp                 = (INT)   635,   //  RLZ DBase
01148             c_rlzdbase_udp                 = (INT)   635,   //  RLZ DBase
01149             c_ldaps_tcp                    = (INT)   636,   //  ldap protocol over TLS/SSL (was sldap)
01150             c_ldaps_udp                    = (INT)   636,   //  ldap protocol over TLS/SSL (was sldap)
01151             c_lanserver_tcp                = (INT)   637,   //  lanserver
01152             c_lanserver_udp                = (INT)   637,   //  lanserver
01153             c_mcns_sec_tcp                 = (INT)   638,   //  mcns-sec
01154             c_mcns_sec_udp                 = (INT)   638,   //  mcns-sec
01155             c_msdp_tcp                     = (INT)   639,   //  MSDP
01156             c_msdp_udp                     = (INT)   639,   //  MSDP
01157             c_entrust_sps_tcp              = (INT)   640,   //  entrust-sps
01158             c_entrust_sps_udp              = (INT)   640,   //  entrust-sps
01159             c_repcmd_tcp                   = (INT)   641,   //  repcmd
01160             c_repcmd_udp                   = (INT)   641,   //  repcmd
01161             c_esro_emsdp_tcp               = (INT)   642,   //  ESRO-EMSDP V1.3
01162             c_esro_emsdp_udp               = (INT)   642,   //  ESRO-EMSDP V1.3
01163             c_sanity_tcp                   = (INT)   643,   //  SANity
01164             c_sanity_udp                   = (INT)   643,   //  SANity
01165             c_dwr_tcp                      = (INT)   644,   //  dwr
01166             c_dwr_udp                      = (INT)   644,   //  dwr
01167             c_pssc_tcp                     = (INT)   645,   //  PSSC
01168             c_pssc_udp                     = (INT)   645,   //  PSSC
01169             c_ldp_tcp                      = (INT)   646,   //  LDP
01170             c_ldp_udp                      = (INT)   646,   //  LDP
01171             c_dhcp_failover_tcp            = (INT)   647,   //  DHCP Failover
01172             c_dhcp_failover_udp            = (INT)   647,   //  DHCP Failover
01173             c_rrp_tcp                      = (INT)   648,   //  Registry Registrar Protocol (RRP)
01174             c_rrp_udp                      = (INT)   648,   //  Registry Registrar Protocol (RRP)
01175             c_aminet_tcp                   = (INT)   649,   //  Aminet
01176             c_aminet_udp                   = (INT)   649,   //  Aminet
01177             c_obex_tcp                     = (INT)   650,   //  OBEX
01178             c_obex_udp                     = (INT)   650,   //  OBEX
01179             c_ieee_mms_tcp                 = (INT)   651,   //  IEEE MMS
01180             c_ieee_mms_udp                 = (INT)   651,   //  IEEE MMS
01181             c_hello_port_tcp               = (INT)   652,   //  HELLO_PORT
01182             c_hello_port_udp               = (INT)   652,   //  HELLO_PORT
01183             c_repscmd_tcp                  = (INT)   653,   //  RepCmd
01184             c_repscmd_udp                  = (INT)   653,   //  RepCmd
01185             c_aodv_tcp                     = (INT)   654,   //  AODV
01186             c_aodv_udp                     = (INT)   654,   //  AODV
01187             c_tinc_tcp                     = (INT)   655,   //  TINC
01188             c_tinc_udp                     = (INT)   655,   //  TINC
01189             c_spmp_tcp                     = (INT)   656,   //  SPMP
01190             c_spmp_udp                     = (INT)   656,   //  SPMP
01191             c_rmc_tcp                      = (INT)   657,   //  RMC
01192             c_rmc_udp                      = (INT)   657,   //  RMC
01193             c_tenfold_tcp                  = (INT)   658,   //  TenFold
01194             c_tenfold_udp                  = (INT)   658,   //  TenFold
01195             c_mac_srvr_admin_tcp           = (INT)   660,   //  MacOS Server Admin
01196             c_mac_srvr_admin_udp           = (INT)   660,   //  MacOS Server Admin
01197             c_hap_tcp                      = (INT)   661,   //  HAP
01198             c_hap_udp                      = (INT)   661,   //  HAP
01199             c_pftp_tcp                     = (INT)   662,   //  PFTP
01200             c_pftp_udp                     = (INT)   662,   //  PFTP
01201             c_purenoise_tcp                = (INT)   663,   //  PureNoise
01202             c_purenoise_udp                = (INT)   663,   //  PureNoise
01203             c_secure_aux_bus_tcp           = (INT)   664,   //  Secure Aux Bus
01204             c_secure_aux_bus_udp           = (INT)   664,   //  Secure Aux Bus
01205             c_sun_dr_tcp                   = (INT)   665,   //  Sun DR
01206             c_sun_dr_udp                   = (INT)   665,   //  Sun DR
01207             c_mdqs_tcp                     = (INT)   666,   //
01208             c_mdqs_udp                     = (INT)   666,   //
01209             c_doom_tcp                     = (INT)   666,   //  doom Id Software
01210             c_doom_udp                     = (INT)   666,   //  doom Id Software
01211             c_disclose_tcp                 = (INT)   667,   //  campaign contribution disclosures - SDR Technologies
01212             c_disclose_udp                 = (INT)   667,   //  campaign contribution disclosures - SDR Technologies
01213             c_mecomm_tcp                   = (INT)   668,   //  MeComm
01214             c_mecomm_udp                   = (INT)   668,   //  MeComm
01215             c_meregister_tcp               = (INT)   669,   //  MeRegister
01216             c_meregister_udp               = (INT)   669,   //  MeRegister
01217             c_vacdsm_sws_tcp               = (INT)   670,   //  VACDSM-SWS
01218             c_vacdsm_sws_udp               = (INT)   670,   //  VACDSM-SWS
01219             c_vacdsm_app_tcp               = (INT)   671,   //  VACDSM-APP
01220             c_vacdsm_app_udp               = (INT)   671,   //  VACDSM-APP
01221             c_vpps_qua_tcp                 = (INT)   672,   //  VPPS-QUA
01222             c_vpps_qua_udp                 = (INT)   672,   //  VPPS-QUA
01223             c_cimplex_tcp                  = (INT)   673,   //  CIMPLEX
01224             c_cimplex_udp                  = (INT)   673,   //  CIMPLEX
01225             c_acap_tcp                     = (INT)   674,   //  ACAP
01226             c_acap_udp                     = (INT)   674,   //  ACAP
01227             c_dctp_tcp                     = (INT)   675,   //  DCTP
01228             c_dctp_udp                     = (INT)   675,   //  DCTP
01229             c_vpps_via_tcp                 = (INT)   676,   //  VPPS Via
01230             c_vpps_via_udp                 = (INT)   676,   //  VPPS Via
01231             c_vpp_tcp                      = (INT)   677,   //  Virtual Presence Protocol
01232             c_vpp_udp                      = (INT)   677,   //  Virtual Presence Protocol
01233             c_ggf_ncp_tcp                  = (INT)   678,   //  GNU Generation Foundation NCP
01234             c_ggf_ncp_udp                  = (INT)   678,   //  GNU Generation Foundation NCP
01235             c_mrm_tcp                      = (INT)   679,   //  MRM
01236             c_mrm_udp                      = (INT)   679,   //  MRM
01237             c_entrust_aaas_tcp             = (INT)   680,   //  entrust-aaas
01238             c_entrust_aaas_udp             = (INT)   680,   //  entrust-aaas
01239             c_entrust_aams_tcp             = (INT)   681,   //  entrust-aams
01240             c_entrust_aams_udp             = (INT)   681,   //  entrust-aams
01241             c_xfr_tcp                      = (INT)   682,   //  XFR
01242             c_xfr_udp                      = (INT)   682,   //  XFR
01243             c_corba_iiop_tcp               = (INT)   683,   //  CORBA IIOP
01244             c_corba_iiop_udp               = (INT)   683,   //  CORBA IIOP
01245             c_corba_iiop_ssl_tcp           = (INT)   684,   //  CORBA IIOP SSL
01246             c_corba_iiop_ssl_udp           = (INT)   684,   //  CORBA IIOP SSL
01247             c_mdc_portmapper_tcp           = (INT)   685,   //  MDC Port Mapper
01248             c_mdc_portmapper_udp           = (INT)   685,   //  MDC Port Mapper
01249             c_hcp_wismar_tcp               = (INT)   686,   //  Hardware Control Protocol Wismar
01250             c_hcp_wismar_udp               = (INT)   686,   //  Hardware Control Protocol Wismar
01251             c_asipregistry_tcp             = (INT)   687,   //  asipregistry
01252             c_asipregistry_udp             = (INT)   687,   //  asipregistry
01253             c_realm_rusd_tcp               = (INT)   688,   //  REALM-RUSD
01254             c_realm_rusd_udp               = (INT)   688,   //  REALM-RUSD
01255             c_nmap_tcp                     = (INT)   689,   //  NMAP
01256             c_nmap_udp                     = (INT)   689,   //  NMAP
01257             c_vatp_tcp                     = (INT)   690,   //  VATP
01258             c_vatp_udp                     = (INT)   690,   //  VATP
01259             c_msexch_routing_tcp           = (INT)   691,   //  MS Exchange Routing
01260             c_msexch_routing_udp           = (INT)   691,   //  MS Exchange Routing
01261             c_hyperwave_isp_tcp            = (INT)   692,   //  Hyperwave-ISP
01262             c_hyperwave_isp_udp            = (INT)   692,   //  Hyperwave-ISP
01263             c_connendp_tcp                 = (INT)   693,   //  connendp
01264             c_connendp_udp                 = (INT)   693,   //  connendp
01265             c_ha_cluster_tcp               = (INT)   694,   //  ha-cluster
01266             c_ha_cluster_udp               = (INT)   694,   //  ha-cluster
01267             c_ieee_mms_ssl_tcp             = (INT)   695,   //  IEEE-MMS-SSL
01268             c_ieee_mms_ssl_udp             = (INT)   695,   //  IEEE-MMS-SSL
01269             c_rushd_tcp                    = (INT)   696,   //  RUSHD
01270             c_rushd_udp                    = (INT)   696,   //  RUSHD
01271             c_uuidgen_tcp                  = (INT)   697,   //  UUIDGEN
01272             c_uuidgen_udp                  = (INT)   697,   //  UUIDGEN
01273             c_olsr_tcp                     = (INT)   698,   //  OLSR
01274             c_olsr_udp                     = (INT)   698,   //  OLSR
01275             c_accessnetwork_tcp            = (INT)   699,   //  Access Network
01276             c_accessnetwork_udp            = (INT)   699,   //  Access Network
01277             c_elcsd_tcp                    = (INT)   704,   //  errlog copy/server daemon
01278             c_elcsd_udp                    = (INT)   704,   //  errlog copy/server daemon
01279             c_agentx_tcp                   = (INT)   705,   //  AgentX
01280             c_agentx_udp                   = (INT)   705,   //  AgentX
01281             c_silc_tcp                     = (INT)   706,   //  SILC
01282             c_silc_udp                     = (INT)   706,   //  SILC
01283             c_borland_dsj_tcp              = (INT)   707,   //  Borland DSJ
01284             c_borland_dsj_udp              = (INT)   707,   //  Borland DSJ
01285             c_entrust_kmsh_tcp             = (INT)   709,   //  Entrust Key Management Service Handler
01286             c_entrust_kmsh_udp             = (INT)   709,   //  Entrust Key Management Service Handler
01287             c_entrust_ash_tcp              = (INT)   710,   //  Entrust Administration Service Handler
01288             c_entrust_ash_udp              = (INT)   710,   //  Entrust Administration Service Handler
01289             c_cisco_tdp_tcp                = (INT)   711,   //  Cisco TDP
01290             c_cisco_tdp_udp                = (INT)   711,   //  Cisco TDP
01291             c_netviewdm1_tcp               = (INT)   729,   //  IBM NetView DM/6000 Server/Client
01292             c_netviewdm1_udp               = (INT)   729,   //  IBM NetView DM/6000 Server/Client
01293             c_netviewdm2_tcp               = (INT)   730,   //  IBM NetView DM/6000 send/tcp
01294             c_netviewdm2_udp               = (INT)   730,   //  IBM NetView DM/6000 send/tcp
01295             c_netviewdm3_tcp               = (INT)   731,   //  IBM NetView DM/6000 receive/tcp
01296             c_netviewdm3_udp               = (INT)   731,   //  IBM NetView DM/6000 receive/tcp
01297             c_netgw_tcp                    = (INT)   741,   //  netGW
01298             c_netgw_udp                    = (INT)   741,   //  netGW
01299             c_netrcs_tcp                   = (INT)   742,   //  Network based Rev. Cont. Sys.
01300             c_netrcs_udp                   = (INT)   742,   //  Network based Rev. Cont. Sys.
01301             c_flexlm_tcp                   = (INT)   744,   //  Flexible License Manager
01302             c_flexlm_udp                   = (INT)   744,   //  Flexible License Manager
01303             c_fujitsu_dev_tcp              = (INT)   747,   //  Fujitsu Device Control
01304             c_fujitsu_dev_udp              = (INT)   747,   //  Fujitsu Device Control
01305             c_ris_cm_tcp                   = (INT)   748,   //  Russell Info Sci Calendar Manager
01306             c_ris_cm_udp                   = (INT)   748,   //  Russell Info Sci Calendar Manager
01307             c_kerberos_adm_tcp             = (INT)   749,   //  kerberos administration
01308             c_kerberos_adm_udp             = (INT)   749,   //  kerberos administration
01309             c_rfile_tcp                    = (INT)   750,   //
01310             c_loadav_udp                   = (INT)   750,   //
01311             c_kerberos_iv_udp              = (INT)   750,   //  kerberos version iv
01312             c_pump_tcp                     = (INT)   751,   //
01313             c_pump_udp                     = (INT)   751,   //
01314             c_qrh_tcp                      = (INT)   752,   //
01315             c_qrh_udp                      = (INT)   752,   //
01316             c_rrh_tcp                      = (INT)   753,   //
01317             c_rrh_udp                      = (INT)   753,   //
01318             c_tell_tcp                     = (INT)   754,   //  send
01319             c_tell_udp                     = (INT)   754,   //  send
01320             c_nlogin_tcp                   = (INT)   758,   //
01321             c_nlogin_udp                   = (INT)   758,   //
01322             c_con_tcp                      = (INT)   759,   //
01323             c_con_udp                      = (INT)   759,   //
01324             c_ns_tcp                       = (INT)   760,   //
01325             c_ns_udp                       = (INT)   760,   //
01326             c_rxe_tcp                      = (INT)   761,   //
01327             c_rxe_udp                      = (INT)   761,   //
01328             c_quotad_tcp                   = (INT)   762,   //
01329             c_quotad_udp                   = (INT)   762,   //
01330             c_cycleserv_tcp                = (INT)   763,   //
01331             c_cycleserv_udp                = (INT)   763,   //
01332             c_omserv_tcp                   = (INT)   764,   //
01333             c_omserv_udp                   = (INT)   764,   //
01334             c_webster_tcp                  = (INT)   765,   //
01335             c_webster_udp                  = (INT)   765,   //
01336             c_phonebook_tcp                = (INT)   767,   //  phone
01337             c_phonebook_udp                = (INT)   767,   //  phone
01338             c_vid_tcp                      = (INT)   769,   //
01339             c_vid_udp                      = (INT)   769,   //
01340             c_cadlock_tcp                  = (INT)   770,   //
01341             c_cadlock_udp                  = (INT)   770,   //
01342             c_rtip_tcp                     = (INT)   771,   //
01343             c_rtip_udp                     = (INT)   771,   //
01344             c_cycleserv2_tcp               = (INT)   772,   //
01345             c_cycleserv2_udp               = (INT)   772,   //
01346             c_submit_tcp                   = (INT)   773,   //
01347             c_notify_udp                   = (INT)   773,   //
01348             c_rpasswd_tcp                  = (INT)   774,   //
01349             c_entomb_tcp                   = (INT)   775,   //
01350             c_wpages_tcp                   = (INT)   776,   //
01351             c_wpages_udp                   = (INT)   776,   //
01352             c_multiling_http_tcp           = (INT)   777,   //  Multiling HTTP
01353             c_multiling_http_udp           = (INT)   777,   //  Multiling HTTP
01354             c_wpgs_tcp                     = (INT)   780,   //
01355             c_wpgs_udp                     = (INT)   780,   //
01356             c_concert_tcp                  = (INT)   786,   //  Concert
01357             c_concert_udp                  = (INT)   786,   //  Concert
01358             c_qsc_tcp                      = (INT)   787,   //  QSC
01359             c_qsc_udp                      = (INT)   787,   //  QSC
01360             c_device_tcp                   = (INT)   801,   //
01361             c_device_udp                   = (INT)   801,   //
01362             c_fcp_udp_tcp                  = (INT)   810,   //  FCP
01363             c_fcp_udp_udp                  = (INT)   810,   //  FCP Datagram
01364             c_itm_mcell_s_tcp              = (INT)   828,   //  itm-mcell-s
01365             c_itm_mcell_s_udp              = (INT)   828,   //  itm-mcell-s
01366             c_pkix_3_ca_ra_tcp             = (INT)   829,   //  PKIX-3 CA/RA
01367             c_pkix_3_ca_ra_udp             = (INT)   829,   //  PKIX-3 CA/RA
01368             c_dhcp_failover2_tcp           = (INT)   847,   //  dhcp-failover 2
01369             c_dhcp_failover2_udp           = (INT)   847,   //  dhcp-failover 2
01370             c_rsync_tcp                    = (INT)   873,   //  rsync
01371             c_rsync_udp                    = (INT)   873,   //  rsync
01372             c_iclcnet_locate_tcp           = (INT)   886,   //  ICL coNETion locate server
01373             c_iclcnet_locate_udp           = (INT)   886,   //  ICL coNETion locate server
01374             c_accessbuilder_tcp            = (INT)   888,   //  AccessBuilder
01375             c_accessbuilder_udp            = (INT)   888,   //  AccessBuilder
01376             c_cddbp_tcp                    = (INT)   888,   //  CD Database Protocol
01377             c_omginitialrefs_tcp           = (INT)   900,   //  OMG Initial Refs
01378             c_omginitialrefs_udp           = (INT)   900,   //  OMG Initial Refs
01379             c_smpnameres_tcp               = (INT)   901,   //  SMPNAMERES
01380             c_smpnameres_udp               = (INT)   901,   //  SMPNAMERES
01381             c_ideafarm_chat_tcp            = (INT)   902,   //  IDEAFARM-CHAT
01382             c_ideafarm_chat_udp            = (INT)   902,   //  IDEAFARM-CHAT
01383             c_ideafarm_catch_tcp           = (INT)   903,   //  IDEAFARM-CATCH
01384             c_ideafarm_catch_udp           = (INT)   903,   //  IDEAFARM-CATCH
01385             c_xact_backup_tcp              = (INT)   911,   //  xact-backup
01386             c_xact_backup_udp              = (INT)   911,   //  xact-backup
01387             c_apex_mesh_tcp                = (INT)   912,   //  APEX relay-relay service
01388             c_apex_mesh_udp                = (INT)   912,   //  APEX relay-relay service
01389             c_apex_edge_tcp                = (INT)   913,   //  APEX endpoint-relay service
01390             c_apex_edge_udp                = (INT)   913,   //  APEX endpoint-relay service
01391
01392             c_nas_tcp                      = (INT)   991,   //  Netnews Administration System
01393             c_nas_udp                      = (INT)   991,   //  Netnews Administration System
01394
01395             c_vsinet_tcp                   = (INT)   996,   //  vsinet
01396             c_vsinet_udp                   = (INT)   996,   //  vsinet
01397             c_maitrd_tcp                   = (INT)   997,   //
01398             c_maitrd_udp                   = (INT)   997,   //
01399             c_busboy_tcp                   = (INT)   998,   //
01400             c_puparp_udp                   = (INT)   998,   //
01401             c_garcon_tcp                   = (INT)   999,   //
01402             c_applix_udp                   = (INT)   999,   //  Applix ac
01403             c_puprouter_tcp                = (INT)   999,   //
01404             c_puprouter_udp                = (INT)   999,   //
01405             c_cadlock2_tcp                 = (INT)  1000,   //
01406             c_cadlock2_udp                 = (INT)  1000,   //
01407             c_surf_tcp                     = (INT)  1010,   //  surf
01408             c_surf_udp                     = (INT)  1010,   //  surf
01409
01410             c_blackjack_tcp                = (INT)  1025,   //  network blackjack
01411             c_blackjack_udp                = (INT)  1025,   //  network blackjack
01412             c_iad1_tcp                     = (INT)  1030,   //  BBN IAD
01413             c_iad1_udp                     = (INT)  1030,   //  BBN IAD
01414             c_iad2_tcp                     = (INT)  1031,   //  BBN IAD
01415             c_iad2_udp                     = (INT)  1031,   //  BBN IAD
01416             c_iad3_tcp                     = (INT)  1032,   //  BBN IAD
01417             c_iad3_udp                     = (INT)  1032,   //  BBN IAD
01418             c_pcg_radar_tcp                = (INT)  1036,   //  RADAR Service Protocol
01419             c_pcg_radar_udp                = (INT)  1036,   //  RADAR Service Protocol
01420             c_netarx_tcp                   = (INT)  1040,   //  Netarx
01421             c_netarx_udp                   = (INT)  1040,   //  Netarx
01422             c_fpitp_tcp                    = (INT)  1045,   //  Fingerprint Image Transfer Protocol
01423             c_fpitp_udp                    = (INT)  1045,   //  Fingerprint Image Transfer Protocol
01424             c_neod1_tcp                    = (INT)  1047,   //  Sun's NEO Object Request Broker
01425             c_neod1_udp                    = (INT)  1047,   //  Sun's NEO Object Request Broker
01426             c_neod2_tcp                    = (INT)  1048,   //  Sun's NEO Object Request Broker
01427             c_neod2_udp                    = (INT)  1048,   //  Sun's NEO Object Request Broker
01428             c_td_postman_tcp               = (INT)  1049,   //  Tobit David Postman VPMN
01429             c_td_postman_udp               = (INT)  1049,   //  Tobit David Postman VPMN
01430             c_cma_tcp                      = (INT)  1050,   //  CORBA Management Agent
01431             c_cma_udp                      = (INT)  1050,   //  CORBA Management Agent
01432             c_optima_vnet_tcp              = (INT)  1051,   //  Optima VNET
01433             c_optima_vnet_udp              = (INT)  1051,   //  Optima VNET
01434             c_ddt_tcp                      = (INT)  1052,   //  Dynamic DNS Tools
01435             c_ddt_udp                      = (INT)  1052,   //  Dynamic DNS Tools
01436             c_remote_as_tcp                = (INT)  1053,   //  Remote Assistant (RA)
01437             c_remote_as_udp                = (INT)  1053,   //  Remote Assistant (RA)
01438             c_brvread_tcp                  = (INT)  1054,   //  BRVREAD
01439             c_brvread_udp                  = (INT)  1054,   //  BRVREAD
01440             c_ansyslmd_tcp                 = (INT)  1055,   //  ANSYS - License Manager
01441             c_ansyslmd_udp                 = (INT)  1055,   //  ANSYS - License Manager
01442             c_vfo_tcp                      = (INT)  1056,   //  VFO
01443             c_vfo_udp                      = (INT)  1056,   //  VFO
01444             c_startron_tcp                 = (INT)  1057,   //  STARTRON
01445             c_startron_udp                 = (INT)  1057,   //  STARTRON
01446             c_nim_tcp                      = (INT)  1058,   //  nim
01447             c_nim_udp                      = (INT)  1058,   //  nim
01448             c_nimreg_tcp                   = (INT)  1059,   //  nimreg
01449             c_nimreg_udp                   = (INT)  1059,   //  nimreg
01450             c_polestar_tcp                 = (INT)  1060,   //  POLESTAR
01451             c_polestar_udp                 = (INT)  1060,   //  POLESTAR
01452             c_kiosk_tcp                    = (INT)  1061,   //  KIOSK
01453             c_kiosk_udp                    = (INT)  1061,   //  KIOSK
01454             c_veracity_tcp                 = (INT)  1062,   //  Veracity
01455             c_veracity_udp                 = (INT)  1062,   //  Veracity
01456             c_kyoceranetdev_tcp            = (INT)  1063,   //  KyoceraNetDev
01457             c_kyoceranetdev_udp            = (INT)  1063,   //  KyoceraNetDev
01458             c_jstel_tcp                    = (INT)  1064,   //  JSTEL
01459             c_jstel_udp                    = (INT)  1064,   //  JSTEL
01460             c_syscomlan_tcp                = (INT)  1065,   //  SYSCOMLAN
01461             c_syscomlan_udp                = (INT)  1065,   //  SYSCOMLAN
01462             c_fpo_fns_tcp                  = (INT)  1066,   //  FPO-FNS
01463             c_fpo_fns_udp                  = (INT)  1066,   //  FPO-FNS
01464             c_cognex_insight_tcp           = (INT)  1069,   //  COGNEX-INSIGHT
01465             c_cognex_insight_udp           = (INT)  1069,   //  COGNEX-INSIGHT
01466             c_gmrupdateserv_tcp            = (INT)  1070,   //  GMRUpdateSERV
01467             c_gmrupdateserv_udp            = (INT)  1070,   //  GMRUpdateSERV
01468             c_bsquare_voip_tcp             = (INT)  1071,   //  BSQUARE-VOIP
01469             c_bsquare_voip_udp             = (INT)  1071,   //  BSQUARE-VOIP
01470             c_cardax_tcp                   = (INT)  1072,   //  CARDAX
01471             c_cardax_udp                   = (INT)  1072,   //  CARDAX
01472             c_bridgecontrol_tcp            = (INT)  1073,   //  BridgeControl
01473             c_bridgecontrol_udp            = (INT)  1073,   //  BridgeControl
01474             c_fastechnologlm_tcp           = (INT)  1074,   //  FASTechnologies License Manager
01475             c_fastechnologlm_udp           = (INT)  1074,   //  FASTechnologies License Manager
01476             c_rdrmshc_tcp                  = (INT)  1075,   //  RDRMSHC
01477             c_rdrmshc_udp                  = (INT)  1075,   //  RDRMSHC
01478             c_dab_sti_c_tcp                = (INT)  1076,   //  DAB STI-C
01479             c_dab_sti_c_udp                = (INT)  1076,   //  DAB STI-C
01480             c_imgames_tcp                  = (INT)  1077,   //  IMGames
01481             c_imgames_udp                  = (INT)  1077,   //  IMGames
01482             c_emanagecstp_tcp              = (INT)  1078,   //  eManageCstp
01483             c_emanagecstp_udp              = (INT)  1078,   //  eManageCstp
01484             c_asprovatalk_tcp              = (INT)  1079,   //  ASPROVATalk
01485             c_asprovatalk_udp              = (INT)  1079,   //  ASPROVATalk
01486             c_socks_tcp                    = (INT)  1080,   //  Socks
01487             c_socks_udp                    = (INT)  1080,   //  Socks
01488             c_pvuniwien_tcp                = (INT)  1081,   //  PVUNIWIEN
01489             c_pvuniwien_udp                = (INT)  1081,   //  PVUNIWIEN
01490             c_amt_esd_prot_tcp             = (INT)  1082,   //  AMT-ESD-PROT
01491             c_amt_esd_prot_udp             = (INT)  1082,   //  AMT-ESD-PROT
01492             c_ansoft_lm_1_tcp              = (INT)  1083,   //  Anasoft License Manager
01493             c_ansoft_lm_1_udp              = (INT)  1083,   //  Anasoft License Manager
01494             c_ansoft_lm_2_tcp              = (INT)  1084,   //  Anasoft License Manager
01495             c_ansoft_lm_2_udp              = (INT)  1084,   //  Anasoft License Manager
01496             c_webobjects_tcp               = (INT)  1085,   //  Web Objects
01497             c_webobjects_udp               = (INT)  1085,   //  Web Objects
01498             c_cplscrambler_lg_tcp          = (INT)  1086,   //  CPL Scrambler Logging
01499             c_cplscrambler_lg_udp          = (INT)  1086,   //  CPL Scrambler Logging
01500             c_cplscrambler_in_tcp          = (INT)  1087,   //  CPL Scrambler Internal
01501             c_cplscrambler_in_udp          = (INT)  1087,   //  CPL Scrambler Internal
01502             c_cplscrambler_al_tcp          = (INT)  1088,   //  CPL Scrambler Alarm Log
01503             c_cplscrambler_al_udp          = (INT)  1088,   //  CPL Scrambler Alarm Log
01504             c_ff_annunc_tcp                = (INT)  1089,   //  FF Annunciation
01505             c_ff_annunc_udp                = (INT)  1089,   //  FF Annunciation
01506             c_ff_fms_tcp                   = (INT)  1090,   //  FF Fieldbus Message Specification
01507             c_ff_fms_udp                   = (INT)  1090,   //  FF Fieldbus Message Specification
01508             c_ff_sm_tcp                    = (INT)  1091,   //  FF System Management
01509             c_ff_sm_udp                    = (INT)  1091,   //  FF System Management
01510             c_obrpd_tcp                    = (INT)  1092,   //  Open Business Reporting Protocol
01511             c_obrpd_udp                    = (INT)  1092,   //  Open Business Reporting Protocol
01512             c_proofd_tcp                   = (INT)  1093,   //  PROOFD
01513             c_proofd_udp                   = (INT)  1093,   //  PROOFD
01514             c_rootd_tcp                    = (INT)  1094,   //  ROOTD
01515             c_rootd_udp                    = (INT)  1094,   //  ROOTD
01516             c_nicelink_tcp                 = (INT)  1095,   //  NICELink
01517             c_nicelink_udp                 = (INT)  1095,   //  NICELink
01518             c_cnrprotocol_tcp              = (INT)  1096,   //  Common Name Resolution Protocol
01519             c_cnrprotocol_udp              = (INT)  1096,   //  Common Name Resolution Protocol
01520             c_sunclustermgr_tcp            = (INT)  1097,   //  Sun Cluster Manager
01521             c_sunclustermgr_udp            = (INT)  1097,   //  Sun Cluster Manager
01522             c_rmiactivation_tcp            = (INT)  1098,   //  RMI Activation
01523             c_rmiactivation_udp            = (INT)  1098,   //  RMI Activation
01524             c_rmiregistry_tcp              = (INT)  1099,   //  RMI Registry
01525             c_rmiregistry_udp              = (INT)  1099,   //  RMI Registry
01526             c_mctp_tcp                     = (INT)  1100,   //  MCTP
01527             c_mctp_udp                     = (INT)  1100,   //  MCTP
01528             c_pt2_discover_tcp             = (INT)  1101,   //  PT2-DISCOVER
01529             c_pt2_discover_udp             = (INT)  1101,   //  PT2-DISCOVER
01530             c_adobeserver_1_tcp            = (INT)  1102,   //  ADOBE SERVER 1
01531             c_adobeserver_1_udp            = (INT)  1102,   //  ADOBE SERVER 1
01532             c_adobeserver_2_tcp            = (INT)  1103,   //  ADOBE SERVER 2
01533             c_adobeserver_2_udp            = (INT)  1103,   //  ADOBE SERVER 2
01534             c_xrl_tcp                      = (INT)  1104,   //  XRL
01535             c_xrl_udp                      = (INT)  1104,   //  XRL
01536             c_ftranhc_tcp                  = (INT)  1105,   //  FTRANHC
01537             c_ftranhc_udp                  = (INT)  1105,   //  FTRANHC
01538             c_isoipsigport_1_tcp           = (INT)  1106,   //  ISOIPSIGPORT-1
01539             c_isoipsigport_1_udp           = (INT)  1106,   //  ISOIPSIGPORT-1
01540             c_isoipsigport_2_tcp           = (INT)  1107,   //  ISOIPSIGPORT-2
01541             c_isoipsigport_2_udp           = (INT)  1107,   //  ISOIPSIGPORT-2
01542             c_ratio_adp_tcp                = (INT)  1108,   //  ratio-adp
01543             c_ratio_adp_udp                = (INT)  1108,   //  ratio-adp
01544             c_nfsd_status_tcp              = (INT)  1110,   //  Cluster status info
01545             c_nfsd_keepalive_udp           = (INT)  1110,   //  Client status info
01546             c_lmsocialserver_tcp           = (INT)  1111,   //  LM Social Server
01547             c_lmsocialserver_udp           = (INT)  1111,   //  LM Social Server
01548             c_icp_tcp                      = (INT)  1112,   //  Intelligent Communication Protocol
01549             c_icp_udp                      = (INT)  1112,   //  Intelligent Communication Protocol
01550             c_mini_sql_tcp                 = (INT)  1114,   //  Mini SQL
01551             c_mini_sql_udp                 = (INT)  1114,   //  Mini SQL
01552             c_ardus_trns_tcp               = (INT)  1115,   //  ARDUS Transfer
01553             c_ardus_trns_udp               = (INT)  1115,   //  ARDUS Transfer
01554             c_ardus_cntl_tcp               = (INT)  1116,   //  ARDUS Control
01555             c_ardus_cntl_udp               = (INT)  1116,   //  ARDUS Control
01556             c_ardus_mtrns_tcp              = (INT)  1117,   //  ARDUS Multicast Transfer
01557             c_ardus_mtrns_udp              = (INT)  1117,   //  ARDUS Multicast Transfer
01558             c_availant_mgr_tcp             = (INT)  1122,   //  availant-mgr
01559             c_availant_mgr_udp             = (INT)  1122,   //  availant-mgr
01560             c_murray_tcp                   = (INT)  1123,   //  Murray
01561             c_murray_udp                   = (INT)  1123,   //  Murray
01562             c_nfa_tcp                      = (INT)  1155,   //  Network File Access
01563             c_nfa_udp                      = (INT)  1155,   //  Network File Access
01564             c_health_polling_tcp           = (INT)  1161,   //  Health Polling
01565             c_health_polling_udp           = (INT)  1161,   //  Health Polling
01566             c_health_trap_tcp              = (INT)  1162,   //  Health Trap
01567             c_health_trap_udp              = (INT)  1162,   //  Health Trap
01568             c_tripwire_tcp                 = (INT)  1169,   //  TRIPWIRE
01569             c_tripwire_udp                 = (INT)  1169,   //  TRIPWIRE
01570             c_mc_client_tcp                = (INT)  1180,   //  Millicent Client Proxy
01571             c_mc_client_udp                = (INT)  1180,   //  Millicent Client Proxy
01572             c_llsurfup_http_tcp            = (INT)  1183,   //  LL Surfup HTTP
01573             c_llsurfup_http_udp            = (INT)  1183,   //  LL Surfup HTTP
01574             c_llsurfup_https_tcp           = (INT)  1184,   //  LL Surfup HTTPS
01575             c_llsurfup_https_udp           = (INT)  1184,   //  LL Surfup HTTPS
01576             c_catchpole_tcp                = (INT)  1185,   //  Catchpole port
01577             c_catchpole_udp                = (INT)  1185,   //  Catchpole port
01578             c_hp_webadmin_tcp              = (INT)  1188,   //  HP Web Admin
01579             c_hp_webadmin_udp              = (INT)  1188,   //  HP Web Admin
01580             c_dmidi_tcp                    = (INT)  1199,   //  DMIDI
01581             c_dmidi_udp                    = (INT)  1199,   //  DMIDI
01582             c_scol_tcp                     = (INT)  1200,   //  SCOL
01583             c_scol_udp                     = (INT)  1200,   //  SCOL
01584             c_nucleus_sand_tcp             = (INT)  1201,   //  Nucleus Sand
01585             c_nucleus_sand_udp             = (INT)  1201,   //  Nucleus Sand
01586             c_caiccipc_tcp                 = (INT)  1202,   //  caiccipc
01587             c_caiccipc_udp                 = (INT)  1202,   //  caiccipc
01588             c_ssslic_mgr_tcp               = (INT)  1203,   //  License Validation
01589             c_ssslic_mgr_udp               = (INT)  1203,   //  License Validation
01590             c_ssslog_mgr_tcp               = (INT)  1204,   //  Log Request Listener
01591             c_ssslog_mgr_udp               = (INT)  1204,   //  Log Request Listener
01592             c_accord_mgc_tcp               = (INT)  1205,   //  Accord-MGC
01593             c_accord_mgc_udp               = (INT)  1205,   //  Accord-MGC
01594             c_anthony_data_tcp             = (INT)  1206,   //  Anthony Data
01595             c_anthony_data_udp             = (INT)  1206,   //  Anthony Data
01596             c_metasage_tcp                 = (INT)  1207,   //  MetaSage
01597             c_metasage_udp                 = (INT)  1207,   //  MetaSage
01598             c_seagull_ais_tcp              = (INT)  1208,   //  SEAGULL AIS
01599             c_seagull_ais_udp              = (INT)  1208,   //  SEAGULL AIS
01600             c_ipcd3_tcp                    = (INT)  1209,   //  IPCD3
01601             c_ipcd3_udp                    = (INT)  1209,   //  IPCD3
01602             c_eoss_tcp                     = (INT)  1210,   //  EOSS
01603             c_eoss_udp                     = (INT)  1210,   //  EOSS
01604             c_groove_dpp_tcp               = (INT)  1211,   //  Groove DPP
01605             c_groove_dpp_udp               = (INT)  1211,   //  Groove DPP
01606             c_lupa_tcp                     = (INT)  1212,   //  lupa
01607             c_lupa_udp                     = (INT)  1212,   //  lupa
01608             c_mpc_lifenet_tcp              = (INT)  1213,   //  MPC LIFENET
01609             c_mpc_lifenet_udp              = (INT)  1213,   //  MPC LIFENET
01610             c_kazaa_tcp                    = (INT)  1214,   //  KAZAA
01611             c_kazaa_udp                    = (INT)  1214,   //  KAZAA
01612             c_scanstat_1_tcp               = (INT)  1215,   //  scanSTAT 1.0
01613             c_scanstat_1_udp               = (INT)  1215,   //  scanSTAT 1.0
01614             c_etebac5_tcp                  = (INT)  1216,   //  ETEBAC 5
01615             c_etebac5_udp                  = (INT)  1216,   //  ETEBAC 5
01616             c_hpss_ndapi_tcp               = (INT)  1217,   //  HPSS-NDAPI
01617             c_hpss_ndapi_udp               = (INT)  1217,   //  HPSS-NDAPI
01618             c_aeroflight_ads_tcp           = (INT)  1218,   //  AeroFlight-ADs
01619             c_aeroflight_ads_udp           = (INT)  1218,   //  AeroFlight-ADs
01620             c_aeroflight_ret_tcp           = (INT)  1219,   //  AeroFlight-Ret
01621             c_aeroflight_ret_udp           = (INT)  1219,   //  AeroFlight-Ret
01622             c_qt_serveradmin_tcp           = (INT)  1220,   //  QT SERVER ADMIN
01623             c_qt_serveradmin_udp           = (INT)  1220,   //  QT SERVER ADMIN
01624             c_sweetware_apps_tcp           = (INT)  1221,   //  SweetWARE Apps
01625             c_sweetware_apps_udp           = (INT)  1221,   //  SweetWARE Apps
01626             c_nerv_tcp                     = (INT)  1222,   //  SNI R&D network
01627             c_nerv_udp                     = (INT)  1222,   //  SNI R&D network
01628             c_tgp_tcp                      = (INT)  1223,   //  TGP
01629             c_tgp_udp                      = (INT)  1223,   //  TGP
01630             c_vpnz_tcp                     = (INT)  1224,   //  VPNz
01631             c_vpnz_udp                     = (INT)  1224,   //  VPNz
01632             c_slinkysearch_tcp             = (INT)  1225,   //  SLINKYSEARCH
01633             c_slinkysearch_udp             = (INT)  1225,   //  SLINKYSEARCH
01634             c_stgxfws_tcp                  = (INT)  1226,   //  STGXFWS
01635             c_stgxfws_udp                  = (INT)  1226,   //  STGXFWS
01636             c_dns2go_tcp                   = (INT)  1227,   //  DNS2Go
01637             c_dns2go_udp                   = (INT)  1227,   //  DNS2Go
01638             c_florence_tcp                 = (INT)  1228,   //  FLORENCE
01639             c_florence_udp                 = (INT)  1228,   //  FLORENCE
01640             c_novell_zfs_tcp               = (INT)  1229,   //  Novell ZFS
01641             c_novell_zfs_udp               = (INT)  1229,   //  Novell ZFS
01642             c_periscope_tcp                = (INT)  1230,   //  Periscope
01643             c_periscope_udp                = (INT)  1230,   //  Periscope
01644             c_menandmice_lpm_tcp           = (INT)  1231,   //  menandmice-lpm
01645             c_menandmice_lpm_udp           = (INT)  1231,   //  menandmice-lpm
01646             c_univ_appserver_tcp           = (INT)  1233,   //  Universal App Server
01647             c_univ_appserver_udp           = (INT)  1233,   //  Universal App Server
01648             c_search_agent_tcp             = (INT)  1234,   //  Infoseek Search Agent
01649             c_search_agent_udp             = (INT)  1234,   //  Infoseek Search Agent
01650             c_mosaicsyssvc1_tcp            = (INT)  1235,   //  mosaicsyssvc1
01651             c_mosaicsyssvc1_udp            = (INT)  1235,   //  mosaicsyssvc1
01652             c_bvcontrol_tcp                = (INT)  1236,   //  bvcontrol
01653             c_bvcontrol_udp                = (INT)  1236,   //  bvcontrol
01654             c_tsdos390_tcp                 = (INT)  1237,   //  tsdos390
01655             c_tsdos390_udp                 = (INT)  1237,   //  tsdos390
01656             c_hacl_qs_tcp                  = (INT)  1238,   //  hacl-qs
01657             c_hacl_qs_udp                  = (INT)  1238,   //  hacl-qs
01658             c_nmsd_tcp                     = (INT)  1239,   //  NMSD
01659             c_nmsd_udp                     = (INT)  1239,   //  NMSD
01660             c_instantia_tcp                = (INT)  1240,   //  Instantia
01661             c_instantia_udp                = (INT)  1240,   //  Instantia
01662             c_nessus_tcp                   = (INT)  1241,   //  nessus
01663             c_nessus_udp                   = (INT)  1241,   //  nessus
01664             c_nmasoverip_tcp               = (INT)  1242,   //  NMAS over IP
01665             c_nmasoverip_udp               = (INT)  1242,   //  NMAS over IP
01666             c_serialgateway_tcp            = (INT)  1243,   //  SerialGateway
01667             c_serialgateway_udp            = (INT)  1243,   //  SerialGateway
01668             c_isbconference1_tcp           = (INT)  1244,   //  isbconference1
01669             c_isbconference1_udp           = (INT)  1244,   //  isbconference1
01670             c_isbconference2_tcp           = (INT)  1245,   //  isbconference2
01671             c_isbconference2_udp           = (INT)  1245,   //  isbconference2
01672             c_payrouter_tcp                = (INT)  1246,   //  payrouter
01673             c_payrouter_udp                = (INT)  1246,   //  payrouter
01674             c_visionpyramid_tcp            = (INT)  1247,   //  VisionPyramid
01675             c_visionpyramid_udp            = (INT)  1247,   //  VisionPyramid
01676             c_hermes_tcp                   = (INT)  1248,   //  hermes
01677             c_hermes_udp                   = (INT)  1248,   //  hermes
01678             c_mesavistaco_tcp              = (INT)  1249,   //  Mesa Vista Co
01679             c_mesavistaco_udp              = (INT)  1249,   //  Mesa Vista Co
01680             c_swldy_sias_tcp               = (INT)  1250,   //  swldy-sias
01681             c_swldy_sias_udp               = (INT)  1250,   //  swldy-sias
01682             c_servergraph_tcp              = (INT)  1251,   //  servergraph
01683             c_servergraph_udp              = (INT)  1251,   //  servergraph
01684             c_bspne_pcc_tcp                = (INT)  1252,   //  bspne-pcc
01685             c_bspne_pcc_udp                = (INT)  1252,   //  bspne-pcc
01686             c_q55_pcc_tcp                  = (INT)  1253,   //  q55-pcc
01687             c_q55_pcc_udp                  = (INT)  1253,   //  q55-pcc
01688             c_de_noc_tcp                   = (INT)  1254,   //  de-noc
01689             c_de_noc_udp                   = (INT)  1254,   //  de-noc
01690             c_de_cache_query_tcp           = (INT)  1255,   //  de-cache-query
01691             c_de_cache_query_udp           = (INT)  1255,   //  de-cache-query
01692             c_de_server_tcp                = (INT)  1256,   //  de-server
01693             c_de_server_udp                = (INT)  1256,   //  de-server
01694             c_shockwave2_tcp               = (INT)  1257,   //  Shockwave 2
01695             c_shockwave2_udp               = (INT)  1257,   //  Shockwave 2
01696             c_opennl_tcp                   = (INT)  1258,   //  Open Network Library
01697             c_opennl_udp                   = (INT)  1258,   //  Open Network Library
01698             c_opennl_voice_tcp             = (INT)  1259,   //  Open Network Library Voice
01699             c_opennl_voice_udp             = (INT)  1259,   //  Open Network Library Voice
01700             c_ibm_ssd_tcp                  = (INT)  1260,   //  ibm-ssd
01701             c_ibm_ssd_udp                  = (INT)  1260,   //  ibm-ssd
01702             c_mpshrsv_tcp                  = (INT)  1261,   //  mpshrsv
01703             c_mpshrsv_udp                  = (INT)  1261,   //  mpshrsv
01704             c_qnts_orb_tcp                 = (INT)  1262,   //  QNTS-ORB
01705             c_qnts_orb_udp                 = (INT)  1262,   //  QNTS-ORB
01706             c_dka_tcp                      = (INT)  1263,   //  dka
01707             c_dka_udp                      = (INT)  1263,   //  dka
01708             c_prat_tcp                     = (INT)  1264,   //  PRAT
01709             c_prat_udp                     = (INT)  1264,   //  PRAT
01710             c_dssiapi_tcp                  = (INT)  1265,   //  DSSIAPI
01711             c_dssiapi_udp                  = (INT)  1265,   //  DSSIAPI
01712             c_dellpwrappks_tcp             = (INT)  1266,   //  DELLPWRAPPKS
01713             c_dellpwrappks_udp             = (INT)  1266,   //  DELLPWRAPPKS
01714             c_pcmlinux_tcp                 = (INT)  1267,   //  pcmlinux
01715             c_pcmlinux_udp                 = (INT)  1267,   //  pcmlinux
01716             c_propel_msgsys_tcp            = (INT)  1268,   //  PROPEL-MSGSYS
01717             c_propel_msgsys_udp            = (INT)  1268,   //  PROPEL-MSGSYS
01718             c_watilapp_tcp                 = (INT)  1269,   //  WATiLaPP
01719             c_watilapp_udp                 = (INT)  1269,   //  WATiLaPP
01720             c_opsman_tcp                   = (INT)  1270,   //  opsman
01721             c_opsman_udp                   = (INT)  1270,   //  opsman
01722             c_dabew_tcp                    = (INT)  1271,   //  Dabew
01723             c_dabew_udp                    = (INT)  1271,   //  Dabew
01724             c_cspmlockmgr_tcp              = (INT)  1272,   //  CSPMLockMgr
01725             c_cspmlockmgr_udp              = (INT)  1272,   //  CSPMLockMgr
01726             c_emc_gateway_tcp              = (INT)  1273,   //  EMC-Gateway
01727             c_emc_gateway_udp              = (INT)  1273,   //  EMC-Gateway
01728             c_t1distproc_tcp               = (INT)  1274,   //  t1distproc
01729             c_t1distproc_udp               = (INT)  1274,   //  t1distproc
01730             c_ivcollector_tcp              = (INT)  1275,   //  ivcollector
01731             c_ivcollector_udp              = (INT)  1275,   //  ivcollector
01732             c_ivmanager_tcp                = (INT)  1276,   //  ivmanager
01733             c_ivmanager_udp                = (INT)  1276,   //  ivmanager
01734             c_miva_mqs_tcp                 = (INT)  1277,   //  mqs
01735             c_miva_mqs_udp                 = (INT)  1277,   //  mqs
01736             c_dellwebadmin_1_tcp           = (INT)  1278,   //  Dell Web Admin 1
01737             c_dellwebadmin_1_udp           = (INT)  1278,   //  Dell Web Admin 1
01738             c_dellwebadmin_2_tcp           = (INT)  1279,   //  Dell Web Admin 2
01739             c_dellwebadmin_2_udp           = (INT)  1279,   //  Dell Web Admin 2
01740             c_pictrography_tcp             = (INT)  1280,   //  Pictrography
01741             c_pictrography_udp             = (INT)  1280,   //  Pictrography
01742             c_healthd_tcp                  = (INT)  1281,   //  healthd
01743             c_healthd_udp                  = (INT)  1281,   //  healthd
01744             c_emperion_tcp                 = (INT)  1282,   //  Emperion
01745             c_emperion_udp                 = (INT)  1282,   //  Emperion
01746             c_productinfo_tcp              = (INT)  1283,   //  ProductInfo
01747             c_productinfo_udp              = (INT)  1283,   //  ProductInfo
01748             c_iee_qfx_tcp                  = (INT)  1284,   //  IEE-QFX
01749             c_iee_qfx_udp                  = (INT)  1284,   //  IEE-QFX
01750             c_neoiface_tcp                 = (INT)  1285,   //  neoiface
01751             c_neoiface_udp                 = (INT)  1285,   //  neoiface
01752             c_netuitive_tcp                = (INT)  1286,   //  netuitive
01753             c_netuitive_udp                = (INT)  1286,   //  netuitive
01754             c_navbuddy_tcp                 = (INT)  1288,   //  NavBuddy
01755             c_navbuddy_udp                 = (INT)  1288,   //  NavBuddy
01756             c_jwalkserver_tcp              = (INT)  1289,   //  JWalkServer
01757             c_jwalkserver_udp              = (INT)  1289,   //  JWalkServer
01758             c_winjaserver_tcp              = (INT)  1290,   //  WinJaServer
01759             c_winjaserver_udp              = (INT)  1290,   //  WinJaServer
01760             c_seagulllms_tcp               = (INT)  1291,   //  SEAGULLLMS
01761             c_seagulllms_udp               = (INT)  1291,   //  SEAGULLLMS
01762             c_dsdn_tcp                     = (INT)  1292,   //  dsdn
01763             c_dsdn_udp                     = (INT)  1292,   //  dsdn
01764             c_pkt_krb_ipsec_tcp            = (INT)  1293,   //  PKT-KRB-IPSec
01765             c_pkt_krb_ipsec_udp            = (INT)  1293,   //  PKT-KRB-IPSec
01766             c_cmmdriver_tcp                = (INT)  1294,   //  CMMdriver
01767             c_cmmdriver_udp                = (INT)  1294,   //  CMMdriver
01768             c_eetp_tcp                     = (INT)  1295,   //  EETP
01769             c_eetp_udp                     = (INT)  1295,   //  EETP
01770             c_dproxy_tcp                   = (INT)  1296,   //  dproxy
01771             c_dproxy_udp                   = (INT)  1296,   //  dproxy
01772             c_sdproxy_tcp                  = (INT)  1297,   //  sdproxy
01773             c_sdproxy_udp                  = (INT)  1297,   //  sdproxy
01774             c_lpcp_tcp                     = (INT)  1298,   //  lpcp
01775             c_lpcp_udp                     = (INT)  1298,   //  lpcp
01776             c_hp_sci_tcp                   = (INT)  1299,   //  hp-sci
01777             c_hp_sci_udp                   = (INT)  1299,   //  hp-sci
01778             c_h323hostcallsc_tcp           = (INT)  1300,   //  H323 Host Call Secure
01779             c_h323hostcallsc_udp           = (INT)  1300,   //  H323 Host Call Secure
01780             c_ci3_software_1_tcp           = (INT)  1301,   //  CI3-Software-1
01781             c_ci3_software_1_udp           = (INT)  1301,   //  CI3-Software-1
01782             c_ci3_software_2_tcp           = (INT)  1302,   //  CI3-Software-2
01783             c_ci3_software_2_udp           = (INT)  1302,   //  CI3-Software-2
01784             c_sftsrv_tcp                   = (INT)  1303,   //  sftsrv
01785             c_sftsrv_udp                   = (INT)  1303,   //  sftsrv
01786             c_boomerang_tcp                = (INT)  1304,   //  Boomerang
01787             c_boomerang_udp                = (INT)  1304,   //  Boomerang
01788             c_pe_mike_tcp                  = (INT)  1305,   //  pe-mike
01789             c_pe_mike_udp                  = (INT)  1305,   //  pe-mike
01790             c_re_conn_proto_tcp            = (INT)  1306,   //  RE-Conn-Proto
01791             c_re_conn_proto_udp            = (INT)  1306,   //  RE-Conn-Proto
01792             c_pacmand_tcp                  = (INT)  1307,   //  Pacmand
01793             c_pacmand_udp                  = (INT)  1307,   //  Pacmand
01794             c_odsi_tcp                     = (INT)  1308,   //  Optical Domain Service Interconnect (ODSI)
01795             c_odsi_udp                     = (INT)  1308,   //  Optical Domain Service Interconnect (ODSI)
01796             c_jtag_server_tcp              = (INT)  1309,   //  JTAG server
01797             c_jtag_server_udp              = (INT)  1309,   //  JTAG server
01798             c_husky_tcp                    = (INT)  1310,   //  Husky
01799             c_husky_udp                    = (INT)  1310,   //  Husky
01800             c_rxmon_tcp                    = (INT)  1311,   //  RxMon
01801             c_rxmon_udp                    = (INT)  1311,   //  RxMon
01802             c_sti_envision_tcp             = (INT)  1312,   //  STI Envision
01803             c_sti_envision_udp             = (INT)  1312,   //  STI Envision
01804             c_pdps_tcp                     = (INT)  1314,   //  Photoscript Distributed Printing System
01805             c_pdps_udp                     = (INT)  1314,   //  Photoscript Distributed Printing System
01806             c_els_tcp                      = (INT)  1315,   //  E.L.S., Event Listener Service
01807             c_els_udp                      = (INT)  1315,   //  E.L.S., Event Listener Service
01808             c_exbit_escp_tcp               = (INT)  1316,   //  Exbit-ESCP
01809             c_exbit_escp_udp               = (INT)  1316,   //  Exbit-ESCP
01810             c_vrts_ipcserver_tcp           = (INT)  1317,   //  vrts-ipcserver
01811             c_vrts_ipcserver_udp           = (INT)  1317,   //  vrts-ipcserver
01812             c_krb5gatekeeper_tcp           = (INT)  1318,   //  krb5gatekeeper
01813             c_krb5gatekeeper_udp           = (INT)  1318,   //  krb5gatekeeper
01814             c_panja_icsp_tcp               = (INT)  1319,   //  Panja-ICSP
01815             c_panja_icsp_udp               = (INT)  1319,   //  Panja-ICSP
01816             c_panja_axbnet_tcp             = (INT)  1320,   //  Panja-AXBNET
01817             c_panja_axbnet_udp             = (INT)  1320,   //  Panja-AXBNET
01818             c_pip_1_tcp                    = (INT)  1321,   //  PIP
01819             c_pip_1_udp                    = (INT)  1321,   //  PIP
01820             c_novation_tcp                 = (INT)  1322,   //  Novation
01821             c_novation_udp                 = (INT)  1322,   //  Novation
01822             c_brcd_tcp                     = (INT)  1323,   //  brcd
01823             c_brcd_udp                     = (INT)  1323,   //  brcd
01824             c_delta_mcp_tcp                = (INT)  1324,   //  delta-mcp
01825             c_delta_mcp_udp                = (INT)  1324,   //  delta-mcp
01826             c_dx_instrument_tcp            = (INT)  1325,   //  DX-Instrument
01827             c_dx_instrument_udp            = (INT)  1325,   //  DX-Instrument
01828             c_wimsic_tcp                   = (INT)  1326,   //  WIMSIC
01829             c_wimsic_udp                   = (INT)  1326,   //  WIMSIC
01830             c_ultrex_tcp                   = (INT)  1327,   //  Ultrex
01831             c_ultrex_udp                   = (INT)  1327,   //  Ultrex
01832             c_ewall_tcp                    = (INT)  1328,   //  EWALL
01833             c_ewall_udp                    = (INT)  1328,   //  EWALL
01834             c_netdb_export_tcp             = (INT)  1329,   //  netdb-export
01835             c_netdb_export_udp             = (INT)  1329,   //  netdb-export
01836             c_streetperfect_tcp            = (INT)  1330,   //  StreetPerfect
01837             c_streetperfect_udp            = (INT)  1330,   //  StreetPerfect
01838             c_intersan_tcp                 = (INT)  1331,   //  intersan
01839             c_intersan_udp                 = (INT)  1331,   //  intersan
01840             c_pcia_rxp_b_tcp               = (INT)  1332,   //  PCIA RXP-B
01841             c_pcia_rxp_b_udp               = (INT)  1332,   //  PCIA RXP-B
01842             c_passwrd_policy_tcp           = (INT)  1333,   //  Password Policy
01843             c_passwrd_policy_udp           = (INT)  1333,   //  Password Policy
01844             c_writesrv_tcp                 = (INT)  1334,   //  writesrv
01845             c_writesrv_udp                 = (INT)  1334,   //  writesrv
01846             c_digital_notary_tcp           = (INT)  1335,   //  Digital Notary Protocol
01847             c_digital_notary_udp           = (INT)  1335,   //  Digital Notary Protocol
01848             c_ischat_tcp                   = (INT)  1336,   //  Instant Service Chat
01849             c_ischat_udp                   = (INT)  1336,   //  Instant Service Chat
01850             c_menandmice_dns_tcp           = (INT)  1337,   //  menandmice DNS
01851             c_menandmice_dns_udp           = (INT)  1337,   //  menandmice DNS
01852             c_wmc_log_svc_tcp              = (INT)  1338,   //  WMC-log-svr
01853             c_wmc_log_svc_udp              = (INT)  1338,   //  WMC-log-svr
01854             c_kjtsiteserver_tcp            = (INT)  1339,   //  kjtsiteserver
01855             c_kjtsiteserver_udp            = (INT)  1339,   //  kjtsiteserver
01856             c_naap_tcp                     = (INT)  1340,   //  NAAP
01857             c_naap_udp                     = (INT)  1340,   //  NAAP
01858             c_qubes_tcp                    = (INT)  1341,   //  QuBES
01859             c_qubes_udp                    = (INT)  1341,   //  QuBES
01860             c_esbroker_tcp                 = (INT)  1342,   //  ESBroker
01861             c_esbroker_udp                 = (INT)  1342,   //  ESBroker
01862             c_re101_tcp                    = (INT)  1343,   //  re101
01863             c_re101_udp                    = (INT)  1343,   //  re101
01864             c_icap_tcp                     = (INT)  1344,   //  ICAP
01865             c_icap_udp                     = (INT)  1344,   //  ICAP
01866             c_vpjp_tcp                     = (INT)  1345,   //  VPJP
01867             c_vpjp_udp                     = (INT)  1345,   //  VPJP
01868             c_alta_ana_lm_tcp              = (INT)  1346,   //  Alta Analytics License Manager
01869             c_alta_ana_lm_udp              = (INT)  1346,   //  Alta Analytics License Manager
01870             c_bbn_mmc_tcp                  = (INT)  1347,   //  multi media conferencing
01871             c_bbn_mmc_udp                  = (INT)  1347,   //  multi media conferencing
01872             c_bbn_mmx_tcp                  = (INT)  1348,   //  multi media conferencing
01873             c_bbn_mmx_udp                  = (INT)  1348,   //  multi media conferencing
01874             c_sbook_tcp                    = (INT)  1349,   //  Registration Network Protocol
01875             c_sbook_udp                    = (INT)  1349,   //  Registration Network Protocol
01876             c_editbench_tcp                = (INT)  1350,   //  Registration Network Protocol
01877             c_editbench_udp                = (INT)  1350,   //  Registration Network Protocol
01878             c_equationbuilder_tcp          = (INT)  1351,   //  Digital Tool Works (MIT)
01879             c_equationbuilder_udp          = (INT)  1351,   //  Digital Tool Works (MIT)
01880             c_lotusnote_tcp                = (INT)  1352,   //  Lotus Note
01881             c_lotusnote_udp                = (INT)  1352,   //  Lotus Note
01882             c_relief_tcp                   = (INT)  1353,   //  Relief Consulting
01883             c_relief_udp                   = (INT)  1353,   //  Relief Consulting
01884             c_rightbrain_tcp               = (INT)  1354,   //  RightBrain Software
01885             c_rightbrain_udp               = (INT)  1354,   //  RightBrain Software
01886             c_intuitive_edge_tcp           = (INT)  1355,   //  Intuitive Edge
01887             c_intuitive_edge_udp           = (INT)  1355,   //  Intuitive Edge
01888             c_cuillamartin_tcp             = (INT)  1356,   //  CuillaMartin Company
01889             c_cuillamartin_udp             = (INT)  1356,   //  CuillaMartin Company
01890             c_pegboard_tcp                 = (INT)  1357,   //  Electronic PegBoard
01891             c_pegboard_udp                 = (INT)  1357,   //  Electronic PegBoard
01892             c_connlcli_tcp                 = (INT)  1358,   //  CONNLCLI
01893             c_connlcli_udp                 = (INT)  1358,   //  CONNLCLI
01894             c_ftsrv_tcp                    = (INT)  1359,   //  FTSRV
01895             c_ftsrv_udp                    = (INT)  1359,   //  FTSRV
01896             c_mimer_tcp                    = (INT)  1360,   //  MIMER
01897             c_mimer_udp                    = (INT)  1360,   //  MIMER
01898             c_linx_tcp                     = (INT)  1361,   //  LinX
01899             c_linx_udp                     = (INT)  1361,   //  LinX
01900             c_timeflies_tcp                = (INT)  1362,   //  TimeFlies
01901             c_timeflies_udp                = (INT)  1362,   //  TimeFlies
01902             c_ndm_requester_tcp            = (INT)  1363,   //  Network DataMover Requester
01903             c_ndm_requester_udp            = (INT)  1363,   //  Network DataMover Requester
01904             c_ndm_server_tcp               = (INT)  1364,   //  Network DataMover Server
01905             c_ndm_server_udp               = (INT)  1364,   //  Network DataMover Server
01906             c_adapt_sna_tcp                = (INT)  1365,   //  Network Software Associates
01907             c_adapt_sna_udp                = (INT)  1365,   //  Network Software Associates
01908             c_netware_csp_tcp              = (INT)  1366,   //  Novell NetWare Comm Service Platform
01909             c_netware_csp_udp              = (INT)  1366,   //  Novell NetWare Comm Service Platform
01910             c_dcs_tcp                      = (INT)  1367,   //  DCS
01911             c_dcs_udp                      = (INT)  1367,   //  DCS
01912             c_screencast_tcp               = (INT)  1368,   //  ScreenCast
01913             c_screencast_udp               = (INT)  1368,   //  ScreenCast
01914             c_gv_us_tcp                    = (INT)  1369,   //  GlobalView to Unix Shell
01915             c_gv_us_udp                    = (INT)  1369,   //  GlobalView to Unix Shell
01916             c_us_gv_tcp                    = (INT)  1370,   //  Unix Shell to GlobalView
01917             c_us_gv_udp                    = (INT)  1370,   //  Unix Shell to GlobalView
01918             c_fc_cli_tcp                   = (INT)  1371,   //  Fujitsu Config Protocol
01919             c_fc_cli_udp                   = (INT)  1371,   //  Fujitsu Config Protocol
01920             c_fc_ser_tcp                   = (INT)  1372,   //  Fujitsu Config Protocol
01921             c_fc_ser_udp                   = (INT)  1372,   //  Fujitsu Config Protocol
01922             c_chromagrafx_tcp              = (INT)  1373,   //  Chromagrafx
01923             c_chromagrafx_udp              = (INT)  1373,   //  Chromagrafx
01924             c_molly_tcp                    = (INT)  1374,   //  EPI Software Systems
01925             c_molly_udp                    = (INT)  1374,   //  EPI Software Systems
01926             c_bytex_tcp                    = (INT)  1375,   //  Bytex
01927             c_bytex_udp                    = (INT)  1375,   //  Bytex
01928             c_ibm_pps_tcp                  = (INT)  1376,   //  IBM Person to Person Software
01929             c_ibm_pps_udp                  = (INT)  1376,   //  IBM Person to Person Software
01930             c_cichlid_tcp                  = (INT)  1377,   //  Cichlid License Manager
01931             c_cichlid_udp                  = (INT)  1377,   //  Cichlid License Manager
01932             c_elan_tcp                     = (INT)  1378,   //  Elan License Manager
01933             c_elan_udp                     = (INT)  1378,   //  Elan License Manager
01934             c_dbreporter_tcp               = (INT)  1379,   //  Integrity Solutions
01935             c_dbreporter_udp               = (INT)  1379,   //  Integrity Solutions
01936             c_telesis_licman_tcp           = (INT)  1380,   //  Telesis Network License Manager
01937             c_telesis_licman_udp           = (INT)  1380,   //  Telesis Network License Manager
01938             c_apple_licman_tcp             = (INT)  1381,   //  Apple Network License Manager
01939             c_apple_licman_udp             = (INT)  1381,   //  Apple Network License Manager
01940             c_gwha_tcp                     = (INT)  1383,   //  GW Hannaway Network License Manager
01941             c_gwha_udp                     = (INT)  1383,   //  GW Hannaway Network License Manager
01942             c_os_licman_tcp                = (INT)  1384,   //  Objective Solutions License Manager
01943             c_os_licman_udp                = (INT)  1384,   //  Objective Solutions License Manager
01944             c_checksum_tcp                 = (INT)  1386,   //  CheckSum License Manager
01945             c_checksum_udp                 = (INT)  1386,   //  CheckSum License Manager
01946             c_cadsi_lm_tcp                 = (INT)  1387,   //  Computer Aided Design Software Inc LM
01947             c_cadsi_lm_udp                 = (INT)  1387,   //  Computer Aided Design Software Inc LM
01948             c_objective_dbc_tcp            = (INT)  1388,   //  Objective Solutions DataBase Cache
01949             c_objective_dbc_udp            = (INT)  1388,   //  Objective Solutions DataBase Cache
01950             c_iclpv_dm_tcp                 = (INT)  1389,   //  Document Manager
01951             c_iclpv_dm_udp                 = (INT)  1389,   //  Document Manager
01952             c_iclpv_sc_tcp                 = (INT)  1390,   //  Storage Controller
01953             c_iclpv_sc_udp                 = (INT)  1390,   //  Storage Controller
01954             c_iclpv_sas_tcp                = (INT)  1391,   //  Storage Access Server
01955             c_iclpv_sas_udp                = (INT)  1391,   //  Storage Access Server
01956             c_iclpv_pm_tcp                 = (INT)  1392,   //  Print Manager
01957             c_iclpv_pm_udp                 = (INT)  1392,   //  Print Manager
01958             c_iclpv_nls_tcp                = (INT)  1393,   //  Network Log Server
01959             c_iclpv_nls_udp                = (INT)  1393,   //  Network Log Server
01960             c_iclpv_nlc_tcp                = (INT)  1394,   //  Network Log Client
01961             c_iclpv_nlc_udp                = (INT)  1394,   //  Network Log Client
01962             c_iclpv_wsm_tcp                = (INT)  1395,   //  PC Workstation Manager software
01963             c_iclpv_wsm_udp                = (INT)  1395,   //  PC Workstation Manager software
01964             c_dvl_activemail_tcp           = (INT)  1396,   //  DVL Active Mail
01965             c_dvl_activemail_udp           = (INT)  1396,   //  DVL Active Mail
01966             c_audio_activmail_tcp          = (INT)  1397,   //  Audio Active Mail
01967             c_audio_activmail_udp          = (INT)  1397,   //  Audio Active Mail
01968             c_video_activmail_tcp          = (INT)  1398,   //  Video Active Mail
01969             c_video_activmail_udp          = (INT)  1398,   //  Video Active Mail
01970             c_cadkey_licman_tcp            = (INT)  1399,   //  Cadkey License Manager
01971             c_cadkey_licman_udp            = (INT)  1399,   //  Cadkey License Manager
01972             c_cadkey_tablet_tcp            = (INT)  1400,   //  Cadkey Tablet Daemon
01973             c_cadkey_tablet_udp            = (INT)  1400,   //  Cadkey Tablet Daemon
01974             c_goldleaf_licman_tcp          = (INT)  1401,   //  Goldleaf License Manager
01975             c_goldleaf_licman_udp          = (INT)  1401,   //  Goldleaf License Manager
01976             c_prm_sm_np_tcp                = (INT)  1402,   //  Prospero Resource Manager
01977             c_prm_sm_np_udp                = (INT)  1402,   //  Prospero Resource Manager
01978             c_prm_nm_np_tcp                = (INT)  1403,   //  Prospero Resource Manager
01979             c_prm_nm_np_udp                = (INT)  1403,   //  Prospero Resource Manager
01980             c_igi_lm_tcp                   = (INT)  1404,   //  Infinite Graphics License Manager
01981             c_igi_lm_udp                   = (INT)  1404,   //  Infinite Graphics License Manager
01982             c_ibm_res_tcp                  = (INT)  1405,   //  IBM Remote Execution Starter
01983             c_ibm_res_udp                  = (INT)  1405,   //  IBM Remote Execution Starter
01984             c_netlabs_lm_tcp               = (INT)  1406,   //  NetLabs License Manager
01985             c_netlabs_lm_udp               = (INT)  1406,   //  NetLabs License Manager
01986             c_dbsa_lm_tcp                  = (INT)  1407,   //  DBSA License Manager
01987             c_dbsa_lm_udp                  = (INT)  1407,   //  DBSA License Manager
01988             c_sophia_lm_tcp                = (INT)  1408,   //  Sophia License Manager
01989             c_sophia_lm_udp                = (INT)  1408,   //  Sophia License Manager
01990             c_here_lm_tcp                  = (INT)  1409,   //  Here License Manager
01991             c_here_lm_udp                  = (INT)  1409,   //  Here License Manager
01992             c_hiq_tcp                      = (INT)  1410,   //  HiQ License Manager
01993             c_hiq_udp                      = (INT)  1410,   //  HiQ License Manager
01994             c_af_tcp                       = (INT)  1411,   //  AudioFile
01995             c_af_udp                       = (INT)  1411,   //  AudioFile
01996             c_innosys_tcp                  = (INT)  1412,   //  InnoSys
01997             c_innosys_udp                  = (INT)  1412,   //  InnoSys
01998             c_innosys_acl_tcp              = (INT)  1413,   //  Innosys-ACL
01999             c_innosys_acl_udp              = (INT)  1413,   //  Innosys-ACL
02000             c_ibm_mqseries_tcp             = (INT)  1414,   //  IBM MQSeries
02001             c_ibm_mqseries_udp             = (INT)  1414,   //  IBM MQSeries
02002             c_dbstar_tcp                   = (INT)  1415,   //  DBStar
02003             c_dbstar_udp                   = (INT)  1415,   //  DBStar
02004             c_timbuktu_srv1_tcp            = (INT)  1417,   //  Timbuktu Service 1 Port
02005             c_timbuktu_srv1_udp            = (INT)  1417,   //  Timbuktu Service 1 Port
02006             c_timbuktu_srv2_tcp            = (INT)  1418,   //  Timbuktu Service 2 Port
02007             c_timbuktu_srv2_udp            = (INT)  1418,   //  Timbuktu Service 2 Port
02008             c_timbuktu_srv3_tcp            = (INT)  1419,   //  Timbuktu Service 3 Port
02009             c_timbuktu_srv3_udp            = (INT)  1419,   //  Timbuktu Service 3 Port
02010             c_timbuktu_srv4_tcp            = (INT)  1420,   //  Timbuktu Service 4 Port
02011             c_timbuktu_srv4_udp            = (INT)  1420,   //  Timbuktu Service 4 Port
02012             c_gandalf_lm_tcp               = (INT)  1421,   //  Gandalf License Manager
02013             c_gandalf_lm_udp               = (INT)  1421,   //  Gandalf License Manager
02014             c_autodesk_lm_tcp              = (INT)  1422,   //  Autodesk License Manager
02015             c_autodesk_lm_udp              = (INT)  1422,   //  Autodesk License Manager
02016             c_essbase_tcp                  = (INT)  1423,   //  Essbase Arbor Software
02017             c_essbase_udp                  = (INT)  1423,   //  Essbase Arbor Software
02018             c_hybrid_tcp                   = (INT)  1424,   //  Hybrid Encryption Protocol
02019             c_hybrid_udp                   = (INT)  1424,   //  Hybrid Encryption Protocol
02020             c_zion_lm_tcp                  = (INT)  1425,   //  Zion Software License Manager
02021             c_zion_lm_udp                  = (INT)  1425,   //  Zion Software License Manager
02022             c_sais_tcp                     = (INT)  1426,   //  Satellite-data Acquisition System 1
02023             c_sais_udp                     = (INT)  1426,   //  Satellite-data Acquisition System 1
02024             c_mloadd_tcp                   = (INT)  1427,   //  mloadd monitoring tool
02025             c_mloadd_udp                   = (INT)  1427,   //  mloadd monitoring tool
02026             c_informatik_lm_tcp            = (INT)  1428,   //  Informatik License Manager
02027             c_informatik_lm_udp            = (INT)  1428,   //  Informatik License Manager
02028             c_nms_tcp                      = (INT)  1429,   //  Hypercom NMS
02029             c_nms_udp                      = (INT)  1429,   //  Hypercom NMS
02030             c_tpdu_tcp                     = (INT)  1430,   //  Hypercom TPDU
02031             c_tpdu_udp                     = (INT)  1430,   //  Hypercom TPDU
02032             c_rgtp_tcp                     = (INT)  1431,   //  Reverse Gossip Transport
02033             c_rgtp_udp                     = (INT)  1431,   //  Reverse Gossip Transport
02034             c_blueberry_lm_tcp             = (INT)  1432,   //  Blueberry Software License Manager
02035             c_blueberry_lm_udp             = (INT)  1432,   //  Blueberry Software License Manager
02036             c_ms_sql_s_tcp                 = (INT)  1433,   //  Microsoft-SQL-Server
02037             c_ms_sql_s_udp                 = (INT)  1433,   //  Microsoft-SQL-Server
02038             c_ms_sql_m_tcp                 = (INT)  1434,   //  Microsoft-SQL-Monitor
02039             c_ms_sql_m_udp                 = (INT)  1434,   //  Microsoft-SQL-Monitor
02040             c_ibm_cics_tcp                 = (INT)  1435,   //  IBM CICS
02041             c_ibm_cics_udp                 = (INT)  1435,   //  IBM CICS
02042             c_saism_tcp                    = (INT)  1436,   //  Satellite-data Acquisition System 2
02043             c_saism_udp                    = (INT)  1436,   //  Satellite-data Acquisition System 2
02044             c_tabula_tcp                   = (INT)  1437,   //  Tabula
02045             c_tabula_udp                   = (INT)  1437,   //  Tabula
02046             c_eicon_server_tcp             = (INT)  1438,   //  Eicon Security Agent/Server
02047             c_eicon_server_udp             = (INT)  1438,   //  Eicon Security Agent/Server
02048             c_eicon_x25_tcp                = (INT)  1439,   //  Eicon X25/SNA Gateway
02049             c_eicon_x25_udp                = (INT)  1439,   //  Eicon X25/SNA Gateway
02050             c_eicon_slp_tcp                = (INT)  1440,   //  Eicon Service Location Protocol
02051             c_eicon_slp_udp                = (INT)  1440,   //  Eicon Service Location Protocol
02052             c_cadis_1_tcp                  = (INT)  1441,   //  Cadis License Management
02053             c_cadis_1_udp                  = (INT)  1441,   //  Cadis License Management
02054             c_cadis_2_tcp                  = (INT)  1442,   //  Cadis License Management
02055             c_cadis_2_udp                  = (INT)  1442,   //  Cadis License Management
02056             c_ies_lm_tcp                   = (INT)  1443,   //  Integrated Engineering Software
02057             c_ies_lm_udp                   = (INT)  1443,   //  Integrated Engineering Software
02058             c_marcam_lm_tcp                = (INT)  1444,   //  Marcam License Management
02059             c_marcam_lm_udp                = (INT)  1444,   //  Marcam License Management
02060             c_proxima_lm_tcp               = (INT)  1445,   //  Proxima License Manager
02061             c_proxima_lm_udp               = (INT)  1445,   //  Proxima License Manager
02062             c_ora_lm_tcp                   = (INT)  1446,   //  Optical Research Associates License Manager
02063             c_ora_lm_udp                   = (INT)  1446,   //  Optical Research Associates License Manager
02064             c_apri_lm_tcp                  = (INT)  1447,   //  Applied Parallel Research LM
02065             c_apri_lm_udp                  = (INT)  1447,   //  Applied Parallel Research LM
02066             c_oc_lm_tcp                    = (INT)  1448,   //  OpenConnect License Manager
02067             c_oc_lm_udp                    = (INT)  1448,   //  OpenConnect License Manager
02068             c_peport_tcp                   = (INT)  1449,   //  PEport
02069             c_peport_udp                   = (INT)  1449,   //  PEport
02070             c_dwf_tcp                      = (INT)  1450,   //  Tandem Distributed Workbench Facility
02071             c_dwf_udp                      = (INT)  1450,   //  Tandem Distributed Workbench Facility
02072             c_infoman_tcp                  = (INT)  1451,   //  IBM Information Management
02073             c_infoman_udp                  = (INT)  1451,   //  IBM Information Management
02074             c_gtegsc_lm_tcp                = (INT)  1452,   //  GTE Government Systems License Man
02075             c_gtegsc_lm_udp                = (INT)  1452,   //  GTE Government Systems License Man
02076             c_genie_lm_tcp                 = (INT)  1453,   //  Genie License Manager
02077             c_genie_lm_udp                 = (INT)  1453,   //  Genie License Manager
02078             c_esl_lm_tcp                   = (INT)  1455,   //  ESL License Manager
02079             c_esl_lm_udp                   = (INT)  1455,   //  ESL License Manager
02080             c_dca_tcp                      = (INT)  1456,   //  DCA
02081             c_dca_udp                      = (INT)  1456,   //  DCA
02082             c_valisys_lm_tcp               = (INT)  1457,   //  Valisys License Manager
02083             c_valisys_lm_udp               = (INT)  1457,   //  Valisys License Manager
02084             c_nrcabq_lm_tcp                = (INT)  1458,   //  Nichols Research Corp.
02085             c_nrcabq_lm_udp                = (INT)  1458,   //  Nichols Research Corp.
02086             c_proshare1_tcp                = (INT)  1459,   //  Proshare Notebook Application
02087             c_proshare1_udp                = (INT)  1459,   //  Proshare Notebook Application
02088             c_proshare2_tcp                = (INT)  1460,   //  Proshare Notebook Application
02089             c_proshare2_udp                = (INT)  1460,   //  Proshare Notebook Application
02090             c_world_lm_tcp                 = (INT)  1462,   //  World License Manager
02091             c_world_lm_udp                 = (INT)  1462,   //  World License Manager
02092             c_nucleus_tcp                  = (INT)  1463,   //  Nucleus
02093             c_nucleus_udp                  = (INT)  1463,   //  Nucleus
02094             c_pipes_tcp                    = (INT)  1465,   //  Pipes Platform
02095             c_pipes_udp                    = (INT)  1465,   //  Pipes Platform mfarlin@peerlogic.com
02096             c_oceansoft_lm_tcp             = (INT)  1466,   //  Ocean Software License Manager
02097             c_oceansoft_lm_udp             = (INT)  1466,   //  Ocean Software License Manager
02098             c_csdmbase_tcp                 = (INT)  1467,   //  CSDMBASE
02099             c_csdmbase_udp                 = (INT)  1467,   //  CSDMBASE
02100             c_csdm_tcp                     = (INT)  1468,   //  CSDM
02101             c_csdm_udp                     = (INT)  1468,   //  CSDM
02102             c_aal_lm_tcp                   = (INT)  1469,   //  Active Analysis Limited License Manager
02103             c_aal_lm_udp                   = (INT)  1469,   //  Active Analysis Limited License Manager
02104             c_uaiact_tcp                   = (INT)  1470,   //  Universal Analytics
02105             c_uaiact_udp                   = (INT)  1470,   //  Universal Analytics
02106             c_csdmbase_1_tcp               = (INT)  1471,   //  csdmbase
02107             c_csdmbase_1_udp               = (INT)  1471,   //  csdmbase
02108             c_csdm_1_tcp                   = (INT)  1472,   //  csdm
02109             c_csdm_1_udp                   = (INT)  1472,   //  csdm
02110             c_openmath_tcp                 = (INT)  1473,   //  OpenMath
02111             c_openmath_udp                 = (INT)  1473,   //  OpenMath
02112             c_telefinder_tcp               = (INT)  1474,   //  Telefinder
02113             c_telefinder_udp               = (INT)  1474,   //  Telefinder
02114             c_taligent_lm_tcp              = (INT)  1475,   //  Taligent License Manager
02115             c_taligent_lm_udp              = (INT)  1475,   //  Taligent License Manager
02116             c_clvm_cfg_tcp                 = (INT)  1476,   //  clvm-cfg
02117             c_clvm_cfg_udp                 = (INT)  1476,   //  clvm-cfg
02118             c_ms_sna_server_tcp            = (INT)  1477,   //  ms-sna-server
02119             c_ms_sna_server_udp            = (INT)  1477,   //  ms-sna-server
02120             c_ms_sna_base_tcp              = (INT)  1478,   //  ms-sna-base
02121             c_ms_sna_base_udp              = (INT)  1478,   //  ms-sna-base
02122             c_dberegister_tcp              = (INT)  1479,   //  dberegister
02123             c_dberegister_udp              = (INT)  1479,   //  dberegister
02124             c_pacerforum_tcp               = (INT)  1480,   //  PacerForum
02125             c_pacerforum_udp               = (INT)  1480,   //  PacerForum
02126             c_airs_tcp                     = (INT)  1481,   //  AIRS
02127             c_airs_udp                     = (INT)  1481,   //  AIRS
02128             c_miteksys_lm_tcp              = (INT)  1482,   //  Miteksys License Manager
02129             c_miteksys_lm_udp              = (INT)  1482,   //  Miteksys License Manager
02130             c_afs_tcp                      = (INT)  1483,   //  AFS License Manager
02131             c_afs_udp                      = (INT)  1483,   //  AFS License Manager
02132             c_confluent_tcp                = (INT)  1484,   //  Confluent License Manager
02133             c_confluent_udp                = (INT)  1484,   //  Confluent License Manager
02134             c_lansource_tcp                = (INT)  1485,   //  LANSource
02135             c_lansource_udp                = (INT)  1485,   //  LANSource
02136             c_localinfosrvr_tcp            = (INT)  1487,   //  LocalInfoSrvr
02137             c_localinfosrvr_udp            = (INT)  1487,   //  LocalInfoSrvr
02138             c_docstor_tcp                  = (INT)  1488,   //  DocStor
02139             c_docstor_udp                  = (INT)  1488,   //  DocStor
02140             c_dmdocbroker_tcp              = (INT)  1489,   //  dmdocbroker
02141             c_dmdocbroker_udp              = (INT)  1489,   //  dmdocbroker
02142             c_insitu_conf_tcp              = (INT)  1490,   //  insitu-conf
02143             c_insitu_conf_udp              = (INT)  1490,   //  insitu-conf
02144             c_anynetgateway_tcp            = (INT)  1491,   //  anynetgateway
02145             c_anynetgateway_udp            = (INT)  1491,   //  anynetgateway
02146             c_stone_design_1_tcp           = (INT)  1492,   //  stone-design-1
02147             c_stone_design_1_udp           = (INT)  1492,   //  stone-design-1
02148             c_ica_tcp                      = (INT)  1494,   //  ica
02149             c_ica_udp                      = (INT)  1494,   //  ica
02150             c_cvc_tcp                      = (INT)  1495,   //  cvc
02151             c_cvc_udp                      = (INT)  1495,   //  cvc
02152             c_liberty_lm_tcp               = (INT)  1496,   //  liberty-lm
02153             c_liberty_lm_udp               = (INT)  1496,   //  liberty-lm
02154             c_rfx_lm_tcp                   = (INT)  1497,   //  rfx-lm
02155             c_rfx_lm_udp                   = (INT)  1497,   //  rfx-lm
02156             c_sybase_sqlany_tcp            = (INT)  1498,   //  Sybase SQL Any
02157             c_sybase_sqlany_udp            = (INT)  1498,   //  Sybase SQL Any
02158             c_fhc_tcp                      = (INT)  1499,   //  Federico Heinz Consultora
02159             c_fhc_udp                      = (INT)  1499,   //  Federico Heinz Consultora
02160             c_vlsi_lm_tcp                  = (INT)  1500,   //  VLSI License Manager
02161             c_vlsi_lm_udp                  = (INT)  1500,   //  VLSI License Manager
02162             c_saiscm_tcp                   = (INT)  1501,   //  Satellite-data Acquisition System 3
02163             c_saiscm_udp                   = (INT)  1501,   //  Satellite-data Acquisition System 3
02164             c_shivadiscovery_tcp           = (INT)  1502,   //  Shiva
02165             c_shivadiscovery_udp           = (INT)  1502,   //  Shiva
02166             c_imtc_mcs_tcp                 = (INT)  1503,   //  Databeam
02167             c_imtc_mcs_udp                 = (INT)  1503,   //  Databeam
02168             c_evb_elm_tcp                  = (INT)  1504,   //  EVB Software Engineering License Manager
02169             c_evb_elm_udp                  = (INT)  1504,   //  EVB Software Engineering License Manager
02170             c_funkproxy_tcp                = (INT)  1505,   //  Funk Software, Inc.
02171             c_funkproxy_udp                = (INT)  1505,   //  Funk Software, Inc.
02172             c_utcd_tcp                     = (INT)  1506,   //  Universal Time daemon (utcd)
02173             c_utcd_udp                     = (INT)  1506,   //  Universal Time daemon (utcd)
02174             c_symplex_tcp                  = (INT)  1507,   //  symplex
02175             c_symplex_udp                  = (INT)  1507,   //  symplex
02176             c_diagmond_tcp                 = (INT)  1508,   //  diagmond
02177             c_diagmond_udp                 = (INT)  1508,   //  diagmond
02178             c_robcad_lm_tcp                = (INT)  1509,   //  Robcad, Ltd. License Manager
02179             c_robcad_lm_udp                = (INT)  1509,   //  Robcad, Ltd. License Manager
02180             c_mvx_lm_tcp                   = (INT)  1510,   //  Midland Valley Exploration Ltd. Lic. Man.
02181             c_mvx_lm_udp                   = (INT)  1510,   //  Midland Valley Exploration Ltd. Lic. Man.
02182             c_3l_l1_tcp                    = (INT)  1511,   //  3l-l1
02183             c_3l_l1_udp                    = (INT)  1511,   //  3l-l1
02184             c_wins_tcp                     = (INT)  1512,   //  Microsoft's Windows Internet Name Service
02185             c_wins_udp                     = (INT)  1512,   //  Microsoft's Windows Internet Name Service
02186             c_fujitsu_dtc_tcp              = (INT)  1513,   //  Fujitsu Systems Business of America, Inc
02187             c_fujitsu_dtc_udp              = (INT)  1513,   //  Fujitsu Systems Business of America, Inc
02188             c_fujitsu_dtcns_tcp            = (INT)  1514,   //  Fujitsu Systems Business of America, Inc
02189             c_fujitsu_dtcns_udp            = (INT)  1514,   //  Fujitsu Systems Business of America, Inc
02190             c_ifor_protocol_tcp            = (INT)  1515,   //  ifor-protocol
02191             c_ifor_protocol_udp            = (INT)  1515,   //  ifor-protocol
02192             c_vpad_tcp                     = (INT)  1516,   //  Virtual Places Audio data
02193             c_vpad_udp                     = (INT)  1516,   //  Virtual Places Audio data
02194             c_vpac_tcp                     = (INT)  1517,   //  Virtual Places Audio control
02195             c_vpac_udp                     = (INT)  1517,   //  Virtual Places Audio control
02196             c_vpvd_tcp                     = (INT)  1518,   //  Virtual Places Video data
02197             c_vpvd_udp                     = (INT)  1518,   //  Virtual Places Video data
02198             c_vpvc_tcp                     = (INT)  1519,   //  Virtual Places Video control
02199             c_vpvc_udp                     = (INT)  1519,   //  Virtual Places Video control
02200             c_atm_zip_office_tcp           = (INT)  1520,   //  atm zip office
02201             c_atm_zip_office_udp           = (INT)  1520,   //  atm zip office
02202             c_ncube_lm_tcp                 = (INT)  1521,   //  nCube License Manager
02203             c_ncube_lm_udp                 = (INT)  1521,   //  nCube License Manager
02204             c_ricardo_lm_tcp               = (INT)  1522,   //  Ricardo North America License Manager
02205             c_ricardo_lm_udp               = (INT)  1522,   //  Ricardo North America License Manager
02206             c_cichild_lm_tcp               = (INT)  1523,   //  cichild
02207             c_cichild_lm_udp               = (INT)  1523,   //  cichild
02208             c_ingreslock_tcp               = (INT)  1524,   //  ingres
02209             c_ingreslock_udp               = (INT)  1524,   //  ingres
02210             c_orasrv_tcp                   = (INT)  1525,   //  oracle
02211             c_orasrv_udp                   = (INT)  1525,   //  oracle
02212             c_prospero_np_tcp              = (INT)  1525,   //  Prospero Directory Service non-priv
02213             c_prospero_np_udp              = (INT)  1525,   //  Prospero Directory Service non-priv
02214             c_pdap_np_tcp                  = (INT)  1526,   //  Prospero Data Access Prot non-priv
02215             c_pdap_np_udp                  = (INT)  1526,   //  Prospero Data Access Prot non-priv
02216             c_tlisrv_tcp                   = (INT)  1527,   //  oracle
02217             c_tlisrv_udp                   = (INT)  1527,   //  oracle
02218             c_mciautoreg_tcp               = (INT)  1528,   //  micautoreg
02219             c_mciautoreg_udp               = (INT)  1528,   //  micautoreg
02220             c_coauthor_tcp                 = (INT)  1529,   //  oracle
02221             c_coauthor_udp                 = (INT)  1529,   //  oracle
02222             c_rap_service_tcp              = (INT)  1530,   //  rap-service
02223             c_rap_service_udp              = (INT)  1530,   //  rap-service
02224             c_rap_listen_tcp               = (INT)  1531,   //  rap-listen
02225             c_rap_listen_udp               = (INT)  1531,   //  rap-listen
02226             c_miroconnect_tcp              = (INT)  1532,   //  miroconnect
02227             c_miroconnect_udp              = (INT)  1532,   //  miroconnect
02228             c_virtual_places_tcp           = (INT)  1533,   //  Virtual Places Software
02229             c_virtual_places_udp           = (INT)  1533,   //  Virtual Places Software
02230             c_micromuse_lm_tcp             = (INT)  1534,   //  micromuse-lm
02231             c_micromuse_lm_udp             = (INT)  1534,   //  micromuse-lm
02232             c_ampr_info_tcp                = (INT)  1535,   //  ampr-info
02233             c_ampr_info_udp                = (INT)  1535,   //  ampr-info
02234             c_ampr_inter_tcp               = (INT)  1536,   //  ampr-inter
02235             c_ampr_inter_udp               = (INT)  1536,   //  ampr-inter
02236             c_sdsc_lm_tcp                  = (INT)  1537,   //  isi-lm
02237             c_sdsc_lm_udp                  = (INT)  1537,   //  isi-lm
02238             c_3ds_lm_tcp                   = (INT)  1538,   //  3ds-lm
02239             c_3ds_lm_udp                   = (INT)  1538,   //  3ds-lm
02240             c_intellistor_lm_tcp           = (INT)  1539,   //  Intellistor License Manager
02241             c_intellistor_lm_udp           = (INT)  1539,   //  Intellistor License Manager
02242             c_rds_tcp                      = (INT)  1540,   //  rds
02243             c_rds_udp                      = (INT)  1540,   //  rds
02244             c_rds2_tcp                     = (INT)  1541,   //  rds2
02245             c_rds2_udp                     = (INT)  1541,   //  rds2
02246             c_gridgen_elmd_tcp             = (INT)  1542,   //  gridgen-elmd
02247             c_gridgen_elmd_udp             = (INT)  1542,   //  gridgen-elmd
02248             c_simba_cs_tcp                 = (INT)  1543,   //  simba-cs
02249             c_simba_cs_udp                 = (INT)  1543,   //  simba-cs
02250             c_aspeclmd_tcp                 = (INT)  1544,   //  aspeclmd
02251             c_aspeclmd_udp                 = (INT)  1544,   //  aspeclmd
02252             c_vistium_share_tcp            = (INT)  1545,   //  vistium-share
02253             c_vistium_share_udp            = (INT)  1545,   //  vistium-share
02254             c_abbaccuray_tcp               = (INT)  1546,   //  abbaccuray
02255             c_abbaccuray_udp               = (INT)  1546,   //  abbaccuray
02256             c_laplink_tcp                  = (INT)  1547,   //  laplink
02257             c_laplink_udp                  = (INT)  1547,   //  laplink
02258             c_axon_lm_tcp                  = (INT)  1548,   //  Axon License Manager
02259             c_axon_lm_udp                  = (INT)  1548,   //  Axon License Manager
02260             c_shivahose_tcp                = (INT)  1549,   //  Shiva Hose
02261             c_shivasound_udp               = (INT)  1549,   //  Shiva Sound
02262             c_3m_image_lm_tcp              = (INT)  1550,   //  Image Storage license manager 3M Company
02263             c_3m_image_lm_udp              = (INT)  1550,   //  Image Storage license manager 3M Company
02264             c_hecmtl_db_tcp                = (INT)  1551,   //  HECMTL-DB
02265             c_hecmtl_db_udp                = (INT)  1551,   //  HECMTL-DB
02266             c_pciarray_tcp                 = (INT)  1552,   //  pciarray
02267             c_pciarray_udp                 = (INT)  1552,   //  pciarray
02268             c_sna_cs_tcp                   = (INT)  1553,   //  sna-cs
02269             c_sna_cs_udp                   = (INT)  1553,   //  sna-cs
02270             c_caci_lm_tcp                  = (INT)  1554,   //  CACI Products Company License Manager
02271             c_caci_lm_udp                  = (INT)  1554,   //  CACI Products Company License Manager
02272             c_livelan_tcp                  = (INT)  1555,   //  livelan
02273             c_livelan_udp                  = (INT)  1555,   //  livelan
02274             c_ashwin_tcp                   = (INT)  1556,   //  AshWin CI Tecnologies
02275             c_ashwin_udp                   = (INT)  1556,   //  AshWin CI Tecnologies
02276             c_arbortext_lm_tcp             = (INT)  1557,   //  ArborText License Manager
02277             c_arbortext_lm_udp             = (INT)  1557,   //  ArborText License Manager
02278             c_xingmpeg_tcp                 = (INT)  1558,   //  xingmpeg
02279             c_xingmpeg_udp                 = (INT)  1558,   //  xingmpeg
02280             c_web2host_tcp                 = (INT)  1559,   //  web2host
02281             c_web2host_udp                 = (INT)  1559,   //  web2host
02282             c_asci_val_tcp                 = (INT)  1560,   //  asci-val
02283             c_asci_val_udp                 = (INT)  1560,   //  asci-val
02284             c_facilityview_tcp             = (INT)  1561,   //  facilityview
02285             c_facilityview_udp             = (INT)  1561,   //  facilityview
02286             c_pconnectmgr_tcp              = (INT)  1562,   //  pconnectmgr
02287             c_pconnectmgr_udp              = (INT)  1562,   //  pconnectmgr
02288             c_cadabra_lm_tcp               = (INT)  1563,   //  Cadabra License Manager
02289             c_cadabra_lm_udp               = (INT)  1563,   //  Cadabra License Manager
02290             c_pay_per_view_tcp             = (INT)  1564,   //  Pay-Per-View
02291             c_pay_per_view_udp             = (INT)  1564,   //  Pay-Per-View
02292             c_winddlb_tcp                  = (INT)  1565,   //  WinDD
02293             c_winddlb_udp                  = (INT)  1565,   //  WinDD
02294             c_corelvideo_tcp               = (INT)  1566,   //  CORELVIDEO
02295             c_corelvideo_udp               = (INT)  1566,   //  CORELVIDEO
02296             c_jlicelmd_tcp                 = (INT)  1567,   //  jlicelmd
02297             c_jlicelmd_udp                 = (INT)  1567,   //  jlicelmd
02298             c_tsspmap_tcp                  = (INT)  1568,   //  tsspmap
02299             c_tsspmap_udp                  = (INT)  1568,   //  tsspmap
02300             c_ets_tcp                      = (INT)  1569,   //  ets
02301             c_ets_udp                      = (INT)  1569,   //  ets
02302             c_orbixd_tcp                   = (INT)  1570,   //  orbixd
02303             c_orbixd_udp                   = (INT)  1570,   //  orbixd
02304             c_rdb_dbs_disp_tcp             = (INT)  1571,   //  Oracle Remote Data Base
02305             c_rdb_dbs_disp_udp             = (INT)  1571,   //  Oracle Remote Data Base
02306             c_chip_lm_tcp                  = (INT)  1572,   //  Chipcom License Manager
02307             c_chip_lm_udp                  = (INT)  1572,   //  Chipcom License Manager
02308             c_itscomm_ns_tcp               = (INT)  1573,   //  itscomm-ns
02309             c_itscomm_ns_udp               = (INT)  1573,   //  itscomm-ns
02310             c_mvel_lm_tcp                  = (INT)  1574,   //  mvel-lm
02311             c_mvel_lm_udp                  = (INT)  1574,   //  mvel-lm
02312             c_oraclenames_tcp              = (INT)  1575,   //  oraclenames
02313             c_oraclenames_udp              = (INT)  1575,   //  oraclenames
02314             c_moldflow_lm_tcp              = (INT)  1576,   //  moldflow-lm
02315             c_moldflow_lm_udp              = (INT)  1576,   //  moldflow-lm
02316             c_hypercube_lm_tcp             = (INT)  1577,   //  hypercube-lm
02317             c_hypercube_lm_udp             = (INT)  1577,   //  hypercube-lm
02318             c_jacobus_lm_tcp               = (INT)  1578,   //  Jacobus License Manager
02319             c_jacobus_lm_udp               = (INT)  1578,   //  Jacobus License Manager
02320             c_ioc_sea_lm_tcp               = (INT)  1579,   //  ioc-sea-lm
02321             c_ioc_sea_lm_udp               = (INT)  1579,   //  ioc-sea-lm
02322             c_tn_tl_r1_tcp                 = (INT)  1580,   //  tn-tl-r1
02323             c_tn_tl_r2_udp                 = (INT)  1580,   //  tn-tl-r2
02324             c_mil_2045_47001_tcp           = (INT)  1581,   //  MIL-2045-47001
02325             c_mil_2045_47001_udp           = (INT)  1581,   //  MIL-2045-47001
02326             c_msims_tcp                    = (INT)  1582,   //  MSIMS
02327             c_msims_udp                    = (INT)  1582,   //  MSIMS
02328             c_simbaexpress_tcp             = (INT)  1583,   //  simbaexpress
02329             c_simbaexpress_udp             = (INT)  1583,   //  simbaexpress
02330             c_tn_tl_fd2_tcp                = (INT)  1584,   //  tn-tl-fd2
02331             c_tn_tl_fd2_udp                = (INT)  1584,   //  tn-tl-fd2
02332             c_intv_tcp                     = (INT)  1585,   //  intv
02333             c_intv_udp                     = (INT)  1585,   //  intv
02334             c_ibm_abtact_tcp               = (INT)  1586,   //  ibm-abtact
02335             c_ibm_abtact_udp               = (INT)  1586,   //  ibm-abtact
02336             c_triquest_lm_tcp              = (INT)  1588,   //  triquest-lm
02337             c_triquest_lm_udp              = (INT)  1588,   //  triquest-lm
02338             c_vqp_tcp                      = (INT)  1589,   //  VQP
02339             c_vqp_udp                      = (INT)  1589,   //  VQP
02340             c_gemini_lm_tcp                = (INT)  1590,   //  gemini-lm
02341             c_gemini_lm_udp                = (INT)  1590,   //  gemini-lm
02342             c_ncpm_pm_tcp                  = (INT)  1591,   //  ncpm-pm
02343             c_ncpm_pm_udp                  = (INT)  1591,   //  ncpm-pm
02344             c_commonspace_tcp              = (INT)  1592,   //  commonspace
02345             c_commonspace_udp              = (INT)  1592,   //  commonspace
02346             c_mainsoft_lm_tcp              = (INT)  1593,   //  mainsoft-lm
02347             c_mainsoft_lm_udp              = (INT)  1593,   //  mainsoft-lm
02348             c_sixtrak_tcp                  = (INT)  1594,   //  sixtrak
02349             c_sixtrak_udp                  = (INT)  1594,   //  sixtrak
02350             c_radio_tcp                    = (INT)  1595,   //  radio
02351             c_radio_udp                    = (INT)  1595,   //  radio
02352             c_radio_sm_tcp                 = (INT)  1596,   //  radio-sm
02353             c_radio_bc_udp                 = (INT)  1596,   //  radio-bc
02354             c_orbplus_iiop_tcp             = (INT)  1597,   //  orbplus-iiop
02355             c_orbplus_iiop_udp             = (INT)  1597,   //  orbplus-iiop
02356             c_picknfs_tcp                  = (INT)  1598,   //  picknfs
02357             c_picknfs_udp                  = (INT)  1598,   //  picknfs
02358             c_simbaservices_tcp            = (INT)  1599,   //  simbaservices
02359             c_simbaservices_udp            = (INT)  1599,   //  simbaservices
02360             c_issd_tcp                     = (INT)  1600,   //
02361             c_issd_udp                     = (INT)  1600,   //
02362             c_aas_tcp                      = (INT)  1601,   //  aas
02363             c_aas_udp                      = (INT)  1601,   //  aas
02364             c_inspect_tcp                  = (INT)  1602,   //  inspect
02365             c_inspect_udp                  = (INT)  1602,   //  inspect
02366             c_picodbc_tcp                  = (INT)  1603,   //  pickodbc
02367             c_picodbc_udp                  = (INT)  1603,   //  pickodbc
02368             c_icabrowser_tcp               = (INT)  1604,   //  icabrowser
02369             c_icabrowser_udp               = (INT)  1604,   //  icabrowser
02370             c_slp_tcp                      = (INT)  1605,   //  Salutation Manager (Salutation Protocol)
02371             c_slp_udp                      = (INT)  1605,   //  Salutation Manager (Salutation Protocol)
02372             c_slm_api_tcp                  = (INT)  1606,   //  Salutation Manager (SLM-API)
02373             c_slm_api_udp                  = (INT)  1606,   //  Salutation Manager (SLM-API)
02374             c_stt_tcp                      = (INT)  1607,   //  stt
02375             c_stt_udp                      = (INT)  1607,   //  stt
02376             c_smart_lm_tcp                 = (INT)  1608,   //  Smart Corp. License Manager
02377             c_smart_lm_udp                 = (INT)  1608,   //  Smart Corp. License Manager
02378             c_isysg_lm_tcp                 = (INT)  1609,   //  isysg-lm
02379             c_isysg_lm_udp                 = (INT)  1609,   //  isysg-lm
02380             c_taurus_wh_tcp                = (INT)  1610,   //  taurus-wh
02381             c_taurus_wh_udp                = (INT)  1610,   //  taurus-wh
02382             c_ill_tcp                      = (INT)  1611,   //  Inter Library Loan
02383             c_ill_udp                      = (INT)  1611,   //  Inter Library Loan
02384             c_netbill_trans_tcp            = (INT)  1612,   //  NetBill Transaction Server
02385             c_netbill_trans_udp            = (INT)  1612,   //  NetBill Transaction Server
02386             c_netbill_keyrep_tcp           = (INT)  1613,   //  NetBill Key Repository
02387             c_netbill_keyrep_udp           = (INT)  1613,   //  NetBill Key Repository
02388             c_netbill_cred_tcp             = (INT)  1614,   //  NetBill Credential Server
02389             c_netbill_cred_udp             = (INT)  1614,   //  NetBill Credential Server
02390             c_netbill_auth_tcp             = (INT)  1615,   //  NetBill Authorization Server
02391             c_netbill_auth_udp             = (INT)  1615,   //  NetBill Authorization Server
02392             c_netbill_prod_tcp             = (INT)  1616,   //  NetBill Product Server
02393             c_netbill_prod_udp             = (INT)  1616,   //  NetBill Product Server
02394             c_nimrod_agent_tcp             = (INT)  1617,   //  Nimrod Inter-Agent Communication
02395             c_nimrod_agent_udp             = (INT)  1617,   //  Nimrod Inter-Agent Communication
02396             c_skytelnet_tcp                = (INT)  1618,   //  skytelnet
02397             c_skytelnet_udp                = (INT)  1618,   //  skytelnet
02398             c_xs_openstorage_tcp           = (INT)  1619,   //  xs-openstorage
02399             c_xs_openstorage_udp           = (INT)  1619,   //  xs-openstorage
02400             c_faxportwinport_tcp           = (INT)  1620,   //  faxportwinport
02401             c_faxportwinport_udp           = (INT)  1620,   //  faxportwinport
02402             c_softdataphone_tcp            = (INT)  1621,   //  softdataphone
02403             c_softdataphone_udp            = (INT)  1621,   //  softdataphone
02404             c_ontime_tcp                   = (INT)  1622,   //  ontime
02405             c_ontime_udp                   = (INT)  1622,   //  ontime
02406             c_jaleosnd_tcp                 = (INT)  1623,   //  jaleosnd
02407             c_jaleosnd_udp                 = (INT)  1623,   //  jaleosnd
02408             c_udp_sr_port_tcp              = (INT)  1624,   //  udp-sr-port
02409             c_udp_sr_port_udp              = (INT)  1624,   //  udp-sr-port
02410             c_svs_omagent_tcp              = (INT)  1625,   //  svs-omagent
02411             c_svs_omagent_udp              = (INT)  1625,   //  svs-omagent
02412             c_shockwave_tcp                = (INT)  1626,   //  Shockwave
02413             c_shockwave_udp                = (INT)  1626,   //  Shockwave
02414             c_t128_gateway_tcp             = (INT)  1627,   //  T.128 Gateway
02415             c_t128_gateway_udp             = (INT)  1627,   //  T.128 Gateway
02416             c_lontalk_norm_tcp             = (INT)  1628,   //  LonTalk normal
02417             c_lontalk_norm_udp             = (INT)  1628,   //  LonTalk normal
02418             c_lontalk_urgnt_tcp            = (INT)  1629,   //  LonTalk urgent
02419             c_lontalk_urgnt_udp            = (INT)  1629,   //  LonTalk urgent
02420             c_oraclenet8cman_tcp           = (INT)  1630,   //  Oracle Net8 Cman
02421             c_oraclenet8cman_udp           = (INT)  1630,   //  Oracle Net8 Cman
02422             c_visitview_tcp                = (INT)  1631,   //  Visit view
02423             c_visitview_udp                = (INT)  1631,   //  Visit view
02424             c_pammratc_tcp                 = (INT)  1632,   //  PAMMRATC
02425             c_pammratc_udp                 = (INT)  1632,   //  PAMMRATC
02426             c_pammrpc_tcp                  = (INT)  1633,   //  PAMMRPC
02427             c_pammrpc_udp                  = (INT)  1633,   //  PAMMRPC
02428             c_loaprobe_tcp                 = (INT)  1634,   //  Log On America Probe
02429             c_loaprobe_udp                 = (INT)  1634,   //  Log On America Probe
02430             c_edb_server1_tcp              = (INT)  1635,   //  EDB Server 1
02431             c_edb_server1_udp              = (INT)  1635,   //  EDB Server 1
02432             c_cncp_tcp                     = (INT)  1636,   //  CableNet Control Protocol
02433             c_cncp_udp                     = (INT)  1636,   //  CableNet Control Protocol
02434             c_cnap_tcp                     = (INT)  1637,   //  CableNet Admin Protocol
02435             c_cnap_udp                     = (INT)  1637,   //  CableNet Admin Protocol
02436             c_cnip_tcp                     = (INT)  1638,   //  CableNet Info Protocol
02437             c_cnip_udp                     = (INT)  1638,   //  CableNet Info Protocol
02438             c_cert_initiator_tcp           = (INT)  1639,   //  cert-initiator
02439             c_cert_initiator_udp           = (INT)  1639,   //  cert-initiator
02440             c_cert_responder_tcp           = (INT)  1640,   //  cert-responder
02441             c_cert_responder_udp           = (INT)  1640,   //  cert-responder
02442             c_invision_tcp                 = (INT)  1641,   //  InVision
02443             c_invision_udp                 = (INT)  1641,   //  InVision
02444             c_isis_am_tcp                  = (INT)  1642,   //  isis-am
02445             c_isis_am_udp                  = (INT)  1642,   //  isis-am
02446             c_isis_ambc_tcp                = (INT)  1643,   //  isis-ambc
02447             c_isis_ambc_udp                = (INT)  1643,   //  isis-ambc
02448             c_saiseh_tcp                   = (INT)  1644,   //  Satellite-data Acquisition System 4
02449             c_sightline_tcp                = (INT)  1645,   //  SightLine
02450             c_sightline_udp                = (INT)  1645,   //  SightLine
02451             c_sa_msg_port_tcp              = (INT)  1646,   //  sa-msg-port
02452             c_sa_msg_port_udp              = (INT)  1646,   //  sa-msg-port
02453             c_rsap_tcp                     = (INT)  1647,   //  rsap
02454             c_rsap_udp                     = (INT)  1647,   //  rsap
02455             c_concurrent_lm_tcp            = (INT)  1648,   //  concurrent-lm
02456             c_concurrent_lm_udp            = (INT)  1648,   //  concurrent-lm
02457             c_kermit_tcp                   = (INT)  1649,   //  kermit
02458             c_kermit_udp                   = (INT)  1649,   //  kermit
02459             c_nkd_tcp                      = (INT)  1650,   //  nkdn
02460             c_nkd_udp                      = (INT)  1650,   //  nkd
02461             c_xnmp_tcp                     = (INT)  1652,   //  xnmp
02462             c_xnmp_udp                     = (INT)  1652,   //  xnmp
02463             c_alphatech_lm_tcp             = (INT)  1653,   //  alphatech-lm
02464             c_alphatech_lm_udp             = (INT)  1653,   //  alphatech-lm
02465             c_stargatealerts_tcp           = (INT)  1654,   //  stargatealerts
02466             c_stargatealerts_udp           = (INT)  1654,   //  stargatealerts
02467             c_dec_mbadmin_tcp              = (INT)  1655,   //  dec-mbadmin
02468             c_dec_mbadmin_udp              = (INT)  1655,   //  dec-mbadmin
02469             c_dec_mbadmin_h_tcp            = (INT)  1656,   //  dec-mbadmin-h
02470             c_dec_mbadmin_h_udp            = (INT)  1656,   //  dec-mbadmin-h
02471             c_fujitsu_mmpdc_tcp            = (INT)  1657,   //  fujitsu-mmpdc
02472             c_fujitsu_mmpdc_udp            = (INT)  1657,   //  fujitsu-mmpdc
02473             c_sixnetudr_tcp                = (INT)  1658,   //  sixnetudr
02474             c_sixnetudr_udp                = (INT)  1658,   //  sixnetudr
02475             c_sg_lm_tcp                    = (INT)  1659,   //  Silicon Grail License Manager
02476             c_sg_lm_udp                    = (INT)  1659,   //  Silicon Grail License Manager
02477             c_skip_mc_gikreq_tcp           = (INT)  1660,   //  skip-mc-gikreq
02478             c_skip_mc_gikreq_udp           = (INT)  1660,   //  skip-mc-gikreq
02479             c_netview_aix_1_tcp            = (INT)  1661,   //  netview-aix-1
02480             c_netview_aix_1_udp            = (INT)  1661,   //  netview-aix-1
02481             c_netview_aix_2_tcp            = (INT)  1662,   //  netview-aix-2
02482             c_netview_aix_2_udp            = (INT)  1662,   //  netview-aix-2
02483             c_netview_aix_3_tcp            = (INT)  1663,   //  netview-aix-3
02484             c_netview_aix_3_udp            = (INT)  1663,   //  netview-aix-3
02485             c_netview_aix_4_tcp            = (INT)  1664,   //  netview-aix-4
02486             c_netview_aix_4_udp            = (INT)  1664,   //  netview-aix-4
02487             c_netview_aix_5_tcp            = (INT)  1665,   //  netview-aix-5
02488             c_netview_aix_5_udp            = (INT)  1665,   //  netview-aix-5
02489             c_netview_aix_6_tcp            = (INT)  1666,   //  netview-aix-6
02490             c_netview_aix_6_udp            = (INT)  1666,   //  netview-aix-6
02491             c_netview_aix_7_tcp            = (INT)  1667,   //  netview-aix-7
02492             c_netview_aix_7_udp            = (INT)  1667,   //  netview-aix-7
02493             c_netview_aix_8_tcp            = (INT)  1668,   //  netview-aix-8
02494             c_netview_aix_8_udp            = (INT)  1668,   //  netview-aix-8
02495             c_netview_aix_9_tcp            = (INT)  1669,   //  netview-aix-9
02496             c_netview_aix_9_udp            = (INT)  1669,   //  netview-aix-9
02497             c_netview_aix_10_tcp           = (INT)  1670,   //  netview-aix-10
02498             c_netview_aix_10_udp           = (INT)  1670,   //  netview-aix-10
02499             c_netview_aix_11_tcp           = (INT)  1671,   //  netview-aix-11
02500             c_netview_aix_11_udp           = (INT)  1671,   //  netview-aix-11
02501             c_netview_aix_12_tcp           = (INT)  1672,   //  netview-aix-12
02502             c_netview_aix_12_udp           = (INT)  1672,   //  netview-aix-12
02503             c_proshare_mc_1_tcp            = (INT)  1673,   //  Intel Proshare Multicast
02504             c_proshare_mc_1_udp            = (INT)  1673,   //  Intel Proshare Multicast
02505             c_proshare_mc_2_tcp            = (INT)  1674,   //  Intel Proshare Multicast
02506             c_proshare_mc_2_udp            = (INT)  1674,   //  Intel Proshare Multicast
02507             c_pdp_tcp                      = (INT)  1675,   //  Pacific Data Products
02508             c_pdp_udp                      = (INT)  1675,   //  Pacific Data Products
02509             c_netcomm1_tcp                 = (INT)  1676,   //  netcomm1
02510             c_netcomm2_udp                 = (INT)  1676,   //  netcomm2
02511             c_groupwise_tcp                = (INT)  1677,   //  groupwise
02512             c_groupwise_udp                = (INT)  1677,   //  groupwise
02513             c_prolink_tcp                  = (INT)  1678,   //  prolink
02514             c_prolink_udp                  = (INT)  1678,   //  prolink
02515             c_darcorp_lm_tcp               = (INT)  1679,   //  darcorp-lm
02516             c_darcorp_lm_udp               = (INT)  1679,   //  darcorp-lm
02517             c_microcom_sbp_tcp             = (INT)  1680,   //  microcom-sbp
02518             c_microcom_sbp_udp             = (INT)  1680,   //  microcom-sbp
02519             c_sd_elmd_tcp                  = (INT)  1681,   //  sd-elmd
02520             c_sd_elmd_udp                  = (INT)  1681,   //  sd-elmd
02521             c_lanyon_lantern_tcp           = (INT)  1682,   //  lanyon-lantern
02522             c_lanyon_lantern_udp           = (INT)  1682,   //  lanyon-lantern
02523             c_ncpm_hip_tcp                 = (INT)  1683,   //  ncpm-hip
02524             c_ncpm_hip_udp                 = (INT)  1683,   //  ncpm-hip
02525             c_snaresecure_tcp              = (INT)  1684,   //  SnareSecure
02526             c_snaresecure_udp              = (INT)  1684,   //  SnareSecure
02527             c_n2nremote_tcp                = (INT)  1685,   //  n2nremote
02528             c_n2nremote_udp                = (INT)  1685,   //  n2nremote
02529             c_cvmon_tcp                    = (INT)  1686,   //  cvmon
02530             c_cvmon_udp                    = (INT)  1686,   //  cvmon
02531             c_nsjtp_ctrl_tcp               = (INT)  1687,   //  nsjtp-ctrl
02532             c_nsjtp_ctrl_udp               = (INT)  1687,   //  nsjtp-ctrl
02533             c_nsjtp_data_tcp               = (INT)  1688,   //  nsjtp-data
02534             c_nsjtp_data_udp               = (INT)  1688,   //  nsjtp-data
02535             c_firefox_tcp                  = (INT)  1689,   //  firefox
02536             c_firefox_udp                  = (INT)  1689,   //  firefox
02537             c_ng_umds_tcp                  = (INT)  1690,   //  ng-umds
02538             c_ng_umds_udp                  = (INT)  1690,   //  ng-umds
02539             c_empire_empuma_tcp            = (INT)  1691,   //  empire-empuma
02540             c_empire_empuma_udp            = (INT)  1691,   //  empire-empuma
02541             c_sstsys_lm_tcp                = (INT)  1692,   //  sstsys-lm
02542             c_sstsys_lm_udp                = (INT)  1692,   //  sstsys-lm
02543             c_rrirtr_tcp                   = (INT)  1693,   //  rrirtr
02544             c_rrirtr_udp                   = (INT)  1693,   //  rrirtr
02545             c_rrimwm_tcp                   = (INT)  1694,   //  rrimwm
02546             c_rrimwm_udp                   = (INT)  1694,   //  rrimwm
02547             c_rrilwm_tcp                   = (INT)  1695,   //  rrilwm
02548             c_rrilwm_udp                   = (INT)  1695,   //  rrilwm
02549             c_rrifmm_tcp                   = (INT)  1696,   //  rrifmm
02550             c_rrifmm_udp                   = (INT)  1696,   //  rrifmm
02551             c_rrisat_tcp                   = (INT)  1697,   //  rrisat
02552             c_rrisat_udp                   = (INT)  1697,   //  rrisat
02553             c_rsvp_encap_1_tcp             = (INT)  1698,   //  RSVP-ENCAPSULATION-1
02554             c_rsvp_encap_1_udp             = (INT)  1698,   //  RSVP-ENCAPSULATION-1
02555             c_rsvp_encap_2_tcp             = (INT)  1699,   //  RSVP-ENCAPSULATION-2
02556             c_rsvp_encap_2_udp             = (INT)  1699,   //  RSVP-ENCAPSULATION-2
02557             c_mps_raft_tcp                 = (INT)  1700,   //  mps-raft
02558             c_mps_raft_udp                 = (INT)  1700,   //  mps-raft
02559             c_l2f_tcp                      = (INT)  1701,   //  l2f
02560             c_l2f_udp                      = (INT)  1701,   //  l2f
02561             c_l2tp_tcp                     = (INT)  1701,   //  l2tp
02562             c_l2tp_udp                     = (INT)  1701,   //  l2tp
02563             c_deskshare_tcp                = (INT)  1702,   //  deskshare
02564             c_deskshare_udp                = (INT)  1702,   //  deskshare
02565             c_hb_engine_tcp                = (INT)  1703,   //  hb-engine
02566             c_hb_engine_udp                = (INT)  1703,   //  hb-engine
02567             c_bcs_broker_tcp               = (INT)  1704,   //  bcs-broker
02568             c_bcs_broker_udp               = (INT)  1704,   //  bcs-broker
02569             c_slingshot_tcp                = (INT)  1705,   //  slingshot
02570             c_slingshot_udp                = (INT)  1705,   //  slingshot
02571             c_jetform_tcp                  = (INT)  1706,   //  jetform
02572             c_jetform_udp                  = (INT)  1706,   //  jetform
02573             c_vdmplay_tcp                  = (INT)  1707,   //  vdmplay
02574             c_vdmplay_udp                  = (INT)  1707,   //  vdmplay
02575             c_gat_lmd_tcp                  = (INT)  1708,   //  gat-lmd
02576             c_gat_lmd_udp                  = (INT)  1708,   //  gat-lmd
02577             c_centra_tcp                   = (INT)  1709,   //  centra
02578             c_centra_udp                   = (INT)  1709,   //  centra
02579             c_impera_tcp                   = (INT)  1710,   //  impera
02580             c_impera_udp                   = (INT)  1710,   //  impera
02581             c_pptconference_tcp            = (INT)  1711,   //  pptconference
02582             c_pptconference_udp            = (INT)  1711,   //  pptconference
02583             c_registrar_tcp                = (INT)  1712,   //  resource monitoring service
02584             c_registrar_udp                = (INT)  1712,   //  resource monitoring service
02585             c_conferencetalk_tcp           = (INT)  1713,   //  ConferenceTalk
02586             c_conferencetalk_udp           = (INT)  1713,   //  ConferenceTalk
02587             c_sesi_lm_tcp                  = (INT)  1714,   //  sesi-lm
02588             c_sesi_lm_udp                  = (INT)  1714,   //  sesi-lm
02589             c_houdini_lm_tcp               = (INT)  1715,   //  houdini-lm
02590             c_houdini_lm_udp               = (INT)  1715,   //  houdini-lm
02591             c_xmsg_tcp                     = (INT)  1716,   //  xmsg
02592             c_xmsg_udp                     = (INT)  1716,   //  xmsg
02593             c_fj_hdnet_tcp                 = (INT)  1717,   //  fj-hdnet
02594             c_fj_hdnet_udp                 = (INT)  1717,   //  fj-hdnet
02595             c_h323gatedisc_tcp             = (INT)  1718,   //  h323gatedisc
02596             c_h323gatedisc_udp             = (INT)  1718,   //  h323gatedisc
02597             c_h323gatestat_tcp             = (INT)  1719,   //  h323gatestat
02598             c_h323gatestat_udp             = (INT)  1719,   //  h323gatestat
02599             c_h323hostcall_tcp             = (INT)  1720,   //  h323hostcall
02600             c_h323hostcall_udp             = (INT)  1720,   //  h323hostcall
02601             c_caicci_tcp                   = (INT)  1721,   //  caicci
02602             c_caicci_udp                   = (INT)  1721,   //  caicci
02603             c_hks_lm_tcp                   = (INT)  1722,   //  HKS License Manager
02604             c_hks_lm_udp                   = (INT)  1722,   //  HKS License Manager
02605             c_pptp_tcp                     = (INT)  1723,   //  pptp
02606             c_pptp_udp                     = (INT)  1723,   //  pptp
02607             c_csbphonemaster_tcp           = (INT)  1724,   //  csbphonemaster
02608             c_csbphonemaster_udp           = (INT)  1724,   //  csbphonemaster
02609             c_iden_ralp_tcp                = (INT)  1725,   //  iden-ralp
02610             c_iden_ralp_udp                = (INT)  1725,   //  iden-ralp
02611             c_iberiagames_tcp              = (INT)  1726,   //  IBERIAGAMES
02612             c_iberiagames_udp              = (INT)  1726,   //  IBERIAGAMES
02613             c_winddx_tcp                   = (INT)  1727,   //  winddx
02614             c_winddx_udp                   = (INT)  1727,   //  winddx
02615             c_telindus_tcp                 = (INT)  1728,   //  TELINDUS
02616             c_telindus_udp                 = (INT)  1728,   //  TELINDUS
02617             c_citynl_tcp                   = (INT)  1729,   //  CityNL License Management
02618             c_citynl_udp                   = (INT)  1729,   //  CityNL License Management
02619             c_roketz_tcp                   = (INT)  1730,   //  roketz
02620             c_roketz_udp                   = (INT)  1730,   //  roketz
02621             c_msiccp_tcp                   = (INT)  1731,   //  MSICCP
02622             c_msiccp_udp                   = (INT)  1731,   //  MSICCP
02623             c_proxim_tcp                   = (INT)  1732,   //  proxim
02624             c_proxim_udp                   = (INT)  1732,   //  proxim
02625             c_siipat_tcp                   = (INT)  1733,   //  SIMS - SIIPAT Protocol for Alarm Transmission
02626             c_siipat_udp                   = (INT)  1733,   //  SIMS - SIIPAT Protocol for Alarm Transmission
02627             c_cambertx_lm_tcp              = (INT)  1734,   //  Camber Corporation License Management
02628             c_cambertx_lm_udp              = (INT)  1734,   //  Camber Corporation License Management
02629             c_privatechat_tcp              = (INT)  1735,   //  PrivateChat
02630             c_privatechat_udp              = (INT)  1735,   //  PrivateChat
02631             c_street_stream_tcp            = (INT)  1736,   //  street-stream
02632             c_street_stream_udp            = (INT)  1736,   //  street-stream
02633             c_ultimad_tcp                  = (INT)  1737,   //  ultimad
02634             c_ultimad_udp                  = (INT)  1737,   //  ultimad
02635             c_gamegen1_tcp                 = (INT)  1738,   //  GameGen1
02636             c_gamegen1_udp                 = (INT)  1738,   //  GameGen1
02637             c_webaccess_tcp                = (INT)  1739,   //  webaccess
02638             c_webaccess_udp                = (INT)  1739,   //  webaccess
02639             c_encore_tcp                   = (INT)  1740,   //  encore
02640             c_encore_udp                   = (INT)  1740,   //  encore
02641             c_cisco_net_mgmt_tcp           = (INT)  1741,   //  cisco-net-mgmt
02642             c_cisco_net_mgmt_udp           = (INT)  1741,   //  cisco-net-mgmt
02643             c_cinegrfx_lm_tcp              = (INT)  1743,   //  Cinema Graphics License Manager
02644             c_cinegrfx_lm_udp              = (INT)  1743,   //  Cinema Graphics License Manager
02645             c_ncpm_ft_tcp                  = (INT)  1744,   //  ncpm-ft
02646             c_ncpm_ft_udp                  = (INT)  1744,   //  ncpm-ft
02647             c_remote_winsock_tcp           = (INT)  1745,   //  remote-winsock
02648             c_remote_winsock_udp           = (INT)  1745,   //  remote-winsock
02649             c_ftrapid_1_tcp                = (INT)  1746,   //  ftrapid-1
02650             c_ftrapid_1_udp                = (INT)  1746,   //  ftrapid-1
02651             c_ftrapid_2_tcp                = (INT)  1747,   //  ftrapid-2
02652             c_ftrapid_2_udp                = (INT)  1747,   //  ftrapid-2
02653             c_oracle_em1_tcp               = (INT)  1748,   //  oracle-em1
02654             c_oracle_em1_udp               = (INT)  1748,   //  oracle-em1
02655             c_aspen_services_tcp           = (INT)  1749,   //  aspen-services
02656             c_aspen_services_udp           = (INT)  1749,   //  aspen-services
02657             c_sslp_tcp                     = (INT)  1750,   //  Simple Socket Library's PortMaster
02658             c_sslp_udp                     = (INT)  1750,   //  Simple Socket Library's PortMaster
02659             c_swiftnet_tcp                 = (INT)  1751,   //  SwiftNet
02660             c_swiftnet_udp                 = (INT)  1751,   //  SwiftNet
02661             c_lofr_lm_tcp                  = (INT)  1752,   //  Leap of Faith Research License Manager
02662             c_lofr_lm_udp                  = (INT)  1752,   //  Leap of Faith Research License Manager
02663             c_translogic_lm_tcp            = (INT)  1753,   //  Translogic License Manager
02664             c_translogic_lm_udp            = (INT)  1753,   //  Translogic License Manager
02665             c_oracle_em2_tcp               = (INT)  1754,   //  oracle-em2
02666             c_oracle_em2_udp               = (INT)  1754,   //  oracle-em2
02667             c_ms_streaming_tcp             = (INT)  1755,   //  ms-streaming
02668             c_ms_streaming_udp             = (INT)  1755,   //  ms-streaming
02669             c_capfast_lmd_tcp              = (INT)  1756,   //  capfast-lmd
02670             c_capfast_lmd_udp              = (INT)  1756,   //  capfast-lmd
02671             c_cnhrp_tcp                    = (INT)  1757,   //  cnhrp
02672             c_cnhrp_udp                    = (INT)  1757,   //  cnhrp
02673             c_tftp_mcast_tcp               = (INT)  1758,   //  tftp-mcast
02674             c_tftp_mcast_udp               = (INT)  1758,   //  tftp-mcast
02675             c_spss_lm_tcp                  = (INT)  1759,   //  SPSS License Manager
02676             c_spss_lm_udp                  = (INT)  1759,   //  SPSS License Manager
02677             c_www_ldap_gw_tcp              = (INT)  1760,   //  www-ldap-gw
02678             c_www_ldap_gw_udp              = (INT)  1760,   //  www-ldap-gw
02679             c_cft_0_tcp                    = (INT)  1761,   //  cft-0
02680             c_cft_0_udp                    = (INT)  1761,   //  cft-0
02681             c_cft_1_tcp                    = (INT)  1762,   //  cft-1
02682             c_cft_1_udp                    = (INT)  1762,   //  cft-1
02683             c_cft_2_tcp                    = (INT)  1763,   //  cft-2
02684             c_cft_2_udp                    = (INT)  1763,   //  cft-2
02685             c_cft_3_tcp                    = (INT)  1764,   //  cft-3
02686             c_cft_3_udp                    = (INT)  1764,   //  cft-3
02687             c_cft_4_tcp                    = (INT)  1765,   //  cft-4
02688             c_cft_4_udp                    = (INT)  1765,   //  cft-4
02689             c_cft_5_tcp                    = (INT)  1766,   //  cft-5
02690             c_cft_5_udp                    = (INT)  1766,   //  cft-5
02691             c_cft_6_tcp                    = (INT)  1767,   //  cft-6
02692             c_cft_6_udp                    = (INT)  1767,   //  cft-6
02693             c_cft_7_tcp                    = (INT)  1768,   //  cft-7
02694             c_cft_7_udp                    = (INT)  1768,   //  cft-7
02695             c_bmc_net_adm_tcp              = (INT)  1769,   //  bmc-net-adm
02696             c_bmc_net_adm_udp              = (INT)  1769,   //  bmc-net-adm
02697             c_bmc_net_svc_tcp              = (INT)  1770,   //  bmc-net-svc
02698             c_bmc_net_svc_udp              = (INT)  1770,   //  bmc-net-svc
02699             c_vaultbase_tcp                = (INT)  1771,   //  vaultbase
02700             c_vaultbase_udp                = (INT)  1771,   //  vaultbase
02701             c_essweb_gw_tcp                = (INT)  1772,   //  EssWeb Gateway
02702             c_essweb_gw_udp                = (INT)  1772,   //  EssWeb Gateway
02703             c_kmscontrol_tcp               = (INT)  1773,   //  KMSControl
02704             c_kmscontrol_udp               = (INT)  1773,   //  KMSControl
02705             c_global_dtserv_tcp            = (INT)  1774,   //  global-dtserv
02706             c_global_dtserv_udp            = (INT)  1774,   //  global-dtserv
02707             c_femis_tcp                    = (INT)  1776,   //  Federal Emergency Management Information System
02708             c_femis_udp                    = (INT)  1776,   //  Federal Emergency Management Information System
02709             c_powerguardian_tcp            = (INT)  1777,   //  powerguardian
02710             c_powerguardian_udp            = (INT)  1777,   //  powerguardian
02711             c_prodigy_intrnet_tcp          = (INT)  1778,   //  prodigy-internet
02712             c_prodigy_intrnet_udp          = (INT)  1778,   //  prodigy-internet
02713             c_pharmasoft_tcp               = (INT)  1779,   //  pharmasoft
02714             c_pharmasoft_udp               = (INT)  1779,   //  pharmasoft
02715             c_dpkeyserv_tcp                = (INT)  1780,   //  dpkeyserv
02716             c_dpkeyserv_udp                = (INT)  1780,   //  dpkeyserv
02717             c_answersoft_lm_tcp            = (INT)  1781,   //  answersoft-lm
02718             c_answersoft_lm_udp            = (INT)  1781,   //  answersoft-lm
02719             c_hp_hcip_tcp                  = (INT)  1782,   //  hp-hcip
02720             c_hp_hcip_udp                  = (INT)  1782,   //  hp-hcip
02721             c_finle_lm_tcp                 = (INT)  1784,   //  Finle License Manager
02722             c_finle_lm_udp                 = (INT)  1784,   //  Finle License Manager
02723             c_windlm_tcp                   = (INT)  1785,   //  Wind River Systems License Manager
02724             c_windlm_udp                   = (INT)  1785,   //  Wind River Systems License Manager
02725             c_funk_logger_tcp              = (INT)  1786,   //  funk-logger
02726             c_funk_logger_udp              = (INT)  1786,   //  funk-logger
02727             c_funk_license_tcp             = (INT)  1787,   //  funk-license
02728             c_funk_license_udp             = (INT)  1787,   //  funk-license
02729             c_psmond_tcp                   = (INT)  1788,   //  psmond
02730             c_psmond_udp                   = (INT)  1788,   //  psmond
02731             c_hello_tcp                    = (INT)  1789,   //  hello
02732             c_hello_udp                    = (INT)  1789,   //  hello
02733             c_nmsp_1_tcp                   = (INT)  1790,   //  Narrative Media Streaming Protocol
02734             c_nmsp_1_udp                   = (INT)  1790,   //  Narrative Media Streaming Protocol
02735             c_ea1_tcp                      = (INT)  1791,   //  EA1
02736             c_ea1_udp                      = (INT)  1791,   //  EA1
02737             c_ibm_dt_2_tcp                 = (INT)  1792,   //  ibm-dt-2
02738             c_ibm_dt_2_udp                 = (INT)  1792,   //  ibm-dt-2
02739             c_rsc_robot_tcp                = (INT)  1793,   //  rsc-robot
02740             c_rsc_robot_udp                = (INT)  1793,   //  rsc-robot
02741             c_cera_bcm_tcp                 = (INT)  1794,   //  cera-bcm
02742             c_cera_bcm_udp                 = (INT)  1794,   //  cera-bcm
02743             c_dpi_proxy_tcp                = (INT)  1795,   //  dpi-proxy
02744             c_dpi_proxy_udp                = (INT)  1795,   //  dpi-proxy
02745             c_vocaltec_admin_tcp           = (INT)  1796,   //  Vocaltec Server Administration
02746             c_vocaltec_admin_udp           = (INT)  1796,   //  Vocaltec Server Administration
02747             c_uma_1_tcp                    = (INT)  1797,   //  UMA
02748             c_uma_1_udp                    = (INT)  1797,   //  UMA
02749             c_etp_tcp                      = (INT)  1798,   //  Event Transfer Protocol
02750             c_etp_udp                      = (INT)  1798,   //  Event Transfer Protocol
02751             c_netrisk_tcp                  = (INT)  1799,   //  NETRISK
02752             c_netrisk_udp                  = (INT)  1799,   //  NETRISK
02753             c_ansys_lm_tcp                 = (INT)  1800,   //  ANSYS-License manager
02754             c_ansys_lm_udp                 = (INT)  1800,   //  ANSYS-License manager
02755             c_msmq_tcp                     = (INT)  1801,   //  Microsoft Message Que
02756             c_msmq_udp                     = (INT)  1801,   //  Microsoft Message Que
02757             c_concomp1_tcp                 = (INT)  1802,   //  ConComp1
02758             c_concomp1_udp                 = (INT)  1802,   //  ConComp1
02759             c_hp_hcip_gwy_tcp              = (INT)  1803,   //  HP-HCIP-GWY
02760             c_hp_hcip_gwy_udp              = (INT)  1803,   //  HP-HCIP-GWY
02761             c_enl_tcp                      = (INT)  1804,   //  ENL
02762             c_enl_udp                      = (INT)  1804,   //  ENL
02763             c_enl_name_tcp                 = (INT)  1805,   //  ENL-Name
02764             c_enl_name_udp                 = (INT)  1805,   //  ENL-Name
02765             c_musiconline_tcp              = (INT)  1806,   //  Musiconline
02766             c_musiconline_udp              = (INT)  1806,   //  Musiconline
02767             c_fhsp_tcp                     = (INT)  1807,   //  Fujitsu Hot Standby Protocol
02768             c_fhsp_udp                     = (INT)  1807,   //  Fujitsu Hot Standby Protocol
02769             c_oracle_vp2_tcp               = (INT)  1808,   //  Oracle-VP2
02770             c_oracle_vp2_udp               = (INT)  1808,   //  Oracle-VP2
02771             c_oracle_vp1_tcp               = (INT)  1809,   //  Oracle-VP1
02772             c_oracle_vp1_udp               = (INT)  1809,   //  Oracle-VP1
02773             c_jerand_lm_tcp                = (INT)  1810,   //  Jerand License Manager
02774             c_jerand_lm_udp                = (INT)  1810,   //  Jerand License Manager
02775             c_scientia_sdb_tcp             = (INT)  1811,   //  Scientia-SDB
02776             c_scientia_sdb_udp             = (INT)  1811,   //  Scientia-SDB
02777             c_radius_tcp                   = (INT)  1812,   //  RADIUS
02778             c_radius_udp                   = (INT)  1812,   //  RADIUS
02779             c_radius_acct_tcp              = (INT)  1813,   //  RADIUS Accounting
02780             c_radius_acct_udp              = (INT)  1813,   //  RADIUS Accounting
02781             c_tdp_suite_tcp                = (INT)  1814,   //  TDP Suite
02782             c_tdp_suite_udp                = (INT)  1814,   //  TDP Suite
02783             c_mmpft_tcp                    = (INT)  1815,   //  MMPFT
02784             c_mmpft_udp                    = (INT)  1815,   //  MMPFT
02785             c_harp_tcp                     = (INT)  1816,   //  HARP
02786             c_harp_udp                     = (INT)  1816,   //  HARP
02787             c_rkb_oscs_tcp                 = (INT)  1817,   //  RKB-OSCS
02788             c_rkb_oscs_udp                 = (INT)  1817,   //  RKB-OSCS
02789             c_etftp_tcp                    = (INT)  1818,   //  Enhanced Trivial File Transfer Protocol
02790             c_etftp_udp                    = (INT)  1818,   //  Enhanced Trivial File Transfer Protocol
02791             c_plato_lm_tcp                 = (INT)  1819,   //  Plato License Manager
02792             c_plato_lm_udp                 = (INT)  1819,   //  Plato License Manager
02793             c_mcagent_tcp                  = (INT)  1820,   //  mcagent
02794             c_mcagent_udp                  = (INT)  1820,   //  mcagent
02795             c_donnyworld_tcp               = (INT)  1821,   //  donnyworld
02796             c_donnyworld_udp               = (INT)  1821,   //  donnyworld
02797             c_es_elmd_tcp                  = (INT)  1822,   //  es-elmd
02798             c_es_elmd_udp                  = (INT)  1822,   //  es-elmd
02799             c_unisys_lm_tcp                = (INT)  1823,   //  Unisys Natural Language License Manager
02800             c_unisys_lm_udp                = (INT)  1823,   //  Unisys Natural Language License Manager
02801             c_metrics_pas_tcp              = (INT)  1824,   //  metrics-pas
02802             c_metrics_pas_udp              = (INT)  1824,   //  metrics-pas
02803             c_direcpc_video_tcp            = (INT)  1825,   //  DirecPC Video
02804             c_direcpc_video_udp            = (INT)  1825,   //  DirecPC Video
02805             c_ardt_tcp                     = (INT)  1826,   //  ARDT
02806             c_ardt_udp                     = (INT)  1826,   //  ARDT
02807             c_asi_tcp                      = (INT)  1827,   //  ASI
02808             c_asi_udp                      = (INT)  1827,   //  ASI
02809             c_itm_mcell_u_tcp              = (INT)  1828,   //  itm-mcell-u
02810             c_itm_mcell_u_udp              = (INT)  1828,   //  itm-mcell-u
02811             c_optika_emedia_tcp            = (INT)  1829,   //  Optika eMedia
02812             c_optika_emedia_udp            = (INT)  1829,   //  Optika eMedia
02813             c_net8_cman_tcp                = (INT)  1830,   //  Oracle Net8 CMan Admin
02814             c_net8_cman_udp                = (INT)  1830,   //  Oracle Net8 CMan Admin
02815             c_myrtle_tcp                   = (INT)  1831,   //  Myrtle
02816             c_myrtle_udp                   = (INT)  1831,   //  Myrtle
02817             c_tht_treasure_tcp             = (INT)  1832,   //  ThoughtTreasure
02818             c_tht_treasure_udp             = (INT)  1832,   //  ThoughtTreasure
02819             c_udpradio_tcp                 = (INT)  1833,   //  udpradio
02820             c_udpradio_udp                 = (INT)  1833,   //  udpradio
02821             c_ardusuni_tcp                 = (INT)  1834,   //  ARDUS Unicast
02822             c_ardusuni_udp                 = (INT)  1834,   //  ARDUS Unicast
02823             c_ardusmul_tcp                 = (INT)  1835,   //  ARDUS Multicast
02824             c_ardusmul_udp                 = (INT)  1835,   //  ARDUS Multicast
02825             c_ste_smsc_tcp                 = (INT)  1836,   //  ste-smsc
02826             c_ste_smsc_udp                 = (INT)  1836,   //  ste-smsc
02827             c_csoft1_tcp                   = (INT)  1837,   //  csoft1
02828             c_csoft1_udp                   = (INT)  1837,   //  csoft1
02829             c_talnet_tcp                   = (INT)  1838,   //  TALNET
02830             c_talnet_udp                   = (INT)  1838,   //  TALNET
02831             c_netopia_vo1_tcp              = (INT)  1839,   //  netopia-vo1
02832             c_netopia_vo1_udp              = (INT)  1839,   //  netopia-vo1
02833             c_netopia_vo2_tcp              = (INT)  1840,   //  netopia-vo2
02834             c_netopia_vo2_udp              = (INT)  1840,   //  netopia-vo2
02835             c_netopia_vo3_tcp              = (INT)  1841,   //  netopia-vo3
02836             c_netopia_vo3_udp              = (INT)  1841,   //  netopia-vo3
02837             c_netopia_vo4_tcp              = (INT)  1842,   //  netopia-vo4
02838             c_netopia_vo4_udp              = (INT)  1842,   //  netopia-vo4
02839             c_netopia_vo5_tcp              = (INT)  1843,   //  netopia-vo5
02840             c_netopia_vo5_udp              = (INT)  1843,   //  netopia-vo5
02841             c_direcpc_dll_tcp              = (INT)  1844,   //  DirecPC-DLL
02842             c_direcpc_dll_udp              = (INT)  1844,   //  DirecPC-DLL
02843             c_altalink_tcp                 = (INT)  1845,   //  altalink
02844             c_altalink_udp                 = (INT)  1845,   //  altalink
02845             c_tunstall_pnc_tcp             = (INT)  1846,   //  Tunstall PNC
02846             c_tunstall_pnc_udp             = (INT)  1846,   //  Tunstall PNC
02847             c_slp_notify_tcp               = (INT)  1847,   //  SLP Notification
02848             c_slp_notify_udp               = (INT)  1847,   //  SLP Notification
02849             c_fjdocdist_tcp                = (INT)  1848,   //  fjdocdist
02850             c_fjdocdist_udp                = (INT)  1848,   //  fjdocdist
02851             c_alpha_sms_tcp                = (INT)  1849,   //  ALPHA-SMS
02852             c_alpha_sms_udp                = (INT)  1849,   //  ALPHA-SMS
02853             c_gsi_tcp                      = (INT)  1850,   //  GSI
02854             c_gsi_udp                      = (INT)  1850,   //  GSI
02855             c_ctcd_tcp                     = (INT)  1851,   //  ctcd
02856             c_ctcd_udp                     = (INT)  1851,   //  ctcd
02857             c_virtual_time_tcp             = (INT)  1852,   //  Virtual Time
02858             c_virtual_time_udp             = (INT)  1852,   //  Virtual Time
02859             c_vids_avtp_tcp                = (INT)  1853,   //  VIDS-AVTP
02860             c_vids_avtp_udp                = (INT)  1853,   //  VIDS-AVTP
02861             c_buddy_draw_tcp               = (INT)  1854,   //  Buddy Draw
02862             c_buddy_draw_udp               = (INT)  1854,   //  Buddy Draw
02863             c_fiorano_rtrsvc_tcp           = (INT)  1855,   //  Fiorano RtrSvc
02864             c_fiorano_rtrsvc_udp           = (INT)  1855,   //  Fiorano RtrSvc
02865             c_fiorano_msgsvc_tcp           = (INT)  1856,   //  Fiorano MsgSvc
02866             c_fiorano_msgsvc_udp           = (INT)  1856,   //  Fiorano MsgSvc
02867             c_datacaptor_tcp               = (INT)  1857,   //  DataCaptor
02868             c_datacaptor_udp               = (INT)  1857,   //  DataCaptor
02869             c_privateark_tcp               = (INT)  1858,   //  PrivateArk
02870             c_privateark_udp               = (INT)  1858,   //  PrivateArk
02871             c_gammafetchsvr_tcp            = (INT)  1859,   //  Gamma Fetcher Server
02872             c_gammafetchsvr_udp            = (INT)  1859,   //  Gamma Fetcher Server
02873             c_sunscalar_svc_tcp            = (INT)  1860,   //  SunSCALAR Services
02874             c_sunscalar_svc_udp            = (INT)  1860,   //  SunSCALAR Services
02875             c_lecroy_vicp_tcp              = (INT)  1861,   //  LeCroy VICP
02876             c_lecroy_vicp_udp              = (INT)  1861,   //  LeCroy VICP
02877             c_techra_server_tcp            = (INT)  1862,   //  techra-server
02878             c_techra_server_udp            = (INT)  1862,   //  techra-server
02879             c_msnp_tcp                     = (INT)  1863,   //  MSNP
02880             c_msnp_udp                     = (INT)  1863,   //  MSNP
02881             c_paradym_31port_tcp           = (INT)  1864,   //  Paradym 31 Port
02882             c_paradym_31port_udp           = (INT)  1864,   //  Paradym 31 Port
02883             c_entp_tcp                     = (INT)  1865,   //  ENTP
02884             c_entp_udp                     = (INT)  1865,   //  ENTP
02885             c_swrmi_tcp                    = (INT)  1866,   //  swrmi
02886             c_swrmi_udp                    = (INT)  1866,   //  swrmi
02887             c_udrive_tcp                   = (INT)  1867,   //  UDRIVE
02888             c_udrive_udp                   = (INT)  1867,   //  UDRIVE
02889             c_viziblebrowser_tcp           = (INT)  1868,   //  VizibleBrowser
02890             c_viziblebrowser_udp           = (INT)  1868,   //  VizibleBrowser
02891             c_yestrader_tcp                = (INT)  1869,   //  YesTrader
02892             c_yestrader_udp                = (INT)  1869,   //  YesTrader
02893             c_sunscalar_dns_tcp            = (INT)  1870,   //  SunSCALAR DNS Service
02894             c_sunscalar_dns_udp            = (INT)  1870,   //  SunSCALAR DNS Service
02895             c_canocentral0_tcp             = (INT)  1871,   //  Cano Central 0
02896             c_canocentral0_udp             = (INT)  1871,   //  Cano Central 0
02897             c_canocentral1_tcp             = (INT)  1872,   //  Cano Central 1
02898             c_canocentral1_udp             = (INT)  1872,   //  Cano Central 1
02899             c_fjmpjps_tcp                  = (INT)  1873,   //  Fjmpjps
02900             c_fjmpjps_udp                  = (INT)  1873,   //  Fjmpjps
02901             c_fjswapsnp_tcp                = (INT)  1874,   //  Fjswapsnp
02902             c_fjswapsnp_udp                = (INT)  1874,   //  Fjswapsnp
02903             c_westell_stats_tcp            = (INT)  1875,   //  westell stats
02904             c_westell_stats_udp            = (INT)  1875,   //  westell stats
02905             c_ewcappsrv_tcp                = (INT)  1876,   //  ewcappsrv
02906             c_ewcappsrv_udp                = (INT)  1876,   //  ewcappsrv
02907             c_hp_webqosdb_tcp              = (INT)  1877,   //  hp-webqosdb
02908             c_hp_webqosdb_udp              = (INT)  1877,   //  hp-webqosdb
02909             c_drmsmc_tcp                   = (INT)  1878,   //  drmsmc
02910             c_drmsmc_udp                   = (INT)  1878,   //  drmsmc
02911             c_nettgain_nms_tcp             = (INT)  1879,   //  NettGain NMS
02912             c_nettgain_nms_udp             = (INT)  1879,   //  NettGain NMS
02913             c_vsat_control_tcp             = (INT)  1880,   //  Gilat VSAT Control
02914             c_vsat_control_udp             = (INT)  1880,   //  Gilat VSAT Control
02915             c_ibm_mqseries2_tcp            = (INT)  1881,   //  IBM MQSeries
02916             c_ibm_mqseries2_udp            = (INT)  1881,   //  IBM MQSeries
02917             c_ecsqdmn_tcp                  = (INT)  1882,   //  ecsqdmn
02918             c_ecsqdmn_udp                  = (INT)  1882,   //  ecsqdmn
02919             c_ibm_mqisdp_tcp               = (INT)  1883,   //  IBM MQSeries SCADA
02920             c_ibm_mqisdp_udp               = (INT)  1883,   //  IBM MQSeries SCADA
02921             c_idmaps_tcp                   = (INT)  1884,   //  Internet Distance Map Svc
02922             c_idmaps_udp                   = (INT)  1884,   //  Internet Distance Map Svc
02923             c_vrtstrapserver_tcp           = (INT)  1885,   //  Veritas Trap Server
02924             c_vrtstrapserver_udp           = (INT)  1885,   //  Veritas Trap Server
02925             c_leoip_tcp                    = (INT)  1886,   //  Leonardo over IP
02926             c_leoip_udp                    = (INT)  1886,   //  Leonardo over IP
02927             c_filex_lport_tcp              = (INT)  1887,   //  FileX Listening Port
02928             c_filex_lport_udp              = (INT)  1887,   //  FileX Listening Port
02929             c_ncconfig_tcp                 = (INT)  1888,   //  NC Config Port
02930             c_ncconfig_udp                 = (INT)  1888,   //  NC Config Port
02931             c_unify_adapter_tcp            = (INT)  1889,   //  Unify Web Adapter Service
02932             c_unify_adapter_udp            = (INT)  1889,   //  Unify Web Adapter Service
02933             c_wilkenlistener_tcp           = (INT)  1890,   //  wilkenListener
02934             c_wilkenlistener_udp           = (INT)  1890,   //  wilkenListener
02935             c_childkey_notif_tcp           = (INT)  1891,   //  ChildKey Notification
02936             c_childkey_notif_udp           = (INT)  1891,   //  ChildKey Notification
02937             c_childkey_ctrl_tcp            = (INT)  1892,   //  ChildKey Control
02938             c_childkey_ctrl_udp            = (INT)  1892,   //  ChildKey Control
02939             c_elad_tcp                     = (INT)  1893,   //  ELAD Protocol
02940             c_elad_udp                     = (INT)  1893,   //  ELAD Protocol
02941             c_o2server_port_tcp            = (INT)  1894,   //  O2Server Port
02942             c_o2server_port_udp            = (INT)  1894,   //  O2Server Port
02943             c_b_novative_ls_tcp            = (INT)  1896,   //  b-novative license server
02944             c_b_novative_ls_udp            = (INT)  1896,   //  b-novative license server
02945             c_metaagent_tcp                = (INT)  1897,   //  MetaAgent
02946             c_metaagent_udp                = (INT)  1897,   //  MetaAgent
02947             c_cymtec_port_tcp              = (INT)  1898,   //  Cymtec secure management
02948             c_cymtec_port_udp              = (INT)  1898,   //  Cymtec secure management
02949             c_mc2studios_tcp               = (INT)  1899,   //  MC2Studios
02950             c_mc2studios_udp               = (INT)  1899,   //  MC2Studios
02951             c_ssdp_tcp                     = (INT)  1900,   //  SSDP
02952             c_ssdp_udp                     = (INT)  1900,   //  SSDP
02953             c_fjicl_tep_a_tcp              = (INT)  1901,   //  Fujitsu ICL Terminal Emulator Program A
02954             c_fjicl_tep_a_udp              = (INT)  1901,   //  Fujitsu ICL Terminal Emulator Program A
02955             c_fjicl_tep_b_tcp              = (INT)  1902,   //  Fujitsu ICL Terminal Emulator Program B
02956             c_fjicl_tep_b_udp              = (INT)  1902,   //  Fujitsu ICL Terminal Emulator Program B
02957             c_linkname_tcp                 = (INT)  1903,   //  Local Link Name Resolution
02958             c_linkname_udp                 = (INT)  1903,   //  Local Link Name Resolution
02959             c_fjicl_tep_c_tcp              = (INT)  1904,   //  Fujitsu ICL Terminal Emulator Program C
02960             c_fjicl_tep_c_udp              = (INT)  1904,   //  Fujitsu ICL Terminal Emulator Program C
02961             c_sugp_tcp                     = (INT)  1905,   //  Secure UP.Link Gateway Protocol
02962             c_sugp_udp                     = (INT)  1905,   //  Secure UP.Link Gateway Protocol
02963             c_tpmd_tcp                     = (INT)  1906,   //  TPortMapperReq
02964             c_tpmd_udp                     = (INT)  1906,   //  TPortMapperReq
02965             c_intrastar_tcp                = (INT)  1907,   //  IntraSTAR
02966             c_intrastar_udp                = (INT)  1907,   //  IntraSTAR
02967             c_dawn_tcp                     = (INT)  1908,   //  Dawn
02968             c_dawn_udp                     = (INT)  1908,   //  Dawn
02969             c_global_wlink_tcp             = (INT)  1909,   //  Global World Link
02970             c_global_wlink_udp             = (INT)  1909,   //  Global World Link
02971             c_ultrabac_tcp                 = (INT)  1910,   //  ultrabac
02972             c_ultrabac_udp                 = (INT)  1910,   //  ultrabac
02973             c_mtp_tcp                      = (INT)  1911,   //  Starlight Networks Multimedia Transport Protocol
02974             c_mtp_udp                      = (INT)  1911,   //  Starlight Networks Multimedia Transport Protocol
02975             c_rhp_iibp_tcp                 = (INT)  1912,   //  rhp-iibp
02976             c_rhp_iibp_udp                 = (INT)  1912,   //  rhp-iibp
02977             c_armadp_tcp                   = (INT)  1913,   //  armadp
02978             c_armadp_udp                   = (INT)  1913,   //  armadp
02979             c_elm_momentum_tcp             = (INT)  1914,   //  Elm-Momentum
02980             c_elm_momentum_udp             = (INT)  1914,   //  Elm-Momentum
02981             c_facelink_tcp                 = (INT)  1915,   //  FACELINK
02982             c_facelink_udp                 = (INT)  1915,   //  FACELINK
02983             c_persona_tcp                  = (INT)  1916,   //  Persoft Persona
02984             c_persona_udp                  = (INT)  1916,   //  Persoft Persona
02985             c_noagent_tcp                  = (INT)  1917,   //  nOAgent
02986             c_noagent_udp                  = (INT)  1917,   //  nOAgent
02987             c_can_nds_tcp                  = (INT)  1918,   //  Candle Directory Service - NDS
02988             c_can_nds_udp                  = (INT)  1918,   //  Candle Directory Service - NDS
02989             c_can_dch_tcp                  = (INT)  1919,   //  Candle Directory Service - DCH
02990             c_can_dch_udp                  = (INT)  1919,   //  Candle Directory Service - DCH
02991             c_can_ferret_tcp               = (INT)  1920,   //  Candle Directory Service - FERRET
02992             c_can_ferret_udp               = (INT)  1920,   //  Candle Directory Service - FERRET
02993             c_noadmin_tcp                  = (INT)  1921,   //  NoAdmin
02994             c_noadmin_udp                  = (INT)  1921,   //  NoAdmin
02995             c_tapestry_tcp                 = (INT)  1922,   //  Tapestry
02996             c_tapestry_udp                 = (INT)  1922,   //  Tapestry
02997             c_spice_tcp                    = (INT)  1923,   //  SPICE
02998             c_spice_udp                    = (INT)  1923,   //  SPICE
02999             c_xiip_tcp                     = (INT)  1924,   //  XIIP
03000             c_xiip_udp                     = (INT)  1924,   //  XIIP
03001             c_discovery_port_tcp           = (INT)  1925,   //  Surrogate Discovery Port
03002             c_discovery_port_udp           = (INT)  1925,   //  Surrogate Discovery Port
03003             c_egs_tcp                      = (INT)  1926,   //  Evolution Game Server
03004             c_egs_udp                      = (INT)  1926,   //  Evolution Game Server
03005             c_videte_cipc_tcp              = (INT)  1927,   //  Videte CIPC Port
03006             c_videte_cipc_udp              = (INT)  1927,   //  Videte CIPC Port
03007             c_emsd_port_tcp                = (INT)  1928,   //  Expnd Maui Srvr Dscovr
03008             c_emsd_port_udp                = (INT)  1928,   //  Expnd Maui Srvr Dscovr
03009             c_bandwiz_system_tcp           = (INT)  1929,   //  Bandwiz System - Server
03010             c_bandwiz_system_udp           = (INT)  1929,   //  Bandwiz System - Server
03011             c_driveappserver_tcp           = (INT)  1930,   //  Drive AppServer
03012             c_driveappserver_udp           = (INT)  1930,   //  Drive AppServer
03013             c_amdsched_tcp                 = (INT)  1931,   //  AMD SCHED
03014             c_amdsched_udp                 = (INT)  1931,   //  AMD SCHED
03015             c_ctt_broker_tcp               = (INT)  1932,   //  CTT Broker
03016             c_ctt_broker_udp               = (INT)  1932,   //  CTT Broker
03017             c_xmapi_tcp                    = (INT)  1933,   //  IBM LM MT Agent
03018             c_xmapi_udp                    = (INT)  1933,   //  IBM LM MT Agent
03019             c_xaapi_tcp                    = (INT)  1934,   //  IBM LM Appl Agent
03020             c_xaapi_udp                    = (INT)  1934,   //  IBM LM Appl Agent
03021             c_tincan_tcp                   = (INT)  1935,   //  TinCan
03022             c_tincan_udp                   = (INT)  1935,   //  TinCan
03023             c_jetcmeserver_tcp             = (INT)  1936,   //  JetCmeServer Server Port
03024             c_jetcmeserver_udp             = (INT)  1936,   //  JetCmeServer Server Port
03025             c_jwserver_tcp                 = (INT)  1937,   //  JetVWay Server Port
03026             c_jwserver_udp                 = (INT)  1937,   //  JetVWay Server Port
03027             c_jwclient_tcp                 = (INT)  1938,   //  JetVWay Client Port
03028             c_jwclient_udp                 = (INT)  1938,   //  JetVWay Client Port
03029             c_jvserver_tcp                 = (INT)  1939,   //  JetVision Server Port
03030             c_jvserver_udp                 = (INT)  1939,   //  JetVision Server Port
03031             c_jvclient_tcp                 = (INT)  1940,   //  JetVision Client Port
03032             c_jvclient_udp                 = (INT)  1940,   //  JetVision Client Port
03033             c_dic_aida_tcp                 = (INT)  1941,   //  DIC-Aida
03034             c_dic_aida_udp                 = (INT)  1941,   //  DIC-Aida
03035             c_res_tcp                      = (INT)  1942,   //  Real Enterprise Service
03036             c_res_udp                      = (INT)  1942,   //  Real Enterprise Service
03037             c_beeyond_media_tcp            = (INT)  1943,   //  Beeyond Media
03038             c_beeyond_media_udp            = (INT)  1943,   //  Beeyond Media
03039             c_close_combat_tcp             = (INT)  1944,   //  close-combat
03040             c_close_combat_udp             = (INT)  1944,   //  close-combat
03041             c_dialogic_elmd_tcp            = (INT)  1945,   //  dialogic-elmd
03042             c_dialogic_elmd_udp            = (INT)  1945,   //  dialogic-elmd
03043             c_tekpls_tcp                   = (INT)  1946,   //  tekpls
03044             c_tekpls_udp                   = (INT)  1946,   //  tekpls
03045             c_hlserver_tcp                 = (INT)  1947,   //  hlserver
03046             c_hlserver_udp                 = (INT)  1947,   //  hlserver
03047             c_eye2eye_tcp                  = (INT)  1948,   //  eye2eye
03048             c_eye2eye_udp                  = (INT)  1948,   //  eye2eye
03049             c_ismaeasdaqlive_tcp           = (INT)  1949,   //  ISMA Easdaq Live
03050             c_ismaeasdaqlive_udp           = (INT)  1949,   //  ISMA Easdaq Live
03051             c_ismaeasdaqtest_tcp           = (INT)  1950,   //  ISMA Easdaq Test
03052             c_ismaeasdaqtest_udp           = (INT)  1950,   //  ISMA Easdaq Test
03053             c_bcs_lmserver_tcp             = (INT)  1951,   //  bcs-lmserver
03054             c_bcs_lmserver_udp             = (INT)  1951,   //  bcs-lmserver
03055             c_mpnjsc_tcp                   = (INT)  1952,   //  mpnjsc
03056             c_mpnjsc_udp                   = (INT)  1952,   //  mpnjsc
03057             c_rapidbase_tcp                = (INT)  1953,   //  Rapid Base
03058             c_rapidbase_udp                = (INT)  1953,   //  Rapid Base
03059             c_abr_basic_tcp                = (INT)  1954,   //  ABR-Basic Data
03060             c_abr_basic_udp                = (INT)  1954,   //  ABR-Basic Data
03061             c_abr_secure_tcp               = (INT)  1955,   //  ABR-Secure Data
03062             c_abr_secure_udp               = (INT)  1955,   //  ABR-Secure Data
03063             c_vrtl_vmf_ds_tcp              = (INT)  1956,   //  Vertel VMF DS
03064             c_vrtl_vmf_ds_udp              = (INT)  1956,   //  Vertel VMF DS
03065             c_unix_status_tcp              = (INT)  1957,   //  unix-status
03066             c_unix_status_udp              = (INT)  1957,   //  unix-status
03067             c_dxadmind_tcp                 = (INT)  1958,   //  CA Administration Daemon
03068             c_dxadmind_udp                 = (INT)  1958,   //  CA Administration Daemon
03069             c_simp_all_tcp                 = (INT)  1959,   //  SIMP Channel
03070             c_simp_all_udp                 = (INT)  1959,   //  SIMP Channel
03071             c_nasmanager_tcp               = (INT)  1960,   //  Merit DAC NASmanager
03072             c_nasmanager_udp               = (INT)  1960,   //  Merit DAC NASmanager
03073             c_bts_appserver_tcp            = (INT)  1961,   //  BTS APPSERVER
03074             c_bts_appserver_udp            = (INT)  1961,   //  BTS APPSERVER
03075             c_biap_mp_tcp                  = (INT)  1962,   //  BIAP-MP
03076             c_biap_mp_udp                  = (INT)  1962,   //  BIAP-MP
03077             c_webmachine_tcp               = (INT)  1963,   //  WebMachine
03078             c_webmachine_udp               = (INT)  1963,   //  WebMachine
03079             c_solid_e_engine_tcp           = (INT)  1964,   //  SOLID E ENGINE
03080             c_solid_e_engine_udp           = (INT)  1964,   //  SOLID E ENGINE
03081             c_tivoli_npm_tcp               = (INT)  1965,   //  Tivoli NPM
03082             c_tivoli_npm_udp               = (INT)  1965,   //  Tivoli NPM
03083             c_slush_tcp                    = (INT)  1966,   //  Slush
03084             c_slush_udp                    = (INT)  1966,   //  Slush
03085             c_sns_quote_tcp                = (INT)  1967,   //  SNS Quote
03086             c_sns_quote_udp                = (INT)  1967,   //  SNS Quote
03087             c_lipsinc_tcp                  = (INT)  1968,   //  LIPSinc
03088             c_lipsinc_udp                  = (INT)  1968,   //  LIPSinc
03089             c_lipsinc1_tcp                 = (INT)  1969,   //  LIPSinc 1
03090             c_lipsinc1_udp                 = (INT)  1969,   //  LIPSinc 1
03091             c_netop_rc_tcp                 = (INT)  1970,   //  NetOp Remote Control
03092             c_netop_rc_udp                 = (INT)  1970,   //  NetOp Remote Control
03093             c_netop_school_tcp             = (INT)  1971,   //  NetOp School
03094             c_netop_school_udp             = (INT)  1971,   //  NetOp School
03095             c_intersys_cache_tcp           = (INT)  1972,   //  Cache
03096             c_intersys_cache_udp           = (INT)  1972,   //  Cache
03097             c_dlsrap_tcp                   = (INT)  1973,   //  Data Link Switching Remote Access Protocol
03098             c_dlsrap_udp                   = (INT)  1973,   //  Data Link Switching Remote Access Protocol
03099             c_drp_tcp                      = (INT)  1974,   //  DRP
03100             c_drp_udp                      = (INT)  1974,   //  DRP
03101             c_tcoflashagent_tcp            = (INT)  1975,   //  TCO Flash Agent
03102             c_tcoflashagent_udp            = (INT)  1975,   //  TCO Flash Agent
03103             c_tcoregagent_tcp              = (INT)  1976,   //  TCO Reg Agent
03104             c_tcoregagent_udp              = (INT)  1976,   //  TCO Reg Agent
03105             c_tcoaddressbook_tcp           = (INT)  1977,   //  TCO Address Book
03106             c_tcoaddressbook_udp           = (INT)  1977,   //  TCO Address Book
03107             c_unisql_tcp                   = (INT)  1978,   //  UniSQL
03108             c_unisql_udp                   = (INT)  1978,   //  UniSQL
03109             c_unisql_java_tcp              = (INT)  1979,   //  UniSQL Java
03110             c_unisql_java_udp              = (INT)  1979,   //  UniSQL Java
03111             c_pearldoc_xact_tcp            = (INT)  1980,   //  PearlDoc XACT
03112             c_pearldoc_xact_udp            = (INT)  1980,   //  PearlDoc XACT
03113             c_p2pq_tcp                     = (INT)  1981,   //  p2pQ
03114             c_p2pq_udp                     = (INT)  1981,   //  p2pQ
03115             c_estamp_tcp                   = (INT)  1982,   //  Evidentiary Timestamp
03116             c_estamp_udp                   = (INT)  1982,   //  Evidentiary Timestamp
03117             c_lhtp_tcp                     = (INT)  1983,   //  Loophole Test Protocol
03118             c_lhtp_udp                     = (INT)  1983,   //  Loophole Test Protocol
03119             c_bb_tcp                       = (INT)  1984,   //  BB
03120             c_bb_udp                       = (INT)  1984,   //  BB
03121             c_hsrp_tcp                     = (INT)  1985,   //  Hot Standby Router Protocol
03122             c_hsrp_udp                     = (INT)  1985,   //  Hot Standby Router Protocol
03123             c_licensedaemon_tcp            = (INT)  1986,   //  cisco license management
03124             c_licensedaemon_udp            = (INT)  1986,   //  cisco license management
03125             c_tr_rsrb_p1_tcp               = (INT)  1987,   //  cisco RSRB Priority 1 port
03126             c_tr_rsrb_p1_udp               = (INT)  1987,   //  cisco RSRB Priority 1 port
03127             c_tr_rsrb_p2_tcp               = (INT)  1988,   //  cisco RSRB Priority 2 port
03128             c_tr_rsrb_p2_udp               = (INT)  1988,   //  cisco RSRB Priority 2 port
03129             c_tr_rsrb_p3_tcp               = (INT)  1989,   //  cisco RSRB Priority 3 port
03130             c_tr_rsrb_p3_udp               = (INT)  1989,   //  cisco RSRB Priority 3 port
03131             c_mshnet_tcp                   = (INT)  1989,   //  MHSnet system
03132             c_mshnet_udp                   = (INT)  1989,   //  MHSnet system
03133             c_stun_p1_tcp                  = (INT)  1990,   //  cisco STUN Priority 1 port
03134             c_stun_p1_udp                  = (INT)  1990,   //  cisco STUN Priority 1 port
03135             c_stun_p2_tcp                  = (INT)  1991,   //  cisco STUN Priority 2 port
03136             c_stun_p2_udp                  = (INT)  1991,   //  cisco STUN Priority 2 port
03137             c_stun_p3_tcp                  = (INT)  1992,   //  cisco STUN Priority 3 port
03138             c_stun_p3_udp                  = (INT)  1992,   //  cisco STUN Priority 3 port
03139             c_ipsendmsg_tcp                = (INT)  1992,   //  IPsendmsg
03140             c_ipsendmsg_udp                = (INT)  1992,   //  IPsendmsg
03141             c_snmp_tcp_port_tcp            = (INT)  1993,   //  cisco SNMP TCP port
03142             c_snmp_tcp_port_udp            = (INT)  1993,   //  cisco SNMP TCP port
03143             c_stun_port_tcp                = (INT)  1994,   //  cisco serial tunnel port
03144             c_stun_port_udp                = (INT)  1994,   //  cisco serial tunnel port
03145             c_perf_port_tcp                = (INT)  1995,   //  cisco perf port
03146             c_perf_port_udp                = (INT)  1995,   //  cisco perf port
03147             c_tr_rsrb_port_tcp             = (INT)  1996,   //  cisco Remote SRB port
03148             c_tr_rsrb_port_udp             = (INT)  1996,   //  cisco Remote SRB port
03149             c_gdp_port_tcp                 = (INT)  1997,   //  cisco Gateway Discovery Protocol
03150             c_gdp_port_udp                 = (INT)  1997,   //  cisco Gateway Discovery Protocol
03151             c_x25_svc_port_tcp             = (INT)  1998,   //  cisco X.25 service (XOT)
03152             c_x25_svc_port_udp             = (INT)  1998,   //  cisco X.25 service (XOT)
03153             c_tcp_id_port_tcp              = (INT)  1999,   //  cisco identification port
03154             c_tcp_id_port_udp              = (INT)  1999,   //  cisco identification port
03155             c_callbook_tcp                 = (INT)  2000,   //
03156             c_callbook_udp                 = (INT)  2000,   //
03157             c_dc_tcp                       = (INT)  2001,   //
03158             c_wizard_udp                   = (INT)  2001,   //  curry
03159             c_globe_tcp                    = (INT)  2002,   //
03160             c_globe_udp                    = (INT)  2002,   //
03161             c_mailbox_tcp                  = (INT)  2004,   //
03162             c_emce_udp                     = (INT)  2004,   //  CCWS mm conf
03163             c_berknet_tcp                  = (INT)  2005,   //
03164             c_oracle_udp                   = (INT)  2005,   //
03165             c_invokator_tcp                = (INT)  2006,   //
03166             c_raid_cc_udp                  = (INT)  2006,   //  raid
03167             c_dectalk_tcp                  = (INT)  2007,   //
03168             c_raid_am_udp                  = (INT)  2007,   //
03169             c_conf_tcp                     = (INT)  2008,   //
03170             c_terminaldb_udp               = (INT)  2008,   //
03171             c_news_tcp                     = (INT)  2009,   //
03172             c_whosockami_udp               = (INT)  2009,   //
03173             c_search_tcp                   = (INT)  2010,   //
03174             c_raid_cc_tcp                  = (INT)  2011,   //  raid
03175             c_servserv_udp                 = (INT)  2011,   //
03176             c_ttyinfo_tcp                  = (INT)  2012,   //
03177             c_raid_ac_udp                  = (INT)  2012,   //
03178             c_raid_am_tcp                  = (INT)  2013,   //
03179             c_raid_cd_udp                  = (INT)  2013,   //
03180             c_troff_tcp                    = (INT)  2014,   //
03181             c_raid_sf_udp                  = (INT)  2014,   //
03182             c_cypress_tcp                  = (INT)  2015,   //
03183             c_raid_cs_udp                  = (INT)  2015,   //
03184             c_bootserver_tcp               = (INT)  2016,   //
03185             c_bootserver_udp               = (INT)  2016,   //
03186             c_cypress_stat_tcp             = (INT)  2017,   //
03187             c_bootclient_udp               = (INT)  2017,   //
03188             c_terminaldb_tcp               = (INT)  2018,   //
03189             c_rellpack_udp                 = (INT)  2018,   //
03190             c_whosockami_tcp               = (INT)  2019,   //
03191             c_about_udp                    = (INT)  2019,   //
03192             c_xinupageserver_tcp           = (INT)  2020,   //
03193             c_xinupageserver_udp           = (INT)  2020,   //
03194             c_servexec_tcp                 = (INT)  2021,   //
03195             c_xinuexpansion1_udp           = (INT)  2021,   //
03196             c_down_tcp                     = (INT)  2022,   //
03197             c_xinuexpansion2_udp           = (INT)  2022,   //
03198             c_xinuexpansion3_tcp           = (INT)  2023,   //
03199             c_xinuexpansion3_udp           = (INT)  2023,   //
03200             c_xinuexpansion4_tcp           = (INT)  2024,   //
03201             c_xinuexpansion4_udp           = (INT)  2024,   //
03202             c_ellpack_tcp                  = (INT)  2025,   //
03203             c_xribs_udp                    = (INT)  2025,   //
03204             c_scrabble_tcp                 = (INT)  2026,   //
03205             c_scrabble_udp                 = (INT)  2026,   //
03206             c_shadowserver_tcp             = (INT)  2027,   //
03207             c_shadowserver_udp             = (INT)  2027,   //
03208             c_submitserver_tcp             = (INT)  2028,   //
03209             c_submitserver_udp             = (INT)  2028,   //
03210             c_device2_tcp                  = (INT)  2030,   //
03211             c_device2_udp                  = (INT)  2030,   //
03212             c_blackboard_tcp               = (INT)  2032,   //
03213             c_blackboard_udp               = (INT)  2032,   //
03214             c_glogger_tcp                  = (INT)  2033,   //
03215             c_glogger_udp                  = (INT)  2033,   //
03216             c_scoremgr_tcp                 = (INT)  2034,   //
03217             c_scoremgr_udp                 = (INT)  2034,   //
03218             c_imsldoc_tcp                  = (INT)  2035,   //
03219             c_imsldoc_udp                  = (INT)  2035,   //
03220             c_p2plus_tcp                   = (INT)  2037,   //  P2plus Application Server
03221             c_p2plus_udp                   = (INT)  2037,   //  P2plus Application Server
03222             c_objectmanager_tcp            = (INT)  2038,   //
03223             c_objectmanager_udp            = (INT)  2038,   //
03224             c_lam_tcp                      = (INT)  2040,   //
03225             c_lam_udp                      = (INT)  2040,   //
03226             c_interbase_tcp                = (INT)  2041,   //
03227             c_interbase_udp                = (INT)  2041,   //
03228             c_isis_tcp                     = (INT)  2042,   //  isis
03229             c_isis_udp                     = (INT)  2042,   //  isis
03230             c_isis_bcast_tcp               = (INT)  2043,   //  isis-bcast
03231             c_isis_bcast_udp               = (INT)  2043,   //  isis-bcast
03232             c_rimsl_tcp                    = (INT)  2044,   //
03233             c_rimsl_udp                    = (INT)  2044,   //
03234             c_cdfunc_tcp                   = (INT)  2045,   //
03235             c_cdfunc_udp                   = (INT)  2045,   //
03236             c_sdfunc_tcp                   = (INT)  2046,   //
03237             c_sdfunc_udp                   = (INT)  2046,   //
03238             c_dls_1_tcp                    = (INT)  2047,   //
03239             c_dls_1_udp                    = (INT)  2047,   //
03240             c_dls_monitor_tcp              = (INT)  2048,   //
03241             c_dls_monitor_udp              = (INT)  2048,   //
03242             c_shilp_tcp                    = (INT)  2049,   //
03243             c_shilp_udp                    = (INT)  2049,   //
03244             c_nfs_tcp                      = (INT)  2049,   //  Network File System - Sun Microsystems
03245             c_nfs_udp                      = (INT)  2049,   //  Network File System - Sun Microsystems
03246             c_av_emb_config_tcp            = (INT)  2050,   //  Avaya EMB Config Port
03247             c_av_emb_config_udp            = (INT)  2050,   //  Avaya EMB Config Port
03248             c_epnsdp_tcp                   = (INT)  2051,   //  EPNSDP
03249             c_epnsdp_udp                   = (INT)  2051,   //  EPNSDP
03250             c_clearvisn_tcp                = (INT)  2052,   //  clearVisn Services Port
03251             c_clearvisn_udp                = (INT)  2052,   //  clearVisn Services Port
03252             c_lot105_ds_upd_tcp            = (INT)  2053,   //  Lot105 DSuper Updates
03253             c_lot105_ds_upd_udp            = (INT)  2053,   //  Lot105 DSuper Updates
03254             c_weblogin_tcp                 = (INT)  2054,   //  Weblogin Port
03255             c_weblogin_udp                 = (INT)  2054,   //  Weblogin Port
03256             c_iop_tcp                      = (INT)  2055,   //  Iliad-Odyssey Protocol
03257             c_iop_udp                      = (INT)  2055,   //  Iliad-Odyssey Protocol
03258             c_omnisky_tcp                  = (INT)  2056,   //  OmniSky Port
03259             c_omnisky_udp                  = (INT)  2056,   //  OmniSky Port
03260             c_rich_cp_tcp                  = (INT)  2057,   //  Rich Content Protocol
03261             c_rich_cp_udp                  = (INT)  2057,   //  Rich Content Protocol
03262             c_newwavesearch_tcp            = (INT)  2058,   //  NewWaveSearchables RMI
03263             c_newwavesearch_udp            = (INT)  2058,   //  NewWaveSearchables RMI
03264             c_bmc_messaging_tcp            = (INT)  2059,   //  BMC Messaging Service
03265             c_bmc_messaging_udp            = (INT)  2059,   //  BMC Messaging Service
03266             c_teleniumdaemon_tcp           = (INT)  2060,   //  Telenium Daemon IF
03267             c_teleniumdaemon_udp           = (INT)  2060,   //  Telenium Daemon IF
03268             c_netmount_tcp                 = (INT)  2061,   //  NetMount
03269             c_netmount_udp                 = (INT)  2061,   //  NetMount
03270             c_icg_swp_tcp                  = (INT)  2062,   //  ICG SWP Port
03271             c_icg_swp_udp                  = (INT)  2062,   //  ICG SWP Port
03272             c_icg_bridge_tcp               = (INT)  2063,   //  ICG Bridge Port
03273             c_icg_bridge_udp               = (INT)  2063,   //  ICG Bridge Port
03274             c_icg_iprelay_tcp              = (INT)  2064,   //  ICG IP Relay Port
03275             c_icg_iprelay_udp              = (INT)  2064,   //  ICG IP Relay Port
03276             c_dlsrpn_tcp                   = (INT)  2065,   //  Data Link Switch Read Port Number
03277             c_dlsrpn_udp                   = (INT)  2065,   //  Data Link Switch Read Port Number
03278             c_dlswpn_tcp                   = (INT)  2067,   //  Data Link Switch Write Port Number
03279             c_dlswpn_udp                   = (INT)  2067,   //  Data Link Switch Write Port Number
03280             c_avauthsrvprtcl_tcp           = (INT)  2068,   //  Avocent AuthSrv Protocol
03281             c_avauthsrvprtcl_udp           = (INT)  2068,   //  Avocent AuthSrv Protocol
03282             c_event_port_tcp               = (INT)  2069,   //  HTTP Event Port
03283             c_event_port_udp               = (INT)  2069,   //  HTTP Event Port
03284             c_ah_esp_encap_tcp             = (INT)  2070,   //  AH and ESP Encapsulated in UDP packet
03285             c_ah_esp_encap_udp             = (INT)  2070,   //  AH and ESP Encapsulated in UDP packet
03286             c_acp_port_tcp                 = (INT)  2071,   //  Axon Control Protocol
03287             c_acp_port_udp                 = (INT)  2071,   //  Axon Control Protocol
03288             c_msync_tcp                    = (INT)  2072,   //  GlobeCast mSync
03289             c_msync_udp                    = (INT)  2072,   //  GlobeCast mSync
03290             c_gxs_data_port_tcp            = (INT)  2073,   //  DataReel Database Socket
03291             c_gxs_data_port_udp            = (INT)  2073,   //  DataReel Database Socket
03292             c_vrtl_vmf_sa_tcp              = (INT)  2074,   //  Vertel VMF SA
03293             c_vrtl_vmf_sa_udp              = (INT)  2074,   //  Vertel VMF SA
03294             c_newlixengine_tcp             = (INT)  2075,   //  Newlix ServerWare Engine
03295             c_newlixengine_udp             = (INT)  2075,   //  Newlix ServerWare Engine
03296             c_newlixconfig_tcp             = (INT)  2076,   //  Newlix JSPConfig
03297             c_newlixconfig_udp             = (INT)  2076,   //  Newlix JSPConfig
03298             c_trellisagt_tcp               = (INT)  2077,   //  TrelliSoft Agent
03299             c_trellisagt_udp               = (INT)  2077,   //  TrelliSoft Agent
03300             c_trellissvr_tcp               = (INT)  2078,   //  TrelliSoft Server
03301             c_trellissvr_udp               = (INT)  2078,   //  TrelliSoft Server
03302             c_idware_router_tcp            = (INT)  2079,   //  IDWARE Router Port
03303             c_idware_router_udp            = (INT)  2079,   //  IDWARE Router Port
03304             c_autodesk_nlm_tcp             = (INT)  2080,   //  Autodesk NLM (FLEXlm)
03305             c_autodesk_nlm_udp             = (INT)  2080,   //  Autodesk NLM (FLEXlm)
03306             c_kme_trap_port_tcp            = (INT)  2081,   //  KME PRINTER TRAP PORT
03307             c_kme_trap_port_udp            = (INT)  2081,   //  KME PRINTER TRAP PORT
03308             c_infowave_tcp                 = (INT)  2082,   //  Infowave Mobility Server
03309             c_infowave_udp                 = (INT)  2082,   //  Infowave Mobiltiy Server
03310             c_eli_tcp                      = (INT)  2087,   //  ELI - Event Logging Integration
03311             c_eli_udp                      = (INT)  2087,   //  ELI - Event Logging Integration
03312             c_sep_tcp                      = (INT)  2089,   //  Security Encapsulation Protocol - SEP
03313             c_sep_udp                      = (INT)  2089,   //  Security Encapsulation Protocol - SEP
03314             c_lrp_tcp                      = (INT)  2090,   //  Load Report Protocol
03315             c_lrp_udp                      = (INT)  2090,   //  Load Report Protocol
03316             c_prp_tcp                      = (INT)  2091,   //  PRP
03317             c_prp_udp                      = (INT)  2091,   //  PRP
03318             c_descent3_tcp                 = (INT)  2092,   //  Descent 3
03319             c_descent3_udp                 = (INT)  2092,   //  Descent 3
03320             c_nbx_cc_tcp                   = (INT)  2093,   //  NBX CC
03321             c_nbx_cc_udp                   = (INT)  2093,   //  NBX CC
03322             c_nbx_au_tcp                   = (INT)  2094,   //  NBX AU
03323             c_nbx_au_udp                   = (INT)  2094,   //  NBX AU
03324             c_nbx_ser_tcp                  = (INT)  2095,   //  NBX SER
03325             c_nbx_ser_udp                  = (INT)  2095,   //  NBX SER
03326             c_nbx_dir_tcp                  = (INT)  2096,   //  NBX DIR
03327             c_nbx_dir_udp                  = (INT)  2096,   //  NBX DIR
03328             c_jetformpreview_tcp           = (INT)  2097,   //  Jet Form Preview
03329             c_jetformpreview_udp           = (INT)  2097,   //  Jet Form Preview
03330             c_dialog_port_tcp              = (INT)  2098,   //  Dialog Port
03331             c_dialog_port_udp              = (INT)  2098,   //  Dialog Port
03332             c_h2250_annex_g_tcp            = (INT)  2099,   //  H.225.0 Annex G
03333             c_h2250_annex_g_udp            = (INT)  2099,   //  H.225.0 Annex G
03334             c_amiganetfs_tcp               = (INT)  2100,   //  amiganetfs
03335             c_amiganetfs_udp               = (INT)  2100,   //  amiganetfs
03336             c_rtcm_sc104_tcp               = (INT)  2101,   //  rtcm-sc104
03337             c_rtcm_sc104_udp               = (INT)  2101,   //  rtcm-sc104
03338             c_zephyr_srv_tcp               = (INT)  2102,   //  Zephyr server
03339             c_zephyr_srv_udp               = (INT)  2102,   //  Zephyr server
03340             c_zephyr_clt_tcp               = (INT)  2103,   //  Zephyr serv-hm connection
03341             c_zephyr_clt_udp               = (INT)  2103,   //  Zephyr serv-hm connection
03342             c_zephyr_hm_tcp                = (INT)  2104,   //  Zephyr hostmanager
03343             c_zephyr_hm_udp                = (INT)  2104,   //  Zephyr hostmanager
03344             c_minipay_tcp                  = (INT)  2105,   //  MiniPay
03345             c_minipay_udp                  = (INT)  2105,   //  MiniPay
03346             c_mzap_tcp                     = (INT)  2106,   //  MZAP
03347             c_mzap_udp                     = (INT)  2106,   //  MZAP
03348             c_bintec_admin_tcp             = (INT)  2107,   //  BinTec Admin
03349             c_bintec_admin_udp             = (INT)  2107,   //  BinTec Admin
03350             c_comcam_tcp                   = (INT)  2108,   //  Comcam
03351             c_comcam_udp                   = (INT)  2108,   //  Comcam
03352             c_ergolight_tcp                = (INT)  2109,   //  Ergolight
03353             c_ergolight_udp                = (INT)  2109,   //  Ergolight
03354             c_umsp_tcp                     = (INT)  2110,   //  UMSP
03355             c_umsp_udp                     = (INT)  2110,   //  UMSP
03356             c_dsatp_tcp                    = (INT)  2111,   //  DSATP
03357             c_dsatp_udp                    = (INT)  2111,   //  DSATP
03358             c_idonix_metanet_tcp           = (INT)  2112,   //  Idonix MetaNet
03359             c_idonix_metanet_udp           = (INT)  2112,   //  Idonix MetaNet
03360             c_hsl_storm_tcp                = (INT)  2113,   //  HSL StoRM
03361             c_hsl_storm_udp                = (INT)  2113,   //  HSL StoRM
03362             c_newheights_tcp               = (INT)  2114,   //  NEWHEIGHTS
03363             c_newheights_udp               = (INT)  2114,   //  NEWHEIGHTS
03364             c_kdm_tcp                      = (INT)  2115,   //  KDM
03365             c_kdm_udp                      = (INT)  2115,   //  KDM
03366             c_ccowcmr_tcp                  = (INT)  2116,   //  CCOWCMR
03367             c_ccowcmr_udp                  = (INT)  2116,   //  CCOWCMR
03368             c_mentaclient_tcp              = (INT)  2117,   //  MENTACLIENT
03369             c_mentaclient_udp              = (INT)  2117,   //  MENTACLIENT
03370             c_mentaserver_tcp              = (INT)  2118,   //  MENTASERVER
03371             c_mentaserver_udp              = (INT)  2118,   //  MENTASERVER
03372             c_gsigatekeeper_tcp            = (INT)  2119,   //  GSIGATEKEEPER
03373             c_gsigatekeeper_udp            = (INT)  2119,   //  GSIGATEKEEPER
03374             c_qencp_tcp                    = (INT)  2120,   //  Quick Eagle Networks CP
03375             c_qencp_udp                    = (INT)  2120,   //  Quick Eagle Networks CP
03376             c_scientia_ssdb_tcp            = (INT)  2121,   //  SCIENTIA-SSDB
03377             c_scientia_ssdb_udp            = (INT)  2121,   //  SCIENTIA-SSDB
03378             c_caupc_remote_tcp             = (INT)  2122,   //  CauPC Remote Control
03379             c_caupc_remote_udp             = (INT)  2122,   //  CauPC Remote Control
03380             c_gtp_control_tcp              = (INT)  2123,   //  GTP-Control Plane (3GPP)
03381             c_gtp_control_udp              = (INT)  2123,   //  GTP-Control Plane (3GPP)
03382             c_elatelink_tcp                = (INT)  2124,   //  ELATELINK
03383             c_elatelink_udp                = (INT)  2124,   //  ELATELINK
03384             c_lockstep_tcp                 = (INT)  2125,   //  LOCKSTEP
03385             c_lockstep_udp                 = (INT)  2125,   //  LOCKSTEP
03386             c_pktcable_cops_tcp            = (INT)  2126,   //  PktCable-COPS
03387             c_pktcable_cops_udp            = (INT)  2126,   //  PktCable-COPS
03388             c_index_pc_wb_tcp              = (INT)  2127,   //  INDEX-PC-WB
03389             c_index_pc_wb_udp              = (INT)  2127,   //  INDEX-PC-WB
03390             c_net_steward_tcp              = (INT)  2128,   //  Net Steward Control
03391             c_net_steward_udp              = (INT)  2128,   //  Net Steward Control
03392             c_cs_live_tcp                  = (INT)  2129,   //  cs-live.com
03393             c_cs_live_udp                  = (INT)  2129,   //  cs-live.com
03394             c_swc_xds_tcp                  = (INT)  2130,   //  SWC-XDS
03395             c_swc_xds_udp                  = (INT)  2130,   //  SWC-XDS
03396             c_avantageb2b_tcp              = (INT)  2131,   //  Avantageb2b
03397             c_avantageb2b_udp              = (INT)  2131,   //  Avantageb2b
03398             c_avail_epmap_tcp              = (INT)  2132,   //  AVAIL-EPMAP
03399             c_avail_epmap_udp              = (INT)  2132,   //  AVAIL-EPMAP
03400             c_zymed_zpp_tcp                = (INT)  2133,   //  ZYMED-ZPP
03401             c_zymed_zpp_udp                = (INT)  2133,   //  ZYMED-ZPP
03402             c_avenue_tcp                   = (INT)  2134,   //  AVENUE
03403             c_avenue_udp                   = (INT)  2134,   //  AVENUE
03404             c_gris_tcp                     = (INT)  2135,   //  Grid Resource Information Server
03405             c_gris_udp                     = (INT)  2135,   //  Grid Resource Information Server
03406             c_appworxsrv_tcp               = (INT)  2136,   //  APPWORXSRV
03407             c_appworxsrv_udp               = (INT)  2136,   //  APPWORXSRV
03408             c_connect_tcp                  = (INT)  2137,   //  CONNECT
03409             c_connect_udp                  = (INT)  2137,   //  CONNECT
03410             c_unbind_cluster_tcp           = (INT)  2138,   //  UNBIND-CLUSTER
03411             c_unbind_cluster_udp           = (INT)  2138,   //  UNBIND-CLUSTER
03412             c_ias_auth_tcp                 = (INT)  2139,   //  IAS-AUTH
03413             c_ias_auth_udp                 = (INT)  2139,   //  IAS-AUTH
03414             c_ias_reg_tcp                  = (INT)  2140,   //  IAS-REG
03415             c_ias_reg_udp                  = (INT)  2140,   //  IAS-REG
03416             c_ias_admind_tcp               = (INT)  2141,   //  IAS-ADMIND
03417             c_ias_admind_udp               = (INT)  2141,   //  IAS-ADMIND
03418             c_tdm_over_ip_tcp              = (INT)  2142,   //  TDM-OVER-IP
03419             c_tdm_over_ip_udp              = (INT)  2142,   //  TDM-OVER-IP
03420             c_lv_jc_tcp                    = (INT)  2143,   //  Live Vault Job Control
03421             c_lv_jc_udp                    = (INT)  2143,   //  Live Vault Job Control
03422             c_lv_ffx_tcp                   = (INT)  2144,   //  Live Vault Fast Object Transfer
03423             c_lv_ffx_udp                   = (INT)  2144,   //  Live Vault Fast Object Transfer
03424             c_lv_pici_tcp                  = (INT)  2145,   //  Live Vault Remote Diagnostic Console Support
03425             c_lv_pici_udp                  = (INT)  2145,   //  Live Vault Remote Diagnostic Console Support
03426             c_lv_not_tcp                   = (INT)  2146,   //  Live Vault Admin Event Notification
03427             c_lv_not_udp                   = (INT)  2146,   //  Live Vault Admin Event Notification
03428             c_lv_auth_tcp                  = (INT)  2147,   //  Live Vault Authentication
03429             c_lv_auth_udp                  = (INT)  2147,   //  Live Vault Authentication
03430             c_veritas_ucl_tcp              = (INT)  2148,   //  VERITAS UNIVERSAL COMMUNICATION LAYER
03431             c_veritas_ucl_udp              = (INT)  2148,   //  VERITAS UNIVERSAL COMMUNICATION LAYER
03432             c_acptsys_tcp                  = (INT)  2149,   //  ACPTSYS
03433             c_acptsys_udp                  = (INT)  2149,   //  ACPTSYS
03434             c_dynamic3d_tcp                = (INT)  2150,   //  DYNAMIC3D
03435             c_dynamic3d_udp                = (INT)  2150,   //  DYNAMIC3D
03436             c_docent_tcp                   = (INT)  2151,   //  DOCENT
03437             c_docent_udp                   = (INT)  2151,   //  DOCENT
03438             c_gtp_user_tcp                 = (INT)  2152,   //  GTP-User Plane (3GPP)
03439             c_gtp_user_udp                 = (INT)  2152,   //  GTP-User Plane (3GPP)
03440             c_gdbremote_tcp                = (INT)  2159,   //  GDB Remote Debug Port
03441             c_gdbremote_udp                = (INT)  2159,   //  GDB Remote Debug Port
03442             c_apc_cms_tcp                  = (INT)  2160,   //  APC Central Mgmt Server
03443             c_apc_cms_udp                  = (INT)  2160,   //  APC Central Mgmt Server
03444             c_apc_agent_tcp                = (INT)  2161,   //  APC Agent
03445             c_apc_agent_udp                = (INT)  2161,   //  APC Agent
03446             c_navisphere_tcp               = (INT)  2162,   //  Navisphere
03447             c_navisphere_udp               = (INT)  2162,   //  Navisphere
03448             c_navisphere_sec_tcp           = (INT)  2163,   //  Navisphere Secure
03449             c_navisphere_sec_udp           = (INT)  2163,   //  Navisphere Secure
03450             c_ddns_v3_tcp                  = (INT)  2164,   //  Dynamic DNS Version 3
03451             c_ddns_v3_udp                  = (INT)  2164,   //  Dynamic DNS Version 3
03452             c_x_bone_api_tcp               = (INT)  2165,   //  X-Bone API
03453             c_x_bone_api_udp               = (INT)  2165,   //  X-Bone API
03454             c_iwserver_tcp                 = (INT)  2166,   //  iwserver
03455             c_iwserver_udp                 = (INT)  2166,   //  iwserver
03456             c_raw_serial_tcp               = (INT)  2167,   //  Raw Async Serial Link
03457             c_raw_serial_udp               = (INT)  2167,   //  Raw Async Serial Link
03458             c_mc_gt_srv_tcp                = (INT)  2180,   //  Millicent Vendor Gateway Server
03459             c_mc_gt_srv_udp                = (INT)  2180,   //  Millicent Vendor Gateway Server
03460             c_eforward_tcp                 = (INT)  2181,   //  eforward
03461             c_eforward_udp                 = (INT)  2181,   //  eforward
03462             c_ici_tcp                      = (INT)  2200,   //  ICI
03463             c_ici_udp                      = (INT)  2200,   //  ICI
03464             c_ats_tcp                      = (INT)  2201,   //  Advanced Training System Program
03465             c_ats_udp                      = (INT)  2201,   //  Advanced Training System Program
03466             c_imtc_map_tcp                 = (INT)  2202,   //  Int. Multimedia Teleconferencing Cosortium
03467             c_imtc_map_udp                 = (INT)  2202,   //  Int. Multimedia Teleconferencing Cosortium
03468             c_kali_tcp                     = (INT)  2213,   //  Kali
03469             c_kali_udp                     = (INT)  2213,   //  Kali
03470             c_netiq_tcp                    = (INT)  2220,   //  NetIQ End2End
03471             c_netiq_udp                    = (INT)  2220,   //  NetIQ End2End
03472             c_rockwell_csp1_tcp            = (INT)  2221,   //  Rockwell CSP1
03473             c_rockwell_csp1_udp            = (INT)  2221,   //  Rockwell CSP1
03474             c_rockwell_csp2_tcp            = (INT)  2222,   //  Rockwell CSP2
03475             c_rockwell_csp2_udp            = (INT)  2222,   //  Rockwell CSP2
03476             c_rockwell_csp3_tcp            = (INT)  2223,   //  Rockwell CSP3
03477             c_rockwell_csp3_udp            = (INT)  2223,   //  Rockwell CSP3
03478             c_ivs_video_tcp                = (INT)  2232,   //  IVS Video default
03479             c_ivs_video_udp                = (INT)  2232,   //  IVS Video default
03480             c_infocrypt_tcp                = (INT)  2233,   //  INFOCRYPT
03481             c_infocrypt_udp                = (INT)  2233,   //  INFOCRYPT
03482             c_directplay_tcp               = (INT)  2234,   //  DirectPlay
03483             c_directplay_udp               = (INT)  2234,   //  DirectPlay
03484             c_sercomm_wlink_tcp            = (INT)  2235,   //  Sercomm-WLink
03485             c_sercomm_wlink_udp            = (INT)  2235,   //  Sercomm-WLink
03486             c_nani_tcp                     = (INT)  2236,   //  Nani
03487             c_nani_udp                     = (INT)  2236,   //  Nani
03488             c_optech_port1_lm_tcp          = (INT)  2237,   //  Optech Port1 License Manager
03489             c_optech_port1_lm_udp          = (INT)  2237,   //  Optech Port1 License Manager
03490             c_aviva_sna_tcp                = (INT)  2238,   //  AVIVA SNA SERVER
03491             c_aviva_sna_udp                = (INT)  2238,   //  AVIVA SNA SERVER
03492             c_imagequery_tcp               = (INT)  2239,   //  Image Query
03493             c_imagequery_udp               = (INT)  2239,   //  Image Query
03494             c_recipe_tcp                   = (INT)  2240,   //  RECIPe
03495             c_recipe_udp                   = (INT)  2240,   //  RECIPe
03496             c_ivsd_tcp                     = (INT)  2241,   //  IVS Daemon
03497             c_ivsd_udp                     = (INT)  2241,   //  IVS Daemon
03498             c_foliocorp_tcp                = (INT)  2242,   //  Folio Remote Server
03499             c_foliocorp_udp                = (INT)  2242,   //  Folio Remote Server
03500             c_magicom_tcp                  = (INT)  2243,   //  Magicom Protocol
03501             c_magicom_udp                  = (INT)  2243,   //  Magicom Protocol
03502             c_nmsserver_tcp                = (INT)  2244,   //  NMS Server
03503             c_nmsserver_udp                = (INT)  2244,   //  NMS Server
03504             c_hao_tcp                      = (INT)  2245,   //  HaO
03505             c_hao_udp                      = (INT)  2245,   //  HaO
03506             c_pc_mta_addrmap_tcp           = (INT)  2246,   //  PacketCable MTA Addr Map
03507             c_pc_mta_addrmap_udp           = (INT)  2246,   //  PacketCable MTA Addr Map
03508             c_ums_tcp                      = (INT)  2248,   //  User Management Service
03509             c_ums_udp                      = (INT)  2248,   //  User Management Service
03510             c_rfmp_tcp                     = (INT)  2249,   //  RISO File Manager Protocol
03511             c_rfmp_udp                     = (INT)  2249,   //  RISO File Manager Protocol
03512             c_remote_collab_tcp            = (INT)  2250,   //  remote-collab
03513             c_remote_collab_udp            = (INT)  2250,   //  remote-collab
03514             c_dif_port_tcp                 = (INT)  2251,   //  Distributed Framework Port
03515             c_dif_port_udp                 = (INT)  2251,   //  Distributed Framework Port
03516             c_njenet_ssl_tcp               = (INT)  2252,   //  NJENET using SSL
03517             c_njenet_ssl_udp               = (INT)  2252,   //  NJENET using SSL
03518             c_dtv_chan_req_tcp             = (INT)  2253,   //  DTV Channel Request
03519             c_dtv_chan_req_udp             = (INT)  2253,   //  DTV Channel Request
03520             c_seispoc_tcp                  = (INT)  2254,   //  Seismic P.O.C. Port
03521             c_seispoc_udp                  = (INT)  2254,   //  Seismic P.O.C. Port
03522             c_vrtp_tcp                     = (INT)  2255,   //  VRTP - ViRtue Transfer Protocol
03523             c_vrtp_udp                     = (INT)  2255,   //  VRTP - ViRtue Transfer Protocol
03524             c_apc_pbeconsole_tcp           = (INT)  2260,   //  APC Console Comm Port
03525             c_apc_pbeconsole_udp           = (INT)  2260,   //  APC Console Comm Port
03526             c_xmquery_tcp                  = (INT)  2279,   //  xmquery
03527             c_xmquery_udp                  = (INT)  2279,   //  xmquery
03528             c_lnvpoller_tcp                = (INT)  2280,   //  LNVPOLLER
03529             c_lnvpoller_udp                = (INT)  2280,   //  LNVPOLLER
03530             c_lnvconsole_tcp               = (INT)  2281,   //  LNVCONSOLE
03531             c_lnvconsole_udp               = (INT)  2281,   //  LNVCONSOLE
03532             c_lnvalarm_tcp                 = (INT)  2282,   //  LNVALARM
03533             c_lnvalarm_udp                 = (INT)  2282,   //  LNVALARM
03534             c_lnvstatus_tcp                = (INT)  2283,   //  LNVSTATUS
03535             c_lnvstatus_udp                = (INT)  2283,   //  LNVSTATUS
03536             c_lnvmaps_tcp                  = (INT)  2284,   //  LNVMAPS
03537             c_lnvmaps_udp                  = (INT)  2284,   //  LNVMAPS
03538             c_lnvmailmon_tcp               = (INT)  2285,   //  LNVMAILMON
03539             c_lnvmailmon_udp               = (INT)  2285,   //  LNVMAILMON
03540             c_nas_metering_tcp             = (INT)  2286,   //  NAS-Metering
03541             c_nas_metering_udp             = (INT)  2286,   //  NAS-Metering
03542             c_dna_tcp                      = (INT)  2287,   //  DNA
03543             c_dna_udp                      = (INT)  2287,   //  DNA
03544             c_netml_tcp                    = (INT)  2288,   //  NETML
03545             c_netml_udp                    = (INT)  2288,   //  NETML
03546             c_konshus_lm_tcp               = (INT)  2294,   //  Konshus License Manager (FLEX)
03547             c_konshus_lm_udp               = (INT)  2294,   //  Konshus License Manager (FLEX)
03548             c_advant_lm_tcp                = (INT)  2295,   //  Advant License Manager
03549             c_advant_lm_udp                = (INT)  2295,   //  Advant License Manager
03550             c_theta_lm_tcp                 = (INT)  2296,   //  Theta License Manager (Rainbow)
03551             c_theta_lm_udp                 = (INT)  2296,   //  Theta License Manager (Rainbow)
03552             c_d2k_datamover1_tcp           = (INT)  2297,   //  D2K DataMover 1
03553             c_d2k_datamover1_udp           = (INT)  2297,   //  D2K DataMover 1
03554             c_d2k_datamover2_tcp           = (INT)  2298,   //  D2K DataMover 2
03555             c_d2k_datamover2_udp           = (INT)  2298,   //  D2K DataMover 2
03556             c_pc_telecommute_tcp           = (INT)  2299,   //  PC Telecommute
03557             c_pc_telecommute_udp           = (INT)  2299,   //  PC Telecommute
03558             c_cvmmon_tcp                   = (INT)  2300,   //  CVMMON
03559             c_cvmmon_udp                   = (INT)  2300,   //  CVMMON
03560             c_cpq_wbem_tcp                 = (INT)  2301,   //  Compaq HTTP
03561             c_cpq_wbem_udp                 = (INT)  2301,   //  Compaq HTTP
03562             c_binderysupport_tcp           = (INT)  2302,   //  Bindery Support
03563             c_binderysupport_udp           = (INT)  2302,   //  Bindery Support
03564             c_proxy_gateway_tcp            = (INT)  2303,   //  Proxy Gateway
03565             c_proxy_gateway_udp            = (INT)  2303,   //  Proxy Gateway
03566             c_attachmate_uts_tcp           = (INT)  2304,   //  Attachmate UTS
03567             c_attachmate_uts_udp           = (INT)  2304,   //  Attachmate UTS
03568             c_mt_scaleserver_tcp           = (INT)  2305,   //  MT ScaleServer
03569             c_mt_scaleserver_udp           = (INT)  2305,   //  MT ScaleServer
03570             c_tappi_boxnet_tcp             = (INT)  2306,   //  TAPPI BoxNet
03571             c_tappi_boxnet_udp             = (INT)  2306,   //  TAPPI BoxNet
03572             c_pehelp_tcp                   = (INT)  2307,   //  pehelp
03573             c_pehelp_udp                   = (INT)  2307,   //  pehelp
03574             c_sdhelp_tcp                   = (INT)  2308,   //  sdhelp
03575             c_sdhelp_udp                   = (INT)  2308,   //  sdhelp
03576             c_sdserver_tcp                 = (INT)  2309,   //  SD Server
03577             c_sdserver_udp                 = (INT)  2309,   //  SD Server
03578             c_sdclient_tcp                 = (INT)  2310,   //  SD Client
03579             c_sdclient_udp                 = (INT)  2310,   //  SD Client
03580             c_messageservice_tcp           = (INT)  2311,   //  Message Service
03581             c_messageservice_udp           = (INT)  2311,   //  Message Service
03582             c_iapp_tcp                     = (INT)  2313,   //  IAPP (Inter Access Point Protocol)
03583             c_iapp_udp                     = (INT)  2313,   //  IAPP (Inter Access Point Protocol)
03584             c_cr_websystems_tcp            = (INT)  2314,   //  CR WebSystems
03585             c_cr_websystems_udp            = (INT)  2314,   //  CR WebSystems
03586             c_precise_sft_tcp              = (INT)  2315,   //  Precise Sft.
03587             c_precise_sft_udp              = (INT)  2315,   //  Precise Sft.
03588             c_sent_lm_tcp                  = (INT)  2316,   //  SENT License Manager
03589             c_sent_lm_udp                  = (INT)  2316,   //  SENT License Manager
03590             c_attachmate_g32_tcp           = (INT)  2317,   //  Attachmate G32
03591             c_attachmate_g32_udp           = (INT)  2317,   //  Attachmate G32
03592             c_cadencecontrol_tcp           = (INT)  2318,   //  Cadence Control
03593             c_cadencecontrol_udp           = (INT)  2318,   //  Cadence Control
03594             c_infolibria_tcp               = (INT)  2319,   //  InfoLibria
03595             c_infolibria_udp               = (INT)  2319,   //  InfoLibria
03596             c_siebel_ns_tcp                = (INT)  2320,   //  Siebel NS
03597             c_siebel_ns_udp                = (INT)  2320,   //  Siebel NS
03598             c_rdlap_tcp                    = (INT)  2321,   //  RDLAP
03599             c_rdlap_udp                    = (INT)  2321,   //  RDLAP
03600             c_ofsd_tcp                     = (INT)  2322,   //  ofsd
03601             c_ofsd_udp                     = (INT)  2322,   //  ofsd
03602             c_3d_nfsd_tcp                  = (INT)  2323,   //  3d-nfsd
03603             c_3d_nfsd_udp                  = (INT)  2323,   //  3d-nfsd
03604             c_cosmocall_tcp                = (INT)  2324,   //  Cosmocall
03605             c_cosmocall_udp                = (INT)  2324,   //  Cosmocall
03606             c_designspace_lm_tcp           = (INT)  2325,   //  Design Space License Management
03607             c_designspace_lm_udp           = (INT)  2325,   //  Design Space License Management
03608             c_idcp_tcp                     = (INT)  2326,   //  IDCP
03609             c_idcp_udp                     = (INT)  2326,   //  IDCP
03610             c_xingcsm_tcp                  = (INT)  2327,   //  xingcsm
03611             c_xingcsm_udp                  = (INT)  2327,   //  xingcsm
03612             c_netrix_sftm_tcp              = (INT)  2328,   //  Netrix SFTM
03613             c_netrix_sftm_udp              = (INT)  2328,   //  Netrix SFTM
03614             c_nvd_tcp                      = (INT)  2329,   //  NVD
03615             c_nvd_udp                      = (INT)  2329,   //  NVD
03616             c_tscchat_tcp                  = (INT)  2330,   //  TSCCHAT
03617             c_tscchat_udp                  = (INT)  2330,   //  TSCCHAT
03618             c_agentview_tcp                = (INT)  2331,   //  AGENTVIEW
03619             c_agentview_udp                = (INT)  2331,   //  AGENTVIEW
03620             c_rcc_host_tcp                 = (INT)  2332,   //  RCC Host
03621             c_rcc_host_udp                 = (INT)  2332,   //  RCC Host
03622             c_snapp_tcp                    = (INT)  2333,   //  SNAPP
03623             c_snapp_udp                    = (INT)  2333,   //  SNAPP
03624             c_ace_client_tcp               = (INT)  2334,   //  ACE Client Auth
03625             c_ace_client_udp               = (INT)  2334,   //  ACE Client Auth
03626             c_ace_proxy_tcp                = (INT)  2335,   //  ACE Proxy
03627             c_ace_proxy_udp                = (INT)  2335,   //  ACE Proxy
03628             c_appleugcontrol_tcp           = (INT)  2336,   //  Apple UG Control
03629             c_appleugcontrol_udp           = (INT)  2336,   //  Apple UG Control
03630             c_ideesrv_tcp                  = (INT)  2337,   //  ideesrv
03631             c_ideesrv_udp                  = (INT)  2337,   //  ideesrv
03632             c_norton_lambert_tcp           = (INT)  2338,   //  Norton Lambert
03633             c_norton_lambert_udp           = (INT)  2338,   //  Norton Lambert
03634             c_3com_webview_tcp             = (INT)  2339,   //  3Com WebView
03635             c_3com_webview_udp             = (INT)  2339,   //  3Com WebView
03636             c_xiostatus_tcp                = (INT)  2341,   //  XIO Status
03637             c_xiostatus_udp                = (INT)  2341,   //  XIO Status
03638             c_manage_exec_tcp              = (INT)  2342,   //  Seagate Manage Exec
03639             c_manage_exec_udp              = (INT)  2342,   //  Seagate Manage Exec
03640             c_nati_logos_tcp               = (INT)  2343,   //  nati logos
03641             c_nati_logos_udp               = (INT)  2343,   //  nati logos
03642             c_fcmsys_tcp                   = (INT)  2344,   //  fcmsys
03643             c_fcmsys_udp                   = (INT)  2344,   //  fcmsys
03644             c_dbm_tcp                      = (INT)  2345,   //  dbm
03645             c_dbm_udp                      = (INT)  2345,   //  dbm
03646             c_psbserver_tcp                = (INT)  2350,   //  psbserver
03647             c_psbserver_udp                = (INT)  2350,   //  psbserver
03648             c_psrserver_tcp                = (INT)  2351,   //  psrserver
03649             c_psrserver_udp                = (INT)  2351,   //  psrserver
03650             c_pslserver_tcp                = (INT)  2352,   //  pslserver
03651             c_pslserver_udp                = (INT)  2352,   //  pslserver
03652             c_pspserver_tcp                = (INT)  2353,   //  pspserver
03653             c_pspserver_udp                = (INT)  2353,   //  pspserver
03654             c_psprserver_tcp               = (INT)  2354,   //  psprserver
03655             c_psprserver_udp               = (INT)  2354,   //  psprserver
03656             c_psdbserver_tcp               = (INT)  2355,   //  psdbserver
03657             c_psdbserver_udp               = (INT)  2355,   //  psdbserver
03658             c_gxtelmd_tcp                  = (INT)  2356,   //  GXT License Managemant
03659             c_gxtelmd_udp                  = (INT)  2356,   //  GXT License Managemant
03660             c_unihub_server_tcp            = (INT)  2357,   //  UniHub Server
03661             c_unihub_server_udp            = (INT)  2357,   //  UniHub Server
03662             c_futrix_tcp                   = (INT)  2358,   //  Futrix
03663             c_futrix_udp                   = (INT)  2358,   //  Futrix
03664             c_flukeserver_tcp              = (INT)  2359,   //  FlukeServer
03665             c_flukeserver_udp              = (INT)  2359,   //  FlukeServer
03666             c_nexstorindltd_tcp            = (INT)  2360,   //  NexstorIndLtd
03667             c_nexstorindltd_udp            = (INT)  2360,   //  NexstorIndLtd
03668             c_tl1_tcp                      = (INT)  2361,   //  TL1
03669             c_tl1_udp                      = (INT)  2361,   //  TL1
03670             c_digiman_tcp                  = (INT)  2362,   //  digiman
03671             c_digiman_udp                  = (INT)  2362,   //  digiman
03672             c_mediacntrlnfsd_tcp           = (INT)  2363,   //  Media Central NFSD
03673             c_mediacntrlnfsd_udp           = (INT)  2363,   //  Media Central NFSD
03674             c_oi_2000_tcp                  = (INT)  2364,   //  OI-2000
03675             c_oi_2000_udp                  = (INT)  2364,   //  OI-2000
03676             c_dbref_tcp                    = (INT)  2365,   //  dbref
03677             c_dbref_udp                    = (INT)  2365,   //  dbref
03678             c_qip_login_tcp                = (INT)  2366,   //  qip-login
03679             c_qip_login_udp                = (INT)  2366,   //  qip-login
03680             c_service_ctrl_tcp             = (INT)  2367,   //  Service Control
03681             c_service_ctrl_udp             = (INT)  2367,   //  Service Control
03682             c_opentable_tcp                = (INT)  2368,   //  OpenTable
03683             c_opentable_udp                = (INT)  2368,   //  OpenTable
03684             c_acs2000_dsp_tcp              = (INT)  2369,   //  ACS2000 DSP
03685             c_acs2000_dsp_udp              = (INT)  2369,   //  ACS2000 DSP
03686             c_l3_hbmon_tcp                 = (INT)  2370,   //  L3-HBMon
03687             c_l3_hbmon_udp                 = (INT)  2370,   //  L3-HBMon
03688             c_worldwire_tcp                = (INT)  2371,   //  Compaq WorldWire Port
03689             c_worldwire_udp                = (INT)  2371,   //  Compaq WorldWire Port
03690             c_compaq_https_tcp             = (INT)  2381,   //  Compaq HTTPS
03691             c_compaq_https_udp             = (INT)  2381,   //  Compaq HTTPS
03692             c_ms_olap3_tcp                 = (INT)  2382,   //  Microsoft OLAP
03693             c_ms_olap3_udp                 = (INT)  2382,   //  Microsoft OLAP
03694             c_ms_olap4_tcp                 = (INT)  2383,   //  Microsoft OLAP
03695             c_ms_olap4_udp                 = (INT)  2383,   //  Microsoft OLAP
03696             c_sd_request_tcp               = (INT)  2384,   //  SD-REQUEST
03697             c_sd_capacity_udp              = (INT)  2384,   //  SD-CAPACITY
03698             c_sd_data_tcp                  = (INT)  2385,   //  SD-DATA
03699             c_sd_data_udp                  = (INT)  2385,   //  SD-DATA
03700             c_virtualtape_tcp              = (INT)  2386,   //  Virtual Tape
03701             c_virtualtape_udp              = (INT)  2386,   //  Virtual Tape
03702             c_vsamredirector_tcp           = (INT)  2387,   //  VSAM Redirector
03703             c_vsamredirector_udp           = (INT)  2387,   //  VSAM Redirector
03704             c_mynahautostart_tcp           = (INT)  2388,   //  MYNAH AutoStart
03705             c_mynahautostart_udp           = (INT)  2388,   //  MYNAH AutoStart
03706             c_ovsessionmgr_tcp             = (INT)  2389,   //  OpenView Session Mgr
03707             c_ovsessionmgr_udp             = (INT)  2389,   //  OpenView Session Mgr
03708             c_rsmtp_tcp                    = (INT)  2390,   //  RSMTP
03709             c_rsmtp_udp                    = (INT)  2390,   //  RSMTP
03710             c_3com_net_mgmt_tcp            = (INT)  2391,   //  3COM Net Management
03711             c_3com_net_mgmt_udp            = (INT)  2391,   //  3COM Net Management
03712             c_tacticalauth_tcp             = (INT)  2392,   //  Tactical Auth
03713             c_tacticalauth_udp             = (INT)  2392,   //  Tactical Auth
03714             c_ms_olap1_tcp                 = (INT)  2393,   //  MS OLAP 1
03715             c_ms_olap1_udp                 = (INT)  2393,   //  MS OLAP 1
03716             c_ms_olap2_tcp                 = (INT)  2394,   //  MS OLAP 2
03717             c_ms_olap2_udp                 = (INT)  2394,   //  MS OLAP 2
03718             c_wusage_tcp                   = (INT)  2396,   //  Wusage
03719             c_wusage_udp                   = (INT)  2396,   //  Wusage
03720             c_ncl_tcp                      = (INT)  2397,   //  NCL
03721             c_ncl_udp                      = (INT)  2397,   //  NCL
03722             c_orbiter_tcp                  = (INT)  2398,   //  Orbiter
03723             c_orbiter_udp                  = (INT)  2398,   //  Orbiter
03724             c_fmpro_fdal_tcp               = (INT)  2399,   //  FileMaker, Inc. - Data Access Layer
03725             c_fmpro_fdal_udp               = (INT)  2399,   //  FileMaker, Inc. - Data Access Layer
03726             c_opequus_server_tcp           = (INT)  2400,   //  OpEquus Server
03727             c_opequus_server_udp           = (INT)  2400,   //  OpEquus Server
03728             c_cvspserver_tcp               = (INT)  2401,   //  cvspserver
03729             c_cvspserver_udp               = (INT)  2401,   //  cvspserver
03730             c_taskmaster2000_tcp           = (INT)  2402,   //  TaskMaster 2000 Server
03731             c_taskmaster2000_udp           = (INT)  2402,   //  TaskMaster 2000 Server
03732             c_taskmaster2000_1_tcp         = (INT)  2403,   //  TaskMaster 2000 Web
03733             c_taskmaster2000_1_udp         = (INT)  2403,   //  TaskMaster 2000 Web
03734             c_iec870_5_104_tcp             = (INT)  2404,   //  IEC870-5-104
03735             c_iec870_5_104_udp             = (INT)  2404,   //  IEC870-5-104
03736             c_trc_netpoll_tcp              = (INT)  2405,   //  TRC Netpoll
03737             c_trc_netpoll_udp              = (INT)  2405,   //  TRC Netpoll
03738             c_jediserver_tcp               = (INT)  2406,   //  JediServer
03739             c_jediserver_udp               = (INT)  2406,   //  JediServer
03740             c_orion_tcp                    = (INT)  2407,   //  Orion
03741             c_orion_udp                    = (INT)  2407,   //  Orion
03742             c_optimanet_tcp                = (INT)  2408,   //  OptimaNet
03743             c_optimanet_udp                = (INT)  2408,   //  OptimaNet
03744             c_sns_protocol_tcp             = (INT)  2409,   //  SNS Protocol
03745             c_sns_protocol_udp             = (INT)  2409,   //  SNS Protocol
03746             c_vrts_registry_tcp            = (INT)  2410,   //  VRTS Registry
03747             c_vrts_registry_udp            = (INT)  2410,   //  VRTS Registry
03748             c_netwave_ap_mgmt_tcp          = (INT)  2411,   //  Netwave AP Management
03749             c_netwave_ap_mgmt_udp          = (INT)  2411,   //  Netwave AP Management
03750             c_cdn_tcp                      = (INT)  2412,   //  CDN
03751             c_cdn_udp                      = (INT)  2412,   //  CDN
03752             c_orion_rmi_reg_tcp            = (INT)  2413,   //  orion-rmi-reg
03753             c_orion_rmi_reg_udp            = (INT)  2413,   //  orion-rmi-reg
03754             c_beeyond_tcp                  = (INT)  2414,   //  Beeyond
03755             c_beeyond_udp                  = (INT)  2414,   //  Beeyond
03756             c_comtest_tcp                  = (INT)  2415,   //  COMTEST
03757             c_comtest_udp                  = (INT)  2415,   //  COMTEST
03758             c_rmtserver_tcp                = (INT)  2416,   //  RMT Server
03759             c_rmtserver_udp                = (INT)  2416,   //  RMT Server
03760             c_composit_server_tcp          = (INT)  2417,   //  Composit Server
03761             c_composit_server_udp          = (INT)  2417,   //  Composit Server
03762             c_cas_tcp                      = (INT)  2418,   //  cas
03763             c_cas_udp                      = (INT)  2418,   //  cas
03764             c_attachmate_s2s_tcp           = (INT)  2419,   //  Attachmate S2S
03765             c_attachmate_s2s_udp           = (INT)  2419,   //  Attachmate S2S
03766             c_dslremote_mgmt_tcp           = (INT)  2420,   //  DSL Remote Management
03767             c_dslremote_mgmt_udp           = (INT)  2420,   //  DSL Remote Management
03768             c_g_talk_tcp                   = (INT)  2421,   //  G-Talk
03769             c_g_talk_udp                   = (INT)  2421,   //  G-Talk
03770             c_crmsbits_tcp                 = (INT)  2422,   //  CRMSBITS
03771             c_crmsbits_udp                 = (INT)  2422,   //  CRMSBITS
03772             c_rnrp_tcp                     = (INT)  2423,   //  RNRP
03773             c_rnrp_udp                     = (INT)  2423,   //  RNRP
03774             c_kofax_svr_tcp                = (INT)  2424,   //  KOFAX-SVR
03775             c_kofax_svr_udp                = (INT)  2424,   //  KOFAX-SVR
03776             c_fjitsuappmgr_tcp             = (INT)  2425,   //  Fujitsu App Manager
03777             c_fjitsuappmgr_udp             = (INT)  2425,   //  Fujitsu App Manager
03778             c_applianttcp_tcp              = (INT)  2426,   //  Appliant TCP
03779             c_appliantudp_udp              = (INT)  2426,   //  Appliant UDP
03780             c_mgcp_gateway_tcp             = (INT)  2427,   //  Media Gateway Control Protocol Gateway
03781             c_mgcp_gateway_udp             = (INT)  2427,   //  Media Gateway Control Protocol Gateway
03782             c_ott_tcp                      = (INT)  2428,   //  One Way Trip Time
03783             c_ott_udp                      = (INT)  2428,   //  One Way Trip Time
03784             c_ft_role_tcp                  = (INT)  2429,   //  FT-ROLE
03785             c_ft_role_udp                  = (INT)  2429,   //  FT-ROLE
03786             c_venus_tcp                    = (INT)  2430,   //  venus
03787             c_venus_udp                    = (INT)  2430,   //  venus
03788             c_venus_se_tcp                 = (INT)  2431,   //  venus-se
03789             c_venus_se_udp                 = (INT)  2431,   //  venus-se
03790             c_codasrv_tcp                  = (INT)  2432,   //  codasrv
03791             c_codasrv_udp                  = (INT)  2432,   //  codasrv
03792             c_codasrv_se_tcp               = (INT)  2433,   //  codasrv-se
03793             c_codasrv_se_udp               = (INT)  2433,   //  codasrv-se
03794             c_pxc_epmap_tcp                = (INT)  2434,   //  pxc-epmap
03795             c_pxc_epmap_udp                = (INT)  2434,   //  pxc-epmap
03796             c_optilogic_tcp                = (INT)  2435,   //  OptiLogic
03797             c_optilogic_udp                = (INT)  2435,   //  OptiLogic
03798             c_topx_tcp                     = (INT)  2436,   //  TOP/X
03799             c_topx_udp                     = (INT)  2436,   //  TOP/X
03800             c_unicontrol_tcp               = (INT)  2437,   //  UniControl
03801             c_unicontrol_udp               = (INT)  2437,   //  UniControl
03802             c_msp_1_tcp                    = (INT)  2438,   //  MSP
03803             c_msp_1_udp                    = (INT)  2438,   //  MSP
03804             c_sybasedbsynch_tcp            = (INT)  2439,   //  SybaseDBSynch
03805             c_sybasedbsynch_udp            = (INT)  2439,   //  SybaseDBSynch
03806             c_spearway_tcp                 = (INT)  2440,   //  Spearway Lockers
03807             c_spearway_udp                 = (INT)  2440,   //  Spearway Lockers
03808             c_pvsw_inet_tcp                = (INT)  2441,   //  pvsw-inet
03809             c_pvsw_inet_udp                = (INT)  2441,   //  pvsw-inet
03810             c_netangel_tcp                 = (INT)  2442,   //  Netangel
03811             c_netangel_udp                 = (INT)  2442,   //  Netangel
03812             c_powerclientcsf_tcp           = (INT)  2443,   //  PowerClient Central Storage Facility
03813             c_powerclientcsf_udp           = (INT)  2443,   //  PowerClient Central Storage Facility
03814             c_btpp2sectrans_tcp            = (INT)  2444,   //  BT PP2 Sectrans
03815             c_btpp2sectrans_udp            = (INT)  2444,   //  BT PP2 Sectrans
03816             c_dtn1_tcp                     = (INT)  2445,   //  DTN1
03817             c_dtn1_udp                     = (INT)  2445,   //  DTN1
03818             c_ovwdb_tcp                    = (INT)  2447,   //  OpenView NNM daemon
03819             c_ovwdb_udp                    = (INT)  2447,   //  OpenView NNM daemon
03820             c_hpppssvr_tcp                 = (INT)  2448,   //  hpppsvr
03821             c_hpppssvr_udp                 = (INT)  2448,   //  hpppsvr
03822             c_ratl_tcp                     = (INT)  2449,   //  RATL
03823             c_ratl_udp                     = (INT)  2449,   //  RATL
03824             c_netadmin_tcp                 = (INT)  2450,   //  netadmin
03825             c_netadmin_udp                 = (INT)  2450,   //  netadmin
03826             c_netchat_tcp                  = (INT)  2451,   //  netchat
03827             c_netchat_udp                  = (INT)  2451,   //  netchat
03828             c_snifferclient_tcp            = (INT)  2452,   //  SnifferClient
03829             c_snifferclient_udp            = (INT)  2452,   //  SnifferClient
03830             c_madge_om_tcp                 = (INT)  2453,   //  madge-om
03831             c_madge_om_udp                 = (INT)  2453,   //  madge-om
03832             c_indx_dds_tcp                 = (INT)  2454,   //  IndX-DDS
03833             c_indx_dds_udp                 = (INT)  2454,   //  IndX-DDS
03834             c_wago_io_system_tcp           = (INT)  2455,   //  WAGO-IO-SYSTEM
03835             c_wago_io_system_udp           = (INT)  2455,   //  WAGO-IO-SYSTEM
03836             c_altav_remmgt_tcp             = (INT)  2456,   //  altav-remmgt
03837             c_altav_remmgt_udp             = (INT)  2456,   //  altav-remmgt
03838             c_rapido_ip_tcp                = (INT)  2457,   //  Rapido_IP
03839             c_rapido_ip_udp                = (INT)  2457,   //  Rapido_IP
03840             c_griffin_tcp                  = (INT)  2458,   //  griffin
03841             c_griffin_udp                  = (INT)  2458,   //  griffin
03842             c_community_tcp                = (INT)  2459,   //  Community
03843             c_community_udp                = (INT)  2459,   //  Community
03844             c_ms_theater_tcp               = (INT)  2460,   //  ms-theater
03845             c_ms_theater_udp               = (INT)  2460,   //  ms-theater
03846             c_qadmifoper_tcp               = (INT)  2461,   //  qadmifoper
03847             c_qadmifoper_udp               = (INT)  2461,   //  qadmifoper
03848             c_qadmifevent_tcp              = (INT)  2462,   //  qadmifevent
03849             c_qadmifevent_udp              = (INT)  2462,   //  qadmifevent
03850             c_symbios_raid_tcp             = (INT)  2463,   //  Symbios Raid
03851             c_symbios_raid_udp             = (INT)  2463,   //  Symbios Raid
03852             c_direcpc_si_tcp               = (INT)  2464,   //  DirecPC SI
03853             c_direcpc_si_udp               = (INT)  2464,   //  DirecPC SI
03854             c_lbm_tcp                      = (INT)  2465,   //  Load Balance Management
03855             c_lbm_udp                      = (INT)  2465,   //  Load Balance Management
03856             c_lbf_tcp                      = (INT)  2466,   //  Load Balance Forwarding
03857             c_lbf_udp                      = (INT)  2466,   //  Load Balance Forwarding
03858             c_high_criteria_tcp            = (INT)  2467,   //  High Criteria
03859             c_high_criteria_udp            = (INT)  2467,   //  High Criteria
03860             c_qip_msgd_tcp                 = (INT)  2468,   //  qip_msgd
03861             c_qip_msgd_udp                 = (INT)  2468,   //  qip_msgd
03862             c_mti_tcs_comm_tcp             = (INT)  2469,   //  MTI-TCS-COMM
03863             c_mti_tcs_comm_udp             = (INT)  2469,   //  MTI-TCS-COMM
03864             c_taskman_port_tcp             = (INT)  2470,   //  taskman port
03865             c_taskman_port_udp             = (INT)  2470,   //  taskman port
03866             c_seaodbc_tcp                  = (INT)  2471,   //  SeaODBC
03867             c_seaodbc_udp                  = (INT)  2471,   //  SeaODBC
03868             c_c3_tcp                       = (INT)  2472,   //  C3
03869             c_c3_udp                       = (INT)  2472,   //  C3
03870             c_aker_cdp_tcp                 = (INT)  2473,   //  Aker-cdp
03871             c_aker_cdp_udp                 = (INT)  2473,   //  Aker-cdp
03872             c_vitalanalysis_tcp            = (INT)  2474,   //  Vital Analysis
03873             c_vitalanalysis_udp            = (INT)  2474,   //  Vital Analysis
03874             c_ace_server_tcp               = (INT)  2475,   //  ACE Server
03875             c_ace_server_udp               = (INT)  2475,   //  ACE Server
03876             c_ace_svr_prop_tcp             = (INT)  2476,   //  ACE Server Propagation
03877             c_ace_svr_prop_udp             = (INT)  2476,   //  ACE Server Propagation
03878             c_ssm_cvs_tcp                  = (INT)  2477,   //  SecurSight Certificate Valifation Service
03879             c_ssm_cvs_udp                  = (INT)  2477,   //  SecurSight Certificate Valifation Service
03880             c_ssm_cssps_tcp                = (INT)  2478,   //  SecurSight Authentication Server (SSL)
03881             c_ssm_cssps_udp                = (INT)  2478,   //  SecurSight Authentication Server (SSL)
03882             c_ssm_els_tcp                  = (INT)  2479,   //  SecurSight Event Logging Server (SSL)
03883             c_ssm_els_udp                  = (INT)  2479,   //  SecurSight Event Logging Server (SSL)
03884             c_lingwood_tcp                 = (INT)  2480,   //  Lingwood's Detail
03885             c_lingwood_udp                 = (INT)  2480,   //  Lingwood's Detail
03886             c_giop_tcp                     = (INT)  2481,   //  Oracle GIOP
03887             c_giop_udp                     = (INT)  2481,   //  Oracle GIOP
03888             c_giop_ssl_tcp                 = (INT)  2482,   //  Oracle GIOP SSL
03889             c_giop_ssl_udp                 = (INT)  2482,   //  Oracle GIOP SSL
03890             c_ttc_tcp                      = (INT)  2483,   //  Oracle TTC
03891             c_ttc_udp                      = (INT)  2483,   //  Oracle TTC
03892             c_ttc_ssl_tcp                  = (INT)  2484,   //  Oracle TTC SSL
03893             c_ttc_ssl_udp                  = (INT)  2484,   //  Oracle TTC SSL
03894             c_netobjects1_tcp              = (INT)  2485,   //  Net Objects1
03895             c_netobjects1_udp              = (INT)  2485,   //  Net Objects1
03896             c_netobjects2_tcp              = (INT)  2486,   //  Net Objects2
03897             c_netobjects2_udp              = (INT)  2486,   //  Net Objects2
03898             c_pns_tcp                      = (INT)  2487,   //  Policy Notice Service
03899             c_pns_udp                      = (INT)  2487,   //  Policy Notice Service
03900             c_moy_corp_tcp                 = (INT)  2488,   //  Moy Corporation
03901             c_moy_corp_udp                 = (INT)  2488,   //  Moy Corporation
03902             c_tsilb_tcp                    = (INT)  2489,   //  TSILB
03903             c_tsilb_udp                    = (INT)  2489,   //  TSILB
03904             c_qip_qdhcp_tcp                = (INT)  2490,   //  qip_qdhcp
03905             c_qip_qdhcp_udp                = (INT)  2490,   //  qip_qdhcp
03906             c_conclave_cpp_tcp             = (INT)  2491,   //  Conclave CPP
03907             c_conclave_cpp_udp             = (INT)  2491,   //  Conclave CPP
03908             c_groove_tcp                   = (INT)  2492,   //  GROOVE
03909             c_groove_udp                   = (INT)  2492,   //  GROOVE
03910             c_talarian_mqs_tcp             = (INT)  2493,   //  Talarian MQS
03911             c_talarian_mqs_udp             = (INT)  2493,   //  Talarian MQS
03912             c_bmc_ar_tcp                   = (INT)  2494,   //  BMC AR
03913             c_bmc_ar_udp                   = (INT)  2494,   //  BMC AR
03914             c_fast_rem_serv_tcp            = (INT)  2495,   //  Fast Remote Services
03915             c_fast_rem_serv_udp            = (INT)  2495,   //  Fast Remote Services
03916             c_dirgis_tcp                   = (INT)  2496,   //  DIRGIS
03917             c_dirgis_udp                   = (INT)  2496,   //  DIRGIS
03918             c_quaddb_tcp                   = (INT)  2497,   //  Quad DB
03919             c_quaddb_udp                   = (INT)  2497,   //  Quad DB
03920             c_odn_castraq_tcp              = (INT)  2498,   //  ODN-CasTraq
03921             c_odn_castraq_udp              = (INT)  2498,   //  ODN-CasTraq
03922             c_unicontrol_1_tcp             = (INT)  2499,   //  UniControl
03923             c_unicontrol_1_udp             = (INT)  2499,   //  UniControl
03924             c_rtsserv_tcp                  = (INT)  2500,   //  Resource Tracking system server
03925             c_rtsserv_udp                  = (INT)  2500,   //  Resource Tracking system server
03926             c_rtsclient_tcp                = (INT)  2501,   //  Resource Tracking system client
03927             c_rtsclient_udp                = (INT)  2501,   //  Resource Tracking system client
03928             c_kentrox_prot_tcp             = (INT)  2502,   //  Kentrox Protocol
03929             c_kentrox_prot_udp             = (INT)  2502,   //  Kentrox Protocol
03930             c_nms_dpnss_tcp                = (INT)  2503,   //  NMS-DPNSS
03931             c_nms_dpnss_udp                = (INT)  2503,   //  NMS-DPNSS
03932             c_wlbs_tcp                     = (INT)  2504,   //  WLBS
03933             c_wlbs_udp                     = (INT)  2504,   //  WLBS
03934             c_torque_traffic_tcp           = (INT)  2505,   //  torque-traffic
03935             c_torque_traffic_udp           = (INT)  2505,   //  torque-traffic
03936             c_jbroker_tcp                  = (INT)  2506,   //  jbroker
03937             c_jbroker_udp                  = (INT)  2506,   //  jbroker
03938             c_spock_tcp                    = (INT)  2507,   //  spock
03939             c_spock_udp                    = (INT)  2507,   //  spock
03940             c_jdatastore_tcp               = (INT)  2508,   //  JDataStore
03941             c_jdatastore_udp               = (INT)  2508,   //  JDataStore
03942             c_fjmpss_tcp                   = (INT)  2509,   //  fjmpss
03943             c_fjmpss_udp                   = (INT)  2509,   //  fjmpss
03944             c_fjappmgrbulk_tcp             = (INT)  2510,   //  fjappmgrbulk
03945             c_fjappmgrbulk_udp             = (INT)  2510,   //  fjappmgrbulk
03946             c_metastorm_tcp                = (INT)  2511,   //  Metastorm
03947             c_metastorm_udp                = (INT)  2511,   //  Metastorm
03948             c_citrixima_tcp                = (INT)  2512,   //  Citrix IMA
03949             c_citrixima_udp                = (INT)  2512,   //  Citrix IMA
03950             c_citrixadmin_tcp              = (INT)  2513,   //  Citrix ADMIN
03951             c_citrixadmin_udp              = (INT)  2513,   //  Citrix ADMIN
03952             c_facsys_ntp_tcp               = (INT)  2514,   //  Facsys NTP
03953             c_facsys_ntp_udp               = (INT)  2514,   //  Facsys NTP
03954             c_facsys_router_tcp            = (INT)  2515,   //  Facsys Router
03955             c_facsys_router_udp            = (INT)  2515,   //  Facsys Router
03956             c_maincontrol_tcp              = (INT)  2516,   //  Main Control
03957             c_maincontrol_udp              = (INT)  2516,   //  Main Control
03958             c_call_sig_trans_tcp           = (INT)  2517,   //  H.323 Annex E call signaling transport
03959             c_call_sig_trans_udp           = (INT)  2517,   //  H.323 Annex E call signaling transport
03960             c_willy_tcp                    = (INT)  2518,   //  Willy
03961             c_willy_udp                    = (INT)  2518,   //  Willy
03962             c_globmsgsvc_tcp               = (INT)  2519,   //  globmsgsvc
03963             c_globmsgsvc_udp               = (INT)  2519,   //  globmsgsvc
03964             c_pvsw_tcp                     = (INT)  2520,   //  pvsw
03965             c_pvsw_udp                     = (INT)  2520,   //  pvsw
03966             c_adaptecmgr_tcp               = (INT)  2521,   //  Adaptec Manager
03967             c_adaptecmgr_udp               = (INT)  2521,   //  Adaptec Manager
03968             c_windb_tcp                    = (INT)  2522,   //  WinDb
03969             c_windb_udp                    = (INT)  2522,   //  WinDb
03970             c_qke_llc_v3_tcp               = (INT)  2523,   //  Qke LLC V.3
03971             c_qke_llc_v3_udp               = (INT)  2523,   //  Qke LLC V.3
03972             c_optiwave_lm_tcp              = (INT)  2524,   //  Optiwave License Management
03973             c_optiwave_lm_udp              = (INT)  2524,   //  Optiwave License Management
03974             c_ms_v_worlds_tcp              = (INT)  2525,   //  MS V-Worlds
03975             c_ms_v_worlds_udp              = (INT)  2525,   //  MS V-Worlds
03976             c_ema_sent_lm_tcp              = (INT)  2526,   //  EMA License Manager
03977             c_ema_sent_lm_udp              = (INT)  2526,   //  EMA License Manager
03978             c_iqserver_tcp                 = (INT)  2527,   //  IQ Server
03979             c_iqserver_udp                 = (INT)  2527,   //  IQ Server
03980             c_utsftp_tcp                   = (INT)  2529,   //  UTS FTP
03981             c_utsftp_udp                   = (INT)  2529,   //  UTS FTP
03982             c_vrcommerce_tcp               = (INT)  2530,   //  VR Commerce
03983             c_vrcommerce_udp               = (INT)  2530,   //  VR Commerce
03984             c_ito_e_gui_tcp                = (INT)  2531,   //  ITO-E GUI
03985             c_ito_e_gui_udp                = (INT)  2531,   //  ITO-E GUI
03986             c_ovtopmd_tcp                  = (INT)  2532,   //  OVTOPMD
03987             c_ovtopmd_udp                  = (INT)  2532,   //  OVTOPMD
03988             c_snifferserver_tcp            = (INT)  2533,   //  SnifferServer
03989             c_snifferserver_udp            = (INT)  2533,   //  SnifferServer
03990             c_combox_web_acc_tcp           = (INT)  2534,   //  Combox Web Access
03991             c_combox_web_acc_udp           = (INT)  2534,   //  Combox Web Access
03992             c_madcap_tcp                   = (INT)  2535,   //  MADCAP
03993             c_madcap_udp                   = (INT)  2535,   //  MADCAP
03994             c_btpp2audctr1_tcp             = (INT)  2536,   //  btpp2audctr1
03995             c_btpp2audctr1_udp             = (INT)  2536,   //  btpp2audctr1
03996             c_upgrade_tcp                  = (INT)  2537,   //  Upgrade Protocol
03997             c_upgrade_udp                  = (INT)  2537,   //  Upgrade Protocol
03998             c_vnwk_prapi_tcp               = (INT)  2538,   //  vnwk-prapi
03999             c_vnwk_prapi_udp               = (INT)  2538,   //  vnwk-prapi
04000             c_vsiadmin_tcp                 = (INT)  2539,   //  VSI Admin
04001             c_vsiadmin_udp                 = (INT)  2539,   //  VSI Admin
04002             c_lonworks_tcp                 = (INT)  2540,   //  LonWorks
04003             c_lonworks_udp                 = (INT)  2540,   //  LonWorks
04004             c_lonworks2_tcp                = (INT)  2541,   //  LonWorks2
04005             c_lonworks2_udp                = (INT)  2541,   //  LonWorks2
04006             c_davinci_tcp                  = (INT)  2542,   //  daVinci
04007             c_davinci_udp                  = (INT)  2542,   //  daVinci
04008             c_reftek_tcp                   = (INT)  2543,   //  REFTEK
04009             c_reftek_udp                   = (INT)  2543,   //  REFTEK
04010             c_novell_zen_tcp               = (INT)  2544,   //  Novell ZEN
04011             c_novell_zen_udp               = (INT)  2544,   //  Novell ZEN
04012             c_sis_emt_tcp                  = (INT)  2545,   //  sis-emt
04013             c_sis_emt_udp                  = (INT)  2545,   //  sis-emt
04014             c_vytalvaultbrtp_tcp           = (INT)  2546,   //  vytalvaultbrtp
04015             c_vytalvaultbrtp_udp           = (INT)  2546,   //  vytalvaultbrtp
04016             c_vytalvaultvsmp_tcp           = (INT)  2547,   //  vytalvaultvsmp
04017             c_vytalvaultvsmp_udp           = (INT)  2547,   //  vytalvaultvsmp
04018             c_vytalvaultpipe_tcp           = (INT)  2548,   //  vytalvaultpipe
04019             c_vytalvaultpipe_udp           = (INT)  2548,   //  vytalvaultpipe
04020             c_ipass_tcp                    = (INT)  2549,   //  IPASS
04021             c_ipass_udp                    = (INT)  2549,   //  IPASS
04022             c_ads_tcp                      = (INT)  2550,   //  ADS
04023             c_ads_udp                      = (INT)  2550,   //  ADS
04024             c_isg_uda_server_tcp           = (INT)  2551,   //  ISG UDA Server
04025             c_isg_uda_server_udp           = (INT)  2551,   //  ISG UDA Server
04026             c_call_logging_tcp             = (INT)  2552,   //  Call Logging
04027             c_call_logging_udp             = (INT)  2552,   //  Call Logging
04028             c_efidiningport_tcp            = (INT)  2553,   //  efidiningport
04029             c_efidiningport_udp            = (INT)  2553,   //  efidiningport
04030             c_vcnet_link_v10_tcp           = (INT)  2554,   //  VCnet-Link v10
04031             c_vcnet_link_v10_udp           = (INT)  2554,   //  VCnet-Link v10
04032             c_compaq_wcp_tcp               = (INT)  2555,   //  Compaq WCP
04033             c_compaq_wcp_udp               = (INT)  2555,   //  Compaq WCP
04034             c_nicetec_nmsvc_tcp            = (INT)  2556,   //  nicetec-nmsvc
04035             c_nicetec_nmsvc_udp            = (INT)  2556,   //  nicetec-nmsvc
04036             c_nicetec_mgmt_tcp             = (INT)  2557,   //  nicetec-mgmt
04037             c_nicetec_mgmt_udp             = (INT)  2557,   //  nicetec-mgmt
04038             c_pclemultimedia_tcp           = (INT)  2558,   //  PCLE Multi Media
04039             c_pclemultimedia_udp           = (INT)  2558,   //  PCLE Multi Media
04040             c_lstp_tcp                     = (INT)  2559,   //  LSTP
04041             c_lstp_udp                     = (INT)  2559,   //  LSTP
04042             c_labrat_tcp                   = (INT)  2560,   //  labrat
04043             c_labrat_udp                   = (INT)  2560,   //  labrat
04044             c_mosaixcc_tcp                 = (INT)  2561,   //  MosaixCC
04045             c_mosaixcc_udp                 = (INT)  2561,   //  MosaixCC
04046             c_delibo_tcp                   = (INT)  2562,   //  Delibo
04047             c_delibo_udp                   = (INT)  2562,   //  Delibo
04048             c_cti_redwood_tcp              = (INT)  2563,   //  CTI Redwood
04049             c_cti_redwood_udp              = (INT)  2563,   //  CTI Redwood
04050             c_hp_3000_telnet_tcp           = (INT)  2564,   //  HP 3000 NS/VT block mode telnet
04051             c_coord_svr_tcp                = (INT)  2565,   //  Coordinator Server
04052             c_coord_svr_udp                = (INT)  2565,   //  Coordinator Server
04053             c_pcs_pcw_tcp                  = (INT)  2566,   //  pcs-pcw
04054             c_pcs_pcw_udp                  = (INT)  2566,   //  pcs-pcw
04055             c_clp_tcp                      = (INT)  2567,   //  Cisco Line Protocol
04056             c_clp_udp                      = (INT)  2567,   //  Cisco Line Protocol
04057             c_spamtrap_tcp                 = (INT)  2568,   //  SPAM TRAP
04058             c_spamtrap_udp                 = (INT)  2568,   //  SPAM TRAP
04059             c_sonuscallsig_tcp             = (INT)  2569,   //  Sonus Call Signal
04060             c_sonuscallsig_udp             = (INT)  2569,   //  Sonus Call Signal
04061             c_hs_port_tcp                  = (INT)  2570,   //  HS Port
04062             c_hs_port_udp                  = (INT)  2570,   //  HS Port
04063             c_cecsvc_tcp                   = (INT)  2571,   //  CECSVC
04064             c_cecsvc_udp                   = (INT)  2571,   //  CECSVC
04065             c_ibp_tcp                      = (INT)  2572,   //  IBP
04066             c_ibp_udp                      = (INT)  2572,   //  IBP
04067             c_trustestablish_tcp           = (INT)  2573,   //  Trust Establish
04068             c_trustestablish_udp           = (INT)  2573,   //  Trust Establish
04069             c_blockade_bpsp_tcp            = (INT)  2574,   //  Blockade BPSP
04070             c_blockade_bpsp_udp            = (INT)  2574,   //  Blockade BPSP
04071             c_hl7_tcp                      = (INT)  2575,   //  HL7
04072             c_hl7_udp                      = (INT)  2575,   //  HL7
04073             c_tclprodebugger_tcp           = (INT)  2576,   //  TCL Pro Debugger
04074             c_tclprodebugger_udp           = (INT)  2576,   //  TCL Pro Debugger
04075             c_scipticslsrvr_tcp            = (INT)  2577,   //  Scriptics Lsrvr
04076             c_scipticslsrvr_udp            = (INT)  2577,   //  Scriptics Lsrvr
04077             c_rvs_isdn_dcp_tcp             = (INT)  2578,   //  RVS ISDN DCP
04078             c_rvs_isdn_dcp_udp             = (INT)  2578,   //  RVS ISDN DCP
04079             c_mpfoncl_tcp                  = (INT)  2579,   //  mpfoncl
04080             c_mpfoncl_udp                  = (INT)  2579,   //  mpfoncl
04081             c_tributary_tcp                = (INT)  2580,   //  Tributary
04082             c_tributary_udp                = (INT)  2580,   //  Tributary
04083             c_argis_te_tcp                 = (INT)  2581,   //  ARGIS TE
04084             c_argis_te_udp                 = (INT)  2581,   //  ARGIS TE
04085             c_argis_ds_tcp                 = (INT)  2582,   //  ARGIS DS
04086             c_argis_ds_udp                 = (INT)  2582,   //  ARGIS DS
04087             c_mon_tcp                      = (INT)  2583,   //  MON
04088             c_mon_udp                      = (INT)  2583,   //  MON
04089             c_cyaserv_tcp                  = (INT)  2584,   //  cyaserv
04090             c_cyaserv_udp                  = (INT)  2584,   //  cyaserv
04091             c_netx_server_tcp              = (INT)  2585,   //  NETX Server
04092             c_netx_server_udp              = (INT)  2585,   //  NETX Server
04093             c_netx_agent_tcp               = (INT)  2586,   //  NETX Agent
04094             c_netx_agent_udp               = (INT)  2586,   //  NETX Agent
04095             c_masc_tcp                     = (INT)  2587,   //  MASC
04096             c_masc_udp                     = (INT)  2587,   //  MASC
04097             c_privilege_tcp                = (INT)  2588,   //  Privilege
04098             c_privilege_udp                = (INT)  2588,   //  Privilege
04099             c_quartus_tcl_tcp              = (INT)  2589,   //  quartus tcl
04100             c_quartus_tcl_udp              = (INT)  2589,   //  quartus tcl
04101             c_idotdist_tcp                 = (INT)  2590,   //  idotdist
04102             c_idotdist_udp                 = (INT)  2590,   //  idotdist
04103             c_maytagshuffle_tcp            = (INT)  2591,   //  Maytag Shuffle
04104             c_maytagshuffle_udp            = (INT)  2591,   //  Maytag Shuffle
04105             c_netrek_tcp                   = (INT)  2592,   //  netrek
04106             c_netrek_udp                   = (INT)  2592,   //  netrek
04107             c_mns_mail_tcp                 = (INT)  2593,   //  MNS Mail Notice Service
04108             c_mns_mail_udp                 = (INT)  2593,   //  MNS Mail Notice Service
04109             c_dts_tcp                      = (INT)  2594,   //  Data Base Server
04110             c_dts_udp                      = (INT)  2594,   //  Data Base Server
04111             c_worldfusion1_tcp             = (INT)  2595,   //  World Fusion 1
04112             c_worldfusion1_udp             = (INT)  2595,   //  World Fusion 1
04113             c_worldfusion2_tcp             = (INT)  2596,   //  World Fusion 2
04114             c_worldfusion2_udp             = (INT)  2596,   //  World Fusion 2
04115             c_homesteadglory_tcp           = (INT)  2597,   //  Homestead Glory
04116             c_homesteadglory_udp           = (INT)  2597,   //  Homestead Glory
04117             c_citriximaclient_tcp          = (INT)  2598,   //  Citrix MA Client
04118             c_citriximaclient_udp          = (INT)  2598,   //  Citrix MA Client
04119             c_meridiandata_tcp             = (INT)  2599,   //  Meridian Data
04120             c_meridiandata_udp             = (INT)  2599,   //  Meridian Data
04121             c_hpstgmgr_tcp                 = (INT)  2600,   //  HPSTGMGR
04122             c_hpstgmgr_udp                 = (INT)  2600,   //  HPSTGMGR
04123             c_discp_client_tcp             = (INT)  2601,   //  discp client
04124             c_discp_client_udp             = (INT)  2601,   //  discp client
04125             c_discp_server_tcp             = (INT)  2602,   //  discp server
04126             c_discp_server_udp             = (INT)  2602,   //  discp server
04127             c_servicemeter_tcp             = (INT)  2603,   //  Service Meter
04128             c_servicemeter_udp             = (INT)  2603,   //  Service Meter
04129             c_nsc_ccs_tcp                  = (INT)  2604,   //  NSC CCS
04130             c_nsc_ccs_udp                  = (INT)  2604,   //  NSC CCS
04131             c_nsc_posa_tcp                 = (INT)  2605,   //  NSC POSA
04132             c_nsc_posa_udp                 = (INT)  2605,   //  NSC POSA
04133             c_netmon_tcp                   = (INT)  2606,   //  Dell Netmon
04134             c_netmon_udp                   = (INT)  2606,   //  Dell Netmon
04135             c_connection_tcp               = (INT)  2607,   //  Dell Connection
04136             c_connection_udp               = (INT)  2607,   //  Dell Connection
04137             c_wag_service_tcp              = (INT)  2608,   //  Wag Service
04138             c_wag_service_udp              = (INT)  2608,   //  Wag Service
04139             c_system_monitor_tcp           = (INT)  2609,   //  System Monitor
04140             c_system_monitor_udp           = (INT)  2609,   //  System Monitor
04141             c_versa_tek_tcp                = (INT)  2610,   //  VersaTek
04142             c_versa_tek_udp                = (INT)  2610,   //  VersaTek
04143             c_lionhead_tcp                 = (INT)  2611,   //  LIONHEAD
04144             c_lionhead_udp                 = (INT)  2611,   //  LIONHEAD
04145             c_qpasa_agent_tcp              = (INT)  2612,   //  Qpasa Agent
04146             c_qpasa_agent_udp              = (INT)  2612,   //  Qpasa Agent
04147             c_smntubootstrap_tcp           = (INT)  2613,   //  SMNTUBootstrap
04148             c_smntubootstrap_udp           = (INT)  2613,   //  SMNTUBootstrap
04149             c_neveroffline_tcp             = (INT)  2614,   //  Never Offline
04150             c_neveroffline_udp             = (INT)  2614,   //  Never Offline
04151             c_firepower_tcp                = (INT)  2615,   //  firepower
04152             c_firepower_udp                = (INT)  2615,   //  firepower
04153             c_appswitch_emp_tcp            = (INT)  2616,   //  appswitch-emp
04154             c_appswitch_emp_udp            = (INT)  2616,   //  appswitch-emp
04155             c_cmadmin_tcp                  = (INT)  2617,   //  Clinical Context Managers
04156             c_cmadmin_udp                  = (INT)  2617,   //  Clinical Context Managers
04157             c_priority_e_com_tcp           = (INT)  2618,   //  Priority E-Com
04158             c_priority_e_com_udp           = (INT)  2618,   //  Priority E-Com
04159             c_bruce_tcp                    = (INT)  2619,   //  bruce
04160             c_bruce_udp                    = (INT)  2619,   //  bruce
04161             c_lpsrecommender_tcp           = (INT)  2620,   //  LPSRecommender
04162             c_lpsrecommender_udp           = (INT)  2620,   //  LPSRecommender
04163             c_miles_apart_tcp              = (INT)  2621,   //  Miles Apart Jukebox Server
04164             c_miles_apart_udp              = (INT)  2621,   //  Miles Apart Jukebox Server
04165             c_metricadbc_tcp               = (INT)  2622,   //  MetricaDBC
04166             c_metricadbc_udp               = (INT)  2622,   //  MetricaDBC
04167             c_lmdp_tcp                     = (INT)  2623,   //  LMDP
04168             c_lmdp_udp                     = (INT)  2623,   //  LMDP
04169             c_aria_tcp                     = (INT)  2624,   //  Aria
04170             c_aria_udp                     = (INT)  2624,   //  Aria
04171             c_blwnkl_port_tcp              = (INT)  2625,   //  Blwnkl Port
04172             c_blwnkl_port_udp              = (INT)  2625,   //  Blwnkl Port
04173             c_gbjd816_tcp                  = (INT)  2626,   //  gbjd816
04174             c_gbjd816_udp                  = (INT)  2626,   //  gbjd816
04175             c_moshebeeri_tcp               = (INT)  2627,   //  Moshe Beeri
04176             c_moshebeeri_udp               = (INT)  2627,   //  Moshe Beeri
04177             c_dict_tcp                     = (INT)  2628,   //  DICT
04178             c_dict_udp                     = (INT)  2628,   //  DICT
04179             c_sitaraserver_tcp             = (INT)  2629,   //  Sitara Server
04180             c_sitaraserver_udp             = (INT)  2629,   //  Sitara Server
04181             c_sitaramgmt_tcp               = (INT)  2630,   //  Sitara Management
04182             c_sitaramgmt_udp               = (INT)  2630,   //  Sitara Management
04183             c_sitaradir_tcp                = (INT)  2631,   //  Sitara Dir
04184             c_sitaradir_udp                = (INT)  2631,   //  Sitara Dir
04185             c_irdg_post_tcp                = (INT)  2632,   //  IRdg Post
04186             c_irdg_post_udp                = (INT)  2632,   //  IRdg Post
04187             c_interintelli_tcp             = (INT)  2633,   //  InterIntelli
04188             c_interintelli_udp             = (INT)  2633,   //  InterIntelli
04189             c_pk_electronics_tcp           = (INT)  2634,   //  PK Electronics
04190             c_pk_electronics_udp           = (INT)  2634,   //  PK Electronics
04191             c_backburner_tcp               = (INT)  2635,   //  Back Burner
04192             c_backburner_udp               = (INT)  2635,   //  Back Burner
04193             c_solve_tcp                    = (INT)  2636,   //  Solve
04194             c_solve_udp                    = (INT)  2636,   //  Solve
04195             c_imdocsvc_tcp                 = (INT)  2637,   //  Import Document Service
04196             c_imdocsvc_udp                 = (INT)  2637,   //  Import Document Service
04197             c_sybaseanywhere_tcp           = (INT)  2638,   //  Sybase Anywhere
04198             c_sybaseanywhere_udp           = (INT)  2638,   //  Sybase Anywhere
04199             c_aminet_1_tcp                 = (INT)  2639,   //  AMInet
04200             c_aminet_1_udp                 = (INT)  2639,   //  AMInet
04201             c_hdl_srv_tcp                  = (INT)  2641,   //  HDL Server
04202             c_hdl_srv_udp                  = (INT)  2641,   //  HDL Server
04203             c_tragic_tcp                   = (INT)  2642,   //  Tragic
04204             c_tragic_udp                   = (INT)  2642,   //  Tragic
04205             c_gte_samp_tcp                 = (INT)  2643,   //  GTE-SAMP
04206             c_gte_samp_udp                 = (INT)  2643,   //  GTE-SAMP
04207             c_travsoft_ipx_t_tcp           = (INT)  2644,   //  Travsoft IPX Tunnel
04208             c_travsoft_ipx_t_udp           = (INT)  2644,   //  Travsoft IPX Tunnel
04209             c_novell_ipx_cmd_tcp           = (INT)  2645,   //  Novell IPX CMD
04210             c_novell_ipx_cmd_udp           = (INT)  2645,   //  Novell IPX CMD
04211             c_and_lm_tcp                   = (INT)  2646,   //  AND License Manager
04212             c_and_lm_udp                   = (INT)  2646,   //  AND License Manager
04213             c_syncserver_tcp               = (INT)  2647,   //  SyncServer
04214             c_syncserver_udp               = (INT)  2647,   //  SyncServer
04215             c_upsnotifyprot_tcp            = (INT)  2648,   //  Upsnotifyprot
04216             c_upsnotifyprot_udp            = (INT)  2648,   //  Upsnotifyprot
04217             c_vpsipport_tcp                = (INT)  2649,   //  VPSIPPORT
04218             c_vpsipport_udp                = (INT)  2649,   //  VPSIPPORT
04219             c_eristwoguns_tcp              = (INT)  2650,   //  eristwoguns
04220             c_eristwoguns_udp              = (INT)  2650,   //  eristwoguns
04221             c_ebinsite_tcp                 = (INT)  2651,   //  EBInSite
04222             c_ebinsite_udp                 = (INT)  2651,   //  EBInSite
04223             c_interpathpanel_tcp           = (INT)  2652,   //  InterPathPanel
04224             c_interpathpanel_udp           = (INT)  2652,   //  InterPathPanel
04225             c_sonus_tcp                    = (INT)  2653,   //  Sonus
04226             c_sonus_udp                    = (INT)  2653,   //  Sonus
04227             c_unglue_tcp                   = (INT)  2655,   //  UNIX Nt Glue
04228             c_unglue_udp                   = (INT)  2655,   //  UNIX Nt Glue
04229             c_kana_tcp                     = (INT)  2656,   //  Kana
04230             c_kana_udp                     = (INT)  2656,   //  Kana
04231             c_sns_dispatcher_tcp           = (INT)  2657,   //  SNS Dispatcher
04232             c_sns_dispatcher_udp           = (INT)  2657,   //  SNS Dispatcher
04233             c_sns_admin_tcp                = (INT)  2658,   //  SNS Admin
04234             c_sns_admin_udp                = (INT)  2658,   //  SNS Admin
04235             c_sns_query_tcp                = (INT)  2659,   //  SNS Query
04236             c_sns_query_udp                = (INT)  2659,   //  SNS Query
04237             c_gcmonitor_tcp                = (INT)  2660,   //  GC Monitor
04238             c_gcmonitor_udp                = (INT)  2660,   //  GC Monitor
04239             c_olhost_tcp                   = (INT)  2661,   //  OLHOST
04240             c_olhost_udp                   = (INT)  2661,   //  OLHOST
04241             c_bintec_capi_tcp              = (INT)  2662,   //  BinTec-CAPI
04242             c_bintec_capi_udp              = (INT)  2662,   //  BinTec-CAPI
04243             c_bintec_tapi_tcp              = (INT)  2663,   //  BinTec-TAPI
04244             c_bintec_tapi_udp              = (INT)  2663,   //  BinTec-TAPI
04245             c_patrol_mq_gm_tcp             = (INT)  2664,   //  Patrol for MQ GM
04246             c_patrol_mq_gm_udp             = (INT)  2664,   //  Patrol for MQ GM
04247             c_patrol_mq_nm_tcp             = (INT)  2665,   //  Patrol for MQ NM
04248             c_patrol_mq_nm_udp             = (INT)  2665,   //  Patrol for MQ NM
04249             c_extensis_tcp                 = (INT)  2666,   //  extensis
04250             c_extensis_udp                 = (INT)  2666,   //  extensis
04251             c_alarm_clock_s_tcp            = (INT)  2667,   //  Alarm Clock Server
04252             c_alarm_clock_s_udp            = (INT)  2667,   //  Alarm Clock Server
04253             c_alarm_clock_c_tcp            = (INT)  2668,   //  Alarm Clock Client
04254             c_alarm_clock_c_udp            = (INT)  2668,   //  Alarm Clock Client
04255             c_toad_tcp                     = (INT)  2669,   //  TOAD
04256             c_toad_udp                     = (INT)  2669,   //  TOAD
04257             c_tve_announce_tcp             = (INT)  2670,   //  TVE Announce
04258             c_tve_announce_udp             = (INT)  2670,   //  TVE Announce
04259             c_newlixreg_tcp                = (INT)  2671,   //  newlixreg
04260             c_newlixreg_udp                = (INT)  2671,   //  newlixreg
04261             c_nhserver_tcp                 = (INT)  2672,   //  nhserver
04262             c_nhserver_udp                 = (INT)  2672,   //  nhserver
04263             c_firstcall42_tcp              = (INT)  2673,   //  First Call 42
04264             c_firstcall42_udp              = (INT)  2673,   //  First Call 42
04265             c_ewnn_tcp                     = (INT)  2674,   //  ewnn
04266             c_ewnn_udp                     = (INT)  2674,   //  ewnn
04267             c_ttc_etap_tcp                 = (INT)  2675,   //  TTC ETAP
04268             c_ttc_etap_udp                 = (INT)  2675,   //  TTC ETAP
04269             c_simslink_tcp                 = (INT)  2676,   //  SIMSLink
04270             c_simslink_udp                 = (INT)  2676,   //  SIMSLink
04271             c_gadgetgate1way_tcp           = (INT)  2677,   //  Gadget Gate 1 Way
04272             c_gadgetgate1way_udp           = (INT)  2677,   //  Gadget Gate 1 Way
04273             c_gadgetgate2way_tcp           = (INT)  2678,   //  Gadget Gate 2 Way
04274             c_gadgetgate2way_udp           = (INT)  2678,   //  Gadget Gate 2 Way
04275             c_syncserverssl_tcp            = (INT)  2679,   //  Sync Server SSL
04276             c_syncserverssl_udp            = (INT)  2679,   //  Sync Server SSL
04277             c_pxc_sapxom_tcp               = (INT)  2680,   //  pxc-sapxom
04278             c_pxc_sapxom_udp               = (INT)  2680,   //  pxc-sapxom
04279             c_mpnjsomb_tcp                 = (INT)  2681,   //  mpnjsomb
04280             c_mpnjsomb_udp                 = (INT)  2681,   //  mpnjsomb
04281             c_srsp_tcp                     = (INT)  2682,   //  SRSP
04282             c_srsp_udp                     = (INT)  2682,   //  SRSP
04283             c_ncdloadbalance_tcp           = (INT)  2683,   //  NCDLoadBalance
04284             c_ncdloadbalance_udp           = (INT)  2683,   //  NCDLoadBalance
04285             c_mpnjsosv_tcp                 = (INT)  2684,   //  mpnjsosv
04286             c_mpnjsosv_udp                 = (INT)  2684,   //  mpnjsosv
04287             c_mpnjsocl_tcp                 = (INT)  2685,   //  mpnjsocl
04288             c_mpnjsocl_udp                 = (INT)  2685,   //  mpnjsocl
04289             c_mpnjsomg_tcp                 = (INT)  2686,   //  mpnjsomg
04290             c_mpnjsomg_udp                 = (INT)  2686,   //  mpnjsomg
04291             c_pq_lic_mgmt_tcp              = (INT)  2687,   //  pq-lic-mgmt
04292             c_pq_lic_mgmt_udp              = (INT)  2687,   //  pq-lic-mgmt
04293             c_md_cg_http_tcp               = (INT)  2688,   //  md-cf-http
04294             c_md_cg_http_udp               = (INT)  2688,   //  md-cf-http
04295             c_fastlynx_tcp                 = (INT)  2689,   //  FastLynx
04296             c_fastlynx_udp                 = (INT)  2689,   //  FastLynx
04297             c_hp_nnm_data_tcp              = (INT)  2690,   //  HP NNM Embedded Database
04298             c_hp_nnm_data_udp              = (INT)  2690,   //  HP NNM Embedded Database
04299             c_itinternet_tcp               = (INT)  2691,   //  ITInternet ISM Server
04300             c_itinternet_udp               = (INT)  2691,   //  ITInternet ISM Server
04301             c_admins_lms_tcp               = (INT)  2692,   //  Admins LMS
04302             c_admins_lms_udp               = (INT)  2692,   //  Admins LMS
04303             c_belarc_http_tcp              = (INT)  2693,   //  belarc-http
04304             c_belarc_http_udp              = (INT)  2693,   //  belarc-http
04305             c_pwrsevent_tcp                = (INT)  2694,   //  pwrsevent
04306             c_pwrsevent_udp                = (INT)  2694,   //  pwrsevent
04307             c_vspread_tcp                  = (INT)  2695,   //  VSPREAD
04308             c_vspread_udp                  = (INT)  2695,   //  VSPREAD
04309             c_unifyadmin_tcp               = (INT)  2696,   //  Unify Admin
04310             c_unifyadmin_udp               = (INT)  2696,   //  Unify Admin
04311             c_oce_snmp_trap_tcp            = (INT)  2697,   //  Oce SNMP Trap Port
04312             c_oce_snmp_trap_udp            = (INT)  2697,   //  Oce SNMP Trap Port
04313             c_mck_ivpip_tcp                = (INT)  2698,   //  MCK-IVPIP
04314             c_mck_ivpip_udp                = (INT)  2698,   //  MCK-IVPIP
04315             c_csoft_plusclnt_tcp           = (INT)  2699,   //  Csoft Plus Client
04316             c_csoft_plusclnt_udp           = (INT)  2699,   //  Csoft Plus Client
04317             c_tqdata_tcp                   = (INT)  2700,   //  tqdata
04318             c_tqdata_udp                   = (INT)  2700,   //  tqdata
04319             c_sms_rcinfo_tcp               = (INT)  2701,   //  SMS RCINFO
04320             c_sms_rcinfo_udp               = (INT)  2701,   //  SMS RCINFO
04321             c_sms_xfer_tcp                 = (INT)  2702,   //  SMS XFER
04322             c_sms_xfer_udp                 = (INT)  2702,   //  SMS XFER
04323             c_sms_chat_tcp                 = (INT)  2703,   //  SMS CHAT
04324             c_sms_chat_udp                 = (INT)  2703,   //  SMS CHAT
04325             c_sms_remctrl_tcp              = (INT)  2704,   //  SMS REMCTRL
04326             c_sms_remctrl_udp              = (INT)  2704,   //  SMS REMCTRL
04327             c_sds_admin_tcp                = (INT)  2705,   //  SDS Admin
04328             c_sds_admin_udp                = (INT)  2705,   //  SDS Admin
04329             c_ncdmirroring_tcp             = (INT)  2706,   //  NCD Mirroring
04330             c_ncdmirroring_udp             = (INT)  2706,   //  NCD Mirroring
04331             c_emcsymapiport_tcp            = (INT)  2707,   //  EMCSYMAPIPORT
04332             c_emcsymapiport_udp            = (INT)  2707,   //  EMCSYMAPIPORT
04333             c_banyan_net_tcp               = (INT)  2708,   //  Banyan-Net
04334             c_banyan_net_udp               = (INT)  2708,   //  Banyan-Net
04335             c_supermon_tcp                 = (INT)  2709,   //  Supermon
04336             c_supermon_udp                 = (INT)  2709,   //  Supermon
04337             c_sso_service_tcp              = (INT)  2710,   //  SSO Service
04338             c_sso_service_udp              = (INT)  2710,   //  SSO Service
04339             c_sso_control_tcp              = (INT)  2711,   //  SSO Control
04340             c_sso_control_udp              = (INT)  2711,   //  SSO Control
04341             c_aocp_tcp                     = (INT)  2712,   //  Axapta Object Communication Protocol
04342             c_aocp_udp                     = (INT)  2712,   //  Axapta Object Communication Protocol
04343             c_raven1_tcp                   = (INT)  2713,   //  Raven1
04344             c_raven1_udp                   = (INT)  2713,   //  Raven1
04345             c_raven2_tcp                   = (INT)  2714,   //  Raven2
04346             c_raven2_udp                   = (INT)  2714,   //  Raven2
04347             c_hpstgmgr2_tcp                = (INT)  2715,   //  HPSTGMGR2
04348             c_hpstgmgr2_udp                = (INT)  2715,   //  HPSTGMGR2
04349             c_inova_ip_disco_tcp           = (INT)  2716,   //  Inova IP Disco
04350             c_inova_ip_disco_udp           = (INT)  2716,   //  Inova IP Disco
04351             c_pn_requester_tcp             = (INT)  2717,   //  PN REQUESTER
04352             c_pn_requester_udp             = (INT)  2717,   //  PN REQUESTER
04353             c_pn_requester2_tcp            = (INT)  2718,   //  PN REQUESTER 2
04354             c_pn_requester2_udp            = (INT)  2718,   //  PN REQUESTER 2
04355             c_scan_change_tcp              = (INT)  2719,   //  Scan & Change
04356             c_scan_change_udp              = (INT)  2719,   //  Scan & Change
04357             c_wkars_tcp                    = (INT)  2720,   //  wkars
04358             c_wkars_udp                    = (INT)  2720,   //  wkars
04359             c_smart_diagnose_tcp           = (INT)  2721,   //  Smart Diagnose
04360             c_smart_diagnose_udp           = (INT)  2721,   //  Smart Diagnose
04361             c_proactivesrvr_tcp            = (INT)  2722,   //  Proactive Server
04362             c_proactivesrvr_udp            = (INT)  2722,   //  Proactive Server
04363             c_watchdognt_tcp               = (INT)  2723,   //  WatchDog NT
04364             c_watchdognt_udp               = (INT)  2723,   //  WatchDog NT
04365             c_qotps_tcp                    = (INT)  2724,   //  qotps
04366             c_qotps_udp                    = (INT)  2724,   //  qotps
04367             c_msolap_ptp2_tcp              = (INT)  2725,   //  MSOLAP PTP2
04368             c_msolap_ptp2_udp              = (INT)  2725,   //  MSOLAP PTP2
04369             c_tams_tcp                     = (INT)  2726,   //  TAMS
04370             c_tams_udp                     = (INT)  2726,   //  TAMS
04371             c_mgcp_callagent_tcp           = (INT)  2727,   //  Media Gateway Control Protocol Call Agent
04372             c_mgcp_callagent_udp           = (INT)  2727,   //  Media Gateway Control Protocol Call Agent
04373             c_sqdr_tcp                     = (INT)  2728,   //  SQDR
04374             c_sqdr_udp                     = (INT)  2728,   //  SQDR
04375             c_tcim_control_tcp             = (INT)  2729,   //  TCIM Control
04376             c_tcim_control_udp             = (INT)  2729,   //  TCIM Control
04377             c_nec_raidplus_tcp             = (INT)  2730,   //  NEC RaidPlus
04378             c_nec_raidplus_udp             = (INT)  2730,   //  NEC RaidPlus
04379             c_fyre_messanger_tcp           = (INT)  2731,   //  Fyre Messanger
04380             c_fyre_messanger_udp           = (INT)  2731,   //  Fyre Messagner
04381             c_g5m_tcp                      = (INT)  2732,   //  G5M
04382             c_g5m_udp                      = (INT)  2732,   //  G5M
04383             c_signet_ctf_tcp               = (INT)  2733,   //  Signet CTF
04384             c_signet_ctf_udp               = (INT)  2733,   //  Signet CTF
04385             c_ccs_software_tcp             = (INT)  2734,   //  CCS Software
04386             c_ccs_software_udp             = (INT)  2734,   //  CCS Software
04387             c_netiq_mc_tcp                 = (INT)  2735,   //  NetIQ Monitor Console
04388             c_netiq_mc_udp                 = (INT)  2735,   //  NetIQ Monitor Console
04389             c_radwiz_nms_srv_tcp           = (INT)  2736,   //  RADWIZ NMS SRV
04390             c_radwiz_nms_srv_udp           = (INT)  2736,   //  RADWIZ NMS SRV
04391             c_srp_feedback_tcp             = (INT)  2737,   //  SRP Feedback
04392             c_srp_feedback_udp             = (INT)  2737,   //  SRP Feedback
04393             c_ndl_tcp_ois_gw_tcp           = (INT)  2738,   //  NDL TCP-OSI Gateway
04394             c_ndl_tcp_ois_gw_udp           = (INT)  2738,   //  NDL TCP-OSI Gateway
04395             c_tn_timing_tcp                = (INT)  2739,   //  TN Timing
04396             c_tn_timing_udp                = (INT)  2739,   //  TN Timing
04397             c_alarm_tcp                    = (INT)  2740,   //  Alarm
04398             c_alarm_udp                    = (INT)  2740,   //  Alarm
04399             c_tsb_tcp                      = (INT)  2741,   //  TSB
04400             c_tsb_udp                      = (INT)  2741,   //  TSB
04401             c_tsb2_tcp                     = (INT)  2742,   //  TSB2
04402             c_tsb2_udp                     = (INT)  2742,   //  TSB2
04403             c_murx_tcp                     = (INT)  2743,   //  murx
04404             c_murx_udp                     = (INT)  2743,   //  murx
04405             c_honyaku_tcp                  = (INT)  2744,   //  honyaku
04406             c_honyaku_udp                  = (INT)  2744,   //  honyaku
04407             c_urbisnet_tcp                 = (INT)  2745,   //  URBISNET
04408             c_urbisnet_udp                 = (INT)  2745,   //  URBISNET
04409             c_cpudpencap_tcp               = (INT)  2746,   //  CPUDPENCAP
04410             c_cpudpencap_udp               = (INT)  2746,   //  CPUDPENCAP
04411             c_fjippol_swrly_tcp            = (INT)  2747,   //
04412             c_fjippol_swrly_udp            = (INT)  2747,   //
04413             c_fjippol_polsvr_tcp           = (INT)  2748,   //
04414             c_fjippol_polsvr_udp           = (INT)  2748,   //
04415             c_fjippol_cnsl_tcp             = (INT)  2749,   //
04416             c_fjippol_cnsl_udp             = (INT)  2749,   //
04417             c_fjippol_port1_tcp            = (INT)  2750,   //
04418             c_fjippol_port1_udp            = (INT)  2750,   //
04419             c_fjippol_port2_tcp            = (INT)  2751,   //
04420             c_fjippol_port2_udp            = (INT)  2751,   //
04421             c_rsisysaccess_tcp             = (INT)  2752,   //  RSISYS ACCESS
04422             c_rsisysaccess_udp             = (INT)  2752,   //  RSISYS ACCESS
04423             c_de_spot_tcp                  = (INT)  2753,   //  de-spot
04424             c_de_spot_udp                  = (INT)  2753,   //  de-spot
04425             c_apollo_cc_tcp                = (INT)  2754,   //  APOLLO CC
04426             c_apollo_cc_udp                = (INT)  2754,   //  APOLLO CC
04427             c_expresspay_tcp               = (INT)  2755,   //  Express Pay
04428             c_expresspay_udp               = (INT)  2755,   //  Express Pay
04429             c_simplement_tie_tcp           = (INT)  2756,   //  simplement-tie
04430             c_simplement_tie_udp           = (INT)  2756,   //  simplement-tie
04431             c_cnrp_tcp                     = (INT)  2757,   //  CNRP
04432             c_cnrp_udp                     = (INT)  2757,   //  CNRP
04433             c_apollo_status_tcp            = (INT)  2758,   //  APOLLO Status
04434             c_apollo_status_udp            = (INT)  2758,   //  APOLLO Status
04435             c_apollo_gms_tcp               = (INT)  2759,   //  APOLLO GMS
04436             c_apollo_gms_udp               = (INT)  2759,   //  APOLLO GMS
04437             c_sabams_tcp                   = (INT)  2760,   //  Saba MS
04438             c_sabams_udp                   = (INT)  2760,   //  Saba MS
04439             c_dicom_iscl_tcp               = (INT)  2761,   //  DICOM ISCL
04440             c_dicom_iscl_udp               = (INT)  2761,   //  DICOM ISCL
04441             c_dicom_tls_tcp                = (INT)  2762,   //  DICOM TLS
04442             c_dicom_tls_udp                = (INT)  2762,   //  DICOM TLS
04443             c_desktop_dna_tcp              = (INT)  2763,   //  Desktop DNA
04444             c_desktop_dna_udp              = (INT)  2763,   //  Desktop DNA
04445             c_data_insurance_tcp           = (INT)  2764,   //  Data Insurance
04446             c_data_insurance_udp           = (INT)  2764,   //  Data Insurance
04447             c_qip_audup_tcp                = (INT)  2765,   //  qip-audup
04448             c_qip_audup_udp                = (INT)  2765,   //  qip-audup
04449             c_compaq_scp_tcp               = (INT)  2766,   //  Compaq SCP
04450             c_compaq_scp_udp               = (INT)  2766,   //  Compaq SCP
04451             c_uadtc_tcp                    = (INT)  2767,   //  UADTC
04452             c_uadtc_udp                    = (INT)  2767,   //  UADTC
04453             c_uacs_tcp                     = (INT)  2768,   //  UACS
04454             c_uacs_udp                     = (INT)  2768,   //  UACS
04455             c_singlept_mvs_tcp             = (INT)  2769,   //  Single Point MVS
04456             c_singlept_mvs_udp             = (INT)  2769,   //  Single Point MVS
04457             c_veronica_tcp                 = (INT)  2770,   //  Veronica
04458             c_veronica_udp                 = (INT)  2770,   //  Veronica
04459             c_vergencecm_tcp               = (INT)  2771,   //  Vergence CM
04460             c_vergencecm_udp               = (INT)  2771,   //  Vergence CM
04461             c_auris_tcp                    = (INT)  2772,   //  auris
04462             c_auris_udp                    = (INT)  2772,   //  auris
04463             c_pcbakcup1_tcp                = (INT)  2773,   //  PC Backup
04464             c_pcbakcup1_udp                = (INT)  2773,   //  PC Backup
04465             c_pcbakcup2_tcp                = (INT)  2774,   //  PC Backup
04466             c_pcbakcup2_udp                = (INT)  2774,   //  PC Backup
04467             c_smpp_tcp                     = (INT)  2775,   //  SMPP
04468             c_smpp_udp                     = (INT)  2775,   //  SMPP
04469             c_ridgeway1_tcp                = (INT)  2776,   //  Ridgeway Systems & Software
04470             c_ridgeway1_udp                = (INT)  2776,   //  Ridgeway Systems & Software
04471             c_ridgeway2_tcp                = (INT)  2777,   //  Ridgeway Systems & Software
04472             c_ridgeway2_udp                = (INT)  2777,   //  Ridgeway Systems & Software
04473             c_gwen_sonya_tcp               = (INT)  2778,   //  Gwen-Sonya
04474             c_gwen_sonya_udp               = (INT)  2778,   //  Gwen-Sonya
04475             c_lbc_sync_tcp                 = (INT)  2779,   //  LBC Sync
04476             c_lbc_sync_udp                 = (INT)  2779,   //  LBC Sync
04477             c_lbc_control_tcp              = (INT)  2780,   //  LBC Control
04478             c_lbc_control_udp              = (INT)  2780,   //  LBC Control
04479             c_whosells_tcp                 = (INT)  2781,   //  whosells
04480             c_whosells_udp                 = (INT)  2781,   //  whosells
04481             c_everydayrc_tcp               = (INT)  2782,   //  everydayrc
04482             c_everydayrc_udp               = (INT)  2782,   //  everydayrc
04483             c_aises_tcp                    = (INT)  2783,   //  AISES
04484             c_aises_udp                    = (INT)  2783,   //  AISES
04485             c_www_dev_tcp                  = (INT)  2784,   //  world wide web - development
04486             c_www_dev_udp                  = (INT)  2784,   //  world wide web - development
04487             c_aic_np_tcp                   = (INT)  2785,   //  aic-np
04488             c_aic_np_udp                   = (INT)  2785,   //  aic-np
04489             c_aic_oncrpc_tcp               = (INT)  2786,   //  aic-oncrpc - Destiny MCD database
04490             c_aic_oncrpc_udp               = (INT)  2786,   //  aic-oncrpc - Destiny MCD database
04491             c_piccolo_tcp                  = (INT)  2787,   //  piccolo - Cornerstone Software
04492             c_piccolo_udp                  = (INT)  2787,   //  piccolo - Cornerstone Software
04493             c_fryeserv_tcp                 = (INT)  2788,   //  NetWare Loadable Module - Seagate Software
04494             c_fryeserv_udp                 = (INT)  2788,   //  NetWare Loadable Module - Seagate Software
04495             c_media_agent_tcp              = (INT)  2789,   //  Media Agent
04496             c_media_agent_udp              = (INT)  2789,   //  Media Agent
04497             c_plgproxy_tcp                 = (INT)  2790,   //  PLG Proxy
04498             c_plgproxy_udp                 = (INT)  2790,   //  PLG Proxy
04499             c_mtport_regist_tcp            = (INT)  2791,   //  MT Port Registrator
04500             c_mtport_regist_udp            = (INT)  2791,   //  MT Port Registrator
04501             c_f5_globalsite_tcp            = (INT)  2792,   //  f5-globalsite
04502             c_f5_globalsite_udp            = (INT)  2792,   //  f5-globalsite
04503             c_initlsmsad_tcp               = (INT)  2793,   //  initlsmsad
04504             c_initlsmsad_udp               = (INT)  2793,   //  initlsmsad
04505             c_aaftp_tcp                    = (INT)  2794,   //  aaftp
04506             c_aaftp_udp                    = (INT)  2794,   //  aaftp
04507             c_livestats_tcp                = (INT)  2795,   //  LiveStats
04508             c_livestats_udp                = (INT)  2795,   //  LiveStats
04509             c_ac_tech_tcp                  = (INT)  2796,   //  ac-tech
04510             c_ac_tech_udp                  = (INT)  2796,   //  ac-tech
04511             c_esp_encap_tcp                = (INT)  2797,   //  esp-encap
04512             c_esp_encap_udp                = (INT)  2797,   //  esp-encap
04513             c_tmesis_upshot_tcp            = (INT)  2798,   //  TMESIS-UPShot
04514             c_tmesis_upshot_udp            = (INT)  2798,   //  TMESIS-UPShot
04515             c_icon_discover_tcp            = (INT)  2799,   //  ICON Discover
04516             c_icon_discover_udp            = (INT)  2799,   //  ICON Discover
04517             c_acc_raid_tcp                 = (INT)  2800,   //  ACC RAID
04518             c_acc_raid_udp                 = (INT)  2800,   //  ACC RAID
04519             c_igcp_tcp                     = (INT)  2801,   //  IGCP
04520             c_igcp_udp                     = (INT)  2801,   //  IGCP
04521             c_veritas_tcp1_tcp             = (INT)  2802,   //  Veritas TCP1
04522             c_veritas_udp1_udp             = (INT)  2802,   //  Veritas UDP1
04523             c_btprjctrl_tcp                = (INT)  2803,   //  btprjctrl
04524             c_btprjctrl_udp                = (INT)  2803,   //  btprjctrl
04525             c_telexis_vtu_tcp              = (INT)  2804,   //  Telexis VTU
04526             c_telexis_vtu_udp              = (INT)  2804,   //  Telexis VTU
04527             c_wta_wsp_s_tcp                = (INT)  2805,   //  WTA WSP-S
04528             c_wta_wsp_s_udp                = (INT)  2805,   //  WTA WSP-S
04529             c_cspuni_tcp                   = (INT)  2806,   //  cspuni
04530             c_cspuni_udp                   = (INT)  2806,   //  cspuni
04531             c_cspmulti_tcp                 = (INT)  2807,   //  cspmulti
04532             c_cspmulti_udp                 = (INT)  2807,   //  cspmulti
04533             c_j_lan_p_tcp                  = (INT)  2808,   //  J-LAN-P
04534             c_j_lan_p_udp                  = (INT)  2808,   //  J-LAN-P
04535             c_corbaloc_tcp                 = (INT)  2809,   //  CORBA LOC
04536             c_corbaloc_udp                 = (INT)  2809,   //  CORBA LOC
04537             c_netsteward_tcp               = (INT)  2810,   //  Active Net Steward
04538             c_netsteward_udp               = (INT)  2810,   //  Active Net Steward
04539             c_gsiftp_tcp                   = (INT)  2811,   //  GSI FTP
04540             c_gsiftp_udp                   = (INT)  2811,   //  GSI FTP
04541             c_atmtcp_tcp                   = (INT)  2812,   //  atmtcp
04542             c_atmtcp_udp                   = (INT)  2812,   //  atmtcp
04543             c_llm_pass_tcp                 = (INT)  2813,   //  llm-pass
04544             c_llm_pass_udp                 = (INT)  2813,   //  llm-pass
04545             c_llm_csv_tcp                  = (INT)  2814,   //  llm-csv
04546             c_llm_csv_udp                  = (INT)  2814,   //  llm-csv
04547             c_lbc_measure_tcp              = (INT)  2815,   //  LBC Measurement
04548             c_lbc_measure_udp              = (INT)  2815,   //  LBC Measurement
04549             c_lbc_watchdog_tcp             = (INT)  2816,   //  LBC Watchdog
04550             c_lbc_watchdog_udp             = (INT)  2816,   //  LBC Watchdog
04551             c_nmsigport_tcp                = (INT)  2817,   //  NMSig Port
04552             c_nmsigport_udp                = (INT)  2817,   //  NMSig Port
04553             c_rmlnk_tcp                    = (INT)  2818,   //  rmlnk
04554             c_rmlnk_udp                    = (INT)  2818,   //  rmlnk
04555             c_fc_faultnotify_tcp           = (INT)  2819,   //  FC Fault Notification
04556             c_fc_faultnotify_udp           = (INT)  2819,   //  FC Fault Notification
04557             c_univision_tcp                = (INT)  2820,   //  UniVision
04558             c_univision_udp                = (INT)  2820,   //  UniVision
04559             c_vml_dms_tcp                  = (INT)  2821,   //  vml_dms
04560             c_vml_dms_udp                  = (INT)  2821,   //  vml_dms
04561             c_ka0wuc_tcp                   = (INT)  2822,   //  ka0wuc
04562             c_ka0wuc_udp                   = (INT)  2822,   //  ka0wuc
04563             c_cqg_netlan_tcp               = (INT)  2823,   //  CQG Net/LAN
04564             c_cqg_netlan_udp               = (INT)  2823,   //  CQG Net/LAN
04565             c_cqg_netlan_1_tcp             = (INT)  2824,   //  CQG Net/LAN 1
04566             c_cqg_netlan_1_udp             = (INT)  2824,   //  CQG Net/Lan 1
04567             c_slc_systemlog_tcp            = (INT)  2826,   //  slc systemlog
04568             c_slc_systemlog_udp            = (INT)  2826,   //  slc systemlog
04569             c_slc_ctrlrloops_tcp           = (INT)  2827,   //  slc ctrlrloops
04570             c_slc_ctrlrloops_udp           = (INT)  2827,   //  slc ctrlrloops
04571             c_itm_lm_tcp                   = (INT)  2828,   //  ITM License Manager
04572             c_itm_lm_udp                   = (INT)  2828,   //  ITM License Manager
04573             c_silkp1_tcp                   = (INT)  2829,   //  silkp1
04574             c_silkp1_udp                   = (INT)  2829,   //  silkp1
04575             c_silkp2_tcp                   = (INT)  2830,   //  silkp2
04576             c_silkp2_udp                   = (INT)  2830,   //  silkp2
04577             c_silkp3_tcp                   = (INT)  2831,   //  silkp3
04578             c_silkp3_udp                   = (INT)  2831,   //  silkp3
04579             c_silkp4_tcp                   = (INT)  2832,   //  silkp4
04580             c_silkp4_udp                   = (INT)  2832,   //  silkp4
04581             c_glishd_tcp                   = (INT)  2833,   //  glishd
04582             c_glishd_udp                   = (INT)  2833,   //  glishd
04583             c_evtp_tcp                     = (INT)  2834,   //  EVTP
04584             c_evtp_udp                     = (INT)  2834,   //  EVTP
04585             c_evtp_data_tcp                = (INT)  2835,   //  EVTP-DATA
04586             c_evtp_data_udp                = (INT)  2835,   //  EVTP-DATA
04587             c_catalyst_tcp                 = (INT)  2836,   //  catalyst
04588             c_catalyst_udp                 = (INT)  2836,   //  catalyst
04589             c_repliweb_tcp                 = (INT)  2837,   //  Repliweb
04590             c_repliweb_udp                 = (INT)  2837,   //  Repliweb
04591             c_starbot_tcp                  = (INT)  2838,   //  Starbot
04592             c_starbot_udp                  = (INT)  2838,   //  Starbot
04593             c_nmsigport_1_tcp              = (INT)  2839,   //  NMSigPort
04594             c_nmsigport_1_udp              = (INT)  2839,   //  NMSigPort
04595             c_l3_exprt_tcp                 = (INT)  2840,   //  l3-exprt
04596             c_l3_exprt_udp                 = (INT)  2840,   //  l3-exprt
04597             c_l3_ranger_tcp                = (INT)  2841,   //  l3-ranger
04598             c_l3_ranger_udp                = (INT)  2841,   //  l3-ranger
04599             c_l3_hawk_tcp                  = (INT)  2842,   //  l3-hawk
04600             c_l3_hawk_udp                  = (INT)  2842,   //  l3-hawk
04601             c_pdnet_tcp                    = (INT)  2843,   //  PDnet
04602             c_pdnet_udp                    = (INT)  2843,   //  PDnet
04603             c_bpcp_poll_tcp                = (INT)  2844,   //  BPCP POLL
04604             c_bpcp_poll_udp                = (INT)  2844,   //  BPCP POLL
04605             c_bpcp_trap_tcp                = (INT)  2845,   //  BPCP TRAP
04606             c_bpcp_trap_udp                = (INT)  2845,   //  BPCP TRAP
04607             c_aimpp_hello_tcp              = (INT)  2846,   //  AIMPP Hello
04608             c_aimpp_hello_udp              = (INT)  2846,   //  AIMPP Hello
04609             c_aimpp_port_req_tcp           = (INT)  2847,   //  AIMPP Port Req
04610             c_aimpp_port_req_udp           = (INT)  2847,   //  AIMPP Port Req
04611             c_amt_blc_port_tcp             = (INT)  2848,   //  AMT-BLC-PORT
04612             c_amt_blc_port_udp             = (INT)  2848,   //  AMT-BLC-PORT
04613             c_fxp_tcp                      = (INT)  2849,   //  FXP
04614             c_fxp_udp                      = (INT)  2849,   //  FXP
04615             c_metaconsole_tcp              = (INT)  2850,   //  MetaConsole
04616             c_metaconsole_udp              = (INT)  2850,   //  MetaConsole
04617             c_webemshttp_tcp               = (INT)  2851,   //  webemshttp
04618             c_webemshttp_udp               = (INT)  2851,   //  webemshttp
04619             c_bears_01_tcp                 = (INT)  2852,   //  bears-01
04620             c_bears_01_udp                 = (INT)  2852,   //  bears-01
04621             c_ispipes_tcp                  = (INT)  2853,   //  ISPipes
04622             c_ispipes_udp                  = (INT)  2853,   //  ISPipes
04623             c_infomover_tcp                = (INT)  2854,   //  InfoMover
04624             c_infomover_udp                = (INT)  2854,   //  InfoMover
04625             c_cesdinv_tcp                  = (INT)  2856,   //  cesdinv
04626             c_cesdinv_udp                  = (INT)  2856,   //  cesdinv
04627             c_simctlp_tcp                  = (INT)  2857,   //  SimCtIP
04628             c_simctlp_udp                  = (INT)  2857,   //  SimCtIP
04629             c_ecnp_tcp                     = (INT)  2858,   //  ECNP
04630             c_ecnp_udp                     = (INT)  2858,   //  ECNP
04631             c_activememory_tcp             = (INT)  2859,   //  Active Memory
04632             c_activememory_udp             = (INT)  2859,   //  Active Memory
04633             c_dialpad_voice1_tcp           = (INT)  2860,   //  Dialpad Voice 1
04634             c_dialpad_voice1_udp           = (INT)  2860,   //  Dialpad Voice 1
04635             c_dialpad_voice2_tcp           = (INT)  2861,   //  Dialpad Voice 2
04636             c_dialpad_voice2_udp           = (INT)  2861,   //  Dialpad Voice 2
04637             c_ttg_protocol_tcp             = (INT)  2862,   //  TTG Protocol
04638             c_ttg_protocol_udp             = (INT)  2862,   //  TTG Protocol
04639             c_sonardata_tcp                = (INT)  2863,   //  Sonar Data
04640             c_sonardata_udp                = (INT)  2863,   //  Sonar Data
04641             c_astromed_main_tcp            = (INT)  2864,   //  main 5001 cmd
04642             c_astromed_main_udp            = (INT)  2864,   //  main 5001 cmd
04643             c_pit_vpn_tcp                  = (INT)  2865,   //  pit-vpn
04644             c_pit_vpn_udp                  = (INT)  2865,   //  pit-vpn
04645             c_iwlistener_tcp               = (INT)  2866,   //  iwlistener
04646             c_iwlistener_udp               = (INT)  2866,   //  iwlistener
04647             c_esps_portal_tcp              = (INT)  2867,   //  esps-portal
04648             c_esps_portal_udp              = (INT)  2867,   //  esps-portal
04649             c_npep_messaging_tcp           = (INT)  2868,   //  NPEP Messaging
04650             c_npep_messaging_udp           = (INT)  2868,   //  NPEP Messaging
04651             c_icslap_tcp                   = (INT)  2869,   //  ICSLAP
04652             c_icslap_udp                   = (INT)  2869,   //  ICSLAP
04653             c_daishi_tcp                   = (INT)  2870,   //  daishi
04654             c_daishi_udp                   = (INT)  2870,   //  daishi
04655             c_msi_selectplay_tcp           = (INT)  2871,   //  MSI Select Play
04656             c_msi_selectplay_udp           = (INT)  2871,   //  MSI Select Play
04657             c_radix_tcp                    = (INT)  2872,   //  RADIX
04658             c_radix_udp                    = (INT)  2872,   //  RADIX
04659             c_paspar2_zoomin_tcp           = (INT)  2873,   //  PASPAR2 ZoomIn
04660             c_paspar2_zoomin_udp           = (INT)  2873,   //  PASPAR2 ZoomIn
04661             c_dxmessagebase1_tcp           = (INT)  2874,   //  dxmessagebase1
04662             c_dxmessagebase1_udp           = (INT)  2874,   //  dxmessagebase1
04663             c_dxmessagebase2_tcp           = (INT)  2875,   //  dxmessagebase2
04664             c_dxmessagebase2_udp           = (INT)  2875,   //  dxmessagebase2
04665             c_sps_tunnel_tcp               = (INT)  2876,   //  SPS Tunnel
04666             c_sps_tunnel_udp               = (INT)  2876,   //  SPS Tunnel
04667             c_bluelance_tcp                = (INT)  2877,   //  BLUELANCE
04668             c_bluelance_udp                = (INT)  2877,   //  BLUELANCE
04669             c_aap_tcp                      = (INT)  2878,   //  AAP
04670             c_aap_udp                      = (INT)  2878,   //  AAP
04671             c_ucentric_ds_tcp              = (INT)  2879,   //  ucentric-ds
04672             c_ucentric_ds_udp              = (INT)  2879,   //  ucentric-ds
04673             c_synapse_tcp                  = (INT)  2880,   //  synapse
04674             c_synapse_udp                  = (INT)  2880,   //  synapse
04675             c_ndsp_tcp                     = (INT)  2881,   //  NDSP
04676             c_ndsp_udp                     = (INT)  2881,   //  NDSP
04677             c_ndtp_tcp                     = (INT)  2882,   //  NDTP
04678             c_ndtp_udp                     = (INT)  2882,   //  NDTP
04679             c_ndnp_tcp                     = (INT)  2883,   //  NDNP
04680             c_ndnp_udp                     = (INT)  2883,   //  NDNP
04681             c_flashmsg_tcp                 = (INT)  2884,   //  Flash Msg
04682             c_flashmsg_udp                 = (INT)  2884,   //  Flash Msg
04683             c_topflow_tcp                  = (INT)  2885,   //  TopFlow
04684             c_topflow_udp                  = (INT)  2885,   //  TopFlow
04685             c_responselogic_tcp            = (INT)  2886,   //  RESPONSELOGIC
04686             c_responselogic_udp            = (INT)  2886,   //  RESPONSELOGIC
04687             c_aironetddp_tcp               = (INT)  2887,   //  aironet
04688             c_aironetddp_udp               = (INT)  2887,   //  aironet
04689             c_spcsdlobby_tcp               = (INT)  2888,   //  SPCSDLOBBY
04690             c_spcsdlobby_udp               = (INT)  2888,   //  SPCSDLOBBY
04691             c_rsom_tcp                     = (INT)  2889,   //  RSOM
04692             c_rsom_udp                     = (INT)  2889,   //  RSOM
04693             c_cspclmulti_tcp               = (INT)  2890,   //  CSPCLMULTI
04694             c_cspclmulti_udp               = (INT)  2890,   //  CSPCLMULTI
04695             c_cinegrfx_elmd_tcp            = (INT)  2891,   //  CINEGRFX-ELMD License Manager
04696             c_cinegrfx_elmd_udp            = (INT)  2891,   //  CINEGRFX-ELMD License Manager
04697             c_snifferdata_tcp              = (INT)  2892,   //  SNIFFERDATA
04698             c_snifferdata_udp              = (INT)  2892,   //  SNIFFERDATA
04699             c_vseconnector_tcp             = (INT)  2893,   //  VSECONNECTOR
04700             c_vseconnector_udp             = (INT)  2893,   //  VSECONNECTOR
04701             c_abacus_remote_tcp            = (INT)  2894,   //  ABACUS-REMOTE
04702             c_abacus_remote_udp            = (INT)  2894,   //  ABACUS-REMOTE
04703             c_natuslink_tcp                = (INT)  2895,   //  NATUS LINK
04704             c_natuslink_udp                = (INT)  2895,   //  NATUS LINK
04705             c_ecovisiong6_1_tcp            = (INT)  2896,   //  ECOVISIONG6-1
04706             c_ecovisiong6_1_udp            = (INT)  2896,   //  ECOVISIONG6-1
04707             c_citrix_rtmp_tcp              = (INT)  2897,   //  Citrix RTMP
04708             c_citrix_rtmp_udp              = (INT)  2897,   //  Citrix RTMP
04709             c_appliance_cfg_tcp            = (INT)  2898,   //  APPLIANCE-CFG
04710             c_appliance_cfg_udp            = (INT)  2898,   //  APPLIANCE-CFG
04711             c_powergemplus_tcp             = (INT)  2899,   //  POWERGEMPLUS
04712             c_powergemplus_udp             = (INT)  2899,   //  POWERGEMPLUS
04713             c_quicksuite_tcp               = (INT)  2900,   //  QUICKSUITE
04714             c_quicksuite_udp               = (INT)  2900,   //  QUICKSUITE
04715             c_allstorcns_tcp               = (INT)  2901,   //  ALLSTORCNS
04716             c_allstorcns_udp               = (INT)  2901,   //  ALLSTORCNS
04717             c_netaspi_tcp                  = (INT)  2902,   //  NET ASPI
04718             c_netaspi_udp                  = (INT)  2902,   //  NET ASPI
04719             c_suitcase_tcp                 = (INT)  2903,   //  SUITCASE
04720             c_suitcase_udp                 = (INT)  2903,   //  SUITCASE
04721             c_m2ua_tcp                     = (INT)  2904,   //  M2UA
04722             c_m2ua_udp                     = (INT)  2904,   //  M2UA
04723             c_m2ua_sctp                    = (INT)  2904,   //  M2UA
04724             c_m3ua_tcp                     = (INT)  2905,   //  M3UA
04725             c_m3ua_udp                     = (INT)  2905,   //  De-registered (2001 June 07)
04726             c_m3ua_sctp                    = (INT)  2905,   //  M3UA
04727             c_caller9_tcp                  = (INT)  2906,   //  CALLER9
04728             c_caller9_udp                  = (INT)  2906,   //  CALLER9
04729             c_webmethods_b2b_tcp           = (INT)  2907,   //  WEBMETHODS B2B
04730             c_webmethods_b2b_udp           = (INT)  2907,   //  WEBMETHODS B2B
04731             c_mao_tcp                      = (INT)  2908,   //  mao
04732             c_mao_udp                      = (INT)  2908,   //  mao
04733             c_funk_dialout_tcp             = (INT)  2909,   //  Funk Dialout
04734             c_funk_dialout_udp             = (INT)  2909,   //  Funk Dialout
04735             c_tdaccess_tcp                 = (INT)  2910,   //  TDAccess
04736             c_tdaccess_udp                 = (INT)  2910,   //  TDAccess
04737             c_blockade_tcp                 = (INT)  2911,   //  Blockade
04738             c_blockade_udp                 = (INT)  2911,   //  Blockade
04739             c_epicon_tcp                   = (INT)  2912,   //  Epicon
04740             c_epicon_udp                   = (INT)  2912,   //  Epicon
04741             c_boosterware_tcp              = (INT)  2913,   //  Booster Ware
04742             c_boosterware_udp              = (INT)  2913,   //  Booster Ware
04743             c_gamelobby_tcp                = (INT)  2914,   //  Game Lobby
04744             c_gamelobby_udp                = (INT)  2914,   //  Game Lobby
04745             c_tksocket_tcp                 = (INT)  2915,   //  TK Socket
04746             c_tksocket_udp                 = (INT)  2915,   //  TK Socket
04747             c_kastenchasepad_tcp           = (INT)  2918,   //  Kasten Chase Pad
04748             c_kastenchasepad_udp           = (INT)  2918,   //  Kasten Chase Pad
04749             c_roboer_tcp                   = (INT)  2919,   //  ROBOER
04750             c_roboer_udp                   = (INT)  2919,   //  ROBOER
04751             c_roboeda_tcp                  = (INT)  2920,   //  ROBOEDA
04752             c_roboeda_udp                  = (INT)  2920,   //  ROBOEDA
04753             c_cesdcdman_tcp                = (INT)  2921,   //  CESD Contents Delivery Management
04754             c_cesdcdman_udp                = (INT)  2921,   //  CESD Contents Delivery Management
04755             c_cesdcdtrn_tcp                = (INT)  2922,   //  CESD Contents Delivery Data Transfer
04756             c_cesdcdtrn_udp                = (INT)  2922,   //  CESD Contents Delivery Data Transfer
04757             c_wta_wsp_wtp_s_tcp            = (INT)  2923,   //  WTA-WSP-WTP-S
04758             c_wta_wsp_wtp_s_udp            = (INT)  2923,   //  WTA-WSP-WTP-S
04759             c_precise_vip_tcp              = (INT)  2924,   //  PRECISE-VIP
04760             c_precise_vip_udp              = (INT)  2924,   //  PRECISE-VIP
04761             c_mobile_file_dl_tcp           = (INT)  2926,   //  MOBILE-FILE-DL
04762             c_mobile_file_dl_udp           = (INT)  2926,   //  MOBILE-FILE-DL
04763             c_unimobilectrl_tcp            = (INT)  2927,   //  UNIMOBILECTRL
04764             c_unimobilectrl_udp            = (INT)  2927,   //  UNIMOBILECTRL
04765             c_redstone_cpss_tcp            = (INT)  2928,   //  REDSTONE-CPSS
04766             c_redstone_cpss_udp            = (INT)  2928,   //  REDSTONE-CPSS
04767             c_panja_webadmin_tcp           = (INT)  2929,   //  PANJA-WEBADMIN
04768             c_panja_webadmin_udp           = (INT)  2929,   //  PANJA-WEBADMIN
04769             c_panja_weblinx_tcp            = (INT)  2930,   //  PANJA-WEBLINX
04770             c_panja_weblinx_udp            = (INT)  2930,   //  PANJA-WEBLINX
04771             c_circle_x_tcp                 = (INT)  2931,   //  Circle-X
04772             c_circle_x_udp                 = (INT)  2931,   //  Circle-X
04773             c_incp_tcp                     = (INT)  2932,   //  INCP
04774             c_incp_udp                     = (INT)  2932,   //  INCP
04775             c_4_tieropmgw_tcp              = (INT)  2933,   //  4-TIER OPM GW
04776             c_4_tieropmgw_udp              = (INT)  2933,   //  4-TIER OPM GW
04777             c_4_tieropmcli_tcp             = (INT)  2934,   //  4-TIER OPM CLI
04778             c_4_tieropmcli_udp             = (INT)  2934,   //  4-TIER OPM CLI
04779             c_qtp_tcp                      = (INT)  2935,   //  QTP
04780             c_qtp_udp                      = (INT)  2935,   //  QTP
04781             c_otpatch_tcp                  = (INT)  2936,   //  OTPatch
04782             c_otpatch_udp                  = (INT)  2936,   //  OTPatch
04783             c_pnaconsult_lm_tcp            = (INT)  2937,   //  PNACONSULT-LM
04784             c_pnaconsult_lm_udp            = (INT)  2937,   //  PNACONSULT-LM
04785             c_sm_pas_1_tcp                 = (INT)  2938,   //  SM-PAS-1
04786             c_sm_pas_1_udp                 = (INT)  2938,   //  SM-PAS-1
04787             c_sm_pas_2_tcp                 = (INT)  2939,   //  SM-PAS-2
04788             c_sm_pas_2_udp                 = (INT)  2939,   //  SM-PAS-2
04789             c_sm_pas_3_tcp                 = (INT)  2940,   //  SM-PAS-3
04790             c_sm_pas_3_udp                 = (INT)  2940,   //  SM-PAS-3
04791             c_sm_pas_4_tcp                 = (INT)  2941,   //  SM-PAS-4
04792             c_sm_pas_4_udp                 = (INT)  2941,   //  SM-PAS-4
04793             c_sm_pas_5_tcp                 = (INT)  2942,   //  SM-PAS-5
04794             c_sm_pas_5_udp                 = (INT)  2942,   //  SM-PAS-5
04795             c_ttnrepository_tcp            = (INT)  2943,   //  TTNRepository
04796             c_ttnrepository_udp            = (INT)  2943,   //  TTNRepository
04797             c_megaco_h248_tcp              = (INT)  2944,   //  Megaco H-248
04798             c_megaco_h248_udp              = (INT)  2944,   //  Megaco H-248
04799             c_h248_binary_tcp              = (INT)  2945,   //  H248 Binary
04800             c_h248_binary_udp              = (INT)  2945,   //  H248 Binary
04801             c_fjsvmpor_tcp                 = (INT)  2946,   //  FJSVmpor
04802             c_fjsvmpor_udp                 = (INT)  2946,   //  FJSVmpor
04803             c_gpsd_tcp                     = (INT)  2947,   //  GPSD
04804             c_gpsd_udp                     = (INT)  2947,   //  GPSD
04805             c_esip_tcp                     = (INT)  2950,   //  ESIP
04806             c_esip_udp                     = (INT)  2950,   //  ESIP
04807             c_ottp_tcp                     = (INT)  2951,   //  OTTP
04808             c_ottp_udp                     = (INT)  2951,   //  OTTP
04809             c_mpfwsas_tcp                  = (INT)  2952,   //  MPFWSAS
04810             c_mpfwsas_udp                  = (INT)  2952,   //  MPFWSAS
04811             c_ovalarmsrv_tcp               = (INT)  2953,   //  OVALARMSRV
04812             c_ovalarmsrv_udp               = (INT)  2953,   //  OVALARMSRV
04813             c_ovalarmsrv_cmd_tcp           = (INT)  2954,   //  OVALARMSRV-CMD
04814             c_ovalarmsrv_cmd_udp           = (INT)  2954,   //  OVALARMSRV-CMD
04815             c_csnotify_tcp                 = (INT)  2955,   //  CSNOTIFY
04816             c_csnotify_udp                 = (INT)  2955,   //  CSNOTIFY
04817             c_ovrimosdbman_tcp             = (INT)  2956,   //  OVRIMOSDBMAN
04818             c_ovrimosdbman_udp             = (INT)  2956,   //  OVRIMOSDBMAN
04819             c_jmact5_tcp                   = (INT)  2957,   //  JAMCT5
04820             c_jmact5_udp                   = (INT)  2957,   //  JAMCT5
04821             c_jmact6_tcp                   = (INT)  2958,   //  JAMCT6
04822             c_jmact6_udp                   = (INT)  2958,   //  JAMCT6
04823             c_rmopagt_tcp                  = (INT)  2959,   //  RMOPAGT
04824             c_rmopagt_udp                  = (INT)  2959,   //  RMOPAGT
04825             c_dfoxserver_tcp               = (INT)  2960,   //  DFOXSERVER
04826             c_dfoxserver_udp               = (INT)  2960,   //  DFOXSERVER
04827             c_boldsoft_lm_tcp              = (INT)  2961,   //  BOLDSOFT-LM
04828             c_boldsoft_lm_udp              = (INT)  2961,   //  BOLDSOFT-LM
04829             c_iph_policy_cli_tcp           = (INT)  2962,   //  IPH-POLICY-CLI
04830             c_iph_policy_cli_udp           = (INT)  2962,   //  IPH-POLICY-CLI
04831             c_iph_policy_adm_tcp           = (INT)  2963,   //  IPH-POLICY-ADM
04832             c_iph_policy_adm_udp           = (INT)  2963,   //  IPH-POLICY-ADM
04833             c_bullant_srap_tcp             = (INT)  2964,   //  BULLANT SRAP
04834             c_bullant_srap_udp             = (INT)  2964,   //  BULLANT SRAP
04835             c_bullant_rap_tcp              = (INT)  2965,   //  BULLANT RAP
04836             c_bullant_rap_udp              = (INT)  2965,   //  BULLANT RAP
04837             c_idp_infotrieve_tcp           = (INT)  2966,   //  IDP-INFOTRIEVE
04838             c_idp_infotrieve_udp           = (INT)  2966,   //  IDP-INFOTRIEVE
04839             c_ssc_agent_tcp                = (INT)  2967,   //  SSC-AGENT
04840             c_ssc_agent_udp                = (INT)  2967,   //  SSC-AGENT
04841             c_enpp_tcp                     = (INT)  2968,   //  ENPP
04842             c_enpp_udp                     = (INT)  2968,   //  ENPP
04843             c_essp_tcp                     = (INT)  2969,   //  ESSP
04844             c_essp_udp                     = (INT)  2969,   //  ESSP
04845             c_index_net_tcp                = (INT)  2970,   //  INDEX-NET
04846             c_index_net_udp                = (INT)  2970,   //  INDEX-NET
04847             c_netclip_tcp                  = (INT)  2971,   //  Net Clip
04848             c_netclip_udp                  = (INT)  2971,   //  Net Clip
04849             c_pmsm_webrctl_tcp             = (INT)  2972,   //  PMSM Webrctl
04850             c_pmsm_webrctl_udp             = (INT)  2972,   //  PMSM Webrctl
04851             c_svnetworks_tcp               = (INT)  2973,   //  SV Networks
04852             c_svnetworks_udp               = (INT)  2973,   //  SV Networks
04853             c_signal_tcp                   = (INT)  2974,   //  Signal
04854             c_signal_udp                   = (INT)  2974,   //  Signal
04855             c_fjmpcm_tcp                   = (INT)  2975,   //  Fujitsu Configuration Management Service
04856             c_fjmpcm_udp                   = (INT)  2975,   //  Fujitsu Configuration Management Service
04857             c_cns_srv_port_tcp             = (INT)  2976,   //  CNS Server Port
04858             c_cns_srv_port_udp             = (INT)  2976,   //  CNS Server Port
04859             c_ttc_etap_ns_tcp              = (INT)  2977,   //  TTCs Enterprise Test Access Protocol - NS
04860             c_ttc_etap_ns_udp              = (INT)  2977,   //  TTCs Enterprise Test Access Protocol - NS
04861             c_ttc_etap_ds_tcp              = (INT)  2978,   //  TTCs Enterprise Test Access Protocol - DS
04862             c_ttc_etap_ds_udp              = (INT)  2978,   //  TTCs Enterprise Test Access Protocol - DS
04863             c_h263_video_tcp               = (INT)  2979,   //  H.263 Video Streaming
04864             c_h263_video_udp               = (INT)  2979,   //  H.263 Video Streaming
04865             c_mylxamport_tcp               = (INT)  2981,   //  MYLXAMPORT
04866             c_mylxamport_udp               = (INT)  2981,   //  MYLXAMPORT
04867             c_iwb_whiteboard_tcp           = (INT)  2982,   //  IWB-WHITEBOARD
04868             c_iwb_whiteboard_udp           = (INT)  2982,   //  IWB-WHITEBOARD
04869             c_netplan_tcp                  = (INT)  2983,   //  NETPLAN
04870             c_netplan_udp                  = (INT)  2983,   //  NETPLAN
04871             c_hpidsadmin_tcp               = (INT)  2984,   //  HPIDSADMIN
04872             c_hpidsadmin_udp               = (INT)  2984,   //  HPIDSADMIN
04873             c_hpidsagent_tcp               = (INT)  2985,   //  HPIDSAGENT
04874             c_hpidsagent_udp               = (INT)  2985,   //  HPIDSAGENT
04875             c_stonefalls_tcp               = (INT)  2986,   //  STONEFALLS
04876             c_stonefalls_udp               = (INT)  2986,   //  STONEFALLS
04877             c_identify_tcp                 = (INT)  2987,   //  identify
04878             c_identify_udp                 = (INT)  2987,   //  identify
04879             c_hippad_tcp                   = (INT)  2988,   //  HIPPA Reporting Protocol
04880             c_hippad_udp                   = (INT)  2988,   //  HIPPA Reporting Protocol
04881             c_zarkov_tcp                   = (INT)  2989,   //  ZARKOV
04882             c_zarkov_udp                   = (INT)  2989,   //  ZARKOV
04883             c_boscap_tcp                   = (INT)  2990,   //  BOSCAP
04884             c_boscap_udp                   = (INT)  2990,   //  BOSCAP
04885             c_wkstn_mon_tcp                = (INT)  2991,   //  WKSTN-MON
04886             c_wkstn_mon_udp                = (INT)  2991,   //  WKSTN-MON
04887             c_itb301_tcp                   = (INT)  2992,   //  ITB301
04888             c_itb301_udp                   = (INT)  2992,   //  ITB301
04889             c_veritas_vis1_tcp             = (INT)  2993,   //  VERITAS VIS1
04890             c_veritas_vis1_udp             = (INT)  2993,   //  VERITAS VIS1
04891             c_veritas_vis2_tcp             = (INT)  2994,   //  VERITAS VIS2
04892             c_veritas_vis2_udp             = (INT)  2994,   //  VERITAS VIS2
04893             c_idrs_tcp                     = (INT)  2995,   //  IDRS
04894             c_idrs_udp                     = (INT)  2995,   //  IDRS
04895             c_vsixml_tcp                   = (INT)  2996,   //  vsixml
04896             c_vsixml_udp                   = (INT)  2996,   //  vsixml
04897             c_rebol_tcp                    = (INT)  2997,   //  REBOL
04898             c_rebol_udp                    = (INT)  2997,   //  REBOL
04899             c_realsecure_tcp               = (INT)  2998,   //  Real Secure
04900             c_realsecure_udp               = (INT)  2998,   //  Real Secure
04901             c_remoteware_un_tcp            = (INT)  2999,   //  RemoteWare Unassigned
04902             c_remoteware_un_udp            = (INT)  2999,   //  RemoteWare Unassigned
04903             c_hbci_tcp                     = (INT)  3000,   //  HBCI
04904             c_hbci_udp                     = (INT)  3000,   //  HBCI
04905             c_remoteware_cl_tcp            = (INT)  3000,   //  RemoteWare Client
04906             c_remoteware_cl_udp            = (INT)  3000,   //  RemoteWare Client
04907             c_redwood_broker_tcp           = (INT)  3001,   //  Redwood Broker
04908             c_redwood_broker_udp           = (INT)  3001,   //  Redwood Broker
04909             c_exlm_agent_tcp               = (INT)  3002,   //  EXLM Agent
04910             c_exlm_agent_udp               = (INT)  3002,   //  EXLM Agent
04911             c_remoteware_srv_tcp           = (INT)  3002,   //  RemoteWare Server
04912             c_remoteware_srv_udp           = (INT)  3002,   //  RemoteWare Server
04913             c_cgms_tcp                     = (INT)  3003,   //  CGMS
04914             c_cgms_udp                     = (INT)  3003,   //  CGMS
04915             c_csoftragent_tcp              = (INT)  3004,   //  Csoft Agent
04916             c_csoftragent_udp              = (INT)  3004,   //  Csoft Agent
04917             c_geniuslm_tcp                 = (INT)  3005,   //  Genius License Manager
04918             c_geniuslm_udp                 = (INT)  3005,   //  Genius License Manager
04919             c_ii_admin_tcp                 = (INT)  3006,   //  Instant Internet Admin
04920             c_ii_admin_udp                 = (INT)  3006,   //  Instant Internet Admin
04921             c_lotusmtap_tcp                = (INT)  3007,   //  Lotus Mail Tracking Agent Protocol
04922             c_lotusmtap_udp                = (INT)  3007,   //  Lotus Mail Tracking Agent Protocol
04923             c_midnight_tech_tcp            = (INT)  3008,   //  Midnight Technologies
04924             c_midnight_tech_udp            = (INT)  3008,   //  Midnight Technologies
04925             c_pxc_ntfy_tcp                 = (INT)  3009,   //  PXC-NTFY
04926             c_pxc_ntfy_udp                 = (INT)  3009,   //  PXC-NTFY
04927             c_gw_tcp                       = (INT)  3010,   //  Telerate Workstation
04928             c_ping_pong_udp                = (INT)  3010,   //  Telerate Workstation
04929             c_trusted_web_tcp              = (INT)  3011,   //  Trusted Web
04930             c_trusted_web_udp              = (INT)  3011,   //  Trusted Web
04931             c_twsdss_tcp                   = (INT)  3012,   //  Trusted Web Client
04932             c_twsdss_udp                   = (INT)  3012,   //  Trusted Web Client
04933             c_gilatskysurfer_tcp           = (INT)  3013,   //  Gilat Sky Surfer
04934             c_gilatskysurfer_udp           = (INT)  3013,   //  Gilat Sky Surfer
04935             c_nati_dstp_tcp                = (INT)  3015,   //  NATI DSTP
04936             c_nati_dstp_udp                = (INT)  3015,   //  NATI DSTP
04937             c_cifs_tcp                     = (INT)  3020,   //  CIFS
04938             c_cifs_udp                     = (INT)  3020,   //  CIFS
04939             c_agriserver_tcp               = (INT)  3021,   //  AGRI Server
04940             c_agriserver_udp               = (INT)  3021,   //  AGRI Server
04941             c_csregagent_tcp               = (INT)  3022,   //  CSREGAGENT
04942             c_csregagent_udp               = (INT)  3022,   //  CSREGAGENT
04943             c_magicnotes_tcp               = (INT)  3023,   //  magicnotes
04944             c_magicnotes_udp               = (INT)  3023,   //  magicnotes
04945             c_arepa_raft_tcp               = (INT)  3025,   //  Arepa Raft
04946             c_arepa_raft_udp               = (INT)  3025,   //  Arepa Raft
04947             c_agri_gateway_tcp             = (INT)  3026,   //  AGRI Gateway
04948             c_agri_gateway_udp             = (INT)  3026,   //  AGRI Gateway
04949             c_arepa_cas_tcp                = (INT)  3030,   //  Arepa Cas
04950             c_arepa_cas_udp                = (INT)  3030,   //  Arepa Cas
04951             c_eppc_tcp                     = (INT)  3031,   //  Remote AppleEvents/PPC Toolbox
04952             c_eppc_udp                     = (INT)  3031,   //  Remote AppleEvents/PPC Toolbox
04953             c_redwood_chat_tcp             = (INT)  3032,   //  Redwood Chat
04954             c_redwood_chat_udp             = (INT)  3032,   //  Redwood Chat
04955             c_pdb_tcp                      = (INT)  3033,   //  PDB
04956             c_pdb_udp                      = (INT)  3033,   //  PDB
04957             c_osmosis_aeea_tcp             = (INT)  3034,   //  Osmosis AEEA
04958             c_osmosis_aeea_udp             = (INT)  3034,   //  Osmosis AEEA
04959             c_fjsv_gssagt_tcp              = (INT)  3035,   //  FJSV gssagt
04960             c_fjsv_gssagt_udp              = (INT)  3035,   //  FJSV gssagt
04961             c_hagel_dump_tcp               = (INT)  3036,   //  Hagel DUMP
04962             c_hagel_dump_udp               = (INT)  3036,   //  Hagel DUMP
04963             c_hp_san_mgmt_tcp              = (INT)  3037,   //  HP SAN Mgmt
04964             c_hp_san_mgmt_udp              = (INT)  3037,   //  HP SAN Mgmt
04965             c_santak_ups_tcp               = (INT)  3038,   //  Santak UPS
04966             c_santak_ups_udp               = (INT)  3038,   //  Santak UPS
04967             c_cogitate_tcp                 = (INT)  3039,   //  Cogitate, Inc.
04968             c_cogitate_udp                 = (INT)  3039,   //  Cogitate, Inc.
04969             c_tomato_springs_tcp           = (INT)  3040,   //  Tomato Springs
04970             c_tomato_springs_udp           = (INT)  3040,   //  Tomato Springs
04971             c_di_traceware_tcp             = (INT)  3041,   //  di-traceware
04972             c_di_traceware_udp             = (INT)  3041,   //  di-traceware
04973             c_journee_tcp                  = (INT)  3042,   //  journee
04974             c_journee_udp                  = (INT)  3042,   //  journee
04975             c_brp_tcp                      = (INT)  3043,   //  BRP
04976             c_brp_udp                      = (INT)  3043,   //  BRP
04977             c_epp_tcp                      = (INT)  3044,   //  EndPoint Protocol
04978             c_epp_udp                      = (INT)  3044,   //  EndPoint Protocol
04979             c_responsenet_tcp              = (INT)  3045,   //  ResponseNet
04980             c_responsenet_udp              = (INT)  3045,   //  ResponseNet
04981             c_di_ase_tcp                   = (INT)  3046,   //  di-ase
04982             c_di_ase_udp                   = (INT)  3046,   //  di-ase
04983             c_hlserver_1_tcp               = (INT)  3047,   //  Fast Security HL Server
04984             c_hlserver_1_udp               = (INT)  3047,   //  Fast Security HL Server
04985             c_pctrader_tcp                 = (INT)  3048,   //  Sierra Net PC Trader
04986             c_pctrader_udp                 = (INT)  3048,   //  Sierra Net PC Trader
04987             c_nsws_tcp                     = (INT)  3049,   //  NSWS
04988             c_nsws_udp                     = (INT)  3049,   //  NSWS
04989             c_galaxy_server_tcp            = (INT)  3051,   //  Galaxy Server
04990             c_galaxy_server_udp            = (INT)  3051,   //  Galaxy Server
04991             c_apcpcns_tcp                  = (INT)  3052,   //  APCPCNS
04992             c_apcpcns_udp                  = (INT)  3052,   //  APCPCNS
04993             c_dsom_server_tcp              = (INT)  3053,   //  dsom-server
04994             c_dsom_server_udp              = (INT)  3053,   //  dsom-server
04995             c_amt_cnf_prot_tcp             = (INT)  3054,   //  AMT CNF PROT
04996             c_amt_cnf_prot_udp             = (INT)  3054,   //  AMT CNF PROT
04997             c_policyserver_tcp             = (INT)  3055,   //  Policy Server
04998             c_policyserver_udp             = (INT)  3055,   //  Policy Server
04999             c_cdl_server_tcp               = (INT)  3056,   //  CDL Server
05000             c_cdl_server_udp               = (INT)  3056,   //  CDL Server
05001             c_goahead_fldup_tcp            = (INT)  3057,   //  GoAhead FldUp
05002             c_goahead_fldup_udp            = (INT)  3057,   //  GoAhead FldUp
05003             c_videobeans_tcp               = (INT)  3058,   //  videobeans
05004             c_videobeans_udp               = (INT)  3058,   //  videobeans
05005             c_qsoft_tcp                    = (INT)  3059,   //  qsoft
05006             c_qsoft_udp                    = (INT)  3059,   //  qsoft
05007             c_interserver_tcp              = (INT)  3060,   //  interserver
05008             c_interserver_udp              = (INT)  3060,   //  interserver
05009             c_cautcpd_tcp                  = (INT)  3061,   //  cautcpd
05010             c_cautcpd_udp                  = (INT)  3061,   //  cautcpd
05011             c_ncacn_ip_tcp_tcp             = (INT)  3062,   //  ncacn-ip-tcp
05012             c_ncacn_ip_tcp_udp             = (INT)  3062,   //  ncacn-ip-tcp
05013             c_ncadg_ip_udp_tcp             = (INT)  3063,   //  ncadg-ip-udp
05014             c_ncadg_ip_udp_udp             = (INT)  3063,   //  ncadg-ip-udp
05015             c_rprt_tcp                     = (INT)  3064,   //  Remote Port Redirector
05016             c_rprt_udp                     = (INT)  3064,   //  Remote Port Redirector
05017             c_slinterbase_tcp              = (INT)  3065,   //  slinterbase
05018             c_slinterbase_udp              = (INT)  3065,   //  slinterbase
05019             c_netattachsdmp_tcp            = (INT)  3066,   //  NETATTACHSDMP
05020             c_netattachsdmp_udp            = (INT)  3066,   //  NETATTACHSDMP
05021             c_fjhpjp_tcp                   = (INT)  3067,   //  FJHPJP
05022             c_fjhpjp_udp                   = (INT)  3067,   //  FJHPJP
05023             c_ls3bcast_tcp                 = (INT)  3068,   //  ls3 Broadcast
05024             c_ls3bcast_udp                 = (INT)  3068,   //  ls3 Broadcast
05025             c_ls3_tcp                      = (INT)  3069,   //  ls3
05026             c_ls3_udp                      = (INT)  3069,   //  ls3
05027             c_mgxswitch_tcp                = (INT)  3070,   //  MGXSWITCH
05028             c_mgxswitch_udp                = (INT)  3070,   //  MGXSWITCH
05029             c_csd_mgmt_port_tcp            = (INT)  3071,   //  ContinuStor Manager Port
05030             c_csd_mgmt_port_udp            = (INT)  3071,   //  ContinuStor Manager Port
05031             c_csd_monitor_tcp              = (INT)  3072,   //  ContinuStor Monitor Port
05032             c_csd_monitor_udp              = (INT)  3072,   //  ContinuStor Monitor Port
05033             c_vcrp_tcp                     = (INT)  3073,   //  Very simple chatroom prot
05034             c_vcrp_udp                     = (INT)  3073,   //  Very simple chatroom prot
05035             c_xbox_tcp                     = (INT)  3074,   //  Xbox game port
05036             c_xbox_udp                     = (INT)  3074,   //  Xbox game port
05037             c_orbix_locator_tcp            = (INT)  3075,   //  Orbix 2000 Locator
05038             c_orbix_locator_udp            = (INT)  3075,   //  Orbix 2000 Locator
05039             c_orbix_config_tcp             = (INT)  3076,   //  Orbix 2000 Config
05040             c_orbix_config_udp             = (INT)  3076,   //  Orbix 2000 Config
05041             c_orbix_loc_ssl_tcp            = (INT)  3077,   //  Orbix 2000 Locator SSL
05042             c_orbix_loc_ssl_udp            = (INT)  3077,   //  Orbix 2000 Locator SSL
05043             c_orbix_cfg_ssl_tcp            = (INT)  3078,   //  Orbix 2000 Locator SSL
05044             c_orbix_cfg_ssl_udp            = (INT)  3078,   //  Orbix 2000 Locator SSL
05045             c_lv_frontpanel_tcp            = (INT)  3079,   //  LV Front Panel
05046             c_lv_frontpanel_udp            = (INT)  3079,   //  LV Front Panel
05047             c_tl1_lv_tcp                   = (INT)  3081,   //  TL1-LV
05048             c_tl1_lv_udp                   = (INT)  3081,   //  TL1-LV
05049             c_tl1_raw_tcp                  = (INT)  3082,   //  TL1-RAW
05050             c_tl1_raw_udp                  = (INT)  3082,   //  TL1-RAW
05051             c_tl1_telnet_tcp               = (INT)  3083,   //  TL1-TELNET
05052             c_tl1_telnet_udp               = (INT)  3083,   //  TL1-TELNET
05053             c_itm_mccs_tcp                 = (INT)  3084,   //  ITM-MCCS
05054             c_itm_mccs_udp                 = (INT)  3084,   //  ITM-MCCS
05055             c_pcihreq_tcp                  = (INT)  3085,   //  PCIHReq
05056             c_pcihreq_udp                  = (INT)  3085,   //  PCIHReq
05057             c_jdl_dbkitchen_tcp            = (INT)  3086,   //  JDL-DBKitchen
05058             c_jdl_dbkitchen_udp            = (INT)  3086,   //  JDL-DBKitchen
05059             c_asoki_sma_tcp                = (INT)  3087,   //  Asoki SMA
05060             c_asoki_sma_udp                = (INT)  3087,   //  Asoki SMA
05061             c_xdtp_tcp                     = (INT)  3088,   //  eXtensible Data Transfer Protocol
05062             c_xdtp_udp                     = (INT)  3088,   //  eXtensible Data Transfer Protocol
05063             c_ptk_alink_tcp                = (INT)  3089,   //  ParaTek Agent Linking
05064             c_ptk_alink_udp                = (INT)  3089,   //  ParaTek Agent Linking
05065             c_rtss_tcp                     = (INT)  3090,   //  Rappore Session Services
05066             c_rtss_udp                     = (INT)  3090,   //  Rappore Session Services
05067             c_1ci_smcs_tcp                 = (INT)  3091,   //  1Ci Server Management
05068             c_1ci_smcs_udp                 = (INT)  3091,   //  1Ci Server Management
05069             c_njfss_tcp                    = (INT)  3092,   //  Netware sync services
05070             c_njfss_udp                    = (INT)  3092,   //  Netware sync services
05071             c_rapidmq_center_tcp           = (INT)  3093,   //  Jiiva RapidMQ Center
05072             c_rapidmq_center_udp           = (INT)  3093,   //  Jiiva RapidMQ Center
05073             c_rapidmq_reg_tcp              = (INT)  3094,   //  Jiiva RapidMQ Registry
05074             c_rapidmq_reg_udp              = (INT)  3094,   //  Jiiva RapidMQ Registry
05075             c_panasas_tcp                  = (INT)  3095,   //  Panasas rendevous port
05076             c_panasas_udp                  = (INT)  3095,   //  Panasas rendevous port
05077             c_ndl_aps_tcp                  = (INT)  3096,   //  Active Print Server Port
05078             c_ndl_aps_udp                  = (INT)  3096,   //  Active Print Server Port
05079             c_ituq2150_3_stc_sctp          = (INT)  3097,   //  ITU Q.2150.3 STC
05080             c_umm_port_tcp                 = (INT)  3098,   //  Universal Message Manager
05081             c_umm_port_udp                 = (INT)  3098,   //  Universal Message Manager
05082             c_chmd_tcp                     = (INT)  3099,   //  CHIPSY Machine Daemon
05083             c_chmd_udp                     = (INT)  3099,   //  CHIPSY Machine Daemon
05084             c_opcon_xps_tcp                = (INT)  3100,   //  OpCon/xps
05085             c_opcon_xps_udp                = (INT)  3100,   //  OpCon/xps
05086             c_hp_pxpib_tcp                 = (INT)  3101,   //  HP PolicyXpert PIB Server
05087             c_hp_pxpib_udp                 = (INT)  3101,   //  HP PolicyXpert PIB Server
05088             c_slslavemon_tcp               = (INT)  3102,   //  SoftlinK Slave Mon Port
05089             c_slslavemon_udp               = (INT)  3102,   //  SoftlinK Slave Mon Port
05090             c_autocuesmi_tcp               = (INT)  3103,   //  Autocue SMI Protocol
05091             c_autocuesmi_udp               = (INT)  3103,   //  Autocue SMI Protocol
05092             c_autocuelog_tcp               = (INT)  3104,   //  Autocue Logger Protocol
05093             c_autocuetime_udp              = (INT)  3104,   //  Autocue Time Service
05094             c_cardbox_tcp                  = (INT)  3105,   //  Cardbox
05095             c_cardbox_udp                  = (INT)  3105,   //  Cardbox
05096             c_cardbox_http_tcp             = (INT)  3106,   //  Cardbox HTTP
05097             c_cardbox_http_udp             = (INT)  3106,   //  Cardbox HTTP
05098             c_business_tcp                 = (INT)  3107,   //  Business protocol
05099             c_business_udp                 = (INT)  3107,   //  Business protocol
05100             c_geolocate_tcp                = (INT)  3108,   //  Geolocate protocol
05101             c_geolocate_udp                = (INT)  3108,   //  Geolocate protocol
05102             c_personnel_tcp                = (INT)  3109,   //  Personnel protocol
05103             c_personnel_udp                = (INT)  3109,   //  Personnel protocol
05104             c_sim_control_tcp              = (INT)  3110,   //  simulator control port
05105             c_sim_control_udp              = (INT)  3110,   //  simulator control port
05106             c_wsynch_tcp                   = (INT)  3111,   //  Web Synchronous Services
05107             c_wsynch_udp                   = (INT)  3111,   //  Web Synchronous Services
05108             c_ksysguard_tcp                = (INT)  3112,   //  KDE System Guard
05109             c_ksysguard_udp                = (INT)  3112,   //  KDE System Guard
05110             c_cs_auth_svr_tcp              = (INT)  3113,   //  CS-Authenticate Svr Port
05111             c_cs_auth_svr_udp              = (INT)  3113,   //  CS-Authenticate Svr Port
05112             c_ccmad_tcp                    = (INT)  3114,   //  CCM AutoDiscover
05113             c_ccmad_udp                    = (INT)  3114,   //  CCM AutoDiscover
05114             c_mctet_master_tcp             = (INT)  3115,   //  MCTET Master
05115             c_mctet_master_udp             = (INT)  3115,   //  MCTET Master
05116             c_mctet_gateway_tcp            = (INT)  3116,   //  MCTET Gateway
05117             c_mctet_gateway_udp            = (INT)  3116,   //  MCTET Gateway
05118             c_mctet_jserv_tcp              = (INT)  3117,   //  MCTET Jserv
05119             c_mctet_jserv_udp              = (INT)  3117,   //  MCTET Jserv
05120             c_pkagent_tcp                  = (INT)  3118,   //  PKAgent
05121             c_pkagent_udp                  = (INT)  3118,   //  PKAgent
05122             c_d2000kernel_tcp              = (INT)  3119,   //  D2000 Kernel Port
05123             c_d2000kernel_udp              = (INT)  3119,   //  D2000 Kernel Port
05124             c_d2000webserver_tcp           = (INT)  3120,   //  D2000 Webserver Port
05125             c_d2000webserver_udp           = (INT)  3120,   //  D2000 Webserver Port
05126             c_epp_temp_tcp                 = (INT)  3121,   //  Extensible Provisioning Protocol
05127             c_epp_temp_udp                 = (INT)  3121,   //  Extensible Provisioning Protocol
05128             c_vtr_emulator_tcp             = (INT)  3122,   //  MTI VTR Emulator port
05129             c_vtr_emulator_udp             = (INT)  3122,   //  MTI VTR Emulator port
05130             c_edix_tcp                     = (INT)  3123,   //  EDI Translation Protocol
05131             c_edix_udp                     = (INT)  3123,   //  EDI Translation Protocol
05132             c_beacon_port_tcp              = (INT)  3124,   //  Beacon Port
05133             c_beacon_port_udp              = (INT)  3124,   //  Beacon Port
05134             c_a13_an_tcp                   = (INT)  3125,   //  A13-AN Interface
05135             c_a13_an_udp                   = (INT)  3125,   //  A13-AN Interface
05136             c_ms_dotnetster_tcp            = (INT)  3126,   //  Microsoft .NETster Port
05137             c_ms_dotnetster_udp            = (INT)  3126,   //  Microsoft .NETster Port
05138             c_ctx_bridge_tcp               = (INT)  3127,   //  CTX Bridge Port
05139             c_ctx_bridge_udp               = (INT)  3127,   //  CTX Bridge Port
05140             c_ndl_aas_tcp                  = (INT)  3128,   //  Active API Server Port
05141             c_ndl_aas_udp                  = (INT)  3128,   //  Active API Server Port
05142             c_netport_id_tcp               = (INT)  3129,   //  NetPort Discovery Port
05143             c_netport_id_udp               = (INT)  3129,   //  NetPort Discovery Port
05144             c_icpv2_tcp                    = (INT)  3130,   //  ICPv2
05145             c_icpv2_udp                    = (INT)  3130,   //  ICPv2
05146             c_netbookmark_tcp              = (INT)  3131,   //  Net Book Mark
05147             c_netbookmark_udp              = (INT)  3131,   //  Net Book Mark
05148             c_ms_slipstream_tcp            = (INT)  3132,   //  MS-Slipstream
05149             c_ms_slipstream_udp            = (INT)  3132,   //  MS-Slipstream
05150             c_prism_deploy_tcp             = (INT)  3133,   //  Prism Deploy User Port
05151             c_prism_deploy_udp             = (INT)  3133,   //  Prism Deploy User Port
05152             c_ecp_tcp                      = (INT)  3134,   //  Extensible Code Protocol
05153             c_ecp_udp                      = (INT)  3134,   //  Extensible Code Protocol
05154             c_peerbook_port_tcp            = (INT)  3135,   //  PeerBook Port
05155             c_peerbook_port_udp            = (INT)  3135,   //  PeerBook Port
05156             c_grubd_tcp                    = (INT)  3136,   //  Grub Server Port
05157             c_grubd_udp                    = (INT)  3136,   //  Grub Server Port
05158             c_rtnt_1_tcp                   = (INT)  3137,   //  rtnt-1 data packets
05159             c_rtnt_1_udp                   = (INT)  3137,   //  rtnt-1 data packets
05160             c_rtnt_2_tcp                   = (INT)  3138,   //  rtnt-2 data packets
05161             c_rtnt_2_udp                   = (INT)  3138,   //  rtnt-2 data packets
05162             c_incognitorv_tcp              = (INT)  3139,   //  Incognito Rendez-Vous
05163             c_incognitorv_udp              = (INT)  3139,   //  Incognito Rendez-Vous
05164             c_ariliamulti_tcp              = (INT)  3140,   //  Arilia Multiplexor
05165             c_ariliamulti_udp              = (INT)  3140,   //  Arilia Multiplexor
05166             c_vmodem_tcp                   = (INT)  3141,   //  VMODEM
05167             c_vmodem_udp                   = (INT)  3141,   //  VMODEM
05168             c_rdc_wh_eos_tcp               = (INT)  3142,   //  RDC WH EOS
05169             c_rdc_wh_eos_udp               = (INT)  3142,   //  RDC WH EOS
05170             c_seaview_tcp                  = (INT)  3143,   //  Sea View
05171             c_seaview_udp                  = (INT)  3143,   //  Sea View
05172             c_tarantella_tcp               = (INT)  3144,   //  Tarantella
05173             c_tarantella_udp               = (INT)  3144,   //  Tarantella
05174             c_csi_lfap_tcp                 = (INT)  3145,   //  CSI-LFAP
05175             c_csi_lfap_udp                 = (INT)  3145,   //  CSI-LFAP
05176             c_bears_02_tcp                 = (INT)  3146,   //  bears-02
05177             c_bears_02_udp                 = (INT)  3146,   //  bears-02
05178             c_rfio_tcp                     = (INT)  3147,   //  RFIO
05179             c_rfio_udp                     = (INT)  3147,   //  RFIO
05180             c_nm_game_admin_tcp            = (INT)  3148,   //  NetMike Game Administrator
05181             c_nm_game_admin_udp            = (INT)  3148,   //  NetMike Game Administrator
05182             c_nm_game_server_tcp           = (INT)  3149,   //  NetMike Game Server
05183             c_nm_game_server_udp           = (INT)  3149,   //  NetMike Game Server
05184             c_nm_asses_admin_tcp           = (INT)  3150,   //  NetMike Assessor Administrator
05185             c_nm_asses_admin_udp           = (INT)  3150,   //  NetMike Assessor Administrator
05186             c_nm_assessor_tcp              = (INT)  3151,   //  NetMike Assessor
05187             c_nm_assessor_udp              = (INT)  3151,   //  NetMike Assessor
05188             c_feitianrockey_tcp            = (INT)  3152,   //  FeiTian Port
05189             c_feitianrockey_udp            = (INT)  3152,   //  FeiTian Port
05190             c_s8_client_port_tcp           = (INT)  3153,   //  S8Cargo Client Port
05191             c_s8_client_port_udp           = (INT)  3153,   //  S8Cargo Client Port
05192             c_ccmrmi_tcp                   = (INT)  3154,   //  ON RMI Registry
05193             c_ccmrmi_udp                   = (INT)  3154,   //  ON RMI Registry
05194             c_jpegmpeg_tcp                 = (INT)  3155,   //  JpegMpeg Port
05195             c_jpegmpeg_udp                 = (INT)  3155,   //  JpegMpeg Port
05196             c_indura_tcp                   = (INT)  3156,   //  Indura Collector
05197             c_indura_udp                   = (INT)  3156,   //  Indura Collector
05198             c_e3consultants_tcp            = (INT)  3157,   //  CCC Listener Port
05199             c_e3consultants_udp            = (INT)  3157,   //  CCC Listener Port
05200             c_stvp_tcp                     = (INT)  3158,   //  SmashTV Protocol
05201             c_stvp_udp                     = (INT)  3158,   //  SmashTV Protocol
05202             c_navegaweb_port_tcp           = (INT)  3159,   //  NavegaWeb Tarification
05203             c_navegaweb_port_udp           = (INT)  3159,   //  NavegaWeb Tarification
05204             c_tip_app_server_tcp           = (INT)  3160,   //  TIP Application Server
05205             c_tip_app_server_udp           = (INT)  3160,   //  TIP Application Server
05206             c_doc1lm_tcp                   = (INT)  3161,   //  DOC1 License Manager
05207             c_doc1lm_udp                   = (INT)  3161,   //  DOC1 License Manager
05208             c_sflm_tcp                     = (INT)  3162,   //  SFLM
05209             c_sflm_udp                     = (INT)  3162,   //  SFLM
05210             c_res_sap_tcp                  = (INT)  3163,   //  RES-SAP
05211             c_res_sap_udp                  = (INT)  3163,   //  RES-SAP
05212             c_imprs_tcp                    = (INT)  3164,   //  IMPRS
05213             c_imprs_udp                    = (INT)  3164,   //  IMPRS
05214             c_newgenpay_tcp                = (INT)  3165,   //  Newgenpay Engine Service
05215             c_newgenpay_udp                = (INT)  3165,   //  Newgenpay Engine Service
05216             c_qrepos_tcp                   = (INT)  3166,   //  Quest Repository
05217             c_qrepos_udp                   = (INT)  3166,   //  Quest Repository
05218             c_poweroncontact_tcp           = (INT)  3167,   //  poweroncontact
05219             c_poweroncontact_udp           = (INT)  3167,   //  poweroncontact
05220             c_poweronnud_tcp               = (INT)  3168,   //  poweronnud
05221             c_poweronnud_udp               = (INT)  3168,   //  poweronnud
05222             c_serverview_as_tcp            = (INT)  3169,   //  SERVERVIEW-AS
05223             c_serverview_as_udp            = (INT)  3169,   //  SERVERVIEW-AS
05224             c_serverview_asn_tcp           = (INT)  3170,   //  SERVERVIEW-ASN
05225             c_serverview_asn_udp           = (INT)  3170,   //  SERVERVIEW-ASN
05226             c_serverview_gf_tcp            = (INT)  3171,   //  SERVERVIEW-GF
05227             c_serverview_gf_udp            = (INT)  3171,   //  SERVERVIEW-GF
05228             c_serverview_rm_tcp            = (INT)  3172,   //  SERVERVIEW-RM
05229             c_serverview_rm_udp            = (INT)  3172,   //  SERVERVIEW-RM
05230             c_serverview_icc_tcp           = (INT)  3173,   //  SERVERVIEW-ICC
05231             c_serverview_icc_udp           = (INT)  3173,   //  SERVERVIEW-ICC
05232             c_armi_server_tcp              = (INT)  3174,   //  ARMI Server
05233             c_armi_server_udp              = (INT)  3174,   //  ARMI Server
05234             c_t1_e1_over_ip_tcp            = (INT)  3175,   //  T1_E1_Over_IP
05235             c_t1_e1_over_ip_udp            = (INT)  3175,   //  T1_E1_Over_IP
05236             c_ars_master_tcp               = (INT)  3176,   //  ARS Master
05237             c_ars_master_udp               = (INT)  3176,   //  ARS Master
05238             c_phonex_port_tcp              = (INT)  3177,   //  Phonex Protocol
05239             c_phonex_port_udp              = (INT)  3177,   //  Phonex Protocol
05240             c_radclientport_tcp            = (INT)  3178,   //  Radiance UltraEdge Port
05241             c_radclientport_udp            = (INT)  3178,   //  Radiance UltraEdge Port
05242             c_h2gf_w_2m_tcp                = (INT)  3179,   //  H2GF W.2m Handover prot.
05243             c_h2gf_w_2m_udp                = (INT)  3179,   //  H2GF W.2m Handover prot.
05244             c_mc_brk_srv_tcp               = (INT)  3180,   //  Millicent Broker Server
05245             c_mc_brk_srv_udp               = (INT)  3180,   //  Millicent Broker Server
05246             c_bmcpatrolagent_tcp           = (INT)  3181,   //  BMC Patrol Agent
05247             c_bmcpatrolagent_udp           = (INT)  3181,   //  BMC Patrol Agent
05248             c_bmcpatrolrnvu_tcp            = (INT)  3182,   //  BMC Patrol Rendezvous
05249             c_bmcpatrolrnvu_udp            = (INT)  3182,   //  BMC Patrol Rendezvous
05250             c_cops_tls_tcp                 = (INT)  3183,   //  COPS/TLS
05251             c_cops_tls_udp                 = (INT)  3183,   //  COPS/TLS
05252             c_apogeex_port_tcp             = (INT)  3184,   //  ApogeeX Port
05253             c_apogeex_port_udp             = (INT)  3184,   //  ApogeeX Port
05254             c_smpppd_tcp                   = (INT)  3185,   //  SuSE Meta PPPD
05255             c_smpppd_udp                   = (INT)  3185,   //  SuSE Meta PPPD
05256             c_iiw_port_tcp                 = (INT)  3186,   //  IIW Monitor User Port
05257             c_iiw_port_udp                 = (INT)  3186,   //  IIW Monitor User Port
05258             c_odi_port_tcp                 = (INT)  3187,   //  Open Design Listen Port
05259             c_odi_port_udp                 = (INT)  3187,   //  Open Design Listen Port
05260             c_brcm_comm_port_tcp           = (INT)  3188,   //  Broadcom Port
05261             c_brcm_comm_port_udp           = (INT)  3188,   //  Broadcom Port
05262             c_pcle_infex_tcp               = (INT)  3189,   //  Pinnacle Sys InfEx Port
05263             c_pcle_infex_udp               = (INT)  3189,   //  Pinnacle Sys InfEx Port
05264             c_csvr_proxy_tcp               = (INT)  3190,   //  ConServR Proxy
05265             c_csvr_proxy_udp               = (INT)  3190,   //  ConServR Proxy
05266             c_csvr_sslproxy_tcp            = (INT)  3191,   //  ConServR SSL Proxy
05267             c_csvr_sslproxy_udp            = (INT)  3191,   //  ConServR SSL Proxy
05268             c_firemonrcc_tcp               = (INT)  3192,   //  FireMon Revision Control
05269             c_firemonrcc_udp               = (INT)  3192,   //  FireMon Revision Control
05270             c_cordataport_tcp              = (INT)  3193,   //  Cordaxis Data Port
05271             c_cordataport_udp              = (INT)  3193,   //  Cordaxis Data Port
05272             c_magbind_tcp                  = (INT)  3194,   //  Rockstorm MAG protocol
05273             c_magbind_udp                  = (INT)  3194,   //  Rockstorm MAG protocol
05274             c_ncu_1_tcp                    = (INT)  3195,   //  Network Control Unit
05275             c_ncu_1_udp                    = (INT)  3195,   //  Network Control Unit
05276             c_ncu_2_tcp                    = (INT)  3196,   //  Network Control Unit
05277             c_ncu_2_udp                    = (INT)  3196,   //  Network Control Unit
05278             c_embrace_dp_s_tcp             = (INT)  3197,   //  Embrace Device Protocol Server
05279             c_embrace_dp_s_udp             = (INT)  3197,   //  Embrace Device Protocol Server
05280             c_embrace_dp_c_tcp             = (INT)  3198,   //  Embrace Device Protocol Client
05281             c_embrace_dp_c_udp             = (INT)  3198,   //  Embrace Device Protocol Client
05282             c_dmod_workspace_tcp           = (INT)  3199,   //  DMOD WorkSpace
05283             c_dmod_workspace_udp           = (INT)  3199,   //  DMOD WorkSpace
05284             c_tick_port_tcp                = (INT)  3200,   //  Press-sense Tick Port
05285             c_tick_port_udp                = (INT)  3200,   //  Press-sense Tick Port
05286             c_cpq_tasksmart_tcp            = (INT)  3201,   //  CPQ-TaskSmart
05287             c_cpq_tasksmart_udp            = (INT)  3201,   //  CPQ-TaskSmart
05288             c_intraintra_tcp               = (INT)  3202,   //  IntraIntra
05289             c_intraintra_udp               = (INT)  3202,   //  IntraIntra
05290             c_netwatcher_mon_tcp           = (INT)  3203,   //  Network Watcher Monitor
05291             c_netwatcher_mon_udp           = (INT)  3203,   //  Network Watcher Monitor
05292             c_netwatcher_db_tcp            = (INT)  3204,   //  Network Watcher DB Access
05293             c_netwatcher_db_udp            = (INT)  3204,   //  Network Watcher DB Access
05294             c_isns_tcp                     = (INT)  3205,   //  iSNS Server Port
05295             c_isns_udp                     = (INT)  3205,   //  iSNS Server Port
05296             c_ironmail_tcp                 = (INT)  3206,   //  IronMail POP Proxy
05297             c_ironmail_udp                 = (INT)  3206,   //  IronMail POP Proxy
05298             c_vx_auth_port_tcp             = (INT)  3207,   //  Veritas Authentication Port
05299             c_vx_auth_port_udp             = (INT)  3207,   //  Veritas Authentication Port
05300             c_pfu_prcallback_tcp           = (INT)  3208,   //  PFU PR Callback
05301             c_pfu_prcallback_udp           = (INT)  3208,   //  PFU PR Callback
05302             c_netwkpathengine_tcp          = (INT)  3209,   //  HP OpenView Network Path Engine Server
05303             c_netwkpathengine_udp          = (INT)  3209,   //  HP OpenView Network Path Engine Server
05304             c_flamenco_proxy_tcp           = (INT)  3210,   //  Flamenco Networks Proxy
05305             c_flamenco_proxy_udp           = (INT)  3210,   //  Flamenco Networks Proxy
05306             c_avsecuremgmt_tcp             = (INT)  3211,   //  Avocent Secure Management
05307             c_avsecuremgmt_udp             = (INT)  3211,   //  Avocent Secure Management
05308             c_surveyinst_tcp               = (INT)  3212,   //  Survey Instrument
05309             c_surveyinst_udp               = (INT)  3212,   //  Survey Instrument
05310             c_neon24x7_tcp                 = (INT)  3213,   //  NEON 24X7 Mission Control
05311             c_neon24x7_udp                 = (INT)  3213,   //  NEON 24X7 Mission Control
05312             c_jmq_daemon_1_tcp             = (INT)  3214,   //  JMQ Daemon Port 1
05313             c_jmq_daemon_1_udp             = (INT)  3214,   //  JMQ Daemon Port 1
05314             c_jmq_daemon_2_tcp             = (INT)  3215,   //  JMQ Daemon Port 2
05315             c_jmq_daemon_2_udp             = (INT)  3215,   //  JMQ Daemon Port 2
05316             c_ferrari_foam_tcp             = (INT)  3216,   //  Ferrari electronic FOAM
05317             c_ferrari_foam_udp             = (INT)  3216,   //  Ferrari electronic FOAM
05318             c_unite_tcp                    = (INT)  3217,   //  Unified IP & Telecomm Env
05319             c_unite_udp                    = (INT)  3217,   //  Unified IP & Telecomm Env
05320             c_smartpackets_tcp             = (INT)  3218,   //  EMC SmartPackets
05321             c_smartpackets_udp             = (INT)  3218,   //  EMC SmartPackets
05322             c_wms_messenger_tcp            = (INT)  3219,   //  WMS Messenger
05323             c_wms_messenger_udp            = (INT)  3219,   //  WMS Messenger
05324             c_xnm_ssl_tcp                  = (INT)  3220,   //  XML NM over SSL
05325             c_xnm_ssl_udp                  = (INT)  3220,   //  XML NM over SSL
05326             c_xnm_clear_text_tcp           = (INT)  3221,   //  XML NM over TCP
05327             c_xnm_clear_text_udp           = (INT)  3221,   //  XML NM over TCP
05328             c_glbp_tcp                     = (INT)  3222,   //  Gateway Load Balancing Pr
05329             c_glbp_udp                     = (INT)  3222,   //  Gateway Load Balancing Pr
05330             c_digivote_tcp                 = (INT)  3223,   //  DIGIVOTE (R) Vote-Server
05331             c_digivote_udp                 = (INT)  3223,   //  DIGIVOTE (R) Vote-Server
05332             c_aes_discovery_tcp            = (INT)  3224,   //  AES Discovery Port
05333             c_aes_discovery_udp            = (INT)  3224,   //  AES Discovery Port
05334             c_fcip_port_tcp                = (INT)  3225,   //  FCIP
05335             c_fcip_port_udp                = (INT)  3225,   //  FCIP
05336             c_isi_irp_tcp                  = (INT)  3226,   //  ISI Industry Software IRP
05337             c_isi_irp_udp                  = (INT)  3226,   //  ISI Industry Software IRP
05338             c_dwnmshttp_tcp                = (INT)  3227,   //  DiamondWave NMS Server
05339             c_dwnmshttp_udp                = (INT)  3227,   //  DiamondWave NMS Server
05340             c_dwmsgserver_tcp              = (INT)  3228,   //  DiamondWave MSG Server
05341             c_dwmsgserver_udp              = (INT)  3228,   //  DiamondWave MSG Server
05342             c_global_cd_port_tcp           = (INT)  3229,   //  Global CD Port
05343             c_global_cd_port_udp           = (INT)  3229,   //  Global CD Port
05344             c_sftdst_port_tcp              = (INT)  3230,   //  Software Distributor Port
05345             c_sftdst_port_udp              = (INT)  3230,   //  Software Distributor Port
05346             c_dsnl_tcp                     = (INT)  3231,   //  Delta Solutions Direct
05347             c_dsnl_udp                     = (INT)  3231,   //  Delta Solutions Direct
05348             c_mdtp_tcp                     = (INT)  3232,   //  MDT port
05349             c_mdtp_udp                     = (INT)  3232,   //  MDT port
05350             c_whisker_tcp                  = (INT)  3233,   //  WhiskerControl main port
05351             c_whisker_udp                  = (INT)  3233,   //  WhiskerControl main port
05352             c_alchemy_tcp                  = (INT)  3234,   //  Alchemy Server
05353             c_alchemy_udp                  = (INT)  3234,   //  Alchemy Server
05354             c_mdap_port_tcp                = (INT)  3235,   //  MDAP port
05355             c_mdap_port_udp                = (INT)  3235,   //  MDAP Port
05356             c_apparenet_ts_tcp             = (INT)  3236,   //  appareNet Test Server
05357             c_apparenet_ts_udp             = (INT)  3236,   //  appareNet Test Server
05358             c_apparenet_tps_tcp            = (INT)  3237,   //  appareNet Test Packet Sequencer
05359             c_apparenet_tps_udp            = (INT)  3237,   //  appareNet Test Packet Sequencer
05360             c_apparenet_as_tcp             = (INT)  3238,   //  appareNet Analysis Server
05361             c_apparenet_as_udp             = (INT)  3238,   //  appareNet Analysis Server
05362             c_apparenet_ui_tcp             = (INT)  3239,   //  appareNet User Interface
05363             c_apparenet_ui_udp             = (INT)  3239,   //  appareNet User Interface
05364             c_triomotion_tcp               = (INT)  3240,   //  Trio Motion Control Port
05365             c_triomotion_udp               = (INT)  3240,   //  Trio Motion Control Port
05366             c_sysorb_tcp                   = (INT)  3241,   //  SysOrb Monitoring Server
05367             c_sysorb_udp                   = (INT)  3241,   //  SysOrb Monitoring Server
05368             c_sdp_id_port_tcp              = (INT)  3242,   //  Session Description ID
05369             c_sdp_id_port_udp              = (INT)  3242,   //  Session Description ID
05370             c_timelot_tcp                  = (INT)  3243,   //  Timelot Port
05371             c_timelot_udp                  = (INT)  3243,   //  Timelot Port
05372             c_onesaf_tcp                   = (INT)  3244,   //  OneSAF
05373             c_onesaf_udp                   = (INT)  3244,   //  OneSAF
05374             c_vieo_fe_tcp                  = (INT)  3245,   //  VIEO Fabric Executive
05375             c_vieo_fe_udp                  = (INT)  3245,   //  VIEO Fabric Executive
05376             c_dvt_system_tcp               = (INT)  3246,   //  DVT SYSTEM PORT
05377             c_dvt_system_udp               = (INT)  3246,   //  DVT SYSTEM PORT
05378             c_dvt_data_tcp                 = (INT)  3247,   //  DVT DATA LINK
05379             c_dvt_data_udp                 = (INT)  3247,   //  DVT DATA LINK
05380             c_procos_lm_tcp                = (INT)  3248,   //  PROCOS LM
05381             c_procos_lm_udp                = (INT)  3248,   //  PROCOS LM
05382             c_ssp_tcp                      = (INT)  3249,   //  State Sync Protocol
05383             c_ssp_udp                      = (INT)  3249,   //  State Sync Protocol
05384             c_hicp_tcp                     = (INT)  3250,   //  HMS hicp port
05385             c_hicp_udp                     = (INT)  3250,   //  HMS hicp port
05386             c_sysscanner_tcp               = (INT)  3251,   //  Sys Scanner
05387             c_sysscanner_udp               = (INT)  3251,   //  Sys Scanner
05388             c_dhe_tcp                      = (INT)  3252,   //  DHE port
05389             c_dhe_udp                      = (INT)  3252,   //  DHE port
05390             c_pda_data_tcp                 = (INT)  3253,   //  PDA Data
05391             c_pda_data_udp                 = (INT)  3253,   //  PDA Data
05392             c_pda_sys_tcp                  = (INT)  3254,   //  PDA System
05393             c_pda_sys_udp                  = (INT)  3254,   //  PDA System
05394             c_semaphore_tcp                = (INT)  3255,   //  Semaphore Connection Port
05395             c_semaphore_udp                = (INT)  3255,   //  Semaphore Connection Port
05396             c_cpqrpm_agent_tcp             = (INT)  3256,   //  Compaq RPM Agent Port
05397             c_cpqrpm_agent_udp             = (INT)  3256,   //  Compaq RPM Agent Port
05398             c_cpqrpm_server_tcp            = (INT)  3257,   //  Compaq RPM Server Port
05399             c_cpqrpm_server_udp            = (INT)  3257,   //  Compaq RPM Server Port
05400             c_ivecon_port_tcp              = (INT)  3258,   //  Ivecon Server Port
05401             c_ivecon_port_udp              = (INT)  3258,   //  Ivecon Server Port
05402             c_epncdp2_tcp                  = (INT)  3259,   //  Epson Network Common Devi
05403             c_epncdp2_udp                  = (INT)  3259,   //  Epson Network Common Devi
05404             c_iscsi_target_tcp             = (INT)  3260,   //  iSCSI port
05405             c_iscsi_target_udp             = (INT)  3260,   //  iSCSI port
05406             c_winshadow_tcp                = (INT)  3261,   //  winShadow
05407             c_winshadow_udp                = (INT)  3261,   //  winShadow
05408             c_necp_tcp                     = (INT)  3262,   //  NECP
05409             c_necp_udp                     = (INT)  3262,   //  NECP
05410             c_ecolor_imager_tcp            = (INT)  3263,   //  E-Color Enterprise Imager
05411             c_ecolor_imager_udp            = (INT)  3263,   //  E-Color Enterprise Imager
05412             c_ccmail_tcp                   = (INT)  3264,   //  cc:mail/lotus
05413             c_ccmail_udp                   = (INT)  3264,   //  cc:mail/lotus
05414             c_altav_tunnel_tcp             = (INT)  3265,   //  Altav Tunnel
05415             c_altav_tunnel_udp             = (INT)  3265,   //  Altav Tunnel
05416             c_ns_cfg_server_tcp            = (INT)  3266,   //  NS CFG Server
05417             c_ns_cfg_server_udp            = (INT)  3266,   //  NS CFG Server
05418             c_ibm_dial_out_tcp             = (INT)  3267,   //  IBM Dial Out
05419             c_ibm_dial_out_udp             = (INT)  3267,   //  IBM Dial Out
05420             c_msft_gc_tcp                  = (INT)  3268,   //  Microsoft Global Catalog
05421             c_msft_gc_udp                  = (INT)  3268,   //  Microsoft Global Catalog
05422             c_msft_gc_ssl_tcp              = (INT)  3269,   //  Microsoft Global Catalog with LDAP/SSL
05423             c_msft_gc_ssl_udp              = (INT)  3269,   //  Microsoft Global Catalog with LDAP/SSL
05424             c_verismart_tcp                = (INT)  3270,   //  Verismart
05425             c_verismart_udp                = (INT)  3270,   //  Verismart
05426             c_csoft_prev_tcp               = (INT)  3271,   //  CSoft Prev Port
05427             c_csoft_prev_udp               = (INT)  3271,   //  CSoft Prev Port
05428             c_user_manager_tcp             = (INT)  3272,   //  Fujitsu User Manager
05429             c_user_manager_udp             = (INT)  3272,   //  Fujitsu User Manager
05430             c_sxmp_tcp                     = (INT)  3273,   //  Simple Extensible Multiplexed Protocol
05431             c_sxmp_udp                     = (INT)  3273,   //  Simple Extensible Multiplexed Protocol
05432             c_ordinox_server_tcp           = (INT)  3274,   //  Ordinox Server
05433             c_ordinox_server_udp           = (INT)  3274,   //  Ordinox Server
05434             c_samd_tcp                     = (INT)  3275,   //  SAMD
05435             c_samd_udp                     = (INT)  3275,   //  SAMD
05436             c_maxim_asics_tcp              = (INT)  3276,   //  Maxim ASICs
05437             c_maxim_asics_udp              = (INT)  3276,   //  Maxim ASICs
05438             c_awg_proxy_tcp                = (INT)  3277,   //  AWG Proxy
05439             c_awg_proxy_udp                = (INT)  3277,   //  AWG Proxy
05440             c_lkcmserver_tcp               = (INT)  3278,   //  LKCM Server
05441             c_lkcmserver_udp               = (INT)  3278,   //  LKCM Server
05442             c_admind_tcp                   = (INT)  3279,   //  admind
05443             c_admind_udp                   = (INT)  3279,   //  admind
05444             c_vs_server_tcp                = (INT)  3280,   //  VS Server
05445             c_vs_server_udp                = (INT)  3280,   //  VS Server
05446             c_sysopt_tcp                   = (INT)  3281,   //  SYSOPT
05447             c_sysopt_udp                   = (INT)  3281,   //  SYSOPT
05448             c_datusorb_tcp                 = (INT)  3282,   //  Datusorb
05449             c_datusorb_udp                 = (INT)  3282,   //  Datusorb
05450             c_net_assistant_tcp            = (INT)  3283,   //  Net Assistant
05451             c_net_assistant_udp            = (INT)  3283,   //  Net Assistant
05452             c_4talk_tcp                    = (INT)  3284,   //  4Talk
05453             c_4talk_udp                    = (INT)  3284,   //  4Talk
05454             c_plato_tcp                    = (INT)  3285,   //  Plato
05455             c_plato_udp                    = (INT)  3285,   //  Plato
05456             c_e_net_tcp                    = (INT)  3286,   //  E-Net
05457             c_e_net_udp                    = (INT)  3286,   //  E-Net
05458             c_directvdata_tcp              = (INT)  3287,   //  DIRECTVDATA
05459             c_directvdata_udp              = (INT)  3287,   //  DIRECTVDATA
05460             c_cops_tcp                     = (INT)  3288,   //  COPS
05461             c_cops_udp                     = (INT)  3288,   //  COPS
05462             c_enpc_tcp                     = (INT)  3289,   //  ENPC
05463             c_enpc_udp                     = (INT)  3289,   //  ENPC
05464             c_caps_lm_tcp                  = (INT)  3290,   //  CAPS LOGISTICS TOOLKIT - LM
05465             c_caps_lm_udp                  = (INT)  3290,   //  CAPS LOGISTICS TOOLKIT - LM
05466             c_sah_lm_tcp                   = (INT)  3291,   //  S A Holditch & Associates - LM
05467             c_sah_lm_udp                   = (INT)  3291,   //  S A Holditch & Associates - LM
05468             c_cart_o_rama_tcp              = (INT)  3292,   //  Cart O Rama
05469             c_cart_o_rama_udp              = (INT)  3292,   //  Cart O Rama
05470             c_fg_fps_tcp                   = (INT)  3293,   //  fg-fps
05471             c_fg_fps_udp                   = (INT)  3293,   //  fg-fps
05472             c_fg_gip_tcp                   = (INT)  3294,   //  fg-gip
05473             c_fg_gip_udp                   = (INT)  3294,   //  fg-gip
05474             c_dyniplookup_tcp              = (INT)  3295,   //  Dynamic IP Lookup
05475             c_dyniplookup_udp              = (INT)  3295,   //  Dynamic IP Lookup
05476             c_rib_slm_tcp                  = (INT)  3296,   //  Rib License Manager
05477             c_rib_slm_udp                  = (INT)  3296,   //  Rib License Manager
05478             c_cytel_lm_tcp                 = (INT)  3297,   //  Cytel License Manager
05479             c_cytel_lm_udp                 = (INT)  3297,   //  Cytel License Manager
05480             c_transview_tcp                = (INT)  3298,   //  Transview
05481             c_transview_udp                = (INT)  3298,   //  Transview
05482             c_pdrncs_tcp                   = (INT)  3299,   //  pdrncs
05483             c_pdrncs_udp                   = (INT)  3299,   //  pdrncs
05484             c_mcs_fastmail_tcp             = (INT)  3302,   //  MCS Fastmail
05485             c_mcs_fastmail_udp             = (INT)  3302,   //  MCS Fastmail
05486             c_opsession_clnt_tcp           = (INT)  3303,   //  OP Session Client
05487             c_opsession_clnt_udp           = (INT)  3303,   //  OP Session Client
05488             c_opsession_srvr_tcp           = (INT)  3304,   //  OP Session Server
05489             c_opsession_srvr_udp           = (INT)  3304,   //  OP Session Server
05490             c_odette_ftp_tcp               = (INT)  3305,   //  ODETTE-FTP
05491             c_odette_ftp_udp               = (INT)  3305,   //  ODETTE-FTP
05492             c_mysql_tcp                    = (INT)  3306,   //  MySQL
05493             c_mysql_udp                    = (INT)  3306,   //  MySQL
05494             c_opsession_prxy_tcp           = (INT)  3307,   //  OP Session Proxy
05495             c_opsession_prxy_udp           = (INT)  3307,   //  OP Session Proxy
05496             c_tns_server_tcp               = (INT)  3308,   //  TNS Server
05497             c_tns_server_udp               = (INT)  3308,   //  TNS Server
05498             c_tns_adv_tcp                  = (INT)  3309,   //  TNS ADV
05499             c_tns_adv_udp                  = (INT)  3309,   //  TNS ADV
05500             c_dyna_access_tcp              = (INT)  3310,   //  Dyna Access
05501             c_dyna_access_udp              = (INT)  3310,   //  Dyna Access
05502             c_mcns_tel_ret_tcp             = (INT)  3311,   //  MCNS Tel Ret
05503             c_mcns_tel_ret_udp             = (INT)  3311,   //  MCNS Tel Ret
05504             c_appman_server_tcp            = (INT)  3312,   //  Application Management Server
05505             c_appman_server_udp            = (INT)  3312,   //  Application Management Server
05506             c_uorb_tcp                     = (INT)  3313,   //  Unify Object Broker
05507             c_uorb_udp                     = (INT)  3313,   //  Unify Object Broker
05508             c_uohost_tcp                   = (INT)  3314,   //  Unify Object Host
05509             c_uohost_udp                   = (INT)  3314,   //  Unify Object Host
05510             c_cdid_tcp                     = (INT)  3315,   //  CDID
05511             c_cdid_udp                     = (INT)  3315,   //  CDID
05512             c_aicc_cmi_tcp                 = (INT)  3316,   //  AICC/CMI
05513             c_aicc_cmi_udp                 = (INT)  3316,   //  AICC/CMI
05514             c_vsaiport_tcp                 = (INT)  3317,   //  VSAI PORT
05515             c_vsaiport_udp                 = (INT)  3317,   //  VSAI PORT
05516             c_ssrip_tcp                    = (INT)  3318,   //  Swith to Swith Routing Information Protocol
05517             c_ssrip_udp                    = (INT)  3318,   //  Swith to Swith Routing Information Protocol
05518             c_sdt_lmd_tcp                  = (INT)  3319,   //  SDT License Manager
05519             c_sdt_lmd_udp                  = (INT)  3319,   //  SDT License Manager
05520             c_officelink2000_tcp           = (INT)  3320,   //  Office Link 2000
05521             c_officelink2000_udp           = (INT)  3320,   //  Office Link 2000
05522             c_vnsstr_tcp                   = (INT)  3321,   //  VNSSTR
05523             c_vnsstr_udp                   = (INT)  3321,   //  VNSSTR
05524             c_sftu_tcp                     = (INT)  3326,   //  SFTU
05525             c_sftu_udp                     = (INT)  3326,   //  SFTU
05526             c_bbars_tcp                    = (INT)  3327,   //  BBARS
05527             c_bbars_udp                    = (INT)  3327,   //  BBARS
05528             c_egptlm_tcp                   = (INT)  3328,   //  Eaglepoint License Manager
05529             c_egptlm_udp                   = (INT)  3328,   //  Eaglepoint License Manager
05530             c_hp_device_disc_tcp           = (INT)  3329,   //  HP Device Disc
05531             c_hp_device_disc_udp           = (INT)  3329,   //  HP Device Disc
05532             c_mcs_calypsoicf_tcp           = (INT)  3330,   //  MCS Calypso ICF
05533             c_mcs_calypsoicf_udp           = (INT)  3330,   //  MCS Calypso ICF
05534             c_mcs_messaging_tcp            = (INT)  3331,   //  MCS Messaging
05535             c_mcs_messaging_udp            = (INT)  3331,   //  MCS Messaging
05536             c_mcs_mailsvr_tcp              = (INT)  3332,   //  MCS Mail Server
05537             c_mcs_mailsvr_udp              = (INT)  3332,   //  MCS Mail Server
05538             c_dec_notes_tcp                = (INT)  3333,   //  DEC Notes
05539             c_dec_notes_udp                = (INT)  3333,   //  DEC Notes
05540             c_directv_web_tcp              = (INT)  3334,   //  Direct TV Webcasting
05541             c_directv_web_udp              = (INT)  3334,   //  Direct TV Webcasting
05542             c_directv_soft_tcp             = (INT)  3335,   //  Direct TV Software Updates
05543             c_directv_soft_udp             = (INT)  3335,   //  Direct TV Software Updates
05544             c_directv_tick_tcp             = (INT)  3336,   //  Direct TV Tickers
05545             c_directv_tick_udp             = (INT)  3336,   //  Direct TV Tickers
05546             c_directv_catlg_tcp            = (INT)  3337,   //  Direct TV Data Catalog
05547             c_directv_catlg_udp            = (INT)  3337,   //  Direct TV Data Catalog
05548             c_anet_b_tcp                   = (INT)  3338,   //  OMF data b
05549             c_anet_b_udp                   = (INT)  3338,   //  OMF data b
05550             c_anet_l_tcp                   = (INT)  3339,   //  OMF data l
05551             c_anet_l_udp                   = (INT)  3339,   //  OMF data l
05552             c_anet_m_tcp                   = (INT)  3340,   //  OMF data m
05553             c_anet_m_udp                   = (INT)  3340,   //  OMF data m
05554             c_anet_h_tcp                   = (INT)  3341,   //  OMF data h
05555             c_anet_h_udp                   = (INT)  3341,   //  OMF data h
05556             c_webtie_tcp                   = (INT)  3342,   //  WebTIE
05557             c_webtie_udp                   = (INT)  3342,   //  WebTIE
05558             c_ms_cluster_net_tcp           = (INT)  3343,   //  MS Cluster Net
05559             c_ms_cluster_net_udp           = (INT)  3343,   //  MS Cluster Net
05560             c_bnt_manager_tcp              = (INT)  3344,   //  BNT Manager
05561             c_bnt_manager_udp              = (INT)  3344,   //  BNT Manager
05562             c_influence_tcp                = (INT)  3345,   //  Influence
05563             c_influence_udp                = (INT)  3345,   //  Influence
05564             c_trnsprntproxy_tcp            = (INT)  3346,   //  Trnsprnt Proxy
05565             c_trnsprntproxy_udp            = (INT)  3346,   //  Trnsprnt Proxy
05566             c_phoenix_rpc_tcp              = (INT)  3347,   //  Phoenix RPC
05567             c_phoenix_rpc_udp              = (INT)  3347,   //  Phoenix RPC
05568             c_pangolin_laser_tcp           = (INT)  3348,   //  Pangolin Laser
05569             c_pangolin_laser_udp           = (INT)  3348,   //  Pangolin Laser
05570             c_chevinservices_tcp           = (INT)  3349,   //  Chevin Services
05571             c_chevinservices_udp           = (INT)  3349,   //  Chevin Services
05572             c_findviatv_tcp                = (INT)  3350,   //  FINDVIATV
05573             c_findviatv_udp                = (INT)  3350,   //  FINDVIATV
05574             c_btrieve_tcp                  = (INT)  3351,   //  BTRIEVE
05575             c_btrieve_udp                  = (INT)  3351,   //  BTRIEVE
05576             c_ssql_tcp                     = (INT)  3352,   //  SSQL
05577             c_ssql_udp                     = (INT)  3352,   //  SSQL
05578             c_fatpipe_tcp                  = (INT)  3353,   //  FATPIPE
05579             c_fatpipe_udp                  = (INT)  3353,   //  FATPIPE
05580             c_suitjd_tcp                   = (INT)  3354,   //  SUITJD
05581             c_suitjd_udp                   = (INT)  3354,   //  SUITJD
05582             c_ordinox_dbase_tcp            = (INT)  3355,   //  Ordinox Dbase
05583             c_ordinox_dbase_udp            = (INT)  3355,   //  Ordinox Dbase
05584             c_upnotifyps_tcp               = (INT)  3356,   //  UPNOTIFYPS
05585             c_upnotifyps_udp               = (INT)  3356,   //  UPNOTIFYPS
05586             c_adtech_test_tcp              = (INT)  3357,   //  Adtech Test IP
05587             c_adtech_test_udp              = (INT)  3357,   //  Adtech Test IP
05588             c_mpsysrmsvr_tcp               = (INT)  3358,   //  Mp Sys Rmsvr
05589             c_mpsysrmsvr_udp               = (INT)  3358,   //  Mp Sys Rmsvr
05590             c_wg_netforce_tcp              = (INT)  3359,   //  WG NetForce
05591             c_wg_netforce_udp              = (INT)  3359,   //  WG NetForce
05592             c_kv_server_tcp                = (INT)  3360,   //  KV Server
05593             c_kv_server_udp                = (INT)  3360,   //  KV Server
05594             c_kv_agent_tcp                 = (INT)  3361,   //  KV Agent
05595             c_kv_agent_udp                 = (INT)  3361,   //  KV Agent
05596             c_dj_ilm_tcp                   = (INT)  3362,   //  DJ ILM
05597             c_dj_ilm_udp                   = (INT)  3362,   //  DJ ILM
05598             c_nati_vi_server_tcp           = (INT)  3363,   //  NATI Vi Server
05599             c_nati_vi_server_udp           = (INT)  3363,   //  NATI Vi Server
05600             c_creativeserver_1_tcp         = (INT)  3364,   //  Creative Server
05601             c_creativeserver_1_udp         = (INT)  3364,   //  Creative Server
05602             c_contentserver_1_tcp          = (INT)  3365,   //  Content Server
05603             c_contentserver_1_udp          = (INT)  3365,   //  Content Server
05604             c_creativepartnr_1_tcp         = (INT)  3366,   //  Creative Partner
05605             c_creativepartnr_1_udp         = (INT)  3366,   //  Creative Partner
05606             c_tip2_tcp                     = (INT)  3372,   //  TIP 2
05607             c_tip2_udp                     = (INT)  3372,   //  TIP 2
05608             c_lavenir_lm_tcp               = (INT)  3373,   //  Lavenir License Manager
05609             c_lavenir_lm_udp               = (INT)  3373,   //  Lavenir License Manager
05610             c_cluster_disc_tcp             = (INT)  3374,   //  Cluster Disc
05611             c_cluster_disc_udp             = (INT)  3374,   //  Cluster Disc
05612             c_vsnm_agent_tcp               = (INT)  3375,   //  VSNM Agent
05613             c_vsnm_agent_udp               = (INT)  3375,   //  VSNM Agent
05614             c_cdbroker_tcp                 = (INT)  3376,   //  CD Broker
05615             c_cdbroker_udp                 = (INT)  3376,   //  CD Broker
05616             c_cogsys_lm_tcp                = (INT)  3377,   //  Cogsys Network License Manager
05617             c_cogsys_lm_udp                = (INT)  3377,   //  Cogsys Network License Manager
05618             c_wsicopy_tcp                  = (INT)  3378,   //  WSICOPY
05619             c_wsicopy_udp                  = (INT)  3378,   //  WSICOPY
05620             c_socorfs_tcp                  = (INT)  3379,   //  SOCORFS
05621             c_socorfs_udp                  = (INT)  3379,   //  SOCORFS
05622             c_sns_channels_tcp             = (INT)  3380,   //  SNS Channels
05623             c_sns_channels_udp             = (INT)  3380,   //  SNS Channels
05624             c_geneous_tcp                  = (INT)  3381,   //  Geneous
05625             c_geneous_udp                  = (INT)  3381,   //  Geneous
05626             c_fujitsu_neat_tcp             = (INT)  3382,   //  Fujitsu Network Enhanced Antitheft function
05627             c_fujitsu_neat_udp             = (INT)  3382,   //  Fujitsu Network Enhanced Antitheft function
05628             c_esp_lm_tcp                   = (INT)  3383,   //  Enterprise Software Products License Manager
05629             c_esp_lm_udp                   = (INT)  3383,   //  Enterprise Software Products License Manager
05630             c_hp_clic_tcp                  = (INT)  3384,   //  Cluster Management Services
05631             c_hp_clic_udp                  = (INT)  3384,   //  Hardware Management
05632             c_qnxnetman_tcp                = (INT)  3385,   //  qnxnetman
05633             c_qnxnetman_udp                = (INT)  3385,   //  qnxnetman
05634             c_gprs_data_tcp                = (INT)  3386,   //  GPRS Data
05635             c_gprs_sig_udp                 = (INT)  3386,   //  GPRS SIG
05636             c_backroomnet_tcp              = (INT)  3387,   //  Back Room Net
05637             c_backroomnet_udp              = (INT)  3387,   //  Back Room Net
05638             c_cbserver_tcp                 = (INT)  3388,   //  CB Server
05639             c_cbserver_udp                 = (INT)  3388,   //  CB Server
05640             c_ms_wbt_server_tcp            = (INT)  3389,   //  MS WBT Server
05641             c_ms_wbt_server_udp            = (INT)  3389,   //  MS WBT Server
05642             c_dsc_tcp                      = (INT)  3390,   //  Distributed Service Coordinator
05643             c_dsc_udp                      = (INT)  3390,   //  Distributed Service Coordinator
05644             c_savant_tcp                   = (INT)  3391,   //  SAVANT
05645             c_savant_udp                   = (INT)  3391,   //  SAVANT
05646             c_efi_lm_tcp                   = (INT)  3392,   //  EFI License Management
05647             c_efi_lm_udp                   = (INT)  3392,   //  EFI License Management
05648             c_d2k_tapestry1_tcp            = (INT)  3393,   //  D2K Tapestry Client to Server
05649             c_d2k_tapestry1_udp            = (INT)  3393,   //  D2K Tapestry Client to Server
05650             c_d2k_tapestry2_tcp            = (INT)  3394,   //  D2K Tapestry Server to Server
05651             c_d2k_tapestry2_udp            = (INT)  3394,   //  D2K Tapestry Server to Server
05652             c_dyna_lm_tcp                  = (INT)  3395,   //  Dyna License Manager (Elam)
05653             c_dyna_lm_udp                  = (INT)  3395,   //  Dyna License Manager (Elam)
05654             c_cloanto_lm_tcp               = (INT)  3397,   //  Cloanto License Manager
05655             c_cloanto_lm_udp               = (INT)  3397,   //  Cloanto License Manager
05656             c_mercantile_tcp               = (INT)  3398,   //  Mercantile
05657             c_mercantile_udp               = (INT)  3398,   //  Mercantile
05658             c_csms_tcp                     = (INT)  3399,   //  CSMS
05659             c_csms_udp                     = (INT)  3399,   //  CSMS
05660             c_csms2_tcp                    = (INT)  3400,   //  CSMS2
05661             c_csms2_udp                    = (INT)  3400,   //  CSMS2
05662             c_filecast_tcp                 = (INT)  3401,   //  filecast
05663             c_filecast_udp                 = (INT)  3401,   //  filecast
05664             c_fxaengine_net_tcp            = (INT)  3402,   //  FXa Engine Network Port
05665             c_fxaengine_net_udp            = (INT)  3402,   //  FXa Engine Network Port
05666             c_copysnap_tcp                 = (INT)  3403,   //  CopySnap Server Port
05667             c_copysnap_udp                 = (INT)  3403,   //  CopySnap Server Port
05668             c_igo_incognito_tcp            = (INT)  3404,   //  IGo Incognito Data Port
05669             c_igo_incognito_udp            = (INT)  3404,   //  IGo Incognito Data Port
05670             c_nokia_ann_ch1_tcp            = (INT)  3405,   //  Nokia Announcement ch 1
05671             c_nokia_ann_ch1_udp            = (INT)  3405,   //  Nokia Announcement ch 1
05672             c_nokia_ann_ch2_tcp            = (INT)  3406,   //  Nokia Announcement ch 2
05673             c_nokia_ann_ch2_udp            = (INT)  3406,   //  Nokia Announcement ch 2
05674             c_ldap_admin_tcp               = (INT)  3407,   //  LDAP admin server port
05675             c_ldap_admin_udp               = (INT)  3407,   //  LDAP admin server port
05676             c_issapi_tcp                   = (INT)  3408,   //  POWERpack API Port
05677             c_issapi_udp                   = (INT)  3408,   //  POWERpack API Port
05678             c_networklens_tcp              = (INT)  3409,   //  NetworkLens Event Port
05679             c_networklens_udp              = (INT)  3409,   //  NetworkLens Event Port
05680             c_networklenss_tcp             = (INT)  3410,   //  NetworkLens SSL Event
05681             c_networklenss_udp             = (INT)  3410,   //  NetworkLens SSL Event
05682             c_biolink_auth_tcp             = (INT)  3411,   //  BioLink Authenteon
05683             c_biolink_auth_udp             = (INT)  3411,   //  BioLink Authenteon
05684             c_xmlblaster_tcp               = (INT)  3412,   //  xmlBlaster
05685             c_xmlblaster_udp               = (INT)  3412,   //  xmlBlaster
05686             c_svnet_tcp                    = (INT)  3413,   //  SpecView Networking
05687             c_svnet_udp                    = (INT)  3413,   //  SpecView Networking
05688             c_wip_port_tcp                 = (INT)  3414,   //  BroadCloud WIP Port
05689             c_wip_port_udp                 = (INT)  3414,   //  BroadCloud WIP Port
05690             c_bcinameservice_tcp           = (INT)  3415,   //  BCI Name Service
05691             c_bcinameservice_udp           = (INT)  3415,   //  BCI Name Service
05692             c_commandport_tcp              = (INT)  3416,   //  AirMobile IS Command Port
05693             c_commandport_udp              = (INT)  3416,   //  AirMobile IS Command Port
05694             c_csvr_tcp                     = (INT)  3417,   //  ConServR file translation
05695             c_csvr_udp                     = (INT)  3417,   //  ConServR file translation
05696             c_rnmap_tcp                    = (INT)  3418,   //  Remote nmap
05697             c_rnmap_udp                    = (INT)  3418,   //  Remote nmap
05698             c_softaudit_tcp                = (INT)  3419,   //  Isogon SoftAudit
05699             c_softaudit_udp                = (INT)  3419,   //  ISogon SoftAudit
05700             c_ifcp_port_tcp                = (INT)  3420,   //  iFCP User Port
05701             c_ifcp_port_udp                = (INT)  3420,   //  iFCP User Port
05702             c_bmap_tcp                     = (INT)  3421,   //  Bull Apprise portmapper
05703             c_bmap_udp                     = (INT)  3421,   //  Bull Apprise portmapper
05704             c_rusb_sys_port_tcp            = (INT)  3422,   //  Remote USB System Port
05705             c_rusb_sys_port_udp            = (INT)  3422,   //  Remote USB System Port
05706             c_xtrm_tcp                     = (INT)  3423,   //  xTrade Reliable Messaging
05707             c_xtrm_udp                     = (INT)  3423,   //  xTrade Reliable Messaging
05708             c_xtrms_tcp                    = (INT)  3424,   //  xTrade over TLS/SSL
05709             c_xtrms_udp                    = (INT)  3424,   //  xTrade over TLS/SSL
05710             c_agps_port_tcp                = (INT)  3425,   //  AGPS Access Port
05711             c_agps_port_udp                = (INT)  3425,   //  AGPS Access Port
05712             c_arkivio_tcp                  = (INT)  3426,   //  Arkivio Storage Protocol
05713             c_arkivio_udp                  = (INT)  3426,   //  Arkivio Storage Protocol
05714             c_websphere_snmp_tcp           = (INT)  3427,   //  WebSphere SNMP
05715             c_websphere_snmp_udp           = (INT)  3427,   //  WebSphere SNMP
05716             c_twcss_tcp                    = (INT)  3428,   //  2Wire CSS
05717             c_twcss_udp                    = (INT)  3428,   //  2Wire CSS
05718             c_gcsp_tcp                     = (INT)  3429,   //  GCSP user port
05719             c_gcsp_udp                     = (INT)  3429,   //  GCSP user port
05720             c_ssdispatch_tcp               = (INT)  3430,   //  Scott Studios Dispatch
05721             c_ssdispatch_udp               = (INT)  3430,   //  Scott Studios Dispatch
05722             c_ndl_als_tcp                  = (INT)  3431,   //  Active License Server Port
05723             c_ndl_als_udp                  = (INT)  3431,   //  Active License Server Port
05724             c_osdcp_tcp                    = (INT)  3432,   //  Secure Device Protocol
05725             c_osdcp_udp                    = (INT)  3432,   //  Secure Device Protocol
05726             c_alta_smp_tcp                 = (INT)  3433,   //  Altaworks Service Management Platform
05727             c_alta_smp_udp                 = (INT)  3433,   //  Altaworks Service Management Platform
05728             c_opencm_tcp                   = (INT)  3434,   //  OpenCM Server
05729             c_opencm_udp                   = (INT)  3434,   //  OpenCM Server
05730             c_pacom_tcp                    = (INT)  3435,   //  Pacom Security User Port
05731             c_pacom_udp                    = (INT)  3435,   //  Pacom Security User Port
05732             c_bw_config_tcp                = (INT)  3436,   //  BurningWall ConfigSrv
05733             c_bw_config_udp                = (INT)  3436,   //  BurningWall ConfigSrv
05734             c_autocueds_tcp                = (INT)  3437,   //  Autocue Directory Service
05735             c_autocueds_udp                = (INT)  3437,   //  Autocue Directory Service
05736             c_spiral_admin_tcp             = (INT)  3438,   //  Spiralcraft Admin
05737             c_spiral_admin_udp             = (INT)  3438,   //  Spiralcraft Admin
05738             c_hri_port_tcp                 = (INT)  3439,   //  HRI Interface Port
05739             c_hri_port_udp                 = (INT)  3439,   //  HRI Interface Port
05740             c_ans_console_tcp              = (INT)  3440,   //  Net Steward Mgmt Console
05741             c_ans_console_udp              = (INT)  3440,   //  Net Steward Mgmt Console
05742             c_connect_client_tcp           = (INT)  3441,   //  OC Connect Client
05743             c_connect_client_udp           = (INT)  3441,   //  OC Connect Client
05744             c_connect_server_tcp           = (INT)  3442,   //  OC Connect Server
05745             c_connect_server_udp           = (INT)  3442,   //  OC Connect Server
05746             c_ov_nnm_websrv_tcp            = (INT)  3443,   //  OpenView Network Node Manager WEB Server
05747             c_ov_nnm_websrv_udp            = (INT)  3443,   //  OpenView Network Node Manager WEB Server
05748             c_denali_server_tcp            = (INT)  3444,   //  Denali Server
05749             c_denali_server_udp            = (INT)  3444,   //  Denali Server
05750             c_monp_tcp                     = (INT)  3445,   //  Media Object Network
05751             c_monp_udp                     = (INT)  3445,   //  Media Object Network
05752             c_3comfaxrpc_tcp               = (INT)  3446,   //  3Com FAX RPC port
05753             c_3comfaxrpc_udp               = (INT)  3446,   //  3Com FAX RPC port
05754             c_cddn_tcp                     = (INT)  3447,   //  CompuDuo DirectNet
05755             c_cddn_udp                     = (INT)  3447,   //  CompuDuo DirectNet
05756             c_dnc_port_tcp                 = (INT)  3448,   //  Discovery and Net Config
05757             c_dnc_port_udp                 = (INT)  3448,   //  Discovery and Net Config
05758             c_hotu_chat_tcp                = (INT)  3449,   //  HotU Chat
05759             c_hotu_chat_udp                = (INT)  3449,   //  HotU Chat
05760             c_castorproxy_tcp              = (INT)  3450,   //  CAStorProxy
05761             c_castorproxy_udp              = (INT)  3450,   //  CAStorProxy
05762             c_asam_tcp                     = (INT)  3451,   //  ASAM Services
05763             c_asam_udp                     = (INT)  3451,   //  ASAM Services
05764             c_sabp_signal_tcp              = (INT)  3452,   //  SABP-Signalling Protocol
05765             c_sabp_signal_udp              = (INT)  3452,   //  SABP-Signalling Protocol
05766             c_pscupd_tcp                   = (INT)  3453,   //  PSC Update Port
05767             c_pscupd_udp                   = (INT)  3453,   //  PSC Update Port
05768             c_mira_tcp                     = (INT)  3454,   //  Apple Remote Access Protocol
05769             c_prsvp_tcp                    = (INT)  3455,   //  RSVP Port
05770             c_prsvp_udp                    = (INT)  3455,   //  RSVP Port
05771             c_vat_tcp                      = (INT)  3456,   //  VAT default data
05772             c_vat_udp                      = (INT)  3456,   //  VAT default data
05773             c_vat_control_tcp              = (INT)  3457,   //  VAT default control
05774             c_vat_control_udp              = (INT)  3457,   //  VAT default control
05775             c_d3winosfi_tcp                = (INT)  3458,   //  D3WinOSFI
05776             c_d3winosfi_udp                = (INT)  3458,   //  D3WinOSFI
05777             c_integral_tcp                 = (INT)  3459,   //  TIP Integral
05778             c_integral_udp                 = (INT)  3459,   //  TIP Integral
05779             c_edm_manager_tcp              = (INT)  3460,   //  EDM Manger
05780             c_edm_manager_udp              = (INT)  3460,   //  EDM Manger
05781             c_edm_stager_tcp               = (INT)  3461,   //  EDM Stager
05782             c_edm_stager_udp               = (INT)  3461,   //  EDM Stager
05783             c_edm_std_notify_tcp           = (INT)  3462,   //  EDM STD Notify
05784             c_edm_std_notify_udp           = (INT)  3462,   //  EDM STD Notify
05785             c_edm_adm_notify_tcp           = (INT)  3463,   //  EDM ADM Notify
05786             c_edm_adm_notify_udp           = (INT)  3463,   //  EDM ADM Notify
05787             c_edm_mgr_sync_tcp             = (INT)  3464,   //  EDM MGR Sync
05788             c_edm_mgr_sync_udp             = (INT)  3464,   //  EDM MGR Sync
05789             c_edm_mgr_cntrl_tcp            = (INT)  3465,   //  EDM MGR Cntrl
05790             c_edm_mgr_cntrl_udp            = (INT)  3465,   //  EDM MGR Cntrl
05791             c_workflow_tcp                 = (INT)  3466,   //  WORKFLOW
05792             c_workflow_udp                 = (INT)  3466,   //  WORKFLOW
05793             c_rcst_tcp                     = (INT)  3467,   //  RCST
05794             c_rcst_udp                     = (INT)  3467,   //  RCST
05795             c_ttcmremotectrl_tcp           = (INT)  3468,   //  TTCM Remote Controll
05796             c_ttcmremotectrl_udp           = (INT)  3468,   //  TTCM Remote Controll
05797             c_pluribus_tcp                 = (INT)  3469,   //  Pluribus
05798             c_pluribus_udp                 = (INT)  3469,   //  Pluribus
05799             c_jt400_tcp                    = (INT)  3470,   //  jt400
05800             c_jt400_udp                    = (INT)  3470,   //  jt400
05801             c_jt400_ssl_tcp                = (INT)  3471,   //  jt400-ssl
05802             c_jt400_ssl_udp                = (INT)  3471,   //  jt400-ssl
05803             c_jaugsremotec_1_tcp           = (INT)  3472,   //  JAUGS N-G Remotec 1
05804             c_jaugsremotec_1_udp           = (INT)  3472,   //  JAUGS N-G Remotec 1
05805             c_jaugsremotec_2_tcp           = (INT)  3473,   //  JAUGS N-G Remotec 2
05806             c_jaugsremotec_2_udp           = (INT)  3473,   //  JAUGS N-G Remotec 2
05807             c_ttntspauto_tcp               = (INT)  3474,   //  TSP Automation
05808             c_ttntspauto_udp               = (INT)  3474,   //  TSP Automation
05809             c_genisar_port_tcp             = (INT)  3475,   //  Genisar Comm Port
05810             c_genisar_port_udp             = (INT)  3475,   //  Genisar Comm Port
05811             c_nppmp_tcp                    = (INT)  3476,   //  NVIDIA Mgmt Protocol
05812             c_nppmp_udp                    = (INT)  3476,   //  NVIDIA Mgmt Protocol
05813             c_ecomm_tcp                    = (INT)  3477,   //  eComm link port
05814             c_ecomm_udp                    = (INT)  3477,   //  eComm link port
05815             c_nat_stun_port_tcp            = (INT)  3478,   //  Simple Traversal of UDP Through NAT (STUN) port
05816             c_nat_stun_port_udp            = (INT)  3478,   //  Simple Traversal of UDP Through NAT (STUN) port
05817             c_twrpc_tcp                    = (INT)  3479,   //  2Wire RPC
05818             c_twrpc_udp                    = (INT)  3479,   //  2Wire RPC
05819             c_ibm3494_tcp                  = (INT)  3494,   //  IBM 3494
05820             c_ibm3494_udp                  = (INT)  3494,   //  IBM 3494
05821             c_seclayer_tcp_tcp             = (INT)  3495,   //  securitylayer over tcp
05822             c_seclayer_tcp_udp             = (INT)  3495,   //  securitylayer over tcp
05823             c_seclayer_tls_tcp             = (INT)  3496,   //  securitylayer over tls
05824             c_seclayer_tls_udp             = (INT)  3496,   //  securitylayer over tls
05825             c_rtmp_port_tcp                = (INT)  3500,   //  RTMP Port
05826             c_rtmp_port_udp                = (INT)  3500,   //  RTMP Port
05827             c_isoft_p2p_tcp                = (INT)  3501,   //  iSoft-P2P
05828             c_isoft_p2p_udp                = (INT)  3501,   //  iSoft-P2P
05829             c_avinstalldisc_tcp            = (INT)  3502,   //  Avocent Install Discovery
05830             c_avinstalldisc_udp            = (INT)  3502,   //  Avocent Install Discovery
05831             c_lsp_ping_tcp                 = (INT)  3503,   //  MPLS LSP-echo Port
05832             c_lsp_ping_udp                 = (INT)  3503,   //  MPLS LSP-echo Port
05833             c_ironstorm_tcp                = (INT)  3504,   //  IronStorm game server
05834             c_ironstorm_udp                = (INT)  3504,   //  IronStorm game server
05835             c_ccmcomm_tcp                  = (INT)  3505,   //  CCM communications port
05836             c_ccmcomm_udp                  = (INT)  3505,   //  CCM communications port
05837             c_apc_aem_status_tcp           = (INT)  3506,   //  APC Device Status Port
05838             c_apc_aem_status_udp           = (INT)  3506,   //  APC Device Status Port
05839             c_nesh_broker_tcp              = (INT)  3507,   //  Nesh Broker Port
05840             c_nesh_broker_udp              = (INT)  3507,   //  Nesh Broker Port
05841             c_interactionweb_tcp           = (INT)  3508,   //  Interaction Web
05842             c_interactionweb_udp           = (INT)  3508,   //  Interaction Web
05843             c_ms_la_tcp                    = (INT)  3535,   //  MS-LA
05844             c_ms_la_udp                    = (INT)  3535,   //  MS-LA
05845             c_watcomdebug_tcp              = (INT)  3563,   //  Watcom Debug
05846             c_watcomdebug_udp              = (INT)  3563,   //  Watcom Debug
05847             c_sharp_server_tcp             = (INT)  3617,   //  ATI SHARP Logic Engine
05848             c_sharp_server_udp             = (INT)  3617,   //  ATI SHARP Logic Engine
05849             c_lispworks_orb_tcp            = (INT)  3672,   //  LispWorks ORB
05850             c_lispworks_orb_udp            = (INT)  3672,   //  LispWorks ORB
05851             c_ca_idms_tcp                  = (INT)  3709,   //  CA-IDMS Server
05852             c_ca_idms_udp                  = (INT)  3709,   //  CA-IDMS Server
05853             c_sphidia_port_tcp             = (INT)  3737,   //  Sphidia Game Port
05854             c_sphidia_port_udp             = (INT)  3737,   //  Sphidia Game Port
05855             c_vhd_tcp                      = (INT)  3802,   //  VHD
05856             c_vhd_udp                      = (INT)  3802,   //  VHD
05857             c_v_one_spp_tcp                = (INT)  3845,   //  V-ONE Single Port Proxy
05858             c_v_one_spp_udp                = (INT)  3845,   //  V-ONE Single Port Proxy
05859             c_giga_pocket_tcp              = (INT)  3862,   //  GIGA-POCKET
05860             c_giga_pocket_udp              = (INT)  3862,   //  GIGA-POCKET
05861             c_pnbscada_tcp                 = (INT)  3875,   //  PNBSCADA
05862             c_pnbscada_udp                 = (INT)  3875,   //  PNBSCADA
05863             c_topflow_ssl_tcp              = (INT)  3885,   //  TopFlow SSL
05864             c_topflow_ssl_udp              = (INT)  3885,   //  TopFlow SSL
05865             c_aamp_tcp                     = (INT)  3939,   //  Anti-virus Application Management Port
05866             c_aamp_udp                     = (INT)  3939,   //  Anti-virus Application Management Port
05867             c_mapper_nodemgr_tcp           = (INT)  3984,   //  MAPPER network node manager
05868             c_mapper_nodemgr_udp           = (INT)  3984,   //  MAPPER network node manager
05869             c_mapper_mapethd_tcp           = (INT)  3985,   //  MAPPER TCP/IP server
05870             c_mapper_mapethd_udp           = (INT)  3985,   //  MAPPER TCP/IP server
05871             c_centerline_tcp               = (INT)  3987,   //  Centerline
05872             c_centerline_udp               = (INT)  3987,   //  Centerline
05873             c_terabase_tcp                 = (INT)  4000,   //  Terabase
05874             c_terabase_udp                 = (INT)  4000,   //  Terabase
05875             c_newoak_tcp                   = (INT)  4001,   //  NewOak
05876             c_newoak_udp                   = (INT)  4001,   //  NewOak
05877             c_pxc_spvr_ft_tcp              = (INT)  4002,   //  pxc-spvr-ft
05878             c_pxc_spvr_ft_udp              = (INT)  4002,   //  pxc-spvr-ft
05879             c_pxc_splr_ft_tcp              = (INT)  4003,   //  pxc-splr-ft
05880             c_pxc_splr_ft_udp              = (INT)  4003,   //  pxc-splr-ft
05881             c_pxc_roid_tcp                 = (INT)  4004,   //  pxc-roid
05882             c_pxc_roid_udp                 = (INT)  4004,   //  pxc-roid
05883             c_pxc_pin_tcp                  = (INT)  4005,   //  pxc-pin
05884             c_pxc_pin_udp                  = (INT)  4005,   //  pxc-pin
05885             c_pxc_spvr_tcp                 = (INT)  4006,   //  pxc-spvr
05886             c_pxc_spvr_udp                 = (INT)  4006,   //  pxc-spvr
05887             c_pxc_splr_tcp                 = (INT)  4007,   //  pxc-splr
05888             c_pxc_splr_udp                 = (INT)  4007,   //  pxc-splr
05889             c_netcheque_tcp                = (INT)  4008,   //  NetCheque accounting
05890             c_netcheque_udp                = (INT)  4008,   //  NetCheque accounting
05891             c_chimera_hwm_tcp              = (INT)  4009,   //  Chimera HWM
05892             c_chimera_hwm_udp              = (INT)  4009,   //  Chimera HWM
05893             c_samsung_unidex_tcp           = (INT)  4010,   //  Samsung Unidex
05894             c_samsung_unidex_udp           = (INT)  4010,   //  Samsung Unidex
05895             c_altserviceboot_tcp           = (INT)  4011,   //  Alternate Service Boot
05896             c_altserviceboot_udp           = (INT)  4011,   //  Alternate Service Boot
05897             c_pda_gate_tcp                 = (INT)  4012,   //  PDA Gate
05898             c_pda_gate_udp                 = (INT)  4012,   //  PDA Gate
05899             c_acl_manager_tcp              = (INT)  4013,   //  ACL Manager
05900             c_acl_manager_udp              = (INT)  4013,   //  ACL Manager
05901             c_taiclock_tcp                 = (INT)  4014,   //  TAICLOCK
05902             c_taiclock_udp                 = (INT)  4014,   //  TAICLOCK
05903             c_talarian_mcast1_tcp          = (INT)  4015,   //  Talarian Mcast
05904             c_talarian_mcast1_udp          = (INT)  4015,   //  Talarian Mcast
05905             c_talarian_mcast2_tcp          = (INT)  4016,   //  Talarian Mcast
05906             c_talarian_mcast2_udp          = (INT)  4016,   //  Talarian Mcast
05907             c_talarian_mcast3_tcp          = (INT)  4017,   //  Talarian Mcast
05908             c_talarian_mcast3_udp          = (INT)  4017,   //  Talarian Mcast
05909             c_talarian_mcast4_tcp          = (INT)  4018,   //  Talarian Mcast
05910             c_talarian_mcast4_udp          = (INT)  4018,   //  Talarian Mcast
05911             c_talarian_mcast5_tcp          = (INT)  4019,   //  Talarian Mcast
05912             c_talarian_mcast5_udp          = (INT)  4019,   //  Talarian Mcast
05913             c_trap_tcp                     = (INT)  4020,   //  TRAP Port
05914             c_trap_udp                     = (INT)  4020,   //  TRAP Port
05915             c_nexus_portal_tcp             = (INT)  4021,   //  Nexus Portal
05916             c_nexus_portal_udp             = (INT)  4021,   //  Nexus Portal
05917             c_dnox_tcp                     = (INT)  4022,   //  DNOX
05918             c_dnox_udp                     = (INT)  4022,   //  DNOX
05919             c_esnm_zoning_tcp              = (INT)  4023,   //  ESNM Zoning Port
05920             c_esnm_zoning_udp              = (INT)  4023,   //  ESNM Zoning Port
05921             c_tnp1_port_tcp                = (INT)  4024,   //  TNP1 User Port
05922             c_tnp1_port_udp                = (INT)  4024,   //  TNP1 User Port
05923             c_partimage_tcp                = (INT)  4025,   //  Partition Image Port
05924             c_partimage_udp                = (INT)  4025,   //  Partition Image Port
05925             c_as_debug_tcp                 = (INT)  4026,   //  Graphical Debug Server
05926             c_as_debug_udp                 = (INT)  4026,   //  Graphical Debug Server
05927             c_bxp_tcp                      = (INT)  4027,   //  bitxpress
05928             c_bxp_udp                      = (INT)  4027,   //  bitxpress
05929             c_dtserver_port_tcp            = (INT)  4028,   //  DTServer Port
05930             c_dtserver_port_udp            = (INT)  4028,   //  DTServer Port
05931             c_ip_qsig_tcp                  = (INT)  4029,   //  IP Q signaling protocol
05932             c_ip_qsig_udp                  = (INT)  4029,   //  IP Q signaling protocol
05933             c_jdmn_port_tcp                = (INT)  4030,   //  Accell/JSP Daemon Port
05934             c_jdmn_port_1_tcp              = (INT)  4030,   //  Accell/JSP Daemon Port
05935             c_suucp_tcp                    = (INT)  4031,   //  UUCP over SSL
05936             c_suucp_udp                    = (INT)  4031,   //  UUCP over SSL
05937             c_vrts_auth_port_tcp           = (INT)  4032,   //  VERITAS Authorize Server
05938             c_vrts_auth_port_udp           = (INT)  4032,   //  VERITAS Authorize Server
05939             c_sanavigator_tcp              = (INT)  4033,   //  SANavigator Peer Port
05940             c_sanavigator_udp              = (INT)  4033,   //  SANavigator Peer Port
05941             c_ubxd_tcp                     = (INT)  4034,   //  Ubiquinox Daemon
05942             c_ubxd_udp                     = (INT)  4034,   //  Ubiquinox Daemon
05943             c_yo_main_tcp                  = (INT)  4040,   //  Yo.net main service
05944             c_yo_main_udp                  = (INT)  4040,   //  Yo.net main service
05945             c_houston_tcp                  = (INT)  4041,   //  Rocketeer-Houston
05946             c_houston_udp                  = (INT)  4041,   //  Rocketeer-Houston
05947             c_ldxp_tcp                     = (INT)  4042,   //  LDXP
05948             c_ldxp_udp                     = (INT)  4042,   //  LDXP
05949             c_bre_tcp                      = (INT)  4096,   //  BRE (Bridge Relay Element)
05950             c_bre_udp                      = (INT)  4096,   //  BRE (Bridge Relay Element)
05951             c_patrolview_tcp               = (INT)  4097,   //  Patrol View
05952             c_patrolview_udp               = (INT)  4097,   //  Patrol View
05953             c_drmsfsd_tcp                  = (INT)  4098,   //  drmsfsd
05954             c_drmsfsd_udp                  = (INT)  4098,   //  drmsfsd
05955             c_dpcp_tcp                     = (INT)  4099,   //  DPCP
05956             c_dpcp_udp                     = (INT)  4099,   //  DPCP
05957             c_nifty_hmi_tcp                = (INT)  4134,   //  NIFTY-Serve HMI protocol
05958             c_nifty_hmi_udp                = (INT)  4134,   //  NIFTY-Serve HMI protocol
05959             c_oirtgsvc_tcp                 = (INT)  4141,   //  Workflow Server
05960             c_oirtgsvc_udp                 = (INT)  4141,   //  Workflow Server
05961             c_oidocsvc_tcp                 = (INT)  4142,   //  Document Server
05962             c_oidocsvc_udp                 = (INT)  4142,   //  Document Server
05963             c_oidsr_tcp                    = (INT)  4143,   //  Document Replication
05964             c_oidsr_udp                    = (INT)  4143,   //  Document Replication
05965             c_vvr_control_tcp              = (INT)  4145,   //  VVR Control
05966             c_vvr_control_udp              = (INT)  4145,   //  VVR Control
05967             c_jini_discovery_tcp           = (INT)  4160,   //  Jini Discovery
05968             c_jini_discovery_udp           = (INT)  4160,   //  Jini Discovery
05969             c_eims_admin_tcp               = (INT)  4199,   //  EIMS ADMIN
05970             c_eims_admin_udp               = (INT)  4199,   //  EIMS ADMIN
05971             c_corelccam_tcp                = (INT)  4300,   //  Corel CCam
05972             c_corelccam_udp                = (INT)  4300,   //  Corel CCam
05973             c_rwhois_tcp                   = (INT)  4321,   //  Remote Who Is
05974             c_rwhois_udp                   = (INT)  4321,   //  Remote Who Is
05975             c_unicall_tcp                  = (INT)  4343,   //  UNICALL
05976             c_unicall_udp                  = (INT)  4343,   //  UNICALL
05977             c_vinainstall_tcp              = (INT)  4344,   //  VinaInstall
05978             c_vinainstall_udp              = (INT)  4344,   //  VinaInstall
05979             c_m4_network_as_tcp            = (INT)  4345,   //  Macro 4 Network AS
05980             c_m4_network_as_udp            = (INT)  4345,   //  Macro 4 Network AS
05981             c_elanlm_tcp                   = (INT)  4346,   //  ELAN LM
05982             c_elanlm_udp                   = (INT)  4346,   //  ELAN LM
05983             c_lansurveyor_tcp              = (INT)  4347,   //  LAN Surveyor
05984             c_lansurveyor_udp              = (INT)  4347,   //  LAN Surveyor
05985             c_itose_tcp                    = (INT)  4348,   //  ITOSE
05986             c_itose_udp                    = (INT)  4348,   //  ITOSE
05987             c_fsportmap_tcp                = (INT)  4349,   //  File System Port Map
05988             c_fsportmap_udp                = (INT)  4349,   //  File System Port Map
05989             c_net_device_tcp               = (INT)  4350,   //  Net Device
05990             c_net_device_udp               = (INT)  4350,   //  Net Device
05991             c_plcy_net_svcs_tcp            = (INT)  4351,   //  PLCY Net Services
05992             c_plcy_net_svcs_udp            = (INT)  4351,   //  PLCY Net Services
05993             c_f5_iquery_tcp                = (INT)  4353,   //  F5 iQuery
05994             c_f5_iquery_udp                = (INT)  4353,   //  F5 iQuery
05995             c_qsnet_trans_tcp              = (INT)  4354,   //  QSNet Transmitter
05996             c_qsnet_trans_udp              = (INT)  4354,   //  QSNet Transmitter
05997             c_qsnet_workst_tcp             = (INT)  4355,   //  QSNet Workstation
05998             c_qsnet_workst_udp             = (INT)  4355,   //  QSNet Workstation
05999             c_qsnet_assist_tcp             = (INT)  4356,   //  QSNet Assistant
06000             c_qsnet_assist_udp             = (INT)  4356,   //  QSNet Assistant
06001             c_qsnet_cond_tcp               = (INT)  4357,   //  QSNet Conductor
06002             c_qsnet_cond_udp               = (INT)  4357,   //  QSNet Conductor
06003             c_qsnet_nucl_tcp               = (INT)  4358,   //  QSNet Nucleus
06004             c_qsnet_nucl_udp               = (INT)  4358,   //  QSNet Nucleus
06005             c_saris_tcp                    = (INT)  4442,   //  Saris
06006             c_saris_udp                    = (INT)  4442,   //  Saris
06007             c_pharos_tcp                   = (INT)  4443,   //  Pharos
06008             c_pharos_udp                   = (INT)  4443,   //  Pharos
06009             c_krb524_tcp                   = (INT)  4444,   //  KRB524
06010             c_krb524_udp                   = (INT)  4444,   //  KRB524
06011             c_nv_video_tcp                 = (INT)  4444,   //  NV Video default
06012             c_nv_video_udp                 = (INT)  4444,   //  NV Video default
06013             c_upnotifyp_tcp                = (INT)  4445,   //  UPNOTIFYP
06014             c_upnotifyp_udp                = (INT)  4445,   //  UPNOTIFYP
06015             c_n1_fwp_tcp                   = (INT)  4446,   //  N1-FWP
06016             c_n1_fwp_udp                   = (INT)  4446,   //  N1-FWP
06017             c_n1_rmgmt_tcp                 = (INT)  4447,   //  N1-RMGMT
06018             c_n1_rmgmt_udp                 = (INT)  4447,   //  N1-RMGMT
06019             c_asc_slmd_tcp                 = (INT)  4448,   //  ASC Licence Manager
06020             c_asc_slmd_udp                 = (INT)  4448,   //  ASC Licence Manager
06021             c_privatewire_tcp              = (INT)  4449,   //  PrivateWire
06022             c_privatewire_udp              = (INT)  4449,   //  PrivateWire
06023             c_camp_tcp                     = (INT)  4450,   //  Camp
06024             c_camp_udp                     = (INT)  4450,   //  Camp
06025             c_ctisystemmsg_tcp             = (INT)  4451,   //  CTI System Msg
06026             c_ctisystemmsg_udp             = (INT)  4451,   //  CTI System Msg
06027             c_ctiprogramload_tcp           = (INT)  4452,   //  CTI Program Load
06028             c_ctiprogramload_udp           = (INT)  4452,   //  CTI Program Load
06029             c_nssalertmgr_tcp              = (INT)  4453,   //  NSS Alert Manager
06030             c_nssalertmgr_udp              = (INT)  4453,   //  NSS Alert Manager
06031             c_nssagentmgr_tcp              = (INT)  4454,   //  NSS Agent Manager
06032             c_nssagentmgr_udp              = (INT)  4454,   //  NSS Agent Manager
06033             c_prchat_user_tcp              = (INT)  4455,   //  PR Chat User
06034             c_prchat_user_udp              = (INT)  4455,   //  PR Chat User
06035             c_prchat_server_tcp            = (INT)  4456,   //  PR Chat Server
06036             c_prchat_server_udp            = (INT)  4456,   //  PR Chat Server
06037             c_ipsec_msft_tcp               = (INT)  4500,   //  Microsoft IPsec NAT-T
06038             c_ipsec_msft_udp               = (INT)  4500,   //  Microsoft IPsec NAT-T
06039             c_worldscores_tcp              = (INT)  4545,   //  WorldScores
06040             c_worldscores_udp              = (INT)  4545,   //  WorldScores
06041             c_sf_lm_tcp                    = (INT)  4546,   //  SF License Manager (Sentinel)
06042             c_sf_lm_udp                    = (INT)  4546,   //  SF License Manager (Sentinel)
06043             c_lanner_lm_tcp                = (INT)  4547,   //  Lanner License Manager
06044             c_lanner_lm_udp                = (INT)  4547,   //  Lanner License Manager
06045             c_rsip_tcp                     = (INT)  4555,   //  RSIP Port
06046             c_rsip_udp                     = (INT)  4555,   //  RSIP Port
06047             c_hylafax_tcp                  = (INT)  4559,   //  HylaFAX
06048             c_hylafax_udp                  = (INT)  4559,   //  HylaFAX
06049             c_tram_tcp                     = (INT)  4567,   //  TRAM
06050             c_tram_udp                     = (INT)  4567,   //  TRAM
06051             c_bmc_reporting_tcp            = (INT)  4568,   //  BMC Reporting
06052             c_bmc_reporting_udp            = (INT)  4568,   //  BMC Reporting
06053             c_piranha1_tcp                 = (INT)  4600,   //  Piranha1
06054             c_piranha1_udp                 = (INT)  4600,   //  Piranha1
06055             c_piranha2_tcp                 = (INT)  4601,   //  Piranha2
06056             c_piranha2_udp                 = (INT)  4601,   //  Piranha2
06057             c_smaclmgr_tcp                 = (INT)  4660,   //  smaclmgr
06058             c_smaclmgr_udp                 = (INT)  4660,   //  smaclmgr
06059             c_kar2ouche_tcp                = (INT)  4661,   //  Kar2ouche Peer location service
06060             c_kar2ouche_udp                = (INT)  4661,   //  Kar2ouche Peer location service
06061             c_rfa_tcp                      = (INT)  4672,   //  remote file access server
06062             c_rfa_udp                      = (INT)  4672,   //  remote file access server
06063             c_snap_tcp                     = (INT)  4752,   //  Simple Network Audio Protocol
06064             c_snap_udp                     = (INT)  4752,   //  Simple Network Audio Protocol
06065             c_iims_tcp                     = (INT)  4800,   //  Icona Instant Messenging System
06066             c_iims_udp                     = (INT)  4800,   //  Icona Instant Messenging System
06067             c_iwec_tcp                     = (INT)  4801,   //  Icona Web Embedded Chat
06068             c_iwec_udp                     = (INT)  4801,   //  Icona Web Embedded Chat
06069             c_ilss_tcp                     = (INT)  4802,   //  Icona License System Server
06070             c_ilss_udp                     = (INT)  4802,   //  Icona License System Server
06071             c_htcp_tcp                     = (INT)  4827,   //  HTCP
06072             c_htcp_udp                     = (INT)  4827,   //  HTCP
06073             c_varadero_0_tcp               = (INT)  4837,   //  Varadero-0
06074             c_varadero_0_udp               = (INT)  4837,   //  Varadero-0
06075             c_varadero_1_tcp               = (INT)  4838,   //  Varadero-1
06076             c_varadero_1_udp               = (INT)  4838,   //  Varadero-1
06077             c_varadero_2_tcp               = (INT)  4839,   //  Varadero-2
06078             c_varadero_2_udp               = (INT)  4839,   //  Varadero-2
06079             c_phrelay_tcp                  = (INT)  4868,   //  Photon Relay
06080             c_phrelay_udp                  = (INT)  4868,   //  Photon Relay
06081             c_phrelaydbg_tcp               = (INT)  4869,   //  Photon Relay Debug
06082             c_phrelaydbg_udp               = (INT)  4869,   //  Photon Relay Debug
06083             c_abbs_tcp                     = (INT)  4885,   //  ABBS
06084             c_abbs_udp                     = (INT)  4885,   //  ABBS
06085             c_lyskom_tcp                   = (INT)  4894,   //  LysKOM Protocol A
06086             c_lyskom_udp                   = (INT)  4894,   //  LysKOM Protocol A
06087             c_att_intercom_tcp             = (INT)  4983,   //  AT&T Intercom
06088             c_att_intercom_udp             = (INT)  4983,   //  AT&T Intercom
06089             c_smar_se_port1_tcp            = (INT)  4987,   //  SMAR Ethernet Port 1
06090             c_smar_se_port1_udp            = (INT)  4987,   //  SMAR Ethernet Port 1
06091             c_smar_se_port2_tcp            = (INT)  4988,   //  SMAR Ethernet Port 2
06092             c_smar_se_port2_udp            = (INT)  4988,   //  SMAR Ethernet Port 2
06093             c_commplex_main_tcp            = (INT)  5000,   //
06094             c_commplex_main_udp            = (INT)  5000,   //
06095             c_commplex_link_tcp            = (INT)  5001,   //
06096             c_commplex_link_udp            = (INT)  5001,   //
06097             c_rfe_tcp                      = (INT)  5002,   //  radio free ethernet
06098             c_rfe_udp                      = (INT)  5002,   //  radio free ethernet
06099             c_fmpro_internal_tcp           = (INT)  5003,   //  FileMaker, Inc. - Proprietary transport
06100             c_fmpro_internal_udp           = (INT)  5003,   //  FileMaker, Inc. - Proprietary name binding
06101             c_avt_profile_1_tcp            = (INT)  5004,   //  avt-profile-1
06102             c_avt_profile_1_udp            = (INT)  5004,   //  avt-profile-1
06103             c_avt_profile_2_tcp            = (INT)  5005,   //  avt-profile-2
06104             c_avt_profile_2_udp            = (INT)  5005,   //  avt-profile-2
06105             c_wsm_server_tcp               = (INT)  5006,   //  wsm server
06106             c_wsm_server_udp               = (INT)  5006,   //  wsm server
06107             c_wsm_server_ssl_tcp           = (INT)  5007,   //  wsm server ssl
06108             c_wsm_server_ssl_udp           = (INT)  5007,   //  wsm server ssl
06109             c_synapsis_edge_tcp            = (INT)  5008,   //  Synapsis EDGE
06110             c_synapsis_edge_udp            = (INT)  5008,   //  Synapsis EDGE
06111             c_telelpathstart_tcp           = (INT)  5010,   //  TelepathStart
06112             c_telelpathstart_udp           = (INT)  5010,   //  TelepathStart
06113             c_telelpathattack_tcp          = (INT)  5011,   //  TelepathAttack
06114             c_telelpathattack_udp          = (INT)  5011,   //  TelepathAttack
06115             c_zenginkyo_1_tcp              = (INT)  5020,   //  zenginkyo-1
06116             c_zenginkyo_1_udp              = (INT)  5020,   //  zenginkyo-1
06117             c_zenginkyo_2_tcp              = (INT)  5021,   //  zenginkyo-2
06118             c_zenginkyo_2_udp              = (INT)  5021,   //  zenginkyo-2
06119             c_mice_tcp                     = (INT)  5022,   //  mice server
06120             c_mice_udp                     = (INT)  5022,   //  mice server
06121             c_htuilsrv_tcp                 = (INT)  5023,   //  Htuil Server for PLD2
06122             c_htuilsrv_udp                 = (INT)  5023,   //  Htuil Server for PLD2
06123             c_asnaacceler8db_tcp           = (INT)  5042,   //  asnaacceler8db
06124             c_asnaacceler8db_udp           = (INT)  5042,   //  asnaacceler8db
06125             c_mmcc_tcp                     = (INT)  5050,   //  multimedia conference control tool
06126             c_mmcc_udp                     = (INT)  5050,   //  multimedia conference control tool
06127             c_ita_agent_tcp                = (INT)  5051,   //  ITA Agent
06128             c_ita_agent_udp                = (INT)  5051,   //  ITA Agent
06129             c_ita_manager_tcp              = (INT)  5052,   //  ITA Manager
06130             c_ita_manager_udp              = (INT)  5052,   //  ITA Manager
06131             c_unot_tcp                     = (INT)  5055,   //  UNOT
06132             c_unot_udp                     = (INT)  5055,   //  UNOT
06133             c_intecom_ps1_tcp              = (INT)  5056,   //  Intecom PS 1
06134             c_intecom_ps1_udp              = (INT)  5056,   //  Intecom PS 1
06135             c_intecom_ps2_tcp              = (INT)  5057,   //  Intecom PS 2
06136             c_intecom_ps2_udp              = (INT)  5057,   //  Intecom PS 2
06137             c_sip_tcp                      = (INT)  5060,   //  SIP
06138             c_sip_udp                      = (INT)  5060,   //  SIP
06139             c_sip_tls_tcp                  = (INT)  5061,   //  SIP-TLS
06140             c_sip_tls_udp                  = (INT)  5061,   //  SIP-TLS
06141             c_stanag_5066_tcp              = (INT)  5066,   //  STANAG-5066-SUBNET-INTF
06142             c_stanag_5066_udp              = (INT)  5066,   //  STANAG-5066-SUBNET-INTF
06143             c_i_net_2000_npr_tcp           = (INT)  5069,   //  I/Net 2000-NPR
06144             c_i_net_2000_npr_udp           = (INT)  5069,   //  I/Net 2000-NPR
06145             c_powerschool_tcp              = (INT)  5071,   //  PowerSchool
06146             c_powerschool_udp              = (INT)  5071,   //  PowerSchool
06147             c_sdl_ets_tcp                  = (INT)  5081,   //  SDL - Ent Trans Server
06148             c_sdl_ets_udp                  = (INT)  5081,   //  SDL - Ent Trans Server
06149             c_sentinel_lm_tcp              = (INT)  5093,   //  Sentinel LM
06150             c_sentinel_lm_udp              = (INT)  5093,   //  Sentinel LM
06151             c_sentlm_srv2srv_tcp           = (INT)  5099,   //  SentLM Srv2Srv
06152             c_sentlm_srv2srv_udp           = (INT)  5099,   //  SentLM Srv2Srv
06153             c_talarian_tcp_tcp             = (INT)  5101,   //  Talarian_TCP
06154             c_talarian_udp_udp             = (INT)  5101,   //  Talarian_UDP
06155             c_atmp_tcp                     = (INT)  5150,   //  Ascend Tunnel Management Protocol
06156             c_atmp_udp                     = (INT)  5150,   //  Ascend Tunnel Management Protocol
06157             c_sde_discovery_tcp            = (INT)  5152,   //  ESRI SDE Instance Discovery
06158             c_sde_discovery_udp            = (INT)  5152,   //  ESRI SDE Instance Discovery
06159             c_aol_tcp                      = (INT)  5190,   //  America-Online
06160             c_aol_udp                      = (INT)  5190,   //  America-Online
06161             c_aol_1_tcp                    = (INT)  5191,   //  AmericaOnline1
06162             c_aol_1_udp                    = (INT)  5191,   //  AmericaOnline1
06163             c_aol_2_tcp                    = (INT)  5192,   //  AmericaOnline2
06164             c_aol_2_udp                    = (INT)  5192,   //  AmericaOnline2
06165             c_aol_3_tcp                    = (INT)  5193,   //  AmericaOnline3
06166             c_aol_3_udp                    = (INT)  5193,   //  AmericaOnline3
06167             c_targus_getdata_tcp           = (INT)  5200,   //  TARGUS GetData
06168             c_targus_getdata_udp           = (INT)  5200,   //  TARGUS GetData
06169             c_targus_getdata1_tcp          = (INT)  5201,   //  TARGUS GetData 1
06170             c_targus_getdata1_udp          = (INT)  5201,   //  TARGUS GetData 1
06171             c_targus_getdata2_tcp          = (INT)  5202,   //  TARGUS GetData 2
06172             c_targus_getdata2_udp          = (INT)  5202,   //  TARGUS GetData 2
06173             c_targus_getdata3_tcp          = (INT)  5203,   //  TARGUS GetData 3
06174             c_targus_getdata3_udp          = (INT)  5203,   //  TARGUS GetData 3
06175             c_jabber_client_tcp            = (INT)  5222,   //  Jabber Client Connection
06176             c_jabber_client_udp            = (INT)  5222,   //  Jabber Client Connection
06177             c_hp_server_tcp                = (INT)  5225,   //  HP Server
06178             c_hp_server_udp                = (INT)  5225,   //  HP Server
06179             c_hp_status_tcp                = (INT)  5226,   //  HP Status
06180             c_hp_status_udp                = (INT)  5226,   //  HP Status
06181             c_padl2sim_tcp                 = (INT)  5236,   //
06182             c_padl2sim_udp                 = (INT)  5236,   //
06183             c_igateway_tcp                 = (INT)  5250,   //  iGateway
06184             c_igateway_udp                 = (INT)  5250,   //  iGateway
06185             c_jabber_server_tcp            = (INT)  5269,   //  Jabber Server Connection
06186             c_jabber_server_udp            = (INT)  5269,   //  Jabber Server Connection
06187             c_pk_tcp                       = (INT)  5272,   //  PK
06188             c_pk_udp                       = (INT)  5272,   //  PK
06189             c_hacl_hb_tcp                  = (INT)  5300,   //  # HA cluster heartbeat
06190             c_hacl_hb_udp                  = (INT)  5300,   //  # HA cluster heartbeat
06191             c_hacl_gs_tcp                  = (INT)  5301,   //  # HA cluster general services
06192             c_hacl_gs_udp                  = (INT)  5301,   //  # HA cluster general services
06193             c_hacl_cfg_tcp                 = (INT)  5302,   //  # HA cluster configuration
06194             c_hacl_cfg_udp                 = (INT)  5302,   //  # HA cluster configuration
06195             c_hacl_probe_tcp               = (INT)  5303,   //  # HA cluster probing
06196             c_hacl_probe_udp               = (INT)  5303,   //  # HA cluster probing
06197             c_hacl_local_tcp               = (INT)  5304,   //  # HA Cluster Commands
06198             c_hacl_local_udp               = (INT)  5304,   //
06199             c_hacl_test_tcp                = (INT)  5305,   //  # HA Cluster Test
06200             c_hacl_test_udp                = (INT)  5305,   //
06201             c_sun_mc_grp_tcp               = (INT)  5306,   //  Sun MC Group
06202             c_sun_mc_grp_udp               = (INT)  5306,   //  Sun MC Group
06203             c_sco_aip_tcp                  = (INT)  5307,   //  SCO AIP
06204             c_sco_aip_udp                  = (INT)  5307,   //  SCO AIP
06205             c_cfengine_tcp                 = (INT)  5308,   //  CFengine
06206             c_cfengine_udp                 = (INT)  5308,   //  CFengine
06207             c_jprinter_tcp                 = (INT)  5309,   //  J Printer
06208             c_jprinter_udp                 = (INT)  5309,   //  J Printer
06209             c_outlaws_tcp                  = (INT)  5310,   //  Outlaws
06210             c_outlaws_udp                  = (INT)  5310,   //  Outlaws
06211             c_tmlogin_tcp                  = (INT)  5311,   //  TM Login
06212             c_tmlogin_udp                  = (INT)  5311,   //  TM Login
06213             c_opalis_rbt_ipc_tcp           = (INT)  5314,   //  opalis-rbt-ipc
06214             c_opalis_rbt_ipc_udp           = (INT)  5314,   //  opalis-rbt-ipc
06215             c_hacl_poll_tcp                = (INT)  5315,   //  HA Cluster UDP Polling
06216             c_hacl_poll_udp                = (INT)  5315,   //  HA Cluster UDP Polling
06217             c_mdns_tcp                     = (INT)  5353,   //  Multicast DNS
06218             c_mdns_udp                     = (INT)  5353,   //  Multicast DNS
06219             c_excerpt_tcp                  = (INT)  5400,   //  Excerpt Search
06220             c_excerpt_udp                  = (INT)  5400,   //  Excerpt Search
06221             c_excerpts_tcp                 = (INT)  5401,   //  Excerpt Search Secure
06222             c_excerpts_udp                 = (INT)  5401,   //  Excerpt Search Secure
06223             c_mftp_1_tcp                   = (INT)  5402,   //  MFTP
06224             c_mftp_1_udp                   = (INT)  5402,   //  MFTP
06225             c_hpoms_ci_lstn_tcp            = (INT)  5403,   //  HPOMS-CI-LSTN
06226             c_hpoms_ci_lstn_udp            = (INT)  5403,   //  HPOMS-CI-LSTN
06227             c_hpoms_dps_lstn_tcp           = (INT)  5404,   //  HPOMS-DPS-LSTN
06228             c_hpoms_dps_lstn_udp           = (INT)  5404,   //  HPOMS-DPS-LSTN
06229             c_netsupport_tcp               = (INT)  5405,   //  NetSupport
06230             c_netsupport_udp               = (INT)  5405,   //  NetSupport
06231             c_systemics_sox_tcp            = (INT)  5406,   //  Systemics Sox
06232             c_systemics_sox_udp            = (INT)  5406,   //  Systemics Sox
06233             c_foresyte_clear_tcp           = (INT)  5407,   //  Foresyte-Clear
06234             c_foresyte_clear_udp           = (INT)  5407,   //  Foresyte-Clear
06235             c_foresyte_sec_tcp             = (INT)  5408,   //  Foresyte-Sec
06236             c_foresyte_sec_udp             = (INT)  5408,   //  Foresyte-Sec
06237             c_salient_dtasrv_tcp           = (INT)  5409,   //  Salient Data Server
06238             c_salient_dtasrv_udp           = (INT)  5409,   //  Salient Data Server
06239             c_salient_usrmgr_tcp           = (INT)  5410,   //  Salient User Manager
06240             c_salient_usrmgr_udp           = (INT)  5410,   //  Salient User Manager
06241             c_actnet_tcp                   = (INT)  5411,   //  ActNet
06242             c_actnet_udp                   = (INT)  5411,   //  ActNet
06243             c_continuus_tcp                = (INT)  5412,   //  Continuus
06244             c_continuus_udp                = (INT)  5412,   //  Continuus
06245             c_wwiotalk_tcp                 = (INT)  5413,   //  WWIOTALK
06246             c_wwiotalk_udp                 = (INT)  5413,   //  WWIOTALK
06247             c_statusd_tcp                  = (INT)  5414,   //  StatusD
06248             c_statusd_udp                  = (INT)  5414,   //  StatusD
06249             c_ns_server_tcp                = (INT)  5415,   //  NS Server
06250             c_ns_server_udp                = (INT)  5415,   //  NS Server
06251             c_sns_gateway_tcp              = (INT)  5416,   //  SNS Gateway
06252             c_sns_gateway_udp              = (INT)  5416,   //  SNS Gateway
06253             c_sns_agent_tcp                = (INT)  5417,   //  SNS Agent
06254             c_sns_agent_udp                = (INT)  5417,   //  SNS Agent
06255             c_mcntp_tcp                    = (INT)  5418,   //  MCNTP
06256             c_mcntp_udp                    = (INT)  5418,   //  MCNTP
06257             c_dj_ice_tcp                   = (INT)  5419,   //  DJ-ICE
06258             c_dj_ice_udp                   = (INT)  5419,   //  DJ-ICE
06259             c_cylink_c_tcp                 = (INT)  5420,   //  Cylink-C
06260             c_cylink_c_udp                 = (INT)  5420,   //  Cylink-C
06261             c_netsupport2_tcp              = (INT)  5421,   //  Net Support 2
06262             c_netsupport2_udp              = (INT)  5421,   //  Net Support 2
06263             c_salient_mux_tcp              = (INT)  5422,   //  Salient MUX
06264             c_salient_mux_udp              = (INT)  5422,   //  Salient MUX
06265             c_virtualuser_tcp              = (INT)  5423,   //  VIRTUALUSER
06266             c_virtualuser_udp              = (INT)  5423,   //  VIRTUALUSER
06267             c_devbasic_tcp                 = (INT)  5426,   //  DEVBASIC
06268             c_devbasic_udp                 = (INT)  5426,   //  DEVBASIC
06269             c_sco_peer_tta_tcp             = (INT)  5427,   //  SCO-PEER-TTA
06270             c_sco_peer_tta_udp             = (INT)  5427,   //  SCO-PEER-TTA
06271             c_telaconsole_tcp              = (INT)  5428,   //  TELACONSOLE
06272             c_telaconsole_udp              = (INT)  5428,   //  TELACONSOLE
06273             c_base_tcp                     = (INT)  5429,   //  Billing and Accounting System Exchange
06274             c_base_udp                     = (INT)  5429,   //  Billing and Accounting System Exchange
06275             c_radec_corp_tcp               = (INT)  5430,   //  RADEC CORP
06276             c_radec_corp_udp               = (INT)  5430,   //  RADEC CORP
06277             c_park_agent_tcp               = (INT)  5431,   //  PARK AGENT
06278             c_park_agent_udp               = (INT)  5431,   //  PARK AGENT
06279             c_postgresql_tcp               = (INT)  5432,   //  PostgreSQL Database
06280             c_postgresql_udp               = (INT)  5432,   //  PostgreSQL Database
06281             c_dttl_tcp                     = (INT)  5435,   //  Data Tunneling Transceiver Linking (DTTL)
06282             c_dttl_udp                     = (INT)  5435,   //  Data Tunneling Transceiver Linking (DTTL)
06283             c_apc_tcp_udp_4_tcp            = (INT)  5454,   //  apc-tcp-udp-4
06284             c_apc_tcp_udp_4_udp            = (INT)  5454,   //  apc-tcp-udp-4
06285             c_apc_tcp_udp_5_tcp            = (INT)  5455,   //  apc-tcp-udp-5
06286             c_apc_tcp_udp_5_udp            = (INT)  5455,   //  apc-tcp-udp-5
06287             c_apc_tcp_udp_6_tcp            = (INT)  5456,   //  apc-tcp-udp-6
06288             c_apc_tcp_udp_6_udp            = (INT)  5456,   //  apc-tcp-udp-6
06289             c_silkmeter_tcp                = (INT)  5461,   //  SILKMETER
06290             c_silkmeter_udp                = (INT)  5461,   //  SILKMETER
06291             c_ttl_publisher_tcp            = (INT)  5462,   //  TTL Publisher
06292             c_ttl_publisher_udp            = (INT)  5462,   //  TTL Publisher
06293             c_ttlpriceproxy_tcp            = (INT)  5463,   //  TTL Price Proxy
06294             c_ttlpriceproxy_udp            = (INT)  5463,   //  TTL Price Proxy
06295             c_netops_broker_tcp            = (INT)  5465,   //  NETOPS-BROKER
06296             c_netops_broker_udp            = (INT)  5465,   //  NETOPS-BROKER
06297             c_fcp_addr_srvr1_tcp           = (INT)  5500,   //  fcp-addr-srvr1
06298             c_fcp_addr_srvr1_udp           = (INT)  5500,   //  fcp-addr-srvr1
06299             c_fcp_addr_srvr2_tcp           = (INT)  5501,   //  fcp-addr-srvr2
06300             c_fcp_addr_srvr2_udp           = (INT)  5501,   //  fcp-addr-srvr2
06301             c_fcp_srvr_inst1_tcp           = (INT)  5502,   //  fcp-srvr-inst1
06302             c_fcp_srvr_inst1_udp           = (INT)  5502,   //  fcp-srvr-inst1
06303             c_fcp_srvr_inst2_tcp           = (INT)  5503,   //  fcp-srvr-inst2
06304             c_fcp_srvr_inst2_udp           = (INT)  5503,   //  fcp-srvr-inst2
06305             c_fcp_cics_gw1_tcp             = (INT)  5504,   //  fcp-cics-gw1
06306             c_fcp_cics_gw1_udp             = (INT)  5504,   //  fcp-cics-gw1
06307             c_sgi_esphttp_tcp              = (INT)  5554,   //  SGI ESP HTTP
06308             c_sgi_esphttp_udp              = (INT)  5554,   //  SGI ESP HTTP
06309             c_personal_agent_tcp           = (INT)  5555,   //  Personal Agent
06310             c_personal_agent_udp           = (INT)  5555,   //  Personal Agent
06311             c_udpplus_tcp                  = (INT)  5566,   //  UDPPlus
06312             c_udpplus_udp                  = (INT)  5566,   //  UDPPlus
06313             c_esinstall_tcp                = (INT)  5599,   //  Enterprise Security Remote Install
06314             c_esinstall_udp                = (INT)  5599,   //  Enterprise Security Remote Install
06315             c_esmmanager_tcp               = (INT)  5600,   //  Enterprise Security Manager
06316             c_esmmanager_udp               = (INT)  5600,   //  Enterprise Security Manager
06317             c_esmagent_tcp                 = (INT)  5601,   //  Enterprise Security Agent
06318             c_esmagent_udp                 = (INT)  5601,   //  Enterprise Security Agent
06319             c_a1_msc_tcp                   = (INT)  5602,   //  A1-MSC
06320             c_a1_msc_udp                   = (INT)  5602,   //  A1-MSC
06321             c_a1_bs_tcp                    = (INT)  5603,   //  A1-BS
06322             c_a1_bs_udp                    = (INT)  5603,   //  A1-BS
06323             c_a3_sdunode_tcp               = (INT)  5604,   //  A3-SDUNode
06324             c_a3_sdunode_udp               = (INT)  5604,   //  A3-SDUNode
06325             c_a4_sdunode_tcp               = (INT)  5605,   //  A4-SDUNode
06326             c_a4_sdunode_udp               = (INT)  5605,   //  A4-SDUNode
06327             c_pcanywheredata_tcp           = (INT)  5631,   //  pcANYWHEREdata
06328             c_pcanywheredata_udp           = (INT)  5631,   //  pcANYWHEREdata
06329             c_pcanywherestat_tcp           = (INT)  5632,   //  pcANYWHEREstat
06330             c_pcanywherestat_udp           = (INT)  5632,   //  pcANYWHEREstat
06331             c_jms_tcp                      = (INT)  5673,   //  JACL Message Server
06332             c_jms_udp                      = (INT)  5673,   //  JACL Message Server
06333             c_hyperscsi_port_tcp           = (INT)  5674,   //  HyperSCSI Port
06334             c_hyperscsi_port_udp           = (INT)  5674,   //  HyperSCSI Port
06335             c_v5ua_tcp                     = (INT)  5675,   //  V5UA application port
06336             c_v5ua_udp                     = (INT)  5675,   //  V5UA application port
06337             c_raadmin_tcp                  = (INT)  5676,   //  RA Administration
06338             c_raadmin_udp                  = (INT)  5676,   //  RA Administration
06339             c_questdb2_lnchr_tcp           = (INT)  5677,   //  Quest Central DB2 Launchr
06340             c_questdb2_lnchr_udp           = (INT)  5677,   //  Quest Central DB2 Launchr
06341             c_rrac_tcp                     = (INT)  5678,   //  Remote Replication Agent Connection
06342             c_rrac_udp                     = (INT)  5678,   //  Remote Replication Agent Connection
06343             c_dccm_tcp                     = (INT)  5679,   //  Direct Cable Connect Manager
06344             c_dccm_udp                     = (INT)  5679,   //  Direct Cable Connect Manager
06345             c_proshareaudio_tcp            = (INT)  5713,   //  proshare conf audio
06346             c_proshareaudio_udp            = (INT)  5713,   //  proshare conf audio
06347             c_prosharevideo_tcp            = (INT)  5714,   //  proshare conf video
06348             c_prosharevideo_udp            = (INT)  5714,   //  proshare conf video
06349             c_prosharedata_tcp             = (INT)  5715,   //  proshare conf data
06350             c_prosharedata_udp             = (INT)  5715,   //  proshare conf data
06351             c_prosharerequest_tcp          = (INT)  5716,   //  proshare conf request
06352             c_prosharerequest_udp          = (INT)  5716,   //  proshare conf request
06353             c_prosharenotify_tcp           = (INT)  5717,   //  proshare conf notify
06354             c_prosharenotify_udp           = (INT)  5717,   //  proshare conf notify
06355             c_openmail_tcp                 = (INT)  5729,   //  Openmail User Agent Layer
06356             c_openmail_udp                 = (INT)  5729,   //  Openmail User Agent Layer
06357             c_unieng_tcp                   = (INT)  5730,   //  Steltor's calendar access
06358             c_unieng_udp                   = (INT)  5730,   //  Steltor's calendar access
06359             c_ida_discover1_tcp            = (INT)  5741,   //  IDA Discover Port 1
06360             c_ida_discover1_udp            = (INT)  5741,   //  IDA Discover Port 1
06361             c_ida_discover2_tcp            = (INT)  5742,   //  IDA Discover Port 2
06362             c_ida_discover2_udp            = (INT)  5742,   //  IDA Discover Port 2
06363             c_fcopy_server_tcp             = (INT)  5745,   //  fcopy-server
06364             c_fcopy_server_udp             = (INT)  5745,   //  fcopy-server
06365             c_fcopys_server_tcp            = (INT)  5746,   //  fcopys-server
06366             c_fcopys_server_udp            = (INT)  5746,   //  fcopys-server
06367             c_openmailg_tcp                = (INT)  5755,   //  OpenMail Desk Gateway server
06368             c_openmailg_udp                = (INT)  5755,   //  OpenMail Desk Gateway server
06369             c_x500ms_tcp                   = (INT)  5757,   //  OpenMail X.500 Directory Server
06370             c_x500ms_udp                   = (INT)  5757,   //  OpenMail X.500 Directory Server
06371             c_openmailns_tcp               = (INT)  5766,   //  OpenMail NewMail Server
06372             c_openmailns_udp               = (INT)  5766,   //  OpenMail NewMail Server
06373             c_s_openmail_tcp               = (INT)  5767,   //  OpenMail Suer Agent Layer (Secure)
06374             c_s_openmail_udp               = (INT)  5767,   //  OpenMail Suer Agent Layer (Secure)
06375             c_openmailpxy_tcp              = (INT)  5768,   //  OpenMail CMTS Server
06376             c_openmailpxy_udp              = (INT)  5768,   //  OpenMail CMTS Server
06377             c_netagent_tcp                 = (INT)  5771,   //  NetAgent
06378             c_netagent_udp                 = (INT)  5771,   //  NetAgent
06379             c_icmpd_tcp                    = (INT)  5813,   //  ICMPD
06380             c_icmpd_udp                    = (INT)  5813,   //  ICMPD
06381             c_wherehoo_tcp                 = (INT)  5859,   //  WHEREHOO
06382             c_wherehoo_udp                 = (INT)  5859,   //  WHEREHOO
06383             c_mppolicy_v5_tcp              = (INT)  5968,   //  mppolicy-v5
06384             c_mppolicy_v5_udp              = (INT)  5968,   //  mppolicy-v5
06385             c_mppolicy_mgr_tcp             = (INT)  5969,   //  mppolicy-mgr
06386             c_mppolicy_mgr_udp             = (INT)  5969,   //  mppolicy-mgr
06387             c_wbem_rmi_tcp                 = (INT)  5987,   //  WBEM RMI
06388             c_wbem_rmi_udp                 = (INT)  5987,   //  WBEM RMI
06389             c_wbem_http_tcp                = (INT)  5988,   //  WBEM HTTP
06390             c_wbem_http_udp                = (INT)  5988,   //  WBEM HTTP
06391             c_wbem_https_tcp               = (INT)  5989,   //  WBEM HTTPS
06392             c_wbem_https_udp               = (INT)  5989,   //  WBEM HTTPS
06393             c_wbem_local_tcp               = (INT)  5990,   //  HP WBEM Local Connection
06394             c_wbem_local_udp               = (INT)  5990,   //  HP WBEM Local Connection
06395             c_nuxsl_tcp                    = (INT)  5991,   //  NUXSL
06396             c_nuxsl_udp                    = (INT)  5991,   //  NUXSL
06397             c_cvsup_tcp                    = (INT)  5999,   //  CVSup
06398             c_cvsup_udp                    = (INT)  5999,   //  CVSup
06399             c_ndl_ahp_svc_tcp              = (INT)  6064,   //  NDL-AHP-SVC
06400             c_ndl_ahp_svc_udp              = (INT)  6064,   //  NDL-AHP-SVC
06401             c_winpharaoh_tcp               = (INT)  6065,   //  WinPharaoh
06402             c_winpharaoh_udp               = (INT)  6065,   //  WinPharaoh
06403             c_ewctsp_tcp                   = (INT)  6066,   //  EWCTSP
06404             c_ewctsp_udp                   = (INT)  6066,   //  EWCTSP
06405             c_srb_tcp                      = (INT)  6067,   //  SRB
06406             c_srb_udp                      = (INT)  6067,   //  SRB
06407             c_gsmp_tcp                     = (INT)  6068,   //  GSMP
06408             c_gsmp_udp                     = (INT)  6068,   //  GSMP
06409             c_trip_tcp                     = (INT)  6069,   //  TRIP
06410             c_trip_udp                     = (INT)  6069,   //  TRIP
06411             c_messageasap_tcp              = (INT)  6070,   //  Messageasap
06412             c_messageasap_udp              = (INT)  6070,   //  Messageasap
06413             c_ssdtp_tcp                    = (INT)  6071,   //  SSDTP
06414             c_ssdtp_udp                    = (INT)  6071,   //  SSDTP
06415             c_diagnose_proc_tcp            = (INT)  6072,   //  DIAGNOSE-PROC
06416             c_diagnose_proc_udp            = (INT)  6072,   //  DIAGNOSE-PROC
06417             c_directplay8_tcp              = (INT)  6073,   //  DirectPlay8
06418             c_directplay8_udp              = (INT)  6073,   //  DirectPlay8
06419             c_synchronet_db_tcp            = (INT)  6100,   //  SynchroNet-db
06420             c_synchronet_db_udp            = (INT)  6100,   //  SynchroNet-db
06421             c_synchronet_rtc_tcp           = (INT)  6101,   //  SynchroNet-rtc
06422             c_synchronet_rtc_udp           = (INT)  6101,   //  SynchroNet-rtc
06423             c_synchronet_upd_tcp           = (INT)  6102,   //  SynchroNet-upd
06424             c_synchronet_upd_udp           = (INT)  6102,   //  SynchroNet-upd
06425             c_rets_tcp                     = (INT)  6103,   //  RETS
06426             c_rets_udp                     = (INT)  6103,   //  RETS
06427             c_dbdb_tcp                     = (INT)  6104,   //  DBDB
06428             c_dbdb_udp                     = (INT)  6104,   //  DBDB
06429             c_primaserver_tcp              = (INT)  6105,   //  Prima Server
06430             c_primaserver_udp              = (INT)  6105,   //  Prima Server
06431             c_mpsserver_tcp                = (INT)  6106,   //  MPS Server
06432             c_mpsserver_udp                = (INT)  6106,   //  MPS Server
06433             c_etc_control_tcp              = (INT)  6107,   //  ETC Control
06434             c_etc_control_udp              = (INT)  6107,   //  ETC Control
06435             c_sercomm_scadmin_tcp          = (INT)  6108,   //  Sercomm-SCAdmin
06436             c_sercomm_scadmin_udp          = (INT)  6108,   //  Sercomm-SCAdmin
06437             c_globecast_id_tcp             = (INT)  6109,   //  GLOBECAST-ID
06438             c_globecast_id_udp             = (INT)  6109,   //  GLOBECAST-ID
06439             c_softcm_tcp                   = (INT)  6110,   //  HP SoftBench CM
06440             c_softcm_udp                   = (INT)  6110,   //  HP SoftBench CM
06441             c_spc_tcp                      = (INT)  6111,   //  HP SoftBench Sub-Process Control
06442             c_spc_udp                      = (INT)  6111,   //  HP SoftBench Sub-Process Control
06443             c_dtspcd_tcp                   = (INT)  6112,   //  dtspcd
06444             c_dtspcd_udp                   = (INT)  6112,   //  dtspcd
06445             c_backup_express_tcp           = (INT)  6123,   //  Backup Express
06446             c_backup_express_udp           = (INT)  6123,   //  Backup Express
06447             c_meta_corp_tcp                = (INT)  6141,   //  Meta Corporation License Manager
06448             c_meta_corp_udp                = (INT)  6141,   //  Meta Corporation License Manager
06449             c_aspentec_lm_tcp              = (INT)  6142,   //  Aspen Technology License Manager
06450             c_aspentec_lm_udp              = (INT)  6142,   //  Aspen Technology License Manager
06451             c_watershed_lm_tcp             = (INT)  6143,   //  Watershed License Manager
06452             c_watershed_lm_udp             = (INT)  6143,   //  Watershed License Manager
06453             c_statsci1_lm_tcp              = (INT)  6144,   //  StatSci License Manager - 1
06454             c_statsci1_lm_udp              = (INT)  6144,   //  StatSci License Manager - 1
06455             c_statsci2_lm_tcp              = (INT)  6145,   //  StatSci License Manager - 2
06456             c_statsci2_lm_udp              = (INT)  6145,   //  StatSci License Manager - 2
06457             c_lonewolf_lm_tcp              = (INT)  6146,   //  Lone Wolf Systems License Manager
06458             c_lonewolf_lm_udp              = (INT)  6146,   //  Lone Wolf Systems License Manager
06459             c_montage_lm_tcp               = (INT)  6147,   //  Montage License Manager
06460             c_montage_lm_udp               = (INT)  6147,   //  Montage License Manager
06461             c_ricardo_lm_1_tcp             = (INT)  6148,   //  Ricardo North America License Manager
06462             c_ricardo_lm_1_udp             = (INT)  6148,   //  Ricardo North America License Manager
06463             c_tal_pod_tcp                  = (INT)  6149,   //  tal-pod
06464             c_tal_pod_udp                  = (INT)  6149,   //  tal-pod
06465             c_crip_tcp                     = (INT)  6253,   //  CRIP
06466             c_crip_udp                     = (INT)  6253,   //  CRIP
06467             c_bmc_grx_tcp                  = (INT)  6300,   //  BMC GRX
06468             c_bmc_grx_udp                  = (INT)  6300,   //  BMC GRX
06469             c_emp_server1_tcp              = (INT)  6321,   //  Empress Software Connectivity Server 1
06470             c_emp_server1_udp              = (INT)  6321,   //  Empress Software Connectivity Server 1
06471             c_emp_server2_tcp              = (INT)  6322,   //  Empress Software Connectivity Server 2
06472             c_emp_server2_udp              = (INT)  6322,   //  Empress Software Connectivity Server 2
06473             c_gnutella_svc_tcp             = (INT)  6346,   //  gnutella-svc
06474             c_gnutella_svc_udp             = (INT)  6346,   //  gnutella-svc
06475             c_gnutella_rtr_tcp             = (INT)  6347,   //  gnutella-rtr
06476             c_gnutella_rtr_udp             = (INT)  6347,   //  gnutella-rtr
06477             c_metatude_mds_tcp             = (INT)  6382,   //  Metatude Dialogue Server
06478             c_metatude_mds_udp             = (INT)  6382,   //  Metatude Dialogue Server
06479             c_clariion_evr01_tcp           = (INT)  6389,   //  clariion-evr01
06480             c_clariion_evr01_udp           = (INT)  6389,   //  clariion-evr01
06481             c_skip_cert_recv_tcp           = (INT)  6455,   //  SKIP Certificate Receive
06482             c_skip_cert_send_tcp           = (INT)  6456,   //  SKIP Certificate Send
06483             c_lvision_lm_tcp               = (INT)  6471,   //  LVision License Manager
06484             c_lvision_lm_udp               = (INT)  6471,   //  LVision License Manager
06485             c_boks_tcp                     = (INT)  6500,   //  BoKS Master
06486             c_boks_udp                     = (INT)  6500,   //  BoKS Master
06487             c_mgcs_mfp_port_tcp            = (INT)  6509,   //  MGCS-MFP Port
06488             c_mgcs_mfp_port_udp            = (INT)  6509,   //  MGCS-MFP Port
06489             c_mcer_port_tcp                = (INT)  6510,   //  MCER Port
06490             c_mcer_port_udp                = (INT)  6510,   //  MCER Port
06491             c_apc_tcp_udp_1_tcp            = (INT)  6547,   //  apc-tcp-udp-1
06492             c_apc_tcp_udp_1_udp            = (INT)  6547,   //  apc-tcp-udp-1
06493             c_apc_tcp_udp_2_tcp            = (INT)  6548,   //  apc-tcp-udp-2
06494             c_apc_tcp_udp_2_udp            = (INT)  6548,   //  apc-tcp-udp-2
06495             c_apc_tcp_udp_3_tcp            = (INT)  6549,   //  apc-tcp-udp-3
06496             c_apc_tcp_udp_3_udp            = (INT)  6549,   //  apc-tcp-udp-3
06497             c_fg_sysupdate_tcp             = (INT)  6550,   //  fg-sysupdate
06498             c_fg_sysupdate_udp             = (INT)  6550,   //  fg-sysupdate
06499             c_xdsxdm_tcp                   = (INT)  6558,   //
06500             c_xdsxdm_udp                   = (INT)  6558,   //
06501             c_parsec_master_tcp            = (INT)  6580,   //  Parsec Masterserver
06502             c_parsec_master_udp            = (INT)  6580,   //  Parsec Masterserver
06503             c_parsec_peer_tcp              = (INT)  6581,   //  Parsec Peer-to-Peer
06504             c_parsec_peer_udp              = (INT)  6581,   //  Parsec Peer-to-Peer
06505             c_parsec_game_tcp              = (INT)  6582,   //  Parsec Gameserver
06506             c_parsec_game_udp              = (INT)  6582,   //  Parsec Gameserver
06507             c_vocaltec_gold_tcp            = (INT)  6670,   //  Vocaltec Global Online Directory
06508             c_vocaltec_gold_udp            = (INT)  6670,   //  Vocaltec Global Online Directory
06509             c_kti_icad_srvr_tcp            = (INT)  6701,   //  KTI/ICAD Nameserver
06510             c_kti_icad_srvr_udp            = (INT)  6701,   //  KTI/ICAD Nameserver
06511             c_ibprotocol_tcp               = (INT)  6714,   //  Internet Backplane Protocol
06512             c_ibprotocol_udp               = (INT)  6714,   //  Internet Backplane Protocol
06513             c_bmc_perf_agent_tcp           = (INT)  6767,   //  BMC PERFORM AGENT
06514             c_bmc_perf_agent_udp           = (INT)  6767,   //  BMC PERFORM AGENT
06515             c_bmc_perf_mgrd_tcp            = (INT)  6768,   //  BMC PERFORM MGRD
06516             c_bmc_perf_mgrd_udp            = (INT)  6768,   //  BMC PERFORM MGRD
06517             c_hnmp_tcp                     = (INT)  6790,   //  HNMP
06518             c_hnmp_udp                     = (INT)  6790,   //  HNMP
06519             c_ambit_lm_tcp                 = (INT)  6831,   //  ambit-lm
06520             c_ambit_lm_udp                 = (INT)  6831,   //  ambit-lm
06521             c_netmo_default_tcp            = (INT)  6841,   //  Netmo Default
06522             c_netmo_default_udp            = (INT)  6841,   //  Netmo Default
06523             c_netmo_http_tcp               = (INT)  6842,   //  Netmo HTTP
06524             c_netmo_http_udp               = (INT)  6842,   //  Netmo HTTP
06525             c_iccrushmore_tcp              = (INT)  6850,   //  ICCRUSHMORE
06526             c_iccrushmore_udp              = (INT)  6850,   //  ICCRUSHMORE
06527             c_muse_tcp                     = (INT)  6888,   //  MUSE
06528             c_muse_udp                     = (INT)  6888,   //  MUSE
06529             c_jmact3_tcp                   = (INT)  6961,   //  JMACT3
06530             c_jmact3_udp                   = (INT)  6961,   //  JMACT3
06531             c_jmevt2_tcp                   = (INT)  6962,   //  jmevt2
06532             c_jmevt2_udp                   = (INT)  6962,   //  jmevt2
06533             c_swismgr1_tcp                 = (INT)  6963,   //  swismgr1
06534             c_swismgr1_udp                 = (INT)  6963,   //  swismgr1
06535             c_swismgr2_tcp                 = (INT)  6964,   //  swismgr2
06536             c_swismgr2_udp                 = (INT)  6964,   //  swismgr2
06537             c_swistrap_tcp                 = (INT)  6965,   //  swistrap
06538             c_swistrap_udp                 = (INT)  6965,   //  swistrap
06539             c_swispol_tcp                  = (INT)  6966,   //  swispol
06540             c_swispol_udp                  = (INT)  6966,   //  swispol
06541             c_acmsoda_tcp                  = (INT)  6969,   //  acmsoda
06542             c_acmsoda_udp                  = (INT)  6969,   //  acmsoda
06543             c_iatp_highpri_tcp             = (INT)  6998,   //  IATP-highPri
06544             c_iatp_highpri_udp             = (INT)  6998,   //  IATP-highPri
06545             c_iatp_normalpri_tcp           = (INT)  6999,   //  IATP-normalPri
06546             c_iatp_normalpri_udp           = (INT)  6999,   //  IATP-normalPri
06547             c_afs3_fileserver_tcp          = (INT)  7000,   //  file server itself
06548             c_afs3_fileserver_udp          = (INT)  7000,   //  file server itself
06549             c_afs3_callback_tcp            = (INT)  7001,   //  callbacks to cache managers
06550             c_afs3_callback_udp            = (INT)  7001,   //  callbacks to cache managers
06551             c_afs3_prserver_tcp            = (INT)  7002,   //  users & groups database
06552             c_afs3_prserver_udp            = (INT)  7002,   //  users & groups database
06553             c_afs3_vlserver_tcp            = (INT)  7003,   //  volume location database
06554             c_afs3_vlserver_udp            = (INT)  7003,   //  volume location database
06555             c_afs3_kaserver_tcp            = (INT)  7004,   //  AFS/Kerberos authentication service
06556             c_afs3_kaserver_udp            = (INT)  7004,   //  AFS/Kerberos authentication service
06557             c_afs3_volser_tcp              = (INT)  7005,   //  volume managment server
06558             c_afs3_volser_udp              = (INT)  7005,   //  volume managment server
06559             c_afs3_errors_tcp              = (INT)  7006,   //  error interpretation service
06560             c_afs3_errors_udp              = (INT)  7006,   //  error interpretation service
06561             c_afs3_bos_tcp                 = (INT)  7007,   //  basic overseer process
06562             c_afs3_bos_udp                 = (INT)  7007,   //  basic overseer process
06563             c_afs3_update_tcp              = (INT)  7008,   //  server-to-server updater
06564             c_afs3_update_udp              = (INT)  7008,   //  server-to-server updater
06565             c_afs3_rmtsys_tcp              = (INT)  7009,   //  remote cache manager service
06566             c_afs3_rmtsys_udp              = (INT)  7009,   //  remote cache manager service
06567             c_ups_onlinet_tcp              = (INT)  7010,   //  onlinet uninterruptable power supplies
06568             c_ups_onlinet_udp              = (INT)  7010,   //  onlinet uninterruptable power supplies
06569             c_talon_disc_tcp               = (INT)  7011,   //  Talon Discovery Port
06570             c_talon_disc_udp               = (INT)  7011,   //  Talon Discovery Port
06571             c_talon_engine_tcp             = (INT)  7012,   //  Talon Engine
06572             c_talon_engine_udp             = (INT)  7012,   //  Talon Engine
06573             c_microtalon_dis_tcp           = (INT)  7013,   //  Microtalon Discovery
06574             c_microtalon_dis_udp           = (INT)  7013,   //  Microtalon Discovery
06575             c_microtalon_com_tcp           = (INT)  7014,   //  Microtalon Communications
06576             c_microtalon_com_udp           = (INT)  7014,   //  Microtalon Communications
06577             c_talon_webserver_tcp          = (INT)  7015,   //  Talon Webserver
06578             c_talon_webserver_udp          = (INT)  7015,   //  Talon Webserver
06579             c_dpserve_tcp                  = (INT)  7020,   //  DP Serve
06580             c_dpserve_udp                  = (INT)  7020,   //  DP Serve
06581             c_dpserveadmin_tcp             = (INT)  7021,   //  DP Serve Admin
06582             c_dpserveadmin_udp             = (INT)  7021,   //  DP Serve Admin
06583             c_arcp_tcp                     = (INT)  7070,   //  ARCP
06584             c_arcp_udp                     = (INT)  7070,   //  ARCP
06585             c_lazy_ptop_tcp                = (INT)  7099,   //  lazy-ptop
06586             c_lazy_ptop_udp                = (INT)  7099,   //  lazy-ptop
06587             c_font_service_tcp             = (INT)  7100,   //  X Font Service
06588             c_font_service_udp             = (INT)  7100,   //  X Font Service
06589             c_virprot_lm_tcp               = (INT)  7121,   //  Virtual Prototypes License Manager
06590             c_virprot_lm_udp               = (INT)  7121,   //  Virtual Prototypes License Manager
06591             c_clutild_tcp                  = (INT)  7174,   //  Clutild
06592             c_clutild_udp                  = (INT)  7174,   //  Clutild
06593             c_fodms_tcp                    = (INT)  7200,   //  FODMS FLIP
06594             c_fodms_udp                    = (INT)  7200,   //  FODMS FLIP
06595             c_dlip_tcp                     = (INT)  7201,   //  DLIP
06596             c_dlip_udp                     = (INT)  7201,   //  DLIP
06597             c_itactionserver1_tcp          = (INT)  7280,   //  ITACTIONSERVER 1
06598             c_itactionserver1_udp          = (INT)  7280,   //  ITACTIONSERVER 1
06599             c_itactionserver2_tcp          = (INT)  7281,   //  ITACTIONSERVER 2
06600             c_itactionserver2_udp          = (INT)  7281,   //  ITACTIONSERVER 2
06601             c_mindfilesys_tcp              = (INT)  7391,   //  mind-file system server
06602             c_mindfilesys_udp              = (INT)  7391,   //  mind-file system server
06603             c_mrssrendezvous_tcp           = (INT)  7392,   //  mrss-rendezvous server
06604             c_mrssrendezvous_udp           = (INT)  7392,   //  mrss-rendezvous server
06605             c_winqedit_tcp                 = (INT)  7395,   //  winqedit
06606             c_winqedit_udp                 = (INT)  7395,   //  winqedit
06607             c_pmdmgr_tcp                   = (INT)  7426,   //  OpenView DM Postmaster Manager
06608             c_pmdmgr_udp                   = (INT)  7426,   //  OpenView DM Postmaster Manager
06609             c_oveadmgr_tcp                 = (INT)  7427,   //  OpenView DM Event Agent Manager
06610             c_oveadmgr_udp                 = (INT)  7427,   //  OpenView DM Event Agent Manager
06611             c_ovladmgr_tcp                 = (INT)  7428,   //  OpenView DM Log Agent Manager
06612             c_ovladmgr_udp                 = (INT)  7428,   //  OpenView DM Log Agent Manager
06613             c_opi_sock_tcp                 = (INT)  7429,   //  OpenView DM rqt communication
06614             c_opi_sock_udp                 = (INT)  7429,   //  OpenView DM rqt communication
06615             c_xmpv7_tcp                    = (INT)  7430,   //  OpenView DM xmpv7 api pipe
06616             c_xmpv7_udp                    = (INT)  7430,   //  OpenView DM xmpv7 api pipe
06617             c_pmd_tcp                      = (INT)  7431,   //  OpenView DM ovc/xmpv3 api pipe
06618             c_pmd_udp                      = (INT)  7431,   //  OpenView DM ovc/xmpv3 api pipe
06619             c_faximum_tcp                  = (INT)  7437,   //  Faximum
06620             c_faximum_udp                  = (INT)  7437,   //  Faximum
06621             c_telops_lmd_tcp               = (INT)  7491,   //  telops-lmd
06622             c_telops_lmd_udp               = (INT)  7491,   //  telops-lmd
06623             c_ovbus_tcp                    = (INT)  7501,   //  HP OpenView Bus Daemon
06624             c_ovbus_udp                    = (INT)  7501,   //  HP OpenView Bus Daemon
06625             c_ovhpas_tcp                   = (INT)  7510,   //  HP OpenView Application Server
06626             c_ovhpas_udp                   = (INT)  7510,   //  HP OpenView Application Server
06627             c_pafec_lm_tcp                 = (INT)  7511,   //  pafec-lm
06628             c_pafec_lm_udp                 = (INT)  7511,   //  pafec-lm
06629             c_nta_ds_tcp                   = (INT)  7544,   //  FlowAnalyzer DisplayServer
06630             c_nta_ds_udp                   = (INT)  7544,   //  FlowAnalyzer DisplayServer
06631             c_nta_us_tcp                   = (INT)  7545,   //  FlowAnalyzer UtilityServer
06632             c_nta_us_udp                   = (INT)  7545,   //  FlowAnalyzer UtilityServer
06633             c_vsi_omega_tcp                = (INT)  7566,   //  VSI Omega
06634             c_vsi_omega_udp                = (INT)  7566,   //  VSI Omega
06635             c_aries_kfinder_tcp            = (INT)  7570,   //  Aries Kfinder
06636             c_aries_kfinder_udp            = (INT)  7570,   //  Aries Kfinder
06637             c_sun_lm_tcp                   = (INT)  7588,   //  Sun License Manager
06638             c_sun_lm_udp                   = (INT)  7588,   //  Sun License Manager
06639             c_pmdfmgt_tcp                  = (INT)  7633,   //  PMDF Management
06640             c_pmdfmgt_udp                  = (INT)  7633,   //  PMDF Management
06641             c_sstp_1_tcp                   = (INT)  7743,   //  Sakura Script Transfer Protocol
06642             c_sstp_1_udp                   = (INT)  7743,   //  Sakura Script Transfer Protocol
06643             c_cbt_tcp                      = (INT)  7777,   //  cbt
06644             c_cbt_udp                      = (INT)  7777,   //  cbt
06645             c_interwise_tcp                = (INT)  7778,   //  Interwise
06646             c_interwise_udp                = (INT)  7778,   //  Interwise
06647             c_vstat_tcp                    = (INT)  7779,   //  VSTAT
06648             c_vstat_udp                    = (INT)  7779,   //  VSTAT
06649             c_accu_lmgr_tcp                = (INT)  7781,   //  accu-lmgr
06650             c_accu_lmgr_udp                = (INT)  7781,   //  accu-lmgr
06651             c_minivend_tcp                 = (INT)  7786,   //  MINIVEND
06652             c_minivend_udp                 = (INT)  7786,   //  MINIVEND
06653             c_apc_snmptrap_tcp             = (INT)  7845,   //  APC SNMP Trap Proxy
06654             c_apc_snmptrap_udp             = (INT)  7845,   //  APC SNMP Trap Proxy
06655             c_apc_snmp_tcp                 = (INT)  7846,   //  APC SNMP Proxy
06656             c_apc_snmp_udp                 = (INT)  7846,   //  APC SNMP Proxy
06657             c_qo_secure_tcp                = (INT)  7913,   //  QuickObjects secure port
06658             c_qo_secure_udp                = (INT)  7913,   //  QuickObjects secure port
06659             c_t2_drm_tcp                   = (INT)  7932,   //  Tier 2 Data Resource Manager
06660             c_t2_drm_udp                   = (INT)  7932,   //  Tier 2 Data Resource Manager
06661             c_t2_brm_tcp                   = (INT)  7933,   //  Tier 2 Business Rules Manager
06662             c_t2_brm_udp                   = (INT)  7933,   //  Tier 2 Business Rules Manager
06663             c_supercell_tcp                = (INT)  7967,   //  Supercell
06664             c_supercell_udp                = (INT)  7967,   //  Supercell
06665             c_micromuse_ncps_tcp           = (INT)  7979,   //  Micromuse-ncps
06666             c_micromuse_ncps_udp           = (INT)  7979,   //  Micromuse-ncps
06667             c_quest_vista_tcp              = (INT)  7980,   //  Quest Vista
06668             c_quest_vista_udp              = (INT)  7980,   //  Quest Vista
06669             c_irdmi2_tcp                   = (INT)  7999,   //  iRDMI2
06670             c_irdmi2_udp                   = (INT)  7999,   //  iRDMI2
06671             c_irdmi_tcp                    = (INT)  8000,   //  iRDMI
06672             c_irdmi_udp                    = (INT)  8000,   //  iRDMI
06673             c_vcom_tunnel_tcp              = (INT)  8001,   //  VCOM Tunnel
06674             c_vcom_tunnel_udp              = (INT)  8001,   //  VCOM Tunnel
06675             c_teradataordbms_tcp           = (INT)  8002,   //  Teradata ORDBMS
06676             c_teradataordbms_udp           = (INT)  8002,   //  Teradata ORDBMS
06677             c_http_alt_1_tcp               = (INT)  8008,   //  HTTP Alternate
06678             c_http_alt_1_udp               = (INT)  8008,   //  HTTP Alternate
06679             c_oa_system_tcp                = (INT)  8022,   //  oa-system
06680             c_oa_system_udp                = (INT)  8022,   //  oa-system
06681             c_pro_ed_tcp                   = (INT)  8032,   //  ProEd
06682             c_pro_ed_udp                   = (INT)  8032,   //  ProEd
06683             c_mindprint_tcp                = (INT)  8033,   //  MindPrint
06684             c_mindprint_udp                = (INT)  8033,   //  MindPrint
06685             c_http_alt_2_tcp               = (INT)  8080,   //  HTTP Alternate (see port 80)
06686             c_http_alt_2_udp               = (INT)  8080,   //  HTTP Alternate (see port 80)
06687             c_xprint_server_tcp            = (INT)  8100,   //  Xprint Server
06688             c_xprint_server_udp            = (INT)  8100,   //  Xprint Server
06689             c_cp_cluster_tcp               = (INT)  8116,   //  Check Point Clustering
06690             c_cp_cluster_udp               = (INT)  8116,   //  Check Point Clustering
06691             c_indigo_vrmi_tcp              = (INT)  8130,   //  INDIGO-VRMI
06692             c_indigo_vrmi_udp              = (INT)  8130,   //  INDIGO-VRMI
06693             c_indigo_vbcp_tcp              = (INT)  8131,   //  INDIGO-VBCP
06694             c_indigo_vbcp_udp              = (INT)  8131,   //  INDIGO-VBCP
06695             c_dbabble_tcp                  = (INT)  8132,   //  dbabble
06696             c_dbabble_udp                  = (INT)  8132,   //  dbabble
06697             c_patrol_tcp                   = (INT)  8160,   //  Patrol
06698             c_patrol_udp                   = (INT)  8160,   //  Patrol
06699             c_patrol_snmp_tcp              = (INT)  8161,   //  Patrol SNMP
06700             c_patrol_snmp_udp              = (INT)  8161,   //  Patrol SNMP
06701             c_vvr_data_tcp                 = (INT)  8199,   //  VVR DATA
06702             c_vvr_data_udp                 = (INT)  8199,   //  VVR DATA
06703             c_trivnet1_tcp                 = (INT)  8200,   //  TRIVNET
06704             c_trivnet1_udp                 = (INT)  8200,   //  TRIVNET
06705             c_trivnet2_tcp                 = (INT)  8201,   //  TRIVNET
06706             c_trivnet2_udp                 = (INT)  8201,   //  TRIVNET
06707             c_lm_perfworks_tcp             = (INT)  8204,   //  LM Perfworks
06708             c_lm_perfworks_udp             = (INT)  8204,   //  LM Perfworks
06709             c_lm_instmgr_tcp               = (INT)  8205,   //  LM Instmgr
06710             c_lm_instmgr_udp               = (INT)  8205,   //  LM Instmgr
06711             c_lm_dta_tcp                   = (INT)  8206,   //  LM Dta
06712             c_lm_dta_udp                   = (INT)  8206,   //  LM Dta
06713             c_lm_sserver_tcp               = (INT)  8207,   //  LM SServer
06714             c_lm_sserver_udp               = (INT)  8207,   //  LM SServer
06715             c_lm_webwatcher_tcp            = (INT)  8208,   //  LM Webwatcher
06716             c_lm_webwatcher_udp            = (INT)  8208,   //  LM Webwatcher
06717             c_server_find_tcp              = (INT)  8351,   //  Server Find
06718             c_server_find_udp              = (INT)  8351,   //  Server Find
06719             c_cruise_enum_tcp              = (INT)  8376,   //  Cruise ENUM
06720             c_cruise_enum_udp              = (INT)  8376,   //  Cruise ENUM
06721             c_cruise_swroute_tcp           = (INT)  8377,   //  Cruise SWROUTE
06722             c_cruise_swroute_udp           = (INT)  8377,   //  Cruise SWROUTE
06723             c_cruise_config_tcp            = (INT)  8378,   //  Cruise CONFIG
06724             c_cruise_config_udp            = (INT)  8378,   //  Cruise CONFIG
06725             c_cruise_diags_tcp             = (INT)  8379,   //  Cruise DIAGS
06726             c_cruise_diags_udp             = (INT)  8379,   //  Cruise DIAGS
06727             c_cruise_update_tcp            = (INT)  8380,   //  Cruise UPDATE
06728             c_cruise_update_udp            = (INT)  8380,   //  Cruise UPDATE
06729             c_cvd_tcp                      = (INT)  8400,   //  cvd
06730             c_cvd_udp                      = (INT)  8400,   //  cvd
06731             c_sabarsd_tcp                  = (INT)  8401,   //  sabarsd
06732             c_sabarsd_udp                  = (INT)  8401,   //  sabarsd
06733             c_abarsd_tcp                   = (INT)  8402,   //  abarsd
06734             c_abarsd_udp                   = (INT)  8402,   //  abarsd
06735             c_admind_1_tcp                 = (INT)  8403,   //  admind
06736             c_admind_1_udp                 = (INT)  8403,   //  admind
06737             c_pcsync_https_tcp             = (INT)  8443,   //  PCsync HTTPS
06738             c_pcsync_https_udp             = (INT)  8443,   //  PCsync HTTPS
06739             c_pcsync_http_tcp              = (INT)  8444,   //  PCsync HTTP
06740             c_pcsync_http_udp              = (INT)  8444,   //  PCsync HTTP
06741             c_npmp_tcp                     = (INT)  8450,   //  npmp
06742             c_npmp_udp                     = (INT)  8450,   //  npmp
06743             c_vp2p_tcp                     = (INT)  8473,   //  Virtual Point to Point
06744             c_vp2p_udp                     = (INT)  8473,   //  Virtual Point to Point
06745             c_rtsp_alt_tcp                 = (INT)  8554,   //  RTSP Alternate (see port 554)
06746             c_rtsp_alt_udp                 = (INT)  8554,   //  RTSP Alternate (see port 554)
06747             c_ibus_tcp                     = (INT)  8733,   //  iBus
06748             c_ibus_udp                     = (INT)  8733,   //  iBus
06749             c_mc_appserver_tcp             = (INT)  8763,   //  MC-APPSERVER
06750             c_mc_appserver_udp             = (INT)  8763,   //  MC-APPSERVER
06751             c_openqueue_tcp                = (INT)  8764,   //  OPENQUEUE
06752             c_openqueue_udp                = (INT)  8764,   //  OPENQUEUE
06753             c_ultraseek_http_tcp           = (INT)  8765,   //  Ultraseek HTTP
06754             c_ultraseek_http_udp           = (INT)  8765,   //  Ultraseek HTTP
06755             c_truecm_tcp                   = (INT)  8804,   //  truecm
06756             c_truecm_udp                   = (INT)  8804,   //  truecm
06757             c_cddbp_alt_tcp                = (INT)  8880,   //  CDDBP
06758             c_cddbp_alt_udp                = (INT)  8880,   //  CDDBP
06759             c_ddi_tcp_1_tcp                = (INT)  8888,   //  NewsEDGE server TCP (TCP 1)
06760             c_ddi_udp_1_udp                = (INT)  8888,   //  NewsEDGE server UDP (UDP 1)
06761             c_ddi_tcp_2_tcp                = (INT)  8889,   //  Desktop Data TCP 1
06762             c_ddi_udp_2_udp                = (INT)  8889,   //  NewsEDGE server broadcast
06763             c_ddi_tcp_3_tcp                = (INT)  8890,   //  Desktop Data TCP 2
06764             c_ddi_udp_3_udp                = (INT)  8890,   //  NewsEDGE client broadcast
06765             c_ddi_tcp_4_tcp                = (INT)  8891,   //  Desktop Data TCP 3: NESS application
06766             c_ddi_udp_4_udp                = (INT)  8891,   //  Desktop Data UDP 3: NESS application
06767             c_ddi_tcp_5_tcp                = (INT)  8892,   //  Desktop Data TCP 4: FARM product
06768             c_ddi_udp_5_udp                = (INT)  8892,   //  Desktop Data UDP 4: FARM product
06769             c_ddi_tcp_6_tcp                = (INT)  8893,   //  Desktop Data TCP 5: NewsEDGE/Web application
06770             c_ddi_udp_6_udp                = (INT)  8893,   //  Desktop Data UDP 5: NewsEDGE/Web application
06771             c_ddi_tcp_7_tcp                = (INT)  8894,   //  Desktop Data TCP 6: COAL application
06772             c_ddi_udp_7_udp                = (INT)  8894,   //  Desktop Data UDP 6: COAL application
06773             c_jmb_cds1_tcp                 = (INT)  8900,   //  JMB-CDS 1
06774             c_jmb_cds1_udp                 = (INT)  8900,   //  JMB-CDS 1
06775             c_jmb_cds2_tcp                 = (INT)  8901,   //  JMB-CDS 2
06776             c_jmb_cds2_udp                 = (INT)  8901,   //  JMB-CDS 2
06777             c_cumulus_admin_tcp            = (INT)  8954,   //  Cumulus Admin Port
06778             c_cumulus_admin_udp            = (INT)  8954,   //  Cumulus Admin Port
06779             c_bctp_tcp                     = (INT)  8999,   //  Brodos Crypto Trade Protocol
06780             c_bctp_udp                     = (INT)  8999,   //  Brodos Crypto Trade Protocol
06781             c_cslistener_tcp               = (INT)  9000,   //  CSlistener
06782             c_cslistener_udp               = (INT)  9000,   //  CSlistener
06783             c_etlservicemgr_tcp            = (INT)  9001,   //  ETL Service Manager
06784             c_etlservicemgr_udp            = (INT)  9001,   //  ETL Service Manager
06785             c_dynamid_tcp                  = (INT)  9002,   //  DynamID authentication
06786             c_dynamid_udp                  = (INT)  9002,   //  DynamID authentication
06787             c_tambora_tcp                  = (INT)  9020,   //  TAMBORA
06788             c_tambora_udp                  = (INT)  9020,   //  TAMBORA
06789             c_panagolin_ident_tcp          = (INT)  9021,   //  Pangolin Identification
06790             c_panagolin_ident_udp          = (INT)  9021,   //  Pangolin Identification
06791             c_paragent_tcp                 = (INT)  9022,   //  PrivateArk Remote Agent
06792             c_paragent_udp                 = (INT)  9022,   //  PrivateArk Remote Agent
06793             c_swa_1_tcp                    = (INT)  9023,   //  Secure Web Access - 1
06794             c_swa_1_udp                    = (INT)  9023,   //  Secure Web Access - 1
06795             c_swa_2_tcp                    = (INT)  9024,   //  Secure Web Access - 2
06796             c_swa_2_udp                    = (INT)  9024,   //  Secure Web Access - 2
06797             c_swa_3_tcp                    = (INT)  9025,   //  Secure Web Access - 3
06798             c_swa_3_udp                    = (INT)  9025,   //  Secure Web Access - 3
06799             c_swa_4_tcp                    = (INT)  9026,   //  Secure Web Access - 4
06800             c_swa_4_udp                    = (INT)  9026,   //  Secure Web Access - 4
06801             c_websm_tcp                    = (INT)  9090,   //  WebSM
06802             c_websm_udp                    = (INT)  9090,   //  WebSM
06803             c_xmltec_xmlmail_tcp           = (INT)  9091,   //  xmltec-xmlmail
06804             c_xmltec_xmlmail_udp           = (INT)  9091,   //  xmltec-xmlmail
06805             c_bacula_dir_tcp               = (INT)  9101,   //  Bacula Director
06806             c_bacula_dir_udp               = (INT)  9101,   //  Bacula Director
06807             c_bacula_fd_tcp                = (INT)  9102,   //  Bacula File Daemon
06808             c_bacula_fd_udp                = (INT)  9102,   //  Bacula File Daemon
06809             c_bacula_sd_tcp                = (INT)  9103,   //  Bacula Storage Daemon
06810             c_bacula_sd_udp                = (INT)  9103,   //  Bacula Storage Daemon
06811             c_netlock1_tcp                 = (INT)  9160,   //  NetLOCK1
06812             c_netlock1_udp                 = (INT)  9160,   //  NetLOCK1
06813             c_netlock2_tcp                 = (INT)  9161,   //  NetLOCK2
06814             c_netlock2_udp                 = (INT)  9161,   //  NetLOCK2
06815             c_netlock3_tcp                 = (INT)  9162,   //  NetLOCK3
06816             c_netlock3_udp                 = (INT)  9162,   //  NetLOCK3
06817             c_netlock4_tcp                 = (INT)  9163,   //  NetLOCK4
06818             c_netlock4_udp                 = (INT)  9163,   //  NetLOCK4
06819             c_netlock5_tcp                 = (INT)  9164,   //  NetLOCK5
06820             c_netlock5_udp                 = (INT)  9164,   //  NetLOCK5
06821             c_fsc_port_tcp                 = (INT)  9217,   //  FSC Communication Port
06822             c_fsc_port_udp                 = (INT)  9217,   //  FSC Communication Port
06823             c_swtp_port1_tcp               = (INT)  9281,   //  SofaWare transport port 1
06824             c_swtp_port1_udp               = (INT)  9281,   //  SofaWare transport port 1
06825             c_swtp_port2_tcp               = (INT)  9282,   //  SofaWare transport port 2
06826             c_swtp_port2_udp               = (INT)  9282,   //  SofaWare transport port 2
06827             c_callwaveiam_tcp              = (INT)  9283,   //  CallWaveIAM
06828             c_callwaveiam_udp              = (INT)  9283,   //  CallWaveIAM
06829             c_visd_tcp                     = (INT)  9284,   //  VERITAS Information Serve
06830             c_visd_udp                     = (INT)  9284,   //  VERITAS Information Serve
06831             c_n2h2server_tcp               = (INT)  9285,   //  N2H2 Filter Service Port
06832             c_n2h2server_udp               = (INT)  9285,   //  N2H2 Filter Service Port
06833             c_cumulus_tcp                  = (INT)  9287,   //  Cumulus
06834             c_cumulus_udp                  = (INT)  9287,   //  Cumulus
06835             c_armtechdaemon_tcp            = (INT)  9292,   //  ArmTech Daemon
06836             c_armtechdaemon_udp            = (INT)  9292,   //  ArmTech Daemon
06837             c_guibase_tcp                  = (INT)  9321,   //  guibase
06838             c_guibase_udp                  = (INT)  9321,   //  guibase
06839             c_mpidcmgr_tcp                 = (INT)  9343,   //  MpIdcMgr
06840             c_mpidcmgr_udp                 = (INT)  9343,   //  MpIdcMgr
06841             c_mphlpdmc_tcp                 = (INT)  9344,   //  Mphlpdmc
06842             c_mphlpdmc_udp                 = (INT)  9344,   //  Mphlpdmc
06843             c_ctechlicensing_tcp           = (INT)  9346,   //  C Tech Licensing
06844             c_ctechlicensing_udp           = (INT)  9346,   //  C Tech Licensing
06845             c_fjdmimgr_tcp                 = (INT)  9374,   //  fjdmimgr
06846             c_fjdmimgr_udp                 = (INT)  9374,   //  fjdmimgr
06847             c_fjinvmgr_tcp                 = (INT)  9396,   //  fjinvmgr
06848             c_fjinvmgr_udp                 = (INT)  9396,   //  fjinvmgr
06849             c_mpidcagt_tcp                 = (INT)  9397,   //  MpIdcAgt
06850             c_mpidcagt_udp                 = (INT)  9397,   //  MpIdcAgt
06851             c_ismserver_tcp                = (INT)  9500,   //  ismserver
06852             c_ismserver_udp                = (INT)  9500,   //  ismserver
06853             c_mngsuite_tcp                 = (INT)  9535,   //
06854             c_mngsuite_udp                 = (INT)  9535,   //
06855             c_msgsys_tcp                   = (INT)  9594,   //  Message System
06856             c_msgsys_udp                   = (INT)  9594,   //  Message System
06857             c_pds_tcp                      = (INT)  9595,   //  Ping Discovery Service
06858             c_pds_udp                      = (INT)  9595,   //  Ping Discovery Service
06859             c_micromuse_ncpw_tcp           = (INT)  9600,   //  MICROMUSE-NCPW
06860             c_micromuse_ncpw_udp           = (INT)  9600,   //  MICROMUSE-NCPW
06861             c_streamcomm_ds_tcp            = (INT)  9612,   //  StreamComm User Directory
06862             c_streamcomm_ds_udp            = (INT)  9612,   //  StreamComm User Directory
06863             c_l5nas_parchan_tcp            = (INT)  9747,   //  L5NAS Parallel Channel
06864             c_l5nas_parchan_udp            = (INT)  9747,   //  L5NAS Parallel Channel
06865             c_rasadv_tcp                   = (INT)  9753,   //  rasadv
06866             c_rasadv_udp                   = (INT)  9753,   //  rasadv
06867             c_davsrc_tcp                   = (INT)  9800,   //  WebDav Source Port
06868             c_davsrc_udp                   = (INT)  9800,   //  WebDav Source Port
06869             c_sstp_2_tcp                   = (INT)  9801,   //  Sakura Script Transfer Protocol-2
06870             c_sstp_2_udp                   = (INT)  9801,   //  Sakura Script Transfer Protocol-2
06871             c_sapv1_tcp                    = (INT)  9875,   //  Session Announcement v1
06872             c_sapv1_udp                    = (INT)  9875,   //  Session Announcement v1
06873             c_sd_tcp                       = (INT)  9876,   //  Session Director
06874             c_sd_udp                       = (INT)  9876,   //  Session Director
06875             c_cyborg_systems_tcp           = (INT)  9888,   //  CYBORG Systems
06876             c_cyborg_systems_udp           = (INT)  9888,   //  CYBORG Systems
06877             c_monkeycom_tcp                = (INT)  9898,   //  MonkeyCom
06878             c_monkeycom_udp                = (INT)  9898,   //  MonkeyCom
06879             c_sctp_tunneling_tcp           = (INT)  9899,   //  SCTP TUNNELING
06880             c_sctp_tunneling_udp           = (INT)  9899,   //  SCTP TUNNELING
06881             c_iua_tcp                      = (INT)  9900,   //  IUA
06882             c_iua_udp                      = (INT)  9900,   //  IUA
06883             c_iua_sctp                     = (INT)  9900,   //  IUA
06884             c_domaintime_tcp               = (INT)  9909,   //  domaintime
06885             c_domaintime_udp               = (INT)  9909,   //  domaintime
06886             c_apcpcpluswin1_tcp            = (INT)  9950,   //  APCPCPLUSWIN1
06887             c_apcpcpluswin1_udp            = (INT)  9950,   //  APCPCPLUSWIN1
06888             c_apcpcpluswin2_tcp            = (INT)  9951,   //  APCPCPLUSWIN2
06889             c_apcpcpluswin2_udp            = (INT)  9951,   //  APCPCPLUSWIN2
06890             c_apcpcpluswin3_tcp            = (INT)  9952,   //  APCPCPLUSWIN3
06891             c_apcpcpluswin3_udp            = (INT)  9952,   //  APCPCPLUSWIN3
06892             c_palace_1_tcp                 = (INT)  9992,   //  OnLive-1
06893             c_palace_1_udp                 = (INT)  9992,   //  OnLive-1
06894             c_palace_2_tcp                 = (INT)  9993,   //  OnLive-2
06895             c_palace_2_udp                 = (INT)  9993,   //  OnLive-2
06896             c_palace_3_tcp                 = (INT)  9994,   //  OnLive-3
06897             c_palace_3_udp                 = (INT)  9994,   //  OnLive-3
06898             c_palace_4_tcp                 = (INT)  9995,   //  Palace-4
06899             c_palace_4_udp                 = (INT)  9995,   //  Palace-4
06900             c_palace_5_tcp                 = (INT)  9996,   //  Palace-5
06901             c_palace_5_udp                 = (INT)  9996,   //  Palace-5
06902             c_palace_6_tcp                 = (INT)  9997,   //  Palace-6
06903             c_palace_6_udp                 = (INT)  9997,   //  Palace-6
06904             c_distinct32_tcp               = (INT)  9998,   //  Distinct32
06905             c_distinct32_udp               = (INT)  9998,   //  Distinct32
06906             c_distinct_tcp                 = (INT)  9999,   //  distinct
06907             c_distinct_udp                 = (INT)  9999,   //  distinct
06908             c_ndmp_tcp                     = (INT) 10000,   //  Network Data Management Protocol
06909             c_ndmp_udp                     = (INT) 10000,   //  Network Data Management Protocol
06910             c_scp_config_tcp               = (INT) 10001,   //  SCP Configuration Port
06911             c_scp_config_udp               = (INT) 10001,   //  SCP Configuration Port
06912             c_mvs_capacity_tcp             = (INT) 10007,   //  MVS Capacity
06913             c_mvs_capacity_udp             = (INT) 10007,   //  MVS Capacity
06914             c_amanda_tcp                   = (INT) 10080,   //  Amanda
06915             c_amanda_udp                   = (INT) 10080,   //  Amanda
06916             c_ezmeeting_2_tcp              = (INT) 10101,   //  eZmeeting
06917             c_ezmeeting_2_udp              = (INT) 10101,   //  eZmeeting
06918             c_ezproxy_2_tcp                = (INT) 10102,   //  eZproxy
06919             c_ezproxy_2_udp                = (INT) 10102,   //  eZproxy
06920             c_ezrelay_tcp                  = (INT) 10103,   //  eZrelay
06921             c_ezrelay_udp                  = (INT) 10103,   //  eZrelay
06922             c_netiq_endpoint_tcp           = (INT) 10113,   //  NetIQ Endpoint
06923             c_netiq_endpoint_udp           = (INT) 10113,   //  NetIQ Endpoint
06924             c_netiq_qcheck_tcp             = (INT) 10114,   //  NetIQ Qcheck
06925             c_netiq_qcheck_udp             = (INT) 10114,   //  NetIQ Qcheck
06926             c_netiq_endpt_tcp              = (INT) 10115,   //  NetIQ Endpoint
06927             c_netiq_endpt_udp              = (INT) 10115,   //  NetIQ Endpoint
06928             c_netiq_voipa_tcp              = (INT) 10116,   //  NetIQ VoIP Assessor
06929             c_netiq_voipa_udp              = (INT) 10116,   //  NetIQ VoIP Assessor
06930             c_bmc_perf_sd_tcp              = (INT) 10128,   //  BMC-PERFORM-SERVICE DAEMON
06931             c_bmc_perf_sd_udp              = (INT) 10128,   //  BMC-PERFORM-SERVICE DAEMON
06932             c_axis_wimp_port_tcp           = (INT) 10260,   //  Axis WIMP Port
06933             c_axis_wimp_port_udp           = (INT) 10260,   //  Axis WIMP Port
06934             c_blocks_tcp                   = (INT) 10288,   //  Blocks
06935             c_blocks_udp                   = (INT) 10288,   //  Blocks
06936             c_rmiaux_tcp                   = (INT) 10990,   //  Auxiliary RMI Port
06937             c_rmiaux_udp                   = (INT) 10990,   //  Auxiliary RMI Port
06938             c_irisa_tcp                    = (INT) 11000,   //  IRISA
06939             c_irisa_udp                    = (INT) 11000,   //  IRISA
06940             c_metasys_tcp                  = (INT) 11001,   //  Metasys
06941             c_metasys_udp                  = (INT) 11001,   //  Metasys
06942             c_vce_tcp                      = (INT) 11111,   //  Viral Computing Environment (VCE)
06943             c_vce_udp                      = (INT) 11111,   //  Viral Computing Environment (VCE)
06944             c_smsqp_tcp                    = (INT) 11201,   //  smsqp
06945             c_smsqp_udp                    = (INT) 11201,   //  smsqp
06946             c_imip_tcp                     = (INT) 11319,   //  IMIP
06947             c_imip_udp                     = (INT) 11319,   //  IMIP
06948             c_imip_channels_tcp            = (INT) 11320,   //  IMIP Channels Port
06949             c_imip_channels_udp            = (INT) 11320,   //  IMIP Channels Port
06950             c_arena_server_tcp             = (INT) 11321,   //  Arena Server Listen
06951             c_arena_server_udp             = (INT) 11321,   //  Arena Server Listen
06952             c_atm_uhas_tcp                 = (INT) 11367,   //  ATM UHAS
06953             c_atm_uhas_udp                 = (INT) 11367,   //  ATM UHAS
06954             c_tempest_port_tcp             = (INT) 11600,   //  Tempest Protocol Port
06955             c_tempest_port_udp             = (INT) 11600,   //  Tempest Protocol Port
06956             c_h323callsigalt_tcp           = (INT) 11720,   //  h323 Call Signal Alternate
06957             c_h323callsigalt_udp           = (INT) 11720,   //  h323 Call Signal Alternate
06958             c_entextxid_tcp                = (INT) 12000,   //  IBM Enterprise Extender SNA XID Exchange
06959             c_entextxid_udp                = (INT) 12000,   //  IBM Enterprise Extender SNA XID Exchange
06960             c_entextnetwk_tcp              = (INT) 12001,   //  IBM Enterprise Extender SNA COS Network Priority
06961             c_entextnetwk_udp              = (INT) 12001,   //  IBM Enterprise Extender SNA COS Network Priority
06962             c_entexthigh_tcp               = (INT) 12002,   //  IBM Enterprise Extender SNA COS High Priority
06963             c_entexthigh_udp               = (INT) 12002,   //  IBM Enterprise Extender SNA COS High Priority
06964             c_entextmed_tcp                = (INT) 12003,   //  IBM Enterprise Extender SNA COS Medium Priority
06965             c_entextmed_udp                = (INT) 12003,   //  IBM Enterprise Extender SNA COS Medium Priority
06966             c_entextlow_tcp                = (INT) 12004,   //  IBM Enterprise Extender SNA COS Low Priority
06967             c_entextlow_udp                = (INT) 12004,   //  IBM Enterprise Extender SNA COS Low Priority
06968             c_hivep_tcp                    = (INT) 12172,   //  HiveP
06969             c_hivep_udp                    = (INT) 12172,   //  HiveP
06970             c_italk_tcp                    = (INT) 12345,   //  Italk Chat System
06971             c_italk_udp                    = (INT) 12345,   //  Italk Chat System
06972             c_tsaf_tcp                     = (INT) 12753,   //  tsaf port
06973             c_tsaf_udp                     = (INT) 12753,   //  tsaf port
06974             c_i_zipqd_tcp                  = (INT) 13160,   //  I-ZIPQD
06975             c_i_zipqd_udp                  = (INT) 13160,   //  I-ZIPQD
06976             c_powwow_client_tcp            = (INT) 13223,   //  PowWow Client
06977             c_powwow_client_udp            = (INT) 13223,   //  PowWow Client
06978             c_powwow_server_tcp            = (INT) 13224,   //  PowWow Server
06979             c_powwow_server_udp            = (INT) 13224,   //  PowWow Server
06980             c_bprd_tcp                     = (INT) 13720,   //  BPRD Protocol (VERITAS NetBackup)
06981             c_bprd_udp                     = (INT) 13720,   //  BPRD Protocol (VERITAS NetBackup)
06982             c_bpdbm_tcp                    = (INT) 13721,   //  BPDBM Protocol (VERITAS NetBackup)
06983             c_bpdbm_udp                    = (INT) 13721,   //  BPDBM Protocol (VERITAS NetBackup)
06984             c_bpjava_msvc_tcp              = (INT) 13722,   //  BP Java MSVC Protocol
06985             c_bpjava_msvc_udp              = (INT) 13722,   //  BP Java MSVC Protocol
06986             c_vnetd_tcp                    = (INT) 13724,   //  Veritas Network Utility
06987             c_vnetd_udp                    = (INT) 13724,   //  Veritas Network Utility
06988             c_bpcd_tcp                     = (INT) 13782,   //  VERITAS NetBackup
06989             c_bpcd_udp                     = (INT) 13782,   //  VERITAS NetBackup
06990             c_vopied_tcp                   = (INT) 13783,   //  VOPIED Protocol
06991             c_vopied_udp                   = (INT) 13783,   //  VOPIED Protocol
06992             c_dsmcc_config_tcp             = (INT) 13818,   //  DSMCC Config
06993             c_dsmcc_config_udp             = (INT) 13818,   //  DSMCC Config
06994             c_dsmcc_session_tcp            = (INT) 13819,   //  DSMCC Session Messages
06995             c_dsmcc_session_udp            = (INT) 13819,   //  DSMCC Session Messages
06996             c_dsmcc_passthru_tcp           = (INT) 13820,   //  DSMCC Pass-Thru Messages
06997             c_dsmcc_passthru_udp           = (INT) 13820,   //  DSMCC Pass-Thru Messages
06998             c_dsmcc_download_tcp           = (INT) 13821,   //  DSMCC Download Protocol
06999             c_dsmcc_download_udp           = (INT) 13821,   //  DSMCC Download Protocol
07000             c_dsmcc_ccp_tcp                = (INT) 13822,   //  DSMCC Channel Change Protocol
07001             c_dsmcc_ccp_udp                = (INT) 13822,   //  DSMCC Channel Change Protocol
07002             c_sua_tcp                      = (INT) 14001,   //  SUA
07003             c_sua_udp                      = (INT) 14001,   //  De-Registered (2001 June 06)
07004             c_sua_sctp                     = (INT) 14001,   //  SUA
07005             c_sage_best_com1_tcp           = (INT) 14033,   //  sage Best! Config Server 1
07006             c_sage_best_com1_udp           = (INT) 14033,   //  sage Best! Config Server 1
07007             c_sage_best_com2_tcp           = (INT) 14034,   //  sage Best! Config Server 2
07008             c_sage_best_com2_udp           = (INT) 14034,   //  sage Best! Config Server 2
07009             c_vcs_app_tcp                  = (INT) 14141,   //  VCS Application
07010             c_vcs_app_udp                  = (INT) 14141,   //  VCS Application
07011             c_gcm_app_tcp                  = (INT) 14145,   //  GCM Application
07012             c_gcm_app_udp                  = (INT) 14145,   //  GCM Application
07013             c_vrts_tdd_tcp                 = (INT) 14149,   //  Veritas Traffic Director
07014             c_vrts_tdd_udp                 = (INT) 14149,   //  Veritas Traffic Director
07015             c_hde_lcesrvr_1_tcp            = (INT) 14936,   //  hde-lcesrvr-1
07016             c_hde_lcesrvr_1_udp            = (INT) 14936,   //  hde-lcesrvr-1
07017             c_hde_lcesrvr_2_tcp            = (INT) 14937,   //  hde-lcesrvr-2
07018             c_hde_lcesrvr_2_udp            = (INT) 14937,   //  hde-lcesrvr-2
07019             c_hydap_tcp                    = (INT) 15000,   //  Hypack Data Aquisition
07020             c_hydap_udp                    = (INT) 15000,   //  Hypack Data Aquisition
07021             c_xpilot_tcp                   = (INT) 15345,   //  XPilot Contact Port
07022             c_xpilot_udp                   = (INT) 15345,   //  XPilot Contact Port
07023             c_netserialext1_tcp            = (INT) 16360,   //  netserialext1
07024             c_netserialext1_udp            = (INT) 16360,   //  netserialext1
07025             c_netserialext2_tcp            = (INT) 16361,   //  netserialext2
07026             c_netserialext2_udp            = (INT) 16361,   //  netserialext2
07027             c_netserialext3_tcp            = (INT) 16367,   //  netserialext3
07028             c_netserialext3_udp            = (INT) 16367,   //  netserialext3
07029             c_netserialext4_tcp            = (INT) 16368,   //  netserialext4
07030             c_netserialext4_udp            = (INT) 16368,   //  netserialext4
07031             c_intel_rci_mp_tcp             = (INT) 16991,   //  INTEL-RCI-MP
07032             c_intel_rci_mp_udp             = (INT) 16991,   //  INTEL-RCI-MP
07033             c_isode_dua_tcp                = (INT) 17007,   //
07034             c_isode_dua_udp                = (INT) 17007,   //
07035             c_soundsvirtual_tcp            = (INT) 17185,   //  Sounds Virtual
07036             c_soundsvirtual_udp            = (INT) 17185,   //  Sounds Virtual
07037             c_chipper_tcp                  = (INT) 17219,   //  Chipper
07038             c_chipper_udp                  = (INT) 17219,   //  Chipper
07039             c_biimenu_tcp                  = (INT) 18000,   //  Beckman Instruments, Inc.
07040             c_biimenu_udp                  = (INT) 18000,   //  Beckman Instruments, Inc.
07041             c_opsec_cvp_tcp                = (INT) 18181,   //  OPSEC CVP
07042             c_opsec_cvp_udp                = (INT) 18181,   //  OPSEC CVP
07043             c_opsec_ufp_tcp                = (INT) 18182,   //  OPSEC UFP
07044             c_opsec_ufp_udp                = (INT) 18182,   //  OPSEC UFP
07045             c_opsec_sam_tcp                = (INT) 18183,   //  OPSEC SAM
07046             c_opsec_sam_udp                = (INT) 18183,   //  OPSEC SAM
07047             c_opsec_lea_tcp                = (INT) 18184,   //  OPSEC LEA
07048             c_opsec_lea_udp                = (INT) 18184,   //  OPSEC LEA
07049             c_opsec_omi_tcp                = (INT) 18185,   //  OPSEC OMI
07050             c_opsec_omi_udp                = (INT) 18185,   //  OPSEC OMI
07051             c_opsec_ela_tcp                = (INT) 18187,   //  OPSEC ELA
07052             c_opsec_ela_udp                = (INT) 18187,   //  OPSEC ELA
07053             c_checkpoint_rtm_tcp           = (INT) 18241,   //  Check Point RTM
07054             c_checkpoint_rtm_udp           = (INT) 18241,   //  Check Point RTM
07055             c_ac_cluster_tcp               = (INT) 18463,   //  AC Cluster
07056             c_ac_cluster_udp               = (INT) 18463,   //  AC Cluster
07057             c_apc_necmp_tcp                = (INT) 18888,   //  APCNECMP
07058             c_apc_necmp_udp                = (INT) 18888,   //  APCNECMP
07059             c_opsec_uaa_tcp                = (INT) 19191,   //  opsec-uaa
07060             c_opsec_uaa_udp                = (INT) 19191,   //  opsec-uaa
07061             c_keysrvr_tcp                  = (INT) 19283,   //  Key Server for SASSAFRAS
07062             c_keysrvr_udp                  = (INT) 19283,   //  Key Server for SASSAFRAS
07063             c_keyshadow_tcp                = (INT) 19315,   //  Key Shadow for SASSAFRAS
07064             c_keyshadow_udp                = (INT) 19315,   //  Key Shadow for SASSAFRAS
07065             c_mtrgtrans_tcp                = (INT) 19398,   //  mtrgtrans
07066             c_mtrgtrans_udp                = (INT) 19398,   //  mtrgtrans
07067             c_hp_sco_tcp                   = (INT) 19410,   //  hp-sco
07068             c_hp_sco_udp                   = (INT) 19410,   //  hp-sco
07069             c_hp_sca_tcp                   = (INT) 19411,   //  hp-sca
07070             c_hp_sca_udp                   = (INT) 19411,   //  hp-sca
07071             c_hp_sessmon_tcp               = (INT) 19412,   //  HP-SESSMON
07072             c_hp_sessmon_udp               = (INT) 19412,   //  HP-SESSMON
07073             c_jcp_tcp                      = (INT) 19541,   //  JCP Client
07074             c_jcp_udp                      = (INT) 19541,   //  JCP Client
07075             c_dnp_tcp                      = (INT) 20000,   //  DNP
07076             c_dnp_udp                      = (INT) 20000,   //  DNP
07077             c_ipulse_ics_tcp               = (INT) 20222,   //  iPulse-ICS
07078             c_ipulse_ics_udp               = (INT) 20222,   //  iPulse-ICS
07079             c_track_tcp                    = (INT) 20670,   //  Track
07080             c_track_udp                    = (INT) 20670,   //  Track
07081             c_athand_mmp_tcp               = (INT) 20999,   //  At Hand MMP
07082             c_athand_mmp_udp               = (INT) 20999,   //  AT Hand MMP
07083             c_vofr_gateway_tcp             = (INT) 21590,   //  VoFR Gateway
07084             c_vofr_gateway_udp             = (INT) 21590,   //  VoFR Gateway
07085             c_tvpm_tcp                     = (INT) 21800,   //  TVNC Pro Multiplexing
07086             c_tvpm_udp                     = (INT) 21800,   //  TVNC Pro Multiplexing
07087             c_webphone_tcp                 = (INT) 21845,   //  webphone
07088             c_webphone_udp                 = (INT) 21845,   //  webphone
07089             c_netspeak_is_tcp              = (INT) 21846,   //  NetSpeak Corp. Directory Services
07090             c_netspeak_is_udp              = (INT) 21846,   //  NetSpeak Corp. Directory Services
07091             c_netspeak_cs_tcp              = (INT) 21847,   //  NetSpeak Corp. Connection Services
07092             c_netspeak_cs_udp              = (INT) 21847,   //  NetSpeak Corp. Connection Services
07093             c_netspeak_acd_tcp             = (INT) 21848,   //  NetSpeak Corp. Automatic Call Distribution
07094             c_netspeak_acd_udp             = (INT) 21848,   //  NetSpeak Corp. Automatic Call Distribution
07095             c_netspeak_cps_tcp             = (INT) 21849,   //  NetSpeak Corp. Credit Processing System
07096             c_netspeak_cps_udp             = (INT) 21849,   //  NetSpeak Corp. Credit Processing System
07097             c_snapenetio_tcp               = (INT) 22000,   //  SNAPenetIO
07098             c_snapenetio_udp               = (INT) 22000,   //  SNAPenetIO
07099             c_optocontrol_tcp              = (INT) 22001,   //  OptoControl
07100             c_optocontrol_udp              = (INT) 22001,   //  OptoControl
07101             c_wnn6_tcp                     = (INT) 22273,   //  wnn6
07102             c_wnn6_udp                     = (INT) 22273,   //  wnn6
07103             c_vocaltec_wconf_tcp           = (INT) 22555,   //  Vocaltec Web Conference
07104             c_vocaltec_phone_udp           = (INT) 22555,   //  Vocaltec Internet Phone
07105             c_aws_brf_tcp                  = (INT) 22800,   //  Telerate Information Platform LAN
07106             c_aws_brf_udp                  = (INT) 22800,   //  Telerate Information Platform LAN
07107             c_brf_gw_tcp                   = (INT) 22951,   //  Telerate Information Platform WAN
07108             c_brf_gw_udp                   = (INT) 22951,   //  Telerate Information Platform WAN
07109             c_med_ltp_tcp                  = (INT) 24000,   //  med-ltp
07110             c_med_ltp_udp                  = (INT) 24000,   //  med-ltp
07111             c_med_fsp_rx_tcp               = (INT) 24001,   //  med-fsp-rx
07112             c_med_fsp_rx_udp               = (INT) 24001,   //  med-fsp-rx
07113             c_med_fsp_tx_tcp               = (INT) 24002,   //  med-fsp-tx
07114             c_med_fsp_tx_udp               = (INT) 24002,   //  med-fsp-tx
07115             c_med_supp_tcp                 = (INT) 24003,   //  med-supp
07116             c_med_supp_udp                 = (INT) 24003,   //  med-supp
07117             c_med_ovw_tcp                  = (INT) 24004,   //  med-ovw
07118             c_med_ovw_udp                  = (INT) 24004,   //  med-ovw
07119             c_med_ci_tcp                   = (INT) 24005,   //  med-ci
07120             c_med_ci_udp                   = (INT) 24005,   //  med-ci
07121             c_med_net_svc_tcp              = (INT) 24006,   //  med-net-svc
07122             c_med_net_svc_udp              = (INT) 24006,   //  med-net-svc
07123             c_filesphere_tcp               = (INT) 24242,   //  fileSphere
07124             c_filesphere_udp               = (INT) 24242,   //  fileSphere
07125             c_vista_4gl_tcp                = (INT) 24249,   //  Vista 4GL
07126             c_vista_4gl_udp                = (INT) 24249,   //  Vista 4GL
07127             c_binkp_tcp                    = (INT) 24554,   //  BINKP
07128             c_binkp_udp                    = (INT) 24554,   //  BINKP
07129             c_flashfiler_tcp               = (INT) 24677,   //  FlashFiler
07130             c_flashfiler_udp               = (INT) 24677,   //  FlashFiler
07131             c_proactivate_tcp              = (INT) 24678,   //  Turbopower Proactivate
07132             c_proactivate_udp              = (INT) 24678,   //  Turbopower Proactivate
07133             c_snip_tcp                     = (INT) 24922,   //  Simple Net Ident Protocol
07134             c_snip_udp                     = (INT) 24922,   //  Simple Net Ident Protocol
07135             c_icl_twobase1_tcp             = (INT) 25000,   //  icl-twobase1
07136             c_icl_twobase1_udp             = (INT) 25000,   //  icl-twobase1
07137             c_icl_twobase2_tcp             = (INT) 25001,   //  icl-twobase2
07138             c_icl_twobase2_udp             = (INT) 25001,   //  icl-twobase2
07139             c_icl_twobase3_tcp             = (INT) 25002,   //  icl-twobase3
07140             c_icl_twobase3_udp             = (INT) 25002,   //  icl-twobase3
07141             c_icl_twobase4_tcp             = (INT) 25003,   //  icl-twobase4
07142             c_icl_twobase4_udp             = (INT) 25003,   //  icl-twobase4
07143             c_icl_twobase5_tcp             = (INT) 25004,   //  icl-twobase5
07144             c_icl_twobase5_udp             = (INT) 25004,   //  icl-twobase5
07145             c_icl_twobase6_tcp             = (INT) 25005,   //  icl-twobase6
07146             c_icl_twobase6_udp             = (INT) 25005,   //  icl-twobase6
07147             c_icl_twobase7_tcp             = (INT) 25006,   //  icl-twobase7
07148             c_icl_twobase7_udp             = (INT) 25006,   //  icl-twobase7
07149             c_icl_twobase8_tcp             = (INT) 25007,   //  icl-twobase8
07150             c_icl_twobase8_udp             = (INT) 25007,   //  icl-twobase8
07151             c_icl_twobase9_tcp             = (INT) 25008,   //  icl-twobase9
07152             c_icl_twobase9_udp             = (INT) 25008,   //  icl-twobase9
07153             c_icl_twobase10_tcp            = (INT) 25009,   //  icl-twobase10
07154             c_icl_twobase10_udp            = (INT) 25009,   //  icl-twobase10
07155             c_vocaltec_hos_tcp             = (INT) 25793,   //  Vocaltec Address Server
07156             c_vocaltec_hos_udp             = (INT) 25793,   //  Vocaltec Address Server
07157             c_niobserver_tcp               = (INT) 25901,   //  NIObserver
07158             c_niobserver_udp               = (INT) 25901,   //  NIObserver
07159             c_niprobe_tcp                  = (INT) 25903,   //  NIProbe
07160             c_niprobe_udp                  = (INT) 25903,   //  NIProbe
07161             c_quake_tcp                    = (INT) 26000,   //  quake
07162             c_quake_udp                    = (INT) 26000,   //  quake
07163             c_wnn6_ds_tcp                  = (INT) 26208,   //  wnn6-ds
07164             c_wnn6_ds_udp                  = (INT) 26208,   //  wnn6-ds
07165             c_ezproxy_tcp                  = (INT) 26260,   //  eZproxy
07166             c_ezproxy_udp                  = (INT) 26260,   //  eZproxy
07167             c_ezmeeting_tcp                = (INT) 26261,   //  eZmeeting
07168             c_ezmeeting_udp                = (INT) 26261,   //  eZmeeting
07169             c_k3software_svr_tcp           = (INT) 26262,   //  K3 Software-Server
07170             c_k3software_svr_udp           = (INT) 26262,   //  K3 Software-Server
07171             c_k3software_cli_tcp           = (INT) 26263,   //  K3 Software-Client
07172             c_k3software_cli_udp           = (INT) 26263,   //  K3 Software-Client
07173             c_gserver_tcp                  = (INT) 26264,   //  Gserver
07174             c_gserver_udp                  = (INT) 26264,   //  Gserver
07175             c_imagepump_tcp                = (INT) 27345,   //  ImagePump
07176             c_imagepump_udp                = (INT) 27345,   //  ImagePump
07177             c_tw_auth_key_tcp              = (INT) 27999,   //  TW Authentication/Key Distribution and
07178             c_tw_auth_key_udp              = (INT) 27999,   //  Attribute Certificate Services
07179             c_pago_services1_tcp           = (INT) 30001,   //  Pago Services 1
07180             c_pago_services1_udp           = (INT) 30001,   //  Pago Services 1
07181             c_pago_services2_tcp           = (INT) 30002,   //  Pago Services 2
07182             c_pago_services2_udp           = (INT) 30002,   //  Pago Services 2
07183             c_filenet_tms_tcp              = (INT) 32768,   //  Filenet TMS
07184             c_filenet_tms_udp              = (INT) 32768,   //  Filenet TMS
07185             c_filenet_rpc_tcp              = (INT) 32769,   //  Filenet RPC
07186             c_filenet_rpc_udp              = (INT) 32769,   //  Filenet RPC
07187             c_filenet_nch_tcp              = (INT) 32770,   //  Filenet NCH
07188             c_filenet_nch_udp              = (INT) 32770,   //  Filenet NCH
07189             c_filenet_rmi_tcp              = (INT) 32771,   //  FileNET RMI
07190             c_filenet_rmi_udp              = (INT) 32771,   //  FileNet RMI
07191             c_traceroute_tcp               = (INT) 33434,   //  traceroute use
07192             c_traceroute_udp               = (INT) 33434,   //  traceroute use
07193             c_turbonote_2_tcp              = (INT) 34249,   //  TurboNote Relay Server Default Port
07194             c_turbonote_2_udp              = (INT) 34249,   //  TurboNote Relay Server Default Port
07195             c_kastenxpipe_tcp              = (INT) 36865,   //  KastenX Pipe
07196             c_kastenxpipe_udp              = (INT) 36865,   //  KastenX Pipe
07197             c_neckar_tcp                   = (INT) 37475,   //  science + computing's Venus Administration Port
07198             c_neckar_udp                   = (INT) 37475,   //  science + computing's Venus Administration Port
07199             c_turbonote_1_tcp              = (INT) 39681,   //  TurboNote Default Port
07200             c_turbonote_1_udp              = (INT) 39681,   //  TurboNote Default Port
07201             c_cscp_tcp                     = (INT) 40841,   //  CSCP
07202             c_cscp_udp                     = (INT) 40841,   //  CSCP
07203             c_csccredir_tcp                = (INT) 40842,   //  CSCCREDIR
07204             c_csccredir_udp                = (INT) 40842,   //  CSCCREDIR
07205             c_csccfirewall_tcp             = (INT) 40843,   //  CSCCFIREWALL
07206             c_csccfirewall_udp             = (INT) 40843,   //  CSCCFIREWALL
07207             c_fs_qos_tcp                   = (INT) 41111,   //  Foursticks QoS Protocol
07208             c_fs_qos_udp                   = (INT) 41111,   //  Forusticks QoS Protocol
07209             c_reachout_tcp                 = (INT) 43188,   //  REACHOUT
07210             c_reachout_udp                 = (INT) 43188,   //  REACHOUT
07211             c_ndm_agent_port_tcp           = (INT) 43189,   //  NDM-AGENT-PORT
07212             c_ndm_agent_port_udp           = (INT) 43189,   //  NDM-AGENT-PORT
07213             c_ip_provision_tcp             = (INT) 43190,   //  IP-PROVISION
07214             c_ip_provision_udp             = (INT) 43190,   //  IP-PROVISION
07215             c_rockwell_encap_tcp           = (INT) 44818,   //  Rockwell Encapsulation
07216             c_rockwell_encap_udp           = (INT) 44818,   //  Rockwell Encapsulation
07217             c_invision_ag_tcp              = (INT) 45054,   //  InVision AG
07218             c_invision_ag_udp              = (INT) 45054,   //  InVision AG
07219             c_eba_tcp                      = (INT) 45678,   //  EBA PRISE
07220             c_eba_udp                      = (INT) 45678,   //  EBA PRISE
07221             c_ssr_servermgr_tcp            = (INT) 45966,   //  SSRServerMgr
07222             c_ssr_servermgr_udp            = (INT) 45966,   //  SSRServerMgr
07223             c_mbus_tcp                     = (INT) 47000,   //  Message Bus
07224             c_mbus_udp                     = (INT) 47000,   //  Message Bus
07225             c_dbbrowse_tcp                 = (INT) 47557,   //  Databeam Corporation
07226             c_dbbrowse_udp                 = (INT) 47557,   //  Databeam Corporation
07227             c_directplaysrvr_tcp           = (INT) 47624,   //  Direct Play Server
07228             c_directplaysrvr_udp           = (INT) 47624,   //  Direct Play Server
07229             c_ap_tcp                       = (INT) 47806,   //  ALC Protocol
07230             c_ap_udp                       = (INT) 47806,   //  ALC Protocol
07231             c_bacnet_tcp                   = (INT) 47808,   //  Building Automation and Control Networks
07232             c_bacnet_udp                   = (INT) 47808,   //  Building Automation and Control Networks
07233             c_nimcontroller_tcp            = (INT) 48000,   //  Nimbus Controller
07234             c_nimcontroller_udp            = (INT) 48000,   //  Nimbus Controller
07235             c_nimspooler_tcp               = (INT) 48001,   //  Nimbus Spooler
07236             c_nimspooler_udp               = (INT) 48001,   //  Nimbus Spooler
07237             c_nimhub_tcp                   = (INT) 48002,   //  Nimbus Hub
07238             c_nimhub_udp                   = (INT) 48002,   //  Nimbus Hub
07239             c_nimgtw_tcp                   = (INT) 48003,   //  Nimbus Gateway
07240             c_nimgtw_udp                   = (INT) 48003,   //  Nimbus Gateway
07241             c_com_bardac_dw_tcp            = (INT) 48556,   //  com-bardac-dw
07242             c_com_bardac_dw_udp            = (INT) 48556,   //  com-bardac-dw
07243 #endif
07244             c_invalid_port_no              = (INT) 0
07245         };
07246 };
07247
07249 #endif  // Apoxi_Iana_hpp
07250
Generated on Tue Jan 24 14:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ImageObtainerDataSource.cpp File Reference

Auxiliary/ImageObtainerDataSource.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ImageObtainerDataSource.hpp"
#include "BinData.hpp"
#include <Gui/Color.hpp>
#include <Gui/Image.hpp>

Include dependency graph for ImageObtainerDataSource.cpp:

Generated on Tue Jan 24 18:40:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ImageObtainerDataSource.hpp File Reference

Auxiliary/ImageObtainerDataSource.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Auxiliary_ImageObtainerDataSource_hpp

Define Documentation

#define Auxiliary_ImageObtainerDataSource_hpp

Generated on Tue Jan 24 18:40:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ImageObtainerDataSource.hpp Source File

Auxiliary/ImageObtainerDataSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_ImageObtainerDataSource_hpp)
00011 #define Auxiliary_ImageObtainerDataSource_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Gui/ImageObtainer.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017 #include <Auxiliary/DataSource.hpp>
00018
00022 class ImageObtainerDataSource : public DataSource
00023 {
00024     typedef DataSource Base;
00025
00026     public:
00033         ImageObtainerDataSource(const ImageObtainer& img_obt);
00034
00036         virtual ~ImageObtainerDataSource();
00037
00038         virtual BOOLEAN Open();
00039         virtual BOOLEAN Close();
00040
00041         virtual BOOLEAN IsOpen() const;
00042
00043         virtual BOOLEAN Read(void HUGE *buffer, UINT32 count);
00044         virtual BOOLEAN Read(void HUGE *buffer, UINT32 max_count, UINT32&bytes_read);
00045         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 count);
00046         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read);
00047         virtual BOOLEAN GetSize(UINT32 &size) const;
00048
00049     protected:
00050         // The data source that is read from.
00051         ImageObtainer m_img_obt;
00052
00053         BOOLEAN m_is_open;
00054         UINT32  m_offset;
00055 };
00056
00057 #endif  // Auxiliary_ImageObtainerDataSource_hpp
00058
00059 #endif // DOXYGEN_SHOULD_SKIP_THIS
00060
Generated on Tue Jan 24 14:48:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/IndexTable.hpp File Reference

Auxiliary/IndexTable.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for IndexTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IndexTable< T >

Defines

#define | _Adc_IndexTable_hpp

Define Documentation

#define _Adc_IndexTable_hpp

Generated on Tue Jan 24 18:41:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/IndexTable.hpp Source File

Auxiliary/IndexTable.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_IndexTable_hpp)
00015 #define _Adc_IndexTable_hpp
00016
00017 #include <Kernel/Types.hpp>
00018
00022 template<class T> class IndexTable
00023 {
00024     public:
00026         IndexTable() : m_indextable(0), m_count(0), m_size(0) {}
00028         IndexTable(INT count) : m_count(count), m_size(count)  {
00029             m_indextable = new T[count];
00030             if(m_indextable==0) {
00031                 m_count = 0;
00032                 m_size = 0;
00033             }
00034         }
00035
00036         IndexTable(const IndexTable<T>& indextable)
00037                : m_indextable(0), m_count(indextable.m_count), m_size(indextable.m_count)  {
00038             if (indextable.m_indextable != 0) {
00039                 m_indextable = new T[m_count];
00040                 if(m_indextable==0) {
00041                     m_count = 0;
00042                     m_size = 0;
00043                 } else {
00044                     for (INT i = 0; i < m_size; ++i) {
00045                         m_indextable[i] = indextable.m_indextable[i];
00046                     }
00047                 }
00048             }
00049         }
00050
00052         ~IndexTable() {
00053             if (m_indextable != 0) {
00054                 delete[] m_indextable;
00055                 m_indextable = 0;
00056             }
00057         }
00058
00060         BOOLEAN Resize(INT count) {
00061             if(m_size<count) {
00062                 delete[] m_indextable;
00063                 m_indextable = new T[count];
00064                 if(m_indextable==0) {
00065                     m_size = 0;
00066                     m_count = 0;
00067                     return FALSE;
00068                 }
00069                 m_size = count;
00070             }
00071             m_count = count;
00072             return TRUE;
00073         }
00074
00076         inline void SetValue(INT idx, T value) { m_indextable[idx] = value; }
00078         inline T  GetValue(INT idx) const { return m_indextable[idx]; }
00079
00081         const T operator [] (INT idx) const { return m_indextable[idx]; }
00083         T operator [] (INT idx) { return m_indextable[idx]; }
00085         IndexTable<T>& operator = (const IndexTable<T>& indextable) {
00086             if (this == &indextable) {
00087                 return *this;
00088             }
00089             INT size = indextable.GetSize();
00090             Resize(size);
00091             for (INT i = 0; i < size; ++i) {
00092                 m_indextable[i] = indextable.m_indextable[i];
00093             }
00094             return *this;
00095         }
00096
00098         inline void SwapValues(INT row1, INT row2) {
00099             T help = GetValue(row1);
00100             SetValue(row1,GetValue(row2));
00101             SetValue(row2,help);
00102         }
00103
00105         inline void MoveValue(INT row1, INT row2) {
00106             INT row = row1;
00107             while (row != row2)
00108             {
00109                SwapValues(row, row +1);
00110                row++;
00111             }
00112         }
00114         inline void FillIndexValues() {
00115             for(INT i=0; i<m_count; i++)
00116                 SetValue(i,(T)i);
00117         }
00119         inline void FillZeroes() {
00120             for(INT i=0; i<m_count; i++)
00121                 SetValue(i,(T)0);
00122         }
00124         inline INT  GetCount() const { return m_count; }
00125
00127         inline INT  GetSize() const { return m_size; }
00128
00129     private:
00130         T *  m_indextable;
00131         INT  m_count;
00132         INT  m_size;
00133 };
00134
00135
00136
00137 #endif
00138
00139
Generated on Tue Jan 24 14:48:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/IpAddr.cpp File Reference

Auxiliary/IpAddr.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "IpAddr.hpp"
#include "Macros.hpp"

Include dependency graph for IpAddr.cpp:

Variables

const INT c_max_ip_str_len = 15

Variable Documentation

const INT c_max_ip_str_len = 15

Generated on Tue Jan 24 18:41:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/IpAddr.hpp File Reference

Auxiliary/IpAddr.hpp File Reference

#include <Kernel/MachType.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for IpAddr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IpAddr

Defines

#define | Apoxi_IpAddr_hpp

Define Documentation

#define Apoxi_IpAddr_hpp

Generated on Tue Jan 24 18:41:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/IpAddr.hpp Source File

Auxiliary/IpAddr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_IpAddr_hpp)
00012 #define Apoxi_IpAddr_hpp
00015
00016 #include <Kernel/MachType.hpp>
00017 #include <Auxiliary/String.hpp>
00018
00019 /*  -------------------------------------------------------------------------
00020                                 Types
00021     ------------------------------------------------------------------------- */
00022
00023
00026 class IpAddr {
00027     public:
00032         enum PredefIpAddr {
00033             c_ipaddr_loopback,
00034             c_ipaddr_any,
00035             c_ipaddr_broadcast
00036         };
00037
00038         typedef UINT32 Persist;
00039
00044         IpAddr(UINT32 addr = 0, BOOLEAN convert_from_native = FALSE);
00045
00048         IpAddr(UINT8 a, UINT8 b, UINT8 c, UINT8 d);
00049
00053         IpAddr(const CHAR *str, INT len = -1);
00054
00056         IpAddr(PredefIpAddr pre);
00057
00061         IpAddr(const WCHAR *str, INT len = -1);
00062
00064         UINT32 GetAddr() const { return m_addr.m_val.m_uint32; }
00065
00067         UINT32 GetNativeAddr() const { return Native32Bit(m_addr).m_val.m_uint32; }
00068
00072         void SetAddr(UINT32 addr, BOOLEAN convert_from_native = FALSE);
00073
00075         UINT8 GetAPart() const { return m_addr.m_val.m_uint8.m_a; }
00077         void SetAPart(UINT8 a) { m_addr.m_val.m_uint8.m_a = a; }
00079         UINT8 GetBPart() const { return m_addr.m_val.m_uint8.m_b; }
00081         void SetBPart(UINT8 b) { m_addr.m_val.m_uint8.m_b = b; }
00083         UINT8 GetCPart() const { return m_addr.m_val.m_uint8.m_c; }
00085         void SetCPart(UINT8 c) { m_addr.m_val.m_uint8.m_c = c; }
00087         UINT8 GetDPart() const { return m_addr.m_val.m_uint8.m_d; }
00089         void SetDPart(UINT8 d) { m_addr.m_val.m_uint8.m_d = d; }
00090
00096         BOOLEAN InitFrom(const CHAR *str, INT len = -1);
00097
00103         BOOLEAN InitFrom(const WCHAR *str, INT len = -1);
00104
00106         void operator<<(const Persist &p) { m_addr.m_val.m_uint32 = p; }
00107
00109         void operator>>(Persist &p) const { p = m_addr.m_val.m_uint32; }
00110
00112         String Verbose() const;
00113
00114     private:
00115         BigEndian32Bit m_addr;
00116 };
00117
00119 #endif  // Apoxi_IpAddr_hpp
00120
00121
Generated on Tue Jan 24 14:48:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/IpPortNo.cpp File Reference

Auxiliary/IpPortNo.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "IpPortNo.hpp"

Include dependency graph for IpPortNo.cpp:

Generated on Tue Jan 24 18:41:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/IpPortNo.hpp File Reference

Auxiliary/IpPortNo.hpp File Reference

#include <Auxiliary/Iana.hpp>
#include <Kernel/MachType.hpp>

Include dependency graph for IpPortNo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IpPortNo

Defines

#define | Apoxi_IpPortNo_hpp

Define Documentation

#define Apoxi_IpPortNo_hpp

Generated on Tue Jan 24 18:41:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/IpPortNo.hpp Source File

Auxiliary/IpPortNo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_IpPortNo_hpp)
00011 #define Apoxi_IpPortNo_hpp
00014
00015 #include <Auxiliary/Iana.hpp>
00016 #include <Kernel/MachType.hpp>
00017
00023 class IpPortNo {
00024     public:
00028         IpPortNo(UINT16 port = 0, BOOLEAN convert_from_native = FALSE);
00029
00031         IpPortNo(Iana::PortNumber n);
00032
00034         UINT16 GetPortNumber() const { return m_port.m_val.m_uint16; }
00035
00038         UINT16 GetNativePortNumber() const { return Native16Bit(m_port).m_val.m_uint16; }
00039
00040     private:
00041         BigEndian16Bit m_port;
00042 };
00043
00045 #endif  // Apoxi_IpPortNo_hpp
00046
Generated on Tue Jan 24 14:48:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/JapaneseTranscoder.cpp File Reference

Auxiliary/JapaneseTranscoder.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "JapaneseTranscoder.hpp"

Include dependency graph for JapaneseTranscoder.cpp:

Generated on Tue Jan 24 18:41:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/JapaneseTranscoder.hpp File Reference

Auxiliary/JapaneseTranscoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for JapaneseTranscoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | JapaneseTranscoder

Defines

#define | Apoxi_JapaneseTranscoder_hpp

Define Documentation

#define Apoxi_JapaneseTranscoder_hpp

Generated on Tue Jan 24 18:41:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/JapaneseTranscoder.hpp Source File

Auxiliary/JapaneseTranscoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_JapaneseTranscoder_hpp)
00010 #define Apoxi_JapaneseTranscoder_hpp
00011
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/WString.hpp>
00017
00030 class JapaneseTranscoder {
00031     public:
00032         enum EncodingType {
00033             Auto = 0,
00034             Sjis = 1,
00035             Jis = 2,
00036             Euc = 3,
00037             Ucs2 = 4
00038         };
00039
00041         static const JapaneseTranscoder& GetInstance();
00042
00043         ~JapaneseTranscoder();  // non-virtual
00044
00061         Vector<UINT8> Convert(const UINT8* text,
00062                               INT text_len,
00063                               EncodingType to_encoding,
00064                               BOOLEAN* success = 0,
00065                               EncodingType from_encoding = Auto) const;
00066
00072         EncodingType DetectEncoding(const UINT8* text, INT text_len) const;
00073
00074     private:
00075         JapaneseTranscoder();
00076
00077 #if defined(APOXI_ENABLE_JAPANESE_TRANSCODER)
00078         // Internal enum used for converting and escape sequence detection
00079         enum JisEncodingMode {
00080             None,
00081             Ascii,          // ASCII (1 byte/char)
00082             JisRoman,       // JIS-Roman (1 byte/char)
00083             JisC6226_1978,  // JIS C 6226-1978 (2 bytes/char)
00084             JisX0208_1983,  // JIS X 0208-1983 (2 bytes/char)
00085             JisX0212_1990,  // JIS X 0212-1990 (2 bytes/char)
00086             JisX0208_1997,  // JIS X 0208-1997 (2 bytes/char)
00087             Jis7Katakana    // RCR STD Katakana 7bit code for halfwidth katakanas in JIS
00088         };
00089
00091         Vector<UINT8> SjisToJis(const Vector<UINT8>& text) const;
00093         Vector<UINT8> SjisToEuc(const Vector<UINT8>& text) const;
00095         Vector<UINT8> SjisToUcs2(const Vector<UINT8>& text) const;
00096
00098         Vector<UINT8> EucToSjis(const Vector<UINT8>& text) const;
00100         Vector<UINT8> EucToJis(const Vector<UINT8>& text) const;
00101
00103         Vector<UINT8> JisToSjis(const Vector<UINT8>& text) const;
00105         Vector<UINT8> JisToEuc(const Vector<UINT8>& text) const;
00106
00108         Vector<UINT8> Ucs2ToSjis(const Vector<UINT8>& text) const;
00109
00111         BOOLEAN IsSjisMultiByteChar(UINT16 sjis_char) const;
00113         void ConvertSingleByteSjisCharToUcs2Char(UINT8 sjis_char, UINT16* ucs2_char_p) const;
00115         void ConvertMultiByteSjisCharToUcs2Char(UINT16 sjis_char, UINT16* ucs2_char_p) const;
00117         void ConvertUcs2CharToSjisChar(UINT16 unicode_char, UINT16* sjis_char_p) const;
00118
00126         INT GetJisEscapeSequenceLength(const Vector<UINT8>& text,
00127                                        INT start_pos,
00128                                        JisEncodingMode* detected_sequence) const;
00129 #endif
00130 };
00131
00133 #endif
00134
Generated on Tue Jan 24 14:48:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Latin.hpp File Reference

Auxiliary/Latin.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | _APOXI_Latin_Defines_h
#define | W_LATIN_AMPERSAND 0x0026
#define | W_LATIN_APOSTROPHE 0x0027
#define | W_LATIN_ASTERISK 0x002A
#define | W_LATIN_CAPITAL_LETTER_A 0x0041
#define | W_LATIN_CAPITAL_LETTER_B 0x0042
#define | W_LATIN_CAPITAL_LETTER_C 0x0043
#define | W_LATIN_CAPITAL_LETTER_D 0x0044
#define | W_LATIN_CAPITAL_LETTER_E 0x0045
#define | W_LATIN_CAPITAL_LETTER_F 0x0046
#define | W_LATIN_CAPITAL_LETTER_G 0x0047
#define | W_LATIN_CAPITAL_LETTER_H 0x0048
#define | W_LATIN_CAPITAL_LETTER_I 0x0049
#define | W_LATIN_CAPITAL_LETTER_J 0x004A
#define | W_LATIN_CAPITAL_LETTER_K 0x004B
#define | W_LATIN_CAPITAL_LETTER_L 0x004C
#define | W_LATIN_CAPITAL_LETTER_M 0x004D
#define | W_LATIN_CAPITAL_LETTER_N 0x004E
#define | W_LATIN_CAPITAL_LETTER_O 0x004F
#define | W_LATIN_CAPITAL_LETTER_P 0x0050
#define | W_LATIN_CAPITAL_LETTER_Q 0x0051
#define | W_LATIN_CAPITAL_LETTER_R 0x0052
#define | W_LATIN_CAPITAL_LETTER_S 0x0053
#define | W_LATIN_CAPITAL_LETTER_T 0x0054
#define | W_LATIN_CAPITAL_LETTER_U 0x0055
#define | W_LATIN_CAPITAL_LETTER_V 0x0056
#define | W_LATIN_CAPITAL_LETTER_W 0x0057
#define | W_LATIN_CAPITAL_LETTER_X 0x0058
#define | W_LATIN_CAPITAL_LETTER_Y 0x0059
#define | W_LATIN_CAPITAL_LETTER_Z 0x005A
#define | W_LATIN_CIRCUMFLEX_ACCENT 0x005E
#define | W_LATIN_COLON 0x003A
#define | W_LATIN_COMMA 0x002C
#define | W_LATIN_COMMERCIAL_AT 0x0040
#define | W_LATIN_CR 0x000D
#define | W_LATIN_DIGIT_EIGHT 0x0038
#define | W_LATIN_DIGIT_FIVE 0x0035
#define | W_LATIN_DIGIT_FOUR 0x0034
#define | W_LATIN_DIGIT_NINE 0x0039
#define | W_LATIN_DIGIT_ONE 0x0031
#define | W_LATIN_DIGIT_SEVEN 0x0037
#define | W_LATIN_DIGIT_SIX 0x0036
#define | W_LATIN_DIGIT_THREE 0x0033
#define | W_LATIN_DIGIT_TWO 0x0032
#define | W_LATIN_DIGIT_ZERO 0x0030
#define | W_LATIN_DOLLAR_SIGN 0x0024
#define | W_LATIN_EQUALS_SIGN 0x003D
#define | W_LATIN_EXCLAMATION_MARK 0x0021
#define | W_LATIN_FF 0x000C
#define | W_LATIN_FULL_STOP 0x002E
#define | W_LATIN_GRAVE_ACCENT 0x0060
#define | W_LATIN_GREATER_THAN_SIGN 0x003E
#define | W_LATIN_HT 0x0009
#define | W_LATIN_HYPHEN_MINUS 0x002D
#define | W_LATIN_LEFT_CURLY_BRACKET 0x007B
#define | W_LATIN_LEFT_PARENTHESIS 0x0028
#define | W_LATIN_LEFT_SQUARE_BRACKET 0x005B
#define | W_LATIN_LESS_THAN_SIGN 0x003C
#define | W_LATIN_LF 0x000A
#define | W_LATIN_LOW_LINE 0x005F
#define | W_LATIN_NUMBER_SIGN 0x0023
#define | W_LATIN_PERCENT_SIGN 0x0025
#define | W_LATIN_PLUS_SIGN 0x002B
#define | W_LATIN_QUESTION_MARK 0x003F
#define | W_LATIN_QUOTATION_MARK 0x0022
#define | W_LATIN_REVERSE_SOLIDUS 0x005C
#define | W_LATIN_RIGHT_CURLY_BRACKET 0x007D
#define | W_LATIN_RIGHT_PARENTHESIS 0x0029
#define | W_LATIN_RIGHT_SQUARE_BRACKET 0x005D
#define | W_LATIN_SEMICOLON 0x003B
#define | W_LATIN_SMALL_LETTER_A 0x0061
#define | W_LATIN_SMALL_LETTER_B 0x0062
#define | W_LATIN_SMALL_LETTER_C 0x0063
#define | W_LATIN_SMALL_LETTER_D 0x0064
#define | W_LATIN_SMALL_LETTER_E 0x0065
#define | W_LATIN_SMALL_LETTER_F 0x0066
#define | W_LATIN_SMALL_LETTER_G 0x0067
#define | W_LATIN_SMALL_LETTER_H 0x0068
#define | W_LATIN_SMALL_LETTER_I 0x0069
#define | W_LATIN_SMALL_LETTER_J 0x006A
#define | W_LATIN_SMALL_LETTER_K 0x006B
#define | W_LATIN_SMALL_LETTER_L 0x006C
#define | W_LATIN_SMALL_LETTER_M 0x006D
#define | W_LATIN_SMALL_LETTER_N 0x006E
#define | W_LATIN_SMALL_LETTER_O 0x006F
#define | W_LATIN_SMALL_LETTER_P 0x0070
#define | W_LATIN_SMALL_LETTER_Q 0x0071
#define | W_LATIN_SMALL_LETTER_R 0x0072
#define | W_LATIN_SMALL_LETTER_S 0x0073
#define | W_LATIN_SMALL_LETTER_T 0x0074
#define | W_LATIN_SMALL_LETTER_U 0x0075
#define | W_LATIN_SMALL_LETTER_V 0x0076
#define | W_LATIN_SMALL_LETTER_W 0x0077
#define | W_LATIN_SMALL_LETTER_X 0x0078
#define | W_LATIN_SMALL_LETTER_Y 0x0079
#define | W_LATIN_SMALL_LETTER_Z 0x007A
#define | W_LATIN_SOLIDUS 0x002F
#define | W_LATIN_SPACE 0x0020
#define | W_LATIN_TILDE 0x007E
#define | W_LATIN_VERTICAL_LINE 0x007C
#define | W_LATIN_VT 0x000B

Define Documentation

#define _APOXI_Latin_Defines_h

#define W_LATIN_AMPERSAND 0x0026

#define W_LATIN_APOSTROPHE 0x0027

#define W_LATIN_ASTERISK 0x002A

#define W_LATIN_CAPITAL_LETTER_A 0x0041

#define W_LATIN_CAPITAL_LETTER_B 0x0042

#define W_LATIN_CAPITAL_LETTER_C 0x0043

#define W_LATIN_CAPITAL_LETTER_D 0x0044

#define W_LATIN_CAPITAL_LETTER_E 0x0045

#define W_LATIN_CAPITAL_LETTER_F 0x0046

#define W_LATIN_CAPITAL_LETTER_G 0x0047

#define W_LATIN_CAPITAL_LETTER_H 0x0048

#define W_LATIN_CAPITAL_LETTER_I 0x0049

#define W_LATIN_CAPITAL_LETTER_J 0x004A

#define W_LATIN_CAPITAL_LETTER_K 0x004B

#define W_LATIN_CAPITAL_LETTER_L 0x004C

#define W_LATIN_CAPITAL_LETTER_M 0x004D

#define W_LATIN_CAPITAL_LETTER_N 0x004E

#define W_LATIN_CAPITAL_LETTER_O 0x004F

#define W_LATIN_CAPITAL_LETTER_P 0x0050

#define W_LATIN_CAPITAL_LETTER_Q 0x0051

#define W_LATIN_CAPITAL_LETTER_R 0x0052

#define W_LATIN_CAPITAL_LETTER_S 0x0053

#define W_LATIN_CAPITAL_LETTER_T 0x0054

#define W_LATIN_CAPITAL_LETTER_U 0x0055

#define W_LATIN_CAPITAL_LETTER_V 0x0056

#define W_LATIN_CAPITAL_LETTER_W 0x0057

#define W_LATIN_CAPITAL_LETTER_X 0x0058

#define W_LATIN_CAPITAL_LETTER_Y 0x0059

#define W_LATIN_CAPITAL_LETTER_Z 0x005A

#define W_LATIN_CIRCUMFLEX_ACCENT 0x005E

#define W_LATIN_COLON 0x003A

#define W_LATIN_COMMA 0x002C

#define W_LATIN_COMMERCIAL_AT 0x0040

#define W_LATIN_CR 0x000D

#define W_LATIN_DIGIT_EIGHT 0x0038

#define W_LATIN_DIGIT_FIVE 0x0035

#define W_LATIN_DIGIT_FOUR 0x0034

#define W_LATIN_DIGIT_NINE 0x0039

#define W_LATIN_DIGIT_ONE 0x0031

#define W_LATIN_DIGIT_SEVEN 0x0037

#define W_LATIN_DIGIT_SIX 0x0036

#define W_LATIN_DIGIT_THREE 0x0033

#define W_LATIN_DIGIT_TWO 0x0032

#define W_LATIN_DIGIT_ZERO 0x0030

#define W_LATIN_DOLLAR_SIGN 0x0024

#define W_LATIN_EQUALS_SIGN 0x003D

#define W_LATIN_EXCLAMATION_MARK 0x0021

#define W_LATIN_FF 0x000C

#define W_LATIN_FULL_STOP 0x002E

#define W_LATIN_GRAVE_ACCENT 0x0060

#define W_LATIN_GREATER_THAN_SIGN 0x003E

#define W_LATIN_HT 0x0009

#define W_LATIN_HYPHEN_MINUS 0x002D

#define W_LATIN_LEFT_CURLY_BRACKET 0x007B

#define W_LATIN_LEFT_PARENTHESIS 0x0028

#define W_LATIN_LEFT_SQUARE_BRACKET 0x005B

#define W_LATIN_LESS_THAN_SIGN 0x003C

#define W_LATIN_LF 0x000A

#define W_LATIN_LOW_LINE 0x005F

#define W_LATIN_NUMBER_SIGN 0x0023

#define W_LATIN_PERCENT_SIGN 0x0025

#define W_LATIN_PLUS_SIGN 0x002B

#define W_LATIN_QUESTION_MARK 0x003F

#define W_LATIN_QUOTATION_MARK 0x0022

#define W_LATIN_REVERSE_SOLIDUS 0x005C

#define W_LATIN_RIGHT_CURLY_BRACKET 0x007D

#define W_LATIN_RIGHT_PARENTHESIS 0x0029

#define W_LATIN_RIGHT_SQUARE_BRACKET 0x005D

#define W_LATIN_SEMICOLON 0x003B

#define W_LATIN_SMALL_LETTER_A 0x0061

#define W_LATIN_SMALL_LETTER_B 0x0062

#define W_LATIN_SMALL_LETTER_C 0x0063

#define W_LATIN_SMALL_LETTER_D 0x0064

#define W_LATIN_SMALL_LETTER_E 0x0065

#define W_LATIN_SMALL_LETTER_F 0x0066

#define W_LATIN_SMALL_LETTER_G 0x0067

#define W_LATIN_SMALL_LETTER_H 0x0068

#define W_LATIN_SMALL_LETTER_I 0x0069

#define W_LATIN_SMALL_LETTER_J 0x006A

#define W_LATIN_SMALL_LETTER_K 0x006B

#define W_LATIN_SMALL_LETTER_L 0x006C

#define W_LATIN_SMALL_LETTER_M 0x006D

#define W_LATIN_SMALL_LETTER_N 0x006E

#define W_LATIN_SMALL_LETTER_O 0x006F

#define W_LATIN_SMALL_LETTER_P 0x0070

#define W_LATIN_SMALL_LETTER_Q 0x0071

#define W_LATIN_SMALL_LETTER_R 0x0072

#define W_LATIN_SMALL_LETTER_S 0x0073

#define W_LATIN_SMALL_LETTER_T 0x0074

#define W_LATIN_SMALL_LETTER_U 0x0075

#define W_LATIN_SMALL_LETTER_V 0x0076

#define W_LATIN_SMALL_LETTER_W 0x0077

#define W_LATIN_SMALL_LETTER_X 0x0078

#define W_LATIN_SMALL_LETTER_Y 0x0079

#define W_LATIN_SMALL_LETTER_Z 0x007A

#define W_LATIN_SOLIDUS 0x002F

#define W_LATIN_SPACE 0x0020

#define W_LATIN_TILDE 0x007E

#define W_LATIN_VERTICAL_LINE 0x007C

#define W_LATIN_VT 0x000B

Generated on Tue Jan 24 18:48:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Latin.hpp Source File

Auxiliary/Latin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(_APOXI_Latin_Defines_h)
00010 #define _APOXI_Latin_Defines_h
00011
00012 #define W_LATIN_HT                    0x0009    // ( ) horizontal tabulator
00013 #define W_LATIN_LF                    0x000A    // ( ) new line
00014 #define W_LATIN_VT                    0x000B    // ( ) vertical tabulator
00015 #define W_LATIN_FF                    0x000C    // ( ) formfeed
00016 #define W_LATIN_CR                    0x000D    // ( ) carriage return
00017
00018 #define W_LATIN_SPACE                 0x0020    // ( ) (aka blank)
00019 #define W_LATIN_EXCLAMATION_MARK      0x0021    // (!)
00020 #define W_LATIN_QUOTATION_MARK        0x0022    // (")
00021 #define W_LATIN_NUMBER_SIGN           0x0023    // (#)
00022 #define W_LATIN_DOLLAR_SIGN           0x0024    // ($)
00023 #define W_LATIN_PERCENT_SIGN          0x0025    // (%)
00024 #define W_LATIN_AMPERSAND             0x0026    // (&)
00025 #define W_LATIN_APOSTROPHE            0x0027    // (')
00026 #define W_LATIN_LEFT_PARENTHESIS      0x0028    // (()
00027 #define W_LATIN_RIGHT_PARENTHESIS     0x0029    // ())
00028 #define W_LATIN_ASTERISK              0x002A    // (*)
00029 #define W_LATIN_PLUS_SIGN             0x002B    // (+)
00030 #define W_LATIN_COMMA                 0x002C    // (,)
00031 #define W_LATIN_HYPHEN_MINUS          0x002D    // (-)
00032 #define W_LATIN_FULL_STOP             0x002E    // (.)
00033 #define W_LATIN_SOLIDUS               0x002F    // (/) (aka slash)
00034
00035 #define W_LATIN_DIGIT_ZERO            0x0030    // (0)
00036 #define W_LATIN_DIGIT_ONE             0x0031    // (1)
00037 #define W_LATIN_DIGIT_TWO             0x0032    // (2)
00038 #define W_LATIN_DIGIT_THREE           0x0033    // (3)
00039 #define W_LATIN_DIGIT_FOUR            0x0034    // (4)
00040 #define W_LATIN_DIGIT_FIVE            0x0035    // (5)
00041 #define W_LATIN_DIGIT_SIX             0x0036    // (6)
00042 #define W_LATIN_DIGIT_SEVEN           0x0037    // (7)
00043 #define W_LATIN_DIGIT_EIGHT           0x0038    // (8)
00044 #define W_LATIN_DIGIT_NINE            0x0039    // (9)
00045 #define W_LATIN_COLON                 0x003A    // (:)
00046 #define W_LATIN_SEMICOLON             0x003B    // (;)
00047 #define W_LATIN_LESS_THAN_SIGN        0x003C    // (<)
00048 #define W_LATIN_EQUALS_SIGN           0x003D    // (=)
00049 #define W_LATIN_GREATER_THAN_SIGN     0x003E    // (>)
00050 #define W_LATIN_QUESTION_MARK         0x003F    // (?)
00051
00052 #define W_LATIN_COMMERCIAL_AT         0x0040    // (@)
00053 #define W_LATIN_CAPITAL_LETTER_A      0x0041    // (A)
00054 #define W_LATIN_CAPITAL_LETTER_B      0x0042    // (B)
00055 #define W_LATIN_CAPITAL_LETTER_C      0x0043    // (C)
00056 #define W_LATIN_CAPITAL_LETTER_D      0x0044    // (D)
00057 #define W_LATIN_CAPITAL_LETTER_E      0x0045    // (E)
00058 #define W_LATIN_CAPITAL_LETTER_F      0x0046    // (F)
00059 #define W_LATIN_CAPITAL_LETTER_G      0x0047    // (G)
00060 #define W_LATIN_CAPITAL_LETTER_H      0x0048    // (H)
00061 #define W_LATIN_CAPITAL_LETTER_I      0x0049    // (I)
00062 #define W_LATIN_CAPITAL_LETTER_J      0x004A    // (J)
00063 #define W_LATIN_CAPITAL_LETTER_K      0x004B    // (K)
00064 #define W_LATIN_CAPITAL_LETTER_L      0x004C    // (L)
00065 #define W_LATIN_CAPITAL_LETTER_M      0x004D    // (M)
00066 #define W_LATIN_CAPITAL_LETTER_N      0x004E    // (N)
00067 #define W_LATIN_CAPITAL_LETTER_O      0x004F    // (O)
00068 #define W_LATIN_CAPITAL_LETTER_P      0x0050    // (P)
00069 #define W_LATIN_CAPITAL_LETTER_Q      0x0051    // (Q)
00070 #define W_LATIN_CAPITAL_LETTER_R      0x0052    // (R)
00071 #define W_LATIN_CAPITAL_LETTER_S      0x0053    // (S)
00072 #define W_LATIN_CAPITAL_LETTER_T      0x0054    // (T)
00073 #define W_LATIN_CAPITAL_LETTER_U      0x0055    // (U)
00074 #define W_LATIN_CAPITAL_LETTER_V      0x0056    // (V)
00075 #define W_LATIN_CAPITAL_LETTER_W      0x0057    // (W)
00076 #define W_LATIN_CAPITAL_LETTER_X      0x0058    // (X)
00077 #define W_LATIN_CAPITAL_LETTER_Y      0x0059    // (Y)
00078 #define W_LATIN_CAPITAL_LETTER_Z      0x005A    // (Z)
00079
00080 #define W_LATIN_LEFT_SQUARE_BRACKET   0x005B    // ([)
00081 #define W_LATIN_REVERSE_SOLIDUS       0x005C    // (\) (aka backslash)
00082 #define W_LATIN_RIGHT_SQUARE_BRACKET  0x005D    // (])
00083 #define W_LATIN_CIRCUMFLEX_ACCENT     0x005E    // (^)
00084 #define W_LATIN_LOW_LINE              0x005F    // (_) (aka underscore)
00085
00086 #define W_LATIN_GRAVE_ACCENT          0x0060    // (`)
00087 #define W_LATIN_SMALL_LETTER_A        0x0061    // (a)
00088 #define W_LATIN_SMALL_LETTER_B        0x0062    // (b)
00089 #define W_LATIN_SMALL_LETTER_C        0x0063    // (c)
00090 #define W_LATIN_SMALL_LETTER_D        0x0064    // (d)
00091 #define W_LATIN_SMALL_LETTER_E        0x0065    // (e)
00092 #define W_LATIN_SMALL_LETTER_F        0x0066    // (f)
00093 #define W_LATIN_SMALL_LETTER_G        0x0067    // (g)
00094 #define W_LATIN_SMALL_LETTER_H        0x0068    // (h)
00095 #define W_LATIN_SMALL_LETTER_I        0x0069    // (i)
00096 #define W_LATIN_SMALL_LETTER_J        0x006A    // (j)
00097 #define W_LATIN_SMALL_LETTER_K        0x006B    // (k)
00098 #define W_LATIN_SMALL_LETTER_L        0x006C    // (l)
00099 #define W_LATIN_SMALL_LETTER_M        0x006D    // (m)
00100 #define W_LATIN_SMALL_LETTER_N        0x006E    // (n)
00101 #define W_LATIN_SMALL_LETTER_O        0x006F    // (o)
00102 #define W_LATIN_SMALL_LETTER_P        0x0070    // (p)
00103 #define W_LATIN_SMALL_LETTER_Q        0x0071    // (q)
00104 #define W_LATIN_SMALL_LETTER_R        0x0072    // (r)
00105 #define W_LATIN_SMALL_LETTER_S        0x0073    // (s)
00106 #define W_LATIN_SMALL_LETTER_T        0x0074    // (t)
00107 #define W_LATIN_SMALL_LETTER_U        0x0075    // (u)
00108 #define W_LATIN_SMALL_LETTER_V        0x0076    // (v)
00109 #define W_LATIN_SMALL_LETTER_W        0x0077    // (w)
00110 #define W_LATIN_SMALL_LETTER_X        0x0078    // (x)
00111 #define W_LATIN_SMALL_LETTER_Y        0x0079    // (y)
00112 #define W_LATIN_SMALL_LETTER_Z        0x007A    // (z)
00113
00114 #define W_LATIN_LEFT_CURLY_BRACKET    0x007B    // ({)
00115 #define W_LATIN_VERTICAL_LINE         0x007C    // (|)
00116 #define W_LATIN_RIGHT_CURLY_BRACKET   0x007D    // (})
00117 #define W_LATIN_TILDE                 0x007E    // (~)
00118
00119 #endif  // _APOXI_Latin_Defines_h
00120
00121
Generated on Tue Jan 24 14:48:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Lib.hpp File Reference

Auxiliary/Lib.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Auxiliary/DbgDump.hpp>
#include <Auxiliary/AlphaCoding.hpp>
#include <Auxiliary/BitVector.hpp>
#include <Auxiliary/BlobObject.hpp>
#include <Auxiliary/BubbleSortProvider.hpp>
#include <Auxiliary/Conversion.hpp>
#include <Auxiliary/DataCoding.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Auxiliary/FifoLinkedList.hpp>
#include <Auxiliary/FilterProvider.hpp>
#include <Auxiliary/FilterRule.hpp>
#include <Auxiliary/Find2Provider.hpp>
#include <Auxiliary/FindProvider.hpp>
#include <Auxiliary/GenericObject.hpp>
#include <Auxiliary/HashTable.hpp>
#include <Auxiliary/HeapObject.hpp>
#include <Auxiliary/IndexTable.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/MemPool.hpp>
#include <Auxiliary/NonCloneable.hpp>
#include <Auxiliary/ObjectReferrer.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/Protector.hpp>
#include <Auxiliary/Provider.hpp>
#include <Auxiliary/QuickSortProvider.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/StrUtil.hpp>
#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Auxiliary/ObservableObject.hpp>
#include <Auxiliary/Observer.hpp>

Include dependency graph for Lib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Auxiliary_Lib_hpp

Define Documentation

#define Auxiliary_Lib_hpp

Generated on Tue Jan 24 14:54:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Lib.hpp Source File

Auxiliary/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Auxiliary_Lib_hpp)
00009 #define Auxiliary_Lib_hpp
00012
00013 #include <Auxiliary/Macros.hpp>
00014 #include <Auxiliary/DbgDump.hpp>
00015
00016 #include <Auxiliary/AlphaCoding.hpp>
00017 #include <Auxiliary/BitVector.hpp>
00018 #include <Auxiliary/BlobObject.hpp>
00019 #include <Auxiliary/BubbleSortProvider.hpp>
00020 #include <Auxiliary/Conversion.hpp>
00021 #include <Auxiliary/DataCoding.hpp>
00022 #include <Auxiliary/DataItem.hpp>
00023 #include <Auxiliary/Date.hpp>
00024 #include <Auxiliary/DateTime.hpp>
00025 #include <Auxiliary/FifoLinkedList.hpp>
00026 #include <Auxiliary/FilterProvider.hpp>
00027 #include <Auxiliary/FilterRule.hpp>
00028 #include <Auxiliary/Find2Provider.hpp>
00029 #include <Auxiliary/FindProvider.hpp>
00030 #include <Auxiliary/GenericObject.hpp>
00031 #include <Auxiliary/HashTable.hpp>
00032 #include <Auxiliary/HeapObject.hpp>
00033 #include <Auxiliary/IndexTable.hpp>
00034 #include <Auxiliary/Linkable.hpp>
00035 #include <Auxiliary/LinkedList.hpp>
00036 #include <Auxiliary/MemPool.hpp>
00037 #include <Auxiliary/NonCloneable.hpp>
00038 #include <Auxiliary/ObjectReferrer.hpp>
00039 #include <Auxiliary/PhoneNumber.hpp>
00040 #include <Auxiliary/Protector.hpp>
00041 #include <Auxiliary/Provider.hpp>
00042 #include <Auxiliary/QuickSortProvider.hpp>
00043 #include <Auxiliary/SimpleMap.hpp>
00044 #include <Auxiliary/String.hpp>
00045 #include <Auxiliary/StrUtil.hpp>
00046 #include <Auxiliary/ThreadSafeProvider.hpp>
00047 #include <Auxiliary/Vector.hpp>
00048 #include <Auxiliary/WString.hpp>
00049 #include <Auxiliary/WStrUtil.hpp>
00050 #include <Auxiliary/ObservableObject.hpp>
00051 #include <Auxiliary/Observer.hpp>
00052
00054 #endif
00055
00056
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Linkable.hpp File Reference

Auxiliary/Linkable.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for Linkable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Linkable< T >
class | LinkableBase

Defines

#define | Apoxi_Linkable_hpp

Define Documentation

#define Apoxi_Linkable_hpp

Generated on Tue Jan 24 18:52:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Linkable.hpp Source File

Auxiliary/Linkable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Linkable_hpp)
00010 #define Apoxi_Linkable_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00019 class LinkableBase {
00020     public:
00022         LinkableBase(LinkableBase *next = 0);
00023
00025         virtual ~LinkableBase();
00026
00028         LinkableBase* GetNext() const {
00029             return(m_next);
00030         }
00031
00033         void SetNext(LinkableBase *next) {
00034             m_next = next;
00035         }
00036
00037     private:
00038         LinkableBase *m_next;
00039 };
00040
00041 template<class T> class Linkable : public LinkableBase {
00042     typedef LinkableBase Base;
00043
00044     public:
00045         T* GetNext() const {
00046             return (T*)Base::GetNext();
00047         }
00048 };
00049
00051 #endif  // Apoxi_Linkable_hpp
00052
00053
Generated on Tue Jan 24 14:48:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/LinkedList.cpp File Reference

Auxiliary/LinkedList.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "LinkedList.hpp"
#include "Linkable.hpp"
#include "Macros.hpp"

Include dependency graph for LinkedList.cpp:

Generated on Tue Jan 24 18:52:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/LinkedList.hpp File Reference

Auxiliary/LinkedList.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for LinkedList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LinkedList< T >
class | LinkedListBase
class | SortedLinkedList< T >
class | SortedLinkedListBase

Defines

#define | Apoxi_LinkedList_hpp

Define Documentation

#define Apoxi_LinkedList_hpp

Generated on Tue Jan 24 18:56:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/LinkedList.hpp Source File

Auxiliary/LinkedList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_LinkedList_hpp)
00010 #define Apoxi_LinkedList_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 class LinkableBase;
00017
00018 /*  ------------------------------------------------------------------------
00019                                     LinkedList
00020     ------------------------------------------------------------------------ */
00021
00024 class LinkedListBase {
00025     public:
00027         LinkedListBase(LinkableBase *elem = 0);
00028
00030         BOOLEAN IsEmpty() const {
00031             return m_anchor == 0;
00032         }
00033
00035         INT GetSize() const;
00036
00038         LinkableBase* GetFront() const {
00039             return m_anchor;
00040         }
00041
00043         void PushFront(LinkableBase *elem);
00044
00046         void PopFront();
00047
00051         LinkableBase* GetBack() const;
00052
00056         void PushBack(LinkableBase *elem);
00057
00059         void PopBack();
00060
00062         void Remove(LinkableBase *elem);
00063
00068         void Insert(LinkableBase *elem, LinkableBase *after = 0);
00069
00071         BOOLEAN Contains(LinkableBase *elem) const;
00072
00073     protected:
00074         LinkableBase *m_anchor;
00075 };
00076
00079 template<class T> class LinkedList : public LinkedListBase {
00080     typedef LinkedListBase Base;
00081
00082     public:
00083         LinkedList(T *elem) : Base(elem) {}
00084         LinkedList() : Base(0) {}
00085
00086         T* GetFront() const {
00087             return (T*)Base::GetFront();
00088         }
00089 };
00090
00091
00092 /*  ------------------------------------------------------------------------
00093                                 SortedLinkedList
00094     ------------------------------------------------------------------------ */
00095 class SortedLinkedListBase : private LinkedListBase {
00096     typedef LinkedListBase Base;
00097
00098     public:
00099         using Base::IsEmpty;
00100         using Base::GetSize;
00101         using Base::Remove;
00102         using Base::PopFront;
00103         using Base::GetFront;
00104         using Base::Contains;
00105
00106     protected:
00107         using Base::PushFront;
00108 };
00109
00111 template<class T> class SortedLinkedList : public SortedLinkedListBase {
00112     typedef SortedLinkedListBase Base;
00113
00114     public:
00115         T* GetFront() const {
00116             return (T*)Base::GetFront();
00117         }
00118
00119
00120         void Insert(T *elem);
00121 };
00122
00123
00124
00125 /*  ------------------------------------------------------------------------
00126     Insert
00127     ------------------------------------------------------------------------ */
00128 template<class T> void SortedLinkedList<T>::Insert(T *elem)
00129 {
00130     T *t = (T*)GetFront();
00131     T *prev = 0;
00132
00133     while(t != 0 && *t < *elem) {
00134         prev = t;
00135         t = (T*)t->GetNext();
00136     }
00137
00138     if (GetFront() == 0 || prev == 0)
00139         PushFront(elem);
00140     else {
00141         prev->SetNext(elem);
00142         elem->SetNext(t);
00143     }
00144 }   // Insert
00145
00147 #endif  // Apoxi_LinkedList_hpp
00148
00149
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Macros.hpp File Reference

Auxiliary/Macros.hpp File Reference

#include <Kernel/Os/Trap.hpp>
#include <Kernel/Os/OsClass.hpp>

Include dependency graph for Macros.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_Macros_hpp
#define | ASSERT(cond) Trap::Assertion(cond, __FILE__, __LINE__);
#define | ASSERT_ALWAYS(cond) Trap::Assertion(cond, __FILE__, __LINE__);
#define | ASSERT_DEBUG(cond)
#define | ASSERT_DEBUG_HOST(cond)
#define | ASSERT_DEBUG_INFO(cond, text)
#define | ASSERT_INFO ASSERT_DEBUG_INFO
#define | DBG_OUT(args)
#define | DBG_OUT_STACK_USAGE()
#define | LOC(x)
#define | LOC_W(x)
#define | max(a, b) (((a) > (b)) ? (a) : (b))
#define | min(a, b) (((a) < (b)) ? (a) : (b))
#define | SaveDelete(p) { delete (p); (p) = 0; }

Functions

template<class T>
void | Unused (const T &t)

Define Documentation

#define Apoxi_Macros_hpp

Generated on Tue Jan 24 19:06:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Macros.hpp Source File

Auxiliary/Macros.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Macros_hpp)
00010 #define Apoxi_Macros_hpp
00013
00014 #include <Kernel/Os/Trap.hpp>
00015 #include <Kernel/Os/OsClass.hpp>
00016
00017 /*  ----------------------------------------------------------------
00018     SaveDelete
00019     ---------------------------------------------------------------- */
00020 #define SaveDelete(p)       { delete (p); (p) = 0; }
00021
00022 // Obsolete - use ASSERT_ALWAYS or ASSERT_DEBUG instead
00023 #if !defined(ASSERT)
00024     #if defined(_MSC)
00025         #include <assert.h>
00026         #define ASSERT(cond)            assert(cond)
00027     #else
00028         #define ASSERT(cond)            Trap::Assertion(cond, __FILE__, __LINE__);
00029     #endif
00030 #endif
00031
00032 // Obsolete - use ASSERT_DEBUG_INFO instead
00033 #if !defined(ASSERT_INFO)
00034 /*
00035     #define ASSERT_INFO(cond, text) {                   \
00036         if (!(cond)) {                                  \
00037             DBG_OUT((0, L"ASSERTION: "text L"\n"));     \
00038         }                                               \
00039         ASSERT(cond);                                   \
00040     }
00041 */
00042     #define ASSERT_INFO ASSERT_DEBUG_INFO
00043 #endif
00044
00045 /*  ----------------------------------------------------------------
00046     ASSERT_ALWAYS
00047     ---------------------------------------------------------------- */
00048 #if !defined(ASSERT_ALWAYS)
00049     #if defined(_MSC)
00050         #include <assert.h>
00051         #define ASSERT_ALWAYS(cond)     assert(cond)
00052     #else
00053         #define ASSERT_ALWAYS(cond)     Trap::Assertion(cond, __FILE__, __LINE__);
00054     #endif
00055 #endif
00056
00057 /*  ----------------------------------------------------------------
00058     ASSERT_DEBUG
00059     ---------------------------------------------------------------- */
00060 #if defined(_DEBUG)
00061     #if !defined(ASSERT_DEBUG)
00062         #if defined(_MSC)
00063             #include <assert.h>
00064             #define ASSERT_DEBUG(cond)  assert(cond)
00065         #else
00066             #define ASSERT_DEBUG(cond)  Trap::Assertion(cond, __FILE__, __LINE__);
00067         #endif
00068     #endif
00069     #if !defined(ASSERT_DEBUG_INFO)
00070         #define ASSERT_DEBUG_INFO(cond, text)   {           \
00071             if (!(cond)) {                                  \
00072                 DBG_OUT((0, L"ASSERTION: "text L"\n"));     \
00073             }                                               \
00074             ASSERT_DEBUG(cond);                             \
00075         }
00076     #endif
00077 #else
00078     #if !defined(ASSERT_DEBUG)
00079         #define ASSERT_DEBUG(cond)
00080     #endif
00081     #if !defined(ASSERT_DEBUG_INFO)
00082         #define ASSERT_DEBUG_INFO(cond, text)
00083     #endif
00084 #endif
00085
00086 /*  ----------------------------------------------------------------
00087     ASSERT_DEBUG_HOST
00088     ---------------------------------------------------------------- */
00089 #if !defined(ASSERT_DEBUG_HOST)
00090     #if defined(_DEBUG)
00091         #if defined(_MSC)
00092             #include <assert.h>
00093             #define ASSERT_DEBUG_HOST(cond)         assert(cond)
00094         #else
00095             #define ASSERT_DEBUG_HOST(cond)
00096         #endif
00097     #else
00098         #define ASSERT_DEBUG_HOST(cond)
00099     #endif
00100 #endif
00101
00102 /*  ----------------------------------------------------------------
00103     DBG_OUT
00104     ---------------------------------------------------------------- */
00105 #if ( defined(_DEBUG) || defined(APOXI_ENABLE_DBG_OUT) )
00106     #define DBG_OUT(args)   Os::DbgOut args
00107 #else
00108     #define DBG_OUT(args)
00109 #endif
00110
00111 /*  ----------------------------------------------------------------
00112     DBG_OUT_STACK_USAGE
00113     ---------------------------------------------------------------- */
00114 #if ( defined(_DEBUG) || defined(APOXI_ENABLE_DBG_OUT) )
00115     #define DBG_OUT_STACK_USAGE()   Os::DbgOutStackUsage()
00116 #else
00117     #define DBG_OUT_STACK_USAGE()
00118 #endif
00119
00120 /*  ----------------------------------------------------------------
00121     Unused
00122     ---------------------------------------------------------------- */
00123 template<class T> inline void Unused(const T &t)
00124 {
00125     const T *x = &t;
00126     x++;
00127 }
00128
00129 /*  ----------------------------------------------------------------
00130     Disable warning C4355 for the Microsoft Visual-Studio Compiler:
00131     << 'this' : used in base member initializer list >>
00132     because 'this' is always used in a clean way.
00133     ---------------------------------------------------------------- */
00134 #if defined(APOXI_COMPILER_MSVC)
00135     #pragma warning(disable : 4355)
00136 #endif
00137
00138 /*  ----------------------------------------------------------------
00139     #pragma message (LOC_W("iii to do"))
00140     dumps
00141       z:\lnz_development\src\apoxi\devices\win32\Dummy.cpp(15): Warning: iii to do
00142     into build window of Visual Studio.
00143     That row can be double clicked to go to the source.
00144     ---------------------------------------------------------------- */
00145 #if defined(APOXI_COMPILER_MSVC)
00146     #define LOC_HELPER2(z) #z
00147     #define LOC_HELPER1(y) LOC_HELPER2(y)
00148
00149     #define LOC_W(x) __FILE__ "(" LOC_HELPER1(__LINE__) "): Warning: " x
00150     #define LOC(x) __FILE__ "(" LOC_HELPER1(__LINE__) "): " x
00151 #else
00152     #define LOC(x)
00153     #define LOC_W(x)
00154 #endif
00155
00156 #undef min
00157 #define min(a,b) (((a) < (b)) ? (a) : (b))
00158
00159 #undef max
00160 #define max(a,b) (((a) > (b)) ? (a) : (b))
00161
00163 #endif  // Apoxi_Macros_hpp
00164
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MainProvider.cpp File Reference

Auxiliary/MainProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "MainProvider.hpp"
#include <Kernel/Os/SemObtainer.hpp>

Include dependency graph for MainProvider.cpp:

Generated on Tue Jan 24 19:06:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MainProvider.hpp File Reference

Auxiliary/MainProvider.hpp File Reference

#include <Auxiliary/ElementList.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/Provider.hpp>

Include dependency graph for MainProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MainProvider
class | ProviderPtr

Defines

#define | Auxiliary_MainProvider_hpp

Typedefs

typedef ElementList< ProviderPtr > | ProviderPtrList

Define Documentation

#define Auxiliary_MainProvider_hpp

Typedef Documentation

typedef ElementList<ProviderPtr> ProviderPtrList

Generated on Tue Jan 24 19:06:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MainProvider.hpp Source File

Auxiliary/MainProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Auxiliary_MainProvider_hpp)
00015 #define Auxiliary_MainProvider_hpp
00016
00017 #include <Auxiliary/ElementList.hpp>
00018 #include <Auxiliary/Linkable.hpp>
00019 #include <Auxiliary/Provider.hpp>
00020
00021 /*------------------------------------------------------------------
00022                             ProviderPtr
00023  ------------------------------------------------------------------*/
00024
00025 class ProviderPtr : public Linkable<ProviderPtr>
00026 {
00027     public:
00028         ProviderPtr() : m_provider(0), m_refcount(0) {};
00029
00030         ProviderPtr(Provider * provider) : m_provider(provider), m_refcount(0) {
00031             ASSERT(provider!=0);
00032         }
00033
00034         virtual ~ProviderPtr() {
00035             ASSERT(m_refcount==0);
00036         }
00037
00038         BOOLEAN operator == (const ProviderPtr &ptr) const { return (m_provider == ptr.m_provider); }
00039
00040         Provider * GetProvider() const { return m_provider; }
00041         INT GetId() const { ASSERT(m_provider!=0); return m_provider->GetProviderId(); }
00042         INT GetRefCount() const { return m_refcount; }
00043         void IncRefCount() { m_refcount++; }
00044         void DecRefCount() { m_refcount--; }
00045
00046     private:
00047         Provider * m_provider;
00048         INT        m_refcount;
00049 };
00050
00051 typedef ElementList<ProviderPtr> ProviderPtrList;
00052
00053 /*------------------------------------------------------------------
00054                             MainProvider
00055  ------------------------------------------------------------------*/
00059 class MainProvider
00060 {
00061     public:
00063         MainProvider();
00064
00066         virtual ~MainProvider();
00067
00069         void Init();
00070
00072         virtual Provider * GetProvider(INT providerid);
00073
00075         BOOLEAN HasProvider(INT providerid) { return GetProvider(providerid)!=0; }
00076
00078         static BOOLEAN    RegisterGlobalProvider(Provider * provider);
00079
00082         static BOOLEAN    AcquireGlobalProvider(INT providerid);
00083
00085         static BOOLEAN    ReleaseGlobalProvider(INT providerid);
00086
00088         static BOOLEAN    UnregisterGlobalProvider(Provider * provider);
00089
00090     protected:
00091         static Provider * GetGlobalProvider(INT columnid);
00092
00093     private:
00094         static ProviderPtr * GetGlobalProviderPtr(INT columnid);
00095
00096         static ProviderPtrList m_globalproviders;
00097         static BOOLEAN         m_semexisting;
00098         static Semaphore       m_semaphore;
00099         static INT             m_refcount;
00100 };
00101
00102 #endif  // Auxiliary_MainProvider_hpp
00103
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Map.hpp File Reference

Auxiliary/Map.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Auxiliary_Map_hpp

Define Documentation

#define Auxiliary_Map_hpp

Generated on Tue Jan 24 19:06:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Map.hpp Source File

Auxiliary/Map.hpp

Go to the documentation of this file.
00001 //  ------------------------------------------------------------------------
00002 //  Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 //  All rights reserved.
00004 //  ------------------------------------------------------------------------
00005 //  This document contains proprietary information belonging to COMNEON.
00006 //  Passing on and copying of this document, use and communication of its
00007 //  contents is not permitted without prior written authorisation.
00008 //  ------------------------------------------------------------------------
00009
00010 #if !defined(Auxiliary_Map_hpp)
00011 #define Auxiliary_Map_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00015
00016 #include <Auxiliary/Vector.hpp>
00017
00021 template <class T1, class T2>
00022 class Map
00023 {
00024
00025
00026     public:
00027
00029         class Pair
00030         {
00031             public:
00033                 Pair(): First(), Second()  {;}
00035                 Pair(const T1& k ,const T2& v): First(k), Second(v) {;}
00036
00037
00039                 T1 First;
00041                 T2 Second;
00042         };
00043
00044     private:
00045         typedef Vector<Pair> VectorType;
00046         VectorType  m_vec;
00047
00048
00049     public:
00051         Map(){};
00052
00053
00055         void Add(const T1& key, const T2& val) {  InsertSorted(Pair(key,val));}
00057         const T2& operator[](const T1& key) const { return (*BinSearch(key)).Second;}
00059         T2& operator[](const T1& key) { return (*FindElem(key)).Second;}
00060
00061
00063         INT GetSize() const { return m_vec.GetSize(); }
00064
00065
00067         typedef typename Vector<Pair>::Iterator Iterator;
00069         typedef typename Vector<Pair>::Iterator ConstIterator;
00070
00072         ConstIterator Begin() const  { return m_vec.Begin();}
00074         ConstIterator End() const  { return m_vec.End();}
00075
00077         ConstIterator RBegin() const  { return m_vec.RBegin();}
00079         ConstIterator REnd() const  { return m_vec.REnd();}
00080
00082         void Erase(const ConstIterator &elem) { m_vec.Erase(elem); }
00084         void Erase(const ConstIterator &first, const ConstIterator &last) { m_vec.Erase(first,last);}
00085
00087         ConstIterator Find(const T1& key) const { return BinSearch(key); }
00088
00089
00090
00091     private:
00092
00093
00094         Iterator FindElem(const T1& key);
00095
00096         void InsertSorted(const Pair& pair);
00097
00098         ConstIterator  BinSearch(const T1& key) const;
00099 };
00100
00101 template<class T1, class T2>
00102 typename Map<T1,T2>::Iterator Map<T1,T2>::FindElem(const T1& key)
00103 {
00104     Iterator it= BinSearch(key);
00105     if (it==m_vec.End()) {
00106         InsertSorted(Pair(key,T2()));
00107         return BinSearch(key);
00108     }
00109     return it;
00110 }
00111
00112 template<class T1, class T2>
00113 void Map<T1,T2>::InsertSorted(const Pair& pair)
00114 {
00115     Iterator it= m_vec.Begin();
00116     for(;(it<m_vec.End()) && pair.First > (*it).First ;it++);
00117     if(it==m_vec.End()) {
00118         m_vec.PushBack(pair);
00119         return;
00120     }
00121     if(pair.First==(*it).First)
00122         *it= pair;
00123     else
00124         m_vec.Insert(it,pair);
00125 }
00126
00127 template<class T1, class T2>
00128 typename Map<T1,T2>::ConstIterator Map<T1,T2>::BinSearch(const T1& key) const
00129 {
00130
00131     if(m_vec.GetSize() <= 0)
00132         return m_vec.End();
00133
00134
00135     INT low = 0;
00136     INT high = m_vec.GetSize()-1;
00137     INT middle;
00138
00139
00140     while( low <= high )
00141     {
00142         middle = ( low  + high ) / 2;
00143         ConstIterator elem= m_vec.Begin() + middle;
00144         if( key == (*elem).First) {
00145             return elem;
00146         }
00147         if(key < (*elem).First)
00148             high = middle-1;
00149         else
00150             low = middle+1;
00151
00152     }
00153     return m_vec.End();
00154 }
00155
00157 #endif // DOXYGEN_SHOULD_SKIP_THIS
00158 #endif  // Auxiliary_Map_hpp
00159
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MemPool.cpp File Reference

Auxiliary/MemPool.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "MemPool.hpp"

Include dependency graph for MemPool.cpp:

Defines

#define Apoxi_MemPool_tpl

Define Documentation

#define Apoxi_MemPool_tpl

Generated on Tue Jan 24 19:06:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MemPool.hpp File Reference

Auxiliary/MemPool.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/BitVector.hpp>

Include dependency graph for MemPool.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MemPool
class | MemPoolEntry

Defines

#define | Apoxi_MemPool_hpp

Define Documentation

#define Apoxi_MemPool_hpp

Generated on Tue Jan 24 19:06:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MemPool.hpp Source File

Auxiliary/MemPool.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MemPool_hpp)
00010 #define Apoxi_MemPool_hpp
00013
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/BitVector.hpp>
00016
00017 class MemPoolEntry : public Linkable<class MemPoolEntry> {
00018     public:
00019         MemPoolEntry();
00020
00021         void* Alloc(INT size);
00022         void Release(void *p,INT size);
00023
00024         inline BOOLEAN Contains(void *data) const {
00025             INT *p = (INT *) data;
00026             return(p >= m_data && p < (m_data + AtomCount));
00027         }
00028
00029     private:
00030         enum {
00031             BytesPerUnit = 8,
00032             UnitCount = 128,
00033
00034             MemSize = BytesPerUnit * UnitCount,
00035             BytesPerAtom = sizeof(INT),
00036             AtomCount = MemSize / BytesPerAtom,
00037             AtomsPerUnit = BytesPerUnit / BytesPerAtom
00038         };
00039
00040         BitVector<UnitCount> m_bitmap;
00041         INT m_data[AtomCount];
00042
00043         INT SizeToUnits(INT size) const;
00044         void* UnitIdxToAddr(INT blockidx);
00045         INT AddrToUnitIdx(void *addr) const;
00046 };
00047
00048 class MemPool {
00049     public:
00050         MemPool();
00051         virtual ~MemPool();
00052
00053         void* Alloc(INT size);
00054         void Release(void *data,INT size);
00055
00056     private:
00057         MemPoolEntry m_mpe;
00058
00059         // prevent cloning of a MemPool
00060         MemPool(const MemPool& mem_pool);
00061
00062         // prevent cloning of a Dispatcher
00063         MemPool& operator=(const MemPool& mem_pool);
00064 };
00065
00067 #endif  // Apoxi_MemPool_hpp
00068
00069
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MessageFactory.cpp File Reference

Auxiliary/MessageFactory.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "MessageFactory.hpp"
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for MessageFactory.cpp:

Generated on Tue Jan 24 19:06:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MessageFactory.hpp File Reference

Auxiliary/MessageFactory.hpp File Reference

#include <Kernel/MsgTypes.hpp>

Include dependency graph for MessageFactory.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Auxiliary_MessageFactory_hpp

Define Documentation

#define Auxiliary_MessageFactory_hpp

Generated on Tue Jan 24 19:06:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MessageFactory.hpp Source File

Auxiliary/MessageFactory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if ! defined(Auxiliary_MessageFactory_hpp)
00010 #define Auxiliary_MessageFactory_hpp
00013
00014 #include <Kernel/MsgTypes.hpp>
00015
00016 /*  ------------------------------------------------------------
00017                              Classes
00018     --------------------------------------------------------------*/
00019
00020 /*  ------------------------------------------------------------
00021         Class MessageFactory
00022     --------------------------------------------------------------*/
00023
00025 #endif // Auxiliary_MessageFactory_hpp
00026
00027
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MimeTypeTable.cpp File Reference

Auxiliary/MimeTypeTable.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include <string.h>
#include "MimeTypeTableUtils.hpp"
#include "MimeTypeTable.hpp"

Include dependency graph for MimeTypeTable.cpp:

Functions

APOXI_ADD_MIME_TYPE_DEFS (MimeTypeTable, s_apoxi_types)
APOXI_END_MIME_TYPE_DEFS (MimeTypeTable, s_apoxi_types)

Function Documentation

APOXI_ADD_MIME_TYPE_DEFS | ( | MimeTypeTable | ,
 |  | s_apoxi_types |
 | ) |

APOXI_END_MIME_TYPE_DEFS | ( | MimeTypeTable | ,
 |  | s_apoxi_types |
 | ) |

Generated on Tue Jan 24 19:06:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MimeTypeTable.hpp File Reference

Auxiliary/MimeTypeTable.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for MimeTypeTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MimeTypeTable
User-extendable MIME type registry. More...
class | MimeTypeTable::Partition
Represents a partition of the APOXI MimeTypeTable. More...
struct | MimeTypeTableEntry
MIME type description record. More...

Defines

#define | MimeTypeTable_hpp

Typedefs

typedef INT | MimeType
Defines the type of MIME type identifiers.

Enumerations

enum ApoxiMimeTypeId {
c_mime_unknown, c_mime_app_j2me_archieve, c_mime_app_j2me_jrs, c_mime_app_mmf,
c_mime_audio_amr, c_mime_audio_imelody, c_mime_audio_midi, c_mime_audio_mpeg,
c_mime_audio_wav, c_mime_drm_ro, c_mime_drm_message, c_mime_drm_textual,
c_mime_drm_encoded, c_mime_drm_content, c_mime_image_bmp, c_mime_image_ems,
c_mime_image_gif, c_mime_image_jpeg, c_mime_image_png, c_mime_image_tiff,
c_mime_image_wbmp, c_mime_text_calendar, c_mime_text_html, c_mime_text_j2me_appdesc,
c_mime_text_plain, c_mime_text_vcard, c_mime_text_wml, c_mime_text_wmlscript,
c_mime_text_xhtml, c_mime_text_xml, c_mime_video_mpeg, c_mime_video_msvideo,
c_mime_video_quicktime, c_mime_video_3gpp, c_mime_audio_3gpp, c_mime_image_svg,
c_mime_image_svgz, c_mime_app_spf, c_mime_apoxi_settings, c_mime_audio_aac,
c_mime_audio_m4a, c_mime_audio_mobile_xmf, c_mime_app_sdp, c_mime_user_offset
}

Define Documentation

#define MimeTypeTable_hpp

Generated on Tue Jan 24 14:55:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MimeTypeTable.hpp Source File

Auxiliary/MimeTypeTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(MimeTypeTable_hpp)
00010 #define MimeTypeTable_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/Macros.hpp>
00016
00017 #if defined(APOXI_COMPAT_1_13_0)
00018     #include <Afs/Ffs/FfsTypes.hpp>
00019 #endif
00020
00028 typedef INT MimeType;
00029
00030
00043 enum ApoxiMimeTypeId {
00045     c_mime_unknown,
00046     c_mime_app_j2me_archieve,
00047     c_mime_app_j2me_jrs,
00048     c_mime_app_mmf,
00049     c_mime_audio_amr,
00050     c_mime_audio_imelody,
00051     c_mime_audio_midi,
00052     c_mime_audio_mpeg,
00053     c_mime_audio_wav,
00054     c_mime_drm_ro,
00055     c_mime_drm_message,
00056     c_mime_drm_textual,
00057     c_mime_drm_encoded,
00058     c_mime_drm_content,
00059     c_mime_image_bmp,
00060     c_mime_image_ems,
00061     c_mime_image_gif,
00062     c_mime_image_jpeg,
00063     c_mime_image_png,
00064     c_mime_image_tiff,
00065     c_mime_image_wbmp,
00066     c_mime_text_calendar,
00067     c_mime_text_html,
00068     c_mime_text_j2me_appdesc,
00069     c_mime_text_plain,
00070     c_mime_text_vcard,
00071     c_mime_text_wml,
00072     c_mime_text_wmlscript,
00073     c_mime_text_xhtml,
00074     c_mime_text_xml,
00075     c_mime_video_mpeg,
00076     c_mime_video_msvideo,
00077     c_mime_video_quicktime,
00078     c_mime_video_3gpp,
00079     c_mime_audio_3gpp,
00080     c_mime_image_svg,
00081     c_mime_image_svgz,
00082     c_mime_app_spf,
00083     c_mime_apoxi_settings,
00084     c_mime_audio_aac,
00085     c_mime_audio_m4a,
00086     c_mime_audio_mobile_xmf,
00087     c_mime_app_sdp,
00088     //  Please add new APOXI mime type constants just above this line !
00089
00091     c_mime_user_offset
00092 };
00093
00094 #if defined(APOXI_COMPAT_1_13_0)
00095     typedef const CHAR* FileExtension;
00096     typedef const CHAR* MimeStr;
00097 #endif
00098
00104 struct MimeTypeTableEntry {
00105
00107     MimeType        mime_type;
00108
00110     BOOLEAN         is_binary;
00111
00113     const CHAR *    mime_str;
00114
00122     const CHAR *    file_ext_substr_list;
00123 };
00124
00138 class MimeTypeTable {
00139
00140     public:
00150         class Partition {
00151
00152             friend class MimeTypeTable;
00153
00154             public:
00156                 Partition(const MimeTypeTableEntry  table[], UINT  no_entries);
00157
00158                 MimeType GetMinMimeTypeId() const;
00159                 MimeType GetMaxMimeTypeId() const;
00160
00161             private:
00162                 const UINT                  m_no_entries;
00163                 const MimeTypeTableEntry *  m_table;
00164                 Partition *                 m_next_ptr;
00165
00167                 Partition(const Partition &);
00168
00170                 Partition&  operator=(const Partition &);
00171
00172                 static BOOLEAN ListContainsString(const CHAR* str_list,
00173                                                   const CHAR* key_str,
00174                                                   UINT8& key_pos);
00175                 const MimeTypeTableEntry *   Begin() const { return &(m_table[0]); }
00176                 const MimeTypeTableEntry *   End() const { return &(m_table[m_no_entries]); }
00177                 const MimeTypeTableEntry &   At(UINT  index) const {
00178                     ASSERT_DEBUG(index < m_no_entries);
00179                     return  m_table[index];
00180                 }
00181                 BOOLEAN HasNext() const { return m_next_ptr != 0; }
00182                 const Partition* GetNext() const { return  m_next_ptr; }
00183                 Partition* GetNext() { return  m_next_ptr; }
00184                 void SetNext(Partition* next_ptr) { m_next_ptr = next_ptr; }
00185                 const MimeTypeTableEntry &  FindByMimeTypeId(MimeType id) const;
00186                 const MimeTypeTableEntry &  FindByMimeString(const CHAR* mime_str) const;
00187                 const MimeTypeTableEntry &  FindByExtension(const CHAR* file_ext, UINT8 &idx) const;
00188         };
00189
00190         friend class Partition;
00191
00201         static MimeType GetMimeTypeByExt(const CHAR* file_ext, UINT8& idx);
00202
00210         static MimeType GetMimeTypeByExt(const CHAR* file_ext);
00211
00218         static MimeType GetMimeTypeByMimeStr(const CHAR* mime_str);
00219
00227         static const CHAR* GetMimeStrByExt(const CHAR* file_ext);
00228
00236         static const CHAR* GetMimeStrByMimeType(MimeType mime_type);
00237
00243         static const CHAR* GetExtByMimeType(MimeType mime_type, UINT8 offset = 0);
00244
00248         static  const CHAR* GetExtByMimeStr(const CHAR* mime_str);
00249
00260         static const CHAR* GetFirstExtByMimeType(MimeType mime_type);
00261
00272         static const CHAR* GetFirstExtByMimeStr(const CHAR* mime_str);
00273
00275         static  MimeType GetMaxMimeTypeId();
00276
00287         static const CHAR* GetNextExtension(const CHAR* file_ext);
00288
00294         static INT IsTextByMimeStr(const CHAR* mime_str);
00295
00301         static INT IsTextByExt(const CHAR* file_ext);
00302
00309         static INT IsBinaryByMimeStr(const CHAR*  mime_str);
00310
00317         static INT IsBinaryByExt(const CHAR* file_ext);
00318
00319 #if defined(APOXI_COMPAT_1_13_0)
00320
00321         static  MimeType    GetMimeTypeByFileType(FfsFileType file_type);
00322
00324         static  const CHAR* GetMimeStrByFileType(FfsFileType file_type);
00325
00327         static  FfsFileType GetFileTypeByExt(const CHAR *extension);
00328
00330         static  FfsFileType GetFileTypeByMimeType(MimeType mime_type);
00331
00333         static  FfsFileType GetFileTypeByMimeStr(const CHAR *mime_str);
00334
00336         static  const CHAR* GetExtByFileType(FfsFileType file_type);
00337
00339         static  INT         IsTextByFileType(FfsFileType file_type);
00340
00342         static  INT         IsBinaryByFileType(FfsFileType file_type);
00343
00344 #endif
00345
00346     private:
00348         static const MimeTypeTableEntry     s_apoxi_types[];
00349         static MimeTypeTable::Partition     s_apoxi_types_part;
00350
00351         static const CHAR *                 c_no_file_extension;
00352         static Partition *                  s_root_part_ptr;
00353
00355         MimeTypeTable();
00356
00358         MimeTypeTable(const MimeTypeTable&);
00359
00361         ~MimeTypeTable();
00362
00364         MimeTypeTable& operator=(const MimeTypeTable&);
00365
00366         static const MimeTypeTableEntry &  GetUnknownMimeTypeInfo() { return  s_apoxi_types[c_mime_unknown]; }
00367         static  const CHAR* GetNextStringInList(const CHAR* str_list);
00368 };
00369
00371 #endif  // MimeTypeTable_hpp
00372
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MimeTypeTableUtils.hpp File Reference

Auxiliary/MimeTypeTableUtils.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for MimeTypeTableUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_ADD_MIME_TYPE_DEFS(class_name, tab_name) const MimeTypeTableEntry class_name##::##tab_name[] =
Adds a MIME type definition record to a MIME type extension table.
#define | APOXI_COUNTOF(array) ( sizeof(array) / sizeof(array[0]) )
Compute number of array elements.
#define | APOXI_DCL_MIME_TYPE_DEFS(tab_name)
Declares a mime type extension.
#define | APOXI_DEF_MIME_TYPE(mime_type, mime_str, is_binary, file_ext_substr_list) { mime_type, is_binary, mime_str, file_ext_substr_list }
#define | APOXI_END_MIME_TYPE_DEFS(class_name, tab_name)
#define | APOXI_MIME_EXT(fileext) fileext "\0"
Constructs a file extension list element from a given string.
#define | APOXI_MIME_STR(mimestr) mimestr "\0"
Constructs a MIME string list element from a given string.
#define | MimeTypeTableUtils_hpp

Define Documentation

#define MimeTypeTableUtils_hpp

Generated on Tue Jan 24 19:06:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/MimeTypeTableUtils.hpp Source File

Auxiliary/MimeTypeTableUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(MimeTypeTableUtils_hpp)
00010 #define MimeTypeTableUtils_hpp
00011
00012 #include <Auxiliary/MimeTypeTable.hpp>
00013
00016
00034 #define APOXI_DCL_MIME_TYPE_DEFS(tab_name) \
00035     static const MimeTypeTableEntry     tab_name[]; \
00036     static MimeTypeTable::Partition     tab_name##_part
00037
00043 #define APOXI_MIME_EXT(fileext) fileext "\0"
00044
00050 #define APOXI_MIME_STR(mimestr) mimestr "\0"
00051
00053 #define APOXI_COUNTOF(array) ( sizeof(array) / sizeof(array[0]) )
00054
00062 #define APOXI_ADD_MIME_TYPE_DEFS(class_name, tab_name) \
00063     const MimeTypeTableEntry    class_name##::##tab_name[] =
00064
00065 #define APOXI_END_MIME_TYPE_DEFS(class_name, tab_name) \
00066     ; \
00067     MimeTypeTable::Partition \
00068         class_name##::##tab_name##_part( class_name##::##tab_name, \
00069                                          APOXI_COUNTOF(class_name##::##tab_name) );
00070
00071 #define APOXI_DEF_MIME_TYPE(mime_type, mime_str, is_binary, file_ext_substr_list) \
00072     { mime_type, is_binary, mime_str, file_ext_substr_list }
00073
00075 #endif  // MimeTypeTableUtils_hpp
00076
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/NiSharedPtr.hpp File Reference

Auxiliary/NiSharedPtr.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for NiSharedPtr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NiSharedPtr< X >
struct | NiSharedPtr< X >::ItemRef

Defines

#define | Apoxi_NiSharedPtr_hpp
#define | NO_MEMBER_TEMPLATES

Functions

template<typename X, typename Y>
BOOLEAN | operator!= (const NiSharedPtr< X > &lhs, const NiSharedPtr< Y > &rhs)
template<typename X, typename Y>
BOOLEAN | operator== (const NiSharedPtr< X > &lhs, const NiSharedPtr< Y > &rhs)

Define Documentation

#define Apoxi_NiSharedPtr_hpp

#define NO_MEMBER_TEMPLATES

Since some ANSI-challenged target compilers do not all support member templates (we would need the templated copy constructor and templated assignment operator) we have to turn off the usage of member templates. This robs the possibility to cast an instance of the smart-pointer to a related instance of another smart-pointer.

Function Documentation

template<typename X, typename Y>
BOOLEAN operator!= | ( | const NiSharedPtr< X > & | lhs,
 |  | const NiSharedPtr< Y > & | rhs
 | ) |

Inequality operator for smart pointers of template class NiSharedPtr<>. Returns whether lhs and rhs point to different objects.

template<typename X, typename Y>
BOOLEAN operator== | ( | const NiSharedPtr< X > & | lhs,
 |  | const NiSharedPtr< Y > & | rhs
 | ) |

Equality operator for smart pointers of template class NiSharedPtr<>. Returns whether lhs and rhs point to the same object.

Generated on Tue Jan 24 19:06:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/NiSharedPtr.hpp Source File

Auxiliary/NiSharedPtr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_NiSharedPtr_hpp)
00011 #define Apoxi_NiSharedPtr_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/Macros.hpp>
00015
00021 #define NO_MEMBER_TEMPLATES
00022
00038 template <typename X>
00039 class NiSharedPtr
00040 {
00041 public:
00043     explicit NiSharedPtr(X* p = 0) // Allocate a new item reference.
00044         : m_itemRef(0) { if (p) m_itemRef = new ItemRef(p); }
00045
00047     ~NiSharedPtr();
00048
00050     NiSharedPtr(const NiSharedPtr &r)
00051         { Acquire(r.m_itemRef); }
00052
00054     NiSharedPtr& operator=(const NiSharedPtr &r);
00055
00056 #ifndef NO_MEMBER_TEMPLATES
00057     template <typename Y> friend class NiSharedPtr;
00058     template <typename Y> NiSharedPtr(const NiSharedPtr<Y>& r)
00059         { Acquire(r.m_itemRef); }
00060     template <typename Y> NiSharedPtr<X>& operator=(const NiSharedPtr<Y> &r);
00061 #endif // NO_MEMBER_TEMPLATES
00062
00070     X& operator*() const
00071     {
00072         ASSERT_DEBUG_HOST(m_itemRef && m_itemRef->m_ptr);
00073         return *m_itemRef->m_ptr;
00074     }
00075
00083     X* operator->() const
00084     {
00085         ASSERT_DEBUG_HOST(m_itemRef && m_itemRef->m_ptr);
00086         return m_itemRef->m_ptr;
00087     }
00088
00090     X* Get() const { return m_itemRef ? m_itemRef->m_ptr : 0; }
00091
00093     BOOLEAN IsValid() const { return Get() != 0; }
00094
00096     BOOLEAN Unique() const
00097         { return (m_itemRef ? m_itemRef->m_count == 1 : FALSE); }
00098
00101     void Release()
00102     {   // Decrement the counter and delete the reference counted object if the
00103         // counter is 0.
00104         if (m_itemRef) {
00105             if (--m_itemRef->m_count == 0) {
00106                 delete m_itemRef->m_ptr;
00107                 delete m_itemRef;
00108             }
00109             m_itemRef = 0;
00110         }
00111     }
00112
00113 private:
00116     struct ItemRef {
00117         ItemRef(X *p = 0, UINT c = 1) : m_ptr(p), m_count(c) {}
00118         X *m_ptr;
00119         UINT m_count;
00120     } *m_itemRef;
00121
00123     void Acquire(ItemRef *itemRef)
00124     {   // Increment the counter.
00125         m_itemRef = itemRef;
00126         if (itemRef) ++itemRef->m_count;
00127     }
00128 };
00129
00130 template <typename X>
00131 NiSharedPtr<X>::~NiSharedPtr()
00132 {
00133     Release();
00134 }
00135
00136 template <typename X>
00137 NiSharedPtr<X>& NiSharedPtr<X>::operator=(const NiSharedPtr<X> &r)
00138 {
00139     if (this != &r) {
00140         Release();
00141         Acquire(r.m_itemRef);
00142     }
00143     return *this;
00144 }
00145
00146 #ifndef NO_MEMBER_TEMPLATES
00147
00148 template <typename X>
00149 template <typename Y>
00150 NiSharedPtr<X>& NiSharedPtr<X>::operator=(const NiSharedPtr<Y> &r)
00151 {
00152     if (this != &r) {
00153         Release();
00154         Acquire(r.m_itemRef);
00155     }
00156     return *this;
00157 }
00158
00159 #endif // NO_MEMBER_TEMPLATES
00160
00164 template<typename X, typename Y>
00165 BOOLEAN operator==(const NiSharedPtr<X> &lhs, const NiSharedPtr<Y> &rhs)
00166 {
00167     return lhs.Get() == rhs.Get();
00168 }
00169
00173 template<typename X, typename Y>
00174 BOOLEAN operator!=(const NiSharedPtr<X> &lhs, const NiSharedPtr<Y> &rhs)
00175 {
00176     return lhs.Get() != rhs.Get();
00177 }
00178
00179 #endif  // Apoxi_NiSharedPtr_hpp
00180
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/NonCloneable.cpp File Reference

Auxiliary/NonCloneable.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "NonCloneable.hpp"

Include dependency graph for NonCloneable.cpp:

Generated on Tue Jan 24 19:06:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/NonCloneable.hpp File Reference

Auxiliary/NonCloneable.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NonCloneable

Defines

#define | Apoxi_NonCloneable_hpp

Define Documentation

#define Apoxi_NonCloneable_hpp

Generated on Tue Jan 24 19:13:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/NonCloneable.hpp Source File

Auxiliary/NonCloneable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_NonCloneable_hpp)
00011 #define Apoxi_NonCloneable_hpp
00014
00015
00016 class NonCloneable {
00017     public:
00018         NonCloneable();
00019
00020         //We need to add a virtual destructor,
00021         //otherwise the default destructor would be non-default,
00022         //and the derived-classes could not have any virtual methods.
00023         virtual ~NonCloneable();
00024
00025     private:
00026         //Make this, and derived classes, non-copyable:
00027         NonCloneable(const NonCloneable &);
00028         NonCloneable& operator=(const NonCloneable &);
00029 };
00030
00031
00033 #endif  // Apoxi_NonCloneable_hpp
00034
00035
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ObjectObtainer.cpp File Reference

Auxiliary/ObjectObtainer.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ObjectObtainer.hpp"
#include <Kernel/Os/MutexObtainer.hpp>
#include "Macros.hpp"

Include dependency graph for ObjectObtainer.cpp:

Generated on Tue Jan 24 19:13:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ObjectObtainer.hpp File Reference

Auxiliary/ObjectObtainer.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Mutex.hpp>

Include dependency graph for ObjectObtainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObjectObtainer
class | ObtainableObject
Base class for objects, that can be controled by an ObjectObtainer. More...

Defines

#define | AddOns_AuxExtensions_ObjectObtainer_hpp

Define Documentation

#define AddOns_AuxExtensions_ObjectObtainer_hpp

Generated on Tue Jan 24 19:14:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ObjectObtainer.hpp Source File

Auxiliary/ObjectObtainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(AddOns_AuxExtensions_ObjectObtainer_hpp)
00011 #define AddOns_AuxExtensions_ObjectObtainer_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/Os/Mutex.hpp>
00017
00019 class ObtainableObject {
00020     public:
00021         ObtainableObject();
00022         virtual ~ObtainableObject();
00023         INT GetObtainedCount();
00024
00025     private:
00026         INT m_obtain_count;
00027         Mutex m_mutex;
00028
00029         friend class ObjectObtainer;
00030         void AddObtainCount(INT cnt);
00031 };
00032
00038 class ObjectObtainer {
00039     public:
00040         ObjectObtainer();
00041
00047         ObjectObtainer(ObtainableObject *object, BOOLEAN disposable, UINT8 object_hint = 0);
00048
00049         ObjectObtainer(const ObjectObtainer& obtainer);
00050
00051         virtual ~ObjectObtainer();
00052
00053         ObjectObtainer& operator=(const ObjectObtainer& obtainer);
00054
00055         ObtainableObject* GetObject() { return m_object; }
00056
00057         const ObtainableObject* GetObject() const { return m_object; }
00058
00062         UINT GetObjectHint() const { return m_object_hint; }
00063
00064     private:
00065         BOOLEAN m_disposable;
00066         UINT8 m_object_hint;
00067         ObtainableObject* m_object;
00068
00069         void Clear();
00070 };
00071
00073 #endif // AddOns_AuxExtensions_ObjectObtainer_hpp
00074
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ObjectReferrer.hpp File Reference

Auxiliary/ObjectReferrer.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for ObjectReferrer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ReferableObject

Defines

#define | Apoxi_ObjectReferrer_hpp
#define | DefObjectReferrer(Name, RefClass)
#define | DefThreadSafeReferableObject(Name, SemClass)

Define Documentation

#define Apoxi_ObjectReferrer_hpp

Generated on Tue Jan 24 19:15:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ObjectReferrer.hpp Source File

Auxiliary/ObjectReferrer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ObjectReferrer_hpp)
00010 #define Apoxi_ObjectReferrer_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Kernel/Os/SemObtainer.hpp>
00017 #include <Auxiliary/Macros.hpp>
00018
00020 class ReferableObject {
00021     public:
00023         ReferableObject(INT refcount = 0) : m_refcount(refcount) {
00024             DBG_OUT((10000, L"create referable object (%p)!", this));
00025         }
00026
00028         virtual ~ReferableObject() { ASSERT_DEBUG(m_refcount == 0); }
00029
00031         virtual INT RefCount() const { return m_refcount; }
00032
00034         virtual void AddRef() const {
00035             m_refcount++;
00036             DBG_OUT((10001, L"add reference to object(%p)! ref_count = %d", this, m_refcount));
00037         }
00038
00040         virtual void Release() const {
00041             ASSERT_DEBUG(m_refcount > 0);
00042
00043             m_refcount--;
00044             DBG_OUT((10002, L"release reference to object(%p)! ref_count = %d", this, m_refcount));
00045
00046             if (m_refcount == 0)
00047                 OnZeroReferrers();
00048         }
00049
00050     protected:
00052         virtual void OnZeroReferrers() const {
00053             ASSERT_DEBUG(m_refcount == 0);
00054             DBG_OUT((10003, L"Delete ReferableObject (%p)", this));
00055
00056             delete this;
00057         }
00058
00059     private:
00060
00061         //This must be mutable so that AddRef and Release can be const.
00062         //AddRef and Release must be const so that const objects can be refcounted.
00063         mutable INT m_refcount;
00064
00066         ReferableObject(const ReferableObject& obj);
00067
00069         ReferableObject& operator=(const ReferableObject& obj);
00070
00071 };
00072
00073 /*  template<class T> class ThreadSafeReferableObject : public ReferableObject {
00074     no templates with virtual functions for target compiler */
00075 #define DefThreadSafeReferableObject(Name, SemClass)        \
00076     class Name : public ReferableObject {       \
00077         public:                                             \
00078             typedef ReferableObject Base;       \
00079                                                             \
00080             Name(INT refcount = 0) : Base(refcount) {       \
00081             }                                           \
00082                                                             \
00083             virtual INT RefCount() const {                  \
00084                 SemObtainer semob(&SemClass::m_sem);    \
00085                 return Base::RefCount();                    \
00086             }                                           \
00087                                                             \
00088             virtual void AddRef() const {                           \
00089                 SemObtainer semob(&SemClass::m_sem);    \
00090                 Base::AddRef();                             \
00091             }                                           \
00092                                                             \
00093             virtual void Release() const {                      \
00094                 SemObtainer semob(&SemClass::m_sem);    \
00095                 Base::Release();                            \
00096             }                                           \
00097     }
00098
00099
00100 /*  template<class T> class ObjectReferrer {
00101     no templates with virtual functions for target compiler */
00102 #define DefObjectReferrer(Name, RefClass)                   \
00103     class Name {                                            \
00104         public:                                             \
00105             Name(RefClass *ref = 0) : m_ref(0) {            \
00106                 SetReference(ref);                          \
00107             }                                           \
00108                                                             \
00109             Name(const Name &or) : m_ref(or.m_ref) {        \
00110                 if (m_ref != 0)                             \
00111                     m_ref->AddRef();                        \
00112             }                                           \
00113                                                             \
00114             virtual ~Name() {                               \
00115                 if (m_ref != 0)                             \
00116                     m_ref->Release();                       \
00117             }                                           \
00118                                                             \
00119             RefClass* GetReference() const {                \
00120                 return(m_ref);                              \
00121             }                                           \
00122                                                             \
00123             void SetReference(RefClass *ref = 0) {  \
00124                 if (m_ref != 0)                             \
00125                     m_ref->Release();                       \
00126                                                             \
00127                 m_ref = ref;                                \
00128                                                             \
00129                 if (m_ref != 0)                             \
00130                     m_ref->AddRef();                        \
00131             }                                           \
00132                                                             \
00133             virtual Name& operator=(const Name &or) {       \
00134                 SetReference(or.m_ref);                     \
00135                 return(*this);                              \
00136             }                                           \
00137                                                             \
00138             RefClass* operator->() const {                  \
00139                 return(m_ref);                              \
00140             }                                           \
00141                                                             \
00142         private:                                            \
00143             RefClass *m_ref;                                \
00144     }
00145
00147 #endif  // Apoxi_ObjectReferrer_hpp
00148
00149
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ObservableObject.cpp File Reference

Auxiliary/ObservableObject.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ObservableObject.hpp"
#include "Observer.hpp"
#include "Macros.hpp"

Include dependency graph for ObservableObject.cpp:

Generated on Tue Jan 24 19:15:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ObservableObject.hpp File Reference

Auxiliary/ObservableObject.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ObservableObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObservableObject

Defines

#define | Apoxi_ObservableObject_hpp

Define Documentation

#define Apoxi_ObservableObject_hpp

Generated on Tue Jan 24 19:16:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ObservableObject.hpp Source File

Auxiliary/ObservableObject.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObservableObject_hpp)
00011 #define Apoxi_ObservableObject_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017 class Observer;
00018
00031 class ObservableObject {
00032     public:
00034         typedef Observer* ObserverPtr;
00035
00037         ObservableObject();
00038
00040         ~ObservableObject();
00041
00045         void Attach(Observer *observer);
00046
00048         void Detach(Observer *observer);
00049
00051         BOOLEAN IsAttached(Observer *observer) const;
00052
00056         void NotifyObservers();
00057
00058     private:
00059 #ifndef APOXI_COMPAT_2_0_0
00060
00061         ObservableObject(const ObservableObject& observable_object);
00062
00064         ObservableObject& operator=(const ObservableObject& observable_object);
00065 #endif
00066
00067         INT m_observer_count;
00068         union {
00069             ObserverPtr instance;
00070             ObserverPtr *vector;
00071         } m_observer;
00072 };
00073
00075 #endif  // Apoxi_ObservableObject_hpp
00076
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Observer.cpp File Reference

Auxiliary/Observer.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Observer.hpp"
#include "Macros.hpp"
#include <Kernel/Types.hpp>

Include dependency graph for Observer.cpp:

Generated on Tue Jan 24 19:16:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Observer.hpp File Reference

Auxiliary/Observer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Observer

Defines

#define | Apoxi_Observer_hpp

Define Documentation

#define Apoxi_Observer_hpp

Generated on Tue Jan 24 19:16:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Observer.hpp Source File

Auxiliary/Observer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_Observer_hpp)
00012 #define Apoxi_Observer_hpp
00015
00016 class ObservableObject;
00017
00026 class Observer {
00027     public:
00029         Observer();
00030
00032         virtual ~Observer();
00033
00034     protected:
00039         virtual void OnUpdate(ObservableObject *obs_obj);
00040 #ifndef APOXI_COMPAT_2_0_0
00041     private:
00043         Observer(const Observer& observer);
00044
00046         Observer& operator=(const Observer& observer);
00047 #endif
00048     friend class ObservableObject;
00049 };
00050
00052 #endif  // Apoxi_Observer_hpp
00053
00054
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/PhoneNumber.cpp File Reference

Auxiliary/PhoneNumber.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "DataCoding.hpp"
#include "PhoneNumber.hpp"

Include dependency graph for PhoneNumber.cpp:

Defines

#define | PHONE_NUMBER_RESET

Functions

BOOLEAN | cmpbcdbuffer (UINT8 *dest, const UINT8 *source, INT no)
void | copybcdbuffer (UINT8 *dest, const UINT8 *source, INT no)
INT | FindSSString (const WCHAR *string)
INT | getrawbcdlength (PhoneNumber::Type type, const UINT8 *buffer)
void | PhoneNumberAssignmentTest ()
void | PhoneNumberConstructorTest ()
void | PhoneNumberPersistentTest ()
void | PhoneNumberTest ()

Define Documentation

#define PHONE_NUMBER_RESET

Value:

m_bcd_number[0] = 0;                                \
    m_bcd_number[1] = 0xFF;                             \
    m_type = Invalid;

Function Documentation

BOOLEAN cmpbcdbuffer | ( | UINT8 * | dest,
 |  | const UINT8 * | source,
 |  | INT | no
 | ) | [inline]

void copybcdbuffer | ( | UINT8 * | dest,
 |  | const UINT8 * | source,
 |  | INT | no
 | ) | [inline]

INT FindSSString ( const WCHAR * string )

INT getrawbcdlength | ( | PhoneNumber::Type | type,
 |  | const UINT8 * | buffer
 | ) | [inline]

void PhoneNumberAssignmentTest ( )

void PhoneNumberConstructorTest ( )

void PhoneNumberPersistentTest ( )

Generated on Tue Jan 24 19:16:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/PhoneNumber.hpp File Reference

Auxiliary/PhoneNumber.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/TypeOfAddress.hpp>

Include dependency graph for PhoneNumber.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PhoneNumber
PhoneNumber implements bcd coded phone numbers regarding to GSM 04.08. More...
struct | PhoneNumber::Persist

Defines

#define | _Adc_PhoneNumber_hpp
#define | APOXI_PHONENUMBER_TEST_SUITE

Enumerations

enum | BCDConversionNibble { DtmfValue = 0xC, WildcardValue = 0xD, ExpansionValue = 0xE }

Functions

void | PhoneNumberTest ()

Variables

const INT | c_default_depth = 6
const UINT8 | c_invalid_nibble = 0xFF
const INT | c_max_bcd_number_size = 0x18
const UINT8 | c_max_nibble_range = 0x18
const INT | c_max_telnr_size = (c_max_bcd_number_size - 4) * 2

Define Documentation

#define _Adc_PhoneNumber_hpp

Generated on Tue Jan 24 19:17:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/PhoneNumber.hpp Source File

Auxiliary/PhoneNumber.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_PhoneNumber_hpp)
00015 #define _Adc_PhoneNumber_hpp
00018
00019 #include <Kernel/Types.hpp>
00020 #include <Auxiliary/String.hpp>
00021 #include <Auxiliary/WString.hpp>
00022 #include <Auxiliary/TypeOfAddress.hpp>
00023
00024 /*------------------------------------------------------------------
00025                             PhoneNumber
00026  ------------------------------------------------------------------*/
00027
00032 enum BCDConversionNibble { DtmfValue = 0xC , WildcardValue = 0xD, ExpansionValue = 0xE };
00033
00034 const INT   c_max_bcd_number_size = 0x18;
00035 const INT   c_max_telnr_size =      (c_max_bcd_number_size - 4) * 2;
00036 const UINT8  c_invalid_nibble =      0xFF;
00037 const UINT8  c_max_nibble_range =    0x18;
00038
00039 #if ! defined(APOXI_PHONENUMBER_MATCH_DEFAULT_DEPTH)
00040     const INT c_default_depth = 6;
00041 #else
00042     const INT c_default_depth = APOXI_PHONENUMBER_MATCH_DEFAULT_DEPTH;
00043 #endif
00044
00045 //typedef UINT16 Key;
00046
00048 class PhoneNumber
00049 {
00050     public:
00051
00052         typedef UINT16 Key;
00053
00055         enum PresentationIndicator
00056         {
00058             PresentationAllowed = 0,
00060             PresentationRestricted = 1,
00062             NumberNotAllowed = 2,
00064             PresentationReserved = 3,
00066             PresentationUndefined = 0xff
00067         };
00068
00070         enum ScreeningIndicator
00071         {
00073             NotScreened = 0,
00075             VerifiedAndPassed = 1,
00077             VerifiedAndFailed = 2,
00079             NetworkProvided = 3,
00081             ScreeningUndefined = 0xff
00082         };
00083
00084
00086         enum Type {
00088                  In,
00090                  Out,
00092                  Tpdu,
00094                  Invalid
00095         };
00096
00097         struct Persist {
00098             UINT8   m_persist[c_max_bcd_number_size + 1];
00099         };
00100
00102         PhoneNumber();
00103
00105         PhoneNumber(const PhoneNumber & number);
00106
00108         PhoneNumber(const PhoneNumber * number);
00109
00111         PhoneNumber(Type type, const UINT8 * rawbcd);
00112
00114         PhoneNumber(UINT8 tonnpi, UINT8 datalen, UINT8 * data);
00115
00118         PhoneNumber(Type type, const WString & telnr);
00119
00122         PhoneNumber(Type type, const WCHAR * telnr);
00123
00125         ~PhoneNumber();
00126
00128         Type GetType() const { return m_type; };
00129
00131         Key GetKey() const { return 0; }
00132
00134         BOOLEAN ChangeType(Type type);
00135
00136
00138         BOOLEAN IsInvalid() const { return (m_type == Invalid); }
00139
00141         BOOLEAN IsEmpty() const { return (m_bcd_number[0] == 0); }
00142
00144         void Clear() { Reset(); }
00145
00147         INT GetNumOfValidDigits() const;
00148
00150         INT GetBCDLength() const;
00151
00153         INT GetRawBCDLength() const {
00154             return (INT)GetBCDLength()+1;
00155         }
00157         static INT GetRawBCDLength(Type type, const UINT8 * buffer);
00158
00160         static BOOLEAN IsStorable(const WCHAR * phnostring);
00161
00163         UINT8 * GetBCD() const { return (UINT8*)&m_bcd_number[1]; };
00164
00166         UINT8 * GetRawBCDBuffer() const { return (UINT8*)&m_bcd_number[0]; };
00167
00169         PresentationIndicator  GetPresentationInd() const;
00170
00172         ScreeningIndicator  GetScreeningInd() const;
00173
00175         BOOLEAN  IsPresentationAllowed() const;
00176
00178         BOOLEAN  HasClirOverrideCategory() const;
00179
00181         TypeOfAddress::TypeOfNumber GetTON() const;
00182
00184         TypeOfAddress::NumberingPlanIdentification GetNPI() const;
00185
00187         UINT8   GetTONNPI() const { return m_bcd_number[1]; }
00188
00190         String  GetString() const;
00191
00193     /*  @param override_presentation_indicator If true, the real phone number is returned although
00194                 the caller has CLIR activated */
00195         WString GetWString() const;
00196
00198         BOOLEAN HasDtmf() const;
00199
00201         PhoneNumber GetNonDtmfPhoneNumber() const;
00202
00204         BOOLEAN     IsMatching(const PhoneNumber & right) const;
00205
00207         BOOLEAN     IsMatching(const PhoneNumber & right, INT depth) const;
00208
00210         INT Compare(const PhoneNumber & right) const;
00211
00213         static INT Compare(const PhoneNumber & ph1, const PhoneNumber & ph2) { return ph1.Compare(ph2); }
00214
00216         PhoneNumber & operator = (const PhoneNumber * value);
00217
00219         PhoneNumber & operator = (const PhoneNumber & value);
00220
00222         BOOLEAN     operator ==(const PhoneNumber & right) const;
00223
00225         BOOLEAN     operator <(const PhoneNumber & right) const;
00226
00228         BOOLEAN     operator >(const PhoneNumber & right) const;
00229
00231         static WCHAR BcdNibbleToWChar(UINT8 value) { return m_bcd_to_wchar[value & 0x0F]; };
00232
00234         static UINT8 WCharToBcdNibble(WCHAR value);
00235
00238         static void SetWCharForBcdCode(BCDConversionNibble nibble, WCHAR character);
00239
00242         static WCHAR GetWCharForBcdCode(UINT8 nibble);
00243
00245         static void SetEmptyNumberText(const WCHAR* text) { m_empty_number_text = text; }
00246
00248         static void SetInvalidNumberText(const WCHAR* text) { m_invalid_number_text = text; }
00249
00251         static void SetRestrictedNumberText(const WCHAR* text) { m_restricted_number_text = text; }
00252
00254         static void SetNumberNotAvailableText(const WCHAR* text) { m_number_not_available_text = text; }
00255
00256         INT TransformToReversedByteBuffer(UINT8 * buffer, INT len) const;
00257         INT TransformToWCharBuffer(WCHAR * buffer, INT len) const;
00259         void operator<<(const PhoneNumber::Persist & phonenumber);
00261         void operator>>(PhoneNumber::Persist & phonenumber) const;
00263         UINT16 GetHashValue() const;
00264
00265     protected:
00266         UINT8   m_bcd_number[c_max_bcd_number_size];
00267         Type    m_type;
00268
00269     private:
00270         BOOLEAN ConvertWStringToBCD(const WString & telnr, INT & digits, UINT8 & tonnpi);
00271
00272         void Reset();
00273
00274         static WCHAR m_bcd_to_wchar[c_max_nibble_range];
00275         static const WCHAR* m_empty_number_text;
00276         static const WCHAR* m_invalid_number_text;
00277         static const WCHAR* m_restricted_number_text;
00278         static const WCHAR* m_number_not_available_text;
00279 };
00280
00281 #if !defined(APOXI_PHONENUMBER_TEST_SUITE) && defined(APOXI_RTOS_WIN32)
00282 #define APOXI_PHONENUMBER_TEST_SUITE
00283 #endif
00284 #if defined(APOXI_PHONENUMBER_TEST_SUITE)
00285     void PhoneNumberTest();
00286 #endif
00287
00288
00289
00291 #endif
00292
00293
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/PreComp.cpp File Reference

Auxiliary/PreComp.cpp File Reference

#include "Auxiliary/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/PreComp.hpp File Reference

Auxiliary/PreComp.hpp File Reference

#include <stdarg.h>
#include <stdio.h>
#include <string.h>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/MachType.hpp>
#include <Gui/LanguageManager.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/PreComp.hpp Source File

Auxiliary/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <stdarg.h> // Variable argument list.
00009 #include <stdio.h>
00010 #include <string.h>
00011 #include <Kernel/Os/MutexObtainer.hpp>
00012 #include <Kernel/MachType.hpp>
00013 #include <Gui/LanguageManager.hpp>
00014
00015
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Protector.cpp File Reference

Auxiliary/Protector.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Protector.hpp"

Include dependency graph for Protector.cpp:

Generated on Tue Jan 24 19:17:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Protector.hpp File Reference

Auxiliary/Protector.hpp File Reference

#include <Kernel/Os/Mutex.hpp>

Include dependency graph for Protector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Protector

Defines

#define | Apoxi_Protector_hpp

Define Documentation

#define Apoxi_Protector_hpp

Generated on Tue Jan 24 19:17:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Protector.hpp Source File

Auxiliary/Protector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Protector_hpp)
00011 #define Apoxi_Protector_hpp
00014
00015 #include <Kernel/Os/Mutex.hpp>
00016
00020 class Protector {
00021     public:
00023         Protector();
00024
00026         virtual ~Protector();
00027
00029         void Init();
00030
00032         BOOLEAN IsInitialized() { return m_initialized; }
00033
00035         virtual BOOLEAN Lock();
00036
00038         virtual BOOLEAN Unlock();
00039
00040     private:
00041         BOOLEAN m_initialized;
00042         Mutex   m_mutex;
00043 };
00044
00046 #endif  // Apoxi_Protector_hpp
00047
00048
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Provider.cpp File Reference

Auxiliary/Provider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Provider.hpp"

Include dependency graph for Provider.cpp:

Generated on Tue Jan 24 19:17:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Provider.hpp File Reference

Auxiliary/Provider.hpp File Reference

#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include <Auxiliary/ObservableObject.hpp>

Include dependency graph for Provider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ColumnInfo
class | Provider
class | Provider::Modification

Defines

#define | _Adc_Provider_hpp

Variables

const INT | c_append_row = -1
const INT | c_invalid_colid = -3
const INT | c_no_row = -2

Define Documentation

#define _Adc_Provider_hpp

Generated on Tue Jan 24 19:17:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Provider.hpp Source File

Auxiliary/Provider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013 #if ! defined(_Adc_Provider_hpp)
00014 #define _Adc_Provider_hpp
00017
00018 #include <Auxiliary/DataItem.hpp>
00019 #include <Auxiliary/ProviderListener.hpp>
00020 #include <Auxiliary/ObservableObject.hpp>
00021
00022 /*------------------------------------------------------------------
00023                             ColumnInfo
00024  ------------------------------------------------------------------*/
00025
00026 struct ColumnInfo {
00027     INT       colid;
00028     DataType  type;
00029 };
00030
00031 /*------------------------------------------------------------------
00032                         Provider constants
00033  ------------------------------------------------------------------*/
00034
00035 const INT  c_append_row         = -1;
00036 const INT  c_no_row             = -2;
00037 const INT  c_invalid_colid      = -3;
00038
00039 // class ProviderListener;
00040
00048 class Provider : public ObservableObject
00049 {
00050     public:
00052         enum Status {
00054             undefined,
00056             updated,
00058             updating,
00060             changed
00061         };
00062
00064         enum ModificationType {
00066             Append,
00068             Insert,
00070             Commit,
00072             Delete,
00074             DeleteAll,
00076             Toggle,
00078             UndefinedModification
00079         };
00080
00081         class Modification {
00082             public:
00083                 Modification(ModificationType type = UndefinedModification, INT row = c_no_row)
00084                     : m_type(type), m_row(row), m_original_row_set(FALSE), m_original_row(c_no_row) {}
00085
00086                 Modification(ModificationType type, INT row, INT original_row)
00087                     : m_type(type), m_row(row), m_original_row_set(TRUE), m_original_row(original_row) {}
00088
00089                 void SetType(ModificationType type) { m_type = type; }
00090
00091                 void SetRow(INT row) { m_row = row; }
00092
00093                 void SetOriginalRow(INT original_row) { m_original_row_set = TRUE; m_original_row = original_row; }
00094
00095                 ModificationType GetType() const { return m_type; }
00096
00097                 INT GetRow() const { return m_row; }
00098
00099                 INT GetOriginalRow() const { return m_original_row_set ? m_original_row : m_row; }
00100
00101         private:
00102                 ModificationType m_type;
00103                 INT m_row;
00104                 BOOLEAN m_original_row_set;
00105                 INT m_original_row;
00106         };
00107
00108     public:
00110         Provider();
00111
00113         virtual ~Provider();
00114
00116         virtual INT GetProviderId() const = 0;
00117
00119         virtual Status GetStatus() const;
00120
00122         virtual INT RowCount() = 0;
00123
00125         virtual INT MaxRowCount();   // to be overwritten if differs
00126
00128         virtual INT ColumnCount() const;
00129
00131         virtual const ColumnInfo * GetColumnInfo(INT column);
00132
00134         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item) = 0;
00135
00137         virtual const WString * GetWString(INT columnid, INT row);
00138
00140         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00141
00143         virtual BOOLEAN SelectRow(INT row);
00144
00146         virtual BOOLEAN CommitRow(INT row);
00147
00149         virtual BOOLEAN DeleteRow(INT row);
00150
00152         virtual BOOLEAN AppendRow();
00153
00155         virtual BOOLEAN InsertRow(INT row);
00156
00158         virtual BOOLEAN ToggleRow(INT row);
00159
00161         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00162
00164         virtual BOOLEAN Update(ProviderListener * listener = 0);
00165
00167         virtual INT GetProgress();
00168
00170         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00171
00173         virtual INT GetBaseRow(INT row);
00174
00176         virtual BOOLEAN ExistColumn(INT colid);
00177
00179         virtual INT GetColumnId(INT column);
00180
00182         virtual const ColumnInfo * GetColumnInfoPerId(INT id);
00183
00185         virtual BOOLEAN SetParameter(const DataItem &item);
00186
00188         virtual BOOLEAN Lock();
00189
00191         virtual BOOLEAN Unlock();
00192
00194         BOOLEAN IsUpdating() const;
00195
00197         virtual BOOLEAN IsWStringDataCached() const;
00198
00200         virtual INT GetSortedColumnId() const;
00201
00203         const Provider::Modification& GetLastModification() const { return m_last_modification; }
00204
00206         INT GetModifiedRow() const { return m_last_modification.GetRow(); }
00207
00209         Provider::ModificationType GetModificationType() const { return m_last_modification.GetType(); }
00210
00212         void SetLastModification(const Provider::Modification& modification) { m_last_modification = modification; }
00213
00215         void SetModifiedRow(INT row) { m_last_modification.SetRow(row); }
00216
00218         void SetModificationType(Provider::ModificationType type) { m_last_modification.SetType(type); }
00219
00221         void ResetModification();
00222
00224         void SetStatus(Status status) { m_status = status; }
00225
00226     protected:
00227
00228         void SetColumnInfoTable(const ColumnInfo * table) { m_columninfo = table; }
00229
00230         BOOLEAN IsInRange(INT row);
00231
00232         void UpdateModification(ModificationType mod_type, INT row);
00233
00234         Status              m_status;
00235         const ColumnInfo *  m_columninfo;
00236
00237     private:
00238
00239         Provider::Modification m_last_modification;
00240 };
00241
00242
00244 #endif
00245
00246
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ProviderListener.cpp File Reference

Auxiliary/ProviderListener.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ProviderListener.hpp"

Include dependency graph for ProviderListener.cpp:

Generated on Tue Jan 24 19:17:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ProviderListener.hpp File Reference

Auxiliary/ProviderListener.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ProviderListener.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ProviderListener

Defines

#define | _Adc_ProviderListener_hpp

Define Documentation

#define _Adc_ProviderListener_hpp

Generated on Tue Jan 24 19:18:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ProviderListener.hpp Source File

Auxiliary/ProviderListener.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_ProviderListener_hpp)
00015 #define _Adc_ProviderListener_hpp
00016
00017 #include <Kernel/Types.hpp>
00018
00019 // #include <Auxiliary/Provider.hpp>
00020
00021
00022 class Provider;
00023
00025 class ProviderListener {
00026     public:
00028         ProviderListener();
00029
00031         virtual ~ProviderListener();
00032
00034         virtual void OnStarted(Provider * provider);
00035
00037         virtual void OnFinished();
00038
00040         virtual void OnExecuting();
00041
00043         Provider * GetProvider() const { return m_provider; }
00044
00045     private:
00046         Provider * m_provider;
00047
00048 };
00049
00050
00051 #endif
00052
00053
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/QuickSortProvider.cpp File Reference

Auxiliary/QuickSortProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "QuickSortProvider.hpp"
#include "DataItem.hpp"
#include "FilterRule.hpp"

Include dependency graph for QuickSortProvider.cpp:

Generated on Tue Jan 24 19:18:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/QuickSortProvider.hpp File Reference

Auxiliary/QuickSortProvider.hpp File Reference

#include <Auxiliary/SortProvider.hpp>

Include dependency graph for QuickSortProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | QuickSortProvider

Defines

#define | _Adc_QuickSortProvider_hpp

Define Documentation

#define _Adc_QuickSortProvider_hpp

Generated on Tue Jan 24 19:18:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/QuickSortProvider.hpp Source File

Auxiliary/QuickSortProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_QuickSortProvider_hpp)
00015 #define _Adc_QuickSortProvider_hpp
00016
00017 #include <Auxiliary/SortProvider.hpp>
00018 #if defined(APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING)
00019 #include <Auxiliary/Vector.hpp>
00020 #endif
00021 class DataItem;
00022 class FilterRule;
00023
00026 #if defined(APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING)
00027
00035 #endif
00036 class QuickSortProvider : public SortProvider
00037 {
00038     public:
00039         typedef SortProvider Base;
00040 #if defined(APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING)
00041         typedef Vector<INT> VectorStackType;
00042 #endif
00043
00045         QuickSortProvider();
00046
00051         QuickSortProvider(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00052
00054         virtual ~QuickSortProvider();
00055
00057         void Init(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00058
00060         virtual BOOLEAN Update(ProviderListener * listener = 0);
00061
00062     protected:
00063         IndexTable<INT>  m_sortbuffer;
00064 #if defined(APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING)
00065         VectorStackType * m_stackbuffer;
00066 #endif
00067
00068         void QuickSortWString(INT left, INT right, INT & depth);
00069         void QuickSortNumber(INT left, INT right, INT & depth);
00070         virtual void QuickSort(INT left, INT right, INT & depth);
00071
00072 };
00073
00074 #endif
00075
00076
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RamData.cpp File Reference

Auxiliary/RamData.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "RamData.hpp"

Include dependency graph for RamData.cpp:

Generated on Tue Jan 24 19:18:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RamData.hpp File Reference

Auxiliary/RamData.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for RamData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RamData

Defines

#define | Auxiliary_RamData_hpp

Define Documentation

#define Auxiliary_RamData_hpp

Generated on Tue Jan 24 19:18:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RamData.hpp Source File

Auxiliary/RamData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_RamData_hpp)
00011 #define Auxiliary_RamData_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/BinData.hpp>
00017
00022 class RamData : public BinData {
00023     typedef BinData Base;
00024
00025     public:
00028         static RamData* CreateInstance(void HUGE *buffer,
00029                                        UINT32 length,
00030                                        DrmLocalId id = c_drm_invalid_local_id);
00031
00033         virtual BOOLEAN Read(UINT32 idx, UINT8& val) const;
00034
00036         virtual UINT32 Read(UINT32 idx, void *val, UINT32 nbytes) const;
00037
00039         virtual UINT32 GetLength() const;
00040
00042         virtual BinData* Clone() const;
00043
00045         virtual MemMap* ObtainMemMap(UINT32 idx, UINT32 size) const;
00046
00048         virtual void ReleaseMemMap(MemMap** h_map) const;
00049
00052         void* GetBuffer() const { return (void*) m_buffer_ptr; }
00053
00054     protected:
00055         RamData(void HUGE *buffer, UINT32 length, DrmLocalId id = c_drm_invalid_local_id);
00056         virtual ~RamData();
00057
00058     private:
00059         UINT32 m_buffer_length;
00060         UINT8 HUGE* m_buffer_ptr;
00061 };
00062
00064 #endif  // Auxiliary_RamData_hpp
00065
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RegBlobObject.cpp File Reference

Auxiliary/RegBlobObject.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "RegBlobObject.hpp"
#include "Macros.hpp"

Include dependency graph for RegBlobObject.cpp:

Generated on Tue Jan 24 19:18:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RegBlobObject.hpp File Reference

Auxiliary/RegBlobObject.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BlobObject.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for RegBlobObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegBlobObject

Defines

#define | _Adc_RegBlobObject_hpp
#define | APOXI_REG_MAX_MIME_TYPE_LEN 30

Variables

const GenericTypeId | c_regblobobject_type = c_apoxi_base_gentypes + 3

Define Documentation

#define _Adc_RegBlobObject_hpp

#define APOXI_REG_MAX_MIME_TYPE_LEN 30

Variable Documentation

const GenericTypeId c_regblobobject_type = c_apoxi_base_gentypes + 3

Generated on Tue Jan 24 19:18:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RegBlobObject.hpp Source File

Auxiliary/RegBlobObject.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_RegBlobObject_hpp)
00015 #define _Adc_RegBlobObject_hpp
00016
00017 #include <Kernel/Types.hpp>
00018
00019 #include <Auxiliary/BlobObject.hpp>
00020 #include <Auxiliary/String.hpp>
00021
00022 #if !defined(APOXI_REG_MAX_MIME_TYPE_LEN)
00023     #define APOXI_REG_MAX_MIME_TYPE_LEN  30
00024 #endif
00025
00026 static const INT c_apoxi_reg_max_mime_type_len = APOXI_REG_MAX_MIME_TYPE_LEN;
00027
00028 const GenericTypeId c_regblobobject_type = c_apoxi_base_gentypes + 3;
00029
00036 class RegBlobObject : public BlobObject
00037 {
00038     public:
00039         typedef BlobObject Base;
00040
00042         RegBlobObject();
00043
00045         RegBlobObject(const UINT8 * data, INT length, const CHAR *mimetype);
00046
00048         RegBlobObject(const RegBlobObject & obj);
00049
00051         virtual ~RegBlobObject();
00052
00054         RegBlobObject & operator = (const RegBlobObject & szCopy);
00055
00057         virtual GenericObject * Copy() const;
00058
00060         virtual BOOLEAN         IsEqual(GenericObject * object);
00061
00063         virtual GenericTypeId   GetTypeId();
00064
00066         void Update(const UINT8 *data, INT length, const CHAR *mime_type);
00067
00069         void Clear();
00070
00072         void Allocate(INT length);
00073
00075         void Reallocate(INT length);
00076
00078         void Append(const UINT8 *data, INT length);
00079
00081         void CutOff(INT length);
00082
00086         INT  Poke(INT offset, const UINT8 *data, INT length);
00087
00091         INT Peek(INT offset, UINT8 *&data, INT length);
00092
00094         BOOLEAN IsEmpty() const { return (m_data == 0 || m_length == 0); }
00095
00097         BOOLEAN RegGetMimeType(String &mime_type);
00098
00100         BOOLEAN RegSetMimeType(String &mime_type);
00101
00103         INT32 RegGetSize() { return m_length + m_mime_type.GetLength() + 1; }
00104
00106         INT32 RegGetDataSize() { return m_length; }
00107
00109         INT16 RegGetMimeTypeSize() { return m_mime_type.GetLength() + 1; }
00110
00111
00112     private:
00114         String m_mime_type;
00115
00116 };
00117
00118
00119 #endif
00120
00121
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RomData.cpp File Reference

Auxiliary/RomData.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "RomData.hpp"

Include dependency graph for RomData.cpp:

Generated on Tue Jan 24 19:18:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RomData.hpp File Reference

Auxiliary/RomData.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for RomData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RomData

Defines

#define | Auxiliary_RomData_hpp

Define Documentation

#define Auxiliary_RomData_hpp

Generated on Tue Jan 24 19:18:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RomData.hpp Source File

Auxiliary/RomData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_RomData_hpp)
00011 #define Auxiliary_RomData_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/BinData.hpp>
00015
00019 class RomData : public BinData {
00020     typedef BinData Base;
00021
00022     public:
00024         static RomData* CreateInstance(const void *buffer,
00025                                        UINT32 length,
00026                                        DrmLocalId id = c_drm_invalid_local_id);
00027
00029         virtual BOOLEAN Read(UINT32 idx, UINT8& val) const;
00030
00032         virtual UINT32 Read(UINT32 idx, void *val, UINT32 nbytes) const;
00033
00035         virtual UINT32 GetLength() const;
00036
00038         const void* GetBuffer() const { return (const void*) m_buffer_ptr; }
00039
00040     protected:
00041         RomData(const void *buffer, UINT32 length, DrmLocalId id = c_drm_invalid_local_id);
00042         virtual ~RomData();
00043
00044     private:
00045         UINT32 m_buffer_length;
00046         const Uint8BufPtr m_buffer_ptr;
00047 };
00048
00049
00050 #endif  // Auxiliary_RomData_hpp
00051
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RomDataRes.hpp File Reference

Auxiliary/RomDataRes.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for RomDataRes.hpp:

Go to the source code of this file.

Data Structures

struct | RomDataRes

Defines

#define | RomDataRes_hpp

Define Documentation

#define RomDataRes_hpp

Generated on Tue Jan 24 19:18:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/RomDataRes.hpp Source File

Auxiliary/RomDataRes.hpp

Go to the documentation of this file.
00001 #if !defined(RomDataRes_hpp)
00002 #define RomDataRes_hpp
00003
00004 #include <Auxiliary/MimeTypeTable.hpp>
00005
00006 struct RomDataRes {
00007     MimeType mimetype;
00008     UINT32 size;
00009     const UINT8 HUGE* data;
00010 };
00011
00012 #endif //RomDataRes_hpp
00013
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SharedPtr.hpp File Reference

Auxiliary/SharedPtr.hpp File Reference

#include <Auxiliary/Linkable.hpp>

Include dependency graph for SharedPtr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SharedPtr< T_obj >

Defines

#define | Apoxi_SharedPtr_hpp

Define Documentation

#define Apoxi_SharedPtr_hpp

Generated on Tue Jan 24 19:18:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SharedPtr.hpp Source File

Auxiliary/SharedPtr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SharedPtr_hpp)
00011 #define Apoxi_SharedPtr_hpp
00014
00015 #include <Auxiliary/Linkable.hpp>
00016
00060 template< typename T_obj >
00061 class SharedPtr : public Linkable< SharedPtr<T_obj> >
00062 {
00063 public:
00067     SharedPtr();
00068
00072     explicit SharedPtr(T_obj* pobj);
00073
00077     SharedPtr(const SharedPtr<T_obj>& src);
00078
00083     //template <typename T_CastFrom>
00084     //inline SharedPtr(const SharedPtr<T_CastFrom>& src);
00085
00087     SharedPtr& operator=(const SharedPtr<T_obj>& src);
00088
00090     //template <class T_CastFrom>
00091     //SharedPtr<T_obj>& operator=(const SharedPtr<T_CastFrom>& src);
00092
00093     virtual ~SharedPtr();
00094
00096     bool operator==(const SharedPtr<T_obj>& src) const;
00097
00099     bool operator!=(const SharedPtr<T_obj>& src) const;
00100
00104     virtual void Clear();
00105
00106
00109     inline T_obj& operator*();
00110
00113     inline const T_obj& operator*() const;
00114
00120     inline T_obj* operator->() const;
00121
00130     inline operator bool() const;
00131
00132
00133
00134 protected:
00135
00136     inline void Ref();
00137     inline void Unref();
00138
00139     mutable T_obj* m_pobj; //The underlying instance. Derived from ReferableObject.
00140 };
00141
00142 template< typename T_obj >
00143 SharedPtr<T_obj>::SharedPtr()
00144 : m_pobj(0)
00145 {
00146 }
00147
00148 template< typename T_obj >
00149 SharedPtr<T_obj>::SharedPtr(T_obj* pobj)
00150 : m_pobj(0)
00151 {
00152     if(pobj)
00153     {
00154         //Copy it:
00155         m_pobj = pobj;
00156
00157         //Start reference counting:
00158         Ref();
00159     }
00160 }
00161
00162 template< typename T_obj >
00163 SharedPtr<T_obj>::SharedPtr(const SharedPtr<T_obj>& src)
00164 {
00165         m_pobj = src.m_pobj;
00166
00167         Ref();
00168 }
00169
00170
00171 template< typename T_obj >
00172 SharedPtr<T_obj>& SharedPtr<T_obj>::operator=(const SharedPtr<T_obj>& src)
00173 {
00174     if(&src != this)
00175     {
00176         //Unref any existing stuff.
00177         //operator= can never run before a constructor, so these values will be initialized already.
00178         if(m_pobj) //The if() might not be required.
00179         {
00180             Unref(); //Could cause a deallocation.
00181         }
00182
00183         //Copy:
00184         m_pobj = src.m_pobj;
00185
00186         Ref();
00187     }
00188
00189     return *this;
00190 }
00191
00192
00193 template< typename T_obj >
00194 SharedPtr<T_obj>::~SharedPtr()
00195 {
00196      Unref();
00197 }
00198
00199 template< typename T_obj >
00200 bool SharedPtr<T_obj>::operator==(const SharedPtr<T_obj>& src) const
00201 {
00202     return m_pobj == src.m_pobj;
00203 }
00204
00205 template< typename T_obj >
00206 bool SharedPtr<T_obj>::operator!=(const SharedPtr<T_obj>& src) const
00207 {
00208     return !operator==(src);
00209 }
00210
00211 template< typename T_obj >
00212 void SharedPtr<T_obj>::Clear()
00213 {
00214     //Forget any previous instance:
00215     //This will not affect any other SharedPtr that happens to contain the same underlying instance,
00216     if(m_pobj)
00217     {
00218         Unref();
00219         m_pobj = 0;
00220     }
00221 }
00222
00223 template< typename T_obj >
00224 inline
00225 T_obj& SharedPtr<T_obj>::operator*()
00226 {
00227     return *m_pobj;
00228 }
00229
00230 template< typename T_obj >
00231 inline
00232 const T_obj& SharedPtr<T_obj>::operator*() const
00233 {
00234     ASSERT(m_pobj != 0);
00235     return *m_pobj;
00236 }
00237
00238 template< typename T_obj >
00239 inline
00240 T_obj* SharedPtr<T_obj>::operator->() const
00241 {
00242     return m_pobj;
00243 }
00244
00245 template <class T_obj >
00246 inline
00247 SharedPtr<T_obj>::operator bool() const
00248 {
00249     return (m_pobj != 0);
00250 }
00251
00252
00253 template <class T_obj >
00254 inline
00255 void SharedPtr<T_obj>::Ref()
00256 {
00257     if(m_pobj)
00258         m_pobj->AddRef(); //This is really a "Reference".
00259 }
00260
00261 template <class T_obj >
00262 inline
00263 void SharedPtr<T_obj>::Unref()
00264 {
00265     if(m_pobj)
00266         m_pobj->Release(); //This is really an "Un-reference".
00267 }
00268
00270 #endif  // Apoxi_SharedPtr_hpp
00271
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SimpleMap.hpp File Reference

Auxiliary/SimpleMap.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/NonCloneable.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for SimpleMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimpleMap< TKey, TValue >
class | SimpleMap< TKey, TValue >::Iterator
class | SimpleMapElem< TKey, TValue >

Defines

#define | Apoxi_SimpleMap_hpp

Define Documentation

#define Apoxi_SimpleMap_hpp

Generated on Tue Jan 24 19:19:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SimpleMap.hpp Source File

Auxiliary/SimpleMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SimpleMap_hpp)
00010 #define Apoxi_SimpleMap_hpp
00013
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/NonCloneable.hpp>
00016 #include <Auxiliary/Macros.hpp>
00017
00018 // Forward declaration.
00019 template <class TKey, class TValue> class SimpleMap;
00020
00024 template <class TKey, class TValue>
00025 class SimpleMapElem : public Linkable<SimpleMapElem<TKey, TValue> >
00026 {
00027     typedef Linkable<SimpleMapElem<TKey, TValue> > Base;
00028
00029     public:
00030         SimpleMapElem(const TKey &key, const TValue &value) :
00031           m_key(key), m_value(value)
00032         {}
00033
00034         TKey& GetKey()
00035             { return m_key; }
00036
00037         TValue& GetValue()
00038             { return m_value; }
00039
00040     private:
00041         TKey m_key;
00042         TValue m_value;
00043
00044         friend class SimpleMap<TKey, TValue>;
00045 };
00046
00122 template <class TKey, class TValue>
00123 class SimpleMap : public NonCloneable
00124 {
00125     public:
00126         typedef SimpleMapElem<TKey, TValue> Pair;
00127
00128     public:
00131         class Iterator
00132         {
00133             protected:
00134                 Iterator(const SimpleMap &map) :
00135                     m_map(map),
00136                     m_cur_elem(map.m_head)
00137                 {}
00138
00139             public:
00140                 BOOLEAN IsValid() const
00141                     { return m_cur_elem != 0; }
00142
00143                 Pair& GetPair() const
00144                     {
00145                         ASSERT_DEBUG(m_cur_elem != 0);
00146                         return *m_cur_elem;
00147                     }
00148
00149                 void Increment()
00150                     {
00151                         ASSERT_DEBUG(m_cur_elem != 0);
00152                         m_cur_elem = m_cur_elem->GetNext();
00153                     }
00154
00155             private:
00156                 const SimpleMap &m_map;
00157                 Pair *m_cur_elem;
00158
00159                 friend class SimpleMap<TKey, TValue>;
00160         };
00161
00162     public:
00164         SimpleMap();
00165
00167         virtual ~SimpleMap();
00168
00174         TValue& operator[](const TKey &key);
00175
00179         const TValue& operator[](const TKey &key) const;
00180
00182         BOOLEAN Exists(const TKey &key) const;
00183
00186         BOOLEAN Remove(const TKey &key);
00187
00189         void RemoveAll();
00190
00198         BOOLEAN Ok() const
00199             { return m_ok; }
00200
00202         UINT GetSize() const;
00203
00205         Iterator GetIterator() const;
00206
00215         BOOLEAN GetValue(const TKey &key, TValue &value) const;
00216
00217     private:
00219         mutable BOOLEAN m_ok;
00220
00222         Pair *m_head;
00223
00224         friend class Iterator;
00225 };
00226
00227 template <class TKey, class TValue>
00228 SimpleMap<TKey, TValue>::SimpleMap() :
00229     m_ok(TRUE),
00230     m_head(0)
00231 {
00232 }
00233
00234 template <class TKey, class TValue>
00235 SimpleMap<TKey, TValue>::~SimpleMap()
00236 {
00237     while (m_head != 0) {
00238         Pair *next = m_head->GetNext();
00239         delete m_head;
00240         m_head = next;
00241     }
00242 }
00243
00244 template <class TKey, class TValue>
00245 TValue& SimpleMap<TKey, TValue>::operator[](const TKey &key)
00246 {
00247     // Static value which is returned on out of memory error.
00248     static TValue s_err_val = TValue();
00249
00250     m_ok = TRUE;
00251
00252     // Search for an existing element for key.
00253     Pair *list = m_head;
00254     while (list != 0) {
00255         if (list->m_key == key) {
00256             return list->m_value;
00257         }
00258         list = list->GetNext();
00259     }
00260
00261     // Insert new element for key at head.
00262     Pair *new_elem = new Pair(key, TValue());
00263
00264     if (new_elem == 0) {
00265         m_ok = FALSE;
00266         return s_err_val;
00267     }
00268
00269     new_elem->SetNext(m_head);
00270     m_head = new_elem;
00271
00272     return m_head->m_value;
00273 }
00274
00275 template <class TKey, class TValue>
00276 const TValue& SimpleMap<TKey, TValue>::operator[](const TKey &key) const
00277 {
00278     // Static value which is returned on out of memory error.
00279     static TValue s_err_val = TValue();
00280
00281     m_ok = TRUE;
00282
00283     // Search for an existing element for key.
00284     Pair *list = m_head;
00285     while (list != 0) {
00286         if (list->m_key == key) {
00287             return list->m_value;
00288         }
00289         list = list->GetNext();
00290     }
00291
00292     m_ok = FALSE;
00293
00294     return s_err_val;
00295 }
00296
00297 template <class TKey, class TValue>
00298 BOOLEAN SimpleMap<TKey, TValue>::Exists(const TKey &key) const
00299 {
00300     Pair *list = m_head;
00301     while (list != 0) {
00302         if (list->m_key == key) {
00303             return TRUE;
00304         }
00305         list = list->GetNext();
00306     }
00307
00308     return FALSE;
00309 }
00310
00311 template <class TKey, class TValue>
00312 BOOLEAN SimpleMap<TKey, TValue>::Remove(const TKey &key)
00313 {
00314     Pair *list = m_head, *prev = 0;
00315     while (list != 0) {
00316         if (list->m_key == key) {
00317             if (prev == 0) {
00318                 m_head = list->GetNext();
00319             }
00320             else {
00321                 prev->SetNext(list->GetNext());
00322             }
00323             delete list;
00324             return TRUE;
00325         }
00326         prev = list;
00327         list = list->GetNext();
00328     }
00329
00330     return FALSE;
00331 }
00332
00333 template <class TKey, class TValue>
00334 void SimpleMap<TKey, TValue>::RemoveAll()
00335 {
00336     while (m_head != 0) {
00337         Pair *next = m_head->GetNext();
00338         delete m_head;
00339         m_head = next;
00340     }
00341 }
00342
00343 template <class TKey, class TValue>
00344 UINT SimpleMap<TKey, TValue>::GetSize() const
00345 {
00346     UINT size = 0;
00347     Pair *list = m_head;
00348     while (list != 0) {
00349         size++;
00350         list = list->GetNext();
00351     }
00352
00353     return size;
00354 }
00355
00356 template <class TKey, class TValue>
00357 typename SimpleMap<TKey, TValue>::Iterator
00358     SimpleMap<TKey, TValue>::GetIterator() const
00359 {
00360     return SimpleMap<TKey, TValue>::Iterator(*this);
00361 }
00362
00363 template <class TKey, class TValue>
00364 BOOLEAN SimpleMap<TKey, TValue>::GetValue(const TKey &key, TValue &value) const
00365 {
00366     value = operator[](key);
00367     return Ok();
00368 }
00369
00371 #endif  // Apoxi_SimpleMap_hpp
00372
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SingleArgHook.hpp File Reference

Auxiliary/SingleArgHook.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for SingleArgHook.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SingleArgHook< T >

Defines

#define | Apoxi_SingleArgHook_hpp

Define Documentation

#define Apoxi_SingleArgHook_hpp

Generated on Tue Jan 24 19:19:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SingleArgHook.hpp Source File

Auxiliary/SingleArgHook.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SingleArgHook_hpp)
00010 #define Apoxi_SingleArgHook_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00023 template <class T> class SingleArgHook {
00024     public:
00025         typedef void (*HookFn)(T);
00026
00027         SingleArgHook() : m_hook(0) {}
00028         virtual ~SingleArgHook() { m_hook = 0; }
00029
00031         BOOLEAN Add(HookFn fn) {
00032             if (m_hook == 0)
00033                 m_hook = fn;
00034
00035             return (m_hook == fn);
00036         }
00037
00039         BOOLEAN Remove(HookFn fn) {
00040             if (m_hook == fn)
00041                 fn = 0;
00042
00043             return (fn == 0);
00044         }
00045
00048         void Call(T t) {
00049             if (m_hook != 0)
00050                 m_hook(t);
00051         }
00052
00053     private:
00054         HookFn m_hook;
00055 };
00056
00058 #endif  // Apoxi_SingleArgHook_hpp
00059
00060
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SortProvider.cpp File Reference

Auxiliary/SortProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "SortProvider.hpp"
#include "DataItem.hpp"
#include "FilterRule.hpp"

Include dependency graph for SortProvider.cpp:

Generated on Tue Jan 24 19:19:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SortProvider.hpp File Reference

Auxiliary/SortProvider.hpp File Reference

#include <Auxiliary/AbstractDelegationProvider.hpp>
#include <Auxiliary/IndexTable.hpp>

Include dependency graph for SortProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SortProvider

Defines

#define | _Adc_SortProvider_hpp

Define Documentation

#define _Adc_SortProvider_hpp

Generated on Tue Jan 24 19:19:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SortProvider.hpp Source File

Auxiliary/SortProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(_Adc_SortProvider_hpp)
00015 #define _Adc_SortProvider_hpp
00018
00019 #include <Auxiliary/AbstractDelegationProvider.hpp>
00020 #include <Auxiliary/IndexTable.hpp>
00021
00022 class DataItem;
00023 class FilterRule;
00024
00030 class SortProvider : public AbstractDelegationProvider
00031 {
00032     public:
00033         typedef AbstractDelegationProvider Base;
00034
00037         SortProvider();
00038
00043         SortProvider(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00044
00046         virtual ~SortProvider();
00047
00049         void Init(Provider * provider, INT columnid = 0, BOOLEAN order = TRUE);
00050
00052         void SetSortOrder(BOOLEAN sortorder) { m_order = sortorder; }
00053
00055         void SetSortColumn(INT sortcolumn) { m_columnid = sortcolumn; }
00056
00058         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00059
00061         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00062
00064         virtual BOOLEAN Update(ProviderListener * listener) = 0;
00065
00068         virtual void OnExecutingListener(Provider* provider = 0);
00069
00071         virtual BOOLEAN InsertRow(INT row);
00072
00073     protected:
00074         virtual void OnChildProviderModification(Provider* provider, const Provider::Modification& modification);
00075
00076         virtual BOOLEAN UpdateIndexTable(ModificationType type, INT row);
00077
00078         virtual void ResizeIndexTable();
00079         virtual INT FindSortedRow(INT row);
00080
00081         INT             m_columnid;
00082         BOOLEAN         m_order;
00083
00084         IndexTable<INT> m_SortedRows;
00085 };
00086
00088 #endif
00089
00090
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StateMachine.cpp File Reference

Auxiliary/StateMachine.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "StateMachine.hpp"
#include "EventData.hpp"
#include "Macros.hpp"

Include dependency graph for StateMachine.cpp:

Generated on Tue Jan 24 19:19:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StateMachine.hpp File Reference

Auxiliary/StateMachine.hpp File Reference

#include <Kernel/Os/Semaphore.hpp>
#include <Kernel/Os/SemObtainer.hpp>

Include dependency graph for StateMachine.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StateMachine
struct | StateStruct

State map macros

Theses macros are used to define the state map of the state machine.

#define | BEGIN_STATE_MAP
#define | END_STATE_MAP
#define | STATE_MAP_ENTRY(entry) { (StateFunc)(entry) },

Transition map macros

Theses macros are used to define the transition maps of the state machine.

#define | BEGIN_TRANSITION_MAP static const UINT8 TRANSITIONS[] = { \
#define | END_TRANSITION_MAP(data)
#define | TRANSITION_MAP_ENTRY(entry) (entry),

Defines

#define | Apoxi_StateMachine_hpp
#define | LOCK_STATE_MACHINE SemObtainer state_machine_so(&GetSempahore());

Typedefs

typedef void(StateMachine::* | StateFunc )(EventData *)

Define Documentation

#define Apoxi_StateMachine_hpp

#define BEGIN_STATE_MAP

Value:

public:                                             \
virtual const StateStruct* GetStateMap() {          \
    static const StateStruct StateMap[] = {
Begins the state map.

#define BEGIN_TRANSITION_MAP static const UINT8 TRANSITIONS[] = { \

Begins a transition map.

#define END_STATE_MAP

Value:

{ (StateFunc)0 }                                \
    };                                              \
    return &StateMap[0]; }
Ends the state map.

#define END_TRANSITION_MAP ( data )

Value:

0 };                                            \
    ExternalEvent(TRANSITIONS, (data));
Ends a transition map.

#define LOCK_STATE_MACHINE SemObtainer state_machine_so(&GetSempahore());

Macro used to lock state machine operations and data accesses. Using this macro at the beginning of a method ensures the method to be atomic.

#define STATE_MAP_ENTRY ( entry ) { (StateFunc)(entry) },

Adds an entry to the state map.

#define TRANSITION_MAP_ENTRY ( entry ) (entry),

Adds an entry to a transition map.

Typedef Documentation

typedef void(StateMachine::* StateFunc)(EventData *)

Generated on Tue Jan 24 19:20:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StateMachine.hpp Source File

Auxiliary/StateMachine.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_StateMachine_hpp)
00010 #define Apoxi_StateMachine_hpp
00011
00012 #include <Kernel/Os/Semaphore.hpp>
00013 #include <Kernel/Os/SemObtainer.hpp>
00014
00015 class EventData;
00016 struct StateStruct;
00017
00022 class StateMachine : public NonCloneable
00023 {
00024 protected:
00025     enum {
00026         EVENT_IGNORED = 0xFE,
00027         CANNOT_HAPPEN
00028     };
00029
00030     UINT8 m_currentState;
00031
00032 protected:
00033     StateMachine(INT maxStates);
00034
00037     void ExternalEvent(const UINT8[], EventData* = 0);
00038
00041     void InternalEvent(UINT8, EventData* = 0);
00042
00043     virtual const StateStruct* GetStateMap() = 0;
00044
00045     Semaphore& GetSempahore() const { return m_sem; }
00046
00047 private:
00048     const INT m_maxStates;
00049     BOOLEAN m_eventGenerated;
00050     EventData *m_pEventData;
00051     mutable Semaphore m_sem;
00052
00053 private:
00055     void StateEngine();
00056 };
00057
00058 typedef void (StateMachine::*StateFunc)(EventData *);
00059
00060 struct StateStruct
00061 {
00062     StateFunc pStateFunc;
00063 };
00064
00067 #define LOCK_STATE_MACHINE SemObtainer state_machine_so(&GetSempahore());
00068
00073
00075 #define BEGIN_STATE_MAP                             \
00076 public:                                             \
00077 virtual const StateStruct* GetStateMap() {          \
00078     static const StateStruct StateMap[] = {
00079
00081 #define STATE_MAP_ENTRY(entry)                      \
00082     { (StateFunc)(entry) },
00083
00085 #define END_STATE_MAP                               \
00086     { (StateFunc)0 }                                \
00087     };                                              \
00088     return &StateMap[0]; }
00089
00091
00096
00098 #define BEGIN_TRANSITION_MAP                        \
00099     static const UINT8 TRANSITIONS[] = {            \
00100
00101
00102 #define TRANSITION_MAP_ENTRY(entry)                 \
00103     (entry),
00104
00106 #define END_TRANSITION_MAP(data)                    \
00107     0 };                                            \
00108     ExternalEvent(TRANSITIONS, (data));
00109
00111
00112 #endif  // Apoxi_StateMachine_hpp
00113
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Stream.cpp File Reference

Auxiliary/Stream.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Stream.hpp"

Include dependency graph for Stream.cpp:

Generated on Tue Jan 24 19:20:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Stream.hpp File Reference

Auxiliary/Stream.hpp File Reference

#include <Auxiliary/StreamingInfo.hpp>

Include dependency graph for Stream.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Stream

Defines

#define | Apoxi_Stream_hpp

Define Documentation

#define Apoxi_Stream_hpp

Generated on Tue Jan 24 19:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Stream.hpp Source File

Auxiliary/Stream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Stream_hpp)
00011 #define Apoxi_Stream_hpp
00014
00015 class StreamWriter;
00016 class StreamReader;
00017
00018 #include <Auxiliary/StreamingInfo.hpp>
00019
00027 class Stream {
00028     public:
00029
00030         // StreamCaps enum ------------------------------------------------------------------------
00031
00034         enum Caps {
00035
00037             StreamCanBeRead = 1,
00038
00040             StreamCanBeWritten,
00041
00043             StreamCanBeReadWritten
00044
00045         };
00046
00047         // StreamOrigin enum ----------------------------------------------------------------------
00048
00051         enum Origin {
00052
00054             StreamBegin = 1,
00055
00057             StreamEnd,
00058
00060             StreamCurrent
00061
00062         };
00063
00064         // construction  --------------------------------------------------------------------------
00065
00067         Stream();
00068
00070         virtual ~Stream();
00071
00072         // capabilites ----------------------------------------------------------------------------
00073
00078         virtual Caps GetCapabilities() = 0;
00079
00080         // reader and writer ----------------------------------------------------------------------
00081
00084         virtual StreamReader* GetReader() = 0;
00085
00088         virtual StreamWriter* GetWriter() = 0;
00089
00090         // opening, closing ----------------------------------------------------------------------
00091
00094         virtual void Open(StreamingInfo& info) = 0;
00095
00098         virtual void Close(StreamingInfo& info) = 0;
00099 };
00100
00102 #endif  // Apoxi_Stream_hpp
00103
00104
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingCallback.hpp File Reference

Auxiliary/StreamingCallback.hpp File Reference

#include <Auxiliary/StreamingReadInfo.hpp>
#include <Auxiliary/StreamingWriteInfo.hpp>

Include dependency graph for StreamingCallback.hpp:

Go to the source code of this file.

Data Structures

class | StreamingCallback

Defines

#define | Apoxi_StreamingCallback_hpp

Define Documentation

#define Apoxi_StreamingCallback_hpp

Generated on Tue Jan 24 19:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingCallback.hpp Source File

Auxiliary/StreamingCallback.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StreamingCallback_hpp)
00011 #define Apoxi_StreamingCallback_hpp
00014
00015 #include <Auxiliary/StreamingReadInfo.hpp>
00016 #include <Auxiliary/StreamingWriteInfo.hpp>
00017
00027 class StreamingCallback {
00028     public:
00031         StreamingCallback();
00032
00034         virtual ~StreamingCallback();
00035
00039         virtual void Callback(StreamingInfo& info) = 0;
00040
00044         virtual void CallbackRead(StreamingReadInfo& read_info) = 0;
00045
00049         virtual void CallbackWrite(StreamingWriteInfo& write_info) = 0;
00050
00051 }
00052
00054 #endif  // Apoxi_StreamingCallback_hpp
00055
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingInfo.cpp File Reference

Auxiliary/StreamingInfo.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "StreamingInfo.hpp"

Include dependency graph for StreamingInfo.cpp:

Generated on Tue Jan 24 19:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingInfo.hpp File Reference

Auxiliary/StreamingInfo.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for StreamingInfo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamingInfo

Defines

#define | Apoxi_StreamingInfo_hpp

Define Documentation

#define Apoxi_StreamingInfo_hpp

Generated on Tue Jan 24 19:20:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingInfo.hpp Source File

Auxiliary/StreamingInfo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StreamingInfo_hpp)
00011 #define Apoxi_StreamingInfo_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/String.hpp>
00017
00021 class StreamingInfo {
00022     public:
00023         // OperationState enum --------------------------------------------------------------------
00024
00026         enum OperationState {
00028             OperationCompletedSynchroneously,
00029
00031             OperationCompleted,
00032
00034             OperationNotCompleted,
00035
00037             OperationErroneous,
00038
00040             OperationFailed,
00041
00042             // Operation is not supported
00043             OperationNotSupported,
00044
00045             // Other state
00046             OperationOtherState
00047         };
00048
00049         // Constructors, destructor ---------------------------------------------------------------
00050
00052         StreamingInfo();
00053
00055         ~StreamingInfo();
00056
00057         // Getters --------------------------------------------------------------------------------
00058
00061         OperationState GetOperationState() const { return m_op_state; }
00062
00067         BOOLEAN IsOperationCompletedSynchroneously() const;
00068
00072         BOOLEAN IsOperationCompleted() const;
00073
00077         BOOLEAN IsOperationErroneous() const;
00078
00082         BOOLEAN IsOperationFailed() const;
00083
00086         String GetErrorMessage() const { return m_error_msg; }
00087
00090         UINT32 GetDeviceErrorCode() const { return m_device_error_code; }
00091
00092         // Setters --------------------------------------------------------------------------------
00093
00096         void SetOperationState(OperationState op_state) { m_op_state = op_state; }
00097
00100         void SetErrorMessage(const String& error_msg) { m_error_msg = error_msg; }
00101
00104         void SetDeviceErrorCode(INT32 error_code) { m_device_error_code = error_code; }
00105
00106         // Private part ---------------------------------------------------------------------------
00107
00108     private:
00110         OperationState m_op_state;
00111
00113         String m_error_msg;
00114
00116         INT32 m_device_error_code;
00117 };
00118
00120 #endif  // Apoxi_StreamingInfo_hpp
00121
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingReadInfo.cpp File Reference

Auxiliary/StreamingReadInfo.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "StreamingReadInfo.hpp"

Include dependency graph for StreamingReadInfo.cpp:

Generated on Tue Jan 24 19:20:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingReadInfo.hpp File Reference

Auxiliary/StreamingReadInfo.hpp File Reference

#include <Auxiliary/StreamingInfo.hpp>

Include dependency graph for StreamingReadInfo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamingReadInfo

Defines

#define | Apoxi_StreamingReadInfo_hpp

Define Documentation

#define Apoxi_StreamingReadInfo_hpp

Generated on Tue Jan 24 19:20:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingReadInfo.hpp Source File

Auxiliary/StreamingReadInfo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StreamingReadInfo_hpp)
00011 #define Apoxi_StreamingReadInfo_hpp
00014
00015 #include <Auxiliary/StreamingInfo.hpp>
00016
00022 class StreamingReadInfo : StreamingInfo {
00023     public:
00024         // Constructors, destructor ---------------------------------------------------------------
00025
00028         StreamingReadInfo(UINT32 requested_byte_count = 0);
00029
00031         ~StreamingReadInfo();
00032
00033         // Getters --------------------------------------------------------------------------------
00034
00036         void* GetDataRead() const { return m_data; }
00037
00042         UINT32 GetRequestedByteCount() const { return m_requested_byte_count; }
00043
00046         UINT32 GetAvailableByteCount() const { return m_available_byte_count; }
00047
00050         BOOLEAN EndOfStream() const { return m_end_of_stream; }
00051
00052         // Setters --------------------------------------------------------------------------------
00053
00056         void SetDataRead(void* data) { m_data = data; }
00057
00062         void SetRequestedByteCount(UINT32 requested_byte_count) { m_requested_byte_count = requested_byte_count; }
00063
00066         void SetAvailableByteCount(UINT32 available_byte_count) { m_available_byte_count = available_byte_count; }
00067
00070         void SetEndOfStream(BOOLEAN eos) { m_end_of_stream = eos; }
00071
00072
00073         // Private part ---------------------------------------------------------------------------
00074
00075     private:
00077         void* m_data;
00078
00080         UINT32 m_requested_byte_count;
00081
00083         UINT32 m_available_byte_count;
00084
00086         BOOLEAN m_end_of_stream;
00087 };
00088
00090 #endif  // Apoxi_StreamingReadInfo_hpp
00091
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingWriteInfo.cpp File Reference

Auxiliary/StreamingWriteInfo.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "StreamingWriteInfo.hpp"

Include dependency graph for StreamingWriteInfo.cpp:

Generated on Tue Jan 24 19:20:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingWriteInfo.hpp File Reference

Auxiliary/StreamingWriteInfo.hpp File Reference

#include <Auxiliary/StreamingInfo.hpp>

Include dependency graph for StreamingWriteInfo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamingWriteInfo

Defines

#define | Apoxi_StreamingWriteInfo_hpp

Define Documentation

#define Apoxi_StreamingWriteInfo_hpp

Generated on Tue Jan 24 19:20:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamingWriteInfo.hpp Source File

Auxiliary/StreamingWriteInfo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StreamingWriteInfo_hpp)
00011 #define Apoxi_StreamingWriteInfo_hpp
00014
00015 #include <Auxiliary/StreamingInfo.hpp>
00016
00022 class StreamingWriteInfo : StreamingInfo {
00023     public:
00024         // Constructors, destructor ---------------------------------------------------------------
00025
00030         StreamingWriteInfo(void* data_to_write = 0, UINT32 write_byte_count = 0);
00031
00033         ~StreamingWriteInfo();
00034
00035         // Getters --------------------------------------------------------------------------------
00036
00038         void* GetDataToWrite() const { return m_data; }
00039
00041         UINT32 GetWriteByteCount() const { return m_write_byte_count; }
00042
00044         UINT32 GetWrittenByteCount() const { return m_written_byte_count; }
00045
00046         // Setters --------------------------------------------------------------------------------
00047
00050         void SetDataToWrite(void* data) { m_data = data; }
00051
00054         void SetWriteByteCount(UINT32 write_byte_count) { m_write_byte_count = write_byte_count; }
00055
00058         void SetWrittenByteCount(UINT32 written_byte_count) { m_written_byte_count = written_byte_count; }
00059
00060         // Private part ---------------------------------------------------------------------------
00061
00062     private:
00064         void* m_data;
00065
00067         UINT32 m_write_byte_count;
00068
00070         UINT32 m_written_byte_count;
00071
00072 };
00073
00075 #endif  // Apoxi_StreamingWriteInfo_hpp
00076
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamReader.cpp File Reference

Auxiliary/StreamReader.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "StreamReader.hpp"

Include dependency graph for StreamReader.cpp:

Generated on Tue Jan 24 19:20:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamReader.hpp File Reference

Auxiliary/StreamReader.hpp File Reference

#include <Auxiliary/Stream.hpp>

Include dependency graph for StreamReader.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamReader

Defines

#define | Apoxi_StreamReader_hpp

Define Documentation

#define Apoxi_StreamReader_hpp

Generated on Tue Jan 24 19:20:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamReader.hpp Source File

Auxiliary/StreamReader.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StreamReader_hpp)
00011 #define Apoxi_StreamReader_hpp
00014
00015 class StreamingReadInfo;
00016 class StreamingCallback;
00017 #include <Auxiliary/Stream.hpp>
00018
00024 class StreamReader {
00025     public:
00027         StreamReader();
00028
00030         virtual ~StreamReader();
00031
00032         // availability ---------------------------------------------------------------------------
00033
00037         virtual UINT32 DataAvailable() const = 0;
00038
00042         virtual BOOLEAN IsDataAvailable(UINT32 byte_count) const = 0;
00043
00044         // reading --------------------------------------------------------------------------------
00045
00068         virtual void RequestRead(StreamingReadInfo& read_info,
00069                                  const StreamingCallback* callback_object = 0) = 0;
00070
00075         virtual void DataProcessed(const void* begin_data, UINT32 byte_count) = 0;
00076
00077         // Positioning ----------------------------------------------------------------------------
00078
00081         virtual BOOLEAN CanSeek() const = 0;
00082
00089         virtual void Seek(Stream::Origin origin,
00090                           INT32 offset,
00091                           StreamingInfo& info) = 0;
00092
00095         virtual UINT32 CurrentPosition(StreamingInfo& info) const = 0;
00096
00097         // opening, closing ----------------------------------------------------------------------
00098
00101         virtual void Open(StreamingInfo& info) = 0;
00102
00105         virtual void Close(StreamingInfo& info) = 0;
00106
00107 };
00108
00110 #endif  // Apoxi_StreamReader_hpp
00111
00112
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamWriter.cpp File Reference

Auxiliary/StreamWriter.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "StreamWriter.hpp"

Include dependency graph for StreamWriter.cpp:

Generated on Tue Jan 24 19:20:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamWriter.hpp File Reference

Auxiliary/StreamWriter.hpp File Reference

#include <Auxiliary/Stream.hpp>

Include dependency graph for StreamWriter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StreamWriter

Defines

#define | Apoxi_StreamWriter_hpp

Define Documentation

#define Apoxi_StreamWriter_hpp

Generated on Tue Jan 24 19:20:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StreamWriter.hpp Source File

Auxiliary/StreamWriter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StreamWriter_hpp)
00011 #define Apoxi_StreamWriter_hpp
00014
00015 class StreamingCallback;
00016 class StreamingWriteInfo;
00017 #include <Auxiliary/Stream.hpp>
00018
00024 class StreamWriter {
00025     public:
00027         StreamWriter();
00028
00030         virtual ~StreamWriter();
00031
00032         // acceptability --------------------------------------------------------------------------
00033
00036         virtual UINT32 DataAcceptable() const = 0;
00037
00041         virtual BOOLEAN IsDataAcceptable(UINT32 byte_count) const = 0;
00042
00043         // writing --------------------------------------------------------------------------------
00044
00064         virtual void RequestWrite(StreamingWriteInfo& write_info,
00065                                   const StreamingCallback* callback_object = 0) = 0;
00066
00067         // Positioning ----------------------------------------------------------------------------
00068
00070         virtual BOOLEAN CanSeek() const = 0;
00071
00078         virtual void Seek(Stream::Origin origin,
00079                           INT32 offset,
00080                           StreamingInfo& info) = 0;
00081
00085         virtual UINT32 CurrentPosition(StreamingInfo& info) const = 0;
00086
00087         // Open, flushing, closing ----------------------------------------------------------------
00088
00092         virtual void Open(StreamingInfo& info) = 0;
00093
00096         virtual void Flush(StreamingInfo& info) = 0;
00097
00100         virtual void Close(StreamingInfo& info) = 0;
00101 };
00102
00104 #endif  // Apoxi_StreamWriter_hpp
00105
00106
Generated on Tue Jan 24 14:48:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/String.cpp File Reference

Auxiliary/String.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include <Config/MemoryConfig.hpp>
#include "WString.hpp"
#include "Unicode.hpp"
#include "Macros.hpp"
#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/VersionInfo.hpp>
#include <stdio.h>

Include dependency graph for String.cpp:

Defines

#define ExtendedDbgCode(code)

Functions

ApoxiUseVersionInfo (Auxiliary)

Define Documentation

#define ExtendedDbgCode ( code )

Function Documentation

ApoxiUseVersionInfo ( Auxiliary )

Generated on Tue Jan 24 19:20:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/String.hpp File Reference

Auxiliary/String.hpp File Reference

#include <stdarg.h>
#include <Kernel/Types.hpp>
#include <Kernel/Os/OsStrLib.hpp>
#include <Auxiliary/StrUtil.hpp>

Include dependency graph for String.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | StrData
class | String

Defines

#define | _APOXI_String_hpp
#define | APOXI_STRING_TEST_SUITE

Functions

void | StringTest ()

Variables

const INT | string_max_buffer_size = 256

Define Documentation

#define _APOXI_String_hpp

Generated on Tue Jan 24 19:29:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/String.hpp Source File

Auxiliary/String.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(_APOXI_String_hpp)
00009 #define _APOXI_String_hpp
00012
00013 #include <stdarg.h>               // Variable argument list.
00014 #include <Kernel/Types.hpp>       // Standard types
00015 #include <Kernel/Os/OsStrLib.hpp>   // string includes
00016 #include <Auxiliary/StrUtil.hpp>  // String utility methods
00017
00018 class WString;  // Necessary forward declaration
00019
00020
00024 struct StrData {
00025     UINT8 m_refcount;
00026     UINT8 m_len;
00027     UINT16 m_bufsize;
00028     static CHAR *m_null_str;
00029     static StrData *m_null_strbuf;
00030
00032     void* operator new(UINT s_strbuf, UINT char_count);
00033
00035     void operator delete(void *p);
00036
00038     const CHAR* ToPtr() const { return (const CHAR*) (this + 1); }
00039
00041     CHAR* ToPtr() { return (CHAR*) (this + 1); }
00042
00044     UINT GetLength() const;
00045
00047     void ResetRefCount();
00048
00050     void SetLength(UINT n);
00051
00053     void SetBufSize(UINT n);
00054
00056     UINT GetBufSize() const { return m_bufsize; }
00057
00059     BOOLEAN HasMultipleRefs() const { return m_refcount > 0; }
00060
00062     BOOLEAN IncRefCount();
00063
00065     void DecRefCount();
00066
00069     BOOLEAN IsNullStr() const { return this == m_null_strbuf; }
00070
00072     static CHAR* GetNullStr() { return m_null_str; }
00073
00075     static StrData* FromPtr(CHAR *str) { return ((StrData *) str) - 1; }
00076 };
00077
00078
00081 const INT string_max_buffer_size = 256;
00082
00083
00088 class String
00089 {
00090     friend class WString;
00091
00092     public:
00094         String();
00095
00097         String(const CHAR * pchCopy);
00098
00100         String(const CHAR * pchCopy, UINT len);
00101
00103         String(const String & szCopy);
00104
00106         String(const String * szCopy);
00107
00109         String(INT32 val);
00110
00112         String(CHAR singlechar);
00113
00115         ~String();
00116
00123         const CHAR * GetCString() const  { return m_strdata; }
00124
00126         const UINT8 * GetData() const  { return (UINT8*) m_strdata; }
00127
00130         BOOLEAN Reserve(UINT nchars) { return Modify(nchars + 1, TRUE); }
00131
00134         BOOLEAN PreAlloc(UINT nchars) { return Modify(nchars + 1, FALSE); }
00135
00137         BOOLEAN IsEmpty() const { return *m_strdata == 0; }
00138
00140         INT GetMemSize() const;
00141
00143         INT GetLength() const;
00144
00146         INT GetSize() const;
00147
00150         String Substring(INT nStart, INT nLength = -1) const;
00151
00155         INT IndexOf(CHAR character, INT frompos = 0) const;
00156
00160         INT IndexOf(const String & searchstr, INT frompos = 0) const {
00161             return Find(searchstr.GetCString(), frompos, searchstr.GetLength());
00162         }
00163
00167         INT IndexOf(const CHAR * searchstr, INT frompos = 0) const {
00168             return Find(searchstr, frompos, strlen(searchstr));
00169         }
00170
00175         INT LastIndexOf(CHAR character, INT frompos = -1) const;
00176
00178         BOOLEAN StartsWith(const String & other) const;
00179
00181         BOOLEAN EndsWith(const String & other) const;
00182
00184         void StrCopy(const CHAR * buffer, INT len);
00185
00187         WString ToWString() const;
00188
00192         WString FromUtf8ToWString() const;
00193
00195         String& ToUpper();
00196
00198         String& ToLower();
00199
00201         void Swap(String & swapstr);
00202
00204         void Clear();
00205
00207         void Erase(INT frompos);
00208
00210         void Erase(INT from, INT nchars);
00211
00213         void Replace(INT pos, CHAR ch);
00214
00216         void Insert(INT pos, CHAR character);
00217
00219         void Insert(INT pos, const String & szInsert);
00220
00222         INT CompareTo(const String & szOther) const { return strcmp(m_strdata, szOther.GetCString()); };
00223
00225         INT CompareTo(const String & szOther, INT startpos, INT count = -1) const { return CompareTo(szOther.GetCString(), startpos, count); };
00226
00228         INT CompareTo(const CHAR * szOther) const { return strcmp(m_strdata, szOther); };
00229
00231         INT CompareTo(const CHAR * szOther, INT startpos, INT count = -1) const;
00232
00234         static INT Compare(const String &s1, const String &s2) { return strcmp(s1.GetCString(), s2.GetCString()); }
00235
00237         void Format(const CHAR * format, ...);
00238
00240         void VFormat(const CHAR * format, va_list args);
00241
00246         void Scan(const CHAR * format, ...) const;
00247
00249         BOOLEAN IsNumeric(INT number = -1) const { return IsNumeric(m_strdata, number); }
00250
00252         static BOOLEAN IsNumeric(const CHAR * string, INT number = -1);
00253
00260         operator const CHAR * () const  { return m_strdata; }
00261
00263         CHAR operator [] (INT nPos) const;
00264
00266         String & operator = (const String & szCopy);
00267
00269         String & operator = (const CHAR * pchCopy);
00270
00272         String operator + (const String & szConcat) const;
00273
00275         String operator + (const CHAR * pchConcat) const;
00276
00278         void operator += (const String & szConcat) { *this << szConcat; }
00279
00281         void operator += (const WString & szConcat) { *this << szConcat; }
00282
00284         void operator += (const CHAR * pchConcat) { *this << pchConcat; }
00285
00287         void operator += (const WCHAR * pchConcat) { *this << pchConcat; }
00288
00290         String & operator << (const String & right);
00291
00293         String & operator << (const String * right);
00294
00296         String & operator << (const WString & right);
00297
00299         String & operator << (const WString * right);
00300
00302         String & operator << (const CHAR * right);
00303
00305         String & operator << (const WCHAR * right);
00306
00308         String & operator << (INT32 number);
00309
00311         BOOLEAN operator == (const String & szcompare) const { return CompareTo(szcompare) == 0; }
00312
00314         BOOLEAN operator == (const CHAR * szcompare) const { return CompareTo(szcompare) == 0; }
00315
00317         BOOLEAN operator != (const String & szcompare) const { return CompareTo(szcompare) != 0; }
00318
00320         BOOLEAN operator < (const String & right) const { return strcmp(GetCString(), right.GetCString()) < 0; }
00321
00323         BOOLEAN operator <= (const String & right) const { return strcmp(GetCString(), right.GetCString()) <= 0; }
00324
00326         BOOLEAN operator > (const String & right) const { return strcmp(GetCString(), right.GetCString()) > 0; }
00327
00329         BOOLEAN operator >= (const String & right) const {
00330             return strcmp(GetCString(), right.GetCString()) >= 0; }
00331
00332 #if defined(APOXI_ENABLE_OBSOLETE_STRING_INTERFACE)
00333
00335         // Obsolete methods - should not be used anymore
00337
00339         const CHAR* c_str() const;
00340
00342         const UINT8* data() const;
00343
00345         BOOLEAN empty() const;
00346
00348         INT memsize() const;
00349
00351         INT length() const;
00352
00354         INT size() const;
00355
00357         WString getwstring() const;
00358
00361         String substr(INT nStart, INT nLength = -1) const;
00362
00366         INT find(CHAR character, INT frompos = 0) const;
00367
00371         INT find(const String & searchstr, INT frompos = 0) const;
00372
00376         INT reverse_find(CHAR character, INT frompos = -1) const;
00377
00379         INT compare(const String & szOther) const;
00380
00382         INT compare(const String & szOther, INT startpos, INT count = -1) const;
00383
00385         INT compare(const CHAR * szOther) const;
00386
00388         INT compare(const CHAR * szOther, INT startpos, INT count = -1) const;
00389
00391         BOOLEAN startswith(const String & other) const;
00392
00394         BOOLEAN endswith(const String & other) const;
00395
00397         void strcopy(const CHAR * buffer, INT len);
00398
00400         String& toupper();
00401
00403         String& tolower();
00404
00406         void swap(String & swapstr);
00407
00409         void clear();
00410
00412         void erase(INT frompos);
00413
00415         void insert(INT pos, CHAR character);
00416
00418         void insert(INT pos, const String & szInsert);
00419
00421         void format(const CHAR * format,...);
00422
00424         void vformat(const CHAR * format, va_list args);
00425
00427         BOOLEAN HasOnlyDigits(INT number = -1) const;
00428
00430         static BOOLEAN HasOnlyDigits(const CHAR * string, INT number = -1);
00431
00432 #endif // APOXI_ENABLE_OBSOLETE_STRING_INTERFACE
00433
00434     private:
00435         CHAR *m_strdata;
00436
00437         BOOLEAN Allocate(UINT nchars);
00438         BOOLEAN Modify(UINT new_nchars, BOOLEAN preserve_content = TRUE);
00439         BOOLEAN AttachTo(StrData *sd);
00440         void DetachFrom(StrData *sd) const;
00441
00442         StrData* GetStrData() const { return StrData::FromPtr(m_strdata); }
00443
00444         INT Find(const CHAR * searchstr, INT frompos, INT searchlen) const;
00445         BOOLEAN ConCat(const CHAR * cc_str, UINT cc_len);
00446         BOOLEAN ConCat(const WCHAR * cc_str, UINT cc_len);
00447
00448         static CHAR m_formatbuffer[string_max_buffer_size+1];
00449 };
00450
00451 #if !defined(APOXI_STRING_TEST_SUITE) && defined(APOXI_RTOS_WIN32)
00452 #define APOXI_STRING_TEST_SUITE
00453
00454 // Call for String test suite, only for WIN32 platform
00455 extern void StringTest();
00456
00457 #endif
00458
00460 #endif
00461
Generated on Tue Jan 24 14:48:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StringDataSink.cpp File Reference

Auxiliary/StringDataSink.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "StringDataSink.hpp"

Include dependency graph for StringDataSink.cpp:

Generated on Tue Jan 24 19:29:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StringDataSink.hpp File Reference

Auxiliary/StringDataSink.hpp File Reference

#include <Auxiliary/DataSink.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for StringDataSink.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StringDataSink

Defines

#define | StringDataSink_hpp

Define Documentation

#define StringDataSink_hpp

Generated on Tue Jan 24 19:29:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StringDataSink.hpp Source File

Auxiliary/StringDataSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(StringDataSink_hpp)
00009 #define StringDataSink_hpp
00012
00013 #include <Auxiliary/DataSink.hpp>
00014 #include <Auxiliary/String.hpp>
00017 class StringDataSink : public DataSink
00018 {
00019     private:
00020         typedef DataSink Base;
00021
00022     public:
00023         StringDataSink();
00024
00026         virtual ~StringDataSink();
00027
00034         virtual BOOLEAN Open();
00035
00041         virtual BOOLEAN Close();
00042
00047         virtual BOOLEAN IsOpen() const;
00048
00057         virtual UINT32 Write(const void HUGE *buf, UINT32 nbytes);
00058
00072         virtual UINT32 Write(UINT32 offset, const void HUGE *buf,
00073             UINT32 nbytes);
00074
00082         virtual BOOLEAN GetSize(UINT32 &size) const;
00083
00086         const String& GetString() { return m_string; }
00087
00088     private:
00089         String m_string;
00090         BOOLEAN m_is_open;
00091
00092 };
00093
00095 #endif  // StringDataSink_hpp
00096
Generated on Tue Jan 24 14:48:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StrPrintf.cpp File Reference

Auxiliary/StrPrintf.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Latin.hpp"
#include "StrUtil.hpp"
#include "Macros.hpp"
#include <string.h>

Include dependency graph for StrPrintf.cpp:

Defines

#define | DP_C_LDOUBLE 3
#define | DP_C_LONG 2
#define | DP_C_SHORT 1
#define | DP_F_MINUS (1 << 0)
#define | DP_F_NUM (1 << 3)
#define | DP_F_PLUS (1 << 1)
#define | DP_F_SPACE (1 << 2)
#define | DP_F_UNSIGNED (1 << 6)
#define | DP_F_UP (1 << 5)
#define | DP_F_ZERO (1 << 4)
#define | DP_S_BCK 2
#define | DP_S_CONV 7
#define | DP_S_DEFAULT 0
#define | DP_S_DONE 9
#define | DP_S_DOT 4
#define | DP_S_FLAGS 1
#define | DP_S_HEX 8
#define | DP_S_MAX 5
#define | DP_S_MIN 3
#define | DP_S_MOD 6
#define | MAX(p, q) ((p >= q) ? p : q)
#define | W_LATIN_ZERO 0

Functions

INT | ApoxiBDigitValue (CHAR c)
INT | ApoxiDDigitValue (CHAR c)
INT | ApoxiODigitValue (CHAR c)
INT | ApoxiXDigitValue (CHAR c)
INT | IsBDigit (CHAR c)
INT | IsDDigit (CHAR c)
INT | IsMinusSign (CHAR c)
INT | IsODigit (CHAR c)
INT | IsPlusSign (CHAR c)
INT | IsSign (CHAR c)
INT | IsWhiteSpace (CHAR c)
INT | IsXDigit (CHAR c)
INT | StrPrintf (CHAR *str, INT strSize, const CHAR *fmt,...)
INT | StrPrintf (CHAR *str, const CHAR *fmt,...)
void | strprintf (CHAR *buffer, const CHAR *format, va_list args,...)
void | strprintf (CHAR *buffer, INT bufSize, const CHAR *format, va_list args,...)

Define Documentation

#define DP_C_LDOUBLE 3

#define DP_C_LONG 2

#define DP_C_SHORT 1

#define DP_F_MINUS (1 << 0)

#define DP_F_NUM (1 << 3)

#define DP_F_PLUS (1 << 1)

#define DP_F_SPACE (1 << 2)

#define DP_F_UNSIGNED (1 << 6)

#define DP_F_UP (1 << 5)

#define DP_F_ZERO (1 << 4)

#define DP_S_BCK 2

#define DP_S_CONV 7

#define DP_S_DEFAULT 0

#define DP_S_DONE 9

#define DP_S_DOT 4

#define DP_S_FLAGS 1

#define DP_S_HEX 8

#define DP_S_MAX 5

#define DP_S_MIN 3

#define DP_S_MOD 6

#define MAX | ( | p,
 |  | q | ) | ((p >= q) ? p : q)

#define W_LATIN_ZERO 0

Function Documentation

INT ApoxiBDigitValue ( CHAR c )

INT ApoxiDDigitValue ( CHAR c )

INT ApoxiODigitValue ( CHAR c )

INT ApoxiXDigitValue ( CHAR c )

INT IsBDigit ( CHAR c )

INT IsDDigit ( CHAR c )

INT IsMinusSign ( CHAR c )

INT IsODigit ( CHAR c )

INT IsPlusSign ( CHAR c )

INT IsSign ( CHAR c )

INT IsWhiteSpace ( CHAR c )

INT IsXDigit ( CHAR c )

Generated on Tue Jan 24 19:29:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StrUtil.hpp File Reference

Auxiliary/StrUtil.hpp File Reference

#include <Kernel/Types.hpp>
#include <stdarg.h>

Include dependency graph for StrUtil.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_StringUtil_h

Functions

CHAR | CharToLower (CHAR ch)
CHAR | CharToUpper (CHAR ch)
void | strprintf (CHAR *buffer, INT bufSize, const CHAR *format, va_list args,...)
INT | StrPrintf (CHAR *str, INT strSize, const CHAR *fmt,...)
void | strprintf (CHAR *buffer, const CHAR *format, va_list args,...)
INT | StrPrintf (CHAR *str, const CHAR *fmt,...)

Define Documentation

#define APOXI_StringUtil_h

Generated on Tue Jan 24 19:36:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/StrUtil.hpp Source File

Auxiliary/StrUtil.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(APOXI_StringUtil_h)
00010 #define APOXI_StringUtil_h
00013
00014 #include <Kernel/Types.hpp>
00015 #include <stdarg.h>
00016
00017 inline CHAR CharToUpper(CHAR ch)
00018 {
00019     if ((ch >= 'a') && (ch <= 'z')) {
00020         ch = ch - 'a' + 'A';
00021     }
00022
00023     return ch;
00024 }
00025
00026 inline CHAR CharToLower(CHAR ch)
00027 {
00028     if ((ch >= 'A') && (ch <= 'Z')) {
00029         ch = ch - 'A' + 'a';
00030     }
00031
00032     return ch;
00033 }
00034
00035 extern "C" INT StrPrintf(CHAR *str, const CHAR *fmt, ...);
00036 extern "C" void strprintf(CHAR *buffer, const CHAR *format, va_list args, ...);
00037
00038 INT StrPrintf(CHAR *str, INT strSize, const CHAR *fmt, ...);
00039 void strprintf(CHAR *buffer, INT bufSize, const CHAR *format, va_list args, ...);
00040
00042 #endif // APOXI_StringUtil_h
00043
Generated on Tue Jan 24 14:48:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SwitchedRleCompression.cpp File Reference

Auxiliary/SwitchedRleCompression.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "SwitchedRleCompression.hpp"

Include dependency graph for SwitchedRleCompression.cpp:

Generated on Tue Jan 24 19:36:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SwitchedRleCompression.hpp File Reference

Auxiliary/SwitchedRleCompression.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for SwitchedRleCompression.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SwitchedRleCompression
class | SwitchedRleCompression::Context

Defines

#define | Apoxi_SwitchedRleCompression_hpp

Define Documentation

#define Apoxi_SwitchedRleCompression_hpp

Generated on Tue Jan 24 16:25:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/SwitchedRleCompression.hpp Source File

Auxiliary/SwitchedRleCompression.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2002 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SwitchedRleCompression_hpp)
00010 #define Apoxi_SwitchedRleCompression_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/BinData.hpp>
00016
00019 class SwitchedRleCompression {
00020     public:
00022         class Context {
00023             public:
00025                 Context();
00026
00028                 ~Context(); // not virtual
00029
00030             private:
00031                 friend class SwitchedRleCompression;
00032
00034                 void SetData (const BinData* data) { m_data = data; }
00035
00037                 const BinData* GetData() { return m_data; }
00038
00040                 void SetOffset(UINT32 offset) { m_offset = offset; }
00041
00043                 UINT32 GetOffset() { return m_offset; }
00044
00045
00046
00047                 enum {
00048                     mode_lit,
00049                     mode_fill
00050                 } m_mode;
00051                 BOOLEAN     m_continue;     // determines wheater to continue in last mode (more than 255 same bytes) or not
00052
00053                 union {
00054                     UINT8  m_lastlit8;
00055                     UINT16 m_lastlit16;
00056                 };
00057
00058                 UINT8       m_ch;           // character that has been read (compression)
00059                 UINT8       m_buff[256];
00060                 UINT8       *m_buff_p;      // buffer for compression and pointer to actual position    (compression)
00061                 INT         m_prev;         // last character - used for comparison (compression)
00062                 INT         m_pcount;       // count of same characters (compression)
00063                 UINT        m_bindex;       // buffer index (compression)
00064                 UINT        m_bytes_left;   // bytes left that must be written in next run (compression)
00065
00066                 UINT        m_lit_bytes;    // how many lit bytes are left  (decompression)
00067                 UINT        m_fill_bytes;   // how many fill bytes are left (decompression)
00068                 const BinData* m_data;
00069                 UINT32      m_offset;
00070                 UINT32      m_idx;
00071         };
00072
00074         static BOOLEAN InitContext(const BinData* src, UINT32 offset, Context& context);
00075
00077         static BOOLEAN DecompressBlock(const Context& context, UINT8 *dest, UINT32& block_size);
00078
00080         static BOOLEAN CompressBlock(const Context& context, UINT8 *dest, UINT32& block_size);
00081
00082     private:
00083
00084         static UINT16 ReadUINT16(UINT8* src, UINT32 idx);
00085
00086         static UINT8  ReadUINT8(UINT8* src, UINT32 idx);
00087
00088         SwitchedRleCompression();
00089         ~SwitchedRleCompression();
00090 };
00091
00093 #endif //Apoxi_SwitchedRleCompression_hpp
00094
00095
Generated on Tue Jan 24 14:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ThreadSafeProvider.cpp File Reference

Auxiliary/ThreadSafeProvider.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "ThreadSafeProvider.hpp"

Include dependency graph for ThreadSafeProvider.cpp:

Generated on Tue Jan 24 19:36:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ThreadSafeProvider.hpp File Reference

Auxiliary/ThreadSafeProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>
#include <Auxiliary/Protector.hpp>

Include dependency graph for ThreadSafeProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ThreadSafeProvider

Defines

#define | Apoxi_ThreadSafeProvider_hpp

Define Documentation

#define Apoxi_ThreadSafeProvider_hpp

Generated on Tue Jan 24 19:36:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/ThreadSafeProvider.hpp Source File

Auxiliary/ThreadSafeProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ThreadSafeProvider_hpp)
00011 #define Apoxi_ThreadSafeProvider_hpp
00014
00015 #include <Auxiliary/Provider.hpp>
00016 #include <Auxiliary/Protector.hpp>
00017
00024 class ThreadSafeProvider : public Provider {
00025     typedef Provider Base;
00026
00027     public:
00029         ThreadSafeProvider();
00030
00033         ThreadSafeProvider(Protector *protector);
00034
00036         virtual ~ThreadSafeProvider();
00037
00039         void Init(Protector *protector);
00040
00042         virtual BOOLEAN Lock();
00043
00045         virtual BOOLEAN Unlock();
00046
00047     private:
00048         Protector   *m_protector;
00049 };
00050
00052 #endif  // Apoxi_ThreadSafeProvider_hpp
00053
00054
Generated on Tue Jan 24 14:48:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Time.cpp File Reference

Auxiliary/Time.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Time.hpp"
#include <Devices/Device.hpp>
#include <Gui/Locale.hpp>

Include dependency graph for Time.cpp:

Generated on Tue Jan 24 19:36:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Time.hpp File Reference

Auxiliary/Time.hpp File Reference

#include <Auxiliary/WString.hpp>

Include dependency graph for Time.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Time
struct | Time::Persist

Defines

#define | Apoxi_Time_hpp

Typedefs

typedef Time::Format | TimeFormat
TimeFormat type is identical to the Format type inside the time class.

Define Documentation

#define Apoxi_Time_hpp

Generated on Tue Jan 24 19:37:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Time.hpp Source File

Auxiliary/Time.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Time_hpp)
00010 #define Apoxi_Time_hpp
00013
00014 #include <Auxiliary/WString.hpp>
00015
00018 class Time {
00019     public:
00021         enum Format {
00023             TimeHM,
00025             TimeHMS
00026         };
00027
00028         // struct must not be larger then 32 bit because of DataItem usage
00029         struct Persist {
00030             UINT8 m_hour;
00031             UINT8 m_minute;
00032             UINT8 m_second;
00033         };
00034
00036         Time();
00037
00039         Time(INT hour, INT minute, INT second = 0, INT millisecond = 0);
00040
00042         Time(const Persist & tstruct);
00043
00045         void SetHour(INT hour);
00046
00048         INT GetHour() const { return m_hour; }
00049
00051         void SetMinute(INT minute);
00052
00054         INT GetMinute() const { return m_minute; }
00055
00057         void SetSecond(INT second);
00058
00060         INT GetSecond() const { return m_second; }
00061
00063         void SetMillisecond(INT millisecond);
00064
00066         INT GetMillisecond() const { return m_millisecond; }
00067
00069         WString GetWString(Format time_format) const;
00070
00072         WString GetWString(const WCHAR *format) const;
00073
00075         BOOLEAN operator==(const Time &time) const;
00076
00078         BOOLEAN operator!=(const Time &time) const;
00079
00081         BOOLEAN operator<(const Time &time) const;
00082
00084         BOOLEAN operator<=(const Time &time) const;
00085
00087         BOOLEAN operator>(const Time &time) const;
00088
00090         BOOLEAN operator>=(const Time &time) const;
00091
00092         static INT Compare(const Time& t1, const Time& t2);
00093
00094         static INT Compare(const Time::Persist & t1, const Time::Persist & t2);
00095
00097         void operator<<(const Time::Persist & time);
00099         void operator>>(Time::Persist & time) const;
00100
00101     private:
00102         UINT8 m_hour;
00103         UINT8 m_minute;
00104         UINT8 m_second;
00105         UINT16 m_millisecond;
00106
00107         template <class T>
00108         T AdjustRange(T value, T range) {
00109             if (value < 0)
00110                 value = 0;
00111             else if (value > range)
00112                 value = range;
00113
00114             return value;
00115         }
00116 };
00117
00119 typedef Time::Format TimeFormat;
00120
00122 #endif  // Apoxi_Time_hpp
00123
00124
Generated on Tue Jan 24 14:48:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TimeSpan.cpp File Reference

Auxiliary/TimeSpan.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "TimeSpan.hpp"

Include dependency graph for TimeSpan.cpp:

Generated on Tue Jan 24 19:37:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TimeSpan.hpp File Reference

Auxiliary/TimeSpan.hpp File Reference

#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>

Include dependency graph for TimeSpan.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TimeSpan

Defines

#define | Apoxi_TimeSpan_h

Define Documentation

#define Apoxi_TimeSpan_h

Generated on Tue Jan 24 19:38:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TimeSpan.hpp Source File

Auxiliary/TimeSpan.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_TimeSpan_h)
00011 #define Apoxi_TimeSpan_h
00014
00015 #include <Auxiliary/Date.hpp>
00016 #include <Auxiliary/Time.hpp>
00017
00020 class TimeSpan
00021 {
00022     public:
00024         TimeSpan() : m_seconds(0) { }
00026         TimeSpan(UINT32 seconds) : m_seconds(seconds) { }
00029         TimeSpan(UINT hours, UINT minutes, UINT seconds = 0);
00030
00032         UINT32 GetAbsoluteSeconds() const { return m_seconds; }
00034         UINT32 GetAbsoluteMinutes() const;
00036         UINT32 GetAbsoluteHours() const;
00038         UINT32 GetAbsoluteDays() const;
00040         UINT32 GetAbsoluteWeeks() const;
00041
00043         void SetAbsoluteSeconds(UINT32 seconds) { m_seconds = seconds; }
00045         void SetAbsoluteMinutes(UINT minutes);
00047         void SetAbsoluteHours(UINT hours);
00049         void SetAbsoluteDays(UINT days);
00051         void SetAbsoluteWeeks(UINT days);
00052
00054         UINT GetHour() const;
00056         UINT GetMinute() const;
00058         UINT GetSecond() const;
00059
00060     private:
00061         UINT32 m_seconds;
00062 };
00063
00064
00066 #endif
00067
00068
Generated on Tue Jan 24 14:48:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TimeZone.cpp File Reference

Auxiliary/TimeZone.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "TimeZone.hpp"

Include dependency graph for TimeZone.cpp:

Generated on Tue Jan 24 19:38:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TimeZone.hpp File Reference

Auxiliary/TimeZone.hpp File Reference

#include <Auxiliary/WString.hpp>

Include dependency graph for TimeZone.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TimeZone

Defines

#define | Apoxi_TimeZone_hpp

Define Documentation

#define Apoxi_TimeZone_hpp

Generated on Tue Jan 24 19:38:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TimeZone.hpp Source File

Auxiliary/TimeZone.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TimeZone_hpp)
00010 #define Apoxi_TimeZone_hpp
00013
00014 #include <Auxiliary/WString.hpp>
00015
00016 class TimeZone {
00017     public:
00018         enum {
00019             InvalidOffset = 0xffff
00020         };
00021
00022         enum DstIndication {
00023             StandardTime = 0,
00024             Plus1Hour = 1,
00025             Plus2Hours = 2,
00026             InvalidDst = 3
00027         };//DstIndication
00028
00030         TimeZone();
00032         TimeZone(INT offset, DstIndication dst_ind) :
00033             m_offset(((offset >= -48) && (offset <= 51)) ? offset : InvalidOffset),
00034             m_dst_ind((dst_ind <= 2) ? dst_ind:InvalidDst) {}
00035
00037         TimeZone(const TimeZone &tz);
00039         ~TimeZone() {}
00040
00042         BOOLEAN IsOffsetInvalid() const { return m_offset == InvalidOffset; }
00044         BOOLEAN IsDstIndInvalid() const { return m_dst_ind == InvalidDst; }
00046         void SetOffset(INT offset) { m_offset = ((offset >= -48) && (offset <= 51)) ? offset : InvalidOffset; }
00048         INT  GetOffset() const { return m_offset; }
00050         void SetDstInd(DstIndication dst_ind) { m_dst_ind = ((dst_ind <= 2)) ? dst_ind : InvalidDst; }
00052         DstIndication GetDstInd() const { return m_dst_ind; }
00054         void SetTimeZone(const TimeZone &tz);
00055
00061         WString Format(const WCHAR* wchr_format= L"GMT: %o DST: %d",
00062                        const WCHAR* wchr_invalid_offset= L"n/a",
00063                        const WCHAR* wchr_invalid_dst= L"n/a") const;
00065         BOOLEAN operator==(const TimeZone &tz) const { return (m_offset == tz.m_offset && m_dst_ind == tz.m_dst_ind); }
00067         BOOLEAN operator!=(const TimeZone &tz) const { return ! operator==(tz); }
00068
00069     private:
00072          INT m_offset;
00073
00076          DstIndication m_dst_ind;
00077
00078 };//class TimeZone
00079
00081 #endif
00082
00083
Generated on Tue Jan 24 14:48:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TriggerTimer.hpp File Reference

Auxiliary/TriggerTimer.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/Timer.hpp>

Include dependency graph for TriggerTimer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TriggerTimer< T >

Defines

#define | Apoxi_TriggerTimer_hpp

Define Documentation

#define Apoxi_TriggerTimer_hpp

Generated on Tue Jan 24 19:39:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TriggerTimer.hpp Source File

Auxiliary/TriggerTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TriggerTimer_hpp)
00011 #define Apoxi_TriggerTimer_hpp
00014
00015 #include <Auxiliary/Macros.hpp>
00016 #include <Kernel/Timer.hpp>
00017
00018 template <class T> class TriggerTimer : public Timer {
00019     typedef Timer Base;
00020
00021     public:
00022         TriggerTimer();
00023         TriggerTimer(T *t, UINT32 timeout, BOOLEAN autotimer = FALSE);
00024         virtual ~TriggerTimer();
00025
00026         void Init(T *t, UINT32 timeout, BOOLEAN autotimer = FALSE);
00027
00028     protected:
00029         virtual void OnTimer();
00030
00031     private:
00032         T   *m_t;
00033 };
00034
00035 /*  ------------------------------------------------------------------------
00036     TriggerTimer
00037     ------------------------------------------------------------------------ */
00038 template <class T>
00039 TriggerTimer<T>::TriggerTimer() :
00040     m_t(0)
00041 {
00042 }   // TriggerTimer
00043
00044 /*  ------------------------------------------------------------------------
00045     TriggerTimer
00046     ------------------------------------------------------------------------ */
00047 template <class T>
00048 TriggerTimer<T>::TriggerTimer(T *t, UINT32 timeout, BOOLEAN autotimer) :
00049     Base(timeout, autotimer),
00050     m_t(t)
00051 {
00052 }   // TriggerTimer
00053
00054 /*  ------------------------------------------------------------------------
00055     ~TriggerTimer
00056     ------------------------------------------------------------------------ */
00057 template <class T>
00058 TriggerTimer<T>::~TriggerTimer()
00059 {
00060     m_t = 0;
00061 }   // ~TriggerTimer
00062
00063 /*  ------------------------------------------------------------------------
00064     Init
00065     ------------------------------------------------------------------------ */
00066 template <class T>
00067 void TriggerTimer<T>::Init(T *t, UINT32 timeout, BOOLEAN autotimer)
00068 {
00069     Base::Init(timeout, autotimer);
00070     m_t = t;
00071 }   // Init
00072
00073 /*  ------------------------------------------------------------------------
00074     OnTimer
00075     ------------------------------------------------------------------------ */
00076 template <class T>
00077 void TriggerTimer<T>::OnTimer()
00078 {
00079     ASSERT(m_t != 0);
00080     m_t->OnTimer();
00081 }   // OnTimer
00082
00084 #endif  // Apoxi_TriggerTimer_hpp
00085
00086
Generated on Tue Jan 24 14:48:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TypeOfAddress.cpp File Reference

Auxiliary/TypeOfAddress.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "TypeOfAddress.hpp"
#include "BitField.hpp"

Include dependency graph for TypeOfAddress.cpp:

Generated on Tue Jan 24 19:39:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TypeOfAddress.hpp File Reference

Auxiliary/TypeOfAddress.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>

Include dependency graph for TypeOfAddress.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TypeOfAddress
Type-of-Address (TON/NPI) - 3GPP TS 23.040 V5.1.0 [9.2.3.9]. More...

Defines

#define | Auxiliary_TypeOfAddress_hpp

Define Documentation

#define Auxiliary_TypeOfAddress_hpp

Generated on Tue Jan 24 19:40:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/TypeOfAddress.hpp Source File

Auxiliary/TypeOfAddress.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003 ------------------------------------------------------------------------
00004 This document
00005 contains proprietary information belonging to COMNEON. Passing on and copying of
00006 this document, use and communication of its contents is not permitted without
00007 prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009 #if !defined(Auxiliary_TypeOfAddress_hpp)
00010 #define Auxiliary_TypeOfAddress_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Auxiliary/BitField.hpp>
00014
00015
00016 /*  ========================================================================
00017     Type-of-Address (TON/NPI) - 3GPP TS 23.040 V5.1.0 [9.2.3.9]
00018     ========================================================================*/
00020 class TypeOfAddress {
00021     public:
00022         // marks the invalidity of the protocol-identifier
00023         enum {
00025             InvalidTypeOfAddress = 0x00
00026         };
00027
00029         enum TypeOfNumber { // do not change order
00031             UnknownTypeOfNumber = 0,
00033             InternationalNumber,
00035             NationalNumber,
00037             NetworkSpecificNumber,
00039             SubscriberNumber,
00041             Alphanumeric,
00043             AbbreviatedNumber,
00045             ReservedTypeOfNumber,
00047             InvalidTypeOfNumber
00048         };
00049
00051         enum NumberingPlanIdentification {
00053             UnknownNumberingPlan,
00055             TelephoneNumberingPlan,
00057             DataNumberingPlan,
00059             TelexNumberingPlan,
00061             ServiceCentreSpecificPlan,
00063             NationalNumberingPlan,
00065             PrivateNumberingPlan,
00067             ErmesNumberingPlan,
00069             ReservedNumberingPlan,
00071             InvalidNumberingPlan,
00072         };
00073
00075         TypeOfAddress();
00077         TypeOfAddress(UINT8 incoming_byte);
00078
00080         UINT8 Get() const { return (m_bit_field.Get()); }
00081
00083         TypeOfNumber GetTypeOfNumber() const;
00085         void SetTypeOfNumber(TypeOfNumber type_of_number);
00086
00088         NumberingPlanIdentification GetNumberingPlanIdentification() const;
00090         void SetNumberingPlanIdentification(NumberingPlanIdentification numbering_plan_identification);
00091
00093         BOOLEAN Is3aExisting() const {
00094             return (! m_bit_field.GetBit(7));
00095         }
00097         void Set3aNotExists() {
00098             m_bit_field.SetTrue(7);
00099         }
00101         void Set3aExists() {
00102             m_bit_field.SetFalse(7);
00103         }
00104
00106         void Clear() { m_bit_field.Set(InvalidTypeOfAddress); }
00107
00108     private:
00109         BitField8 m_bit_field;
00110 };
00111
00112
00113 #endif  // Auxiliary_TypeOfAddress_hpp
00114
00115
Generated on Tue Jan 24 14:48:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Unicode.cpp File Reference

Auxiliary/Unicode.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "Unicode.hpp"
#include "WStrUtil.hpp"

Include dependency graph for Unicode.cpp:

Functions

INT | UnicodeFromUtf8 (WCHAR *unicode, const CHAR *utf8)
CHAR * | UnicodeGetUtf8 (const CHAR *p, WCHAR *result)
INT | UnicodeIndexToOffset (const CHAR *src, INT index)
CHAR * | UnicodeLastUtf8 (const CHAR *p)
CHAR * | UnicodeNextUtf8 (const CHAR *p)
INT | UnicodeOffsetToIndex (const CHAR *src, INT offset)
CHAR * | UnicodePreviousUtf8 (const CHAR *start, const CHAR *p)
INT | UnicodePutUtf8 (WCHAR c, CHAR *outbuf)
INT | UnicodeStrcmp (const WCHAR *str1, const WCHAR *str2)
UINT | UnicodeStringWidth (const CHAR *p)
UINT | UnicodeStrlen (const WCHAR *unicode, INT max)
INT | UnicodeStrncmp (const WCHAR *str1, const WCHAR *str2, INT n)
CHAR * | UnicodeStrncpy (CHAR *dest, const CHAR *src, UINT n)
WCHAR * | UnicodeStrstr (const WCHAR *str, const WCHAR *sub)
INT | UnicodeToUtf8 (CHAR *utf8, const WCHAR *unicode)
CHAR * | UnicodeUtf8Strchr (const CHAR *p, WCHAR c)
UINT | UnicodeUtf8Strlen (const CHAR *p, INT max)
INT | UnicodeUtf8Validate (const CHAR *str, INT max_len, const CHAR **end)
INT | Utf8FromUnicode (CHAR *utf8, const WCHAR *unicode)
INT | Utf8ToUnicode (WCHAR *unicode, const CHAR *utf8)
Generated on Tue Jan 24 19:40:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Unicode.hpp File Reference

Auxiliary/Unicode.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/StrUtil.hpp>

Include dependency graph for Unicode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_UNICODE_EOF (WCHAR)0xffff
#define | Auxiliary_Unicode_hpp
#define | UTF8_COMPUTE(Char, Mask, Len)
#define | UTF8_GET(Result, Chars, Count, Mask, Len)

Functions

INT | UnicodeFromUtf8 (WCHAR *unicode, const CHAR *utf8)
CHAR * | UnicodeGetUtf8 (const CHAR *p, WCHAR *result)
INT | UnicodeIndexToOffset (const CHAR *src, INT index)
CHAR * | UnicodeLastUtf8 (const CHAR *p)
CHAR * | UnicodeNextUtf8 (const CHAR *p)
INT | UnicodeOffsetToIndex (const CHAR *src, INT offset)
CHAR * | UnicodePreviousUtf8 (const CHAR *start, const CHAR *p)
INT | UnicodePutUtf8 (WCHAR c, CHAR *outbuf)
INT | UnicodeStrcmp (const WCHAR *str1, const WCHAR *str2)
UINT | UnicodeStringWidth (const CHAR *p)
UINT | UnicodeStrlen (const WCHAR *unicode, INT max)
INT | UnicodeStrncmp (const WCHAR *str1, const WCHAR *str2, INT n)
CHAR * | UnicodeStrncpy (CHAR *dest, const CHAR *src, UINT n)
WCHAR * | UnicodeStrstr (const WCHAR *str, const WCHAR *sub)
INT | UnicodeToUtf8 (CHAR *utf8, const WCHAR *unicode)
CHAR * | UnicodeUtf8Strchr (const CHAR *p, WCHAR c)
UINT | UnicodeUtf8Strlen (const CHAR *p, INT max)
INT | UnicodeUtf8Validate (const CHAR *str, INT max_len, const CHAR **end)
INT | Utf8FromUnicode (CHAR *utf8, const WCHAR *unicode)
INT | Utf8ToUnicode (WCHAR *unicode, const CHAR *utf8)

Define Documentation

#define Auxiliary_Unicode_hpp

Generated on Tue Jan 24 19:40:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Unicode.hpp Source File

Auxiliary/Unicode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_Unicode_hpp)
00011 #define Auxiliary_Unicode_hpp
00012
00015
00016 /*
00017   =============================================================================
00018   APOXI Library for UNICODE to/from UTF8 conversion.
00019   =============================================================================
00020   UnicodeNextUtf8      Searches the beginning of the next UTF-8 character
00021                        in the UTF-8 string.
00022
00023   UnicodePreviousUtf8  Searches the beginning of the previous UTF-8 character
00024                        in the UTF-8 string
00025
00026   UnicodeUtf8Strlen    Calculates the length of the UTF-8 string with limited
00027                        length.
00028
00029   UnicodeLastUtf8      Searches for the last UTF-8 character in UTF-8 string.
00030   UnicodeGetUtf8       Fetch the next UTF-8 character from P into result and
00031                        convert it into the UNICODE value.
00032   UnicodePutUtf8       Convert a single UNICODE character to UTF-8 character
00033                        and send it to UTF-8 output buffer.
00034   UnicodeUtf8Strchr    Finds the first occurrence of the UNICODE character in
00035                        the UTF-8 string.
00036   UnicodeOffsetToIndex Searches for beginning of offset of UTF-8 character in
00037                        UTF-8 string and returns its offset in bytes.
00038   UnicodeIndexToOffset Searches for number of UTF-8 characters in UTF-8
00039                        string in first offset bytes.
00040
00041   UnicodeToUtf8        Convert UNICODE string to UTF-8 string and return length
00042                        counted including terminating null-character.
00043   Utf8ToUnicode        Convert UTF-8 string to UNICODE string and return length
00044                        counted including terminating null-character.
00045
00046   UnicodeFromUtf8      Convert UTF-8 string to UNICODE string and return length
00047                        counted excluding terminating null-character.
00048   Utf8FromUnicode      Convert UNICODE string to UTF-8 string and return length
00049                        counted excluding terminating null-character.
00050
00051   UnicodeUtf8Validate  Validates UTF-8 encoded text.
00052
00053   UnicodeStrlen        Find length of UNICODE string.
00054   UnicodeStringWidth   Same as UnicodeStrlen.
00055   UnicodeStrncpy       Copies a given number of bytes from one string into
00056                        another.
00057   UnicodeStrcmp        Compares a portion of one UNICODE string to a portion
00058                        of another with case sensitivity.
00059   UnicodeStrncmp       Compares a portion of one UNICODE string to a portion
00060                        of another with case sensitivity.
00061   UnicodeStrstr        Scans UNICODE string for the occurrence of a given
00062
00063
00064   Common warning:
00065
00066   The caller and his/her C/C++ compiler are responsible for proper arguments
00067   boundary on the stack by calling some function; on some systems (depending on
00068   target processor), access to an element bigger than a byte (short, integer, long,
00069   etc.) and located on an odd address, can cause address error exception (or even
00070   something worse).
00071
00072   =============================================================================
00073 */
00074
00075 #include  <Kernel/Types.hpp>
00076 #include  <Auxiliary/StrUtil.hpp>
00077
00078 #define APOXI_UNICODE_EOF (WCHAR)0xffff
00079
00080 /*
00081       UnicodeToUtf8
00082 Description:
00083         Scans UNICODE string buffer and converts UNICODE characters into UTF-8
00084         characters and copies UTF-8 characters to destination buffer.
00085         Destination buffer must have enough space available.
00086 Arguments:
00087           utf8      Pointer to destination memory buffer receiving converted UNICODE.
00088                     If this pointer is 0 (NULL), no conversion will be done but the
00089                     number of UTF-8 characters needed for conversion is returned
00090                     (including null-terminator).
00091           unicode   Pointer to a memory buffer holding text in UNICODE data format,
00092                     must be null-terminated.
00093 Returns:
00094         The number of UTF-8 characters generated (including null-terminator).
00095 Notes:
00096         Be aware that the generated UNICODE string will be null-terminated. The
00097         difference to the function "Utf8FromUnicode" is therefore just the counting
00098         of the length, the string conversion and generation is the same.
00099 */
00100 INT UnicodeToUtf8(CHAR *utf8, const WCHAR *unicode);
00101
00102
00103 /*
00104       Utf8ToUnicode
00105 Description:
00106         Scans UTF-8 string buffer and converts UTF-8 characters into UNICODE
00107         characters and copies UNICODE characters to destination buffer.
00108         Destination buffer must have enough space available.
00109 Arguments:
00110           unicode   Pointer to destination memory buffer receiving converted UTF-8.
00111                     If this pointer is 0 (NULL), no conversion will be done but the
00112                     number of UNICODE characters needed for conversion is returned
00113                     (including null-terminator).
00114           utf8      Pointer to a memory buffer holding text in UTF-8 data format,
00115                     must be null-terminated.
00116 Returns:
00117         The number of UNICODE characters generated (including null-terminator).
00118 Notes:
00119         Be aware that the generated UTF-8 string will be null-terminated. The
00120         difference to the function "UnicodeFromUtf8" is therefore just the counting
00121         of the length, the string conversion and generation is the same.
00122 */
00123 INT Utf8ToUnicode(WCHAR *unicode, const CHAR *utf8);
00124
00125
00126 /*
00127       UnicodeFromUtf8
00128 Description:
00129         Scans UTF-8 string buffer and converts UTF-8 characters into UNICODE
00130         characters and copies UNICODE characters to destination buffer.
00131         Destination buffer must have enough space available.
00132 Arguments:
00133           unicode   Pointer to destination memory buffer receiving converted UTF-8.
00134                     If this pointer is 0 (NULL), no conversion will be done but the
00135                     number of UNICODE characters needed for conversion is returned
00136                     (excluding null-terminator).
00137           utf8      Pointer to a memory buffer holding text in UTF-8 data format,
00138                     must be null-terminated.
00139 Returns:
00140         The number of UNICODE characters generated (excluding null-terminator).
00141 Notes:
00142         Be aware that the generated UNICODE string will be null-terminated. The
00143         difference to the function "Utf8ToUnicode" is therefore just the counting
00144         of the length, the string conversion and generation is the same.
00145 */
00146 INT UnicodeFromUtf8(WCHAR *unicode, const CHAR *utf8);
00147
00148
00149 /*
00150       Utf8FromUnicode
00151 Description:
00152         Scans UNICODE string buffer and converts UNICODE characters into UTF-8
00153         characters and copies UTF-8 characters to destination buffer.
00154         Destination buffer must have enough space available.
00155 Arguments:
00156           utf8      Pointer to destination memory buffer receiving converted UNICODE.
00157                     If this pointer is 0 (NULL), no conversion will be done but the
00158                     number of UTF-8 characters needed for conversion is returned
00159                     (excluding null-terminator).
00160           unicode   Pointer to a memory buffer holding text in UNICODE data format,
00161                     must be null-terminated.
00162 Returns:
00163         The number of UTF-8 characters generated (excluding null-terminator).
00164 Notes:
00165         Be aware that the generated UTF-8 string will be null-terminated. The
00166         difference to the function "UnicodeToUtf8" is therefore just the counting
00167         of the length, the string conversion and generation is the same.
00168 */
00169 INT Utf8FromUnicode(CHAR *utf8, const WCHAR *unicode);
00170
00171
00172 /*
00173       UnicodeUtf8Validate
00174 Description:
00175         Validates UTF-8 encoded text. str is the text to validate. If str is
00176         null-terminated, then max_len can be -1, otherwise max_len should be
00177         the number of bytes to validate. If end is non-NULL, then the end of
00178         the valid range will be stored there (i.e. the address of the first
00179         invalid byte if some bytes were invalid, or the end of the text being
00180         validated otherwise).
00181         Many routines valid UTF8 as input. So data read from a file or the
00182         network should be checked with this function before doing
00183         anything else with it.
00184 Arguments:
00185           str     a pointer to character data
00186         max_len max bytes to validate, or -1 to go until null
00187         end     return location for end of valid data
00188 Returns:
00189         TRUE if the text was valid UTF-8, otherwise FALSE.
00190 */
00191 INT UnicodeUtf8Validate(const CHAR *str, INT max_len, const CHAR **end);
00192
00193
00194 /*
00195       UnicodePreviousUtf8
00196 Description:
00197         Searches the beginning of the previous UTF-8 character in the UTF-8
00198         string.
00199 Arguments:
00200           start     pointer to the beginning of the UTF-8 string.
00201           p         pointer insidee the UTF-8 string.
00202 Returns:
00203         Pointer to the beginning of the UTF-8 character
00204         If P points to the middle of an UTF-8 character, this function
00205         returns a pointer to the first byte of the character.
00206         If P points to the start of an UTF-8 character, this function returns a
00207         pointer to the first byte of the previous character.
00208         If P does not point to an UTF-8 character, NULL is returned.
00209         START bounds the search, in no case will a value before START be
00210         returned.
00211         If p does not point inside UTF-8 string the result is false
00212 */
00213 CHAR *UnicodePreviousUtf8 (const CHAR *start, const CHAR *p);
00214
00215
00216 /*
00217     UnicodeNextUtf8
00218 Description:
00219         Searches the beginning of the next UTF-8 character in the UTF-8 string.
00220 Arguments:
00221           p         pointer inside the UTF-8 string.
00222 Returns:
00223         Returns pointer to the next UTF-8 character in the string of the UTF-8
00224         characters
00225         Return pointer to the first byte of the next UTF-8 character after P.
00226         This works whether P points to the start or to the middle of an UTF-8
00227         character.
00228         P is assumed to be null-terminated.
00229         If p does not point inside the UTF-8 string, the result is false
00230 */
00231 CHAR *UnicodeNextUtf8 (const CHAR *p);
00232
00233
00234 /*
00235     UnicodeUtf8Strlen
00236 Description:
00237         Calculates the length of the UTF-8 string with limited length
00238 Arguments:
00239           p         pointer to a valid UTF-8 character.
00240           max       limited number of characters for the search function.
00241 Returns:
00242         Return the length, in characters, of p, an UTF-8 string.  Max is the
00243         maximum number of bytes to examine.  If max is less than 0, then P is
00244         assumed to be null-terminated.
00245 */
00246 UINT  UnicodeUtf8Strlen (const CHAR *p, INT max);
00247
00248
00249 /*
00250       UnicodeStrlen
00251 Description:
00252         Find length of UNICODE string.
00253 Arguments:
00254         unicode pointer to the start of an UTF-8 string.
00255         max     the maximum number of WCHAR objects to examine.
00256 Returns:
00257         Function returns length of an UNICODE string in  WCHAR characters
00258 */
00259 UINT  UnicodeStrlen(const WCHAR *unicode, INT max);
00260
00261
00262 /*
00263     UnicodeStringWidth
00264 Description:
00265         Calculates the length of the UTF-8 string with no length limitation
00266 Arguments:
00267           p         pointer to a valid UTF-8 character.
00268 Returns:
00269         Return the length, in characters, of p, an UTF-8 string.  Max is the
00270         maximum number of bytes to examine.  If max is less than 0, then P is
00271         assumed to be null-terminated.
00272         Returns the visual width, in character-size units, of P, a string. This
00273         value may be used for tabulation.
00274 */
00275 UINT  UnicodeStringWidth(const CHAR *p);
00276
00277
00278 /*
00279     UnicodeGetUtf8
00280 Description:
00281         Fetch the next UTF-8 character from P into result and convert it into
00282         the UNICODE value.
00283 Arguments:
00284           p         pointer to the valid UTF-8 character.
00285           result    pointer to the location into which the UNICODE value of the
00286                   UTF-8 character returns.
00287 Returns:
00288         If the next character is a valid UTF-8 character, rasult holds UNICODE
00289         value of UTF-8 character. If the character is not valid, result holds -1.
00290         The function returns a pointer to the start of the next UTF-8 character.
00291         If p is not well formed, it will return NULL.
00292 */
00293 CHAR *UnicodeGetUtf8(const CHAR *p, WCHAR *result);
00294
00295
00296 /*
00297     UnicodePutUtf8
00298 Description:
00299         Convert a single UNICODE CHAR to UTF-8 CHAR and send it to UTF-8 output
00300         buffer.
00301 Arguments:
00302           c         ISO10646 character code.
00303           outbuf    output buffer must have at least 6 bytes of space. If %NULL,
00304                   the length will be computed and returned and nothing will be
00305                   written to @out.
00306 Returns:
00307         number of bytes written
00308 */
00309 INT UnicodePutUtf8(WCHAR c, CHAR *outbuf);
00310
00311
00312 /*
00313     UnicodeOffsetToIndex
00314 Description:
00315         Function searches for begining of offset of UTF-8 character in UTF-8
00316         string and returns its offset in bytes
00317 Arguments:
00318           p         pointer to a valid UTF-8 string.
00319           offset    offset of UTF-8 character in UTF-8 string.
00320 Returns:
00321         offset of UTF-8 character in UTF-8 string in bytes, if offset is within
00322         the range of UTF-8 string.
00323         If offset is biger then size of UTF-8 string in UTF-8 characters,
00324         function returns size of UTF-8 string in bytes
00325 */
00326 INT UnicodeOffsetToIndex(const CHAR *src, INT offset);
00327
00328
00329 /*
00330     UnicodeIndexToOffset
00331 Description:
00332         Function searches for number of UTF-8 characters in UTF-8 string in
00333         first offset bytes.
00334 Arguments:
00335           p         pointer to a valid UTF-8 character.
00336           offset    offset in UTF-8 string in bytes.
00337 Returns:
00338         number of UTF-8 characters in first offset bytes.
00339               if offset is longer than UTF-8 string in bytes, function returns
00340               number of UTF-8 characters
00341 */
00342 INT UnicodeIndexToOffset(const CHAR *src, INT  index);
00343
00344
00345 /*
00346     UnicodeLastUtf8
00347 Description:
00348         Searches for the last UTF-8 character in UTF-8 string
00349 Arguments:
00350           p         pointer to a valid UTF-8 string
00351 Returns
00352         Pointer to the last UTF-8 sequence in a string
00353         If the string is empty, it returns pointer to empty string
00354 */
00355 CHAR *UnicodeLastUtf8(const CHAR *p);
00356
00357
00358 /*
00359       UnicodeStrcmp
00360 Description:
00361         Compares a portion of one string to a portion of another, with case
00362         sensitivity. Function performs a signed comparison of s1 to s2,
00363         starting with the first character in each string and continuing with
00364         subsequent characters until the corresponding characters differ .
00365         The comparison is case sensitive. It returns a value (< 0, 0, or > 0)
00366         based on the result of comparing s1 (or part of it) to s2 (or part of it).
00367 Arguments:
00368           str1   pointer to first Unicode string.
00369           str2   pointer to second Unicode string.
00370 Returns:
00371         If s1 is... returns a value that is...
00372         less than s2    < 0
00373         the same as s2  == 0
00374         greater than s2 > 0
00375 */
00376 INT UnicodeStrcmp( const WCHAR *str1, const WCHAR *str2 );
00377
00378
00379 /*
00380       UnicodeStrncmp
00381 Description:
00382         Compares a portion of one string to a portion of another, with case
00383         sensitivity. Function performs a signed comparison of s1 to s2,
00384         for a maximum length of n bytes, starting with the first character in
00385         each string and continuing with subsequent characters until the
00386         corresponding characters differ or until n characters have been examined.
00387         The comparison is not case sensitive. It returns a value (< 0, 0, or > 0)
00388         based on the result of comparing s1 (or part of it) to s2 (or part of it).
00389 Arguments:
00390           str1    pointer to first Unicode string.
00391           str2    pointer to second Unicode string.
00392 Returns:
00393         If s1 is... returns a value that is...
00394         less than s2    < 0
00395         the same as s2  == 0
00396         greater than s2 > 0
00397 */
00398 INT UnicodeStrncmp( const WCHAR *str1, const WCHAR *str2, INT n );
00399
00400
00401 /*
00402       UnicodeStrstr
00403 Description:
00404         Scans a string for the occurrence of a given substring. Function
00405         scans s1 for the first occurrence of the substring s2.
00406 Arguments:
00407           str     pointer to first Unicode string.
00408           sub     pointer to Unicode substring.
00409 Returns:
00410         return a pointer to the element in s1, where s2 begins
00411         (points to s2 in s1). If s2 does not occur in s1, strstr returns null.
00412 */
00413 WCHAR *UnicodeStrstr( const WCHAR *str, const WCHAR *sub );
00414
00415
00416 /*
00417       UnicodeStrncpy
00418 Description:
00419         Copies a given number of bytes from one string into another, truncating
00420         or padding as necessary. Strncpy copies up to maxlen characters from src
00421         into dest, truncating or null-padding dest. The target string, dest,
00422         might not be null-terminated if the length of src is maxlen or more.
00423 Arguments:
00424           dest      pointer to destination UTF-8 string
00425           src       pointer to source UTF-8 string
00426           n         maximum number of UTF-8 characters to copy
00427 Returns:
00428         Value strncpy returns dest.
00429 */
00430 CHAR  *UnicodeStrncpy(CHAR *dest, const CHAR *src, UINT n);
00431
00432
00433 /*
00434       UnicodeUtf8Strchr
00435 Description:
00436         Scans UNICODE character corresponding to ch, in string p.
00437         Function scans a string in forward direction, looking for a
00438         specific character. It finds the first occurrence of the
00439         unicode WCHAR c in the UTF-8 string s. The null-terminator is considered
00440         to be part of the string.
00441 Arguments:
00442           p         pointer to destination UNICODE string
00443           ch        value of UNICODE character
00444 Returns:
00445         pointer to the first occurrence of the character c in s. If c does not
00446         occur in s, function returns null.
00447 */
00448 CHAR *UnicodeUtf8Strchr(const CHAR *p, WCHAR c);
00449
00450
00451 #define UTF8_COMPUTE(Char, Mask, Len)                                         \
00452   if (Char < 128)       { Len = 1;  Mask = 0x7f; }                            \
00453   else if ((Char & 0xe0) == 0xc0)                                             \
00454     { Len = 2; Mask = 0x1f; }                                                 \
00455   else if ((Char & 0xf0) == 0xe0)                                             \
00456     { Len = 3; Mask = 0x0f; }                                                 \
00457   else if ((Char & 0xf8) == 0xf0)                                             \
00458     { Len = 4; Mask = 0x07; }                                                 \
00459   else if ((Char & 0xfc) == 0xf8)                                             \
00460     { Len = 5; Mask = 0x03; }                                                 \
00461   else if ((Char & 0xfe) == 0xfc)                                             \
00462     { Len = 6; Mask = 0x01; }                                                 \
00463   else                                                                        \
00464     Len = -1;
00465
00466 #define UTF8_GET(Result, Chars, Count, Mask, Len)                             \
00467   (Result) = (Chars)[0] & (Mask);                                             \
00468   for ((Count) = 1; (Count) < (Len); ++(Count))                               \
00469     {                                                                         \
00470       if (((Chars)[(Count)] & 0xc0) != 0x80)                                  \
00471         {                                                                     \
00472           (Result) = -1;                                                      \
00473           break;                                                              \
00474     }                                                                     \
00475       (Result) <<= 6;                                                         \
00476       (Result) |= ((Chars)[(Count)] & 0x3f);                                  \
00477 }
00478
00480
00481 #endif // Auxiliary_Unicode_hpp
00482
Generated on Tue Jan 24 14:48:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/VCard.cpp File Reference

Auxiliary/VCard.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "VCard.hpp"
#include "Unicode.hpp"
#include "Macros.hpp"
#include <AddOns/AuxExtensions/MimeCoding.hpp>

Include dependency graph for VCard.cpp:

Defines

#define | APOXI_VCARD_ADR 4
#define | APOXI_VCARD_BEGIN 0
#define | APOXI_VCARD_EMAIL 7
#define | APOXI_VCARD_END 1
#define | APOXI_VCARD_FN 3
#define | APOXI_VCARD_N 2
#define | APOXI_VCARD_ORG 5
#define | APOXI_VCARD_TEL 6
#define | APOXI_VCARD_TITLE 8
#define | APOXI_VCARD_VERSION 9
#define | APOXI_VCARD_X 10

Define Documentation

#define APOXI_VCARD_ADR 4

#define APOXI_VCARD_BEGIN 0

#define APOXI_VCARD_EMAIL 7

#define APOXI_VCARD_END 1

#define APOXI_VCARD_FN 3

#define APOXI_VCARD_N 2

#define APOXI_VCARD_ORG 5

#define APOXI_VCARD_TEL 6

#define APOXI_VCARD_TITLE 8

#define APOXI_VCARD_VERSION 9

#define APOXI_VCARD_X 10

Variable Documentation

UINT flag

INT index

INT len

INT len

const CHAR* name

const CHAR* name

Generated on Tue Jan 24 19:40:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/VCard.hpp File Reference

Auxiliary/VCard.hpp File Reference

#include <Auxiliary/WString.hpp>

Include dependency graph for VCard.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VCard
class | VCardParser
class | VCardWriter

Defines

#define | APOXI_VCARD_ADDRESS_MAX 2
number of supported addresses
#define | APOXI_VCARD_ADR_COUNT 7
#define | APOXI_VCARD_ADR_COUNTRY 6
#define | APOXI_VCARD_ADR_EXTENDED 1
#define | APOXI_VCARD_ADR_LOCALITY 3
#define | APOXI_VCARD_ADR_POSTALCODE 5
#define | APOXI_VCARD_ADR_POSTOFFICE 0
#define | APOXI_VCARD_ADR_REGION 4
#define | APOXI_VCARD_ADR_STREET 2
#define | APOXI_VCARD_NAME_ADD 2
#define | APOXI_VCARD_NAME_COUNT 5
#define | APOXI_VCARD_NAME_FAMILY 0
#define | APOXI_VCARD_NAME_GIVEN 1
#define | APOXI_VCARD_NAME_PREFIX 3
#define | APOXI_VCARD_NAME_SUFFIX 4
#define | APOXI_VCARD_ORG_ADDUNIT 2
#define | APOXI_VCARD_ORG_MAX 3
number of organisation properties supported
#define | APOXI_VCARD_ORG_NAME 0
#define | APOXI_VCARD_ORG_UNIT 1
#define | APOXI_VCARD_TYPE_ADR_DEFAULT (APOXI_VCARD_TYPE_ADR_INTL|APOXI_VCARD_TYPE_ADR_POSTAL|APOXI_VCARD_TYPE_ADR_PARCEL|APOXI_VCARD_TYPE_ADR_WORK)
default value as defined in the specification if nothing is given
#define | APOXI_VCARD_TYPE_ADR_DOM 0x0001
#define | APOXI_VCARD_TYPE_ADR_HOME 0x0010
#define | APOXI_VCARD_TYPE_ADR_INTL 0x0002
#define | APOXI_VCARD_TYPE_ADR_PARCEL 0x0008
#define | APOXI_VCARD_TYPE_ADR_POSTAL 0x0004
#define | APOXI_VCARD_TYPE_ADR_WORK 0x0020
#define | APOXI_VCARD_TYPE_TEL_BBS 0x0010
#define | APOXI_VCARD_TYPE_TEL_CAR 0x0040
#define | APOXI_VCARD_TYPE_TEL_CELL 0x0040
#define | APOXI_VCARD_TYPE_TEL_DEFAULT (APOXI_VCARD_TYPE_TEL_VOICE)
default value as defined in the specification if nothing is given
#define | APOXI_VCARD_TYPE_TEL_FAX 0x0010
#define | APOXI_VCARD_TYPE_TEL_HOME 0x0004
#define | APOXI_VCARD_TYPE_TEL_ISDN 0x0080
#define | APOXI_VCARD_TYPE_TEL_MODEM 0x0020
#define | APOXI_VCARD_TYPE_TEL_MSG 0x0020
#define | APOXI_VCARD_TYPE_TEL_PAGER 0x0080
#define | APOXI_VCARD_TYPE_TEL_PREF 0x0001
#define | APOXI_VCARD_TYPE_TEL_VIDEO 0x0100
#define | APOXI_VCARD_TYPE_TEL_VOICE 0x0008
#define | APOXI_VCARD_TYPE_TEL_WORK 0x0002

Define Documentation

#define APOXI_VCARD_ADDRESS_MAX 2

number of supported addresses

#define APOXI_VCARD_ADR_COUNT 7

#define APOXI_VCARD_ADR_COUNTRY 6

#define APOXI_VCARD_ADR_EXTENDED 1

#define APOXI_VCARD_ADR_LOCALITY 3

#define APOXI_VCARD_ADR_POSTALCODE 5

#define APOXI_VCARD_ADR_POSTOFFICE 0

#define APOXI_VCARD_ADR_REGION 4

#define APOXI_VCARD_ADR_STREET 2

#define APOXI_VCARD_NAME_ADD 2

#define APOXI_VCARD_NAME_COUNT 5

#define APOXI_VCARD_NAME_FAMILY 0

#define APOXI_VCARD_NAME_GIVEN 1

#define APOXI_VCARD_NAME_PREFIX 3

#define APOXI_VCARD_NAME_SUFFIX 4

#define APOXI_VCARD_ORG_ADDUNIT 2

#define APOXI_VCARD_ORG_MAX 3

number of organisation properties supported

#define APOXI_VCARD_ORG_NAME 0

#define APOXI_VCARD_ORG_UNIT 1

#define APOXI_VCARD_TYPE_ADR_DEFAULT (APOXI_VCARD_TYPE_ADR_INTL|APOXI_VCARD_TYPE_ADR_POSTAL|APOXI_VCARD_TYPE_ADR_PARCEL|APOXI_VCARD_TYPE_ADR_WORK)

default value as defined in the specification if nothing is given

#define APOXI_VCARD_TYPE_ADR_DOM 0x0001

#define APOXI_VCARD_TYPE_ADR_HOME 0x0010

#define APOXI_VCARD_TYPE_ADR_INTL 0x0002

#define APOXI_VCARD_TYPE_ADR_PARCEL 0x0008

#define APOXI_VCARD_TYPE_ADR_POSTAL 0x0004

#define APOXI_VCARD_TYPE_ADR_WORK 0x0020

#define APOXI_VCARD_TYPE_TEL_BBS 0x0010

#define APOXI_VCARD_TYPE_TEL_CAR 0x0040

#define APOXI_VCARD_TYPE_TEL_CELL 0x0040

#define APOXI_VCARD_TYPE_TEL_DEFAULT (APOXI_VCARD_TYPE_TEL_VOICE)

default value as defined in the specification if nothing is given

#define APOXI_VCARD_TYPE_TEL_FAX 0x0010

#define APOXI_VCARD_TYPE_TEL_HOME 0x0004

#define APOXI_VCARD_TYPE_TEL_ISDN 0x0080

#define APOXI_VCARD_TYPE_TEL_MODEM 0x0020

#define APOXI_VCARD_TYPE_TEL_MSG 0x0020

#define APOXI_VCARD_TYPE_TEL_PAGER 0x0080

#define APOXI_VCARD_TYPE_TEL_PREF 0x0001

#define APOXI_VCARD_TYPE_TEL_VIDEO 0x0100

#define APOXI_VCARD_TYPE_TEL_VOICE 0x0008

#define APOXI_VCARD_TYPE_TEL_WORK 0x0002

Generated on Tue Jan 24 19:40:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/VCard.hpp Source File

Auxiliary/VCard.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifndef Apoxi_VCard_hpp
00010 #define Apoxi_VCard_hpp
00011
00012 #include <Auxiliary/WString.hpp>
00013
00015 #define APOXI_VCARD_ADDRESS_MAX 2
00016
00017 #define APOXI_VCARD_NAME_COUNT 5
00018 // order specified by vCard standard
00019 #define APOXI_VCARD_NAME_FAMILY     0
00020 #define APOXI_VCARD_NAME_GIVEN      1
00021 #define APOXI_VCARD_NAME_ADD        2
00022 #define APOXI_VCARD_NAME_PREFIX     3
00023 #define APOXI_VCARD_NAME_SUFFIX     4
00024
00025 #define APOXI_VCARD_ADR_COUNT 7
00026 // order specified by vCard standard
00027 #define APOXI_VCARD_ADR_POSTOFFICE      0
00028 #define APOXI_VCARD_ADR_EXTENDED        1
00029 #define APOXI_VCARD_ADR_STREET          2
00030 #define APOXI_VCARD_ADR_LOCALITY        3
00031 #define APOXI_VCARD_ADR_REGION          4
00032 #define APOXI_VCARD_ADR_POSTALCODE      5
00033 #define APOXI_VCARD_ADR_COUNTRY         6
00034
00036 #define APOXI_VCARD_ORG_MAX 3
00037
00038 #define APOXI_VCARD_ORG_NAME            0
00039 #define APOXI_VCARD_ORG_UNIT            1
00040 #define APOXI_VCARD_ORG_ADDUNIT         2
00041
00042 // telephone type flags
00043 #define APOXI_VCARD_TYPE_TEL_PREF   0x0001
00044 #define APOXI_VCARD_TYPE_TEL_WORK   0x0002
00045 #define APOXI_VCARD_TYPE_TEL_HOME   0x0004
00046 #define APOXI_VCARD_TYPE_TEL_VOICE  0x0008
00047 #define APOXI_VCARD_TYPE_TEL_FAX    0x0010
00048 #define APOXI_VCARD_TYPE_TEL_MSG    0x0020
00049 #define APOXI_VCARD_TYPE_TEL_CELL   0x0040
00050 #define APOXI_VCARD_TYPE_TEL_PAGER  0x0080
00051 #define APOXI_VCARD_TYPE_TEL_BBS    0x0010
00052 #define APOXI_VCARD_TYPE_TEL_MODEM  0x0020
00053 #define APOXI_VCARD_TYPE_TEL_CAR    0x0040
00054 #define APOXI_VCARD_TYPE_TEL_ISDN   0x0080
00055 #define APOXI_VCARD_TYPE_TEL_VIDEO  0x0100
00056
00058 #define APOXI_VCARD_TYPE_TEL_DEFAULT (APOXI_VCARD_TYPE_TEL_VOICE)
00059
00060 // address type flags
00061 #define APOXI_VCARD_TYPE_ADR_DOM    0x0001
00062 #define APOXI_VCARD_TYPE_ADR_INTL   0x0002
00063 #define APOXI_VCARD_TYPE_ADR_POSTAL 0x0004
00064 #define APOXI_VCARD_TYPE_ADR_PARCEL 0x0008
00065 #define APOXI_VCARD_TYPE_ADR_HOME   0x0010
00066 #define APOXI_VCARD_TYPE_ADR_WORK   0x0020
00067
00069 #define APOXI_VCARD_TYPE_ADR_DEFAULT (APOXI_VCARD_TYPE_ADR_INTL|APOXI_VCARD_TYPE_ADR_POSTAL|APOXI_VCARD_TYPE_ADR_PARCEL|APOXI_VCARD_TYPE_ADR_WORK)
00070
00084 class VCard
00085 {
00086         friend class VCardParser;
00087         friend class VCardWriter;
00088
00089     public:
00090
00091         typedef UINT TelType;
00092         typedef UINT AdrType;
00093
00095         VCard();
00096
00098         VCard(const VCard &vCard);
00099
00101         ~VCard();
00102
00104         VCard& operator=(const VCard &vcard);
00105
00112         UINT32 ReadBuffer(const CHAR* buffer, UINT32 buffer_len);
00113
00120         UINT32 WriteBuffer(CHAR* buffer, UINT32 buffer_len) const;
00121
00122
00127         WString GetFormattedName() const;
00128
00133         void SetFormattedName(const WString& formatted_name);
00134
00135
00140         WString GetFamilyName() const;
00141
00146         void SetFamilyName(const WString& family_name);
00147
00148
00153         WString GetGivenName() const;
00154
00159         void SetGivenName(const WString& given_name);
00160
00161
00166         WString GetAdditionalNames() const;
00167
00172         void SetAdditionalNames(const WString& add_name);
00173
00174
00179         WString GetNamePrefix() const;
00180
00185         void SetNamePrefix(const WString& name_prefix);
00186
00187
00192         WString GetNameSuffix() const;
00193
00198         void SetNameSuffix(const WString& name_suffix);
00199
00200
00205         INT GetNumberOfAddresses() const;
00206
00207
00213         AdrType GetAddressType(UINT index = 0) const;
00214
00220         void SetAddressType(AdrType address_type, UINT index = 0);
00221
00222
00228         WString GetPostOfficeAdress(UINT index = 0) const;
00229
00235         void SetPostOfficeAddress(const WString& po_address, UINT index = 0);
00236
00237
00243         WString GetExtendedAddress(UINT index = 0) const;
00244
00250         void SetExtendedAddress(const WString& ext_address, UINT index = 0);
00251
00252
00258         WString GetStreet(UINT index = 0) const;
00259
00265         void SetStreet(const WString& street, UINT index = 0);
00266
00267
00273         WString GetLocality(UINT index = 0) const;
00274
00280         void SetLocality(const WString& locality, UINT index = 0);
00281
00282
00288         WString GetRegion(UINT index = 0) const;
00289
00295         void SetRegion(const WString& region, UINT index = 0);
00296
00297
00303         WString GetPostalCode(UINT index = 0) const;
00304
00310         void SetPostalCode(const WString& postal_code, UINT index = 0);
00311
00312
00318         WString GetCountry(UINT index = 0) const;
00319
00325         void SetCountry(const WString& country, UINT index = 0);
00326
00327
00332         WString GetEmail() const;
00333
00338         void SetEmail(const WString& email);
00339
00340
00345         WString GetOrganizationName() const;
00346
00351         void SetOrganizationName(const WString& org_name);
00352
00353
00358         WString GetOrganizationalUnit() const;
00359
00364         void SetOrganizationalUnit(const WString& org_unit);
00365
00366
00371         WString GetAdditionalOrgUnit() const;
00372
00377         void SetAdditionalOrgUnit(const WString& add_org_unit);
00378
00379
00384         WString GetTitle() const;
00385
00390         void SetTitle(const WString& title);
00391
00392
00397         UINT GetTelNumberCount() const;
00398
00399
00405         WString GetTelNumber(UINT index = 0) const;
00406
00412         void SetTelNumber(const WString& number, UINT index = 0);
00413
00419         TelType GetTelNumberType(UINT index = 0) const;
00420
00426         void SetTelNumberType(TelType tel_type, UINT index = 0);
00427
00433         void AddTelNumber(const WString& number, TelType tel_types);
00434
00435     private:
00436         void CleanUp();
00437         void SetNull();
00438
00439         WString m_fn;                                       // formatted name
00440         WString m_names[APOXI_VCARD_NAME_COUNT];            // family name, given name, additional name, prefix, suffix
00441
00442         /* address array:
00443
00444             Post Office Address, Extended Address, Street, Locality, Region, Postal Code, and Country
00445         */
00446         WString             m_addresses[APOXI_VCARD_ADDRESS_MAX][APOXI_VCARD_ADR_COUNT];
00447         UINT                m_address_count;                // number of addresses in use
00448         /* address type array:
00449             the address type consists of an combination of address type flags
00450         */
00451         AdrType             m_address_types[APOXI_VCARD_ADDRESS_MAX];
00452
00453         WString             m_orgs[APOXI_VCARD_ORG_MAX];    // organization properties
00454
00455         WString             m_title;                        // job title
00456         WString             m_email;                        // email
00457
00458         WString             *m_tel;                         // dynamic array of telephone numbers
00459         UINT                m_tel_count;                    // number of telephone numbers
00460         TelType             *m_tel_types;                   // dynamic array of telephone types
00461
00462 };
00463
00469 class VCardParser
00470 {
00471     public:
00483         UINT32 ReadVCard(const CHAR* vcard_buffer, const UINT32 vcard_buffer_len, VCard* vcard);
00484
00485     private:
00486
00487         enum Encoding {
00488             None,
00489             Base64,
00490             QuotedPrintable
00491         };
00492
00493         enum Charset {
00494             Ascii,
00495             Utf8
00496         };
00497
00498         /* caseless compare (ASCII) */
00499         INT StrnCaseCmp(const CHAR *s1, const CHAR *s2, const UINT size) const;
00500
00501         BOOLEAN Check(UINT amount) const;
00502
00503         void ReadAdvance(INT amount);
00504
00510         BOOLEAN IsWs(const CHAR b) const;
00511
00513         void SkipWs();
00514
00516         void SkipWsls();
00517
00518         BOOLEAN ReadString(const CHAR *string, INT len);
00519         BOOLEAN ReadChar(const CHAR c);
00520         BOOLEAN ReadColon();
00521         BOOLEAN ReadSeparator();
00522         BOOLEAN ReadCrlf();
00523
00524         void Canonical2Native(CHAR *buffer);
00525         void Canonical2Native(WCHAR *buffer);
00526
00527         BOOLEAN ReadVCardBegin();
00528         BOOLEAN ReadVCardEnd();
00529
00530         BOOLEAN ReadValue(WString& value, Encoding encoding, Charset charset);
00531         void ReadVector(const WString& value, WString vector[], UINT count) const;
00532
00533         INT GetNextCrlfOffset(INT offset = 0) const;
00534         INT GetNextGroupOffset() const;
00535         INT GetNextParamOffset() const;
00536         INT GetNextParamValueOffset() const;
00537         INT GetNextItemNameOffset() const;
00538
00539         INT GetNextItemNameIndex(INT offset) const;
00540
00545         const CHAR*  m_vcard_buffer;
00546         const CHAR*  m_vcard_buffer_ptr;
00550         UINT32 m_vcard_buffer_len;
00551         UINT32 m_vcard_buffer_left;
00552 };
00553
00559 class VCardWriter
00560 {
00561     public:
00570         UINT32 WriteVCard(CHAR *buffer, UINT32 buffer_len, const VCard *vcard);
00571
00572     private:
00573
00578         BOOLEAN WriteBegin();
00579
00584         BOOLEAN WriteEnd();
00585
00586         void WriteAdvance(INT amount);
00587
00594         BOOLEAN Write(const CHAR *data, UINT len);
00595
00596         BOOLEAN WriteChar(const CHAR c);
00597
00603         BOOLEAN WriteStr(const CHAR *s);
00604
00605         BOOLEAN WriteWStr(const WString & ws);
00606
00607         INT WriteQP(const CHAR *string, INT len);
00608
00609         BOOLEAN WriteQPStr(const CHAR *string);
00610
00611         BOOLEAN WriteQPUTF8(const WString& string);
00612
00613         BOOLEAN WriteValue(const WString& value);
00614
00615         INT GetCanonicalStrLen(const WString& string);
00616
00617         WString GetCanonicalStr(const WString& string);
00618
00623         BOOLEAN WriteOrganization();
00624
00629         BOOLEAN WriteEmail();
00630
00635         BOOLEAN WriteTelephoneNumbers();
00636
00641         BOOLEAN WriteAddresses();
00642
00647         BOOLEAN WriteName();
00648
00653         BOOLEAN WriteTitle();
00654
00655         const VCard     *m_vcard;
00656         CHAR            *m_write_buffer_ptr;
00657         UINT32          m_write_buffer_len;
00658         UINT32          m_write_buffer_left;
00659 };
00660
00661 #endif // Apoxi_VCard_hpp
00662
Generated on Tue Jan 24 14:48:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Vector.hpp File Reference

Auxiliary/Vector.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Allocator.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for Vector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Vector< T >
class | Vector< T >::Iterator
Iterator can be used to iterate elements of a vector. More...

Defines

#define | Apoxi_Vector_hpp

Define Documentation

#define Apoxi_Vector_hpp

Generated on Tue Jan 24 19:41:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Vector.hpp Source File

Auxiliary/Vector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Vector_hpp)
00010 #define Apoxi_Vector_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Allocator.hpp>
00016 #include <Auxiliary/Macros.hpp>
00017
00021 template<typename T>
00022 class Vector {
00023 public:
00024     friend class Iterator;
00025     typedef INT DifferenceType;
00026     typedef T ValueType;
00027     typedef T& Reference;
00028     typedef const T& ConstReference;
00029     typedef INT SizeType;
00030
00031     enum {
00032         c_increment = 5
00033     };
00034
00036     class Iterator {
00037     protected:
00038         friend class Vector<T>;
00039
00040         Vector<T> *owner;
00041         SizeType current;
00042
00043         Iterator(Vector<T> *daddy, SizeType i) :
00044             owner(daddy), current(i) { }
00045         Iterator(const Vector<T> *daddy, SizeType i) :
00046             owner((Vector<T> *)daddy), current(i) { }
00047
00048     public:
00054         Iterator& operator++(INT) {
00055             ++current;
00056             return(*this);
00057         }
00058
00064         Iterator& operator--(INT) {
00065             --current;
00066             return(*this);
00067         }
00068
00070 #if !defined(_MSC_VER) || (defined(_MSC_VER) && (_MSC_VER >= 1300))
00071         Iterator operator+(DifferenceType n) const;
00072 #else
00073         Iterator operator+(DifferenceType n) const {
00074             Iterator i(*this);
00075             i.current += n;
00076             return(i);
00077         }
00078 #endif
00079
00081 #if !defined(_MSC_VER) || (defined(_MSC_VER) && (_MSC_VER >= 1300))
00082         Iterator operator-(DifferenceType n) const;
00083 #else
00084         Iterator operator-(DifferenceType n) const {
00085             Iterator i(*this);
00086             i.current -= n;
00087             return(i);
00088         }
00089 #endif
00090
00092         Reference operator*() { return(owner->operator[](current)); }
00093
00095         ConstReference operator*() const
00096             { return(owner->operator[](current)); }
00097
00099         BOOLEAN operator<(const Iterator &i) const
00100             { return(current < i.current); }
00101
00103         BOOLEAN operator>(const Iterator &i) const
00104             { return(current > i.current); }
00105
00107         BOOLEAN operator<=(const Iterator &i) const
00108             { return(current <= i.current); }
00109
00111         BOOLEAN operator>=(const Iterator &i) const
00112             { return(current >= i.current); }
00113
00115         BOOLEAN operator==(const Iterator &i) const
00116             { return(current == i.current && owner == i.owner); }
00117
00119         BOOLEAN operator!=(const Iterator &i) const
00120             { return(!(*this == i)); }
00121
00123         DifferenceType operator+(const Iterator &i)
00124             { return(current + i.current); }
00125
00127         DifferenceType operator-(const Iterator &i)
00128             { return(current - i.current); }
00129     };
00130
00131     typedef const Iterator ConstIterator;
00132     typedef Iterator ReverseIterator;
00133     typedef const Iterator ConstReverseIterator;
00134
00135 private:
00136     T *m_elem;
00137     SizeType m_nelem;
00138     SizeType m_capacity;
00139     Allocator<T> allocator;
00140
00141     void Set(SizeType i, ConstReference x);
00142
00143     void Copy(SizeType to, SizeType from) { Set(to, m_elem[from]); }
00144
00145     void Construct(Reference elem, ConstReference x);
00146     void Destruct(Reference elem);
00147
00148     void Resize(SizeType n) {
00149         for (SizeType i = 0; i < GetSize(); ++i)
00150             Destruct(m_elem[i]);
00151
00152         if (Capacity() < n) {
00153             allocator.Free(m_elem);
00154
00155             m_capacity = ((n - m_capacity) < c_increment) ?
00156                 m_capacity + c_increment : n;
00157
00158             m_elem = allocator.Alloc(m_capacity);
00159
00160             ASSERT_DEBUG(m_elem != 0);
00161         }
00162     }
00163
00164     void CheckFree(SizeType n) {
00165         if ((GetSize() + n) > Capacity())
00166             Reserve(GetSize() + n);
00167     }
00168
00169     void CheckFree() {
00170         CheckFree(1);
00171     }
00172
00173 public:
00177     Vector(SizeType n, ConstReference value);
00178
00180     Vector() : m_elem(0), m_nelem(0), m_capacity(0) { }
00181
00185     Vector(SizeType n);
00186
00188     Vector(const Vector<T> &x) : m_elem(0), m_nelem(0), m_capacity(0)
00189         { *this = x; }
00190
00192     ~Vector();
00193
00195     Iterator Begin() const { return(Iterator(this, 0)); }
00196
00199     Iterator End() const { return(Iterator(this, m_nelem)); }
00200
00203     ReverseIterator RBegin() const
00204         { return(ReverseIterator(this, m_nelem - 1)); }
00205
00209     ReverseIterator REnd() const { return(ReverseIterator(this, -1)); }
00210
00212     SizeType GetSize() const { return(m_nelem); }
00213
00215     SizeType MaxSize() const { return(SizeType(UINT_MAX / sizeof(T))); }
00216
00218     BOOLEAN IsEmpty() const { return m_nelem == 0; }
00219
00222     Reference operator[](SizeType i) {
00223         ASSERT_DEBUG(i >= 0 && i < GetSize());
00224         return(m_elem[i]);
00225     }
00226
00229     ConstReference operator[](SizeType i) const {
00230         ASSERT_DEBUG(i >= 0 && i < GetSize());
00231         return(m_elem[i]);
00232     }
00233
00235     Reference Front() {
00236         ASSERT_DEBUG(GetSize() > 0);
00237         return(m_elem[0]);
00238     }
00239
00241     ConstReference Front() const {
00242         ASSERT_DEBUG(GetSize() > 0);
00243         return(m_elem[0]);
00244     }
00245
00247     Reference Back() {
00248         ASSERT_DEBUG(GetSize() > 0);
00249         return(m_elem[m_nelem - 1]);
00250     }
00251
00253     ConstReference Back() const {
00254         ASSERT_DEBUG(GetSize() > 0);
00255         return(m_elem[m_nelem - 1]);
00256     }
00257
00259     void PushBack(ConstReference x);
00260
00262     void Insert(const Iterator &pos, ConstReference x);
00263
00265     void Insert(const Iterator &pos) {
00266         Insert(pos, T());
00267     }
00268
00270     void Insert(const Iterator &pos, SizeType n, ConstReference x);
00271
00273     void PopBack();
00274
00276     void Erase(const Iterator &pos);
00277
00279     void Erase(const Iterator &first, const Iterator &last);
00280
00282     void Reserve(SizeType n);
00283
00285     SizeType Capacity() const { return m_capacity; }
00286
00288     Vector<T>& operator=(const Vector<T> &from);
00289 };
00290
00291 #if !defined(_MSC_VER) || (defined(_MSC_VER) && (_MSC_VER >= 1300))
00292 template<typename T>
00293 typename Vector<T>::Iterator Vector<T>::Iterator::operator+(
00294     typename Vector<T>::DifferenceType n) const
00295 {
00296     Iterator i(*this);
00297     i.current += n;
00298     return(i);
00299 }
00300 #endif
00301
00302 #if !defined(_MSC_VER) || (defined(_MSC_VER) && (_MSC_VER >= 1300))
00303 template<typename T>
00304 typename Vector<T>::Iterator Vector<T>::Iterator::operator-(
00305     typename Vector<T>::DifferenceType n) const
00306 {
00307     Iterator i(*this);
00308     i.current -= n;
00309     return(i);
00310 }
00311 #endif
00312
00313 template<typename T>
00314 void Vector<T>::Set(SizeType i, ConstReference x)
00315 {
00316     if (i < GetSize())
00317         operator[](i) = x;
00318     else
00319         Construct(m_elem[i], x);
00320 }
00321
00322 template<typename T>
00323 void Vector<T>::Construct(Reference elem, ConstReference x)
00324 {
00325     allocator.Construct(&elem, x);
00326 }
00327
00328 template<typename T>
00329 void Vector<T>::Destruct(Reference elem)
00330 {
00331     allocator.Destruct(&elem);
00332 }
00333
00334 template<typename T>
00335 Vector<T>::Vector(SizeType n, ConstReference value) :
00336     m_elem(0),
00337     m_nelem(0),
00338     m_capacity(0)
00339 {
00340     if (n > 0) {
00341         Reserve(n);
00342         Insert(Begin(), n, value);
00343     }
00344 }
00345
00346 template<typename T>
00347 Vector<T>::Vector(SizeType n) :
00348     m_elem(0),
00349     m_nelem(0),
00350     m_capacity(0)
00351 {
00352     if (n > 0) {
00353         Reserve(n);
00354         Insert(Begin(), n, T());
00355     }
00356 }
00357
00358 template<typename T>
00359 Vector<T>::~Vector()
00360 {
00361     for (SizeType i = 0; i < GetSize(); ++i)
00362         Destruct(m_elem[i]);
00363     allocator.Free(m_elem);
00364 }
00365
00366 template<typename T>
00367 void Vector<T>::PushBack(ConstReference x)
00368 {
00369     CheckFree();
00370     Construct(m_elem[m_nelem], x);
00371     ++m_nelem;
00372 }
00373
00374 template<typename T>
00375 void Vector<T>::Insert(const Iterator &pos, ConstReference x)
00376 {
00377     SizeType p;
00378
00379     p = pos.current;
00380     if (p >= GetSize())
00381         PushBack(x);
00382     else {
00383         Reserve(GetSize() + 1);
00384
00385         SizeType i = GetSize();
00386
00387         while (i > p) {
00388             Copy(i, i - 1);
00389             --i;
00390         }
00391         Set(i, x);
00392         ++m_nelem;
00393     }
00394 }
00395
00396 template<typename T>
00397 void Vector<T>::Insert(const Iterator &pos, SizeType n, ConstReference x)
00398 {
00399     if (n == 0)
00400         return;
00401
00402     Reserve(GetSize() + n);
00403     SizeType p;
00404
00405     p = pos.current;
00406     if (p < GetSize()) {
00407         SizeType i(m_nelem + n - 1);
00408         SizeType j(m_nelem - 1);
00409
00410         while (j >= p)
00411             Copy(i--, j--);
00412     }
00413     for (SizeType i = 0; i < n; ++i) {
00414         Set(p, x);
00415         ++p;
00416     }
00417     m_nelem += n;
00418 }
00419
00420 template<typename T>
00421 void Vector<T>::PopBack()
00422 {
00423     ASSERT_DEBUG(GetSize() > 0);
00424
00425     Destruct(Back());
00426     --m_nelem;
00427 }
00428
00429 template<typename T>
00430 void Vector<T>::Erase(const Iterator &pos)
00431 {
00432     if (GetSize() <= 0 || pos.current >= GetSize())
00433         return;
00434
00435     SizeType i = pos.current;
00436     while (i < GetSize() - 1) {
00437         Copy(i, i + 1);
00438         ++i;
00439     }
00440     Destruct(Back());
00441     --m_nelem;
00442 }
00443
00444 template<typename T>
00445 void Vector<T>::Erase(const Iterator &first, const Iterator &last)
00446 {
00447     if (last <= first)
00448         return;
00449
00450     SizeType ifirst = first.current;
00451     SizeType ilast = last.current;
00452
00453     while (ilast < GetSize())
00454         Copy(ifirst++, ilast++);
00455
00456     SizeType nelem = ilast - ifirst;
00457     while (ifirst < GetSize()) {
00458         Destruct(m_elem[ifirst]);
00459         ++ifirst;
00460     }
00461     m_nelem -= nelem;
00462 }
00463
00464 template<typename T>
00465 void Vector<T>::Reserve(SizeType n)
00466 {
00467     if (Capacity() >= n)
00468         return;
00469
00470     SizeType as = ((n - m_capacity) < c_increment) ? m_capacity + c_increment : n;
00471
00472     T *tmp = allocator.Alloc(as);
00473     ASSERT_DEBUG(tmp != 0);
00474
00475     for (SizeType i = 0; i < m_nelem; ++i) {
00476         Construct(tmp[i], m_elem[i]);
00477         Destruct(m_elem[i]);
00478     }
00479
00480     m_capacity = as;
00481     allocator.Free(m_elem);
00482     m_elem = tmp;
00483 }
00484
00485 template<typename T>
00486 Vector<T>& Vector<T>::operator=(const Vector<T> &from)
00487 {
00488     if (&from == this)
00489         return(*this);
00490
00491     Resize(from.GetSize());
00492     m_nelem = 0;
00493     for (SizeType i = 0; i < from.GetSize(); ++i)
00494         Construct(m_elem[i], from[i]);
00495
00496     m_nelem = from.GetSize();
00497     return(*this);
00498 }
00499
00501 #endif  // Apoxi_Vector_hpp
00502
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WCattr.cpp File Reference

Auxiliary/WCattr.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "WCattr.hpp"
#include "Macros.hpp"

Include dependency graph for WCattr.cpp:

Defines

#define | F_HAS_LOWER_AND_UPPER_CASE 0x03
#define | F_HAS_LOWER_CASE 0x01
#define | F_HAS_UPPER_CASE 0x02
#define | F_IS_COMPOSED 0x04

Functions

WCHAR | AttrGetCase (WCHAR wc, UINT i)
UINT8 | AttrGetCaseFlags (UINT i)
UINT8 | AttrGetCompFlags (UINT i)
WCHAR | AttrGetDecomp (UINT i)
UINT16 | AttrGetIdx (WCHAR wc)
WCType | AttrGetType (UINT i)
WCHAR | WCharToLower (WCHAR wc)
WCHAR | WCharToUpper (WCHAR wc)
WCHAR | WDecompose (WCHAR wc)
BOOLEAN | WIsComposed (WCHAR wc)
BOOLEAN | WIsUnicode (void)
WCType | WType (WCHAR wc)

Variables

const INT | A_SIZE = 418
const INT | I1_SIZE = 4096
const INT | I2_SIZE = 2612

Define Documentation

#define F_HAS_LOWER_AND_UPPER_CASE 0x03

#define F_HAS_LOWER_CASE 0x01

#define F_HAS_UPPER_CASE 0x02

#define F_IS_COMPOSED 0x04

Function Documentation

WCHAR AttrGetCase | ( | WCHAR | wc,
 |  | UINT | i
 | ) | [inline]

UINT8 AttrGetCaseFlags ( UINT i ) [inline]

UINT8 AttrGetCompFlags ( UINT i ) [inline]

WCHAR AttrGetDecomp ( UINT i ) [inline]

UINT16 AttrGetIdx ( WCHAR wc ) [inline]

WCType AttrGetType ( UINT i ) [inline]

Variable Documentation

const INT A_SIZE = 418

const INT I1_SIZE = 4096

const INT I2_SIZE = 2612

Generated on Tue Jan 24 19:41:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WCattr.hpp File Reference

Auxiliary/WCattr.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for WCattr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | _APOXI_WCAttr_h

Enumerations

enum WCBType {
WCBTypeL, WCBTypeLRE, WCBTypeLRO, WCBTypeR,
WCBTypeAL, WCBTypeRLE, WCBTypeRLO, WCBTypePDF,
WCBTypeEN, WCBTypeES, WCBTypeET, WCBTypeAN,
WCBTypeCS, WCBTypeNSM, WCBTypeBN, WCBTypeB,
WCBTypeS, WCBTypeWS, WCBTypeON
}
enum WCType {
WCTypeLu, WCTypeLl, WCTypeLt, WCTypeLm,
WCTypeLo, WCTypeMn, WCTypeMc, WCTypeMe,
WCTypeNd, WCTypeNl, WCTypeNo, WCTypePc,
WCTypePd, WCTypePs, WCTypePe, WCTypePi,
WCTypePf, WCTypePo, WCTypeSm, WCTypeSc,
WCTypeSk, WCTypeSo, WCTypeZs, WCTypeZl,
WCTypeZp, WCTypeCc, WCTypeCf, WCTypeCs,
WCTypeCo, WCTypeCn
}

Functions

WCHAR | WDecompose (WCHAR wc)
BOOLEAN | WIsComposed (WCHAR wc)
BOOLEAN | WIsUnicode (void)
WCType | WType (WCHAR wc)

Define Documentation

#define _APOXI_WCAttr_h

Generated on Tue Jan 24 19:46:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WCattr.hpp Source File

Auxiliary/WCattr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(_APOXI_WCAttr_h)
00010 #define _APOXI_WCAttr_h
00013
00014 #include <Kernel/Types.hpp>
00015
00016
00017
00018 // Unicode General Category
00019 typedef enum {
00020     WCTypeLu, // Letter, Uppercase
00021     WCTypeLl, // Letter, Lowercase
00022     WCTypeLt, // Letter, Titlecase
00023     WCTypeLm, // Letter, Modifier
00024     WCTypeLo, // Letter, Other
00025     WCTypeMn, // Mark, Non-Spacing
00026     WCTypeMc, // Mark, Spacing Combining
00027     WCTypeMe, // Mark, Enclosing
00028     WCTypeNd, // Number, Decimal Digit
00029     WCTypeNl, // Number, Letter
00030     WCTypeNo, // Number, Other
00031     WCTypePc, // Punctuation, Connector
00032     WCTypePd, // Punctuation, Dash
00033     WCTypePs, // Punctuation, Open
00034     WCTypePe, // Punctuation, Close
00035     WCTypePi, // Punctuation, Initial quote
00036     WCTypePf, // Punctuation, Final quote
00037     WCTypePo, // Punctuation, Other
00038     WCTypeSm, // Symbol, Math
00039     WCTypeSc, // Symbol, Currency
00040     WCTypeSk, // Symbol, Modifier
00041     WCTypeSo, // Symbol, Other
00042     WCTypeZs, // Separator, Space
00043     WCTypeZl, // Separator, Line
00044     WCTypeZp, // Separator, Paragraph
00045     WCTypeCc, // Other, Control
00046     WCTypeCf, // Other, Format
00047     WCTypeCs, // Other, Surrogate
00048     WCTypeCo, // Other, Private Use
00049     WCTypeCn  // Other, Not Assigned
00050 } WCType;
00051
00052 // Unicode Bidirectional Category
00053 typedef enum {
00054     WCBTypeL,   // Left-to-Right
00055     WCBTypeLRE, // Left-to-Right Embedding
00056     WCBTypeLRO, // Left-to-Right Override
00057     WCBTypeR,   // Right-to-Left
00058     WCBTypeAL,  // Right-to-Left Arabic
00059     WCBTypeRLE, // Right-to-Left Embedding
00060     WCBTypeRLO, // Right-to-Left Override
00061     WCBTypePDF, // Pop Directional Format
00062     WCBTypeEN,  // European Number
00063     WCBTypeES,  // European Number Separator
00064     WCBTypeET,  // European Number Terminator
00065     WCBTypeAN,  // Arabic Number
00066     WCBTypeCS,  // Common Number Separator
00067     WCBTypeNSM, // Non-Spacing Mark
00068     WCBTypeBN,  // Boundary Neutral
00069     WCBTypeB,   // Paragraph Separator
00070     WCBTypeS,   // Segment Separator
00071     WCBTypeWS,  // Whitespace
00072     WCBTypeON   // Other Neutrals
00073 } WCBType;
00074
00075 WCType  WType(WCHAR wc);
00076 BOOLEAN WIsComposed(WCHAR wc);
00077 WCHAR   WDecompose(WCHAR wc);
00078 BOOLEAN WIsUnicode(void);
00079
00080
00082 #endif // _APOXI_WCAttr_h
00083
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WCattr_tbl.hpp File Reference

Auxiliary/WCattr_tbl.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for WCattr_tbl.hpp:

Go to the source code of this file.

Defines

#define | _APOXI_WCAttr_Tbl_hpp
#define | A_SIZE 418
#define | I1_SIZE 4096
#define | I2_SIZE 2612

Define Documentation

#define _APOXI_WCAttr_Tbl_hpp

#define A_SIZE 418

#define I1_SIZE 4096

#define I2_SIZE 2612

Generated on Tue Jan 24 19:46:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WildcardStrncmp.cpp File Reference

Auxiliary/WildcardStrncmp.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "WildcardStrncmp.hpp"
#include "WStrUtil.hpp"
#include <ctype.h>
#include <string.h>

Include dependency graph for WildcardStrncmp.cpp:

Functions

template<typename T>
INT | wc_strncmp (const T *pattern, const T *candidate, INT count, INT do_case, INT do_wildcards)
template INT | wc_strncmp< CHAR > (const CHAR *, const CHAR *, INT, INT, INT)
template INT | wc_strncmp< WCHAR > (const WCHAR *, const WCHAR *, INT, INT, INT)

Function Documentation

template<typename T>
INT wc_strncmp | ( | const T * | pattern,
 |  | const T * | candidate,
 |  | INT | count,
 |  | INT | do_case,
 |  | INT | do_wildcards
 | ) |

***************************************************************************

Function: wc_strncmp( const char * pattern, // match this string (can contain ?, *) const char * candidate, // against this one. int count, // require at least count chars in pattern int do_case, // 0 = no case, !0 = cased compare int do_wildcards) // 0 = no wc's, !0 = honor ? and *

Action: See if the string pointed by candidate meets the criteria given in the string pointed by pattern. The pattern string can contain the special wild-card characters: * -- meaning match any number of characters, including zero, in the candidate string; ? -- meaning match any single character, which must be present to satisfy the match, in the candidate string.

The int arg count tells the minimum length of the pattern string, after '*' expansion, that will satisfy the string compare in this call. If count is negative, then forbid abbreviations: pattern and candidate strings must match exactly in content and length to give a good compare. If count is 0, then an empty pattern string (pattern == "") returns success. If count is positive, then must match "count" characters in the two strings to succeed, except we yield success if: -- pattern and candidate strings are the same length; or -- pattern string is shorter than "count"; or -- do_wildcards > 0 and final pattern char == '*'.

If the integer argument do_case == 0, then ignore the case of each character: compare the tolower() of each character; if do_case != 0, then consider case in character compares.

If the int arg do_wildcards == 0, then treat the wildcard characters '*' and '?' just like any others: do a normal char-for-char string compare. But if do_wildcards is nonzero, then the string compare uses those wildcard characters as you'd expect.

Returns: WC_MATCH on successful match. If not WC_MATCH, then the return val conveys a little more info: see wc_strncmp.h

Note on Resynchronization: After a span of one or more pattern-string '*' found; and an immediately following span of zero [sic: 0] or more '?', we have to resynchronize the candidate string with the pattern string: need to find a place in the candidate to restart our compares. We've not a clue how many chars a span of '*' will match/absorb/represent until we find the next matching character in the candidate string. For example:

------------------------------------------------------------------------- patt cand resync at 'A' what's going on? ------ ------- ------------- ------------------------------------------ "***A" "AbcdA" "A----" "***" matches zero characters "**A" "aAcdA" "-A---" "**" absorbs just one char: "a" "*??A" "abcdA" "----A" "*" absorbs "ab", "??" skips "cd" "**?A" "abAdA" "--A--" "**" absorbs "a", "?" skips "b" -------------------------------------------------------------------------

During any resync phase, we'll naturally be looking for the end of the candidate string and fail if we see it.

template INT wc_strncmp< CHAR > | ( | const CHAR * | ,
 |  | const CHAR * | ,
 |  | INT | ,
 |  | INT | ,
 |  | INT |
 | ) |

template INT wc_strncmp< WCHAR > | ( | const WCHAR * | ,
 |  | const WCHAR * | ,
 |  | INT | ,
 |  | INT | ,
 |  | INT |
 | ) |

Generated on Tue Jan 24 19:46:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WildcardStrncmp.hpp File Reference

Auxiliary/WildcardStrncmp.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for WildcardStrncmp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_WildcardStrncmp_hpp
#define | WC_QUES '?'
#define | WC_STAR '*'

Enumerations

enum {
WC_MATCH = 0, WC_MISMATCH, WC_PAT_NULL_PTR, WC_CAN_NULL_PTR,
WC_PAT_TOO_SHORT, WC_CAN_TOO_SHORT
}

Functions

template<typename T>
INT | wc_strncmp (const T *pattern, const T *candidate, INT count, INT do_case, INT do_wildcards)

Define Documentation

#define Apoxi_WildcardStrncmp_hpp

#define WC_QUES '?'

#define WC_STAR '*'

Enumeration Type Documentation

anonymous enum

Enumerator:
WC_MATCH
WC_MISMATCH
WC_PAT_NULL_PTR
WC_CAN_NULL_PTR
WC_PAT_TOO_SHORT
WC_CAN_TOO_SHORT

Function Documentation

template<typename T>
INT wc_strncmp | ( | const T * | pattern,
 |  | const T * | candidate,
 |  | INT | count,
 |  | INT | do_case,
 |  | INT | do_wildcards
 | ) |

***************************************************************************

Function: wc_strncmp( const char * pattern, // match this string (can contain ?, *) const char * candidate, // against this one. int count, // require at least count chars in pattern int do_case, // 0 = no case, !0 = cased compare int do_wildcards) // 0 = no wc's, !0 = honor ? and *

Action: See if the string pointed by candidate meets the criteria given in the string pointed by pattern. The pattern string can contain the special wild-card characters: * -- meaning match any number of characters, including zero, in the candidate string; ? -- meaning match any single character, which must be present to satisfy the match, in the candidate string.

The int arg count tells the minimum length of the pattern string, after '*' expansion, that will satisfy the string compare in this call. If count is negative, then forbid abbreviations: pattern and candidate strings must match exactly in content and length to give a good compare. If count is 0, then an empty pattern string (pattern == "") returns success. If count is positive, then must match "count" characters in the two strings to succeed, except we yield success if: -- pattern and candidate strings are the same length; or -- pattern string is shorter than "count"; or -- do_wildcards > 0 and final pattern char == '*'.

If the integer argument do_case == 0, then ignore the case of each character: compare the tolower() of each character; if do_case != 0, then consider case in character compares.

If the int arg do_wildcards == 0, then treat the wildcard characters '*' and '?' just like any others: do a normal char-for-char string compare. But if do_wildcards is nonzero, then the string compare uses those wildcard characters as you'd expect.

Returns: WC_MATCH on successful match. If not WC_MATCH, then the return val conveys a little more info: see wc_strncmp.h

Note on Resynchronization: After a span of one or more pattern-string '*' found; and an immediately following span of zero [sic: 0] or more '?', we have to resynchronize the candidate string with the pattern string: need to find a place in the candidate to restart our compares. We've not a clue how many chars a span of '*' will match/absorb/represent until we find the next matching character in the candidate string. For example:

------------------------------------------------------------------------- patt cand resync at 'A' what's going on? ------ ------- ------------- ------------------------------------------ "***A" "AbcdA" "A----" "***" matches zero characters "**A" "aAcdA" "-A---" "**" absorbs just one char: "a" "*??A" "abcdA" "----A" "*" absorbs "ab", "??" skips "cd" "**?A" "abAdA" "--A--" "**" absorbs "a", "?" skips "b" -------------------------------------------------------------------------

During any resync phase, we'll naturally be looking for the end of the candidate string and fail if we see it.

Generated on Tue Jan 24 19:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WildcardStrncmp.hpp Source File

Auxiliary/WildcardStrncmp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 // Copyright notice of the original code:
00011
00012 /* ***************************************************************************
00013  *
00014  *          Copyright 1992-2002 by Pete Wilson All Rights Reserved
00015  *           50 Staples Street : Lowell Massachusetts 01851 : USA
00016  *        http://www.pwilson.net/   pete@pwilson.net   +1 978-454-4547
00017  *
00018  * This item is free software: you can redistribute it and/or modify it as
00019  * long as you preserve this copyright notice. Pete Wilson prepared this item
00020  * hoping it might be useful, but it has NO WARRANTY WHATEVER, not even any
00021  * implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
00022  *
00023  *************************************************************************** */
00024
00025 // Modified the code to a template which can be used with char and wchar.
00026
00027 #if !defined(Apoxi_WildcardStrncmp_hpp)
00028 #define Apoxi_WildcardStrncmp_hpp
00029
00030 #include <Kernel/Types.hpp>
00031
00097 template <typename T>
00098 INT wc_strncmp(const T * pattern,      /* match this str (can contain *,?) */
00099                const T * candidate,    /*   against this one. */
00100                INT count,              /* require count chars in pattern */
00101                INT do_case,            /* 0 = no case, !0 = cased compare */
00102                INT do_wildcards);      /* 0 = no wc's, !0 = honor * and ? */
00103
00104 #define WC_QUES '?'
00105 #define WC_STAR '*'
00106
00107 /* string and character match/no-match return codes */
00108
00109 enum {
00110   WC_MATCH = 0,     /* char/string-match succeed */
00111   WC_MISMATCH,      /* general char/string-match fail */
00112   WC_PAT_NULL_PTR,  /* (char *) pattern == NULL */
00113   WC_CAN_NULL_PTR,  /* (char *) candidate == NULL */
00114   WC_PAT_TOO_SHORT, /* too few pattern chars to satisfy count */
00115   WC_CAN_TOO_SHORT  /* too few candidate chars to satisfy '?' in pattern */
00116 };
00117
00118 #endif  // Apoxi_WildcardStrncmp_hpp
00119
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Wsprintf.cpp File Reference

Auxiliary/Wsprintf.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "WStrUtil.hpp"
#include "Macros.hpp"

Include dependency graph for Wsprintf.cpp:

Defines

#define | DP_C_LDOUBLE 3
#define | DP_C_LONG 2
#define | DP_C_SHORT 1
#define | DP_F_MINUS (1 << 0)
#define | DP_F_NUM (1 << 3)
#define | DP_F_PLUS (1 << 1)
#define | DP_F_SPACE (1 << 2)
#define | DP_F_UNSIGNED (1 << 6)
#define | DP_F_UP (1 << 5)
#define | DP_F_ZERO (1 << 4)
#define | DP_S_BCK 2
#define | DP_S_CONV 7
#define | DP_S_DEFAULT 0
#define | DP_S_DONE 9
#define | DP_S_DOT 4
#define | DP_S_FLAGS 1
#define | DP_S_HEX 8
#define | DP_S_MAX 5
#define | DP_S_MIN 3
#define | DP_S_MOD 6
#define | MAX(p, q) ((p >= q) ? p : q)
#define | W_LATIN_ZERO 0

Functions

INT | WStrPrintf (WCHAR *str, INT maxStrChars, const WCHAR *fmt,...)
INT | WStrPrintf (WCHAR *str, const WCHAR *fmt,...)
void | wstrprintf (WCHAR *buffer, INT maxBufChars, const WCHAR *format, va_list args,...)
void | wstrprintf (WCHAR *buffer, const WCHAR *format, va_list args,...)

Define Documentation

#define DP_C_LDOUBLE 3

#define DP_C_LONG 2

#define DP_C_SHORT 1

#define DP_F_MINUS (1 << 0)

#define DP_F_NUM (1 << 3)

#define DP_F_PLUS (1 << 1)

#define DP_F_SPACE (1 << 2)

#define DP_F_UNSIGNED (1 << 6)

#define DP_F_UP (1 << 5)

#define DP_F_ZERO (1 << 4)

#define DP_S_BCK 2

#define DP_S_CONV 7

#define DP_S_DEFAULT 0

#define DP_S_DONE 9

#define DP_S_DOT 4

#define DP_S_FLAGS 1

#define DP_S_HEX 8

#define DP_S_MAX 5

#define DP_S_MIN 3

#define DP_S_MOD 6

#define MAX | ( | p,
 |  | q | ) | ((p >= q) ? p : q)

#define W_LATIN_ZERO 0

Generated on Tue Jan 24 19:46:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/Wsscanf.cpp File Reference

Auxiliary/Wsscanf.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "StrUtil.hpp"
#include "Latin.hpp"
#include "WStrUtil.hpp"

Include dependency graph for Wsscanf.cpp:

Defines

#define | EOS(s) (s == 0x0000)
#define | F_LONG 0x02
#define | F_SIGNALLOW 0x04
#define | F_SUPPRESS 0x01
#define | FlagsIsSet(flags, flag) ((flags & flag) != 0)
#define | FlagsSet(flags, flag) (flags |= flag)
#define | IsInFieldRange(field_width, position) (field_width == 0 || position < field_width)
#define | ReportErrorAndReturn return (res_stored * -1 - 3)

Functions

INT | WStrScanf (const WCHAR *str, const WCHAR *format,...)
INT | wstrscanf (const WCHAR *str, const WCHAR *format, va_list ap,...)

Define Documentation

#define EOS ( s ) (s == 0x0000)

#define F_LONG 0x02

#define F_SIGNALLOW 0x04

#define F_SUPPRESS 0x01

#define FlagsIsSet | ( | flags,
 |  | flag | ) | ((flags & flag) != 0)

#define FlagsSet | ( | flags,
 |  | flag | ) | (flags |= flag)

#define IsInFieldRange | ( | field_width,
 |  | position | ) | (field_width == 0 || position < field_width)

#define ReportErrorAndReturn return (res_stored * -1 - 3)

Generated on Tue Jan 24 19:46:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WString.cpp File Reference

Auxiliary/WString.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include <Config/MemoryConfig.hpp>
#include "WString.hpp"
#include "Unicode.hpp"
#include "Macros.hpp"
#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for WString.cpp:

Defines

#define | ExtendedDbgCode(code)

Functions

void | WStringAccessOperatorTest ()
void | WStringAccessTest ()
void | WStringAssignmentOperators ()
void | WStringCompareOperatorTest ()
void | WStringConstructorTest ()
void | WStringFindTest ()
void | WStringFormatTest ()
void | WStringManipulationTest ()
void | WStringStreamOperators ()
void | WStringTest ()

Define Documentation

#define ExtendedDbgCode ( code )

Function Documentation

void WStringAccessOperatorTest ( )

void WStringAccessTest ( )

void WStringAssignmentOperators ( )

void WStringCompareOperatorTest ( )

void WStringConstructorTest ( )

void WStringFindTest ( )

void WStringFormatTest ( )

void WStringManipulationTest ( )

void WStringStreamOperators ( )

Generated on Tue Jan 24 19:46:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WString.hpp File Reference

Auxiliary/WString.hpp File Reference

#include <stdarg.h>
#include <Kernel/Types.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for WString.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | WStrData
class | WString

Defines

#define | _APOXI_WString_hpp
#define | APOXI_WSTRING_TEST_SUITE

Functions

void | WStringTest ()

Variables

const INT | wstring_max_buffer_size = 256

Define Documentation

#define _APOXI_WString_hpp

Generated on Tue Jan 24 19:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WString.hpp Source File

Auxiliary/WString.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(_APOXI_WString_hpp)
00009 #define _APOXI_WString_hpp
00012
00013 #include <stdarg.h>                 // Variable argument list
00014 #include <Kernel/Types.hpp>         // Standard types
00015 #include <Auxiliary/WStrUtil.hpp>   // WString utility methods
00016 #include <Auxiliary/String.hpp>     // String
00017
00021 struct WStrData {
00022     UINT8 m_refcount;
00023     UINT8 m_len;
00024     UINT16 m_bufsize;
00025     static WCHAR *m_null_str;
00026     static WStrData *m_null_strbuf;
00027
00029     void* operator new(UINT s, UINT wchar_count);
00030
00032     void operator delete(void *p);
00033
00035     const WCHAR* ToPtr() const { return (const WCHAR*) (this + 1); }
00036
00038     WCHAR* ToPtr() { return (WCHAR*) (this + 1); }
00039
00041     UINT GetLength() const;
00042
00044     void ResetRefCount();
00045
00047     void SetLength(UINT n);
00048
00050     void SetBufSize(UINT n);
00051
00053     UINT GetBufSize() const { return m_bufsize; }
00054
00056     BOOLEAN HasMultipleRefs() const { return m_refcount > 0; }
00057
00059     BOOLEAN IncRefCount();
00060
00062     void DecRefCount();
00063
00066     BOOLEAN IsNullStr() const { return this == m_null_strbuf; }
00067
00069     static WCHAR* GetNullStr() { return m_null_str; }
00070
00072     static WStrData* FromPtr(WCHAR *str) { return ((WStrData *) str) - 1; }
00073 };
00074
00075
00078 const INT wstring_max_buffer_size = 256;
00079
00080
00084 class WString {
00085
00086     friend class String;
00087
00088     public:
00090         WString();
00091
00093         WString(const WCHAR* str);
00094
00096         WString(const WCHAR* str, UINT len);
00097
00099         WString(const UINT8* str, UINT len);
00100
00102         WString(const WString& str);
00103
00105         WString(const WString* str);
00106
00108         WString(const CHAR* str);
00109
00111         WString(const String& str);
00112
00114         WString(INT32 val);
00115
00117         WString(WCHAR ch);
00118
00120         ~WString();
00121
00128         const WCHAR * GetCString() const { return m_strdata; }
00129
00131         const UINT8 * GetData() const  { return (UINT8*) m_strdata; }
00132
00135         BOOLEAN Reserve(UINT char_count) { return Modify(char_count + 1, TRUE); }
00136
00139         BOOLEAN PreAlloc(UINT char_count) { return Modify(char_count + 1, FALSE); }
00140
00142         BOOLEAN IsEmpty() const { return *m_strdata == 0; }
00143
00145         INT GetMemSize() const;
00146
00148         INT GetLength() const;
00149
00151         INT GetSize() const;
00152
00155         WString Substring(INT start, INT length = -1) const;
00156
00160         INT IndexOf(WCHAR ch, INT from = 0) const;
00161
00165         INT IndexOf(const WString& str, INT from = 0) const {
00166             return Find(str.GetCString(), from, str.GetLength());
00167         }
00168
00172         INT IndexOf(const WCHAR* str, INT from = 0) const {
00173             return Find(str, from, WStrLen(str));
00174         }
00175
00180         INT LastIndexOf(WCHAR ch, INT from = -1) const;
00181
00183         BOOLEAN StartsWith(const WString& other) const;
00184
00186         BOOLEAN StartsWith(WCHAR chr) const;
00187
00189         BOOLEAN EndsWith(const WString& other) const;
00190
00192         BOOLEAN EndsWith(WCHAR chr) const;
00193
00195         void StrCopy(const WCHAR* buffer, INT len);
00196
00198         String ToString() const;
00199
00203         String ToUtf8String() const;
00204
00206         WString& ToUpper();
00207
00209         WString& ToLower();
00210
00212         void Swap(WString & str);
00213
00215         void Clear();
00216
00218         void Erase(INT from);
00219
00221         void Erase(INT from, INT char_count);
00222
00224         void Replace(INT pos, WCHAR ch);
00225
00229         void Insert(INT pos, WCHAR ch);
00230
00234         void Insert(INT pos, const WString & str);
00235
00242         INT CompareTo(const WString& other_str,
00243                       BOOLEAN ignore_case = TRUE,
00244                       BOOLEAN locale_sensitive = TRUE) const
00245         {
00246             return WXStrCmp(m_strdata, other_str.GetCString(), ignore_case, locale_sensitive);
00247         }
00248
00256         INT CompareTo(const WCHAR* other_str,
00257                       BOOLEAN ignore_case = TRUE,
00258                       BOOLEAN locale_sensitive = TRUE) const
00259         {
00260             return WXStrCmp(m_strdata, other_str, ignore_case, locale_sensitive);
00261         }
00262
00268         static INT Compare(const WString& s1,
00269                            const WString& s2,
00270                            BOOLEAN ignore_case = TRUE,
00271                            BOOLEAN locale_sensitive = TRUE)
00272         {
00273             return WXStrCmp(s1.GetCString(), s2.GetCString(), ignore_case, locale_sensitive);
00274         }
00275
00277         void Format(const WCHAR* format,...);
00278
00280         void VFormat(const WCHAR* format, va_list args);
00281
00283         void Scan(const WCHAR* format,...) const;
00284
00286         BOOLEAN IsNumeric(INT number = -1) const { return IsNumeric(GetCString(), number); }
00287
00289         static BOOLEAN IsNumeric(const WCHAR* string, INT number = -1);
00290
00297         operator const WCHAR* () const  { return m_strdata; }
00298
00300         WCHAR operator [] (INT pos) const;
00301
00303         WString& operator = (const WString & str);
00304
00306         WString& operator = (const WCHAR *str);
00307
00309         WString operator + (const WString & str) const;
00310
00312         WString operator + (const WCHAR * str) const;
00313
00315         void operator += (const String & str) { *this << str; }
00316
00318         void operator += (const WString & str) { *this << str; }
00319
00321         void operator += (const CHAR * str) { *this << str; }
00322
00324         void operator += (const WCHAR * str) { *this << str; }
00325
00327         WString& operator << (const String & right);
00328
00330         WString& operator << (const String * right);
00331
00333         WString& operator << (const WString & right);
00334
00336         WString& operator << (const WString * right);
00337
00339         WString& operator << (const CHAR * right);
00340
00342         WString& operator << (const WCHAR * right);
00343
00345         WString& operator << (INT32 number);
00346
00348         BOOLEAN operator == (const WString & str) const { return CompareTo(str) == 0; }
00349
00351         BOOLEAN operator == (const WCHAR * str) const { return CompareTo(str) == 0; }
00352
00354         BOOLEAN operator != (const WString & str) const { return CompareTo(str) != 0; }
00355
00357         BOOLEAN operator < (const WString & right) const { return CompareTo(right) < 0; }
00358
00360         BOOLEAN operator <= (const WString & right) const { return CompareTo(right) <= 0; }
00361
00363         BOOLEAN operator > (const WString & right) const { return CompareTo(right) > 0; }
00364
00366         BOOLEAN operator >= (const WString & right) const { return CompareTo(right) >= 0; }
00367
00368 #if defined(APOXI_ENABLE_OBSOLETE_WSTRING_INTERFACE)
00369
00371         // Obsolete methods - should not be used anymore
00373
00375         const WCHAR* c_str() const;
00376
00378         const UINT8* data() const;
00379
00382         BOOLEAN reserve(UINT char_count);
00383
00386         BOOLEAN prealloc(UINT char_count);
00387
00389         BOOLEAN empty() const;
00390
00392         INT memsize() const;
00393
00395         INT length() const;
00396
00398         INT size() const;
00399
00402         WString substr(INT start, INT length = -1) const;
00403
00407         INT find(WCHAR ch, INT from = 0) const;
00408
00411         INT find(const WString & str, INT from = 0) const;
00412
00415         INT find(const WCHAR *str, INT from = 0) const;
00416
00421         INT reverse_find(WCHAR ch, INT from = -1) const;
00422
00424         BOOLEAN startswith(const WString & other) const;
00425
00427         BOOLEAN startswith(WCHAR chr) { return StartsWith(chr); }
00428
00430         BOOLEAN endswith(const WString & other) const;
00431
00433         BOOLEAN endswith(WCHAR chr) { return EndsWith(chr); }
00434
00436         String getstring() const;
00437
00439         void strcopy(const WCHAR * buffer, INT len);
00440
00442         WString& toupper();
00443
00445         WString& tolower();
00446
00448         void swap(WString & str);
00449
00451         void clear();
00452
00454         void erase(INT from);
00455
00457         void erase(INT from, INT char_count);
00458
00460         void replace(INT pos, WCHAR ch);
00461
00463         void insert(INT pos, WCHAR ch);
00464
00466         void insert(INT pos, const WString & str);
00467
00469         INT compare(const WString & other_str) const;
00470
00472         INT compare(const WCHAR * other_str) const;
00473
00475         void format(const WCHAR * format,...);
00476
00478         void vformat(const WCHAR * format, va_list args);
00479
00481         void scan(const WCHAR * format,...) const;
00482
00484         BOOLEAN HasOnlyDigits(INT number = -1) const;
00485
00487         static BOOLEAN HasOnlyDigits(const WCHAR * string, INT number = -1);
00488
00489 #endif // APOXI_ENABLE_OBSOLETE_WSTRING_INTERFACE
00490
00491     private:
00492         WCHAR *m_strdata;
00493
00494         BOOLEAN Allocate(UINT char_count);
00495         BOOLEAN Modify(UINT new_nchars, BOOLEAN preserve_content = TRUE);
00496         BOOLEAN AttachTo(WStrData *wsd);
00497         void DetachFrom(WStrData *wsd) const;
00498
00499         WStrData* GetWStrData() const { return WStrData::FromPtr(m_strdata); }
00500         UINT WCharToByteCount(UINT n) const { return n << 1U; }
00501
00502         INT Find(const WCHAR *str, INT from, INT searchlen) const;
00503         BOOLEAN ConCat(const CHAR *cc_str, UINT cc_len);
00504         BOOLEAN ConCat(const WCHAR *cc_str, UINT cc_len);
00505
00506         static WCHAR m_formatbuffer[wstring_max_buffer_size+1];
00507 };
00508
00509 #if !defined(APOXI_WSTRING_TEST_SUITE) && defined(APOXI_RTOS_WIN32)
00510 #define APOXI_WSTRING_TEST_SUITE
00511
00512 // Call for WString test suite, only for WIN32 platform
00513 extern void WStringTest();
00514
00515 #endif
00516
00518 #endif
00519
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WStrUtil.cpp File Reference

Auxiliary/WStrUtil.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include "WStrUtil.hpp"
#include "Macros.hpp"
#include <string.h>

Include dependency graph for WStrUtil.cpp:

Functions

WCHAR * | HexToWStr (UINT8 value, WCHAR *s)
WCHAR * | Int32ToWStr (INT32 value, WCHAR *s)
WCHAR * | IntToWStr (INT value, WCHAR *s)
INT | IsWbDigit (WCHAR c)
INT | IsWdDigit (WCHAR c)
INT | IsWminusSign (WCHAR c)
INT | IsWoDigit (WCHAR c)
INT | IsWplusSign (WCHAR c)
INT | IsWsign (WCHAR c)
INT | IsWwhiteSpace (WCHAR c)
INT | IsWxDigit (WCHAR c)
WCHAR * | IToW (INT value, WCHAR *s, INT radix)
WCHAR * | LToW (INT32 value, WCHAR *s, INT radix)
WCHAR * | StrToWStr (WCHAR *dest, const CHAR *src)
WCHAR * | UInt32ToWStr (UINT32 value, WCHAR *s)
WCHAR * | UIntToWStr (UINT value, WCHAR *s)
INT | WbDigitValue (WCHAR c)
WCHAR * | WCharStrToLower (WCHAR *wc)
WCHAR * | WCharStrToUpper (WCHAR *wc)
INT | WdDigitValue (WCHAR c)
WCHAR | WminusSign (void)
INT | WoDigitValue (WCHAR c)
WCHAR * | WStrCat (WCHAR *dest, const WCHAR *src)
UINT | WStrChr (const WCHAR *s, UINT size, const WCHAR c)
INT | WStrCmp (const WCHAR *s1, const WCHAR *s2)
WCHAR * | WStrCpy (WCHAR *dest, const WCHAR *src)
UINT | WStrLen (const WCHAR *s)
WCHAR * | WStrnCat (WCHAR *dest, const WCHAR *src, UINT maxlen)
INT | WStrnCmp (const WCHAR *s1, const WCHAR *s2, UINT maxlen)
WCHAR * | WStrnCpy (WCHAR *dest, const WCHAR *src, UINT maxlen)
INT | WStrPrINTD (WCHAR *dest, INT value)
UINT | WStrrChr (const WCHAR *send, UINT size, const WCHAR c)
UINT | WStrrStr (const WCHAR *s1end, UINT size, const WCHAR *s2)
UINT | WStrrStrn (const WCHAR *s1end, UINT size, const WCHAR *s2, UINT s2size)
UINT | WStrStr (const WCHAR *s1, UINT size, const WCHAR *s2)
UINT | WStrStrn (const WCHAR *s1, UINT size, const WCHAR *s2, UINT s2size)
INT | WStrToInt (const WCHAR *s)
INT32 | WStrToInt32 (const WCHAR *s)
CHAR * | WStrToStr (CHAR *dest, const WCHAR *src)
WCHAR | WxDigit (INT digit, INT xstyle)
INT | WxDigitValue (WCHAR c)
INT | WXStrCmp (const WCHAR *s1, const WCHAR *s2, BOOLEAN ignore_case, BOOLEAN locale_sensitive)

Function Documentation

WCHAR* IToW | ( | INT | value,
 |  | WCHAR * | s,
 |  | INT | radix
 | ) |

WCHAR* LToW | ( | INT32 | value,
 |  | WCHAR * | s,
 |  | INT | radix
 | ) |

INT WStrPrINTD | ( | WCHAR * | dest,
 |  | INT | value
 | ) |

Generated on Tue Jan 24 19:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WStrUtil.hpp File Reference

Auxiliary/WStrUtil.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Latin.hpp>
#include <Auxiliary/StrUtil.hpp>
#include <Auxiliary/WCattr.hpp>

Include dependency graph for WStrUtil.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | _APOXI_WStrutil_h

Functions

WCHAR * | HexToWStr (UINT8 value, WCHAR *s)
WCHAR * | Int32ToWStr (INT32 value, WCHAR *s)
WCHAR * | IntToWStr (INT value, WCHAR *s)
INT | IsWbDigit (WCHAR c)
INT | IsWdDigit (WCHAR c)
INT | IsWminusSign (WCHAR c)
INT | IsWoDigit (WCHAR c)
INT | IsWplusSign (WCHAR c)
INT | IsWsign (WCHAR c)
INT | IsWwhiteSpace (WCHAR c)
INT | IsWxDigit (WCHAR c)
WCHAR * | StrToWStr (WCHAR *dest, const CHAR *src)
WCHAR * | UInt32ToWStr (UINT32 value, WCHAR *s)
WCHAR * | UIntToWStr (UINT value, WCHAR *s)
INT | WbDigitValue (WCHAR c)
WCHAR * | WCharStrToLower (WCHAR *wc)
WCHAR * | WCharStrToUpper (WCHAR *wc)
WCHAR | WCharToLower (WCHAR wc)
WCHAR | WCharToUpper (WCHAR wc)
INT | WdDigitValue (WCHAR c)
WCHAR | WminusSign (void)
INT | WoDigitValue (WCHAR c)
WCHAR * | WStrCat (WCHAR *dest, const WCHAR *src)
UINT | WStrChr (const WCHAR *s, UINT size, const WCHAR c)
INT | WStrCmp (const WCHAR *s1, const WCHAR *s2)
WCHAR * | WStrCpy (WCHAR *dest, const WCHAR *src)
UINT | WStrLen (const WCHAR *s)
WCHAR * | WStrnCat (WCHAR *dest, const WCHAR *src, UINT maxlen)
INT | WStrnCmp (const WCHAR *s1, const WCHAR *s2, UINT maxlen)
WCHAR * | WStrnCpy (WCHAR *dest, const WCHAR *src, UINT maxlen)
INT | WStrPrintD (WCHAR *dest, INT value)
void | wstrprintf (WCHAR *buffer, const WCHAR *format, va_list args,...)
void | wstrprintf (WCHAR *buffer, INT maxBufChars, const WCHAR *format, va_list args,...)
INT | WStrPrintf (WCHAR *s, const WCHAR *format,...)
INT | WStrPrintf (WCHAR *s, INT maxStrChars, const WCHAR *format,...)
UINT | WStrrChr (const WCHAR *send, UINT size, const WCHAR c)
UINT | WStrrStr (const WCHAR *s1end, UINT size, const WCHAR *s2)
UINT | WStrrStrn (const WCHAR *s1end, UINT size, const WCHAR *s2, UINT s2size)
INT | wstrscanf (const WCHAR *str, const WCHAR *format, va_list args,...)
INT | WStrScanf (const WCHAR *s, const WCHAR *format,...)
UINT | WStrStr (const WCHAR *s1, UINT size, const WCHAR *s2)
UINT | WStrStrn (const WCHAR *s1, UINT size, const WCHAR *s2, UINT s2size)
INT | WStrToInt (const WCHAR *s)
INT32 | WStrToInt32 (const WCHAR *s)
CHAR * | WStrToStr (CHAR *dest, const WCHAR *src)
WCHAR | WxDigit (INT digit, INT xstyle)
INT | WxDigitValue (WCHAR c)
INT | WXStrCmp (const WCHAR *s1, const WCHAR *s2, BOOLEAN ignore_case=TRUE, BOOLEAN locale_sensitive=TRUE)

Define Documentation

#define _APOXI_WStrutil_h

Generated on Tue Jan 24 19:56:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary/WStrUtil.hpp Source File

Auxiliary/WStrUtil.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(_APOXI_WStrutil_h)
00010 #define _APOXI_WStrutil_h
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/Latin.hpp>
00016 #include <Auxiliary/StrUtil.hpp>
00017 #include <Auxiliary/WCattr.hpp>
00018
00019 UINT    WStrLen(const WCHAR *s);
00020 WCHAR * WStrCpy(WCHAR *dest, const WCHAR *src);
00021 WCHAR * WStrnCpy(WCHAR *dest, const WCHAR *src, UINT maxlen);
00022 INT     WStrCmp(const WCHAR *s1, const WCHAR *s2);
00023 INT     WXStrCmp(const WCHAR *s1, const WCHAR *s2, BOOLEAN ignore_case = TRUE, BOOLEAN locale_sensitive = TRUE);
00024 INT     WStrnCmp(const WCHAR *s1, const WCHAR *s2, UINT maxlen);
00025 WCHAR * WStrCat(WCHAR *dest, const WCHAR *src);
00026 WCHAR * WStrnCat(WCHAR *dest, const WCHAR *src, UINT maxlen);
00027 CHAR *  WStrToStr(CHAR *dest, const WCHAR *src);
00028 WCHAR * StrToWStr(WCHAR *dest, const CHAR *src);
00029 INT     WStrPrintD(WCHAR *dest, INT value);
00030
00031 INT     WStrPrintf(WCHAR *s, INT maxStrChars, const WCHAR *format, ...);
00032 INT     WStrPrintf(WCHAR *s, const WCHAR *format, ...);
00033 void    wstrprintf(WCHAR *buffer, INT maxBufChars, const WCHAR *format, va_list args, ...);
00034 void    wstrprintf(WCHAR *buffer, const WCHAR *format, va_list args, ...);
00035
00036 INT     WStrScanf(const WCHAR *s, const WCHAR * format, ...);
00037 INT     wstrscanf(const WCHAR* str, const WCHAR * format, va_list args, ...);
00038
00039 WCHAR   WCharToLower(WCHAR wc);
00040 WCHAR   WCharToUpper(WCHAR wc);
00041
00042 WCHAR*  WCharStrToLower(WCHAR *wc);
00043 WCHAR*  WCharStrToUpper(WCHAR *wc);
00044
00045 UINT    WStrChr(const WCHAR* s, UINT size, const WCHAR c);
00046 UINT    WStrrChr(const WCHAR* send, UINT size, const WCHAR c);
00047 UINT    WStrStr(const WCHAR* s1, UINT size, const WCHAR* s2);
00048 UINT    WStrStrn(const WCHAR* s1, UINT size, const WCHAR* s2, UINT s2size);
00049 UINT    WStrrStr(const WCHAR* s1end, UINT size, const WCHAR* s2);
00050 UINT    WStrrStrn(const WCHAR* s1end, UINT size, const WCHAR* s2, UINT s2size);
00051
00052 INT     WStrToInt(const WCHAR *s);
00053 INT32   WStrToInt32(const WCHAR *s);
00054 WCHAR * IntToWStr(INT value, WCHAR *s);
00055 WCHAR * Int32ToWStr(INT32 value, WCHAR *s);
00056 WCHAR * UIntToWStr(UINT value, WCHAR *s);
00057 WCHAR * UInt32ToWStr(UINT32 value, WCHAR *s);
00058 WCHAR * HexToWStr(UINT8 value, WCHAR *s);
00059
00060 INT     IsWwhiteSpace(WCHAR c);
00061 INT     IsWsign(WCHAR c);
00062 INT     IsWplusSign(WCHAR c);
00063 INT     IsWminusSign(WCHAR c);
00064 INT     IsWdDigit(WCHAR c);
00065 INT     IsWxDigit(WCHAR c);
00066 INT     IsWbDigit(WCHAR c);
00067 INT     IsWoDigit(WCHAR c);
00068 INT     WdDigitValue(WCHAR c);
00069 INT     WxDigitValue(WCHAR c);
00070 INT     WbDigitValue(WCHAR c);
00071 INT     WoDigitValue(WCHAR c);
00072 WCHAR   WminusSign(void);
00073 WCHAR   WxDigit(INT digit,INT xstyle);
00074
00075
00077 #endif  // _APOXI_WStrutil_h
00078
00079
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtApplicationMessage.cpp File Reference

Bluetooth/BtApplicationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtApplicationMessage.hpp"

Include dependency graph for BtApplicationMessage.cpp:

Generated on Tue Jan 24 20:00:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtApplicationMessage.hpp File Reference

Bluetooth/BtApplicationMessage.hpp File Reference

#include <Kernel/Message.hpp>
#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtApplicationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtApplicationMessage

Defines

#define | Bluetooth_BtApplicationMessage_hpp

Define Documentation

#define Bluetooth_BtApplicationMessage_hpp

Generated on Tue Jan 24 20:00:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtApplicationMessage.hpp Source File

Bluetooth/BtApplicationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshot\lnz_development\src\Apoxi\Bluetooth\BtApplicationMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtApplicationMessage_hpp)
00016 #define Bluetooth_BtApplicationMessage_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Bluetooth/BtTypes.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class BtApplicationMessage
00028     ====================================================================== */
00029
00031 class BtApplicationMessage : public Message {
00032     public:
00033         BtApplicationMessage(const BtResultCode& result);
00034         virtual ~BtApplicationMessage();
00035
00036         virtual const MsgMetaData& GetMetaData() const;
00037         void SetResult(const BtResultCode& result) { m_result = result; }
00038         const BtResultCode& GetResult() const { return m_result; }
00039         virtual Message* Clone() const;
00040
00041         enum  {
00042             ID = 10000
00043             };
00044
00045     private:
00046         static const MsgMetaData m_meta_data;
00047         BtResultCode m_result;
00048
00049     };
00050
00051 #endif // Bluetooth_BtApplicationMessage_hpp
00052
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtAudioAccessoryService.cpp File Reference

Bluetooth/BtAudioAccessoryService.cpp File Reference

#include "PreComp.hpp"
#include "BtAudioAccessoryService.hpp"

Include dependency graph for BtAudioAccessoryService.cpp:

Generated on Tue Jan 24 20:00:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtAudioAccessoryService.hpp File Reference

Bluetooth/BtAudioAccessoryService.hpp File Reference

#include <Bluetooth/BtService.hpp>

Include dependency graph for BtAudioAccessoryService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAudioAccessoryService

Defines

#define | BT_AA_INVALID_VOLUME_LEVEL 0xFF
#define | BtAudioAccessoryService_hpp

Define Documentation

#define BtAudioAccessoryService_hpp

Generated on Tue Jan 24 20:00:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtAudioAccessoryService.hpp Source File

Bluetooth/BtAudioAccessoryService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAudioAccessoryService_hpp)
00009 #define BtAudioAccessoryService_hpp
00012
00013 #include <Bluetooth/BtService.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     macro definitions
00017     ------------------------------------------------------------------------ */
00018
00019 #define BT_AA_INVALID_VOLUME_LEVEL 0xFF
00020
00023 class BtAudioAccessoryService: public BtService
00024 {
00025     private:
00026         typedef BtService Base;
00027
00028     public:
00030         BtAudioAccessoryService();
00031
00033         BtAudioAccessoryService(const BtDevice& target_device);
00034
00036         virtual ~BtAudioAccessoryService();
00037
00038     public:
00040
00042         BOOLEAN GetAudioAlwaysOnAccessory() const;
00043
00045
00047         void SetAudioAlwaysOnAccessory(BOOLEAN audio_always_on_accessory);
00048
00050
00052         BOOLEAN GetUseInbandRinging() const;
00053
00055
00057         virtual void SetUseInbandRinging(BOOLEAN use_inband_ringing);
00058
00059     public:
00061
00063         virtual BOOLEAN IsConnected() const = 0;
00064
00066
00068         virtual BOOLEAN IsRinging() const = 0;
00069
00071
00073         virtual BOOLEAN IsInCall() const = 0;
00074
00076
00078         virtual BtRequestState ConnectRequest() = 0;
00079
00081
00083         virtual BtRequestState DisconnectRequest() = 0;
00084
00086
00088         virtual BtRequestState TransferAudioToPhoneRequest() = 0;
00089
00091
00093         virtual BtRequestState TransferAudioToAccessoryRequest() = 0;
00094
00096
00098         virtual UINT8 GetMicrophoneGain() const = 0;
00099
00101
00103         virtual BtRequestState SetMicrophoneGainRequest(INT8 gain_offset) = 0;
00104
00106
00108         virtual UINT8 GetSpeakerGain() const = 0;
00109
00111
00113         virtual BtRequestState SetSpeakerGainRequest(INT8 gain_offset) = 0;
00114
00115     private:
00117         BOOLEAN m_audio_always_on_accessory;
00118
00120         BOOLEAN m_use_inband_ringing;
00121 };  // BtAudioAccessoryService
00122
00124 #endif  // BtAudioAccessoryService_hpp
00125
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableBroadcastRequest.cpp File Reference

Bluetooth/BtCancelableBroadcastRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtCancelableBroadcastRequest.hpp"

Include dependency graph for BtCancelableBroadcastRequest.cpp:

Generated on Tue Jan 24 20:00:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableBroadcastRequest.hpp File Reference

Bluetooth/BtCancelableBroadcastRequest.hpp File Reference

#include <Bluetooth/BtCancelableRequest.hpp>

Include dependency graph for BtCancelableBroadcastRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtCancelableBroadcastRequest

Defines

#define | BtCancelableBroadcastRequest_hpp

Define Documentation

#define BtCancelableBroadcastRequest_hpp

Generated on Tue Jan 24 20:00:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableBroadcastRequest.hpp Source File

Bluetooth/BtCancelableBroadcastRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtCancelableBroadcastRequest_hpp)
00009 #define BtCancelableBroadcastRequest_hpp
00012
00013 #include <Bluetooth/BtCancelableRequest.hpp>
00014
00024 class BtCancelableBroadcastRequest: public BtCancelableRequest
00025 {
00026     private:
00027         typedef BtCancelableRequest Base;
00028
00029     public:
00031         BtCancelableBroadcastRequest();
00032
00034         virtual ~BtCancelableBroadcastRequest();
00035 };
00036
00038 #endif  // BtCancelableBroadcastRequest_hpp
00039
00040
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableMulticastRequest.cpp File Reference

Bluetooth/BtCancelableMulticastRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtCancelableMulticastRequest.hpp"

Include dependency graph for BtCancelableMulticastRequest.cpp:

Generated on Tue Jan 24 20:00:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableMulticastRequest.hpp File Reference

Bluetooth/BtCancelableMulticastRequest.hpp File Reference

#include <Bluetooth/BtDeviceList.hpp>
#include <Bluetooth/BtCancelableRequest.hpp>

Include dependency graph for BtCancelableMulticastRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtCancelableMulticastRequest

Defines

#define | BtCancelableMulticastRequest_hpp

Define Documentation

#define BtCancelableMulticastRequest_hpp

Generated on Tue Jan 24 20:00:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableMulticastRequest.hpp Source File

Bluetooth/BtCancelableMulticastRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtCancelableMulticastRequest_hpp)
00009 #define BtCancelableMulticastRequest_hpp
00012
00013 #include <Bluetooth/BtDeviceList.hpp>
00014 #include <Bluetooth/BtCancelableRequest.hpp>
00015
00025 class BtCancelableMulticastRequest: public BtCancelableRequest
00026 {
00027     private:
00028         typedef BtCancelableRequest Base;
00029
00030     public:
00032         BtCancelableMulticastRequest(const BtDeviceList& device_list);
00033
00035         virtual ~BtCancelableMulticastRequest();
00036
00038
00042         BtDeviceList& GetDeviceList();
00043
00045
00049         const BtDeviceList& GetDeviceList() const;
00050
00052
00059         void SetDeviceList(const BtDeviceList& device_list);
00060
00061     private:
00063         BtDeviceList m_device_list;
00064 };
00065
00067 #endif  // BtCancelableMulticastRequest_hpp
00068
00069
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableRequest.cpp File Reference

Bluetooth/BtCancelableRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtCancelableRequest.hpp"

Include dependency graph for BtCancelableRequest.cpp:

Generated on Tue Jan 24 20:00:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableRequest.hpp File Reference

Bluetooth/BtCancelableRequest.hpp File Reference

#include <Bluetooth/BtLocalRequest.hpp>

Include dependency graph for BtCancelableRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtCancelableRequest

Defines

#define | BtCancelableRequest_hpp

Define Documentation

#define BtCancelableRequest_hpp

Generated on Tue Jan 24 20:00:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtCancelableRequest.hpp Source File

Bluetooth/BtCancelableRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtCancelableRequest_hpp)
00009 #define BtCancelableRequest_hpp
00012
00013 #include <Bluetooth/BtLocalRequest.hpp>
00014
00022 class BtCancelableRequest: public BtLocalRequest
00023 {
00024     private:
00025         typedef BtLocalRequest Base;
00026
00027     public:
00029         BtCancelableRequest();
00030
00032         virtual ~BtCancelableRequest();
00033
00035
00048         virtual BOOLEAN IsCancelable() const;
00049 };
00050
00052 #endif  // BtCancelableRequest_hpp
00053
00054
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectionBasedController.cpp File Reference

Bluetooth/BtConnectionBasedController.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtConnectionBasedController.hpp"

Include dependency graph for BtConnectionBasedController.cpp:

Generated on Tue Jan 24 20:00:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectionBasedController.hpp File Reference

Bluetooth/BtConnectionBasedController.hpp File Reference

#include <Bluetooth/BtController.hpp>

Include dependency graph for BtConnectionBasedController.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtConnectionBasedController

Defines

#define | BtConnectionBasedController_hpp

Define Documentation

#define BtConnectionBasedController_hpp

Generated on Tue Jan 24 20:00:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectionBasedController.hpp Source File

Bluetooth/BtConnectionBasedController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtConnectionBasedController_hpp)
00009 #define BtConnectionBasedController_hpp
00012
00013 #include <Bluetooth/BtController.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtGapAndSdapController;
00020
00029 class BtConnectionBasedController: public BtController
00030 {
00031     private:
00032         typedef BtController Base;
00033
00034     public:
00036         BtConnectionBasedController();
00037
00039         virtual ~BtConnectionBasedController();
00040
00042
00052         virtual UINT8 GetPriority() const;
00053
00054     protected:
00056
00058         virtual void Init();
00059
00061
00071         virtual btapi_userid_t GetUserId() const;
00072
00074
00085         virtual btapi_cb_funp_t* GetCallbackFunctionPointers() const;
00086
00088
00110         virtual BOOLEAN IsDeviceConnected(const BtDevice& device) const = 0;
00111
00112     private:
00113         friend class BtGapAndSdapController;
00114 };
00115
00117 #endif  // BtConnectionBasedController_hpp
00118
00119
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectionlessController.cpp File Reference

Bluetooth/BtConnectionlessController.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtConnectionlessController.hpp"

Include dependency graph for BtConnectionlessController.cpp:

Generated on Tue Jan 24 20:00:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectionlessController.hpp File Reference

Bluetooth/BtConnectionlessController.hpp File Reference

#include <Bluetooth/BtController.hpp>
#include <Bluetooth/BtServiceRequest.hpp>

Include dependency graph for BtConnectionlessController.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtConnectionlessController

Defines

#define | BtConnectionlessController_hpp

Define Documentation

#define BtConnectionlessController_hpp

Generated on Tue Jan 24 20:00:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectionlessController.hpp Source File

Bluetooth/BtConnectionlessController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtConnectionlessController_hpp)
00009 #define BtConnectionlessController_hpp
00012
00013 #include <Bluetooth/BtController.hpp>
00014 #include <Bluetooth/BtServiceRequest.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00020 class BtGapAndSdapController;
00021
00024 class BtConnectionlessController: public BtController
00025 {
00026     private:
00027         typedef BtController Base;
00028
00029     public:
00031         BtConnectionlessController();
00032
00034         virtual ~BtConnectionlessController();
00035
00037
00047         virtual UINT8 GetPriority() const;
00048
00049     protected:
00051
00053         virtual void Init();
00054
00056
00066         virtual btapi_userid_t GetUserId() const;
00067
00069
00080         virtual btapi_cb_funp_t* GetCallbackFunctionPointers() const;
00081
00083
00092         BtServiceRequest* GetExecutingRequest() const;
00093
00095
00112         BOOLEAN PrepareRequestExecution(BtServiceRequest* request);
00113
00115
00140         BtServiceRequest* CleanUpRequestExecution(BtResultCode result_code, BtRequestType request_type);
00141
00142     private:
00144         Mutex m_executing_request_mutex;
00145
00147         BtServiceRequest* m_executing_request;
00148     private:
00149         friend class BtGapAndSdapController;
00150 };
00151
00153 #endif  // BtConnectionlessController_hpp
00154
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectRequest.cpp File Reference

Bluetooth/BtConnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtService.hpp"
#include "BtRequestMessage.hpp"
#include "BtConnectRequest.hpp"

Include dependency graph for BtConnectRequest.cpp:

Generated on Tue Jan 24 20:00:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectRequest.hpp File Reference

Bluetooth/BtConnectRequest.hpp File Reference

#include <Bluetooth/BtServiceRequest.hpp>

Include dependency graph for BtConnectRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtConnectRequest

Defines

#define | BtConnectRequest_hpp

Define Documentation

#define BtConnectRequest_hpp

Generated on Tue Jan 24 20:00:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConnectRequest.hpp Source File

Bluetooth/BtConnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtConnectRequest_hpp)
00009 #define BtConnectRequest_hpp
00012
00013 #include <Bluetooth/BtServiceRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtSingleConnectionController;
00020
00027 class BtConnectRequest: public BtServiceRequest
00028 {
00029     private:
00030         typedef BtServiceRequest Base;
00031
00032     public:
00034         BtConnectRequest(BtService& service);
00035
00037         virtual ~BtConnectRequest();
00038
00039     protected:
00041
00056         virtual BOOLEAN Execute();
00057
00059
00073         virtual BOOLEAN PerformConnectControllerCall() = 0;
00074
00075     protected:
00077
00084         const btapi_connect_t* GetApiSettings() const;
00085
00086     private:
00088         btapi_connect_t m_api_connect;
00089
00090     private:
00091         friend class BtSingleConnectionController;
00092 };
00093
00095 #endif  // BtConnectRequest_hpp
00096
00097
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConstants.hpp File Reference

Bluetooth/BtConstants.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Bt_Constants_hpp
#define | BT_MDC_AUDIO_VIDEO 0x04
#define | BT_MDC_COMPUTER 0x01
#define | BT_MDC_IMAGING 0x06
#define | BT_MDC_LAN 0x03
#define | BT_MDC_MASK 0x1F
#define | BT_MDC_PERIPHERAL 0x05
#define | BT_MDC_PHONE 0x02
#define | BT_MDC_SHIFT 8
#define | BT_MDC_UNCATEGORIZED 0x1F
#define | BT_MSC_AUDIO 0x100
#define | BT_MSC_CAPTURING 0x040
#define | BT_MSC_INFORMATION 0x400
#define | BT_MSC_MASK 0x7FF
#define | BT_MSC_NETWORK 0x010
#define | BT_MSC_OBJECT_TRANSFER 0x080
#define | BT_MSC_POSITIONING 0x008
#define | BT_MSC_RENDERING 0x020
#define | BT_MSC_SHIFT 13
#define | BT_MSC_TELEPHONY 0x200
#define | BT_SDC_01_TO_17_UTILIZED 0x08
#define | BT_SDC_17_TO_33_UTILIZED 0x10
#define | BT_SDC_33_TO_50_UTILIZED 0x18
#define | BT_SDC_50_TO_67_UTILIZED 0x20
#define | BT_SDC_67_TO_83_UTILIZED 0x28
#define | BT_SDC_83_TO_99_UTILIZED 0x30
#define | BT_SDC_CAMCORDER 0x0D
#define | BT_SDC_CAMERA 0x08
#define | BT_SDC_CAR_AUDIO 0x08
#define | BT_SDC_CARD_READER 0x18
#define | BT_SDC_CELLULAR 0x01
#define | BT_SDC_COMBO_KEYBOARD_POINTING_DEVICE 0x03
#define | BT_SDC_COMMON_ISDN_ACCESS 0x05
#define | BT_SDC_CORDLESS 0x02
#define | BT_SDC_DESKTOP_WORKSTATION 0x01
#define | BT_SDC_DIGITIZER_TABLET 0x14
#define | BT_SDC_DISPLAY 0x04
#define | BT_SDC_GAMEPAD 0x08
#define | BT_SDC_GAMING_TOY 0x12
#define | BT_SDC_HAEDPHONES 0x06
#define | BT_SDC_HANDHELD_PC_PDA 0x04
#define | BT_SDC_HANDS_FREE 0x02
#define | BT_SDC_HEADSET 0x01
#define | BT_SDC_HIFI_AUDIO 0x0A
#define | BT_SDC_JOYSTICK 0x04
#define | BT_SDC_KEYBOARD 0x01
#define | BT_SDC_LAPTOP 0x03
#define | BT_SDC_LOUDSPEAKER 0x05
#define | BT_SDC_MASK 0x3F
#define | BT_SDC_MICROPHONE 0x04
#define | BT_SDC_NO_SERVICE 0x38
#define | BT_SDC_PALM_SIZED_PS_PDA 0x05
#define | BT_SDC_POINTING_DEVICE 0x02
#define | BT_SDC_PORTABLE_AUDIO 0x07
#define | BT_SDC_PRINTER 0x20
#define | BT_SDC_REMOTE_CONTROL 0x0C
#define | BT_SDC_SCANNER 0x10
#define | BT_SDC_SENSING_DEVICE 0x10
#define | BT_SDC_SERVER_CLASS_COMPUTER 0x02
#define | BT_SDC_SET_TOP_BOX 0x09
#define | BT_SDC_SHIFT 2
#define | BT_SDC_SMART_PHONE 0x03
#define | BT_SDC_VCR 0x0B
#define | BT_SDC_VIDEO_CAMERA 0x0C
#define | BT_SDC_VIDEO_CONFERENCING 0x10
#define | BT_SDC_VIDEO_DISPLAY_AND_LOUDSPEAKER 0x0F
#define | BT_SDC_VIDEO_MONITOR 0x0E
#define | BT_SDC_WEARABLE_COMPUTER 0x06
#define | BT_SDC_WIRED_MODEM_OR_VOICE_GATEWAY 0x04

Define Documentation

#define Bt_Constants_hpp

Generated on Tue Jan 24 20:00:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtConstants.hpp Source File

Bluetooth/BtConstants.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bt_Constants_hpp)
00009 #define Bt_Constants_hpp
00012
00013 /*---------------------------------------------------------------------------*
00014  * Constants for GAP & SDAP                                                  *
00015  *---------------------------------------------------------------------------*/
00016
00017 // BT...Bluetooth, MSC...Major Service Class
00018 #define BT_MSC_SHIFT           13
00019 #define BT_MSC_MASK            0x7FF
00020 #define BT_MSC_POSITIONING     0x008
00021 #define BT_MSC_NETWORK         0x010
00022 #define BT_MSC_RENDERING       0x020
00023 #define BT_MSC_CAPTURING       0x040
00024 #define BT_MSC_OBJECT_TRANSFER 0x080
00025 #define BT_MSC_AUDIO           0x100
00026 #define BT_MSC_TELEPHONY       0x200
00027 #define BT_MSC_INFORMATION     0x400
00028
00029 // BT...Bluetooth, MDC...Major Device Class
00030 #define BT_MDC_SHIFT         8
00031 #define BT_MDC_MASK          0x1F
00032 #define BT_MDC_COMPUTER      0x01
00033 #define BT_MDC_PHONE         0x02
00034 #define BT_MDC_LAN           0x03
00035 #define BT_MDC_AUDIO_VIDEO   0x04
00036 #define BT_MDC_PERIPHERAL    0x05
00037 #define BT_MDC_IMAGING       0x06
00038 #define BT_MDC_UNCATEGORIZED 0x1F
00039
00040 // BT...Bluetooth, SDC...(Sub) minor Device Class
00041 #define BT_SDC_SHIFT 2
00042 #define BT_SDC_MASK  0x3F
00043
00044 // Minor Device Class for BT_MDC_COMPUTER
00045 #define BT_SDC_DESKTOP_WORKSTATION   0x01
00046 #define BT_SDC_SERVER_CLASS_COMPUTER 0x02
00047 #define BT_SDC_LAPTOP                0x03
00048 #define BT_SDC_HANDHELD_PC_PDA       0x04
00049 #define BT_SDC_PALM_SIZED_PS_PDA     0x05
00050 #define BT_SDC_WEARABLE_COMPUTER     0x06
00051
00052 // Minor Device Class for BT_MDC_PHONE
00053 #define BT_SDC_CELLULAR                     0x01
00054 #define BT_SDC_CORDLESS                     0x02
00055 #define BT_SDC_SMART_PHONE                  0x03
00056 #define BT_SDC_WIRED_MODEM_OR_VOICE_GATEWAY 0x04
00057 #define BT_SDC_COMMON_ISDN_ACCESS           0x05
00058
00059 // Minor Device Class for BT_MDC_LAN
00060 #define BT_SDC_01_TO_17_UTILIZED 0x08
00061 #define BT_SDC_17_TO_33_UTILIZED 0x10
00062 #define BT_SDC_33_TO_50_UTILIZED 0x18
00063 #define BT_SDC_50_TO_67_UTILIZED 0x20
00064 #define BT_SDC_67_TO_83_UTILIZED 0x28
00065 #define BT_SDC_83_TO_99_UTILIZED 0x30
00066 #define BT_SDC_NO_SERVICE        0x38
00067
00068 // Minor Device Class for BT_MDC_AUDIO_VIDEO
00069 #define BT_SDC_HEADSET                       0x01
00070 #define BT_SDC_HANDS_FREE                    0x02
00071 #define BT_SDC_MICROPHONE                    0x04
00072 #define BT_SDC_LOUDSPEAKER                   0x05
00073 #define BT_SDC_HAEDPHONES                    0x06
00074 #define BT_SDC_PORTABLE_AUDIO                0x07
00075 #define BT_SDC_CAR_AUDIO                     0x08
00076 #define BT_SDC_SET_TOP_BOX                   0x09
00077 #define BT_SDC_HIFI_AUDIO                    0x0A
00078 #define BT_SDC_VCR                           0x0B
00079 #define BT_SDC_VIDEO_CAMERA                  0x0C
00080 #define BT_SDC_CAMCORDER                     0x0D
00081 #define BT_SDC_VIDEO_MONITOR                 0x0E
00082 #define BT_SDC_VIDEO_DISPLAY_AND_LOUDSPEAKER 0x0F
00083 #define BT_SDC_VIDEO_CONFERENCING            0x10
00084 #define BT_SDC_GAMING_TOY                    0x12
00085
00086 // Minor Device Class for BT_MDC_PERIPHERAL
00087 #define BT_SDC_KEYBOARD                       0x01
00088 #define BT_SDC_POINTING_DEVICE                0x02
00089 #define BT_SDC_COMBO_KEYBOARD_POINTING_DEVICE 0x03
00090 #define BT_SDC_JOYSTICK                       0x04
00091 #define BT_SDC_GAMEPAD                        0x08
00092 #define BT_SDC_REMOTE_CONTROL                 0x0C
00093 #define BT_SDC_SENSING_DEVICE                 0x10
00094 #define BT_SDC_DIGITIZER_TABLET               0x14
00095 #define BT_SDC_CARD_READER                    0x18
00096
00097 // Minor Device Class for BT_MDC_IMAGING
00098 #define BT_SDC_DISPLAY 0x04
00099 #define BT_SDC_CAMERA  0x08
00100 #define BT_SDC_SCANNER 0x10
00101 #define BT_SDC_PRINTER 0x20
00102
00104 #endif //Bt_Constants_hpp
00105
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtController.cpp File Reference

Bluetooth/BtController.cpp File Reference

#include "PreComp.hpp"
#include "BtController.hpp"

Include dependency graph for BtController.cpp:

Generated on Tue Jan 24 20:00:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtController.hpp File Reference

Bluetooth/BtController.hpp File Reference

#include <Kernel/Os/Mutex.hpp>
#include <Kernel/SubSystem.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtRequest.hpp>

Include dependency graph for BtController.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtController

Defines

#define | BtController_hpp

Define Documentation

#define BtController_hpp

Generated on Tue Jan 24 20:01:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtController.hpp Source File

Bluetooth/BtController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtController_hpp)
00009 #define BtController_hpp
00012
00013 #include <Kernel/Os/Mutex.hpp>
00014 #include <Kernel/SubSystem.hpp>
00015 #include <Bluetooth/BtTypes.hpp>
00016 #include <Bluetooth/BtRequest.hpp>
00017
00018 /*  ------------------------------------------------------------------------
00019     Forward deklarations for friend relationships.
00020     ------------------------------------------------------------------------ */
00021
00022 class BtGapAndSdapController;
00023
00038 class BtController: public SubSystem
00039 {
00040     private:
00041         typedef SubSystem Base;
00042
00043     public:
00045         BtController();
00046
00048         virtual ~BtController();
00049
00051
00057         virtual void OnPowerUp();
00058
00060
00066         virtual void OnPowerDown();
00067
00069
00075         virtual BootSequenceState InvokeAt() const;
00076
00077     protected:
00079
00085         virtual void Init() = 0;
00086
00088
00094         virtual void CleanUp();
00095
00097
00103         virtual void Register() = 0;
00104
00106
00112         virtual void Unregister() = 0;
00113
00115
00126         BOOLEAN GetIsRegistered() const;
00127
00129
00136         void SetIsRegistered(BOOLEAN is_registered);
00137
00139
00149         virtual btapi_userid_t GetUserId() const = 0;
00150
00152
00163         virtual btapi_cb_funp_t* GetCallbackFunctionPointers() const = 0;
00164
00166
00168         void PerformExecutionCallback(BtRequest* request, BtResultCode result);
00169
00170     private:
00172         BOOLEAN m_is_registered;
00173
00174     private:
00175         friend class BtGapAndSdapController;
00176 };
00177
00179 #endif  // BtController_hpp
00180
00181
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDevice.cpp File Reference

Bluetooth/BtDevice.cpp File Reference

#include "PreComp.hpp"
#include "BtConstants.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtDeviceAndServiceClass.hpp"
#include "BtDevice.hpp"

Include dependency graph for BtDevice.cpp:

Variables

const BtDevice bt_c_unknown_device
Generated on Tue Jan 24 20:01:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDevice.hpp File Reference

Bluetooth/BtDevice.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>
#include <Bluetooth/BtDeviceAndServiceClass.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for BtDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDevice

Defines

#define | BtDevice_hpp

Variables

const BtDevice | bt_c_unknown_device

Define Documentation

#define BtDevice_hpp

Generated on Tue Jan 24 20:01:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDevice.hpp Source File

Bluetooth/BtDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDevice_hpp)
00009 #define BtDevice_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtDeviceAddress.hpp>
00015 #include <Bluetooth/BtDeviceAndServiceClass.hpp>
00016 #include <Auxiliary/WString.hpp>
00017
00026 class BtDevice
00027 {
00028     public:
00030         BtDevice(const BtDeviceAddress& address = bt_c_empty_device_address);
00031
00033         BtDevice(const BtDevice& device);
00034
00036         virtual ~BtDevice();
00037
00039
00052         BtResultCode GetDeviceAddress(BtDeviceAddress& device_addres) const;
00053
00055
00068         BtResultCode GetDeviceName(WString& device_name) const;
00069
00071
00087         BtResultCode GetDeviceAndServiceClass(BtDeviceAndServiceClass& device_and_service_class) const;
00088
00090
00104         BtResultCode IsKnown(BOOLEAN& is_paired) const;
00105
00107
00120         BtResultCode IsPaired(BOOLEAN& is_paired) const;
00121
00123
00136         BtResultCode IsTrusted(BOOLEAN& is_trusted) const;
00137
00139
00152         BtResultCode IsConnected(BOOLEAN& is_connected) const;
00153
00155
00168         BOOLEAN operator==(const BtDevice& device) const;
00169
00171
00184         BOOLEAN operator!=(const BtDevice& device) const;
00185
00186     protected:
00188
00203         BOOLEAN GetRemoteDeviceInformation(btapi_known_device_t& remote_device_information) const;
00204
00205     private:
00207         BtDeviceAddress m_device_address;
00208
00209     private:
00210         friend class BtGapAndSdapController;
00211 };
00212
00213 extern const BtDevice bt_c_unknown_device;
00214
00216 #endif  // BtDevice_hpp
00217
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceAddress.cpp File Reference

Bluetooth/BtDeviceAddress.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceAddress.hpp"

Include dependency graph for BtDeviceAddress.cpp:

Variables

const BtDeviceAddress bt_c_empty_device_address
bt_c_empty_device_address represents an invalid device address
Generated on Tue Jan 24 20:01:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceAddress.hpp File Reference

Bluetooth/BtDeviceAddress.hpp File Reference

#include <stack/extensions.h>
#include <Auxiliary/WString.hpp>

Include dependency graph for BtDeviceAddress.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceAddress

Defines

#define | BtDeviceAddress_hpp

Variables

const BtDeviceAddress | bt_c_empty_device_address
bt_c_empty_device_address represents an invalid device address

Define Documentation

#define BtDeviceAddress_hpp

Generated on Tue Jan 24 20:01:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceAddress.hpp Source File

Bluetooth/BtDeviceAddress.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(BtDeviceAddress_hpp)
00010 #define BtDeviceAddress_hpp
00013
00014 #include <stack/extensions.h>
00015 #include <Auxiliary/WString.hpp>
00016
00021 class BtDeviceAddress
00022 {
00023     public:
00025         BtDeviceAddress();
00026
00028         BtDeviceAddress(const BtDeviceAddress& device_address);
00029
00031         BtDeviceAddress(const btapi_bdaddr_t& api_device_address);
00032
00034         BtDeviceAddress(const char* pc_device_address);
00035
00037         ~BtDeviceAddress();
00038
00040
00047         BtDeviceAddress& operator=(const BtDeviceAddress& device_address);
00048
00050
00063         BOOLEAN operator==(const BtDeviceAddress& device_address) const;
00064
00066
00079         BOOLEAN operator!=(const BtDeviceAddress& device_address) const;
00080
00082
00091         WString& AsString(WString& string) const;
00092
00094
00099         const btapi_bdaddr_t& GetApiDeviceAddress() const;
00100
00102
00108         void SetApiDeviceAddress(const btapi_bdaddr_t& api_devcie_address);
00109
00111
00113         void SetStringDeviceAddress(const char* pc_device_address);
00114
00115     private:
00117         btapi_bdaddr_t m_device_address;
00118 };
00119
00120 /*  ------------------------------------------------------------------------
00121     constant declartion
00122     ------------------------------------------------------------------------ */
00123
00125 extern const BtDeviceAddress bt_c_empty_device_address;
00126
00128 #endif // BtDeviceAddress_hpp
00129
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceAndServiceClass.cpp File Reference

Bluetooth/BtDeviceAndServiceClass.cpp File Reference

#include "PreComp.hpp"
#include "BtConstants.hpp"
#include "BtDeviceAndServiceClass.hpp"

Include dependency graph for BtDeviceAndServiceClass.cpp:

Generated on Tue Jan 24 20:01:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceAndServiceClass.hpp File Reference

Bluetooth/BtDeviceAndServiceClass.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceAndServiceClass

Defines

#define | BtDeviceAndServiceClass_hpp

Define Documentation

#define BtDeviceAndServiceClass_hpp

Generated on Tue Jan 24 20:01:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceAndServiceClass.hpp Source File

Bluetooth/BtDeviceAndServiceClass.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceAndServiceClass_hpp)
00009 #define BtDeviceAndServiceClass_hpp
00012
00013
00018 class BtDeviceAndServiceClass
00019 {
00020     public:
00022         BtDeviceAndServiceClass();
00023
00025         BtDeviceAndServiceClass(const BtDeviceAndServiceClass& device_and_service_class);
00026
00028         BtDeviceAndServiceClass(ULONG device_and_service_class);
00029
00031         virtual ~BtDeviceAndServiceClass();
00032
00034
00038         UINT8 GetMajorDeviceClass() const;
00039
00041
00044         void SetMajorDeviceClass(UINT8 major_device_class);
00045
00047
00052         UINT8 GetMinorDeviceClass() const;
00053
00055
00060         void SetMinorDeviceClass(UINT8 minor_device_class);
00061
00063
00067         UINT16 GetServiceClass() const;
00068
00070
00073         void SetServiceClass(UINT16 service_class);
00074
00076
00082         BtDeviceAndServiceClass& operator=(const BtDeviceAndServiceClass& device_and_service_class);
00083
00085
00098         BOOLEAN operator==(const BtDeviceAndServiceClass& device_and_service_class) const;
00099
00101
00114         BOOLEAN operator!=(const BtDeviceAndServiceClass& device_and_service_class) const;
00115
00116     private:
00118         ULONG m_device_and_service_class;
00119 };
00120
00122 #endif  // BtDeviceAndServiceClass_hpp
00123
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceFilter.cpp File Reference

Bluetooth/BtDeviceFilter.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceList.hpp"
#include "BtDeviceListIterator.hpp"
#include "BtDeviceFilter.hpp"

Include dependency graph for BtDeviceFilter.cpp:

Generated on Tue Jan 24 20:01:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceFilter.hpp File Reference

Bluetooth/BtDeviceFilter.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtDeviceAndServiceClass.hpp>
#include <Bluetooth/BtDevice.hpp>

Include dependency graph for BtDeviceFilter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceFilter

Defines

#define | BtDeviceFilter_hpp

Define Documentation

#define BtDeviceFilter_hpp

Generated on Tue Jan 24 20:01:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceFilter.hpp Source File

Bluetooth/BtDeviceFilter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceFilter_hpp)
00009 #define BtDeviceFilter_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtDeviceAndServiceClass.hpp>
00015 #include <Bluetooth/BtDevice.hpp>
00016
00022 class BtDeviceFilter
00023 {
00024     public:
00026         BtDeviceFilter();
00027
00029         BtDeviceFilter(const BtDeviceFilter& device_filter);
00030
00032         BtDeviceFilter(const BtDeviceAndServiceClass& device_and_service_class, BtDeviceState device_state = BtDsKnown);
00033
00035         virtual ~BtDeviceFilter();
00036
00038
00042         BtDeviceAndServiceClass& GetDeviceAndServiceClass();
00043
00045
00049         const BtDeviceAndServiceClass& GetDeviceAndServiceClass() const;
00050
00052
00056         void SetDeviceAndServiceClass(const BtDeviceAndServiceClass& device_and_service_class);
00057
00059
00063         BtDeviceState GetDeviceState() const;
00064
00066
00070         void SetDeviceState(BtDeviceState device_state);
00071
00073
00088         virtual BOOLEAN Matches(const BtDevice& device) const;
00089
00090     private:
00092         BtDeviceAndServiceClass m_device_and_service_class;
00093
00095         BtDeviceState m_device_state;
00096 };
00097
00099 #endif  // BtDeviceFilter_hpp
00100
00101
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceList.cpp File Reference

Bluetooth/BtDeviceList.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceList.hpp"
#include "BtDeviceListIterator.hpp"
#include "BtDeviceListReverseIterator.hpp"
#include "BtGapAndSdapController.hpp"

Include dependency graph for BtDeviceList.cpp:

Generated on Tue Jan 24 20:01:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceList.hpp File Reference

Bluetooth/BtDeviceList.hpp File Reference

#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtDeviceFilter.hpp>

Include dependency graph for BtDeviceList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceList
class | BtDeviceList::BtDeviceListBidirectionalIterator
class | BtDeviceList::BtDeviceListNode

Defines

#define | BtDeviceList_hpp

Variables

const BtDeviceList | bt_c_empty_device_list

Define Documentation

#define BtDeviceList_hpp

Generated on Tue Jan 24 20:01:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceList.hpp Source File

Bluetooth/BtDeviceList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceList_hpp)
00009 #define BtDeviceList_hpp
00012
00013 #include <Bluetooth/BtDevice.hpp>
00014 #include <Bluetooth/BtDeviceFilter.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     forward declartion
00018     ------------------------------------------------------------------------ */
00019 class BtGapAndSdapController;
00020 class BtDeviceListConstantIterator;
00021 class BtDeviceListIterator;
00022 class BtDeviceListConstantReverseIterator;
00023 class BtDeviceListReverseIterator;
00024
00049 class BtDeviceList
00050 {
00051     public:
00053
00062         explicit BtDeviceList(BOOLEAN do_refresh = FALSE, const BtDeviceFilter& device_filter = BtDeviceFilter());
00063
00065
00073         explicit BtDeviceList(const BtDeviceList& device_list, const BtDeviceFilter& device_filter = BtDeviceFilter());
00074
00076         virtual ~BtDeviceList();
00077
00079
00090         BtDeviceListIterator Begin();
00091
00093
00105         BtDeviceListConstantIterator Begin() const;
00106
00108
00112         BtDeviceListIterator End();
00113
00115
00119         BtDeviceListConstantIterator End() const;
00120
00122
00135         BtDeviceListReverseIterator RBegin();
00136
00138
00152         BtDeviceListConstantReverseIterator RBegin() const;
00153
00155
00161         BtDeviceListReverseIterator REnd();
00162
00164
00171         BtDeviceListConstantReverseIterator REnd() const;
00172
00174
00177         UINT GetSize() const;
00178
00180
00191         BOOLEAN IsEmpty() const;
00192
00194
00198         BtDevice& Front();
00199
00201
00205         const BtDevice& Front() const;
00206
00208
00212         BtDevice& Back();
00213
00215
00219         const BtDevice& Back() const;
00220
00222
00227         void PushFront(const BtDevice& device);
00228
00230
00232         void PopFront();
00233
00235
00240         void PushBack(const BtDevice& device);
00241
00243
00245         void PopBack();
00246
00248
00266         BtDeviceListIterator Insert(BtDeviceListIterator iterator, const BtDevice& device);
00267
00269
00289         BtDeviceListIterator Erase(BtDeviceListIterator iterator);
00290
00292
00313         BtDeviceListIterator Erase(BtDeviceListIterator first, BtDeviceListIterator last);
00314
00316
00318         void Clear(void);
00319
00321
00325         void Remove(const BtDevice& device);
00326
00328
00345         BtDeviceListIterator Find(const BtDevice& device);
00346
00348
00365         BtDeviceListConstantIterator Find(const BtDevice& device) const;
00366
00368
00385         BtDeviceListIterator Find(const BtDeviceAddress& device_address);
00386
00388
00405         BtDeviceListConstantIterator Find(const BtDeviceAddress& device_address) const;
00406
00408
00420         void Refresh(const BtDeviceFilter& device_filter = BtDeviceFilter());
00421
00423
00432         void Filter(const BtDeviceFilter& device_filter);
00433
00434     public:
00435         /*  BtDeviceListBidirectionalIterator is made public only because some
00436             target compilers can not dervive classes from nested protected or
00437             private classes. */
00438         class BtDeviceListBidirectionalIterator;
00439
00440     protected:
00441         friend class BtGapAndSdapController;
00442         friend class BtDeviceListBidirectionalIterator;
00443         friend class BtDeviceListConstantIterator;
00444         friend class BtDeviceListIterator;
00445         friend class BtDeviceListConstantReverseIterator;
00446         friend class BtDeviceListReverseIterator;
00447
00448
00455         class BtDeviceListNode
00456         {
00457             public:
00459                 BtDeviceListNode();
00460
00462                 virtual ~BtDeviceListNode();
00463
00464             public:
00466
00477                 BtDeviceListNode* GetNext();
00478
00480
00491                 const BtDeviceListNode* GetNext() const;
00492
00494
00500                 void SetNext(BtDeviceListNode* next);
00501
00503
00515                 BtDeviceListNode* GetPrevious();
00516
00518
00530                 const BtDeviceListNode* GetPrevious() const;
00531
00533
00539                 void SetPrevious(BtDeviceListNode* previous);
00540
00542
00549                 BtDevice& GetDevice();
00550
00552
00558                 const BtDevice& GetDevice() const;
00559
00561
00566                 void SetDevice(const BtDevice& device);
00567
00568             private:
00570                 BtDeviceListNode* m_next;
00571
00573                 BtDeviceListNode* m_previous;
00574
00576                 BtDevice m_device;
00577
00578             private:
00579                 friend class BtDeviceListBidirectionalIterator;
00580         };
00581
00582     public:
00583         /*  BtDeviceListBidirectionalIterator is made public only because some
00584             target compilers can not dervive classes from nested protected or
00585             private classes. */
00586
00591         class BtDeviceListBidirectionalIterator
00592         {
00593             public:
00595                 BtDeviceListBidirectionalIterator();
00596
00598                 explicit BtDeviceListBidirectionalIterator(const BtDeviceListBidirectionalIterator& bidirectional_iterator);
00599
00600             protected:
00602                 explicit BtDeviceListBidirectionalIterator(BtDeviceListNode* device_list_node);
00603
00604             protected:
00606
00612                 BtDeviceListNode* GetDeviceListNode()
00613                     { return m_device_list_node; }
00614
00616
00622                 const BtDeviceListNode* GetDeviceListNode() const
00623                     { return m_device_list_node; }
00624
00626
00633                 void SetDeviceListNode(BtDeviceListNode* device_list_node);
00634
00635             protected:
00637                 BtDeviceListNode* m_device_list_node;
00638         };
00639
00640     private:
00642         unsigned int m_size;
00643
00645
00648         BtDeviceListNode m_empty_node;
00649
00651
00654         BtDeviceListNode* m_anchor;
00655 };
00656
00657 const BtDeviceList bt_c_empty_device_list;
00659 #endif  // BtDeviceList_hpp
00660
00661
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceListIterator.cpp File Reference

Bluetooth/BtDeviceListIterator.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceListIterator.hpp"
#include "BtDeviceListReverseIterator.hpp"

Include dependency graph for BtDeviceListIterator.cpp:

Generated on Tue Jan 24 20:01:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceListIterator.hpp File Reference

Bluetooth/BtDeviceListIterator.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtDeviceList.hpp>

Include dependency graph for BtDeviceListIterator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceListConstantIterator
class | BtDeviceListIterator

Defines

#define | BtDeviceListIterator_hpp

Define Documentation

#define BtDeviceListIterator_hpp

Generated on Tue Jan 24 20:01:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceListIterator.hpp Source File

Bluetooth/BtDeviceListIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceListIterator_hpp)
00009 #define BtDeviceListIterator_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtDevice.hpp>
00015 #include <Bluetooth/BtDeviceList.hpp>
00016
00022 class BtDeviceListConstantIterator: public BtDeviceList::BtDeviceListBidirectionalIterator
00023 {
00024     private:
00025         typedef BtDeviceList::BtDeviceListBidirectionalIterator Base;
00026
00027         friend class BtDeviceListConstantReverseIterator;
00028         friend class BtDeviceList;
00029
00030     public:
00032         BtDeviceListConstantIterator();
00033
00035         explicit BtDeviceListConstantIterator(const BtDeviceListConstantReverseIterator& device_list_constant_reverse_iterator);
00036
00038
00044         const BtDevice& operator*() const;
00045
00047
00053         const BtDevice* operator->() const;
00054
00056
00063         BtDeviceListConstantIterator& operator++();
00064
00066
00074         BtDeviceListConstantIterator operator++(int);
00075
00077
00085         BtDeviceListConstantIterator& operator--();
00086
00088
00097         BtDeviceListConstantIterator operator--(int);
00098
00100
00114         BOOLEAN operator==(const BtDeviceListConstantIterator& device_list_constant_iterator) const;
00115
00117
00131         BOOLEAN operator!=(const BtDeviceListConstantIterator& device_list_constant_iterator) const;
00132
00134
00148         BOOLEAN operator==(const BtDeviceListConstantReverseIterator& device_list_constant_reverse_iterator) const;
00149
00151
00165         BOOLEAN operator!=(const BtDeviceListConstantReverseIterator& device_list_constant_reverse_iterator) const;
00166
00167     protected:
00169         explicit BtDeviceListConstantIterator(BtDeviceList::BtDeviceListNode* device_list_node);
00170 };
00171
00177 class BtDeviceListIterator : public BtDeviceListConstantIterator
00178 {
00179     private:
00180         typedef BtDeviceListConstantIterator Base;
00181
00182         friend class BtDeviceListReverseIteator;
00183         friend class BtDeviceList;
00184
00185     public:
00187         BtDeviceListIterator();
00188
00190         explicit BtDeviceListIterator(const BtDeviceListReverseIterator& device_list_reverse_iterator);
00191
00193
00199         BtDevice& operator*();
00200
00202
00208         BtDevice* operator->();
00209
00211
00218         BtDeviceListIterator& operator++();
00219
00221
00229         BtDeviceListIterator operator++(int);
00230
00232
00240         BtDeviceListIterator& operator--();
00241
00243
00252         BtDeviceListIterator operator--(int);
00253
00254     protected:
00256         explicit BtDeviceListIterator(BtDeviceList::BtDeviceListNode* device_list_node);
00257 };
00258
00260 #endif  // BtDeviceListIterator_hpp
00261
00262
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceListReverseIterator.cpp File Reference

Bluetooth/BtDeviceListReverseIterator.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceListReverseIterator.hpp"
#include "BtDeviceListIterator.hpp"

Include dependency graph for BtDeviceListReverseIterator.cpp:

Generated on Tue Jan 24 20:01:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceListReverseIterator.hpp File Reference

Bluetooth/BtDeviceListReverseIterator.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtDeviceList.hpp>

Include dependency graph for BtDeviceListReverseIterator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceListConstantReverseIterator
class | BtDeviceListReverseIterator

Defines

#define | BtDeviceListReverseIterator_hpp

Define Documentation

#define BtDeviceListReverseIterator_hpp

Generated on Tue Jan 24 20:01:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceListReverseIterator.hpp Source File

Bluetooth/BtDeviceListReverseIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceListReverseIterator_hpp)
00009 #define BtDeviceListReverseIterator_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtDevice.hpp>
00015 #include <Bluetooth/BtDeviceList.hpp>
00016
00022 class BtDeviceListConstantReverseIterator : public BtDeviceList::BtDeviceListBidirectionalIterator
00023 {
00024     private:
00025         typedef BtDeviceList::BtDeviceListBidirectionalIterator Base;
00026
00027         friend class BtDeviceListConstantIterator;
00028
00029     public:
00031         BtDeviceListConstantReverseIterator();
00032
00034         explicit BtDeviceListConstantReverseIterator(const BtDeviceListConstantIterator& device_list_constant_iterator);
00035
00037
00043         const BtDevice& operator*() const;
00044
00046
00052         const BtDevice* operator->() const;
00053
00055
00065         BtDeviceListConstantReverseIterator& operator++();
00066
00068
00078         BtDeviceListConstantReverseIterator operator++(int);
00079
00081
00092         BtDeviceListConstantReverseIterator& operator--();
00093
00095
00106         BtDeviceListConstantReverseIterator operator--(int);
00107
00109
00123         BOOLEAN operator==(const BtDeviceListConstantReverseIterator& device_list_constant_reverse_iterator) const;
00124
00126
00140         BOOLEAN operator!=(const BtDeviceListConstantReverseIterator& device_list_constant_reverse_iterator) const;
00141
00142     protected:
00144         explicit BtDeviceListConstantReverseIterator(BtDeviceList::BtDeviceListNode* device_list_node);
00145 };
00146
00152 class BtDeviceListReverseIterator: public BtDeviceListConstantReverseIterator
00153 {
00154     private:
00155         typedef BtDeviceListConstantReverseIterator Base;
00156
00157     public:
00159         BtDeviceListReverseIterator();
00160
00162         explicit BtDeviceListReverseIterator(const BtDeviceListIterator& device_list_iterator);
00163
00165
00171         BtDevice& operator*();
00172
00174
00180         BtDevice* operator->();
00181
00183
00192         BtDeviceListReverseIterator& operator++();
00193
00195
00205         BtDeviceListReverseIterator operator++(int);
00206
00208
00218         BtDeviceListReverseIterator& operator--();
00219
00221
00232         BtDeviceListReverseIterator operator--(int);
00233
00234     protected:
00236         explicit BtDeviceListReverseIterator(BtDeviceList::BtDeviceListNode* device_list_node);
00237 };
00238
00240 #endif  // BtDeviceListReverseIterator_hpp
00241
00242
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDevicePairRequest.cpp File Reference

Bluetooth/BtDevicePairRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtDevicePairRequest.hpp"

Include dependency graph for BtDevicePairRequest.cpp:

Generated on Tue Jan 24 20:01:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDevicePairRequest.hpp File Reference

Bluetooth/BtDevicePairRequest.hpp File Reference

#include <Bluetooth/BtUncancelablePointToPointRequest.hpp>

Include dependency graph for BtDevicePairRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDevicePairRequest

Defines

#define | BtDevicePairRequest_hpp

Define Documentation

#define BtDevicePairRequest_hpp

Generated on Tue Jan 24 20:01:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDevicePairRequest.hpp Source File

Bluetooth/BtDevicePairRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDevicePairRequest_hpp)
00009 #define BtDevicePairRequest_hpp
00012
00013 #include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtGapAndSdapController;
00020
00036 class BtDevicePairRequest: public BtUncancelablePointToPointRequest
00037 {
00038     private:
00039         typedef BtUncancelablePointToPointRequest Base;
00040
00041     public:
00043         BtDevicePairRequest(const BtDevice& device);
00044
00046         virtual ~BtDevicePairRequest();
00047
00049
00057         virtual BtRequestType GetRequestType() const;
00058
00060
00070         BOOLEAN GetCreateTrust() const;
00071
00073
00079         void SetCreateTrust(BOOLEAN create_trust);
00080
00081     protected:
00083
00104         virtual BOOLEAN Execute();
00105
00107
00112         virtual void RegisterMessages() const;
00113
00115
00120         virtual void UnregisterMessages() const;
00121
00123
00137
00138         virtual BOOLEAN OnMessage(const Message& message);
00139
00140     private:
00142
00144         const btapi_bond_settings_t* GetApiSettings() const;
00145
00146     private:
00148         btapi_bond_settings_t m_api_bond_settings;
00149
00150     private:
00151         friend class BtGapAndSdapController;
00152 };
00153
00155 #endif  // BtDevicePairRequest_hpp
00156
00157
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceSearchRequest.cpp File Reference

Bluetooth/BtDeviceSearchRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceList.hpp"
#include "BtDeviceListIterator.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtDeviceSearchRequest.hpp"

Include dependency graph for BtDeviceSearchRequest.cpp:

Defines

#define MAX_INQUIRY_TIMEOUT 0x30

Define Documentation

#define MAX_INQUIRY_TIMEOUT 0x30

Generated on Tue Jan 24 20:01:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceSearchRequest.hpp File Reference

Bluetooth/BtDeviceSearchRequest.hpp File Reference

#include <Bluetooth/BtDeviceList.hpp>
#include <Bluetooth/BtCancelableBroadcastRequest.hpp>

Include dependency graph for BtDeviceSearchRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceSearchRequest

Defines

#define | BtDeviceSearchRequest_hpp

Define Documentation

#define BtDeviceSearchRequest_hpp

Generated on Tue Jan 24 20:01:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceSearchRequest.hpp Source File

Bluetooth/BtDeviceSearchRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceSearchRequest_hpp)
00009 #define BtDeviceSearchRequest_hpp
00012
00013 #include <Bluetooth/BtDeviceList.hpp>
00014 #include <Bluetooth/BtCancelableBroadcastRequest.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00020 class BtGapAndSdapController;
00021
00028 class BtDeviceSearchRequest: public BtCancelableBroadcastRequest
00029 {
00030     private:
00031         typedef BtCancelableBroadcastRequest Base;
00032
00033     public:
00035         BtDeviceSearchRequest();
00036
00038         virtual ~BtDeviceSearchRequest();
00039
00041
00049         virtual BtRequestType GetRequestType() const;
00050
00052
00058         BtDeviceAndServiceClass GetDeviceAndServiceClass() const;
00059
00061
00067         void SetDeviceAndServiceClass(BtDeviceAndServiceClass device_and_service_class);
00068
00070
00077         UINT8 GetMaximalFoundDevices() const;
00078
00080
00090         void SetMaximalFoundDevice(UINT8 maximal_found_devices = 0);
00091
00093
00101         UINT8 GetInquiryTimeOut() const;
00102
00104
00115         void SetInquiryTimeOut(UINT8 inquiry_time_out = 0);
00116
00118
00123         BtInquiryAccessCode GetInquiryAccessCode() const;
00124
00126
00132         void SetInquiryAccessCode(BtInquiryAccessCode inquiry_access_code);
00133
00135
00146         BOOLEAN GetQueryRemoteDeviceName() const;
00147
00149
00154         void SetQueryRemoteDeviceName(BOOLEAN query_remote_device_name);
00155
00157
00159         BOOLEAN GetImmediatlyRetrieveRemoteDeviceNames() const;
00160
00162
00164         void SetImmediatlyRerieveRemoteDeviceNames(BOOLEAN immediatly_rerieve_names);
00165
00167
00172         const BtDeviceList& GetDeviceList() const;
00173
00174     protected:
00176
00197         virtual BOOLEAN Execute();
00198
00200
00217         virtual BOOLEAN Cancel();
00218
00220
00227         virtual void RegisterMessages(void) const;
00228
00230
00237         virtual void UnregisterMessages(void) const;
00238
00240
00254         virtual BOOLEAN OnMessage(const Message& message);
00255
00256         /* #################################################################
00257             ATTENTION: Obsolete, only for backward compatiblities - Start
00258            ############################################################## */
00259
00261
00273         virtual void OnRemoteDeviceFound(const BtDevice& remote_device, const BtDeviceAndServiceClass& remote_device_and_service_class);
00274
00275         /* #################################################################
00276             ATTENTION: Obsolete, only for backward compatiblities - End
00277            ############################################################## */
00278
00280
00292         virtual void OnRemoteDeviceFound(const BtDevice& remote_device, const BtDeviceAndServiceClass& remote_device_and_service_class, UINT8 signal_strength);
00293
00295
00308         virtual void OnRemoteDeviceName(const BtDevice& remote_device, const WString& remote_device_name);
00309
00310     private:
00312
00314         const btapi_device_search_req_t* GetApiSettings() const;
00315
00316     private:
00318         btapi_device_search_req_t m_api_device_search_request;
00319
00321         BtDeviceList m_device_list;
00322
00323     private:
00324         friend class BtGapAndSdapController;
00325 };
00326
00328 #endif  // BtDeviceSearchRequest_hpp
00329
00330
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceTrustRequest.cpp File Reference

Bluetooth/BtDeviceTrustRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtDeviceTrustRequest.hpp"

Include dependency graph for BtDeviceTrustRequest.cpp:

Generated on Tue Jan 24 20:01:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceTrustRequest.hpp File Reference

Bluetooth/BtDeviceTrustRequest.hpp File Reference

#include <Bluetooth/BtUncancelablePointToPointRequest.hpp>

Include dependency graph for BtDeviceTrustRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceTrustRequest

Defines

#define | BtDeviceTrustRequest_hpp

Define Documentation

#define BtDeviceTrustRequest_hpp

Generated on Tue Jan 24 20:01:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceTrustRequest.hpp Source File

Bluetooth/BtDeviceTrustRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceTrustRequest_hpp)
00009 #define BtDeviceTrustRequest_hpp
00012
00013 #include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
00014
00028 class BtDeviceTrustRequest: public BtUncancelablePointToPointRequest
00029 {
00030     private:
00031         typedef BtUncancelablePointToPointRequest Base;
00032
00033     public:
00035         BtDeviceTrustRequest(const BtDevice& device);
00036
00038         virtual ~BtDeviceTrustRequest();
00039
00041
00049         virtual BtRequestType GetRequestType() const;
00050
00051     protected:
00053
00074         virtual BOOLEAN Execute();
00075
00077
00082         virtual void RegisterMessages() const;
00083
00085
00090         virtual void UnregisterMessages() const;
00091
00093
00107         virtual BOOLEAN OnMessage(const Message& message);
00108 };
00109
00111 #endif  // BtDeviceTrustRequest_hpp
00112
00113
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceUnpairRequest.cpp File Reference

Bluetooth/BtDeviceUnpairRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtDeviceUnpairRequest.hpp"

Include dependency graph for BtDeviceUnpairRequest.cpp:

Generated on Tue Jan 24 20:02:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceUnpairRequest.hpp File Reference

Bluetooth/BtDeviceUnpairRequest.hpp File Reference

#include <Bluetooth/BtUncancelablePointToPointRequest.hpp>

Include dependency graph for BtDeviceUnpairRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceUnpairRequest

Defines

#define | BtDeviceUnpairRequest_hpp

Define Documentation

#define BtDeviceUnpairRequest_hpp

Generated on Tue Jan 24 20:02:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceUnpairRequest.hpp Source File

Bluetooth/BtDeviceUnpairRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceUnpairRequest_hpp)
00009 #define BtDeviceUnpairRequest_hpp
00012
00013 #include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
00014
00023 class BtDeviceUnpairRequest: public BtUncancelablePointToPointRequest
00024 {
00025     private:
00026         typedef BtUncancelablePointToPointRequest Base;
00027
00028     public:
00030         BtDeviceUnpairRequest(const BtDevice& device);
00031
00033         virtual ~BtDeviceUnpairRequest();
00034
00036
00044         virtual BtRequestType GetRequestType() const;
00045
00046     protected:
00048
00069         virtual BOOLEAN Execute();
00070
00072
00077         virtual void RegisterMessages() const;
00078
00080
00085         virtual void UnregisterMessages() const;
00086
00088
00102         virtual BOOLEAN OnMessage(const Message& message);
00103 };
00104
00106 #endif  // BtDeviceUnpairRequest_hpp
00107
00108
Generated on Tue Jan 24 14:48:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceUntrustRequest.cpp File Reference

Bluetooth/BtDeviceUntrustRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtDeviceUntrustRequest.hpp"

Include dependency graph for BtDeviceUntrustRequest.cpp:

Generated on Tue Jan 24 20:02:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceUntrustRequest.hpp File Reference

Bluetooth/BtDeviceUntrustRequest.hpp File Reference

#include <Bluetooth/BtUncancelablePointToPointRequest.hpp>

Include dependency graph for BtDeviceUntrustRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceUntrustRequest

Defines

#define | BtDeviceUntrustRequest_hpp

Define Documentation

#define BtDeviceUntrustRequest_hpp

Generated on Tue Jan 24 20:02:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDeviceUntrustRequest.hpp Source File

Bluetooth/BtDeviceUntrustRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceUntrustRequest_hpp)
00009 #define BtDeviceUntrustRequest_hpp
00012
00013 #include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
00014
00022 class BtDeviceUntrustRequest: public BtUncancelablePointToPointRequest
00023 {
00024     private:
00025         typedef BtUncancelablePointToPointRequest Base;
00026
00027     public:
00029         BtDeviceUntrustRequest(const BtDevice& device);
00030
00032         virtual ~BtDeviceUntrustRequest();
00033
00035
00043         virtual BtRequestType GetRequestType() const;
00044
00045     protected:
00047
00068         virtual BOOLEAN Execute();
00069
00071
00076         virtual void RegisterMessages() const;
00077
00079
00084         virtual void UnregisterMessages() const;
00085
00087
00101         virtual BOOLEAN OnMessage(const Message& message);
00102 };
00103
00105 #endif  // BtDeviceUntrustRequest_hpp
00106
00107
Generated on Tue Jan 24 14:48:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDisconnectRequest.cpp File Reference

Bluetooth/BtDisconnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtService.hpp"
#include "BtDisconnectRequest.hpp"
#include "BtRequestMessage.hpp"

Include dependency graph for BtDisconnectRequest.cpp:

Generated on Tue Jan 24 20:02:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDisconnectRequest.hpp File Reference

Bluetooth/BtDisconnectRequest.hpp File Reference

#include <Bluetooth/BtServiceRequest.hpp>

Include dependency graph for BtDisconnectRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDisconnectRequest

Defines

#define | BtDisconnectRequest_hpp

Define Documentation

#define BtDisconnectRequest_hpp

Generated on Tue Jan 24 20:02:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtDisconnectRequest.hpp Source File

Bluetooth/BtDisconnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDisconnectRequest_hpp)
00009 #define BtDisconnectRequest_hpp
00012
00013 #include <Bluetooth/BtServiceRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtSingleConnectionController;
00020
00028 class BtDisconnectRequest: public BtServiceRequest
00029 {
00030     private:
00031         typedef BtServiceRequest Base;
00032
00033     public:
00035         BtDisconnectRequest(BtService& service);
00036
00038         virtual ~BtDisconnectRequest();
00039
00040     protected:
00042
00057         virtual BOOLEAN Execute();
00058
00060
00074         virtual BOOLEAN PerformDisconnectControllerCall() = 0;
00075
00076     private:
00078
00085         const btapi_disconnect_t* GetApiSettings() const;
00086
00087     private:
00089         btapi_disconnect_t m_api_disconnect;
00090
00091     private:
00092         friend class BtSingleConnectionController;
00093 };
00094
00096 #endif  // BtDisconnectRequest_hpp
00097
00098
Generated on Tue Jan 24 14:48:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtEvent.cpp File Reference

Bluetooth/BtEvent.cpp File Reference

#include "PreComp.hpp"
#include "BtEvent.hpp"

Include dependency graph for BtEvent.cpp:

Generated on Tue Jan 24 20:02:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtEvent.hpp File Reference

Bluetooth/BtEvent.hpp File Reference

#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtEvent.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtEvent

Defines

#define | BtEvent_hpp

Define Documentation

#define BtEvent_hpp

Generated on Tue Jan 24 20:02:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtEvent.hpp Source File

Bluetooth/BtEvent.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtEvent_hpp)
00009 #define BtEvent_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014
00017 class BtEvent
00018 {
00019     public:
00021         BtEvent(BtResultCode result);
00022
00024         virtual ~BtEvent();
00025
00027
00029         BtResultCode GetResult() const;
00030
00031     public:
00033
00035         virtual UINT16 GetId() const = 0;
00036
00037     private:
00039         BtResultCode m_result;
00040 };
00041
00043 #endif  // BtEvent_hpp
00044
00045
Generated on Tue Jan 24 14:48:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapApplicationMessage.cpp File Reference

Bluetooth/BtGapAndSdapApplicationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapApplicationMessage.hpp"

Include dependency graph for BtGapAndSdapApplicationMessage.cpp:

Generated on Tue Jan 24 20:02:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapApplicationMessage.hpp File Reference

Bluetooth/BtGapAndSdapApplicationMessage.hpp File Reference

#include <Bluetooth/BtApplicationMessage.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtGapAndSdapApplicationMessage.hpp>

Include dependency graph for BtGapAndSdapApplicationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAuthorizationRequiredMessage
class | BtGapAndSdapApplicationMessage
class | BtGapAndSdapNotificationMessage
class | BtGapAndSdapRemoteRequestMessage
class | BtPasskeyRequiredMessage
class | BtRemoteDevicePairMessage

Defines

#define | Bluetooth_BtGapAndSdapApplicationMessage_hpp

Define Documentation

#define Bluetooth_BtGapAndSdapApplicationMessage_hpp

Generated on Tue Jan 24 20:02:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapApplicationMessage.hpp Source File

Bluetooth/BtGapAndSdapApplicationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshot\lnz_development\src\Apoxi\Bluetooth\BtGapAndSdapApplicationMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtGapAndSdapApplicationMessage_hpp)
00016 #define Bluetooth_BtGapAndSdapApplicationMessage_hpp
00017
00018 #include <Bluetooth/BtApplicationMessage.hpp>
00019 #include <Bluetooth/BtDevice.hpp>
00020 #include <Bluetooth/BtGapAndSdapApplicationMessage.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtGapAndSdapApplicationMessage
00029     ====================================================================== */
00030
00032 class BtGapAndSdapApplicationMessage : public BtApplicationMessage {
00033     public:
00034         BtGapAndSdapApplicationMessage(const BtResultCode& result);
00035         virtual ~BtGapAndSdapApplicationMessage();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         virtual Message* Clone() const;
00039
00040         enum  {
00041             ID = 10010
00042             };
00043
00044     private:
00045         static const MsgMetaData m_meta_data;
00046
00047     };
00048
00049
00050 /*  ======================================================================
00051     Class BtGapAndSdapRemoteRequestMessage
00052     ====================================================================== */
00053
00055 class BtGapAndSdapRemoteRequestMessage : public BtGapAndSdapApplicationMessage {
00056     public:
00057         BtGapAndSdapRemoteRequestMessage(const BtResultCode& result, const BtDeviceAddress& device_address, const WString& device_name);
00058         virtual ~BtGapAndSdapRemoteRequestMessage();
00059
00060         virtual const MsgMetaData& GetMetaData() const;
00061         void SetDeviceAddress(const BtDeviceAddress& device_address) { m_device_address = device_address; }
00062         const BtDeviceAddress& GetDeviceAddress() const { return m_device_address; }
00063         void SetDeviceName(const WString& device_name) { m_device_name = device_name; }
00064         const WString& GetDeviceName() const { return m_device_name; }
00065         virtual Message* Clone() const;
00066
00067         enum  {
00068             ID = 10011
00069             };
00070
00071     private:
00072         static const MsgMetaData m_meta_data;
00073         BtDeviceAddress m_device_address;
00074         WString m_device_name;
00075
00076     };
00077
00078
00079 /*  ======================================================================
00080     Class BtPasskeyRequiredMessage
00081     ====================================================================== */
00082
00084 class BtPasskeyRequiredMessage : public BtGapAndSdapRemoteRequestMessage {
00085     public:
00086         BtPasskeyRequiredMessage(const BtResultCode& result, const BtDeviceAddress& device_address, const WString& device_name);
00087         virtual ~BtPasskeyRequiredMessage();
00088
00089         virtual const MsgMetaData& GetMetaData() const;
00090         virtual Message* Clone() const;
00091
00092         enum  {
00093             ID = 10012
00094             };
00095
00096     private:
00097         static const MsgMetaData m_meta_data;
00098
00099     };
00100
00101
00102 /*  ======================================================================
00103     Class BtAuthorizationRequiredMessage
00104     ====================================================================== */
00105
00107 class BtAuthorizationRequiredMessage : public BtGapAndSdapRemoteRequestMessage {
00108     public:
00109         BtAuthorizationRequiredMessage(const BtResultCode& result, const BtDeviceAddress& device_address, const WString& device_name, const BtProfile& profile);
00110         virtual ~BtAuthorizationRequiredMessage();
00111
00112         virtual const MsgMetaData& GetMetaData() const;
00113         void SetProfile(const BtProfile& profile) { m_profile = profile; }
00114         const BtProfile& GetProfile() const { return m_profile; }
00115         virtual Message* Clone() const;
00116
00117         enum  {
00118             ID = 10013
00119             };
00120
00121     private:
00122         static const MsgMetaData m_meta_data;
00123         BtProfile m_profile;
00124
00125     };
00126
00127
00128 /*  ======================================================================
00129     Class BtGapAndSdapNotificationMessage
00130     ====================================================================== */
00131
00133 class BtGapAndSdapNotificationMessage : public BtGapAndSdapApplicationMessage {
00134     public:
00135         BtGapAndSdapNotificationMessage(const BtResultCode& result);
00136         virtual ~BtGapAndSdapNotificationMessage();
00137
00138         virtual const MsgMetaData& GetMetaData() const;
00139         virtual Message* Clone() const;
00140
00141         enum  {
00142             ID = 10014
00143             };
00144
00145     private:
00146         static const MsgMetaData m_meta_data;
00147
00148     };
00149
00150
00151 /*  ======================================================================
00152     Class BtRemoteDevicePairMessage
00153     ====================================================================== */
00154
00156 class BtRemoteDevicePairMessage : public BtGapAndSdapNotificationMessage {
00157     public:
00158         BtRemoteDevicePairMessage(const BtResultCode& result);
00159         virtual ~BtRemoteDevicePairMessage();
00160
00161         virtual const MsgMetaData& GetMetaData() const;
00162         virtual Message* Clone() const;
00163
00164         enum  {
00165             ID = 10015
00166             };
00167
00168     private:
00169         static const MsgMetaData m_meta_data;
00170
00171     };
00172
00173 #endif // Bluetooth_BtGapAndSdapApplicationMessage_hpp
00174
Generated on Tue Jan 24 14:48:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapController.cpp File Reference

Bluetooth/BtGapAndSdapController.cpp File Reference

#include "PreComp.hpp"
#include "BtTypes.hpp"
#include "BtUtility.hpp"
#include "BtSetRemoteDeviceNameRequest.hpp"
#include "BtDevicePairRequest.hpp"
#include "BtDeviceUnpairRequest.hpp"
#include "BtDeviceTrustRequest.hpp"
#include "BtDeviceUntrustRequest.hpp"
#include "BtQuerySupportedProfilesRequest.hpp"
#include "BtDeviceSearchRequest.hpp"
#include "BtServiceVerifyRequest.hpp"
#include "BtSddbRegisterServiceRecordRequest.hpp"
#include "BtSddbUnregisterServiceRecordRequest.hpp"
#include "BtServiceDiscoveryDatabase.hpp"
#include "BtGapAndSdapApplicationMessage.hpp"
#include "BtTransport.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtConnectionBasedController.hpp"

Include dependency graph for BtGapAndSdapController.cpp:

Generated on Tue Jan 24 20:02:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapController.hpp File Reference

Bluetooth/BtGapAndSdapController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtGapAndSdapController_hpp

Define Documentation

#define BtGapAndSdapController_hpp

Generated on Tue Jan 24 20:02:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapController.hpp Source File

Bluetooth/BtGapAndSdapController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtGapAndSdapController_hpp)
00009 #define BtGapAndSdapController_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <stack/extensions.h>
00021 #include <Kernel/Os/Mutex.hpp>
00022 #include <Bluetooth/BtTypes.hpp>
00023 #include <Bluetooth/BtDeviceAddress.hpp>
00024 #include <Bluetooth/BtDeviceAndServiceClass.hpp>
00025 #include <Bluetooth/BtLocalSettings.hpp>
00026 #include <Bluetooth/BtDeviceList.hpp>
00027 #include <Bluetooth/BtController.hpp>
00028
00029 /*  ------------------------------------------------------------------------
00030     Forward deklarations for friend relationships.
00031     ------------------------------------------------------------------------ */
00032
00033 class BtLocalSettings;
00034 class BtDevice;
00035 class BtDeviceList;
00036
00037 class BtTransport;
00038
00039 class BtSetRemoteDeviceNameRequest;
00040 class BtDevicePairRequest;
00041 class BtDeviceUnpairRequest;
00042 class BtDeviceTrustRequest;
00043 class BtDeviceUntrustRequest;
00044 class BtQuerySupportedProfilesRequest;
00045 class BtSendPasskeyRequest;
00046 class BtRespondAuthorizationRequest;
00047 class BtDeviceSearchRequest;
00048 class BtServiceVerifyRequest;
00049
00050 class BtSddbRegisterServiceRecordRequest;
00051 class BtSddbUnregisterServiceRecordRequest;
00052
00053 class BtConnectionlessController;
00054 class BtConnectionBasedController;
00055
00086 class BtGapAndSdapController: public BtController
00087 {
00088     private:
00089         typedef BtController Base;
00090
00091     public:
00093
00098         static BtGapAndSdapController& GetInstance();
00099
00100     public:
00102         virtual ~BtGapAndSdapController();
00103
00105
00109         virtual const WCHAR* GetName() const;
00110
00112
00117         virtual UINT8 GetPriority() const;
00118
00119     protected:
00121
00127         virtual void Init();
00128
00130
00145         virtual void Register();
00146
00148
00160         virtual void Unregister();
00161
00163
00173         virtual btapi_userid_t GetUserId() const;
00174
00176
00185         void SetUserId(btapi_userid_t user_id);
00186
00188
00199         virtual btapi_cb_funp_t* GetCallbackFunctionPointers() const;
00200
00202
00214         void SetCallbackFunctionPointers(btapi_cb_funp_t* callback_functions);
00215
00216     private:
00217         /*---------------------------------------------------------------------*/
00218         /* The following functions are used for the device list management     */
00219         /*---------------------------------------------------------------------*/
00220
00222
00242         BOOLEAN GetFilteredDeviceList(BtDeviceList& device_list, const BtDeviceFilter& device_filter);
00243
00245
00261         BOOLEAN GetKnownDeviceList(BtDeviceList& device_list);
00262
00264
00280         BOOLEAN GetPairedDeviceList(BtDeviceList& device_list);
00281
00282         /*---------------------------------------------------------------------*/
00283         /* The following functions are used for the local Bluetooth Device     */
00284         /*---------------------------------------------------------------------*/
00285
00287
00292         BtStackState GetLocalState() const;
00293
00295
00321         BtResultCode TurnOnRequest(BtLocalSettings* local_settings = 0);
00322
00324
00350         BtResultCode TurnOffRequest(BtLocalSettings* local_settings = 0);
00351
00353
00370         BOOLEAN GetChipVersion(BtChipVersion& chip_version) const;
00371
00373
00389         BOOLEAN GetLocalAddress(BtDeviceAddress& device_address) const;
00390
00392
00407         BOOLEAN GetLocalName(WString& local_name) const;
00408
00410
00437         BtResultCode SetLocalNameRequest(const WString& local_name, BtLocalSettings* local_settings = 0);
00438
00440
00457         BOOLEAN GetDiscoverableMode(BtDiscoverableMode& discoverable_mode) const;
00458
00460
00488         BtResultCode SetDiscoverableModeRequest(BtDiscoverableMode discoverable_mode = BtDmGeneralDiscoverable, BtLocalSettings* local_settings = 0);
00489
00491
00508         BOOLEAN GetPairableMode(BtPairableMode& pairable_mode) const;
00509
00511
00539         BtResultCode SetPairableModeRequest(BtPairableMode pairable_mode = BtPmPairable, BtLocalSettings* local_settings = 0);
00540
00542
00559         BOOLEAN GetConnectableMode(BtConnectableMode& connectable_mode) const;
00560
00562
00590         BtResultCode SetConnectableModeRequest(BtConnectableMode connectable_mode = BtCmConnectable, BtLocalSettings* local_settings = 0);
00591
00593
00595         BOOLEAN GetIsProfileActive(BtProfile profile, BOOLEAN& active);
00596
00598
00600         BtResultCode SetIsProfileActiveRequest(BtProfile profile, BOOLEAN active, BtLocalSettings* local_settings = 0);
00601
00602         /*---------------------------------------------------------------------*/
00603         /* The following functions are for remote Bluetooth devices            */
00604         /*---------------------------------------------------------------------*/
00605
00607
00629         BOOLEAN GetRemoteDeviceInformation(btapi_bdaddr_t& device_address, btapi_known_device_t& device_information) const;
00630
00632
00655         BOOLEAN SetRemoteDeviceNameRequest(BtSetRemoteDeviceNameRequest* set_remote_device_name_request);
00656
00658
00681         BOOLEAN DevicePairRequest(BtDevicePairRequest* device_pair_request);
00682
00684
00703         BOOLEAN DeviceUnpairRequest(BtDeviceUnpairRequest* device_unpair_request);
00704
00706
00726         BOOLEAN DeviceTrustRequest(BtDeviceTrustRequest* device_trust_request);
00727
00729
00749         BOOLEAN DeviceUntrustRequest(BtDeviceUntrustRequest* device_untrust_request);
00750
00752
00780         BOOLEAN QuerySupportedProfilesRequest(BtQuerySupportedProfilesRequest* query_supported_profiles_request);
00781
00783
00802         BOOLEAN SendPasskeyRequest(const btapi_passkey_rsp_t& passkey_response);
00803
00805
00824         BOOLEAN RespondAuthorizationRequest(const btapi_authorisation_rsp_t& authorization_response);
00825
00827
00857         BOOLEAN DeviceSearchRequest(BtDeviceSearchRequest* device_search_request);
00858
00860
00878         BOOLEAN CancelDeviceSearchRequest();
00879
00881
00909         BOOLEAN ServiceVerfiyRequest(BtServiceVerifyRequest* service_verify_request);
00910
00929         BOOLEAN CancelServiceVerifyRequest();
00930
00931         /*---------------------------------------------------------------------*/
00932         /* The following functions are for the SDDB                            */
00933         /*---------------------------------------------------------------------*/
00934
00936
00938         BOOLEAN SddbRegisterServiceRecordRequest(BtSddbRegisterServiceRecordRequest* register_service_record_request);
00939
00941
00943         BOOLEAN SddbUnregisterServiceRecordRequest(BtSddbUnregisterServiceRecordRequest* unregister_service_record_request);
00944
00945     private:
00946         /*---------------------------------------------------------------------*/
00947         /* The following functions must not be called by an application.       */
00948         /* They are the entry point from the stack callback functions into our */
00949         /* object orientated framework (APOXI).                                */
00950         /* They are implemented as static because they have to be passed as    */
00951         /* normal C function pointers. The reason for this is the BT-API Stack */
00952         /* interface that demands C function pointers for callback the         */
00953         /* callback functions it calls to state the progress of ongoing        */
00954         /* operations                                                          */
00955         /*---------------------------------------------------------------------*/
00956
00958
00963         static void OnStateChangedCallback(btapi_result_t result, btapi_stack_state_t state);
00964
00966
00972         void OnStateChanged(BtResultCode result, BtStackState state);
00973
00975
00981         static void OnGapCommonCallback(btapi_result_t result, btapi_common_gapcb_t type);
00982
00984
00989         void OnSetLocalName(BtResultCode result);
00990
00992
00997         void OnSetDiscoverable(BtResultCode result);
00998
01000
01005         void OnSetPairable(BtResultCode result);
01006
01008
01013         void OnSetConnectable(BtResultCode result);
01014
01016
01021         void OnPairedDeviceNameChange(BtResultCode result);
01022
01024
01030         void OnCreateBond(BtResultCode result);
01031
01033
01039         void OnPairedDeviceDelete(BtResultCode result);
01040
01042
01050         void OnPairedDeviceTrustChange(BtResultCode result);
01051
01053
01058         static void OnGapAuthorizationRequestCallback(btapi_result_t result, const btapi_authorisation_req_t *authorization_request);
01059
01061
01073         void OnAuthorization(BtResultCode result, const btapi_authorisation_req_t *authorization_request);
01074
01076
01081         static void OnGapPasskeyRequestCallback(btapi_result_t result, const btapi_passkey_req_t *passeky_request);
01082
01084
01094         void OnPasskey(BtResultCode result, const btapi_passkey_req_t *passeky_request);
01095
01097
01103         static void OnSdapCommonCallback(btapi_result_t result, btapi_common_sdapcb_t type);
01104
01106
01111         void OnAccessoryReq(BtResultCode result);
01112
01114
01119         void OnInquiry(BtResultCode result);
01120
01122
01127         void OnServiceSearch(BtResultCode result);
01128
01130
01135         void OnCancel(BtResultCode result);
01136
01138
01142         static void OnSdapRemoteDeviceCallback(btapi_result_t result, const btapi_remote_device_t *remote_device);
01143
01145
01153         void OnSdapRemoteDevice(const btapi_remote_device_t *remote_device);
01154
01156
01161         static void OnSdapRemoteDeviceNameCallback(btapi_result_t result, const btapi_remote_name_t *remote_name);
01162
01164
01174         void OnSdapRemoteDeviceName(const btapi_remote_name_t *remote_name);
01175
01177
01182         static void OnSdapServiceSearchCallback(btapi_result_t result, const btapi_service_search_rsp_t *service_search_response);
01183
01185
01199         void OnSdapServiceSearchResult(BtResultCode result, const btapi_service_search_rsp_t *service_search_response);
01200
01202
01207         static void OnSdapHsServiceCallback(btapi_result_t result, const btapi_hs_service_t *hs_service);
01208
01210
01220         void OnSdapHsService(BtResultCode result, const btapi_hs_service_t *hs_service);
01221
01223
01228         static void OnSdapHfServiceCallback(btapi_result_t result, const btapi_hf_service_t *hf_service);
01229
01231
01242         void OnSdapHfService(BtResultCode result, const btapi_hf_service_t *hf_service);
01243
01245
01250         static void OnSdapPaServiceCallback(btapi_result_t result, const btapi_pa_service_t *pa_service);
01251
01253
01264         void OnSdapPaService(BtResultCode result, const btapi_pa_service_t *pa_service);
01265
01267
01269         static void OnSddbServiceRegisterCallback(btapi_result_t result, const btapi_service_register_t* service_register);
01270
01272
01274         void OnSddbServiceRegister(BtResultCode result, const btapi_service_register_t* service_register);
01275
01277
01279         static void OnProfileActiveCallback(btapi_result_t result, const btapi_profile_active_t *response);
01280
01282
01284         void OnProfileActive(BtResultCode result, const btapi_profile_active_t *response);
01285
01286     private:
01288         BtGapAndSdapController();
01289
01291
01300         BtRequest* GetExecutingRequest() const;
01301
01303
01320         BOOLEAN PrepareRequestExecution(BtRequest* request);
01321
01323
01348         BtRequest* CleanUpRequestExecution(BtResultCode result, BtRequestType request_type);
01349
01351
01378         BtResultCode PerpareLocalRequestExecution(BtResultCode* result, BtLocalSettings* local_settings);
01379
01381
01406         void CleanUpLocalRequestExecution(BtResultCode result, BtLocalSettings* local_settings);
01407
01409
01425         UINT32 CallLocalRequestCallback(BtResultCode result, INT message_id);
01426
01428
01430         BOOLEAN AddControllerForRegistration(BtController* controller);
01431
01432     private:
01434
01436         class BtControllerListElement
01437         {
01438             public:
01440                 BtControllerListElement();
01441
01443                 virtual ~BtControllerListElement();
01444
01445             public:
01447
01449                 BtController* GetController() const;
01450
01452
01454                 void SetController(BtController* controller);
01455
01457
01459                 BtControllerListElement* GetNext() const;
01460
01462
01464                 void SetNext(BtControllerListElement* next);
01465
01466             private:
01468                 BtController* m_controller;
01469
01471                 BtControllerListElement* m_next;
01472         };
01473
01475
01477         static void BtStartupTimerFunction(void* timer_function_data);
01478
01479     private:
01481         btapi_userid_t m_user_id;
01482
01484         btapi_cb_funp_t* m_callback_functions;
01485
01487         btapi_gapcb_funp_t* m_gap_callback_functions;
01488
01490         btapi_sdapcb_funp_t* m_sdap_callback_functions;
01491
01493         Mutex m_executing_request_mutex;
01494
01496         BtRequest* m_executing_request;
01497
01499         Mutex m_executing_local_request_mutex;
01500
01502         BtLocalSettings* m_executing_local_request;
01503
01505         BtResultCode* m_executing_local_request_result;
01506
01508         BtControllerListElement* m_controller_list_anchor;
01509
01510     private:
01512         static BtGapAndSdapController m_controller;
01513
01515         static SystemTimer m_startup_timer;
01516
01517     private:
01518         friend class BtLocalSettings;
01519         friend class BtDevice;
01520         friend class BtDeviceList;
01521
01522         friend class BtTransport;
01523
01524         friend class BtSetRemoteDeviceNameRequest;
01525         friend class BtDevicePairRequest;
01526         friend class BtDeviceUnpairRequest;
01527         friend class BtDeviceTrustRequest;
01528         friend class BtDeviceUntrustRequest;
01529         friend class BtQuerySupportedProfilesRequest;
01530         friend class BtSendPasskeyRequest;
01531         friend class BtRespondAuthorizationRequest;
01532         friend class BtDeviceSearchRequest;
01533         friend class BtServiceVerifyRequest;
01534
01535         friend class BtSddbRegisterServiceRecordRequest;
01536         friend class BtSddbUnregisterServiceRecordRequest;
01537
01538         friend class BtConnectionlessController;
01539         friend class BtConnectionBasedController;
01540 };
01541
01543 #endif  // DOXYGEN_SHOULD_SKIP_THIS
01544 #endif  // BtGapAndSdapController_hpp
01545
01546
Generated on Tue Jan 24 14:48:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapRequestMessage.cpp File Reference

Bluetooth/BtGapAndSdapRequestMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"

Include dependency graph for BtGapAndSdapRequestMessage.cpp:

Generated on Tue Jan 24 20:02:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapRequestMessage.hpp File Reference

Bluetooth/BtGapAndSdapRequestMessage.hpp File Reference

#include <Bluetooth/BtRequestMessage.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtGapAndSdapRequestMessage.hpp>

Include dependency graph for BtGapAndSdapRequestMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtCancelSearchMessage
class | BtCancelVerifyMessage
class | BtConnectabilityMessage
class | BtDevicePairMessage
class | BtDeviceSearchMessage
class | BtDeviceTrustMessage
class | BtDeviceUnpairMessage
class | BtDeviceUntrustMessage
class | BtDiscoverabilityMessage
class | BtGapAndSdapRequestMessage
class | BtHfSupportedProfileMessage
class | BtHsSupportedProfileMessage
class | BtLocalNameMessage
class | BtLocalSettingsMessage
class | BtPairabilityMessage
class | BtPaSupportedProfileMessage
class | BtProfileActivationMessage
class | BtQuerySupportedProfilesMessage
class | BtRemoteDeviceMessage
class | BtRemoteDeviceNameMessage
class | BtRespondAuthorizationMessage
class | BtSendPasskeyMessage
class | BtServiceVerifyMessage
class | BtServiceVerifyResultMessage
class | BtSetRemoteDeviceNameMessage
class | BtStateChangedMessage

Defines

#define | Bluetooth_BtGapAndSdapRequestMessage_hpp

Define Documentation

#define Bluetooth_BtGapAndSdapRequestMessage_hpp

Generated on Tue Jan 24 20:02:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtGapAndSdapRequestMessage.hpp Source File

Bluetooth/BtGapAndSdapRequestMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\BtGapAndSdapRequestMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtGapAndSdapRequestMessage_hpp)
00016 #define Bluetooth_BtGapAndSdapRequestMessage_hpp
00017
00018 #include <Bluetooth/BtRequestMessage.hpp>
00019 #include <Bluetooth/BtDevice.hpp>
00020 #include <Bluetooth/BtGapAndSdapRequestMessage.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtGapAndSdapRequestMessage
00029     ====================================================================== */
00030
00032 class BtGapAndSdapRequestMessage : public BtRequestMessage {
00033     public:
00034         BtGapAndSdapRequestMessage(const BtResultCode& result, UINT32 request_id);
00035         virtual ~BtGapAndSdapRequestMessage();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         virtual Message* Clone() const;
00039
00040         enum  {
00041             ID = 10210
00042             };
00043
00044     private:
00045         static const MsgMetaData m_meta_data;
00046
00047     };
00048
00049
00050 /*  ======================================================================
00051     Class BtStateChangedMessage
00052     ====================================================================== */
00053
00055 class BtStateChangedMessage : public BtGapAndSdapRequestMessage {
00056     public:
00057         BtStateChangedMessage(const BtResultCode& result, UINT32 request_id, const BtStackState& stack_state);
00058         virtual ~BtStateChangedMessage();
00059
00060         virtual const MsgMetaData& GetMetaData() const;
00061         void SetStackState(const BtStackState& stack_state) { m_stack_state = stack_state; }
00062         const BtStackState& GetStackState() const { return m_stack_state; }
00063         virtual Message* Clone() const;
00064
00065         enum  {
00066             ID = 10211
00067             };
00068
00069     private:
00070         static const MsgMetaData m_meta_data;
00071         BtStackState m_stack_state;
00072
00073     };
00074
00075
00076 /*  ======================================================================
00077     Class BtLocalSettingsMessage
00078     ====================================================================== */
00079
00081 class BtLocalSettingsMessage : public BtGapAndSdapRequestMessage {
00082     public:
00083         BtLocalSettingsMessage(const BtResultCode& result, UINT32 request_id);
00084         virtual ~BtLocalSettingsMessage();
00085
00086         virtual const MsgMetaData& GetMetaData() const;
00087         virtual Message* Clone() const;
00088
00089         enum  {
00090             ID = 10212
00091             };
00092
00093     private:
00094         static const MsgMetaData m_meta_data;
00095
00096     };
00097
00098
00099 /*  ======================================================================
00100     Class BtLocalNameMessage
00101     ====================================================================== */
00102
00104 class BtLocalNameMessage : public BtLocalSettingsMessage {
00105     public:
00106         BtLocalNameMessage(const BtResultCode& result, UINT32 request_id);
00107         virtual ~BtLocalNameMessage();
00108
00109         virtual const MsgMetaData& GetMetaData() const;
00110         virtual Message* Clone() const;
00111
00112         enum  {
00113             ID = 10213
00114             };
00115
00116     private:
00117         static const MsgMetaData m_meta_data;
00118
00119     };
00120
00121
00122 /*  ======================================================================
00123     Class BtDiscoverabilityMessage
00124     ====================================================================== */
00125
00127 class BtDiscoverabilityMessage : public BtLocalSettingsMessage {
00128     public:
00129         BtDiscoverabilityMessage(const BtResultCode& result, UINT32 request_id);
00130         virtual ~BtDiscoverabilityMessage();
00131
00132         virtual const MsgMetaData& GetMetaData() const;
00133         virtual Message* Clone() const;
00134
00135         enum  {
00136             ID = 10214
00137             };
00138
00139     private:
00140         static const MsgMetaData m_meta_data;
00141
00142     };
00143
00144
00145 /*  ======================================================================
00146     Class BtPairabilityMessage
00147     ====================================================================== */
00148
00150 class BtPairabilityMessage : public BtLocalSettingsMessage {
00151     public:
00152         BtPairabilityMessage(const BtResultCode& result, UINT32 request_id);
00153         virtual ~BtPairabilityMessage();
00154
00155         virtual const MsgMetaData& GetMetaData() const;
00156         virtual Message* Clone() const;
00157
00158         enum  {
00159             ID = 10215
00160             };
00161
00162     private:
00163         static const MsgMetaData m_meta_data;
00164
00165     };
00166
00167
00168 /*  ======================================================================
00169     Class BtConnectabilityMessage
00170     ====================================================================== */
00171
00173 class BtConnectabilityMessage : public BtLocalSettingsMessage {
00174     public:
00175         BtConnectabilityMessage(const BtResultCode& result, UINT32 request_id);
00176         virtual ~BtConnectabilityMessage();
00177
00178         virtual const MsgMetaData& GetMetaData() const;
00179         virtual Message* Clone() const;
00180
00181         enum  {
00182             ID = 10216
00183             };
00184
00185     private:
00186         static const MsgMetaData m_meta_data;
00187
00188     };
00189
00190
00191 /*  ======================================================================
00192     Class BtProfileActivationMessage
00193     ====================================================================== */
00194
00196 class BtProfileActivationMessage : public BtLocalSettingsMessage {
00197     public:
00198         BtProfileActivationMessage(const BtResultCode& result, UINT32 request_id);
00199         virtual ~BtProfileActivationMessage();
00200
00201         virtual const MsgMetaData& GetMetaData() const;
00202         virtual Message* Clone() const;
00203
00204         enum  {
00205             ID = 10217
00206             };
00207
00208     private:
00209         static const MsgMetaData m_meta_data;
00210
00211     };
00212
00213
00214 /*  ======================================================================
00215     Class BtSendPasskeyMessage
00216     ====================================================================== */
00217
00219 class BtSendPasskeyMessage : public BtGapAndSdapRequestMessage {
00220     public:
00221         BtSendPasskeyMessage(const BtResultCode& result, UINT32 request_id);
00222         virtual ~BtSendPasskeyMessage();
00223
00224         virtual const MsgMetaData& GetMetaData() const;
00225         virtual Message* Clone() const;
00226
00227         enum  {
00228             ID = 10218
00229             };
00230
00231     private:
00232         static const MsgMetaData m_meta_data;
00233
00234     };
00235
00236
00237 /*  ======================================================================
00238     Class BtRespondAuthorizationMessage
00239     ====================================================================== */
00240
00242 class BtRespondAuthorizationMessage : public BtGapAndSdapRequestMessage {
00243     public:
00244         BtRespondAuthorizationMessage(const BtResultCode& result, UINT32 request_id);
00245         virtual ~BtRespondAuthorizationMessage();
00246
00247         virtual const MsgMetaData& GetMetaData() const;
00248         virtual Message* Clone() const;
00249
00250         enum  {
00251             ID = 10219
00252             };
00253
00254     private:
00255         static const MsgMetaData m_meta_data;
00256
00257     };
00258
00259
00260 /*  ======================================================================
00261     Class BtDeviceSearchMessage
00262     ====================================================================== */
00263
00265 class BtDeviceSearchMessage : public BtGapAndSdapRequestMessage {
00266     public:
00267         BtDeviceSearchMessage(const BtResultCode& result, UINT32 request_id);
00268         virtual ~BtDeviceSearchMessage();
00269
00270         virtual const MsgMetaData& GetMetaData() const;
00271         virtual Message* Clone() const;
00272
00273         enum  {
00274             ID = 10220
00275             };
00276
00277     private:
00278         static const MsgMetaData m_meta_data;
00279
00280     };
00281
00282
00283 /*  ======================================================================
00284     Class BtRemoteDeviceMessage
00285     ====================================================================== */
00286
00288 class BtRemoteDeviceMessage : public BtGapAndSdapRequestMessage {
00289     public:
00290         BtRemoteDeviceMessage(const BtResultCode& result, UINT32 request_id, const BtDeviceAddress& device_address, const BtDeviceAndServiceClass& device_and_service_class, UINT8 signal_strength);
00291         virtual ~BtRemoteDeviceMessage();
00292
00293         virtual const MsgMetaData& GetMetaData() const;
00294         void SetDeviceAddress(const BtDeviceAddress& device_address) { m_device_address = device_address; }
00295         const BtDeviceAddress& GetDeviceAddress() const { return m_device_address; }
00296         void SetDeviceAndServiceClass(const BtDeviceAndServiceClass& device_and_service_class) { m_device_and_service_class = device_and_service_class; }
00297         const BtDeviceAndServiceClass& GetDeviceAndServiceClass() const { return m_device_and_service_class; }
00298         void SetSignalStrength(UINT8 signal_strength) { m_signal_strength = signal_strength; }
00299         UINT8 GetSignalStrength() const { return m_signal_strength; }
00300         virtual Message* Clone() const;
00301
00302         enum  {
00303             ID = 10221
00304             };
00305
00306     private:
00307         static const MsgMetaData m_meta_data;
00308         BtDeviceAddress m_device_address;
00309         BtDeviceAndServiceClass m_device_and_service_class;
00310         UINT8 m_signal_strength;
00311
00312     };
00313
00314
00315 /*  ======================================================================
00316     Class BtRemoteDeviceNameMessage
00317     ====================================================================== */
00318
00320 class BtRemoteDeviceNameMessage : public BtGapAndSdapRequestMessage {
00321     public:
00322         BtRemoteDeviceNameMessage(const BtResultCode& result, UINT32 request_id, const BtDeviceAddress& device_address, const WString& device_name);
00323         virtual ~BtRemoteDeviceNameMessage();
00324
00325         virtual const MsgMetaData& GetMetaData() const;
00326         void SetDeviceAddress(const BtDeviceAddress& device_address) { m_device_address = device_address; }
00327         const BtDeviceAddress& GetDeviceAddress() const { return m_device_address; }
00328         void SetDeviceName(const WString& device_name) { m_device_name = device_name; }
00329         const WString& GetDeviceName() const { return m_device_name; }
00330         virtual Message* Clone() const;
00331
00332         enum  {
00333             ID = 10222
00334             };
00335
00336     private:
00337         static const MsgMetaData m_meta_data;
00338         BtDeviceAddress m_device_address;
00339         WString m_device_name;
00340
00341     };
00342
00343
00344 /*  ======================================================================
00345     Class BtCancelSearchMessage
00346     ====================================================================== */
00347
00349 class BtCancelSearchMessage : public BtGapAndSdapRequestMessage {
00350     public:
00351         BtCancelSearchMessage(const BtResultCode& result, UINT32 request_id);
00352         virtual ~BtCancelSearchMessage();
00353
00354         virtual const MsgMetaData& GetMetaData() const;
00355         virtual Message* Clone() const;
00356
00357         enum  {
00358             ID = 10223
00359             };
00360
00361     private:
00362         static const MsgMetaData m_meta_data;
00363
00364     };
00365
00366
00367 /*  ======================================================================
00368     Class BtSetRemoteDeviceNameMessage
00369     ====================================================================== */
00370
00372 class BtSetRemoteDeviceNameMessage : public BtGapAndSdapRequestMessage {
00373     public:
00374         BtSetRemoteDeviceNameMessage(const BtResultCode& result, UINT32 request_id);
00375         virtual ~BtSetRemoteDeviceNameMessage();
00376
00377         virtual const MsgMetaData& GetMetaData() const;
00378         virtual Message* Clone() const;
00379
00380         enum  {
00381             ID = 10224
00382             };
00383
00384     private:
00385         static const MsgMetaData m_meta_data;
00386
00387     };
00388
00389
00390 /*  ======================================================================
00391     Class BtDevicePairMessage
00392     ====================================================================== */
00393
00395 class BtDevicePairMessage : public BtGapAndSdapRequestMessage {
00396     public:
00397         BtDevicePairMessage(const BtResultCode& result, UINT32 request_id);
00398         virtual ~BtDevicePairMessage();
00399
00400         virtual const MsgMetaData& GetMetaData() const;
00401         virtual Message* Clone() const;
00402
00403         enum  {
00404             ID = 10225
00405             };
00406
00407     private:
00408         static const MsgMetaData m_meta_data;
00409
00410     };
00411
00412
00413 /*  ======================================================================
00414     Class BtDeviceUnpairMessage
00415     ====================================================================== */
00416
00418 class BtDeviceUnpairMessage : public BtGapAndSdapRequestMessage {
00419     public:
00420         BtDeviceUnpairMessage(const BtResultCode& result, UINT32 request_id);
00421         virtual ~BtDeviceUnpairMessage();
00422
00423         virtual const MsgMetaData& GetMetaData() const;
00424         virtual Message* Clone() const;
00425
00426         enum  {
00427             ID = 10226
00428             };
00429
00430     private:
00431         static const MsgMetaData m_meta_data;
00432
00433     };
00434
00435
00436 /*  ======================================================================
00437     Class BtDeviceTrustMessage
00438     ====================================================================== */
00439
00441 class BtDeviceTrustMessage : public BtGapAndSdapRequestMessage {
00442     public:
00443         BtDeviceTrustMessage(const BtResultCode& result, UINT32 request_id);
00444         virtual ~BtDeviceTrustMessage();
00445
00446         virtual const MsgMetaData& GetMetaData() const;
00447         virtual Message* Clone() const;
00448
00449         enum  {
00450             ID = 10227
00451             };
00452
00453     private:
00454         static const MsgMetaData m_meta_data;
00455
00456     };
00457
00458
00459 /*  ======================================================================
00460     Class BtDeviceUntrustMessage
00461     ====================================================================== */
00462
00464 class BtDeviceUntrustMessage : public BtGapAndSdapRequestMessage {
00465     public:
00466         BtDeviceUntrustMessage(const BtResultCode& result, UINT32 request_id);
00467         virtual ~BtDeviceUntrustMessage();
00468
00469         virtual const MsgMetaData& GetMetaData() const;
00470         virtual Message* Clone() const;
00471
00472         enum  {
00473             ID = 10228
00474             };
00475
00476     private:
00477         static const MsgMetaData m_meta_data;
00478
00479     };
00480
00481
00482 /*  ======================================================================
00483     Class BtQuerySupportedProfilesMessage
00484     ====================================================================== */
00485
00487 class BtQuerySupportedProfilesMessage : public BtGapAndSdapRequestMessage {
00488     public:
00489         BtQuerySupportedProfilesMessage(const BtResultCode& result, UINT32 request_id);
00490         virtual ~BtQuerySupportedProfilesMessage();
00491
00492         virtual const MsgMetaData& GetMetaData() const;
00493         virtual Message* Clone() const;
00494
00495         enum  {
00496             ID = 10229
00497             };
00498
00499     private:
00500         static const MsgMetaData m_meta_data;
00501
00502     };
00503
00504
00505 /*  ======================================================================
00506     Class BtHsSupportedProfileMessage
00507     ====================================================================== */
00508
00510 class BtHsSupportedProfileMessage : public BtGapAndSdapRequestMessage {
00511     public:
00512         BtHsSupportedProfileMessage(const BtResultCode& result, UINT32 request_id, const WString& hs_profile_name, BOOLEAN hs_has_remote_volume_control);
00513         virtual ~BtHsSupportedProfileMessage();
00514
00515         virtual const MsgMetaData& GetMetaData() const;
00516         void SetHsProfileName(const WString& hs_profile_name) { m_hs_profile_name = hs_profile_name; }
00517         const WString& GetHsProfileName() const { return m_hs_profile_name; }
00518         void SetHsHasRemoteVolumeControl(BOOLEAN hs_has_remote_volume_control) { m_hs_has_remote_volume_control = hs_has_remote_volume_control; }
00519         BOOLEAN IsHsHasRemoteVolumeControl() const { return m_hs_has_remote_volume_control; }
00520         virtual Message* Clone() const;
00521
00522         enum  {
00523             ID = 10230
00524             };
00525
00526     private:
00527         static const MsgMetaData m_meta_data;
00528         WString m_hs_profile_name;
00529         BOOLEAN m_hs_has_remote_volume_control;
00530
00531     };
00532
00533
00534 /*  ======================================================================
00535     Class BtHfSupportedProfileMessage
00536     ====================================================================== */
00537
00539 class BtHfSupportedProfileMessage : public BtGapAndSdapRequestMessage {
00540     public:
00541         BtHfSupportedProfileMessage(const BtResultCode& result, UINT32 request_id, const WString& hf_profile_name, UINT16 hf_supported_features);
00542         virtual ~BtHfSupportedProfileMessage();
00543
00544         virtual const MsgMetaData& GetMetaData() const;
00545         void SetHfProfileName(const WString& hf_profile_name) { m_hf_profile_name = hf_profile_name; }
00546         const WString& GetHfProfileName() const { return m_hf_profile_name; }
00547         void SetHfSupportedFeatures(UINT16 hf_supported_features) { m_hf_supported_features = hf_supported_features; }
00548         UINT16 GetHfSupportedFeatures() const { return m_hf_supported_features; }
00549         virtual Message* Clone() const;
00550
00551         enum  {
00552             ID = 10231
00553             };
00554
00555     private:
00556         static const MsgMetaData m_meta_data;
00557         WString m_hf_profile_name;
00558         UINT16 m_hf_supported_features;
00559
00560     };
00561
00562
00563 /*  ======================================================================
00564     Class BtPaSupportedProfileMessage
00565     ====================================================================== */
00566
00568 class BtPaSupportedProfileMessage : public BtGapAndSdapRequestMessage {
00569     public:
00570         BtPaSupportedProfileMessage(const BtResultCode& result, UINT32 request_id, const WString& pa_profile_name);
00571         virtual ~BtPaSupportedProfileMessage();
00572
00573         virtual const MsgMetaData& GetMetaData() const;
00574         void SetPaProfileName(const WString& pa_profile_name) { m_pa_profile_name = pa_profile_name; }
00575         const WString& GetPaProfileName() const { return m_pa_profile_name; }
00576         virtual Message* Clone() const;
00577
00578         enum  {
00579             ID = 10232
00580             };
00581
00582     private:
00583         static const MsgMetaData m_meta_data;
00584         WString m_pa_profile_name;
00585
00586     };
00587
00588
00589 /*  ======================================================================
00590     Class BtServiceVerifyMessage
00591     ====================================================================== */
00592
00594 class BtServiceVerifyMessage : public BtGapAndSdapRequestMessage {
00595     public:
00596         BtServiceVerifyMessage(const BtResultCode& result, UINT32 request_id);
00597         virtual ~BtServiceVerifyMessage();
00598
00599         virtual const MsgMetaData& GetMetaData() const;
00600         virtual Message* Clone() const;
00601
00602         enum  {
00603             ID = 10233
00604             };
00605
00606     private:
00607         static const MsgMetaData m_meta_data;
00608
00609     };
00610
00611
00612 /*  ======================================================================
00613     Class BtServiceVerifyResultMessage
00614     ====================================================================== */
00615
00617 class BtServiceVerifyResultMessage : public BtGapAndSdapRequestMessage {
00618     public:
00619         BtServiceVerifyResultMessage(const BtResultCode& result, UINT32 request_id, const BtDeviceAddress& device_address, const WString& device_name, void* data, UINT16 data_size);
00620         virtual ~BtServiceVerifyResultMessage();
00621
00622         virtual const MsgMetaData& GetMetaData() const;
00623         void SetDeviceAddress(const BtDeviceAddress& device_address) { m_device_address = device_address; }
00624         const BtDeviceAddress& GetDeviceAddress() const { return m_device_address; }
00625         void SetDeviceName(const WString& device_name) { m_device_name = device_name; }
00626         const WString& GetDeviceName() const { return m_device_name; }
00627         void SetData(void* data) { m_data = data; }
00628         void* GetData() const { return m_data; }
00629         void SetDataSize(UINT16 data_size) { m_data_size = data_size; }
00630         UINT16 GetDataSize() const { return m_data_size; }
00631         virtual Message* Clone() const;
00632
00633         enum  {
00634             ID = 10234
00635             };
00636
00637     private:
00638         static const MsgMetaData m_meta_data;
00639         BtDeviceAddress m_device_address;
00640         WString m_device_name;
00641         void* m_data;
00642         UINT16 m_data_size;
00643
00644     };
00645
00646
00647 /*  ======================================================================
00648     Class BtCancelVerifyMessage
00649     ====================================================================== */
00650
00652 class BtCancelVerifyMessage : public BtGapAndSdapRequestMessage {
00653     public:
00654         BtCancelVerifyMessage(const BtResultCode& result, UINT32 request_id);
00655         virtual ~BtCancelVerifyMessage();
00656
00657         virtual const MsgMetaData& GetMetaData() const;
00658         virtual Message* Clone() const;
00659
00660         enum  {
00661             ID = 10235
00662             };
00663
00664     private:
00665         static const MsgMetaData m_meta_data;
00666
00667     };
00668
00669 #endif // Bluetooth_BtGapAndSdapRequestMessage_hpp
00670
Generated on Tue Jan 24 14:48:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtLocalRequest.cpp File Reference

Bluetooth/BtLocalRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtLocalRequest.hpp"

Include dependency graph for BtLocalRequest.cpp:

Generated on Tue Jan 24 20:02:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtLocalRequest.hpp File Reference

Bluetooth/BtLocalRequest.hpp File Reference

#include <Kernel/UserDispatcher.hpp>
#include <Bluetooth/BtRequest.hpp>
#include <Bluetooth/BtRequestMessage.hpp>

Include dependency graph for BtLocalRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtLocalRequest

Defines

#define | BtLocalRequest_hpp

Define Documentation

#define BtLocalRequest_hpp

Generated on Tue Jan 24 20:02:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtLocalRequest.hpp Source File

Bluetooth/BtLocalRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtLocalRequest_hpp)
00009 #define BtLocalRequest_hpp
00012
00013 #include <Kernel/UserDispatcher.hpp>
00014 #include <Bluetooth/BtRequest.hpp>
00015 #include <Bluetooth/BtRequestMessage.hpp>
00016
00044 class BtLocalRequest: public BtRequest, public UserDispatcher
00045 {
00046     private:
00047         typedef BtRequest Base;
00048
00049     public:
00051         BtLocalRequest();
00052
00054         virtual ~BtLocalRequest();
00055
00057
00067         virtual BtRequestState ExecuteRequest();
00068
00069     protected:
00071
00079         virtual void SetRequestState(BtRequestState request_state);
00080
00082
00084         virtual void ExecutionCallback(BtResultCode result);
00085
00087
00103         BOOLEAN RegisterDispatcher();
00104
00106
00121         BOOLEAN UnregisterDispatcher();
00122
00124
00138 //      BOOLEAN CheckMessage(const Message& message, MsgId id) const;
00139
00141
00159         virtual BOOLEAN EvaluateMessageResult(const BtRequestMessage& message);
00160
00162
00176         virtual BOOLEAN OnMessage(const Message& messsage) = 0;
00177
00179
00192         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state) = 0;
00193
00194     private:
00196         BOOLEAN m_is_registered;
00197 };
00198
00200 #endif  // BtLocalRequest_hpp
00201
00202
Generated on Tue Jan 24 14:48:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtLocalSettings.cpp File Reference

Bluetooth/BtLocalSettings.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtLocalSettings.hpp"

Include dependency graph for BtLocalSettings.cpp:

Generated on Tue Jan 24 20:02:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtLocalSettings.hpp File Reference

Bluetooth/BtLocalSettings.hpp File Reference

#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/UserDispatcher.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>
#include <Bluetooth/BtGapAndSdapRequestMessage.hpp>

Include dependency graph for BtLocalSettings.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtLocalSettings

Defines

#define | BtLocalSettings_hpp

Define Documentation

#define BtLocalSettings_hpp

Generated on Tue Jan 24 20:02:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtLocalSettings.hpp Source File

Bluetooth/BtLocalSettings.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtLocalSettings_hpp)
00009 #define BtLocalSettings_hpp
00012
00013 #include <Kernel/Os/Mutex.hpp>
00014 #include <Kernel/Condition.hpp>
00015 #include <Kernel/Application.hpp>
00016 #include <Kernel/UserDispatcher.hpp>
00017
00018 #include <Bluetooth/BtTypes.hpp>
00019 #include <Bluetooth/BtDeviceAddress.hpp>
00020 #include <Bluetooth/BtGapAndSdapRequestMessage.hpp>
00021
00058 class BtLocalSettings: public UserDispatcher, private BooleanCondition
00059 {
00060     private:
00061         typedef UserDispatcher Base;
00062
00063     public:
00065         BtLocalSettings(Application* application);
00066
00068         virtual ~BtLocalSettings();
00069
00071
00075         UINT32 GetLocalSettingsId();
00076
00078
00083         BtStackState GetLocalState() const;
00084
00086
00120         BtResultCode TurnOn(BOOLEAN execute_synchron = FALSE);
00121
00123
00158         BtResultCode TurnOff(BOOLEAN execute_synchron = FALSE);
00159
00161
00178         BtResultCode GetChipVersion(BtChipVersion& chip_version) const;
00179
00181
00197         BtResultCode GetLocalAddress(BtDeviceAddress& device_address) const;
00198
00200
00215         BtResultCode GetLocalName(WString& local_name) const;
00216
00218
00254         BtResultCode SetLocalName(const WString& local_name, BOOLEAN execute_synchron = FALSE);
00255
00257
00274         BtResultCode GetDiscoverableMode(BtDiscoverableMode& discoverable_mode) const;
00275
00277
00314         BtResultCode SetDiscoverableMode(BtDiscoverableMode discoverable_mode = BtDmGeneralDiscoverable, BOOLEAN execute_synchron = FALSE);
00315
00317
00332         BtResultCode GetPairableMode(BtPairableMode& pairable_mode) const;
00333
00335
00372         BtResultCode SetPairableMode(BtPairableMode pairable_mode = BtPmPairable, BOOLEAN execute_synchron = FALSE);
00373
00375
00390         BtResultCode GetConnectableMode(BtConnectableMode& connectable_mode) const;
00391
00393
00430         BtResultCode SetConnectableMode(BtConnectableMode connectable_mode = BtCmConnectable, BOOLEAN execute_synchron = FALSE);
00431
00433
00435         BtResultCode GetIsProfileActive(BtProfile profile, BOOLEAN& active);
00436
00438
00440         BtResultCode SetIsProfileActive(BtProfile profile, BOOLEAN active, BOOLEAN execute_synchron = FALSE);
00441
00443
00447         using BooleanCondition::IsTrue;
00448
00449     protected:
00451
00470         virtual BOOLEAN OnMessage(const Message& message);
00471
00473
00487         virtual void OnStateChange(BtStackState stack_state);
00488
00490
00506         virtual void OnLocalName(BtResultCode result);
00507
00509
00525         virtual void OnDiscoverableMode(BtResultCode result);
00526
00528
00544         virtual void OnPairableMode(BtResultCode result);
00545
00547
00563         virtual void OnConnectableMode(BtResultCode result);
00564
00566
00568         virtual void OnProfileActivation(BtResultCode result);
00569
00570     protected:
00572
00574         typedef enum
00575         {
00577             BtArNone = 0,
00579             BtArSwitchState       = BtStateChangedMessage::ID,
00581             BtArLocalName         = BtLocalNameMessage::ID,
00583             BtArDiscoverability   = BtDiscoverabilityMessage::ID,
00585             BtArPairability       = BtPairabilityMessage::ID,
00587             BtArConnectablity     = BtConnectabilityMessage::ID,
00589             BtArProfileActivation = BtProfileActivationMessage::ID
00590         } BtActiveRequest;
00591
00592     private:
00594
00608         BtLocalSettings* GetLocalSettings(BOOLEAN execute_synchron);
00609
00611
00623         BOOLEAN GetDone(void) const;
00624
00626
00632         void SetDone(BOOLEAN done);
00633
00635
00639         BtActiveRequest GetActiveRequest() const;
00640
00642
00655         BOOLEAN BeginRequest(BtActiveRequest active_request);
00656
00658
00660         void EndRequest();
00661
00662     private:
00664         Mutex m_active_request_mutex;
00665
00667         BtActiveRequest m_active_request;
00668
00670         Application* m_application;
00671
00673         BtResultCode* m_result;
00674
00675     private:
00676         friend class BtGapAndSdapController;
00677 };
00678
00680 #endif  // BtLocalSettings_hpp
00681
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtMultiConnectionController.cpp File Reference

Bluetooth/BtMultiConnectionController.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceListIterator.hpp"
#include "BtMultiConnectionController.hpp"

Include dependency graph for BtMultiConnectionController.cpp:

Generated on Tue Jan 24 20:02:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtMultiConnectionController.hpp File Reference

Bluetooth/BtMultiConnectionController.hpp File Reference

#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtServiceRequest.hpp>
#include <Bluetooth/BtConnectionBasedController.hpp>

Include dependency graph for BtMultiConnectionController.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtMultiConnectionController
class | BtMultiConnectionController::BtConnection

Defines

#define | BtMultiConnectionController_hpp

Define Documentation

#define BtMultiConnectionController_hpp

Generated on Tue Jan 24 20:03:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtMultiConnectionController.hpp Source File

Bluetooth/BtMultiConnectionController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtMultiConnectionController_hpp)
00009 #define BtMultiConnectionController_hpp
00012
00013 #include <Bluetooth/BtDevice.hpp>
00014 #include <Bluetooth/BtServiceRequest.hpp>
00015 #include <Bluetooth/BtConnectionBasedController.hpp>
00016
00021 class BtMultiConnectionController: public BtConnectionBasedController
00022 {
00023     private:
00024         typedef BtConnectionBasedController Base;
00025
00026     public:
00028         BtMultiConnectionController();
00029
00031         virtual ~BtMultiConnectionController();
00032
00033     protected:
00048         virtual BOOLEAN IsDeviceConnected(const BtDevice& device) const;
00049
00051
00060 //      BtServiceRequest* GetExecutingRequest() const;
00061
00063
00080         BOOLEAN PrepareRequestExecution(void* apoxi_handle, BtServiceRequest* request);
00081
00083
00108     BtServiceRequest* CleanUpRequestExecution(void* apoxi_handle, BtResultCode result_code, BtRequestType request_type);
00109
00110     public:
00113         class BtConnection
00114         {
00115             public:
00117                 BtConnection();
00118
00120                 virtual ~BtConnection();
00121
00123
00125                 void* GetApoxiHandle() const;
00126
00128
00130                 void SetApoxiHandle(void* apoxi_handle);
00131
00133
00135                 BtServiceRequest* GetRunningRequest() const;
00136
00138
00140                 void SetRunningRequest(BtServiceRequest* request);
00141
00143
00145                 const BtDevice& GetDevice() const;
00146
00148
00150                 void SetDevice(const BtDevice& device);
00151
00153
00155                 BtConnection* GetNext() const;
00156
00158
00160                 void SetNext(BtConnection* next);
00161
00162             private:
00164                 void* m_apoxi_handle;
00165
00167                 BtDevice m_connected_device;
00168
00170                 BtServiceRequest* m_running_request;
00171
00173                 BtConnection* m_next;
00174         };
00175
00176     protected:
00178
00180         BtConnection* GetFirstConnection() const;
00181
00183
00185         BtConnection* GetNextConnection(const BtConnection* current) const;
00186
00188
00190         BOOLEAN InsertConnection(BtConnection* connection_to_insert, const BtConnection* location = 0);
00191
00193
00195         BtConnection* RemoveConnection(const BtConnection* connection_to_remove);
00196
00198
00200         BtConnection* FindConnectionByApoxiHandle(const void* apoxi_handle) const;
00201
00203
00205         BtConnection* FindConnectionByDevice(const BtDevice& device) const;
00206
00208
00210         BtConnection* FindConnectionByRequest(const BtServiceRequest* request) const;
00211
00212     protected:
00214         Mutex m_connection_list_mutex;
00215
00216     private:
00218         BtConnection* m_connection_list;
00219 };
00220
00222 #endif  // BtMultiConnectionController_hpp
00223
00224
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtObexResponseCode.hpp File Reference

Bluetooth/BtObexResponseCode.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexResponseCode
Indicates success or failure of an OBEX operation. More...

Defines

#define | Apoxi_BtObexResponseCode_hpp

Define Documentation

#define Apoxi_BtObexResponseCode_hpp

Generated on Tue Jan 24 20:03:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtObexResponseCode.hpp Source File

Bluetooth/BtObexResponseCode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BtObexResponseCode_hpp)
00011 #define Apoxi_BtObexResponseCode_hpp
00012
00013
00025 class BtObexResponseCode
00026 {
00027     public:
00028         enum ResponseCode {
00029             // Success
00030             Success                     = 0x20,
00031             Continue                    = 0x10,
00032             PartialContent              = 0x26,
00033
00034             // Error Codes
00035             BadRequest                  = 0x40,
00036             NotImplemented              = 0x51,
00037             Forbidden                   = 0x43,
00038             Unauthorised                = 0x41,
00039             PreconditionFailed          = 0x4C,
00040             NotFound                    = 0x44,
00041             NotAcceptable               = 0x46,
00042             ServiceUnavailable          = 0x53,
00043
00044             // Unspecified error
00045             Unspecified                 = 0x7F
00046         };
00047
00049         static inline BtObexResponseCode Ok();
00050
00055         inline BtObexResponseCode(ResponseCode  obex_resp_code = Unspecified, BOOLEAN final_flag = FALSE);
00056
00058         inline BtObexResponseCode(UINT8 obex_resp_code);
00059
00061         inline BtObexResponseCode(const BtObexResponseCode &  from);
00062
00064         inline BtObexResponseCode & operator=(const BtObexResponseCode &  from);
00065
00067         inline BOOLEAN IsError() const;
00068
00070         inline BOOLEAN IsOk() const;
00071
00073         inline BOOLEAN IsFinal() const;
00074
00076         inline BOOLEAN IsFinished() const;
00077
00082         inline operator BOOLEAN() const;
00083
00085         inline ResponseCode GetObexResponseCode() const;
00086
00088         inline UINT8 GetObexResponseCodeByte() const;
00089
00090     private:
00091         UINT8       m_obex_resp_code;
00092 };
00093
00094 /*  ----------------------------------------------------------------------
00095     Ok
00096     ---------------------------------------------------------------------- */
00097 BtObexResponseCode  BtObexResponseCode::Ok()
00098 {
00099     return  BtObexResponseCode(Success, TRUE);
00100 }// Ok
00101
00102 /*  ----------------------------------------------------------------------
00103     BtObexResponseCode
00104     ---------------------------------------------------------------------- */
00105 BtObexResponseCode::BtObexResponseCode(ResponseCode  obex_resp_code, BOOLEAN final_flag)
00106 {
00107     m_obex_resp_code = obex_resp_code;
00108
00109     if (final_flag) {
00110         m_obex_resp_code = (ResponseCode)(m_obex_resp_code | 0x80);
00111     }
00112 }// BtObexResponseCode
00113
00114 /*  ----------------------------------------------------------------------
00115     BtObexResponseCode
00116     ---------------------------------------------------------------------- */
00117 BtObexResponseCode::BtObexResponseCode(UINT8 obex_response_code) :
00118     m_obex_resp_code(obex_response_code)
00119 {
00120 }// BtObexResponseCode
00121
00122 /*  ----------------------------------------------------------------------
00123     BtObexResponseCode
00124     ---------------------------------------------------------------------- */
00125 BtObexResponseCode::BtObexResponseCode(const BtObexResponseCode &  from) :
00126     m_obex_resp_code( from.m_obex_resp_code )
00127 {
00128 }// BtObexResponseCode
00129
00130 /*  ----------------------------------------------------------------------
00131     operator=
00132     ---------------------------------------------------------------------- */
00133 BtObexResponseCode &    BtObexResponseCode::operator=(const BtObexResponseCode &  from)
00134 {
00135     // Self - assignment doesn't hurt here, so we don't check for it !
00136     m_obex_resp_code = from.m_obex_resp_code;
00137     return *this;
00138 }// operator=
00139
00140 /*  ----------------------------------------------------------------------
00141     IsError
00142     ---------------------------------------------------------------------- */
00143 BOOLEAN BtObexResponseCode::IsError() const
00144 {
00145     return ((m_obex_resp_code & 0x7F) > 0x30);
00146 }// IsError
00147
00148 /*  ----------------------------------------------------------------------
00149     IsOk
00150     ---------------------------------------------------------------------- */
00151 BOOLEAN BtObexResponseCode::IsOk() const
00152 {
00153     return ((m_obex_resp_code & 0x7F) < 0x30);
00154 }// IsOk
00155
00156 /*  ----------------------------------------------------------------------
00157     IsFinal
00158     ---------------------------------------------------------------------- */
00159 BOOLEAN BtObexResponseCode::IsFinal() const
00160 {
00161     return (m_obex_resp_code & 0x80);
00162 }// IsOk
00163
00164 /*  ----------------------------------------------------------------------
00165     operator BOOLEAN
00166     ---------------------------------------------------------------------- */
00167 BOOLEAN BtObexResponseCode::IsFinished() const
00168 {
00169     return (GetObexResponseCode() != Continue);
00170 }
00171
00172 /*  ----------------------------------------------------------------------
00173     operator BOOLEAN
00174     ---------------------------------------------------------------------- */
00175 BtObexResponseCode::operator BOOLEAN() const
00176 {
00177     return IsOk();
00178 }// BOOLEAN
00179
00180 /*  ----------------------------------------------------------------------
00181     GetObexResponseCode
00182     ---------------------------------------------------------------------- */
00183 BtObexResponseCode::ResponseCode BtObexResponseCode::GetObexResponseCode() const
00184 {
00185     return (ResponseCode)(m_obex_resp_code & 0x7F);
00186 }// GetErrorCode
00187
00188 /*  ----------------------------------------------------------------------
00189     GetObexResponseCodeByte
00190     ---------------------------------------------------------------------- */
00191 UINT8 BtObexResponseCode::GetObexResponseCodeByte() const
00192 {
00193     return m_obex_resp_code;
00194 }// GetErrorCode
00195
00196 #endif  // Apoxi_BtObexResponseCode_hpp
00197
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtObservableService.cpp File Reference

Bluetooth/BtObservableService.cpp File Reference

#include "PreComp.hpp"
#include "BtObservableService.hpp"

Include dependency graph for BtObservableService.cpp:

Generated on Tue Jan 24 20:03:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtObservableService.hpp File Reference

Bluetooth/BtObservableService.hpp File Reference

#include <Bluetooth/BtService.hpp>
#include <Bluetooth/BtServiceObserver.hpp>
#include <Bluetooth/BtEvent.hpp>

Include dependency graph for BtObservableService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObservableService
class | BtObservableService::BtServiceObserverListElement

Defines

#define | BtObservableService_hpp

Define Documentation

#define BtObservableService_hpp

Generated on Tue Jan 24 20:03:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtObservableService.hpp Source File

Bluetooth/BtObservableService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObservableService_hpp)
00009 #define BtObservableService_hpp
00012
00013 #include <Bluetooth/BtService.hpp>
00014 #include <Bluetooth/BtServiceObserver.hpp>
00015 #include <Bluetooth/BtEvent.hpp>
00016
00019 class BtObservableService: public BtService
00020 {
00021     private:
00022         typedef BtService Base;
00023
00024     public:
00026         BtObservableService();
00027
00029         virtual ~BtObservableService();
00030
00032
00034         BOOLEAN GetUseMessageInterface() const;
00035
00037
00039         void SetUseMessageInterface(BOOLEAN use_message_interface);
00040
00041     protected:
00043
00045         BOOLEAN Attach(BtServiceObserver* service_observer);
00046
00048
00050         BOOLEAN Detach(BtServiceObserver* service_observer);
00051
00053
00055         void Notify(const BtEvent& event);
00056
00057     private:
00059         BOOLEAN m_use_message_interface;
00060
00061     private:
00062         class BtServiceObserverListElement
00063         {
00064             public:
00066                 BtServiceObserverListElement(BtServiceObserver* observer, BtServiceObserverListElement* next = 0);
00067
00069                 virtual ~BtServiceObserverListElement();
00070
00072
00074                 BtServiceObserver* GetObserver() const;
00075
00077
00079                 void SetObserver(BtServiceObserver* observer);
00080
00082
00084                 BtServiceObserverListElement* GetNext() const;
00085
00087
00089                 void SetNext(BtServiceObserverListElement* next);
00090
00091             private:
00093                 BtServiceObserver* m_observer;
00094
00096                 BtServiceObserverListElement* m_next;
00097         };
00098
00099     private:
00101         BtServiceObserverListElement* m_anchor;
00102 };
00103
00105 #endif  // BtObservableService_hpp
00106
00107
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationBase.cpp File Reference

Bluetooth/BtOperationBase.cpp File Reference

#include "PreComp.hpp"
#include "BtOperationBase.hpp"

Include dependency graph for BtOperationBase.cpp:

Generated on Tue Jan 24 20:03:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationBase.hpp File Reference

Bluetooth/BtOperationBase.hpp File Reference

#include <Auxiliary/ObjectReferrer.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtOperationBase.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtOperationBase

Defines

#define | BtOperationBase_hpp

Typedefs

typedef SharedPtr< BtOperationBase > | BtOperationPtr

Define Documentation

#define BtOperationBase_hpp

Generated on Tue Jan 24 20:03:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationBase.hpp Source File

Bluetooth/BtOperationBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtOperationBase_hpp)
00009 #define BtOperationBase_hpp
00012
00013 #include <Auxiliary/ObjectReferrer.hpp>
00014 #include <Auxiliary/SharedPtr.hpp>
00015 #include <Bluetooth/BtTypes.hpp>
00016
00019 class BtOperationBase: public ReferableObject
00020 {
00021     private:
00022         typedef ReferableObject Base;
00023
00024     public:
00025         typedef enum { BtErUnknown, BtErUserBreak, BtErOperationResultInvalid, BtErOperationFailure } BtErrorReason;
00026
00027     public:
00029         BtOperationBase();
00030
00032         virtual ~BtOperationBase();
00033
00034     public:
00036
00038         virtual BtOperationType GetOperationType() const = 0;
00039
00041
00043         BtResultCode GetResult() const;
00044
00046
00048         void SetResult(BtResultCode result, BtErrorReason error_reason = BtErUnknown);
00049
00051
00053         BtErrorReason GetErrorReason() const;
00054
00056
00058         void SetErrorReason(BtErrorReason error_reason);
00059
00060     protected:
00062
00064         virtual void OnResult(BtResultCode result) = 0;
00065
00066     private:
00068         BtResultCode m_result;
00069
00071         BtErrorReason m_error_reason;
00072 };
00073
00076 typedef SharedPtr<BtOperationBase> BtOperationPtr;
00077
00078 #endif // BtOperationBase_hpp
00079
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationSelectDevice.cpp File Reference

Bluetooth/BtOperationSelectDevice.cpp File Reference

#include "PreComp.hpp"
#include "BtOperationSelectDevice.hpp"

Include dependency graph for BtOperationSelectDevice.cpp:

Generated on Tue Jan 24 20:03:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationSelectDevice.hpp File Reference

Bluetooth/BtOperationSelectDevice.hpp File Reference

#include <Bluetooth/BtDeviceFilter.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtOperationBase.hpp>

Include dependency graph for BtOperationSelectDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtOperationSelectDevice

Defines

#define | BtOperationSelectDevice_hpp

Define Documentation

#define BtOperationSelectDevice_hpp

Generated on Tue Jan 24 20:03:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationSelectDevice.hpp Source File

Bluetooth/BtOperationSelectDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtOperationSelectDevice_hpp)
00009 #define BtOperationSelectDevice_hpp
00012
00013 #include <Bluetooth/BtDeviceFilter.hpp>
00014 #include <Bluetooth/BtDevice.hpp>
00015 #include <Bluetooth/BtOperationBase.hpp>
00016
00019 class BtOperationSelectDevice: public BtOperationBase
00020 {
00021     private:
00022         typedef BtOperationBase Base;
00023
00024     public:
00026         BtOperationSelectDevice(const BtDeviceFilter& device_filter = BtDeviceFilter());
00027
00029         virtual ~BtOperationSelectDevice();
00030
00031     public:
00033
00035         virtual BtOperationType GetOperationType() const;
00036
00037     public:
00039
00041         void SetDeviceFilter(const BtDeviceFilter& device_filter);
00042
00044
00046         const BtDeviceFilter& GetDeviceFilter() const;
00047
00049
00051         void SetDevice(const BtDevice& device);
00052
00054
00056         const BtDevice& GetDevice() const;
00057
00058     private:
00060         BtDeviceFilter m_device_filter;
00061
00063         BtDevice m_device;
00064 };
00065
00066 #endif // BtOperationSelectDevice_hpp
00067
00068
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.cpp File Reference

Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.cpp File Reference

#include "PreComp.hpp"
#include "BtOperationSelectDeviceAndPerformServiceVerify.hpp"

Include dependency graph for BtOperationSelectDeviceAndPerformServiceVerify.cpp:

Generated on Tue Jan 24 20:03:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp File Reference

Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtDeviceFilter.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtServiceVerifyResult.hpp>
#include <Bluetooth/BtOperationBase.hpp>

Include dependency graph for BtOperationSelectDeviceAndPerformServiceVerify.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtOperationSelectDeviceAndPerformServiceVerify

Defines

#define | BtOperationSelectDeviceAndPerformServiceVerify_hpp

Define Documentation

#define BtOperationSelectDeviceAndPerformServiceVerify_hpp

Generated on Tue Jan 24 20:03:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp Source File

Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtOperationSelectDeviceAndPerformServiceVerify_hpp)
00009 #define BtOperationSelectDeviceAndPerformServiceVerify_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtDeviceFilter.hpp>
00015 #include <Bluetooth/BtDevice.hpp>
00016 #include <Bluetooth/BtServiceVerifyResult.hpp>
00017 #include <Bluetooth/BtOperationBase.hpp>
00018
00021 class BtOperationSelectDeviceAndPerformServiceVerify: public BtOperationBase
00022 {
00023     private:
00024         typedef BtOperationBase Base;
00025
00026     public:
00028         BtOperationSelectDeviceAndPerformServiceVerify();
00029
00031         virtual ~BtOperationSelectDeviceAndPerformServiceVerify();
00032
00033     public:
00035
00037         virtual BtOperationType GetOperationType() const;
00038
00039     public:
00041
00043         const BtDeviceFilter& GetDeviceFilter() const;
00044
00046
00048         void SetDeviceFilter(const BtDeviceFilter& device_filter);
00049
00051
00053         const BtDevice& GetDevice() const;
00054
00056
00058         void SetDevice(const BtDevice& device);
00059
00061
00063         BtDeviceRelation GetDeviceRelation() const;
00064
00066
00068         void SetDeviceReleation(BtDeviceRelation device_relation);
00069
00071
00073         UINT8 GetNumberOfServicesToVerify() const;
00074
00076
00078         const BtUUID* GetServiceToVerify() const;
00079
00081
00083         BOOLEAN SetServicesToVerify(const BtUUID* services_to_verify, UINT8 number_of_services_to_verify);
00084
00086
00088         UINT8 GetNumberOfAttributesRequested() const;
00089
00091
00093         const BtAttributeId* GetAttributesRequested() const;
00094
00096
00098         BOOLEAN SetAttributesRequested(const BtAttributeId* attributes_requested, UINT8 number_of_attributes_requested);
00099
00101
00103         const BtServiceVerifyResult& GetServiceVerifyResult() const;
00104
00106
00108         BOOLEAN SetServiceVerifyResult(const BtServiceVerifyResult& service_verify_result);
00109
00110     private:
00112         BtDeviceFilter m_device_filter;
00113
00115         BtDevice m_device;
00116
00118         BtDeviceRelation m_device_relation;
00119
00121         UINT8 m_number_of_services_to_verify;
00122
00124         BtUUID* m_services_to_verify;
00125
00127         UINT8 m_number_of_attributes_requested;
00128
00130         BtAttributeId* m_attributes_requested;
00131
00133         BtServiceVerifyResult m_service_verify_result;
00134 };
00135
00136 #endif // BtOperationSelectDeviceAndPerformServiceVerify_hpp
00137
00138
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtQuerySupportedProfilesRequest.cpp File Reference

Bluetooth/BtQuerySupportedProfilesRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtQuerySupportedProfilesRequest.hpp"

Include dependency graph for BtQuerySupportedProfilesRequest.cpp:

Generated on Tue Jan 24 20:03:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtQuerySupportedProfilesRequest.hpp File Reference

Bluetooth/BtQuerySupportedProfilesRequest.hpp File Reference

#include <Bluetooth/BtUncancelablePointToPointRequest.hpp>

Include dependency graph for BtQuerySupportedProfilesRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtQuerySupportedProfilesRequest

Defines

#define | BtQuerySupportedProfilesRequest_hpp

Define Documentation

#define BtQuerySupportedProfilesRequest_hpp

Generated on Tue Jan 24 20:03:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtQuerySupportedProfilesRequest.hpp Source File

Bluetooth/BtQuerySupportedProfilesRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtQuerySupportedProfilesRequest_hpp)
00009 #define BtQuerySupportedProfilesRequest_hpp
00012
00013 #include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
00014
00023 class BtQuerySupportedProfilesRequest: public BtUncancelablePointToPointRequest
00024 {
00025     private:
00026         typedef BtUncancelablePointToPointRequest Base;
00027
00028     public:
00030         BtQuerySupportedProfilesRequest(const BtDevice& device);
00031
00033         virtual ~BtQuerySupportedProfilesRequest();
00034
00036
00044         virtual BtRequestType GetRequestType() const;
00045
00047
00058         BOOLEAN IsHsServiceSupported() const;
00059
00061
00066         const WString& GetHsServiceName() const;
00067
00069
00082         BOOLEAN HasRemoteVolumeControl() const;
00083
00085
00097         BOOLEAN IsHfServiceSupported() const;
00098
00100
00105         const WString& GetHfServiceName() const;
00106
00108
00114         UINT16 GetSupportedFeatures() const;
00115
00117
00129         BOOLEAN IsPaServiceSupported() const;
00130
00132
00137         const WString& GetPaServiceName() const;
00138
00139     protected:
00141
00162         virtual BOOLEAN Execute();
00163
00165
00174         virtual void RegisterMessages() const;
00175
00177
00185         virtual void UnregisterMessages() const;
00186
00188
00202         virtual BOOLEAN OnMessage(const Message& message);
00203
00206
00208         virtual void OnHsProfileSupported(BtResultCode result, const WString& name, BOOLEAN has_remote_volume_control);
00209
00211
00225         virtual void OnHsProfileSupported(const WString& name, BOOLEAN has_remote_volume_control);
00226
00228
00230         virtual void OnHfProfileSupported(BtResultCode result, const WString& name, UINT16 supported_features);
00231
00233
00247         virtual void OnHfProfileSupported(const WString& name, UINT16 supported_features);
00248
00250
00252         virtual void OnPaProfileSupported(BtResultCode result, const WString& name);
00253
00255
00266         virtual void OnPaProfileSupported(const WString& name);
00267
00268     private:
00270
00274         void Reset(void);
00275
00276     private:
00278         BOOLEAN m_is_hs_service_supported;
00279
00281         WString m_hs_service_name;
00282
00284         BOOLEAN m_has_remote_volume_control;
00285
00287         BOOLEAN m_is_hf_service_supported;
00288
00290         WString m_hf_service_name;
00291
00293         UINT16 m_suported_features;
00294
00296         BOOLEAN m_is_pa_service_supported;
00297
00299         WString m_pa_service_name;
00300 };
00301
00303 #endif  // BtQuerySupportedProfilesRequest_hpp
00304
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequest.cpp File Reference

Bluetooth/BtRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtRequest.hpp"

Include dependency graph for BtRequest.cpp:

Generated on Tue Jan 24 20:03:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequest.hpp File Reference

Bluetooth/BtRequest.hpp File Reference

#include <Kernel/Os/Mutex.hpp>
#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtRequest

Defines

#define | BtRequest_hpp

Define Documentation

#define BtRequest_hpp

Generated on Tue Jan 24 20:03:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequest.hpp Source File

Bluetooth/BtRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtRequest_hpp)
00009 #define BtRequest_hpp
00012
00013 #include <Kernel/Os/Mutex.hpp>
00014 #include <Bluetooth/BtTypes.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00020 class BtController;
00021
00049 class BtRequest
00050 {
00051     public:
00053         BtRequest();
00054
00056         virtual ~BtRequest();
00057
00059
00067         virtual BtRequestType GetRequestType() const = 0;
00068
00070
00077         BtRequestState GetRequestState() const;
00078
00080
00084         UINT32 GetRequestId() const;
00085
00087
00098         virtual BOOLEAN CanExecuteRequest() const;
00099
00101
00111         virtual BtRequestState ExecuteRequest() = 0;
00112
00114
00129         virtual BOOLEAN IsCancelable() const = 0;
00130
00132
00142         virtual BOOLEAN CanCancelRequest() const;
00143
00145
00158         BtRequestState CancelRequest();
00159
00160     protected:
00162
00170         virtual void SetRequestState(BtRequestState request_state) = 0;
00171
00173
00175         virtual void ResetRequestState();
00176
00178
00195         virtual BOOLEAN Execute() = 0;
00196
00198
00215         virtual BOOLEAN Cancel() = 0;
00216
00218
00231         virtual BtRequestState ChangeRequestState(BOOLEAN success);
00232
00234
00244         virtual BtRequestState ChangeRequestStateForCancel(BOOLEAN success);
00245
00247
00249         virtual BOOLEAN EvaluateExecutionResult(BtResultCode result);
00250
00252
00254         virtual void ExecutionCallback(BtResultCode result) = 0;
00255
00256     protected:
00258         BtRequestState m_state;
00259
00261         Mutex m_is_registered_mutex;
00262
00263     private:
00264         friend class BtController;
00265 };
00266
00268 #endif  // BtRequest_hpp
00269
00270
Generated on Tue Jan 24 14:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestMessage.cpp File Reference

Bluetooth/BtRequestMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtRequestMessage.hpp"

Include dependency graph for BtRequestMessage.cpp:

Generated on Tue Jan 24 20:03:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestMessage.hpp File Reference

Bluetooth/BtRequestMessage.hpp File Reference

#include <Kernel/Message.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtRequestMessage.hpp>

Include dependency graph for BtRequestMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtCloseMessage
class | BtOpenMessage
class | BtRequestMessage

Defines

#define | Bluetooth_BtRequestMessage_hpp

Define Documentation

#define Bluetooth_BtRequestMessage_hpp

Generated on Tue Jan 24 20:03:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestMessage.hpp Source File

Bluetooth/BtRequestMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\BtRequestMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtRequestMessage_hpp)
00016 #define Bluetooth_BtRequestMessage_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Bluetooth/BtTypes.hpp>
00020 #include <Bluetooth/BtRequestMessage.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtRequestMessage
00029     ====================================================================== */
00030
00032 class BtRequestMessage : public Message {
00033     public:
00034         BtRequestMessage(const BtResultCode& result, UINT32 request_id);
00035         virtual ~BtRequestMessage();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         void SetResult(const BtResultCode& result) { m_result = result; }
00039         const BtResultCode& GetResult() const { return m_result; }
00040         void SetRequestId(UINT32 request_id) { m_request_id = request_id; }
00041         UINT32 GetRequestId() const { return m_request_id; }
00042         virtual Message* Clone() const;
00043
00044         enum  {
00045             ID = 10200
00046             };
00047
00048     private:
00049         static const MsgMetaData m_meta_data;
00050         BtResultCode m_result;
00051         UINT32 m_request_id;
00052
00053     };
00054
00055
00056 /*  ======================================================================
00057     Class BtOpenMessage
00058     ====================================================================== */
00059
00061 class BtOpenMessage : public BtRequestMessage {
00062     public:
00063         BtOpenMessage(const BtResultCode& result, UINT32 request_id, const BtProfile& profile);
00064         virtual ~BtOpenMessage();
00065
00066         virtual const MsgMetaData& GetMetaData() const;
00067         void SetProfile(const BtProfile& profile) { m_profile = profile; }
00068         const BtProfile& GetProfile() const { return m_profile; }
00069         virtual Message* Clone() const;
00070
00071         enum  {
00072             ID = 10201
00073             };
00074
00075     private:
00076         static const MsgMetaData m_meta_data;
00077         BtProfile m_profile;
00078
00079     };
00080
00081
00082 /*  ======================================================================
00083     Class BtCloseMessage
00084     ====================================================================== */
00085
00087 class BtCloseMessage : public BtRequestMessage {
00088     public:
00089         BtCloseMessage(const BtResultCode& result, UINT32 request_id, const BtProfile& profile);
00090         virtual ~BtCloseMessage();
00091
00092         virtual const MsgMetaData& GetMetaData() const;
00093         void SetProfile(const BtProfile& profile) { m_profile = profile; }
00094         const BtProfile& GetProfile() const { return m_profile; }
00095         virtual Message* Clone() const;
00096
00097         enum  {
00098             ID = 10202
00099             };
00100
00101     private:
00102         static const MsgMetaData m_meta_data;
00103         BtProfile m_profile;
00104
00105     };
00106
00107 #endif // Bluetooth_BtRequestMessage_hpp
00108
Generated on Tue Jan 24 14:48:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestOperationMessage.cpp File Reference

Bluetooth/BtRequestOperationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtRequestOperationMessage.hpp"

Include dependency graph for BtRequestOperationMessage.cpp:

Generated on Tue Jan 24 20:03:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestOperationMessage.hpp File Reference

Bluetooth/BtRequestOperationMessage.hpp File Reference

#include <Kernel/Message.hpp>
#include <Bluetooth/BtOperationBase.hpp>

Include dependency graph for BtRequestOperationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtRequestOperationMessage

Defines

#define | Bluetooth_BtRequestOperationMessage_hpp

Define Documentation

#define Bluetooth_BtRequestOperationMessage_hpp

Generated on Tue Jan 24 20:03:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestOperationMessage.hpp Source File

Bluetooth/BtRequestOperationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\BtRequestOperationMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtRequestOperationMessage_hpp)
00016 #define Bluetooth_BtRequestOperationMessage_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Bluetooth/BtOperationBase.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class BtRequestOperationMessage
00028     ====================================================================== */
00029
00031 class BtRequestOperationMessage : public Message {
00032     public:
00033         BtRequestOperationMessage(const BtOperationPtr& operation);
00034         virtual ~BtRequestOperationMessage();
00035
00036         virtual const MsgMetaData& GetMetaData() const;
00037         void SetOperation(const BtOperationPtr& operation) { m_operation = operation; }
00038         const BtOperationPtr& GetOperation() const { return m_operation; }
00039         virtual Message* Clone() const;
00040
00041         enum  {
00042             ID = 10099
00043             };
00044
00045     private:
00046         static const MsgMetaData m_meta_data;
00047         BtOperationPtr m_operation;
00048
00049     };
00050
00051 #endif // Bluetooth_BtRequestOperationMessage_hpp
00052
Generated on Tue Jan 24 14:48:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestRespondRequest.cpp File Reference

Bluetooth/BtRequestRespondRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtRequestRespondRequest.hpp"

Include dependency graph for BtRequestRespondRequest.cpp:

Generated on Tue Jan 24 20:03:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestRespondRequest.hpp File Reference

Bluetooth/BtRequestRespondRequest.hpp File Reference

#include <Bluetooth/BtUncancelablePointToPointRequest.hpp>

Include dependency graph for BtRequestRespondRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtRequestRespondRequest

Defines

#define | BtRequestRespondRequest_hpp

Define Documentation

#define BtRequestRespondRequest_hpp

Generated on Tue Jan 24 20:03:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRequestRespondRequest.hpp Source File

Bluetooth/BtRequestRespondRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtRequestRespondRequest_hpp)
00009 #define BtRequestRespondRequest_hpp
00012
00013 #include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
00014
00026 class BtRequestRespondRequest: public BtUncancelablePointToPointRequest
00027 {
00028     private:
00029         typedef BtUncancelablePointToPointRequest Base;
00030
00031     public:
00033         BtRequestRespondRequest(const BtDevice& device);
00034
00036         virtual ~BtRequestRespondRequest();
00037
00038     protected:
00040
00053         virtual BtRequestState ChangeRequestState(BOOLEAN success);
00054
00056
00074         virtual BOOLEAN EvaluateMessageResult(const BtRequestMessage& message);
00075 };
00076
00078 #endif  // BtRequestRespondRequest_hpp
00079
00080
Generated on Tue Jan 24 14:48:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRespondAuthorizationRequest.cpp File Reference

Bluetooth/BtRespondAuthorizationRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtRespondAuthorizationRequest.hpp"

Include dependency graph for BtRespondAuthorizationRequest.cpp:

Generated on Tue Jan 24 20:03:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRespondAuthorizationRequest.hpp File Reference

Bluetooth/BtRespondAuthorizationRequest.hpp File Reference

#include <Bluetooth/BtRequestRespondRequest.hpp>

Include dependency graph for BtRespondAuthorizationRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtRespondAuthorizationRequest

Defines

#define | BtRespondAuthorizationRequest_hpp

Define Documentation

#define BtRespondAuthorizationRequest_hpp

Generated on Tue Jan 24 20:03:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtRespondAuthorizationRequest.hpp Source File

Bluetooth/BtRespondAuthorizationRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtRespondAuthorizationRequest_hpp)
00009 #define BtRespondAuthorizationRequest_hpp
00012
00013 #include <Bluetooth/BtRequestRespondRequest.hpp>
00014
00025 class BtRespondAuthorizationRequest: public BtRequestRespondRequest
00026 {
00027     private:
00028         typedef BtRequestRespondRequest Base;
00029
00030     public:
00032         BtRespondAuthorizationRequest(const BtDevice& device);
00033
00035         virtual ~BtRespondAuthorizationRequest();
00036
00038
00046         virtual BtRequestType GetRequestType() const;
00047
00049
00059         BOOLEAN GetAcceptAuthorization() const;
00060
00062
00067         void SetAcceptAuthorization(BOOLEAN accept_authorization);
00068
00070
00080         BOOLEAN GetCreateTrust() const;
00081
00083
00088         void SetCreateTrust(BOOLEAN create_trust);
00089
00090     protected:
00092
00113         virtual BOOLEAN Execute();
00114
00116
00122         virtual void RegisterMessages() const;
00123
00125
00130         virtual void UnregisterMessages() const;
00131
00133
00147         virtual BOOLEAN OnMessage(const Message& message);
00148
00149     private:
00151         btapi_authorisation_rsp_t m_api_authorization_response;
00152 };
00153
00155 #endif  // BtRespondAuthorizationRequest_hpp
00156
00157
Generated on Tue Jan 24 14:48:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbDataElements.cpp File Reference

Bluetooth/BtSddbDataElements.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbDataElements.hpp"

Include dependency graph for BtSddbDataElements.cpp:

Defines

#define | BT_SDDB_BOOLEAN_SIZE 1L
#define | BT_SDDB_DESCRIPTOR_SIZE 1L
#define | BT_SDDB_NIL_SIZE 0L
#define | BT_SDDB_SINT128_SIZE 16L
#define | BT_SDDB_SINT16_SIZE 2L
#define | BT_SDDB_SINT32_SIZE 4L
#define | BT_SDDB_SINT64_SIZE 8L
#define | BT_SDDB_SINT8_SIZE 1L
#define | BT_SDDB_SIZE16_SIZE 2L
#define | BT_SDDB_SIZE32_SIZE 4L
#define | BT_SDDB_SIZE8_SIZE 1L
#define | BT_SDDB_UINT128_SIZE 16L
#define | BT_SDDB_UINT16_SIZE 2L
#define | BT_SDDB_UINT32_SIZE 4L
#define | BT_SDDB_UINT64_SIZE 8L
#define | BT_SDDB_UINT8_SIZE 1L
#define | BT_SDDB_UUID128_SIZE 16L
#define | BT_SDDB_UUID16_SIZE 2L
#define | BT_SDDB_UUID32_SIZE 4L

Define Documentation

#define BT_SDDB_BOOLEAN_SIZE 1L

#define BT_SDDB_DESCRIPTOR_SIZE 1L

#define BT_SDDB_NIL_SIZE 0L

#define BT_SDDB_SINT128_SIZE 16L

#define BT_SDDB_SINT16_SIZE 2L

#define BT_SDDB_SINT32_SIZE 4L

#define BT_SDDB_SINT64_SIZE 8L

#define BT_SDDB_SINT8_SIZE 1L

#define BT_SDDB_SIZE16_SIZE 2L

#define BT_SDDB_SIZE32_SIZE 4L

#define BT_SDDB_SIZE8_SIZE 1L

#define BT_SDDB_UINT128_SIZE 16L

#define BT_SDDB_UINT16_SIZE 2L

#define BT_SDDB_UINT32_SIZE 4L

#define BT_SDDB_UINT64_SIZE 8L

#define BT_SDDB_UINT8_SIZE 1L

#define BT_SDDB_UUID128_SIZE 16L

#define BT_SDDB_UUID16_SIZE 2L

#define BT_SDDB_UUID32_SIZE 4L

Generated on Tue Jan 24 20:04:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbDataElements.hpp File Reference

Bluetooth/BtSddbDataElements.hpp File Reference

#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtSddbDataElements.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSddbDataElement
class | BtSddbDataElementFactory
class | BtSddbDeAlternative
class | BtSddbDeBaseCType
class | BtSddbDeBigSintBase
class | BtSddbDeBigUintBase
class | BtSddbDeBoolean
class | BtSddbDeByteBlockType
class | BtSddbDeContainer
class | BtSddbDeContainer::BtSddbDeContainerNode
class | BtSddbDeNil
class | BtSddbDeOneByteDescriptionType
class | BtSddbDeSequence
class | BtSddbDeSint128
class | BtSddbDeSint16
class | BtSddbDeSint32
class | BtSddbDeSint64
class | BtSddbDeSint8
class | BtSddbDeSintBase
class | BtSddbDeString
class | BtSddbDeUint128
class | BtSddbDeUint16
class | BtSddbDeUint32
class | BtSddbDeUint64
class | BtSddbDeUint8
class | BtSddbDeUintBase
class | BtSddbDeUrl
class | BtSddbDeUuid128
class | BtSddbDeUuid16
class | BtSddbDeUuid32
class | BtSddbDeUuidBase
class | BtSddbDeVariableLengthType

Defines

#define | BtSddbDataElements_hpp

Define Documentation

#define BtSddbDataElements_hpp

Generated on Tue Jan 24 20:04:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbDataElements.hpp Source File

Bluetooth/BtSddbDataElements.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbDataElements_hpp)
00009 #define BtSddbDataElements_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations
00017     ------------------------------------------------------------------------ */
00018
00019 class BtSddbDataElement;
00020
00023 class BtSddbDataElementFactory
00024 {
00025     public:
00027
00029         static BtSddbDataElementFactory& GetInstance();
00030
00031     public:
00033         virtual ~BtSddbDataElementFactory();
00034
00036
00038         BtSddbDataElement* NewDataElement(UINT8 data_element_descriptor);
00039
00040     protected:
00042
00044         BtSddbDataElement* NewUint(UINT8 size_descriptor);
00045
00047
00049         BtSddbDataElement* NewSint(UINT8 size_descriptor);
00050
00052
00054         BtSddbDataElement* NewUuid(UINT8 size_descriptor);
00055
00056     private:
00058         BtSddbDataElementFactory();
00059
00060     private:
00062         static BtSddbDataElementFactory m_factory;
00063 };
00064
00065 /*  ------------------------------------------------------------------------
00066     Forward deklarations for friend declaration
00067     ------------------------------------------------------------------------ */
00068
00069 class BtSddbServiceAttribute;
00070 class BtSddbDeContainer;
00071
00079 class BtSddbDataElement
00080 {
00081     public:
00083         BtSddbDataElement();
00084
00086         virtual ~BtSddbDataElement();
00087
00089
00093         virtual BtDataElementType GetType() const = 0;
00094
00096
00099         virtual INT32 GetSize() const = 0;
00100
00102
00104         virtual BOOLEAN IsValid() const = 0;
00105
00106     protected:
00108
00114         virtual BtSddbDataElement* Clone() const = 0;
00115
00117
00124         virtual INT32 GetMemorySize() const = 0;
00125
00127
00129         virtual BOOLEAN ReadFromMemory(const void*& memory, INT32& memory_size) = 0;
00130
00132
00139         virtual void* WriteToMemory(void* memory) const = 0;
00140
00141     private:
00142         friend class BtSddbServiceAttribute;
00143         friend class BtSddbDeContainer;
00144 };
00145
00147
00149 class BtSddbDeOneByteDescriptionType: public BtSddbDataElement
00150 {
00151     private:
00152         typedef BtSddbDataElement Base;
00153
00154     public:
00156         BtSddbDeOneByteDescriptionType();
00157
00159         virtual ~BtSddbDeOneByteDescriptionType();
00160
00162
00169         void* GetData();
00170
00172
00179         const void* GetData() const;
00180
00181     protected:
00183
00185         virtual INT32 GetMemorySize() const;
00186
00188
00190         virtual BOOLEAN ReadFromMemory(const void*& memory, INT32& memory_size);
00191
00199         virtual void* WriteToMemory(void* memory) const;
00200
00202
00204         void SetData(void* data);
00205
00207
00209         virtual UINT8 GetDataElementDescriptor() const = 0;
00210
00211     protected:
00213         void* m_data;
00214 };
00215
00217
00219 class BtSddbDeBaseCType: public BtSddbDeOneByteDescriptionType
00220 {
00221     private:
00222         typedef BtSddbDeOneByteDescriptionType Base;
00223
00224     public:
00226         BtSddbDeBaseCType();
00227
00229         virtual ~BtSddbDeBaseCType();
00230
00232
00234         virtual BOOLEAN IsValid() const;
00235 };
00236
00239 class BtSddbDeNil: public BtSddbDeBaseCType
00240 {
00241     private:
00242         typedef BtSddbDeBaseCType Base;
00243
00244     public:
00246         BtSddbDeNil();
00247
00249         virtual ~BtSddbDeNil();
00250
00252
00254         virtual BtDataElementType GetType() const;
00255
00257
00259         virtual INT32 GetSize() const;
00260
00261     protected:
00263
00265         virtual BtSddbDataElement* Clone() const;
00266
00268
00270         virtual UINT8 GetDataElementDescriptor() const;
00271 };
00272
00275 class BtSddbDeUintBase: public BtSddbDeBaseCType
00276 {
00277     private:
00278         typedef BtSddbDeBaseCType Base;
00279
00280     public:
00282         BtSddbDeUintBase();
00283
00285         virtual ~BtSddbDeUintBase();
00286
00288
00290         virtual BtDataElementType GetType() const;
00291 };
00292
00295 class BtSddbDeUint8: public BtSddbDeUintBase
00296 {
00297     private:
00298         typedef BtSddbDeUintBase Base;
00299
00300     public:
00302         BtSddbDeUint8(UINT8 value = 0);
00303
00305         virtual ~BtSddbDeUint8();
00306
00308
00310         virtual INT32 GetSize() const;
00311
00313
00315         UINT8 GetValue() const;
00316
00318
00320         void SetValue(UINT8 value);
00321
00322     protected:
00324
00326         virtual BtSddbDataElement* Clone() const;
00327
00329
00331         virtual UINT8 GetDataElementDescriptor() const;
00332
00333     private:
00334         UINT8 m_value;
00335 };
00336
00339 class BtSddbDeUint16: public BtSddbDeUintBase
00340 {
00341     private:
00342         typedef BtSddbDeUintBase Base;
00343
00344     public:
00346         BtSddbDeUint16(UINT16 value = 0);
00347
00349         virtual ~BtSddbDeUint16();
00350
00352
00354         virtual INT32 GetSize() const;
00355
00357
00359         UINT16 GetValue() const;
00360
00362
00364         void SetValue(UINT16 value);
00365
00366     protected:
00368
00370         virtual BtSddbDataElement* Clone() const;
00371
00373
00375         virtual UINT8 GetDataElementDescriptor() const;
00376
00377     private:
00378         UINT8 m_value[2];
00379 };
00380
00383 class BtSddbDeUint32: public BtSddbDeUintBase
00384 {
00385     private:
00386         typedef BtSddbDeUintBase Base;
00387
00388     public:
00390         BtSddbDeUint32(UINT32 value = 0);
00391
00393         virtual ~BtSddbDeUint32();
00394
00396
00398         virtual INT32 GetSize() const;
00399
00401
00403         UINT32 GetValue() const;
00404
00406
00408         void SetValue(UINT32 value);
00409
00410     protected:
00412
00414         virtual BtSddbDataElement* Clone() const;
00415
00417
00419         virtual UINT8 GetDataElementDescriptor() const;
00420
00421     private:
00422         UINT8 m_value[4];
00423 };
00424
00427 class BtSddbDeSintBase: public BtSddbDeBaseCType
00428 {
00429     private:
00430         typedef BtSddbDeBaseCType Base;
00431
00432     public:
00434         BtSddbDeSintBase();
00435
00437         virtual ~BtSddbDeSintBase();
00438
00440
00442         virtual BtDataElementType GetType() const;
00443 };
00444
00447 class BtSddbDeSint8: public BtSddbDeSintBase
00448 {
00449     private:
00450         typedef BtSddbDeSintBase Base;
00451
00452     public:
00454         BtSddbDeSint8(INT8 value = 0);
00455
00457         virtual ~BtSddbDeSint8();
00458
00460
00462         virtual INT32 GetSize() const;
00463
00465
00467         INT8 GetValue() const;
00468
00470
00472         void SetValue(INT8 value);
00473
00474     protected:
00476
00478         virtual BtSddbDataElement* Clone() const;
00479
00481
00483         virtual UINT8 GetDataElementDescriptor() const;
00484
00485     private:
00486         UINT8 m_value;
00487 };
00488
00491 class BtSddbDeSint16: public BtSddbDeSintBase
00492 {
00493     private:
00494         typedef BtSddbDeSintBase Base;
00495
00496     public:
00498         BtSddbDeSint16(INT16 value = 0);
00499
00501         virtual ~BtSddbDeSint16();
00502
00504
00506         virtual INT32 GetSize() const;
00507
00509
00511         INT16 GetValue() const;
00512
00514
00516         void SetValue(INT16 value);
00517
00518     protected:
00520
00522         virtual BtSddbDataElement* Clone() const;
00523
00525
00527         virtual UINT8 GetDataElementDescriptor() const;
00528
00529     private:
00530         UINT8 m_value[2];
00531 };
00532
00535 class BtSddbDeSint32: public BtSddbDeSintBase
00536 {
00537     private:
00538         typedef BtSddbDeSintBase Base;
00539
00540     public:
00542         BtSddbDeSint32(INT32 value = 0);
00543
00545         virtual ~BtSddbDeSint32();
00546
00548
00550         virtual INT32 GetSize() const;
00551
00553
00555         INT32 GetValue() const;
00556
00558
00560         void SetValue(INT32 value);
00561
00562     protected:
00564
00566         virtual BtSddbDataElement* Clone() const;
00567
00569
00571         virtual UINT8 GetDataElementDescriptor() const;
00572
00573     private:
00574         UINT8 m_value[4];
00575 };
00576
00579 class BtSddbDeUuidBase: public BtSddbDeBaseCType
00580 {
00581     private:
00582         typedef BtSddbDeBaseCType Base;
00583
00584     public:
00586         BtSddbDeUuidBase();
00587
00589         virtual ~BtSddbDeUuidBase();
00590
00592
00594         virtual BtDataElementType GetType() const;
00595 };
00596
00599 class BtSddbDeUuid16: public BtSddbDeUuidBase
00600 {
00601     private:
00602         typedef BtSddbDeUuidBase Base;
00603
00604     public:
00606         BtSddbDeUuid16(UINT16 value = 0);
00607
00609         virtual ~BtSddbDeUuid16();
00610
00612
00614         virtual INT32 GetSize() const;
00615
00617
00619         UINT16 GetValue() const;
00620
00622
00624         void SetValue(UINT16 value);
00625
00626     protected:
00628
00630         virtual BtSddbDataElement* Clone() const;
00631
00633
00635         virtual UINT8 GetDataElementDescriptor() const;
00636
00637     private:
00638         UINT8 m_value[2];
00639 };
00640
00643 class BtSddbDeUuid32: public BtSddbDeUuidBase
00644 {
00645     private:
00646         typedef BtSddbDeUuidBase Base;
00647
00648     public:
00650         BtSddbDeUuid32(UINT32 value = 0);
00651
00653         virtual ~BtSddbDeUuid32();
00654
00656
00658         virtual INT32 GetSize() const;
00659
00661
00663         UINT32 GetValue() const;
00664
00666
00668         void SetValue(UINT32 value);
00669
00670     protected:
00672
00674         virtual BtSddbDataElement* Clone() const;
00675
00677
00679         virtual UINT8 GetDataElementDescriptor() const;
00680
00681     private:
00682         UINT8 m_value[4];
00683 };
00684
00687 class BtSddbDeBoolean: public BtSddbDeBaseCType
00688 {
00689     private:
00690         typedef BtSddbDeBaseCType Base;
00691
00692     public:
00694         BtSddbDeBoolean(BOOLEAN value = FALSE);
00695
00697         virtual ~BtSddbDeBoolean();
00698
00700
00702         virtual BtDataElementType GetType() const;
00703
00705
00707         virtual INT32 GetSize() const;
00708
00710
00712         BOOLEAN GetValue() const;
00713
00715
00717         void SetValue(BOOLEAN value);
00718
00719     protected:
00721
00723         virtual BtSddbDataElement* Clone() const;
00724
00726
00728         virtual UINT8 GetDataElementDescriptor() const;
00729
00730     private:
00731         BOOLEAN m_value;
00732 };
00733
00736 class BtSddbDeByteBlockType: public BtSddbDeOneByteDescriptionType
00737 {
00738     private:
00739         typedef BtSddbDeOneByteDescriptionType Base;
00740
00741     public:
00743         BtSddbDeByteBlockType();
00744
00746         virtual ~BtSddbDeByteBlockType();
00747
00749
00751         virtual BOOLEAN IsValid() const;
00752
00754
00756         UINT8* GetValue() const;
00757
00759
00761         void SetValue(const UINT8* value);
00762 };
00763
00766 class BtSddbDeBigUintBase: public BtSddbDeByteBlockType
00767 {
00768     private:
00769         typedef BtSddbDeByteBlockType Base;
00770
00771     public:
00773         BtSddbDeBigUintBase();
00774
00776         virtual ~BtSddbDeBigUintBase();
00777
00779
00781         virtual BtDataElementType GetType() const;
00782 };
00783
00786 class BtSddbDeUint64: public BtSddbDeBigUintBase
00787 {
00788     private:
00789         typedef BtSddbDeBigUintBase Base;
00790
00791     public:
00793         BtSddbDeUint64(const UINT8* value = 0);
00794
00796         virtual ~BtSddbDeUint64();
00797
00799
00801         virtual INT32 GetSize() const;
00802
00803     protected:
00805
00807         virtual BtSddbDataElement* Clone() const;
00808
00810
00812         virtual UINT8 GetDataElementDescriptor() const;
00813
00814     private:
00816         UINT8 m_value[8];
00817 };
00818
00821 class BtSddbDeUint128: public BtSddbDeBigUintBase
00822 {
00823     private:
00824         typedef BtSddbDeBigUintBase Base;
00825
00826     public:
00828         BtSddbDeUint128(const UINT8* value = 0);
00829
00831         virtual ~BtSddbDeUint128();
00832
00834
00836         virtual INT32 GetSize() const;
00837
00838     protected:
00840
00842         virtual BtSddbDataElement* Clone() const;
00843
00845
00847         virtual UINT8 GetDataElementDescriptor() const;
00848
00849     private:
00851         UINT8 m_value[16];
00852 };
00853
00856 class BtSddbDeBigSintBase: public BtSddbDeByteBlockType
00857 {
00858     private:
00859         typedef BtSddbDeByteBlockType Base;
00860
00861     public:
00863         BtSddbDeBigSintBase();
00864
00866         virtual ~BtSddbDeBigSintBase();
00867
00869
00871         virtual BtDataElementType GetType() const;
00872 };
00873
00876 class BtSddbDeSint64: public BtSddbDeBigUintBase
00877 {
00878     private:
00879         typedef BtSddbDeBigUintBase Base;
00880
00881     public:
00883         BtSddbDeSint64(const UINT8* value = 0);
00884
00886         virtual ~BtSddbDeSint64();
00887
00889
00891         virtual INT32 GetSize() const;
00892
00893     protected:
00895
00897         virtual BtSddbDataElement* Clone() const;
00898
00900
00902         virtual UINT8 GetDataElementDescriptor() const;
00903
00904     private:
00906         UINT8 m_value[8];
00907 };
00908
00911 class BtSddbDeSint128: public BtSddbDeBigUintBase
00912 {
00913     private:
00914         typedef BtSddbDeBigUintBase Base;
00915
00916     public:
00918         BtSddbDeSint128(const UINT8* value = 0);
00919
00921         virtual ~BtSddbDeSint128();
00922
00924
00926         virtual INT32 GetSize() const;
00927
00928     protected:
00930
00932         virtual BtSddbDataElement* Clone() const;
00933
00935
00937         virtual UINT8 GetDataElementDescriptor() const;
00938
00939     private:
00941         UINT8 m_value[16];
00942 };
00943
00946 class BtSddbDeUuid128: public BtSddbDeByteBlockType
00947 {
00948     private:
00949         typedef BtSddbDeByteBlockType Base;
00950
00951     public:
00953         BtSddbDeUuid128(const UINT8* value = 0);
00954
00956         virtual ~BtSddbDeUuid128();
00957
00959
00961         virtual BtDataElementType GetType() const;
00962
00964
00966         virtual INT32 GetSize() const;
00967
00968     protected:
00970
00972         virtual BtSddbDataElement* Clone() const;
00973
00975
00977         virtual UINT8 GetDataElementDescriptor() const;
00978
00979     private:
00981         UINT8 m_value[16];
00982 };
00983
00986 class BtSddbDeVariableLengthType: public BtSddbDataElement
00987 {
00988     private:
00989         typedef BtSddbDataElement Base;
00990
00991     public:
00993         BtSddbDeVariableLengthType();
00994
00996         BtSddbDeVariableLengthType(const WString& value);
00997
00999         virtual ~BtSddbDeVariableLengthType();
01000
01002
01004         virtual INT32 GetSize() const;
01005
01007
01009         virtual BOOLEAN IsValid() const;
01010
01012
01014         WString GetValue() const;
01015
01017
01019         void SetValue(const WString& value);
01020
01021     protected:
01023
01025         virtual INT32 GetMemorySize() const;
01026
01028
01030         virtual BOOLEAN ReadFromMemory(const void*& memory, INT32& memory_size);
01031
01033
01035         virtual void* WriteToMemory(void* memory) const;
01036
01038
01040         virtual UINT8 GetDataElementTypeDescriptor() const = 0;
01041
01043
01045         UINT8 GetDataElementSizeDescriptor() const;
01046
01047     protected:
01049         String m_value;
01050 };
01051
01054 class BtSddbDeString: public BtSddbDeVariableLengthType
01055 {
01056     private:
01057         typedef BtSddbDeVariableLengthType Base;
01058
01059     public:
01061         BtSddbDeString();
01062
01064         BtSddbDeString(const WString& value);
01065
01067         virtual ~BtSddbDeString();
01068
01070
01072         virtual BtDataElementType GetType() const;
01073
01074     protected:
01076
01078         virtual BtSddbDataElement* Clone() const;
01079
01081
01083         virtual UINT8 GetDataElementTypeDescriptor() const;
01084 };
01085
01088 class BtSddbDeUrl: public BtSddbDeVariableLengthType
01089 {
01090     private:
01091         typedef BtSddbDeVariableLengthType Base;
01092
01093     public:
01095         BtSddbDeUrl(const WString& value);
01096
01098         BtSddbDeUrl();
01099
01101         virtual ~BtSddbDeUrl();
01102
01104
01106         virtual BtDataElementType GetType() const;
01107
01108     protected:
01110
01112         virtual BtSddbDataElement* Clone() const;
01113
01115
01117         virtual UINT8 GetDataElementTypeDescriptor() const;
01118 };
01119
01135 class BtSddbDeContainer: public BtSddbDataElement
01136 {
01137     private:
01138         typedef BtSddbDataElement Base;
01139
01140     public:
01142         BtSddbDeContainer();
01143
01145         virtual ~BtSddbDeContainer();
01146
01148
01153         virtual INT32 GetSize() const;
01154
01156
01158         virtual BOOLEAN IsValid() const;
01159
01161
01168         BtSddbDataElement* GetFirst();
01169
01171
01178         const BtSddbDataElement* GetFirst() const;
01179
01181
01192         BtSddbDataElement* GetNext(const BtSddbDataElement* current);
01193
01195
01206         const BtSddbDataElement* GetNext(const BtSddbDataElement* current) const;
01207
01209
01223         BOOLEAN Insert(const BtSddbDataElement& data_element, const BtSddbDataElement* position = 0);
01224
01226
01240         BtSddbDataElement* Delete(const BtSddbDataElement* data_element);
01241
01243
01245         void Clear(void);
01246
01247     protected:
01249
01256         virtual INT32 GetMemorySize() const;
01257
01259
01261         INT32 GetMemorySizeOfContainedDataElements() const;
01262
01264
01266         virtual BOOLEAN ReadFromMemory(const void*& memory, INT32& memory_size);
01267
01269
01276         virtual void* WriteToMemory(void* memory) const;
01277
01279
01281         virtual UINT8 GetDataElementTypeDescriptor() const = 0;
01282
01284
01286         UINT8 GetDataElementSizeDescriptor() const;
01287
01289
01291         BOOLEAN Copy(const BtSddbDeContainer* to_copy);
01292
01293     private:
01299         class BtSddbDeContainerNode
01300         {
01301             public:
01303                 BtSddbDeContainerNode(BtSddbDataElement* data_element, BtSddbDeContainerNode* next = 0);
01304
01306                 virtual ~BtSddbDeContainerNode();
01307
01309
01314                 BtSddbDataElement* GetDataElement();
01315
01321                 void SetDataElement(BtSddbDataElement* data_element);
01322
01329                 BtSddbDeContainerNode* GetNext();
01330
01335                 void SetNext(BtSddbDeContainerNode* next);
01336
01337             private:
01339                 BtSddbDataElement* m_data_element;
01340
01342
01345                 BtSddbDeContainerNode* m_next;
01346         };
01347
01348     private:
01350
01352         BtSddbDeContainerNode* CreateNewContainerNode(const BtSddbDataElement* data_element);
01353
01355
01367         BtSddbDeContainerNode* Search(const BtSddbDataElement* data_element) const;
01368
01369     private:
01371         BOOLEAN m_is_valid;
01372
01375         BtSddbDeContainerNode* m_anchor;
01376
01378         INT32 m_number_of_nodes;
01379 };
01380
01383 class BtSddbDeSequence: public BtSddbDeContainer
01384 {
01385     private:
01386         typedef BtSddbDeContainer Base;
01387
01388     public:
01390         BtSddbDeSequence();
01391
01393         virtual ~BtSddbDeSequence();
01394
01396
01398         virtual BtDataElementType GetType() const;
01399
01400     protected:
01402
01404         virtual BtSddbDataElement* Clone() const;
01405
01407
01409         virtual UINT8 GetDataElementTypeDescriptor() const;
01410 };
01411
01414 class BtSddbDeAlternative: public BtSddbDeContainer
01415 {
01416     private:
01417         typedef BtSddbDeContainer Base;
01418
01419     public:
01421         BtSddbDeAlternative();
01422
01424         virtual ~BtSddbDeAlternative();
01425
01427
01429         virtual BtDataElementType GetType() const;
01430
01431     protected:
01433
01435         virtual BtSddbDataElement* Clone() const;
01436
01438
01440         virtual UINT8 GetDataElementTypeDescriptor() const;
01441 };
01442
01444 #endif  // BtSddbDataElements_hpp
01445
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbEvent.cpp File Reference

Bluetooth/BtSddbEvent.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbEvent.hpp"

Include dependency graph for BtSddbEvent.cpp:

Generated on Tue Jan 24 20:04:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbEvent.hpp File Reference

Bluetooth/BtSddbEvent.hpp File Reference

#include <Bluetooth/BtEvent.hpp>

Include dependency graph for BtSddbEvent.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSddbEvent
class | BtSddbRegisterServiceEvent
class | BtSddbUnregisterServiceEvent

Defines

#define | BtSddbEvent_hpp

Define Documentation

#define BtSddbEvent_hpp

Generated on Tue Jan 24 20:04:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbEvent.hpp Source File

Bluetooth/BtSddbEvent.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbEvent_hpp)
00009 #define BtSddbEvent_hpp
00012
00013 #include <Bluetooth/BtEvent.hpp>
00014
00017 class BtSddbEvent: public BtEvent
00018 {
00019     private:
00020         typedef BtEvent Base;
00021
00022     public:
00024         BtSddbEvent(BtResultCode result);
00025
00027         virtual ~BtSddbEvent();
00028 };
00029
00032 class BtSddbRegisterServiceEvent: public BtSddbEvent
00033 {
00034     private:
00035         typedef BtSddbEvent Base;
00036
00037     public:
00039         BtSddbRegisterServiceEvent(BtResultCode result, UINT32 service_record_handle);
00040
00042         virtual ~BtSddbRegisterServiceEvent();
00043
00045
00047         UINT32 GetSerivceRecordHandle() const;
00048
00049     public:
00051
00053         virtual UINT16 GetId() const;
00054
00055     public:
00056         enum { ID = 1 };
00057
00058     private:
00060         UINT32 m_service_record_handle;
00061 };
00062
00065 class BtSddbUnregisterServiceEvent: public BtSddbEvent
00066 {
00067     private:
00068         typedef BtSddbEvent Base;
00069
00070     public:
00072         BtSddbUnregisterServiceEvent(BtResultCode result);
00073
00075         virtual ~BtSddbUnregisterServiceEvent();
00076
00077     public:
00079
00081         virtual UINT16 GetId() const;
00082
00083     public:
00084         enum { ID = 2 };
00085 };
00086
00088 #endif  // BtSddbEvent_hpp
00089
00090
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbRegisterServiceRecordRequest.cpp File Reference

Bluetooth/BtSddbRegisterServiceRecordRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbService.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtSddbRegisterServiceRecordRequest.hpp"
#include <stdio.h>

Include dependency graph for BtSddbRegisterServiceRecordRequest.cpp:

Generated on Tue Jan 24 20:04:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbRegisterServiceRecordRequest.hpp File Reference

Bluetooth/BtSddbRegisterServiceRecordRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtSddbRegisterServiceRecordRequest_hpp

Define Documentation

#define BtSddbRegisterServiceRecordRequest_hpp

Generated on Tue Jan 24 20:04:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbRegisterServiceRecordRequest.hpp Source File

Bluetooth/BtSddbRegisterServiceRecordRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbRegisterServiceRecordRequest_hpp)
00009 #define BtSddbRegisterServiceRecordRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtTypes.hpp>
00021 #include <Bluetooth/BtSddbServiceRecord.hpp>
00022 #include <Bluetooth/BtSddbRequest.hpp>
00023
00024 /*  ------------------------------------------------------------------------
00025     Forward deklarations for friend relationships.
00026     ------------------------------------------------------------------------ */
00027
00028 class BtSddbService;
00029 class BtGapAndSdapController;
00030
00033 class BtSddbRegisterServiceRecordRequest: public BtSddbRequest
00034 {
00035     private:
00036         typedef BtSddbRequest Base;
00037
00038     public:
00040         BtSddbRegisterServiceRecordRequest(BtSddbService& sddb_service);
00041
00043         virtual ~BtSddbRegisterServiceRecordRequest();
00044
00046
00048         virtual BtRequestType GetRequestType() const;
00049
00051
00053         const BtSddbServiceRecord& GetServiceRecord() const;
00054
00056
00058         BtSddbServiceRecord& GetServiceRecord();
00059
00061
00063         void SetServiceRecord(const BtSddbServiceRecord& service_record);
00064
00066
00068         UINT32 GetServiceRecordHandle() const;
00069
00071
00073         void SetServiceRecordHandle(UINT32 service_record_handle);
00074
00075     protected:
00077
00079         virtual BOOLEAN Execute();
00080
00082
00084         void ServiceRecordHandleCallback(UINT32 service_record_handle);
00085
00087
00089         virtual void ExecutionCallback(BtResultCode result);
00090
00091     private:
00093         BtSddbServiceRecord m_service_record;
00094
00096         UINT32 m_service_record_handle;
00097
00098     private:
00099         friend class BtGapAndSdapController;
00100 };
00101
00103 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00104 #endif  // BtSddbRegisterServiceRecordRequest_hpp
00105
00106
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbRequest.cpp File Reference

Bluetooth/BtSddbRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbService.hpp"
#include "BtSddbRequest.hpp"

Include dependency graph for BtSddbRequest.cpp:

Generated on Tue Jan 24 20:04:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbRequest.hpp File Reference

Bluetooth/BtSddbRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtSddbRequest_hpp

Define Documentation

#define BtSddbRequest_hpp

Generated on Tue Jan 24 20:04:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbRequest.hpp Source File

Bluetooth/BtSddbRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbRequest_hpp)
00009 #define BtSddbRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtServiceRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtSddbService;
00027
00030 class BtSddbRequest: public BtServiceRequest
00031 {
00032     private:
00033         typedef BtServiceRequest Base;
00034
00035     public:
00037         BtSddbRequest(BtSddbService& sddb_service);
00038
00040         virtual ~BtSddbRequest();
00041 };
00042
00044 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00045 #endif  // BtSddbRequest_hpp
00046
00047
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbService.cpp File Reference

Bluetooth/BtSddbService.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbEvent.hpp"
#include "BtSddbService.hpp"
#include "BtSddbServiceMessage.hpp"

Include dependency graph for BtSddbService.cpp:

Generated on Tue Jan 24 20:04:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbService.hpp File Reference

Bluetooth/BtSddbService.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtObservableService.hpp>
#include <Bluetooth/BtSddbServiceObserver.hpp>
#include <Bluetooth/BtSddbServiceRecord.hpp>
#include <Bluetooth/BtSddbRegisterServiceRecordRequest.hpp>
#include <Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp>

Include dependency graph for BtSddbService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSddbService

Defines

#define | BtSddbService_hpp

Define Documentation

#define BtSddbService_hpp

Generated on Tue Jan 24 20:04:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbService.hpp Source File

Bluetooth/BtSddbService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbService_hpp)
00009 #define BtSddbService_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtObservableService.hpp>
00015 #include <Bluetooth/BtSddbServiceObserver.hpp>
00016 #include <Bluetooth/BtSddbServiceRecord.hpp>
00017 #include <Bluetooth/BtSddbRegisterServiceRecordRequest.hpp>
00018 #include <Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp>
00019
00022 class BtSddbService: public BtObservableService
00023 {
00024     private:
00025         typedef BtObservableService Base;
00026
00027     public:
00029         BtSddbService();
00030
00032         virtual ~BtSddbService();
00033
00035
00039         virtual BtProfile GetProfile() const;
00040
00042
00044         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00045
00047
00049         UINT32 GetServiceRecordHandle();
00050
00052
00054         BtRequestState RegisterServiceRecordRequest(const BtSddbServiceRecord& service_record, UINT32 service_record_handle = 0);
00055
00057
00059         BtRequestState UnregisterServiceRecordRequest(UINT32 service_record_handle);
00060
00061     public:
00063
00065         BOOLEAN Attach(BtSddbServiceObserver* service_observer);
00066
00068
00070         BOOLEAN Detach(BtSddbServiceObserver* service_observer);
00071
00072     protected:
00074
00076         virtual void RegisterMessages() const;
00077
00079
00081         virtual void UnregisterMessages() const;
00082
00084
00086         virtual BOOLEAN OnMessage(const Message& message);
00087
00089
00091         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00092
00094
00096         void RegisterServiceCallback(BtResultCode result, UINT32 service_record_handle);
00097
00099
00101         void UnregisterServiceCallback(BtResultCode result);
00102
00103     private:
00105         BtSddbRegisterServiceRecordRequest m_register_request;
00106
00108         BtSddbUnregisterServiceRecordRequest m_unregister_request;
00109
00110     private:
00111         friend class BtSddbRegisterServiceRecordRequest;
00112         friend class BtSddbUnregisterServiceRecordRequest;
00113 };
00114
00116 #endif  // BtSddbService_hpp
00117
00118
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceAttribute.cpp File Reference

Bluetooth/BtSddbServiceAttribute.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbServiceRecord.hpp"

Include dependency graph for BtSddbServiceAttribute.cpp:

Generated on Tue Jan 24 20:04:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceAttribute.hpp File Reference

Bluetooth/BtSddbServiceAttribute.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtSddbDataElements.hpp>

Include dependency graph for BtSddbServiceAttribute.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSddbServiceAttribute

Defines

#define | BtSddbServiceAttribute_hpp

Define Documentation

#define BtSddbServiceAttribute_hpp

Generated on Tue Jan 24 20:04:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceAttribute.hpp Source File

Bluetooth/BtSddbServiceAttribute.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbServiceAttribute_hpp)
00009 #define BtSddbServiceAttribute_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtSddbDataElements.hpp>
00015
00016
00017 /*  ------------------------------------------------------------------------
00018     forward declartion
00019     ------------------------------------------------------------------------ */
00020 class BtSddbServiceRecord;
00021
00024 class BtSddbServiceAttribute
00025 {
00026     public:
00028         BtSddbServiceAttribute();
00029
00031         BtSddbServiceAttribute(UINT16 attribute_id, const BtSddbDataElement& data_delement);
00032
00034         BtSddbServiceAttribute(const BtSddbServiceAttribute& service_attribute);
00035
00037         virtual ~BtSddbServiceAttribute();
00038
00040
00042         BOOLEAN IsValid() const;
00043
00045
00049         UINT16 GetAttributeId() const;
00050
00052
00054         void SetAttributeId(UINT16 attribute_id);
00055
00057
00061         BtSddbDataElement* GetAttributeValue();
00062
00064
00068         const BtSddbDataElement* GetAttributeValue() const;
00069
00071
00073         BOOLEAN SetAttributeValue(const BtSddbDataElement& attribute_value);
00074
00075     protected:
00077
00083         UINT32 GetMemorySize() const;
00084
00086
00088         BOOLEAN ReadFromMemory(const void*& memory, INT32& memory_size);
00089
00091
00097         void* WriteToMemory(void* memory) const;
00098
00099     private:
00101         BOOLEAN m_is_valid;
00102
00104         UINT16 m_attribute_id;
00105
00107         BtSddbDataElement* m_attribute_value;
00108
00109     private:
00110         friend class BtSddbServiceRecord;
00111 };
00112
00114 #endif  // BtSddbServiceAttribute_hpp
00115
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceMessage.cpp File Reference

Bluetooth/BtSddbServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbServiceMessage.hpp"

Include dependency graph for BtSddbServiceMessage.cpp:

Generated on Tue Jan 24 20:04:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceMessage.hpp File Reference

Bluetooth/BtSddbServiceMessage.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtSddbServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSddbRequestStateChangedMessage

Defines

#define | Bluetooth_BtSddbServiceMessage_hpp

Define Documentation

#define Bluetooth_BtSddbServiceMessage_hpp

Generated on Tue Jan 24 20:04:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceMessage.hpp Source File

Bluetooth/BtSddbServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\BtSddbServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtSddbServiceMessage_hpp)
00016 #define Bluetooth_BtSddbServiceMessage_hpp
00017
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtSddbRequestStateChangedMessage
00027     ====================================================================== */
00028
00030 class BtSddbRequestStateChangedMessage : public BtRequestStateChangedMessage {
00031     public:
00032         BtSddbRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00033         virtual ~BtSddbRequestStateChangedMessage();
00034
00035         virtual const MsgMetaData& GetMetaData() const;
00036         virtual Message* Clone() const;
00037
00038         enum  {
00039             ID = 10310
00040             };
00041
00042     private:
00043         static const MsgMetaData m_meta_data;
00044
00045     };
00046
00047 #endif // Bluetooth_BtSddbServiceMessage_hpp
00048
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceObserver.cpp File Reference

Bluetooth/BtSddbServiceObserver.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbEvent.hpp"
#include "BtSddbServiceObserver.hpp"

Include dependency graph for BtSddbServiceObserver.cpp:

Generated on Tue Jan 24 20:04:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceObserver.hpp File Reference

Bluetooth/BtSddbServiceObserver.hpp File Reference

#include <Bluetooth/BtServiceObserver.hpp>

Include dependency graph for BtSddbServiceObserver.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSddbServiceObserver

Defines

#define | BtSddbServiceObserver_hpp

Define Documentation

#define BtSddbServiceObserver_hpp

Generated on Tue Jan 24 20:04:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceObserver.hpp Source File

Bluetooth/BtSddbServiceObserver.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbServiceObserver_hpp)
00009 #define BtSddbServiceObserver_hpp
00012
00013 #include <Bluetooth/BtServiceObserver.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtSddbService;
00020
00023 class BtSddbServiceObserver: public BtServiceObserver
00024 {
00025     private:
00026         typedef BtServiceObserver Base;
00027
00028     public:
00030         BtSddbServiceObserver();
00031
00033         virtual ~BtSddbServiceObserver();
00034
00035     protected:
00037
00039         virtual void OnEvent(const BtEvent& event);
00040
00042
00044         virtual void OnRegisterService(BtResultCode code) = 0;
00045
00047
00049         virtual void OnUnregisterService(BtResultCode code) = 0;
00050
00051 private:
00052         friend class BtSddbService;
00053 };
00054
00056 #endif  // BtSddbServiceObserver_hpp
00057
00058
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceRecord.cpp File Reference

Bluetooth/BtSddbServiceRecord.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbServiceRecord.hpp"

Include dependency graph for BtSddbServiceRecord.cpp:

Generated on Tue Jan 24 20:04:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceRecord.hpp File Reference

Bluetooth/BtSddbServiceRecord.hpp File Reference

#include <Bluetooth/BtSddbServiceAttribute.hpp>

Include dependency graph for BtSddbServiceRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSddbServiceRecord
class | BtSddbServiceRecord::BtSddbServiceRecordNode

Defines

#define | BtSddbServiceRecord_hpp

Define Documentation

#define BtSddbServiceRecord_hpp

Generated on Tue Jan 24 20:04:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbServiceRecord.hpp Source File

Bluetooth/BtSddbServiceRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbServiceRecord_hpp)
00009 #define BtSddbServiceRecord_hpp
00012
00013 #include <Bluetooth/BtSddbServiceAttribute.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     forward declartion
00017     ------------------------------------------------------------------------ */
00018 class BtServiceDiscoveryDatabase;
00019
00022 class BtSddbServiceRecord
00023 {
00024     public:
00026         BtSddbServiceRecord();
00027
00029         virtual ~BtSddbServiceRecord();
00030
00032
00034         BOOLEAN IsValid() const;
00035
00037
00043         UINT16 GetNumberOfAttributes() const;
00044
00046
00058         BtSddbServiceAttribute* GetAttributeById(UINT16 service_attribute_id);
00059
00061
00073         const BtSddbServiceAttribute* GetAttributeById(UINT16 service_attribute_id) const;
00074
00076
00083         BtSddbServiceAttribute* GetFirstAttribute();
00084
00086
00093         const BtSddbServiceAttribute* GetFirstAttribute() const;
00094
00096
00109         BtSddbServiceAttribute* GetNextAttribute(const BtSddbServiceAttribute* current);
00110
00112
00125         const BtSddbServiceAttribute* GetNextAttribute(const BtSddbServiceAttribute* current) const;
00126
00128
00143         BOOLEAN Insert(const BtSddbServiceAttribute& service_attribute, const BtSddbServiceAttribute* position = 0);
00144
00146
00164         BtSddbServiceAttribute* Delete(BtSddbServiceAttribute* service_attribute);
00165
00167
00169         void Clear(void);
00170
00172
00174         BtSddbServiceRecord& operator=(const BtSddbServiceRecord& service_record);
00175
00176     protected:
00183         UINT32 GetMemorySize() const;
00184
00194         BOOLEAN ReadFromMemory(const void*& memory, INT32& memory_size);
00195
00204         void* WriteToMemory(void* memory) const;
00205
00206     private:
00210         class BtSddbServiceRecordNode
00211         {
00212             public:
00214                 BtSddbServiceRecordNode(BtSddbServiceAttribute* service_attribute, BtSddbServiceRecordNode* next = 0);
00215
00217                 virtual ~BtSddbServiceRecordNode();
00218
00224                 BtSddbServiceAttribute* GetServiceAttribute();
00225
00228                 void SetServiceAttribute(BtSddbServiceAttribute* service_attribtue);
00229
00236                 BtSddbServiceRecordNode* GetNext();
00237
00242                 void SetNext(BtSddbServiceRecordNode* next);
00243
00244             private:
00246                 BtSddbServiceAttribute* m_service_attribute;
00247
00251                 BtSddbServiceRecordNode* m_next;
00252         };
00253
00254     private:
00256
00258         BtSddbServiceRecordNode* CreateNewServiceRecordNode(const BtSddbServiceAttribute* data_element);
00259
00261
00263         BtSddbServiceRecordNode* Search(const BtSddbServiceAttribute* service_attribute) const;
00264
00265     private:
00267         BOOLEAN m_is_valid;
00268
00271         BtSddbServiceRecordNode* m_anchor;
00272
00274         INT16 m_number_of_attributes;
00275
00276     private:
00277         friend class BtServiceDiscoveryDatabase;
00278 };
00279
00281 #endif  // BtSddbServiceRecord_hpp
00282
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbUnregisterServiceRecordRequest.cpp File Reference

Bluetooth/BtSddbUnregisterServiceRecordRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtSddbService.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtSddbUnregisterServiceRecordRequest.hpp"

Include dependency graph for BtSddbUnregisterServiceRecordRequest.cpp:

Generated on Tue Jan 24 20:04:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp File Reference

Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtSddbUnregisterServiceRecordRequest_hpp

Define Documentation

#define BtSddbUnregisterServiceRecordRequest_hpp

Generated on Tue Jan 24 20:04:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp Source File

Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSddbUnregisterServiceRecordRequest_hpp)
00009 #define BtSddbUnregisterServiceRecordRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtTypes.hpp>
00021 #include <Bluetooth/BtSddbRequest.hpp>
00022
00023 /*  ------------------------------------------------------------------------
00024     Forward deklarations for friend relationships.
00025     ------------------------------------------------------------------------ */
00026
00027 class BtSddbService;
00028 class BtGapAndSdapController;
00029
00032 class BtSddbUnregisterServiceRecordRequest: public BtSddbRequest
00033 {
00034     private:
00035         typedef BtSddbRequest Base;
00036
00037     public:
00039         BtSddbUnregisterServiceRecordRequest(BtSddbService& sddb_service);
00040
00042         virtual ~BtSddbUnregisterServiceRecordRequest();
00043
00045
00047         virtual BtRequestType GetRequestType() const;
00048
00050
00052         UINT32 GetServiceRecordHandle();
00053
00055
00057         void SetServiceRecordHandle(UINT32 service_record_handle);
00058
00059     protected:
00061
00063         virtual BOOLEAN Execute();
00064
00066
00068         virtual void ExecutionCallback(BtResultCode result);
00069
00070     private:
00072
00074         btapi_u32_t GetApiSettings() const;
00075
00076     private:
00078         btapi_u32_t m_service_record_handle;
00079
00080     private:
00081         friend class BtGapAndSdapController;
00082 };
00083
00085 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00086 #endif  // BtSddbUnregisterServiceRecordRequest_hpp
00087
00088
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSendPasskeyRequest.cpp File Reference

Bluetooth/BtSendPasskeyRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtSendPasskeyRequest.hpp"

Include dependency graph for BtSendPasskeyRequest.cpp:

Generated on Tue Jan 24 20:05:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSendPasskeyRequest.hpp File Reference

Bluetooth/BtSendPasskeyRequest.hpp File Reference

#include <Bluetooth/BtRequestRespondRequest.hpp>

Include dependency graph for BtSendPasskeyRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSendPasskeyRequest

Defines

#define | BtSendPasskeyRequest_hpp

Define Documentation

#define BtSendPasskeyRequest_hpp

Generated on Tue Jan 24 20:05:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSendPasskeyRequest.hpp Source File

Bluetooth/BtSendPasskeyRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSendPasskeyRequest_hpp)
00009 #define BtSendPasskeyRequest_hpp
00012
00013 #include <Bluetooth/BtRequestRespondRequest.hpp>
00014
00025 class BtSendPasskeyRequest: public BtRequestRespondRequest
00026 {
00027     private:
00028         typedef BtRequestRespondRequest Base;
00029
00030     public:
00032         BtSendPasskeyRequest(const BtDevice& device);
00033
00035         virtual ~BtSendPasskeyRequest();
00036
00038
00046         virtual BtRequestType GetRequestType() const;
00047
00049
00059         BOOLEAN GetAcceptPairing() const;
00060
00062
00067         void SetAcceptPairing(BOOLEAN accept_pairing);
00068
00070
00074         const WString& GetPinCode() const;
00075
00077
00082         void SetPinCode(const WString& pin_code);
00083
00084     protected:
00086
00107         virtual BOOLEAN Execute();
00108
00110
00115         virtual void RegisterMessages() const;
00116
00118
00123         virtual void UnregisterMessages() const;
00124
00126
00140         virtual BOOLEAN OnMessage(const Message& message);
00141
00142     private:
00144         WString m_pin_code;
00145
00147         btapi_passkey_rsp_t m_api_passkey_response;
00148 };
00149
00151 #endif  // BtSendPasskeyRequest_hpp
00152
00153
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtService.cpp File Reference

Bluetooth/BtService.cpp File Reference

#include "PreComp.hpp"
#include "BtService.hpp"

Include dependency graph for BtService.cpp:

Generated on Tue Jan 24 20:05:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtService.hpp File Reference

Bluetooth/BtService.hpp File Reference

#include <Kernel/UserDispatcher.hpp>
#include <Bluetooth/BtDevice.hpp>

Include dependency graph for BtService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtService

Defines

#define | BtService_hpp

Define Documentation

#define BtService_hpp

Generated on Tue Jan 24 20:05:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtService.hpp Source File

Bluetooth/BtService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtService_hpp)
00009 #define BtService_hpp
00012
00013 #include <Kernel/UserDispatcher.hpp>
00014 #include <Bluetooth/BtDevice.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00020 class BtServiceRequest;
00021
00031 class BtService: public UserDispatcher
00032 {
00033     private:
00034         typedef UserDispatcher Base;
00035
00036     public:
00038         BtService();
00039
00041         BtService(const BtDevice& target_device);
00042
00044         virtual ~BtService();
00045
00047
00052         virtual BtProfile GetProfile() const = 0;
00053
00055
00062         const BtDevice& GetTargetDevice() const;
00063
00065
00072         BtDevice& GetTargetDevice();
00073
00075
00082         virtual void SetTargetDevice(const BtDevice& target_device);
00083
00085
00087         virtual BtRequestState GetRequestState(BtRequestType request_type) const = 0;
00088
00089     protected:
00091
00093         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state) = 0;
00094
00096
00111         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state) = 0;
00112
00113     private:
00115         BtDevice m_target_device;
00116
00117     private:
00118         friend class BtServiceRequest;
00119 }; //BtService
00120
00122 #endif  // BtService_hpp
00123
00124
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceDiscoveryDatabase.cpp File Reference

Bluetooth/BtServiceDiscoveryDatabase.cpp File Reference

#include "PreComp.hpp"
#include "BtServiceDiscoveryDatabase.hpp"

Include dependency graph for BtServiceDiscoveryDatabase.cpp:

Generated on Tue Jan 24 20:05:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceDiscoveryDatabase.hpp File Reference

Bluetooth/BtServiceDiscoveryDatabase.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtServiceDiscoveryDatabase_hpp

Define Documentation

#define BtServiceDiscoveryDatabase_hpp

Generated on Tue Jan 24 20:05:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceDiscoveryDatabase.hpp Source File

Bluetooth/BtServiceDiscoveryDatabase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtServiceDiscoveryDatabase_hpp)
00009 #define BtServiceDiscoveryDatabase_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtSddbServiceRecord.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtGapAndSdapController;
00027
00030 class BtServiceDiscoveryDatabase
00031 {
00032     public:
00034
00036         static BtServiceDiscoveryDatabase& GetInstance();
00037
00038     public:
00040         virtual ~BtServiceDiscoveryDatabase();
00041
00042     protected:
00044
00046         void* AddServiceRecord(const BtSddbServiceRecord& service_record);
00047
00049
00051         void RemoveServiceRecordByBuffer(const void* service_record_buffer);
00052
00054
00056         void RemoveServiceRecordByHandle(UINT32 service_record_handle);
00057
00059
00061         BOOLEAN SetServiceRecordHandle(const void* service_record_buffer, UINT32 service_record_handle);
00062
00063     protected:
00064         class BtServiceDiscoveryDatabaseNode
00065         {
00066             public:
00068                 BtServiceDiscoveryDatabaseNode();
00069
00071                 ~BtServiceDiscoveryDatabaseNode();
00072
00074
00076                 UINT32 GetServiceRecordHandle();
00077
00079
00081                 void SetServiceRecordHandle(UINT32 service_record_handle);
00082
00084
00086                 void* GetServiceRecordBuffer();
00087
00089
00091                 void SetServiceRecordBuffer(void* service_record_buffer);
00092
00094
00096                 BtServiceDiscoveryDatabaseNode* GetNext();
00097
00099
00101                 void SetNext(BtServiceDiscoveryDatabaseNode* next);
00102
00103             private:
00105                 UINT32 m_service_record_handle;
00106
00108                 void* m_service_record_buffer;
00109
00111                 BtServiceDiscoveryDatabaseNode* m_next;
00112         };
00113
00114     private:
00116         BtServiceDiscoveryDatabase();
00117
00119
00121         BtServiceDiscoveryDatabaseNode* FindServiceDiscoveryDatabaseNodeByServiceRecordBuffer(const void* service_record_buffer);
00122
00123     private:
00125         BtServiceDiscoveryDatabaseNode* m_anchor;
00126
00127     private:
00129         static BtServiceDiscoveryDatabase m_service_discovery_database;
00130
00131     private:
00132         friend class BtGapAndSdapController;
00133 };
00134
00136 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00137 #endif  // BtServiceDiscoveryDatabase_hpp
00138
00139
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceMessage.cpp File Reference

Bluetooth/BtServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtServiceMessage.hpp"

Include dependency graph for BtServiceMessage.cpp:

Generated on Tue Jan 24 20:05:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceMessage.hpp File Reference

Bluetooth/BtServiceMessage.hpp File Reference

#include <Kernel/Message.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtService.hpp>
#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtRequestStateChangedMessage
class | BtServiceMessage

Defines

#define | Bluetooth_BtServiceMessage_hpp

Define Documentation

#define Bluetooth_BtServiceMessage_hpp

Generated on Tue Jan 24 20:05:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceMessage.hpp Source File

Bluetooth/BtServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\BtServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtServiceMessage_hpp)
00016 #define Bluetooth_BtServiceMessage_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Bluetooth/BtTypes.hpp>
00020 #include <Bluetooth/BtService.hpp>
00021 #include <Bluetooth/BtServiceMessage.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class BtServiceMessage
00030     ====================================================================== */
00031
00033 class BtServiceMessage : public Message {
00034     public:
00035         BtServiceMessage(BtService* service);
00036         virtual ~BtServiceMessage();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         void SetService(BtService* service) { m_service = service; }
00040         BtService* GetService() const { return m_service; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 10300
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         BtService* m_service;
00050
00051     };
00052
00053
00054 /*  ======================================================================
00055     Class BtRequestStateChangedMessage
00056     ====================================================================== */
00057
00059 class BtRequestStateChangedMessage : public BtServiceMessage {
00060     public:
00061         BtRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00062         virtual ~BtRequestStateChangedMessage();
00063
00064         virtual const MsgMetaData& GetMetaData() const;
00065         void SetRequestType(const BtRequestType& request_type) { m_request_type = request_type; }
00066         const BtRequestType& GetRequestType() const { return m_request_type; }
00067         void SetOldRequestState(const BtRequestState& old_request_state) { m_old_request_state = old_request_state; }
00068         const BtRequestState& GetOldRequestState() const { return m_old_request_state; }
00069         void SetNewRequestState(const BtRequestState& new_request_state) { m_new_request_state = new_request_state; }
00070         const BtRequestState& GetNewRequestState() const { return m_new_request_state; }
00071         virtual Message* Clone() const;
00072
00073         enum  {
00074             ID = 10305
00075             };
00076
00077     private:
00078         static const MsgMetaData m_meta_data;
00079         BtRequestType m_request_type;
00080         BtRequestState m_old_request_state;
00081         BtRequestState m_new_request_state;
00082
00083     };
00084
00085 #endif // Bluetooth_BtServiceMessage_hpp
00086
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceObserver.cpp File Reference

Bluetooth/BtServiceObserver.cpp File Reference

#include "PreComp.hpp"
#include "BtServiceObserver.hpp"

Include dependency graph for BtServiceObserver.cpp:

Generated on Tue Jan 24 20:05:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceObserver.hpp File Reference

Bluetooth/BtServiceObserver.hpp File Reference

#include <Bluetooth/BtEvent.hpp>

Include dependency graph for BtServiceObserver.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtServiceObserver

Defines

#define | BtServiceObserver_hpp

Define Documentation

#define BtServiceObserver_hpp

Generated on Tue Jan 24 20:05:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceObserver.hpp Source File

Bluetooth/BtServiceObserver.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtServiceObserver_hpp)
00009 #define BtServiceObserver_hpp
00012
00013 #include <Bluetooth/BtEvent.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObservableService;
00020
00023 class BtServiceObserver
00024 {
00025     public:
00027         BtServiceObserver();
00028
00030         virtual ~BtServiceObserver();
00031
00032     protected:
00034
00036         virtual void OnEvent(const BtEvent& event) = 0;
00037
00038     private:
00039         friend class BtObservableService;
00040 };
00041
00043 #endif  // BtServiceObserver_hpp
00044
00045
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceRequest.cpp File Reference

Bluetooth/BtServiceRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtServiceRequest.hpp"

Include dependency graph for BtServiceRequest.cpp:

Generated on Tue Jan 24 20:05:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceRequest.hpp File Reference

Bluetooth/BtServiceRequest.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Bluetooth/BtRequest.hpp>
#include <Bluetooth/BtService.hpp>

Include dependency graph for BtServiceRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtServiceRequest

Defines

#define | BtServiceRequest_hpp

Define Documentation

#define BtServiceRequest_hpp

Generated on Tue Jan 24 20:05:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceRequest.hpp Source File

Bluetooth/BtServiceRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtServiceRequest_hpp)
00009 #define BtServiceRequest_hpp
00012
00013 #include <Kernel/Os/Os.hpp>
00014 #include <Bluetooth/BtRequest.hpp>
00015 #include <Bluetooth/BtService.hpp>
00016
00024 class BtServiceRequest: public BtRequest
00025 {
00026     private:
00027         typedef BtRequest Base;
00028
00029     public:
00031
00032         BtServiceRequest(BtService &service);
00033
00035         virtual ~BtServiceRequest();
00036
00038
00042         const BtService& GetService() const;
00043
00045
00049         BtService& GetService();
00050
00052
00062         virtual BtRequestState ExecuteRequest();
00063
00065
00080         virtual BOOLEAN IsCancelable() const;
00081
00082     protected:
00084
00092         virtual void SetRequestState(BtRequestState request_state);
00093
00095
00103         virtual BOOLEAN Cancel();
00104
00106
00108         virtual void ExecutionCallback(BtResultCode result);
00109
00110     private:
00112         BtService& m_service;
00113
00115         Semaphore m_execution_semaphore;
00116
00117     private:
00118         friend class BtController;
00119 };
00120
00122 #endif  // BtServiceRequest_hpp
00123
00124
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceVerifyRequest.cpp File Reference

Bluetooth/BtServiceVerifyRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceListIterator.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtServiceVerifyRequest.hpp"

Include dependency graph for BtServiceVerifyRequest.cpp:

Generated on Tue Jan 24 20:05:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceVerifyRequest.hpp File Reference

Bluetooth/BtServiceVerifyRequest.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtCancelableMulticastRequest.hpp>
#include <Bluetooth/BtServiceVerifyResult.hpp>

Include dependency graph for BtServiceVerifyRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtServiceVerifyRequest
class | BtServiceVerifyRequest::BtServiceVerifyResultNode

Defines

#define | BtServiceVerifyRequest_hpp

Define Documentation

#define BtServiceVerifyRequest_hpp

Generated on Tue Jan 24 20:05:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceVerifyRequest.hpp Source File

Bluetooth/BtServiceVerifyRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtServiceVerifyRequest_hpp)
00009 #define BtServiceVerifyRequest_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtCancelableMulticastRequest.hpp>
00015 #include <Bluetooth/BtServiceVerifyResult.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020
00021 class BtGapAndSdapController;
00022
00032 class BtServiceVerifyRequest: public BtCancelableMulticastRequest
00033 {
00034     private:
00035         typedef BtCancelableMulticastRequest Base;
00036
00037     public:
00039         BtServiceVerifyRequest(const BtDeviceList& device_list);
00040
00042         virtual ~BtServiceVerifyRequest();
00043
00045
00053         virtual BtRequestType GetRequestType() const;
00054
00056
00062         BtDeviceRelation GetDeviceRelation() const;
00063
00065
00072         void SetDeviceRelation(BtDeviceRelation device_relation);
00073
00075
00081         UINT8 GetNumberOfServicesToVerify() const;
00082
00084
00090         const BtUUID* GetServicesToVerify() const;
00091
00093
00111         BOOLEAN SetServicesToVerify(const BtUUID* uuids, UINT8 number_of_uuids);
00112
00114
00121         UINT8 GetNumberOfAttributesRequested() const;
00122
00124
00131         const BtAttributeId* GetAttributesRequested() const;
00132
00134
00153         BOOLEAN SetAttributesRequested(const BtAttributeId* attribute_ids, UINT8 number_of_attribute_ids);
00154
00156
00173         const BtServiceVerifyResult* GetServiceVerifyResult(const BtDeviceAddress& device_address) const;
00174
00175     protected:
00177
00198         virtual BOOLEAN Execute();
00199
00201
00218         virtual BOOLEAN Cancel();
00219
00221
00227         virtual void RegisterMessages(void) const;
00228
00230
00236         virtual void UnregisterMessages(void) const;
00237
00239
00253         virtual BOOLEAN OnMessage(const Message& message);
00254
00256
00271         virtual void OnServiceVerifyResultReceived(const BtDeviceAddress& device_address, const WString& device_name, const BtServiceVerifyResult* service_verify_result);
00272
00273     private:
00275
00279         void ClearServiceVerifyResultList();
00280
00281     private:
00291         class BtServiceVerifyResultNode
00292         {
00293             public:
00295                 BtServiceVerifyResultNode(const BtDeviceAddress& device_address, BtServiceVerifyResult* service_verify_result = 0, BtServiceVerifyResultNode* next = 0);
00296
00298                 ~BtServiceVerifyResultNode();
00299
00301
00306                 BtServiceVerifyResultNode* GetNext();
00307
00309                 /* <em>SetNext</em> sets thelink pointer to the passed in node
00310                     that should become the successor of <em>this</em> node.
00311                     @param next A pointer to a
00312                                     <em>BtServiceVerifyResultNode</em> that
00313                                     should become <em>this</em> nodes
00314                                     successor. */
00315                 void SetNext(BtServiceVerifyResultNode* next);
00316
00318
00324                 BtDeviceAddress& GetDeviceAddress();
00325
00327
00332                 BtServiceVerifyResult* GetServiceVerifyResult();
00333
00335
00341                 void SetServiceVerifyResult(BtServiceVerifyResult* service_verify_result);
00342
00343             private:
00345                 BtServiceVerifyResultNode* m_next;
00346
00348                 BtDeviceAddress m_device_address;
00349
00351                 BtServiceVerifyResult* m_service_verify_result;
00352         };
00353
00354     private:
00356
00358         const btapi_service_search_req_t* GetApiSettings() const;
00359
00360     private:
00362         btapi_service_search_req_t m_api_service_verify;
00363
00365         BtServiceVerifyResultNode* m_anchor;
00366
00367     private:
00368         friend class BtGapAndSdapController;
00369 };
00370
00372 #endif  // BtServiceVerifyRequest_hpp
00373
00374
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceVerifyResult.cpp File Reference

Bluetooth/BtServiceVerifyResult.cpp File Reference

#include "PreComp.hpp"
#include "BtServiceVerifyResult.hpp"

Include dependency graph for BtServiceVerifyResult.cpp:

Generated on Tue Jan 24 20:05:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceVerifyResult.hpp File Reference

Bluetooth/BtServiceVerifyResult.hpp File Reference

#include <Bluetooth/BtSvrServiceRecord.hpp>

Include dependency graph for BtServiceVerifyResult.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtServiceVerifyResult

Defines

#define | BtServiceVerifyResult_hpp

Define Documentation

#define BtServiceVerifyResult_hpp

Generated on Tue Jan 24 20:05:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtServiceVerifyResult.hpp Source File

Bluetooth/BtServiceVerifyResult.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtServiceVerifyResult_hpp)
00009 #define BtServiceVerifyResult_hpp
00012
00013 #include <Bluetooth/BtSvrServiceRecord.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     forward declartion
00017     ------------------------------------------------------------------------ */
00018 class BtServiceVerifyRequest;
00019 class BtOperationSelectDeviceAndPerformServiceVerify;
00020
00039 class BtServiceVerifyResult
00040 {
00041     public:
00043         virtual ~BtServiceVerifyResult();
00044
00045     public:
00047
00060         BOOLEAN IsValid() const;
00061
00063
00067         UINT16 GetNumberOfServiceRecords() const;
00068
00070
00087         BOOLEAN GetServiceRecordAtIndex(UINT16 index, BtSvrServiceRecord& svr_service_record) const;
00088
00089     private:
00091         BtServiceVerifyResult();
00092
00094         BtServiceVerifyResult(const void* data, UINT16 data_size);
00095
00097
00103         UINT32 GetDataSize() const;
00104
00106
00110         const void* GetData() const;
00111
00113
00123         void SetData(const void* data, UINT16 data_size) const;
00124
00126
00128         BtServiceVerifyResult& operator=(const BtServiceVerifyResult& service_verify_result);
00129
00130     private:
00132         BOOLEAN m_is_valid;
00133
00135         UINT8* m_data;
00136
00138         UINT32 m_data_size;
00139
00141         UINT16 m_number_of_service_records;
00142
00143     private:
00144         friend class BtServiceVerifyRequest;
00145         friend class BtOperationSelectDeviceAndPerformServiceVerify;
00146 };
00147
00149 #endif  // BtServiceVerifyResult_hpp
00150
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSetRemoteDeviceNameRequest.cpp File Reference

Bluetooth/BtSetRemoteDeviceNameRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapRequestMessage.hpp"
#include "BtGapAndSdapController.hpp"
#include "BtSetRemoteDeviceNameRequest.hpp"

Include dependency graph for BtSetRemoteDeviceNameRequest.cpp:

Generated on Tue Jan 24 20:05:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSetRemoteDeviceNameRequest.hpp File Reference

Bluetooth/BtSetRemoteDeviceNameRequest.hpp File Reference

#include <Bluetooth/BtUncancelablePointToPointRequest.hpp>

Include dependency graph for BtSetRemoteDeviceNameRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSetRemoteDeviceNameRequest

Defines

#define | BtSetRemoteDeviceNameRequest_hpp

Define Documentation

#define BtSetRemoteDeviceNameRequest_hpp

Generated on Tue Jan 24 20:05:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSetRemoteDeviceNameRequest.hpp Source File

Bluetooth/BtSetRemoteDeviceNameRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSetRemoteDeviceNameRequest_hpp)
00009 #define BtSetRemoteDeviceNameRequest_hpp
00012
00013 #include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtGapAndSdapController;
00020
00037 class BtSetRemoteDeviceNameRequest: public BtUncancelablePointToPointRequest
00038 {
00039     private:
00040         typedef BtUncancelablePointToPointRequest Base;
00041
00042     public:
00044         BtSetRemoteDeviceNameRequest(const BtDevice& device);
00045
00047         virtual ~BtSetRemoteDeviceNameRequest();
00048
00050
00058         virtual BtRequestType GetRequestType() const;
00059
00061
00066         const WString& GetRemoteDeviceName() const;
00067
00069
00074         void SetRemoteDeviceName(const WString& remoted_device_name);
00075
00076     protected:
00078
00099         virtual BOOLEAN Execute();
00100
00102
00108         virtual void RegisterMessages() const;
00109
00111
00116         virtual void UnregisterMessages() const;
00117
00119
00133         virtual BOOLEAN OnMessage(const Message& message);
00134
00135     private:
00137
00139         const btapi_utf8_t* GetApiSettings() const;
00140
00141     private:
00143         WString m_remote_device_name;
00144
00146         btapi_utf8_t* m_utf8_remote_device_name;
00147
00148     private:
00149         friend class BtGapAndSdapController;
00150 };
00151
00153 #endif  // BtSetRemoteDeviceNameRequest_hpp
00154
00155
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSingleConnectionController.cpp File Reference

Bluetooth/BtSingleConnectionController.cpp File Reference

#include "PreComp.hpp"
#include "BtConnectRequest.hpp"
#include "BtDisconnectRequest.hpp"
#include "BtSingleConnectionController.hpp"

Include dependency graph for BtSingleConnectionController.cpp:

Generated on Tue Jan 24 20:05:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSingleConnectionController.hpp File Reference

Bluetooth/BtSingleConnectionController.hpp File Reference

#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtServiceRequest.hpp>
#include <Bluetooth/BtConnectionBasedController.hpp>

Include dependency graph for BtSingleConnectionController.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSingleConnectionController

Defines

#define | BtSingleConnectionController_hpp

Define Documentation

#define BtSingleConnectionController_hpp

Generated on Tue Jan 24 20:05:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSingleConnectionController.hpp Source File

Bluetooth/BtSingleConnectionController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSingleConnectionController_hpp)
00009 #define BtSingleConnectionController_hpp
00012
00013 #include <Bluetooth/BtDevice.hpp>
00014 #include <Bluetooth/BtServiceRequest.hpp>
00015 #include <Bluetooth/BtConnectionBasedController.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations
00019     ------------------------------------------------------------------------ */
00020
00021 class BtConnectRequest;
00022 class BtDisconnectRequest;
00023
00028 class BtSingleConnectionController: public BtConnectionBasedController
00029 {
00030     private:
00031         typedef BtConnectionBasedController Base;
00032
00033     public:
00035         BtSingleConnectionController();
00036
00038         virtual ~BtSingleConnectionController();
00039
00040     protected:
00042
00056         virtual BOOLEAN IsDeviceConnected(const BtDevice& device) const;
00057
00059
00061         const BtDevice& GetConnectedDevice() const;
00062
00064
00081         BOOLEAN SetConnectedDevice(const BtDevice& connected_device);
00082
00084
00088         void ClearConnectedDevice();
00089
00091
00106         BOOLEAN ConnectRequest(BtConnectRequest* connect_request);
00107
00109
00124         BOOLEAN DisconnectRequest(BtDisconnectRequest* disconnect_request);
00125
00127
00136         BtServiceRequest* GetExecutingRequest() const;
00137
00139
00156         BOOLEAN PrepareRequestExecution(BtServiceRequest* request);
00157
00159
00184         BtServiceRequest* CleanUpRequestExecution(BtResultCode result_code, BtRequestType request_type);
00185
00186     private:
00188         Mutex m_connected_device_mutex;
00189
00191         BtDevice m_connected_device;
00192
00194         Mutex m_executing_request_mutex;
00195
00197         BtServiceRequest* m_executing_request;
00198 };
00199
00201 #endif  // BtSingleConnectionController_hpp
00202
00203
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrDataElement.cpp File Reference

Bluetooth/BtSvrDataElement.cpp File Reference

#include "PreComp.hpp"
#include "BtUtility.hpp"
#include "BtSvrDataElement.hpp"

Include dependency graph for BtSvrDataElement.cpp:

Functions

BOOLEAN | operator!= (const BtSvrDataElement &left_value, const BtSvrDataElement &right_value)
BOOLEAN | operator== (const BtSvrDataElement &left_value, const BtSvrDataElement &right_value)
Generated on Tue Jan 24 20:06:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrDataElement.hpp File Reference

Bluetooth/BtSvrDataElement.hpp File Reference

#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtSvrDataElement.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSvrDataElement

Defines

#define | BtDatatElements_hpp

Functions

BOOLEAN | operator!= (const BtSvrDataElement &left_value, const BtSvrDataElement &right_value)
BOOLEAN | operator== (const BtSvrDataElement &left_value, const BtSvrDataElement &right_value)

Define Documentation

#define BtDatatElements_hpp

Generated on Tue Jan 24 20:06:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrDataElement.hpp Source File

Bluetooth/BtSvrDataElement.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDatatElements_hpp)
00009 #define BtDatatElements_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     forward declaration
00017     ------------------------------------------------------------------------ */
00018
00019 class BtSvrServiceAttribute;
00020
00053 class BtSvrDataElement
00054 {
00055     private:
00056         friend class BtSvrServiceAttribute;
00057
00058     public:
00060         BtSvrDataElement();
00061
00063         virtual ~BtSvrDataElement();
00064
00065     public:
00067
00080         BOOLEAN IsValid() const;
00081
00083
00089         BtDataElementType GetType() const;
00090
00092
00098         INT32 GetValueSize() const;
00099
00101
00107         const void* GetValuePointer() const;
00108
00110
00115         UINT16 GetNumberOfDataElements() const;
00116
00118
00136         BOOLEAN GetDataElementAtIndex(UINT16 index, BtSvrDataElement& svr_data_element) const;
00137
00138     public:
00140
00142         UINT32 AsUnsigned() const;
00143
00145
00147         INT32 AsSigned() const;
00148
00150
00152         BtUUID AsUuid() const;
00153
00155
00157         String AsString() const;
00158
00160
00162         WString AsWString() const;
00163
00165
00167         BOOLEAN AsBoolean() const;
00168
00169     private:
00171
00173         friend BOOLEAN operator==(const BtSvrDataElement& left_value, const BtSvrDataElement& right_value);
00174
00176
00178         friend BOOLEAN operator!=(const BtSvrDataElement& left_value, const BtSvrDataElement& right_value);
00179
00180     private:
00182
00190         BtSvrDataElement(const btapi_de_t& data_element);
00191
00193
00202         BtSvrDataElement& operator=(const BtSvrDataElement& svr_data_element);
00203
00204     private:
00206
00208         BOOLEAN IsEqual(const BtSvrDataElement& right_value) const;
00209
00211
00213         int CompareUnsigned(const BtSvrDataElement& right_value) const;
00214
00216
00218         int CompareSigned(const BtSvrDataElement& right_value) const;
00219
00221
00223         BOOLEAN CompareUuid(const BtSvrDataElement& right_value) const;
00224
00225     private:
00227         BOOLEAN m_is_valid;
00228
00230         btapi_de_t m_data_element;
00231
00233         UINT16 m_number_of_data_elements;
00234 };
00235
00237
00239 BOOLEAN operator==(const BtSvrDataElement& left_value, const BtSvrDataElement& right_value);
00240
00242
00244 BOOLEAN operator!=(const BtSvrDataElement& left_value, const BtSvrDataElement& right_value);
00245
00247 #endif  // BtDatatElements_hpp
00248
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrServiceAttribute.cpp File Reference

Bluetooth/BtSvrServiceAttribute.cpp File Reference

#include "PreComp.hpp"
#include "BtSvrServiceAttribute.hpp"

Include dependency graph for BtSvrServiceAttribute.cpp:

Generated on Tue Jan 24 20:06:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrServiceAttribute.hpp File Reference

Bluetooth/BtSvrServiceAttribute.hpp File Reference

#include <stack/extensions.h>
#include <Bluetooth/BtSvrDataElement.hpp>

Include dependency graph for BtSvrServiceAttribute.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSvrServiceAttribute

Defines

#define | BtSvrServiceAttribute_hpp

Define Documentation

#define BtSvrServiceAttribute_hpp

Generated on Tue Jan 24 20:06:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrServiceAttribute.hpp Source File

Bluetooth/BtSvrServiceAttribute.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSvrServiceAttribute_hpp)
00009 #define BtSvrServiceAttribute_hpp
00012
00013 #include <stack/extensions.h>
00014 #include <Bluetooth/BtSvrDataElement.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     forward declartion
00018     ------------------------------------------------------------------------ */
00019 class BtSvrServiceRecord;
00020
00040 class BtSvrServiceAttribute
00041 {
00042     private:
00043         friend class BtSvrServiceRecord;
00044
00045     public:
00047         BtSvrServiceAttribute();
00048
00050         virtual ~BtSvrServiceAttribute();
00051
00052     public:
00054
00067         BOOLEAN IsValid() const;
00068
00070
00077         UINT16 GetAttributeId() const;
00078
00080
00094         BOOLEAN GetAttributeValue(BtSvrDataElement& svr_data_element) const;
00095
00096     private:
00098
00106         BtSvrServiceAttribute(const btapi_attr_t& service_attribute);
00107
00109
00119         BtSvrServiceAttribute& operator=(const BtSvrServiceAttribute& srv_service_attribute);
00120
00121     private:
00123         BOOLEAN m_is_valid;
00124
00126         btapi_attr_t m_service_attribute;
00127 };
00128
00130 #endif  // BtSvrServiceAttribute_hpp
00131
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrServiceRecord.cpp File Reference

Bluetooth/BtSvrServiceRecord.cpp File Reference

#include "PreComp.hpp"
#include "BtSvrServiceRecord.hpp"

Include dependency graph for BtSvrServiceRecord.cpp:

Generated on Tue Jan 24 20:06:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrServiceRecord.hpp File Reference

Bluetooth/BtSvrServiceRecord.hpp File Reference

#include <stack/extensions.h>
#include <Bluetooth/BtSvrServiceAttribute.hpp>

Include dependency graph for BtSvrServiceRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtSvrServiceRecord

Defines

#define | BtSvrServiceRecord_hpp

Define Documentation

#define BtSvrServiceRecord_hpp

Generated on Tue Jan 24 20:06:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtSvrServiceRecord.hpp Source File

Bluetooth/BtSvrServiceRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSvrServiceRecord_hpp)
00009 #define BtSvrServiceRecord_hpp
00012
00013 #include <stack/extensions.h>
00014 #include <Bluetooth/BtSvrServiceAttribute.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     forward declaration
00018     ------------------------------------------------------------------------ */
00019
00020 class BtServiceVerifyResult;
00021
00037 class BtSvrServiceRecord
00038 {
00039     private:
00040         friend class BtServiceVerifyResult;
00041
00042     public:
00044         BtSvrServiceRecord();
00045
00047         virtual ~BtSvrServiceRecord();
00048
00049     public:
00051
00067         BOOLEAN IsValid() const;
00068
00070
00074         UINT16 GetNumberOfServiceAttributes() const;
00075
00077
00095         BOOLEAN GetServiceAttributeAtIndex(UINT16 index, BtSvrServiceAttribute& svr_service_attribute) const;
00096
00098
00115         BOOLEAN GetServiceAttributeById(UINT16 id, BtSvrServiceAttribute& svr_service_attribute) const;
00116
00117     private:
00119
00126         BtSvrServiceRecord(const btapi_de_t& service_record);
00127
00129
00139         BtSvrServiceRecord& operator=(const BtSvrServiceRecord& svr_service_record);
00140
00141     private:
00143         BOOLEAN m_is_valid;
00144
00146         btapi_de_t m_service_record;
00147
00149         UINT16 m_number_of_service_attributes;
00150 };
00151
00153 #endif  // BtSvrServiceRecord_hpp
00154
Generated on Tue Jan 24 14:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtTemplates.cpp File Reference

Bluetooth/BtTemplates.cpp File Reference

#include "Bluetooth/PreComp.hpp"
#include <Bluetooth/BtOperationBase.hpp>

Include dependency graph for BtTemplates.cpp:

Generated on Tue Jan 24 20:06:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtTransport.cpp File Reference

Bluetooth/BtTransport.cpp File Reference

#include "PreComp.hpp"
#include "BtGapAndSdapController.hpp"

Include dependency graph for BtTransport.cpp:

Generated on Tue Jan 24 20:06:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtTransport.hpp File Reference

Bluetooth/BtTransport.hpp File Reference

#include <Devices/AbstractTransport.hpp>

Include dependency graph for BtTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtTransport

Defines

#define | BtTransport_hpp

Define Documentation

#define BtTransport_hpp

Generated on Tue Jan 24 20:06:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtTransport.hpp Source File

Bluetooth/BtTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtTransport_hpp)
00009 #define BtTransport_hpp
00012
00013 #include <Devices/AbstractTransport.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtGapAndSdapController;
00020
00023 class BtTransport: public AbstractTransport
00024 {
00025     private:
00026         typedef AbstractTransport Base;
00027
00028     public:
00030
00035         static BtTransport& GetInstance();
00036
00037     public:
00039         virtual ~BtTransport();
00040
00042
00044         virtual void Enable();
00045
00047
00049         virtual AvState GetAvState() const;
00050
00051     private:
00053         BtTransport(const WCHAR* mmi_name);
00054
00055     private:
00057         static BtTransport m_transport;
00058
00059     private:
00060         friend class BtGapAndSdapController;
00061 };
00062
00064 #endif  // BtTransport_hpp
00065
00066
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtTypes.hpp File Reference

Bluetooth/BtTypes.hpp File Reference

#include <stack/extensions.h>
#include <Kernel/Types.hpp>

Include dependency graph for BtTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | BtAttributeId
struct | BtChipBmscr
struct | BtChipBmu
union | BtChipVersion
struct | BtUUID

Defines

#define | Bt_Types_hpp

Enumerations

enum | BtChipType { BtCtBmscr = BTAPI_BT_HW_BMSCR, BtCtBmu = BTAPI_BT_HW_BMU }
Hardware types. More...
enum | BtConnectableMode { BtCmNonConnectable = BTAPI_NON_CONNECTABLE, BtCmConnectable = BTAPI_CONNECTABLE }
Enumeration for modes of connectability. More...
enum BtDataElementType {
BtDetNil = BTAPI_NIL, BtDetUint = BTAPI_SDAP_UINT, BtDetSint = BTAPI_SDAP_SINT, BtDetUuid = BTAPI_SDAP_UUID,
BtDetString = BTAPI_SDAP_STRING, BtDetBool = BTAPI_SDAP_BOOL, BtDetSequence = BTAPI_SDAP_DATA_SEQ, BtDetEnumeration = BTAPI_SDAP_DATA_ALT,
BtDetUrl = BTAPI_SDAP_URL
}
Enumeration of possible tyes of data elements. More...
enum | BtDeviceRelation { BtDrNone = BTAPI_NO_RELATION, BtDrTrusted = BTAPI_TRUSTED, BtDrConnected = BTAPI_CONNECTED, BtDrTrustedAndConnected = BTAPI_TRUSTED_AND_CONNECTED }
enum | BtDeviceState { BtDsKnown, BtDsPaired, BtDsTrusted, BtDsConnected }
enum | BtDiscoverableMode { BtDmNonDiscoverable = BTAPI_NON_DISCOVERABLE, BtDmGeneralDiscoverable = BTAPI_GENERAL_DISCOVERABLE, BtDmLimitedDiscoverable = BTAPI_LIMITED_DISCOVERABLE }
Enumeration for modes of discoverability. More...
enum | BtInquiryAccessCode { BtIacGlobal = BTAPI_GIAC, BtIacLocal = BTAPI_LIAC }
Types for inquiry settings. More...
enum | BtOperationType { BtOpPerformServiceVerify, BtOpSelectDevice, BtOpSelectDeviceAndPerformServiceVerify }
enum | BtPairableMode { BtPmNonPairable = BTAPI_NON_PAIRABLE, BtPmPairable = BTAPI_PAIRABLE }
Enumeration for modes of pairability. More...
enum BtProfile {
BtProfileUnknown = -1, BtProfileGapAndSdap, BtProfileDun = BTAPI_DUN, BtProfileHs = BTAPI_HS,
BtProfileHf = BTAPI_HF, BtProfileOpp = BTAPI_OPP, BtProfileFtp = BTAPI_FTP, BtProfileObex = BTAPI_OBEX,
BtProfileSap = BTAPI_SAP, BtProfileFax = BTAPI_FAX, BtProfileA2dp = BTAPI_A2DP, BtProfileAad = BtProfileA2dp,
BtProfilePap = BTAPI_PAP, BtProfileAvrcp = BTAPI_AVRCP, BtProfileBip = BTAPI_BIP, BtProfileBpp = BTAPI_BPP
}
enum BtRequestState {
BtRqsUnknown = -1, BtRqsInitialized, BtRqsAccepted, BtRqsRejected,
BtRqsAcceptedCancelation, BtRqsExecuting, BtRqsIgnored, BtRqsExecutingCancelation,
BtRqsFinishedOk, BtRqsFinishedFailure
}
Current state of execution for BtRequest classes. More...
enum BtRequestType {
BtRqtUnknown, BtRqtDevicePair, BtRqtDeviceUnpair, BtRqtDeviceTrust,
BtRqtDeviceUntrust, BtRqtSetRemoteDeviceName, BtRqtQuerySupportedProfiles, BtRqtSendPasskey,
BtRqtRespondAuthorization, BtRqtDeviceSearch, BtRqtServiceVerify, BtRqtSddbRegisterServiceRecord,
BtRqtSddbUnregisterServiceRecord, BtRqtDunDisconnect, BtRqtFaxDisconnect, BtRqtHsConnect,
BtRqtHsDisconnect, BtRqtHsRing, BtRqtHsStopRing, BtRqtHsHangUp,
BtRqtHsTransferAudioToPhone, BtRqtHsTransferAudioToAccessory, BtRqtHsSetMicrophoneGain, BtRqtHsSetSpeakerGain,
BtRqtHfConnect, BtRqtHfDisconnect, BtRqtHfTransferAudioToPhone, BtRqtHfTransferAudioToAccessory,
BtRqtHfSetMicrophoneGain, BtRqtHfSetSpeakerGain, BtRqtObexRegisterServer, BtRqtObexUnregisterServer,
BtRqtObexSendResponse, BtRqtObexRegisterClient, BtRqtObexUnregisterClient, BtRqtObexConnect,
BtRqtObexDisconnect, BtRqtObexSetPath, BtRqtObexGet, BtRqtObexPut,
BtRqtObexAbort, BtRqtAvrcpConnect, BtRqtAvrcpConnectRsp, BtRqtAvrcpDisconnect,
BtRqtAvrcpRegister, BtRqtAvrcpDeRegister, BtRqtAvrcpUnitInfo, BtRqtAvrcpPanelPassThrough,
BtRqtAvrcpRawFrame, BtRqtAvrcpSubunitInfo, BtRqtAvrcpPanelPassThroughRsp, BtRqtAvrcpRawFrameRsp,
BtRqtBppSndFilePushReq, BtRqtBppSndGetRefObjRsp, BtRqtBppSndAbortReq, BtRqtBppSndAuthenticationReqRes,
BtRqtBipConnect, BtRqtBipDisconnect, BtRqtBipAbort, BtRqtBipPutImage,
BtRqtBipPutLinkedThumbnail, BtRqtBipPutLinkedAttachment, BtRqtBipGetImagesList, BtRqtBipGetImage,
BtRqtBipGetLinkedThumbnail, BtRqtBipGetLinkedAttachment, BtRqtBipGetImageProperties, BtRqtBipDeleteImage,
BtRqtBipGetImagingCapabilities
}
Quasi RTTI for BtRequest classes. More...
enum BtResultCode {
BtRcAccepted = 2, BtRcPending = 3, BtRcOk = 0, BtRcRejected = -1,
BtRcIgnored = -2, BtRcError = -3, BtRcUnknown = -128
}
Result codes for Bluetooth stack operations. More...
enum BtSecuritySettings {
BtSesNoSecurity = BTAPI_NO_SECURITY, BtSesAuthentication = BTAPI_AUTHENTICATION, BtSesAuthenticationEncryption = BTAPI_AUTHENTICATION_ENCRYPTION, BtSesAuthenticationAuthorization = BTAPI_AUTHENTICATION_AUTHORISATION,
BtSesAuthenticationEncryptionAuthorization = BTAPI_AUTHENTICATION_ENCRYPTION_AUTHORISATION, BtSesAlwaysAuthenticatedTrustedDevices = BTAPI_ALWAYS_AUTHENTICATED_TRUSTED_DEVICES, BtSesAuthorizationAlwaysAuthenticatedTrustedDevices = BTAPI_AUTHORISATION_ALWAYS_AUTHENTICATED_TRUSTED_DEVICES, BtSesAuthorization = BTAPI_AUTHORISATION
}
enum BtStackState {
BtSsNotInitialized = BTAPI_STACK_NOT_INITIALIZED, BtSsInitialized = BTAPI_STACK_INITIALIZED, BtSsOn = BTAPI_STACK_ON, BtSsOff = BTAPI_STACK_OFF,
BtSsError = BTAPI_STACK_ERROR, BtSsNoState
}
Current state of Bluetooth stack. More...
enum | BtUuidType { BtUuid16 = BTAPI_UUID_16, BtUuid32 = BTAPI_UUID_32, BtUuid128 = BTAPI_UUID_128 }
Types for UUID witdthes. More...

Define Documentation

#define Bt_Types_hpp

Generated on Tue Jan 24 19:57:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtTypes.hpp Source File

Bluetooth/BtTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bt_Types_hpp)
00009 #define Bt_Types_hpp
00012
00013 #include <stack/extensions.h>
00014 #include <Kernel/Types.hpp>
00015
00016 /*****************************************************************************
00017  * Bluetooth general definitions                                             *
00018  *****************************************************************************
00019
00020  *---------------------------------------------------------------------------*
00021  * Bluetooth general constants                                               *
00022  *---------------------------------------------------------------------------*/
00023
00024 /*---------------------------------------------------------------------------*
00025  * Bluetooth general enums                                                   *
00026  *---------------------------------------------------------------------------*/
00027
00029
00038 typedef enum {
00040     BtRcAccepted =  2,
00042     BtRcPending  =  3,
00044     BtRcOk       =  0,
00046     BtRcRejected = -1,
00048     BtRcIgnored  = -2,
00050     BtRcError    = -3,
00052     BtRcUnknown  = -128
00053 } BtResultCode;
00054
00056
00060 typedef enum {
00062     BtRqsUnknown = -1,
00064     BtRqsInitialized,
00066     BtRqsAccepted,
00068     BtRqsRejected,
00070     BtRqsAcceptedCancelation,
00072     BtRqsExecuting,
00074     BtRqsIgnored,
00076     BtRqsExecutingCancelation,
00078     BtRqsFinishedOk,
00080     BtRqsFinishedFailure
00081 } BtRequestState;
00082
00084
00090 typedef enum {
00092     BtRqtUnknown,
00094     BtRqtDevicePair,
00096     BtRqtDeviceUnpair,
00098     BtRqtDeviceTrust,
00100     BtRqtDeviceUntrust,
00102     BtRqtSetRemoteDeviceName,
00104     BtRqtQuerySupportedProfiles,
00106     BtRqtSendPasskey,
00108     BtRqtRespondAuthorization,
00110     BtRqtDeviceSearch,
00112     BtRqtServiceVerify,
00114     BtRqtSddbRegisterServiceRecord,
00116     BtRqtSddbUnregisterServiceRecord,
00118     BtRqtDunDisconnect,
00120     BtRqtFaxDisconnect,
00122     BtRqtHsConnect,
00124     BtRqtHsDisconnect,
00126     BtRqtHsRing,
00128     BtRqtHsStopRing,
00130     BtRqtHsHangUp,
00132     BtRqtHsTransferAudioToPhone,
00134     BtRqtHsTransferAudioToAccessory,
00136     BtRqtHsSetMicrophoneGain,
00138     BtRqtHsSetSpeakerGain,
00140     BtRqtHfConnect,
00142     BtRqtHfDisconnect,
00144     BtRqtHfTransferAudioToPhone,
00146     BtRqtHfTransferAudioToAccessory,
00148     BtRqtHfSetMicrophoneGain,
00150     BtRqtHfSetSpeakerGain,
00152     BtRqtObexRegisterServer,
00154     BtRqtObexUnregisterServer,
00156     BtRqtObexSendResponse,
00158     BtRqtObexRegisterClient,
00160     BtRqtObexUnregisterClient,
00162     BtRqtObexConnect,
00164     BtRqtObexDisconnect,
00166     BtRqtObexSetPath,
00168     BtRqtObexGet,
00170     BtRqtObexPut,
00172     BtRqtObexAbort,
00174     BtRqtAvrcpConnect,
00176     BtRqtAvrcpConnectRsp,
00178     BtRqtAvrcpDisconnect,
00180     BtRqtAvrcpRegister,
00182     BtRqtAvrcpDeRegister,
00184     BtRqtAvrcpUnitInfo,
00186     BtRqtAvrcpPanelPassThrough,
00188     BtRqtAvrcpRawFrame,
00190     BtRqtAvrcpSubunitInfo,
00192     BtRqtAvrcpPanelPassThroughRsp,
00194     BtRqtAvrcpRawFrameRsp,
00196     BtRqtBppSndFilePushReq,
00198     BtRqtBppSndGetRefObjRsp,
00200     BtRqtBppSndAbortReq,
00202     BtRqtBppSndAuthenticationReqRes,
00204     BtRqtBipConnect,
00206     BtRqtBipDisconnect,
00208     BtRqtBipAbort,
00210     BtRqtBipPutImage,
00212     BtRqtBipPutLinkedThumbnail,
00214     BtRqtBipPutLinkedAttachment,
00216     BtRqtBipGetImagesList,
00218     BtRqtBipGetImage,
00220     BtRqtBipGetLinkedThumbnail,
00222     BtRqtBipGetLinkedAttachment,
00224     BtRqtBipGetImageProperties,
00226     BtRqtBipDeleteImage,
00228     BtRqtBipGetImagingCapabilities
00229 } BtRequestType;
00230
00232
00234 typedef enum {
00236     BtOpPerformServiceVerify,
00238     BtOpSelectDevice,
00240     BtOpSelectDeviceAndPerformServiceVerify
00241 } BtOperationType;
00242
00244
00246 typedef enum {
00248     BtDsKnown,
00250     BtDsPaired,
00252     BtDsTrusted,
00254     BtDsConnected
00255 } BtDeviceState;
00256
00258
00260 typedef enum {
00262     BtProfileUnknown = -1,
00264     BtProfileGapAndSdap,
00266     BtProfileDun     = BTAPI_DUN,
00268     BtProfileHs      = BTAPI_HS,
00270     BtProfileHf      = BTAPI_HF,
00272     BtProfileOpp     = BTAPI_OPP,
00274     BtProfileFtp     = BTAPI_FTP,
00276     BtProfileObex    = BTAPI_OBEX,
00278     BtProfileSap     = BTAPI_SAP,
00280     BtProfileFax     = BTAPI_FAX,
00282     BtProfileA2dp    = BTAPI_A2DP,
00283     BtProfileAad     = BtProfileA2dp,
00285     BtProfilePap     = BTAPI_PAP,
00287     BtProfileAvrcp   = BTAPI_AVRCP,
00289     BtProfileBip     = BTAPI_BIP,
00291     BtProfileBpp     = BTAPI_BPP
00292
00293 } BtProfile;
00294
00296
00298 typedef enum {
00300     BtSesNoSecurity                                     = BTAPI_NO_SECURITY,
00302     BtSesAuthentication                                 = BTAPI_AUTHENTICATION,
00304     BtSesAuthenticationEncryption                       = BTAPI_AUTHENTICATION_ENCRYPTION,
00306     BtSesAuthenticationAuthorization                    = BTAPI_AUTHENTICATION_AUTHORISATION,
00308     BtSesAuthenticationEncryptionAuthorization          = BTAPI_AUTHENTICATION_ENCRYPTION_AUTHORISATION,
00310     BtSesAlwaysAuthenticatedTrustedDevices              = BTAPI_ALWAYS_AUTHENTICATED_TRUSTED_DEVICES,
00312     BtSesAuthorizationAlwaysAuthenticatedTrustedDevices = BTAPI_AUTHORISATION_ALWAYS_AUTHENTICATED_TRUSTED_DEVICES,
00314     BtSesAuthorization                                  = BTAPI_AUTHORISATION
00315 } BtSecuritySettings;
00316
00317 /*---------------------------------------------------------------------------*
00318  * Bluetooth general types                                                   *
00319  *---------------------------------------------------------------------------*/
00320
00321 /*****************************************************************************
00322  * GAP & SDAP definitions                                                    *
00323  *****************************************************************************
00324
00325  *---------------------------------------------------------------------------*
00326  * GAP & SDAP constants                                                      *
00327  *---------------------------------------------------------------------------*/
00328
00329 /*---------------------------------------------------------------------------*
00330  * GAP & SDAP enums                                                          *
00331  *---------------------------------------------------------------------------*/
00332
00334
00336 typedef enum  {
00338     BtCtBmscr = BTAPI_BT_HW_BMSCR,
00340     BtCtBmu = BTAPI_BT_HW_BMU
00341 } BtChipType;
00342
00344
00346 typedef enum {
00348     BtSsNotInitialized = BTAPI_STACK_NOT_INITIALIZED,
00350     BtSsInitialized = BTAPI_STACK_INITIALIZED,
00352     BtSsOn = BTAPI_STACK_ON,
00354     BtSsOff = BTAPI_STACK_OFF,
00356     BtSsError = BTAPI_STACK_ERROR,
00358     BtSsNoState
00359 } BtStackState;
00360
00362
00364 typedef enum {
00366     BtDmNonDiscoverable     = BTAPI_NON_DISCOVERABLE,
00368     BtDmGeneralDiscoverable = BTAPI_GENERAL_DISCOVERABLE,
00370     BtDmLimitedDiscoverable = BTAPI_LIMITED_DISCOVERABLE
00371 } BtDiscoverableMode;
00372
00374
00376 typedef enum {
00378     BtPmNonPairable = BTAPI_NON_PAIRABLE,
00380     BtPmPairable    = BTAPI_PAIRABLE
00381 } BtPairableMode;
00382
00384
00386 typedef enum {
00388     BtCmNonConnectable = BTAPI_NON_CONNECTABLE,
00390     BtCmConnectable    = BTAPI_CONNECTABLE
00391 } BtConnectableMode;
00392
00394
00396 typedef enum {
00398     BtIacGlobal = BTAPI_GIAC,
00400     BtIacLocal  = BTAPI_LIAC
00401 } BtInquiryAccessCode;
00402
00404
00406 typedef enum {
00408     BtDrNone                  = BTAPI_NO_RELATION,
00410     BtDrTrusted               = BTAPI_TRUSTED,
00412     BtDrConnected             = BTAPI_CONNECTED,
00414     BtDrTrustedAndConnected   = BTAPI_TRUSTED_AND_CONNECTED
00415 } BtDeviceRelation;
00416
00418
00420 typedef enum {
00422     BtUuid16  = BTAPI_UUID_16,
00424     BtUuid32  = BTAPI_UUID_32,
00426     BtUuid128 = BTAPI_UUID_128
00427 } BtUuidType;
00428
00430
00432 typedef enum {
00434     BtDetNil         = BTAPI_NIL,
00436     BtDetUint        = BTAPI_SDAP_UINT,
00438     BtDetSint        = BTAPI_SDAP_SINT,
00440     BtDetUuid        = BTAPI_SDAP_UUID,
00442     BtDetString      = BTAPI_SDAP_STRING,
00444     BtDetBool        = BTAPI_SDAP_BOOL,
00446     BtDetSequence    = BTAPI_SDAP_DATA_SEQ,
00448     BtDetEnumeration = BTAPI_SDAP_DATA_ALT,
00450     BtDetUrl         = BTAPI_SDAP_URL
00451 } BtDataElementType;
00452
00453 /*---------------------------------------------------------------------------*
00454  * GAP & SDAP types                                                          *
00455  *---------------------------------------------------------------------------*/
00456
00458
00460 typedef struct {
00462     BtChipType chip_type;
00464     UINT16 lm_fw_vers;
00466     UINT16 lc_fw_vers;
00467 } BtChipBmscr;
00468
00470
00472 typedef struct {
00474     BtChipType chip_type;
00476     UINT8 hw_platform;
00478     UINT8 hw_variant;
00480     UINT8 hw_revision;
00482     UINT8 fw_varinat;
00484     UINT8 fw_revision;
00486     UINT8 fw_build[3];
00488     UINT8 fw_patch;
00489 } BtChipBmu;
00490
00492
00494 typedef union {
00496     BtChipType chip_type;
00498     BtChipBmscr bmscr;
00500     BtChipBmu bmu;
00501 } BtChipVersion;
00502
00504
00506 typedef struct {
00508     UINT8      uuid[16];
00510     BtUuidType type;
00511 } BtUUID;
00512
00514
00516 typedef struct {
00518     union {
00520         UINT16 id;
00522         UINT16 range[2];
00523     }   attribute;
00525     BOOLEAN attribute_range;
00526 } BtAttributeId;
00527
00529 #endif // Bt_Types_hpp
00530
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUncancelablePointToPointRequest.cpp File Reference

Bluetooth/BtUncancelablePointToPointRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtUncancelablePointToPointRequest.hpp"

Include dependency graph for BtUncancelablePointToPointRequest.cpp:

Generated on Tue Jan 24 20:06:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUncancelablePointToPointRequest.hpp File Reference

Bluetooth/BtUncancelablePointToPointRequest.hpp File Reference

#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtUncancelableRequest.hpp>

Include dependency graph for BtUncancelablePointToPointRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtUncancelablePointToPointRequest

Defines

#define | BtUncancelablePointToPointRequest_hpp

Define Documentation

#define BtUncancelablePointToPointRequest_hpp

Generated on Tue Jan 24 20:06:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUncancelablePointToPointRequest.hpp Source File

Bluetooth/BtUncancelablePointToPointRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtUncancelablePointToPointRequest_hpp)
00009 #define BtUncancelablePointToPointRequest_hpp
00012
00013 #include <Bluetooth/BtDevice.hpp>
00014 #include <Bluetooth/BtUncancelableRequest.hpp>
00015
00025 class BtUncancelablePointToPointRequest: public BtUncancelableRequest
00026 {
00027     private:
00028         typedef BtUncancelableRequest Base;
00029
00030     public:
00032         BtUncancelablePointToPointRequest(const BtDevice& device);
00033
00035         virtual ~BtUncancelablePointToPointRequest();
00036
00038
00042         BtDevice& GetDevice();
00043
00045
00049         const BtDevice& GetDevice() const;
00050
00052
00059         void SetDevice(const BtDevice& device);
00060
00061     private:
00063         BtDevice m_device;
00064 };
00065
00067 #endif  // BtUncancelablePointToPointRequest_hpp
00068
00069
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUncancelableRequest.cpp File Reference

Bluetooth/BtUncancelableRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtUncancelableRequest.hpp"

Include dependency graph for BtUncancelableRequest.cpp:

Generated on Tue Jan 24 20:06:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUncancelableRequest.hpp File Reference

Bluetooth/BtUncancelableRequest.hpp File Reference

#include <Bluetooth/BtLocalRequest.hpp>

Include dependency graph for BtUncancelableRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtUncancelableRequest

Defines

#define | BtUncancelableRequest_hpp

Define Documentation

#define BtUncancelableRequest_hpp

Generated on Tue Jan 24 20:06:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUncancelableRequest.hpp Source File

Bluetooth/BtUncancelableRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtUncancelableRequest_hpp)
00009 #define BtUncancelableRequest_hpp
00012
00013 #include <Bluetooth/BtLocalRequest.hpp>
00014
00022 class BtUncancelableRequest: public BtLocalRequest
00023 {
00024     private:
00025         typedef BtLocalRequest Base;
00026
00027     public:
00029         BtUncancelableRequest();
00030
00032         virtual ~BtUncancelableRequest();
00033
00035
00048         virtual BOOLEAN IsCancelable() const;
00049
00050     protected:
00052
00060         virtual BOOLEAN Cancel();
00061 };
00062
00064 #endif  // BtUncancelableRequest_hpp
00065
00066
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUtility.cpp File Reference

Bluetooth/BtUtility.cpp File Reference

#include "PreComp.hpp"
#include "BtUtility.hpp"

Include dependency graph for BtUtility.cpp:

Functions

BOOLEAN | ConvertUtf8ToWString (const CHAR *utf_char_pointer, WString &w_string)
Convert UTF-8 character array to WString object.
void | ExtendUuidTo128Bit (const BtUUID &uuid_base, BtUUID &uuid_128)
BOOLEAN | operator!= (const BtUUID &left_value, const BtUUID &right_value)
BOOLEAN | operator== (const BtUUID &left_value, const BtUUID &right_value)
BtProfile | ToProfile (btapi_profile_t profile)
Convert stack profile type to APOXI profile type.
BtResultCode | ToResultCode (btapi_result_t result)
Convert stack result code to APOXI result code.
Generated on Tue Jan 24 20:06:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUtility.hpp File Reference

Bluetooth/BtUtility.hpp File Reference

#include <stack/extensions.h>
#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtUtility.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | BtUtil_hpp

Functions

BOOLEAN | ConvertUtf8ToWString (const CHAR *utf_char_pointer, WString &w_string)
Convert UTF-8 character array to WString object.
void | ExtendUuidTo128Bit (const BtUUID &uuid_base, BtUUID &uuid_128)
BOOLEAN | operator!= (const BtUUID &left_value, const BtUUID &right_value)
BOOLEAN | operator== (const BtUUID &left_value, const BtUUID &right_value)
BtProfile | ToProfile (btapi_profile_t profile)
Convert stack profile type to APOXI profile type.
BtResultCode | ToResultCode (btapi_result_t result)
Convert stack result code to APOXI result code.

Define Documentation

#define BtUtil_hpp

Generated on Tue Jan 24 20:06:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BtUtility.hpp Source File

Bluetooth/BtUtility.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtUtil_hpp)
00009 #define BtUtil_hpp
00012
00013 #include <stack/extensions.h>
00014 #include <Bluetooth/BtTypes.hpp>
00015
00016 /*  ************************************************************************
00017     BTAPI -> APOXI conversion functions
00018     ************************************************************************ */
00019
00021
00029 BtResultCode ToResultCode(btapi_result_t result);
00030
00032
00039 BtProfile ToProfile(btapi_profile_t profile);
00040
00041 /*  ************************************************************************
00042     UTF-8 utility functions
00043     ************************************************************************ */
00044
00046
00063 BOOLEAN ConvertUtf8ToWString(const CHAR* utf_char_pointer, WString& w_string);
00064
00065 /*  ************************************************************************
00066     fuctions for dealing with BtXXX - structures
00067     ************************************************************************ */
00068
00070
00072 void ExtendUuidTo128Bit(const BtUUID& uuid_base, BtUUID& uuid_128);
00073
00075
00077 BOOLEAN operator==(const BtUUID& left_value, const BtUUID& right_value);
00078
00080
00082 BOOLEAN operator!=(const BtUUID& left_value, const BtUUID& right_value);
00083
00084 #ifdef _DEBUG
00085 /*  ************************************************************************
00086     Debugging functions
00087     ************************************************************************ */
00088
00090 /***
00091 */
00092 const CHAR* BooleanAsString(BOOLEAN boolean);
00093
00095 /***
00096 */
00097 const CHAR* BtapiResultTAsString(btapi_result_t result);
00098
00100 /***
00101 */
00102 const CHAR* BtResultAsString(BtResultCode result);
00103
00105
00107 const CHAR* BtRequestStateAsString(BtRequestState state);
00108 #endif /* _DEBUG */
00109
00111 #endif
00112
00113
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/Lib.hpp File Reference

Bluetooth/Lib.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtConstants.hpp>
#include <Bluetooth/BtApplicationMessage.hpp>
#include <Bluetooth/BtRequestMessage.hpp>
#include <Bluetooth/BtRequestOperationMessage.hpp>
#include <Bluetooth/BtServiceMessage.hpp>
#include <Bluetooth/BtEvent.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>
#include <Bluetooth/BtDeviceAndServiceClass.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtDeviceFilter.hpp>
#include <Bluetooth/BtDeviceListIterator.hpp>
#include <Bluetooth/BtDeviceListReverseIterator.hpp>
#include <Bluetooth/BtDeviceList.hpp>
#include <Bluetooth/BtOperationBase.hpp>
#include <Bluetooth/BtRequest.hpp>
#include <Bluetooth/BtCancelableRequest.hpp>
#include <Bluetooth/BtCancelableBroadcastRequest.hpp>
#include <Bluetooth/BtCancelableMulticastRequest.hpp>
#include <Bluetooth/BtUncancelableRequest.hpp>
#include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
#include <Bluetooth/BtRequestRespondRequest.hpp>
#include <Bluetooth/BtService.hpp>
#include <Bluetooth/BtServiceRequest.hpp>
#include <Bluetooth/BtConnectRequest.hpp>
#include <Bluetooth/BtDisconnectRequest.hpp>
#include <Bluetooth/BtAudioAccessoryService.hpp>
#include <Bluetooth/BtObservableService.hpp>
#include <Bluetooth/BtServiceObserver.hpp>
#include <Bluetooth/BtController.hpp>
#include <Bluetooth/BtConnectionBasedController.hpp>
#include <Bluetooth/BtSingleConnectionController.hpp>
#include <Bluetooth/BtMultiConnectionController.hpp>
#include <Bluetooth/BtUtility.hpp>
#include <Bluetooth/BtGapAndSdapApplicationMessage.hpp>
#include <Bluetooth/BtGapAndSdapRequestMessage.hpp>
#include <Bluetooth/BtGapAndSdapController.hpp>
#include <Bluetooth/BtTransport.hpp>
#include <Bluetooth/BtLocalSettings.hpp>
#include <Bluetooth/BtLocalRequest.hpp>
#include <Bluetooth/BtOperationSelectDevice.hpp>
#include <Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp>
#include <Bluetooth/BtDevicePairRequest.hpp>
#include <Bluetooth/BtDeviceUnpairRequest.hpp>
#include <Bluetooth/BtDeviceTrustRequest.hpp>
#include <Bluetooth/BtDeviceUntrustRequest.hpp>
#include <Bluetooth/BtSetRemoteDeviceNameRequest.hpp>
#include <Bluetooth/BtQuerySupportedProfilesRequest.hpp>
#include <Bluetooth/BtSendPasskeyRequest.hpp>
#include <Bluetooth/BtRespondAuthorizationRequest.hpp>
#include <Bluetooth/BtDeviceSearchRequest.hpp>
#include <Bluetooth/BtServiceVerifyRequest.hpp>
#include <Bluetooth/BtServiceVerifyResult.hpp>
#include <Bluetooth/BtSvrServiceRecord.hpp>
#include <Bluetooth/BtSvrServiceAttribute.hpp>
#include <Bluetooth/BtSvrDataElement.hpp>
#include <Bluetooth/BtSddbEvent.hpp>
#include <Bluetooth/BtSddbServiceMessage.hpp>
#include <Bluetooth/BtSddbService.hpp>
#include <Bluetooth/BtSddbServiceObserver.hpp>
#include <Bluetooth/BtSddbRequest.hpp>
#include <Bluetooth/BtSddbRegisterServiceRecordRequest.hpp>
#include <Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp>
#include <Bluetooth/BtSddbServiceRecord.hpp>
#include <Bluetooth/BtSddbDataElements.hpp>
#include <Bluetooth/BtSddbServiceAttribute.hpp>
#include <Bluetooth/BtServiceDiscoveryDatabase.hpp>

Include dependency graph for Lib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Bluetooth_Lib_hpp

Define Documentation

#define Bluetooth_Lib_hpp

Generated on Tue Jan 24 14:54:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/Lib.hpp Source File

Bluetooth/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bluetooth_Lib_hpp)
00009 #define Bluetooth_Lib_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BtConstants.hpp>
00015 #include <Bluetooth/BtApplicationMessage.hpp>
00016 #include <Bluetooth/BtRequestMessage.hpp>
00017 #include <Bluetooth/BtRequestOperationMessage.hpp>
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019 #include <Bluetooth/BtEvent.hpp>
00020 #include <Bluetooth/BtDeviceAddress.hpp>
00021 #include <Bluetooth/BtDeviceAndServiceClass.hpp>
00022 #include <Bluetooth/BtDevice.hpp>
00023 #include <Bluetooth/BtDeviceFilter.hpp>
00024 #include <Bluetooth/BtDeviceListIterator.hpp>
00025 #include <Bluetooth/BtDeviceListReverseIterator.hpp>
00026 #include <Bluetooth/BtDeviceList.hpp>
00027 #include <Bluetooth/BtOperationBase.hpp>
00028 #include <Bluetooth/BtRequest.hpp>
00029 #include <Bluetooth/BtCancelableRequest.hpp>
00030 #include <Bluetooth/BtCancelableBroadcastRequest.hpp>
00031 #include <Bluetooth/BtCancelableMulticastRequest.hpp>
00032 #include <Bluetooth/BtUncancelableRequest.hpp>
00033 #include <Bluetooth/BtUncancelablePointToPointRequest.hpp>
00034 #include <Bluetooth/BtRequestRespondRequest.hpp>
00035 #include <Bluetooth/BtService.hpp>
00036 #include <Bluetooth/BtServiceRequest.hpp>
00037 #include <Bluetooth/BtConnectRequest.hpp>
00038 #include <Bluetooth/BtDisconnectRequest.hpp>
00039 #include <Bluetooth/BtAudioAccessoryService.hpp>
00040 #include <Bluetooth/BtObservableService.hpp>
00041 #include <Bluetooth/BtServiceObserver.hpp>
00042 #include <Bluetooth/BtController.hpp>
00043 #include <Bluetooth/BtConnectionBasedController.hpp>
00044 #include <Bluetooth/BtSingleConnectionController.hpp>
00045 #include <Bluetooth/BtMultiConnectionController.hpp>
00046 #include <Bluetooth/BtUtility.hpp>
00047
00048 #include <Bluetooth/BtGapAndSdapApplicationMessage.hpp>
00049 #include <Bluetooth/BtGapAndSdapRequestMessage.hpp>
00050 #include <Bluetooth/BtGapAndSdapController.hpp>
00051 #include <Bluetooth/BtTransport.hpp>
00052 #include <Bluetooth/BtLocalSettings.hpp>
00053 #include <Bluetooth/BtLocalRequest.hpp>
00054 #include <Bluetooth/BtOperationSelectDevice.hpp>
00055 #include <Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp>
00056 #include <Bluetooth/BtDevicePairRequest.hpp>
00057 #include <Bluetooth/BtDeviceUnpairRequest.hpp>
00058 #include <Bluetooth/BtDeviceTrustRequest.hpp>
00059 #include <Bluetooth/BtDeviceUntrustRequest.hpp>
00060 #include <Bluetooth/BtSetRemoteDeviceNameRequest.hpp>
00061 #include <Bluetooth/BtQuerySupportedProfilesRequest.hpp>
00062 #include <Bluetooth/BtSendPasskeyRequest.hpp>
00063 #include <Bluetooth/BtRespondAuthorizationRequest.hpp>
00064 #include <Bluetooth/BtDeviceSearchRequest.hpp>
00065 #include <Bluetooth/BtServiceVerifyRequest.hpp>
00066 #include <Bluetooth/BtServiceVerifyResult.hpp>
00067 #include <Bluetooth/BtSvrServiceRecord.hpp>
00068 #include <Bluetooth/BtSvrServiceAttribute.hpp>
00069 #include <Bluetooth/BtSvrDataElement.hpp>
00070
00071 #include <Bluetooth/BtSddbEvent.hpp>
00072 #include <Bluetooth/BtSddbServiceMessage.hpp>
00073 #include <Bluetooth/BtSddbService.hpp>
00074 #include <Bluetooth/BtSddbServiceObserver.hpp>
00075 #include <Bluetooth/BtSddbRequest.hpp>
00076 #include <Bluetooth/BtSddbRegisterServiceRecordRequest.hpp>
00077 #include <Bluetooth/BtSddbUnregisterServiceRecordRequest.hpp>
00078 #include <Bluetooth/BtSddbServiceRecord.hpp>
00079 #include <Bluetooth/BtSddbDataElements.hpp>
00080 #include <Bluetooth/BtSddbServiceAttribute.hpp>
00081 #include <Bluetooth/BtServiceDiscoveryDatabase.hpp>
00082
00084 #endif  // Bluetooth_Lib_hpp
00085
00086
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/PreComp.cpp File Reference

Bluetooth/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/PreComp.hpp File Reference

Bluetooth/PreComp.hpp File Reference

#include <string.h>
#include <Kernel/Lib.hpp>
#include <Adc/DataHandler.hpp>
#include <Auxiliary/Lib.hpp>
#include <Auxiliary/Unicode.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Apc/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/PreComp.hpp Source File

Bluetooth/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <string.h>
00010 #include <Kernel/Lib.hpp>
00011 #include <Adc/DataHandler.hpp>
00012 #include <Auxiliary/Lib.hpp>
00013 #include <Auxiliary/Unicode.hpp>
00014 #include <Auxiliary/WStrUtil.hpp>
00015 #include <Apc/Lib.hpp>
00016
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpConnectRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpConnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpService.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpConnectRequest.hpp"

Include dependency graph for BtAvrcpConnectRequest.cpp:

Generated on Tue Jan 24 19:56:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpConnectRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpConnectRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtAvrcpConnectRequest_hpp

Define Documentation

#define BtAvrcpConnectRequest_hpp

Generated on Tue Jan 24 19:56:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpConnectRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpConnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpConnectRequest_hpp)
00009 #define BtAvrcpConnectRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtConnectRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtAvrcpService;
00027 class BtAvrcpOperationController;
00028
00031 class BtAvrcpConnectRequest : public BtConnectRequest
00032 {
00033     private:
00034         typedef BtConnectRequest Base;
00035
00036     public:
00038         BtAvrcpConnectRequest(BtAvrcpService& avrcp_service);
00039
00041         virtual ~BtAvrcpConnectRequest();
00043
00045         virtual BtRequestType GetRequestType() const;
00046
00047     protected:
00049
00051         virtual BOOLEAN PerformConnectControllerCall();
00052
00053     private:
00054         friend class BtAvrcpOperationController;
00055 };
00056
00058 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00059 #endif  // BtAvrcpConnectRequest_hpp
00060
00061
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpConnectResponse.cpp File Reference

Bluetooth/AVRCP/BtAvrcpConnectResponse.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationService.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpConnectResponse.hpp"

Include dependency graph for BtAvrcpConnectResponse.cpp:

Generated on Tue Jan 24 19:56:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp File Reference

Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>

Include dependency graph for BtAvrcpConnectResponse.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpConnectResponse

Defines

#define | BtAvrcpConnectResponse_hpp

Define Documentation

#define BtAvrcpConnectResponse_hpp

Generated on Tue Jan 24 19:56:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp Source File

Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpConnectResponse_hpp)
00009 #define BtAvrcpConnectResponse_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019 class BtAvrcpOperationService;
00020 class BtAvrcpOperationController;
00022
00023
00026 class BtAvrcpConnectResponse : public BtAvrcpRequest
00027 {
00028     private:
00029         typedef BtAvrcpRequest Base;
00030
00031     public:
00033         BtAvrcpConnectResponse(BtAvrcpOperationService& avrcp_service);
00034
00035         void SetBtapiHandle(btapi_avrcp_handle_t hdl) { m_hdl = hdl; };
00036
00038         virtual ~BtAvrcpConnectResponse();
00039
00041
00043         virtual BtRequestType GetRequestType() const;
00044
00045     protected:
00047
00049         virtual BOOLEAN Execute();
00050
00051     private:
00052         btapi_avrcp_handle_t GetApiSettings() { return m_hdl; };
00053         btapi_avrcp_handle_t m_hdl;
00054
00055     private:
00056         friend class BtAvrcpOperationService;
00057         friend class BtAvrcpOperationController;
00058
00059
00060 };
00061
00063 #endif  // BtAvrcpConnectResponse_hpp
00064
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpRegistrationController.hpp"
#include "BtAvrcpDeRegisterRequest.hpp"
#include "BtAvrcpRegistrationService.hpp"

Include dependency graph for BtAvrcpDeRegisterRequest.cpp:

Generated on Tue Jan 24 19:56:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>

Include dependency graph for BtAvrcpDeRegisterRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpDeRegisterRequest

Defines

#define | BtAvrcpDeRegisterRequest_hpp

Define Documentation

#define BtAvrcpDeRegisterRequest_hpp

Generated on Tue Jan 24 19:56:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpDeRegisterRequest_hpp)
00009 #define BtAvrcpDeRegisterRequest_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019 class BtAvrcpRegistrationService;
00020 class BtAvrcpRegistrationController;
00021
00022
00025 class BtAvrcpDeRegisterRequest : public BtAvrcpRequest
00026 {
00027     private:
00028         typedef BtAvrcpRequest Base;
00029
00030     public:
00032         BtAvrcpDeRegisterRequest(BtAvrcpRegistrationService& avrcp_service);
00033
00035         virtual ~BtAvrcpDeRegisterRequest();
00036
00037         void SetRole(BtAvrcpRole role) { m_role = role; };
00038
00039         BtAvrcpRole GetRole() const { return m_role; };
00040
00042
00044         virtual BtRequestType GetRequestType() const;
00045
00046     protected:
00048
00050         virtual BOOLEAN Execute();
00051
00052
00053     private:
00054         BtAvrcpRole     m_role;
00055
00056     private:
00057         friend class BtAvrcpRegistrationService;
00058         friend class BtAvrcpRegistrationController;
00059
00060 };
00061
00063 #endif  // BtAvrcpDeRegisterRequest
00064
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpDisconnectRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpDisconnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpDisconnectRequest.hpp"
#include "BtAvrcpOperationService.hpp"
#include "BtAvrcpOperationController.hpp"

Include dependency graph for BtAvrcpDisconnectRequest.cpp:

Generated on Tue Jan 24 19:56:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpDisconnectRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpDisconnectRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtAvrcpDisconnectRequest_hpp

Define Documentation

#define BtAvrcpDisconnectRequest_hpp

Generated on Tue Jan 24 19:56:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpDisconnectRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpDisconnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpDisconnectRequest_hpp)
00009 #define BtAvrcpDisconnectRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtDisconnectRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtAvrcpOperationService;
00027
00030 class BtAvrcpDisconnectRequest : public BtDisconnectRequest
00031 {
00032     private:
00033         typedef BtDisconnectRequest Base;
00034
00035     public:
00037         BtAvrcpDisconnectRequest(BtAvrcpOperationService& avrcp_service);
00038
00040         virtual ~BtAvrcpDisconnectRequest();
00041
00043
00045         virtual BtRequestType GetRequestType() const;
00046
00047     protected:
00049
00051         virtual BOOLEAN PerformDisconnectControllerCall();
00052 };
00053
00055 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00056 #endif  // BtAvrcpDisconnectRequest_hpp
00057
00058
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpMessageArguments.cpp File Reference

Bluetooth/AVRCP/BtAvrcpMessageArguments.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpMessageArguments.hpp"

Include dependency graph for BtAvrcpMessageArguments.cpp:

Generated on Tue Jan 24 19:56:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpMessageArguments.hpp File Reference

Bluetooth/AVRCP/BtAvrcpMessageArguments.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp>

Include dependency graph for BtAvrcpMessageArguments.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpMessageArgumentsDestroyTableNode

Defines

#define | Bluetooth_BtAvrcpMessageArguments_hpp

Define Documentation

#define Bluetooth_BtAvrcpMessageArguments_hpp

Generated on Tue Jan 24 19:56:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpMessageArguments.hpp Source File

Bluetooth/AVRCP/BtAvrcpMessageArguments.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Bluetooth\AVRCP\BtAvrcpNotificationMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Bluetooth_BtAvrcpMessageArguments_hpp)
00014 #define Bluetooth_BtAvrcpMessageArguments_hpp
00015 #include <Apc/StackMsgArgument.hpp>
00016 #include <Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp>
00017 /* ----------------------------------------------------------------------
00018     Classes
00019     ---------------------------------------------------------------------- */
00020 /*  ======================================================================
00021     Class BtAvrcpMessageArgumentsDestroyTableNode
00022     ====================================================================== */
00023 class BtAvrcpMessageArgumentsDestroyTableNode : public StackMsgArgDestroyTableNode {
00024     public:
00025
00026         static BtAvrcpMessageArgumentsDestroyTableNode* GetInstance();
00027
00028     private:
00029         BtAvrcpMessageArgumentsDestroyTableNode();
00030
00031
00032         static BtAvrcpMessageArgumentsDestroyTableNode* m_node;
00033         static const ArgumentDestroyEntry m_destroy_table[];
00034
00035     };
00036 #endif // Bluetooth_BtAvrcpMessageArguments_hpp
00037
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpNotificationMessage.cpp File Reference

Bluetooth/AVRCP/BtAvrcpNotificationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpNotificationMessage.hpp"

Include dependency graph for BtAvrcpNotificationMessage.cpp:

Generated on Tue Jan 24 19:56:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp File Reference

Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp File Reference

#include <Apc/Message.hpp>
#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/AVRCP/BtAvrcpOperationService.hpp>

Include dependency graph for BtAvrcpNotificationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpNotificationMessage

Defines

#define | BtAvrcpNotificationMessage_hpp

Define Documentation

#define BtAvrcpNotificationMessage_hpp

Generated on Tue Jan 24 19:56:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp Source File

Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpNotificationMessage_hpp)
00009 #define BtAvrcpNotificationMessage_hpp
00012
00013 #include <Apc/Message.hpp>
00014 #include <Apc/StackMsgArgument.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpOperationService.hpp>
00016
00030 class BtAvrcpNotificationMessage: public FromStackMsg
00031 {
00032     private:
00033         typedef FromStackMsg Base;
00034
00035     public:
00037         BtAvrcpNotificationMessage(StackMsgArgument *argument = 0);
00038
00040         BtAvrcpNotificationMessage(BtAvrcpOperationService* service, StackMsgArgument *argument = 0);
00041
00043         BtAvrcpNotificationMessage(const BtAvrcpNotificationMessage &message);
00044
00046         virtual ~BtAvrcpNotificationMessage();
00047
00048
00050
00052         BtAvrcpOperationService* GetService() const;
00053
00055
00057         virtual FromStackMsg& operator=(const FromStackMsg &message);
00058
00060
00062         virtual BtAvrcpNotificationMessage& operator=(const BtAvrcpNotificationMessage& message);
00063
00065
00067         virtual const MsgMetaData& GetMetaData() const;
00068
00070
00072         virtual Message* Clone() const;
00073
00074     public:
00075         enum { ID = 10450 };
00076
00077     private:
00079         BtAvrcpOperationService* m_service;
00080
00081     private:
00083         static const MsgMetaData m_meta_data;
00084 };
00085
00086 #endif // BtAvrcpNotificationMessage_hpp
00087
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.cpp File Reference

Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpNotificationMessageArgument.hpp"

Include dependency graph for BtAvrcpNotificationMessageArgument.cpp:

Generated on Tue Jan 24 19:56:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp File Reference

Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>

Include dependency graph for BtAvrcpNotificationMessageArgument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpNmaConnect
class | BtAvrcpNmaDisconnect

Defines

#define | Bluetooth_AVRCP_BtAvrcpNotificationMessageArgument_hpp

Define Documentation

#define Bluetooth_AVRCP_BtAvrcpNotificationMessageArgument_hpp

Generated on Tue Jan 24 19:56:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp Source File

Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\bt_avrcp_multiconnection\lnz_apoxi\Apoxi\Bluetooth\AVRCP\BtAvrcpNotificationMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Bluetooth_AVRCP_BtAvrcpNotificationMessageArgument_hpp)
00014 #define Bluetooth_AVRCP_BtAvrcpNotificationMessageArgument_hpp
00015 #include <Apc/StackMsgArgument.hpp>
00016 #include <Bluetooth/BtTypes.hpp>
00017 #include <Bluetooth/AVRCP/BtTypes.hpp>
00018 /* ----------------------------------------------------------------------
00019     Classes
00020     ---------------------------------------------------------------------- */
00021 /*  ======================================================================
00022     Class BtAvrcpNmaConnect
00023     ====================================================================== */
00025 class BtAvrcpNmaConnect : public StackMsgArgument {
00026     friend class BtAvrcpMessageArgumentsDestroyTableNode;
00027     public:
00028         BtAvrcpNmaConnect(const btapi_avrcp_connect_handle_t& btapi_hdl);
00029         BtAvrcpNmaConnect();
00030         ~BtAvrcpNmaConnect();
00031
00032         static const BtAvrcpNmaConnect& Cast(const StackMsgArgument& arg);
00033         const btapi_avrcp_connect_handle_t& GetBtapiHdl() const { return m_btapi_hdl; }
00034
00035         enum  {
00036             ID = 10
00037             };
00038
00039     private:
00040
00041         static void Destroy(StackMsgArgument* arg) { delete ((BtAvrcpNmaConnect*) arg); }
00042
00043         btapi_avrcp_connect_handle_t m_btapi_hdl;
00044
00045     };
00046 // Inline definitions
00047 inline const BtAvrcpNmaConnect& BtAvrcpNmaConnect::Cast(const StackMsgArgument& arg) {
00048     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtAvrcpNmaConnect!\n");
00049     return ((BtAvrcpNmaConnect &) arg);
00050 }
00051 /*  ======================================================================
00052     Class BtAvrcpNmaDisconnect
00053     ====================================================================== */
00055 class BtAvrcpNmaDisconnect : public StackMsgArgument {
00056     friend class BtAvrcpMessageArgumentsDestroyTableNode;
00057     public:
00058         BtAvrcpNmaDisconnect(void* app_hdl);
00059         BtAvrcpNmaDisconnect();
00060         ~BtAvrcpNmaDisconnect();
00061
00062         static const BtAvrcpNmaDisconnect& Cast(const StackMsgArgument& arg);
00063         void* GetAppHdl() const { return m_app_hdl; }
00064
00065         enum  {
00066             ID = 11
00067             };
00068
00069     private:
00070
00071         static void Destroy(StackMsgArgument* arg) { delete ((BtAvrcpNmaDisconnect*) arg); }
00072
00073         void* m_app_hdl;
00074
00075     };
00076 // Inline definitions
00077 inline const BtAvrcpNmaDisconnect& BtAvrcpNmaDisconnect::Cast(const StackMsgArgument& arg) {
00078     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtAvrcpNmaDisconnect!\n");
00079     return ((BtAvrcpNmaDisconnect &) arg);
00080 }
00081 #endif // Bluetooth_AVRCP_BtAvrcpNotificationMessageArgument_hpp
00082
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationController.cpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationController.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpOperationService.hpp"
#include "BtAvrcpNotificationMessage.hpp"
#include "BtAvrcpNotificationMessageArgument.hpp"
#include "BtAvrcpService.hpp"
#include "BtAvrcpConnectRequest.hpp"
#include "BtAvrcpConnectResponse.hpp"
#include "BtAvrcpDisconnectRequest.hpp"
#include "BtAvrcpPanelPassThroughRequest.hpp"
#include "BtAvrcpRawFrameRequest.hpp"
#include "BtAvrcpUnitInfoRequest.hpp"
#include "BtAvrcpSubunitInfoRequest.hpp"
#include "BtAvrcpOperationRequestResponse.hpp"

Include dependency graph for BtAvrcpOperationController.cpp:

Defines

#define | DBG_STATE
#define | DBG_STATE_STATIC

Define Documentation

#define DBG_STATE

#define DBG_STATE_STATIC

Generated on Tue Jan 24 19:56:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationController.hpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtAvrcpOperationController_hpp

Define Documentation

#define BtAvrcpOperationController_hpp

Generated on Tue Jan 24 19:56:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationController.hpp Source File

Bluetooth/AVRCP/BtAvrcpOperationController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpOperationController_hpp)
00009 #define BtAvrcpOperationController_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <stack/extensions.h>
00021 #include <Bluetooth/BtTypes.hpp>
00022 #include <Bluetooth/BtServiceRequest.hpp>
00023 #include <Bluetooth/BtSingleConnectionController.hpp>
00024 #include <Bluetooth/AVRCP/BtTypes.hpp>
00025 //#include <Bluetooth/AVRCP/BtAvrcpResponse.hpp>
00026
00027 /*  ------------------------------------------------------------------------
00028     Forward deklarations for friend relationships.
00029     ------------------------------------------------------------------------ */
00030
00031 class BtAvrcpRequest;
00032 class BtAvrcpRegisterUnitInfo;
00033 class BtAvrcpConnectRequest;
00034 class BtAvrcpConnectResponse;
00035 class BtAvrcpOperationService;
00036 class BtAvrcpDisconnectRequest;
00037 class BtAvrcpPanelPassThroughRequest;
00038 class BtAvrcpRawFrameRequest;
00039 class BtAvrcpUnitInfoRequest;
00040 class BtAvrcpSubunitInfoRequest;
00041 class BtAvrcpOperationRequestResponse;
00042
00043
00047 class BtAvrcpOperationController : public BtMultiConnectionController
00048 {
00049     private:
00050         typedef BtMultiConnectionController Base;
00051
00052     public:
00054
00059         static BtAvrcpOperationController& GetInstance();
00060
00061     public:
00063         virtual ~BtAvrcpOperationController();
00064
00066
00068         virtual const WCHAR* GetName() const;
00069
00071
00086         BOOLEAN ConnectRequest(BtAvrcpConnectRequest *connect_request);
00087
00088         BOOLEAN DisconnectRequest(BtAvrcpDisconnectRequest *disconnect_request);
00089
00090         BOOLEAN PanelPassThroughRequest(BtAvrcpPanelPassThroughRequest *panel_passthrough_request);
00091
00092         BOOLEAN RawFrameRequest(BtAvrcpRawFrameRequest *raw_frame_request);
00093
00094         BOOLEAN UnitInfoRequest(BtAvrcpUnitInfoRequest *unit_info_request);
00095
00096         BOOLEAN SubunitInfoRequest(BtAvrcpSubunitInfoRequest *subunit_info_request);
00097
00098
00099         BOOLEAN ConnectResponse(BtAvrcpConnectResponse *connect_response);
00100
00101         BOOLEAN RequestResponse(BtAvrcpOperationRequestResponse *request_response);
00102
00103     protected:
00106         class BtAvrcpConnection: public BtMultiConnectionController::BtConnection
00107         {
00108             private:
00109                 typedef BtMultiConnectionController::BtConnection Base;
00110
00111             public:
00113                 BtAvrcpConnection();
00114
00116                 virtual ~BtAvrcpConnection();
00117
00119
00121                 btapi_avrcp_handle_t GetAvrcpHandle() const;
00122
00124
00126                 void SetAvrcpHandle(btapi_avrcp_handle_t avrcp_handle);
00127
00128             private:
00130                 btapi_avrcp_handle_t m_avrcp_handle;
00131
00132         };
00133
00134     private:
00136
00138         BtAvrcpConnection* FindConnectionByAvrcpHandle(btapi_avrcp_handle_t avrcp_handle) const;
00139
00141
00143         btapi_avrcp_handle_t GetAvrcpHandle(const void* apoxi_handle);
00144
00145
00146 #ifdef _XXX_
00147
00148
00151         BOOLEAN DeRegisterApplication(BtAvrcpRegisterUnitInfo* unit_info);
00152
00153 #endif
00154
00155     private:
00156
00157
00158         /*---------------------------------------------------------------------*/
00159         /* The following functions must not be called by an application.       */
00160         /* They are the entry point from the stack callback functions into our */
00161         /* object orientated framework (APOXI).                                */
00162         /* They are implemented as static because they have to be passed as    */
00163         /* normal C function pointers. The reason for this is the BT-API Stack */
00164         /* interface that demands C function pointers for callback the         */
00165         /* callback functions it calls to state the progress of ongoing        */
00166         /* operations                                                          */
00167         /*---------------------------------------------------------------------*/
00168
00170
00173         static void OnAvrcpConnectCfmCb(btapi_result_t result, const btapi_avrcp_connect_handle_t *hdl);
00174
00175         static void OnAvrcpDisconnectCb(btapi_result_t result, const void *app_handle);
00176
00177         static void OnAvrcpPanelPassthroughCfmCb(btapi_result_t result, const btapi_avrcp_response_t *rsp);
00178
00179         static void OnAvrcpRawFrameCfmCb(btapi_result_t result, const btapi_avrcp_response_t *rsp);
00180
00181         static void OnAvrcpUnitInfoCfmCb(btapi_result_t result, const btapi_avrcp_unit_info_t *rsp);
00182
00183         static void OnAvrcpResponseCfmCb(btapi_result_t result, const btapi_avrcp_response_callback_t *rsp);
00184
00185         static void OnAvrcpSubunitInfoCfmCb(btapi_result_t result, const btapi_avrcp_subunit_info_t *rsp);
00186
00187         static void OnAvrcpConnectIndCb(btapi_result_t result, const btapi_avrcp_connect_handle_t *hdl);
00188
00189         static void OnAvrcpPanelPassThroughIndCb(btapi_result_t result, const btapi_avrcp_panel_passthrough_t *ind);
00190
00191         static void OnAvrcpRawFrameIndCb(btapi_result_t result, const btapi_avrcp_raw_frame_t *ind);
00192
00193     private:
00195         BtAvrcpOperationController();
00196
00198
00200         virtual void Register();
00201
00203
00205         virtual void Unregister();
00206
00207     private:
00208         btapi_avrcpcb_funp_t* m_avrcp_callback_functions;
00209         static BtAvrcpOperationController m_controller;
00210
00211     private:
00212         friend class BtAvrcpRequest;
00213         friend class BtAvrcpConnectRequest;
00214         friend class BtAvrcpConnectResponse;
00215         friend class BtAvrcpOperationService;
00216         friend class BtAvrcpDisconnectRequest;
00217         friend class BtAvrcpPanelPassThroughRequest;
00218         friend class BtAvrcpRawFrameRequest;
00219         friend class BtAvrcpUnitInfoRequest;
00220         friend class BtAvrcpSubunitInfoRequest;
00221         friend class BtAvrcpOperationRequestResponse;
00222 };
00223
00225 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00226 #endif  // BtHfController_hpp
00227
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.cpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationRequestResponse.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpOperationService.hpp"

Include dependency graph for BtAvrcpOperationRequestResponse.cpp:

Generated on Tue Jan 24 19:56:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>

Include dependency graph for BtAvrcpOperationRequestResponse.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpOperationRequestResponse

Defines

#define | BtAvrcpOperationRequestResponse_hpp

Define Documentation

#define BtAvrcpOperationRequestResponse_hpp

Generated on Tue Jan 24 19:56:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp Source File

Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpOperationRequestResponse_hpp)
00009 #define BtAvrcpOperationRequestResponse_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtTypes.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020 class BtAvrcpOperationService;
00021 class BtAvrcpOperationController;
00023
00024
00027 class BtAvrcpOperationRequestResponse : public BtAvrcpRequest
00028 {
00029     private:
00030         typedef BtAvrcpRequest Base;
00031
00032     public:
00034         BtAvrcpOperationRequestResponse(BtAvrcpOperationService& avrcp_service);
00035
00037         virtual ~BtAvrcpOperationRequestResponse();
00038
00040
00042         virtual BtRequestType GetRequestType() const;
00043
00044         void SetRequestType(BtRequestType request_type);
00045
00046         BtAvrcpResponseType GetResponse() { return m_response; };
00047
00048         void SetResponseType(BtAvrcpResponseType response) { m_response = response; };
00049
00050     protected:
00052
00054         virtual BOOLEAN Execute();
00055
00056     private:
00057         BtRequestType           m_request_type;
00058         BtAvrcpResponseType     m_response;
00059
00060     private:
00061         friend class BtAvrcpOperationController;
00062         friend class BtAvrcpOperationService;
00063 };
00064
00066 #endif  // BtAvrcpOperationRequestResponse_hpp
00067
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationService.cpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationService.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationService.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpServiceMessage.hpp"
#include "BtAvrcpOperationServiceMessage.hpp"
#include "BtAvrcpOperationServiceMessageArgument.hpp"
#include "BtAvrcpOperationRequestResponse.hpp"

Include dependency graph for BtAvrcpOperationService.cpp:

Generated on Tue Jan 24 19:56:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationService.hpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationService.hpp File Reference

#include <Bluetooth/AVRCP/BtAvrcpService.hpp>
#include <Bluetooth/AVRCP/BtAvrcpConnectRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpDisconnectRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp>
#include <Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp>

Include dependency graph for BtAvrcpOperationService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpOperationService

Defines

#define | BtAvrcpOperationService_hpp

Define Documentation

#define BtAvrcpOperationService_hpp

Generated on Tue Jan 24 19:56:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationService.hpp Source File

Bluetooth/AVRCP/BtAvrcpOperationService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtAvrcpOperationService_hpp)
00010 #define BtAvrcpOperationService_hpp
00013
00014 #include <Bluetooth/AVRCP/BtAvrcpService.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpConnectRequest.hpp>
00016 #include <Bluetooth/AVRCP/BtAvrcpDisconnectRequest.hpp>
00017 #include <Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp>
00018 #include <Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp>
00019 #include <Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp>
00020 #include <Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp>
00021 #include <Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp>
00022 #include <Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp>
00023
00024
00025 class BtAvrcpOperationController;
00026
00027
00035 class BtAvrcpOperationService : public BtAvrcpService
00036 {
00037     private:
00038         typedef BtAvrcpService Base;
00039
00040     public:
00042         BtAvrcpOperationService();
00043
00045         virtual ~BtAvrcpOperationService();
00046
00051         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00052
00059         BOOLEAN IsConnected() const;
00060
00066         BtRequestState ConnectRequest();
00067
00073         BtRequestState DisconnectRequest();
00074
00081         BtRequestState PanelPassthroughRequest(BtAvrcpOperation operation);
00082
00090         BtRequestState PanelPassthroughRequest(BtAvrcpOperation operation, BtAvrcpStateFlag state_flag);
00091
00098         BtRequestState PanelPassthroughRequest(BtAvrcpPanelPassThroughParams ppt_params);
00099
00105         BtRequestState RawFrameRequest(BtAvrcpRawFrameParams raw_frame_params);
00106
00107
00114         BtRequestState UnitInfoRequest();
00115
00125         BOOLEAN GetUnitInfo(BtAvrcpUnitInfoParams &unit_info);
00126
00128
00135         BtRequestState SubunitInfoRequest(UINT8 page);
00136
00137
00148         BOOLEAN GetSubunitInfo(BtAvrcpSubunitInfoParams &subunit_info);
00149
00151         /*
00152             <em>ConnectResponse</em> Sent over the air in case the Application
00153             Programmer wants to accept an incoming connection.
00154             @param avrcp_handle A <em>btapi_avrcp_handle_t</em> which is delivered
00155             from the stack via the incoming BtAvrcpNotificationMessage. Needs to
00156             be sent back in order to accept the communication between two devices.
00157         */
00158         BtRequestState ConnectResponse(btapi_avrcp_handle_t avrcp_handle);
00159
00161
00175         BtRequestState OperationRequestResponse(BtRequestType request_type, BtAvrcpResponseType response);
00176
00177
00178     protected:
00180         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00181
00183
00189         virtual void OnPanelPassThrough(BtAvrcpPanelPassThroughParams panel_passthrough_params);
00190
00194         virtual void OnRawFrame(BtAvrcpRawFrameParams raw_frame_params);
00195
00197
00199         virtual BOOLEAN OnMessage(const Message& message);
00200
00202
00206         virtual void RegisterMessages() const;
00207
00209
00212         virtual void UnregisterMessages() const;
00213
00214     private:
00216
00218         void PanelPassThroughIndicationCallback(BtAvrcpPanelPassThroughParams ppt_params);
00219
00221
00223         void RawFrameIndicationCallback(BtAvrcpRawFrameParams raw_frame_params);
00224
00225 private:
00226         BtAvrcpConnectRequest           m_connect_request;
00227         BtAvrcpConnectResponse          m_connect_response;
00228         BtAvrcpDisconnectRequest        m_disconnect_request;
00229         BtAvrcpPanelPassThroughRequest  m_panel_passthrough_request;
00230         BtAvrcpRawFrameRequest          m_raw_frame_request;
00231         BtAvrcpUnitInfoRequest          m_unit_info_request;
00232         BtAvrcpSubunitInfoRequest       m_subunit_info_request;
00233         BtAvrcpOperationRequestResponse m_response_request;
00234
00235     private:
00236         friend class BtAvrcpOperationController;
00237 };
00238
00240 #endif  // BtAvrcpOperationService_hpp
00241
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.cpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationServiceMessage.hpp"

Include dependency graph for BtAvrcpOperationServiceMessage.cpp:

Generated on Tue Jan 24 19:56:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.hpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.hpp File Reference

#include <Apc/Message.hpp>
#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/AVRCP/BtAvrcpOperationService.hpp>

Include dependency graph for BtAvrcpOperationServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpOperationServiceMessage

Defines

#define | BtAvrcpOperationServiceMessage_hpp

Define Documentation

#define BtAvrcpOperationServiceMessage_hpp

Generated on Tue Jan 24 19:56:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.hpp Source File

Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpOperationServiceMessage_hpp)
00009 #define BtAvrcpOperationServiceMessage_hpp
00012
00013 #include <Apc/Message.hpp>
00014 #include <Apc/StackMsgArgument.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpOperationService.hpp>
00016
00025 class BtAvrcpOperationServiceMessage : public FromStackMsg
00026 {
00027     private:
00028         typedef FromStackMsg Base;
00029
00030     public:
00032         BtAvrcpOperationServiceMessage(StackMsgArgument *argument = 0);
00033
00035         BtAvrcpOperationServiceMessage(BtAvrcpOperationService* service, StackMsgArgument *argument = 0);
00036
00038         BtAvrcpOperationServiceMessage(const BtAvrcpOperationServiceMessage &message);
00039
00041         virtual ~BtAvrcpOperationServiceMessage();
00042
00043
00045
00047         BtAvrcpOperationService* GetService() const;
00048
00050
00052         virtual FromStackMsg& operator=(const FromStackMsg &message);
00053
00055
00057         virtual BtAvrcpOperationServiceMessage& operator=(const BtAvrcpOperationServiceMessage& message);
00058
00060
00062         virtual const MsgMetaData& GetMetaData() const;
00063
00065
00067         virtual Message* Clone() const;
00068
00069     public:
00070         enum { ID = 10451 };
00071
00072     private:
00074         BtAvrcpOperationService* m_service;
00075
00076     private:
00078         static const MsgMetaData m_meta_data;
00079 };
00080
00081 #endif // BtAvrcpOperationServiceMessage_hpp
00082
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.cpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationServiceMessageArgument.hpp"

Include dependency graph for BtAvrcpOperationServiceMessageArgument.cpp:

Generated on Tue Jan 24 19:56:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp File Reference

Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp>

Include dependency graph for BtAvrcpOperationServiceMessageArgument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpNmaPanelPassThrough
class | BtAvrcpNmaRawFrame

Defines

#define | Bluetooth_AVRCP_BtAvrcpOperationServiceMessageArgument_hpp

Define Documentation

#define Bluetooth_AVRCP_BtAvrcpOperationServiceMessageArgument_hpp

Generated on Tue Jan 24 19:56:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp Source File

Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\bt_avrcp_multiconnection\lnz_apoxi\Apoxi\Bluetooth\AVRCP\BtAvrcpOperationServiceMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Bluetooth_AVRCP_BtAvrcpOperationServiceMessageArgument_hpp)
00014 #define Bluetooth_AVRCP_BtAvrcpOperationServiceMessageArgument_hpp
00015 #include <Apc/StackMsgArgument.hpp>
00016 #include <Bluetooth/BtTypes.hpp>
00017 #include <Bluetooth/AVRCP/BtTypes.hpp>
00018 #include <Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp>
00019 #include <Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp>
00020 /* ----------------------------------------------------------------------
00021     Classes
00022     ---------------------------------------------------------------------- */
00023 /*  ======================================================================
00024     Class BtAvrcpNmaPanelPassThrough
00025     ====================================================================== */
00027 class BtAvrcpNmaPanelPassThrough : public StackMsgArgument {
00028     friend class BtAvrcpMessageArgumentsDestroyTableNode;
00029     public:
00030         BtAvrcpNmaPanelPassThrough(const BtAvrcpPanelPassThroughParams& panel_passthrough_params);
00031         BtAvrcpNmaPanelPassThrough();
00032         ~BtAvrcpNmaPanelPassThrough();
00033
00034         static const BtAvrcpNmaPanelPassThrough& Cast(const StackMsgArgument& arg);
00035         const BtAvrcpPanelPassThroughParams& GetPanelPassthroughParams() const { return m_panel_passthrough_params; }
00036
00037         enum  {
00038             ID = 12
00039             };
00040
00041     private:
00042
00043         static void Destroy(StackMsgArgument* arg) { delete ((BtAvrcpNmaPanelPassThrough*) arg); }
00044
00045         BtAvrcpPanelPassThroughParams m_panel_passthrough_params;
00046
00047     };
00048 // Inline definitions
00049 inline const BtAvrcpNmaPanelPassThrough& BtAvrcpNmaPanelPassThrough::Cast(const StackMsgArgument& arg) {
00050     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtAvrcpNmaPanelPassThrough!\n");
00051     return ((BtAvrcpNmaPanelPassThrough &) arg);
00052 }
00053 /*  ======================================================================
00054     Class BtAvrcpNmaRawFrame
00055     ====================================================================== */
00057 class BtAvrcpNmaRawFrame : public StackMsgArgument {
00058     friend class BtAvrcpMessageArgumentsDestroyTableNode;
00059     public:
00060         BtAvrcpNmaRawFrame(const BtAvrcpRawFrameParams& raw_frame_params);
00061         BtAvrcpNmaRawFrame();
00062         ~BtAvrcpNmaRawFrame();
00063
00064         static const BtAvrcpNmaRawFrame& Cast(const StackMsgArgument& arg);
00065         const BtAvrcpRawFrameParams& GetRawFrameParams() const { return m_raw_frame_params; }
00066
00067         enum  {
00068             ID = 13
00069             };
00070
00071     private:
00072
00073         static void Destroy(StackMsgArgument* arg) { delete ((BtAvrcpNmaRawFrame*) arg); }
00074
00075         BtAvrcpRawFrameParams m_raw_frame_params;
00076
00077     };
00078 // Inline definitions
00079 inline const BtAvrcpNmaRawFrame& BtAvrcpNmaRawFrame::Cast(const StackMsgArgument& arg) {
00080     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtAvrcpNmaRawFrame!\n");
00081     return ((BtAvrcpNmaRawFrame &) arg);
00082 }
00083 #endif // Bluetooth_AVRCP_BtAvrcpOperationServiceMessageArgument_hpp
00084
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.cpp File Reference

Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpPanelPassThroughParams.hpp"

Include dependency graph for BtAvrcpPanelPassThroughParams.cpp:

Generated on Tue Jan 24 19:56:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp File Reference

Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>

Include dependency graph for BtAvrcpPanelPassThroughParams.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpPanelPassThroughParams

Defines

#define | BtAvrcpPanelPassThroughParams_hpp

Define Documentation

#define BtAvrcpPanelPassThroughParams_hpp

Generated on Tue Jan 24 19:56:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp Source File

Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpPanelPassThroughParams_hpp)
00009 #define BtAvrcpPanelPassThroughParams_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtTypes.hpp>
00015
00021 class BtAvrcpPanelPassThroughParams
00022 {
00023
00024     public:
00026         BtAvrcpPanelPassThroughParams();
00027
00029         BtAvrcpPanelPassThroughParams(BtAvrcpOperation operation, BtAvrcpStateFlag state);
00030
00032         virtual ~BtAvrcpPanelPassThroughParams();
00033
00034         /**********************************************************************/
00035         /* Avrcp Panel Pass Through Parameters                            */
00036         /**********************************************************************/
00037
00041         const BtAvrcpOperation GetOperation() const { return (BtAvrcpOperation)m_operation; };
00042
00047         void SetOperation(BtAvrcpOperation operation) { m_operation = operation; };
00048
00052         const BtAvrcpStateFlag GetState() const { return m_state_flag; };
00053
00058         void SetState(BtAvrcpStateFlag state) { m_state_flag = state; };
00059
00063         const UINT8 GetOperationDataLength() const { return m_operation_data_length; };
00064
00066
00070         void SetOperationDataLength(UINT8 data_length) { m_operation_data_length = data_length; };
00071
00075         const UINT8* GetOperationData() const { return m_operation_data; };
00076
00081         BOOLEAN SetOperationData(UINT8* operation_data);
00082
00086         BOOLEAN ReleaseOperationData();
00087
00088     private:
00089         BtAvrcpOperation    m_operation;
00090         BtAvrcpStateFlag    m_state_flag;
00091         UINT8               m_operation_data_length;
00092         UINT8*              m_operation_data;
00093
00094 };
00095
00097 #endif  // BtAvrcpPanelPassThroughParams
00098
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpPanelPassThroughRequest.hpp"
#include "BtAvrcpOperationService.hpp"

Include dependency graph for BtAvrcpPanelPassThroughRequest.cpp:

Generated on Tue Jan 24 19:56:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp>

Include dependency graph for BtAvrcpPanelPassThroughRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpPanelPassThroughRequest

Defines

#define | BtAvrcpPanelPassThroughRequest_hpp

Define Documentation

#define BtAvrcpPanelPassThroughRequest_hpp

Generated on Tue Jan 24 19:56:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpPanelPassThroughRequest_hpp)
00009 #define BtAvrcpPanelPassThroughRequest_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020 class BtAvrcpOperationService;
00021 class BtAvrcpOperationController;
00022
00023
00026 class BtAvrcpPanelPassThroughRequest : public BtAvrcpRequest
00027 {
00028     private:
00029         typedef BtAvrcpRequest Base;
00030
00031     public:
00033         BtAvrcpPanelPassThroughRequest(BtAvrcpOperationService& avrcp_service);
00034
00036         virtual ~BtAvrcpPanelPassThroughRequest();
00037
00038         void SetPanelPassThroughParams(BtAvrcpPanelPassThroughParams ppt_params) { m_ppt_params = ppt_params; };
00039
00040         BtAvrcpPanelPassThroughParams GetPanelPassThroughParams() const { return m_ppt_params; };
00041
00042         void SetResponse(btapi_avrcp_response_code_t response) { m_response = (BtAvrcpResponseType)response; };
00043
00044         BtAvrcpResponseType GetResponse() { return m_response; };
00045
00047         BOOLEAN ReleaseParams();
00049
00051         virtual BtRequestType GetRequestType() const;
00052
00053     protected:
00055
00057         virtual BOOLEAN Execute();
00058
00059
00060     private:
00061
00062         btapi_avrcp_panel_passthrough_t*    GetApiSettings();
00063         btapi_avrcp_panel_passthrough_t     m_api_settings;
00064         BtAvrcpPanelPassThroughParams       m_ppt_params;
00065         BtAvrcpResponseType                 m_response;
00066     private:
00067         friend class BtAvrcpOperationService;
00068         friend class BtAvrcpOperationController;
00069
00070 };
00071
00073 #endif  // BtAvrcpPanelPassThroughRequest_hpp
00074
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRawFrameParams.cpp File Reference

Bluetooth/AVRCP/BtAvrcpRawFrameParams.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpRawFrameParams.hpp"

Include dependency graph for BtAvrcpRawFrameParams.cpp:

Generated on Tue Jan 24 19:56:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp File Reference

Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include "BtTypes.hpp"

Include dependency graph for BtAvrcpRawFrameParams.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpRawFrameParams

Defines

#define | BtAvrcpRawFrameParams_hpp

Define Documentation

#define BtAvrcpRawFrameParams_hpp

Generated on Tue Jan 24 19:56:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp Source File

Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpRawFrameParams_hpp)
00009 #define BtAvrcpRawFrameParams_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include "BtTypes.hpp"
00015
00022 class BtAvrcpRawFrameParams
00023 {
00024
00025     public:
00027         BtAvrcpRawFrameParams();
00028
00030         virtual ~BtAvrcpRawFrameParams();
00031
00032         /**********************************************************************/
00033         /* Avrcp Raw Frame Parameters                             */
00034         /**********************************************************************/
00035
00042         const BtAvrcpControlType GetControlType() const { return m_ctype; };
00043
00048         void SetControlType(BtAvrcpControlType ctype) { m_ctype = ctype; };
00049
00053         const BtAvrcpSubunitType GetSubunitType() const { return m_subunit_type; };
00054
00059         void SetSubunitType(BtAvrcpSubunitType subunit_type) { m_subunit_type = subunit_type; };
00060
00064         const UINT8 GetSubunitId() const { return m_subunit_id; };
00065
00070         void SetSubunitId(UINT8 subunit_id) { m_subunit_id = subunit_id; };
00071
00075         const BtAvrcpOpcode GetOpCode() const { return m_opcode; };
00076
00080         const UINT8 GetOperandsLength() const { return m_operands_length; };
00081
00086         void SetOperandsLength(UINT8 operands_length) { m_operands_length = operands_length; };
00087
00091         const UINT8* GetOperands() const { return m_operands; };
00092
00097         BOOLEAN SetOperands(UINT8* operands);
00098
00103         BOOLEAN ReleaseOperands();
00104
00105     private:
00106
00107         BtAvrcpControlType  m_ctype;
00108         BtAvrcpStateFlag    m_state_flag;
00109         BtAvrcpSubunitType  m_subunit_type;
00110         UINT8               m_subunit_id;
00111         BtAvrcpOpcode       m_opcode;
00112         UINT8               m_operands_length;
00113         UINT8*              m_operands;
00114 };
00115
00117 #endif  // BtAvrcpRawFrameParams_hpp
00118
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRawFrameRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpRawFrameRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpRawFrameRequest.hpp"
#include "BtAvrcpOperationService.hpp"

Include dependency graph for BtAvrcpRawFrameRequest.cpp:

Generated on Tue Jan 24 19:56:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp>

Include dependency graph for BtAvrcpRawFrameRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpRawFrameRequest

Defines

#define | BtAvrcpRawFrameRequest_hpp

Define Documentation

#define BtAvrcpRawFrameRequest_hpp

Generated on Tue Jan 24 19:56:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpRawFrameRequest_hpp)
00009 #define BtAvrcpRawFrameRequest_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020 class BtAvrcpOperationService;
00021 class BtAvrcpOperationController;
00022
00023
00026 class BtAvrcpRawFrameRequest : public BtAvrcpRequest
00027 {
00028     private:
00029         typedef BtAvrcpRequest Base;
00030
00031     public:
00033         BtAvrcpRawFrameRequest(BtAvrcpOperationService &avrcp_service);
00034
00036         virtual ~BtAvrcpRawFrameRequest();
00037
00038
00039         void SetRawFrameParams(BtAvrcpRawFrameParams raw_frame_params) { m_raw_frame_params = raw_frame_params; };
00040
00041         BtAvrcpRawFrameParams GetRawFrameParams() const { return m_raw_frame_params; };
00042
00043         void SetResponse(btapi_avrcp_response_code_t response) { m_response = (BtAvrcpResponseType)response; };
00044
00045         BtAvrcpResponseType GetResponse() { return m_response; };
00046
00048         BOOLEAN ReleaseParams();
00050
00052         virtual BtRequestType GetRequestType() const;
00053
00054     protected:
00056
00058         virtual BOOLEAN Execute();
00059
00060
00061     private:
00062
00063         btapi_avrcp_raw_frame_t*    GetApiSettings();
00064         btapi_avrcp_raw_frame_t     m_api_settings;
00065         BtAvrcpRawFrameParams       m_raw_frame_params;
00066         BtAvrcpResponseType         m_response;
00067
00068     private:
00069         friend class BtAvrcpOperationService;
00070         friend class BtAvrcpOperationController;
00071
00072 };
00073
00075 #endif  // BtAvrcpRawFrameRequest_hpp
00076
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegisterParams.cpp File Reference

Bluetooth/AVRCP/BtAvrcpRegisterParams.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpRegisterParams.hpp"

Include dependency graph for BtAvrcpRegisterParams.cpp:

Generated on Tue Jan 24 19:57:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp File Reference

Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>

Include dependency graph for BtAvrcpRegisterParams.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpRegisterParams

Defines

#define | BtAvrcpRegisterParams_hpp

Define Documentation

#define BtAvrcpRegisterParams_hpp

Generated on Tue Jan 24 19:57:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp Source File

Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpRegisterParams_hpp)
00009 #define BtAvrcpRegisterParams_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtTypes.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00020
00021
00028 class BtAvrcpRegisterParams
00029 {
00030
00031     public:
00033         BtAvrcpRegisterParams();
00034
00036         virtual ~BtAvrcpRegisterParams();
00037
00038         /**********************************************************************/
00039         /* Bt Avrcp Unit Info                             */
00040         /**********************************************************************/
00045         void SetRole(BtAvrcpRole role) { m_role = role; };
00046
00051         BtAvrcpRole GetRole() { return m_role; };
00052
00057         const BtAvrcpSubunitType GetUnitType() const { return m_unit_type; };
00058
00064         void SetUnitType(BtAvrcpSubunitType type) { m_unit_type = type; };
00065
00069         const UINT8 GetUnit() const { return m_unit; };
00070
00072
00076         void SetUnit(UINT8 unit) { m_unit = unit; };
00077
00082         const ULONG GetCompanyId() const { return m_company_id; };
00083
00088         void SetCompanyId(ULONG company_id) { m_company_id = company_id; };
00089
00095         const UINT8 GetNoOfSubunits() const { return m_no_of_subunits; };
00096
00100         const BtAvrcpSubunitInfoEntry* GetSubunitInfos() const { return m_subunit_infos; };
00101
00107         void SetSubunitInfos(UINT8 no_of_subunits, BtAvrcpSubunitInfoEntry* subunit_infos);
00108
00113         const UINT8 GetSupportedCategories() const { return m_categories; };
00114
00124         void SetSupportedCategories(UINT8 categories) { m_categories = categories; };
00125
00127         BOOLEAN ReleaseSubunitInfos();
00128
00129     private:
00130         BtAvrcpSubunitType          m_unit_type;
00131         UINT8                       m_unit;
00132         UINT8                       m_categories;
00133         ULONG                       m_company_id;
00134         BtAvrcpRole                 m_role;
00135         UINT8                       m_no_of_subunits;
00136         BtAvrcpSubunitInfoEntry*    m_subunit_infos;
00137 };
00138
00140 #endif  // BtAvrcpRegisterParams_hpp
00141
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegisterRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpRegisterRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpRegistrationController.hpp"
#include "BtAvrcpRegisterRequest.hpp"
#include "BtAvrcpRegistrationService.hpp"

Include dependency graph for BtAvrcpRegisterRequest.cpp:

Generated on Tue Jan 24 19:57:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp>

Include dependency graph for BtAvrcpRegisterRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpRegisterRequest

Defines

#define | BtAvrcpRegisterRequest_hpp

Define Documentation

#define BtAvrcpRegisterRequest_hpp

Generated on Tue Jan 24 19:57:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpRegisterRequest_hpp)
00009 #define BtAvrcpRegisterRequest_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020 class BtAvrcpRegistrationService;
00021 class BtAvrcpRegistrationController;
00022
00023
00026 class BtAvrcpRegisterRequest : public BtAvrcpRequest
00027 {
00028     private:
00029         typedef BtAvrcpRequest Base;
00030
00031     public:
00033         BtAvrcpRegisterRequest(BtAvrcpRegistrationService& avrcp_service);
00034
00036         virtual ~BtAvrcpRegisterRequest();
00037
00038         void SetRegisterParams(BtAvrcpRegisterParams register_params) { m_register_params = register_params; };
00039
00040         BtAvrcpRegisterParams GetRegisterParams() const { return m_register_params; };
00041
00043         BOOLEAN ReleaseParams();
00045
00047         virtual BtRequestType GetRequestType() const;
00048
00049     protected:
00051
00053         virtual BOOLEAN Execute();
00054
00055
00056     private:
00057         btapi_avrcp_service_unit_info_t*    GetApiSettings();
00058         btapi_avrcp_service_unit_info_t     m_api_settings;
00059         BtAvrcpRegisterParams               m_register_params;
00060
00061     private:
00062         friend class BtAvrcpRegistrationService;
00063         friend class BtAvrcpRegistrationController;
00064
00065 };
00066
00068 #endif  // BtAvrcpRegisterRequest_hpp
00069
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegistrationController.cpp File Reference

Bluetooth/AVRCP/BtAvrcpRegistrationController.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpRegistrationController.hpp"
#include "BtAvrcpService.hpp"
#include "BtAvrcpRegisterRequest.hpp"
#include "BtAvrcpDeRegisterRequest.hpp"

Include dependency graph for BtAvrcpRegistrationController.cpp:

Defines

#define | DBG_STATE
#define | DBG_STATE_STATIC

Define Documentation

#define DBG_STATE

#define DBG_STATE_STATIC

Generated on Tue Jan 24 19:57:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegistrationController.hpp File Reference

Bluetooth/AVRCP/BtAvrcpRegistrationController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtAvrcpRegistrationController_hpp

Define Documentation

#define BtAvrcpRegistrationController_hpp

Generated on Tue Jan 24 19:57:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegistrationController.hpp Source File

Bluetooth/AVRCP/BtAvrcpRegistrationController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpRegistrationController_hpp)
00009 #define BtAvrcpRegistrationController_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <stack/extensions.h>
00021 #include <Bluetooth/BtTypes.hpp>
00022 #include <Bluetooth/BtConnectionlessController.hpp>
00023 #include <Bluetooth/BtServiceRequest.hpp>
00024 #include <Bluetooth/AVRCP/BtTypes.hpp>
00025
00026 /*  ------------------------------------------------------------------------
00027     Forward deklarations for friend relationships.
00028     ------------------------------------------------------------------------ */
00029
00030 class BtAvrcpRegisterRequest;
00031 class BtAvrcpDeRegisterRequest;
00032
00037 class BtAvrcpRegistrationController : public BtConnectionlessController
00038 {
00039     private:
00040         typedef BtConnectionlessController Base;
00041
00042     public:
00044
00049         static BtAvrcpRegistrationController& GetInstance();
00050
00051     public:
00053         virtual ~BtAvrcpRegistrationController();
00054
00056
00058         virtual const WCHAR* GetName() const;
00059
00060
00061     private:
00062
00066         BOOLEAN RegisterApplication(BtAvrcpRegisterRequest *reg_app_req);
00067
00071         BOOLEAN DeRegisterApplication(BtAvrcpDeRegisterRequest *dereg_app_req);
00072
00073     private:
00074
00075
00076         /*---------------------------------------------------------------------*/
00077         /* The following functions must not be called by an application.       */
00078         /* They are the entry point from the stack callback functions into our */
00079         /* object orientated framework (APOXI).                                */
00080         /* They are implemented as static because they have to be passed as    */
00081         /* normal C function pointers. The reason for this is the BT-API Stack */
00082         /* interface that demands C function pointers for callback the         */
00083         /* callback functions it calls to state the progress of ongoing        */
00084         /* operations                                                          */
00085         /*---------------------------------------------------------------------*/
00086
00090         static void OnAvrcpRegisterCfmCb(btapi_result_t result, void *app_handle);
00091
00092
00096         static void OnAvrcpDeRegisterCfmCb(btapi_result_t result, void *app_handle);
00097
00098
00099     private:
00101         BtAvrcpRegistrationController();
00102
00104
00106         virtual void Register();
00107
00109
00111         virtual void Unregister();
00112
00113     private:
00114         btapi_avrcpcb_funp_t* m_avrcp_callback_functions;
00115
00116     private:
00117
00118         static BtAvrcpRegistrationController m_controller;
00119
00120     private:
00121
00122         friend class BtAvrcpRegisterRequest;
00123         friend class BtAvrcpDeRegisterRequest;
00124 };
00125
00127 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00128 #endif  // BtAvrcpRegistrationController_hpp
00129
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegistrationService.cpp File Reference

Bluetooth/AVRCP/BtAvrcpRegistrationService.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpRegistrationService.hpp"
#include "BtAvrcpRegistrationController.hpp"
#include "BtAvrcpServiceMessage.hpp"

Include dependency graph for BtAvrcpRegistrationService.cpp:

Generated on Tue Jan 24 19:57:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp File Reference

Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp File Reference

#include <Bluetooth/AVRCP/BtAvrcpService.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp>

Include dependency graph for BtAvrcpRegistrationService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpRegistrationService

Defines

#define | BtAvrcpRegistrationService_hpp

Define Documentation

#define BtAvrcpRegistrationService_hpp

Generated on Tue Jan 24 19:57:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp Source File

Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtAvrcpRegistrationService_hpp)
00010 #define BtAvrcpRegistrationService_hpp
00013
00014 #include <Bluetooth/AVRCP/BtAvrcpService.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp>
00016 #include <Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp>
00017 #include <Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp>
00018
00024 class BtAvrcpRegistrationService : public BtAvrcpService
00025 {
00026     private:
00027         typedef BtAvrcpService Base;
00028
00029     public:
00031         BtAvrcpRegistrationService();
00032
00034         virtual ~BtAvrcpRegistrationService();
00035
00039         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00040
00046         void RegisterRequest(BtAvrcpRegisterParams unit_info);
00047
00053         void DeRegisterRequest(BtAvrcpRole role);
00054
00055
00056     protected:
00058         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00059
00060     private:
00062         BtAvrcpRegisterRequest      m_register_request;
00063         BtAvrcpDeRegisterRequest    m_deregister_request;
00064 };
00065
00067 #endif  // BtAvrcpRegistrationService_hpp
00068
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpService.hpp"
#include "BtAvrcpRequest.hpp"

Include dependency graph for BtAvrcpRequest.cpp:

Generated on Tue Jan 24 19:57:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpRequest.hpp File Reference

#include <Bluetooth/BtServiceRequest.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>

Include dependency graph for BtAvrcpRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpRequest

Defines

#define | BtAvrcpRequest_hpp

Define Documentation

#define BtAvrcpRequest_hpp

Generated on Tue Jan 24 19:57:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtAvrcpRequest_hpp)
00010 #define BtAvrcpRequest_hpp
00013
00014 #include <Bluetooth/BtServiceRequest.hpp>
00015 #include <Bluetooth/AVRCP/BtTypes.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020
00021 class BtAvrcpOperationController;
00022 class BtAvrcpService;
00023
00026 class BtAvrcpRequest : public BtServiceRequest
00027 {
00028     private:
00029         typedef BtServiceRequest Base;
00030
00031     public:
00033         BtAvrcpRequest(BtAvrcpService& avrcp_service);
00034
00036         virtual ~BtAvrcpRequest();
00037
00038 #ifdef _XXX_
00039
00041         void SetRequestResponse(btapi_avrcp_response_t response) { m_request_response = (BtAvrcpResponseType)response; };
00042
00044         const BtAvrcpResponseType GetRequestResponse() const { return m_request_response; };
00045 #endif
00046
00047     protected:
00049
00062         virtual BtRequestState ChangeRequestState(BOOLEAN success);
00063
00064     private:
00065         BtAvrcpResponseType m_request_response;
00066
00067     private:
00068         friend class BtAvrcpOperationController;
00069         friend class BtAvrcpService;
00070 };
00071
00073 #endif  // BtAvrcpRequest_hpp
00074
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpService.cpp File Reference

Bluetooth/AVRCP/BtAvrcpService.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpService.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpServiceMessage.hpp"

Include dependency graph for BtAvrcpService.cpp:

Generated on Tue Jan 24 19:57:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpService.hpp File Reference

Bluetooth/AVRCP/BtAvrcpService.hpp File Reference

#include <Bluetooth/BtService.hpp>

Include dependency graph for BtAvrcpService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpService

Defines

#define | BtAvrcpService_hpp

Define Documentation

#define BtAvrcpService_hpp

Generated on Tue Jan 24 19:57:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpService.hpp Source File

Bluetooth/AVRCP/BtAvrcpService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtAvrcpService_hpp)
00010 #define BtAvrcpService_hpp
00013
00014 #include <Bluetooth/BtService.hpp>
00015
00018 class BtAvrcpService : public BtService
00019 {
00020     private:
00021         typedef BtService Base;
00022
00023     public:
00025         BtAvrcpService();
00026
00028         virtual ~BtAvrcpService();
00029
00031
00033         virtual void Init();
00034
00036
00041         virtual BtProfile GetProfile() const;
00042
00043
00044     protected:
00046
00048         virtual BOOLEAN OnMessage(const Message& message);
00049
00051
00053         virtual void RegisterMessages() const;
00054
00056
00058         virtual void UnregisterMessages() const;
00059
00060 };
00061
00063 #endif  // BtAvrcpService_hpp
00064
Generated on Tue Jan 24 14:48:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpServiceMessage.cpp File Reference

Bluetooth/AVRCP/BtAvrcpServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpServiceMessage.hpp"

Include dependency graph for BtAvrcpServiceMessage.cpp:

Generated on Tue Jan 24 19:57:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpServiceMessage.hpp File Reference

Bluetooth/AVRCP/BtAvrcpServiceMessage.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtAvrcpServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpRequestStateChangedMessage

Defines

#define | Bluetooth_BtAvrcpServiceMessage_hpp

Define Documentation

#define Bluetooth_BtAvrcpServiceMessage_hpp

Generated on Tue Jan 24 19:57:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpServiceMessage.hpp Source File

Bluetooth/AVRCP/BtAvrcpServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\bt_avrcp_multiconnection\lnz_apoxi\Apoxi\Bluetooth\AVRCP\BtAvrcpServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Bluetooth_BtAvrcpServiceMessage_hpp)
00014 #define Bluetooth_BtAvrcpServiceMessage_hpp
00015 #include <Bluetooth/BtServiceMessage.hpp>
00016 /* ----------------------------------------------------------------------
00017     Classes
00018     ---------------------------------------------------------------------- */
00019 /*  ======================================================================
00020     Class BtAvrcpRequestStateChangedMessage
00021     ====================================================================== */
00023 class BtAvrcpRequestStateChangedMessage : public BtRequestStateChangedMessage {
00024     public:
00025         BtAvrcpRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00026         virtual ~BtAvrcpRequestStateChangedMessage();
00027
00028         virtual const MsgMetaData& GetMetaData() const;
00029         virtual Message* Clone() const;
00030
00031         enum  {
00032             ID = 10455
00033             };
00034
00035     private:
00036         static const MsgMetaData m_meta_data;
00037
00038     };
00039 #endif // Bluetooth_BtAvrcpServiceMessage_hpp
00040
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.cpp File Reference

Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpSubunitInfoParams.hpp"

Include dependency graph for BtAvrcpSubunitInfoParams.cpp:

Generated on Tue Jan 24 19:57:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp File Reference

Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>

Include dependency graph for BtAvrcpSubunitInfoParams.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpSubunitInfoParams

Defines

#define | BtAvrcpSubunitInfoParams_hpp

Define Documentation

#define BtAvrcpSubunitInfoParams_hpp

Generated on Tue Jan 24 19:57:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp Source File

Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpSubunitInfoParams_hpp)
00009 #define BtAvrcpSubunitInfoParams_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtTypes.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00021
00022
00025 class BtAvrcpSubunitInfoParams
00026 {
00027
00028     public:
00030         BtAvrcpSubunitInfoParams();
00031
00032
00034         virtual ~BtAvrcpSubunitInfoParams();
00035
00036         /**********************************************************************/
00037         /* Bt Avrcp Sub Unit Info                             */
00038         /**********************************************************************/
00039
00041
00043         const UINT8 GetPage() const { return m_page; };
00044
00046
00048         void SetPage(UINT8 page) { m_page = page; };
00049
00051
00053         const UINT8 GetNoOfSubunitInfoEntries() const { return m_no_of_subunit_info_entries; };
00054
00056
00058         void SetNoOfSubunitInfoEntries(UINT8 no_of_subunit_info_entries) { m_no_of_subunit_info_entries = no_of_subunit_info_entries; };
00059
00061
00063         const BtAvrcpSubunitInfoEntry* GetSubunitInfoEntries() const { return m_subunit_info_entries; };
00064
00066
00068         void SetSubunitInfoEntries(BtAvrcpSubunitInfoEntry* subunit_info_entries);
00069
00070
00071     private:
00072
00073         UINT8                   m_page;
00074         UINT8                   m_no_of_subunit_info_entries;
00075         BtAvrcpSubunitInfoEntry m_subunit_info_entries[4];
00076
00077 };
00078
00080 #endif  // BtAvrcpSubunitInfoParams_hpp
00081
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpSubunitInfoRequest.hpp"
#include "BtAvrcpOperationService.hpp"

Include dependency graph for BtAvrcpSubunitInfoRequest.cpp:

Generated on Tue Jan 24 19:57:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp>

Include dependency graph for BtAvrcpSubunitInfoRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpSubunitInfoRequest

Defines

#define | BtAvrcpSubunitInfoRequest_hpp

Define Documentation

#define BtAvrcpSubunitInfoRequest_hpp

Generated on Tue Jan 24 19:57:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpSubunitInfoRequest_hpp)
00009 #define BtAvrcpSubunitInfoRequest_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020 class BtAvrcpOperationService;
00021 class BtAvrcpOperationController;
00022
00023
00026 class BtAvrcpSubunitInfoRequest : public BtAvrcpRequest
00027 {
00028     private:
00029         typedef BtAvrcpRequest Base;
00030
00031     public:
00033         BtAvrcpSubunitInfoRequest(BtAvrcpOperationService& avrcp_service);
00034
00036         virtual ~BtAvrcpSubunitInfoRequest();
00037
00039
00041         virtual BtRequestType GetRequestType() const;
00042
00043         //BtAvrcpSubunitInfoParams
00044         BtAvrcpSubunitInfoParams GetSubunitInfoParams() { return m_subunit_info_params; };
00045
00046         void SetSubunitInfoParams(BtAvrcpSubunitInfoParams subunit_info_params) { m_subunit_info_params = subunit_info_params; };
00047
00048         BtAvrcpResponseType GetResponse() { return m_response; };
00049
00050         void SetResponse(btapi_avrcp_response_code_t response) { m_response = (BtAvrcpResponseType)response; };
00051
00052
00053     protected:
00055
00057         virtual BOOLEAN Execute();
00058
00059
00060     private:
00061         btapi_u8_t GetApiSettings() { return (btapi_u8_t)m_subunit_info_params.GetPage(); };
00062         void SetPage(UINT8 page)    { m_subunit_info_params.SetPage(page); };
00063
00064     private:
00065         BtAvrcpSubunitInfoParams    m_subunit_info_params;
00066         BtAvrcpResponseType         m_response;
00067
00068     private:
00069         friend class BtAvrcpOperationService;
00070         friend class BtAvrcpOperationController;
00071
00072 };
00073
00075 #endif  // BtAvrcpSubunitInfoRequest_hpp
00076
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpUnitInfoParams.cpp File Reference

Bluetooth/AVRCP/BtAvrcpUnitInfoParams.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpUnitInfoParams.hpp"

Include dependency graph for BtAvrcpUnitInfoParams.cpp:

Generated on Tue Jan 24 19:57:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp File Reference

Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>

Include dependency graph for BtAvrcpUnitInfoParams.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpUnitInfoParams

Defines

#define | BtAvrcpUnitInfoParams_hpp

Define Documentation

#define BtAvrcpUnitInfoParams_hpp

Generated on Tue Jan 24 19:57:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp Source File

Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpUnitInfoParams_hpp)
00009 #define BtAvrcpUnitInfoParams_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtTypes.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00020
00021
00024 class BtAvrcpUnitInfoParams
00025 {
00026
00027     public:
00029         BtAvrcpUnitInfoParams();
00030
00032         virtual ~BtAvrcpUnitInfoParams();
00033
00034         /**********************************************************************/
00035         /* Bt Avrcp Unit Info                             */
00036         /**********************************************************************/
00037
00039
00041         const BtAvrcpSubunitType GetUnitType() const { return m_unit_type; };
00042
00044
00046         void SetUnitType(BtAvrcpSubunitType type) { m_unit_type = type; };
00047
00049
00051         const UINT8 GetUnit() const { return m_unit; };
00052
00054
00056         void SetUnit(UINT8 unit) { m_unit = unit; };
00057
00059
00061         const ULONG GetCompanyId() const { return m_company_id; };
00062
00064
00066         void SetCompanyId(ULONG company_id) { m_company_id = company_id; };
00067
00068     private:
00069         BtAvrcpSubunitType          m_unit_type;
00070         UINT8                       m_unit;
00071         ULONG                       m_company_id;
00072 };
00073
00075 #endif  // BtAvrcpUnitInfoParams_hpp
00076
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.cpp File Reference

Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtAvrcpOperationController.hpp"
#include "BtAvrcpOperationService.hpp"
#include "BtAvrcpUnitInfoRequest.hpp"

Include dependency graph for BtAvrcpUnitInfoRequest.cpp:

Generated on Tue Jan 24 19:57:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp File Reference

Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
#include <Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp>

Include dependency graph for BtAvrcpUnitInfoRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpUnitInfoRequest

Defines

#define | BtAvrcpUnitInfoRequest_hpp

Define Documentation

#define BtAvrcpUnitInfoRequest_hpp

Generated on Tue Jan 24 19:57:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp Source File

Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpUnitInfoRequest_hpp)
00009 #define BtAvrcpUnitInfoRequest_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/AVRCP/BtAvrcpRequest.hpp>
00015 #include <Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020 class BtAvrcpOperationService;
00021 class BtAvrcpOperationController;
00022
00023
00026 class BtAvrcpUnitInfoRequest : public BtAvrcpRequest
00027 {
00028     private:
00029         typedef BtAvrcpRequest Base;
00030
00031     public:
00033         BtAvrcpUnitInfoRequest(BtAvrcpOperationService& avrcp_service);
00034
00036         virtual ~BtAvrcpUnitInfoRequest();
00037
00039
00041         virtual BtRequestType GetRequestType() const;
00042
00043         BtAvrcpUnitInfoParams GetUnitInfoParams();
00044
00045         void SetUnitInfoParams(BtAvrcpUnitInfoParams unit_info_params) { m_unit_info_params = unit_info_params; };
00046
00047         BtAvrcpResponseType GetResponse() { return m_response; };
00048
00049         void SetResponse(btapi_avrcp_response_code_t response) { m_response = (BtAvrcpResponseType)response; };
00050
00051     protected:
00053
00055         virtual BOOLEAN Execute();
00056
00057
00058     private:
00059
00060         BtAvrcpUnitInfoParams       m_unit_info_params;
00061         BtAvrcpResponseType         m_response;
00062
00063     private:
00064         friend class BtAvrcpOperationService;
00065         friend class BtAvrcpOperationController;
00066
00067 };
00068
00070 #endif  // BtAvrcpUnitInfoRequest_hpp
00071
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtTypes.hpp File Reference

Bluetooth/AVRCP/BtTypes.hpp File Reference

#include <stack/extensions.h>

Include dependency graph for BtTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | BtAvrcpSubunitInfoEntry

Defines

#define | BtAvrcpTypes_hpp

Enumerations

enum | BtAvrcpCategory { BtAcCategory1 = BTAPI_AVRCP_CATEGORY_1, BtAcCategory2 = BTAPI_AVRCP_CATEGORY_2, BtAcCategory3 = BTAPI_AVRCP_CATEGORY_3, BtAcCategory4 = BTAPI_AVRCP_CATEGORY_4 }
enum | BtAvrcpCommand { BtAcConnect, BtAcDisconnect, BtAcNotCongested }
General commands to be sent to the target. More...
enum BtAvrcpControlType {
BtActControl = BTAPI_AVRCP_CTYPE_CONTROL, BtActStatus = BTAPI_AVRCP_CTYPE_STATUS, BtActSpecificInquiry = BTAPI_AVRCP_CTYPE_SPECIFIC_INQUIRY, BtActNotify = BTAPI_AVRCP_CTYPE_NOTIFY,
BtActGeneralInquiry = BTAPI_AVRCP_CTYPE_GENERAL_INQUIRY
}
State the type of the operation. More...
enum | BtAvrcpOpcode { BtAocUnitInfo = BTAPI_AVRCP_OPCODE_UNIT_INFO, BtAocSubunitInfo = BTAPI_AVRCP_OPCODE_SUBUNIT_INFO, BtAocVendorDependent = BTAPI_AVRCP_OPCODE_VENDOR_DEPENDENT, BtAocPanelPassThrough = BTAPI_AVRCP_OPCODE_PANEL_PASS_THROUGH }
Operational code. More...
enum BtAvrcpOperation {
BtAoSelect = BTAPI_AVRCP_OP_SELECT, BtAoUp = BTAPI_AVRCP_OP_UP, BtAoDown = BTAPI_AVRCP_OP_DOWN, BtAoLeft = BTAPI_AVRCP_OP_LEFT,
BtAoRight = BTAPI_AVRCP_OP_RIGHT, BtAoRightUp = BTAPI_AVRCP_OP_RIGHT_UP, BtAoRightDown = BTAPI_AVRCP_OP_RIGHT_DOWN, BtAoLeftUp = BTAPI_AVRCP_OP_LEFT_UP,
BtApLeftDown = BTAPI_AVRCP_OP_LEFT_DOWN, BtAoRootMenu = BTAPI_AVRCP_OP_ROOT_MENU, BtAoSetupMenu = BTAPI_AVRCP_OP_SETUP_MENU, BtAoContentsMenu = BTAPI_AVRCP_OP_CONTENTS_MENU,
BtAoFavouriteMenu = BTAPI_AVRCP_OP_FAVORITE_MENU, BtAoExit = BTAPI_AVRCP_OP_EXIT, BtAo0 = BTAPI_AVRCP_OP_0, BtAo1 = BTAPI_AVRCP_OP_1,
BtAo2 = BTAPI_AVRCP_OP_2, BtAo3 = BTAPI_AVRCP_OP_3, BtAo4 = BTAPI_AVRCP_OP_4, BtAo5 = BTAPI_AVRCP_OP_5,
BtAo6 = BTAPI_AVRCP_OP_6, BtAo7 = BTAPI_AVRCP_OP_7, BtAo8 = BTAPI_AVRCP_OP_8, BtAo9 = BTAPI_AVRCP_OP_9,
BtAoDot = BTAPI_AVRCP_OP_DOT, BtAoEnter = BTAPI_AVRCP_OP_ENTER, BtAoClear = BTAPI_AVRCP_OP_CLEAR, BtAoChannelUp = BTAPI_AVRCP_OP_CHANNEL_UP,
BtAoChannelDown = BTAPI_AVRCP_OP_CHANNEL_DOWN, BtAoPrevChannel = BTAPI_AVRCP_OP_PREVIOUS_CHANNEL, BtAoSoundSelect = BTAPI_AVRCP_OP_SOUND_SELECT, BtAoInputSelect = BTAPI_AVRCP_OP_INPUT_SELECT,
BtAoDisplayInfo = BTAPI_AVRCP_OP_DISPLAY_INFORMATION, BtAoHelp = BTAPI_AVRCP_OP_HELP, BtAoPageUp = BTAPI_AVRCP_OP_PAGE_UP, BtAoPageDown = BTAPI_AVRCP_OP_PAGE_DOWN,
BtAoPower = BTAPI_AVRCP_OP_POWER, BtAoVolumeUp = BTAPI_AVRCP_OP_VOLUME_UP, BtAoVolumeDown = BTAPI_AVRCP_OP_VOLUME_DOWN, BtAoMute = BTAPI_AVRCP_OP_MUTE,
BtAoPlay = BTAPI_AVRCP_OP_PLAY, BtAoStop = BTAPI_AVRCP_OP_STOP, BtAoPause = BTAPI_AVRCP_OP_PAUSE, BtAoRecord = BTAPI_AVRCP_OP_RECORD,
BtAoRewind = BTAPI_AVRCP_OP_REWIND, BtAoFastForward = BTAPI_AVRCP_OP_FAST_FORWARD, BtAoEject = BTAPI_AVRCP_OP_EJECT, BtAoForward = BTAPI_AVRCP_OP_FORWARD,
BtAoBackward = BTAPI_AVRCP_OP_BACKWARD, BtAoAngle = BTAPI_AVRCP_OP_ANGLE, BtAoSubpicture = BTAPI_AVRCP_OP_SUBPICTURE, BtAoF1 = BTAPI_AVRCP_OP_F1,
BtAoF2 = BTAPI_AVRCP_OP_F2, BtAoF3 = BTAPI_AVRCP_OP_F3, BtAoF4 = BTAPI_AVRCP_OP_F4, BtAoF5 = BTAPI_AVRCP_OP_F5,
BaAoVendorUnique = BTAPI_AVRCP_OP_VENDOR_UNIQUE, BtAoNotDefined = BTAPI_AVRCP_OPERATION_NOT_DEFINED
}
enum BtAvrcpResponseType {
BtArNotImplemented = BTAPI_AVRCP_RESPONSE_NOT_IMPLEMENTED, BtArAccepted = BTAPI_AVRCP_RESPONSE_ACCEPTED, BtArRejected = BTAPI_AVRCP_RESPONSE_REJECTED, BtArInTransition = BTAPI_AVRCP_RESPONSE_IN_TRANSITION,
BtArImplementedStable = BTAPI_AVRCP_RESPONSE_IMPLEMENTED_STABLE, BtArResponseChanged = BTAPI_AVRCP_RESPONSE_CHANGED, BtArInterim = BTAPI_AVRCP_RESPONSE_INTERIM, BtArNotDefined = 99
}
enum | BtAvrcpRole { BtAroleController = BTAPI_AVRCP_CONTROLLER, BtAroleTarget = BTAPI_AVRCP_TARGET }
enum | BtAvrcpStateFlag { BtAsfButtonPress = BTAPI_AVRCP_BUTTON_PRESS, BtAsfButtonRelease = BTAPI_AVRCP_BUTTON_RELEASE }
Stateflag for button states (pressed, released). More...
enum BtAvrcpSubunitType {
BtAstMonitor = BTAPI_AVRCP_SUBUNIT_MONITOR, BtAstAudio = BTAPI_AVRCP_SUBUNIT_AUDIO, BtAstPrinter = BTAPI_AVRCP_SUBUNIT_PRINTER, BtAstDisc = BTAPI_AVRCP_SUBUNIT_DISC,
BtAstTapeRecPlayer = BTAPI_AVRCP_SUBUNIT_TAPE_RECORDER_PLAYER, BtAstTuner = BTAPI_AVRCP_SUBUNIT_TUNER, BtAstCa = BTAPI_AVRCP_SUBUNIT_CA, BtAstCamera = BTAPI_AVRCP_SUBUNIT_CAMERA,
BtAstPanel = BTAPI_AVRCP_SUBUNIT_PANEL, BtAstBulletinBoard = BTAPI_AVRCP_SUBUNIT_BULLETIN_BOARD, BtAstCameraStorage = BTAPI_AVRCP_SUBUNIT_CAMERA_STORAGE, BtAstVendorUnique = BTAPI_AVRCP_SUBUNIT_VENDOR_UNIQUE,
BtAstUnit = BTAPI_AVRCP_SUBUNIT_UNIT
}
Describes the type of a subunit which is implemented. More...

Define Documentation

#define BtAvrcpTypes_hpp

Generated on Tue Jan 24 19:57:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/BtTypes.hpp Source File

Bluetooth/AVRCP/BtTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpTypes_hpp)
00009 #define BtAvrcpTypes_hpp
00012
00013 #include <stack/extensions.h>
00014
00015
00016 /*  ------------------------------------------------------------------------
00017     Enums
00018     ------------------------------------------------------------------------ */
00019
00021 enum BtAvrcpCommand {
00022     BtAcConnect,
00023     BtAcDisconnect,
00024     BtAcNotCongested
00025 };
00026
00027 // Roles defined in AVRCP
00028 enum BtAvrcpRole {
00029     BtAroleController   = BTAPI_AVRCP_CONTROLLER,
00030     BtAroleTarget       = BTAPI_AVRCP_TARGET
00031 };
00032
00037 enum BtAvrcpCategory {
00038     BtAcCategory1       =   BTAPI_AVRCP_CATEGORY_1,
00039     BtAcCategory2       =   BTAPI_AVRCP_CATEGORY_2,
00040     BtAcCategory3       =   BTAPI_AVRCP_CATEGORY_3,
00041     BtAcCategory4       =   BTAPI_AVRCP_CATEGORY_4
00042 };
00043
00045 enum BtAvrcpStateFlag {
00046     BtAsfButtonPress   = BTAPI_AVRCP_BUTTON_PRESS,
00047     BtAsfButtonRelease = BTAPI_AVRCP_BUTTON_RELEASE
00048 };
00049
00052 enum BtAvrcpResponseType {
00053     BtArNotImplemented    = BTAPI_AVRCP_RESPONSE_NOT_IMPLEMENTED,
00054     BtArAccepted          = BTAPI_AVRCP_RESPONSE_ACCEPTED,
00055     BtArRejected          = BTAPI_AVRCP_RESPONSE_REJECTED,
00056     BtArInTransition      = BTAPI_AVRCP_RESPONSE_IN_TRANSITION,
00057     BtArImplementedStable = BTAPI_AVRCP_RESPONSE_IMPLEMENTED_STABLE,
00058     BtArResponseChanged   = BTAPI_AVRCP_RESPONSE_CHANGED,
00059     BtArInterim           = BTAPI_AVRCP_RESPONSE_INTERIM,
00060     BtArNotDefined        = 99
00061 };
00062
00066 enum BtAvrcpOperation {
00067     BtAoSelect        = BTAPI_AVRCP_OP_SELECT,
00068     BtAoUp            = BTAPI_AVRCP_OP_UP,
00069     BtAoDown          = BTAPI_AVRCP_OP_DOWN,
00070     BtAoLeft          = BTAPI_AVRCP_OP_LEFT,
00071     BtAoRight         = BTAPI_AVRCP_OP_RIGHT,
00072     BtAoRightUp       = BTAPI_AVRCP_OP_RIGHT_UP,
00073     BtAoRightDown     = BTAPI_AVRCP_OP_RIGHT_DOWN,
00074     BtAoLeftUp        = BTAPI_AVRCP_OP_LEFT_UP,
00075     BtApLeftDown      = BTAPI_AVRCP_OP_LEFT_DOWN,
00076     BtAoRootMenu      = BTAPI_AVRCP_OP_ROOT_MENU,
00077     BtAoSetupMenu     = BTAPI_AVRCP_OP_SETUP_MENU,
00078     BtAoContentsMenu  = BTAPI_AVRCP_OP_CONTENTS_MENU,
00079     BtAoFavouriteMenu = BTAPI_AVRCP_OP_FAVORITE_MENU,
00080     BtAoExit          = BTAPI_AVRCP_OP_EXIT,
00081     BtAo0             = BTAPI_AVRCP_OP_0,
00082     BtAo1             = BTAPI_AVRCP_OP_1,
00083     BtAo2             = BTAPI_AVRCP_OP_2,
00084     BtAo3             = BTAPI_AVRCP_OP_3,
00085     BtAo4             = BTAPI_AVRCP_OP_4,
00086     BtAo5             = BTAPI_AVRCP_OP_5,
00087     BtAo6             = BTAPI_AVRCP_OP_6,
00088     BtAo7             = BTAPI_AVRCP_OP_7,
00089     BtAo8             = BTAPI_AVRCP_OP_8,
00090     BtAo9             = BTAPI_AVRCP_OP_9,
00091     BtAoDot           = BTAPI_AVRCP_OP_DOT,
00092     BtAoEnter         = BTAPI_AVRCP_OP_ENTER,
00093     BtAoClear         = BTAPI_AVRCP_OP_CLEAR,
00094     BtAoChannelUp     = BTAPI_AVRCP_OP_CHANNEL_UP,
00095     BtAoChannelDown   = BTAPI_AVRCP_OP_CHANNEL_DOWN,
00096     BtAoPrevChannel   = BTAPI_AVRCP_OP_PREVIOUS_CHANNEL,
00097     BtAoSoundSelect   = BTAPI_AVRCP_OP_SOUND_SELECT,
00098     BtAoInputSelect   = BTAPI_AVRCP_OP_INPUT_SELECT,
00099     BtAoDisplayInfo   = BTAPI_AVRCP_OP_DISPLAY_INFORMATION,
00100     BtAoHelp          = BTAPI_AVRCP_OP_HELP,
00101     BtAoPageUp        = BTAPI_AVRCP_OP_PAGE_UP,
00102     BtAoPageDown      = BTAPI_AVRCP_OP_PAGE_DOWN,
00103     BtAoPower         = BTAPI_AVRCP_OP_POWER,
00104     BtAoVolumeUp      = BTAPI_AVRCP_OP_VOLUME_UP,
00105     BtAoVolumeDown    = BTAPI_AVRCP_OP_VOLUME_DOWN,
00106     BtAoMute          = BTAPI_AVRCP_OP_MUTE,
00107     BtAoPlay          = BTAPI_AVRCP_OP_PLAY,
00108     BtAoStop          = BTAPI_AVRCP_OP_STOP,
00109     BtAoPause         = BTAPI_AVRCP_OP_PAUSE,
00110     BtAoRecord        = BTAPI_AVRCP_OP_RECORD,
00111     BtAoRewind        = BTAPI_AVRCP_OP_REWIND,
00112     BtAoFastForward   = BTAPI_AVRCP_OP_FAST_FORWARD,
00113     BtAoEject         = BTAPI_AVRCP_OP_EJECT,
00114     BtAoForward       = BTAPI_AVRCP_OP_FORWARD,
00115     BtAoBackward      = BTAPI_AVRCP_OP_BACKWARD,
00116     BtAoAngle         = BTAPI_AVRCP_OP_ANGLE,
00117     BtAoSubpicture    = BTAPI_AVRCP_OP_SUBPICTURE,
00118     BtAoF1            = BTAPI_AVRCP_OP_F1,
00119     BtAoF2            = BTAPI_AVRCP_OP_F2,
00120     BtAoF3            = BTAPI_AVRCP_OP_F3,
00121     BtAoF4            = BTAPI_AVRCP_OP_F4,
00122     BtAoF5            = BTAPI_AVRCP_OP_F5,
00123     BaAoVendorUnique  = BTAPI_AVRCP_OP_VENDOR_UNIQUE,
00124     BtAoNotDefined    = BTAPI_AVRCP_OPERATION_NOT_DEFINED
00125 };
00126
00128 enum BtAvrcpControlType {
00129     BtActControl         = BTAPI_AVRCP_CTYPE_CONTROL,
00130     BtActStatus          = BTAPI_AVRCP_CTYPE_STATUS,
00131     BtActSpecificInquiry = BTAPI_AVRCP_CTYPE_SPECIFIC_INQUIRY,
00132     BtActNotify          = BTAPI_AVRCP_CTYPE_NOTIFY,
00133     BtActGeneralInquiry  = BTAPI_AVRCP_CTYPE_GENERAL_INQUIRY
00134 };
00135
00137 enum BtAvrcpSubunitType {
00138     BtAstMonitor       = BTAPI_AVRCP_SUBUNIT_MONITOR,
00139     BtAstAudio         = BTAPI_AVRCP_SUBUNIT_AUDIO,
00140     BtAstPrinter       = BTAPI_AVRCP_SUBUNIT_PRINTER,
00141     BtAstDisc          = BTAPI_AVRCP_SUBUNIT_DISC,
00142     BtAstTapeRecPlayer = BTAPI_AVRCP_SUBUNIT_TAPE_RECORDER_PLAYER,
00143     BtAstTuner         = BTAPI_AVRCP_SUBUNIT_TUNER,
00144     BtAstCa            = BTAPI_AVRCP_SUBUNIT_CA,
00145     BtAstCamera        = BTAPI_AVRCP_SUBUNIT_CAMERA,
00146     BtAstPanel         = BTAPI_AVRCP_SUBUNIT_PANEL,
00147     BtAstBulletinBoard = BTAPI_AVRCP_SUBUNIT_BULLETIN_BOARD,
00148     BtAstCameraStorage = BTAPI_AVRCP_SUBUNIT_CAMERA_STORAGE,
00149     BtAstVendorUnique  = BTAPI_AVRCP_SUBUNIT_VENDOR_UNIQUE,
00150     BtAstUnit          = BTAPI_AVRCP_SUBUNIT_UNIT
00151 };
00152
00154 enum BtAvrcpOpcode {
00155     BtAocUnitInfo         = BTAPI_AVRCP_OPCODE_UNIT_INFO,
00156     BtAocSubunitInfo      = BTAPI_AVRCP_OPCODE_SUBUNIT_INFO,
00157     BtAocVendorDependent  = BTAPI_AVRCP_OPCODE_VENDOR_DEPENDENT,
00158     BtAocPanelPassThrough = BTAPI_AVRCP_OPCODE_PANEL_PASS_THROUGH
00159 };
00160
00161 /*  ------------------------------------------------------------------------
00162     Structures
00163     ------------------------------------------------------------------------ */
00164
00168 typedef struct {
00169     BtAvrcpSubunitType m_subunit_type;
00170     UINT8              m_max_subunit_id;
00171 } BtAvrcpSubunitInfoEntry;
00172
00173 #endif // BtAvrcpTypes_hpp
00174
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/PreComp.cpp File Reference

Bluetooth/AVRCP/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/PreComp.hpp File Reference

Bluetooth/AVRCP/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/AVRCP/PreComp.hpp Source File

Bluetooth/AVRCP/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Bluetooth/Lib.hpp>
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipAbortReq.cpp File Reference

Bluetooth/BIP/BtBipAbortReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipAbortReq.hpp"

Include dependency graph for BtBipAbortReq.cpp:

Generated on Tue Jan 24 19:57:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipAbortReq.hpp File Reference

Bluetooth/BIP/BtBipAbortReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipAbortReq_hpp

Define Documentation

#define BtBipAbortReq_hpp

Generated on Tue Jan 24 19:57:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipAbortReq.hpp Source File

Bluetooth/BIP/BtBipAbortReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipAbortReq_hpp)
00009 #define BtBipAbortReq_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Bluetooth/BIP/BtBipReq.hpp>
00016
00017 extern const UINT16 c_bip_client_put_packet_size;
00018
00021 class BtBipAbortReq : public BtServiceRequest
00022 {
00023     private:
00024         typedef BtServiceRequest Base;
00025
00026     public:
00028         BtBipAbortReq(BtBipClientService& bip_client_service, BtBipReq* parent);
00029
00031         virtual ~BtBipAbortReq();
00032         virtual BtRequestType GetRequestType() const;
00033
00034         void SetAbortDesc(const WString& desc) { m_desc = desc; }
00035         BtObexResponseCode GetObexResult() { return m_obex_result; }
00036         BtBipResult GetBipResult() { return m_bip_result; }
00037
00038     protected:
00039
00041
00043         virtual BOOLEAN Execute();
00044
00045         virtual void ExecutionCallback(BtResultCode result);
00046
00047         void SetObexResult(BtObexResponseCode res) { m_obex_result = res; }
00048         void SetBipResult(BtBipResult res) { m_bip_result = res; }
00049
00050
00051 private:
00052
00053         const WCHAR* GetApiSettings() { return m_desc.GetCString(); }
00054         WString     m_desc;
00055         BtBipReq*   m_parent;
00056
00057         BtBipResult m_bip_result;
00058         BtObexResponseCode  m_obex_result;
00059
00060         friend class BtBipController;
00061         friend class BtBipClientService;
00062         friend class BtBipPutReq;
00063         friend class BtBipGetReq;
00064 };
00065
00066 #endif // DOXYGEN_SHOULD_SKIP_THIS
00067
00068 #endif  // BtBipAbortReq_hpp
00069
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipClientService.cpp File Reference

Bluetooth/BIP/BtBipClientService.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include "BtBipServiceMsg.hpp"
#include <Auxiliary/ImageObtainerDataSource.hpp>
#include <Auxiliary/StringDataSink.hpp>
#include <Auxiliary/DataSource.hpp>
#include <Auxiliary/BinDataDataSource.hpp>
#include <Gui/Image.hpp>

Include dependency graph for BtBipClientService.cpp:

Variables

const UINT16 c_bip_client_read_buf_size = 256
BIP Client Service (image initiator).
Generated on Tue Jan 24 19:57:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipClientService.hpp File Reference

Bluetooth/BIP/BtBipClientService.hpp File Reference

#include <Auxiliary/DataSink.hpp>
#include <Auxiliary/DataSource.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BIP/BtBipService.hpp>
#include <Bluetooth/BIP/BtBipTypes.hpp>
#include <Bluetooth/BIP/BtBipConnectReq.hpp>
#include <Bluetooth/BIP/BtBipDisconnectReq.hpp>
#include <Bluetooth/BIP/BtBipPutImageReq.hpp>
#include <Bluetooth/BIP/BtBipPutThumbReq.hpp>
#include <Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.hpp>
#include <Bluetooth/BIP/BtBipGetImagePropertiesReq.hpp>
#include <Bluetooth/BIP/BtBipPutAttachReq.hpp>
#include <Bluetooth/BIP/BtBipGetImagesListReq.hpp>
#include <Bluetooth/BIP/BtBipGetImageReq.hpp>
#include <Bluetooth/BIP/BtBipGetLinkedThumbnailReq.hpp>
#include <Bluetooth/BIP/BtBipGetLinkedAttachmentReq.hpp>
#include <Bluetooth/BIP/BtBipDeleteImageReq.hpp>
#include <Gui/ImageObtainer.hpp>

Include dependency graph for BtBipClientService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBipClientService

Defines

#define | BtBipClientService_hpp

Variables

const UINT16 | c_bip_client_read_buf_size
BIP Client Service (image initiator).

Define Documentation

#define BtBipClientService_hpp

Generated on Tue Jan 24 19:57:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipClientService.hpp Source File

Bluetooth/BIP/BtBipClientService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipClientService_hpp)
00009 #define BtBipClientService_hpp
00012 #include <Auxiliary/DataSink.hpp>
00013 #include <Auxiliary/DataSource.hpp>
00014 #include <Bluetooth/BtDeviceAddress.hpp>
00015 #include <Bluetooth/BtTypes.hpp>
00016
00017 #include <Bluetooth/BIP/BtBipService.hpp>
00018 #include <Bluetooth/BIP/BtBipTypes.hpp>
00019 #include <Bluetooth/BIP/BtBipConnectReq.hpp>
00020 #include <Bluetooth/BIP/BtBipDisconnectReq.hpp>
00021 #include <Bluetooth/BIP/BtBipPutImageReq.hpp>
00022 #include <Bluetooth/BIP/BtBipPutThumbReq.hpp>
00023 #include <Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.hpp>
00024 #include <Bluetooth/BIP/BtBipGetImagePropertiesReq.hpp>
00025 #include <Bluetooth/BIP/BtBipPutAttachReq.hpp>
00026 #include <Bluetooth/BIP/BtBipGetImagesListReq.hpp>
00027 #include <Bluetooth/BIP/BtBipGetImageReq.hpp>
00028 #include <Bluetooth/BIP/BtBipGetLinkedThumbnailReq.hpp>
00029 #include <Bluetooth/BIP/BtBipGetLinkedAttachmentReq.hpp>
00030 #include <Bluetooth/BIP/BtBipDeleteImageReq.hpp>
00031
00032
00033 #include <Gui/ImageObtainer.hpp>
00034
00035 //#include "BtBipConnectReq.hpp"
00036
00038
00047 extern const UINT16 c_bip_client_read_buf_size;
00048
00049 class BtBipClientService : public BtBipService
00050 {
00051     private:
00052         typedef BtBipService Base;
00053
00054     public:
00056         BtBipClientService();
00057
00059         virtual ~BtBipClientService();
00060
00062
00064         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00065
00067
00069         virtual BOOLEAN IsServerService() const;
00070
00072
00074         BOOLEAN IsConnected() const;
00075
00076         // General requests
00078
00083         BtRequestState ConnectReq(BtBipSessionId session_id, const BtDevice& device);
00084
00086
00088         BtRequestState DisconnectReq();
00089
00091
00094         BtRequestState AbortReq(const WString& reason);
00095
00097
00100         BtRequestState GetImagingCapabilitiesReq();
00101
00102         // Image Push
00103
00105
00115         BtRequestState PutImageReq(const WString& name, const BtBipImageDescPtr& img_desc, const DataSourcePtr& img);
00116
00118
00127         BtRequestState PutImageReq(const WString& name, BtBipImageDescPtr& img_desc, const ImageObtainer& image);
00128
00130
00138         BtRequestState PutImageReq(const WString& name, const ImageObtainer& image);
00139
00141
00147         BtRequestState PutLinkedThumbnailReq(const BtBipImageHdlPtr& img_hdl, const ImageObtainer& thumb);
00148
00150
00156         BtRequestState PutLinkedThumbnailReq(const BtBipImageHdlPtr& img_hdl, const DataSourcePtr& thumb);
00157
00159
00164         BtRequestState PutLinkedAttachmentReq(const BtBipImageHdlPtr& img_hdl, const BtBipAttachmentDescPtr& attach_desc, const DataSourcePtr& attach);
00165
00166         // Image Pull
00168
00173         BtRequestState GetImagesListReq(UINT16 first_index, UINT16 max_images, BOOLEAN sort_by_latest_first, const BtBipImageHdlDescPtr& filter);
00174
00176
00180         BtRequestState GetImagePropertiesReq(const BtBipImageHdlPtr& img_hdl);
00181
00183
00188         BtRequestState GetImageReq(const BtBipImageHdlPtr& img_hdl, const BtBipImageDescPtr& img_desc, const DataSinkPtr& image);
00189
00191
00196         BtRequestState GetLinkedThumbnailReq(const BtBipImageHdlPtr& img_hdl, const DataSinkPtr& thumb);
00197
00199
00204         BtRequestState GetLinkedAttachmentReq(const BtBipImageHdlPtr& img_hdl, const WString& file_name, const DataSinkPtr& attach);
00205
00207
00210         BtRequestState DeleteImageReq(const BtBipImageHdlPtr& img_hdl);
00211
00213         BtResultCode GetResult();
00214
00216         BtObexResponseCode GetObexResponseCode();
00217
00219         BtBipResult GetBipResult();
00220
00222
00227         BtResultCode GetImagingCapabilites(BtBipImagingCapabilitiesPtr& caps);
00228
00230
00233         BtResultCode GetImageHdl(BtBipImageHdlPtr& img_hdl);
00234
00236
00239         BtResultCode GetImagesList(BtBipImageListPtr& img_list);
00240
00242
00245         BtResultCode GetImageProperties(BtBipImagePropertiesPtr& props);
00246
00248
00250         UINT32  GetProgressInBytes() {return m_cur_req ? m_cur_req->GetBytesTransfered():0; }
00251
00252 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00253
00254         virtual BOOLEAN OnMessage(const Message& msg);
00255 #endif
00256
00257     protected:
00258         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00259
00260         virtual void RegisterMessages() const;
00261         virtual void UnregisterMessages() const;
00262
00263     private:
00264
00265         BOOLEAN PutNextPacket();
00266         BOOLEAN GetNextPacket();
00267
00268         BtBipConnectReq                 m_connect_req;
00269         BtBipDisconnectReq              m_disconnect_req;
00270         BtBipGetImagingCapabilitiesReq  m_get_cap_req;
00271         BtBipPutImageReq                m_put_img_req;
00272         BtBipPutThumbReq                m_put_thumb_req;
00273         BtBipPutAttachReq               m_put_attach_req;
00274         BtBipGetImagesListReq           m_get_imgs_list_req;
00275         BtBipGetImageReq                m_get_img_req;
00276         BtBipGetLinkedThumbnailReq      m_get_thumb_req;
00277         BtBipGetLinkedAttachmentReq     m_get_attach_req;
00278         BtBipDeleteImageReq             m_delete_img_req;
00279         BtBipGetImagePropertiesReq      m_get_img_props_req;
00280
00281         // currently active request
00282         BtBipReq*                       m_cur_req;
00283
00284         friend class BtBipConnectReq;
00285 };
00286
00288 #endif  // BtBipClientService_hpp
00289
00290
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipConnectReq.cpp File Reference

Bluetooth/BIP/BtBipConnectReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipConnectReq.hpp"

Include dependency graph for BtBipConnectReq.cpp:

Generated on Tue Jan 24 19:57:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipConnectReq.hpp File Reference

Bluetooth/BIP/BtBipConnectReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipConnectReq_hpp

Define Documentation

#define BtBipConnectReq_hpp

Generated on Tue Jan 24 19:57:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipConnectReq.hpp Source File

Bluetooth/BIP/BtBipConnectReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipConnectReq_hpp)
00009 #define BtBipConnectReq_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Bluetooth/BIP/BtBipReq.hpp>
00016 #include <Bluetooth/BIP/BtBipTypes.hpp>
00017
00018 /*  ------------------------------------------------------------------------
00019     Forward deklarations for friend relationships.
00020     ------------------------------------------------------------------------ */
00021
00022 class BtBipClientService;
00023
00026 class BtBipConnectReq: public BtBipReq
00027 {
00028     private:
00029         typedef BtBipReq Base;
00030
00031     public:
00033         BtBipConnectReq(BtBipClientService& Bip_client_service);
00034
00036         virtual ~BtBipConnectReq();
00037
00039
00041         virtual BtRequestType GetRequestType() const;
00042
00044
00046         BtDevice GetTargetDevice() const;
00047
00049
00051         void SetTargetDevice(const BtDevice& target_device);
00052
00053         BtBipSessionId GetSessionId();
00054
00055         void SetSessionId(const BtBipSessionId session_id);
00056
00057
00058     protected:
00060
00062         virtual BOOLEAN Execute();
00063
00065
00067 //      virtual void ExecutionCallback(BtResultCode result);
00068
00069         btapi_bip_connect_t* GetApiSettings();
00070
00071     private:
00072
00073         btapi_bip_connect_t m_operation_params;
00074
00075         friend class BtBipController;
00076 };
00077 #endif
00078
00079 #endif  // BtBipConnectReq_hpp
00080
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipController.cpp File Reference

Bluetooth/BIP/BtBipController.cpp File Reference

#include "PreComp.hpp"
#include "BtBipServerService.hpp"
#include "BtBipController.hpp"
#include "BtBipConnectReq.hpp"
#include "BtBipDisconnectReq.hpp"
#include "BtBipPutImageReq.hpp"
#include "BtBipPutThumbReq.hpp"
#include "BtBipPutAttachReq.hpp"
#include "BtBipGetImagesListReq.hpp"
#include "BtBipGetImageReq.hpp"
#include "BtBipGetLinkedThumbnailReq.hpp"
#include "BtBipGetLinkedAttachmentReq.hpp"
#include "BtBipDeleteImageReq.hpp"
#include "BtBipGetImagePropertiesReq.hpp"
#include "BtBipGetImagingCapabilitiesReq.hpp"
#include "BtBipTypes.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include <stdio.h>

Include dependency graph for BtBipController.cpp:

Generated on Tue Jan 24 19:57:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipController.hpp File Reference

Bluetooth/BIP/BtBipController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipController_hpp

Define Documentation

#define BtBipController_hpp

Generated on Tue Jan 24 19:57:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipController.hpp Source File

Bluetooth/BIP/BtBipController.hpp

Go to the documentation of this file.
00001
00002 /*  ------------------------------------------------------------------------
00003     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(BtBipController_hpp)
00010 #define BtBipController_hpp
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <stack/extensions.h>
00016 #include <Bluetooth/BtSingleConnectionController.hpp>
00017 #include <Bluetooth/BIP/BtBipTypes.hpp>
00018
00019 /*  ------------------------------------------------------------------------
00020     Forward deklarations for friend relationships.
00021     ------------------------------------------------------------------------ */
00022
00023 class BtBipService;
00024 class BtBipServerService;
00025 class BtBipClientService;
00026 class BtBipConnectReq;
00027 class BtBipDisconnectReq;
00028 class BtBipAbortReq;
00029 class BtBipPutImageReq;
00030 class BtBipPutThumbReq;
00031 class BtBipPutAttachReq;
00032 class BtBipGetImagesListReq;
00033 class BtBipGetImageReq;
00034 class BtBipGetLinkedThumbnailReq;
00035 class BtBipGetLinkedAttachmentReq;
00036 class BtBipDeleteImageReq;
00037 class BtBipGetImagingCapabilitiesReq;
00038 class BtBipGetImagePropertiesReq;
00039
00043 class BtBipController: public BtSingleConnectionController
00044 {
00045
00046     public:
00048
00050         static BtBipController& GetInstance();
00051
00053         virtual ~BtBipController();
00054
00056
00058         virtual const WCHAR* GetName() const;
00059
00060     protected:
00061         // Register BIP Server Service at controller
00065         BOOLEAN RegisterBipServer(BtBipServerService* svr);
00066
00068         BOOLEAN BipConnectReq(BtBipConnectReq* req);
00069
00071         BOOLEAN BipConnectRsp(BtObexResponseCode obex_result);
00072
00074         BOOLEAN BipDisconnectReq(BtBipDisconnectReq* req);
00075
00077         BOOLEAN BipAbortReq(BtBipAbortReq* req);
00078
00079         BOOLEAN BipAbortRsp(BtObexResponseCode obex_result);
00080
00082         BOOLEAN BipGetImagingCapabilitiesReq(BtBipGetImagingCapabilitiesReq* req);
00083
00085         BOOLEAN BipGetImagingCapabilitesRsp(BtObexResponseCode obex_result, UINT16 img_cap_len, const UINT8* img_cap);
00086
00088
00090         BOOLEAN BipPutImageReq(BtBipPutImageReq* req);
00091
00093         BOOLEAN BipPutImageRsp(BtObexResponseCode obex_result, const BtBipImageHdlPtr& img_hdl);
00094
00096
00098         BOOLEAN BipPutLinkedThumbReq(BtBipPutThumbReq* req);
00099
00101
00103         BOOLEAN BipPutLinkedThumbRsp(BtObexResponseCode obex_result);
00104
00106
00108         BOOLEAN BipPutLinkedAttachmentReq(BtBipPutAttachReq* req);
00109
00111         BOOLEAN BipPutLinkedAttachmentRsp(BtObexResponseCode obex_result);
00112
00114         BOOLEAN BipGetImagesListReq(BtBipGetImagesListReq* req);
00115
00117         BOOLEAN BipGetImagesListRsp(BtObexResponseCode obex_result, UINT16 img_count, UINT16 filter_len, const UINT8* filter, UINT16 list_len, const UINT8* list);
00118
00120         BOOLEAN BipGetImagePropertiesReq(BtBipGetImagePropertiesReq* req);
00121
00123         BOOLEAN BipGetImagePropertiesRsp(BtObexResponseCode obex_result, UINT16 img_props_len, const UINT8* img_props);
00124
00126         BOOLEAN BipGetImageReq(BtBipGetImageReq* req);
00127
00129         BOOLEAN BipGetImageRsp(BtObexResponseCode obex_result, UINT32 file_length, UINT16 body_len, const UINT8* body);
00130
00132         BOOLEAN BipGetLinkedThumbReq(BtBipGetLinkedThumbnailReq* req);
00133
00135         BOOLEAN BipGetLinkedThumbRsp(BtObexResponseCode obex_result, UINT16 body_len, const UINT8* body);
00136
00138         BOOLEAN BipGetLinkedAttachmentReq(BtBipGetLinkedAttachmentReq* req);
00139
00141         BOOLEAN BipGetLinkedAttachmentRsp(BtObexResponseCode obex_result, UINT16 body_len, const UINT8* body);
00142
00144         BOOLEAN BipDeleteImageReq(BtBipDeleteImageReq* req);
00145
00147         BOOLEAN BipDeleteImageRsp(BtObexResponseCode obex_result);
00148
00149     private:
00150
00151         typedef BtSingleConnectionController Base;
00152
00153         /*---------------------------------------------------------------------*/
00154         /* The following functions must not be called by an application.       */
00155         /* They are the entry point from the stack callback functions into our */
00156         /* object orientated framework (APOXI).                                */
00157         /* They are implemented as static because they have to be passed as    */
00158         /* normal C function pointers. The reason for this is the BT-API Stack */
00159         /* interface that demands C function pointers for callback the         */
00160         /* callback functions it calls to state the progress of ongoing        */
00161         /* operations                                                          */
00162         /*---------------------------------------------------------------------*/
00163
00164
00165         // Callbacks where no paramters are passed
00166         static void CommonBipCb(btapi_result_t Result, btapi_common_bipcb_t Type);
00167
00168         // Callback for Connect Confirmation (BIP_CONNECT_CFM)
00169         static void BipConnectCfmCb(btapi_result_t Result, btapi_bip_common_cfm_t *cfm);
00170
00171         // Callback for Connect Ind (BIP_CONNECT_IND)
00172         static void BipConnectIndCb(btapi_result_t Result, btapi_bip_connect_t *ind);
00173
00174         // Callback for Disconnect Confirmation (BIP_DISCONNECT_CFM)
00175         static void BipDisconnectCfmCb(btapi_result_t Result, btapi_bip_common_cfm_t *cfm);
00176
00177         // Callback for Abort Confirmation (BIP_ABORT_CFM)
00178         static void BipAbortCfmCb(btapi_result_t Result, btapi_bip_common_cfm_t *cfm);
00179
00180         // Callback for Abort Indication (BIP_ABORT_IND)
00181         static void BipAbortIndCb(btapi_result_t Result, btapi_bip_abort_ind_t *cfm);
00182
00183         // Callback for Get Imaging Capabilities Confirmation (BIP_GET_CAPABILITIES_CFM)
00184         static void BipGetImagingCapabilitiesCfmCb(btapi_result_t result, const btapi_bip_common_body_cfm_t *cfm);
00185
00186         // Callback for Put Img Confirmation (BIP_PUT_IMAGE_CFM)
00187         static void BipPutImageCfmCb(btapi_result_t result, const btapi_bip_put_img_cfm_t *cfm);
00188
00189         // Callback for Put Img Indication (BIP_PUT_IMAGE_IND)
00190         static void BipPutImageIndCb(btapi_result_t result, const btapi_bip_put_img_ind_t *ind);
00191
00192         // Callback for Put Linked Thumbnail Confirmation (BIP_PUT_LINKED_THUMBNAIL_CFM)
00193         static void BipPutLinkedThumbnailCfmCb(btapi_result_t result, const btapi_bip_common_cfm_t *cfm);
00194
00195         // Callback for Put Linked Thumbnail Indication (BIP_PUT_LINKED_THUMBNAIL_IND)
00196         static void BipPutLinkedThumbnailIndCb(btapi_result_t result, const btapi_bip_put_linked_thumb_t *ind);
00197
00198         // Callback for Put Linked Attachment Confirmation (BIP_PUT_LINKED_ATTACHMENT_CFM)
00199         static void BipPutLinkedAttachmentCfmCb(btapi_result_t result, const btapi_bip_common_cfm_t *cfm);
00200
00201         // Callback for Put Linked Attachment Indication (BIP_PUT_LINKED_ATTACHMENT_IND)
00202         static void BipPutLinkedAttachmentIndCb(btapi_result_t result, const btapi_bip_put_linked_attachment_t *ind);
00203
00204         // Callback for Get Imgs List Confirmation (BIP_GET_IMAGES_LIST_CFM)
00205         static void BipGetImgsListCfmCb(btapi_result_t result, const btapi_bip_get_imgs_list_cfm_t *cfm);
00206
00207         // Callback for Get Imgs List Indication (BIP_GET_IMAGES_LIST_IND)
00208         static void BipGetImgsListIndCb(btapi_result_t result, const btapi_bip_get_imgs_list_t *ind);
00209
00210         // Callback for Get Img Properites Confirmation (BIP_GET_IMAGE_PROPERTIES_CFM)
00211         static void BipGetImgPropertiesCfmCb(btapi_result_t result, const btapi_bip_common_body_cfm_t *cfm);
00212
00213         // Callback for Get Img Properties Indication (BIP_GET_IMAGE_PROPERTIES_IND)
00214         static void BipGetImgPropertiesIndCb(btapi_result_t result, const btapi_bip_img_hdl_t *ind);
00215
00216         // Callback for Get Img Confirmation (BIP_GET_IMAGE_CFM)
00217         static void BipGetImgCfmCb(btapi_result_t result, const btapi_bip_get_img_cfm_t *cfm);
00218
00219         // Callback for Get Img Indication (BIP_GET_IMAGE_IND)
00220         static void BipGetImgIndCb(btapi_result_t result, const btapi_bip_get_img_t *cfm);
00221
00222         // Callback for Get Linked Thumbnail Confirmation (BIP_GET_LINKED_THUMBNAIL_CFM)
00223         static void BipGetLinkedThumbnailCfmCb(btapi_result_t result, const btapi_bip_common_body_cfm_t *cfm);
00224
00225         // Callback for Get Linked Thumbnail Indication (BIP_GET_LINKED_THUMBNAIL_IND)
00226         static void BipGetLinkedThumbnailIndCb(btapi_result_t result, const btapi_bip_img_hdl_t *ind);
00227
00228         // Callback for Get Linked Attachment Indication (BIP_GET_LINKED_ATTACHMENT_CFM)
00229         static void BipGetLinkedAttachmentCfmCb(btapi_result_t result, const btapi_bip_common_body_cfm_t *cfm);
00230
00231         // Callback for Get Linked Attachment Indication (BIP_GET_LINKED_ATTACHMENT_IND)
00232         static void BipGetLinkedAttachmentIndCb(btapi_result_t result, const btapi_bip_get_linked_attach_ind_t *ind);
00233
00234         // Callback for Delete Image Confirmation (BIP_DELETE_IMAGE_CFM)
00235         static void BipDeleteImgCfmCb(btapi_result_t result, const btapi_bip_common_cfm_t *cfm);
00236
00237         // Callback for Delete Image Indication (BIP_DELETE_IMAGE_IND)
00238         static void BipDeleteImgIndCb(btapi_result_t result, const btapi_bip_img_hdl_t *ind);
00239
00240         // Callbacks where no paramters are passed
00241         void OnBipCommon(btapi_result_t Result, btapi_common_bipcb_t Type);
00242
00243         // Callback for Connect Confirmation (BIP_CONNECT_CFM)
00244         void OnBipConnectCfm(btapi_result_t Result, btapi_bip_common_cfm_t *cfm);
00245
00246         // Callback for Connect Ind (BIP_CONNECT_IND)
00247         void OnBipConnectInd(btapi_result_t Result, btapi_bip_connect_t *ind);
00248
00249         // Callback for Disconnect Confirmation (BIP_DISCONNECT_CFM)
00250         void OnBipDisconnectCfm(btapi_result_t Result, btapi_bip_common_cfm_t *cfm);
00251
00252         // Callback for Disconnect Confirmation (BIP_DISCONNECT_IND)
00253         void OnBipDisconnectInd(btapi_result_t Result);
00254
00255         // Callback for Abort Confirmation (BIP_ABORT_CFM)
00256         void OnBipAbortCfm(btapi_result_t Result, btapi_bip_common_cfm_t *cfm);
00257
00258         // Callback for Abort Indication (BIP_ABORT_IND)
00259         void OnBipAbortInd(btapi_result_t Result, btapi_bip_abort_ind_t *cfm);
00260
00261         // Callback for Get Imaging Capabilities Confirmation (BIP_GET_CAPABILITIES_CFM)
00262         void OnBipGetImagingCapabilitiesCfm(btapi_result_t result, const btapi_bip_common_body_cfm_t *cfm);
00263
00264         // Callback for Get Imaging Capabilities Confirmation (BIP_GET_CAPABILITIES_CFM)
00265         void OnBipGetImagingCapabilitesInd(btapi_result_t result);
00266
00267         // Callback for Put Img Confirmation (BIP_PUT_IMAGE_CFM)
00268         void OnBipPutImageCfm(btapi_result_t result, const btapi_bip_put_img_cfm_t *cfm);
00269
00270         // Callback for Put Img Indication (BIP_PUT_IMAGE_IND)
00271         void OnBipPutImageInd(btapi_result_t result, const btapi_bip_put_img_ind_t *ind);
00272
00273         // Callback for Put Linked Thumbnail Confirmation (BIP_PUT_LINKED_THUMBNAIL_CFM)
00274         void OnBipPutLinkedThumbnailCfm(btapi_result_t result, const btapi_bip_common_cfm_t *cfm);
00275
00276         // Callback for Put Linked Thumbnail Indication (BIP_PUT_LINKED_THUMBNAIL_IND)
00277         void OnBipPutLinkedThumbnailInd(btapi_result_t result, const btapi_bip_put_linked_thumb_t *ind);
00278
00279         // Callback for Put Linked Attachment Confirmation (BIP_PUT_LINKED_ATTACHMENT_CFM)
00280         void OnBipPutLinkedAttachmentCfm(btapi_result_t result, const btapi_bip_common_cfm_t *cfm);
00281
00282         // Callback for Put Linked Attachment Indication (BIP_PUT_LINKED_ATTACHMENT_IND)
00283         void OnBipPutLinkedAttachmentInd(btapi_result_t result, const btapi_bip_put_linked_attachment_t *ind);
00284
00285         // Callback for Get Imgs List Confirmation (BIP_GET_IMAGES_LIST_CFM)
00286         void OnBipGetImgsListCfm(btapi_result_t result, const btapi_bip_get_imgs_list_cfm_t *cfm);
00287
00288         // Callback for Get Imgs List Indication (BIP_GET_IMAGES_LIST_IND)
00289         void OnBipGetImgsListInd(btapi_result_t result, const btapi_bip_get_imgs_list_t *ind);
00290
00291         // Callback for Get Img Properites Confirmation (BIP_GET_IMAGE_PROPERTIES_CFM)
00292         void OnBipGetImgPropertiesCfm(btapi_result_t result, const btapi_bip_common_body_cfm_t *cfm);
00293
00294         // Callback for Get Img Properties Indication (BIP_GET_IMAGE_PROPERTIES_IND)
00295         void OnBipGetImgPropertiesInd(btapi_result_t result, const btapi_bip_img_hdl_t *ind);
00296
00297         // Callback for Get Img Confirmation (BIP_GET_IMAGE_CFM)
00298         void OnBipGetImgCfm(btapi_result_t result, const btapi_bip_get_img_cfm_t *cfm);
00299
00300         // Callback for Get Img Indication (BIP_GET_IMAGE_IND)
00301         void OnBipGetImgInd(btapi_result_t result, const btapi_bip_get_img_t *cfm);
00302
00303         // Callback for Get Img Body Complete Indication (BIP_BODY_COMPLETE_IND)
00304         void OnBipBodyCompleteInd(btapi_result_t result);
00305
00306         // Callback for Get Linked Thumbnail Confirmation (BIP_GET_LINKED_THUMBNAIL_CFM)
00307         void OnBipGetLinkedThumbnailCfm(btapi_result_t result, const btapi_bip_common_body_cfm_t *cfm);
00308
00309         // Callback for Get Linked Thumbnail Indication (BIP_GET_LINKED_THUMBNAIL_IND)
00310         void OnBipGetLinkedThumbnailInd(btapi_result_t result, const btapi_bip_img_hdl_t *ind);
00311
00312         // Callback for Get Linked Attachment Indication (BIP_GET_LINKED_ATTACHMENT_CFM)
00313         void OnBipGetLinkedAttachmentCfm(btapi_result_t result, const  btapi_bip_common_body_cfm_t *cfm);
00314
00315         // Callback for Get Linked Attachment Indication (BIP_GET_LINKED_ATTACHMENT_IND)
00316         void OnBipGetLinkedAttachmentInd(btapi_result_t result, const btapi_bip_get_linked_attach_ind_t *ind);
00317
00318         // Callback for Delete Image Confirmation (BIP_DELETE_IMAGE_CFM)
00319         void OnBipDeleteImgCfm(btapi_result_t result, const btapi_bip_common_cfm_t *cfm);
00320
00321         // Callback for Delete Image Indication (BIP_DELETE_IMAGE_IND)
00322         void OnBipDeleteImgInd(btapi_result_t result, const btapi_bip_img_hdl_t *ind);
00323
00325         //<em>Singleton</em>
00326         BtBipController();
00327
00329
00331         virtual void Register();
00332
00334
00336         virtual void Unregister();
00337
00339         void BigTroubleWithLittleEndian(WString& str);
00341
00343 //      btapi_bip_handle_t GetBipHandle(const void* apoxi_handle);
00344
00346         btapi_bipcb_funp_t* m_bip_callbacks;
00347
00348         BtBipServerService* m_bip_server;
00349
00351         static BtBipController m_controller;
00352
00353         friend class BtBipService;
00354         friend class BtBipServerService;
00355         friend class BtBipClientService;
00356         friend class BtBipConnectReq;
00357         friend class BtBipDisconnectReq;
00358         friend class BtBipPutImageReq;
00359         friend class BtBipPutThumbReq;
00360         friend class BtBipPutAttachReq;
00361         friend class BtBipGetReq;
00362         friend class BtBipGetImagePropertiesReq;
00363         friend class BtBipGetImagePropertiesRsp;
00364         friend class BtBipGetImagingCapabilitiesReq;
00365         friend class BtBipGetImagesListReq;
00366         friend class BtBipGetImageReq;
00367         friend class BtBipGetLinkedThumbnailReq;
00368         friend class BtBipGetLinkedThumbnailRsp;
00369         friend class BtBipGetLinkedAttachmentReq;
00370         friend class BtBipGetLinkedAttachmentRsp;
00371         friend class BtBipDeleteImageReq;
00372         friend class BtBipDeleteImageRsp;
00373         friend class BtBipPutRsp;
00374         friend class BtBipPutImageRsp;
00375         friend class BtBipPutThumbRsp;
00376         friend class BtBipPutAttachRsp;
00377         friend class BtBipPutReq;
00378         friend class BtBipAbortReq;
00379         friend class BtBipGetRsp;
00380         friend class BtBipGetImagingCapabilitiesRsp;
00381         friend class BtBipGetImagesListRsp;
00382         friend class BtBipGetImageRsp;
00383
00384 };
00385
00386 #endif // DOXYGEN_SHOULD_SKIP_THIS
00387
00388 #endif  // BtBipController_hpp
00389
00390
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDataConverter.cpp File Reference

Bluetooth/BIP/BtBipDataConverter.cpp File Reference

#include "PreComp.hpp"
#include "BtBipDataConverter.hpp"

Include dependency graph for BtBipDataConverter.cpp:

Generated on Tue Jan 24 19:57:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDataConverter.hpp File Reference

Bluetooth/BIP/BtBipDataConverter.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipDataConverter_hpp

Define Documentation

#define BtBipDataConverter_hpp

Generated on Tue Jan 24 19:57:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDataConverter.hpp Source File

Bluetooth/BIP/BtBipDataConverter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipDataConverter_hpp)
00009 #define BtBipDataConverter_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipTypes.hpp>
00014
00015 class BtBipDataConverter
00016 {
00017
00018 public:
00019
00020     BtBipDataConverter();
00021     virtual ~BtBipDataConverter();
00022
00023     virtual void Init() = 0;
00024
00025     /* Encoding */
00026     virtual BOOLEAN ConvertBipImageDesc(const BtBipImageDesc& img_desc) = 0;
00027     virtual BOOLEAN ConvertBipImageHdlDesc(const BtBipImageHdlDesc& img_hdl_desc) = 0;
00028     virtual BOOLEAN ConvertBipImagesList(const BtBipImageList& img_list) = 0;
00029     virtual BOOLEAN ConvertBipImagingCapabilities(const BtBipImagingCapabilities& img_list) = 0;
00030     virtual BOOLEAN ConvertBipImageProperties(const BtBipImageProperties& img_props) = 0;
00031     virtual BOOLEAN ConvertBipAttachmentDesc(const BtBipAttachmentDesc& attach_hdl_desc) = 0;
00032
00033     /* Decoding */
00034     virtual void ConvertXmlImageDesc(const UINT8* body, UINT16 len, BtBipImageDesc& img_desc) = 0;
00035     virtual void ConvertXmlImageHdlDesc(const UINT8* body, UINT16 len, BtBipImageHdlDesc& img_hdl_desc) = 0;
00036     virtual void ConvertXmlImageList(const UINT8* body, UINT16 len, BtBipImageListPtr& img_list) = 0;
00037     virtual void ConvertXmlImagingCapabilities(const UINT8* body, UINT16 len, BtBipImagingCapabilities& img_list) = 0;
00038     virtual void ConvertXmlImageProperties(const UINT8* body, UINT16 len, BtBipImageProperties& img_props) = 0;
00039     virtual void ConvertXmlAttachmentDesc(const UINT8* body, UINT16 len, BtBipAttachmentDesc& attach_hdl_desc)  = 0;
00040
00041 protected:
00042     BtBipEncoding TextToBtBipEncoding(CHAR* text, UINT16 len);
00043     void BtBipToTextEncoding(BtBipEncoding encoding, String& enc_str);
00044     void TextToBtBipImageDim(CHAR* text, UINT16 len, BtBipImageFormat::ImageDim& img_dim);
00045
00046     void CreateImageHdl(const BtBipImageHdl::ImgHdl* hdl, BtBipImageHdlPtr& hdl_ptr) { BtBipImageHdl::CreateImageHdl(hdl, hdl_ptr); }
00047     const BtBipImageHdl::ImgHdl* GetImageHdl(const BtBipImageHdlPtr& hdl) { return hdl->GetHdl(); }
00048 };
00049
00050 #endif // APOXI_SHOULD SKIP_THIS
00051 #endif // BtBipDataConverter
00052
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDeleteImageReq.cpp File Reference

Bluetooth/BIP/BtBipDeleteImageReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipDeleteImageReq.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipDeleteImageReq.cpp:

Generated on Tue Jan 24 19:58:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDeleteImageReq.hpp File Reference

Bluetooth/BIP/BtBipDeleteImageReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipDeleteImageReq_hpp

Define Documentation

#define BtBipDeleteImageReq_hpp

Generated on Tue Jan 24 19:58:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDeleteImageReq.hpp Source File

Bluetooth/BIP/BtBipDeleteImageReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipDeleteImageReq_hpp)
00009 #define BtBipDeleteImageReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipReq.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtBipClientService;
00020
00023 class BtBipDeleteImageReq : public BtBipReq
00024 {
00025     private:
00026         typedef BtBipReq Base;
00027
00028     public:
00030         BtBipDeleteImageReq(BtBipClientService& Bip_client_service);
00031
00033         virtual ~BtBipDeleteImageReq();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040
00041         /**********************************************************************/
00042         /* Put Image Req parameter access methods                         */
00043         /**********************************************************************/
00044
00046
00048         void SetImageHdl(const BtBipImageHdlPtr& hdl);
00049         void SetImageDesc(const BtBipImageDescPtr& img_desc);
00050
00051
00053
00054         void SetFileLen(UINT32 file_len) { m_file_len = file_len; }
00055         UINT32 GetFileLen() { return m_file_len; }
00056
00057     protected:
00059
00061         virtual BOOLEAN Execute();
00062
00063     private:
00064         /* Parameters */
00065         const btapi_bip_img_hdl_t*  GetApiSettings();
00066         const btapi_bip_img_hdl_t*  m_operation_params;
00067
00068         BtBipImageHdlPtr    m_img_hdl;
00069
00070         /* Results */
00071         UINT16  m_img_len;
00072         UINT8*  m_img_body;
00073         UINT32  m_file_len;
00074
00075     private:
00076         friend class BtBipController;
00077         friend class BtBipClientService;
00078 };
00079 #endif
00080
00081 #endif  // BtBipDeleteImageReq_hpp
00082
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDisconnectReq.cpp File Reference

Bluetooth/BIP/BtBipDisconnectReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipDisconnectReq.hpp"

Include dependency graph for BtBipDisconnectReq.cpp:

Generated on Tue Jan 24 19:58:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDisconnectReq.hpp File Reference

Bluetooth/BIP/BtBipDisconnectReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipDisconnectReq_hpp

Define Documentation

#define BtBipDisconnectReq_hpp

Generated on Tue Jan 24 19:58:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipDisconnectReq.hpp Source File

Bluetooth/BIP/BtBipDisconnectReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipDisconnectReq_hpp)
00009 #define BtBipDisconnectReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include <Bluetooth/BIP/BtBipReq.hpp>
00015 #include <Bluetooth/BIP/BtBipTypes.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020
00021 class BtBipClientService;
00022
00025 class BtBipDisconnectReq: public BtBipReq
00026 {
00027     private:
00028         typedef BtBipReq Base;
00029
00030     public:
00032         BtBipDisconnectReq(BtBipClientService& Bip_client_service);
00033
00035         virtual ~BtBipDisconnectReq();
00036
00038
00040         virtual BtRequestType GetRequestType() const;
00041
00042     protected:
00044
00046         virtual BOOLEAN Execute();
00047
00049
00051 //      virtual void ExecutionCallback(BtResultCode result);
00052
00053     private:
00054
00055         friend class BtBipController;
00056 };
00057
00058 #endif
00059
00060 #endif  // BtBipDisconnectReq_hpp
00061
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagePropertiesReq.cpp File Reference

Bluetooth/BIP/BtBipGetImagePropertiesReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipGetImagePropertiesReq.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include <Auxiliary/StringDataSink.hpp>

Include dependency graph for BtBipGetImagePropertiesReq.cpp:

Generated on Tue Jan 24 19:58:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagePropertiesReq.hpp File Reference

Bluetooth/BIP/BtBipGetImagePropertiesReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetImagePropertiesReq_hpp

Define Documentation

#define BtBipGetImagePropertiesReq_hpp

Generated on Tue Jan 24 19:58:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagePropertiesReq.hpp Source File

Bluetooth/BIP/BtBipGetImagePropertiesReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetImagePropertiesReq_hpp)
00009 #define BtBipGetImagePropertiesReq_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Bluetooth/BIP/BtBipGetReq.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020
00021 class BtBipClientService;
00022
00025 class BtBipGetImagePropertiesReq : public BtBipGetReq
00026 {
00027     private:
00028         typedef BtBipGetReq Base;
00029
00030     public:
00032         BtBipGetImagePropertiesReq(BtBipClientService& Bip_client_service);
00033
00035         virtual ~BtBipGetImagePropertiesReq();
00036
00038
00040         virtual BtRequestType GetRequestType() const;
00041
00042         /**********************************************************************/
00043         /* Put Image Req parameter access methods                         */
00044         /*********************************************************************/
00045
00046         void SetImagePropertiesSink(const DataSinkPtr& sink) { m_img_props_sink = sink; }
00047         void SetImageHdl(const BtBipImageHdlPtr& hdl);
00048
00049         const BtBipImagePropertiesPtr& GetImageProperties();
00050
00051     protected:
00053
00055         virtual BOOLEAN Execute();
00056
00057     private:
00058
00059         const btapi_bip_img_hdl_t*  GetApiSettings() { return m_operation_params; }
00060         const btapi_bip_img_hdl_t*  m_operation_params;
00061
00062         BtBipImagePropertiesPtr     m_img_props;
00063         DataSinkPtr                 m_img_props_sink;
00064         BtBipImageHdlPtr            m_img_hdl;
00065
00066     private:
00067         friend class BtBipController;
00068         friend class BtBipClientService;
00069 };
00070
00071 #endif
00072
00073 #endif  // BtBipGetImagePropertiesReq_hpp
00074
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagePropertiesRsp.cpp File Reference

Bluetooth/BIP/BtBipGetImagePropertiesRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipGetImagePropertiesRsp.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include <Auxiliary/BinDataDataSource.hpp>
#include <Auxiliary/RamData.hpp>

Include dependency graph for BtBipGetImagePropertiesRsp.cpp:

Generated on Tue Jan 24 19:58:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagePropertiesRsp.hpp File Reference

Bluetooth/BIP/BtBipGetImagePropertiesRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetImagePropertiesRsp_hpp

Define Documentation

#define BtBipGetImagePropertiesRsp_hpp

Generated on Tue Jan 24 19:58:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagePropertiesRsp.hpp Source File

Bluetooth/BIP/BtBipGetImagePropertiesRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetImagePropertiesRsp_hpp)
00009 #define BtBipGetImagePropertiesRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Auxiliary/DataSink.hpp>
00014 #include <Bluetooth/BIP/BtBipGetRsp.hpp>
00015
00018 class BtBipGetImagePropertiesRsp : BtBipGetRsp
00019 {
00020     private:
00021         typedef BtBipGetRsp Base;
00022
00023     public:
00025         BtBipGetImagePropertiesRsp();
00027         virtual ~BtBipGetImagePropertiesRsp();
00028
00029         virtual BtRequestType GetRequestType() const { return BtRqtBipGetImageProperties; }
00030
00031         void GetImagePropertiesInd(const BtBipImageHdlPtr& hdl);
00032         void SetImageProperties(const BtBipImagePropertiesPtr& img_props);
00033
00034 protected:
00035         virtual BOOLEAN ExecuteRsp();
00036
00037     private:
00038         BtBipImagePropertiesPtr m_img_props;
00039         UINT8*  m_img_props_text;
00040
00041     private:
00042         friend class BtBipController;
00043         friend class BtBipServerService;
00044 };
00045
00046 #endif
00047
00048 #endif  // BtBipGetImagePropertiesRsp_hpp
00049
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImageReq.cpp File Reference

Bluetooth/BIP/BtBipGetImageReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipGetImageReq.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipGetImageReq.cpp:

Generated on Tue Jan 24 19:58:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImageReq.hpp File Reference

Bluetooth/BIP/BtBipGetImageReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetImageReq_hpp

Define Documentation

#define BtBipGetImageReq_hpp

Generated on Tue Jan 24 19:58:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImageReq.hpp Source File

Bluetooth/BIP/BtBipGetImageReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetImageReq_hpp)
00009 #define BtBipGetImageReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipGetReq.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtBipClientService;
00020
00023 class BtBipGetImageReq : public BtBipGetReq
00024 {
00025     private:
00026         typedef BtBipGetReq Base;
00027
00028     public:
00030         BtBipGetImageReq(BtBipClientService& Bip_client_service);
00031
00033         virtual ~BtBipGetImageReq();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040
00041         /**********************************************************************/
00042         /* Put Image Req parameter access methods                         */
00043         /**********************************************************************/
00044
00046
00048         void SetImageHdl(const BtBipImageHdlPtr& hdl);
00049         void SetImageDesc(const BtBipImageDescPtr& img_desc);
00050
00051
00053
00054         void SetFileLen(UINT32 file_len) { m_file_len = file_len; }
00055         UINT32 GetFileLen() { return m_file_len; }
00056
00057     protected:
00059
00061         virtual BOOLEAN Execute();
00062
00063     private:
00064         /* Parameters */
00065         btapi_bip_get_img_t*    GetApiSettings();
00066         btapi_bip_get_img_t m_operation_params;
00067
00068         BtBipImageHdlPtr    m_img_hdl;
00069
00070         /* Results */
00071         UINT16  m_img_len;
00072         UINT8*  m_img_body;
00073         UINT32  m_file_len;
00074
00075     private:
00076         friend class BtBipController;
00077         friend class BtBipClientService;
00078 };
00079 #endif
00080
00081 #endif  // BtBipGetImageReq_hpp
00082
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImageRsp.cpp File Reference

Bluetooth/BIP/BtBipGetImageRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipGetImageRsp.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipGetImageRsp.cpp:

Generated on Tue Jan 24 19:58:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImageRsp.hpp File Reference

Bluetooth/BIP/BtBipGetImageRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetImageRsp_hpp

Define Documentation

#define BtBipGetImageRsp_hpp

Generated on Tue Jan 24 19:58:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImageRsp.hpp Source File

Bluetooth/BIP/BtBipGetImageRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetImageRsp_hpp)
00009 #define BtBipGetImageRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Auxiliary/DataSink.hpp>
00014 #include <Bluetooth/BIP/BtBipGetRsp.hpp>
00015
00018 class BtBipGetImageRsp : BtBipGetRsp
00019 {
00020     private:
00021         typedef BtBipGetRsp Base;
00022
00023     public:
00025         BtBipGetImageRsp();
00027         virtual ~BtBipGetImageRsp();
00028
00029         virtual BtRequestType GetRequestType() const { return BtRqtBipGetImage; }
00030
00031         void GetImageInd(const BtBipImageHdlPtr& img_hdl, const UINT8* img_desc, UINT16 img_desc_len);
00032         void SetFileLen(UINT32 file_len) { m_file_len = file_len; }
00033
00034         BtBipImageDescPtr&  GetImageDesc() { return m_img_desc; }
00035
00036     protected:
00037         virtual BOOLEAN ExecuteRsp();
00038
00039     private:
00040         UINT32  m_file_len;
00041         BtBipImageDescPtr   m_img_desc;
00042
00043     private:
00044         friend class BtBipController;
00045         friend class BtBipServerService;
00046 };
00047 #endif
00048
00049 #endif  // BtBipGetImageRsp_hpp
00050
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagesListReq.cpp File Reference

Bluetooth/BIP/BtBipGetImagesListReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipGetImagesListReq.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include <Auxiliary/StringDataSink.hpp>

Include dependency graph for BtBipGetImagesListReq.cpp:

Generated on Tue Jan 24 19:58:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagesListReq.hpp File Reference

Bluetooth/BIP/BtBipGetImagesListReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetImagesListReq_hpp

Define Documentation

#define BtBipGetImagesListReq_hpp

Generated on Tue Jan 24 19:58:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagesListReq.hpp Source File

Bluetooth/BIP/BtBipGetImagesListReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetImagesListReq_hpp)
00009 #define BtBipGetImagesListReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipGetReq.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtBipClientService;
00020
00023 class BtBipGetImagesListReq : public BtBipGetReq
00024 {
00025     private:
00026         typedef BtBipGetReq Base;
00027
00028     public:
00030         BtBipGetImagesListReq(BtBipClientService& Bip_client_service);
00031
00033         virtual ~BtBipGetImagesListReq();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040
00041         /**********************************************************************/
00042         /* Put Image Req parameter access methods                         */
00043         /**********************************************************************/
00044
00046
00049
00050
00053         void SetNrOfHandles(UINT16 nr_of_handles) { m_operation_params.NrOfHandles = nr_of_handles; }
00054
00055         void SetStartOffset(UINT16 start_offset) { m_operation_params.StartOffset = start_offset; }
00056
00057         void SetSortByLatest(BOOLEAN sort_by_latest) { m_operation_params.SortByLatest = sort_by_latest; }
00058
00059         void SetHandleDesc(const BtBipImageHdlDescPtr& img_hdl_desc);
00060
00061         void SetImageListSink(const DataSinkPtr& sink) { m_img_list_sink = sink; }
00062
00063         const BtBipImageListPtr& GetImageList();
00064         //TODO: GetAppliedHandleDesc
00065
00066     protected:
00068
00070         virtual BOOLEAN Execute();
00071
00072     private:
00073         /* Results */
00074         void SetAppliedHandleDesc(UINT16 hdl_desc_len, const UINT8* hdl_desc);
00075
00076         btapi_bip_get_imgs_list_t*  GetApiSettings();
00077         btapi_bip_get_imgs_list_t   m_operation_params;
00078
00079         BtBipImageListPtr   m_img_list;
00080         DataSinkPtr         m_img_list_sink;
00081
00082     private:
00083         friend class BtBipController;
00084         friend class BtBipClientService;
00085 };
00086 #endif
00087
00088 #endif  // BtBipGetImagesListReq_hpp
00089
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagesListRsp.cpp File Reference

Bluetooth/BIP/BtBipGetImagesListRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipGetImagesListRsp.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include <Auxiliary/BinDataDataSource.hpp>
#include <Auxiliary/RamData.hpp>

Include dependency graph for BtBipGetImagesListRsp.cpp:

Generated on Tue Jan 24 19:58:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagesListRsp.hpp File Reference

Bluetooth/BIP/BtBipGetImagesListRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetImagesListRsp_hpp

Define Documentation

#define BtBipGetImagesListRsp_hpp

Generated on Tue Jan 24 19:58:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagesListRsp.hpp Source File

Bluetooth/BIP/BtBipGetImagesListRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetImagesListRsp_hpp)
00009 #define BtBipGetImagesListRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Auxiliary/DataSink.hpp>
00014 #include <Bluetooth/BIP/BtBipGetRsp.hpp>
00015
00018 class BtBipGetImagesListRsp : BtBipGetRsp
00019 {
00020     private:
00021         typedef BtBipGetRsp Base;
00022
00023     public:
00025         BtBipGetImagesListRsp();
00027         virtual ~BtBipGetImagesListRsp();
00028
00029         virtual BtRequestType GetRequestType() const { return BtRqtBipGetImagesList; }
00030
00031         void GetImagesListInd(UINT16 first_index, UINT16 max_images, BOOLEAN sort_by_latest_first, UINT16 filter_len, UINT8* filter);
00032         void SetImagesList(const BtBipImageListPtr& image_list);
00033
00034         const BtBipImageHdlDescPtr& GetFilter() { return m_filter; }
00035
00036 protected:
00037         virtual BOOLEAN ExecuteRsp();
00038
00039     private:
00040         UINT16  m_imgs_cnt;
00041         BtBipImageHdlDescPtr m_filter;
00042         UINT8*  m_img_desc_text;
00043
00044     private:
00045         friend class BtBipController;
00046         friend class BtBipServerService;
00047 };
00048 #endif
00049
00050 #endif  // BtBipGetImagesListRsp_hpp
00051
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.cpp File Reference

Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipGetImagingCapabilitiesReq.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include <Auxiliary/StringDataSink.hpp>

Include dependency graph for BtBipGetImagingCapabilitiesReq.cpp:

Generated on Tue Jan 24 19:58:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.hpp File Reference

Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetImagingCapabilitiesReq_hpp

Define Documentation

#define BtBipGetImagingCapabilitiesReq_hpp

Generated on Tue Jan 24 19:58:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.hpp Source File

Bluetooth/BIP/BtBipGetImagingCapabilitiesReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetImagingCapabilitiesReq_hpp)
00009 #define BtBipGetImagingCapabilitiesReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipGetReq.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtBipClientService;
00020
00023 class BtBipGetImagingCapabilitiesReq : public BtBipGetReq
00024 {
00025     private:
00026         typedef BtBipGetReq Base;
00027
00028     public:
00030         BtBipGetImagingCapabilitiesReq(BtBipClientService& Bip_client_service);
00031
00033         virtual ~BtBipGetImagingCapabilitiesReq();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040         /**********************************************************************/
00041         /* Put Image Req parameter access methods                         */
00042         /*********************************************************************/
00043
00044         void SetImageHdl(const BtBipImageHdlPtr& hdl);
00045         void SetImageCapabilitiesSink(const DataSinkPtr& sink) { m_img_caps_sink = sink; }
00046
00047         const BtBipImagingCapabilitiesPtr& GetImagingCapabilities();
00048
00049     protected:
00051
00053         virtual BOOLEAN Execute();
00054
00055     private:
00056
00057         BtBipImagingCapabilitiesPtr m_img_caps;
00058         DataSinkPtr                 m_img_caps_sink;
00059
00060     private:
00061         friend class BtBipController;
00062         friend class BtBipClientService;
00063 };
00064 #endif
00065
00066 #endif  // BtBipGetImagingCapabilitiesReq_hpp
00067
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.cpp File Reference

Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipGetImagingCapabilitiesRsp.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include <Auxiliary/BinDataDataSource.hpp>
#include <Auxiliary/RamData.hpp>

Include dependency graph for BtBipGetImagingCapabilitiesRsp.cpp:

Generated on Tue Jan 24 19:58:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.hpp File Reference

Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetImagingCapabilitiesRsp_hpp

Define Documentation

#define BtBipGetImagingCapabilitiesRsp_hpp

Generated on Tue Jan 24 19:58:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.hpp Source File

Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetImagingCapabilitiesRsp_hpp)
00009 #define BtBipGetImagingCapabilitiesRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Auxiliary/DataSink.hpp>
00014 #include <Bluetooth/BIP/BtBipGetRsp.hpp>
00015 #include <Bluetooth/BIP/BtBipTypes.hpp>
00016
00019 class BtBipGetImagingCapabilitiesRsp : BtBipGetRsp
00020 {
00021     private:
00022         typedef BtBipGetRsp Base;
00023
00024     public:
00026         BtBipGetImagingCapabilitiesRsp();
00028         virtual ~BtBipGetImagingCapabilitiesRsp();
00029
00030         virtual BtRequestType GetRequestType() const { return BtRqtBipGetImagingCapabilities; }
00031
00032         void GetImagingCapabilitesInd();
00033
00034         void SetImagingCapabilities(const BtBipImagingCapabilitiesPtr& caps);
00035
00036     protected:
00037         virtual BOOLEAN ExecuteRsp();
00038
00039         UINT8*  m_img_caps;
00040
00041
00042     private:
00043         friend class BtBipController;
00044         friend class BtBipServerService;
00045 };
00046 #endif
00047
00048 #endif  // BtBipGetImagingCapabilitiesRsp_hpp
00049
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedAttachmentReq.cpp File Reference

Bluetooth/BIP/BtBipGetLinkedAttachmentReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipGetLinkedAttachmentReq.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipGetLinkedAttachmentReq.cpp:

Generated on Tue Jan 24 19:58:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedAttachmentReq.hpp File Reference

Bluetooth/BIP/BtBipGetLinkedAttachmentReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetLinkedAttachmentReq_hpp

Define Documentation

#define BtBipGetLinkedAttachmentReq_hpp

Generated on Tue Jan 24 19:58:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedAttachmentReq.hpp Source File

Bluetooth/BIP/BtBipGetLinkedAttachmentReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetLinkedAttachmentReq_hpp)
00009 #define BtBipGetLinkedAttachmentReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipGetReq.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtBipClientService;
00020
00023 class BtBipGetLinkedAttachmentReq : public BtBipGetReq
00024 {
00025     private:
00026         typedef BtBipGetReq Base;
00027
00028     public:
00030         BtBipGetLinkedAttachmentReq(BtBipClientService& Bip_client_service);
00031
00033         virtual ~BtBipGetLinkedAttachmentReq();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040
00041         /**********************************************************************/
00042         /* Put Image Req parameter access methods                         */
00043         /**********************************************************************/
00044
00046
00048         void SetImageHdl(const BtBipImageHdlPtr& hdl);
00049         void SetFileName(const WString& filename);
00050
00051
00053
00054     protected:
00056
00058         virtual BOOLEAN Execute();
00059
00060     private:
00061         /* Parameters */
00062         btapi_bip_get_linked_attach_req_t*  GetApiSettings() { return &m_operation_params; }
00063         btapi_bip_get_linked_attach_req_t       m_operation_params;
00064
00065         WString             m_file_name;
00066         BtBipImageHdlPtr    m_img_hdl;
00067
00068     private:
00069         friend class BtBipController;
00070         friend class BtBipClientService;
00071 };
00072 #endif
00073
00074 #endif  // BtBipGetLinkedAttachmentReq_hpp
00075
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.cpp File Reference

Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipGetLinkedAttachmentRsp.hpp"

Include dependency graph for BtBipGetLinkedAttachmentRsp.cpp:

Generated on Tue Jan 24 19:58:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.hpp File Reference

Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetLinkedAttachmentRsp_hpp

Define Documentation

#define BtBipGetLinkedAttachmentRsp_hpp

Generated on Tue Jan 24 19:58:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.hpp Source File

Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetLinkedAttachmentRsp_hpp)
00009 #define BtBipGetLinkedAttachmentRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include <Auxiliary/DataSink.hpp>
00015 #include <Bluetooth/BIP/BtBipGetRsp.hpp>
00016
00019 class BtBipGetLinkedAttachmentRsp : BtBipGetRsp
00020 {
00021     private:
00022         typedef BtBipGetRsp Base;
00023
00024     public:
00026         BtBipGetLinkedAttachmentRsp();
00028         virtual ~BtBipGetLinkedAttachmentRsp();
00029
00030         virtual BtRequestType GetRequestType() const { return BtRqtBipGetLinkedAttachment; }
00031
00032         void GetLinkedAttachmentInd();
00033
00034     protected:
00035         virtual BOOLEAN ExecuteRsp();
00036
00037     private:
00038         friend class BtBipController;
00039         friend class BtBipServerService;
00040 };
00041 #endif
00042
00043 #endif  // BtBipGetLinkedAttachmentRsp_hpp
00044
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedThumbnailReq.cpp File Reference

Bluetooth/BIP/BtBipGetLinkedThumbnailReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipGetLinkedThumbnailReq.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipGetLinkedThumbnailReq.cpp:

Generated on Tue Jan 24 19:58:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedThumbnailReq.hpp File Reference

Bluetooth/BIP/BtBipGetLinkedThumbnailReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetLinkedThumbnailReq_hpp

Define Documentation

#define BtBipGetLinkedThumbnailReq_hpp

Generated on Tue Jan 24 19:58:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedThumbnailReq.hpp Source File

Bluetooth/BIP/BtBipGetLinkedThumbnailReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetLinkedThumbnailReq_hpp)
00009 #define BtBipGetLinkedThumbnailReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipGetReq.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtBipClientService;
00020
00023 class BtBipGetLinkedThumbnailReq : public BtBipGetReq
00024 {
00025     private:
00026         typedef BtBipGetReq Base;
00027
00028     public:
00030         BtBipGetLinkedThumbnailReq(BtBipClientService& Bip_client_service);
00031
00033         virtual ~BtBipGetLinkedThumbnailReq();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040
00041         /**********************************************************************/
00042         /* Put Image Req parameter access methods                         */
00043         /**********************************************************************/
00044
00046
00048         void SetImageHdl(const BtBipImageHdlPtr& hdl);
00049
00050
00052
00053     protected:
00055
00057         virtual BOOLEAN Execute();
00058
00059     private:
00060         /* Parameters */
00061         const btapi_bip_img_hdl_t*  GetApiSettings() { return m_operation_params; }
00062         const btapi_bip_img_hdl_t*  m_operation_params;
00063
00064         BtBipImageHdlPtr    m_img_hdl;
00065
00066     private:
00067         friend class BtBipController;
00068         friend class BtBipClientService;
00069 };
00070 #endif
00071
00072 #endif  // BtBipGetLinkedThumbnailReq_hpp
00073
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.cpp File Reference

Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipGetLinkedThumbnailRsp.hpp"

Include dependency graph for BtBipGetLinkedThumbnailRsp.cpp:

Generated on Tue Jan 24 19:58:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.hpp File Reference

Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetLinkedThumbnailRsp_hpp

Define Documentation

#define BtBipGetLinkedThumbnailRsp_hpp

Generated on Tue Jan 24 19:58:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.hpp Source File

Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetLinkedThumbnailRsp_hpp)
00009 #define BtBipGetLinkedThumbnailRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include <Auxiliary/DataSink.hpp>
00015 #include <Bluetooth/BIP/BtBipGetRsp.hpp>
00016
00019 class BtBipGetLinkedThumbnailRsp : BtBipGetRsp
00020 {
00021     private:
00022         typedef BtBipGetRsp Base;
00023
00024     public:
00026         BtBipGetLinkedThumbnailRsp();
00028         virtual ~BtBipGetLinkedThumbnailRsp();
00029
00030         virtual BtRequestType GetRequestType() const { return BtRqtBipGetLinkedThumbnail; }
00031
00032         void GetLinkedThumbnailInd();
00033
00034     protected:
00035         virtual BOOLEAN ExecuteRsp();
00036
00037     private:
00038         friend class BtBipController;
00039         friend class BtBipServerService;
00040 };
00041 #endif
00042
00043 #endif  // BtBipGetLinkedThumbnailRsp_hpp
00044
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetReq.cpp File Reference

Bluetooth/BIP/BtBipGetReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipGetReq.hpp"

Include dependency graph for BtBipGetReq.cpp:

Generated on Tue Jan 24 19:58:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetReq.hpp File Reference

Bluetooth/BIP/BtBipGetReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetReq_hpp

Define Documentation

#define BtBipGetReq_hpp

Generated on Tue Jan 24 19:58:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetReq.hpp Source File

Bluetooth/BIP/BtBipGetReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetReq_hpp)
00009 #define BtBipGetReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipReq.hpp>
00014 #include <Bluetooth/BIP/BtBipAbortReq.hpp>
00015 #include <Auxiliary/DataSink.hpp>
00016
00019 class BtBipGetReq : public BtBipReq
00020 {
00021     private:
00022         typedef BtBipReq Base;
00023
00024     public:
00026         BtBipGetReq(BtBipClientService& bip_client_service);
00027
00029         virtual ~BtBipGetReq();
00030
00031         BOOLEAN Init(const DataSinkPtr& ds);
00032         void WritePacket(UINT16 len, UINT8* data);
00033
00034         virtual BOOLEAN Abort(const WString& abort_desc);
00035         virtual void AbortCfm(BtBipResult bip_result, const BtObexResponseCode& obex_response);
00036
00037
00038         UINT32  GetBytesReceived() { return m_bytes_rec; }
00039
00040         virtual UINT32  GetBytesTransfered() { return GetBytesReceived(); }
00041
00042     protected:
00043
00045
00048         BOOLEAN Finished() { return (m_cur_sink.Get() == 0); }
00049
00050         // called by BtBipGetReq if request is finished
00051 //      virtual void CleanUp() = 0;
00052
00053         virtual void ExecutionCallback(BtResultCode result);
00054
00055
00056     private:
00057         void ReleaseEverything();
00058
00059         DataSinkPtr     m_cur_sink;
00060
00061         UINT16          m_packet_cnt;
00062         UINT32          m_bytes_rec;
00063
00064         BtBipAbortReq*  m_abort_req;
00065         BOOLEAN         m_req_pending;
00066
00067     private:
00068         friend class BtBipController;
00069         friend class BtBipClientService;
00070 };
00071 #endif
00072
00073 #endif  // BtBipGetReq_hpp
00074
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetRsp.cpp File Reference

Bluetooth/BIP/BtBipGetRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipGetRsp.hpp"

Include dependency graph for BtBipGetRsp.cpp:

Variables

const UINT16 c_server_get_packet_size = 256

Variable Documentation

const UINT16 c_server_get_packet_size = 256

Generated on Tue Jan 24 19:58:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetRsp.hpp File Reference

Bluetooth/BIP/BtBipGetRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipGetRsp_hpp

Define Documentation

#define BtBipGetRsp_hpp

Generated on Tue Jan 24 19:58:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipGetRsp.hpp Source File

Bluetooth/BIP/BtBipGetRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipGetRsp_hpp)
00009 #define BtBipGetRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Auxiliary/DataSource.hpp>
00014
00017 class BtBipGetRsp
00018 {
00019     public:
00021         BtBipGetRsp();
00023         virtual ~BtBipGetRsp();
00024
00025         void SetDataSource(const DataSourcePtr& ds);
00026         void SetLastMsg(BOOLEAN last_msg) { m_last_msg = last_msg; }
00027         void SetObexResult(BtObexResponseCode obex_rsp_code) { m_obex_rsp = obex_rsp_code; }
00028
00029         BOOLEAN Execute();
00030
00031         virtual BtRequestType GetRequestType() const = 0;
00032
00033
00034         void GetInd();
00035         void BodyCompleteInd();
00036
00037         BOOLEAN Cancel(BtObexResponseCode obex_rsp_code);
00038
00039         BOOLEAN IsFirst() { return m_first_msg; }
00040         BOOLEAN IsLast() { return m_last_msg; }
00041         BOOLEAN IsFinished() { return !m_active; }
00042         void Abort(const WString& desc);
00043
00044         UINT32 GetProgressInBytes() { return m_bytes_transfered; }
00045
00046
00047     protected:
00048         BtObexResponseCode GetObexResult() { return m_obex_rsp; }
00049         const UINT8*    GetBody() { return m_cur_buf; }
00050         UINT16          GetBodyLen() { return m_cur_buf_len; }
00051
00052         virtual BOOLEAN ExecuteRsp() = 0;
00053
00054     private:
00055
00056         DataSourcePtr   m_cur_src;
00057         UINT8*          m_cur_buf;
00058         UINT16          m_cur_buf_len;
00059
00060         BtObexResponseCode  m_obex_rsp;
00061         UINT16              m_packet_cnt;
00062         WString             m_abort_desc;
00063
00064         UINT16          m_packet_size;
00065
00066         BOOLEAN         m_first_msg;
00067         BOOLEAN         m_last_msg;
00068
00069         BOOLEAN         m_cancel_pending;
00070         BOOLEAN         m_abort_pending;
00071         BOOLEAN         m_rsp_pending;
00072         BOOLEAN         m_active;
00073
00074         UINT32          m_bytes_transfered;
00075
00076     private:
00077         friend class BtBipController;
00078         friend class BtBipServerService;
00079 };
00080 #endif
00081
00082 #endif  // BtBipGetRsp_hpp
00083
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipMecelXmlConverter.cpp File Reference

Bluetooth/BIP/BtBipMecelXmlConverter.cpp File Reference

#include "PreComp.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include "btapi_bip_xml.h"
#include "BtBipTypes.hpp"
#include <Auxiliary/String.hpp>

Include dependency graph for BtBipMecelXmlConverter.cpp:

Variables

const int c_bip_convert_buf_size = 20480

Variable Documentation

const int c_bip_convert_buf_size = 20480

Generated on Tue Jan 24 19:58:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipMecelXmlConverter.hpp File Reference

Bluetooth/BIP/BtBipMecelXmlConverter.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipMecelXMLConverter_hpp

Define Documentation

#define BtBipMecelXMLConverter_hpp

Generated on Tue Jan 24 19:58:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipMecelXmlConverter.hpp Source File

Bluetooth/BIP/BtBipMecelXmlConverter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipMecelXMLConverter_hpp)
00009 #define BtBipMecelXMLConverter_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014 #include <Bluetooth/BIP/BtBipDataConverter.hpp>
00015
00016 extern const int c_bip_convert_buf_size ;
00017
00019 /*
00020 */
00021 class BtBipMecelXmlConverter : public BtBipDataConverter
00022 {
00023 public:
00024
00025     BtBipMecelXmlConverter();
00026
00027     virtual ~BtBipMecelXmlConverter();
00028
00030     /* The text can be retrieved once after a conversion. Afterwards, the internal buffer is freed.
00031        If buffer_handover is set to TRUE, the caller has to take the responsibilitie
00032        to free the buffer.
00033     */
00034     UINT8* GetXmlText(BOOLEAN buffer_handover = FALSE);
00035
00036     virtual void Init();
00037
00038     /* Encoding Data->XML */
00039     virtual BOOLEAN ConvertBipImageDesc(const BtBipImageDesc& img_desc);
00040     virtual BOOLEAN ConvertBipImageHdlDesc(const BtBipImageHdlDesc& img_hdl_desc);
00041     virtual BOOLEAN ConvertBipImagesList(const BtBipImageList& img_list);
00042     virtual BOOLEAN ConvertBipImagingCapabilities(const BtBipImagingCapabilities& img_list);
00043     virtual BOOLEAN ConvertBipImageProperties(const BtBipImageProperties& img_props);
00044     virtual BOOLEAN ConvertBipAttachmentDesc(const BtBipAttachmentDesc& attach_hdl_desc);
00045
00046     /* Decoding XML->Data */
00047     virtual void ConvertXmlImageDesc(const UINT8* body, UINT16 len, BtBipImageDesc& img_desc);
00048     virtual void ConvertXmlImageHdlDesc(const UINT8* body, UINT16 len, BtBipImageHdlDesc& img_hdl_desc);
00049     virtual void ConvertXmlImageList(const UINT8* body, UINT16 len, BtBipImageListPtr& img_list);
00050     virtual void ConvertXmlImagingCapabilities(const UINT8* body, UINT16 len, BtBipImagingCapabilities& img_list);
00051     virtual void ConvertXmlImageProperties(const UINT8* body, UINT16 len, BtBipImageProperties& img_props);
00052     virtual void ConvertXmlAttachmentDesc(const UINT8* body, UINT16 len, BtBipAttachmentDesc& attach_hdl_desc);
00053
00054 private:
00055
00056     void BtBipMecelXmlConverter::ConvertBipImageDim(const BtBipImageFormat::ImageDim& img_dim, String& dim_str);
00057
00058     UINT8*  m_buffer;
00059     UINT8*  m_buffer_ptr;
00060     UINT16  m_free_bytes;
00061     BOOLEAN m_keep_buffer;
00062 };
00063 #endif
00064 #endif // BtBipMecelXMLConverter_hpp
00065
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipMsgArg.cpp File Reference

Bluetooth/BIP/BtBipMsgArg.cpp File Reference

#include "PreComp.hpp"
#include "BtObexMessageArguments.hpp"

Include dependency graph for BtBipMsgArg.cpp:

Generated on Tue Jan 24 19:58:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipMsgArg.hpp File Reference

Bluetooth/BIP/BtBipMsgArg.hpp File Reference

Go to the source code of this file.

Data Structures

class | BtBipDeleteImageIndArg
Delete Image Request Indication. More...
class | BtBipGetImageInd
Get Image Request Indication. More...
class | BtBipGetImagePropertiesInd
Get Image Properties Request Indication. More...
class | BtBipGetImagesListInd
Get Images List Request Indication. More...
class | BtBipGetImagingCapabilitesIndArg
Get Imaging Capabilities Request Indication. More...
class | BtBipGetLinkedAttachmentInd
Get Linked Attachment Request Indication. More...
class | BtBipGetLinkedThumbnailInd
Get Linked Thumbnail Image Request Indication. More...
class | BtBipMsgArg
Base class for all notification arguments of Bt BIP profile. More...
class | BtBipPutImageIndArg
Put Image Request Indication. More...
class | BtBipPutLinkedAttachmentInd
Put Linked Attachment Request Indication. More...
class | BtBipPutLinkedThumbnailIndArg
Put Linked Thumbnail Request Indication. More...

Defines

#define | Bluetooth_BtBipMsgArg_hpp

Typedefs

typedef NiSharedPtr< BtBipMsgArg > | BtBipMsgArgPtr
Shared Pointer to BIP Msg Arguments.

Define Documentation

#define Bluetooth_BtBipMsgArg_hpp

Typedef Documentation

typedef NiSharedPtr<BtBipMsgArg> BtBipMsgArgPtr

Shared Pointer to BIP Msg Arguments.

Generated on Tue Jan 24 19:58:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipMsgArg.hpp Source File

Bluetooth/BIP/BtBipMsgArg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------*/
00008
00009 #if !defined(Bluetooth_BtBipMsgArg_hpp)
00010 #define Bluetooth_BtBipMsgArg_hpp
00011
00012
00014 typedef NiSharedPtr<BtBipMsgArg> BtBipMsgArgPtr;
00015
00017 class BtBipMsgArg
00018 {
00019 public:
00020     BtBipMsgArg();
00021     virtual ~BtBipMsgArg();
00022 };
00023
00025
00029 class BtBipGetImagingCapabilitesIndArg : public BtBipMsgArg
00030 {
00031     enum {
00032         ID = 9
00033     };
00034
00035     BtBipGetImagingCapabilitiesIndArg();
00036 };
00037
00039
00043 class BtBipPutImageIndArg : public BtBipMsgArg
00044 {
00045     enum  {
00046         ID = 10
00047     };
00048
00049     BtBipPutImageIndArg(const WString& name, const BipImageDescriptor& img_desc, BOOLEAN img_complete);
00050
00051 private:
00052     WString name;
00053     BipImageDescriptor img_desc;
00054     DataSourcePtr img;
00055     BOOLEAN img_complete;
00056 };
00057
00058
00060
00064 class BtBipPutLinkedThumbnailIndArg : public BtBipMsgArg
00065 {
00066     enum  {
00067         ID = 11
00068     };
00069
00070     BtBipPutLinkedThumbnailIndArg(const BipImageHandle& img_handle, BOOLEAN thumb_complete);
00071 };
00072
00074
00078 class BtBipPutLinkedAttachmentInd : public BtBipMsgArg
00079 {
00080     enum  {
00081         ID = 12
00082     };
00083
00084     BtBipPutLinkedAttachmentInd(const BipImageHandle& img_handle, const BipImageDescriptor& img_desc, BOOLEAN attachment_complete)
00085 };
00086
00088
00092 class BtBipGetImagesListInd : public BtBipMsgArg
00093 {
00094     enum  {
00095         ID = 13
00096     };
00097
00098     BtBipGetImagesListInd(INT first_index, INT max_images, BOOLEAN sort_by_latest_first, const ImageHandleDescriptor& filter);
00099 };
00100
00102
00106 class BtBipGetImagePropertiesInd : public BtBipMsgArg
00107 {
00108     enum  {
00109         ID = 14
00110     };
00111
00112     BtBipGetImagePropertiesInd(const BipImageHandle& img_handle);
00113 };
00114
00116
00120 class BtBipGetImageInd : public BtBipMsgArg
00121 {
00122     enum  {
00123         ID = 15
00124     };
00125
00126     BtBipGetImageInd(const BipImageHandle& img_handle, const BipImageDescriptor& img_desc);
00127 };
00128
00130
00134 class BtBipGetLinkedThumbnailInd : public BtBipMsgArg
00135 {
00136     enum  {
00137         ID = 16
00138     };
00139
00140     BtBipGetLinkedThumbnailInd(const BipImageHandle& img_handle);
00141 };
00142
00144
00148 class BtBipGetLinkedAttachmentInd : public BtBipMsgArg
00149 {
00150     enum  {
00151         ID = 17
00152     };
00153
00154     BtBipGetLinkedAttachmentInd(const BipImageHandle& img_handle, const WString& file_name);
00155 };
00156
00158
00162 class BtBipDeleteImageIndArg : public BtBipMsgArg
00163 {
00164     enum  {
00165         ID = 18
00166     };
00167
00168     BtBipDeleteImageIndArg(const BipImageHandle& img_handle);
00169 };
00170
00171 #endif // Bluetooth_BtBipMsgArg_hpp
00172
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipNotificationMsg.cpp File Reference

Bluetooth/BIP/BtBipNotificationMsg.cpp File Reference

#include "PreComp.hpp"
#include "BtBipNotificationMsg.hpp"
#include "BtBipNotificationMsgArg.hpp"

Include dependency graph for BtBipNotificationMsg.cpp:

Generated on Tue Jan 24 19:58:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipNotificationMsg.hpp File Reference

Bluetooth/BIP/BtBipNotificationMsg.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipServerNotificationMsg_hpp

Define Documentation

#define BtBipServerNotificationMsg_hpp

Generated on Tue Jan 24 19:58:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipNotificationMsg.hpp Source File

Bluetooth/BIP/BtBipNotificationMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipServerNotificationMsg_hpp)
00009 #define BtBipServerNotificationMsg_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Kernel/Message.hpp>
00014 #include <Bluetooth/BIP/BtBipServerService.hpp>
00015 #include <Bluetooth/BIP/BtBipNotificationMsgArg.hpp>
00016
00022 class BtBipServerNotificationMsg : public Message
00023 {
00024     private:
00025         typedef Message Base;
00026
00027     public:
00029         BtBipServerNotificationMsg(BtBipServerService* service, BtBipServerNotificationMsgArgPtr argument);
00030
00032         BtBipServerNotificationMsg(const BtBipServerNotificationMsg &message);
00033
00035         virtual ~BtBipServerNotificationMsg();
00036
00038
00040         virtual BtBipServerNotificationMsg& operator=(const BtBipServerNotificationMsg &message);
00041
00043         BtBipServerService* GetService() const;
00044
00046         BtBipServerNotificationMsgArgPtr    GetArgument() const;
00047
00049
00051         virtual const MsgMetaData& GetMetaData() const;
00052
00054
00056         virtual Message* Clone() const;
00057
00058     public:
00059         enum { ID = 10501  };
00060
00061     private:
00063         BtBipServerService*                 m_service;
00064         BtBipServerNotificationMsgArgPtr    m_arg;
00065
00066     private:
00068         static const MsgMetaData m_meta_data;
00069 };
00070 #endif
00071 #endif // BtBipServerNotificationMsg_hpp
00072
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipNotificationMsgArg.cpp File Reference

Bluetooth/BIP/BtBipNotificationMsgArg.cpp File Reference

#include "PreComp.hpp"
#include "BtBipNotificationMsgArg.hpp"

Include dependency graph for BtBipNotificationMsgArg.cpp:

Generated on Tue Jan 24 19:59:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipNotificationMsgArg.hpp File Reference

Bluetooth/BIP/BtBipNotificationMsgArg.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BIP/BtBipTypes.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/DataSource.hpp>
#include <Auxiliary/DataSink.hpp>

Include dependency graph for BtBipNotificationMsgArg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBipAbortIndArg
Abort Indication. More...
class | BtBipConnectIndArg
Connect Indication. More...
class | BtBipDeleteImageIndArg
Delete Image Request Indication. More...
class | BtBipDisconnectIndArg
Disconnect Indication. More...
class | BtBipGetImageIndArg
Get Image Request Indication. More...
class | BtBipGetImagePropertiesIndArg
Get Images List Request Indication. More...
class | BtBipGetImagesListIndArg
Get Images List Request Indication. More...
class | BtBipGetImagingCapabilitiesIndArg
Get Imaging Capabilities Request Indication. More...
class | BtBipGetLinkedAttachmentIndArg
Get Images List Request Indication. More...
class | BtBipGetLinkedThumbnailIndArg
Get Images List Request Indication. More...
class | BtBipOpFinishedArg
Get Images List Request Indication. More...
class | BtBipPutImageCompleteArg
Put Image Complete. More...
class | BtBipPutImageIndArg
Put Image Request Indication. More...
class | BtBipPutLinkedAttachmentCompleteArg
Put Image Complete. More...
class | BtBipPutLinkedAttachmentIndArg
Put Image Request Indication. More...
class | BtBipPutLinkedThumbnailCompleteArg
Put Image Complete. More...
class | BtBipPutLinkedThumbnailIndArg
Put Linked Thumbnail Request Indication. More...
class | BtBipServerNotificationMsgArg

Defines

#define | Bluetooth_BIP_BtBipServerNotificationMsgArg_hpp

Typedefs

typedef NiSharedPtr< BtBipServerNotificationMsgArg > | BtBipServerNotificationMsgArgPtr

Define Documentation

#define Bluetooth_BIP_BtBipServerNotificationMsgArg_hpp

Typedef Documentation

typedef NiSharedPtr<BtBipServerNotificationMsgArg> BtBipServerNotificationMsgArgPtr

Generated on Tue Jan 24 19:59:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipNotificationMsgArg.hpp Source File

Bluetooth/BIP/BtBipNotificationMsgArg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008 */
00009
00010 #if !defined(Bluetooth_BIP_BtBipServerNotificationMsgArg_hpp)
00011 #define Bluetooth_BIP_BtBipServerNotificationMsgArg_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/BIP/BtBipTypes.hpp>
00015 #include <Bluetooth/BtDeviceAddress.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017 #include <Auxiliary/WString.hpp>
00018 #include <Auxiliary/DataSource.hpp>
00019 #include <Auxiliary/DataSink.hpp>
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 // Base class for all BtBipServerNotificationMsgArgs
00026 class BtBipServerNotificationMsgArg
00027 {
00028 public:
00029     BtBipServerNotificationMsgArg(INT id);
00030     virtual ~BtBipServerNotificationMsgArg();
00031
00032     INT Id() const { return m_id; }
00033
00034 private:
00035     INT m_id;
00036 };
00037
00038 typedef NiSharedPtr<BtBipServerNotificationMsgArg> BtBipServerNotificationMsgArgPtr;
00039
00040
00041 /*  ------------------------------------------------------------------------
00042     Connect
00043     ------------------------------------------------------------------------ */
00044
00046
00049 class BtBipConnectIndArg : public BtBipServerNotificationMsgArg {
00050
00051     typedef BtBipServerNotificationMsgArg Base;
00052
00053     public:
00054         BtBipConnectIndArg(const BtBipSessionId& session_id, const BtDeviceAddress& device_adr);
00055         virtual ~BtBipConnectIndArg();
00056
00057         static const BtBipConnectIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00058
00059         BtBipSessionId GetSessionId() const { return m_session_id; }
00060         const BtDeviceAddress& GetDeviceAdr() const { return m_device_adr; }
00061
00062         enum  {
00063             ID = 1
00064             };
00065
00066     private:
00067
00068         BtBipSessionId m_session_id;
00069         BtDeviceAddress m_device_adr;
00070
00071 };
00072
00073 // Inline definitions
00074 inline const BtBipConnectIndArg& BtBipConnectIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00075     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipConnectIndArg!\n");
00076     return ((const BtBipConnectIndArg&) arg);
00077 };
00078
00079 /*  ------------------------------------------------------------------------
00080     Disconnect
00081     ------------------------------------------------------------------------ */
00082
00084
00087 class BtBipDisconnectIndArg : public BtBipServerNotificationMsgArg {
00088
00089     typedef BtBipServerNotificationMsgArg Base;
00090
00091     public:
00092         BtBipDisconnectIndArg();
00093         virtual ~BtBipDisconnectIndArg();
00094
00095         static const BtBipDisconnectIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00096
00097         enum  {
00098             ID = 2
00099             };
00100
00101     private:
00102
00103 };
00104
00105 // Inline definitions
00106 inline const BtBipDisconnectIndArg& BtBipDisconnectIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00107     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipDisconnectIndArg!\n");
00108     return ((const BtBipDisconnectIndArg&) arg);
00109 };
00110
00111 /*  ------------------------------------------------------------------------
00112     Abort
00113     ------------------------------------------------------------------------ */
00114
00116
00119 class BtBipAbortIndArg : public BtBipServerNotificationMsgArg {
00120
00121     typedef BtBipServerNotificationMsgArg Base;
00122
00123     public:
00124         BtBipAbortIndArg(const WString& abort_desc);
00125         virtual ~BtBipAbortIndArg();
00126
00127         static const BtBipAbortIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00128
00129         const WString& GetAbortDesc() const { return m_desc; }
00130
00131         enum  {
00132             ID = 7
00133             };
00134
00135     private:
00136         WString m_desc;
00137
00138 };
00139
00140 // Inline definitions
00141 inline const BtBipAbortIndArg& BtBipAbortIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00142     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipAbortIndArg!\n");
00143     return ((const BtBipAbortIndArg&) arg);
00144 };
00145
00146 /*  ------------------------------------------------------------------------
00147     PutImage
00148     ------------------------------------------------------------------------ */
00149
00151
00155 class BtBipPutImageIndArg : public BtBipServerNotificationMsgArg
00156 {
00157     typedef BtBipServerNotificationMsgArg Base;
00158
00159     public:
00160
00161         BtBipPutImageIndArg(const WString& name, const BtBipImageDescPtr& img_desc);
00162         virtual ~BtBipPutImageIndArg();
00163
00164         const WString& GetImageName() const { return m_name; }
00165         const BtBipImageDescPtr& GetImageDesc() const { return m_img_desc; }
00166
00167         static const BtBipPutImageIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00168
00169         enum  {
00170             ID = 3
00171         };
00172
00173     private:
00174         WString m_name;
00175         BtBipImageDescPtr m_img_desc;
00176 };
00177
00178 // Inline definitions
00179 inline const BtBipPutImageIndArg& BtBipPutImageIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00180     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipPutImageIndArg!\n");
00181     return ((const BtBipPutImageIndArg&) arg);
00182 };
00183
00185
00188 class BtBipPutImageCompleteArg : public BtBipServerNotificationMsgArg
00189 {
00190     typedef BtBipServerNotificationMsgArg Base;
00191
00192     public:
00193
00194         BtBipPutImageCompleteArg(const BtBipImageHdlPtr& img_hdl);
00195         virtual ~BtBipPutImageCompleteArg();
00196
00197         static const BtBipPutImageCompleteArg& Cast(const BtBipServerNotificationMsgArg& arg);
00198
00199         const BtBipImageHdlPtr& GetImageHdl() { return m_img_hdl; }
00200
00201         enum  {
00202             ID = 4
00203         };
00204
00205     private:
00206         BtBipImageHdlPtr    m_img_hdl;
00207 };
00208
00209 // Inline definitions
00210 inline const BtBipPutImageCompleteArg& BtBipPutImageCompleteArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00211     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipPutImageIndArg!\n");
00212     return ((const BtBipPutImageCompleteArg&) arg);
00213 };
00214
00215 /*  ------------------------------------------------------------------------
00216     PutThumb
00217     ------------------------------------------------------------------------ */
00218
00220
00224 class BtBipPutLinkedThumbnailIndArg : public BtBipServerNotificationMsgArg
00225 {
00226     typedef BtBipServerNotificationMsgArg Base;
00227
00228     public:
00229
00230         BtBipPutLinkedThumbnailIndArg(const BtBipImageHdlPtr& img_hdl);
00231         virtual ~BtBipPutLinkedThumbnailIndArg();
00232
00233         const BtBipImageHdlPtr& GetImageHdl() const { return m_img_hdl; }
00234
00235         static const BtBipPutLinkedThumbnailIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00236
00237         enum  {
00238             ID = 10
00239         };
00240
00241     private:
00242         BtBipImageHdlPtr m_img_hdl;
00243 };
00244
00245 // Inline definitions
00246 inline const BtBipPutLinkedThumbnailIndArg& BtBipPutLinkedThumbnailIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00247     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipPutLinkedThumbnailIndArg!\n");
00248     return ((const BtBipPutLinkedThumbnailIndArg&) arg);
00249 };
00250
00252
00255 class BtBipPutLinkedThumbnailCompleteArg : public BtBipServerNotificationMsgArg
00256 {
00257     typedef BtBipServerNotificationMsgArg Base;
00258
00259     public:
00260
00261         BtBipPutLinkedThumbnailCompleteArg(const BtBipImageHdlPtr& img_hdl);
00262         virtual ~BtBipPutLinkedThumbnailCompleteArg();
00263
00264         static const BtBipPutLinkedThumbnailCompleteArg& Cast(const BtBipServerNotificationMsgArg& arg);
00265
00266         const BtBipImageHdlPtr& GetImageHdl() { return m_img_hdl; }
00267
00268         enum  {
00269             ID = 11
00270         };
00271
00272     private:
00273         BtBipImageHdlPtr    m_img_hdl;
00274 };
00275
00276 // Inline definitions
00277 inline const BtBipPutLinkedThumbnailCompleteArg& BtBipPutLinkedThumbnailCompleteArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00278     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipPutLinkedThumbnailCompleteArg!\n");
00279     return ((const BtBipPutLinkedThumbnailCompleteArg&) arg);
00280 };
00281
00282 /*  ------------------------------------------------------------------------
00283     PutAttach
00284     ------------------------------------------------------------------------ */
00285
00287
00291 class BtBipPutLinkedAttachmentIndArg : public BtBipServerNotificationMsgArg
00292 {
00293     typedef BtBipServerNotificationMsgArg Base;
00294
00295     public:
00296
00297         BtBipPutLinkedAttachmentIndArg(const BtBipImageHdlPtr& img_hdl, const BtBipAttachmentDescPtr& attach_desc);
00298         virtual ~BtBipPutLinkedAttachmentIndArg();
00299
00300         const BtBipImageHdlPtr& GetImageHdl() const { return m_img_hdl; }
00301         const BtBipAttachmentDescPtr& GetAttachmentDesc() const { return m_attach_desc; }
00302
00303         static const BtBipPutLinkedAttachmentIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00304
00305         enum  {
00306             ID = 12
00307         };
00308
00309     private:
00310         BtBipImageHdlPtr m_img_hdl;
00311         BtBipAttachmentDescPtr m_attach_desc;
00312 };
00313
00314 // Inline definitions
00315 inline const BtBipPutLinkedAttachmentIndArg& BtBipPutLinkedAttachmentIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00316     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipPutLinkedAttachmentIndArg!\n");
00317     return ((const BtBipPutLinkedAttachmentIndArg&) arg);
00318 };
00319
00321
00324 class BtBipPutLinkedAttachmentCompleteArg : public BtBipServerNotificationMsgArg
00325 {
00326     typedef BtBipServerNotificationMsgArg Base;
00327
00328     public:
00329
00330         BtBipPutLinkedAttachmentCompleteArg(const BtBipImageHdlPtr& img_hdl);
00331         virtual ~BtBipPutLinkedAttachmentCompleteArg();
00332
00333         static const BtBipPutLinkedAttachmentCompleteArg& Cast(const BtBipServerNotificationMsgArg& arg);
00334
00335         const BtBipImageHdlPtr& GetImageHdl() { return m_img_hdl; }
00336
00337         enum  {
00338             ID = 13
00339         };
00340
00341     private:
00342         BtBipImageHdlPtr    m_img_hdl;
00343 };
00344
00345 // Inline definitions
00346 inline const BtBipPutLinkedAttachmentCompleteArg& BtBipPutLinkedAttachmentCompleteArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00347     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipPutLinkedAttachmentCompleteArg!\n");
00348     return ((const BtBipPutLinkedAttachmentCompleteArg&) arg);
00349 };
00350
00351 /*  ------------------------------------------------------------------------
00352     BtBipGetImagesListInd
00353     ------------------------------------------------------------------------ */
00354
00356
00360 class BtBipGetImagesListIndArg : public BtBipServerNotificationMsgArg
00361 {
00362     typedef BtBipServerNotificationMsgArg Base;
00363
00364     public:
00365
00366         BtBipGetImagesListIndArg(UINT16 first_index, UINT16 max_images, BOOLEAN sort_by_latest_first, const BtBipImageHdlDescPtr& filter);
00367         virtual ~BtBipGetImagesListIndArg();
00368
00369         static const BtBipGetImagesListIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00370
00371         INT GetFirstIndex() const { return m_first_index; }
00372         INT GetMaxImages() const { return m_max_images; }
00373         BOOLEAN GetSortByLatestFirst() const { return m_sort_by_latest; }
00374         const BtBipImageHdlDescPtr& GetFilter() const { return m_filter; }
00375
00376         enum  {
00377             ID = 5
00378         };
00379
00380     private:
00381         BtBipImageHdlDescPtr    m_filter;
00382         UINT16                  m_first_index;
00383         UINT16                  m_max_images;
00384         BOOLEAN                 m_sort_by_latest;
00385
00386 };
00387
00388 // Inline definitions
00389 inline const BtBipGetImagesListIndArg& BtBipGetImagesListIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00390     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipGetImagesListIndArg!\n");
00391     return ((const BtBipGetImagesListIndArg&) arg);
00392 };
00393
00394 /*  ------------------------------------------------------------------------
00395     BtBipGetImageProperties
00396     ------------------------------------------------------------------------ */
00397
00399
00403 class BtBipGetImagePropertiesIndArg : public BtBipServerNotificationMsgArg
00404 {
00405     typedef BtBipServerNotificationMsgArg Base;
00406
00407     public:
00408
00409         BtBipGetImagePropertiesIndArg(const BtBipImageHdlPtr& hdl);
00410         virtual ~BtBipGetImagePropertiesIndArg();
00411
00412         static const BtBipGetImagePropertiesIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00413
00414         const BtBipImageHdlPtr& GetImageHdl() const { return m_img_hdl; }
00415
00416         enum  {
00417             ID = 14
00418         };
00419
00420     private:
00421         BtBipImageHdlPtr        m_img_hdl;
00422 };
00423
00424 // Inline definitions
00425 inline const BtBipGetImagePropertiesIndArg& BtBipGetImagePropertiesIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00426     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipGetImagePropertiesIndArg!\n");
00427     return ((const BtBipGetImagePropertiesIndArg&) arg);
00428 };
00429
00431
00435 class BtBipOpFinishedArg : public BtBipServerNotificationMsgArg
00436 {
00437     typedef BtBipServerNotificationMsgArg Base;
00438
00439     public:
00440
00441         BtBipOpFinishedArg(BtObexResponseCode obex_rsp, BtRequestType request_type);
00442         virtual ~BtBipOpFinishedArg();
00443
00444         static const BtBipOpFinishedArg& Cast(const BtBipServerNotificationMsgArg& arg);
00445
00446         BtObexResponseCode GetObexResult() const { return m_obex_rsp; }
00447
00448         BtRequestType GetRequestType() const { return m_req_type; }
00449
00450         enum  {
00451             ID = 8
00452         };
00453
00454     private:
00455         BtObexResponseCode      m_obex_rsp;
00456         BtRequestType           m_req_type;
00457 };
00458
00459 // Inline definitions
00460 inline const BtBipOpFinishedArg& BtBipOpFinishedArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00461     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipOpFinishedArg!\n");
00462     return ((const BtBipOpFinishedArg&) arg);
00463 };
00464
00465 /*  ------------------------------------------------------------------------
00466     BtBipGetImageInd
00467     ------------------------------------------------------------------------ */
00468
00470
00474 class BtBipGetImageIndArg : public BtBipServerNotificationMsgArg
00475 {
00476     typedef BtBipServerNotificationMsgArg Base;
00477
00478     public:
00479
00480         BtBipGetImageIndArg(const BtBipImageHdlPtr& img_hdl, const BtBipImageDescPtr& img_desc);
00481         ~BtBipGetImageIndArg();
00482
00483         static const BtBipGetImageIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00484
00485         const BtBipImageHdlPtr& GetImageHandle() const { return m_img_hdl; }
00486         const BtBipImageDescPtr& GetImageDesc() const { return m_img_desc; }
00487
00488         enum  {
00489             ID = 6
00490         };
00491
00492     private:
00493         BtBipImageHdlPtr m_img_hdl;
00494         BtBipImageDescPtr m_img_desc;
00495
00496 };
00497
00498 // Inline definitions
00499 inline const BtBipGetImageIndArg& BtBipGetImageIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00500     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipGetImageIndArg!\n");
00501     return ((const BtBipGetImageIndArg&) arg);
00502 };
00503
00504 /*  ------------------------------------------------------------------------
00505     BtBipGetLinkedThumbnailIndArg
00506     ------------------------------------------------------------------------ */
00507
00509
00513 class BtBipGetLinkedThumbnailIndArg : public BtBipServerNotificationMsgArg
00514 {
00515     typedef BtBipServerNotificationMsgArg Base;
00516
00517     public:
00518
00519         BtBipGetLinkedThumbnailIndArg(const BtBipImageHdlPtr& hdl);
00520         virtual ~BtBipGetLinkedThumbnailIndArg();
00521
00522         static const BtBipGetLinkedThumbnailIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00523
00524         const BtBipImageHdlPtr& GetImageHdl() const { return m_img_hdl; }
00525
00526         enum  {
00527             ID = 15
00528         };
00529
00530     private:
00531         BtBipImageHdlPtr        m_img_hdl;
00532 };
00533
00534 // Inline definitions
00535 inline const BtBipGetLinkedThumbnailIndArg& BtBipGetLinkedThumbnailIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00536     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipGetLinkedThumbnailIndArg!\n");
00537     return ((const BtBipGetLinkedThumbnailIndArg&) arg);
00538 };
00539
00540 /*  ------------------------------------------------------------------------
00541     BtBipGetLinkedAttachmentIndArg
00542     ------------------------------------------------------------------------ */
00543
00545
00549 class BtBipGetLinkedAttachmentIndArg : public BtBipServerNotificationMsgArg
00550 {
00551     typedef BtBipServerNotificationMsgArg Base;
00552
00553     public:
00554
00555         BtBipGetLinkedAttachmentIndArg(const BtBipImageHdlPtr& hdl, const WString& file_name);
00556         virtual ~BtBipGetLinkedAttachmentIndArg();
00557
00558         static const BtBipGetLinkedAttachmentIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00559
00560         const BtBipImageHdlPtr& GetImageHdl() const { return m_img_hdl; }
00561         const WString& GetFileName() const { return m_file_name; }
00562
00563         enum  {
00564             ID = 16
00565         };
00566
00567     private:
00568         BtBipImageHdlPtr        m_img_hdl;
00569         WString                 m_file_name;
00570 };
00571
00572 // Inline definitions
00573 inline const BtBipGetLinkedAttachmentIndArg& BtBipGetLinkedAttachmentIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00574     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipGetLinkedAttachmentIndArg!\n");
00575     return ((const BtBipGetLinkedAttachmentIndArg&) arg);
00576 };
00577
00578 /*  ------------------------------------------------------------------------
00579     BtBipDeleteImageIndArg
00580     ------------------------------------------------------------------------ */
00581
00583
00587 class BtBipDeleteImageIndArg : public BtBipServerNotificationMsgArg
00588 {
00589     typedef BtBipServerNotificationMsgArg Base;
00590
00591     public:
00592
00593         BtBipDeleteImageIndArg(const BtBipImageHdlPtr& hdl);
00594         virtual ~BtBipDeleteImageIndArg();
00595
00596         static const BtBipDeleteImageIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00597
00598         const BtBipImageHdlPtr& GetImageHdl() const { return m_img_hdl; }
00599
00600         enum  {
00601             ID = 17
00602         };
00603
00604     private:
00605         BtBipImageHdlPtr        m_img_hdl;
00606 };
00607
00608 // Inline definitions
00609 inline const BtBipDeleteImageIndArg& BtBipDeleteImageIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00610     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipDeleteImageIndArg!\n");
00611     return ((const BtBipDeleteImageIndArg&) arg);
00612 };
00613
00614 /*  ------------------------------------------------------------------------
00615     GetImagingCapabilities
00616     ------------------------------------------------------------------------ */
00617
00619
00623 class BtBipGetImagingCapabilitiesIndArg : public BtBipServerNotificationMsgArg
00624 {
00625     private:
00626         typedef BtBipServerNotificationMsgArg Base;
00627
00628     public:
00629         BtBipGetImagingCapabilitiesIndArg();
00630         ~BtBipGetImagingCapabilitiesIndArg();
00631
00632         static const BtBipGetImagingCapabilitiesIndArg& Cast(const BtBipServerNotificationMsgArg& arg);
00633
00634         enum {
00635             ID = 9
00636         };
00637 };
00638
00639 // Inline definitions
00640 inline const BtBipGetImagingCapabilitiesIndArg& BtBipGetImagingCapabilitiesIndArg::Cast(const BtBipServerNotificationMsgArg& arg) {
00641     ASSERT_INFO((arg.Id() == ID), L"BtBipServerNotificationMsgArg failed to cast to BtBipGetImagingCapabilitiesIndArg!\n");
00642     return ((const BtBipGetImagingCapabilitiesIndArg&) arg);
00643 };
00644
00645
00646 #endif // Bluetooth_BIP_BtBipServerNotificationMsgArg_hpp
00647
00648
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutAttachReq.cpp File Reference

Bluetooth/BIP/BtBipPutAttachReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipPutAttachReq.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipPutAttachReq.cpp:

Generated on Tue Jan 24 19:59:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutAttachReq.hpp File Reference

Bluetooth/BIP/BtBipPutAttachReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipPutAttachReq_hpp

Define Documentation

#define BtBipPutAttachReq_hpp

Generated on Tue Jan 24 19:59:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutAttachReq.hpp Source File

Bluetooth/BIP/BtBipPutAttachReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipPutAttachReq_hpp)
00009 #define BtBipPutAttachReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include <Bluetooth/BIP/BtBipReq.hpp>
00015 #include <Bluetooth/BIP/BtBipPutReq.hpp>
00016
00017 #include <Gui/ImageObtainer.hpp>
00018
00019 /*  ------------------------------------------------------------------------
00020     Forward deklarations for friend relationships.
00021     ------------------------------------------------------------------------ */
00022
00023 class BtBipClientService;
00024
00027 class BtBipPutAttachReq : public BtBipPutReq
00028 {
00029     private:
00030         typedef BtBipPutReq Base;
00031
00032     public:
00034         BtBipPutAttachReq(BtBipClientService& Bip_client_service);
00035
00037         virtual ~BtBipPutAttachReq();
00038
00040
00042         virtual BtRequestType GetRequestType() const;
00043
00044         /**********************************************************************/
00045         /* Put Image Req parameter access methods                             */
00046         /**********************************************************************/
00047
00049
00051         void SetImageHdl(const BtBipImageHdlPtr& img_hdl);
00052         void SetAttachmentDesc(const BtBipAttachmentDescPtr& attach_desc);
00053
00054         /**********************************************************************/
00056         /**********************************************************************/
00057
00058         virtual void PrepareNextPacket();
00059
00060     protected:
00062
00064         virtual BOOLEAN Execute();
00065
00066         virtual void CleanUp();
00067
00068     private:
00069
00070         btapi_bip_put_linked_attachment_t*  GetApiSettings();
00071         btapi_bip_put_linked_attachment_t   m_operation_params;
00072
00073         BtBipImageHdlPtr        m_img_hdl;
00074
00075     private:
00076         friend class BtBipController;
00077         friend class BtBipClientService;
00078 };
00079 #endif
00080
00081 #endif  // BtBipPutAttachReq_hpp
00082
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutAttachRsp.cpp File Reference

Bluetooth/BIP/BtBipPutAttachRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipPutAttachRsp.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipPutAttachRsp.cpp:

Generated on Tue Jan 24 19:59:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutAttachRsp.hpp File Reference

Bluetooth/BIP/BtBipPutAttachRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipPutAttachRsp_hpp

Define Documentation

#define BtBipPutAttachRsp_hpp

Generated on Tue Jan 24 19:59:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutAttachRsp.hpp Source File

Bluetooth/BIP/BtBipPutAttachRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipPutAttachRsp_hpp)
00009 #define BtBipPutAttachRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipPutRsp.hpp>
00014
00017 class BtBipPutAttachRsp : public BtBipPutRsp
00018 {
00019     private:
00020         typedef BtBipPutRsp Base;
00021
00022     public:
00024         BtBipPutAttachRsp();
00025
00027         virtual ~BtBipPutAttachRsp();
00028
00029         void PutLinkedAttachmentInd(const BtBipImageHdlPtr& img_hdl, const UINT8* attach_desc, UINT16 attach_desc_len,
00030                                     const UINT8* body, UINT16 body_len, BOOLEAN last_msg);
00031
00032         virtual BOOLEAN ExecuteRsp();
00033
00034         const BtBipImageHdlPtr& GetImageHdl() { return m_img_hdl; }
00035         const BtBipAttachmentDescPtr& GetAttachDesc() { return m_attach_desc; }
00036
00037         virtual BtRequestType GetRequestType() const { return BtRqtBipPutLinkedAttachment; }
00038
00039     protected:
00040
00041     private:
00042         BtBipImageHdlPtr    m_img_hdl;
00043         BtBipAttachmentDescPtr  m_attach_desc;
00044
00045     private:
00046         friend class BtBipController;
00047 };
00048 #endif
00049
00050 #endif  // BtBipPutAttachRsp_hpp
00051
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutImageReq.cpp File Reference

Bluetooth/BIP/BtBipPutImageReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipPutImageReq.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipPutImageReq.cpp:

Generated on Tue Jan 24 19:59:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutImageReq.hpp File Reference

Bluetooth/BIP/BtBipPutImageReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipPutImageReq_hpp

Define Documentation

#define BtBipPutImageReq_hpp

Generated on Tue Jan 24 19:59:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutImageReq.hpp Source File

Bluetooth/BIP/BtBipPutImageReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipPutImageReq_hpp)
00009 #define BtBipPutImageReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipReq.hpp>
00014 #include <Bluetooth/BIP/BtBipPutReq.hpp>
00015
00016 #include <Gui/ImageObtainer.hpp>
00017
00018 /*  ------------------------------------------------------------------------
00019     Forward deklarations for friend relationships.
00020     ------------------------------------------------------------------------ */
00021
00022 class BtBipClientService;
00023
00026 class BtBipPutImageReq : public BtBipPutReq
00027 {
00028     private:
00029         typedef BtBipPutReq Base;
00030
00031     public:
00033         BtBipPutImageReq(BtBipClientService& Bip_client_service);
00034
00036         virtual ~BtBipPutImageReq();
00037
00039
00041         virtual BtRequestType GetRequestType() const;
00042
00043         /**********************************************************************/
00044         /* Put Image Req parameter access methods                             */
00045         /**********************************************************************/
00046
00048
00050         void SetImageName(const WCHAR* img_name);
00051         void SetImageDesc(const BtBipImageDescPtr& img_desc);
00052         void SetImageObtainer(const ImageObtainer& img_obt);
00053
00054         /**********************************************************************/
00056         /**********************************************************************/
00057         void SetImageHdl(const BtBipImageHdlPtr& hdl) { m_img_hdl = hdl; }
00058         const BtBipImageHdlPtr& GetImageHdl() { return m_img_hdl; }
00059
00060         virtual void PrepareNextPacket();
00061
00062     protected:
00064
00066         virtual BOOLEAN Execute();
00067
00068         virtual void CleanUp();
00069
00071
00073 //      virtual void ExecutionCallback(BtResultCode result);
00074
00075     private:
00076
00077         btapi_bip_put_img_t*    GetApiSettings();
00078
00079         btapi_bip_put_img_t     m_operation_params;
00080
00081         BtBipImageHdlPtr        m_img_hdl;
00082         ImageObtainer*          m_cur_img_obt;
00083
00084     private:
00085         friend class BtBipController;
00086         friend class BtBipClientService;
00087 };
00088 #endif
00089
00090 #endif  // BtBipPutImageReq_hpp
00091
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutImageRsp.cpp File Reference

Bluetooth/BIP/BtBipPutImageRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipPutImageRsp.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipPutImageRsp.cpp:

Variables

const UINT16 c_bip_client_put_packet_size = 256

Variable Documentation

const UINT16 c_bip_client_put_packet_size = 256

Generated on Tue Jan 24 19:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutImageRsp.hpp File Reference

Bluetooth/BIP/BtBipPutImageRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BipPutImageRsp_hpp

Define Documentation

#define BipPutImageRsp_hpp

Generated on Tue Jan 24 19:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutImageRsp.hpp Source File

Bluetooth/BIP/BtBipPutImageRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BipPutImageRsp_hpp)
00009 #define BipPutImageRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipPutRsp.hpp>
00014
00017 class BtBipPutImageRsp : public BtBipPutRsp
00018 {
00019     private:
00020         typedef BtBipPutRsp Base;
00021
00022     public:
00024         BtBipPutImageRsp();
00025
00027         virtual ~BtBipPutImageRsp();
00028
00029         void PutImageInd(const WString& name, const UINT8* img_desc,
00030                          UINT16 img_desc_len, const UINT8* body, UINT16 body_len, BOOLEAN last_msg);
00031
00032         void SetImageHdl(const BtBipImageHdlPtr& img_hdl) { m_img_hdl = img_hdl; }
00033         virtual BOOLEAN ExecuteRsp();
00034
00035         const WString& GetName() { return m_name; }
00036         const BtBipImageDescPtr& GetImageDesc() { return m_img_desc; }
00037         const BtBipImageHdlPtr& GetImageHdl() { return m_img_hdl; }
00038
00039         virtual BtRequestType GetRequestType() const { return BtRqtBipPutImage; }
00040
00041     protected:
00042
00043     private:
00044         WString             m_name;
00045         BtBipImageDescPtr   m_img_desc;
00046         BtBipImageHdlPtr    m_img_hdl;
00047
00048 //      BOOLEAN             m_abort_pending;
00049 //      BOOLEAN             m_rsp_pending;
00050
00051     private:
00052         friend class BtBipController;
00053 };
00054 #endif
00055
00056 #endif  // BipPutImageRsp_hpp
00057
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutReq.cpp File Reference

Bluetooth/BIP/BtBipPutReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipPutReq.hpp"

Include dependency graph for BtBipPutReq.cpp:

Variables

const UINT16 c_bip_client_put_packet_size = 256

Variable Documentation

const UINT16 c_bip_client_put_packet_size = 256

Generated on Tue Jan 24 19:59:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutReq.hpp File Reference

Bluetooth/BIP/BtBipPutReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipPutReq_hpp

Define Documentation

#define BtBipPutReq_hpp

Generated on Tue Jan 24 19:59:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutReq.hpp Source File

Bluetooth/BIP/BtBipPutReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipPutReq_hpp)
00009 #define BtBipPutReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipReq.hpp>
00014 #include <Bluetooth/BIP/BtBipAbortReq.hpp>
00015
00016 extern const UINT16 c_bip_client_put_packet_size;
00017
00020 class BtBipPutReq : public BtBipReq
00021 {
00022     private:
00023         typedef BtBipReq Base;
00024
00025     public:
00027         BtBipPutReq(BtBipClientService& bip_client_service);
00028
00030         virtual ~BtBipPutReq();
00031
00032         BOOLEAN Init(const DataSourcePtr& ds);
00033         virtual void PrepareNextPacket() = 0;
00034         void SetPacketSize(UINT16 packet_size) { m_packet_size = packet_size; }
00035
00036         virtual BOOLEAN Abort(const WString& abort_desc);
00037         virtual void AbortCfm(BtBipResult bip_result, const BtObexResponseCode& obex_response);
00038
00039         UINT32  GetBytesSent() { return m_bytes_sent; }
00040
00041         virtual UINT32  GetBytesTransfered() { return GetBytesSent(); }
00042
00043
00044     protected:
00045
00047
00050         const UINT8* ReadNextPacket(UINT32& bytes_read);
00051
00052         BOOLEAN Finished() { return (m_cur_src.Get() == 0); }
00053
00054         // called by BtBipPutReq if request is finished
00055         virtual void CleanUp() = 0;
00056
00057         virtual void ExecutionCallback(BtResultCode result);
00058
00059
00060     private:
00061         void ReleaseEverything();
00062
00063         DataSourcePtr   m_cur_src;
00064         UINT8*          m_cur_buf;
00065         UINT16          m_cur_buf_len;
00066         UINT16          m_packet_size;
00067
00068         UINT16          m_packet_cnt;
00069         UINT32          m_bytes_sent;
00070
00071         BtBipAbortReq*  m_abort_req;
00072         BOOLEAN         m_req_pending;
00073
00074     private:
00075         friend class BtBipController;
00076         friend class BtBipClientService;
00077 };
00078 #endif
00079
00080 #endif  // BtBipPutReq_hpp
00081
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutRsp.cpp File Reference

Bluetooth/BIP/BtBipPutRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipPutRsp.hpp"

Include dependency graph for BtBipPutRsp.cpp:

Generated on Tue Jan 24 19:59:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutRsp.hpp File Reference

Bluetooth/BIP/BtBipPutRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipPutRsp_hpp

Define Documentation

#define BtBipPutRsp_hpp

Generated on Tue Jan 24 19:59:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutRsp.hpp Source File

Bluetooth/BIP/BtBipPutRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipPutRsp_hpp)
00009 #define BtBipPutRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Auxiliary/DataSink.hpp>
00014
00017 class BtBipPutRsp
00018 {
00019     public:
00021         BtBipPutRsp();
00023         virtual ~BtBipPutRsp();
00024
00025         void SetBody(const UINT8* buf, UINT16 buf_len);
00026         void SetDataSink(const DataSinkPtr& ds);
00027         void SetLastMsg(BOOLEAN last_msg) { m_last_msg = last_msg; }
00028         void SetObexResult(BtObexResponseCode obex_resp_code) { m_obex_resp = obex_resp_code; }
00029
00030         BOOLEAN IsFirst() { return ((m_cur_sink.Get() == 0) || (m_first_msg)); }
00031         BOOLEAN IsFinished() { return m_last_msg; }
00032
00033         void SetFirstMsg(BOOLEAN first) { m_first_msg = first; }
00034         void PrepareNextPacket();
00035         BOOLEAN Execute();
00036
00037         void Abort(const WString& desc);
00038
00039         virtual BtRequestType GetRequestType() const = 0;
00040
00041         UINT32 GetProgressInBytes() { return m_bytes_transfered; }
00042
00043     protected:
00044         BtObexResponseCode GetObexResult() { return m_obex_resp; }
00045
00046         virtual BOOLEAN ExecuteRsp() = 0;
00047
00048     private:
00049
00050         DataSinkPtr     m_cur_sink;
00051         UINT8*          m_cur_buf;
00052         UINT16          m_cur_buf_len;
00053
00054         BOOLEAN         m_last_msg;
00055         BOOLEAN         m_first_msg;
00056         BOOLEAN         m_active;
00057         BOOLEAN         m_rsp_pending;
00058         BOOLEAN         m_abort_pending;
00059
00060         BtObexResponseCode  m_obex_resp;
00061         UINT16          m_packet_cnt;
00062         WString         m_abort_desc;
00063
00064         UINT32          m_bytes_transfered;
00065
00066
00067     private:
00068         friend class BtBipController;
00069         friend class BtBipServerService;
00070 };
00071 #endif
00072
00073 #endif  // BtBipPutRsp_hpp
00074
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutThumbReq.cpp File Reference

Bluetooth/BIP/BtBipPutThumbReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipClientService.hpp"
#include "BtBipController.hpp"
#include "BtBipPutThumbReq.hpp"

Include dependency graph for BtBipPutThumbReq.cpp:

Generated on Tue Jan 24 19:59:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutThumbReq.hpp File Reference

Bluetooth/BIP/BtBipPutThumbReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipPutThumbReq_hpp

Define Documentation

#define BtBipPutThumbReq_hpp

Generated on Tue Jan 24 19:59:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutThumbReq.hpp Source File

Bluetooth/BIP/BtBipPutThumbReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipPutThumbReq_hpp)
00009 #define BtBipPutThumbReq_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #include <Bluetooth/BIP/BtBipReq.hpp>
00014 #include <Bluetooth/BIP/BtBipPutReq.hpp>
00015
00016 #include <Gui/ImageObtainer.hpp>
00017
00018 /*  ------------------------------------------------------------------------
00019     Forward deklarations for friend relationships.
00020     ------------------------------------------------------------------------ */
00021
00022 class BtBipClientService;
00023
00026 class BtBipPutThumbReq : public BtBipPutReq
00027 {
00028     private:
00029         typedef BtBipPutReq Base;
00030
00031     public:
00033         BtBipPutThumbReq(BtBipClientService& Bip_client_service);
00034
00036         virtual ~BtBipPutThumbReq();
00037
00039
00041         virtual BtRequestType GetRequestType() const;
00042
00043         /**********************************************************************/
00044         /* Put Image Req parameter access methods                             */
00045         /**********************************************************************/
00046
00048
00050         void SetImageHdl(const BtBipImageHdlPtr& img_hdl);
00051         void SetImageObtainer(const ImageObtainer& img_obt);
00052
00053         /**********************************************************************/
00055         /**********************************************************************/
00056
00057         virtual void PrepareNextPacket();
00058
00059     protected:
00061
00063         virtual BOOLEAN Execute();
00064
00065         virtual void CleanUp();
00066
00068
00070 //      virtual void ExecutionCallback(BtResultCode result);
00071
00072     private:
00073
00074         btapi_bip_put_linked_thumb_t*   GetApiSettings();
00075
00076         btapi_bip_put_linked_thumb_t    m_operation_params;
00077
00078         BtBipImageHdlPtr        m_img_hdl;
00079
00080         ImageObtainer*          m_cur_img_obt;
00081
00082     private:
00083         friend class BtBipController;
00084         friend class BtBipClientService;
00085 };
00086 #endif
00087
00088 #endif  // BtBipPutThumbReq_hpp
00089
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutThumbRsp.cpp File Reference

Bluetooth/BIP/BtBipPutThumbRsp.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipPutThumbRsp.hpp"
#include "BtBipMecelXmlConverter.hpp"

Include dependency graph for BtBipPutThumbRsp.cpp:

Generated on Tue Jan 24 19:59:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutThumbRsp.hpp File Reference

Bluetooth/BIP/BtBipPutThumbRsp.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipPutThumbRsp_hpp

Define Documentation

#define BtBipPutThumbRsp_hpp

Generated on Tue Jan 24 19:59:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipPutThumbRsp.hpp Source File

Bluetooth/BIP/BtBipPutThumbRsp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipPutThumbRsp_hpp)
00009 #define BtBipPutThumbRsp_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include <Bluetooth/BIP/BtBipPutRsp.hpp>
00015
00018 class BtBipPutThumbRsp : public BtBipPutRsp
00019 {
00020     private:
00021         typedef BtBipPutRsp Base;
00022
00023     public:
00025         BtBipPutThumbRsp();
00026
00028         virtual ~BtBipPutThumbRsp();
00029
00030         void PutLinkedThumbnailInd(const BtBipImageHdlPtr& img_hdl, const UINT8* body, UINT16 body_len, BOOLEAN last_msg);
00031
00032         virtual BOOLEAN ExecuteRsp();
00033
00034         const BtBipImageHdlPtr& GetImageHdl() { return m_img_hdl; }
00035
00036         virtual BtRequestType GetRequestType() const { return BtRqtBipPutLinkedThumbnail; }
00037
00038     protected:
00039
00040     private:
00041         BtBipImageHdlPtr    m_img_hdl;
00042
00043     private:
00044         friend class BtBipController;
00045 };
00046 #endif // DOXYGEN_SHOULD_SKIP_THIS
00047
00048 #endif  // BtBipPutThumbRsp_hpp
00049
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipReq.cpp File Reference

Bluetooth/BIP/BtBipReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBipService.hpp"
#include "BtBipReq.hpp"

Include dependency graph for BtBipReq.cpp:

Generated on Tue Jan 24 19:59:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipReq.hpp File Reference

Bluetooth/BIP/BtBipReq.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipRequest_hpp

Define Documentation

#define BtBipRequest_hpp

Generated on Tue Jan 24 19:59:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipReq.hpp Source File

Bluetooth/BIP/BtBipReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipRequest_hpp)
00009 #define BtBipRequest_hpp
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 #include <Bluetooth/BtServiceRequest.hpp>
00015 #include <Bluetooth/BIP/BtBipService.hpp>
00016 #include <Bluetooth/BIP/BtBipTypes.hpp>
00017 #include <stack/extensions.h>
00018
00019 /*  ------------------------------------------------------------------------
00020     Forward deklarations for friend relationships.
00021     ------------------------------------------------------------------------ */
00022
00023 class BtBipController;
00024
00027 class BtBipReq : public BtServiceRequest
00028 {
00029     private:
00030         typedef BtServiceRequest Base;
00031
00032     public:
00034         BtBipReq(BtBipService& obex_service);
00035
00037         virtual ~BtBipReq();
00038
00039         virtual BOOLEAN Abort(const WString& abort_desc) { return FALSE; } // should be abstract if implemented in all sub classes
00040         virtual void AbortCfm(BtBipResult bip_result, const BtObexResponseCode& obex_response) {}
00041
00042         BtObexResponseCode GetObexResult() { return m_obex_result; }
00043         BtBipResult GetBipResult() { return m_bip_result; }
00044
00045         virtual UINT32  GetBytesTransfered() { return 0; }
00046
00047
00048     protected:
00050
00063         virtual BtRequestState ChangeRequestState(BOOLEAN success);
00064
00066
00068 //      virtual BOOLEAN EvaluateExecutionResult(BtResultCode result);
00069
00070         void SetObexResult(BtObexResponseCode res) { m_obex_result = res; }
00071         void SetBipResult(BtBipResult res) { m_bip_result = res; }
00072
00073         BOOLEAN IsAbortPending() { return m_abort_pending; }
00074         void SetAbortPending(BOOLEAN abort_pending) { m_abort_pending = abort_pending; }
00075
00076         BtBipSessionId BtApi2ApoxiBipSessionId(btapi_bip_session_id_t btapi_session_id) const;
00077         btapi_bip_session_id_t Apoxi2BtApiBipSessionId(BtBipSessionId apoxi_session_id) const;
00078
00079     private:
00080         BOOLEAN m_abort_pending;
00081         BtBipResult m_bip_result;
00082         BtObexResponseCode  m_obex_result;
00083         friend class BtBipController;
00084 };
00085 #endif
00086
00087 #endif  // BtBipRequest_hpp
00088
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipServerService.cpp File Reference

Bluetooth/BIP/BtBipServerService.cpp File Reference

#include "PreComp.hpp"
#include "BtBipController.hpp"
#include "BtBipServerService.hpp"
#include "BtBipNotificationMsg.hpp"
#include "BtBipNotificationMsgArg.hpp"
#include "BtBipServiceMsg.hpp"
#include "BtBipMecelXmlConverter.hpp"
#include <Auxiliary/BinDataDataSource.hpp>
#include <Auxiliary/RamData.hpp>

Include dependency graph for BtBipServerService.cpp:

Functions

void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)

Variables

const UINT16 | c_bip_server_read_buf_size = 256

Function Documentation

void OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) |

Variable Documentation

const UINT16 c_bip_server_read_buf_size = 256

Generated on Tue Jan 24 19:59:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipServerService.hpp File Reference

Bluetooth/BIP/BtBipServerService.hpp File Reference

#include <Bluetooth/BIP/BtBipService.hpp>
#include <Bluetooth/BIP/BtBipController.hpp>
#include <Bluetooth/BIP/BtBipTypes.hpp>
#include <Bluetooth/BIP/BtBipPutImageRsp.hpp>
#include <Bluetooth/BIP/BtBipPutThumbRsp.hpp>
#include <Bluetooth/BIP/BtBipPutAttachRsp.hpp>
#include <Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.hpp>
#include <Bluetooth/BIP/BtBipGetImagePropertiesRsp.hpp>
#include <Bluetooth/BIP/BtBipGetImagesListRsp.hpp>
#include <Bluetooth/BIP/BtBipGetImageRsp.hpp>
#include <Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.hpp>
#include <Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.hpp>
#include <Auxiliary/DataSink.hpp>
#include <Auxiliary/DataSource.hpp>

Include dependency graph for BtBipServerService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBipServerService
BIP Server Service (imaging responder). More...

Defines

#define | BtBipServerService_hpp

Define Documentation

#define BtBipServerService_hpp

Generated on Tue Jan 24 19:59:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipServerService.hpp Source File

Bluetooth/BIP/BtBipServerService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipServerService_hpp)
00009 #define BtBipServerService_hpp
00012
00013 #include <Bluetooth/BIP/BtBipService.hpp>
00014 #include <Bluetooth/BIP/BtBipController.hpp>
00015 #include <Bluetooth/BIP/BtBipTypes.hpp>
00016 #include <Bluetooth/BIP/BtBipPutImageRsp.hpp>
00017 #include <Bluetooth/BIP/BtBipPutThumbRsp.hpp>
00018 #include <Bluetooth/BIP/BtBipPutAttachRsp.hpp>
00019 #include <Bluetooth/BIP/BtBipGetImagingCapabilitiesRsp.hpp>
00020 #include <Bluetooth/BIP/BtBipGetImagePropertiesRsp.hpp>
00021 #include <Bluetooth/BIP/BtBipGetImagesListRsp.hpp>
00022 #include <Bluetooth/BIP/BtBipGetImageRsp.hpp>
00023 #include <Bluetooth/BIP/BtBipGetLinkedThumbnailRsp.hpp>
00024 #include <Bluetooth/BIP/BtBipGetLinkedAttachmentRsp.hpp>
00025
00026 #include <Auxiliary/DataSink.hpp>
00027 #include <Auxiliary/DataSource.hpp>
00028
00030
00038 class BtBipServerService : public BtBipService
00039 {
00040     friend class BtBipController;
00041
00042     private:
00043         typedef BtBipService Base;
00044
00045     public:
00046
00048         BtBipServerService();
00049
00051         virtual ~BtBipServerService();
00052
00054
00056         virtual BtRequestState GetRequestState(BtRequestType request_type) const {
00057             return BtRqsUnknown;
00058         }
00059
00061
00063         virtual BOOLEAN IsServerService() const;
00064
00065         BOOLEAN RegisterBipServer();
00066
00068
00070         UINT8 GetRfComChannel() const;
00071
00073
00077         BOOLEAN ConnectRsp(BtObexResponseCode obex_result);
00078
00080
00085         BOOLEAN AbortRsp(BtObexResponseCode obex_result);
00086
00088
00098         BOOLEAN Cancel(BtObexResponseCode obex_result);
00099
00101
00106         BOOLEAN PutImageRsp(BtObexResponseCode obex_result, const BtBipImageHdlPtr& hdl, const DataSinkPtr& image);
00107
00109
00113         BOOLEAN PutLinkedThumbnailRsp(BtObexResponseCode obex_result, const DataSinkPtr& thumb);
00114
00116
00120         BOOLEAN PutLinkedAttachmentRsp(BtObexResponseCode obex_result, const DataSinkPtr& attach);
00121
00123
00128         BOOLEAN GetImagingCapabilitiesRsp(BtObexResponseCode obex_result, const BtBipImagingCapabilitiesPtr& img_cap);
00129
00131
00137         BOOLEAN GetImagesListRsp(BtObexResponseCode obex_result, const BtBipImageListPtr& image_list, const BtBipImageHdlDescPtr& applied_filter);
00138
00140
00144         BOOLEAN GetImagePropertiesRsp(BtObexResponseCode obex_result, const BtBipImagePropertiesPtr& img_props);
00145
00147
00152         BOOLEAN GetImageRsp(BtObexResponseCode obex_result, UINT32 file_length, const DataSourcePtr& img);
00153
00155
00159         BOOLEAN GetLinkedThumbnailRsp(BtObexResponseCode obex_result, const DataSourcePtr& thumb);
00160
00162
00166         BOOLEAN GetLinkedAttachmentRsp(BtObexResponseCode obex_result, const DataSourcePtr& attach);
00167
00169
00172         BOOLEAN DeleteImageRsp(BtObexResponseCode obex_result);
00173
00175
00179         BOOLEAN ErrorRsp(BtRequestState rc);
00180
00182
00184         UINT32  GetProgressInBytes();
00185
00186
00187 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00188
00189         virtual BOOLEAN OnMessage(const Message& msg);
00190 #endif
00191
00192     protected:
00193         virtual void RegisterMessages() const;
00194         virtual void UnregisterMessages() const;
00195
00196         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state) {}
00197
00198     private:
00199
00201         void ConnectInd(BtBipSessionId session_id, const BtDeviceAddress& device_adr);
00203         void DisconnectInd();
00205         void AbortInd(const WString& desc);
00207         void PutImageInd(const WString& name, const UINT8* img_desc, UINT16 img_desc_len, const UINT8* body, UINT16 body_len, BOOLEAN last_msg);
00209         void PutLinkedThumbnailInd(const BtBipImageHdlPtr& img_handle, const UINT8* body, UINT16 body_len, BOOLEAN last_msg);
00211         void PutLinkedAttachmentInd(const BtBipImageHdlPtr& img_handle, const UINT8* attach_desc, UINT16 attach_desc_len, const UINT8* body, UINT16 body_len, BOOLEAN last_msg);
00213         void GetImagingCapabilitiesInd();
00215         void GetImagesListInd(UINT16 first_index, UINT16 max_images, BOOLEAN sort_by_latest_first, UINT16 filter_len, UINT8* filter);
00217         void GetImagePropertiesInd(const BtBipImageHdlPtr& img_hdl);
00219         void GetImageInd(const BtBipImageHdlPtr& img_hdl, const UINT8* img_desc, UINT16 img_desc_len);
00221         void BodyCompleteInd();
00223         void GetLinkedThumbnailInd(const BtBipImageHdlPtr& img_handle);
00225         void GetLinkedAttachmentInd(const BtBipImageHdlPtr& img_handle, const WString& file_name);
00227         void DeleteImageInd(const BtBipImageHdlPtr& img_handle);
00228
00229
00230
00231         BtBipPutRsp*        m_cur_put_rsp;
00232         BtBipPutImageRsp    m_put_img_rsp;
00233         BtBipPutThumbRsp    m_put_thumb_rsp;
00234         BtBipPutAttachRsp   m_put_attach_rsp;
00235
00236         BtBipGetRsp*        m_cur_get_rsp;
00237
00238         BtBipGetImagingCapabilitiesRsp  m_get_img_caps_rsp;
00239         BtBipGetImagesListRsp           m_get_imgs_list_rsp;
00240         BtBipGetImageRsp                m_get_img_rsp;
00241         BtBipGetLinkedThumbnailRsp      m_get_thumb_rsp;
00242         BtBipGetLinkedAttachmentRsp     m_get_attach_rsp;
00243         BtBipGetImagePropertiesRsp      m_get_img_props_rsp;
00244 };
00246 #endif  // BtBipServerService_hpp
00247
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipService.cpp File Reference

Bluetooth/BIP/BtBipService.cpp File Reference

#include "PreComp.hpp"
#include "BtBipService.hpp"
#include "BtBipController.hpp"
#include "BtBipServiceMsg.hpp"

Include dependency graph for BtBipService.cpp:

Generated on Tue Jan 24 19:59:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipService.hpp File Reference

Bluetooth/BIP/BtBipService.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtBipService_hpp

Define Documentation

#define BtBipService_hpp

Generated on Tue Jan 24 19:59:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipService.hpp Source File

Bluetooth/BIP/BtBipService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtBipService_hpp)
00010 #define BtBipService_hpp
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Kernel/UserDispatcher.hpp>
00016 #include <Bluetooth/BtService.hpp>
00017
00018 class BtBipController;
00019
00020
00022 class BtBipService: public BtService
00023 {
00024     private:
00025         typedef BtService Base;
00026
00027     public:
00028         enum MsgType {
00029             ClientPutNextPacket,
00030             ClientGetNextPacket,
00031             ServerPutNextPacket,
00032             ServerGetNextPacket
00033         };
00034
00036         BtBipService();
00037
00039         virtual ~BtBipService();
00040
00042
00047         virtual BtProfile GetProfile() const;
00048
00050
00052         virtual BOOLEAN IsServerService() const = 0;
00053
00055
00057         virtual BOOLEAN OnMessage(const Message& msg);
00058
00059         void SetBufferSize(UINT16 buf_size) { m_buf_size = buf_size; }
00060
00061     protected:
00062
00063
00064         virtual void RegisterMessages() const;
00065         virtual void UnregisterMessages() const;
00066
00067         void SetDispatcher();
00068         void RemoveDispatcher();
00069
00070         void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00071
00072         UINT16              m_buf_size;
00073
00074     private:
00076
00078         BOOLEAN m_disp_added;
00079
00080
00081 };
00082 #endif
00083
00084 #endif  // BtBipService_hpp
00085
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipServiceMsg.cpp File Reference

Bluetooth/BIP/BtBipServiceMsg.cpp File Reference

#include "PreComp.hpp"
#include "BtBipServiceMsg.hpp"

Include dependency graph for BtBipServiceMsg.cpp:

Generated on Tue Jan 24 19:59:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipServiceMsg.hpp File Reference

Bluetooth/BIP/BtBipServiceMsg.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>
#include <Bluetooth/BIP/BtBipService.hpp>

Include dependency graph for BtBipServiceMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBipProgressMsg

Defines

#define | Bluetooth_BtBipServiceMsg_hpp

Define Documentation

#define Bluetooth_BtBipServiceMsg_hpp

Generated on Tue Jan 24 19:59:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipServiceMsg.hpp Source File

Bluetooth/BIP/BtBipServiceMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "src\hauth_bip_apoxi_test_sv\lnz_apoxi\Apoxi\Bluetooth\BIP\BtBipServiceMsg.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtBipServiceMsg_hpp)
00016 #define Bluetooth_BtBipServiceMsg_hpp
00017
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019 #include <Bluetooth/BIP/BtBipService.hpp>
00020
00021 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class BtBipRequestStateChangedMsg
00028     ====================================================================== */
00029
00031 class BtBipRequestStateChangedMsg : public BtRequestStateChangedMessage {
00032     public:
00033         BtBipRequestStateChangedMsg(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00034         virtual ~BtBipRequestStateChangedMsg();
00035
00036         virtual const MsgMetaData& GetMetaData() const;
00037         virtual Message* Clone() const;
00038
00039         enum  {
00040             ID = 10500
00041             };
00042
00043     private:
00044         static const MsgMetaData m_meta_data;
00045
00046 };
00047
00048 /*  ======================================================================
00049     Class BtBipPutImageNextPacketMsg
00050     ====================================================================== */
00051
00053 class BtBipPutImageNextPacketMsg : public BtServiceMessage {
00054     public:
00055         BtBipPutImageNextPacketMsg(BtService* service);
00056         virtual ~BtBipPutImageNextPacketMsg();
00057
00058         virtual const MsgMetaData& GetMetaData() const;
00059         virtual Message* Clone() const;
00060
00061         enum  {
00062             ID = 10502
00063             };
00064
00065     private:
00066         static const MsgMetaData m_meta_data;
00067
00068 };
00069
00070
00071 /*  ======================================================================
00072     Class BtBipGetImageNextPacketMsg
00073     ====================================================================== */
00074
00076 class BtBipGetImageNextPacketMsg : public BtServiceMessage {
00077     public:
00078         BtBipGetImageNextPacketMsg(BtService* service);
00079         virtual ~BtBipGetImageNextPacketMsg();
00080
00081         virtual const MsgMetaData& GetMetaData() const;
00082         virtual Message* Clone() const;
00083
00084         enum  {
00085             ID = 10503
00086             };
00087
00088     private:
00089         static const MsgMetaData m_meta_data;
00090
00091 };
00092
00093
00094 /*  ======================================================================
00095     Class BtBipServiceMsg
00096     ====================================================================== */
00097
00099 class BtBipServiceMsg : public BtServiceMessage {
00100     public:
00101         BtBipServiceMsg(BtService* service, const BtBipService::MsgType& msg_type);
00102         virtual ~BtBipServiceMsg();
00103
00104         virtual const MsgMetaData& GetMetaData() const;
00105         const BtBipService::MsgType& GetMsgType() const { return m_msg_type; }
00106         virtual Message* Clone() const;
00107
00108         enum  {
00109             ID = 10504
00110             };
00111
00112     private:
00113         static const MsgMetaData m_meta_data;
00114         BtBipService::MsgType m_msg_type;
00115
00116 };
00117
00118 #endif
00119
00120 /*  ======================================================================
00121     Class BtBipProgressMsg
00122     ====================================================================== */
00123
00125 class BtBipProgressMsg : public BtServiceMessage {
00126     public:
00127         BtBipProgressMsg(BtService* service, const BtRequestType& request_type, UINT32 bytes_processed);
00128         virtual ~BtBipProgressMsg();
00129
00130         virtual const MsgMetaData& GetMetaData() const;
00131         const BtRequestType& GetRequestType() const { return m_request_type; }
00132         UINT32 GetBytesProcessed() const { return m_bytes_processed; }
00133         virtual Message* Clone() const;
00134
00135         enum  {
00136             ID = 10506
00137             };
00138
00139     private:
00140         static const MsgMetaData m_meta_data;
00141         BtRequestType m_request_type;
00142         UINT32 m_bytes_processed;
00143
00144     };
00145
00146 #endif // Bluetooth_BtBipServiceMsg_hpp
00147
Generated on Tue Jan 24 14:48:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipTypes.cpp File Reference

Bluetooth/BIP/BtBipTypes.cpp File Reference

#include "PreComp.hpp"
#include "BtBipTypes.hpp"
#include <Auxiliary/StrUtil.hpp>

Include dependency graph for BtBipTypes.cpp:

Variables

const int | c_bip_invalid_res = 65535
Result of OBEX operation used for BIP operation.
const UINT32 | c_bip_max_image_hdl = 9999999
Generated on Tue Jan 24 19:59:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipTypes.hpp File Reference

Bluetooth/BIP/BtBipTypes.hpp File Reference

#include <Bluetooth/BtObexResponseCode.hpp>

Include dependency graph for BtBipTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBipAttachment
An attachment. More...
class | BtBipAttachmentDesc
Attachment descriptor. More...
class | BtBipAttachmentFormat
Format of an attachment. More...
class | BtBipImage
An image. More...
class | BtBipImageDesc
Image Desc. More...
class | BtBipImageFormat
Image format. More...
struct | BtBipImageFormat::ImageDim
class | BtBipImageHdl
class | BtBipImageHdlDesc
Image Handle Desc. More...
class | BtBipImageList
List of images. More...
class | BtBipImageProperties
Image properties. More...
class | BtBipImagingCapabilities
Imaging Capabilities. More...

Defines

#define | BIP_IMG_HDL_SIZE 8
#define | BtBipTypes_hpp

Typedefs

typedef NiSharedPtr< BtBipAttachmentDesc > | BtBipAttachmentDescPtr
typedef NiSharedPtr< BtBipAttachmentFormat > | BtBipAttachmentFormatPtr
typedef NiSharedPtr< BtBipAttachment > | BtBipAttachmentPtr
typedef NiSharedPtr< BtBipImageDesc > | BtBipImageDescPtr
typedef NiSharedPtr< BtBipImageFormat > | BtBipImageFormatPtr
typedef NiSharedPtr< BtBipImageHdlDesc > | BtBipImageHdlDescPtr
typedef NiSharedPtr< BtBipImageHdl > | BtBipImageHdlPtr
typedef NiSharedPtr< BtBipImageList > | BtBipImageListPtr
typedef NiSharedPtr< BtBipImageProperties > | BtBipImagePropertiesPtr
typedef NiSharedPtr< BtBipImage > | BtBipImagePtr
typedef NiSharedPtr< BtBipImagingCapabilities > | BtBipImagingCapabilitiesPtr

Enumerations

enum BtBipEncoding {
BtBipJpeg, BtBipGif, BtBipWBmp, BtBipPng,
BtBipJpeg2000, BtBipBmp, BtBipInvalidEncoding
}
Image encoding type. More...
enum BtBipResult {
BipOk, BipContinue, BipPartialContent, BipCallError,
BipObexFailed, BipSdapFailed, BipPadaptFailed
}
Result of BIP operation. More...
enum | BtBipSessionId { BipImagePush, BipImagePull, BipInvalidSessionId }
Type of session. More...
enum BtBipTransformation {
BtBipNone = 0, BtBipStretch = 1, BtBipCrop = 2, BtBipFill = 3,
BtBipInvalidTransformation = 4
}
Transformation type. More...

Variables

const int | c_bip_invalid_res
Result of OBEX operation used for BIP operation.
const UINT32 | c_bip_max_image_hdl

Define Documentation

#define BtBipTypes_hpp

Generated on Tue Jan 24 19:59:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/BtBipTypes.hpp Source File

Bluetooth/BIP/BtBipTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBipTypes_hpp)
00009 #define BtBipTypes_hpp
00012
00013 // Imaging Capabilities
00014
00015 #include <Bluetooth/BtObexResponseCode.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Enums
00019     ------------------------------------------------------------------------ */
00020
00022 enum BtBipEncoding {
00023
00024     // BtBip specified standard encodings
00025     BtBipJpeg,
00026     BtBipGif,
00027     BtBipWBmp,
00028     BtBipPng,
00029     BtBipJpeg2000,
00030     BtBipBmp,
00031
00032     BtBipInvalidEncoding
00033
00034     // BtBip User defineable encodings
00035 };
00036
00038 enum BtBipTransformation {
00039     BtBipNone = 0,
00040     BtBipStretch = 1,
00041     BtBipCrop = 2,
00042     BtBipFill = 3,
00043     BtBipInvalidTransformation = 4
00044 };
00045
00047 enum BtBipResult {
00048     BipOk,
00049     BipContinue,
00050     BipPartialContent,
00051     BipCallError,
00052     BipObexFailed,
00053     BipSdapFailed,
00054     BipPadaptFailed,
00055 };
00056
00058 enum BtBipSessionId {
00059     BipImagePush,
00060     BipImagePull,
00061     BipInvalidSessionId
00062 };
00063
00065 /*enum BtBipObexResult {
00066     BipObexOk,
00067     BipObexContinue,
00068     BipObexPartialContent,
00069
00070     BipObexBadRequest,
00071     BipObexNotImplemented,
00072     BipObexForbidden,
00073     BipObexUnauthorised,
00074     BipObexPreconditionFailed,
00075     BipObexNotFound,
00076     BipObexNotAcceptable,
00077     BipObexServiceUnavailable,
00078     BipObexUndefined
00079 };*/
00080
00081 extern const int c_bip_invalid_res;
00082
00083 #define BIP_IMG_HDL_SIZE 8
00084
00085 /*  ------------------------------------------------------------------------
00086     Data Wrappers
00087     ------------------------------------------------------------------------ */
00088
00090 class BtBipImageFormat
00091 {
00092 public:
00093
00094     struct ImageDim {
00095         UINT16 min_width;
00096         UINT16 min_height;
00097         UINT16 max_width;
00098         UINT16 max_height;
00099     };
00100
00102     void SetEncoding(BtBipEncoding encoding) { m_encoding = encoding; }
00103
00105     void SetImageDim(UINT16 width, UINT16 height);
00106
00108     void SetImageDim(UINT16 min_width, UINT16 max_width, UINT16 max_height);
00109
00111     void SetImageDim(UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height);
00112
00114     void SetMaxImageSize(UINT32 max_size) { m_max_size = max_size; }
00115
00117     void SetTransformation(BtBipTransformation transformation) { m_transformation = transformation; }
00118
00120     BtBipEncoding GetEncoding() const { return m_encoding; }
00121
00123     void GetImageDim(ImageDim& dim) const { dim = m_dim; }
00124
00125     const ImageDim& GetImageDim() const { return m_dim; }
00126
00128     UINT32 GetMaxImageSize() const { return m_max_size; }
00129
00131     BtBipTransformation GetTransformation() const { return m_transformation; }
00132
00133
00134 private:
00135     BtBipEncoding m_encoding;
00136     BtBipTransformation m_transformation;
00137
00138     ImageDim m_dim;
00139
00140     UINT32 m_max_size;
00141 };
00142
00143 typedef NiSharedPtr<BtBipImageFormat> BtBipImageFormatPtr;
00144
00145 class BtBipImageDesc;
00146
00147 typedef NiSharedPtr<BtBipImageDesc> BtBipImageDescPtr;
00148
00150
00152 class BtBipImageDesc
00153 {
00154 public:
00155     void SetEncoding(BtBipEncoding encoding) {
00156         m_img_format.SetEncoding(encoding);
00157     }
00158
00159     void SetImageDim(UINT16 width, UINT16 height) {
00160         m_img_format.SetImageDim(width, height);
00161     }
00162
00163     void SetImageDim(UINT16 min_width, UINT16 max_width, UINT16 max_height) {
00164         m_img_format.SetImageDim(min_width, max_width, max_height);
00165     }
00166
00167     void SetImageDim(UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height) {
00168         m_img_format.SetImageDim(min_width, min_height, max_width, max_height);
00169     }
00170
00171     void SetMaxImageSize(UINT32 max_size) { m_img_format.SetMaxImageSize(max_size); }
00172
00173     void SetTransformation(BtBipTransformation transformation) {
00174         m_img_format.SetTransformation(transformation);
00175     }
00176
00177     void SetImageSize(UINT32 size) { m_size = size; }
00178
00179     BtBipEncoding GetEncoding() const {
00180         return m_img_format.GetEncoding();
00181     }
00182
00183     BtBipTransformation GetTransformation() const {
00184         return m_img_format.GetTransformation();
00185     }
00186
00187     UINT32 GetMaxImageSize() const {
00188         return m_img_format.GetMaxImageSize();
00189     }
00190
00191     void GetImageDim(BtBipImageFormat::ImageDim& dim) const {
00192         m_img_format.GetImageDim(dim);
00193     }
00194
00195     const BtBipImageFormat::ImageDim& GetImageDim() const {
00196         return m_img_format.GetImageDim();
00197     }
00198
00199     UINT32 GetImageSize() const { return m_size; }
00200
00201 private:
00202     BtBipImageFormat m_img_format;
00203     UINT32           m_size;
00204 };
00205
00207
00210 class BtBipImageHdl;
00211
00212 typedef NiSharedPtr<BtBipImageHdl> BtBipImageHdlPtr;
00213
00214 extern const UINT32 c_bip_max_image_hdl;
00215
00216
00217 class BtBipImageHdl
00218 {
00219
00220 public:
00221     ~BtBipImageHdl();
00222
00224
00227     static void CreateImageHdl(UINT32 id, BtBipImageHdlPtr& hdl_ptr);
00228
00229 //  BOOLEAN operator == (const BtBipImageHdl& hdl) const { return m_hdl.CompareTo(hdl.m_hdl) == 0; }
00230
00231     String AsString() { return String((CHAR*)m_hdl, sizeof(m_hdl)); }
00232
00233 private:
00234
00235     typedef UINT8 ImgHdl[8];
00236
00237     BtBipImageHdl(UINT32 id);
00238     BtBipImageHdl(const ImgHdl* id);
00239
00240     static void  CreateImageHdl(const ImgHdl* id, BtBipImageHdlPtr& hdl_ptr);
00241
00242     const ImgHdl* GetHdl() const { return &m_hdl; }
00243
00244     ImgHdl m_hdl;
00245
00246 //  friend class BtBipClientService;
00247     friend class BtBipServerService;
00248     friend class BtBipPutImageReq;
00249     friend class BtBipPutThumbReq;
00250     friend class BtBipPutAttachReq;
00251     friend class BtBipGetImagePropertiesReq;
00252     friend class BtBipGetImageReq;
00253     friend class BtBipGetLinkedThumbnailReq;
00254     friend class BtBipGetLinkedAttachmentReq;
00255     friend class BtBipDeleteImageReq;
00256     friend class BtBipController;
00257     friend class BtBipDataConverter;
00258     // hack to make integration possible, think about twice another time
00259     friend class BtBipMecelXmlConverter;
00260 };
00261
00263
00265 class BtBipImageHdlDesc
00266 {
00267 public:
00268     BtBipImageHdlDesc();
00269     virtual ~BtBipImageHdlDesc();
00270
00271     void SetCreatedFrom(UINT16 year, UINT16 month, UINT16 day, UINT16 hour=0, UINT16 minute=0, UINT16 second=0);
00272     void SetCreatedFrom(const DateTime& from) { m_created_from = from;  }
00273     void SetCreatedTo(UINT16 year, UINT16 month, UINT16 day, UINT16 hour=23, UINT16 minut=59, UINT16 second=59);
00274     void SetCreatedTo(const DateTime& to) { m_created_to = to; }
00275
00276     void SetModifiedFrom(UINT16 year, UINT16 month, UINT16 day, UINT16 hour, UINT16 minute, UINT16 second);
00277     void SetModifiedFrom(const DateTime& from) { m_modified_from = from; }
00278     void SetModifiedTo(UINT16 year, UINT16 month, UINT16 day, UINT16 hour, UINT16 minute, UINT16 second);
00279     void SetModifiedTo(const DateTime& to) { m_modified_to = to; }
00280
00281     void SetEncoding(BtBipEncoding encoding) { m_img_format.SetEncoding(encoding); }
00282
00283     void SetImageDim(UINT16 width, UINT16 height) { m_img_format.SetImageDim(width, height); }
00284     void SetImageDim(UINT16 min_width, UINT16 max_width, UINT16 max_height) {
00285         m_img_format.SetImageDim(min_width, max_width, max_height);
00286     }
00287
00288     void SetImageDim(UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height) {
00289         m_img_format.SetImageDim(min_width, min_height, max_width, max_height);
00290     }
00291
00292     const DateTime& GetCreatedFrom() const { return m_created_from; }
00293     const DateTime& GetCreatedTo() const { return m_created_to; }
00294     const DateTime& GetModifiedFrom() const { return m_modified_from; }
00295     const DateTime& GetModifiedTo() const { return m_modified_to; }
00296
00297     void GetImageDim(BtBipImageFormat::ImageDim& dim) const {
00298         m_img_format.GetImageDim(dim);
00299     }
00300
00301     const BtBipImageFormat::ImageDim& GetImageDim() const { return m_img_format.GetImageDim(); }
00302
00303     BtBipEncoding GetEncoding() const { return m_img_format.GetEncoding(); }
00304
00305 private:
00306     DateTime m_created_from;
00307     DateTime m_created_to;
00308
00309     DateTime m_modified_from;
00310     DateTime m_modified_to;
00311
00312     BtBipImageFormat m_img_format;
00313 };
00314
00315 typedef NiSharedPtr<BtBipImageHdlDesc> BtBipImageHdlDescPtr;
00316
00317
00318 class BtBipImage;
00319 typedef NiSharedPtr<BtBipImage> BtBipImagePtr;
00320
00322 class BtBipImage
00323 {
00324 public:
00325     BtBipImage(const BtBipImageHdlPtr& hdl, const DateTime& created, const DateTime& modified);
00326     virtual ~BtBipImage();
00327
00328     void SetImageHdl(const BtBipImageHdlPtr& hdl) { m_img_hdl = hdl; }
00329     void SetCreatedDate(const DateTime& created) { m_created = created; }
00330     void SetModifiedDate(const DateTime& modified) { m_modified = modified; }
00331
00332     const BtBipImageHdlPtr& GetImageHdl() const { return m_img_hdl; }
00333     const DateTime& GetCreated() const { return m_created; }
00334     const DateTime& GetModified() const { return m_modified; }
00335
00336 private:
00337     BtBipImageHdlPtr m_img_hdl;
00338     DateTime m_created;
00339     DateTime m_modified;
00340 };
00341
00343 class BtBipImageList
00344 {
00345 public:
00346     typedef Vector<BtBipImagePtr> ImageList;
00347
00348     BtBipImageList();
00349     virtual ~BtBipImageList();
00350
00351     void AddImage(const BtBipImagePtr& image);
00352     void AddImage(const BtBipImageHdlPtr& handle, const DateTime& created, const DateTime& modified);
00353
00354     const ImageList& GetImageList() const { return m_image_list; }
00355
00356 private:
00357     ImageList m_image_list;
00358 };
00359
00360 typedef NiSharedPtr<BtBipImageList> BtBipImageListPtr;
00361
00363 class BtBipAttachmentFormat
00364 {
00365 public:
00366     BtBipAttachmentFormat();
00367     ~BtBipAttachmentFormat();
00368     void SetMimeType(ApoxiMimeTypeId mime_type) { m_mime_type = mime_type; }
00369     void SetCharset(const String& charset) { m_charset = charset; }
00370
00371     ApoxiMimeTypeId GetMimeType() const { return m_mime_type; }
00372     const String& GetCharset() const { return m_charset; }
00373
00374 private:
00375     ApoxiMimeTypeId m_mime_type;
00376     String m_charset;
00377 };
00378
00379 typedef NiSharedPtr<BtBipAttachmentFormat> BtBipAttachmentFormatPtr;
00380
00382 class BtBipImagingCapabilities
00383 {
00384 public:
00385     typedef Vector<BtBipImageFormatPtr> BtBipImageFormatList;
00386     typedef Vector<BtBipAttachmentFormatPtr> BtBipAttachmentFormatList;
00387
00388     BtBipImagingCapabilities();
00389     ~BtBipImagingCapabilities();
00390
00391     void SetPreferredFormat(const BtBipImageFormat& format) { m_preferred_format = format; }
00392
00394     void SetPreferredFormat(BtBipEncoding encoding, UINT16 width, UINT16 height, BtBipTransformation transformation, UINT32 max_size);
00395
00397     /* The height of an image is calculated using the formula H=(W*H2)/W2.
00398        The aspect ratio of the image is not changed.
00399        @param min_width min. width of image
00400        @param max_width max. width of image
00401        @param max_height max. height of image
00402     */
00403     void SetPreferredFormat(BtBipEncoding encoding, UINT16 min_width, UINT16 max_width, UINT16 max_height, BtBipTransformation transformation, UINT32 max_size);
00404
00406     /* An image can be transformed freely, the aspect ratio may be changed. */
00407     void SetPreferredFormat(BtBipEncoding encoding, UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height, BtBipTransformation transformation, UINT32 max_size);
00408
00409     void AddImageFormat(const BtBipImageFormatPtr& format) { m_supported_img_formats.PushBack(format); }
00410     void AddImageFormat(BtBipEncoding, UINT16 res_x, UINT16 res_y, UINT32 max_size);
00411
00412     void AddAttachmentFormat(const BtBipAttachmentFormatPtr& format) { m_supported_attach_formats.PushBack(format); }
00413     void AddAttachmentFormat(ApoxiMimeTypeId mime_type, const String& charset);
00414
00415     void SetDpofOptions(UINT8 dpof_options) { m_dpof_options = dpof_options; }
00416     void SetFilterParamters(UINT8 filter_params) { m_filter_params = filter_params; }
00417
00418     const BtBipImageFormat& GetPreferredFormat() const { return m_preferred_format; }
00419     BtBipEncoding GetPrefEncoding() const { return m_preferred_format.GetEncoding(); }
00420     UINT8   GetDpofOptions() const { return m_dpof_options; }
00421     UINT8   GetFilterParams() const { return m_filter_params; }
00422
00423
00424     // fix size min(w|h)==max(w|h)
00425     // w/aspect minh == maxh
00426     // n/aspect ratio min(w|h) like set
00427     UINT16      GetPrefMinWidth() const { return m_preferred_format.GetImageDim().min_width; }
00428     UINT16      GetPrefMaxWidth() const { return m_preferred_format.GetImageDim().max_width; }
00429     UINT16      GetPrefMinHeight() const { return m_preferred_format.GetImageDim().min_height; }
00430     UINT16      GetPrefMaxHeight() const { return m_preferred_format.GetImageDim().max_height; }
00431     UINT16      GetPrefTransformation() const { return m_preferred_format.GetTransformation(); }
00432     UINT32      GetPrefMaxSize() const { return m_preferred_format.GetMaxImageSize(); }
00433
00434     BOOLEAN     IsDpofOptionSupported(UINT8 dpof_options) const { return (m_dpof_options & dpof_options) > 0; }
00435     BOOLEAN     IsFilterSupported(UINT8 filter) const { return (m_filter_params & filter) > 0; }
00436
00437     const BtBipImageFormatList& GetSupportedImageFormatList() const { return m_supported_img_formats; }
00438     const BtBipAttachmentFormatList& GetSupportedAttachmentFormatList() const { return m_supported_attach_formats; }
00439
00440 private:
00441     UINT8                   m_dpof_options;
00442     UINT8                   m_filter_params;
00443
00444     BtBipImageFormat            m_preferred_format;
00445     BtBipImageFormatList        m_supported_img_formats;
00446     BtBipAttachmentFormatList   m_supported_attach_formats;
00447 };
00448
00449 typedef NiSharedPtr<BtBipImagingCapabilities> BtBipImagingCapabilitiesPtr;
00450
00451
00453 class BtBipAttachment
00454 {
00455 public:
00456     void SetAttachmentFormat(const BtBipAttachmentFormat& format) { m_format = format; }
00457     void SetMimeType(ApoxiMimeTypeId mime_type) { m_format.SetMimeType(mime_type); }
00458     void SetCharset(const String& charset) { m_format.SetCharset(charset); }
00459
00460     void SetName(const String& name){ m_name = name; }
00461     void SetSize(UINT32 size){ m_size = size; }
00462     void SetCreateDate(const DateTime& date) { m_created = date; }
00463     void SetModifyDate(const DateTime& date) { m_modified = date; }
00464
00465     ApoxiMimeTypeId GetMimeType() { return m_format.GetMimeType(); }
00466     const String& GetCharset() { return m_format.GetCharset(); }
00467     const String& GetName() { return m_name; }
00468     const DateTime& GetCreateDate() { return m_created; }
00469     const DateTime& GetModifyDate() { return m_modified; }
00470     UINT32 GetSize() { return m_size; }
00471
00472 private:
00473     BtBipAttachmentFormat m_format;
00474     String              m_name;
00475     UINT32              m_size;
00476     DateTime            m_created;
00477     DateTime            m_modified;
00478 };
00479
00480 typedef NiSharedPtr<BtBipAttachment> BtBipAttachmentPtr;
00481
00482
00484
00487 class BtBipAttachmentDesc
00488 {
00489 public:
00490
00491     BtBipAttachmentDesc();
00492     ~BtBipAttachmentDesc();
00493
00494     void SetMimeType(ApoxiMimeTypeId mime_type) { m_format.SetMimeType(mime_type); }
00495     void SetCharset(const String& charset) { m_format.SetCharset(charset); }
00496
00497     void SetName(const String& name){ m_name = name; }
00498     void SetSize(UINT32 size){ m_size = size; }
00499     void SetCreateDate(const DateTime& date) { m_created = date; }
00500
00501     ApoxiMimeTypeId GetMimeType() const { return m_format.GetMimeType(); }
00502     const String& GetCharset() const { return m_format.GetCharset(); }
00503     const String& GetName() const { return m_name; }
00504     const DateTime& GetCreated() const { return m_created; }
00505     UINT32 GetSize() const { return m_size; }
00506
00507 private:
00508     BtBipAttachmentFormat m_format;
00509     String              m_name;
00510     UINT32              m_size;
00511     DateTime            m_created;
00512 };
00513
00514 typedef NiSharedPtr<BtBipAttachmentDesc> BtBipAttachmentDescPtr;
00515
00517 class BtBipImageProperties
00518 {
00519 public:
00520     typedef Vector<BtBipImageFormatPtr> BtBipVariantList;
00521     typedef Vector<BtBipAttachmentPtr> BtBipAttachmentList;
00522
00523     void SetImageHandle(const BtBipImageHdlPtr& hdl)  { m_img_hdl = hdl; }
00524     void SetFriendlyName(const String& name) { m_img_name = name; }
00525
00526     void SetNativeFormat(const BtBipImageFormat& fmt) { m_native_fmt = fmt; }
00527     void SetNativeEncoding(BtBipEncoding encoding) { m_native_fmt.SetEncoding(encoding); }
00528     void SetNativeDim(UINT16 width, UINT16 height) { m_native_fmt.SetImageDim(width, height); }
00529     void SetNativeSize(UINT32 size) { m_native_fmt.SetMaxImageSize(size); }
00530
00531     void AddVariant(const BtBipImageFormatPtr& fmt) { m_variants.PushBack(fmt); }
00532     void AddVariant(BtBipEncoding encoding, UINT16 width, UINT16 height, UINT32 max_size, BtBipTransformation transformation);
00533     void AddVariant(BtBipEncoding encoding, UINT16 min_width, UINT16 max_width, UINT16 max_height, UINT32 max_size, BtBipTransformation transformation);
00534     void AddVariant(BtBipEncoding encoding, UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height, UINT32 max_size, BtBipTransformation transformation);
00535
00536     void AddAttachment(const BtBipAttachmentPtr& attach) { m_attaches.PushBack(attach); }
00537     void AddAttachment(ApoxiMimeTypeId mime_type, const String& charset, const String& name, UINT32 size, const DateTime& created, const DateTime& modified);
00538
00539     const BtBipImageFormat& GetNativeFormat() const { return m_native_fmt; }
00540     BtBipEncoding GetNativeEncoding() const { return m_native_fmt.GetEncoding(); }
00541     UINT16 GetNativeWidth() const { return m_native_fmt.GetImageDim().min_width; }
00542     UINT16 GetNativeHeight() const { return m_native_fmt.GetImageDim().min_height; }
00543
00544     const BtBipImageHdlPtr& GetImageHdl() const { return m_img_hdl; }
00545     const String& GetImageName() const { return m_img_name; }
00546     UINT32 GetNativeSize() const { return m_native_fmt.GetMaxImageSize(); }
00547
00548     const BtBipVariantList& GetVariantList() const { return m_variants; }
00549     const BtBipAttachmentList& GetAttachmentList() const { return m_attaches; }
00550
00551 private:
00552     BtBipImageHdlPtr        m_img_hdl;
00553     String                  m_img_name;
00554
00555     BtBipImageFormat        m_native_fmt;
00556     BtBipVariantList        m_variants;
00557     BtBipAttachmentList     m_attaches;
00558 };
00559
00560 typedef NiSharedPtr<BtBipImageProperties> BtBipImagePropertiesPtr;
00561
00562
00563 #endif // BtBipTypes_hpp
00564
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/PreComp.cpp File Reference

Bluetooth/BIP/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/PreComp.hpp File Reference

Bluetooth/BIP/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BIP/PreComp.hpp Source File

Bluetooth/BIP/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Bluetooth/Lib.hpp>
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppClientService.cpp File Reference

Bluetooth/BPP/BtBppClientService.cpp File Reference

#include "PreComp.hpp"
#include "BtBppClientService.hpp"
#include "BtBppController.hpp"
#include "BtBppTypes.hpp"
#include <Auxiliary/HostIniFile.hpp>

Include dependency graph for BtBppClientService.cpp:

Generated on Tue Jan 24 19:59:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppClientService.hpp File Reference

Bluetooth/BPP/BtBppClientService.hpp File Reference

#include <Auxiliary/DataSink.hpp>
#include <Auxiliary/DataSource.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp>
#include <Bluetooth/BPP/BtBppSndAbortReqRequest.hpp>
#include <Bluetooth/BPP/BtBppTypes.hpp>

Include dependency graph for BtBppClientService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppClientService

Defines

#define | BtBppClientService_hpp

Define Documentation

#define BtBppClientService_hpp

Generated on Tue Jan 24 19:59:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppClientService.hpp Source File

Bluetooth/BPP/BtBppClientService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppClientService_hpp)
00009 #define BtBppClientService_hpp
00012
00013 #include <Auxiliary/DataSink.hpp>
00014 #include <Auxiliary/DataSource.hpp>
00015 #include <Bluetooth/BtDeviceAddress.hpp>
00016 #include <Bluetooth/BtTypes.hpp>
00017 #include <Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp>
00018 #include <Bluetooth/BPP/BtBppSndAbortReqRequest.hpp>
00019 #include <Bluetooth/BPP/BtBppTypes.hpp>
00020
00021
00028 class BtBppClientService: public BtBppService
00029 {
00030     private:
00031         typedef BtBppService Base;
00032
00033     public:
00035         BtBppClientService();
00036
00038         virtual ~BtBppClientService();
00039
00041
00043         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00044
00046
00048         virtual BOOLEAN IsServerService() const;
00049
00050
00052
00054         BOOLEAN IsConnected() const;
00055
00057
00061         BtRequestState BppSndFilePush( //const BtDeviceAddress& device,
00062             BppObjectTypeEnum bpp_object_type_enum,  const DataSourcePtr& pagetoprint );
00063
00064         //Not necessary 2 different functions:
00065 //      BtRequestState BppSndFilePushFromRam( const BtDeviceAddress& device,
00066 //          BppObjectTypeEnum bpp_object_type_enum,  const DataSourcePtr& pagetoprint );
00067
00068 //      BtRequestState BppSndFilePushFromFlash ( const BtDeviceAddress& device,
00069 //          BppObjectTypeEnum bpp_object_type_enum,  const Pathname& pathname);
00070
00071
00072
00073
00074
00076
00078         BtRequestState BppSndAbortReq();
00079
00080
00081
00082
00083
00085         BtResultCode GetResult();
00086         BtBppSndFilePushReqRequest::BppSubstate GetSubState() { return  m_file_push_req.GetBppSubState();}
00087         UINT8 GetProgressInPercent() {return (UINT8)((100 * (m_bytes_read_so_far+1)) / (m_data_source_size+1)); }
00088         UINT32  GetProgressInBytes() {return m_bytes_read_so_far; }
00089         UINT32  GetProgressTotalBytes() {return m_data_source_size;}
00090
00091
00092         //      virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00093
00094     private:
00095
00096         void BppSndConnectIndCb(BtResultCode result);
00097         void BppSndFilePushCfmCb(BtResultCode result);
00098         void BppSndDisconnectIndCb(BtResultCode result);
00099         void BppSndAbortCfmCb(BtResultCode result);
00100 //      void BppSndAuthenticationRequestIndCb(BtAuthenticationReq auth_req);
00101
00102         BtBppSndFilePushReqRequest      m_file_push_req;
00103         BOOLEAN                         m_is_final_buffer;
00104         DataSourcePtr                   m_pagetoprint;
00105         UINT32                          m_data_source_size;
00106         UINT32                          m_bytes_read_so_far;
00107         BtBppSndAbortReqRequest         m_abort_req;
00108
00109 #ifdef _DEBUG
00110         static SystemTimer m_clienttimer;
00111         static void OnClientTimer(void* arg);
00112         static INT delay_ms_to_abort ;
00113         static BOOLEAN start_abort_from_connect_indication ;
00114 #endif
00115
00116         friend class BtBppSndFilePushReqRequest;
00117         friend class BtBppSndAbortReqRequest;
00118 };
00119
00120 #if defined(APOXI_RTOS_WIN32)
00121
00122
00123
00124 #endif //#if defined(APOXI_RTOS_WIN32)
00125
00126 #endif  // BtBppClientService_hpp
00127
00128
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppController.cpp File Reference

Bluetooth/BPP/BtBppController.cpp File Reference

#include "PreComp.hpp"
#include "BtBppController.hpp"
#include "BtBppSndFilePushReqRequest.hpp"
#include "BtBppServerService.hpp"
#include "BtBppTypes.hpp"

Include dependency graph for BtBppController.cpp:

Generated on Tue Jan 24 19:59:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppController.hpp File Reference

Bluetooth/BPP/BtBppController.hpp File Reference

#include <stack/extensions.h>
#include <Bluetooth/BtSingleConnectionController.hpp>
#include <Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp>
#include <Bluetooth/BPP/BtBppSndAbortReqRequest.hpp>
#include <Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp>

Include dependency graph for BtBppController.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppController

Defines

#define | BtBppController_hpp

Define Documentation

#define BtBppController_hpp

Generated on Tue Jan 24 19:59:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppController.hpp Source File

Bluetooth/BPP/BtBppController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppController_hpp)
00009 #define BtBppController_hpp
00010
00011 //#define BTAPI_SIMULATION_234
00012
00015
00016 #include <stack/extensions.h>
00017 //#include <Bluetooth/BtMultiConnectionController.hpp>
00018 #include <Bluetooth/BtSingleConnectionController.hpp>
00019 #include <Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp>
00020 #include <Bluetooth/BPP/BtBppSndAbortReqRequest.hpp>
00021 #include <Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp>
00022
00023
00024 /*  ------------------------------------------------------------------------
00025     Forward deklarations for friend relationships.
00026     ------------------------------------------------------------------------ */
00027
00028 //class BtBppService;
00029 //class BtBppServerService;
00030 //class BtBppClientService;
00031 //class BtBppRegisterServerRequest;
00032 //class BtBppUnregisterServerRequest;
00033
00034 //class BtBppSndFilePushReq;
00035 //class BtBppSndGetRefObjRsp;
00036 //class BtBppSndAbortReq;
00037 //class BtBppSndAuthenticationReqRes;
00038
00039
00043 class BtBppController: public BtSingleConnectionController
00044 {
00045
00046     private:
00047         typedef BtSingleConnectionController Base;
00048
00049     public:
00051         BtBppController()   ;
00052
00054         virtual ~BtBppController();
00055
00057
00059         static BtBppController& GetInstance() ;
00060
00061
00062
00064
00066         virtual const WCHAR* GetName() const;
00067
00068     protected:
00069
00070
00071         BOOLEAN BppSndFilePushReq(BtBppSndFilePushReqRequest* filepushreq);
00072
00073         BOOLEAN BppSndGetRefObjRsp(BtBppSndGetRefObjRspRequest* getrefobjrsp);
00074
00075         BOOLEAN BppSndAbortReq(BtBppSndAbortReqRequest* abortreq);
00076
00077
00078 //      BOOLEAN BppSndAuthenticationReqRes(BtBppSndAuthenticationReqRes* authenticationreqres);
00079
00080
00081
00082     private:
00083
00084 //      typedef BtSingleConnectionController Base;
00085         /*---------------------------------------------------------------------*/
00086         /* The following functions must not be called by an application.       */
00087         /* They are the entry point from the stack callback functions into our */
00088         /* object orientated framework (APOXI).                                */
00089         /* They are implemented as static because they have to be passed as    */
00090         /* normal C function pointers. The reason for this is the BT-API Stack */
00091         /* interface that demands C function pointers for callback the         */
00092         /* callback functions it calls to state the progress of ongoing        */
00093         /* operations                                                          */
00094         /*---------------------------------------------------------------------*/
00095
00096
00097
00098
00099         //File Push scenarios
00100         // Callback corresponding to BPP_SND_CONNECT_IND msg, BPP_SND_ConnectInd
00101         static void BppSndConnectIndCb (btapi_result_t result, const btapi_bpp_snd_connect_ind_t *ind);
00102         // Callback corresponding to BPP_SND_FILE_PUSH_CFM
00103         static void BppSndFilePushCfmCb(btapi_result_t result, const btapi_bpp_snd_file_push_cfm_t *cfm);
00104         static void BppSndDisconnectIndCb(btapi_result_t result, const btapi_bpp_snd_disconnect_ind_t *ind);
00105
00106         //getReferencedObjects Scenarios
00107         static void BppSndGetRefObjIndCb(btapi_result_t result, const btapi_bpp_snd_get_ref_obj_ind_t *ind);
00108         static void BppSndGetRefObjCompleteIndCb(btapi_result_t result);
00109
00110         //Abort Scenarios
00111         static void BppSndAbortCfmCb(btapi_result_t result, const btapi_bpp_snd_abort_cfm_t *cfm); // Callback for Abort Indication (BIP_ABORT_IND)
00112
00113         //Obex Authentication
00114         static void BppSndAuthenticationReqIndCb(btapi_result_t result, const btapi_bpp_snd_authentication_req_ind_t *cfm); // Callback for Abort Indication (BIP_ABORT_IND)
00115
00116
00117
00118         //File Push scenarios
00119         // Callback corresponding to BPP_SND_CONNECT_IND msg, BPP_SND_ConnectInd
00120         void OnBppSndConnectIndCb (btapi_result_t result, const btapi_bpp_snd_connect_ind_t *ind);
00121         // Callback corresponding to BPP_SND_FILE_PUSH_CFM
00122         void OnBppSndFilePushCfmCb(btapi_result_t result, const btapi_bpp_snd_file_push_cfm_t *cfm);
00123         void OnBppSndDisconnectIndCb(btapi_result_t result, const btapi_bpp_snd_disconnect_ind_t *ind);
00124
00125         //getReferencedObjects Scenarios
00126         void OnBppSndGetRefObjIndCb(btapi_result_t result, const btapi_bpp_snd_get_ref_obj_ind_t *ind);
00127         void OnBppSndGetRefObjCompleteIndCb(btapi_result_t result);
00128
00129         //Abort Scenarios
00130         void OnBppAbortCfmCb(btapi_result_t result, const btapi_bpp_snd_abort_cfm_t *cfm); // Callback for Abort Indication (BIP_ABORT_IND)
00131
00132         //Obex Authentication
00133         void OnBppAuthenticationReqIndCb(btapi_result_t result, const btapi_bpp_snd_authentication_req_ind_t *cfm); // Callback for Abort Indication (BIP_ABORT_IND)
00134
00135
00137 //      BtBppController::BtBppController()  ;
00138
00140
00142         virtual void Register();
00143
00145
00147         virtual void Unregister();
00148
00149
00151
00153         btapi_bpp_handle_t GetBppHandle(const void* apoxi_handle);
00154
00156         btapi_bppcb_funp_t* m_Bpp_callback_functions;
00157
00159         static BtBppController m_controller;
00160         BOOLEAN m_need_disconnect_request_after_abort_cfm; // because of Mecel BPP SDK, Figure 6, page 12
00161 #ifdef BTAPI_SIMULATION_234
00162         static void OnResponseTimer1(void* arg);
00163         static void OnResponseTimer2(void* arg);
00164         static void OnResponseTimer3(void* arg);
00165         static SystemTimer m_responsetimer1;
00166         static SystemTimer m_responsetimer2;
00167         static SystemTimer m_responsetimer3;
00168         btapi_bpp_snd_file_push_req_t* m_op_params_btapi_simulation;
00169         static btapi_BT_BdAddr m_bdAddr_btapi_simulation;
00170 #endif //BTAPI_SIMULATION_234
00171
00172
00173         friend class BtBppService;
00174         friend class BtBppServerService;
00175         friend class BtBppClientService;
00176 //      friend class BtBppRegisterServerRequest;
00177 //      friend class BtBppUnregisterServerRequest;
00178
00179         friend class BtBppSndFilePushReqRequest;
00180         friend class BtBppSndGetRefObjRspRequest;
00181         friend class BtBppSndAbortReqRequest;
00182 //      friend class BtBppSndAuthenticationReqRes;
00183 };
00184
00186 #endif  // BtBppController_hpp
00187
00188
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppReq.cpp File Reference

Bluetooth/BPP/BtBppReq.cpp File Reference

#include "PreComp.hpp"
#include "BtBppService.hpp"
#include "BtBppReq.hpp"

Include dependency graph for BtBppReq.cpp:

Generated on Tue Jan 24 19:59:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppReq.hpp File Reference

Bluetooth/BPP/BtBppReq.hpp File Reference

#include <Bluetooth/BtServiceRequest.hpp>
#include <Bluetooth/BPP/BtBppService.hpp>
#include <Bluetooth/BPP/BtBppTypes.hpp>

Include dependency graph for BtBppReq.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppReq

Defines

#define | BtBppRequest_hpp

Define Documentation

#define BtBppRequest_hpp

Generated on Tue Jan 24 19:59:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppReq.hpp Source File

Bluetooth/BPP/BtBppReq.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppRequest_hpp)
00009 #define BtBppRequest_hpp
00012
00013 #include <Bluetooth/BtServiceRequest.hpp>
00014 #include <Bluetooth/BPP/BtBppService.hpp>
00015 //#include <Bluetooth/BPP/BtBppController.hpp>
00016 #include <Bluetooth/BPP/BtBppTypes.hpp>
00017
00018
00019 /*  ------------------------------------------------------------------------
00020     Forward deklarations for friend relationships.
00021     ------------------------------------------------------------------------ */
00022
00023 class BtBppController;
00024
00027 class BtBppReq: public BtServiceRequest
00028 {
00029     private:
00030         typedef BtServiceRequest Base;
00031
00032     public:
00034         BtBppReq(BtBppService& obex_service);
00035
00037         virtual ~BtBppReq();
00038
00039     protected:
00041
00054         virtual BtRequestState ChangeRequestState(BOOLEAN success);
00055
00056         virtual void SetRequestState(BtRequestState request_state);
00057
00058
00060
00062         virtual BOOLEAN EvaluateExecutionResult(BtResultCode result);
00063
00064
00065         void SetObexResult(UINT8 res) { m_obex_result = res; }
00066         void SetBppResult(BtBppResult res) { m_bpp_result = res; }
00067
00068
00069     private:
00070         BtBppResult m_bpp_result;
00071         UINT8   m_obex_result;
00072         friend class BtBppController;
00073 };
00074
00076 #endif  // BtBppRequest_hpp
00077
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppServerService.hpp File Reference

Bluetooth/BPP/BtBppServerService.hpp File Reference

#include <Bluetooth/BPP/BtBppService.hpp>
#include <Bluetooth/BPP/BtBppController.hpp>
#include <Bluetooth/BPP/BtBppTypes.hpp>

Include dependency graph for BtBppServerService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppServerService

Defines

#define | BtBppServerService_hpp

Define Documentation

#define BtBppServerService_hpp

Generated on Tue Jan 24 19:59:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppServerService.hpp Source File

Bluetooth/BPP/BtBppServerService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppServerService_hpp)
00009 #define BtBppServerService_hpp
00012
00013 //#include <Bluetooth/BPP/BtBppServerServiceObserver.hpp>
00014 //#include <Bluetooth/BPP/BtBppRegisterServerRequest.hpp>
00015 //#include <Bluetooth/BPP/BtBppUnregisterServerRequest.hpp>
00016 //#include <Bluetooth/BPP/BtBppSendResponseRequest.hpp>
00017 #include <Bluetooth/BPP/BtBppService.hpp>
00018 #include <Bluetooth/BPP/BtBppController.hpp>
00019
00020 #include <Bluetooth/BPP/BtBppTypes.hpp>
00021
00024 class BtBppServerService: public BtBppService
00025 {
00026     private:
00027         typedef BtBppService Base;
00028
00029     public:
00031         BtBppServerService();
00032
00034         virtual ~BtBppServerService();
00035
00037
00039         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00040
00042
00044         virtual BOOLEAN IsServerService() const;
00045
00047
00049         virtual BtRequestState RegisterRequest(UINT8* header_buffer, UINT16 header_buffer_size, BtSecuritySettings security_settings = BtSesNoSecurity);
00050
00052
00054         virtual BtRequestState UnregisterRequest();
00055
00057
00059         UINT8 GetRfComChannel() const;
00060
00062
00064         BOOLEAN ConnectResponse();
00065
00066
00067
00068         //to discuss, if application should need to handle this, or if it is better handled "under the hood"
00069         BtRequestState BppSndGetRefObjRsp( const BtDeviceAddress& device, BppObjectTypeEnum bpp_object_type_enum,  const Pathname& pathname);
00070
00071
00072
00073     private:
00074
00076         void BppSndGetRefObjIndCb(BtResultCode result);
00078         void BppSndGetRefObjCompleteIndCb(BtResultCode result);
00079
00080
00081 };
00082
00084 #endif  // BtBppServerService_hpp
00085
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppService.cpp File Reference

Bluetooth/BPP/BtBppService.cpp File Reference

#include "PreComp.hpp"
#include "BtBppService.hpp"
#include "BtBppController.hpp"
#include "BtBppServiceMessage.hpp"

Include dependency graph for BtBppService.cpp:

Generated on Tue Jan 24 19:59:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppService.hpp File Reference

Bluetooth/BPP/BtBppService.hpp File Reference

#include <Kernel/UserDispatcher.hpp>
#include <Bluetooth/BtService.hpp>

Include dependency graph for BtBppService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppService
Base class for BIP service classes. More...

Defines

#define | BtBppService_hpp

Define Documentation

#define BtBppService_hpp

Generated on Tue Jan 24 19:59:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppService.hpp Source File

Bluetooth/BPP/BtBppService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtBppService_hpp)
00010 #define BtBppService_hpp
00013
00014 #include <Kernel/UserDispatcher.hpp>
00015 #include <Bluetooth/BtService.hpp>
00016
00017 class BtBppController;
00018
00019
00021 class BtBppService: public BtService
00022 {
00023     private:
00024         typedef BtService Base;
00025
00026     public:
00028         BtBppService();
00029
00031         virtual ~BtBppService();
00032
00034
00039         virtual BtProfile GetProfile() const;
00040
00042
00044         virtual BOOLEAN IsServerService() const = 0;
00045
00047
00049         virtual BOOLEAN OnMessage(const Message& msg);
00050
00051         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00052
00053
00054     protected:
00055
00056         virtual void RegisterMessages() const;
00057         virtual void UnregisterMessages() const;
00058
00059         void SetDispatcher();
00060         void RemoveDispatcher();
00061
00062
00063     private:
00065
00067         BOOLEAN m_disp_added;
00068 };
00069
00071 #endif  // BtBppService_hpp
00072
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppServiceMessage.cpp File Reference

Bluetooth/BPP/BtBppServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtBppServiceMessage.hpp"

Include dependency graph for BtBppServiceMessage.cpp:

Generated on Tue Jan 24 19:59:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppServiceMessage.hpp File Reference

Bluetooth/BPP/BtBppServiceMessage.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtBppServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppRequestStateChangedMessage

Defines

#define | Bluetooth_BtBppServiceMessage_hpp

Define Documentation

#define Bluetooth_BtBppServiceMessage_hpp

Generated on Tue Jan 24 19:59:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppServiceMessage.hpp Source File

Bluetooth/BPP/BtBppServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\Schwenkr_viewBT\lnz_apoxi\Apoxi\Bluetooth\BPP\BtBppServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtBppServiceMessage_hpp)
00016 #define Bluetooth_BtBppServiceMessage_hpp
00017
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtBppRequestStateChangedMessage
00027     ====================================================================== */
00028
00030 class BtBppRequestStateChangedMessage : public BtRequestStateChangedMessage {
00031     public:
00032         BtBppRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00033         virtual ~BtBppRequestStateChangedMessage();
00034
00035         virtual const MsgMetaData& GetMetaData() const;
00036         virtual Message* Clone() const;
00037
00038         enum  {
00039             ID = 10316
00040             };
00041
00042     private:
00043         static const MsgMetaData m_meta_data;
00044
00045     };
00046
00047 #endif // Bluetooth_BtBppServiceMessage_hpp
00048
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndAbortReqRequest.cpp File Reference

Bluetooth/BPP/BtBppSndAbortReqRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtBppClientService.hpp"
#include "BtBppController.hpp"
#include "BtBppSndAbortReqRequest.hpp"
#include "BtBppServiceMessage.hpp"

Include dependency graph for BtBppSndAbortReqRequest.cpp:

Generated on Tue Jan 24 20:00:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndAbortReqRequest.hpp File Reference

Bluetooth/BPP/BtBppSndAbortReqRequest.hpp File Reference

#include <Bluetooth/BPP/BtBppTypes.hpp>
#include <Bluetooth/BPP/BtBppReq.hpp>

Include dependency graph for BtBppSndAbortReqRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppSndAbortReqRequest

Defines

#define | BtBppSndAbortReqRequest_hpp

Define Documentation

#define BtBppSndAbortReqRequest_hpp

Generated on Tue Jan 24 20:00:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndAbortReqRequest.hpp Source File

Bluetooth/BPP/BtBppSndAbortReqRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppSndAbortReqRequest_hpp)
00009 #define BtBppSndAbortReqRequest_hpp
00012
00013 #include <Bluetooth/BPP/BtBppTypes.hpp>
00014 #include <Bluetooth/BPP/BtBppReq.hpp>
00015 //#include <Bluetooth/BPP/BtBppClientService.hpp>
00016
00017
00018 /*  ------------------------------------------------------------------------
00019     Forward deklarations for friend relationships.
00020     ------------------------------------------------------------------------ */
00021
00022 class BtBppClientService;
00023
00026 class BtBppSndAbortReqRequest: public BtBppReq
00027 {
00028     private:
00029         typedef BtBppReq Base;
00030
00031     public:
00033         BtBppSndAbortReqRequest(BtBppClientService& Bpp_client_service);
00034
00036         virtual ~BtBppSndAbortReqRequest();
00037
00039
00041         virtual BtRequestType GetRequestType() const;
00042
00044
00046         BtDevice GetTargetDevice() const;
00047
00049
00051 //      void SetTargetDevice(const BtDevice& target_device);
00052 //      void SetObjectType( BppObjectTypeEnum bpp_object_type);
00053 //      void SetObjectName( UINT16* object_name);
00054 //      void SetObjectDescription( UINT16* object_description);
00055
00056 //      void SetBuffer(UINT8 * buffer, UINT32  buff_used_bytes, UINT32 total_body_length, BOOLEAN is_final_buff);
00057
00058         virtual BtRequestState ChangeRequestState(BOOLEAN success);
00059         virtual void SetRequestState(BtRequestState request_state);
00060
00061 /*      enum BppSubstate {
00062             bpp_state1_initial,
00063             bpp_state2_pushsent,
00064             bpp_state3_connect_ind_received_ok,
00065             bpp_state3_connect_ind_received_failed,
00066             bpp_state4_push_cfm_received_ok_send_more,
00067             bpp_state4_push_cfm_received_ok_final,
00068             bpp_state4_push_cfm_received_failed,
00069             bpp_state5_disconnect_ind_received,
00070
00071
00072         }; */
00073
00074 //      void SetBppSubState(BppSubstate substate) { m_bpp_sub_state = substate; }
00075 //      BppSubstate GetBppSubState() { return m_bpp_sub_state; }
00076
00077     protected:
00079
00081         virtual BOOLEAN Execute();
00082
00084
00086         virtual void ExecutionCallback(BtResultCode result);
00087
00088 //      btapi_bpp_snd_abort_req_t* GetApiSettings();
00089
00090     private:
00091
00092 //      btapi_bpp_snd_abort_req_t   m_operation_params;
00093
00094
00095 //      BppSubstate m_bpp_sub_state;
00096
00097         friend class BtBppController;
00098     public:
00099 //      UINT8 * buff;
00100 //      UINT32  buff_used_bytes;
00101
00102 };
00103
00105 #endif  // BtBppSndAbortReqRequest_hpp
00106
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndFilePushReqRequest.cpp File Reference

Bluetooth/BPP/BtBppSndFilePushReqRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtBppClientService.hpp"
#include "BtBppController.hpp"
#include "BtBppSndFilePushReqRequest.hpp"
#include "BtBppServiceMessage.hpp"

Include dependency graph for BtBppSndFilePushReqRequest.cpp:

Generated on Tue Jan 24 20:00:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp File Reference

Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp File Reference

#include <Bluetooth/BPP/BtBppTypes.hpp>
#include <Bluetooth/BPP/BtBppReq.hpp>

Include dependency graph for BtBppSndFilePushReqRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppSndFilePushReqRequest

Defines

#define | BtBppSndFilePushReqRequest_hpp

Define Documentation

#define BtBppSndFilePushReqRequest_hpp

Generated on Tue Jan 24 20:00:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp Source File

Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppSndFilePushReqRequest_hpp)
00009 #define BtBppSndFilePushReqRequest_hpp
00012
00013 #include <Bluetooth/BPP/BtBppTypes.hpp>
00014 #include <Bluetooth/BPP/BtBppReq.hpp>
00015 //#include <Bluetooth/BPP/BtBppClientService.hpp>
00016
00017
00018 /*  ------------------------------------------------------------------------
00019     Forward deklarations for friend relationships.
00020     ------------------------------------------------------------------------ */
00021
00022 class BtBppClientService;
00023
00026 class BtBppSndFilePushReqRequest: public BtBppReq
00027 {
00028     private:
00029         typedef BtBppReq Base;
00030
00031     public:
00033 //      BtBppSndFilePushReqRequest();
00034         BtBppSndFilePushReqRequest(BtBppClientService& Bpp_client_service);
00035 //      BtBppSndFilePushReqRequest(BtBppService& Bpp_client_service);
00036
00038         virtual ~BtBppSndFilePushReqRequest();
00039
00041
00043         virtual BtRequestType GetRequestType() const;
00044
00046
00048         BtDevice GetTargetDevice() const;
00049
00051
00053         void SetTargetDevice(const BtDevice& target_device);
00054         void SetObjectType( BppObjectTypeEnum bpp_object_type);
00055         void SetObjectName( WCHAR* object_name);
00056         void SetObjectDescription( WCHAR* object_description);
00057
00058         void SetBuffer(UINT8 * buffer, UINT32  buff_used_bytes, UINT32 total_body_length, BOOLEAN is_final_buff);
00059
00060         virtual BtRequestState ChangeRequestState(BOOLEAN success);
00061         virtual void SetRequestState(BtRequestState request_state);
00062
00063         enum BppSubstate {
00064             bpp_state1_initial,
00065             bpp_state2_pushsent,
00066             bpp_state3_connect_ind_received_ok,
00067             bpp_state3_connect_ind_received_failed,
00068             bpp_state4_push_cfm_received_ok_send_more,
00069             bpp_state4_push_cfm_received_ok_final,
00070             bpp_state4_push_cfm_received_failed,
00071             bpp_state5_abort_cfm_received,
00072             bpp_state6_disconnect_ind_received,
00073
00074
00075         };
00076
00077         void SetBppSubState(BppSubstate substate) { m_bpp_sub_state = substate; }
00078         BppSubstate GetBppSubState() { return m_bpp_sub_state; }
00079
00080     protected:
00082
00084         virtual BOOLEAN Execute();
00085
00087
00089         virtual void ExecutionCallback(BtResultCode result);
00090
00091         btapi_bpp_snd_file_push_req_t* GetApiSettings();
00092
00093     private:
00094
00095         btapi_bpp_snd_file_push_req_t   m_operation_params;
00096
00097
00098         BppSubstate m_bpp_sub_state;
00099
00100         friend class BtBppController;
00101     public:
00102         UINT8 * buff;
00103         UINT32  buff_used_bytes;
00104
00105 };
00106
00108 #endif  // BtBppSndFilePushReqRequest_hpp
00109
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndGetRefObjRspRequest.cpp File Reference

Bluetooth/BPP/BtBppSndGetRefObjRspRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtBppClientService.hpp"
#include "BtBppController.hpp"
#include "BtBppSndGetRefObjRspRequest.hpp"

Include dependency graph for BtBppSndGetRefObjRspRequest.cpp:

Generated on Tue Jan 24 20:00:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp File Reference

Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp File Reference

#include <Bluetooth/BPP/BtBppReq.hpp>
#include "BtBppTypes.hpp"

Include dependency graph for BtBppSndGetRefObjRspRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtBppSndGetRefObjRspRequest

Defines

#define | BtBppSndGetRefObjRspRequest_hpp

Define Documentation

#define BtBppSndGetRefObjRspRequest_hpp

Generated on Tue Jan 24 20:00:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp Source File

Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppSndGetRefObjRspRequest_hpp)
00009 #define BtBppSndGetRefObjRspRequest_hpp
00012
00013 #include <Bluetooth/BPP/BtBppReq.hpp>
00014 #include "BtBppTypes.hpp"
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00020 class BtBppClientService;
00021
00024 class BtBppSndGetRefObjRspRequest: public BtBppReq
00025 {
00026     private:
00027         typedef BtBppReq Base;
00028
00029     public:
00031         BtBppSndGetRefObjRspRequest(BtBppClientService& Bpp_client_service);
00032
00034         virtual ~BtBppSndGetRefObjRspRequest();
00035
00037
00039         virtual BtRequestType GetRequestType() const;
00040
00042
00044         BtDevice GetTargetDevice() const;
00045
00047
00049         void SetTargetDevice(const BtDevice& target_device);
00050
00051
00052
00053
00054
00055     protected:
00057
00059         virtual BOOLEAN Execute();
00060
00062
00064         virtual void ExecutionCallback(BtResultCode result);
00065
00066         btapi_bpp_snd_get_ref_obj_ind_t* GetApiSettings();
00067
00068     private:
00069
00070         btapi_bpp_snd_get_ref_obj_ind_t m_operation_params;
00071
00072         friend class BtBppController;
00073 };
00074
00076 #endif  // BtBppSndGetRefObjRspRequest_hpp
00077
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppTestData.hpp File Reference

Bluetooth/BPP/BtBppTestData.hpp File Reference

Go to the source code of this file.

Defines

#define BtBppTestData_hpp

Define Documentation

#define BtBppTestData_hpp

Generated on Tue Jan 24 20:00:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppTestData.hpp Source File

Bluetooth/BPP/BtBppTestData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppTestData_hpp)
00009 #define BtBppTestData_hpp
00012
00013 #if defined(_DEBUG)
00014
00015 static const char * bpp_testdata_tab[] ={
00016         "BEGIN:VCARD\nVERSION:2.1\nN:Clinic;Abha\nTEL;PREF;VOICE:+912512550054\nEND:VCARD\n\0",
00017         "BEGIN:VCARD\nVERSION:2.1\nN:Clinic;Abha\nTEL;PREF;VOICE:+912512550054\nEND:VCARD\n\0",
00018         "BEGIN:VCARD\nVERSION:2.1\nN:Clinic;Abha\nTEL;PREF;VOICE:+912512550054\nEND:VCARD\n\0",
00019
00020 };
00021
00022 #endif // _DEBUG
00023
00024
00025
00027 #endif  // BtBppTestData_hpp
00028
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppTypes.hpp File Reference

Bluetooth/BPP/BtBppTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | BtBppTypes_hpp

Enumerations

enum | BppBuffSize { e_bpp_buff_size = 2048 }
enum BppObjectTypeEnum {
e_bpp_snd_media_xhtml_print, e_bpp_snd_media_basic_text, e_bpp_snd_media_vcard, e_bpp_snd_media_vcalendar,
e_bpp_snd_media_icalendar, e_bpp_snd_media_vmessage, e_bpp_snd_media_post_script, e_bpp_snd_media_pcl,
e_bpp_snd_media_pdf, e_bpp_snd_media_jpeg, e_bpp_snd_media_gif
}
enum BtBppObexResult {
BppObexOk, BppObexContinue, BppObexPartialContent, BppObexBadRequest,
BppObexNotImplemented, BppObexForbidden, BppObexUnauthorised, BppObexPreconditionFailed,
BppObexNotFound, BppObexNotAcceptable, BppObexServiceUnavailable, BppObexUndefined
}
Result of OBEX operation used for BPP operation. More...
enum BtBppResult {
BppOk, BppContinue, BppObexFailed, BppSdapFailed,
BppPadaptFailed, BppObexHeaderFailed, BppCallError, BppUnauthenticated
}

Define Documentation

#define BtBppTypes_hpp

Generated on Tue Jan 24 20:00:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/BtBppTypes.hpp Source File

Bluetooth/BPP/BtBppTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtBppTypes_hpp)
00009 #define BtBppTypes_hpp
00012
00013         //corresponds to \3p_bt_mec\inc\bpp_snd.h Predefined Mime Media-Type strings.
00014 typedef enum   {
00015                 e_bpp_snd_media_xhtml_print,
00016                 e_bpp_snd_media_basic_text,
00017                 e_bpp_snd_media_vcard,
00018                 e_bpp_snd_media_vcalendar,
00019                 e_bpp_snd_media_icalendar,
00020                 e_bpp_snd_media_vmessage,
00021                 e_bpp_snd_media_post_script,
00022                 e_bpp_snd_media_pcl,
00023                 e_bpp_snd_media_pdf,
00024                 e_bpp_snd_media_jpeg,
00025                 e_bpp_snd_media_gif,
00026 } BppObjectTypeEnum;
00027
00028 //corresponds to \3p_bt_mec\inc\bpp_snd.h Predefined Mime Media-Type strings.
00029 static char * bpp_object_type_tab[] ={
00030         "application/vnd.pwg-xhtml-print+xml\0",
00031         "text/plain\0",
00032         "text/x-vcard\0",
00033         "text/x-vcalendar\0",
00034         "text/calendar\0",
00035         "text/x-vmessage\0",
00036         "application/PostScript\0",
00037         "application/vnd.hp-PCL\0",
00038         "application/PDF\0",
00039         "image/jpeg\0",
00040         "image/gif\0"
00041 };
00042
00043 static WCHAR * bpp_object_name_tab[] ={
00044         L"comneon.xml\0\0",
00045         L"comneon.txt\0\0",
00046         L"comneon.vcf\0\0",
00047         L"comneon.vcl\0\0",
00048         L"comneon.icl\0\0",
00049         L"comneon.msg\0\0",
00050         L"comneon.ps\0\0",
00051         L"comneon.pcl\0\0",
00052         L"comneon.pdf\0\0",
00053         L"comneon.jpg\0\0",
00054         L"comneon.gif\0\0",
00055 };
00056
00057 static WCHAR * bpp_object_description_tab[] ={ // formatiing commands possible here, according to Mecel BPP reference Manual
00058         L"\0\0",
00059         L"\0\0",
00060         L"\0\0",
00061         L"\0\0",
00062         L"\0\0",
00063         L"\0\0",
00064         L"\0\0",
00065         L"\0\0",
00066         L"\0\0",
00067         L"\0\0",
00068         L"\0\0",
00069 };
00070
00071
00072 enum BppBuffSize {e_bpp_buff_size = 2048};
00073
00074
00075
00076 // Result of BPP operation
00077 enum BtBppResult {
00078         BppOk,
00079         BppContinue,
00080         BppObexFailed,
00081         BppSdapFailed,
00082         BppPadaptFailed,
00083         BppObexHeaderFailed,
00084         BppCallError,
00085         BppUnauthenticated,
00086
00087 };
00088
00089
00090 /*
00091 typedef enum
00092 {
00093         BTAPI_BPP_RESULT_OK,
00094         BTAPI_BPP_RESULT_OBEX_FAILED,
00095         BTAPI_BPP_RESULT_SAP_FAILED,
00096         BTAPI_BPP_RESULT_PADAPT_FAILED
00097 } btapi_bpp_snd_result_t; */
00098
00099
00101 enum BtBppObexResult {
00102         BppObexOk,
00103         BppObexContinue,
00104         BppObexPartialContent,
00105         BppObexBadRequest,
00106         BppObexNotImplemented,
00107         BppObexForbidden,
00108         BppObexUnauthorised,
00109         BppObexPreconditionFailed,
00110         BppObexNotFound,
00111         BppObexNotAcceptable,
00112         BppObexServiceUnavailable,
00113         BppObexUndefined
00114 };
00115
00116 #if defined(_DEBUG)
00117 static const char * BtResultCode_tab[] ={
00118         "BtRcOk\0",
00119         "",
00120         "BtRcAccepted\0",
00121         "BtRcPending\0",
00122         "",
00123         "",
00124         "",
00125         "",
00126         "",
00127         "",
00128         "",//10
00129
00130         "","","","","","","","","","",//11-20
00131         "","","","","","","","","","",//21-30
00132         "","","","","","","","","","",//31-40
00133         "","","","","","","","","","",//41-50
00134         "","","","","","","","","","",//51-60
00135         "","","","","","","","","","",//61-70
00136         "","","","","","","","","","",//71-80
00137         "","","","","","","","","","",//81-90
00138         "","","","","","","","","","",//91-100
00139
00140         "","","","","","","","","","",//101-110
00141         "","","","","","","","","","",//111-120
00142         "","","","","","","","BtRcUnknown","","",//121-130
00143         "","","","","","","","","","",//131-140
00144         "","","","","","","","","","",//141-150
00145         "","","","","","","","","","",//151-160
00146         "","","","","","","","","","",//161-170
00147         "","","","","","","","","","",//171-180
00148         "","","","","","","","","","",//181-190
00149         "","","","","","","","","","",//191-200
00150
00151         "","","","","","","","","","",//201-210
00152         "","","","","","","","","","",//211-220
00153         "","","","","","","","","","",//221-230
00154         "","","","","","","","","","",//231-240
00155         "","","","","","","","","","",//241-250
00156         "","","BtRcError","BtRcIgnored","BtRcRejected"                  //251-255
00157 };
00158
00159
00160 static const char * bt_request_state_tab[] ={ // from enum BtRequestState: \lnz_apoxi\Apoxi\Bluetooth\BtTypes.hpp
00161         "BtRqsUnknown\0",
00162         "BtRqsInitialized\0",
00163         "BtRqsAccepted\0",
00164         "BtRqsRejected\0",
00165         "BtRqsAcceptedCancelation\0",
00166         "BtRqsExecuting\0",
00167         "BtRqsIgnored\0",
00168         "BtRqsExecutingCancelation\0",
00169         "BtRqsFinishedOk\0",
00170         "BtRqsFinishedFailure\0",
00171
00172 };
00173
00174 static const char * bt_bpp_substate_tab[] ={ // from enum BppSubstate
00175         "bpp_state1_initial\0",
00176         "bpp_state2_pushsent\0",
00177         "bpp_state3_connect_ind_received_ok\0",
00178         "bpp_state3_connect_ind_received_failed\0",
00179         "bpp_state4_push_cfm_received_ok_send_more\0",
00180         "bpp_state4_push_cfm_received_ok_final\0",
00181         "bpp_state4_push_cfm_received_failed\0",
00182         "bpp_state5_abort_cfm_received\0",
00183         "bpp_state6_disconnect_ind_received\0",
00184
00185 };
00186
00187 #endif // _DEBUG
00188
00189
00191 #endif // BtBppTypes_hpp
00192
Generated on Tue Jan 24 14:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/PreComp.cpp File Reference

Bluetooth/BPP/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/PreComp.hpp File Reference

Bluetooth/BPP/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:18:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/BPP/PreComp.hpp Source File

Bluetooth/BPP/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Bluetooth/Lib.hpp>
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunApplicationMessage.cpp File Reference

Bluetooth/DUN/BtDunApplicationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtDunApplicationMessage.hpp"

Include dependency graph for BtDunApplicationMessage.cpp:

Generated on Tue Jan 24 20:06:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunApplicationMessage.hpp File Reference

Bluetooth/DUN/BtDunApplicationMessage.hpp File Reference

#include <Bluetooth/BtApplicationMessage.hpp>
#include <Bluetooth/BtDevice.hpp>

Include dependency graph for BtDunApplicationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDunApplicationMessage
class | BtDunConnectMessage
class | BtDunDisconnectMessage

Defines

#define | Bluetooth_BtDunApplicationMessage_hpp

Define Documentation

#define Bluetooth_BtDunApplicationMessage_hpp

Generated on Tue Jan 24 20:06:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunApplicationMessage.hpp Source File

Bluetooth/DUN/BtDunApplicationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\DUN\BtDunApplicationMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtDunApplicationMessage_hpp)
00016 #define Bluetooth_BtDunApplicationMessage_hpp
00017
00018 #include <Bluetooth/BtApplicationMessage.hpp>
00019 #include <Bluetooth/BtDevice.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class BtDunApplicationMessage
00028     ====================================================================== */
00029
00031 class BtDunApplicationMessage : public BtApplicationMessage {
00032     public:
00033         BtDunApplicationMessage(const BtResultCode& result);
00034         virtual ~BtDunApplicationMessage();
00035
00036         virtual const MsgMetaData& GetMetaData() const;
00037         virtual Message* Clone() const;
00038
00039         enum  {
00040             ID = 10020
00041             };
00042
00043     private:
00044         static const MsgMetaData m_meta_data;
00045
00046     };
00047
00048
00049 /*  ======================================================================
00050     Class BtDunConnectMessage
00051     ====================================================================== */
00052
00054 class BtDunConnectMessage : public BtDunApplicationMessage {
00055     public:
00056         BtDunConnectMessage(const BtResultCode& result, const BtDevice& device);
00057         virtual ~BtDunConnectMessage();
00058
00059         virtual const MsgMetaData& GetMetaData() const;
00060         void SetDevice(const BtDevice& device) { m_device = device; }
00061         const BtDevice& GetDevice() const { return m_device; }
00062         virtual Message* Clone() const;
00063
00064         enum  {
00065             ID = 10021
00066             };
00067
00068     private:
00069         static const MsgMetaData m_meta_data;
00070         BtDevice m_device;
00071
00072     };
00073
00074
00075 /*  ======================================================================
00076     Class BtDunDisconnectMessage
00077     ====================================================================== */
00078
00080 class BtDunDisconnectMessage : public BtDunApplicationMessage {
00081     public:
00082         BtDunDisconnectMessage(const BtResultCode& result);
00083         virtual ~BtDunDisconnectMessage();
00084
00085         virtual const MsgMetaData& GetMetaData() const;
00086         virtual Message* Clone() const;
00087
00088         enum  {
00089             ID = 10022
00090             };
00091
00092     private:
00093         static const MsgMetaData m_meta_data;
00094
00095     };
00096
00097 #endif // Bluetooth_BtDunApplicationMessage_hpp
00098
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunController.cpp File Reference

Bluetooth/DUN/BtDunController.cpp File Reference

#include "PreComp.hpp"
#include "BtDunApplicationMessage.hpp"
#include "BtDunService.hpp"
#include "BtDunController.hpp"

Include dependency graph for BtDunController.cpp:

Generated on Tue Jan 24 20:06:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunController.hpp File Reference

Bluetooth/DUN/BtDunController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtDunController_hpp

Define Documentation

#define BtDunController_hpp

Generated on Tue Jan 24 20:06:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunController.hpp Source File

Bluetooth/DUN/BtDunController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDunController_hpp)
00009 #define BtDunController_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <stack/extensions.h>
00021 #include <Bluetooth/BtServiceRequest.hpp>
00022 #include <Bluetooth/BtSingleConnectionController.hpp>
00023
00024 /*  ------------------------------------------------------------------------
00025     Forward deklarations for friend relationships.
00026     ------------------------------------------------------------------------ */
00027
00028 class BtDunService;
00029 class BtDunDisconnectRequest;
00030
00034 class BtDunController : public BtSingleConnectionController
00035 {
00036     private:
00037         typedef BtSingleConnectionController Base;
00038
00039     public:
00041
00046         static BtDunController& GetInstance();
00047
00048     public:
00050         virtual ~BtDunController();
00051
00053
00055         virtual const WCHAR* GetName() const;
00056
00057     private:
00058         /*---------------------------------------------------------------------*/
00059         /* The following functions must not be called by an application.       */
00060         /* They are the entry point from the stack callback functions into our */
00061         /* object orientated framework (APOXI).                                */
00062         /* They are implemented as static because they have to be passed as    */
00063         /* normal C function pointers. The reason for this is the BT-API Stack */
00064         /* interface that demands C function pointers for callback the         */
00065         /* callback functions it calls to state the progress of ongoing        */
00066         /* operations                                                          */
00067         /*---------------------------------------------------------------------*/
00068
00070
00073         static void OnDunConnectCallback(btapi_result_t result, btapi_bdaddr_t api_device_address);
00074
00076
00078         void OnDunConnect(BtResultCode result, const BtDeviceAddress& device_address);
00079
00081
00084         static void OnDunDisconnectCallback(btapi_result_t result);
00085
00087
00089         void OnDunDisconnect(BtResultCode result);
00090
00091     private:
00093         BtDunController();
00094
00096
00098         virtual void Register();
00099
00101
00103         virtual void Unregister();
00104
00105     private:
00107         btapi_duncb_funp_t* m_dun_callback_functions;
00108
00109     private:
00111         static BtDunController m_controller;
00112
00113     private:
00114         friend class BtDunService;
00115         friend class BtDunDisconnectRequest;
00116 };
00117
00119 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00120 #endif  // BtDunController_hpp
00121
00122
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunDisconnectRequest.cpp File Reference

Bluetooth/DUN/BtDunDisconnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtDunService.hpp"
#include "BtDunController.hpp"
#include "BtDunDisconnectRequest.hpp"

Include dependency graph for BtDunDisconnectRequest.cpp:

Generated on Tue Jan 24 20:06:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunDisconnectRequest.hpp File Reference

Bluetooth/DUN/BtDunDisconnectRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtDunDisconnectRequest_hpp

Define Documentation

#define BtDunDisconnectRequest_hpp

Generated on Tue Jan 24 20:06:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunDisconnectRequest.hpp Source File

Bluetooth/DUN/BtDunDisconnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDunDisconnectRequest_hpp)
00009 #define BtDunDisconnectRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtDisconnectRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtDunService;
00027
00031 class BtDunDisconnectRequest: public BtDisconnectRequest
00032 {
00033     private:
00034         typedef BtDisconnectRequest Base;
00035
00036     public:
00038
00048         BtDunDisconnectRequest(BtDunService& dun_service);
00049
00051         virtual ~BtDunDisconnectRequest();
00052
00054
00062         virtual BtRequestType GetRequestType() const;
00063
00064     protected:
00066
00068         virtual BOOLEAN PerformDisconnectControllerCall();
00069 };
00070
00072 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00073 #endif  // BtCloseRequest_hpp
00074
00075
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunService.cpp File Reference

Bluetooth/DUN/BtDunService.cpp File Reference

#include "PreComp.hpp"
#include "BtDunService.hpp"
#include "BtDunServiceMessage.hpp"
#include "BtDunController.hpp"

Include dependency graph for BtDunService.cpp:

Generated on Tue Jan 24 20:06:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunService.hpp File Reference

Bluetooth/DUN/BtDunService.hpp File Reference

#include <Bluetooth/BtService.hpp>
#include <Bluetooth/DUN/BtDunDisconnectRequest.hpp>

Include dependency graph for BtDunService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDunService

Defines

#define | BtDunService_hpp

Define Documentation

#define BtDunService_hpp

Generated on Tue Jan 24 20:06:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunService.hpp Source File

Bluetooth/DUN/BtDunService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDunService_hpp)
00009 #define BtDunService_hpp
00012
00013 #include <Bluetooth/BtService.hpp>
00014 #include <Bluetooth/DUN/BtDunDisconnectRequest.hpp>
00015
00021 class BtDunService: public BtService
00022 {
00023     private:
00024         typedef BtService Base;
00025
00026     public:
00028         BtDunService();
00029
00031         virtual ~BtDunService();
00032
00034
00038         virtual BtProfile GetProfile() const;
00039
00041
00043         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00044
00046
00048         BOOLEAN IsConnected() const;
00049
00051
00053         BtRequestState DisconnectRequest();
00054
00055     protected:
00057
00059         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00060
00062
00064         virtual void RegisterMessages() const;
00065
00067
00069         virtual void UnregisterMessages() const;
00070
00072
00074         virtual BOOLEAN OnMessage(const Message& message);
00075
00076     private:
00078         BtDunDisconnectRequest m_dun_disconnect_request;
00079
00081         BOOLEAN m_dispatcher_added;
00082 };
00083
00085 #endif  // BtDunService_hpp
00086
00087
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunServiceMessage.cpp File Reference

Bluetooth/DUN/BtDunServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtDunServiceMessage.hpp"

Include dependency graph for BtDunServiceMessage.cpp:

Generated on Tue Jan 24 20:06:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunServiceMessage.hpp File Reference

Bluetooth/DUN/BtDunServiceMessage.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtDunServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDunRequestStateChangedMessage

Defines

#define | Bluetooth_BtDunServiceMessage_hpp

Define Documentation

#define Bluetooth_BtDunServiceMessage_hpp

Generated on Tue Jan 24 20:06:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/BtDunServiceMessage.hpp Source File

Bluetooth/DUN/BtDunServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\DUN\BtDunServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtDunServiceMessage_hpp)
00016 #define Bluetooth_BtDunServiceMessage_hpp
00017
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtDunRequestStateChangedMessage
00027     ====================================================================== */
00028
00030 class BtDunRequestStateChangedMessage : public BtRequestStateChangedMessage {
00031     public:
00032         BtDunRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00033         virtual ~BtDunRequestStateChangedMessage();
00034
00035         virtual const MsgMetaData& GetMetaData() const;
00036         virtual Message* Clone() const;
00037
00038         enum  {
00039             ID = 10315
00040             };
00041
00042     private:
00043         static const MsgMetaData m_meta_data;
00044
00045     };
00046
00047 #endif // Bluetooth_BtDunServiceMessage_hpp
00048
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/Lib.hpp File Reference

Bluetooth/DUN/Lib.hpp File Reference

#include <Bluetooth/DUN/BtDunApplicationMessage.hpp>
#include <Bluetooth/DUN/BtDunServiceMessage.hpp>
#include <Bluetooth/DUN/BtDunController.hpp>
#include <Bluetooth/DUN/BtDunService.hpp>
#include <Bluetooth/DUN/BtDunDisconnectRequest.hpp>

Include dependency graph for Lib.hpp:

Go to the source code of this file.

Defines

#define Bluetooth_Dun_Lib_hpp

Define Documentation

#define Bluetooth_Dun_Lib_hpp

Generated on Tue Jan 24 14:54:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/Lib.hpp Source File

Bluetooth/DUN/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bluetooth_Dun_Lib_hpp)
00009 #define Bluetooth_Dun_Lib_hpp
00012
00013 #include <Bluetooth/DUN/BtDunApplicationMessage.hpp>
00014 #include <Bluetooth/DUN/BtDunServiceMessage.hpp>
00015 #include <Bluetooth/DUN/BtDunController.hpp>
00016 #include <Bluetooth/DUN/BtDunService.hpp>
00017 #include <Bluetooth/DUN/BtDunDisconnectRequest.hpp>
00018
00020 #endif /* Bluetooth_Dun_Lib_hpp */
00021
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/PreComp.cpp File Reference

Bluetooth/DUN/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/PreComp.hpp File Reference

Bluetooth/DUN/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:19:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/DUN/PreComp.hpp Source File

Bluetooth/DUN/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Bluetooth/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxApplicationMessage.cpp File Reference

Bluetooth/FAX/BtFaxApplicationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtFaxApplicationMessage.hpp"

Include dependency graph for BtFaxApplicationMessage.cpp:

Generated on Tue Jan 24 20:07:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxApplicationMessage.hpp File Reference

Bluetooth/FAX/BtFaxApplicationMessage.hpp File Reference

#include <Bluetooth/BtApplicationMessage.hpp>
#include <Bluetooth/BtDevice.hpp>

Include dependency graph for BtFaxApplicationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtFaxApplicationMessage
class | BtFaxConnectMessage
class | BtFaxDisconnectMessage

Defines

#define | Bluetooth_BtFaxApplicationMessage_hpp

Define Documentation

#define Bluetooth_BtFaxApplicationMessage_hpp

Generated on Tue Jan 24 20:07:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxApplicationMessage.hpp Source File

Bluetooth/FAX/BtFaxApplicationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\FAX\BtFaxApplicationMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtFaxApplicationMessage_hpp)
00016 #define Bluetooth_BtFaxApplicationMessage_hpp
00017
00018 #include <Bluetooth/BtApplicationMessage.hpp>
00019 #include <Bluetooth/BtDevice.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class BtFaxApplicationMessage
00028     ====================================================================== */
00029
00031 class BtFaxApplicationMessage : public BtApplicationMessage {
00032     public:
00033         BtFaxApplicationMessage(const BtResultCode& result);
00034         virtual ~BtFaxApplicationMessage();
00035
00036         virtual const MsgMetaData& GetMetaData() const;
00037         virtual Message* Clone() const;
00038
00039         enum  {
00040             ID = 10030
00041             };
00042
00043     private:
00044         static const MsgMetaData m_meta_data;
00045
00046     };
00047
00048
00049 /*  ======================================================================
00050     Class BtFaxConnectMessage
00051     ====================================================================== */
00052
00054 class BtFaxConnectMessage : public BtFaxApplicationMessage {
00055     public:
00056         BtFaxConnectMessage(const BtResultCode& result, const BtDevice& device);
00057         virtual ~BtFaxConnectMessage();
00058
00059         virtual const MsgMetaData& GetMetaData() const;
00060         void SetDevice(const BtDevice& device) { m_device = device; }
00061         const BtDevice& GetDevice() const { return m_device; }
00062         virtual Message* Clone() const;
00063
00064         enum  {
00065             ID = 10031
00066             };
00067
00068     private:
00069         static const MsgMetaData m_meta_data;
00070         BtDevice m_device;
00071
00072     };
00073
00074
00075 /*  ======================================================================
00076     Class BtFaxDisconnectMessage
00077     ====================================================================== */
00078
00080 class BtFaxDisconnectMessage : public BtFaxApplicationMessage {
00081     public:
00082         BtFaxDisconnectMessage(const BtResultCode& result);
00083         virtual ~BtFaxDisconnectMessage();
00084
00085         virtual const MsgMetaData& GetMetaData() const;
00086         virtual Message* Clone() const;
00087
00088         enum  {
00089             ID = 10032
00090             };
00091
00092     private:
00093         static const MsgMetaData m_meta_data;
00094
00095     };
00096
00097 #endif // Bluetooth_BtFaxApplicationMessage_hpp
00098
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxController.cpp File Reference

Bluetooth/FAX/BtFaxController.cpp File Reference

#include "PreComp.hpp"
#include "BtFaxApplicationMessage.hpp"
#include "BtFaxService.hpp"
#include "BtFaxController.hpp"

Include dependency graph for BtFaxController.cpp:

Generated on Tue Jan 24 20:07:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxController.hpp File Reference

Bluetooth/FAX/BtFaxController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtFaxController_hpp

Define Documentation

#define BtFaxController_hpp

Generated on Tue Jan 24 20:07:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxController.hpp Source File

Bluetooth/FAX/BtFaxController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtFaxController_hpp)
00009 #define BtFaxController_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <stack/extensions.h>
00021 #include <Bluetooth/BtServiceRequest.hpp>
00022 #include <Bluetooth/BtSingleConnectionController.hpp>
00023
00024 /*  ------------------------------------------------------------------------
00025     Forward deklarations for friend relationships.
00026     ------------------------------------------------------------------------ */
00027
00028 class BtFaxService;
00029 class BtFaxDisconnectRequest;
00030
00034 class BtFaxController : public BtSingleConnectionController
00035 {
00036     private:
00037         typedef BtSingleConnectionController Base;
00038
00039     public:
00041
00046         static BtFaxController& GetInstance();
00047
00048     public:
00050         virtual ~BtFaxController();
00051
00053
00055         virtual const WCHAR* GetName() const;
00056
00057     private:
00058         /*---------------------------------------------------------------------*/
00059         /* The following functions must not be called by an application.       */
00060         /* They are the entry point from the stack callback functions into our */
00061         /* object orientated framework (APOXI).                                */
00062         /* They are implemented as static because they have to be passed as    */
00063         /* normal C function pointers. The reason for this is the BT-API Stack */
00064         /* interface that demands C function pointers for callback the         */
00065         /* callback functions it calls to state the progress of ongoing        */
00066         /* operations                                                          */
00067         /*---------------------------------------------------------------------*/
00068
00070
00073         static void OnFaxConnectCallback(btapi_result_t result, btapi_bdaddr_t api_device_address);
00074
00076
00078         void OnFaxConnect(BtResultCode result, const BtDeviceAddress& device_address);
00079
00081
00084         static void OnFaxDisconnectCallback(btapi_result_t result);
00085
00087
00089         void OnFaxDisconnect(BtResultCode result);
00090
00091     private:
00093         BtFaxController();
00094
00096
00098         virtual void Register();
00099
00101
00103         virtual void Unregister();
00104
00105     private:
00107         btapi_faxcb_funp_t* m_fax_callback_functions;
00108
00109     private:
00111         static BtFaxController m_controller;
00112
00113     private:
00114         friend class BtFaxService;
00115         friend class BtFaxDisconnectRequest;
00116 };
00117
00119 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00120 #endif  // BtFaxController_hpp
00121
00122
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxDisconnectRequest.cpp File Reference

Bluetooth/FAX/BtFaxDisconnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtFaxService.hpp"
#include "BtFaxController.hpp"
#include "BtFaxDisconnectRequest.hpp"

Include dependency graph for BtFaxDisconnectRequest.cpp:

Generated on Tue Jan 24 20:07:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxDisconnectRequest.hpp File Reference

Bluetooth/FAX/BtFaxDisconnectRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtFaxDisconnectRequest_hpp

Define Documentation

#define BtFaxDisconnectRequest_hpp

Generated on Tue Jan 24 20:07:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxDisconnectRequest.hpp Source File

Bluetooth/FAX/BtFaxDisconnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtFaxDisconnectRequest_hpp)
00009 #define BtFaxDisconnectRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtDisconnectRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtFaxService;
00027
00031 class BtFaxDisconnectRequest: public BtDisconnectRequest
00032 {
00033     private:
00034         typedef BtDisconnectRequest Base;
00035
00036     public:
00038
00048         BtFaxDisconnectRequest(BtFaxService& fax_service);
00049
00051         virtual ~BtFaxDisconnectRequest();
00052
00054
00062         virtual BtRequestType GetRequestType() const;
00063
00064     protected:
00066
00068         virtual BOOLEAN PerformDisconnectControllerCall();
00069 };
00070
00072 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00073 #endif  // BtFaxDisconnectRequest_hpp
00074
00075
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxService.cpp File Reference

Bluetooth/FAX/BtFaxService.cpp File Reference

#include "PreComp.hpp"
#include "BtFaxService.hpp"
#include "BtFaxServiceMessage.hpp"
#include "BtFaxController.hpp"

Include dependency graph for BtFaxService.cpp:

Generated on Tue Jan 24 20:07:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxService.hpp File Reference

Bluetooth/FAX/BtFaxService.hpp File Reference

#include <Bluetooth/BtService.hpp>
#include <Bluetooth/FAX/BtFaxDisconnectRequest.hpp>

Include dependency graph for BtFaxService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtFaxService

Defines

#define | BtFaxService_hpp

Define Documentation

#define BtFaxService_hpp

Generated on Tue Jan 24 20:07:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxService.hpp Source File

Bluetooth/FAX/BtFaxService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtFaxService_hpp)
00009 #define BtFaxService_hpp
00012
00013 #include <Bluetooth/BtService.hpp>
00014 #include <Bluetooth/FAX/BtFaxDisconnectRequest.hpp>
00015
00021 class BtFaxService: public BtService
00022 {
00023     private:
00024         typedef BtService Base;
00025
00026     public:
00028         BtFaxService();
00029
00031         virtual ~BtFaxService();
00032
00034
00038         virtual BtProfile GetProfile() const;
00039
00041
00043         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00044
00046
00048         BOOLEAN IsConnected() const;
00049
00051
00053         BtRequestState DisconnectRequest();
00054
00055     protected:
00057
00059         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00060
00062
00064         virtual void RegisterMessages() const;
00065
00067
00069         virtual void UnregisterMessages() const;
00070
00072
00074         virtual BOOLEAN OnMessage(const Message& message);
00075
00076     private:
00078         BtFaxDisconnectRequest m_fax_disconnect_request;
00079
00081         BOOLEAN m_dispatcher_added;
00082 };
00083
00085 #endif  // BtFaxService_hpp
00086
00087
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxServiceMessage.cpp File Reference

Bluetooth/FAX/BtFaxServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtFaxServiceMessage.hpp"

Include dependency graph for BtFaxServiceMessage.cpp:

Generated on Tue Jan 24 20:07:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxServiceMessage.hpp File Reference

Bluetooth/FAX/BtFaxServiceMessage.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtFaxServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtFaxRequestStateChangedMessage

Defines

#define | Bluetooth_BtFaxServiceMessage_hpp

Define Documentation

#define Bluetooth_BtFaxServiceMessage_hpp

Generated on Tue Jan 24 20:07:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/BtFaxServiceMessage.hpp Source File

Bluetooth/FAX/BtFaxServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\FAX\BtFaxServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtFaxServiceMessage_hpp)
00016 #define Bluetooth_BtFaxServiceMessage_hpp
00017
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtFaxRequestStateChangedMessage
00027     ====================================================================== */
00028
00030 class BtFaxRequestStateChangedMessage : public BtRequestStateChangedMessage {
00031     public:
00032         BtFaxRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00033         virtual ~BtFaxRequestStateChangedMessage();
00034
00035         virtual const MsgMetaData& GetMetaData() const;
00036         virtual Message* Clone() const;
00037
00038         enum  {
00039             ID = 10320
00040             };
00041
00042     private:
00043         static const MsgMetaData m_meta_data;
00044
00045     };
00046
00047 #endif // Bluetooth_BtFaxServiceMessage_hpp
00048
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/Lib.hpp File Reference

Bluetooth/FAX/Lib.hpp File Reference

#include <Bluetooth/FAX/BtFaxApplicationMessage.hpp>
#include <Bluetooth/FAX/BtFaxServiceMessage.hpp>
#include <Bluetooth/FAX/BtFaxController.hpp>
#include <Bluetooth/FAX/BtFaxService.hpp>
#include <Bluetooth/FAX/BtFaxDisconnectRequest.hpp>

Include dependency graph for Lib.hpp:

Go to the source code of this file.

Defines

#define Bluetooth_Fax_Lib_hpp

Define Documentation

#define Bluetooth_Fax_Lib_hpp

Generated on Tue Jan 24 14:54:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/Lib.hpp Source File

Bluetooth/FAX/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bluetooth_Fax_Lib_hpp)
00009 #define Bluetooth_Fax_Lib_hpp
00012
00013 #include <Bluetooth/FAX/BtFaxApplicationMessage.hpp>
00014 #include <Bluetooth/FAX/BtFaxServiceMessage.hpp>
00015 #include <Bluetooth/FAX/BtFaxController.hpp>
00016 #include <Bluetooth/FAX/BtFaxService.hpp>
00017 #include <Bluetooth/FAX/BtFaxDisconnectRequest.hpp>
00018
00020 #endif /* Bluetooth_Fax_Lib_hpp */
00021
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/PreComp.cpp File Reference

Bluetooth/FAX/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/PreComp.hpp File Reference

Bluetooth/FAX/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:19:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/FAX/PreComp.hpp Source File

Bluetooth/FAX/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Bluetooth/Lib.hpp>
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfConnectRequest.cpp File Reference

Bluetooth/HF/BtHfConnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHfService.hpp"
#include "BtHfController.hpp"
#include "BtHfConnectRequest.hpp"

Include dependency graph for BtHfConnectRequest.cpp:

Generated on Tue Jan 24 20:07:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfConnectRequest.hpp File Reference

Bluetooth/HF/BtHfConnectRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfConnectRequest_hpp

Define Documentation

#define BtHfConnectRequest_hpp

Generated on Tue Jan 24 20:07:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfConnectRequest.hpp Source File

Bluetooth/HF/BtHfConnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfConnectRequest_hpp)
00009 #define BtHfConnectRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtConnectRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHfService;
00027
00030 class BtHfConnectRequest: public BtConnectRequest
00031 {
00032     private:
00033         typedef BtConnectRequest Base;
00034
00035     public:
00037         BtHfConnectRequest(BtHfService& hf_service);
00038
00040         virtual ~BtHfConnectRequest();
00041
00043
00045         virtual BtRequestType GetRequestType() const;
00046
00047     protected:
00049
00051         virtual BOOLEAN PerformConnectControllerCall();
00052 };
00053
00055 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00056 #endif  // BtHfConnectRequest_hpp
00057
00058
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfController.cpp File Reference

Bluetooth/HF/BtHfController.cpp File Reference

#include "PreComp.hpp"
#include "BtHfControllerMessage.hpp"
#include "BtHfControllerMessageArgument.hpp"
#include "BtHfNotificationMessage.hpp"
#include "BtHfNotificationMessageArgument.hpp"
#include "BtHfConnectRequest.hpp"
#include "BtHfDisconnectRequest.hpp"
#include "BtHfTransferAudioToPhoneRequest.hpp"
#include "BtHfTransferAudioToAccessoryRequest.hpp"
#include "BtHfSetMicrophoneGainRequest.hpp"
#include "BtHfSetSpeakerGainRequest.hpp"
#include "BtHfService.hpp"
#include "BtHfController.hpp"

Include dependency graph for BtHfController.cpp:

Defines

#define | DBG_STATE
#define | DBG_STATE_STATIC
#define | FEATURE_HF_VOICE_TAG 0x10

Functions

unsigned | msap_retrieve_brsf (void)

Define Documentation

#define DBG_STATE

#define DBG_STATE_STATIC

#define FEATURE_HF_VOICE_TAG 0x10

Function Documentation

unsigned msap_retrieve_brsf ( void )

Generated on Tue Jan 24 20:07:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfController.hpp File Reference

Bluetooth/HF/BtHfController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfController_hpp

Define Documentation

#define BtHfController_hpp

Generated on Tue Jan 24 20:07:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfController.hpp Source File

Bluetooth/HF/BtHfController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfController_hpp)
00009 #define BtHfController_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <stack/extensions.h>
00021 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00022 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>
00023 #include <Apc/SignalHandler/StackMsgProcessor.hpp>
00024 #include <Devices/AudioAccessoryDetails.hpp>
00025 #include <Bluetooth/BtServiceRequest.hpp>
00026 #include <Bluetooth/BtSingleConnectionController.hpp>
00027 #include <Bluetooth/HF/BtTypes.hpp>
00028
00029 /*  ------------------------------------------------------------------------
00030     Forward deklarations for friend relationships.
00031     ------------------------------------------------------------------------ */
00032
00033 class BtHfService;
00034 class BtHfConnectRequest;
00035 class BtHfDisconnectRequest;
00036 class BtHfTransferAudioToPhoneRequest;
00037 class BtHfTransferAudioToAccessoryRequest;
00038 class BtHfSetMicrophoneGainRequest;
00039 class BtHfSetSpeakerGainRequest;
00040 class BtHfPmiMsgManager;
00041 class BtHfAudioTransferRequest;
00042
00047 class BtHfController : public BtSingleConnectionController
00048 {
00049     private:
00050         typedef BtSingleConnectionController Base;
00051
00052     public:
00054
00059         static BtHfController& GetInstance();
00060
00061     public:
00063         virtual ~BtHfController();
00064
00066
00068         virtual const WCHAR* GetName() const;
00069
00070     protected:
00072
00074         void HfSetInbandRinging(BOOLEAN enable);
00075
00077
00079         BOOLEAN HfTransferAudioToPhoneRequest(BtHfTransferAudioToPhoneRequest* transfer_audio_to_phone_request);
00080
00082
00084         BOOLEAN HfTransferAudioToAccessoryRequest(BtHfTransferAudioToAccessoryRequest* transfer_audio_to_accessory_request);
00085
00087
00089         BOOLEAN HfSetMicrophoneGainRequest(BtHfSetMicrophoneGainRequest* set_microphone_gain_request);
00090
00092
00094         BOOLEAN HfSetSpeakerGainRequest(BtHfSetSpeakerGainRequest* set_speaker_gain_request);
00095
00097
00099         BtHfState GetState(const BtDevice& device) const;
00100
00102
00104         BOOLEAN GetIsRinging(const BtDevice& device) const;
00105
00107
00109         void SetIsRinging(const BtDevice& device, BOOLEAN is_ringing);
00110
00112
00114         BtHfCallLocation GetCallLocation(const BtDevice& device) const;
00115
00117
00119         void SetCallLocation(const BtDevice& device, BtHfCallLocation call_location);
00120
00122
00124         UINT8 GetMicrophoneGain(const BtDevice& device) const;
00125
00127
00129         UINT8 GetSpeakerGain(const BtDevice& device) const;
00130
00132
00134         UINT16 GetSupportedFeatures(const BtDevice& device) const;
00135
00136     private:
00137         /*---------------------------------------------------------------------*/
00138         /* The following functions must not be called by an application.       */
00139         /* They are the entry point from the stack callback functions into our */
00140         /* object orientated framework (APOXI).                                */
00141         /* They are implemented as static because they have to be passed as    */
00142         /* normal C function pointers. The reason for this is the BT-API Stack */
00143         /* interface that demands C function pointers for callback the         */
00144         /* callback functions it calls to state the progress of ongoing        */
00145         /* operations                                                          */
00146         /*---------------------------------------------------------------------*/
00147
00149
00151         static void OnHfCommonCallback(btapi_result_t result, btapi_common_hfcb_t type);
00152
00154
00156         void OnHfAudioConnectionLost(BtResultCode result);
00157
00159
00161         void OnHfLowPowerModeNotPosssible(BtResultCode result);
00162
00164
00166         static void OnHfConnectCallback(btapi_result_t result, btapi_bdaddr_t api_device_address);
00167
00169
00171         void OnHfConnect(BtResultCode result, BtDeviceAddress device_address);
00172
00174
00176         static void OnHfDisconnectCallback(btapi_result_t result, btapi_bdaddr_t api_device_address);
00177
00179
00181         void OnHfDisconnect(BtResultCode result /*, btapi_bdaddr_t bdaddr*/);
00182
00184
00186         static void OnHfAudioCallback(btapi_result_t result, btapi_bool_t is_audio_at_phone);
00187
00189
00191         void OnHfAudio(BtResultCode result, BOOLEAN is_audio_at_phone);
00192
00194
00196         void OnHfTransferAudioToPhoneRequest(BtHfTransferAudioToPhoneRequest* request, BtResultCode result, BOOLEAN is_audio_at_phone);
00197
00199
00201         void OnHfTransferAudioToAccessoryRequest(BtHfTransferAudioToAccessoryRequest* request, BtResultCode result, BOOLEAN is_audio_at_phone);
00202
00204
00206         void OnHfTransferAudio(BtResultCode result, BOOLEAN is_audio_at_phone);
00207
00209
00211         static void OnHfPmiCallback(const ProcessPtr& process_pointer);
00212
00214
00216         void OnHfPmi(UINT16 pmi_function, UINT16 pmi_accessory, UINT16 pmi_tid, UINT16 pmi_report);
00217
00219
00221         void OnHfPmiMtcOnHf(void);
00222
00224
00226         void OnHfPmiMocOnHf(void);
00227
00229
00231         void OnHfPmiNameRecognized(void);
00232
00234
00236         void OnHfPmiVoiceRecognition(BOOLEAN pmi_accessory);
00237
00239
00241         void OnHfPmiNoiseReductionEchoCancelationRequest(UINT16 status);
00242
00244
00246         void OnHfPmiMicrophoneGain(UINT8 microphone_gain);
00247
00249
00251         void OnHfPmiSpeakerGain(UINT8 speaker_gain);
00252
00254
00256         void OnHfPmiReleaseWaitingAndAcceptWaitingOnHf();
00257
00259
00261         void OnAudioPathConnected(BOOLEAN connected, BOOLEAN update_path);
00262
00263     private:
00265         BtHfController();
00266
00268
00270         virtual void Register();
00271
00273
00275         virtual void Unregister();
00276
00278
00280         void SetState(BtHfState state);
00281
00283
00285         void SetMicrophoneGain(UINT8 microphone_gain);
00286
00288
00290         void SetSpeakerGain(UINT8 speaker_gain);
00291
00293
00295         BOOLEAN SwitchAudio(BOOLEAN conneded, BOOLEAN switch_path);
00296
00298
00300         void SetRunningAudioSetConnected(BOOLEAN running, BOOLEAN connected, BOOLEAN switch_path);
00301
00303
00305         void SetPendingAudioCallback(BOOLEAN pending, BOOLEAN connected, BOOLEAN switch_path);
00306
00308
00310         void CheckPendingAudioCallback();
00311
00312     private:
00313         class BtHfSignalMapTableNode: public SignalMapTableNode
00314         {
00315             private:
00316                 typedef SignalMapTableNode Base;
00317
00318             public:
00320                 BtHfSignalMapTableNode();
00321
00323                 virtual ~BtHfSignalMapTableNode();
00324
00325             private:
00326                 static const SignalMapTableEntry m_signal_map_table_entry[];
00327         };  // BtHfSignalMapTableNode
00328
00329         class BtHfStackMessageProcessor: public StackMsgProcessor
00330         {
00331             private:
00332                 typedef StackMsgProcessor Base;
00333
00334             public:
00336                 BtHfStackMessageProcessor();
00337
00339                 virtual ~BtHfStackMessageProcessor();
00340
00341             public:
00343
00345                 UINT16 GetPmiTid() const;
00346
00348
00350                 void SetPmiTid(UINT16 pmi_tid);
00351
00353
00355                 void SendHsInformIndication(UINT16 pmi_function, UINT16 pmi_report, UINT32* pmi_data);
00356
00358
00360                 void SetHfDataInput(UINT8* number);
00361
00363
00365                 void SetHfVoiceRecognitionReq(BOOLEAN enable);
00366
00368
00370                 void SetHfVoiceRecognitionInd(T_PMI_REPORT report);
00371
00373
00375                 void SetHfInbandRingingIndication(BOOLEAN enable);
00376
00378
00380                 void SendNoiceReductionEchoCancelationIndication(BOOLEAN result);
00381
00382             protected:
00384
00386                 void SendSignal(UINT16 pmi_function, UINT16 pmi_accessory, UINT16 pmi_report, UINT32* pmi_data);
00387
00388             private:
00389                 UINT16 m_pmi_tid;
00390         };  // BtStackMessageProcessor
00391
00392         class BtHfAudioAccessoryDetails: public AudioAccessoryDetails
00393         {
00394             private:
00395                 typedef AudioAccessoryDetails Base;
00396
00397             public:
00399                 BtHfAudioAccessoryDetails();
00400
00402
00404                 virtual void OnAudioPathConnected(BOOLEAN connected, BOOLEAN update_path);
00405         };  // BtHfAudioAccessoryDetails
00406
00407 #ifdef _DEBUG
00408     private:
00410
00412         void DebugState();
00413 #endif /* _DEBUG */
00414
00415     private:
00417         btapi_hfcb_funp_t* m_hf_callback_functions;
00418
00420         BtHfState m_hf_state;
00421
00423         BOOLEAN m_is_ringing;
00424
00426         BtHfCallLocation m_call_location;
00427
00429         BOOLEAN m_noice_reduction_echo_cancelation;
00430
00432         UINT8 m_microphone_gain;
00433
00435         UINT8 m_speaker_gain;
00436
00438         BtHfSignalMapTableNode m_signal_map_table_node;
00439
00441         BtHfStackMessageProcessor m_stack_message_processor;
00442
00444         BtHfAudioAccessoryDetails m_audio_accessory_details;
00445
00447         Semaphore m_audio_callback_pending_semaphore;
00448
00450         BOOLEAN m_audio_set_connected_running;
00451
00453         BOOLEAN m_audio_set_connected_connected;
00454
00456         BOOLEAN m_audio_set_connected_switch_path;
00457
00459         BOOLEAN m_audio_callback_pending;
00460
00462         BOOLEAN m_audio_callback_connected;
00463
00465         BOOLEAN m_audio_callback_switch_path;
00466
00467     private:
00469         static BtHfController m_controller;
00470
00471     private:
00472         friend class BtHfController::BtHfAudioAccessoryDetails;
00473
00474     private:
00475         friend class BtHfService;
00476         friend class BtHfConnectRequest;
00477         friend class BtHfDisconnectRequest;
00478         friend class BtHfTransferAudioToPhoneRequest;
00479         friend class BtHfTransferAudioToAccessoryRequest;
00480         friend class BtHfSetMicrophoneGainRequest;
00481         friend class BtHfSetSpeakerGainRequest;
00482         friend class BtHfPmiMsgManager;
00483         friend class BtHfAudioTransferRequest;
00484 };
00485
00487 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00488 #endif  // BtHfController_hpp
00489
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfControllerMessage.cpp File Reference

Bluetooth/HF/BtHfControllerMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtHfControllerMessage.hpp"

Include dependency graph for BtHfControllerMessage.cpp:

Generated on Tue Jan 24 20:07:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfControllerMessage.hpp File Reference

Bluetooth/HF/BtHfControllerMessage.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfControllerMessage_hpp

Define Documentation

#define BtHfControllerMessage_hpp

Generated on Tue Jan 24 20:07:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfControllerMessage.hpp Source File

Bluetooth/HF/BtHfControllerMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfControllerMessage_hpp)
00009 #define BtHfControllerMessage_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Apc/Message.hpp>
00021 #include <Apc/StackMsgArgument.hpp>
00022
00025 class BtHfControllerMessage: public FromStackMsg
00026 {
00027     private:
00028         typedef FromStackMsg Base;
00029
00030     public:
00032         BtHfControllerMessage(const BtDevice& device = bt_c_unknown_device, StackMsgArgument *argument = 0);
00033
00035         BtHfControllerMessage(const BtHfControllerMessage &message);
00036
00038         virtual ~BtHfControllerMessage();
00039
00041
00043         const BtDevice& GetDevice() const;
00044
00046
00048         virtual FromStackMsg& operator=(const FromStackMsg &message);
00049
00051
00053         virtual BtHfControllerMessage& operator=(const BtHfControllerMessage &message);
00054
00056
00058         virtual const MsgMetaData& GetMetaData() const;
00059
00061
00063         virtual Message* Clone() const;
00064
00065     public:
00066         enum { ID = 10405 };
00067
00068     private:
00070         BtDevice m_device;
00071
00072     private:
00074         static const MsgMetaData m_meta_data;
00075 };
00076
00078 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00079 #endif // BtHfControllerMessage_hpp
00080
00081
Generated on Tue Jan 24 14:48:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfControllerMessageArgument.cpp File Reference

Bluetooth/HF/BtHfControllerMessageArgument.cpp File Reference

#include "PreComp.hpp"
#include "BtHfControllerMessageArgument.hpp"

Include dependency graph for BtHfControllerMessageArgument.cpp:

Generated on Tue Jan 24 20:08:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfControllerMessageArgument.hpp File Reference

Bluetooth/HF/BtHfControllerMessageArgument.hpp File Reference

#include <Apc/StackMsgArgument.hpp>

Include dependency graph for BtHfControllerMessageArgument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfCmaAtChldOneCommandReceived
class | BtHfCmaAudioAsynchronous
class | BtHfCmaCheckPendingAudioCallback
class | BtHfCmaMOC
class | BtHfCmaMTC
class | BtHfCmaPhoneNumberRequired

Defines

#define | Bluetooth_HF_BtHfControllerMessageArgument_hpp

Define Documentation

#define Bluetooth_HF_BtHfControllerMessageArgument_hpp

Generated on Tue Jan 24 20:08:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfControllerMessageArgument.hpp Source File

Bluetooth/HF/BtHfControllerMessageArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "pointner_leopard_development_pu_dv\lnz_apoxi\Apoxi\Bluetooth\HF\BtHfControllerMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_HF_BtHfControllerMessageArgument_hpp)
00016 #define Bluetooth_HF_BtHfControllerMessageArgument_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtHfCmaPhoneNumberRequired
00027     ====================================================================== */
00028
00030 class BtHfCmaPhoneNumberRequired : public StackMsgArgument {
00031     friend class BtHfMessageArgumentsDestroyTableNode;
00032     public:
00033         BtHfCmaPhoneNumberRequired(const BtResultCode& result);
00034         BtHfCmaPhoneNumberRequired();
00035         ~BtHfCmaPhoneNumberRequired();
00036
00037         static const BtHfCmaPhoneNumberRequired& Cast(const StackMsgArgument& arg);
00038         void SetResult(const BtResultCode& result) { m_result = result; }
00039         const BtResultCode& GetResult() const { return m_result; }
00040
00041         enum  {
00042             ID = 0
00043             };
00044
00045     private:
00046
00047         static void Destroy(StackMsgArgument* arg) { delete ((BtHfCmaPhoneNumberRequired*) arg); }
00048
00049         BtResultCode m_result;
00050
00051     };
00052
00053 // Inline definitions
00054 inline const BtHfCmaPhoneNumberRequired& BtHfCmaPhoneNumberRequired::Cast(const StackMsgArgument& arg) {
00055     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfCmaPhoneNumberRequired!\n");
00056     return ((BtHfCmaPhoneNumberRequired &) arg);
00057 }
00058
00059
00060
00061 /*  ======================================================================
00062     Class BtHfCmaMTC
00063     ====================================================================== */
00064
00066 class BtHfCmaMTC : public StackMsgArgument {
00067     friend class BtHfMessageArgumentsDestroyTableNode;
00068     public:
00069         BtHfCmaMTC();
00070         ~BtHfCmaMTC();
00071
00072         static const BtHfCmaMTC& Cast(const StackMsgArgument& arg);
00073
00074         enum  {
00075             ID = 1
00076             };
00077
00078     private:
00079
00080         static void Destroy(StackMsgArgument* arg) { delete ((BtHfCmaMTC*) arg); }
00081
00082     };
00083
00084 // Inline definitions
00085 inline const BtHfCmaMTC& BtHfCmaMTC::Cast(const StackMsgArgument& arg) {
00086     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfCmaMTC!\n");
00087     return ((BtHfCmaMTC &) arg);
00088 }
00089
00090
00091
00092 /*  ======================================================================
00093     Class BtHfCmaMOC
00094     ====================================================================== */
00095
00097 class BtHfCmaMOC : public StackMsgArgument {
00098     friend class BtHfMessageArgumentsDestroyTableNode;
00099     public:
00100         BtHfCmaMOC();
00101         ~BtHfCmaMOC();
00102
00103         static const BtHfCmaMOC& Cast(const StackMsgArgument& arg);
00104
00105         enum  {
00106             ID = 2
00107             };
00108
00109     private:
00110
00111         static void Destroy(StackMsgArgument* arg) { delete ((BtHfCmaMOC*) arg); }
00112
00113     };
00114
00115 // Inline definitions
00116 inline const BtHfCmaMOC& BtHfCmaMOC::Cast(const StackMsgArgument& arg) {
00117     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfCmaMOC!\n");
00118     return ((BtHfCmaMOC &) arg);
00119 }
00120
00121
00122
00123 /*  ======================================================================
00124     Class BtHfCmaAudioAsynchronous
00125     ====================================================================== */
00126
00128 class BtHfCmaAudioAsynchronous : public StackMsgArgument {
00129     friend class BtHfMessageArgumentsDestroyTableNode;
00130     public:
00131         BtHfCmaAudioAsynchronous(BOOLEAN sco_path_status, BOOLEAN audio_connected, BOOLEAN audio_switch_path);
00132         BtHfCmaAudioAsynchronous();
00133         ~BtHfCmaAudioAsynchronous();
00134
00135         static const BtHfCmaAudioAsynchronous& Cast(const StackMsgArgument& arg);
00136         void SetScoPathStatus(BOOLEAN sco_path_status) { m_sco_path_status = sco_path_status; }
00137         BOOLEAN IsScoPathStatus() const { return m_sco_path_status; }
00138         void SetAudioConnected(BOOLEAN audio_connected) { m_audio_connected = audio_connected; }
00139         BOOLEAN IsAudioConnected() const { return m_audio_connected; }
00140         void SetAudioSwitchPath(BOOLEAN audio_switch_path) { m_audio_switch_path = audio_switch_path; }
00141         BOOLEAN IsAudioSwitchPath() const { return m_audio_switch_path; }
00142
00143         enum  {
00144             ID = 3
00145             };
00146
00147     private:
00148
00149         static void Destroy(StackMsgArgument* arg) { delete ((BtHfCmaAudioAsynchronous*) arg); }
00150
00151         BOOLEAN m_sco_path_status;
00152         BOOLEAN m_audio_connected;
00153         BOOLEAN m_audio_switch_path;
00154
00155     };
00156
00157 // Inline definitions
00158 inline const BtHfCmaAudioAsynchronous& BtHfCmaAudioAsynchronous::Cast(const StackMsgArgument& arg) {
00159     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfCmaAudioAsynchronous!\n");
00160     return ((BtHfCmaAudioAsynchronous &) arg);
00161 }
00162
00163
00164
00165 /*  ======================================================================
00166     Class BtHfCmaAtChldOneCommandReceived
00167     ====================================================================== */
00168
00170 class BtHfCmaAtChldOneCommandReceived : public StackMsgArgument {
00171     friend class BtHfMessageArgumentsDestroyTableNode;
00172     public:
00173         BtHfCmaAtChldOneCommandReceived();
00174         ~BtHfCmaAtChldOneCommandReceived();
00175
00176         static const BtHfCmaAtChldOneCommandReceived& Cast(const StackMsgArgument& arg);
00177
00178         enum  {
00179             ID = 4
00180             };
00181
00182     private:
00183
00184         static void Destroy(StackMsgArgument* arg) { delete ((BtHfCmaAtChldOneCommandReceived*) arg); }
00185
00186     };
00187
00188 // Inline definitions
00189 inline const BtHfCmaAtChldOneCommandReceived& BtHfCmaAtChldOneCommandReceived::Cast(const StackMsgArgument& arg) {
00190     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfCmaAtChldOneCommandReceived!\n");
00191     return ((BtHfCmaAtChldOneCommandReceived &) arg);
00192 }
00193
00194
00195
00196 /*  ======================================================================
00197     Class BtHfCmaCheckPendingAudioCallback
00198     ====================================================================== */
00199
00201 class BtHfCmaCheckPendingAudioCallback : public StackMsgArgument {
00202     friend class BtHfMessageArgumentsDestroyTableNode;
00203     public:
00204         BtHfCmaCheckPendingAudioCallback();
00205         ~BtHfCmaCheckPendingAudioCallback();
00206
00207         static const BtHfCmaCheckPendingAudioCallback& Cast(const StackMsgArgument& arg);
00208
00209         enum  {
00210             ID = 5
00211             };
00212
00213     private:
00214
00215         static void Destroy(StackMsgArgument* arg) { delete ((BtHfCmaCheckPendingAudioCallback*) arg); }
00216
00217     };
00218
00219 // Inline definitions
00220 inline const BtHfCmaCheckPendingAudioCallback& BtHfCmaCheckPendingAudioCallback::Cast(const StackMsgArgument& arg) {
00221     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfCmaCheckPendingAudioCallback!\n");
00222     return ((BtHfCmaCheckPendingAudioCallback &) arg);
00223 }
00224
00225
00226 #endif // Bluetooth_HF_BtHfControllerMessageArgument_hpp
00227
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfDisconnectRequest.cpp File Reference

Bluetooth/HF/BtHfDisconnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHfService.hpp"
#include "BtHfController.hpp"
#include "BtHfDisconnectRequest.hpp"

Include dependency graph for BtHfDisconnectRequest.cpp:

Generated on Tue Jan 24 20:08:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfDisconnectRequest.hpp File Reference

Bluetooth/HF/BtHfDisconnectRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfDisonnectRequest_hpp

Define Documentation

#define BtHfDisonnectRequest_hpp

Generated on Tue Jan 24 20:08:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfDisconnectRequest.hpp Source File

Bluetooth/HF/BtHfDisconnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfDisonnectRequest_hpp)
00009 #define BtHfDisonnectRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtDisconnectRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHfService;
00027
00031 class BtHfDisconnectRequest: public BtDisconnectRequest
00032 {
00033     private:
00034         typedef BtDisconnectRequest Base;
00035
00036     public:
00038         BtHfDisconnectRequest(BtHfService& hf_service);
00039
00041         virtual ~BtHfDisconnectRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00048     protected:
00050
00052         virtual BOOLEAN PerformDisconnectControllerCall();
00053 };
00054
00056 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00057 #endif  // BtHfDisonnectRequest_hpp
00058
00059
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfMessageArguments.cpp File Reference

Bluetooth/HF/BtHfMessageArguments.cpp File Reference

#include "PreComp.hpp"
#include "BtHfMessageArguments.hpp"

Include dependency graph for BtHfMessageArguments.cpp:

Generated on Tue Jan 24 20:08:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfMessageArguments.hpp File Reference

Bluetooth/HF/BtHfMessageArguments.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/HF/BtHfControllerMessageArgument.hpp>
#include <Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Include dependency graph for BtHfMessageArguments.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfMessageArgumentsDestroyTableNode

Defines

#define | Bluetooth_BtHfMessageArguments_hpp

Define Documentation

#define Bluetooth_BtHfMessageArguments_hpp

Generated on Tue Jan 24 20:08:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfMessageArguments.hpp Source File

Bluetooth/HF/BtHfMessageArguments.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "pointner_leopard_development_pu_dv\lnz_apoxi\Apoxi\Bluetooth\HF\BtHfControllerMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtHfMessageArguments_hpp)
00016 #define Bluetooth_BtHfMessageArguments_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Bluetooth/HF/BtHfControllerMessageArgument.hpp>
00020 #include <Bluetooth/HF/BtHfNotificationMessageArgument.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtHfMessageArgumentsDestroyTableNode
00029     ====================================================================== */
00030
00031 class BtHfMessageArgumentsDestroyTableNode : public StackMsgArgDestroyTableNode {
00032     public:
00033
00034         static BtHfMessageArgumentsDestroyTableNode* GetInstance();
00035
00036     private:
00037         BtHfMessageArgumentsDestroyTableNode();
00038
00039
00040         static BtHfMessageArgumentsDestroyTableNode* m_node;
00041         static const ArgumentDestroyEntry m_destroy_table[];
00042
00043     };
00044
00045 #endif // Bluetooth_BtHfMessageArguments_hpp
00046
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfNotificationMessage.cpp File Reference

Bluetooth/HF/BtHfNotificationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtHfNotificationMessage.hpp"

Include dependency graph for BtHfNotificationMessage.cpp:

Generated on Tue Jan 24 20:08:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfNotificationMessage.hpp File Reference

Bluetooth/HF/BtHfNotificationMessage.hpp File Reference

#include <Apc/Message.hpp>
#include <Apc/StackMsgArgument.hpp>

Include dependency graph for BtHfNotificationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfNotificationMessage

Defines

#define | BtHfNotificationMessage_hpp

Define Documentation

#define BtHfNotificationMessage_hpp

Generated on Tue Jan 24 20:08:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfNotificationMessage.hpp Source File

Bluetooth/HF/BtHfNotificationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfNotificationMessage_hpp)
00009 #define BtHfNotificationMessage_hpp
00012
00013 #include <Apc/Message.hpp>
00014 #include <Apc/StackMsgArgument.hpp>
00015
00018 class BtHfNotificationMessage: public FromStackMsg
00019 {
00020     private:
00021         typedef FromStackMsg Base;
00022
00023     public:
00025         BtHfNotificationMessage(StackMsgArgument *argument = 0);
00026
00028         BtHfNotificationMessage(const BtHfNotificationMessage &message);
00029
00031         virtual ~BtHfNotificationMessage();
00032
00034
00036         virtual FromStackMsg& operator=(const FromStackMsg &message);
00037
00039
00041         virtual BtHfNotificationMessage& operator=(const BtHfNotificationMessage &message);
00042
00044
00046         virtual const MsgMetaData& GetMetaData() const;
00047
00049
00051         virtual Message* Clone() const;
00052
00053     public:
00054         enum { ID = 10105 };
00055
00056     private:
00058         BtDevice m_device;
00059
00060     private:
00062         static const MsgMetaData m_meta_data;
00063 };
00064
00065 #endif // BtHfNotificationMessage_hpp
00066
00067
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfNotificationMessageArgument.cpp File Reference

Bluetooth/HF/BtHfNotificationMessageArgument.cpp File Reference

#include "PreComp.hpp"
#include "BtHfNotificationMessageArgument.hpp"

Include dependency graph for BtHfNotificationMessageArgument.cpp:

Generated on Tue Jan 24 20:08:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfNotificationMessageArgument.hpp File Reference

Bluetooth/HF/BtHfNotificationMessageArgument.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/HF/BtTypes.hpp>

Include dependency graph for BtHfNotificationMessageArgument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfNmaAudioConnectionLost
class | BtHfNmaCallEvent
class | BtHfNmaConnect
class | BtHfNmaDisconnect
class | BtHfNmaLowPowerModeNotPossible
class | BtHfNmaMicrophoneGain
class | BtHfNmaSpeakerGain
class | BtHfNmaTransferAudioToAccessory
class | BtHfNmaTransferAudioToPhone

Defines

#define | Bluetooth_HF_BtHfNotificationMessageArgument_hpp

Define Documentation

#define Bluetooth_HF_BtHfNotificationMessageArgument_hpp

Generated on Tue Jan 24 20:08:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfNotificationMessageArgument.hpp Source File

Bluetooth/HF/BtHfNotificationMessageArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\HF\BtHfNotificationMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_HF_BtHfNotificationMessageArgument_hpp)
00016 #define Bluetooth_HF_BtHfNotificationMessageArgument_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Bluetooth/BtTypes.hpp>
00020 #include <Bluetooth/HF/BtTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtHfNmaConnect
00029     ====================================================================== */
00030
00032 class BtHfNmaConnect : public StackMsgArgument {
00033     friend class BtHfMessageArgumentsDestroyTableNode;
00034     public:
00035         BtHfNmaConnect(const BtResultCode& result, const BtDevice& device);
00036         BtHfNmaConnect();
00037         ~BtHfNmaConnect();
00038
00039         static const BtHfNmaConnect& Cast(const StackMsgArgument& arg);
00040         const BtResultCode& GetResult() const { return m_result; }
00041         const BtDevice& GetDevice() const { return m_device; }
00042
00043         enum  {
00044             ID = 10
00045             };
00046
00047     private:
00048
00049         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaConnect*) arg); }
00050
00051         BtResultCode m_result;
00052         BtDevice m_device;
00053
00054     };
00055
00056 // Inline definitions
00057 inline const BtHfNmaConnect& BtHfNmaConnect::Cast(const StackMsgArgument& arg) {
00058     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaConnect!\n");
00059     return ((BtHfNmaConnect &) arg);
00060 }
00061
00062
00063
00064 /*  ======================================================================
00065     Class BtHfNmaDisconnect
00066     ====================================================================== */
00067
00069 class BtHfNmaDisconnect : public StackMsgArgument {
00070     friend class BtHfMessageArgumentsDestroyTableNode;
00071     public:
00072         BtHfNmaDisconnect(const BtResultCode& result);
00073         BtHfNmaDisconnect();
00074         ~BtHfNmaDisconnect();
00075
00076         static const BtHfNmaDisconnect& Cast(const StackMsgArgument& arg);
00077         const BtResultCode& GetResult() const { return m_result; }
00078
00079         enum  {
00080             ID = 11
00081             };
00082
00083     private:
00084
00085         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaDisconnect*) arg); }
00086
00087         BtResultCode m_result;
00088
00089     };
00090
00091 // Inline definitions
00092 inline const BtHfNmaDisconnect& BtHfNmaDisconnect::Cast(const StackMsgArgument& arg) {
00093     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaDisconnect!\n");
00094     return ((BtHfNmaDisconnect &) arg);
00095 }
00096
00097
00098
00099 /*  ======================================================================
00100     Class BtHfNmaTransferAudioToAccessory
00101     ====================================================================== */
00102
00104 class BtHfNmaTransferAudioToAccessory : public StackMsgArgument {
00105     friend class BtHfMessageArgumentsDestroyTableNode;
00106     public:
00107         BtHfNmaTransferAudioToAccessory(const BtResultCode& result);
00108         BtHfNmaTransferAudioToAccessory();
00109         ~BtHfNmaTransferAudioToAccessory();
00110
00111         static const BtHfNmaTransferAudioToAccessory& Cast(const StackMsgArgument& arg);
00112         const BtResultCode& GetResult() const { return m_result; }
00113
00114         enum  {
00115             ID = 12
00116             };
00117
00118     private:
00119
00120         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaTransferAudioToAccessory*) arg); }
00121
00122         BtResultCode m_result;
00123
00124     };
00125
00126 // Inline definitions
00127 inline const BtHfNmaTransferAudioToAccessory& BtHfNmaTransferAudioToAccessory::Cast(const StackMsgArgument& arg) {
00128     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaTransferAudioToAccessory!\n");
00129     return ((BtHfNmaTransferAudioToAccessory &) arg);
00130 }
00131
00132
00133
00134 /*  ======================================================================
00135     Class BtHfNmaTransferAudioToPhone
00136     ====================================================================== */
00137
00139 class BtHfNmaTransferAudioToPhone : public StackMsgArgument {
00140     friend class BtHfMessageArgumentsDestroyTableNode;
00141     public:
00142         BtHfNmaTransferAudioToPhone(const BtResultCode& result);
00143         BtHfNmaTransferAudioToPhone();
00144         ~BtHfNmaTransferAudioToPhone();
00145
00146         static const BtHfNmaTransferAudioToPhone& Cast(const StackMsgArgument& arg);
00147         const BtResultCode& GetResult() const { return m_result; }
00148
00149         enum  {
00150             ID = 13
00151             };
00152
00153     private:
00154
00155         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaTransferAudioToPhone*) arg); }
00156
00157         BtResultCode m_result;
00158
00159     };
00160
00161 // Inline definitions
00162 inline const BtHfNmaTransferAudioToPhone& BtHfNmaTransferAudioToPhone::Cast(const StackMsgArgument& arg) {
00163     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaTransferAudioToPhone!\n");
00164     return ((BtHfNmaTransferAudioToPhone &) arg);
00165 }
00166
00167
00168
00169 /*  ======================================================================
00170     Class BtHfNmaAudioConnectionLost
00171     ====================================================================== */
00172
00174 class BtHfNmaAudioConnectionLost : public StackMsgArgument {
00175     friend class BtHfMessageArgumentsDestroyTableNode;
00176     public:
00177         BtHfNmaAudioConnectionLost(const BtResultCode& result);
00178         BtHfNmaAudioConnectionLost();
00179         ~BtHfNmaAudioConnectionLost();
00180
00181         static const BtHfNmaAudioConnectionLost& Cast(const StackMsgArgument& arg);
00182         const BtResultCode& GetResult() const { return m_result; }
00183
00184         enum  {
00185             ID = 14
00186             };
00187
00188     private:
00189
00190         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaAudioConnectionLost*) arg); }
00191
00192         BtResultCode m_result;
00193
00194     };
00195
00196 // Inline definitions
00197 inline const BtHfNmaAudioConnectionLost& BtHfNmaAudioConnectionLost::Cast(const StackMsgArgument& arg) {
00198     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaAudioConnectionLost!\n");
00199     return ((BtHfNmaAudioConnectionLost &) arg);
00200 }
00201
00202
00203
00204 /*  ======================================================================
00205     Class BtHfNmaMicrophoneGain
00206     ====================================================================== */
00207
00209 class BtHfNmaMicrophoneGain : public StackMsgArgument {
00210     friend class BtHfMessageArgumentsDestroyTableNode;
00211     public:
00212         BtHfNmaMicrophoneGain(const BtResultCode& result, UINT8 gain);
00213         BtHfNmaMicrophoneGain();
00214         ~BtHfNmaMicrophoneGain();
00215
00216         static const BtHfNmaMicrophoneGain& Cast(const StackMsgArgument& arg);
00217         const BtResultCode& GetResult() const { return m_result; }
00218         UINT8 GetGain() const { return m_gain; }
00219
00220         enum  {
00221             ID = 15
00222             };
00223
00224     private:
00225
00226         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaMicrophoneGain*) arg); }
00227
00228         BtResultCode m_result;
00229         UINT8 m_gain;
00230
00231     };
00232
00233 // Inline definitions
00234 inline const BtHfNmaMicrophoneGain& BtHfNmaMicrophoneGain::Cast(const StackMsgArgument& arg) {
00235     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaMicrophoneGain!\n");
00236     return ((BtHfNmaMicrophoneGain &) arg);
00237 }
00238
00239
00240
00241 /*  ======================================================================
00242     Class BtHfNmaSpeakerGain
00243     ====================================================================== */
00244
00246 class BtHfNmaSpeakerGain : public StackMsgArgument {
00247     friend class BtHfMessageArgumentsDestroyTableNode;
00248     public:
00249         BtHfNmaSpeakerGain(const BtResultCode& result, UINT8 gain);
00250         BtHfNmaSpeakerGain();
00251         ~BtHfNmaSpeakerGain();
00252
00253         static const BtHfNmaSpeakerGain& Cast(const StackMsgArgument& arg);
00254         const BtResultCode& GetResult() const { return m_result; }
00255         UINT8 GetGain() const { return m_gain; }
00256
00257         enum  {
00258             ID = 16
00259             };
00260
00261     private:
00262
00263         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaSpeakerGain*) arg); }
00264
00265         BtResultCode m_result;
00266         UINT8 m_gain;
00267
00268     };
00269
00270 // Inline definitions
00271 inline const BtHfNmaSpeakerGain& BtHfNmaSpeakerGain::Cast(const StackMsgArgument& arg) {
00272     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaSpeakerGain!\n");
00273     return ((BtHfNmaSpeakerGain &) arg);
00274 }
00275
00276
00277
00278 /*  ======================================================================
00279     Class BtHfNmaLowPowerModeNotPossible
00280     ====================================================================== */
00281
00283 class BtHfNmaLowPowerModeNotPossible : public StackMsgArgument {
00284     friend class BtHfMessageArgumentsDestroyTableNode;
00285     public:
00286         BtHfNmaLowPowerModeNotPossible(const BtResultCode& result);
00287         BtHfNmaLowPowerModeNotPossible();
00288         ~BtHfNmaLowPowerModeNotPossible();
00289
00290         static const BtHfNmaLowPowerModeNotPossible& Cast(const StackMsgArgument& arg);
00291         const BtResultCode& GetResult() const { return m_result; }
00292
00293         enum  {
00294             ID = 17
00295             };
00296
00297     private:
00298
00299         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaLowPowerModeNotPossible*) arg); }
00300
00301         BtResultCode m_result;
00302
00303     };
00304
00305 // Inline definitions
00306 inline const BtHfNmaLowPowerModeNotPossible& BtHfNmaLowPowerModeNotPossible::Cast(const StackMsgArgument& arg) {
00307     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaLowPowerModeNotPossible!\n");
00308     return ((BtHfNmaLowPowerModeNotPossible &) arg);
00309 }
00310
00311
00312
00313 /*  ======================================================================
00314     Class BtHfNmaCallEvent
00315     ====================================================================== */
00316
00318 class BtHfNmaCallEvent : public StackMsgArgument {
00319     friend class BtHfMessageArgumentsDestroyTableNode;
00320     public:
00321         BtHfNmaCallEvent(const BtHfCallEvent& call_event);
00322         BtHfNmaCallEvent();
00323         ~BtHfNmaCallEvent();
00324
00325         static const BtHfNmaCallEvent& Cast(const StackMsgArgument& arg);
00326         const BtHfCallEvent& GetCallEvent() const { return m_call_event; }
00327
00328         enum  {
00329             ID = 18
00330             };
00331
00332     private:
00333
00334         static void Destroy(StackMsgArgument* arg) { delete ((BtHfNmaCallEvent*) arg); }
00335
00336         BtHfCallEvent m_call_event;
00337
00338     };
00339
00340 // Inline definitions
00341 inline const BtHfNmaCallEvent& BtHfNmaCallEvent::Cast(const StackMsgArgument& arg) {
00342     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHfNmaCallEvent!\n");
00343     return ((BtHfNmaCallEvent &) arg);
00344 }
00345
00346
00347 #endif // Bluetooth_HF_BtHfNotificationMessageArgument_hpp
00348
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfRequest.cpp File Reference

Bluetooth/HF/BtHfRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHfRequest.hpp"
#include "BtHfService.hpp"

Include dependency graph for BtHfRequest.cpp:

Generated on Tue Jan 24 20:09:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfRequest.hpp File Reference

Bluetooth/HF/BtHfRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfRequest_hpp

Define Documentation

#define BtHfRequest_hpp

Generated on Tue Jan 24 20:09:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfRequest.hpp Source File

Bluetooth/HF/BtHfRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfRequest_hpp)
00009 #define BtHfRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /*  !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015     The class may not be used by the MMI in a direct
00016     manner and the interface may be changed in future
00017     releases.
00018     !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtServiceRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHfService;
00027
00030 class BtHfRequest: public BtServiceRequest
00031 {
00032     private:
00033         typedef BtServiceRequest Base;
00034
00035     public:
00037         BtHfRequest(BtHfService& hf_service);
00038
00040         virtual ~BtHfRequest();
00041 };
00042
00044 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00045 #endif  // BtHfRequest_hpp
00046
00047
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfService.cpp File Reference

Bluetooth/HF/BtHfService.cpp File Reference

#include "PreComp.hpp"
#include "BtHfControllerMessage.hpp"
#include "BtHfControllerMessageArgument.hpp"
#include "BtHfNotificationMessage.hpp"
#include "BtHfNotificationMessageArgument.hpp"
#include "BtHfServiceMessage.hpp"
#include "BtHfService.hpp"
#include "BtHfController.hpp"

Include dependency graph for BtHfService.cpp:

Defines

#define | DBG_STATE
#define | FEATURE_HF_INBAND_RINGING 0x08

Functions

unsigned | msap_retrieve_brsf (void)

Define Documentation

#define DBG_STATE

#define FEATURE_HF_INBAND_RINGING 0x08

Function Documentation

unsigned msap_retrieve_brsf ( void )

Generated on Tue Jan 24 20:09:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfService.hpp File Reference

Bluetooth/HF/BtHfService.hpp File Reference

#include <Kernel/Application.hpp>
#include <Bluetooth/BtAudioAccessoryService.hpp>
#include <Bluetooth/HF/BtTypes.hpp>
#include <Bluetooth/HF/BtHfControllerMessage.hpp>
#include <Bluetooth/HF/BtHfConnectRequest.hpp>
#include <Bluetooth/HF/BtHfDisconnectRequest.hpp>
#include <Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp>
#include <Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp>
#include <Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp>
#include <Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp>

Include dependency graph for BtHfService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfService
class | BtHfService::BtHfAtChldOneCommand

Defines

#define | BtHfService_hpp

Define Documentation

#define BtHfService_hpp

Generated on Tue Jan 24 20:09:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfService.hpp Source File

Bluetooth/HF/BtHfService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfService_hpp)
00009 #define BtHfService_hpp
00012
00013 #include <Kernel/Application.hpp>
00014 #include <Bluetooth/BtAudioAccessoryService.hpp>
00015 #include <Bluetooth/HF/BtTypes.hpp>
00016 #include <Bluetooth/HF/BtHfControllerMessage.hpp>
00017 #include <Bluetooth/HF/BtHfConnectRequest.hpp>
00018 #include <Bluetooth/HF/BtHfDisconnectRequest.hpp>
00019 #include <Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp>
00020 #include <Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp>
00021 #include <Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp>
00022 #include <Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp>
00023
00030 class BtHfService: public BtAudioAccessoryService
00031 {
00032     private:
00033         typedef BtAudioAccessoryService Base;
00034
00035     public:
00037         BtHfService();
00038
00040         virtual ~BtHfService();
00041
00043
00046         virtual void Init();
00047
00049
00053         virtual BtProfile GetProfile() const;
00054
00056
00058         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00059
00061
00068         virtual void SetTargetDevice(const BtDevice& target_device);
00069
00071
00080         virtual BOOLEAN IsConnected() const;
00081
00083
00085         virtual void SetUseInbandRinging(BOOLEAN use_inband_ringing);
00086
00088
00090         virtual BOOLEAN IsRinging() const;
00091
00093
00095         virtual BOOLEAN IsInCall() const;
00096
00098
00105         virtual BtRequestState ConnectRequest();
00106
00108
00116         virtual BtRequestState DisconnectRequest();
00117
00119
00121         virtual BtRequestState TransferAudioToPhoneRequest();
00122
00124
00126         virtual BtRequestState TransferAudioToAccessoryRequest();
00127
00129
00131         virtual UINT8 GetMicrophoneGain() const;
00132
00134
00136         virtual BtRequestState SetMicrophoneGainRequest(INT8 gain_offset);
00137
00139
00141         virtual UINT8 GetSpeakerGain() const;
00142
00144
00146         virtual BtRequestState SetSpeakerGainRequest(INT8 gain_offset);
00147
00149
00151         UINT16 GetSupportedFeatures() const;
00152
00154
00156         BtHfState GetState() const;
00157
00158     protected:
00160
00162         virtual void RegisterMessages() const;
00163
00165
00167         virtual void UnregisterMessages() const;
00168
00170
00172         virtual BOOLEAN OnMessage(const Message& message);
00173
00175
00177         virtual BOOLEAN OnCallEventMessage(const CallEventMsg& call_event_message);
00178
00180
00182         BOOLEAN OnControllerMessage(const BtHfControllerMessage& controller_message);
00183
00184     private:
00186
00188         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00189
00191
00193         virtual void OnPhoneNumberRequired(BtResultCode result) = 0;
00194
00196
00198         void TryAudioRequest(BtRequest* audio_request);
00199
00201
00203         void CheckPendingAudioRequest();
00204
00205     private:
00207
00209         class BtHfAtChldOneCommand
00210         {
00211             public:
00213                 typedef enum {
00215                     BtHfAcocStopped,
00217                     BtHfAcocWaitingForRelease,
00219                     BtHfAcocWaitingForEstablishment
00220                 } BtHfAtChldOneCommandState;
00221
00222             public:
00224                 BtHfAtChldOneCommand();
00225
00227                 virtual ~BtHfAtChldOneCommand();
00228
00229             public:
00231
00233                 void Start();
00234
00236
00238                 void Stop();
00239
00241
00243                 void Step();
00244
00246
00248                 BOOLEAN IsRunning() const;
00249
00251
00253                 BOOLEAN IsRightCallEvent(StackMsgArgId id) const;
00254
00256
00258                 BtHfCallLocation GetCallLocation() const;
00259
00261
00263                 void SetCallLocation(BtHfCallLocation call_location);
00264
00266
00268                 BtHfAtChldOneCommandState GetState() const;
00269
00270             private:
00272                 BtHfAtChldOneCommandState m_state;
00273
00275                 BtHfCallLocation m_call_location;
00276         };
00277
00278 #ifdef _DEBUG
00279     private:
00281
00283         const char* BtHfRequestAsString(BtRequest* request);
00284
00286
00288         void DebugState();
00289 #endif /* _DEBUG */
00290
00291     private:
00293         Application* m_owner;
00294
00296         Semaphore m_audio_request_pending_semaphore;
00297
00299         BtRequest* m_pending_audio_request;
00300
00302         BtHfAtChldOneCommand m_at_chld_one_command;
00303
00305         BtHfConnectRequest m_connect_request;
00306
00308         BtHfDisconnectRequest m_disconnect_request;
00309
00311         BtHfTransferAudioToPhoneRequest m_transfer_audio_to_phone_request;
00312
00314         BtHfTransferAudioToPhoneRequest m_transfer_audio_to_phone_request_intern;
00315
00317         BtHfTransferAudioToAccessoryRequest m_transfer_audio_to_accessory_request;
00318
00320         BtHfTransferAudioToAccessoryRequest m_transfer_audio_to_accessory_request_intern;
00321
00323         BtHfSetMicrophoneGainRequest m_set_microphone_gain_request;
00324
00326         BtHfSetSpeakerGainRequest m_set_speaker_gain_request;
00327 };
00328
00330 #endif  // BtHfService_hpp
00331
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfServiceMessage.cpp File Reference

Bluetooth/HF/BtHfServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtHfServiceMessage.hpp"

Include dependency graph for BtHfServiceMessage.cpp:

Generated on Tue Jan 24 20:09:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfServiceMessage.hpp File Reference

Bluetooth/HF/BtHfServiceMessage.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtHfServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfRequestStateChangedMessage

Defines

#define | Bluetooth_BtHfServiceMessage_hpp

Define Documentation

#define Bluetooth_BtHfServiceMessage_hpp

Generated on Tue Jan 24 20:09:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfServiceMessage.hpp Source File

Bluetooth/HF/BtHfServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\HF\BtHfServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtHfServiceMessage_hpp)
00016 #define Bluetooth_BtHfServiceMessage_hpp
00017
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtHfRequestStateChangedMessage
00027     ====================================================================== */
00028
00030 class BtHfRequestStateChangedMessage : public BtRequestStateChangedMessage {
00031     public:
00032         BtHfRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00033         virtual ~BtHfRequestStateChangedMessage();
00034
00035         virtual const MsgMetaData& GetMetaData() const;
00036         virtual Message* Clone() const;
00037
00038         enum  {
00039             ID = 10330
00040             };
00041
00042     private:
00043         static const MsgMetaData m_meta_data;
00044
00045     };
00046
00047 #endif // Bluetooth_BtHfServiceMessage_hpp
00048
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfSetMicrophoneGainRequest.cpp File Reference

Bluetooth/HF/BtHfSetMicrophoneGainRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHfService.hpp"
#include "BtHfController.hpp"
#include "BtHfSetMicrophoneGainRequest.hpp"

Include dependency graph for BtHfSetMicrophoneGainRequest.cpp:

Generated on Tue Jan 24 20:09:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp File Reference

Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfSetMicrophoneGainRequest_hpp

Define Documentation

#define BtHfSetMicrophoneGainRequest_hpp

Generated on Tue Jan 24 20:09:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp Source File

Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfSetMicrophoneGainRequest_hpp)
00009 #define BtHfSetMicrophoneGainRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HF/BtHfRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHfController;
00027 class BtHfService;
00028
00031 class BtHfSetMicrophoneGainRequest: public BtHfRequest
00032 {
00033     private:
00034         typedef BtHfRequest Base;
00035
00036     public:
00038         BtHfSetMicrophoneGainRequest(BtHfService& hf_service);
00039
00041         virtual ~BtHfSetMicrophoneGainRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00049
00051         UINT8 GetMicrophoneGain() const;
00052
00054
00056         void SetMicrophoneGain(UINT8 mircophone_gain);
00057
00058     protected:
00060
00062         virtual BOOLEAN Execute();
00063
00064     private:
00066
00068         btapi_u8_t GetApiSettings() const;
00069
00070     private:
00072         btapi_u8_t m_microphone_gain;
00073
00074     private:
00075         friend class BtHfController;
00076         friend class BtHfService;
00077 };
00078
00080 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00081 #endif  // BtHfSetMicrophoneGainRequest_hpp
00082
00083
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfSetSpeakerGainRequest.cpp File Reference

Bluetooth/HF/BtHfSetSpeakerGainRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHfService.hpp"
#include "BtHfController.hpp"
#include "BtHfSetSpeakerGainRequest.hpp"

Include dependency graph for BtHfSetSpeakerGainRequest.cpp:

Generated on Tue Jan 24 20:10:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp File Reference

Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfSetSpeakerGainRequest_hpp

Define Documentation

#define BtHfSetSpeakerGainRequest_hpp

Generated on Tue Jan 24 20:10:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp Source File

Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfSetSpeakerGainRequest_hpp)
00009 #define BtHfSetSpeakerGainRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HF/BtHfRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHfController;
00027 class BtHfService;
00028
00031 class BtHfSetSpeakerGainRequest: public BtHfRequest
00032 {
00033     private:
00034         typedef BtHfRequest Base;
00035
00036     public:
00038         BtHfSetSpeakerGainRequest(BtHfService& hf_service);
00039
00041         virtual ~BtHfSetSpeakerGainRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00049
00051         UINT8 GetSpeakerGain() const;
00052
00054
00056         void SetSpeakerGain(UINT8 speaker_gain);
00057
00058     protected:
00060
00062         virtual BOOLEAN Execute();
00063
00064     private:
00066
00068         btapi_u8_t GetApiSettings() const;
00069
00070     private:
00072         btapi_u8_t m_speaker_gain;
00073
00074     private:
00075         friend class BtHfController;
00076         friend class BtHfService;
00077 };
00078
00080 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00081 #endif  // BtHfSetSpeakerGainRequest_hpp
00082
00083
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.cpp File Reference

Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHfService.hpp"
#include "BtHfController.hpp"
#include "BtHfTransferAudioToAccessoryRequest.hpp"

Include dependency graph for BtHfTransferAudioToAccessoryRequest.cpp:

Generated on Tue Jan 24 20:10:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp File Reference

Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfTransferAudioToAccessoryRequest_hpp

Define Documentation

#define BtHfTransferAudioToAccessoryRequest_hpp

Generated on Tue Jan 24 20:10:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp Source File

Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfTransferAudioToAccessoryRequest_hpp)
00009 #define BtHfTransferAudioToAccessoryRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HF/BtHfRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHfController;
00027 class BtHfService;
00028
00031 class BtHfTransferAudioToAccessoryRequest: public BtHfRequest
00032 {
00033     private:
00034         typedef BtHfRequest Base;
00035
00036     public:
00038         BtHfTransferAudioToAccessoryRequest(BtHfService& hf_service);
00039
00041         virtual ~BtHfTransferAudioToAccessoryRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00048     protected:
00050
00052         virtual BOOLEAN Execute();
00053
00054     private:
00056
00058         btapi_bool_t GetApiSettings() const;
00059
00061
00063         BOOLEAN GetIsSynchronizationRequest() const;
00064
00066
00068         void SetIsSynchronizationRequest(BOOLEAN is_synchronization_request);
00069
00070     private:
00072
00074         BOOLEAN m_is_synchronization_request;
00075
00076     private:
00077         friend class BtHfController;
00078         friend class BtHfService;
00079 };
00080
00082 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00083 #endif  // BtHfTransferAudioToAccessoryRequest_hpp
00084
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfTransferAudioToPhoneRequest.cpp File Reference

Bluetooth/HF/BtHfTransferAudioToPhoneRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHfService.hpp"
#include "BtHfController.hpp"
#include "BtHfTransferAudioToPhoneRequest.hpp"

Include dependency graph for BtHfTransferAudioToPhoneRequest.cpp:

Generated on Tue Jan 24 20:10:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp File Reference

Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHfTransferAudioToPhoneRequest_hpp

Define Documentation

#define BtHfTransferAudioToPhoneRequest_hpp

Generated on Tue Jan 24 20:10:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp Source File

Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfTransferAudioToPhoneRequest_hpp)
00009 #define BtHfTransferAudioToPhoneRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HF/BtHfRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHfController;
00027 class BtHfService;
00028
00031 class BtHfTransferAudioToPhoneRequest: public BtHfRequest
00032 {
00033     private:
00034         typedef BtHfRequest Base;
00035
00036     public:
00038         BtHfTransferAudioToPhoneRequest(BtHfService& hf_service);
00039
00041         virtual ~BtHfTransferAudioToPhoneRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00048     protected:
00050
00052         virtual BOOLEAN Execute();
00053
00054     private:
00056
00058         btapi_bool_t GetApiSettings() const;
00059
00061
00063         BOOLEAN GetIsSynchronizationRequest() const;
00064
00066
00068         void SetIsSynchronizationRequest(BOOLEAN is_synchronization_request);
00069
00070     private:
00072
00074         BOOLEAN m_is_synchronization_request;
00075
00076     private:
00077         friend class BtHfController;
00078         friend class BtHfService;
00079 };
00080
00082 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00083 #endif  // BtHfTransferAudioToPhoneRequest_hpp
00084
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtTypes.hpp File Reference

Bluetooth/HF/BtTypes.hpp File Reference

#include <stack/extensions.h>
#include <Kernel/Types.hpp>

Include dependency graph for BtTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Bt_Hf_Types_hpp

Enumerations

enum | BtHfCallEvent { BtHfCe }
enum | BtHfCallLocation { BtHfClNoCall, BtHfClCallOnPhone, BtHfClCallOnAccessory }
enum | BtHfState { BtHfsNotConnected, BtHfsConnected, BtHfsAvailableForAudio, BtHfsAudioActive }

Define Documentation

#define Bt_Hf_Types_hpp

Generated on Tue Jan 24 19:57:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/BtTypes.hpp Source File

Bluetooth/HF/BtTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bt_Hf_Types_hpp)
00009 #define Bt_Hf_Types_hpp
00012
00013 #include <stack/extensions.h>
00014 #include <Kernel/Types.hpp>
00015
00016 /*****************************************************************************
00017  * Bluetooth HF definitions                                                  *
00018  *****************************************************************************
00019
00020  *---------------------------------------------------------------------------*
00021  * Bluetooth HF constants                                                    *
00022  *---------------------------------------------------------------------------*/
00023
00024 /*---------------------------------------------------------------------------*
00025  * Bluetooth HF enums                                                        *
00026  *---------------------------------------------------------------------------*/
00027
00028 typedef enum{
00030     BtHfsNotConnected,
00032     BtHfsConnected,
00034     BtHfsAvailableForAudio,
00036     BtHfsAudioActive
00037 } BtHfState;
00038
00039 typedef enum {
00041     BtHfCe
00042 } BtHfCallEvent;
00043
00044 typedef enum {
00046     BtHfClNoCall,
00048     BtHfClCallOnPhone,
00050     BtHfClCallOnAccessory
00051 } BtHfCallLocation;
00052
00053 /*---------------------------------------------------------------------------*
00054  * Bluetooth HF types                                                        *
00055  *---------------------------------------------------------------------------*/
00056
00058 #endif // Bt_Hf_Types_hpp
00059
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/Lib.hpp File Reference

Bluetooth/HF/Lib.hpp File Reference

#include <Bluetooth/HF/BtTypes.hpp>
#include <Bluetooth/HF/BtHfControllerMessage.hpp>
#include <Bluetooth/HF/BtHfNotificationMessage.hpp>
#include <Bluetooth/HF/BtHfServiceMessage.hpp>
#include <Bluetooth/HF/BtHfMessageArguments.hpp>
#include <Bluetooth/HF/BtHfControllerMessageArgument.hpp>
#include <Bluetooth/HF/BtHfNotificationMessageArgument.hpp>
#include <Bluetooth/HF/BtHfController.hpp>
#include <Bluetooth/HF/BtHfService.hpp>
#include <Bluetooth/HF/BtHfRequest.hpp>
#include <Bluetooth/HF/BtHfConnectRequest.hpp>
#include <Bluetooth/HF/BtHfDisconnectRequest.hpp>
#include <Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp>
#include <Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp>
#include <Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp>
#include <Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp>

Include dependency graph for Lib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Bluetooth_Hf_Lib_hpp

Define Documentation

#define Bluetooth_Hf_Lib_hpp

Generated on Tue Jan 24 14:54:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/Lib.hpp Source File

Bluetooth/HF/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bluetooth_Hf_Lib_hpp)
00009 #define Bluetooth_Hf_Lib_hpp
00012
00013 #include <Bluetooth/HF/BtTypes.hpp>
00014 #include <Bluetooth/HF/BtHfControllerMessage.hpp>
00015 #include <Bluetooth/HF/BtHfNotificationMessage.hpp>
00016 #include <Bluetooth/HF/BtHfServiceMessage.hpp>
00017 #include <Bluetooth/HF/BtHfMessageArguments.hpp>
00018 #include <Bluetooth/HF/BtHfControllerMessageArgument.hpp>
00019 #include <Bluetooth/HF/BtHfNotificationMessageArgument.hpp>
00020 #include <Bluetooth/HF/BtHfController.hpp>
00021 #include <Bluetooth/HF/BtHfService.hpp>
00022 #include <Bluetooth/HF/BtHfRequest.hpp>
00023 #include <Bluetooth/HF/BtHfConnectRequest.hpp>
00024 #include <Bluetooth/HF/BtHfDisconnectRequest.hpp>
00025 #include <Bluetooth/HF/BtHfTransferAudioToAccessoryRequest.hpp>
00026 #include <Bluetooth/HF/BtHfTransferAudioToPhoneRequest.hpp>
00027 #include <Bluetooth/HF/BtHfSetMicrophoneGainRequest.hpp>
00028 #include <Bluetooth/HF/BtHfSetSpeakerGainRequest.hpp>
00029
00031 #endif /* Bluetooth_Hf_Lib_hpp */
00032
Generated on Tue Jan 24 14:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/PreComp.cpp File Reference

Bluetooth/HF/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:58:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/PreComp.hpp File Reference

Bluetooth/HF/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Devices/AudioAccessoryDetails.hpp>
#include <Devices/AudioAccessoryStore.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:19:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HF/PreComp.hpp Source File

Bluetooth/HF/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Asc/Lib.hpp>
00011 #include <Devices/AudioAccessoryDetails.hpp>
00012 #include <Devices/AudioAccessoryStore.hpp>
00013 #include <Bluetooth/Lib.hpp>
00014
00015
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsConnectRequest.cpp File Reference

Bluetooth/HS/BtHsConnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"
#include "BtHsConnectRequest.hpp"

Include dependency graph for BtHsConnectRequest.cpp:

Generated on Tue Jan 24 20:10:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsConnectRequest.hpp File Reference

Bluetooth/HS/BtHsConnectRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsConnectRequest_hpp

Define Documentation

#define BtHsConnectRequest_hpp

Generated on Tue Jan 24 20:10:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsConnectRequest.hpp Source File

Bluetooth/HS/BtHsConnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsConnectRequest_hpp)
00009 #define BtHsConnectRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtConnectRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHsService;
00027
00030 class BtHsConnectRequest: public BtConnectRequest
00031 {
00032     private:
00033         typedef BtConnectRequest Base;
00034
00035     public:
00037         BtHsConnectRequest(BtHsService& hs_service);
00038
00040         virtual ~BtHsConnectRequest();
00041
00043
00045         virtual BtRequestType GetRequestType() const;
00046
00047     protected:
00049
00051         virtual BOOLEAN PerformConnectControllerCall();
00052 };
00053
00055 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00056 #endif  // BtHsConnectRequest_hpp
00057
00058
Generated on Tue Jan 24 14:49:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsController.cpp File Reference

Bluetooth/HS/BtHsController.cpp File Reference

#include "PreComp.hpp"
#include "BtHsControllerMessage.hpp"
#include "BtHsControllerMessageArgument.hpp"
#include "BtHsNotificationMessage.hpp"
#include "BtHsNotificationMessageArgument.hpp"
#include "BtHsConnectRequest.hpp"
#include "BtHsDisconnectRequest.hpp"
#include "BtHsRingRequest.hpp"
#include "BtHsStopRingRequest.hpp"
#include "BtHsTransferAudioToPhoneRequest.hpp"
#include "BtHsTransferAudioToAccessoryRequest.hpp"
#include "BtHsSetMicrophoneGainRequest.hpp"
#include "BtHsSetSpeakerGainRequest.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"

Include dependency graph for BtHsController.cpp:

Defines

#define | DBG_STATE
#define | DBG_STATE_STATIC

Define Documentation

#define DBG_STATE

#define DBG_STATE_STATIC

Generated on Tue Jan 24 20:10:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsController.hpp File Reference

Bluetooth/HS/BtHsController.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsController_hpp

Define Documentation

#define BtHsController_hpp

Generated on Tue Jan 24 20:10:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsController.hpp Source File

Bluetooth/HS/BtHsController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsController_hpp)
00009 #define BtHsController_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <stack/extensions.h>
00021 #include <Devices/AudioAccessoryDetails.hpp>
00022 #include <Bluetooth/BtServiceRequest.hpp>
00023 #include <Bluetooth/BtSingleConnectionController.hpp>
00024 #include <Bluetooth/HS/BtTypes.hpp>
00025
00026 /*  ------------------------------------------------------------------------
00027     Forward deklarations for friend relationships.
00028     ------------------------------------------------------------------------ */
00029
00030 class BtHsService;
00031 class BtHsConnectRequest;
00032 class BtHsDisconnectRequest;
00033 class BtHsRingRequest;
00034 class BtHsStopRingRequest;
00035 class BtHsTransferAudioToPhoneRequest;
00036 class BtHsTransferAudioToAccessoryRequest;
00037 class BtHsSetMicrophoneGainRequest;
00038 class BtHsSetSpeakerGainRequest;
00039
00043 class BtHsController : public BtSingleConnectionController
00044 {
00045     private:
00046         typedef BtSingleConnectionController Base;
00047
00048     public:
00050
00055         static BtHsController& GetInstance();
00056
00057     public:
00059         virtual ~BtHsController();
00060
00062
00064         virtual const WCHAR* GetName() const;
00065
00066     protected:
00068
00070         BOOLEAN HsRingRequest(BtHsRingRequest* ring_request);
00071
00073
00075         BOOLEAN HsStopRingRequest(BtHsStopRingRequest* stop_ring_request);
00076
00078
00080         BOOLEAN HsTransferAudioToPhoneRequest(BtHsTransferAudioToPhoneRequest* transfer_audio_to_phone_request);
00081
00083
00085         BOOLEAN HsTransferAudioToAccessoryRequest(BtHsTransferAudioToAccessoryRequest* transfer_audio_to_accessory_request);
00086
00088
00090         BOOLEAN HsSetMicrophoneGainRequest(BtHsSetMicrophoneGainRequest* set_microphone_gain_request);
00091
00093
00095         BOOLEAN HsSetSpeakerGainRequest(BtHsSetSpeakerGainRequest* set_speaker_gain_request);
00096
00098
00100         BtHsState GetState(const BtDevice& device) const;
00101
00103
00105         BOOLEAN GetIsRinging(const BtDevice& device) const;
00106
00108
00110         void SetIsRinging(const BtDevice& device, BOOLEAN is_ringing);
00111
00113
00115         BtHsCallLocation GetCallLocation(const BtDevice& device) const;
00116
00118
00120         void SetCallLocation(const BtDevice& device, BtHsCallLocation call_location);
00121
00123
00125         UINT8 GetMicrophoneGain(const BtDevice& device) const;
00126
00128
00130         UINT8 GetSpeakerGain(const BtDevice& device) const;
00131
00133
00135         BOOLEAN GetLowPowerModePossible() const;
00136
00138
00140         const BtDevice& GetLastConnectedDevice() const;
00141
00143
00145         void SetLastConnectedDevice(const BtDevice& last_connected_device);
00146
00147     private:
00148         /*---------------------------------------------------------------------*/
00149         /* The following functions must not be called by an application.       */
00150         /* They are the entry point from the stack callback functions into our */
00151         /* object orientated framework (APOXI).                                */
00152         /* They are implemented as static because they have to be passed as    */
00153         /* normal C function pointers. The reason for this is the BT-API Stack */
00154         /* interface that demands C function pointers for callback the         */
00155         /* callback functions it calls to state the progress of ongoing        */
00156         /* operations                                                          */
00157         /*---------------------------------------------------------------------*/
00158
00160
00163         static void OnHsCommonCallback(btapi_result_t result,btapi_common_hscb_t type);
00164
00166
00168         void OnHsRing(BtResultCode result);
00169
00171
00173         void OnHsStopRing(BtResultCode result);
00174
00176
00178         void OnHsAudioConnectionLost(BtResultCode result);
00179
00181
00183         void OnHsLowPowerModeNotPosssible(BtResultCode result);
00184
00186
00189         static void OnHsConnectCallback(btapi_result_t result, btapi_bdaddr_t api_device_address);
00190
00192
00194         void OnHsConnect(BtResultCode result, BtDeviceAddress& device_address);
00195
00197
00199         static void OnHsDisconnectCallback(btapi_result_t result, btapi_bdaddr_t api_device_address);
00200
00202
00204         void OnHsDisconnect(BtResultCode result);
00205
00207
00209         static void OnHsAudioCallback(btapi_result_t result, btapi_bool_t is_audio_at_phone);
00210
00212
00214         void OnHsAudio(BtResultCode result, BOOLEAN is_audio_at_phone);
00215
00217
00219         void OnHsTransferAudioToPhoneRequest(BtHsTransferAudioToPhoneRequest* request, BtResultCode result, BOOLEAN is_audio_at_phone);
00220
00222
00224         void OnHsTransferAudioToAccessoryRequest(BtHsTransferAudioToAccessoryRequest* request, BtResultCode result, BOOLEAN is_audio_at_phone);
00225
00227
00229         void OnHsTransferAudio(BtResultCode result, BOOLEAN is_audio_at_phone);
00230
00232
00235         static void OnHsMicrophoneGainCallback(btapi_result_t result, btapi_u8_t gain);
00236
00238
00240         void OnHsMicrophoneGain(BtResultCode result, UINT8 microphone_gain);
00241
00243
00246         static void OnHsSpeakerGainCallback(btapi_result_t result, btapi_u8_t gain);
00247
00249
00251         void OnHsSpeakerGain(BtResultCode result, UINT8 speaker_gain);
00252
00254
00256         void OnAudioPathConnected(BOOLEAN connected, BOOLEAN update_path);
00257
00258     private:
00260         BtHsController();
00261
00263
00265         virtual void Register();
00266
00268
00270         virtual void Unregister();
00271
00273
00275         void SetState(BtHsState state);
00276
00278
00280         void SetMicrophoneGain(UINT8 microphone_gain);
00281
00283
00285         void SetSpeakerGain(UINT8 speaker_gain);
00286
00288
00290         void SetLowPowerModePossible(BOOLEAN low_power_mode_possible);
00291
00293
00295         BOOLEAN SwitchAudio(BOOLEAN connected, BOOLEAN switch_path);
00296
00298
00300         void SetRunningAudioSetConnected(BOOLEAN running, BOOLEAN connected, BOOLEAN switch_path);
00301
00303
00305         void SetPendingAudioCallback(BOOLEAN pending, BOOLEAN connected, BOOLEAN switch_path);
00306
00308
00310         void CheckPendingAudioCallback();
00311
00312     private:
00313         class BtHsAudioAccessoryDetails: public AudioAccessoryDetails
00314         {
00315             private:
00316                 typedef AudioAccessoryDetails Base;
00317
00318             public:
00320                 BtHsAudioAccessoryDetails();
00321
00323
00325                 virtual void OnAudioPathConnected(BOOLEAN connected, BOOLEAN update_path);
00326         };  // BtHsAudioAccessoryDetails
00327
00328 #ifdef _DEBUG
00329     private:
00331
00333         void DebugState();
00334 #endif /* _DEBUG */
00335
00336     private:
00338         btapi_hscb_funp_t* m_hs_callback_functions;
00339
00341         BtHsState m_hs_state;
00342
00344         BOOLEAN m_is_ringing;
00345
00347         BtHsCallLocation m_call_location;
00348
00350         BOOLEAN m_low_power_mode_possible;
00351
00353         BtDevice m_last_connected_device;
00354
00356         UINT8 m_microphone_gain;
00357
00359         UINT8 m_speaker_gain;
00360
00362         BOOLEAN m_in_audio_switch;
00363
00365         BtHsAudioAccessoryDetails m_audio_accessory_details;
00366
00368         Semaphore m_audio_callback_pending_semaphore;
00369
00371         BOOLEAN m_audio_set_connected_running;
00372
00374         BOOLEAN m_audio_set_connected_connected;
00375
00377         BOOLEAN m_audio_set_connected_switch_path;
00378
00380         BOOLEAN m_audio_callback_pending;
00381
00383         BOOLEAN m_audio_callback_connected;
00384
00386         BOOLEAN m_audio_callback_switch_path;
00387
00388     private:
00390         static BtHsController m_controller;
00391
00392     private:
00393         friend class BtHsController::BtHsAudioAccessoryDetails;
00394
00395     private:
00396         friend class BtHsService;
00397         friend class BtHsConnectRequest;
00398         friend class BtHsDisconnectRequest;
00399         friend class BtHsRingRequest;
00400         friend class BtHsStopRingRequest;
00401         friend class BtHsTransferAudioToPhoneRequest;
00402         friend class BtHsTransferAudioToAccessoryRequest;
00403         friend class BtHsSetMicrophoneGainRequest;
00404         friend class BtHsSetSpeakerGainRequest;
00405 };
00406
00408 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00409 #endif  // BtHsController_hpp
00410
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsControllerMessage.cpp File Reference

Bluetooth/HS/BtHsControllerMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtHsControllerMessage.hpp"

Include dependency graph for BtHsControllerMessage.cpp:

Generated on Tue Jan 24 20:11:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsControllerMessage.hpp File Reference

Bluetooth/HS/BtHsControllerMessage.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsControllerMessage_hpp

Define Documentation

#define BtHsControllerMessage_hpp

Generated on Tue Jan 24 20:11:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsControllerMessage.hpp Source File

Bluetooth/HS/BtHsControllerMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsControllerMessage_hpp)
00009 #define BtHsControllerMessage_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Apc/Message.hpp>
00021 #include <Apc/StackMsgArgument.hpp>
00022
00025 class BtHsControllerMessage: public FromStackMsg
00026 {
00027     private:
00028         typedef FromStackMsg Base;
00029
00030     public:
00032         BtHsControllerMessage(const BtDevice& device = bt_c_unknown_device, StackMsgArgument *argument = 0);
00033
00035         BtHsControllerMessage(const BtHsControllerMessage &message);
00036
00038         virtual ~BtHsControllerMessage();
00039
00041
00043         const BtDevice& GetDevice() const;
00044
00046
00048         virtual FromStackMsg& operator=(const FromStackMsg &message);
00049
00051
00053         virtual BtHsControllerMessage& operator=(const BtHsControllerMessage &message);
00054
00056
00058         virtual const MsgMetaData& GetMetaData() const;
00059
00061
00063         virtual Message* Clone() const;
00064
00065     public:
00066         enum { ID = 10404 };
00067
00068     private:
00070         BtDevice m_device;
00071
00072     private:
00074         static const MsgMetaData m_meta_data;
00075 };
00076
00078 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00079 #endif // BtHsControllerMessage_hpp
00080
00081
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsControllerMessageArgument.cpp File Reference

Bluetooth/HS/BtHsControllerMessageArgument.cpp File Reference

#include "PreComp.hpp"
#include "BtHsControllerMessageArgument.hpp"

Include dependency graph for BtHsControllerMessageArgument.cpp:

Generated on Tue Jan 24 20:11:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsControllerMessageArgument.hpp File Reference

Bluetooth/HS/BtHsControllerMessageArgument.hpp File Reference

#include <Apc/StackMsgArgument.hpp>

Include dependency graph for BtHsControllerMessageArgument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsCmaAudioAsynchronous
class | BtHsCmaAudioTransferOutOfCall
class | BtHsCmaCheckPendingAudioCallback
class | BtHsCmaEnterLowPowerMode
class | BtHsCmaHangUp

Defines

#define | Bluetooth_HS_BtHsControllerMessageArgument_hpp

Define Documentation

#define Bluetooth_HS_BtHsControllerMessageArgument_hpp

Generated on Tue Jan 24 20:11:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsControllerMessageArgument.hpp Source File

Bluetooth/HS/BtHsControllerMessageArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "pointner_leopard_development_pu_dv\lnz_apoxi\Apoxi\Bluetooth\HS\BtHsControllerMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_HS_BtHsControllerMessageArgument_hpp)
00016 #define Bluetooth_HS_BtHsControllerMessageArgument_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtHsCmaHangUp
00027     ====================================================================== */
00028
00030 class BtHsCmaHangUp : public StackMsgArgument {
00031     friend class BtHsMessageArgumentsDestroyTableNode;
00032     public:
00033         BtHsCmaHangUp();
00034         ~BtHsCmaHangUp();
00035
00036         static const BtHsCmaHangUp& Cast(const StackMsgArgument& arg);
00037
00038         enum  {
00039             ID = 1
00040             };
00041
00042     private:
00043
00044         static void Destroy(StackMsgArgument* arg) { delete ((BtHsCmaHangUp*) arg); }
00045
00046     };
00047
00048 // Inline definitions
00049 inline const BtHsCmaHangUp& BtHsCmaHangUp::Cast(const StackMsgArgument& arg) {
00050     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsCmaHangUp!\n");
00051     return ((BtHsCmaHangUp &) arg);
00052 }
00053
00054
00055
00056 /*  ======================================================================
00057     Class BtHsCmaAudioAsynchronous
00058     ====================================================================== */
00059
00061 class BtHsCmaAudioAsynchronous : public StackMsgArgument {
00062     friend class BtHsMessageArgumentsDestroyTableNode;
00063     public:
00064         BtHsCmaAudioAsynchronous(BOOLEAN sco_path_status, BOOLEAN audio_connected, BOOLEAN audio_switch_path);
00065         BtHsCmaAudioAsynchronous();
00066         ~BtHsCmaAudioAsynchronous();
00067
00068         static const BtHsCmaAudioAsynchronous& Cast(const StackMsgArgument& arg);
00069         void SetScoPathStatus(BOOLEAN sco_path_status) { m_sco_path_status = sco_path_status; }
00070         BOOLEAN IsScoPathStatus() const { return m_sco_path_status; }
00071         void SetAudioConnected(BOOLEAN audio_connected) { m_audio_connected = audio_connected; }
00072         BOOLEAN IsAudioConnected() const { return m_audio_connected; }
00073         void SetAudioSwitchPath(BOOLEAN audio_switch_path) { m_audio_switch_path = audio_switch_path; }
00074         BOOLEAN IsAudioSwitchPath() const { return m_audio_switch_path; }
00075
00076         enum  {
00077             ID = 2
00078             };
00079
00080     private:
00081
00082         static void Destroy(StackMsgArgument* arg) { delete ((BtHsCmaAudioAsynchronous*) arg); }
00083
00084         BOOLEAN m_sco_path_status;
00085         BOOLEAN m_audio_connected;
00086         BOOLEAN m_audio_switch_path;
00087
00088     };
00089
00090 // Inline definitions
00091 inline const BtHsCmaAudioAsynchronous& BtHsCmaAudioAsynchronous::Cast(const StackMsgArgument& arg) {
00092     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsCmaAudioAsynchronous!\n");
00093     return ((BtHsCmaAudioAsynchronous &) arg);
00094 }
00095
00096
00097
00098 /*  ======================================================================
00099     Class BtHsCmaEnterLowPowerMode
00100     ====================================================================== */
00101
00103 class BtHsCmaEnterLowPowerMode : public StackMsgArgument {
00104     friend class BtHsMessageArgumentsDestroyTableNode;
00105     public:
00106         BtHsCmaEnterLowPowerMode();
00107         ~BtHsCmaEnterLowPowerMode();
00108
00109         static const BtHsCmaEnterLowPowerMode& Cast(const StackMsgArgument& arg);
00110
00111         enum  {
00112             ID = 3
00113             };
00114
00115     private:
00116
00117         static void Destroy(StackMsgArgument* arg) { delete ((BtHsCmaEnterLowPowerMode*) arg); }
00118
00119     };
00120
00121 // Inline definitions
00122 inline const BtHsCmaEnterLowPowerMode& BtHsCmaEnterLowPowerMode::Cast(const StackMsgArgument& arg) {
00123     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsCmaEnterLowPowerMode!\n");
00124     return ((BtHsCmaEnterLowPowerMode &) arg);
00125 }
00126
00127
00128
00129 /*  ======================================================================
00130     Class BtHsCmaAudioTransferOutOfCall
00131     ====================================================================== */
00132
00134 class BtHsCmaAudioTransferOutOfCall : public StackMsgArgument {
00135     friend class BtHsMessageArgumentsDestroyTableNode;
00136     public:
00137         BtHsCmaAudioTransferOutOfCall();
00138         ~BtHsCmaAudioTransferOutOfCall();
00139
00140         static const BtHsCmaAudioTransferOutOfCall& Cast(const StackMsgArgument& arg);
00141
00142         enum  {
00143             ID = 4
00144             };
00145
00146     private:
00147
00148         static void Destroy(StackMsgArgument* arg) { delete ((BtHsCmaAudioTransferOutOfCall*) arg); }
00149
00150     };
00151
00152 // Inline definitions
00153 inline const BtHsCmaAudioTransferOutOfCall& BtHsCmaAudioTransferOutOfCall::Cast(const StackMsgArgument& arg) {
00154     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsCmaAudioTransferOutOfCall!\n");
00155     return ((BtHsCmaAudioTransferOutOfCall &) arg);
00156 }
00157
00158
00159
00160 /*  ======================================================================
00161     Class BtHsCmaCheckPendingAudioCallback
00162     ====================================================================== */
00163
00165 class BtHsCmaCheckPendingAudioCallback : public StackMsgArgument {
00166     friend class BtHsMessageArgumentsDestroyTableNode;
00167     public:
00168         BtHsCmaCheckPendingAudioCallback();
00169         ~BtHsCmaCheckPendingAudioCallback();
00170
00171         static const BtHsCmaCheckPendingAudioCallback& Cast(const StackMsgArgument& arg);
00172
00173         enum  {
00174             ID = 5
00175             };
00176
00177     private:
00178
00179         static void Destroy(StackMsgArgument* arg) { delete ((BtHsCmaCheckPendingAudioCallback*) arg); }
00180
00181     };
00182
00183 // Inline definitions
00184 inline const BtHsCmaCheckPendingAudioCallback& BtHsCmaCheckPendingAudioCallback::Cast(const StackMsgArgument& arg) {
00185     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsCmaCheckPendingAudioCallback!\n");
00186     return ((BtHsCmaCheckPendingAudioCallback &) arg);
00187 }
00188
00189
00190 #endif // Bluetooth_HS_BtHsControllerMessageArgument_hpp
00191
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsDisconnectRequest.cpp File Reference

Bluetooth/HS/BtHsDisconnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"
#include "BtHsDisconnectRequest.hpp"

Include dependency graph for BtHsDisconnectRequest.cpp:

Generated on Tue Jan 24 20:11:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsDisconnectRequest.hpp File Reference

Bluetooth/HS/BtHsDisconnectRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsDisconnectRequest_hpp

Define Documentation

#define BtHsDisconnectRequest_hpp

Generated on Tue Jan 24 20:11:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsDisconnectRequest.hpp Source File

Bluetooth/HS/BtHsDisconnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsDisconnectRequest_hpp)
00009 #define BtHsDisconnectRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/BtDisconnectRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHsService;
00027
00031 class BtHsDisconnectRequest: public BtDisconnectRequest
00032 {
00033     private:
00034         typedef BtDisconnectRequest Base;
00035
00036     public:
00038         BtHsDisconnectRequest(BtHsService& hs_service);
00039
00041         virtual ~BtHsDisconnectRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00048     protected:
00050
00052         virtual BOOLEAN PerformDisconnectControllerCall();
00053 };
00054
00056 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00057 #endif  // BtHsDisconnectRequest_hpp
00058
00059
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsMessageArguments.cpp File Reference

Bluetooth/HS/BtHsMessageArguments.cpp File Reference

#include "PreComp.hpp"
#include "BtHsMessageArguments.hpp"

Include dependency graph for BtHsMessageArguments.cpp:

Generated on Tue Jan 24 20:11:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsMessageArguments.hpp File Reference

Bluetooth/HS/BtHsMessageArguments.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/HS/BtHsControllerMessageArgument.hpp>
#include <Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Include dependency graph for BtHsMessageArguments.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsMessageArgumentsDestroyTableNode

Defines

#define | Bluetooth_BtHsMessageArguments_hpp

Define Documentation

#define Bluetooth_BtHsMessageArguments_hpp

Generated on Tue Jan 24 20:11:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsMessageArguments.hpp Source File

Bluetooth/HS/BtHsMessageArguments.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "pointner_leopard_development_pu_dv\lnz_apoxi\Apoxi\Bluetooth\HS\BtHsControllerMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtHsMessageArguments_hpp)
00016 #define Bluetooth_BtHsMessageArguments_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Bluetooth/HS/BtHsControllerMessageArgument.hpp>
00020 #include <Bluetooth/HS/BtHsNotificationMessageArgument.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtHsMessageArgumentsDestroyTableNode
00029     ====================================================================== */
00030
00031 class BtHsMessageArgumentsDestroyTableNode : public StackMsgArgDestroyTableNode {
00032     public:
00033
00034         static BtHsMessageArgumentsDestroyTableNode* GetInstance();
00035
00036     private:
00037         BtHsMessageArgumentsDestroyTableNode();
00038
00039
00040         static BtHsMessageArgumentsDestroyTableNode* m_node;
00041         static const ArgumentDestroyEntry m_destroy_table[];
00042
00043     };
00044
00045 #endif // Bluetooth_BtHsMessageArguments_hpp
00046
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsNotificationMessage.cpp File Reference

Bluetooth/HS/BtHsNotificationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtHsNotificationMessage.hpp"

Include dependency graph for BtHsNotificationMessage.cpp:

Generated on Tue Jan 24 20:11:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsNotificationMessage.hpp File Reference

Bluetooth/HS/BtHsNotificationMessage.hpp File Reference

#include <Apc/Message.hpp>
#include <Apc/StackMsgArgument.hpp>

Include dependency graph for BtHsNotificationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsNotificationMessage

Defines

#define | BtHsNotificationMessage_hpp

Define Documentation

#define BtHsNotificationMessage_hpp

Generated on Tue Jan 24 20:11:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsNotificationMessage.hpp Source File

Bluetooth/HS/BtHsNotificationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsNotificationMessage_hpp)
00009 #define BtHsNotificationMessage_hpp
00012
00013 #include <Apc/Message.hpp>
00014 #include <Apc/StackMsgArgument.hpp>
00015
00018 class BtHsNotificationMessage: public FromStackMsg
00019 {
00020     private:
00021         typedef FromStackMsg Base;
00022
00023     public:
00025         BtHsNotificationMessage(StackMsgArgument *argument = 0);
00026
00028         BtHsNotificationMessage(const BtHsNotificationMessage &message);
00029
00031         virtual ~BtHsNotificationMessage();
00032
00034
00036         virtual FromStackMsg& operator=(const FromStackMsg &message);
00037
00039
00041         virtual BtHsNotificationMessage& operator=(const BtHsNotificationMessage &message);
00042
00044
00046         virtual const MsgMetaData& GetMetaData() const;
00047
00049
00051         virtual Message* Clone() const;
00052
00053     public:
00054         enum { ID = 10104 };
00055
00056     private:
00058         BtDevice m_device;
00059
00060     private:
00062         static const MsgMetaData m_meta_data;
00063 };
00064
00065 #endif // BtHsNotificationMessage_hpp
00066
00067
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsNotificationMessageArgument.cpp File Reference

Bluetooth/HS/BtHsNotificationMessageArgument.cpp File Reference

#include "PreComp.hpp"
#include "BtHsNotificationMessageArgument.hpp"

Include dependency graph for BtHsNotificationMessageArgument.cpp:

Generated on Tue Jan 24 20:12:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsNotificationMessageArgument.hpp File Reference

Bluetooth/HS/BtHsNotificationMessageArgument.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/HS/BtTypes.hpp>

Include dependency graph for BtHsNotificationMessageArgument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsNmaAudioConnectionLost
class | BtHsNmaCallEvent
class | BtHsNmaConnect
class | BtHsNmaDisconnect
class | BtHsNmaLowPowerModeNotPossible
class | BtHsNmaMicrophoneGain
class | BtHsNmaSpeakerGain
class | BtHsNmaTransferAudioToAccessory
class | BtHsNmaTransferAudioToPhone

Defines

#define | Bluetooth_HS_BtHsNotificationMessageArgument_hpp

Define Documentation

#define Bluetooth_HS_BtHsNotificationMessageArgument_hpp

Generated on Tue Jan 24 20:12:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsNotificationMessageArgument.hpp Source File

Bluetooth/HS/BtHsNotificationMessageArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\HS\BtHsNotificationMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_HS_BtHsNotificationMessageArgument_hpp)
00016 #define Bluetooth_HS_BtHsNotificationMessageArgument_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Bluetooth/BtTypes.hpp>
00020 #include <Bluetooth/HS/BtTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtHsNmaConnect
00029     ====================================================================== */
00030
00032 class BtHsNmaConnect : public StackMsgArgument {
00033     friend class BtHsMessageArgumentsDestroyTableNode;
00034     public:
00035         BtHsNmaConnect(const BtResultCode& result, const BtDevice& device);
00036         BtHsNmaConnect();
00037         ~BtHsNmaConnect();
00038
00039         static const BtHsNmaConnect& Cast(const StackMsgArgument& arg);
00040         const BtResultCode& GetResult() const { return m_result; }
00041         const BtDevice& GetDevice() const { return m_device; }
00042
00043         enum  {
00044             ID = 10
00045             };
00046
00047     private:
00048
00049         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaConnect*) arg); }
00050
00051         BtResultCode m_result;
00052         BtDevice m_device;
00053
00054     };
00055
00056 // Inline definitions
00057 inline const BtHsNmaConnect& BtHsNmaConnect::Cast(const StackMsgArgument& arg) {
00058     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaConnect!\n");
00059     return ((BtHsNmaConnect &) arg);
00060 }
00061
00062
00063
00064 /*  ======================================================================
00065     Class BtHsNmaDisconnect
00066     ====================================================================== */
00067
00069 class BtHsNmaDisconnect : public StackMsgArgument {
00070     friend class BtHsMessageArgumentsDestroyTableNode;
00071     public:
00072         BtHsNmaDisconnect(const BtResultCode& result);
00073         BtHsNmaDisconnect();
00074         ~BtHsNmaDisconnect();
00075
00076         static const BtHsNmaDisconnect& Cast(const StackMsgArgument& arg);
00077         const BtResultCode& GetResult() const { return m_result; }
00078
00079         enum  {
00080             ID = 11
00081             };
00082
00083     private:
00084
00085         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaDisconnect*) arg); }
00086
00087         BtResultCode m_result;
00088
00089     };
00090
00091 // Inline definitions
00092 inline const BtHsNmaDisconnect& BtHsNmaDisconnect::Cast(const StackMsgArgument& arg) {
00093     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaDisconnect!\n");
00094     return ((BtHsNmaDisconnect &) arg);
00095 }
00096
00097
00098
00099 /*  ======================================================================
00100     Class BtHsNmaTransferAudioToAccessory
00101     ====================================================================== */
00102
00104 class BtHsNmaTransferAudioToAccessory : public StackMsgArgument {
00105     friend class BtHsMessageArgumentsDestroyTableNode;
00106     public:
00107         BtHsNmaTransferAudioToAccessory(const BtResultCode& result);
00108         BtHsNmaTransferAudioToAccessory();
00109         ~BtHsNmaTransferAudioToAccessory();
00110
00111         static const BtHsNmaTransferAudioToAccessory& Cast(const StackMsgArgument& arg);
00112         const BtResultCode& GetResult() const { return m_result; }
00113
00114         enum  {
00115             ID = 12
00116             };
00117
00118     private:
00119
00120         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaTransferAudioToAccessory*) arg); }
00121
00122         BtResultCode m_result;
00123
00124     };
00125
00126 // Inline definitions
00127 inline const BtHsNmaTransferAudioToAccessory& BtHsNmaTransferAudioToAccessory::Cast(const StackMsgArgument& arg) {
00128     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaTransferAudioToAccessory!\n");
00129     return ((BtHsNmaTransferAudioToAccessory &) arg);
00130 }
00131
00132
00133
00134 /*  ======================================================================
00135     Class BtHsNmaTransferAudioToPhone
00136     ====================================================================== */
00137
00139 class BtHsNmaTransferAudioToPhone : public StackMsgArgument {
00140     friend class BtHsMessageArgumentsDestroyTableNode;
00141     public:
00142         BtHsNmaTransferAudioToPhone(const BtResultCode& result);
00143         BtHsNmaTransferAudioToPhone();
00144         ~BtHsNmaTransferAudioToPhone();
00145
00146         static const BtHsNmaTransferAudioToPhone& Cast(const StackMsgArgument& arg);
00147         const BtResultCode& GetResult() const { return m_result; }
00148
00149         enum  {
00150             ID = 13
00151             };
00152
00153     private:
00154
00155         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaTransferAudioToPhone*) arg); }
00156
00157         BtResultCode m_result;
00158
00159     };
00160
00161 // Inline definitions
00162 inline const BtHsNmaTransferAudioToPhone& BtHsNmaTransferAudioToPhone::Cast(const StackMsgArgument& arg) {
00163     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaTransferAudioToPhone!\n");
00164     return ((BtHsNmaTransferAudioToPhone &) arg);
00165 }
00166
00167
00168
00169 /*  ======================================================================
00170     Class BtHsNmaAudioConnectionLost
00171     ====================================================================== */
00172
00174 class BtHsNmaAudioConnectionLost : public StackMsgArgument {
00175     friend class BtHsMessageArgumentsDestroyTableNode;
00176     public:
00177         BtHsNmaAudioConnectionLost(const BtResultCode& result);
00178         BtHsNmaAudioConnectionLost();
00179         ~BtHsNmaAudioConnectionLost();
00180
00181         static const BtHsNmaAudioConnectionLost& Cast(const StackMsgArgument& arg);
00182         const BtResultCode& GetResult() const { return m_result; }
00183
00184         enum  {
00185             ID = 14
00186             };
00187
00188     private:
00189
00190         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaAudioConnectionLost*) arg); }
00191
00192         BtResultCode m_result;
00193
00194     };
00195
00196 // Inline definitions
00197 inline const BtHsNmaAudioConnectionLost& BtHsNmaAudioConnectionLost::Cast(const StackMsgArgument& arg) {
00198     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaAudioConnectionLost!\n");
00199     return ((BtHsNmaAudioConnectionLost &) arg);
00200 }
00201
00202
00203
00204 /*  ======================================================================
00205     Class BtHsNmaMicrophoneGain
00206     ====================================================================== */
00207
00209 class BtHsNmaMicrophoneGain : public StackMsgArgument {
00210     friend class BtHsMessageArgumentsDestroyTableNode;
00211     public:
00212         BtHsNmaMicrophoneGain(const BtResultCode& result, UINT8 gain);
00213         BtHsNmaMicrophoneGain();
00214         ~BtHsNmaMicrophoneGain();
00215
00216         static const BtHsNmaMicrophoneGain& Cast(const StackMsgArgument& arg);
00217         const BtResultCode& GetResult() const { return m_result; }
00218         UINT8 GetGain() const { return m_gain; }
00219
00220         enum  {
00221             ID = 15
00222             };
00223
00224     private:
00225
00226         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaMicrophoneGain*) arg); }
00227
00228         BtResultCode m_result;
00229         UINT8 m_gain;
00230
00231     };
00232
00233 // Inline definitions
00234 inline const BtHsNmaMicrophoneGain& BtHsNmaMicrophoneGain::Cast(const StackMsgArgument& arg) {
00235     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaMicrophoneGain!\n");
00236     return ((BtHsNmaMicrophoneGain &) arg);
00237 }
00238
00239
00240
00241 /*  ======================================================================
00242     Class BtHsNmaSpeakerGain
00243     ====================================================================== */
00244
00246 class BtHsNmaSpeakerGain : public StackMsgArgument {
00247     friend class BtHsMessageArgumentsDestroyTableNode;
00248     public:
00249         BtHsNmaSpeakerGain(const BtResultCode& result, UINT8 gain);
00250         BtHsNmaSpeakerGain();
00251         ~BtHsNmaSpeakerGain();
00252
00253         static const BtHsNmaSpeakerGain& Cast(const StackMsgArgument& arg);
00254         const BtResultCode& GetResult() const { return m_result; }
00255         UINT8 GetGain() const { return m_gain; }
00256
00257         enum  {
00258             ID = 16
00259             };
00260
00261     private:
00262
00263         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaSpeakerGain*) arg); }
00264
00265         BtResultCode m_result;
00266         UINT8 m_gain;
00267
00268     };
00269
00270 // Inline definitions
00271 inline const BtHsNmaSpeakerGain& BtHsNmaSpeakerGain::Cast(const StackMsgArgument& arg) {
00272     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaSpeakerGain!\n");
00273     return ((BtHsNmaSpeakerGain &) arg);
00274 }
00275
00276
00277
00278 /*  ======================================================================
00279     Class BtHsNmaLowPowerModeNotPossible
00280     ====================================================================== */
00281
00283 class BtHsNmaLowPowerModeNotPossible : public StackMsgArgument {
00284     friend class BtHsMessageArgumentsDestroyTableNode;
00285     public:
00286         BtHsNmaLowPowerModeNotPossible(const BtResultCode& result);
00287         BtHsNmaLowPowerModeNotPossible();
00288         ~BtHsNmaLowPowerModeNotPossible();
00289
00290         static const BtHsNmaLowPowerModeNotPossible& Cast(const StackMsgArgument& arg);
00291         const BtResultCode& GetResult() const { return m_result; }
00292
00293         enum  {
00294             ID = 17
00295             };
00296
00297     private:
00298
00299         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaLowPowerModeNotPossible*) arg); }
00300
00301         BtResultCode m_result;
00302
00303     };
00304
00305 // Inline definitions
00306 inline const BtHsNmaLowPowerModeNotPossible& BtHsNmaLowPowerModeNotPossible::Cast(const StackMsgArgument& arg) {
00307     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaLowPowerModeNotPossible!\n");
00308     return ((BtHsNmaLowPowerModeNotPossible &) arg);
00309 }
00310
00311
00312
00313 /*  ======================================================================
00314     Class BtHsNmaCallEvent
00315     ====================================================================== */
00316
00318 class BtHsNmaCallEvent : public StackMsgArgument {
00319     friend class BtHsMessageArgumentsDestroyTableNode;
00320     public:
00321         BtHsNmaCallEvent(const BtHsCallEvent& call_event);
00322         BtHsNmaCallEvent();
00323         ~BtHsNmaCallEvent();
00324
00325         static const BtHsNmaCallEvent& Cast(const StackMsgArgument& arg);
00326         const BtHsCallEvent& GetCallEvent() const { return m_call_event; }
00327
00328         enum  {
00329             ID = 18
00330             };
00331
00332     private:
00333
00334         static void Destroy(StackMsgArgument* arg) { delete ((BtHsNmaCallEvent*) arg); }
00335
00336         BtHsCallEvent m_call_event;
00337
00338     };
00339
00340 // Inline definitions
00341 inline const BtHsNmaCallEvent& BtHsNmaCallEvent::Cast(const StackMsgArgument& arg) {
00342     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtHsNmaCallEvent!\n");
00343     return ((BtHsNmaCallEvent &) arg);
00344 }
00345
00346
00347 #endif // Bluetooth_HS_BtHsNotificationMessageArgument_hpp
00348
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsRequest.cpp File Reference

Bluetooth/HS/BtHsRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsRequest.hpp"
#include "BtHsService.hpp"

Include dependency graph for BtHsRequest.cpp:

Generated on Tue Jan 24 20:12:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsRequest.hpp File Reference

Bluetooth/HS/BtHsRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsRequest_hpp

Define Documentation

#define BtHsRequest_hpp

Generated on Tue Jan 24 20:12:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsRequest.hpp Source File

Bluetooth/HS/BtHsRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsRequest_hpp)
00009 #define BtHsRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 /*  ------------------------------------------------------------------------
00021     Forward deklarations
00022     ------------------------------------------------------------------------ */
00023
00024 class BtHsService;
00025
00028 class BtHsRequest: public BtServiceRequest
00029 {
00030     private:
00031         typedef BtServiceRequest Base;
00032
00033     public:
00035         BtHsRequest(BtHsService& hs_service);
00036
00038         virtual ~BtHsRequest();
00039 };
00040
00042 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00043 #endif  // BtHsRequest_hpp
00044
00045
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsRingRequest.cpp File Reference

Bluetooth/HS/BtHsRingRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"
#include "BtHsRingRequest.hpp"

Include dependency graph for BtHsRingRequest.cpp:

Generated on Tue Jan 24 20:12:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsRingRequest.hpp File Reference

Bluetooth/HS/BtHsRingRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsRingRequest_hpp

Define Documentation

#define BtHsRingRequest_hpp

Generated on Tue Jan 24 20:12:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsRingRequest.hpp Source File

Bluetooth/HS/BtHsRingRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsRingRequest_hpp)
00009 #define BtHsRingRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HS/BtHsRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHsController;
00027 class BtHsService;
00028
00031 class BtHsRingRequest: public BtHsRequest
00032 {
00033     private:
00034         typedef BtHsRequest Base;
00035
00036     public:
00038         BtHsRingRequest(BtHsService& hs_service);
00039
00041         virtual ~BtHsRingRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00049
00051         UINT16 GetRingInterval() const;
00052
00054
00056         void SetRingInterval(UINT16 ring_interval);
00057
00059
00061         UINT8 GetNumberOfRingSignals() const;
00062
00064
00066         void SetNumberOfRingSignals(UINT8 number_of_ring_signals);
00067
00068     protected:
00070
00072         virtual BOOLEAN Execute();
00073
00075
00077         void Abort();
00078
00080
00082         BOOLEAN GetUseInbandRinging() const;
00083
00085
00087         void SetUseInbandRinging(BOOLEAN use_inband_ringing);
00088
00090
00092         BOOLEAN GetKeepAudio() const;
00093
00095
00097         void SetKeepAudio(BOOLEAN keep_audio);
00098
00099     private:
00101
00103         const btapi_ring_settings_t* GetApiSettings() const;
00104
00105     private:
00107         btapi_ring_settings_t m_ring_settings;
00108
00109     private:
00110         friend class BtHsController;
00111         friend class BtHsService;
00112 };
00113
00115 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00116 #endif  // BtHsRingRequest_hpp
00117
00118
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsService.cpp File Reference

Bluetooth/HS/BtHsService.cpp File Reference

#include "PreComp.hpp"
#include "BtHsControllerMessage.hpp"
#include "BtHsControllerMessageArgument.hpp"
#include "BtHsNotificationMessage.hpp"
#include "BtHsNotificationMessageArgument.hpp"
#include "BtHsServiceMessage.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"

Include dependency graph for BtHsService.cpp:

Defines

#define DBG_STATE

Define Documentation

#define DBG_STATE

Generated on Tue Jan 24 20:12:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsService.hpp File Reference

Bluetooth/HS/BtHsService.hpp File Reference

#include <Kernel/Application.hpp>
#include <Bluetooth/BtAudioAccessoryService.hpp>
#include <Bluetooth/HS/BtTypes.hpp>
#include <Bluetooth/HS/BtHsControllerMessage.hpp>
#include <Bluetooth/HS/BtHsConnectRequest.hpp>
#include <Bluetooth/HS/BtHsDisconnectRequest.hpp>
#include <Bluetooth/HS/BtHsRingRequest.hpp>
#include <Bluetooth/HS/BtHsStopRingRequest.hpp>
#include <Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp>
#include <Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp>
#include <Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp>
#include <Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp>

Include dependency graph for BtHsService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsService

Defines

#define | BtHsService_hpp

Define Documentation

#define BtHsService_hpp

Generated on Tue Jan 24 20:12:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsService.hpp Source File

Bluetooth/HS/BtHsService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsService_hpp)
00009 #define BtHsService_hpp
00012
00013 #include <Kernel/Application.hpp>
00014 #include <Bluetooth/BtAudioAccessoryService.hpp>
00015 #include <Bluetooth/HS/BtTypes.hpp>
00016 #include <Bluetooth/HS/BtHsControllerMessage.hpp>
00017 #include <Bluetooth/HS/BtHsConnectRequest.hpp>
00018 #include <Bluetooth/HS/BtHsDisconnectRequest.hpp>
00019 #include <Bluetooth/HS/BtHsRingRequest.hpp>
00020 #include <Bluetooth/HS/BtHsStopRingRequest.hpp>
00021 #include <Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp>
00022 #include <Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp>
00023 #include <Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp>
00024 #include <Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp>
00025
00040 class BtHsService: public BtAudioAccessoryService
00041 {
00042     private:
00043         typedef BtAudioAccessoryService Base;
00044
00045     public:
00047         BtHsService();
00048
00050         virtual ~BtHsService();
00051
00053
00056         virtual void Init();
00057
00059
00063         virtual BtProfile GetProfile() const;
00064
00066
00068         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00069
00071
00078         virtual void SetTargetDevice(const BtDevice& target_device);
00079
00081
00090         virtual BOOLEAN IsConnected() const;
00091
00093
00095         virtual BOOLEAN IsRinging() const;
00096
00098
00100         virtual BOOLEAN IsInCall() const;
00101
00103
00110         virtual BtRequestState ConnectRequest();
00111
00113
00121         virtual BtRequestState DisconnectRequest();
00122
00124
00132         virtual BtRequestState TransferAudioToPhoneRequest();
00133
00135
00143         virtual BtRequestState TransferAudioToAccessoryRequest();
00144
00146
00148         virtual UINT8 GetMicrophoneGain() const;
00149
00151
00163         virtual BtRequestState SetMicrophoneGainRequest(INT8 gain_offset);
00164
00166
00168         virtual UINT8 GetSpeakerGain() const;
00169
00171
00183         virtual BtRequestState SetSpeakerGainRequest(INT8 gain_offset);
00184
00186
00198         BOOLEAN GetConnectionOnlyDuringCall() const;
00199
00201
00211         void SetConnectionOnlyDuringCall(BOOLEAN connection_only_during_call);
00212
00214
00219         UINT16 GetRingInterval() const;
00220
00222
00227         void SetRingInterval(UINT16 ring_interval);
00228
00230
00234         UINT8 GetNumberOfRingSignals() const;
00235
00237
00242         void SetNumberOfRingSignals(UINT8 number_of_ring_signals);
00243
00245
00267         BtHsState GetState() const;
00268
00269     public:
00271
00277         static const BtDevice& GetLastConnectedDevice();
00278
00280
00287         static void SetLastConnectedDevice(const BtDevice& last_connected_device);
00288
00289     protected:
00291
00293         BtRequestState RingRequest();
00294
00296
00298         BtRequestState StopRingRequest(BOOLEAN keep_audio = FALSE);
00299
00301
00303         virtual void RegisterMessages() const;
00304
00306
00308         virtual void UnregisterMessages() const;
00309
00311
00313         virtual BOOLEAN OnMessage(const Message& message);
00314
00316
00318         virtual BOOLEAN OnCallEventMessage(const CallEventMsg& call_event_message);
00319
00321
00323         virtual BOOLEAN OnControllerMessage(const BtHsControllerMessage& controller_message);
00324
00326
00328         void AcceptCall();
00329
00331
00333         void ReleaseCall();
00334
00335     private:
00337
00339         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00340
00342
00344         void TryAudioRequest(BtRequest* audio_request);
00345
00347
00349         void CheckPendingAudioRequest();
00350
00351 #ifdef _DEBUG
00352     private:
00354
00356         const char* BtHsRequestAsString(BtRequest* request);
00357
00359
00361         void DebugState();
00362 #endif /* _DEBUG */
00363
00364     private:
00366         Application* m_owner;
00367
00369         Semaphore m_audio_request_pending_semaphore;
00370
00372         BtRequest* m_pending_audio_request;
00373
00375         BOOLEAN m_connection_only_during_call;
00376
00378         BtHsConnectRequest m_connect_request;
00379
00381         BtHsConnectRequest m_connect_request_intern;
00382
00384         BtHsDisconnectRequest m_disconnect_request;
00385
00387         BtHsDisconnectRequest m_disconnect_request_intern;
00388
00390         BtHsRingRequest m_ring_request_intern;
00391
00393         BtHsStopRingRequest m_stop_ring_request_intern;
00394
00396         BtHsTransferAudioToPhoneRequest m_transfer_audio_to_phone_request;
00397
00399         BtHsTransferAudioToPhoneRequest m_transfer_audio_to_phone_request_intern;
00400
00402         BtHsTransferAudioToAccessoryRequest m_transfer_audio_to_accessory_request;
00403
00405         BtHsTransferAudioToAccessoryRequest m_transfer_audio_to_accessory_request_intern;
00406
00408         BtHsSetMicrophoneGainRequest m_set_microphone_gain_request;
00409
00411         BtHsSetSpeakerGainRequest m_set_speaker_gain_request;
00412
00413     private:
00414         friend class BtHsRequest;
00415         friend class BtHsRingRequest;
00416 };
00417
00419 #endif  // BtHsService_hpp
00420
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsServiceMessage.cpp File Reference

Bluetooth/HS/BtHsServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtHsServiceMessage.hpp"

Include dependency graph for BtHsServiceMessage.cpp:

Generated on Tue Jan 24 20:12:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsServiceMessage.hpp File Reference

Bluetooth/HS/BtHsServiceMessage.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtHsServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsRequestStateChangedMessage

Defines

#define | Bluetooth_BtHsServiceMessage_hpp

Define Documentation

#define Bluetooth_BtHsServiceMessage_hpp

Generated on Tue Jan 24 20:13:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsServiceMessage.hpp Source File

Bluetooth/HS/BtHsServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\HS\BtHsServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtHsServiceMessage_hpp)
00016 #define Bluetooth_BtHsServiceMessage_hpp
00017
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtHsRequestStateChangedMessage
00027     ====================================================================== */
00028
00030 class BtHsRequestStateChangedMessage : public BtRequestStateChangedMessage {
00031     public:
00032         BtHsRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00033         virtual ~BtHsRequestStateChangedMessage();
00034
00035         virtual const MsgMetaData& GetMetaData() const;
00036         virtual Message* Clone() const;
00037
00038         enum  {
00039             ID = 10325
00040             };
00041
00042     private:
00043         static const MsgMetaData m_meta_data;
00044
00045     };
00046
00047 #endif // Bluetooth_BtHsServiceMessage_hpp
00048
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsSetMicrophoneGainRequest.cpp File Reference

Bluetooth/HS/BtHsSetMicrophoneGainRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"
#include "BtHsSetMicrophoneGainRequest.hpp"

Include dependency graph for BtHsSetMicrophoneGainRequest.cpp:

Generated on Tue Jan 24 20:13:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp File Reference

Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsSetMicrophoneGainRequest_hpp

Define Documentation

#define BtHsSetMicrophoneGainRequest_hpp

Generated on Tue Jan 24 20:13:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp Source File

Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsSetMicrophoneGainRequest_hpp)
00009 #define BtHsSetMicrophoneGainRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HS/BtHsRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHsController;
00027
00030 class BtHsSetMicrophoneGainRequest: public BtHsRequest
00031 {
00032     private:
00033         typedef BtHsRequest Base;
00034
00035     public:
00037         BtHsSetMicrophoneGainRequest(BtHsService& hs_service);
00038
00040         virtual ~BtHsSetMicrophoneGainRequest();
00041
00043
00045         virtual BtRequestType GetRequestType() const;
00046
00048
00050         UINT8 GetMicrophoneGain() const;
00051
00053
00055         void SetMicrophoneGain(UINT8 mircophone_gain);
00056
00057     protected:
00059
00061         virtual BOOLEAN Execute();
00062
00063     private:
00065
00067         btapi_u8_t GetApiSettings() const;
00068
00069     private:
00071         btapi_u8_t m_microphone_gain;
00072
00073     private:
00074         friend class BtHsController;
00075 };
00076
00078 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00079 #endif  // BtHsSetMicrophoneGainRequest_hpp
00080
00081
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsSetSpeakerGainRequest.cpp File Reference

Bluetooth/HS/BtHsSetSpeakerGainRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"
#include "BtHsSetSpeakerGainRequest.hpp"

Include dependency graph for BtHsSetSpeakerGainRequest.cpp:

Generated on Tue Jan 24 20:13:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp File Reference

Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsSetSpeakerGainRequest_hpp

Define Documentation

#define BtHsSetSpeakerGainRequest_hpp

Generated on Tue Jan 24 20:13:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp Source File

Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsSetSpeakerGainRequest_hpp)
00009 #define BtHsSetSpeakerGainRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HS/BtHsRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHsController;
00027
00030 class BtHsSetSpeakerGainRequest: public BtHsRequest
00031 {
00032     private:
00033         typedef BtHsRequest Base;
00034
00035     public:
00037         BtHsSetSpeakerGainRequest(BtHsService& hs_service);
00038
00040         virtual ~BtHsSetSpeakerGainRequest();
00041
00043
00045         virtual BtRequestType GetRequestType() const;
00046
00048
00050         UINT8 GetSpeakerGain() const;
00051
00053
00055         void SetSpeakerGain(UINT8 speaker_gain);
00056
00057     protected:
00059
00061         virtual BOOLEAN Execute();
00062
00063     private:
00065
00067         btapi_u8_t GetApiSettings() const;
00068
00069     private:
00071         btapi_u8_t m_speaker_gain;
00072
00073     private:
00074         friend class BtHsController;
00075 };
00076
00078 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00079 #endif  // BtHsSetSpeakerGainRequest_hpp
00080
00081
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsStopRingRequest.cpp File Reference

Bluetooth/HS/BtHsStopRingRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"
#include "BtHsStopRingRequest.hpp"

Include dependency graph for BtHsStopRingRequest.cpp:

Generated on Tue Jan 24 20:13:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsStopRingRequest.hpp File Reference

Bluetooth/HS/BtHsStopRingRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsStopRingRequest_hpp

Define Documentation

#define BtHsStopRingRequest_hpp

Generated on Tue Jan 24 20:13:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsStopRingRequest.hpp Source File

Bluetooth/HS/BtHsStopRingRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsStopRingRequest_hpp)
00009 #define BtHsStopRingRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HS/BtHsRequest.hpp>
00021
00024 class BtHsStopRingRequest: public BtHsRequest
00025 {
00026     private:
00027         typedef BtHsRequest Base;
00028
00029     public:
00031         BtHsStopRingRequest(BtHsService& hs_service);
00032
00034         virtual ~BtHsStopRingRequest();
00035
00037
00039         virtual BtRequestType GetRequestType() const;
00040
00042
00044         BOOLEAN GetKeepAudio() const;
00045
00047
00049         void SetKeepAudio(BOOLEAN keep_audio);
00050
00051     protected:
00053
00055         virtual BOOLEAN Execute();
00056
00057     private:
00059
00061         btapi_bool_t GetApiSettings() const;
00062
00063     private:
00065         btapi_bool_t m_keep_audio;
00066
00067     private:
00068         friend class BtHsController;
00069 };
00070
00072 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00073 #endif  // BtHsStopRingRequest_hpp
00074
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.cpp File Reference

Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"
#include "BtHsTransferAudioToAccessoryRequest.hpp"

Include dependency graph for BtHsTransferAudioToAccessoryRequest.cpp:

Generated on Tue Jan 24 20:13:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp File Reference

Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsTransferAudioToAccessoryRequest_hpp

Define Documentation

#define BtHsTransferAudioToAccessoryRequest_hpp

Generated on Tue Jan 24 20:13:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp Source File

Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsTransferAudioToAccessoryRequest_hpp)
00009 #define BtHsTransferAudioToAccessoryRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HS/BtHsRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHsController;
00027 class BtHsService;
00028
00031 class BtHsTransferAudioToAccessoryRequest: public BtHsRequest
00032 {
00033     private:
00034         typedef BtHsRequest Base;
00035
00036     public:
00038         BtHsTransferAudioToAccessoryRequest(BtHsService& hs_service);
00039
00041         virtual ~BtHsTransferAudioToAccessoryRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00048     protected:
00050
00052         virtual BOOLEAN Execute();
00053
00054     private:
00056
00058         btapi_bool_t GetApiSettings() const;
00059
00061
00063         BOOLEAN GetIsSynchronizationRequest() const;
00064
00066
00068         void SetIsSynchronizationRequest(BOOLEAN is_synchronization_request);
00069
00070     private:
00072
00074         BOOLEAN m_is_synchronization_request;
00075
00076     private:
00077         friend class BtHsController;
00078         friend class BtHsService;
00079 };
00080
00082 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00083 #endif  // BtHsTransferAudioToAccessoryRequest_hpp
00084
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsTransferAudioToPhoneRequest.cpp File Reference

Bluetooth/HS/BtHsTransferAudioToPhoneRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtHsService.hpp"
#include "BtHsController.hpp"
#include "BtHsTransferAudioToPhoneRequest.hpp"

Include dependency graph for BtHsTransferAudioToPhoneRequest.cpp:

Generated on Tue Jan 24 20:14:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp File Reference

Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define BtHsTransferAudioToPhoneRequest_hpp

Define Documentation

#define BtHsTransferAudioToPhoneRequest_hpp

Generated on Tue Jan 24 20:14:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp Source File

Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsTransferAudioToPhoneRequest_hpp)
00009 #define BtHsTransferAudioToPhoneRequest_hpp
00010 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013
00014 /* !!! ATTENTON !!! Internal class only !!! ATTENTION !!!
00015    The class may not be used by the MMI in a direct
00016    manner and the interface may be changed in future
00017    releases.
00018    !!! ATTENTON !!! Internal class only !!! ATTENTION !!! */
00019
00020 #include <Bluetooth/HS/BtHsRequest.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtHsController;
00027 class BtHsService;
00028
00031 class BtHsTransferAudioToPhoneRequest: public BtHsRequest
00032 {
00033     private:
00034         typedef BtHsRequest Base;
00035
00036     public:
00038         BtHsTransferAudioToPhoneRequest(BtHsService& hs_service);
00039
00041         virtual ~BtHsTransferAudioToPhoneRequest();
00042
00044
00046         virtual BtRequestType GetRequestType() const;
00047
00048     protected:
00050
00052         virtual BOOLEAN Execute();
00053
00054     private:
00056
00058         btapi_bool_t GetApiSettings() const;
00059
00061
00063         BOOLEAN GetIsSynchronizationRequest() const;
00064
00066
00068         void SetIsSynchronizationRequest(BOOLEAN is_synchronization_request);
00069
00070     private:
00072
00074         BOOLEAN m_is_synchronization_request;
00075
00076     private:
00077         friend class BtHsController;
00078         friend class BtHsService;
00079 };
00080
00082 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00083 #endif  // BtHsTransferAudioToPhoneRequest_hpp
00084
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtTypes.hpp File Reference

Bluetooth/HS/BtTypes.hpp File Reference

#include <stack/extensions.h>
#include <Kernel/Types.hpp>

Include dependency graph for BtTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Bt_Hs_Types_hpp

Enumerations

enum | BtHsCallEvent { BtHsCeCallOnPhone, BtHsCeCallOnHeadset, BtHsCeHangUp, BtHsCeCallRelease }
enum | BtHsCallLocation { BtHsClNoCall, BtHsClCallOnPhone, BtHsClCallOnAccessory }
enum | BtHsState { BtHssNotConnected, BtHssConnected, BtHssAvailableForAudio, BtHssAudioActive }

Define Documentation

#define Bt_Hs_Types_hpp

Generated on Tue Jan 24 19:57:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/BtTypes.hpp Source File

Bluetooth/HS/BtTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bt_Hs_Types_hpp)
00009 #define Bt_Hs_Types_hpp
00012
00013 #include <stack/extensions.h>
00014 #include <Kernel/Types.hpp>
00015
00016 /*****************************************************************************
00017  * Bluetooth HS definitions                                                  *
00018  *****************************************************************************
00019
00020  *---------------------------------------------------------------------------*
00021  * Bluetooth HS constants                                                    *
00022  *---------------------------------------------------------------------------*/
00023
00024 /*---------------------------------------------------------------------------*
00025  * Bluetooth HS enums                                                        *
00026  *---------------------------------------------------------------------------*/
00027
00029
00031 typedef enum {
00033     BtHssNotConnected,
00035     BtHssConnected,
00037     BtHssAvailableForAudio,
00039     BtHssAudioActive
00040 } BtHsState;
00041
00042 typedef enum {
00044     BtHsCeCallOnPhone,
00046     BtHsCeCallOnHeadset,
00048     BtHsCeHangUp,
00050     BtHsCeCallRelease
00051 } BtHsCallEvent;
00052
00053 typedef enum {
00055     BtHsClNoCall,
00057     BtHsClCallOnPhone,
00059     BtHsClCallOnAccessory
00060 } BtHsCallLocation;
00061
00062 /*---------------------------------------------------------------------------*
00063  * Bluetooth HS types                                                        *
00064  *---------------------------------------------------------------------------*/
00065
00067 #endif // Bt_Hs_Types_hpp
00068
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/Lib.hpp File Reference

Bluetooth/HS/Lib.hpp File Reference

#include <Bluetooth/HS/BtTypes.hpp>
#include <Bluetooth/HS/BtHsControllerMessage.hpp>
#include <Bluetooth/HS/BtHsNotificationMessage.hpp>
#include <Bluetooth/HS/BtHsServiceMessage.hpp>
#include <Bluetooth/HS/BtHsControllerMessageArgument.hpp>
#include <Bluetooth/HS/BtHsMessageArguments.hpp>
#include <Bluetooth/HS/BtHsNotificationMessageArgument.hpp>
#include <Bluetooth/HS/BtHsController.hpp>
#include <Bluetooth/HS/BtHsService.hpp>
#include <Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp>
#include <Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp>
#include <Bluetooth/HS/BtHsConnectRequest.hpp>
#include <Bluetooth/HS/BtHsDisconnectRequest.hpp>
#include <Bluetooth/HS/BtHsRequest.hpp>
#include <Bluetooth/HS/BtHsRingRequest.hpp>
#include <Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp>
#include <Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp>
#include <Bluetooth/HS/BtHsStopRingRequest.hpp>

Include dependency graph for Lib.hpp:

Go to the source code of this file.

Defines

#define Bluetooth_Hs_Lib_hpp

Define Documentation

#define Bluetooth_Hs_Lib_hpp

Generated on Tue Jan 24 14:54:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/Lib.hpp Source File

Bluetooth/HS/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bluetooth_Hs_Lib_hpp)
00009 #define Bluetooth_Hs_Lib_hpp
00012
00013 #include <Bluetooth/HS/BtTypes.hpp>
00014 #include <Bluetooth/HS/BtHsControllerMessage.hpp>
00015 #include <Bluetooth/HS/BtHsNotificationMessage.hpp>
00016 #include <Bluetooth/HS/BtHsServiceMessage.hpp>
00017 #include <Bluetooth/HS/BtHsControllerMessageArgument.hpp>
00018 #include <Bluetooth/HS/BtHsMessageArguments.hpp>
00019 #include <Bluetooth/HS/BtHsNotificationMessageArgument.hpp>
00020 #include <Bluetooth/HS/BtHsController.hpp>
00021 #include <Bluetooth/HS/BtHsService.hpp>
00022 #include <Bluetooth/HS/BtHsTransferAudioToAccessoryRequest.hpp>
00023 #include <Bluetooth/HS/BtHsTransferAudioToPhoneRequest.hpp>
00024 #include <Bluetooth/HS/BtHsConnectRequest.hpp>
00025 #include <Bluetooth/HS/BtHsDisconnectRequest.hpp>
00026 #include <Bluetooth/HS/BtHsRequest.hpp>
00027 #include <Bluetooth/HS/BtHsRingRequest.hpp>
00028 #include <Bluetooth/HS/BtHsSetMicrophoneGainRequest.hpp>
00029 #include <Bluetooth/HS/BtHsSetSpeakerGainRequest.hpp>
00030 #include <Bluetooth/HS/BtHsStopRingRequest.hpp>
00031
00033 #endif /* Bluetooth_Hs_Lib_hpp */
00034
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/PreComp.cpp File Reference

Bluetooth/HS/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/PreComp.hpp File Reference

Bluetooth/HS/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Devices/AudioAccessoryDetails.hpp>
#include <Devices/AudioAccessoryStore.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:19:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/HS/PreComp.hpp Source File

Bluetooth/HS/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Asc/Lib.hpp>
00011 #include <Devices/AudioAccessoryDetails.hpp>
00012 #include <Devices/AudioAccessoryStore.hpp>
00013 #include <Bluetooth/Lib.hpp>
00014
00015
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/JSR82/BtJsr82Url.cpp File Reference

Bluetooth/JSR82/BtJsr82Url.cpp File Reference

#include "PreComp.hpp"
#include <stdlib.h>
#include <Auxiliary/BinarySearch.hpp>
#include "BtJsr82Url.hpp"

Include dependency graph for BtJsr82Url.cpp:

Generated on Tue Jan 24 20:14:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/JSR82/BtJsr82Url.hpp File Reference

Bluetooth/JSR82/BtJsr82Url.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/BitField.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>

Include dependency graph for BtJsr82Url.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtJsr82Url
class | BtJsr82Url::Scanner
class | BtJsr82Url::StringReader
class | BtJsr82Url::Token
struct | BtJsr82Url::Token::Keyword

Defines

#define | BtJsr82Url_hpp

Define Documentation

#define BtJsr82Url_hpp

Generated on Tue Jan 24 20:14:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/JSR82/BtJsr82Url.hpp Source File

Bluetooth/JSR82/BtJsr82Url.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2005 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtJsr82Url_hpp)
00009 #define BtJsr82Url_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/BitField.hpp>
00015
00016 #include <Bluetooth/BtTypes.hpp>
00017 #include <Bluetooth/BtDeviceAddress.hpp>
00018
00019 /*  ------------------------------------------------------------------------
00020     Forward deklarations for friend relationships.
00021     ------------------------------------------------------------------------ */
00022
00023
00026 class BtJsr82Url
00027 {
00028     // Forward declarations
00029     public:
00030         class Token;
00031
00032     private:
00033         class Scanner;
00034
00035         friend class Scanner;
00036         friend class Token;
00037
00038     public:
00039         class Token {
00040
00041             friend class Scanner;
00042
00043             public:
00044                 enum TypeId {
00045                     TUnknown,       // Unknown yet, currently being assembled
00046                     TAmbigous,      // Context-dependent, look at properties
00047
00048                     TScheme,        // Protocol identifier in URL
00049                     TBadInput,      // Illegal character in input stream
00050                     TEndInput,      // End of input (not necessarily an error)
00051
00052                     TColon,         // Separators
00053                     TEqual,
00054                     TSemicolon,
00055                     TComma,
00056                     TDot,
00057                     TAsterix,
00058                     TSlashes,
00059
00060                     TDecNumber,
00061                     THexNumber,
00062                     TText,
00063
00064                     TLocalhost,
00065                     TAuthenticate,  // Keywords / predefined identifiers
00066                     TAuthorize,
00067                     TEncrypt,
00068                     TMaster,
00069                     TName,
00070                     TFalse,
00071                     TTrue
00072                 };
00073
00074                 struct  Keyword {
00075                     const CHAR *        text_ptr;
00076                     TypeId              type_id;
00077                 };
00078
00079                 inline  TypeId          GetTypeId()
00080                 const
00081                 {
00082                     return  m_type;
00083                 }
00084
00085                 inline  const String &  GetValue()
00086                 const
00087                 {
00088                     return  m_value;
00089                 }
00090
00091                 inline  BOOLEAN         IsOfType(TypeId     type_id)
00092                 const
00093                 {
00094                     return  ( type_id == m_type );
00095                 }
00096
00097                 BOOLEAN                 MatchesType(TypeId  type_id) const;
00098
00099             private:
00100                 class StrCaseCmp;
00101
00102                 enum Property {
00103                     HasDecDigits,
00104                     HasHexDigits,
00105                     HasLetters,
00106                     HasDash,
00107                     HasUnderscore,
00108                     HasWhitespace
00109                 };
00110
00111                 enum {
00112
00113                     KeywordMask = ( (1 << HasDecDigits)  |
00114                                     (1 << HasDash)       |
00115                                     (1 << HasUnderscore) |
00116                                     (1 << HasWhitespace)   ),
00117
00118                     SchemeMask  = ( (1 << HasDash)       |
00119                                     (1 << HasUnderscore) |
00120                                     (1 << HasWhitespace)   ),
00121
00122                     DecNumMask  = ( (1 << HasHexDigits)  |
00123                                     (1 << HasLetters)    |
00124                                     (1 << HasDash)       |
00125                                     (1 << HasUnderscore) |
00126                                     (1 << HasWhitespace)   ),
00127
00128                     HexNumMask  =( (1 << HasLetters)     |
00129                                    (1 << HasDash)        |
00130                                    (1 << HasUnderscore)  |
00131                                    (1 << HasWhitespace) ),
00132                 };
00133
00134                 static  const Keyword   s_keywords[];
00135
00136                 String                  m_value;
00137                 TypeId                  m_type;
00138                 BitField8               m_props;
00139
00140                 Token();
00141
00142                 void                    Reset();
00143
00144                 void                    Append(CHAR ch, Property    p);
00145
00146                 void                    SetType(TypeId  type_id);
00147                 void                    SetType();
00148         };
00149
00150         enum UrlType {
00151             UnknownUrlType,
00152             ClientUrlType,
00153             ServerUrlType
00154         };
00155
00156         enum Parameter {
00157             // Boolean parameters
00158             PAuthenticate,
00159             PAuthorize,
00160             PEncrypt,
00161             PMaster,
00162
00163             // Text parameters
00164             PName
00165         };
00166
00167         enum Result {
00168             RParsing,
00169             RSuccess,
00170             RSyntaxErr,
00171             RParameterDuplicatedErr,
00172             RParameterValueRangeErr,
00173             RSecuritySettingsErr
00174         };
00175
00177         BtJsr82Url(const String &   url_str,
00178                    UrlType          url_type = UnknownUrlType);
00179
00180         inline  Result      GetResult()
00181         const
00182         {
00183             return  m_result;
00184         }
00185
00186         inline  BOOLEAN     IsUrlValid()
00187         const
00188         {
00189             return  ( m_result == RSuccess );
00190         }
00191
00192         inline  UrlType     GetUrlType()
00193         const
00194         {
00195             return  m_url_type;
00196         }
00197
00198         BOOLEAN             GetParamValue(Parameter     param,
00199                                           BOOLEAN &     value) const;
00200
00201         BOOLEAN             GetParamValue(Parameter     param,
00202                                           String &      value) const;
00203
00211         BOOLEAN             GetBtService(BtUUID &   uuid) const;
00212
00220         BOOLEAN             GetBtAddress(BtDeviceAddress &  bt_addr) const;
00221
00226         inline  UINT8       GetBtChannel() const
00227         {
00228             return  m_channel;
00229         }
00230
00243         BOOLEAN             GetSecuritySettings(BtSecuritySettings &    ses) const;
00244
00245     private:
00246         class StringReader {
00247
00248             public:
00249                 enum {
00250                     EndOfInput = '\0'
00251                 };
00252
00253                 StringReader(const String &     input);
00254
00256                 CHAR    GetNextChar();
00257
00258             private:
00259                 String  m_input;
00260                 INT     m_pos;
00261         };
00262
00263         class Scanner {
00264             public:
00265                 Scanner(const String &  text);
00266
00267                 static  BOOLEAN     IsHexDigit(CHAR         ch)
00268                 {
00269                     return  ( Between(ch, 'a', 'f') || Between(ch, 'A', 'F') );
00270                 }
00271
00272                 static  BOOLEAN     IsAlpha(CHAR            ch)
00273                 {
00274                     return  ( Between(ch, 'a', 'z') || Between(ch, 'A', 'Z') );
00275                 }
00276
00277                 static  BOOLEAN     IsDecDigit(CHAR         ch)
00278                 {
00279                     return  Between(ch, '0', '9');
00280                 }
00281
00282                 static  BOOLEAN     HexStringToOctetSeq(UINT8 *         oct_seq_buf,
00283                                                         UINT            oct_seq_len,
00284                                                         String const &  hex_str);
00285
00286                 void                    Advance();
00287
00288                 inline  const Token &   GetToken()
00289                 {
00290                     return  m_token;
00291                 }
00292
00293             private:
00294                 StringReader        m_reader;
00295                 Token               m_token;
00296                 CHAR                m_lookahead;
00297
00298                 void    HandleCharacter(Token::Property     p);
00299                 void    HandleSeparator();
00300         };
00301
00302         Scanner             m_scanner;
00303         UrlType             m_url_type;
00304         Result              m_result;
00305         String              m_name;
00306         String              m_addr;                 //  Client: Device address
00307                                                     //  Server: UUID
00308         UINT8               m_channel;              //  Client: RFComm channel
00309         BitField8           m_param_set;
00310         BitField8           m_bool_values;          //  BOOLEAN parameter values
00311         BOOLEAN             m_is_strictly_jsr82;
00312         BOOLEAN             m_is_wildcard_url;      //  address contains '*://'
00313
00314         inline  BOOLEAN     IsParsing()
00315         const
00316         {
00317             return  ( m_result == RParsing );
00318         }
00319
00320         inline  BOOLEAN     IsStrictlyJsr82() const
00321         {
00322             return  m_is_strictly_jsr82;
00323         }
00324
00325         inline  BOOLEAN     IsWildcardUrl() const
00326         {
00327             return  m_is_wildcard_url;
00328         }
00329
00330         inline  BOOLEAN     IsBoolean(Parameter     p)
00331         const
00332         {
00333             return  ( p < PName );
00334         }
00335
00336         inline  BOOLEAN     IsText(Parameter        p)
00337         const
00338         {
00339             return  ( p >= PName );
00340         }
00341
00343         BtJsr82Url(const BtJsr82Url &);
00344         BtJsr82Url &        operator=(const BtJsr82Url &);
00345
00346         void                SetError(Result     err_code);
00347
00348         void                SetParamValue(Parameter     param,
00349                                           BOOLEAN       value);
00350
00352         void                MatchToken(Token::TypeId    t);
00353
00354         void                Parse();
00355         void                ParseProtocol();
00356         void                ParseHost();
00357         void                ParseClientHost();
00358         void                ParseServerHost();
00359         void                ParseParamList();
00360         void                ParseParameter();
00361         void                ParseBoolParam(Parameter    p);
00362         void                ParseTextParam(Parameter    p);
00363
00364         void                CheckParameter(Parameter    p);
00365         void                CheckDepSecurityParam(Parameter p);
00366 };
00367
00369 #endif  // BtJsr82Url_hpp
00370
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/JSR82/PreComp.cpp File Reference

Bluetooth/JSR82/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/JSR82/PreComp.hpp File Reference

Bluetooth/JSR82/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:19:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/JSR82/PreComp.hpp Source File

Bluetooth/JSR82/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Bluetooth/Lib.hpp>
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexAbortRequest.cpp File Reference

Bluetooth/OBEX/BtObexAbortRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"
#include "BtObexAbortRequest.hpp"

Include dependency graph for BtObexAbortRequest.cpp:

Generated on Tue Jan 24 20:14:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexAbortRequest.hpp File Reference

Bluetooth/OBEX/BtObexAbortRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>

Include dependency graph for BtObexAbortRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexAbortRequest

Defines

#define | BtObexAbortRequest_hpp

Define Documentation

#define BtObexAbortRequest_hpp

Generated on Tue Jan 24 20:14:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexAbortRequest.hpp Source File

Bluetooth/OBEX/BtObexAbortRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexAbortRequest_hpp)
00009 #define BtObexAbortRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexClientService;
00020
00023 class BtObexAbortRequest: public BtObexClientOperationRequest
00024 {
00025     private:
00026         typedef BtObexClientOperationRequest Base;
00027
00028     public:
00030         BtObexAbortRequest(BtObexClientService& obex_client_service);
00031
00033         virtual ~BtObexAbortRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040     protected:
00042
00044         virtual BOOLEAN Execute();
00045
00047
00049         virtual void ExecutionCallback(BtResultCode result);
00050
00051     private:
00053
00055         btapi_goep_operation_t* GetApiSettings();
00056
00057     private:
00059         btapi_goep_operation_t m_operation_settings;
00060
00061     private:
00062         friend class BtObexController;
00063 };
00064
00066 #endif  // BtObexAbortRequest_hpp
00067
00068
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientOperationRequest.cpp File Reference

Bluetooth/OBEX/BtObexClientOperationRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientOperationRequest.hpp"

Include dependency graph for BtObexClientOperationRequest.cpp:

Generated on Tue Jan 24 20:14:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientOperationRequest.hpp File Reference

Bluetooth/OBEX/BtObexClientOperationRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexRequest.hpp>

Include dependency graph for BtObexClientOperationRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientOperationRequest

Defines

#define | BtObexClientOperationRequest_hpp

Define Documentation

#define BtObexClientOperationRequest_hpp

Generated on Tue Jan 24 20:14:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientOperationRequest.hpp Source File

Bluetooth/OBEX/BtObexClientOperationRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexClientOperationRequest_hpp)
00009 #define BtObexClientOperationRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexController;
00020
00023 class BtObexClientOperationRequest: public BtObexRequest
00024 {
00025     private:
00026         typedef BtObexRequest Base;
00027
00028     public:
00030         BtObexClientOperationRequest(BtObexService& obex_service);
00031
00033         virtual ~BtObexClientOperationRequest();
00034
00035     public:
00037
00039         UINT8 GetResponseCode() const;
00040
00042
00044         void SetResponseCode(UINT8 response_code);
00045
00047
00049         BOOLEAN GetAborted() const;
00050
00051     protected:
00053
00055         virtual BOOLEAN GetAcceptAbort() const;
00056
00058
00060         void SetAborted(BOOLEAN aborted);
00061
00062     private:
00064         UINT8 m_response_code;
00065
00067         BOOLEAN m_aborted;
00068
00069     private:
00070         friend class BtObexController;
00071 };
00072
00074 #endif  // BtObexClientOperationRequest_hpp
00075
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientService.cpp File Reference

Bluetooth/OBEX/BtObexClientService.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"

Include dependency graph for BtObexClientService.cpp:

Defines

#define DBG_STATE

Define Documentation

#define DBG_STATE

Generated on Tue Jan 24 20:14:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientService.hpp File Reference

Bluetooth/OBEX/BtObexClientService.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientServiceObserver.hpp>
#include <Bluetooth/OBEX/BtObexRegisterClientRequest.hpp>
#include <Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp>
#include <Bluetooth/OBEX/BtObexConnectRequest.hpp>
#include <Bluetooth/OBEX/BtObexDisconnectRequest.hpp>
#include <Bluetooth/OBEX/BtObexSetPathRequest.hpp>
#include <Bluetooth/OBEX/BtObexGetRequest.hpp>
#include <Bluetooth/OBEX/BtObexPutRequest.hpp>
#include <Bluetooth/OBEX/BtObexAbortRequest.hpp>
#include <Bluetooth/OBEX/BtObexService.hpp>

Include dependency graph for BtObexClientService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientService

Defines

#define | BtObexClientService_hpp

Define Documentation

#define BtObexClientService_hpp

Generated on Tue Jan 24 20:14:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientService.hpp Source File

Bluetooth/OBEX/BtObexClientService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexClientService_hpp)
00009 #define BtObexClientService_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexClientServiceObserver.hpp>
00014 #include <Bluetooth/OBEX/BtObexRegisterClientRequest.hpp>
00015 #include <Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp>
00016 #include <Bluetooth/OBEX/BtObexConnectRequest.hpp>
00017 #include <Bluetooth/OBEX/BtObexDisconnectRequest.hpp>
00018 #include <Bluetooth/OBEX/BtObexSetPathRequest.hpp>
00019 #include <Bluetooth/OBEX/BtObexGetRequest.hpp>
00020 #include <Bluetooth/OBEX/BtObexPutRequest.hpp>
00021 #include <Bluetooth/OBEX/BtObexAbortRequest.hpp>
00022 #include <Bluetooth/OBEX/BtObexService.hpp>
00023
00026 class BtObexClientService: public BtObexService
00027 {
00028     private:
00029         typedef BtObexService Base;
00030
00031     public:
00033         BtObexClientService();
00034
00036         virtual ~BtObexClientService();
00037
00039
00041         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00042
00044
00046         virtual BOOLEAN IsServerService() const;
00047
00049
00051         BOOLEAN IsConnected() const;
00052
00054
00056         UINT8 GetRfComPort() const;
00057
00059
00061         void SetRfComPort(UINT8 rf_com_port);
00062
00064
00066         virtual BtRequestState RegisterRequest(UINT8* header_buffer, UINT16 header_buffer_size, BtSecuritySettings security_settings = BtSesNoSecurity);
00067
00069
00071         virtual BtRequestState UnregisterRequest();
00072
00074
00076         BtRequestState ConnectRequest();
00077
00079
00081         BtRequestState DisconnectRequest();
00082
00084
00086         BtRequestState SetPathRequest(BOOLEAN backup, BOOLEAN create);
00087
00089
00091         BtRequestState GetRequest();
00092
00094
00096         BtRequestState PutRequest(BOOLEAN delete_object, BOOLEAN create_empty_object);
00097
00099
00101         BtRequestState AbortRequest();
00102
00104
00106         BOOLEAN DataReadyIndication(const UINT8* data, UINT16 data_size, BOOLEAN more_data_pending = FALSE);
00107
00109
00111         BOOLEAN DataBufferIndication(UINT8* data_buffer, UINT16 data_buffer_size);
00112
00113     public:
00115
00117         BOOLEAN Attach(BtObexClientServiceObserver* service_observer);
00118
00120
00122         BOOLEAN Detach(BtObexClientServiceObserver* service_observer);
00123
00124 #ifdef _DEBUG
00125     protected:
00127
00129         virtual void DebugState();
00130 #endif /* DEBUG */
00131
00132     private:
00134
00136         void RegisterCallback(BtResultCode result);
00137
00139
00141         void ConnectCallback(BtResultCode result);
00142
00144
00146         void DisconnectCallback(BtResultCode result);
00147
00149
00151         void SetPathCallback(BtResultCode result);
00152
00154
00156         void GetCallback(BtResultCode result);
00157
00159
00161         void PutCallback(BtResultCode result);
00162
00164
00166         void AbortCallback(BtResultCode result);
00167
00168     private:
00170         UINT8 m_rf_com_port;
00171
00173         BtObexRegisterClientRequest m_register_client_request;
00174
00176         BtObexUnregisterClientRequest m_unregister_client_request;
00177
00179         BtObexConnectRequest m_connect_request;
00180
00182         BtObexDisconnectRequest m_disconnect_request;
00183
00185         BtObexSetPathRequest m_set_path_request;
00186
00188         BtObexGetRequest m_get_request;
00189
00191         BtObexPutRequest m_put_request;
00192
00194         BtObexAbortRequest m_abort_request;
00195
00196     private:
00197         friend class BtObexRegisterClientRequest;
00198         friend class BtObexUnregisterClientRequest;
00199         friend class BtObexConnectRequest;
00200         friend class BtObexDisconnectRequest;
00201         friend class BtObexSetPathRequest;
00202         friend class BtObexGetRequest;
00203         friend class BtObexPutRequest;
00204         friend class BtObexAbortRequest;
00205 };
00206
00208 #endif  // BtObexClientService_hpp
00209
00210
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientServiceObserver.cpp File Reference

Bluetooth/OBEX/BtObexClientServiceObserver.cpp File Reference

#include "PreComp.hpp"
#include "BtObexEvent.hpp"
#include "BtObexClientServiceObserver.hpp"

Include dependency graph for BtObexClientServiceObserver.cpp:

Generated on Tue Jan 24 20:14:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientServiceObserver.hpp File Reference

Bluetooth/OBEX/BtObexClientServiceObserver.hpp File Reference

#include <Bluetooth/OBEX/BtObexServiceObserver.hpp>

Include dependency graph for BtObexClientServiceObserver.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientServiceObserver

Defines

#define | BtObexClientServiceObserver_hpp

Define Documentation

#define BtObexClientServiceObserver_hpp

Generated on Tue Jan 24 20:14:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexClientServiceObserver.hpp Source File

Bluetooth/OBEX/BtObexClientServiceObserver.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 /*  ------------------------------------------------------------------------
00009     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00010     ------------------------------------------------------------------------
00011     This document contains proprietary information belonging to COMNEON.
00012     Passing on and copying of this document, use and communication of its
00013     contents is not permitted without prior written authorisation.
00014     ------------------------------------------------------------------------ */
00015 #if !defined(BtObexClientServiceObserver_hpp)
00016 #define BtObexClientServiceObserver_hpp
00019
00020 #include <Bluetooth/OBEX/BtObexServiceObserver.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     Forward deklarations for friend relationships.
00024     ------------------------------------------------------------------------ */
00025
00026 class BtObexClientService;
00027
00030 class BtObexClientServiceObserver: public BtObexServiceObserver
00031 {
00032     private:
00033         typedef BtObexServiceObserver Base;
00034
00035     public:
00037         BtObexClientServiceObserver();
00038
00040         virtual ~BtObexClientServiceObserver();
00041
00042     protected:
00044
00046         virtual void OnEvent(const BtEvent& event);
00047
00049
00051         virtual void OnRegister(BtResultCode code) = 0;
00052
00054
00056         virtual void OnConnect(BtResultCode code, UINT8 response_code) = 0;
00057
00059
00061         virtual void OnDisconnect(BtResultCode code, UINT8 response_code) = 0;
00062
00064
00066         virtual void OnSetPath(BtResultCode code, UINT8 response_code) = 0;
00067
00069
00071         virtual void OnGet(BtResultCode code, UINT8 response_code) = 0;
00072
00074
00076         virtual void OnPut(BtResultCode code, UINT8 response_code) = 0;
00077
00079
00081         virtual void OnAbort(BtResultCode code, UINT8 response_code) = 0;
00082
00083     private:
00084         friend class BtObexClientService;
00085 };
00086
00088 #endif  // BtObexClientServiceObserver_hpp
00089
00090
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexConnectRequest.cpp File Reference

Bluetooth/OBEX/BtObexConnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"
#include "BtObexConnectRequest.hpp"

Include dependency graph for BtObexConnectRequest.cpp:

Generated on Tue Jan 24 20:14:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexConnectRequest.hpp File Reference

Bluetooth/OBEX/BtObexConnectRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>

Include dependency graph for BtObexConnectRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexConnectRequest

Defines

#define | BtObexConnectRequest_hpp

Define Documentation

#define BtObexConnectRequest_hpp

Generated on Tue Jan 24 20:14:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexConnectRequest.hpp Source File

Bluetooth/OBEX/BtObexConnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexConnectRequest_hpp)
00009 #define BtObexConnectRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexClientService;
00020
00023 class BtObexConnectRequest: public BtObexClientOperationRequest
00024 {
00025     private:
00026         typedef BtObexClientOperationRequest Base;
00027
00028     public:
00030         BtObexConnectRequest(BtObexClientService& obex_client_service);
00031
00033         virtual ~BtObexConnectRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00041
00043         BtDevice GetTargetDevice() const;
00044
00046
00048         void SetTargetDevice(const BtDevice& target_device);
00049
00051
00053         UINT8 GetRfComPort() const;
00054
00056
00058         void SetRfComPort(UINT8 rfcom_port);
00059
00060     protected:
00062
00064         virtual BOOLEAN Execute();
00065
00067
00069         virtual void ExecutionCallback(BtResultCode result);
00070
00071     private:
00073
00075         btapi_goep_operation_t* GetApiSettings();
00076
00077     private:
00079         btapi_goep_operation_t m_operation_settings;
00080
00081     private:
00082         friend class BtObexController;
00083 };
00084
00086 #endif  // BtObexConnectRequest_hpp
00087
00088
Generated on Tue Jan 24 14:49:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexController.cpp File Reference

Bluetooth/OBEX/BtObexController.cpp File Reference

#include "PreComp.hpp"
#include "BtObexController.hpp"
#include "BtObexRegisterServerRequest.hpp"
#include "BtObexUnregisterServerRequest.hpp"
#include "BtObexRegisterClientRequest.hpp"
#include "BtObexUnregisterClientRequest.hpp"
#include "BtObexConnectRequest.hpp"
#include "BtObexDisconnectRequest.hpp"
#include "BtObexSetPathRequest.hpp"
#include "BtObexGetRequest.hpp"
#include "BtObexPutRequest.hpp"
#include "BtObexAbortRequest.hpp"
#include "BtObexServerService.hpp"
#include <stdio.h>

Include dependency graph for BtObexController.cpp:

Defines

#define DBG_STATE

Define Documentation

#define DBG_STATE

Generated on Tue Jan 24 20:14:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexController.hpp File Reference

Bluetooth/OBEX/BtObexController.hpp File Reference

#include <stack/extensions.h>
#include <Bluetooth/BtMultiConnectionController.hpp>

Include dependency graph for BtObexController.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexController
class | BtObexController::BtObexConnection

Defines

#define | BtObexController_hpp

Define Documentation

#define BtObexController_hpp

Generated on Tue Jan 24 20:14:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexController.hpp Source File

Bluetooth/OBEX/BtObexController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexController_hpp)
00009 #define BtObexController_hpp
00012
00013 #include <stack/extensions.h>
00014 #include <Bluetooth/BtMultiConnectionController.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00020 class BtObexService;
00021 class BtObexServerService;
00022 class BtObexClientService;
00023 class BtObexRegisterServerRequest;
00024 class BtObexUnregisterServerRequest;
00025 class BtObexSendResponseRequest;
00026 class BtObexRegisterClientRequest;
00027 class BtObexUnregisterClientRequest;
00028 class BtObexConnectRequest;
00029 class BtObexDisconnectRequest;
00030 class BtObexSetPathRequest;
00031 class BtObexGetRequest;
00032 class BtObexPutRequest;
00033 class BtObexAbortRequest;
00034
00038 class BtObexController: public BtMultiConnectionController
00039 {
00040     private:
00041         typedef BtMultiConnectionController Base;
00042
00043     public:
00045
00050         static BtObexController& GetInstance();
00051
00052     public:
00054         virtual ~BtObexController();
00055
00057
00059         virtual const WCHAR* GetName() const;
00060
00061     protected:
00063
00065         BOOLEAN ObexRegisterServerRequest(BtObexRegisterServerRequest* register_request);
00066
00068
00070         BOOLEAN ObexUnregisterServerRequest(BtObexUnregisterServerRequest* unregister_request);
00071
00072 //      ///
00073 //      /**
00074 //      */
00075 //      BOOLEAN ObexSendResponseRequest(BtObexSendResponseRequest* send_response_request);
00076
00078
00080         BOOLEAN ObexRegisterClientRequest(BtObexRegisterClientRequest* register_request);
00081
00083
00085         BOOLEAN ObexUnregisterClientRequest(BtObexUnregisterClientRequest* unregister_request);
00086
00088
00090         BOOLEAN ObexConnectRequest(BtObexConnectRequest* connect_request);
00091
00093
00095         BOOLEAN ObexDisconnectRequest(BtObexDisconnectRequest* disconnect_request);
00096
00098
00100         BOOLEAN ObexSetPathRequest(BtObexSetPathRequest* set_path_request);
00101
00103
00105         BOOLEAN ObexGetRequest(BtObexGetRequest* get_request);
00106
00108
00110         BOOLEAN ObexPutRequest(BtObexPutRequest* put_request);
00111
00113
00115         BOOLEAN ObexAbortRequest(BtObexAbortRequest* abort_request);
00116
00118
00120         BOOLEAN ObexAddHeader(const BtObexService* obex_service, UINT8 header_id, UINT8 header_value);
00121
00123
00125         BOOLEAN ObexAddHeader(const BtObexService* obex_service, UINT8 header_id, UINT32 header_value);
00126
00128
00130         BOOLEAN ObexAddHeader(const BtObexService* obex_service, UINT8 header_id, UINT8* header_value, UINT16 header_value_length);
00131
00133
00135         BOOLEAN ObexAddHeader(const BtObexService* obex_service, UINT8 header_id, WString header_value);
00136
00138
00140         BOOLEAN ObexDiscardHeaders(const BtObexService* obex_service);
00141
00143
00145         BOOLEAN ObexGetFreeSize(const BtObexService* obex_service, UINT16 &bytes_free);
00146
00148
00150         BOOLEAN ObexSendResponse(const BtObexService* obex_service, UINT8 response_code);
00151
00153
00155         BOOLEAN ObexDataBufferIndication(const BtObexService* obex_service, UINT8* data_buffer, UINT16 data_buffer_size, UINT8 response_code);
00156
00158
00160         BOOLEAN ObexDataIndication(const BtObexService* obex_service, const UINT8* data, UINT16 data_size, BOOLEAN more_data_pending, UINT8 response_code);
00161
00162     private:
00163         /*---------------------------------------------------------------------*/
00164         /* The following functions must not be called by an application.       */
00165         /* They are the entry point from the stack callback functions into our */
00166         /* object orientated framework (APOXI).                                */
00167         /* They are implemented as static because they have to be passed as    */
00168         /* normal C function pointers. The reason for this is the BT-API Stack */
00169         /* interface that demands C function pointers for callback the         */
00170         /* callback functions it calls to state the progress of ongoing        */
00171         /* operations                                                          */
00172         /*---------------------------------------------------------------------*/
00173
00175
00177         static void OnObexErrorCallback(btapi_result_t result, const btapi_goep_error_t* error);
00178
00180
00182         void OnObexError(BtResultCode result, const btapi_goep_error_t* error);
00183
00185
00187         static void OnObexRegisterCallback(btapi_result_t result, const btapi_goep_register_t* registration_info);
00188
00190
00192         void OnObexRegister(BtResultCode result, const btapi_goep_register_t* registration_info);
00193
00195
00197         static void OnObexGetDataCallback(btapi_result_t result, void* apoxi_handle);
00198
00200
00202         void OnObexGetData(BtResultCode result, void* apoxi_handle);
00203
00205
00207         static void OnObexHeaderInidicationCallback(btapi_result_t result, const btapi_goep_header_ind_t* header_indication);
00208
00210
00212         void OnObexHeaderInidication(BtResultCode result, const btapi_goep_header_ind_t* header_indication);
00213
00215
00217         static void OnObexHeaderSentCallback(btapi_result_t result, void* apoxi_handle);
00218
00220
00222         void OnObexHeaderSent(BtResultCode result, void* apoxi_handle);
00223
00225
00227         static void OnObexResponseIndicationCallback(btapi_result_t result, const btapi_goep_rsp_t* response_indication);
00228
00230
00232         void OnObexResponseIndication(BtResultCode result, const btapi_goep_rsp_t* response_indication);
00233
00235
00237         static void OnObexGetBufferCallback(btapi_result_t result, const btapi_goep_getbuffer_t* get_buffer_description);
00238
00240
00242         void OnObexGetBuffer(BtResultCode result, const btapi_goep_getbuffer_t* get_buffer_description);
00243
00245
00247         static void OnObexOperationIndicationCallback(btapi_result_t result, const btapi_goep_operation_ind_t* operation_indication);
00248
00250
00252         void OnObexOperationIndication(BtResultCode result, const btapi_goep_operation_ind_t* operation_indication);
00253
00255
00257         static void OnObexTransportDisconnectCallback(btapi_result_t result, void* apoxi_handle);
00258
00260
00262         void OnObexTransportDisconnect(BtResultCode result, void* apoxi_handle);
00263
00264     private:
00266         BtObexController();
00267
00269
00271         virtual void Register();
00272
00274
00276         virtual void Unregister();
00277
00279
00281         BOOLEAN PrepareAbortRequestExecution(void* apoxi_handle, BtObexAbortRequest* request);
00282
00284
00286         BtObexAbortRequest* CleanUpAbortRequestExecution(void* apoxi_handle, BtResultCode result_code);
00287
00288     protected:
00291         class BtObexConnection: public BtMultiConnectionController::BtConnection
00292         {
00293             private:
00294                 typedef BtMultiConnectionController::BtConnection Base;
00295
00296             public:
00298                 BtObexConnection();
00299
00301                 virtual ~BtObexConnection();
00302
00304
00306                 btapi_goep_handle_t GetObexHandle() const;
00307
00309
00311                 void SetObexHandle(btapi_goep_handle_t obex_handle);
00312
00314
00316                 BOOLEAN GetIsServer() const;
00317
00319
00321                 void SetIsServer(BOOLEAN is_server);
00322
00324
00326                 BtObexAbortRequest* GetRunningAbortRequest() const;
00327
00329
00331                 void SetRunningAbortRequest(BtObexAbortRequest* request);
00332
00333             private:
00335                 btapi_goep_handle_t m_obex_handle;
00336
00338                 BOOLEAN m_is_server;
00339
00341                 BtObexAbortRequest* m_abort_request;
00342         };
00343
00344     private:
00346
00348         BtObexConnection* FindConnectionByObexHandle(btapi_goep_handle_t obex_handle) const;
00349
00351
00353         btapi_goep_handle_t GetObexHandle(const void* apoxi_handle);
00354
00355 #ifdef _DEBUG
00356     private:
00358
00360         void DebugState();
00361 #endif /* _DEBUG */
00362
00363     private:
00365         btapi_goepcb_funp_t* m_obex_callback_functions;
00366
00367     private:
00369         static BtObexController m_controller;
00370
00371     private:
00372         friend class BtObexService;
00373         friend class BtObexServerService;
00374         friend class BtObexClientService;
00375         friend class BtObexRegisterServerRequest;
00376         friend class BtObexUnregisterServerRequest;
00377         friend class BtObexSendResponseRequest;
00378         friend class BtObexRegisterClientRequest;
00379         friend class BtObexUnregisterClientRequest;
00380         friend class BtObexConnectRequest;
00381         friend class BtObexDisconnectRequest;
00382         friend class BtObexSetPathRequest;
00383         friend class BtObexGetRequest;
00384         friend class BtObexPutRequest;
00385         friend class BtObexAbortRequest;
00386 };
00387
00389 #endif  // BtObexController_hpp
00390
Generated on Tue Jan 24 14:49:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexDisconnectRequest.cpp File Reference

Bluetooth/OBEX/BtObexDisconnectRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"
#include "BtObexDisconnectRequest.hpp"

Include dependency graph for BtObexDisconnectRequest.cpp:

Generated on Tue Jan 24 20:14:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexDisconnectRequest.hpp File Reference

Bluetooth/OBEX/BtObexDisconnectRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>

Include dependency graph for BtObexDisconnectRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexDisconnectRequest

Defines

#define | BtObexDisconnectRequest_hpp

Define Documentation

#define BtObexDisconnectRequest_hpp

Generated on Tue Jan 24 20:14:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexDisconnectRequest.hpp Source File

Bluetooth/OBEX/BtObexDisconnectRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexDisconnectRequest_hpp)
00009 #define BtObexDisconnectRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexClientService;
00020
00023 class BtObexDisconnectRequest: public BtObexClientOperationRequest
00024 {
00025     private:
00026         typedef BtObexClientOperationRequest Base;
00027
00028     public:
00030         BtObexDisconnectRequest(BtObexClientService& obex_client_service);
00031
00033         virtual ~BtObexDisconnectRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040     protected:
00042
00044         virtual BOOLEAN Execute();
00045
00047
00049         virtual void ExecutionCallback(BtResultCode result);
00050
00051     private:
00053
00055         btapi_goep_operation_t* GetApiSettings();
00056
00057     private:
00059         btapi_goep_operation_t m_operation_settings;
00060
00061     private:
00062         friend class BtObexController;
00063 };
00064
00066 #endif  // BtObexDisconnectRequest_hpp
00067
00068
Generated on Tue Jan 24 14:49:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexEvent.cpp File Reference

Bluetooth/OBEX/BtObexEvent.cpp File Reference

#include "PreComp.hpp"
#include "BtObexEvent.hpp"

Include dependency graph for BtObexEvent.cpp:

Generated on Tue Jan 24 20:14:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexEvent.hpp File Reference

Bluetooth/OBEX/BtObexEvent.hpp File Reference

#include <Bluetooth/BtEvent.hpp>
#include <Bluetooth/OBEX/BtTypes.hpp>

Include dependency graph for BtObexEvent.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientAbortEvent
class | BtObexClientConnectEvent
class | BtObexClientDisconnectEvent
class | BtObexClientEvent
class | BtObexClientGetEvent
class | BtObexClientOperationEvent
class | BtObexClientPutEvent
class | BtObexClientSetPathEvent
class | BtObexDataBufferIndicationEvent
class | BtObexDataIndicationEvent
class | BtObexEvent
class | BtObexHeaderIndicationEvent
class | BtObexHeaderSentEvent
class | BtObexRegisterClientEvent
class | BtObexRegisterServerEvent
class | BtObexServerAbortIndicationEvent
class | BtObexServerConnectIndicationEvent
class | BtObexServerDisconnectIndicationEvent
class | BtObexServerEvent
class | BtObexServerGetIndicationEvent
class | BtObexServerPutIndicationEvent
class | BtObexServerSetPathIndicationEvent
class | BtObexTransportDisconnectEvent
class | BtObexUnregisterEvent

Defines

#define | BtObexEvent_hpp

Define Documentation

#define BtObexEvent_hpp

Generated on Tue Jan 24 20:14:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexEvent.hpp Source File

Bluetooth/OBEX/BtObexEvent.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexEvent_hpp)
00009 #define BtObexEvent_hpp
00012
00013 #include <Bluetooth/BtEvent.hpp>
00014 #include <Bluetooth/OBEX/BtTypes.hpp>
00015
00018 class BtObexEvent: public BtEvent
00019 {
00020     private:
00021         typedef BtEvent Base;
00022
00023     public:
00025         BtObexEvent(BtResultCode result);
00026
00028         virtual ~BtObexEvent();
00029 };
00030
00033 class BtObexUnregisterEvent: public BtObexEvent
00034 {
00035     private:
00036         typedef BtObexEvent Base;
00037
00038     public:
00040         BtObexUnregisterEvent(BtResultCode result);
00041
00043         virtual ~BtObexUnregisterEvent();
00044
00045     public:
00047
00049         virtual UINT16 GetId() const;
00050
00051     public:
00052         enum { ID = 1 };
00053 };
00054
00057 class BtObexHeaderIndicationEvent: public BtObexEvent
00058 {
00059     private:
00060         typedef BtObexEvent Base;
00061
00062     public:
00064         BtObexHeaderIndicationEvent(BtResultCode result, const BtObexHeader& header);
00065
00067         virtual ~BtObexHeaderIndicationEvent();
00068
00070
00072         const BtObexHeader& GetHeader() const;
00073
00074     public:
00076
00078         virtual UINT16 GetId() const;
00079
00080     public:
00081         enum { ID = 2 };
00082
00083     private:
00085         const BtObexHeader& m_header;
00086 };
00087
00090 class BtObexHeaderSentEvent: public BtObexEvent
00091 {
00092     private:
00093         typedef BtObexEvent Base;
00094
00095     public:
00097         BtObexHeaderSentEvent(BtResultCode result);
00098
00100         virtual ~BtObexHeaderSentEvent();
00101
00102     public:
00104
00106         virtual UINT16 GetId() const;
00107
00108     public:
00109         enum { ID = 3 };
00110 };
00111
00114 class BtObexDataBufferIndicationEvent: public BtObexEvent
00115 {
00116     private:
00117         typedef BtObexEvent Base;
00118
00119     public:
00121         BtObexDataBufferIndicationEvent(BtResultCode result, UINT16 last_buffer_filled, BOOLEAN delete_object, BOOLEAN create_empty_object);
00122
00124         virtual ~BtObexDataBufferIndicationEvent();
00125
00127
00129         UINT16 GetLastBufferFilled() const;
00130
00132
00134         BOOLEAN GetDeleteObect() const;
00135
00137
00139         BOOLEAN GetCreateEmptyObject() const;
00140
00141     public:
00143
00145         virtual UINT16 GetId() const;
00146
00147     public:
00148         enum { ID = 4 };
00149
00150     private:
00152         UINT16 m_last_buffer_filled;
00153
00155         BOOLEAN m_delete_object;
00156
00158         BOOLEAN m_create_empty_object;
00159 };
00160
00163 class BtObexDataIndicationEvent: public BtObexEvent
00164 {
00165     private:
00166         typedef BtObexEvent Base;
00167
00168     public:
00170         BtObexDataIndicationEvent(BtResultCode result);
00171
00173         virtual ~BtObexDataIndicationEvent();
00174
00175     public:
00177
00179         virtual UINT16 GetId() const;
00180
00181     public:
00182         enum { ID = 5 };
00183 };
00184
00187 class BtObexTransportDisconnectEvent: public BtObexEvent
00188 {
00189     private:
00190         typedef BtObexEvent Base;
00191
00192     public:
00194         BtObexTransportDisconnectEvent(BtResultCode result);
00195
00197         virtual ~BtObexTransportDisconnectEvent();
00198
00199     public:
00201
00203         virtual UINT16 GetId() const;
00204
00205     public:
00206         enum { ID = 6 };
00207 };
00208
00211 class BtObexServerEvent: public BtObexEvent
00212 {
00213     private:
00214         typedef BtObexEvent Base;
00215
00216     public:
00218         BtObexServerEvent(BtResultCode result);
00219
00221         virtual ~BtObexServerEvent();
00222 };
00223
00226 class BtObexRegisterServerEvent: public BtObexServerEvent
00227 {
00228     private:
00229         typedef BtObexServerEvent Base;
00230
00231     public:
00233         BtObexRegisterServerEvent(BtResultCode result, UINT8 rfcom_channel);
00234
00236         virtual ~BtObexRegisterServerEvent();
00237
00239
00241         UINT8 GetRfComChannel() const;
00242
00243     public:
00245
00247         virtual UINT16 GetId() const;
00248
00249     public:
00250         enum { ID = 7 };
00251
00252     private:
00254         UINT8 m_rfcom_channel;
00255 };
00256
00259 class BtObexServerConnectIndicationEvent: public BtObexServerEvent
00260 {
00261     private:
00262         typedef BtObexServerEvent Base;
00263
00264     public:
00266         BtObexServerConnectIndicationEvent(BtResultCode result, const BtDevice& device);
00267
00269         virtual ~BtObexServerConnectIndicationEvent();
00270
00272
00274         const BtDevice& GetDevice() const;
00275
00276     public:
00278
00280         virtual UINT16 GetId() const;
00281
00282     public:
00283         enum { ID = 8 };
00284
00285     private:
00287         BtDevice m_device;
00288 };
00289
00292 class BtObexServerDisconnectIndicationEvent: public BtObexServerEvent
00293 {
00294     private:
00295         typedef BtObexServerEvent Base;
00296
00297     public:
00299         BtObexServerDisconnectIndicationEvent(BtResultCode result);
00300
00302         virtual ~BtObexServerDisconnectIndicationEvent();
00303
00304     public:
00306
00308         virtual UINT16 GetId() const;
00309
00310     public:
00311         enum { ID = 9 };
00312 };
00313
00314
00317 class BtObexServerSetPathIndicationEvent: public BtObexServerEvent
00318 {
00319     private:
00320         typedef BtObexServerEvent Base;
00321
00322     public:
00324         BtObexServerSetPathIndicationEvent(BtResultCode result, BOOLEAN backup, BOOLEAN create);
00325
00327         virtual ~BtObexServerSetPathIndicationEvent();
00328
00329     public:
00331
00333         virtual UINT16 GetId() const;
00334
00336
00338         BOOLEAN GetBackup() const;
00339
00341
00343         BOOLEAN GetCreate() const;
00344
00345     public:
00346         enum { ID = 10 };
00347
00348     private:
00350         BOOLEAN m_backup;
00351
00353         BOOLEAN m_create;
00354 };
00355
00358 class BtObexServerGetIndicationEvent: public BtObexServerEvent
00359 {
00360     private:
00361         typedef BtObexServerEvent Base;
00362
00363     public:
00365         BtObexServerGetIndicationEvent(BtResultCode result);
00366
00368         virtual ~BtObexServerGetIndicationEvent();
00369
00370     public:
00372
00374         virtual UINT16 GetId() const;
00375
00376     public:
00377         enum { ID = 11 };
00378 };
00379
00382 class BtObexServerPutIndicationEvent: public BtObexServerEvent
00383 {
00384     private:
00385         typedef BtObexServerEvent Base;
00386
00387     public:
00389         BtObexServerPutIndicationEvent(BtResultCode result);
00390
00392         virtual ~BtObexServerPutIndicationEvent();
00393
00394     public:
00396
00398         virtual UINT16 GetId() const;
00399
00400     public:
00401         enum { ID = 12 };
00402 };
00403
00406 class BtObexServerAbortIndicationEvent: public BtObexServerEvent
00407 {
00408     private:
00409         typedef BtObexServerEvent Base;
00410
00411     public:
00413         BtObexServerAbortIndicationEvent(BtResultCode result);
00414
00416         virtual ~BtObexServerAbortIndicationEvent();
00417
00418     public:
00420
00422         virtual UINT16 GetId() const;
00423
00424     public:
00425         enum { ID = 13 };
00426 };
00427
00430 class BtObexClientEvent: public BtObexEvent
00431 {
00432     private:
00433         typedef BtObexEvent Base;
00434
00435     public:
00437         BtObexClientEvent(BtResultCode result);
00438
00440         virtual ~BtObexClientEvent();
00441 };
00442
00443 class BtObexRegisterClientEvent: public BtObexClientEvent
00444 {
00445     private:
00446         typedef BtObexClientEvent Base;
00447
00448     public:
00450         BtObexRegisterClientEvent(BtResultCode result);
00451
00453         virtual ~BtObexRegisterClientEvent();
00454
00455     public:
00457
00459         virtual UINT16 GetId() const;
00460
00461     public:
00462         enum { ID = 14 };
00463
00464     private:
00466         UINT8 m_rfcom_channel;
00467 };
00468
00471 class BtObexClientOperationEvent: public BtObexClientEvent
00472 {
00473     private:
00474         typedef BtObexClientEvent Base;
00475
00476     public:
00478         BtObexClientOperationEvent(BtResultCode result, UINT8 response_code);
00479
00481         virtual ~BtObexClientOperationEvent();
00482
00483     public:
00485
00487         UINT8 GetResponseCode() const;
00488
00489     private:
00491         UINT8 m_response_code;
00492 };
00493
00496 class BtObexClientConnectEvent: public BtObexClientOperationEvent
00497 {
00498     private:
00499         typedef BtObexClientOperationEvent Base;
00500
00501     public:
00503         BtObexClientConnectEvent(BtResultCode result, UINT8 response_code);
00504
00506         virtual ~BtObexClientConnectEvent();
00507
00508     public:
00510
00512         virtual UINT16 GetId() const;
00513
00514     public:
00515         enum { ID = 15 };
00516 };
00517
00520 class BtObexClientDisconnectEvent: public BtObexClientOperationEvent
00521 {
00522     private:
00523         typedef BtObexClientOperationEvent Base;
00524
00525     public:
00527         BtObexClientDisconnectEvent(BtResultCode result, UINT8 response_code);
00528
00530         virtual ~BtObexClientDisconnectEvent();
00531
00532     public:
00534
00536         virtual UINT16 GetId() const;
00537
00538     public:
00539         enum { ID = 16 };
00540 };
00541
00544 class BtObexClientSetPathEvent: public BtObexClientOperationEvent
00545 {
00546     private:
00547         typedef BtObexClientOperationEvent Base;
00548
00549     public:
00551         BtObexClientSetPathEvent(BtResultCode result, UINT8 response_code);
00552
00554         virtual ~BtObexClientSetPathEvent();
00555
00556     public:
00558
00560         virtual UINT16 GetId() const;
00561
00562     public:
00563         enum { ID = 17 };
00564 };
00565
00568 class BtObexClientGetEvent: public BtObexClientOperationEvent
00569 {
00570     private:
00571         typedef BtObexClientOperationEvent Base;
00572
00573     public:
00575         BtObexClientGetEvent(BtResultCode result, UINT8 response_code);
00576
00578         virtual ~BtObexClientGetEvent();
00579
00580     public:
00582
00584         virtual UINT16 GetId() const;
00585
00586     public:
00587         enum { ID = 18 };
00588 };
00589
00592 class BtObexClientPutEvent: public BtObexClientOperationEvent
00593 {
00594     private:
00595         typedef BtObexClientOperationEvent Base;
00596
00597     public:
00599         BtObexClientPutEvent(BtResultCode result, UINT8 response_code);
00600
00602         virtual ~BtObexClientPutEvent();
00603
00604     public:
00606
00608         virtual UINT16 GetId() const;
00609
00610     public:
00611         enum { ID = 19 };
00612 };
00613
00616 class BtObexClientAbortEvent: public BtObexClientOperationEvent
00617 {
00618     private:
00619         typedef BtObexClientOperationEvent Base;
00620
00621     public:
00623         BtObexClientAbortEvent(BtResultCode resul, UINT8 response_code);
00624
00626         virtual ~BtObexClientAbortEvent();
00627
00628     public:
00630
00632         virtual UINT16 GetId() const;
00633
00634     public:
00635         enum { ID = 20 };
00636 };
00637
00639 #endif  // BtObexEvent_hpp
00640
00641
Generated on Tue Jan 24 14:49:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexGetRequest.cpp File Reference

Bluetooth/OBEX/BtObexGetRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"
#include "BtObexGetRequest.hpp"

Include dependency graph for BtObexGetRequest.cpp:

Generated on Tue Jan 24 20:14:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexGetRequest.hpp File Reference

Bluetooth/OBEX/BtObexGetRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>

Include dependency graph for BtObexGetRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexGetRequest

Defines

#define | BtObexGetRequest_hpp

Define Documentation

#define BtObexGetRequest_hpp

Generated on Tue Jan 24 20:14:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexGetRequest.hpp Source File

Bluetooth/OBEX/BtObexGetRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexGetRequest_hpp)
00009 #define BtObexGetRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexClientService;
00020
00023 class BtObexGetRequest: public BtObexClientOperationRequest
00024 {
00025     private:
00026         typedef BtObexClientOperationRequest Base;
00027
00028     public:
00030         BtObexGetRequest(BtObexClientService& obex_client_service);
00031
00033         virtual ~BtObexGetRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00040     protected:
00042
00044         virtual BOOLEAN Execute();
00045
00047
00049         virtual void ExecutionCallback(BtResultCode result);
00050
00052
00054         virtual BOOLEAN GetAcceptAbort() const;
00055
00056     private:
00058
00060         btapi_goep_operation_t* GetApiSettings();
00061
00062     private:
00064         btapi_goep_operation_t m_operation_settings;
00065
00066     private:
00067         friend class BtObexController;
00068 };
00069
00071 #endif  // BtObexGetRequest_hpp
00072
00073
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexMessageArguments.cpp File Reference

Bluetooth/OBEX/BtObexMessageArguments.cpp File Reference

#include "PreComp.hpp"
#include "BtObexMessageArguments.hpp"

Include dependency graph for BtObexMessageArguments.cpp:

Generated on Tue Jan 24 20:14:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexMessageArguments.hpp File Reference

Bluetooth/OBEX/BtObexMessageArguments.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Include dependency graph for BtObexMessageArguments.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexMessageArgumentsDestroyTableNode

Defines

#define | Bluetooth_BtObexMessageArguments_hpp

Define Documentation

#define Bluetooth_BtObexMessageArguments_hpp

Generated on Tue Jan 24 20:14:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexMessageArguments.hpp Source File

Bluetooth/OBEX/BtObexMessageArguments.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXITEST_20_10_06-2_SV\lnz_apoxi\Apoxi\Bluetooth\OBEX\BtObexNotificationMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtObexMessageArguments_hpp)
00016 #define Bluetooth_BtObexMessageArguments_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class BtObexMessageArgumentsDestroyTableNode
00028     ====================================================================== */
00029
00030 class BtObexMessageArgumentsDestroyTableNode : public StackMsgArgDestroyTableNode {
00031     public:
00032
00033         static BtObexMessageArgumentsDestroyTableNode* GetInstance();
00034
00035     private:
00036         BtObexMessageArgumentsDestroyTableNode();
00037
00038
00039         static BtObexMessageArgumentsDestroyTableNode* m_node;
00040         static const ArgumentDestroyEntry m_destroy_table[];
00041
00042     };
00043
00044 #endif // Bluetooth_BtObexMessageArguments_hpp
00045
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexNotificationMessage.cpp File Reference

Bluetooth/OBEX/BtObexNotificationMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtObexNotificationMessage.hpp"

Include dependency graph for BtObexNotificationMessage.cpp:

Generated on Tue Jan 24 20:14:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexNotificationMessage.hpp File Reference

Bluetooth/OBEX/BtObexNotificationMessage.hpp File Reference

#include <Apc/Message.hpp>
#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/OBEX/BtObexServerService.hpp>
#include <Bluetooth/OBEX/BtObexClientService.hpp>

Include dependency graph for BtObexNotificationMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientNotificationMessage
class | BtObexServerNotificationMessage

Defines

#define | BtObexServerNotificationMessage_hpp

Define Documentation

#define BtObexServerNotificationMessage_hpp

Generated on Tue Jan 24 20:14:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexNotificationMessage.hpp Source File

Bluetooth/OBEX/BtObexNotificationMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexServerNotificationMessage_hpp)
00009 #define BtObexServerNotificationMessage_hpp
00012
00013 #include <Apc/Message.hpp>
00014 #include <Apc/StackMsgArgument.hpp>
00015 #include <Bluetooth/OBEX/BtObexServerService.hpp>
00016 #include <Bluetooth/OBEX/BtObexClientService.hpp>
00017
00020 class BtObexServerNotificationMessage: public FromStackMsg
00021 {
00022     private:
00023         typedef FromStackMsg Base;
00024
00025     public:
00027         BtObexServerNotificationMessage(BtObexServerService* service, StackMsgArgument *argument = 0);
00028
00030         BtObexServerNotificationMessage(const BtObexServerNotificationMessage &message);
00031
00033         virtual ~BtObexServerNotificationMessage();
00034
00036
00038         virtual FromStackMsg& operator=(const FromStackMsg &message);
00039
00041
00043         virtual BtObexServerNotificationMessage& operator=(const BtObexServerNotificationMessage &message);
00044
00046
00048         BtObexServerService* GetService() const;
00049
00051
00053         virtual const MsgMetaData& GetMetaData() const;
00054
00056
00058         virtual Message* Clone() const;
00059
00060     public:
00061         enum { ID = 10106 };
00062
00063     private:
00065         BtObexServerService* m_service;
00066
00067     private:
00069         static const MsgMetaData m_meta_data;
00070 };
00071
00074 class BtObexClientNotificationMessage: public FromStackMsg
00075 {
00076     private:
00077         typedef FromStackMsg Base;
00078
00079     public:
00081         BtObexClientNotificationMessage(BtObexClientService* service, StackMsgArgument *argument = 0);
00082
00084         BtObexClientNotificationMessage(const BtObexClientNotificationMessage&message);
00085
00087         virtual ~BtObexClientNotificationMessage();
00088
00090
00092         virtual FromStackMsg& operator=(const FromStackMsg &message);
00093
00095
00097         virtual BtObexClientNotificationMessage& operator=(const BtObexClientNotificationMessage &message);
00098
00100
00102         BtObexClientService* GetService() const;
00103
00105
00107         virtual const MsgMetaData& GetMetaData() const;
00108
00110
00112         virtual Message* Clone() const;
00113
00114     public:
00115         enum { ID = 10107 };
00116
00117     private:
00119         BtObexClientService* m_service;
00120
00121     private:
00123         static const MsgMetaData m_meta_data;
00124 };
00125
00126 #endif // BtObexServerNotificationMessage_hpp
00127
00128
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp File Reference

Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp File Reference

#include "PreComp.hpp"
#include "BtObexNotificationMessageArgument.hpp"

Include dependency graph for BtObexNotificationMessageArgument.cpp:

Generated on Tue Jan 24 20:14:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp File Reference

Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp File Reference

#include <Apc/StackMsgArgument.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/OBEX/BtTypes.hpp>

Include dependency graph for BtObexNotificationMessageArgument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientNmaDataBufferIndication
class | BtObexClientNmaDataInidication
class | BtObexClientNmaHeaderIndication
class | BtObexClientNmaHeaderSent
class | BtObexClientNmaTransportDisconnect
class | BtObexServerNmaAbort
class | BtObexServerNmaConnect
class | BtObexServerNmaDataBufferIndication
class | BtObexServerNmaDataInidication
class | BtObexServerNmaDisconnect
class | BtObexServerNmaGet
class | BtObexServerNmaHeaderIndication
class | BtObexServerNmaHeaderSent
class | BtObexServerNmaPut
class | BtObexServerNmaSetPath
class | BtObexServerNmaTransportDisconnect

Defines

#define | Bluetooth_OBEX_BtObexNotificationMessageArgument_hpp

Define Documentation

#define Bluetooth_OBEX_BtObexNotificationMessageArgument_hpp

Generated on Tue Jan 24 20:14:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp Source File

Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXITEST_20_10_06-2_SV\lnz_apoxi\Apoxi\Bluetooth\OBEX\BtObexNotificationMessageArgument.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_OBEX_BtObexNotificationMessageArgument_hpp)
00016 #define Bluetooth_OBEX_BtObexNotificationMessageArgument_hpp
00017
00018 #include <Apc/StackMsgArgument.hpp>
00019 #include <Bluetooth/BtTypes.hpp>
00020 #include <Bluetooth/OBEX/BtTypes.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtObexServerNmaConnect
00029     ====================================================================== */
00030
00032 class BtObexServerNmaConnect : public StackMsgArgument {
00033     friend class BtObexMessageArgumentsDestroyTableNode;
00034     public:
00035         BtObexServerNmaConnect(const BtResultCode& result);
00036         BtObexServerNmaConnect();
00037         ~BtObexServerNmaConnect();
00038
00039         static const BtObexServerNmaConnect& Cast(const StackMsgArgument& arg);
00040         const BtResultCode& GetResult() const { return m_result; }
00041
00042         enum  {
00043             ID = 20
00044             };
00045
00046     private:
00047
00048         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaConnect*) arg); }
00049
00050         BtResultCode m_result;
00051
00052     };
00053
00054 // Inline definitions
00055 inline const BtObexServerNmaConnect& BtObexServerNmaConnect::Cast(const StackMsgArgument& arg) {
00056     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaConnect!\n");
00057     return ((BtObexServerNmaConnect &) arg);
00058 }
00059
00060
00061
00062 /*  ======================================================================
00063     Class BtObexServerNmaDisconnect
00064     ====================================================================== */
00065
00067 class BtObexServerNmaDisconnect : public StackMsgArgument {
00068     friend class BtObexMessageArgumentsDestroyTableNode;
00069     public:
00070         BtObexServerNmaDisconnect(const BtResultCode& result);
00071         BtObexServerNmaDisconnect();
00072         ~BtObexServerNmaDisconnect();
00073
00074         static const BtObexServerNmaDisconnect& Cast(const StackMsgArgument& arg);
00075         const BtResultCode& GetResult() const { return m_result; }
00076
00077         enum  {
00078             ID = 21
00079             };
00080
00081     private:
00082
00083         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaDisconnect*) arg); }
00084
00085         BtResultCode m_result;
00086
00087     };
00088
00089 // Inline definitions
00090 inline const BtObexServerNmaDisconnect& BtObexServerNmaDisconnect::Cast(const StackMsgArgument& arg) {
00091     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaDisconnect!\n");
00092     return ((BtObexServerNmaDisconnect &) arg);
00093 }
00094
00095
00096
00097 /*  ======================================================================
00098     Class BtObexServerNmaSetPath
00099     ====================================================================== */
00100
00102 class BtObexServerNmaSetPath : public StackMsgArgument {
00103     friend class BtObexMessageArgumentsDestroyTableNode;
00104     public:
00105         BtObexServerNmaSetPath(const BtResultCode& result, BOOLEAN Backup, BOOLEAN Create);
00106         BtObexServerNmaSetPath();
00107         ~BtObexServerNmaSetPath();
00108
00109         static const BtObexServerNmaSetPath& Cast(const StackMsgArgument& arg);
00110         const BtResultCode& GetResult() const { return m_result; }
00111         BOOLEAN IsBackup() const { return m_Backup; }
00112         BOOLEAN IsCreate() const { return m_Create; }
00113
00114         enum  {
00115             ID = 22
00116             };
00117
00118     private:
00119
00120         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaSetPath*) arg); }
00121
00122         BtResultCode m_result;
00123         BOOLEAN m_Backup;
00124         BOOLEAN m_Create;
00125
00126     };
00127
00128 // Inline definitions
00129 inline const BtObexServerNmaSetPath& BtObexServerNmaSetPath::Cast(const StackMsgArgument& arg) {
00130     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaSetPath!\n");
00131     return ((BtObexServerNmaSetPath &) arg);
00132 }
00133
00134
00135
00136 /*  ======================================================================
00137     Class BtObexServerNmaGet
00138     ====================================================================== */
00139
00141 class BtObexServerNmaGet : public StackMsgArgument {
00142     friend class BtObexMessageArgumentsDestroyTableNode;
00143     public:
00144         BtObexServerNmaGet(const BtResultCode& result);
00145         BtObexServerNmaGet();
00146         ~BtObexServerNmaGet();
00147
00148         static const BtObexServerNmaGet& Cast(const StackMsgArgument& arg);
00149         const BtResultCode& GetResult() const { return m_result; }
00150
00151         enum  {
00152             ID = 23
00153             };
00154
00155     private:
00156
00157         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaGet*) arg); }
00158
00159         BtResultCode m_result;
00160
00161     };
00162
00163 // Inline definitions
00164 inline const BtObexServerNmaGet& BtObexServerNmaGet::Cast(const StackMsgArgument& arg) {
00165     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaGet!\n");
00166     return ((BtObexServerNmaGet &) arg);
00167 }
00168
00169
00170
00171 /*  ======================================================================
00172     Class BtObexServerNmaPut
00173     ====================================================================== */
00174
00176 class BtObexServerNmaPut : public StackMsgArgument {
00177     friend class BtObexMessageArgumentsDestroyTableNode;
00178     public:
00179         BtObexServerNmaPut(const BtResultCode& result);
00180         BtObexServerNmaPut();
00181         ~BtObexServerNmaPut();
00182
00183         static const BtObexServerNmaPut& Cast(const StackMsgArgument& arg);
00184         const BtResultCode& GetResult() const { return m_result; }
00185
00186         enum  {
00187             ID = 24
00188             };
00189
00190     private:
00191
00192         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaPut*) arg); }
00193
00194         BtResultCode m_result;
00195
00196     };
00197
00198 // Inline definitions
00199 inline const BtObexServerNmaPut& BtObexServerNmaPut::Cast(const StackMsgArgument& arg) {
00200     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaPut!\n");
00201     return ((BtObexServerNmaPut &) arg);
00202 }
00203
00204
00205
00206 /*  ======================================================================
00207     Class BtObexServerNmaAbort
00208     ====================================================================== */
00209
00211 class BtObexServerNmaAbort : public StackMsgArgument {
00212     friend class BtObexMessageArgumentsDestroyTableNode;
00213     public:
00214         BtObexServerNmaAbort(const BtResultCode& result);
00215         BtObexServerNmaAbort();
00216         ~BtObexServerNmaAbort();
00217
00218         static const BtObexServerNmaAbort& Cast(const StackMsgArgument& arg);
00219         const BtResultCode& GetResult() const { return m_result; }
00220
00221         enum  {
00222             ID = 25
00223             };
00224
00225     private:
00226
00227         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaAbort*) arg); }
00228
00229         BtResultCode m_result;
00230
00231     };
00232
00233 // Inline definitions
00234 inline const BtObexServerNmaAbort& BtObexServerNmaAbort::Cast(const StackMsgArgument& arg) {
00235     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaAbort!\n");
00236     return ((BtObexServerNmaAbort &) arg);
00237 }
00238
00239
00240
00241 /*  ======================================================================
00242     Class BtObexServerNmaHeaderSent
00243     ====================================================================== */
00244
00246 class BtObexServerNmaHeaderSent : public StackMsgArgument {
00247     friend class BtObexMessageArgumentsDestroyTableNode;
00248     public:
00249         BtObexServerNmaHeaderSent(const BtResultCode& result);
00250         BtObexServerNmaHeaderSent();
00251         ~BtObexServerNmaHeaderSent();
00252
00253         static const BtObexServerNmaHeaderSent& Cast(const StackMsgArgument& arg);
00254         const BtResultCode& GetResult() const { return m_result; }
00255
00256         enum  {
00257             ID = 26
00258             };
00259
00260     private:
00261
00262         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaHeaderSent*) arg); }
00263
00264         BtResultCode m_result;
00265
00266     };
00267
00268 // Inline definitions
00269 inline const BtObexServerNmaHeaderSent& BtObexServerNmaHeaderSent::Cast(const StackMsgArgument& arg) {
00270     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaHeaderSent!\n");
00271     return ((BtObexServerNmaHeaderSent &) arg);
00272 }
00273
00274
00275
00276 /*  ======================================================================
00277     Class BtObexServerNmaHeaderIndication
00278     ====================================================================== */
00279
00281 class BtObexServerNmaHeaderIndication : public StackMsgArgument {
00282     friend class BtObexMessageArgumentsDestroyTableNode;
00283     public:
00284         BtObexServerNmaHeaderIndication(const BtResultCode& result, const BtObexHeader& header);
00285         BtObexServerNmaHeaderIndication();
00286         ~BtObexServerNmaHeaderIndication();
00287
00288         static const BtObexServerNmaHeaderIndication& Cast(const StackMsgArgument& arg);
00289         const BtResultCode& GetResult() const { return m_result; }
00290         const BtObexHeader& GetHeader() const { return m_header; }
00291
00292         enum  {
00293             ID = 27
00294             };
00295
00296     private:
00297
00298         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaHeaderIndication*) arg); }
00299
00300         BtResultCode m_result;
00301         BtObexHeader m_header;
00302
00303     };
00304
00305 // Inline definitions
00306 inline const BtObexServerNmaHeaderIndication& BtObexServerNmaHeaderIndication::Cast(const StackMsgArgument& arg) {
00307     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaHeaderIndication!\n");
00308     return ((BtObexServerNmaHeaderIndication &) arg);
00309 }
00310
00311
00312
00313 /*  ======================================================================
00314     Class BtObexServerNmaDataBufferIndication
00315     ====================================================================== */
00316
00318 class BtObexServerNmaDataBufferIndication : public StackMsgArgument {
00319     friend class BtObexMessageArgumentsDestroyTableNode;
00320     public:
00321         BtObexServerNmaDataBufferIndication(const BtResultCode& result, UINT16 number_of_bytes, BOOLEAN delete_object, BOOLEAN create_empty);
00322         BtObexServerNmaDataBufferIndication();
00323         ~BtObexServerNmaDataBufferIndication();
00324
00325         static const BtObexServerNmaDataBufferIndication& Cast(const StackMsgArgument& arg);
00326         const BtResultCode& GetResult() const { return m_result; }
00327         UINT16 GetNumberOfBytes() const { return m_number_of_bytes; }
00328         BOOLEAN IsDeleteObject() const { return m_delete_object; }
00329         BOOLEAN IsCreateEmpty() const { return m_create_empty; }
00330
00331         enum  {
00332             ID = 28
00333             };
00334
00335     private:
00336
00337         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaDataBufferIndication*) arg); }
00338
00339         BtResultCode m_result;
00340         UINT16 m_number_of_bytes;
00341         BOOLEAN m_delete_object;
00342         BOOLEAN m_create_empty;
00343
00344     };
00345
00346 // Inline definitions
00347 inline const BtObexServerNmaDataBufferIndication& BtObexServerNmaDataBufferIndication::Cast(const StackMsgArgument& arg) {
00348     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaDataBufferIndication!\n");
00349     return ((BtObexServerNmaDataBufferIndication &) arg);
00350 }
00351
00352
00353
00354 /*  ======================================================================
00355     Class BtObexServerNmaDataInidication
00356     ====================================================================== */
00357
00359 class BtObexServerNmaDataInidication : public StackMsgArgument {
00360     friend class BtObexMessageArgumentsDestroyTableNode;
00361     public:
00362         BtObexServerNmaDataInidication(const BtResultCode& result);
00363         BtObexServerNmaDataInidication();
00364         ~BtObexServerNmaDataInidication();
00365
00366         static const BtObexServerNmaDataInidication& Cast(const StackMsgArgument& arg);
00367         const BtResultCode& GetResult() const { return m_result; }
00368
00369         enum  {
00370             ID = 29
00371             };
00372
00373     private:
00374
00375         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaDataInidication*) arg); }
00376
00377         BtResultCode m_result;
00378
00379     };
00380
00381 // Inline definitions
00382 inline const BtObexServerNmaDataInidication& BtObexServerNmaDataInidication::Cast(const StackMsgArgument& arg) {
00383     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaDataInidication!\n");
00384     return ((BtObexServerNmaDataInidication &) arg);
00385 }
00386
00387
00388
00389 /*  ======================================================================
00390     Class BtObexServerNmaTransportDisconnect
00391     ====================================================================== */
00392
00394 class BtObexServerNmaTransportDisconnect : public StackMsgArgument {
00395     friend class BtObexMessageArgumentsDestroyTableNode;
00396     public:
00397         BtObexServerNmaTransportDisconnect(const BtResultCode& result);
00398         BtObexServerNmaTransportDisconnect();
00399         ~BtObexServerNmaTransportDisconnect();
00400
00401         static const BtObexServerNmaTransportDisconnect& Cast(const StackMsgArgument& arg);
00402         const BtResultCode& GetResult() const { return m_result; }
00403
00404         enum  {
00405             ID = 30
00406             };
00407
00408     private:
00409
00410         static void Destroy(StackMsgArgument* arg) { delete ((BtObexServerNmaTransportDisconnect*) arg); }
00411
00412         BtResultCode m_result;
00413
00414     };
00415
00416 // Inline definitions
00417 inline const BtObexServerNmaTransportDisconnect& BtObexServerNmaTransportDisconnect::Cast(const StackMsgArgument& arg) {
00418     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexServerNmaTransportDisconnect!\n");
00419     return ((BtObexServerNmaTransportDisconnect &) arg);
00420 }
00421
00422
00423
00424 /*  ======================================================================
00425     Class BtObexClientNmaHeaderSent
00426     ====================================================================== */
00427
00429 class BtObexClientNmaHeaderSent : public StackMsgArgument {
00430     friend class BtObexMessageArgumentsDestroyTableNode;
00431     public:
00432         BtObexClientNmaHeaderSent(const BtResultCode& result);
00433         BtObexClientNmaHeaderSent();
00434         ~BtObexClientNmaHeaderSent();
00435
00436         static const BtObexClientNmaHeaderSent& Cast(const StackMsgArgument& arg);
00437         const BtResultCode& GetResult() const { return m_result; }
00438
00439         enum  {
00440             ID = 40
00441             };
00442
00443     private:
00444
00445         static void Destroy(StackMsgArgument* arg) { delete ((BtObexClientNmaHeaderSent*) arg); }
00446
00447         BtResultCode m_result;
00448
00449     };
00450
00451 // Inline definitions
00452 inline const BtObexClientNmaHeaderSent& BtObexClientNmaHeaderSent::Cast(const StackMsgArgument& arg) {
00453     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexClientNmaHeaderSent!\n");
00454     return ((BtObexClientNmaHeaderSent &) arg);
00455 }
00456
00457
00458
00459 /*  ======================================================================
00460     Class BtObexClientNmaHeaderIndication
00461     ====================================================================== */
00462
00464 class BtObexClientNmaHeaderIndication : public StackMsgArgument {
00465     friend class BtObexMessageArgumentsDestroyTableNode;
00466     public:
00467         BtObexClientNmaHeaderIndication(const BtResultCode& result, const BtObexHeader& header);
00468         BtObexClientNmaHeaderIndication();
00469         ~BtObexClientNmaHeaderIndication();
00470
00471         static const BtObexClientNmaHeaderIndication& Cast(const StackMsgArgument& arg);
00472         const BtResultCode& GetResult() const { return m_result; }
00473         const BtObexHeader& GetHeader() const { return m_header; }
00474
00475         enum  {
00476             ID = 41
00477             };
00478
00479     private:
00480
00481         static void Destroy(StackMsgArgument* arg) { delete ((BtObexClientNmaHeaderIndication*) arg); }
00482
00483         BtResultCode m_result;
00484         BtObexHeader m_header;
00485
00486     };
00487
00488 // Inline definitions
00489 inline const BtObexClientNmaHeaderIndication& BtObexClientNmaHeaderIndication::Cast(const StackMsgArgument& arg) {
00490     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexClientNmaHeaderIndication!\n");
00491     return ((BtObexClientNmaHeaderIndication &) arg);
00492 }
00493
00494
00495
00496 /*  ======================================================================
00497     Class BtObexClientNmaDataBufferIndication
00498     ====================================================================== */
00499
00501 class BtObexClientNmaDataBufferIndication : public StackMsgArgument {
00502     friend class BtObexMessageArgumentsDestroyTableNode;
00503     public:
00504         BtObexClientNmaDataBufferIndication(const BtResultCode& result, UINT16 number_of_bytes, BOOLEAN delete_object, BOOLEAN create_empty);
00505         BtObexClientNmaDataBufferIndication();
00506         ~BtObexClientNmaDataBufferIndication();
00507
00508         static const BtObexClientNmaDataBufferIndication& Cast(const StackMsgArgument& arg);
00509         const BtResultCode& GetResult() const { return m_result; }
00510         UINT16 GetNumberOfBytes() const { return m_number_of_bytes; }
00511         BOOLEAN IsDeleteObject() const { return m_delete_object; }
00512         BOOLEAN IsCreateEmpty() const { return m_create_empty; }
00513
00514         enum  {
00515             ID = 42
00516             };
00517
00518     private:
00519
00520         static void Destroy(StackMsgArgument* arg) { delete ((BtObexClientNmaDataBufferIndication*) arg); }
00521
00522         BtResultCode m_result;
00523         UINT16 m_number_of_bytes;
00524         BOOLEAN m_delete_object;
00525         BOOLEAN m_create_empty;
00526
00527     };
00528
00529 // Inline definitions
00530 inline const BtObexClientNmaDataBufferIndication& BtObexClientNmaDataBufferIndication::Cast(const StackMsgArgument& arg) {
00531     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexClientNmaDataBufferIndication!\n");
00532     return ((BtObexClientNmaDataBufferIndication &) arg);
00533 }
00534
00535
00536
00537 /*  ======================================================================
00538     Class BtObexClientNmaDataInidication
00539     ====================================================================== */
00540
00542 class BtObexClientNmaDataInidication : public StackMsgArgument {
00543     friend class BtObexMessageArgumentsDestroyTableNode;
00544     public:
00545         BtObexClientNmaDataInidication(const BtResultCode& result);
00546         BtObexClientNmaDataInidication();
00547         ~BtObexClientNmaDataInidication();
00548
00549         static const BtObexClientNmaDataInidication& Cast(const StackMsgArgument& arg);
00550         const BtResultCode& GetResult() const { return m_result; }
00551
00552         enum  {
00553             ID = 43
00554             };
00555
00556     private:
00557
00558         static void Destroy(StackMsgArgument* arg) { delete ((BtObexClientNmaDataInidication*) arg); }
00559
00560         BtResultCode m_result;
00561
00562     };
00563
00564 // Inline definitions
00565 inline const BtObexClientNmaDataInidication& BtObexClientNmaDataInidication::Cast(const StackMsgArgument& arg) {
00566     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexClientNmaDataInidication!\n");
00567     return ((BtObexClientNmaDataInidication &) arg);
00568 }
00569
00570
00571
00572 /*  ======================================================================
00573     Class BtObexClientNmaTransportDisconnect
00574     ====================================================================== */
00575
00577 class BtObexClientNmaTransportDisconnect : public StackMsgArgument {
00578     friend class BtObexMessageArgumentsDestroyTableNode;
00579     public:
00580         BtObexClientNmaTransportDisconnect(const BtResultCode& result);
00581         BtObexClientNmaTransportDisconnect();
00582         ~BtObexClientNmaTransportDisconnect();
00583
00584         static const BtObexClientNmaTransportDisconnect& Cast(const StackMsgArgument& arg);
00585         const BtResultCode& GetResult() const { return m_result; }
00586
00587         enum  {
00588             ID = 44
00589             };
00590
00591     private:
00592
00593         static void Destroy(StackMsgArgument* arg) { delete ((BtObexClientNmaTransportDisconnect*) arg); }
00594
00595         BtResultCode m_result;
00596
00597     };
00598
00599 // Inline definitions
00600 inline const BtObexClientNmaTransportDisconnect& BtObexClientNmaTransportDisconnect::Cast(const StackMsgArgument& arg) {
00601     ASSERT_INFO((arg.Id() == ID), L"StackMsgArgument failed to cast to BtObexClientNmaTransportDisconnect!\n");
00602     return ((BtObexClientNmaTransportDisconnect &) arg);
00603 }
00604
00605
00606 #endif // Bluetooth_OBEX_BtObexNotificationMessageArgument_hpp
00607
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexPutRequest.cpp File Reference

Bluetooth/OBEX/BtObexPutRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"
#include "BtObexPutRequest.hpp"

Include dependency graph for BtObexPutRequest.cpp:

Generated on Tue Jan 24 20:14:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexPutRequest.hpp File Reference

Bluetooth/OBEX/BtObexPutRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>

Include dependency graph for BtObexPutRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexPutRequest

Defines

#define | BtObexPutRequest_hpp

Define Documentation

#define BtObexPutRequest_hpp

Generated on Tue Jan 24 20:14:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexPutRequest.hpp Source File

Bluetooth/OBEX/BtObexPutRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexPutRequest_hpp)
00009 #define BtObexPutRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexClientService;
00020
00023 class BtObexPutRequest: public BtObexClientOperationRequest
00024 {
00025     private:
00026         typedef BtObexClientOperationRequest Base;
00027
00028     public:
00030         BtObexPutRequest(BtObexClientService& obex_client_service);
00031
00033         virtual ~BtObexPutRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00041
00043         BOOLEAN GetDeleteObject() const;
00044
00046
00048         void SetDeleteObject(BOOLEAN delete_object = TRUE);
00049
00051
00053         BOOLEAN GetCreateEmptyObject() const;
00054
00056
00058         void SetCreateEmptyObject(BOOLEAN create_empty = TRUE);
00059
00060     protected:
00062
00064         virtual BOOLEAN Execute();
00065
00067
00069         virtual void ExecutionCallback(BtResultCode result);
00070
00072
00074         virtual BOOLEAN GetAcceptAbort() const;
00075
00076     private:
00078
00080         btapi_goep_operation_t* GetApiSettings();
00081
00082     private:
00084         btapi_goep_operation_t m_operation_settings;
00085
00086     private:
00087         friend class BtObexController;
00088 };
00089
00091 #endif  // BtObexPutRequest_hpp
00092
00093
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRegisterClientRequest.cpp File Reference

Bluetooth/OBEX/BtObexRegisterClientRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"
#include "BtObexRegisterClientRequest.hpp"

Include dependency graph for BtObexRegisterClientRequest.cpp:

Generated on Tue Jan 24 20:14:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRegisterClientRequest.hpp File Reference

Bluetooth/OBEX/BtObexRegisterClientRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexRequest.hpp>

Include dependency graph for BtObexRegisterClientRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexRegisterClientRequest

Defines

#define | BtObexRegisterClientRequest_hpp

Define Documentation

#define BtObexRegisterClientRequest_hpp

Generated on Tue Jan 24 20:14:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRegisterClientRequest.hpp Source File

Bluetooth/OBEX/BtObexRegisterClientRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexRegisterClientRequest_hpp)
00009 #define BtObexRegisterClientRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexClientService;
00020
00023 class BtObexRegisterClientRequest: public BtObexRequest
00024 {
00025     private:
00026         typedef BtObexRequest Base;
00027
00028     public:
00030         BtObexRegisterClientRequest(BtObexClientService& obex_client_service);
00031
00033         virtual ~BtObexRegisterClientRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00041
00043         BtSecuritySettings GetSecuritySettings() const;
00044
00046
00048         void SetSecuritySettings(BtSecuritySettings security_settings);
00049
00051
00053         const UINT8* GetHeaderBuffer(void) const;
00054
00056
00058         UINT8* GetHeaderBuffer(void);
00059
00061
00063         UINT16 GetHeaderBufferSize(void) const;
00064
00066
00068         void SetHeaderBuffer(UINT8* header_buffer, UINT16 header_buffer_size);
00069
00071
00073         const void* GetApoxiHandle(void) const;
00074
00076
00078         void* GetApoxiHandle(void);
00079
00081
00083         void SetApoxiHandle(void* apoxi_handle);
00084
00085     protected:
00087
00089         virtual BOOLEAN Execute();
00090
00092
00094         virtual void ExecutionCallback(BtResultCode result);
00095
00096     private:
00098
00100         btapi_goep_register_app_t* GetApiSettings();
00101
00102     private:
00104         btapi_goep_register_app_t m_registration_settings;
00105
00106     private:
00107         friend class BtObexController;
00108 };
00109
00111 #endif  // BtObexRegisterClientRequest_hpp
00112
00113
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRegisterServerRequest.cpp File Reference

Bluetooth/OBEX/BtObexRegisterServerRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexServerService.hpp"
#include "BtObexController.hpp"
#include "BtObexRegisterServerRequest.hpp"

Include dependency graph for BtObexRegisterServerRequest.cpp:

Generated on Tue Jan 24 20:14:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRegisterServerRequest.hpp File Reference

Bluetooth/OBEX/BtObexRegisterServerRequest.hpp File Reference

#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/OBEX/BtObexRequest.hpp>

Include dependency graph for BtObexRegisterServerRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexRegisterServerRequest

Defines

#define | BtObexRegisterServerRequest_hpp

Define Documentation

#define BtObexRegisterServerRequest_hpp

Generated on Tue Jan 24 20:14:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRegisterServerRequest.hpp Source File

Bluetooth/OBEX/BtObexRegisterServerRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexRegisterServerRequest_hpp)
00009 #define BtObexRegisterServerRequest_hpp
00012
00013 #include <Bluetooth/BtTypes.hpp>
00014 #include <Bluetooth/OBEX/BtObexRequest.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00020 class BtObexServerService;
00021 class BtObexController;
00022
00025 class BtObexRegisterServerRequest: public BtObexRequest
00026 {
00027     private:
00028         typedef BtObexRequest Base;
00029
00030     public:
00032         BtObexRegisterServerRequest(BtObexServerService& obex_server_service);
00033
00035         virtual ~BtObexRegisterServerRequest();
00036
00038
00040         virtual BtRequestType GetRequestType() const;
00041
00043
00045         BtSecuritySettings GetSecuritySettings() const;
00046
00048
00050         void SetSecuritySettings(BtSecuritySettings security_settings);
00051
00053
00055         const UINT8* GetHeaderBuffer(void) const;
00056
00058
00060         UINT8* GetHeaderBuffer(void);
00061
00063
00065         UINT16 GetHeaderBufferSize(void) const;
00066
00068
00070         void SetHeaderBuffer(UINT8* header_buffer, UINT16 header_buffer_size);
00071
00073
00075         const void* GetApoxiHandle(void) const;
00076
00078
00080         void* GetApoxiHandle(void);
00081
00083
00085         void SetApoxiHandle(void* apoxi_handle);
00086
00088
00090         UINT8 GetRfComChannel() const;
00091
00092     protected:
00094
00096         virtual BOOLEAN Execute();
00097
00099
00101         void OnRfComChannel(UINT8 rfcom_channel);
00102
00104
00106         virtual void ExecutionCallback(BtResultCode result);
00107
00108     private:
00110
00112         btapi_goep_register_app_t* GetApiSettings();
00113
00114     private:
00116         btapi_goep_register_app_t m_registration_settings;
00117
00119         UINT8 m_rfcom_channel;
00120
00121     private:
00122         friend class BtObexController;
00123 };
00124
00126 #endif  // BtObexRegisterServerRequest_hpp
00127
00128
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRequest.cpp File Reference

Bluetooth/OBEX/BtObexRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexService.hpp"
#include "BtObexRequest.hpp"

Include dependency graph for BtObexRequest.cpp:

Generated on Tue Jan 24 20:14:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRequest.hpp File Reference

Bluetooth/OBEX/BtObexRequest.hpp File Reference

#include <Bluetooth/BtServiceRequest.hpp>
#include <Bluetooth/OBEX/BtObexService.hpp>

Include dependency graph for BtObexRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexRequest

Defines

#define | BtObexRequest_hpp

Define Documentation

#define BtObexRequest_hpp

Generated on Tue Jan 24 20:15:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexRequest.hpp Source File

Bluetooth/OBEX/BtObexRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexRequest_hpp)
00009 #define BtObexRequest_hpp
00012
00013 #include <Bluetooth/BtServiceRequest.hpp>
00014 #include <Bluetooth/OBEX/BtObexService.hpp>
00015
00016 /*  ------------------------------------------------------------------------
00017     Forward deklarations for friend relationships.
00018     ------------------------------------------------------------------------ */
00019
00020 class BtObexController;
00021
00024 class BtObexRequest: public BtServiceRequest
00025 {
00026     private:
00027         typedef BtServiceRequest Base;
00028
00029     public:
00031         BtObexRequest(BtObexService& obex_service);
00032
00034         virtual ~BtObexRequest();
00035
00036     protected:
00038
00051         virtual BtRequestState ChangeRequestState(BOOLEAN success);
00052
00054
00056         virtual BOOLEAN EvaluateExecutionResult(BtResultCode result);
00057
00058     private:
00059         friend class BtObexController;
00060 };
00061
00063 #endif  // BtObexRequest_hpp
00064
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServerService.cpp File Reference

Bluetooth/OBEX/BtObexServerService.cpp File Reference

#include "PreComp.hpp"
#include "BtObexController.hpp"
#include "BtObexServerService.hpp"
#include "BtObexNotificationMessage.hpp"
#include "BtObexNotificationMessageArgument.hpp"

Include dependency graph for BtObexServerService.cpp:

Defines

#define DBG_STATE

Define Documentation

#define DBG_STATE

Generated on Tue Jan 24 20:15:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServerService.hpp File Reference

Bluetooth/OBEX/BtObexServerService.hpp File Reference

#include <Bluetooth/OBEX/BtObexServerServiceObserver.hpp>
#include <Bluetooth/OBEX/BtObexRegisterServerRequest.hpp>
#include <Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp>
#include <Bluetooth/OBEX/BtObexService.hpp>
#include <Bluetooth/OBEX/BtObexController.hpp>

Include dependency graph for BtObexServerService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexServerService

Defines

#define | BtObexServerService_hpp

Define Documentation

#define BtObexServerService_hpp

Generated on Tue Jan 24 20:15:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServerService.hpp Source File

Bluetooth/OBEX/BtObexServerService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexServerService_hpp)
00009 #define BtObexServerService_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexServerServiceObserver.hpp>
00014 #include <Bluetooth/OBEX/BtObexRegisterServerRequest.hpp>
00015 #include <Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp>
00016 //#include <Bluetooth/OBEX/BtObexSendResponseRequest.hpp>
00017 #include <Bluetooth/OBEX/BtObexService.hpp>
00018 #include <Bluetooth/OBEX/BtObexController.hpp>
00019
00022 class BtObexServerService: public BtObexService
00023 {
00024     private:
00025         typedef BtObexService Base;
00026
00027     public:
00029         BtObexServerService();
00030
00032         virtual ~BtObexServerService();
00033
00035
00037         virtual BtRequestState GetRequestState(BtRequestType request_type) const;
00038
00040
00042         virtual BOOLEAN IsServerService() const;
00043
00045
00047         virtual BtRequestState RegisterRequest(UINT8* header_buffer, UINT16 header_buffer_size, BtSecuritySettings security_settings = BtSesNoSecurity);
00048
00050
00052         virtual BtRequestState UnregisterRequest();
00053
00055
00057         BOOLEAN DataBufferIndication(UINT8* data_buffer, UINT16 data_buffer_size, UINT8 response_code = 0);
00058
00060
00062         BOOLEAN DataIndication(const UINT8* data, UINT16 data_size, BOOLEAN more_data_pending = FALSE, UINT8 response_code = 0);
00063
00065
00067         BOOLEAN SendResponse(UINT8 response_code);
00068
00070
00072         UINT8 GetRfComChannel() const;
00073
00074     public:
00076
00078         BOOLEAN Attach(BtObexServerServiceObserver* service_observer);
00079
00081
00083         BOOLEAN Detach(BtObexServerServiceObserver* service_observer);
00084
00085 #ifdef _DEBUG
00086     protected:
00088
00090         virtual void DebugState();
00091 #endif /* DEBUG */
00092
00093     private:
00095
00097         void RegisterCallback(BtResultCode result, UINT8 rfcom_channel);
00098
00100
00102         void ConnectCallback(BtResultCode result, const BtDevice& device);
00103
00105
00107         void DisconnectCallback(BtResultCode result);
00108
00110
00112         void SetPathCallback(BtResultCode result, BOOLEAN backup, BOOLEAN create);
00113
00115
00117         void GetCallback(BtResultCode result);
00118
00120
00122         void PutCallback(BtResultCode result);
00123
00125
00127         void AbortCallback(BtResultCode result);
00128
00129     private:
00131         BtObexRegisterServerRequest m_register_server_request;
00132
00134         BtObexUnregisterServerRequest m_unregister_server_request;
00135
00136 //      BtObexSendResponseRequest m_send_response_request;
00137
00138     private:
00139         friend class BtObexRegisterServerRequest;
00140         friend class BtObexUnregisterServerRequest;
00141         friend class BtObexController;
00142 };
00143
00145 #endif  // BtObexServerService_hpp
00146
00147
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServerServiceObserver.cpp File Reference

Bluetooth/OBEX/BtObexServerServiceObserver.cpp File Reference

#include "PreComp.hpp"
#include "BtObexEvent.hpp"
#include "BtObexServerServiceObserver.hpp"

Include dependency graph for BtObexServerServiceObserver.cpp:

Generated on Tue Jan 24 20:15:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServerServiceObserver.hpp File Reference

Bluetooth/OBEX/BtObexServerServiceObserver.hpp File Reference

#include <Bluetooth/OBEX/BtObexServiceObserver.hpp>

Include dependency graph for BtObexServerServiceObserver.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexServerServiceObserver

Defines

#define | BtObexServerServiceObserver_hpp

Define Documentation

#define BtObexServerServiceObserver_hpp

Generated on Tue Jan 24 20:15:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServerServiceObserver.hpp Source File

Bluetooth/OBEX/BtObexServerServiceObserver.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexServerServiceObserver_hpp)
00009 #define BtObexServerServiceObserver_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexServiceObserver.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexServerService;
00020 class BtDevice;
00021
00024 class BtObexServerServiceObserver: public BtObexServiceObserver
00025 {
00026     private:
00027         typedef BtObexServiceObserver Base;
00028
00029     public:
00031         BtObexServerServiceObserver();
00032
00034         virtual ~BtObexServerServiceObserver();
00035
00036     protected:
00038
00040         virtual void OnEvent(const BtEvent& event);
00041
00043
00045         virtual void OnRegister(BtResultCode code, UINT8 rfcom_channel) = 0;
00046
00048
00050         virtual void OnConnect(BtResultCode code, const BtDevice& device) = 0;
00051
00053
00055         virtual void OnDisconnect(BtResultCode code) = 0;
00056
00058
00060         virtual void OnSetPath(BtResultCode code, BOOLEAN backup, BOOLEAN create) = 0;
00061
00063
00065         virtual void OnGet(BtResultCode code) = 0;
00066
00068
00070         virtual void OnPut(BtResultCode code) = 0;
00071
00073
00075         virtual void OnAbort(BtResultCode code) = 0;
00076
00077     private:
00078         friend class BtObexServerService;
00079 };
00080
00082 #endif  // BtObexServerServiceObserver_hpp
00083
00084
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexService.cpp File Reference

Bluetooth/OBEX/BtObexService.cpp File Reference

#include "PreComp.hpp"
#include "BtObexEvent.hpp"
#include "BtObexService.hpp"
#include "BtObexServiceMessage.hpp"
#include "BtObexNotificationMessage.hpp"
#include "BtObexNotificationMessageArgument.hpp"
#include "BtObexController.hpp"

Include dependency graph for BtObexService.cpp:

Defines

#define DBG_STATE

Define Documentation

#define DBG_STATE

Generated on Tue Jan 24 20:15:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexService.hpp File Reference

Bluetooth/OBEX/BtObexService.hpp File Reference

#include <Kernel/UserDispatcher.hpp>
#include <Bluetooth/BtObservableService.hpp>
#include <Bluetooth/OBEX/BtObexEvent.hpp>
#include <Bluetooth/OBEX/BtObexServiceObserver.hpp>

Include dependency graph for BtObexService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexService

Defines

#define | BtObexService_hpp

Define Documentation

#define BtObexService_hpp

Generated on Tue Jan 24 20:15:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexService.hpp Source File

Bluetooth/OBEX/BtObexService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexService_hpp)
00009 #define BtObexService_hpp
00012
00013 #include <Kernel/UserDispatcher.hpp>
00014 #include <Bluetooth/BtObservableService.hpp>
00015 #include <Bluetooth/OBEX/BtObexEvent.hpp>
00016 #include <Bluetooth/OBEX/BtObexServiceObserver.hpp>
00017
00018 /*  ------------------------------------------------------------------------
00019     Forward deklarations for friend relationships.
00020     ------------------------------------------------------------------------ */
00021
00022 class BtObexRequest;
00023 class BtObexController;
00024
00027 class BtObexService: public BtObservableService
00028 {
00029     private:
00030         typedef BtObservableService Base;
00031
00032     public:
00034         BtObexService();
00035
00037         virtual ~BtObexService();
00038
00040
00045         virtual BtProfile GetProfile() const;
00046
00048
00050         virtual BOOLEAN IsServerService() const = 0;
00051
00053
00055         virtual BtRequestState RegisterRequest(UINT8* header_buffer, UINT16 header_buffer_size, BtSecuritySettings security_settings = BtSesNoSecurity) = 0;
00056
00058
00060         virtual BtRequestState UnregisterRequest() = 0;
00061
00063
00065         BOOLEAN AddHeader(UINT8 header_id, UINT8 header_value);
00066
00068
00070         BOOLEAN AddHeader(UINT8 header_id, UINT32 header_value);
00071
00073
00075         BOOLEAN AddHeader(UINT8 header_id, UINT8* header_value, UINT16 header_value_length);
00076
00078
00080         BOOLEAN AddHeader(UINT8 header_id, WString header_value);
00081
00083
00085         BOOLEAN DiscardHeaders();
00086
00088
00090         BOOLEAN GetFreeSize(UINT16 &bytes_free);
00091
00092     protected:
00094
00096         virtual void RegisterMessages() const;
00097
00099
00101         virtual void UnregisterMessages() const;
00102
00104
00106         virtual BOOLEAN OnMessage(const Message& message);
00107
00109
00111 //      BOOLEAN DataReady(btapi_goep_data_ready_t& api_data_ready);
00112
00113     protected:
00115
00117         virtual void RequestStateChangeCallback(BtServiceRequest* request, BtRequestState old_request_state, BtRequestState new_request_state);
00118
00120
00122         void UnregisterCallback(BtResultCode result);
00123
00124 #ifdef _DEBUG
00125     protected:
00127
00129         virtual void DebugState();
00130 #endif /* DEBUG */
00131
00132 private:
00134
00136         void HeaderIndicationCallback(BtResultCode result, const BtObexHeader& obex_header);
00137
00139
00141         void HeaderSentIndicationCallback(BtResultCode result);
00142
00144
00146         void GetDataBufferIndicationCallback(BtResultCode result, UINT16 number_of_bytes, BOOLEAN delete_object, BOOLEAN create_empty);
00147
00149
00151         void GetDataIndicationCallback(BtResultCode result);
00152
00154
00156         void TransportDisconnectCallback(BtResultCode result);
00157
00158     private:
00159         friend class BtObexRequest;
00160         friend class BtObexController;
00161 };
00162
00164 #endif  // BtObexService_hpp
00165
00166
Generated on Tue Jan 24 14:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServiceMessage.cpp File Reference

Bluetooth/OBEX/BtObexServiceMessage.cpp File Reference

#include "PreComp.hpp"
#include "BtObexServiceMessage.hpp"

Include dependency graph for BtObexServiceMessage.cpp:

Generated on Tue Jan 24 20:15:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServiceMessage.hpp File Reference

Bluetooth/OBEX/BtObexServiceMessage.hpp File Reference

#include <Bluetooth/BtServiceMessage.hpp>

Include dependency graph for BtObexServiceMessage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientRequestStateChangedMessage
class | BtObexServerRequestStateChangedMessage

Defines

#define | Bluetooth_BtObexServiceMessage_hpp

Define Documentation

#define Bluetooth_BtObexServiceMessage_hpp

Generated on Tue Jan 24 20:15:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServiceMessage.hpp Source File

Bluetooth/OBEX/BtObexServiceMessage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "Snapshots\APOXI_DEVELOPMENT_SV\lnz_apoxi\Apoxi\Bluetooth\OBEX\BtObexServiceMessage.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Bluetooth_BtObexServiceMessage_hpp)
00016 #define Bluetooth_BtObexServiceMessage_hpp
00017
00018 #include <Bluetooth/BtServiceMessage.hpp>
00019
00020
00021 /* ----------------------------------------------------------------------
00022     Classes
00023     ---------------------------------------------------------------------- */
00024
00025 /*  ======================================================================
00026     Class BtObexServerRequestStateChangedMessage
00027     ====================================================================== */
00028
00030 class BtObexServerRequestStateChangedMessage : public BtRequestStateChangedMessage {
00031     public:
00032         BtObexServerRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00033         virtual ~BtObexServerRequestStateChangedMessage();
00034
00035         virtual const MsgMetaData& GetMetaData() const;
00036         virtual Message* Clone() const;
00037
00038         enum  {
00039             ID = 10335
00040             };
00041
00042     private:
00043         static const MsgMetaData m_meta_data;
00044
00045     };
00046
00047
00048 /*  ======================================================================
00049     Class BtObexClientRequestStateChangedMessage
00050     ====================================================================== */
00051
00053 class BtObexClientRequestStateChangedMessage : public BtRequestStateChangedMessage {
00054     public:
00055         BtObexClientRequestStateChangedMessage(BtService* service, const BtRequestType& request_type, const BtRequestState& old_request_state, const BtRequestState& new_request_state);
00056         virtual ~BtObexClientRequestStateChangedMessage();
00057
00058         virtual const MsgMetaData& GetMetaData() const;
00059         virtual Message* Clone() const;
00060
00061         enum  {
00062             ID = 10340
00063             };
00064
00065     private:
00066         static const MsgMetaData m_meta_data;
00067
00068     };
00069
00070 #endif // Bluetooth_BtObexServiceMessage_hpp
00071
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServiceObserver.cpp File Reference

Bluetooth/OBEX/BtObexServiceObserver.cpp File Reference

#include "PreComp.hpp"
#include "BtObexEvent.hpp"
#include "BtObexServiceObserver.hpp"

Include dependency graph for BtObexServiceObserver.cpp:

Generated on Tue Jan 24 20:15:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServiceObserver.hpp File Reference

Bluetooth/OBEX/BtObexServiceObserver.hpp File Reference

#include <Bluetooth/BtEvent.hpp>
#include <Bluetooth/BtServiceObserver.hpp>
#include <Bluetooth/OBEX/BtTypes.hpp>

Include dependency graph for BtObexServiceObserver.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexServiceObserver

Defines

#define | BtObexServiceObserver_hpp

Define Documentation

#define BtObexServiceObserver_hpp

Generated on Tue Jan 24 20:15:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexServiceObserver.hpp Source File

Bluetooth/OBEX/BtObexServiceObserver.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexServiceObserver_hpp)
00009 #define BtObexServiceObserver_hpp
00012
00013 #include <Bluetooth/BtEvent.hpp>
00014 #include <Bluetooth/BtServiceObserver.hpp>
00015 #include <Bluetooth/OBEX/BtTypes.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018     Forward deklarations for friend relationships.
00019     ------------------------------------------------------------------------ */
00020
00021 class BtObexService;
00022
00025 class BtObexServiceObserver: public BtServiceObserver
00026 {
00027     private:
00028         typedef BtServiceObserver Base;
00029
00030     public:
00032         BtObexServiceObserver();
00033
00035         virtual ~BtObexServiceObserver();
00036
00037     protected:
00039
00041         virtual void OnEvent(const BtEvent& event);
00042
00044
00046         virtual void OnUnregister(BtResultCode result) = 0;
00047
00049
00051         virtual void OnHeader(BtResultCode result, const BtObexHeader& header) = 0;
00052
00054
00056         virtual void OnHeaderSent(BtResultCode result) = 0;
00057
00059
00061         virtual void OnBufferRequested(BtResultCode result, UINT16 last_buffer_filled, BOOLEAN delete_object, BOOLEAN create_empty_object) = 0;
00062
00064
00066         virtual void OnDataRequested(BtResultCode result) = 0;
00067
00069
00071         virtual void OnTransportDisconnect(BtResultCode result) = 0;
00072
00074
00076         virtual void OnError(BtObexErrorCode error) = 0;
00077
00078     private:
00079         friend class BtObexService;
00080 };
00081
00083 #endif  // BtObexServiceObserver_hpp
00084
00085
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexSetPathRequest.cpp File Reference

Bluetooth/OBEX/BtObexSetPathRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"
#include "BtObexSetPathRequest.hpp"

Include dependency graph for BtObexSetPathRequest.cpp:

Generated on Tue Jan 24 20:15:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexSetPathRequest.hpp File Reference

Bluetooth/OBEX/BtObexSetPathRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>

Include dependency graph for BtObexSetPathRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexSetPathRequest

Defines

#define | BtObexSetPathRequest_hpp

Define Documentation

#define BtObexSetPathRequest_hpp

Generated on Tue Jan 24 20:15:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexSetPathRequest.hpp Source File

Bluetooth/OBEX/BtObexSetPathRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexSetPathRequest_hpp)
00009 #define BtObexSetPathRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexClientOperationRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexClientService;
00020
00023 class BtObexSetPathRequest: public BtObexClientOperationRequest
00024 {
00025     private:
00026         typedef BtObexClientOperationRequest Base;
00027
00028     public:
00030         BtObexSetPathRequest(BtObexClientService& obex_client_service);
00031
00033         virtual ~BtObexSetPathRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00041
00043         BOOLEAN GetBackup() const;
00044
00046
00048         void SetBackup(BOOLEAN backup = TRUE);
00049
00051
00053         BOOLEAN GetCreateDirectory() const;
00054
00056
00058         void SetCreateDirectory(BOOLEAN create_directory = TRUE);
00059
00060     protected:
00062
00064         virtual BOOLEAN Execute();
00065
00067
00069         virtual void ExecutionCallback(BtResultCode result);
00070
00071 private:
00073
00075         btapi_goep_operation_t* GetApiSettings();
00076
00077     private:
00079         btapi_goep_operation_t m_operation_settings;
00080
00081     private:
00082         friend class BtObexController;
00083 };
00084
00086 #endif  // BtObexSetPathRequest_hpp
00087
00088
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexUnregisterClientRequest.cpp File Reference

Bluetooth/OBEX/BtObexUnregisterClientRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientService.hpp"
#include "BtObexController.hpp"
#include "BtObexUnregisterClientRequest.hpp"

Include dependency graph for BtObexUnregisterClientRequest.cpp:

Generated on Tue Jan 24 20:15:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp File Reference

Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexRequest.hpp>

Include dependency graph for BtObexUnregisterClientRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexUnregisterClientRequest

Defines

#define | BtObexUnregisterClientRequest_hpp

Define Documentation

#define BtObexUnregisterClientRequest_hpp

Generated on Tue Jan 24 20:15:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp Source File

Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexUnregisterClientRequest_hpp)
00009 #define BtObexUnregisterClientRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexClientService;
00020
00023 class BtObexUnregisterClientRequest: public BtObexRequest
00024 {
00025     private:
00026         typedef BtObexRequest Base;
00027
00028     public:
00030         BtObexUnregisterClientRequest(BtObexClientService& obex_client_service);
00031
00033         virtual ~BtObexUnregisterClientRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00041
00043         btapi_goep_handle_t GetObexHandle(void) const;
00044
00046
00048         void SetObexHandle(btapi_goep_handle_t obex_handle);
00049
00050     protected:
00052
00054         virtual BOOLEAN Execute();
00055
00057
00059         virtual void ExecutionCallback(BtResultCode result);
00060
00061     private:
00063
00065         btapi_goep_handle_t GetApiSettings() const;
00066
00067     private:
00069         btapi_goep_handle_t m_obex_handle;
00070
00071     private:
00072         friend class BtObexController;
00073 };
00074
00076 #endif  // BtObexUnregisterClientRequest_hpp
00077
00078
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexUnregisterServerRequest.cpp File Reference

Bluetooth/OBEX/BtObexUnregisterServerRequest.cpp File Reference

#include "PreComp.hpp"
#include "BtObexServerService.hpp"
#include "BtObexController.hpp"
#include "BtObexUnregisterServerRequest.hpp"

Include dependency graph for BtObexUnregisterServerRequest.cpp:

Generated on Tue Jan 24 20:15:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp File Reference

Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp File Reference

#include <Bluetooth/OBEX/BtObexRequest.hpp>

Include dependency graph for BtObexUnregisterServerRequest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexUnregisterServerRequest

Defines

#define | BtObexUnregisterServerRequest_hpp

Define Documentation

#define BtObexUnregisterServerRequest_hpp

Generated on Tue Jan 24 20:15:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp Source File

Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexUnregisterServerRequest_hpp)
00009 #define BtObexUnregisterServerRequest_hpp
00012
00013 #include <Bluetooth/OBEX/BtObexRequest.hpp>
00014
00015 /*  ------------------------------------------------------------------------
00016     Forward deklarations for friend relationships.
00017     ------------------------------------------------------------------------ */
00018
00019 class BtObexServerService;
00020
00023 class BtObexUnregisterServerRequest: public BtObexRequest
00024 {
00025     private:
00026         typedef BtObexRequest Base;
00027
00028     public:
00030         BtObexUnregisterServerRequest(BtObexServerService& obex_server_service);
00031
00033         virtual ~BtObexUnregisterServerRequest();
00034
00036
00038         virtual BtRequestType GetRequestType() const;
00039
00041
00043         btapi_goep_handle_t GetObexHandle(void) const;
00044
00046
00048         void SetObexHandle(btapi_goep_handle_t obex_handle);
00049
00050     protected:
00052
00054         virtual BOOLEAN Execute();
00055
00057
00059         virtual void ExecutionCallback(BtResultCode result);
00060
00061     private:
00063
00065         btapi_goep_handle_t GetApiSettings() const;
00066
00067     private:
00069         btapi_goep_handle_t m_obex_handle;
00070
00071     private:
00072         friend class BtObexController;
00073 };
00074
00076 #endif  // BtObexUnregisterServerRequest_hpp
00077
00078
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtTypes.hpp File Reference

Bluetooth/OBEX/BtTypes.hpp File Reference

#include <stack/extensions.h>
#include <Kernel/Types.hpp>

Include dependency graph for BtTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | BtObexHeader

Defines

#define | Bt_Obex_Types_hpp

Enumerations

enum BtObexErrorCode {
BtOecHandleUnknown = ObexHandleUnknown, BtOecOperationNotAllowed = ObexOperationNotAllowed, BtOecBusy = ObexBusy, BtOecNotConnected = ObexNotConnected,
BtOecConnected = ObexConnected
}
enum | BtObexHeaderType { BtOhtUnicodeString = 0x00, BtOhtByteSequence = 0x40, BtOhtByteValue = 0x80, BtOhtDWordValue = 0xC0 }
enum BtObexOperationCode {
BtOocConnect = BTAPI_GOEP_CONNECT, BtOocSetPath = BTAPI_GOEP_SETPATH, BtOocGet = BTAPI_GOEP_GET, BtOocPut = BTAPI_GOEP_PUT,
BtOocAbort = BTAPI_GOEP_ABORT, BtOocDisconnect = BTAPI_GOEP_DISCONNECT
}

Define Documentation

#define Bt_Obex_Types_hpp

Generated on Tue Jan 24 19:57:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/BtTypes.hpp Source File

Bluetooth/OBEX/BtTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bt_Obex_Types_hpp)
00009 #define Bt_Obex_Types_hpp
00012
00013 #include <stack/extensions.h>
00014 #include <Kernel/Types.hpp>
00015
00016 /*****************************************************************************
00017  * Bluetooth OBEX definitions                                                *
00018  *****************************************************************************
00019
00020  *---------------------------------------------------------------------------*
00021  * Bluetooth OBEX constants                                                  *
00022  *---------------------------------------------------------------------------*/
00023
00024 /*---------------------------------------------------------------------------*
00025  * Bluetooth OBEX enums                                                      *
00026  *---------------------------------------------------------------------------*/
00027
00029
00031 typedef enum {
00033     BtOocConnect = BTAPI_GOEP_CONNECT,
00035     BtOocSetPath = BTAPI_GOEP_SETPATH,
00037     BtOocGet = BTAPI_GOEP_GET,
00039     BtOocPut = BTAPI_GOEP_PUT,
00041     BtOocAbort = BTAPI_GOEP_ABORT,
00043     BtOocDisconnect = BTAPI_GOEP_DISCONNECT
00044 } BtObexOperationCode;
00045
00047
00049 typedef enum {
00051     BtOecHandleUnknown = ObexHandleUnknown,
00053     BtOecOperationNotAllowed = ObexOperationNotAllowed,
00055     BtOecBusy = ObexBusy,
00057     BtOecNotConnected = ObexNotConnected,
00059     BtOecConnected = ObexConnected
00060 } BtObexErrorCode;
00061
00063
00065 typedef enum
00066 {
00068     BtOhtUnicodeString = 0x00,
00070     BtOhtByteSequence  = 0x40,
00072     BtOhtByteValue     = 0x80,
00074     BtOhtDWordValue    = 0xC0
00075 } BtObexHeaderType;
00076
00077 /*---------------------------------------------------------------------------*
00078  * Bluetooth OBEX types                                                      *
00079  *---------------------------------------------------------------------------*/
00080
00081 typedef struct {
00082     union {
00083         struct {
00084             const UINT8*  buffer;
00085             UINT16        size;
00086         }                 byte_sequence;
00087         struct {
00088             const UINT16* buffer;
00089             UINT16        size;
00090         }                 unicode_string;
00091         UINT8             byte_value;
00092         UINT32            dword_value;
00093     }                     value;
00094     BtObexHeaderType      header_type;
00095     UINT8                 header_id;
00096 } BtObexHeader;
00097
00099 #endif // Bt_Obex_Types_hpp
00100
00101
Generated on Tue Jan 24 14:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/Lib.hpp File Reference

Bluetooth/OBEX/Lib.hpp File Reference

#include <Bluetooth/OBEX/BtTypes.hpp>
#include <Bluetooth/OBEX/BtObexEvent.hpp>
#include <Bluetooth/OBEX/BtObexNotificationMessage.hpp>
#include <Bluetooth/OBEX/BtObexServiceMessage.hpp>
#include <Bluetooth/OBEX/BtObexMessageArguments.hpp>
#include <Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>
#include <Bluetooth/OBEX/BtObexController.hpp>
#include <Bluetooth/OBEX/BtObexService.hpp>
#include <Bluetooth/OBEX/BtObexServiceObserver.hpp>
#include <Bluetooth/OBEX/BtObexClientService.hpp>
#include <Bluetooth/OBEX/BtObexClientServiceObserver.hpp>
#include <Bluetooth/OBEX/BtObexRegisterClientRequest.hpp>
#include <Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp>
#include <Bluetooth/OBEX/BtObexConnectRequest.hpp>
#include <Bluetooth/OBEX/BtObexDisconnectRequest.hpp>
#include <Bluetooth/OBEX/BtObexSetPathRequest.hpp>
#include <Bluetooth/OBEX/BtObexGetRequest.hpp>
#include <Bluetooth/OBEX/BtObexPutRequest.hpp>
#include <Bluetooth/OBEX/BtObexAbortRequest.hpp>
#include <Bluetooth/OBEX/BtObexServerService.hpp>
#include <Bluetooth/OBEX/BtObexServerServiceObserver.hpp>
#include <Bluetooth/OBEX/BtObexRegisterServerRequest.hpp>
#include <Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp>

Include dependency graph for Lib.hpp:

Go to the source code of this file.

Defines

#define Bluetooth_Obex_Lib_hpp

Define Documentation

#define Bluetooth_Obex_Lib_hpp

Generated on Tue Jan 24 14:54:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/Lib.hpp Source File

Bluetooth/OBEX/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bluetooth_Obex_Lib_hpp)
00009 #define Bluetooth_Obex_Lib_hpp
00012
00013 #include <Bluetooth/OBEX/BtTypes.hpp>
00014 #include <Bluetooth/OBEX/BtObexEvent.hpp>
00015 #include <Bluetooth/OBEX/BtObexNotificationMessage.hpp>
00016 #include <Bluetooth/OBEX/BtObexServiceMessage.hpp>
00017 #include <Bluetooth/OBEX/BtObexMessageArguments.hpp>
00018 #include <Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>
00019 #include <Bluetooth/OBEX/BtObexController.hpp>
00020 #include <Bluetooth/OBEX/BtObexService.hpp>
00021 #include <Bluetooth/OBEX/BtObexServiceObserver.hpp>
00022 #include <Bluetooth/OBEX/BtObexClientService.hpp>
00023 #include <Bluetooth/OBEX/BtObexClientServiceObserver.hpp>
00024 #include <Bluetooth/OBEX/BtObexRegisterClientRequest.hpp>
00025 #include <Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp>
00026 #include <Bluetooth/OBEX/BtObexConnectRequest.hpp>
00027 #include <Bluetooth/OBEX/BtObexDisconnectRequest.hpp>
00028 #include <Bluetooth/OBEX/BtObexSetPathRequest.hpp>
00029 #include <Bluetooth/OBEX/BtObexGetRequest.hpp>
00030 #include <Bluetooth/OBEX/BtObexPutRequest.hpp>
00031 #include <Bluetooth/OBEX/BtObexAbortRequest.hpp>
00032 #include <Bluetooth/OBEX/BtObexServerService.hpp>
00033 #include <Bluetooth/OBEX/BtObexServerServiceObserver.hpp>
00034 #include <Bluetooth/OBEX/BtObexRegisterServerRequest.hpp>
00035 #include <Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp>
00036
00038 #endif /* Bluetooth_Obex_Lib_hpp */
00039
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/PreComp.cpp File Reference

Bluetooth/OBEX/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/PreComp.hpp File Reference

Bluetooth/OBEX/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Bluetooth/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:19:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/PreComp.hpp Source File

Bluetooth/OBEX/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Bluetooth/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.cpp File Reference

#include "PreComp.hpp"
#include "BtObexTransport.hpp"
#include "BtObexImplAddress.hpp"
#include "BtObexClientAddrResultNotifier.hpp"

Include dependency graph for BtObexClientAddrResultNotifier.cpp:

Generated on Tue Jan 24 20:15:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.hpp File Reference

#include <Obex/ObexOperationId.hpp>
#include <Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>

Include dependency graph for BtObexClientAddrResultNotifier.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientAddrResultNotifier

Defines

#define | Apoxi_BtObexClientAddrResultNotifier_hpp

Define Documentation

#define Apoxi_BtObexClientAddrResultNotifier_hpp

Generated on Tue Jan 24 20:15:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_BtObexClientAddrResultNotifier_hpp)
00009 #define Apoxi_BtObexClientAddrResultNotifier_hpp
00010
00011 #include <Obex/ObexOperationId.hpp>
00012
00013 #include <Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp>
00014 #include <Bluetooth/BtDeviceAddress.hpp>
00015
00016
00017 class BtObexClientAddrResultNotifier: public BtOperationSelectDeviceAndPerformServiceVerify
00018 {
00019     private:
00020         typedef BtOperationSelectDeviceAndPerformServiceVerify Base;
00021
00022     public:
00023         static SharedPtr<BtObexClientAddrResultNotifier>
00024                     Create(const ObexOperationId &  job_id,
00025                            BtSecuritySettings       security,
00026                            const BtDeviceAddress &  device_addr,
00027                            UINT8                    rfcomm_chan);
00028
00029     protected:
00030         BtObexClientAddrResultNotifier(const ObexOperationId &  job_id,
00031                                        BtSecuritySettings       security,
00032                                        const BtDeviceAddress &  device_addr,
00033                                        UINT8                    rfcomm_chan);
00034
00035         virtual void OnResult(BtResultCode result);
00036
00037     private:
00038         BtDeviceAddress     m_device_addr_2_verify;
00039         UINT8               m_rfcomm_chan_2_verify;
00040         BtSecuritySettings  m_security_settings;
00041         ObexOperationId     m_job_id;
00042 };
00043
00044 #endif  // Apoxi_BtObexClientAddrResultNotifier_hpp
00045
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientObserverImpl.hpp"
#include "BtObexTransport.hpp"
#include "BtObexImpl.hpp"
#include <Auxiliary/String.hpp>
#include <Auxiliary/ByteBuffer.hpp>
#include <Obex/ObexBuffer.hpp>
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for BtObexClientObserverImpl.cpp:

Generated on Tue Jan 24 20:15:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientServiceObserver.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexBuffer.hpp>

Include dependency graph for BtObexClientObserverImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientObserverImpl
This class contains the implementation of the Client Service Observer, related to the Bt stack/controller callbacks for Obex Client operations (Connect, Put, Get, ...). More...

Defines

#define | Apoxi_BtObexClientObserverImpl_hpp

Define Documentation

#define Apoxi_BtObexClientObserverImpl_hpp

Generated on Tue Jan 24 20:15:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp

Go to the documentation of this file.
00001
00002 #if !defined(Apoxi_BtObexClientObserverImpl_hpp)
00003 #define Apoxi_BtObexClientObserverImpl_hpp
00004
00005 #include <Bluetooth/OBEX/BtObexClientServiceObserver.hpp>
00006 #include <Obex/ObexObject.hpp>
00007 #include <Obex/ObexBuffer.hpp>
00008 class BtObexImpl;
00009
00013 class BtObexClientObserverImpl: public BtObexClientServiceObserver
00014 {
00015
00016     typedef BtObexClientServiceObserver Base;
00017
00018     public:
00020         BtObexClientObserverImpl();
00021
00023         virtual ~BtObexClientObserverImpl();
00024
00025     protected:
00027
00029         virtual void OnRegister(BtResultCode code);
00030
00032
00034         virtual void OnResponse(BtResultCode code, UINT8 response_code);
00035
00037
00039         virtual void OnUnregister(BtResultCode result);
00040
00042
00044         virtual void OnHeader(BtResultCode result, const BtObexHeader& header);
00045
00047
00049         virtual void OnHeaderSent( BtResultCode resul ){}; //unuseful for Client, ignore
00050
00052
00054         virtual void OnDataRequested(BtResultCode result);
00055
00057
00059         virtual void OnBufferRequested(BtResultCode result, UINT16 last_buffer_filled, BOOLEAN delete_object, BOOLEAN create_empty_object);
00060
00062
00064         virtual void OnTransportDisconnect(BtResultCode result); //cannot be implemented before controller availability, lack of specification
00065
00067
00069         virtual void OnError(BtObexErrorCode error){}; //cannot be implemented before controller availability, lack of specification
00070
00071         //New Interface. Under evaluation, remapping on the OnResponse only?
00074         virtual void OnConnect(BtResultCode code, UINT8 response_code);
00075
00077
00079         virtual void OnDisconnect(BtResultCode code, UINT8 response_code);
00080
00082
00084         virtual void OnSetPath(BtResultCode code, UINT8 response_code);
00085
00087
00089         virtual void OnGet(BtResultCode code, UINT8 response_code);
00090
00092
00094         virtual void OnPut(BtResultCode code, UINT8 response_code);
00095
00097
00099         virtual void OnAbort(BtResultCode code, UINT8 response_code);
00100
00101
00102     private:
00103
00104
00110         inline void SetIndex( UINT8 id ) { m_id = id; };
00111
00114         void ResetObserverInstance();
00115
00118         void AllocateResponseObexBufferIfNeeded();
00119
00121         UINT8 m_id;
00122
00124         UINT32 m_req_buf_byte_read;
00125
00127         ObexObject m_curr_resp_obj;
00128
00130         ObexBuffer m_curr_resp_buf;
00131
00133         friend class BtObexImpl;
00134
00135 };
00136
00137 #endif
00138
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.cpp File Reference

#include "PreComp.hpp"
#include "BtObexClientServiceImpl.hpp"

Include dependency graph for BtObexClientServiceImpl.cpp:

Generated on Tue Jan 24 20:15:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp File Reference

#include <Bluetooth/OBEX/BtObexClientService.hpp>

Include dependency graph for BtObexClientServiceImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientServiceImpl
This class contains the extension of the BtObexClientService class. More...

Defines

#define | Apoxi_BtObexClientServiceImpl_hpp

Define Documentation

#define Apoxi_BtObexClientServiceImpl_hpp

Generated on Tue Jan 24 20:15:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp

Go to the documentation of this file.
00001 #if !defined(Apoxi_BtObexClientServiceImpl_hpp)
00002 #define Apoxi_BtObexClientServiceImpl_hpp
00003
00004
00005 #include <Bluetooth/OBEX/BtObexClientService.hpp>
00006
00013 class BtObexClientServiceImpl : public BtObexClientService
00014 {
00015     private:
00016         typedef BtObexClientService Base;
00017
00018     public:
00019         BtObexClientServiceImpl();
00020         virtual ~BtObexClientServiceImpl();
00021
00022     protected:
00023         virtual void OnRequestStateChange( BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00024 };
00025
00026 #endif
00027
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexImpl.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexImpl.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/MutexObtainer.hpp>
#include <Auxiliary/ByteBuffer.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexBuffer.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>
#include <Bluetooth/BtSddbService.hpp>
#include <Bluetooth/BtSddbDataElements.hpp>
#include "BtObexTransport.hpp"
#include "BtObexImplAddress.hpp"
#include "BtObexSddbImpl.hpp"
#include "BtObexImpl.hpp"

Include dependency graph for BtObexImpl.cpp:

Generated on Tue Jan 24 20:15:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp File Reference

#include <Auxiliary/String.hpp>
#include <Obex/ObexLayer.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexAddress.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp>
#include <Kernel/Os/Mutex.hpp>

Include dependency graph for BtObexImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexImpl
This class contains the implementation of Obex related operations (Connect, Put, Get, ...) for both Client and Server connections. More...
class | BtObexImpl::BtObexClientConnection
Information for managing an Obex Client connection (i.e. instance).
class | BtObexImpl::BtObexServerConnection
Information for managing an Obex Server connection (i.e. instance).
class | BtObexImpl::ChannelPool
Structure to manage relationships among: channel, address, Client/Server Service instances.

Defines

#define | Apoxi_BtObexImpl_hpp
#define | BT_OBEX_DEBUG_OUT 40230
#define | LOCAL_BUFFER_SIZE (1024)
Size of temporary local buffers.
#define | MAX_BT_AVAILABLE_CHANNELS (MAX_BT_CLIENT_CHANNELS + MAX_BT_SERVER_CHANNELS)
#define | MAX_BT_CLIENT_CHANNELS 3
Maximum Number of Client Service instances.
#define | MAX_BT_SERVER_CHANNELS 2
Maximum Number of Client Service instances.
#define | OBEX_BUFFER_MAX_SIZE (LOCAL_BUFFER_SIZE)
Max size of Obex related buffers.
#define | OBEX_HEADER_SIZE 1320
Size of the header buffer.

Define Documentation

#define Apoxi_BtObexImpl_hpp

#define BT_OBEX_DEBUG_OUT 40230

#define LOCAL_BUFFER_SIZE (1024)

Size of temporary local buffers.

#define MAX_BT_AVAILABLE_CHANNELS (MAX_BT_CLIENT_CHANNELS + MAX_BT_SERVER_CHANNELS)

#define MAX_BT_CLIENT_CHANNELS 3

Maximum Number of Client Service instances.

#define MAX_BT_SERVER_CHANNELS 2

Maximum Number of Client Service instances.

#define OBEX_BUFFER_MAX_SIZE (LOCAL_BUFFER_SIZE)

Max size of Obex related buffers.

#define OBEX_HEADER_SIZE 1320

Size of the header buffer.

Generated on Tue Jan 24 20:15:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp

Go to the documentation of this file.
00001
00002 #if !defined(Apoxi_BtObexImpl_hpp)
00003 #define Apoxi_BtObexImpl_hpp
00004
00005 #include <Auxiliary/String.hpp>
00006 #include <Obex/ObexLayer.hpp>
00007 #include <Obex/ObexChannel.hpp>
00008 #include <Obex/ObexAddress.hpp>
00009
00010 #include <Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp>
00011 #include <Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp>
00012 #include <Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp>
00013 #include <Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp>
00014 #include <Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp>
00015 #include <Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp>
00016 #include <Kernel/Os/Mutex.hpp>
00017
00018 #define BT_OBEX_DEBUG_OUT 40230
00019
00020 //Forward declaration for friend class
00021 class BtObexClientObserverImpl;
00022 //class Mutex;
00023
00031 class BtObexImpl : public ObexLayer
00032 {
00033     typedef ObexLayer Base;
00034
00035     class BtObexClientConnection;
00036     class BtObexServerConnection;
00037
00038     friend class BtObexClientConnection;
00039     friend class BtObexServerConnection;
00040
00041     public:
00043         BtObexImpl();
00044
00046         virtual ~BtObexImpl();
00047
00059         virtual ObexResult AcquireClientChannel( ObexChannel& result,
00060                                                                 const ObexAddrPtr & addr_ptr,
00061                                                                 BOOLEAN reserve = FALSE);
00062
00070         virtual void OpenClientChannel( const ObexChannel & client_chan,
00071                                                     ObexOperationId oper_id,
00072                                                     const ObexAddrPtr & addr_ptr );
00073
00074
00085         virtual ObexResult AcquireServerChannel( ObexChannel& result,
00086                                                                 const ObexAddrPtr & addr_ptr,
00087                                                                 BOOLEAN reserve = FALSE );
00088
00089
00098         virtual void BindServerChannel( const ObexChannel & server_chan,
00099                                                     ObexOperationId oper_id,
00100                                                     const ObexAddrPtr & addr_ptr );
00101
00102
00109         virtual void CloseChannel(const ObexChannel &  channel,
00110                                   ObexOperationId      oper_id);
00111
00112
00119         virtual ObexResult ReleaseChannel(ObexChannel &  channel);
00120
00121
00130         virtual void Connect( const ObexChannel & client_chan,
00131                                     ObexOperationId oper_id,
00132                                     const ObexObject & conn_req );
00133
00134
00140         virtual void Put( const ObexChannel &   client_chan,
00141                             ObexOperationId oper_id,
00142                             const ObexObject & put_req);
00143
00144
00154         virtual void Get(const ObexChannel & client_chan,
00155                             ObexOperationId oper_id,
00156                             const ObexObject & get_req);
00157
00158
00165         virtual void Abort(const ObexChannel & client_chan, ObexOperationId oper_id, const ObexObject & abort_req);
00166
00167
00176         virtual void SetPath( const ObexChannel & client_chan,
00177                                     ObexOperationId oper_id,
00178                                     const ObexObject & setp_req);
00179
00180
00188             virtual void Disconnect( const ObexChannel & client_chan,
00189                                         ObexOperationId oper_id,
00190                                         const ObexObject & disc_req);
00191
00198         virtual void ReturnResponse(const ObexChannel & server_chan,
00199                                                 ObexOperationId oper_id,
00200                                                 const ObexObject & server_resp);
00201
00210         virtual void DataProcessed(const ObexChannel & channel, ObexOperationId oper_id, ObexBuffer & obex_buffer);
00211
00212         Mutex* GetTransportMutex() {return &m_transport_mutex;};
00213
00214     private:
00222         void Init();
00223
00224 #ifdef APOXI_PLATFORM_BP30
00225
00226         #define MAX_BT_CLIENT_CHANNELS 1
00227
00228         #define MAX_BT_SERVER_CHANNELS 1
00229 #else /* APOXI_PLATFORM_BP30 */
00230
00231         #define MAX_BT_CLIENT_CHANNELS 3
00232
00233         #define MAX_BT_SERVER_CHANNELS 2
00234 #endif /* APOXI_PLATFORM_BP30 */
00235
00236         #define MAX_BT_AVAILABLE_CHANNELS (MAX_BT_CLIENT_CHANNELS + MAX_BT_SERVER_CHANNELS)
00237
00239         #define OBEX_HEADER_SIZE 1320
00240
00242         //XXXXX
00243         //#define LOCAL_BUFFER_SIZE 512
00244         #define LOCAL_BUFFER_SIZE (1024)
00245
00247         //XXXXX
00248         //#define OBEX_BUFFER_MAX_SIZE 600
00249         #define OBEX_BUFFER_MAX_SIZE (LOCAL_BUFFER_SIZE)
00250
00252         enum ChannelPoolStatus
00253         {
00254             Free,
00255             Allocated,
00256             Associated
00257         };
00258
00260         class  ChannelPool
00261         {
00262             public:
00263                 ObexChannel m_chp_channel;
00264                 ObexAddrPtr m_chp_addr_p;
00265                 UINT8 m_chp_cs_idx;
00266                 ChannelPoolStatus m_chp_status;
00267         };
00268
00270         ChannelPool m_channel_pool[MAX_BT_AVAILABLE_CHANNELS];
00271
00273         UINT8 m_num_cli_idx;
00274
00276         UINT8 m_num_srv_idx;
00277
00278         BOOLEAN m_empty_buff_rec;
00279
00284         BOOLEAN AllocateIndex( UINT16 &returned_index );
00285
00290         BOOLEAN DeallocateIndex( UINT16 index );
00291
00292
00293         //TBD: Is it really necessary?
00294         BOOLEAN CheckAddressInThePool( const ObexAddrPtr &addr_ptr );
00295
00297         enum ClientConnectionStatus
00298         {
00299             ClientFree,
00300             ClientReady,
00301             ClientOpened,
00302             ClientConnected
00303         };
00304
00306         enum ClientOperationStatus
00307         {
00308             ClientOperationReady,
00309             ClientOpenRequested,
00310             ClientCloseRequested,
00311             ClientConnectRequested,
00312             ClientPut,
00313             ClientAbortRequested,
00314             ClientGetRequested,
00315             ClientGetEnd,
00316             ClientSetPathRequested,
00317             ClientDisconnectRequested
00318         };
00319
00321         enum ServerConnectionStatus
00322         {
00323             ServerFree,
00324             ServerReady,
00325             ServerBounded,
00326             ServerConnected
00327         };
00328
00330         enum ServerOperationStatus
00331         {
00332             ServerOperationReady,
00333             ServerBindRequested,
00334             ServerCloseRequested,
00335             ServerConnectIncoming,
00336             ServerPutIncoming,
00337             ServerPutContinue,
00338             ServerPutEnd,
00339             ServerAbortIncoming,
00340             ServerGetIncoming,
00341             ServerGetContinue,
00342             ServerSetPathIncoming,
00343             ServerDisconnectIncoming
00344         };
00345
00347         class BtObexClientConnection
00348         {
00349             public:
00350                 BtObexClientServiceImpl m_service;
00351                 ClientConnectionStatus m_status;
00352                 ClientOperationStatus m_op_status;
00353                 ObexOperationId m_op_id;
00354                 ObexBuffer m_obj_buffer;
00355                 ObexObject m_obex_abort;
00356                 BOOLEAN m_obj_is_end_of_data;
00357                 BOOLEAN m_ready;
00358                 UINT8 m_header[OBEX_HEADER_SIZE];
00359                 UINT16 m_index;
00360
00361                 void            BeginOperation(const ObexOperationId &  oper_id,
00362                                                ClientOperationStatus    status);
00363
00364                 ObexOperationId EndOperation();
00365         };
00366
00368         class BtObexServerConnection
00369         {
00370             public:
00371                 BtObexServerServiceImpl m_service;
00372                 BtObexSddbImpl m_sddb_service;
00373                 ServerConnectionStatus m_status;
00374                 ServerOperationStatus m_op_status;
00375                 ObexOperationId m_op_id;
00376                 ObexBuffer m_obj_buffer;
00377                 BOOLEAN m_obj_is_end_of_data;
00378                 BOOLEAN m_ready;
00379                 BOOLEAN m_isAborted;
00380                 ObexServerId    m_obex_server_id;
00381                 UINT8 m_header[OBEX_HEADER_SIZE];
00382                 UINT16 m_index;
00383
00384                 void            BeginOperation(const ObexOperationId &  oper_id,
00385                                                ServerOperationStatus    status);
00386
00387                 ObexOperationId EndOperation();
00388
00389                 void            HandleAbortIfPending();
00390         };
00391
00392         static  void            AddHeader(ObexObject &          obex_obj,
00393                                           const BtObexHeader &  header);
00394
00401         BOOLEAN AllocateClientInstance( UINT16 index );
00402
00409         BOOLEAN AllocateServerInstance( UINT16 index );
00410
00418         BOOLEAN GetServiceIndex( const ObexChannel &ob_chan, UINT8 &instance_index );
00419
00427         BOOLEAN GetServiceIndex( UINT16 index, UINT8 &instance_index );
00428
00433         void ObexClientHeadersToServiceHeaders( const ObexObject &obj, UINT8 i );
00434         void ObexServerHeadersToServiceHeaders( const ObexObject &obj, UINT8 i );
00435
00436         void    AcceptServerOperation(UINT8                     conn_no,
00437                                       ServerOperationStatus     status);
00438
00440         void    FinishClientOperation(UINT8             conn_no,
00441                                       const ObexResult  result);
00442
00444         void    FinishServerOperation(UINT8             conn_no,
00445                                       const ObexResult  result);
00446
00450         BOOLEAN CreateObexServiceRecord( UINT16 index );
00451
00455         void DbgOut( String dbg_str );
00456
00458         BtObexClientConnection m_cli[MAX_BT_CLIENT_CHANNELS];
00459
00461         BtObexClientObserverImpl m_cli_obs[MAX_BT_CLIENT_CHANNELS];
00462
00464         BtObexServerConnection m_srv[MAX_BT_SERVER_CHANNELS];
00465
00467         BtObexServerObserverImpl m_srv_obs[MAX_BT_SERVER_CHANNELS];
00468
00470         BtObexSddbServiceObserverImpl m_srv_sddb_service[MAX_BT_SERVER_CHANNELS];
00471
00472         Mutex m_transport_mutex;
00473
00475         friend class BtObexServerObserverImpl;
00476
00478         friend class BtObexClientObserverImpl;
00479
00480         friend class BtObexSddbServiceObserverImpl;
00481 };
00482
00483 #endif
00484
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexImplAddress.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexImplAddress.cpp File Reference

#include "PreComp.hpp"
#include "BtObexTransport.hpp"
#include "BtObexImplAddress.hpp"

Include dependency graph for BtObexImplAddress.cpp:

Generated on Tue Jan 24 20:15:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp File Reference

#include <Auxiliary/String.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Bluetooth/BtDeviceAddress.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Obex/ObexAddress.hpp>

Include dependency graph for BtObexImplAddress.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexClientAddr
class | BtObexServerAddr

Defines

#define | Apoxi_BtObexImplAddress_hpp

Define Documentation

#define Apoxi_BtObexImplAddress_hpp

Generated on Tue Jan 24 20:15:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_BtObexImplAddress_hpp)
00009 #define Apoxi_BtObexImplAddress_hpp
00010
00011 #include <Auxiliary/String.hpp>
00012 #include <Auxiliary/SharedPtr.hpp>
00013 #include <Bluetooth/BtDeviceAddress.hpp>
00014 #include <Bluetooth/BtTypes.hpp>
00015 #include <Obex/ObexAddress.hpp>
00016
00017
00018 class BtObexServerObserverImpl;
00019 class BtObexTransport;
00020
00022 class BtObexClientAddr : public ObexClientAddr
00023 {
00024     friend class BtObexTransport;
00025
00026     private:
00027         typedef ObexClientAddr Base;
00028
00029     public:
00031         static SharedPtr<BtObexClientAddr>
00032                             Create(BtSecuritySettings       security    = BtSesNoSecurity,
00033                                    const BtDeviceAddress &  device_addr = bt_c_empty_device_address,
00034                                    UINT8                    rfcomm_chan = 0);
00035
00036         virtual ObexResult  ToString(String &  obex_url) const;
00037
00038         inline const BtDeviceAddress &  GetDeviceAddress() const
00039         {
00040             return  m_device_addr;
00041         }
00042
00043         inline UINT8                    GetRfCommChannel() const
00044         {
00045             return  m_rfcomm_chan;
00046         }
00047
00049         inline UINT8                    GetRemoteRfComm()
00050         {
00051             return  m_rfcomm_chan;
00052         }
00053
00054         inline BtSecuritySettings       GetSecurity() const
00055         {
00056             return  m_security;
00057         }
00058
00060         void                        GetRemoteAddr( UINT8* remote_addr );
00061
00066         void    BtObexSetClientAddrInfo(const UINT8* remote_addr, UINT8 remote_channel );
00067
00068     protected:
00071         BtObexClientAddr(BtSecuritySettings         security,
00072                          const BtDeviceAddress &    device_addr,
00073                          UINT8                      rfcomm_chan);
00074
00075     private:
00077         BtDeviceAddress     m_device_addr;
00079         UINT8               m_rfcomm_chan;
00081         BtSecuritySettings  m_security;
00082 };
00083
00084
00086 class BtObexServerAddr : public ObexServerAddr
00087 {
00088     friend class BtObexServerObserverImpl;
00089     friend class BtObexTransport;
00090
00091     public:
00092
00093         enum BtObexServerCodes
00094         {
00095             InvalidRfCommPortNumber = 0xFF
00096         };
00097
00099         static SharedPtr<BtObexServerAddr> Create();
00100
00101         virtual ObexResult ToString(String &  obex_url) const;
00102
00103         UINT8   GetRfCommPortNumber();
00104         void    SetRfCommPortNumber( UINT8 rfcomm );
00105         void    SetServerUuid128( UINT8* service_id );
00106         void    SetServerTargetString( String target );
00107
00108         void    SetSddbCase( UINT16 sddb_case );
00109         UINT16  GetSddbCase();
00110         void    SetServerDefaultParam();
00111         void    SetSecurity(BtSecuritySettings security) {m_security = security;};
00112
00113         const String &      GetServiceName() const
00114         {
00115             return m_service_name;
00116         }
00117
00118         BtSecuritySettings  GetSecurity() {return m_security;};
00119
00120     protected:
00122         BtObexServerAddr();
00123
00124     private:
00125         typedef ObexServerAddr Base;
00126
00127         UINT8               m_uuid128[16];
00128         UINT16              m_sddb_case;
00129         UINT8               m_local_rfcomm;
00130         String              m_service_name;
00131         String              m_target;
00132         BtSecuritySettings  m_security;
00133
00134         void                SetServiceName(const String &   service_name)
00135         {
00136             m_service_name = service_name;
00137         }
00138
00139 };
00140
00141 #endif
00142
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.cpp File Reference

#include "PreComp.hpp"
#include "BtObexSddbImpl.hpp"

Include dependency graph for BtObexSddbImpl.cpp:

Generated on Tue Jan 24 20:15:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp File Reference

#include <Bluetooth/BtSddbService.hpp>

Include dependency graph for BtObexSddbImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexSddbImpl

Defines

#define | Apoxi_BtObexSddbImpl_hpp

Define Documentation

#define Apoxi_BtObexSddbImpl_hpp

Generated on Tue Jan 24 20:15:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp

Go to the documentation of this file.
00001 #if !defined(Apoxi_BtObexSddbImpl_hpp)
00002 #define Apoxi_BtObexSddbImpl_hpp
00003
00004
00005 #include <Bluetooth/BtSddbService.hpp>
00006
00007 class BtObexSddbImpl : public BtSddbService
00008 {
00009     typedef BtSddbService Base;
00010
00011     public:
00013         BtObexSddbImpl();
00014
00016         virtual ~BtObexSddbImpl();
00017
00018         BtRequestState UnregisterServiceRecordRequest();
00019
00020     protected:
00021         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00022 };
00023
00024
00025 #endif
00026
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.cpp File Reference

#include "PreComp.hpp"
#include "BtObexSddbServiceObserverImpl.hpp"
#include "BtObexTransport.hpp"
#include "BtObexImpl.hpp"
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for BtObexSddbServiceObserverImpl.cpp:

Generated on Tue Jan 24 20:15:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp File Reference

#include <Bluetooth/BtSddbServiceObserver.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexBuffer.hpp>

Include dependency graph for BtObexSddbServiceObserverImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexSddbServiceObserverImpl
This class contains the implementation of the BtSddb Service Observer, related to the Bt stack/controller callbacks for Sddb operations (Register, Reregister, Unregister). More...

Defines

#define | Apoxi_BtSddbServiceObserverImpl_hpp

Define Documentation

#define Apoxi_BtSddbServiceObserverImpl_hpp

Generated on Tue Jan 24 20:15:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp

Go to the documentation of this file.
00001
00002 #if !defined(Apoxi_BtSddbServiceObserverImpl_hpp)
00003 #define Apoxi_BtSddbServiceObserverImpl_hpp
00004
00005 #include <Bluetooth/BtSddbServiceObserver.hpp>
00006 #include <Obex/ObexObject.hpp>
00007 #include <Obex/ObexBuffer.hpp>
00008
00012 class BtObexSddbServiceObserverImpl: public BtSddbServiceObserver
00013 {
00014     private:
00015         typedef BtSddbServiceObserver Base;
00016
00017     public:
00019         BtObexSddbServiceObserverImpl();
00020
00022         virtual ~BtObexSddbServiceObserverImpl();
00023
00025
00027         inline void SetIndex( UINT8 id ) { m_id = id; };
00028
00029     protected:
00030
00032
00034         virtual void OnRegisterService(BtResultCode code);
00035
00037
00039         virtual void OnUnregisterService(BtResultCode code);
00040
00041
00042         UINT8 m_id;
00043
00044 private:
00045         friend class BtSddbService;
00046 };
00047
00048 #endif//BtSddbServiceObserverImpl
00049
00050
00051
00052
00053
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.cpp File Reference

#include "PreComp.hpp"
#include "BtObexServerObserverImpl.hpp"
#include "BtObexTransport.hpp"
#include "BtObexImpl.hpp"
#include "BtObexImplAddress.hpp"
#include <Auxiliary/String.hpp>
#include <Auxiliary/ByteBuffer.hpp>
#include <Obex/ObexBuffer.hpp>
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for BtObexServerObserverImpl.cpp:

Generated on Tue Jan 24 20:15:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp File Reference

#include <Bluetooth/OBEX/BtObexServerServiceObserver.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexBuffer.hpp>

Include dependency graph for BtObexServerObserverImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexServerObserverImpl
This class contains the implementation of the Server Service Observer, related to the Bt stack/controller callbacks for Obex Server operations (Put, Get, ...). More...

Defines

#define | Apoxi_BtObexServerObserverImpl_hpp

Define Documentation

#define Apoxi_BtObexServerObserverImpl_hpp

Generated on Tue Jan 24 20:15:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp

Go to the documentation of this file.
00001
00002 #if !defined(Apoxi_BtObexServerObserverImpl_hpp)
00003 #define Apoxi_BtObexServerObserverImpl_hpp
00004
00005 #include <Bluetooth/OBEX/BtObexServerServiceObserver.hpp>
00006 #include <Bluetooth/BtDevice.hpp>
00007 #include <Obex/ObexObject.hpp>
00008 #include <Obex/ObexBuffer.hpp>
00009
00010
00011 class BtObexImpl;
00016 class BtObexServerObserverImpl: public BtObexServerServiceObserver
00017 {
00018
00019     typedef BtObexServerServiceObserver Base;
00020
00021     public:
00023         BtObexServerObserverImpl();
00024
00026         virtual ~BtObexServerObserverImpl();
00027
00033         inline void SetIndex( UINT8 id ) { m_id = id; };
00034
00035     protected:
00037
00039         virtual void OnRegister(BtResultCode code, UINT8 rfcom_channel);
00040
00042
00044         virtual void OnConnect(BtResultCode code, const BtDevice& device);
00045
00047
00049         virtual void OnDisconnect(BtResultCode code);
00050
00052
00054         virtual void OnSetPath(BtResultCode code, BOOLEAN backup, BOOLEAN create);
00055
00057
00059         virtual void OnGet(BtResultCode code);
00060
00062
00064         virtual void OnPut(BtResultCode code);
00065
00067
00069         virtual void OnAbort(BtResultCode code);
00070
00072
00074         virtual void OnHeaderSent(BtResultCode result);
00075
00077
00079         virtual void OnUnregister(BtResultCode result) ;
00080
00082
00084         virtual void OnHeader(BtResultCode result, const BtObexHeader& header);
00085
00087
00089         virtual void OnDataRequested(BtResultCode result);
00090
00092
00094         virtual void OnBufferRequested(BtResultCode result, UINT16 last_buffer_filled, BOOLEAN delete_object, BOOLEAN create_empty_object);
00095
00097
00099         virtual void OnTransportDisconnect(BtResultCode result); //cannot be implemented before controller availability, lack of specification
00100
00102
00104         virtual void OnError(BtObexErrorCode error){}; //cannot be implemented before controller availability, lack of specification
00105
00106     private:
00107
00110         void ResetObserverInstance();
00111
00114         void AllocateIncomingObexBufferIfNeeded();
00115
00116         UINT8 m_id;
00117
00119         ObexObject m_incoming_obj;
00120
00122         ObexBuffer m_incoming_buf;
00123
00125         UINT32 m_buf_byte_read;
00126
00128         friend class BtObexImpl;
00129
00130 };
00131
00132 #endif
00133
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.cpp File Reference

#include "PreComp.hpp"
#include "BtObexServerServiceImpl.hpp"

Include dependency graph for BtObexServerServiceImpl.cpp:

Generated on Tue Jan 24 20:15:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp File Reference

#include <Bluetooth/OBEX/BtObexServerService.hpp>

Include dependency graph for BtObexServerServiceImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexServerServiceImpl
This class contains the extension of the BtObexServerService class. More...

Defines

#define | Apoxi_BtObexServerServiceImpl_hpp

Define Documentation

#define Apoxi_BtObexServerServiceImpl_hpp

Generated on Tue Jan 24 20:15:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp

Go to the documentation of this file.
00001
00002 #if !defined(Apoxi_BtObexServerServiceImpl_hpp)
00003 #define Apoxi_BtObexServerServiceImpl_hpp
00004
00005 #include <Bluetooth/OBEX/BtObexServerService.hpp>
00006
00007
00014 class BtObexServerServiceImpl : public BtObexServerService
00015 {
00016     private:
00017         typedef BtObexServerService Base;
00018
00019     public:
00020         BtObexServerServiceImpl();
00021         virtual ~BtObexServerServiceImpl();
00022
00023     protected:
00024         virtual void OnRequestStateChange( BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00025 };
00026
00027 #endif
00028
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServiceTable.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexServiceTable.cpp File Reference

#include "PreComp.hpp"
#include <Auxiliary/ByteBuffer.hpp>
#include "BtObexServiceTable.hpp"

Include dependency graph for BtObexServiceTable.cpp:

Generated on Tue Jan 24 20:15:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp File Reference

#include <Kernel/Types.hpp>
#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtObexServiceTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexServiceTable
struct | BtObexServiceTable::Entry
struct | BtObexServiceTable::ObexTarget
struct | BtObexServiceTable::Security
class | BtObexServiceTable::ServiceInfo

Defines

#define | APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY BtSesNoSecurity
Default APOXI Bluetooth OBEX client security settings.
#define | APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY BtSesAuthorization
Default APOXI Bluetooth OBEX server security settings.
#define | Apoxi_BtObexServiceTable_hpp

Functions

BOOLEAN | operator!= (const BtObexServiceTable::ServiceInfo &lhs, const BtObexServiceTable::ServiceInfo &rhs)
BOOLEAN | operator== (const BtObexServiceTable::ServiceInfo &lhs, const BtObexServiceTable::ServiceInfo &rhs)

Define Documentation

#define Apoxi_BtObexServiceTable_hpp

Generated on Tue Jan 24 20:15:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_BtObexServiceTable_hpp)
00010 #define Apoxi_BtObexServiceTable_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Bluetooth/BtTypes.hpp>
00016
00018 #ifndef APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY
00019     #define APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY BtSesNoSecurity
00020 #endif
00021
00023 #ifndef APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY
00024     #define APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY BtSesAuthorization
00025 #endif
00026
00027 // Forward declarations of classes
00028 class   ByteBuffer;
00029
00030
00031 class BtObexServiceTable {
00032
00033     public:
00034         enum {
00035             MAX_LEN_TARGET = 24
00036         };
00037
00038         typedef UINT8   ServiceType;
00039
00040         struct ObexTarget {
00041             UINT8       data[MAX_LEN_TARGET];
00042             UINT8       length;
00043         };
00044
00045         struct Security {
00046             BtSecuritySettings  client;
00047             BtSecuritySettings  server;
00048         };
00049
00050         struct Entry {
00051             ServiceType         service_type;
00052             Security            service_ses;
00053             BtUUID              service_class;
00054             const CHAR *        service_name;
00055             ObexTarget          obex_target;
00056         };
00057
00058
00059         class   ServiceInfo {
00060
00061             friend class BtObexServiceTable;
00062
00063             public:
00064                 ServiceInfo();
00065
00067                 BOOLEAN             IsValid() const
00068                 {
00069                     return ( m_desc_ptr != 0 );
00070                 }
00071
00072                 BOOLEAN             IsEqualTo(const ServiceInfo &   rhs) const
00073                 {
00074                     return ( m_desc_ptr == rhs.m_desc_ptr );
00075                 }
00076
00078                 ServiceType         GetServiceType() const
00079                 {
00080                     return IsValid() ? m_desc_ptr->service_type : 0;
00081                 }
00082
00084                 const CHAR *        GetServiceName() const
00085                 {
00086                     return IsValid() ? m_desc_ptr->service_name : "";
00087                 }
00088
00090                 BtSecuritySettings  GetClientSecurity() const
00091                 {
00092                     return IsValid() ? m_desc_ptr->service_ses.client
00093                                      : APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY;
00094                 }
00095
00097                 BtSecuritySettings  GetServerSecurity() const
00098                 {
00099                     return IsValid() ? m_desc_ptr->service_ses.server
00100                                      : APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY;
00101                 }
00102
00104                 BOOLEAN             GetServiceClass(BtUUID &    uuid) const;
00105
00107                 BOOLEAN             GetObexTarget(ByteBuffer &  target) const;
00108
00109             private:
00110                 const Entry *   m_desc_ptr;
00111
00112                 ServiceInfo(const Entry *   m_desc_ptr);
00113         };
00114
00115         static  ServiceInfo     GetServiceInfoByType(UINT                   serv_type);
00116         static  ServiceInfo     GetServiceInfoByUuid(const BtUUID &         uuid);
00117         static  ServiceInfo     GetServiceInfoByTarget(const ByteBuffer &   target);
00118
00119         static  void            ExtendToUuid128(BtUUID &                    uuid128,
00120                                                 const BtUUID &              uuid_in);
00121     private:
00122         static  const Entry     s_table[];
00123
00125         BtObexServiceTable();
00127        ~BtObexServiceTable();
00128
00129         static  BOOLEAN         TestUuidsEqual(const BtUUID &   lhs,
00130                                                const BtUUID &   rhs);
00131 };
00132
00133
00134 inline  BOOLEAN     operator==(const BtObexServiceTable::ServiceInfo &  lhs,
00135                                const BtObexServiceTable::ServiceInfo &  rhs)
00136 {
00137     return  lhs.IsEqualTo(rhs);
00138 }
00139
00140
00141 inline  BOOLEAN     operator!=(const BtObexServiceTable::ServiceInfo &  lhs,
00142                                const BtObexServiceTable::ServiceInfo &  rhs)
00143 {
00144     return  ! lhs.IsEqualTo(rhs);
00145 }
00146
00148
00149 #endif  // BtObexServiceTable.hpp
00150
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexTransport.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexTransport.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/MessageRouter.hpp>
#include <Obex/ObexUrlParser.hpp>
#include <Bluetooth/BtTransport.hpp>
#include <Bluetooth/JSR82/BtJsr82Url.hpp>
#include <Bluetooth/OBEX/BtObexNotificationMessage.hpp>
#include "BtObexImplAddress.hpp"
#include "BtObexServiceTable.hpp"
#include "BtObexClientAddrResultNotifier.hpp"
#include "BtObexTransport.hpp"

Include dependency graph for BtObexTransport.cpp:

Generated on Tue Jan 24 20:15:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp File Reference

#include <Kernel/SubSystem.hpp>
#include <Devices/AbstractTransport.hpp>
#include <Obex/ObexTransport.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp>

Include dependency graph for BtObexTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtObexSubSystem
class | BtObexTransport

Defines

#define | BtObexTransport_hpp

Define Documentation

#define BtObexTransport_hpp

Generated on Tue Jan 24 20:15:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp Source File

Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtObexTransport_hpp)
00009 #define BtObexTransport_hpp
00012
00013 #include <Kernel/SubSystem.hpp>
00014 #include <Devices/AbstractTransport.hpp>
00015 #include <Obex/ObexTransport.hpp>
00016 #include <Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp>
00017
00018 // Forward declaration of classes
00019 class BtDeviceAddress;
00020
00021
00025 class BtObexTransport: public ObexAbstractTransport
00026 {
00027     friend class BtObexClientAddrResultNotifier;
00028
00029     private:
00030         typedef ObexAbstractTransport Base;
00031
00032     public:
00034
00036         static BtObexTransport* GetInstance();
00037
00039
00041         static BtObexImpl& GetObexInstance();
00042
00044
00046         virtual ObexProtocol* GetProtocol(ObexProtocolId level);
00047
00048
00056         virtual void ResolveClientAddr(const String& client_url, ObexProtocolId prot_id, ObexOperationId job_id);
00057
00066         virtual void ResolveServerAddr(const String& server_url, ObexProtocolId prot_id, BOOLEAN sdb_autocreate, ObexOperationId job_id);
00067
00068         virtual ~BtObexTransport();
00069
00070     protected:
00071
00072         BtObexTransport();
00073         void Init();
00074
00075     private:
00077         static BtObexTransport  m_bt_obex_transport;
00079         static BOOLEAN          m_already_inst;
00081         BtObexImpl              m_bt_obex_impl;
00082 };
00083
00084 class BtObexSubSystem : public SubSystem {
00085     public:
00086         virtual const WCHAR* GetName() const
00087         {
00088             return L"Bluetooth Obex";
00089         }
00090         virtual void OnPowerUp();
00091
00092         virtual BootSequenceState InvokeAt() const
00093         {
00094            return SubSystemManager::c_run_level_1;
00095         }
00096
00097     private:
00098         static BtObexSubSystem     s_bt_obex_sub_system;
00099 };
00100
00102 #endif  // BtObexTransport_hpp
00103
00104
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/BtObexTransportTemplates.cpp File Reference

Bluetooth/OBEX/ObexTransport/BtObexTransportTemplates.cpp File Reference

#include "Bluetooth/OBEX/ObexTransport/PreComp.hpp"
#include <Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp>
#include <Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp>

Include dependency graph for BtObexTransportTemplates.cpp:

Generated on Tue Jan 24 20:15:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/PreComp.cpp File Reference

Bluetooth/OBEX/ObexTransport/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/PreComp.hpp File Reference

Bluetooth/OBEX/ObexTransport/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Auxiliary/WString.hpp>
#include <Bluetooth/BtRequestOperationMessage.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:19:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth/OBEX/ObexTransport/PreComp.hpp Source File

Bluetooth/OBEX/ObexTransport/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Auxiliary/WString.hpp>
00012 #include <Bluetooth/BtRequestOperationMessage.hpp>
00013
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractEditBox.cpp File Reference

Compat/AbstractEditBox.cpp File Reference

#include "PreComp.hpp"
#include "AbstractEditBox.hpp"
#include "EditBox.hpp"
#include <Gui/Locale.hpp>
#include <Gui/PagingMap.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/Bitmap.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/System.hpp>
#include <Kernel/InputMap.hpp>
#include <Config/LocaleConfig.hpp>
#include <Config/EditConfig.hpp>

Include dependency graph for AbstractEditBox.cpp:

Generated on Tue Jan 24 20:15:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractEditBox.hpp File Reference

Compat/AbstractEditBox.hpp File Reference

#include <Gui/Model.hpp>
#include <Gui/View.hpp>
#include <Gui/Control.hpp>
#include <Kernel/Timer.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for AbstractEditBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractEditBox
Obsolete - use MultiLineEditor or LineEditor from Gui instead. More...
class | AbstractEditBoxModel
Describes the model of an editbox. More...
class | AbstractEditBoxView
Describes the view of an editbox. More...
class | EditBoxBlinkTimer
class | EditLine

Defines

#define | Apoxi_AbstractEditBox_hpp

Define Documentation

#define Apoxi_AbstractEditBox_hpp

Generated on Tue Jan 24 20:15:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractEditBox.hpp Source File

Compat/AbstractEditBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractEditBox_hpp)
00010 #define Apoxi_AbstractEditBox_hpp
00011
00012 #include <Gui/Model.hpp>
00013 #include <Gui/View.hpp>
00014 #include <Gui/Control.hpp>
00015 #include <Kernel/Timer.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017
00018 class AbstractEditBox;
00019 struct PagingMapEntry;
00020
00021 class EditLine {
00022     public:
00023         EditLine();
00024
00025         void SetIndex(INT index) { m_index = index; }
00026         INT GetIndex() const { return m_index; }
00027
00028         void SetLength(INT length) { m_length = length; }
00029         INT GetLength() const { return m_length; }
00030
00031     private:
00032         INT m_index;
00033         INT m_length;
00034 };
00035
00037 class AbstractEditBoxModel : public Model {
00038     public:
00039         typedef Model Base;
00040
00042         AbstractEditBoxModel(WCHAR *buff = 0,
00043                      INT max_text_len = 0,
00044                      const WCHAR *caption = 0,
00045                      UINT caption_type = 0,
00046                      BOOLEAN password_mode = FALSE);
00047
00049         virtual ~AbstractEditBoxModel();
00050
00052         void Init(WCHAR *buff = 0,
00053                   INT max_text_len = 0,
00054                   const WCHAR *caption = 0,
00055                   UINT caption_type = 0,
00056                   BOOLEAN password_mode = FALSE);
00057
00059         void SetCaption(const WCHAR *caption) { m_caption = caption; }
00060
00062         const WCHAR* GetCaption() const { return m_caption; }
00063
00065         void SetCaptionType(UINT caption_type) { m_caption_type = caption_type; }
00066
00068         UINT GetCaptionType() const { return m_caption_type; }
00069
00072         void SetInputValid(BOOLEAN input_valid) { m_bits.input_valid = input_valid; }
00073
00075         BOOLEAN IsInputValid() const { return m_bits.input_valid; }
00076
00078         void SetPasswordMode(BOOLEAN password_mode) { m_bits.password_mode = password_mode; }
00079
00081         BOOLEAN IsPasswordMode() const { return m_bits.password_mode; }
00082
00084         void SetText(const WCHAR *text);
00085
00087         WCHAR* GetText() const { return m_text; }
00088
00091         void SetMaxTextLength(INT max_text_len);
00092
00095         INT GetMaxTextLength() const { return m_max_text_len; }
00096
00099         void SetTextLength(INT text_len);
00100
00103         INT GetTextLength() const { return m_text_len; }
00104
00108         BOOLEAN InsertChar(WCHAR ch, INT insert_idx = -1);
00109
00113         BOOLEAN ReplaceChar(WCHAR ch, INT replace_idx = -1);
00114
00117         WCHAR GetChar(INT idx = -1) const;
00118
00120         void RemoveEmptyLines();
00121
00124         void DeleteChar(INT idx = -1);
00125
00127         void SetCursorPos(INT i) { m_cursor_pos = i; }
00128
00130         INT GetCursorPos() const { return m_cursor_pos; }
00131
00134         void SetLineIndex(INT line, INT index) { m_line[line].SetIndex(index); }
00135
00138         INT GetLineIndex(INT line) const { return m_line[line].GetIndex(); }
00139
00143         void SetLineLength(INT line, INT length) { m_line[line].SetLength(length); }
00144
00146         INT GetLineLength(INT line) const {return m_line[line].GetLength(); }
00147
00151         INT GetLine(INT char_idx = -1) const;
00152
00154         void AppendEmptyLine();
00155
00157         void SetCursorVisible(BOOLEAN state) { m_bits.cursor_blink_state = state; }
00158
00160         BOOLEAN IsCursorVisible() const { return m_bits.cursor_blink_state; }
00161
00163         void SetPaging(BOOLEAN paging) { m_bits.paging = paging; }
00164
00166         BOOLEAN IsPaging() const { return m_bits.paging; }
00167
00169         INT GetNoOfLines() const { return m_line.GetSize(); }
00170
00172         void SetNoOfVisibleLines(INT lines) { m_nr_of_visible_lines = lines; }
00173
00175         INT GetNoOfVisibleLines() const { return m_nr_of_visible_lines; }
00176
00178         void SetFirstVisibleLine(INT line) { m_first_visible_line = line; }
00179
00181         INT GetFirstVisibleLine() const { return m_first_visible_line; }
00182
00184         INT GetLastVisibleLine() const;
00185
00187         INT GetFirstVisibleIndex() const { return GetLineIndex(GetFirstVisibleLine()); }
00188
00190         INT GetLastVisibleIndex() const { return GetLastCharIdxOfLine(GetLastVisibleLine()); }
00191
00193         BOOLEAN IsIndexVisible(INT index) const { return (index >= GetFirstVisibleIndex()) && (index <= GetLastVisibleIndex()); }
00194
00196         void Reset();
00197
00199         void SetBuffer(WCHAR *buff) { m_text = buff; }
00200
00202         WCHAR* GetBuffer() const { return m_text; }
00203
00204     private:
00205         struct {
00206             UINT    paging              : 1;
00207             UINT    cursor_blink_state  : 1;
00208             UINT    input_valid         : 1;
00209             UINT    password_mode       : 1;
00210         } m_bits;
00211         INT     m_caption_type;
00212         INT     m_max_text_len;
00213         INT     m_first_visible_line;
00214         INT     m_nr_of_visible_lines;
00215         INT     m_text_len;
00216         INT     m_cursor_pos;
00217         WCHAR   *m_text;
00218         const WCHAR *m_caption;
00219         Vector<EditLine>    m_line;
00220
00221         INT GetLastCharIdxOfLine(INT i) const { return (m_line[i].GetIndex() + m_line[i].GetLength() - 1); };
00222 };
00223
00225 class AbstractEditBoxView : public View {
00226     typedef View Base;
00227
00228     public:
00230         AbstractEditBoxView();
00232         AbstractEditBoxView(XYDIM line_height,
00233                     XYDIM caption_gap,
00234                     XYDIM caption_width,
00235                     XYDIM caption_height,
00236                     XYDIM edit_box_frame_size,
00237                     XYDIM default_width = -1,
00238                     XYDIM default_height = -1);
00239
00241         virtual ~AbstractEditBoxView();
00242
00244         Rect GetCursorRect(const AbstractEditBoxModel &model, const DeviceContext &dc, INT cursor_pos = -1) const;
00245
00247         XYDIM GetLineHeight() const { return m_line_height; }
00248
00250         XYDIM GetCaptionGap() const { return m_caption_gap; }
00251
00253         XYDIM GetCaptionWidth() const { return m_caption_width; }
00254
00256         XYDIM GetCaptionHeight() const { return m_caption_height; }
00257
00259         XYDIM GetFrameSize() const { return m_frame_size; }
00260
00261     protected:
00262         XYDIM m_line_height;
00263         XYDIM m_caption_gap;
00264         XYDIM m_caption_width;
00265         XYDIM m_caption_height;
00266         XYDIM m_frame_size;
00267
00268         // Draws the cursor of the editbox.
00269         void DrawCursor(const AbstractEditBoxModel &model, DeviceContext *dc) const;
00270
00271     private:
00272         BOOLEAN m_block_cursor;
00273         BOOLEAN m_underscore_cursor;
00274
00275         INT GetNoOfFittingChars(const AbstractEditBoxModel &model, const DeviceContext &dc, INT start_index, XYDIM width) const;
00276 };
00277
00278 class AbstractEditBox;
00279
00280 class EditBoxBlinkTimer : public Timer {
00281     public:
00282         typedef Timer Base;
00283         EditBoxBlinkTimer();
00284         void SetEditBox(AbstractEditBox *edit_box) { m_edit_box = edit_box; }
00285
00286     protected:
00287         virtual void OnTimer();
00288
00289     private:
00290         AbstractEditBox *m_edit_box;
00291 };
00292
00294 class AbstractEditBox : public Control {
00295     typedef Control Base;
00296
00297     public:
00298         friend class EditBoxBlinkTimer;
00299
00301         enum  CaptionPos {
00303             CaptionOnLeft,
00305             CaptionOnTop
00306         };
00307
00314         AbstractEditBox(Control *parent = 0,
00315                         WCHAR *buffer = 0,
00316                         INT max_text_len = 0,
00317                         const WCHAR *caption = 0,
00318                         CaptionPos caption_pos = CaptionOnTop,
00319                         BOOLEAN password_mode = FALSE);
00320
00321         virtual ~AbstractEditBox();
00322
00324         void Init(Control *parent,
00325                   WCHAR *buffer,
00326                   INT max_text_len = 0,
00327                   const WCHAR *caption = 0,
00328                   CaptionPos caption_pos = CaptionOnTop,
00329                   BOOLEAN password_mode = FALSE);
00330
00332         void SetCaption(const WCHAR *caption);
00333
00335         const WCHAR* GetCaption() const { return GetMyModel()->GetCaption(); }
00336
00338         void SetText(const WCHAR* text);
00339
00341         WCHAR* GetText() const { return GetMyModel()->GetText(); }
00342
00344         void SetPasswordMode(BOOLEAN password_mode) { GetMyModel()->SetPasswordMode(password_mode); }
00345
00347         void SetCursorPos(INT cursor_pos);
00348
00351         void SetMaxTextLength(INT max_text_len) { GetMyModel()->SetMaxTextLength(max_text_len); }
00352
00355         INT GetMaxTextLength() const { return GetMyModel()->GetMaxTextLength(); }
00356
00358         void SetBuffer(WCHAR *buff) { GetMyModel()->SetBuffer(buff); }
00359
00361         WCHAR* GetBuffer() const { return GetMyModel()->GetBuffer(); }
00362
00363     protected:
00365         virtual void Refresh(const Rect &rect);
00366
00368         virtual BOOLEAN OnInputMap(const InputMapItem &input_map_item);
00369
00371         virtual void OnGetFocus();
00372
00374         virtual void OnLoseFocus();
00375
00377         virtual void OnBlinkTimer();
00378
00380         virtual void OnCursorRight();
00381
00383         virtual void OnCursorLeft();
00384
00386         virtual void OnCursorDown();
00387
00389         virtual void OnCursorUp();
00390
00392         virtual void OnDeleteChar() {}
00393
00395         virtual void OnThemeChanged();
00396
00401         virtual BOOLEAN AcceptChar(WCHAR ch, INT insert_idx) const { return TRUE; };
00402
00406         BOOLEAN ReplaceChar(WCHAR ch, INT replace_idx = -1);
00407
00411         BOOLEAN InsertChar(WCHAR ch, INT insert_idx = -1);
00412
00415         WCHAR GetChar(INT idx = -1) const;
00416
00418         void SetInputValid(BOOLEAN input_valid) { GetMyModel()->SetInputValid(input_valid); }
00419
00421         BOOLEAN IsInputValid() const { return GetMyModel()->IsInputValid(); }
00422
00424         virtual const AbstractEditBoxView* GetView() const = 0;
00425
00427         void DrawCursor();
00428
00430         void EraseCursor();
00431
00433         void InvertCursor();
00434
00436         virtual void MoveCursor(INT inc);
00437
00439         void MoveCursorToLine(INT line);
00440
00445         void SetCursorMode(BOOLEAN paging);
00446
00451         const PagingMapEntry& GetPagingMapEntry(KeyCode key_code) const;
00452
00454         void InvalidateText();
00455
00457         void InvalidateCursor();
00458
00461         void Layout(INT line_index);
00462
00466         INT GetNoOfFittingChars(INT start_index, XYDIM width);
00467
00470         BOOLEAN IsCursorVisible(INT cursor_pos = -1);
00471
00473         XYDIM GetLineWidth() const;
00474
00475
00476     private:
00477         XYDIM                       m_vertical_pos;
00478         static EditBoxBlinkTimer    m_blink_timer;
00479
00480         // Returns the x-position of the the upper left
00481         // edge of the box containing the text.
00482         XYDIM GetBoxXPos() const;
00483
00484         // Returns the y-position of the the upper left
00485         // edge of the box containing the text.
00486         XYDIM GetBoxYPos() const;
00487
00488         AbstractEditBoxModel* GetMyModel() const { return (AbstractEditBoxModel *)GetModel(); }
00489
00490         void AdjustThemeDependencies();
00491 };
00492
00493
00494 #endif  // Apoxi_EditBox_hpp
00495
00496
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractIMelodyParser.cpp File Reference

Compat/AbstractIMelodyParser.cpp File Reference

#include "PreComp.hpp"
#include "AbstractIMelodyParser.hpp"

Include dependency graph for AbstractIMelodyParser.cpp:

Generated on Tue Jan 24 20:15:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractIMelodyParser.hpp File Reference

Compat/AbstractIMelodyParser.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <AddOns/MultiMedia/IMelody.hpp>

Include dependency graph for AbstractIMelodyParser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractIMelodyParser

Defines

#define | MultiMedia_AbstractIMelodyParser_hpp

Define Documentation

#define MultiMedia_AbstractIMelodyParser_hpp

Generated on Tue Jan 24 16:42:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractIMelodyParser.hpp Source File

Compat/AbstractIMelodyParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(MultiMedia_AbstractIMelodyParser_hpp)
00011 #define MultiMedia_AbstractIMelodyParser_hpp
00014
00015 #include <Auxiliary/BinData.hpp>
00016 #include <AddOns/MultiMedia/IMelody.hpp>
00017
00021 class AbstractIMelodyParser
00022 {
00023     public:
00025         AbstractIMelodyParser();
00027         virtual ~AbstractIMelodyParser();
00028
00030         virtual INT GetToneCount(BinData* data) = 0;
00031
00040         virtual void Parse(BinData* data, IMelodyData& parsed_data) = 0;
00041 };
00042
00044 #endif // MultiMedia_AbstractIMelodyParser_hpp
00045
00046
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractListBox.cpp File Reference

Compat/AbstractListBox.cpp File Reference

#include "PreComp.hpp"
#include "AbstractListBox.hpp"
#include <Gui/PaintDc.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/Window.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/InputMap.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/OptionalConfig.hpp>

Include dependency graph for AbstractListBox.cpp:

Generated on Tue Jan 24 20:15:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractListBox.hpp File Reference

Compat/AbstractListBox.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Control.hpp>
#include <Gui/Model.hpp>
#include <Gui/View.hpp>
#include <Gui/PositionIndicator.hpp>
#include <Gui/ScrollBehavior.hpp>

Include dependency graph for AbstractListBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractListBox
class | AbstractListBox::SmoothScrollInfo
class | AbstractListBoxModel
Obsolete, as the class AbstractListBox has been replaced by the class ItemGrid. More...
class | AbstractListBoxView

Defines

#define | Apoxi_AbstractListBox_hpp

Define Documentation

#define Apoxi_AbstractListBox_hpp

Generated on Tue Jan 24 20:15:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractListBox.hpp Source File

Compat/AbstractListBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractListBox_hpp)
00010 #define Apoxi_AbstractListBox_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Gui/Control.hpp>
00016 #include <Gui/Model.hpp>
00017 #include <Gui/View.hpp>
00018 #include <Gui/PositionIndicator.hpp>
00019 #include <Gui/ScrollBehavior.hpp>
00020
00021 class AbstractListBox;
00022
00024 class AbstractListBoxModel : public Model {
00025     typedef Model Base;
00026
00027     public:
00030         AbstractListBoxModel();
00031
00033         AbstractListBoxModel(INT item_count);
00034
00036         virtual ~AbstractListBoxModel();
00037
00039         void Init(INT item_count);
00040
00042         void SetItemCount(INT item_count);
00043
00045         INT GetItemCount() const { return m_item_count; };
00046
00048         void SetListBox(AbstractListBox* list_box) { m_list_box = list_box; }
00049
00051         AbstractListBox* GetListBox() const { return m_list_box; }
00052
00054         void SetNoOfItems(INT item_count) {
00055             DBG_OUT((5003, L"Obsolete - AbstractListBox::SetNoOfItems(). Use SetItemCount() instead.\n"));
00056             SetItemCount(item_count);
00057         }
00058
00060         INT GetNoOfItems() const {
00061             DBG_OUT((5003, L"Obsolete - AbstractListBox::GetNoOfItems(). Use GetItemCount() instead.\n"));
00062             return GetItemCount();
00063         }
00064
00067         AbstractListBoxModel(INT item_count, INT selected_index);
00068
00071         void Init(INT item_count, INT selected_index);
00072
00074         void SetSelectedIndex(INT index);
00075
00077         INT GetSelectedIndex() const;
00078
00080         void SetFirstVisibleIndex(INT index);
00081
00083         INT GetFirstVisibleIndex() const;
00084
00086         void SetMaxVisibleItems(INT max_visible_items);
00087
00089         INT GetMaxVisibleItems() const;
00090
00091     private:
00092         INT m_item_count;
00093         AbstractListBox *m_list_box;
00094 };
00095
00098 class AbstractListBox : public Control {
00099     typedef Control Base;
00100
00101     public:
00106         class SmoothScrollInfo {
00107         public:
00110             BOOLEAN IsSelector() const { return m_is_selector; }
00111
00113             const Timer& GetTimer() const { return m_timer; }
00114
00118             XYDIM GetDiff() const { return (XYDIM)m_diff; }
00119
00121             XYDIM GetInc() const { return (XYDIM)m_inc; }
00122
00123         private:
00124             BOOLEAN m_is_selector;
00125             Timer m_timer;
00126             INT8 m_diff;
00127             INT8 m_inc;
00128
00129             friend class AbstractListBox;
00130         };
00131
00133         AbstractListBox();
00134
00136         AbstractListBox(Control* parent);
00137
00138         virtual ~AbstractListBox();
00139
00141         void Init(Control* parent);
00142
00144         void SetSelectedIndex(INT index);
00145
00147         INT GetSelectedIndex() const;
00148
00150         void SetFirstVisibleIndex(INT index);
00151
00153         INT GetFirstVisibleIndex() const { return m_first_visible_idx; }
00154
00157         INT GetLastVisibleIndex() const;
00158
00160         void SetItemCount(INT item_count);
00161
00163         INT GetItemCount() const;
00164
00167         void SetItemHeight(XYDIM item_height) { m_item_height = (INT8)item_height; };
00168
00170         XYDIM GetItemWidth() const;
00171
00173         XYDIM GetItemHeight() const;
00174
00176         INT GetMaxVisibleItems() const;
00177
00179         const PositionIndicator& GetPositionIndicator() const { return m_pos_ind; }
00180
00184         virtual BOOLEAN IsPositionIndicatorShown() const;
00185
00189         virtual ScrollBehavior GetScrollBehavior() const;
00190
00194         void SetFocusPassingEnabled(BOOLEAN flag) { m_focus_passing_enabled = flag; }
00195
00198         BOOLEAN IsFocusPassingEnabled() const { return m_focus_passing_enabled; }
00199
00201         void SetNoOfItems(INT item_count) { SetItemCount(item_count); }
00202
00204         INT GetNoOfItems() const { return GetItemCount(); }
00205
00208         AbstractListBox(Control* parent,
00209                         INT item_count,
00210                         ScrollBehavior behavior,
00211                         INT selected_index = 0);
00212
00215         void Init(Control* parent,
00216                   INT item_count,
00217                   ScrollBehavior behavior,
00218                   INT selected_index = 0);
00219
00222         void SetBehavior(Behavior behavior);
00223
00225         Behavior GetBehavior() const;
00226
00229         const SmoothScrollInfo* GetSmoothScrollInfo() const;
00230
00231     protected:
00233         virtual void Refresh(const Rect& rect);
00234
00236         virtual void OnLayoutClient();
00237
00239         virtual void OnResize(XYDIM dx, XYDIM dy);
00240
00242         virtual BOOLEAN OnInputMap(const InputMapItem& input_map_item);
00243
00245         virtual BOOLEAN OnPenDown(const Point& pen_pos);
00246
00248         virtual void OnPreviousItem();
00249
00251         virtual void OnNextItem();
00252
00255         virtual void OnSelectionChanged();
00256
00258         virtual void OnThemeChanged();
00259
00261         virtual void OnPaint(const Rect& repaint_rect);
00262
00264         virtual BOOLEAN OnTimeout(const Timer& timer);
00265
00267         void UpdatePositionIndicator();
00268
00271         void IndicateSelectionChanged();
00272
00274         void InvalidateSelectedItem();
00275
00276     private:
00277         INT                 m_selected_idx;
00278         INT                 m_first_visible_idx;
00279         BOOLEAN             m_focus_passing_enabled;
00280         INT8                m_item_height;
00281         PositionIndicator   m_pos_ind;
00282 #ifdef APOXI_ENABLE_SMOOTH_SCROLLING
00283         SmoothScrollInfo    m_smooth_scroll_info;
00284 #endif
00285
00286         AbstractListBoxModel* GetMyModel() const { return (AbstractListBoxModel* )GetModel(); }
00287
00289         INT GetLastCompleteVisibleIndex() const;
00290
00292         INT GetMaxCompleteVisibleItems() const;
00293
00295         void AdjustThemeDependencies();
00296
00300         ScrollBehavior GetInterpretedScrollBehavior() const;
00301
00302         void InitProperties();
00303 };
00304
00306 class AbstractListBoxView : public View {
00307     typedef View Base;
00308
00309     public:
00311         AbstractListBoxView();
00312
00314         AbstractListBoxView(XYDIM default_item_height);
00315
00317         void Init(XYDIM default_item_height);
00318
00320         virtual ~AbstractListBoxView() {};
00321
00323         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00324
00326         virtual void DrawItem(const AbstractListBox& listbox, DeviceContext* dc, INT index, const Rect& item_rect) const;
00327
00329         Rect GetItemRect(const AbstractListBox& listbox, INT index) const;
00330
00332         void SetDefaultItemHeight(XYDIM default_item_height) { m_default_item_height = default_item_height; };
00333
00335         XYDIM GetDefaultItemHeight() const { return m_default_item_height; };
00336
00338         BOOLEAN IsBackgrDrawingEnabled() const { return m_backgr_drawing; }
00339
00340     private:
00341         mutable BOOLEAN m_backgr_drawing;
00342         XYDIM m_default_item_height;
00343 };
00344
00346 #endif // Apoxi_AbstractListBox_hpp
00347
00348
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractMenuAccessor.cpp File Reference

Compat/AbstractMenuAccessor.cpp File Reference

#include "PreComp.hpp"
#include "AbstractMenuAccessor.hpp"
#include "Menu.hpp"

Include dependency graph for AbstractMenuAccessor.cpp:

Generated on Tue Jan 24 20:15:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractMenuAccessor.hpp File Reference

Compat/AbstractMenuAccessor.hpp File Reference

#include <Kernel/Dispatcher.hpp>

Include dependency graph for AbstractMenuAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractMenuAccessor

Defines

#define | Apoxi_AbstractMenuAccessor_hpp

Define Documentation

#define Apoxi_AbstractMenuAccessor_hpp

Generated on Tue Jan 24 20:15:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractMenuAccessor.hpp Source File

Compat/AbstractMenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AbstractMenuAccessor_hpp)
00011 #define Apoxi_AbstractMenuAccessor_hpp
00014
00015 #include <Kernel/Dispatcher.hpp>
00016
00017 class Menu;
00018 class DeviceContext;
00019 class Rect;
00020
00023 class AbstractMenuAccessor : public Dispatcher {
00024     public:
00026         AbstractMenuAccessor();
00027
00029         void Init();
00030
00032         virtual ~AbstractMenuAccessor();
00033
00037         virtual BOOLEAN First() = 0;
00038
00042         virtual BOOLEAN Next() = 0;
00043
00045         virtual XYDIM GetItemHeight() const = 0;
00046
00049         virtual XYDIM GetItemWidth() const;
00050
00052         virtual INT GetColumnCount() const;
00053
00056         virtual BOOLEAN IsEnabled();
00057
00062         virtual void Draw(DeviceContext* dc, const Rect& draw_rect, BOOLEAN highlighted) = 0;
00063
00065         virtual void Trigger(Menu* menu) = 0;
00066
00068         virtual void Back(Menu* menu) = 0;
00069
00072         virtual BOOLEAN IsRoot();
00073
00074     protected:
00076         virtual BOOLEAN OnMessage(const Message& msg);
00077
00080         virtual void OnLanguageChanged();
00081
00083         virtual void OnActivate(Menu* menu, AbstractMenuAccessor* parent_accessor);
00084
00086         virtual void OnDeactivate(Menu* menu);
00087
00089         virtual void OnSelectionChanged(INT selected_idx);
00090
00091     private:
00092         INT m_act_lang;
00093
00094     friend class Menu;
00095 };
00096
00097 #endif  // Apoxi_AbstractMenuAccessor_hpp
00098
00099
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractMenuList.cpp File Reference

Compat/AbstractMenuList.cpp File Reference

#include "PreComp.hpp"
#include "AbstractMenuList.hpp"
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Application.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for AbstractMenuList.cpp:

Generated on Tue Jan 24 20:15:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractMenuList.hpp File Reference

Compat/AbstractMenuList.hpp File Reference

#include <Gui/AbstractListBox.hpp>
#include <Auxiliary/LinkedList.hpp>

Include dependency graph for AbstractMenuList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractMenuList
Is an abstract listbox, which is the base for MenuList, CheckBoxList, RadioButtonList, ... More...
class | AbstractMenuListModel< Item >

Defines

#define | Apoxi_AbstractMenuList_hpp

Define Documentation

#define Apoxi_AbstractMenuList_hpp

Generated on Tue Jan 24 20:15:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AbstractMenuList.hpp Source File

Compat/AbstractMenuList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractMenuList_hpp)
00010 #define Apoxi_AbstractMenuList_hpp
00011
00012 #include <Gui/AbstractListBox.hpp>
00013 #include <Auxiliary/LinkedList.hpp>
00014
00015
00016 class AbstractListBox;
00017 class Window;
00018
00019 // TODO: template can be avoided by using a cast and hiding this cast in a method... (peter_p)
00020 template<class Item> class AbstractMenuListModel : public AbstractListBoxModel {
00021     typedef AbstractListBoxModel Base;
00022
00023     public:
00025         AbstractMenuListModel();
00026
00028         AbstractMenuListModel(INT n_items, INT selected_index);
00029
00030         AbstractMenuListModel(INT n_items);
00031
00033         void Init(INT n_items, INT selected_index);
00034         void Init(INT n_items) {
00035             Init(n_items, 0);
00036         }
00037
00041         void AddItem(Item *item, Item *after);
00042         void AddItem(Item *item) {
00043             AddItem(item, 0);
00044         }
00045
00047         void RemoveItem(Item *item);
00048
00050         void RemoveAllItems();
00051
00053         Item* GetFirstItem() const;
00054
00056         Item* GetItemForIndex(INT index) const;
00057
00058     private:
00059         LinkedList<Item> m_items;
00060 };
00061
00063 class AbstractMenuList : public AbstractListBox {
00064     typedef AbstractListBox Base;
00065
00066     public:
00069         AbstractMenuList();
00070
00072         AbstractMenuList(Control *parent,
00073                          INT n_items = 0,
00074                          Behavior behavior = DefaultBehavior,
00075                          INT selected_index = 0);
00076
00077         virtual ~AbstractMenuList();
00078
00079     protected:
00081         virtual BOOLEAN OnSoftkeyPressed(INT idx);
00082
00084         virtual BOOLEAN OnInputMap(const InputMapItem &input_map_item);
00085
00087         virtual BOOLEAN OnPenUp(const Point &pen_pos);
00088
00090         virtual void OnItemSelected();
00091 };
00092
00093
00094 /*  ------------------------------------------------------------------------
00095                             Template implementation
00096     ------------------------------------------------------------------------ */
00097
00098 /*  ------------------------------------------------------------------------
00099     AbstractMenuListModel
00100     ------------------------------------------------------------------------ */
00101 template<class Item> AbstractMenuListModel<Item>::AbstractMenuListModel()
00102 {
00103 }   // AbstractMenuListModel
00104
00105 /*  ------------------------------------------------------------------------
00106     AbstractMenuListModel
00107     ------------------------------------------------------------------------ */
00108 template<class Item> AbstractMenuListModel<Item>::AbstractMenuListModel(INT n_items, INT selected_index) :
00109     Base(n_items, selected_index)
00110 {
00111 }   // AbstractMenuListModel
00112
00113 /*  ------------------------------------------------------------------------
00114     AbstractMenuListModel
00115     ------------------------------------------------------------------------ */
00116 template<class Item> AbstractMenuListModel<Item>::AbstractMenuListModel(INT n_items) :
00117     Base(n_items, 0)
00118 {
00119 }   // AbstractMenuListModel
00120
00121 /*  ------------------------------------------------------------------------
00122     Init
00123     ------------------------------------------------------------------------ */
00124 template<class Item> void AbstractMenuListModel<Item>::Init(INT n_items, INT selected_index)
00125 {
00126     Base::Init(n_items, selected_index);
00127 }   // Init
00128
00129 /*  ------------------------------------------------------------------------
00130     AddItem
00131     ------------------------------------------------------------------------ */
00132 template<class Item> void AbstractMenuListModel<Item>::AddItem(Item *item, Item *after)
00133 {
00134     if (after == 0)
00135         m_items.PushBack(item);
00136     else
00137         m_items.Insert(item, after);
00138
00139     SetItemCount(GetItemCount() + 1);
00140 }   // AddItem
00141
00142 /*  ------------------------------------------------------------------------
00143     RemoveItem
00144     ------------------------------------------------------------------------ */
00145 template<class Item> void AbstractMenuListModel<Item>::RemoveItem(Item *item)
00146 {
00147     ASSERT_DEBUG(GetNoOfItems() > 0);
00148
00149     m_items.Remove(item);
00150     SetItemCount(GetItemCount() - 1);
00151 }   // RemoveItem
00152
00153 /*  ------------------------------------------------------------------------
00154     RemoveAllItems
00155     ------------------------------------------------------------------------ */
00156 template<class Item> void AbstractMenuListModel<Item>::RemoveAllItems()
00157 {
00158     while (GetItemCount() > 0)
00159         RemoveItem(m_items.GetFront());
00160 }   // RemoveAllItems
00161
00162 /*  ------------------------------------------------------------------------
00163     GetFirstItem
00164     ------------------------------------------------------------------------ */
00165 template<class Item> Item* AbstractMenuListModel<Item>::GetFirstItem() const
00166 {
00167     return m_items.GetFront();
00168 }   // GetFirstItem
00169
00170 /*  ------------------------------------------------------------------------
00171     GetItemForIndex
00172     ------------------------------------------------------------------------ */
00173 template<class Item> Item* AbstractMenuListModel<Item>::GetItemForIndex(INT index) const
00174 {
00175     INT curr_index = 0;
00176     Item *item = m_items.GetFront();
00177     while ((item != 0) && (curr_index != index)) {
00178         item = item->GetNext();
00179         curr_index++;
00180     }
00181
00182     return item;
00183 }   // GetItemForIndex
00184
00185 #endif  // Apoxi_AbstractMenuList_hpp
00186
00187
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ActionExtension.cpp File Reference

Compat/ActionExtension.cpp File Reference

#include "PreComp.hpp"
#include "ActionExtension.hpp"

Include dependency graph for ActionExtension.cpp:

Generated on Tue Jan 24 20:15:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ActionExtension.hpp File Reference

Compat/ActionExtension.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ActionExtension.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ActionExtension

Defines

#define | Apoxi_ActionExtension_hpp

Define Documentation

#define Apoxi_ActionExtension_hpp

Generated on Tue Jan 24 20:15:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ActionExtension.hpp Source File

Compat/ActionExtension.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ActionExtension_hpp)
00010 #define Apoxi_ActionExtension_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00018 class ActionExtension {
00019     public:
00021         ActionExtension();
00022
00024         virtual ~ActionExtension();
00025
00027         virtual INT GetId() const = 0;
00028
00031         virtual BOOLEAN IsInstanceOf(INT id) const = 0;
00032 };
00033
00035 #endif  // Apoxi_ActionExtension_hpp
00036
00037
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Animation.cpp File Reference

Compat/Animation.cpp File Reference

#include "PreComp.hpp"
#include "Animation.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for Animation.cpp:

Generated on Tue Jan 24 20:15:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Animation.hpp File Reference

Compat/Animation.hpp File Reference

#include <Gui/Lib.hpp>
#include <Kernel/Timer.hpp>

Include dependency graph for Animation.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Animation
Obsolete - use class ImageBox from GUI instead. More...
class | AnimationBmpArrayIterator
class | AnimationBmpIterator
class | AnimationBmpPointerArrayIterator
class | AnimationModel
Describes the model of an animated bitmap. More...
class | AnimationView
Describes the view of an animated bitmap. More...

Defines

#define | Apoxi_Animation_hpp

Define Documentation

#define Apoxi_Animation_hpp

Generated on Tue Jan 24 20:16:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Animation.hpp Source File

Compat/Animation.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Animation_hpp)
00010 #define Apoxi_Animation_hpp
00011
00012 #include <Gui/Lib.hpp>
00013 #include <Kernel/Timer.hpp>
00014
00016 class AnimationBmpIterator {
00017     public:
00018         virtual INT BitmapCount() const = 0;
00019         virtual const BitmapRes* operator()(INT idx) const = 0;
00020 };
00021
00023 class AnimationBmpArrayIterator : public AnimationBmpIterator {
00024     public:
00025         AnimationBmpArrayIterator(INT bmp_count = 0, const BitmapRes *bmp = 0);
00026
00027         virtual INT BitmapCount() const { return m_bmp_count; }
00028         virtual const BitmapRes* operator()(INT idx) const {
00029             ASSERT(idx >= 0 && idx < m_bmp_count);
00030             return &m_bmp[idx];
00031         }
00032
00033         void Init(INT bmp_count, const BitmapRes *bmp) {
00034             m_bmp_count = bmp_count;
00035             m_bmp = bmp;
00036         }
00037
00038     private:
00039         INT m_bmp_count;
00040         const BitmapRes *m_bmp;
00041 };
00042
00043
00045 class AnimationBmpPointerArrayIterator : public AnimationBmpIterator {
00046     public:
00047         typedef const BitmapRes* CBitmapResPtr;
00048
00049         AnimationBmpPointerArrayIterator(INT bmp_count = 0, const CBitmapResPtr *bmp = 0);
00050
00051         virtual INT BitmapCount() const { return m_bmp_count; }
00052         virtual const BitmapRes* operator()(INT idx) const {
00053             ASSERT(idx >= 0 && idx < m_bmp_count);
00054             return m_bmp[idx];
00055         }
00056
00057         void Init(INT bmp_count, const CBitmapResPtr *bmp) {
00058             m_bmp_count = bmp_count;
00059             m_bmp = bmp;
00060         }
00061
00062     private:
00063         INT m_bmp_count;
00064         const CBitmapResPtr *m_bmp;
00065 };
00066
00068 class AnimationModel : public Model {
00069     typedef Model Base;
00070
00071     public:
00073         AnimationModel();
00074
00076         void SetIndex(INT index) { m_index = index; };
00077
00079         INT GetIndex() const { return m_index; };
00080
00082         void SetBmpIterator(const AnimationBmpIterator *bmp_it) { m_bmp_it = bmp_it; }
00083
00085         const AnimationBmpIterator* GetBmpIterator() const { return m_bmp_it; }
00086
00088         const BitmapRes& GetActiveBitmap() const { return *m_bmp_it->operator()(m_index); }
00089
00090     private:
00091         INT             m_index;
00092         const AnimationBmpIterator *m_bmp_it;
00093 };
00094
00096 class AnimationView : public DrawableObjectView {
00097     public:
00098         typedef DrawableObjectView Base;
00099
00101         virtual ~AnimationView();
00102
00104         virtual void Draw(const Component &component, DeviceContext *dc, const Rect &repaint_rect) const;
00105 };
00106
00108 class Animation : public DrawableObject, private Timer {
00109     public:
00110         typedef DrawableObject Base;
00111
00119         enum AnimationType {
00120             Cycle,
00121             Oscillate,
00122             Once
00123         };
00124
00127         Animation();
00128
00130         Animation(Control *control,
00131                   const AnimationBmpIterator *bmp_it,
00132                   UINT32 timeout = 0,
00133                   AnimationType type = Cycle);
00134
00136         virtual ~Animation();
00137
00139         void Init(Control *control,
00140                   const AnimationBmpIterator *bmp_it,
00141                   UINT32 timeout = 0,
00142                   AnimationType type = Cycle);
00143
00145         void Start();
00146
00148         using Timer::Stop;
00149
00151         void SetIndex(INT index);
00152
00154         INT GetIndex() const;
00155
00157         void SetBmpIterator(const AnimationBmpIterator *bmp_it);
00158
00160         const AnimationBmpIterator* GetBmpIterator() const;
00161
00163         virtual XYDIM GetDefaultWidth() const;
00164
00166         virtual XYDIM GetDefaultHeight() const;
00167
00168     protected:
00170         virtual Model* CreateModel() const;
00171
00173         virtual void OnTimer();
00174
00176         virtual void OnThemeChanged();
00177
00178     private:
00179         struct {
00180             UINT cycle_forward  : 1;
00181             UINT type           : 2;
00182         } m_bits;
00183
00184         static AnimationView m_view;
00185
00186         AnimationModel* GetMyModel() const { return (AnimationModel *)GetModel(); }
00187         virtual void AdjustThemeDependencies();
00188 };
00189
00190
00191 #endif  // Apoxi_Animation_hpp
00192
00193
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemGrid.cpp File Reference

Compat/AtlItemGrid.cpp File Reference

#include "PreComp.hpp"
#include <Atl/AtlMsgTypes.hpp>
#include "AtlItemGrid.hpp"

Include dependency graph for AtlItemGrid.cpp:

Generated on Tue Jan 24 20:16:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemGrid.hpp File Reference

Compat/AtlItemGrid.hpp File Reference

#include <Gui/ItemGrid.hpp>

Include dependency graph for AtlItemGrid.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlItemGrid

Defines

#define | Atl_AtlItemGrid_hpp

Define Documentation

#define Atl_AtlItemGrid_hpp

Generated on Tue Jan 24 17:57:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemGrid.hpp Source File

Compat/AtlItemGrid.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_AtlItemGrid_hpp)
00010 #define Atl_AtlItemGrid_hpp
00013
00014 #include <Gui/ItemGrid.hpp>
00015
00023 class AtlItemGrid : public ItemGrid {
00024     typedef ItemGrid Base;
00025
00026     public:
00028         AtlItemGrid();
00029
00033         AtlItemGrid(Control* parent, AbstractItemContainer* item_cont = 0);
00034
00036         virtual ~AtlItemGrid();
00037
00041         void Init(Control* parent, AbstractItemContainer* item_cont = 0);
00042
00043     protected:
00045         virtual BOOLEAN OnMessage(const Message& msg);
00046
00047 };
00048
00050 #endif  // Atl_AtlItemGrid_hpp
00051
00052
Generated on Tue Jan 24 14:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemMenu.cpp File Reference

Compat/AtlItemMenu.cpp File Reference

#include "PreComp.hpp"
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/Gui/AtlItemMenu.hpp>
#include "AtlItemMenu.hpp"

Include dependency graph for AtlItemMenu.cpp:

Generated on Tue Jan 24 20:16:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemMenu.hpp File Reference

Compat/AtlItemMenu.hpp File Reference

#include <Gui/ItemMenu.hpp>

Include dependency graph for AtlItemMenu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlItemMenu

Defines

#define | Atl_AtlItemMenu_hpp

Define Documentation

#define Atl_AtlItemMenu_hpp

Generated on Tue Jan 24 17:58:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemMenu.hpp Source File

Compat/AtlItemMenu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_AtlItemMenu_hpp)
00010 #define Atl_AtlItemMenu_hpp
00013
00014 #include <Gui/ItemMenu.hpp>
00015
00022 class AtlItemMenu : public ItemMenu {
00023     typedef ItemMenu Base;
00024
00025     public:
00026         //
00027         AtlItemMenu();
00028
00035         AtlItemMenu(Control* parent,
00036                  AbstractItemContainer* item_cont = 0,
00037                  BOOLEAN adjust_win_title = FALSE);
00038
00040         virtual ~AtlItemMenu();
00041
00042
00043     protected:
00045         virtual BOOLEAN OnMessage(const Message& msg);
00046 };
00047
00049 #endif  // Atl_AtlItemMenu_hpp
00050
00051
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemRenderer.cpp File Reference

Compat/AtlItemRenderer.cpp File Reference

#include "PreComp.hpp"
#include <Atl/Features/FeatureItem.hpp>
#include <Atl/Features/FeatureItemContainer.hpp>
#include "AtlItemRenderer.hpp"

Include dependency graph for AtlItemRenderer.cpp:

Generated on Tue Jan 24 20:16:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemRenderer.hpp File Reference

Compat/AtlItemRenderer.hpp File Reference

#include <Gui/DefaultItemRenderer.hpp>
#include <Gui/Item.hpp>
#include <Atl/Properties/SubstitutedText.hpp>

Include dependency graph for AtlItemRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtlItemRenderer

Defines

#define | Atl_AtlItemRenderer_hpp

Define Documentation

#define Atl_AtlItemRenderer_hpp

Generated on Tue Jan 24 17:58:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AtlItemRenderer.hpp Source File

Compat/AtlItemRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_AtlItemRenderer_hpp)
00010 #define Atl_AtlItemRenderer_hpp
00013
00014 #include <Gui/DefaultItemRenderer.hpp>
00015 #include <Gui/Item.hpp>
00016 #include <Atl/Properties/SubstitutedText.hpp>
00017
00021 class AtlItemRenderer : public DefaultItemRenderer {
00022     typedef DefaultItemRenderer Base;
00023
00024     public:
00026         AtlItemRenderer(const ItemRendererProperties* properties = 0);
00027
00029         virtual ~AtlItemRenderer();
00030
00032         virtual Rect GetIconRect(const Item& item, const Rect& bounds) const;
00033
00035         virtual void DrawBackground(DeviceContext* dc,
00036                                     const Item& item,
00037                                     const Rect& bounds,
00038                                     INT item_style) const;
00039
00041         virtual void DrawItem(DeviceContext* dc,
00042                               const Item& item,
00043                               const Rect& bounds,
00044                               INT item_style) const;
00045
00047         virtual BOOLEAN StartTextScrolling(const Item& item, const Rect& bounds) const;
00048
00050         virtual void StopTextScrolling(const Item& item) const;
00051
00052     private:
00054         const Item& GetSubstitutedItem(const Item& item) const;
00055
00056         mutable Item                m_item;
00057         mutable SubstitutedText     m_substituted_text;
00058 };
00059
00061 #endif  // Atl_AtlItemRenderer_hpp
00062
00063
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AudioContext.cpp File Reference

Compat/AudioContext.cpp File Reference

#include "PreComp.hpp"
#include "AudioContext.hpp"

Include dependency graph for AudioContext.cpp:

Generated on Tue Jan 24 20:16:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AudioContext.hpp File Reference

Compat/AudioContext.hpp File Reference

#include <Devices/Device.hpp>

Include dependency graph for AudioContext.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioContext

Defines

#define | MultiMedia_AudioContext_hpp

Define Documentation

#define MultiMedia_AudioContext_hpp

Generated on Tue Jan 24 16:42:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/AudioContext.hpp Source File

Compat/AudioContext.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009
00010 #if !defined(MultiMedia_AudioContext_hpp)
00011 #define MultiMedia_AudioContext_hpp
00014
00015 #include <Devices/Device.hpp>
00016
00017 #if defined(APOXI_PLATFORM_BP30) && defined(APOXI_3GPP_REL_97_DOWNGRADE)
00018   #include <Compat/Devices/BP30/Audio.hpp>
00019 #endif
00020
00021
00025 class AudioContext {
00026     public:
00029         AudioContext(Audio::AudioDevice device = Audio::DeviceBuzzer);
00030
00032         virtual ~AudioContext();
00033
00035         Audio::AudioDevice GetDevice() const { return m_device; }
00036
00040         void SetAudioMode(Audio::AudioMode mode);
00041
00043         Audio::AudioMode GetMode() const { return m_mode; }
00044
00048         void SetPriority(Audio::AudioPriority priority) { m_priority = priority; }
00049
00051         Audio::AudioPriority GetPriority() const { return m_priority; }
00052
00054         void SetVolume(UINT8 volume);
00055
00057         UINT8 GetVolume() const { return m_volume; }
00058
00060         void SetMute(BOOLEAN mute);
00061
00063         BOOLEAN IsMute() const { return m_mute; }
00064
00067         virtual BOOLEAN PlaySound(Audio::AudioToneId sound, INT repeats = 1);
00068
00071         virtual BOOLEAN PlaySound(Audio::ToneData* sound);
00072
00074         virtual void StopSound();
00075
00076     private:
00077         BOOLEAN                 m_mute;
00078         UINT8                   m_volume;
00079         Audio::AudioDevice      m_device;
00080         Audio::AudioMode        m_mode;
00081         Audio::AudioPriority    m_priority;
00082 };
00083
00085 #endif // MultiMedia_AudioContext_hpp
00086
00087
Generated on Tue Jan 24 14:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/BattHandler.cpp File Reference

Compat/BattHandler.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for BattHandler.cpp:

Generated on Tue Jan 24 20:16:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/BattHandler.hpp File Reference

Compat/BattHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_BattHandler_hpp

Define Documentation

#define Asc_BattHandler_hpp

Generated on Tue Jan 24 17:13:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/BattHandler.hpp Source File

Compat/BattHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_BattHandler_hpp)
00009 #define Asc_BattHandler_hpp
00012 #if defined(APOXI_COMPAT_2_2_0)
00013
00014 #include <Asc/BaseHandler.hpp>
00015
00018 class BattHandler : public BaseHandler {
00019     typedef BaseHandler Base;
00020     public:
00021         enum { ID = BattHandlerId };
00022
00024         BattHandler();
00026         virtual ~BattHandler();
00028         virtual HandlerId GetHandlerId() const;
00029
00031         void Start() const;
00032
00034         void Stop() const;
00035 };
00036
00038 #endif //APOXI_COMPAT_2_2_0
00039
00040 #endif // Asc_BattHandler_hpp
00041
00042
Generated on Tue Jan 24 14:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/BufferedOutputStream.cpp File Reference

Compat/BufferedOutputStream.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "BufferedOutputStream.hpp"

Include dependency graph for BufferedOutputStream.cpp:

Generated on Tue Jan 24 20:16:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/BufferedOutputStream.hpp File Reference

Compat/BufferedOutputStream.hpp File Reference

#include <Kernel/OutputStream.hpp>

Include dependency graph for BufferedOutputStream.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BufferedOutputStream

Defines

#define | Apoxi_BufferedOutputStream_hpp

Define Documentation

#define Apoxi_BufferedOutputStream_hpp

Generated on Tue Jan 24 20:16:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/BufferedOutputStream.hpp Source File

Compat/BufferedOutputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BufferedOutputStream_hpp)
00010 #define Apoxi_BufferedOutputStream_hpp
00013
00014 #include <Kernel/OutputStream.hpp>
00015
00016 #ifndef APOXI_NOSTREAMING
00017
00018 class BufferedOutputStream : public OutputStream {
00019     public:
00020         BufferedOutputStream(OutputStream* stream);
00021         virtual ~BufferedOutputStream();
00022
00023         virtual INT Write (const BYTE data);
00024         virtual INT Write (const BYTE* data, INT len);
00025
00026         virtual void Flush();
00027
00028     private:
00029         OutputStream* m_stream;
00030         const UINT16 m_maxBuffer;
00031         UINT16 m_tail;
00032         BYTE m_buffer[512];
00033 };
00034
00035 #endif
00036
00038 #endif // Apoxi_BufferedOutputStream_hpp
00039
00040
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CancelAction.cpp File Reference

Compat/CancelAction.cpp File Reference

#include "PreComp.hpp"
#include "CancelAction.hpp"
#include <Kernel/System.hpp>

Include dependency graph for CancelAction.cpp:

Generated on Tue Jan 24 20:16:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CancelAction.hpp File Reference

Compat/CancelAction.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/Control.hpp>
#include <Kernel/MsgTypes.hpp>

Include dependency graph for CancelAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CancelAction

Defines

#define | Apoxi_CancelAction_hpp

Define Documentation

#define Apoxi_CancelAction_hpp

Generated on Tue Jan 24 20:16:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CancelAction.hpp Source File

Compat/CancelAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CancelAction_hpp)
00010 #define Apoxi_CancelAction_hpp
00013
00014 #include <Gui/Action.hpp>
00015 #include <Gui/Control.hpp>
00016 #include <Kernel/MsgTypes.hpp>
00017
00026 class CancelAction : public Action {
00027     typedef Action Base;
00028
00029     public:
00032         CancelAction();
00033
00035         CancelAction(Control* control, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00036
00038         virtual ~CancelAction();
00039
00041         void Init(Control* control,  const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00042
00045         virtual BOOLEAN Execute();
00046 };
00047
00049 #endif  // Apoxi_CancelAction_hpp
00050
00051
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CheckBox.cpp File Reference

Compat/CheckBox.cpp File Reference

#include "PreComp.hpp"
#include "CheckBox.hpp"
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/System.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>

Include dependency graph for CheckBox.cpp:

Generated on Tue Jan 24 20:16:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CheckBox.hpp File Reference

Compat/CheckBox.hpp File Reference

#include <Gui/Model.hpp>
#include <Gui/View.hpp>
#include <Gui/Control.hpp>

Include dependency graph for CheckBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CheckBox
Obsolete - use the class CheckBoxControl from GUI instead. More...
class | CheckBoxModel
Describes the model of a checkbox. More...
class | CheckBoxView
Describes the view of a checkbox. More...

Defines

#define | Apoxi_CheckBox_hpp

Define Documentation

#define Apoxi_CheckBox_hpp

Generated on Tue Jan 24 20:16:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CheckBox.hpp Source File

Compat/CheckBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_CheckBox_hpp)
00011 #define Apoxi_CheckBox_hpp
00012
00013 #include <Gui/Model.hpp>
00014 #include <Gui/View.hpp>
00015 #include <Gui/Control.hpp>
00016
00017
00019 class CheckBoxModel : public Model {
00020     public:
00021         typedef Model Base;
00022
00024         CheckBoxModel(const WCHAR *caption = 0, BOOLEAN selected = FALSE);
00025
00027         void SetSelected(BOOLEAN selected) { m_selected = selected; };
00028
00030         BOOLEAN IsSelected() const { return m_selected; };
00031
00033         void SetCaption(const WCHAR *caption) { m_caption = caption; };
00034
00036         const WCHAR* GetCaption() const { return m_caption; };
00037
00038     private:
00039         BOOLEAN     m_selected;
00040         const WCHAR *m_caption;
00041 };
00042
00044 class CheckBoxView : public View {
00045     typedef View Base;
00046
00047     public:
00049         CheckBoxView();
00050
00052         CheckBoxView(XYDIM default_height, XYDIM left_gap, XYDIM middle_gap);
00053
00055         virtual ~CheckBoxView();
00056
00058         void SetItemHeight(XYDIM item_height) { m_item_height = item_height; };
00059
00061         XYDIM GetItemHeight() const { return m_item_height; };
00062
00065         void SetLeftGap(XYDIM left_gap) { m_left_gap = left_gap; };
00066
00069         XYDIM GetLeftGap() const { return m_left_gap; };
00070
00072         void SetMiddleGap(XYDIM middle_gap) { m_middle_gap = middle_gap; };
00073
00075         XYDIM GetMiddleGap() const { return m_middle_gap; };
00076
00078         virtual void Draw(const Component &component, DeviceContext *dc, const Rect &repaint_rect) const;
00079
00081         virtual void DrawShifted(const Rect &shift_rect, const Model &abstract_model, DeviceContext *dc,  const Rect &repaint_rect) const;
00082
00083     protected:
00085         virtual void DrawCheckBox(const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const = 0;
00086
00088         virtual void DrawShiftedCheckBox(const Rect &shift_rect, const CheckBoxModel &abstract_model, DeviceContext *dc,  const Rect &repaint_rect) const = 0;
00089
00090     private:
00091         XYDIM m_item_height;
00092         XYDIM m_left_gap;
00093         XYDIM m_middle_gap;
00094 };
00095
00097 class CheckBox : public Control {
00098     typedef Control Base;
00099
00100     public:
00103         CheckBox();
00104
00108         CheckBox(Control *parent, const WCHAR *caption = 0, BOOLEAN selected = FALSE);
00109
00110         virtual ~CheckBox();
00111
00115         void Init(Control *parent, const WCHAR *caption = 0, BOOLEAN selected = FALSE);
00116
00118         void SetSelected(BOOLEAN selected);
00119
00121         BOOLEAN IsSelected() const;
00122
00123     protected:
00125         virtual Model* CreateModel() const;
00126
00128         virtual void Refresh(const Rect &rect);
00129
00131         virtual void OnGetFocus();
00132
00134         virtual void OnLoseFocus();
00135
00137         virtual BOOLEAN OnSoftkeyPressed(INT idx);
00138
00140         virtual BOOLEAN OnInputMap(const InputMapItem &input_map_item);
00141
00143         virtual void OnThemeChanged();
00144
00146         virtual void OnLanguageChanged();
00147
00149         virtual void OnChangeStatus();
00150
00151     private:
00152         CheckBoxModel* GetMyModel() const { return (CheckBoxModel *)GetModel(); }
00153         void AdjustThemeDependencies();
00154
00155 };
00156
00157
00158 #endif  // Apoxi_CheckBox_hpp
00159
00160
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CheckBoxItem.hpp File Reference

Compat/CheckBoxItem.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CheckBoxItem

Defines

#define | Apoxi_CheckBoxItem_hpp

Define Documentation

#define Apoxi_CheckBoxItem_hpp

Generated on Tue Jan 24 20:16:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CheckBoxItem.hpp Source File

Compat/CheckBoxItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CheckBoxItem_hpp)
00010 #define Apoxi_CheckBoxItem_hpp
00011
00012
00017 class CheckBoxItem : public Linkable<CheckBoxItem> {
00018     public:
00019         CheckBoxItem(const WCHAR *text = 0, BOOLEAN selected = FALSE) :
00020             m_text(text), m_selected(selected) {}
00021
00023         void SetText(const WCHAR *text) { m_text = text; };
00024
00026         const WCHAR* GetText() const { return m_text; };
00027
00029         void SetSelected(BOOLEAN selected) { m_selected = selected; };
00030
00032         BOOLEAN IsSelected() const { return m_selected; };
00033
00034     private:
00035         const WCHAR *m_text;
00036         BOOLEAN     m_selected;
00037 };
00038
00039
00040 #endif  // Apoxi_CheckBoxItem_hpp
00041
00042
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CheckBoxList.cpp File Reference

Compat/CheckBoxList.cpp File Reference

#include "PreComp.hpp"
#include "CheckBoxList.hpp"
#include <Kernel/MsgTypes.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Application.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>

Include dependency graph for CheckBoxList.cpp:

Generated on Tue Jan 24 20:16:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CheckBoxList.hpp File Reference

Compat/CheckBoxList.hpp File Reference

#include <Gui/Lib.hpp>
#include <Gui/AbstractListBox.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Gui/AbstractMenuList.hpp>
#include <Gui/CheckBoxItem.hpp>
#include <Gui/CheckBox.hpp>

Include dependency graph for CheckBoxList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CheckBoxList
class | CheckBoxListView
Describes the view of a checkbox-list. More...

Defines

#define | Apoxi_CheckBoxList_hpp

Typedefs

typedef AbstractMenuListModel<
CheckBoxItem > 		CheckBoxListModel

Define Documentation

#define Apoxi_CheckBoxList_hpp

Typedef Documentation

typedef AbstractMenuListModel<CheckBoxItem> CheckBoxListModel

Generated on Tue Jan 24 20:16:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CheckBoxList.hpp Source File

Compat/CheckBoxList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CheckBoxList_hpp)
00010 #define Apoxi_CheckBoxList_hpp
00011
00012 #include <Gui/Lib.hpp>
00013 #include <Gui/AbstractListBox.hpp>
00014 #include <Auxiliary/LinkedList.hpp>
00015 #include <Gui/AbstractMenuList.hpp>
00016 #include <Gui/CheckBoxItem.hpp>
00017 #include <Gui/CheckBox.hpp>
00018
00019
00020 typedef AbstractMenuListModel<CheckBoxItem> CheckBoxListModel;
00021
00024 class CheckBoxList : public AbstractMenuList {
00025     typedef AbstractMenuList Base;
00026
00027     public:
00030         CheckBoxList();
00031
00033         CheckBoxList(Control *parent);
00034
00035         virtual ~CheckBoxList();
00036
00038         void Init(Control *parent);
00039
00043         void AddItem(CheckBoxItem *item, CheckBoxItem *after = 0);
00044
00046         void AddItem(CheckBoxItem *item, const WCHAR *text, BOOLEAN selected = FALSE) const;
00047
00049         void RemoveItem(CheckBoxItem *item);
00050
00052         void RemoveAllItems() const;
00053
00055         CheckBoxItem* GetFirstItem() const;
00056
00057     protected:
00059         virtual Model* CreateModel() const;
00060
00062         virtual void Refresh(const Rect &rect);
00063
00065         virtual void OnThemeChanged();
00066
00068         virtual void OnLanguageChanged();
00069
00071         virtual void OnItemSelected();
00072
00073     private:
00074         CheckBoxListModel* GetMyModel() const { return (CheckBoxListModel *)GetModel(); }
00075 };
00076
00078 class CheckBoxListView : public AbstractListBoxView {
00079     typedef AbstractListBoxView Base;
00080
00081     public:
00082         // Constructor of the view of a checkbox-list.
00083         CheckBoxListView();
00084         CheckBoxListView(CheckBoxView *view, XYDIM item_height);
00085
00087         virtual ~CheckBoxListView();
00088
00090         virtual void DrawItem(const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const;
00091
00092     protected:
00093         const CheckBoxView *m_view;
00094
00096         virtual void DrawCheckBoxItem(const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const = 0;
00097 };
00098
00099
00100 #endif  // Apoxi_CheckBoxList_hpp
00101
00102
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ChrHandler.cpp File Reference

Compat/ChrHandler.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for ChrHandler.cpp:

Generated on Tue Jan 24 20:16:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ChrHandler.hpp File Reference

Compat/ChrHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_ChrHandler_hpp

Define Documentation

#define Asc_ChrHandler_hpp

Generated on Tue Jan 24 17:18:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ChrHandler.hpp Source File

Compat/ChrHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_ChrHandler_hpp)
00009 #define Asc_ChrHandler_hpp
00012
00013 #ifdef APOXI_COMPAT_2_2_0
00014
00015 #include <Asc/BaseHandler.hpp>
00016
00017 /*  ========================================================================
00018     ChrHandler
00019     ======================================================================== */
00022 class ChrHandler : public BaseHandler {
00023     typedef BaseHandler Base;
00024     public:
00025         enum { ID = ChrHandlerId };
00026
00028         ChrHandler();
00030         virtual ~ChrHandler();
00031
00033         virtual HandlerId GetHandlerId() const;
00034
00035 };
00036 #endif // APOXI_COMPAT_2_2_0
00037
00039 #endif // Asc_ChrHandler_hpp
00040
00041
Generated on Tue Jan 24 14:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CompatInfo.cpp File Reference

Compat/CompatInfo.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for CompatInfo.cpp:

Generated on Tue Jan 24 20:16:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/CompatTemplates.cpp File Reference

Compat/CompatTemplates.cpp File Reference

#include "PreComp.hpp"
#include <Compat/CheckBoxList.hpp>
#include <Compat/RadioButtonList.hpp>
#include <Compat/AbstractEditBox.hpp>
#include <Compat/TextList.hpp>

Include dependency graph for CompatTemplates.cpp:

Generated on Tue Jan 24 20:16:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ConfirmAction.cpp File Reference

Compat/ConfirmAction.cpp File Reference

#include "PreComp.hpp"
#include "ConfirmAction.hpp"
#include <Kernel/System.hpp>

Include dependency graph for ConfirmAction.cpp:

Generated on Tue Jan 24 20:16:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ConfirmAction.hpp File Reference

Compat/ConfirmAction.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/Control.hpp>
#include <Gui/MsgTypes.hpp>

Include dependency graph for ConfirmAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ConfirmAction

Defines

#define | Apoxi_ConfirmAction_hpp

Define Documentation

#define Apoxi_ConfirmAction_hpp

Generated on Tue Jan 24 20:16:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ConfirmAction.hpp Source File

Compat/ConfirmAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ConfirmAction_hpp)
00010 #define Apoxi_ConfirmAction_hpp
00013
00014 #include <Gui/Action.hpp>
00015 #include <Gui/Control.hpp>
00016 #include <Gui/MsgTypes.hpp>
00017
00026 class ConfirmAction : public Action {
00027     typedef Action Base;
00028
00029     public:
00032         ConfirmAction();
00033
00035         ConfirmAction(Control* control, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00036
00038         virtual ~ConfirmAction();
00039
00041         void Init(Control* control, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00042
00045         virtual BOOLEAN Execute();
00046 };
00047
00049 #endif  // Apoxi_ConfirmAction_hpp
00050
00051
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DateEditBox.cpp File Reference

Compat/DateEditBox.cpp File Reference

#include "PreComp.hpp"
#include "DateEditBox.hpp"
#include <Gui/PagingMap.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Gui/Locale.hpp>

Include dependency graph for DateEditBox.cpp:

Generated on Tue Jan 24 20:16:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DateEditBox.hpp File Reference

Compat/DateEditBox.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Date.hpp>
#include <Compat/AbstractEditBox.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for DateEditBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DateEditBox
Obsolete - use DateEditor from Gui instead. More...
class | DateEditBoxModel
Describes the model of a date editbox. More...
class | DateEditBoxView
Describes the view of a date editbox. More...

Defines

#define | Apoxi_DateEditBox_hpp

Define Documentation

#define Apoxi_DateEditBox_hpp

Generated on Tue Jan 24 20:16:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DateEditBox.hpp Source File

Compat/DateEditBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DateEditBox_hpp)
00010 #define Apoxi_DateEditBox_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Auxiliary/Date.hpp>
00014 #include <Compat/AbstractEditBox.hpp>
00015 #include <Gui/Lib.hpp>
00016
00018 class DateEditBoxModel : public AbstractEditBoxModel {
00019 };
00020
00022 class DateEditBoxView : public AbstractEditBoxView {
00023     typedef AbstractEditBoxView Base;
00024
00025     public:
00027         DateEditBoxView();
00029         DateEditBoxView(XYDIM line_height,
00030                         XYDIM caption_gap,
00031                         XYDIM caption_width,
00032                         XYDIM caption_height,
00033                         XYDIM frame_size,
00034                         XYDIM default_width = -1,
00035                         XYDIM default_height = -1);
00036
00038         virtual ~DateEditBoxView();
00039
00041         virtual void Draw(const Component &component, DeviceContext *dc, const Rect &repaint_rect) const;
00042
00043     protected:
00049         virtual void DrawDateEditBox(const DateEditBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00050 };
00051
00053 class DateEditBox : public AbstractEditBox {
00054     typedef AbstractEditBox Base;
00055
00056     public:
00059         DateEditBox();
00060
00065         DateEditBox(Control *parent,
00066                     Date::Format format = Date::ShortDateDMY,
00067                     const WCHAR *caption = 0,
00068                     CaptionPos caption_pos = CaptionOnTop);
00069
00071         virtual ~DateEditBox();
00072
00077         void Init(Control *parent,
00078                   Date::Format format = Date::ShortDateDMY,
00079                   const WCHAR *caption = 0,
00080                   CaptionPos caption_pos = CaptionOnTop);
00081
00083         void SetFormat(Date::Format format);
00085         void SetFormat(const WCHAR *format);
00086
00088         const WCHAR* GetFormat() const { return m_format; }
00089
00091         void SetDate(const Date& date) const;
00092
00094         Date GetDate() const;
00095
00097         virtual BOOLEAN IsInputValid() const;
00098
00099     protected:
00101         virtual Model* CreateModel() const;
00102
00104         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00105
00107         virtual void OnDeleteChar();
00108
00110         virtual void MoveCursor(INT inc);
00111
00113         virtual const AbstractEditBoxView* GetView() const;
00114
00115     private:
00116         const WCHAR         *m_format;
00117         WCHAR               m_buffer[20];
00118         static DateEditBoxView m_view;
00119
00120         DateEditBoxModel* GetMyModel() const { return (DateEditBoxModel *)GetModel(); }
00121         INT GetCharPos(WCHAR chr) const;
00122         INT GetDay() const;
00123         INT GetMonth() const;
00124         INT GetYear() const;
00125         INT GetBufferSize() const { return sizeof(m_buffer)/sizeof(m_buffer[0]); }
00126 };
00127
00128
00129 #endif  // Apoxi_DateEditBox_hpp
00130
00131
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DebugOutputStream.cpp File Reference

Compat/DebugOutputStream.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "DebugOutputStream.hpp"
#include "Kernel/Os/OsStrLib.hpp"

Include dependency graph for DebugOutputStream.cpp:

Generated on Tue Jan 24 20:16:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DebugOutputStream.hpp File Reference

Compat/DebugOutputStream.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for DebugOutputStream.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DebugOutputStream

Defines

#define | Apoxi_DebugOutputStream_hpp

Define Documentation

#define Apoxi_DebugOutputStream_hpp

Generated on Tue Jan 24 20:16:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DebugOutputStream.hpp Source File

Compat/DebugOutputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DebugOutputStream_hpp)
00010 #define Apoxi_DebugOutputStream_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 #ifndef APOXI_NOSTREAMING
00017
00018 class DebugOutputStream : public OutputStream {
00019     public:
00020         DebugOutputStream();
00021         virtual ~DebugOutputStream();
00022
00023         virtual INT Write (const BYTE data);
00024         virtual INT Write (const BYTE* data, INT len);
00025
00026         virtual OutputStream& operator << (const char c);
00027         virtual OutputStream& operator << (const unsigned char c);
00028         virtual OutputStream& operator << (const signed char c);
00029
00030         virtual OutputStream& operator << (const char* s);
00031
00032         virtual OutputStream& operator << (const wchar_t* w);
00033
00034         virtual OutputStream& operator << (const short n);
00035         virtual OutputStream& operator << (const unsigned short n);
00036
00037         virtual OutputStream& operator << (const int n);
00038         virtual OutputStream& operator << (const unsigned int n);
00039
00040         virtual OutputStream& operator << (const long n);
00041         virtual OutputStream& operator << (const unsigned long n);
00042
00043         virtual void Flush();
00044
00045 };
00046
00047 #endif
00048
00050 #endif // Apoxi_DebugOutputStream_hpp
00051
00052
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DialogWindow.cpp File Reference

Compat/DialogWindow.cpp File Reference

#include "PreComp.hpp"
#include "DialogWindow.hpp"

Include dependency graph for DialogWindow.cpp:

Generated on Tue Jan 24 20:17:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DialogWindow.hpp File Reference

Compat/DialogWindow.hpp File Reference

#include <Gui/Window.hpp>

Include dependency graph for DialogWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DialogWindow

Defines

#define | Apoxi_DialogWindow_hpp

Define Documentation

#define Apoxi_DialogWindow_hpp

Generated on Tue Jan 24 20:17:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/DialogWindow.hpp Source File

Compat/DialogWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DialogWindow_hpp)
00010 #define Apoxi_DialogWindow_hpp
00013
00014 #include <Gui/Window.hpp>
00015
00017 class DialogWindow : public Window {
00018     typedef Window Base;
00019
00020     public:
00022         enum ReturnId {
00024             ConfirmId,
00026             CancelId,
00027         };
00028
00030         virtual ~DialogWindow();
00031
00032     protected:
00036         virtual BOOLEAN OnConfirm();
00037
00041         virtual BOOLEAN OnCancel();
00042 };
00043
00045 #endif  // Apoxi_DialogWindow_hpp
00046
00047
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/EditBox.cpp File Reference

Compat/EditBox.cpp File Reference

#include "PreComp.hpp"
#include "EditBox.hpp"
#include <Kernel/MsgTypes.hpp>
#include <Kernel/InputMap.hpp>
#include <Gui/PagingMap.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Config/EditConfig.hpp>

Include dependency graph for EditBox.cpp:

Functions

InputStream & operator>> (InputStream &istr, EditBoxShiftState val)

Function Documentation

InputStream& operator>> | ( | InputStream & | istr,
 |  | EditBoxShiftState | val
 | ) |

Generated on Tue Jan 24 20:17:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/EditBox.hpp File Reference

Compat/EditBox.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Compat/AbstractEditBox.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for EditBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EditBox
Obsolete - use MultiLineEditor or LineEditor from Gui instead. More...
class | EditBoxModel
Describes the model of a date editbox. More...
class | EditBoxPagingTimer
class | EditBoxView
Describes the view of a date editbox. More...

Defines

#define | Apoxi_EditBox_hpp

Typedefs

typedef EditBox::ShiftState | EditBoxShiftState

Functions

InputStream & | operator>> (InputStream &istr, EditBoxShiftState val)

Define Documentation

#define Apoxi_EditBox_hpp

Typedef Documentation

typedef EditBox::ShiftState EditBoxShiftState

Function Documentation

InputStream& operator>> | ( | InputStream & | istr,
 |  | EditBoxShiftState | val
 | ) |

Generated on Tue Jan 24 20:17:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/EditBox.hpp Source File

Compat/EditBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_EditBox_hpp)
00010 #define Apoxi_EditBox_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Kernel/Os/Os.hpp>
00014 #include <Compat/AbstractEditBox.hpp>
00015 #include <Gui/Lib.hpp>
00016
00017
00019 class EditBoxModel : public AbstractEditBoxModel {
00020 };
00021
00023 class EditBoxView : public AbstractEditBoxView {
00024     typedef AbstractEditBoxView Base;
00025
00026     public:
00028         EditBoxView();
00030         EditBoxView(XYDIM line_height,
00031                         XYDIM caption_gap,
00032                         XYDIM caption_width,
00033                         XYDIM caption_height,
00034                         XYDIM frame_size,
00035                         XYDIM default_width = -1,
00036                         XYDIM default_height = -1);
00037
00039         virtual ~EditBoxView();
00040
00042         virtual void Draw(const Component &component, DeviceContext *dc, const Rect &repaint_rect) const;
00043
00044     protected:
00049         virtual void DrawEditBox(const EditBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00050 };
00051
00052 class EditBox;
00053
00054 class EditBoxPagingTimer : public Timer {
00055     public:
00056         typedef Timer Base;
00057         EditBoxPagingTimer();
00058         void SetEditBox(EditBox *edit_box) { m_edit_box = edit_box; }
00059
00060     protected:
00061         virtual void OnTimer();
00062
00063     private:
00064         EditBox *m_edit_box;
00065 };
00066
00067
00069 class EditBox : public AbstractEditBox {
00070     public:
00071         typedef AbstractEditBox Base;
00072
00073         friend class EditBoxPagingTimer;
00074
00076         enum EditMode {
00078             AlphanumMode,
00080             AlphanumNameMode,
00082             NumericMode,
00084             PhoneNumberMode,
00086             PredInputMode,
00087         };
00088
00090         enum DeleteMode {
00093             DelLeftCharMode,
00095             DelCurrCharMode
00096         };
00097
00098         enum ShiftState {
00099             OffShiftstate,
00100             OnShiftstate,
00101             LockedShiftstate
00102         };
00103
00106         EditBox();
00107
00114         EditBox(Control *parent,
00115                 WCHAR *text = 0,
00116                 INT max_text_len = 0,
00117                 EditMode edit_mode = AlphanumMode,
00118                 const WCHAR *caption = 0,
00119                 CaptionPos caption_pos = CaptionOnTop);
00120
00122         virtual ~EditBox();
00123
00130         void Init(Control *parent,
00131                   WCHAR *text = 0,
00132                   INT max_text_len = 0,
00133                   EditMode edit_mode = AlphanumMode,
00134                   const WCHAR *caption = 0,
00135                   CaptionPos caption_pos = CaptionOnTop);
00136
00138         void SetEditMode(EditMode edit_mode);
00139
00141         EditMode GetEditMode() const { return (EditMode)m_bits.edit_mode; }
00142
00144         void SetDeleteMode(DeleteMode delete_mode) { m_bits.delete_mode = delete_mode; }
00145
00147         DeleteMode GetDeleteMode() const { return (DeleteMode)m_bits.delete_mode; }
00148
00149     protected:
00151         virtual Model* CreateModel() const;
00152
00154         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00155
00157         virtual BOOLEAN OnInputMap(const InputMapItem &input_map_item);
00158
00160         virtual void OnShiftKey();
00161
00163         virtual void OnGetFocus();
00164
00166         virtual void OnLoseFocus();
00167
00169         virtual void OnPagingTimer();
00170
00172         virtual void OnDeleteChar();
00173
00176         virtual void OnDtmfSeparator();
00177
00179         virtual void OnPlus();
00180
00183         virtual void OnWildcard();
00184
00186         virtual const AbstractEditBoxView* GetView() const;
00187
00189         virtual void MoveCursor(INT inc);
00190
00191     private:
00192         struct {
00193             UINT edit_mode      : 2;
00194             UINT delete_mode    : 1;
00195             UINT shift_state    : 2;
00196             UINT i_paging       : 5;
00197         } m_bits;
00198         KeyCode         m_prev_key;
00199         static EditBoxPagingTimer m_paging_timer;
00200         static EditBoxView m_view;
00201
00202         EditBoxModel* GetMyModel() const { return (EditBoxModel *)GetModel(); }
00203
00204         BOOLEAN GetAcceptableChar(const WCHAR *presentation, INT insert_idx);
00205
00206         void SetShiftState(ShiftState state) { m_bits.shift_state = state; };
00207         ShiftState GetShiftState() const { return (ShiftState)m_bits.shift_state; };
00208 };
00209
00210 typedef EditBox::ShiftState EditBoxShiftState;
00211
00212 #ifndef APOXI_NOSTREAMING
00213
00214 InputStream & operator >> (InputStream & istr, EditBoxShiftState val);
00215
00216 #endif
00217
00218
00219 #endif  // Apoxi_EditBox_hpp
00220
00221
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FfsFile.cpp File Reference

Compat/FfsFile.cpp File Reference

#include "PreComp.hpp"
#include "FfsFile.hpp"
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for FfsFile.cpp:

Generated on Tue Jan 24 20:17:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FfsFile.hpp File Reference

Compat/FfsFile.hpp File Reference

#include <Adc/FfsMimeTypeMap.hpp>

Include dependency graph for FfsFile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsFile

Defines

#define | Adc_FfsFile_hpp

Define Documentation

#define Adc_FfsFile_hpp

Generated on Tue Jan 24 20:17:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FfsFile.hpp Source File

Compat/FfsFile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Adc_FfsFile_hpp)
00010 #define Adc_FfsFile_hpp
00011
00012 #include <Adc/FfsMimeTypeMap.hpp>
00013
00014 /*------------------------------------------------------------------
00015                             FfsFile
00016  ------------------------------------------------------------------*/
00017
00022 class FfsFile
00023 {
00024     public:
00026         FfsFile();
00028         ~FfsFile();
00029
00031         BOOLEAN     Open(FfsFileId id, FfsFileType file_type, FfsOpenMode mode);
00033         BOOLEAN     Open(FfsFileId id, MimeType mime_type, FfsOpenMode mode);
00036         BOOLEAN     Open(const CHAR *filename, FfsOpenMode mode);
00038         BOOLEAN     Open(const CHAR *filename, FfsFileType file_type, FfsOpenMode mode);
00040         BOOLEAN     Open(const CHAR *filename, MimeType mime_type, FfsOpenMode mode);
00041
00043         BOOLEAN     Close();
00044
00046         BOOLEAN     Read(UINT32 offset, void FFS_HUGE *dst, UINT16 nof);
00047
00050         BOOLEAN     Create(FfsFileId id, FfsFileType file_type, UINT32 size);
00052         BOOLEAN     Create(FfsFileId id, MimeType mime_type, UINT32 size);
00055         BOOLEAN     Create(const CHAR *filename, UINT32 size);
00057         BOOLEAN     Create(const CHAR *filename, FfsFileType file_type, UINT32 size);
00059         BOOLEAN     Create(const CHAR *filename, MimeType mime_type, UINT32 size);
00060
00062         BOOLEAN     Write(const void FFS_HUGE *src, UINT32 offset, UINT16 nof);
00063
00065         BOOLEAN     Modify(const void FFS_HUGE *src, UINT32 offset, UINT16 nof);
00066
00068         BOOLEAN     Delete();
00069
00071         BOOLEAN     Append(const void FFS_HUGE *src, UINT16 nof);
00072
00074         BOOLEAN     Rename(FfsFileId new_id);
00076         BOOLEAN     Rename(const CHAR *new_filename);
00077
00079         UINT32      GetFileSize();
00080
00082         FfsFileType GetFileType();
00083
00085         FfsTimeRecord   GetTimestamp();
00086
00088         FfsError    GetLastError() const { return m_last_error; }
00089
00090     private:
00091         BOOLEAN     Open(FfsOpenMode mode);
00092         BOOLEAN     Create(FfsFileId id, UINT32 size);
00093         BOOLEAN     GetFileInfo();
00094         const CHAR* GetFileExtension(const CHAR *filename);
00095
00096         BOOLEAN     m_is_info_upd;
00097         BOOLEAN     m_has_filename;
00098         FfsFileId   m_file_id;
00099         FfsUserType m_user_id;
00100         FfsFileType m_file_type;
00101         FfsError    m_last_error;
00102         FfsHandle   m_filehandle;
00103         FfsFileInfo m_file_info;
00104         String      m_filename;
00105 };
00106
00107
00108
00109 #endif
00110
00111
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FileInputStream.cpp File Reference

Compat/FileInputStream.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "FileInputStream.hpp"

Include dependency graph for FileInputStream.cpp:

Generated on Tue Jan 24 20:17:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FileInputStream.hpp File Reference

Compat/FileInputStream.hpp File Reference

#include <Kernel/InputStream.hpp>

Include dependency graph for FileInputStream.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileInputStream

Defines

#define | Apoxi_FileInputStream_hpp

Define Documentation

#define Apoxi_FileInputStream_hpp

Generated on Tue Jan 24 20:17:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FileInputStream.hpp Source File

Compat/FileInputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_FileInputStream_hpp)
00010 #define Apoxi_FileInputStream_hpp
00013
00014 #include <Kernel/InputStream.hpp>
00015
00016 #ifndef APOXI_NOSTREAMING
00017
00018 class FileInputStream : public InputStream{
00019     public:
00020
00021         FileInputStream();
00022         virtual ~FileInputStream();
00023
00024         int IsOpen() const { return m_peer.IsOpen(); };
00025         void Open(const char* name, int flags) { m_peer.Open(name, flags); };
00026         void Close() { m_peer.Close(); };
00027         int Peek() { return m_peer.Peek(); };
00028         int Eof() {return m_peer.Eof(); };
00029
00030         virtual INT Read (BYTE& data);
00031         virtual INT Read (BYTE* data, INT len);
00032
00033         virtual UINT32 Available();
00034
00035     private:
00036         FileIoPeer m_peer;
00037 };
00038
00039 #endif
00040
00042 #endif // Apoxi_FileInputStream_hpp
00043
00044
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FileOutputStream.cpp File Reference

Compat/FileOutputStream.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "FileOutputStream.hpp"

Include dependency graph for FileOutputStream.cpp:

Generated on Tue Jan 24 20:17:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FileOutputStream.hpp File Reference

Compat/FileOutputStream.hpp File Reference

#include <Kernel/OutputStream.hpp>

Include dependency graph for FileOutputStream.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileOutputStream

Defines

#define | Apoxi_FileOutputStream_hpp

Define Documentation

#define Apoxi_FileOutputStream_hpp

Generated on Tue Jan 24 20:17:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/FileOutputStream.hpp Source File

Compat/FileOutputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_FileOutputStream_hpp)
00010 #define Apoxi_FileOutputStream_hpp
00013
00014 #include <Kernel/OutputStream.hpp>
00015
00016 #ifndef APOXI_NOSTREAMING
00017
00018 class FileOutputStream : public OutputStream {
00019     public:
00020         FileOutputStream();
00021         virtual ~FileOutputStream();
00022
00023         virtual INT Write (const BYTE data);
00024         virtual INT Write (const BYTE* data, INT len);
00025
00026         INT IsOpen() const { return m_peer.IsOpen(); };
00027         void Open(const char* name, int flags) { m_peer.Open(name, flags); };
00028         void Close() { m_peer.Close(); };
00029         INT Eof() {return m_peer.Eof(); };
00030
00031         virtual void Flush();
00032
00033     private:
00034         FileIoPeer m_peer;
00035 };
00036
00037 #endif
00038
00040 #endif // Apoxi_FileOutputStream_hpp
00041
00042
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Grid.cpp File Reference

Compat/Grid.cpp File Reference

#include "PreComp.hpp"
#include "Grid.hpp"
#include <Gui/PaintDc.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/InputMap.hpp>
#include <Kernel/System.hpp>

Include dependency graph for Grid.cpp:

Generated on Tue Jan 24 20:21:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Grid.hpp File Reference

Compat/Grid.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Control.hpp>
#include <Gui/Model.hpp>
#include <Gui/View.hpp>
#include <Gui/PositionIndicator.hpp>
#include <Gui/AbstractListBox.hpp>

Include dependency graph for Grid.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Cell
Combines the row and column of a matrix. More...
class | Grid
Obsolete - use AbstractGrid or Menu from GUI instead. More...
class | GridModel
A matixbox-model describes the data of the widget grid. More...
class | GridView

Defines

#define | Kernel_Grid_hpp

Typedefs

typedef UINT | Behaviour

Enumerations

enum {
DefaultBehaviour = 0, BlockScrollBehaviour = 1, NoSelectionBehaviour = 2, NoHighlightningBehaviour = 4,
RotateBehaviour = 8
}
enum RepaintHint {
NoRepaintHint, TopReachedRepaintHint, BottomReachedRepaintHint, MovedLeftRepaintHint,
MovedRightRepaintHint, MovedUpRepaintHint, MovedDownRepaintHint
}
enum | SelectionMode { Horizontal, Vertical }

Define Documentation

#define Kernel_Grid_hpp

Typedef Documentation

typedef UINT Behaviour

Enumeration Type Documentation

anonymous enum

Enumerator:
DefaultBehaviour
BlockScrollBehaviour
NoSelectionBehaviour
NoHighlightningBehaviour
RotateBehaviour

enum RepaintHint

Enumerator:
NoRepaintHint
TopReachedRepaintHint
BottomReachedRepaintHint
MovedLeftRepaintHint
MovedRightRepaintHint
MovedUpRepaintHint
MovedDownRepaintHint

enum SelectionMode

Enumerator:
Horizontal
Vertical

Generated on Tue Jan 24 20:21:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Grid.hpp Source File

Compat/Grid.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Kernel_Grid_hpp)
00010 #define Kernel_Grid_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Gui/Control.hpp>
00014 #include <Gui/Model.hpp>
00015 #include <Gui/View.hpp>
00016 #include <Gui/PositionIndicator.hpp>
00017 #include <Gui/AbstractListBox.hpp>
00018
00019 enum {
00020     DefaultBehaviour = 0,
00021     BlockScrollBehaviour = 1,
00022     NoSelectionBehaviour = 2,
00023     NoHighlightningBehaviour = 4,
00024     RotateBehaviour = 8
00025 };
00026
00027 enum RepaintHint {
00028     NoRepaintHint,
00029     TopReachedRepaintHint,
00030     BottomReachedRepaintHint,
00031     MovedLeftRepaintHint,
00032     MovedRightRepaintHint,
00033     MovedUpRepaintHint,
00034     MovedDownRepaintHint
00035 };
00036
00037 typedef UINT Behaviour;
00038
00039 enum SelectionMode {
00040     Horizontal,
00041     Vertical
00042 };
00043
00045 class Cell {
00046     public:
00048         Cell(INT column = 0, XYDIM row = 0);
00049
00051         Cell(const Cell &row);
00052
00054         void SetColumn(INT column) { m_column = column; }
00055
00057         INT GetColumn() const { return m_column; }
00058
00060         void SetRow(INT row) {  m_row = row; }
00061
00063         INT GetRow() const {    return m_row; }
00064
00065         BOOLEAN IsEqual(const Cell *cell) const;
00066
00067         BOOLEAN IsLess(const Cell *cell) const;
00068
00069         BOOLEAN IsGreater(const Cell *cell) const;
00070
00071     private:
00072         INT m_column;
00073         INT m_row;
00074 };
00075
00077 class GridModel : public AbstractListBoxModel {
00078     typedef AbstractListBoxModel Base;
00079     public:
00081         GridModel();
00083         GridModel(INT n_columns, INT n_rows, Behaviour behaviour = DefaultBehaviour,
00084                   const Cell &selected_cell = Cell());
00085
00086         virtual ~GridModel() {}
00087
00089         void Init(INT n_columns, INT n_rows, Behaviour behaviour = DefaultBehaviour,
00090                   const Cell &selected_cell = Cell());
00091
00093         void SetSelectedCell(const Cell &cell);
00094
00096         Cell GetSelectedCell() const { return m_selected_cell; };
00097
00099         INT GetNoOfCells() const { return (m_n_rows * m_n_columns); };
00100
00102         void SetNoOfColumns(INT n_columns);
00103
00105         INT GetNoOfColumns() const { return m_n_columns; };
00106
00108         void SetNoOfRows(INT n_rows);
00109
00111         INT GetNoOfRows() const { return m_n_rows; };
00112
00114         void SetColumnTitled(BOOLEAN column_titled);
00115
00117         BOOLEAN IsColumnTitled() const { return m_column_titled; };
00118
00120         void SetRowTitled(BOOLEAN row_titled);
00121
00123         BOOLEAN IsRowTitled() const { return m_row_titled; };
00124
00126         void SetFirstCell(const Cell &cell);
00127
00129         Cell GetFirstCell() const { return m_first_cell; };
00130
00132         void SetLastCell(const Cell &cell);
00133
00135         Cell GetLastCell() const { return m_last_cell; };
00136
00138         void SetSelectionMode(SelectionMode mode) { m_selection_mode = mode; };
00139
00141         SelectionMode GetSelectionMode() const { return m_selection_mode; };
00142
00144         void SetBehaviour(Behaviour behaviour) { m_behaviour = behaviour; };
00145
00147         Behaviour GetBehaviour() const { return m_behaviour; };
00148
00150         void SetFirstVisibleRow(INT row);
00151
00153         INT GetFirstVisibleRow() const { return m_first_visible_row; };
00154
00156         void SetRepaintHint(RepaintHint hint) { m_hint = hint; };
00157
00159         INT GetRepaintHint() const { return m_hint; };
00160
00162         //void SetPositionIndicator(PositionIndicator *position_indicator) { m_position_indicator = *position_indicator; };
00163
00165         PositionIndicator* GetPositionIndicator() { return &m_position_indicator; };
00166
00168         void SetMaxVisibleRows(INT max_visible_rows);
00169
00171         INT GetMaxVisibleRows() const { return m_max_visible_rows; };
00172
00174         BOOLEAN IsIndicatorFullsized() const { return (m_first_visible_row == 0 || IsColumnTitled()) && (m_max_visible_rows >= m_n_rows); };
00175
00176         //cell manipulation and checking functions:
00177         //infos about data in the model is needed
00179         BOOLEAN IncrementCell(Cell *cell, BOOLEAN select) const;
00180
00182         BOOLEAN DecrementCell(Cell *cell, BOOLEAN select) const;
00183
00185         BOOLEAN IsFirstCell(const Cell *cell) const;
00186
00188         BOOLEAN IsLastCell(const Cell *cell) const;
00189
00191         BOOLEAN IsSelectableCell(const Cell *cell) const;
00192
00193     private:
00194         BOOLEAN             m_column_titled;
00195         BOOLEAN             m_row_titled;
00196         INT                 m_n_columns;
00197         INT                 m_n_rows;
00198         INT                 m_first_visible_row;
00199         INT                 m_max_visible_rows;
00200         Behaviour           m_behaviour;            // TODO: Behaviour part of model? Shouldn't it be part of the control?
00201         RepaintHint         m_hint;
00202         PositionIndicator   m_position_indicator;
00203         Cell                m_first_cell;
00204         Cell                m_last_cell;
00205         Cell                m_selected_cell;
00206         SelectionMode       m_selection_mode;
00207
00208 };
00209
00213 class GridView : public View {
00214     typedef View Base;
00215
00216     public:
00218         GridView();
00220         GridView(XYDIM cell_width, XYDIM cell_height, XYDIM pos_indicator_width);
00221
00223         virtual ~GridView();
00224
00226         void SetCellHeight(XYDIM cell_height) { m_cell_height = cell_height; m_col_title_height = cell_height; };
00227
00229         XYDIM GetCellHeight() const { return m_cell_height; };
00230
00232         void SetCellWidth(XYDIM cell_width) { m_cell_width = cell_width; m_row_title_width = cell_width; };
00233
00235         XYDIM GetCellWidth() const { return m_cell_width; };
00236
00238         void SetColTitleHeight(XYDIM height) {m_col_title_height = height; };
00239
00241         XYDIM GetColTitleHeight() const { return m_col_title_height; };
00242
00244         void SetRowTitleWidth(XYDIM width) {m_row_title_width = width; };
00245
00247         XYDIM GetRowTitleWidth() const { return m_row_title_width; };
00248
00250         void SetPosIndicatorWidth(XYDIM pos_indicator_width) { m_pos_indicator_width = pos_indicator_width; }
00251
00253         XYDIM GetPosIndicatorWidth() const { return m_pos_indicator_width; }
00254
00256         virtual void Draw(const Component &component, DeviceContext *dc, const Rect &repaint_rect) const;
00257
00261         virtual void DrawCell(const GridModel &model, DeviceContext *dc, const Cell &cell, BOOLEAN highlighted = FALSE) const;
00262
00264         virtual void DrawCellPreHighlighted(const GridModel &model, DeviceContext *dc, const Cell &cell) const;
00265
00267         virtual void DrawCellPostHighlighted(const GridModel &model, DeviceContext *dc, const Cell &cell) const;
00268
00270         INT GetLastVisibleRow(const GridModel &model, const DeviceContext &dc) const;
00271
00273         INT GetLastCompletelyVisibleRow(const GridModel &model, const DeviceContext &dc) const;
00274
00276         Rect GetCellRect(const GridModel &model, const DeviceContext &dc, const Cell &cell) const;
00277
00279         XYDIM GetCellXPos(const GridModel &model, const DeviceContext &dc, const Cell &cell) const;
00280
00282         XYDIM GetCellYPos(const GridModel &model, const DeviceContext &dc, const Cell &cell) const;
00283
00284     private:
00285         XYDIM m_cell_width;
00286         XYDIM m_cell_height;
00287         XYDIM m_row_title_width;
00288         XYDIM m_col_title_height;
00289         XYDIM m_pos_indicator_width;
00290
00291         void DrawCellHighlighted(const GridModel &model, DeviceContext *dc, const Cell &cell) const;
00292         void DrawPositionIndicator(GridModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00293 };
00294
00296 class Grid : public Control {
00297     public:
00298         typedef Control Base;
00299
00301         Grid();
00302
00304         Grid(Control *parent, INT columns, INT rows,
00305              Behaviour behaviour = DefaultBehaviour,
00306              const Cell &selected_cell = Cell());
00307
00309         virtual ~Grid();
00310
00312         void Init(Control *parent, INT columns, INT rows,
00313                   Behaviour behaviour = DefaultBehaviour,
00314                   const Cell &selected_cell = Cell());
00315
00317         void SetSelectedCell(const Cell &cell);
00318
00320         Cell GetSelectedCell() const;
00321
00323         INT GetNoOfCells() const;
00324
00326         void SetNoOfColumns(INT n_columns);
00327
00329         INT GetNoOfColumns() const;
00330
00332         void SetNoOfRows(INT n_rows);
00333
00335         INT GetNoOfRows() const;
00336
00338         void SetColumnTitled(BOOLEAN column_titled);
00339
00341         BOOLEAN IsColumnTitled() const;
00342
00344         void SetRowTitled(BOOLEAN row_titled);
00345
00347         BOOLEAN IsRowTitled() const;
00348
00350         void SetFirstCell(const Cell &cell);
00351
00353         Cell GetFirstCell() const;
00354
00356         void SetLastCell(const Cell &cell);
00357
00359         Cell GetLastCell() const;
00360
00362         void SetSelectionMode(SelectionMode mode);
00363
00365         SelectionMode GetSelectionMode() const;
00366
00368         virtual void SetWidth(XYDIM width);
00369
00371         virtual void SetHeight(XYDIM height);
00372
00374         virtual void SetSize(const Size &size);
00375
00377         void SetSize(XYDIM width, XYDIM height) { SetSize(Size(width, height)); }
00378
00379     protected:
00381         virtual Model* CreateModel() const;
00382
00384         virtual void Refresh(const Rect &rect);
00385
00387         virtual BOOLEAN OnInputMap(const InputMapItem &input_map_item);
00388
00390         virtual void OnMoveLeft();
00391
00393         virtual void OnMoveRight();
00394
00396         virtual void OnMoveUp();
00397
00399         virtual void OnMoveDown();
00400
00402         virtual void OnSelectionChanged() {}
00403
00405         virtual void OnThemeChanged();
00406
00408         void AdjustThemeDependencies();
00409
00410     private:
00411         GridModel* GetMyModel() const { return (GridModel *)GetModel(); }
00412 };
00413
00414
00415
00416 #endif // Kernel_Grid_hpp
00417
00418
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IMelody.cpp File Reference

Compat/IMelody.cpp File Reference

#include "PreComp.hpp"
#include "AbstractIMelodyParser.hpp"
#include "IMelody.hpp"

Include dependency graph for IMelody.cpp:

Generated on Tue Jan 24 20:21:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IMelody.hpp File Reference

Compat/IMelody.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <AddOns/MultiMedia/Melody.hpp>

Include dependency graph for IMelody.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IMelody
struct | IMelodyData
Holds parsed IMelody data. More...

Defines

#define | MultiMedia_IMelody_hpp

Define Documentation

#define MultiMedia_IMelody_hpp

Generated on Tue Jan 24 16:43:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IMelody.hpp Source File

Compat/IMelody.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(MultiMedia_IMelody_hpp)
00011 #define MultiMedia_IMelody_hpp
00014
00015 #include <Auxiliary/BinData.hpp>
00016 #include <AddOns/MultiMedia/Melody.hpp>
00017
00019 struct IMelodyData {
00021     WString m_version;
00023     WString m_format;
00025     WString m_name;
00027     WString m_composer;
00029     Audio::ToneData m_tone_data;
00030
00032     struct {
00034         UINT16 beat     : 10;
00036         UINT8  style    : 2;
00038         UINT8  volume   : 4;
00039     } m_properties;
00040 };
00041
00042 class AbstractIMelodyParser;
00043
00047 class IMelody : public Melody {
00048     typedef Melody Base;
00049
00050     public:
00051         enum {
00052             ID = 0
00053         };
00054
00057         IMelody();
00058
00066         explicit IMelody(BinData* bin_data, BOOLEAN copyrighted = FALSE);
00067
00069         virtual ~IMelody();
00070
00078         void Init(BinData* bin_data, BOOLEAN copyrighted = FALSE);
00079
00081         virtual INT GetId() const;
00082
00084         virtual Audio::ToneData* GetToneData();
00085
00087         static void RegisterParser(AbstractIMelodyParser* parser);
00088
00090         virtual const BinData* GetBinData() const;
00091
00095         BinData* GetPlainData() { return m_bin_data; }
00096
00097     private:
00098         BinData* m_bin_data;
00099         IMelodyData m_parsed_data;
00100         static AbstractIMelodyParser* m_parser;
00101 };
00102
00104 #endif // MultiMedia_IMelody_hpp
00105
00106
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Indicator.cpp File Reference

Compat/Indicator.cpp File Reference

#include "PreComp.hpp"
#include "Indicator.hpp"
#include <Gui/Desktop.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>
#include <Gui/Bitmap.hpp>

Include dependency graph for Indicator.cpp:

Generated on Tue Jan 24 20:21:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Indicator.hpp File Reference

Compat/Indicator.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/PaintDc.hpp>
#include <Auxiliary/ObservableObject.hpp>
#include <Auxiliary/WString.hpp>
#include <Atl/Gui/IndicatorID.hpp>
#include <Atl/Gui/IndicatorBarID.hpp>
#include <Atl/Gui/IndicatorDescription.hpp>

Include dependency graph for Indicator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CenteredTextIndicator
Indicator that displays a text width maximized width. More...
class | IconIndicator
Indicator that displays an icon. More...
class | IconTextIndicator
Indicator that displays an icon and text. More...
struct | IconValueIndicator
Indicator that displays icon assigned for iterator values. More...
class | Indicator
Base class of indicators to be used in IndicatorBars. More...
class | TextIndicator
Indicator that displays an text. More...
class | ValueIndicator
Indicator that has several qualities. More...

Defines

#define | Atl_Gui_Indicator_hpp

Define Documentation

#define Atl_Gui_Indicator_hpp

Generated on Tue Jan 24 17:59:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Indicator.hpp Source File

Compat/Indicator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_Gui_Indicator_hpp)
00010 #define Atl_Gui_Indicator_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Gui/PaintDc.hpp>
00016 #include <Auxiliary/ObservableObject.hpp>
00017 #include <Auxiliary/WString.hpp>
00018 #include <Atl/Gui/IndicatorID.hpp>
00019 #include <Atl/Gui/IndicatorBarID.hpp>
00020 #include <Atl/Gui/IndicatorDescription.hpp>
00021
00022
00023
00025 class Indicator : public ObservableObject {
00026     public:
00027
00028
00029
00031         enum IndicatorAlignment {
00032             Left = 0,   // order must not be changed
00033             Center = 1,
00034             Right = 2
00035         };
00037         typedef INT IndicatorPosition;
00038
00040         Indicator(IndicatorPosition pos, IndicatorAlignment align);
00041
00043         void SetAlignment(IndicatorAlignment align);
00044
00046         IndicatorAlignment GetAlignment() const { return m_data.align; }
00047
00049         void SetPosition(IndicatorPosition pos);
00050
00052         IndicatorPosition GetPosition() const   { return m_pos; }
00053
00054
00055
00056
00058         Indicator();
00059
00061         void Init(const IndicatorID& indicatorId, const IndicatorDescription* desc = 0);
00062
00064         void SetIndicatorDescription(const IndicatorDescription *desc);
00065
00067         const IndicatorDescription *GetIndicatorDescription() const { return m_description; }
00068
00070         virtual ~Indicator();
00071
00073         virtual Size GetSize() const = 0;
00074
00076         void SetVisible(BOOLEAN flag);
00077
00078
00080         virtual BOOLEAN IsVisible() const { return m_data.visible; }
00081
00083         virtual void Draw(DeviceContext* dc, Point pos, Rect draw_rect) = 0;
00084
00086         const IndicatorID &GetId() const { return m_indicator_id; };
00087
00088     private:
00089
00090         struct {
00091             UINT    visible : 2;
00092             IndicatorAlignment  align : 3;  //OBSOLETE SINCE 1.21
00093
00094         } m_data;
00095
00096         IndicatorID             m_indicator_id;
00097         const IndicatorDescription* m_description;
00098
00099         IndicatorPosition   m_pos;
00100 };
00101
00103 class IconIndicator : public Indicator {
00104     typedef Indicator Base;
00105
00106     public:
00107
00109         IconIndicator(const BitmapRes* icon = 0, IndicatorPosition pos = 0, IndicatorAlignment align = Center);
00110
00114 //      IconIndicator(const BitmapRes* icon); HAS TO BE REACTIVATED
00116         virtual ~IconIndicator();
00117
00119         virtual Size GetSize() const;
00120
00123         void SetIcon (const BitmapRes* icon) { m_icon = icon; }
00125         const BitmapRes* GetIcon() const { return m_icon; }
00126
00128         virtual void Draw(DeviceContext* dc, Point pos, Rect draw_rect);
00129
00130     private:
00131         const BitmapRes* m_icon;
00132 };
00133
00135 class TextIndicator : public Indicator {
00136     typedef Indicator Base;
00137
00138     public:
00139         TextIndicator(){m_text = L"";};
00140         TextIndicator(const WString& text);
00142         virtual ~TextIndicator();
00143
00145         virtual Size GetSize() const;
00146
00149         void SetText (const WString& text);
00151         const WString& GetText() const { return m_text; }
00152
00154         virtual void Draw(DeviceContext* dc, Point pos, Rect draw_rect);
00155
00156     private:
00157         WString m_text;
00158
00159 };
00160
00162 class CenteredTextIndicator : public TextIndicator {
00163     typedef TextIndicator Base;
00164
00165     public:
00166         CenteredTextIndicator() {};
00167         CenteredTextIndicator(const WString& text);
00169         virtual ~CenteredTextIndicator();
00170
00172         virtual Size GetSize() const;
00173 };
00174
00175
00177 class IconTextIndicator : public Indicator {
00178     typedef Indicator Base;
00179
00180     public:
00184
00185         IconTextIndicator(){m_ind_text = L""; m_icon = 0;};
00187         IconTextIndicator(const WString& text, const BitmapRes* icon = 0);
00189         virtual ~IconTextIndicator();
00190
00193         void SetText (const WString& text) { m_ind_text = text; }
00194
00195         // Returns the size of the indicator.
00196         virtual Size GetSize() const;
00197
00199         const WString& GetText() const { return m_ind_text; }
00200
00203         void SetIcon (const BitmapRes* icon) { m_icon = icon; }
00204
00206         const BitmapRes* GetIcon() const { return m_icon; }
00207
00209         virtual void Draw(DeviceContext* dc, Point pos, Rect draw_rect);
00210
00211     private:
00212         WString m_ind_text;
00213         const BitmapRes* m_icon;
00214
00215 };
00216
00218 class ValueIndicator : public Indicator {
00219     typedef Indicator Base;
00220
00221     public:
00222
00224         ValueIndicator(IndicatorPosition pos, IndicatorAlignment align);
00225
00227         ValueIndicator();
00229         virtual ~ValueIndicator();
00230
00232         INT GetMaximumValue() const { return m_max; }
00234         INT GetMinimumValue() const { return m_min; }
00236         INT GetValue() const { return m_value; }
00238         virtual INT GetStep() const;
00241         void SetRange(INT min, INT max);
00246         void SetValue(INT value);
00247
00248     private:
00249         INT m_value;
00250         INT m_min;
00251         INT m_max;
00252 };
00253
00255 struct IconValueIndicator : public ValueIndicator {
00256     typedef ValueIndicator Base;
00257     typedef const BitmapRes* BitmapResArray;
00258
00259     public:
00260
00262         IconValueIndicator(const BitmapResArray* icons = 0, UINT8 icon_count = 0, IndicatorPosition pos = 0, IndicatorAlignment align = Left);
00263
00264
00266 //      IconValueIndicator(const BitmapResArray* icons = 0, UINT8 icon_count = 0); HAS TO BE REACTIVATED
00268         virtual ~IconValueIndicator();
00269
00271         virtual Size GetSize() const;
00272
00274         virtual INT GetStep() const;
00275
00277         virtual const BitmapRes* GetIcon() const;
00278
00283         void SetIcons(const BitmapResArray* icons, UINT8 icon_count);
00284
00286         virtual void Draw(DeviceContext* dc, Point pos, Rect draw_rect);
00287
00288     private:
00289         UINT8 m_icon_count;
00290         const BitmapResArray* m_icons;
00291 };
00292
00294 #endif  // Atl_Gui_Indicator_hpp
00295
00296
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorBar.cpp File Reference

Compat/IndicatorBar.cpp File Reference

#include "PreComp.hpp"
#include <Gui/PaintDc.hpp>
#include <Atl/AtlMsgTypes.hpp>
#include <Config/IdeaIndicatorConfig.hpp>
#include <Kernel/System.hpp>
#include "IndicatorBar.hpp"

Include dependency graph for IndicatorBar.cpp:

Generated on Tue Jan 24 20:21:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorBar.hpp File Reference

Compat/IndicatorBar.hpp File Reference

#include <Gui/DrawableObject.hpp>
#include <Gui/Desktop.hpp>
#include <Auxiliary/Vector.hpp>
#include <Atl/Gui/Indicator.hpp>
#include <Auxiliary/Observer.hpp>
#include "IndicatorBarID.hpp"

Include dependency graph for IndicatorBar.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IndicatorBar
class | IndicatorBarView

Defines

#define | Mmi_IndicatorBar_hpp

Define Documentation

#define Mmi_IndicatorBar_hpp

Generated on Tue Jan 24 17:59:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorBar.hpp Source File

Compat/IndicatorBar.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_IndicatorBar_hpp)
00010 #define Mmi_IndicatorBar_hpp
00013
00014 #include <Gui/DrawableObject.hpp>
00015 #include <Gui/Desktop.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017 #include <Atl/Gui/Indicator.hpp>
00018 #include <Auxiliary/Observer.hpp>
00019
00020 #include "IndicatorBarID.hpp"
00021
00023 class IndicatorBarView : public View {
00024
00025     typedef View Base;
00026
00027 public:
00029     IndicatorBarView();
00030     virtual ~IndicatorBarView();
00031
00033     virtual void Draw(const Component &component,
00034         DeviceContext *dc,
00035         const Rect &repaint_rect) const;
00036
00038     enum IndicatorBarOrientation {
00039         horizontal = 0,
00040         vertical = 1
00041     };
00042
00043 private:
00044 };
00045
00048 class IndicatorBar : public Control, public Observer {
00049     typedef Control Base;
00050
00051     public:
00053         IndicatorBar();
00054
00056         virtual ~IndicatorBar();
00057
00059         void Init(const IndicatorBarID& id, Control *control, Desktop::SectionType section, BOOLEAN auto_draw = TRUE);
00060
00062         void AddIndicator(Indicator* indicator);
00063
00065         void RemoveIndicator(Indicator* indicator);
00066
00068         void RemoveAllIndicators();
00069
00071         virtual DrawableObjectView* GetView() const;
00072
00074         XYDIM GetIndicatorbarExpansion();
00075
00077         void SetIndicatorbarExpansion(XYDIM indicatorbar_expansion);
00078
00080         IndicatorBarView::IndicatorBarOrientation GetOrientation();
00081
00082         // Used for temporary workaround, should be removed when parent-switching works in APOXI
00083 /*      void AddToControl(Control* parent);
00084         void RemoveFromControl(Control* parent);*/
00085
00087         const IndicatorBarID &GetId() { return m_indicator_bar_id; };
00088
00090         Desktop::SectionType GetSection() const { return m_section; };
00091
00093         BOOLEAN IsEmpty() const { return m_indicators.IsEmpty(); };
00094
00095     protected:
00096         virtual void OnUpdate(ObservableObject *obs_obj);
00097         virtual BOOLEAN OnMessage(const Message &msg);
00098
00099     private:
00100         friend class IndicatorBarView;
00101         Vector<Indicator*> m_indicators;
00102
00103         IndicatorBarID     m_indicator_bar_id;
00104         Desktop::SectionType    m_section;
00105         IndicatorBarView::IndicatorBarOrientation m_orientation;
00106 };
00107
00108
00110 #endif  // Mmi_IndicatorBar_hpp
00111
00112
Generated on Tue Jan 24 14:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorBarID.hpp File Reference

Compat/IndicatorBarID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for IndicatorBarID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Atl_Gui_IndicatorBarID_hpp

Typedefs

typedef ResourceID | IndicatorBarID

Define Documentation

#define Atl_Gui_IndicatorBarID_hpp

Typedef Documentation

typedef ResourceID IndicatorBarID

Generated on Tue Jan 24 17:59:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorBarID.hpp Source File

Compat/IndicatorBarID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Atl_Gui_IndicatorBarID_hpp)
00011 #define Atl_Gui_IndicatorBarID_hpp
00012
00013 #include <Atl/ResourceID.hpp>
00014
00015 typedef ResourceID IndicatorBarID;
00016
00017 #endif
00018
00019
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorDescription.cpp File Reference

Compat/IndicatorDescription.cpp File Reference

#include "PreComp.hpp"
#include "IndicatorDescription.hpp"

Include dependency graph for IndicatorDescription.cpp:

Generated on Tue Jan 24 20:21:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorDescription.hpp File Reference

Compat/IndicatorDescription.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Point.hpp>
#include <Atl/Gui/IndicatorID.hpp>
#include <Atl/Gui/IndicatorBarID.hpp>

Include dependency graph for IndicatorDescription.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IndicatorDescription
class | IndicatorLocation

Defines

#define | Atl_Gui_Indicator_Description_hpp

Define Documentation

#define Atl_Gui_Indicator_Description_hpp

Generated on Tue Jan 24 17:59:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorDescription.hpp Source File

Compat/IndicatorDescription.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_Gui_Indicator_Description_hpp)
00010 #define Atl_Gui_Indicator_Description_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 #include <Gui/Point.hpp>
00017 #include <Atl/Gui/IndicatorID.hpp>
00018 #include <Atl/Gui/IndicatorBarID.hpp>
00019
00020
00029 class IndicatorLocation {
00030     public:
00032         enum Alignment {
00033             Start = 0,  // order must not be changed
00034             Middle = 1,
00035             End = 2
00036         };
00037
00038         IndicatorLocation();
00039
00040         IndicatorLocation(const IndicatorBarID& barId, Alignment align, INT pos);
00041
00042         IndicatorLocation(const Point& glass_pane_pos);
00043
00044         ~IndicatorLocation();
00045
00047         void SetIndicatorBarId(const IndicatorBarID& barId) { m_bar_id = barId; }
00048
00050         const IndicatorBarID& GetIndicatorBarId() const { return m_bar_id; }
00051
00053         void SetAlignment(Alignment align) { m_align = align; }
00054
00056         Alignment GetAlignment() const { return m_align; }
00057
00059         void SetIndicatorBarPosition(INT pos) { m_pos = pos; }
00060
00062         INT GetIndicatorBarPosition() const { return m_pos; }
00063
00065         void SetGlassPanePosition(const Point& pos) { m_glass_pane_pos = pos; }
00066
00068         const Point& GetGlassPanePosition() const   { return m_glass_pane_pos; }
00069
00071         BOOLEAN DisplayOnGlassPane() const { return m_display_on_glasspane; }
00072
00073         private:
00074             Alignment       m_align;
00075             INT             m_pos;
00076             IndicatorBarID  m_bar_id;
00077             Point           m_glass_pane_pos;
00078             BOOLEAN         m_display_on_glasspane;
00079 };
00080
00081
00082 class IndicatorDescription {
00083 public:
00085         IndicatorDescription();
00086
00088         IndicatorDescription(const IndicatorID& id, const IndicatorLocation& pos);
00089
00091         ~IndicatorDescription();
00092
00094         void Init(const IndicatorID& id, const IndicatorLocation& pos);
00095
00097         void SetIndicatorLocation(const IndicatorLocation& pos) { m_pos = pos; }
00098
00100         const IndicatorLocation& GetIndicatorLocation() const   { return m_pos; }
00101
00103         void SetIndicatorId(const IndicatorID& id) { m_id = id; }
00104
00106         const IndicatorID& GetIndicatorId() const { return m_id; }
00107
00108         private:
00109             IndicatorID         m_id;
00110             IndicatorLocation   m_pos;
00111
00112 };
00113
00115 #endif  // Atl_Gui_Indicator_Description_hpp
00116
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorID.hpp File Reference

Compat/IndicatorID.hpp File Reference

#include <Atl/ResourceID.hpp>

Include dependency graph for IndicatorID.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Atl_Gui_IndicatorID_hpp

Typedefs

typedef ResourceID | IndicatorID

Define Documentation

#define Atl_Gui_IndicatorID_hpp

Generated on Tue Jan 24 17:59:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorID.hpp Source File

Compat/IndicatorID.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Atl_Gui_IndicatorID_hpp)
00011 #define Atl_Gui_IndicatorID_hpp
00014
00015
00016 #include <Atl/ResourceID.hpp>
00017
00018 typedef ResourceID  IndicatorID;
00019
00020 #endif /* Atl_Gui_IndicatorID_hpp */
00021
00022
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorPaneObject.cpp File Reference

Compat/IndicatorPaneObject.cpp File Reference

#include "PreComp.hpp"
#include "IndicatorPaneObject.hpp"
#include <Gui/Desktop.hpp>

Include dependency graph for IndicatorPaneObject.cpp:

Generated on Tue Jan 24 20:21:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorPaneObject.hpp File Reference

Compat/IndicatorPaneObject.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/GlassPane.hpp>
#include <Atl/Gui/Indicator.hpp>
#include <Atl/Gui/IndicatorBar.hpp>

Include dependency graph for IndicatorPaneObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IndicatorBarPaneObject
class | IndicatorPaneObject

Defines

#define | Atl_Gui_IndicatorPaneObject_hpp

Define Documentation

#define Atl_Gui_IndicatorPaneObject_hpp

Generated on Tue Jan 24 17:59:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/IndicatorPaneObject.hpp Source File

Compat/IndicatorPaneObject.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Atl_Gui_IndicatorPaneObject_hpp)
00010 #define Atl_Gui_IndicatorPaneObject_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Gui/PaintDc.hpp>
00016 #include <Gui/GlassPane.hpp>
00017 #include <Atl/Gui/Indicator.hpp>
00018 #include <Atl/Gui/IndicatorBar.hpp>
00019
00020 class IndicatorPaneObject : public Observer,
00021                             public PaneObject {
00022
00023     typedef PaneObject Base;
00024
00025     public:
00026
00028         IndicatorPaneObject();
00029
00031         virtual ~IndicatorPaneObject();
00032
00034         void Init(Indicator* indicator, const Rect& bounding_rect = Rect());
00035
00037         virtual void OnUpdate (ObservableObject *obs_obj);
00038
00040         virtual void Draw(DeviceContext* dc);
00041
00042     private:
00043
00044         Indicator* m_indicator;
00045
00046 };
00047
00048
00049 class IndicatorBarPaneObject : public PaneObject {
00050
00051     typedef PaneObject Base;
00052
00053     public:
00054
00056         IndicatorBarPaneObject();
00057
00059         virtual ~IndicatorBarPaneObject();
00060
00062         void Init(IndicatorBar* indicator_bar, const Rect& bounding_rect = Rect());
00063
00065         virtual void Draw(DeviceContext* dc);
00066
00067     private:
00068
00069         IndicatorBar* m_indicator_bar;
00070
00071 };
00073 #endif  // Atl_Gui_IndicatorPaneObject_hpp
00074
00075
Generated on Tue Jan 24 14:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/InputStream.cpp File Reference

Compat/InputStream.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "InputStream.hpp"

Include dependency graph for InputStream.cpp:

Generated on Tue Jan 24 20:21:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/InputStream.hpp File Reference

Compat/InputStream.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for InputStream.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InputStream

Defines

#define | Apoxi_InputStream_hpp

Define Documentation

#define Apoxi_InputStream_hpp

Generated on Tue Jan 24 20:21:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/InputStream.hpp Source File

Compat/InputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_InputStream_hpp)
00010 #define Apoxi_InputStream_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 #ifndef APOXI_NOSTREAMING
00017
00019 class InputStream{
00020     public:
00022         InputStream();
00023
00025         virtual ~InputStream();
00026
00028         virtual INT Read(BYTE& data) = 0;
00029
00031         virtual INT Read(BYTE* data, INT len);
00032
00034         virtual INT Read(BYTE* data, INT offset, INT len);
00035
00037         virtual InputStream& operator >> (char& c);
00038
00040         virtual InputStream& operator >> (unsigned char& c);
00041
00043         virtual InputStream& operator >> (signed char& c);
00044
00046         virtual InputStream& operator >> (char* s);
00047
00049         virtual InputStream& operator >> (unsigned char* s);
00050
00052         virtual InputStream& operator >> (signed char* s);
00053
00055         virtual InputStream& operator >> (const wchar_t* w);
00056
00057         #if defined(APOXI_RTOS_NUC16) | defined(APOXI_RTOS_SIM166)
00058
00059         virtual InputStream& operator >> (const WCHAR& w);
00060         #endif
00061
00063         virtual InputStream& operator >> (short& n);
00064
00066         virtual InputStream& operator >> (unsigned short& n);
00067
00069         virtual InputStream& operator >> (int& n);
00070
00072         virtual InputStream& operator >> (unsigned int& n);
00073
00075         virtual InputStream& operator >> (long& n);
00076
00078         virtual InputStream& operator >> (unsigned long& n);
00079
00081         virtual UINT32 Available() = 0;
00082 };
00083
00084 #endif
00085
00087 #endif // Apoxi_InputStream_hpp
00088
00089
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Lib.hpp File Reference

Compat/Lib.hpp File Reference

#include <Compat/AbstractEditBox.hpp>
#include <Compat/DateEditBox.hpp>
#include <Compat/EditBox.hpp>
#include <Compat/Grid.hpp>
#include <Compat/MenuItem.hpp>
#include <Compat/MenuList.hpp>
#include <Compat/MenuWindow.hpp>
#include <Compat/ResourceManager.hpp>
#include <Compat/TimeEditBox.hpp>
#include <Compat/WinMenuItem.hpp>
#include <Compat/WinRect.hpp>
#include <Compat/AbstractMenuList.hpp>
#include <Compat/CheckBox.hpp>
#include <Compat/CheckBoxList.hpp>
#include <Compat/CheckBoxItem.hpp>
#include <Compat/RadioButton.hpp>
#include <Compat/RadioButtonList.hpp>
#include <Compat/RadioButtonItem.hpp>

Include dependency graph for Lib.hpp:

Go to the source code of this file.

Defines

#define Compat_Lib_hpp

Define Documentation

#define Compat_Lib_hpp

Generated on Tue Jan 24 14:54:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Lib.hpp Source File

Compat/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Compat_Lib_hpp)
00010 #define Compat_Lib_hpp
00011
00012 #include <Compat/AbstractEditBox.hpp>
00013 #include <Compat/DateEditBox.hpp>
00014 #include <Compat/EditBox.hpp>
00015 #include <Compat/Grid.hpp>
00016 #include <Compat/MenuItem.hpp>
00017 #include <Compat/MenuList.hpp>
00018 #include <Compat/MenuWindow.hpp>
00019 #include <Compat/ResourceManager.hpp>
00020 #include <Compat/TimeEditBox.hpp>
00021 #include <Compat/WinMenuItem.hpp>
00022 #include <Compat/WinRect.hpp>
00023 #include <Compat/AbstractMenuList.hpp>
00024 #include <Compat/CheckBox.hpp>
00025 #include <Compat/CheckBoxList.hpp>
00026 #include <Compat/CheckBoxItem.hpp>
00027 #include <Compat/RadioButton.hpp>
00028 #include <Compat/RadioButtonList.hpp>
00029 #include <Compat/RadioButtonItem.hpp>
00030
00031 #endif  // Compat_Lib_hpp
00032
00033
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Melody.cpp File Reference

Compat/Melody.cpp File Reference

#include "PreComp.hpp"
#include "Melody.hpp"

Include dependency graph for Melody.cpp:

Generated on Tue Jan 24 20:21:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Melody.hpp File Reference

Compat/Melody.hpp File Reference

#include <Devices/Device.hpp>
#include <AddOns/MultiMedia/Sound.hpp>

Include dependency graph for Melody.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Melody

Defines

#define | MultiMedia_Melody_hpp

Define Documentation

#define MultiMedia_Melody_hpp

Generated on Tue Jan 24 16:43:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Melody.hpp Source File

Compat/Melody.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(MultiMedia_Melody_hpp)
00011 #define MultiMedia_Melody_hpp
00014
00015 #include <Devices/Device.hpp>
00016 #include <AddOns/MultiMedia/Sound.hpp>
00017
00021 class Melody : public Sound
00022 {
00023     typedef Sound Base;
00024     public:
00026         Melody(BOOLEAN copyrighted = FALSE);
00027
00029         virtual ~Melody();
00030
00032         void Init(BOOLEAN copyrighted = FALSE);
00033
00035         virtual const WCHAR* GetName() const;
00036
00038         virtual BOOLEAN Play(AudioContext* context);
00039
00041         virtual Audio::ToneData* GetToneData();
00042
00044         virtual void SetCopyright(BOOLEAN state);
00045
00047         virtual BOOLEAN IsCopyrighted() const;
00048
00049     protected:
00051         void SetName(const WCHAR* name) { m_name = name; }
00052
00053     private:
00054         BOOLEAN m_copyrighted;
00055         WString m_name;
00056 };
00057
00059 #endif // MultiMedia_Melody_hpp
00060
00061
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Menu.cpp File Reference

Compat/Menu.cpp File Reference

#include "PreComp.hpp"
#include "Menu.hpp"
#include "MenuAccessor.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/ScrollBehavior.hpp>

Include dependency graph for Menu.cpp:

Generated on Tue Jan 24 20:21:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Menu.hpp File Reference

Compat/Menu.hpp File Reference

#include <Gui/View.hpp>
#include <Gui/AbstractGrid.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for Menu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Menu
class | MenuView

Defines

#define | Apoxi_Menu_hpp

Define Documentation

#define Apoxi_Menu_hpp

Generated on Tue Jan 24 20:21:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Menu.hpp Source File

Compat/Menu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Menu_hpp)
00011 #define Apoxi_Menu_hpp
00015
00016 #include <Gui/View.hpp>
00017 #include <Gui/AbstractGrid.hpp>
00018 #include <Kernel/Os/Os.hpp>
00019
00021 class MenuView : public View {
00022     typedef View Base;
00023
00024     public:
00026         MenuView();
00028         virtual ~MenuView();
00029
00031         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00032
00034         BOOLEAN IsBackgrDrawingEnabled() const { return m_backgr_drawing; }
00035
00036     private:
00037         mutable BOOLEAN m_backgr_drawing;
00038 };
00039
00040
00041 class AbstractMenuAccessor;
00042
00045 class Menu : public AbstractGrid {
00046     typedef AbstractGrid Base;
00047
00048     public:
00050         Menu();
00052         virtual ~Menu();
00053
00056         void Init(Control* parent, AbstractMenuAccessor* menu_accessor);
00057
00059         AbstractMenuAccessor* GetMenuAccessor() const { return m_menu_accessor; }   //lint !e1763
00060
00070         virtual void ChangeMenuAccessor(AbstractMenuAccessor* accessor, BOOLEAN is_sub_accessor = FALSE);
00071
00073         virtual INT GetCellCount() const;
00074
00076         virtual INT GetColumnCount() const;
00077
00079         virtual XYDIM GetCellWidth() const;
00080
00082         virtual XYDIM GetCellHeight() const;
00083
00089         virtual void Trigger(INT index = -1);
00090
00092         virtual void Back();
00093
00097         void UpdateItemCount();
00098
00099     protected:
00101         virtual void Refresh(const Rect& rect);
00102
00104         virtual void Cleanup();
00105
00107         virtual BOOLEAN OnMessage(const Message& msg);
00108
00110         virtual void OnLanguageChanged();
00111
00113         virtual void OnSelectionChanged();
00114
00116         virtual void OnTrigger();
00117
00119         virtual void OnBack();
00120
00121     private:
00122         INT m_item_count;
00123         AbstractMenuAccessor* m_menu_accessor;
00124
00125         static MenuView m_menu_view;
00126 };
00127
00129 #endif  // Apoxi_Menu_hpp
00130
00131
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuAccessor.cpp File Reference

Compat/MenuAccessor.cpp File Reference

#include "PreComp.hpp"
#include "MenuAccessor.hpp"
#include "Menu.hpp"
#include <Gui/TextLine.hpp>
#include <Gui/AnimatedTextLine.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/Window.hpp>
#include <Gui/Locale.hpp>
#include <Kernel/System.hpp>

Include dependency graph for MenuAccessor.cpp:

Generated on Tue Jan 24 20:21:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuAccessor.hpp File Reference

Compat/MenuAccessor.hpp File Reference

#include <Gui/AbstractMenuAccessor.hpp>

Include dependency graph for MenuAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuAccessor

Defines

#define | Apoxi_MenuAccessor_hpp

Define Documentation

#define Apoxi_MenuAccessor_hpp

Generated on Tue Jan 24 20:21:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuAccessor.hpp Source File

Compat/MenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MenuAccessor_hpp)
00011 #define Apoxi_MenuAccessor_hpp
00014
00015 #include <Gui/AbstractMenuAccessor.hpp>
00016
00017 class TextLine;
00018 class AnimatedTextLine;
00019 class Menu;
00020 struct BitmapRes;
00021
00036 class MenuAccessor : public AbstractMenuAccessor {
00037     typedef AbstractMenuAccessor Base;
00038
00039     public:
00041         MenuAccessor();
00042
00044         MenuAccessor(INT columns, INT selected_idx = 0);
00045
00047         MenuAccessor(const WCHAR* title);
00048
00050         virtual ~MenuAccessor();
00051
00054         void Init(INT columns = 1, INT selected_idx = 0);
00055
00057         void Init(const WCHAR* title);
00058
00060         void SetColumnCount(INT columns) { m_columns = (INT8)columns; }
00061
00063         virtual INT GetColumnCount() const;
00064
00067         void SetItemHeight(XYDIM item_height) { m_item_height = (INT8)item_height; }
00068
00071         virtual XYDIM GetItemHeight() const;
00072
00074         virtual BOOLEAN IsRoot();
00075
00077         void SetSelectedIndex(INT selected_idx);
00078
00080         INT GetSelectedIndex() const { return m_selected_idx; }
00081
00085         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00086
00090         virtual const BitmapRes* GetItemIcon(BOOLEAN highlighted);
00091
00093         void SetTitle(const WCHAR* title);
00094
00096         const WCHAR* GetTitle() const { return m_title; }
00097
00102         virtual void Draw(DeviceContext* dc, const Rect& draw_rect, BOOLEAN highlighted);
00103
00105         virtual void Trigger(Menu* menu);
00106
00108         virtual void Back(Menu* menu);
00109
00110     protected:
00112         virtual BOOLEAN OnMessage(const Message& msg);
00113
00115         virtual void OnActivate(Menu* menu, AbstractMenuAccessor* parent_accessor);
00116
00118         virtual void OnDeactivate(Menu* menu);
00119
00121         virtual AbstractMenuAccessor* GetParent() const;
00122
00125         virtual AbstractMenuAccessor* GetChild();
00126
00129         virtual void OnTrigger(INT selected_idx);
00130
00132         virtual void OnSelectionChanged(INT selected_idx);
00133
00135         virtual void OnLanguageChanged();
00136
00137     private:
00138         INT m_selected_idx;
00139         INT m_first_visible_idx;
00140         INT8 m_columns;
00141         INT8 m_item_height;
00142         AbstractMenuAccessor* m_parent_accessor;
00143         const WCHAR* m_title;
00144         TextLine* m_text_line;
00145         AnimatedTextLine* m_anim_text_line;
00146 };
00147
00149 #endif  // Apoxi_MenuAccessor_hpp
00150
00151
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuItem.cpp File Reference

Compat/MenuItem.cpp File Reference

#include "PreComp.hpp"
#include "MenuItem.hpp"
#include "MenuList.hpp"

Include dependency graph for MenuItem.cpp:

Generated on Tue Jan 24 20:21:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuItem.hpp File Reference

Compat/MenuItem.hpp File Reference

#include <Gui/Action.hpp>
#include <Auxiliary/Linkable.hpp>

Include dependency graph for MenuItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuItem

Defines

#define | Apoxi_MenuItem_hpp

Define Documentation

#define Apoxi_MenuItem_hpp

Generated on Tue Jan 24 20:21:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuItem.hpp Source File

Compat/MenuItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MenuItem_hpp)
00010 #define Apoxi_MenuItem_hpp
00011
00012 #include <Gui/Action.hpp>
00013 #include <Auxiliary/Linkable.hpp>
00014
00017 class MenuItem : public Linkable<MenuItem> {
00018     public:
00021         MenuItem();
00022
00024         MenuItem(Action *action);
00025
00027         void Init(Action *action);
00028
00030         void SetAction(Action *action) { m_action = action; }
00031
00033         Action* GetAction() const { return m_action; }
00034
00035     private:
00036         Action *m_action;
00037 };
00038
00039
00040 #endif  // Apoxi_MenuItem_hpp
00041
00042
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuList.cpp File Reference

Compat/MenuList.cpp File Reference

#include "PreComp.hpp"
#include "MenuList.hpp"
#include <Gui/Window.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Kernel/System.hpp>
#include <Gui/Locale.hpp>

Include dependency graph for MenuList.cpp:

Generated on Tue Jan 24 20:21:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuList.hpp File Reference

Compat/MenuList.hpp File Reference

#include <Auxiliary/LinkedList.hpp>
#include <Gui/Lib.hpp>
#include <Gui/AbstractListBox.hpp>
#include <Gui/AbstractMenuList.hpp>
#include <Compat/MenuItem.hpp>

Include dependency graph for MenuList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuList
Obsolete - use Menu and MenuAccessor from Gui instead. More...
class | MenuListView

Defines

#define | Apoxi_MenuList_hpp

Typedefs

typedef AbstractMenuListModel<
MenuItem > 		MenuListModel

Define Documentation

#define Apoxi_MenuList_hpp

Typedef Documentation

typedef AbstractMenuListModel<MenuItem> MenuListModel

Generated on Tue Jan 24 20:21:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuList.hpp Source File

Compat/MenuList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MenuList_hpp)
00010 #define Apoxi_MenuList_hpp
00011
00012 #include <Auxiliary/LinkedList.hpp>
00013 #include <Gui/Lib.hpp>
00014 #include <Gui/AbstractListBox.hpp>
00015 #include <Gui/AbstractMenuList.hpp>
00016 #include <Compat/MenuItem.hpp>
00017
00018
00019 typedef AbstractMenuListModel<MenuItem> MenuListModel;
00020
00022 class MenuListView : public AbstractListBoxView {
00023     typedef AbstractListBoxView Base;
00024
00025     public:
00027         MenuListView();
00029         MenuListView(XYDIM item_height);
00030
00032         virtual ~MenuListView();
00033
00035         virtual void DrawItem(const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const;
00036
00037     protected:
00039         virtual void DrawMenuItem(const MenuItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const;
00040 };
00041
00043 class MenuList : public AbstractMenuList {
00044     typedef AbstractMenuList Base;
00045
00046     public:
00049         MenuList();
00050
00052         MenuList(Window *parent);
00053
00054         virtual ~MenuList();
00055
00057         void Init(Window *parent);
00058
00062         void AddItem(MenuItem *item, MenuItem *after = 0);
00063
00065         void AddItem(MenuItem *item, Action *action) const;
00066
00068         void RemoveItem(MenuItem *item);
00069
00071         void RemoveAllItems() const;
00072
00074         MenuItem* GetFirstItem() const;
00075
00076     protected:
00078         virtual Model* CreateModel() const;
00079
00081         virtual void Refresh(const Rect &rect);
00082
00084         virtual void OnItemSelected();
00085
00087         virtual void OnLanguageChanged();
00088
00090         virtual void OnThemeChanged();
00091
00092     private:
00093         static MenuListView m_view;
00094
00095         MenuListModel* GetMyModel() const { return (MenuListModel *)GetModel(); }
00096         void AdjustThemeDependencies();
00097 };
00098
00099 #endif  // Apoxi_MenuList_hpp
00100
00101
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuTextIterator.hpp File Reference

Compat/MenuTextIterator.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuTextIterator

Defines

#define | Apoxi_MenuTextIterator_hpp

Define Documentation

#define Apoxi_MenuTextIterator_hpp

Generated on Tue Jan 24 20:21:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuTextIterator.hpp Source File

Compat/MenuTextIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MenuTextIterator_hpp)
00011 #define Apoxi_MenuTextIterator_hpp
00014
00015
00019 class MenuTextIterator {
00020     public:
00022         virtual INT ItemCount() const = 0;
00023
00025         virtual const WCHAR* operator()(INT idx) const = 0;
00026 };
00027
00029 #endif  // Apoxi_MenuTextIterator_hpp
00030
00031
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuTextPtrArrayIterator.cpp File Reference

Compat/MenuTextPtrArrayIterator.cpp File Reference

#include "PreComp.hpp"
#include "MenuTextPtrArrayIterator.hpp"

Include dependency graph for MenuTextPtrArrayIterator.cpp:

Generated on Tue Jan 24 20:21:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuTextPtrArrayIterator.hpp File Reference

Compat/MenuTextPtrArrayIterator.hpp File Reference

#include "MenuTextIterator.hpp"

Include dependency graph for MenuTextPtrArrayIterator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuTextPtrArrayIterator

Defines

#define | Apoxi_MenuTextPtrArrayIterator_hpp

Define Documentation

#define Apoxi_MenuTextPtrArrayIterator_hpp

Generated on Tue Jan 24 20:21:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuTextPtrArrayIterator.hpp Source File

Compat/MenuTextPtrArrayIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MenuTextPtrArrayIterator_hpp)
00011 #define Apoxi_MenuTextPtrArrayIterator_hpp
00014
00015 #include "MenuTextIterator.hpp"
00016
00022 class MenuTextPtrArrayIterator : public MenuTextIterator {
00023     public:
00025         MenuTextPtrArrayIterator(INT item_count = 0, const WCHAR* *menu_text = 0);
00026
00028         void Init(INT item_count, const WCHAR* *menu_text);
00029
00031         virtual INT ItemCount() const;
00032
00034         virtual const WCHAR* operator()(INT idx) const;
00035
00036     private:
00037         INT m_item_count;
00038         const WCHAR* *m_menu_text;
00039 };
00040
00042 #endif  // Apoxi_MenuTextPtrArrayIterator_hpp
00043
00044
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuWindow.cpp File Reference

Compat/MenuWindow.cpp File Reference

#include "PreComp.hpp"
#include "MenuWindow.hpp"

Include dependency graph for MenuWindow.cpp:

Generated on Tue Jan 24 20:21:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuWindow.hpp File Reference

Compat/MenuWindow.hpp File Reference

#include <Gui/Window.hpp>

Include dependency graph for MenuWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MenuWindow

Defines

#define | Apoxi_MenuWindow_hpp

Define Documentation

#define Apoxi_MenuWindow_hpp

Generated on Tue Jan 24 20:21:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MenuWindow.hpp Source File

Compat/MenuWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_MenuWindow_hpp)
00011 #define Apoxi_MenuWindow_hpp
00012
00013 #include <Gui/Window.hpp>
00014
00015 class AbstractMenuList;
00016
00019 class MenuWindow : public Window {
00020     typedef Window Base;
00021
00022     public:
00023         MenuWindow();
00024
00025         virtual ~MenuWindow();
00026
00027     protected:
00029         virtual BOOLEAN OnCancel();
00030 };
00031
00032
00033 #endif  // Apoxi_MenuWindow_hpp
00034
00035
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MidiSound.cpp File Reference

Compat/MidiSound.cpp File Reference

#include "PreComp.hpp"
#include "MidiSound.hpp"

Include dependency graph for MidiSound.cpp:

Generated on Tue Jan 24 20:21:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MidiSound.hpp File Reference

Compat/MidiSound.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <AddOns/MultiMedia/Melody.hpp>

Include dependency graph for MidiSound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MidiSound

Defines

#define | MultiMedia_MidiSound_hpp

Define Documentation

#define MultiMedia_MidiSound_hpp

Generated on Tue Jan 24 16:43:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/MidiSound.hpp Source File

Compat/MidiSound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(MultiMedia_MidiSound_hpp)
00011 #define MultiMedia_MidiSound_hpp
00014
00015 #include <Auxiliary/BinData.hpp>
00016 #include <AddOns/MultiMedia/Melody.hpp>
00017
00021 class MidiSound : public Melody {
00022     typedef Melody Base;
00023
00024     public:
00025         enum {
00026             ID = 3
00027         };
00028
00031         MidiSound();
00032
00039         explicit MidiSound(BinData* bin_data);
00040
00042         virtual ~MidiSound();
00043
00050         void Init(BinData* bin_data);
00051
00053         virtual INT GetId() const;
00054
00056         virtual const BinData* GetBinData() const;
00057
00058     private:
00059         BinData* m_bin_data;
00060 };
00061
00063 #endif // MultiMedia_MidiSound_hpp
00064
00065
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRam.cpp File Reference

Compat/NvRam.cpp File Reference

#include "PreComp.hpp"
#include "NvRam.hpp"
#include <stdio.h>
#include <stdlib.h>

Include dependency graph for NvRam.cpp:

Defines

#define | NVRAM_IN_FILE

Functions

INT | GetNvRamSize ()
void * | GetNvRamStartAddress ()
CHAR * | NvRamGetWin32FilePath ()
FILE * | NvRamOpenEmuFile (CHAR *mode)
void | NvRamRead (void *addr, void *data, INT len)
void | NvRamWrite (void *addr, void *data, INT len)

Define Documentation

#define NVRAM_IN_FILE

Function Documentation

INT GetNvRamSize ( )

void* GetNvRamStartAddress ( )

CHAR * NvRamGetWin32FilePath ( )

static FILE * NvRamOpenEmuFile ( CHAR * mode )

void NvRamRead | ( | void * | addr,
 |  | void * | data,
 |  | INT | len
 | ) |

void NvRamWrite | ( | void * | addr,
 |  | void * | data,
 |  | INT | len
 | ) |

Generated on Tue Jan 24 20:21:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRam.hpp File Reference

Compat/NvRam.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_AdcExtensions_NvRam_hpp

Functions

INT | GetNvRamSize ()
void * | GetNvRamStartAddress ()
void | NvRamRead (void *addr, void *data, INT len)
void | NvRamWrite (void *addr, void *data, INT len)

Define Documentation

#define Apoxi_AdcExtensions_NvRam_hpp

Function Documentation

INT GetNvRamSize ( )

void* GetNvRamStartAddress ( )

void NvRamRead | ( | void * | addr,
 |  | void * | data,
 |  | INT | len
 | ) |

void NvRamWrite | ( | void * | addr,
 |  | void * | data,
 |  | INT | len
 | ) |

Generated on Tue Jan 24 16:21:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRam.hpp Source File

Compat/NvRam.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AdcExtensions_NvRam_hpp)
00009 #define Apoxi_AdcExtensions_NvRam_hpp
00010
00011 /* Read from Nv-Ram starting from addr len bytes and store it into data */
00012 void NvRamRead(void *addr, void *data, INT len);
00013
00014 /* Write len bytes data into Nv-Ram starting at addr */
00015 void NvRamWrite(void *addr, void *data, INT len);
00016
00017 /* Return starting address of Nv-Ram */
00018 void *GetNvRamStartAddress();
00019
00020 /* Return size of Nv-Ram */
00021 INT GetNvRamSize();
00022
00023 #endif //Apoxi_AdcExtensions_NvRam_hpp
00024
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRamDataRecordHandler.cpp File Reference

Compat/NvRamDataRecordHandler.cpp File Reference

#include "PreComp.hpp"
#include "NvRamStorage.hpp"
#include "NvRamDataRecordHandler.hpp"

Include dependency graph for NvRamDataRecordHandler.cpp:

Generated on Tue Jan 24 20:21:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRamDataRecordHandler.hpp File Reference

Compat/NvRamDataRecordHandler.hpp File Reference

#include <AddOns/AdcExtensions/DataRecordHandler.hpp>

Include dependency graph for NvRamDataRecordHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NvRamDataRecordHandler

Defines

#define | Apoxi_AdcExtensions_NvRamDataRecordHandler_hpp

Define Documentation

#define Apoxi_AdcExtensions_NvRamDataRecordHandler_hpp

Generated on Tue Jan 24 16:21:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRamDataRecordHandler.hpp Source File

Compat/NvRamDataRecordHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AdcExtensions_NvRamDataRecordHandler_hpp)
00009 #define Apoxi_AdcExtensions_NvRamDataRecordHandler_hpp
00010
00011 #include <AddOns/AdcExtensions/DataRecordHandler.hpp>
00012
00013 class NvRamStorage;
00014
00015 class NvRamDataRecordHandler : public DataRecordHandler {
00016     typedef DataRecordHandler Base;
00017     public:
00018         NvRamDataRecordHandler(const INT record_length, DataRecord &record);
00019         void Init();
00020
00021         virtual BOOLEAN LoadRecord(INT row, DataRecord *rec);
00022         virtual BOOLEAN StoreRecord(INT row, const DataRecord *rec);
00023         virtual BOOLEAN AddRecord(const DataRecord *rec);
00024         virtual BOOLEAN DeleteRecord(INT row);
00025
00026     private:
00027         virtual BOOLEAN DoesRecordExist(INT row);
00028
00029         DataRecord &m_record;
00030         NvRamStorage *m_nv_ram;
00031 };
00032
00033
00034 #endif  // Apoxi_AdcExtensions_NvRamDataRecordHandler_hpp
00035
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRamStorage.cpp File Reference

Compat/NvRamStorage.cpp File Reference

#include "PreComp.hpp"
#include "NvRamStorage.hpp"
#include "NvRam.hpp"

Include dependency graph for NvRamStorage.cpp:

Generated on Tue Jan 24 20:21:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRamStorage.hpp File Reference

Compat/NvRamStorage.hpp File Reference

#include <AddOns/AdcExtensions/DataRecord.hpp>

Include dependency graph for NvRamStorage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | NvRamBlockInfo
class | NvRamStorage

Defines

#define | Apoxi_AdcExtensions_NvRamStorage_hpp

Define Documentation

#define Apoxi_AdcExtensions_NvRamStorage_hpp

Generated on Tue Jan 24 16:21:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/NvRamStorage.hpp Source File

Compat/NvRamStorage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AdcExtensions_NvRamStorage_hpp)
00009 #define Apoxi_AdcExtensions_NvRamStorage_hpp
00010
00011 #include <AddOns/AdcExtensions/DataRecord.hpp>
00012
00013 struct NvRamBlockInfo {
00014         DataRecordId id;
00015         INT size;
00016         INT array_size;
00017 };
00018
00019 class NvRamStorage {
00020     public:
00021         static NvRamStorage *GetStorage();
00022         static void SetNvRamStorageInfo(const NvRamBlockInfo *info) { m_info = info; }
00023         BOOLEAN Read(DataRecord *record, INT idx = 0);
00024         BOOLEAN Store(const DataRecord *record, INT idx = 0);
00025         BOOLEAN GetBlockInfo(DataRecordId block_id, NvRamBlockInfo &info);
00026
00027     private:
00028         NvRamStorage();
00029         static void Init();
00030         static BOOLEAN IsInitialized();
00031         static INT GetBlockOffset(DataRecordId block_id, INT idx);
00032
00033         static const NvRamBlockInfo *m_info;
00034         static CHAR* m_start_address;
00035         static INT m_size;
00036         static NvRamStorage m_storage;
00037 };
00038
00039 #endif // Apoxi_AdcExtensions_NvRamStorage_hpp
00040
Generated on Tue Jan 24 14:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/OutputStream.cpp File Reference

Compat/OutputStream.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "OutputStream.hpp"

Include dependency graph for OutputStream.cpp:

Generated on Tue Jan 24 20:21:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/OutputStream.hpp File Reference

Compat/OutputStream.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for OutputStream.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | OutputStream

Defines

#define | Apoxi_OutputStream_hpp

Define Documentation

#define Apoxi_OutputStream_hpp

Generated on Tue Jan 24 20:21:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/OutputStream.hpp Source File

Compat/OutputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_OutputStream_hpp)
00010 #define Apoxi_OutputStream_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 #ifndef APOXI_NOSTREAMING
00017
00018 class OutputStream{
00019     public:
00020         OutputStream();
00021         virtual ~OutputStream();
00022
00023         // output
00024         virtual INT Write (const BYTE data) = 0;
00025         virtual INT Write (const BYTE* data, INT len);
00026         virtual INT Write (const BYTE* data, INT offset, INT len);
00027
00028         virtual OutputStream& operator << (const char c);
00029         virtual OutputStream& operator << (const unsigned char c);
00030         virtual OutputStream& operator << (const signed char c);
00031
00032         virtual OutputStream& operator << (const char* s);
00033         virtual OutputStream& operator << (const unsigned char* s);
00034         virtual OutputStream& operator << (const signed char* s);
00035
00036         virtual OutputStream& operator << (const wchar_t* w);
00037
00038         virtual OutputStream& operator << (const short n);
00039         virtual OutputStream& operator << (const unsigned short n);
00040
00041         virtual OutputStream& operator << (const int n);
00042         virtual OutputStream& operator << (const unsigned int n);
00043
00044         virtual OutputStream& operator << (const long n);
00045         virtual OutputStream& operator << (const unsigned long n);
00046
00047         virtual void Flush();
00048 };
00049
00050 #endif
00051
00053 #endif // Apoxi_OutputStream_hpp
00054
00055
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/PreComp.cpp File Reference

Compat/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:04:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/PreComp.hpp File Reference

Compat/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Kernel/Timer.hpp>
#include <Gui/Locale.hpp>
#include <Gui/ClientDc.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/Bitmap.hpp>
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/PreComp.hpp Source File

Compat/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Timer.hpp>
00012 #include <Gui/Locale.hpp>
00013 #include <Gui/ClientDc.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/MsgTypes.hpp>
00016 #include <Gui/MsgTypes.hpp>
00017 #include <Gui/Bitmap.hpp>
00018 #include <Kernel/ExecutionContext.hpp>
00019
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/PreparedSound.cpp File Reference

Compat/PreparedSound.cpp File Reference

#include "PreComp.hpp"
#include "PreparedSound.hpp"

Include dependency graph for PreparedSound.cpp:

Generated on Tue Jan 24 20:21:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/PreparedSound.hpp File Reference

Compat/PreparedSound.hpp File Reference

#include <Devices/Device.hpp>
#include <AddOns/MultiMedia/Sound.hpp>

Include dependency graph for PreparedSound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PreparedSound

Defines

#define | MultiMedia_PreparedSound_hpp

Define Documentation

#define MultiMedia_PreparedSound_hpp

Generated on Tue Jan 24 16:43:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/PreparedSound.hpp Source File

Compat/PreparedSound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(MultiMedia_PreparedSound_hpp)
00011 #define MultiMedia_PreparedSound_hpp
00014
00015 #include <Devices/Device.hpp>
00016 #include <AddOns/MultiMedia/Sound.hpp>
00017
00021 class PreparedSound : public Sound {
00022     typedef Sound Base;
00023     public:
00025         enum {
00026             ID = 1
00027         };
00028
00031         PreparedSound();
00032
00034         PreparedSound(const WCHAR* name);
00035
00037         virtual ~PreparedSound();
00038
00040         void Init(const WCHAR* name);
00041
00043         void SetToneId(Audio::AudioToneId tone_id) { m_tone_id = tone_id; }
00044
00046         Audio::AudioToneId GetToneId() const { return m_tone_id; }
00047
00049         void SetRepeatCount(INT times) { m_times = times; }
00050
00052         INT GetRepeatCount() const { return m_times; }
00053
00055         virtual INT GetId() const;
00056
00059         void SetName(const WCHAR* name) { m_name = name; }
00060
00062         virtual const WCHAR* GetName() const;
00063
00065         virtual BOOLEAN Play(AudioContext* context);
00066
00067     private:
00068         Audio::AudioToneId  m_tone_id;
00069         INT                 m_times;
00070         const WCHAR         *m_name;
00071 };
00072
00074 #endif // MultiMedia_PreparedSound_hpp
00075
00076
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ProviderListBox.cpp File Reference

Compat/ProviderListBox.cpp File Reference

#include "PreComp.hpp"
#include "ProviderListBox.hpp"
#include <Auxiliary/Provider.hpp>
#include <Gui/PaintDc.hpp>
#include <Kernel/System.hpp>

Include dependency graph for ProviderListBox.cpp:

Generated on Tue Jan 24 20:21:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ProviderListBox.hpp File Reference

Compat/ProviderListBox.hpp File Reference

#include <Gui/AbstractListBox.hpp>
#include <Auxiliary/DataItem.hpp>

Include dependency graph for ProviderListBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ProviderListBox
Abstract ListBox, which shows a WString row of a provider. More...
class | ProviderListBoxModel
Describes the model of a ProviderListBox. More...
class | ProviderListBoxView
Describes the view of a ProviderListBox. More...

Defines

#define | Apoxi_ProviderListBox_hpp

Define Documentation

#define Apoxi_ProviderListBox_hpp

Generated on Tue Jan 24 20:22:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ProviderListBox.hpp Source File

Compat/ProviderListBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ProviderListBox_hpp)
00010 #define Apoxi_ProviderListBox_hpp
00011
00012 #include <Gui/AbstractListBox.hpp>
00013 #include <Auxiliary/DataItem.hpp>
00014
00015
00017 class ProviderListBoxModel : public AbstractListBoxModel {
00018     typedef AbstractListBoxModel Base;
00019
00020     public:
00022         ProviderListBoxModel();
00024         ProviderListBoxModel(Provider *provider, INT col_id);
00025
00027         void Init(Provider *provider, INT col_id);
00028
00030         virtual ~ProviderListBoxModel();
00031
00033         virtual BOOLEAN GetProviderEntry(INT col_id, INT row, DataItem &item)const;
00034
00036         virtual void SetProvider(Provider *provider);
00037
00039         virtual Provider* GetProvider() const { return m_provider; }
00040
00042         virtual void UpdateNoOfItems();
00043
00045         virtual void SetColId(INT col_id);
00046
00048         virtual INT GetColId() const;
00049
00050     private:
00051         INT m_col_id;
00052         Provider *m_provider;
00053 };
00054
00056 class ProviderListBoxView : public AbstractListBoxView {
00057     typedef AbstractListBoxView Base;
00058     public:
00060         ProviderListBoxView();
00062         ProviderListBoxView(XYDIM item_height);
00063
00065         virtual ~ProviderListBoxView();
00066
00068         virtual void DrawItem(const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const;
00069 };
00070
00071
00073 class ProviderListBox : public AbstractListBox {
00074     typedef AbstractListBox Base;
00075
00076     public:
00079         ProviderListBox();
00080
00082         ProviderListBox(Control *parent, Provider *provider, INT col_id);
00083
00085         virtual ~ProviderListBox();
00086
00088         void Init(Control *parent, Provider *provider, INT col_id);
00089
00091         virtual void Update();
00092
00093     protected:
00095         virtual Model* CreateModel() const;
00096
00097     private:
00098         ProviderListBoxView m_view;
00099         ProviderListBoxModel* GetMyModel() const { return (ProviderListBoxModel *)GetModel(); }
00100 };
00101
00102 #endif  // Apoxi_ProviderListBox_hpp
00103
00104
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RadioButton.cpp File Reference

Compat/RadioButton.cpp File Reference

#include "PreComp.hpp"
#include "RadioButton.hpp"
#include <Kernel/MsgTypes.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>

Include dependency graph for RadioButton.cpp:

Generated on Tue Jan 24 20:22:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RadioButton.hpp File Reference

Compat/RadioButton.hpp File Reference

#include <Gui/Control.hpp>
#include <Gui/Model.hpp>
#include <Gui/View.hpp>

Include dependency graph for RadioButton.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RadioButtonModel
class | RadioButtonView

Defines

#define | Apoxi_RadioButton_hpp

Define Documentation

#define Apoxi_RadioButton_hpp

Generated on Tue Jan 24 20:22:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RadioButton.hpp Source File

Compat/RadioButton.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_RadioButton_hpp)
00011 #define Apoxi_RadioButton_hpp
00012
00013 #include <Gui/Control.hpp>
00014 #include <Gui/Model.hpp>
00015 #include <Gui/View.hpp>
00016
00017
00018 class RadioButtonView;
00019
00021 class RadioButtonModel : public Model {
00022     public:
00023         typedef Model Base;
00024
00025         // Constructor of the radiobutton-model.
00026         RadioButtonModel(const WCHAR *caption = 0, BOOLEAN state = 0) :
00027             m_caption(caption), m_state(state)  {};
00028
00029         //
00030         void SetCaption(const WCHAR *caption) { m_caption = caption; };
00031
00032         //
00033         const WCHAR* GetCaption() const { return m_caption; };
00034
00035         //
00036         void SetState(BOOLEAN state) { m_state = state; };
00037
00038         //
00039         BOOLEAN GetState() const { return m_state; };
00040
00041     private:
00042         const WCHAR     *m_caption;
00043         BOOLEAN         m_state;
00044 };
00045
00047 class RadioButtonView : public View {
00048     typedef View Base;
00049
00050     public:
00051         RadioButtonView();
00052         // Constructor of the radiobutton-view.
00053         RadioButtonView(XYDIM item_height,
00054                                XYDIM left_gap,
00055                                XYDIM middle_gap) :
00056                     Base(-1, item_height),
00057                     m_item_height(item_height),
00058                     m_left_gap(left_gap),
00059                     m_middle_gap(middle_gap) {};
00060
00061         virtual ~RadioButtonView() {}
00062
00063         //
00064         void SetItemHeight(XYDIM item_height) { m_item_height = item_height; };
00065
00066         //
00067         XYDIM GetItemHeight() { return m_item_height; };
00068
00069         //
00070         void SetLeftGap(XYDIM left_gap) { m_left_gap = left_gap; };
00071
00072         //
00073         XYDIM GetLeftGap() const { return m_left_gap; };
00074
00075         //
00076         void SetMiddleGap(XYDIM middle_gap) { m_middle_gap = middle_gap; };
00077
00078         //
00079         XYDIM GetMiddleGap() const { return m_middle_gap; };
00080
00082         virtual void Draw(const Component &component, DeviceContext *dc, const Rect &repaint_rect) const;
00083
00085         virtual void DrawShifted(const Rect &shift_rect, const Model &abstract_model, DeviceContext *dc,  const Rect &repaint_rect) const;
00086
00087     protected:
00089         virtual void DrawRadioButton(const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const = 0;
00090
00092         virtual void DrawShiftedRadioButton(const Rect &shift_rect, const RadioButtonModel &abstract_model, DeviceContext *dc,  const Rect &repaint_rect) const = 0;
00093
00094     private:
00095         XYDIM m_item_height;
00096         XYDIM m_left_gap;
00097         XYDIM m_middle_gap;
00098 };
00099
00100
00101 #endif  // Apoxi_RadioButton_hpp
00102
00103
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RadioButtonItem.hpp File Reference

Compat/RadioButtonItem.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RadioButtonItem
class | TRadioButtonItem< Content >

Defines

#define | Apoxi_RadioButtonItem_hpp

Define Documentation

#define Apoxi_RadioButtonItem_hpp

Generated on Tue Jan 24 20:22:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RadioButtonItem.hpp Source File

Compat/RadioButtonItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_RadioButtonItem_hpp)
00010 #define Apoxi_RadioButtonItem_hpp
00011
00012
00015 class RadioButtonItem : public Linkable<RadioButtonItem> {
00016     public:
00017         RadioButtonItem(const WCHAR *text = 0, BOOLEAN pressed = FALSE) :
00018             m_text(text), m_pressed(pressed) {}
00019
00020         // Sets the text of the item.
00021         void SetText(const WCHAR *text) { m_text = text; };
00022
00023         // Returns the text of the item.
00024         const WCHAR* GetText() const { return m_text; };
00025
00026         // Sets the selection of the item.
00027         void SetPressed(BOOLEAN pressed) { m_pressed = pressed; };
00028
00029         // Returns <b>TRUE</b>, if the checkbox is pressed.
00030         BOOLEAN IsPressed() const { return m_pressed; };
00031
00033         void SetValue(INT value) { m_value = value; }
00034
00036         INT GetValue() { return m_value; }
00037
00038     private:
00039         const WCHAR *m_text;
00040         BOOLEAN     m_pressed;
00041         INT         m_value;
00042 };
00043
00047 template<class Content> class TRadioButtonItem : public RadioButtonItem {
00048     public:
00049         typedef RadioButtonItem Base;
00050
00053         TRadioButtonItem() : Base(0, FALSE) {}
00054         TRadioButtonItem(const WCHAR *text) : Base(text, FALSE) {}
00055         TRadioButtonItem(const WCHAR *text, BOOLEAN pressed) : Base(text, pressed) {}
00056
00058         void SetContent(Content content) { m_content = content; }
00059
00061         Content GetContent() const { return m_content; }
00062
00063     private:
00064         Content m_content;
00065 };
00066
00067
00068 #endif  // Apoxi_RadioButtonItem_hpp
00069
00070
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RadioButtonList.cpp File Reference

Compat/RadioButtonList.cpp File Reference

#include "PreComp.hpp"
#include "RadioButtonList.hpp"
#include <Kernel/MsgTypes.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for RadioButtonList.cpp:

Generated on Tue Jan 24 20:22:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RadioButtonList.hpp File Reference

Compat/RadioButtonList.hpp File Reference

#include <Gui/AbstractListBox.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Gui/AbstractMenuList.hpp>
#include <Gui/RadioButtonItem.hpp>
#include <Gui/RadioButton.hpp>

Include dependency graph for RadioButtonList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RadioButtonList
class | RadioButtonListView
Describes the view of a RadioButtonList. More...
class | TRadioButtonList< Content >

Defines

#define | Apoxi_RadioButtonList_hpp

Typedefs

typedef AbstractMenuListModel<
RadioButtonItem > 		RadioButtonListModel

Define Documentation

#define Apoxi_RadioButtonList_hpp

Typedef Documentation

typedef AbstractMenuListModel<RadioButtonItem> RadioButtonListModel

Generated on Tue Jan 24 20:22:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RadioButtonList.hpp Source File

Compat/RadioButtonList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_RadioButtonList_hpp)
00010 #define Apoxi_RadioButtonList_hpp
00011
00012 #include <Gui/AbstractListBox.hpp>
00013 #include <Auxiliary/LinkedList.hpp>
00014 #include <Gui/AbstractMenuList.hpp>
00015 #include <Gui/RadioButtonItem.hpp>
00016 #include <Gui/RadioButton.hpp>
00017
00018
00019 typedef AbstractMenuListModel<RadioButtonItem> RadioButtonListModel;
00020
00023 class RadioButtonList : public AbstractMenuList {
00024     typedef AbstractMenuList Base;
00025
00026     public:
00029         RadioButtonList();
00030
00032         RadioButtonList(Control *parent);
00033
00034         virtual ~RadioButtonList();
00035
00037         void Init(Control *parent);
00038
00040         void AddItem(RadioButtonItem *item, RadioButtonItem *after = 0);
00041
00043         void AddItem(RadioButtonItem *item, const WCHAR *text, INT value, BOOLEAN pressed = FALSE) const;
00044
00046         void RemoveItem(RadioButtonItem *item);
00047
00049         void RemoveAllItems() const;
00050
00052         void SetPressedItem(RadioButtonItem *item);
00053
00055         void SetPressedItem(INT value);
00056
00060         RadioButtonItem* GetPressedItem(INT *index = 0) const;
00061
00063         RadioButtonItem* GetFirstItem() const;
00064
00065     protected:
00067         virtual Model* CreateModel() const;
00068
00070         virtual void Refresh(const Rect &rect);
00071
00073         virtual BOOLEAN OnSoftkeyPressed(INT idx);
00074
00076         virtual BOOLEAN OnSoftkeyReleased(INT idx);
00077
00079         virtual void OnThemeChanged();
00080
00082         virtual void OnLanguageChanged();
00083
00086         virtual void OnItemSelected();
00087
00088     private:
00089         BOOLEAN m_item_selected;
00090
00091         RadioButtonListModel* GetMyModel() const {return (RadioButtonListModel *)GetModel(); }
00092 };
00093
00096 template<class Content> class TRadioButtonList : public RadioButtonList {
00097     typedef RadioButtonList Base;
00098
00099     public:
00101         void AddItem(TRadioButtonItem<Content> *item, const WCHAR *text, Content content, BOOLEAN pressed = FALSE);
00102
00104         void SetPressedItem(TRadioButtonItem<Content> *item) {  Base::SetPressedItem(item); }
00105
00107         void SetPressedItem(Content content);
00108
00110         TRadioButtonItem<Content>* GetFirstItem() const { return (TRadioButtonItem<Content>*)Base::GetFirstItem(); }
00111
00113         TRadioButtonItem<Content>* GetPressedItem() const { return (TRadioButtonItem<Content>*)Base::GetPressedItem(); }
00114
00115     private:
00116         RadioButtonListModel* GetMyModel() const { return (RadioButtonListModel *)GetModel(); }
00117 };
00118
00120 class RadioButtonListView : public AbstractListBoxView {
00121     typedef AbstractListBoxView Base;
00122
00123     public:
00124         RadioButtonListView();
00125         // Constructor of the view.
00126         RadioButtonListView(const RadioButtonView *view, XYDIM item_height);
00127
00129         virtual ~RadioButtonListView();
00130
00132         virtual void DrawItem(const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const;
00133
00134     protected:
00135         const RadioButtonView *m_view;
00136
00138         virtual void DrawRadioButtonItem(const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const = 0;
00139
00140 };
00141
00142 /*  ------------------------------------------------------------------------
00143                             Template implementation
00144     ------------------------------------------------------------------------ */
00145
00146 /*  ------------------------------------------------------------------------
00147     AddItem
00148     ------------------------------------------------------------------------ */
00149 template<class Content> void TRadioButtonList<Content>::AddItem(TRadioButtonItem<Content> *item,
00150                                                                 const WCHAR *text, Content content,
00151                                                                 BOOLEAN pressed)
00152 {
00153     Base::AddItem(item, text, 0, pressed);
00154     item->SetContent(content);
00155 }   // AddItem
00156
00157 /*  ------------------------------------------------------------------------
00158     SetPressedItem
00159     ------------------------------------------------------------------------ */
00160 template<class Content> void TRadioButtonList<Content>::SetPressedItem(Content content)
00161 {
00162     TRadioButtonItem<Content> *item = GetFirstItem();
00163     INT index = 0;
00164
00165     while (item != 0) {
00166         if (item->GetContent() == content) {
00167             item->SetPressed(TRUE);
00168             GetMyModel()->SetSelectedIndex(index);
00169             return;
00170         }
00171         item = (TRadioButtonItem<Content>*)item->GetNext();
00172         index++;
00173     }
00174
00175     ASSERT(FALSE);
00176 }   // SetPressedItem
00177
00178 #endif  // Apoxi_RadioButtonList_hpp
00179
00180
Generated on Tue Jan 24 14:49:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ResourceManager.cpp File Reference

Compat/ResourceManager.cpp File Reference

#include "PreComp.hpp"
#include "ResourceManager.hpp"
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>
#include <Config/LocaleConfig.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Gui/ColorTable.hpp>

Include dependency graph for ResourceManager.cpp:

Generated on Tue Jan 24 20:22:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ResourceManager.hpp File Reference

Compat/ResourceManager.hpp File Reference

#include <Kernel/InputMap.hpp>

Include dependency graph for ResourceManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ResourceManager
Obsolete (comments from methods describe the replacement). More...

Defines

#define | Apoxi_ResourceManager_hpp

Define Documentation

#define Apoxi_ResourceManager_hpp

Generated on Tue Jan 24 20:22:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/ResourceManager.hpp Source File

Compat/ResourceManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ResourceManager_hpp)
00010 #define Apoxi_ResourceManager_hpp
00011
00012 #include <Kernel/InputMap.hpp>
00013
00014 class Font;
00015 struct PagingMap;
00016 struct ColorTable;
00017
00019 class ResourceManager {
00020     public:
00022         const ColorTable& GetColorTable() const;
00023
00025         const InputMap& GetInputMap(MapItemType type) const;
00026
00028         const Font& GetFont(INT id) const;
00029
00031         const PagingMap& GetPagingMap(INT lang_id = -1) const;
00032 };
00033
00034 #endif  // Apoxi_ResourceManager_hpp
00035
00036
Generated on Tue Jan 24 14:49:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RtcHandler.cpp File Reference

Compat/RtcHandler.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for RtcHandler.cpp:

Generated on Tue Jan 24 20:22:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RtcHandler.hpp File Reference

Compat/RtcHandler.hpp File Reference

#include <Asc/BaseHandler.hpp>

Include dependency graph for RtcHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Asc_RtcHandler_hpp

Define Documentation

#define Asc_RtcHandler_hpp

Generated on Tue Jan 24 17:31:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/RtcHandler.hpp Source File

Compat/RtcHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_RtcHandler_hpp)
00009 #define Asc_RtcHandler_hpp
00010
00011 #include <Asc/BaseHandler.hpp>
00012
00013 /*  ========================================================================
00014     RtcHandler
00015     ======================================================================== */
00018 #ifdef APOXI_COMPAT_2_0_0
00019
00020 class RtcHandler : public BaseHandler {
00021     typedef BaseHandler Base;
00022     public:
00023         enum { ID = RtcHandlerId };
00024
00026         RtcHandler();
00028         virtual ~RtcHandler();
00029
00031         virtual HandlerId GetHandlerId() const;
00032 };
00033
00034 #endif  // APOXI_COMPAT_2_0_0
00035
00036 #endif // Asc_RtcHandler_hpp
00037
00038
Generated on Tue Jan 24 14:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SetLanguageAction.cpp File Reference

Compat/SetLanguageAction.cpp File Reference

#include "PreComp.hpp"
#include "SetLanguageAction.hpp"

Include dependency graph for SetLanguageAction.cpp:

Generated on Tue Jan 24 20:22:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SetLanguageAction.hpp File Reference

Compat/SetLanguageAction.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/Window.hpp>
#include <Kernel/MsgTypes.hpp>

Include dependency graph for SetLanguageAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SetLanguageAction

Defines

#define | Apoxi_SetLanguageAction_hpp

Define Documentation

#define Apoxi_SetLanguageAction_hpp

Generated on Tue Jan 24 20:22:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SetLanguageAction.hpp Source File

Compat/SetLanguageAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SetLanguageAction_hpp)
00010 #define Apoxi_SetLanguageAction_hpp
00013
00014 #include <Gui/Action.hpp>
00015 #include <Gui/Window.hpp>
00016 #include <Kernel/MsgTypes.hpp>
00017
00023 class SetLanguageAction : public Action {
00024     typedef Action Base;
00025
00026     public:
00029         SetLanguageAction();
00030
00032         SetLanguageAction(INT lang_id, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00033
00035         virtual ~SetLanguageAction();
00036
00038         void Init(INT lang_id,  const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00039
00042         virtual BOOLEAN Execute();
00043
00044     private:
00045         INT m_lang_id;
00046 };
00047
00049 #endif  // Apoxi_SetLanguageAction_hpp
00050
00051
Generated on Tue Jan 24 14:49:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SetThemeAction.cpp File Reference

Compat/SetThemeAction.cpp File Reference

#include "PreComp.hpp"
#include "SetThemeAction.hpp"

Include dependency graph for SetThemeAction.cpp:

Generated on Tue Jan 24 20:22:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SetThemeAction.hpp File Reference

Compat/SetThemeAction.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/Window.hpp>
#include <Kernel/MsgTypes.hpp>

Include dependency graph for SetThemeAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SetThemeAction

Defines

#define | Apoxi_SetThemeAction_hpp

Define Documentation

#define Apoxi_SetThemeAction_hpp

Generated on Tue Jan 24 20:22:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SetThemeAction.hpp Source File

Compat/SetThemeAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SetThemeAction_hpp)
00010 #define Apoxi_SetThemeAction_hpp
00013
00014 #include <Gui/Action.hpp>
00015 #include <Gui/Window.hpp>
00016 #include <Kernel/MsgTypes.hpp>
00017
00023 class SetThemeAction : public Action {
00024     typedef Action Base;
00025
00026     public:
00029         SetThemeAction();
00030
00032         SetThemeAction(INT theme_id, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00033
00035         virtual ~SetThemeAction();
00036
00038         void Init(INT theme_id, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00039
00042         virtual BOOLEAN Execute();
00043
00044     private:
00045         INT m_theme_id;
00046 };
00047
00049 #endif  // Apoxi_SetThemeAction_hpp
00050
00051
Generated on Tue Jan 24 14:49:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SharedTimer.cpp File Reference

Compat/SharedTimer.cpp File Reference

#include "PreComp.hpp"
#include "SharedTimer.hpp"

Include dependency graph for SharedTimer.cpp:

Generated on Tue Jan 24 20:22:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SharedTimer.hpp File Reference

Compat/SharedTimer.hpp File Reference

#include <Kernel/Timer.hpp>
#include <Kernel/UserDispatcher.hpp>

Include dependency graph for SharedTimer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SharedTimer
class | SharedTriggerTimer< T >

Defines

#define | Apoxi_SharedTimer_hpp

Define Documentation

#define Apoxi_SharedTimer_hpp

Generated on Tue Jan 24 20:22:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SharedTimer.hpp Source File

Compat/SharedTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SharedTimer_hpp)
00011 #define Apoxi_SharedTimer_hpp
00014
00015 #include <Kernel/Timer.hpp>
00016 #include <Kernel/UserDispatcher.hpp>
00017
00021 class SharedTimer : public Timer, public UserDispatcher {
00022     typedef Timer Base;
00023
00024     public:
00026         SharedTimer();
00028         SharedTimer(UINT32 timeout, BOOLEAN autotimer = FALSE);
00030         virtual ~SharedTimer();
00031
00033         void Init(UINT32 timeout, BOOLEAN autotimer = FALSE);
00034
00036         void Start();
00038         void Stop();
00040         void Resume();
00042         void Restart();
00043
00044     protected:
00046         virtual BOOLEAN OnMessage(const Message& msg);
00047
00048     private:
00049         enum MsgArg {
00050             TimerStart,
00051             TimerStop,
00052             TimerResume,
00053             TimerRestart
00054         };
00055 };
00056
00057 template <class T> class SharedTriggerTimer : public SharedTimer {
00058     typedef SharedTimer Base;
00059
00060     public:
00061         SharedTriggerTimer();
00062         SharedTriggerTimer(T* t, UINT32 timeout, BOOLEAN autotimer = FALSE);
00063         virtual ~SharedTriggerTimer();
00064
00065         void Init(T* t, UINT32 timeout, BOOLEAN autotimer = FALSE);
00066
00067     protected:
00068         virtual void OnTimer();
00069
00070     private:
00071         T   *m_t;
00072 };
00073
00074 /*  ------------------------------------------------------------------------
00075     TriggerTimer
00076     ------------------------------------------------------------------------ */
00077 template <class T>
00078 SharedTriggerTimer<T>::SharedTriggerTimer() :
00079     m_t(0)
00080 {
00081 }   // TriggerTimer
00082
00083 /*  ------------------------------------------------------------------------
00084     TriggerTimer
00085     ------------------------------------------------------------------------ */
00086 template <class T>
00087 SharedTriggerTimer<T>::SharedTriggerTimer(T* t, UINT32 timeout, BOOLEAN autotimer) :
00088     Base(timeout, autotimer),
00089     m_t(t)
00090 {
00091 }   // TriggerTimer
00092
00093 /*  ------------------------------------------------------------------------
00094     ~TriggerTimer
00095     ------------------------------------------------------------------------ */
00096 template <class T>
00097 SharedTriggerTimer<T>::~SharedTriggerTimer()
00098 {
00099     m_t = 0;
00100 }   // ~TriggerTimer
00101
00102 /*  ------------------------------------------------------------------------
00103     Init
00104     ------------------------------------------------------------------------ */
00105 template <class T>
00106 void SharedTriggerTimer<T>::Init(T* t, UINT32 timeout, BOOLEAN autotimer)
00107 {
00108     Base::Init(timeout, autotimer);
00109     m_t = t;
00110 }   // Init
00111
00112 /*  ------------------------------------------------------------------------
00113     OnTimer
00114     ------------------------------------------------------------------------ */
00115 template <class T>
00116 void SharedTriggerTimer<T>::OnTimer()
00117 {
00118     ASSERT_DEBUG(m_t != 0);
00119     m_t->OnTimer();
00120 }   // OnTimer
00121
00123 #endif  // Apoxi_SharedTimer_hpp
00124
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SmafSound.cpp File Reference

Compat/SmafSound.cpp File Reference

#include "PreComp.hpp"
#include "SmafSound.hpp"

Include dependency graph for SmafSound.cpp:

Generated on Tue Jan 24 20:22:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SmafSound.hpp File Reference

Compat/SmafSound.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <AddOns/MultiMedia/Melody.hpp>

Include dependency graph for SmafSound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmafSound

Defines

#define | MultiMedia_SmafSound_hpp

Define Documentation

#define MultiMedia_SmafSound_hpp

Generated on Tue Jan 24 16:43:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SmafSound.hpp Source File

Compat/SmafSound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(MultiMedia_SmafSound_hpp)
00011 #define MultiMedia_SmafSound_hpp
00014
00015 #include <Auxiliary/BinData.hpp>
00016 #include <AddOns/MultiMedia/Melody.hpp>
00017
00021 class SmafSound : public Melody {
00022     typedef Melody Base;
00023
00024     public:
00025         enum {
00026             ID = 2
00027         };
00028
00031         SmafSound();
00032
00039         explicit SmafSound(BinData* bin_data);
00040
00042         virtual ~SmafSound();
00043
00050         void Init(BinData* bin_data);
00051
00053         virtual INT GetId() const;
00054
00056         virtual const BinData* GetBinData() const;
00057
00058     private:
00059         BinData* m_bin_data;
00060 };
00061
00063 #endif // MultiMedia_SmafSound_hpp
00064
00065
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SoftkeyBar.cpp File Reference

Compat/SoftkeyBar.cpp File Reference

#include "PreComp.hpp"
#include "SoftkeyBar.hpp"
#include <Gui/Window.hpp>
#include <Kernel/Message.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Gui/Action.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>

Include dependency graph for SoftkeyBar.cpp:

Generated on Tue Jan 24 20:22:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SoftkeyBar.hpp File Reference

Compat/SoftkeyBar.hpp File Reference

#include <Gui/DrawableObject.hpp>

Include dependency graph for SoftkeyBar.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoftkeyBar
class | SoftkeyBarView
Describes the view of a Softkey-Bar. More...

Defines

#define | APOXI_MAX_SOFTKEY_COUNT 2
#define | Apoxi_SoftkeyBar_hpp

Define Documentation

#define Apoxi_SoftkeyBar_hpp

Generated on Tue Jan 24 20:22:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SoftkeyBar.hpp Source File

Compat/SoftkeyBar.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SoftkeyBar_hpp)
00010 #define Apoxi_SoftkeyBar_hpp
00013
00014 class Window;
00015 class Action;
00016 class Message;
00017
00018 #include <Gui/DrawableObject.hpp>
00019
00020 #if !defined(APOXI_MAX_SOFTKEY_COUNT)
00021 #define APOXI_MAX_SOFTKEY_COUNT 2
00022 #endif
00023
00032 class SoftkeyBar : public DrawableObject {
00033     typedef DrawableObject Base;
00034
00035     public:
00038         SoftkeyBar();
00039
00042         SoftkeyBar(Window* win);
00043
00045         virtual ~SoftkeyBar();
00046
00049         void Init(Window* win);
00050
00056         void Set(INT idx, Action* action);
00057
00061         Action* Get(INT idx) const;
00062
00067         void Trigger(INT idx) const;
00068
00072         void SetPressedIndex(INT pressed_idx);
00073
00075         INT GetPressedIndex() const { return m_pressed_idx; }
00076
00078         INT GetSoftkeyCount() const;
00079
00081         INT GetNoOfSoftkeys() const { return GetSoftkeyCount(); }
00082
00083     protected:
00085         virtual BOOLEAN OnMessage(const Message& msg);
00086
00088         virtual void OnThemeChanged();
00089
00091         virtual void OnLanguageChanged();
00092
00093     private:
00094         INT m_pressed_idx;
00095         Action* m_actions[APOXI_MAX_SOFTKEY_COUNT];
00096 };
00097
00099 class SoftkeyBarView : public DrawableObjectView {
00100     public:
00102         SoftkeyBarView();
00103
00105         virtual ~SoftkeyBarView();
00106
00108         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00109
00110     protected:
00115         virtual void DrawSoftkeyBar(const SoftkeyBar& softkey_bar, DeviceContext* dc, const Rect& repaint_rect) const = 0;
00116 };
00117
00119 #endif  // Apoxi_SoftkeyBar
00120
00121
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Sound.cpp File Reference

Compat/Sound.cpp File Reference

#include "PreComp.hpp"
#include "Sound.hpp"

Include dependency graph for Sound.cpp:

Generated on Tue Jan 24 20:22:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Sound.hpp File Reference

Compat/Sound.hpp File Reference

#include <Auxiliary/ObjectObtainer.hpp>
#include <AddOns/MultiMedia/AudioContext.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for Sound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Sound
class | SoundObtainer

Defines

#define | AddOns_MultiMedia_Sound_hpp

Define Documentation

#define AddOns_MultiMedia_Sound_hpp

Generated on Tue Jan 24 16:43:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Sound.hpp Source File

Compat/Sound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(AddOns_MultiMedia_Sound_hpp)
00011 #define AddOns_MultiMedia_Sound_hpp
00014
00015 #include <Auxiliary/ObjectObtainer.hpp>
00016 #include <AddOns/MultiMedia/AudioContext.hpp>
00017 #include <Auxiliary/BinData.hpp>
00018
00019 class Sound;
00020
00022 class SoundObtainer : public ObjectObtainer {
00023     typedef ObjectObtainer Base;
00024
00025     public:
00027         SoundObtainer();
00028
00030         SoundObtainer(Sound* sound, BOOLEAN disposable);
00031
00032         // needed because of a bug in the tasking-compiler
00033         SoundObtainer(const SoundObtainer& sound_obt) { *this = sound_obt; }
00034
00036         virtual ~SoundObtainer();
00037
00039         Sound* GetSound() { return (Sound*)GetObject(); }
00040
00042         const Sound* GetSound() const { return (Sound*)GetObject(); }
00043 };
00044
00051 class Sound : public ObtainableObject {
00052     typedef ObtainableObject Base;
00053
00054     public:
00056         Sound();
00057
00059         virtual ~Sound();
00060
00062         virtual INT GetId() const = 0;
00063
00065         virtual const WCHAR* GetName() const = 0;
00066
00069         virtual BOOLEAN Play(AudioContext* context) = 0;
00070
00072         virtual const BinData* GetBinData() const;
00073 };
00074
00076 #endif // AddOns_MultiMedia_Sound_hpp
00077
00078
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SoundItem.cpp File Reference

Compat/SoundItem.cpp File Reference

#include "PreComp.hpp"
#include "SoundItem.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for SoundItem.cpp:

Generated on Tue Jan 24 20:22:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SoundItem.hpp File Reference

Compat/SoundItem.hpp File Reference

#include <AddOns/MultiMedia/Sound.hpp>
#include <AddOns/MultiMedia/BoundedItem.hpp>

Include dependency graph for SoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoundItem

Defines

#define | Apoxi_SoundItem_hpp

Define Documentation

#define Apoxi_SoundItem_hpp

Generated on Tue Jan 24 16:43:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SoundItem.hpp Source File

Compat/SoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SoundItem_hpp)
00011 #define Apoxi_SoundItem_hpp
00014
00015 #include <AddOns/MultiMedia/Sound.hpp>
00016 #include <AddOns/MultiMedia/BoundedItem.hpp>
00017
00021 class SoundItem : public BoundedItem {
00022     typedef BoundedItem Base;
00023
00024     public:
00025         enum {
00026             ID = 5
00027         };
00028
00030         explicit SoundItem(const SoundObtainer& obtainer);
00031
00033         virtual ~SoundItem();
00034
00036         virtual INT GetId() const;
00037
00039         virtual XYDIM GetWidth() const;
00040
00042         virtual XYDIM GetHeight() const;
00043
00045         const SoundObtainer& GetSoundObtainer() const { return m_obtainer; }
00046
00048         const Sound* GetSound() const { return m_obtainer.GetSound(); }
00049
00051         virtual void Draw(DeviceContext* dc, const Rect& bounds) const;
00052
00054         virtual void Play(AudioContext* ac) const;
00055
00059         virtual AtomItem* Clone() const;
00060
00062         virtual BOOLEAN IsInstanceOf(INT id) const;
00063
00064     private:
00065         SoundObtainer m_obtainer;
00066 };
00067
00069 #endif  // Apoxi_SoundItem_hpp
00070
00071
Generated on Tue Jan 24 14:45:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsDispatcher.cpp File Reference

Compat/SsDispatcher.cpp File Reference

#include "PreComp.hpp"
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Asc/MainHandler.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Apc/Message.hpp>
#include "SsDispatcher.hpp"

Include dependency graph for SsDispatcher.cpp:

Generated on Tue Jan 24 20:22:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsDispatcher.hpp File Reference

Compat/SsDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Message.hpp>
#include <Asc/StackMsgDispatcher.hpp>

Include dependency graph for SsDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsDispatcher

Defines

#define | Asc_SsDispatcher_hpp

Define Documentation

#define Asc_SsDispatcher_hpp

Generated on Tue Jan 24 17:37:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsDispatcher.hpp Source File

Compat/SsDispatcher.hpp

Go to the documentation of this file.
00001           /*    ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SsDispatcher_hpp)
00009 #define Asc_SsDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/Message.hpp>
00015
00016 #include <Asc/StackMsgDispatcher.hpp>
00017
00018 /*  ========================================================================
00019     SimDispatcher
00020     ======================================================================== */
00022 class SsDispatcher : public StackMsgDispatcher {
00023     typedef StackMsgDispatcher Base;
00024     public:
00026         SsDispatcher();
00028         virtual ~SsDispatcher();
00029
00030     protected:
00032         BOOLEAN OnSsForwardingInd(const StackMsgArgument &arg);
00034         BOOLEAN OnSsBarringInd(const StackMsgArgument &arg);
00036         BOOLEAN OnSsDataInd(const StackMsgArgument &arg);
00038         BOOLEAN OnSsNotifyInd(const StackMsgArgument &arg);
00040         BOOLEAN OnSsInterrogateInd(const StackMsgArgument &arg);
00042         BOOLEAN OnSsPasswordInd(const StackMsgArgument &arg);
00044         BOOLEAN OnSsUnstructInd(const StackMsgArgument &arg);
00046         BOOLEAN OnSsForwcheckInd(const StackMsgArgument &arg);
00048         BOOLEAN OnSsRetResInd(const StackMsgArgument &arg);
00050         BOOLEAN OnSsFacilityRej(const StackMsgArgument &arg);
00051
00053         BOOLEAN OnSsEndInd(const StackMsgArgument &arg);
00055         BOOLEAN OnSsRej(const StackMsgArgument &arg);
00057         BOOLEAN OnSsErrInd(const StackMsgArgument &arg);
00059         BOOLEAN OnSsGetPasswordInd(const StackMsgArgument &arg);
00061         BOOLEAN OnSsGetPasswordRej(const StackMsgArgument &arg);
00062
00063         BOOLEAN OnSsUssdInd(const StackMsgArgument &arg);
00064
00065         BOOLEAN OnSsUssdResentInd(const StackMsgArgument &arg);
00067         BOOLEAN OnSsBeginAcc(const StackMsgArgument &arg);
00069         BOOLEAN OnSsCauseInd(const StackMsgArgument &arg);
00070 #if defined(APOXI_AT_MMI_INTERWORKING_SS)
00071
00072         BOOLEAN OnSsFacilityInd(const StackMsgArgument &arg);
00073 #endif
00074 #if defined(APOXI_AT_MMI_INTERWORKING_USSD)
00075
00076         BOOLEAN OnUssdAnswerInd(const StackMsgArgument &arg);
00077 #endif
00078     private:
00079         static const StackMsgArgMap<SsDispatcher> m_arg_map[];
00080         StackMsgArgMapContainer<SsDispatcher> m_arg_map_container;
00081
00082         void CheckReleaseComplete(BOOLEAN release_complete) const;
00083
00084 };
00085
00087 #endif // Asc_SimDispatcher_hpp
00088
00089
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsHandler.cpp File Reference

Compat/SsHandler.cpp File Reference

#include "PreComp.hpp"
#include <Asc/CallHandler.hpp>
#include <Asc/AdcInterface.hpp>
#include <Asc/CallHandlingData.hpp>
#include <Asc/MainHandler.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Apc/SsStackMsgArgs.hpp>
#include <Apc/Message.hpp>
#include "SsHandler.hpp"
#include "SsWaitDispatcher.hpp"

Include dependency graph for SsHandler.cpp:

Generated on Tue Jan 24 20:22:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsHandler.hpp File Reference

Compat/SsHandler.hpp File Reference

#include <Kernel/Types.hpp>
#include <Apc/TaggedProblemCode.hpp>
#include <Asc/BaseHandler.hpp>
#include <Asc/InputParser.hpp>
#include <Asc/SsDispatcher.hpp>
#include <Asc/SsWaitDispatcher.hpp>
#include <Apc/SsErrorCode.hpp>

Include dependency graph for SsHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsHandler

Defines

#define | Asc_SsHandler_hpp

Define Documentation

#define Asc_SsHandler_hpp

Generated on Tue Jan 24 17:37:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsHandler.hpp Source File

Compat/SsHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SsHandler_hpp)
00009 #define Asc_SsHandler_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Apc/TaggedProblemCode.hpp>
00016
00017 #include <Asc/BaseHandler.hpp>
00018 #include <Asc/InputParser.hpp>
00019
00020 #include <Asc/SsDispatcher.hpp>
00021 #include <Asc/SsWaitDispatcher.hpp>
00022 #include <Apc/SsErrorCode.hpp>
00023
00024 /*  ========================================================================
00025     SsHandler
00026     ======================================================================== */
00028 class SsHandler : public BaseHandler {
00029     typedef BaseHandler Base;
00030     public:
00031         enum { ID = SsHandlerId };
00032
00034         SsHandler();
00036         virtual ~SsHandler();
00037
00039         virtual HandlerId GetHandlerId() const;
00040
00051         SsApiRc SendControlString(const WString &code) const;
00052
00055         SsApiRc SendControlString(const WCHAR * code) const;
00056
00057
00063         SsApiRc TerminateSupplementaryService() const;
00064
00065
00074         SsApiRc SendPasswordResponse(const WString &password) const;
00075
00076
00083         SsApiRc SendDetectedError(const SsErrorCode::Code error_code) const;
00084
00085
00087         SsApiRc SendUssdReturnResult(SsOperationCode code, const WString &result) const;
00088
00089
00091         SsApiRc RejectUssdRequest(const TaggedProblemCode::ProblemCode code = TaggedProblemCode::ResourceLimitation) const;
00092
00099         BOOLEAN IsSsPending() const;
00100
00101
00104         SsApiRc GetClipStatus() const;
00105
00108         SsApiRc GetClirStatus() const;
00109
00112         SsApiRc GetColpStatus() const;
00113
00116         SsApiRc GetColrStatus() const;
00117
00122         SsApiRc ActivateCallWaiting(const InputParser::BasicServiceMmiCode bs = InputParser::AllServices) const;
00123
00129         SsApiRc DeactivateCallWaiting(const InputParser::BasicServiceMmiCode bs = InputParser::AllServices) const;
00130
00133         SsApiRc GetCallWaitingStatus() const;
00134
00135
00152         SsApiRc ActivateCallForwarding(
00153             const InputParser::SsCode code,
00154             const PhoneNumber & forward_to_no,
00155             const InputParser::BasicServiceMmiCode bs = InputParser::AllServices,
00156             const WString & time = L"") const;
00157
00163         SsApiRc DeactivateCallForwarding(
00164             const InputParser::SsCode code,
00165             const InputParser::BasicServiceMmiCode bs = InputParser::AllServices) const;
00166
00172         SsApiRc GetCallForwardingStatus(
00173             const InputParser::SsCode code,
00174             const InputParser::BasicServiceMmiCode bs = InputParser::AllServices) const;
00175
00176
00183         SsApiRc ActivateCallBarring(
00184             const InputParser::SsCode code,
00185             const WString & pw,
00186             const InputParser::BasicServiceMmiCode bs = InputParser::AllServices) const;
00187
00194         SsApiRc DeactivateCallBarring(
00195             const InputParser::SsCode code,
00196             const WString & pw,
00197             const InputParser::BasicServiceMmiCode bs = InputParser::AllServices) const;
00198
00203         SsApiRc GetCallBarringStatus(const InputParser::SsCode code) const;
00204
00205
00211         SsApiRc RegisterNewPw(const WString & old_pw, const WString & new_pw) const;
00212
00217         SsApiRc ChangePin(const WString & old_pin, const WString & new_pin) const;
00218
00223         SsApiRc ChangePin2(const WString & old_pin2, const WString & new_pin2) const;
00224
00225
00226         // Methods still available for compatibility reasons:
00227         inline SsApiRc InterrogateClip() const { return GetClipStatus(); }
00228         inline SsApiRc InterrogateClir() const { return GetClirStatus(); }
00229         inline SsApiRc InterrogateColp() const { return GetColpStatus(); }
00230         inline SsApiRc InterrogateColr() const { return GetColrStatus(); }
00231
00232         inline SsApiRc ActivateCallForwarding(
00233             const InputParser::SsCode code,
00234             const WString & forward_to_no,
00235             const InputParser::BasicServiceMmiCode bs = InputParser::AllServices) const
00236         { return ActivateCallForwarding(code, PhoneNumber(PhoneNumber::Out, forward_to_no), bs); }
00237
00238
00239     private:
00240         SsDispatcher m_ss_dispatcher; // main dispatcher for retrieving asynchronous messages
00241         BOOLEAN m_rejected;
00242 };
00243
00245 #endif // Asc_SsHandler_hpp
00246
00247
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsWaitDispatcher.cpp File Reference

Compat/SsWaitDispatcher.cpp File Reference

#include "PreComp.hpp"
#include <Asc/MocVoiceHandler.hpp>
#include "SsWaitDispatcher.hpp"
#include <Apc/SsStackMsgArgs.hpp>
#include <Apc/SimTkStackMsgArgs.hpp>
#include <Asc/MainHandler.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Asc/StackControl.hpp>

Include dependency graph for SsWaitDispatcher.cpp:

Generated on Tue Jan 24 20:22:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsWaitDispatcher.hpp File Reference

Compat/SsWaitDispatcher.hpp File Reference

#include <Kernel/Types.hpp>
#include <Asc/StackMsgActiveWaitDispatcher.hpp>

Include dependency graph for SsWaitDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SsWaitDispatcher

Defines

#define | Asc_SsWaitDispatcher_hpp

Define Documentation

#define Asc_SsWaitDispatcher_hpp

Generated on Tue Jan 24 17:37:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/SsWaitDispatcher.hpp Source File

Compat/SsWaitDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Asc_SsWaitDispatcher_hpp)
00009 #define Asc_SsWaitDispatcher_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 #include <Asc/StackMsgActiveWaitDispatcher.hpp>
00016
00017 /*  ========================================================================
00018     SsWaitDispatcher
00019     ======================================================================== */
00021 class SsWaitDispatcher : public StackMsgActiveWaitDispatcher {
00022     typedef StackMsgActiveWaitDispatcher Base;
00023     public:
00025         SsWaitDispatcher();
00027         virtual ~SsWaitDispatcher();
00028
00030         BOOLEAN WasRejected() { return m_rejected; }
00032         BOOLEAN WasChangedToMoc() { return m_changed_to_moc; }
00033
00034         Tipd GetTipd() { return m_tipd; }
00035         CallErrorCause GetCause() { return m_cause; }
00036
00037     protected:
00039         BOOLEAN OnSsBeginAcc(const StackMsgArgument &arg);
00041         BOOLEAN OnSsFacilityRej(const StackMsgArgument &arg);
00043         BOOLEAN OnCallControlIndMsg(const StackMsgArgument &arg);
00044
00045     private:
00046         static const StackMsgArgMap<SsWaitDispatcher> m_arg_map[];
00047         StackMsgArgMapContainer<SsWaitDispatcher> m_arg_map_container;
00048
00049         Tipd m_tipd;
00050         BOOLEAN m_rejected;
00051
00052         CallErrorCause m_cause;
00053
00054         BOOLEAN m_changed_to_moc;
00055 };
00056
00058 #endif  // Asc_SsWaitDispatcher_hpp
00059
00060
Generated on Tue Jan 24 14:46:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TextList.cpp File Reference

Compat/TextList.cpp File Reference

#include "PreComp.hpp"
#include "TextList.hpp"
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Gui/ClientDc.hpp>
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for TextList.cpp:

Generated on Tue Jan 24 20:22:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TextList.hpp File Reference

Compat/TextList.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/AbstractListBox.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for TextList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextList
class | TextListLine
class | TextListModel
Describes the model of a textlist. More...
class | TextListView
Describes the view of a textlist. More...

Defines

#define | Apoxi_TextList_hpp

Typedefs

typedef Vector< TextListLine > | TLLVector

Define Documentation

#define Apoxi_TextList_hpp

Generated on Tue Jan 24 20:22:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TextList.hpp Source File

Compat/TextList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TextList_hpp)
00010 #define Apoxi_TextList_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Gui/AbstractListBox.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017
00018 class TextListLine {
00019     public:
00020         TextListLine() :
00021                     m_start_index(0),
00022                     m_length(0) {};
00023
00024         void SetStartIndex(INT start_index) { m_start_index = start_index; };
00025         INT GetStartIndex() const { return m_start_index; };
00026
00027         void SetLength(INT length) { m_length = length; };
00028         INT GetLength() const { return m_length; };
00029
00030
00031     private:
00032         INT m_start_index;
00033         INT m_length;
00034 };
00035
00036 typedef Vector<TextListLine> TLLVector;
00037
00038
00040 class TextListModel : public AbstractListBoxModel {
00041     typedef AbstractListBoxModel Base;
00042
00043     public:
00044         TLLVector m_lines;
00045
00047         TextListModel();
00049         TextListModel(const WCHAR* text);
00050
00052         void SetText(const WCHAR* text) { m_text = text; };
00053
00055         const WCHAR* GetText() const { return m_text; };
00056
00057     private:
00058         const WCHAR *m_text;
00059 };
00060
00064 class TextList : public AbstractListBox {
00065     typedef AbstractListBox Base;
00066
00067     public:
00070         TextList();
00071
00074         TextList(Control* parent, const WCHAR* text);
00075
00077         virtual ~TextList();
00078
00081         void Init(Control* parent, const WCHAR* text);
00082
00084         void SetText(const WCHAR* text);
00085
00087         const WCHAR* GetText() const;
00088
00089     protected:
00091         virtual Model* CreateModel() const;
00092
00094         virtual void OnLayoutClient();
00095
00097         virtual void Refresh(const Rect& rect);
00098
00100         void Layout(XYDIM width);
00101
00103         virtual void OnPreviousItem();
00104
00106         virtual void OnNextItem();
00107
00109         virtual void OnThemeChanged();
00110
00111         void UpdateNavigationGuidance();
00112
00113     private:
00114         TextListModel* GetMyModel() const { return (TextListModel* )GetModel(); }
00115 };
00116
00118 class TextListView : public AbstractListBoxView {
00119     typedef AbstractListBoxView Base;
00120
00121     public:
00123         TextListView();
00125         TextListView(XYDIM item_height) :
00126                     AbstractListBoxView(item_height) {};
00127
00129         virtual ~TextListView();
00130
00132         virtual void DrawItem(const AbstractListBox& listbox, DeviceContext* dc, INT index, const Rect& item_rect) const;
00133
00134     protected:
00136         virtual void DrawTextListItem(const TextList& text_list, DeviceContext* dc, INT index, const Rect& item_rect) const = 0;
00137 };
00138
00140 #endif // Apoxi_TextList_hpp
00141
00142
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TextMenuAccessor.cpp File Reference

Compat/TextMenuAccessor.cpp File Reference

#include "PreComp.hpp"
#include "TextMenuAccessor.hpp"
#include "MenuTextIterator.hpp"
#include "Menu.hpp"
#include <Gui/MsgTypes.hpp>
#include <Gui/PaintDc.hpp>
#include <Kernel/Dispatcher.hpp>

Include dependency graph for TextMenuAccessor.cpp:

Generated on Tue Jan 24 20:22:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TextMenuAccessor.hpp File Reference

Compat/TextMenuAccessor.hpp File Reference

#include <Gui/AbstractMenuAccessor.hpp>
#include <Gui/MenuTextPtrArrayIterator.hpp>

Include dependency graph for TextMenuAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextMenuAccessor

Defines

#define | Apoxi_TextMenuAccessor_hpp

Define Documentation

#define Apoxi_TextMenuAccessor_hpp

Generated on Tue Jan 24 20:22:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TextMenuAccessor.hpp Source File

Compat/TextMenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TextMenuAccessor_hpp)
00011 #define Apoxi_TextMenuAccessor_hpp
00014
00015 #include <Gui/AbstractMenuAccessor.hpp>
00016 #include <Gui/MenuTextPtrArrayIterator.hpp>     // included for backward-compatibility for APOXI-versions < 1.6
00017
00018 class Dispatcher;
00019
00099 class TextMenuAccessor : public AbstractMenuAccessor {
00100     typedef AbstractMenuAccessor Base;
00101
00102     public:
00105         TextMenuAccessor();
00106
00114         TextMenuAccessor(Dispatcher* dispatcher, const MenuTextIterator* iterator);
00115
00117         virtual ~TextMenuAccessor();
00118
00126         void Init(Dispatcher* dispatcher, const MenuTextIterator* iterator);
00127
00129         virtual BOOLEAN First();
00130
00132         virtual BOOLEAN Next();
00133
00135         virtual XYDIM GetItemHeight() const;
00136
00138         virtual void Draw(DeviceContext* dc, const Rect& draw_rect, BOOLEAN highlighted);
00139
00141         virtual void Trigger(Menu* menu);
00142
00144         virtual void Back(Menu* menu);
00145
00151         TextMenuAccessor(const MenuTextIterator* iterator);
00152
00158         void Init(const MenuTextIterator* iterator);
00159
00160     private:
00161         INT m_idx;
00162         Dispatcher* m_dispatcher;
00163         const MenuTextIterator* m_iterator;
00164 };
00165
00167 #endif  // Apoxi_TextMenuAccessor_hpp
00168
00169
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TimeEditBox.cpp File Reference

Compat/TimeEditBox.cpp File Reference

#include "PreComp.hpp"
#include "TimeEditBox.hpp"
#include <Gui/PagingMap.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/Theme.hpp>
#include <Gui/Locale.hpp>

Include dependency graph for TimeEditBox.cpp:

Generated on Tue Jan 24 20:22:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TimeEditBox.hpp File Reference

Compat/TimeEditBox.hpp File Reference

#include <Gui/Lib.hpp>
#include <Kernel/Types.hpp>
#include <Auxiliary/Time.hpp>
#include <Compat/AbstractEditBox.hpp>

Include dependency graph for TimeEditBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TimeEditBox
Obsolete - use TimeEditor from Gui instead. More...
class | TimeEditBoxModel
Describes the model of a time editbox. More...
class | TimeEditBoxView
Describes the view of a time editbox. More...

Defines

#define | Apoxi_TimeEditBox_hpp

Define Documentation

#define Apoxi_TimeEditBox_hpp

Generated on Tue Jan 24 20:22:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TimeEditBox.hpp Source File

Compat/TimeEditBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TimeEditBox_hpp)
00010 #define Apoxi_TimeEditBox_hpp
00011
00012 #include <Gui/Lib.hpp>
00013 #include <Kernel/Types.hpp>
00014 #include <Auxiliary/Time.hpp>
00015 #include <Compat/AbstractEditBox.hpp>
00016
00018 class TimeEditBoxModel : public AbstractEditBoxModel {
00019 };
00020
00022 class TimeEditBoxView : public AbstractEditBoxView {
00023     typedef AbstractEditBoxView Base;
00024
00025     public:
00027         TimeEditBoxView();
00029         TimeEditBoxView(XYDIM line_height,
00030                         XYDIM caption_gap,
00031                         XYDIM caption_width,
00032                         XYDIM caption_height,
00033                         XYDIM frame_size,
00034                         XYDIM default_width = -1,
00035                         XYDIM default_height = -1);
00036
00038         virtual ~TimeEditBoxView();
00039
00041         virtual void Draw(const Component &component, DeviceContext *dc, const Rect &repaint_rect) const;
00042
00043     protected:
00049         virtual void DrawTimeEditBox(const TimeEditBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00050 };
00051
00053 class TimeEditBox : public AbstractEditBox {
00054     typedef AbstractEditBox Base;
00055
00056     public:
00059         TimeEditBox();
00060
00065         TimeEditBox(Control *parent,
00066                     Time::Format format = Time::TimeHM,
00067                     const WCHAR *caption = 0,
00068                     CaptionPos caption_pos = CaptionOnTop);
00069
00071         virtual ~TimeEditBox();
00072
00077         void Init(Control *parent,
00078                   Time::Format format = Time::TimeHM,
00079                   const WCHAR *caption = 0,
00080                   CaptionPos caption_pos = CaptionOnTop);
00081
00083         void SetFormat(Time::Format format);
00085         void SetFormat(const WCHAR *format);
00086
00088         const WCHAR* GetFormat() const { return m_format; }
00089
00091         void SetTime(const Time& time) const;
00092
00094         Time GetTime() const;
00095
00097         virtual BOOLEAN IsInputValid() const;
00098
00099     protected:
00101         virtual Model* CreateModel() const;
00102
00104         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00105
00107         virtual void OnDeleteChar();
00108
00110         virtual void MoveCursor(INT inc);
00111
00113         virtual const AbstractEditBoxView* GetView() const;
00114
00116         INT GetHour() const { return GetDigits(L'H'); }
00117
00119         INT GetMinute() const { return GetDigits(L'M'); }
00120
00122         INT GetSecond() const { return GetDigits(L'S'); }
00123
00124     private:
00125         const WCHAR         *m_format;
00126         WCHAR               m_buffer[10];
00127         static TimeEditBoxView m_view;
00128
00129         TimeEditBoxModel* GetMyModel() const { return (TimeEditBoxModel *)GetModel(); }
00130
00131         INT GetCharPos(WCHAR chr) const;
00132         INT GetDigits(WCHAR c) const;
00133         INT GetBufferSize() const { return sizeof(m_buffer) / sizeof(m_buffer[0]); }
00134 };
00135
00136
00137 #endif  // Apoxi_TimeEditBox_hpp
00138
00139
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TraceOutputStream.cpp File Reference

Compat/TraceOutputStream.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "TraceOutputStream.hpp"

Include dependency graph for TraceOutputStream.cpp:

Generated on Tue Jan 24 20:22:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TraceOutputStream.hpp File Reference

Compat/TraceOutputStream.hpp File Reference

#include <Kernel/OutputStream.hpp>

Include dependency graph for TraceOutputStream.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TraceOutputStream

Defines

#define | Apoxi_TraceOutputStream_hpp

Define Documentation

#define Apoxi_TraceOutputStream_hpp

Generated on Tue Jan 24 20:22:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/TraceOutputStream.hpp Source File

Compat/TraceOutputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TraceOutputStream_hpp)
00010 #define Apoxi_TraceOutputStream_hpp
00013
00014 #include <Kernel/OutputStream.hpp>
00015
00016 #ifndef APOXI_NOSTREAMING
00017
00018 class TraceOutputStream : public OutputStream {
00019     public:
00020         TraceOutputStream(OutputStream* stream);
00021         virtual ~TraceOutputStream();
00022
00023         virtual INT Write (const BYTE data);
00024         virtual INT Write (const BYTE* data, INT len);
00025
00026         virtual OutputStream& operator << (const char c);
00027         virtual OutputStream& operator << (const unsigned char c);
00028 //      virtual OutputStream& operator << (const signed char c);
00029
00030         virtual OutputStream& operator << (const char* s);
00031
00032         virtual OutputStream& operator << (const wchar_t* w);
00033
00034         virtual OutputStream& operator << (const short n);
00035         virtual OutputStream& operator << (const unsigned short n);
00036
00037         virtual OutputStream& operator << (const int n);
00038         virtual OutputStream& operator << (const unsigned int n);
00039
00040         virtual OutputStream& operator << (const long n);
00041         virtual OutputStream& operator << (const unsigned long n);
00042
00043         virtual void Flush();
00044
00045     private:
00046         OutputStream* m_stream;
00047 };
00048
00049 #endif
00050
00052 #endif // Apoxi_TraceOutputStream_hpp
00053
00054
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/WinMenuItem.cpp File Reference

Compat/WinMenuItem.cpp File Reference

#include "PreComp.hpp"
#include "WinMenuItem.hpp"
#include "MenuList.hpp"
#include <Gui/Window.hpp>

Include dependency graph for WinMenuItem.cpp:

Generated on Tue Jan 24 20:22:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/WinMenuItem.hpp File Reference

Compat/WinMenuItem.hpp File Reference

#include <Compat/MenuItem.hpp>
#include <Gui/OpenWindowAction.hpp>

Include dependency graph for WinMenuItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WinMenuItem

Defines

#define | Apoxi_WinMenuItem_hpp

Define Documentation

#define Apoxi_WinMenuItem_hpp

Generated on Tue Jan 24 20:22:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/WinMenuItem.hpp Source File

Compat/WinMenuItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_WinMenuItem_hpp)
00010 #define Apoxi_WinMenuItem_hpp
00011
00012 #include <Compat/MenuItem.hpp>
00013 #include <Gui/OpenWindowAction.hpp>
00014
00015 class MenuList;
00016 class Window;
00017
00020 class WinMenuItem : public MenuItem {
00021     typedef MenuItem Base;
00022
00023     public:
00026         WinMenuItem();
00027
00029         WinMenuItem(Window *win, const WCHAR *text = 0, const BitmapRes *bitmap = 0, BOOLEAN enabled = TRUE);
00030
00032         void Init(Window *win, const WCHAR *text = 0, const BitmapRes *bitmap = 0, BOOLEAN enabled = TRUE);
00033
00035         Window* GetWindow() { return m_win; }
00036
00037     private:
00038         Window           *m_win;
00039         OpenWindowAction m_open_win_action;
00040 };
00041
00042 #endif  // Apoxi_WinMenuItem_hpp
00043
00044
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/WinRect.cpp File Reference

Compat/WinRect.cpp File Reference

#include "PreComp.hpp"
#include "WinRect.hpp"

Include dependency graph for WinRect.cpp:

Generated on Tue Jan 24 20:22:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/WinRect.hpp File Reference

Compat/WinRect.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for WinRect.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WinRect

Defines

#define | Apoxi_WinRect_hpp

Define Documentation

#define Apoxi_WinRect_hpp

Generated on Tue Jan 24 20:22:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/WinRect.hpp Source File

Compat/WinRect.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_WinRect_hpp)
00010 #define Apoxi_WinRect_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Gui/Rect.hpp>
00014
00017 class WinRect {
00018     public:
00021         WinRect();
00022
00028         WinRect(const Rect &rect, XYDIM abs_left = 0, XYDIM abs_top = 0);
00029
00035         void Init(const Rect &rect, XYDIM abs_left = 0, XYDIM abs_top = 0);
00036
00038         void SetLeft(XYDIM left);
00039
00041         XYDIM GetLeft() const   { return m_rel_rect.GetLeft(); }
00042
00044         void SetTop(XYDIM top);
00045
00047         XYDIM GetTop() const    { return m_rel_rect.GetTop(); }
00048
00050         void SetRight(XYDIM right);
00051
00053         XYDIM GetRight() const  { return m_rel_rect.GetRight(); }
00054
00056         void SetBottom(XYDIM bottom);
00057
00059         XYDIM GetBottom() const { return m_rel_rect.GetBottom(); }
00060
00062         void SetWidth(XYDIM width) { m_rel_rect.SetWidth(width); }
00063
00065         XYDIM GetWidth() const { return m_rel_rect.GetWidth(); }
00066
00068         void SetHeight(XYDIM height) { m_rel_rect.SetHeight(height); }
00069
00071         XYDIM GetHeight() const { return m_rel_rect.GetHeight(); }
00072
00075         void SetSize(XYDIM width, XYDIM height) { m_rel_rect.SetSize(width, height); }
00076
00078         Size GetSize() const { return m_rel_rect.GetSize(); }
00079
00081         const Rect& GetRect() const;
00082
00086         void UpdateAbsRect(XYDIM dx, XYDIM dy);
00087
00089         const Rect& GetAbsRect() const;
00090
00094         void Move(XYDIM dx, XYDIM dy) { m_rel_rect.Move(dx, dy); }
00095
00097         XYDIM GetAbsLeft() const   { return m_abs_rect.GetLeft(); }
00098
00100         XYDIM GetAbsTop() const    { return m_abs_rect.GetTop();  }
00101
00103         XYDIM GetAbsRight() const  { return m_abs_rect.GetRight(); }
00104
00106         XYDIM GetAbsBottom() const { return m_abs_rect.GetBottom(); }
00107
00108     private:
00109         Rect m_rel_rect;
00110         Rect m_abs_rect;
00111 };
00112
00113
00114 #endif  // Apoxi_winRect_hpp
00115
00116
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/BP30/Audio.cpp File Reference

Compat/Devices/BP30/Audio.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/Os.hpp>
#include <Devices/AudioDeviceManager.hpp>
#include <ApoxiVersion.hpp>
#include "Audio.hpp"

Include dependency graph for Audio.cpp:

Generated on Tue Jan 24 20:16:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/BP30/Audio.hpp File Reference

Compat/Devices/BP30/Audio.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <stack/driver.h>

Include dependency graph for Audio.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Audio
struct | Audio::SingleTone
struct | Audio::ToneData

Defines

#define | Apoxi_Audio_hpp

Define Documentation

#define Apoxi_Audio_hpp

Generated on Tue Jan 24 20:16:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/BP30/Audio.hpp Source File

Compat/Devices/BP30/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Audio_hpp)
00010 #define Apoxi_Audio_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Devices/AbstractDevice.hpp>
00014
00015 #include <stack/driver.h>
00016
00017 class Audio : public AbstractDevice {
00018     public:
00019
00020         struct SingleTone {
00021             UINT16 freq;
00022             UINT16 dur;
00023         };
00024
00025         struct ToneData {
00026             SingleTone *tones;
00027             UINT16 nof_tones;
00028             UINT16 nof_repeats;
00029         };
00030
00031         enum AudioPriority {
00032             PriorityHigh    = 3,
00033             PriorityMedium  = 2,
00034             PriorityLow     = 1,
00035             PriorityNone    = 0
00036         };
00037
00038         enum AudioDevice {
00039             DeviceNone     = 0x0000,
00040             DeviceBuzzer   = 0x0001,
00041             DeviceEarPiece = 0x0002,
00043             DeviceTrembler = 0x0004,
00044             DeviceOut      = 0x000f,
00045             DeviceMic      = 0x0010,
00046             DeviceIn        = 0x00f0
00047         };
00048
00049         enum AudioMode {
00050             ModeNormal,
00051             ModeHeadset,
00052             ModeHandsfree
00053         };
00054
00055         enum AudioToneId {
00056             ToneDtmf0 = 0,
00057             ToneDtmf1,
00058             ToneDtmf2,
00059             ToneDtmf3,
00060             ToneDtmf4,
00061             ToneDtmf5,
00062             ToneDtmf6,
00063             ToneDtmf7,
00064             ToneDtmf8,
00065             ToneDtmf9,
00066             ToneDtmfHash,
00067             ToneDtmfStar,
00068             ToneSupervisorySubsciberBusy,
00069             ToneSupervisoryCongestion,
00070             ToneSupervisoryRadioPathAck,
00071             ToneSupervisoryRadioPathNotAvail,
00072             ToneSupervisoryError,
00073             ToneSupervisoryCallWaiting,
00074             ToneInfoFree,
00075             ToneInfoLowBat,
00076             ToneInfoConnection,
00077             ToneInfoDisconnect,
00078             ToneInfoPowerOn,
00079             ToneInfoPowerOff,
00080             ToneInfoDeviceIn,
00081             ToneInfoDeviceOut,
00082             ToneInfoMsgFull,
00083             ToneInfoUssd,
00084             ToneInfoMinuteBeep,
00085             ToneInfoSmsReceived,
00086             ToneInfoBroadcast,
00087             ToneInfoAlarm,
00088             ToneInfoAutoRedial,
00089             ToneInfoNetworkAttention,
00090             ToneInfoDialTone,
00091             ToneInfoLowBatInCall,
00092             ToneKey1,
00093             ToneKey2,
00094             ToneKey3,
00095             ToneKey4,
00096             ToneBroadcast1,
00097             ToneBroadcast2,
00098             ToneBroadcast3,
00099             ToneBroadcast4,
00100             ToneMessage1,
00101             ToneMessage2,
00102             ToneMessage3,
00103             ToneMessage4,
00104             ToneMessage5,
00105             ToneMessage6,
00106             ToneMessage7,
00107             ToneMessage8,
00108             ToneMessage9,
00109             ToneMessage10,
00110             ToneMessageSingleBeep,
00111             ToneRinging1,
00112             ToneRinging2,
00113             ToneRinging3,
00114             ToneRinging4,
00115             ToneRinging5,
00116             ToneRinging6,
00117             ToneRinging7,
00118             ToneRinging8,
00119             ToneRinging9,
00120             ToneRinging10,
00121             ToneRinging11,
00122             ToneRinging12,
00123             ToneRinging13,
00124             ToneRinging14,
00125             ToneRinging15,
00126             ToneRinging16,
00127             ToneRinging17,
00128             ToneRinging18,
00129             ToneRinging19,
00130             ToneRinging20,
00131             ToneRinging21,
00132             ToneRinging22,
00133             ToneRinging23,
00134             ToneRinging24,
00135             ToneRinging25,
00136             ToneRinging26,
00137             ToneRinging27,
00138             ToneRinging28,
00139             ToneRinging29,
00140             ToneRinging30,
00141             ToneRinging31,
00142             ToneRinging32,
00143             ToneRinging33,
00144             ToneRinging34,
00145             ToneRinging35,
00146             ToneRinging36,
00147             ToneRinging37,
00148             ToneRinging38,
00149             ToneRinging39,
00150             ToneRinging40,
00151             ToneRinging41,
00152             ToneRinging42,
00153             ToneRinging43,
00154             ToneRinging44,
00155             ToneRinging45,
00156             ToneRinging46,
00157             ToneRinging47,
00158             ToneRinging48,
00159             ToneUserDefined,
00160             ToneAlarm1,
00161             AudioInvalidTone
00162         };
00163
00164         // Mute direction
00165         enum MuteDirection {
00166             MuteUplink      = aud_direction_uplink,
00167             MuteDownlink    = aud_direction_downlink,
00168             MuteTch         = aud_direction_updownlink
00169         };
00170
00171         // Speech volume: Steps for speech volume are available, with a 3 dB
00172         // change for each step.
00173         enum SpeechVolume {
00174             SpeechVolume1 = aud_speech_volume_1,
00175             SpeechVolume2 = aud_speech_volume_2,
00176             SpeechVolume3 = aud_speech_volume_3,
00177             SpeechVolume4 = aud_speech_volume_4,
00178             SpeechVolume5 = aud_speech_volume_5,
00179             SpeechVolume6 = aud_speech_volume_6,
00180             SpeechVolume7 = aud_speech_volume_7,
00181             SpeechVolume8 = aud_speech_volume_8
00182         };
00183
00185         virtual const WCHAR* GetName() const;
00186
00188         Audio ();
00189
00191         virtual ~Audio();
00192
00193         static void Init();
00194
00195         static BOOLEAN StartTone(AudioToneId tone_id,
00196                                  INT nof_repeats = 0,
00197                                  AudioDevice device = DeviceBuzzer,
00198                                  AudioPriority priority = PriorityNone);
00199
00201         static BOOLEAN StartTone(const ToneData *tone_data,
00202                                  AudioDevice device = DeviceBuzzer,
00203                                  AudioPriority priority = PriorityNone);
00204
00205         static void StopTone();
00206
00207         enum VibratorMode
00208         {
00209             VibratorModeAsync1 = Aud_vibrator_mode_async_1,
00210             VibratorModeAsync2 = Aud_vibrator_mode_async_2,
00211             VibratorModeSync1 = Aud_vibrator_mode_sync_1,
00212             VibratorModeSync2 = Aud_vibrator_mode_sync_2
00213         };
00214
00215         enum VibratorOnTime
00216         {
00217             VibratorOnTime400ms = Aud_vibrator_on_400ms,
00218             VibratorOnTime600ms = Aud_vibrator_on_600ms,
00219             VibratorOnTime800ms = Aud_vibrator_on_800ms,
00220             VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
00221             VibratorOnTimeOn = Aud_vibrator_on
00222         };
00223
00224         enum VibratorOffTime
00225         {
00226             VibratorOffTime200ms = Aud_vibrator_off_200ms,
00227             VibratorOffTime300ms = Aud_vibrator_off_300ms,
00228             VibratorOffTime400ms = Aud_vibrator_off_400ms,
00229             VibratorOffTime600ms = Aud_vibrator_off_600ms,
00230             VibratorOffTimeOff = Aud_vibrator_off
00231         };
00232
00233         //TODO: Are these sensible default values? Murray.
00237         static BOOLEAN StartVibrator(VibratorMode mode = VibratorModeAsync1,  VibratorOnTime on = VibratorOnTimeOn, VibratorOffTime off = VibratorOffTimeOff);
00238
00242             static void StopVibrator();
00243
00245         static BOOLEAN IsTremblerOn() { return IsVibratorOn(); }
00246
00248         static BOOLEAN IsVibratorOn() { return m_vibrator_on; }
00249
00250         static void SetVolume(UINT8 volume, AudioDevice device);
00251
00252         static void SetMute(BOOLEAN mute, AudioDevice device);
00253
00254         static void SetAudioMode(AudioMode audio_mode);
00255
00256         // Enable uplink and downlink audio path for speech.
00257         // The volume level will be level last set with SetVolumeSpeech.
00258         static BOOLEAN InitSpeech();
00259
00260         // Powers down the audio path, both uplink and downlink.
00261         static BOOLEAN ReleaseSpeech();
00262
00263         // Change the speaker volume.
00264         // The audio driver only stores the volume in RAM.
00265         static BOOLEAN SetVolumeSpeech(SpeechVolume vol);
00266
00267         // The audio driver only stores the volume in RAM.
00268         static BOOLEAN MuteSpeech(BOOLEAN mute, MuteDirection dir);
00269
00271         static BOOLEAN IsEnabled();
00272
00273     private:
00274         // Id used for AUD_allocate_resource
00275         enum ResourceID {
00276             ToneID      = 1,
00277             RingerID    = 2,
00278             SpeechID    = 3
00279         };
00280
00281         static BOOLEAN m_vibrator_on;
00282         static AudioPriority m_priority;
00283         static BOOLEAN m_init;
00284
00285
00286         //DWD Resources handles:
00287         static INT8 m_tone;
00288         static INT8 m_ringer;
00289         static INT8 m_speech;
00290         static INT8 m_dwd_resource_vibrator; //Also known as trembler.
00291         static UINT8 m_no_speech_volume;
00292     };
00293 #endif  // Apoxi_Audio_hpp
00294
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/BP30/PreComp.cpp File Reference

Compat/Devices/BP30/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/BP30/PreComp.hpp File Reference

Compat/Devices/BP30/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Kernel/Timer.hpp>
#include <Gui/Locale.hpp>
#include <Gui/ClientDc.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/Bitmap.hpp>
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/BP30/PreComp.hpp Source File

Compat/Devices/BP30/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Timer.hpp>
00012 #include <Gui/Locale.hpp>
00013 #include <Gui/ClientDc.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/MsgTypes.hpp>
00016 #include <Gui/MsgTypes.hpp>
00017 #include <Gui/Bitmap.hpp>
00018 #include <Kernel/ExecutionContext.hpp>
00019
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPE/Audio.cpp File Reference

Compat/Devices/MPE/Audio.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/Os.hpp>
#include <Devices/AudioDeviceManager.hpp>
#include <ApoxiVersion.hpp>
#include "Audio.hpp"

Include dependency graph for Audio.cpp:

Generated on Tue Jan 24 20:16:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPE/Audio.hpp File Reference

Compat/Devices/MPE/Audio.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <stack/driver.h>

Include dependency graph for Audio.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Audio
struct | Audio::SingleTone
struct | Audio::ToneData

Defines

#define | Apoxi_Audio_hpp

Define Documentation

#define Apoxi_Audio_hpp

Generated on Tue Jan 24 20:16:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPE/Audio.hpp Source File

Compat/Devices/MPE/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Audio_hpp)
00010 #define Apoxi_Audio_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Devices/AbstractDevice.hpp>
00014
00015 #include <stack/driver.h>
00016
00017 class Audio : public AbstractDevice {
00018     public:
00019
00020         struct SingleTone {
00021             UINT16 freq;
00022             UINT16 dur;
00023         };
00024
00025         struct ToneData {
00026             SingleTone *tones;
00027             UINT16 nof_tones;
00028             UINT16 nof_repeats;
00029         };
00030
00031         enum AudioPriority {
00032             PriorityHigh    = 3,
00033             PriorityMedium  = 2,
00034             PriorityLow     = 1,
00035             PriorityNone    = 0
00036         };
00037
00038         enum AudioDevice {
00039             DeviceNone     = 0x0000,
00040             DeviceBuzzer   = 0x0001,
00041             DeviceEarPiece = 0x0002,
00043             DeviceTrembler = 0x0004,
00044             DeviceOut      = 0x000f,
00045             DeviceMic      = 0x0010,
00046             DeviceIn        = 0x00f0
00047         };
00048
00049         enum AudioMode {
00050             ModeNormal,
00051             ModeHeadset,
00052             ModeHandsfree
00053         };
00054
00055         enum AudioToneId {
00056             ToneDtmf0 = 0,
00057             ToneDtmf1,
00058             ToneDtmf2,
00059             ToneDtmf3,
00060             ToneDtmf4,
00061             ToneDtmf5,
00062             ToneDtmf6,
00063             ToneDtmf7,
00064             ToneDtmf8,
00065             ToneDtmf9,
00066             ToneDtmfHash,
00067             ToneDtmfStar,
00068             ToneSupervisorySubsciberBusy,
00069             ToneSupervisoryCongestion,
00070             ToneSupervisoryRadioPathAck,
00071             ToneSupervisoryRadioPathNotAvail,
00072             ToneSupervisoryError,
00073             ToneSupervisoryCallWaiting,
00074             ToneInfoFree,
00075             ToneInfoLowBat,
00076             ToneInfoConnection,
00077             ToneInfoDisconnect,
00078             ToneInfoPowerOn,
00079             ToneInfoPowerOff,
00080             ToneInfoDeviceIn,
00081             ToneInfoDeviceOut,
00082             ToneInfoMsgFull,
00083             ToneInfoUssd,
00084             ToneInfoMinuteBeep,
00085             ToneInfoSmsReceived,
00086             ToneInfoBroadcast,
00087             ToneInfoAlarm,
00088             ToneInfoAutoRedial,
00089             ToneInfoNetworkAttention,
00090             ToneInfoDialTone,
00091             ToneInfoLowBatInCall,
00092             ToneKey1,
00093             ToneKey2,
00094             ToneKey3,
00095             ToneKey4,
00096             ToneBroadcast1,
00097             ToneBroadcast2,
00098             ToneBroadcast3,
00099             ToneBroadcast4,
00100             ToneMessage1,
00101             ToneMessage2,
00102             ToneMessage3,
00103             ToneMessage4,
00104             ToneMessage5,
00105             ToneMessage6,
00106             ToneMessage7,
00107             ToneMessage8,
00108             ToneMessage9,
00109             ToneMessage10,
00110             ToneMessageSingleBeep,
00111             ToneRinging1,
00112             ToneRinging2,
00113             ToneRinging3,
00114             ToneRinging4,
00115             ToneRinging5,
00116             ToneRinging6,
00117             ToneRinging7,
00118             ToneRinging8,
00119             ToneRinging9,
00120             ToneRinging10,
00121             ToneRinging11,
00122             ToneRinging12,
00123             ToneRinging13,
00124             ToneRinging14,
00125             ToneRinging15,
00126             ToneRinging16,
00127             ToneRinging17,
00128             ToneRinging18,
00129             ToneRinging19,
00130             ToneRinging20,
00131             ToneRinging21,
00132             ToneRinging22,
00133             ToneRinging23,
00134             ToneRinging24,
00135             ToneRinging25,
00136             ToneRinging26,
00137             ToneRinging27,
00138             ToneRinging28,
00139             ToneRinging29,
00140             ToneRinging30,
00141             ToneRinging31,
00142             ToneRinging32,
00143             ToneRinging33,
00144             ToneRinging34,
00145             ToneRinging35,
00146             ToneRinging36,
00147             ToneRinging37,
00148             ToneRinging38,
00149             ToneRinging39,
00150             ToneRinging40,
00151             ToneRinging41,
00152             ToneRinging42,
00153             ToneRinging43,
00154             ToneRinging44,
00155             ToneRinging45,
00156             ToneRinging46,
00157             ToneRinging47,
00158             ToneRinging48,
00159             ToneUserDefined,
00160             ToneAlarm1,
00161             AudioInvalidTone
00162         };
00163
00164         // Mute direction
00165         enum MuteDirection {
00166             MuteUplink      = aud_direction_uplink,
00167             MuteDownlink    = aud_direction_downlink,
00168             MuteTch         = aud_direction_updownlink
00169         };
00170
00171         // Speech volume: Steps for speech volume are available, with a 3 dB
00172         // change for each step.
00173         enum SpeechVolume {
00174             SpeechVolume1 = aud_speech_volume_1,
00175             SpeechVolume2 = aud_speech_volume_2,
00176             SpeechVolume3 = aud_speech_volume_3,
00177             SpeechVolume4 = aud_speech_volume_4,
00178             SpeechVolume5 = aud_speech_volume_5,
00179             SpeechVolume6 = aud_speech_volume_6,
00180             SpeechVolume7 = aud_speech_volume_7,
00181             SpeechVolume8 = aud_speech_volume_8
00182         };
00183
00185         virtual const WCHAR* GetName() const;
00186
00188         Audio ();
00189
00191         virtual ~Audio();
00192
00193         static void Init();
00194
00195         static BOOLEAN StartTone(AudioToneId tone_id,
00196                                  INT nof_repeats = 0,
00197                                  AudioDevice device = DeviceBuzzer,
00198                                  AudioPriority priority = PriorityNone);
00199
00201         static BOOLEAN StartTone(const ToneData *tone_data,
00202                                  AudioDevice device = DeviceBuzzer,
00203                                  AudioPriority priority = PriorityNone);
00204
00205         static void StopTone();
00206
00207         enum VibratorMode
00208         {
00209             VibratorModeAsync1 = Aud_vibrator_mode_async_1,
00210             VibratorModeAsync2 = Aud_vibrator_mode_async_2,
00211             VibratorModeSync1 = Aud_vibrator_mode_sync_1,
00212             VibratorModeSync2 = Aud_vibrator_mode_sync_2
00213         };
00214
00215         enum VibratorOnTime
00216         {
00217             VibratorOnTime400ms = Aud_vibrator_on_400ms,
00218             VibratorOnTime600ms = Aud_vibrator_on_600ms,
00219             VibratorOnTime800ms = Aud_vibrator_on_800ms,
00220             VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
00221             VibratorOnTimeOn = Aud_vibrator_on
00222         };
00223
00224         enum VibratorOffTime
00225         {
00226             VibratorOffTime200ms = Aud_vibrator_off_200ms,
00227             VibratorOffTime300ms = Aud_vibrator_off_300ms,
00228             VibratorOffTime400ms = Aud_vibrator_off_400ms,
00229             VibratorOffTime600ms = Aud_vibrator_off_600ms,
00230             VibratorOffTimeOff = Aud_vibrator_off
00231         };
00232
00233         //TODO: Are these sensible default values? Murray.
00237         static BOOLEAN StartVibrator(VibratorMode mode = VibratorModeAsync1,  VibratorOnTime on = VibratorOnTimeOn, VibratorOffTime off = VibratorOffTimeOff);
00238
00242             static void StopVibrator();
00243
00245         static BOOLEAN IsTremblerOn() { return IsVibratorOn(); }
00246
00248         static BOOLEAN IsVibratorOn() { return m_vibrator_on; }
00249
00250         static void SetVolume(UINT8 volume, AudioDevice device);
00251
00252         static void SetMute(BOOLEAN mute, AudioDevice device);
00253
00254         static void SetAudioMode(AudioMode audio_mode);
00255
00256         // Enable uplink and downlink audio path for speech.
00257         // The volume level will be level last set with SetVolumeSpeech.
00258         static BOOLEAN InitSpeech();
00259
00260         // Powers down the audio path, both uplink and downlink.
00261         static BOOLEAN ReleaseSpeech();
00262
00263         // Change the speaker volume.
00264         // The audio driver only stores the volume in RAM.
00265         static BOOLEAN SetVolumeSpeech(SpeechVolume vol);
00266
00267         // The audio driver only stores the volume in RAM.
00268         static BOOLEAN MuteSpeech(BOOLEAN mute, MuteDirection dir);
00269
00271         static BOOLEAN IsEnabled();
00272
00273     private:
00274         // Id used for AUD_allocate_resource
00275         enum ResourceID {
00276             ToneID      = 1,
00277             RingerID    = 2,
00278             SpeechID    = 3
00279         };
00280
00281         static BOOLEAN m_vibrator_on;
00282         static AudioPriority m_priority;
00283         static BOOLEAN m_init;
00284
00285
00286         //DWD Resources handles:
00287         static INT8 m_tone;
00288         static INT8 m_ringer;
00289         static INT8 m_speech;
00290         static INT8 m_dwd_resource_vibrator; //Also known as trembler.
00291         static UINT8 m_no_speech_volume;
00292     };
00293 #endif  // Apoxi_Audio_hpp
00294
00295
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPE/PreComp.cpp File Reference

Compat/Devices/MPE/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPE/PreComp.hpp File Reference

Compat/Devices/MPE/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Kernel/Timer.hpp>
#include <Gui/Locale.hpp>
#include <Gui/ClientDc.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/Bitmap.hpp>
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPE/PreComp.hpp Source File

Compat/Devices/MPE/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Timer.hpp>
00012 #include <Gui/Locale.hpp>
00013 #include <Gui/ClientDc.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/MsgTypes.hpp>
00016 #include <Gui/MsgTypes.hpp>
00017 #include <Gui/Bitmap.hpp>
00018 #include <Kernel/ExecutionContext.hpp>
00019
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPEU/Audio.cpp File Reference

Compat/Devices/MPEU/Audio.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/Os.hpp>
#include <Devices/AudioDeviceManager.hpp>
#include <ApoxiVersion.hpp>
#include "Audio.hpp"

Include dependency graph for Audio.cpp:

Generated on Tue Jan 24 20:16:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPEU/Audio.hpp File Reference

Compat/Devices/MPEU/Audio.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <stack/driver.h>

Include dependency graph for Audio.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Audio
struct | Audio::SingleTone
struct | Audio::ToneData

Defines

#define | Apoxi_Audio_hpp

Define Documentation

#define Apoxi_Audio_hpp

Generated on Tue Jan 24 20:16:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPEU/Audio.hpp Source File

Compat/Devices/MPEU/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Audio_hpp)
00010 #define Apoxi_Audio_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Devices/AbstractDevice.hpp>
00014
00015 #include <stack/driver.h>
00016
00017 class Audio : public AbstractDevice {
00018     public:
00019
00020         struct SingleTone {
00021             UINT16 freq;
00022             UINT16 dur;
00023         };
00024
00025         struct ToneData {
00026             SingleTone *tones;
00027             UINT16 nof_tones;
00028             UINT16 nof_repeats;
00029         };
00030
00031         enum AudioPriority {
00032             PriorityHigh    = 3,
00033             PriorityMedium  = 2,
00034             PriorityLow     = 1,
00035             PriorityNone    = 0
00036         };
00037
00038         enum AudioDevice {
00039             DeviceNone     = 0x0000,
00040             DeviceBuzzer   = 0x0001,
00041             DeviceEarPiece = 0x0002,
00043             DeviceTrembler = 0x0004,
00044             DeviceOut      = 0x000f,
00045             DeviceMic      = 0x0010,
00046             DeviceIn        = 0x00f0
00047         };
00048
00049         enum AudioMode {
00050             ModeNormal,
00051             ModeHeadset,
00052             ModeHandsfree
00053         };
00054
00055         enum AudioToneId {
00056             ToneDtmf0 = 0,
00057             ToneDtmf1,
00058             ToneDtmf2,
00059             ToneDtmf3,
00060             ToneDtmf4,
00061             ToneDtmf5,
00062             ToneDtmf6,
00063             ToneDtmf7,
00064             ToneDtmf8,
00065             ToneDtmf9,
00066             ToneDtmfHash,
00067             ToneDtmfStar,
00068             ToneSupervisorySubsciberBusy,
00069             ToneSupervisoryCongestion,
00070             ToneSupervisoryRadioPathAck,
00071             ToneSupervisoryRadioPathNotAvail,
00072             ToneSupervisoryError,
00073             ToneSupervisoryCallWaiting,
00074             ToneInfoFree,
00075             ToneInfoLowBat,
00076             ToneInfoConnection,
00077             ToneInfoDisconnect,
00078             ToneInfoPowerOn,
00079             ToneInfoPowerOff,
00080             ToneInfoDeviceIn,
00081             ToneInfoDeviceOut,
00082             ToneInfoMsgFull,
00083             ToneInfoUssd,
00084             ToneInfoMinuteBeep,
00085             ToneInfoSmsReceived,
00086             ToneInfoBroadcast,
00087             ToneInfoAlarm,
00088             ToneInfoAutoRedial,
00089             ToneInfoNetworkAttention,
00090             ToneInfoDialTone,
00091             ToneInfoLowBatInCall,
00092             ToneKey1,
00093             ToneKey2,
00094             ToneKey3,
00095             ToneKey4,
00096             ToneBroadcast1,
00097             ToneBroadcast2,
00098             ToneBroadcast3,
00099             ToneBroadcast4,
00100             ToneMessage1,
00101             ToneMessage2,
00102             ToneMessage3,
00103             ToneMessage4,
00104             ToneMessage5,
00105             ToneMessage6,
00106             ToneMessage7,
00107             ToneMessage8,
00108             ToneMessage9,
00109             ToneMessage10,
00110             ToneMessageSingleBeep,
00111             ToneRinging1,
00112             ToneRinging2,
00113             ToneRinging3,
00114             ToneRinging4,
00115             ToneRinging5,
00116             ToneRinging6,
00117             ToneRinging7,
00118             ToneRinging8,
00119             ToneRinging9,
00120             ToneRinging10,
00121             ToneRinging11,
00122             ToneRinging12,
00123             ToneRinging13,
00124             ToneRinging14,
00125             ToneRinging15,
00126             ToneRinging16,
00127             ToneRinging17,
00128             ToneRinging18,
00129             ToneRinging19,
00130             ToneRinging20,
00131             ToneRinging21,
00132             ToneRinging22,
00133             ToneRinging23,
00134             ToneRinging24,
00135             ToneRinging25,
00136             ToneRinging26,
00137             ToneRinging27,
00138             ToneRinging28,
00139             ToneRinging29,
00140             ToneRinging30,
00141             ToneRinging31,
00142             ToneRinging32,
00143             ToneRinging33,
00144             ToneRinging34,
00145             ToneRinging35,
00146             ToneRinging36,
00147             ToneRinging37,
00148             ToneRinging38,
00149             ToneRinging39,
00150             ToneRinging40,
00151             ToneRinging41,
00152             ToneRinging42,
00153             ToneRinging43,
00154             ToneRinging44,
00155             ToneRinging45,
00156             ToneRinging46,
00157             ToneRinging47,
00158             ToneRinging48,
00159             ToneUserDefined,
00160             ToneAlarm1,
00161             AudioInvalidTone
00162         };
00163
00164         // Mute direction
00165         enum MuteDirection {
00166             MuteUplink      = aud_direction_uplink,
00167             MuteDownlink    = aud_direction_downlink,
00168             MuteTch         = aud_direction_updownlink
00169         };
00170
00171         // Speech volume: Steps for speech volume are available, with a 3 dB
00172         // change for each step.
00173         enum SpeechVolume {
00174             SpeechVolume1 = aud_speech_volume_1,
00175             SpeechVolume2 = aud_speech_volume_2,
00176             SpeechVolume3 = aud_speech_volume_3,
00177             SpeechVolume4 = aud_speech_volume_4,
00178             SpeechVolume5 = aud_speech_volume_5,
00179             SpeechVolume6 = aud_speech_volume_6,
00180             SpeechVolume7 = aud_speech_volume_7,
00181             SpeechVolume8 = aud_speech_volume_8
00182         };
00183
00185         virtual const WCHAR* GetName() const;
00186
00188         Audio ();
00189
00191         virtual ~Audio();
00192
00193         static void Init();
00194
00195         static BOOLEAN StartTone(AudioToneId tone_id,
00196                                  INT nof_repeats = 0,
00197                                  AudioDevice device = DeviceBuzzer,
00198                                  AudioPriority priority = PriorityNone);
00199
00201         static BOOLEAN StartTone(const ToneData *tone_data,
00202                                  AudioDevice device = DeviceBuzzer,
00203                                  AudioPriority priority = PriorityNone);
00204
00205         static void StopTone();
00206
00207         enum VibratorMode
00208         {
00209             VibratorModeAsync1 = Aud_vibrator_mode_async_1,
00210             VibratorModeAsync2 = Aud_vibrator_mode_async_2,
00211             VibratorModeSync1 = Aud_vibrator_mode_sync_1,
00212             VibratorModeSync2 = Aud_vibrator_mode_sync_2
00213         };
00214
00215         enum VibratorOnTime
00216         {
00217             VibratorOnTime400ms = Aud_vibrator_on_400ms,
00218             VibratorOnTime600ms = Aud_vibrator_on_600ms,
00219             VibratorOnTime800ms = Aud_vibrator_on_800ms,
00220             VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
00221             VibratorOnTimeOn = Aud_vibrator_on
00222         };
00223
00224         enum VibratorOffTime
00225         {
00226             VibratorOffTime200ms = Aud_vibrator_off_200ms,
00227             VibratorOffTime300ms = Aud_vibrator_off_300ms,
00228             VibratorOffTime400ms = Aud_vibrator_off_400ms,
00229             VibratorOffTime600ms = Aud_vibrator_off_600ms,
00230             VibratorOffTimeOff = Aud_vibrator_off
00231         };
00232
00233         //TODO: Are these sensible default values? Murray.
00237         static BOOLEAN StartVibrator(VibratorMode mode = VibratorModeAsync1,  VibratorOnTime on = VibratorOnTimeOn, VibratorOffTime off = VibratorOffTimeOff);
00238
00242             static void StopVibrator();
00243
00245         static BOOLEAN IsTremblerOn() { return IsVibratorOn(); }
00246
00248         static BOOLEAN IsVibratorOn() { return m_vibrator_on; }
00249
00250         static void SetVolume(UINT8 volume, AudioDevice device);
00251
00252         static void SetMute(BOOLEAN mute, AudioDevice device);
00253
00254         static void SetAudioMode(AudioMode audio_mode);
00255
00256         // Enable uplink and downlink audio path for speech.
00257         // The volume level will be level last set with SetVolumeSpeech.
00258         static BOOLEAN InitSpeech();
00259
00260         // Powers down the audio path, both uplink and downlink.
00261         static BOOLEAN ReleaseSpeech();
00262
00263         // Change the speaker volume.
00264         // The audio driver only stores the volume in RAM.
00265         static BOOLEAN SetVolumeSpeech(SpeechVolume vol);
00266
00267         // The audio driver only stores the volume in RAM.
00268         static BOOLEAN MuteSpeech(BOOLEAN mute, MuteDirection dir);
00269
00271         static BOOLEAN IsEnabled();
00272
00273     private:
00274         // Id used for AUD_allocate_resource
00275         enum ResourceID {
00276             ToneID      = 1,
00277             RingerID    = 2,
00278             SpeechID    = 3
00279         };
00280
00281         static BOOLEAN m_vibrator_on;
00282         static AudioPriority m_priority;
00283         static BOOLEAN m_init;
00284
00285
00286         //DWD Resources handles:
00287         static INT8 m_tone;
00288         static INT8 m_ringer;
00289         static INT8 m_speech;
00290         static INT8 m_dwd_resource_vibrator; //Also known as trembler.
00291         static UINT8 m_no_speech_volume;
00292     };
00293 #endif  // Apoxi_Audio_hpp
00294
00295
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPEU/PreComp.cpp File Reference

Compat/Devices/MPEU/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPEU/PreComp.hpp File Reference

Compat/Devices/MPEU/PreComp.hpp File Reference

#include <Gui/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/MPEU/PreComp.hpp Source File

Compat/Devices/MPEU/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #include <Gui/Lib.hpp>
00011 #include <Asc/Lib.hpp>
00012 #include <Auxiliary/Lib.hpp>
00013
00014
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/SGold/Audio.cpp File Reference

Compat/Devices/SGold/Audio.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/Os.hpp>
#include <Devices/AudioDeviceManager.hpp>
#include <ApoxiVersion.hpp>
#include "Audio.hpp"

Include dependency graph for Audio.cpp:

Generated on Tue Jan 24 20:16:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/SGold/Audio.hpp File Reference

Compat/Devices/SGold/Audio.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <stack/driver.h>

Include dependency graph for Audio.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Audio
struct | Audio::SingleTone
struct | Audio::ToneData

Defines

#define | Apoxi_Audio_hpp

Define Documentation

#define Apoxi_Audio_hpp

Generated on Tue Jan 24 20:16:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/SGold/Audio.hpp Source File

Compat/Devices/SGold/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Audio_hpp)
00010 #define Apoxi_Audio_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Devices/AbstractDevice.hpp>
00014
00015 #include <stack/driver.h>
00016
00017 class Audio : public AbstractDevice {
00018     public:
00019
00020         struct SingleTone {
00021             UINT16 freq;
00022             UINT16 dur;
00023         };
00024
00025         struct ToneData {
00026             SingleTone *tones;
00027             UINT16 nof_tones;
00028             UINT16 nof_repeats;
00029         };
00030
00031         enum AudioPriority {
00032             PriorityHigh    = 3,
00033             PriorityMedium  = 2,
00034             PriorityLow     = 1,
00035             PriorityNone    = 0
00036         };
00037
00038         enum AudioDevice {
00039             DeviceNone     = 0x0000,
00040             DeviceBuzzer   = 0x0001,
00041             DeviceEarPiece = 0x0002,
00043             DeviceTrembler = 0x0004,
00044             DeviceOut      = 0x000f,
00045             DeviceMic      = 0x0010,
00046             DeviceIn        = 0x00f0
00047         };
00048
00049         enum AudioMode {
00050             ModeNormal,
00051             ModeHeadset,
00052             ModeHandsfree
00053         };
00054
00055         enum AudioToneId {
00056             ToneDtmf0 = 0,
00057             ToneDtmf1,
00058             ToneDtmf2,
00059             ToneDtmf3,
00060             ToneDtmf4,
00061             ToneDtmf5,
00062             ToneDtmf6,
00063             ToneDtmf7,
00064             ToneDtmf8,
00065             ToneDtmf9,
00066             ToneDtmfHash,
00067             ToneDtmfStar,
00068             ToneSupervisorySubsciberBusy,
00069             ToneSupervisoryCongestion,
00070             ToneSupervisoryRadioPathAck,
00071             ToneSupervisoryRadioPathNotAvail,
00072             ToneSupervisoryError,
00073             ToneSupervisoryCallWaiting,
00074             ToneInfoFree,
00075             ToneInfoLowBat,
00076             ToneInfoConnection,
00077             ToneInfoDisconnect,
00078             ToneInfoPowerOn,
00079             ToneInfoPowerOff,
00080             ToneInfoDeviceIn,
00081             ToneInfoDeviceOut,
00082             ToneInfoMsgFull,
00083             ToneInfoUssd,
00084             ToneInfoMinuteBeep,
00085             ToneInfoSmsReceived,
00086             ToneInfoBroadcast,
00087             ToneInfoAlarm,
00088             ToneInfoAutoRedial,
00089             ToneInfoNetworkAttention,
00090             ToneInfoDialTone,
00091             ToneInfoLowBatInCall,
00092             ToneKey1,
00093             ToneKey2,
00094             ToneKey3,
00095             ToneKey4,
00096             ToneBroadcast1,
00097             ToneBroadcast2,
00098             ToneBroadcast3,
00099             ToneBroadcast4,
00100             ToneMessage1,
00101             ToneMessage2,
00102             ToneMessage3,
00103             ToneMessage4,
00104             ToneMessage5,
00105             ToneMessage6,
00106             ToneMessage7,
00107             ToneMessage8,
00108             ToneMessage9,
00109             ToneMessage10,
00110             ToneMessageSingleBeep,
00111             ToneRinging1,
00112             ToneRinging2,
00113             ToneRinging3,
00114             ToneRinging4,
00115             ToneRinging5,
00116             ToneRinging6,
00117             ToneRinging7,
00118             ToneRinging8,
00119             ToneRinging9,
00120             ToneRinging10,
00121             ToneRinging11,
00122             ToneRinging12,
00123             ToneRinging13,
00124             ToneRinging14,
00125             ToneRinging15,
00126             ToneRinging16,
00127             ToneRinging17,
00128             ToneRinging18,
00129             ToneRinging19,
00130             ToneRinging20,
00131             ToneRinging21,
00132             ToneRinging22,
00133             ToneRinging23,
00134             ToneRinging24,
00135             ToneRinging25,
00136             ToneRinging26,
00137             ToneRinging27,
00138             ToneRinging28,
00139             ToneRinging29,
00140             ToneRinging30,
00141             ToneRinging31,
00142             ToneRinging32,
00143             ToneRinging33,
00144             ToneRinging34,
00145             ToneRinging35,
00146             ToneRinging36,
00147             ToneRinging37,
00148             ToneRinging38,
00149             ToneRinging39,
00150             ToneRinging40,
00151             ToneRinging41,
00152             ToneRinging42,
00153             ToneRinging43,
00154             ToneRinging44,
00155             ToneRinging45,
00156             ToneRinging46,
00157             ToneRinging47,
00158             ToneRinging48,
00159             ToneUserDefined,
00160             ToneAlarm1,
00161             AudioInvalidTone
00162         };
00163
00164         // Mute direction
00165         enum MuteDirection {
00166             MuteUplink      = aud_direction_uplink,
00167             MuteDownlink    = aud_direction_downlink,
00168             MuteTch         = aud_direction_updownlink
00169         };
00170
00171         // Speech volume: Steps for speech volume are available, with a 3 dB
00172         // change for each step.
00173         enum SpeechVolume {
00174             SpeechVolume1 = aud_speech_volume_1,
00175             SpeechVolume2 = aud_speech_volume_2,
00176             SpeechVolume3 = aud_speech_volume_3,
00177             SpeechVolume4 = aud_speech_volume_4,
00178             SpeechVolume5 = aud_speech_volume_5,
00179             SpeechVolume6 = aud_speech_volume_6,
00180             SpeechVolume7 = aud_speech_volume_7,
00181             SpeechVolume8 = aud_speech_volume_8
00182         };
00183
00185         virtual const WCHAR* GetName() const;
00186
00188         Audio ();
00189
00191         virtual ~Audio();
00192
00193         static void Init();
00194
00195         static BOOLEAN StartTone(AudioToneId tone_id,
00196                                  INT nof_repeats = 0,
00197                                  AudioDevice device = DeviceBuzzer,
00198                                  AudioPriority priority = PriorityNone);
00199
00201         static BOOLEAN StartTone(const ToneData *tone_data,
00202                                  AudioDevice device = DeviceBuzzer,
00203                                  AudioPriority priority = PriorityNone);
00204
00205         static void StopTone();
00206
00207         enum VibratorMode
00208         {
00209             VibratorModeAsync1 = Aud_vibrator_mode_async_1,
00210             VibratorModeAsync2 = Aud_vibrator_mode_async_2,
00211             VibratorModeSync1 = Aud_vibrator_mode_sync_1,
00212             VibratorModeSync2 = Aud_vibrator_mode_sync_2
00213         };
00214
00215         enum VibratorOnTime
00216         {
00217             VibratorOnTime400ms = Aud_vibrator_on_400ms,
00218             VibratorOnTime600ms = Aud_vibrator_on_600ms,
00219             VibratorOnTime800ms = Aud_vibrator_on_800ms,
00220             VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
00221             VibratorOnTimeOn = Aud_vibrator_on
00222         };
00223
00224         enum VibratorOffTime
00225         {
00226             VibratorOffTime200ms = Aud_vibrator_off_200ms,
00227             VibratorOffTime300ms = Aud_vibrator_off_300ms,
00228             VibratorOffTime400ms = Aud_vibrator_off_400ms,
00229             VibratorOffTime600ms = Aud_vibrator_off_600ms,
00230             VibratorOffTimeOff = Aud_vibrator_off
00231         };
00232
00233         //TODO: Are these sensible default values? Murray.
00237         static BOOLEAN StartVibrator(VibratorMode mode = VibratorModeAsync1,  VibratorOnTime on = VibratorOnTimeOn, VibratorOffTime off = VibratorOffTimeOff);
00238
00242             static void StopVibrator();
00243
00245         static BOOLEAN IsTremblerOn() { return IsVibratorOn(); }
00246
00248         static BOOLEAN IsVibratorOn() { return m_vibrator_on; }
00249
00250         static void SetVolume(UINT8 volume, AudioDevice device);
00251
00252         static void SetMute(BOOLEAN mute, AudioDevice device);
00253
00254         static void SetAudioMode(AudioMode audio_mode);
00255
00256         // Enable uplink and downlink audio path for speech.
00257         // The volume level will be level last set with SetVolumeSpeech.
00258         static BOOLEAN InitSpeech();
00259
00260         // Powers down the audio path, both uplink and downlink.
00261         static BOOLEAN ReleaseSpeech();
00262
00263         // Change the speaker volume.
00264         // The audio driver only stores the volume in RAM.
00265         static BOOLEAN SetVolumeSpeech(SpeechVolume vol);
00266
00267         // The audio driver only stores the volume in RAM.
00268         static BOOLEAN MuteSpeech(BOOLEAN mute, MuteDirection dir);
00269
00271         static BOOLEAN IsEnabled();
00272
00273     private:
00274         // Id used for AUD_allocate_resource
00275         enum ResourceID {
00276             ToneID      = 1,
00277             RingerID    = 2,
00278             SpeechID    = 3
00279         };
00280
00281         static BOOLEAN m_vibrator_on;
00282         static AudioPriority m_priority;
00283         static BOOLEAN m_init;
00284
00285
00286         //DWD Resources handles:
00287         static INT8 m_tone;
00288         static INT8 m_ringer;
00289         static INT8 m_speech;
00290         static INT8 m_dwd_resource_vibrator; //Also known as trembler.
00291         static UINT8 m_no_speech_volume;
00292     };
00293 #endif  // Apoxi_Audio_hpp
00294
00295
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/SGold/PreComp.cpp File Reference

Compat/Devices/SGold/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/SGold/PreComp.hpp File Reference

Compat/Devices/SGold/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Kernel/Timer.hpp>
#include <Gui/Locale.hpp>
#include <Gui/ClientDc.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/Bitmap.hpp>
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/SGold/PreComp.hpp Source File

Compat/Devices/SGold/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Timer.hpp>
00012 #include <Gui/Locale.hpp>
00013 #include <Gui/ClientDc.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/MsgTypes.hpp>
00016 #include <Gui/MsgTypes.hpp>
00017 #include <Gui/Bitmap.hpp>
00018 #include <Kernel/ExecutionContext.hpp>
00019
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/Win32/Audio.cpp File Reference

Compat/Devices/Win32/Audio.cpp File Reference

#include "PreComp.hpp"
#include "Audio.hpp"
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for Audio.cpp:

Functions

void | PlayDtmf (char *tone, int size)
DWORD WINAPI | PlayTone (LPVOID data)

Variables

Audio::SingleTone aud_tone_alarm_1_data []
Audio::SingleTone broadcast_tone_1_data []
Audio::SingleTone broadcast_tone_2_data []
Audio::SingleTone broadcast_tone_3_data []
Audio::SingleTone broadcast_tone_4_data []
unsigned char | dtmf_tone_0_data []
unsigned char | dtmf_tone_1_data []
unsigned char | dtmf_tone_2_data []
unsigned char | dtmf_tone_3_data []
unsigned char | dtmf_tone_4_data []
unsigned char | dtmf_tone_5_data []
unsigned char | dtmf_tone_6_data []
unsigned char | dtmf_tone_7_data []
unsigned char | dtmf_tone_8_data []
unsigned char | dtmf_tone_9_data []
unsigned char | dtmf_tone_hash_data []
unsigned char | dtmf_tone_star_data []
WAVEFORMATEX | format
BOOLEAN | g_mute = FALSE
Audio::AudioPriority | g_priority = Audio::PriorityNone
BOOLEAN | g_started = FALSE
Audio::ToneData g_tone_data
Audio::SingleTone | g_tones [100] = {0}
HANDLE | hdl = 0
Audio::SingleTone info_tone_connection_data []
Audio::SingleTone info_tone_device_in_data []
Audio::SingleTone info_tone_device_out_data []
Audio::SingleTone info_tone_disconnect_data []
Audio::SingleTone info_tone_free_data []
Audio::SingleTone info_tone_low_bat_data []
Audio::SingleTone info_tone_msg_full_data []
Audio::SingleTone info_tone_power_off_data []
Audio::SingleTone info_tone_power_on_data []
Audio::SingleTone info_tone_ussd_data []
Audio::SingleTone key_tone_1_data []
Audio::SingleTone key_tone_2_data []
Audio::SingleTone key_tone_3_data []
Audio::SingleTone key_tone_4_data []
Audio::SingleTone message_tone_10_data []
Audio::SingleTone message_tone_1_data []
Audio::SingleTone message_tone_2_data []
Audio::SingleTone message_tone_3_data []
Audio::SingleTone message_tone_4_data []
Audio::SingleTone message_tone_5_data []
Audio::SingleTone message_tone_6_data []
Audio::SingleTone message_tone_7_data []
Audio::SingleTone message_tone_8_data []
Audio::SingleTone message_tone_9_data []
Audio::SingleTone message_tone_single_beep_data []
Audio::SingleTone ringing_tone_10_data []
Audio::SingleTone ringing_tone_11_data []
Audio::SingleTone ringing_tone_12_data []
Audio::SingleTone ringing_tone_13_data []
Audio::SingleTone ringing_tone_14_data []
Audio::SingleTone ringing_tone_15_data []
Audio::SingleTone ringing_tone_16_data []
Audio::SingleTone ringing_tone_17_data []
Audio::SingleTone ringing_tone_18_data []
Audio::SingleTone ringing_tone_19_data []
Audio::SingleTone ringing_tone_1_data []
Audio::SingleTone ringing_tone_20_data []
Audio::SingleTone ringing_tone_21_data []
Audio::SingleTone ringing_tone_22_data []
Audio::SingleTone ringing_tone_23_data []
Audio::SingleTone ringing_tone_24_data []
Audio::SingleTone ringing_tone_25_data []
Audio::SingleTone ringing_tone_26_data []
Audio::SingleTone ringing_tone_27_data []
Audio::SingleTone ringing_tone_28_data []
Audio::SingleTone ringing_tone_29_data []
Audio::SingleTone ringing_tone_2_data []
Audio::SingleTone ringing_tone_30_data []
Audio::SingleTone ringing_tone_31_data []
Audio::SingleTone ringing_tone_32_data []
Audio::SingleTone ringing_tone_33_data []
Audio::SingleTone ringing_tone_34_data []
Audio::SingleTone ringing_tone_35_data []
Audio::SingleTone ringing_tone_36_data []
Audio::SingleTone ringing_tone_37_data []
Audio::SingleTone ringing_tone_38_data []
Audio::SingleTone ringing_tone_39_data []
Audio::SingleTone ringing_tone_3_data []
Audio::SingleTone ringing_tone_40_data []
Audio::SingleTone ringing_tone_41_data []
Audio::SingleTone ringing_tone_42_data []
Audio::SingleTone ringing_tone_43_data []
Audio::SingleTone ringing_tone_44_data []
Audio::SingleTone ringing_tone_45_data []
Audio::SingleTone ringing_tone_46_data []
Audio::SingleTone ringing_tone_47_data []
Audio::SingleTone ringing_tone_48_data []
Audio::SingleTone ringing_tone_4_data []
Audio::SingleTone ringing_tone_5_data []
Audio::SingleTone ringing_tone_6_data []
Audio::SingleTone ringing_tone_7_data []
Audio::SingleTone ringing_tone_8_data []
Audio::SingleTone ringing_tone_9_data []
Audio::SingleTone supervisory_tone_call_waiting_data []
Audio::SingleTone supervisory_tone_congestion_data []
Audio::SingleTone supervisory_tone_error_data []
Audio::SingleTone supervisory_tone_radio_path_ack_data []
Audio::SingleTone supervisory_tone_radio_path_not_avail_data []
Audio::SingleTone supervisory_tone_subscriber_busy_data []
WAVEHDR | wav
HWAVEOUT | wav_out

Function Documentation

static void PlayDtmf | ( | char * | tone,
 |  | int | size
 | ) |

static DWORD WINAPI PlayTone ( LPVOID data )

Variable Documentation

Audio::SingleTone aud_tone_alarm_1_data[]

Initial value:

 {
    {2500,   90}, {   0,   60}, {2500,   90}, {   0,  720}
}

Audio::SingleTone broadcast_tone_1_data[]

Initial value:

 {
    { 400, 6000}
}

Audio::SingleTone broadcast_tone_2_data[]

Initial value:

 {
    {1390, 6000}
}

Audio::SingleTone broadcast_tone_3_data[]

Initial value:

 {
    {3900, 6000}
}

Audio::SingleTone broadcast_tone_4_data[]

Initial value:

 {
    {3880, 6000}
}

unsigned char dtmf_tone_0_data[]

unsigned char dtmf_tone_1_data[]

unsigned char dtmf_tone_2_data[]

unsigned char dtmf_tone_3_data[]

unsigned char dtmf_tone_4_data[]

unsigned char dtmf_tone_5_data[]

unsigned char dtmf_tone_6_data[]

unsigned char dtmf_tone_7_data[]

unsigned char dtmf_tone_8_data[]

unsigned char dtmf_tone_9_data[]

unsigned char dtmf_tone_hash_data[]

unsigned char dtmf_tone_star_data[]

WAVEFORMATEX format

BOOLEAN g_mute = FALSE

Audio::AudioPriority g_priority = Audio::PriorityNone

BOOLEAN g_started = FALSE

Audio::ToneData g_tone_data

Audio::SingleTone g_tones[100] = {0}

HANDLE hdl = 0

Audio::SingleTone info_tone_connection_data[]

Initial value:

 {
    {2093,  100}, {1318,  100}, {1568,  100}, {2093,  100}, {   0,   80}
}

Audio::SingleTone info_tone_device_in_data[]

Initial value:

 {
    {1568,  150}, {4186,   80}, {   0,   80}
}

Audio::SingleTone info_tone_device_out_data[]

Initial value:

 {
    {1318,  150}, {2093,   80}, {   0,   80}
}

Audio::SingleTone info_tone_disconnect_data[]

Initial value:

 {
    {1046,   80}, { 932,   80}, { 739,   80}, { 554,   80}, {   0,   20}
}

Audio::SingleTone info_tone_free_data[]

Initial value:

 {
    { 425, 1000}, {   0, 4000}
}

Audio::SingleTone info_tone_low_bat_data[]

Initial value:

 {
    { 697,   60}
}

Audio::SingleTone info_tone_msg_full_data[]

Initial value:

 {
    {2794,   80}, {   0,  200}, {2637,   80}, {   0,  200}
}

Audio::SingleTone info_tone_power_off_data[]

Initial value:

 {
    {   0,   80}, {1109,  160}, { 830,  160}, { 739,  160}, {   0,  160}
}

Audio::SingleTone info_tone_power_on_data[]

Initial value:

 {
    {   0,   80}, { 659,  160}, { 830,  160}, { 987,  160}, {   0,  160}

}

Audio::SingleTone info_tone_ussd_data[]

Initial value:

 {
    { 440,  100}, { 392,  100}, { 440,  100}, { 392,  100}
}

Audio::SingleTone key_tone_1_data[]

Initial value:

 {
    {1000,   10}
}

Audio::SingleTone key_tone_2_data[]

Initial value:

 {
    { 400,   30}
}

Audio::SingleTone key_tone_3_data[]

Initial value:

 {
    {2000,   30}
}

Audio::SingleTone key_tone_4_data[]

Initial value:

 {
    {2500,   20}
}

Audio::SingleTone message_tone_10_data[]

Initial value:

 {
    {   0,  180}, { 523,  120}, { 392,  120}, { 523,  120}, { 659,  120},
    { 783,  180}, {   0,  180}
}

Audio::SingleTone message_tone_1_data[]

Initial value:

 {
    {   0,  180}, { 698,  120}, {   0,  120}, { 587,  120}, {   0,  120},
    { 783,  120}, {   0,  180}
}

Audio::SingleTone message_tone_2_data[]

Initial value:

 {
    {   0,  180}, { 698,  180}, { 739,  180}, { 783,  180}, {   0,  180}
}

Audio::SingleTone message_tone_3_data[]

Initial value:

 {
    {   0,  180}, { 587,  120}, { 622,  120}, { 659,  120}, { 698,  120},
    {   0,  180}
}

Audio::SingleTone message_tone_4_data[]

Initial value:

 {
    {   0,  180}, {1318,  120}, {1046,  120}, {1318,  120}, {1046,  120},
    {   0,  180}
}

Audio::SingleTone message_tone_5_data[]

Initial value:

 {
    {   0,  180}, { 698,  120}, {   0,   60}, { 698,   60}, { 698,   60},
    { 698,  120}, {   0,   60}, { 698,  120}, {   0,   60}, { 698,  120},
    {   0,   60}, { 698,   60}, { 698,   60}, { 698,  120}, {   0,  180}
}

Audio::SingleTone message_tone_6_data[]

Initial value:

 {
    {   0,  180}, { 523,   60}, { 587,   60}, { 659,   60}, { 587,   60},
    { 659,   60}, { 698,   60}, {1046,  180}, {   0,  180}
}

Audio::SingleTone message_tone_7_data[]

Initial value:

 {
    {   0,  180}, { 783,  120}, { 698,  120}, { 659,  120}, { 523,  420},
    {   0,  180}
}

Audio::SingleTone message_tone_8_data[]

Initial value:

 {
    {   0,  180}, { 587,  120}, { 622,  120}, {1318,  120}, { 622,  120},
    { 587,  120}, { 622,  120}, { 659,  120}, {   0,  180}
}

Audio::SingleTone message_tone_9_data[]

Initial value:

 {
    {   0,  180}, { 523,  420}, { 587,  120}, { 659,  120}, { 698,  120},
    {   0,  180}
}

Audio::SingleTone message_tone_single_beep_data[]

Initial value:

 {
    { 697,   60}
}

Audio::SingleTone ringing_tone_10_data[]

Initial value:

 {
    {   0,   90}, { 932,  216}, { 300,  108}, { 932,  108}, {   0,  108},
    { 932,  108}, {   0,  108}, { 932,  108}, { 987,  108}, {   0,  108},
    { 932,  108}, { 300,  108}, {   0,  432}, { 783,  216}, { 300,  108},
    { 783,  108}, {   0,  108}, { 300,  108}, { 739,  216}, {   0, 1296}
}

Audio::SingleTone ringing_tone_11_data[]

Initial value:

 {
    {   0,  100}, { 659,  240}, {1318,  240}, {   0,  240}, {1175,  240},
    { 659,  240}, {1318,  120}, {1175,  120}, { 659,  120}, {1318,  120},
    {1175,  240}, { 932,  240}, {1109,  120}, {1175,  120}, { 659,  120},
    {1318,  120}, {1175,  240}, { 932,  120}, { 932,  120}, {1109,  120},
    {1109,  120}, {1175,  120}, {1175,  120}, {1245,  120}, {1245,  120},
    { 659,  240}, {1318,  240}, {   0,  240}, {1175,  240}, { 659,  240},
    {1318,  120}, {1175,  120}, { 659,  120}, {1318,  120}, {1175,  240},
    { 932,  240}, {1109,  120}, {1175,  120}, { 659,  120}, {1318,  120},
    {1175,  240}, { 932,  480}, {1109,   80}, {1318,   80}, {1760,  200},
    {   0, 1000}
}

Audio::SingleTone ringing_tone_12_data[]

Initial value:

 {
    {   0, 1000}, {1046,   45}, {2093,   45}, {1046,   45}, {2093,   45},
    {4186,   45}, {2093,   45}, {2093,   45}, {4186,   45}, {2093,   45},
    {   0,  720}, {1046,   45}, {2093,   45}, {1046,   45}, {2093,   45},
    {4186,   45}, {2093,   45}, {2093,   45}, {4186,   45}, {2093,   45},
    {   0, 1440}, {1046,   45}, {2093,   45}, {1046,   45}, {2093,   45},
    {4186,   45}, {2093,   45}, {2093,   45}, {4186,   45}, {2093,   45},
    {   0,  720}, {1046,   45}, {2093,   45}, {1046,   45}, {2093,   45},
    {4186,   45}, {2093,   45}, {2093,   45}, {4186,   45}, {2093,   45},
    {   0, 1440}, {1046,   90}, { 494,   90}, {1046,   90}, { 587,   45},
    { 622,   45}, { 659,   90}, { 587,   90}, { 659,   90}, { 698,   45},
    { 739,   45}, { 783,   90}, { 698,   90}, { 783,   90}, { 880,   45},
    { 932,   45}, { 987,   90}, { 880,   90}, { 987,   90}, {2093,   90},
    {2093,   90}, { 987,   90}, {2093,   90}, {1175,   45}, {1245,   45},
    {1318,   90}, {1175,   90}, {1318,   90}, {1397,   45}, {1480,   45},
    {1568,   90}, {1397,   90}, {1568,   90}, {1760,   45}, {1865,   45},
    {1976,   90}, {1760,   90}, {1976,   90}, {4186,   90}, {1976,   90},
    {1760,   90}, {1976,   90}, {1865,   45}, {1760,   45}, {1568,   90},
    {1397,   90}, {1568,   90}, {1480,   45}, {1397,   45}, {1318,   90},
    {1175,   90}, {1318,   90}, {1245,   45}, {1175,   45}, {2093,   90},
    { 987,   90}, {2093,   90}, { 987,   90}, { 880,   90}, { 987,   90},
    { 932,   45}, { 880,   45}, { 783,   90}, { 698,   90}, { 783,   90},
    { 739,   45}, { 698,   45}, { 659,   90}, { 587,   90}, { 659,   90},
    { 622,   45}, { 587,   45}, {1046,   90}, { 494,   90}, {1046,   90}
}

Audio::SingleTone ringing_tone_13_data[]

Initial value:

 {
    {   0, 1000}, {2637,  200}, {2489,  200}, {2637,  200}, {2489,  200},
    {2637,  200}, {1976,  200}, {2349,  200}, {2093,  200}, {1760,  200},
    { 659,  200}, { 880,  200}, {1046,  200}, {1318,  200}, {1760,  200},
    {1976,  200}, { 659,  200}, { 830,  200}, {1318,  200}, {1661,  200},
    {1976,  200}, {2093,  200}, { 659,  200}, { 880,  200}, {1318,  200},
    {2637,  200}, {2489,  200}, {2637,  200}, {2489,  200}, {2637,  200},
    {1976,  200}, {2349,  200}, {2093,  200}, {1760,  200}, { 659,  200},
    { 880,  200}, {1046,  200}, {1318,  200}, {1760,  200}, {1976,  200},
    { 659,  200}, { 830,  200}, {1318,  200}, {2093,  200}, {1976,  200},
    {1760,  200}, { 659,  200}, { 880,  200}, {1976,  200}, {2093,  200},
    {2349,  200}, {2637,  200}, { 783,  200}, {1046,  200}, {1568,  200},
    {2794,  200}, {2637,  200}, {2349,  200}, { 783,  200}, { 987,  200},
    {1397,  200}, {2637,  200}, {2349,  200}, {2093,  200}, { 659,  200},
    { 880,  200}, {1318,  200}, {2349,  200}, {2093,  200}, {1976,  200},
    {1318,  200}, {2637,  200}, {1318,  200}, {2637,  200}, {2637,  200},
    {2637,  200}, {2489,  200}, {2637,  200}, {2489,  200}, {2637,  200},
    {2489,  200}, {2637,  200}, {2489,  200}, {2637,  200}, {2489,  200},
    {2637,  200}, {2489,  200}, {2637,  200}, {2489,  200}, {2637,  200},
    {1976,  200}, {2349,  200}, {2093,  200}, {1760,  200}, { 659,  200},
    { 880,  200}, {1046,  200}, {1318,  200}, {1760,  200}, {1976,  200},
    { 659,  200}, { 830,  200}, {1318,  200}, {1661,  200}, {1976,  200},
    {2093,  200}, { 659,  200}, { 880,  200}, {1318,  200}, {2637,  200},
    {2489,  200}, {2637,  200}, {2489,  200}, {2637,  200}, {1976,  200},
    {2349,  200}, {2093,  200}, {1760,  200}, { 659,  200}, { 880,  200},
    {1046,  200}, {1318,  200}, {1760,  200}, {1976,  200}, { 659,  200},
    { 830,  200}, {1318,  200}, {2093,  200}, {1976,  200}, {1760,  200},
    { 659,  200}, { 880,  600}
}

Audio::SingleTone ringing_tone_14_data[]

Initial value:

 {
    {   0, 1000}, {1046,  120}, {1175,  120}, {1318,  240}, {1568,  240},
    {1568,  240}, {1760,  240}, {1568,  240}, {1318,  240}, {1046,  360},
    {1175,  120}, {1318,  240}, {1318,  240}, {1175,  240}, {1046,  240},
    {1175,  480}, {   0,  240}, {1046,  120}, {1175,  120}, {1318,  240},
    {1568,  240}, {1568,  240}, {1760,  240}, {1568,  240}, {1318,  240},
    {1046,  360}, {1175,  120}, {1318,  240}, {1318,  240}, {1175,  240},
    {1175,  240}, {1046,  480}, {   0,  240}, {1046,  120}, {1175,  120},
    {1318,  240}, {1568,  240}, {1568,  240}, {1760,  240}, {1568,  240},
    {1318,  240}, {1046,  360}, {1175,  120}, {1318,  240}, {1318,  240},
    {1175,  240}, {1046,  240}, {1175,  480}, {   0,  240}, {1046,  120},
    {1175,  120}, {1318,  240}, {1568,  240}, {1568,  240}, {1760,  240},
    {1568,  240}, {1318,  240}, {1046,  360}, {1175,  120}, {1318,  240},
    {1318,  240}, {1175,  240}, {1175,  240}, {1046,  480}, {   0,  480},
    {1397,  480}, {1397,  480}, {1760,  240}, {1760,  480}, {1760,  240},
    {1568,  240}, {1568,  240}, {1318,  240}, {1046,  240}, {1175,  480},
    {   0,  240}, {1046,  120}, {1175,  120}, {1318,  240}, {1568,  240},
    {1568,  240}, {1760,  240}, {1568,  240}, {1318,  240}, {1046,  360},
    {1175,  120}, {1318,  240}, {1318,  240}, {1175,  240}, {1175,  240},
    {1046,  480}
}

Audio::SingleTone ringing_tone_15_data[]

Initial value:

 {
    {   0, 1000}, { 494,  130}, { 523,  130}, { 587,  130}, { 523,  130},
    { 494,  130}, { 523,  130}, { 783,  130}, { 698,  130}, { 659,  130},
    { 698,  130}, { 932,  130}, { 880,  130}, { 830,  130}, { 880,  130},
    {1175,  260}, {   0,  390}, {1109,  130}, {1046,  260}, {   0,  390},
    { 987,  130}, { 932,  260}, {   0,  390}, { 830,  130}, { 880,  260},
    {   0,  390}, { 739,  130}, { 783,  780}, {   0,  520}, { 494,  130},
    { 523,  130}, { 587,  130}, { 523,  130}, { 494,  130}, { 523,  130},
    { 698,  130}, { 659,  130}, { 622,  130}, { 659,  130}, { 880,  130},
    { 783,  130}, { 739,  130}, { 783,  130}, {1318,  260}, {   0,  390},
    {1175,  130}, {1109,  260}, {   0,  390}, {1046,  130}, { 987,  260},
    {   0,  390}, { 932,  130}, { 880,  260}, {   0,  390}, { 830,  130},
    { 880,  780}, {   0,  520}, { 494,  130}, { 523,  130}, { 587,  130},
    { 523,  130}, { 494,  130}, { 523,  130}, { 783,  130}, { 698,  130},
    { 659,  130}, { 698,  130}, { 932,  130}, { 880,  130}, { 830,  130},
    { 880,  130}, {1175,  260}, {   0,  390}, {1109,  130}, {1046,  260},
    {   0,  390}, { 880,  130}, {1568,  260}, {   0,  390}, {1480,  130},
    {1397,  260}, {   0,  390}, {1318,  130}, {1397,  520}, { 659,  130},
    { 698,  130}, { 783,  130}, { 698,  130}, { 659,  130}, { 698,  130},
    {1318,  130}, {1175,  130}, {1046,  260}, {   0,  390}, {1046,  130},
    { 987,  260}, {   0,  390}, { 987,  130}, {1046,  520}, { 659,  130},
    { 698,  130}, { 783,  130}, { 698,  130}, { 659,  130}, { 698,  130},
    {1318,  130}, {1175,  130}, {1175,  260}, {1397,  130}, {   0,  130},
    { 880,  130}, {   0,  130}, {1175,  130}, {   0,  130}, { 783,  130},
    {   0,  130}, {1046,  130}, {   0,  130}, { 698,  780}, {   0,  520}
}

Audio::SingleTone ringing_tone_16_data[]

Initial value:

 {
    {   0, 1000}, { 659,  120}, {   0,   15}, { 659,  120}, {   0,   15},
    { 659,  255}, {   0,   15}, { 659,  120}, {   0,   15}, { 659,  120},
    {   0,   15}, { 659,  255}, {   0,   15}, { 659,  135}, { 783,  135},
    { 523,  135}, { 587,  135}, { 659,  510}, {   0,   40}, { 698,  120},
    {   0,   15}, { 698,  120}, {   0,   15}, { 698,  120}, {   0,   15},
    { 698,  120}, {   0,   15}, { 698,  120}, {   0,   15}, { 659,  120},
    {   0,   15}, { 659,  255}, {   0,   15}, { 659,  120}, {   0,   15},
    { 587,  120}, {   0,   15}, { 587,  120}, {   0,   15}, { 659,  120},
    {   0,   15}, { 587,  255}, {   0,   15}, { 783,  255}, {   0,   15},
    { 659,  120}, {   0,   15}, { 659,  120}, {   0,   15}, { 659,  255},
    {   0,   15}, { 659,  120}, {   0,   15}, { 659,  120}, {   0,   15},
    { 659,  255}, {   0,   15}, { 659,  135}, { 783,  135}, { 523,  135},
    { 587,  135}, { 659,  510}, {   0,   30}, { 698,  120}, {   0,   15},
    { 698,  120}, {   0,   15}, { 698,  120}, {   0,   15}, { 698,  120},
    {   0,   15}, { 698,  120}, {   0,   15}, { 659,  120}, {   0,   15},
    { 659,  255}, {   0,   15}, { 783,  120}, {   0,   15}, { 783,  120},
    {   0,   15}, { 698,  120}, {   0,   15}, { 587,  120}, {   0,   15},
    { 523,  720}
}

Audio::SingleTone ringing_tone_17_data[]

Initial value:

 {
    {   0, 1000}, {   0,   20}, { 783,  210}, { 783,  315}, { 880,  105},
    { 783,  210}, {1046,  210}, { 987,  210}, { 880,  210}, { 783,  630},
    { 698,  420}, { 698,  210}, { 659,  420}, { 659,  210}, { 587,  210},
    { 523,  210}, { 587,  210}, { 659,  840}, {   0,  210}, { 783,  210},
    { 783,  315}, { 880,  105}, { 783,  210}, {1046,  210}, { 987,  210},
    { 880,  210}, { 783,  630}, { 698,  420}, { 698,  210}, { 659,  420},
    { 659,  210}, { 783,  210}, { 698,  210}, { 587,  210}, { 523,  840},
    {   0,  210}, { 659,  210}, { 587,  315}, { 659,  105}, { 587,  210},
    { 783,  210}, { 587,  210}, { 587,  210}, { 987,  630}, { 880,  420},
    { 880,  210}, { 783,  420}, { 783,  210}, { 739,  210}, { 783,  210},
    { 880,  210}, { 783,  840}, {   0,  210}, { 783,  210}, { 783,  315},
    { 880,  105}, { 783,  210}, {1046,  210}, { 987,  210}, { 880,  210},
    { 783,  420}, {1318,  210}, {1175,  420}, {1175,  210}, {1046,  420},
    {1046,  210}, { 987,  210}, { 880,  210}, { 987,  210}, {1046,  840},
    {   0,  210}
}

Audio::SingleTone ringing_tone_18_data[]

Initial value:

 {
    {   0, 1000}, {1046,  400}, {1175,  300}, {1046,  100}, { 880,  400},
    { 880,  400}, { 880,  300}, { 783,  100}, { 880,  300}, { 932,  100},
    { 880,  600}, {   0,  200}, { 932,  400}, { 783,  300}, {1046,  100},
    { 880,  600}, {   0,  200}, { 698,  400}, { 587,  300}, { 783,  100},
    { 523,  600}, {   0,  200}, { 783,  800}, { 783,  200}, {1175,  200},
    {1046,  200}, { 932,  200}, { 880,  200}, { 783,  200}, { 880,  200},
    { 932,  200}, { 880,  600}, {   0,  200}, { 659,  400}, { 880,  300},
    { 880,  100}, { 880,  400}, { 830,  300}, { 987,  100}, {1318, 1600},
    {1318,  200}, {1175,  200}, {1109,  200}, {1175,  200}, { 783,  200},
    { 880,  200}, { 932,  400}, {   0,  200}, { 880,  200}, { 698,  200},
    {1175,  200}, {1046,  800}, {   0,  200}, { 698,  200}, { 523,  200},
    { 932,  200}, { 880,  400}, { 783,  400}, { 698,  800}, { 698,  100},
    { 523,  100}, { 587,  100}, { 659,  100}, { 698,  100}, { 783,  100},
    { 880,  100}, { 932,  100}, {1046,  400}, {1175,  300}, {1046,  100},
    { 880,  400}, { 880,  400}, { 880,  300}, { 783,  100}, { 880,  300},
    { 932,  100}, { 880,  600}, {   0,  200}, { 932,  400}, { 783,  300},
    {1046,  100}, { 880,  600}, {   0,  200}, { 698,  400}, { 587,  300},
    { 783,  100}, { 523,  600}, {   0,  200}, { 783,  800}, { 783,  200},
    {1175,  200}, {1046,  200}, { 932,  200}, { 880,  200}, { 783,  200},
    { 880,  200}, { 932,  200}, { 880,  600}, {   0,  200}, { 659,  400},
    { 880,  300}, { 880,  100}, { 880,  400}, { 830,  300}, { 987,  100},
    {1318, 1600}, {1318,  200}, {1175,  200}, {1109,  200}, {1175,  200},
    { 783,  200}, { 880,  200}, { 932,  400}, {   0,  200}, { 880,  200},
    { 698,  200}, {1175,  200}, {1046,  800}, {   0,  200}, { 698,  200},
    { 523,  200}, { 932,  200}, { 880,  400}, { 783,  400}, { 698,  200},
    {   0,  200}, {1046,  300}, {1046,  100}, {1046,  400}, {   0,  400}
}

Audio::SingleTone ringing_tone_19_data[]

Initial value:

 {
    {   0, 1000}, {   0,   20}, {1175,  420}, {1568,  210}, {1976,  420},
    {1760,  210}, {1568,  420}, {1480,  210}, {1568,  210}, {1480,  210},
    {1318,  210}, {1175,  420}, {1175,  210}, { 987,  420}, {1046,  210},
    {1175, 1050}, {   0,  210}, {1046,  420}, {1046,  210}, { 880,  420},
    { 987,  210}, {1046, 1050}, {   0,  210}, {1175,  420}, {1175,  210},
    { 987,  420}, {1046,  210}, {1175, 1050}, {   0,  210}, {1175,  420},
    {1568,  210}, {1976,  420}, {1760,  210}, {1568,  420}, {1480,  210},
    {1568,  210}, {1480,  210}, {1318,  210}, {1175,  420}, {1175,  210},
    { 987,  420}, {1046,  210}, {1175, 1050}, {   0,  210}, {1046,  420},
    {1046,  210}, { 880,  420}, { 987,  210}, {1046, 1050}, {   0,  210},
    {1175,  420}, {1175,  210}, {1976,  420}, {1760,  210}, {1568, 1050},
    {   0,  210}, {1976,  210}, {1976,  105}, {1760,  105}, {1568,  210},
    {1976,  210}, {1976,  105}, {1760,  105}, {1568,  210}, {1976,  210},
    {2093,  315}, {1976,  105}, {1760,  630}, {1760,  210}, {1760,  105},
    {1568,  105}, {1480,  210}, {1760,  210}, {1760,  105}, {1568,  105},
    {1480,  210}, {1760,  210}, {1976,  315}, {1760,  105}, {1568,  630},
    {1976,  210}, {1976,  105}, {1760,  105}, {1568,  210}, {1976,  210},
    {1976,  105}, {1760,  105}, {1568,  210}, {1976,  210}, {2093,  315},
    {1976,  105}, {1760,  630}, {2093,  210}, {1976,  210}, {1760,  210},
    {1568,  210}, {1480,  210}, {1318,  210}, {1175,  210}, {1318,  210},
    {1480,  210}, {1568,  630}
}

Audio::SingleTone ringing_tone_1_data[]

Initial value:

 {
    {   0, 1000}, {2794,   60}, {4186,   60}, {2794,   60}, {4186,   60},
    {2794,   60}, {4186,   60}, {2794,   60}, {4186,   60}, {2794,   60},
    {4186,   60}, {2794,   60}, {4186,   60}, {2794,   60}, {4186,   60},
    {2794,   60}, {4186,   60}, {2794,   60}, {4186,   60}, {2794,   60},
    {4186,   60}, {2794,   60}, {4186,   60}, {2794,   60}, {4186,   60},
    {2794,   60}, {4186,   60}, {2794,   60}, {4186,   60}, {2794,   60},
    {4186,   60}, {2794,   60}, {4186,   60}
}

Audio::SingleTone ringing_tone_20_data[]

Audio::SingleTone ringing_tone_21_data[]

Audio::SingleTone ringing_tone_22_data[]

Initial value:

 {
    {   0, 1000}, { 659,  340}, {   0,   20}, { 659,  180}, { 587,  180},
    { 523,  340}, {   0,   20}, { 523,  360}, { 587,  340}, {   0,   20},
    { 587,  360}, { 659,  180}, { 587,  180}, { 523,  360}, { 783,  340},
    {   0,   20}, { 783,  180}, { 698,  180}, { 659,  340}, {   0,   20},
    { 659,  360}, { 587,  180}, { 523,  180}, { 587,  180}, { 659,  180},
    { 523,  360}, {   0,  360}, { 659,  340}, {   0,   20}, { 659,  180},
    { 698,  180}, { 783,  340}, {   0,   20}, { 783,  360}, { 880,  340},
    {   0,   20}, { 880,  360}, { 783,  180}, { 698,  180}, { 659,  340},
    {   0,   20}, { 659,  340}, {   0,   20}, { 659,  180}, { 698,  180},
    { 783,  340}, {   0,   20}, { 783,  360}, { 880,  340}, {   0,   20},
    { 880,  360}, { 783,  360}, {   0,  360}, { 659,  340}, {   0,   20},
    { 659,  180}, { 587,  180}, { 523,  340}, {   0,   20}, { 523,  360},
    { 587,  340}, {   0,   20}, { 587,  360}, { 659,  180}, { 587,  180},
    { 523,  360}, { 783,  340}, {   0,   20}, { 783,  180}, { 698,  180},
    { 659,  340}, {   0,   20}, { 659,  360}, { 587,  180}, { 523,  180},
    { 587,  180}, { 659,  180}, { 523,  360}, {   0,  360}, { 659,  340},
    {   0,   20}, { 659,  180}, { 587,  180}, { 523,  340}, {   0,   20},
    { 523,  360}, { 587,  340}, {   0,   20}, { 587,  180}, { 698,  180},
    { 659,  180}, { 587,  180}, { 523,  360}, { 783,  340}, {   0,   20},
    { 783,  180}, { 698,  180}, { 659,  340}, {   0,   20}, { 659,  360},
    { 587,  180}, { 698,  180}, { 659,  180}, { 587,  180}, { 523,  360},
    {   0,  360}
}

Audio::SingleTone ringing_tone_23_data[]

Initial value:

 {
    {   0, 1000}, { 783,  370}, {   0,   30}, { 523,  200}, { 587,  200},
    { 659,  200}, { 698,  200}, { 783,  370}, {   0,   30}, { 523,  370},
    {   0,   30}, { 523,  400}, { 880,  370}, {   0,   30}, { 698,  200},
    { 783,  200}, { 880,  200}, { 987,  200}, {1046,  370}, {   0,   30},
    { 523,  370}, {   0,   30}, { 523,  400}, { 698,  370}, {   0,   30},
    { 783,  200}, { 698,  200}, { 659,  200}, { 587,  200}, { 659,  370},
    {   0,   30}, { 698,  200}, { 659,  200}, { 587,  200}, { 523,  200},
    { 494,  370}, {   0,   30}, { 523,  200}, { 587,  200}, { 659,  200},
    { 523,  200}, { 659,  370}, {   0,   30}, { 587,  600}, {   0,  200},
    { 783,  370}, {   0,   30}, { 523,  200}, { 587,  200}, { 659,  200},
    { 698,  200}, { 783,  370}, {   0,   30}, { 523,  370}, {   0,   30},
    { 523,  400}, { 880,  370}, {   0,   30}, { 698,  200}, { 783,  200},
    { 880,  200}, { 987,  200}, {1046,  370}, {   0,   30}, { 523,  370},
    {   0,   30}, { 523,  400}, { 698,  370}, {   0,   30}, { 783,  200},
    { 698,  200}, { 659,  200}, { 587,  200}, { 659,  370}, {   0,   30},
    { 698,  200}, { 659,  200}, { 587,  200}, { 523,  200}, { 587,  370},
    {   0,   30}, { 659,  200}, { 587,  200}, { 523,  200}, { 494,  200},
    { 523, 1000}
}

Audio::SingleTone ringing_tone_24_data[]

Initial value:

 {
    {   0, 1000}, { 587,  400}, { 783,  800}, { 987,  280}, {   0,   20},
    { 987,  100}, { 932,  300}, { 987,  100}, {1175,  300}, {1046,  100},
    { 987,  300}, {1046,  550}, {   0,   50}, {1175,  400}, { 880,  780},
    {   0,   20}, { 880,  280}, {   0,   20}, { 880,  100}, { 830,  300},
    { 880,  100}, {1046,  300}, { 987,  100}, { 932,  300}, { 987,  850},
    {   0,   50}, { 783,  300}, { 739,  100}, { 783,  300}, { 987,  580},
    {   0,   20}, { 987,  400}, { 880,  300}, { 830,  100}, { 880,  300},
    { 987,  100}, {1046,  750}, {   0,   50}, {1175,  950}, {   0,   50},
    {1175,  100}, {1046,  300}, { 987,  100}, { 880,  300}, { 783,  650},
    {   0,   50}, { 783,   80}, {   0,   20}, { 783,  300}, {1175,  100},
    {1318,  300}, {1175,  600}, {   0,  200}, {1046,  300}, {1175,  100},
    { 987,  600}
}

Audio::SingleTone ringing_tone_25_data[]

Audio::SingleTone ringing_tone_26_data[]

Audio::SingleTone ringing_tone_27_data[]

Initial value:

 {
    {   0, 1000}, { 523,  180}, {   0,   20}, { 523,  200}, { 587,  400},
    { 523,  400}, { 698,  400}, { 659,  760}, {   0,   40}, { 523,  180},
    {   0,   20}, { 523,  200}, { 587,  400}, { 523,  400}, { 783,  400},
    { 698,  400}, {   0,  400}, { 523,  180}, {   0,   20}, { 523,  200},
    {1046,  400}, { 880,  400}, { 698,  400}, { 659,  400}, { 587,  800},
    { 932,  180}, {   0,   20}, { 932,  200}, { 880,  400}, { 698,  400},
    { 783,  400}, { 698,  800}, {   0,  400}, { 523,  180}, {   0,   20},
    { 523,  200}, { 587,  400}, { 523,  400}, { 698,  400}, { 659,  760},
    {   0,   40}, { 523,  180}, {   0,   20}, { 523,  200}, { 587,  400},
    { 523,  400}, { 783,  400}, { 698,  400}, {   0,  400}, { 523,  180},
    {   0,   20}, { 523,  200}, {1046,  400}, { 880,  400}, { 698,  400},
    { 659,  400}, { 587,  400}, { 932,  180}, {   0,   20}, { 932,  200},
    { 880,  400}, { 698,  400}, { 783,  400}, { 698,  800}
}

Audio::SingleTone ringing_tone_28_data[]

Initial value:

 {
    {   0, 1000}, { 523,  210}, { 587,  210}, { 659,  400}, {   0,   20},
    { 659,  210}, { 783,  210}, { 698,  400}, {   0,   20}, { 698,  210},
    { 880,  210}, { 783,  400}, {   0,   20}, { 783,  210}, { 698,  210},
    { 659,  840}, { 783,  400}, {   0,   20}, { 783,  210}, { 698,  210},
    { 659,  400}, {   0,   20}, { 659,  210}, { 783,  210}, { 698,  400},
    {   0,   20}, { 698,  420}, { 587,  420}, { 783,  420}, { 659, 1050},
    { 523,  210}, { 659,  210}, { 587,  630}, { 659,  210}, { 698,  420},
    { 587,  420}, { 659,  630}, { 698,  210}, { 783,  400}, {   0,   20},
    { 783,  420}, { 880,  400}, {   0,   20}, { 880,  420}, {1046,  420},
    { 987,  210}, { 880,  210}, { 783, 1050}, { 523,  210}, { 659,  210},
    { 783,  420}, { 783,  210}, { 880,  210}, { 783,  420}, { 783,  210},
    {1046,  210}, { 783,  420}, { 783,  210}, { 698,  210}, { 659,  840},
    { 783,  420}, { 783,  210}, { 698,  210}, { 659,  420}, { 659,  210},
    { 783,  210}, { 698,  420}, { 698,  420}, { 587,  420}, { 783,  420},
    { 659,  840}
}

Audio::SingleTone ringing_tone_29_data[]

Initial value:

 {
    {   0, 1000}, { 622,  480}, { 370,  240}, { 622,  240}, { 554,  240},
    { 494,  240}, { 466,  240}, { 494,  240}, { 659,  460}, {   0,   20},
    { 659,  460}, {   0,   20}, { 659,  700}, {   0,   20}, { 370,  240},
    { 622,  480}, { 392,  240}, { 622,  240}, { 554,  240}, { 494,  240},
    { 466,  240}, { 494,  240}, { 554, 1680}, { 587,  240}, { 622,  480},
    { 370,  240}, { 622,  240}, { 554,  240}, { 494,  240}, { 466,  240},
    { 494,  240}, { 830,  460}, {   0,   20}, { 830,  460}, {   0,   20},
    { 830,  460}, {   0,   20}, { 739,  240}, { 659,  240}, { 622,  480},
    { 554,  240}, { 494,  240}, { 415,  480}, { 466,  480}, { 494,  480},
    { 330,  480}, { 311,  480}, { 739,  480}, {1245,  480}, { 739,  240},
    {1245,  240}, {1109,  240}, { 987,  240}, { 932,  240}, { 987,  240},
    {1318,  460}, {   0,   20}, {1318,  460}, {   0,   20}, {1318,  700},
    {   0,   20}, { 739,  240}, {1245,  480}, { 783,  240}, {1245,  240},
    {1109,  240}, { 987,  240}, { 932,  240}, { 987,  240}, {1109, 1680},
    {1175,  240}, {1245,  480}, { 739,  240}, {1245,  240}, {1109,  240},
    { 987,  240}, { 932,  240}, { 987,  240}, {1661,  460}, {   0,   20},
    {1661,  460}, {   0,   20}, {1661,  460}, {   0,   20}, {1480,  240},
    {1318,  240}, {1245,  480}, {1109,  240}, { 987,  240}, { 830,  480},
    { 932,  480}, { 987,  480}, { 330,  480}, { 311,  960}
}

Audio::SingleTone ringing_tone_2_data[]

Initial value:

 {
    {   0, 1000}, {2349,   60}, {2637,   60}, {1397,   60}, {1568,   60},
    {2349,   60}, {2637,   60}, {1397,   60}, {1568,   60}, {2349,   60},
    {2637,   60}, {1397,   60}, {1568,   60}, {2349,   60}, {2637,   60},
    {1397,   60}, {1568,   60}, {2349,   60}, {2637,   60}, {1397,   60},
    {1568,   60}
}

Audio::SingleTone ringing_tone_30_data[]

Initial value:

 {
    {   0, 1000}, { 659,  580}, {   0,   20}, { 659,  450}, { 587,  150},
    { 523,  150}, { 587,  150}, { 659,  150}, { 698,  150}, { 783,  300},
    { 659,  300}, {1046,  300}, { 783,  300}, {1318,  300}, {   0,  300},
    { 587,  580}, {   0,   20}, { 587,  450}, { 659,  150}, { 587,  150},
    { 523,  150}, { 494,  150}, { 440,  150}, { 392,  300}, { 494,  300},
    { 587,  300}, { 494,  300}, { 783,  300}, {   0,  300}, { 523,  580},
    {   0,   20}, { 523,  600}, { 587,  150}, { 523,  150}, { 494,  150},
    { 523,  150}, { 587,  300}, { 659,  300}, { 698,  300}, { 783,  300},
    { 880,  300}, {   0,  300}, { 587,  580}, {   0,   20}, { 587,  600},
    { 587,  150}, { 523,  150}, { 587,  150}, { 659,  150}, { 523,  900}
}

Audio::SingleTone ringing_tone_31_data[]

Initial value:

 {
    {   0, 1000}, { 392,  300}, { 523,  580}, {   0,   20}, { 523,  150},
    { 587,  150}, { 659,  150}, { 698,  150}, { 783,  600}, { 659,  280},
    {   0,   20}, { 659,  300}, { 587,  300}, { 783,  300}, { 587,  300},
    { 783,  300}, { 659,  150}, { 698,  150}, { 659,  150}, { 587,  150},
    { 523,  250}, {   0,   50}, { 392,  300}, { 523,  580}, {   0,   20},
    { 523,  150}, { 587,  150}, { 659,  150}, { 698,  150}, { 783,  600},
    { 659,  280}, {   0,   20}, { 659,  300}, { 587,  300}, { 783,  300},
    { 987,  300}, { 880,  300}, { 783,  900}
}

Audio::SingleTone ringing_tone_32_data[]

Initial value:

 {
    {   0, 1000}, { 392, 1080}, { 440,  270}, { 392,  270}, { 523,  270},
    { 587,  270}, { 659, 1080}, { 783, 1080}, { 698,  540}, { 659,  540},
    { 587,  180}, { 659,   90}, { 587,   90}, { 523,   90}, { 587,   90},
    { 659,  405}, { 523,  135}, { 392, 1080}, { 440, 2160}, { 466,  270},
    { 440,  270}, { 587,  270}, { 659,  270}, { 698,  540}, { 659,  540},
    { 587,  540}, { 659,  540}, { 523, 1080}, { 659,  810}, { 587,  225},
    {   0,   45}, { 587, 2160}, { 392, 1080}, { 440,  270}, { 392,  270},
    { 523,  270}, { 587,  270}, { 659, 1080}, { 783, 1080}, { 698,  540},
    { 659,  540}, { 587,  180}, { 659,   90}, { 587,   90}, { 523,   90},
    { 587,   90}, { 659,  405}, { 523,  135}, { 392, 1080}, { 440, 2160},
    { 466,  270}, { 440,  270}, { 587,  270}, { 659,  270}, { 698,  540},
    { 659,  540}, { 587,  540}, { 659,  540}, { 523,  720}, { 370,   90},
    { 392,   90}, { 440,   90}, { 392,   90}, { 659,  810}, { 587,  225},
    {   0,   45}, { 587, 1080}, { 523, 1080}
}

Audio::SingleTone ringing_tone_33_data[]

Initial value:

 {
    {   0, 1000}, { 659,  360}, { 698,  120}, { 783,  360}, { 739,  120},
    { 783,  360}, { 739,  120}, { 783,  360}, { 739,  120}, { 783,  960},
    { 880,  360}, { 659,  120}, { 698,  960}, { 783,  360}, { 587,  120},
    { 659,  480}, {   0,  480}, { 523,  360}, { 587,  120}, { 659,  360},
    { 622,  120}, { 659,  360}, { 622,  120}, { 659,  360}, { 622,  120},
    { 659,  960}, { 587,  240}, { 523,  220}, {   0,   20}, { 523,  240},
    { 494,  220}, {   0,   20}, { 494,  240}, { 587,  240}, { 523,  240},
    { 440,  240}, { 392,  480}, {   0,  480}, { 783,  240}, {1046,  240},
    {1046,  480}, { 987,  480}, {1046,  480}, {1175,  960}, {1046,  120},
    { 987,  120}, { 880,  120}, { 783,  120}, { 698,  480}, { 659,  480},
    { 880,  360}, { 698,  120}, { 659,  480}, { 587,  240}, {   0,  240},
    { 523,  360}, { 587,  120}, { 659,  360}, { 622,  120}, { 659,  360},
    { 622,  120}, { 659,  360}, { 622,  120}, { 659,  960}, { 698,  360},
    { 554,  120}, { 587,  960}, { 659,  360}, { 494,  120}, { 523,  480},
    {   0,  480}
}

Audio::SingleTone ringing_tone_34_data[]

Initial value:

 {
    {   0, 1000}, { 880,  250}, {1046,  500}, {1175,  250}, {1318,  375},
    {1397,  125}, {1318,  250}, {1175,  500}, { 987,  250}, { 783,  375},
    { 880,  125}, { 987,  250}, {1046,  500}, { 880,  250}, { 880,  375},
    { 830,  125}, { 880,  250}, { 987,  500}, { 783,  250}, { 659,  500},
    { 880,  250}, {1046,  500}, {1175,  250}, {1318,  375}, {1397,  125},
    {1318,  250}, {1175,  500}, { 987,  250}, { 783,  375}, { 880,  125},
    { 987,  250}, {1046,  375}, { 987,  125}, { 880,  250}, { 830,  375},
    { 739,  125}, { 830,  250}, { 880, 1250}, {   0,  250}, {1568,  750},
    {1568,  375}, {1480,  125}, {1318,  250}, {1175,  500}, { 987,  250},
    { 783,  375}, { 880,  125}, { 987,  250}, {1046,  500}, { 880,  250},
    { 880,  375}, { 830,  125}, { 880,  250}, { 987,  500}, { 783,  250},
    { 659,  750}, {1568,  750}, {1568,  375}, {1480,  125}, {1318,  250},
    {1175,  500}, { 987,  250}, { 783,  375}, { 880,  125}, { 987,  250},
    {1046,  375}, { 987,  125}, { 880,  250}, { 830,  375}, { 739,  125},
    { 830,  250}, { 880, 1250}
}

Audio::SingleTone ringing_tone_35_data[]

Initial value:

 {
    {   0, 1000}, { 330,  150}, { 392,  150}, { 659,  150}, { 523,  150},
    { 330,  150}, { 392,  150}, { 659,  150}, { 523,  150}, { 330,  150},
    { 392,  150}, { 659,  150}, { 523,  150}, { 330,  150}, { 392,  150},
    { 659,  150}, { 523,  150}, {1046,  600}, { 987,  600}, { 659,  600},
    { 880,  600}, { 783,  600}, { 523,  600}, { 587, 1200}, { 587,  300},
    { 659,  300}, { 698, 1200}, {   0,  600}, { 440, 1200}, { 494,  300},
    { 523,  300}, { 587,  300}, { 659,  300}, { 698,  300}, { 783,  300},
    { 880,  300}, { 987,  300}, {1318, 1800}, { 659,  300}, {   0,  300},
    {   0, 1200}, {1046,  600}, { 987,  600}, { 659,  600}, { 880,  600},
    { 783,  600}, { 523,  600}, { 587, 1200}, { 587,  300}, { 659,  300},
    { 698, 1200}, {   0,  600}, { 494,  900}, { 554,  300}, { 622,  300},
    { 659,  300}, { 739,  300}, { 783,  300}, { 880,  300}, { 987,  300},
    {1109,  300}, {1245,  300}, {1568, 2100}
}

Audio::SingleTone ringing_tone_36_data[]

Initial value:

 {
    {   0, 1000}, {1046,  400}, {1318,  600}, {1397,  200}, {1397,  400},
    {1568,  400}, {1568,  800}, {1318,  400}, {1568,  400}, {1397,  600},
    {1318,  200}, {1397,  400}, {1175,  400}, {1318,  800}, {   0,  400},
    {1046,  400}, {1318,  600}, {1397,  200}, {1397,  400}, {1568,  400},
    {1568,  600}, {1318,  200}, {1318,  400}, {1568,  400}, {1397,  600},
    {1318,  200}, {1397,  400}, {1175,  400}, {1046,  800}, {   0,  400},
    {1568,  400}, {2093,  600}, {1976,  200}, {1760,  400}, {1568,  400},
    {1568,  800}, {1318,  400}, {1568,  400}, {1397,  600}, {1318,  200},
    {1397,  400}, {1175,  400}, {1318,  800}, {   0,  400}, {1568,  400},
    {2093,  600}, {1976,  200}, {1760,  400}, {1568,  400}, {1568,  800},
    {1318,  400}, {1568,  400}, {1397,  600}, {1318,  200}, {1397,  400},
    {1175,  400}, {1046, 1200}, {   0,  400}, {1568, 1600}, {1397,  800},
    {1175,  800}, {1046,  800}, {1175,  800}, {1318,  800}, {   0,  400},
    {1568,  400}, {2093,  600}, {1976,  200}, {1760,  400}, {1568,  400},
    {1568,  800}, {1318,  400}, {1568,  400}, {1397,  600}, {1318,  200},
    {1397,  400}, {1175,  400}, {1046,  800}
}

Audio::SingleTone ringing_tone_37_data[]

Audio::SingleTone ringing_tone_38_data[]

Initial value:

 {
    {   0, 1000}, { 523,  240}, { 392,  100}, {   0,   20}, { 392,  120},
    { 330,  240}, { 392,  240}, { 523,  240}, { 392,  100}, {   0,   20},
    { 392,  120}, { 330,  240}, { 392,  240}, { 523,  240}, { 392,  240},
    { 523,  240}, { 392,  240}, { 523,  240}, { 392,  240}, { 330,  240},
    { 392,  240}, { 523,  240}, { 392,  240}, { 523,  240}, { 330,  240},
    { 392,  940}, {   0,   20}, { 783,  480}, { 698,  240}, { 659,  240},
    { 587,  480}, { 659,  240}, { 587,  240}, { 523,  480}, { 587,  240},
    { 659,  240}, { 392,  360}, { 440,  120}, { 392,  240}, {   0,  240},
    { 783,  480}, { 698,  240}, { 659,  240}, { 880,  480}, { 783,  240},
    { 659,  240}, { 698,  240}, { 783,  120}, { 698,  120}, { 659,  240},
    { 698,  120}, { 659,  120}, { 587,  100}, {   0,   20}, { 587,  120},
    { 659,  120}, { 698,  120}, { 783,  120}, { 880,  120}, { 987,  120},
    {1046,  120}, {1175,  240}, { 587,  100}, {   0,   20}, { 587,  120},
    { 523,  240}, { 587,  240}, { 659,  240}, { 698,  240}, { 783,  480},
    { 587,  240}, { 659,  240}, { 698,  480}, { 659,  240}, { 587,  240},
    { 523,  480}, { 587,  220}, {   0,   20}, { 587,  100}, {   0,   20},
    { 587,  120}, { 523,  240}, { 587,  240}, { 659,  240}, { 698,  240},
    { 783,  480}
}

Audio::SingleTone ringing_tone_39_data[]

Audio::SingleTone ringing_tone_3_data[]

Initial value:

 {
    {   0, 1000}, {1175,   80}, {1397,   80}, {1318,   80}, {1568,   80},
    {1318,   80}, {1397,   80}, {1175,   80}, {1397,   80}, {1318,   80},
    {1568,   80}, {1318,   80}, {1397,   80}, {1175,   80}, {1397,   80},
    {1318,   80}, {1568,   80}, {1318,   80}, {1397,   80}, {1175,   80}
}

Audio::SingleTone ringing_tone_40_data[]

Initial value:

 {
    {   0, 1000}, {2093,  180}, {1976,  180}, {2093,  180}, {1568,  540},
    {1318,  540}, {1175,  180}, {1109,  180}, {1175,  180}, {1760, 1080},
    {1568,  180}, {1976,  180}, {1760,  180}, {1760,  180}, {1568,  180},
    {1397,  180}, {1397,  180}, {1318,  180}, {1175,  180}, {1318, 1620},
    {2093,  180}, {1976,  180}, {2093,  180}, {1568,  540}, {1318,  540},
    {1175,  180}, {1109,  180}, {1175,  180}, {1760, 1080}, {1568,  180},
    {1976,  180}, {1760,  180}, {1760,  180}, {1568,  180}, {1397,  180},
    {1397,  180}, {1318,  180}, {1175,  180}, {1046, 1620}, {1568,  180},
    {1397,  180}, {1175,  180}, { 987,  540}, {1760,  540}, {1760,  180},
    {1568,  180}, {1318,  180}, {1046, 1080}, {2093,  180}, {1976,  180},
    {2093,  180}, {1760,  540}, {2349,  360}, {2093,  180}, {1976,  180},
    {2093,  180}, {1760,  180}, {1568, 1080}, {2093,  180}, {1976,  180},
    {2093,  180}, {1568,  540}, {1318,  540}, {1175,  180}, {1109,  180},
    {1175,  180}, {1760, 1080}, {1568,  180}, {1976,  180}, {1760,  180},
    {1760,  180}, {1568,  180}, {1397,  180}, {1397,  180}, {1318,  180},
    {1175,  180}, {1318, 1620}, {1760,  180}, {1976,  180}, {2093,  180},
    {2093,  180}, {1568,  180}, {1318,  180}, {1397,  180}, {1318,  180},
    {1175,  180}, {1046, 1620}
}

Audio::SingleTone ringing_tone_41_data[]

Audio::SingleTone ringing_tone_42_data[]

Initial value:

 {
    {   0, 1000}, {1046,  170}, {1046,  170}, {1397,  170}, {1397,  170},
    {1760,  170}, {1760,  170}, {2093,  340}, {1760,  680}, {2093,  170},
    {2093,  170}, {2349,  170}, {2093,  170}, {1865,  170}, {1760,  170},
    {1865,  340}, {1568,  680}, {1046,  170}, {1046,  170}, {1318,  170},
    {1318,  170}, {1568,  170}, {1568,  170}, {1865,  340}, {1568,  680},
    {2093,  170}, {2349,  170}, {2093,  170}, {1865,  170}, {1760,  170},
    {1568,  170}, {1760,  340}, {1397,  680}, {1046,  170}, {1046,  170},
    {1397,  170}, {1397,  170}, {1760,  170}, {1760,  170}, {2093,  340},
    {1760,  680}, {2093,  170}, {2093,  170}, {2349,  170}, {2093,  170},
    {1865,  170}, {1760,  170}, {1865,  340}, {1568,  680}, {1046,  170},
    {1046,  170}, {1318,  170}, {1318,  170}, {1568,  170}, {1568,  170},
    {1865,  340}, {1568,  680}, {2093,  170}, {2349,  170}, {2093,  170},
    {1865,  170}, {1760,  170}, {1568,  170}, {1397,  510}, {1046,  170},
    {1046,  170}, {1046,  170}, {1397,  340}, {1760,  170}, {1046,  170},
    {1046,  170}, {1046,  170}, {1397,  340}, {1760,  680}, {1397,  170},
    {1318,  170}, {1397,  170}, {1318,  170}, {1397,  170}, {1480,  170},
    {1568,  510}, {1046,  170}, {1046,  170}, {1046,  170}, {1318,  340},
    {1568,  170}, {1046,  170}, {1046,  170}, {1046,  170}, {1318,  340},
    {1568,  680}, {2093,  170}, {2349,  170}, {2093,  170}, {1865,  170},
    {1760,  170}, {1568,  170}, {1397,  510}, {1046,  170}, {1046,  170},
    {1046,  170}, {1397,  340}, {1760,  170}, {1046,  170}, {1046,  170},
    {1046,  170}, {1397,  340}, {1760,  680}, {1397,  170}, {1318,  170},
    {1397,  170}, {1318,  170}, {1397,  170}, {1480,  170}, {1568,  510},
    {1046,  170}, {1046,  170}, {1046,  170}, {1318,  340}, {1568,  170},
    {1046,  170}, {1046,  170}, {1046,  170}, {1318,  340}, {1568,  680},
    {2093,  170}, {2349,  170}, {2093,  170}, {1865,  170}, {1760,  170},
    {1568,  170}, {1397,  850}
}

Audio::SingleTone ringing_tone_43_data[]

Initial value:

 {
    {   0, 1000}, { 783,  210}, { 739,  210}, { 783,  210}, { 659,  840},
    {   0,  105}, { 659,  210}, { 622,  210}, { 659,  210}, { 523,  840},
    {   0,  105}, { 659,  210}, { 587,  210}, { 523,  210}, { 587,  840},
    {   0,  105}, { 783,  210}, { 880,  210}, { 783,  210}, { 659,  840},
    {   0,  105}, { 783,  210}, { 880,  210}, { 987,  210}, {1046,  420},
    { 783,  420}, { 659,  420}, { 523,  420}, { 880,  840}, {   0,  105},
    { 880,  210}, { 987,  210}, { 880,  210}, { 783,  420}, { 698,  420},
    { 659,  420}, { 587,  420}, { 523,  840}, {   0,  200}
}

Audio::SingleTone ringing_tone_44_data[]

Initial value:

 {
    {   0, 1000}, { 987,  360}, {   0,   72}, { 880,  324}, { 659,  108},
    { 783,  288}, {   0,   36}, { 783,  540}, { 987,  360}, {   0,   72},
    { 880,  324}, { 659,  108}, { 783,  288}, {   0,   36}, { 783,  540},
    { 783,  432}, { 987,  288}, {   0,   36}, { 987,  108}, { 880,  324},
    { 987,  108}, { 783,  288}, {   0,   36}, { 783,  108}, { 659,  144},
    { 783,  144}, { 659,  144}, { 783,  288}, {   0,   36}, { 783,  108},
    { 659,  144}, { 783,  144}, { 659,  144}, { 783,  288}, {   0,   36},
    { 783,  108}, { 494,  288}, {   0,   36}, { 587,  108}, { 659,  324},
    { 587,  324}, {   0,  108}, { 987,  108}, { 880,  288}, {   0,   36},
    { 783,  108}, { 587,  288}, {   0,   36}, { 783,  108}, { 880,  324},
    { 783,  324}, {   0,  216}, { 783,  144}, { 880,  144}, { 783,  144},
    { 659,   72}, {   0,   36}, { 659,  324}, { 587,  144}, { 659,  144},
    { 587,  144}, { 783,  216}, {   0,   72}, { 783,  432}
}

Audio::SingleTone ringing_tone_45_data[]

Initial value:

 {
    {   0, 1000}, { 659,  360}, { 880,  180}, { 659,  360}, { 880,  160},
    {   0,   20}, { 880,  520}, {   0,   20}, { 659,  360}, { 880,  180},
    { 659,  360}, { 880,  160}, {   0,   20}, { 880,  520}, {   0,   20},
    { 880,  160}, {   0,   20}, { 880,  340}, {   0,   20}, { 880,  360},
    {1046,  160}, {   0,   20}, {1046,  180}, { 987,  360}, { 880,  900},
    {1046,  180}, { 987,  180}, {1046,  360}, { 659,  900}, { 880,  160},
    {   0,   20}, { 880,  520}, {   0,   20}, { 880,  520}, {   0,   20},
    { 880,  540}, {1046,  180}, { 987,  360}, { 880,  360}, {1046,  160},
    {   0,   20}, {1046,  180}, { 987,  360}, { 659,  540}, { 880,  360},
    {   0,  180}, { 880,  900}, {   0,  180}, {1046,  360}, {   0,  180},
    {1046, 1080}, {1318,  360}, {   0,  180}, {1318,  520}, {   0,   20},
    {1318,  540}, { 880,  360}, {1046,  160}, {   0,   20}, {1046,  360},
    {1318,  180}, {1046,  180}, { 987,  360}, { 880,  540}, { 659,  900},
    {   0,  180}, { 880,  160}, {   0,   20}, { 880,  340}, {   0,   20},
    { 880,  540}, {1046,  540}, {1318,  160}, {   0,   20}, {1318,  360},
    {1046,  360}, {1318,  180}, {1046,  180}, { 987,  360}, { 880,  360},
    {1046,  160}, {   0,   20}, {1046,  180}, { 987,  360}, { 659,  540},
    { 880,  360}, {   0,  180}, { 880,  900}, {   0,  180}
}

Audio::SingleTone ringing_tone_46_data[]

Initial value:

 {
    {   0, 1000}, {1175,  250}, {   0,   10}, {1175,  250}, {   0,   10},
    {1175,  260}, {1046,  750}, {   0,   30}, {1175,  260}, {1397,  260},
    {1175,  260}, {1046,  520}, {1175,  130}, {1046,  130}, { 880,  250},
    {   0,   10}, { 880,  380}, {   0,   10}, { 880,  120}, {   0,   10},
    { 880,  260}, { 783,  260}, { 698,  260}, { 783,  130}, { 880,  130},
    { 783,  130}, { 698,  130}, { 587,  260}, { 523,  750}, {   0,   30},
    { 698,  780}, { 523,  260}, { 698,  260}, { 880,  130}, { 783,  130},
    { 698,  260}, { 783,  130}, { 698,  130}, { 587,  260}, { 523,  750}
}

Audio::SingleTone ringing_tone_47_data[]

Audio::SingleTone ringing_tone_48_data[]

Initial value:

 {
    {   0, 1000}, { 880,   40}, { 987,  460}, {   0,   20}, { 987,  460},
    {   0,   20}, { 987,  460}, {   0,   20}, { 987,  800}, { 880,  160},
    { 783,  480}, { 880,   40}, {1175,  960}, {1318,  320}, {1175,  160},
    { 987,  800}, { 880,  160}, { 783,  480}, { 880,  160}, { 987,  300},
    {   0,   20}, { 987,  480}, { 987,  480}, { 880,  320}, { 987,  160},
    { 880,  320}, { 783,  160}, { 659,  160}, { 587,  320}, { 659,  480},
    { 783,  800}, { 659,  160}, { 587,  960}, {   0,  480}, { 659,  320},
    { 587,  160}, { 659,  320}, { 783,  160}, { 659,  160}, { 587,  320},
    { 659,  320}, { 587,  160}, { 659,  320}, { 783,  160}, { 659,  160},
    { 587,  320}, { 783,  320}, {   0,  160}, { 783,  480}, { 783,  320},
    { 880,  160}, { 783,  960}, { 880,  320}, {   0,  160}, { 880,   40},
    { 987,  460}, {   0,   20}, { 987,  460}, {   0,   20}, { 987,  460},
    {   0,   20}, { 987,  800}, { 880,  160}, { 783,  480}, { 880,   40},
    {1175,  960}, {1318,  320}, {1175,  160}, { 987,  800}, { 880,  160},
    { 783,  480}, { 880,  320}, { 987,  140}, {   0,   20}, { 987,  460},
    {   0,   20}, { 987,  480}, { 880,  320}, { 987,  160}, { 880,  320},
    { 783,  160}, { 659,  160}, { 587,  320}, { 659,  480}, { 783,  800},
    { 659,  160}, { 587,  480}, { 587,  480}
}

Audio::SingleTone ringing_tone_4_data[]

Initial value:

 {
    {   0, 1000}, { 932,  140}, {1175,  140}, {1397,  140}, {1865,  140},
    {1175,  140}, {1397,  140}, {1865,  140}, {1175,  140}, { 932,  140},
    {1175,  140}, {1397,  140}, {1865,  140}, {1175,  140}, {1397,  140},
    {1865,  140}, {1175,  140}, { 932,  140}, {2093,  140}, {1568,  140},
    {2093,  140}, {1245,  140}, {1568,  140}, {2093,  140}, {1245,  140},
    { 932,  140}, {2093,  140}, {1568,  140}, {2093,  140}, {1245,  140},
    {1568,  140}, {2093,  140}, {1245,  140}, { 880,  140}, {2093,  140},
    {1397,  140}, {1760,  140}, {2093,  140}, {1397,  140}, {1760,  140},
    {2093,  140}, { 880,  140}, {2093,  140}, {1397,  140}, {1760,  140},
    {2093,  140}, {1397,  140}, {1760,  140}, {2093,  140}, { 932,  140},
    {1175,  140}, {1397,  140}, {1865,  140}, {1175,  140}, {1397,  140},
    {1865,  140}, {1175,  140}, { 932,  140}, {1175,  140}, {1397,  140},
    {1865,  140}, {1175,  140}, {1397,  140}, {1865,  140}, {1175,  140}
}

Audio::SingleTone ringing_tone_5_data[]

Initial value:

 {
    {   0, 1000}, { 300,  224}, { 370,  112}, { 440,  168}, {   0,  168},
    { 311,  224}, { 370,  112}, { 440,  168}, {   0,  168}, { 330,  224},
    { 415,  112}, { 494,  224}, { 440,  112}, {   0,  336}, {   0,  336},
    { 587,  224}, { 739,  112}, { 880,  168}, {   0,  168}, { 622,  224},
    { 739,  112}, { 880,  168}, {   0,  168}, { 659,  224}, { 783,  112},
    { 987,  224}, { 880,  112}, {   0,  336}, {   0,  336}, { 783,  224},
    { 987,  112}, {1175,  224}, {1397,  112}, {1318,  224}, {1175,  112},
    { 987,  224}, {1175,  336}, { 494,  112}, { 587,  224}, { 698,  112},
    { 659,  224}, { 587,  112}, { 494,  224}, { 587,  112}, {   0,  336},
    {   0,  224}, { 300,  112}, {   0,  336}, {   0,  336}
}

Audio::SingleTone ringing_tone_6_data[]

Initial value:

 {
    {   0, 1000}, {1568,   60}, {2489,   60}, {1568,   60}, {2489,   60},
    {1568,   60}, {2489,   60}, {1568,   60}, {2489,   60}, {1568,   60},
    {2489,   60}, {1568,   60}, {2489,   60}, {1568,   60}, {2489,   60},
    {1568,   60}, {2489,   60}, {1568,   60}, {2489,   60}, {1568,   60},
    {2489,   60}, {1568,   60}, {2489,   60}, {1568,   60}, {2489,   60},
    {1568,   60}, {2489,   60}, {1568,   60}, {2489,   60}, {1568,   60},
    {2489,   60}, {1568,   60}, {2489,   60}, {1568,   60}, {2489,   60},
    {1568,   60}, {2489,   60}, {1568,   60}, {2489,   60}, {1568,   60},
    {   0, 1000}
}

Audio::SingleTone ringing_tone_7_data[]

Initial value:

 {
    {   0, 1000}, {1046,  288}, { 830,  144}, {2093,  144}, {   0,  144},
    {1318,  144}, {   0,  144}, { 830,  144}, {2093,  288}, { 830,  144},
    {2093,  144}, {   0,  144}, {1318,  144}, {   0,  144}, { 830,  144},
    {2093,  288}, { 880,  144}, {2093,  144}, {   0,  144}, {1397,  144},
    {   0,  144}, { 880,  144}, {2093,  288}, { 880,  144}, {2093,  144},
    {   0,  144}, {1397,  144}, {   0,  144}, { 880,  144}, {2093,  288},
    { 830,  144}, {2093,  144}, {   0,  144}, {1318,  144}, {   0,  144},
    { 830,  144}, {2093,  288}, { 830,  144}, {2093,  144}, {   0,  144},
    {1318,  144}, {   0,  144}, { 830,  144}, {2093,  288}, { 880,  144},
    {2093,  144}, {   0,  144}, {1568,  144}, {   0,  144}, { 880,  144},
    {1397,  144}, {   0,  144}
}

Audio::SingleTone ringing_tone_8_data[]

Audio::SingleTone ringing_tone_9_data[]

Initial value:

 {
    {   0,  110}, { 783,   88}, {1046,   88}, {1318,   88}, { 783,   88},
    {1046,   88}, {1318,   88}, { 783,   88}, {1046,   88}, {1318,   88},
    {   0, 1056}, {   0, 1000}
}

Audio::SingleTone supervisory_tone_call_waiting_data[]

Initial value:

 {
    { 425,  200}, {   0,  600}, { 425,  200}, {   0, 3000}
}

Audio::SingleTone supervisory_tone_congestion_data[]

Initial value:

 {
    {   0,  200}, { 425,  200}
}

Audio::SingleTone supervisory_tone_error_data[]

Initial value:

 {
    { 950,  330}, {1400,  330}, {1800,  330}, {   0, 1000}
}

Audio::SingleTone supervisory_tone_radio_path_ack_data[]

Initial value:

 {
    { 425,  200}
}

Audio::SingleTone supervisory_tone_radio_path_not_avail_data[]

Initial value:

 {
    {   0,  200}, { 425,  200}
}

Audio::SingleTone supervisory_tone_subscriber_busy_data[]

Initial value:

 {
    {   0,  500}, { 425,  500}
}

WAVEHDR wav

HWAVEOUT wav_out

Generated on Tue Jan 24 20:16:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/Win32/Audio.hpp File Reference

Compat/Devices/Win32/Audio.hpp File Reference

#include <Devices/AbstractDevice.hpp>

Include dependency graph for Audio.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Audio
struct | Audio::SingleTone
struct | Audio::ToneData

Defines

#define | Apoxi_Audio_hpp

Define Documentation

#define Apoxi_Audio_hpp

Generated on Tue Jan 24 20:17:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/Win32/Audio.hpp Source File

Compat/Devices/Win32/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Audio_hpp)
00010 #define Apoxi_Audio_hpp
00013
00014 #include <Devices/AbstractDevice.hpp>
00015
00016
00018 class Audio : public AbstractDevice {
00019     public:
00021         struct SingleTone {
00023             UINT16 freq;
00025             UINT16 dur;
00026         };
00027
00029         struct ToneData {
00031             SingleTone *tones;
00033             UINT16 nof_tones;
00035             UINT16 nof_repeats;
00036         };
00037
00039         enum AudioPriority {
00041             PriorityHigh    = 3,
00043             PriorityMedium  = 2,
00045             PriorityLow     = 1,
00047             PriorityNone    = 0
00048         };
00049
00050
00052         enum AudioDevice {
00054             DeviceNone     = 0x0000,
00056             DeviceBuzzer   = 0x0001,
00058             DeviceEarPiece = 0x0002,
00060             DeviceTrembler = 0x0004,
00062             DeviceOut      = 0x000f,
00064             DeviceMic      = 0x0010,
00066             DeviceIn       = 0x00f0
00067         };
00068
00070         enum AudioMode {
00072             ModeNormal,
00074             ModeHeadset,
00076             ModeHandsfree,
00077
00078             ModeBluetoothHeadset,
00079
00080         };
00081
00083         //TODO: Just use ToneDtmf0 = aud_tone_DTMF_0 etc, instead of using a big switch() statement,
00084         //unless we really need to keep the aud_drv.h header out of this header.
00085         //And don't duplicate it in individual enums in AudioDevice classes. murrayc.
00086         enum AudioToneId{
00087             ToneDtmf0,
00088             ToneDtmf1,
00089             ToneDtmf2,
00090             ToneDtmf3,
00091             ToneDtmf4,
00092             ToneDtmf5,
00093             ToneDtmf6,
00094             ToneDtmf7,
00095             ToneDtmf8,
00096             ToneDtmf9,
00097             ToneDtmfHash,
00098             ToneDtmfStar,
00099             ToneSupervisorySubsciberBusy,
00100             ToneSupervisoryCongestion,
00101             ToneSupervisoryRadioPathAck,
00102             ToneSupervisoryRadioPathNotAvail,
00103             ToneSupervisoryError,
00104             ToneSupervisoryCallWaiting,
00105             ToneInfoFree,
00106             ToneInfoLowBat,
00107             ToneInfoConnection,
00108             ToneInfoDisconnect,
00109             ToneInfoPowerOn,
00110             ToneInfoPowerOff,
00111             ToneInfoDeviceIn,
00112             ToneInfoDeviceOut,
00113             ToneInfoMsgFull,
00114             ToneInfoUssd,
00115             ToneKey1,
00116             ToneKey2,
00117             ToneKey3,
00118             ToneKey4,
00119             ToneBroadcast1,
00120             ToneBroadcast2,
00121             ToneBroadcast3,
00122             ToneBroadcast4,
00123             ToneMessage1,
00124             ToneMessage2,
00125             ToneMessage3,
00126             ToneMessage4,
00127             ToneMessage5,
00128             ToneMessage6,
00129             ToneMessage7,
00130             ToneMessage8,
00131             ToneMessage9,
00132             ToneMessage10,
00133             ToneMessageSingleBeep,
00134             ToneRinging1,
00135             ToneRinging2,
00136             ToneRinging3,
00137             ToneRinging4,
00138             ToneRinging5,
00139             ToneRinging6,
00140             ToneRinging7,
00141             ToneRinging8,
00142             ToneRinging9,
00143             ToneRinging10,
00144             ToneRinging11,
00145             ToneRinging12,
00146             ToneRinging13,
00147             ToneRinging14,
00148             ToneRinging15,
00149             ToneRinging16,
00150             ToneRinging17,
00151             ToneRinging18,
00152             ToneRinging19,
00153             ToneRinging20,
00154             ToneRinging21,
00155             ToneRinging22,
00156             ToneRinging23,
00157             ToneRinging24,
00158             ToneRinging25,
00159             ToneRinging26,
00160             ToneRinging27,
00161             ToneRinging28,
00162             ToneRinging29,
00163             ToneRinging30,
00164             ToneRinging31,
00165             ToneRinging32,
00166             ToneRinging33,
00167             ToneRinging34,
00168             ToneRinging35,
00169             ToneRinging36,
00170             ToneRinging37,
00171             ToneRinging38,
00172             ToneRinging39,
00173             ToneRinging40,
00174             ToneRinging41,
00175             ToneRinging42,
00176             ToneRinging43,
00177             ToneRinging44,
00178             ToneRinging45,
00179             ToneRinging46,
00180             ToneRinging47,
00181             ToneRinging48,
00182             ToneUserDefined,
00183             ToneAlarm1,
00184             AudioInvalidTone
00185         };
00186
00187         // Mute direction
00188         enum MuteDirection {
00189             MuteUplink  ,
00190             MuteDownlink,
00191             MuteTch
00192         };
00193
00194         // Speech volume: Steps for speech volume are available, with a 3 dB
00195         // change for each step.
00196         enum SpeechVolume {
00197             SpeechVolume1,
00198             SpeechVolume2,
00199             SpeechVolume3,
00200             SpeechVolume4,
00201             SpeechVolume5,
00202             SpeechVolume6,
00203             SpeechVolume7,
00204             SpeechVolume8
00205         };
00206
00208         virtual const WCHAR* GetName() const;
00209
00211         Audio ();
00212
00214         virtual ~Audio();
00215
00217         static void Init() {};
00218
00220         static BOOLEAN StartTone(AudioToneId tone_id,
00221                                  INT nof_repeats = 0,
00222                                  AudioDevice device = DeviceBuzzer,
00223                                  AudioPriority priority = PriorityNone);
00224
00226         static BOOLEAN StartTone(const ToneData *tone_data,
00227                                  AudioDevice device = DeviceBuzzer,
00228                                  AudioPriority priority = PriorityNone);
00229
00231         static void StopTone();
00232
00233         enum VibratorMode
00234         {
00235             VibratorModeAsync1, // = Aud_vibrator_mode_async_1,
00236             VibratorModeAsync2, // = Aud_vibrator_mode_async_2,
00237             VibratorModeSync1, // = Aud_vibrator_mode_sync_1,
00238             VibratorModeSync2 // = Aud_vibrator_mode_sync_2
00239         };
00240
00241         enum VibratorOnTime
00242         {
00243             VibratorOnTime400ms, // = Aud_vibrator_on_400ms,
00244             VibratorOnTime600ms, // = Aud_vibrator_on_600ms,
00245             VibratorOnTime800ms, // = Aud_vibrator_on_800ms,
00246             VibratorOnTime1000ms, // = Aud_vibrator_on_1000ms,
00247             VibratorOnTimeOn // = Aud_vibrator_on
00248         };
00249
00250         enum VibratorOffTime
00251         {
00252             VibratorOffTime200ms, // = Aud_vibrator_off_200ms,
00253             VibratorOffTime300ms, // = Aud_vibrator_off_300ms,
00254             VibratorOffTime400ms, // = Aud_vibrator_off_400ms,
00255             VibratorOffTime600ms, // = Aud_vibrator_off_600ms,
00256             VibratorOffTimeOff // = Aud_vibrator_off
00257         };
00258
00259         //TODO: Are these sensible default values? Murray.
00263         static BOOLEAN StartVibrator(VibratorMode mode = VibratorModeAsync1,  VibratorOnTime on = VibratorOnTimeOn, VibratorOffTime off = VibratorOffTimeOff);
00264
00268             static void StopVibrator();
00269
00271         static BOOLEAN IsTremblerOn() { return IsVibratorOn(); }
00272
00274         static BOOLEAN IsVibratorOn() { return m_vibrator_on; }
00275
00277         static void SetVolume(UINT8 volume, AudioDevice device);
00278
00280         static void SetMute(BOOLEAN mute, AudioDevice device);
00281
00283         static void SetAudioMode(AudioMode audio_mode);
00284
00285         // Enable uplink and downlink audio path for speech.
00286         // The volume level will be level last set with SetVolumeSpeech.
00287         static BOOLEAN InitSpeech();
00288
00289         // Powers down the audio path, both uplink and downlink.
00290         static BOOLEAN ReleaseSpeech();
00291
00292         // Change the speaker volume.
00293         // The audio driver only stores the volume in RAM.
00294         static BOOLEAN SetVolumeSpeech(SpeechVolume vol);
00295
00296         // The audio driver only stores the volume in RAM.
00297         static BOOLEAN MuteSpeech(BOOLEAN mute, MuteDirection dir);
00298
00299         private:
00300             static BOOLEAN  m_bluetooth_headset_in_use;
00301             static BOOLEAN  m_vibrator_on;
00302             static AudioPriority m_Priority;
00303 };
00304
00306 #endif  // Apoxi_Audio_hpp
00307
00308
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/Win32/PreComp.cpp File Reference

Compat/Devices/Win32/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/Win32/PreComp.hpp File Reference

Compat/Devices/Win32/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Kernel/Timer.hpp>
#include <Gui/Locale.hpp>
#include <Gui/ClientDc.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/Bitmap.hpp>
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/Devices/Win32/PreComp.hpp Source File

Compat/Devices/Win32/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Timer.hpp>
00012 #include <Gui/Locale.hpp>
00013 #include <Gui/ClientDc.hpp>
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/MsgTypes.hpp>
00016 #include <Gui/MsgTypes.hpp>
00017 #include <Gui/Bitmap.hpp>
00018 #include <Kernel/ExecutionContext.hpp>
00019
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/PreComp.cpp File Reference

Compat/GlobalThemes/PreComp.cpp File Reference

#include "GlobalThemes/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:03:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/PreComp.hpp File Reference

Compat/GlobalThemes/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/PreComp.hpp Source File

Compat/GlobalThemes/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Gui/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.cpp File Reference

Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.cpp File Reference

#include "GlobalThemes/BlackAndWhiteTheme/PreComp.hpp"
#include "Gui/Color.hpp"
#include "BlackAndWhiteTheme.hpp"

Include dependency graph for BlackAndWhiteTheme.cpp:

Variables

const BlackAndWhiteTheme | black_and_white_theme
const SystemColor | c_black_and_white_system_color_table []
const INT | c_black_and_white_system_font_table []

Variable Documentation

const BlackAndWhiteTheme black_and_white_theme

const SystemColor c_black_and_white_system_color_table[]

Initial value:

 {
    0,
    1,
    1,
    0,
    1,
    0,
    1,
    0,
    1
}

const INT c_black_and_white_system_font_table[]

Initial value:

 {
    0,
    0,
    0,
    0,
    0
}

Generated on Tue Jan 24 20:17:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.hpp File Reference

Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>

Include dependency graph for BlackAndWhiteTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlackAndWhiteTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_BlackAndWhiteTheme_hpp

Variables

const BlackAndWhiteTheme | black_and_white_theme

Define Documentation

#define Apoxi_BlackAndWhiteTheme_hpp

Variable Documentation

const BlackAndWhiteTheme black_and_white_theme

Generated on Tue Jan 24 20:17:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.hpp Source File

Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_BlackAndWhiteTheme_hpp)
00009 #define Apoxi_BlackAndWhiteTheme_hpp
00010
00011 #include <Gui/Theme.hpp>
00012
00013 #include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
00014 #include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
00015 #include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
00016 #include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
00017 #include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
00018 #include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
00019 #include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
00020 #include <GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>
00021 #include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
00022 #include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
00023 #include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>
00024
00026 class BlackAndWhiteTheme : public Theme {
00027     public:
00028         BlackAndWhiteTheme();
00029         virtual ~BlackAndWhiteTheme();
00030         virtual const SystemColor GetSystemColor(SystemColorId id) const;
00031         virtual const FontId GetSystemFontId(SystemFontId id) const;
00032         virtual const WindowFrameView* GetWindowFrameView() const;
00033         virtual const ControlFrameView* GetControlFrameView() const;
00034         virtual const CheckBoxView* GetCheckBoxView() const;
00035         virtual const RadioButtonView* GetRadioButtonView() const;
00036         virtual const CheckBoxListView* GetCheckBoxListView() const;
00037         virtual const RadioButtonListView* GetRadioButtonListView() const;
00038         virtual const TextListView* GetTextListView() const;
00039         virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00040         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00041         virtual const ProgressBarView* GetProgressBarView() const;
00042         virtual const PushButtonView* GetPushButtonView() const;
00043
00044     private:
00045         DefaultWindowFrameView          m_window_frame_view;
00046         DefaultControlFrameView         m_control_frame_view;
00047         DefaultCheckBoxView             m_check_box_view;
00048         DefaultRadioButtonView          m_radio_button_view;
00049         DefaultCheckBoxListView         m_check_box_list_view;
00050         DefaultRadioButtonListView      m_radio_button_list_view;
00051         DefaultTextListView             m_text_list_view;
00052         DefaultSoftkeyBarView           m_softkey_bar_view;
00053         DefaultPositionIndicatorView    m_position_indicator_view;
00054         DefaultProgressBarView          m_progress_bar_view;
00055         DefaultPushButtonView           m_push_button_view;
00056 };
00057
00058 extern const BlackAndWhiteTheme black_and_white_theme;
00059
00060 #endif
00061
00062
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlackAndWhiteTheme/PreComp.cpp File Reference

Compat/GlobalThemes/BlackAndWhiteTheme/PreComp.cpp File Reference

#include "GlobalThemes/BlackAndWhiteTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 14:59:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlackAndWhiteTheme/PreComp.hpp File Reference

Compat/GlobalThemes/BlackAndWhiteTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlackAndWhiteTheme/PreComp.hpp Source File

Compat/GlobalThemes/BlackAndWhiteTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.cpp File Reference

Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.cpp File Reference

#include "GlobalThemes/BlueSkyChineseTheme/PreComp.hpp"
#include <GlobalThemes/BlueSkyTheme/BlueSkyTheme.hpp>
#include <GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.hpp>
#include <Gui/Color.hpp>

Include dependency graph for BlueSkyChineseTheme.cpp:

Variables

const BlueSkyChineseTheme | blue_sky_chinese_theme
const INT | c_blue_sky_chinese_system_font_table []
const SystemColor | c_blue_sky_system_color_table []

Variable Documentation

const BlueSkyChineseTheme blue_sky_chinese_theme

const INT c_blue_sky_chinese_system_font_table[]

Initial value:

 {
    3,
    3,
    3,
    3,
    3
}

const SystemColor c_blue_sky_system_color_table[]

Initial value:

 {
    0x00FFFFFF,
    0x00010101,
    0x004466AA,
    0x00FFFFFF,
    0x00DDDDDD,
    0x00000000,
    0x00DCB43C,
    0x00783C28,
    0x00999999
}

Generated on Tue Jan 24 20:17:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.hpp File Reference

Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp>

Include dependency graph for BlueSkyChineseTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyChineseTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_BlueSkyChineseTheme_hpp

Variables

const BlueSkyChineseTheme | blue_sky_chinese_theme

Define Documentation

#define Apoxi_BlueSkyChineseTheme_hpp

Variable Documentation

const BlueSkyChineseTheme blue_sky_chinese_theme

Generated on Tue Jan 24 20:17:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.hpp Source File

Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_BlueSkyChineseTheme_hpp)
00009 #define Apoxi_BlueSkyChineseTheme_hpp
00010
00011 #include <Gui/Theme.hpp>
00012
00013 #include <GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp>
00014 #include <GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp>
00015 #include <GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp>
00016 #include <GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp>
00017 #include <GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp>
00018 #include <GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp>
00019 #include <GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp>
00020 #include <GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp>
00021 #include <GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp>
00022 #include <GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp>
00023 #include <GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp>
00024
00026 class BlueSkyChineseTheme : public Theme {
00027     public:
00028         BlueSkyChineseTheme();
00029         virtual ~BlueSkyChineseTheme();
00030         virtual const SystemColor GetSystemColor(SystemColorId id) const;
00031         virtual const FontId GetSystemFontId(SystemFontId id) const;
00032         virtual const WindowFrameView* GetWindowFrameView() const;
00033         virtual const ControlFrameView* GetControlFrameView() const;
00034         virtual const CheckBoxView* GetCheckBoxView() const;
00035         virtual const RadioButtonView* GetRadioButtonView() const;
00036         virtual const CheckBoxListView* GetCheckBoxListView() const;
00037         virtual const RadioButtonListView* GetRadioButtonListView() const;
00038         virtual const TextListView* GetTextListView() const;
00039         virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00040         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00041         virtual const ProgressBarView* GetProgressBarView() const;
00042         virtual const PushButtonView* GetPushButtonView() const;
00043
00044     private:
00045         BlueSkyWindowFrameView          m_window_frame_view;
00046         BlueSkyControlFrameView         m_control_frame_view;
00047         BlueSkyCheckBoxView             m_check_box_view;
00048         BlueSkyRadioButtonView          m_radio_button_view;
00049         BlueSkyCheckBoxListView         m_check_box_list_view;
00050         BlueSkyRadioButtonListView      m_radio_button_list_view;
00051         BlueSkyTextListView             m_text_list_view;
00052         BlueSkySoftkeyBarView           m_softkey_bar_view;
00053         BlueSkyPositionIndicatorView    m_position_indicator_view;
00054         BlueSkyProgressBarView          m_progress_bar_view;
00055         BlueSkyPushButtonView           m_push_button_view;
00056 };
00057
00058 extern const BlueSkyChineseTheme blue_sky_chinese_theme;
00059
00060 #endif
00061
00062
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyChineseTheme/PreComp.cpp File Reference

Compat/GlobalThemes/BlueSkyChineseTheme/PreComp.cpp File Reference

#include "GlobalThemes/BlueSkyChineseTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:00:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyChineseTheme/PreComp.hpp File Reference

Compat/GlobalThemes/BlueSkyChineseTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyChineseTheme/PreComp.hpp Source File

Compat/GlobalThemes/BlueSkyChineseTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Gui/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyCheckBoxListView.hpp"
#include "Gui/PaintDc.hpp"
#include "Gui/CheckBoxItem.hpp"

Include dependency graph for BlueSkyCheckBoxListView.cpp:

Generated on Tue Jan 24 20:17:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp File Reference

#include <Gui/CheckBoxList.hpp>

Include dependency graph for BlueSkyCheckBoxListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyCheckBoxListView

Defines

#define | Apoxi_BlueSkyCheckBoxListView_hpp

Define Documentation

#define Apoxi_BlueSkyCheckBoxListView_hpp

Generated on Tue Jan 24 20:17:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyCheckBoxListView_hpp)
00010 #define Apoxi_BlueSkyCheckBoxListView_hpp
00011
00012 #include <Gui/CheckBoxList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyCheckBoxListView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyCheckBoxListView : public CheckBoxListView {
00018     typedef CheckBoxListView Base;
00019
00020     public:
00021         BlueSkyCheckBoxListView(CheckBoxView *cb_view, XYDIM item_height);
00022         virtual ~BlueSkyCheckBoxListView() {}
00023
00024     protected:
00025         virtual void DrawCheckBoxItem(const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const;
00026 };
00027
00028 #endif  // Apoxi_BlueSkyCheckBoxListView_hpp
00029
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include <Gui/Bitmap.hpp>
#include "BlueSkyCheckBoxView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for BlueSkyCheckBoxView.cpp:

Generated on Tue Jan 24 20:17:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp File Reference

#include <Gui/CheckBox.hpp>

Include dependency graph for BlueSkyCheckBoxView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyCheckBoxView

Defines

#define | Apoxi_BlueSkyCheckBoxView_hpp

Define Documentation

#define Apoxi_BlueSkyCheckBoxView_hpp

Generated on Tue Jan 24 20:17:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyCheckBoxView_hpp)
00010 #define Apoxi_BlueSkyCheckBoxView_hpp
00011
00012 #include <Gui/CheckBox.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyCheckBoxView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyCheckBoxView : public CheckBoxView {
00018     public:
00019         typedef CheckBoxView Base;
00020
00021         BlueSkyCheckBoxView(XYDIM default_height, XYDIM left_gap, XYDIM middle_gap);
00022         virtual ~BlueSkyCheckBoxView() {}
00023
00024     protected:
00025         virtual void DrawCheckBox(const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00026         virtual void DrawShiftedCheckBox(const Rect &shift_rect, const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_BlueSkyCheckBoxView_hpp
00030
00031
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyControlFrameView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for BlueSkyControlFrameView.cpp:

Generated on Tue Jan 24 20:17:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp File Reference

#include <Gui/ControlFrameView.hpp>

Include dependency graph for BlueSkyControlFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyControlFrameView

Defines

#define | Apoxi_BlueSkyControlFrameView_hpp

Define Documentation

#define Apoxi_BlueSkyControlFrameView_hpp

Generated on Tue Jan 24 20:17:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyControlFrameView_hpp)
00010 #define Apoxi_BlueSkyControlFrameView_hpp
00011
00012 #include <Gui/ControlFrameView.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyControlFrameView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyControlFrameView : public ControlFrameView {
00018     typedef ControlFrameView Base;
00019
00020     public:
00022         BlueSkyControlFrameView(XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size);
00023
00025         virtual ~BlueSkyControlFrameView();
00026
00027     protected:
00029         virtual void DrawControlFrame(const Control &control, DeviceContext *dc, const Rect &repaint_rect) const;
00030 };
00031
00032 #endif  // Apoxi_BlueSkyControlFrameView_hpp
00033
00034
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyPositionIndicatorView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for BlueSkyPositionIndicatorView.cpp:

Generated on Tue Jan 24 20:17:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp File Reference

#include <Gui/PositionIndicator.hpp>

Include dependency graph for BlueSkyPositionIndicatorView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyPositionIndicatorView

Defines

#define | Apoxi_BlueSkyPositionIndicatorView_hpp

Define Documentation

#define Apoxi_BlueSkyPositionIndicatorView_hpp

Generated on Tue Jan 24 20:17:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyPositionIndicatorView_hpp)
00010 #define Apoxi_BlueSkyPositionIndicatorView_hpp
00011
00012 #include <Gui/PositionIndicator.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyPositionIndicatorView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyPositionIndicatorView : public PositionIndicatorView {
00018     typedef PositionIndicatorView Base;
00019
00020     public:
00021         BlueSkyPositionIndicatorView(XYDIM size);
00022
00023         virtual ~BlueSkyPositionIndicatorView() {}
00024
00025     protected:
00026         virtual void DrawPositionIndicator(const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_BlueSkyPositionIndicatorView_hpp
00030
00031
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyProgressBarView.hpp"
#include <Gui/PaintDc.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for BlueSkyProgressBarView.cpp:

Generated on Tue Jan 24 20:17:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp File Reference

#include <Gui/ProgressBar.hpp>

Include dependency graph for BlueSkyProgressBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyProgressBarView

Defines

#define | Apoxi_BlueSkyProgressBarView_hpp

Define Documentation

#define Apoxi_BlueSkyProgressBarView_hpp

Generated on Tue Jan 24 20:17:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyProgressBarView_hpp)
00010 #define Apoxi_BlueSkyProgressBarView_hpp
00011
00012 #include <Gui/ProgressBar.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyProgressBarView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyProgressBarView : public ProgressBarView {
00018     typedef ProgressBarView Base;
00019
00020     public:
00021         BlueSkyProgressBarView(XYDIM default_height);
00022         virtual ~BlueSkyProgressBarView() {}
00023
00024     protected:
00025         virtual void DrawProgressBar(const ProgressBar &progress_bar, DeviceContext *dc, const Rect &repaint_rect) const;
00026 };
00027
00028 #endif  // Apoxi_BlueSkyProgressBarView_hpp
00029
00030
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyPushButtonView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for BlueSkyPushButtonView.cpp:

Generated on Tue Jan 24 20:17:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp File Reference

#include <Gui/PushButton.hpp>

Include dependency graph for BlueSkyPushButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyPushButtonView

Defines

#define | Apoxi_BlueSkyPushButtonView_hpp

Define Documentation

#define Apoxi_BlueSkyPushButtonView_hpp

Generated on Tue Jan 24 20:17:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyPushButtonView_hpp)
00010 #define Apoxi_BlueSkyPushButtonView_hpp
00011
00012 #include <Gui/PushButton.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyPushButtonView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyPushButtonView : public PushButtonView {
00018     public:
00019         typedef PushButtonView Base;
00020
00021         BlueSkyPushButtonView(XYDIM default_height);
00022         virtual ~BlueSkyPushButtonView() {}
00023
00024     protected:
00025         virtual void DrawPushButton(const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const;
00026 };
00027
00028 #endif  // Apoxi_BlueSkyPushButtonView_hpp
00029
00030
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyRadioButtonListView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for BlueSkyRadioButtonListView.cpp:

Generated on Tue Jan 24 20:17:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp File Reference

#include <Gui/RadioButtonList.hpp>

Include dependency graph for BlueSkyRadioButtonListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyRadioButtonListView

Defines

#define | Apoxi_BlueSkyRadioButtonListView_hpp

Define Documentation

#define Apoxi_BlueSkyRadioButtonListView_hpp

Generated on Tue Jan 24 20:17:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyRadioButtonListView_hpp)
00010 #define Apoxi_BlueSkyRadioButtonListView_hpp
00011
00012 #include <Gui/RadioButtonList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyRadioButtonListView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyRadioButtonListView : public RadioButtonListView {
00018     typedef RadioButtonListView Base;
00019
00020     public:
00021         BlueSkyRadioButtonListView(RadioButtonView *rb_view, XYDIM item_height);
00022         virtual ~BlueSkyRadioButtonListView() {}
00023
00024     protected:
00025         virtual void DrawRadioButtonItem(const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const;
00026 };
00027
00028 #endif  // Apoxi_BlueSkyRadioButtonListView_hpp
00029
00030
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyRadioButtonView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for BlueSkyRadioButtonView.cpp:

Variables

const BitmapRes checked_bmp = { {1, 0, 0}, 12, 12, checked_bits, 0x00ffffff }

Variable Documentation

const BitmapRes checked_bmp = { {1, 0, 0}, 12, 12, checked_bits, 0x00ffffff }

Generated on Tue Jan 24 20:17:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp File Reference

#include <Gui/RadioButton.hpp>

Include dependency graph for BlueSkyRadioButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyRadioButtonView

Defines

#define | Apoxi_BlueSkyRadioButtonView_hpp

Define Documentation

#define Apoxi_BlueSkyRadioButtonView_hpp

Generated on Tue Jan 24 20:17:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyRadioButtonView_hpp)
00010 #define Apoxi_BlueSkyRadioButtonView_hpp
00011
00012 #include <Gui/RadioButton.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyRadioButtonView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyRadioButtonView : public RadioButtonView{
00018     public:
00019         typedef RadioButtonView Base;
00020
00021         BlueSkyRadioButtonView(XYDIM item_height, XYDIM left_gap, XYDIM middle_gap);
00022         virtual ~BlueSkyRadioButtonView() {}
00023
00024     protected:
00025         virtual void DrawRadioButton(const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00026         virtual void DrawShiftedRadioButton(const Rect &shift_rect, const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_BlueSkyRadioButtonView_hpp
00030
00031
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkySoftkeyBarView.hpp"
#include "Gui/TextFormat.hpp"
#include "Gui/PaintDc.hpp"
#include "Gui/DeviceContext.hpp"

Include dependency graph for BlueSkySoftkeyBarView.cpp:

Generated on Tue Jan 24 20:18:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp File Reference

#include <Gui/SoftkeyBar.hpp>

Include dependency graph for BlueSkySoftkeyBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkySoftkeyBarView

Defines

#define | Apoxi_BlueSkySoftkeyBarView_hpp

Define Documentation

#define Apoxi_BlueSkySoftkeyBarView_hpp

Generated on Tue Jan 24 20:18:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkySoftkeyBarView_hpp)
00010 #define Apoxi_BlueSkySoftkeyBarView_hpp
00011
00012 #include <Gui/SoftkeyBar.hpp>
00013
00014 class DeviceContext;
00015
00016 /*  ------------------------------------------------------------------------
00017     BlueSkySoftkeyBarView
00018     ------------------------------------------------------------------------ */
00019 class BlueSkySoftkeyBarView : public SoftkeyBarView {
00020     public:
00021         typedef SoftkeyBarView Base;
00022
00023         virtual ~BlueSkySoftkeyBarView() {}
00024
00025     protected:
00026         virtual void DrawSoftkeyBar(const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_BlueSkySoftkeyBarView_hpp
00030
00031
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyTextListView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for BlueSkyTextListView.cpp:

Generated on Tue Jan 24 20:18:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp File Reference

#include <Gui/TextList.hpp>

Include dependency graph for BlueSkyTextListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyTextListView

Defines

#define | Apoxi_BlueSkyTextListView_hpp

Define Documentation

#define Apoxi_BlueSkyTextListView_hpp

Generated on Tue Jan 24 20:18:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyTextListView_hpp)
00010 #define Apoxi_BlueSkyTextListView_hpp
00011
00012 #include <Gui/TextList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyTextListView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyTextListView : public TextListView {
00018     typedef TextListView Base;
00019
00020     public:
00021         BlueSkyTextListView(XYDIM item_height);
00022         virtual ~BlueSkyTextListView() {}
00023
00024     protected:
00025         virtual void DrawTextListItem(const TextList &text_list, DeviceContext *dc, INT index, const Rect &item_rect) const;
00026 };
00027
00028 #endif  // Apoxi_BlueSkyTextListView_hpp
00029
00030
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyTheme.hpp"
#include <Gui/Color.hpp>

Include dependency graph for BlueSkyTheme.cpp:

Variables

const BlueSkyTheme | blue_sky_theme
const SystemColor | c_blue_sky_system_color_table []
const INT | c_blue_sky_system_font_table []

Variable Documentation

const BlueSkyTheme blue_sky_theme

const SystemColor c_blue_sky_system_color_table[]

Initial value:

 {
    0x00FFFFFF,
    0x00010101,
    0x004466AA,
    0x00FFFFFF,
    0x00DDDDDD,
    0x00000000,
    0x00DCB43C,
    0x00783C28,
    0x00999999
}

const INT c_blue_sky_system_font_table[]

Initial value:

 {
    0,
    0,
    0,
    0,
    0
}

Generated on Tue Jan 24 20:18:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp>
#include <GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp>

Include dependency graph for BlueSkyTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_BlueSkyTheme_hpp

Variables

const BlueSkyTheme | blue_sky_theme

Define Documentation

#define Apoxi_BlueSkyTheme_hpp

Variable Documentation

const BlueSkyTheme blue_sky_theme

Generated on Tue Jan 24 20:18:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_BlueSkyTheme_hpp)
00009 #define Apoxi_BlueSkyTheme_hpp
00010
00011 #include <Gui/Theme.hpp>
00012
00013 #include <GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp>
00014 #include <GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp>
00015 #include <GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp>
00016 #include <GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp>
00017 #include <GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp>
00018 #include <GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp>
00019 #include <GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp>
00020 #include <GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp>
00021 #include <GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp>
00022 #include <GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp>
00023 #include <GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp>
00024
00026 class BlueSkyTheme : public Theme {
00027     public:
00028         BlueSkyTheme();
00029         virtual ~BlueSkyTheme();
00030         virtual const SystemColor GetSystemColor(SystemColorId id) const;
00031         virtual const FontId GetSystemFontId(SystemFontId id) const;
00032         virtual const WindowFrameView* GetWindowFrameView() const;
00033         virtual const ControlFrameView* GetControlFrameView() const;
00034         virtual const CheckBoxView* GetCheckBoxView() const;
00035         virtual const RadioButtonView* GetRadioButtonView() const;
00036         virtual const CheckBoxListView* GetCheckBoxListView() const;
00037         virtual const RadioButtonListView* GetRadioButtonListView() const;
00038         virtual const TextListView* GetTextListView() const;
00039         virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00040         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00041         virtual const ProgressBarView* GetProgressBarView() const;
00042         virtual const PushButtonView* GetPushButtonView() const;
00043
00044     private:
00045         BlueSkyWindowFrameView          m_window_frame_view;
00046         BlueSkyControlFrameView         m_control_frame_view;
00047         BlueSkyCheckBoxView             m_check_box_view;
00048         BlueSkyRadioButtonView          m_radio_button_view;
00049         BlueSkyCheckBoxListView         m_check_box_list_view;
00050         BlueSkyRadioButtonListView      m_radio_button_list_view;
00051         BlueSkyTextListView             m_text_list_view;
00052         BlueSkySoftkeyBarView           m_softkey_bar_view;
00053         BlueSkyPositionIndicatorView    m_position_indicator_view;
00054         BlueSkyProgressBarView          m_progress_bar_view;
00055         BlueSkyPushButtonView           m_push_button_view;
00056 };
00057
00058 extern const BlueSkyTheme blue_sky_theme;
00059
00060 #endif
00061
00062
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"
#include "BlueSkyWindowFrameView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for BlueSkyWindowFrameView.cpp:

Generated on Tue Jan 24 20:18:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp File Reference

#include <Gui/WindowFrameView.hpp>

Include dependency graph for BlueSkyWindowFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BlueSkyWindowFrameView

Defines

#define | Apoxi_BlueSkyWindowFrameView_hpp

Define Documentation

#define Apoxi_BlueSkyWindowFrameView_hpp

Generated on Tue Jan 24 20:18:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BlueSkyWindowFrameView_hpp)
00010 #define Apoxi_BlueSkyWindowFrameView_hpp
00011
00012 #include <Gui/WindowFrameView.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     BlueSkyWindowFrameView
00016     ------------------------------------------------------------------------ */
00017 class BlueSkyWindowFrameView : public WindowFrameView {
00018     typedef WindowFrameView Base;
00019
00020     public:
00022         BlueSkyWindowFrameView(XYDIM left_size,
00023                                XYDIM top_size,
00024                                XYDIM right_size,
00025                                XYDIM bottom_size,
00026                                XYDIM title_height,
00027                                XYDIM softkey_bar_height);
00028
00030         virtual ~BlueSkyWindowFrameView();
00031
00032     protected:
00034         virtual void DrawControlFrame(const Control &control, DeviceContext *dc, const Rect &repaint_rect) const;
00035
00037         virtual void DrawWindowExtensions(const Window &window,  DeviceContext *dc, const Rect &repaint_rect) const;
00038 };
00039
00040 #endif  // Apoxi_BlueSkyWindowFrameView_hpp
00041
00042
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/PreComp.cpp File Reference

Compat/GlobalThemes/BlueSkyTheme/PreComp.cpp File Reference

#include "GlobalThemes/BlueSkyTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:00:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/PreComp.hpp File Reference

Compat/GlobalThemes/BlueSkyTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:20:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/BlueSkyTheme/PreComp.hpp Source File

Compat/GlobalThemes/BlueSkyTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Gui/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.cpp File Reference

Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.cpp File Reference

#include "GlobalThemes/DefaultChineseTheme/PreComp.hpp"
#include <Gui/Color.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTheme.hpp>
#include <GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.hpp>

Include dependency graph for DefaultChineseTheme.cpp:

Variables

SystemColor | c_default_chinese_system_color_table [8]
const INT | c_default_chinese_system_font_table []
const Palette | c_system_color []
const DefaultChineseTheme | default_chinese_theme

Variable Documentation

SystemColor c_default_chinese_system_color_table[8]

const INT c_default_chinese_system_font_table[]

Initial value:

 {
    3,
    3,
    3,
    3,
    3
}

const Palette c_system_color[]

Initial value:

 {
    {255, 255, 255},
    {0, 0, 0},
    {68, 102, 170},
    {255, 255, 255},
    {221, 221, 221},
    {0, 0, 0},
    {220, 180, 60},
    {120, 60, 40},
    {128, 128, 128}
    }

const DefaultChineseTheme default_chinese_theme

Generated on Tue Jan 24 20:18:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.hpp File Reference

Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>

Include dependency graph for DefaultChineseTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultChineseTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_DefaultChineseTheme_hpp

Variables

const DefaultChineseTheme | default_chinese_theme

Define Documentation

#define Apoxi_DefaultChineseTheme_hpp

Variable Documentation

const DefaultChineseTheme default_chinese_theme

Generated on Tue Jan 24 20:18:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.hpp Source File

Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_DefaultChineseTheme_hpp)
00009 #define Apoxi_DefaultChineseTheme_hpp
00010
00011 #include <Gui/Theme.hpp>
00012
00013 #include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
00014 #include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
00015 #include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
00016 #include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
00017 #include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
00018 #include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
00019 #include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
00020 #include <GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>
00021 #include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
00022 #include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
00023 #include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>
00024
00026 class DefaultChineseTheme : public Theme {
00027     public:
00028         DefaultChineseTheme();
00029         virtual ~DefaultChineseTheme();
00030         void Update();
00031         virtual const SystemColor GetSystemColor(SystemColorId id) const;
00032         virtual const FontId GetSystemFontId(SystemFontId id) const;
00033         virtual const WindowFrameView* GetWindowFrameView() const;
00034         virtual const ControlFrameView* GetControlFrameView() const;
00035         virtual const CheckBoxView* GetCheckBoxView() const;
00036         virtual const RadioButtonView* GetRadioButtonView() const;
00037         virtual const CheckBoxListView* GetCheckBoxListView() const;
00038         virtual const RadioButtonListView* GetRadioButtonListView() const;
00039         virtual const TextListView* GetTextListView() const;
00040         virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00041         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00042         virtual const ProgressBarView* GetProgressBarView() const;
00043         virtual const PushButtonView* GetPushButtonView() const;
00044
00045     private:
00046         DefaultWindowFrameView          m_window_frame_view;
00047         DefaultControlFrameView         m_control_frame_view;
00048         DefaultCheckBoxView             m_check_box_view;
00049         DefaultRadioButtonView          m_radio_button_view;
00050         DefaultCheckBoxListView         m_check_box_list_view;
00051         DefaultRadioButtonListView      m_radio_button_list_view;
00052         DefaultTextListView             m_text_list_view;
00053         DefaultSoftkeyBarView           m_softkey_bar_view;
00054         DefaultPositionIndicatorView    m_position_indicator_view;
00055         DefaultProgressBarView          m_progress_bar_view;
00056         DefaultPushButtonView           m_push_button_view;
00057 };
00058
00059 extern const DefaultChineseTheme default_chinese_theme;
00060
00061 #endif
00062
00063
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultChineseTheme/PreComp.cpp File Reference

Compat/GlobalThemes/DefaultChineseTheme/PreComp.cpp File Reference

#include "GlobalThemes/DefaultChineseTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:01:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultChineseTheme/PreComp.hpp File Reference

Compat/GlobalThemes/DefaultChineseTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultChineseTheme/PreComp.hpp Source File

Compat/GlobalThemes/DefaultChineseTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Gui/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultCheckBoxListView.hpp"
#include <Gui/PaintDc.hpp>
#include <Gui/CheckBoxItem.hpp>
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultCheckBoxListView.cpp:

Generated on Tue Jan 24 20:18:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp File Reference

#include <Gui/CheckBoxList.hpp>

Include dependency graph for DefaultCheckBoxListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultCheckBoxListView
Obsolete since APOXI-1.6.2. More...

Defines

#define | Apoxi_DefaultCheckBoxListView_hpp

Define Documentation

#define Apoxi_DefaultCheckBoxListView_hpp

Generated on Tue Jan 24 20:18:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultCheckBoxListView_hpp)
00010 #define Apoxi_DefaultCheckBoxListView_hpp
00011
00012 #include <Gui/CheckBoxList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultCheckBoxListView
00016     ------------------------------------------------------------------------ */
00017 class DefaultCheckBoxListView : public CheckBoxListView {
00018     typedef CheckBoxListView Base;
00019
00020     public:
00021         DefaultCheckBoxListView();
00022         DefaultCheckBoxListView(CheckBoxView *cb_view, XYDIM item_height);
00023         virtual void Update(const Theme &theme);
00024         virtual ~DefaultCheckBoxListView() {}
00025
00026     protected:
00027         virtual void DrawCheckBoxItem(const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const;
00028 };
00029
00030 #endif  // Apoxi_DefaultCheckBoxListView_hpp
00031
00032
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include <Gui/Bitmap.hpp>
#include "DefaultCheckBoxView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/Resources/checked_checkbox.hpp"
#include "Config/Resources/unchecked_checkbox.hpp"
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultCheckBoxView.cpp:

Generated on Tue Jan 24 20:18:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp File Reference

#include <Gui/CheckBox.hpp>

Include dependency graph for DefaultCheckBoxView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultCheckBoxView
Obsolete since APOXI-1.6.2. More...

Defines

#define | Apoxi_DefaultCheckBoxView_hpp

Define Documentation

#define Apoxi_DefaultCheckBoxView_hpp

Generated on Tue Jan 24 20:18:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultCheckBoxView_hpp)
00010 #define Apoxi_DefaultCheckBoxView_hpp
00011
00012 #include <Gui/CheckBox.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultCheckBoxView
00016     ------------------------------------------------------------------------ */
00017 class DefaultCheckBoxView : public CheckBoxView {
00018     typedef CheckBoxView Base;
00019
00020     public:
00021         DefaultCheckBoxView();
00022         DefaultCheckBoxView(XYDIM default_height, XYDIM left_gap, XYDIM middle_gap);
00023         virtual void Update(const Theme &theme);
00024         virtual ~DefaultCheckBoxView() {}
00025
00026     protected:
00027         virtual void DrawCheckBox(const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00028         virtual void DrawShiftedCheckBox(const Rect &shift_rect, const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00029 };
00030
00031 #endif  // Apoxi_DefaultCheckBoxView_hpp
00032
00033
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultControlFrameView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for DefaultControlFrameView.cpp:

Generated on Tue Jan 24 20:18:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp File Reference

#include <Gui/ControlFrameView.hpp>

Include dependency graph for DefaultControlFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultControlFrameView

Defines

#define | Apoxi_DefaultControlFrameView_hpp

Define Documentation

#define Apoxi_DefaultControlFrameView_hpp

Generated on Tue Jan 24 20:18:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultControlFrameView_hpp)
00010 #define Apoxi_DefaultControlFrameView_hpp
00011
00012 #include <Gui/ControlFrameView.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultControlFrameView
00016     ------------------------------------------------------------------------ */
00017 class DefaultControlFrameView : public ControlFrameView {
00018     typedef ControlFrameView Base;
00019
00020     public:
00022         DefaultControlFrameView();
00023
00025         DefaultControlFrameView(XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size);
00026
00028         virtual void Update(const Theme &theme);
00029
00031         virtual ~DefaultControlFrameView();
00032
00033     protected:
00035         virtual void DrawControlFrame(const Control &control, DeviceContext *dc, const Rect &repaint_rect) const;
00036 };
00037
00038 #endif  // Apoxi_DefaultControlFrameView_hpp
00039
00040
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultPositionIndicatorView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/DisplayConfig.hpp"

Include dependency graph for DefaultPositionIndicatorView.cpp:

Generated on Tue Jan 24 20:18:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp File Reference

#include <Gui/PositionIndicator.hpp>

Include dependency graph for DefaultPositionIndicatorView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultPositionIndicatorView

Defines

#define | Apoxi_DefaultPositionIndicatorView_hpp

Define Documentation

#define Apoxi_DefaultPositionIndicatorView_hpp

Generated on Tue Jan 24 20:19:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultPositionIndicatorView_hpp)
00010 #define Apoxi_DefaultPositionIndicatorView_hpp
00011
00012 #include <Gui/PositionIndicator.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultPositionIndicatorView
00016     ------------------------------------------------------------------------ */
00017 class DefaultPositionIndicatorView : public PositionIndicatorView {
00018     typedef PositionIndicatorView Base;
00019
00020     public:
00021         DefaultPositionIndicatorView();
00022         explicit DefaultPositionIndicatorView(XYDIM size);
00023         virtual ~DefaultPositionIndicatorView() {}
00024
00025     protected:
00026         virtual void DrawPositionIndicator(const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_DefaultPositionIndicatorView_hpp
00030
00031
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultProgressBarView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/DisplayConfig.hpp"
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultProgressBarView.cpp:

Generated on Tue Jan 24 20:19:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp File Reference

#include <Gui/ProgressBar.hpp>

Include dependency graph for DefaultProgressBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultProgressBarView

Defines

#define | Apoxi_DefaultProgressBarView_hpp

Define Documentation

#define Apoxi_DefaultProgressBarView_hpp

Generated on Tue Jan 24 20:19:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultProgressBarView_hpp)
00010 #define Apoxi_DefaultProgressBarView_hpp
00011
00012 #include <Gui/ProgressBar.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultProgressBarView
00016     ------------------------------------------------------------------------ */
00017 class DefaultProgressBarView : public ProgressBarView {
00018     typedef ProgressBarView Base;
00019
00020     public:
00021         DefaultProgressBarView();
00022         explicit DefaultProgressBarView(XYDIM default_height);
00023         virtual void Update(const Theme &theme);
00024         virtual ~DefaultProgressBarView() {}
00025
00026     protected:
00027         virtual void DrawProgressBar(const ProgressBar &progress_bar, DeviceContext *dc, const Rect &repaint_rect) const;
00028 };
00029
00030 #endif  // Apoxi_DefaultProgressBarView_hpp
00031
00032
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultPushButtonView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/DisplayConfig.hpp"
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultPushButtonView.cpp:

Generated on Tue Jan 24 20:19:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp File Reference

#include <Gui/PushButton.hpp>

Include dependency graph for DefaultPushButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultPushButtonView

Defines

#define | Apoxi_DefaultPushButtonView_hpp

Define Documentation

#define Apoxi_DefaultPushButtonView_hpp

Generated on Tue Jan 24 20:19:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultPushButtonView_hpp)
00010 #define Apoxi_DefaultPushButtonView_hpp
00011
00012 #include <Gui/PushButton.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultPushButtonView
00016     ------------------------------------------------------------------------ */
00017 class DefaultPushButtonView : public PushButtonView {
00018     typedef PushButtonView Base;
00019
00020     public:
00021         DefaultPushButtonView();
00022         explicit DefaultPushButtonView(XYDIM default_height);
00023         virtual ~DefaultPushButtonView() {}
00024         virtual void Update(const Theme &theme);
00025
00026     protected:
00027         virtual void DrawPushButton(const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const;
00028 };
00029
00030 #endif  // Apoxi_DefaultPushButtonView_hpp
00031
00032
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultRadioButtonListView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultRadioButtonListView.cpp:

Generated on Tue Jan 24 20:19:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp File Reference

#include <Gui/RadioButtonList.hpp>

Include dependency graph for DefaultRadioButtonListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultRadioButtonListView
Obsolete since APOXI-1.6.2. More...

Defines

#define | Apoxi_DefaultRadioButtonListView_hpp

Define Documentation

#define Apoxi_DefaultRadioButtonListView_hpp

Generated on Tue Jan 24 20:19:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultRadioButtonListView_hpp)
00010 #define Apoxi_DefaultRadioButtonListView_hpp
00011
00012 #include <Gui/RadioButtonList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultRadioButtonListView
00016     ------------------------------------------------------------------------ */
00017 class DefaultRadioButtonListView : public RadioButtonListView {
00018     typedef RadioButtonListView Base;
00019
00020     public:
00021         DefaultRadioButtonListView();
00022         DefaultRadioButtonListView(const RadioButtonView *rb_view, XYDIM item_height);
00023
00024         virtual void Update(const Theme &theme);
00025
00026         virtual ~DefaultRadioButtonListView() {}
00027
00028     protected:
00029         virtual void DrawRadioButtonItem(const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const;
00030 };
00031
00032 #endif  // Apoxi_DefaultRadioButtonListView_hpp
00033
00034
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultRadioButtonView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/Resources/checked_radiobutton.hpp"
#include "Config/Resources/unchecked_radiobutton.hpp"
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultRadioButtonView.cpp:

Generated on Tue Jan 24 20:19:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp File Reference

#include <Gui/RadioButton.hpp>

Include dependency graph for DefaultRadioButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultRadioButtonView
Obsolete since APOXI-1.6.2. More...

Defines

#define | Apoxi_DefaultRadioButtonView_hpp

Define Documentation

#define Apoxi_DefaultRadioButtonView_hpp

Generated on Tue Jan 24 20:19:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultRadioButtonView_hpp)
00010 #define Apoxi_DefaultRadioButtonView_hpp
00011
00012 #include <Gui/RadioButton.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultRadioButtonView
00016     ------------------------------------------------------------------------ */
00017 class DefaultRadioButtonView : public RadioButtonView{
00018     typedef RadioButtonView Base;
00019
00020     public:
00021         DefaultRadioButtonView();
00022         DefaultRadioButtonView(XYDIM item_height, XYDIM left_gap, XYDIM middle_gap);
00023         virtual void Update(const Theme &theme);
00024         virtual ~DefaultRadioButtonView() {}
00025
00026     protected:
00027         virtual void DrawRadioButton(const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00028         virtual void DrawShiftedRadioButton(const Rect &shift_rect, const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00029 };
00030
00031 #endif  // Apoxi_DefaultRadioButtonView_hpp
00032
00033
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultSoftkeyBarView.hpp"
#include "Gui/TextFormat.hpp"
#include "Gui/PaintDc.hpp"
#include "Gui/DeviceContext.hpp"
#include "Config/DisplayConfig.hpp"

Include dependency graph for DefaultSoftkeyBarView.cpp:

Generated on Tue Jan 24 20:19:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp File Reference

#include <Gui/SoftkeyBar.hpp>

Include dependency graph for DefaultSoftkeyBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultSoftkeyBarView

Defines

#define | Apoxi_DefaultSoftkeyBarView_hpp

Define Documentation

#define Apoxi_DefaultSoftkeyBarView_hpp

Generated on Tue Jan 24 20:19:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultSoftkeyBarView_hpp)
00010 #define Apoxi_DefaultSoftkeyBarView_hpp
00011
00012 #include <Gui/SoftkeyBar.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultSoftkeyBarView
00016     ------------------------------------------------------------------------ */
00017 class DefaultSoftkeyBarView : public SoftkeyBarView {
00018     //typedef SoftkeyBarView Base;
00019
00020     public:
00021         virtual ~DefaultSoftkeyBarView() {}
00022
00023     protected:
00024         virtual void DrawSoftkeyBar(const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const;
00025 };
00026
00027 #endif  // Apoxi_DefaultSoftkeyBarView_hpp
00028
00029
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultTextListView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultTextListView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultTextListView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultTextListView.cpp:

Generated on Tue Jan 24 20:19:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultTextListView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultTextListView.hpp File Reference

#include <Gui/TextList.hpp>

Include dependency graph for DefaultTextListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultTextListView

Defines

#define | Apoxi_DefaultTextListView_hpp

Define Documentation

#define Apoxi_DefaultTextListView_hpp

Generated on Tue Jan 24 20:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultTextListView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultTextListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultTextListView_hpp)
00010 #define Apoxi_DefaultTextListView_hpp
00011
00012 #include <Gui/TextList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultTextListView
00016     ------------------------------------------------------------------------ */
00017 class DefaultTextListView : public TextListView {
00018     typedef TextListView Base;
00019
00020     public:
00021         DefaultTextListView();
00022         explicit DefaultTextListView(XYDIM item_height);
00023         virtual void Update(const Theme &theme);
00024         virtual ~DefaultTextListView() {}
00025
00026     protected:
00027         virtual void DrawTextListItem(const TextList &text_list, DeviceContext *dc, INT index, const Rect &item_rect) const;
00028 };
00029
00030 #endif  // Apoxi_DefaultTextListView_hpp
00031
00032
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultTheme.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultTheme.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "Gui/Color.hpp"
#include "DefaultTheme.hpp"
#include "Config/DisplayConfig.hpp"

Include dependency graph for DefaultTheme.cpp:

Variables

ColorTable | c_default_system_color_table = { c_system_color, 9 }
const Palette | c_system_color []
const DefaultTheme | default_theme

Variable Documentation

ColorTable c_default_system_color_table = { c_system_color, 9 }

const Palette c_system_color[]

Initial value:

 {
    {255, 255, 255},
    {0, 0, 0},
    {68, 102, 170},
    {255, 255, 255},
    {221, 221, 221},
    {0, 0, 0},
    {220, 180, 60},
    {120, 60, 40},
    {128, 128, 128}
    }

const DefaultTheme default_theme

Generated on Tue Jan 24 20:20:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultTheme.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>

Include dependency graph for DefaultTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_DefaultTheme_hpp

Variables

const DefaultTheme | default_theme

Define Documentation

#define Apoxi_DefaultTheme_hpp

Variable Documentation

const DefaultTheme default_theme

Generated on Tue Jan 24 20:20:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultTheme.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_DefaultTheme_hpp)
00009 #define Apoxi_DefaultTheme_hpp
00010
00011 #include <Gui/Theme.hpp>
00012
00013 #include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
00014 #include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
00015 #include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
00016 #include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
00017 #include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
00018 #include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
00019 #include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
00020 #include <GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>
00021 #include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
00022 #include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
00023 #include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>
00024
00026 class DefaultTheme : public Theme {
00027     typedef Theme Base;
00028
00029     public:
00030         DefaultTheme();
00031         virtual ~DefaultTheme();
00032         void Update();
00033         virtual const ColorTable* GetSystemColorTable() const;
00034         virtual const WindowFrameView* GetWindowFrameView() const;
00035         virtual const ControlFrameView* GetControlFrameView() const;
00036         virtual const CheckBoxView* GetCheckBoxView() const;
00037         virtual const RadioButtonView* GetRadioButtonView() const;
00038         virtual const CheckBoxListView* GetCheckBoxListView() const;
00039         virtual const RadioButtonListView* GetRadioButtonListView() const;
00040         virtual const TextListView* GetTextListView() const;
00041         virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00042         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00043         virtual const ProgressBarView* GetProgressBarView() const;
00044         virtual const PushButtonView* GetPushButtonView() const;
00045
00046     private:
00047         DefaultWindowFrameView          m_window_frame_view;
00048         DefaultControlFrameView         m_control_frame_view;
00049         DefaultCheckBoxView             m_check_box_view;
00050         DefaultRadioButtonView          m_radio_button_view;
00051         DefaultCheckBoxListView         m_check_box_list_view;
00052         DefaultRadioButtonListView      m_radio_button_list_view;
00053         DefaultTextListView             m_text_list_view;
00054         DefaultSoftkeyBarView           m_softkey_bar_view;
00055         DefaultPositionIndicatorView    m_position_indicator_view;
00056         DefaultProgressBarView          m_progress_bar_view;
00057         DefaultPushButtonView           m_push_button_view;
00058 };
00059
00060 extern const DefaultTheme default_theme;
00061
00062 #endif
00063
00064
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.cpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultWindowFrameView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for DefaultWindowFrameView.cpp:

Generated on Tue Jan 24 20:20:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp File Reference

Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp File Reference

#include <Gui/WindowFrameView.hpp>

Include dependency graph for DefaultWindowFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultWindowFrameView

Defines

#define | Apoxi_DefaultWindowFrameView_hpp

Define Documentation

#define Apoxi_DefaultWindowFrameView_hpp

Generated on Tue Jan 24 20:20:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp Source File

Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultWindowFrameView_hpp)
00010 #define Apoxi_DefaultWindowFrameView_hpp
00011
00012 #include <Gui/WindowFrameView.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultWindowFrameView
00016     ------------------------------------------------------------------------ */
00017 class DefaultWindowFrameView : public WindowFrameView {
00018     typedef WindowFrameView Base;
00019
00020     public:
00021         DefaultWindowFrameView();
00022         DefaultWindowFrameView(XYDIM left_size,
00023                                XYDIM top_size,
00024                                XYDIM right_size,
00025                                XYDIM bottom_size,
00026                                XYDIM title_height,
00027                                XYDIM softkey_bar_height);
00028
00029         virtual ~DefaultWindowFrameView();
00030
00032         virtual void Update(const Theme &theme);
00033
00034
00035     protected:
00037         virtual void DrawControlFrame(const Control &control, DeviceContext *dc, const Rect &repaint_rect) const;
00038
00040         virtual void DrawWindowExtensions(const Window &window,  DeviceContext *dc, const Rect &repaint_rect) const;
00041 };
00042
00043 #endif  // Apoxi_DefaultWindowFrameView_hpp
00044
00045
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/PreComp.cpp File Reference

Compat/GlobalThemes/DefaultTheme/PreComp.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:01:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/PreComp.hpp File Reference

Compat/GlobalThemes/DefaultTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/DefaultTheme/PreComp.hpp Source File

Compat/GlobalThemes/DefaultTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Gui/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.cpp File Reference

Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"
#include "FoggySoftkeyBarView.hpp"
#include "Gui/TextFormat.hpp"
#include "Gui/PaintDc.hpp"
#include "Gui/DeviceContext.hpp"

Include dependency graph for FoggySoftkeyBarView.cpp:

Generated on Tue Jan 24 20:20:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp File Reference

Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp File Reference

#include <Gui/SoftkeyBar.hpp>

Include dependency graph for FoggySoftkeyBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FoggySoftkeyBarView

Defines

#define | Apoxi_FoggySoftkeyBarView_hpp

Define Documentation

#define Apoxi_FoggySoftkeyBarView_hpp

Generated on Tue Jan 24 20:20:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp Source File

Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_FoggySoftkeyBarView_hpp)
00010 #define Apoxi_FoggySoftkeyBarView_hpp
00011
00012 #include <Gui/SoftkeyBar.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     FoggySoftkeyBarView
00016     ------------------------------------------------------------------------ */
00017 class FoggySoftkeyBarView : public SoftkeyBarView {
00018     //typedef SoftkeyBarView Base;
00019
00020     public:
00021         virtual ~FoggySoftkeyBarView() {}
00022
00023     protected:
00024         virtual void DrawSoftkeyBar(const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const;
00025 };
00026
00027 #endif  // Apoxi_FoggySoftkeyBarView_hpp
00028
00029
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/FoggyTheme.cpp File Reference

Compat/GlobalThemes/FoggyTheme/FoggyTheme.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"
#include "FoggyTheme.hpp"
#include <Gui/Color.hpp>

Include dependency graph for FoggyTheme.cpp:

Variables

const Palette | c_foggy_system_color []
SystemColor | c_foggy_system_color_table [8]
const FoggyTheme | foggy_theme

Variable Documentation

const Palette c_foggy_system_color[]

Initial value:

 {
    {255, 255, 255},
    {0, 0, 0},
    {68, 102, 170},
    {255, 255, 255},
    {221, 221, 221},
    {0, 0, 0},
    {220, 180, 60},
    {120, 60, 40},
    {128, 128, 128}
    }

SystemColor c_foggy_system_color_table[8]

const FoggyTheme foggy_theme

Generated on Tue Jan 24 20:20:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/FoggyTheme.hpp File Reference

Compat/GlobalThemes/FoggyTheme/FoggyTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
#include <GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>

Include dependency graph for FoggyTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FoggyTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_FoggyTheme_hpp

Variables

const FoggyTheme | foggy_theme

Define Documentation

#define Apoxi_FoggyTheme_hpp

Variable Documentation

const FoggyTheme foggy_theme

Generated on Tue Jan 24 20:20:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/FoggyTheme.hpp Source File

Compat/GlobalThemes/FoggyTheme/FoggyTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_FoggyTheme_hpp)
00010 #define Apoxi_FoggyTheme_hpp
00011
00012 #include <Gui/Theme.hpp>
00013
00014 #include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
00015 #include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
00016 #include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
00017 #include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
00018 #include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
00019 #include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
00020 #include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
00021 #include <GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp>
00022 #include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
00023 #include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
00024 #include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>
00025
00027 class FoggyTheme : public Theme {
00028     public:
00029         FoggyTheme();
00030         virtual ~FoggyTheme();
00031         virtual void Update();
00032         virtual const SystemColor GetSystemColor(SystemColorId id) const;
00033         virtual const WindowFrameView* GetWindowFrameView() const;
00034         virtual const ControlFrameView* GetControlFrameView() const;
00035         virtual const CheckBoxView* GetCheckBoxView() const;
00036         virtual const RadioButtonView* GetRadioButtonView() const;
00037         virtual const CheckBoxListView* GetCheckBoxListView() const;
00038         virtual const RadioButtonListView* GetRadioButtonListView() const;
00039         virtual const TextListView* GetTextListView() const;
00040         virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00041         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00042         virtual const ProgressBarView* GetProgressBarView() const;
00043         virtual const PushButtonView* GetPushButtonView() const;
00044
00045     private:
00046         DefaultWindowFrameView          m_window_frame_view;
00047         DefaultControlFrameView         m_control_frame_view;
00048         DefaultCheckBoxView             m_check_box_view;
00049         DefaultRadioButtonView          m_radio_button_view;
00050         DefaultCheckBoxListView         m_check_box_list_view;
00051         DefaultRadioButtonListView      m_radio_button_list_view;
00052         DefaultTextListView             m_text_list_view;
00053         FoggySoftkeyBarView             m_softkey_bar_view;
00054         DefaultPositionIndicatorView    m_position_indicator_view;
00055         DefaultProgressBarView          m_progress_bar_view;
00056         DefaultPushButtonView           m_push_button_view;
00057 };
00058
00059 extern const FoggyTheme foggy_theme;
00060
00061 #endif
00062
00063
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/PreComp.cpp File Reference

Compat/GlobalThemes/FoggyTheme/PreComp.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:01:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/PreComp.hpp File Reference

Compat/GlobalThemes/FoggyTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/FoggyTheme/PreComp.hpp Source File

Compat/GlobalThemes/FoggyTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/PreComp.cpp File Reference

Compat/GlobalThemes/TestTheme/PreComp.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:04:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/PreComp.hpp File Reference

Compat/GlobalThemes/TestTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/PreComp.hpp Source File

Compat/GlobalThemes/TestTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Kernel/Lib.hpp>
00009 #include <Gui/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestCheckBoxListView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestCheckBoxListView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestCheckBoxListView.hpp"
#include "Gui/PaintDc.hpp"
#include "Gui/CheckBoxItem.hpp"

Include dependency graph for TestCheckBoxListView.cpp:

Generated on Tue Jan 24 20:20:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestCheckBoxListView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestCheckBoxListView.hpp File Reference

#include <Gui/CheckBoxList.hpp>

Include dependency graph for TestCheckBoxListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestCheckBoxListView

Defines

#define | Apoxi_TestCheckBoxListView_hpp

Define Documentation

#define Apoxi_TestCheckBoxListView_hpp

Generated on Tue Jan 24 20:20:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestCheckBoxListView.hpp Source File

Compat/GlobalThemes/TestTheme/TestCheckBoxListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestCheckBoxListView_hpp)
00010 #define Apoxi_TestCheckBoxListView_hpp
00011
00012 #include <Gui/CheckBoxList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     TestCheckBoxView
00016     ------------------------------------------------------------------------ */
00017 class TestCheckBoxListView : public CheckBoxListView {
00018     typedef CheckBoxListView Base;
00019
00020     public:
00021         TestCheckBoxListView(CheckBoxView *cb_view, XYDIM item_height);
00022         virtual ~TestCheckBoxListView() {}
00023
00024     protected:
00025         virtual void DrawCheckBoxItem(const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const;
00026 };
00027
00028 #endif  // Apoxi_TestCheckBoxListView_hpp
00029
00030
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestCheckBoxView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestCheckBoxView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestCheckBoxView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for TestCheckBoxView.cpp:

Generated on Tue Jan 24 20:20:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestCheckBoxView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestCheckBoxView.hpp File Reference

#include <Gui/CheckBox.hpp>

Include dependency graph for TestCheckBoxView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestCheckBoxView

Defines

#define | Apoxi_TestCheckBoxView_hpp

Define Documentation

#define Apoxi_TestCheckBoxView_hpp

Generated on Tue Jan 24 20:20:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestCheckBoxView.hpp Source File

Compat/GlobalThemes/TestTheme/TestCheckBoxView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestCheckBoxView_hpp)
00010 #define Apoxi_TestCheckBoxView_hpp
00011
00012 #include <Gui/CheckBox.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     TestCheckBoxView
00016     ------------------------------------------------------------------------ */
00017 class TestCheckBoxView : public CheckBoxView{
00018     public:
00019         typedef CheckBoxView Base;
00020
00021         TestCheckBoxView(XYDIM item_height, XYDIM left_gap, XYDIM middle_gap);
00022         virtual ~TestCheckBoxView() {}
00023
00024     protected:
00025         virtual void DrawCheckBox(const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00026         virtual void DrawShiftedCheckBox(const Rect &shift_rect, const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_TestCheckBoxView_hpp
00030
00031
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestControlFrameView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestControlFrameView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestControlFrameView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for TestControlFrameView.cpp:

Generated on Tue Jan 24 20:20:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestControlFrameView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestControlFrameView.hpp File Reference

#include <Gui/ControlFrameView.hpp>

Include dependency graph for TestControlFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestControlFrameView

Defines

#define | Apoxi_TestControlFrameView_hpp

Define Documentation

#define Apoxi_TestControlFrameView_hpp

Generated on Tue Jan 24 20:20:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestControlFrameView.hpp Source File

Compat/GlobalThemes/TestTheme/TestControlFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestControlFrameView_hpp)
00010 #define Apoxi_TestControlFrameView_hpp
00011
00012 #include <Gui/ControlFrameView.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     TestControlFrameView
00016     ------------------------------------------------------------------------ */
00017 class TestControlFrameView : public ControlFrameView {
00018     typedef ControlFrameView Base;
00019
00020     public:
00021         TestControlFrameView(XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size);
00022         virtual ~TestControlFrameView();
00023
00024     protected:
00026         virtual void DrawControlFrame(const Control &control, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_TestControlFrameView_hpp
00030
00031
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestPositionIndicatorView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for TestPositionIndicatorView.cpp:

Generated on Tue Jan 24 20:21:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.hpp File Reference

#include <Gui/PositionIndicator.hpp>

Include dependency graph for TestPositionIndicatorView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestPositionIndicatorView

Defines

#define | Apoxi_TestPositionIndicatorView_hpp

Define Documentation

#define Apoxi_TestPositionIndicatorView_hpp

Generated on Tue Jan 24 20:21:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.hpp Source File

Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestPositionIndicatorView_hpp)
00010 #define Apoxi_TestPositionIndicatorView_hpp
00011
00012 #include <Gui/PositionIndicator.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     TestPositionIndicatorView
00016     ------------------------------------------------------------------------ */
00017 class TestPositionIndicatorView : public PositionIndicatorView {
00018     typedef PositionIndicatorView Base;
00019
00020     public:
00021         TestPositionIndicatorView(XYDIM size);
00022
00023         virtual ~TestPositionIndicatorView() {}
00024
00025     protected:
00026         virtual void DrawPositionIndicator(const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_TestPositionIndicatorView_hpp
00030
00031
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestPushButtonView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestPushButtonView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestPushButtonView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for TestPushButtonView.cpp:

Generated on Tue Jan 24 20:21:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestPushButtonView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestPushButtonView.hpp File Reference

#include <Gui/PushButton.hpp>

Include dependency graph for TestPushButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestPushButtonView

Defines

#define | Apoxi_TestPushButtonView_hpp

Define Documentation

#define Apoxi_TestPushButtonView_hpp

Generated on Tue Jan 24 20:21:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestPushButtonView.hpp Source File

Compat/GlobalThemes/TestTheme/TestPushButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestPushButtonView_hpp)
00010 #define Apoxi_TestPushButtonView_hpp
00011
00012 #include <Gui/PushButton.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     TestPushButtonView
00016     ------------------------------------------------------------------------ */
00017 class TestPushButtonView : public PushButtonView {
00018     typedef PushButtonView Base;
00019
00020     public:
00021         TestPushButtonView(XYDIM default_height);
00022         virtual ~TestPushButtonView() {}
00023
00024     protected:
00025         virtual void DrawPushButton(const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const;
00026 };
00027
00028 #endif  // Apoxi_TestPushButtonView_hpp
00029
00030
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestRadioButtonListView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestRadioButtonListView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestRadioButtonListView.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for TestRadioButtonListView.cpp:

Generated on Tue Jan 24 20:21:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestRadioButtonListView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestRadioButtonListView.hpp File Reference

#include <Gui/RadioButtonList.hpp>

Include dependency graph for TestRadioButtonListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestRadioButtonListView

Defines

#define | Apoxi_TestRadioButtonListView_hpp

Define Documentation

#define Apoxi_TestRadioButtonListView_hpp

Generated on Tue Jan 24 20:21:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestRadioButtonListView.hpp Source File

Compat/GlobalThemes/TestTheme/TestRadioButtonListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestRadioButtonListView_hpp)
00010 #define Apoxi_TestRadioButtonListView_hpp
00011
00012 #include <Gui/RadioButtonList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     TestRadioButtonListView
00016     ------------------------------------------------------------------------ */
00017 class TestRadioButtonListView : public RadioButtonListView {
00018     typedef RadioButtonListView Base;
00019
00020     public:
00021         TestRadioButtonListView(RadioButtonView *rb_view, XYDIM item_height);
00022         virtual ~TestRadioButtonListView() {}
00023
00024     protected:
00025         virtual void DrawRadioButtonItem(const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const;
00026 };
00027
00028 #endif  // Apoxi_TestRadioButtonListView_hpp
00029
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestRadioButtonView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestRadioButtonView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestRadioButtonView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for TestRadioButtonView.cpp:

Generated on Tue Jan 24 20:21:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestRadioButtonView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestRadioButtonView.hpp File Reference

#include <Gui/RadioButton.hpp>

Include dependency graph for TestRadioButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestRadioButtonView

Defines

#define | Apoxi_TestRadioButtonView_hpp

Define Documentation

#define Apoxi_TestRadioButtonView_hpp

Generated on Tue Jan 24 20:21:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestRadioButtonView.hpp Source File

Compat/GlobalThemes/TestTheme/TestRadioButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestRadioButtonView_hpp)
00010 #define Apoxi_TestRadioButtonView_hpp
00011
00012 #include <Gui/RadioButton.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     TestRadioButtonView
00016     ------------------------------------------------------------------------ */
00017 class TestRadioButtonView : public RadioButtonView{
00018     public:
00019         typedef RadioButtonView Base;
00020
00021         TestRadioButtonView(XYDIM item_height, XYDIM left_gap, XYDIM middle_gap);
00022         virtual ~TestRadioButtonView() {}
00023
00024     protected:
00025         virtual void DrawRadioButton(const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00026         virtual void DrawShiftedRadioButton(const Rect &shift_rect, const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_TestRadioButtonView_hpp
00030
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestSoftkeyBarView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for TestSoftkeyBarView.cpp:

Generated on Tue Jan 24 20:21:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.hpp File Reference

#include <Gui/SoftkeyBar.hpp>

Include dependency graph for TestSoftkeyBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestSoftkeyBarView

Defines

#define | Apoxi_TestSoftkeyBarView_hpp

Define Documentation

#define Apoxi_TestSoftkeyBarView_hpp

Generated on Tue Jan 24 20:21:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.hpp Source File

Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestSoftkeyBarView_hpp)
00010 #define Apoxi_TestSoftkeyBarView_hpp
00011
00012 #include <Gui/SoftkeyBar.hpp>
00013
00014 class DeviceContext;
00015
00016 /*  ------------------------------------------------------------------------
00017     TestSoftkeyBarView
00018     ------------------------------------------------------------------------ */
00019 class TestSoftkeyBarView : public SoftkeyBarView {
00020     public:
00021         typedef SoftkeyBarView Base;
00022
00023         virtual ~TestSoftkeyBarView() {}
00024
00025     protected:
00026         virtual void DrawSoftkeyBar(const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const;
00027
00028     private:
00029         void DrawShadedRect(DeviceContext *dc, XYDIM left, XYDIM top, XYDIM right, XYDIM bottom, UINT8 red, UINT8 green, UINT8 blue) const;
00030
00031 };
00032
00033 #endif  // Apoxi_TestSoftkeyBarView_hpp
00034
00035
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestTheme.cpp File Reference

Compat/GlobalThemes/TestTheme/TestTheme.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestTheme.hpp"
#include <Gui/Color.hpp>

Include dependency graph for TestTheme.cpp:

Variables

const SystemColor | c_test_system_color_table []
const INT | c_test_system_font_table []
const TestTheme | test_theme

Variable Documentation

const SystemColor c_test_system_color_table[]

Initial value:

 {
    0x00FFFFFF,
    0x00322896,
    0x00225599,
    0x00FFFFFF,
    0x00BBBBBB,
    0x00DDDDDD,
    0x00DDDDEE,
    0x00000000,
    0x00999999
}

const INT c_test_system_font_table[]

Initial value:

 {
    1,
    1,
    1,
    1,
    1
}

const TestTheme test_theme

Generated on Tue Jan 24 20:21:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestTheme.hpp File Reference

Compat/GlobalThemes/TestTheme/TestTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/TestTheme/TestWindowFrameView.hpp>
#include <GlobalThemes/TestTheme/TestControlFrameView.hpp>
#include <GlobalThemes/TestTheme/TestCheckBoxView.hpp>
#include <GlobalThemes/TestTheme/TestRadioButtonView.hpp>
#include <GlobalThemes/TestTheme/TestCheckBoxListView.hpp>
#include <GlobalThemes/TestTheme/TestRadioButtonListView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
#include <GlobalThemes/TestTheme/TestSoftkeyBarView.hpp>
#include <GlobalThemes/TestTheme/TestPositionIndicatorView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
#include <GlobalThemes/TestTheme/TestPushButtonView.hpp>

Include dependency graph for TestTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_TestTheme_hpp

Variables

const TestTheme | test_theme

Define Documentation

#define Apoxi_TestTheme_hpp

Variable Documentation

const TestTheme test_theme

Generated on Tue Jan 24 20:21:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestTheme.hpp Source File

Compat/GlobalThemes/TestTheme/TestTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestTheme_hpp)
00010 #define Apoxi_TestTheme_hpp
00011
00012 #include <Gui/Theme.hpp>
00013
00014 #include <GlobalThemes/TestTheme/TestWindowFrameView.hpp>
00015 #include <GlobalThemes/TestTheme/TestControlFrameView.hpp>
00016 #include <GlobalThemes/TestTheme/TestCheckBoxView.hpp>
00017 #include <GlobalThemes/TestTheme/TestRadioButtonView.hpp>
00018 #include <GlobalThemes/TestTheme/TestCheckBoxListView.hpp>
00019 #include <GlobalThemes/TestTheme/TestRadioButtonListView.hpp>
00020 #include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>            // using default-view
00021 #include <GlobalThemes/TestTheme/TestSoftkeyBarView.hpp>
00022 #include <GlobalThemes/TestTheme/TestPositionIndicatorView.hpp>
00023 #include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>         // using default-view
00024 #include <GlobalThemes/TestTheme/TestPushButtonView.hpp>
00025
00027 class TestTheme : public Theme {
00028     public:
00029         TestTheme();
00030         virtual ~TestTheme();
00031         virtual const SystemColor GetSystemColor(SystemColorId id) const;
00032         virtual const FontId GetSystemFontId(SystemFontId id) const;
00033         virtual const WindowFrameView* GetWindowFrameView() const;
00034         virtual const ControlFrameView* GetControlFrameView() const;
00035         virtual const CheckBoxView* GetCheckBoxView() const;
00036         virtual const RadioButtonView* GetRadioButtonView() const;
00037         virtual const CheckBoxListView* GetCheckBoxListView() const;
00038         virtual const RadioButtonListView* GetRadioButtonListView() const;
00039         virtual const TextListView* GetTextListView() const;
00040         virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00041         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00042         virtual const ProgressBarView* GetProgressBarView() const;
00043         virtual const PushButtonView* GetPushButtonView() const;
00044
00045     private:
00046         TestWindowFrameView         m_window_frame_view;
00047         TestControlFrameView        m_control_frame_view;
00048         TestCheckBoxView            m_check_box_view;
00049         TestRadioButtonView         m_radio_button_view;
00050         TestCheckBoxListView        m_check_box_list_view;
00051         TestRadioButtonListView     m_radio_button_list_view;
00052         DefaultTextListView         m_text_list_view;
00053         TestSoftkeyBarView          m_softkey_bar_view;
00054         TestPositionIndicatorView   m_position_indicator_view;
00055         DefaultProgressBarView      m_progress_bar_view;
00056         TestPushButtonView          m_push_button_view;
00057 };
00058
00059 extern const TestTheme test_theme;
00060
00061 #endif
00062
00063
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestWindowFrameView.cpp File Reference

Compat/GlobalThemes/TestTheme/TestWindowFrameView.cpp File Reference

#include "GlobalThemes/TestTheme/PreComp.hpp"
#include "TestWindowFrameView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for TestWindowFrameView.cpp:

Generated on Tue Jan 24 20:21:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestWindowFrameView.hpp File Reference

Compat/GlobalThemes/TestTheme/TestWindowFrameView.hpp File Reference

#include <Gui/WindowFrameView.hpp>

Include dependency graph for TestWindowFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestWindowFrameView

Defines

#define | Apoxi_TestWindowFrameView_hpp

Define Documentation

#define Apoxi_TestWindowFrameView_hpp

Generated on Tue Jan 24 20:21:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compat/GlobalThemes/TestTheme/TestWindowFrameView.hpp Source File

Compat/GlobalThemes/TestTheme/TestWindowFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestWindowFrameView_hpp)
00010 #define Apoxi_TestWindowFrameView_hpp
00011
00012 #include <Gui/WindowFrameView.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     TestWindowFrameView
00016     ------------------------------------------------------------------------ */
00017 class TestWindowFrameView : public WindowFrameView {
00018     typedef WindowFrameView Base;
00019
00020     public:
00021         TestWindowFrameView(XYDIM left_size,
00022                             XYDIM top_size,
00023                             XYDIM right_size,
00024                             XYDIM bottom_size,
00025                             XYDIM title_height,
00026                             XYDIM softkey_bar_height);
00027
00028         virtual ~TestWindowFrameView();
00029
00030     protected:
00032         virtual void DrawControlFrame(const Control &control, DeviceContext *dc, const Rect &repaint_rect) const;
00033
00035         virtual void DrawWindowExtensions(const Window &window,  DeviceContext *dc, const Rect &repaint_rect) const;
00036 };
00037
00038 #endif  // Apoxi_TestWindowFrameView_hpp
00039
00040
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractDevice.cpp File Reference

Devices/AbstractDevice.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "AbstractDevice.hpp"

Include dependency graph for AbstractDevice.cpp:

Generated on Tue Jan 24 20:22:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractDevice.hpp File Reference

Devices/AbstractDevice.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for AbstractDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractDevice
union | AbstractDevice::ControlArg

Defines

#define | Apoxi_AbstractDevice_hpp

Define Documentation

#define Apoxi_AbstractDevice_hpp

Generated on Tue Jan 24 20:23:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractDevice.hpp Source File

Devices/AbstractDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractDevice_hpp)
00010 #define Apoxi_AbstractDevice_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/Macros.hpp>
00016
00020 class AbstractDevice {
00021     public:
00026         enum Category {
00027             DisplayCategory = 0,
00028             StillCameraCategory = 1,
00029             VideoCameraCategory = 2,
00030             KeyboardCategory = 3,
00031             LedCategory = 4,
00032             ChargerCategory = 5,
00033             RealTimeClockCategory = 6,
00034             CodecCategory = 7,
00035             CustomCategory = 100
00036         };
00037
00039         union ControlArg {
00040             ControlArg() {};
00041             ControlArg(BOOLEAN val) {m_boolean = val;}
00042             ControlArg(UINT8 val) {m_uint8 = val;}
00043             ControlArg(INT8 val) {m_int8 = val;}
00044             ControlArg(UINT16 val) {m_uint16 = val;}
00045             ControlArg(INT16 val) {m_int16 = val;}
00046             ControlArg(UINT32 val) {m_uint32 = val;}
00047             ControlArg(INT32 val) {m_int32 = val;}
00048             ControlArg(CHAR* val) {m_char_ptr = val;}
00049             ControlArg(WCHAR* val) {m_wchar_ptr = val;}
00050             ControlArg(void* val) {m_void_ptr = val;}
00051
00052             BOOLEAN m_boolean;
00053             UINT8 m_uint8;
00054             INT8 m_int8;
00055             UINT16 m_uint16;
00056             INT16 m_int16;
00057             UINT32 m_uint32;
00058             INT32 m_int32;
00059             CHAR* m_char_ptr;
00060             WCHAR* m_wchar_ptr;
00061             void* m_void_ptr;
00062         };
00063
00071         explicit AbstractDevice(INT category = CustomCategory, INT index = 0);
00072
00073         virtual ~AbstractDevice();
00074
00077         virtual const WCHAR* GetName() const = 0;
00078
00083         INT GetCategory() const { return (INT)m_category; }
00084
00089         INT GetIndex() const { return (INT)m_index; }
00090
00096         ControlArg Control(INT command, ControlArg arg);
00097
00098     protected:
00102         virtual void OnStart();
00103
00107         virtual void OnStop();
00108
00109     private:
00110         UINT8 m_category;
00111         UINT8 m_index;
00112         AbstractDevice* m_next;
00113
00115         AbstractDevice(const AbstractDevice& device);
00116
00118         AbstractDevice& operator=(const AbstractDevice& device);
00119
00120         friend class DeviceManager;             // reads and adjusts m_next property
00121 };
00122
00124 #endif  // Apoxi_Device_hpp
00125
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractLockableDevice.cpp File Reference

Devices/AbstractLockableDevice.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "AbstractLockableDevice.hpp"

Include dependency graph for AbstractLockableDevice.cpp:

Generated on Tue Jan 24 20:23:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractLockableDevice.hpp File Reference

Devices/AbstractLockableDevice.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Devices/AbstractDevice.hpp>

Include dependency graph for AbstractLockableDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractLockableDevice
Abstract base class for all hardware devices. More...

Defines

#define | Apoxi_AbstractLockableDevice_hpp

Define Documentation

#define Apoxi_AbstractLockableDevice_hpp

Generated on Tue Jan 24 20:23:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractLockableDevice.hpp Source File

Devices/AbstractLockableDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractLockableDevice_hpp)
00010 #define Apoxi_AbstractLockableDevice_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/Macros.hpp>
00016 #include <Devices/AbstractDevice.hpp>
00017
00019 class AbstractLockableDevice : public AbstractDevice {
00020     typedef AbstractDevice Base;
00021
00022     public:
00023
00024         AbstractLockableDevice(INT category, INT device_id) : Base(category, device_id) {};
00025
00029         virtual BOOLEAN Lock();
00030
00033         virtual BOOLEAN Unlock();
00034
00035     protected:
00036
00037         virtual BOOLEAN& GetLock() = 0;
00038
00039     private:
00040
00041         BOOLEAN InitSemaphore();
00042         static BOOLEAN m_initialized;
00043         static Semaphore m_sem;
00044
00045
00046 };
00047
00049 #endif  // Apoxi_AbstractLockableDevice_hpp
00050
00051
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractTransport.cpp File Reference

Devices/AbstractTransport.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "Kernel/MessageRouter.hpp"
#include "Devices/Messages/TransportNotificationMsg.hpp"
#include "Devices/AbstractTransport.hpp"

Include dependency graph for AbstractTransport.cpp:

Generated on Tue Jan 24 20:23:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractTransport.hpp File Reference

Devices/AbstractTransport.hpp File Reference

#include <Auxiliary/ObservableObject.hpp>

Include dependency graph for AbstractTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractTransport
Abstract representation of communication hardware. More...

Defines

#define | Apoxi_AbstractTransport_hpp

Define Documentation

#define Apoxi_AbstractTransport_hpp

Generated on Tue Jan 24 20:23:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AbstractTransport.hpp Source File

Devices/AbstractTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_AbstractTransport_hpp)
00010 #define Apoxi_AbstractTransport_hpp
00011
00012 #include <Auxiliary/ObservableObject.hpp>
00013
00014 // Forward declarations of classes
00015 class Application;
00016
00024 class AbstractTransport : public ObservableObject {
00025
00026     public:
00027         typedef ObservableObject    Base;
00028
00030         enum AvState {
00031             AvsReady,
00032             AvsBusy,
00033             AvsConflict,
00034             AvsDisabled
00035         };
00036
00037         enum NotificationMsgType {
00038             NotifyAvStateChanged
00039         };
00040
00049         BOOLEAN                 RegisterTransportApp(Application *  app_ptr);
00050
00055         inline  WString         GetMmiName() const;
00056
00063         virtual void            Enable() = 0;
00064
00070         virtual AvState         GetAvState() const = 0;
00071
00072     protected:
00075         AbstractTransport(const WCHAR *     mmi_name_str);
00076
00078         inline  Application *   GetAppPtr() const;
00079
00086         void                    OnAvStateChanged();
00087
00088     private:
00089         const WCHAR *   m_mmi_name_str;
00090         Application *   m_app_ptr;
00091 };
00092
00093 /*  ----------------------------------------------------------------------
00094     GetAppPtr
00095     ---------------------------------------------------------------------- */
00096 Application *   AbstractTransport::GetAppPtr()
00097 const
00098 {
00099     return m_app_ptr;
00100 }// GetAppPtr
00101
00102 /*  ----------------------------------------------------------------------
00103     GetMmiName
00104     ---------------------------------------------------------------------- */
00105 WString     AbstractTransport::GetMmiName()
00106 const
00107 {
00108     return WString(m_mmi_name_str);
00109 }// GetMmiName
00110
00111
00112 #endif  // Apoxi_AbstractTransport_hpp
00113
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioAccessoryDetails.hpp File Reference

Devices/AudioAccessoryDetails.hpp File Reference

#include <Audio/AudioAccessoryDetails.hpp>

Include dependency graph for AudioAccessoryDetails.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:06:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioAccessoryDetails.hpp Source File

Devices/AudioAccessoryDetails.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioAccessoryDetails.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioAccessoryStore.hpp File Reference

Devices/AudioAccessoryStore.hpp File Reference

#include <Audio/AudioAccessoryStore.hpp>

Include dependency graph for AudioAccessoryStore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:06:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioAccessoryStore.hpp Source File

Devices/AudioAccessoryStore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioAccessoryStore.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioActiveReference.hpp File Reference

Devices/AudioActiveReference.hpp File Reference

#include <Audio/AudioActiveReference.hpp>

Include dependency graph for AudioActiveReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:06:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioActiveReference.hpp Source File

Devices/AudioActiveReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioActiveReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioDef.hpp File Reference

Devices/AudioDef.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | AUD_DBG_NR (0)
#define | AUD_DBG_OUT(x) DBG_OUT(x)
#define | AudioDef_hpp

Define Documentation

#define AUD_DBG_NR (0)

#define AUD_DBG_OUT ( x ) DBG_OUT(x)

#define AudioDef_hpp

Generated on Tue Jan 24 20:23:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioDef.hpp Source File

Devices/AudioDef.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AudioDef_hpp)
00010 #define AudioDef_hpp
00011
00012 // If the #define AUD_DBG_OUT(x) DBG_OUT(x) is defined than all function
00013 // calls to the audio driver (see aud_drv.h) incl. the calling paramter are dumped.
00014 #define AUD_DBG_OUT(x) DBG_OUT(x)
00015 // #define AUD_DBG_OUT(x)
00016 #define AUD_DBG_NR  (0)
00017
00018 #endif // #define AudioDef_hpp
00019
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioDeviceBase.hpp File Reference

Devices/AudioDeviceBase.hpp File Reference

#include <Audio/AudioDeviceBase.hpp>

Include dependency graph for AudioDeviceBase.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:07:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioDeviceBase.hpp Source File

Devices/AudioDeviceBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioDeviceBase.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioDeviceManager.hpp File Reference

Devices/AudioDeviceManager.hpp File Reference

#include <Audio/AudioDeviceManager.hpp>

Include dependency graph for AudioDeviceManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:07:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioDeviceManager.hpp Source File

Devices/AudioDeviceManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioDeviceManager.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioDwdIdManager.hpp File Reference

Devices/AudioDwdIdManager.hpp File Reference

#include <Audio/AudioDwdIdManager.hpp>

Include dependency graph for AudioDwdIdManager.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:23:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioDwdIdManager.hpp Source File

Devices/AudioDwdIdManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioDwdIdManager.hpp>
00010
00011
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioError.hpp File Reference

Devices/AudioError.hpp File Reference

#include <Audio/AudioError.hpp>

Include dependency graph for AudioError.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:07:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioError.hpp Source File

Devices/AudioError.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioError.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioMsgProcessor.hpp File Reference

Devices/AudioMsgProcessor.hpp File Reference

#include <Audio/AudioMsgProcessor.hpp>

Include dependency graph for AudioMsgProcessor.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:07:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioMsgProcessor.hpp Source File

Devices/AudioMsgProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Audio/AudioMsgProcessor.hpp>
00009
00010
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPath.hpp File Reference

Devices/AudioPath.hpp File Reference

#include <Audio/AudioPath.hpp>

Include dependency graph for AudioPath.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:07:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPath.hpp Source File

Devices/AudioPath.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioPath.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPathManager.hpp File Reference

Devices/AudioPathManager.hpp File Reference

#include <Audio/AudioPathManager.hpp>

Include dependency graph for AudioPathManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:07:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPathManager.hpp Source File

Devices/AudioPathManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioPathManager.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPlayer.hpp File Reference

Devices/AudioPlayer.hpp File Reference

#include <Audio/AudioPlayer.hpp>

Include dependency graph for AudioPlayer.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:07:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPlayer.hpp Source File

Devices/AudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioPlayer.hpp>
00010
00011
Generated on Tue Jan 24 14:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPreset.hpp File Reference

Devices/AudioPreset.hpp File Reference

#include <Audio/AudioPreset.hpp>

Include dependency graph for AudioPreset.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:08:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPreset.hpp Source File

Devices/AudioPreset.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioPreset.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPresetStore.hpp File Reference

Devices/AudioPresetStore.hpp File Reference

#include <Audio/AudioPresetStore.hpp>

Include dependency graph for AudioPresetStore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:08:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPresetStore.hpp Source File

Devices/AudioPresetStore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioPresetStore.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPriorityManager.hpp File Reference

Devices/AudioPriorityManager.hpp File Reference

#include <Audio/AudioPriorityManager.hpp>

Include dependency graph for AudioPriorityManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:08:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioPriorityManager.hpp Source File

Devices/AudioPriorityManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioPriorityManager.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioReference.hpp File Reference

Devices/AudioReference.hpp File Reference

#include <Audio/AudioReference.hpp>

Include dependency graph for AudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:08:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioReference.hpp Source File

Devices/AudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioSignalMapTableNode.hpp File Reference

Devices/AudioSignalMapTableNode.hpp File Reference

#include <Audio/AudioAudioSignalMapTableNode.hpp>

Include dependency graph for AudioSignalMapTableNode.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:08:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioSignalMapTableNode.hpp Source File

Devices/AudioSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #include <Audio/AudioAudioSignalMapTableNode.hpp>
00009
00010
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioSuspendedDetails.hpp File Reference

Devices/AudioSuspendedDetails.hpp File Reference

#include <Audio/AudioSuspendedDetails.hpp>

Include dependency graph for AudioSuspendedDetails.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:08:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioSuspendedDetails.hpp Source File

Devices/AudioSuspendedDetails.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioSuspendedDetails.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioUtility.hpp File Reference

Devices/AudioUtility.hpp File Reference

#include <Audio/AudioUtility.hpp>

Include dependency graph for AudioUtility.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:08:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioUtility.hpp Source File

Devices/AudioUtility.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioUtility.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioVibratorDevice.hpp File Reference

Devices/AudioVibratorDevice.hpp File Reference

#include <Audio/AudioVibratorDevice.hpp>

Include dependency graph for AudioVibratorDevice.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:09:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/AudioVibratorDevice.hpp Source File

Devices/AudioVibratorDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/AudioVibratorDevice.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Camera.hpp File Reference

Devices/Camera.hpp File Reference

#include <Devices/Win32/Camera.hpp>

Include dependency graph for Camera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_Camera_hpp

Define Documentation

#define Apoxi_Devices_Camera_hpp

Generated on Tue Jan 24 20:24:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Camera.hpp Source File

Devices/Camera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_Devices_Camera_hpp)
00010 #define Apoxi_Devices_Camera_hpp
00011
00014
00015 #if defined(APOXI_RTOS_WIN32)
00016     #if defined(APOXI_ATI_SUPPORT)
00017         #include <Devices/MPEU/Extensions/AtiW2282/Camera.hpp>
00018     #else
00019     #include <Devices/Win32/Camera.hpp>
00020     #endif
00021 #elif defined(APOXI_PLATFORM_BP30)
00022     #include <Devices/BP30/Camera.hpp>
00023 #elif defined(APOXI_PLATFORM_MPE)
00024     #include <Devices/MPE/Camera.hpp>
00025 #elif defined(APOXI_PLATFORM_MPEU)
00026     #include <Devices/MPEU/Camera.hpp>
00027 #elif defined(APOXI_PLATFORM_MP1U)
00028     #include <Devices/SGold/Camera.hpp>
00029 #else
00030     #error Platform not supported!
00031 #endif
00032
00034 #endif //Apoxi_Devices_Camera_hpp
00035
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CameraInterface.hpp File Reference

Devices/CameraInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Camera
struct | Camera::ParameterLimits

Generated on Tue Jan 24 20:28:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CameraInterface.hpp Source File

Devices/CameraInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00013 #if defined DOXYGEN_SHOULD_SKIP_THIS
00014 class Camera {
00015 #endif
00016     public:
00017
00018         typedef struct ParameterLimits {
00019                 INT min;
00020                 INT def;
00021                 INT max;
00022         } ParameterLimits;
00023
00025         enum AntiFlickerType {
00027             AntiFlickerNotSupported,
00029             AntiFlickerDisabled,
00031             AntiFlickerHz50,
00033             AntiFlickerHz60
00034         };
00035
00037         enum WhiteBalanceType {
00039             AutoBalance,
00041             SunlightBalance,
00043             CloudyBalance,
00045             IncandescentBalance,
00047             FluorescentBalance
00048         };
00049
00050         enum MeteringType {
00052             FullImageMetering,
00054             CenterBasedMetering
00055         };
00056
00060         enum TransformationType {
00062             NoTransformation,
00064             Rotate90,
00066             Rotate180,
00068             Rotate270,
00070             Mirror,
00072             MirrorRotate90,
00074             MirrorRotate180,
00076             MirrorRotate270
00077         };
00078
00080         enum FlashType {
00082             FlashNotSupported,
00084             FlashDisabled,
00086             FlashEnabled,
00088             AutomaticFlash,
00090             RedEyeReductionFlash
00091         };
00092
00094         enum TwilightType {
00096             TwilightOff,
00098             TwilightOn,
00100             TwilightAuto
00101         };
00102
00105         enum ImageSizeType {
00107             QqcifSize,
00109             Size96x96,
00111             SqcifSize,
00113             QqvgaSize,
00115             QcifSize,
00117             QsifSize,
00119             QvgaSize,
00121             CifSize,
00123             VgaSize,
00125             SvgaSize,
00127             XgaSize,
00129             Size1Mp,
00131             Size1_3Mp,
00133             SxgaSize,
00135             UxgaSize,
00137             Size2Mp,
00139             Size3Mp,
00141             EndOfImageSizeType
00142         };
00143
00145         enum ScalingMethodType{
00147             NoScaling,
00149             LetterboxScaling,
00152             BestFitScaling
00153         };
00154
00156         enum FilterType {
00157             NoFilter = 0,
00158             SepiaFilter,
00159             EmbossFilter,
00160             GrayScaleFilter,
00161             NegativeFilter,
00162             HorrorFilter = 50,
00163             HazeFilter = 51,
00164             GlassTileFilter = 52,
00165             PuzzleTileFilter = 53,
00166             OilpaintFilter = 54,
00167             PictureFrameFilter = 55,
00168             FilmFilter = 56,
00169             ConcaveFilter = 57,
00170             EndOfFilterType
00171         };
00172
00174         enum ActionType {
00176             Decrease,
00178             Reset,
00180             Increase
00181         };
00182
00185         enum CameraError {
00186             NoError,
00188             CameraAlreadyLockedError,
00190             CameraNotReadyError,
00192             UnsupportedCameraFeature,
00194             CameraNotInitializedError,
00196             BufferNotAvailableError,
00198             BufferAllocationError,
00200             VideoEncoderBufferAllocationError,
00202             ApplicationControlError,
00204             UnsupportedFrameRateError,
00206             InvalidCameraParameter,
00208             InvalidSizeError,
00210             JpegEncodingError,
00212             UserAbortedError
00213         };
00214
00215         enum Result {
00216             ViewfinderStarted,
00217             ViewfinderStopped,
00218             BrightnessChanged,
00219             ContrastChanged,
00220             ExposureChanged,
00221             FilterChanged,
00222             AntiflickerChanged,
00223             TwilightChanged,
00224             WhiteBalanceChanged,
00225             FrameRateChanged,
00226             VideoCaptureStarted,            // not used yet, only for future use
00227             VideoCaptureStopped,
00228             VideoCapturePaused,
00229             VideoCaptureUnPaused            // not used yet, only for future use
00230         };
00231
00232         enum CameraState {
00233             UnitializedState,
00234             IdleState,
00235             ViewfindingState,
00236             ViewfinderHiddenState,
00237             ImageCapturingState,
00238             VideoCapturingState,
00239             VideoCapturingHiddenState,
00240             ViewfinderHoldState,
00241             ViewfinderHoldHiddenState,
00242             VideoCapturingPausedState,
00243             ErrorState
00244         };
00245
00248         Camera(INT category, INT device_id);
00249
00250         virtual ~Camera();
00251
00256         virtual BOOLEAN Open();
00257
00260         virtual BOOLEAN Close();
00261
00264         INT GetDisplayIndex() const;
00265
00268         INT GetLastError() const;
00269
00271         CameraState GetState() const;
00272
00273 #if defined(APOXI_COMPAT_2_8_0)
00274
00279         virtual BOOLEAN SetCaptureTransformation(TransformationType trans);
00280 #endif  // #if defined(APOXI_COMPAT_2_8_0)
00281
00283         TransformationType GetCaptureTransformation() const;
00284
00290         virtual BOOLEAN SetViewScalingMethod(ScalingMethodType scaling_method);
00291
00293         ScalingMethodType GetViewScalingMethod() const;
00294
00300         virtual BOOLEAN GetSupportedImageSizes(const ImageSizeType* &array, UINT8& count) const;
00301
00302 #if defined(APOXI_COMPAT_2_8_0)
00303
00307         virtual BOOLEAN SetImageSize(ImageSizeType size);
00308 #endif  // #if defined(APOXI_COMPAT_2_8_0)
00309
00314         virtual BOOLEAN SetCaptureImageSize(ImageSizeType capture_image_size,
00315                                             TransformationType capture_transformation =
00316                                                                 Camera::NoTransformation);
00317
00319         ImageSizeType GetSelectedImageSize() const;
00320
00325         static const Size GetImageSizeDimensions(ImageSizeType size_type);
00326
00331         BOOLEAN SetFlash(FlashType flash);
00332
00335         FlashType GetFlash() const;
00336
00344         virtual BOOLEAN SetZoom(ActionType action, UINT8 step_size = 1);
00345
00350         virtual INT GetZoomLevelCount() const;
00351
00355         BOOLEAN SetBrightness(INT brightness);
00356
00359         INT GetBrightness() const;
00360
00366         BOOLEAN GetBrightnessLimits(INT& min_level, INT& max_level, INT& def_level);
00367
00372         BOOLEAN SetContrast(INT level);
00373
00376         INT GetContrast() const;
00377
00383         BOOLEAN GetContrastLimits(INT& min_level, INT& max_level, INT& def_level);
00384
00392         BOOLEAN SetExposure(INT level);
00393
00395         INT GetExposure() const;
00396
00402         BOOLEAN GetExposureLimits(INT& min_level, INT& max_level, INT& def_level);
00403
00410         BOOLEAN SetTwilightMode(TwilightType twilight);
00411
00413         /*  TwilightAuto is currently not supported. When set, function returns FALSE and
00414             last camera error is set to UnsupportedCameraFeature. */
00415         TwilightType GetTwilightMode() const;
00416
00422         BOOLEAN SetAntiFlickerMode(AntiFlickerType anti_flicker_mode);
00423
00426         AntiFlickerType GetAntiFlickerMode() const;
00427
00433         BOOLEAN SetFilter(FilterType filter);
00434
00437         FilterType GetFilter() const;
00438
00443         BOOLEAN SetWhiteBalance(WhiteBalanceType white_balance_mode);
00444
00446         WhiteBalanceType GetWhiteBalance() const;
00447
00454         BOOLEAN SetMeteringMode(MeteringType metering_mode);
00455
00457         MeteringType GetMeteringMode() const;
00458
00459 #if defined(APOXI_COMPAT_2_8_0)
00460
00467         virtual BOOLEAN SetViewfinderRect(const Rect& vf_rect,
00468                                           UINT8 display_idx = 0,
00469                                           TransformationType transformation = NoTransformation);
00470 #endif  // #if defined(APOXI_COMPAT_2_8_0)
00471
00482         virtual BOOLEAN SetViewfinderRect(Rect& vf_rect,
00483                                           INT display_idx = 0,
00484                                           TransformationType view_transformation = NoTransformation,
00485                                           ScalingMethodType view_scaling_method = NoScaling);
00486
00491         BOOLEAN GetEffectiveViewfinderRect(Rect& effective_rect);
00492
00521         BOOLEAN SetTwinViewfinderEnabled(BOOLEAN enabled);
00522
00524         BOOLEAN IsTwinViewfinderEnabled() const;
00525
00530         virtual BOOLEAN StartViewfinder();
00531
00532         /* tbd: can maybe done in StartViewfinder - check availability in GDD */
00533         virtual BOOLEAN RestartViewfinder();
00534
00537         virtual BOOLEAN StopViewfinder();
00538
00543         virtual BOOLEAN HideViewfinder();
00544
00549         virtual BOOLEAN ShowViewfinder();
00550
00551 #if defined DOXYGEN_SHOULD_SKIP_THIS
00552 };
00553 #endif
00554
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Charger.hpp File Reference

Devices/Charger.hpp File Reference

#include <Devices/Win32/Charger.hpp>

Include dependency graph for Charger.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_Charger_hpp

Define Documentation

#define Apoxi_Devices_Charger_hpp

Generated on Tue Jan 24 20:24:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Charger.hpp Source File

Devices/Charger.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Devices_Charger_hpp)
00011 #define Apoxi_Devices_Charger_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Devices/Win32/Charger.hpp>
00018 #elif defined(APOXI_PLATFORM_BP30)
00019     #include <Devices/BP30/Charger.hpp>
00020 #elif defined(APOXI_PLATFORM_MPE)
00021     #include <Devices/MPE/Charger.hpp>
00022 #elif defined(APOXI_PLATFORM_MPEU)
00023     #include <Devices/MPEU/Charger.hpp>
00024 #elif defined(APOXI_PLATFORM_MP1U)
00025     #include <Devices/SGold/Charger.hpp>
00026 #else
00027     #error Platform not supported!
00028 #endif
00029
00031 #endif  // Apoxi_Devices_Charger_hpp
00032
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerInterface.hpp File Reference

Devices/ChargerInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class Charger

Generated on Tue Jan 24 20:28:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerInterface.hpp Source File

Devices/ChargerInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00012 #if defined DOXYGEN_SHOULD_SKIP_THIS
00013 class Charger {
00014 #endif
00015     public:
00017         enum ChargerMsgType {
00018             ChargerRemoved,
00019             ChargeBattery,
00020             ChargingPaused,
00021             ChargingResumed,
00022             LowBattery,
00023             BatteryIdError,
00024             BatteryEmpty,
00025             ChargeEndChargerIsDisconnected,
00026             ChargeEndBatteryIsFull
00027         };
00028
00030         enum ChargerStatus {
00031             Disabled,
00032             WaitingForConnection,
00033             ConnectedAndCharging,
00034             ConnectedAndTemperatureProtection,
00035             ConnectedAndBatteryFull,
00036             DisconnectedAndBatteryFull,
00037             DisconnectedAndBatteryNotFull,
00038             ChargerDisabledBatteryIdError,
00039             ChargerDisabledVoltageError
00040         };
00041
00043         virtual ~Charger();
00044
00046         virtual const WCHAR* GetName() const;
00047
00049         static ControlArg Control(INT command, ControlArg arg);
00050
00052         static void Charge(BOOLEAN charge);
00053
00055         static ChargerStatus GetStatus();
00056
00058         static UINT8 GetCapacityStatus();
00059
00061         static BOOLEAN IsChargerInserted();
00062
00064         static INT16 GetBatteryVoltage();
00065
00067         static void StartBatteryLoadListening();
00068
00070         static void StopBatteryLoadListening();
00071
00073         static BOOLEAN IsBatteryLow();
00074
00076         static void SetUsbCharging(BOOLEAN enable);
00077
00079         static BOOLEAN IsUsbChargingEnabled();
00080
00081     private:
00082         static Charger m_charger;
00083
00084         Charger();
00085
00086 #if defined DOXYGEN_SHOULD_SKIP_THIS
00087 };
00088 #endif
00089
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerMsgTypes.cpp File Reference

Devices/ChargerMsgTypes.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "ChargerMsgTypes.hpp"

Include dependency graph for ChargerMsgTypes.cpp:

Generated on Tue Jan 24 20:28:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerMsgTypes.hpp File Reference

Devices/ChargerMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Apc/SignalTypes.hpp>
#include <Devices/Charger.hpp>

Include dependency graph for ChargerMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BatteryLoadLevelMsg
class | ChargerInfoMsg

Defines

#define | Devices_ChargerMsgTypes_hpp

Define Documentation

#define Devices_ChargerMsgTypes_hpp

Generated on Tue Jan 24 20:28:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerMsgTypes.hpp Source File

Devices/ChargerMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "auzinger_view_fp1g_dv_snap\lnz_apoxi\Apoxi\Devices\ChargerMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(Devices_ChargerMsgTypes_hpp)
00017 #define Devices_ChargerMsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Apc/SignalTypes.hpp>
00021 #include <Devices/Charger.hpp>
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class ChargerInfoMsg
00029     ====================================================================== */
00030
00032 class ChargerInfoMsg : public Message {
00033     public:
00034         ChargerInfoMsg(const Charger::ChargerMsgType& charger_msg_type);
00035         virtual ~ChargerInfoMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         const Charger::ChargerMsgType& GetChargerMsgType() const { return m_charger_msg_type; }
00039         virtual Message* Clone() const;
00040
00041         enum  {
00042             ID = 9150
00043             };
00044
00045     private:
00046         static const MsgMetaData m_meta_data;
00047         Charger::ChargerMsgType m_charger_msg_type;
00048
00049     };
00050
00051
00052 /*  ======================================================================
00053     Class BatteryLoadLevelMsg
00054     ====================================================================== */
00055
00057 class BatteryLoadLevelMsg : public Message {
00058     public:
00059         BatteryLoadLevelMsg(const BatteryLoadLevel& arg);
00060         virtual ~BatteryLoadLevelMsg();
00061
00062         virtual const MsgMetaData& GetMetaData() const;
00063         void SetArg(const BatteryLoadLevel& arg) { m_arg = arg; }
00064         const BatteryLoadLevel& GetArg() const { return m_arg; }
00065         virtual Message* Clone() const;
00066
00067         enum  {
00068             ID = 9151
00069             };
00070
00071     private:
00072         static const MsgMetaData m_meta_data;
00073         BatteryLoadLevel m_arg;
00074
00075     };
00076
00077 #endif // Devices_ChargerMsgTypes_hpp
00078
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerSignalMapTableNode.cpp File Reference

Devices/ChargerSignalMapTableNode.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "ChargerSignalMapTableNode.hpp"
#include "ChargerSignalProcessor.hpp"

Include dependency graph for ChargerSignalMapTableNode.cpp:

Generated on Tue Jan 24 20:28:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerSignalMapTableNode.hpp File Reference

Devices/ChargerSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for ChargerSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ChargerSignalMapTableNode

Defines

#define | Apoxi_Devices_ChargerSignalMapTableNode_hpp

Define Documentation

#define Apoxi_Devices_ChargerSignalMapTableNode_hpp

Generated on Tue Jan 24 20:28:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerSignalMapTableNode.hpp Source File

Devices/ChargerSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_ChargerSignalMapTableNode_hpp)
00010 #define Apoxi_Devices_ChargerSignalMapTableNode_hpp
00013
00014 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00015
00016 /*  ======================================================================
00017     ChargerSignalMapTableNode
00018     ====================================================================== */
00019 class ChargerSignalMapTableNode : public SignalMapTableNode {
00020     public:
00021         static ChargerSignalMapTableNode* GetInstance();
00022
00023     private:
00024         static ChargerSignalMapTableNode *m_node;
00025         static const SignalMapTableEntry m_map_table[];
00026
00027         ChargerSignalMapTableNode();
00028 };
00029
00031 #endif  // Apoxi_Devices_ChargerSignalMapTableNode_hpp
00032
00033
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerSignalProcessor.cpp File Reference

Devices/ChargerSignalProcessor.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "ChargerSignalProcessor.hpp"
#include <Kernel/MessageRouter.hpp>
#include <Devices/ChargerMsgTypes.hpp>
#include <Adc/DataHandler.hpp>

Include dependency graph for ChargerSignalProcessor.cpp:

Generated on Tue Jan 24 20:28:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerSignalProcessor.hpp File Reference

Devices/ChargerSignalProcessor.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableEntry.hpp>

Include dependency graph for ChargerSignalProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ChargerSignalProcessor

Defines

#define | Apoxi_Devices_ChargerSignalProcessor_hpp

Define Documentation

#define Apoxi_Devices_ChargerSignalProcessor_hpp

Generated on Tue Jan 24 20:28:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ChargerSignalProcessor.hpp Source File

Devices/ChargerSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_ChargerSignalProcessor_hpp)
00010 #define Apoxi_Devices_ChargerSignalProcessor_hpp
00011
00014
00015 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>
00016
00018 class ChargerSignalProcessor {
00019     public:
00020         static void PostStopChargingBatteryInd(const ProcessPtr &process_ptr);
00021         static void PostChargingBatteryInd(const ProcessPtr &process_ptr);
00022         static void PostChargingPausedInd(const ProcessPtr &process_ptr);
00023         static void PostChargingResumedInd(const ProcessPtr &process_ptr);
00024         static void PostLowBatteryInd(const ProcessPtr &process_ptr);
00025         static void PostEmptyBatteryInd(const ProcessPtr &process_ptr);
00026         static void PostRemoveChargerInd(const ProcessPtr &process_ptr);
00027         static void PostBatteryLoadLevelInd(const ProcessPtr &process_ptr);
00028 };
00029
00031 #endif  // Apoxi_Devices_ChargerSignalProcessor_hpp
00032
00033
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CustomIMelodyAudioReference.hpp File Reference

Devices/CustomIMelodyAudioReference.hpp File Reference

#include <Audio/CustomIMelodyAudioReference.hpp>

Include dependency graph for CustomIMelodyAudioReference.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:09:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CustomIMelodyAudioReference.hpp Source File

Devices/CustomIMelodyAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/CustomIMelodyAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CustomRingerAudioReference.hpp File Reference

Devices/CustomRingerAudioReference.hpp File Reference

#include <Audio/CustomRingerAudioReference.hpp>

Include dependency graph for CustomRingerAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:09:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CustomRingerAudioReference.hpp Source File

Devices/CustomRingerAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/CustomRingerAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CustomSmafPhraseAudioReference.hpp File Reference

Devices/CustomSmafPhraseAudioReference.hpp File Reference

#include <Audio/CustomSmafPhraseAudioReference.hpp>

Include dependency graph for CustomSmafPhraseAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:09:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CustomSmafPhraseAudioReference.hpp Source File

Devices/CustomSmafPhraseAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/CustomSmafPhraseAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CustomToneAudioReference.hpp File Reference

Devices/CustomToneAudioReference.hpp File Reference

#include <Audio/CustomToneAudioReference.hpp>

Include dependency graph for CustomToneAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:09:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/CustomToneAudioReference.hpp Source File

Devices/CustomToneAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/CustomToneAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DefaultDisplay.hpp File Reference

Devices/DefaultDisplay.hpp File Reference

#include <Devices/Win32/DefaultDisplay.hpp>

Include dependency graph for DefaultDisplay.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:25:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DefaultDisplay.hpp Source File

Devices/DefaultDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if defined(APOXI_RTOS_WIN32)
00011     #include <Devices/Win32/DefaultDisplay.hpp>
00012 #elif defined(APOXI_PLATFORM_BP30)
00013     #include <Devices/BP30/DefaultDisplay.hpp>
00014 #elif defined(APOXI_PLATFORM_MPE)
00015     #include <Devices/MPE/DefaultDisplay.hpp>
00016 #elif defined(APOXI_PLATFORM_MPEU)
00017     #include <Devices/MPEU/DefaultDisplay.hpp>
00018 #elif defined(APOXI_PLATFORM_MP1U)
00019     #include <Devices/SGold/DefaultDisplay.hpp>
00020 #else
00021     #error UNDEFINED PLATFORM
00022 #endif
00023
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Device.hpp File Reference

Devices/Device.hpp File Reference

#include <Devices/Win32/AmplifierAudioDevice.hpp>
#include <Devices/Win32/KeyToneAudioDevice.hpp>
#include <Devices/Win32/MiscAudioDevice.hpp>
#include <Devices/Win32/Mp3AudioDevice.hpp>
#include <Devices/Win32/RingerAudioDevice.hpp>
#include <Devices/Win32/SpeechAudioDevice.hpp>
#include <Devices/Win32/ToneAudioDevice.hpp>
#include <Devices/Win32/VoiceMemoAudioDevice.hpp>
#include <Devices/Win32/GenericAudioDevice.hpp>
#include <Devices/Win32/VideoChannel.hpp>
#include <Devices/Win32/StillCamera.hpp>
#include <Devices/Win32/VideoCamera.hpp>
#include <Devices/Charger.hpp>
#include <Devices/Display.hpp>
#include <Devices/Keyboard.hpp>
#include <Devices/Led.hpp>
#include <Devices/RealTimeClock.hpp>
#include <Devices/ChargerMsgTypes.hpp>
#include <Devices/AudioDeviceManager.hpp>
#include <Devices/AudioActiveReference.hpp>
#include <Devices/AudioReference.hpp>
#include <Devices/CustomRingerAudioReference.hpp>
#include <Devices/CustomSmafPhraseAudioReference.hpp>
#include <Devices/CustomToneAudioReference.hpp>
#include <Devices/PresetAudioReference.hpp>
#include <Devices/RingerAudioReference.hpp>
#include <Devices/ToneAudioReference.hpp>
#include <Devices/VoiceMemoAudioReference.hpp>
#include <Devices/AudioPresetStore.hpp>

Include dependency graph for Device.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Device_hpp

Define Documentation

#define Apoxi_Device_hpp

Generated on Tue Jan 24 20:29:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Device.hpp Source File

Devices/Device.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Device_hpp)
00010 #define Apoxi_Device_hpp
00011
00012 #if defined(APOXI_RTOS_WIN32)
00013     #include <Devices/Win32/AmplifierAudioDevice.hpp>
00014     #include <Devices/Win32/KeyToneAudioDevice.hpp>
00015     #include <Devices/Win32/MiscAudioDevice.hpp>
00016     #include <Devices/Win32/Mp3AudioDevice.hpp>
00017     #include <Devices/Win32/RingerAudioDevice.hpp>
00018     #include <Devices/Win32/SpeechAudioDevice.hpp>
00019     #include <Devices/Win32/ToneAudioDevice.hpp>
00020     #include <Devices/Win32/VoiceMemoAudioDevice.hpp>
00021     #include <Devices/Win32/GenericAudioDevice.hpp>
00022     #if defined(APOXI_COMPAT_2_6_0)
00023     #include <Devices/Win32/Audio.hpp>
00024     #endif
00025     #include <Devices/Win32/VideoChannel.hpp>
00026     #if defined(APOXI_CAMERA_SUPPORT)
00027         #include <Devices/Win32/StillCamera.hpp>
00028         #include <Devices/Win32/VideoCamera.hpp>
00029     #endif
00030
00031 #elif defined(APOXI_PLATFORM_BP30)
00032     #if defined(APOXI_COMPAT_2_6_0)
00033     #include <Devices/BP30/Audio.hpp>
00034     #endif
00035     #include <Devices/BP30/VideoChannel.hpp>
00036     #if defined(APOXI_CAMERA_SUPPORT)
00037         #include <Devices/BP30/Camera.hpp>
00038         //#include <Devices/Bp30/VideoCamera.hpp>
00039     #endif
00040
00041 #elif defined(APOXI_PLATFORM_MPE)
00042     #if defined(APOXI_COMPAT_2_6_0)
00043     #include <Devices/MPE/Audio.hpp>
00044     #endif
00045     #include <Devices/MPE/VideoChannel.hpp>
00046     #if defined(APOXI_CAMERA_SUPPORT)
00047         #include <Devices/MPE/StillCamera.hpp>
00048         #include <Devices/MPE/VideoCamera.hpp>
00049     #endif
00050
00051 #elif defined(APOXI_PLATFORM_MPEU)
00052     #if defined(APOXI_COMPAT_2_6_0)
00053     #include <Devices/MPEU/Audio.hpp>
00054     #endif
00055     #include <Devices/MPEU/VideoChannel.hpp>
00056     #if defined(APOXI_CAMERA_SUPPORT)
00057         #include <Devices/MPEU/StillCamera.hpp>
00058         #include <Devices/MPEU/VideoCamera.hpp>
00059     #endif
00060
00061 #elif defined(APOXI_PLATFORM_MP1U)
00062     #if defined(APOXI_COMPAT_2_6_0)
00063     #include <Devices/SGold/Audio.hpp>
00064     #endif
00065     #include <Devices/SGold/VideoChannel.hpp>
00066     #if defined(APOXI_CAMERA_SUPPORT)
00067         #include <Devices/SGold/Camera.hpp>
00068         #include <Devices/SGold/VideoCamera.hpp>
00069     #endif
00070
00071 #else
00072     #error UNDEFINED PLATFORM
00073 #endif
00074
00075     #include <Devices/Charger.hpp>
00076     #include <Devices/Display.hpp>
00077 #include <Devices/Keyboard.hpp>
00078     #include <Devices/Led.hpp>
00079     #include <Devices/RealTimeClock.hpp>
00080
00081     #include <Devices/ChargerMsgTypes.hpp>
00082
00083     // ToDo: check if all are necessary
00084     #include <Devices/AudioDeviceManager.hpp>
00085     #include <Devices/AudioActiveReference.hpp>
00086     #include <Devices/AudioReference.hpp>
00087     #include <Devices/CustomRingerAudioReference.hpp>
00088     #include <Devices/CustomSmafPhraseAudioReference.hpp>
00089     #include <Devices/CustomToneAudioReference.hpp>
00090     #include <Devices/PresetAudioReference.hpp>
00091     #include <Devices/RingerAudioReference.hpp>
00092     #include <Devices/ToneAudioReference.hpp>
00093     #include <Devices/VoiceMemoAudioReference.hpp>
00094     #include <Devices/AudioPresetStore.hpp>
00095
00096 #endif // Apoxi_Device_hpp
00097
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DeviceManager.cpp File Reference

Devices/DeviceManager.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "DeviceManager.hpp"
#include "AbstractDevice.hpp"
#include <Kernel/Os/SemObtainer.hpp>
#include <Gui/ClientDc.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for DeviceManager.cpp:

Generated on Tue Jan 24 20:29:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DeviceManager.hpp File Reference

Devices/DeviceManager.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>

Include dependency graph for DeviceManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DeviceManager
class | DeviceManager::Iterator

Defines

#define | Apoxi_Devices_DeviceManager_hpp
#define | APOXI_MAX_DISPLAY_COUNT 2

Define Documentation

#define Apoxi_Devices_DeviceManager_hpp

Generated on Tue Jan 24 20:29:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DeviceManager.hpp Source File

Devices/DeviceManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_DeviceManager_hpp)
00010 #define Apoxi_Devices_DeviceManager_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Devices/AbstractDevice.hpp>
00016
00017 class Display;
00018 class ClientDc;
00019
00020 #if !defined(APOXI_MAX_DISPLAY_COUNT)
00021 #define APOXI_MAX_DISPLAY_COUNT 2
00022 #endif
00023
00029 class DeviceManager {
00030     public:
00043         class Iterator {
00044             public:
00045                 Iterator();
00046                 ~Iterator();
00047
00050                 BOOLEAN Begin();
00051
00053                 Iterator& operator++();
00054
00056                 Iterator operator++(INT);
00057
00060                 AbstractDevice* Get() const { return m_device; }
00061
00062             private:
00063                 AbstractDevice* m_device;
00064         };
00065
00067         static DeviceManager& GetInstance();
00068
00077         AbstractDevice* GetDevice(AbstractDevice::Category category, INT index = 0) const;
00078
00084         void AddDevice(AbstractDevice& device);
00085
00088         void RemoveDevice(AbstractDevice& device);
00089
00098         static Display* GetDisplay(INT display_idx = 0) { return m_display[display_idx]; }
00099
00103         static ClientDc* GetSharedDc(INT display_idx = 0) { return m_shared_dc[display_idx]; }
00104
00105     private:
00106         AbstractDevice* m_first;
00107         mutable Semaphore m_sem;
00108
00109         static BOOLEAN m_initialized;
00110         static Display* m_display[APOXI_MAX_DISPLAY_COUNT];
00111         static ClientDc* m_shared_dc[APOXI_MAX_DISPLAY_COUNT];
00112
00113         DeviceManager();
00114
00116         void Startup();
00117
00119         void Shutdown();
00120
00122         void NotifyDevice(BOOLEAN startup);
00123
00127         AbstractDevice* GetNextDevice(const AbstractDevice& device) const;
00128
00129         friend class StartUp;   // invokes StartUp
00130         friend class ShutDown;  // invokes ShutDown
00131         friend class Iterator;
00132 };
00133
00135 #endif  // Apoxi_Devices_DeviceManager_hpp
00136
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DevicesPreComp.cpp File Reference

Devices/DevicesPreComp.cpp File Reference

#include "Devices/DevicesPreComp.hpp"

Include dependency graph for DevicesPreComp.cpp:

Generated on Tue Jan 24 20:29:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DevicesPreComp.hpp File Reference

Devices/DevicesPreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Auxiliary/WString.hpp>
#include <Devices/Device.hpp>

Include dependency graph for DevicesPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:29:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DevicesPreComp.hpp Source File

Devices/DevicesPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Kernel/Condition.hpp>
00011 #include <Kernel/System.hpp>
00012 #include <Kernel/MessageRouter.hpp>
00013 #include <Kernel/Application.hpp>
00014 #include <Kernel/AppContainer.hpp>
00015 #include <Kernel/MsgTypes.hpp>
00016 #include <Kernel/Os/MutexObtainer.hpp>
00017 #include <Auxiliary/WString.hpp>
00018 #include <Devices/Device.hpp>
00019
00020
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DevicesTemplates.cpp File Reference

Devices/DevicesTemplates.cpp File Reference

#include "Devices/DevicesPreComp.hpp"

Include dependency graph for DevicesTemplates.cpp:

Generated on Tue Jan 24 20:29:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Display.cpp File Reference

Devices/Display.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "Display.hpp"
#include <Devices/DeviceManager.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>

Include dependency graph for Display.cpp:

Generated on Tue Jan 24 20:29:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Display.hpp File Reference

Devices/Display.hpp File Reference

#include <Devices/Win32/VirtualDisplay.hpp>

Include dependency graph for Display.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Display
class | Display::CustomFrameBuffer

Defines

#define | Apoxi_Devices_Display_hpp

Define Documentation

#define Apoxi_Devices_Display_hpp

Generated on Tue Jan 24 20:29:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Display.hpp Source File

Devices/Display.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_Devices_Display_hpp)
00012 #define Apoxi_Devices_Display_hpp
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Devices/Win32/VirtualDisplay.hpp>
00018 #elif defined(APOXI_PLATFORM_BP30)
00019     #include <Devices/BP30/VirtualDisplay.hpp>
00020 #elif defined(APOXI_PLATFORM_MPE)
00021     #include <Devices/MPE/VirtualDisplay.hpp>
00022 #elif defined(APOXI_PLATFORM_MPEU)
00023     #include <Devices/MPEU/VirtualDisplay.hpp>
00024 #elif defined(APOXI_PLATFORM_MP1U)
00025     #include <Devices/SGold/VirtualDisplay.hpp>
00026 #else
00027     #error Platform not supported!
00028 #endif
00029
00034 class Display : public VirtualDisplay {
00035     typedef VirtualDisplay Base;
00036
00037     public:
00040         enum BacklightMode {
00042             BacklightModeOff,
00045             BacklightModeAuto,
00047             BacklightModeOn
00048         };
00049
00052         enum PowerMode {
00054             PowerModeOff,
00058             PowerModeAuto,
00060             PowerModeOn
00061         };
00062
00065         enum Info {
00066             PowerTurnedOn,
00067             PowerTurnedOff,
00068             BacklightTurnedOn,
00069             BacklightTurnedOff,
00070             DisplayTimeout
00071         };
00072
00076         class CustomFrameBuffer {
00077             public:
00083                 CustomFrameBuffer(const Bitmap& bmp, const Rect& blit_rect) :
00084                   m_bmp(bmp), m_blit_rect(blit_rect) {}
00085                 const Bitmap& GetBitmap() const { return m_bmp; }
00086                 const Rect& GetBlitRect() const { return m_blit_rect; }
00087
00088             private:
00089                 const Bitmap& m_bmp;
00090                 const Rect& m_blit_rect;
00091         };
00092
00095         Display(INT index);
00096
00097         virtual ~Display();
00098
00100         virtual void SetContrast(INT contrast);
00101
00103         virtual INT GetContrast() const;
00104
00106         virtual void SetBrightness(INT brightness);
00107
00109         virtual INT GetBrightness() const;
00110
00113         virtual void SetBacklightTimeout(UINT32 timeout);
00114
00117         virtual void SetPowerTimeout(UINT32 timeout);
00118
00121         virtual void ReactivateBacklight();
00122
00126         virtual void ReactivatePower();
00127
00129         virtual void SetBacklightMode(BacklightMode mode);
00130
00132         virtual BacklightMode GetBacklightMode() const;
00133
00135         virtual BOOLEAN IsBacklightOn() const;
00136
00138         virtual void SetPowerMode(PowerMode mode);
00139
00141         virtual PowerMode GetPowerMode() const;
00142
00144         virtual BOOLEAN IsPowerOn() const;
00145
00150         virtual void SetCustomFrameBufferRect(const Rect& rect);
00151
00153         virtual void Refresh();
00154
00163         virtual void Refresh(const CustomFrameBuffer* custom_frame_buf);
00164
00168         virtual VideoChannel* GetVideoChannel();
00169
00176         virtual void IndicateAlphaMaskUpdate();
00177
00182         void SetLocked(BOOLEAN locked) { m_locked = locked; }
00183
00187         BOOLEAN IsLocked() const { return m_locked; }
00188
00190         virtual void SetCallbackActive(BOOLEAN state);
00191
00193         virtual BOOLEAN IsCallbackActive() const;
00194
00197         void Refresh(BOOLEAN block, const CustomFrameBuffer* custom_frame_buf = 0);
00198
00199     private:
00200         BOOLEAN m_locked;
00201 };
00202
00204 #endif  // Apoxi_Devices_Display_hpp
00205
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DisplayMsgTypes.cpp File Reference

Devices/DisplayMsgTypes.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "DisplayMsgTypes.hpp"

Include dependency graph for DisplayMsgTypes.cpp:

Generated on Tue Jan 24 20:29:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DisplayMsgTypes.hpp File Reference

Devices/DisplayMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Devices/Display.hpp>

Include dependency graph for DisplayMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DisplayInfoMsg

Defines

#define | Devices_DisplayMsgTypes_hpp

Define Documentation

#define Devices_DisplayMsgTypes_hpp

Generated on Tue Jan 24 20:29:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/DisplayMsgTypes.hpp Source File

Devices/DisplayMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "wickhara_latest_dv\lnz_apoxi\Apoxi\Devices\DisplayMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(Devices_DisplayMsgTypes_hpp)
00017 #define Devices_DisplayMsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Devices/Display.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class DisplayInfoMsg
00029     ====================================================================== */
00030
00032 class DisplayInfoMsg : public Message {
00033     public:
00034         DisplayInfoMsg(const Display::Info& info, INT index = 0);
00035         virtual ~DisplayInfoMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         const Display::Info& GetInfo() const { return m_info; }
00039         INT GetIndex() const { return m_index; }
00040         virtual Message* Clone() const;
00041
00042         enum  {
00043             ID = 9060
00044             };
00045
00046     private:
00047         static const MsgMetaData m_meta_data;
00048         Display::Info m_info;
00049         INT m_index;
00050     };
00051
00052 #endif // Devices_DisplayMsgTypes_hpp
00053
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Fota.hpp File Reference

Devices/Fota.hpp File Reference

#include <Devices/Win32/Fota.hpp>

Include dependency graph for Fota.hpp:

Go to the source code of this file.

Defines

#define Apoxi_Devices_Fota_hpp

Define Documentation

#define Apoxi_Devices_Fota_hpp

Generated on Tue Jan 24 20:25:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Fota.hpp Source File

Devices/Fota.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Devices_Fota_hpp)
00011 #define Apoxi_Devices_Fota_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Devices/Win32/Fota.hpp>
00018 #elif defined(APOXI_PLATFORM_BP30)
00019     #include <Devices/BP30/Fota.hpp>
00020 #elif defined(APOXI_PLATFORM_MPE)
00021     #include <Devices/MPE/Fota.hpp>
00022 #elif defined(APOXI_PLATFORM_MPEU)
00023     #include <Devices/MPEU/Fota.hpp>
00024 #elif defined(APOXI_PLATFORM_MP1U)
00025     #include <Devices/SGold/Fota.hpp>
00026 #else
00027     #error Platform not supported!
00028 #endif
00029
00031 #endif  // Apoxi_Devices_Fota_hpp
00032
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/FotaInterface.hpp File Reference

Devices/FotaInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class Fota

Generated on Tue Jan 24 20:29:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/FotaInterface.hpp Source File

Devices/FotaInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00018 #if defined DOXYGEN_SHOULD_SKIP_THIS
00019 class Fota {
00020 #endif
00021     public:
00022         virtual ~Fota();
00023
00025         virtual const WCHAR* GetName() const;
00026
00028         static ControlArg Control(INT command, ControlArg arg);
00029
00037         static INT InitiateFirmwareUpdate(BOOLEAN force = TRUE);
00038
00045         static INT ReadMetaData(UINT32 offset, void* buffer, UINT32 size);
00046
00053         static INT WriteMetaData(UINT32 offset, const void* buffer, UINT32 size);
00054
00059         static UINT32 GetMetaDataCapacity();
00060
00061     private:
00062         friend class ShutDown;
00063
00064         static Fota m_fota;
00065
00066         Fota();
00067         static void RebootSystem();
00068
00069 #if defined DOXYGEN_SHOULD_SKIP_THIS
00070 };
00071 #endif
00072
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Keyboard.hpp File Reference

Devices/Keyboard.hpp File Reference

#include <Devices/Win32/Keyboard.hpp>

Include dependency graph for Keyboard.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_Keyboard_hpp

Define Documentation

#define Apoxi_Devices_Keyboard_hpp

Generated on Tue Jan 24 20:25:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Keyboard.hpp Source File

Devices/Keyboard.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Devices_Keyboard_hpp)
00011 #define Apoxi_Devices_Keyboard_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Devices/Win32/Keyboard.hpp>
00018 #elif defined(APOXI_PLATFORM_BP30)
00019     #include <Devices/BP30/Keyboard.hpp>
00020 #elif defined(APOXI_PLATFORM_MPE)
00021     #include <Devices/MPE/Keyboard.hpp>
00022 #elif defined(APOXI_PLATFORM_MPEU)
00023     #include <Devices/MPEU/Keyboard.hpp>
00024 #elif defined(APOXI_PLATFORM_MP1U)
00025     #include <Devices/SGold/Keyboard.hpp>
00026 #else
00027     #error Platform not supported!
00028 #endif
00029
00031 #endif  // Apoxi_Devices_Keyboard_hpp
00032
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/KeyboardInterface.hpp File Reference

Devices/KeyboardInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class Keyboard
Keyboard. More...

Generated on Tue Jan 24 20:29:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/KeyboardInterface.hpp Source File

Devices/KeyboardInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00012 #if defined DOXYGEN_SHOULD_SKIP_THIS
00013 class Keyboard {
00014 #endif
00015
00016     public:
00018         enum Flag {
00019             KeyDown,
00020             KeyUp,
00021             LongKeyPress,
00022             VeryLongKeyPress,
00023             KeyAutoRepeat,
00024             InputChar   // Obsolete!
00025         };
00026
00028         enum IlluminationMode {
00029             IlluminationModeOff,
00030             IlluminationModeAuto,
00032             IlluminationModeOn
00033         };
00034
00036         virtual ~Keyboard();
00037
00039         virtual const WCHAR* GetName() const;
00040
00042         static ControlArg Control(INT command, ControlArg arg);
00043
00045         static void PostKeyMsg(KeyCode key_code, Flag key_flag, UINT32 duration = 0);
00046
00048         static void ConfirmKeyInput();
00049
00051         static void SetLocked(BOOLEAN locked);
00052
00054         static BOOLEAN IsLocked();
00055
00057         static BOOLEAN GetKeyState(KeyCode keycode);
00058
00061         static void SetMultiKeyMode(BOOLEAN enable);
00062
00064         static BOOLEAN IsMultiKeyMode();
00065
00068         static void SetIlluminationTimeout(UINT32 timeout);
00069
00072         static void ReactivateIllumination();
00073
00075         static void SetIlluminationMode(IlluminationMode mode);
00076
00078         static IlluminationMode GetIlluminationMode();
00079
00081         static BOOLEAN IsIlluminationOn();
00082
00083     private:
00084         static Keyboard m_keyboard;
00085
00086         static BOOLEAN m_key_pressed_very_long;
00087         static KeyCode m_prev_key_code;
00088         static SystemTimer m_key_press_timer;
00089         static SystemTimer m_key_autorepeat_timer;
00090
00091         Keyboard();
00092
00093         static void UpdateKeyTimers(KeyCode key_code, Flag key_flag);
00094         static void OnKeyPressTimer(void* arg);
00095         static void OnKeyAutorepeatTimer(void* arg);
00096
00097 #if defined DOXYGEN_SHOULD_SKIP_THIS
00098 };
00099 #endif
00100
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Led.hpp File Reference

Devices/Led.hpp File Reference

#include <Devices/Win32/Led.hpp>

Include dependency graph for Led.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_Led_hpp

Define Documentation

#define Apoxi_Devices_Led_hpp

Generated on Tue Jan 24 20:25:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Led.hpp Source File

Devices/Led.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_Devices_Led_hpp)
00010 #define Apoxi_Devices_Led_hpp
00011
00014
00015 #if defined(APOXI_RTOS_WIN32)
00016     #include <Devices/Win32/Led.hpp>
00017 #elif defined(APOXI_PLATFORM_BP30)
00018     #include <Devices/BP30/Led.hpp>
00019 #elif defined(APOXI_PLATFORM_MPE)
00020     #include <Devices/MPE/Led.hpp>
00021 #elif defined(APOXI_PLATFORM_MPEU)
00022     #include <Devices/MPEU/Led.hpp>
00023 #elif defined(APOXI_PLATFORM_MP1U)
00024     #include <Devices/SGold/Led.hpp>
00025 #else
00026     #error Platform not supported!
00027 #endif
00028
00030 #endif //Apoxi_Devices_Led_hpp
00031
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedInterface.hpp File Reference

Devices/LedInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Led
Back light device. More...
struct | Led::Color
struct | Led::Frame
struct | Led::Stream
struct | Led::StreamField

Generated on Tue Jan 24 20:29:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedInterface.hpp Source File

Devices/LedInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00012 #if defined DOXYGEN_SHOULD_SKIP_THIS
00013 class Led {
00014 #endif
00015 #if defined(APOXI_LED_NEW_INTERFACE)
00016     public:
00018         /* bit field, internally mapped to led_keyboard, led_service... */
00019         enum Peripheral {
00020             Keyboard = 0x01,
00021             Display = 0x02,
00022             InService = 0x04,
00023             All = (Keyboard | Display | InService)
00024         };
00025
00027         enum Notification {
00028             StreamFinished,
00029             StreamStopped,
00030             StreamError
00031         };
00032
00034         struct Color {
00035             UINT8 red;
00036             UINT8 green;
00037             UINT8 blue;
00038         };
00039
00041         struct Frame {
00042             Color color;
00043             UINT32 on_time;
00044             UINT32 total_time;
00045             UINT16 iterations;
00046         };
00047
00049         struct StreamField {
00050             Frame frame;
00051             Color fading_color;
00052         };
00053
00055         struct Stream {
00056             const StreamField* stream_field;
00057             UINT8 length;
00058             UINT16 iterations;
00059         };
00060
00062         virtual ~Led();
00063
00065         virtual const WCHAR* GetName() const;
00066
00068         static void Reset();
00069
00071         static BOOLEAN On(Peripheral peripheral, Frame frame);
00072
00074         static BOOLEAN ChangeColor(Peripheral peripheral, Color color);
00075
00077         static BOOLEAN Off(Peripheral peripheral, UINT32 fading_time);
00078
00082         static BOOLEAN ColorStream(Peripheral peripheral, const Stream* stream, INT sequence_id = 0);
00083
00085         static BOOLEAN MusicMode(Peripheral peripheral, BOOLEAN on);
00086
00087 #else
00088     public:
00089         typedef UINT16 Duration;
00090
00091         class Config {
00092             public:
00093                 Config(Color color = InvalidColor, BOOLEAN is_changeable = TRUE,
00094                         Duration on_time = 0, Duration total_time = 0) :
00095                     m_color(color),
00096                     m_is_changeable(is_changeable),
00097                     m_on_time(on_time),
00098                     m_total_time(total_time) {}
00099
00100                 Color GetColor() const { return (m_color); }
00101                 BOOLEAN IsChangeable() const { return (m_is_changeable); }
00102                 Duration GetOnTime() const { return (m_on_time); }
00103                 Duration GetTotalTime() const { return (m_total_time); }
00104
00105                 void SetColor(Color color) { m_color = color; }
00106                 void SetOnTime(Duration on_time) { m_on_time = on_time; }
00107                 void SetTotalTime(Duration total_time) { m_total_time = total_time; }
00108
00109             private:
00110                 Color m_color;
00111                 BOOLEAN m_is_changeable;
00112                 Duration m_on_time;
00113                 Duration m_total_time;
00114         };
00115
00117         virtual ~Led();
00118
00120         virtual const WCHAR* GetName() const;
00121
00123         static ControlArg Control(INT command, ControlArg arg);
00124
00126         static BOOLEAN Do(Action action, Color color, Duration on_time, Duration total_time);
00127         static BOOLEAN Do(Action action, Config config);
00128
00130         static INT GetMaxColorStreamLength() { return (c_max_colorstream_length); }
00131
00133         static void SetColorStream(Color *color_buffer, INT len);
00134         static void SetColorStream(Config *config, INT len);
00135
00137         static Config GetEvent(Event event);
00138
00140         static BOOLEAN SetEvent(Event event, const Config &config);
00141
00143         static void ChangeIntensity(Color color, Intensity level);
00144
00146         static BOOLEAN IsOn(Color color);
00147
00149         static void Charger(BOOLEAN activate);
00150
00152         static void MusicMode(BOOLEAN activate);
00153
00155         static void Reset();
00156 #endif
00157
00158     private:
00159         static Led m_led;
00160
00161         Led();
00162
00163 #if defined DOXYGEN_SHOULD_SKIP_THIS
00164 };
00165 #endif
00166
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedMsgTypes.cpp File Reference

Devices/LedMsgTypes.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "LedMsgTypes.hpp"

Include dependency graph for LedMsgTypes.cpp:

Generated on Tue Jan 24 20:29:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedMsgTypes.hpp File Reference

Devices/LedMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Devices/Led.hpp>

Include dependency graph for LedMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LedNotificationMsg

Defines

#define | Devices_LedMsgTypes_hpp

Define Documentation

#define Devices_LedMsgTypes_hpp

Generated on Tue Jan 24 20:29:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedMsgTypes.hpp Source File

Devices/LedMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "src\wickhara_apoxitest_host\lnz_apoxi\Apoxi\Devices\LedMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(Devices_LedMsgTypes_hpp)
00017 #define Devices_LedMsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Devices/Led.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 #ifdef APOXI_LED_NEW_INTERFACE
00028
00029
00030 /*  ======================================================================
00031     Class LedNotificationMsg
00032     ====================================================================== */
00033
00035 class LedNotificationMsg : public Message {
00036     public:
00037         LedNotificationMsg(INT led_id, INT sequence_id, const Led::Notification& notification);
00038         virtual ~LedNotificationMsg();
00039
00040         virtual const MsgMetaData& GetMetaData() const;
00041         INT GetLedId() const { return m_led_id; }
00042         INT GetSequenceId() const { return m_sequence_id; }
00043         const Led::Notification& GetNotification() const { return m_notification; }
00044         virtual Message* Clone() const;
00045
00046         enum  {
00047             ID = 9070
00048             };
00049
00050     private:
00051         static const MsgMetaData m_meta_data;
00052         INT m_led_id;
00053         INT m_sequence_id;
00054         Led::Notification m_notification;
00055
00056     };
00057
00058 #endif //APOXI_LED_NEW_INTERFACE
00059
00060 #endif // Devices_LedMsgTypes_hpp
00061
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedSignalMapTableNode.cpp File Reference

Devices/LedSignalMapTableNode.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "LedSignalMapTableNode.hpp"
#include "LedSignalProcessor.hpp"
#include "Led.hpp"

Include dependency graph for LedSignalMapTableNode.cpp:

Generated on Tue Jan 24 20:29:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedSignalMapTableNode.hpp File Reference

Devices/LedSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for LedSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LedSignalMapTableNode

Defines

#define | Apoxi_Devices_LedSignalMapTableNode_hpp

Define Documentation

#define Apoxi_Devices_LedSignalMapTableNode_hpp

Generated on Tue Jan 24 20:29:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedSignalMapTableNode.hpp Source File

Devices/LedSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_LedSignalMapTableNode_hpp)
00010 #define Apoxi_Devices_LedSignalMapTableNode_hpp
00013
00014 #if defined(APOXI_LED_NEW_INTERFACE)
00015
00016 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00017
00018 /*  ======================================================================
00019     LedSignalMapTableNode
00020     ====================================================================== */
00021 class LedSignalMapTableNode : public SignalMapTableNode {
00022
00023     public:
00024         static LedSignalMapTableNode* GetInstance();
00025
00026     private:
00027         static LedSignalMapTableNode *m_node;
00028         static const SignalMapTableEntry m_map_table[];
00029
00030         LedSignalMapTableNode();
00031 };
00032
00033 #endif  // APOXI_LED_NEW_INTERFACE
00034
00036 #endif  // Apoxi_Devices_LedSignalMapTableNode_hpp
00037
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedSignalProcessor.cpp File Reference

Devices/LedSignalProcessor.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "LedSignalProcessor.hpp"
#include <Kernel/MessageRouter.hpp>
#include <Devices/LedMsgTypes.hpp>

Include dependency graph for LedSignalProcessor.cpp:

Generated on Tue Jan 24 20:29:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedSignalProcessor.hpp File Reference

Devices/LedSignalProcessor.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableEntry.hpp>

Include dependency graph for LedSignalProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LedSignalProcessor

Defines

#define | Apoxi_Devices_LedSignalProcessor_hpp

Define Documentation

#define Apoxi_Devices_LedSignalProcessor_hpp

Generated on Tue Jan 24 20:29:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/LedSignalProcessor.hpp Source File

Devices/LedSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_LedSignalProcessor_hpp)
00010 #define Apoxi_Devices_LedSignalProcessor_hpp
00011
00014
00015 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>
00016
00018 class LedSignalProcessor {
00019     public:
00020         static void PostLedStreamStatus(const ProcessPtr& process_ptr);
00021 };
00022
00024 #endif  // Apoxi_Devices_LedSignalProcessor_hpp
00025
00026
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/PresetAudioReference.hpp File Reference

Devices/PresetAudioReference.hpp File Reference

#include <Audio/PresetAudioReference.hpp>

Include dependency graph for PresetAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/PresetAudioReference.hpp Source File

Devices/PresetAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/PresetAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RadioAudioDevice.hpp File Reference

Devices/RadioAudioDevice.hpp File Reference

#include <Audio/RadioAudioDevice.hpp>

Include dependency graph for RadioAudioDevice.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RadioAudioDevice.hpp Source File

Devices/RadioAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/RadioAudioDevice.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RealTimeClock.hpp File Reference

Devices/RealTimeClock.hpp File Reference

#include <Auxiliary/DateTime.hpp>
#include <Devices/Win32/RealTimeClock.hpp>

Include dependency graph for RealTimeClock.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_RealTimeClock_hpp

Define Documentation

#define Apoxi_Devices_RealTimeClock_hpp

Generated on Tue Jan 24 20:26:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RealTimeClock.hpp Source File

Devices/RealTimeClock.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_Devices_RealTimeClock_hpp)
00010 #define Apoxi_Devices_RealTimeClock_hpp
00011
00014
00015 #include <Auxiliary/DateTime.hpp>
00016
00017 #if defined(APOXI_RTOS_WIN32)
00018     #include <Devices/Win32/RealTimeClock.hpp>
00019 #elif defined(APOXI_PLATFORM_BP30)
00020     #include <Devices/BP30/RealTimeClock.hpp>
00021 #elif defined(APOXI_PLATFORM_MPE)
00022     #include <Devices/MPE/RealTimeClock.hpp>
00023 #elif defined(APOXI_PLATFORM_MPEU)
00024     #include <Devices/MPEU/RealTimeClock.hpp>
00025 #elif defined(APOXI_PLATFORM_MP1U)
00026     #include <Devices/SGold/RealTimeClock.hpp>
00027 #else
00028     #error Platform not supported!
00029 #endif
00030
00032 #endif //Apoxi_Devices_RealTimeClock_hpp
00033
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RealTimeClockInterface.hpp File Reference

Devices/RealTimeClockInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RealTimeClock
struct | RealTimeClock::DateAndTime

Generated on Tue Jan 24 20:32:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RealTimeClockInterface.hpp Source File

Devices/RealTimeClockInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00012 #if defined DOXYGEN_SHOULD_SKIP_THIS
00013 class RealTimeClock {
00014 #endif
00015     public:
00017         struct DateAndTime {
00018             UINT8 hour;
00019             UINT8 minute;
00020             UINT8 second;
00021             UINT8 day;
00022             UINT8 month;
00023             INT16 gmt_bias;
00024             UINT16 millisec;
00025             UINT16 year;
00026         };
00027
00029         enum RtcInfo {
00030             DataNotValid,
00031             TimeChanged,
00032             DateChanged,
00033             MinuteTick,
00034             AlarmReached
00035         };
00036
00038         virtual ~RealTimeClock();
00039
00041         virtual const WCHAR* GetName() const;
00042
00044         static ControlArg Control(INT command, ControlArg arg);
00045
00047         static DateAndTime GetLocalDateAndTime();
00048
00050         static DateTime GetLocalDateTime();
00051
00055         static DateTime GetSecureDateTime();
00056
00058         static BOOLEAN IsSecureClockValid();
00059
00061         static void SetSleepMode();
00062
00064         static BOOLEAN SetLocalDate(Date* date);
00065
00067         static BOOLEAN SetLocalTime(Time* time);
00068
00070         static BOOLEAN SetLocalDateTime(DateTime* date_time);
00071
00073         static void SetAlarm(DateTime* date_time);
00074
00076         static void ClearAlarm();
00077
00079         static DateTime GetAlarm();
00080
00082         static BOOLEAN IsRTCStartUpEvent();
00083
00085         static void CleanUp();
00086
00087     private:
00088         static RealTimeClock m_real_time_clock;
00089
00090         RealTimeClock();
00091
00092 #if defined DOXYGEN_SHOULD_SKIP_THIS
00093 };
00094 #endif
00095
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RingerAudioInternalMidiPlayer.hpp File Reference

Devices/RingerAudioInternalMidiPlayer.hpp File Reference

#include <Audio/RingerAudioInternalMidiPlayer.hpp>

Include dependency graph for RingerAudioInternalMidiPlayer.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RingerAudioInternalMidiPlayer.hpp Source File

Devices/RingerAudioInternalMidiPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/RingerAudioInternalMidiPlayer.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RingerAudioPlayer.hpp File Reference

Devices/RingerAudioPlayer.hpp File Reference

#include <Audio/RingerAudioPlayer.hpp>

Include dependency graph for RingerAudioPlayer.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RingerAudioPlayer.hpp Source File

Devices/RingerAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/RingerAudioPlayer.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RingerAudioReference.hpp File Reference

Devices/RingerAudioReference.hpp File Reference

#include <Audio/RingerAudioReference.hpp>

Include dependency graph for RingerAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RingerAudioReference.hpp Source File

Devices/RingerAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/RingerAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcMsgTypes.cpp File Reference

Devices/RtcMsgTypes.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "RtcMsgTypes.hpp"

Include dependency graph for RtcMsgTypes.cpp:

Generated on Tue Jan 24 20:32:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcMsgTypes.hpp File Reference

Devices/RtcMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Devices/RealTimeClock.hpp>

Include dependency graph for RtcMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RtcInfoMsg

Defines

#define | Devices_RtcMsgTypes_hpp

Define Documentation

#define Devices_RtcMsgTypes_hpp

Generated on Tue Jan 24 20:32:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcMsgTypes.hpp Source File

Devices/RtcMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "wickhara_latest_dv\lnz_apoxi\Apoxi\Devices\RtcMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(Devices_RtcMsgTypes_hpp)
00017 #define Devices_RtcMsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Devices/RealTimeClock.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class RtcInfoMsg
00029     ====================================================================== */
00030
00032 class RtcInfoMsg : public Message {
00033     public:
00034         RtcInfoMsg(const RealTimeClock::RtcInfo& rtc_info);
00035         virtual ~RtcInfoMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         const RealTimeClock::RtcInfo& GetRtcInfo() const { return m_rtc_info; }
00039         virtual Message* Clone() const;
00040
00041         enum  {
00042             ID = 9050
00043             };
00044
00045     private:
00046         static const MsgMetaData m_meta_data;
00047         RealTimeClock::RtcInfo m_rtc_info;
00048
00049     };
00050
00051 #endif // Devices_RtcMsgTypes_hpp
00052
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcSignalMapTableNode.cpp File Reference

Devices/RtcSignalMapTableNode.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "RtcSignalMapTableNode.hpp"
#include "RtcSignalProcessor.hpp"

Include dependency graph for RtcSignalMapTableNode.cpp:

Generated on Tue Jan 24 20:32:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcSignalMapTableNode.hpp File Reference

Devices/RtcSignalMapTableNode.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableNode.hpp>

Include dependency graph for RtcSignalMapTableNode.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RtcSignalMapTableNode

Defines

#define | Apoxi_Devices_RtcSignalMapTableNode_hpp

Define Documentation

#define Apoxi_Devices_RtcSignalMapTableNode_hpp

Generated on Tue Jan 24 20:32:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcSignalMapTableNode.hpp Source File

Devices/RtcSignalMapTableNode.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_RtcSignalMapTableNode_hpp)
00010 #define Apoxi_Devices_RtcSignalMapTableNode_hpp
00013
00014 #include <Apc/SignalHandler/SignalMapTableNode.hpp>
00015
00016 /*  ======================================================================
00017     RtcSignalMapTableNode
00018     ====================================================================== */
00019 class RtcSignalMapTableNode : public SignalMapTableNode {
00020     public:
00021         static RtcSignalMapTableNode* GetInstance();
00022
00023     private:
00024         static RtcSignalMapTableNode *m_node;
00025         static const SignalMapTableEntry m_map_table[];
00026
00027         RtcSignalMapTableNode();
00028 };
00029
00031 #endif  // Apoxi_Devices_RtcSignalMapTableNode_hpp
00032
00033
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcSignalProcessor.cpp File Reference

Devices/RtcSignalProcessor.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "RtcSignalProcessor.hpp"
#include <Kernel/MessageRouter.hpp>
#include <Devices/RtcMsgTypes.hpp>

Include dependency graph for RtcSignalProcessor.cpp:

Generated on Tue Jan 24 20:32:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcSignalProcessor.hpp File Reference

Devices/RtcSignalProcessor.hpp File Reference

#include <Apc/SignalHandler/SignalMapTableEntry.hpp>

Include dependency graph for RtcSignalProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RtcSignalProcessor

Defines

#define | Apoxi_Devices_RtcSignalProcessor_hpp

Define Documentation

#define Apoxi_Devices_RtcSignalProcessor_hpp

Generated on Tue Jan 24 20:32:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/RtcSignalProcessor.hpp Source File

Devices/RtcSignalProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_RtcSignalProcessor_hpp)
00010 #define Apoxi_Devices_RtcSignalProcessor_hpp
00011
00014
00015 #include <Apc/SignalHandler/SignalMapTableEntry.hpp>
00016
00018 class RtcSignalProcessor {
00019     public:
00020         static void PostRtcEventInd(const ProcessPtr& process_ptr);
00021         static void PostMinuteTickInd(const ProcessPtr& process_ptr);
00022         static void PostRtcNotValidInd(const ProcessPtr& process_ptr);
00023
00024         typedef void (*RtcEventCallbackFn)();
00025         static void SetRtcEventCallbackFn(RtcEventCallbackFn fn) { m_callback_fn = fn; }
00026
00027     private:
00028         static RtcEventCallbackFn m_callback_fn;
00029 };
00030
00032 #endif  // Apoxi_Devices_RtcSignalProcessor_hpp
00033
00034
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ShutDown.cpp File Reference

Devices/ShutDown.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "ShutDown.hpp"
#include <Asc/PowerHandler.hpp>
#include <Kernel/System.hpp>
#include <Kernel/SubSystemManager.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/Win32/MmiSimClient.hpp>
#include <stdlib.h>
#include <stdio.h>

Include dependency graph for ShutDown.cpp:

Defines

#define | APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT 20
#define | APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL 500

Variables

const INT | c_shutdown_app_close_timeout = APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT
const UINT32 | c_shutdown_check_applications_interval = APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL

Define Documentation

#define APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT 20

#define APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL 500

Variable Documentation

const INT c_shutdown_app_close_timeout = APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT

const UINT32 c_shutdown_check_applications_interval = APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL

Generated on Tue Jan 24 20:33:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ShutDown.hpp File Reference

Devices/ShutDown.hpp File Reference

#include <Kernel/Os/SystemTimer.hpp>

Include dependency graph for ShutDown.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ShutDown

Defines

#define | Apoxi_ShutDown_hpp

Define Documentation

#define Apoxi_ShutDown_hpp

Generated on Tue Jan 24 20:33:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ShutDown.hpp Source File

Devices/ShutDown.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ShutDown_hpp)
00010 #define Apoxi_ShutDown_hpp
00013
00014 #include <Kernel/Os/SystemTimer.hpp>
00015
00018 class ShutDown {
00019     public:
00021         enum Mode {
00022             PowerOff,
00023             Restart,
00024             SilentReset,
00025             FirmwareUpdate
00026         };
00027
00032         static void Execute(Mode mode = PowerOff);
00033
00038         static void PowerDown(BOOLEAN restart = FALSE);
00039
00040     private:
00041         static BOOLEAN m_mobile_network_stopped;
00042         static Mode m_mode;
00043         static SystemTimer m_timer;
00044         static UINT32 m_timeout;
00045
00046         friend class CommonSignalProcessor;
00047
00048         static void OnTimer(void* arg);
00049         static void OnMobileNetworkStopped();
00050 };
00051
00053 #endif
00054
00055
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SimpleAudioDevice.hpp File Reference

Devices/SimpleAudioDevice.hpp File Reference

#include <Audio/SimpleAudioDevice.hpp>

Include dependency graph for SimpleAudioDevice.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:11:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SimpleAudioDevice.hpp Source File

Devices/SimpleAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/SimpleAudioDevice.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SimpleAudioReference.hpp File Reference

Devices/SimpleAudioReference.hpp File Reference

#include <Audio/SimpleAudioReference.hpp>

Include dependency graph for SimpleAudioReference.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:11:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SimpleAudioReference.hpp Source File

Devices/SimpleAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/SimpleAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SpeechSimpleAudioDevice.hpp File Reference

Devices/SpeechSimpleAudioDevice.hpp File Reference

#include <Audio/SpeechSimpleAudioDevice.hpp>

Include dependency graph for SpeechSimpleAudioDevice.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:11:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SpeechSimpleAudioDevice.hpp Source File

Devices/SpeechSimpleAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/SpeechSimpleAudioDevice.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StartUp.cpp File Reference

Devices/StartUp.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "StartUp.hpp"
#include "ShutDown.hpp"
#include "Device.hpp"
#include <Config/StartUpConfig.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/SubSystemManager.hpp>
#include <Auxiliary/String.hpp>
#include <Devices/DeviceManager.hpp>
#include <Apc/SignalHandler/ProcessNode.hpp>
#include <Apc/SignalHandler/SignalHandler.hpp>
#include <Kernel/VersionInfo.hpp>
#include <Devices/Win32/MmiSimClient.hpp>
#include <stdio.h>

Include dependency graph for StartUp.cpp:

Generated on Tue Jan 24 20:33:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StartUp.hpp File Reference

Devices/StartUp.hpp File Reference

#include <Auxiliary/BitField.hpp>

Include dependency graph for StartUp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StartUp
class | StartUp::Data
struct | StartUp::Table

Defines

#define | Apoxi_StartUp_hpp

Define Documentation

#define Apoxi_StartUp_hpp

Generated on Tue Jan 24 20:33:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StartUp.hpp Source File

Devices/StartUp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_StartUp_hpp)
00011 #define Apoxi_StartUp_hpp
00014
00015 #include <Auxiliary/BitField.hpp>
00016
00018 class StartUp {
00019     public:
00023         enum Cause {
00025             NormalOn = 1,   // value must begin with 1, cause 0 is reserved for SilentReset (see StartUp::Data)
00027             AlarmOn,
00029             ChargerOn,
00031             ProductionTestOn,
00033             AirplaneOn
00034             // INFO: probably must be expanded by currently missing accessories, which are also causing startup (see SignalHandler.cpp -> Apoxi_startup())
00035         };
00036
00037         class Data {
00038             public:
00040                 Data() { }
00041
00043                 Data(Cause startup_cause) { SetCause(startup_cause); }
00044
00046                 void Reset() { m_bits.Clear(); }
00047
00049                 BOOLEAN IsValid() const { return (m_bits.Get() != 0); }
00050
00052                 void SetCause(Cause cause, BOOLEAN set = TRUE) { m_bits.SetBit(cause, set); }
00053
00058                 BOOLEAN IsCause(Cause cause) const { return m_bits.GetBit(cause); }
00059
00061                 Cause GetMainCause() const;
00062
00064                 void SetSilentReset(BOOLEAN set = TRUE) { m_bits.SetBit(SilentReset, set); }
00065
00067                 BOOLEAN IsSilentReset() const { return m_bits.GetBit(SilentReset); }
00068
00069             private:
00070                 enum {
00072                     SilentReset = 0
00073                 };
00074
00075                 BitField8 m_bits;
00076         };
00077
00079         struct Table {
00080             BOOLEAN enabled;
00082             Application* app;
00083             INT app_cont_idx;
00084             UINT stacksize;
00086         };
00087
00090         static void Start(const Data &startup_data);
00091
00100         static void Restart(const Data &startup_data);
00101
00105         static const Data& GetStartupData() { return m_startup_data; }
00106
00112         static void Abort();
00113
00114     private:
00115         friend class AlarmManager;
00116
00117         static BOOLEAN m_canceled;
00118         static Data m_startup_data;
00119
00120         static void SetStartupData(const Data& startup_data) {
00121             m_startup_data = startup_data;
00122         }
00123 };
00124
00126 #endif  // Apoxi_StartUp_hpp
00127
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StillCamera.hpp File Reference

Devices/StillCamera.hpp File Reference

#include <Devices/Win32/StillCamera.hpp>

Include dependency graph for StillCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_StillCamera_hpp

Define Documentation

#define Apoxi_Devices_StillCamera_hpp

Generated on Tue Jan 24 20:26:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StillCamera.hpp Source File

Devices/StillCamera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_Devices_StillCamera_hpp)
00010 #define Apoxi_Devices_StillCamera_hpp
00011
00014
00015 #if defined(APOXI_RTOS_WIN32)
00016     #if defined(APOXI_ATI_SUPPORT)
00017         #include <Devices/MPEU/Extensions/AtiW2282/StillCamera.hpp>
00018     #else
00019     #include <Devices/Win32/StillCamera.hpp>
00020     #endif
00021 #elif defined(APOXI_PLATFORM_BP30)
00022     #include <Devices/BP30/StillCamera.hpp>
00023 #elif defined(APOXI_PLATFORM_MPE)
00024     #include <Devices/MPE/StillCamera.hpp>
00025 #elif defined(APOXI_PLATFORM_MPEU)
00026     #include <Devices/MPEU/StillCamera.hpp>
00027 #elif defined(APOXI_PLATFORM_MP1U)
00028     #include <Devices/SGold/StillCamera.hpp>
00029 #else
00030     #error Platform not supported!
00031 #endif
00032
00034 #endif //Apoxi_Devices_StillCamera_hpp
00035
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StillCameraInterface.hpp File Reference

Devices/StillCameraInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class StillCamera

Generated on Tue Jan 24 20:33:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StillCameraInterface.hpp Source File

Devices/StillCameraInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00012 #if defined DOXYGEN_SHOULD_SKIP_THIS
00013 class StillCamera {
00014 #endif
00015     public:
00021         typedef void (*CbImageCaptured)(INT result, void* context, UINT16 frame);
00027         typedef void (*CbImageEncoded)(INT result, void* context, UINT16 frame);
00033         typedef void (*CbCaptureFinished)(INT result, void* context, UINT16 frame);
00034
00035
00037         StillCamera(INT device_id);
00038
00040         virtual ~StillCamera();
00041
00043         virtual const WCHAR* GetName() const;
00044
00046         virtual BOOLEAN GetSupportedImageSizes(const ImageSizeType* &array, UINT8& count) const;
00047
00048 #if defined(APOXI_COMPAT_2_8_0)
00049
00051         virtual BOOLEAN SetImageSize(ImageSizeType size);
00052 #endif  // #if defined(APOXI_COMPAT_2_8_0)
00053
00055         virtual BOOLEAN SetCaptureImageSize(ImageSizeType capture_image_size,
00056                                             TransformationType capture_transformation =
00057                                                                 Camera::NoTransformation);
00058
00062         BOOLEAN SetJpegQuality(INT level);
00063
00066         INT GetJpegQuality() const;
00067
00079         BOOLEAN Capture(DataSink** sink_array,
00080                         UINT16 count,
00081                         void* context,
00082                         CbImageCaptured cb_image_captured,
00083                         CbImageEncoded cb_image_encoded,
00084                         CbCaptureFinished cb_capture_finished);
00085
00092         BOOLEAN ConfigureMultiShot(UINT16 no_of_pictures, UINT8 frame_rate_subsampling);
00093
00096         BOOLEAN CancelCapture();
00097
00098 #if defined DOXYGEN_SHOULD_SKIP_THIS
00099 };
00100 #endif
00101
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StreamAudioPlayer.hpp File Reference

Devices/StreamAudioPlayer.hpp File Reference

#include <Audio/StreamAudioPlayer.hpp>

Include dependency graph for StreamAudioPlayer.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:11:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StreamAudioPlayer.hpp Source File

Devices/StreamAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/StreamAudioPlayer.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StreamAudioReference.hpp File Reference

Devices/StreamAudioReference.hpp File Reference

#include <Audio/StreamAudioReference.hpp>

Include dependency graph for StreamAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:12:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/StreamAudioReference.hpp Source File

Devices/StreamAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/StreamAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ToneAudioPlayer.hpp File Reference

Devices/ToneAudioPlayer.hpp File Reference

#include <Audio/ToneAudioPlayer.hpp>

Include dependency graph for ToneAudioPlayer.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:12:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ToneAudioPlayer.hpp Source File

Devices/ToneAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/ToneAudioPlayer.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ToneAudioReference.hpp File Reference

Devices/ToneAudioReference.hpp File Reference

#include <Audio/ToneAudioReference.hpp>

Include dependency graph for ToneAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:12:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/ToneAudioReference.hpp Source File

Devices/ToneAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/ToneAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VibratorDevice.cpp File Reference

Devices/VibratorDevice.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include <Devices/VibratorDevice.hpp>
#include <Kernel/Os/Os.hpp>
#include <Devices/Win32/vib_drv.h>

Include dependency graph for VibratorDevice.cpp:

Generated on Tue Jan 24 20:33:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VibratorDevice.hpp File Reference

Devices/VibratorDevice.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/SharedPtr.hpp>

Include dependency graph for VibratorDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VibratorDevice

Defines

#define | Apoxi_NewAPI_VibratorDevice_hpp

Define Documentation

#define Apoxi_NewAPI_VibratorDevice_hpp

Generated on Tue Jan 24 20:33:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VibratorDevice.hpp Source File

Devices/VibratorDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_NewAPI_VibratorDevice_hpp)
00011 #define Apoxi_NewAPI_VibratorDevice_hpp
00014
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Auxiliary/SharedPtr.hpp>
00018
00022 class VibratorDevice : public SystemTimer
00023 {
00024     private:
00025         //Use GetInstance() instead.
00026         VibratorDevice();
00027
00028     public:
00029         static VibratorDevice& GetInstance();
00030
00034         enum VibratorMode
00035         {
00037             Vibrator_Sync_Control,
00039             Vibrator_Async_1,
00041             Vibrator_Async_2,
00043             Vibrator_Async_3,
00045             Vibrator_Async_4,
00047             Vibrator_Async_5,
00049             Vibrator_Async_6,
00050         };
00051
00055         BOOLEAN StartVibrator(VibratorMode mode = Vibrator_Async_1, UINT16 channel = 0);
00056
00060         void StopVibrator();
00061
00063         BOOLEAN IsVibratorOn();
00064
00065     protected:
00066         static VibratorDevice m_instance;
00067         static void OnTimer(void *data);
00068         //TRUE if Vibrator is in On period, FALSE if it is in Off period
00069         BOOLEAN m_on;
00070         //TRUE if Vibrator was started and is in either in On or Off period,FALSE if the vibrator is not started or it has been stoped using StopVibrator
00071         BOOLEAN m_active;
00072         //on-off period of time matching the mode in which Vibrator was started
00073         UINT16 m_PeriodTime;
00074
00075
00076 };
00077
00079
00080 #endif  // Apoxi_NewAPI_VibratorDevice_hpp
00081
00082
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VideoCamera.hpp File Reference

Devices/VideoCamera.hpp File Reference

#include <Devices/Win32/VideoCamera.hpp>

Include dependency graph for VideoCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_VideoCamera_hpp

Define Documentation

#define Apoxi_Devices_VideoCamera_hpp

Generated on Tue Jan 24 20:27:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VideoCamera.hpp Source File

Devices/VideoCamera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_Devices_VideoCamera_hpp)
00010 #define Apoxi_Devices_VideoCamera_hpp
00011
00014 #if defined(APOXI_RTOS_WIN32)
00015     #if defined(APOXI_ATI_SUPPORT)
00016         #include <Devices/MPEU/Extensions/AtiW2282/VideoCamera.hpp>
00017     #else
00018     #include <Devices/Win32/VideoCamera.hpp>
00019     #endif
00020 #elif defined(APOXI_PLATFORM_BP30)
00021     #include <Devices/BP30/VideoCamera.hpp>
00022 #elif defined(APOXI_PLATFORM_MPE)
00023     #include <Devices/MPE/VideoCamera.hpp>
00024 #elif defined(APOXI_PLATFORM_MPEU)
00025     #include <Devices/MPEU/VideoCamera.hpp>
00026 #elif defined(APOXI_PLATFORM_MP1U)
00027     #include <Devices/SGold/VideoCamera.hpp>
00028 #else
00029     #error Platform not supported!
00030 #endif
00031
00033 #endif //Apoxi_Devices_VideoCamera_hpp
00034
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VideoCameraInterface.hpp File Reference

Devices/VideoCameraInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class VideoCamera

Generated on Tue Jan 24 20:33:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VideoCameraInterface.hpp Source File

Devices/VideoCameraInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00012 #if defined DOXYGEN_SHOULD_SKIP_THIS
00013 class VideoCamera {
00014 #endif
00015     public:
00017     enum FrameRateType {
00018         Fps3_7_5 = 0,
00019         Fps5,
00020         Fps7_5,
00021         Fps10,
00022         Fps12,
00023         Fps15,
00024         Fps24,
00025         Fps25,
00026         Fps30,
00027         EndOfFpsType
00028     };
00029
00031     enum BufferLocation {
00032         HostLocation,
00033         CompanionLocation
00034     };
00035
00044     typedef void (*Cb_FrameCaptured)(INT ret, void* context,
00045                                      UINT8 HUGE* buf, UINT32 size, UINT32 stamp);
00046
00051         typedef void (*Cb_NotifyCaptureBufferStatus)(void* context, UINT8 free_buffer_count);
00052
00057         typedef void (*Cb_VideoCaptureStopped)(INT ret, void* context);
00058
00063         typedef void (*Cb_VideoCapturePaused)(INT ret, void* context);
00065     VideoCamera(INT device_id);
00066
00068     virtual ~VideoCamera();
00069
00070
00071
00073     virtual const WCHAR* GetName() const;
00074
00079         virtual BOOLEAN Open();
00080
00081
00095     BOOLEAN SetFrameRate(FrameRateType frame_rate);
00096
00099     FrameRateType GetFrameRate() const;
00100
00104     BOOLEAN GetSupportedFrameRates(const FrameRateType* &array, UINT8& count) const;
00105
00106 #if defined(APOXI_COMPAT_2_8_0)
00107
00111         virtual BOOLEAN SetImageSize(ImageSizeType size);
00112 #endif  // #if defined(APOXI_COMPAT_2_8_0)
00113
00118         virtual BOOLEAN SetCaptureImageSize(ImageSizeType capture_image_size,
00119                                             TransformationType capture_transformation
00120                                                                 = Camera::NoTransformation);
00121
00126     virtual BOOLEAN GetSupportedImageSizes(const ImageSizeType* &array, UINT8& count) const;
00127
00131         BOOLEAN ReleaseCaptureBuffer(UINT8 HUGE* buf);
00132
00133 #if defined(APOXI_COMPAT_2_8_0)
00134
00148         BOOLEAN AllocateCaptureBuffers(UINT32& handle,
00149                                        UINT8& buf_count,
00150                                        UINT32 buf_len = 0,
00151                                        BufferLocation buf_location = HostLocation);
00152 #endif  // #if defined(APOXI_COMPAT_2_8_0)
00153
00163         BOOLEAN AllocateCaptureBuffers(UINT8& buf_count,
00164                                        UINT32 buf_len = 0);
00165
00169     BOOLEAN FreeCaptureBuffers();
00170
00175     virtual BOOLEAN StartViewfinder(/*BOOLEAN block = TRUE*/);
00176
00185     BOOLEAN StartVideoCapture(void* context,
00186                               Cb_FrameCaptured cb_frame_captured,
00187                               Cb_NotifyCaptureBufferStatus cb_notify_captbuf_status,
00188                               UINT32 starting_time = 0);
00189
00195         BOOLEAN StopVideoCapture(Cb_VideoCaptureStopped cb_video_capture_stopped = 0,
00196                                     void* context = 0);
00197
00202         BOOLEAN PauseVideoCapture(Cb_VideoCapturePaused cb_video_capture_paused = 0,
00203                                   void* context = 0);
00204
00208         BOOLEAN UnPauseVideoCapture(UINT32 new_video_capture_clock_time);
00209
00210 #if defined DOXYGEN_SHOULD_SKIP_THIS
00211 };
00212 #endif
00213
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VirtualDisplay.hpp File Reference

Devices/VirtualDisplay.hpp File Reference

#include <Devices/Win32/VirtualDisplay.hpp>

Include dependency graph for VirtualDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Devices_VirtualDisplay_hpp

Define Documentation

#define Apoxi_Devices_VirtualDisplay_hpp

Generated on Tue Jan 24 20:28:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VirtualDisplay.hpp Source File

Devices/VirtualDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_Devices_VirtualDisplay_hpp)
00010 #define Apoxi_Devices_VirtualDisplay_hpp
00011
00014
00015 #if defined(APOXI_RTOS_WIN32)
00016     #include <Devices/Win32/VirtualDisplay.hpp>
00017 #elif defined(APOXI_PLATFORM_BP30)
00018     #include <Devices/BP30/VirtualDisplay.hpp>
00019 #elif defined(APOXI_PLATFORM_MPE)
00020     #include <Devices/MPE/VirtualDisplay.hpp>
00021 #elif defined(APOXI_PLATFORM_MPEU)
00022     #include <Devices/MPEU/VirtualDisplay.hpp>
00023 #elif defined(APOXI_PLATFORM_MP1U)
00024     #include <Devices/SGold/VirtualDisplay.hpp>
00025 #else
00026     #error Platform not supported!
00027 #endif
00028
00030 #endif //Apoxi_Devices_VirtualDisplay_hpp
00031
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VoiceMemoAudioPlayer.hpp File Reference

Devices/VoiceMemoAudioPlayer.hpp File Reference

#include <Audio/VoiceMemoAudioPlayer.hpp>

Include dependency graph for VoiceMemoAudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:12:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VoiceMemoAudioPlayer.hpp Source File

Devices/VoiceMemoAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/VoiceMemoAudioPlayer.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VoiceMemoAudioReference.hpp File Reference

Devices/VoiceMemoAudioReference.hpp File Reference

#include <Audio/VoiceMemoAudioReference.hpp>

Include dependency graph for VoiceMemoAudioReference.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 18:13:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/VoiceMemoAudioReference.hpp Source File

Devices/VoiceMemoAudioReference.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Audio/VoiceMemoAudioReference.hpp>
00010
00011
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Audio.hpp File Reference

Devices/BP30/Audio.hpp File Reference

#include <Compat/Devices/BP30/Audio.hpp>

Include dependency graph for Audio.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:17:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Audio.hpp Source File

Devices/BP30/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /* The class Audio has been moved to Compat.
00010 This header-file assures backward-compatibility for
00011 applications written with APOXI-versions smaller than 2.7.0*/
00012 #include <Compat/Devices/BP30/Audio.hpp>
00013
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/BitBlit_16Bpp.cpp File Reference

Devices/BP30/BitBlit_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (clip_rect.GetHeight()<=bmp.GetHeight())
ASSERT_DEBUG_HOST (clip_rect.GetWidth()<=bmp.GetWidth())
ASSERT_DEBUG_HOST (clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (clip_rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (!clip_rect.IsEmpty())
ASSERT_DEBUG_HOST (dest_y+clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (dest_x+clip_rect.GetLeft() >=0)
if (bmp.IsTransparent())

Variables

register INT | bmp_width = bmp.GetWidth()
XYDIM | dest_end_x = dest_x + clip_rect.GetWidth() - 1
XYDIM | dest_end_y = dest_y + clip_rect.GetHeight() - 1
dest_x = clip_rect.GetLeft()
dest_y = clip_rect.GetTop()
register DDrvColorBits16Ptr | left_atom = (DDrvColorBits16Ptr)(GetBitmap()->GetBits()) + dest_y * scanline_inc + dest_x
register INT | right_clip_inc = bmp_width - clip_rect.GetWidth()
register INT | scanline_inc = m_scanline_atom_count >> 1
const register DDrvColorBits16Ptr | src_data = (const DDrvColorBits16Ptr)(bmp.GetBits()) + clip_rect.GetTop() * bmp.GetWidth() + clip_rect.GetLeft()
register INT | xlen = dest_end_x - dest_x + 1
register INT | ylen = dest_end_y - dest_y + 1

Function Documentation

ASSERT_DEBUG_HOST ( clip_rect. GetHeight()<=bmp.GetHeight() )

ASSERT_DEBUG_HOST ( clip_rect. GetWidth()<=bmp.GetWidth() )

ASSERT_DEBUG_HOST ( clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( clip_rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( !clip_rect. IsEmpty() )

ASSERT_DEBUG_HOST ( dest_y+clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( dest_x+clip_rect.GetLeft() >= 0 )

if ( bmp. IsTransparent() )

Variable Documentation

register INT bmp_width = bmp.GetWidth()

XYDIM dest_end_x = dest_x + clip_rect.GetWidth() - 1

XYDIM dest_end_y = dest_y + clip_rect.GetHeight() - 1

dest_x = clip_rect.GetLeft()

dest_y = clip_rect.GetTop()

register DDrvColorBits16Ptr left_atom = (DDrvColorBits16Ptr)(GetBitmap()->GetBits()) + dest_y * scanline_inc + dest_x

register INT right_clip_inc = bmp_width - clip_rect.GetWidth()

register INT scanline_inc = m_scanline_atom_count >> 1

const register DDrvColorBits16Ptr src_data = (const DDrvColorBits16Ptr)(bmp.GetBits()) + clip_rect.GetTop() * bmp.GetWidth() + clip_rect.GetLeft()

register INT xlen = dest_end_x - dest_x + 1

register INT ylen = dest_end_y - dest_y + 1

Generated on Tue Jan 24 20:23:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Camera.cpp File Reference

Devices/BP30/Camera.cpp File Reference

#include "PreComp.hpp"
#include "Camera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/Display.hpp>

Include dependency graph for Camera.cpp:

Functions

void | ApoxiSendGddViewfinderError (void)
BOOLEAN | GetContrastLimits (INT &min_index, INT &max_index, INT &def_index)

Function Documentation

void ApoxiSendGddViewfinderError ( void )

BOOLEAN GetContrastLimits | ( | INT & | min_index,
 |  | INT & | max_index,
 |  | INT & | def_index
 | ) |

Generated on Tue Jan 24 20:23:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Camera.hpp File Reference

Devices/BP30/Camera.hpp File Reference

#include <Devices/AbstractLockableDevice.hpp>
#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>
#include <Devices/CameraInterface.hpp>

Include dependency graph for Camera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Camera

Defines

#define | Apoxi_Camera_hpp

Define Documentation

#define Apoxi_Camera_hpp

Generated on Tue Jan 24 20:24:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Camera.hpp Source File

Devices/BP30/Camera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Camera_hpp)
00010 #define Apoxi_Camera_hpp
00011
00014
00015 #include <Devices/AbstractLockableDevice.hpp>
00016 #include <Kernel/Types.hpp>
00017 #include <Gui/Rect.hpp>
00018
00020 class Camera : public AbstractLockableDevice {
00021     typedef AbstractLockableDevice Base;
00022
00023     #include <Devices/CameraInterface.hpp>
00024
00025     protected:
00026         INT m_last_error;
00027         INT m_zoom_level;
00028         INT m_brightness_level;
00029         INT m_contrast_level;
00030         Rect m_rect;    // the current viewfinder rectangle
00031         ImageSizeType m_image_size;
00032
00033
00035         virtual BOOLEAN& GetLock() { return m_lock[GetIndex()]; }
00036
00037         void SetState(CameraState state) {m_state = state; }
00038
00039     private:
00040         static BOOLEAN m_lock[2];
00041         CameraState m_state;
00042         INT m_display_idx;  // display index where the camera viewfinder should be displayed
00043
00044         AntiFlickerType m_antiflicker_mode;
00045         FilterType m_filter;
00046         TransformationType m_capture_transformation;
00047         ScalingMethodType m_scaling_method;
00048         TwilightType m_twilight_mode;
00049
00050
00051 };
00052
00053 inline Camera::CameraState Camera::GetState() const
00054 {
00055     return m_state;
00056 }
00057
00058
00059 inline INT Camera::GetDisplayIndex() const
00060 {
00061     return m_display_idx;
00062 }
00063
00064
00065 inline INT Camera::GetLastError() const
00066 {
00067     return m_last_error;
00068 }
00069
00071 #endif  // Apoxi_Devices_Bp30_Camera_hpp
00072
00073
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Charger.cpp File Reference

Devices/BP30/Charger.cpp File Reference

#include "PreComp.hpp"
#include <stack/driver.h>
#include "Charger.hpp"
#include <Devices/ChargerSignalMapTableNode.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for Charger.cpp:

Generated on Tue Jan 24 20:24:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Charger.hpp File Reference

Devices/BP30/Charger.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/ChargerInterface.hpp>

Include dependency graph for Charger.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Charger

Defines

#define | Apoxi_Devices_Bp30_Charger_hpp

Define Documentation

#define Apoxi_Devices_Bp30_Charger_hpp

Generated on Tue Jan 24 20:24:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Charger.hpp Source File

Devices/BP30/Charger.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Devices_Bp30_Charger_hpp)
00011 #define Apoxi_Devices_Bp30_Charger_hpp
00012
00013 #include <Devices/AbstractDevice.hpp>
00014
00015 class Charger: public AbstractDevice {
00016     typedef AbstractDevice Base;
00017
00018     #include <Devices/ChargerInterface.hpp>
00019
00020     protected:
00022         virtual void OnStart();
00023
00024 };
00025
00026 #endif  // Apoxi_Devices_Bp30_Charger_hpp
00027
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/DefaultDisplay.cpp File Reference

Devices/BP30/DefaultDisplay.cpp File Reference

#include "PreComp.hpp"
#include "DefaultDisplay.hpp"
#include "VideoChannel.hpp"
#include <Gui/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DisplayMsgTypes.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <stack/driver.h>
#include <memory.h>

Include dependency graph for DefaultDisplay.cpp:

Generated on Tue Jan 24 20:24:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/DefaultDisplay.hpp File Reference

Devices/BP30/DefaultDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Devices/Display.hpp>

Include dependency graph for DefaultDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultDisplay

Defines

#define | Apoxi_DefaultDisplay_hpp

Define Documentation

#define Apoxi_DefaultDisplay_hpp

Generated on Tue Jan 24 20:25:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/DefaultDisplay.hpp Source File

Devices/BP30/DefaultDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultDisplay_hpp)
00010 #define Apoxi_DefaultDisplay_hpp
00013
00014 class VideoChannel;
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/Os/SystemTimer.hpp>
00017 #include <Devices/Display.hpp>
00018
00023 class DefaultDisplay : public Display {
00024     typedef Display Base;
00025
00026     public:
00029         DefaultDisplay(INT index);
00030
00031         virtual ~DefaultDisplay();
00032
00034         virtual const WCHAR* GetName() const;
00035
00037         virtual void OnStart();
00038
00040         virtual void OnStop();
00041
00043         virtual void SetContrast(INT contrast);
00044
00046         virtual INT GetContrast() const;
00047
00049         virtual void SetBrightness(INT brightness);
00050
00052         virtual INT GetBrightness() const;
00053
00055         virtual void SetBacklightTimeout(UINT32 timeout);
00056
00058         virtual void SetPowerTimeout(UINT32 timeout);
00059
00061         virtual void ReactivateBacklight();
00062
00064         virtual void ReactivatePower();
00065
00067         virtual void SetBacklightMode(BacklightMode mode);
00068
00070         virtual BacklightMode GetBacklightMode() const;
00071
00073         virtual BOOLEAN IsBacklightOn() const;
00074
00076         virtual void SetPowerMode(PowerMode mode);
00077
00079         virtual PowerMode GetPowerMode() const;
00080
00082         virtual BOOLEAN IsPowerOn() const;
00083
00085         virtual void Refresh();
00086
00095         virtual void Refresh(const CustomFrameBuffer* custom_frame_buf);
00096
00100         virtual VideoChannel* GetVideoChannel();
00101
00104         void OnTimer();
00105
00106         /*  S-Gold specific interface, which is not part of the common Display interface and hence may
00107             not be used by any APOXI or MMI interface. */
00108         static void SynchronizeBuffers();
00109
00111         virtual void SetCallbackActive(BOOLEAN state);
00112
00114         virtual BOOLEAN IsCallbackActive() const;
00115
00116     private:
00117         enum Status {
00118             DisplayOff,
00119             BacklightOff,
00120             BacklightOn
00121         };
00122
00123         struct {
00124             UINT backlight_mode         : 2;
00125             UINT power_mode             : 2;
00126             UINT status                 : 2;
00127             UINT power_on               : 1;
00128             UINT backlight_on           : 1;
00129         } m_bits;
00130         VideoChannel* m_video_channel;
00131         SystemTimer* m_timer;
00132         UINT32 m_backlight_timeout;
00133         UINT32 m_power_timeout;
00134
00135         UINT8 m_contrast;
00136         UINT8 m_brightness;
00137
00138         volatile BOOLEAN m_cb_active;
00139         DDrvAtomPtr m_transfer_buffer;      // buffer which contains a copy of the main frame buffer
00140
00141         void SetBacklight(BOOLEAN backlight);
00142         void SetPower(BOOLEAN power);
00143
00144         static void CallbackFn(void* arg);
00145
00146         friend class VideoChannel;
00147 };
00148
00150 #endif  // Apoxi_DefaultDisplay_hpp
00151
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/DrawChar_16Bpp.cpp File Reference

Devices/BP30/DrawChar_16Bpp.cpp File Reference

Functions

while (--height >=0)

Variables

INT | atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())
const DDrvAtomPtr | data = (const DDrvAtomPtr)glyph.GetData()
INT | line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * 2 * atoms_per_scanline
p = y * m_scanline_atom_count + (x << 1)
DDrvAtomPtr | p = GetBitmap()->GetBits()

Function Documentation

while ( --height >= 0 )

Variable Documentation

INT atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())

const DDrvAtomPtr data = (const DDrvAtomPtr)glyph.GetData()

INT line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * 2 * atoms_per_scanline

p = y * m_scanline_atom_count + (x << 1)

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:25:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/FillRect_16Bpp.cpp File Reference

Devices/BP30/FillRect_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (rect.GetBottom()<=GetHeight())
ASSERT_DEBUG_HOST (rect.GetRight()<=GetWidth())
ASSERT_DEBUG_HOST (rect.GetTop() >=0)
ASSERT_DEBUG_HOST (rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (rect.GetTop()<=rect.GetBottom())
ASSERT_DEBUG_HOST (rect.GetLeft()<=rect.GetRight())
if (xlen >=28)

Variables

register DDrvColorBits16 | col_bits = (DDrvColorBits16)m_color_value
p = rect.GetTop() * m_scanline_atom_count + (rect.GetLeft() << 1)
DDrvAtomPtr | p = GetBitmap()->GetBits()
register INT | xlen = rect.GetRight() - rect.GetLeft() + 1
register INT | ylen = rect.GetBottom() - rect.GetTop() + 1

Function Documentation

ASSERT_DEBUG_HOST ( rect. GetBottom()<=GetHeight() )

ASSERT_DEBUG_HOST ( rect. GetRight()<=GetWidth() )

ASSERT_DEBUG_HOST ( rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( rect. GetTop()<=rect.GetBottom() )

ASSERT_DEBUG_HOST ( rect. GetLeft()<=rect.GetRight() )

if ( xlen >= 28 )

Variable Documentation

register DDrvColorBits16 col_bits = (DDrvColorBits16)m_color_value

p = rect.GetTop() * m_scanline_atom_count + (rect.GetLeft() << 1)

DDrvAtomPtr p = GetBitmap()->GetBits()

register INT xlen = rect.GetRight() - rect.GetLeft() + 1

register INT ylen = rect.GetBottom() - rect.GetTop() + 1

Generated on Tue Jan 24 20:25:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Fota.cpp File Reference

Devices/BP30/Fota.cpp File Reference

#include "PreComp.hpp"
#include "Fota.hpp"

Include dependency graph for Fota.cpp:

Generated on Tue Jan 24 20:25:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Fota.hpp File Reference

Devices/BP30/Fota.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/FotaInterface.hpp>

Include dependency graph for Fota.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Fota

Defines

#define | Apoxi_Devices_BP30_Fota_hpp

Define Documentation

#define Apoxi_Devices_BP30_Fota_hpp

Generated on Tue Jan 24 20:25:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Fota.hpp Source File

Devices/BP30/Fota.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_BP30_Fota_hpp)
00010 #define Apoxi_Devices_BP30_Fota_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class Fota : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/FotaInterface.hpp>
00018
00019     private:
00020 };
00021
00022 #endif  // Apoxi_Devices_BP30_Fota_hpp
00023
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Keyboard.cpp File Reference

Devices/BP30/Keyboard.cpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Config/KeyboardConfig.hpp>
#include <stack/driver.h>
#include "Keyboard.hpp"
#include <Devices/SharedMethods/KeyboardTimer.cpp>

Include dependency graph for Keyboard.cpp:

Generated on Tue Jan 24 20:25:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Keyboard.hpp File Reference

Devices/BP30/Keyboard.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/KeyboardInterface.hpp>

Include dependency graph for Keyboard.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Keyboard
Keyboard. More...
struct | Keyboard::BitStruct

Defines

#define | Apoxi_Devices_Bp30_Keyboard_hpp

Define Documentation

#define Apoxi_Devices_Bp30_Keyboard_hpp

Generated on Tue Jan 24 20:25:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Keyboard.hpp Source File

Devices/BP30/Keyboard.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Bp30_Keyboard_hpp)
00010 #define Apoxi_Devices_Bp30_Keyboard_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class Keyboard : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/KeyboardInterface.hpp>
00018
00019     protected:
00020         virtual void OnStart();
00021
00022     private:
00023         struct BitStruct {
00024             UINT locked                 : 1;
00025             UINT multi_key_mode         : 1;
00026             UINT illumination_status    : 1;
00027             UINT illumination_mode      : 2;
00028         };
00029
00030         static BitStruct m_bits;
00031         static UINT32 m_illumination_timeout;
00032         static SystemTimer m_illumination_timer;
00033
00034         static void SetIllumination(BOOLEAN illumination);
00035         static void OnIlluminationTimer(void *arg);
00036 };
00037
00038 /*  ------------------------------------------------------------------------
00039     IsLocked
00040     ------------------------------------------------------------------------ */
00041 inline BOOLEAN Keyboard::IsLocked()
00042 {
00043     return m_bits.locked;
00044 }
00045
00046 /*  ------------------------------------------------------------------------
00047     IsMultiKeyMode
00048     ------------------------------------------------------------------------ */
00049 inline BOOLEAN Keyboard::IsMultiKeyMode()
00050 {
00051     return (BOOLEAN)m_bits.multi_key_mode;
00052 }
00053
00054 /*  ------------------------------------------------------------------------
00055     SetIlluminationTimeout
00056     ------------------------------------------------------------------------ */
00057 inline void Keyboard::SetIlluminationTimeout(UINT32 timeout)
00058 {
00059     m_illumination_timeout = timeout;
00060 }
00061
00062 /*  ------------------------------------------------------------------------
00063     GetIlluminationMode
00064     ------------------------------------------------------------------------ */
00065 inline Keyboard::IlluminationMode Keyboard::GetIlluminationMode()
00066 {
00067     return static_cast<IlluminationMode>(m_bits.illumination_mode);
00068 }
00069
00070 /*  ------------------------------------------------------------------------
00071     IsIlluminationOn
00072     ------------------------------------------------------------------------ */
00073 inline BOOLEAN Keyboard::IsIlluminationOn()
00074 {
00075     return (BOOLEAN)m_bits.illumination_status;
00076 }
00077
00078 #endif  // Apoxi_Devices_Bp30_Keyboard_hpp
00079
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Led.cpp File Reference

Devices/BP30/Led.cpp File Reference

#include "PreComp.hpp"
#include "Led.hpp"
#include <Devices/LedSignalMapTableNode.hpp>

Include dependency graph for Led.cpp:

Generated on Tue Jan 24 20:25:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Led.hpp File Reference

Devices/BP30/Led.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <stack/driver.h>
#include <Devices/LedInterface.hpp>

Include dependency graph for Led.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Led
Back light device. More...

Defines

#define | Apoxi_Devices_Bp30_Led_hpp

Define Documentation

#define Apoxi_Devices_Bp30_Led_hpp

Generated on Tue Jan 24 20:25:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/Led.hpp Source File

Devices/BP30/Led.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Bp30_Led_hpp)
00010 #define Apoxi_Devices_Bp30_Led_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013 #include <stack/driver.h>
00014
00016 class Led : public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     public:
00020         #if !defined(APOXI_LED_NEW_INTERFACE)
00021             enum Event {
00022                 Call = led_call,                /* stored in eep  */
00023                 ReceivingCall = led_receiving_call,     /* stored in eep  */
00024                 CallUnanswered = led_call_unanswered,       /* stored in eep  */
00025                 Mail = led_mail,                /* stored in eep  */
00026                 Service = led_service,          /* stored in eep  */
00027                 NoService = led_no_service,         /* stored in eep  */
00028                 LimitedService = led_limited_service,
00029                 PowerOn = led_power_on,
00030                 PowerOff = led_power_off,
00031                 ReceivedCallConnected = led_received_call_connected,
00032                 SmsReceiving = led_sms_receiving,
00033                 SmsSending = led_sms_sending,
00034                 AlarmOngoing = led_alarm_ongoing,
00035                 AlarmStopped = led_alarm_stopped,
00036                 BatteryLow = led_battery_low,
00037                 ChargerDisconnected = led_charger_disconnected,
00038                 ChargerConnected = led_charger_connected,
00039                 ChargeComplete = led_charge_complete
00040             };
00041
00042             enum Color {
00043                 Blue = led_blue,
00044                 Red = led_red,
00045                 Green = led_green,
00046                 Magenta = led_blue_red,        /* magenta */
00047                 Cyan = led_blue_green,      /* cyan    */
00048                 Yellow = led_red_green,       /* yellow  */
00049                 White = led_red_blue_green,  /* white   */
00050                 NoOfColors = led_nof_colors,
00051                 InvalidColor,
00052             };
00053
00054
00055             enum Action {
00056                 On = LED_ON,
00057                 Off = LED_OFF,
00058                 Flash = LED_FLASH,
00059                 ColorStream = LED_COLORSTREAM,
00060             };
00061
00062             #if defined (USE_SMPOWER)
00063                 enum Intensity {
00064                     NoCurrent = led_no_current, /*   0 mA */
00065                     Minimum = led_20_ma,        /*  20 mA */
00066                     Low = led_40_ma,            /*  40 mA */
00067                     LessThanNormal = led_60_ma, /*  60 mA */
00068                     Normal = led_80_ma,         /*  80 mA */
00069                     MoreThanNormal = led_100_ma,/* 100 mA */
00070                     High = led_120_ma,          /* 120 mA */
00071                     Maximum = led_140_ma        /* 140 mA */
00072                 };
00073             #else
00074                 enum Intensity {
00075                     NoCurrent,
00076                     Minimum,
00077                     Low,
00078                     LessThanNormal,
00079                     Normal,
00080                     MoreThanNormal,
00081                     High,
00082                     Maximum,
00083                 };
00084             #endif
00085         #endif
00086
00087     #include <Devices/LedInterface.hpp>
00088
00089     protected:
00090         #if defined(APOXI_LED_NEW_INTERFACE)
00091             virtual void OnStart();
00092         #endif
00093
00094     private:
00095         static const INT c_max_colorstream_length;
00096 };
00097
00098 #endif  // Apoxi_Devices_Bp30_Led_hpp
00099
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/PreComp.cpp File Reference

Devices/BP30/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:04:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/PreComp.hpp File Reference

Devices/BP30/PreComp.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/System.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/PreComp.hpp Source File

Devices/BP30/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013 #include <Kernel/System.hpp>
00014
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/RealTimeClock.cpp File Reference

Devices/BP30/RealTimeClock.cpp File Reference

#include "PreComp.hpp"
#include <Devices/RealTimeClock.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Devices/RtcSignalMapTableNode.hpp>
#include <Devices/RtcMsgTypes.hpp>
#include <stdio.h>
#include <stack/driver.h>
#include <stack/stack.h>

Include dependency graph for RealTimeClock.cpp:

Functions

void RTC_OnEvent (void)

Function Documentation

void RTC_OnEvent ( void )

Generated on Tue Jan 24 20:25:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/RealTimeClock.hpp File Reference

Devices/BP30/RealTimeClock.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/RealTimeClockInterface.hpp>

Include dependency graph for RealTimeClock.hpp:

Go to the source code of this file.

Data Structures

class | RealTimeClock

Defines

#define | Apoxi_Devices_Bp30_RealTimeClock_hpp

Define Documentation

#define Apoxi_Devices_Bp30_RealTimeClock_hpp

Generated on Tue Jan 24 20:25:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/RealTimeClock.hpp Source File

Devices/BP30/RealTimeClock.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Bp30_RealTimeClock_hpp)
00010 #define Apoxi_Devices_Bp30_RealTimeClock_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class RealTimeClock : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/RealTimeClockInterface.hpp>
00018
00019     protected:
00021         virtual void OnStart();
00022
00024         virtual void OnStop();
00025 };
00026
00027 #endif  // Apoxi_Devices_Bp30_RealTimeClock_hpp
00028
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/ScrollHorizontal_16Bpp.cpp File Reference

Devices/BP30/ScrollHorizontal_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT x=x_start;x!=x_stop;x-=Sign(dx))
if (dx > 0) right-

Variables

XYDIM | bottom = rect.GetBottom()
INT | col_inc = Sign(dx) << 1
DDrvAtomPtr | dest_col_start_atom = src_col_start_atom + (dx << 1)
else | left = dx
XYDIM | left = rect.GetLeft()
XYDIM | right = rect.GetRight()
XYDIM | top = rect.GetTop()
XYDIM | x_start
XYDIM | x_stop
INT | ylen = bottom - top + 1

Function Documentation

for ( INT x = x_start; x != x_stop; x -= Sign(dx) )

if | ( | dx | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

INT col_inc = Sign(dx) << 1

DDrvAtomPtr dest_col_start_atom = src_col_start_atom + (dx << 1)

else left = dx

XYDIM left = rect.GetLeft()

XYDIM right = rect.GetRight()

XYDIM top = rect.GetTop()

XYDIM x_start

XYDIM x_stop

INT ylen = bottom - top + 1

Generated on Tue Jan 24 20:26:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/ScrollVertical_16Bpp.cpp File Reference

Devices/BP30/ScrollVertical_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT y=y_start;y!=y_stop;y-=Sign(dy))
if (dy > 0) bottom-

Variables

XYDIM | bottom = rect.GetBottom()
DDrvAtomPtr | dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count
XYDIM | left = rect.GetLeft()
INT | line_inc = m_scanline_atom_count * Sign(dy)
XYDIM | right = rect.GetRight()
else | top = dy
XYDIM | top = rect.GetTop()
XYDIM | xlen = right - left + 1
INT | y_start
INT | y_stop

Function Documentation

for ( INT y = y_start; y != y_stop; y -= Sign(dy) )

if | ( | dy | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

DDrvAtomPtr dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count

XYDIM left = rect.GetLeft()

INT line_inc = m_scanline_atom_count * Sign(dy)

XYDIM right = rect.GetRight()

else top = dy

XYDIM top = rect.GetTop()

XYDIM xlen = right - left + 1

INT y_start

INT y_stop

Generated on Tue Jan 24 20:26:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/StillCamera.cpp File Reference

Devices/BP30/StillCamera.cpp File Reference

#include "PreComp.hpp"
#include "StillCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for StillCamera.cpp:

Generated on Tue Jan 24 20:26:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/StillCamera.hpp File Reference

Devices/BP30/StillCamera.hpp File Reference

#include <Auxiliary/DataSink.hpp>
#include <Devices/BP30/Camera.hpp>
#include <Devices/StillCameraInterface.hpp>

Include dependency graph for StillCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StillCamera

Defines

#define | Apoxi_StillCamera_hpp

Define Documentation

#define Apoxi_StillCamera_hpp

Generated on Tue Jan 24 20:26:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/StillCamera.hpp Source File

Devices/BP30/StillCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_StillCamera_hpp)
00010 #define Apoxi_StillCamera_hpp
00013
00014 #include <Auxiliary/DataSink.hpp>
00015 #include <Devices/BP30/Camera.hpp>
00016
00018 class StillCamera : public Camera {
00019     typedef Camera Base;
00020
00021     public:
00022         #include <Devices/StillCameraInterface.hpp>
00023
00024     protected:
00025
00026     private:
00027         FlashType m_flash;
00028
00029         INT m_jpeg_quality;
00030
00031         CbImageCaptured     m_cb_image_captured;
00032         CbImageEncoded      m_cb_image_encoded;
00033         CbCaptureFinished   m_cb_capture_finished;
00034
00035                 // callbacks
00036         // callback for still camera, where buffer for raw data will be passed to
00037         static void Cb_GDD_GetCaptureBuffer(void* context, UINT8 HUGE **buffer, UINT32 size);
00038
00039         // callback where an image has been captured as RAW data in to buffer
00040         static void Cb_GDD_ImageCaptured(INT, void* context, UINT8 HUGE* captured_buffer, UINT32 size);
00041
00042         // callback from JpegEncoder, when an RAW data image has been encoded to JPEG
00043         static void Cb_GDD_ImageEncoded(INT, void* context, DataSink& sink);
00044 };
00045
00046 inline INT StillCamera::GetJpegQuality() const
00047 {
00048     return m_jpeg_quality;
00049 }
00050
00052 #endif  // Apoxi_StillCamera_hpp
00053
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VideoCamera.cpp File Reference

Devices/BP30/VideoCamera.cpp File Reference

#include "PreComp.hpp"
#include "VideoCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for VideoCamera.cpp:

Generated on Tue Jan 24 20:26:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VideoCamera.hpp File Reference

Devices/BP30/VideoCamera.hpp File Reference

#include <Devices/BP30/Camera.hpp>
#include <Devices/VideoCameraInterface.hpp>

Include dependency graph for VideoCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoCamera

Defines

#define | Apoxi_VideoCamera_hpp

Define Documentation

#define Apoxi_VideoCamera_hpp

Generated on Tue Jan 24 20:27:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VideoCamera.hpp Source File

Devices/BP30/VideoCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VideoCamera_hpp)
00010 #define Apoxi_VideoCamera_hpp
00013
00014 #include <Devices/BP30/Camera.hpp>
00015
00017 class VideoCamera : public Camera {
00018     typedef Camera Base;
00019
00020     public:
00021         #include <Devices/VideoCameraInterface.hpp>
00022
00023     protected:
00024
00025     private:
00026         // tbd: check whether signature of callbacks are equal to the GDD 2.2 ones
00027         static UINT8 HUGE* GetCaptureBuffer_GDD_CB(/*UINT8 HUGE ** buffer, UINT32 size*/);
00028         static void VideoFrameCaptured_GDD_CB(int result, UINT8 HUGE * buffer, UINT32 size, UINT32 stamp);
00029         static void NotifyCaptureBufferStatus_GDD_CB(void* context, UINT8 free_buffer_count);
00030
00031         FrameRateType m_fps;
00032
00033         static UINT32 m_starting_time;          // frame count or timestamp
00034
00036         static UINT32 m_pool_handle;
00037
00038         static Cb_NotifyCaptureBufferStatus m_cb_notify_status;
00039         static Cb_FrameCaptured m_cb_frame_captured;
00040 };
00041
00042 inline VideoCamera::FrameRateType VideoCamera::GetFrameRate() const
00043 {
00044     return m_fps;
00045 }
00046
00048 #endif  // Apoxi_VideoCamera_hpp
00049
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VideoChannel.cpp File Reference

Devices/BP30/VideoChannel.cpp File Reference

#include "PreComp.hpp"
#include "VideoChannel.hpp"

Include dependency graph for VideoChannel.cpp:

Generated on Tue Jan 24 20:27:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VideoChannel.hpp File Reference

Devices/BP30/VideoChannel.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for VideoChannel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoChannel
struct | VideoChannel::StateFlags

Defines

#define | Apoxi_Devices_BP30_VideoChannel_hpp

Define Documentation

#define Apoxi_Devices_BP30_VideoChannel_hpp

Generated on Tue Jan 24 20:28:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VideoChannel.hpp Source File

Devices/BP30/VideoChannel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_BP30_VideoChannel_hpp)
00010 #define Apoxi_Devices_BP30_VideoChannel_hpp
00011
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Rect.hpp>
00017
00026 class VideoChannel {
00027
00028     public:
00029
00030 #ifdef APOXI_COMPAT_2_8_0
00031
00034         enum VideoParameterType {
00036             Rotate,
00038             Mirror,
00040             Flip,
00042             Antitearing,
00044             SmartOverlays,
00046             YuvToRgbConversion,
00048             ZoomFactorHorizontalMin,
00050             ZoomFactorHorizontalMax,
00052             ZoomFactorVerticalMin,
00054             ZoomFactorVerticalMax
00055         };
00056 #endif // APOXI_COMPAT_2_8_0
00057
00059         enum TransformationType {
00060             NoTransformation,
00061             Rotation90Transformation,
00062             Rotation180Transformation,
00063             Rotation270Transformation,
00064             MirrorTransformation,
00065             MirrorRotate90Transformation,
00066             MirrorRotate180Transformation,  // same as flip
00067             MirrorRotate270Transformation
00068         };
00069
00070         enum ScalingMethodType {
00071             NoScaling,
00072             LetterboxScaling,
00073             BestFitScaling
00074         };
00075
00076         enum VideoAndViewfinderOrderType {
00077             ViewfinderOverVideoPlayback,
00078             VideoPlaybackOverViewfinder
00079         };
00080
00090         typedef void (*CbResult)(   BOOLEAN result,
00091                                     void* context);
00092
00093 #ifdef APOXI_COMPAT_2_8_0
00094
00105         typedef void (*CbVideoFrameRendered)(INT result,
00106                                             void* context,
00107                                             const UINT8 HUGE* frame_buf);
00108
00120         typedef void (*CbVideoFrameRenderedNew)(BOOLEAN result,
00121                                             void* context,
00122                                             const UINT8 HUGE* frame_buf);
00123 #else // APOXI_COMPAT_2_8_0
00124
00136         typedef void (*CbVideoFrameRendered)(BOOLEAN result,
00137                                             void* context,
00138                                             const UINT8 HUGE* frame_buf);
00139 #endif // APOXI_COMPAT_2_8_0
00140
00144         VideoChannel(INT display_idx = 0);
00145
00146         ~VideoChannel();
00147
00148 #ifdef APOXI_COMPAT_2_8_0
00149
00162         BOOLEAN Open(Rect& video_frame_rect, CbVideoFrameRendered cb_frame_rendered, void* context = 0);
00163
00175         BOOLEAN Open(CbVideoFrameRenderedNew cb_frame_rendered, void* context);
00176 #else // APOXI_COMPAT_2_8_0
00177
00189         BOOLEAN Open(CbVideoFrameRendered cb_frame_rendered, void* context);
00190 #endif // APOXI_COMPAT_2_8_0
00191
00193         void Close();
00194
00204         BOOLEAN Start(CbResult cb_video_channel_started, void* context);
00205
00215         BOOLEAN Stop(CbResult cb_video_channel_stopped, void* context);
00216
00227         void RenderFrame(void* frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame = FALSE);
00228
00232         BOOLEAN IsOpen() const;
00233
00236         UINT32 GetRefreshDelay() const;
00237
00238 #ifdef APOXI_COMPAT_2_8_0
00239
00244         BOOLEAN SetParam(VideoParameterType type, UINT32 value);
00245
00252         BOOLEAN GetParam(VideoParameterType type, UINT32* value) const;
00253 #endif // APOXI_COMPAT_2_8_0
00254
00255 #ifdef APOXI_COMPAT_2_6_0
00256
00264         void SetSize(Size video_size)
00265         {
00266         #ifdef APOXI_COMPAT_2_8_0
00267             SetVideoSize(video_size);
00268         #endif //  APOXI_COMPAT_2_8_0
00269         }
00270 #endif // APOXI_COMPAT_2_6_0
00271
00272 #ifdef APOXI_COMPAT_2_8_0
00273
00280         void SetVideoSize(Size video_size);
00281 #endif // APOXI_COMPAT_2_8_0
00282
00294         BOOLEAN SetVideoSize(   Size actual_video_size,
00295                                 Size extended_video_size,
00296                                 Point left_top_offset);
00297
00298 #ifdef APOXI_COMPAT_2_8_0
00299
00310         BOOLEAN SetCropRect(Rect& crop_rect);
00311 #endif // APOXI_COMPAT_2_8_0
00312
00326         BOOLEAN SetCropRect(Rect& crop_rect, Rect& effective_playback_rect);
00327
00328 #ifdef APOXI_COMPAT_2_6_0
00329
00336         BOOLEAN AdjustFrameRect(Rect& video_frame_rect)
00337         {
00338         #ifdef APOXI_COMPAT_2_8_0
00339             return SetFrameRect(video_frame_rect);
00340         #else
00341             return FALSE;
00342         #endif //  APOXI_COMPAT_2_8_0
00343         }
00344 #endif // APOXI_COMPAT_2_6_0
00345
00346 #ifdef APOXI_COMPAT_2_8_0
00347
00354         BOOLEAN SetFrameRect(Rect& video_frame_rect);
00355 #endif // APOXI_COMPAT_2_8_0
00356
00368         BOOLEAN SetPlaybackRect(Rect& playback_rect,
00369                                 TransformationType playback_transformation,
00370                                 ScalingMethodType scaling_method);
00371
00372 #ifdef APOXI_COMPAT_2_8_0
00373
00384         BOOLEAN QueryRects(Rect& video_frame_rect, Rect& crop_rect);
00385 #endif // APOXI_COMPAT_2_8_0
00386
00397         BOOLEAN SetPlaybackAndViewfinderOrder(
00398                             VideoAndViewfinderOrderType video_viewfinder_order);
00399
00400     private:
00401
00403         enum StateType {
00404             IdleState = 0,
00405             OpeningState,
00406             OpenState,
00407             StartingState,
00408             StartedState,
00409             StoppingState,
00410             ClosingState
00411         };
00412
00413         struct StateFlags {
00414             UINT m_state                        :3;
00415             UINT m_video_size_set               :1;
00416             UINT m_playback_rect_set            :1;
00417         };
00418
00419         static void CbNotifyVideoFrameRendered( INT result,
00420                                                 void *context,
00421                                                 UINT8 * frame_buf);
00422         static void CbNotifyStarted(INT result, void* context);
00423         static void CbNotifyStopped(INT result, void* context);
00424
00425 #ifdef APOXI_COMPAT_2_8_0
00426         CbVideoFrameRenderedNew m_cb_video_frame_rendered;
00427 #else // APOXI_COMPAT_2_8_0
00428         CbVideoFrameRendered    m_cb_video_frame_rendered;
00429 #endif // APOXI_COMPAT_2_8_0
00430         CbResult                m_cb_stopped;
00431         CbResult                m_cb_started;
00432
00433         INT                 m_display_idx;
00434         StateFlags          m_flags;
00435
00436         TransformationType  m_transformation;
00437         ScalingMethodType   m_scaling_method;
00438         Rect                m_playback_rect;
00439         Rect                m_effective_playback_rect;
00440         Rect                m_crop_rect;
00441         Rect                m_actual_video_rect;
00442         Size                m_extended_video_size;
00443         void*               m_client_context_frame_rendered;
00444         void*               m_client_context_start;
00445         void*               m_client_context_stop;
00446
00452         BOOLEAN ConvertResultCode(INT result_code);
00453
00454         void ResetVideoChannel();
00455
00456 };
00457
00459 #endif  // Apoxi_Devices_BP30_VideoChannel_hpp
00460
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VirtualDisplay.cpp File Reference

Devices/BP30/VirtualDisplay.cpp File Reference

#include "PreComp.hpp"
#include "VirtualDisplay.hpp"
#include "../SharedMethods/Ddrv.cpp"
#include <Devices/DeviceManager.hpp>
#include <memory.h>
#include "../SharedMethods/SetPixel_16Bpp.cpp"
#include "FillRect_16Bpp.cpp"
#include "BitBlit_16Bpp.cpp"
#include "ScrollHorizontal_16Bpp.cpp"
#include "ScrollVertical_16Bpp.cpp"
#include "../SharedMethods/DrawChar_16Bpp.cpp"
#include "../SharedMethods/ConvertToColorValue_Bpp.cpp"
#include "../SharedMethods/GetPixelColor_16Bpp.cpp"

Include dependency graph for VirtualDisplay.cpp:

Generated on Tue Jan 24 20:28:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VirtualDisplay.hpp File Reference

Devices/BP30/VirtualDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/Rect.hpp>
#include <Gui/ColorTable.hpp>
#include <Gui/Color.hpp>
#include <Gui/Font.hpp>
#include <Kernel/Os/SystemTimer.hpp>

Include dependency graph for VirtualDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ScanlineAccessor
class | VirtualDisplay

Defines

#define | Apoxi_VirtualDisplay_hpp

Define Documentation

#define Apoxi_VirtualDisplay_hpp

Generated on Tue Jan 24 20:28:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/BP30/VirtualDisplay.hpp Source File

Devices/BP30/VirtualDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_VirtualDisplay_hpp)
00010 #define Apoxi_VirtualDisplay_hpp
00013
00014 class VideoChannel;
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Devices/AbstractDevice.hpp>
00018 #include <Gui/Bitmap.hpp>
00019 #include <Gui/Rect.hpp>
00020 #include <Gui/ColorTable.hpp>
00021 #include <Gui/Color.hpp>
00022 #include <Gui/Font.hpp>
00023 #include <Kernel/Os/SystemTimer.hpp>
00024
00029 class VirtualDisplay : public AbstractDevice {
00030     typedef AbstractDevice Base;
00031
00032     public:
00034         enum Type {
00036             Monochrome,
00038             Planes2,
00040             Planes4,
00042             Planes8,
00044             BitsPerPixel8,
00046             BitsPerPixel16,
00048             BitsPerPixel24,
00050             BitsPerPixel32
00051         };
00052
00054         VirtualDisplay(INT index = 0);
00055
00068         VirtualDisplay(XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00069
00071         VirtualDisplay(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00072
00074         virtual ~VirtualDisplay();
00075
00088         void Init(XYDIM width, XYDIM height,  INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00089
00091         void Init(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00092
00094         virtual const WCHAR* GetName() const;
00095
00097         ControlArg Control(INT command, ControlArg arg);
00098
00100         XYDIM GetWidth() const { return m_bitmap.GetWidth();}
00101
00103         XYDIM GetHeight() const { return m_bitmap.GetHeight(); }
00104
00106         Bitmap* GetBitmap() { return &m_bitmap; }
00107
00109         Type GetType() { return m_type; }
00110
00114         void SetBlitRect(const Rect& rect = Rect()) { m_blit_rect = rect; }
00115
00117         const Rect& GetBlitRect() const { return m_blit_rect; };
00118
00121         void AdjustBlitRect(const Rect& rect) { m_blit_rect.Union(rect); }
00122
00125         virtual void Refresh();
00126
00129         void SetPixel(XYDIM x, XYDIM y);
00130
00133         void FillRect(const Rect& rect);
00134
00144             void BitBlit(XYDIM dest_x,
00145                      XYDIM dest_y,
00146                      const BitmapRes& bmp,
00147                      const Rect& clip_rect,
00148                      UINT8 trans_mode = 0);
00149
00154         void Scroll(const Rect& rect, XYDIM dx, XYDIM dy);
00155
00158         void DrawChar(XYDIM x, XYDIM y, const Glyph& glyph, INT height);
00159
00161         void SetColorValue(ColorValue color_value, UINT8 alpha = 255);
00162
00164         ColorValue GetColorValue() const { return m_color_value; }
00165
00167         void SetColor(Color color);
00168
00170         Color GetColor() const { return m_color; }
00171
00176         ColorValue ConvertToColorValue(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const;
00177
00179         Color GetPixelColor(XYDIM x, XYDIM y) const;
00180
00182         INT GetScanlineAtomCount() const { return m_scanline_atom_count; }
00183
00186         void SetAlphaBlendingMode(BOOLEAN mode) {
00187                                                     #ifdef APOXI_ENABLE_ALPHA_BLENDING
00188                                                         m_alpha_mode = mode;
00189                                                     #endif
00190                                                 }
00191
00193         BOOLEAN GetAlphaBlendingMode() const {
00194                                                 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00195                                                     return m_alpha_mode;
00196                                                 #else
00197                                                     return TRUE;
00198                                                 #endif
00199                                                 }
00200     private:
00201 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00202         BOOLEAN m_alpha_mode;
00203 #endif
00204         Bitmap m_bitmap;
00205         Rect m_blit_rect;
00206         Type m_type;
00207         ColorValue m_color_value;
00208         Color m_color;
00209         INT m_pixel_atom_count;
00210         INT m_scanline_atom_count;
00211         INT m_plane_count;
00212         INT m_scanline_inc;
00213         INT m_plane_inc;
00214         DDrvAtomPtr m_data;
00215         DDrvAtomPtr m_scanline_buffer;
00216
00217         void ScrollHorizontal(const Rect& rect, XYDIM dx);
00218         void ScrollVertical(const Rect& rect, XYDIM dy);
00219 };
00220
00223 class ScanlineAccessor {
00224     public:
00229         ScanlineAccessor(VirtualDisplay* display, XYDIM x, XYDIM y, XYDIM width) :
00230             m_data((UINT16 GDI_HUGE*)display->GetBitmap()->GetBits()),
00231             m_count(width)
00232         {
00233             m_data += (display->GetScanlineAtomCount() >> 1) * y + x;
00234         }
00235
00237         BOOLEAN HasNext() { return (m_count > 0); };
00238
00240         void Draw(UINT8 red, UINT8 green, UINT8 blue)
00241         {
00242             *m_data = ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)));
00243
00244             #if defined(APOXI_DISPLAY_FORMAT_BIG_ENDIAN)
00245                 *m_data = ((*m_data & 0xffU) << 8U) | ((*m_data & 0xff00U)) >> 8U;
00246             #endif
00247             m_data++;
00248             m_count--;
00249         }
00250
00251         void Draw(ColorValue cv)
00252         {
00253             *m_data = cv;
00254             m_data++;
00255             m_count--;
00256         }
00257
00261         void Next() {
00262             m_data++;
00263             m_count--;
00264         }
00265
00266     private:
00268         UINT16 GDI_HUGE* m_data;
00270         XYDIM m_count;
00271
00272 };
00273
00275 #endif  // Apoxi_VirtualDisplay_hpp
00276
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioDeviceStatusMsg.hpp File Reference

Devices/Messages/AudioDeviceStatusMsg.hpp File Reference

#include <Audio/Messages/AudioDeviceStatusMsg.hpp>

Include dependency graph for AudioDeviceStatusMsg.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:09:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioDeviceStatusMsg.hpp Source File

Devices/Messages/AudioDeviceStatusMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "frankovi_view2\lnz_development\src\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioDeviceStatusMsg.hpp>
00014
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioErrorMsg.hpp File Reference

Devices/Messages/AudioErrorMsg.hpp File Reference

#include <Audio/Messages/AudioErrorMsg.hpp>

Include dependency graph for AudioErrorMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:54:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioErrorMsg.hpp Source File

Devices/Messages/AudioErrorMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "frankovi_view2\lnz_development\src\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioErrorMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioMsg.hpp File Reference

Devices/Messages/AudioMsg.hpp File Reference

#include <Audio/Messages/AudioMsg.hpp>

Include dependency graph for AudioMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:54:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioMsg.hpp Source File

Devices/Messages/AudioMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "frankovi_view2\lnz_development\src\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:45:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioPlayTimeMsg.hpp File Reference

Devices/Messages/AudioPlayTimeMsg.hpp File Reference

#include <Audio/Messages/AudioPlayTimeMsg.hpp>

Include dependency graph for AudioPlayTimeMsg.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioPlayTimeMsg.hpp Source File

Devices/Messages/AudioPlayTimeMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "simonal_view_sgold_lite\lnz_apoxi\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioPlayTimeMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioRadioDeviceNotificationMsg.hpp File Reference

Devices/Messages/AudioRadioDeviceNotificationMsg.hpp File Reference

#include <Audio/Messages/AudioRadioDeviceNotificationMsg.hpp>

Include dependency graph for AudioRadioDeviceNotificationMsg.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioRadioDeviceNotificationMsg.hpp Source File

Devices/Messages/AudioRadioDeviceNotificationMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "frankovi_view2\lnz_development\src\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioRadioDeviceNotificationMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioRestartedMsg.hpp File Reference

Devices/Messages/AudioRestartedMsg.hpp File Reference

#include <Audio/Messages/AudioRestartedMsg.hpp>

Include dependency graph for AudioRestartedMsg.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioRestartedMsg.hpp Source File

Devices/Messages/AudioRestartedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "frankovi_view2\lnz_development\src\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioRestartedMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioResumedMsg.hpp File Reference

Devices/Messages/AudioResumedMsg.hpp File Reference

#include <Audio/Messages/AudioResumedMsg.hpp>

Include dependency graph for AudioResumedMsg.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioResumedMsg.hpp Source File

Devices/Messages/AudioResumedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "poles_view3\lnz_apoxi\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioResumedMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioStartedMsg.hpp File Reference

Devices/Messages/AudioStartedMsg.hpp File Reference

#include <Audio/Messages/AudioStartedMsg.hpp>

Include dependency graph for AudioStartedMsg.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioStartedMsg.hpp Source File

Devices/Messages/AudioStartedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "poles_view3\lnz_apoxi\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioStartedMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioStoppedMsg.hpp File Reference

Devices/Messages/AudioStoppedMsg.hpp File Reference

#include <Audio/Messages/AudioStoppedMsg.hpp>

Include dependency graph for AudioStoppedMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:54:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioStoppedMsg.hpp Source File

Devices/Messages/AudioStoppedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "simonal_view_sgold_lite\lnz_apoxi\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioStoppedMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioStreamingSyncMsg.hpp File Reference

Devices/Messages/AudioStreamingSyncMsg.hpp File Reference

#include <Audio/Messages/AudioStreamingSyncMsg.hpp>

Include dependency graph for AudioStreamingSyncMsg.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 18:10:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioStreamingSyncMsg.hpp Source File

Devices/Messages/AudioStreamingSyncMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "frankovi_view2\lnz_development\src\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioStreamingSyncMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioSuspendedMsg.hpp File Reference

Devices/Messages/AudioSuspendedMsg.hpp File Reference

#include <Audio/Messages/AudioSuspendedMsg.hpp>

Include dependency graph for AudioSuspendedMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:54:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioSuspendedMsg.hpp Source File

Devices/Messages/AudioSuspendedMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "frankovi_view2\lnz_development\src\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioSuspendedMsg.hpp>
00014
00015
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp File Reference

Devices/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp File Reference

#include <Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp>

Include dependency graph for AudioVoiceMemoOutOfSpaceMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:54:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp Source File

Devices/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "frankovi_view2\lnz_development\src\Apoxi\Devices\Messages\AudioTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #include <Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp>
00014
Generated on Tue Jan 24 14:45:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/TransportNotificationMsg.cpp File Reference

Devices/Messages/TransportNotificationMsg.cpp File Reference

#include "Devices/DevicesPreComp.hpp"
#include "TransportNotificationMsg.hpp"

Include dependency graph for TransportNotificationMsg.cpp:

Generated on Tue Jan 24 20:29:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/TransportNotificationMsg.hpp File Reference

Devices/Messages/TransportNotificationMsg.hpp File Reference

#include <Kernel/Message.hpp>
#include <Devices/AbstractTransport.hpp>

Include dependency graph for TransportNotificationMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TransportNotificationMsg

Defines

#define | Apoxi_Devices_TransportNotificationMsg_hpp

Define Documentation

#define Apoxi_Devices_TransportNotificationMsg_hpp

Generated on Tue Jan 24 20:29:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Messages/TransportNotificationMsg.hpp Source File

Devices/Messages/TransportNotificationMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Devices\Messages\TransportTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Apoxi_Devices_TransportNotificationMsg_hpp)
00016 #define Apoxi_Devices_TransportNotificationMsg_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Devices/AbstractTransport.hpp>
00020
00021
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025
00026 /*  ======================================================================
00027     Class TransportNotificationMsg
00028     ====================================================================== */
00029
00031 class TransportNotificationMsg : public ContextMsg {
00032     public:
00033         TransportNotificationMsg(ExecutionContext* context, const AbstractTransport::NotificationMsgType& msg_type);
00034         virtual ~TransportNotificationMsg();
00035
00036         virtual const MsgMetaData& GetMetaData() const;
00037         const AbstractTransport::NotificationMsgType& GetMsgType() const { return m_msg_type; }
00038         virtual Message* Clone() const;
00039
00040         enum  {
00041             ID = 9100
00042             };
00043
00044     private:
00045         static const MsgMetaData m_meta_data;
00046         AbstractTransport::NotificationMsgType m_msg_type;
00047
00048     };
00049
00050 #endif // Apoxi_Devices_TransportNotificationMsg_hpp
00051
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Audio.hpp File Reference

Devices/MPE/Audio.hpp File Reference

#include <Compat/Devices/MPE/Audio.hpp>

Include dependency graph for Audio.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:17:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Audio.hpp Source File

Devices/MPE/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /* The class Audio has been moved to Compat.
00010 This header-file assures backward-compatibility for
00011 applications written with APOXI-versions smaller than 2.7.0*/
00012 #include <Compat/Devices/MPE/Audio.hpp>
00013
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/BackLight.cpp File Reference

Devices/MPE/BackLight.cpp File Reference

#include "BackLight.hpp"

Include dependency graph for BackLight.cpp:

Generated on Tue Jan 24 20:29:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/BackLight.hpp File Reference

Devices/MPE/BackLight.hpp File Reference

#include "Kernel/Types.hpp"
#include <Devices/AbstractDevice.hpp>

Include dependency graph for BackLight.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BackLight
Back light device. More...

Defines

#define | Apoxi_BackLight_hpp

Define Documentation

#define Apoxi_BackLight_hpp

Generated on Tue Jan 24 20:29:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/BackLight.hpp Source File

Devices/MPE/BackLight.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BackLight_hpp)
00010 #define Apoxi_BackLight_hpp
00011
00012 #include "Kernel/Types.hpp"
00013 #include <Devices/AbstractDevice.hpp>
00014
00015
00016
00017
00019 class BackLight : public AbstractDevice {
00020     public:
00021
00022         enum BackLightMode {
00023             BackLightOn  ,
00024             BackLightOff
00025         };
00026
00028         static void Init();
00029
00031         virtual const WCHAR* GetName() const;
00032
00034         static void Switch(BackLightMode mode);
00035
00037         static BOOLEAN GetStatus();
00038
00040         static void CleanUp(){};
00041
00042 };
00043
00044
00045
00046 #endif  // Apoxi_BackLight_hpp
00047
00048
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Camera.cpp File Reference

Devices/MPE/Camera.cpp File Reference

#include "PreComp.hpp"
#include "Camera.hpp"
#include <Config/CameraConfig.hpp>
#include <Devices/DeviceManager.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <stack/driver.h>

Include dependency graph for Camera.cpp:

Defines

#define | DEBUG_CAMERA_CPP
#define | DEBUG_DEVICE_CAMERA_CPP_FILE (0)

Functions

void | ApoxiSendGddViewfinderError ()

Define Documentation

#define DEBUG_CAMERA_CPP

#define DEBUG_DEVICE_CAMERA_CPP_FILE (0)

Function Documentation

void ApoxiSendGddViewfinderError ( void )

Generated on Tue Jan 24 20:23:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Camera.hpp File Reference

Devices/MPE/Camera.hpp File Reference

#include <Devices/AbstractLockableDevice.hpp>
#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>
#include <Devices/CameraInterface.hpp>

Include dependency graph for Camera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Camera
struct | Camera::ViewfinderInfo

Defines

#define | Apoxi_Camera_hpp
#define | APOXI_CAMERA_TWINVIEWFINDER_SUPPORT

Define Documentation

#define Apoxi_Camera_hpp

Generated on Tue Jan 24 20:24:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Camera.hpp Source File

Devices/MPE/Camera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Camera_hpp)
00010 #define Apoxi_Camera_hpp
00013
00014 #include <Devices/AbstractLockableDevice.hpp>
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Rect.hpp>
00017
00018 #define APOXI_CAMERA_TWINVIEWFINDER_SUPPORT
00019
00021 class Camera : public AbstractLockableDevice {
00022     typedef AbstractLockableDevice Base;
00023
00024     public:
00025
00026         #include <Devices/CameraInterface.hpp>
00027
00028     protected:
00029
00031         virtual BOOLEAN& GetLock() {return m_lock[GetIndex()];}
00032
00033         void SetState(CameraState camera_state);
00034
00036         INT m_last_error;
00038         INT m_zoom_level;
00040         INT m_brightness_level;
00042         INT m_contrast_level;
00044         INT m_exposure_level;
00046         Rect m_rect;
00048         ImageSizeType m_capture_image_size;
00050         TransformationType m_capture_transformation;
00052         TransformationType m_view_image_transformation;
00054         FlashType m_flash;
00056         WhiteBalanceType m_white_balance;
00057
00058         MeteringType m_metering_mode;
00059
00060     private:
00061
00062         static BOOLEAN m_lock[2];
00063
00064         CameraState m_camera_state;
00065         INT m_display_idx;  // display index where the camera viewfinder should be displayed
00066
00067 #ifdef APOXI_CAMERA_TWINVIEWFINDER_SUPPORT
00068         typedef struct ViewfinderInfo {
00069             BOOLEAN set;
00070             Rect rect;
00071             TransformationType transformation;
00072             ScalingMethodType scaling;
00073         } ViewfinderInfo;
00074
00075         BOOLEAN m_twinviewfinder_enabled;
00076
00077         ViewfinderInfo m_viewfinder_info[2];
00078 #endif
00079         AntiFlickerType m_antiflicker_mode;
00080         FilterType m_filter;
00081
00082         ScalingMethodType m_scaling_method;
00083         TwilightType m_twilight_mode;
00084
00085 };
00086
00087 inline INT Camera::GetLastError() const
00088 {
00089     return m_last_error;
00090 }
00091
00092 inline INT Camera::GetDisplayIndex() const
00093 {
00094     return m_display_idx;
00095 }
00096
00098 #endif  // Apoxi_Camera_hpp
00099
00100
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Charger.cpp File Reference

Devices/MPE/Charger.cpp File Reference

#include "PreComp.hpp"
#include <stack/driver.h>
#include "Charger.hpp"
#include <Devices/ChargerSignalMapTableNode.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for Charger.cpp:

Generated on Tue Jan 24 20:24:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Charger.hpp File Reference

Devices/MPE/Charger.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/ChargerInterface.hpp>

Include dependency graph for Charger.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Charger

Defines

#define | Apoxi_Devices_Mpe_Charger_hpp

Define Documentation

#define Apoxi_Devices_Mpe_Charger_hpp

Generated on Tue Jan 24 20:24:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Charger.hpp Source File

Devices/MPE/Charger.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Devices_Mpe_Charger_hpp)
00011 #define Apoxi_Devices_Mpe_Charger_hpp
00012
00013 #include <Devices/AbstractDevice.hpp>
00014
00016 class Charger: public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     #include <Devices/ChargerInterface.hpp>
00020
00021     protected:
00023         virtual void OnStart();
00024 };
00025
00026 #endif  // Apoxi_Devices_Mpe_Charger_hpp
00027
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/DefaultDisplay.cpp File Reference

Devices/MPE/DefaultDisplay.cpp File Reference

#include "PreComp.hpp"
#include "DefaultDisplay.hpp"
#include "VideoChannel.hpp"
#include <Gui/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DisplayMsgTypes.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <Gui/WindowManager.hpp>
#include <stack/driver.h>

Include dependency graph for DefaultDisplay.cpp:

Functions

void | ApoxiSendDisplayUpdateFinished (int, void *, ubyte shuge *)
void | ApoxiSendDisplayUpdateFinished_dummy (int, void *)

Function Documentation

void ApoxiSendDisplayUpdateFinished | ( | int | ,
 |  | void * | ,
 |  | ubyte shuge * |
 | ) |

void ApoxiSendDisplayUpdateFinished_dummy | ( | int | ,
 |  | void * |
 | ) |

Generated on Tue Jan 24 20:24:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/DefaultDisplay.hpp File Reference

Devices/MPE/DefaultDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Devices/Display.hpp>

Include dependency graph for DefaultDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultDisplay

Defines

#define | Apoxi_DefaultDisplay_hpp

Define Documentation

#define Apoxi_DefaultDisplay_hpp

Generated on Tue Jan 24 20:25:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/DefaultDisplay.hpp Source File

Devices/MPE/DefaultDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultDisplay_hpp)
00010 #define Apoxi_DefaultDisplay_hpp
00013
00014 class VideoChannel;
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/Os/SystemTimer.hpp>
00017 #include <Devices/Display.hpp>
00018
00023 class DefaultDisplay : public Display {
00024     typedef Display Base;
00025
00026     public:
00029         DefaultDisplay(INT index);
00030
00031         virtual ~DefaultDisplay();
00032
00034         virtual const WCHAR* GetName() const;
00035
00037         virtual void OnStart();
00038
00040         virtual void OnStop();
00041
00043         virtual void SetContrast(INT contrast);
00044
00046         virtual INT GetContrast() const;
00047
00049         virtual void SetBrightness(INT brightness);
00050
00052         virtual INT GetBrightness() const;
00053
00055         virtual void SetBacklightTimeout(UINT32 timeout);
00056
00058         virtual void SetPowerTimeout(UINT32 timeout);
00059
00061         virtual void ReactivateBacklight();
00062
00064         virtual void ReactivatePower();
00065
00067         virtual void SetBacklightMode(BacklightMode mode);
00068
00070         virtual BacklightMode GetBacklightMode() const;
00071
00073         virtual BOOLEAN IsBacklightOn() const;
00074
00076         virtual void SetPowerMode(PowerMode mode);
00077
00079         virtual PowerMode GetPowerMode() const;
00080
00082         virtual BOOLEAN IsPowerOn() const;
00083
00085         virtual void SetCustomFrameBufferRect(const Rect& rect);
00086
00088         virtual void Refresh();
00089
00098         virtual void Refresh(const CustomFrameBuffer* custom_frame_buf);
00099
00103         virtual VideoChannel* GetVideoChannel();
00104
00108         void OnTimer();
00109
00110         /*  S-Gold specific interface, which is not part of the common Display interface and hence may
00111             not be used by any APOXI or MMI interface. */
00112         static void SynchronizeBuffers();
00113
00115         virtual void SetCallbackActive(BOOLEAN state);
00116
00118         virtual BOOLEAN IsCallbackActive() const;
00119
00120     private:
00121         enum Status {
00122             DisplayOff,
00123             BacklightOff,
00124             BacklightOn
00125         };
00126
00127         struct {
00128             UINT backlight_mode         : 2;
00129             UINT power_mode             : 2;
00130             UINT status                 : 2;
00131             UINT power_on               : 1;
00132             UINT backlight_on           : 1;
00133             UINT timer_expired          : 1;
00134         } m_bits;
00135         VideoChannel* m_video_channel;
00136         SystemTimer* m_timer;
00137         UINT32 m_backlight_timeout;
00138         UINT32 m_power_timeout;
00139
00140         UINT8 m_contrast;
00141         UINT8 m_brightness;
00142
00143         volatile BOOLEAN m_cb_active;
00144         BOOLEAN m_skipped_buffer_synchronization;
00145         BOOLEAN m_use_custom_frame_buffer;
00146         BOOLEAN m_update_frame_buffer;
00147
00148         Semaphore m_sem;
00149         BOOLEAN m_gdd_transfer;
00150         Rect m_updated_blit_rect;
00151         Rect m_custom_frame_buf_rect;
00152         const Bitmap* m_custom_bmp;
00153         DDrvAtomPtr m_transfer_buffer;      // buffer which contains a copy of the main frame buffer
00154
00155         void SetBacklight(BOOLEAN backlight);
00156         void SetPower(BOOLEAN power);
00157
00158         static void CallbackFn(void* arg);
00159
00160         friend class VideoChannel;
00161 };
00162
00164 #endif  // Apoxi_DefaultDisplay_hpp
00165
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Fota.cpp File Reference

Devices/MPE/Fota.cpp File Reference

#include "PreComp.hpp"
#include "Fota.hpp"
#include <stack/driver.h>

Include dependency graph for Fota.cpp:

Generated on Tue Jan 24 20:25:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Fota.hpp File Reference

Devices/MPE/Fota.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/FotaInterface.hpp>

Include dependency graph for Fota.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Fota

Defines

#define | Apoxi_Devices_MPE_Fota_hpp

Define Documentation

#define Apoxi_Devices_MPE_Fota_hpp

Generated on Tue Jan 24 20:25:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Fota.hpp Source File

Devices/MPE/Fota.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_MPE_Fota_hpp)
00010 #define Apoxi_Devices_MPE_Fota_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class Fota : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/FotaInterface.hpp>
00018
00019     private:
00020 };
00021
00022 #endif  // Apoxi_Devices_MPE_Fota_hpp
00023
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Keyboard.cpp File Reference

Devices/MPE/Keyboard.cpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Config/KeyboardConfig.hpp>
#include <stack/driver.h>
#include "Keyboard.hpp"
#include <Devices/SharedMethods/KeyboardTimer.cpp>

Include dependency graph for Keyboard.cpp:

Generated on Tue Jan 24 20:25:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Keyboard.hpp File Reference

Devices/MPE/Keyboard.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/KeyboardInterface.hpp>

Include dependency graph for Keyboard.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Keyboard
Keyboard. More...
struct | Keyboard::BitStruct

Defines

#define | Apoxi_Devices_Mpe_Keyboard_hpp

Define Documentation

#define Apoxi_Devices_Mpe_Keyboard_hpp

Generated on Tue Jan 24 20:25:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Keyboard.hpp Source File

Devices/MPE/Keyboard.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Mpe_Keyboard_hpp)
00010 #define Apoxi_Devices_Mpe_Keyboard_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00015 class Keyboard : public AbstractDevice {
00016     typedef AbstractDevice Base;
00017
00018     #include <Devices/KeyboardInterface.hpp>
00019
00020     protected:
00021         virtual void OnStart();
00022
00023     private:
00024         struct BitStruct {
00025             UINT locked                 : 1;
00026             UINT multi_key_mode         : 1;
00027             UINT illumination_status    : 1;
00028             UINT illumination_mode      : 2;
00029         };
00030
00031         static BitStruct m_bits;
00032         static UINT32 m_illumination_timeout;
00033         static SystemTimer m_illumination_timer;
00034
00035         static void SetIllumination(BOOLEAN illumination);
00036         static void OnIlluminationTimer(void *arg);
00037 };
00038
00039 /*  ------------------------------------------------------------------------
00040     IsLocked
00041     ------------------------------------------------------------------------ */
00042 inline BOOLEAN Keyboard::IsLocked()
00043 {
00044     return m_bits.locked;
00045 }
00046
00047 /*  ------------------------------------------------------------------------
00048     IsMultiKeyMode
00049     ------------------------------------------------------------------------ */
00050 inline BOOLEAN Keyboard::IsMultiKeyMode()
00051 {
00052     return (BOOLEAN)m_bits.multi_key_mode;
00053 }
00054
00055 /*  ------------------------------------------------------------------------
00056     SetIlluminationTimeout
00057     ------------------------------------------------------------------------ */
00058 inline void Keyboard::SetIlluminationTimeout(UINT32 timeout)
00059 {
00060     m_illumination_timeout = timeout;
00061 }
00062
00063 /*  ------------------------------------------------------------------------
00064     GetIlluminationMode
00065     ------------------------------------------------------------------------ */
00066 inline Keyboard::IlluminationMode Keyboard::GetIlluminationMode()
00067 {
00068     return static_cast<IlluminationMode>(m_bits.illumination_mode);
00069 }
00070
00071 /*  ------------------------------------------------------------------------
00072     IsIlluminationOn
00073     ------------------------------------------------------------------------ */
00074 inline BOOLEAN Keyboard::IsIlluminationOn()
00075 {
00076     return (BOOLEAN)m_bits.illumination_status;
00077 }
00078
00079 #endif  // Apoxi_Devices_Mpe_Keyboard_hpp
00080
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Led.cpp File Reference

Devices/MPE/Led.cpp File Reference

#include "PreComp.hpp"
#include "Led.hpp"
#include <Devices/LedSignalMapTableNode.hpp>

Include dependency graph for Led.cpp:

Generated on Tue Jan 24 20:25:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Led.hpp File Reference

Devices/MPE/Led.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <stack/driver.h>
#include <Devices/LedInterface.hpp>

Include dependency graph for Led.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Led
Back light device. More...

Defines

#define | Apoxi_Devices_Mpe_Led_hpp

Define Documentation

#define Apoxi_Devices_Mpe_Led_hpp

Generated on Tue Jan 24 20:25:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Led.hpp Source File

Devices/MPE/Led.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Mpe_Led_hpp)
00010 #define Apoxi_Devices_Mpe_Led_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013 #include <stack/driver.h>
00014
00015 class Led : public AbstractDevice {
00016     typedef AbstractDevice Base;
00017
00018     public:
00019         #if !defined(APOXI_LED_NEW_INTERFACE)
00020             enum Event {
00021                 Call = led_call,                /* stored in eep  */
00022                 ReceivingCall = led_receiving_call,     /* stored in eep  */
00023                 CallUnanswered = led_call_unanswered,       /* stored in eep  */
00024                 Mail = led_mail,                /* stored in eep  */
00025                 Service = led_service,          /* stored in eep  */
00026                 NoService = led_no_service,         /* stored in eep  */
00027                 LimitedService = led_limited_service,
00028                 PowerOn = led_power_on,
00029                 PowerOff = led_power_off,
00030                 ReceivedCallConnected = led_received_call_connected,
00031                 SmsReceiving = led_sms_receiving,
00032                 SmsSending = led_sms_sending,
00033                 AlarmOngoing = led_alarm_ongoing,
00034                 AlarmStopped = led_alarm_stopped,
00035                 BatteryLow = led_battery_low,
00036                 ChargerDisconnected = led_charger_disconnected,
00037                 ChargerConnected = led_charger_connected,
00038                 ChargeComplete = led_charge_complete
00039             };
00040
00041             enum Color {
00042                 Blue = led_blue,
00043                 Red = led_red,
00044                 Green = led_green,
00045                 Magenta = led_blue_red,        /* magenta */
00046                 Cyan = led_blue_green,      /* cyan    */
00047                 Yellow = led_red_green,       /* yellow  */
00048                 White = led_red_blue_green,  /* white   */
00049                 NoOfColors = led_nof_colors,
00050                 InvalidColor,
00051             };
00052
00053
00054             enum Action {
00055                 On = LED_ON,
00056                 Off = LED_OFF,
00057                 Flash = LED_FLASH,
00058                 ColorStream = LED_COLORSTREAM,
00059             };
00060
00061             #if defined (USE_SMPOWER)
00062                 enum Intensity {
00063                     NoCurrent = led_no_current, /*   0 mA */
00064                     Minimum = led_20_ma,        /*  20 mA */
00065                     Low = led_40_ma,            /*  40 mA */
00066                     LessThanNormal = led_60_ma, /*  60 mA */
00067                     Normal = led_80_ma,         /*  80 mA */
00068                     MoreThanNormal = led_100_ma,/* 100 mA */
00069                     High = led_120_ma,          /* 120 mA */
00070                     Maximum = led_140_ma        /* 140 mA */
00071                 };
00072             #else
00073                 enum Intensity {
00074                     NoCurrent,
00075                     Minimum,
00076                     Low,
00077                     LessThanNormal,
00078                     Normal,
00079                     MoreThanNormal,
00080                     High,
00081                     Maximum,
00082                 };
00083             #endif
00084         #endif
00085
00086     #include <Devices/LedInterface.hpp>
00087
00088     protected:
00089         #if defined(APOXI_LED_NEW_INTERFACE)
00090             virtual void OnStart();
00091         #endif
00092
00093     private:
00094         static const INT c_max_colorstream_length;
00095 };
00096
00097 #endif  // Apoxi_Devices_Mpe_Led_hpp
00098
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/PreComp.cpp File Reference

Devices/MPE/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:04:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/PreComp.hpp File Reference

Devices/MPE/PreComp.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/System.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/PreComp.hpp Source File

Devices/MPE/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013 #include <Kernel/System.hpp>
00014
00015
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/RealTimeClock.cpp File Reference

Devices/MPE/RealTimeClock.cpp File Reference

#include "PreComp.hpp"
#include <Devices/RealTimeClock.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Devices/RtcSignalMapTableNode.hpp>
#include <Devices/RtcMsgTypes.hpp>
#include <stdio.h>
#include <stack/driver.h>
#include <stack/stack.h>

Include dependency graph for RealTimeClock.cpp:

Generated on Tue Jan 24 20:25:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/RealTimeClock.hpp File Reference

Devices/MPE/RealTimeClock.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/RealTimeClockInterface.hpp>

Include dependency graph for RealTimeClock.hpp:

Go to the source code of this file.

Data Structures

class | RealTimeClock

Defines

#define | Apoxi_Devices_Mpe_RealTimeClock_hpp

Define Documentation

#define Apoxi_Devices_Mpe_RealTimeClock_hpp

Generated on Tue Jan 24 20:25:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/RealTimeClock.hpp Source File

Devices/MPE/RealTimeClock.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Mpe_RealTimeClock_hpp)
00010 #define Apoxi_Devices_Mpe_RealTimeClock_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class RealTimeClock : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/RealTimeClockInterface.hpp>
00018
00019     protected:
00021         virtual void OnStart();
00022
00024         virtual void OnStop();
00025 };
00026
00027 #endif  // Apoxi_Devices_Mpe_RealTimeClock_hpp
00028
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/StillCamera.cpp File Reference

Devices/MPE/StillCamera.cpp File Reference

#include "PreComp.hpp"
#include "StillCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Afs/Rfs/FileDataSink.hpp>
#include <AddOns/AfsRam/RamDataSink.hpp>
#include <Afs/Rfs/FileBinData.hpp>

Include dependency graph for StillCamera.cpp:

Defines

#define | DEBUG_DEVICE_STILL_CAMERA (30610)
#define | DEBUG_STILL_CAMERA_CPP

Define Documentation

#define DEBUG_DEVICE_STILL_CAMERA (30610)

#define DEBUG_STILL_CAMERA_CPP

Generated on Tue Jan 24 20:26:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/StillCamera.hpp File Reference

Devices/MPE/StillCamera.hpp File Reference

#include <Auxiliary/DataSink.hpp>
#include <Devices/MPE/Camera.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Devices/StillCameraInterface.hpp>

Include dependency graph for StillCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StillCamera
struct | StillCamera::BufferInfoType

Defines

#define | Apoxi_StillCamera_hpp
#define | MAX_BUFFER_INFO_INDEX 20

Define Documentation

#define Apoxi_StillCamera_hpp

#define MAX_BUFFER_INFO_INDEX 20

Generated on Tue Jan 24 20:26:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/StillCamera.hpp Source File

Devices/MPE/StillCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_StillCamera_hpp)
00010 #define Apoxi_StillCamera_hpp
00013
00014 #include <Auxiliary/DataSink.hpp>
00015 #include <Devices/MPE/Camera.hpp>
00016 #include <AddOns/MultiMedia/JpegEncoder.hpp>
00017
00018 class RamData;
00019
00021 class StillCamera : public Camera {
00022
00023     typedef Camera Base;
00024
00025     public:
00026         #include <Devices/StillCameraInterface.hpp>
00027
00032         virtual BOOLEAN Open();
00033
00036         virtual BOOLEAN Close();
00037
00038
00039     protected:
00040         friend class CameraConfig;
00041
00042
00043     private:
00044
00045         #define MAX_BUFFER_INFO_INDEX  20
00046
00047         enum CaptureState {
00048             Init,
00049             StartRunning,
00050             GetCaptureBuffer,
00051             ImageCaptured,
00052             ImageEncodingBegin,
00053             ImageEncoded,
00054             ErrorGetCaptureBuffer,
00055             ErrorImageCaptured,
00056             ErrorImageEncoded
00057         };
00058
00059 /*      enum CallBackState {
00060             Nothing,
00061             CbGDDCaptureResult,
00062             CbJPEGImageEncoded
00063         };
00064 */
00065         typedef struct BufferInfoType {
00066             INT picture_number;
00067             CaptureState state;
00068 //          UINT32 length;
00069             UINT8 HUGE* capture_buffer;
00070             DataSink* data_sink;
00071             JpegEncoder* encoder;
00072         } BufferInfoType;
00073
00074
00075         BOOLEAN m_capture_in_use;
00076         INT m_jpeg_quality;
00077         INT m_picture_count;
00078
00079
00080         static CbImageCaptured m_cb_image_captured;
00081         static CbImageEncoded m_cb_image_encoded;
00082         static CbCaptureFinished m_cb_capture_finished;
00083
00084         static void* m_app_context;
00085         static BOOLEAN m_cancel_capture;
00086         static UINT32 m_pool_handle;
00087         static INT m_pool_index;
00088
00089         JpegEncoder::EncodingParameters* m_encoding_params;
00090         Image::MetaData m_meta_data;
00091
00092         BufferInfoType m_buffer_info[MAX_BUFFER_INFO_INDEX];
00093
00094         // callbacks
00095         // callback from GDD for still camera, where buffer for raw data will be passed to
00096         static void Cb_GDD_GetCaptureBuffer(void* context, UINT8 HUGE **buffer, UINT32 size);
00097
00098         // callback from GDD where an image has been captured as RAW data in to buffer
00099         static void Cb_GDD_ImageCaptured(INT result, void* context, UINT8 HUGE* captured_buffer, UINT32 size);
00100
00101         // callback from GDD for the asynchronous result
00102         static void Cb_GDD_CaptureResult(INT result, void* context);
00103
00104         // callback from JpegEncoder, when an RAW data image has been encoded to JPEG
00105         static void Cb_JPEG_ImageEncoded(INT result, void* context, DataSink& sink);
00106
00107         BOOLEAN         FreeImageBuffer();
00108         BOOLEAN         GetImageBuffer(UINT8 no_of_pictures, ImageSizeType size);
00109
00110         BOOLEAN         Encode(BufferInfoType* bufferInfoPtr,UINT32 length);
00111
00112
00113         BufferInfoType* GetUsedImageBuffer(UINT8 HUGE* captured_buffer);
00114         BufferInfoType* GetUsedImageBuffer(DataSink* sink);
00115         BufferInfoType* GetNextImageBuffer(DataSink* sink);
00116
00117         void ResetBufferInfo();
00118         INT GetEncodedPictureCount() const;
00119
00120 };
00121
00123 #endif  // Apoxi_StillCamera_hpp
00124
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VideoCamera.cpp File Reference

Devices/MPE/VideoCamera.cpp File Reference

#include "PreComp.hpp"
#include "VideoCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for VideoCamera.cpp:

Defines

#define | DEACTIVATE_SET_CAPTURE_IMAGE_FORMAT
#define | DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE (30620)
#define | DEBUG_VIDEOCAMERA_CPP
#define | TRACE1LN(x, n) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n))
#define | TRACE2LN(x, n, o) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o))
#define | TRACE3LN(x, n, o, p) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p))
#define | TRACE4LN(x, n, o, p, q) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p, q))
#define | TRACELN(x) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x))

Variables

const INT | c_bytes_per_pixel_of_rawdata = 2

Define Documentation

#define DEACTIVATE_SET_CAPTURE_IMAGE_FORMAT

#define DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE (30620)

#define DEBUG_VIDEOCAMERA_CPP

#define TRACE1LN | ( | x,
 |  | n | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n))

#define TRACE2LN | ( | x,
 |  | n,
 |  | o | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o))

#define TRACE3LN | ( | x,
 |  | n,
 |  | o,
 |  | p | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p))

#define TRACE4LN | ( | x,
 |  | n,
 |  | o,
 |  | p,
 |  | q | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p, q))

#define TRACELN ( x ) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x))

Variable Documentation

const INT c_bytes_per_pixel_of_rawdata = 2

Generated on Tue Jan 24 20:26:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VideoCamera.hpp File Reference

Devices/MPE/VideoCamera.hpp File Reference

#include <Kernel/System.hpp>
#include <Kernel/Types.hpp>
#include <Devices/MPE/Camera.hpp>
#include <Devices/VideoCameraInterface.hpp>

Include dependency graph for VideoCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoCamera

Defines

#define | Apoxi_VideoCamera_hpp

Define Documentation

#define Apoxi_VideoCamera_hpp

Generated on Tue Jan 24 20:27:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VideoCamera.hpp Source File

Devices/MPE/VideoCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VideoCamera_hpp)
00010 #define Apoxi_VideoCamera_hpp
00013
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/Types.hpp>
00016 #include <Devices/MPE/Camera.hpp>
00017
00019 class VideoCamera : public Camera {
00020     typedef Camera Base;
00021
00022     public:
00023         #include <Devices/VideoCameraInterface.hpp>
00024
00025     protected:
00026         friend class CameraConfig;
00027
00028     private:
00029
00031         static void GetCaptureBuffer_GDD_CB(void*, UINT8 HUGE ** buffer, UINT32 size);
00032
00034         static void VideoFrameCaptured_GDD_CB(int result, void* context, UINT8 HUGE * buffer, UINT32 buf_len_used);
00035
00037         static void NotifyCaptureBufferStatus_GDD_CB(void* context, UINT8 free_buffer_count);
00038
00040         FrameRateType m_framerate;
00041
00043         static UINT32 m_buffer_length;
00044
00046         static UINT32 m_starting_time;          // frame count or timestamp
00047
00049         static UINT32 m_pool_handle;
00050
00053         static void* m_context;
00054
00055         static Cb_NotifyCaptureBufferStatus m_cb_notify_status;
00056         static Cb_FrameCaptured m_cb_frame_captured;
00057         static Cb_VideoCaptureStopped m_cb_video_capture_stopped;
00058         static Cb_VideoCapturePaused m_cb_video_capture_paused;
00059 };
00060
00062 #endif  // Apoxi_VideoCamera_hpp
00063
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VideoChannel.cpp File Reference

Devices/MPE/VideoChannel.cpp File Reference

#include "PreComp.hpp"
#include "VideoChannel.hpp"
#include <stack/driver.h>

Include dependency graph for VideoChannel.cpp:

Generated on Tue Jan 24 20:27:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VideoChannel.hpp File Reference

Devices/MPE/VideoChannel.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for VideoChannel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoChannel
struct | VideoChannel::StateFlags

Defines

#define | Apoxi_Devices_MPE_VideoChannel_hpp

Define Documentation

#define Apoxi_Devices_MPE_VideoChannel_hpp

Generated on Tue Jan 24 20:28:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VideoChannel.hpp Source File

Devices/MPE/VideoChannel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_MPE_VideoChannel_hpp)
00010 #define Apoxi_Devices_MPE_VideoChannel_hpp
00011
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Rect.hpp>
00017
00026 class VideoChannel {
00027
00028     public:
00029
00030 #ifdef APOXI_COMPAT_2_8_0
00031
00034         enum VideoParameterType {
00036             Rotate,
00038             Mirror,
00040             Flip,
00042             Antitearing,
00044             SmartOverlays,
00046             YuvToRgbConversion,
00048             ZoomFactorHorizontalMin,
00050             ZoomFactorHorizontalMax,
00052             ZoomFactorVerticalMin,
00054             ZoomFactorVerticalMax
00055         };
00056 #endif // APOXI_COMPAT_2_8_0
00057
00059         enum TransformationType {
00060             NoTransformation,
00061             Rotation90Transformation,
00062             Rotation180Transformation,
00063             Rotation270Transformation,
00064             MirrorTransformation,
00065             MirrorRotate90Transformation,
00066             MirrorRotate180Transformation,  // same as flip
00067             MirrorRotate270Transformation
00068         };
00069
00070         enum ScalingMethodType {
00071             NoScaling,
00072             LetterboxScaling,
00073             BestFitScaling
00074         };
00075
00076         enum VideoAndViewfinderOrderType {
00077             ViewfinderOverVideoPlayback,
00078             VideoPlaybackOverViewfinder
00079         };
00080
00090         typedef void (*CbResult)(   BOOLEAN result,
00091                                     void* context);
00092
00093 #ifdef APOXI_COMPAT_2_8_0
00094
00105         typedef void (*CbVideoFrameRendered)(INT result,
00106                                             void* context,
00107                                             const UINT8 HUGE* frame_buf);
00108
00120         typedef void (*CbVideoFrameRenderedNew)(BOOLEAN result,
00121                                             void* context,
00122                                             const UINT8 HUGE* frame_buf);
00123 #else // APOXI_COMPAT_2_8_0
00124
00136         typedef void (*CbVideoFrameRendered)(BOOLEAN result,
00137                                             void* context,
00138                                             const UINT8 HUGE* frame_buf);
00139 #endif // APOXI_COMPAT_2_8_0
00140
00144         VideoChannel(INT display_idx = 0);
00145
00146         ~VideoChannel();
00147
00148 #ifdef APOXI_COMPAT_2_8_0
00149
00162         BOOLEAN Open(Rect& video_frame_rect, CbVideoFrameRendered cb_frame_rendered, void* context = 0);
00163
00175         BOOLEAN Open(CbVideoFrameRenderedNew cb_frame_rendered, void* context);
00176 #else // APOXI_COMPAT_2_8_0
00177
00189         BOOLEAN Open(CbVideoFrameRendered cb_frame_rendered, void* context);
00190 #endif // APOXI_COMPAT_2_8_0
00191
00193         void Close();
00194
00204         BOOLEAN Start(CbResult cb_video_channel_started, void* context);
00205
00215         BOOLEAN Stop(CbResult cb_video_channel_stopped, void* context);
00216
00227         void RenderFrame(void* frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame = FALSE);
00228
00232         BOOLEAN IsOpen() const;
00233
00236         UINT32 GetRefreshDelay() const;
00237
00238 #ifdef APOXI_COMPAT_2_8_0
00239
00244         BOOLEAN SetParam(VideoParameterType type, UINT32 value);
00245
00252         BOOLEAN GetParam(VideoParameterType type, UINT32* value) const;
00253 #endif // APOXI_COMPAT_2_8_0
00254
00255 #ifdef APOXI_COMPAT_2_6_0
00256
00264         void SetSize(Size video_size)
00265         {
00266         #ifdef APOXI_COMPAT_2_8_0
00267             SetVideoSize(video_size);
00268         #endif //  APOXI_COMPAT_2_8_0
00269         }
00270 #endif // APOXI_COMPAT_2_6_0
00271
00272 #ifdef APOXI_COMPAT_2_8_0
00273
00280         void SetVideoSize(Size video_size);
00281 #endif // APOXI_COMPAT_2_8_0
00282
00294         BOOLEAN SetVideoSize(   Size actual_video_size,
00295                                 Size extended_video_size,
00296                                 Point left_top_offset);
00297
00298 #ifdef APOXI_COMPAT_2_8_0
00299
00310         BOOLEAN SetCropRect(Rect& crop_rect);
00311 #endif // APOXI_COMPAT_2_8_0
00312
00326         BOOLEAN SetCropRect(Rect& crop_rect, Rect& effective_playback_rect);
00327
00328 #ifdef APOXI_COMPAT_2_6_0
00329
00336         BOOLEAN AdjustFrameRect(Rect& video_frame_rect)
00337         {
00338         #ifdef APOXI_COMPAT_2_8_0
00339             return SetFrameRect(video_frame_rect);
00340         #else
00341             return FALSE;
00342         #endif //  APOXI_COMPAT_2_8_0
00343         }
00344 #endif // APOXI_COMPAT_2_6_0
00345
00346 #ifdef APOXI_COMPAT_2_8_0
00347
00354         BOOLEAN SetFrameRect(Rect& video_frame_rect);
00355 #endif // APOXI_COMPAT_2_8_0
00356
00367         BOOLEAN SetPlaybackRect(Rect& playback_rect,
00368                                 TransformationType playback_transformation,
00369                                 ScalingMethodType scaling_method);
00370
00371 #ifdef APOXI_COMPAT_2_8_0
00372
00383         BOOLEAN QueryRects(Rect& video_frame_rect, Rect& crop_rect);
00384 #endif // APOXI_COMPAT_2_8_0
00385
00396         BOOLEAN SetPlaybackAndViewfinderOrder(
00397                             VideoAndViewfinderOrderType video_viewfinder_order);
00398
00399     private:
00400
00402         enum StateType {
00403             IdleState = 0,
00404             OpeningState,
00405             OpenState,
00406             StartingState,
00407             StartedState,
00408             StoppingState,
00409             ClosingState
00410         };
00411
00412         struct StateFlags {
00413             UINT m_state                        :3;
00414             UINT m_video_size_set               :1;
00415             UINT m_playback_rect_set            :1;
00416         };
00417
00418         static void CbNotifyVideoFrameRendered( INT result,
00419                                                 void *context,
00420                                                 UINT8 * frame_buf);
00421         static void CbNotifyStarted(INT result, void* context);
00422         static void CbNotifyStopped(INT result, void* context);
00423
00424 #ifdef APOXI_COMPAT_2_8_0
00425         CbVideoFrameRenderedNew m_cb_video_frame_rendered;
00426 #else // APOXI_COMPAT_2_8_0
00427         CbVideoFrameRendered m_cb_video_frame_rendered;
00428 #endif // APOXI_COMPAT_2_8_0
00429         CbResult                m_cb_stopped;
00430         CbResult                m_cb_started;
00431
00432         INT                 m_display_idx;
00433         StateFlags          m_flags;
00434
00435         TransformationType  m_transformation;
00436         ScalingMethodType   m_scaling_method;
00437         Rect                m_playback_rect;
00438         Rect                m_effective_playback_rect;
00439         Rect                m_crop_rect;
00440         Rect                m_actual_video_rect;
00441         Size                m_extended_video_size;
00442         void*               m_client_context_frame_rendered;
00443         void*               m_client_context_start;
00444         void*               m_client_context_stop;
00445
00451         BOOLEAN ConvertResultCode(INT result_code);
00452
00453         void ResetVideoChannel();
00454
00455 };
00456
00458 #endif  // Apoxi_Devices_MPE_VideoChannel_hpp
00459
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VirtualDisplay.cpp File Reference

Devices/MPE/VirtualDisplay.cpp File Reference

#include "PreComp.hpp"
#include "VirtualDisplay.hpp"
#include "../SharedMethods/Ddrv.cpp"
#include <Devices/DeviceManager.hpp>
#include "../SharedMethods/SetPixel_16Bpp.cpp"
#include "../SharedMethods/FillRect_16Bpp.cpp"
#include "../SharedMethods/BitBlit_16Bpp.cpp"
#include "../SharedMethods/ScrollHorizontal_16Bpp.cpp"
#include "../SharedMethods/ScrollVertical_16Bpp.cpp"
#include "../SharedMethods/DrawChar_16Bpp.cpp"
#include "../SharedMethods/ConvertToColorValue_Bpp.cpp"
#include "../SharedMethods/GetPixelColor_16Bpp.cpp"

Include dependency graph for VirtualDisplay.cpp:

Generated on Tue Jan 24 20:28:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VirtualDisplay.hpp File Reference

Devices/MPE/VirtualDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/Rect.hpp>
#include <Gui/ColorTable.hpp>
#include <Gui/Color.hpp>
#include <Gui/Font.hpp>
#include <Kernel/Os/SystemTimer.hpp>

Include dependency graph for VirtualDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ScanlineAccessor
class | VirtualDisplay

Defines

#define | Apoxi_VirtualDisplay_hpp

Define Documentation

#define Apoxi_VirtualDisplay_hpp

Generated on Tue Jan 24 20:28:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/VirtualDisplay.hpp Source File

Devices/MPE/VirtualDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_VirtualDisplay_hpp)
00010 #define Apoxi_VirtualDisplay_hpp
00013
00014 class VideoChannel;
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Devices/AbstractDevice.hpp>
00018 #include <Gui/Bitmap.hpp>
00019 #include <Gui/Rect.hpp>
00020 #include <Gui/ColorTable.hpp>
00021 #include <Gui/Color.hpp>
00022 #include <Gui/Font.hpp>
00023 #include <Kernel/Os/SystemTimer.hpp>
00024
00029 class VirtualDisplay : public AbstractDevice {
00030     typedef AbstractDevice Base;
00031
00032     public:
00034         enum Type {
00036             Monochrome,
00038             Planes2,
00040             Planes4,
00042             Planes8,
00044             BitsPerPixel8,
00046             BitsPerPixel16,
00048             BitsPerPixel24,
00050             BitsPerPixel32
00051         };
00052
00054         VirtualDisplay(INT index = 0);
00055
00068         VirtualDisplay(XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00069
00071         VirtualDisplay(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00072
00074         virtual ~VirtualDisplay();
00075
00088         void Init(XYDIM width, XYDIM height,  INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00089
00091         void Init(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00092
00094         virtual const WCHAR* GetName() const;
00095
00097         ControlArg Control(INT command, ControlArg arg);
00098
00100         XYDIM GetWidth() const { return m_bitmap.GetWidth();}
00101
00103         XYDIM GetHeight() const { return m_bitmap.GetHeight(); }
00104
00106         Bitmap* GetBitmap() { return &m_bitmap; }
00107
00109         Type GetType() { return m_type; }
00110
00114         void SetBlitRect(const Rect& rect = Rect()) { m_blit_rect = rect; }
00115
00117         const Rect& GetBlitRect() const { return m_blit_rect; };
00118
00121         void AdjustBlitRect(const Rect& rect) { m_blit_rect.Union(rect); }
00122
00125         virtual void Refresh();
00126
00129         void SetPixel(XYDIM x, XYDIM y);
00130
00133         void FillRect(const Rect& rect);
00134
00144             void BitBlit(XYDIM dest_x,
00145                      XYDIM dest_y,
00146                      const BitmapRes& bmp,
00147                      const Rect& clip_rect,
00148                      UINT8 trans_mode = 0);
00149
00154         void Scroll(const Rect& rect, XYDIM dx, XYDIM dy);
00155
00158         void DrawChar(XYDIM x, XYDIM y, const Glyph& glyph, INT height);
00159
00161         void SetColorValue(ColorValue color_value, UINT8 alpha = 255);
00162
00164         ColorValue GetColorValue() const { return m_color_value; }
00165
00167         void SetColor(Color color);
00168
00170         Color GetColor() const { return m_color; }
00171
00176         ColorValue ConvertToColorValue(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const;
00177
00179         Color GetPixelColor(XYDIM x, XYDIM y) const;
00180
00182         INT GetScanlineAtomCount() const { return m_scanline_atom_count; }
00183
00186         void SetAlphaBlendingMode(BOOLEAN mode) {
00187                                                     #ifdef APOXI_ENABLE_ALPHA_BLENDING
00188                                                         m_alpha_mode = mode;
00189                                                     #endif
00190                                                 }
00191
00193         BOOLEAN GetAlphaBlendingMode() const {
00194                                                 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00195                                                     return m_alpha_mode;
00196                                                 #else
00197                                                     return TRUE;
00198                                                 #endif
00199                                                 }
00200     private:
00201 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00202         BOOLEAN m_alpha_mode;
00203 #endif
00204         Bitmap m_bitmap;
00205         Rect m_blit_rect;
00206         Type m_type;
00207         ColorValue m_color_value;
00208         Color m_color;
00209         INT m_pixel_atom_count;
00210         INT m_scanline_atom_count;
00211         INT m_plane_count;
00212         INT m_scanline_inc;
00213         INT m_plane_inc;
00214         DDrvAtomPtr m_data;
00215         DDrvAtomPtr m_scanline_buffer;
00216
00217         void ScrollHorizontal(const Rect& rect, XYDIM dx);
00218         void ScrollVertical(const Rect& rect, XYDIM dy);
00219 };
00220
00223 class ScanlineAccessor {
00224     public:
00229         ScanlineAccessor(VirtualDisplay* display, XYDIM x, XYDIM y, XYDIM width) :
00230             m_data((UINT16 GDI_HUGE*)display->GetBitmap()->GetBits()),
00231             m_count(width)
00232         {
00233             m_data += (display->GetScanlineAtomCount() >> 1) * y + x;
00234         }
00235
00237         BOOLEAN HasNext() { return (m_count > 0); };
00238
00240         void Draw(UINT8 red, UINT8 green, UINT8 blue)
00241         {
00242             *m_data = ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)));
00243
00244             #if defined(APOXI_DISPLAY_FORMAT_BIG_ENDIAN)
00245                 *m_data = ((*m_data & 0xffU) << 8U) | ((*m_data & 0xff00U)) >> 8U;
00246             #endif
00247             m_data++;
00248             m_count--;
00249         }
00250
00251         void Draw(ColorValue cv)
00252         {
00253             *m_data = cv;
00254             m_data++;
00255             m_count--;
00256         }
00257
00261         void Next() {
00262             m_data++;
00263             m_count--;
00264         }
00265
00266     private:
00268         UINT16 GDI_HUGE* m_data;
00270         XYDIM m_count;
00271
00272 };
00273
00275 #endif  // Apoxi_VirtualDisplay_hpp
00276
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzAacDecoder.hpp"
#include "EmzAacDecoderThread.hpp"
#include <EmzCodecs/AacDecoder/AacCodec.h>

Include dependency graph for EmzAacDecoder.cpp:

Variables

const UINT8 | c_emz_codec_aac_dec_multi_frame_out_buf_max_count = 5
const UINT32 | c_emz_codec_aac_dec_multi_frame_out_buf_max_len = 20000
const UINT8 | c_emz_codec_aac_dec_multi_frame_out_buf_min_count = 2
const UINT8 | c_emz_codec_aac_dec_op_queue_max_count = 10
const UINT8 | c_emz_codec_aac_dec_single_frame_out_buf_max_count = 10
const UINT8 | c_emz_codec_aac_dec_single_frame_out_buf_min_count = 2

Variable Documentation

const UINT8 c_emz_codec_aac_dec_multi_frame_out_buf_max_count = 5

Maximum number of the audio decoder output buffers (for DecodeBuffer).

const UINT32 c_emz_codec_aac_dec_multi_frame_out_buf_max_len = 20000

Length (in bytes) of the audio decoder output buffer (for DecodeBuffer).

const UINT8 c_emz_codec_aac_dec_multi_frame_out_buf_min_count = 2

Minimum number of the audio decoder output buffers (for DecodeBuffer).

const UINT8 c_emz_codec_aac_dec_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_aac_dec_single_frame_out_buf_max_count = 10

Maximum number of the audio decoder output buffers (for DecodeFrame).

const UINT8 c_emz_codec_aac_dec_single_frame_out_buf_min_count = 2

Minimum number of the audio decoder output buffers (for DecodeFrame).

Generated on Tue Jan 24 20:29:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzAacDecoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzAacDecoder
class | EmzAacDecoder::OperationInfo
struct | EmzAacDecoder::StateFlags

Defines

#define | Apoxi_EmzAacDecoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_aac_dec_inst = 2

Define Documentation

#define Apoxi_EmzAacDecoder_hpp

Generated on Tue Jan 24 20:29:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_EmzAacDecoder_hpp)
00010 #define Apoxi_EmzAacDecoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/AudioDecoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzAacDecoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_aac_dec_inst = 2;
00023
00025 class EmzAacDecoder : public AudioDecoder {
00026
00027     typedef AudioDecoder Base;
00028
00029     public:
00030
00032         virtual ~EmzAacDecoder();
00033
00035         virtual CodecManager::ResultType GetCapabilities(
00036                                 CodecManager::AudioCodecCapabilities& caps);
00037
00039         virtual CodecManager::ResultType GetAudioStreamInfo(
00040                             const UINT8* config_stream,
00041                             UINT32& config_len,
00042                             const CodecManager::AudioDecoderParameters& params,
00043                             CodecManager::AudioStreamInfo& stream_info);
00044
00046         virtual CodecManager::ResultType AllocateOutputBuffers(
00047                                             UINT8 HUGE** &out_buf_array,
00048                                             UINT8& out_buf_count,
00049                                             UINT32& out_buf_len,
00050                                             DecodingFunctionType& dec_fct);
00051
00053         virtual CodecManager::ResultType RegisterCallbackFunctions(
00054                                         void* context,
00055                                         CbFrameDecoded cb_frame_decoded);
00056
00058         virtual CodecManager::ResultType DecodeFrame(
00059                                                     const UINT8 HUGE* in_buf,
00060                                                     UINT32 in_buf_len,
00061                                                     const UINT8 HUGE* out_buf,
00062                                                     UINT32 out_buf_len);
00064         virtual CodecManager::ResultType DecodeBuffer(
00065                                                     const UINT8 HUGE* in_buf,
00066                                                     UINT32 in_buf_len,
00067                                                     const UINT8 HUGE* out_buf,
00068                                                     UINT32 out_buf_len);
00069
00071         virtual CodecManager::ResultType SetParameters(
00072                                             const ParameterType* types_array,
00073                                             const UINT32* values_array,
00074                                             UINT8 array_count);
00075
00077         virtual CodecManager::ResultType GetParameters(
00078                                             const ParameterType* types_array,
00079                                             UINT32* values_array,
00080                                             UINT8 array_count);
00081
00083         virtual CodecManager::ResultType Flush();
00084
00086         virtual CodecManager::ResultType Reset();
00087
00088     private:
00089
00091         enum StateType {
00092             IdleState = 0,
00093             StartingState,
00094             StartedState,
00095             StoppingState
00096         };
00097
00098         struct StateFlags {
00099             UINT m_state                        :2;
00100             UINT m_out_buffers_allocated        :1;
00101             UINT m_callback_funcs_registered    :1;
00102             UINT m_stop_requested               :1;
00103             UINT m_decode_op_running            :1;
00104             UINT m_reset_requested              :1;
00105         };
00106
00107         class OperationInfo {
00108             public:
00109                 enum OperationType {
00110                     DecodeBufferOp,
00111                     DecodeFrameOp,
00112                 };
00113
00114                 OperationType m_op;
00115                 UINT8 HUGE* m_in_buf;
00116                 UINT32 m_in_buf_len;
00117                 UINT8 HUGE* m_out_buf;
00118                 UINT32 m_out_buf_len;
00119
00120                 OperationInfo();
00121
00122                 OperationInfo(  OperationType op,
00123                                         UINT8* in_buf,
00124                                         UINT32 in_buf_len,
00125                                         UINT8 HUGE* out_buf,
00126                                         UINT32 out_buf_len);
00127
00128                 OperationInfo(const OperationInfo& op_info);
00129
00130                 OperationInfo& operator=(const OperationInfo& op_info);
00131
00132                 virtual ~OperationInfo();
00133         }; // OperationInfo
00134
00137         CbFrameDecoded m_cb_frame_decoded;
00138
00141         static EmzAacDecoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_aac_dec_inst];
00144         void* m_client_context;
00146         UINT32 m_max_out_frame_len;
00148         UINT32 m_out_buf_len;
00152         UINT8 HUGE** m_out_buf_array;
00158         UINT8 m_out_buf_array_count;
00160         StateFlags m_flags;
00162         EmzUtils::Queue<OperationInfo> m_ops_queue;
00164         EmzAacDecoderThread* m_thread;
00165
00167         EmzAacDecoder();
00168
00170         virtual CodecManager::ResultType Start(
00171                             const UINT8* config_stream,
00172                             UINT32& config_len,
00173                             const CodecManager::AudioDecoderParameters& params,
00174                             CodecManager::AudioStreamInfo& stream_info);
00175
00177         virtual void Stop();
00178
00185         CodecManager::ResultType FreeOutputBuffers();
00186
00192         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00193
00196         void ReleaseDevice();
00197
00198     friend class EmzCodecsLib; // creates/destroys EmzAacDecoder
00199
00200     friend class EmzAacDecoderThread;
00201
00202 };
00203
00205 #endif // Apoxi_EmzAacDecoder_hpp
00206
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzAacDecoderThread.hpp"
#include <EmzCodecs/AacDecoder/AacCodec.h>

Include dependency graph for EmzAacDecoderThread.cpp:

Variables

const INT | c_emz_codec_aac_dec_thread_prio = 104
const UINT32 | c_emz_codec_aac_dec_thread_stacksize = 16384

Variable Documentation

const INT c_emz_codec_aac_dec_thread_prio = 104

Priority of the audio decoder thread.

const UINT32 c_emz_codec_aac_dec_thread_stacksize = 16384

Size (in bytes) of the thread's stack (shall be multiple of 4).

Generated on Tue Jan 24 20:29:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmzAacDecoder.hpp"

Include dependency graph for EmzAacDecoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzAacDecoderThread

Defines

#define | EmzAacDecoderThread_hpp

Define Documentation

#define EmzAacDecoderThread_hpp

Generated on Tue Jan 24 20:30:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzAacDecoderThread_hpp)
00010 #define EmzAacDecoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/AudioDecoder.hpp>
00018 #include "EmzAacDecoder.hpp"
00019
00020 #ifndef APOXI_EMZ_AAC_PLUS_V2_DEC_ENABLED
00021 #define APOXI_EMZ_AAC_PLUS_V2_DEC_ENABLED
00022 #endif //APOXI_EMZ_AAC_PLUS_V2_DEC_ENABLED
00023
00025 class EmzAacDecoderThread : public Thread {
00026
00027     typedef Thread Base;
00028
00029     public:
00030
00032         virtual INT ThreadFn();
00033
00034     private:
00035
00037         int m_exited;
00039         Semaphore m_thread_sem;
00041         Semaphore m_stop_sem;
00043         EmzAacDecoder* m_device;
00045         void* m_base;
00047         void* m_frame_info;
00049         void* m_stack;
00050
00052         EmzAacDecoderThread();
00053
00055         virtual ~EmzAacDecoderThread();
00056
00085         CodecManager::ResultType Start( const UINT8* config_stream,
00086                                         UINT32& config_len,
00087                                         const CodecManager::AudioDecoderParameters& params,
00088                                         CodecManager::AudioStreamInfo& stream_info,
00089                                         EmzAacDecoder* parent);
00090
00096         void Stop();
00097
00103         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00104
00108         void DecodeBufferSynchronously(EmzAacDecoder::OperationInfo& op);
00109
00111         void Reset();
00112
00113     friend class EmzAacDecoder; // creates/destroys EmzAacDecoderThread
00114
00115 };
00116
00118 #endif // EmzAacDecoderThread_hpp
00119
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzCodecsLib.hpp"
#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include "EmzMpeg4Encoder.hpp"
#include "EmzMpeg4Decoder.hpp"
#include "EmzH264Decoder.hpp"
#include "EmzAacDecoder.hpp"
#include "EmzMp3Decoder.hpp"
#include "EmzSbcEncoder.hpp"
#include <EmzCodecs/Mpeg4SpDecoder/exp_emz_common.h>

Include dependency graph for EmzCodecsLib.cpp:

Functions

void | emz_free (void *p)
void * | emz_malloc (tEmzInt32 size)
void * | emz_realloc (void *oldaddress, tEmzInt32 newsize)

Function Documentation

void emz_free ( void * p )

void* emz_malloc ( tEmzInt32 size )

void* emz_realloc | ( | void * | oldaddress,
 |  | tEmzInt32 | newsize
 | ) |

Generated on Tue Jan 24 20:30:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzCodecsLib

Defines

#define | EmzCodecsLib_hpp

Define Documentation

#define EmzCodecsLib_hpp

Generated on Tue Jan 24 20:30:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzCodecsLib_hpp)
00010 #define EmzCodecsLib_hpp
00013
00014
00015 class EmzCodecsLib {
00016     private:
00017
00020         static void LoadLib();
00021
00022     friend class CodecConfig; // loads this library
00023
00024 };
00025
00027 #endif // EmzCodecsLib_hpp
00028
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzCodecsPreComp.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzCodecsPreComp.cpp File Reference

#include "EmzCodecsPreComp.hpp"

Include dependency graph for EmzCodecsPreComp.cpp:

Generated on Tue Jan 24 20:30:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzCodecsPreComp.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzCodecsPreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for EmzCodecsPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:30:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzCodecsPreComp.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzCodecsPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Kernel/Types.hpp>
00011 #include <Kernel/Os/Os.hpp>
00012
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzH264Decoder.hpp"
#include "EmzH264DecoderThread.hpp"

Include dependency graph for EmzH264Decoder.cpp:

Variables

const UINT8 | c_emz_codec_h264_dec_op_queue_max_count = 10
const UINT8 | c_emz_codec_h264_dec_out_buf_max_count = 2
const UINT8 | c_emz_codec_h264_dec_out_buf_min_count = 1

Variable Documentation

const UINT8 c_emz_codec_h264_dec_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_h264_dec_out_buf_max_count = 2

Maximum number of the video decoder output buffers.

const UINT8 c_emz_codec_h264_dec_out_buf_min_count = 1

Minimum number of the video decoder output buffers.

Generated on Tue Jan 24 20:30:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzH264Decoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzH264Decoder
class | EmzH264Decoder::OperationInfo
struct | EmzH264Decoder::StateFlags

Defines

#define | EmzH264Decoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_h264_dec_inst = 3

Define Documentation

#define EmzH264Decoder_hpp

Generated on Tue Jan 24 20:30:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzH264Decoder_hpp)
00010 #define EmzH264Decoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoDecoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzH264DecoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_h264_dec_inst = 3;
00023
00025 class EmzH264Decoder : public VideoDecoder {
00026
00027     typedef VideoDecoder Base;
00028
00029     public:
00030
00032         virtual ~EmzH264Decoder();
00033
00035         virtual CodecManager::ResultType GetCapabilities(CodecManager::VideoCodecCapabilities& caps);
00036
00038         virtual CodecManager::ResultType AllocateOutputBuffers( UINT8& out_buf_count,
00039                                                                 UINT32& out_buf_len);
00041         virtual CodecManager::ResultType GetNumberOfInitialDecodeOperations(UINT8& operations);
00042
00044         virtual CodecManager::ResultType RegisterCallbackFunctions( void* context,
00045                                                                     CbFrameDecoded cb_frame_decoded,
00046                                                                     CbInBufferFree cb_in_buf_free);
00047
00049         virtual CodecManager::ResultType DecodeFrame(   const UINT8 HUGE* in_buf,
00050                                                         UINT32 in_buf_len,
00051                                                         UINT16 flags);
00052
00054         virtual CodecManager::ResultType DecodePacket(  const UINT8 HUGE* in_buf,
00055                                                         UINT32 in_buf_len,
00056                                                         UINT16 flags);
00057
00059         virtual CodecManager::ResultType ReleaseOutputBuffer(const UINT8 HUGE* out_buf);
00060
00062         virtual CodecManager::ResultType NotifyOutputBufferReleased(const UINT8 HUGE* out_buf);
00063
00065         virtual CodecManager::ResultType Flush();
00066
00068         virtual CodecManager::ResultType Reset();
00069
00071         virtual CodecManager::ResultType SetParameters( const ParameterType* types_array,
00072                                                         const UINT32* values_array,
00073                                                         UINT8 array_count);
00074
00076         virtual CodecManager::ResultType GetParameters( const ParameterType* types_array,
00077                                                         UINT32* values_array,
00078                                                         UINT8 array_count);
00079
00080     private:
00081
00083         enum StateType {
00084             IdleState = 0,
00085             StartingState,
00086             StartedState,
00087             StoppingState
00088         };
00089
00090         struct StateFlags {
00091             UINT m_state                        :2;
00092             UINT m_out_buffers_allocated        :1;
00093             UINT m_callback_funcs_registered    :1;
00094             UINT m_stop_requested               :1;
00095             UINT m_decode_op_running            :1;
00096             UINT m_reset_requested              :1;
00097         };
00098
00099         class OperationInfo {
00100             public:
00101                 enum OperationType {
00102                     DecodeFrameOp,
00103                     DecodePacketOp,
00104                     SetParametersOp
00105                 };
00106
00107                 OperationType m_op;
00108                 UINT8* m_in_buf;
00109                 UINT32 m_in_buf_len;
00110                 UINT16 m_flags;
00111
00112                 OperationInfo();
00113
00114                 OperationInfo(  OperationType op,
00115                                         UINT8* in_buf,
00116                                         UINT32 in_buf_len,
00117                                         UINT16 flags);
00118
00119                 OperationInfo(const OperationInfo& op_info);
00120
00121                 OperationInfo& operator=(const OperationInfo& op_info);
00122
00123                 virtual ~OperationInfo();
00124         }; // OperationInfo
00125
00128         CbFrameDecoded m_cb_frame_decoded;
00131         CbInBufferFree m_cb_in_buf_free;
00132
00135         static EmzH264Decoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_h264_dec_inst];
00138         void* m_client_context;
00142         UINT8 HUGE** m_out_buf_array;
00148         UINT8 m_out_buf_max_count;
00151         UINT8 m_out_buf_cur_used_count;
00153         StateFlags m_flags;
00155         EmzUtils::Queue<OperationInfo> m_ops_queue;
00157         EmzH264DecoderThread* m_thread;
00160         ParameterType* m_types_arr;
00163         UINT32* m_values_arr;
00164
00166         EmzH264Decoder();
00167
00169         virtual CodecManager::ResultType Start( const UINT8* config_stream,
00170                                                 UINT32& config_len,
00171                                                 const CodecManager::VideoDecoderParameters& params,
00172                                                 CodecManager::VideoStreamInfo& stream_info);
00173
00175         virtual void Stop();
00176
00180         void ReleaseDevice();
00181
00182     friend class EmzCodecsLib; // creates/destroys EmzH264Decoder
00183
00184     friend class EmzH264DecoderThread;
00185
00186 };
00187
00189 #endif // EmzH264Decoder_hpp
00190
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzH264DecoderThread.hpp"

Include dependency graph for EmzH264DecoderThread.cpp:

Variables

const INT | c_emz_codec_h264_dec_thread_prio = 104
const UINT32 | c_emz_codec_h264_dec_thread_stacksize = 16384

Variable Documentation

const INT c_emz_codec_h264_dec_thread_prio = 104

Priority of the video decoder thread.

const UINT32 c_emz_codec_h264_dec_thread_stacksize = 16384

Size (in bytes) of the thread's stack (shall be multiple of 4).

Generated on Tue Jan 24 20:30:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>
#include "EmzH264Decoder.hpp"
#include <EmzCodecs/H264Decoder/exp_h264_smp_decoder.h>

Include dependency graph for EmzH264DecoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzH264DecoderThread

Defines

#define | EmzH264DecoderThread_hpp

Define Documentation

#define EmzH264DecoderThread_hpp

Generated on Tue Jan 24 20:30:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzH264DecoderThread_hpp)
00010 #define EmzH264DecoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/VideoDecoder.hpp>
00018 #include "EmzH264Decoder.hpp"
00019
00020 extern "C"{
00021 #include <EmzCodecs/H264Decoder/exp_h264_smp_decoder.h>
00022 }
00023
00026 class EmzH264DecoderThread : public Thread {
00027
00028     typedef Thread Base;
00029
00030     public:
00031
00033         virtual INT ThreadFn();
00034
00035     private:
00036
00038         int m_exited;
00040         Semaphore m_thread_sem;
00042         Semaphore m_stop_sem;
00044         EmzH264Decoder* m_device;
00047         tBaseVideoDecoder* m_base;
00049         void* m_stack;
00050
00052         EmzH264DecoderThread();
00053
00055         virtual ~EmzH264DecoderThread();
00056
00088         CodecManager::ResultType Start( const UINT8* config_stream,
00089                                         UINT32& config_len,
00090                                         const CodecManager::VideoDecoderParameters& params,
00091                                         CodecManager::VideoStreamInfo& stream_info,
00092                                         EmzH264Decoder* parent);
00093
00099         void Stop();
00100
00118         CodecManager::ResultType SetParameters( const VideoDecoder::ParameterType* types_array,
00119                                                 const UINT32* values_array,
00120                                                 UINT8 array_count);
00121
00142         CodecManager::ResultType GetParameters( const VideoDecoder::ParameterType* types_array,
00143                                                 UINT32* values_array,
00144                                                 UINT8 array_count);
00145
00151         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00152
00153
00157         void DecodeFrameSynchronously(EmzH264Decoder::OperationInfo& op);
00158
00162         void DecodePacketSynchronously(EmzH264Decoder::OperationInfo& op);
00163
00165         void Reset();
00166
00167     friend class EmzH264Decoder; // creates/destroys EmzH264DecoderThread
00168
00169 };
00170
00172 #endif // EmzH264DecoderThread_hpp
00173
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzMp3Decoder.hpp"
#include "EmzMp3DecoderThread.hpp"

Include dependency graph for EmzMp3Decoder.cpp:

Variables

const UINT8 | c_emz_codec_mp3_dec_multi_frame_out_buf_max_count = 5
const UINT32 | c_emz_codec_mp3_dec_multi_frame_out_buf_max_len = 20000
const UINT8 | c_emz_codec_mp3_dec_multi_frame_out_buf_min_count = 2
const UINT8 | c_emz_codec_mp3_dec_op_queue_max_count = 10
const UINT8 | c_emz_codec_mp3_dec_single_frame_out_buf_max_count = 10
const UINT8 | c_emz_codec_mp3_dec_single_frame_out_buf_min_count = 2

Variable Documentation

const UINT8 c_emz_codec_mp3_dec_multi_frame_out_buf_max_count = 5

Maximum number of the audio decoder output buffers (for DecodeBuffer).

const UINT32 c_emz_codec_mp3_dec_multi_frame_out_buf_max_len = 20000

Length (in bytes) of the audio decoder output buffer (for DecodeBuffer).

const UINT8 c_emz_codec_mp3_dec_multi_frame_out_buf_min_count = 2

Minimum number of the audio decoder output buffers (for DecodeBuffer).

const UINT8 c_emz_codec_mp3_dec_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_mp3_dec_single_frame_out_buf_max_count = 10

Maximum number of the audio decoder output buffers (for DecodeFrame).

const UINT8 c_emz_codec_mp3_dec_single_frame_out_buf_min_count = 2

Minimum number of the audio decoder output buffers (for DecodeFrame).

Generated on Tue Jan 24 20:30:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzMp3Decoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMp3Decoder
class | EmzMp3Decoder::OperationInfo
struct | EmzMp3Decoder::StateFlags

Defines

#define | Apoxi_EmzMp3Decoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_mp3_dec_inst = 2

Define Documentation

#define Apoxi_EmzMp3Decoder_hpp

Generated on Tue Jan 24 20:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_EmzMp3Decoder_hpp)
00010 #define Apoxi_EmzMp3Decoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/AudioDecoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzMp3DecoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_mp3_dec_inst = 2;
00023
00025 class EmzMp3Decoder : public AudioDecoder {
00026
00027     typedef AudioDecoder Base;
00028
00029     public:
00030
00032         virtual ~EmzMp3Decoder();
00033
00035         virtual CodecManager::ResultType GetCapabilities(
00036                                 CodecManager::AudioCodecCapabilities& caps);
00037
00039         virtual CodecManager::ResultType GetAudioStreamInfo(
00040                             const UINT8* config_stream,
00041                             UINT32& config_len,
00042                             const CodecManager::AudioDecoderParameters& params,
00043                             CodecManager::AudioStreamInfo& stream_info);
00044
00046         virtual CodecManager::ResultType AllocateOutputBuffers(
00047                                             UINT8 HUGE** &out_buf_array,
00048                                             UINT8& out_buf_count,
00049                                             UINT32& out_buf_len,
00050                                             DecodingFunctionType& dec_fct);
00051
00053         virtual CodecManager::ResultType RegisterCallbackFunctions(
00054                                         void* context,
00055                                         CbFrameDecoded cb_frame_decoded);
00056
00058         virtual CodecManager::ResultType DecodeFrame(
00059                                                     const UINT8 HUGE* in_buf,
00060                                                     UINT32 in_buf_len,
00061                                                     const UINT8 HUGE* out_buf,
00062                                                     UINT32 out_buf_len);
00064         virtual CodecManager::ResultType DecodeBuffer(
00065                                                     const UINT8 HUGE* in_buf,
00066                                                     UINT32 in_buf_len,
00067                                                     const UINT8 HUGE* out_buf,
00068                                                     UINT32 out_buf_len);
00069
00071         virtual CodecManager::ResultType SetParameters(
00072                                             const ParameterType* types_array,
00073                                             const UINT32* values_array,
00074                                             UINT8 array_count);
00075
00077         virtual CodecManager::ResultType GetParameters(
00078                                             const ParameterType* types_array,
00079                                             UINT32* values_array,
00080                                             UINT8 array_count);
00081
00083         virtual CodecManager::ResultType Flush();
00084
00086         virtual CodecManager::ResultType Reset();
00087
00088     private:
00089
00091         enum StateType {
00092             IdleState = 0,
00093             StartingState,
00094             StartedState,
00095             StoppingState
00096         };
00097
00098         struct StateFlags {
00099             UINT m_state                        :2;
00100             UINT m_out_buffers_allocated        :1;
00101             UINT m_callback_funcs_registered    :1;
00102             UINT m_stop_requested               :1;
00103             UINT m_decode_op_running            :1;
00104             UINT m_reset_requested              :1;
00105         };
00106
00107         class OperationInfo {
00108             public:
00109                 enum OperationType {
00110                     DecodeBufferOp,
00111                     DecodeFrameOp
00112                 };
00113
00114                 OperationType m_op;
00115                 UINT8 HUGE* m_in_buf;
00116                 UINT32 m_in_buf_len;
00117                 UINT8 HUGE* m_out_buf;
00118                 UINT32 m_out_buf_len;
00119
00120                 OperationInfo();
00121
00122                 OperationInfo(  OperationType op,
00123                                         UINT8* in_buf,
00124                                         UINT32 in_buf_len,
00125                                         UINT8 HUGE* out_buf,
00126                                         UINT32 out_buf_len);
00127
00128                 OperationInfo(const OperationInfo& op_info);
00129
00130                 OperationInfo& operator=(const OperationInfo& op_info);
00131
00132                 virtual ~OperationInfo();
00133         }; // OperationInfo
00134
00137         CbFrameDecoded m_cb_frame_decoded;
00138
00141         static EmzMp3Decoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_mp3_dec_inst];
00144         void* m_client_context;
00146         UINT32 m_max_out_frame_len;
00148         UINT32 m_out_buf_len;
00152         UINT8 HUGE** m_out_buf_array;
00158         UINT8 m_out_buf_array_count;
00160         StateFlags m_flags;
00162         EmzUtils::Queue<OperationInfo> m_ops_queue;
00164         EmzMp3DecoderThread* m_thread;
00165
00167         EmzMp3Decoder();
00168
00170         virtual CodecManager::ResultType Start(
00171                             const UINT8* config_stream,
00172                             UINT32& config_len,
00173                             const CodecManager::AudioDecoderParameters& params,
00174                             CodecManager::AudioStreamInfo& stream_info);
00175
00177         virtual void Stop();
00178
00185         virtual CodecManager::ResultType FreeOutputBuffers();
00186
00189         void ReleaseDevice();
00190
00191     friend class EmzCodecsLib; // creates/destroys EmzMp3Decoder
00192
00193     friend class EmzMp3DecoderThread;
00194
00195 };
00196
00198 #endif // Apoxi_EmzMp3Decoder_hpp
00199
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzMp3DecoderThread.hpp"
#include <EmzCodecs/Mp3Decoder/exp_emz_common.h>
#include <EmzCodecs/Mp3Decoder/export_mp3_decoder.h>

Include dependency graph for EmzMp3DecoderThread.cpp:

Variables

const INT | c_emz_codec_mp3_dec_thread_prio = 104
const UINT32 | c_emz_codec_mp3_dec_thread_stacksize = 16384

Variable Documentation

const INT c_emz_codec_mp3_dec_thread_prio = 104

Priority of the audio decoder thread.

const UINT32 c_emz_codec_mp3_dec_thread_stacksize = 16384

Size (in bytes) of the thread's stack (shall be multiple of 4).

Generated on Tue Jan 24 20:30:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmzMp3Decoder.hpp"

Include dependency graph for EmzMp3DecoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMp3DecoderThread

Defines

#define | EmzMp3DecoderThread_hpp

Define Documentation

#define EmzMp3DecoderThread_hpp

Generated on Tue Jan 24 20:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMp3DecoderThread_hpp)
00010 #define EmzMp3DecoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/AudioDecoder.hpp>
00018 #include "EmzMp3Decoder.hpp"
00019
00021 class EmzMp3DecoderThread : public Thread {
00022
00023     typedef Thread Base;
00024
00025     public:
00026
00028         virtual INT ThreadFn();
00029
00030     private:
00031
00033         int m_exited;
00035         Semaphore m_thread_sem;
00037         Semaphore m_stop_sem;
00039         EmzMp3Decoder* m_device;
00041         void* m_base;
00043         void* m_stack;
00044
00046         EmzMp3DecoderThread();
00047
00049         virtual ~EmzMp3DecoderThread();
00050
00079         CodecManager::ResultType Start( const UINT8* config_stream,
00080                                         UINT32& config_len,
00081                                         const CodecManager::AudioDecoderParameters& params,
00082                                         CodecManager::AudioStreamInfo& stream_info,
00083                                         EmzMp3Decoder* parent);
00084
00090         void Stop();
00091
00097         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00098
00102         void DecodeBufferSynchronously(EmzMp3Decoder::OperationInfo& op);
00103
00105         void Reset();
00106
00107     friend class EmzMp3Decoder; // creates/destroys EmzMp3DecoderThread
00108
00109 };
00110
00112 #endif // EmzMp3DecoderThread_hpp
00113
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzMpeg4Decoder.hpp"
#include "EmzMpeg4DecoderThread.hpp"

Include dependency graph for EmzMpeg4Decoder.cpp:

Variables

const UINT8 | c_emz_codec_mpeg4_dec_op_queue_max_count = 10
const UINT8 | c_emz_codec_mpeg4_dec_out_buf_max_count = 2
const UINT8 | c_emz_codec_mpeg4_dec_out_buf_min_count = 1

Variable Documentation

const UINT8 c_emz_codec_mpeg4_dec_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_mpeg4_dec_out_buf_max_count = 2

Maximum number of the video decoder output buffers.

const UINT8 c_emz_codec_mpeg4_dec_out_buf_min_count = 1

Minimum number of the video decoder output buffers.

Generated on Tue Jan 24 20:30:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzMpeg4Decoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMpeg4Decoder
class | EmzMpeg4Decoder::OperationInfo
struct | EmzMpeg4Decoder::StateFlags

Defines

#define | EmzMpeg4Decoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_mpeg4_dec_inst = 3

Define Documentation

#define EmzMpeg4Decoder_hpp

Generated on Tue Jan 24 20:30:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMpeg4Decoder_hpp)
00010 #define EmzMpeg4Decoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoDecoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzMpeg4DecoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_mpeg4_dec_inst = 3;
00023
00025 class EmzMpeg4Decoder : public VideoDecoder {
00026
00027     typedef VideoDecoder Base;
00028
00029     public:
00030
00032         virtual ~EmzMpeg4Decoder();
00033
00035         virtual CodecManager::ResultType GetCapabilities(CodecManager::VideoCodecCapabilities& caps);
00036
00038         virtual CodecManager::ResultType AllocateOutputBuffers( UINT8& out_buf_count,
00039                                                                 UINT32& out_buf_len);
00041         virtual CodecManager::ResultType GetNumberOfInitialDecodeOperations(UINT8& operations);
00042
00044         virtual CodecManager::ResultType RegisterCallbackFunctions( void* context,
00045                                                                     CbFrameDecoded cb_frame_decoded,
00046                                                                     CbInBufferFree cb_in_buf_free);
00047
00049         virtual CodecManager::ResultType DecodeFrame(   const UINT8 HUGE* in_buf,
00050                                                         UINT32 in_buf_len,
00051                                                         UINT16 flags);
00052
00054         virtual CodecManager::ResultType DecodePacket(  const UINT8 HUGE* in_buf,
00055                                                         UINT32 in_buf_len,
00056                                                         UINT16 flags);
00057
00059         virtual CodecManager::ResultType ReleaseOutputBuffer(const UINT8 HUGE* out_buf);
00060
00062         virtual CodecManager::ResultType NotifyOutputBufferReleased(const UINT8 HUGE* out_buf);
00063
00065         virtual CodecManager::ResultType Flush();
00066
00068         virtual CodecManager::ResultType Reset();
00069
00071         virtual CodecManager::ResultType SetParameters( const ParameterType* types_array,
00072                                                         const UINT32* values_array,
00073                                                         UINT8 array_count);
00074
00076         virtual CodecManager::ResultType GetParameters( const ParameterType* types_array,
00077                                                         UINT32* values_array,
00078                                                         UINT8 array_count);
00079
00080     private:
00081
00083         enum StateType {
00084             IdleState = 0,
00085             StartingState,
00086             StartedState,
00087             StoppingState
00088         };
00089
00090         struct StateFlags {
00091             UINT m_state                        :2;
00092             UINT m_out_buffers_allocated        :1;
00093             UINT m_callback_funcs_registered    :1;
00094             UINT m_stop_requested               :1;
00095             UINT m_decode_op_running            :1;
00096             UINT m_reset_requested              :1;
00097         };
00098
00099         class OperationInfo {
00100             public:
00101                 enum OperationType {
00102                     DecodeFrameOp,
00103                     DecodePacketOp,
00104                     SetParametersOp
00105                 };
00106
00107                 OperationType m_op;
00108                 UINT8* m_in_buf;
00109                 UINT32 m_in_buf_len;
00110                 UINT16 m_flags;
00111
00112                 OperationInfo();
00113
00114                 OperationInfo(  OperationType op,
00115                                 UINT8* in_buf,
00116                                 UINT32 in_buf_len,
00117                                 UINT16 flags);
00118
00119                 OperationInfo(const OperationInfo& op_info);
00120
00121                 OperationInfo& operator=(const OperationInfo& op_info);
00122
00123                 virtual ~OperationInfo();
00124         }; // OperationInfo
00125
00128         CbFrameDecoded m_cb_frame_decoded;
00131         CbInBufferFree m_cb_in_buf_free;
00132
00135         static EmzMpeg4Decoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_mpeg4_dec_inst];
00138         void* m_client_context;
00142         UINT8 HUGE** m_out_buf_array;
00148         UINT8 m_out_buf_max_count;
00151         UINT8 m_out_buf_cur_used_count;
00153         StateFlags m_flags;
00155         EmzUtils::Queue<OperationInfo> m_ops_queue;
00157         EmzMpeg4DecoderThread* m_thread;
00160         ParameterType* m_types_arr;
00163         UINT32* m_values_arr;
00164
00166         EmzMpeg4Decoder();
00167
00169         virtual CodecManager::ResultType Start( const UINT8* config_stream,
00170                                                 UINT32& config_len,
00171                                                 const CodecManager::VideoDecoderParameters& params,
00172                                                 CodecManager::VideoStreamInfo& stream_info);
00173
00175         virtual void Stop();
00176
00180         void ReleaseDevice();
00181
00182     friend class EmzCodecsLib; // creates/destroys EmzMpeg4Decoder
00183
00184     friend class EmzMpeg4DecoderThread;
00185
00186 };
00187
00189 #endif // EmzMpeg4Decoder_hpp
00190
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzMpeg4DecoderThread.hpp"

Include dependency graph for EmzMpeg4DecoderThread.cpp:

Variables

const INT | c_emz_codec_mpeg4_dec_thread_prio = 104
const UINT32 | c_emz_codec_mpeg4_dec_thread_stacksize = 16384

Variable Documentation

const INT c_emz_codec_mpeg4_dec_thread_prio = 104

Priority of the video decoder thread.

const UINT32 c_emz_codec_mpeg4_dec_thread_stacksize = 16384

Size (in bytes) of the thread's stack (shall be multiple of 4).

Generated on Tue Jan 24 20:30:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>
#include "EmzMpeg4Decoder.hpp"
#include <EmzCodecs/Mpeg4SpDecoder/exp_MP4SP_VD.h>
#include <EmzCodecs/Mpeg4SpDecoder/exp_H263_VD.h>

Include dependency graph for EmzMpeg4DecoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMpeg4DecoderThread

Defines

#define | EmzMpeg4DecoderThread_hpp

Define Documentation

#define EmzMpeg4DecoderThread_hpp

Generated on Tue Jan 24 20:30:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMpeg4DecoderThread_hpp)
00010 #define EmzMpeg4DecoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/VideoDecoder.hpp>
00018 #include "EmzMpeg4Decoder.hpp"
00019
00020 extern "C"{
00021 #include <EmzCodecs/Mpeg4SpDecoder/exp_MP4SP_VD.h>
00022 #include <EmzCodecs/Mpeg4SpDecoder/exp_H263_VD.h>
00023 }
00024
00026 class EmzMpeg4DecoderThread : public Thread {
00027
00028     typedef Thread Base;
00029
00030     public:
00031
00033         virtual INT ThreadFn();
00034
00035     private:
00036
00038         int m_exited;
00040         Semaphore m_thread_sem;
00042         Semaphore m_stop_sem;
00044         EmzMpeg4Decoder* m_device;
00047         tBaseVideoDecoder* m_base;
00049         void* m_stack;
00050
00052         EmzMpeg4DecoderThread();
00053
00055         virtual ~EmzMpeg4DecoderThread();
00056
00088         CodecManager::ResultType Start( const UINT8* config_stream,
00089                                                 UINT32& config_len,
00090                                                 const CodecManager::VideoDecoderParameters& params,
00091                                                 CodecManager::VideoStreamInfo& stream_info,
00092                                                 EmzMpeg4Decoder* parent);
00093
00099         void Stop();
00100
00118         CodecManager::ResultType SetParameters( const VideoDecoder::ParameterType* types_array,
00119                                                 const UINT32* values_array,
00120                                                 UINT8 array_count);
00121
00142         CodecManager::ResultType GetParameters( const VideoDecoder::ParameterType* types_array,
00143                                                 UINT32* values_array,
00144                                                 UINT8 array_count);
00145
00151         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00152
00153
00157         void DecodeFrameSynchronously(EmzMpeg4Decoder::OperationInfo& op);
00158
00162         void DecodePacketSynchronously(EmzMpeg4Decoder::OperationInfo& op);
00163
00165         void Reset();
00166
00167     friend class EmzMpeg4Decoder; // creates/destroys EmzMpeg4DecoderThread
00168
00169 };
00170
00172 #endif // EmzMpeg4DecoderThread_hpp
00173
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzMpeg4Encoder.hpp"
#include "EmzMpeg4EncoderThread.hpp"

Include dependency graph for EmzMpeg4Encoder.cpp:

Variables

const UINT8 | c_emz_codec_mpeg4_enc_op_queue_max_count = 11
const UINT8 | c_emz_codec_mpeg4_enc_out_buf_max_count = 10
const UINT8 | c_emz_codec_mpeg4_enc_out_buf_min_count = 1

Variable Documentation

const UINT8 c_emz_codec_mpeg4_enc_op_queue_max_count = 11

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_mpeg4_enc_out_buf_max_count = 10

Maximum number of the output buffers.

const UINT8 c_emz_codec_mpeg4_enc_out_buf_min_count = 1

Maximum number of the output buffers.

Generated on Tue Jan 24 20:30:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoEncoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzMpeg4Encoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMpeg4Encoder
class | EmzMpeg4Encoder::OperationInfo
struct | EmzMpeg4Encoder::StateFlags

Defines

#define | EmzMpeg4Encoder_hpp

Variables

const UINT8 | c_emz_codecs_max_num_of_mpeg4_enc_inst = 2

Define Documentation

#define EmzMpeg4Encoder_hpp

Generated on Tue Jan 24 20:30:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMpeg4Encoder_hpp)
00010 #define EmzMpeg4Encoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoEncoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00020 const UINT8 c_emz_codecs_max_num_of_mpeg4_enc_inst = 2;
00021
00022 class EmzMpeg4EncoderThread;
00023
00026 class EmzMpeg4Encoder : public VideoEncoder {
00027
00028     typedef VideoEncoder Base;
00029
00030     public:
00031
00033         virtual ~EmzMpeg4Encoder();
00034
00036         virtual CodecManager::ResultType GetCapabilities(CodecManager::VideoCodecCapabilities& caps);
00037
00039         virtual CodecManager::ResultType AllocateOutputBuffers( UINT8 HUGE** &out_buf_array,
00040                                                                 UINT8& out_buf_count,
00041                                                                 UINT32& out_buf_len);
00042
00044         virtual CodecManager::ResultType RegisterCallbackFunctions( void* context,
00045                                                                     CbFrameEncoded cb_frame_encoded);
00046
00048         virtual CodecManager::ResultType EncodeFrame(   UINT8 HUGE* in_buf,
00049                                                         UINT32 time_stamp,
00050                                                         UINT32 key_frame_ind,
00051                                                         UINT8 HUGE* out_buf);
00052
00054         virtual CodecManager::ResultType SetParameters( const ParameterType* types_array,
00055                                                         const UINT32* values_array,
00056                                                         UINT8 array_count);
00057
00059         virtual CodecManager::ResultType GetParameters( const ParameterType* types_array,
00060                                                         UINT32* values_array,
00061                                                         UINT8 array_count);
00062
00064         virtual CodecManager::ResultType GetConfigStream(   UINT8 HUGE* out_buf,
00065                                                             UINT32& out_buf_len);
00066
00068         virtual CodecManager::ResultType AssignCaptureBufferPool(
00069                                                 UINT32 buf_pool_handle);
00070
00072         virtual CodecManager::ResultType Flush();
00073
00075         virtual CodecManager::ResultType Reset();
00076
00077     private:
00078
00080         enum StateType {
00081             IdleState = 0,
00082             StartingState,
00083             StartedState,
00084             StoppingState
00085         };
00086
00087         struct StateFlags {
00088             UINT m_state                        :2;
00089             UINT m_out_buffers_allocated        :1;
00090             UINT m_callback_funcs_registered    :1;
00091             UINT m_stop_requested               :1;
00092             UINT m_encode_op_running            :1;
00093             UINT m_reset_requested              :1;
00094         };
00095
00096         class OperationInfo {
00097
00098             public:
00099                 enum OperationType {
00100                     EncodeFrameOp,
00101                     SetParametersOp
00102                 };
00103
00104                 OperationType m_op;
00105                 UINT8 HUGE* m_in_buf;
00106                 UINT32 m_time_stamp;
00107                 UINT32 m_key_frame_ind;
00108                 UINT8 HUGE* m_out_buf;
00109
00110                 OperationInfo();
00111
00112                 OperationInfo(  OperationType op,
00113                                 UINT8 HUGE* in_buf,
00114                                 UINT32 time_stamp,
00115                                 UINT32 key_frame_ind,
00116                                 UINT8 HUGE* out_buf);
00117
00118                 OperationInfo(const OperationInfo& op_info);
00119
00120                 OperationInfo& operator=(const OperationInfo& op_info);
00121
00122                 virtual ~OperationInfo();
00123         }; // OperationInfo
00124
00127         CbFrameEncoded m_cb_frame_encoded;
00128
00131         static EmzMpeg4Encoder* m_exist_this_ptr_array[c_emz_codecs_max_num_of_mpeg4_enc_inst];
00134         void* m_client_context;
00136         UINT32 m_in_buf_len;
00138         UINT32 m_out_buf_len;
00141         UINT8 m_out_buf_array_count;
00143         UINT8 HUGE** m_out_buf_array;
00145         StateFlags m_flags;
00147         EmzUtils::Queue<OperationInfo> m_ops_queue;
00149         EmzMpeg4EncoderThread* m_thread;
00151         UINT32 m_capture_buffer_pool;
00154         ParameterType* m_types_arr;
00157         UINT32* m_values_arr;
00158
00160         EmzMpeg4Encoder();
00161
00163         virtual CodecManager::ResultType Start(
00164                             const CodecManager::VideoEncoderParameters& params,
00165                             CodecManager::VideoEncoderInfo& enc_info);
00166
00168         virtual void Stop();
00169
00174         virtual CodecManager::ResultType FreeOutputBuffers();
00175
00179         void ReleaseDevice();
00180
00181     friend class EmzCodecsLib; // creates/destroys the EmzMpeg4Encoder
00182
00183     friend class EmzMpeg4EncoderThread;
00184
00185 };
00186
00188 #endif // EmzMpeg4Encoder_hpp
00189
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzMpeg4EncoderThread.hpp"
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for EmzMpeg4EncoderThread.cpp:

Variables

const INT | c_emz_codec_mpeg4_enc_thread_prio = 104
const UINT32 | c_emz_codec_mpeg4_enc_thread_stacksize = 16384

Variable Documentation

const INT c_emz_codec_mpeg4_enc_thread_prio = 104

Priority of the video encoder thread.

const UINT32 c_emz_codec_mpeg4_enc_thread_stacksize = 16384

Size (in bytes) of the thread's stack (shall be multiple of 4).

Generated on Tue Jan 24 20:30:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoEncoder.hpp>
#include "EmzMpeg4Encoder.hpp"
#include <EmzCodecs/Mpeg4SpEncoder/exp_emz_MPEG4SP_video_enc.h>
#include <EmzCodecs/Mpeg4SpEncoder/exp_emz_H263_video_enc.h>

Include dependency graph for EmzMpeg4EncoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMpeg4EncoderThread

Defines

#define | EmzMpeg4EncoderThread_hpp

Define Documentation

#define EmzMpeg4EncoderThread_hpp

Generated on Tue Jan 24 20:30:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMpeg4EncoderThread_hpp)
00010 #define EmzMpeg4EncoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/VideoEncoder.hpp>
00018 #include "EmzMpeg4Encoder.hpp"
00019
00020 extern "C"{
00021 #include <EmzCodecs/Mpeg4SpEncoder/exp_emz_MPEG4SP_video_enc.h>
00022 #include <EmzCodecs/Mpeg4SpEncoder/exp_emz_H263_video_enc.h>
00023 }
00024
00026 class EmzMpeg4EncoderThread : public Thread {
00027
00028     typedef Thread Base;
00029
00030     public:
00031
00033         virtual INT ThreadFn();
00034
00035     private:
00036
00038         int m_exited;
00040         Semaphore m_thread_sem;
00042         Semaphore m_stop_sem;
00044         EmzMpeg4Encoder* m_device;
00047         tBaseVideoEncoder* m_base;
00049         void* m_stack;
00050
00052         EmzMpeg4EncoderThread();
00053
00055         virtual ~EmzMpeg4EncoderThread();
00056
00069         CodecManager::ResultType Start(
00070                             const CodecManager::VideoEncoderParameters& params,
00071                             CodecManager::VideoEncoderInfo& enc_info,
00072                             EmzMpeg4Encoder* video_enc);
00073
00079         void Stop();
00080
00093         CodecManager::ResultType GetConfigStream(   UINT8 HUGE* out_buf,
00094                                                     UINT32& out_buf_len);
00095
00113         CodecManager::ResultType SetParameters( const VideoEncoder::ParameterType* types_array,
00114                                                 const UINT32* values_array,
00115                                                 UINT8 array_count);
00116
00137         CodecManager::ResultType GetParameters( const VideoEncoder::ParameterType* types_array,
00138                                                 UINT32* values_array,
00139                                                 UINT8 array_count);
00140
00146         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00147
00151         void EncodeFrameSynchronously(EmzMpeg4Encoder::OperationInfo& op);
00152
00154         void Reset();
00155
00156     friend class EmzMpeg4Encoder; // creates/destroys EmzMpeg4EncoderThread
00157
00158 };
00159
00161 #endif // EmzMpeg4EncoderThread_hpp
00162
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzSbcEncoder.hpp"
#include "EmzSbcEncoderThread.hpp"

Include dependency graph for EmzSbcEncoder.cpp:

Variables

const UINT8 | c_emz_codec_sbc_enc_multi_frame_out_buf_max_count = 5
const UINT32 | c_emz_codec_sbc_enc_multi_frame_out_buf_max_len = 15000
const UINT8 | c_emz_codec_sbc_enc_multi_frame_out_buf_min_count = 2
const UINT8 | c_emz_codec_sbc_enc_op_queue_max_count = 10
const UINT8 | c_emz_codec_sbc_enc_single_frame_out_buf_max_count = 10
const UINT8 | c_emz_codec_sbc_enc_single_frame_out_buf_min_count = 2

Variable Documentation

const UINT8 c_emz_codec_sbc_enc_multi_frame_out_buf_max_count = 5

Maximum number of the audio encoder output buffers (for EncodeBuffer).

const UINT32 c_emz_codec_sbc_enc_multi_frame_out_buf_max_len = 15000

Length (in bytes) of the audio encoder output buffer (for EncodeBuffer).

const UINT8 c_emz_codec_sbc_enc_multi_frame_out_buf_min_count = 2

Minimum number of the audio encoder output buffers (for EncodeBuffer).

const UINT8 c_emz_codec_sbc_enc_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_sbc_enc_single_frame_out_buf_max_count = 10

Maximum number of the audio encoder output buffers (for EncodeFrame).

const UINT8 c_emz_codec_sbc_enc_single_frame_out_buf_min_count = 2

Minimum number of the audio encoder output buffers (for EncodeFrame).

Generated on Tue Jan 24 20:30:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioEncoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzSbcEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzSbcEncoder
class | EmzSbcEncoder::OperationInfo
struct | EmzSbcEncoder::StateFlags

Defines

#define | Apoxi_EmzSbcEncoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_sbc_enc_inst = 2

Define Documentation

#define Apoxi_EmzSbcEncoder_hpp

Generated on Tue Jan 24 20:30:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_EmzSbcEncoder_hpp)
00010 #define Apoxi_EmzSbcEncoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/AudioEncoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzSbcEncoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_sbc_enc_inst = 2;
00023
00025 class EmzSbcEncoder : public AudioEncoder {
00026
00027     typedef AudioEncoder Base;
00028
00029     public:
00030
00032         virtual ~EmzSbcEncoder();
00033
00035         virtual CodecManager::ResultType GetCapabilities(
00036                                 CodecManager::AudioCodecCapabilities& caps);
00037
00039         virtual CodecManager::ResultType AllocateOutputBuffers(
00040                                             UINT8 HUGE** &out_buf_array,
00041                                             UINT8& out_buf_count,
00042                                             UINT32& out_buf_len,
00043                                             EncodingFunctionType& dec_fct);
00044
00046         virtual CodecManager::ResultType RegisterCallbackFunctions(
00047                                         void* context,
00048                                         CbFrameEncoded cb_frame_encoded);
00049
00051         virtual CodecManager::ResultType EncodeFrame(
00052                                                     const UINT8 HUGE* in_buf,
00053                                                     UINT32 in_buf_len,
00054                                                     const UINT8 HUGE* out_buf,
00055                                                     UINT32 out_buf_len);
00057         virtual CodecManager::ResultType EncodeBuffer(
00058                                                     const UINT8 HUGE* in_buf,
00059                                                     UINT32 in_buf_len,
00060                                                     const UINT8 HUGE* out_buf,
00061                                                     UINT32 out_buf_len);
00062
00064         virtual CodecManager::ResultType SetParameters(
00065                                             const ParameterType* types_array,
00066                                             const UINT32* values_array,
00067                                             UINT8 array_count);
00068
00070         virtual CodecManager::ResultType GetParameters(
00071                                             const ParameterType* types_array,
00072                                             UINT32* values_array,
00073                                             UINT8 array_count);
00074
00076         virtual CodecManager::ResultType Flush();
00077
00079         virtual CodecManager::ResultType Reset();
00080
00081     private:
00082
00084         enum StateType {
00085             IdleState = 0,
00086             StartingState,
00087             StartedState,
00088             StoppingState
00089         };
00090
00091         struct StateFlags {
00092             UINT m_state                        :2;
00093             UINT m_out_buffers_allocated        :1;
00094             UINT m_callback_funcs_registered    :1;
00095             UINT m_stop_requested               :1;
00096             UINT m_encode_op_running            :1;
00097             UINT m_reset_requested              :1;
00098         };
00099
00100         class OperationInfo {
00101             public:
00102                 enum OperationType {
00103                     EncodeBufferOp,
00104                     EncodeFrameOp,
00105                     SetParametersOp
00106                 };
00107
00108                 OperationType m_op;
00109                 UINT8 HUGE* m_in_buf;
00110                 UINT32 m_in_buf_len;
00111                 UINT8 HUGE* m_out_buf;
00112                 UINT32 m_out_buf_len;
00113
00114                 OperationInfo();
00115
00116                 OperationInfo(  OperationType op,
00117                                         UINT8* in_buf,
00118                                         UINT32 in_buf_len,
00119                                         UINT8 HUGE* out_buf,
00120                                         UINT32 out_buf_len);
00121
00122                 OperationInfo(const OperationInfo& op_info);
00123
00124                 OperationInfo& operator=(const OperationInfo& op_info);
00125
00126                 virtual ~OperationInfo();
00127         }; // OperationInfo
00128
00131         CbFrameEncoded m_cb_frame_encoded;
00132
00135         static EmzSbcEncoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_sbc_enc_inst];
00138         void* m_client_context;
00140         UINT32 m_in_frame_len;
00142         UINT32 m_max_out_frame_len;
00144         UINT32 m_out_buf_len;
00148         UINT8 HUGE** m_out_buf_array;
00154         UINT8 m_out_buf_array_count;
00156         StateFlags m_flags;
00158         EmzUtils::Queue<OperationInfo> m_ops_queue;
00160         EmzSbcEncoderThread* m_thread;
00163         ParameterType* m_types_arr;
00166         UINT32* m_values_arr;
00167
00169         EmzSbcEncoder();
00170
00172         virtual CodecManager::ResultType Start(
00173                             const CodecManager::AudioEncoderParameters& params);
00174
00176         virtual void Stop();
00177
00184         CodecManager::ResultType FreeOutputBuffers();
00185
00188         void ReleaseDevice();
00189
00190     friend class EmzCodecsLib; // creates/destroys EmzSbcEncoder
00191
00192     friend class EmzSbcEncoderThread;
00193
00194 };
00195
00197 #endif // Apoxi_EmzSbcEncoder_hpp
00198
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.cpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzSbcEncoderThread.hpp"
#include <EmzCodecs/SbcEncoder/sbcencode_api.h>

Include dependency graph for EmzSbcEncoderThread.cpp:

Variables

const INT | c_emz_codec_sbc_enc_thread_prio = 104
const UINT32 | c_emz_codec_sbc_enc_thread_stacksize = 16384

Variable Documentation

const INT c_emz_codec_sbc_enc_thread_prio = 104

Priority of the audio encoder thread.

const UINT32 c_emz_codec_sbc_enc_thread_stacksize = 16384

Size (in bytes) of the thread's stack (shall be multiple of 4).

Generated on Tue Jan 24 20:30:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioEncoder.hpp>
#include "EmzSbcEncoder.hpp"

Include dependency graph for EmzSbcEncoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzSbcEncoderThread

Defines

#define | EmzSbcEncoderThread_hpp

Define Documentation

#define EmzSbcEncoderThread_hpp

Generated on Tue Jan 24 20:30:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzSbcEncoderThread_hpp)
00010 #define EmzSbcEncoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/AudioEncoder.hpp>
00018 #include "EmzSbcEncoder.hpp"
00019
00021 class EmzSbcEncoderThread : public Thread {
00022
00023     typedef Thread Base;
00024
00025     public:
00026
00028         virtual INT ThreadFn();
00029
00030     private:
00031
00033         int m_exited;
00035         Semaphore m_thread_sem;
00037         Semaphore m_stop_sem;
00039         EmzSbcEncoder* m_device;
00041         void* m_base;
00043         void* m_base_config;
00045         void* m_stack;
00046
00048         EmzSbcEncoderThread();
00049
00051         virtual ~EmzSbcEncoderThread();
00052
00081         CodecManager::ResultType Start(
00082                             const CodecManager::AudioEncoderParameters& params,
00083                             EmzSbcEncoder* parent);
00084
00090          void Stop();
00091
00097         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00098
00102         void EncodeBufferSynchronously(EmzSbcEncoder::OperationInfo& op);
00103
00105         void Reset();
00106
00108         CodecManager::ResultType SetParameters(
00109                                 const AudioEncoder::ParameterType* types_array,
00110                                 const UINT32* values_array,
00111                                 UINT8 array_count);
00112
00113     friend class EmzSbcEncoder; // creates/destroys EmzSbcEncoderThread
00114
00115 };
00116
00118 #endif // EmzSbcEncoderThread_hpp
00119
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp File Reference

Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for EmzUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzUtils
class | EmzUtils::Queue< T >

Defines

#define | EmzUtils_hpp

Define Documentation

#define EmzUtils_hpp

Generated on Tue Jan 24 20:30:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp Source File

Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzUtils_hpp)
00010 #define EmzUtils_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00017 class EmzUtils {
00018     public:
00019
00021     template<class T> class Queue {
00022
00023         public:
00026             Queue();
00030             Queue(UINT32 max_num_of_elems);
00032             ~Queue();
00035             BOOLEAN Init(UINT32 max_num_of_elems);
00038             BOOLEAN Reset();
00041             BOOLEAN PopAll();
00042             UINT32 GetCurrentNumberOfElements() const;
00043             UINT32 GetMaxNumberOfElements() const;
00044             BOOLEAN PushBack(T& elem);
00045             BOOLEAN PushFront(T& elem);
00046             BOOLEAN PopBack();
00047             BOOLEAN PopFront();
00048             T* GetFront() const;
00049             T* GetBack() const;
00050
00051         private:
00052             UINT32 m_max_num_of_elems;
00053             UINT32 m_curr_num_of_elems;
00054             UINT32 m_curr_pos;
00055             T** m_queue;
00056     }; // class Queue
00057
00058 }; // class EmzUtils
00059
00060 // Template and inline functions
00061
00062 /*  ------------------------------------------------------------------------
00063     Queue
00064     ------------------------------------------------------------------------ */
00065 template<class T> EmzUtils::Queue<T>::Queue():
00066     m_max_num_of_elems(0),
00067     m_curr_num_of_elems(0),
00068     m_curr_pos(0),
00069     m_queue(0)
00070 {
00071 } // Queue
00072
00073 /*  ------------------------------------------------------------------------
00074     Queue
00075     ------------------------------------------------------------------------ */
00076 template<class T> EmzUtils::Queue<T>::Queue(UINT32 max_num_of_elems):
00077     m_max_num_of_elems(0),
00078     m_curr_num_of_elems(0),
00079     m_curr_pos(0),
00080     m_queue(0)
00081 {
00082     Init(max_num_of_elems);
00083 } // Queue
00084
00085 /*  ------------------------------------------------------------------------
00086     ~Queue
00087     ------------------------------------------------------------------------ */
00088 template<class T> EmzUtils::Queue<T>::~Queue()
00089 {
00090     Reset();
00091 } // ~Queue
00092
00093 /*  ------------------------------------------------------------------------
00094     Init
00095     ------------------------------------------------------------------------ */
00096 template<class T> BOOLEAN EmzUtils::Queue<T>::Init(UINT32 max_num_of_elems)
00097 {
00098     Reset();
00099     m_queue = new T*[max_num_of_elems];
00100     if (!m_queue)
00101         return FALSE;
00102     UINT32 i;
00103     for (i = 0; i < max_num_of_elems; i++) {
00104         m_queue[i] = 0;
00105     }
00106     for (i = 0; i < max_num_of_elems; i++) {
00107         m_queue[i] = new T;
00108         if (!m_queue[i]) {
00109             Reset();
00110             return FALSE;
00111         }
00112     }
00113     m_max_num_of_elems = max_num_of_elems;
00114     return TRUE;
00115 } // Init
00116
00117 /*  ------------------------------------------------------------------------
00118     Reset
00119     ------------------------------------------------------------------------ */
00120 template<class T> BOOLEAN EmzUtils::Queue<T>::Reset()
00121 {
00122     if (!m_queue)
00123         return TRUE;
00124     for (UINT32 i = 0; i < m_max_num_of_elems; i++) {
00125         delete m_queue[i];
00126         m_queue[i] = 0;
00127     }
00128     m_max_num_of_elems = 0;
00129     m_curr_num_of_elems = 0;
00130     m_curr_pos = 0;
00131     delete [] m_queue;
00132     m_queue = 0;
00133     return TRUE;
00134 } // Reset
00135
00136 /*  ------------------------------------------------------------------------
00137     PopAll
00138     ------------------------------------------------------------------------ */
00139 template<class T> BOOLEAN EmzUtils::Queue<T>::PopAll()
00140 {
00141     m_curr_num_of_elems = 0;
00142     m_curr_pos = 0;
00143     return TRUE;
00144 } // PopAll
00145
00146 /*  ------------------------------------------------------------------------
00147     GetCurrentNumberOfElements
00148     ------------------------------------------------------------------------ */
00149 template<class T> UINT32 EmzUtils::Queue<T>::GetCurrentNumberOfElements() const
00150 {
00151     return m_curr_num_of_elems;
00152 } // GetCurrentNumberOfElements
00153
00154 /*  ------------------------------------------------------------------------
00155     GetMaxNumberOfElements
00156     ------------------------------------------------------------------------ */
00157 template<class T> UINT32 EmzUtils::Queue<T>::GetMaxNumberOfElements() const
00158 {
00159     return m_max_num_of_elems;
00160 } // GetMaxNumberOfElements
00161
00162 /*  ------------------------------------------------------------------------
00163     PushBack
00164     ------------------------------------------------------------------------ */
00165 template<class T> BOOLEAN EmzUtils::Queue<T>::PushBack(T& elem)
00166 {
00167     if (m_curr_num_of_elems >= m_max_num_of_elems)
00168         return FALSE;
00169     *m_queue[(m_curr_pos + m_curr_num_of_elems) % m_max_num_of_elems] = elem;
00170     m_curr_num_of_elems++;
00171     return TRUE;
00172 } // PushBack
00173
00174 /*  ------------------------------------------------------------------------
00175     PushFront
00176     ------------------------------------------------------------------------ */
00177 template<class T> BOOLEAN EmzUtils::Queue<T>::PushFront(T& elem)
00178 {
00179     if (m_curr_num_of_elems >= m_max_num_of_elems)
00180         return FALSE;
00181     if (m_curr_num_of_elems > 0)
00182             m_curr_pos = (m_curr_pos + m_max_num_of_elems - 1) % m_max_num_of_elems;
00183     *m_queue[m_curr_pos] = elem;
00184     m_curr_num_of_elems++;
00185     return TRUE;
00186 } // PushFront
00187
00188 /*  ------------------------------------------------------------------------
00189     PopBack
00190     ------------------------------------------------------------------------ */
00191 template<class T> BOOLEAN EmzUtils::Queue<T>::PopBack()
00192 {
00193     if (m_curr_num_of_elems == 0)
00194         return TRUE;
00195     m_curr_num_of_elems--;
00196     return TRUE;
00197 } // PopBack
00198
00199 /*  ------------------------------------------------------------------------
00200     PopFront
00201     ------------------------------------------------------------------------ */
00202 template<class T> BOOLEAN EmzUtils::Queue<T>::PopFront()
00203 {
00204     if (m_curr_num_of_elems == 0)
00205         return TRUE;
00206     m_curr_pos = (m_curr_pos + 1) % m_max_num_of_elems;
00207     m_curr_num_of_elems--;
00208     return TRUE;
00209 } // PopFront
00210
00211 /*  ------------------------------------------------------------------------
00212     GetFront
00213     ------------------------------------------------------------------------ */
00214 template<class T> T* EmzUtils::Queue<T>::GetFront() const
00215 {
00216     if (m_curr_num_of_elems == 0) {
00217         return 0;
00218     }
00219     return m_queue[m_curr_pos];
00220 } // GetFront
00221
00222 /*  ------------------------------------------------------------------------
00223     GetBack
00224     ------------------------------------------------------------------------ */
00225 template<class T> T* EmzUtils::Queue<T>::GetBack() const
00226 {
00227     if (m_curr_num_of_elems == 0) {
00228         return 0;
00229     }
00230     return m_queue[(m_curr_pos + m_curr_num_of_elems - 1) % m_max_num_of_elems];
00231 } // GetBack
00232
00234 #endif // EmzUtils_hpp
00235
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Audio.hpp File Reference

Devices/MPEU/Audio.hpp File Reference

#include <Compat/Devices/MPEU/Audio.hpp>

Include dependency graph for Audio.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:17:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Audio.hpp Source File

Devices/MPEU/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /* The class Audio has been moved to Compat.
00010 This header-file assures backward-compatibility for
00011 applications written with APOXI-versions smaller than 2.7.0*/
00012 #include <Compat/Devices/MPEU/Audio.hpp>
00013
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/BackLight.cpp File Reference

Devices/MPEU/BackLight.cpp File Reference

#include "BackLight.hpp"

Include dependency graph for BackLight.cpp:

Generated on Tue Jan 24 20:29:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/BackLight.hpp File Reference

Devices/MPEU/BackLight.hpp File Reference

#include "Kernel/Types.hpp"
#include <Devices/AbstractDevice.hpp>

Include dependency graph for BackLight.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BackLight
Back light device. More...

Defines

#define | Apoxi_Devices_MPEU_BackLight_hpp

Define Documentation

#define Apoxi_Devices_MPEU_BackLight_hpp

Generated on Tue Jan 24 20:29:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/BackLight.hpp Source File

Devices/MPEU/BackLight.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_MPEU_BackLight_hpp)
00010 #define Apoxi_Devices_MPEU_BackLight_hpp
00011
00012 #include "Kernel/Types.hpp"
00013 #include <Devices/AbstractDevice.hpp>
00014
00015
00016
00017
00019 class BackLight : public AbstractDevice {
00020     public:
00021
00022         enum BackLightMode {
00023             BackLightOn  ,
00024             BackLightOff
00025         };
00026
00028         static void Init();
00029
00031         virtual const WCHAR* GetName() const;
00032
00034         static void Switch(BackLightMode mode);
00035
00037         static BOOLEAN GetStatus();
00038
00040         static void CleanUp(){};
00041
00042 };
00043
00044
00045
00046 #endif  // Apoxi_Devices_MPEU_BackLight_hpp
00047
00048
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Camera.cpp File Reference

Devices/MPEU/Camera.cpp File Reference

#include "PreComp.hpp"
#include "Camera.hpp"
#include <Config/CameraConfig.hpp>
#include <Devices/DeviceManager.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for Camera.cpp:

Defines

#define | CifSize_INDEX (6)
#define | DEBUG_CAMERA_CPP
#define | DEBUG_DEVICE_CAMERA_CPP_FILE (30600)
#define | DEFAULT_STEP_SIZE (1)
#define | DefaultZoomLevelCifSize_INDEX (3)
#define | DefaultZoomLevelQcifSize_INDEX (3)
#define | DefaultZoomLevelQqcifSize_INDEX (3)
#define | DefaultZoomLevelQqvgaSize_INDEX (3)
#define | DefaultZoomLevelQsifSize_INDEX (3)
#define | DefaultZoomLevelQvgaSize_INDEX (3)
#define | DefaultZoomLevelSize1_3Mp_INDEX (3)
#define | DefaultZoomLevelSize1Mp_INDEX (3)
#define | DefaultZoomLevelSize2Mp_INDEX (3)
#define | DefaultZoomLevelSize3Mp_INDEX (3)
#define | DefaultZoomLevelSqcifSize_INDEX (3)
#define | DefaultZoomLevelSvgaSize_INDEX (3)
#define | DefaultZoomLevelUxgaSize_INDEX (3)
#define | DefaultZoomLevelVgaSize_INDEX (3)
#define | DefaultZoomLevelXgaSize_INDEX (3)
#define | MAX_LCD_SCREEN_FORMATS (5)
#define | MAX_ZOOM_LEVELS (7)
#define | MIN_ZOOM_LEVELS (1)
#define | NOT_USEABLE (-1)
#define | QcifSize_INDEX (3)
#define | QqcifSize_INDEX (0)
#define | QqvgaSize_INDEX (2)
#define | QsifSize_INDEX (4)
#define | QvgaSize_INDEX (5)
#define | Size1_3Mp_INDEX (0x0B)
#define | Size1Mp_INDEX (0x0A)
#define | Size2Mp_INDEX (0x0D)
#define | Size3Mp_INDEX (0x0E)
#define | SqcifSize_INDEX (1)
#define | SvgaSize_INDEX (8)
#define | UxgaSize_INDEX (0x0C)
#define | VgaSize_INDEX (7)
#define | XgaSize_INDEX (9)

Functions

void | ApoxiSendGddViewfinderError ()

Variables

const gdd_cam_fps_type | DEFAULT_VIEWFINDER_FRAMERATE = GDD_FPS_15

Define Documentation

#define CifSize_INDEX (6)

#define DEBUG_CAMERA_CPP

#define DEBUG_DEVICE_CAMERA_CPP_FILE (30600)

#define DEFAULT_STEP_SIZE (1)

#define DefaultZoomLevelCifSize_INDEX (3)

#define DefaultZoomLevelQcifSize_INDEX (3)

#define DefaultZoomLevelQqcifSize_INDEX (3)

#define DefaultZoomLevelQqvgaSize_INDEX (3)

#define DefaultZoomLevelQsifSize_INDEX (3)

#define DefaultZoomLevelQvgaSize_INDEX (3)

#define DefaultZoomLevelSize1_3Mp_INDEX (3)

#define DefaultZoomLevelSize1Mp_INDEX (3)

#define DefaultZoomLevelSize2Mp_INDEX (3)

#define DefaultZoomLevelSize3Mp_INDEX (3)

#define DefaultZoomLevelSqcifSize_INDEX (3)

#define DefaultZoomLevelSvgaSize_INDEX (3)

#define DefaultZoomLevelUxgaSize_INDEX (3)

#define DefaultZoomLevelVgaSize_INDEX (3)

#define DefaultZoomLevelXgaSize_INDEX (3)

#define MAX_LCD_SCREEN_FORMATS (5)

#define MAX_ZOOM_LEVELS (7)

#define MIN_ZOOM_LEVELS (1)

#define NOT_USEABLE (-1)

#define QcifSize_INDEX (3)

#define QqcifSize_INDEX (0)

#define QqvgaSize_INDEX (2)

#define QsifSize_INDEX (4)

#define QvgaSize_INDEX (5)

#define Size1_3Mp_INDEX (0x0B)

#define Size1Mp_INDEX (0x0A)

#define Size2Mp_INDEX (0x0D)

#define Size3Mp_INDEX (0x0E)

#define SqcifSize_INDEX (1)

#define SvgaSize_INDEX (8)

#define UxgaSize_INDEX (0x0C)

#define VgaSize_INDEX (7)

#define XgaSize_INDEX (9)

Function Documentation

void ApoxiSendGddViewfinderError ( void )

Variable Documentation

const gdd_cam_fps_type DEFAULT_VIEWFINDER_FRAMERATE = GDD_FPS_15

Generated on Tue Jan 24 20:23:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Camera.hpp File Reference

Devices/MPEU/Camera.hpp File Reference

#include <Devices/AbstractLockableDevice.hpp>
#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>
#include <Devices/CameraInterface.hpp>

Include dependency graph for Camera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Camera
struct | Camera::ParameterStruct

Defines

#define | Apoxi_Camera_hpp

Define Documentation

#define Apoxi_Camera_hpp

Generated on Tue Jan 24 20:24:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Camera.hpp Source File

Devices/MPEU/Camera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Camera_hpp)
00010 #define Apoxi_Camera_hpp
00013
00014 #include <Devices/AbstractLockableDevice.hpp>
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Rect.hpp>
00017
00019 class Camera : public AbstractLockableDevice {
00020     typedef AbstractLockableDevice Base;
00021
00022     public:
00023     #include <Devices/CameraInterface.hpp>
00024
00025     protected:
00026
00028         virtual BOOLEAN& GetLock() {return m_lock[GetIndex()];}
00030         INT GetZoom();
00032         UINT16 CalcCameraScalingRate(ImageSizeType imageType, INT device_zoom_level);
00033
00034         void SetState(CameraState camera_state);
00035
00037         INT m_last_error;
00038
00040         INT m_zoom_level;
00041
00043         INT m_brightness_level;
00044
00046         INT m_contrast_level;
00047
00049         FlashType m_flash;
00050
00052         Rect m_rect;
00053
00055         ImageSizeType m_capture_image_size;
00056
00058         TransformationType m_capture_transformation;
00059
00061         TransformationType m_view_image_transformation;
00062
00063     private:
00064
00065
00067         typedef struct ParameterStruct {
00068                     INT min;
00069                     INT def;
00070                     INT max;
00071                     INT step;
00072                 } ParameterStruct;
00073
00074
00075                 enum ParameterType {
00076                     BrightnessParameter = 0,
00077                     ContrastParameter
00078                 };
00079
00080         static BOOLEAN m_lock[2];
00081
00082         CameraState m_camera_state;
00083         INT m_display_idx;  // display index where the camera viewfinder should be displayed
00084
00085         AntiFlickerType m_antiflicker_mode;
00086         FilterType m_filter;
00087
00088         ScalingMethodType m_scaling_method;
00089         TwilightType m_twilight_mode;
00090
00091         ParameterStruct m_DeviceParameterLimits[2];
00092         ParameterLimits m_CameraParameterLimits[2];
00093
00094         void ConvertCameraToDeviceLimits(ParameterType type);
00095
00096         INT CalcCameraValue(ParameterType type, INT deviceValue);
00097         BOOLEAN CheckDeviceBrightnessContrastLevel(ParameterType type, INT val);
00098 };
00099
00100 inline INT Camera::GetLastError() const
00101 {
00102     return m_last_error;
00103 }
00104
00105 inline INT Camera::GetDisplayIndex() const
00106 {
00107     return m_display_idx;
00108 }
00109
00111 #endif  // Apoxi_Camera_hpp
00112
00113
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Charger.cpp File Reference

Devices/MPEU/Charger.cpp File Reference

#include "PreComp.hpp"
#include <stack/driver.h>
#include "Charger.hpp"
#include <Devices/ChargerSignalMapTableNode.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for Charger.cpp:

Generated on Tue Jan 24 20:24:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Charger.hpp File Reference

Devices/MPEU/Charger.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/ChargerInterface.hpp>

Include dependency graph for Charger.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Charger

Defines

#define | Apoxi_Devices_Mpeu_Charger_hpp

Define Documentation

#define Apoxi_Devices_Mpeu_Charger_hpp

Generated on Tue Jan 24 20:24:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Charger.hpp Source File

Devices/MPEU/Charger.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Devices_Mpeu_Charger_hpp)
00011 #define Apoxi_Devices_Mpeu_Charger_hpp
00012
00013 #include <Devices/AbstractDevice.hpp>
00014
00016 class Charger: public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     #include <Devices/ChargerInterface.hpp>
00020
00021     protected:
00023         virtual void OnStart();
00024 };
00025
00026 #endif  // Apoxi_Devices_Mpeu_Charger_hpp
00027
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/DefaultDisplay.cpp File Reference

Devices/MPEU/DefaultDisplay.cpp File Reference

#include "PreComp.hpp"
#include "DefaultDisplay.hpp"
#include "VideoChannel.hpp"
#include <Gui/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DisplayMsgTypes.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <stack/driver.h>

Include dependency graph for DefaultDisplay.cpp:

Functions

void ApoxiSendDisplayUpdateFinished (int, void *, ubyte shuge *)

Function Documentation

void ApoxiSendDisplayUpdateFinished | ( | int | ,
 |  | void * | ,
 |  | ubyte shuge * |
 | ) |

Generated on Tue Jan 24 20:24:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/DefaultDisplay.hpp File Reference

Devices/MPEU/DefaultDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Devices/Display.hpp>

Include dependency graph for DefaultDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultDisplay

Defines

#define | Apoxi_Devices_MPEU_DefaultDisplay_hpp

Define Documentation

#define Apoxi_Devices_MPEU_DefaultDisplay_hpp

Generated on Tue Jan 24 20:25:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/DefaultDisplay.hpp Source File

Devices/MPEU/DefaultDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_MPEU_DefaultDisplay_hpp)
00010 #define Apoxi_Devices_MPEU_DefaultDisplay_hpp
00013
00014 class VideoChannel;
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/Os/SystemTimer.hpp>
00017 #include <Devices/Display.hpp>
00018
00023 class DefaultDisplay : public Display {
00024     typedef Display Base;
00025
00026     public:
00029         DefaultDisplay(INT index);
00030
00031         virtual ~DefaultDisplay();
00032
00034         virtual const WCHAR* GetName() const;
00035
00037         virtual void OnStart();
00038
00040         virtual void OnStop();
00041
00043         virtual void SetContrast(INT contrast);
00044
00046         virtual INT GetContrast() const;
00047
00049         virtual void SetBrightness(INT brightness);
00050
00052         virtual INT GetBrightness() const;
00053
00055         virtual void SetBacklightTimeout(UINT32 timeout);
00056
00058         virtual void SetPowerTimeout(UINT32 timeout);
00059
00061         virtual void ReactivateBacklight();
00062
00064         virtual void ReactivatePower();
00065
00067         virtual void SetBacklightMode(BacklightMode mode);
00068
00070         virtual BacklightMode GetBacklightMode() const;
00071
00073         virtual BOOLEAN IsBacklightOn() const;
00074
00076         virtual void SetPowerMode(PowerMode mode);
00077
00079         virtual PowerMode GetPowerMode() const;
00080
00082         virtual BOOLEAN IsPowerOn() const;
00083
00085         virtual void SetCustomFrameBufferRect(const Rect& rect);
00086
00088         virtual void Refresh();
00089
00098         virtual void Refresh(const CustomFrameBuffer* custom_frame_buf);
00099
00103         virtual VideoChannel* GetVideoChannel();
00104
00108         void OnTimer();
00109
00110         /*  S-Gold specific interface, which is not part of the common Display interface and hence may
00111             not be used by any APOXI or MMI interface. */
00112         static void SynchronizeBuffers();
00113
00115         virtual void SetCallbackActive(BOOLEAN state);
00116
00118         virtual BOOLEAN IsCallbackActive() const;
00119
00120     private:
00121         enum Status {
00122             DisplayOff,
00123             BacklightOff,
00124             BacklightOn
00125         };
00126
00127         struct {
00128             UINT backlight_mode         : 2;
00129             UINT power_mode             : 2;
00130             UINT status                 : 2;
00131             UINT power_on               : 1;
00132             UINT backlight_on           : 1;
00133             UINT timer_expired          : 1;
00134         } m_bits;
00135         VideoChannel* m_video_channel;
00136         SystemTimer* m_timer;
00137         UINT32 m_backlight_timeout;
00138         UINT32 m_power_timeout;
00139
00140         UINT8 m_contrast;
00141         UINT8 m_brightness;
00142
00143         volatile BOOLEAN m_cb_active;
00144         BOOLEAN m_skipped_buffer_synchronization;
00145         BOOLEAN m_use_custom_frame_buffer;
00146         BOOLEAN m_update_frame_buffer;
00147
00148         Semaphore m_sem;
00149         BOOLEAN m_gdd_transfer;
00150         Rect m_updated_blit_rect;
00151         Rect m_custom_frame_buf_rect;
00152         const Bitmap* m_custom_bmp;
00153         DDrvAtomPtr m_transfer_buffer;      // buffer which contains a copy of the main frame buffer
00154
00155         void SetBacklight(BOOLEAN backlight);
00156         void SetPower(BOOLEAN power);
00157
00158         static void CallbackFn(void* arg);
00159
00160         friend class VideoChannel;
00161 };
00162
00164 #endif  // Apoxi_Devices_MPEU_DefaultDisplay_hpp
00165
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Fota.cpp File Reference

Devices/MPEU/Fota.cpp File Reference

#include "PreComp.hpp"
#include "Fota.hpp"
#include <Devices/ShutDown.hpp>
#include <stack/driver.h>

Include dependency graph for Fota.cpp:

Generated on Tue Jan 24 20:25:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Fota.hpp File Reference

Devices/MPEU/Fota.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/FotaInterface.hpp>

Include dependency graph for Fota.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Fota

Defines

#define | Apoxi_Devices_MPEU_Fota_hpp

Define Documentation

#define Apoxi_Devices_MPEU_Fota_hpp

Generated on Tue Jan 24 20:25:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Fota.hpp Source File

Devices/MPEU/Fota.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_MPEU_Fota_hpp)
00010 #define Apoxi_Devices_MPEU_Fota_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class Fota : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/FotaInterface.hpp>
00018
00019     private:
00020 };
00021
00022 #endif  // Apoxi_Devices_MPEU_Fota_hpp
00023
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Keyboard.cpp File Reference

Devices/MPEU/Keyboard.cpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Config/KeyboardConfig.hpp>
#include <stack/driver.h>
#include "Keyboard.hpp"
#include <Devices/SharedMethods/KeyboardTimer.cpp>

Include dependency graph for Keyboard.cpp:

Generated on Tue Jan 24 20:25:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Keyboard.hpp File Reference

Devices/MPEU/Keyboard.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/KeyboardInterface.hpp>

Include dependency graph for Keyboard.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Keyboard
Keyboard. More...
struct | Keyboard::BitStruct

Defines

#define | Apoxi_Devices_Mpeu_Keyboard_hpp

Define Documentation

#define Apoxi_Devices_Mpeu_Keyboard_hpp

Generated on Tue Jan 24 20:25:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Keyboard.hpp Source File

Devices/MPEU/Keyboard.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Mpeu_Keyboard_hpp)
00010 #define Apoxi_Devices_Mpeu_Keyboard_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00015 class Keyboard : public AbstractDevice {
00016     typedef AbstractDevice Base;
00017
00018     #include <Devices/KeyboardInterface.hpp>
00019
00020     protected:
00021         virtual void OnStart();
00022
00023     private:
00024         struct BitStruct {
00025             UINT locked                 : 1;
00026             UINT multi_key_mode         : 1;
00027             UINT illumination_status    : 1;
00028             UINT illumination_mode      : 2;
00029         };
00030
00031         static BitStruct m_bits;
00032         static UINT32 m_illumination_timeout;
00033         static SystemTimer m_illumination_timer;
00034
00035         static void SetIllumination(BOOLEAN illumination);
00036         static void OnIlluminationTimer(void *arg);
00037 };
00038
00039 /*  ------------------------------------------------------------------------
00040     IsLocked
00041     ------------------------------------------------------------------------ */
00042 inline BOOLEAN Keyboard::IsLocked()
00043 {
00044     return m_bits.locked;
00045 }
00046
00047 /*  ------------------------------------------------------------------------
00048     IsMultiKeyMode
00049     ------------------------------------------------------------------------ */
00050 inline BOOLEAN Keyboard::IsMultiKeyMode()
00051 {
00052     return (BOOLEAN)m_bits.multi_key_mode;
00053 }
00054
00055 /*  ------------------------------------------------------------------------
00056     SetIlluminationTimeout
00057     ------------------------------------------------------------------------ */
00058 inline void Keyboard::SetIlluminationTimeout(UINT32 timeout)
00059 {
00060     m_illumination_timeout = timeout;
00061 }
00062
00063 /*  ------------------------------------------------------------------------
00064     GetIlluminationMode
00065     ------------------------------------------------------------------------ */
00066 inline Keyboard::IlluminationMode Keyboard::GetIlluminationMode()
00067 {
00068     return static_cast<IlluminationMode>(m_bits.illumination_mode);
00069 }
00070
00071 /*  ------------------------------------------------------------------------
00072     IsIlluminationOn
00073     ------------------------------------------------------------------------ */
00074 inline BOOLEAN Keyboard::IsIlluminationOn()
00075 {
00076     return (BOOLEAN)m_bits.illumination_status;
00077 }
00078
00079 #endif  // Apoxi_Devices_Mpeu_Keyboard_hpp
00080
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Led.cpp File Reference

Devices/MPEU/Led.cpp File Reference

#include "PreComp.hpp"
#include "Led.hpp"
#include <Devices/LedSignalMapTableNode.hpp>

Include dependency graph for Led.cpp:

Generated on Tue Jan 24 20:25:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Led.hpp File Reference

Devices/MPEU/Led.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <stack/driver.h>
#include <Devices/LedInterface.hpp>

Include dependency graph for Led.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Led
Back light device. More...

Defines

#define | Apoxi_Devices_Mpeu_Led_hpp

Define Documentation

#define Apoxi_Devices_Mpeu_Led_hpp

Generated on Tue Jan 24 20:25:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Led.hpp Source File

Devices/MPEU/Led.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Mpeu_Led_hpp)
00010 #define Apoxi_Devices_Mpeu_Led_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013 #include <stack/driver.h>
00014
00015 class Led : public AbstractDevice {
00016     typedef AbstractDevice Base;
00017
00018     public:
00019         #if !defined(APOXI_LED_NEW_INTERFACE)
00020             enum Event {
00021                 Call = led_call,                /* stored in eep  */
00022                 ReceivingCall = led_receiving_call,     /* stored in eep  */
00023                 CallUnanswered = led_call_unanswered,       /* stored in eep  */
00024                 Mail = led_mail,                /* stored in eep  */
00025                 Service = led_service,          /* stored in eep  */
00026                 NoService = led_no_service,         /* stored in eep  */
00027                 LimitedService = led_limited_service,
00028                 PowerOn = led_power_on,
00029                 PowerOff = led_power_off,
00030                 ReceivedCallConnected = led_received_call_connected,
00031                 SmsReceiving = led_sms_receiving,
00032                 SmsSending = led_sms_sending,
00033                 AlarmOngoing = led_alarm_ongoing,
00034                 AlarmStopped = led_alarm_stopped,
00035                 BatteryLow = led_battery_low,
00036                 ChargerDisconnected = led_charger_disconnected,
00037                 ChargerConnected = led_charger_connected,
00038                 ChargeComplete = led_charge_complete
00039             };
00040
00041             enum Color {
00042                 Blue = led_blue,
00043                 Red = led_red,
00044                 Green = led_green,
00045                 Magenta = led_blue_red,        /* magenta */
00046                 Cyan = led_blue_green,      /* cyan    */
00047                 Yellow = led_red_green,       /* yellow  */
00048                 White = led_red_blue_green,  /* white   */
00049                 NoOfColors = led_nof_colors,
00050                 InvalidColor,
00051             };
00052
00053
00054             enum Action {
00055                 On = LED_ON,
00056                 Off = LED_OFF,
00057                 Flash = LED_FLASH,
00058                 ColorStream = LED_COLORSTREAM,
00059             };
00060
00061             #if defined (USE_SMPOWER)
00062                 enum Intensity {
00063                     NoCurrent = led_no_current, /*   0 mA */
00064                     Minimum = led_20_ma,        /*  20 mA */
00065                     Low = led_40_ma,            /*  40 mA */
00066                     LessThanNormal = led_60_ma, /*  60 mA */
00067                     Normal = led_80_ma,         /*  80 mA */
00068                     MoreThanNormal = led_100_ma,/* 100 mA */
00069                     High = led_120_ma,          /* 120 mA */
00070                     Maximum = led_140_ma        /* 140 mA */
00071                 };
00072             #else
00073                 enum Intensity {
00074                     NoCurrent,
00075                     Minimum,
00076                     Low,
00077                     LessThanNormal,
00078                     Normal,
00079                     MoreThanNormal,
00080                     High,
00081                     Maximum,
00082                 };
00083             #endif
00084         #endif
00085
00086     #include <Devices/LedInterface.hpp>
00087
00088     protected:
00089         #if defined(APOXI_LED_NEW_INTERFACE)
00090             virtual void OnStart();
00091         #endif
00092
00093     private:
00094         static const INT c_max_colorstream_length;
00095 };
00096
00097 #endif  // Apoxi_Devices_Mpeu_Led_hpp
00098
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/PreComp.cpp File Reference

Devices/MPEU/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:04:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/PreComp.hpp File Reference

Devices/MPEU/PreComp.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/System.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/PreComp.hpp Source File

Devices/MPEU/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013 #include <Kernel/System.hpp>
00014
00015
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/RealTimeClock.cpp File Reference

Devices/MPEU/RealTimeClock.cpp File Reference

#include "PreComp.hpp"
#include <Devices/RealTimeClock.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Devices/RtcSignalMapTableNode.hpp>
#include <Devices/RtcMsgTypes.hpp>
#include <stdio.h>
#include <stack/driver.h>
#include <stack/stack.h>

Include dependency graph for RealTimeClock.cpp:

Generated on Tue Jan 24 20:25:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/RealTimeClock.hpp File Reference

Devices/MPEU/RealTimeClock.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/RealTimeClockInterface.hpp>

Include dependency graph for RealTimeClock.hpp:

Go to the source code of this file.

Data Structures

class | RealTimeClock

Defines

#define | Apoxi_Devices_Mpeu_RealTimeClock_hpp

Define Documentation

#define Apoxi_Devices_Mpeu_RealTimeClock_hpp

Generated on Tue Jan 24 20:25:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/RealTimeClock.hpp Source File

Devices/MPEU/RealTimeClock.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Mpeu_RealTimeClock_hpp)
00010 #define Apoxi_Devices_Mpeu_RealTimeClock_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class RealTimeClock : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/RealTimeClockInterface.hpp>
00018
00019     protected:
00021         virtual void OnStart();
00022
00024         virtual void OnStop();
00025 };
00026
00027 #endif  // Apoxi_Devices_Mpeu_RealTimeClock_hpp
00028
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/StillCamera.cpp File Reference

Devices/MPEU/StillCamera.cpp File Reference

#include "PreComp.hpp"
#include "StillCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Afs/Rfs/FileDataSink.hpp>
#include <AddOns/AfsRam/RamDataSink.hpp>
#include <Afs/Rfs/FileBinData.hpp>

Include dependency graph for StillCamera.cpp:

Defines

#define | BITS_PRO_BYTE (8)
#define | BITS_PRO_JPEG_PIXEL BITS_PRO_BYTE*BYTEST_PRO_JPEG_PIXEL
#define | BYTEST_PRO_JPEG_PIXEL BYTEST_PRO_PIXEL
#define | BYTEST_PRO_PIXEL MULTIPLIKATOR/DIVISOR
#define | DEBUG_DEVICE_STILL_CAMERA_CPP_FILE (30610)
#define | DEBUG_STILL_CAMERA_CPP
#define | DEBUG_STILL_CAMERA_CPP_CB
#define | DIVISOR (1)
#define | IMAGE_BUFFER_NOT_USED (0)
#define | MULTIPLIKATOR (2)
#define | NO_FRAME_RATE_SUB (0)
#define | NO_OF_PICTURE_FOR_SINGLE_SHOT (1)
#define | NO_OF_PICTURES_EMPTY (0)
#define | RESET_PICTURE_COUNTER (0)
#define | TEMPORARY_USED

Functions

BOOLEAN | GetStoredCameraBuffer (UINT8 HUGE **captured_buffer, UINT32 *size)

Define Documentation

#define BITS_PRO_BYTE (8)

#define BITS_PRO_JPEG_PIXEL BITS_PRO_BYTE*BYTEST_PRO_JPEG_PIXEL

#define BYTEST_PRO_JPEG_PIXEL BYTEST_PRO_PIXEL

#define BYTEST_PRO_PIXEL MULTIPLIKATOR/DIVISOR

#define DEBUG_DEVICE_STILL_CAMERA_CPP_FILE (30610)

#define DEBUG_STILL_CAMERA_CPP

#define DEBUG_STILL_CAMERA_CPP_CB

#define DIVISOR (1)

#define IMAGE_BUFFER_NOT_USED (0)

#define MULTIPLIKATOR (2)

#define NO_FRAME_RATE_SUB (0)

#define NO_OF_PICTURE_FOR_SINGLE_SHOT (1)

#define NO_OF_PICTURES_EMPTY (0)

#define RESET_PICTURE_COUNTER (0)

#define TEMPORARY_USED

Function Documentation

BOOLEAN GetStoredCameraBuffer | ( | UINT8 HUGE ** | captured_buffer,
 |  | UINT32 * | size
 | ) |

Generated on Tue Jan 24 20:26:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/StillCamera.hpp File Reference

Devices/MPEU/StillCamera.hpp File Reference

#include <Auxiliary/DataSink.hpp>
#include <Devices/MPEU/Camera.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Devices/StillCameraInterface.hpp>

Include dependency graph for StillCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StillCamera
struct | StillCamera::BufferInfoType

Defines

#define | Apoxi_StillCamera_hpp
#define | IMAGE_CAPTURED_OK (0)
#define | IMAGE_ENCODED_OK (0)
#define | MAX_BUFFER_INFO_INDEX (19)
#define | STOPPED_BY_GDD_PROBLEM (3)
#define | STOPPED_BY_NO_BUFFER_FOUND (2)
#define | STOPPED_BY_USER_CANCEL (1)
#define | STOPPED_NORMALLY (0)

Define Documentation

#define Apoxi_StillCamera_hpp

#define MAX_BUFFER_INFO_INDEX (19)

Generated on Tue Jan 24 20:26:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/StillCamera.hpp Source File

Devices/MPEU/StillCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_StillCamera_hpp)
00010 #define Apoxi_StillCamera_hpp
00013
00014 #include <Auxiliary/DataSink.hpp>
00015 #include <Devices/MPEU/Camera.hpp>
00016 #include <AddOns/MultiMedia/JpegEncoder.hpp>
00017
00018 class RamData;
00019
00020 //send by m_cb_capture_finished()
00021 #define STOPPED_NORMALLY            (0)
00022 #define STOPPED_BY_USER_CANCEL      (1)
00023 #define STOPPED_BY_NO_BUFFER_FOUND  (2)
00024 #define STOPPED_BY_GDD_PROBLEM      (3)
00025
00026 //send by m_cb_image_captured()
00027 #define IMAGE_CAPTURED_OK           (0)
00028
00029 //send by m_cb_image_encoded()
00030 #define IMAGE_ENCODED_OK            (0)
00031
00033 class StillCamera : public Camera {
00034
00035     typedef Camera Base;
00036
00037     public:
00038         #include <Devices/StillCameraInterface.hpp>
00039
00042         virtual BOOLEAN Close();
00043
00044     protected:
00045         friend class CameraConfig;
00046
00047     private:
00048
00049         #define MAX_BUFFER_INFO_INDEX  (19)
00050
00051             enum CaptureState {
00052             Init,
00053             StartRunning,
00054             GetCaptureBuffer,
00055             ImageCaptured,
00056             ImageEncodingBegin,
00057             ImageEncoded,
00058             ErrorGetCaptureBuffer,
00059             ErrorImageCaptured,
00060             ErrorImageEncoded
00061         };
00062
00063             enum CallBackState {
00064             Nothing,
00065             CbGDDCaptureResult,
00066             CbJPEGImageEncoded
00067         };
00068
00069         typedef struct BufferInfoType {
00070                     BOOLEAN Use;
00071                     UINT16 PictNo;
00072                     CaptureState State;
00073                     UINT32 Buflen;
00074                     UINT8 HUGE* BufPtr;
00075                     RamData* RamDataPtr;
00076                     Image::MetaData* MetaDataPtr;
00077                     DataSink* TargetSinkPtr;
00078                 } BufferInfoType;
00079
00080         UINT16 m_no_of_pictures;
00081         UINT16 m_picture_counter;
00082         INT m_jpeg_quality;
00083         BOOLEAN m_capture_in_use;
00084         DataSink* m_target_sink_ptr;
00085         INT       m_image_buffer_counter;
00086
00087         static CbImageCaptured m_cb_image_captured;
00088         static CbImageEncoded m_cb_image_encoded;
00089         static CbCaptureFinished m_cb_capture_finished;
00090         static void* m_context_appl;
00091
00092         JpegEncoder::EncodingParameters* m_jpeg_encoder_param;
00093         JpegEncoder* m_jpeg_encoder;
00094
00095         static UINT32  m_pool_handle;
00096         UINT8          m_frame_rate_subsampling;
00097         static BOOLEAN m_capture_canceled;
00098                 static UINT32  m_jpeg_encoder_counter;
00099
00100                 BufferInfoType m_buffer_info[MAX_BUFFER_INFO_INDEX+1];
00101                 UINT16         m_buffer_info_index;
00102         // callbacks
00103         // callback from GDD for still camera, where buffer for raw data will be passed to
00104         static void Cb_GDD_GetCaptureBuffer(void* context, UINT8 HUGE **buffer, UINT32 size);
00105
00106         // callback from GDD where an image has been captured as RAW data in to buffer
00107         static void Cb_GDD_ImageCaptured    (INT result, void* context, UINT8 HUGE* captured_buffer, UINT32 size);
00108
00109         // callback from GDD for the asynchronous result
00110         static void Cb_GDD_CaptureResult(INT result, void* context);
00111
00112         // callback from JpegEncoder, when an RAW data image has been encoded to JPEG
00113         static void Cb_JPEG_ImageEncoded    (INT result, void* context, DataSink& sink);
00114
00115         BOOLEAN         DeleteOneImageBuffer(UINT8 HUGE* buff_ptr);
00116         BOOLEAN         DeleteOneMetaBuffer(Image::MetaData* MetaDataPtr);
00117         BOOLEAN         FreeImageBuffer();
00118         BOOLEAN         GetImageBuffer(UINT8 no_of_pictures, ImageSizeType size);
00119         BOOLEAN         Encode(BufferInfoType* bufferInfoPtr,UINT32 length);
00120         void            DeleteJpegSoftwareEncoder();
00121         void            DeleteJpegSoftwareEncoderCallBack(CallBackState state);
00122         BOOLEAN         SetJpegSoftwareEncoder(XYDIM width, XYDIM height, INT quality_level);
00123         BOOLEAN         IsMultiShot();
00124         BOOLEAN         GetOneImageBuffer(UINT8 HUGE **buffer);
00125         BufferInfoType* GetUsedImageBuffer(UINT8 HUGE* captured_buffer);
00126         BufferInfoType* GetUsedImageBuffer(DataSink* sink);
00127         BufferInfoType* GetNextImageBuffer(DataSink* sink);
00128         BOOLEAN         DeleteAllUsedImageBuffer();
00129         BOOLEAN         ResetAllBufferInfo(UINT16 MaxNumber,DataSink** sink_ptr);
00130         UINT16          GetNofEncodeImages();
00131         static  void    SetCancleFlag(BOOLEAN capture_cancled);
00132         static  BOOLEAN GetCancleFlag();
00133
00134                 typedef void (*Cb_JpegEncoded)(INT result, void* context, DataSink* dest);
00135 };
00136
00138 #endif  // Apoxi_StillCamera_hpp
00139
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VideoCamera.cpp File Reference

Devices/MPEU/VideoCamera.cpp File Reference

#include "PreComp.hpp"
#include "VideoCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for VideoCamera.cpp:

Defines

#define | DEACTIVATE_SET_CAPTURE_IMAGE_FORMAT
#define | DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE (30620)
#define | DEBUG_VIDEOCAMERA_CPP
#define | TRACE1LN(x, n) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n))
#define | TRACE2LN(x, n, o) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o))
#define | TRACE3LN(x, n, o, p) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p))
#define | TRACE4LN(x, n, o, p, q) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p, q))
#define | TRACELN(x) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x))

Variables

const INT | c_bytes_per_pixel_of_rawdata = 2

Define Documentation

#define DEACTIVATE_SET_CAPTURE_IMAGE_FORMAT

#define DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE (30620)

#define DEBUG_VIDEOCAMERA_CPP

#define TRACE1LN | ( | x,
 |  | n | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n))

#define TRACE2LN | ( | x,
 |  | n,
 |  | o | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o))

#define TRACE3LN | ( | x,
 |  | n,
 |  | o,
 |  | p | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p))

#define TRACE4LN | ( | x,
 |  | n,
 |  | o,
 |  | p,
 |  | q | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p, q))

#define TRACELN ( x ) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x))

Variable Documentation

const INT c_bytes_per_pixel_of_rawdata = 2

Generated on Tue Jan 24 20:27:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VideoCamera.hpp File Reference

Devices/MPEU/VideoCamera.hpp File Reference

#include <Kernel/System.hpp>
#include <Kernel/Types.hpp>
#include <Devices/MPEU/Camera.hpp>
#include <Devices/VideoCameraInterface.hpp>

Include dependency graph for VideoCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoCamera

Defines

#define | Apoxi_VideoCamera_hpp

Define Documentation

#define Apoxi_VideoCamera_hpp

Generated on Tue Jan 24 20:27:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VideoCamera.hpp Source File

Devices/MPEU/VideoCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VideoCamera_hpp)
00010 #define Apoxi_VideoCamera_hpp
00013
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/Types.hpp>
00016 #include <Devices/MPEU/Camera.hpp>
00017
00019 class VideoCamera : public Camera {
00020     typedef Camera Base;
00021
00022     public:
00023         #include <Devices/VideoCameraInterface.hpp>
00024
00025     protected:
00026         friend class CameraConfig;
00027
00028     private:
00029
00031         static void GetCaptureBuffer_GDD_CB(void*, UINT8 HUGE ** buffer, UINT32 size);
00032
00034         static void VideoFrameCaptured_GDD_CB(int result, void* context, UINT8 HUGE * buffer, UINT32 buf_len_used);
00035
00037         static void NotifyCaptureBufferStatus_GDD_CB(void* context, UINT8 free_buffer_count);
00038
00040         FrameRateType m_framerate;
00041
00043         static UINT32 m_buffer_length;
00044
00046         static UINT32 m_starting_time;          // frame count or timestamp
00047
00049         static UINT32 m_pool_handle;
00050
00053         static void* m_context;
00054
00055         static Cb_NotifyCaptureBufferStatus m_cb_notify_status;
00056         static Cb_FrameCaptured m_cb_frame_captured;
00057         static Cb_VideoCaptureStopped m_cb_video_capture_stopped;
00058         static Cb_VideoCapturePaused m_cb_video_capture_paused;
00059 };
00060
00062 #endif  // Apoxi_VideoCamera_hpp
00063
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VideoChannel.cpp File Reference

Devices/MPEU/VideoChannel.cpp File Reference

#include "PreComp.hpp"
#include "VideoChannel.hpp"
#include <stack/driver.h>

Include dependency graph for VideoChannel.cpp:

Generated on Tue Jan 24 20:28:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VideoChannel.hpp File Reference

Devices/MPEU/VideoChannel.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for VideoChannel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoChannel
struct | VideoChannel::StateFlags

Defines

#define | Apoxi_Devices_MPEU_VideoChannel_hpp

Define Documentation

#define Apoxi_Devices_MPEU_VideoChannel_hpp

Generated on Tue Jan 24 20:28:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VideoChannel.hpp Source File

Devices/MPEU/VideoChannel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_MPEU_VideoChannel_hpp)
00010 #define Apoxi_Devices_MPEU_VideoChannel_hpp
00011
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Rect.hpp>
00017
00026 class VideoChannel {
00027
00028     public:
00029
00030 #ifdef APOXI_COMPAT_2_8_0
00031
00034         enum VideoParameterType {
00036             Rotate,
00038             Mirror,
00040             Flip,
00042             Antitearing,
00044             SmartOverlays,
00046             YuvToRgbConversion,
00048             ZoomFactorHorizontalMin,
00050             ZoomFactorHorizontalMax,
00052             ZoomFactorVerticalMin,
00054             ZoomFactorVerticalMax
00055         };
00056 #endif // APOXI_COMPAT_2_8_0
00057
00059         enum TransformationType {
00060             NoTransformation,
00061             Rotation90Transformation,
00062             Rotation180Transformation,
00063             Rotation270Transformation,
00064             MirrorTransformation,
00065             MirrorRotate90Transformation,
00066             MirrorRotate180Transformation,  // same as flip
00067             MirrorRotate270Transformation
00068         };
00069
00070         enum ScalingMethodType {
00071             NoScaling,
00072             LetterboxScaling,
00073             BestFitScaling
00074         };
00075
00076         enum VideoAndViewfinderOrderType {
00077             ViewfinderOverVideoPlayback,
00078             VideoPlaybackOverViewfinder
00079         };
00080
00090         typedef void (*CbResult)(   BOOLEAN result,
00091                                     void* context);
00092
00093 #ifdef APOXI_COMPAT_2_8_0
00094
00105         typedef void (*CbVideoFrameRendered)(INT result,
00106                                             void* context,
00107                                             const UINT8 HUGE* frame_buf);
00108
00120         typedef void (*CbVideoFrameRenderedNew)(BOOLEAN result,
00121                                             void* context,
00122                                             const UINT8 HUGE* frame_buf);
00123 #else // APOXI_COMPAT_2_8_0
00124
00136         typedef void (*CbVideoFrameRendered)(BOOLEAN result,
00137                                             void* context,
00138                                             const UINT8 HUGE* frame_buf);
00139 #endif // APOXI_COMPAT_2_8_0
00140
00144         VideoChannel(INT display_idx = 0);
00145
00146         ~VideoChannel();
00147
00148 #ifdef APOXI_COMPAT_2_8_0
00149
00162         BOOLEAN Open(Rect& video_frame_rect, CbVideoFrameRendered cb_frame_rendered, void* context = 0);
00163
00175         BOOLEAN Open(CbVideoFrameRenderedNew cb_frame_rendered, void* context);
00176 #else // APOXI_COMPAT_2_8_0
00177
00189         BOOLEAN Open(CbVideoFrameRendered cb_frame_rendered, void* context);
00190 #endif // APOXI_COMPAT_2_8_0
00191
00193         void Close();
00194
00204         BOOLEAN Start(CbResult cb_video_channel_started, void* context);
00205
00215         BOOLEAN Stop(CbResult cb_video_channel_stopped, void* context);
00216
00227         void RenderFrame(void* frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame = FALSE);
00228
00232         BOOLEAN IsOpen() const;
00233
00236         UINT32 GetRefreshDelay() const;
00237
00238 #ifdef APOXI_COMPAT_2_8_0
00239
00244         BOOLEAN SetParam(VideoParameterType type, UINT32 value);
00245
00252         BOOLEAN GetParam(VideoParameterType type, UINT32* value) const;
00253 #endif // APOXI_COMPAT_2_8_0
00254
00255 #ifdef APOXI_COMPAT_2_6_0
00256
00264         void SetSize(Size video_size)
00265         {
00266         #ifdef APOXI_COMPAT_2_8_0
00267             SetVideoSize(video_size);
00268         #endif //  APOXI_COMPAT_2_8_0
00269         }
00270 #endif // APOXI_COMPAT_2_6_0
00271
00272 #ifdef APOXI_COMPAT_2_8_0
00273
00280         void SetVideoSize(Size video_size);
00281 #endif // APOXI_COMPAT_2_8_0
00282
00294         BOOLEAN SetVideoSize(   Size actual_video_size,
00295                                 Size extended_video_size,
00296                                 Point left_top_offset);
00297
00298 #ifdef APOXI_COMPAT_2_8_0
00299
00310         BOOLEAN SetCropRect(Rect& crop_rect);
00311 #endif // APOXI_COMPAT_2_8_0
00312
00326         BOOLEAN SetCropRect(Rect& crop_rect, Rect& effective_playback_rect);
00327
00328 #ifdef APOXI_COMPAT_2_6_0
00329
00336         BOOLEAN AdjustFrameRect(Rect& video_frame_rect)
00337         {
00338         #ifdef APOXI_COMPAT_2_8_0
00339             return SetFrameRect(video_frame_rect);
00340         #else
00341             return FALSE;
00342         #endif //  APOXI_COMPAT_2_8_0
00343         }
00344 #endif // APOXI_COMPAT_2_6_0
00345
00346 #ifdef APOXI_COMPAT_2_8_0
00347
00354         BOOLEAN SetFrameRect(Rect& video_frame_rect);
00355 #endif // APOXI_COMPAT_2_8_0
00356
00368         BOOLEAN SetPlaybackRect(Rect& playback_rect,
00369                                 TransformationType playback_transformation,
00370                                 ScalingMethodType scaling_method);
00371
00372 #ifdef APOXI_COMPAT_2_8_0
00373
00384         BOOLEAN QueryRects(Rect& video_frame_rect, Rect& crop_rect);
00385 #endif // APOXI_COMPAT_2_8_0
00386
00397         BOOLEAN SetPlaybackAndViewfinderOrder(
00398                             VideoAndViewfinderOrderType video_viewfinder_order);
00399
00400     private:
00401
00403         enum StateType {
00404             IdleState = 0,
00405             OpeningState,
00406             OpenState,
00407             StartingState,
00408             StartedState,
00409             StoppingState,
00410             ClosingState
00411         };
00412
00413         struct StateFlags {
00414             UINT m_state                        :3;
00415             UINT m_video_size_set               :1;
00416             UINT m_playback_rect_set            :1;
00417         };
00418
00419         static void CbNotifyVideoFrameRendered( INT result,
00420                                                 void *context,
00421                                                 UINT8 * frame_buf);
00422         static void CbNotifyStarted(INT result, void* context);
00423         static void CbNotifyStopped(INT result, void* context);
00424
00425 #ifdef APOXI_COMPAT_2_8_0
00426         CbVideoFrameRenderedNew m_cb_video_frame_rendered;
00427 #else // APOXI_COMPAT_2_8_0
00428         CbVideoFrameRendered    m_cb_video_frame_rendered;
00429 #endif // APOXI_COMPAT_2_8_0
00430         CbResult                m_cb_stopped;
00431         CbResult                m_cb_started;
00432
00433         INT                 m_display_idx;
00434         StateFlags          m_flags;
00435
00436         TransformationType  m_transformation;
00437         ScalingMethodType   m_scaling_method;
00438         Rect                m_playback_rect;
00439         Rect                m_effective_playback_rect;
00440         Rect                m_crop_rect;
00441         Rect                m_actual_video_rect;
00442         Size                m_extended_video_size;
00443         void*               m_client_context_frame_rendered;
00444         void*               m_client_context_start;
00445         void*               m_client_context_stop;
00446
00452         BOOLEAN ConvertResultCode(INT result_code);
00453
00454         void ResetVideoChannel();
00455
00456 };
00457
00459 #endif  // Apoxi_Devices_MPEU_VideoChannel_hpp
00460
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VirtualDisplay.cpp File Reference

Devices/MPEU/VirtualDisplay.cpp File Reference

#include "PreComp.hpp"
#include "VirtualDisplay.hpp"
#include "../SharedMethods/Ddrv.cpp"
#include <Devices/DeviceManager.hpp>
#include "../SharedMethods/SetPixel_16Bpp.cpp"
#include "../SharedMethods/FillRect_16Bpp.cpp"
#include "../SharedMethods/BitBlit_16Bpp.cpp"
#include "../SharedMethods/ScrollHorizontal_16Bpp.cpp"
#include "../SharedMethods/ScrollVertical_16Bpp.cpp"
#include "../SharedMethods/DrawChar_16Bpp.cpp"
#include "../SharedMethods/ConvertToColorValue_Bpp.cpp"
#include "../SharedMethods/GetPixelColor_16Bpp.cpp"

Include dependency graph for VirtualDisplay.cpp:

Generated on Tue Jan 24 20:28:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VirtualDisplay.hpp File Reference

Devices/MPEU/VirtualDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/Rect.hpp>
#include <Gui/ColorTable.hpp>
#include <Gui/Color.hpp>
#include <Gui/Font.hpp>
#include <Kernel/Os/SystemTimer.hpp>

Include dependency graph for VirtualDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ScanlineAccessor
class | VirtualDisplay

Defines

#define | Apoxi_Devices_MPEU_VirtualDisplay_hpp

Define Documentation

#define Apoxi_Devices_MPEU_VirtualDisplay_hpp

Generated on Tue Jan 24 20:28:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/VirtualDisplay.hpp Source File

Devices/MPEU/VirtualDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_MPEU_VirtualDisplay_hpp)
00010 #define Apoxi_Devices_MPEU_VirtualDisplay_hpp
00013
00014 class VideoChannel;
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Devices/AbstractDevice.hpp>
00018 #include <Gui/Bitmap.hpp>
00019 #include <Gui/Rect.hpp>
00020 #include <Gui/ColorTable.hpp>
00021 #include <Gui/Color.hpp>
00022 #include <Gui/Font.hpp>
00023 #include <Kernel/Os/SystemTimer.hpp>
00024
00029 class VirtualDisplay : public AbstractDevice {
00030     typedef AbstractDevice Base;
00031
00032     public:
00034         enum Type {
00036             Monochrome,
00038             Planes2,
00040             Planes4,
00042             Planes8,
00044             BitsPerPixel8,
00046             BitsPerPixel16,
00048             BitsPerPixel24,
00050             BitsPerPixel32
00051         };
00052
00054         VirtualDisplay(INT index = 0);
00055
00068         VirtualDisplay(XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00069
00071         VirtualDisplay(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00072
00074         virtual ~VirtualDisplay();
00075
00088         void Init(XYDIM width, XYDIM height,  INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00089
00091         void Init(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00092
00094         virtual const WCHAR* GetName() const;
00095
00097         ControlArg Control(INT command, ControlArg arg);
00098
00100         XYDIM GetWidth() const { return m_bitmap.GetWidth();}
00101
00103         XYDIM GetHeight() const { return m_bitmap.GetHeight(); }
00104
00106         Bitmap* GetBitmap() { return &m_bitmap; }
00107
00109         Type GetType() { return m_type; }
00110
00114         void SetBlitRect(const Rect& rect = Rect()) { m_blit_rect = rect; }
00115
00117         const Rect& GetBlitRect() const { return m_blit_rect; };
00118
00121         void AdjustBlitRect(const Rect& rect) { m_blit_rect.Union(rect); }
00122
00125         virtual void Refresh();
00126
00129         void SetPixel(XYDIM x, XYDIM y);
00130
00133         void FillRect(const Rect& rect);
00134
00144             void BitBlit(XYDIM dest_x,
00145                      XYDIM dest_y,
00146                      const BitmapRes& bmp,
00147                      const Rect& clip_rect,
00148                      UINT8 trans_mode = 0);
00149
00154         void Scroll(const Rect& rect, XYDIM dx, XYDIM dy);
00155
00158         void DrawChar(XYDIM x, XYDIM y, const Glyph& glyph, INT height);
00159
00161         void SetColorValue(ColorValue color_value, UINT8 alpha = 255);
00162
00164         ColorValue GetColorValue() const { return m_color_value; }
00165
00167         void SetColor(Color color);
00168
00170         Color GetColor() const { return m_color; }
00171
00176         ColorValue ConvertToColorValue(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const;
00177
00179         Color GetPixelColor(XYDIM x, XYDIM y) const;
00180
00182         INT GetScanlineAtomCount() const { return m_scanline_atom_count; }
00183
00186         void SetAlphaBlendingMode(BOOLEAN mode) {
00187                                                     #ifdef APOXI_ENABLE_ALPHA_BLENDING
00188                                                         m_alpha_mode = mode;
00189                                                     #endif
00190                                                 }
00191
00193         BOOLEAN GetAlphaBlendingMode() const {
00194                                                 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00195                                                     return m_alpha_mode;
00196                                                 #else
00197                                                     return TRUE;
00198                                                 #endif
00199                                                 }
00200     private:
00201 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00202         BOOLEAN m_alpha_mode;
00203 #endif
00204         Bitmap m_bitmap;
00205         Rect m_blit_rect;
00206         Type m_type;
00207         ColorValue m_color_value;
00208         Color m_color;
00209         INT m_pixel_atom_count;
00210         INT m_scanline_atom_count;
00211         INT m_plane_count;
00212         INT m_scanline_inc;
00213         INT m_plane_inc;
00214         DDrvAtomPtr m_data;
00215         DDrvAtomPtr m_scanline_buffer;
00216
00217         void ScrollHorizontal(const Rect& rect, XYDIM dx);
00218         void ScrollVertical(const Rect& rect, XYDIM dy);
00219 };
00220
00223 class ScanlineAccessor {
00224     public:
00229         ScanlineAccessor(VirtualDisplay* display, XYDIM x, XYDIM y, XYDIM width) :
00230             m_data((UINT16 GDI_HUGE*)display->GetBitmap()->GetBits()),
00231             m_count(width)
00232         {
00233             m_data += (display->GetScanlineAtomCount() >> 1) * y + x;
00234         }
00235
00237         BOOLEAN HasNext() { return (m_count > 0); };
00238
00240         void Draw(UINT8 red, UINT8 green, UINT8 blue)
00241         {
00242             *m_data = ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)));
00243
00244             #if defined(APOXI_DISPLAY_FORMAT_BIG_ENDIAN)
00245                 *m_data = ((*m_data & 0xffU) << 8U) | ((*m_data & 0xff00U)) >> 8U;
00246             #endif
00247             m_data++;
00248             m_count--;
00249         }
00250
00251         void Draw(ColorValue cv)
00252         {
00253             *m_data = cv;
00254             m_data++;
00255             m_count--;
00256         }
00257
00261         void Next() {
00262             m_data++;
00263             m_count--;
00264         }
00265
00266     private:
00268         UINT16 GDI_HUGE* m_data;
00270         XYDIM m_count;
00271
00272 };
00273
00275 #endif  // Apoxi_Devices_MPEU_VirtualDisplay_hpp
00276
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.cpp File Reference

#include "PreComp.hpp"
#include "AtiUtils.hpp"
#include "AtiConfig.hpp"
#include "AtiAudioCapturerEncoder.hpp"

Include dependency graph for AtiAudioCapturerEncoder.cpp:

Generated on Tue Jan 24 20:30:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>
#include <AddOns/CodecManager/AudioCapturerEncoder.hpp>
#include <gci_common.h>
#include <gci_audio.h>

Include dependency graph for AtiAudioCapturerEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtiAudioCapturerEncoder
struct | AtiAudioCapturerEncoder::StateFlags

Defines

#define | AtiAudioCapturerEncoder_hpp

Define Documentation

#define AtiAudioCapturerEncoder_hpp

Generated on Tue Jan 24 20:30:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtiAudioCapturerEncoder_hpp)
00010 #define AtiAudioCapturerEncoder_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/CodecDevice.hpp>
00018 #include <AddOns/CodecManager/AudioCapturerEncoder.hpp>
00019
00020 extern "C"{
00021 #include <gci_common.h>
00022 #include <gci_audio.h>
00023 }
00024
00026 class AtiAudioCapturerEncoder : public AudioCapturerEncoder {
00027     public:
00029         virtual ~AtiAudioCapturerEncoder();
00030
00032         virtual ResultType GetProperties(Properties& properties);
00033
00035         virtual ResultType Open(AudioChannel& audio_channel);
00036
00038         virtual void Close();
00039
00041         virtual ResultType RegisterCallbackFunctions(
00042                                         void* context,
00043                                         CbReady cb_data_available);
00044
00046         virtual ResultType GetAudioChannelId(AudioChannel& audio_channel);
00047
00049         virtual ResultType ConfigureAMR(    AmrIfFormat amr_if_format,
00050                                             EncQualityConfig quality_config,
00051                                             AmrDtxConfig dtx_config,
00052                                             UINT32 max_buffer_size);
00053
00055         virtual ResultType ConfigureAAC(    AacFormat aac_encoding_format,
00056                                             UINT16 sampling_rate,
00057                                             EncQualityConfig quality_config,
00058                                             MonoSteroConfig monostero_config,
00059                                             UINT32 max_buffer_size);
00060
00062         virtual ResultType GetBuffer(AudioIOBuffer** buffer);
00063
00064     protected:
00066         virtual ResultType SetCodec(CodecType codec);
00067
00068     private:
00070         typedef UINT8 t_ati_codec_max_num_of_audio_cap_enc_inst;
00071         static const t_ati_codec_max_num_of_audio_cap_enc_inst  c_ati_codec_max_num_of_audio_cap_enc_inst = 1;
00072
00074         enum StateType {
00075             IdleState = 0,
00076             ConfiguredState,
00077             RunningState
00078         };
00079
00080         struct StateFlags {
00081             UINT m_state                        :3;
00082             UINT m_callback_funcs_registered    :1;
00083         };
00084
00086         StateFlags m_flags;
00087
00089         AudioChannel m_audio_channel;
00090
00096         CbReady m_client_cb_data_available;
00097
00101         void* m_client_context;
00102
00104         CodecType m_codec;
00105
00108         static AtiAudioCapturerEncoder*
00109             m_exist_this_ptr_array[c_ati_codec_max_num_of_audio_cap_enc_inst];
00110
00112         AtiAudioCapturerEncoder();
00113
00118         static void CbDataAvailable(void* context);
00119
00127         static BOOLEAN IsValidContext(void* context);
00128
00130         void ResetAtiAudioCapturerEncoder();
00131
00132 friend class AtiCodecsLib; // creates/destroys the AtiAudioCapturerEncoder
00133 };
00134
00136 #endif // AtiAudioCapturerEncoder_hpp
00137
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.cpp File Reference

#include "PreComp.hpp"
#include "AtiUtils.hpp"
#include "AtiConfig.hpp"
#include "AtiAudioDecoderRenderer.hpp"

Include dependency graph for AtiAudioDecoderRenderer.cpp:

Generated on Tue Jan 24 20:31:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/AudioDecoderRenderer.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>
#include <gci_common.h>
#include <gci_audio.h>

Include dependency graph for AtiAudioDecoderRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtiAudioDecoderRenderer
struct | AtiAudioDecoderRenderer::StateFlags

Defines

#define | AtiAudioDecoderRenderer_hpp

Define Documentation

#define AtiAudioDecoderRenderer_hpp

Generated on Tue Jan 24 20:31:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtiAudioDecoderRenderer_hpp)
00010 #define AtiAudioDecoderRenderer_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/AudioDecoderRenderer.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/CodecDevice.hpp>
00018
00019 extern "C"{
00020 #include <gci_common.h>
00021 #include <gci_audio.h>
00022 }
00023
00026 class AtiAudioDecoderRenderer : public AudioDecoderRenderer {
00027
00028 //------------------------------------------------------------------------------
00029     public:
00030 //------------------------------------------------------------------------------
00032         virtual ~AtiAudioDecoderRenderer();
00033
00035         virtual ResultType GetProperties(Properties& properties);
00036
00038         virtual ResultType Open(AudioChannel& audio_channel);
00039
00041         virtual void Close();
00042
00044         virtual ResultType RegisterCallbackFunctions(void* context,
00045                                                      CbReady cb_ready_for_data,
00046                                                      CbResult cb_all_buffers_processed);
00047
00049         virtual ResultType DecodeRenderBuffer(AudioIOBuffer* buffer);
00050
00052         virtual ResultType GetAudioChannelId(AudioChannel& audio_channel);
00053
00054
00055 //------------------------------------------------------------------------------
00056     protected:
00057 //------------------------------------------------------------------------------
00058
00060         virtual ResultType SetCodec(CodecType codec);
00061
00062
00063
00064 //------------------------------------------------------------------------------
00065     private:
00066 //------------------------------------------------------------------------------
00068         typedef UINT8 t_ati_codec_max_num_of_audio_dec_rend_inst;
00069         static const t_ati_codec_max_num_of_audio_dec_rend_inst c_ati_codec_max_num_of_audio_dec_rend_inst = 2;
00070
00072         enum StateType {
00073             IdleState = 0,
00074             ConfiguredState,
00075             RunningState
00076         };
00077
00078         struct StateFlags {
00079             UINT m_state                        :3;
00080             UINT m_callback_funcs_registered    :1;
00081         };
00082
00084         StateFlags m_flags;
00085
00087         AudioChannel m_audio_channel;
00088
00090         tGciAudioInputBuffer m_gci_input_buffer;
00091
00096         static void CbReadyForData(void* context);
00097
00103         static void CbAllBuffersProcessed(tGciResult result, void* context);
00104
00110         CbReady m_client_cb_ready_for_data;
00111
00112
00117         CbResult m_client_cb_all_buffers_processed;
00118
00122         void* m_client_context;
00123
00125         CodecType m_codec;
00126
00128         AtiAudioDecoderRenderer();
00129
00131         void ResetAudioDecoderRenderer();
00132
00135         static AtiAudioDecoderRenderer*
00136             m_exist_this_ptr_array[c_ati_codec_max_num_of_audio_dec_rend_inst];
00137
00145         static BOOLEAN IsValidContext(void* context);
00146
00147     friend class CodecManager;
00148     friend class AtiCodecsLib; // creates/destroys AtiAudioDecoderRenderer
00149 };
00150
00152 #endif // AtiAudioDecoderRenderer_hpp
00153
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.cpp File Reference

#include "PreComp.hpp"
#include "AtiAudioPlayer.hpp"
#include <Config/AudioConfig.hpp>
#include <Audio/AudioPlayerEvent.hpp>
#include <Audio/AudioPlayer.hpp>
#include <Audio/AudioPriorityManager.hpp>
#include <Audio/AudioPathManager.hpp>
#include <Audio/AudioUtility.hpp>
#include <Audio/VoiceMemoAudioReference.hpp>
#include <Audio/GenericFeatureData.hpp>
#include <Auxiliary/BinData.hpp>
#include <Auxiliary/RamData.hpp>
#include <Auxiliary/FileBinData.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Ffs/FfsTypes.hpp>
#include <Audio/Messages/AudioGetPlayPositionMsg.hpp>
#include <Audio/Messages/AudioRestartedMsg.hpp>
#include <Kernel/Threadlet.hpp>

Include dependency graph for AtiAudioPlayer.cpp:

Generated on Tue Jan 24 20:31:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.hpp File Reference

#include <Audio/CombinedDeviceAudioReference.hpp>
#include <Audio/TimeFeatureObject.hpp>
#include <Audio/StreamAudioPlayer.hpp>
#include <Audio/RtStreaming/DataSourceRtStreamingSource.hpp>
#include <gci_common.h>
#include <gci_audio.h>
#include "AtiAudioPlayerRtStreamingConn.hpp"
#include "AtiAudioPlayerRtStreamingSink.hpp"
#include "NonsharedBinDataDataSource.hpp"

Include dependency graph for AtiAudioPlayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AudioNewAPI_AtiAudioPlayer_hpp

Define Documentation

#define Apoxi_AudioNewAPI_AtiAudioPlayer_hpp

Generated on Tue Jan 24 20:31:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AudioNewAPI_AtiAudioPlayer_hpp)
00011 #define Apoxi_AudioNewAPI_AtiAudioPlayer_hpp
00014
00015 #include <Audio/CombinedDeviceAudioReference.hpp>
00016 #include <Audio/TimeFeatureObject.hpp>
00017 #include <Audio/StreamAudioPlayer.hpp>
00018 #include <Audio/RtStreaming/DataSourceRtStreamingSource.hpp>
00019
00020 #include <gci_common.h>
00021 #include <gci_audio.h>
00022
00023 #include "AtiAudioPlayerRtStreamingConn.hpp"
00024 #include "AtiAudioPlayerRtStreamingSink.hpp"
00025 #include "NonsharedBinDataDataSource.hpp"
00026
00027 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00028
00031 class AtiAudioPlayer : public StreamAudioPlayer
00032 {
00033
00034     friend class AtiAudioPlayerRtStreamingSink;
00035
00036     public:
00037         AtiAudioPlayer();
00038         virtual ~AtiAudioPlayer();
00039
00043         void Initialize();
00044
00045         virtual AudioSourceType GetSource() const; //override
00046
00050         virtual void Play(AudioActiveReference& active_reference);
00051
00055         virtual void Stop(AudioActiveReference& active_reference);
00056
00061         virtual BOOLEAN CanSuspend(const AudioActiveReference& active_reference) const;
00062
00067         virtual BOOLEAN CanPlay(const AudioActiveReference& active_reference) const;
00068
00072         virtual BOOLEAN CanResume(const AudioActiveReference& active_reference) const;
00073
00077         virtual void Suspend(AudioActiveReference& active_reference);
00078
00082         virtual void ResumeSuspended(AudioActiveReference& active_reference);
00083
00088         virtual SharedPtr<AudioActiveReference> StartRecording(const AudioReference &audio_ref);
00089
00090         /* Stop recording.
00091          * @param active_reference A reference to the active recording.
00092          */
00093         virtual void StopRecording(AudioActiveReference &active_reference);
00094
00101         virtual BOOLEAN IsFeatureSupported(Feature feature, MimeType mime_type = c_mime_unknown, AudioReference::SoundDataSource sound_data_source = AudioReference::InvalidSoundDataSource) const;
00102
00110         virtual BOOLEAN ExecuteFeature(Feature feature, GenericObject* data = 0);
00111
00115         virtual SharedPtr<AudioReference> CreateAudioReferenceFromStream(MimeType mime_type, GetAudioBufferFunction func, void* user_data = 0);
00116
00120         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, Buffer buffer, UINT32 buffer_size);
00121
00125         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRamBuffer(MimeType mime_type, ConstBuffer buffer, UINT32 buffer_size);
00126
00130         virtual SharedPtr<AudioReference> CreateAudioReferenceFromRfsFile(MimeType mime_type, const Path& path);
00131
00135         virtual SharedPtr<AudioReference> CreateAudioReferenceFromBinData(MimeType mime_type, BinData* bin_data);
00136
00143         virtual BOOLEAN GetPlayPosition(AudioActiveReference &active_reference);
00144
00151         virtual BOOLEAN GetTotalPlayTime(AudioActiveReference &active_reference);
00152
00153         static AudioDeviceBase* GetInstance();
00154         virtual Vector<MimeTypeSupportInfo> GetMimeTypeSupportInfo() const;
00155
00156         //function is called when error occurs in playback
00157         void OnDriverError(AudioActiveReference& active_reference, AudioError::AudReturnCode error_code);
00158         //function is called when error occurs while reading data
00159         void OnSourceError(AudioActiveReference& active_reference, AudioError::AudReturnCode error_code);
00160
00161     protected:
00162
00163         virtual UINT16 GetDeviceID() const;//override
00164
00165         virtual BOOLEAN Play_Allocate(AudioActiveReference &audio_ref);
00166
00167         //GCI callbacks
00168
00169         static void OnCbCommonStart(tGciResult result, void* context);
00170         static void OnCbCommonStop(tGciResult result, void* context);
00171         static void OnCbCommonStartRecord(tGciResult result, void* context);
00172         static void OnCbCommonStopRecord(tGciResult result, void* context);
00173         static void OnCbCommonResume(tGciResult result, void* context);
00174         static void OnCbCommonAllBuffersProcessed(tGciResult result, void* context);
00175         static void OnCbSuspend(tGciResult result, CombinedDeviceAudioReference::TimeStampType time, tGciAudionegByteOffset negByteOffset, void* context);
00176         static void OnCbReady(void* context);
00177         static void OnCbReadyStreaming(void* context);
00178         static void OnCbNotification(tGciAudioNotification notification, void* context);
00179
00180         Semaphore m_wait_semaphore;
00181
00182         //Boolean value which is set to TRUE only when XMF,AMR or WAVE playback finishes till the end
00183         BOOLEAN m_finished;
00184
00185     private:
00186
00187         static AtiAudioPlayer m_singleton_instance;
00188
00189         //Map containing the pairs of GciHandles and apropriate buffers allocated for playback
00190         SimpleMap<UINT32, UINT8*> m_buffers;
00191
00192         //m_handle_counter contains the number of currently allocated GCI handles
00193         INT8 m_handle_counter;
00194
00195         //needed for transfering time between callback and the function which is waiting
00196         UINT32 m_time;
00197
00198         // Gci handle used for CbDataReady callback
00199         tGciAudioHandle *m_gci_handles[3];
00200
00201         // Sources and Sinks for streaming
00202         DataSourceRtStreamingSource *m_srcs[3];
00203         AtiAudioPlayerRtStreamingSink *m_snks[3];
00204         AtiAudioPlayerRtStreamingConn *m_conns[3];
00205
00206 };
00207 #endif //DOXYGEN_SHOULD_SKIP_THIS
00208
00210 #endif  // Apoxi_AudioNewAPI_AtiAudioPlayer_hpp
00211
00212
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.cpp File Reference

#include <Audio/AudioPreComp.hpp>
#include "AtiAudioPlayerRtStreamingConn.hpp"
#include <Audio/RtStreaming/RtStreamingSink.hpp>
#include <Audio/RtStreaming/RtStreamingSource.hpp>

Include dependency graph for AtiAudioPlayerRtStreamingConn.cpp:

Generated on Tue Jan 24 20:31:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.hpp File Reference

#include <Audio/RtStreaming/RtStreamingConn.hpp>

Include dependency graph for AtiAudioPlayerRtStreamingConn.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtiAudioPlayerRtStreamingConn

Defines

#define | Apoxi_AtiAudioPlayerRtStreamingConn_hpp

Define Documentation

#define Apoxi_AtiAudioPlayerRtStreamingConn_hpp

Generated on Tue Jan 24 20:31:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_AtiAudioPlayerRtStreamingConn_hpp)
00010 #define Apoxi_AtiAudioPlayerRtStreamingConn_hpp
00011
00012 #include <Audio/RtStreaming/RtStreamingConn.hpp>
00013
00014 class AtiAudioPlayerRtStreamingSink;
00015 class DataSourceRtStreamingSource;
00016
00018 class AtiAudioPlayerRtStreamingConn : public RtStreamingConn{
00019
00020     public:
00021
00022         AtiAudioPlayerRtStreamingConn(AtiAudioPlayerRtStreamingSink *snk, DataSourceRtStreamingSource *src);
00023
00024     protected:
00025
00026     private:
00027
00028 };
00029
00030 #endif  // Apoxi_AtiAudioPlayerRtStreamingConn_hpp
00031
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.cpp File Reference

#include "Audio/AudioPreComp.hpp"
#include "AtiAudioPlayerRtStreamingSink.hpp"
#include <Kernel/ApoxiThread.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/Os/Semaphore.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for AtiAudioPlayerRtStreamingSink.cpp:

Generated on Tue Jan 24 20:31:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.hpp File Reference

#include <Audio/RtStreaming/RtStreamingConn.hpp>
#include <Audio/RtStreaming/RtStreamingSource.hpp>
#include <Audio/RtStreaming/RtStreamingSink.hpp>
#include <Audio/RtStreaming/RtStreamingBuffer.hpp>
#include <gci_common.h>
#include <gci_audio.h>
#include <Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.hpp>

Include dependency graph for AtiAudioPlayerRtStreamingSink.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtiAudioPlayerRtStreamingSink

Defines

#define | Apoxi_AtiAudioPlayerRtStreamingSink_hpp

Define Documentation

#define Apoxi_AtiAudioPlayerRtStreamingSink_hpp

Generated on Tue Jan 24 20:31:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_AtiAudioPlayerRtStreamingSink_hpp)
00010 #define Apoxi_AtiAudioPlayerRtStreamingSink_hpp
00011
00012 #include <Audio/RtStreaming/RtStreamingConn.hpp>
00013 #include <Audio/RtStreaming/RtStreamingSource.hpp>
00014 #include <Audio/RtStreaming/RtStreamingSink.hpp>
00015 #include <Audio/RtStreaming/RtStreamingBuffer.hpp>
00016 #include <gci_common.h>
00017 #include <gci_audio.h>
00018 #include <Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayer.hpp>
00019
00020 class AtiAudioPlayerSinkThread;
00021
00022 class AtiAudioPlayerRtStreamingSink : public RtStreamingSink {
00023
00024     friend class AtiAudioPlayer;
00025     friend class AtiAudioPlayerSinkThread;
00026
00027 public:
00028     AtiAudioPlayerRtStreamingSink();
00029     AtiAudioPlayerRtStreamingSink(AudioActiveReference &audio_ref);
00030
00031     void ReleaseSemaphore() {m_wait_semaphore.Release();}
00032
00033 protected:
00034     virtual void StopOnCause (RtStreamingConn::StopCause cause);
00035     virtual void GetBufferInfo(BufferInfo & buf_info) const;
00036
00037     virtual BOOLEAN StartAction();
00038     virtual BOOLEAN StopAction(RtStreamingConn::StopCause cause);
00039
00040     virtual BOOLEAN OpenAction();
00041     virtual BOOLEAN CloseAction();
00042
00043     RtStreamingBuffer m_buffers[2];
00044
00045 private:
00046     AtiAudioPlayerSinkThread * m_sink_thread;
00047     Semaphore m_wait_semaphore;
00048     AudioActiveReference &m_audio_ref;
00049     BOOLEAN m_stop_requested_by_conn;
00050 };
00051
00052 #endif  // Apoxi_AtiAudioPlayerRtStreamingSink_hpp
00053
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.cpp File Reference

#include "PreComp.hpp"
#include "AtiCodecsLib.hpp"
#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include "AtiMpeg4Decoder.hpp"
#include "AtiMpeg4Encoder.hpp"
#include "AtiAudioDecoderRenderer.hpp"
#include "AtiAudioCapturerEncoder.hpp"

Include dependency graph for AtiCodecsLib.cpp:

Generated on Tue Jan 24 20:31:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtiCodecsLib

Defines

#define | AtiCodecsLib_hpp

Define Documentation

#define AtiCodecsLib_hpp

Generated on Tue Jan 24 20:31:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtiCodecsLib_hpp)
00010 #define AtiCodecsLib_hpp
00013
00014
00015 class AtiCodecsLib {
00016     private:
00017
00020         static void LoadLib();
00021
00022     friend class CodecConfig; // loads this library
00023
00024 };
00025
00027 #endif // AtiCodecsLib_hpp
00028
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiConfig.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiConfig.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>
#include <AddOns/CodecManager/AudioCapturerEncoder.hpp>
#include <gci_audio.h>

Include dependency graph for AtiConfig.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | AtiConfig_hpp

Variables

const tGciAudioVolume | GciVolume = 100

Define Documentation

#define AtiConfig_hpp

Generated on Tue Jan 24 20:31:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiConfig.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtiConfig_hpp)
00010 #define AtiConfig_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/CodecDevice.hpp>
00018 #include <AddOns/CodecManager/AudioCapturerEncoder.hpp>
00019
00020 extern "C"{
00021 #include <gci_audio.h>
00022 }
00023
00024 // Volume definition
00025 const tGciAudioVolume GciVolume = 100; // Volume in percent 0=mute,100=max (as described by ATI)
00026 #endif
00027
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.cpp File Reference

#include "PreComp.hpp"
#include "AtiMpeg4Decoder.hpp"
#include <gci_vdec.h>

Include dependency graph for AtiMpeg4Decoder.cpp:

Variables

const UINT8 | c_ati_codec_mpeg4_dec_out_buf_def_count = 4
const UINT8 | c_ati_codec_mpeg4_dec_out_buf_max_count = 8
const UINT8 | c_ati_codec_mpeg4_dec_out_buf_min_count = 1

Variable Documentation

const UINT8 c_ati_codec_mpeg4_dec_out_buf_def_count = 4

Default number of the video decoder output buffers.

const UINT8 c_ati_codec_mpeg4_dec_out_buf_max_count = 8

Maximum number of the video decoder output buffers.

const UINT8 c_ati_codec_mpeg4_dec_out_buf_min_count = 1

Minimum number of the video decoder output buffers.

Generated on Tue Jan 24 20:32:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>

Include dependency graph for AtiMpeg4Decoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtiMpeg4Decoder
struct | AtiMpeg4Decoder::StateFlags

Defines

#define | AtiMpeg4Decoder_hpp

Variables

const UINT8 | c_ati_codec_max_num_of_mpeg4_dec_inst = 1

Define Documentation

#define AtiMpeg4Decoder_hpp

Generated on Tue Jan 24 20:32:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtiMpeg4Decoder_hpp)
00010 #define AtiMpeg4Decoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/VideoDecoder.hpp>
00016
00017 class AtiMpeg4DecoderThread;
00018
00020 const UINT8 c_ati_codec_max_num_of_mpeg4_dec_inst = 1;
00021
00024 class AtiMpeg4Decoder : public VideoDecoder {
00025
00026     typedef VideoDecoder Base;
00027
00028     public:
00029
00031         virtual ~AtiMpeg4Decoder();
00032
00034         virtual ResultType GetProperties(Properties& properties);
00035
00037         virtual ResultType Open(VideoDecoderInfo& dec_info);
00038
00040         virtual ResultType Close();
00041
00043         virtual ResultType Start(
00044                                 CbResultAndTimeInfo cb_video_decoder_started,
00045                                 void* context);
00046
00048         virtual ResultType Stop(
00049                                 CbResult cb_video_decoder_stopped,
00050                                 void* context);
00051
00053         virtual ResultType SetConfig(
00054                             const UINT8* config_stream,
00055                             UINT32& config_len,
00056                             const VideoDecoderParameters& params,
00057                             VideoStreamInfo& stream_info);
00058
00059
00060
00062         virtual ResultType GetCapabilities(
00063                                                     VideoCodecCapabilities& caps);
00064
00066         virtual ResultType AllocateOutputBuffers(
00067                                                 UINT8& out_buf_count,
00068                                                 UINT32& out_buf_len);
00069
00071         virtual ResultType RegisterCallbackFunctions(
00072                                                 void* context,
00073                                                 CbFrameDecoded cb_frame_decoded,
00074                                                 CbInBufferFree cb_in_buf_free);
00075
00077         virtual ResultType SetAssociatedAudioCh(
00078                                         UINT32 audio_channel);
00079
00081         virtual ResultType SetVideoClockTime(
00082                                         UINT32 time_ms);
00083
00085         virtual ResultType GetCurrentVideoClockTime(
00086                                         UINT32& time_ms);
00087
00089         virtual ResultType DecodeFrame(
00090                                         const UINT8 HUGE* in_buf,
00091                                         UINT32 in_buf_len,
00092                                         UINT16 flags,
00093                                         UINT32 time_stamp);
00094
00096         virtual ResultType DecodePacket(
00097                                         const UINT8 HUGE* in_buf,
00098                                         UINT32 in_buf_len,
00099                                         UINT16 flags);
00100
00102         virtual ResultType ReleaseOutputBuffer(
00103                                                 const UINT8 HUGE* out_buf);
00104
00106         virtual ResultType FlushBuffers(
00107                                         CbResult cb_video_decoder_flushed,
00108                                         void* context);
00109
00110     protected:
00111
00113         virtual ResultType SetCodec(CodecType codec);
00114
00115     private:
00116
00118         enum StateType {
00119             IdleState = 0,
00120             OpeningState,
00121             OpenState,
00122             StartingState,
00123             StartedState,
00124             StoppingState,
00125             ClosingState
00126         };
00127
00128         struct StateFlags {
00129             UINT m_state                        :3;
00130             UINT m_out_buffers_allocated        :1;
00131             UINT m_callback_funcs_registered    :1;
00132             UINT m_set_config_called            :1;
00133             UINT m_stop_requested               :1;
00134             UINT m_close_requested              :1;
00135         };
00136
00142         static void CbNotifyInBufferFree(   void* context,
00143                                             UINT8* in_buf);
00144
00151         static void CbNotifyStarted(INT result, void* context, UINT32 time_ms);
00152
00158         static void CbNotifyStopped(INT result, void* context);
00159
00165         static void CbNotifyBuffersFlushed(INT result, void* context);
00166
00169         CbInBufferFree m_cb_in_buf_free;
00172         CbResultAndTimeInfo m_cb_started;
00175         CbResult m_cb_stopped;
00178         CbResult m_cb_buffers_flushed;
00179
00182         static AtiMpeg4Decoder* m_exist_this_ptr_array[c_ati_codec_max_num_of_mpeg4_dec_inst];
00183
00186         void* m_client_context_inbuf_free;
00189         void* m_client_context_start;
00192         void* m_client_context_stop;
00195         void* m_client_context_flush;
00196
00202         UINT8 m_out_buf_max_count;
00205         UINT8 m_out_buf_cur_used_count;
00207         UINT32 m_out_buf_len;
00209         StateFlags m_flags;
00211         CodecType m_codec;
00213         void* m_base;
00214
00216         AtiMpeg4Decoder();
00217
00221         void ReleaseDecoder();
00222
00228         ResultType ConvertResultCode(INT result_code);
00229
00236         static BOOLEAN IsValidContext(void* context);
00237
00238     friend class AtiCodecsLib; // creates/destroys AtiMpeg4Decoder
00239
00240 };
00241
00243 #endif // AtiMpeg4Decoder_hpp
00244
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.cpp File Reference

#include "PreComp.hpp"
#include "AtiMpeg4Encoder.hpp"
#include <Auxiliary/BufferPoolManager.hpp>
#include <gci_venc.h>

Include dependency graph for AtiMpeg4Encoder.cpp:

Defines

#define | VIDEO_ENCODER_MAX_CONFIG_STREAM_SIZE 500

Variables

const UINT8 | c_ati_codec_mpeg4_enc_out_buf_def_count = 4
const UINT8 | c_ati_codec_mpeg4_enc_out_buf_max_count = 10
const UINT8 | c_ati_codec_mpeg4_enc_out_buf_min_count = 1

Define Documentation

#define VIDEO_ENCODER_MAX_CONFIG_STREAM_SIZE 500

Variable Documentation

const UINT8 c_ati_codec_mpeg4_enc_out_buf_def_count = 4

Default number of the output buffers.

const UINT8 c_ati_codec_mpeg4_enc_out_buf_max_count = 10

Maximum number of the output buffers.

const UINT8 c_ati_codec_mpeg4_enc_out_buf_min_count = 1

Maximum number of the output buffers.

Generated on Tue Jan 24 20:32:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoEncoder.hpp>

Include dependency graph for AtiMpeg4Encoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtiMpeg4Encoder
struct | AtiMpeg4Encoder::StateFlags

Defines

#define | AtiMpeg4Encoder_hpp

Variables

const UINT8 | c_ati_codecs_max_num_of_mpeg4_enc_inst = 1

Define Documentation

#define AtiMpeg4Encoder_hpp

Generated on Tue Jan 24 20:32:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtiMpeg4Encoder_hpp)
00010 #define AtiMpeg4Encoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoEncoder.hpp>
00017
00019 const UINT8 c_ati_codecs_max_num_of_mpeg4_enc_inst = 1;
00020
00023 class AtiMpeg4Encoder : public VideoEncoder {
00024
00025     typedef VideoEncoder Base;
00026
00027     public:
00028
00030         virtual ~AtiMpeg4Encoder();
00031
00033         virtual ResultType GetProperties(Properties& properties);
00034
00036         virtual ResultType GetCapabilities(VideoCodecCapabilities& caps);
00037
00039         virtual ResultType Open();
00040
00042         virtual ResultType Close();
00043
00045         virtual ResultType SetConfig(
00046                             const VideoEncoderParameters& params,
00047                             UINT32& out_buf_max_len);
00048
00050         virtual ResultType SetDynamicConfig(VideoEncoderDynParameters &params);
00051
00053         virtual ResultType AllocateOutputBuffers(
00054                                                 UINT8& out_buf_count,
00055                                                 UINT32& out_buf_len);
00056
00058         virtual ResultType RegisterCallbackFunctions(
00059                                             void* context,
00060                                             CbVideoFrameEncoded cb_video_frame_encoded);
00061
00063         virtual ResultType Start();
00064
00066         virtual ResultType Stop(
00067                                 CbResult cb_video_encoder_stopped,
00068                                 void* context);
00069
00071         virtual ResultType EncodeFrame( UINT8 HUGE* in_buf,
00072                                         UINT32 time_stamp,
00073                                         UINT32 key_frame_ind);
00074
00076         virtual ResultType ReleaseOutputBuffer(UINT8 HUGE* out_buf);
00077
00079         virtual ResultType GetConfigStream(
00080                                             UINT8 HUGE*& out_buf,
00081                                             UINT32& out_buf_len);
00082
00084         virtual ResultType ReleaseConfigStreamBuffer(UINT8 HUGE* buf);
00085
00087         virtual ResultType FlushBuffers(
00088                                             CbResult cb_video_encoder_flushed,
00089                                             void* context);
00090
00092         virtual ResultType InsertKeyFrame();
00093
00094     protected:
00095
00097         virtual ResultType SetCodec(CodecType codec);
00098
00099     private:
00100
00102         enum StateType {
00103             IdleState = 0,
00104             OpeningState,
00105             OpenState,
00106             StartedState,
00107             StoppingState,
00108             ClosingState
00109         };
00110
00111         struct StateFlags {
00112             UINT m_state                        :3;
00113             UINT m_out_buffers_allocated        :1;
00114             UINT m_callback_funcs_registered    :1;
00115             UINT m_set_config_called            :1;
00116             UINT m_stop_requested               :1;
00117             UINT m_close_requested              :1;
00118         };
00119
00125         static void CbNotifyBuffersFlushed(INT result, void* context);
00126
00136         static void CbNotifyFrameEncoded(   INT result,
00137                                             void* context,
00138                                             UINT8* out_buf,
00139                                             UINT32 out_buf_len_used,
00140                                             UINT32 time_stamp,
00141                                             INT vop_coding_type );
00142
00148         static void CbNotifyStopped(    INT result,
00149                                         void* context);
00150
00160         static void CbGetBuffer(    void* context,
00161                                     UINT8** out_buf,
00162                                     UINT32 out_buf_len );
00163
00166         CbVideoFrameEncoded m_cb_frame_encoded;
00169         CbResult m_cb_buffers_flushed;
00172         CbResult m_cb_stopped;
00173
00176         static AtiMpeg4Encoder* m_exist_this_ptr_array[c_ati_codecs_max_num_of_mpeg4_enc_inst];
00179         void* m_client_context_frame_encoded;
00182         void* m_client_context_flushed;
00185         void* m_client_context_stopped;
00187         UINT32 m_in_buf_len;
00189         UINT32 m_venc_out_buf_max_len;
00192         UINT8 m_out_buf_array_count;
00194         UINT32 m_out_buf_pool;
00196         StateFlags m_flags;
00198         CodecType m_codec;
00200         void* m_base;
00201
00203         AtiMpeg4Encoder();
00204
00208         void ResetEncoder();
00209
00215         ResultType ConvertResultCode(INT result_code);
00216
00223         static BOOLEAN IsValidContext(void* context);
00224
00225     friend class AtiCodecsLib; // creates/destroys the AtiMpeg4Encoder
00226
00227 };
00228
00230 #endif // AtiMpeg4Encoder_hpp
00231
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiUtils.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiUtils.cpp File Reference

#include "PreComp.hpp"
#include "AtiUtils.hpp"

Include dependency graph for AtiUtils.cpp:

Functions

tGciAudioBitrate | AtiUtils::ConvertAACToGCIFormat (CodecDevice::EncQualityConfig input)
tGciAudioAmrBitrateConfig | AtiUtils::ConvertAMRToGCIFormat (CodecDevice::EncQualityConfig input)
CodecDevice::TimestampMSec | AtiUtils::ConvertFromGCIFormat (tGciAudioTimestampMSec input)
BOOLEAN | AtiUtils::ConvertFromGCIFormat (tGciBoolean input)
UINT8 * | AtiUtils::ConvertFromGCIFormat (UINT32 *input)
CodecDevice::AudioChannel | AtiUtils::ConvertFromGCIFormat (tGciAudioHandle input)
CodecDevice::ResultType | AtiUtils::ConvertFromGCIFormat (tGciResult input)
tGciAudioTimestampMSec | AtiUtils::ConvertToGCIFormat (CodecDevice::TimestampMSec input)
tGciBoolean | AtiUtils::ConvertToGCIFormat (BOOLEAN input)
UINT32 * | AtiUtils::ConvertToGCIFormat (const UINT8 *input)
tGciAudioFormat | AtiUtils::ConvertToGCIFormat (CodecDevice::CodecType codec)
tGciAudioMonoStereoConfiguration | AtiUtils::ConvertToGCIFormat (CodecDevice::MonoSteroConfig input)
tGciAudioSamplingFreqHz | AtiUtils::ConvertToGCIFormat (UINT16 input)
tGciAudioAacFormat | AtiUtils::ConvertToGCIFormat (CodecDevice::AacFormat input)
tGciAudioAmrDtxConfig | AtiUtils::ConvertToGCIFormat (CodecDevice::AmrDtxConfig input)
tGciAudioAmrInterfaceFormatConfig | AtiUtils::ConvertToGCIFormat (CodecDevice::AmrIfFormat input)
tGciAudioHandle | AtiUtils::ConvertToGCIFormat (CodecDevice::AudioChannel input)
Generated on Tue Jan 24 20:32:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiUtils.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/AtiUtils.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/CodecDevice.hpp>
#include <gci_common.h>
#include <gci_audio.h>

Include dependency graph for AtiUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Namespaces

namespace | AtiUtils

Defines

#define | AtiUtils_hpp

Functions

tGciAudioBitrate | AtiUtils::ConvertAACToGCIFormat (CodecDevice::EncQualityConfig input)
tGciAudioAmrBitrateConfig | AtiUtils::ConvertAMRToGCIFormat (CodecDevice::EncQualityConfig input)
CodecDevice::TimestampMSec | AtiUtils::ConvertFromGCIFormat (tGciAudioTimestampMSec input)
BOOLEAN | AtiUtils::ConvertFromGCIFormat (tGciBoolean input)
UINT8 * | AtiUtils::ConvertFromGCIFormat (UINT32 *input)
CodecDevice::AudioChannel | AtiUtils::ConvertFromGCIFormat (tGciAudioHandle input)
CodecDevice::ResultType | AtiUtils::ConvertFromGCIFormat (tGciResult input)
tGciAudioTimestampMSec | AtiUtils::ConvertToGCIFormat (CodecDevice::TimestampMSec input)
tGciBoolean | AtiUtils::ConvertToGCIFormat (BOOLEAN input)
UINT32 * | AtiUtils::ConvertToGCIFormat (const UINT8 *input)
tGciAudioFormat | AtiUtils::ConvertToGCIFormat (CodecDevice::CodecType codec)
tGciAudioMonoStereoConfiguration | AtiUtils::ConvertToGCIFormat (CodecDevice::MonoSteroConfig input)
tGciAudioSamplingFreqHz | AtiUtils::ConvertToGCIFormat (UINT16 input)
tGciAudioAacFormat | AtiUtils::ConvertToGCIFormat (CodecDevice::AacFormat input)
tGciAudioAmrDtxConfig | AtiUtils::ConvertToGCIFormat (CodecDevice::AmrDtxConfig input)
tGciAudioAmrInterfaceFormatConfig | AtiUtils::ConvertToGCIFormat (CodecDevice::AmrIfFormat input)
tGciAudioHandle | AtiUtils::ConvertToGCIFormat (CodecDevice::AudioChannel input)

Define Documentation

#define AtiUtils_hpp

Generated on Tue Jan 24 20:32:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/AtiUtils.hpp Source File

Devices/MPEU/Extensions/AtiW2282/AtiUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(AtiUtils_hpp)
00010 #define AtiUtils_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/CodecDevice.hpp>
00018
00019 extern "C"{
00020 #include <gci_common.h>
00021 #include <gci_audio.h>
00022 }
00023
00025 namespace AtiUtils {
00026         /* Bitrate constansts for encoder settings */
00027         static const tGciAudioAmrBitrateConfig  c_GciAmrEncQualityLow   = GCI_AUDIO_AMR_BITRATE_4750;
00028         static const tGciAudioAmrBitrateConfig  c_GciAmrEncQualityMid   = GCI_AUDIO_AMR_BITRATE_7400;
00029         static const tGciAudioAmrBitrateConfig  c_GciAmrEncQualityHigh  = GCI_AUDIO_AMR_BITRATE_12200;
00030         static const tGciAudioBitrate           c_GciAacEncQualityLow   = 24000;
00031         static const tGciAudioBitrate           c_GciAacEncQualityMid   = 48000;
00032         static const tGciAudioBitrate           c_GciAacEncQualityHigh  = 96000;
00033
00034         /******************************************************************************
00035         *                             ConvertFromGCIFormat                            *
00036         *                                   Functions                                 *
00037         *       Used for converting from GCI types to the types specified in the      *
00038         *                              CodecDevice class.                             *
00039         ******************************************************************************/
00040
00045         CodecDevice::ResultType ConvertFromGCIFormat(tGciResult input);
00046
00051         CodecDevice::AudioChannel ConvertFromGCIFormat(tGciAudioHandle input);
00052
00057         UINT8* ConvertFromGCIFormat(UINT32* input);
00058
00063         BOOLEAN ConvertFromGCIFormat(tGciBoolean input);
00064
00069         CodecDevice::TimestampMSec ConvertFromGCIFormat(tGciAudioTimestampMSec input);
00070
00071         /******************************************************************************
00072         *                              ConvertToGCIFormat                             *
00073         *                                  Functions                                  *
00074         *   Used for converting from CodecDevice class types to GCI specified types.  *
00075         *                                                                             *
00076         ******************************************************************************/
00077
00082         tGciAudioHandle ConvertToGCIFormat(CodecDevice::AudioChannel input);
00083
00088         tGciAudioAmrInterfaceFormatConfig ConvertToGCIFormat(CodecDevice::AmrIfFormat input);
00089
00094         tGciAudioAmrBitrateConfig ConvertAMRToGCIFormat(CodecDevice::EncQualityConfig input);
00095
00100         tGciAudioAmrDtxConfig ConvertToGCIFormat(CodecDevice::AmrDtxConfig input);
00101
00106         tGciAudioAacFormat ConvertToGCIFormat(CodecDevice::AacFormat input);
00107
00112         tGciAudioSamplingFreqHz ConvertToGCIFormat(UINT16 input);
00113
00118         tGciAudioBitrate ConvertAACToGCIFormat(CodecDevice::EncQualityConfig input);
00119
00124         tGciAudioMonoStereoConfiguration ConvertToGCIFormat(CodecDevice::MonoSteroConfig input);
00125
00129         tGciAudioFormat ConvertToGCIFormat(CodecDevice::CodecType codec);
00130
00135         UINT32* ConvertToGCIFormat(const UINT8* input);
00136
00141         tGciBoolean ConvertToGCIFormat(BOOLEAN input);
00142
00147         tGciAudioTimestampMSec ConvertToGCIFormat(CodecDevice::TimestampMSec input);
00148  };
00149 #endif //AtiUtils_hpp
00150
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/Camera.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/Camera.cpp File Reference

#include "PreComp.hpp"
#include "Camera.hpp"
#include <Config/CameraConfig.hpp>
#include <Devices/DeviceManager.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for Camera.cpp:

Defines

#define | CifSize_INDEX (6)
#define | DEBUG_CAMERA_CPP
#define | DEBUG_DEVICE_CAMERA_CPP_FILE (30600)
#define | DEFAULT_STEP_SIZE (1)
#define | DefaultZoomLevelCifSize_INDEX (3)
#define | DefaultZoomLevelQcifSize_INDEX (3)
#define | DefaultZoomLevelQqcifSize_INDEX (3)
#define | DefaultZoomLevelQqvgaSize_INDEX (3)
#define | DefaultZoomLevelQsifSize_INDEX (3)
#define | DefaultZoomLevelQvgaSize_INDEX (3)
#define | DefaultZoomLevelSize1_3Mp_INDEX (3)
#define | DefaultZoomLevelSize1Mp_INDEX (3)
#define | DefaultZoomLevelSize2Mp_INDEX (3)
#define | DefaultZoomLevelSize3Mp_INDEX (3)
#define | DefaultZoomLevelSqcifSize_INDEX (3)
#define | DefaultZoomLevelSvgaSize_INDEX (3)
#define | DefaultZoomLevelUxgaSize_INDEX (3)
#define | DefaultZoomLevelVgaSize_INDEX (3)
#define | DefaultZoomLevelXgaSize_INDEX (3)
#define | MAX_LCD_SCREEN_FORMATS (5)
#define | MAX_ZOOM_LEVELS (7)
#define | MIN_ZOOM_LEVELS (1)
#define | NOT_USEABLE (-1)
#define | QcifSize_INDEX (3)
#define | QqcifSize_INDEX (0)
#define | QqvgaSize_INDEX (2)
#define | QsifSize_INDEX (4)
#define | QvgaSize_INDEX (5)
#define | Size1_3Mp_INDEX (0x0B)
#define | Size1Mp_INDEX (0x0A)
#define | Size2Mp_INDEX (0x0D)
#define | Size3Mp_INDEX (0x0E)
#define | SqcifSize_INDEX (1)
#define | SvgaSize_INDEX (8)
#define | UxgaSize_INDEX (0x0C)
#define | VgaSize_INDEX (7)
#define | XgaSize_INDEX (9)

Functions

void | ApoxiSendGddViewfinderError ()

Variables

const gdd_cam_fps_type | DEFAULT_VIEWFINDER_FRAMERATE = GDD_FPS_15

Define Documentation

#define CifSize_INDEX (6)

#define DEBUG_CAMERA_CPP

#define DEBUG_DEVICE_CAMERA_CPP_FILE (30600)

#define DEFAULT_STEP_SIZE (1)

#define DefaultZoomLevelCifSize_INDEX (3)

#define DefaultZoomLevelQcifSize_INDEX (3)

#define DefaultZoomLevelQqcifSize_INDEX (3)

#define DefaultZoomLevelQqvgaSize_INDEX (3)

#define DefaultZoomLevelQsifSize_INDEX (3)

#define DefaultZoomLevelQvgaSize_INDEX (3)

#define DefaultZoomLevelSize1_3Mp_INDEX (3)

#define DefaultZoomLevelSize1Mp_INDEX (3)

#define DefaultZoomLevelSize2Mp_INDEX (3)

#define DefaultZoomLevelSize3Mp_INDEX (3)

#define DefaultZoomLevelSqcifSize_INDEX (3)

#define DefaultZoomLevelSvgaSize_INDEX (3)

#define DefaultZoomLevelUxgaSize_INDEX (3)

#define DefaultZoomLevelVgaSize_INDEX (3)

#define DefaultZoomLevelXgaSize_INDEX (3)

#define MAX_LCD_SCREEN_FORMATS (5)

#define MAX_ZOOM_LEVELS (7)

#define MIN_ZOOM_LEVELS (1)

#define NOT_USEABLE (-1)

#define QcifSize_INDEX (3)

#define QqcifSize_INDEX (0)

#define QqvgaSize_INDEX (2)

#define QsifSize_INDEX (4)

#define QvgaSize_INDEX (5)

#define Size1_3Mp_INDEX (0x0B)

#define Size1Mp_INDEX (0x0A)

#define Size2Mp_INDEX (0x0D)

#define Size3Mp_INDEX (0x0E)

#define SqcifSize_INDEX (1)

#define SvgaSize_INDEX (8)

#define UxgaSize_INDEX (0x0C)

#define VgaSize_INDEX (7)

#define XgaSize_INDEX (9)

Function Documentation

void ApoxiSendGddViewfinderError ( void )

Variable Documentation

const gdd_cam_fps_type DEFAULT_VIEWFINDER_FRAMERATE = GDD_FPS_15

Generated on Tue Jan 24 20:23:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/Camera.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/Camera.hpp File Reference

#include <Devices/AbstractLockableDevice.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>
#include <Devices/CameraInterface.hpp>

Include dependency graph for Camera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Camera
struct | Camera::ParameterStruct

Defines

#define | Apoxi_Camera_hpp

Define Documentation

#define Apoxi_Camera_hpp

Generated on Tue Jan 24 20:24:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/Camera.hpp Source File

Devices/MPEU/Extensions/AtiW2282/Camera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Camera_hpp)
00010 #define Apoxi_Camera_hpp
00013
00014 #include <Devices/AbstractLockableDevice.hpp>
00015 #include <Kernel/System.hpp>
00016 #include <Kernel/Types.hpp>
00017 #include <Gui/Rect.hpp>
00018
00019 // GDD include
00020 #ifdef APOXI_RTOS_WIN32
00021     #ifdef APOXI_ATI_SUPPORT
00022         extern "C" {
00023             #include <gdd.h>
00024         };
00025     #endif // #ifdef APOXI_ATI_SUPPORT
00026 #endif
00027
00029 class Camera : public AbstractLockableDevice {
00030     typedef AbstractLockableDevice Base;
00031
00032     public:
00033         #include <Devices/CameraInterface.hpp>
00034
00035     protected:
00036
00038         virtual BOOLEAN& GetLock() {return m_lock[GetIndex()];}
00040         INT GetZoom();
00042         UINT16 CalcCameraScalingRate(ImageSizeType imageType, INT device_zoom_level);
00043
00044         void SetState(CameraState camera_state);
00045
00047         INT m_last_error;
00049         INT m_zoom_level;
00051         INT m_brightness_level;
00053         INT m_contrast_level;
00055         Rect m_rect;
00057         ImageSizeType m_capture_image_size;
00059         TransformationType m_capture_transformation;
00061         TransformationType m_view_image_transformation;
00062
00063     private:
00064
00066         typedef struct ParameterStruct {
00067                     INT min;
00068                     INT def;
00069                     INT max;
00070                     INT step;
00071                 } ParameterStruct;
00072
00073
00074                 enum ParameterType {
00075                     BrightnessParameter = 0,
00076                     ContrastParameter
00077                 };
00078
00079         static BOOLEAN m_lock[2];
00080
00081         CameraState m_camera_state;
00082         INT m_display_idx;  // display index where the camera viewfinder should be displayed
00083
00084         AntiFlickerType m_antiflicker_mode;
00085         FilterType m_filter;
00086
00087         ScalingMethodType m_scaling_method;
00088         TwilightType m_twilight_mode;
00089
00090         ParameterStruct m_DeviceParameterLimits[2];
00091         ParameterLimits m_CameraParameterLimits[2];
00092
00093         FlashType m_flash;
00094
00095         void ConvertCameraToDeviceLimits(ParameterType type);
00096         void StoreCameraParameterLimits(ParameterType type, gdd_limits_type limits);
00097         INT CalcCameraValue(ParameterType type, INT deviceValue);
00098         BOOLEAN CheckDeviceBrightnessContrastLevel(ParameterType type, INT val);
00099 };
00100
00101 inline INT Camera::GetLastError() const
00102 {
00103     return m_last_error;
00104 }
00105
00106 inline INT Camera::GetDisplayIndex() const
00107 {
00108     return m_display_idx;
00109 }
00110
00112 #endif  // Apoxi_Camera_hpp
00113
00114
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.cpp File Reference

#include "PreComp.hpp"
#include "DefaultDisplay.hpp"
#include "VideoChannel.hpp"
#include <Gui/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DisplayMsgTypes.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <lcd.h>

Include dependency graph for DefaultDisplay.cpp:

Defines

#define | GDD_LCD_UPDATE_CALLBACK

Functions

void | ApoxiSendDisplayUpdateFinished (int, void *, ubyte shuge *)

Define Documentation

#define GDD_LCD_UPDATE_CALLBACK

Function Documentation

void ApoxiSendDisplayUpdateFinished | ( | int | ,
 |  | void * | ,
 |  | ubyte shuge * |
 | ) |

Generated on Tue Jan 24 20:25:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Devices/Display.hpp>

Include dependency graph for DefaultDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultDisplay

Defines

#define | Apoxi_DefaultDisplay_hpp

Define Documentation

#define Apoxi_DefaultDisplay_hpp

Generated on Tue Jan 24 20:25:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.hpp Source File

Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultDisplay_hpp)
00010 #define Apoxi_DefaultDisplay_hpp
00013
00014 class VideoChannel;
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/Os/SystemTimer.hpp>
00017 #include <Devices/Display.hpp>
00018
00023 class DefaultDisplay : public Display {
00024     typedef Display Base;
00025
00026     public:
00029         DefaultDisplay(INT index);
00030
00031         virtual ~DefaultDisplay();
00032
00034         virtual const WCHAR* GetName() const;
00035
00037         virtual void OnStart();
00038
00040         virtual void OnStop();
00041
00043         virtual void SetContrast(INT contrast);
00044
00046         virtual INT GetContrast() const;
00047
00049         virtual void SetBrightness(INT brightness);
00050
00052         virtual INT GetBrightness() const;
00053
00055         virtual void SetBacklightTimeout(UINT32 timeout);
00056
00058         virtual void SetPowerTimeout(UINT32 timeout);
00059
00061         virtual void ReactivateBacklight();
00062
00064         virtual void ReactivatePower();
00065
00067         virtual void SetBacklightMode(BacklightMode mode);
00068
00070         virtual BacklightMode GetBacklightMode() const;
00071
00073         virtual BOOLEAN IsBacklightOn() const;
00074
00076         virtual void SetPowerMode(PowerMode mode);
00077
00079         virtual PowerMode GetPowerMode() const;
00080
00082         virtual BOOLEAN IsPowerOn() const;
00083
00085         virtual void Refresh();
00086
00095         virtual void Refresh(const CustomFrameBuffer* custom_frame_buf);
00096
00100         virtual VideoChannel* GetVideoChannel();
00101
00104         void OnTimer();
00105
00106         /*  S-Gold specific interface, which is not part of the common Display interface and hence may
00107             not be used by any APOXI or MMI interface. */
00108         static void SynchronizeBuffers();
00109
00111         virtual void SetCallbackActive(BOOLEAN state);
00112
00114         virtual BOOLEAN IsCallbackActive() const;
00115
00116     private:
00117         enum Status {
00118             DisplayOff,
00119             BacklightOff,
00120             BacklightOn
00121         };
00122
00123         struct {
00124             UINT backlight_mode         : 2;
00125             UINT power_mode             : 2;
00126             UINT status                 : 2;
00127             UINT power_on               : 1;
00128             UINT backlight_on           : 1;
00129         } m_bits;
00130         VideoChannel* m_video_channel;
00131         SystemTimer* m_timer;
00132         UINT32 m_backlight_timeout;
00133         UINT32 m_power_timeout;
00134
00135         UINT8 m_contrast;
00136         UINT8 m_brightness;
00137
00138         volatile BOOLEAN m_cb_active;
00139         BOOLEAN m_synchronize_buffer_skipped;
00140
00141         Semaphore m_sem;
00142         BOOLEAN m_gdd_transfer;
00143         Rect m_updated_blit_rect;
00144         DDrvAtomPtr m_transfer_buffer;      // buffer which contains a copy of the main frame buffer
00145
00146         void SetBacklight(BOOLEAN backlight);
00147         void SetPower(BOOLEAN power);
00148
00149         static void CallbackFn(void* arg);
00150
00151         friend class VideoChannel;
00152 };
00153
00155 #endif  // Apoxi_DefaultDisplay_hpp
00156
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.cpp File Reference

#include "Auxiliary/PreComp.hpp"
#include <Auxiliary/BinData.hpp>
#include "NonsharedBinDataDataSource.hpp"

Include dependency graph for NonsharedBinDataDataSource.cpp:

Generated on Tue Jan 24 20:32:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.hpp File Reference

#include <Auxiliary/DataSource.hpp>

Include dependency graph for NonsharedBinDataDataSource.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NonsharedBinDataDataSource

Defines

#define | Auxiliary_NonsharedBinDataDataSource_hpp

Define Documentation

#define Auxiliary_NonsharedBinDataDataSource_hpp

Generated on Tue Jan 24 20:32:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.hpp Source File

Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Auxiliary_NonsharedBinDataDataSource_hpp)
00011 #define Auxiliary_NonsharedBinDataDataSource_hpp
00012
00013 class BinData;
00014 #include <Auxiliary/DataSource.hpp>
00015
00017 class NonsharedBinDataDataSource : public DataSource
00018 {
00019     typedef DataSource Base;
00020
00021     public:
00028         NonsharedBinDataDataSource(const BinData* bin_data);
00029
00031         virtual ~NonsharedBinDataDataSource();
00032
00033         virtual BOOLEAN Open();
00034         virtual BOOLEAN Close();
00035
00036         virtual BOOLEAN IsOpen() const;
00037
00038         virtual BOOLEAN Read(void HUGE *buffer, UINT32 count);
00039         virtual BOOLEAN Read(void HUGE *buffer, UINT32 max_count, UINT32&bytes_read);
00040         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 count);
00041         virtual BOOLEAN Read(UINT32 offset, void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read);
00042         virtual BOOLEAN GetSize(UINT32 &size) const;
00043
00044     protected:
00045         // The data source that is read from.
00046         const BinData* m_bin_data;
00047
00048         BOOLEAN m_is_open;
00049         UINT32  m_offset;
00050 };
00051
00052 #endif  // Auxiliary_DataSourceBinData_hpp
00053
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/StillCamera.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/StillCamera.cpp File Reference

#include "PreComp.hpp"
#include "StillCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Afs/Rfs/FileDataSink.hpp>
#include <AddOns/AfsRam/RamDataSink.hpp>
#include <Afs/Rfs/FileBinData.hpp>

Include dependency graph for StillCamera.cpp:

Defines

#define | BITS_PRO_BYTE (8)
#define | BITS_PRO_JPEG_PIXEL BITS_PRO_BYTE*BYTEST_PRO_JPEG_PIXEL
#define | BYTEST_PRO_JPEG_PIXEL BYTEST_PRO_PIXEL
#define | BYTEST_PRO_PIXEL MULTIPLIKATOR/DIVISOR
#define | DEBUG_DEVICE_STILL_CAMERA_CPP_FILE (30610)
#define | DEBUG_STILL_CAMERA_CPP
#define | DEBUG_STILL_CAMERA_CPP_CB
#define | DIVISOR (1)
#define | HARDWARE_ENCODER_IS_USED
#define | IMAGE_BUFFER_NOT_USED (0)
#define | MAX_ARRAY_CHECK_INDEX (19)
#define | MULTIPLIKATOR (2)
#define | NO_FRAME_RATE_SUB (0)
#define | NO_OF_PICTURE_FOR_SINGLE_SHOT (1)
#define | NO_OF_PICTURES_EMPTY (0)
#define | RESET_PICTURE_COUNTER (0)
#define | StillCameraTestCode
#define | TEMPORARY_USED

Functions

BOOLEAN | GetStoredCameraBuffer (UINT8 HUGE **captured_buffer, UINT32 *size)

Define Documentation

#define BITS_PRO_BYTE (8)

#define BITS_PRO_JPEG_PIXEL BITS_PRO_BYTE*BYTEST_PRO_JPEG_PIXEL

#define BYTEST_PRO_JPEG_PIXEL BYTEST_PRO_PIXEL

#define BYTEST_PRO_PIXEL MULTIPLIKATOR/DIVISOR

#define DEBUG_DEVICE_STILL_CAMERA_CPP_FILE (30610)

#define DEBUG_STILL_CAMERA_CPP

#define DEBUG_STILL_CAMERA_CPP_CB

#define DIVISOR (1)

#define HARDWARE_ENCODER_IS_USED

#define IMAGE_BUFFER_NOT_USED (0)

#define MAX_ARRAY_CHECK_INDEX (19)

#define MULTIPLIKATOR (2)

#define NO_FRAME_RATE_SUB (0)

#define NO_OF_PICTURE_FOR_SINGLE_SHOT (1)

#define NO_OF_PICTURES_EMPTY (0)

#define RESET_PICTURE_COUNTER (0)

#define StillCameraTestCode

#define TEMPORARY_USED

Function Documentation

BOOLEAN GetStoredCameraBuffer | ( | UINT8 HUGE ** | captured_buffer,
 |  | UINT32 * | size
 | ) |

Generated on Tue Jan 24 20:26:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/StillCamera.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/StillCamera.hpp File Reference

#include <Auxiliary/DataSink.hpp>
#include <Devices/MPE/Camera.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Devices/StillCameraInterface.hpp>

Include dependency graph for StillCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StillCamera
struct | StillCamera::BufferInfoType

Defines

#define | Apoxi_StillCamera_hpp
#define | IMAGE_CAPTURED_OK (0)
#define | IMAGE_ENCODED_OK (0)
#define | MAX_BUFFER_INFO_INDEX (19)
#define | STOPPED_BY_GDD_PROBLEM (3)
#define | STOPPED_BY_NO_BUFFER_FOUND (2)
#define | STOPPED_BY_USER_CANCEL (1)
#define | STOPPED_NORMALLY (0)

Define Documentation

#define Apoxi_StillCamera_hpp

#define MAX_BUFFER_INFO_INDEX (19)

Generated on Tue Jan 24 20:26:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/StillCamera.hpp Source File

Devices/MPEU/Extensions/AtiW2282/StillCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_StillCamera_hpp)
00010 #define Apoxi_StillCamera_hpp
00013
00014 // GDD include
00015 #ifdef APOXI_RTOS_WIN32
00016     #ifdef APOXI_ATI_SUPPORT
00017         extern "C" {
00018             #include <gdd.h>
00019         };
00020     #endif // #ifdef APOXI_ATI_SUPPORT
00021 #endif
00022
00023
00024 #include <Auxiliary/DataSink.hpp>
00025 #include <Devices/MPE/Camera.hpp>
00026 #include <AddOns/MultiMedia/JpegEncoder.hpp>
00027
00028
00029
00030 class RamData;
00031
00032 //send by m_cb_capture_finished()
00033 #define STOPPED_NORMALLY            (0)
00034 #define STOPPED_BY_USER_CANCEL      (1)
00035 #define STOPPED_BY_NO_BUFFER_FOUND  (2)
00036 #define STOPPED_BY_GDD_PROBLEM      (3)
00037
00038 //send by m_cb_image_captured()
00039 #define IMAGE_CAPTURED_OK           (0)
00040
00041 //send by m_cb_image_encoded()
00042 #define IMAGE_ENCODED_OK            (0)
00043
00045 class StillCamera : public Camera {
00046
00047     typedef Camera Base;
00048
00049     public:
00050         #include <Devices/StillCameraInterface.hpp>
00051
00054         virtual BOOLEAN Close();
00055
00056     protected:
00057         friend class CameraConfig;
00058
00059     private:
00060
00061         #define MAX_BUFFER_INFO_INDEX  (19)
00062
00063             enum CaptureState {
00064             Init,
00065             StartRunning,
00066             GetCaptureBuffer,
00067             ImageCaptured,
00068             ImageEncodingBegin,
00069             ImageEncoded,
00070             ErrorGetCaptureBuffer,
00071             ErrorImageCaptured,
00072             ErrorImageEncoded
00073         };
00074
00075             enum CallBackState {
00076             Nothing,
00077             CbGDDCaptureResult,
00078             CbJPEGImageEncoded
00079         };
00080
00081         typedef struct BufferInfoType {
00082                     BOOLEAN Use;
00083                     UINT16 PictNo;
00084                     CaptureState State;
00085                     UINT32 Buflen;
00086                     UINT8 HUGE* BufPtr;
00087                     RamData* RamDataPtr;
00088                     Image::MetaData* MetaDataPtr;
00089                     DataSink* TargetSinkPtr;
00090                 } BufferInfoType;
00091
00092         UINT16 m_no_of_pictures;
00093         UINT16 m_picture_counter;
00094         INT m_jpeg_quality;
00095         BOOLEAN m_capture_in_use;
00096         DataSink* m_target_sink_ptr;
00097         INT       m_ImageBufferCounter;
00098
00099         static CbImageCaptured m_cb_image_captured;
00100         static CbImageEncoded m_cb_image_encoded;
00101         static CbCaptureFinished m_cb_capture_finished;
00102         static void* m_context_appl;
00103
00104                 JpegEncoder::EncodingParameters* m_JpegEncoderParam;
00105                 JpegEncoder* m_JpegEncoder;
00106
00107         static UINT32  m_pool_handle;
00108                 UINT8          m_frame_rate_subsampling;
00109                 static BOOLEAN m_capture_cancled;
00110                 static UINT32  m_Jpeg_Encoder_Counter;
00111
00112                 BufferInfoType m_bufferInfo[MAX_BUFFER_INFO_INDEX+1];
00113                 UINT16         m_bufferInfoIndex;
00114         // callbacks
00115         // callback from GDD for still camera, where buffer for raw data will be passed to
00116         static void Cb_GDD_GetCaptureBuffer(void* context, UINT8 HUGE **buffer, UINT32 size);
00117
00118         // callback from GDD where an image has been captured as RAW data in to buffer
00119         static void Cb_GDD_ImageCaptured    (INT result, void* context, UINT8 HUGE* captured_buffer, UINT32 size);
00120
00121                 // callback from GDD for the asynchronous result
00122                 static void Cb_GDD_CaptureResult(INT result, void* context);
00123
00124         // callback from JpegEncoder, when an RAW data image has been encoded to JPEG
00125                 static void Cb_JPEG_ImageEncoded    (INT result, void* context, DataSink& sink);
00126
00127         BOOLEAN         DeleteOneImageBuffer(UINT8 HUGE* buff_ptr);
00128         BOOLEAN         DeleteOneMetaBuffer(Image::MetaData* MetaDataPtr);
00129         BOOLEAN         FreeImageBuffer();
00130         BOOLEAN         GetImageBuffer(UINT8 no_of_pictures, ImageSizeType size);
00131         BOOLEAN         Encode(BufferInfoType* bufferInfoPtr,UINT32 length);
00132         void            DeleteJpegSoftwareEncoder();
00133         void            DeleteJpegSoftwareEncoderCallBack(CallBackState state);
00134         BOOLEAN         SetJpegSoftwareEncoder(XYDIM width, XYDIM height, INT quality_level);
00135         BOOLEAN         GetCameraImageSize(ImageSizeType size, gdd_image_size_format_type& gdd_image_size);
00136         BOOLEAN         IsMultiShot();
00137         BOOLEAN         GetOneImageBuffer(UINT8 HUGE **buffer);
00138         BufferInfoType* GetUsedImageBuffer(UINT8 HUGE* captured_buffer);
00139         BufferInfoType* GetUsedImageBuffer(DataSink* sink);
00140         BufferInfoType* GetNextImageBuffer(DataSink* sink);
00141         BOOLEAN         DeleteAllUsedImageBuffer();
00142         BOOLEAN         ResetAllBufferInfo(UINT16 MaxNumber,DataSink** sink_ptr);
00143         UINT16          GetNofEncodeImages();
00144         static  void    SetCancleFlag(BOOLEAN capture_cancled);
00145         static  BOOLEAN GetCancleFlag();
00146
00147                 typedef void (*Cb_JpegEncoded)(INT result, void* context, DataSink* dest);
00148 };
00149
00151 #endif  // Apoxi_StillCamera_hpp
00152
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/VideoCamera.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/VideoCamera.cpp File Reference

#include "PreComp.hpp"
#include "VideoCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for VideoCamera.cpp:

Defines

#define | DEACTIVATE_SET_CAPTURE_IMAGE_FORMAT
#define | DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE (30620)
#define | DEBUG_VIDEOCAMERA_CPP
#define | TRACE1LN(x, n) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n))
#define | TRACE2LN(x, n, o) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o))
#define | TRACE3LN(x, n, o, p) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p))
#define | TRACE4LN(x, n, o, p, q) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p, q))
#define | TRACELN(x) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x))

Variables

const INT | c_bytes_per_pixel_of_rawdata = 2

Define Documentation

#define DEACTIVATE_SET_CAPTURE_IMAGE_FORMAT

#define DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE (30620)

#define DEBUG_VIDEOCAMERA_CPP

#define TRACE1LN | ( | x,
 |  | n | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n))

#define TRACE2LN | ( | x,
 |  | n,
 |  | o | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o))

#define TRACE3LN | ( | x,
 |  | n,
 |  | o,
 |  | p | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p))

#define TRACE4LN | ( | x,
 |  | n,
 |  | o,
 |  | p,
 |  | q | ) | DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x, n, o, p, q))

#define TRACELN ( x ) DBG_OUT ((DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE, x))

Variable Documentation

const INT c_bytes_per_pixel_of_rawdata = 2

Generated on Tue Jan 24 20:27:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/VideoCamera.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/VideoCamera.hpp File Reference

#include <Kernel/System.hpp>
#include <Kernel/Types.hpp>
#include <Devices/Camera.hpp>
#include <Devices/VideoCameraInterface.hpp>

Include dependency graph for VideoCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoCamera

Defines

#define | Apoxi_VideoCamera_hpp

Define Documentation

#define Apoxi_VideoCamera_hpp

Generated on Tue Jan 24 20:27:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/VideoCamera.hpp Source File

Devices/MPEU/Extensions/AtiW2282/VideoCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VideoCamera_hpp)
00010 #define Apoxi_VideoCamera_hpp
00013
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/Types.hpp>
00016 #include <Devices/Camera.hpp>
00017
00019 class VideoCamera : public Camera
00020 {
00021     typedef Camera Base;
00022
00023     public:
00024         #include <Devices/VideoCameraInterface.hpp>
00025
00028         virtual BOOLEAN Close();
00029
00037         virtual BOOLEAN SetZoom(ActionType action, UINT8 step_size = 1);
00038
00039 #if defined(APOXI_COMPAT_2_8_0)
00040
00049         virtual BOOLEAN SetViewfinderRect(const Rect& vf_rect,
00050                                   INT display_idx = 0,
00051                                   TransformationType transformation = NoTransformation);
00052
00053 #endif  // #if defined(APOXI_COMPAT_2_8_0)
00054
00065         virtual BOOLEAN SetViewfinderRect(Rect& vf_rect,
00066                                           INT display_idx = 0,
00067                                           TransformationType view_transformation = NoTransformation,
00068                                           ScalingMethodType view_scaling_method = NoScaling);
00069
00072         virtual BOOLEAN StopViewfinder();
00073
00074     protected:
00075 friend class CameraConfig;
00076
00077     private:
00078
00080         static void GetCaptureBuffer_GDD_CB(void*, UINT8 HUGE ** buffer, UINT32 size);
00081
00083         static void VideoFrameCaptured_GDD_CB(int result, void* context, UINT8 HUGE * buffer, UINT32 buf_len_used);
00084
00086         static void NotifyCaptureBufferStatus_GDD_CB(void* context, UINT8 free_buffer_count);
00087
00089         static void VideoCaptureStopped_GDD_CB(int result, void* context);
00090
00092         static void VideoCapturePaused_GDD_CB(int result, void* context);
00093
00095         FrameRateType m_framerate;
00096
00098         static UINT32 m_buffer_length;
00099
00101         static UINT32 m_starting_time;          // frame count or timestamp
00102
00104         static UINT32 m_pool_handle;
00105
00108         static void* m_context;
00109
00110         static Cb_NotifyCaptureBufferStatus m_cb_notify_status;
00111         static Cb_FrameCaptured m_cb_frame_captured;
00112         static Cb_VideoCaptureStopped m_cb_video_capture_stopped;
00113         static Cb_VideoCapturePaused m_cb_video_capture_paused;
00114 };
00115
00117 #endif  // Apoxi_VideoCamera_hpp
00118
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/VideoChannel.cpp File Reference

Devices/MPEU/Extensions/AtiW2282/VideoChannel.cpp File Reference

#include "PreComp.hpp"
#include "VideoChannel.hpp"
#include <gci_vrnd.h>

Include dependency graph for VideoChannel.cpp:

Generated on Tue Jan 24 20:28:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/VideoChannel.hpp File Reference

Devices/MPEU/Extensions/AtiW2282/VideoChannel.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for VideoChannel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoChannel
struct | VideoChannel::StateFlags

Defines

#define | Apoxi_Devices_MPEU_Extensions_AtiW2282_VideoChannel_hpp

Define Documentation

#define Apoxi_Devices_MPEU_Extensions_AtiW2282_VideoChannel_hpp

Generated on Tue Jan 24 20:28:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/AtiW2282/VideoChannel.hpp Source File

Devices/MPEU/Extensions/AtiW2282/VideoChannel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_MPEU_Extensions_AtiW2282_VideoChannel_hpp)
00010 #define Apoxi_Devices_MPEU_Extensions_AtiW2282_VideoChannel_hpp
00011
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Rect.hpp>
00017
00026 class VideoChannel {
00027
00028     public:
00029
00030 #ifdef APOXI_COMPAT_2_8_0
00031
00034         enum VideoParameterType {
00036             Rotate,
00038             Mirror,
00040             Flip,
00042             Antitearing,
00044             SmartOverlays,
00046             YuvToRgbConversion,
00048             ZoomFactorHorizontalMin,
00050             ZoomFactorHorizontalMax,
00052             ZoomFactorVerticalMin,
00054             ZoomFactorVerticalMax
00055         };
00056 #endif // APOXI_COMPAT_2_8_0
00057
00059         enum TransformationType {
00060             NoTransformation,
00061             Rotation90Transformation,
00062             Rotation180Transformation,
00063             Rotation270Transformation,
00064             MirrorTransformation,
00065             MirrorRotate90Transformation,
00066             MirrorRotate180Transformation,  // same as flip
00067             MirrorRotate270Transformation
00068         };
00069
00070         enum ScalingMethodType {
00071             NoScaling,
00072             LetterboxScaling,
00073             BestFitScaling
00074         };
00075
00076         enum VideoAndViewfinderOrderType {
00077             ViewfinderOverVideoPlayback,
00078             VideoPlaybackOverViewfinder
00079         };
00080
00090         typedef void (*CbResult)(   BOOLEAN result,
00091                                     void* context);
00092
00093 #ifdef APOXI_COMPAT_2_8_0
00094
00105         typedef void (*CbVideoFrameRendered)(INT result,
00106                                             void* context,
00107                                             const UINT8 HUGE* frame_buf);
00108
00120         typedef void (*CbVideoFrameRenderedNew)(BOOLEAN result,
00121                                             void* context,
00122                                             const UINT8 HUGE* frame_buf);
00123 #else // APOXI_COMPAT_2_8_0
00124
00136         typedef void (*CbVideoFrameRendered)(BOOLEAN result,
00137                                             void* context,
00138                                             const UINT8 HUGE* frame_buf);
00139 #endif // APOXI_COMPAT_2_8_0
00140
00142         VideoChannel();
00143
00145         VideoChannel(UINT8 display_idx);
00146
00148         ~VideoChannel();
00149
00150 #ifdef APOXI_COMPAT_2_8_0
00151
00164         BOOLEAN Open(Rect& video_frame_rect, CbVideoFrameRendered cb_frame_rendered, void* context = 0);
00165
00177         BOOLEAN Open(CbVideoFrameRenderedNew cb_frame_rendered, void* context);
00178 #else // APOXI_COMPAT_2_8_0
00179
00191         BOOLEAN Open(CbVideoFrameRendered cb_frame_rendered, void* context);
00192 #endif // APOXI_COMPAT_2_8_0
00193
00195         void Close();
00196
00206         BOOLEAN Start(CbResult cb_video_channel_started, void* context);
00207
00217         BOOLEAN Stop(CbResult cb_video_channel_stopped, void* context);
00218
00229         void RenderFrame(void* frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame = FALSE);
00230
00234         BOOLEAN IsOpen() const;
00235
00238         UINT32 GetRefreshDelay() const;
00239
00240 #ifdef APOXI_COMPAT_2_8_0
00241
00246         BOOLEAN SetParam(VideoParameterType type, UINT32 value);
00247
00254         BOOLEAN GetParam(VideoParameterType type, UINT32* value) const;
00255 #endif // APOXI_COMPAT_2_8_0
00256
00257 #ifdef APOXI_COMPAT_2_6_0
00258
00266         void SetSize(Size video_size)
00267         {
00268         #ifdef APOXI_COMPAT_2_8_0
00269             SetVideoSize(video_size);
00270         #endif //  APOXI_COMPAT_2_8_0
00271         }
00272 #endif // APOXI_COMPAT_2_6_0
00273
00274 #ifdef APOXI_COMPAT_2_8_0
00275
00282         void SetVideoSize(Size video_size);
00283 #endif // APOXI_COMPAT_2_8_0
00284
00296         BOOLEAN SetVideoSize(   Size actual_video_size,
00297                                 Size extended_video_size,
00298                                 Point left_top_offset);
00299
00300 #ifdef APOXI_COMPAT_2_8_0
00301
00312         BOOLEAN SetCropRect(Rect& crop_rect);
00313 #endif // APOXI_COMPAT_2_8_0
00314
00328         BOOLEAN SetCropRect(Rect& crop_rect, Rect& effective_playback_rect);
00329
00330 #ifdef APOXI_COMPAT_2_6_0
00331
00338         BOOLEAN AdjustFrameRect(Rect& video_frame_rect)
00339         {
00340         #ifdef APOXI_COMPAT_2_8_0
00341             return SetFrameRect(video_frame_rect);
00342         #else
00343             return FALSE;
00344         #endif //  APOXI_COMPAT_2_8_0
00345         }
00346 #endif // APOXI_COMPAT_2_6_0
00347
00348 #ifdef APOXI_COMPAT_2_8_0
00349
00356         BOOLEAN SetFrameRect(Rect& video_frame_rect);
00357 #endif // APOXI_COMPAT_2_8_0
00358
00370         BOOLEAN SetPlaybackRect(Rect& playback_rect,
00371                                 TransformationType playback_transformation,
00372                                 ScalingMethodType scaling_method);
00373
00374 #ifdef APOXI_COMPAT_2_8_0
00375
00386         BOOLEAN QueryRects(Rect& video_frame_rect, Rect& crop_rect);
00387 #endif // APOXI_COMPAT_2_8_0
00388
00399         BOOLEAN SetPlaybackAndViewfinderOrder(
00400                             VideoAndViewfinderOrderType video_viewfinder_order);
00401
00402     private:
00403
00405         enum StateType {
00406             IdleState = 0,
00407             OpeningState,
00408             OpenState,
00409             StartingState,
00410             StartedState,
00411             StoppingState,
00412             ClosingState
00413         };
00414
00415         struct StateFlags {
00416             UINT m_state                        :3;
00417             UINT m_video_size_set               :1;
00418             UINT m_playback_rect_set            :1;
00419         };
00420
00421         static void CbNotifyVideoFrameRendered( INT result,
00422                                                 void *context,
00423                                                 UINT8 * frame_buf);
00424         static void CbNotifyStarted(INT result, void* context);
00425         static void CbNotifyStopped(INT result, void* context);
00426
00427 #ifdef APOXI_COMPAT_2_8_0
00428         CbVideoFrameRenderedNew m_cb_video_frame_rendered;
00429 #else // APOXI_COMPAT_2_8_0
00430         CbVideoFrameRendered    m_cb_video_frame_rendered;
00431 #endif // APOXI_COMPAT_2_8_0
00432         CbResult                m_cb_stopped;
00433         CbResult                m_cb_started;
00434
00435         UINT8               m_display_idx;
00436         StateFlags          m_flags;
00437
00438         TransformationType  m_transformation;
00439         ScalingMethodType   m_scaling_method;
00440         Rect                m_playback_rect;
00441         Rect                m_effective_playback_rect;
00442         Rect                m_crop_rect;
00443         Rect                m_actual_video_rect;
00444         Size                m_extended_video_size;
00445         void*               m_client_context_frame_rendered;
00446         void*               m_client_context_start;
00447         void*               m_client_context_stop;
00448
00454         BOOLEAN ConvertResultCode(INT result_code);
00455
00456         void ResetVideoChannel();
00457
00458 };
00459
00461 #endif  // Apoxi_Devices_MPEU_Extensions_AtiW2282_VideoChannel_hpp
00462
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzAacDecoder.hpp"
#include "EmzAacDecoderThread.hpp"

Include dependency graph for EmzAacDecoder.cpp:

Variables

const UINT8 | c_emz_codec_aac_dec_multi_frame_out_buf_max_count = 5
const UINT32 | c_emz_codec_aac_dec_multi_frame_out_buf_max_len = 20000
const UINT8 | c_emz_codec_aac_dec_multi_frame_out_buf_min_count = 2
const UINT8 | c_emz_codec_aac_dec_op_queue_max_count = 10
const UINT8 | c_emz_codec_aac_dec_single_frame_out_buf_max_count = 10
const UINT8 | c_emz_codec_aac_dec_single_frame_out_buf_min_count = 2

Variable Documentation

const UINT8 c_emz_codec_aac_dec_multi_frame_out_buf_max_count = 5

Maximum number of the audio decoder output buffers (for DecodeBuffer).

const UINT32 c_emz_codec_aac_dec_multi_frame_out_buf_max_len = 20000

Length (in bytes) of the audio decoder output buffer (for DecodeBuffer).

const UINT8 c_emz_codec_aac_dec_multi_frame_out_buf_min_count = 2

Minimum number of the audio decoder output buffers (for DecodeBuffer).

const UINT8 c_emz_codec_aac_dec_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_aac_dec_single_frame_out_buf_max_count = 10

Maximum number of the audio decoder output buffers (for DecodeFrame).

const UINT8 c_emz_codec_aac_dec_single_frame_out_buf_min_count = 2

Minimum number of the audio decoder output buffers (for DecodeFrame).

Generated on Tue Jan 24 20:29:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzAacDecoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzAacDecoder
class | EmzAacDecoder::OperationInfo
struct | EmzAacDecoder::StateFlags

Defines

#define | Apoxi_EmzAacDecoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_aac_dec_inst = 1

Define Documentation

#define Apoxi_EmzAacDecoder_hpp

Generated on Tue Jan 24 20:29:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_EmzAacDecoder_hpp)
00010 #define Apoxi_EmzAacDecoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/AudioDecoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzAacDecoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_aac_dec_inst = 1;
00023
00025 class EmzAacDecoder : public AudioDecoder {
00026
00027     typedef AudioDecoder Base;
00028
00029     public:
00030
00032         virtual ~EmzAacDecoder();
00033
00035         virtual ResultType GetProperties(Properties& properties);
00036
00045         virtual ResultType Open();
00046
00052         virtual void Close();
00053
00078         virtual ResultType SetConfig(   const UINT8* config_stream,
00079                                         UINT32& config_len,
00080                                         const AudioDecoderParameters& params,
00081                                         AudioStreamInfo& stream_info);
00082
00094         virtual ResultType GetCapabilities( AudioCodecCapabilities& caps);
00095
00122         virtual ResultType AllocateOutputBuffers(
00123                                             UINT8 HUGE** &out_buf_array,
00124                                             UINT8& out_buf_count,
00125                                             UINT32& out_buf_len,
00126                                             DecodingFunctionType& dec_fct);
00127
00143         virtual ResultType RegisterCallbackFunctions( void* context,
00144                                                       CbFrameDecoded cb_frame_decoded);
00145
00164         virtual ResultType DecodeFrame( const UINT8 HUGE* in_buf,
00165                                         UINT32 in_buf_len,
00166                                         const UINT8 HUGE* out_buf,
00167                                         UINT32 out_buf_len);
00168
00187         virtual ResultType DecodeBuffer( const UINT8 HUGE* in_buf,
00188                                          UINT32 in_buf_len,
00189                                          const UINT8 HUGE* out_buf,
00190                                          UINT32 out_buf_len);
00191
00210         virtual ResultType SetParameters( const ParameterType* types_array,
00211                                           const UINT32* values_array,
00212                                           UINT8 array_count);
00213
00235         virtual ResultType GetParameters( const ParameterType* types_array,
00236                                           UINT32* values_array,
00237                                           UINT8 array_count);
00238     protected:
00239
00241         virtual ResultType SetCodec(CodecType codec);
00242
00243     private:
00244
00246         enum StateType {
00247             IdleState = 0,
00248             OpeningState,
00249             OpenState,
00250             ClosingState
00251         };
00252
00253         struct StateFlags {
00254             UINT m_state                        :2;
00255             UINT m_set_config_called            :1;
00256             UINT m_out_buffers_allocated        :1;
00257             UINT m_callback_funcs_registered    :1;
00258             UINT m_stop_requested               :1;
00259             UINT m_decode_op_running            :1;
00260         };
00261
00262         class OperationInfo {
00263             public:
00264                 enum OperationType {
00265                     DecodeBufferOp,
00266                     DecodeFrameOp,
00267                 };
00268
00269                 OperationType m_op;
00270                 UINT8 HUGE* m_in_buf;
00271                 UINT32 m_in_buf_len;
00272                 UINT8 HUGE* m_out_buf;
00273                 UINT32 m_out_buf_len;
00274
00275                 OperationInfo();
00276
00277                 OperationInfo(  OperationType op,
00278                                 UINT8* in_buf,
00279                                 UINT32 in_buf_len,
00280                                 UINT8 HUGE* out_buf,
00281                                 UINT32 out_buf_len);
00282
00283                 OperationInfo(const OperationInfo& op_info);
00284
00285                 OperationInfo& operator=(const OperationInfo& op_info);
00286
00287                 virtual ~OperationInfo();
00288         }; // OperationInfo
00289
00292         CbFrameDecoded m_cb_frame_decoded;
00293
00296         static EmzAacDecoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_aac_dec_inst];
00299         void* m_client_context;
00301         UINT32 m_max_out_frame_len;
00303         UINT32 m_out_buf_len;
00307         UINT8 HUGE** m_out_buf_array;
00313         UINT8 m_out_buf_array_count;
00315         StateFlags m_flags;
00317         EmzUtils::Queue<OperationInfo> m_ops_queue;
00320         CodecType m_codec;
00321         EmzAacDecoderThread* m_thread;
00322
00324         EmzAacDecoder();
00325
00326
00333         ResultType FreeOutputBuffers();
00334
00337         void ReleaseDecoder();
00338
00339     friend class EmzCodecsLib; // creates/destroys EmzAacDecoder
00340
00341     friend class EmzAacDecoderThread;
00342
00343 };
00344
00346 #endif // Apoxi_EmzAacDecoder_hpp
00347
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzAacDecoderThread.hpp"
#include <EmzCodecs/AacDecoder/AacCodec.h>

Include dependency graph for EmzAacDecoderThread.cpp:

Variables

const INT | c_emz_codec_aac_dec_thread_prio = 104
const UINT32 | c_emz_codec_aac_dec_thread_stacksize = 16384

Variable Documentation

const INT c_emz_codec_aac_dec_thread_prio = 104

Priority of the audio decoder thread.

const UINT32 c_emz_codec_aac_dec_thread_stacksize = 16384

Size (in bytes) of the thread's stack (shall be multiple of 4).

Generated on Tue Jan 24 20:29:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmzAacDecoder.hpp"

Include dependency graph for EmzAacDecoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzAacDecoderThread

Defines

#define | EmzAacDecoderThread_hpp

Define Documentation

#define EmzAacDecoderThread_hpp

Generated on Tue Jan 24 20:30:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzAacDecoderThread_hpp)
00010 #define EmzAacDecoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/AudioDecoder.hpp>
00018 #include "EmzAacDecoder.hpp"
00019
00020 #ifndef APOXI_EMZ_AAC_PLUS_V2_DEC_ENABLED
00021 #define APOXI_EMZ_AAC_PLUS_V2_DEC_ENABLED
00022 #endif //APOXI_EMZ_AAC_PLUS_V2_DEC_ENABLED
00023
00025 class EmzAacDecoderThread : public Thread {
00026
00027     typedef Thread Base;
00028
00029     public:
00030
00032         virtual INT ThreadFn();
00033
00034     private:
00035
00037         int m_exited;
00039         Semaphore m_thread_sem;
00041         Semaphore m_stop_sem;
00043         EmzAacDecoder* m_device;
00045         void* m_base;
00047         void* m_frame_info;
00049         void* m_stack;
00050
00052         EmzAacDecoderThread();
00053
00055         virtual ~EmzAacDecoderThread();
00056
00066         virtual CodecDevice::ResultType Start(  EmzAacDecoder* parent);
00067
00073         virtual void Stop();
00074
00100         CodecDevice::ResultType SetConfig(  const UINT8* config_stream,
00101                                             UINT32& config_len,
00102                                             const CodecDevice::AudioDecoderParameters& params,
00103                                             CodecDevice::AudioStreamInfo& stream_info);
00104
00110         CodecDevice::ResultType ConvertResultCode(INT32 result_code);
00111
00115         void DecodeBufferSynchronously(EmzAacDecoder::OperationInfo& op);
00116
00117     friend class EmzAacDecoder; // creates/destroys EmzAacDecoderThread
00118
00119 };
00120
00122 #endif // EmzAacDecoderThread_hpp
00123
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzCodecsLib.hpp"
#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include "EmzMpeg4Encoder.hpp"
#include "EmzMpeg4Decoder.hpp"
#include "EmzH264Decoder.hpp"
#include "EmzAacDecoder.hpp"
#include "EmzMp3Decoder.hpp"
#include <Mpeg4SpDecoder/exp_emz_common.h>

Include dependency graph for EmzCodecsLib.cpp:

Functions

void | emz_free (void *p)
void * | emz_malloc (tEmzInt32 size)
void * | emz_realloc (void *oldaddress, tEmzInt32 newsize)

Function Documentation

void emz_free ( void * p )

void* emz_malloc ( tEmzInt32 size )

void* emz_realloc | ( | void * | oldaddress,
 |  | tEmzInt32 | newsize
 | ) |

Generated on Tue Jan 24 20:30:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzCodecsLib

Defines

#define | EmzCodecsLib_hpp

Define Documentation

#define EmzCodecsLib_hpp

Generated on Tue Jan 24 20:30:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzCodecsLib_hpp)
00010 #define EmzCodecsLib_hpp
00013
00014
00015 class EmzCodecsLib {
00016     private:
00017
00020         static void LoadLib();
00021
00022     friend class CodecConfig; // loads this library
00023
00024 };
00025
00027 #endif // EmzCodecsLib_hpp
00028
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzCodecsPreComp.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzCodecsPreComp.cpp File Reference

#include "EmzCodecsPreComp.hpp"

Include dependency graph for EmzCodecsPreComp.cpp:

Generated on Tue Jan 24 20:30:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzCodecsPreComp.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzCodecsPreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for EmzCodecsPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:30:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzCodecsPreComp.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzCodecsPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Kernel/Types.hpp>
00011 #include <Kernel/Os/Os.hpp>
00012
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzH264Decoder.hpp"
#include "EmzH264DecoderThread.hpp"

Include dependency graph for EmzH264Decoder.cpp:

Variables

const UINT8 | c_emz_codec_h264_dec_op_queue_max_count = 10
const UINT8 | c_emz_codec_h264_dec_out_buf_max_count = 1
const UINT8 | c_emz_codec_h264_dec_out_buf_min_count = 1

Variable Documentation

const UINT8 c_emz_codec_h264_dec_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_h264_dec_out_buf_max_count = 1

Maximum number of the video decoder output buffers.

const UINT8 c_emz_codec_h264_dec_out_buf_min_count = 1

Minimum number of the video decoder output buffers.

Generated on Tue Jan 24 20:30:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzH264Decoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzH264Decoder
class | EmzH264Decoder::OperationInfo
struct | EmzH264Decoder::StateFlags

Defines

#define | EmzH264Decoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_h264_dec_inst = 1

Define Documentation

#define EmzH264Decoder_hpp

Generated on Tue Jan 24 20:30:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzH264Decoder_hpp)
00010 #define EmzH264Decoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoDecoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzH264DecoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_h264_dec_inst = 1;
00023
00025 class EmzH264Decoder : public VideoDecoder {
00026
00027     typedef VideoDecoder Base;
00028
00029     public:
00030
00032         virtual ~EmzH264Decoder();
00033
00035         virtual ResultType GetProperties(Properties& properties);
00036
00038         virtual ResultType Open(VideoDecoderInfo& dec_info);
00039
00041         virtual ResultType Close();
00042
00044         virtual ResultType Start( CbResultAndTimeInfo cb_video_decoder_started,
00045                                   void* context);
00046
00048         virtual ResultType Stop( CbResult cb_video_decoder_stopped,
00049                                  void* context);
00050
00052         virtual ResultType SetConfig(
00053                             const UINT8* config_stream,
00054                             UINT32& config_len,
00055                             const VideoDecoderParameters& params,
00056                             VideoStreamInfo& stream_info);
00057
00069         virtual ResultType GetCapabilities(VideoCodecCapabilities& caps);
00070
00090         virtual ResultType AllocateOutputBuffers(   UINT8& out_buf_count,
00091                                                                 UINT32& out_buf_len);
00092
00099         virtual ResultType GetNumberOfInitialDecodeOperations(UINT8& operations);
00100
00121         virtual ResultType RegisterCallbackFunctions(   void* context,
00122                                                                     CbFrameDecoded cb_frame_decoded,
00123                                                                     CbInBufferFree cb_in_buf_free);
00124
00126         virtual ResultType SetAssociatedAudioCh(UINT32 audio_channel);
00127
00129         virtual ResultType SetVideoClockTime(UINT32 time_ms);
00130
00132         virtual ResultType GetCurrentVideoClockTime(UINT32& time_ms);
00133
00134
00149         virtual ResultType DecodeFrame( const UINT8 HUGE* in_buf,
00150                                                         UINT32 in_buf_len,
00151                                                         UINT16 flags,
00152                                                         UINT32 time_stamp);
00153
00168         virtual ResultType DecodePacket(    const UINT8 HUGE* in_buf,
00169                                                         UINT32 in_buf_len,
00170                                                         UINT16 flags);
00171
00184         virtual ResultType ReleaseOutputBuffer(const UINT8 HUGE* out_buf);
00185
00198         virtual ResultType NotifyOutputBufferReleased(const UINT8 HUGE* out_buf);
00199
00201         virtual ResultType FlushBuffers( CbResult cb_video_decoder_flushed,
00202                                          void* context);
00203
00205         virtual ResultType Reset();
00206
00207
00225         virtual ResultType SetParameters(   const ParameterType* types_array,
00226                                                         const UINT32* values_array,
00227                                                         UINT8 array_count);
00228
00249         virtual ResultType GetParameters(   const ParameterType* types_array,
00250                                                         UINT32* values_array,
00251                                                         UINT8 array_count);
00252
00253     protected:
00254
00256         virtual ResultType SetCodec(CodecType codec);
00257
00258     private:
00259
00261         enum StateType {
00262             IdleState = 0,
00263             OpeningState,
00264             OpenState,
00265             ClosingState
00266         };
00267
00268         struct StateFlags {
00269             UINT m_state                        :2;
00270             UINT m_set_config_called            :1;
00271             UINT m_out_buffers_allocated        :1;
00272             UINT m_callback_funcs_registered    :1;
00273             UINT m_start_requested              :1;
00274             UINT m_stop_requested               :1;
00275             UINT m_close_requested              :1;
00276             UINT m_decode_op_running            :1;
00277             UINT m_flush_requested              :1;
00278         };
00279
00280         class OperationInfo {
00281             public:
00282                 enum OperationType {
00283                     DecodeFrameOp,
00284                     DecodePacketOp,
00285                     SetParametersOp
00286                 };
00287
00288                 OperationType m_op;
00289                 UINT8* m_in_buf;
00290                 UINT32 m_in_buf_len;
00291                 UINT16 m_flags;
00292
00293                 OperationInfo();
00294
00295                 OperationInfo(  OperationType op,
00296                                         UINT8* in_buf,
00297                                         UINT32 in_buf_len,
00298                                         UINT16 flags);
00299
00300                 OperationInfo(const OperationInfo& op_info);
00301
00302                 OperationInfo& operator=(const OperationInfo& op_info);
00303
00304                 virtual ~OperationInfo();
00305         }; // OperationInfo
00306
00309         CbFrameDecoded m_cb_frame_decoded;
00312         CbInBufferFree m_cb_in_buf_free;
00313
00316         static EmzH264Decoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_h264_dec_inst];
00319         void* m_client_context;
00323         UINT8 HUGE** m_out_buf_array;
00329         UINT8 m_out_buf_max_count;
00332         UINT8 m_out_buf_cur_used_count;
00334         StateFlags m_flags;
00336         CodecType m_codec;
00338         EmzUtils::Queue<OperationInfo> m_ops_queue;
00340         EmzH264DecoderThread* m_thread;
00342         CbResultAndTimeInfo m_cb_start;
00344         CbResult m_cb_stop;
00346         void* m_context_start;
00348         void* m_context_stop;
00350         CbResult m_cb_flush;
00352         void* m_context_flush;
00355         ParameterType* m_types_arr;
00358         UINT32* m_values_arr;
00359
00361         EmzH264Decoder();
00362
00363
00367         void ReleaseDevice();
00368
00369     friend class EmzCodecsLib; // creates/destroys EmzH264Decoder
00370
00371     friend class EmzH264DecoderThread;
00372
00373 };
00374
00376 #endif // EmzH264Decoder_hpp
00377
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzH264DecoderThread.hpp"

Include dependency graph for EmzH264DecoderThread.cpp:

Variables

const INT | c_emz_codec_h264_dec_thread_prio = 104
const UINT32 | c_emz_codec_h264_dec_thread_stacksize = 16384

Variable Documentation

const INT c_emz_codec_h264_dec_thread_prio = 104

Priority of the video decoder thread.

const UINT32 c_emz_codec_h264_dec_thread_stacksize = 16384

Size (in bytes) of the thread's stack (shall be multiple of 4).

Generated on Tue Jan 24 20:30:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>
#include "EmzH264Decoder.hpp"
#include <EmzCodecs/H264Decoder/exp_h264_smp_decoder.h>

Include dependency graph for EmzH264DecoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzH264DecoderThread

Defines

#define | EmzH264DecoderThread_hpp

Define Documentation

#define EmzH264DecoderThread_hpp

Generated on Tue Jan 24 20:30:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzH264DecoderThread_hpp)
00010 #define EmzH264DecoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/VideoDecoder.hpp>
00018 #include "EmzH264Decoder.hpp"
00019
00020 extern "C"{
00021 #include <EmzCodecs/H264Decoder/exp_h264_smp_decoder.h>
00022 }
00023
00026 class EmzH264DecoderThread : public Thread {
00027
00028     typedef Thread Base;
00029
00030     public:
00031
00033         virtual INT ThreadFn();
00034
00035     private:
00036
00038         int m_exited;
00040         Semaphore m_thread_sem;
00042         Semaphore m_stop_sem;
00043
00045         EmzH264Decoder* m_device;
00048         tBaseVideoDecoder* m_base;
00049
00051         void* m_stack;
00052
00054         EmzH264DecoderThread();
00055
00057         virtual ~EmzH264DecoderThread();
00058
00068         virtual CodecDevice::ResultType Start( EmzH264Decoder* parent);
00069
00075         virtual void Stop();
00076
00094         CodecDevice::ResultType SetParameters(  const VideoDecoder::ParameterType* types_array,
00095                                                 const UINT32* values_array,
00096                                                 UINT8 array_count);
00097
00118         CodecDevice::ResultType GetParameters(  const VideoDecoder::ParameterType* types_array,
00119                                                 UINT32* values_array,
00120                                                 UINT8 array_count);
00121
00122
00128         CodecDevice::ResultType ConvertResultCode(INT32 result_code);
00129
00130
00134         void DecodeFrameSynchronously(EmzH264Decoder::OperationInfo& op);
00135
00139         void DecodePacketSynchronously(EmzH264Decoder::OperationInfo& op);
00140
00142         void Reset();
00143
00144
00175         CodecDevice::ResultType SetConfig( const UINT8* config_stream,
00176                                                     UINT32& config_len,
00177                                                     const CodecDevice::VideoDecoderParameters& params,
00178                                                     CodecDevice::VideoStreamInfo& stream_info);
00179
00180
00181     friend class EmzH264Decoder; // creates/destroys EmzH264DecoderThread
00182
00183 };
00184
00186 #endif // EmzH264DecoderThread_hpp
00187
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzMp3Decoder.hpp"
#include "EmzMp3DecoderThread.hpp"

Include dependency graph for EmzMp3Decoder.cpp:

Variables

const UINT8 | c_emz_codec_mp3_dec_multi_frame_out_buf_max_count = 5
const UINT32 | c_emz_codec_mp3_dec_multi_frame_out_buf_max_len = 20000
const UINT8 | c_emz_codec_mp3_dec_multi_frame_out_buf_min_count = 2
const UINT8 | c_emz_codec_mp3_dec_op_queue_max_count = 10
const UINT8 | c_emz_codec_mp3_dec_single_frame_out_buf_max_count = 10
const UINT8 | c_emz_codec_mp3_dec_single_frame_out_buf_min_count = 2

Variable Documentation

const UINT8 c_emz_codec_mp3_dec_multi_frame_out_buf_max_count = 5

Maximum number of the audio decoder output buffers (for DecodeBuffer).

const UINT32 c_emz_codec_mp3_dec_multi_frame_out_buf_max_len = 20000

Length (in bytes) of the audio decoder output buffer (for DecodeBuffer).

const UINT8 c_emz_codec_mp3_dec_multi_frame_out_buf_min_count = 2

Minimum number of the audio decoder output buffers (for DecodeBuffer).

const UINT8 c_emz_codec_mp3_dec_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_mp3_dec_single_frame_out_buf_max_count = 10

Maximum number of the audio decoder output buffers (for DecodeFrame).

const UINT8 c_emz_codec_mp3_dec_single_frame_out_buf_min_count = 2

Minimum number of the audio decoder output buffers (for DecodeFrame).

Generated on Tue Jan 24 20:30:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzMp3Decoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMp3Decoder
class | EmzMp3Decoder::OperationInfo
struct | EmzMp3Decoder::StateFlags

Defines

#define | Apoxi_EmzMp3Decoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_mp3_dec_inst = 1

Define Documentation

#define Apoxi_EmzMp3Decoder_hpp

Generated on Tue Jan 24 20:30:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_EmzMp3Decoder_hpp)
00010 #define Apoxi_EmzMp3Decoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/AudioDecoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzMp3DecoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_mp3_dec_inst = 1;
00023
00025 class EmzMp3Decoder : public AudioDecoder {
00026
00027     typedef AudioDecoder Base;
00028
00029     public:
00030
00032         virtual ~EmzMp3Decoder();
00033
00035         virtual ResultType GetProperties(Properties& properties);
00036
00045         virtual ResultType Open();
00046
00052         virtual void Close();
00053
00078         virtual ResultType SetConfig(   const UINT8* config_stream,
00079                                         UINT32& config_len,
00080                                         const AudioDecoderParameters& params,
00081                                         AudioStreamInfo& stream_info);
00093         virtual ResultType GetCapabilities(
00094                                 AudioCodecCapabilities& caps);
00095
00122         virtual ResultType AllocateOutputBuffers(
00123                                             UINT8 HUGE** &out_buf_array,
00124                                             UINT8& out_buf_count,
00125                                             UINT32& out_buf_len,
00126                                             DecodingFunctionType& dec_fct);
00127
00143         virtual ResultType RegisterCallbackFunctions(
00144                                         void* context,
00145                                         CbFrameDecoded cb_frame_decoded);
00146
00165         virtual ResultType DecodeBuffer(
00166                                                     const UINT8 HUGE* in_buf,
00167                                                     UINT32 in_buf_len,
00168                                                     const UINT8 HUGE* out_buf,
00169                                                     UINT32 out_buf_len);
00170
00189         virtual ResultType DecodeFrame(
00190                                                     const UINT8 HUGE* in_buf,
00191                                                     UINT32 in_buf_len,
00192                                                     const UINT8 HUGE* out_buf,
00193                                                     UINT32 out_buf_len);
00194
00213         virtual ResultType SetParameters(
00214                                             const ParameterType* types_array,
00215                                             const UINT32* values_array,
00216                                             UINT8 array_count);
00217
00239         virtual ResultType GetParameters(
00240                                             const ParameterType* types_array,
00241                                             UINT32* values_array,
00242                                             UINT8 array_count);
00243     protected:
00244
00246         virtual ResultType SetCodec(CodecType codec);
00247
00248     private:
00249
00251         enum StateType {
00252             IdleState = 0,
00253             OpeningState,
00254             OpenState,
00255             ClosingState
00256         };
00257
00258         struct StateFlags {
00259             UINT m_state                        :2;
00260             UINT m_set_config_called            :1;
00261             UINT m_out_buffers_allocated        :1;
00262             UINT m_callback_funcs_registered    :1;
00263             UINT m_stop_requested               :1;
00264             UINT m_decode_op_running            :1;
00265         };
00266
00267         class OperationInfo {
00268             public:
00269                 enum OperationType {
00270                     DecodeBufferOp,
00271                     DecodeFrameOp
00272                 };
00273
00274                 OperationType m_op;
00275                 UINT8 HUGE* m_in_buf;
00276                 UINT32 m_in_buf_len;
00277                 UINT8 HUGE* m_out_buf;
00278                 UINT32 m_out_buf_len;
00279
00280                 OperationInfo();
00281
00282                 OperationInfo(  OperationType op,
00283                                         UINT8* in_buf,
00284                                         UINT32 in_buf_len,
00285                                         UINT8 HUGE* out_buf,
00286                                         UINT32 out_buf_len);
00287
00288                 OperationInfo(const OperationInfo& op_info);
00289
00290                 OperationInfo& operator=(const OperationInfo& op_info);
00291
00292                 virtual ~OperationInfo();
00293         }; // OperationInfo
00294
00297         CbFrameDecoded m_cb_frame_decoded;
00298
00301         static EmzMp3Decoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_mp3_dec_inst];
00304         void* m_client_context;
00306         UINT32 m_max_out_frame_len;
00308         UINT32 m_out_buf_len;
00312         UINT8 HUGE** m_out_buf_array;
00318         UINT8 m_out_buf_array_count;
00320         StateFlags m_flags;
00322         EmzUtils::Queue<OperationInfo> m_ops_queue;
00324         CodecType m_codec;
00326         EmzMp3DecoderThread* m_thread;
00327
00329         EmzMp3Decoder();
00330
00337         virtual ResultType FreeOutputBuffers();
00338
00341         void ReleaseDecoder();
00342
00343     friend class EmzCodecsLib; // creates/destroys EmzMp3Decoder
00344
00345     friend class EmzMp3DecoderThread;
00346
00347 };
00348
00350 #endif // Apoxi_EmzMp3Decoder_hpp
00351
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include "EmzMp3DecoderThread.hpp"
#include <EmzCodecs/Mp3Decoder/exp_emz_common.h>
#include <EmzCodecs/Mp3Decoder/export_mp3_decoder.h>

Include dependency graph for EmzMp3DecoderThread.cpp:

Variables

const INT c_emz_codec_mp3_dec_thread_prio = 104

Variable Documentation

const INT c_emz_codec_mp3_dec_thread_prio = 104

Priority of the audio decoder thread.

Generated on Tue Jan 24 20:30:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/AudioDecoder.hpp>
#include "EmzMp3Decoder.hpp"

Include dependency graph for EmzMp3DecoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMp3DecoderThread

Defines

#define | EmzMp3DecoderThread_hpp

Define Documentation

#define EmzMp3DecoderThread_hpp

Generated on Tue Jan 24 20:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMp3DecoderThread_hpp)
00010 #define EmzMp3DecoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/AudioDecoder.hpp>
00018 #include "EmzMp3Decoder.hpp"
00019
00021 class EmzMp3DecoderThread : public Thread {
00022
00023     typedef Thread Base;
00024
00025     public:
00026
00028         virtual INT ThreadFn();
00029
00030     private:
00031
00033         int m_exited;
00035         Semaphore m_thread_sem;
00037         Semaphore m_stop_sem;
00038
00040         EmzMp3Decoder* m_device;
00042         void* m_base;
00043
00045         EmzMp3DecoderThread();
00046
00048         virtual ~EmzMp3DecoderThread();
00049
00059         virtual CodecDevice::ResultType Start(  EmzMp3Decoder* parent);
00060
00066         virtual void Stop();
00067
00073         CodecDevice::ResultType ConvertResultCode(INT32 result_code);
00074
00078         void DecodeBufferSynchronously(EmzMp3Decoder::OperationInfo& op);
00079
00104         CodecDevice::ResultType SetConfig(  const UINT8* config_stream,
00105                                             UINT32& config_len,
00106                                             const CodecDevice::AudioDecoderParameters& params,
00107                                             CodecDevice::AudioStreamInfo& stream_info);
00108
00109     friend class EmzMp3Decoder; // creates/destroys EmzMp3DecoderThread
00110
00111 };
00112
00114 #endif // EmzMp3DecoderThread_hpp
00115
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.cpp File Reference

#include "EmzMpeg4Decoder.hpp"
#include "EmzMpeg4DecoderThread.hpp"

Include dependency graph for EmzMpeg4Decoder.cpp:

Variables

const UINT8 | c_emz_codec_mpeg4_dec_op_queue_max_count = 10
const UINT8 | c_emz_codec_mpeg4_dec_out_buf_max_count = 2
const UINT8 | c_emz_codec_mpeg4_dec_out_buf_min_count = 1

Variable Documentation

const UINT8 c_emz_codec_mpeg4_dec_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_mpeg4_dec_out_buf_max_count = 2

Maximum number of the video decoder output buffers.

const UINT8 c_emz_codec_mpeg4_dec_out_buf_min_count = 1

Minimum number of the video decoder output buffers.

Generated on Tue Jan 24 20:30:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzMpeg4Decoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMpeg4Decoder
class | EmzMpeg4Decoder::OperationInfo
struct | EmzMpeg4Decoder::StateFlags

Defines

#define | EmzMpeg4Decoder_hpp

Variables

const UINT8 | c_emz_codec_max_num_of_mpeg4_dec_inst = 1

Define Documentation

#define EmzMpeg4Decoder_hpp

Generated on Tue Jan 24 20:30:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMpeg4Decoder_hpp)
00010 #define EmzMpeg4Decoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoDecoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00019 class EmzMpeg4DecoderThread;
00020
00022 const UINT8 c_emz_codec_max_num_of_mpeg4_dec_inst = 1;
00023
00025 class EmzMpeg4Decoder : public VideoDecoder {
00026
00027     typedef VideoDecoder Base;
00028
00029     public:
00030
00032         virtual ~EmzMpeg4Decoder();
00033
00035         virtual ResultType GetProperties(Properties& properties);
00036
00038         virtual ResultType Open(VideoDecoderInfo& dec_info);
00039
00041         virtual ResultType Close();
00042
00044         virtual ResultType Start(CbResultAndTimeInfo cb_video_decoder_started,
00045                                 void* context);
00046
00048         virtual ResultType Stop(CbResult cb_video_decoder_stopped,
00049                                 void* context);
00050
00052         virtual ResultType SetConfig(
00053                             const UINT8* config_stream,
00054                             UINT32& config_len,
00055                             const VideoDecoderParameters& params,
00056                             VideoStreamInfo& stream_info);
00057
00058
00060         virtual ResultType GetCapabilities(
00061                                 VideoCodecCapabilities& caps);
00062
00064         virtual ResultType AllocateOutputBuffers(   UINT8& out_buf_count,
00065                                                         UINT32& out_buf_len);
00066
00067
00069         virtual ResultType RegisterCallbackFunctions(   void* context,
00070                                                         CbFrameDecoded cb_frame_decoded,
00071                                                         CbInBufferFree cb_in_buf_free);
00072
00074         virtual ResultType SetAssociatedAudioCh(UINT32 audio_channel);
00075
00077         virtual ResultType SetVideoClockTime(UINT32 time_ms);
00078
00080         virtual ResultType GetCurrentVideoClockTime(UINT32& time_ms);
00081
00082
00084         virtual ResultType DecodeFrame( const UINT8 HUGE* in_buf,
00085                                         UINT32 in_buf_len,
00086                                         UINT16 flags,
00087                                         UINT32 time_stamp);
00088
00090         virtual ResultType DecodePacket(const UINT8 HUGE* in_buf,
00091                                         UINT32 in_buf_len,
00092                                         UINT16 flags);
00093
00095         virtual ResultType ReleaseOutputBuffer( const UINT8 HUGE* out_buf);
00096
00097
00099         virtual ResultType FlushBuffers( CbResult cb_video_decoder_flushed,
00100                                          void* context);
00101
00102
00103     protected:
00104
00106         virtual ResultType SetCodec(CodecType codec);
00107
00108
00109     private:
00110
00112         enum StateType {
00113             IdleState = 0,
00114             OpeningState,
00115             OpenState,
00116             ClosingState
00117         };
00118
00119         struct StateFlags {
00120             UINT m_state                        :2;
00121             UINT m_set_config_called            :1;
00122             UINT m_out_buffers_allocated        :1;
00123             UINT m_callback_funcs_registered    :1;
00124             UINT m_start_requested              :1;
00125             UINT m_stop_requested               :1;
00126             UINT m_close_requested              :1;
00127             UINT m_decode_op_running            :1;
00128             UINT m_flush_requested              :1;
00129         };
00130
00131         class OperationInfo {
00132             public:
00133                 enum OperationType {
00134                     DecodeFrameOp,
00135                     DecodePacketOp
00136                 };
00137
00138                 OperationType m_op;
00139                 UINT8* m_in_buf;
00140                 UINT32 m_in_buf_len;
00141                 UINT16 m_flags;
00142
00143                 OperationInfo();
00144
00145                 OperationInfo(  OperationType op,
00146                                         UINT8* in_buf,
00147                                         UINT32 in_buf_len,
00148                                         UINT16 flags);
00149
00150                 OperationInfo(const OperationInfo& op_info);
00151
00152                 OperationInfo& operator=(const OperationInfo& op_info);
00153
00154                 virtual ~OperationInfo();
00155         }; // OperationInfo
00156
00159         CbFrameDecoded m_cb_frame_decoded;
00162         CbInBufferFree m_cb_in_buf_free;
00163
00166         static EmzMpeg4Decoder* m_exist_this_ptr_array[c_emz_codec_max_num_of_mpeg4_dec_inst];
00169         void* m_client_context;
00173         UINT8 HUGE** m_out_buf_array;
00179         UINT8 m_out_buf_max_count;
00182         UINT8 m_out_buf_cur_used_count;
00184         StateFlags m_flags;
00186         CodecType m_codec;
00188         EmzUtils::Queue<OperationInfo> m_ops_queue;
00190         EmzMpeg4DecoderThread* m_thread;
00192         CbResultAndTimeInfo m_cb_start;
00194         CbResult m_cb_stop;
00196         void* m_context_start;
00198         void* m_context_stop;
00200         CbResult m_cb_flush;
00202         void* m_context_flush;
00203
00205         EmzMpeg4Decoder();
00206
00210         void ReleaseDecoder();
00211
00212     friend class EmzCodecsLib; // creates/destroys EmzMpeg4Decoder
00213
00214     friend class EmzMpeg4DecoderThread;
00215
00216 };
00217
00219 #endif // EmzMpeg4Decoder_hpp
00220
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include <Auxiliary/BufferPoolManager.hpp>
#include "EmzMpeg4DecoderThread.hpp"

Include dependency graph for EmzMpeg4DecoderThread.cpp:

Variables

const INT c_emz_codec_mpeg4_dec_thread_prio = 104

Variable Documentation

const INT c_emz_codec_mpeg4_dec_thread_prio = 104

Priority of the video decoder thread.

Generated on Tue Jan 24 20:30:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>
#include "EmzMpeg4Decoder.hpp"
#include <EmzCodecs/Mpeg4SpDecoder/exp_MP4SP_VD.h>
#include <EmzCodecs/Mpeg4SpDecoder/exp_H263_VD.h>

Include dependency graph for EmzMpeg4DecoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMpeg4DecoderThread

Defines

#define | EmzMpeg4DecoderThread_hpp

Define Documentation

#define EmzMpeg4DecoderThread_hpp

Generated on Tue Jan 24 20:30:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMpeg4DecoderThread_hpp)
00010 #define EmzMpeg4DecoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/VideoDecoder.hpp>
00018 #include "EmzMpeg4Decoder.hpp"
00019
00020 extern "C"{
00021 #include <EmzCodecs/Mpeg4SpDecoder/exp_MP4SP_VD.h>
00022 #include <EmzCodecs/Mpeg4SpDecoder/exp_H263_VD.h>
00023 }
00024
00026 class EmzMpeg4DecoderThread : public Thread {
00027
00028     typedef Thread Base;
00029
00030     public:
00031
00033         virtual INT ThreadFn();
00034
00035     private:
00036
00038         int m_exited;
00040         Semaphore m_thread_sem;
00042         Semaphore m_stop_sem;
00043
00045         EmzMpeg4Decoder* m_device;
00048         tBaseVideoDecoder* m_base;
00049
00051         EmzMpeg4DecoderThread();
00052
00054         virtual ~EmzMpeg4DecoderThread();
00055
00065         virtual VideoDecoder::ResultType Start( EmzMpeg4Decoder* parent);
00066
00072         virtual void Stop();
00073
00101         virtual VideoDecoder::ResultType SetConfig(
00102                             const UINT8* config_stream,
00103                             UINT32& config_len,
00104                             const VideoDecoder::VideoDecoderParameters& params,
00105                             VideoDecoder::VideoStreamInfo& stream_info);
00106
00112         VideoDecoder::ResultType ConvertResultCode(INT32 result_code);
00113
00114
00118         void DecodeFrameSynchronously(EmzMpeg4Decoder::OperationInfo& op);
00119
00123         void DecodePacketSynchronously(EmzMpeg4Decoder::OperationInfo& op);
00124
00125     friend class EmzMpeg4Decoder; // creates/destroys EmzMpeg4DecoderThread
00126
00127 };
00128
00130 #endif // EmzMpeg4DecoderThread_hpp
00131
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.cpp File Reference

#include <Auxiliary/BufferPoolManager.hpp>
#include "EmzMpeg4Encoder.hpp"
#include "EmzMpeg4EncoderThread.hpp"

Include dependency graph for EmzMpeg4Encoder.cpp:

Variables

const UINT8 | c_emz_codec_mpeg4_enc_op_queue_max_count = 10
const UINT8 | c_emz_codec_mpeg4_enc_out_buf_max_count = 10
const UINT8 | c_emz_codec_mpeg4_enc_out_buf_min_count = 1

Variable Documentation

const UINT8 c_emz_codec_mpeg4_enc_op_queue_max_count = 10

Maximum number of the queued coding operations.

const UINT8 c_emz_codec_mpeg4_enc_out_buf_max_count = 10

Maximum number of the output buffers.

const UINT8 c_emz_codec_mpeg4_enc_out_buf_min_count = 1

Maximum number of the output buffers.

Generated on Tue Jan 24 20:30:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoEncoder.hpp>
#include "EmzUtils.hpp"

Include dependency graph for EmzMpeg4Encoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMpeg4Encoder
class | EmzMpeg4Encoder::OperationInfo
struct | EmzMpeg4Encoder::StateFlags

Defines

#define | EmzMpeg4Encoder_hpp

Variables

const UINT8 | c_emz_codecs_max_num_of_mpeg4_enc_inst = 1

Define Documentation

#define EmzMpeg4Encoder_hpp

Generated on Tue Jan 24 20:30:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMpeg4Encoder_hpp)
00010 #define EmzMpeg4Encoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoEncoder.hpp>
00017 #include "EmzUtils.hpp"
00018
00020 const UINT8 c_emz_codecs_max_num_of_mpeg4_enc_inst = 1;
00021
00022 class EmzMpeg4EncoderThread;
00023
00026 class EmzMpeg4Encoder : public VideoEncoder {
00027
00028     typedef VideoEncoder Base;
00029
00030     public:
00031
00033         virtual ~EmzMpeg4Encoder();
00034
00036         virtual ResultType GetProperties(Properties& properties);
00037
00039         virtual ResultType GetCapabilities(VideoCodecCapabilities& caps);
00040
00042         virtual ResultType Open();
00043
00045         virtual ResultType Close();
00046
00048         virtual ResultType Start();
00049
00051         virtual ResultType Stop(CbResult cb_video_decoder_stopped,
00052                                 void* context);
00053
00055         virtual ResultType SetConfig( const VideoEncoderParameters& params,
00056                                       UINT32& out_buf_max_len);
00057
00059         virtual ResultType SetDynamicConfig( VideoEncoderDynParameters &params);
00060
00062         virtual ResultType AllocateOutputBuffers( UINT8& out_buf_count,
00063                                                   UINT32& out_buf_len);
00064
00066         virtual ResultType RegisterCallbackFunctions( void* context,
00067                                                       CbVideoFrameEncoded cb_frame_encoded);
00068
00070         virtual ResultType EncodeFrame( UINT8 HUGE* in_buf,
00071                                         UINT32 time_stamp,
00072                                         UINT32 key_frame_ind);
00073
00075         virtual ResultType ReleaseOutputBuffer(UINT8 HUGE* out_buf);
00076
00078         virtual ResultType GetConfigStream( UINT8 HUGE*& out_buf,
00079                                             UINT32& out_buf_len);
00080
00082         virtual ResultType ReleaseConfigStreamBuffer(UINT8 HUGE* buf);
00083
00085         virtual ResultType FlushBuffers(CbResult cb_video_encoder_flushed,
00086                                         void* context);
00087
00089         virtual ResultType SetCodec(CodecType codec);
00090
00092         virtual ResultType InsertKeyFrame();
00093
00094     private:
00095
00097         enum StateType {
00098             IdleState = 0,
00099             OpeningState,
00100             OpenState,
00101             ClosingState
00102         };
00103
00104         struct StateFlags {
00105             UINT m_state                        :2;
00106             UINT m_out_buffers_allocated        :1;
00107             UINT m_callback_funcs_registered    :1;
00108             UINT m_close_requested              :1;
00109             UINT m_stop_requested               :1;
00110             UINT m_set_config_called            :1;
00111             UINT m_encode_op_running            :1;
00112             UINT m_flush_requested              :1;
00113         };
00114
00115         class OperationInfo {
00116
00117             public:
00118                 enum OperationType {
00119                     EncodeFrameOp
00120                 };
00121
00122                 OperationType m_op;
00123                 UINT8 HUGE* m_in_buf;
00124                 UINT32 m_time_stamp;
00125                 UINT32 m_key_frame_ind;
00126                 UINT8 HUGE* m_out_buf;
00127
00128                 OperationInfo();
00129
00130                 OperationInfo(  OperationType op,
00131                                         UINT8 HUGE* in_buf,
00132                                         UINT32 time_stamp,
00133                                         UINT32 key_frame_ind,
00134                                         UINT8 HUGE* out_buf);
00135
00136                 OperationInfo(const OperationInfo& op_info);
00137
00138                 OperationInfo& operator=(const OperationInfo& op_info);
00139
00140                 virtual ~OperationInfo();
00141         }; // OperationInfo
00142
00145         CbVideoFrameEncoded m_cb_frame_encoded;
00146
00149         static EmzMpeg4Encoder* m_exist_this_ptr_array[c_emz_codecs_max_num_of_mpeg4_enc_inst];
00152         void* m_client_context;
00154         UINT32 m_in_buf_len;
00156         UINT32 m_out_buf_len;
00159         UINT8 m_out_buf_array_count;
00161         UINT8 HUGE** m_out_buf_array;
00163         UINT32 m_out_buf_pool;
00165         StateFlags m_flags;
00167         EmzUtils::Queue<OperationInfo> m_ops_queue;
00169         CodecType m_codec;
00171         EmzMpeg4EncoderThread* m_thread;
00173         CbResult m_cb_stop;
00175         void* m_context_stop;
00177         CbResult m_cb_flush;
00179         void* m_context_flush;
00180
00182         EmzMpeg4Encoder();
00183
00187         void ReleaseEncoder();
00188
00189     friend class EmzCodecsLib; // creates/destroys the EmzMpeg4Encoder
00190
00191     friend class EmzMpeg4EncoderThread;
00192
00193 };
00194
00196 #endif // EmzMpeg4Encoder_hpp
00197
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.cpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.cpp File Reference

#include "EmzCodecsPreComp.hpp"
#include <Auxiliary/BufferPoolManager.hpp>
#include "EmzMpeg4EncoderThread.hpp"

Include dependency graph for EmzMpeg4EncoderThread.cpp:

Variables

const INT c_emz_codec_mpeg4_enc_thread_prio = 104

Variable Documentation

const INT c_emz_codec_mpeg4_enc_thread_prio = 104

Priority of the video encoder thread.

Generated on Tue Jan 24 20:30:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoEncoder.hpp>
#include "EmzMpeg4Encoder.hpp"
#include <EmzCodecs/Mpeg4SpEncoder/exp_emz_MPEG4SP_video_enc.h>
#include <EmzCodecs/Mpeg4SpEncoder/exp_emz_H263_video_enc.h>

Include dependency graph for EmzMpeg4EncoderThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzMpeg4EncoderThread

Defines

#define | EmzMpeg4EncoderThread_hpp

Define Documentation

#define EmzMpeg4EncoderThread_hpp

Generated on Tue Jan 24 20:30:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzMpeg4EncoderThread_hpp)
00010 #define EmzMpeg4EncoderThread_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <AddOns/CodecManager/CodecManager.hpp>
00017 #include <AddOns/CodecManager/VideoEncoder.hpp>
00018 #include "EmzMpeg4Encoder.hpp"
00019
00020 extern "C"{
00021 #include <EmzCodecs/Mpeg4SpEncoder/exp_emz_MPEG4SP_video_enc.h>
00022 #include <EmzCodecs/Mpeg4SpEncoder/exp_emz_H263_video_enc.h>
00023 }
00024
00026 class EmzMpeg4EncoderThread : public Thread {
00027
00028     typedef Thread Base;
00029
00030     public:
00031
00033         virtual INT ThreadFn();
00034
00035     private:
00036
00038         int m_exited;
00040         Semaphore m_thread_sem;
00042         Semaphore m_stop_sem;
00043
00045         EmzMpeg4Encoder* m_device;
00048         tBaseVideoEncoder* m_base;
00049
00050         UINT8 HUGE*        m_conf_buf;
00051
00053         EmzMpeg4EncoderThread();
00054
00056         virtual ~EmzMpeg4EncoderThread();
00057
00070         CodecDevice::ResultType Start(EmzMpeg4Encoder* video_enc);
00071
00077         void Stop();
00078
00079
00081         CodecDevice::ResultType SetConfig(const CodecDevice::VideoEncoderParameters& params,
00082                                           UINT32& out_buf_max_len);
00083
00096         CodecDevice::ResultType GetConfigStream(    UINT8 HUGE*& out_buf,
00097                                                     UINT32& out_buf_len);
00098
00100         CodecDevice::ResultType ReleaseConfigStreamBuffer(UINT8 HUGE* buf);
00101
00107         CodecDevice::ResultType ConvertResultCode(INT32 result_code);
00108
00112         void EncodeFrameSynchronously(EmzMpeg4Encoder::OperationInfo& op);
00113
00114
00116         void Reset();
00117
00118     friend class EmzMpeg4Encoder; // creates/destroys EmzMpeg4EncoderThread
00119
00120 };
00121
00123 #endif // EmzMpeg4EncoderThread_hpp
00124
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzUtils.hpp File Reference

Devices/MPEU/Extensions/EmzCodecs/EmzUtils.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for EmzUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmzUtils
class | EmzUtils::Queue< T >

Defines

#define | EmzUtils_hpp

Define Documentation

#define EmzUtils_hpp

Generated on Tue Jan 24 20:30:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/MPEU/Extensions/EmzCodecs/EmzUtils.hpp Source File

Devices/MPEU/Extensions/EmzCodecs/EmzUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmzUtils_hpp)
00010 #define EmzUtils_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00017 class EmzUtils {
00018     public:
00019
00021     template<class T> class Queue {
00022
00023         public:
00026             Queue();
00030             Queue(UINT32 max_num_of_elems);
00032             ~Queue();
00035             BOOLEAN Init(UINT32 max_num_of_elems);
00038             BOOLEAN Reset();
00041             BOOLEAN PopAll();
00042             UINT32 GetCurrentNumberOfElements() const;
00043             UINT32 GetMaxNumberOfElements() const;
00044             BOOLEAN PushBack(T& elem);
00045             BOOLEAN PushFront(T& elem);
00046             BOOLEAN PopBack();
00047             BOOLEAN PopFront();
00048             T* GetFront() const;
00049             T* GetBack() const;
00050
00051         private:
00052             UINT32 m_max_num_of_elems;
00053             UINT32 m_curr_num_of_elems;
00054             UINT32 m_curr_pos;
00055             T** m_queue;
00056     }; // class Queue
00057
00058 }; // class EmzUtils
00059
00060 // Template and inline functions
00061
00062 /*  ------------------------------------------------------------------------
00063     Queue
00064     ------------------------------------------------------------------------ */
00065 template<class T> EmzUtils::Queue<T>::Queue():
00066     m_max_num_of_elems(0),
00067     m_curr_num_of_elems(0),
00068     m_curr_pos(0),
00069     m_queue(0)
00070 {
00071 } // Queue
00072
00073 /*  ------------------------------------------------------------------------
00074     Queue
00075     ------------------------------------------------------------------------ */
00076 template<class T> EmzUtils::Queue<T>::Queue(UINT32 max_num_of_elems):
00077     m_max_num_of_elems(0),
00078     m_curr_num_of_elems(0),
00079     m_curr_pos(0),
00080     m_queue(0)
00081 {
00082     Init(max_num_of_elems);
00083 } // Queue
00084
00085 /*  ------------------------------------------------------------------------
00086     ~Queue
00087     ------------------------------------------------------------------------ */
00088 template<class T> EmzUtils::Queue<T>::~Queue()
00089 {
00090     Reset();
00091 } // ~Queue
00092
00093 /*  ------------------------------------------------------------------------
00094     Init
00095     ------------------------------------------------------------------------ */
00096 template<class T> BOOLEAN EmzUtils::Queue<T>::Init(UINT32 max_num_of_elems)
00097 {
00098     Reset();
00099     m_queue = new T*[max_num_of_elems];
00100     if (!m_queue)
00101         return FALSE;
00102     UINT32 i;
00103     for (i = 0; i < max_num_of_elems; i++) {
00104         m_queue[i] = 0;
00105     }
00106     for (i = 0; i < max_num_of_elems; i++) {
00107         m_queue[i] = new T;
00108         if (!m_queue[i]) {
00109             Reset();
00110             return FALSE;
00111         }
00112     }
00113     m_max_num_of_elems = max_num_of_elems;
00114     return TRUE;
00115 } // Init
00116
00117 /*  ------------------------------------------------------------------------
00118     Reset
00119     ------------------------------------------------------------------------ */
00120 template<class T> BOOLEAN EmzUtils::Queue<T>::Reset()
00121 {
00122     if (!m_queue)
00123         return TRUE;
00124     for (UINT32 i = 0; i < m_max_num_of_elems; i++) {
00125         delete m_queue[i];
00126         m_queue[i] = 0;
00127     }
00128     m_max_num_of_elems = 0;
00129     m_curr_num_of_elems = 0;
00130     m_curr_pos = 0;
00131     delete [] m_queue;
00132     m_queue = 0;
00133     return TRUE;
00134 } // Reset
00135
00136 /*  ------------------------------------------------------------------------
00137     PopAll
00138     ------------------------------------------------------------------------ */
00139 template<class T> BOOLEAN EmzUtils::Queue<T>::PopAll()
00140 {
00141     m_curr_num_of_elems = 0;
00142     m_curr_pos = 0;
00143     return TRUE;
00144 } // PopAll
00145
00146 /*  ------------------------------------------------------------------------
00147     GetCurrentNumberOfElements
00148     ------------------------------------------------------------------------ */
00149 template<class T> UINT32 EmzUtils::Queue<T>::GetCurrentNumberOfElements() const
00150 {
00151     return m_curr_num_of_elems;
00152 } // GetCurrentNumberOfElements
00153
00154 /*  ------------------------------------------------------------------------
00155     GetMaxNumberOfElements
00156     ------------------------------------------------------------------------ */
00157 template<class T> UINT32 EmzUtils::Queue<T>::GetMaxNumberOfElements() const
00158 {
00159     return m_max_num_of_elems;
00160 } // GetMaxNumberOfElements
00161
00162 /*  ------------------------------------------------------------------------
00163     PushBack
00164     ------------------------------------------------------------------------ */
00165 template<class T> BOOLEAN EmzUtils::Queue<T>::PushBack(T& elem)
00166 {
00167     if (m_curr_num_of_elems >= m_max_num_of_elems)
00168         return FALSE;
00169     *m_queue[(m_curr_pos + m_curr_num_of_elems) % m_max_num_of_elems] = elem;
00170     m_curr_num_of_elems++;
00171     return TRUE;
00172 } // PushBack
00173
00174 /*  ------------------------------------------------------------------------
00175     PushFront
00176     ------------------------------------------------------------------------ */
00177 template<class T> BOOLEAN EmzUtils::Queue<T>::PushFront(T& elem)
00178 {
00179     if (m_curr_num_of_elems >= m_max_num_of_elems)
00180         return FALSE;
00181     if (m_curr_num_of_elems > 0)
00182             m_curr_pos = (m_curr_pos + m_max_num_of_elems - 1) % m_max_num_of_elems;
00183     *m_queue[m_curr_pos] = elem;
00184     m_curr_num_of_elems++;
00185     return TRUE;
00186 } // PushFront
00187
00188 /*  ------------------------------------------------------------------------
00189     PopBack
00190     ------------------------------------------------------------------------ */
00191 template<class T> BOOLEAN EmzUtils::Queue<T>::PopBack()
00192 {
00193     if (m_curr_num_of_elems == 0)
00194         return TRUE;
00195     m_curr_num_of_elems--;
00196     return TRUE;
00197 } // PopBack
00198
00199 /*  ------------------------------------------------------------------------
00200     PopFront
00201     ------------------------------------------------------------------------ */
00202 template<class T> BOOLEAN EmzUtils::Queue<T>::PopFront()
00203 {
00204     if (m_curr_num_of_elems == 0)
00205         return TRUE;
00206     m_curr_pos = (m_curr_pos + 1) % m_max_num_of_elems;
00207     m_curr_num_of_elems--;
00208     return TRUE;
00209 } // PopFront
00210
00211 /*  ------------------------------------------------------------------------
00212     GetFront
00213     ------------------------------------------------------------------------ */
00214 template<class T> T* EmzUtils::Queue<T>::GetFront() const
00215 {
00216     if (m_curr_num_of_elems == 0) {
00217         return 0;
00218     }
00219     return m_queue[m_curr_pos];
00220 } // GetFront
00221
00222 /*  ------------------------------------------------------------------------
00223     GetBack
00224     ------------------------------------------------------------------------ */
00225 template<class T> T* EmzUtils::Queue<T>::GetBack() const
00226 {
00227     if (m_curr_num_of_elems == 0) {
00228         return 0;
00229     }
00230     return m_queue[(m_curr_pos + m_curr_num_of_elems - 1) % m_max_num_of_elems];
00231 } // GetBack
00232
00234 #endif // EmzUtils_hpp
00235
Generated on Tue Jan 24 14:49:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Audio.hpp File Reference

Devices/SGold/Audio.hpp File Reference

#include <Compat/Devices/SGold/Audio.hpp>

Include dependency graph for Audio.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:17:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Audio.hpp Source File

Devices/SGold/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /* The class Audio has been moved to Compat.
00010 This header-file assures backward-compatibility for
00011 applications written with APOXI-versions smaller than 2.7.0*/
00012 #include <Compat/Devices/SGold/Audio.hpp>
00013
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/BackLight.cpp File Reference

Devices/SGold/BackLight.cpp File Reference

#include "BackLight.hpp"

Include dependency graph for BackLight.cpp:

Generated on Tue Jan 24 20:29:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/BackLight.hpp File Reference

Devices/SGold/BackLight.hpp File Reference

#include "Kernel/Types.hpp"
#include <Devices/AbstractDevice.hpp>

Include dependency graph for BackLight.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BackLight
Back light device. More...

Defines

#define | Apoxi_BackLight_hpp

Define Documentation

#define Apoxi_BackLight_hpp

Generated on Tue Jan 24 20:29:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/BackLight.hpp Source File

Devices/SGold/BackLight.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BackLight_hpp)
00010 #define Apoxi_BackLight_hpp
00011
00012 #include "Kernel/Types.hpp"
00013 #include <Devices/AbstractDevice.hpp>
00014
00015
00016
00017
00019 class BackLight : public AbstractDevice {
00020     public:
00021
00022         enum BackLightMode {
00023             BackLightOn  ,
00024             BackLightOff
00025         };
00026
00028         static void Init();
00029
00031         virtual const WCHAR* GetName() const;
00032
00034         static void Switch(BackLightMode mode);
00035
00037         static BOOLEAN GetStatus();
00038
00040         static void CleanUp(){};
00041
00042 };
00043
00044
00045
00046 #endif  // Apoxi_BackLight_hpp
00047
00048
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Camera.cpp File Reference

Devices/SGold/Camera.cpp File Reference

#include "PreComp.hpp"
#include "Camera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for Camera.cpp:

Defines

#define | CifSize_INDEX (6)
#define | DEBUG_CAMERA_CPP
#define | DEBUG_DEVICE_CAMERA_CPP_FILE (0)
#define | DEFAULT_STEP_SIZE (1)
#define | DefaultZoomLevelCifSize_INDEX (3)
#define | DefaultZoomLevelQcifSize_INDEX (3)
#define | DefaultZoomLevelQqcifSize_INDEX (3)
#define | DefaultZoomLevelQqvgaSize_INDEX (3)
#define | DefaultZoomLevelQsifSize_INDEX (3)
#define | DefaultZoomLevelQvgaSize_INDEX (3)
#define | DefaultZoomLevelSize1_3Mp_INDEX (3)
#define | DefaultZoomLevelSize1Mp_INDEX (3)
#define | DefaultZoomLevelSize2Mp_INDEX (3)
#define | DefaultZoomLevelSize3Mp_INDEX (3)
#define | DefaultZoomLevelSqcifSize_INDEX (3)
#define | DefaultZoomLevelSvgaSize_INDEX (3)
#define | DefaultZoomLevelUxgaSize_INDEX (3)
#define | DefaultZoomLevelVgaSize_INDEX (3)
#define | DefaultZoomLevelXgaSize_INDEX (3)
#define | MAX_LCD_SCREEN_FORMATS (5)
#define | MAX_ZOOM_LEVELS (7)
#define | MIN_ZOOM_LEVELS (1)
#define | NOT_USEABLE (-1)
#define | QcifSize_INDEX (3)
#define | QqcifSize_INDEX (0)
#define | QqvgaSize_INDEX (2)
#define | QsifSize_INDEX (4)
#define | QvgaSize_INDEX (5)
#define | Size1_3Mp_INDEX (0x0B)
#define | Size1Mp_INDEX (0x0A)
#define | Size2Mp_INDEX (0x0D)
#define | Size3Mp_INDEX (0x0E)
#define | SqcifSize_INDEX (1)
#define | SvgaSize_INDEX (8)
#define | UxgaSize_INDEX (0x0C)
#define | VgaSize_INDEX (7)
#define | XgaSize_INDEX (9)

Variables

const gdd_cam_fps_type | DEFAULT_VIEWFINDER_FRAMERATE = GDD_FPS_15

Define Documentation

#define CifSize_INDEX (6)

#define DEBUG_CAMERA_CPP

#define DEBUG_DEVICE_CAMERA_CPP_FILE (0)

#define DEFAULT_STEP_SIZE (1)

#define DefaultZoomLevelCifSize_INDEX (3)

#define DefaultZoomLevelQcifSize_INDEX (3)

#define DefaultZoomLevelQqcifSize_INDEX (3)

#define DefaultZoomLevelQqvgaSize_INDEX (3)

#define DefaultZoomLevelQsifSize_INDEX (3)

#define DefaultZoomLevelQvgaSize_INDEX (3)

#define DefaultZoomLevelSize1_3Mp_INDEX (3)

#define DefaultZoomLevelSize1Mp_INDEX (3)

#define DefaultZoomLevelSize2Mp_INDEX (3)

#define DefaultZoomLevelSize3Mp_INDEX (3)

#define DefaultZoomLevelSqcifSize_INDEX (3)

#define DefaultZoomLevelSvgaSize_INDEX (3)

#define DefaultZoomLevelUxgaSize_INDEX (3)

#define DefaultZoomLevelVgaSize_INDEX (3)

#define DefaultZoomLevelXgaSize_INDEX (3)

#define MAX_LCD_SCREEN_FORMATS (5)

#define MAX_ZOOM_LEVELS (7)

#define MIN_ZOOM_LEVELS (1)

#define NOT_USEABLE (-1)

#define QcifSize_INDEX (3)

#define QqcifSize_INDEX (0)

#define QqvgaSize_INDEX (2)

#define QsifSize_INDEX (4)

#define QvgaSize_INDEX (5)

#define Size1_3Mp_INDEX (0x0B)

#define Size1Mp_INDEX (0x0A)

#define Size2Mp_INDEX (0x0D)

#define Size3Mp_INDEX (0x0E)

#define SqcifSize_INDEX (1)

#define SvgaSize_INDEX (8)

#define UxgaSize_INDEX (0x0C)

#define VgaSize_INDEX (7)

#define XgaSize_INDEX (9)

Variable Documentation

const gdd_cam_fps_type DEFAULT_VIEWFINDER_FRAMERATE = GDD_FPS_15

Generated on Tue Jan 24 20:23:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Camera.hpp File Reference

Devices/SGold/Camera.hpp File Reference

#include <Kernel/System.hpp>
#include <Kernel/Types.hpp>
#include <Devices/Camera.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for Camera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Camera
struct | Camera::ParameterStruct

Defines

#define | Apoxi_Camera_hpp

Define Documentation

#define Apoxi_Camera_hpp

Generated on Tue Jan 24 20:24:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Camera.hpp Source File

Devices/SGold/Camera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Camera_hpp)
00010 #define Apoxi_Camera_hpp
00013
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/Types.hpp>
00016 #include <Devices/Camera.hpp>
00017 #include <Gui/Rect.hpp>
00018
00020 class Camera : public AbstractCamera {
00021
00022     typedef AbstractCamera Base;
00023
00024     public:
00025         APOXI_PUBLIC_INTERFACE_CAMERA
00026
00027     protected:
00028
00029         INT m_last_error;
00030         INT m_zoom_level;
00031         INT m_brightness_level;
00032         INT m_contrast_level;
00033
00034         Rect m_rect;    // the current viewfinder rectangle
00035
00036         ImageSizeType m_capture_image_size;
00037
00038         INT GetZoom();
00039         UINT16 CalcCameraScalingRate(ImageSizeType imageType, INT device_zoom_level);
00040
00041
00043         virtual BOOLEAN& GetLock() { return m_lock[GetIndex()]; }
00044
00045         void SetState(CameraState state) {m_state = state; }
00046
00047     private:
00048
00049
00051         typedef struct ParameterStruct {
00052                     INT min;
00053                     INT def;
00054                     INT max;
00055                     INT step;
00056                 } ParameterStruct;
00057
00058
00059                 enum ParameterType {
00060                     BrightnessParameter=0,
00061                     ContrastParameter
00062                 };
00063
00064         static BOOLEAN m_lock[2];
00065         CameraState m_state;
00066         INT m_display_idx;  // display index where the camera viewfinder should be displayed
00067
00068         AntiFlickerType m_antiflicker_mode;
00069         FilterType m_filter;
00070         TransformationType m_capture_transformation;
00071         ScalingMethodType m_scaling_method;
00072         TwilightType m_twilight_mode;
00073
00074         ParameterStruct m_DeviceParameterLimits[2];
00075         ParameterLimits m_CameraParameterLimits[2];
00076
00077         void ConvertCameraToDeviceLimits(ParameterType type);
00078         void StoreCameraParameterLimits(ParameterType type, gdd_limits_type limits);
00079         INT CalcCameraValue(ParameterType type, INT deviceValue);
00080         BOOLEAN CheckDeviceBrightnessContrastLevel(ParameterType type, INT val);
00081 };
00082
00083 inline Camera::CameraState Camera::GetState() const
00084 {
00085     return m_state;
00086 }
00087
00088
00089 inline INT Camera::GetDisplayIndex() const
00090 {
00091     return m_display_idx;
00092 }
00093
00094
00095 inline INT Camera::GetLastError() const
00096 {
00097     return m_last_error;
00098 }
00100 #endif  // Apoxi_Camera_hpp
00101
00102
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Charger.cpp File Reference

Devices/SGold/Charger.cpp File Reference

#include "PreComp.hpp"
#include <stack/driver.h>
#include "Charger.hpp"
#include <Devices/ChargerSignalMapTableNode.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>

Include dependency graph for Charger.cpp:

Generated on Tue Jan 24 20:24:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Charger.hpp File Reference

Devices/SGold/Charger.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/ChargerInterface.hpp>

Include dependency graph for Charger.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Charger

Defines

#define | Apoxi_Devices_SGold_Charger_hpp

Define Documentation

#define Apoxi_Devices_SGold_Charger_hpp

Generated on Tue Jan 24 20:24:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Charger.hpp Source File

Devices/SGold/Charger.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Devices_SGold_Charger_hpp)
00011 #define Apoxi_Devices_SGold_Charger_hpp
00012
00013 #include <Devices/AbstractDevice.hpp>
00014
00016 class Charger: public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     #include <Devices/ChargerInterface.hpp>
00020
00021     protected:
00023         virtual void OnStart();
00024
00025 };
00026
00027 #endif
00028
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/DefaultDisplay.cpp File Reference

Devices/SGold/DefaultDisplay.cpp File Reference

#include "PreComp.hpp"
#include "DefaultDisplay.hpp"
#include "VideoChannel.hpp"
#include <Gui/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DisplayMsgTypes.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <stack/driver.h>

Include dependency graph for DefaultDisplay.cpp:

Functions

void ApoxiSendDisplayUpdateFinished (ubyte shuge *, gdd_result_type)

Function Documentation

void ApoxiSendDisplayUpdateFinished | ( | ubyte shuge * | ,
 |  | gdd_result_type |
 | ) |

Generated on Tue Jan 24 20:25:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/DefaultDisplay.hpp File Reference

Devices/SGold/DefaultDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Devices/Display.hpp>

Include dependency graph for DefaultDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultDisplay

Defines

#define | Apoxi_DefaultDisplay_hpp

Define Documentation

#define Apoxi_DefaultDisplay_hpp

Generated on Tue Jan 24 20:25:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/DefaultDisplay.hpp Source File

Devices/SGold/DefaultDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultDisplay_hpp)
00010 #define Apoxi_DefaultDisplay_hpp
00013
00014 class VideoChannel;
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/Os/SystemTimer.hpp>
00017 #include <Devices/Display.hpp>
00018
00023 class DefaultDisplay : public Display {
00024     typedef Display Base;
00025
00026     public:
00029         DefaultDisplay(INT index);
00030
00031         virtual ~DefaultDisplay();
00032
00034         virtual const WCHAR* GetName() const;
00035
00037         virtual void OnStart();
00038
00040         virtual void OnStop();
00041
00043         virtual void SetContrast(INT contrast);
00044
00046         virtual INT GetContrast() const;
00047
00049         virtual void SetBrightness(INT brightness);
00050
00052         virtual INT GetBrightness() const;
00053
00055         virtual void SetBacklightTimeout(UINT32 timeout);
00056
00058         virtual void SetPowerTimeout(UINT32 timeout);
00059
00061         virtual void ReactivateBacklight();
00062
00064         virtual void ReactivatePower();
00065
00067         virtual void SetBacklightMode(BacklightMode mode);
00068
00070         virtual BacklightMode GetBacklightMode() const;
00071
00073         virtual BOOLEAN IsBacklightOn() const;
00074
00076         virtual void SetPowerMode(PowerMode mode);
00077
00079         virtual PowerMode GetPowerMode() const;
00080
00082         virtual BOOLEAN IsPowerOn() const;
00083
00085         virtual void Refresh();
00086
00095         virtual void Refresh(const CustomFrameBuffer* custom_frame_buf);
00096
00100         virtual VideoChannel* GetVideoChannel();
00101
00104         void OnTimer();
00105
00106         /*  S-Gold specific interface, which is not part of the common Display interface and hence may
00107             not be used by any APOXI or MMI interface. */
00108         static void SynchronizeBuffers();
00109
00111         virtual void SetCallbackActive(BOOLEAN state);
00112
00114         virtual BOOLEAN IsCallbackActive() const;
00115
00116     private:
00117         enum Status {
00118             DisplayOff,
00119             BacklightOff,
00120             BacklightOn
00121         };
00122
00123         struct {
00124             UINT backlight_mode         : 2;
00125             UINT power_mode             : 2;
00126             UINT status                 : 2;
00127             UINT power_on               : 1;
00128             UINT backlight_on           : 1;
00129         } m_bits;
00130         VideoChannel* m_video_channel;
00131         SystemTimer* m_timer;
00132         UINT32 m_backlight_timeout;
00133         UINT32 m_power_timeout;
00134
00135         UINT8 m_contrast;
00136         UINT8 m_brightness;
00137
00138         volatile BOOLEAN m_cb_active;
00139         BOOLEAN m_synchronize_buffer_skipped;
00140
00141         Semaphore m_sem;
00142         BOOLEAN m_gdd_transfer;
00143         Rect m_updated_blit_rect;
00144         DDrvAtomPtr m_transfer_buffer;      // buffer which contains a copy of the main frame buffer
00145
00146         void SetBacklight(BOOLEAN backlight);
00147         void SetPower(BOOLEAN power);
00148
00149         static void CallbackFn(void* arg);
00150
00151         friend class VideoChannel;
00152 };
00153
00155 #endif  // Apoxi_DefaultDisplay_hpp
00156
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Fota.cpp File Reference

Devices/SGold/Fota.cpp File Reference

#include "PreComp.hpp"
#include "Fota.hpp"
#include <stack/driver.h>

Include dependency graph for Fota.cpp:

Generated on Tue Jan 24 20:25:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Fota.hpp File Reference

Devices/SGold/Fota.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/FotaInterface.hpp>

Include dependency graph for Fota.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Fota

Defines

#define | Apoxi_Devices_SGold_Fota_hpp

Define Documentation

#define Apoxi_Devices_SGold_Fota_hpp

Generated on Tue Jan 24 20:25:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Fota.hpp Source File

Devices/SGold/Fota.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_SGold_Fota_hpp)
00010 #define Apoxi_Devices_SGold_Fota_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class Fota : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/FotaInterface.hpp>
00018
00019     private:
00020 };
00021
00022 #endif  // Apoxi_Devices_SGold_Fota_hpp
00023
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Keyboard.cpp File Reference

Devices/SGold/Keyboard.cpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Config/KeyboardConfig.hpp>
#include <stack/driver.h>
#include "Keyboard.hpp"
#include <Devices/SharedMethods/KeyboardTimer.cpp>

Include dependency graph for Keyboard.cpp:

Generated on Tue Jan 24 20:25:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Keyboard.hpp File Reference

Devices/SGold/Keyboard.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/KeyboardInterface.hpp>

Include dependency graph for Keyboard.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Keyboard
Keyboard. More...
struct | Keyboard::BitStruct

Defines

#define | Apoxi_Devices_SGold_Keyboard_hpp

Define Documentation

#define Apoxi_Devices_SGold_Keyboard_hpp

Generated on Tue Jan 24 20:25:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Keyboard.hpp Source File

Devices/SGold/Keyboard.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_SGold_Keyboard_hpp)
00010 #define Apoxi_Devices_SGold_Keyboard_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00015 class Keyboard : public AbstractDevice {
00016     typedef AbstractDevice Base;
00017
00018     #include <Devices/KeyboardInterface.hpp>
00019
00020     protected:
00021         virtual void OnStart();
00022
00023     private:
00024         struct BitStruct {
00025             UINT locked                 : 1;
00026             UINT multi_key_mode         : 1;
00027             UINT illumination_status    : 1;
00028             UINT illumination_mode      : 2;
00029         };
00030
00031         static BitStruct m_bits;
00032         static UINT32 m_illumination_timeout;
00033         static SystemTimer m_illumination_timer;
00034
00035         static void SetIllumination(BOOLEAN illumination);
00036         static void OnIlluminationTimer(void *arg);
00037 };
00038
00039 /*  ------------------------------------------------------------------------
00040     IsLocked
00041     ------------------------------------------------------------------------ */
00042 inline BOOLEAN Keyboard::IsLocked()
00043 {
00044     return m_bits.locked;
00045 }
00046
00047 /*  ------------------------------------------------------------------------
00048     IsLocked
00049     ------------------------------------------------------------------------ */
00050 inline BOOLEAN Keyboard::IsMultiKeyMode()
00051 {
00052     return (BOOLEAN)m_bits.multi_key_mode;
00053 }
00054
00055 /*  ------------------------------------------------------------------------
00056     SetIlluminationTimeout
00057     ------------------------------------------------------------------------ */
00058 inline void Keyboard::SetIlluminationTimeout(UINT32 timeout)
00059 {
00060     m_illumination_timeout = timeout;
00061 }
00062
00063 /*  ------------------------------------------------------------------------
00064     GetIlluminationMode
00065     ------------------------------------------------------------------------ */
00066 inline Keyboard::IlluminationMode Keyboard::GetIlluminationMode()
00067 {
00068     return static_cast<IlluminationMode>(m_bits.illumination_mode);
00069 }
00070
00071 /*  ------------------------------------------------------------------------
00072     IsIlluminationOn
00073     ------------------------------------------------------------------------ */
00074 inline BOOLEAN Keyboard::IsIlluminationOn()
00075 {
00076     return (BOOLEAN)m_bits.illumination_status;
00077 }
00078
00079 #endif  // Apoxi_Devices_SGold_Keyboard_hpp
00080
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Led.cpp File Reference

Devices/SGold/Led.cpp File Reference

#include "PreComp.hpp"
#include "Led.hpp"
#include <Devices/LedSignalMapTableNode.hpp>

Include dependency graph for Led.cpp:

Generated on Tue Jan 24 20:25:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Led.hpp File Reference

Devices/SGold/Led.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <stack/driver.h>
#include <Devices/LedInterface.hpp>

Include dependency graph for Led.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Led
Back light device. More...

Defines

#define | Apoxi_Devices_SGold_Led_hpp

Define Documentation

#define Apoxi_Devices_SGold_Led_hpp

Generated on Tue Jan 24 20:25:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Led.hpp Source File

Devices/SGold/Led.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_SGold_Led_hpp)
00010 #define Apoxi_Devices_SGold_Led_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013 #include <stack/driver.h>
00014
00016 class Led : public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     public:
00020         #if !defined(APOXI_LED_NEW_INTERFACE)
00021             enum Event {
00022                 Call = led_call,                /* stored in eep  */
00023                 ReceivingCall = led_receiving_call,     /* stored in eep  */
00024                 CallUnanswered = led_call_unanswered,       /* stored in eep  */
00025                 Mail = led_mail,                /* stored in eep  */
00026                 Service = led_service,          /* stored in eep  */
00027                 NoService = led_no_service,         /* stored in eep  */
00028                 LimitedService = led_limited_service,
00029                 PowerOn = led_power_on,
00030                 PowerOff = led_power_off,
00031                 ReceivedCallConnected = led_received_call_connected,
00032                 SmsReceiving = led_sms_receiving,
00033                 SmsSending = led_sms_sending,
00034                 AlarmOngoing = led_alarm_ongoing,
00035                 AlarmStopped = led_alarm_stopped,
00036                 BatteryLow = led_battery_low,
00037                 ChargerDisconnected = led_charger_disconnected,
00038                 ChargerConnected = led_charger_connected,
00039                 ChargeComplete = led_charge_complete
00040             };
00041
00042             enum Color {
00043                 Blue = led_blue,
00044                 Red = led_red,
00045                 Green = led_green,
00046                 Magenta = led_blue_red,        /* magenta */
00047                 Cyan = led_blue_green,      /* cyan    */
00048                 Yellow = led_red_green,       /* yellow  */
00049                 White = led_red_blue_green,  /* white   */
00050                 NoOfColors = led_nof_colors,
00051                 InvalidColor,
00052             };
00053
00054
00055             enum Action {
00056                 On = LED_ON,
00057                 Off = LED_OFF,
00058                 Flash = LED_FLASH,
00059                 ColorStream = LED_COLORSTREAM,
00060             };
00061
00062             #if defined (USE_SMPOWER)
00063                 enum Intensity {
00064                     NoCurrent = led_no_current, /*   0 mA */
00065                     Minimum = led_20_ma,        /*  20 mA */
00066                     Low = led_40_ma,            /*  40 mA */
00067                     LessThanNormal = led_60_ma, /*  60 mA */
00068                     Normal = led_80_ma,         /*  80 mA */
00069                     MoreThanNormal = led_100_ma,/* 100 mA */
00070                     High = led_120_ma,          /* 120 mA */
00071                     Maximum = led_140_ma        /* 140 mA */
00072                 };
00073             #else
00074                 enum Intensity {
00075                     NoCurrent,
00076                     Minimum,
00077                     Low,
00078                     LessThanNormal,
00079                     Normal,
00080                     MoreThanNormal,
00081                     High,
00082                     Maximum,
00083                 };
00084             #endif
00085         #endif
00086
00087     #include <Devices/LedInterface.hpp>
00088
00089     protected:
00090         #if defined(APOXI_LED_NEW_INTERFACE)
00091             virtual void OnStart();
00092         #endif
00093
00094     private:
00095         static const INT c_max_colorstream_length;
00096 };
00097
00098 #endif  // Apoxi_Devices_SGold_Led_hpp
00099
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/PreComp.cpp File Reference

Devices/SGold/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:04:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/PreComp.hpp File Reference

Devices/SGold/PreComp.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/System.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/PreComp.hpp Source File

Devices/SGold/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013 #include <Kernel/System.hpp>
00014
00015
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/RealTimeClock.cpp File Reference

Devices/SGold/RealTimeClock.cpp File Reference

#include "PreComp.hpp"
#include <Devices/RealTimeClock.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Devices/RtcSignalMapTableNode.hpp>
#include <Devices/RtcMsgTypes.hpp>
#include <stdio.h>
#include <stack/driver.h>
#include <stack/stack.h>

Include dependency graph for RealTimeClock.cpp:

Generated on Tue Jan 24 20:25:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/RealTimeClock.hpp File Reference

Devices/SGold/RealTimeClock.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/RealTimeClockInterface.hpp>

Include dependency graph for RealTimeClock.hpp:

Go to the source code of this file.

Data Structures

class | RealTimeClock

Defines

#define | Apoxi_Devices_SGold_RealTimeClock_hpp

Define Documentation

#define Apoxi_Devices_SGold_RealTimeClock_hpp

Generated on Tue Jan 24 20:26:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/RealTimeClock.hpp Source File

Devices/SGold/RealTimeClock.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_SGold_RealTimeClock_hpp)
00010 #define Apoxi_Devices_SGold_RealTimeClock_hpp
00011
00012 #include <Devices/AbstractDevice.hpp>
00013
00014 class RealTimeClock : public AbstractDevice {
00015     typedef AbstractDevice Base;
00016
00017     #include <Devices/RealTimeClockInterface.hpp>
00018
00019     protected:
00021         virtual void OnStart();
00022
00024         virtual void OnStop();
00025 };
00026
00027 #endif  // Apoxi_Devices_SGold_RealTimeClock_hpp
00028
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/StillCamera.cpp File Reference

Devices/SGold/StillCamera.cpp File Reference

#include "PreComp.hpp"
#include "StillCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Afs/Rfs/FileDataSink.hpp>
#include <AddOns/AfsRam/RamDataSink.hpp>
#include <Afs/Rfs/FileBinData.hpp>

Include dependency graph for StillCamera.cpp:

Defines

#define | BITS_PRO_BYTE (8)
#define | BITS_PRO_JPEG_PIXEL (24)
#define | BITS_PRO_JPEG_PIXEL ((BYTEST_PRO_JPEG_PIXEL)*(BITS_PRO_BYTE))
#define | BYTEST_PRO_JPEG_PIXEL (BYTEST_PRO_PIXEL)
#define | BYTEST_PRO_PIXEL (2)
#define | DEBUG_DEVICE_STILL_CAMERA_CPP_FILE (0)
#define | DEBUG_STILL_CAMERA_CPP
#define | DEBUG_STILL_CAMERA_CPP_CB
#define | MAX_BANANA_HEIGHT (35)
#define | MAX_BANANA_WIDTH (33)
#define | MAX_LENGTH_OF_BANANA_DATA_REAL (3465)
#define | NEW_HEIGHT_JPEG (100)
#define | NEW_JPEG_QUALITY (50)
#define | NEW_WIDTH_JPEG (100)
#define | NO_OF_PICTURE_FOR_SINGLE_SHOT (1)
#define | NO_OF_PICTURES_EMPTY (0)
#define | TEMPORARY_USED
#define | TESTEN_DEBUG

Define Documentation

#define BITS_PRO_BYTE (8)

#define BITS_PRO_JPEG_PIXEL (24)

#define BITS_PRO_JPEG_PIXEL ((BYTEST_PRO_JPEG_PIXEL)*(BITS_PRO_BYTE))

#define BYTEST_PRO_JPEG_PIXEL (BYTEST_PRO_PIXEL)

#define BYTEST_PRO_PIXEL (2)

#define DEBUG_DEVICE_STILL_CAMERA_CPP_FILE (0)

#define DEBUG_STILL_CAMERA_CPP

#define DEBUG_STILL_CAMERA_CPP_CB

#define MAX_BANANA_HEIGHT (35)

#define MAX_BANANA_WIDTH (33)

#define MAX_LENGTH_OF_BANANA_DATA_REAL (3465)

#define NEW_HEIGHT_JPEG (100)

#define NEW_JPEG_QUALITY (50)

#define NEW_WIDTH_JPEG (100)

#define NO_OF_PICTURE_FOR_SINGLE_SHOT (1)

#define NO_OF_PICTURES_EMPTY (0)

#define TEMPORARY_USED

#define TESTEN_DEBUG

Generated on Tue Jan 24 20:26:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/StillCamera.hpp File Reference

Devices/SGold/StillCamera.hpp File Reference

#include <Devices/StillCamera.hpp>
#include <Auxiliary/DataSink.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>

Include dependency graph for StillCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StillCamera

Defines

#define | Apoxi_StillCamera_hpp

Define Documentation

#define Apoxi_StillCamera_hpp

Generated on Tue Jan 24 20:26:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/StillCamera.hpp Source File

Devices/SGold/StillCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_StillCamera_hpp)
00010 #define Apoxi_StillCamera_hpp
00013
00014 #include <Devices/StillCamera.hpp>
00015 #include <Auxiliary/DataSink.hpp>
00016 #include <AddOns/MultiMedia/JpegEncoder.hpp>
00017
00018
00020 class StillCamera : public AbstractStillCamera {
00021
00022     typedef AbstractStillCamera Base;
00023
00024     public:
00025         APOXI_PUBLIC_INTERFACE_STILLCAMERA
00026
00027     protected:
00028
00029
00030     private:
00031         FlashType               m_flash;
00032         UINT16                  m_no_of_pictures;
00033         INT                     m_jpeg_quality;
00034
00035         static CbImageCaptured    m_cb_image_captured;
00036         static CbImageEncoded     m_cb_image_encoded;
00037         static CbCaptureFinished  m_cb_capture_finished;
00038
00039         JpegEncoder::EncodingParameters* m_JpegEncoderParam;
00040         JpegEncoder*            m_JpegEncoder;
00041
00042         static  UINT32          m_pool_handle;
00043
00044         // callbacks
00045         // callback from GDD for still camera, where buffer for raw data will be passed to
00046         static void Cb_GDD_GetCaptureBuffer(void* context, UINT8 HUGE **buffer, UINT32 size);
00047
00048         // callback from GDD where an image has been captured as RAW data in to buffer
00049         static void Cb_GDD_ImageCaptured(int result, void* context, UINT8 HUGE* captured_buffer, UINT32 size);
00050
00051         // callback from GDD for the asynchronous result
00052         static void Cb_GDD_CaptureResult(INT result, void* context);
00053
00054         // callback from JpegEncoder, when an RAW data image has been encoded to JPEG
00055         static void Cb_JPEG_ImageEncoded(INT result, void* context, UINT8 HUGE *source, DataSinkPtr sink);
00056
00057         BOOLEAN DeleteOneImageBuffer(UINT8 HUGE* buff_ptr);
00058         BOOLEAN FreeImageBuffer();
00059         BOOLEAN GetImageBuffer(UINT8 no_of_pictures, ImageSizeType size);
00060         BOOLEAN Encode();
00061         void    DeleteJpegSoftwareEncoder();
00062         BOOLEAN SetJpegSoftwareEncoder(XYDIM width, XYDIM height, INT quality_level);
00063 #ifdef APOXI_GDD_2_0_INTERFACE
00064         BOOLEAN GetCameraImageSize(ImageSizeType size, gdd_image_size_format_type& gdd_image_size);
00065 #endif
00066 };
00067
00069 #endif  // Apoxi_StillCamera_hpp
00070
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VideoCamera.cpp File Reference

Devices/SGold/VideoCamera.cpp File Reference

#include "PreComp.hpp"
#include "VideoCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for VideoCamera.cpp:

Defines

#define | DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE (0)
#define | DEBUG_VIDEOCAMERA_CPP

Variables

const INT | c_bytes_per_pixel_of_rawdata = 2

Define Documentation

#define DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE (0)

#define DEBUG_VIDEOCAMERA_CPP

Variable Documentation

const INT c_bytes_per_pixel_of_rawdata = 2

Generated on Tue Jan 24 20:27:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VideoCamera.hpp File Reference

Devices/SGold/VideoCamera.hpp File Reference

#include <Kernel/System.hpp>
#include <Kernel/Types.hpp>
#include <Devices/VideoCamera.hpp>

Include dependency graph for VideoCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoCamera

Defines

#define | Apoxi_VideoCamera_hpp

Define Documentation

#define Apoxi_VideoCamera_hpp

Generated on Tue Jan 24 20:27:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VideoCamera.hpp Source File

Devices/SGold/VideoCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VideoCamera_hpp)
00010 #define Apoxi_VideoCamera_hpp
00013
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/Types.hpp>
00016 #include <Devices/VideoCamera.hpp>
00017
00019 class VideoCamera : public AbstractVideoCamera
00020 {
00021     typedef AbstractVideoCamera Base;
00022
00023     public:
00024
00025         APOXI_PUBLIC_INTERFACE_VIDEOCAMERA
00026
00027     protected:
00028
00029
00030     private:
00031
00032         // ToDo: check whether signature of callbacks are equal to the GDD 2.2 ones
00033         static void GetCaptureBuffer_GDD_CB(void*, UINT8 HUGE ** buffer, UINT32 size);
00034         static void VideoFrameCaptured_GDD_CB(int result, void* context, UINT8 HUGE * buffer, UINT32 buf_len_used);
00035         static void NotifyCaptureBufferStatus_GDD_CB(void* context, UINT8 free_buffer_count);
00036
00038         FrameRateType m_framerate;
00039
00041         static UINT32 m_buffer_length;
00042
00044         static UINT32 m_starting_time;          // frame count or timestamp
00045
00047         static UINT32 m_pool_handle;
00048
00049         static Cb_NotifyCaptureBufferStatus m_cb_notify_status;
00050         static Cb_FrameCaptured m_cb_frame_captured;
00051 };
00052
00054 #endif  // Apoxi_VideoCamera_hpp
00055
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VideoChannel.cpp File Reference

Devices/SGold/VideoChannel.cpp File Reference

#include "PreComp.hpp"
#include "VideoChannel.hpp"
#include "Display.hpp"
#include <Config/DisplayConfig.hpp>
#include <Gui/DeviceContext.hpp>

Include dependency graph for VideoChannel.cpp:

Generated on Tue Jan 24 20:28:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VideoChannel.hpp File Reference

Devices/SGold/VideoChannel.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for VideoChannel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoChannel

Defines

#define | Apoxi_VideoChannel_hpp

Define Documentation

#define Apoxi_VideoChannel_hpp

Generated on Tue Jan 24 20:28:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VideoChannel.hpp Source File

Devices/SGold/VideoChannel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_VideoChannel_hpp)
00010 #define Apoxi_VideoChannel_hpp
00011
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Rect.hpp>
00017
00026 class VideoChannel {
00027     public:
00030         enum VideoParameterType {
00032             Rotate,
00034             Mirror,
00036             Flip,
00038             Antitearing,
00040             SmartOverlay,
00042             ZoomFactorMin,
00044             ZoomFactorMax
00045         };
00046
00050         VideoChannel(INT display_idx = 0);
00051
00052         ~VideoChannel();
00053
00063         BOOLEAN Open(Rect& video_frame_rect, void (*CbVideoFrameRendered)(), void* context = 0);
00064
00065
00067         void Close();
00068
00077         void RenderFrame(void* frame_buffer, UINT32 length, UINT32 frame_id, BOOLEAN auto_skip_frame = FALSE);
00078
00079
00082         BOOLEAN IsOpen() const;
00083
00085         UINT32 GetRefreshDelay() const;
00086
00091         BOOLEAN SetParam(VideoParameterType type, UINT32 value);
00092
00098         BOOLEAN GetParam(VideoParameterType type, UINT32* value) const;
00099
00106 #ifdef APOXI_COMPAT_2_6_0
00107         void SetSize(Size video_size) {SetVideoSize(video_size);}
00108 #endif
00109         void SetVideoSize(Size video_size);
00110
00121         BOOLEAN SetCropRect(Rect& crop_rect);
00122
00130 #ifdef APOXI_COMPAT_2_6_0
00131         BOOLEAN AdjustFrameRect(Rect& video_frame_rect) {SetFrameRect(video_frame_rect);}
00132 #endif
00133         BOOLEAN SetFrameRect(Rect& video_frame_rect);
00134
00146         BOOLEAN QueryRects(Rect& video_frame_rect, Rect& crop_rect);
00147
00148     private:
00149         Rect m_video_frame_rect;
00150         const DDrvAtomPtr m_video_frame_buffer;
00151 };
00152
00154 #endif  // Apoxi_VideoChannel_hpp
00155
00156
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VirtualDisplay.cpp File Reference

Devices/SGold/VirtualDisplay.cpp File Reference

#include "PreComp.hpp"
#include "VirtualDisplay.hpp"
#include "../SharedMethods/Ddrv.cpp"
#include <Devices/DeviceManager.hpp>
#include "../SharedMethods/SetPixel_16Bpp.cpp"
#include "../SharedMethods/FillRect_16Bpp.cpp"
#include "../SharedMethods/BitBlit_16Bpp.cpp"
#include "../SharedMethods/ScrollHorizontal_16Bpp.cpp"
#include "../SharedMethods/ScrollVertical_16Bpp.cpp"
#include "../SharedMethods/DrawChar_16Bpp.cpp"
#include "../SharedMethods/ConvertToColorValue_Bpp.cpp"
#include "../SharedMethods/GetPixelColor_16Bpp.cpp"

Include dependency graph for VirtualDisplay.cpp:

Generated on Tue Jan 24 20:28:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VirtualDisplay.hpp File Reference

Devices/SGold/VirtualDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/Rect.hpp>
#include <Gui/ColorTable.hpp>
#include <Gui/Color.hpp>
#include <Gui/Font.hpp>
#include <Kernel/Os/SystemTimer.hpp>

Include dependency graph for VirtualDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ScanlineAccessor
class | VirtualDisplay

Defines

#define | Apoxi_VirtualDisplay_hpp

Define Documentation

#define Apoxi_VirtualDisplay_hpp

Generated on Tue Jan 24 20:28:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/VirtualDisplay.hpp Source File

Devices/SGold/VirtualDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_VirtualDisplay_hpp)
00010 #define Apoxi_VirtualDisplay_hpp
00013
00014 class VideoChannel;
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Devices/AbstractDevice.hpp>
00018 #include <Gui/Bitmap.hpp>
00019 #include <Gui/Rect.hpp>
00020 #include <Gui/ColorTable.hpp>
00021 #include <Gui/Color.hpp>
00022 #include <Gui/Font.hpp>
00023 #include <Kernel/Os/SystemTimer.hpp>
00024
00029 class VirtualDisplay : public AbstractDevice {
00030     typedef AbstractDevice Base;
00031
00032     public:
00034         enum Type {
00036             Monochrome,
00038             Planes2,
00040             Planes4,
00042             Planes8,
00044             BitsPerPixel8,
00046             BitsPerPixel16,
00048             BitsPerPixel24,
00050             BitsPerPixel32
00051         };
00052
00054         VirtualDisplay(INT index = 0);
00055
00068         VirtualDisplay(XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00069
00071         VirtualDisplay(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00072
00074         virtual ~VirtualDisplay();
00075
00088         void Init(XYDIM width, XYDIM height,  INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00089
00091         void Init(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00092
00094         virtual const WCHAR* GetName() const;
00095
00097         ControlArg Control(INT command, ControlArg arg);
00098
00100         XYDIM GetWidth() const { return m_bitmap.GetWidth();}
00101
00103         XYDIM GetHeight() const { return m_bitmap.GetHeight(); }
00104
00106         Bitmap* GetBitmap() { return &m_bitmap; }
00107
00109         Type GetType() { return m_type; }
00110
00114         void SetBlitRect(const Rect& rect = Rect()) { m_blit_rect = rect; }
00115
00117         const Rect& GetBlitRect() const { return m_blit_rect; };
00118
00121         void AdjustBlitRect(const Rect& rect) { m_blit_rect.Union(rect); }
00122
00125         virtual void Refresh();
00126
00129         void SetPixel(XYDIM x, XYDIM y);
00130
00133         void FillRect(const Rect& rect);
00134
00144             void BitBlit(XYDIM dest_x,
00145                      XYDIM dest_y,
00146                      const BitmapRes& bmp,
00147                      const Rect& clip_rect,
00148                      UINT8 trans_mode = 0);
00149
00154         void Scroll(const Rect& rect, XYDIM dx, XYDIM dy);
00155
00158         void DrawChar(XYDIM x, XYDIM y, const Glyph& glyph, INT height);
00159
00161         void SetColorValue(ColorValue color_value, UINT8 alpha = 255);
00162
00164         ColorValue GetColorValue() const { return m_color_value; }
00165
00167         void SetColor(Color color);
00168
00170         Color GetColor() const { return m_color; }
00171
00176         ColorValue ConvertToColorValue(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const;
00177
00179         Color GetPixelColor(XYDIM x, XYDIM y) const;
00180
00182         INT GetScanlineAtomCount() const { return m_scanline_atom_count; }
00183
00186         void SetAlphaBlendingMode(BOOLEAN mode) {
00187                                                     #ifdef APOXI_ENABLE_ALPHA_BLENDING
00188                                                         m_alpha_mode = mode;
00189                                                     #endif
00190                                                 }
00191
00193         BOOLEAN GetAlphaBlendingMode() const {
00194                                                 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00195                                                     return m_alpha_mode;
00196                                                 #else
00197                                                     return TRUE;
00198                                                 #endif
00199                                                 }
00200     private:
00201 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00202         BOOLEAN m_alpha_mode;
00203 #endif
00204         Bitmap m_bitmap;
00205         Rect m_blit_rect;
00206         Type m_type;
00207         ColorValue m_color_value;
00208         Color m_color;
00209         INT m_pixel_atom_count;
00210         INT m_scanline_atom_count;
00211         INT m_plane_count;
00212         INT m_scanline_inc;
00213         INT m_plane_inc;
00214         DDrvAtomPtr m_data;
00215         DDrvAtomPtr m_scanline_buffer;
00216
00217         void ScrollHorizontal(const Rect& rect, XYDIM dx);
00218         void ScrollVertical(const Rect& rect, XYDIM dy);
00219 };
00220
00223 class ScanlineAccessor {
00224     public:
00229         ScanlineAccessor(VirtualDisplay* display, XYDIM x, XYDIM y, XYDIM width) :
00230             m_data((UINT16 GDI_HUGE*)display->GetBitmap()->GetBits()),
00231             m_count(width)
00232         {
00233             m_data += (display->GetScanlineAtomCount() >> 1) * y + x;
00234         }
00235
00237         BOOLEAN HasNext() { return (m_count > 0); };
00238
00240         void Draw(UINT8 red, UINT8 green, UINT8 blue)
00241         {
00242             *m_data = ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)));
00243
00244             #if defined(APOXI_DISPLAY_FORMAT_BIG_ENDIAN)
00245                 *m_data = ((*m_data & 0xffU) << 8U) | ((*m_data & 0xff00U)) >> 8U;
00246             #endif
00247             m_data++;
00248             m_count--;
00249         }
00250
00251         void Draw(ColorValue cv)
00252         {
00253             *m_data = cv;
00254             m_data++;
00255             m_count--;
00256         }
00257
00261         void Next() {
00262             m_data++;
00263             m_count--;
00264         }
00265
00266     private:
00268         UINT16 GDI_HUGE* m_data;
00270         XYDIM m_count;
00271
00272 };
00273
00275 #endif  // Apoxi_VirtualDisplay_hpp
00276
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Epson716/Camera.cpp File Reference

Devices/SGold/Companion/Epson716/Camera.cpp File Reference

#include "PreComp.hpp"
#include "Camera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include "cam32.h"

Include dependency graph for Camera.cpp:

Generated on Tue Jan 24 20:24:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Epson716/VideoCamera.cpp File Reference

Devices/SGold/Companion/Epson716/VideoCamera.cpp File Reference

#include "PreComp.hpp"
#include "VideoCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for VideoCamera.cpp:

Generated on Tue Jan 24 20:27:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/Camera.cpp File Reference

Devices/SGold/Companion/Scicos3020/Camera.cpp File Reference

#include "PreComp.hpp"
#include "Camera.hpp"
#include <Config/CameraConfig.hpp>
#include <mm_tools.h>
#include <mmcd_interface.h>
#include <gdd_scicos.h>

Include dependency graph for Camera.cpp:

Generated on Tue Jan 24 20:24:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.cpp File Reference

Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.cpp File Reference

#include <Kernel/Types.hpp>
#include "ScicosCodecIfLib.hpp"
#include <Config/CodecConfig.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include "ScicosMpeg4VideoEncoder.hpp"
#include "ScicosMpeg4VideoDecoder.hpp"

Include dependency graph for ScicosCodecIfLib.cpp:

Generated on Tue Jan 24 20:32:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.hpp File Reference

Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ScicosCodecIfLib

Defines

#define | ScicosCodecIfLib_hpp

Define Documentation

#define ScicosCodecIfLib_hpp

Generated on Tue Jan 24 20:32:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.hpp Source File

Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ScicosCodecIfLib_hpp)
00010 #define ScicosCodecIfLib_hpp
00013
00014
00015 class ScicosCodecIfLib {
00016     private:
00017
00020         static void LoadLib();
00021
00022     friend class CodecConfig; // loads this library
00023
00024 };
00025
00027 #endif // ScicosCodecIfLib_hpp
00028
00029
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.cpp File Reference

Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.cpp File Reference

#include "ScicosMpeg4VideoDecoder.hpp"
#include "mm_tools.h"
#include "mmcd_interface.h"

Include dependency graph for ScicosMpeg4VideoDecoder.cpp:

Generated on Tue Jan 24 20:32:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.hpp File Reference

Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoDecoder.hpp>

Include dependency graph for ScicosMpeg4VideoDecoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ScicosMpeg4VideoDecoder
struct | ScicosMpeg4VideoDecoder::StateFlags

Defines

#define | ScicosMpeg4VideoDecoder_hpp

Variables

const UINT8 | c_scicos_codec_if_max_num_of_vid_dec_inst = 1

Define Documentation

#define ScicosMpeg4VideoDecoder_hpp

Generated on Tue Jan 24 20:32:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.hpp Source File

Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ScicosMpeg4VideoDecoder_hpp)
00010 #define ScicosMpeg4VideoDecoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoDecoder.hpp>
00017
00019 const UINT8 c_scicos_codec_if_max_num_of_vid_dec_inst = 1;
00020
00023 class ScicosMpeg4VideoDecoder : public VideoDecoder {
00024
00025     typedef VideoDecoder Base;
00026
00027     public:
00028
00030         virtual ~ScicosMpeg4VideoDecoder();
00031
00043         virtual CodecManager::ResultType GetCapabilities(CodecManager::VideoCodecCapabilities& caps);
00044
00064         virtual CodecManager::ResultType AllocateOutputBuffers( UINT8& out_buf_count,
00065                                                                 UINT32& out_buf_len);
00066
00073         virtual CodecManager::ResultType GetNumberOfInitialDecodeOperations(UINT8& operations);
00074
00095         virtual CodecManager::ResultType RegisterCallbackFunctions( UINT32 context,
00096                                                                     CbFrameDecoded cb_frame_decoded,
00097                                                                     CbInBufferFree cb_in_buf_free);
00098
00113         virtual CodecManager::ResultType DecodeFrame(   const UINT8 HUGE* in_buf,
00114                                                         UINT32 in_buf_len,
00115                                                         UINT16 flags);
00116
00131         virtual CodecManager::ResultType DecodePacket(  const UINT8 HUGE* in_buf,
00132                                                         UINT32 in_buf_len,
00133                                                         UINT16 flags);
00134
00148         virtual CodecManager::ResultType SkipFrames(const UINT8 HUGE** out_buf_array,
00149                                                     UINT8 out_buf_count = 1);
00150
00163         virtual CodecManager::ResultType ReleaseOutputBuffer(const UINT8 HUGE* out_buf);
00164
00174         virtual CodecManager::ResultType Flush();
00175
00193         virtual CodecManager::ResultType SetParameters( const ParameterType* types_array,
00194                                                         const UINT32* values_array,
00195                                                         UINT8 array_count);
00196
00217         virtual CodecManager::ResultType GetParameters( const ParameterType* types_array,
00218                                                         UINT32* values_array,
00219                                                         UINT8 array_count);
00220
00234         CodecManager::ResultType SetOutputFrame(const UINT8 HUGE* src_buf,
00235                                                 UINT32 src_buf_len,
00236                                                 UINT8 HUGE*& dec_out_buf);
00237
00255         CodecManager::ResultType GetOutputFrame(const UINT8 HUGE* dec_out_buf,
00256                                                 UINT8 HUGE* dest_buf,
00257                                                 UINT32& dest_buf_len);
00258
00259     private:
00260
00262         enum StateType {
00263             NotInUseState = 0,
00264             StartingState,
00265             StartedState,
00266             StoppingState
00267         };
00268
00269         struct StateFlags {
00270             UINT state                      :2;
00271             UINT out_buffers_allocated      :1;
00272             UINT callback_funcs_registered  :1;
00273             UINT stop_requested             :1;
00274         };
00275
00284         static void CbNotifyFrameDecoded(   UINT32 context,
00285                                             INT32 result,
00286                                             UINT32 time_stamp,
00287                                             UINT8* out_buf);
00288
00295         static void CbNotifyInBufferFree(   UINT32 context,
00296                                             INT32 result,
00297                                             UINT8* in_buf);
00298
00301         CbFrameDecoded m_cb_frame_decoded;
00304         CbInBufferFree m_cb_in_buf_free;
00305
00308         static ScicosMpeg4VideoDecoder* m_exist_this_ptr_array[c_scicos_codec_if_max_num_of_vid_dec_inst];
00311         UINT32 m_client_context;
00313         UINT32 m_out_buf_len;
00315         UINT8* m_out_buf_pool_handle;
00317         UINT8 HUGE** m_out_buf_array;
00324         UINT8 m_out_buf_array_max_count;
00327         UINT8 m_out_buf_array_curr_count;
00329         StateFlags m_flags;
00330
00332         ScicosMpeg4VideoDecoder();
00333
00365         virtual CodecManager::ResultType Start( const UINT8* config_stream,
00366                                                 UINT32& config_len,
00367                                                 const CodecManager::VideoDecoderParameters& params,
00368                                                 CodecManager::VideoStreamInfo& stream_info);
00369
00375         virtual void Stop();
00376
00382         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00383
00390         static BOOLEAN IsValidContext(UINT32 context);
00391
00395         void ReleaseDecoder();
00396
00397     friend class ScicosCodecIfLib; // creates/destroys ScicosMpeg4VideoDecoder
00398
00399 };
00400
00402 #endif // ScicosMpeg4VideoDecoder_hpp
00403
00404
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.cpp File Reference

Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.cpp File Reference

#include "ScicosMpeg4VideoEncoder.hpp"
#include "mm_tools.h"
#include "mmcd_interface.h"
#include <Kernel/Os/Os.hpp>

Include dependency graph for ScicosMpeg4VideoEncoder.cpp:

Generated on Tue Jan 24 20:32:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.hpp File Reference

Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.hpp File Reference

#include <Kernel/Types.hpp>
#include <AddOns/CodecManager/CodecManager.hpp>
#include <AddOns/CodecManager/VideoEncoder.hpp>

Include dependency graph for ScicosMpeg4VideoEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ScicosMpeg4VideoEncoder
struct | ScicosMpeg4VideoEncoder::StateFlags

Defines

#define | ScicosMpeg4VideoEncoder_hpp

Variables

const UINT8 | c_scicos_codec_if_max_num_of_vid_enc_inst = 1

Define Documentation

#define ScicosMpeg4VideoEncoder_hpp

Generated on Tue Jan 24 20:32:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.hpp Source File

Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ScicosMpeg4VideoEncoder_hpp)
00010 #define ScicosMpeg4VideoEncoder_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <AddOns/CodecManager/CodecManager.hpp>
00016 #include <AddOns/CodecManager/VideoEncoder.hpp>
00017
00019 const UINT8 c_scicos_codec_if_max_num_of_vid_enc_inst = 1;
00020
00023 class ScicosMpeg4VideoEncoder : public VideoEncoder {
00024
00025     typedef VideoEncoder Base;
00026
00027     public:
00028
00030         virtual ~ScicosMpeg4VideoEncoder();
00031
00043         virtual CodecManager::ResultType GetCapabilities(CodecManager::VideoCodecCapabilities& caps);
00044
00067         virtual CodecManager::ResultType AllocateOutputBuffers( UINT8 HUGE** &out_buf_array,
00068                                                                 UINT8& out_buf_count,
00069                                                                 UINT32& out_buf_len);
00070
00084         virtual CodecManager::ResultType RegisterCallbackFunctions( UINT32 context,
00085                                                                     CbFrameEncoded cb_frame_encoded);
00086
00112         virtual CodecManager::ResultType EncodeFrame(   UINT8 HUGE* in_buf,
00113                                                         UINT32 in_buf_len,
00114                                                         UINT32 time_stamp,
00115                                                         UINT32 key_frame_ind,
00116                                                         UINT8 HUGE* out_buf);
00117
00135         virtual CodecManager::ResultType SetParameters( const ParameterType* types_array,
00136                                                         const UINT32* values_array,
00137                                                         UINT8 array_count);
00138
00159         virtual CodecManager::ResultType GetParameters( const ParameterType* types_array,
00160                                                         UINT32* values_array,
00161                                                         UINT8 array_count);
00162
00175         virtual CodecManager::ResultType GetConfigStream(   UINT8 HUGE* out_buf,
00176                                                             UINT32& out_buf_len);
00177
00178     private:
00179
00181         enum StateType {
00182             NotInUseState = 0,
00183             StartingState,
00184             StartedState,
00185             StoppingState
00186         };
00187
00188         struct StateFlags {
00189             UINT state                      :2;
00190             UINT out_buffers_allocated      :1;
00191             UINT callback_funcs_registered  :1;
00192             UINT stop_requested             :1;
00193         };
00194
00207         static void CbNotifyFrameEncoded(   UINT32 context,
00208                                             INT32 result,
00209                                             UINT8* out_buf,
00210                                             UINT32 out_buf_len,
00211                                             UINT32 frame_type);
00212
00215         CbFrameEncoded m_cb_frame_encoded;
00216
00219         static ScicosMpeg4VideoEncoder* m_exist_this_ptr_array[c_scicos_codec_if_max_num_of_vid_enc_inst];
00222         UINT32 m_client_context;
00224         UINT32 m_out_buf_len;
00227         UINT8 m_out_buf_array_count;
00229         UINT8 HUGE** m_out_buf_array;
00231         UINT32* m_time_stamp_array;
00233         UINT8* m_config_stream_buf;
00235         UINT32 m_config_stream_buf_len;
00237         StateFlags m_flags;
00238
00240         ScicosMpeg4VideoEncoder();
00241
00252         virtual CodecManager::ResultType Start(CodecManager::VideoEncoderParameters& params);
00253
00259         virtual void Stop();
00260
00265         virtual CodecManager::ResultType ReleaseOutputBuffers();
00266
00272         CodecManager::ResultType ConvertResultCode(INT32 result_code);
00273
00279         static BOOLEAN IsValidContext(UINT32 context);
00280
00284         void ReleaseEncoder();
00285
00286
00287     friend class ScicosCodecIfLib; // creates/destroys the ScicosMpeg4VideoEncoder
00288
00289 };
00290
00292 #endif // ScicosMpeg4VideoEncoder_hpp
00293
00294
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SGold/Companion/Scicos3020/VideoCamera.cpp File Reference

Devices/SGold/Companion/Scicos3020/VideoCamera.cpp File Reference

#include "PreComp.hpp"
#include "VideoCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <mm_tools.h>
#include <mmcd_interface.h>

Include dependency graph for VideoCamera.cpp:

Generated on Tue Jan 24 20:27:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/BitBlit_16Bpp.cpp File Reference

Devices/SharedMethods/BitBlit_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (clip_rect.GetHeight()<=bmp.GetHeight())
ASSERT_DEBUG_HOST (clip_rect.GetWidth()<=bmp.GetWidth())
ASSERT_DEBUG_HOST (clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (clip_rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (dest_y+clip_rect.GetHeight()<=GetBitmap()->GetHeight())
ASSERT_DEBUG_HOST (dest_x+clip_rect.GetWidth()<=GetBitmap()->GetWidth())
ASSERT_DEBUG_HOST (dest_y+clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (dest_x+clip_rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (!clip_rect.IsEmpty())
if (bmp.IsTransparent())
if (trans_mode!=0)

Variables

XYDIM | dest_end_x = dest_x + clip_rect.GetWidth() - 1
XYDIM | dest_end_y = dest_y + clip_rect.GetHeight() - 1
dest_x = clip_rect.GetLeft()
dest_y = clip_rect.GetTop()
DDrvColorBits16Ptr | left_atom = (DDrvColorBits16Ptr)(GetBitmap()->GetBits()) + dest_y * scanline_inc + dest_x
INT | left_clip_inc = clip_rect.GetLeft()
INT | right_clip_inc = bmp.GetWidth() - clip_rect.GetWidth()
INT | scanline_inc = m_scanline_atom_count >> 1
const DDrvColorBits16Ptr | src_data = (const DDrvColorBits16Ptr)(bmp.GetBits()) + clip_rect.GetTop() * bmp.GetWidth() + left_clip_inc

Function Documentation

ASSERT_DEBUG_HOST ( clip_rect. GetHeight()<=bmp.GetHeight() )

ASSERT_DEBUG_HOST ( clip_rect. GetWidth()<=bmp.GetWidth() )

ASSERT_DEBUG_HOST ( clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( clip_rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( dest_y+clip_rect. GetHeight()<=GetBitmap()->GetHeight() )

ASSERT_DEBUG_HOST ( dest_x+clip_rect. GetWidth()<=GetBitmap()->GetWidth() )

ASSERT_DEBUG_HOST ( dest_y+clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( dest_x+clip_rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( !clip_rect. IsEmpty() )

if ( bmp. IsTransparent() )

if ( trans_mode! = 0 )

Variable Documentation

XYDIM dest_end_x = dest_x + clip_rect.GetWidth() - 1

XYDIM dest_end_y = dest_y + clip_rect.GetHeight() - 1

dest_x = clip_rect.GetLeft()

dest_y = clip_rect.GetTop()

DDrvColorBits16Ptr left_atom = (DDrvColorBits16Ptr)(GetBitmap()->GetBits()) + dest_y * scanline_inc + dest_x

INT left_clip_inc = clip_rect.GetLeft()

INT right_clip_inc = bmp.GetWidth() - clip_rect.GetWidth()

INT scanline_inc = m_scanline_atom_count >> 1

const DDrvColorBits16Ptr src_data = (const DDrvColorBits16Ptr)(bmp.GetBits()) + clip_rect.GetTop() * bmp.GetWidth() + left_clip_inc

Generated on Tue Jan 24 20:23:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/BitBlit_24Bpp.cpp File Reference

Devices/SharedMethods/BitBlit_24Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (clip_rect.GetHeight()<=bmp.GetHeight())
ASSERT_DEBUG_HOST (clip_rect.GetWidth()<=bmp.GetWidth())
ASSERT_DEBUG_HOST (clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (clip_rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (!clip_rect.IsEmpty())
ASSERT_DEBUG_HOST (dest_y+clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (dest_x+clip_rect.GetLeft() >=0)
if (bmp.IsTransparent())

Variables

DDrvAtomPtr | dest_atom
XYDIM | dest_end_x = dest_x + clip_rect.GetWidth() - 1
XYDIM | dest_end_y = dest_y + clip_rect.GetHeight() - 1
dest_x = clip_rect.GetLeft()
dest_y = clip_rect.GetTop()
DDrvAtomPtr | left_atom = GetBitmap()->GetBits() + dest_y * m_scanline_atom_count + (dest_x * 3)
INT | left_clip_inc = clip_rect.GetLeft() * 3
INT | right_clip_inc = (bmp.GetWidth() - clip_rect.GetWidth()) * 3
const DDrvAtomPtr | src_data = bmp.GetBits() + ((clip_rect.GetTop() * bmp.GetWidth()) * 3) + left_clip_inc

Function Documentation

ASSERT_DEBUG_HOST ( clip_rect. GetHeight()<=bmp.GetHeight() )

ASSERT_DEBUG_HOST ( clip_rect. GetWidth()<=bmp.GetWidth() )

ASSERT_DEBUG_HOST ( clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( clip_rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( !clip_rect. IsEmpty() )

ASSERT_DEBUG_HOST ( dest_y+clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( dest_x+clip_rect.GetLeft() >= 0 )

if ( bmp. IsTransparent() )

Variable Documentation

DDrvAtomPtr dest_atom

XYDIM dest_end_x = dest_x + clip_rect.GetWidth() - 1

XYDIM dest_end_y = dest_y + clip_rect.GetHeight() - 1

dest_x = clip_rect.GetLeft()

dest_y = clip_rect.GetTop()

DDrvAtomPtr left_atom = GetBitmap()->GetBits() + dest_y * m_scanline_atom_count + (dest_x * 3)

INT left_clip_inc = clip_rect.GetLeft() * 3

INT right_clip_inc = (bmp.GetWidth() - clip_rect.GetWidth()) * 3

const DDrvAtomPtr src_data = bmp.GetBits() + ((clip_rect.GetTop() * bmp.GetWidth()) * 3) + left_clip_inc

Generated on Tue Jan 24 20:32:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/BitBlit_32Bpp.cpp File Reference

Devices/SharedMethods/BitBlit_32Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (clip_rect.GetHeight()<=bmp.GetHeight())
ASSERT_DEBUG_HOST (clip_rect.GetWidth()<=bmp.GetWidth())
ASSERT_DEBUG_HOST (clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (clip_rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (!clip_rect.IsEmpty())
ASSERT_DEBUG_HOST (dest_y+clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (dest_x+clip_rect.GetLeft() >=0)
if (bmp.IsTransparent())

Variables

DDrvAtomPtr | dest_atom
XYDIM | dest_end_x = dest_x + clip_rect.GetWidth() - 1
XYDIM | dest_end_y = dest_y + clip_rect.GetHeight() - 1
dest_x = clip_rect.GetLeft()
dest_y = clip_rect.GetTop()
DDrvAtomPtr | left_atom = GetBitmap()->GetBits() + dest_y * m_scanline_atom_count + (dest_x << 2)
INT | left_clip_inc = clip_rect.GetLeft() << 2
INT | right_clip_inc = (bmp.GetWidth() - clip_rect.GetWidth()) << 2
const DDrvAtomPtr | src_data = bmp.GetBits() + ((clip_rect.GetTop() * bmp.GetWidth()) << 2) + left_clip_inc

Function Documentation

ASSERT_DEBUG_HOST ( clip_rect. GetHeight()<=bmp.GetHeight() )

ASSERT_DEBUG_HOST ( clip_rect. GetWidth()<=bmp.GetWidth() )

ASSERT_DEBUG_HOST ( clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( clip_rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( !clip_rect. IsEmpty() )

ASSERT_DEBUG_HOST ( dest_y+clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( dest_x+clip_rect.GetLeft() >= 0 )

if ( bmp. IsTransparent() )

Variable Documentation

DDrvAtomPtr dest_atom

XYDIM dest_end_x = dest_x + clip_rect.GetWidth() - 1

XYDIM dest_end_y = dest_y + clip_rect.GetHeight() - 1

dest_x = clip_rect.GetLeft()

dest_y = clip_rect.GetTop()

DDrvAtomPtr left_atom = GetBitmap()->GetBits() + dest_y * m_scanline_atom_count + (dest_x << 2)

INT left_clip_inc = clip_rect.GetLeft() << 2

INT right_clip_inc = (bmp.GetWidth() - clip_rect.GetWidth()) << 2

const DDrvAtomPtr src_data = bmp.GetBits() + ((clip_rect.GetTop() * bmp.GetWidth()) << 2) + left_clip_inc

Generated on Tue Jan 24 20:32:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/BitBlit_8Bpp.cpp File Reference

Devices/SharedMethods/BitBlit_8Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (clip_rect.GetHeight()<=bmp.GetHeight())
ASSERT_DEBUG_HOST (clip_rect.GetWidth()<=bmp.GetWidth())
ASSERT_DEBUG_HOST (clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (clip_rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (!clip_rect.IsEmpty())
ASSERT_DEBUG_HOST (dest_y+clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (dest_x+clip_rect.GetLeft() >=0)
if (bmp.IsTransparent())

Variables

DDrvAtomPtr | dest_atom
XYDIM | dest_end_x = dest_x + clip_rect.GetWidth() - 1
XYDIM | dest_end_y = dest_y + clip_rect.GetHeight() - 1
dest_x = clip_rect.GetLeft()
dest_y = clip_rect.GetTop()
DDrvAtomPtr | left_atom = GetBitmap()->GetBits() + dest_y * m_scanline_atom_count + dest_x
INT | left_clip_inc = clip_rect.GetLeft()
INT | right_clip_inc = (bmp.GetWidth() - clip_rect.GetWidth())
const DDrvAtomPtr | src_data = bmp.GetBits() + clip_rect.GetTop() * bmp.GetWidth() + left_clip_inc

Function Documentation

ASSERT_DEBUG_HOST ( clip_rect. GetHeight()<=bmp.GetHeight() )

ASSERT_DEBUG_HOST ( clip_rect. GetWidth()<=bmp.GetWidth() )

ASSERT_DEBUG_HOST ( clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( clip_rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( !clip_rect. IsEmpty() )

ASSERT_DEBUG_HOST ( dest_y+clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( dest_x+clip_rect.GetLeft() >= 0 )

if ( bmp. IsTransparent() )

Variable Documentation

DDrvAtomPtr dest_atom

XYDIM dest_end_x = dest_x + clip_rect.GetWidth() - 1

XYDIM dest_end_y = dest_y + clip_rect.GetHeight() - 1

dest_x = clip_rect.GetLeft()

dest_y = clip_rect.GetTop()

DDrvAtomPtr left_atom = GetBitmap()->GetBits() + dest_y * m_scanline_atom_count + dest_x

INT left_clip_inc = clip_rect.GetLeft()

INT right_clip_inc = (bmp.GetWidth() - clip_rect.GetWidth())

const DDrvAtomPtr src_data = bmp.GetBits() + clip_rect.GetTop() * bmp.GetWidth() + left_clip_inc

Generated on Tue Jan 24 20:32:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/BitBlit_Planes.cpp File Reference

Devices/SharedMethods/BitBlit_Planes.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (clip_rect.GetHeight()<=bmp.GetHeight())
ASSERT_DEBUG_HOST (clip_rect.GetWidth()<=bmp.GetWidth())
ASSERT_DEBUG_HOST (clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (clip_rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (!clip_rect.IsEmpty())
ASSERT_DEBUG_HOST (dest_y+clip_rect.GetTop() >=0)
ASSERT_DEBUG_HOST (dest_x+clip_rect.GetLeft() >=0)
ForAllPlanes (i)
if (clip_right_border)
if (clip_left_border)
if (delta< 0) delta+
if (clip_rect.GetLeft() > dest_x)

Variables

BOOLEAN | clip_left_border = (left_clip > 0)
BOOLEAN | clip_right_border = (right_clip > 0)
INT | delta = dest_x % DDRV_ATOM_BIT_COUNT
Bitmap * | dest_bmp = GetBitmap()
INT | dest_line_inc = m_scanline_atom_count - (end_atom_idx - left_atom_idx)
INT | dest_plane_inc = dest_scanline_inc * dest_bmp->GetHeight()
INT | dest_scanline_inc = DDrvGetScanlineInc(dest_bmp->GetWidth())
INT | end_atom_idx = left_atom_idx + DDrvDimToAtomIdx(clip_rect.GetRight() + 1) - DDrvDimToAtomIdx(clip_rect.GetLeft()) - 1
XYDIM | end_y = start_y + clip_rect.GetHeight() - 1
INT | i
INT | left_atom_idx = DDrvDimToAtomIdx(dest_x + clip_rect.GetLeft())
INT | left_clip = clip_rect.GetLeft() % DDRV_ATOM_BIT_COUNT
DDrvAtom left_mask_1
DDrvAtom left_mask_2
const DDrvAtom | middle_mask_1 = AtomLeftBits(delta)
const DDrvAtom | middle_mask_2 = AtomRightBits(DDRV_ATOM_BIT_COUNT - delta)
INT | n_delta = DDRV_ATOM_BIT_COUNT - delta
DDrvAtom n_left_mask_1
DDrvAtom n_left_mask_2
DDrvAtom n_right_mask_1
DDrvAtom n_right_mask_2
INT | right_clip = (clip_rect.GetRight() + 1) % DDRV_ATOM_BIT_COUNT
DDrvAtom right_mask_1
DDrvAtom right_mask_2
INT | src_line_inc = DDrvDimToAtomBitIdx(bmp.GetWidth()) - DDrvDimToAtomBitIdx(end_atom_idx - left_atom_idx)
const DDrvAtom | src_mask = AtomRightBits(delta)
INT | src_plane_inc = src_scanline_inc * bmp.GetHeight()
INT | src_scanline_inc = DDrvGetScanlineInc(bmp.GetWidth())
INT | start_atom_idx = left_atom_idx
XYDIM | start_y = dest_y + clip_rect.GetTop()

Function Documentation

ASSERT_DEBUG_HOST ( clip_rect. GetHeight()<=bmp.GetHeight() )

ASSERT_DEBUG_HOST ( clip_rect. GetWidth()<=bmp.GetWidth() )

ASSERT_DEBUG_HOST ( clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( clip_rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( !clip_rect. IsEmpty() )

ASSERT_DEBUG_HOST ( dest_y+clip_rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( dest_x+clip_rect.GetLeft() >= 0 )

ForAllPlanes ( i )

if ( clip_right_border )

if ( clip_left_border )

if ( )

if | ( | clip_rect. | GetLeft(),
 |  | dest_x |
 | ) |

Variable Documentation

BOOLEAN clip_left_border = (left_clip > 0)

BOOLEAN clip_right_border = (right_clip > 0)

INT delta = dest_x % DDRV_ATOM_BIT_COUNT

Bitmap* dest_bmp = GetBitmap()

INT dest_line_inc = m_scanline_atom_count - (end_atom_idx - left_atom_idx)

INT dest_plane_inc = dest_scanline_inc * dest_bmp->GetHeight()

INT dest_scanline_inc = DDrvGetScanlineInc(dest_bmp->GetWidth())

INT end_atom_idx = left_atom_idx + DDrvDimToAtomIdx(clip_rect.GetRight() + 1) - DDrvDimToAtomIdx(clip_rect.GetLeft()) - 1

XYDIM end_y = start_y + clip_rect.GetHeight() - 1

INT i

INT left_atom_idx = DDrvDimToAtomIdx(dest_x + clip_rect.GetLeft())

INT left_clip = clip_rect.GetLeft() % DDRV_ATOM_BIT_COUNT

DDrvAtom left_mask_1

DDrvAtom left_mask_2

const DDrvAtom middle_mask_1 = AtomLeftBits(delta)

const DDrvAtom middle_mask_2 = AtomRightBits(DDRV_ATOM_BIT_COUNT - delta)

INT n_delta = DDRV_ATOM_BIT_COUNT - delta

DDrvAtom n_left_mask_1

DDrvAtom n_left_mask_2

DDrvAtom n_right_mask_1

DDrvAtom n_right_mask_2

INT right_clip = (clip_rect.GetRight() + 1) % DDRV_ATOM_BIT_COUNT

DDrvAtom right_mask_1

DDrvAtom right_mask_2

INT src_line_inc = DDrvDimToAtomBitIdx(bmp.GetWidth()) - DDrvDimToAtomBitIdx(end_atom_idx - left_atom_idx)

const DDrvAtom src_mask = AtomRightBits(delta)

INT src_plane_inc = src_scanline_inc * bmp.GetHeight()

INT src_scanline_inc = DDrvGetScanlineInc(bmp.GetWidth())

INT start_atom_idx = left_atom_idx

XYDIM start_y = dest_y + clip_rect.GetTop()

Generated on Tue Jan 24 20:32:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ConvertToColorValue_Bpp.cpp File Reference

Devices/SharedMethods/ConvertToColorValue_Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Variables

return | color_value
color_value = (static_cast<ColorValue>(blue >> compl_blue_bits ) | color_value)
color_value = (static_cast<ColorValue>(green >> compl_green_bits) | color_value) << blue_bits
color_value = (static_cast<ColorValue>(red >> compl_red_bits ) | color_value) << green_bits
ColorValue | color_value = static_cast<ColorValue>((alpha >> compl_alpha_bits) << red_bits)

Variable Documentation

return color_value

color_value = (static_cast<ColorValue>(blue >> compl_blue_bits ) | color_value)

color_value = (static_cast<ColorValue>(green >> compl_green_bits) | color_value) << blue_bits

color_value = (static_cast<ColorValue>(red >> compl_red_bits ) | color_value) << green_bits

ColorValue color_value = static_cast<ColorValue>((alpha >> compl_alpha_bits) << red_bits)

Generated on Tue Jan 24 20:33:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ConvertToColorValue_Planes.cpp File Reference

Devices/SharedMethods/ConvertToColorValue_Planes.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT idx=0;idx< color_cont;idx++)
return (ColorValue) col_idx

Variables

UINT16 | blue_exp_2 = (UINT16)blue * (UINT16)blue
INT | col_idx = 0
const ColorTable & | col_table = DisplayConfig::GetColorTable(0)
INT | color_cont = col_table.GetColorCount()
UINT16 | green_exp_2 = (UINT16)green * (UINT16)green
UINT32 | min_distance = 0xffffffff
UINT16 | red_exp_2 = (UINT16)red * (UINT)red

Function Documentation

for ( )

return ( ColorValue )

Variable Documentation

UINT16 blue_exp_2 = (UINT16)blue * (UINT16)blue

INT col_idx = 0

const ColorTable& col_table = DisplayConfig::GetColorTable(0)

INT color_cont = col_table.GetColorCount()

UINT16 green_exp_2 = (UINT16)green * (UINT16)green

UINT32 min_distance = 0xffffffff

UINT16 red_exp_2 = (UINT16)red * (UINT)red

Generated on Tue Jan 24 20:33:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/Ddrv.cpp File Reference

Devices/SharedMethods/Ddrv.cpp File Reference

#include <Gui/ColorSegmentation.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for Ddrv.cpp:

This graph shows which files directly or indirectly include this file:

Defines

#define | ATOM_ALL_BITS ((DDrvAtom)~0)
#define | ATOM_LEFT_BIT ((DDrvAtom)(1 << (DDRV_ATOM_BIT_COUNT - 1)))
#define | DDRV_ATOM_BIT_COUNT 8
#define | DDrvColorBits16Ptr DDrvColorBits16 GDI_HUGE *
#define | DDrvColorBits32Ptr DDrvColorBits32 GDI_HUGE *
#define | DDrvColorBits8Ptr DDrvColorBits8 GDI_HUGE *
#define | DDrvDimToAtomIdx(x) ((x) >> 3)
#define | ForAllPlanes(i) for ((i) = 0; (i) < m_plane_count; (i)++)

Typedefs

typedef UINT8 | DDrvAtom
typedef UINT16 | DDrvColorBits16
typedef UINT32 | DDrvColorBits32
typedef UINT8 | DDrvColorBits8

Functions

DDrvAtom | AtomBit (DDrvAtom n)
DDrvAtom | AtomLeftBits (DDrvAtom n)
DDrvAtom | AtomRightBits (DDrvAtom n)
void | AtomShift (DDrvAtomPtr dest, const DDrvAtomPtr src, XYDIM dx)
template<class T>
T | DDrvDimToAtomBitIdx (T x)
INT | DDrvGetScanlineInc (INT width)

Define Documentation

#define ATOM_ALL_BITS ((DDrvAtom)~0)

#define ATOM_LEFT_BIT ((DDrvAtom)(1 << (DDRV_ATOM_BIT_COUNT - 1)))

#define DDRV_ATOM_BIT_COUNT 8

#define DDrvColorBits16Ptr DDrvColorBits16 GDI_HUGE *

#define DDrvColorBits32Ptr DDrvColorBits32 GDI_HUGE *

#define DDrvColorBits8Ptr DDrvColorBits8 GDI_HUGE *

#define DDrvDimToAtomIdx ( x ) ((x) >> 3)

#define ForAllPlanes ( i ) for ((i) = 0; (i) < m_plane_count; (i)++)

Typedef Documentation

typedef UINT8 DDrvAtom

typedef UINT16 DDrvColorBits16

typedef UINT32 DDrvColorBits32

typedef UINT8 DDrvColorBits8

Function Documentation

DDrvAtom AtomBit ( DDrvAtom n ) [inline]

DDrvAtom AtomLeftBits ( DDrvAtom n ) [inline]

DDrvAtom AtomRightBits ( DDrvAtom n ) [inline]

void AtomShift | ( | DDrvAtomPtr | dest,
 |  | const DDrvAtomPtr | src,
 |  | XYDIM | dx
 | ) |

template<class T>
T DDrvDimToAtomBitIdx ( T x ) [inline]

INT DDrvGetScanlineInc ( INT width ) [inline]

Generated on Tue Jan 24 20:33:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/DrawChar_16Bpp.cpp File Reference

Devices/SharedMethods/DrawChar_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Defines

#define | B00000001 (0x01)
#define | B00000001 (0x01)
#define | B00000001 (0x01)
#define | B00000001 (0x01)
#define | B00000001 (0x01)
#define | B00000001 (0x01)
#define | B00000010 (0x02)
#define | B00000010 (0x02)
#define | B00000010 (0x02)
#define | B00000010 (0x02)
#define | B00000010 (0x02)
#define | B00000010 (0x02)
#define | B00000100 (0x04)
#define | B00000100 (0x04)
#define | B00000100 (0x04)
#define | B00000100 (0x04)
#define | B00000100 (0x04)
#define | B00000100 (0x04)
#define | B00001000 (0x08)
#define | B00001000 (0x08)
#define | B00001000 (0x08)
#define | B00001000 (0x08)
#define | B00001000 (0x08)
#define | B00001000 (0x08)
#define | B00010000 (0x10)
#define | B00010000 (0x10)
#define | B00010000 (0x10)
#define | B00010000 (0x10)
#define | B00010000 (0x10)
#define | B00010000 (0x10)
#define | B00100000 (0x20)
#define | B00100000 (0x20)
#define | B00100000 (0x20)
#define | B00100000 (0x20)
#define | B00100000 (0x20)
#define | B00100000 (0x20)
#define | B01000000 (0x40)
#define | B01000000 (0x40)
#define | B01000000 (0x40)
#define | B01000000 (0x40)
#define | B01000000 (0x40)
#define | B01000000 (0x40)
#define | B10000000 (0x80)
#define | B10000000 (0x80)
#define | B10000000 (0x80)
#define | B10000000 (0x80)
#define | B10000000 (0x80)
#define | B10000000 (0x80)

Functions

for (INT y_idx=0;y_idx< height;y_idx++)

Variables

INT | atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())
const DDrvAtomPtr | data = (const DDrvAtomPtr)glyph.GetData()
INT | line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * 2 * atoms_per_scanline
p = y * m_scanline_atom_count + (x << 1)
DDrvAtomPtr | p = GetBitmap()->GetBits()

Define Documentation

#define B00000001 (0x01)

#define B00000001 (0x01)

#define B00000001 (0x01)

#define B00000001 (0x01)

#define B00000001 (0x01)

#define B00000001 (0x01)

#define B00000010 (0x02)

#define B00000010 (0x02)

#define B00000010 (0x02)

#define B00000010 (0x02)

#define B00000010 (0x02)

#define B00000010 (0x02)

#define B00000100 (0x04)

#define B00000100 (0x04)

#define B00000100 (0x04)

#define B00000100 (0x04)

#define B00000100 (0x04)

#define B00000100 (0x04)

#define B00001000 (0x08)

#define B00001000 (0x08)

#define B00001000 (0x08)

#define B00001000 (0x08)

#define B00001000 (0x08)

#define B00001000 (0x08)

#define B00010000 (0x10)

#define B00010000 (0x10)

#define B00010000 (0x10)

#define B00010000 (0x10)

#define B00010000 (0x10)

#define B00010000 (0x10)

#define B00100000 (0x20)

#define B00100000 (0x20)

#define B00100000 (0x20)

#define B00100000 (0x20)

#define B00100000 (0x20)

#define B00100000 (0x20)

#define B01000000 (0x40)

#define B01000000 (0x40)

#define B01000000 (0x40)

#define B01000000 (0x40)

#define B01000000 (0x40)

#define B01000000 (0x40)

#define B10000000 (0x80)

#define B10000000 (0x80)

#define B10000000 (0x80)

#define B10000000 (0x80)

#define B10000000 (0x80)

#define B10000000 (0x80)

Function Documentation

for ( )

Variable Documentation

INT atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())

const DDrvAtomPtr data = (const DDrvAtomPtr)glyph.GetData()

INT line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * 2 * atoms_per_scanline

p = y * m_scanline_atom_count + (x << 1)

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:25:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/DrawChar_24Bpp.cpp File Reference

Devices/SharedMethods/DrawChar_24Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT y_idx=0;y_idx< height;y_idx++)

Variables

INT | atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())
const DDrvAtomPtr | data = (const DDrvAtomPtr)glyph.GetData()
INT | line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * 3 * atoms_per_scanline
p = y * m_scanline_atom_count + (x * 3)
DDrvAtomPtr | p = GetBitmap()->GetBits()

Function Documentation

for ( )

Variable Documentation

INT atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())

const DDrvAtomPtr data = (const DDrvAtomPtr)glyph.GetData()

INT line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * 3 * atoms_per_scanline

p = y * m_scanline_atom_count + (x * 3)

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/DrawChar_32Bpp.cpp File Reference

Devices/SharedMethods/DrawChar_32Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT y_idx=0;y_idx< height;y_idx++)

Variables

INT | atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())
const DDrvAtomPtr | data = (const DDrvAtomPtr)glyph.GetData()
INT | line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * 4 * atoms_per_scanline
p = y * m_scanline_atom_count + (x << 2)
DDrvAtomPtr | p = GetBitmap()->GetBits()

Function Documentation

for ( )

Variable Documentation

INT atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())

const DDrvAtomPtr data = (const DDrvAtomPtr)glyph.GetData()

INT line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * 4 * atoms_per_scanline

p = y * m_scanline_atom_count + (x << 2)

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/DrawChar_8Bpp.cpp File Reference

Devices/SharedMethods/DrawChar_8Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT y_idx=0;y_idx< height;y_idx++)

Variables

INT | atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())
const DDrvAtomPtr | data = (const DDrvAtomPtr)glyph.GetData()
INT | line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * atoms_per_scanline
p = y * m_scanline_atom_count + x
DDrvAtomPtr | p = GetBitmap()->GetBits()

Function Documentation

for ( )

Variable Documentation

INT atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())

const DDrvAtomPtr data = (const DDrvAtomPtr)glyph.GetData()

INT line_inc = m_scanline_atom_count - DDRV_ATOM_BIT_COUNT * atoms_per_scanline

p = y * m_scanline_atom_count + x

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/DrawChar_Planes.cpp File Reference

Devices/SharedMethods/DrawChar_Planes.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ForAllPlanes (i)

Variables

INT | atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())
UINT16 | col_val = (UINT16)m_color_value
INT | delta = x % DDRV_ATOM_BIT_COUNT
INT | dest_inc = m_scanline_inc - atoms_per_scanline
DDrvAtomPtr | dest_root = GetBitmap()->GetBits() + y * m_scanline_inc + DDrvDimToAtomIdx(x)
INT | i
INT | ndelta = DDRV_ATOM_BIT_COUNT - delta
const DDrvAtom | src_mask = AtomRightBits(delta)

Function Documentation

ForAllPlanes ( i )

Variable Documentation

INT atoms_per_scanline = DDrvGetScanlineInc(glyph.GetWidth())

UINT16 col_val = (UINT16)m_color_value

Implementation note:

Assuming that lower case characters have around 40 % of empty data, the penalty for asking (*src_data != 0) should be compensated. For chinese characters this leads to a slight performance decreasement...

INT delta = x % DDRV_ATOM_BIT_COUNT

INT dest_inc = m_scanline_inc - atoms_per_scanline

DDrvAtomPtr dest_root = GetBitmap()->GetBits() + y * m_scanline_inc + DDrvDimToAtomIdx(x)

INT i

INT ndelta = DDRV_ATOM_BIT_COUNT - delta

const DDrvAtom src_mask = AtomRightBits(delta)

Generated on Tue Jan 24 20:33:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/FillRect_16Bpp.cpp File Reference

Devices/SharedMethods/FillRect_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (rect.GetBottom()<=GetHeight())
ASSERT_DEBUG_HOST (rect.GetRight()<=GetWidth())
ASSERT_DEBUG_HOST (rect.GetTop() >=0)
ASSERT_DEBUG_HOST (rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (rect.GetTop()<=rect.GetBottom())
ASSERT_DEBUG_HOST (rect.GetLeft()<=rect.GetRight())
if ((scanline_width<=8)&&(bottom-top<=2)||(m_scanline_buffer==0))

Variables

INT | bottom = rect.GetBottom()
INT | byte_count = scanline_width << 1
INT | left = rect.GetLeft()
INT | line_inc = m_scanline_atom_count - ((rect.GetRight() - rect.GetLeft() + 1) << 1)
p = rect.GetTop() * m_scanline_atom_count + (rect.GetLeft() << 1)
DDrvAtomPtr | p = GetBitmap()->GetBits()
INT | right = rect.GetRight()
INT | scanline_width = right - left + 1
INT | top = rect.GetTop()

Function Documentation

ASSERT_DEBUG_HOST ( rect. GetBottom()<=GetHeight() )

ASSERT_DEBUG_HOST ( rect. GetRight()<=GetWidth() )

ASSERT_DEBUG_HOST ( rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( rect. GetTop()<=rect.GetBottom() )

ASSERT_DEBUG_HOST ( rect. GetLeft()<=rect.GetRight() )

if ( (scanline_width<=8)&&(bottom-top<=2)||(m_scanline_buffer==0) )

Variable Documentation

INT bottom = rect.GetBottom()

INT byte_count = scanline_width << 1

INT left = rect.GetLeft()

INT line_inc = m_scanline_atom_count - ((rect.GetRight() - rect.GetLeft() + 1) << 1)

p = rect.GetTop() * m_scanline_atom_count + (rect.GetLeft() << 1)

DDrvAtomPtr p = GetBitmap()->GetBits()

INT right = rect.GetRight()

INT scanline_width = right - left + 1

INT top = rect.GetTop()

Generated on Tue Jan 24 20:25:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/FillRect_24Bpp.cpp File Reference

Devices/SharedMethods/FillRect_24Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (rect.GetBottom()<=GetHeight())
ASSERT_DEBUG_HOST (rect.GetRight()<=GetWidth())
ASSERT_DEBUG_HOST (rect.GetTop() >=0)
ASSERT_DEBUG_HOST (rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (rect.GetTop()<=rect.GetBottom())
ASSERT_DEBUG_HOST (rect.GetLeft()<=rect.GetRight())
for (INT y=rect.GetTop();y<=rect.GetBottom();y++)

Variables

INT | line_inc = m_scanline_atom_count - ((rect.GetRight() - rect.GetLeft() + 1) * 3)
p = rect.GetTop() * m_scanline_atom_count + (rect.GetLeft() * 3)
DDrvAtomPtr | p = GetBitmap()->GetBits()

Function Documentation

ASSERT_DEBUG_HOST ( rect. GetBottom()<=GetHeight() )

ASSERT_DEBUG_HOST ( rect. GetRight()<=GetWidth() )

ASSERT_DEBUG_HOST ( rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( rect. GetTop()<=rect.GetBottom() )

ASSERT_DEBUG_HOST ( rect. GetLeft()<=rect.GetRight() )

for ( )

Variable Documentation

INT line_inc = m_scanline_atom_count - ((rect.GetRight() - rect.GetLeft() + 1) * 3)

p = rect.GetTop() * m_scanline_atom_count + (rect.GetLeft() * 3)

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/FillRect_32Bpp.cpp File Reference

Devices/SharedMethods/FillRect_32Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (rect.GetBottom()<=GetHeight())
ASSERT_DEBUG_HOST (rect.GetRight()<=GetWidth())
ASSERT_DEBUG_HOST (rect.GetTop() >=0)
ASSERT_DEBUG_HOST (rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (rect.GetTop()<=rect.GetBottom())
ASSERT_DEBUG_HOST (rect.GetLeft()<=rect.GetRight())
for (INT y=rect.GetTop();y<=rect.GetBottom();y++)

Variables

DDrvColorBits32 | col_bits = (DDrvColorBits32)m_color_value
INT | line_inc = m_scanline_atom_count - ((rect.GetRight() - rect.GetLeft() + 1) << 2)
p = rect.GetTop() * m_scanline_atom_count + (rect.GetLeft() << 2)
DDrvAtomPtr | p = GetBitmap()->GetBits()

Function Documentation

ASSERT_DEBUG_HOST ( rect. GetBottom()<=GetHeight() )

ASSERT_DEBUG_HOST ( rect. GetRight()<=GetWidth() )

ASSERT_DEBUG_HOST ( rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( rect. GetTop()<=rect.GetBottom() )

ASSERT_DEBUG_HOST ( rect. GetLeft()<=rect.GetRight() )

for ( )

Variable Documentation

DDrvColorBits32 col_bits = (DDrvColorBits32)m_color_value

INT line_inc = m_scanline_atom_count - ((rect.GetRight() - rect.GetLeft() + 1) << 2)

p = rect.GetTop() * m_scanline_atom_count + (rect.GetLeft() << 2)

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/FillRect_8Bpp.cpp File Reference

Devices/SharedMethods/FillRect_8Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (rect.GetBottom()<=GetHeight())
ASSERT_DEBUG_HOST (rect.GetRight()<=GetWidth())
ASSERT_DEBUG_HOST (rect.GetTop() >=0)
ASSERT_DEBUG_HOST (rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (rect.GetTop()<=rect.GetBottom())
ASSERT_DEBUG_HOST (rect.GetLeft()<=rect.GetRight())
for (INT y=rect.GetTop();y<=rect.GetBottom();y++)

Variables

DDrvColorBits8 | col_bits = (DDrvColorBits8)m_color_value
INT | line_inc = m_scanline_atom_count - (rect.GetRight() - rect.GetLeft() + 1)
p = rect.GetTop() * m_scanline_atom_count + rect.GetLeft()
DDrvAtomPtr | p = GetBitmap()->GetBits()

Function Documentation

ASSERT_DEBUG_HOST ( rect. GetBottom()<=GetHeight() )

ASSERT_DEBUG_HOST ( rect. GetRight()<=GetWidth() )

ASSERT_DEBUG_HOST ( rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( rect. GetTop()<=rect.GetBottom() )

ASSERT_DEBUG_HOST ( rect. GetLeft()<=rect.GetRight() )

for ( )

Variable Documentation

DDrvColorBits8 col_bits = (DDrvColorBits8)m_color_value

INT line_inc = m_scanline_atom_count - (rect.GetRight() - rect.GetLeft() + 1)

p = rect.GetTop() * m_scanline_atom_count + rect.GetLeft()

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/FillRect_Planes.cpp File Reference

Devices/SharedMethods/FillRect_Planes.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (rect.GetBottom()<=GetHeight())
ASSERT_DEBUG_HOST (rect.GetRight()<=GetWidth())
ASSERT_DEBUG_HOST (rect.GetTop() >=0)
ASSERT_DEBUG_HOST (rect.GetLeft() >=0)
ASSERT_DEBUG_HOST (rect.GetTop()<=rect.GetBottom())
ASSERT_DEBUG_HOST (rect.GetLeft()<=rect.GetRight())
ForAllPlanes (i)
if (i_left==i_right)

Variables

DDrvAtom | acb [8]
DDrvAtom acb_brushstyle
DDrvAtom | atom_brushstyle_bits = ATOM_ALL_BITS
Bitmap * | bitmap = GetBitmap()
DDrvColorBits8 | cb = (DDrvColorBits8)m_color_value
INT | i
INT | i_left = DDrvDimToAtomIdx(rect.GetLeft())
INT | i_right = DDrvDimToAtomIdx(rect.GetRight())
DDrvAtom | left_mask = AtomLeftBits(DDrvDimToAtomBitIdx((DDrvAtom)rect.GetLeft()))
DDrvAtom | right_mask = AtomRightBits(DDRV_ATOM_BIT_COUNT - DDrvDimToAtomBitIdx(rect.GetRight()) - 1)
INT | y

Function Documentation

ASSERT_DEBUG_HOST ( rect. GetBottom()<=GetHeight() )

ASSERT_DEBUG_HOST ( rect. GetRight()<=GetWidth() )

ASSERT_DEBUG_HOST ( rect.GetTop() >= 0 )

ASSERT_DEBUG_HOST ( rect.GetLeft() >= 0 )

ASSERT_DEBUG_HOST ( rect. GetTop()<=rect.GetBottom() )

ASSERT_DEBUG_HOST ( rect. GetLeft()<=rect.GetRight() )

ForAllPlanes ( i )

if ( i_left = = i_right )

Variable Documentation

DDrvAtom acb[8]

DDrvAtom acb_brushstyle

DDrvAtom atom_brushstyle_bits = ATOM_ALL_BITS

Bitmap* bitmap = GetBitmap()

DDrvColorBits8 cb = (DDrvColorBits8)m_color_value

INT i

INT i_left = DDrvDimToAtomIdx(rect.GetLeft())

INT i_right = DDrvDimToAtomIdx(rect.GetRight())

DDrvAtom left_mask = AtomLeftBits(DDrvDimToAtomBitIdx((DDrvAtom)rect.GetLeft()))

DDrvAtom right_mask = AtomRightBits(DDRV_ATOM_BIT_COUNT - DDrvDimToAtomBitIdx(rect.GetRight()) - 1)

INT y

Generated on Tue Jan 24 20:33:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/GetPixelColor_16Bpp.cpp File Reference

Devices/SharedMethods/GetPixelColor_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

return | Color (color_value)

Variables

ColorValue color_value = (ColorValue)(*p)
DDrvColorBits16Ptr | p = (DDrvColorBits16Ptr)(m_bitmap.GetBits() + y * m_scanline_atom_count) + x

Function Documentation

return Color ( color_value )

Variable Documentation

ColorValue color_value = (ColorValue)(*p)

DDrvColorBits16Ptr p = (DDrvColorBits16Ptr)(m_bitmap.GetBits() + y * m_scanline_atom_count) + x

Generated on Tue Jan 24 20:33:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/GetPixelColor_24Bpp.cpp File Reference

Devices/SharedMethods/GetPixelColor_24Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

return | Color (color_value)

Variables

ColorValue color_value
p = y * m_scanline_atom_count + (x * 3)
DDrvAtomPtr | p = m_bitmap.GetBits()

Function Documentation

return Color ( color_value )

Variable Documentation

ColorValue color_value

Initial value:

 (static_cast<ColorValue>(*p) << 16) +
                         (static_cast<ColorValue>(*(p + 1)) << 8) +
                          static_cast<ColorValue>(*(p + 2))

p = y * m_scanline_atom_count + (x * 3)

DDrvAtomPtr p = m_bitmap.GetBits()

Generated on Tue Jan 24 20:33:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/GetPixelColor_32Bpp.cpp File Reference

Devices/SharedMethods/GetPixelColor_32Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

return | Color (color_value)

Variables

ColorValue | color_value = (ColorValue)(*((DDrvColorBits32Ptr)p))
p = y * m_scanline_atom_count + (x << 2)
DDrvAtomPtr | p = m_bitmap.GetBits()

Function Documentation

return Color ( color_value )

Variable Documentation

ColorValue color_value = (ColorValue)(*((DDrvColorBits32Ptr)p))

p = y * m_scanline_atom_count + (x << 2)

DDrvAtomPtr p = m_bitmap.GetBits()

Generated on Tue Jan 24 20:33:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/GetPixelColor_8Bpp.cpp File Reference

Devices/SharedMethods/GetPixelColor_8Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

return | Color (color_value)

Variables

ColorValue | color_value = (ColorValue)(*((DDrvColorBits8Ptr)p))
p = y * m_scanline_atom_count + x
DDrvAtomPtr | p = m_bitmap.GetBits()

Function Documentation

return Color ( color_value )

Variable Documentation

ColorValue color_value = (ColorValue)(*((DDrvColorBits8Ptr)p))

p = y * m_scanline_atom_count + x

DDrvAtomPtr p = m_bitmap.GetBits()

Generated on Tue Jan 24 20:33:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/GetPixelColor_Planes.cpp File Reference

Devices/SharedMethods/GetPixelColor_Planes.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

return | Color (color_value)
ForAllPlanes (i)

Variables

DDrvAtom | atom_bit = AtomBit(i_bit)
ColorValue | color_value = 0
INT | i
INT | i_atom = DDrvDimToAtomIdx((UINT16)x)
INT | i_bit = DDrvDimToAtomBitIdx(x)

Function Documentation

return Color ( color_value )

ForAllPlanes ( i )

Variable Documentation

DDrvAtom atom_bit = AtomBit(i_bit)

ColorValue color_value = 0

INT i

INT i_atom = DDrvDimToAtomIdx((UINT16)x)

INT i_bit = DDrvDimToAtomBitIdx(x)

Generated on Tue Jan 24 20:33:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/KeyboardTimer.cpp File Reference

Devices/SharedMethods/KeyboardTimer.cpp File Reference

This graph shows which files directly or indirectly include this file:

Generated on Tue Jan 24 20:33:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollHorizontal_16Bpp.cpp File Reference

Devices/SharedMethods/ScrollHorizontal_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT x=x_start;x!=x_stop;x-=Sign(dx))
if (dx > 0) right-

Variables

XYDIM | bottom = rect.GetBottom()
INT | col_inc = Sign(dx) << 1
DDrvAtomPtr | dest_col_start_atom = src_col_start_atom + (dx << 1)
else | left = dx
XYDIM | left = rect.GetLeft()
XYDIM | right = rect.GetRight()
XYDIM | top = rect.GetTop()
XYDIM | x_start
XYDIM | x_stop

Function Documentation

for ( INT x = x_start; x != x_stop; x -= Sign(dx) )

if | ( | dx | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

INT col_inc = Sign(dx) << 1

DDrvAtomPtr dest_col_start_atom = src_col_start_atom + (dx << 1)

else left = dx

XYDIM left = rect.GetLeft()

XYDIM right = rect.GetRight()

XYDIM top = rect.GetTop()

XYDIM x_start

XYDIM x_stop

Generated on Tue Jan 24 20:26:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollHorizontal_24Bpp.cpp File Reference

Devices/SharedMethods/ScrollHorizontal_24Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT x=x_start;x!=x_stop;x-=Sign(dx))
if (dx > 0) right-

Variables

XYDIM | bottom = rect.GetBottom()
INT | col_inc = Sign(dx) << 2
DDrvAtomPtr | dest_col_start_atom = src_col_start_atom + (dx * 3)
else | left = dx
XYDIM | left = rect.GetLeft()
XYDIM | right = rect.GetRight()
XYDIM | top = rect.GetTop()
XYDIM | x_start
XYDIM | x_stop

Function Documentation

for ( INT x = x_start; x != x_stop; x -= Sign(dx) )

if | ( | dx | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

INT col_inc = Sign(dx) << 2

DDrvAtomPtr dest_col_start_atom = src_col_start_atom + (dx * 3)

else left = dx

XYDIM left = rect.GetLeft()

XYDIM right = rect.GetRight()

XYDIM top = rect.GetTop()

XYDIM x_start

XYDIM x_stop

Generated on Tue Jan 24 20:33:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollHorizontal_32Bpp.cpp File Reference

Devices/SharedMethods/ScrollHorizontal_32Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT x=x_start;x!=x_stop;x-=Sign(dx))
if (dx > 0) right-

Variables

XYDIM | bottom = rect.GetBottom()
INT | col_inc = Sign(dx) << 2
DDrvAtomPtr | dest_col_start_atom = src_col_start_atom + (dx << 2)
else | left = dx
XYDIM | left = rect.GetLeft()
XYDIM | right = rect.GetRight()
XYDIM | top = rect.GetTop()
XYDIM | x_start
XYDIM | x_stop

Function Documentation

for ( INT x = x_start; x != x_stop; x -= Sign(dx) )

if | ( | dx | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

INT col_inc = Sign(dx) << 2

DDrvAtomPtr dest_col_start_atom = src_col_start_atom + (dx << 2)

else left = dx

XYDIM left = rect.GetLeft()

XYDIM right = rect.GetRight()

XYDIM top = rect.GetTop()

XYDIM x_start

XYDIM x_stop

Generated on Tue Jan 24 20:33:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollHorizontal_8Bpp.cpp File Reference

Devices/SharedMethods/ScrollHorizontal_8Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT x=x_start;x!=x_stop;x-=Sign(dx))
if (dx > 0) right-

Variables

XYDIM | bottom = rect.GetBottom()
INT | col_inc = Sign(dx)
DDrvAtomPtr | dest_col_start_atom = src_col_start_atom + dx
else | left = dx
XYDIM | left = rect.GetLeft()
XYDIM | right = rect.GetRight()
XYDIM | top = rect.GetTop()
XYDIM | x_start
XYDIM | x_stop

Function Documentation

for ( INT x = x_start; x != x_stop; x -= Sign(dx) )

if | ( | dx | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

INT col_inc = Sign(dx)

DDrvAtomPtr dest_col_start_atom = src_col_start_atom + dx

else left = dx

XYDIM left = rect.GetLeft()

XYDIM right = rect.GetRight()

XYDIM top = rect.GetTop()

XYDIM x_start

XYDIM x_stop

Generated on Tue Jan 24 20:33:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollHorizontal_Planes.cpp File Reference

Devices/SharedMethods/ScrollHorizontal_Planes.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ForAllPlanes (p)
if (dx > 0) right-

Variables

Bitmap * | bitmap = GetBitmap()
XYDIM | bottom = rect.GetBottom()
DDrvAtomPtr | dest_atom
XYDIM | dx_atom = DDrvDimToAtomBitIdx(x_start_dest) - DDrvDimToAtomBitIdx(x_start)
INT | i_dest
INT | i_src
XYDIM | i_start_dest = DDrvDimToAtomIdx(x_start_dest)
XYDIM | i_start_src = DDrvDimToAtomIdx(x_start)
XYDIM | i_stodest_atom = DDrvDimToAtomIdx(x_stop_dest)
XYDIM | i_stosrc_atom = DDrvDimToAtomIdx(x_stop)
else | left = dx
XYDIM | left = rect.GetLeft()
DDrvAtom mask_dest
DDrvAtom mask_src
INT | p
XYDIM | right = rect.GetRight()
DDrvAtom src
DDrvAtomPtr | src_atom
XYDIM | top = rect.GetTop()
XYDIM | x_start
XYDIM | x_start_dest
XYDIM | x_stop
x_stop_dest = x_stop + dx
XYDIM | x_stop_dest
XYDIM | y

Function Documentation

ForAllPlanes ( p )

if | ( | dx | ,
 |  | 0 |
 | ) |

Variable Documentation

Bitmap* bitmap = GetBitmap()

XYDIM bottom = rect.GetBottom()

DDrvAtomPtr dest_atom

XYDIM dx_atom = DDrvDimToAtomBitIdx(x_start_dest) - DDrvDimToAtomBitIdx(x_start)

INT i_dest

INT i_src

XYDIM i_start_dest = DDrvDimToAtomIdx(x_start_dest)

XYDIM i_start_src = DDrvDimToAtomIdx(x_start)

XYDIM i_stodest_atom = DDrvDimToAtomIdx(x_stop_dest)

XYDIM i_stosrc_atom = DDrvDimToAtomIdx(x_stop)

else left = dx

XYDIM left = rect.GetLeft()

DDrvAtom mask_dest

DDrvAtom mask_src

INT p

XYDIM right = rect.GetRight()

DDrvAtom src

DDrvAtomPtr src_atom

XYDIM top = rect.GetTop()

XYDIM x_start

XYDIM x_start_dest

XYDIM x_stop

x_stop_dest = x_stop + dx

XYDIM x_stop_dest

XYDIM y

Generated on Tue Jan 24 20:33:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollVertical_16Bpp.cpp File Reference

Devices/SharedMethods/ScrollVertical_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT y=y_start;y!=y_stop;y-=Sign(dy))
if (dy > 0) bottom-

Variables

XYDIM | bottom = rect.GetBottom()
DDrvAtomPtr | dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count
XYDIM | left = rect.GetLeft()
INT | line_inc = m_scanline_atom_count * Sign(dy)
XYDIM | right = rect.GetRight()
else | top = dy
XYDIM | top = rect.GetTop()
INT | y_start
INT | y_stop

Function Documentation

for ( INT y = y_start; y != y_stop; y -= Sign(dy) )

if | ( | dy | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

DDrvAtomPtr dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count

XYDIM left = rect.GetLeft()

INT line_inc = m_scanline_atom_count * Sign(dy)

XYDIM right = rect.GetRight()

else top = dy

XYDIM top = rect.GetTop()

INT y_start

INT y_stop

Generated on Tue Jan 24 20:26:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollVertical_24Bpp.cpp File Reference

Devices/SharedMethods/ScrollVertical_24Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT y=y_start;y!=y_stop;y-=Sign(dy))
if (dy > 0) bottom-

Variables

XYDIM | bottom = rect.GetBottom()
DDrvAtomPtr | dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count
XYDIM | left = rect.GetLeft()
INT | line_inc = m_scanline_atom_count * Sign(dy)
XYDIM | right = rect.GetRight()
else | top = dy
XYDIM | top = rect.GetTop()
INT | y_start
INT | y_stop

Function Documentation

for ( INT y = y_start; y != y_stop; y -= Sign(dy) )

if | ( | dy | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

DDrvAtomPtr dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count

XYDIM left = rect.GetLeft()

INT line_inc = m_scanline_atom_count * Sign(dy)

XYDIM right = rect.GetRight()

else top = dy

XYDIM top = rect.GetTop()

INT y_start

INT y_stop

Generated on Tue Jan 24 20:33:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollVertical_32Bpp.cpp File Reference

Devices/SharedMethods/ScrollVertical_32Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT y=y_start;y!=y_stop;y-=Sign(dy))
if (dy > 0) bottom-

Variables

XYDIM | bottom = rect.GetBottom()
DDrvAtomPtr | dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count
XYDIM | left = rect.GetLeft()
INT | line_inc = m_scanline_atom_count * Sign(dy)
XYDIM | right = rect.GetRight()
else | top = dy
XYDIM | top = rect.GetTop()
INT | y_start
INT | y_stop

Function Documentation

for ( INT y = y_start; y != y_stop; y -= Sign(dy) )

if | ( | dy | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

DDrvAtomPtr dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count

XYDIM left = rect.GetLeft()

INT line_inc = m_scanline_atom_count * Sign(dy)

XYDIM right = rect.GetRight()

else top = dy

XYDIM top = rect.GetTop()

INT y_start

INT y_stop

Generated on Tue Jan 24 20:33:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollVertical_8Bpp.cpp File Reference

Devices/SharedMethods/ScrollVertical_8Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

for (INT y=y_start;y!=y_stop;y-=Sign(dy))
if (dy > 0) bottom-

Variables

XYDIM | bottom = rect.GetBottom()
DDrvAtomPtr | dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count
XYDIM | left = rect.GetLeft()
INT | line_inc = m_scanline_atom_count * Sign(dy)
XYDIM | right = rect.GetRight()
else | top = dy
XYDIM | top = rect.GetTop()
INT | y_start
INT | y_stop

Function Documentation

for ( INT y = y_start; y != y_stop; y -= Sign(dy) )

if | ( | dy | ,
 |  | 0 |
 | ) |

Variable Documentation

XYDIM bottom = rect.GetBottom()

DDrvAtomPtr dest_line_start_atom = src_line_start_atom + dy * m_scanline_atom_count

XYDIM left = rect.GetLeft()

INT line_inc = m_scanline_atom_count * Sign(dy)

XYDIM right = rect.GetRight()

else top = dy

XYDIM top = rect.GetTop()

INT y_start

INT y_stop

Generated on Tue Jan 24 20:33:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/ScrollVertical_Planes.cpp File Reference

Devices/SharedMethods/ScrollVertical_Planes.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

if (i_left==i_right)
if (dy > 0) bottom-

Variables

Bitmap * | bitmap = GetBitmap()
XYDIM | bottom = rect.GetBottom()
INT | i = 0
INT | i_right = DDrvDimToAtomIdx(right)
XYDIM | left = rect.GetLeft()
DDrvAtom | left_mask = AtomLeftBits(DDrvDimToAtomBitIdx((DDrvAtom)left))
XYDIM | right = rect.GetRight()
DDrvAtom | right_mask = AtomRightBits(DDRV_ATOM_BIT_COUNT - DDrvDimToAtomBitIdx((DDrvAtom)right) - 1)
else | top = dy
XYDIM | top = rect.GetTop()
INT | y_start
INT | y_stop

Function Documentation

if ( i_left = = i_right )

if | ( | dy | ,
 |  | 0 |
 | ) |

Variable Documentation

Bitmap* bitmap = GetBitmap()

XYDIM bottom = rect.GetBottom()

INT i = 0

INT i_right = DDrvDimToAtomIdx(right)

XYDIM left = rect.GetLeft()

DDrvAtom left_mask = AtomLeftBits(DDrvDimToAtomBitIdx((DDrvAtom)left))

XYDIM right = rect.GetRight()

DDrvAtom right_mask = AtomRightBits(DDRV_ATOM_BIT_COUNT - DDrvDimToAtomBitIdx((DDrvAtom)right) - 1)

else top = dy

XYDIM top = rect.GetTop()

INT y_start

INT y_stop

Generated on Tue Jan 24 20:33:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/SetPixel_16Bpp.cpp File Reference

Devices/SharedMethods/SetPixel_16Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ASSERT_DEBUG_HOST (x >=0 &&x< GetWidth())

Variables

* p = m_color_value
DDrvColorBits16Ptr p = (DDrvColorBits16Ptr)(GetBitmap()->GetBits() + y * m_scanline_atom_count) + x

Function Documentation

ASSERT_DEBUG_HOST ( )

Variable Documentation

* p = m_color_value

DDrvColorBits16Ptr p = (DDrvColorBits16Ptr)(GetBitmap()->GetBits() + y * m_scanline_atom_count) + x

Generated on Tue Jan 24 20:33:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/SetPixel_24Bpp.cpp File Reference

Devices/SharedMethods/SetPixel_24Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Variables

* p = static_cast<DDrvAtom>(m_color_value & 0xff)
* p = static_cast<DDrvAtom>((m_color_value >> 8) & 0xff)
* p = static_cast<DDrvAtom>(m_color_value >> 16)
p = y * m_scanline_atom_count + (x * 3)
DDrvAtomPtr p = GetBitmap()->GetBits()

Variable Documentation

* p = static_cast<DDrvAtom>(m_color_value & 0xff)

* p = static_cast<DDrvAtom>((m_color_value >> 8) & 0xff)

* p = static_cast<DDrvAtom>(m_color_value >> 16)

p = y * m_scanline_atom_count + (x * 3)

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/SetPixel_32Bpp.cpp File Reference

Devices/SharedMethods/SetPixel_32Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Variables

*DDrvColorBits32Ptr | p = (DDrvColorBits32)m_color_value
p = y * m_scanline_atom_count + (x << 2)
DDrvAtomPtr | p = GetBitmap()->GetBits()

Variable Documentation

* DDrvColorBits32Ptr p = (DDrvColorBits32)m_color_value

p = y * m_scanline_atom_count + (x << 2)

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/SetPixel_8Bpp.cpp File Reference

Devices/SharedMethods/SetPixel_8Bpp.cpp File Reference

This graph shows which files directly or indirectly include this file:

Variables

*DDrvColorBits8Ptr | p = (DDrvColorBits8)m_color_value
p = y * m_scanline_atom_count + x
DDrvAtomPtr | p = GetBitmap()->GetBits()

Variable Documentation

* DDrvColorBits8Ptr p = (DDrvColorBits8)m_color_value

p = y * m_scanline_atom_count + x

DDrvAtomPtr p = GetBitmap()->GetBits()

Generated on Tue Jan 24 20:33:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/SharedMethods/SetPixel_Planes.cpp File Reference

Devices/SharedMethods/SetPixel_Planes.cpp File Reference

This graph shows which files directly or indirectly include this file:

Functions

ForAllPlanes (i)

Variables

DDrvAtom | atom_bit = AtomBit(i_bit)
Bitmap * | bitmap = GetBitmap()
UINT16 | col_val = (UINT16)m_color_value
INT | i
INT | i_atom = DDrvDimToAtomIdx((UINT16)x)
INT | i_bit = DDrvDimToAtomBitIdx(x)
DDrvAtom mask = ~atom_bit

Function Documentation

ForAllPlanes ( i )

Variable Documentation

DDrvAtom atom_bit = AtomBit(i_bit)

Bitmap* bitmap = GetBitmap()

UINT16 col_val = (UINT16)m_color_value

INT i

INT i_atom = DDrvDimToAtomIdx((UINT16)x)

INT i_bit = DDrvDimToAtomBitIdx(x)

DDrvAtom mask = ~atom_bit

Generated on Tue Jan 24 20:33:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/AmplifierAudioDevice.cpp File Reference

Devices/Win32/AmplifierAudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "AmplifierAudioDevice.hpp"

Include dependency graph for AmplifierAudioDevice.cpp:

Generated on Tue Jan 24 20:33:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/AmplifierAudioDevice.hpp File Reference

Devices/Win32/AmplifierAudioDevice.hpp File Reference

#include <Kernel/Types.hpp>
#include "GenericAudioDevice.hpp"

Include dependency graph for AmplifierAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AmplifierAudioDevice

Defines

#define | AmplifierAudioDevice_hpp

Define Documentation

#define AmplifierAudioDevice_hpp

Generated on Tue Jan 24 20:33:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/AmplifierAudioDevice.hpp Source File

Devices/Win32/AmplifierAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009
00010 #if !defined(AmplifierAudioDevice_hpp)
00011 #define AmplifierAudioDevice_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include "GenericAudioDevice.hpp"
00015
00022 class AmplifierAudioDevice : public GenericAudioDevice {
00023     public:
00024         AmplifierAudioDevice();
00025         virtual ~AmplifierAudioDevice();
00026
00028         virtual const WCHAR* GetName() const;
00029
00031         virtual AudioReturnCode Init(Priority prio);
00032
00035         virtual AudioReturnCode Start(BOOLEAN auto_release = TRUE);
00036
00038         virtual AudioReturnCode Stop(UINT8 channel = 0);
00039 };
00040
00041 #endif // AmplifierAudioDevice_hpp
00042
00043
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/AragonServer.cpp File Reference

Devices/Win32/AragonServer.cpp File Reference

#include "PreComp.hpp"
#include "AragonServer.hpp"
#include "GatiManager.hpp"
#include <Devices/Display.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/Window.hpp>
#include <Gui/WindowManager.hpp>
#include <Gui/ResourceManager.hpp>
#include <Gui/DrawableObject.hpp>
#include <Gui/GridLayout.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/Application.hpp>
#include <Auxiliary/BufferedData.hpp>
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for AragonServer.cpp:

Defines

#define APOXI_MAX_RESPONSE_LEN 500000

Functions

REGISTER_GATI_SERVER (AragonServer) AragonServer

Define Documentation

#define APOXI_MAX_RESPONSE_LEN 500000

Function Documentation

REGISTER_GATI_SERVER ( AragonServer )

Generated on Tue Jan 24 20:33:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/AragonServer.hpp File Reference

Devices/Win32/AragonServer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_AragonServer_hpp

Define Documentation

#define Apoxi_AragonServer_hpp

Generated on Tue Jan 24 20:33:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/AragonServer.hpp Source File

Devices/Win32/AragonServer.hpp

Go to the documentation of this file.
00001 /* ----------------------------------------------------------------------------------------------
00002    Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003    ----------------------------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted withOut prior written authorisation.
00007    ---------------------------------------------------------------------------------------------- */
00008
00009 #if !defined(Apoxi_AragonServer_hpp)
00010 #define Apoxi_AragonServer_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00012
00013 class String;
00014 class Component;
00015 class Control;
00016 #include <Devices/Win32/GatiServer.hpp>
00017 #include <Kernel/Os/Semaphore.hpp>
00018
00022 class AragonServer : public GatiServer {
00023     public:
00024         enum {
00025             ID = 1
00026         };
00027
00029         static AragonServer& GetInstance();
00030         virtual ~AragonServer();
00031
00033         virtual INT GetId() const;
00034
00036         virtual void Destroy();
00037
00039         virtual void OnConnect();
00040
00042         virtual void OnDisconnect();
00043
00048         virtual void OnDataReceived(UINT32 cmd, UINT32 length, void* data);
00049
00053         static GatiServer* CreateInstance();
00054
00056         BOOLEAN HasRequests() const { return m_has_requests; }
00057
00061         void MarkResponseReady() { m_response_ready = TRUE; }
00062
00067         BOOLEAN IsResponseReady() const { return m_response_ready; }
00068
00072         void SendResponse();
00073
00074 #ifdef APOXI_COMPAT_2_0_0
00075
00076         void MarkDisplayEvent() {}
00077
00079         BOOLEAN HasDisplayEvent() const { return FALSE; }
00080 #endif
00081
00082     private:
00083         AragonServer();
00084         void SendComponentBoundaries();
00085         void TraverseControls(const Control* control);
00086         void WriteBoundary(const Component& comp);
00087
00088         BOOLEAN m_has_requests;
00089         BOOLEAN m_response_ready;
00090         INT m_clients_count;
00091         INT32 m_request_id;
00092         CHAR* m_output_string;
00093         INT32 m_output_idx;
00094         XYDIM m_display_width;
00095         XYDIM m_display_height;
00096         Semaphore m_sem;
00097 };
00098
00099 #endif // DOXYGEN_SHOULD_SKIP_THIS
00100 #endif  // Apoxi_AragonServer_hpp
00101
00102
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/aud_drv.cpp File Reference

Devices/Win32/aud_drv.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/Os.hpp>
#include <Devices/Win32/aud_drv.h>
#include <Devices/Win32/aud_drv_tone_var.h>
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for aud_drv.cpp:

Defines

#define | huge
#define | SET_G_TONE_DATA(x)

Typedefs

typedef int(* | ptr_GetAudioBufferFunction )(UINT8 **, UINT16 *, void *user_data)
typedef _Wav | Wav

Functions

SINT8 | AUD_add_downlinkpath (aud_downlink_source_enum path)
SINT8 | AUD_add_uplinkpath (aud_uplink_source_enum path)
SINT8 | AUD_allocate_resource (UINT16 id, aud_resource_enum resource, aud_priority_enum priority)
SINT8 | AUD_amp_disable (UINT8 handle)
SINT8 | AUD_amp_enable (UINT8 handle)
void | aud_drv_check_timeout (void)
void | aud_drv_restart_hf (void)
void | aud_drv_tst_buzzer_melody (void *data, unsigned int id, unsigned int nof_repeats, unsigned int nof_tones, unsigned char duty_cycle)
void | aud_drv_tst_buzzer_tone (unsigned int freq, unsigned char duty_cycle)
void | aud_drv_tst_buzzer_tune (unsigned char melody, unsigned char duty_cycle, unsigned int nof_repeats)
unsigned char | aud_drv_tst_dsp_parm_ready (void)
void | aud_drv_tst_external_devices (unsigned char device, aud_accessory_enum audio_mode)
void | aud_drv_tst_read_dsp_audio_parms (unsigned int *data)
void | aud_drv_tst_set_audio_parm (unsigned int parm_id, signed int *data)
void | aud_drv_tst_start_testing_poly_tone_chip (aud_tone_id_enum tone_id, unsigned int nof_repeat, unsigned char mix_tone, unsigned int mix_ratio, aud_ringer_device_enum ring_type)
void | aud_drv_tst_stop_testing_poly_tone_chip (void)
UINT32 | AUD_get_downlnk_parallel_path_configuration (aud_downlink_source_enum path)
UINT32 | AUD_get_uplink_parallel_path_configuration (aud_uplink_source_enum path)
UINT16 | AUD_info_driver_status (void)
UINT32 | AUD_info_hw_available (void)
void | AUD_init (void)
SINT8 | AUD_mapi (UINT8 handle, aud_mapi_if_enum func_id, UINT32 parm1, UINT32 parm2, UINT32 parm3, UINT32 parm4, UINT32 parm5, UINT32 parm6, UINT32 parm7)
void | AUD_misc_set_accessory (aud_accessory_enum accessory)
void | AUD_misc_set_vmic (UINT8 status)
SINT8 | AUD_mp3_backward (UINT8 handle, UINT16 frame)
SINT8 | AUD_mp3_fastforward (UINT8 handle, UINT16 frame)
void | Aud_mp3_get_buffer_function (UINT8 handle, ptr_GetAudioBufferFunction func, void *user_data)
SINT8 | AUD_mp3_pause (UINT8 handle)
SINT8 | AUD_mp3_resume (UINT8 handle)
SINT8 | AUD_mp3_seek (UINT8 handle, SINT8 speed)
SINT8 | AUD_mp3_set (UINT8 handle, UINT16 time)
SINT8 | AUD_mp3_set_volume (UINT8 handle, aud_volume_enum volume)
SINT8 | AUD_mp3_set_volume (UINT8 handle)
SINT8 | AUD_mp3_start (UINT8 handle, aud_media_enum media_type, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size, UINT32 id_offset, UINT32 start_frame, UINT16 nof_repeats)
SINT8 | AUD_mp3_start (UINT8 handle, aud_media_enum media_type, UINT16 DWD_HUGE *file_handle, UINT16 buffer_size)
SINT8 | AUD_mp3_start (UINT8 handle)
SINT8 | AUD_mp3_suspend (UINT8 handle)
SINT8 | AUD_mute_master (aud_mute_enum enable_disable)
SINT8 | AUD_mute_resource (UINT8 handle, aud_mute_enum enable_disable, aud_ul_dl_direction_enum direction)
SINT8 | AUD_pcm_intern_get_play_position (UINT8 handle)
SINT8 | AUD_pcm_intern_get_total_playtime (UINT8 handle, aud_media_enum media_type, aud_pcm_format_enum format, aud_pcm_sample_rate_enum sample_rate, aud_pcm_mode_enum mode, UINT8 bit_rate, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size, UINT32 offset)
SINT8 | AUD_pcm_intern_resume (UINT8 handle, UINT8 slot_id)
SINT8 | AUD_pcm_intern_set_play_position (UINT8 handle, UINT32 pos, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size)
SINT8 | AUD_pcm_intern_suspend (UINT8 handle, UINT8 slot_id)
SINT8 | AUD_radio_disable (UINT8 handle)
SINT8 | AUD_radio_enable (UINT8 handle)
SINT8 | AUD_radio_rds_subscribe (UINT8 handle, ptr_FmRadioRdsCallbackFunction pCbFunc)
SINT8 | AUD_radio_rssi_subscribe (UINT8 handle, aud_fm_radio_rssi_enum lower_threshold, aud_fm_radio_rssi_enum upper_threshold)
SINT8 | AUD_radio_set_station (UINT8 handle, aud_fm_radio_seek_mode_enum seekmode, UINT32 frequency, aud_fm_radio_rssi_enum detect_level, UINT8 force_mono)
SINT8 | AUD_release_resource (UINT8 handle)
SINT8 | AUD_remove_downlinkpath (aud_downlink_source_enum path)
SINT8 | AUD_remove_uplinkpath (aud_uplink_source_enum path)
SINT8 | AUD_ringer_get_playposition (UINT8 handle)
SINT8 | AUD_ringer_get_total_playtime (UINT8 handle, UINT8 DWD_HUGE *data, UINT32 data_size, aud_format_enum format, aud_ringer_tone_id_enum tone_id)
SINT8 | AUD_ringer_resume (UINT8 handle, UINT8 SlotID, UINT8 channel)
SINT8 | AUD_ringer_set_channel_volume (UINT8 handle, UINT8 channel_volume, UINT8 channel)
SINT8 | AUD_ringer_set_playposition (UINT8 handle, UINT8 channel, UINT32 offset)
SINT8 | AUD_ringer_set_volume (UINT8 handle, aud_ringer_volume_enum volume)
SINT8 | AUD_ringer_start (UINT8 handle, aud_ringer_tone_id_enum tone_id, UINT16 nof_repeats, aud_ringer_device_enum device)
SINT8 | AUD_ringer_start_user_tone (UINT8 handle, UINT8 huge *ringer_data, UINT32 size, aud_format_enum format, UINT16 nof_repeats, aud_ringer_device_enum device, UINT8 channel, UINT8 channel_volume)
SINT8 | AUD_ringer_stop (UINT8 handle, UINT8 channel)
SINT8 | AUD_ringer_stop_suspend (UINT8 handle, UINT8 SlotID, UINT8 channel)
SINT8 | AUD_ringer_suspend (UINT8 handle, UINT8 SlotID, UINT8 channel)
SINT8 | AUD_set_EC_NR (UINT8 EC_on, UINT8 NR_on)
SINT8 | AUD_set_master_volume (aud_volume_enum volume)
SINT8 | AUD_set_resource_volume (UINT8 handle, aud_volume_enum volume)
SINT8 | AUD_set_volume (UINT8 handle, aud_volume_enum level)
SINT8 | AUD_speech_disable (UINT8 handle)
SINT8 | AUD_speech_enable (UINT8 handle)
SINT8 | AUD_speech_mute (UINT8 handle, aud_mute_enum status, aud_direction_enum direction)
SINT8 | AUD_speech_set_volume (UINT8 handle, aud_speech_volume_enum volume)
SINT8 | AUD_tone_get_play_position (UINT8 handle)
SINT8 | AUD_tone_get_total_playtime (UINT8 handle, aud_tone_id_enum tone_id, void *tone_data, UINT32 nof_tones, aud_tone_type_enum type)
SINT8 | AUD_tone_resume (UINT8 handle, UINT8 slot_id)
SINT8 | AUD_tone_set_play_position (UINT8 handle, UINT32 pos)
SINT8 | AUD_tone_start (UINT8 handle, aud_tone_id_enum tone_id, UINT16 nof_repeats, SINT16 mix_factor)
SINT8 | AUD_tone_start_user_tone (UINT8 handle, void *tone_data, aud_tone_type_enum type, UINT32 nof_tones, UINT16 nof_repeats, SINT16 mix_factor)
SINT8 | AUD_tone_stop (UINT8 handle)
SINT8 | AUD_tone_suspend (UINT8 handle, UINT8 slot_id)
void | AUD_tst_set_dai (aud_dai_mode_enum mode)
SINT8 | AUD_vibrator_start (UINT8 handle, aud_vibrator_mode_enum mode, aud_vibrator_on_enum on, aud_vibrator_off_enum off)
SINT8 | AUD_vibrator_stop (UINT8 handle)
SINT8 | AUD_vm_get_play_position (UINT8 handle)
SINT8 | AUD_vm_get_total_playtime (UINT8 handle, aud_media_enum media_type, aud_dsp_format_enum format, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size, UINT32 offset)
SINT8 | AUD_vm_resume (UINT8 handle, UINT8 slot_id)
SINT8 | AUD_vm_set_play_position (UINT8 handle, UINT32 pos, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size)
SINT8 | AUD_vm_start_playback (UINT8 handle, aud_vm_mode_enum vm_mode, aud_media_enum media_type, aud_dsp_format_enum format, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size, UINT16 nof_repeats, UINT32 offset)
SINT8 | AUD_vm_start_recording (UINT8 handle, aud_vm_mode_enum vm_mode, aud_media_enum media_type, aud_dsp_format_enum format, UINT8 rate, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size, UINT32 offset)
SINT8 | AUD_vm_suspend (UINT8 handle, UINT8 slot_id)

Variables

UINT16 | g_drv_id []
aud_priority_enum | g_priority = aud_priority_normal

Define Documentation

#define huge

#define SET_G_TONE_DATA ( x )

Value:

g_tone_data.p_data = x;\
    g_tone_data.nof_tones = sizeof(x) / sizeof(NormalTone); \
    g_tone_data.nof_repeats = nof_repeats;\
    g_tone_data.type = aud_single_user_tone;

Typedef Documentation

typedef int(* ptr_GetAudioBufferFunction)(UINT8 **, UINT16 *,void *user_data)

typedef struct _Wav Wav

Function Documentation

SINT8 AUD_add_downlinkpath ( aud_downlink_source_enum path )

SINT8 AUD_add_uplinkpath ( aud_uplink_source_enum path )

SINT8 AUD_allocate_resource | ( | UINT16 | id,
 |  | aud_resource_enum | resource,
 |  | aud_priority_enum | priority
 | ) |

SINT8 AUD_amp_disable ( UINT8 handle )

SINT8 AUD_amp_enable ( UINT8 handle )

void aud_drv_check_timeout ( void )

void aud_drv_restart_hf ( void )

void aud_drv_tst_buzzer_melody | ( | void * | data,
 |  | unsigned int | id,
 |  | unsigned int | nof_repeats,
 |  | unsigned int | nof_tones,
 |  | unsigned char | duty_cycle
 | ) |

void aud_drv_tst_buzzer_tone | ( | unsigned int | freq,
 |  | unsigned char | duty_cycle
 | ) |

void aud_drv_tst_buzzer_tune | ( | unsigned char | melody,
 |  | unsigned char | duty_cycle,
 |  | unsigned int | nof_repeats
 | ) |

unsigned char aud_drv_tst_dsp_parm_ready ( void )

void aud_drv_tst_external_devices | ( | unsigned char | device,
 |  | aud_accessory_enum | audio_mode
 | ) |

void aud_drv_tst_read_dsp_audio_parms ( unsigned int * data )

void aud_drv_tst_set_audio_parm | ( | unsigned int | parm_id,
 |  | signed int * | data
 | ) |

void aud_drv_tst_start_testing_poly_tone_chip | ( | aud_tone_id_enum | tone_id,
 |  | unsigned int | nof_repeat,
 |  | unsigned char | mix_tone,
 |  | unsigned int | mix_ratio,
 |  | aud_ringer_device_enum | ring_type
 | ) |

void aud_drv_tst_stop_testing_poly_tone_chip ( void )

UINT32 AUD_get_downlnk_parallel_path_configuration ( aud_downlink_source_enum path )

UINT32 AUD_get_uplink_parallel_path_configuration ( aud_uplink_source_enum path )

UINT16 AUD_info_driver_status ( void )

UINT32 AUD_info_hw_available ( void )

void AUD_init ( void )

SINT8 AUD_mapi | ( | UINT8 | handle,
 |  | aud_mapi_if_enum | func_id,
 |  | UINT32 | parm1,
 |  | UINT32 | parm2,
 |  | UINT32 | parm3,
 |  | UINT32 | parm4,
 |  | UINT32 | parm5,
 |  | UINT32 | parm6,
 |  | UINT32 | parm7
 | ) |

void AUD_misc_set_accessory ( aud_accessory_enum accessory )

void AUD_misc_set_vmic ( UINT8 status )

SINT8 AUD_mp3_backward | ( | UINT8 | handle,
 |  | UINT16 | frame
 | ) |

SINT8 AUD_mp3_fastforward | ( | UINT8 | handle,
 |  | UINT16 | frame
 | ) |

void Aud_mp3_get_buffer_function | ( | UINT8 | handle,
 |  | ptr_GetAudioBufferFunction | func,
 |  | void * | user_data
 | ) |

SINT8 AUD_mp3_pause ( UINT8 handle )

SINT8 AUD_mp3_resume ( UINT8 handle )

SINT8 AUD_mp3_seek | ( | UINT8 | handle,
 |  | SINT8 | speed
 | ) |

SINT8 AUD_mp3_set | ( | UINT8 | handle,
 |  | UINT16 | time
 | ) |

SINT8 AUD_mp3_set_volume | ( | UINT8 | handle,
 |  | aud_volume_enum | volume
 | ) |

SINT8 AUD_mp3_set_volume ( UINT8 handle )

SINT8 AUD_mp3_start | ( | UINT8 | handle,
 |  | aud_media_enum | media_type,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size,
 |  | UINT32 | id_offset,
 |  | UINT32 | start_frame,
 |  | UINT16 | nof_repeats
 | ) |

SINT8 AUD_mp3_start | ( | UINT8 | handle,
 |  | aud_media_enum | media_type,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT16 | buffer_size
 | ) |

SINT8 AUD_mp3_start ( UINT8 handle )

SINT8 AUD_mp3_suspend ( UINT8 handle )

SINT8 AUD_mute_master ( aud_mute_enum enable_disable )

SINT8 AUD_mute_resource | ( | UINT8 | handle,
 |  | aud_mute_enum | enable_disable,
 |  | aud_ul_dl_direction_enum | direction
 | ) |

SINT8 AUD_pcm_intern_get_play_position ( UINT8 handle )

SINT8 AUD_pcm_intern_get_total_playtime | ( | UINT8 | handle,
 |  | aud_media_enum | media_type,
 |  | aud_pcm_format_enum | format,
 |  | aud_pcm_sample_rate_enum | sample_rate,
 |  | aud_pcm_mode_enum | mode,
 |  | UINT8 | bit_rate,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size,
 |  | UINT32 | offset
 | ) |

SINT8 AUD_pcm_intern_resume | ( | UINT8 | handle,
 |  | UINT8 | slot_id
 | ) |

SINT8 AUD_pcm_intern_set_play_position | ( | UINT8 | handle,
 |  | UINT32 | pos,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size
 | ) |

SINT8 AUD_pcm_intern_suspend | ( | UINT8 | handle,
 |  | UINT8 | slot_id
 | ) |

SINT8 AUD_radio_disable ( UINT8 handle )

SINT8 AUD_radio_enable ( UINT8 handle )

SINT8 AUD_radio_rds_subscribe | ( | UINT8 | handle,
 |  | ptr_FmRadioRdsCallbackFunction | pCbFunc
 | ) |

SINT8 AUD_radio_rssi_subscribe | ( | UINT8 | handle,
 |  | aud_fm_radio_rssi_enum | lower_threshold,
 |  | aud_fm_radio_rssi_enum | upper_threshold
 | ) |

SINT8 AUD_radio_set_station | ( | UINT8 | handle,
 |  | aud_fm_radio_seek_mode_enum | seekmode,
 |  | UINT32 | frequency,
 |  | aud_fm_radio_rssi_enum | detect_level,
 |  | UINT8 | force_mono
 | ) |

SINT8 AUD_release_resource ( UINT8 handle )

SINT8 AUD_remove_downlinkpath ( aud_downlink_source_enum path )

SINT8 AUD_remove_uplinkpath ( aud_uplink_source_enum path )

SINT8 AUD_ringer_get_playposition ( UINT8 handle )

SINT8 AUD_ringer_get_total_playtime | ( | UINT8 | handle,
 |  | UINT8 DWD_HUGE * | data,
 |  | UINT32 | data_size,
 |  | aud_format_enum | format,
 |  | aud_ringer_tone_id_enum | tone_id
 | ) |

SINT8 AUD_ringer_resume | ( | UINT8 | handle,
 |  | UINT8 | SlotID,
 |  | UINT8 | channel
 | ) |

SINT8 AUD_ringer_set_channel_volume | ( | UINT8 | handle,
 |  | UINT8 | channel_volume,
 |  | UINT8 | channel
 | ) |

SINT8 AUD_ringer_set_playposition | ( | UINT8 | handle,
 |  | UINT8 | channel,
 |  | UINT32 | offset
 | ) |

SINT8 AUD_ringer_set_volume | ( | UINT8 | handle,
 |  | aud_ringer_volume_enum | volume
 | ) |

SINT8 AUD_ringer_start | ( | UINT8 | handle,
 |  | aud_ringer_tone_id_enum | tone_id,
 |  | UINT16 | nof_repeats,
 |  | aud_ringer_device_enum | device
 | ) |

SINT8 AUD_ringer_start_user_tone | ( | UINT8 | handle,
 |  | UINT8 huge * | ringer_data,
 |  | UINT32 | size,
 |  | aud_format_enum | format,
 |  | UINT16 | nof_repeats,
 |  | aud_ringer_device_enum | device,
 |  | UINT8 | channel,
 |  | UINT8 | channel_volume
 | ) |

SINT8 AUD_ringer_stop | ( | UINT8 | handle,
 |  | UINT8 | channel
 | ) |

SINT8 AUD_ringer_stop_suspend | ( | UINT8 | handle,
 |  | UINT8 | SlotID,
 |  | UINT8 | channel
 | ) |

SINT8 AUD_ringer_suspend | ( | UINT8 | handle,
 |  | UINT8 | SlotID,
 |  | UINT8 | channel
 | ) |

SINT8 AUD_set_EC_NR | ( | UINT8 | EC_on,
 |  | UINT8 | NR_on
 | ) |

SINT8 AUD_set_master_volume ( aud_volume_enum volume )

SINT8 AUD_set_resource_volume | ( | UINT8 | handle,
 |  | aud_volume_enum | volume
 | ) |

SINT8 AUD_set_volume | ( | UINT8 | handle,
 |  | aud_volume_enum | level
 | ) |

SINT8 AUD_speech_disable ( UINT8 handle )

SINT8 AUD_speech_enable ( UINT8 handle )

SINT8 AUD_speech_mute | ( | UINT8 | handle,
 |  | aud_mute_enum | status,
 |  | aud_direction_enum | direction
 | ) |

SINT8 AUD_speech_set_volume | ( | UINT8 | handle,
 |  | aud_speech_volume_enum | volume
 | ) |

SINT8 AUD_tone_get_play_position ( UINT8 handle )

SINT8 AUD_tone_get_total_playtime | ( | UINT8 | handle,
 |  | aud_tone_id_enum | tone_id,
 |  | void * | tone_data,
 |  | UINT32 | nof_tones,
 |  | aud_tone_type_enum | type
 | ) |

SINT8 AUD_tone_resume | ( | UINT8 | handle,
 |  | UINT8 | slot_id
 | ) |

SINT8 AUD_tone_set_play_position | ( | UINT8 | handle,
 |  | UINT32 | pos
 | ) |

SINT8 AUD_tone_start | ( | UINT8 | handle,
 |  | aud_tone_id_enum | tone_id,
 |  | UINT16 | nof_repeats,
 |  | SINT16 | mix_factor
 | ) |

SINT8 AUD_tone_start_user_tone | ( | UINT8 | handle,
 |  | void * | tone_data,
 |  | aud_tone_type_enum | type,
 |  | UINT32 | nof_tones,
 |  | UINT16 | nof_repeats,
 |  | SINT16 | mix_factor
 | ) |

SINT8 AUD_tone_stop ( UINT8 handle )

SINT8 AUD_tone_suspend | ( | UINT8 | handle,
 |  | UINT8 | slot_id
 | ) |

void AUD_tst_set_dai ( aud_dai_mode_enum mode )

SINT8 AUD_vibrator_start | ( | UINT8 | handle,
 |  | aud_vibrator_mode_enum | mode,
 |  | aud_vibrator_on_enum | on,
 |  | aud_vibrator_off_enum | off
 | ) |

SINT8 AUD_vibrator_stop ( UINT8 handle )

SINT8 AUD_vm_get_play_position ( UINT8 handle )

SINT8 AUD_vm_get_total_playtime | ( | UINT8 | handle,
 |  | aud_media_enum | media_type,
 |  | aud_dsp_format_enum | format,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size,
 |  | UINT32 | offset
 | ) |

SINT8 AUD_vm_resume | ( | UINT8 | handle,
 |  | UINT8 | slot_id
 | ) |

SINT8 AUD_vm_set_play_position | ( | UINT8 | handle,
 |  | UINT32 | pos,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size
 | ) |

SINT8 AUD_vm_start_playback | ( | UINT8 | handle,
 |  | aud_vm_mode_enum | vm_mode,
 |  | aud_media_enum | media_type,
 |  | aud_dsp_format_enum | format,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size,
 |  | UINT16 | nof_repeats,
 |  | UINT32 | offset
 | ) |

SINT8 AUD_vm_start_recording | ( | UINT8 | handle,
 |  | aud_vm_mode_enum | vm_mode,
 |  | aud_media_enum | media_type,
 |  | aud_dsp_format_enum | format,
 |  | UINT8 | rate,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size,
 |  | UINT32 | offset
 | ) |

SINT8 AUD_vm_suspend | ( | UINT8 | handle,
 |  | UINT8 | slot_id
 | ) |

Variable Documentation

UINT16 g_drv_id[]

aud_priority_enum g_priority = aud_priority_normal

Generated on Tue Jan 24 20:33:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Audio.hpp File Reference

Devices/Win32/Audio.hpp File Reference

#include <Compat/Devices/Win32/Audio.hpp>

Include dependency graph for Audio.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:17:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Audio.hpp Source File

Devices/Win32/Audio.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /* The class Audio has been moved to Compat.
00010 This header-file assures backward-compatibility for
00011 applications written with APOXI-versions smaller than 2.7.0*/
00012 #include <Compat/Devices/Win32/Audio.hpp>
00013
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Camera.cpp File Reference

Devices/Win32/Camera.cpp File Reference

#include "PreComp.hpp"
#include "Camera.hpp"
#include "CamWin32.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/Win32/VideoChannel.hpp>
#include <Devices/Display.hpp>

Include dependency graph for Camera.cpp:

Generated on Tue Jan 24 20:24:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Camera.hpp File Reference

Devices/Win32/Camera.hpp File Reference

#include <Devices/AbstractLockableDevice.hpp>
#include <Gui/Size.hpp>
#include <Gui/Rect.hpp>
#include <Devices/CameraInterface.hpp>

Include dependency graph for Camera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Camera

Defines

#define | Apoxi_Devices_Win32_Camera_hpp

Define Documentation

#define Apoxi_Devices_Win32_Camera_hpp

Generated on Tue Jan 24 20:24:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Camera.hpp Source File

Devices/Win32/Camera.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Win32_Camera_hpp)
00010 #define Apoxi_Devices_Win32_Camera_hpp
00011
00014
00015 #include <Devices/AbstractLockableDevice.hpp>
00016 #include <Gui/Size.hpp>
00017 #include <Gui/Rect.hpp>
00018
00019 class CamWin32;
00020
00021 class Camera : public AbstractLockableDevice {
00022     typedef AbstractLockableDevice Base;
00023
00024     #include <Devices/CameraInterface.hpp>
00025
00026     protected:
00027         INT m_last_error;
00028         INT m_zoom_level;
00029         INT m_brightness_level;
00030         INT m_contrast_level;
00031         Rect m_rect;    // the current viewfinder rectangle
00032         ImageSizeType m_capture_image_size;
00033
00034         CamWin32* m_cam_win32;
00035
00037         virtual BOOLEAN& GetLock() { return m_lock[GetIndex()]; }
00038
00039         void SetState(CameraState state) {m_state = (CameraState)state; }
00040
00041     private:
00042         static BOOLEAN m_lock[2];
00043         CameraState m_state;
00044         INT m_display_idx;  // display index where the camera viewfinder should be displayed
00045
00046         AntiFlickerType m_antiflicker_mode;
00047         FilterType m_filter;
00048         TransformationType m_capture_transformation;
00049         ScalingMethodType m_scaling_method;
00050         TwilightType m_twilight_mode;
00051         FlashType m_flash;
00052         WhiteBalanceType m_white_balance;
00053
00054
00055 };
00056
00057 inline Camera::CameraState Camera::GetState() const
00058 {
00059     return m_state;
00060 }
00061
00062
00063 inline INT Camera::GetDisplayIndex() const
00064 {
00065     return m_display_idx;
00066 }
00067
00068
00069 inline INT Camera::GetLastError() const
00070 {
00071     return m_last_error;
00072 }
00073
00075 #endif  // Apoxi_Devices_Win32_Camera_hpp
00076
00077
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/CamWin32.cpp File Reference

Devices/Win32/CamWin32.cpp File Reference

#include "PreComp.hpp"
#include <Devices/Win32/CamWin32.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/AfsRam/RamDataSink.hpp>
#include <AddOns/AfsRam/RamDataSource.hpp>
#include <Auxiliary/DataSource.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Devices/Win32/VideoChannel.hpp>
#include <Devices/Win32/DefaultDisplay.hpp>
#include <Devices/DeviceManager.hpp>
#include <Gui/BitmapDc.hpp>

Include dependency graph for CamWin32.cpp:

Generated on Tue Jan 24 20:33:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/CamWin32.hpp File Reference

Devices/Win32/CamWin32.hpp File Reference

#include <Devices/Win32/MmiSimClient.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for CamWin32.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CamWin32

Defines

#define | CamWin32_hpp

Define Documentation

#define CamWin32_hpp

Generated on Tue Jan 24 20:33:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/CamWin32.hpp Source File

Devices/Win32/CamWin32.hpp

Go to the documentation of this file.
00001 #/* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(CamWin32_hpp)
00010 #define CamWin32_hpp
00011
00012 #include <Devices/Win32/MmiSimClient.hpp>
00013 #include <Config/DisplayConfig.hpp>
00014
00015
00016
00017 class CamWin32 {
00018
00019 public:
00020
00024     enum Property {
00025         BrightnessProperty = 0,
00026         ContrastProperty,
00027         CompressionProperty,
00028         EndOfProperty
00029     };
00030
00033     enum PropertyType {
00034         DefaultValue,
00035         CurrentValue,
00036         AutoValue,
00037         EndOfPropertyType
00038     };
00039
00042     enum ImageSizeType {
00043         QqcifSize,          // 88x72
00044         SqcifSize,          // 128x96
00045         QqvgaSize,          // 160x120
00046         QcifSize,           // 176x144
00047         QsifSize,           // 276x120
00048         QvgaSize,           // 320x240
00049         CifSize,            // 352x288      0,3 mp
00050         VgaSize,            // 640x480
00051         SvgaSize,           // 800x600
00052         XgaSize,            // 1024x768
00053         Size1Mp,            // 1152x864     1,0 mp
00054         Size1_3Mp,          // 1280x960     1,3 mp
00055         UxgaSize,           // 1600x1200    2,0 mp
00056         Size2Mp,            // 1728x1152    2,0 mp
00057         Size3Mp,            // 2048x1536    3,0 mp
00058         EndOfImageSizeType
00059     };
00060
00061     enum ColorFormatType {
00062         DefaultFormat,
00063         RawFormat,
00064         JpegFormat,
00065         PngFormat,
00066         EndOfColorType
00067     };
00068
00069     enum TransformationType {
00070         NoTransformation,
00071         Rotate90,
00072         Rotate180,
00073         Rotate270,
00074         Mirror,
00075         MirrorRotate90,
00076         MirrorRotate180,
00077         MirrorRotate270
00078     };
00079
00080     enum ImageFormatType {
00081         YUV420
00082     };
00083
00084     enum FrameRateType {
00085         Fps5 = 0,
00086         Fps7_5,
00087         Fps10,
00088         Fps12,
00089         Fps15,
00090         Fps24,
00091         Fps25,
00092         Fps30,
00093         EndOfFpsType
00094     };
00095
00096     /********************************************************/
00097     /*     for documentation of methods see Camera.hpp      */
00098     /********************************************************/
00099
00100     static CamWin32* GetInstance();
00101     BOOLEAN Init();
00102
00103     virtual ~CamWin32();
00104
00105     BOOLEAN Enable(INT device_idx=0);
00106     void Disable();
00107
00108
00117     BOOLEAN GetPropertyRange(INT property,INT &min,INT &max,INT &interval,INT &def,INT &cur);
00118
00119
00128     BOOLEAN SetProperty(INT property, INT type, INT value);
00129
00130
00135     BOOLEAN GetCurrentImage(UINT8 HUGE* &buffer, UINT32& length);
00136
00137
00141     BOOLEAN GetCurrentImageBufferSize(UINT32& length);
00142
00143
00151     BOOLEAN SetImageSize(ImageSizeType size,UINT8 &max_zoom_level);
00152
00153
00158     BOOLEAN GetSupportedImageSizes(const ImageSizeType* &array, UINT8& count);
00159
00160
00167     BOOLEAN SetSensorImageSize(ImageSizeType size,UINT8 &max_zoom_level);
00168
00173     BOOLEAN GetSupportedSensorImageSizes(const ImageSizeType* &array, UINT8& count);
00174
00175
00180     BOOLEAN SetColorFormat(ColorFormatType color_format);
00181
00182
00190     BOOLEAN SetTwilightModeEnabled(BOOLEAN twilight_mode);
00191
00192
00197     BOOLEAN SetColorModeEnabled(BOOLEAN color_mode);
00198
00199
00204     BOOLEAN SetTransformation(TransformationType trans);
00205
00206
00211     void SetViewFinder(const Rect& vf_rect,UINT8 display_idx);
00212
00213
00218     BOOLEAN StartViewFinder();
00219
00220
00223     BOOLEAN FreezeViewFinder();
00224
00225
00228     BOOLEAN StopViewFinder();
00229
00230
00234     BOOLEAN SetZoomLevel(UINT8 zoom);
00235
00236
00238     INT GetMaxZoomLevel();
00239
00240
00246     BOOLEAN StartVideoCapture(ImageFormatType format_type);
00247
00248
00252     BOOLEAN StopVideoCapture();
00253
00254
00260     BOOLEAN GetSupportedFrameRates(const FrameRateType* &array, UINT8& count);
00261
00262
00265     BOOLEAN SetFrameRate(FrameRateType frame_rate);
00266
00267
00269     void RegisterGetBufferCB(UINT8 HUGE* (*CB_GetBuffer)());
00270
00271
00273     void RegisterFrameCapturedCB(void (*CB_FrameCaptured)(INT ret, UINT8 HUGE* buf, UINT32 size, UINT32 stamp));
00274
00275     static void ViewFinder_CB(double Time, BYTE *pBuffer, long BufferLen);
00276
00277
00278 private:
00279     static CamWin32 m_cam;
00280     CamWin32();
00281     static MmiSimClient* m_mmisim_client;
00282
00283     //viewfinder rectangle
00284     static Rect m_vf_rect;
00285
00286     static INT m_display_idx;
00287     BOOLEAN m_jpeg_enabled;
00288
00289     UINT8 m_compression_ratio;
00290
00291 };
00292
00293
00294
00295 #endif //CamWin32_hpp
00296
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Charger.cpp File Reference

Devices/Win32/Charger.cpp File Reference

#include "PreComp.hpp"
#include "Charger.hpp"
#include <Devices/ChargerSignalMapTableNode.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>
#include <Devices/DeviceManager.hpp>

Include dependency graph for Charger.cpp:

Generated on Tue Jan 24 20:24:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Charger.hpp File Reference

Devices/Win32/Charger.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/ChargerInterface.hpp>

Include dependency graph for Charger.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Charger

Defines

#define | Apoxi_Devices_Win32_Charger_hpp

Define Documentation

#define Apoxi_Devices_Win32_Charger_hpp

Generated on Tue Jan 24 20:24:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Charger.hpp Source File

Devices/Win32/Charger.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Devices_Win32_Charger_hpp)
00010 #define Apoxi_Devices_Win32_Charger_hpp
00013
00014 #include <Devices/AbstractDevice.hpp>
00015
00016 class Charger: public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     #include <Devices/ChargerInterface.hpp>
00020
00021     protected:
00023         virtual void OnStart();
00024 };
00025
00027 #endif
00028
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/DefaultDisplay.cpp File Reference

Devices/Win32/DefaultDisplay.cpp File Reference

#include "PreComp.hpp"
#include "DefaultDisplay.hpp"
#include "MmiSimServer.hpp"
#include "VideoChannel.hpp"
#include "MmiSimClient.hpp"
#include <Gui/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DisplayMsgTypes.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/OptionalConfig.hpp>

Include dependency graph for DefaultDisplay.cpp:

Generated on Tue Jan 24 20:25:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/DefaultDisplay.hpp File Reference

Devices/Win32/DefaultDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Devices/Display.hpp>

Include dependency graph for DefaultDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultDisplay

Defines

#define | Apoxi_DefaultDisplay_hpp

Define Documentation

#define Apoxi_DefaultDisplay_hpp

Generated on Tue Jan 24 20:25:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/DefaultDisplay.hpp Source File

Devices/Win32/DefaultDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultDisplay_hpp)
00010 #define Apoxi_DefaultDisplay_hpp
00013
00014 class VideoChannel;
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/Os/SystemTimer.hpp>
00017 #include <Devices/Display.hpp>
00018
00023 class DefaultDisplay : public Display {
00024     typedef Display Base;
00025
00026     public:
00029         DefaultDisplay(INT index);
00030
00031         virtual ~DefaultDisplay();
00032
00034         virtual const WCHAR* GetName() const;
00035
00037         virtual void OnStart();
00038
00040         virtual void OnStop();
00041
00043         virtual void SetContrast(INT contrast);
00044
00046         virtual INT GetContrast() const;
00047
00049         virtual void SetBrightness(INT brightness);
00050
00052         virtual INT GetBrightness() const;
00053
00055         virtual void SetBacklightTimeout(UINT32 timeout);
00056
00058         virtual void SetPowerTimeout(UINT32 timeout);
00059
00061         virtual void ReactivateBacklight();
00062
00064         virtual void ReactivatePower();
00065
00067         virtual void SetBacklightMode(BacklightMode mode);
00068
00070         virtual BacklightMode GetBacklightMode() const;
00071
00073         virtual BOOLEAN IsBacklightOn() const;
00074
00076         virtual void SetPowerMode(PowerMode mode);
00077
00079         virtual PowerMode GetPowerMode() const;
00080
00082         virtual BOOLEAN IsPowerOn() const;
00083
00085         virtual void SetCustomFrameBufferRect(const Rect& rect);
00086
00088         virtual void Refresh();
00089
00098         virtual void Refresh(const CustomFrameBuffer* custom_frame_buf);
00099
00103         virtual VideoChannel* GetVideoChannel();
00104
00108         void OnTimer();
00109
00110     private:
00111         enum Status {
00112             DisplayOff,
00113             BacklightOff,
00114             BacklightOn
00115         };
00116
00117         struct {
00118             UINT backlight_mode         : 2;
00119             UINT power_mode             : 2;
00120             UINT status                 : 2;
00121             UINT power_on               : 1;
00122             UINT backlight_on           : 1;
00123             UINT timer_expired          : 1;
00124         } m_bits;
00125         Bitmap m_transfer_buffer;
00126         VideoChannel* m_video_channel;
00127         SystemTimer* m_timer;
00128         UINT32 m_backlight_timeout;
00129         UINT32 m_power_timeout;
00130         Rect m_custom_frame_buf_rect;
00131         const Bitmap* m_custom_bmp;
00132
00133         void SetBacklight(BOOLEAN backlight);
00134         void SetPower(BOOLEAN power);
00135
00136         static void CallbackFn(void* arg);
00137
00138         friend class VideoChannel;
00139 };
00140
00142 #endif  // Apoxi_DefaultDisplay_hpp
00143
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Fota.cpp File Reference

Devices/Win32/Fota.cpp File Reference

#include "PreComp.hpp"
#include "Fota.hpp"

Include dependency graph for Fota.cpp:

Generated on Tue Jan 24 20:25:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Fota.hpp File Reference

Devices/Win32/Fota.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/FotaInterface.hpp>

Include dependency graph for Fota.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Fota

Defines

#define | Apoxi_Devices_Win32_Fota_hpp

Define Documentation

#define Apoxi_Devices_Win32_Fota_hpp

Generated on Tue Jan 24 20:25:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Fota.hpp Source File

Devices/Win32/Fota.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_Win32_Fota_hpp)
00010 #define Apoxi_Devices_Win32_Fota_hpp
00013
00014 #include <Devices/AbstractDevice.hpp>
00015
00016 class Fota : public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     #include <Devices/FotaInterface.hpp>
00020
00021     private:
00022 };
00023
00025 #endif  // Apoxi_Devices_Win32_Fota_hpp
00026
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/GatiManager.cpp File Reference

Devices/Win32/GatiManager.cpp File Reference

#include "PreComp.hpp"
#include "GatiManager.hpp"
#include "GatiServer.hpp"
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for GatiManager.cpp:

Generated on Tue Jan 24 20:33:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/GatiManager.hpp File Reference

Devices/Win32/GatiManager.hpp File Reference

#include <Kernel/SubSystem.hpp>

Include dependency graph for GatiManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GatiManager
struct | GatiManager::DataGramHeader
struct | GatiManager::GatiConnectionEntry
struct | GatiManager::GatiServerEntry

Defines

#define | Apoxi_GatiManager_hpp
#define | GATIMANAGER_CONNECTIONS_MAX 20
#define | GATIMANAGER_DATABASE_MAX 10
#define | GATIMANAGER_PORT 9009
#define | GATIMANAGER_PORT_VAR "APOXI_GATI_PORT"
#define | REGISTER_GATI_SERVER(classname)

Variables

const UINT8 | c_gati_manager_connections_max = GATIMANAGER_CONNECTIONS_MAX
const UINT8 | c_gati_manager_database_max = GATIMANAGER_DATABASE_MAX
const UINT16 | c_gati_manager_port = GATIMANAGER_PORT

Define Documentation

#define Apoxi_GatiManager_hpp

#define GATIMANAGER_CONNECTIONS_MAX 20

#define GATIMANAGER_DATABASE_MAX 10

#define GATIMANAGER_PORT 9009

#define GATIMANAGER_PORT_VAR "APOXI_GATI_PORT"

#define REGISTER_GATI_SERVER ( classname )

Value:

static BOOLEAN __##classname_registered = \
        GatiManager::GetInstance().Register(##classname::CreateInstance, ##classname::ID);

Variable Documentation

const UINT8 c_gati_manager_connections_max = GATIMANAGER_CONNECTIONS_MAX

const UINT8 c_gati_manager_database_max = GATIMANAGER_DATABASE_MAX

const UINT16 c_gati_manager_port = GATIMANAGER_PORT

Generated on Tue Jan 24 20:33:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/GatiManager.hpp Source File

Devices/Win32/GatiManager.hpp

Go to the documentation of this file.
00001 /* ----------------------------------------------------------------------------------------------
00002    Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003    ----------------------------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted withOut prior written authorisation.
00007    ---------------------------------------------------------------------------------------------- */
00008
00009 #if !defined(Apoxi_GatiManager_hpp)
00010 #define Apoxi_GatiManager_hpp
00011
00012 #include <Kernel/SubSystem.hpp>
00013
00014 #if !defined(GATIMANAGER_DATABASE_MAX)
00015     #define GATIMANAGER_DATABASE_MAX 10
00016 #endif
00017
00018 const UINT8 c_gati_manager_database_max = GATIMANAGER_DATABASE_MAX;
00019
00020 #if !defined(GATIMANAGER_CONNECTIONS_MAX)
00021     #define GATIMANAGER_CONNECTIONS_MAX 20
00022 #endif
00023
00024 const UINT8 c_gati_manager_connections_max = GATIMANAGER_CONNECTIONS_MAX;
00025
00026 #if !defined(GATIMANAGER_PORT)
00027     #define GATIMANAGER_PORT 9009
00028 #endif
00029
00030 const UINT16 c_gati_manager_port = GATIMANAGER_PORT;
00031
00032 #if !defined(GATIMANAGER_PORT_VAR)
00033     #define GATIMANAGER_PORT_VAR "APOXI_GATI_PORT"
00034 #endif
00035
00036 #if !defined(REGISTER_GATI_SERVER)
00037     #define REGISTER_GATI_SERVER(classname) static BOOLEAN __##classname_registered = \
00038         GatiManager::GetInstance().Register(##classname::CreateInstance, ##classname::ID);
00039 #endif
00040
00041 class GatiServer;
00042
00051 class GatiManager : SubSystem {
00052
00053     typedef SubSystem Base;
00054
00055     public:
00056
00058         virtual ~GatiManager();
00059
00062         static GatiManager& GetInstance();
00063
00066         BOOLEAN StartUp();
00067
00070         BOOLEAN ShutDown();
00071
00076         BOOLEAN Register(GatiServer* (*createInstanceFunc)(), const UINT32 id);
00077
00083         BOOLEAN Deregister(const UINT32 id);
00084
00091         BOOLEAN SendData(const GatiServer* server, const UINT32 cmd, const UINT32 length, const void* data);
00092
00100         BOOLEAN Broadcast(const INT id, const UINT32 cmd, const UINT32 length, const void* data);
00101
00102         // ------ Methods derived from class SubSystem ------------------------------------------------
00103
00104         virtual const WCHAR* GetName() const { return L"GATI"; }
00105
00106         virtual BootSequenceState InvokeAt() const { return SubSystemManager::c_run_level_1; }
00107
00108         virtual void OnPowerUp() { GatiManager::GetInstance().StartUp(); }
00109
00110         virtual void OnPowerDown() { GatiManager::GetInstance().ShutDown(); }
00111
00112     private:
00113         friend class GatiManagerInternals;
00114
00116         struct GatiServerEntry {
00117             GatiServer* (*m_createInstanceFunc)();
00118             UINT32 m_id;
00119         };
00120
00122         struct GatiConnectionEntry {
00123             GatiServer* m_server;
00124             UINT32 m_socket;
00125         };
00126
00128         struct DataGramHeader {
00130             UINT32 m_id;
00131
00133             UINT32 m_cmd;
00134
00136             UINT32 m_length;
00137         };
00138
00140         GatiManager();
00141
00143         GatiManager(const GatiManager& obj);
00144
00146         void Init();
00147
00150         INT16 FindServer(const UINT32 id);
00151
00154         INT16 FindFreeConnectionEntry();
00155
00159         GatiServer* GetNewServer(const UINT32 id);
00160
00163         void HandleConnectionRequest(UINT32 socket);
00164
00168         BOOLEAN IsSocketOpen(UINT32 socket);
00169
00172         void CloseSocket(UINT32 &socket);
00173
00178         void CloseConnection(const UINT16 connpos);
00179
00186         BOOLEAN ReadHeader(UINT32 socket, DataGramHeader &header);
00187
00194         BOOLEAN WriteHeader(UINT32 socket, DataGramHeader header);
00195
00202         BOOLEAN ReadData(UINT32 socket, void* buffer, UINT32 len);
00203
00210         BOOLEAN WriteData(UINT32 socket, void* buffer, UINT32 len);
00211
00213         void Run();
00214
00215         /************************************************************************/
00216
00218         UINT8 m_servers_tab_size;
00219
00221         GatiServerEntry m_servers_tab[c_gati_manager_database_max];
00222
00224         GatiConnectionEntry m_conns_tab[c_gati_manager_connections_max];
00225
00227         BOOLEAN m_wsa_initialized;
00228
00230         void* m_thread;
00231
00233         UINT32 m_socket;
00234
00236         static GatiManager m_instance;
00237
00239         static BOOLEAN m_is_initialized;
00240 };
00241
00242 #endif  // Apoxi_GatiManager_hpp
00243
00244
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/GatiServer.hpp File Reference

Devices/Win32/GatiServer.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for GatiServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GatiServer

Defines

#define | Apoxi_GatiServer_hpp

Define Documentation

#define Apoxi_GatiServer_hpp

Generated on Tue Jan 24 20:34:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/GatiServer.hpp Source File

Devices/Win32/GatiServer.hpp

Go to the documentation of this file.
00001 /* ----------------------------------------------------------------------------------------------
00002    Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003    ----------------------------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted withOut prior written authorisation.
00007    ---------------------------------------------------------------------------------------------- */
00008
00009 #if !defined(Apoxi_GatiServer_hpp)
00010 #define Apoxi_GatiServer_hpp
00011
00012 #include <Kernel/Types.hpp>
00013
00015 class GatiServer {
00016     public:
00021         virtual INT GetId() const = 0;
00022
00024         virtual void Destroy() = 0;
00025
00028         virtual void OnConnect() = 0;
00029
00032         virtual void OnDisconnect() = 0;
00033
00038         virtual void OnDataReceived(UINT32 cmd, UINT32 length, void* data) = 0;
00039 };
00040
00041 #endif  // Apoxi_GatiServer_hpp
00042
00043
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/GenericAudioDevice.cpp File Reference

Devices/Win32/GenericAudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "GenericAudioDevice.hpp"
#include <Devices/Messages/AudioMsg.hpp>
#include <Kernel/Application.hpp>

Include dependency graph for GenericAudioDevice.cpp:

Generated on Tue Jan 24 20:34:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/GenericAudioDevice.hpp File Reference

Devices/Win32/GenericAudioDevice.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/UserDispatcher.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Devices/AbstractDevice.hpp>

Include dependency graph for GenericAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GenericAudioDevice

Defines

#define | GenericAudioDevice_hpp

Define Documentation

#define GenericAudioDevice_hpp

Generated on Tue Jan 24 20:34:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/GenericAudioDevice.hpp Source File

Devices/Win32/GenericAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009
00010 #if !defined(GenericAudioDevice_hpp)
00011 #define GenericAudioDevice_hpp
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/UserDispatcher.hpp>
00015 #include <Kernel/Message.hpp>
00016 #include <Kernel/Os/Mutex.hpp>
00017 #include <Devices/AbstractDevice.hpp>
00018
00026 class GenericAudioDevice : public AbstractDevice, public UserDispatcher {
00027     public:
00029         enum Priority {
00030             PrioNormal,
00031             PrioHigh
00032         };
00033
00035         enum AudioReturnCode {
00037             AudioRcOk,
00039             AudioRcfunctionalityNotAvailable,
00041             AudioRcResourceInUse,
00043             AudioRcResourceConflict,
00045             AudioRcHandleNotUsed,
00047             AudioRcNoHwSupport,
00049             AudioRcSharingViolation,
00051             AudioRcParameterOutOfRange,
00053             AudioRcFormatNotSupported,
00055             AudioRcAudioDriverDisabled,
00057             AudioRcRingerToneError,
00059             AudioRcMp3Info,
00061             AudioRcRadioInfo,
00063             AudioRcRingerToneFinish,
00065             AudioRcToneFinish,
00066             //
00068             AudioRcDeviceNotInitialized,
00070             AudioRcMimeTypeNotSupported,
00072             AudioRcDeviceAlreadyInitialized,
00074             AudioRcErrorAllocateHW,
00076             AudioRcFileNotFound,
00078             AudioRcFileCloseError,
00080             AudioRcStartParamNotSet,
00082             AudioRcError
00083         };
00084
00085         GenericAudioDevice();
00086         virtual ~GenericAudioDevice();
00087
00089         virtual const WCHAR* GetName() const;
00090
00096         virtual AudioReturnCode Init(Priority prio = PrioNormal);
00097
00101         virtual AudioReturnCode Stop(UINT8 channel = 0);
00102
00104         virtual AudioReturnCode Release();
00105
00115         virtual AudioReturnCode Start(BOOLEAN auto_release = TRUE);
00116
00119         BOOLEAN IsInitialized();
00120
00125         UINT GetId();
00126
00127     protected:
00129         virtual BOOLEAN OnMessage(const Message& msg);
00130
00135         virtual void OnToneStopped(AudioReturnCode return_code, INT nParams, UINT32 param_array[]);
00136
00138         AudioReturnCode Convert2AudioReturnCode(INT error);
00139
00141         INT ConvertPriority2INT(Priority prio);
00142
00144         UINT8 m_hw_handle;
00145
00147         BOOLEAN m_auto_release;
00148
00149     private:
00150         UINT m_id;
00151 };
00152
00153 #endif // GenericAudioDevice_hpp
00154
00155
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/HostAudioDriver.cpp File Reference

Devices/Win32/HostAudioDriver.cpp File Reference

#include "PreComp.hpp"
#include "HostAudioGatiServer.hpp"
#include "HostAudioDriver.hpp"
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for HostAudioDriver.cpp:

Defines

#define | MP3BLOCKSIZE 3000

Functions

SINT8 | AUD_mp3_backward (UINT8 handle, UINT16 frame, UINT16 slot_id)
SINT8 | AUD_mp3_fastforward (UINT8 handle, UINT16 frame, UINT16 slot_id)
SINT8 | Aud_mp3_get_current_frame (UINT8 handle, UINT16 slot_id)
SINT8 | AUD_mp3_get_play_position (UINT8 handle)
SINT8 | AUD_mp3_get_total_playtime (UINT8 handle, aud_media_enum media_type, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size, UINT32 id_offset)
SINT8 | AUD_mp3_resume (UINT8 handle, UINT16 slot_id)
void | Aud_mp3_set_getbuffer_function (UINT8 handle, ptr_GetAudioBufferFunction func, void *user_data)
SINT8 | AUD_mp3_set_play_position (UINT8 handle, UINT32 pos, UINT16 DWD_HUGE *file_handle, UINT32 buffer_size)
SINT8 | AUD_mp3_start (UINT8 handle, aud_media_enum media_type, UINT16 *file_handle, UINT16 buffer_size, UINT32 id_offset, UINT32 start_frame)
SINT8 | AUD_mp3_stop (UINT8 handle)
SINT8 | AUD_mp3_stop_suspend (UINT8 handle, UINT8 SlotID)
SINT8 | AUD_mp3_suspend (UINT8 handle, UINT16 slot_id)
SINT8 | AUD_pcm_intern_getbuffer_function (UINT8 handle, ptr_GetAudioBufferFunction func, void *user_data)
SINT8 | AUD_pcm_intern_start_playback (UINT8 handle, aud_pcm_mode_enum mode, aud_pcm_sample_rate_enum sample_rate, UINT8 bit_rate, aud_media_enum media_type, aud_pcm_format_enum format, UINT16 *file_handle, UINT32 buffer_size, UINT16 nof_repeats, UINT32 offset)
SINT8 | AUD_pcm_intern_start_recording (UINT8 handle, aud_pcm_sample_rate_enum sample_rate, aud_media_enum media_type, aud_pcm_format_enum format, UINT16 *file_handle, UINT32 buffer_size, UINT32 offset)
SINT8 | AUD_pcm_intern_stop_playback (UINT8 handle)
SINT8 | AUD_pcm_intern_stop_recording (UINT8 handle)
SINT8 | AUD_vm_start_playback (UINT8 handle, aud_vm_mode_enum vm_mode, aud_media_enum media_type, aud_dsp_format_enum format, UINT16 *file_handle, UINT16 buffer_size)
SINT8 | AUD_vm_start_recording (UINT8 handle, aud_vm_mode_enum vm_mode, aud_media_enum media_type, aud_dsp_format_enum format, UINT8 rate, UINT16 *file_handle, UINT16 buffer_size)
SINT8 | AUD_vm_stop_playback (UINT8 handle)
SINT8 | AUD_vm_stop_recording (UINT8 handle)
void | Aud_vms_set_getbuffer_function (UINT8 handle, ptr_GetAudioBufferFunction func, void *user_data)
BOOLEAN | GetMp3Head (Mp3Header *mp3head, INT *framesize, CHAR hdr_frame[])
BOOLEAN | InitShmemEvent ()
UINT16 | PlayAmrCallback ()
INT | PlayAmrStreamFile ()
UINT16 | PlayMp3Callback ()
INT | PlayMp3StreamFile ()
UINT16 | PlayPcmCallback ()
INT | PlayPcmStreamFile ()
UINT16 | RecAmrCallback ()
INT | RecAmrStreamFile ()
UINT16 | RecPcmCallback ()
INT | RecPcmStreamFile ()

Variables

ptr_GetAudioBufferFunction g_audio_callback
INT | g_check = 0
UINT8 * | g_data_ptr = NULL
UINT8 | g_handle
HANDLE | g_hevent
HANDLE | g_hmap_file
Mp3Param g_mp3param
INT | g_notifn_size
LPCTSTR | g_pbuf
PcmParam g_pcmparam
INT | g_recorded_size []
INT | g_rem_rec_len = 0
void * | g_user_data
VmParam g_vmparam
UINT8 | MpegLayer [] = { 0, 3, 2, 1 }
INT | MpegV1Freq [] = { 44100, 48000, 32000, 0 }
UINT16 | MpegV1L3Br []
INT | MpegV2Freq [] = { 22050, 24000, 16000, 0 }
UINT16 | MpegV2L3Br []
UINT8 | MpegVersion [] = { 25, 0, 2, 1 }

Define Documentation

#define MP3BLOCKSIZE 3000

Function Documentation

SINT8 AUD_mp3_backward | ( | UINT8 | handle,
 |  | UINT16 | frame,
 |  | UINT16 | slot_id
 | ) |

SINT8 AUD_mp3_fastforward | ( | UINT8 | handle,
 |  | UINT16 | frame,
 |  | UINT16 | slot_id
 | ) |

SINT8 Aud_mp3_get_current_frame | ( | UINT8 | handle,
 |  | UINT16 | slot_id
 | ) |

SINT8 AUD_mp3_get_play_position ( UINT8 handle )

SINT8 AUD_mp3_get_total_playtime | ( | UINT8 | handle,
 |  | aud_media_enum | media_type,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size,
 |  | UINT32 | id_offset
 | ) |

SINT8 AUD_mp3_resume | ( | UINT8 | handle,
 |  | UINT16 | slot_id
 | ) |

void Aud_mp3_set_getbuffer_function | ( | UINT8 | handle,
 |  | ptr_GetAudioBufferFunction | func,
 |  | void * | user_data
 | ) |

SINT8 AUD_mp3_set_play_position | ( | UINT8 | handle,
 |  | UINT32 | pos,
 |  | UINT16 DWD_HUGE * | file_handle,
 |  | UINT32 | buffer_size
 | ) |

SINT8 AUD_mp3_start | ( | UINT8 | handle,
 |  | aud_media_enum | media_type,
 |  | UINT16 * | file_handle,
 |  | UINT16 | buffer_size,
 |  | UINT32 | id_offset,
 |  | UINT32 | start_frame
 | ) |

SINT8 AUD_mp3_stop ( UINT8 handle )

SINT8 AUD_mp3_stop_suspend | ( | UINT8 | handle,
 |  | UINT8 | SlotID
 | ) |

SINT8 AUD_mp3_suspend | ( | UINT8 | handle,
 |  | UINT16 | slot_id
 | ) |

SINT8 AUD_pcm_intern_getbuffer_function | ( | UINT8 | handle,
 |  | ptr_GetAudioBufferFunction | func,
 |  | void * | user_data
 | ) |

SINT8 AUD_pcm_intern_start_playback | ( | UINT8 | handle,
 |  | aud_pcm_mode_enum | mode,
 |  | aud_pcm_sample_rate_enum | sample_rate,
 |  | UINT8 | bit_rate,
 |  | aud_media_enum | media_type,
 |  | aud_pcm_format_enum | format,
 |  | UINT16 * | file_handle,
 |  | UINT32 | buffer_size,
 |  | UINT16 | nof_repeats,
 |  | UINT32 | offset
 | ) |

SINT8 AUD_pcm_intern_start_recording | ( | UINT8 | handle,
 |  | aud_pcm_sample_rate_enum | sample_rate,
 |  | aud_media_enum | media_type,
 |  | aud_pcm_format_enum | format,
 |  | UINT16 * | file_handle,
 |  | UINT32 | buffer_size,
 |  | UINT32 | offset
 | ) |

SINT8 AUD_pcm_intern_stop_playback ( UINT8 handle )

SINT8 AUD_pcm_intern_stop_recording ( UINT8 handle )

SINT8 AUD_vm_start_playback | ( | UINT8 | handle,
 |  | aud_vm_mode_enum | vm_mode,
 |  | aud_media_enum | media_type,
 |  | aud_dsp_format_enum | format,
 |  | UINT16 * | file_handle,
 |  | UINT16 | buffer_size
 | ) |

SINT8 AUD_vm_start_recording | ( | UINT8 | handle,
 |  | aud_vm_mode_enum | vm_mode,
 |  | aud_media_enum | media_type,
 |  | aud_dsp_format_enum | format,
 |  | UINT8 | rate,
 |  | UINT16 * | file_handle,
 |  | UINT16 | buffer_size
 | ) |

SINT8 AUD_vm_stop_playback ( UINT8 handle )

SINT8 AUD_vm_stop_recording ( UINT8 handle )

void Aud_vms_set_getbuffer_function | ( | UINT8 | handle,
 |  | ptr_GetAudioBufferFunction | func,
 |  | void * | user_data
 | ) |

BOOLEAN GetMp3Head | ( | Mp3Header * | mp3head,
 |  | INT * | framesize,
 |  | CHAR | hdr_frame[]
 | ) |

BOOLEAN InitShmemEvent ( )

UINT16 PlayAmrCallback ( )

INT PlayAmrStreamFile ( )

UINT16 PlayMp3Callback ( )

INT PlayMp3StreamFile ( )

UINT16 PlayPcmCallback ( )

INT PlayPcmStreamFile ( )

UINT16 RecAmrCallback ( )

INT RecAmrStreamFile ( )

UINT16 RecPcmCallback ( )

INT RecPcmStreamFile ( )

Variable Documentation

ptr_GetAudioBufferFunction g_audio_callback

INT g_check = 0

UINT8* g_data_ptr = NULL

UINT8 g_handle

HANDLE g_hevent

HANDLE g_hmap_file

Mp3Param g_mp3param

INT g_notifn_size

LPCTSTR g_pbuf

PcmParam g_pcmparam

INT g_recorded_size[]

INT g_rem_rec_len = 0

void* g_user_data

VmParam g_vmparam

UINT8 MpegLayer[] = { 0, 3, 2, 1 }

INT MpegV1Freq[] = { 44100, 48000, 32000, 0 }

UINT16 MpegV1L3Br[]

Initial value:

 { 0, 32, 40, 48, 56, 64, 80, 96, 112, 128, 160, 192,
                            224, 256, 320, 0 }

INT MpegV2Freq[] = { 22050, 24000, 16000, 0 }

UINT16 MpegV2L3Br[]

Initial value:

 { 0, 8, 16, 24, 32, 40, 48, 56, 64, 80, 96, 112, 128,
                            144, 160, 0 }

UINT8 MpegVersion[] = { 25, 0, 2, 1 }

Generated on Tue Jan 24 20:34:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/HostAudioDriver.hpp File Reference

Devices/Win32/HostAudioDriver.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Devices/Win32/aud_drv.h>

Include dependency graph for HostAudioDriver.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | Mp3Header
struct | Mp3Param
struct | PcmParam
struct | VmParam

Defines

#define | AMR_FILEPLAY_FRAMENUM 6
#define | AMR_FILEREC_FRAMENUM 3
#define | Apoxi_HostAudioDriver_hpp
#define | MAXSHMEMSIZE 200004
#define | PCM_FILEPLAY_FRAMENUM 6
#define | PCM_FILEREC_FRAMENUM 3

Enumerations

enum AudCmd {
InvalidEntry, PlayPcm, RecordPcm, StopPlayPcm,
StopRecPcm, PlayAmr, RecordAmr, StopPlayAmr,
StopRecAmr, PlayMp3, StopMp3, PcmPlayCallBack,
PcmRecCallBack, AmrPlayCallBack, AmrRecCallBack, Mp3PlayCallBack,
PcmRetCode, VmRetCode, Mp3RetCode
}
enum | StopRetCode { Playback_Finish, Playback_Stopped, Recording_Finish }

Functions

BOOLEAN | GetMp3Head (Mp3Header *mp3head, INT *framesize, CHAR hdr_frame[])
BOOLEAN | InitShmemEvent ()
UINT16 | PlayAmrCallback ()
INT | PlayAmrStreamFile ()
UINT16 | PlayMp3Callback ()
INT | PlayMp3StreamFile ()
UINT16 | PlayPcmCallback ()
INT | PlayPcmStreamFile ()
UINT16 | RecAmrCallback ()
INT | RecAmrStreamFile ()
UINT16 | RecPcmCallback ()
INT | RecPcmStreamFile ()

Variables

const UINT16 | AMR_SM_WORDS [] = {13,14,16,18,20,21,27,32,5,0,0,0,0,0,0,1}

Define Documentation

#define AMR_FILEPLAY_FRAMENUM 6

#define AMR_FILEREC_FRAMENUM 3

#define Apoxi_HostAudioDriver_hpp

#define MAXSHMEMSIZE 200004

#define PCM_FILEPLAY_FRAMENUM 6

#define PCM_FILEREC_FRAMENUM 3

Enumeration Type Documentation

enum AudCmd

Enumerator:
InvalidEntry
PlayPcm
RecordPcm
StopPlayPcm
StopRecPcm
PlayAmr
RecordAmr
StopPlayAmr
StopRecAmr
PlayMp3
StopMp3
PcmPlayCallBack
PcmRecCallBack
AmrPlayCallBack
AmrRecCallBack
Mp3PlayCallBack
PcmRetCode
VmRetCode
Mp3RetCode

enum StopRetCode

Enumerator:
Playback_Finish
Playback_Stopped
Recording_Finish

Function Documentation

BOOLEAN GetMp3Head | ( | Mp3Header * | mp3head,
 |  | INT * | framesize,
 |  | CHAR | hdr_frame[]
 | ) |

BOOLEAN InitShmemEvent ( )

UINT16 PlayAmrCallback ( )

INT PlayAmrStreamFile ( )

UINT16 PlayMp3Callback ( )

INT PlayMp3StreamFile ( )

UINT16 PlayPcmCallback ( )

INT PlayPcmStreamFile ( )

UINT16 RecAmrCallback ( )

INT RecAmrStreamFile ( )

UINT16 RecPcmCallback ( )

INT RecPcmStreamFile ( )

Variable Documentation

const UINT16 AMR_SM_WORDS[] = {13,14,16,18,20,21,27,32,5,0,0,0,0,0,0,1}

Generated on Tue Jan 24 20:34:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/HostAudioDriver.hpp Source File

Devices/Win32/HostAudioDriver.hpp

Go to the documentation of this file.
00001 /* ----------------------------------------------------------------------------------------------
00002    Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003    ----------------------------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted withOut prior written authorisation.
00007    ---------------------------------------------------------------------------------------------- */
00008
00009 #if !defined(Apoxi_HostAudioDriver_hpp)
00010 #define Apoxi_HostAudioDriver_hpp
00011
00012 #include <Kernel/Os/Os.hpp>
00013 #include <Devices/Win32/aud_drv.h>
00014
00015 // Number of AMR encoded bytes based on Frame Type along with Frame Header
00016 const UINT16 AMR_SM_WORDS[] = {13,14,16,18,20,21,27,32,5,0,0,0,0,0,0,1};
00017
00018 // Maximum size of the Shared Memory between APOXI & Audio Gati Client
00019 // Support 312 Stereo or 625 Mono Pcm Samples of 16 bits width
00020 #define MAXSHMEMSIZE 200004
00021
00022 // Number of Frames used to signal Notification event on client side
00023 #define PCM_FILEPLAY_FRAMENUM   6
00024 #define AMR_FILEPLAY_FRAMENUM   6
00025 #define PCM_FILEREC_FRAMENUM    3
00026 #define AMR_FILEREC_FRAMENUM    3
00027
00028 // Structures for passing driver API parameters to Audio Gati Client
00029 struct PcmParam {
00030     UINT8 handle;
00031     aud_pcm_mode_enum mode;
00032     aud_pcm_sample_rate_enum sample_rate;
00033     UINT8 bit_rate;
00034     aud_media_enum media;
00035     aud_pcm_format_enum format;
00036     UINT16* file_handle;
00037     UINT32 buffer_size;
00038 };
00039
00040 struct VmParam {
00041     UINT8 handle;
00042     aud_vm_mode_enum vm_mode;
00043     aud_media_enum media;
00044     aud_dsp_format_enum format;
00045     UINT8 rate;
00046     UINT16* file_handle;
00047     UINT16 buffer_size;
00048 };
00049
00050 struct Mp3Header {
00051     UINT8   mpg_ver;
00052     UINT8   mpg_layer;
00053     UINT8   mpg_pad_bit;
00054     UINT16  mpg_br;
00055     INT     mpg_freq;
00056 };
00057
00058 struct Mp3Param {
00059         UINT8 handle;
00060         aud_media_enum media;
00061         UINT16* file_handle;
00062         UINT16 buffer_size;
00063         UINT32 id_offset;
00064         UINT32 start_frame;
00065         Mp3Header m_mpghead;
00066 };
00067
00068 // Commands passed between Audio Gati Server/Client
00069 typedef enum
00070 {
00071         InvalidEntry,
00072         PlayPcm,
00073         RecordPcm,
00074         StopPlayPcm,
00075         StopRecPcm,
00076
00077         PlayAmr,
00078         RecordAmr,
00079         StopPlayAmr,
00080         StopRecAmr,
00081
00082         PlayMp3,
00083         StopMp3,
00084
00085         PcmPlayCallBack,
00086         PcmRecCallBack,
00087
00088         AmrPlayCallBack,
00089         AmrRecCallBack,
00090         Mp3PlayCallBack,
00091
00092         PcmRetCode,
00093         VmRetCode,
00094         Mp3RetCode
00095 } AudCmd ;
00096
00097 enum StopRetCode {
00098     Playback_Finish,
00099     Playback_Stopped,
00100     Recording_Finish
00101 };
00102
00103 // Methods to simulate driver functionality
00104 BOOLEAN InitShmemEvent();
00105
00106 UINT16  PlayPcmCallback();
00107 UINT16  RecPcmCallback();
00108 UINT16  PlayAmrCallback();
00109 UINT16  RecAmrCallback();
00110
00111 BOOLEAN GetMp3Head(Mp3Header* mp3head, INT* framesize, CHAR hdr_frame[] );
00112 UINT16  PlayMp3Callback();
00113
00114 INT PlayPcmStreamFile();
00115 INT RecPcmStreamFile();
00116 INT PlayAmrStreamFile();
00117 INT RecAmrStreamFile();
00118 INT PlayMp3StreamFile();
00119
00120
00121 #endif  // Apoxi_HostAudioDriver_hpp
00122
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/HostAudioGatiServer.cpp File Reference

Devices/Win32/HostAudioGatiServer.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/Win32/Win32.hpp>
#include <Kernel/System.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>
#include <Devices/AudioPriorityManager.hpp>
#include <Devices/Win32/aud_drv.h>
#include <Devices/Win32/GatiManager.hpp>
#include "HostAudioDriver.hpp"
#include "HostAudioGatiServer.hpp"

Include dependency graph for HostAudioGatiServer.cpp:

Functions

REGISTER_GATI_SERVER (AudioGatiServer) AudioGatiServer

Variables

UINT16 | g_drv_id [NUM_PLAYERS] = {0, 0, 0}
UINT8 | g_handle = 0
HANDLE | g_hmap_file
LPCTSTR | g_pbuf
INT | g_recorded_size [NUM_PLAYERS-1] = {0, 0}

Function Documentation

REGISTER_GATI_SERVER ( AudioGatiServer )

Variable Documentation

UINT16 g_drv_id[NUM_PLAYERS] = {0, 0, 0}

UINT8 g_handle = 0

HANDLE g_hmap_file

LPCTSTR g_pbuf

INT g_recorded_size[NUM_PLAYERS-1] = {0, 0}

Generated on Tue Jan 24 20:34:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/HostAudioGatiServer.hpp File Reference

Devices/Win32/HostAudioGatiServer.hpp File Reference

#include <Devices/Win32/GatiServer.hpp>

Include dependency graph for HostAudioGatiServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AudioGatiServer

Defines

#define | Apoxi_HostAudioGatiServer_hpp

Define Documentation

#define Apoxi_HostAudioGatiServer_hpp

Generated on Tue Jan 24 20:34:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/HostAudioGatiServer.hpp Source File

Devices/Win32/HostAudioGatiServer.hpp

Go to the documentation of this file.
00001 /* ----------------------------------------------------------------------------------------------
00002    Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003    ----------------------------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted withOut prior written authorisation.
00007    ---------------------------------------------------------------------------------------------- */
00008
00009 #if !defined(Apoxi_HostAudioGatiServer_hpp)
00010 #define Apoxi_HostAudioGatiServer_hpp
00011
00012 #include <Devices/Win32/GatiServer.hpp>
00013
00015 class AudioGatiServer : public GatiServer {
00016     public:
00017         enum {
00018             ID = 3
00019         };
00020
00023         static AudioGatiServer& GetInstance();
00024
00026         virtual ~AudioGatiServer();
00027
00029         virtual INT GetId() const;
00030
00032         virtual void Destroy();
00033
00035         virtual void OnConnect();
00036
00038         virtual void OnDisconnect();
00039
00042         virtual void OnDataReceived(UINT32 cmd, UINT32 length, void* data);
00043
00045         static GatiServer* CreateInstance();
00046
00048         void SendData(UINT32 cmd, UINT32 length, void* data);
00049
00050     private:
00051         AudioGatiServer();
00052         void SendSdlSignal(INT8 ret_code, UINT16 drv_id, UINT32 param1);
00053
00054
00055         INT m_clients_count;
00056         INT m_request_id;
00057
00058 };
00059
00060 #endif  // Apoxi_HostAudioGatiServer_hpp
00061
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Keyboard.cpp File Reference

Devices/Win32/Keyboard.cpp File Reference

#include "PreComp.hpp"
#include "Keyboard.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Gui/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/SharedMethods/KeyboardTimer.cpp>

Include dependency graph for Keyboard.cpp:

Generated on Tue Jan 24 20:25:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Keyboard.hpp File Reference

Devices/Win32/Keyboard.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/KeyboardInterface.hpp>

Include dependency graph for Keyboard.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Keyboard
Keyboard. More...
struct | Keyboard::BitStruct

Defines

#define | Apoxi_Devices_Win32_Keyboard_hpp

Define Documentation

#define Apoxi_Devices_Win32_Keyboard_hpp

Generated on Tue Jan 24 20:25:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Keyboard.hpp Source File

Devices/Win32/Keyboard.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_Win32_Keyboard_hpp)
00010 #define Apoxi_Devices_Win32_Keyboard_hpp
00013
00014 #include <Devices/AbstractDevice.hpp>
00015
00016 class Keyboard : public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     #include <Devices/KeyboardInterface.hpp>
00020
00021     private:
00022         struct BitStruct {
00023             UINT locked                 : 1;
00024             UINT multi_key_mode         : 1;
00025             UINT illumination_status    : 1;
00026             UINT illumination_mode      : 2;
00027         };
00028
00029         static BitStruct m_bits;
00030         static UINT32 m_illumination_timeout;
00031         static SystemTimer m_illumination_timer;
00032         static KeyCode m_key_state;
00033
00034         static void SetIllumination(BOOLEAN illumination);
00035         static void OnIlluminationTimer(void *arg);
00036 };
00037
00038 inline BOOLEAN Keyboard::IsLocked()
00039 {
00040     return m_bits.locked;
00041 }
00042
00043 inline void Keyboard::SetMultiKeyMode(BOOLEAN /* enable */)
00044 {
00045 }
00046
00047 inline BOOLEAN Keyboard::IsMultiKeyMode()
00048 {
00049     return FALSE;
00050 }
00051
00052 inline void Keyboard::SetIlluminationTimeout(UINT32 timeout)
00053 {
00054     m_illumination_timeout = timeout;
00055 }
00056
00057 inline Keyboard::IlluminationMode Keyboard::GetIlluminationMode()
00058 {
00059     return static_cast<IlluminationMode>(m_bits.illumination_mode);
00060 }
00061
00062 inline BOOLEAN Keyboard::IsIlluminationOn()
00063 {
00064     return m_bits.illumination_status;
00065 }
00066
00068 #endif  // Apoxi_Devices_Win32_Keyboard_hpp
00069
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/KeyToneAudioDevice.cpp File Reference

Devices/Win32/KeyToneAudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "KeyToneAudioDevice.hpp"

Include dependency graph for KeyToneAudioDevice.cpp:

Generated on Tue Jan 24 20:34:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/KeyToneAudioDevice.hpp File Reference

Devices/Win32/KeyToneAudioDevice.hpp File Reference

#include "GenericAudioDevice.hpp"

Include dependency graph for KeyToneAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | KeyToneAudioDevice
struct | KeyToneAudioDevice::StartParam
Start parameter. More...

Defines

#define | KeyToneAudioDevice_hpp

Define Documentation

#define KeyToneAudioDevice_hpp

Generated on Tue Jan 24 20:34:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/KeyToneAudioDevice.hpp Source File

Devices/Win32/KeyToneAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009 #if !defined(KeyToneAudioDevice_hpp)
00010 #define KeyToneAudioDevice_hpp
00011
00012 #include "GenericAudioDevice.hpp"
00013
00021 class KeyToneAudioDevice : public GenericAudioDevice {
00022     public:
00023
00025         enum KeyTone {
00027             KeyTone1,
00029             KeyTone2,
00031             KeyTone3,
00033             KeyTone4,
00035             KeyTone5
00036         };
00037
00039         struct StartParam {
00041             StartParam() {
00042                 key_tone = KeyTone1;
00043                 mix_factor = 0x4000;
00044             };
00046             KeyTone key_tone;
00051             UINT16 mix_factor;
00052         };
00053
00054         KeyToneAudioDevice();
00055         virtual ~KeyToneAudioDevice();
00056
00058         virtual const WCHAR* GetName() const;
00059
00060
00062         virtual AudioReturnCode Init(Priority prio);
00063
00066         void SetStartParam(const StartParam* p_start_param);
00067
00073         virtual AudioReturnCode Start(BOOLEAN auto_release = TRUE);
00074
00077         virtual AudioReturnCode Stop(UINT8 channel = 0);
00078
00079     protected:
00082         INT ConvertKeyTone2INT(KeyTone key_tone);
00083
00084     private:
00085         StartParam m_start_param;
00086         BOOLEAN m_start_param_set;
00087 };
00088
00089 #endif // KeyToneAudioDevice_hpp
00090
00091
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Led.cpp File Reference

Devices/Win32/Led.cpp File Reference

#include "PreComp.hpp"
#include "Led.hpp"
#include "MmiSimClient.hpp"
#include <Auxiliary/SimpleMap.hpp>
#include <stack/stack.h>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>
#include <Devices/LedSignalMapTableNode.hpp>
#include <Devices/DeviceManager.hpp>

Include dependency graph for Led.cpp:

Generated on Tue Jan 24 20:25:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Led.hpp File Reference

Devices/Win32/Led.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/LedInterface.hpp>

Include dependency graph for Led.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Led
Back light device. More...

Defines

#define | Apoxi_Devices_Win32_Led_hpp

Define Documentation

#define Apoxi_Devices_Win32_Led_hpp

Generated on Tue Jan 24 20:25:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Led.hpp Source File

Devices/Win32/Led.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_Win32_Led_hpp)
00010 #define Apoxi_Devices_Win32_Led_hpp
00013
00014 #include <Devices/AbstractDevice.hpp>
00015
00016 class Led : public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     public:
00020         #if !defined(APOXI_LED_NEW_INTERFACE)
00021             enum Event {
00022                 Call,
00023                 ReceivingCall,
00024                 CallUnanswered,
00025                 Mail,
00026                 Service,
00027                 NoService,
00028                 LimitedService,
00029                 PowerOn,
00030                 PowerOff,
00031                 ReceivedCallConnected,
00032                 SmsReceiving,
00033                 SmsSending,
00034                 AlarmOngoing,
00035                 AlarmStopped,
00036                 BatteryLow,
00037                 ChargerDisconnected,
00038                 ChargerConnected,
00039                 ChargeComplete,
00040             };
00041
00042             enum Color {
00043                 Blue,
00044                 Red,
00045                 Green,
00046                 Magenta,
00047                 Cyan,
00048                 Yellow,
00049                 White,
00050                 NoOfColors,
00051                 InvalidColor,
00052             };
00053
00054             enum Action {
00055                 On,
00056                 Off,
00057                 Flash,
00058                 ColorStream,
00059             };
00060
00061             enum Intensity {
00062                 NoCurrent,
00063                 Minimum,
00064                 Low,
00065                 LessThanNormal,
00066                 Normal,
00067                 MoreThanNormal,
00068                 High,
00069                 Maximum,
00070             };
00071         #endif
00072
00073     #include <Devices/LedInterface.hpp>
00074
00075     protected:
00076         #if defined(APOXI_LED_NEW_INTERFACE)
00077             virtual void OnStart();
00078         #endif
00079
00080     private:
00081         static const INT c_max_colorstream_length;
00082 };
00083
00085 #endif  // Apoxi_Devices_Win32_Led_hpp
00086
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MiscAudioDevice.cpp File Reference

Devices/Win32/MiscAudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "MiscAudioDevice.hpp"

Include dependency graph for MiscAudioDevice.cpp:

Functions

MiscAudioDevice::AvailableHW GetAvailableHW ()
MiscAudioDevice::PowerStatus GetPowerStatus ()

Function Documentation

MiscAudioDevice::AvailableHW GetAvailableHW ( )

MiscAudioDevice::PowerStatus GetPowerStatus ( )

Generated on Tue Jan 24 20:34:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MiscAudioDevice.hpp File Reference

Devices/Win32/MiscAudioDevice.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for MiscAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MiscAudioDevice
struct | MiscAudioDevice::AvailableHW
Available HW. If a member variable is TRUE the hardware is available. More...
struct | MiscAudioDevice::PowerStatus
Power status. If a member variable is TRUE the device is powered on. More...

Defines

#define | MiscAudioDevice_hpp

Define Documentation

#define MiscAudioDevice_hpp

Generated on Tue Jan 24 20:34:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MiscAudioDevice.hpp Source File

Devices/Win32/MiscAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009
00010 #if !defined(MiscAudioDevice_hpp)
00011 #define MiscAudioDevice_hpp
00012
00013 #include <Devices/AbstractDevice.hpp>
00014 #include <Auxiliary/Lib.hpp>
00015
00022 class MiscAudioDevice : public AbstractDevice {
00023     public:
00025         virtual const WCHAR* GetName() const;
00026
00028         enum Accessory {
00030             AccessoryNormal,
00032             AccessoryHeadset,
00034             AccessoryStereoPhones,
00036             AccessoryBtHeadset,
00038             AccessoryCarKit
00039         };
00040
00042         struct PowerStatus {
00044             BOOLEAN speech          : 1;
00046             BOOLEAN amplifier       : 1;
00048             BOOLEAN ringer          : 1;
00051             BOOLEAN vibrator        : 1;
00053             BOOLEAN radio           : 1;
00055             BOOLEAN mp3_player      : 1;
00057             BOOLEAN vm_play         : 1;
00059             BOOLEAN vm_rec          : 1;
00060         };
00061
00063         struct AvailableHW {
00065             BOOLEAN speech          : 1;
00067             BOOLEAN amplifier       : 1;
00069             BOOLEAN ringer          : 1;
00071             BOOLEAN tone_generator  : 1;
00073             BOOLEAN radio           : 1;
00075             BOOLEAN mp3_player      : 1;
00077             BOOLEAN vm_play         : 1;
00079             BOOLEAN vm_rec          : 1;
00080         };
00081
00086         static PowerStatus GetPowerStatus();
00087
00090         static AvailableHW GetAvailableHW();
00091
00094         static void SetVmic(UINT8 status);
00095
00100         static void SetAccessory(Accessory accessory);
00101
00106         static void RestartHf();
00107
00110         static void CheckTime();
00111 };
00112
00113 #endif // MiscAudioDevice_hpp
00114
00115
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MmiSimClient.cpp File Reference

Devices/Win32/MmiSimClient.cpp File Reference

#include "PreComp.hpp"
#include "MmiSimClient.hpp"
#include "MmiSimProtocol.hpp"
#include "Keyboard.hpp"
#include <Devices/Display.hpp>
#include <Gui/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DeviceManager.hpp>
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for MmiSimClient.cpp:

Generated on Tue Jan 24 20:34:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MmiSimClient.hpp File Reference

Devices/Win32/MmiSimClient.hpp File Reference

#include <Gui/Bitmap.hpp>
#include <Gui/Rect.hpp>
#include <Kernel/Os/Semaphore.hpp>

Include dependency graph for MmiSimClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmiSimClient

Defines

#define | Apoxi_MmiSimClient_hpp

Define Documentation

#define Apoxi_MmiSimClient_hpp

Generated on Tue Jan 24 20:34:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MmiSimClient.hpp Source File

Devices/Win32/MmiSimClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_MmiSimClient_hpp)
00011 #define Apoxi_MmiSimClient_hpp
00012
00013 #include <Gui/Bitmap.hpp>
00014 #include <Gui/Rect.hpp>
00015 #include <Kernel/Os/Semaphore.hpp>
00016
00018 class MmiSimClient {
00019     public:
00020         virtual ~MmiSimClient();
00021
00022         static MmiSimClient* GetClient();
00023         void Connect();
00024         void Disconnect();
00025         void UpdateDisplay(const Bitmap& bitmap, const Rect& blit_rect, int display_idx);
00026         void SetBacklightState(BOOLEAN state, UINT8 display_idx = 0);
00027         void SetVibrationState(BOOLEAN state);
00028         void SetLedState(BOOLEAN state, UINT32 color);
00029
00030     private:
00031         MmiSimClient();
00032
00033         static unsigned long __stdcall Receive(void* p);
00034         static BOOLEAN FillReadBuffer(UINT32 sock, char* dst, int len);
00035         static MmiSimClient m_client;
00036
00037         UINT32 m_server_socket;
00038         bool m_sockets_initialized;
00039         Semaphore m_sem;
00040 };
00041
00042 #endif  // Apoxi_MmiSimClient_hpp
00043
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MmiSimProtocol.hpp File Reference

Devices/Win32/MmiSimProtocol.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | MmiSimMsg
MmiSimMsg consist of a unique id and four MmiSimMsgArgs. More...
union | MmiSimMsgArg
MmiSimMsgArg contains a generic MmiSimMsg argument. More...

Defines

#define | _MmiSimProtocol_h
#define | MMISIM_ENV_VAR_DISABLE "MMISIM_DISABLE"
#define | MMISIM_ENV_VAR_HOST "MMISIM_HOST"
#define | MMISIM_ENV_VAR_PORT "MMISIM_PORT"
#define | MMISIM_LOCALHOST "localhost"
#define | MMISIM_MASK_ALT 0x00000002
#define | MMISIM_MASK_CTRL 0x00000004
#define | MMISIM_MASK_NONE 0x00000000
#define | MMISIM_MASK_SHIFT 0x00000001
#define | MMISIM_PORT 5555
#define | MMISIM_PORT_RANGE 10

Enumerations

enum MmiSimMsgId {
MmiSimDisplayUpdateHeaderId = 1, MmiSimDisplayUpdateDataId = 2, MmiSimBacklightStateId = 10, MmiSimVibrationStateId = 11,
MmiSimLedStateId = 12, MmiSimKeyDownId = 200, MmiSimKeyUpId = 201, MmiSimCharId = 220,
MmiSimPenDownId = 250, MmiSimPenUpId = 251, MmiSimPenMoveId = 252
}

Define Documentation

#define _MmiSimProtocol_h

#define MMISIM_ENV_VAR_DISABLE "MMISIM_DISABLE"

#define MMISIM_ENV_VAR_HOST "MMISIM_HOST"

#define MMISIM_ENV_VAR_PORT "MMISIM_PORT"

#define MMISIM_LOCALHOST "localhost"

#define MMISIM_MASK_ALT 0x00000002

#define MMISIM_MASK_CTRL 0x00000004

#define MMISIM_MASK_NONE 0x00000000

#define MMISIM_MASK_SHIFT 0x00000001

#define MMISIM_PORT 5555

#define MMISIM_PORT_RANGE 10

Enumeration Type Documentation

enum MmiSimMsgId

MmiSimMsgId defines the type of a generic MmiSim message.

Enumerator:
MmiSimDisplayUpdateHeaderId
MmiSimDisplayUpdateDataId
MmiSimBacklightStateId
MmiSimVibrationStateId
MmiSimLedStateId
MmiSimKeyDownId
MmiSimKeyUpId
MmiSimCharId
MmiSimPenDownId
MmiSimPenUpId
MmiSimPenMoveId

Generated on Tue Jan 24 20:34:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MmiSimProtocol.hpp Source File

Devices/Win32/MmiSimProtocol.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(_MmiSimProtocol_h)
00010 #define _MmiSimProtocol_h
00011
00012 /*----------------------------------------------------------------
00013                             Constants
00014   ----------------------------------------------------------------*/
00015
00016 #define MMISIM_MASK_NONE        0x00000000
00017 #define MMISIM_MASK_SHIFT       0x00000001
00018 #define MMISIM_MASK_ALT         0x00000002
00019 #define MMISIM_MASK_CTRL        0x00000004
00020
00021 #define MMISIM_PORT             5555
00022 #define MMISIM_PORT_RANGE       10
00023 #define MMISIM_LOCALHOST        "localhost"
00024
00025 #define MMISIM_ENV_VAR_HOST     "MMISIM_HOST"
00026 #define MMISIM_ENV_VAR_PORT     "MMISIM_PORT"
00027 #define MMISIM_ENV_VAR_DISABLE  "MMISIM_DISABLE"
00028
00030 enum MmiSimMsgId {
00031     MmiSimDisplayUpdateHeaderId = 1,
00032     MmiSimDisplayUpdateDataId = 2,
00033     MmiSimBacklightStateId = 10,
00034     MmiSimVibrationStateId = 11,
00035     MmiSimLedStateId = 12,
00036     MmiSimKeyDownId = 200,
00037     MmiSimKeyUpId = 201,
00038     MmiSimCharId = 220,
00039     MmiSimPenDownId = 250,
00040     MmiSimPenUpId = 251,
00041     MmiSimPenMoveId = 252
00042 };
00043
00044 /*  Each data transfer between MmiSim and simulation environment is a sequence of MmiSimMsgs and
00045     an optional data buffer, whose length is typically defined by one of the MmiSimMsg's MmiSimMsgArgs.<br />
00046     <br />
00047     Example 1: A DisplayUpdate Notification looks like this:
00048     <pre>
00049     |------------------------------------------------------------------------------------------------------------------------------|
00050     | MmiSimMsg                                                                                                                    |
00051     |------------------------------------------------------------------------------------------------------------------------------|
00052     | id                    | args[0].t_xydim[0] | args[0].t_xydim[1] | args[1].t_xydim[0] | args[1].t_xydim[1] | args[2].t_uint32 |
00053     |------------------------------------------------------------------------------------------------------------------------------|
00054     | DisplayUpdateHeaderId | r_blit_left        | r_blit_top         | r_blit_right       | r_blit_bottom      | data_count       |
00055     |------------------------------------------------------------------------------------------------------------------------------|
00056
00057     Followed by [data_count] times (in case once we want to support a list of several independent blit rectangles):
00058     |-----------------------------------------------------------| |------| .....
00059     | MmiSimMsg                                                 | | Data | .....
00060     |-----------------------------------------------------------| |------| .....
00061     | id                  | args[0].t_uint32 | args[1].t_uint32 | | .... | .....
00062     |-----------------------------------------------------------| |------| .....
00063     | DisplayUpdateDataId | data_len         | data_offset      | | .... | .....
00064     |-----------------------------------------------------------| |------| .....
00065     </pre>
00066     <br />
00067     Example 2: A BackLight Notification looks like this:
00068
00069     <pre>
00070     |--------------------------------|
00071     | MmiSimMsg                      |
00072     |--------------------------------|
00073     | id          | args[0].t_uint32 |
00074     |--------------------------------|
00075     | BackLightId | backlight_state  |
00076     |--------------------------------|
00077     </pre>
00078     <br>
00079     This the format for switching the vibration device on and off:
00080
00081     <pre>
00082     |-------------------------------------------|
00083     | MmiSimMsg                                 |
00084     |-------------------------------------------|
00085     | id                     | args[0].t_uint32 |
00086     |-------------------------------------------|
00087     | MmiSimVibrationStateId |vibration_state   |
00088     |-------------------------------------------|
00089     </pre>
00090     <br>
00091     To handle the LED this message format should be used:
00092
00093     <pre>
00094     |------------------------------------------------------------|
00095     | MmiSimMsg                                                  |
00096     |------------------------------------------------------------|
00097     | id               | args[0].t_uint32     | args[1].t_uint32 |
00098     |------------------------------------------------------------|
00099     | MmiSimLedStateId | led_state (on / off) | led color (rgb)  |
00100     |------------------------------------------------------------|
00101     </pre>
00102 */
00103
00105 typedef union {
00106     char t_char[4];
00107     unsigned char t_uchar[4];
00108     unsigned char t_byte[4];
00109     char t_int8[4];
00110     unsigned short t_wchar[2];
00111     short t_int16[2];
00112     unsigned short t_uint[2];
00113     short t_xydim[2];
00114     int t_int32;
00115     unsigned int t_uint32;
00116     int t_int;
00117     void* t_void;
00118 } MmiSimMsgArg;
00119
00121 // todo: id should be of type MmiSimMsgId. This change must be done synchronously for MmiSim and Apoxi, in order not to break compatibility.
00122 typedef struct {
00123     short id;
00124     MmiSimMsgArg args[4];
00125 } MmiSimMsg;
00126
00127 #endif  // _MmiSimProtocol_h
00128
00129
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MmiSimServer.cpp File Reference

Devices/Win32/MmiSimServer.cpp File Reference

#include "PreComp.hpp"
#include "MmiSimServer.hpp"
#include "GatiManager.hpp"
#include <Devices/Display.hpp>
#include "Keyboard.hpp"
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Config/DisplayConfig.hpp>
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for MmiSimServer.cpp:

Functions

REGISTER_GATI_SERVER (MmiSimServer) MmiSimServer

Function Documentation

REGISTER_GATI_SERVER ( MmiSimServer )

Generated on Tue Jan 24 20:34:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MmiSimServer.hpp File Reference

Devices/Win32/MmiSimServer.hpp File Reference

#include <Devices/Win32/GatiServer.hpp>

Include dependency graph for MmiSimServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MmiSimServer

Defines

#define | Apoxi_MmiSimServer_hpp

Define Documentation

#define Apoxi_MmiSimServer_hpp

Generated on Tue Jan 24 20:34:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/MmiSimServer.hpp Source File

Devices/Win32/MmiSimServer.hpp

Go to the documentation of this file.
00001 /* ----------------------------------------------------------------------------------------------
00002    Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003    ----------------------------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted withOut prior written authorisation.
00007    ---------------------------------------------------------------------------------------------- */
00008
00009 #if !defined(Apoxi_MmiSimServer_hpp)
00010 #define Apoxi_MmiSimServer_hpp
00011
00012 class Rect;
00013 #include <Devices/Win32/GatiServer.hpp>
00014
00016 class MmiSimServer {
00017
00018     // MmiSimServer::ClientHandler forward declaration
00019     class ClientHandler;
00020
00021     // The ClientHandler class has to be a friend class in order to access private components of the MmiSimServer
00022     friend class ClientHandler;
00023
00024     public:
00025
00027         enum {
00028             ID = 0
00029         };
00030
00032         enum MmiSimCmdId {
00033             MmiSimDisplayUpdateHeaderId = 1,
00034             MmiSimDisplayUpdateDataId = 2,
00035             MmiSimBacklightStateId = 10,
00036             MmiSimVibrationStateId = 11,
00037             MmiSimLedStateId = 12,
00038             MmiSimPowerStateId = 13,
00039             MmiSimClipStateId = 14,
00040             MmiSimKeyDownId = 200,
00041             MmiSimKeyUpId = 201,
00042             MmiSimCharId = 220,
00043             MmiSimPenDownId = 250,
00044             MmiSimPenUpId = 251,
00045             MmiSimPenMoveId = 252
00046         };
00047
00050         static MmiSimServer& GetInstance();
00051
00055         static GatiServer* CreateInstance();
00056
00061         void UpdateDisplay(const Rect& blit_rect, INT display_idx);
00062
00067         void SetBacklightState(BOOLEAN state, INT backlight_idx = 0);
00068
00072         void SetVibrationState(BOOLEAN state);
00073
00079         void SetLedState(BOOLEAN state, UINT32 color, INT led_idx = 0);
00080
00085         void SetPowerState(BOOLEAN state, INT display_idx);
00086
00090         void SetClipState(BOOLEAN state);
00091
00092 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00093
00095         virtual ~MmiSimServer();
00096
00097     private:
00098
00100         class ClientHandler : public GatiServer {
00101
00102             public:
00103
00104                 virtual INT GetId() const;
00105
00106                 virtual void Destroy();
00107
00108                 virtual void OnConnect();
00109
00110                 virtual void OnDisconnect();
00111
00112                 virtual void OnDataReceived(UINT32 cmd, UINT32 length, void* data);
00113         };
00114
00116         MmiSimServer();
00117
00119         MmiSimServer(const MmiSimServer& obj);
00120
00122         void Init();
00123
00125         void OnDataReceived(UINT32 cmd, UINT32 length, void* data);
00126
00129         void PerformDisplayUpdate(const Rect& blit_rect, INT display_idx, GatiServer* sender);
00130
00132         static UINT8** m_display_buffers;
00133
00135         static UINT8 m_num_clients;
00136
00138         static MmiSimServer m_instance;
00139
00141         static BOOLEAN m_is_initialized;
00142
00143 #endif // DOXYGEN_SHOULD_SKIP_THIS
00144
00145 };
00146
00147 #endif  // Apoxi_MmiSimServer_hpp
00148
00149
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Mp3AudioDevice.cpp File Reference

Devices/Win32/Mp3AudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "Mp3AudioDevice.hpp"

Include dependency graph for Mp3AudioDevice.cpp:

Generated on Tue Jan 24 20:34:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Mp3AudioDevice.hpp File Reference

Devices/Win32/Mp3AudioDevice.hpp File Reference

#include "GenericAudioDevice.hpp"

Include dependency graph for Mp3AudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Mp3AudioDevice
struct | Mp3AudioDevice::StartParam
Start parameter. More...

Defines

#define | Mp3AudioDevice_hpp

Define Documentation

#define Mp3AudioDevice_hpp

Generated on Tue Jan 24 20:34:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/Mp3AudioDevice.hpp Source File

Devices/Win32/Mp3AudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009
00010 #if !defined(Mp3AudioDevice_hpp)
00011 #define Mp3AudioDevice_hpp
00012
00013 #include "GenericAudioDevice.hpp"
00014
00021 class Mp3AudioDevice : public GenericAudioDevice {
00022     public:
00024         struct StartParam {
00025         };
00026
00027         Mp3AudioDevice();
00028         virtual ~Mp3AudioDevice();
00029
00031         virtual const WCHAR* GetName() const;
00032
00034         virtual AudioReturnCode Init(Priority prio);
00035
00037         void SetStartParam(const StartParam* p_start_param);
00038
00040         virtual AudioReturnCode Start(BOOLEAN auto_release = TRUE);
00041
00043         virtual AudioReturnCode Stop(UINT8 channel = 0);
00044
00046         void AudioReturnSuspend();
00047
00050         AudioReturnCode Resume();
00051
00054         AudioReturnCode Seek();
00055
00059         AudioReturnCode Set(UINT16 seconds);
00060
00061     private:
00062         StartParam m_start_param;
00063         BOOLEAN m_start_param_set;
00064 };
00065 #endif // Mp3AudioDevice_hpp
00066
00067
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/PreComp.cpp File Reference

Devices/Win32/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:04:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/PreComp.hpp File Reference

Devices/Win32/PreComp.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/System.hpp>
#include "../AudioDef.hpp"
#include <stack/target/aud_drv.h>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/PreComp.hpp Source File

Devices/Win32/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Kernel/Types.hpp>
00012 #include <Kernel/Os/Os.hpp>
00013 #include <Kernel/System.hpp>
00014 #include "../AudioDef.hpp"
00015
00016 //This should not be necessary, because this file is part of the Win2 platform anyway.
00017 //TODO: This should check for a _platform_ instead of a compiler anyway.
00018 #if defined(APOXI_COMPILER_MSVC)
00019 #define huge // ToDo: workaround due to HUGE define in aud_drv.h
00020              // remove when HUGE define in aud_drv.h is fixed.
00021 #include <Devices/Win32/aud_drv.h>
00022 #else
00023 #include <stack/target/aud_drv.h>
00024 #endif
00025
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/RealTimeClock.cpp File Reference

Devices/Win32/RealTimeClock.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/Win32/Win32.hpp>
#include <Devices/RealTimeClock.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Gui/MsgTypes.hpp>
#include <Devices/RtcSignalMapTableNode.hpp>
#include <Devices/RtcMsgTypes.hpp>
#include <Apc/SignalHandler/StackMsgProcessor.hpp>
#include <Devices/DeviceManager.hpp>

Include dependency graph for RealTimeClock.cpp:

Functions

BOOLEAN | isleap (UINT yr)
UINT | months_to_days (UINT month)
void CALLBACK | OnMinuteTickCheck (UINT uID, UINT uMsg, DWORD dwUser, DWORD dw1, DWORD dw2)
void CALLBACK | OnTime (UINT uID, UINT uMsg, DWORD dwUser, DWORD dw1, DWORD dw2)
void | scalar_to_ymd (UINT scalar, UINT *yr, UINT *mo, UINT *day)
UINT | years_to_days (UINT yr)
UINT | ymd_to_scalar (UINT yr, UINT mo, UINT day)

Variables

UINT8 | g_alarm_day = 0
UINT8 | g_alarm_hour = 0
UINT8 | g_alarm_minute = 0
UINT8 | g_alarm_month = 0
UINT8 | g_alarm_second = 0
UINT16 | g_alarm_year = 0
INT | g_offset_day = 0
INT8 | g_offset_hour = 0
INT8 | g_offset_minute = 0
INT8 | g_offset_month = 0
INT | g_offset_second = 0
INT16 | g_offset_year = 0
UINT | timer_id

Function Documentation

BOOLEAN isleap ( UINT yr )

UINT months_to_days ( UINT month )

void CALLBACK OnMinuteTickCheck | ( | UINT | uID,
 |  | UINT | uMsg,
 |  | DWORD | dwUser,
 |  | DWORD | dw1,
 |  | DWORD | dw2
 | ) |

void CALLBACK OnTime | ( | UINT | uID,
 |  | UINT | uMsg,
 |  | DWORD | dwUser,
 |  | DWORD | dw1,
 |  | DWORD | dw2
 | ) |

void scalar_to_ymd | ( | UINT | scalar,
 |  | UINT * | yr,
 |  | UINT * | mo,
 |  | UINT * | day
 | ) |

UINT years_to_days ( UINT yr )

UINT ymd_to_scalar | ( | UINT | yr,
 |  | UINT | mo,
 |  | UINT | day
 | ) |

Variable Documentation

UINT8 g_alarm_day = 0

UINT8 g_alarm_hour = 0

UINT8 g_alarm_minute = 0

UINT8 g_alarm_month = 0

UINT8 g_alarm_second = 0

UINT16 g_alarm_year = 0

INT g_offset_day = 0

INT8 g_offset_hour = 0

INT8 g_offset_minute = 0

INT8 g_offset_month = 0

INT g_offset_second = 0

INT16 g_offset_year = 0

UINT timer_id

Generated on Tue Jan 24 20:25:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/RealTimeClock.hpp File Reference

Devices/Win32/RealTimeClock.hpp File Reference

#include <Devices/AbstractDevice.hpp>
#include <Devices/RealTimeClockInterface.hpp>

Include dependency graph for RealTimeClock.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RealTimeClock

Defines

#define | Apoxi_Devices_Win32_RealTimeClock_hpp

Define Documentation

#define Apoxi_Devices_Win32_RealTimeClock_hpp

Generated on Tue Jan 24 20:26:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/RealTimeClock.hpp Source File

Devices/Win32/RealTimeClock.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_Devices_Win32_RealTimeClock_hpp)
00010 #define Apoxi_Devices_Win32_RealTimeClock_hpp
00013
00014 #include <Devices/AbstractDevice.hpp>
00015
00016 class RealTimeClock : public AbstractDevice {
00017     typedef AbstractDevice Base;
00018
00019     #include <Devices/RealTimeClockInterface.hpp>
00020
00021     protected:
00023         virtual void OnStart();
00024
00026         virtual void OnStop();
00027 };
00028
00030 #endif  // Apoxi_Devices_Win32_RealTimeClock_hpp
00031
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/RingerAudioDevice.cpp File Reference

Devices/Win32/RingerAudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "RingerAudioDevice.hpp"
#include <Afs/Ffs/FlsFile.hpp>

Include dependency graph for RingerAudioDevice.cpp:

Variables

RingerToneInfo ringer_tone_infos []

Variable Documentation

RingerToneInfo ringer_tone_infos[]

Generated on Tue Jan 24 20:34:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/RingerAudioDevice.hpp File Reference

Devices/Win32/RingerAudioDevice.hpp File Reference

#include "GenericAudioDevice.hpp"
#include <Auxiliary/Lib.hpp>

Include dependency graph for RingerAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RingerAudioDevice
struct | RingerAudioDevice::RingerToneInfo
Detailed information to a fixed ringer tone. See enum ToneId. More...
struct | RingerAudioDevice::StartParam
Start parameter. More...

Defines

#define | RingerAudioDevice_hpp

Define Documentation

#define RingerAudioDevice_hpp

Generated on Tue Jan 24 20:34:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/RingerAudioDevice.hpp Source File

Devices/Win32/RingerAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009
00010 #if !defined(RingerAudioDevice_hpp)
00011 #define RingerAudioDevice_hpp
00012
00013 #include "GenericAudioDevice.hpp"
00014
00015 #include <Auxiliary/Lib.hpp>
00016
00027 class RingerAudioDevice : public GenericAudioDevice {
00028     public:
00029
00031         enum RingTone {
00033             RingerInfoPowerOff,
00035             RingerInfoPowerOn,
00037             RingerInfoLowBat,
00039             RingerInfoConnection,
00041             RingerInfoError1,
00043             RingerInfoError2,
00045             RingerInfoDeviceIn,
00047             RingerInfoDeviceOut,
00049             RingerInfoMsgFull,
00050
00052             RingerMessage1,
00054             RingerMessage2,
00056             RingerMessage3,
00058             RingerMessage4,
00060             RingerMessage5,
00062             RingerMessage6,
00064             RingerMessage7,
00066             RingerMessage8,
00068             RingerMessage9,
00070             RingerMessage10,
00071
00073             RingerBroadcast1,
00075             RingerBroadcast2,
00077             RingerBroadcast3,
00079             RingerBroadcast4,
00081             RingerBroadcast5,
00083             RingerBroadcast6,
00085             RingerBroadcast7,
00087             RingerBroadcast8,
00089             RingerBroadcast9,
00091             RingerBroadcast10,
00092
00094             RingerAlarm1,
00096             RingerAlarm2,
00098             RingerAlarm3,
00100             RingerAlarm4,
00102             RingerAlarm5,
00104             RingerAlarm6,
00106             RingerAlarm7,
00108             RingerAlarm8,
00110             RingerAlarm9,
00112             RingerAlarm10,
00113
00115             Ringer1,
00117             Ringer2,
00119             Ringer3,
00121             Ringer4,
00123             Ringer5,
00125             Ringer6,
00127             Ringer7,
00129             Ringer8,
00131             Ringer9,
00133             Ringer10,
00135             Ringer11,
00137             Ringer12,
00139             Ringer13,
00141             Ringer14,
00143             Ringer15,
00145             Ringer16,
00147             Ringer17,
00149             Ringer18,
00151             Ringer19,
00153             Ringer20,
00155             Ringer21,
00157             Ringer22,
00159             Ringer23,
00161             Ringer24,
00163             Ringer25,
00165             Ringer26,
00167             Ringer27,
00169             Ringer28,
00171             Ringer29,
00173             Ringer30,
00175             Ringer31,
00177             Ringer32,
00179             Ringer33,
00181             Ringer34,
00183             Ringer35,
00185             Ringer36,
00187             Ringer37,
00189             Ringer38,
00191             Ringer39,
00193             Ringer40,
00195             Ringer41,
00197             Ringer42,
00199             Ringer43,
00201             Ringer44,
00203             Ringer45,
00205             Ringer46,
00207             Ringer47,
00209             Ringer48,
00211             Ringer49,
00213             Ringer50,
00214
00216             RingerGame1,
00218             RingerGame2,
00220             RingerGame3,
00222             RingerGame4,
00224             RingerGame5,
00226             RingerGame6,
00228             RingerGame7,
00230             RingerGame8,
00232             RingerGame9,
00234             RingerGame10,
00235         };
00236
00238         enum RingerDevice {
00240             RingerDeviceSound,
00242             RingerDeviceVibrator,
00244             RingerDeviceSoundAndVibrator
00245         };
00246
00248         enum RingerVolume {
00250             RingerVolumeOff,
00252             RingerVolume1,
00254             RingerVolume2,
00256             RingerVolume3,
00258             RingerVolume4,
00260             RingerVolume5,
00262             RingerVolumeInCall
00263         };
00264
00266         enum Format {
00271             FormatSmaf,
00275             FormatMidi,
00277             FormatSmafPhrase11,
00279             FormatRmd,
00281             FormatImelody,
00283             FormatBuzzer,
00284         };
00285
00287         enum Channel {
00289             ChannelAll,
00291             Channel1,
00293             Channel2,
00295             Channel3,
00297             Channel4
00298         };
00299
00301         struct RingerToneInfo {
00303             RingTone ring_tone_id;
00305             String name;
00307             UINT16 duration;
00309             BOOLEAN copyright;
00310         };
00311
00313         struct StartParam {
00315             StartParam() {
00316                 use_param = 1;
00317                 Param1.ring_tone = RingerMessage1;
00318                 play_count = 1;
00319                 device = RingerDeviceSound;
00320             };
00322             UINT8 use_param;
00324             union {
00326                 struct {
00328                     RingTone ring_tone;
00329                 } Param1;
00331                 struct {
00333                     BYTE* buffer;
00335                     UINT32 buffer_size;
00337                     Format format;
00339                     Channel channel;
00341                     UINT8 channel_volume;
00342                 } Param2;
00344                 struct {
00346                     WCHAR path;
00347 //iii                   Location loc;
00349                     Format format;
00351                     Channel channel;
00353                     UINT8 channel_volume;
00354                 } Param3;
00355             };
00357             UINT16 play_count;
00359             RingerDevice device;
00360         };
00361
00362         RingerAudioDevice();
00363         virtual ~RingerAudioDevice();
00364
00366         virtual const WCHAR* GetName() const;
00367
00369         virtual AudioReturnCode Init(Priority prio);
00370
00373         void SetStartParam(const StartParam* p_start_param);
00374
00381         virtual AudioReturnCode Start(BOOLEAN auto_release = TRUE);
00382
00384         virtual AudioReturnCode Stop(UINT8 channel = 0);
00385
00392         AudioReturnCode SetVolume(RingerVolume volume = RingerVolume3);
00393
00397         RingerToneInfo GetFixedRingerToneInfo(RingTone ring_tone);
00398
00400         static AudioReturnCode WriteDefaultRingToneInfo2Ffs();
00401
00406         static AudioReturnCode WriteRingToneInfo2Ffs(RingTone ring_tone, const RingerToneInfo* info);
00407
00412         static AudioReturnCode ReadRingToneInfoFromFfs(RingTone ring_rone, RingerToneInfo* info);
00413
00414     private:
00415         StartParam m_start_param;
00416         BOOLEAN m_start_param_set;
00417 };
00418
00419 #endif // RingerAudioDevice_hpp
00420
00421
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/SpeechAudioDevice.cpp File Reference

Devices/Win32/SpeechAudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "SpeechAudioDevice.hpp"

Include dependency graph for SpeechAudioDevice.cpp:

Generated on Tue Jan 24 20:34:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/SpeechAudioDevice.hpp File Reference

Devices/Win32/SpeechAudioDevice.hpp File Reference

#include "GenericAudioDevice.hpp"

Include dependency graph for SpeechAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SpeechAudioDevice

Defines

#define | SpeechAudioDevice_hpp

Define Documentation

#define SpeechAudioDevice_hpp

Generated on Tue Jan 24 20:34:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/SpeechAudioDevice.hpp Source File

Devices/Win32/SpeechAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009
00010 #if !defined(SpeechAudioDevice_hpp)
00011 #define SpeechAudioDevice_hpp
00012
00013 #include "GenericAudioDevice.hpp"
00014
00022 class SpeechAudioDevice : public GenericAudioDevice {
00023     public:
00024
00026         enum MuteDirection {
00028             MuteUplink,
00030             MuteDownlink,
00032             MuteUpDownlink
00033         };
00034
00036         enum SpeechVolume {
00038             SpeechVolume1 = 1,
00040             SpeechVolume2,
00042             SpeechVolume3,
00044             SpeechVolume4,
00046             SpeechVolume5,
00048             SpeechVolume6,
00050             SpeechVolume7,
00052             SpeechVolume8
00053         };
00054
00055         SpeechAudioDevice();
00056         virtual ~SpeechAudioDevice();
00057
00059         virtual const WCHAR* GetName() const;
00060
00064         virtual AudioReturnCode Init(Priority prio);
00065
00067         virtual AudioReturnCode Start(BOOLEAN auto_release = TRUE);
00068
00070         virtual AudioReturnCode Stop(UINT8 channel = 0);
00071
00078         AudioReturnCode SetVolume(SpeechVolume volume);
00079
00083         AudioReturnCode Mute(BOOLEAN mute, MuteDirection direction);
00084     };
00085
00086 #endif // SpeechAudioDevice_hpp
00087
00088
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/StillCamera.cpp File Reference

Devices/Win32/StillCamera.cpp File Reference

#include "PreComp.hpp"
#include "StillCamera.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Afs/Rfs/Pathname.hpp>
#include <Afs/Rfs/Path.hpp>

Include dependency graph for StillCamera.cpp:

Generated on Tue Jan 24 20:26:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/StillCamera.hpp File Reference

Devices/Win32/StillCamera.hpp File Reference

#include <Devices/Win32/Camera.hpp>
#include <AddOns/MultiMedia/JpegEncoder.hpp>
#include <Devices/StillCameraInterface.hpp>

Include dependency graph for StillCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | StillCamera

Defines

#define | Apoxi_StillCamera_hpp

Define Documentation

#define Apoxi_StillCamera_hpp

Generated on Tue Jan 24 20:26:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/StillCamera.hpp Source File

Devices/Win32/StillCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_StillCamera_hpp)
00010 #define Apoxi_StillCamera_hpp
00013
00014 #include <Devices/Win32/Camera.hpp>
00015 #include <AddOns/MultiMedia/JpegEncoder.hpp>
00016
00017 class DataSink;
00018
00019 class StillCamera : public Camera {
00020     typedef Camera Base;
00021
00022     public:
00023
00024         #include <Devices/StillCameraInterface.hpp>
00025
00027         virtual BOOLEAN Open();
00028
00030         virtual BOOLEAN Close();
00031
00032     protected:
00033
00034     private:
00035
00036         INT m_jpeg_quality;
00037
00038         JpegEncoder* m_encoder;
00039         JpegEncoder::EncodingParameters* m_encoding_params;
00040         Image::MetaData m_source_prop;
00041
00042         CbImageCaptured     m_cb_image_captured;
00043         CbImageEncoded      m_cb_image_encoded;
00044         CbCaptureFinished   m_cb_capture_finished;
00045
00046         void* m_app_context;
00047
00048         // callbacks
00049         // callback for still camera, where buffer for raw data will be passed to
00050         static void Cb_GDD_GetCaptureBuffer(void* context, UINT8 HUGE **buffer, UINT32 size);
00051
00052         // callback where an image has been captured as RAW data in to buffer
00053         static void Cb_GDD_ImageCaptured(INT, void* context, UINT8 HUGE* captured_buffer, UINT32 size);
00054
00055         // callback from JpegEncoder, when an RAW data image has been encoded to JPEG
00056         static void Cb_ImageEncoded(INT, void* context, DataSink& sink);
00057 };
00058
00059 inline INT StillCamera::GetJpegQuality() const
00060 {
00061     return m_jpeg_quality;
00062 }
00063
00065 #endif  // Apoxi_StillCamera_hpp
00066
Generated on Tue Jan 24 14:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/ToneAudioDevice.cpp File Reference

Devices/Win32/ToneAudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "ToneAudioDevice.hpp"

Include dependency graph for ToneAudioDevice.cpp:

Generated on Tue Jan 24 20:34:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/ToneAudioDevice.hpp File Reference

Devices/Win32/ToneAudioDevice.hpp File Reference

#include <Devices/Win32/GenericAudioDevice.hpp>

Include dependency graph for ToneAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ToneAudioDevice
struct | ToneAudioDevice::StartParam
Start paramter. More...
struct | ToneAudioDevice::UserTone
User tone. More...

Defines

#define | ToneAudioDevice_hpp

Define Documentation

#define ToneAudioDevice_hpp

Generated on Tue Jan 24 20:34:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/ToneAudioDevice.hpp Source File

Devices/Win32/ToneAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009 #if !defined(ToneAudioDevice_hpp)
00010 #define ToneAudioDevice_hpp
00011
00012 #include <Devices/Win32/GenericAudioDevice.hpp>
00013
00022 class ToneAudioDevice : public GenericAudioDevice {
00023     public:
00024
00026         enum Tone {
00028             ToneDTMF0,
00030             ToneDTMF1,
00032             ToneDTMF2,
00034             ToneDTMF3,
00036             ToneDTMF4,
00038             ToneDTMF5,
00040             ToneDTMF6,
00042             ToneDTMF7,
00044             ToneDTMF8,
00046             ToneDTMF9,
00048             ToneDTMFHash,
00050             ToneDTMFAsterix,
00051
00053             ToneSvSubscriberBusy,
00055             ToneSvCongestion,
00057             ToneSvRadioPathAck,
00059             ToneSvRadioPathNotAvail,
00061             ToneSvErrorInfo,
00063             ToneSvCallWaiting,
00064
00066             ToneInfoFreeTone,
00068             ToneInfoConnection,
00070             ToneInfoDisconnect,
00072             ToneInfoDeviceIn,
00074             ToneInfoDeviceOut,
00076             ToneInfoMsgFull,
00078             ToneInfoUssd,
00080             ToneInfoMinuteMinder,
00082             ToneInfoError1,
00084             ToneInfoError2,
00086             ToneInfoSmsInCall,
00088             ToneInfoBroadcastInCall,
00090             ToneInfoAlarmInCall,
00092             ToneInfoLowBatInCall,
00094             ToneInfoPowerOff,
00096             ToneInfoPowerOn,
00098             ToneInfoSingleBeep,
00099         };
00100
00102         enum ToneType {
00104             NormalUserTone,
00106             DualUserTone,
00108             TripleUserTone,
00109         };
00110
00112         struct UserTone {
00114             UINT16 frequency;
00116             UINT16 duration;
00117         };
00118
00120         struct StartParam {
00122             StartParam() {
00123                 use_tone = TRUE;
00124                 tone = ToneDTMF0;
00125                 play_count = 1;
00126                 mix_factor = 0x4000;
00127             };
00129             BOOLEAN use_tone;
00130             union {
00132                 Tone tone;
00133                 struct {
00135                     UserTone* user_tone;
00136                     // Number of tones
00137                     UINT32 tone_count;
00138                     // Type of tone
00139                     ToneType tone_type;
00140                 } UTone;
00141             };
00142
00144             UINT16 play_count;
00148             UINT16 mix_factor;
00149         };
00150
00151         ToneAudioDevice();
00152         virtual ~ToneAudioDevice();
00153
00155         virtual const WCHAR* GetName() const;
00156
00158         virtual AudioReturnCode Init(Priority prio);
00159
00162         void SetStartParam(const StartParam* p_start_param);
00163
00165         virtual AudioReturnCode Start(BOOLEAN auto_release = TRUE);
00166
00168         virtual AudioReturnCode Stop(UINT8 channel = 0);
00169
00170     protected:
00172         INT ConvertTone2INT(Tone tone);
00173
00174     private:
00175         StartParam m_start_param;
00176         BOOLEAN m_start_param_set;
00177 };
00178
00179 #endif // ToneAudioDevice_hpp
00180
00181
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/vib_drv.cpp File Reference

Devices/Win32/vib_drv.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/Os/Os.hpp>
#include <Devices/Win32/aud_drv.h>
#include "vib_drv.h"

Include dependency graph for vib_drv.cpp:

Functions

vib_result_t | VIB_init (void)
vib_result_t | VIB_pause (void)
vib_result_t | VIB_start (vib_level_t level, vib_mode_t mode, unsigned char channel)
vib_result_t | VIB_status (void)
vib_result_t | VIB_stop (void)

Function Documentation

vib_result_t VIB_init ( void )

Copyright (C) Danish Wireless Design A/S. All rights reserved.

This document contains proprietary information belonging to Danish Wireless Design A/S. Passing on and copying of this document, use and communication of its contents is not permitted without prior written authorisation.

Description: Vibrator driver

Revision Information: File name: .c Version: Date: 2004-05-04 18:11:10 Responsible: klj Comment: added hw_reg.h to support both CBE build and the old build environment

vib_result_t VIB_pause ( void )

vib_result_t VIB_start | ( | vib_level_t | level,
 |  | vib_mode_t | mode,
 |  | unsigned char | channel
 | ) |

vib_result_t VIB_status ( void )

vib_result_t VIB_stop ( void )

Generated on Tue Jan 24 20:34:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VideoCamera.cpp File Reference

Devices/Win32/VideoCamera.cpp File Reference

#include "PreComp.hpp"
#include "VideoCamera.hpp"
#include "CamWin32.hpp"
#include <Config/CameraConfig.hpp>
#include <Auxiliary/BufferPoolManager.hpp>

Include dependency graph for VideoCamera.cpp:

Generated on Tue Jan 24 20:27:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VideoCamera.hpp File Reference

Devices/Win32/VideoCamera.hpp File Reference

#include <Devices/Win32/Camera.hpp>
#include <Devices/VideoCameraInterface.hpp>

Include dependency graph for VideoCamera.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoCamera

Defines

#define | Apoxi_VideoCamera_hpp

Define Documentation

#define Apoxi_VideoCamera_hpp

Generated on Tue Jan 24 20:27:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VideoCamera.hpp Source File

Devices/Win32/VideoCamera.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VideoCamera_hpp)
00010 #define Apoxi_VideoCamera_hpp
00013
00014 #include <Devices/Win32/Camera.hpp>
00015
00016 class VideoCamera : public Camera {
00017     typedef Camera Base;
00018
00019     public:
00020         #include <Devices/VideoCameraInterface.hpp>
00021
00022     protected:
00023
00024     private:
00025         // tbd: check whether signature of callbacks are equal to the GDD 2.2 ones
00026         static UINT8 HUGE* GetCaptureBuffer_GDD_CB(/*UINT8 HUGE ** buffer, UINT32 size*/);
00027         static void VideoFrameCaptured_GDD_CB(int result, UINT8 HUGE * buffer, UINT32 size, UINT32 stamp);
00028         static void NotifyCaptureBufferStatus_GDD_CB(void* context, UINT8 free_buffer_count);
00029
00030         FrameRateType m_fps;
00031
00032         static UINT32 m_starting_time;          // frame count or timestamp
00033
00035         static UINT32 m_pool_handle;
00036
00037         static Cb_NotifyCaptureBufferStatus m_cb_notify_status;
00038         static Cb_FrameCaptured m_cb_frame_captured;
00039 };
00040
00041 inline VideoCamera::FrameRateType VideoCamera::GetFrameRate() const
00042 {
00043     return m_fps;
00044 }
00045
00047 #endif  // Apoxi_VideoCamera_hpp
00048
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VideoChannel.cpp File Reference

Devices/Win32/VideoChannel.cpp File Reference

#include "PreComp.hpp"
#include "VideoChannel.hpp"
#include <Config/DisplayConfig.hpp>
#include <Gui/DeviceContext.hpp>
#include <Devices/Display.hpp>

Include dependency graph for VideoChannel.cpp:

Generated on Tue Jan 24 20:28:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VideoChannel.hpp File Reference

Devices/Win32/VideoChannel.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for VideoChannel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VideoChannel

Defines

#define | Apoxi_VideoChannel_hpp

Define Documentation

#define Apoxi_VideoChannel_hpp

Generated on Tue Jan 24 20:28:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VideoChannel.hpp Source File

Devices/Win32/VideoChannel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_VideoChannel_hpp)
00010 #define Apoxi_VideoChannel_hpp
00011
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/Rect.hpp>
00017
00026 class VideoChannel {
00027
00028     public:
00029
00030 #ifdef APOXI_COMPAT_2_8_0
00031         /*  Obsolete - removed in Apoxi 2.9.0 and later.
00032             Defines the types of available video parameters.
00033             The values can be set by VideoChannel::SetParam */
00034         enum VideoParameterType {
00036             Rotate,
00038             Mirror,
00040             Flip,
00042             Antitearing,
00044             SmartOverlays,
00046             YuvToRgbConversion,
00048             ZoomFactorHorizontalMin,
00050             ZoomFactorHorizontalMax,
00052             ZoomFactorVerticalMin,
00054             ZoomFactorVerticalMax
00055         };
00056 #endif // APOXI_COMPAT_2_8_0
00057
00059         enum TransformationType {
00060             NoTransformation,
00061             Rotation90Transformation,
00062             Rotation180Transformation,
00063             Rotation270Transformation,
00064             MirrorTransformation,
00065             MirrorRotate90Transformation,
00066             MirrorRotate180Transformation,  // same as flip
00067             MirrorRotate270Transformation
00068         };
00069
00070         enum ScalingMethodType {
00071             NoScaling,
00072             LetterboxScaling,
00073             BestFitScaling
00074         };
00075
00076         enum VideoAndViewfinderOrderType {
00077             ViewfinderOverVideoPlayback,
00078             VideoPlaybackOverViewfinder
00079         };
00080
00090         typedef void (*CbResult)(BOOLEAN result,
00091                                  void* context);
00092
00093 #ifdef APOXI_COMPAT_2_8_0
00094         /*  Obsolete - use the changed typedef instead.
00095             Callback function that is invoked by the VideoChannel when a
00096             frame has been rendered.
00097             @param result           A result (error) code from the lower layer
00098             @param context          A context (e.g. this pointer) that has been
00099                                     passed to the VideoChannel object when
00100                                     VideoChannel::Open
00101                                     has been invoked.
00102             @param frame_buf        Pointer to the video frame buffer
00103                                     that has been rendered.
00104             @see RenderFrame*/
00105         typedef void (*CbVideoFrameRendered)(INT result,
00106                                              void* context,
00107                                              const UINT8 HUGE* frame_buf);
00108
00109         /*  Obsolete - not needed anymore.
00110             Callback function that is invoked by the VideoChannel when a
00111             frame has been rendered.
00112             @param result           <em>TRUE</em> if the operation was
00113                                     succesfull. Otherwise, <em>FALSE</em>.
00114             @param context          A context (e.g. this pointer) that has been
00115                                     passed to the VideoChannel object when
00116                                     VideoChannel::Open
00117                                     has been invoked.
00118             @param frame_buf        Pointer to the video frame buffer
00119                                     that has been rendered.
00120             @see RenderFrame*/
00121         typedef void (*CbVideoFrameRenderedNew)(BOOLEAN result,
00122                                                 void* context,
00123                                                 const UINT8 HUGE* frame_buf);
00124 #else // APOXI_COMPAT_2_8_0
00125
00137         typedef void (*CbVideoFrameRendered)(BOOLEAN result,
00138                                             void* context,
00139                                             const UINT8 HUGE* frame_buf);
00140 #endif // APOXI_COMPAT_2_8_0
00141
00145         VideoChannel(INT display_idx = 0);
00146
00147         ~VideoChannel();
00148
00149 #ifdef APOXI_COMPAT_2_8_0
00150         /*  Obsolete - use the overloaded function instead.
00151             Opens the video channel and sets the bounding rectangle for the video frames, which will be
00152             used to display the video content set by VideoChannel::RenderFrame. VideoChannel::Close
00153             should be invoked when the no frames are rendered anymore.
00154             @param video_frame_rect     [IN/OUT] Position and size of area to be filled with video.
00155             @param cb_frame_rendered    [IN] Pointer to callback function which is called when the rendering
00156                                         of a frame has been completed (i. e. the frame is written to the display
00157                                         buffer, the transfer of frame from display buffer to LCD is not
00158                                         included).
00159             @param context              Context (e.g. this pointer) of the calling application.
00160                                         This context will be passed in the callback function.
00161             @return                     TRUE if the video channel could be opened.
00162             @see CbVideoFrameRendered*/
00163         BOOLEAN Open(Rect& video_frame_rect, CbVideoFrameRendered cb_frame_rendered, void* context = 0);
00164
00165         /*  Opens the video channel and sets the bounding rectangle for the video frames, which will be
00166             used to display the video content set by VideoChannel::RenderFrame. VideoChannel::Close
00167             should be invoked when the no frames are rendered anymore.
00168             @param cb_frame_rendered    [IN] Pointer to callback function which is called when the rendering
00169                                         of a frame has been completed (i. e. the frame is written to the display
00170                                         buffer, the transfer of frame from display buffer to LCD is not
00171                                         included).
00172             @param context              Context (e.g. this pointer) of the calling application.
00173                                         This context will be passed in the callback function.
00174             @return                     TRUE if the video channel could be opened.
00175             @see CbVideoFrameRendered*/
00176         BOOLEAN Open(CbVideoFrameRenderedNew cb_frame_rendered, void* context);
00177 #else // APOXI_COMPAT_2_8_0
00178
00190         BOOLEAN Open(CbVideoFrameRendered cb_frame_rendered, void* context);
00191 #endif // APOXI_COMPAT_2_8_0
00192
00194         void Close();
00195
00205         BOOLEAN Start(CbResult cb_video_channel_started, void* context);
00206
00216         BOOLEAN Stop(CbResult cb_video_channel_stopped, void* context);
00217
00228         void RenderFrame(void* frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame = FALSE);
00229
00233         BOOLEAN IsOpen() const;
00234
00237         UINT32 GetRefreshDelay() const;
00238
00239 #ifdef APOXI_COMPAT_2_8_0
00240         /*  Obsolete - removed in Apoxi 2.9.0 and later.
00241             Parameterizes the rendering path and configures the transformation blocks.
00242             @param type     [IN] Type of the parameter to be configured
00243             @param value        [IN] Value to which the parameter type should be set
00244             @return         TRUE if the setting of the parameter was successful */
00245         BOOLEAN SetParam(VideoParameterType type, UINT32 value);
00246
00247         /*  Obsolete - removed in Apoxi 2.9.0 and later.
00248             Reads out parameters of the rendering path and transformation blocks.
00249             Parameters are set with the complementary function VideoChannel::SetVideoParam.
00250             @param type     [IN] Type of the parameter to be configured.
00251             @param value    [OUT] Current value of the parameter.
00252             @return         TRUE if the setting of the parameter was successful. */
00253         BOOLEAN GetParam(VideoParameterType type, UINT32* value) const;
00254 #endif // APOXI_COMPAT_2_8_0
00255
00256 #ifdef APOXI_COMPAT_2_6_0
00257         /*  Obsolete - use the method SetVideoSize instead.
00258             Sets the actual size of the video in pixels. The actual size can be determined
00259             by analyzing the transport format of the video or the encoded elementary stream directly.
00260             (Compare to 'extended size' as defined by some codec standards, which is the actual size
00261             rounded up to a full integer number of macroblocks)
00262             @param video_size       [IN] Actual size of the decoded video as determined by analyzing
00263                                     the videos transport format or the elementary stream */
00264
00265         void SetSize(Size video_size)
00266         {
00267         #ifdef APOXI_COMPAT_2_8_0
00268             SetVideoSize(video_size);
00269         #endif //  APOXI_COMPAT_2_8_0
00270         }
00271 #endif // APOXI_COMPAT_2_6_0
00272
00273 #ifdef APOXI_COMPAT_2_8_0
00274         /*  Obsolete - use the overloaded function instead.
00275             Sets the actual size of the video in pixels. The actual size can be determined
00276             by analyzing the transport format of the video or the encoded elementary stream directly.
00277             (Compare to 'extended size' as defined by some codec standards, which is the actual size
00278             rounded up to a full integer number of macroblocks)
00279             @param video_size       [IN] Actual size of the decoded video as determined by analyzing
00280                                     the videos transport format or the elementary stream */
00281         void SetVideoSize(Size video_size);
00282 #endif // APOXI_COMPAT_2_8_0
00283
00295         BOOLEAN SetVideoSize(   Size actual_video_size,
00296                                 Size extended_video_size,
00297                                 Point left_top_offset);
00298
00299 #ifdef APOXI_COMPAT_2_8_0
00300         /*  Obsolete - use the overloaded method instead.
00301             Defines a sub rectangle within the decoded video.
00302             The coordinates are relative to the upper left corner of the video. The rectangle may never
00303             exceed the size of the decoded video i.e. the cropping rectangle must always lie completely within the video.
00304             Together with video frame rectangle this implicitly also defines a zoom factor - the content of the
00305             cropping rectangle is zoomed up or down to best fit to the video frame rectangle. This is limited by the capability
00306             of the transformation blocks for zoom and crop (i.e. in most cases the hardware).
00307             @param crop_rect    [IN/OUT] Position and size of area to be cut out from the original video.
00308             @return             TRUE if the setting of the parameter was possible in the transformation blocks.
00309                                 If it was not possible FALSE is returned and the cropping rectangle contains the best effort
00310                                 of the transformation blocks to fit to the desired rectangle. */
00311         BOOLEAN SetCropRect(Rect& crop_rect);
00312 #endif // APOXI_COMPAT_2_8_0
00313
00327         BOOLEAN SetCropRect(Rect& crop_rect, Rect& effective_playback_rect);
00328
00329 #ifdef APOXI_COMPAT_2_6_0
00330         /*  Obsolete - use the method SetPlaybackRect instead.
00331             Adjusts the size and position of the actual video area on the screen.
00332             The rectangle is initially set when opening a channel with DisplayChannel::Open but can be changed dynamically with this method.
00333             @param video_frame_rect     [IN/OUT] Position and size of screen area to be filled with video.
00334             @return                     TRUE if the setting of the parameter was possible in the underlying HW.
00335                                         If it was not possible, FALSE is returned and the  video frame rectangle
00336                                         contains the best effort of the hardware to fit the desired rectangle. */
00337         BOOLEAN AdjustFrameRect(Rect& video_frame_rect)
00338         {
00339         #ifdef APOXI_COMPAT_2_8_0
00340             return SetFrameRect(video_frame_rect);
00341         #else
00342             return FALSE;
00343         #endif //  APOXI_COMPAT_2_8_0
00344         }
00345 #endif // APOXI_COMPAT_2_6_0
00346
00347 #ifdef APOXI_COMPAT_2_8_0
00348         /*  Obsolete - use the function SetPlaybackRect instead.
00349             Adjusts the size and position of the actual video area on the screen.
00350             The rectangle is initially set when opening a channel with DisplayChannel::Open but can be changed dynamically with this method.
00351             @param video_frame_rect     [IN/OUT] Position and size of screen area to be filled with video.
00352             @return                     TRUE if the setting of the parameter was possible in the underlying HW.
00353                                         If it was not possible, FALSE is returned and the  video frame rectangle
00354                                         contains the best effort of the hardware to fit the desired rectangle. */
00355         BOOLEAN SetFrameRect(Rect& video_frame_rect);
00356 #endif // APOXI_COMPAT_2_8_0
00357
00369         BOOLEAN SetPlaybackRect(Rect& playback_rect,
00370                                 TransformationType playback_transformation,
00371                                 ScalingMethodType scaling_method);
00372
00373 #ifdef APOXI_COMPAT_2_8_0
00374         /*  Reads out the capabilities of the underlying layers to fulfill a certain programming for the video rectangles.
00375             Constraints generally come in due to the utilized hardware blocks.
00376             Underlying layers try to achieve a best effort to reach the desired rectangles - if this cannot be achieved
00377             the nearest possible rectangles are returned. It is ensured, that these rectangles will never be larger.
00378             The returned rectangles can the be used in VideoChannel::SetCropRect and VideoChannel::AdjustFrameRect which guarantees that
00379             these functions will be successful.
00380             @param video_frame_rect     [IN/OUT] Position and size of screen area to be filled with video.
00381             @param crop_rect            [IN/OUT] Position and size of area to be cut out from the original video.
00382             @return                     TRUE if the setting of the parameter *would be* possible in the underlying hardware.
00383                                         If itwas not possible, FALSE is returned and the video frame rectangle and cropping rectangle
00384                                         contain the best effort of the hardware to fit the desired rectangles */
00385         BOOLEAN QueryRects(Rect& video_frame_rect, Rect& crop_rect);
00386 #endif // APOXI_COMPAT_2_8_0
00387
00398         BOOLEAN SetPlaybackAndViewfinderOrder(
00399                             VideoAndViewfinderOrderType video_viewfinder_order);
00400
00401     private:
00402         Rect m_playback_rect;
00403         const DDrvAtomPtr m_video_frame_buf;
00404         INT m_display_idx;
00405 };
00406
00408 #endif  // Apoxi_VideoChannel_hpp
00409
00410
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VirtualDisplay.cpp File Reference

Devices/Win32/VirtualDisplay.cpp File Reference

#include "PreComp.hpp"
#include "VirtualDisplay.hpp"
#include "../SharedMethods/Ddrv.cpp"
#include <Devices/DeviceManager.hpp>
#include "../SharedMethods/SetPixel_Planes.cpp"
#include "../SharedMethods/SetPixel_8Bpp.cpp"
#include "../SharedMethods/SetPixel_16Bpp.cpp"
#include "../SharedMethods/SetPixel_24Bpp.cpp"
#include "../SharedMethods/SetPixel_32Bpp.cpp"
#include "../SharedMethods/FillRect_Planes.cpp"
#include "../SharedMethods/FillRect_8Bpp.cpp"
#include "../SharedMethods/FillRect_16Bpp.cpp"
#include "../SharedMethods/FillRect_24Bpp.cpp"
#include "../SharedMethods/FillRect_32Bpp.cpp"
#include "../SharedMethods/BitBlit_Planes.cpp"
#include "../SharedMethods/BitBlit_8Bpp.cpp"
#include "../SharedMethods/BitBlit_16Bpp.cpp"
#include "../SharedMethods/BitBlit_24Bpp.cpp"
#include "../SharedMethods/BitBlit_32Bpp.cpp"
#include "../SharedMethods/ScrollHorizontal_Planes.cpp"
#include "../SharedMethods/ScrollHorizontal_8Bpp.cpp"
#include "../SharedMethods/ScrollHorizontal_16Bpp.cpp"
#include "../SharedMethods/ScrollHorizontal_24Bpp.cpp"
#include "../SharedMethods/ScrollHorizontal_32Bpp.cpp"
#include "../SharedMethods/ScrollVertical_Planes.cpp"
#include "../SharedMethods/ScrollVertical_8Bpp.cpp"
#include "../SharedMethods/ScrollVertical_16Bpp.cpp"
#include "../SharedMethods/ScrollVertical_24Bpp.cpp"
#include "../SharedMethods/ScrollVertical_32Bpp.cpp"
#include "../SharedMethods/DrawChar_Planes.cpp"
#include "../SharedMethods/DrawChar_8Bpp.cpp"
#include "../SharedMethods/DrawChar_16Bpp.cpp"
#include "../SharedMethods/DrawChar_24Bpp.cpp"
#include "../SharedMethods/DrawChar_32Bpp.cpp"
#include "../SharedMethods/ConvertToColorValue_Planes.cpp"
#include "../SharedMethods/ConvertToColorValue_Bpp.cpp"
#include "../SharedMethods/GetPixelColor_Planes.cpp"
#include "../SharedMethods/GetPixelColor_8Bpp.cpp"
#include "../SharedMethods/GetPixelColor_16Bpp.cpp"
#include "../SharedMethods/GetPixelColor_24Bpp.cpp"
#include "../SharedMethods/GetPixelColor_32Bpp.cpp"

Include dependency graph for VirtualDisplay.cpp:

Generated on Tue Jan 24 20:28:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VirtualDisplay.hpp File Reference

Devices/Win32/VirtualDisplay.hpp File Reference

#include <Kernel/Types.hpp>
#include <Devices/AbstractDevice.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/Rect.hpp>
#include <Gui/ColorTable.hpp>
#include <Gui/Color.hpp>
#include <Gui/Font.hpp>

Include dependency graph for VirtualDisplay.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ScanlineAccessor
class | VirtualDisplay

Defines

#define | Apoxi_VirtualDisplay_hpp

Define Documentation

#define Apoxi_VirtualDisplay_hpp

Generated on Tue Jan 24 20:28:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VirtualDisplay.hpp Source File

Devices/Win32/VirtualDisplay.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_VirtualDisplay_hpp)
00010 #define Apoxi_VirtualDisplay_hpp
00013
00014 class VideoChannel;
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Devices/AbstractDevice.hpp>
00018 #include <Gui/Bitmap.hpp>
00019 #include <Gui/Rect.hpp>
00020 #include <Gui/ColorTable.hpp>
00021 #include <Gui/Color.hpp>
00022 #include <Gui/Font.hpp>
00023
00028 class VirtualDisplay : public AbstractDevice {
00029     typedef AbstractDevice Base;
00030
00031     public:
00033         enum Type {
00035             Monochrome,
00037             Planes2,
00039             Planes4,
00041             Planes8,
00043             BitsPerPixel8,
00045             BitsPerPixel16,
00047             BitsPerPixel24,
00049             BitsPerPixel32
00050         };
00051
00053         VirtualDisplay(INT index = 0);
00054
00067         VirtualDisplay(XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00068
00070         VirtualDisplay(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00071
00073         virtual ~VirtualDisplay();
00074
00087         void Init(XYDIM width, XYDIM height,  INT bits_per_pixel, BOOLEAN planes = FALSE, DDrvAtomPtr buffer = 0);
00088
00090         void Init(Bitmap* bitmap, INT bits_per_pixel, BOOLEAN planes = FALSE);
00091
00093         virtual const WCHAR* GetName() const;
00094
00096         ControlArg Control(INT command, ControlArg arg);
00097
00099         XYDIM GetWidth() const { return m_bitmap.GetWidth();}
00100
00102         XYDIM GetHeight() const { return m_bitmap.GetHeight(); }
00103
00105         Bitmap* GetBitmap() { return &m_bitmap; }
00106
00108         Type GetType() { return m_type; }
00109
00113         void SetBlitRect(const Rect& rect = Rect()) { m_blit_rect = rect; }
00114
00116         const Rect& GetBlitRect() const { return m_blit_rect; };
00117
00120         void AdjustBlitRect(const Rect& rect) { m_blit_rect.Union(rect); }
00121
00124         virtual void Refresh();
00125
00128         void SetPixel(XYDIM x, XYDIM y);
00129
00132         void FillRect(const Rect& rect);
00133
00143             void BitBlit(XYDIM dest_x,
00144                      XYDIM dest_y,
00145                      const BitmapRes& bmp,
00146                      const Rect& clip_rect,
00147                      UINT8 trans_mode = 0);
00148
00153         void Scroll(const Rect& rect, XYDIM dx, XYDIM dy);
00154
00157         void DrawChar(XYDIM x, XYDIM y, const Glyph& glyph, INT height);
00158
00160         void SetColorValue(ColorValue color_value, UINT8 alpha = 255);
00161
00163         ColorValue GetColorValue() const { return m_color_value; }
00164
00166         void SetColor(Color color);
00167
00169         Color GetColor() const { return m_color; }
00170
00175         ColorValue ConvertToColorValue(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const;
00176
00178         Color GetPixelColor(XYDIM x, XYDIM y) const;
00179
00181         INT GetScanlineAtomCount() const { return m_scanline_atom_count; }
00182
00185         void SetAlphaBlendingMode(BOOLEAN mode) {
00186                                                     #ifdef APOXI_ENABLE_ALPHA_BLENDING
00187                                                         m_alpha_mode = mode;
00188                                                     #endif
00189                                                 }
00190
00192         BOOLEAN GetAlphaBlendingMode() const {
00193                                                 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00194                                                     return m_alpha_mode;
00195                                                 #else
00196                                                     return TRUE;
00197                                                 #endif
00198                                                 }
00199     private:
00200 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00201         BOOLEAN m_alpha_mode;
00202 #endif
00203         Bitmap m_bitmap;
00204         Rect m_blit_rect;
00205         Type m_type;
00206         ColorValue m_color_value;
00207         Color m_color;
00208         INT m_pixel_atom_count;
00209         INT m_scanline_atom_count;
00210         INT m_plane_count;
00211         INT m_scanline_inc;
00212         INT m_plane_inc;
00213         DDrvAtomPtr m_data;
00214         DDrvAtomPtr m_scanline_buffer;
00215
00216         void ScrollHorizontal(const Rect& rect, XYDIM dx);
00217         void ScrollVertical(const Rect& rect, XYDIM dy);
00218 };
00219
00222 class ScanlineAccessor {
00223     public:
00228         ScanlineAccessor(VirtualDisplay* display, XYDIM x, XYDIM y, XYDIM width) :
00229             m_display(display),
00230             m_count(width),
00231             m_xpos(0),
00232             m_x(x),
00233             m_y(y)
00234         {
00235         }
00236
00238         BOOLEAN HasNext() { return (m_count > 0); };
00239
00241         void Draw(UINT8 red, UINT8 green, UINT8 blue)
00242         {
00243             m_display->SetColor(Color(red, green, blue));
00244             m_display->SetPixel(m_x + m_xpos, m_y);
00245             m_xpos++;
00246             m_count--;
00247         }
00248
00250         void Draw(ColorValue color)
00251         {
00252             m_display->SetColorValue(color);
00253             m_display->SetPixel(m_x + m_xpos, m_y);
00254             m_xpos++;
00255             m_count--;
00256         }
00257
00261         void Next() {
00262             m_xpos++;
00263             m_count--;
00264         }
00265
00266
00267     private:
00269         XYDIM m_count;
00270         VirtualDisplay* m_display;
00271         XYDIM m_xpos;
00272         XYDIM m_x;
00273         XYDIM m_y;
00274
00275 //  The optimized implementation for 16bpp displays is left in here for reference
00276 //
00277 //  public:
00278 //      ScanlineAccessor(VirtualDisplay* display, XYDIM x, XYDIM y, XYDIM width) :
00279 //          m_data((UINT16 GDI_HUGE*)display->GetBitmap()->GetBits()),
00280 //          m_count(width)
00281 //      {
00282 //          m_data += (display->GetScanlineAtomCount() >> 1) * y + x;
00283 //      }
00284 //
00285 //      BOOLEAN HasNext() { return (m_count > 0); };
00286 //
00287 //      void Draw(UINT8 red, UINT8 green, UINT8 blue)
00288 //      {
00289 //          *m_data = ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)));
00290 //
00291 //          #if defined(APOXI_DISPLAY_FORMAT_BIG_ENDIAN)
00292 //              *m_data = ((*m_data & 0xffU) << 8U) | ((*m_data & 0xff00U)) >> 8U;
00293 //          #endif
00294 //          m_data++;
00295 //          m_count--;
00296 //      }
00297 //
00298 //      void Next() {
00299 //          m_data++;
00300 //          m_count--;
00301 //      }
00302 //
00303 //
00304 //  private:
00305 //      /// pointer to the current line onscreen
00306 //      UINT16 GDI_HUGE* m_data;
00307 //      /// used to determine if there are pixels left to draw
00308 //      XYDIM m_count;
00309
00310 };
00311
00313 #endif  // Apoxi_VirtualDisplay_hpp
00314
Generated on Tue Jan 24 14:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VoiceMemoAudioDevice.cpp File Reference

Devices/Win32/VoiceMemoAudioDevice.cpp File Reference

#include "PreComp.hpp"
#include "VoiceMemoAudioDevice.hpp"
#include <aud_drv.h>

Include dependency graph for VoiceMemoAudioDevice.cpp:

Generated on Tue Jan 24 20:34:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VoiceMemoAudioDevice.hpp File Reference

Devices/Win32/VoiceMemoAudioDevice.hpp File Reference

#include "GenericAudioDevice.hpp"

Include dependency graph for VoiceMemoAudioDevice.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VoiceMemoAudioDevice
struct | VoiceMemoAudioDevice::StartParam
Start paramter. More...

Defines

#define | VoiceMemoAudioDevice_hpp

Define Documentation

#define VoiceMemoAudioDevice_hpp

Generated on Tue Jan 24 20:34:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices/Win32/VoiceMemoAudioDevice.hpp Source File

Devices/Win32/VoiceMemoAudioDevice.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009 #if !defined(VoiceMemoAudioDevice_hpp)
00010 #define VoiceMemoAudioDevice_hpp
00011
00012 #include "GenericAudioDevice.hpp"
00013
00014 //This class is deprecated. Murray.
00015
00027 class VoiceMemoAudioDevice : public GenericAudioDevice {
00028     public:
00029
00031         enum VmPlayMode {
00033             VmModePlayback,
00035             VmModeRec
00036         };
00037
00039         enum AudioVmMode {
00041             VmModeStandby,
00043             VmModeTch
00044         };
00045
00047         enum MediaType  {
00049             MediaTypeFfs,
00051             MediaRam,
00053             MediaMmc
00054         };
00055
00057         enum DspFormat {
00059             DspFormatFullRate,
00061             DspFormatAmr
00062         };
00063
00065         enum Rate {
00067             Rate0,
00069             Rate1,
00071             Rate2,
00073             Rate3,
00075             Rate4,
00077             Rate5,
00079             Rate6,
00081             Rate7
00082         };
00083
00085         struct StartParam {
00087             union {
00090                 Rate rate;
00092                 DspFormat dsp_format;
00093             };
00095             AudioVmMode audio_vm_mode;
00097             MediaType media_type;
00099             UINT16* file_handle;
00100             UINT16 file_handle_size;
00101         };
00102
00106         VoiceMemoAudioDevice(VmPlayMode vm_play_mode = VmModePlayback);
00107
00108         virtual ~VoiceMemoAudioDevice();
00109
00111         virtual const WCHAR* GetName() const;
00112
00114         virtual AudioReturnCode Init(Priority prio);
00115
00118         void SetStartParam(const StartParam* p_start_param);
00119
00121         virtual AudioReturnCode Start(BOOLEAN auto_release = TRUE);
00122
00125         virtual AudioReturnCode Stop(UINT8 channel = 0);
00126
00127     private:
00128         VmPlayMode m_vm_play_mode;
00129
00130         StartParam m_start_param;
00131         BOOLEAN m_start_param_set;
00132 };
00133
00134 #endif // VoiceMemoAudioDevice_hpp
00135
00136
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTControlFrameView.cpp File Reference

GlobalThemes/CustomizableTheme/CTControlFrameView.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CTControlFrameView.hpp"
#include <Gui/PaintDc.hpp>
#include "CustomizableTheme.hpp"

Include dependency graph for CTControlFrameView.cpp:

Generated on Tue Jan 24 20:34:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTControlFrameView.hpp File Reference

GlobalThemes/CustomizableTheme/CTControlFrameView.hpp File Reference

#include <Gui/ControlFrameView.hpp>

Include dependency graph for CTControlFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CTControlFrameView

Defines

#define | Apoxi_CTControlFrameView_hpp

Define Documentation

#define Apoxi_CTControlFrameView_hpp

Generated on Tue Jan 24 20:35:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTControlFrameView.hpp Source File

GlobalThemes/CustomizableTheme/CTControlFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_CTControlFrameView_hpp)
00010 #define Apoxi_CTControlFrameView_hpp
00011
00012 #include <Gui/ControlFrameView.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     CTControlFrameView
00016     ------------------------------------------------------------------------*/
00017 class CTControlFrameView : public ControlFrameView {
00018     typedef ControlFrameView Base;
00019
00020     public:
00022         CTControlFrameView();
00023
00025         CTControlFrameView(XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size);
00026
00028         virtual ~CTControlFrameView();
00029
00037         void SetDimensions(XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size);
00038
00039     protected:
00041         virtual void DrawControlFrame(const Control& control, DeviceContext* dc, const Rect& repaint_rect) const;
00042 };
00043
00044 #endif  // Apoxi_CTControlFrameView_hpp
00045
00046
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPanelView.cpp File Reference

GlobalThemes/CustomizableTheme/CTPanelView.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CTPanelView.hpp"
#include <Gui/TextFormat.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/DeviceContext.hpp>
#include "CustomizableTheme.hpp"
#include <Config/FontConfig.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for CTPanelView.cpp:

Generated on Tue Jan 24 20:35:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPanelView.hpp File Reference

GlobalThemes/CustomizableTheme/CTPanelView.hpp File Reference

#include <Gui/Panel.hpp>

Include dependency graph for CTPanelView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CTPanelView

Defines

#define | Apoxi_CTPanelView_hpp

Define Documentation

#define Apoxi_CTPanelView_hpp

Generated on Tue Jan 24 20:35:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPanelView.hpp Source File

GlobalThemes/CustomizableTheme/CTPanelView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_CTPanelView_hpp)
00010 #define Apoxi_CTPanelView_hpp
00011
00012 #include <Gui/Panel.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     CTPanelView
00016     ------------------------------------------------------------------------*/
00017 class CTPanelView : public PanelView {
00018     typedef PanelView Base;
00019
00020     public:
00021         CTPanelView();
00022         CTPanelView(XYDIM default_height);
00023
00025         virtual ~CTPanelView();
00026
00028         virtual void Update(const Theme& theme);
00029
00030     protected:
00032         virtual void DrawPanel(const Panel& panel, DeviceContext* dc, const Rect& repaint_rect) const;
00033
00034 };
00035
00036 #endif  // Apoxi_CTPanelView_hpp
00037
00038
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPositionIndicatorView.cpp File Reference

GlobalThemes/CustomizableTheme/CTPositionIndicatorView.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CTPositionIndicatorView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/DisplayConfig.hpp"
#include "CustomizableTheme.hpp"
#include <Auxiliary/WStrUtil.hpp>

Include dependency graph for CTPositionIndicatorView.cpp:

Generated on Tue Jan 24 20:35:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPositionIndicatorView.hpp File Reference

GlobalThemes/CustomizableTheme/CTPositionIndicatorView.hpp File Reference

#include <Gui/PositionIndicator.hpp>

Include dependency graph for CTPositionIndicatorView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CTPositionIndicatorView

Defines

#define | Apoxi_CTPositionIndicatorView_hpp

Define Documentation

#define Apoxi_CTPositionIndicatorView_hpp

Generated on Tue Jan 24 20:35:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPositionIndicatorView.hpp Source File

GlobalThemes/CustomizableTheme/CTPositionIndicatorView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_CTPositionIndicatorView_hpp)
00010 #define Apoxi_CTPositionIndicatorView_hpp
00011
00012 #include <Gui/PositionIndicator.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultPositionIndicatorView
00016     ------------------------------------------------------------------------*/
00017 class CTPositionIndicatorView : public PositionIndicatorView {
00018     typedef PositionIndicatorView Base;
00019
00020     public:
00021         CTPositionIndicatorView();
00022         explicit CTPositionIndicatorView(XYDIM size);
00023         virtual ~CTPositionIndicatorView() {}
00024
00032         void SetPosIndSize(XYDIM size);
00033
00034     protected:
00036         virtual void DrawPositionIndicator(const PositionIndicator& pos_ind, DeviceContext* dc, const Rect& repaint_rect) const;
00037 };
00038
00039 #endif  // Apoxi_CTPositionIndicatorView_hpp
00040
00041
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPreComp.cpp File Reference

GlobalThemes/CustomizableTheme/CTPreComp.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"

Include dependency graph for CTPreComp.cpp:

Generated on Tue Jan 24 20:35:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPreComp.hpp File Reference

GlobalThemes/CustomizableTheme/CTPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for CTPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:35:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPreComp.hpp Source File

GlobalThemes/CustomizableTheme/CTPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTProgressBarView.cpp File Reference

GlobalThemes/CustomizableTheme/CTProgressBarView.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CTProgressBarView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/DisplayConfig.hpp"
#include "Config/FontConfig.hpp"
#include "CustomizableTheme.hpp"

Include dependency graph for CTProgressBarView.cpp:

Generated on Tue Jan 24 20:35:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTProgressBarView.hpp File Reference

GlobalThemes/CustomizableTheme/CTProgressBarView.hpp File Reference

#include <Gui/ProgressBar.hpp>

Include dependency graph for CTProgressBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CTProgressBarView

Defines

#define | Apoxi_CTProgressBarView_hpp

Define Documentation

#define Apoxi_CTProgressBarView_hpp

Generated on Tue Jan 24 20:35:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTProgressBarView.hpp Source File

GlobalThemes/CustomizableTheme/CTProgressBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_CTProgressBarView_hpp)
00010 #define Apoxi_CTProgressBarView_hpp
00011
00012 #include <Gui/ProgressBar.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     CTProgressBarView
00016     ------------------------------------------------------------------------*/
00017 class CTProgressBarView : public ProgressBarView {
00018     typedef ProgressBarView Base;
00019
00020     public:
00021         CTProgressBarView();
00022         explicit CTProgressBarView(XYDIM default_height);
00023         virtual void Update(const Theme& theme);
00024         virtual ~CTProgressBarView() {}
00025
00033         void SetDefaultProgressBarHeight(XYDIM height);
00034
00035     protected:
00036         virtual void DrawProgressBar(const ProgressBar& progress_bar, DeviceContext* dc, const Rect& repaint_rect) const;
00037
00038     private:
00039         static WString m_percent_str;
00040         mutable XYDIM m_throbber;
00041
00042 };
00043
00044 #endif  // Apoxi_CTProgressBarView_hpp
00045
00046
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPushButtonView.cpp File Reference

GlobalThemes/CustomizableTheme/CTPushButtonView.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CTPushButtonView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/DisplayConfig.hpp"
#include "Config/FontConfig.hpp"
#include "CustomizableTheme.hpp"

Include dependency graph for CTPushButtonView.cpp:

Generated on Tue Jan 24 20:35:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPushButtonView.hpp File Reference

GlobalThemes/CustomizableTheme/CTPushButtonView.hpp File Reference

#include <Gui/PushButton.hpp>

Include dependency graph for CTPushButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CTPushButtonView

Defines

#define | Apoxi_CTPushButtonView_hpp

Define Documentation

#define Apoxi_CTPushButtonView_hpp

Generated on Tue Jan 24 20:35:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTPushButtonView.hpp Source File

GlobalThemes/CustomizableTheme/CTPushButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_CTPushButtonView_hpp)
00010 #define Apoxi_CTPushButtonView_hpp
00011
00012 #include <Gui/PushButton.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     CTPushButtonView
00016     ------------------------------------------------------------------------*/
00017 class CTPushButtonView : public PushButtonView {
00018     typedef PushButtonView Base;
00019
00020     public:
00021         CTPushButtonView();
00022
00023         explicit CTPushButtonView(XYDIM default_height);
00024
00025         virtual ~CTPushButtonView() {}
00026
00027         virtual void Update(const Theme& theme);
00028
00036         void SetDefaultPushButtonHeight(XYDIM height);
00037
00038     protected:
00039         virtual void DrawPushButton(const PushButton& push_button, DeviceContext* dc, const Rect& repaint_rect) const;
00040
00041 };
00042
00043 #endif  // Apoxi_CTPushButtonView_hpp
00044
00045
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTResourcePack.cpp File Reference

GlobalThemes/CustomizableTheme/CTResourcePack.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CTResourcePack.hpp"
#include <Gui/BitmapDc.hpp>
#include <Auxiliary/ChildBinData.hpp>
#include <AddOns/MultiMedia/GifImage.hpp>
#include <AddOns/MultiMedia/ImageFactory.hpp>
#include <Config/Resources/checked_checkbox.hpp>
#include <Config/Resources/unchecked_checkbox.hpp>
#include <Config/Resources/checked_radiobutton.hpp>
#include <Config/Resources/unchecked_radiobutton.hpp>

Include dependency graph for CTResourcePack.cpp:

Generated on Tue Jan 24 20:35:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTResourcePack.hpp File Reference

GlobalThemes/CustomizableTheme/CTResourcePack.hpp File Reference

#include <Gui/Bitmap.hpp>
#include <Gui/ColorTable.hpp>

Include dependency graph for CTResourcePack.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CTResourcePack
struct | CTResourcePack::CommonProperties

Defines

#define | Apoxi_CTResourcePack_hpp

Define Documentation

#define Apoxi_CTResourcePack_hpp

Generated on Tue Jan 24 20:35:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTResourcePack.hpp Source File

GlobalThemes/CustomizableTheme/CTResourcePack.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_CTResourcePack_hpp)
00010 #define Apoxi_CTResourcePack_hpp
00011
00012 #include <Gui/Bitmap.hpp>
00013 #include <Gui/ColorTable.hpp>
00014
00015 class CTResourceParser;
00016
00017 /*  ------------------------------------------------------------------------
00018     CTResourcePack
00019     ------------------------------------------------------------------------*/
00020 class CTResourcePack {
00021
00022     public:
00023         CTResourcePack();
00024         ~CTResourcePack();
00025
00026         enum LightOriginType {
00027             LowerLeft,
00028             LowerRight,
00029             UpperLeft,
00030             UpperRight
00031         };
00032
00033         enum CornerModeType {
00034             Angular,
00035             Rounded                             // NSY (Not Supported Yet)
00036         };
00037
00038         enum BorderModeType {
00039             Flat,
00040             Raised,         // raised control
00041             RaisedBorder,   // raised border    // NSY
00042             Sunken,
00043             SunkenBorder                        // NSY
00044         };
00045
00046         enum ProgressBarDrawModeType {
00047             DrawPrimitives,
00048             DrawBitmap
00049         };
00050
00051         enum ResourceType {
00052             Global = 0,
00053
00054             ControlFrameControl,
00055
00056             WindowFrameControl,
00057             WindowTitleBarControl,
00058
00059             InactiveWindowFrameControl,
00060             InactiveWindowTitleBarControl,
00061
00062             SoftkeyBarControl,
00063             SoftkeyBarButtonsControl,
00064
00065             ProgressBarControl,
00066             ProgressBarBarControl,
00067
00068             PushButtonControl,
00069
00070             PositionIndicatorControl,
00071             PositionIndicatorBarControl,
00072             PositionIndicatorArrowBoxControl
00073         };
00074
00075         enum PropertyType {
00076             UnknownPropertyType = 255,
00077             SubComponentPropertyType,
00078
00079             // global properties
00080             SystemColorTable = 0,           // ColorTable
00081             ThemeName,
00082
00083             ClientBackgroundColor,          // Color
00084             ClientForegroundColor,          // Color
00085             ActiveFrameBackgroundColor,     // Color
00086             ActiveFrameForegroundColor,     // Color
00087             InactiveFrameBackgroundColor,   // Color
00088             InactiveFrameForegroundColor,   // Color
00089             SelectionBackgroundColor,       // Color
00090             SelectionForegroundColor,       // Color
00091             ShadedColor,                    // Color
00092             ButtonBackgroundColor,          // Color
00093             ButtonForegroundColor,          // Color
00094             ContextMenuBackgroundColor,     // Color
00095
00096             LightOrigin,                    // LightOriginType
00097             DropShadowWidth,                // XYDIM
00098             DropShadowDistance,             // XYDIM
00099             DropShadowColor,                // Color
00100             DropShadowMaxAlpha,             // UINT8
00101             DropShadowMinAlpha,             // UINT8
00102
00103             BackgroundDim,                  // BOOLEAN  // NSY
00104
00105             SelectedCheckBoxBitmapUri,      // WString
00106             DeselectedCheckBoxBitmapUri,    // WString
00107             SelectedRadioButtonBitmapUri,   // WString
00108             DeselectedRadioButtonBitmapUri, // WString
00109
00110             SelectedCheckBoxBitmap,         // BitmapRes
00111             DeselectedCheckBoxBitmap,       // BitmapRes
00112             SelectedRadioButtonBitmap,      // BitmapRes
00113             DeselectedRadioButtonBitmap,    // BitmapRes
00114
00115             // common component properties
00116             BorderMode,                     // BorderModeType
00117             BorderWidth,                    // XYDIM
00118             OuterBorderWidth,               // XYDIM
00119             BorderCornerMode,               // CornerModeType
00120             RoundedCornerRadius,            // XYDIM
00121             DropShadowEnabled,              // BOOLEAN
00122             ComponentForegroundColor,       // Color
00123             ComponentBackgroundColor,       // Color
00124             OuterBorderColor,               // Color
00125             InnerBorderColor,               // Color
00126             LightColor,                     // Color
00127             DarkerLightColor,               // Color
00128             LightShadow,                    // Color
00129             DarkShadow,                     // Color
00130
00131             // component specific properties
00132             // WindowTitlebar
00133             TitleBarHeight,                 // XYDIM
00134             TitleBarBitmapUri,              // WString
00135             TitleBarBitmap,                 // Bitmap
00136             InactiveTitleBarHeight,         // XYDIM
00137             InactiveTitleBarBitmapUri,      // WString
00138             InactiveTitleBarBitmap,         // Bitmap
00139
00140             // Panel
00141             // Softkeys
00142             SoftkeyBarHeight,               // XYDIM
00143             SoftkeyBarButtonSpacing,        // XYDIM
00144             SoftkeyBarBackgroundBitmapUri,  // WString
00145             SoftkeyBarBackgroundBitmap,     // Bitmap
00146             SoftkeyBarButton1BitmapUri,     // WString
00147             SoftkeyBarButton1Bitmap,        // Bitmap
00148             SoftkeyBarButton2BitmapUri,     // WString
00149             SoftkeyBarButton2Bitmap,        // Bitmap
00150             // Navigation guidance
00151             SoftkeyBarNavGuideEnabled,      // BOOLEAN
00152             SoftkeyBarNavGuideActiveColor,  // Color
00153             SoftkeyBarNavGuideInactiveColor,// Color
00154
00155             ProgressBarDrawingMode,         // ProgressBarDrawModeType
00156             ProgressBarBitmap,              // BOOLEAN
00157             ProgressBarDrawPercentage,      // BOOLEAN
00158             ProgressBarHeight,              // XYDIM
00159
00160             PushButtonHeight,               // XYDIM
00161
00162             PositionIndicatorWidth,         // XYDIM
00163             PositionIndicatorDrawArrows,    // BOOLEAN
00164             PositionIndicatorArrowHeight,   // XYDIM
00165
00166             TextFormatProp,                 // TextFormat
00167             TextAlignProp,                  // TextFormat::TextAlign
00168             TextAttrProp,                   // TextFormat::TextAttr
00169             FontAlignProp                   // TextFormat::FontAlign
00170         };
00171
00172         enum ParseType {
00173             UnknownParseType,
00174             BooleanParseType,
00175             XyDimParseType,
00176             IntegerParseType,
00177             UInt8ParseType,
00178             UInt16ParseType,
00179             WStringParseType,
00180             ColorParseType,
00181             LightOriginParseType,
00182             CornerModeParseType,
00183             BorderModeParseType,
00184             ProgressBarDrawModeParseType,
00185             TextAttrParseType,
00186             TextAlignParseType,
00187             FontAlignParseType
00188         };
00189
00190         void InitProperties();
00191
00192         void* GetProperty(ResourceType resource, PropertyType property);
00193
00197         BOOLEAN SetProperty(ResourceType resource, PropertyType property, void* data);
00198
00199         WString GetResourceUri() const { return m_resource_uri; }
00200
00201         void SetResourceUri(const WString& resource_uri) { m_resource_uri = resource_uri; }
00202
00203         BOOLEAN ReadProperties(CTResourceParser& parser);
00204
00207         BOOLEAN CustomizedDataAvailable() { return m_customized_data_available; }
00208
00210         WString GetName() const { return m_name; }
00211
00212     private:
00213
00214         WString m_resource_uri;
00215
00216         static CTResourcePack::ResourceType MapIdToResourceType (INT id);
00217
00218         static CTResourcePack::PropertyType MapIdToPropertyType (INT id);
00219
00220         static CTResourcePack::ParseType MapPropertyToParseType (PropertyType prop_id);
00221
00222         BOOLEAN ReadNextProperty(CTResourceParser& parser, CTResourcePack::ResourceType resource_id, CTResourcePack::PropertyType property_id);
00223
00225         BOOLEAN IsCommonProperty(PropertyType property);
00226
00227         Bitmap* GenerateBitmap(const WString& uri);
00228
00229         void Cleanup();
00230
00234         BOOLEAN m_customized_data_available;
00235         WString m_name;
00236
00237         Palette* m_cust_system_colors;
00238         ColorTable m_cust_system_color_table;
00239
00240         CTResourcePack::LightOriginType m_light_origin;
00241
00242         CTResourcePack::CornerModeType m_border_corners;
00243
00244         XYDIM m_dropshadow_width;
00245         XYDIM m_dropshadow_distance;
00246         Color m_dropshadow_color;
00247         UINT8 m_dropshadow_max_alpha;
00248         UINT8 m_dropshadow_min_alpha;
00249
00250         BOOLEAN m_background_dim_enabled;
00251
00252         // checkbox / radiobutton bitmap properties
00253         WString m_selected_checkbox_bmp_uri;
00254         BitmapRes* m_selected_checkbox_bmp;
00255
00256         WString m_deselected_checkbox_bmp_uri;
00257         BitmapRes* m_deselected_checkbox_bmp;
00258
00259         WString m_selected_radiobutton_bmp_uri;
00260         BitmapRes* m_selected_radiobutton_bmp;
00261
00262         WString m_deselected_radiobutton_bmp_uri;
00263         BitmapRes* m_deselected_radiobutton_bmp;
00264
00265         struct CommonProperties {
00266             BorderModeType m_border_mode;
00267             XYDIM m_border_width;
00268             XYDIM m_outer_width;
00269             CornerModeType m_corner_mode;
00270             XYDIM m_round_corner_radius;
00271             BOOLEAN m_dropshadow_enabled;
00272             Color m_fg_color;
00273             Color m_bg_color;
00274             Color m_outer_border_color;
00275             Color m_inner_border_color;
00276             Color m_light;
00277             Color m_darker_light;
00278             Color m_light_shadow;
00279             Color m_dark_shadow;
00280         };
00281
00282         CommonProperties m_windowframe_props;
00283         CommonProperties m_window_titlebar_props;
00284         XYDIM m_window_titlebar_height;
00285         // window titlebar bitmap properties
00286         WString m_window_titlebar_bmp_uri;
00287         Bitmap* m_window_titlebar_bmp;
00288         TextFormat m_window_titlebar_textformat;
00289
00290         CommonProperties m_inactive_windowframe_props;
00291         CommonProperties m_inactive_window_titlebar_props;
00292         XYDIM m_inactive_window_titlebar_height;
00293         // inactive window titlebar bitmap properties
00294         WString m_inactive_window_titlebar_bmp_uri;
00295         Bitmap* m_inactive_window_titlebar_bmp;
00296         TextFormat m_inactive_window_titlebar_textformat;
00297
00298         // Softkeybar
00299         CommonProperties m_softkeybar_props;
00300         XYDIM m_softkeybar_height;
00301         XYDIM m_softkeybar_button_spacing;
00302         WString m_softkeybar_background_bmp_uri;
00303         Bitmap* m_softkeybar_background_bmp;
00304         // nav guide specific properties
00305         BOOLEAN m_softkeybar_navguide_enabled;
00306         Color m_softkeybar_navguide_active_color;
00307         Color m_softkeybar_navguide_inactive_color;
00308
00309         CommonProperties m_softkeybar_buttons_props;
00310         TextFormat m_softkeybar_buttons_textformat;
00311         // softkeybar bitmap properties
00312         WString m_softkeybar_button_1_bmp_uri;
00313         Bitmap* m_softkeybar_button_1_bmp;
00314         WString m_softkeybar_button_2_bmp_uri;
00315         Bitmap* m_softkeybar_button_2_bmp;
00316
00317         CommonProperties m_progressbar_props;
00318         XYDIM m_progressbar_height;
00319         CTResourcePack::ProgressBarDrawModeType m_progressbar_draw_mode;
00320         Bitmap* m_progressbar_bitmap;
00321         BOOLEAN m_progressbar_draw_percentage;
00322         TextFormat m_progressbar_textformat;
00323
00324         CommonProperties m_progressbar_bar_props;
00325
00326         CommonProperties m_controlframe_props;
00327
00328         CommonProperties m_pushbutton_props;
00329         XYDIM m_pushbutton_height;
00330         TextFormat m_pushbutton_textformat;
00331
00332         CommonProperties m_positionindicator_props;
00333         XYDIM m_positionindicator_width;
00334         BOOLEAN m_positionindicator_draw_arrows;
00335
00336         CommonProperties m_positionindicatorbar_props;
00337
00338         CommonProperties m_positionindicator_arrowbox_props;
00339         XYDIM m_positionindicator_arrowbox_height;
00340
00341         friend class CTResourceParser;
00342 };
00343
00344 #endif  // Apoxi_CTResourcePack_hpp
00345
00346
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTResourceParser.cpp File Reference

GlobalThemes/CustomizableTheme/CTResourceParser.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CTResourceParser.hpp"

Include dependency graph for CTResourceParser.cpp:

Generated on Tue Jan 24 20:35:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTResourceParser.hpp File Reference

GlobalThemes/CustomizableTheme/CTResourceParser.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_CTResourceParser_hpp

Define Documentation

#define Apoxi_CTResourceParser_hpp

Generated on Tue Jan 24 20:35:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTResourceParser.hpp Source File

GlobalThemes/CustomizableTheme/CTResourceParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CTResourceParser_hpp)
00010 #define Apoxi_CTResourceParser_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015
00016 #include "CTResourcePack.hpp"
00017
00021 class CTResourceParser {
00022     public:
00023
00024         CTResourceParser(BinData* bin_data, const WString& resource_uri);
00025
00026         ~CTResourceParser();
00027
00029         void Release();
00030
00031         WString GetResourceUri() const { return m_resource_uri; }
00032
00038         BOOLEAN GetPropertyValue(CTResourcePack::ParseType parse_type, void* value);
00039
00040         UINT32 GetPos() const { return m_pos; }
00041
00042         void SetPos(UINT32 pos) { m_pos = pos; }
00043
00044         BOOLEAN Skip(UINT32 bytes);
00045
00046         UINT32 ReadCompressedLength();
00047
00048         BOOLEAN ReadBoolean();
00049
00050         WString ReadWString();
00051
00052         UINT8 ReadUInt8();
00053         UINT16 ReadUInt16();
00054         UINT32 ReadUInt32();
00055
00056         INT8 ReadInt8();
00057         INT16 ReadInt16();
00058         INT32 ReadInt32();
00059
00060     private:
00061         WString m_resource_uri;
00062         BinData* m_bin_data;
00063         UINT32 m_pos;
00064 };
00065
00067 #endif // DOXYGEN_SHOULD_SKIP_THIS
00068 #endif // Apoxi_CTResourceParser_hpp
00069
00070
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTWindowFrameView.cpp File Reference

GlobalThemes/CustomizableTheme/CTWindowFrameView.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CTWindowFrameView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>
#include "CustomizableTheme.hpp"
#include <Gui/BitmapDc.hpp>
#include <AddOns/MultiMedia/GifImage.hpp>

Include dependency graph for CTWindowFrameView.cpp:

Generated on Tue Jan 24 20:35:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTWindowFrameView.hpp File Reference

GlobalThemes/CustomizableTheme/CTWindowFrameView.hpp File Reference

#include <Gui/WindowFrameView.hpp>

Include dependency graph for CTWindowFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CTWindowFrameView

Defines

#define | Apoxi_CTWindowFrameView_hpp

Define Documentation

#define Apoxi_CTWindowFrameView_hpp

Generated on Tue Jan 24 20:35:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CTWindowFrameView.hpp Source File

GlobalThemes/CustomizableTheme/CTWindowFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_CTWindowFrameView_hpp)
00010 #define Apoxi_CTWindowFrameView_hpp
00011
00012 #include <Gui/WindowFrameView.hpp>
00013
00014 class CTWindowFrameView : public WindowFrameView {
00015     typedef WindowFrameView Base;
00016
00017     public:
00018         CTWindowFrameView();
00019         CTWindowFrameView(XYDIM left_size,
00020                           XYDIM top_size,
00021                           XYDIM right_size,
00022                           XYDIM bottom_size,
00023                           XYDIM title_height,
00024                           XYDIM softkey_bar_height);
00025
00026         virtual ~CTWindowFrameView();
00027
00035         void SetDimensions(XYDIM left_size,
00036                            XYDIM top_size,
00037                            XYDIM right_size,
00038                            XYDIM bottom_size,
00039                            XYDIM title_height,
00040                            XYDIM softkey_bar_height);
00041
00042     protected:
00044         virtual void DrawControlFrame(const Control& control, DeviceContext* dc, const Rect& repaint_rect) const;
00045
00047         virtual void DrawWindowExtensions(const Window& window,  DeviceContext* dc, const Rect& repaint_rect) const;
00048
00049
00050     private:
00051         static const XYDIM c_border;
00052 };
00053
00054 #endif  // Apoxi_CTWindowFrameView_hpp
00055
00056
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CustomizableTheme.cpp File Reference

GlobalThemes/CustomizableTheme/CustomizableTheme.cpp File Reference

#include "GlobalThemes/CustomizableTheme/CTPreComp.hpp"
#include "CustomizableTheme.hpp"
#include "CTResourcePack.hpp"
#include <Gui/Color.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for CustomizableTheme.cpp:

Generated on Tue Jan 24 20:35:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CustomizableTheme.hpp File Reference

GlobalThemes/CustomizableTheme/CustomizableTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <Gui/PaintDc.hpp>
#include "CTResourcePack.hpp"
#include "CTPanelView.hpp"
#include "CTWindowFrameView.hpp"
#include "CTPositionIndicatorView.hpp"
#include "CTProgressBarView.hpp"
#include "CTPushButtonView.hpp"
#include "CTControlFrameView.hpp"

Include dependency graph for CustomizableTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CustomizableTheme

Defines

#define | Apoxi_CTTheme_hpp

Define Documentation

#define Apoxi_CTTheme_hpp

Generated on Tue Jan 24 20:35:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/CustomizableTheme/CustomizableTheme.hpp Source File

GlobalThemes/CustomizableTheme/CustomizableTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_CTTheme_hpp)
00010 #define Apoxi_CTTheme_hpp
00011
00012 #include <Gui/Theme.hpp>
00013 #include <Gui/PaintDc.hpp>
00014
00015 #include "CTResourcePack.hpp"
00016
00017 #include "CTPanelView.hpp"
00018 #include "CTWindowFrameView.hpp"
00019 #include "CTPositionIndicatorView.hpp"
00020 #include "CTProgressBarView.hpp"
00021 #include "CTPushButtonView.hpp"
00022 #include "CTControlFrameView.hpp"
00023
00024 #ifdef APOXI_COMPAT_1_9_0
00025     #include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
00026     #include <GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>
00027 #endif
00028
00029 #ifdef APOXI_COMPAT_1_7_0
00030     #include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
00031     #include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
00032     #include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
00033     #include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
00034 #endif
00035
00036 class ImageObtainer;
00037 class AbstractItemContainer;
00038
00039 /*  ------------------------------------------------------------------------
00040     CustomizableTheme
00041     ------------------------------------------------------------------------*/
00044 class CustomizableTheme : public Theme {
00045     typedef Theme Base;
00046
00047     public:
00048         virtual ~CustomizableTheme();
00049
00066         static const Theme& GetInstance(CTResourcePack* pack = 0);
00067
00072         static CTResourcePack* GetResourcePackIfActive();
00073
00075         void SetResourcePack(CTResourcePack* resource_pack) { m_resource_pack = resource_pack; }
00077         CTResourcePack* GetResourcePack() { return m_resource_pack; }
00078
00079         virtual const WCHAR* GetName() const;
00080         virtual void Update();
00081         virtual const ColorTable* GetSystemColorTable() const;
00082         virtual const WindowFrameView* GetWindowFrameView() const;
00083         virtual const ControlFrameView* GetControlFrameView() const;
00084
00085         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00086         virtual const ProgressBarView* GetProgressBarView() const;
00087         virtual const PushButtonView* GetPushButtonView() const;
00088         virtual const PanelView* GetPanelView() const;
00089
00090         virtual const BitmapRes* GetBitmap(BitmapResId id) const;
00091
00092         #ifdef APOXI_COMPAT_1_9_0
00093             virtual const TextListView* GetTextListView() const;
00094             virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00095         #endif
00096
00097         #ifdef APOXI_COMPAT_1_7_0
00098             virtual const CheckBoxView* GetCheckBoxView() const;
00099             virtual const RadioButtonView* GetRadioButtonView() const;
00100             virtual const CheckBoxListView* GetCheckBoxListView() const;
00101             virtual const RadioButtonListView* GetRadioButtonListView() const;
00102         #endif
00103
00104         static Rect AdjustBounds(const Rect& bounds, CTResourcePack* pack, CTResourcePack::ResourceType resource);
00105
00106         static void DrawComponent(PaintDc& pdc,
00107                                   const Rect& bounds,
00108                                   CTResourcePack* pack,
00109                                   CTResourcePack::ResourceType resource);
00110
00111         static WString c_theme_name;
00112
00113     private:
00114         CustomizableTheme();
00115         CustomizableTheme(CTResourcePack *resource_pack);
00116
00117         CTPanelView                 m_panel_view;
00118         CTWindowFrameView           m_window_frame_view;
00119         CTPositionIndicatorView     m_position_indicator_view;
00120         CTProgressBarView           m_progress_bar_view;
00121         CTPushButtonView            m_push_button_view;
00122         CTControlFrameView          m_control_frame_view;
00123
00124         #ifdef APOXI_COMPAT_1_9_0
00125             DefaultTextListView             m_text_list_view;
00126             DefaultSoftkeyBarView           m_softkey_bar_view;
00127         #endif
00128
00129         #ifdef APOXI_COMPAT_1_7_0
00130             DefaultCheckBoxView             m_check_box_view;
00131             DefaultRadioButtonView          m_radio_button_view;
00132             DefaultCheckBoxListView         m_check_box_list_view;
00133             DefaultRadioButtonListView      m_radio_button_list_view;
00134         #endif
00135
00136         static void DrawAngularBorderComponent(PaintDc& pdc,
00137                                                const Rect& bounds_param,
00138                                                CTResourcePack* pack,
00139                                                CTResourcePack::ResourceType resource);
00140
00141         static void DrawRoundedBorderComponent(PaintDc& pdc,
00142                                              const Rect& bounds_param,
00143                                              CTResourcePack* pack,
00144                                              CTResourcePack::ResourceType resource);
00145
00146         void UpdateProperties();
00147
00148         static CTResourcePack c_default_pack;
00149         static CustomizableTheme m_instance;
00150         CTResourcePack* m_resource_pack;
00151 };
00152
00153 #endif
00154
00155
Generated on Tue Jan 24 14:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultCheckBoxListView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultCheckBoxListView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultCheckBoxListView.hpp"
#include <Gui/PaintDc.hpp>
#include <Gui/CheckBoxItem.hpp>
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultCheckBoxListView.cpp:

Generated on Tue Jan 24 20:18:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp File Reference

#include <Gui/CheckBoxList.hpp>

Include dependency graph for DefaultCheckBoxListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultCheckBoxListView
Obsolete since APOXI-1.6.2. More...

Defines

#define | Apoxi_DefaultCheckBoxListView_hpp

Define Documentation

#define Apoxi_DefaultCheckBoxListView_hpp

Generated on Tue Jan 24 20:18:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp Source File

GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultCheckBoxListView_hpp)
00010 #define Apoxi_DefaultCheckBoxListView_hpp
00011
00012 #include <Gui/CheckBoxList.hpp>
00013
00015 class DefaultCheckBoxListView : public CheckBoxListView {
00016     typedef CheckBoxListView Base;
00017
00018     public:
00019         DefaultCheckBoxListView();
00020         DefaultCheckBoxListView(CheckBoxView* cb_view, XYDIM item_height);
00021         virtual void Update(const Theme& theme);
00022         virtual ~DefaultCheckBoxListView() {}
00023
00024     protected:
00025         virtual void DrawCheckBoxItem(const CheckBoxItem& item, DeviceContext* dc, const Rect& item_rect, BOOLEAN highlighted) const;
00026 };
00027
00028 #endif  // Apoxi_DefaultCheckBoxListView_hpp
00029
00030
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultCheckBoxView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultCheckBoxView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include <Gui/Bitmap.hpp>
#include <Gui/Locale.hpp>
#include "DefaultCheckBoxView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/Resources/checked_checkbox.hpp>
#include <Config/Resources/unchecked_checkbox.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for DefaultCheckBoxView.cpp:

Generated on Tue Jan 24 20:18:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp File Reference

#include <Gui/CheckBox.hpp>

Include dependency graph for DefaultCheckBoxView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultCheckBoxView
Obsolete since APOXI-1.6.2. More...

Defines

#define | Apoxi_DefaultCheckBoxView_hpp

Define Documentation

#define Apoxi_DefaultCheckBoxView_hpp

Generated on Tue Jan 24 20:18:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp Source File

GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultCheckBoxView_hpp)
00010 #define Apoxi_DefaultCheckBoxView_hpp
00011
00012 #include <Gui/CheckBox.hpp>
00013
00015 class DefaultCheckBoxView : public CheckBoxView {
00016     typedef CheckBoxView Base;
00017
00018     public:
00019         DefaultCheckBoxView();
00020         DefaultCheckBoxView(XYDIM default_height, XYDIM left_gap, XYDIM middle_gap);
00021         virtual void Update(const Theme& theme);
00022         virtual ~DefaultCheckBoxView() {}
00023
00024     protected:
00025         virtual void DrawCheckBox(const CheckBoxModel& model, DeviceContext* dc, const Rect& repaint_rect) const;
00026         virtual void DrawShiftedCheckBox(const Rect& shift_rect, const CheckBoxModel& model, DeviceContext* dc, const Rect& repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_DefaultCheckBoxView_hpp
00030
00031
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultControlFrameView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultControlFrameView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultControlFrameView.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for DefaultControlFrameView.cpp:

Generated on Tue Jan 24 20:18:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp File Reference

#include <Gui/ControlFrameView.hpp>

Include dependency graph for DefaultControlFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultControlFrameView

Defines

#define | Apoxi_DefaultControlFrameView_hpp

Define Documentation

#define Apoxi_DefaultControlFrameView_hpp

Generated on Tue Jan 24 20:18:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp Source File

GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultControlFrameView_hpp)
00010 #define Apoxi_DefaultControlFrameView_hpp
00011
00012 #include <Gui/ControlFrameView.hpp>
00013
00014 class DefaultControlFrameView : public ControlFrameView {
00015     typedef ControlFrameView Base;
00016
00017     public:
00018         DefaultControlFrameView();
00019         DefaultControlFrameView(XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size);
00020         virtual void Update(const Theme& theme);
00021         virtual ~DefaultControlFrameView();
00022
00023     protected:
00024         virtual void DrawControlFrame(const Control& control, DeviceContext* dc, const Rect& repaint_rect) const;
00025 };
00026
00027 #endif  // Apoxi_DefaultControlFrameView_hpp
00028
00029
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPanelView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultPanelView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultPanelView.hpp"
#include <Gui/TextFormat.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/DeviceContext.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for DefaultPanelView.cpp:

Generated on Tue Jan 24 20:35:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPanelView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultPanelView.hpp File Reference

#include <Gui/Panel.hpp>

Include dependency graph for DefaultPanelView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultPanelView

Defines

#define | Apoxi_DefaultPanelView_hpp

Define Documentation

#define Apoxi_DefaultPanelView_hpp

Generated on Tue Jan 24 20:35:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPanelView.hpp Source File

GlobalThemes/DefaultTheme/DefaultPanelView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultPanelView_hpp)
00010 #define Apoxi_DefaultPanelView_hpp
00011
00012 #include <Gui/Panel.hpp>
00013
00014 class DefaultPanelView : public PanelView {
00015     typedef PanelView Base;
00016
00017     public:
00018         virtual ~DefaultPanelView();
00019         virtual void Update(const Theme& theme);
00020
00021     protected:
00022         virtual void DrawPanel(const Panel& panel, DeviceContext* dc, const Rect& repaint_rect) const;
00023 };
00024
00025 #endif  // Apoxi_DefaultPanelView_hpp
00026
00027
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultPositionIndicatorView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for DefaultPositionIndicatorView.cpp:

Generated on Tue Jan 24 20:19:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp File Reference

#include <Gui/PositionIndicator.hpp>

Include dependency graph for DefaultPositionIndicatorView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultPositionIndicatorView

Defines

#define | Apoxi_DefaultPositionIndicatorView_hpp

Define Documentation

#define Apoxi_DefaultPositionIndicatorView_hpp

Generated on Tue Jan 24 20:19:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp Source File

GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultPositionIndicatorView_hpp)
00010 #define Apoxi_DefaultPositionIndicatorView_hpp
00011
00012 #include <Gui/PositionIndicator.hpp>
00013
00014 class DefaultPositionIndicatorView : public PositionIndicatorView {
00015     typedef PositionIndicatorView Base;
00016
00017     public:
00018         DefaultPositionIndicatorView();
00019         explicit DefaultPositionIndicatorView(XYDIM size);
00020         virtual ~DefaultPositionIndicatorView() {}
00021
00022     protected:
00023         virtual void DrawPositionIndicator(const PositionIndicator& pos_ind, DeviceContext* dc, const Rect& repaint_rect) const;
00024 };
00025
00026 #endif  // Apoxi_DefaultPositionIndicatorView_hpp
00027
00028
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultProgressBarView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultProgressBarView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultProgressBarView.hpp"
#include "Gui/PaintDc.hpp"
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for DefaultProgressBarView.cpp:

Generated on Tue Jan 24 20:19:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp File Reference

#include <Gui/ProgressBar.hpp>

Include dependency graph for DefaultProgressBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultProgressBarView

Defines

#define | Apoxi_DefaultProgressBarView_hpp

Define Documentation

#define Apoxi_DefaultProgressBarView_hpp

Generated on Tue Jan 24 20:19:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp Source File

GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultProgressBarView_hpp)
00010 #define Apoxi_DefaultProgressBarView_hpp
00011
00012 #include <Gui/ProgressBar.hpp>
00013
00014 class DefaultProgressBarView : public ProgressBarView {
00015     typedef ProgressBarView Base;
00016
00017     public:
00018         DefaultProgressBarView();
00019         explicit DefaultProgressBarView(XYDIM default_height);
00020         virtual void Update(const Theme& theme);
00021         virtual ~DefaultProgressBarView() {}
00022
00023     protected:
00024         virtual void DrawProgressBar(const ProgressBar& progress_bar, DeviceContext* dc, const Rect& repaint_rect) const;
00025
00026     private:
00027         static WString m_percent_str;
00028
00029 };
00030
00031 #endif  // Apoxi_DefaultProgressBarView_hpp
00032
00033
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPushButtonView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultPushButtonView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultPushButtonView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for DefaultPushButtonView.cpp:

Generated on Tue Jan 24 20:19:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp File Reference

#include <Gui/PushButton.hpp>

Include dependency graph for DefaultPushButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultPushButtonView

Defines

#define | Apoxi_DefaultPushButtonView_hpp

Define Documentation

#define Apoxi_DefaultPushButtonView_hpp

Generated on Tue Jan 24 20:19:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp Source File

GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultPushButtonView_hpp)
00010 #define Apoxi_DefaultPushButtonView_hpp
00011
00012 #include <Gui/PushButton.hpp>
00013
00014 class DefaultPushButtonView : public PushButtonView {
00015     typedef PushButtonView Base;
00016
00017     public:
00018         DefaultPushButtonView();
00019         explicit DefaultPushButtonView(XYDIM default_height);
00020         virtual ~DefaultPushButtonView() {}
00021         virtual void Update(const Theme& theme);
00022
00023     protected:
00024         virtual void DrawPushButton(const PushButton& push_button, DeviceContext* dc, const Rect& repaint_rect) const;
00025 };
00026
00027 #endif  // Apoxi_DefaultPushButtonView_hpp
00028
00029
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultRadioButtonListView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultRadioButtonListView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultRadioButtonListView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for DefaultRadioButtonListView.cpp:

Generated on Tue Jan 24 20:19:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp File Reference

#include <Gui/RadioButtonList.hpp>

Include dependency graph for DefaultRadioButtonListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultRadioButtonListView
Obsolete since APOXI-1.6.2. More...

Defines

#define | Apoxi_DefaultRadioButtonListView_hpp

Define Documentation

#define Apoxi_DefaultRadioButtonListView_hpp

Generated on Tue Jan 24 20:19:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp Source File

GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultRadioButtonListView_hpp)
00010 #define Apoxi_DefaultRadioButtonListView_hpp
00011
00012 #include <Gui/RadioButtonList.hpp>
00013
00015 class DefaultRadioButtonListView : public RadioButtonListView {
00016     typedef RadioButtonListView Base;
00017
00018     public:
00019         DefaultRadioButtonListView();
00020         DefaultRadioButtonListView(const RadioButtonView* rb_view, XYDIM item_height);
00021
00022         virtual void Update(const Theme& theme);
00023
00024         virtual ~DefaultRadioButtonListView() {}
00025
00026     protected:
00027         virtual void DrawRadioButtonItem(const RadioButtonItem& item, DeviceContext* dc, const Rect& item_rect, BOOLEAN highlighted) const;
00028 };
00029
00030 #endif  // Apoxi_DefaultRadioButtonListView_hpp
00031
00032
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultRadioButtonView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultRadioButtonView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultRadioButtonView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/Resources/checked_radiobutton.hpp>
#include <Config/Resources/unchecked_radiobutton.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for DefaultRadioButtonView.cpp:

Generated on Tue Jan 24 20:19:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp File Reference

#include <Gui/RadioButton.hpp>

Include dependency graph for DefaultRadioButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultRadioButtonView
Obsolete since APOXI-1.6.2. More...

Defines

#define | Apoxi_DefaultRadioButtonView_hpp

Define Documentation

#define Apoxi_DefaultRadioButtonView_hpp

Generated on Tue Jan 24 20:19:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp Source File

GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultRadioButtonView_hpp)
00010 #define Apoxi_DefaultRadioButtonView_hpp
00011
00012 #include <Gui/RadioButton.hpp>
00013
00015 class DefaultRadioButtonView : public RadioButtonView{
00016     typedef RadioButtonView Base;
00017
00018     public:
00019         DefaultRadioButtonView();
00020         DefaultRadioButtonView(XYDIM item_height, XYDIM left_gap, XYDIM middle_gap);
00021         virtual void Update(const Theme& theme);
00022         virtual ~DefaultRadioButtonView() {}
00023
00024     protected:
00025         virtual void DrawRadioButton(const RadioButtonModel& model, DeviceContext* dc, const Rect& repaint_rect) const;
00026         virtual void DrawShiftedRadioButton(const Rect& shift_rect, const RadioButtonModel& model, DeviceContext* dc, const Rect& repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_DefaultRadioButtonView_hpp
00030
00031
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultSoftkeyBarView.hpp"
#include "Gui/TextFormat.hpp"
#include "Gui/PaintDc.hpp"
#include "Gui/DeviceContext.hpp"
#include "Config/DisplayConfig.hpp"

Include dependency graph for DefaultSoftkeyBarView.cpp:

Generated on Tue Jan 24 20:19:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp File Reference

#include <Gui/SoftkeyBar.hpp>

Include dependency graph for DefaultSoftkeyBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultSoftkeyBarView

Defines

#define | Apoxi_DefaultSoftkeyBarView_hpp

Define Documentation

#define Apoxi_DefaultSoftkeyBarView_hpp

Generated on Tue Jan 24 20:19:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp Source File

GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultSoftkeyBarView_hpp)
00010 #define Apoxi_DefaultSoftkeyBarView_hpp
00011
00012 #include <Gui/SoftkeyBar.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultSoftkeyBarView
00016     ------------------------------------------------------------------------*/
00017 class DefaultSoftkeyBarView : public SoftkeyBarView {
00018     //typedef SoftkeyBarView Base;
00019
00020     public:
00021         virtual ~DefaultSoftkeyBarView() {}
00022
00023     protected:
00024         virtual void DrawSoftkeyBar(const SoftkeyBar& softkey_bar, DeviceContext* dc, const Rect& repaint_rect) const;
00025 };
00026
00027 #endif  // Apoxi_DefaultSoftkeyBarView_hpp
00028
00029
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTabButtonView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultTabButtonView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultTabButtonView.hpp"
#include <Gui/TabControl.hpp>
#include <Config/OptionalConfig.hpp>

Include dependency graph for DefaultTabButtonView.cpp:

Generated on Tue Jan 24 20:35:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp File Reference

#include <Gui/TabButton.hpp>

Include dependency graph for DefaultTabButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultTabButtonView
Implements the drawing of the TabButton. More...

Defines

#define | Apoxi_DefaultTabButtonView_hpp

Define Documentation

#define Apoxi_DefaultTabButtonView_hpp

Generated on Tue Jan 24 20:35:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp Source File

GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultTabButtonView_hpp)
00010 #define Apoxi_DefaultTabButtonView_hpp
00011
00012 #if !defined(APOXI_DISABLE_TAB_CONTROL)
00013
00014 #include <Gui/TabButton.hpp>
00015
00017 class DefaultTabButtonView : public TabButtonView {
00018     typedef TabButtonView Base;
00019
00020     public:
00022         DefaultTabButtonView(XYDIM default_height,
00023                              XYDIM default_width = -1,
00024                              XYDIM min_width = -1,
00025                              XYDIM max_width = -1,
00026                              XYDIM clipped_width = 20);
00027
00028         virtual ~DefaultTabButtonView();
00029
00030     protected:
00032         virtual void DrawTabButton(const TabButton& tab_button, DeviceContext* dc, const Rect& repaint_rect) const;
00033
00034     private:
00035         void DimmColor(Color& color) const;
00036         void DrawClippedArea(const TabButton& tab_button, DeviceContext* dc, BOOLEAN  left) const;
00037 };
00038
00039 #endif // APOXI_DISABLE_TAB_CONTROL
00040 #endif  // Apoxi_DefaultTabButtonView_hpp
00041
00042
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTabControlView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultTabControlView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultTabControlView.hpp"
#include <Gui/TabButton.hpp>

Include dependency graph for DefaultTabControlView.cpp:

Generated on Tue Jan 24 20:36:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTabControlView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultTabControlView.hpp File Reference

#include <Gui/TabControl.hpp>

Include dependency graph for DefaultTabControlView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultTabControlView
Implements the drawing of the TabControl. More...

Defines

#define | Apoxi_DefaultTabControlView_hpp

Define Documentation

#define Apoxi_DefaultTabControlView_hpp

Generated on Tue Jan 24 20:36:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTabControlView.hpp Source File

GlobalThemes/DefaultTheme/DefaultTabControlView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultTabControlView_hpp)
00010 #define Apoxi_DefaultTabControlView_hpp
00011
00012 #if !defined(APOXI_DISABLE_TAB_CONTROL)
00013
00014 #include <Gui/TabControl.hpp>
00015
00017 class DefaultTabControlView : public TabControlView {
00018     typedef TabControlView Base;
00019
00020     public:
00022         DefaultTabControlView(XYDIM border_size,
00023                               XYDIM header_height = -1);
00024
00025         virtual ~DefaultTabControlView();
00026
00027     protected:
00029         virtual void DrawTabControl(const TabControl& tab_control,
00030                                     DeviceContext* dc,
00031                                     const Rect& repaint_rect) const;
00032 };
00033
00034 #endif // APOXI_DISABLE_TAB_CONTROL
00035 #endif  // Apoxi_DefaultTabControlView_hpp
00036
00037
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTextListView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultTextListView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultTextListView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/FontConfig.hpp"

Include dependency graph for DefaultTextListView.cpp:

Generated on Tue Jan 24 20:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTextListView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultTextListView.hpp File Reference

#include <Gui/TextList.hpp>

Include dependency graph for DefaultTextListView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultTextListView

Defines

#define | Apoxi_DefaultTextListView_hpp

Define Documentation

#define Apoxi_DefaultTextListView_hpp

Generated on Tue Jan 24 20:20:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTextListView.hpp Source File

GlobalThemes/DefaultTheme/DefaultTextListView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultTextListView_hpp)
00010 #define Apoxi_DefaultTextListView_hpp
00011
00012 #include <Gui/TextList.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultTextListView
00016     ------------------------------------------------------------------------*/
00017 class DefaultTextListView : public TextListView {
00018     typedef TextListView Base;
00019
00020     public:
00021         DefaultTextListView();
00022         explicit DefaultTextListView(XYDIM item_height);
00023         virtual void Update(const Theme& theme);
00024         virtual ~DefaultTextListView() {}
00025
00026     protected:
00027         virtual void DrawTextListItem(const TextList& text_list, DeviceContext* dc, INT index, const Rect& item_rect) const;
00028 };
00029
00030 #endif  // Apoxi_DefaultTextListView_hpp
00031
00032
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTheme.cpp File Reference

GlobalThemes/DefaultTheme/DefaultTheme.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultTheme.hpp"
#include <Gui/Color.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/Resources/checked_checkbox.hpp>
#include <Config/Resources/unchecked_checkbox.hpp>
#include <Config/Resources/checked_radiobutton.hpp>
#include <Config/Resources/unchecked_radiobutton.hpp>

Include dependency graph for DefaultTheme.cpp:

Variables

ColorTable | c_default_system_color_table = { c_system_color, 14 }
const Palette | c_system_color []

Variable Documentation

ColorTable c_default_system_color_table = { c_system_color, 14 }

const Palette c_system_color[]

Initial value:

 {
    {255, 255, 255},
    {0, 0, 0},
    {80, 120, 200},
    {255, 255, 255},
    {221, 221, 221},
    {90, 90, 90},
    {80, 120, 200},
    {255, 255, 255},
    {128, 128, 128},
    {220, 220, 220},
    {60, 60, 60},
    {220, 220, 220},
    {255, 255, 255},
    {90, 90, 90}
    }

Generated on Tue Jan 24 20:20:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTheme.hpp File Reference

GlobalThemes/DefaultTheme/DefaultTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultPanelView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTabControlView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp>

Include dependency graph for DefaultTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_DefaultTheme_hpp

Define Documentation

#define Apoxi_DefaultTheme_hpp

Generated on Tue Jan 24 20:20:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultTheme.hpp Source File

GlobalThemes/DefaultTheme/DefaultTheme.hpp

Go to the documentation of this file.
00001
00002 /*  ------------------------------------------------------------------------
00003     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------*/
00009 #if !defined(Apoxi_DefaultTheme_hpp)
00010 #define Apoxi_DefaultTheme_hpp
00011
00012 #include <Gui/Theme.hpp>
00013
00014 #include <GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>
00015 #include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
00016
00017 #include <GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>
00018 #include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
00019 #include <GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>
00020 #include <GlobalThemes/DefaultTheme/DefaultPanelView.hpp>
00021
00022 #ifndef APOXI_DISABLE_TAB_CONTROL
00023     #include <GlobalThemes/DefaultTheme/DefaultTabControlView.hpp>
00024     #include <GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp>
00025 #endif
00026
00027 #ifdef APOXI_COMPAT_1_9_0
00028     #include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
00029     #include <GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>
00030 #endif
00031
00032 #ifdef APOXI_COMPAT_1_7_0
00033     #include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
00034     #include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
00035     #include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
00036     #include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
00037 #endif
00038
00039 class DefaultTheme : public Theme {
00040     typedef Theme Base;
00041
00042     public:
00043         static const Theme& GetInstance();
00044         virtual ~DefaultTheme();
00045
00046         virtual const WCHAR* GetName() const;
00047         virtual void Update();
00048         virtual const ColorTable* GetSystemColorTable() const;
00049         virtual const WindowFrameView* GetWindowFrameView() const;
00050         virtual const ControlFrameView* GetControlFrameView() const;
00051         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00052         virtual const ProgressBarView* GetProgressBarView() const;
00053         virtual const PushButtonView* GetPushButtonView() const;
00054         virtual const PanelView* GetPanelView() const;
00055
00056         #ifndef APOXI_DISABLE_TAB_CONTROL
00057             virtual const TabControlView* GetTabControlView() const;
00058             virtual const TabButtonView* GetTabButtonView() const;
00059         #endif
00060
00061         virtual const BitmapRes* GetBitmap(BitmapResId id) const;
00062
00063         #ifdef APOXI_COMPAT_1_9_0
00064             virtual const TextListView* GetTextListView() const;
00065             virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00066         #endif
00067
00068         #ifdef APOXI_COMPAT_1_7_0
00069             virtual const CheckBoxView* GetCheckBoxView() const;
00070             virtual const RadioButtonView* GetRadioButtonView() const;
00071             virtual const CheckBoxListView* GetCheckBoxListView() const;
00072             virtual const RadioButtonListView* GetRadioButtonListView() const;
00073         #endif
00074
00075     private:
00076         DefaultWindowFrameView m_window_frame_view;
00077         DefaultControlFrameView m_control_frame_view;
00078         DefaultPositionIndicatorView m_position_indicator_view;
00079         DefaultProgressBarView m_progress_bar_view;
00080         DefaultPushButtonView m_push_button_view;
00081         DefaultPanelView m_panel_view;
00082
00083         #ifndef APOXI_DISABLE_TAB_CONTROL
00084             DefaultTabControlView m_tab_control_view;
00085             DefaultTabButtonView m_tab_button_view;
00086         #endif
00087
00088         #ifdef APOXI_COMPAT_1_9_0
00089             DefaultTextListView m_text_list_view;
00090             DefaultSoftkeyBarView m_softkey_bar_view;
00091         #endif
00092
00093         #ifdef APOXI_COMPAT_1_7_0
00094             DefaultCheckBoxView m_check_box_view;
00095             DefaultRadioButtonView m_radio_button_view;
00096             DefaultCheckBoxListView m_check_box_list_view;
00097             DefaultRadioButtonListView m_radio_button_list_view;
00098         #endif
00099
00100         static DefaultTheme m_default_theme;
00101
00102         DefaultTheme();
00103 };
00104
00105 #ifdef APOXI_COMPAT_1_9_0
00106     #define default_theme DefaultTheme::GetInstance()
00107 #endif
00108
00109 #endif
00110
00111
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultWindowFrameView.cpp File Reference

GlobalThemes/DefaultTheme/DefaultWindowFrameView.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"
#include "DefaultWindowFrameView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for DefaultWindowFrameView.cpp:

Generated on Tue Jan 24 20:20:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp File Reference

GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp File Reference

#include <Gui/WindowFrameView.hpp>

Include dependency graph for DefaultWindowFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultWindowFrameView

Defines

#define | Apoxi_DefaultWindowFrameView_hpp

Define Documentation

#define Apoxi_DefaultWindowFrameView_hpp

Generated on Tue Jan 24 20:20:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp Source File

GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_DefaultWindowFrameView_hpp)
00010 #define Apoxi_DefaultWindowFrameView_hpp
00011
00012 #include <Gui/WindowFrameView.hpp>
00013
00015 class DefaultWindowFrameView : public WindowFrameView {
00016     typedef WindowFrameView Base;
00017
00018     public:
00019         DefaultWindowFrameView();
00020
00021         DefaultWindowFrameView(XYDIM left_size,
00022                                XYDIM top_size,
00023                                XYDIM right_size,
00024                                XYDIM bottom_size,
00025                                XYDIM title_height,
00026                                XYDIM softkey_bar_height);
00027
00028         virtual ~DefaultWindowFrameView();
00029
00031         virtual void Update(const Theme& theme);
00032
00034         virtual void DrawClientAreaBackground(const Control& control,
00035                                               DeviceContext* dc,
00036                                               const Rect& repaint_rect) const;
00037
00038     protected:
00039         virtual void DrawControlFrame(const Control& control,
00040                                       DeviceContext* dc,
00041                                       const Rect& repaint_rect) const;
00042
00043         virtual void DrawWindowExtensions(const Window& window,
00044                                           DeviceContext* dc,
00045                                           const Rect& repaint_rect) const;
00046 };
00047
00048 #endif  // Apoxi_DefaultWindowFrameView_hpp
00049
00050
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/PreComp.cpp File Reference

GlobalThemes/DefaultTheme/PreComp.cpp File Reference

#include "GlobalThemes/DefaultTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:05:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/PreComp.hpp File Reference

GlobalThemes/DefaultTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/DefaultTheme/PreComp.hpp Source File

GlobalThemes/DefaultTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008 #include <Kernel/Lib.hpp>
00009 #include <Gui/Lib.hpp>
00010
00011
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPanelView.cpp File Reference

GlobalThemes/FoggyTheme/FoggyPanelView.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"
#include "FoggyPanelView.hpp"
#include <Gui/TextFormat.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/DeviceContext.hpp>
#include <Config/Resources/softkey_left.hpp>
#include <Config/Resources/softkey_middle.hpp>
#include <Config/Resources/softkey_right.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for FoggyPanelView.cpp:

Generated on Tue Jan 24 20:36:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPanelView.hpp File Reference

GlobalThemes/FoggyTheme/FoggyPanelView.hpp File Reference

#include <Gui/Panel.hpp>

Include dependency graph for FoggyPanelView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FoggyPanelView

Defines

#define | Apoxi_FoggyPanelView_hpp

Define Documentation

#define Apoxi_FoggyPanelView_hpp

Generated on Tue Jan 24 20:36:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPanelView.hpp Source File

GlobalThemes/FoggyTheme/FoggyPanelView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_FoggyPanelView_hpp)
00010 #define Apoxi_FoggyPanelView_hpp
00011
00012 #include <Gui/Panel.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     FoggyPanelView
00016     ------------------------------------------------------------------------*/
00017 class FoggyPanelView : public PanelView {
00018     typedef PanelView Base;
00019
00020     public:
00022         virtual ~FoggyPanelView();
00023
00025         virtual void Update(const Theme& theme);
00026
00027     protected:
00029         virtual void DrawPanel(const Panel& panel, DeviceContext* dc, const Rect& repaint_rect) const;
00030
00031     private:
00033         void DrawShadedRect(DeviceContext* dc, XYDIM left, XYDIM top, XYDIM right, XYDIM bottom, UINT8 red, UINT8 green, UINT8 blue) const;
00034
00035 };
00036
00037 #endif  // Apoxi_FoggyPanelView_hpp
00038
00039
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.cpp File Reference

GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"
#include "FoggyPositionIndicatorView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/DisplayConfig.hpp"

Include dependency graph for FoggyPositionIndicatorView.cpp:

Generated on Tue Jan 24 20:36:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp File Reference

GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp File Reference

#include <Gui/PositionIndicator.hpp>

Include dependency graph for FoggyPositionIndicatorView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FoggyPositionIndicatorView

Defines

#define | Apoxi_FoggyPositionIndicatorView_hpp

Define Documentation

#define Apoxi_FoggyPositionIndicatorView_hpp

Generated on Tue Jan 24 20:36:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp Source File

GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_FoggyPositionIndicatorView_hpp)
00010 #define Apoxi_FoggyPositionIndicatorView_hpp
00011
00012 #include <Gui/PositionIndicator.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     DefaultPositionIndicatorView
00016     ------------------------------------------------------------------------*/
00017 class FoggyPositionIndicatorView : public PositionIndicatorView {
00018     typedef PositionIndicatorView Base;
00019
00020     public:
00021         FoggyPositionIndicatorView();
00022         explicit FoggyPositionIndicatorView(XYDIM size);
00023         virtual ~FoggyPositionIndicatorView() {}
00024
00025     protected:
00026         virtual void DrawPositionIndicator(const PositionIndicator& pos_ind, DeviceContext* dc, const Rect& repaint_rect) const;
00027 };
00028
00029 #endif  // Apoxi_FoggyPositionIndicatorView_hpp
00030
00031
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPushButtonView.cpp File Reference

GlobalThemes/FoggyTheme/FoggyPushButtonView.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"
#include "FoggyPushButtonView.hpp"
#include "Gui/PaintDc.hpp"
#include "Config/DisplayConfig.hpp"
#include "Config/FontConfig.hpp"

Include dependency graph for FoggyPushButtonView.cpp:

Generated on Tue Jan 24 20:36:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp File Reference

GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp File Reference

#include <Gui/PushButton.hpp>

Include dependency graph for FoggyPushButtonView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FoggyPushButtonView

Defines

#define | Apoxi_FoggyPushButtonView_hpp

Define Documentation

#define Apoxi_FoggyPushButtonView_hpp

Generated on Tue Jan 24 20:36:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp Source File

GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_FoggyPushButtonView_hpp)
00010 #define Apoxi_FoggyPushButtonView_hpp
00011
00012 #include <Gui/PushButton.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     FoggyPushButtonView
00016     ------------------------------------------------------------------------*/
00017 class FoggyPushButtonView : public PushButtonView {
00018     typedef PushButtonView Base;
00019
00020     public:
00021         FoggyPushButtonView();
00022         explicit FoggyPushButtonView(XYDIM Foggy_height);
00023         virtual ~FoggyPushButtonView() {}
00024         virtual void Update(const Theme& theme);
00025
00026     protected:
00027         virtual void DrawPushButton(const PushButton& push_button, DeviceContext* dc, const Rect& repaint_rect) const;
00028 };
00029
00030 #endif  // Apoxi_FoggyPushButtonView_hpp
00031
00032
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggySoftkeyBarView.cpp File Reference

GlobalThemes/FoggyTheme/FoggySoftkeyBarView.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"
#include "FoggySoftkeyBarView.hpp"
#include <Gui/TextFormat.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/DeviceContext.hpp>
#include <Config/Resources/softkey_left.hpp>
#include <Config/Resources/softkey_middle.hpp>
#include <Config/Resources/softkey_right.hpp>

Include dependency graph for FoggySoftkeyBarView.cpp:

Generated on Tue Jan 24 20:20:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp File Reference

GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp File Reference

#include <Gui/SoftkeyBar.hpp>

Include dependency graph for FoggySoftkeyBarView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FoggySoftkeyBarView

Defines

#define | Apoxi_FoggySoftkeyBarView_hpp

Define Documentation

#define Apoxi_FoggySoftkeyBarView_hpp

Generated on Tue Jan 24 20:20:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp Source File

GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_FoggySoftkeyBarView_hpp)
00010 #define Apoxi_FoggySoftkeyBarView_hpp
00011
00012 #include <Gui/SoftkeyBar.hpp>
00013
00014 /*  ------------------------------------------------------------------------
00015     FoggySoftkeyBarView
00016     ------------------------------------------------------------------------*/
00017 class FoggySoftkeyBarView : public SoftkeyBarView {
00018     typedef SoftkeyBarView Base;
00019
00020     public:
00022         virtual ~FoggySoftkeyBarView() {}
00023
00024     protected:
00026         virtual void DrawSoftkeyBar(const SoftkeyBar& softkey_bar, DeviceContext* dc, const Rect& repaint_rect) const;
00027
00028     private:
00030         void DrawShadedRect(DeviceContext* dc, XYDIM left, XYDIM top, XYDIM right, XYDIM bottom, UINT8 red, UINT8 green, UINT8 blue) const;
00031
00032 };
00033
00034 #endif  // Apoxi_FoggySoftkeyBarView_hpp
00035
00036
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyTheme.cpp File Reference

GlobalThemes/FoggyTheme/FoggyTheme.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"
#include "FoggyTheme.hpp"
#include <Gui/Color.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/Resources/checked_checkbox.hpp>
#include <Config/Resources/unchecked_checkbox.hpp>
#include <Config/Resources/checked_radiobutton.hpp>
#include <Config/Resources/unchecked_radiobutton.hpp>

Include dependency graph for FoggyTheme.cpp:

Variables

const Palette | c_foggy_system_color []
ColorTable | c_foggy_system_color_table = { c_foggy_system_color, 14 }

Variable Documentation

const Palette c_foggy_system_color[]

Initial value:

 {
    {255, 255, 255},
    {0, 0, 0},
    {220, 250, 250},
    {64, 141, 209},
    {192, 192, 192},
    {0, 0, 0},
    {64, 141, 209},
    {220, 250, 250},
    {128, 128, 128},
    {230, 230, 230},
    {60, 60, 60},
    {255, 255, 255},
    {0, 0, 0},
    {128, 128, 128}
}

ColorTable c_foggy_system_color_table = { c_foggy_system_color, 14 }

Generated on Tue Jan 24 20:20:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyTheme.hpp File Reference

GlobalThemes/FoggyTheme/FoggyTheme.hpp File Reference

#include <Gui/Theme.hpp>
#include <GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
#include <GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
#include <GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp>
#include <GlobalThemes/FoggyTheme/FoggyPanelView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTabControlView.hpp>
#include <GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp>

Include dependency graph for FoggyTheme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FoggyTheme
Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

Defines

#define | Apoxi_FoggyTheme_hpp

Define Documentation

#define Apoxi_FoggyTheme_hpp

Generated on Tue Jan 24 20:20:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyTheme.hpp Source File

GlobalThemes/FoggyTheme/FoggyTheme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_FoggyTheme_hpp)
00010 #define Apoxi_FoggyTheme_hpp
00011
00012 #include <Gui/Theme.hpp>
00013
00014 #include <GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp>
00015 #include <GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>
00016 #include <GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp>
00017 #include <GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>
00018 #include <GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp>
00019 #include <GlobalThemes/FoggyTheme/FoggyPanelView.hpp>
00020
00021 #ifndef APOXI_DISABLE_TAB_CONTROL
00022     #include <GlobalThemes/DefaultTheme/DefaultTabControlView.hpp>
00023     #include <GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp>
00024 #endif
00025
00026 #ifdef APOXI_COMPAT_1_9_0
00027     #include <GlobalThemes/DefaultTheme/DefaultTextListView.hpp>
00028     #include <GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp>
00029 #endif
00030
00031 #ifdef APOXI_COMPAT_1_7_0
00032     #include <GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>
00033     #include <GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>
00034     #include <GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>
00035     #include <GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>
00036 #endif
00037
00038 /*  ------------------------------------------------------------------------
00039     FoggyTheme
00040     ------------------------------------------------------------------------*/
00041 class FoggyTheme : public Theme {
00042     typedef Theme Base;
00043
00044     public:
00045         static const Theme& GetInstance();
00046         virtual ~FoggyTheme();
00047
00048         virtual const WCHAR* GetName() const;
00049         virtual void Update();
00050         virtual const ColorTable* GetSystemColorTable() const;
00051         virtual const WindowFrameView* GetWindowFrameView() const;
00052         virtual const ControlFrameView* GetControlFrameView() const;
00053
00054         virtual const PositionIndicatorView* GetPositionIndicatorView() const;
00055         virtual const ProgressBarView* GetProgressBarView() const;
00056         virtual const PushButtonView* GetPushButtonView() const;
00057         virtual const PanelView* GetPanelView() const;
00058
00059         #ifndef APOXI_DISABLE_TAB_CONTROL
00060             virtual const TabControlView* GetTabControlView() const;
00061             virtual const TabButtonView* GetTabButtonView() const;
00062         #endif
00063
00064         virtual const BitmapRes* GetBitmap(BitmapResId id) const;
00065
00066         #ifdef APOXI_COMPAT_1_9_0
00067             virtual const TextListView* GetTextListView() const;
00068             virtual const SoftkeyBarView* GetSoftkeyBarView() const;
00069         #endif
00070
00071         #ifdef APOXI_COMPAT_1_7_0
00072             virtual const CheckBoxView* GetCheckBoxView() const;
00073             virtual const RadioButtonView* GetRadioButtonView() const;
00074             virtual const CheckBoxListView* GetCheckBoxListView() const;
00075             virtual const RadioButtonListView* GetRadioButtonListView() const;
00076         #endif
00077
00078     private:
00079         FoggyWindowFrameView m_window_frame_view;
00080         DefaultControlFrameView m_control_frame_view;
00081         FoggyPositionIndicatorView m_position_indicator_view;
00082         DefaultProgressBarView m_progress_bar_view;
00083         FoggyPushButtonView m_push_button_view;
00084         FoggyPanelView m_panel_view;
00085
00086         #ifndef APOXI_DISABLE_TAB_CONTROL
00087             DefaultTabControlView m_tab_control_view;
00088             DefaultTabButtonView m_tab_button_view;
00089         #endif
00090
00091         #ifdef APOXI_COMPAT_1_9_0
00092             DefaultTextListView m_text_list_view;
00093             FoggySoftkeyBarView m_softkey_bar_view;
00094         #endif
00095
00096         #ifdef APOXI_COMPAT_1_7_0
00097             DefaultCheckBoxView m_check_box_view;
00098             DefaultRadioButtonView m_radio_button_view;
00099             DefaultCheckBoxListView m_check_box_list_view;
00100             DefaultRadioButtonListView m_radio_button_list_view;
00101         #endif
00102
00103         static FoggyTheme m_foggy_theme;
00104
00105         FoggyTheme();
00106 };
00107
00108 #ifdef APOXI_COMPAT_1_9_0
00109     #define foggy_theme FoggyTheme::GetInstance()
00110 #endif
00111
00112 #endif
00113
00114
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyWindowFrameView.cpp File Reference

GlobalThemes/FoggyTheme/FoggyWindowFrameView.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"
#include "FoggyWindowFrameView.hpp"
#include <Gui/PaintDc.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/FontConfig.hpp>
#include <Config/Resources/softkey_middle.hpp>

Include dependency graph for FoggyWindowFrameView.cpp:

Generated on Tue Jan 24 20:36:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp File Reference

GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp File Reference

#include <Gui/WindowFrameView.hpp>

Include dependency graph for FoggyWindowFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FoggyWindowFrameView

Defines

#define | Apoxi_FoggyWindowFrameView_hpp

Define Documentation

#define Apoxi_FoggyWindowFrameView_hpp

Generated on Tue Jan 24 20:36:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp Source File

GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #if !defined(Apoxi_FoggyWindowFrameView_hpp)
00010 #define Apoxi_FoggyWindowFrameView_hpp
00011
00012 #include <Gui/WindowFrameView.hpp>
00013
00014 class FoggyWindowFrameView : public WindowFrameView {
00015     typedef WindowFrameView Base;
00016
00017     public:
00018         FoggyWindowFrameView();
00019         FoggyWindowFrameView(XYDIM left_size,
00020                              XYDIM top_size,
00021                              XYDIM right_size,
00022                              XYDIM bottom_size,
00023                              XYDIM title_height,
00024                              XYDIM softkey_bar_height);
00025
00026         virtual ~FoggyWindowFrameView();
00027         virtual void Update(const Theme& theme);
00028
00029     protected:
00030         virtual void DrawControlFrame(const Control& control, DeviceContext* dc, const Rect& repaint_rect) const;
00031         virtual void DrawWindowExtensions(const Window& window,  DeviceContext* dc, const Rect& repaint_rect) const;
00032 };
00033
00034 #endif  // Apoxi_FoggyWindowFrameView_hpp
00035
00036
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/PreComp.cpp File Reference

GlobalThemes/FoggyTheme/PreComp.cpp File Reference

#include "GlobalThemes/FoggyTheme/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:06:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/PreComp.hpp File Reference

GlobalThemes/FoggyTheme/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlobalThemes/FoggyTheme/PreComp.hpp Source File

GlobalThemes/FoggyTheme/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------*/
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011
00012
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractButton.cpp File Reference

Gui/AbstractButton.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractButton.hpp"
#include "Action.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for AbstractButton.cpp:

Generated on Tue Jan 24 20:36:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractButton.hpp File Reference

Gui/AbstractButton.hpp File Reference

#include <Gui/Control.hpp>

Include dependency graph for AbstractButton.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractButton

Defines

#define | Apoxi_AbstractButton_hpp

Define Documentation

#define Apoxi_AbstractButton_hpp

Generated on Tue Jan 24 20:36:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractButton.hpp Source File

Gui/AbstractButton.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_AbstractButton_hpp)
00011 #define Apoxi_AbstractButton_hpp
00015
00016 class Action;
00017 struct BitmapRes;
00018 #include <Gui/Control.hpp>
00019
00023 class AbstractButton : public Control {
00024     typedef Control Base;
00025
00026     public:
00027         enum {
00028             ID = 0
00029         };
00030
00033         AbstractButton();
00034
00037         AbstractButton(Control* parent, Action* action);
00038
00039         virtual ~AbstractButton();
00040
00043         void Init(Control* parent, Action* action);
00044
00047         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00048
00050         virtual BOOLEAN IsInstanceOf(INT id) const;
00051
00054         BOOLEAN IsPressed() const { return m_pressed; }
00055
00057         void SetBitmap(const BitmapRes* bitmap);
00058
00060         const BitmapRes* GetBitmap() const;
00061
00063         void SetText(const WCHAR* text);
00064
00066         const WCHAR* GetText() const;
00067
00069         void SetEnabled(BOOLEAN enabled);
00070
00072         BOOLEAN IsEnabled() const;
00073
00076         void Trigger();
00077
00079         void SetAction(Action* action);
00080
00082         Action* GetAction() const { return m_action; }
00083
00084     protected:
00086         virtual BOOLEAN OnMessage(const Message& msg);
00087
00089         virtual void OnClick();
00090
00092         virtual void OnRelease();
00093
00096         virtual void OnLanguageChanged();
00097
00099         void SetAbstractAction(Action* action) { SetAction(action); };
00100
00102         Action* GetAbstractAction() const { return GetAction(); }
00103
00104     private:
00105         BOOLEAN m_pressed;
00106         Action* m_action;
00107 };
00108
00110 #endif  // Apoxi_AbstractButton_hpp
00111
00112
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractEditor.cpp File Reference

Gui/AbstractEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DefaultCaret.hpp"
#include "AbstractEditor.hpp"
#include "EditorDocument.hpp"
#include "InputMapper.hpp"
#include "AtomItem.hpp"
#include "PaintDc.hpp"
#include "ClientDc.hpp"
#include <Devices/Device.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Config/EditConfig.hpp>
#include <Kernel/System.hpp>
#include <Devices/DisplayMsgTypes.hpp>
#include <Config/OptionalConfig.hpp>

Include dependency graph for AbstractEditor.cpp:

Generated on Tue Jan 24 20:36:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractEditor.hpp File Reference

Gui/AbstractEditor.hpp File Reference

#include <Gui/Control.hpp>
#include <Gui/Caret.hpp>
#include <Gui/EditorDocument.hpp>
#include <Gui/InputMapper.hpp>

Include dependency graph for AbstractEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractEditor
Abstract base class for all editors. More...

Defines

#define | Apoxi_AbstractEditor_hpp

Define Documentation

#define Apoxi_AbstractEditor_hpp

Generated on Tue Jan 24 20:36:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractEditor.hpp Source File

Gui/AbstractEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AbstractEditor_hpp)
00011 #define Apoxi_AbstractEditor_hpp
00016
00017 #include <Gui/Control.hpp>
00018 #include <Gui/Caret.hpp>
00019 #include <Gui/EditorDocument.hpp>
00020 #include <Gui/InputMapper.hpp>
00021
00023 class AbstractEditor : public Control {
00024     typedef Control Base;
00025
00026     public:
00027         enum {
00028             ID = 27
00029         };
00030
00037         enum SelectionStyle {
00039             InvertedSelection = 0,
00043             TransparentSelection = 1
00044         };
00045
00048         AbstractEditor();
00049
00053         AbstractEditor(Control* parent, INT input_mapper_id);
00054
00055         virtual ~AbstractEditor();
00056
00060         void Init(Control* parent, INT input_mapper_id);
00061
00064         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00065
00067         virtual BOOLEAN IsInstanceOf(INT id) const;
00068
00071         virtual void SetReadOnly(BOOLEAN read_only);
00072
00075         BOOLEAN IsReadOnly() const { return static_cast<BOOLEAN>(m_bits.read_only); }
00076
00081         void SetCaretAlwaysVisible(BOOLEAN visible);
00082
00086         BOOLEAN IsCaretAlwaysVisible() const { return static_cast<BOOLEAN>(m_bits.caret_always_visible); }
00087
00092         void SetEditMode(Caret::Mode mode);
00093
00096         Caret::Mode GetEditMode() const;
00097
00099         EditorDocument* GetDocument() { return (EditorDocument*)GetModel(); }   //lint !e1762
00100
00102         const EditorDocument* GetDocument() const { return (const EditorDocument*)GetModel(); }
00103
00105         INT GetItemCount() const;
00106
00110         INT GetMaxItemCount() const;
00111
00116         void SetInputMapper(INT input_mapper_id);
00117
00119         InputMapper* GetInputMapper() { return m_input_mapper; }
00120
00122         const InputMapper* GetInputMapper() const { return m_input_mapper; }
00123
00125         Caret* GetCaret();
00126
00128         const Caret* GetCaret() const;
00129
00138         virtual void MoveCaret(INT steps);
00139
00142         void SetCaretIndex(INT index);
00143
00147         virtual INT GetCaretIndex() const = 0;
00148
00155         virtual Rect GetItemRect(INT index) const = 0;
00156
00163         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00164
00171         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00172
00177         virtual BOOLEAN RemoveItem(INT index = -1);
00178
00181         virtual BOOLEAN Backspace();
00182
00190         virtual void Update();
00191
00196         BOOLEAN InsertCompoundItem(CompoundItem* compound_item, INT comp_item_index = -1);
00197
00207         BOOLEAN InsertCompoundItemBeforeItem(CompoundItem* compound_item, INT item_index = -1);
00208
00213         BOOLEAN RemoveCompoundItem(INT comp_item_index = -1);
00214
00217         void UpdateDocumentAlphabet(InputMapper::Alphabet alphabet);
00218
00222         void StartSelection();
00223
00226         void StopSelection();
00227
00230         void SetSelection(INT item_index, INT count);
00231
00237         void GetSelection(INT* item_index, INT* count) const;
00238
00240         BOOLEAN HasSelection() const { return m_sel_count != 0; }
00241
00245         void SetSelectionStyle(SelectionStyle style);
00246
00248         SelectionStyle GetSelectionStyle() const { return static_cast<SelectionStyle>(m_bits.selection_style); }
00249
00257         virtual BOOLEAN IsStandaloneItem(INT index) const;
00258
00263         virtual void DrawSelection(DeviceContext* dc, const Rect& bounds) const;
00264
00265     protected:
00269         void AssureValidCaretIndex(INT& index);
00270
00273         void AssureValidIndex(INT& index) const;
00274
00276         virtual void Refresh(const Rect& rect);
00277
00279         virtual void Cleanup();
00280
00282         virtual BOOLEAN OnMessage(const Message& msg);
00283
00285         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00286
00288         virtual BOOLEAN OnKeyUp(KeyCode key_code, UINT32 duration);
00289
00291         virtual BOOLEAN OnLongKeyPress(KeyCode key_code);
00292
00294         virtual void OnGetFocus();
00295
00297         virtual void OnLoseFocus();
00298
00300         virtual void OnPaint(const Rect& repaint_rect);
00301
00302     private:
00303         struct {
00304             UINT read_only            : 1;
00305             UINT caret_always_visible : 1;
00306             UINT selection_started    : 1;
00307             UINT selection_style      : 2;
00308         } m_bits;
00309         INT m_sel_start;
00310         INT m_sel_count;
00311         InputMapper* m_input_mapper;
00312
00313         void InitProperties(INT input_mapper_id);
00314         void UpdateNavigationGuidance();
00315 };
00316
00318 #endif  // Apoxi_AbstractEditor_hpp
00319
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractEditorItem.cpp File Reference

Gui/AbstractEditorItem.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractEditorItem.hpp"
#include "EditorDocument.hpp"

Include dependency graph for AbstractEditorItem.cpp:

Generated on Tue Jan 24 20:36:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractEditorItem.hpp File Reference

Gui/AbstractEditorItem.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractEditorItem

Defines

#define | Apoxi_AbstractEditorItem_hpp

Define Documentation

#define Apoxi_AbstractEditorItem_hpp

Generated on Tue Jan 24 20:36:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractEditorItem.hpp Source File

Gui/AbstractEditorItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AbstractEditorItem_hpp)
00011 #define Apoxi_AbstractEditorItem_hpp
00015
00016
00036 class AbstractEditorItem {
00037     public:
00039         AbstractEditorItem();
00040
00042         virtual ~AbstractEditorItem();
00043
00045         virtual INT GetId() const = 0;
00046
00050         virtual BOOLEAN IsInstanceOf(INT id) const = 0;
00051 };
00052
00054 #endif  // Apoxi_AbstractEditorItem_hpp
00055
00056
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractGrid.cpp File Reference

Gui/AbstractGrid.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractGrid.hpp"
#include "Window.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include "ScrollBehavior.hpp"
#include "PaintDc.hpp"
#include "ClientDc.hpp"
#include "Locale.hpp"
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Application.hpp>

Include dependency graph for AbstractGrid.cpp:

Generated on Tue Jan 24 20:36:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractGrid.hpp File Reference

Gui/AbstractGrid.hpp File Reference

#include <Gui/Control.hpp>
#include <Gui/PositionIndicator.hpp>
#include <Gui/ScrollBehavior.hpp>
#include <Kernel/Timer.hpp>

Include dependency graph for AbstractGrid.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractGrid
Simple grid functionality for arranging items on the screen in rows and columns. More...
class | AbstractGrid::SmoothScrollInfo

Defines

#define | Apoxi_AbstractGrid_hpp

Define Documentation

#define Apoxi_AbstractGrid_hpp

Generated on Tue Jan 24 20:36:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractGrid.hpp Source File

Gui/AbstractGrid.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AbstractGrid_hpp)
00011 #define Apoxi_AbstractGrid_hpp
00015
00016 class ResourceParser;
00017 #include <Gui/Control.hpp>
00018 #include <Gui/PositionIndicator.hpp>
00019 #include <Gui/ScrollBehavior.hpp>
00020 #include <Kernel/Timer.hpp>
00021
00023 class AbstractGrid : public Control {
00024     typedef Control Base;
00025
00026     public:
00027         enum {
00028             ID = 1
00029         };
00030
00032         enum MoveDirection {
00034             Left,
00036             Right,
00038             Up,
00040             Down,
00043             PageUp,
00046             PageDown,
00047         };
00048
00053         class SmoothScrollInfo {
00054             public:
00055                 SmoothScrollInfo();
00056                 ~SmoothScrollInfo();
00057
00060                 BOOLEAN IsSelector() const { return (BOOLEAN)m_flags.is_selector; }
00061
00064                 BOOLEAN IsHorizontal() const { return (BOOLEAN)m_flags.is_horizontal; }
00065
00069                 BOOLEAN IsMirrored() const { return (BOOLEAN)m_flags.is_mirrored; }
00070
00072                 const Timer& GetTimer() const { return m_timer; }
00073
00077                 XYDIM GetDiff() const { return (XYDIM)m_diff; }
00078
00080                 XYDIM GetInc() const { return (XYDIM)m_inc; }
00081
00082             private:
00083                 struct {
00084                     UINT is_selector    : 1;
00085                     UINT is_horizontal  : 1;
00086                     UINT is_mirrored    : 1;
00087                 } m_flags;
00088                 Timer m_timer;
00089                 INT8 m_diff;
00090                 INT8 m_inc;
00091
00092             friend class AbstractGrid;
00093         };
00094
00095         AbstractGrid(Control* parent = 0);
00096
00097         virtual ~AbstractGrid();
00098
00100         void Init(Control* parent = 0);
00101
00104         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00105
00107         virtual BOOLEAN IsInstanceOf(INT id) const;
00108
00113         virtual void SetSelectedIndex(INT idx);
00114
00119         virtual void MoveSelectedIndex(MoveDirection move_dir);
00120
00122         INT GetSelectedIndex() const;
00123
00129         void SetFirstVisibleIndex(INT idx, BOOLEAN respect_scroll_gap = TRUE);
00130
00132         INT GetFirstVisibleIndex() const { return m_first_visible_idx; }
00133
00135         INT GetLastVisibleIndex() const;
00136
00138         INT GetLastCompleteVisibleIndex() const;
00139
00142         INT GetVisibleRowCount() const;
00143
00146         INT GetCompleteVisibleRowCount() const;
00147
00150         Rect GetCellRect(INT idx) const;
00151
00153         virtual INT GetCellCount() const = 0;
00154
00156         virtual INT GetColumnCount() const = 0;
00157
00159         virtual XYDIM GetCellHeight() const = 0;
00160
00163         INT GetRowCount() const;
00164
00167         virtual XYDIM GetCellWidth() const;
00168
00170         void SetFirstVisibleColumn(INT column);
00171
00173         INT GetFirstVisibleColumn() const { return m_first_visible_column; }
00174
00177         virtual BOOLEAN HasHeader() const;
00178
00180         virtual XYDIM GetHeaderHeight() const;
00181
00186         virtual XYDIM GetSelectionHeight() const;
00187
00192         Rect GetHeaderRect(INT column_idx) const;
00193
00197         virtual BOOLEAN IsPositionIndicatorShown() const;
00198
00202         virtual ScrollBehavior GetScrollBehavior() const;
00203
00206         const SmoothScrollInfo* GetSmoothScrollInfo() const;
00207
00208     protected:
00210         virtual void Refresh(const Rect& rect);
00211
00213         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00214
00216         virtual BOOLEAN OnKeyAutoRepeat(KeyCode key_code);
00217
00219         virtual void OnLayoutClient();
00220
00222         virtual void OnPaint(const Rect& repaint_rect);
00223
00225         virtual void OnThemeChanged();
00226
00229         virtual void OnSelectionChanged();
00230
00232         virtual BOOLEAN OnTimeout(const Timer& timer);
00233
00235         virtual void OnGetFocus();
00236
00243         void AssureVisibleSelection(BOOLEAN respect_scroll_gap = TRUE);
00244
00247         void UpdatePositionIndicator();
00248
00250         BOOLEAN IsPositionIndicatorLeftAligned() const;
00251
00254         void DrawPositionIndicator(const Rect& repaint_rect);
00255
00262         INT GetSelectedIndexProperty() const { return m_selected_idx; }
00263
00266         void UpdateNavigationGuidance();
00267
00271         void CancelSmoothScrolling(INT new_selected_idx);
00272
00273     private:
00274         INT m_selected_idx;
00275         INT m_first_visible_idx;
00276         INT m_first_visible_column;
00277         PositionIndicator m_pos_ind;
00278 #ifdef APOXI_ENABLE_SMOOTH_SCROLLING
00279         SmoothScrollInfo m_smooth_scroll_info;
00280 #endif
00281
00282         INT GetCompleteVisibleCellCount() const;
00283         INT GetVisibleCellCount() const;
00284         INT GetRowOfIndex(INT idx) const;
00285         void AdjustCellWidth(XYDIM& cell_width) const;
00286
00291         void EnlargeGridSelection(Rect& cell_rect) const;
00292
00293         BOOLEAN TreatKeyCode(KeyCode key_code);
00294         void CenterSelection(INT complete_visible_cell_count);
00295         void TreatScrollGap();
00296         void InitProperties();
00297 #ifdef APOXI_ENABLE_SMOOTH_SCROLLING
00298         void InvalidateSmoothAnim(BOOLEAN up);
00299 #endif
00300 };
00301
00303 #endif  // Apoxi_AbstractGrid_hpp
00304
00305
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemContainer.cpp File Reference

Gui/AbstractItemContainer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractItemContainer.hpp"

Include dependency graph for AbstractItemContainer.cpp:

Generated on Tue Jan 24 20:36:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemContainer.hpp File Reference

Gui/AbstractItemContainer.hpp File Reference

#include <Gui/Item.hpp>

Include dependency graph for AbstractItemContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractItemContainer

Defines

#define | Apoxi_AbstractItemContainer_hpp

Define Documentation

#define Apoxi_AbstractItemContainer_hpp

Generated on Tue Jan 24 20:36:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemContainer.hpp Source File

Gui/AbstractItemContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractItemContainer_hpp)
00010 #define Apoxi_AbstractItemContainer_hpp
00013
00014 class ItemRendererProperties;
00015 #include <Gui/Item.hpp>
00016
00023 class AbstractItemContainer : public Item {
00024     typedef Item Base;
00025
00026     public:
00027         enum {
00028             ID = 2
00029         };
00030
00032         enum AbstractItemContainerPropertyId {
00034             ItemPropertyId = 4,
00036             RendererPropertyId = 5,
00037         };
00038
00041         AbstractItemContainer();
00042
00054         AbstractItemContainer(Dispatcher* dispatcher,
00055                       const WCHAR* text,
00056                       const BitmapRes* icon = 0,
00057                       BOOLEAN enabled = TRUE);
00058
00070         AbstractItemContainer(Dispatcher* dispatcher,
00071                       const WString& text,
00072                       const BitmapRes* icon = 0,
00073                       BOOLEAN enabled = TRUE);
00074
00086         AbstractItemContainer(Dispatcher* dispatcher,
00087                       const WString& text,
00088                       const ImageObtainer& icon,
00089                       BOOLEAN enabled = TRUE);
00090
00102         AbstractItemContainer(Dispatcher* dispatcher,
00103                               const WString& text,
00104                               const IconSet& icon_set,
00105                               BOOLEAN enabled = TRUE);
00106
00107         virtual ~AbstractItemContainer();
00108
00120         void Init(Dispatcher* dispatcher,
00121                   const WCHAR* text,
00122                   const BitmapRes* icon = 0,
00123                   BOOLEAN enabled = TRUE);
00124
00136         void Init(Dispatcher* dispatcher,
00137                   const WString& text,
00138                   const BitmapRes* icon = 0,
00139                   BOOLEAN enabled = TRUE);
00140
00152         void Init(Dispatcher* dispatcher,
00153                   const WString& text,
00154                   const ImageObtainer& icon,
00155                   BOOLEAN enabled = TRUE);
00156
00168         void Init(Dispatcher* dispatcher,
00169                   const WString& text,
00170                   const IconSet& icon_set,
00171                   BOOLEAN enabled = TRUE);
00172
00175         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00176
00178         virtual BOOLEAN IsInstanceOf(INT id) const;
00179
00183         virtual BOOLEAN AddItem(Item* item) = 0;
00184
00188         virtual BOOLEAN InsertItem(INT index, Item* item) = 0;
00189
00193         virtual BOOLEAN RemoveItem(INT index) = 0;
00194
00198         virtual BOOLEAN RemoveAllItems() = 0;
00199
00201         virtual Item* GetItem(INT index) const = 0;
00202
00205         virtual INT GetItemIndex(const Item& item) const = 0;
00206
00208         virtual INT GetItemCount() const = 0;
00209
00213         BOOLEAN ContainsItem(const Item& item) const;
00214
00217         virtual BOOLEAN SetParentContainer(AbstractItemContainer* container) = 0;
00218
00220         virtual AbstractItemContainer* GetParentContainer() = 0;
00221
00226         virtual BOOLEAN SetRendererProperties(const ItemRendererProperties* properties);
00227
00231         virtual const ItemRendererProperties* GetRendererProperties() const;
00232 };
00233
00235 #endif  // Apoxi_Item_hpp
00236
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemGrid.cpp File Reference

Gui/AbstractItemGrid.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractItemGrid.hpp"
#include "AbstractItemContainer.hpp"
#include "AbstractItemRenderer.hpp"
#include "DefaultItemRenderer.hpp"
#include "Image.hpp"
#include "ImageBox.hpp"
#include "PaintDc.hpp"
#include "ClientDc.hpp"
#include "Window.hpp"
#include "TextLine.hpp"
#include <Config/GuiEngineConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <Kernel/MsgTypes.hpp>

Include dependency graph for AbstractItemGrid.cpp:

Generated on Tue Jan 24 20:36:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemGrid.hpp File Reference

Gui/AbstractItemGrid.hpp File Reference

#include <Gui/AbstractGrid.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Auxiliary/TriggerTimer.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for AbstractItemGrid.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractItemGrid

Defines

#define | Apoxi_AbstractItemGrid_hpp

Define Documentation

#define Apoxi_AbstractItemGrid_hpp

Generated on Tue Jan 24 20:36:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemGrid.hpp Source File

Gui/AbstractItemGrid.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractItemGrid_hpp)
00010 #define Apoxi_AbstractItemGrid_hpp
00014
00015 class PaintDc;
00016 class AbstractItemContainer;
00017 class AbstractItemRenderer;
00018 class ImageBox;
00019 class ItemRendererProperties;
00020 class Item;
00021 class TextLine;
00022 #include <Gui/AbstractGrid.hpp>
00023 #include <Gui/ImageObtainer.hpp>
00024 #include <Auxiliary/TriggerTimer.hpp>
00025 #include <Auxiliary/Vector.hpp>
00026 #if defined(APOXI_ENABLE_POSITION_PREVIEW)
00027     #include <Gui/IconState.hpp>
00028     #include <Auxiliary/WString.hpp>
00029 #endif
00030
00042 class AbstractItemGrid : public AbstractGrid {
00043     typedef AbstractGrid Base;
00044
00045     public:
00046         enum {
00047             ID = 2
00048         };
00049
00052         AbstractItemGrid();
00053
00059         AbstractItemGrid(Control* parent, AbstractItemContainer* item_cont = 0);
00060
00061         virtual ~AbstractItemGrid();
00062
00065         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00066
00068         virtual BOOLEAN IsInstanceOf(INT id) const;
00069
00075         void Init(Control* parent, AbstractItemContainer* item_cont = 0);
00076
00082         void SetRenderer(const ItemRendererProperties* properties = 0);
00083
00085         const AbstractItemRenderer* GetRenderer() const { return m_renderer; }
00086
00088         void SetItemContainer(AbstractItemContainer* item_cont);
00089
00092         virtual AbstractItemContainer* GetItemContainer() const;
00093
00095         virtual INT GetCellCount() const;
00096
00100         virtual XYDIM GetCellHeight() const;
00101
00105         virtual BOOLEAN HasHeader() const;
00106
00108         virtual XYDIM GetHeaderHeight() const;
00109
00111         virtual XYDIM GetSelectionHeight() const;
00112
00115         void SetHeaderItem(INT column, Item* item);
00116
00118         Item* GetHeaderItem(INT column) const;
00119
00123         BOOLEAN AddItem(Item* item);
00124
00127         Item* GetSelectedItem() const;
00128
00130         virtual void SetSelectedIndex(INT idx);
00131
00133         virtual void MoveSelectedIndex(MoveDirection move_dir);
00134
00135 #if defined(APOXI_ENABLE_POSITION_PREVIEW)
00136
00146         void SetParentShortcutInfo(const WString& parent_info);
00147
00150         const WString& GetParentShortcutInfo() const { return m_parent_shortcut_info; }
00151
00159         virtual WString GetShortcutInfo() const;
00160 #endif
00161
00162     protected:
00164         virtual BOOLEAN OnMessage(const Message& msg);
00165
00167         virtual void OnSelectionChanged();
00168
00170         virtual void OnPaint(const Rect& repaint_rect);
00171
00173         virtual void Refresh(const Rect& rect);
00174
00176         virtual void Cleanup();
00177
00179         virtual void OnGetFocus();
00180
00182         virtual void OnLoseFocus();
00183
00185         virtual void OnResize(XYDIM dx, XYDIM dy);
00186
00188         virtual void OnThemeChanged();
00189
00191         virtual void OnLanguageChanged();
00192
00194         virtual BOOLEAN OnTimeout(const Timer& timer);
00195
00203         virtual Rect GetItemRect(INT item_index) const;
00204
00210         virtual void DrawItemBorder(DeviceContext* dc,
00211                                     const Rect& cell_rect,
00212                                     const Rect& item_rect,
00213                                     INT item_index) const;
00214
00220         void RefreshImageCache();
00221
00224         void CleanupImageCache();
00225
00231         void SwitchItemContainer(AbstractItemContainer* item_cont);
00232
00233     private:
00234         friend class TriggerTimer<AbstractItemGrid>;
00235
00236         BOOLEAN m_allocated_item_cont;
00237         AbstractItemRenderer* m_renderer;
00238         AbstractItemContainer* m_item_cont;
00239         Vector<Item*> m_header_vec;
00240         Vector<ImageBox*> m_img_box_vec;
00241         TriggerTimer<AbstractItemGrid> m_timer;
00242
00243 #if defined(APOXI_ENABLE_POSITION_PREVIEW)
00244
00245         class TitleIconView : public View {
00246             public:
00247                 TitleIconView();
00248                 virtual ~TitleIconView();
00249                 virtual void Draw(const Component& component,
00250                                   DeviceContext* dc,
00251                                   const Rect& repaint_rect) const;
00252         };
00253
00257         class TitleIcon : public DrawableObject {
00258             typedef DrawableObject Base;
00259
00260             public:
00261                 TitleIcon(Control* parent, const ImageObtainer& img_obt);
00262                 virtual ~TitleIcon();
00263                 void SetImageObtainer(const ImageObtainer& img_obt);
00264                 const ImageObtainer& GetImageObtainer() const { return m_img_obt; }
00265
00266             private:
00267                 ImageObtainer m_img_obt;
00268         };
00269
00270         TitleIcon* m_title_icon;
00271         TextLine* m_title_pos;
00272         WString m_parent_shortcut_info;
00273 #endif
00274
00275         void InitProperties();
00276         void OnTimer();
00277         void StartTextScrolling();
00278         BOOLEAN IsValidIndex(INT index) const;
00279         void RefreshContent();
00280         Rect GetIconRect(const Item& item, INT index) const;
00281
00286         void ReTranslateItemContainer(AbstractItemContainer& item_cont) const;
00287
00290         void ResetDispatchers(AbstractItemContainer& item_cont) const;
00291
00295         void DeleteImageBoxes(INT start_index = 0);
00296
00303         BOOLEAN MoveImageBox(INT item_idx, const ImageObtainer& icon);
00304
00306         BOOLEAN HasImage() const;
00307
00310         void IncreaseImageVectorSize(INT size);
00311
00314         BOOLEAN IsItemSelectable(const Item* item) const;
00315
00318         void UpdateImageBoxBounds();
00319
00334         void DrawItem(DeviceContext& dc,
00335                       INT idx,
00336                       INT& item_idx,
00337                       INT last_visible_idx,
00338                       const Rect& repaint_rect,
00339                       BOOLEAN draw_background,
00340                       BOOLEAN draw_mirrored = FALSE);
00341
00343         void DrawHeaders(PaintDc& pdc);
00344
00347         Rect GetScaledImageBounds(const Rect& icon_rect, XYDIM width, XYDIM height) const;
00348
00351         void CreateDefaultItemContainer();
00352
00353 #if defined(APOXI_ENABLE_POSITION_PREVIEW)
00354
00356         void UpdatePositionPreview();
00357
00360         void DeletePreviewObject(DrawableObject* obj);
00361
00364         void AdjustTitleIconSize();
00365
00369         IconState::Size GetTitleIconSize(Size* pixel_size = 0) const;
00370
00373         void UpdateTitlePosColor();
00374 #endif
00375 };
00376
00378 #endif  // Apoxi_AbstractItemGrid_hpp
00379
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemRenderer.cpp File Reference

Gui/AbstractItemRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractItemRenderer.hpp"
#include "ItemRendererProperties.hpp"

Include dependency graph for AbstractItemRenderer.cpp:

Generated on Tue Jan 24 20:36:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemRenderer.hpp File Reference

Gui/AbstractItemRenderer.hpp File Reference

#include <Kernel/Timer.hpp>
#include <Gui/AbstractGrid.hpp>
#include <Gui/Item.hpp>
#include <Auxiliary/Vector.hpp>
#include <Gui/ItemContainer.hpp>
#include <Gui/ItemRendererProperties.hpp>

Include dependency graph for AbstractItemRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractItemRenderer

Defines

#define | Apoxi_AbstractItemRenderer_hpp

Define Documentation

#define Apoxi_AbstractItemRenderer_hpp

Generated on Tue Jan 24 20:36:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractItemRenderer.hpp Source File

Gui/AbstractItemRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractItemRenderer_hpp)
00010 #define Apoxi_AbstractItemRenderer_hpp
00013
00014 #include <Kernel/Timer.hpp>
00015 #include <Gui/AbstractGrid.hpp>
00016 #include <Gui/Item.hpp>
00017 #include <Auxiliary/Vector.hpp>
00018 #include <Gui/ItemContainer.hpp>
00019 #include <Gui/ItemRendererProperties.hpp>
00020
00049 class AbstractItemRenderer {
00050     public:
00054         enum ItemStyle {
00056             DefaultStyle            = 0,
00059             SelectedStyle           = 1,
00063             HeaderStyle             = 2,
00065             AnimatedStyle           = 3,
00067             CustomStyle             = 100
00068         };
00069
00071         AbstractItemRenderer(const ItemRendererProperties* properties = 0);
00072
00074         virtual ~AbstractItemRenderer();
00075
00077         const ItemRendererProperties* GetProperties() const { return m_properties; }
00078
00085         virtual Rect GetIconRect(const Item& item, const Rect& bounds) const = 0;
00086
00089         virtual XYDIM GetItemHeight(INT item_style = DefaultStyle) const = 0;
00090
00107         virtual void DrawBackground(DeviceContext* dc,
00108                                     const Item& item,
00109                                     const Rect& bounds,
00110                                     INT item_style) const = 0;
00111
00127         virtual void DrawItem(DeviceContext* dc,
00128                               const Item& item,
00129                               const Rect& bounds,
00130                               INT item_style) const = 0;
00131
00149         virtual BOOLEAN StartTextScrolling(const Item& item, const Rect& bounds) const;
00150
00152         virtual void StopTextScrolling(const Item& item) const;
00153
00165         virtual BOOLEAN ScrollText() const;
00166
00170         virtual IconState::Size GetIconSizeState(INT item_style = DefaultStyle) const;
00171
00172     protected:
00174         void SetProperties(const ItemRendererProperties* properties) { m_properties = properties; }
00175
00176     private:
00177         const ItemRendererProperties* m_properties;
00178 };
00179
00181 #endif  // Apoxi_AbstractItemRenderer_hpp
00182
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractLineEditor.cpp File Reference

Gui/AbstractLineEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractLineEditor.hpp"
#include "AtomItem.hpp"
#include "PaintDc.hpp"
#include "ClientDc.hpp"
#include "Locale.hpp"

Include dependency graph for AbstractLineEditor.cpp:

Generated on Tue Jan 24 20:36:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractLineEditor.hpp File Reference

Gui/AbstractLineEditor.hpp File Reference

#include <Gui/AbstractEditor.hpp>

Include dependency graph for AbstractLineEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractLineEditor
class | AbstractLineEditorView

Defines

#define | Apoxi_AbstractLineEditor_hpp

Define Documentation

#define Apoxi_AbstractLineEditor_hpp

Generated on Tue Jan 24 20:36:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractLineEditor.hpp Source File

Gui/AbstractLineEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AbstractLineEditor_hpp)
00011 #define Apoxi_AbstractLineEditor_hpp
00016
00017 #include <Gui/AbstractEditor.hpp>
00018
00020 class AbstractLineEditorView : public View {
00021     typedef View Base;
00022
00023     public:
00024         explicit AbstractLineEditorView();
00025         virtual ~AbstractLineEditorView();
00026         void Init();
00027         virtual void Draw(const Component& component,
00028                           DeviceContext* dc,
00029                           const Rect& repaint_rect) const;
00030 };
00031
00032
00036 class AbstractLineEditor : public AbstractEditor {
00037     typedef AbstractEditor Base;
00038
00039     public:
00040         enum {
00041             ID = 28
00042         };
00043
00046         AbstractLineEditor();
00047
00051         AbstractLineEditor(Control* parent, INT input_mapper_id);
00052
00053         virtual ~AbstractLineEditor();
00054
00058         void Init(Control* parent, INT input_mapper_id);
00059
00062         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00063
00065         virtual BOOLEAN IsInstanceOf(INT id) const;
00066
00068         virtual void MoveCaret(INT steps);
00069
00071         virtual INT GetCaretIndex() const;
00072
00074         virtual Rect GetItemRect(INT index) const;
00075
00077         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00078
00080         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00081
00083         virtual BOOLEAN RemoveItem(INT index = -1);
00084
00086         virtual BOOLEAN Backspace();
00087
00089         virtual void Update();
00090
00094         void SetFirstVisibleIndex(INT index);
00095
00099         INT GetFirstVisibleIndex() const { return m_first_visible_idx; }
00100
00103         INT GetVisibleItemCount() const;
00104
00105     protected:
00107         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00108
00109     private:
00110         INT m_first_visible_idx;
00111
00112         static AbstractLineEditorView m_view;
00113
00114         void InvalidateToEol(INT from);
00115 };
00116
00118 #endif  // Apoxi_AbstractLineEditor_hpp
00119
00120
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractListBox.hpp File Reference

Gui/AbstractListBox.hpp File Reference

#include <Compat/AbstractListBox.hpp>

Include dependency graph for AbstractListBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:15:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractListBox.hpp Source File

Gui/AbstractListBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class AbstractListBox has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/AbstractListBox.hpp>
00014
00015
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractMenuAccessor.hpp File Reference

Gui/AbstractMenuAccessor.hpp File Reference

#include <Compat/AbstractMenuAccessor.hpp>

Include dependency graph for AbstractMenuAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:15:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractMenuAccessor.hpp Source File

Gui/AbstractMenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class AbstractMenuAccessor has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/AbstractMenuAccessor.hpp>
00014
00015
Generated on Tue Jan 24 14:49:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractMenuList.hpp File Reference

Gui/AbstractMenuList.hpp File Reference

#include <Compat/AbstractMenuList.hpp>

Include dependency graph for AbstractMenuList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:15:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractMenuList.hpp Source File

Gui/AbstractMenuList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class AbstractMenuList has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.2.*/
00013 #include <Compat/AbstractMenuList.hpp>
00014
00015
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractMultiLineEditor.cpp File Reference

Gui/AbstractMultiLineEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractMultiLineEditor.hpp"
#include "AtomItem.hpp"
#include "CharItem.hpp"
#include "TextCompoundItem.hpp"
#include "PaintDc.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/OptionalConfig.hpp>
#include <Kernel/Application.hpp>
#include <Auxiliary/Macros.hpp>
#include "Locale.hpp"

Include dependency graph for AbstractMultiLineEditor.cpp:

Generated on Tue Jan 24 20:36:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractMultiLineEditor.hpp File Reference

Gui/AbstractMultiLineEditor.hpp File Reference

#include <Gui/AbstractEditor.hpp>
#include <Gui/EditorLine.hpp>
#include <Gui/PositionIndicator.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for AbstractMultiLineEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractMultiLineEditor
Abstract base class for all multiline editors. More...
class | AbstractMultiLineEditorView
View which shows the content of a multiline editor. More...

Defines

#define | Apoxi_AbstractMultiLineEditor_hpp

Define Documentation

#define Apoxi_AbstractMultiLineEditor_hpp

Generated on Tue Jan 24 20:36:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractMultiLineEditor.hpp Source File

Gui/AbstractMultiLineEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AbstractMultiLineEditor_hpp)
00011 #define Apoxi_AbstractMultiLineEditor_hpp
00016
00017 #include <Gui/AbstractEditor.hpp>
00018 #include <Gui/EditorLine.hpp>
00019 #include <Gui/PositionIndicator.hpp>
00020 #include <Auxiliary/Vector.hpp>
00021
00023 class AbstractMultiLineEditorView : public View {
00024     typedef View Base;
00025
00026     public:
00027         explicit AbstractMultiLineEditorView(XYDIM default_width = -1, XYDIM default_height = -1);
00028         virtual ~AbstractMultiLineEditorView();
00029         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00030 };
00031
00033 class AbstractMultiLineEditor : public AbstractEditor {
00034     typedef AbstractEditor Base;
00035
00036     public:
00037         enum {
00038             ID = 29
00039         };
00040
00043         enum CaretAction {
00047             CaretLeft,
00051             CaretRight,
00054             CaretLineUp,
00057             CaretLineDown
00058         };
00059
00062         AbstractMultiLineEditor();
00063
00069         AbstractMultiLineEditor(Control* parent, INT input_mapper_id);
00070
00071         virtual ~AbstractMultiLineEditor();
00072
00078         void Init(Control* parent, INT input_mapper_id);
00079
00082         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00083
00085         virtual BOOLEAN IsInstanceOf(INT id) const;
00086
00088         virtual void NavigateCaret(CaretAction caret_action);
00089
00091         virtual Rect GetItemRect(INT index) const;
00092
00094         virtual void MoveCaret(INT steps);
00095
00097         virtual INT GetCaretIndex() const;
00098
00100         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00101
00103         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00104
00106         virtual BOOLEAN RemoveItem(INT index = -1);
00107
00109         virtual BOOLEAN Backspace();
00110
00112         virtual void Update();
00113
00116         virtual void SetFirstVisibleLineIndex(INT line_idx);
00117
00119         INT GetFirstVisibleLineIndex() const { return m_first_visible_line_idx; }
00120
00122         const EditorLine& GetLine(INT line_idx) const { return m_line[line_idx]; }
00123
00126         INT GetLineCount() const { return m_line.GetSize(); }
00127
00132         INT GetVisibleLineCount(BOOLEAN* line_clipped = 0) const;
00133
00138         void SetUpDownPermitted(BOOLEAN flag) { m_bits.up_down_permitted = flag; }
00139
00142         BOOLEAN IsUpDownPermitted() const { return (BOOLEAN)m_bits.up_down_permitted; }
00143
00167         void SetPositionIndicatorEnabled(BOOLEAN flag);
00168
00171         BOOLEAN IsPositionIndicatorEnabled() const { return (BOOLEAN)m_bits.pos_ind_enabled; }
00172
00174         BOOLEAN IsPositionIndicatorLeftAligned() const;
00175
00181         XYDIM GetLineAlignInc(INT index, INT count, XYDIM width) const;
00182
00185         XYDIM GetContentLeft() const;
00186
00190         XYDIM GetMaxContentWidth() const;
00191
00193         virtual BOOLEAN IsStandaloneItem(INT index) const;
00194
00202         virtual BOOLEAN GetCharItem(INT index, WCHAR& chr) const;
00203
00207         void SetWrapPolicy(WrapPolicy wrap_policy);
00208
00212         WrapPolicy GetWrapPolicy() const { return (WrapPolicy)m_bits.wrap_policy; }
00213
00214     protected:
00216         virtual void Refresh(const Rect& rect);
00217
00219         virtual void OnPaint(const Rect& repaint_rect);
00220
00222         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00223
00225         virtual void OnGetFocus();
00226
00228         virtual void OnResize(XYDIM dx, XYDIM dy);
00229
00231         virtual void OnLayoutClient();
00232
00237         void Layout(INT line_idx = 0, INT added_items = -1);
00238
00239     private:
00240         struct {
00241             UINT up_down_permitted  : 1;
00242             UINT pos_ind_enabled    : 1;
00243             UINT wrap_policy        : 3;
00244         } m_bits;
00245         XYDIM               m_old_caret_x;
00246         INT                 m_first_visible_line_idx;
00247         Vector<EditorLine>  m_line;
00248         PositionIndicator   m_pos_ind;
00249
00250         static AbstractMultiLineEditorView m_view;
00251
00252         INT GetLineForIndex(INT index) const;
00253         void UpdateNavigationGuidance();
00254 };
00255
00257 #endif  // Apoxi_AbstractMultiLineEditor_hpp
00258
00259
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractRenderer.cpp File Reference

Gui/AbstractRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractRenderer.hpp"

Include dependency graph for AbstractRenderer.cpp:

Generated on Tue Jan 24 20:36:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractRenderer.hpp File Reference

Gui/AbstractRenderer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractRenderer

Defines

#define | Apoxi_AbstractRenderer_hpp

Define Documentation

#define Apoxi_AbstractRenderer_hpp

Generated on Tue Jan 24 20:36:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractRenderer.hpp Source File

Gui/AbstractRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2003 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractRenderer_hpp)
00010 #define Apoxi_AbstractRenderer_hpp
00013
00014 class DeviceContext;
00015
00017 class AbstractRenderer {
00018     public:
00020         AbstractRenderer();
00021
00023         virtual ~AbstractRenderer();
00024
00026         virtual void Draw(DeviceContext* dc) const = 0;
00027 };
00028
00030 #endif // Apoxi_AbstractRenderer_hpp
00031
00032
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractTextObject.cpp File Reference

Gui/AbstractTextObject.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractTextObject.hpp"
#include "PaintDc.hpp"
#include "LanguageManager.hpp"
#include "Locale.hpp"

Include dependency graph for AbstractTextObject.cpp:

Generated on Tue Jan 24 20:36:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractTextObject.hpp File Reference

Gui/AbstractTextObject.hpp File Reference

#include <Gui/Color.hpp>
#include <Gui/DrawableObject.hpp>
#include <Gui/TextFormat.hpp>

Include dependency graph for AbstractTextObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractTextObject

Defines

#define | Apoxi_AbstractTextObject_hpp

Define Documentation

#define Apoxi_AbstractTextObject_hpp

Generated on Tue Jan 24 20:37:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractTextObject.hpp Source File

Gui/AbstractTextObject.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractTextObject_hpp)
00010 #define Apoxi_AbstractTextObject_hpp
00014
00015 #include <Gui/Color.hpp>
00016 #include <Gui/DrawableObject.hpp>
00017 #include <Gui/TextFormat.hpp>
00018
00019 class Font;
00020 class Control;
00021 class View;
00022
00025 class AbstractTextObject : public DrawableObject {
00026     typedef DrawableObject Base;
00027
00028     public:
00029         enum {
00030             ID = 3
00031         };
00032
00035         AbstractTextObject();
00036
00041         AbstractTextObject(Control* control,
00042                            const View* view,
00043                            const WCHAR* text = 0,
00044                            const TextFormat& text_format = TextFormat());
00045
00046         virtual ~AbstractTextObject();
00047
00052         void Init(Control* control,
00053                   const View* view,
00054                   const WCHAR* text = 0,
00055                   const TextFormat& text_format = TextFormat());
00056
00059         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00060
00062         virtual BOOLEAN IsInstanceOf(INT id) const;
00063
00066         virtual void SetText(const WCHAR* text);
00067
00069         void SetText(const WString& text);
00070
00071         const WString& GetText() const { return m_text; }
00072
00074         virtual void SetTextFormat(const TextFormat& text_format);
00075
00077         const TextFormat& GetTextFormat() const { return m_text_format; }
00078
00081         virtual void SetFont(const Font& font);
00082
00084         const Font& GetFont() const;
00085
00088         void SetColor(const Color& color);
00089
00091         const Color& GetColor() const { return m_color; }
00092
00093     protected:
00095         virtual void OnLanguageChanged();
00096
00098         virtual void OnThemeChanged();
00099
00100     private:
00101         BOOLEAN m_use_default_color;
00102         WString m_text;
00103         TextFormat m_text_format;
00104         Color m_color;
00105
00106         void InitProperties(const WCHAR* text, const TextFormat& text_format);
00107 };
00108
00110 #endif  // Apoxi_AbstractTextObject_hpp
00111
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractTextRenderer.cpp File Reference

Gui/AbstractTextRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractTextRenderer.hpp"
#include <Devices/Display.hpp>
#include <Config/GuiEngineConfig.hpp>

Include dependency graph for AbstractTextRenderer.cpp:

Generated on Tue Jan 24 20:37:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractTextRenderer.hpp File Reference

Gui/AbstractTextRenderer.hpp File Reference

#include <Gui/DeviceContext.hpp>
#include <Gui/EditorDocument.hpp>
#include <Gui/Font.hpp>

Include dependency graph for AbstractTextRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractTextRenderer

Defines

#define | Apoxi_AbstractTextRenderer_hpp

Define Documentation

#define Apoxi_AbstractTextRenderer_hpp

Generated on Tue Jan 24 20:37:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractTextRenderer.hpp Source File

Gui/AbstractTextRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractTextRenderer_hpp)
00010 #define Apoxi_AbstractTextRenderer_hpp
00013
00014 #include <Gui/DeviceContext.hpp>
00015 #include <Gui/EditorDocument.hpp>
00016 #include <Gui/Font.hpp>
00017
00036 class AbstractTextRenderer {
00037     public:
00038         virtual ~AbstractTextRenderer();
00039
00059         virtual XYDIM DrawText(DeviceContext* dc,
00060                                const Rect& clip_rect,
00061                                XYDIM x,
00062                                XYDIM y,
00063                                const WCHAR* text,
00064                                INT from,
00065                                INT char_count);
00066
00078         virtual INT GetTextWidth(const WCHAR* text,
00079                                  const Font& font,
00080                                  TextAttr text_attr,
00081                                  INT from,
00082                                  INT char_count,
00083                                  BOOLEAN include_gap = FALSE);
00084
00096         virtual BOOLEAN IsStandaloneCharacter(const WCHAR* text,
00097                                               INT index);
00098
00114         virtual INT WrapLine(const WCHAR* text,
00115                              const Font& font,
00116                              TextAttr text_attr,
00117                              INT char_count,
00118                              XYDIM max_width = -1,
00119                              WrapPolicy policy = (WrapPolicy)0, // this awkward construction is forced on us by the egold compiler. 0 is WhitespaceWrap
00120                              BOOLEAN include_gap_at_end = FALSE,
00121                              Size* total_size = 0,
00122                              INT* ws_at_eol_count = 0,
00123                              XYDIM* ws_at_eol_width = 0,
00124                              INT* last_whitespace_index = 0);
00125
00128         static XYDIM GetItalicIncrement(INT font_height);
00129
00171         static Vector<INT> GetWrapPositions(const WCHAR* text,
00172                                             const Font& font,
00173                                             TextAttr text_attr,
00174                                             WrapPolicy policy,
00175                                             XYDIM width);
00176
00177
00178     protected:
00180         AbstractTextRenderer();
00181
00194         virtual BOOLEAN BeginGlyphRetrieval(const WCHAR* text_start,
00195                                             const Font& font,
00196                                             TextAttr text_attr);
00197
00203         virtual void EndGlyphRetrieval();
00204
00233         virtual Size GetGlyph(const WCHAR* cur_text_pos,
00234                               const WCHAR* substitution_char,
00235                               INT char_count,
00236                               GlyphPtr glyph,
00237                               INT& parsed_glyphs,
00238                               BOOLEAN& is_diacritic) = 0;
00239
00241         void DrawGlyphInItalic(VirtualDisplay* display,
00242                                INT font_height,
00243                                const Glyph& glyph,
00244                                XYDIM x,
00245                                XYDIM y,
00246                                const Rect& clip_rect);
00247
00249         BOOLEAN ObtainMutex() { return m_mutex.Obtain(); }
00250
00252         void ReleaseMutex() { m_mutex.Release(); }
00253
00255         const WCHAR* m_text_start;
00256
00258         const Font* m_font;
00259
00261         TextAttr m_text_attr;
00262
00263     private:
00265         Mutex m_mutex;
00266 };
00267
00268
00270 #endif // Apoxi_AbstractTextRenderer_hpp
00271
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractToggleAction.cpp File Reference

Gui/AbstractToggleAction.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AbstractToggleAction.hpp"

Include dependency graph for AbstractToggleAction.cpp:

Generated on Tue Jan 24 20:37:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractToggleAction.hpp File Reference

Gui/AbstractToggleAction.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/Bitmap.hpp>

Include dependency graph for AbstractToggleAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractToggleAction

Defines

#define | Apoxi_AbstractToggleAction_hpp

Define Documentation

#define Apoxi_AbstractToggleAction_hpp

Generated on Tue Jan 24 20:37:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AbstractToggleAction.hpp Source File

Gui/AbstractToggleAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractToggleAction_hpp)
00010 #define Apoxi_AbstractToggleAction_hpp
00014
00015 #include <Gui/Action.hpp>
00016 #include <Gui/Bitmap.hpp>
00017
00022 class AbstractToggleAction : public Action {
00023     typedef Action Base;
00024
00025     public:
00026         enum {
00027             ID = 4
00028         };
00029
00031         enum AbstractToogleActionPropertyId {
00032             SelectedPropertyId = 3,
00033             ValuePropertyId = 4
00034         };
00035
00036         AbstractToggleAction();
00037
00048         AbstractToggleAction(Dispatcher* dispatcher,
00049                              const WCHAR* text,
00050                              BOOLEAN enabled = TRUE,
00051                              BOOLEAN selected = FALSE,
00052                              INT value = 0);    //lint !e1931
00053
00054         virtual ~AbstractToggleAction();
00055
00066         void Init(Dispatcher* dispatcher,
00067                   const WCHAR* text,
00068                   BOOLEAN enabled = TRUE,
00069                   BOOLEAN selected = FALSE,
00070                   INT value = 0);
00071
00074         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00075
00077         virtual BOOLEAN Execute();
00078
00080         virtual BOOLEAN IsInstanceOf(INT id) const;
00081
00083         virtual BOOLEAN IsEqual(const Item& item) const;
00084
00086         virtual void SetSelected(BOOLEAN selected);
00087
00089         virtual BOOLEAN IsSelected() const;
00090
00092         virtual BOOLEAN Toggle(BOOLEAN old_state) = 0;
00093
00096         void SetValue(INT value);
00097
00100         INT GetValue() const { return m_value; }
00101
00103         AbstractToggleAction(const WCHAR* text,
00104                              BOOLEAN enabled = TRUE,
00105                              BOOLEAN selected = FALSE,
00106                              INT value = 0);    //lint !e1931
00107
00109         void Init(const WCHAR* text,
00110                   BOOLEAN enabled = TRUE,
00111                   BOOLEAN selected = FALSE,
00112                   INT value = 0);
00113
00116         virtual const BitmapRes* GetSelectedIcon() const;
00117
00120         virtual const BitmapRes* GetDeselectedIcon() const;
00121
00122     private:
00123         BOOLEAN m_selected;
00124         INT m_value;
00125 };
00126
00128 #endif // Apoxi_AbstractToggleAction_hpp
00129
00130
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AcacLanguage.cpp File Reference

Gui/AcacLanguage.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AcacLanguage.hpp"

Include dependency graph for AcacLanguage.cpp:

Generated on Tue Jan 24 20:37:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AcacLanguage.hpp File Reference

Gui/AcacLanguage.hpp File Reference

#include <Gui/AcacTypes.hpp>

Include dependency graph for AcacLanguage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AcacLanguage

Defines

#define | Apoxi_AcacLanguage_hpp

Define Documentation

#define Apoxi_AcacLanguage_hpp

Generated on Tue Jan 24 20:37:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AcacLanguage.hpp Source File

Gui/AcacLanguage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AcacLanguage_hpp)
00011 #define Apoxi_AcacLanguage_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014
00019 class AcacLanguage {
00020     public:
00026         AcacLanguage(const LanguageData *data);
00027
00028
00032         virtual ~AcacLanguage();
00033
00038         EntryId GetId() const { return m_data->id; };
00039
00044         const WCHAR *GetName() const { return m_data->name; };
00045
00050         const WCHAR *GetNativeName() const { return m_data->native_name; };
00051
00057         UINT16 GetNumberOfStrings() const { return m_data->string_count; };
00058
00063         const WCHAR* GetText(UINT16 index) const;
00064
00071         INT32 GetIndexOf(const WCHAR *text) const;
00072
00073     private:
00075         const LanguageData *        m_data;
00076
00078         const TranslationTable *    m_trans_table;
00079 };
00080
00081 #endif  // Apoxi_AcacLanguage_hpp
00082
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AcacTypes.hpp File Reference

Gui/AcacTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | tagCPGlyph
struct | tagCustFileData
struct | tagCustomizationPack
struct | tagDataPackHeader
struct | tagFilePackData
struct | tagFont
struct | tagFontFamily
struct | tagFontPack
struct | tagGlyphData
struct | tagLanguage
struct | tagLdbData
struct | tagT9Pack
struct | tagTextPack
struct | tagTranslationTable

Defines

#define | Apoxi_AcacTypes_hpp
#define | FILEPACK_ID 0x656C6966
#define | FONTPACK_ID 0x746E6F66
#define | INVALID_GLYPH_UNICODE 32
#define | T9PACK_ID 0x74636964
#define | TEXTPACK_ID 0x74786574
#define | TEXTPACK_KEYLANG_INDEX 0

Typedefs

typedef tagCPGlyph | CPGlyph
typedef tagCustFileData | CustFileData
typedef tagCustomizationPack | CustomizationPackData
typedef tagDataPackHeader | DataPackHeaderData
typedef UINT32 | DataPackId
typedef UINT8 | EntryId
typedef tagFilePackData | FilePackData
typedef tagFont | FontData
typedef tagFontFamily | FontFamily
typedef tagFontPack | FontPackData
typedef tagGlyphData | GlyphData
typedef tagLanguage | LanguageData
typedef tagLdbData | T9LdbData
typedef tagT9Pack | T9PackData
typedef tagTextPack | TextPackData
typedef tagTranslationTable | TranslationTable

Define Documentation

#define Apoxi_AcacTypes_hpp

#define FILEPACK_ID 0x656C6966

#define FONTPACK_ID 0x746E6F66

#define INVALID_GLYPH_UNICODE 32

#define T9PACK_ID 0x74636964

#define TEXTPACK_ID 0x74786574

#define TEXTPACK_KEYLANG_INDEX 0

Typedef Documentation

typedef struct tagCPGlyph CPGlyph

typedef struct tagCustFileData CustFileData

typedef struct tagCustomizationPack CustomizationPackData

typedef struct tagDataPackHeader DataPackHeaderData

typedef UINT32 DataPackId

typedef UINT8 EntryId

typedef struct tagFilePackData FilePackData

typedef struct tagFont FontData

typedef struct tagFontFamily FontFamily

typedef struct tagFontPack FontPackData

typedef struct tagGlyphData GlyphData

typedef struct tagLanguage LanguageData

typedef struct tagLdbData T9LdbData

typedef struct tagT9Pack T9PackData

typedef struct tagTextPack TextPackData

typedef struct tagTranslationTable TranslationTable

Generated on Tue Jan 24 20:37:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AcacTypes.hpp Source File

Gui/AcacTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AcacTypes_hpp)
00011 #define Apoxi_AcacTypes_hpp
00012
00013 #define TEXTPACK_ID 0x74786574  //74 65 78 74 = text
00014 #define FONTPACK_ID 0x746E6F66  //66 6F 6E 74 = font
00015 #define T9PACK_ID   0x74636964  //64 69 63 74 = dict
00016 #define FILEPACK_ID 0x656C6966  //66 69 6C 65 = file
00017 //UINT32 CUSTPACK_HEADER =  0x48434353; // SCCH
00018
00019 #define TEXTPACK_KEYLANG_INDEX 0
00020
00021 #define INVALID_GLYPH_UNICODE 32
00022
00023 #if defined(APOXI_FACTORY_CUSTOMIZATION_SUPPORT)
00024     #if !defined (APOXI_RTOS_NUC32) && !defined (APOXI_RTOS_WIN32)
00025         #undef APOXI_FACTORY_CUSTOMIZATION_SUPPORT
00026     #endif
00027 #endif
00028
00029 typedef UINT8 EntryId;
00030 typedef UINT32 DataPackId;
00031
00032 // Use this pragma for defining another alignment than 4 UINT8s.
00033 #pragma pack(push,ULOZ, 4)
00034
00035 // The following structures define the structures of the customization pack
00036 // Details about the members of the structures and the structures themselves
00037 // are described in Customization Pack Binary Structure.doc
00038 typedef struct tagCustomizationPack
00039 {
00040     UINT32      size;
00041     UINT32      header;
00042     UINT8       version;
00043     UINT8       running_version;
00044     UINT8       data_pack_count;
00045     UINT8       padding;
00046     UINT8       data_pack[1];
00047 } CustomizationPackData;
00048
00049
00050 typedef struct tagDataPackHeader
00051 {
00052     UINT32      size; //size is the whole size of the DataPack, including the
00053                       //size of the fixed members (size, header,..)
00054     UINT16      entry_count;
00055     UINT16      padding;
00056     DataPackId  data_pack_id;
00057     UINT8       data_pack_data[1];
00058 } DataPackHeaderData;
00059
00060
00061 typedef struct tagTextPack
00062 {
00063     UINT8   language[1];
00064 } TextPackData;
00065
00066
00067 typedef struct tagLanguage {
00068     UINT32      size;
00069     EntryId     id;
00070     UINT8       padding;
00071     UINT16      string_count;
00072     WCHAR       name[16];
00073     WCHAR       native_name[16];
00074     UINT16      offset_table[1];
00075 } LanguageData;
00076
00077 typedef struct tagTranslationTable {
00078     WCHAR       data[1];
00079 } TranslationTable;
00080
00081 typedef struct tagFontPack
00082 {
00083     UINT8       font[1];
00084 } FontPackData;
00085
00086 typedef struct tagFontFamily {
00087     WCHAR       family_name[16];
00088     BOOLEAN     serif;
00089     UINT8       padding[3];
00090 } FontFamily;
00091
00092 typedef struct tagFont {
00093     UINT32      size;
00094     EntryId     id;
00095     UINT8       baseline;
00096     UINT8       height;
00097     UINT8       gap_to_next_char;
00098     WCHAR       name[16];
00099     FontFamily  font_family;
00100     UINT8       table_count;
00101     UINT8       bold_index;
00102     UINT8       italic_index;
00103     UINT8       padding2;
00104     UINT16      num_glyphs;
00105     UINT8       padding3[2];
00106     UINT8       index_table[256];
00107     UINT32      offset_table[1];
00108 } FontData;
00109
00110 typedef struct tagGlyphData {
00111     UINT8 *     data_table;
00112 } GlyphData;
00113
00114 typedef struct tagCPGlyph {
00115     UINT8       size;
00116     UINT8       width;                  // Character width in pixels
00117     UINT8       data[1];                    // Pointer to the character bitmap
00118 } CPGlyph;
00119
00120 typedef struct tagT9Pack
00121 {
00122     UINT8       t9_pack[1];
00123 } T9PackData;
00124
00125 typedef struct tagLdbData {
00126     UINT32      size;
00127     UINT32      ldb_size;
00128     UINT16      ldb_id;
00129     UINT8       padding[2];
00130     UINT8       data[1];
00131 } T9LdbData;
00132
00133
00134 // Structures for storing arbitrary files
00135
00136 typedef struct  tagFilePackData
00137 {
00138     UINT8       cust_file[1];
00139 } FilePackData;
00140
00141 typedef struct tagCustFileData {
00142     UINT32      size;
00143     UINT8       mime_type;
00144     UINT8       padding[3];
00145     WCHAR       file_name[32];
00146     UINT32      file_size;
00147     UINT8       data[1];
00148 } CustFileData;
00149
00150 #pragma pack(pop,ULOZ)
00151
00152
00153 #endif //Apoxi_AcacTypes_hpp
00154
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Action.cpp File Reference

Gui/Action.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Action.hpp"
#include <Kernel/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/Dispatcher.hpp>

Include dependency graph for Action.cpp:

Generated on Tue Jan 24 20:37:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Action.hpp File Reference

Gui/Action.hpp File Reference

#include <Gui/Item.hpp>
#include <Kernel/Dispatcher.hpp>

Include dependency graph for Action.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Action

Defines

#define | Apoxi_Action_hpp

Define Documentation

#define Apoxi_Action_hpp

Generated on Tue Jan 24 20:37:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Action.hpp Source File

Gui/Action.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Action_hpp)
00010 #define Apoxi_Action_hpp
00014
00015 class ResourceParser;
00016 class ActionExtension;
00017
00018 #include <Gui/Item.hpp>
00019 #include <Kernel/Dispatcher.hpp>
00020
00069 class Action : public Item {
00070     typedef Item Base;
00071
00072     public:
00073         enum {
00074             ID = 1
00075         };
00076
00077         typedef void (Dispatcher::*ExecFn)();
00078
00081         Action();
00082
00090         Action(Dispatcher* dispatcher,
00091                const WCHAR* text,
00092                const BitmapRes* icon = 0,
00093                BOOLEAN enabled = TRUE);
00094
00102         Action(Dispatcher* dispatcher,
00103                const WString& text,
00104                const BitmapRes* icon = 0,
00105                BOOLEAN enabled = TRUE);
00106
00114         Action(Dispatcher* dispatcher,
00115                const WString& text,
00116                const ImageObtainer& icon,
00117                BOOLEAN enabled = TRUE);
00118
00126         Action(Dispatcher* dispatcher,
00127                const WString& text,
00128                const IconSet& icon_set,
00129                BOOLEAN enabled = TRUE);
00130
00143         Action(Dispatcher* dispatcher,
00144                const WString& text,
00145                ExecFn exec_fn);
00146
00148         virtual ~Action();
00149
00157         void Init(Dispatcher* dispatcher,
00158                   const WCHAR* text,
00159                   const BitmapRes* icon = 0,
00160                   BOOLEAN enabled = TRUE);
00161
00169         void Init(Dispatcher* dispatcher,
00170                   const WString& text,
00171                   const BitmapRes* icon = 0,
00172                   BOOLEAN enabled = TRUE);
00173
00181         void Init(Dispatcher* dispatcher,
00182                   const WString& text,
00183                   const ImageObtainer& icon,
00184                   BOOLEAN enabled = TRUE);
00185
00193         void Init(Dispatcher* dispatcher,
00194                   const WString& text,
00195                   const IconSet& icon_set,
00196                   BOOLEAN enabled = TRUE);
00197
00210         void Init(Dispatcher* dispatcher,
00211                   const WString& text,
00212                   ExecFn exec_fn);
00213
00216         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00217
00224         virtual BOOLEAN Execute();
00225
00227         virtual BOOLEAN IsInstanceOf(INT id) const;
00228
00234         void SetExecFn(ExecFn exec_fn) { m_exec_fn = exec_fn; }
00235
00238         ExecFn GetExecFn() const { return m_exec_fn; }
00239
00240 #ifdef APOXI_COMPAT_2_2_0
00241
00242         Action(const WCHAR* text,
00243                const BitmapRes* icon = 0,
00244                BOOLEAN enabled = TRUE);
00245
00247         void Init(const WCHAR* text,
00248                   const BitmapRes* icon = 0,
00249                   BOOLEAN enabled = TRUE);
00250
00252         void SetBitmap(const BitmapRes* bitmap);
00253
00255         const BitmapRes* GetBitmap() const;
00256
00259         virtual const ActionExtension* GetExtension() const;
00260 #endif // APOXI_COMPAT_2_2_0
00261
00262     private:
00263         ExecFn m_exec_fn;
00264 };
00265
00267 #endif  // Apoxi_Action_hpp
00268
00269
Generated on Tue Jan 24 14:49:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ActionExtension.hpp File Reference

Gui/ActionExtension.hpp File Reference

#include <Compat/ActionExtension.hpp>

Include dependency graph for ActionExtension.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:15:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ActionExtension.hpp Source File

Gui/ActionExtension.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class ActionExtension has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/ActionExtension.hpp>
00014
00015
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Alert.cpp File Reference

Gui/Alert.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Alert.hpp"
#include "PaintDc.hpp"
#include "ClientDc.hpp"
#include <Kernel/Application.hpp>
#include <Kernel/AppContainer.hpp>

Include dependency graph for Alert.cpp:

Generated on Tue Jan 24 20:37:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Alert.hpp File Reference

Gui/Alert.hpp File Reference

#include <Gui/Window.hpp>
#include <Gui/TextFormat.hpp>
#include <Kernel/Condition.hpp>

Include dependency graph for Alert.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Alert
class | Alert::CloseCondition

Defines

#define | Apoxi_Alert_hpp

Define Documentation

#define Apoxi_Alert_hpp

Generated on Tue Jan 24 20:37:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Alert.hpp Source File

Gui/Alert.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Alert_hpp)
00010 #define Apoxi_Alert_hpp
00014
00015 #include <Gui/Window.hpp>
00016 #include <Gui/TextFormat.hpp>
00017 #include <Kernel/Condition.hpp>
00018
00025 class Alert : public Window {
00026     typedef Window Base;
00027
00028     public:
00029         enum {
00030             ID = 4
00031         };
00032
00035         Alert();
00036
00040         Alert(const WCHAR* text, INT delay = -1);
00041
00045         Alert(const WString& text, INT delay = -1);
00046
00048         virtual ~Alert();
00049
00053         void Init(const WCHAR* text, INT delay = -1);
00054
00058         void Init(const WString& text, INT delay = -1);
00059
00061         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00062
00064         virtual BOOLEAN IsInstanceOf(INT id) const;
00065
00067         void SetText(const WCHAR* text);
00068
00070         void SetText(const WString& text);
00071
00073         const WString& GetText() const { return m_text; }
00074
00078         void SetDelay(INT delay);
00079
00081         INT GetDelay() const { return m_delay; }
00082
00084         void SetTextFormat(const TextFormat& text_format) { m_text_format = text_format; }
00085
00087         const TextFormat& GetTextFormat() const { return m_text_format; }
00088
00090         virtual void OpenModeless(const Rect& rect = Rect());
00091
00093         virtual INT OpenModal(const Rect& rect = Rect());
00094
00098         BOOLEAN CloseImmediately();
00099
00100     protected:
00102         virtual BOOLEAN OnMessage(const Message& msg);
00103
00105         virtual void OnPaint(const Rect& repaint_rect);
00106
00108         virtual BOOLEAN OnTimeout(const Timer& timer);
00109
00111         virtual void OnClose();
00112
00113     private:
00114         class CloseCondition : public Condition {
00115             public:
00116                 explicit CloseCondition(const Timer* timer) : m_timer(timer) { }
00117                 virtual BOOLEAN IsTrue() const { return !m_timer->IsActive(); }
00118             private:
00119                 const Timer* m_timer;
00120         };
00121
00122         BOOLEAN     m_auto_close;
00123         INT         m_delay;
00124         WString     m_text;
00125         Timer       m_timer;
00126         TextFormat  m_text_format;
00127
00128         void InitProperties(const WCHAR* text, INT delay);
00129         void StartTimer();
00130 };
00131
00133 #endif  // Apoxi_Alert_hpp
00134
00135
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AnimatedTextLine.cpp File Reference

Gui/AnimatedTextLine.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TextLine.hpp"
#include "PaintDc.hpp"
#include "AnimatedTextLine.hpp"
#include "Locale.hpp"
#include "Control.hpp"

Include dependency graph for AnimatedTextLine.cpp:

Generated on Tue Jan 24 20:37:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AnimatedTextLine.hpp File Reference

Gui/AnimatedTextLine.hpp File Reference

#include <Auxiliary/TriggerTimer.hpp>
#include <Gui/TextLine.hpp>

Include dependency graph for AnimatedTextLine.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AnimatedTextLine
class | AnimatedTextLineView

Defines

#define | Apoxi_AnimatedTextLine_hpp

Define Documentation

#define Apoxi_AnimatedTextLine_hpp

Generated on Tue Jan 24 20:37:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AnimatedTextLine.hpp Source File

Gui/AnimatedTextLine.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AnimatedTextLine_hpp)
00010 #define Apoxi_AnimatedTextLine_hpp
00014
00015 #include <Auxiliary/TriggerTimer.hpp>
00016 #include <Gui/TextLine.hpp>
00017
00020 class AnimatedTextLineView : public TextLineView {
00021     typedef TextLineView Base;
00022
00023     public:
00024         AnimatedTextLineView();
00025         virtual ~AnimatedTextLineView();
00026
00027     private:
00029         virtual void Draw(const Component& component,
00030                           DeviceContext* dc,
00031                           const Rect& repaint_rect) const;
00032 };
00033
00037 class AnimatedTextLine : public TextLine {
00038     typedef TextLine Base;
00039
00040     public:
00041         enum {
00042             ID = 5
00043         };
00044
00045         enum Type {
00047             Bounce,
00049             Cycle,
00051             OnlyOnce
00052         };
00053
00056         AnimatedTextLine();
00057
00072         AnimatedTextLine(Control* control,
00073                          const WCHAR* text = 0,
00074                          const TextFormat& text_format = TextFormat(),
00075                          Type anim_type = Cycle,
00076                          UINT16 start_delay = 300,
00077                          UINT16 anim_speed = 200,
00078                          XYDIM step = 2,
00079                          BOOLEAN auto_start = FALSE);
00080
00081         virtual ~AnimatedTextLine();
00082
00084         void SetHighlighted(BOOLEAN highlighted) const;
00085
00100         void Init(Control* control,
00101                   const WCHAR* text = 0,
00102                   const TextFormat& text_format = TextFormat(),
00103                   Type anim_type = Cycle,
00104                   UINT16 start_delay = 300,
00105                   UINT16 anim_speed = 200,
00106                   XYDIM step = 2,
00107                   BOOLEAN auto_start = FALSE);
00108
00111         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00112
00114         virtual BOOLEAN IsInstanceOf(INT id) const;
00115
00117         virtual void SetText(const WCHAR* text);
00118
00120         virtual void SetTextFormat(const TextFormat& text_format);
00121
00123         virtual void SetFont(const Font& font);
00124
00129         void Start();
00130
00132         void Stop();
00133
00135         BOOLEAN IsStarted() const { return m_started; }
00136
00138         Type GetType() const { return m_type; }
00139
00141         INT GetOffset() const { return m_offset; }
00142
00145         XYDIM GetStep() const { return m_step; }
00146
00149         XYDIM GetTextGap() const;
00150
00151     protected:
00153         virtual void OnResize(XYDIM dx, XYDIM dy);
00154
00156         virtual void Cleanup();
00157
00159         virtual void Refresh(const Rect& rect);
00160
00161
00162     private:
00163         friend class TriggerTimer<AnimatedTextLine>;
00164
00165         BOOLEAN m_started;
00166         BOOLEAN m_auto_start;
00167         XYDIM m_offset;
00168         XYDIM m_step;
00169         Type m_type;
00170         UINT16 m_animation_speed;
00171         TriggerTimer<AnimatedTextLine> m_timer;
00172
00173         static AnimatedTextLineView m_view;
00174
00175         void UpdateAnimationState();
00176         void OnTimer();
00177
00179         XYDIM GetTextWidth() const;
00180 };
00181
00183 #endif  // Apoxi_AnimatedTextLine_hpp
00184
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Animation.hpp File Reference

Gui/Animation.hpp File Reference

#include <Compat/Animation.hpp>

Include dependency graph for Animation.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:16:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Animation.hpp Source File

Gui/Animation.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class Animation has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6. Use
00013     the class ImageBox instead.*/
00014 #include <Compat/Animation.hpp>
00015
00016
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ApoxiGuiVersion.cpp File Reference

Gui/ApoxiGuiVersion.cpp File Reference

#include "Gui/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiGuiVersion.cpp:

Functions

ApoxiDefVersionInfo (Gui, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | Gui | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 20:37:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ArabicTextRenderer.cpp File Reference

Gui/ArabicTextRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ArabicTextRenderer.hpp"

Include dependency graph for ArabicTextRenderer.cpp:

Defines

#define | L2R -1
#define | R2L 1

Define Documentation

#define L2R -1

#define R2L 1

Generated on Tue Jan 24 20:37:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ArabicTextRenderer.hpp File Reference

Gui/ArabicTextRenderer.hpp File Reference

#include <Gui/AbstractTextRenderer.hpp>

Include dependency graph for ArabicTextRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ArabicTextRenderer

Defines

#define | Apoxi_ArabicTextRenderer_hpp

Define Documentation

#define Apoxi_ArabicTextRenderer_hpp

Generated on Tue Jan 24 20:37:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ArabicTextRenderer.hpp Source File

Gui/ArabicTextRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ArabicTextRenderer_hpp)
00010 #define Apoxi_ArabicTextRenderer_hpp
00013
00014 #include <Gui/AbstractTextRenderer.hpp>
00015
00017 class ArabicTextRenderer : public AbstractTextRenderer {
00018     typedef AbstractTextRenderer Base;
00019
00020     public:
00021         virtual ~ArabicTextRenderer();
00022
00024         static ArabicTextRenderer& GetInstance();
00025
00030         virtual XYDIM DrawText(DeviceContext* dc,
00031                                const Rect& clip_rect,
00032                                XYDIM x,
00033                                XYDIM y,
00034                                const WCHAR* text,
00035                                INT from,
00036                                INT char_count);
00037
00042         virtual INT GetTextWidth(const WCHAR* text,
00043                                  const Font& font,
00044                                  TextAttr text_attr,
00045                                  INT from,
00046                                  INT char_count,
00047                                  BOOLEAN include_gap = FALSE);
00048
00053         virtual INT WrapLine(const WCHAR* text,
00054                              const Font& font,
00055                              TextAttr text_attr,
00056                              INT char_count,
00057                              XYDIM max_width = -1,
00058                              WrapPolicy policy = (WrapPolicy)0, // this awkward construction is forced on us by the egold compiler. 0 is WhitespaceWrap
00059                              BOOLEAN include_gap_at_end = FALSE,
00060                              Size* total_size = 0,
00061                              INT* ws_at_eol_count = 0,
00062                              XYDIM* ws_at_eol_width = 0,
00063                              INT* last_whitespace_index = 0);
00064
00065     protected:
00066         ArabicTextRenderer();
00067
00070         virtual Size GetGlyph(const WCHAR* cur_text_pos,
00071                               const WCHAR* substitution_char,
00072                               INT n_chars,
00073                               GlyphPtr glyph,
00074                               INT& parsed_glyphs,
00075                               BOOLEAN& is_diacritic);
00076
00077     private:
00078         enum CharacterPosition {
00079             Final = 0,
00080             Medial = 1,
00081             Initial = 2,
00082             Isolated = 3
00083         };
00084
00087         BOOLEAN IsBindingLetter(WCHAR chr) const;
00088
00089         INT m_direction; // direction in which the text is parsed. DrawText and GetTextWidth need R2L, WrapLine needs L2R
00090 };
00091
00092
00094 #endif // Apoxi_ArabicTextRenderer_hpp
00095
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AtomItem.cpp File Reference

Gui/AtomItem.cpp File Reference

#include "Gui/PreComp.hpp"
#include "AtomItem.hpp"
#include "EditorDocument.hpp"

Include dependency graph for AtomItem.cpp:

Generated on Tue Jan 24 20:37:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AtomItem.hpp File Reference

Gui/AtomItem.hpp File Reference

#include <Gui/AbstractEditorItem.hpp>

Include dependency graph for AtomItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AtomItem

Defines

#define | Apoxi_AtomItem_hpp

Define Documentation

#define Apoxi_AtomItem_hpp

Generated on Tue Jan 24 20:37:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/AtomItem.hpp Source File

Gui/AtomItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AtomItem_hpp)
00011 #define Apoxi_AtomItem_hpp
00015
00016 #include <Gui/AbstractEditorItem.hpp>
00017
00018 class DeviceContext;
00019
00023 class AtomItem : public AbstractEditorItem {
00024     typedef AbstractEditorItem Base;
00025
00026     public:
00027         enum {
00028             ID = 0
00029         };
00030
00032         AtomItem();
00033
00035         virtual ~AtomItem();
00036
00038         virtual INT GetId() const;
00039
00041         virtual void Draw(DeviceContext* dc, const Rect& bounds) const = 0;
00042
00048         virtual AtomItem* Clone() const = 0;
00049
00051         virtual BOOLEAN IsInstanceOf(INT id) const;
00052 };
00053
00055 #endif  // Apoxi_AtomItem_hpp
00056
00057
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BasicPackConnector.cpp File Reference

Gui/BasicPackConnector.cpp File Reference

#include "Gui/PreComp.hpp"
#include "BasicPackConnector.hpp"
#include <stdio.h>
#include <stdlib.h>
#include <Afs/Ffs/FlsFile.hpp>
#include "TextPackConnector.hpp"
#include "FontPackConnector.hpp"
#include "FilePackConnector.hpp"

Include dependency graph for BasicPackConnector.cpp:

Generated on Tue Jan 24 20:37:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BasicPackConnector.hpp File Reference

Gui/BasicPackConnector.hpp File Reference

#include <Gui/DataPack.hpp>
#include <Gui/TextPack.hpp>
#include <Gui/FontPack.hpp>
#include <Gui/FilePack.hpp>
#include <Gui/AcacTypes.hpp>

Include dependency graph for BasicPackConnector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BasicPackConnector

Defines

#define | Apoxi_BasicPackConnector_hpp

Define Documentation

#define Apoxi_BasicPackConnector_hpp

Generated on Tue Jan 24 20:38:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BasicPackConnector.hpp Source File

Gui/BasicPackConnector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BasicPackConnector_hpp)
00011 #define Apoxi_BasicPackConnector_hpp
00012
00013 #include <Gui/DataPack.hpp>
00014 #include <Gui/TextPack.hpp>
00015 #include <Gui/FontPack.hpp>
00016 #include <Gui/FilePack.hpp>
00017 #include <Gui/AcacTypes.hpp>
00018
00023 class BasicPackConnector {
00024     public:
00025
00031         static void Init();
00032
00038         static const DataPack *GetDataPack(DataPackId datapack_id);
00039
00047         static BOOLEAN ContainsDataPack(DataPackId datapack_id);
00048
00055         static UINT32 GetSizeOfDataPack(DataPackId datapack_id);
00056
00063         static UINT16 GetNumberOfEntries(DataPackId datapack_id);
00064
00065     protected:
00070         BasicPackConnector();
00074         virtual ~BasicPackConnector();
00075
00076
00077     private:
00082         static void InitDataPacks(const DataPackHeaderData *dphd);
00083
00085         static DataPack **  m_datapacks;
00086
00088         static UINT8 *  cp_handle;
00089
00091         static UINT32       m_number_of_datapacks;
00092
00094         static BOOLEAN      m_is_initialized;
00095 };
00096
00097 #endif  // Apoxi_BasicPackConnector_hpp
00098
00099
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BidiManager.cpp File Reference

Gui/BidiManager.cpp File Reference

#include "Gui/PreComp.hpp"
#include "BidiManager.hpp"

Include dependency graph for BidiManager.cpp:

Defines

#define | IsOdd(x) ((x) & 1)
#define | IsRightToLeftCharacter(ch) (((ch >= 0x591) && (ch <= 0x5f4)) || ((ch >= 0x60c) && (ch <= 0x6fe)))

Variables

const INT | c_level_max = 61
const INT | c_ls = 0x13

Define Documentation

#define IsOdd ( x ) ((x) & 1)

#define IsRightToLeftCharacter ( ch ) (((ch >= 0x591) && (ch <= 0x5f4)) || ((ch >= 0x60c) && (ch <= 0x6fe)))

Variable Documentation

const INT c_level_max = 61

const INT c_ls = 0x13

Generated on Tue Jan 24 20:38:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BidiManager.hpp File Reference

Gui/BidiManager.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for BidiManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BidiManager
struct | BidiManager::ParagraphContext

Defines

#define | Apoxi_BidiManager_hpp

Define Documentation

#define Apoxi_BidiManager_hpp

Generated on Tue Jan 24 20:38:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BidiManager.hpp Source File

Gui/BidiManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------
00008
00009     The implementation of the class BidiManager has been taken from the
00010     sample implementation of the Unicode Bidirectional Algorithm and
00011     has been adapted to work within APOXI. See
00012     http://www.unicode.org/unicode/reports/tr9 for the sample
00013     implementation.
00014
00015     Original quote:
00016     "Disclaimer and legal rights: This file contains bugs.
00017     All representations to the contrary are void.
00018
00019     Source code in this file and the accompanying headers and included files
00020     may be distributed free of charge by anyone, as long as full credit is
00021     given and any and all liabilities are assumed by the recipient.
00022
00023     Written by: Asmus Freytag
00024     Command line interface by: Rick McGowan
00025     Verification and Test Harness: Doug Felt
00026
00027     Copyright (C) 1999, ASMUS, Inc. All Rights Reserved"
00028     ------------------------------------------------------------------------ */
00029
00030 #if !defined(Apoxi_BidiManager_hpp)
00031 #define Apoxi_BidiManager_hpp
00034
00035 #include <Kernel/Types.hpp>
00036
00041 class BidiManager {
00042     public:
00043         enum CharType {
00044             NeutralType,
00045             LeftToRightType,
00046             RightToLeftType
00047         };
00048
00049         struct ParagraphContext {
00050             WCHAR* dest_text;
00051             INT* dest_pos;
00052             INT* types;
00053             INT* levels;
00054             INT base_level;
00055             INT from;
00056             INT count;
00057         };
00058
00060         static BidiManager* GetInstance();
00061
00067         void SetActive(BOOLEAN flag) { m_is_active = flag; }
00068
00070         BOOLEAN IsActive() const { return m_is_active; }
00071
00073         ParagraphContext* BeginProcessing(const WCHAR* text, INT from = 0, INT count = -1);
00074
00076         void EndProcessing(ParagraphContext* context);
00077
00080         const WCHAR* GetConvertedText(ParagraphContext* context,
00081                                       INT from = 0,
00082                                       INT count = -1,
00083                                       INT* cursor_pos = 0);
00084
00087         const INT* GetConvertedPositions(ParagraphContext* context,
00088                                          INT from = 0) const
00089         {
00090             if (!m_alloc_ok)
00091                 return 0;
00092             else
00093                 return &context->dest_pos[from];
00094         }
00095
00101         INT RemoveFormattingCodes(WCHAR* text, INT char_count);
00102
00104         CharType GetCharType(WCHAR chr) const;
00105
00106     private:
00112         enum BidiType {
00113             ON = 0,  // Other Neutral
00114             L,       // Left Letter
00115             R,       // Right Letter
00116             AN,      // Arabic Number
00117             EN,      // European Number
00118             AL,      // Arabic Letter (Right-to-left)
00119             NSM,     // Non-spacing Mark
00120             CS,      // Common Separator
00121             ES,      // European Separator
00122             ET,      // European Terminator (post/prefix e.g. $ and %)
00123
00124             // resolved types
00125             BN,      // Boundary neutral (type of RLE etc after explicit levels)
00126
00127             // input types,
00128             S,       // Segment Separator (TAB) - used only in L1
00129             WS,      // White space - used only in L1
00130             B,       // Paragraph Separator (aka as PS)
00131
00132             // types for explicit controls
00133             RLO,     // these are used only in X1-X9
00134             RLE,
00135             LRO,
00136             LRE,
00137             PDF,
00138
00139             // resolved types, also resolved directions
00140             N = ON,  // alias, where ON, WS and S are treated the same
00141         };
00142
00143         enum State {
00144             xa,     //  arabic letter
00145             xr,     //  right leter
00146             xl,     //  left letter
00147
00148             ao,     //  arabic lett. foll by ON
00149             ro,     //  right lett. foll by ON
00150             lo,     //  left lett. foll by ON
00151
00152             rt,     //  ET following R
00153             lt,     //  ET following L
00154
00155             cn,     //  EN, AN following AL
00156             ra,     //  arabic number foll R
00157             re,     //  european number foll R
00158             la,     //  arabic number foll L
00159             le,     //  european number foll L
00160
00161             ac,     //  CS following cn
00162             rc,     //  CS following ra
00163             rs,     //  CS,ES following re
00164             lc,     //  CS following la
00165             ls,     //  CS,ES following le
00166
00167             ret,    //  ET following re
00168             let,    //  ET following le
00169         };
00170
00171         enum Action {
00172             // primitives
00173             IX = 0x100,                 // increment
00174             XX = 0xF,                   // no-op
00175
00176             // actions
00177             xxx = (XX << 4) + XX,       // no-op
00178             xIx = IX + xxx,             // increment run
00179             xxN = (XX << 4) + ON,       // set current to N
00180             xxE = (XX << 4) + EN,       // set current to EN
00181             xxA = (XX << 4) + AN,       // set current to AN
00182             xxR = (XX << 4) + R,        // set current to R
00183             xxL = (XX << 4) + L,        // set current to L
00184             Nxx = (ON << 4) + 0xF,      // set run to neutral
00185             Axx = (AN << 4) + 0xF,      // set run to AN
00186             ExE = (EN << 4) + EN,       // set run to EN, set current to EN
00187             NIx = (ON << 4) + 0xF + IX, // set run to N, increment
00188             NxN = (ON << 4) + ON,       // set run to N, set current to N
00189             NxR = (ON << 4) + R,        // set run to N, set current to R
00190             NxE = (ON << 4) + EN,       // set run to N, set current to EN
00191
00192             AxA = (AN << 4) + AN,       // set run to AN, set current to AN
00193             NxL = (ON << 4) + L,        // set run to N, set current to L
00194             LxL = (L << 4) + L,         // set run to L, set current to L
00195         };
00196
00197         enum ActionValue {
00198             // action to resolve previous input
00199             nL = L,         // resolve EN to L
00200             En = 3 << 4,    // resolve neutrals run to embedding level direction
00201             Rn = R << 4,    // resolve neutrals run to strong right
00202             Ln = L << 4,    // resolved neutrals run to strong left
00203             In = (1<<8),    // increment count of deferred neutrals
00204             LnL = (1<<4)+L, // set run and EN to L
00205         };
00206
00207         enum StateValue {
00208             r,  // R and characters resolved to R
00209             l,  // L and characters resolved to L
00210             rn, // N preceded by right
00211             ln, // N preceded by left
00212             a,  // AN preceded by left (the abbrev 'la' is used up above)
00213             na, // N preceeded by a
00214         };
00215
00216         BOOLEAN m_is_active;
00217         ParagraphContext m_context;
00218
00219         static INT m_char_types[];
00220         static INT m_bidi_types[];
00221         static INT m_weak_state[][10];
00222         static INT m_weak_action[][10];
00223         static INT m_action_neutrals[][5];
00224         static INT m_state_neutrals[][5];
00225         static INT m_add_level[][4];
00226
00227         INT m_max_length;
00228         BOOLEAN m_alloc_ok;
00229
00231         BidiManager();
00232
00241         INT Classify(const WCHAR* dest_text,
00242                      INT* pcls,
00243                      INT char_count,
00244                      BOOLEAN whitespace = FALSE);
00245
00255         INT ResolveParagraphs(INT* types, INT char_count);
00256
00262         INT GetBaseLevel(const INT* pcls, INT char_count);
00263
00278         INT ResolveExplicit(INT level,
00279                             INT dir,
00280                             INT* pcls,
00281                             INT* p_level,
00282                             INT char_count,
00283                             INT depth = 0);
00284
00293         void ResolveWeak(INT base_level, INT* pcls, INT* p_level, INT char_count);
00294
00301         void ResolveNeutrals(INT base_level,
00302                              INT* pcls,
00303                              const INT* p_level,
00304                              INT char_count);
00305
00311         void ResolveImplicit(const INT* pcls, INT* p_level, INT char_count);
00312
00321         INT ResolveLines(const WCHAR* dest_text, BOOLEAN* pbrk, INT char_count);
00322
00333         void ResolveWhitespace(INT base_level, const INT* pcls, INT* p_level,
00334                                INT char_count);
00335
00341         INT Reorder(INT base_level,
00342                     WCHAR* dest_text,
00343                     INT* dest_pos,
00344                     const INT* p_level,
00345                     INT char_count,
00346                     INT* cursor_pos);
00347
00349         INT ReorderLevel(INT level,
00350                          WCHAR* dest_text,
00351                          INT* dest_pos,
00352                          const INT* p_level,
00353                          INT start_idx,
00354                          INT char_count,
00355                          INT* cursor_pos,
00356                          BOOLEAN reverse = FALSE);
00357
00362         void MirrorText(WCHAR* dest_text, const INT * p_level, INT char_count);
00363
00365         void WrapLine(INT base_level,
00366                       WCHAR* dest_text,
00367                       INT* dest_pos,
00368                       INT* pcls_line,
00369                       INT* p_level_line,
00370                       INT char_count,
00371                       BOOLEAN mirror,
00372                       INT* cursor_pos,
00373                       BOOLEAN* pbrk = 0);
00374
00375         INT ClassFromChN(WCHAR ch);
00376         INT ClassFromChWS(WCHAR ch);
00377         void SetDeferredRun(INT* pval, INT count, INT start, INT value);
00378         INT GreaterEven(INT i);
00379         INT GreaterOdd(INT i);
00380         INT EmbeddingDirection(INT level);
00381         INT GetDeferredType(INT action);
00382         INT GetResolvedType(INT action);
00383         INT GetDeferredNeutrals(INT action, INT level);
00384         INT GetResolvedNeutrals(INT action);
00385
00386         static BidiManager m_bidi_manager;
00387 };
00388
00389
00391 #endif // Apoxi_BidiManager_hpp
00392
00393
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Bitmap.cpp File Reference

Gui/Bitmap.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Bitmap.hpp"
#include "BitmapDc.hpp"
#include <Config/DisplayConfig.hpp>

Include dependency graph for Bitmap.cpp:

Generated on Tue Jan 24 20:38:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Bitmap.hpp File Reference

Gui/Bitmap.hpp File Reference

#include <Gui/Color.hpp>
#include <Gui/Size.hpp>

Include dependency graph for Bitmap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Bitmap
struct | BitmapRes

Defines

#define | Apoxi_Bitmap_hpp

Define Documentation

#define Apoxi_Bitmap_hpp

Generated on Tue Jan 24 20:38:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Bitmap.hpp Source File

Gui/Bitmap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Bitmap_hpp)
00010 #define Apoxi_Bitmap_hpp
00013
00014 #include <Gui/Color.hpp>
00015 #include <Gui/Size.hpp>
00016
00017 class Rect;
00018 class DeviceContext;
00019
00025 struct BitmapRes {
00027     XYDIM GetWidth() const { return m_width; };
00028
00030     XYDIM GetHeight() const { return m_height; };
00031
00033     const DDrvAtomPtr GetBits() const { return m_bits; };
00034
00036     const DDrvAtomPtr GetAlphaMask() const {
00037                                             #ifdef APOXI_ENABLE_ALPHA_BLENDING
00038                                                 return m_alphamask;
00039                                             #else
00040                                                 return 0;
00041                                             #endif
00042                                             }
00043
00045     BOOLEAN IsTransparent() const { return (BOOLEAN)m_flags.transparent; }
00046
00048     BOOLEAN IsCompressed() const { return (BOOLEAN)m_flags.compressed; }
00049
00051     BOOLEAN IsCopyrighted() const { return (BOOLEAN)m_flags.copyrighted; }
00052
00054     BOOLEAN IsAlphaBlendingEnabled() const {
00055 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00056                                                 return (BOOLEAN)m_flags.alpha_blending_enabled;
00057 #else
00058                                                 return 0;
00059 #endif
00060                                             }
00061
00063     BOOLEAN HasNativeImageData() const { return (BOOLEAN)m_flags.has_native_img_data; }
00064
00066     ColorValue GetTransparentColor() const { return m_transparent_color; }
00067
00068     // Important: the order of the members must match with the order of the members
00069     // of the class Bitmap!
00070     struct {
00071         UINT transparent            : 1;
00072         UINT compressed             : 1;
00073         UINT copyrighted            : 1;
00074 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00075         UINT alpha_blending_enabled : 1;
00076 #endif
00077         UINT has_native_img_data    : 1;
00078     } m_flags;
00079     XYDIM m_width;
00080     XYDIM m_height;
00081     const DDrvAtomPtr m_bits;
00082     ColorValue  m_transparent_color;
00083 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00084     const DDrvAtomPtr m_alphamask;
00085 #endif
00086 };
00087
00092 class Bitmap {
00093     typedef BitmapRes Base;
00094
00095     public:
00097         Bitmap();
00098
00137         Bitmap(XYDIM width,
00138                XYDIM height,
00139                BOOLEAN transparent = FALSE,
00140                ColorValue transparent_color = 0,
00141                BOOLEAN compressed = FALSE,
00142                BOOLEAN copyrighted = FALSE,
00143                INT display_idx = 0,
00144                DDrvAtomPtr external_buffer = 0,
00145                BOOLEAN free_external_buffer = FALSE,
00146                BOOLEAN create_alpha_mask = FALSE);
00147
00149         ~Bitmap();
00150
00152         operator BitmapRes() const;
00153
00156         static UINT32 GetBufferByteCount(XYDIM width, XYDIM height, INT display_idx = 0);
00157
00159         XYDIM GetWidth() const { return m_width; };
00160
00162         void SetWidth(XYDIM width) { m_width = width; };
00163
00165         XYDIM GetHeight() const { return m_height; };
00166
00168         void SetHeight(XYDIM height) { m_height = height; };
00169
00171         DDrvAtomPtr GetBits() const { return m_bits; };
00172
00178         void SetBits(DDrvAtomPtr bits, BOOLEAN free_external_buffer = FALSE);
00179
00181         void SetTransparent(BOOLEAN flag) { m_flags.transparent = flag; }
00182
00184         BOOLEAN IsTransparent() const { return (BOOLEAN)m_flags.transparent; }
00185
00187         BOOLEAN IsCompressed() const { return (BOOLEAN)m_flags.compressed; }
00188
00190         BOOLEAN IsCopyrighted() const { return (BOOLEAN)m_flags.copyrighted; }
00191
00193         BOOLEAN HasNativeImageData() const { return (BOOLEAN)m_flags.has_native_img_data; }
00194
00199         BOOLEAN IsValid() const { return m_bits != 0; }
00200
00202         void SetTransparentColor(ColorValue color) { m_transparent_color = color; }
00203
00206         ColorValue GetTransparentColor() const { return m_transparent_color; }
00207
00209         DDrvAtomPtr GetAlphaMask() const {
00210 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00211                                             return m_alphamask;
00212 #else
00213                                             return 0;
00214 #endif
00215                                             }
00217         void SetAlphaMask(DDrvAtomPtr alphamask);
00218
00220         void SetAlphaValue(XYDIM x, XYDIM y, UINT8 alpha_value);
00221
00223         UINT8 GetAlphaValue(XYDIM x, XYDIM y) const;
00224
00226         BOOLEAN IsAlphaBlendingEnabled() const {
00227 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00228                                                 return (BOOLEAN)m_flags.alpha_blending_enabled;
00229 #else
00230                                                 return FALSE;
00231 #endif
00232                                             }
00233
00235         void SetAlphaBlendingEnabled(BOOLEAN alpha_enabled) {
00236 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00237                                                 m_flags.alpha_blending_enabled = alpha_enabled;
00238 #endif
00239                                                 }
00240     private:
00241         // Important: the order of the members must match with the order of the members
00242         // of the struct BitmapRes!
00243         struct {
00244             UINT transparent                : 1;
00245             UINT compressed                 : 1;
00246             UINT copyrighted                : 1;
00247 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00248             UINT alpha_blending_enabled     : 1;
00249 #endif
00250             UINT has_native_img_data        : 1;
00251             UINT free_external_buffer       : 1;
00252             UINT external_buffer            : 1;
00253 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00254             UINT alpha_external_buffer      : 1;
00255             UINT alpha_free_external_buffer : 1;
00256 #endif
00257         } m_flags;
00258
00259         XYDIM       m_width;
00260         XYDIM       m_height;
00261         DDrvAtomPtr m_bits;
00262         ColorValue  m_transparent_color;
00263 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00264         DDrvAtomPtr m_alphamask;
00265 #endif
00266 };
00267
00269 #endif  // Apoxi_Bitmap_hpp
00270
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BitmapDc.cpp File Reference

Gui/BitmapDc.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/BitmapDc.hpp"
#include "Gui/Control.hpp"
#include "Devices/Device.hpp"
#include "Kernel/System.hpp"
#include <Config/DisplayConfig.hpp>

Include dependency graph for BitmapDc.cpp:

Generated on Tue Jan 24 20:38:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BitmapDc.hpp File Reference

Gui/BitmapDc.hpp File Reference

#include <Gui/DeviceContext.hpp>

Include dependency graph for BitmapDc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BitmapDc
Device-context for a Bitmap. More...

Defines

#define | Apoxi_BitmapDc_hpp

Define Documentation

#define Apoxi_BitmapDc_hpp

Generated on Tue Jan 24 20:38:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/BitmapDc.hpp Source File

Gui/BitmapDc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_BitmapDc_hpp)
00010 #define Apoxi_BitmapDc_hpp
00013
00014 #include <Gui/DeviceContext.hpp>
00015
00016 class Bitmap;
00017 class VirtualDisplay;
00018
00020 class BitmapDc : public DeviceContext {
00021     typedef DeviceContext Base;
00022
00023     public:
00026         BitmapDc();
00027
00029         BitmapDc(Bitmap* bitmap);
00030
00032         virtual ~BitmapDc();
00033
00035         void Init(Bitmap* bitmap);
00036
00038         virtual void AdjustBoundingRect();
00039
00040     private:
00041         Bitmap* m_bitmap;
00042         VirtualDisplay* m_display;
00043 };  // BitmapDc
00044
00046 #endif  // Apoxi_BitmapDc_hpp
00047
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Brush.hpp File Reference

Gui/Brush.hpp File Reference

#include <Gui/Color.hpp>

Include dependency graph for Brush.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Brush

Defines

#define | Apoxi_Brush_hpp

Typedefs

typedef Brush::BrushStyle | BrushStyle

Define Documentation

#define Apoxi_Brush_hpp

Generated on Tue Jan 24 20:38:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Brush.hpp Source File

Gui/Brush.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Brush_hpp)
00010 #define Apoxi_Brush_hpp
00013
00014 #include <Gui/Color.hpp>
00015
00016
00019 class Brush {
00020     public:
00024         enum BrushStyle {
00025             Solid,
00026             Checkered
00027         };
00028
00030         Brush(const Color& color = Color(0), BrushStyle style = Solid) :
00031              m_style(style), m_color(color) {}
00032
00034         void SetStyle(BrushStyle style) { m_style = style; }
00035
00037         BrushStyle GetStyle() const { return m_style; }
00038
00040         void SetColor(const Color& color) { m_color = color; }
00041
00043         const Color& GetColor() const { return m_color; }
00044
00046         void SetColorValue(ColorValue color_value) { m_color.SetValue(color_value); };
00047
00049         ColorValue GetColorValue() const { return m_color.GetValue(); }
00050
00053         void SetColorRgb(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha = 255) { m_color.SetRgb(red, green, blue, alpha); }
00054
00057         void SetColorHsv(UINT8 hue, UINT8 saturation, UINT8 value, UINT8 alpha = 255) { m_color.SetHsv(hue, saturation, value, alpha); }
00058
00059     private:
00060         BrushStyle  m_style;
00061         Color       m_color;
00062 };
00063
00064 typedef Brush::BrushStyle BrushStyle;
00065
00067 #endif  // Apoxi_Brush_hpp
00068
00069
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CalculatorInputMapper.cpp File Reference

Gui/CalculatorInputMapper.cpp File Reference

#include "Gui/PreComp.hpp"
#include "CalculatorInputMapper.hpp"
#include "AbstractEditor.hpp"
#include "CharItem.hpp"
#include "TextCompoundItem.hpp"
#include <Config/KeyboardConfig.hpp>
#include "Locale.hpp"

Include dependency graph for CalculatorInputMapper.cpp:

Generated on Tue Jan 24 20:38:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CalculatorInputMapper.hpp File Reference

Gui/CalculatorInputMapper.hpp File Reference

#include <Gui/NumericInputMapper.hpp>

Include dependency graph for CalculatorInputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalculatorInputMapper
Manages the input of numbers and a decimal point. More...

Defines

#define | Apoxi_CalculatorInputMapper_hpp

Define Documentation

#define Apoxi_CalculatorInputMapper_hpp

Generated on Tue Jan 24 20:38:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CalculatorInputMapper.hpp Source File

Gui/CalculatorInputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_CalculatorInputMapper_hpp)
00011 #define Apoxi_CalculatorInputMapper_hpp
00015
00016 #include <Gui/NumericInputMapper.hpp>
00017
00019 class CalculatorInputMapper : public NumericInputMapper {
00020     typedef NumericInputMapper Base;
00021
00022     public:
00023         explicit CalculatorInputMapper();
00024         virtual ~CalculatorInputMapper();
00025
00027         virtual INT GetId() const;
00028
00031         virtual Alphabet GetAlphabet() const;
00032
00033     protected:
00034         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00035 };
00036
00038 #endif  // Apoxi_CalculatorInputMapper_hpp
00039
00040
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CancelAction.hpp File Reference

Gui/CancelAction.hpp File Reference

#include <Compat/CancelAction.hpp>

Include dependency graph for CancelAction.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:16:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CancelAction.hpp Source File

Gui/CancelAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class CancelAction has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/CancelAction.hpp>
00014
00015
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Caret.cpp File Reference

Gui/Caret.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Caret.hpp"
#include "EditorDocument.hpp"
#include "AbstractEditor.hpp"

Include dependency graph for Caret.cpp:

Generated on Tue Jan 24 20:38:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Caret.hpp File Reference

Gui/Caret.hpp File Reference

#include <Gui/DrawableObject.hpp>

Include dependency graph for Caret.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Caret

Defines

#define | Apoxi_Caret_hpp

Define Documentation

#define Apoxi_Caret_hpp

Generated on Tue Jan 24 20:38:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Caret.hpp Source File

Gui/Caret.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Caret_hpp)
00011 #define Apoxi_Caret_hpp
00015
00016 #include <Gui/DrawableObject.hpp>
00017
00018 class AbstractEditor;   //lint !e763
00019 class DeviceContext;
00020 class Rect;             //lint !e763
00021 class AtomItem;
00022
00029 class Caret {
00030     public:
00032         enum Mode {
00035             Insert,
00038             Overwrite
00039         };
00040
00041         Caret();
00042         explicit Caret(AbstractEditor* editor, Mode mode = Insert);
00043         virtual ~Caret();
00044
00047         virtual void SetRow(INT row);
00048
00050         INT GetRow() const { return (INT)m_row; }
00051
00054         virtual void SetColumn(INT column);
00055
00057         INT GetColumn() const { return (INT)m_column; }
00058
00062         INT GetIndex() const;
00063
00066         void SetMode(Mode mode) { m_mode = mode; }
00067
00069         Mode GetMode() const { return m_mode; }
00070
00073         virtual void SetVisible(BOOLEAN visible);
00074
00076         BOOLEAN IsVisible() const;
00077
00079         virtual XYDIM GetMinimalWidth() const = 0;
00080
00087         virtual void Draw(DeviceContext* dc, const Rect& bounds, BOOLEAN right_to_left = FALSE) const = 0;
00088
00093         virtual void ShowHint() const;
00094
00096         const AbstractEditor* GetEditor() const { return m_editor; }
00097
00098     protected:
00100         AbstractEditor* GetEditor() { return m_editor; }
00101
00102     private:
00103         Mode m_mode;
00104         INT m_row;
00105         INT m_column;
00106         AbstractEditor *m_editor;
00107 };
00108
00110 #endif  // Apoxi_Caret_hpp
00111
00112
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CharItem.cpp File Reference

Gui/CharItem.cpp File Reference

#include "Gui/PreComp.hpp"
#include "CharItem.hpp"
#include "EditorDocument.hpp"
#include "Locale.hpp"
#include "PaintDc.hpp"

Include dependency graph for CharItem.cpp:

Generated on Tue Jan 24 20:38:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CharItem.hpp File Reference

Gui/CharItem.hpp File Reference

#include <Gui/AtomItem.hpp>

Include dependency graph for CharItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CharItem
Editor-Item which contains a wide-character. More...

Defines

#define | Apoxi_CharItem_hpp

Define Documentation

#define Apoxi_CharItem_hpp

Generated on Tue Jan 24 20:38:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CharItem.hpp Source File

Gui/CharItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_CharItem_hpp)
00011 #define Apoxi_CharItem_hpp
00015
00016 #include <Gui/AtomItem.hpp>
00017
00019 class CharItem : public AtomItem {
00020     typedef AtomItem Base;
00021
00022     public:
00023         enum {
00024             ID = 2
00025         };
00026
00028         CharItem();
00029
00031         explicit CharItem(WCHAR c) : m_char(c) {}
00032
00034         virtual ~CharItem();
00035
00037         virtual INT GetId() const;
00038
00040         WCHAR GetChar() const { return m_char; }
00041
00043         CharItem& operator=(WCHAR c) { m_char = c; return* this; }
00044
00046         operator WCHAR () const { return m_char; }  //lint !e1930
00047
00049         virtual void Draw(DeviceContext* dc, const Rect& bounds) const;
00050
00053         virtual AtomItem* Clone() const;
00054
00056         virtual BOOLEAN IsInstanceOf(INT id) const;
00057
00058     private:
00059         WCHAR m_char;
00060 };  //lint !e1721
00061
00063 #endif  // Apoxi_CharItem_hpp
00064
00065
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBox.hpp File Reference

Gui/CheckBox.hpp File Reference

#include <Compat/CheckBox.hpp>

Include dependency graph for CheckBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:16:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBox.hpp Source File

Gui/CheckBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class CheckBox has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.2.*/
00013 #include <Compat/CheckBox.hpp>
00014
00015
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxAction.cpp File Reference

Gui/CheckBoxAction.cpp File Reference

#include "Gui/PreComp.hpp"
#include "CheckBoxAction.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"

Include dependency graph for CheckBoxAction.cpp:

Generated on Tue Jan 24 20:38:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxAction.hpp File Reference

Gui/CheckBoxAction.hpp File Reference

#include <Gui/AbstractToggleAction.hpp>

Include dependency graph for CheckBoxAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CheckBoxAction

Defines

#define | Apoxi_CheckBoxAction_hpp

Define Documentation

#define Apoxi_CheckBoxAction_hpp

Generated on Tue Jan 24 20:38:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxAction.hpp Source File

Gui/CheckBoxAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CheckBoxAction_hpp)
00010 #define Apoxi_CheckBoxAction_hpp
00014
00015 #include <Gui/AbstractToggleAction.hpp>
00016
00020 class CheckBoxAction : public AbstractToggleAction {
00021     typedef AbstractToggleAction Base;
00022
00023     public:
00024         enum {
00025             ID = 5
00026         };
00027
00028         CheckBoxAction();
00029
00038         CheckBoxAction(Dispatcher* dispatcher,
00039                        const WCHAR* text,
00040                        BOOLEAN enabled = TRUE,
00041                        BOOLEAN selected = FALSE);   //lint !e1931
00042
00043         virtual ~CheckBoxAction();
00044
00053         void Init(Dispatcher* dispatcher, const WCHAR* text, BOOLEAN enabled = TRUE, BOOLEAN selected = FALSE);
00054
00057         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00058
00060         virtual void SetSelected(BOOLEAN select);
00061
00063         virtual BOOLEAN Toggle(BOOLEAN old_state);
00064
00066         virtual BOOLEAN IsInstanceOf(INT id) const;
00067
00069         CheckBoxAction(const WCHAR* text,
00070                        BOOLEAN enabled = TRUE,
00071                        BOOLEAN selected = FALSE);   //lint !e1931
00072
00074         void Init(const WCHAR* text, BOOLEAN enabled = TRUE, BOOLEAN selected = FALSE);
00075
00077         virtual const BitmapRes* GetSelectedIcon() const;
00078
00080         virtual const BitmapRes* GetDeselectedIcon() const;
00081
00082     private:
00084         void UpdateIcon();
00085 };
00086
00088 #endif // Apoxi_CheckBoxAction_hpp
00089
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxControl.cpp File Reference

Gui/CheckBoxControl.cpp File Reference

#include "Gui/PreComp.hpp"
#include "PaintDc.hpp"
#include "CheckBoxControl.hpp"
#include "ThemeManager.hpp"
#include "Locale.hpp"

Include dependency graph for CheckBoxControl.cpp:

Generated on Tue Jan 24 20:39:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxControl.hpp File Reference

Gui/CheckBoxControl.hpp File Reference

#include <Gui/AbstractButton.hpp>
#include <Gui/CheckBoxAction.hpp>
#include <Gui/View.hpp>

Include dependency graph for CheckBoxControl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CheckBoxControl
class | CheckBoxControlView
Describes the view of a checkbox-control. More...

Defines

#define | Apoxi_CheckBoxControl_hpp

Define Documentation

#define Apoxi_CheckBoxControl_hpp

Generated on Tue Jan 24 20:39:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxControl.hpp Source File

Gui/CheckBoxControl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_CheckBoxControl_hpp)
00011 #define Apoxi_CheckBoxControl_hpp
00015
00016 #include <Gui/AbstractButton.hpp>
00017 #include <Gui/CheckBoxAction.hpp>
00018 #include <Gui/View.hpp>
00019
00021 class CheckBoxControlView : public View {
00022     typedef View Base;
00023
00024     public:
00025         CheckBoxControlView();
00026         CheckBoxControlView(XYDIM default_height);
00027         virtual ~CheckBoxControlView();
00028
00030         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00031
00033         virtual void Update(const Theme& theme);
00034 };
00035
00040 class CheckBoxControl : public AbstractButton {
00041     typedef AbstractButton Base;
00042
00043     public:
00044         enum {
00045             ID = 6
00046         };
00047
00050         CheckBoxControl();
00051
00055         CheckBoxControl(Control* parent, const WCHAR* text, BOOLEAN selected = FALSE);
00056
00058         virtual ~CheckBoxControl();
00059
00063         void Init(Control* parent, const WCHAR* text, BOOLEAN selected = FALSE);
00064
00067         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00068
00070         virtual BOOLEAN IsInstanceOf(INT id) const;
00071
00074         void Toggle();
00075
00077         void SetSelected(BOOLEAN selected) { m_checkbox_action.SetSelected(selected); }
00078
00080         BOOLEAN IsSelected() const { return m_checkbox_action.IsSelected(); }
00081
00083         void SetValue(INT value) { m_checkbox_action.SetValue(value); }
00084
00086         INT GetValue() const { return m_checkbox_action.GetValue(); }
00087
00088     protected:
00090         virtual void Refresh(const Rect& rect);
00091
00093         virtual void OnThemeChanged();
00094
00095     private:
00096         CheckBoxAction m_checkbox_action;
00097         static CheckBoxControlView m_view;
00098 };
00099
00101 #endif  // Apoxi_CheckBoxControl_hpp
00102
00103
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxItem.hpp File Reference

Gui/CheckBoxItem.hpp File Reference

#include <Compat/CheckBoxItem.hpp>

Include dependency graph for CheckBoxItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:16:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxItem.hpp Source File

Gui/CheckBoxItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class CheckBoxItem has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.2.*/
00013 #include <Compat/CheckBoxItem.hpp>
00014
00015
Generated on Tue Jan 24 14:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxList.hpp File Reference

Gui/CheckBoxList.hpp File Reference

#include <Compat/CheckBoxList.hpp>

Include dependency graph for CheckBoxList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:16:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CheckBoxList.hpp Source File

Gui/CheckBoxList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class CheckBoxList has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.2.*/
00013 #include <Compat/CheckBoxList.hpp>
00014
00015
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ClientDc.cpp File Reference

Gui/ClientDc.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/ClientDc.hpp"
#include "Gui/Control.hpp"
#include "Devices/Device.hpp"

Include dependency graph for ClientDc.cpp:

Generated on Tue Jan 24 20:39:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ClientDc.hpp File Reference

Gui/ClientDc.hpp File Reference

#include <Gui/ControlDc.hpp>

Include dependency graph for ClientDc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ClientDc

Defines

#define | Apoxi_ClientDc_hpp

Define Documentation

#define Apoxi_ClientDc_hpp

Generated on Tue Jan 24 20:39:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ClientDc.hpp Source File

Gui/ClientDc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ClientDc_hpp)
00010 #define Apoxi_ClientDc_hpp
00013
00014 #include <Gui/ControlDc.hpp>
00015
00016
00017 class Control;
00018
00022 class ClientDc : public ControlDc {
00023     typedef ControlDc Base;
00024
00025     public:
00026         ClientDc();
00027         ClientDc(Control* control);
00028         ClientDc(VirtualDisplay* display);
00030         virtual void AdjustBoundingRect();
00031 };  // ClientDc
00032
00034 #endif  // Apoxi_ClientDc_hpp
00035
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CloseWindowAction.cpp File Reference

Gui/CloseWindowAction.cpp File Reference

#include "Gui/PreComp.hpp"
#include "CloseWindowAction.hpp"

Include dependency graph for CloseWindowAction.cpp:

Generated on Tue Jan 24 20:39:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CloseWindowAction.hpp File Reference

Gui/CloseWindowAction.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/Window.hpp>
#include <Kernel/MsgTypes.hpp>

Include dependency graph for CloseWindowAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CloseWindowAction

Defines

#define | Apoxi_CloseWindowAction_hpp

Define Documentation

#define Apoxi_CloseWindowAction_hpp

Generated on Tue Jan 24 20:39:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CloseWindowAction.hpp Source File

Gui/CloseWindowAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_CloseWindowAction_hpp)
00010 #define Apoxi_CloseWindowAction_hpp
00014
00015 #include <Gui/Action.hpp>
00016 #include <Gui/Window.hpp>
00017 #include <Kernel/MsgTypes.hpp>
00018
00020 class CloseWindowAction : public Action {
00021     typedef Action Base;
00022
00023     public:
00026         CloseWindowAction();
00027
00036         CloseWindowAction(Dispatcher* dispatcher,
00037                           Window* win,
00038                           const WString& text,
00039                           const ImageObtainer& icon = ImageObtainer());
00040
00042         virtual ~CloseWindowAction();
00043
00052         void Init(Dispatcher* dispatcher,
00053                   Window* win,
00054                   const WString& text,
00055                   const ImageObtainer& icon = ImageObtainer());
00056
00057
00059         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00060
00063         virtual BOOLEAN Execute();
00064
00066         CloseWindowAction(Window* win, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00067
00069         void Init(Window* win, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00070
00072         void SetWindow (Window* win) { m_win = win; }
00073
00074     private:
00075         Window* m_win;
00076 };
00077
00079 #endif  // Apoxi_CloseWindowAction_hpp
00080
00081
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Color.cpp File Reference

Gui/Color.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Color.hpp"
#include "ColorTable.hpp"
#include "ColorSegmentation.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include <Devices/Display.hpp>
#include <Kernel/System.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for Color.cpp:

Defines

#define APOXI_COLOR_VALUE_BITCOUNT 16

Define Documentation

#define APOXI_COLOR_VALUE_BITCOUNT 16

Generated on Tue Jan 24 20:39:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Color.hpp File Reference

Gui/Color.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Color

Defines

#define | Apoxi_Color_hpp

Typedefs

typedef UINT16 | ColorValue
typedef ColorValue | SystemColor
typedef Color::SystemColorId | SystemColorId

Define Documentation

#define Apoxi_Color_hpp

Generated on Tue Jan 24 20:40:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Color.hpp Source File

Gui/Color.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (Apoxi_Color_hpp)
00010 #define Apoxi_Color_hpp
00013
00014 #if defined(APOXI_DISPLAY_32BPP) || defined (APOXI_DISPLAY_24BPP)
00015 typedef UINT32 ColorValue;
00016 #else
00017 typedef UINT16 ColorValue;
00018 #endif
00019
00028 class Color {
00029     public:
00037         enum SystemColorId {
00039             ClientBackground = 0,
00041             ClientForeground = 1,
00043             ActiveFrameBackground = 2,
00045             ActiveFrameForeground = 3,
00047             InactiveFrameBackground = 4,
00049             InactiveFrameForeground = 5,
00051             SelectionBackground = 6,
00053             SelectionForeground = 7,
00055             Shaded = 8,
00057             ButtonBackground = 9,
00059             ButtonForeground = 10,
00061             ContextMenuBackground = 11,
00063             ActiveWindowTitle = 12,
00065             InactiveWindowTitle = 13,
00066             SystemColorIdCount = 14 // mandatory last entry
00067         };
00068
00070         Color();
00071
00074         Color(ColorValue color_value);
00075
00079         Color(SystemColorId system_color_id);
00080
00082         Color(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha = 255);
00083
00085         void SetValue(ColorValue color_value);
00086
00088         ColorValue GetValue() const;
00089
00094         void SetRgb(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha = 255);
00095
00097         void GetRgb(UINT8& red, UINT8& green, UINT8& blue, UINT8* alpha = 0) const;
00098
00100         UINT8 GetRed() const { return m_red; }
00101
00103         UINT8 GetGreen() const { return m_green; }
00104
00106         UINT8 GetBlue() const { return m_blue; }
00107
00109         UINT8 GetAlpha() const { return m_alpha; }
00110
00112         void SetRed(UINT8 red) { m_red = red; }
00113
00115         void SetGreen(UINT8 green) { m_green = green; }
00116
00118         void SetBlue(UINT8 blue) { m_blue = blue; }
00119
00121         void SetAlpha(UINT8 alpha) { m_alpha = alpha; }
00122
00123         // SetHsv not implemented yet.
00124         /*  Sets the color to the value represented by hue, saturation and
00125             the value. Optionally an alpha-channel can be specified.*/
00126         void SetHsv(UINT16 hue, UINT8 saturation, UINT8 value, UINT8 alpha = 255);
00127
00129         BOOLEAN operator==(const Color& color) const;
00130
00132         BOOLEAN operator!=(const Color& color) const;
00133
00138         Color Blend(const Color& background) const;
00139
00144         ColorValue Blend(ColorValue background) const;
00145
00152         static ColorValue Blend(ColorValue foreground, ColorValue background, UINT8 alpha = 255);
00153
00154     private:
00155         UINT8 m_red;
00156         UINT8 m_green;
00157         UINT8 m_blue;
00158         UINT8 m_alpha;
00159 };
00160
00161 typedef Color::SystemColorId SystemColorId;
00162 typedef ColorValue SystemColor;     // obsolete since APOXI-1.6.3; simply use ColorValue instead
00163
00165 #endif  // Apoxi_Color_hpp
00166
00167
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ColorSegmentation.hpp File Reference

Gui/ColorSegmentation.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ColorSegmentation

Defines

#define | Apoxi_ColorSegmentation_hpp

Define Documentation

#define Apoxi_ColorSegmentation_hpp

Generated on Tue Jan 24 20:40:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ColorSegmentation.hpp Source File

Gui/ColorSegmentation.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ColorSegmentation_hpp)
00010 #define Apoxi_ColorSegmentation_hpp
00013
00014
00016 struct ColorSegmentation {
00017     INT GetAlphaBitCount() const { return m_alpha_bit_count; }
00018     INT GetRedBitCount() const { return m_red_bit_count; }
00019     INT GetGreenBitCount() const { return m_green_bit_count; }
00020     INT GetBlueBitCount() const { return m_blue_bit_count; }
00021
00022     INT m_alpha_bit_count;
00023     INT m_red_bit_count;
00024     INT m_green_bit_count;
00025     INT m_blue_bit_count;
00026 };
00027
00029 #endif  // Apoxi_ColorSegmentation_hpp
00030
00031
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ColorTable.hpp File Reference

Gui/ColorTable.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ColorTable
struct | Palette

Defines

#define | Apoxi_ColorTable_hpp

Define Documentation

#define Apoxi_ColorTable_hpp

Generated on Tue Jan 24 20:40:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ColorTable.hpp Source File

Gui/ColorTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ColorTable_hpp)
00010 #define Apoxi_ColorTable_hpp
00013
00014 struct Palette {
00015     UINT8 red;
00016     UINT8 green;
00017     UINT8 blue;
00018 };
00019
00023 struct ColorTable {
00024     INT GetColorCount() const       { return m_color_count; }
00025     UINT8 GetRed(INT index) const   { return m_palette[index].red; }
00026     UINT8 GetGreen(INT index) const { return m_palette[index].green; }
00027     UINT8 GetBlue(INT index) const  { return m_palette[index].blue; }
00028     const Palette* GetRgb(INT index) const { return &m_palette[index]; }
00029
00030     const Palette* m_palette;
00031     INT m_color_count;
00032 };
00033
00035 #endif  // Apoxi_ColorTable_hpp
00036
00037
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Component.cpp File Reference

Gui/Component.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Component.hpp"
#include "Control.hpp"
#include <Config/DisplayConfig.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Application.hpp>
#include "Model.hpp"
#include "View.hpp"

Include dependency graph for Component.cpp:

Generated on Tue Jan 24 20:40:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Component.hpp File Reference

Gui/Component.hpp File Reference

#include <Kernel/Dispatcher.hpp>
#include <Gui/Point.hpp>
#include <Gui/Rect.hpp>
#include <Gui/Size.hpp>
#include <Config/GuiObjectFactory.hpp>

Include dependency graph for Component.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Component

Defines

#define | Apoxi_Component_hpp

Define Documentation

#define Apoxi_Component_hpp

Generated on Tue Jan 24 20:40:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Component.hpp Source File

Gui/Component.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Component_hpp)
00010 #define Apoxi_Component_hpp
00014
00015 #include <Kernel/Dispatcher.hpp>
00016 #include <Gui/Point.hpp>
00017 #include <Gui/Rect.hpp>
00018 #include <Gui/Size.hpp>
00019 #include <Config/GuiObjectFactory.hpp>
00020
00021 class Model;
00022 class View;
00023 class Control;
00024 class ResourceParser;
00025
00033 class Component : public Dispatcher {
00034     typedef Dispatcher Base;
00035
00036     public:
00037         enum {
00038             ID = 7
00039         };
00040
00043         Component();
00044
00048         Component(const View* view, Control* parent = 0);
00049
00050         virtual ~Component();
00051
00055         void Init(const View* view, Control* parent = 0);
00056
00059         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00060
00063         virtual void SetParent(Control* parent) = 0;
00064
00068         Control* GetParent() const { return m_parent; }
00069
00097         /* Internal comment: the following IDs are currently used inside APOXI
00098             -  0: AbstractButton
00099             -  1: AbstractGrid
00100             -  2: AbstractItemGrid
00101             -  3: AbstractTextObject
00102             -  4: Alert
00103             -  5: AnimatedTextLine
00104             -  6: CheckBoxControl
00105             -  7: Component
00106             -  8: ContextMenu
00107             -  9: Control
00108             - 10: DrawableObject
00109             - 11: ImageBox
00110             - 12: ItemGrid
00111             - 13: ItemMenu
00112             - 14: ItemTree
00113             - 15: GridLayout
00114             - 16: MessageBox
00115             - 17: Panel
00116             - 18: PositionIndicator
00117             - 19: ProgressBar
00118             - 20: PushButton
00119             - 21: RadioButtonControl
00120             - 22: TabButton
00121             - 23: TabControl
00122             - 24: TextBox
00123             - 25: TextLine
00124             - 26: Window
00125             - 27: AbstractEditor
00126             - 28: AbstractLineEditor
00127             - 29: AbstractMultiLineEditor
00128             - 30: DateEditor
00129             - 31: IpAddrEditor
00130             - 32: LineEditor
00131             - 33: MultiLineEditor
00132             - 34: PasswordEditor
00133             - 35: TimeEditor
00134             - 36: MultiMediaEditor
00135             - 37: ItemBox
00136             - 38: FlowLayout
00137             - 39: AtlWindow
00138             - 40: AtlItemMenuWindow
00139             - 41: AtlItemListWindow
00140             - 42: AtlItemGridWindow
00141         */
00142         virtual BOOLEAN IsInstanceOf(INT id) const;
00143
00145         void SetXPos(XYDIM x_pos);
00146
00148         void SetYPos(XYDIM y_pos);
00149
00151         XYDIM GetXPos() const { return m_bounds.GetLeft(); }
00152
00154         XYDIM GetYPos() const { return m_bounds.GetTop(); }
00155
00157         void SetWidth(XYDIM width);
00158
00160         XYDIM GetWidth() const { return m_bounds.GetWidth(); }
00161
00163         void SetHeight(XYDIM height);
00164
00166         XYDIM GetHeight() const { return m_bounds.GetHeight(); }
00167
00169         void SetPos(const Point& pos);
00170
00173         void SetPos(XYDIM x, XYDIM y);
00174
00176         Point GetPos() const { return m_bounds.GetPos(); }
00177
00179         void SetSize(const Size& size);
00180
00183         void SetSize(XYDIM width, XYDIM height);
00184
00186         Size GetSize() const { return m_bounds.GetSize(); }
00187
00189         void SetBoundingRect(const Rect& bounds);
00190
00195         void SetBoundingRect(XYDIM left, XYDIM top, XYDIM right, XYDIM bottom);
00196
00198         const Rect& GetBoundingRect() const { return m_bounds; }
00199
00203         virtual XYDIM GetDefaultWidth() const;
00204
00208         virtual XYDIM GetDefaultHeight() const;
00209
00211         Model* GetModel() const;
00212
00214         const View* GetView() const { return m_abstract_view; }
00215
00222         void DeleteLater();
00223
00229         void AdjustParent(Control* parent) { m_parent = parent; }
00230
00235         INT GetId() const { return m_id; }
00236
00238         void SetId(INT id) { m_id = id; }
00239
00240     protected:
00244         const View* m_abstract_view;
00245
00248         virtual void Refresh(const Rect& rect);
00249
00252         virtual void Cleanup();
00253
00259         virtual Model* CreateModel() const;
00260
00266         void SetModel(Model* model) { m_model = model; }
00267
00271         void SetView(const View* view) { m_abstract_view = view; }
00272
00274         virtual BOOLEAN OnMessage(const Message& msg);
00275
00277         virtual void OnMove(XYDIM dx, XYDIM dy);
00278
00280         virtual void OnResize(XYDIM dx, XYDIM dy);
00281
00285         virtual void OnThemeChanged() = 0;
00286
00290         virtual void OnLanguageChanged() = 0;
00291
00292 #if defined(APOXI_COMPAT_1_8_0)
00293
00295         virtual BOOLEAN DestroyModel(Model* model);
00296 #endif // APOXI_COMPAT_1_8_0
00297
00298     private:
00299         INT m_id;
00300         Control* m_parent;
00301         mutable Model* m_model;
00302         Rect m_bounds;
00303 };
00304
00306 #endif
00307
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CompoundItem.cpp File Reference

Gui/CompoundItem.cpp File Reference

#include "Gui/PreComp.hpp"
#include "CompoundItem.hpp"

Include dependency graph for CompoundItem.cpp:

Generated on Tue Jan 24 20:40:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CompoundItem.hpp File Reference

Gui/CompoundItem.hpp File Reference

#include <Gui/AbstractEditorItem.hpp>
#include <Gui/EditorDocument.hpp>

Include dependency graph for CompoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CompoundItem

Defines

#define | Apoxi_CompoundItem_hpp

Define Documentation

#define Apoxi_CompoundItem_hpp

Generated on Tue Jan 24 20:40:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/CompoundItem.hpp Source File

Gui/CompoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_CompoundItem_hpp)
00011 #define Apoxi_CompoundItem_hpp
00015
00016 class AtomItem;
00017
00018 #include <Gui/AbstractEditorItem.hpp>
00019 #include <Gui/EditorDocument.hpp>
00020
00031 class CompoundItem : public AbstractEditorItem {
00032     public:
00033         enum {
00034             ID = 1
00035         };
00036
00038         virtual ~CompoundItem();
00039
00042         virtual void ReleaseInstance();
00043
00045         virtual INT GetId() const;
00046
00053         virtual void Draw(DeviceContext* dc,
00054                           XYDIM x,
00055                           XYDIM y,
00056                           INT index,
00057                           INT count) const = 0;
00058
00067         virtual INT WrapLine(INT index,
00068                              XYDIM width,
00069                              WrapPolicy wrap_policy = EditorDocument::WhitespaceWrap) const = 0;
00070
00073         virtual XYDIM GetLineWidth(INT index, INT count) const = 0;
00074
00079         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const = 0;
00080
00083         virtual INT GetItemCount() const = 0;
00084
00089         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00090
00095         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00096
00101         virtual BOOLEAN RemoveItem(INT index = -1);
00102
00112         virtual BOOLEAN Split(INT index, CompoundItem** compound_item);
00113
00123         virtual BOOLEAN Merge(const CompoundItem& compound_item);
00124
00134         virtual CompoundItem* Clone() const;
00135
00137         virtual void Clear();
00138
00140         virtual BOOLEAN IsInstanceOf(INT id) const;
00141
00142     protected:
00144         CompoundItem();
00145 };
00146
00148 #endif  // Apoxi_CompoundItem_hpp
00149
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ConfirmAction.hpp File Reference

Gui/ConfirmAction.hpp File Reference

#include <Compat/ConfirmAction.hpp>

Include dependency graph for ConfirmAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:16:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ConfirmAction.hpp Source File

Gui/ConfirmAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class ConfirmAction has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/ConfirmAction.hpp>
00014
00015
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ContextMenu.cpp File Reference

Gui/ContextMenu.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ContextMenu.hpp"
#include "AbstractItemContainer.hpp"
#include "ItemGrid.hpp"
#include "AbstractItemRenderer.hpp"
#include <Devices/Display.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/MessageRouter.hpp>
#include "Panel.hpp"

Include dependency graph for ContextMenu.cpp:

Generated on Tue Jan 24 20:40:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ContextMenu.hpp File Reference

Gui/ContextMenu.hpp File Reference

#include <Gui/Window.hpp>
#include <Gui/Action.hpp>
#include <Gui/ItemGrid.hpp>

Include dependency graph for ContextMenu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextMenu

Defines

#define | Apoxi_ContextMenu_hpp

Define Documentation

#define Apoxi_ContextMenu_hpp

Generated on Tue Jan 24 20:40:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ContextMenu.hpp Source File

Gui/ContextMenu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ContextMenu_hpp)
00010 #define Apoxi_ContextMenu_hpp
00014
00015 class AbstractItemContainer;
00016 class Item;
00017 class ItemRendererProperties;
00018 class AbstractItemRenderer;
00019
00020 #include <Gui/Window.hpp>
00021 #include <Gui/Action.hpp>
00022 #include <Gui/ItemGrid.hpp>
00023
00029 class ContextMenu : public Window {
00030     typedef Window Base;
00031
00032     public:
00033         enum {
00034             ID = 8
00035         };
00036
00039         enum Corner {
00041             TopLeft,
00043             TopRight,
00045             BottomLeft,
00047             BottomRight
00048         };
00049
00059         ContextMenu(XYDIM x,
00060                     XYDIM y,
00061                     Corner corner = TopLeft,
00062                     AbstractItemContainer* item_cont = 0,
00063                     ContextMenu* parent_menu = 0);
00064
00065         /*  Constructor used by Aragon to create the instance out of a resource file.
00066             This constructor may not be used by the MMI in a direct manner
00067             and the interface may be changed in future releases. */
00068         ContextMenu();
00069
00070         virtual ~ContextMenu();
00071
00074         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00075
00077         virtual BOOLEAN IsInstanceOf(INT id) const;
00078
00084         void SetRenderer(const ItemRendererProperties* properties = 0);
00085
00087         const AbstractItemRenderer* GetRenderer() const;
00088
00092         BOOLEAN AddItem(Item* item);
00093
00095         AbstractItemContainer* GetItemContainer() const;
00096
00097     protected:
00099         virtual BOOLEAN OnMessage(const Message& msg);
00100
00102         virtual void OnActionExecuted(Action* action);
00103
00105         virtual void Refresh(const Rect& rect);
00106
00108         virtual void Cleanup();
00109
00110     private:
00111         Corner m_corner;
00112         XYDIM m_x;
00113         XYDIM m_y;
00114         ContextMenu* m_parent_menu;
00115         ContextMenu* m_child_menu;
00116         ItemGrid m_item_grid;
00117         Action m_select_action;
00118         Action m_cancel_action;
00119
00121         XYDIM GetItemHeight() const;
00122
00125         void AdjustBounds(XYDIM& x, XYDIM& y, XYDIM& width, XYDIM& height) const;
00126 };
00127
00129 #endif  // Apoxi_ContextMenu_hpp
00130
00131
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Control.cpp File Reference

Gui/Control.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Control.hpp"
#include "PaintDc.hpp"
#include "FrameDc.hpp"
#include "ClientDc.hpp"
#include "SoftkeyBar.hpp"
#include "Window.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include "Layouter.hpp"
#include "LanguageManager.hpp"
#include "WindowManager.hpp"
#include "ControlFrameView.hpp"
#include "Desktop.hpp"
#include "DrawableObject.hpp"
#include "Panel.hpp"
#include <Kernel/System.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/Device.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for Control.cpp:

Generated on Tue Jan 24 20:40:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Control.hpp File Reference

Gui/Control.hpp File Reference

#include <Gui/Component.hpp>
#include <Kernel/MsgCategory.hpp>

Include dependency graph for Control.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Control
class | Control::ComponentIterator
class | Control::NavigationGuidance

Defines

#define | Apoxi_Control_hpp

Typedefs

typedef Control::FrameType | FrameType

Define Documentation

#define Apoxi_Control_hpp

Generated on Tue Jan 24 20:41:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Control.hpp Source File

Gui/Control.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Control_hpp)
00010 #define Apoxi_Control_hpp
00014
00015 #include <Gui/Component.hpp>
00016 #include <Kernel/MsgCategory.hpp>
00017
00018 class Timer;
00019 class Rect;
00020 class Point;
00021 class Size;
00022 class ControlFrameView;
00023 class Window;
00024 class DrawableObject;
00025 class ClientDc;
00026 class Message;
00027 class InputMapItem;
00028 class ResourceParser;
00029
00034 class Control : public Component {
00035     typedef Component Base;
00036
00037     public:
00038         enum {
00039             ID = 9
00040         };
00041
00046         enum FrameType {
00049             NoFrame,
00054             DefaultFrame,
00058             StaticFrame,
00061             DynamicFrame
00062         };  // when extending the enum, the bit-size for m_bits.frame_type must be adjusted
00063
00068         class NavigationGuidance {
00069             public:
00071                 enum Type {
00073                     Left    = 0,
00075                     Right   = 2,
00077                     Up      = 4,
00079                     Down    = 6,
00081                     Center  = 8
00082                 };
00083
00085                 enum State {
00087                     Off         = 0,
00090                     Disabled    = 1,
00092                     Enabled     = 2
00093                 };
00094
00095                 NavigationGuidance();
00096                 NavigationGuidance(State left_state,
00097                                    State right_state = Off,
00098                                    State up_state = Off,
00099                                    State down_state = Off,
00100                                    State center_state = Off);
00101                 ~NavigationGuidance();
00102
00104                 void SetState(Type type, State state);
00105
00107                 State GetState(Type type) const;
00108
00111                 void Merge(NavigationGuidance nav_guid);
00112
00113                 BOOLEAN operator == (NavigationGuidance nav_guid) const { return nav_guid.m_value == m_value; }
00114                 BOOLEAN operator != (NavigationGuidance nav_guid) const { return nav_guid.m_value != m_value; }
00115
00116             private:
00117                 UINT16 m_value;
00118         };
00119
00128         class ComponentIterator {
00129             public:
00131                 enum Type {
00133                     All,
00135                     Controls,
00137                     DrawableObjects
00138                 };
00139
00142                 ComponentIterator(const Control& control, Type type = All);
00143
00144                 ~ComponentIterator();
00145
00148                 BOOLEAN Begin();
00149
00151                 ComponentIterator& operator++();
00152
00154                 ComponentIterator operator++(INT);
00155
00158                 BOOLEAN Next();
00159
00161                 Component* Get() const { return m_comp; }
00162
00163             private:
00164                 Type m_type;
00165                 BOOLEAN m_iterate_controls;
00166                 const Control& m_control;
00167                 Component* m_comp;
00168         };
00169
00173         Control(Control* parent = 0, const View* view = 0);
00174
00175         /*  Constructor used by Aragon to create the instance out of a resource file.
00176             This constructor may not be used by the MMI in a direct manner
00177             and the interface may be changed in future releases. */
00178         virtual ~Control();
00179
00183         void Init(Control* parent = 0, const View* view = 0);
00184
00187         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00188
00190         virtual BOOLEAN IsInstanceOf(INT id) const;
00191
00193         virtual void SetParent(Control* parent);
00194
00196         Application* GetApplication() const;
00197
00204         void SetFrameType(FrameType frame_type) { m_bits.frame_type = frame_type; }
00205
00208         FrameType GetFrameType() const { return (FrameType)m_bits.frame_type; }
00209
00218         void SetNavigationGuidance(NavigationGuidance navigation_guidance);
00219
00223         NavigationGuidance GetNavigationGuidance() const { return m_navigation_guidance; }
00224
00229         BOOLEAN IsParentWindowOpen() const;
00230
00234         BOOLEAN HasFocus() const { return m_bits.focused; }
00235
00241         BOOLEAN IsInForeground() const;
00242
00245         void PutToForeground();
00246
00252         virtual void Maximize();
00253
00256         BOOLEAN IsMaximized() const { return m_bits.maximized; }
00257
00260         void Invalidate();
00261
00271         void Invalidate(const Rect& rect, BOOLEAN erase = TRUE);
00272
00273
00276         void InvalidateClient();
00277
00287         void InvalidateClient(const Rect& rect, BOOLEAN erase = TRUE);
00288
00290         XYDIM GetClientXPos() const;
00291
00293         XYDIM GetClientYPos() const;
00294
00296         XYDIM GetClientWidth() const;
00297
00299         XYDIM GetClientHeight() const;
00300
00302         Size GetClientSize() const;
00303
00311         virtual Rect GetClientRect() const;
00312
00316         Window* GetParentWindow() const;
00317
00320         void SetNext(Control* next) { m_next = next; }
00321
00326         Control* GetNext() const { return m_next; }
00327
00331         Control* GetNext(const Control* control) const;
00332
00336         Control* GetPrevious(Control* control) const;
00337
00347         void AddDrawableObject(DrawableObject* drawable_object, BOOLEAN at_end = TRUE);
00348
00353         void RemoveDrawableObject(DrawableObject* drawable_object);
00354
00357         BOOLEAN ContainsDrawableObject(const DrawableObject* obj) const;
00358
00362         DrawableObject* GetFirstDrawableObject() const { return m_first_drawable_object; }
00363
00372         void AddControl(Control* control, BOOLEAN at_end = TRUE);
00373
00376         void RemoveControl(Control* control);
00377
00380         BOOLEAN ContainsControl(const Control* control) const;
00381
00385         Control* GetFirstControl() const { return m_first_control; }
00386
00390         Control* GetFocusedControl() const;
00391
00394         Control* GetLastFocusedControl() const { return m_last_focused_control; }
00395
00404         Component* GetComponent(INT id) const;
00405
00414         BOOLEAN GrabFocus();
00415
00423         void SetDisabled(BOOLEAN disabled);
00424
00428         BOOLEAN IsDisabled() const { return (BOOLEAN)m_bits.disabled; }
00429
00432         void LayoutClient();
00433
00438         void SetAutoClearEnabled(BOOLEAN enabled);
00439
00442         BOOLEAN IsAutoClearEnabled() const { return (BOOLEAN)m_bits.auto_clear_enabled; }
00443
00452         void SetAutoLayoutEnabled(BOOLEAN enabled) { m_bits.auto_layout_enabled = enabled; }
00453
00457         BOOLEAN IsAutoLayoutEnabled() const { return (BOOLEAN)m_bits.auto_layout_enabled; }
00458
00463         void Draw();
00464
00478         virtual void DrawLayer();
00479
00482         const Rect& GetRepaintRect() const { return m_repaint_rect; }
00483
00489         BOOLEAN SetDisplayIndex(INT index);
00490
00492         INT GetDisplayIndex() const { return (INT)m_bits.display_idx; }
00493
00498         ClientDc* GetDeviceContext();
00499
00501         const ClientDc* GetDeviceContext() const;
00502
00504         XYDIM GetAbsXPos() const;
00505
00507         XYDIM GetAbsYPos() const;
00508
00510         Rect GetAbsRect() const;
00511
00513         XYDIM GetAbsClientXPos() const;
00514
00516         XYDIM GetAbsClientYPos() const;
00517
00519         Rect GetAbsClientRect() const;
00520
00522         BOOLEAN IsChild() const { return GetParent() != 0; }
00523
00525         INT GetLanguageId() const { return static_cast<INT>(m_language_id); }
00526
00527 #if defined(APOXI_COMPAT_1_11_0)
00528
00534         void SetAutoLayout(BOOLEAN auto_layout);
00535
00539         BOOLEAN IsAutoLayout() const { return FALSE; }
00540 #endif
00541
00542 #if defined(APOXI_COMPAT_2_0_0)
00543
00544         BOOLEAN IsWindowInstance() const;
00545 #endif // APOXI_COMPAT_2_0_0
00546
00548         BOOLEAN IsOpen() const;
00549
00552         Control* GetForegroundControl() const;
00553
00554
00555     protected:
00559         virtual void Refresh(const Rect& rect);
00560
00564         virtual void Cleanup();
00565
00569         virtual BOOLEAN RouteMessage(const Message& msg);
00570
00572         virtual void OnMove(XYDIM dx, XYDIM dy);
00573
00575         virtual void OnResize(XYDIM dx, XYDIM dy);
00576
00579         virtual void OnGetFocus();
00580
00583         virtual void OnLoseFocus();
00584
00594         virtual void OnPaint(const Rect& repaint_rect);
00595
00602         virtual void OnLayoutClient();
00603
00609         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00610
00616         virtual BOOLEAN OnKeyUp(KeyCode key_code, UINT32 duration);
00617
00621         virtual BOOLEAN OnKeyAutoRepeat(KeyCode key_code);
00622
00626         virtual BOOLEAN OnLongKeyPress(KeyCode key_code);
00627
00630         virtual BOOLEAN OnTimeout(const Timer& timer);
00631
00633         virtual void OnThemeChanged();
00634
00636         virtual void OnLanguageChanged();
00637
00640         virtual void OnFocusNextControl();
00641
00644         virtual void OnFocusPreviousControl();
00645
00648         void SetLastFocusedControl(Control* control) { m_last_focused_control = control; }
00649
00652         virtual const ControlFrameView* GetFrameView() const;
00653
00656         void OptimizeAutoClear();
00657
00660         void SetInternalDisplayIndex(INT index) { m_bits.display_idx = index; }
00661
00664         MsgId GetTriggeredMessage(InputMapId map_id, const InputMapItem& input_map_item) const;
00665
00667         INT GetInternalDisplayIndex() const { return (INT)m_bits.display_idx; }
00668
00670         void SetLastFocusedChild(Control* control) { SetLastFocusedControl(control); }
00671
00673         Control* GetLastFocusedChild() const { return GetLastFocusedControl(); }
00674
00675         // Obsolete - provided for backward compatibility with older APOXI releases.
00676         virtual BOOLEAN OnInputMap(const InputMapItem& input_map_item);
00677
00678 #if defined(APOXI_COMPAT_1_8_0)
00679
00682         virtual BOOLEAN OnConfirm();
00683
00687         virtual BOOLEAN OnCancel();
00688
00692         virtual BOOLEAN OnSoftkeyPressed(INT idx);
00693 #endif // APOXI_COMPAT_1_8_0
00694
00695 #if defined(APOXI_COMPAT_1_12_0)
00696
00698         virtual BOOLEAN OnSoftkeyReleased(INT idx);
00699 #endif // APOXI_COMPAT_1_12_0
00700
00701 #if defined(APOXI_COMPAT_2_0_0)
00702
00703         virtual BOOLEAN OnInputChar(WCHAR chr);
00704 #endif // APOXI_COMPAT_2_0_0
00705
00706     private:
00707         struct {
00708             UINT clear               : 1;
00709             UINT maximized           : 1;
00710             UINT focused             : 1;
00711             UINT received_key_down   : 1;
00712             UINT disabled            : 1;
00713             UINT auto_clear_enabled  : 1;
00714             UINT optimize_auto_clear : 1;
00715             UINT internal_redraw     : 2;
00716             UINT frame_type          : 2;
00717             UINT display_idx         : 1;
00718             UINT auto_layout_enabled : 1;
00719         } m_bits;
00720
00721         UINT8 m_language_id;
00722         Control* m_last_focused_control;
00723         Control* m_next;
00724         Control* m_first_control;
00725         DrawableObject* m_first_drawable_object;
00726
00727         Rect m_repaint_rect;
00728         NavigationGuidance m_navigation_guidance;
00729
00731         void InitProperties(Control* parent);
00732
00734         BOOLEAN IsRepaintInsideClient() const;
00735
00737         Rect OptimizeInvArea(const Control& control, const Rect& abs_inv_rect) const;
00738
00740         void AbsInvalidate(Control* control, const Rect& abs_inv_rect, BOOLEAN erase);
00741
00751         void AbsInvalidateBackground(const Control* control,
00752                                      const Rect& abs_inv_rect,
00753                                      BOOLEAN is_next = FALSE);
00754
00755         void DrawFrame();
00756         BOOLEAN HasChildren() { return m_first_control != 0; }
00757         void BroadcastMsgToDrawableObjects(const Message& msg);
00758         BOOLEAN HandleMessage(const Message& msg);
00759
00762         void UpdateNavigationGuidance();
00763
00766         void ShowNavigationGuidance();
00767
00768
00769         friend class Application;   // Application::RouteMessage() accesses Control::RouteMessage()
00770         friend class Window;        // Window::Close() accesses Control::AbsInvalidate()
00771
00772 #if defined(APOXI_COMPAT_1_8_0)
00773         friend class Animation;
00774 #endif
00775 };
00776
00777 typedef Control::FrameType FrameType;
00778
00780 #endif  // Apoxi_Control_hpp
00781
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ControlDc.cpp File Reference

Gui/ControlDc.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/ControlDc.hpp"
#include "Gui/Control.hpp"
#include "Devices/Device.hpp"
#include "Kernel/System.hpp"

Include dependency graph for ControlDc.cpp:

Generated on Tue Jan 24 20:41:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ControlDc.hpp File Reference

Gui/ControlDc.hpp File Reference

#include <Gui/DeviceContext.hpp>

Include dependency graph for ControlDc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ControlDc

Defines

#define | Apoxi_ControlDc_hpp

Define Documentation

#define Apoxi_ControlDc_hpp

Generated on Tue Jan 24 20:41:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ControlDc.hpp Source File

Gui/ControlDc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ControlDc_hpp)
00010 #define Apoxi_ControlDc_hpp
00013
00014 #include <Gui/DeviceContext.hpp>
00015
00016 class Control;
00017
00019 class ControlDc : public DeviceContext {
00020     typedef DeviceContext Base;
00021
00022     public:
00023         ControlDc();
00024         ControlDc(Control* control);
00025         ControlDc(VirtualDisplay* display);
00026         void Init(Control* control);
00027         void Init(VirtualDisplay* display);
00028
00029     protected:
00031         void Update(const Rect& abs_rect);
00032 };  // ControlDc
00033
00035 #endif  // Apoxi_ControlDc_hpp
00036
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ControlFrameView.cpp File Reference

Gui/ControlFrameView.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ControlFrameView.hpp"
#include "DrawableObject.hpp"
#include "Control.hpp"
#include "PaintDc.hpp"

Include dependency graph for ControlFrameView.cpp:

Generated on Tue Jan 24 20:41:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ControlFrameView.hpp File Reference

Gui/ControlFrameView.hpp File Reference

#include <Gui/View.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for ControlFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ControlFrameView

Defines

#define | Apoxi_ControlFrameView_hpp

Define Documentation

#define Apoxi_ControlFrameView_hpp

Generated on Tue Jan 24 20:41:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ControlFrameView.hpp Source File

Gui/ControlFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ControlFrameView_hpp)
00010 #define Apoxi_ControlFrameView_hpp
00013
00014 #include <Gui/View.hpp>
00015 #include <Gui/Rect.hpp>
00016
00017 class LanguageManager;
00018 class Control;
00019
00022 class ControlFrameView : public View {
00023     public:
00024         ControlFrameView();
00025
00030         ControlFrameView(XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size);
00031
00032         virtual ~ControlFrameView();
00033
00035         XYDIM GetLeftSize() const { return m_left_size; }
00036
00038         XYDIM GetTopSize() const { return m_top_size; }
00039
00041         XYDIM GetRightSize() const { return m_right_size; }
00042
00044         XYDIM GetBottomSize() const { return m_bottom_size; }
00045
00047         virtual void Draw(const Component& component,
00048                           DeviceContext* dc,
00049                           const Rect& repaint_rect) const;
00050
00055         virtual void DrawClientAreaBackground(const Control& control,
00056                                               DeviceContext* dc,
00057                                               const Rect& repaint_rect) const;
00058
00059     protected:
00065         virtual void DrawControlFrame(const Control& control,  DeviceContext* dc, const Rect& repaint_rect) const = 0;
00066
00067         void SetLeftSize(XYDIM left_size) { m_left_size = left_size; }
00068
00069         void SetRightSize(XYDIM right_size) { m_right_size = right_size; }
00070
00071         void SetTopSize(XYDIM top_size) { m_top_size = top_size; }
00072
00073         void SetBottomSize(XYDIM bottom_size) { m_bottom_size = bottom_size; }
00074
00076         void DrawFrameComponents(const Control& control,
00077                                  DeviceContext* dc,
00078                                  const Rect& repaint_rect) const;
00079
00080     private:
00081         XYDIM m_left_size;
00082         XYDIM m_top_size;
00083         XYDIM m_right_size;
00084         XYDIM m_bottom_size;
00085 };
00086
00088 #endif  // Apoxi_ControlFrameView_hpp
00089
00090
Generated on Tue Jan 24 14:50:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DataPack.cpp File Reference

Gui/DataPack.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DataPack.hpp"

Include dependency graph for DataPack.cpp:

Generated on Tue Jan 24 20:41:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DataPack.hpp File Reference

Gui/DataPack.hpp File Reference

#include <Gui/AcacTypes.hpp>

Include dependency graph for DataPack.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataPack

Defines

#define | Apoxi_DataPack_hpp

Define Documentation

#define Apoxi_DataPack_hpp

Generated on Tue Jan 24 20:41:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DataPack.hpp Source File

Gui/DataPack.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DataPack_hpp)
00011 #define Apoxi_DataPack_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014
00020 class DataPack {
00021     public:
00027         DataPack(const UINT8 *data);
00028
00032         virtual ~DataPack();
00033
00038         DataPackId GetId() const;
00039
00044         UINT32 GetSize() const;
00045
00050         UINT16 GetNumberOfEntries() const;
00051
00052     protected:
00054         const DataPackHeaderData* m_data;
00055
00056         friend class BasicPackConnector;
00057 };
00058 #endif //Apoxi_DataPack_hpp
00059
00060
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateCompoundItem.cpp File Reference

Gui/DateCompoundItem.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DateCompoundItem.hpp"
#include "PaintDc.hpp"

Include dependency graph for DateCompoundItem.cpp:

Generated on Tue Jan 24 20:41:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateCompoundItem.hpp File Reference

Gui/DateCompoundItem.hpp File Reference

#include <Gui/CompoundItem.hpp>
#include <Auxiliary/Date.hpp>

Include dependency graph for DateCompoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DateCompoundItem
Contains a date. More...

Defines

#define | Apoxi_DateCompoundItem_hpp

Define Documentation

#define Apoxi_DateCompoundItem_hpp

Generated on Tue Jan 24 20:41:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateCompoundItem.hpp Source File

Gui/DateCompoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DateCompoundItem_hpp)
00011 #define Apoxi_DateCompoundItem_hpp
00015
00016 #include <Gui/CompoundItem.hpp>
00017 #include <Auxiliary/Date.hpp>
00018
00020 class DateCompoundItem : public CompoundItem {
00021     typedef CompoundItem Base;
00022
00023     public:
00024         enum {
00025             ID = 8
00026         };
00027
00029         static DateCompoundItem* CreateInstance(const Date& date = Date());
00030
00032         virtual ~DateCompoundItem();
00033
00035         virtual INT GetId() const;
00036
00038         void SetDate(const Date& date) { m_date = date; }
00039
00041         const Date& GetDate() const { return m_date; }
00042
00044         void SetDateFormat(DateFormat date_format) { m_date_format = date_format; }
00045
00047         DateFormat GetDateFormat() const { return m_date_format; }
00048
00050         virtual void Draw(DeviceContext* dc,
00051                           XYDIM x,
00052                           XYDIM y,
00053                           INT index,
00054                           INT count) const;
00055
00057         virtual INT WrapLine(INT index,
00058                              XYDIM width,
00059                              WrapPolicy wrap_policy = EditorDocument::WhitespaceWrap) const;
00060
00062         virtual XYDIM GetLineWidth(INT index, INT count) const;
00063
00065         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const;
00066
00068         virtual INT GetItemCount() const;
00069
00071         virtual BOOLEAN IsInstanceOf(INT id) const;
00072
00073     protected:
00075         DateCompoundItem(const Date& date = Date());
00076
00077     private:
00078         Date            m_date;
00079         DateFormat      m_date_format;
00080 };
00081
00083 #endif  // Apoxi_DateCompoundItem_hpp
00084
00085
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateEditor.cpp File Reference

Gui/DateEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DateEditor.hpp"
#include "DefaultCaret.hpp"
#include "DateTimeInputMapper.hpp"
#include <Gui/Control.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/ClientDc.hpp>
#include <Gui/Locale.hpp>

Include dependency graph for DateEditor.cpp:

Generated on Tue Jan 24 20:41:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateEditor.hpp File Reference

Gui/DateEditor.hpp File Reference

#include <Gui/AbstractLineEditor.hpp>
#include <Gui/DateEditorDocument.hpp>
#include <Gui/View.hpp>
#include <Auxiliary/Date.hpp>

Include dependency graph for DateEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DateEditor
class | DateEditorView

Defines

#define | Apoxi_DateEditor_hpp

Define Documentation

#define Apoxi_DateEditor_hpp

Generated on Tue Jan 24 20:41:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateEditor.hpp Source File

Gui/DateEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DateEditor_hpp)
00011 #define Apoxi_DateEditor_hpp
00016
00017 #include <Gui/AbstractLineEditor.hpp>
00018 #include <Gui/DateEditorDocument.hpp>
00019 #include <Gui/View.hpp>
00020 #include <Auxiliary/Date.hpp>
00021
00022 class DefaultCaret;
00023
00025 class DateEditorView : public AbstractLineEditorView {
00026     typedef AbstractLineEditorView Base;
00027
00028     public:
00030         explicit DateEditorView();
00031
00033         virtual ~DateEditorView();
00034
00036         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00037 };
00038
00041 class DateEditor : public AbstractLineEditor {
00042     typedef AbstractLineEditor Base;
00043
00044     public:
00045         enum {
00046             ID = 30
00047         };
00048
00051         DateEditor();
00052
00055         explicit DateEditor(Control* parent, const Date& date = Date());
00056
00058         virtual ~DateEditor();
00059
00062         void Init(Control* parent, const Date& date = Date());
00063
00065         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00066
00068         virtual BOOLEAN IsInstanceOf(INT id) const;
00069
00071         virtual void MoveCaret(INT steps);
00072
00074         void SetDate(const Date& date);
00075
00077         Date GetDate() const;
00078
00080         void SetDateFormat(DateFormat date_format);
00081
00083         DateFormat GetDateFormat() const;
00084
00085     protected:
00087         virtual Model* CreateModel() const;
00088
00090         virtual void Refresh(const Rect& rect);
00091
00092     private:
00093         BOOLEAN m_valid;
00094
00095         static DateEditorView m_view;
00096
00097         DateEditorDocument* GetMyDocument() { return (DateEditorDocument*)GetModel(); } //lint !e1762
00098         const DateEditorDocument* GetMyDocument() const { return (const DateEditorDocument*)GetModel(); }
00099
00100         DefaultCaret* GetMyCaret() { return (DefaultCaret*)GetCaret(); }
00101 };
00102
00104 #endif  // Apoxi_DateEditor_hpp
00105
00106
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateEditorDocument.cpp File Reference

Gui/DateEditorDocument.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DateEditorDocument.hpp"
#include "PaintDc.hpp"
#include "Font.hpp"
#include "Locale.hpp"
#include <Config/FontConfig.hpp>

Include dependency graph for DateEditorDocument.cpp:

Generated on Tue Jan 24 20:41:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateEditorDocument.hpp File Reference

Gui/DateEditorDocument.hpp File Reference

#include <Gui/EditorDocument.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/DateCompoundItem.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for DateEditorDocument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DateEditorDocument
A Date-Editor-Document contains a Date-Compound-Item. More...

Defines

#define | Apoxi_DateEditorDocument_hpp

Define Documentation

#define Apoxi_DateEditorDocument_hpp

Generated on Tue Jan 24 20:41:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateEditorDocument.hpp Source File

Gui/DateEditorDocument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DateEditorDocument_hpp)
00011 #define Apoxi_DateEditorDocument_hpp
00015
00016 #include <Gui/EditorDocument.hpp>
00017 #include <Gui/CharItem.hpp>
00018 #include <Gui/DateCompoundItem.hpp>
00019 #include <Auxiliary/Date.hpp>
00020 #include <Auxiliary/WString.hpp>
00021
00023 class DateEditorDocument : public EditorDocument {
00024     typedef EditorDocument Base;
00025
00026     public:
00028         DateEditorDocument(const Date& date = Date());
00029
00031         virtual ~DateEditorDocument();
00032
00034         void Init(const Date& date);
00035
00037         virtual INT GetItemCount() const;
00038
00040         virtual INT GetMaxItemCount() const;
00041
00043         virtual BOOLEAN InsertItem(const AtomItem& item, INT index);
00044
00046         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index);
00047
00049         virtual BOOLEAN RemoveItem(INT index);
00050
00052         virtual const CompoundItem& GetCompoundItem(INT index, INT* start_item_index = 0) const;
00053
00055         void SetDate(const Date& date);
00056
00058         const Date& GetDate() const;
00059
00061         void SetDateFormat(DateFormat date_format);
00062
00064         DateFormat GetDateFormat() const;
00065
00067         virtual void Draw(DeviceContext* dc, XYDIM x, XYDIM y,
00068                           INT index, INT count) const;
00069
00071         virtual INT WrapLine(INT index, XYDIM width, WrapPolicy wrap_policy = WhitespaceWrap) const;
00072
00074         virtual XYDIM GetLineWidth(INT index, INT count) const;
00075
00077         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const;
00078
00080         BOOLEAN IsSeparator(INT index) const;
00081
00082     protected:
00086         BOOLEAN Reinterpret(INT index);
00087
00088     private:
00089         // Supported pattern-types for editing.
00090         enum PatternType {
00091             Day,
00092             Month,
00093             ShortYear,
00094             LongYear
00095         };
00096
00097         DateCompoundItem    *m_compound_item;
00098         WString             m_date_buffer;          // Buffer for increasing performance.
00099
00100         /*  Returns the INTEGER-value of the date-buffer on the
00101             position given by <em>index</em>. Also the pattern-type is returned,
00102             hence checking and setting is possible for operations on the date-type.
00103             @param index    Pointer to the index (e. g. caret-position)
00104             @param value    Contains the INTEGER-value, if the return-value
00105                             is <em>TRUE</em>.
00106             @return         <em>TRUE</em>, if the operation was successful.*/
00107         BOOLEAN GetValue(INT index,
00108                          INT& value,
00109                          PatternType& pattern_type) const;
00110 };
00111
00113 #endif  // Apoxi_DateEditorDocument_hpp
00114
00115
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateTimeInputMapper.cpp File Reference

Gui/DateTimeInputMapper.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DateTimeInputMapper.hpp"
#include "AbstractEditor.hpp"
#include "DateEditorDocument.hpp"
#include <Config/KeyboardConfig.hpp>

Include dependency graph for DateTimeInputMapper.cpp:

Generated on Tue Jan 24 20:41:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateTimeInputMapper.hpp File Reference

Gui/DateTimeInputMapper.hpp File Reference

#include <Gui/NumericInputMapper.hpp>

Include dependency graph for DateTimeInputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DateTimeInputMapper

Defines

#define | Apoxi_DateTimeInputMapper_hpp

Define Documentation

#define Apoxi_DateTimeInputMapper_hpp

Generated on Tue Jan 24 20:41:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DateTimeInputMapper.hpp Source File

Gui/DateTimeInputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DateTimeInputMapper_hpp)
00011 #define Apoxi_DateTimeInputMapper_hpp
00015
00016 #include <Gui/NumericInputMapper.hpp>
00017
00020 class DateTimeInputMapper : public NumericInputMapper {
00021     typedef NumericInputMapper Base;
00022
00023     public:
00028         explicit DateTimeInputMapper(BOOLEAN date_mode = TRUE,
00029                                      BOOLEAN highlight_field = FALSE);
00030
00031         virtual ~DateTimeInputMapper();
00032
00034         virtual void SetEditor(AbstractEditor* editor);
00035
00037         virtual INT GetId() const;
00038
00041         virtual Alphabet GetAlphabet() const;
00042
00043     protected:
00045         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00046
00048         virtual void OnGetFocus();
00049
00051         virtual void OnLoseFocus();
00052
00053     private:
00054         BOOLEAN m_date_mode;
00055         BOOLEAN m_highlight_field;
00056
00057         void UpdateFieldHighlight();
00058 };
00059
00061 #endif  // Apoxi_DateTimeInputMapper_hpp
00062
00063
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DecodingThreadlet.cpp File Reference

Gui/DecodingThreadlet.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DecodingThreadlet.hpp"
#include "BitmapDc.hpp"

Include dependency graph for DecodingThreadlet.cpp:

Generated on Tue Jan 24 20:41:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DecodingThreadlet.hpp File Reference

Gui/DecodingThreadlet.hpp File Reference

#include <Gui/Bitmap.hpp>
#include <Gui/Image.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Kernel/Threadlet.hpp>

Include dependency graph for DecodingThreadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DecodingThreadlet

Defines

#define | Apoxi_DecodingThreadlet_hpp

Define Documentation

#define Apoxi_DecodingThreadlet_hpp

Generated on Tue Jan 24 20:41:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DecodingThreadlet.hpp Source File

Gui/DecodingThreadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DecodingThreadlet_hpp)
00011 #define Apoxi_DecodingThreadlet_hpp
00014
00015 #include <Gui/Bitmap.hpp>
00016 #include <Gui/Image.hpp>
00017 #include <Gui/ImageObtainer.hpp>
00018 #include <Kernel/Threadlet.hpp>
00019
00022 class DecodingThreadlet : public Threadlet {
00023     typedef Threadlet Base;
00024
00025     public:
00026         virtual ~DecodingThreadlet();
00027
00030         static DecodingThreadlet* CreateInstance(Image* image,
00031                                                  Bitmap* bitmap,
00032                                                  INT frame_idx);
00033
00035         virtual void ReleaseInstance();
00036
00038         virtual INT Fn();
00039
00040
00041     private:
00042         DecodingThreadlet(Image* image,
00043                           Bitmap* bitmap,
00044                           INT frame_idx);
00045
00046         Image* m_image;
00047         Bitmap* m_bitmap;
00048         INT m_frame_idx;
00049         ImageObtainer m_image_obt;
00050 };
00051
00052
00053
00055 #endif // Apoxi_DecodingThreadlet_hpp
00056
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DefaultCaret.cpp File Reference

Gui/DefaultCaret.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DefaultCaret.hpp"
#include "AbstractEditor.hpp"
#include "EditorDocument.hpp"
#include "AtomItem.hpp"
#include "CharItem.hpp"
#include "PaintDc.hpp"
#include "Locale.hpp"
#include "BidiManager.hpp"
#include <Devices/Display.hpp>

Include dependency graph for DefaultCaret.cpp:

Variables

const XYDIM | c_insert_width = 2
const XYDIM | c_overwrite_width = 5

Variable Documentation

const XYDIM c_insert_width = 2

const XYDIM c_overwrite_width = 5

Generated on Tue Jan 24 20:41:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DefaultCaret.hpp File Reference

Gui/DefaultCaret.hpp File Reference

#include <Gui/Caret.hpp>
#include <Gui/EditorDocument.hpp>
#include <Gui/DrawableObject.hpp>
#include <Auxiliary/TriggerTimer.hpp>

Include dependency graph for DefaultCaret.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultCaret

Defines

#define | Apoxi_DefaultCaret_hpp

Define Documentation

#define Apoxi_DefaultCaret_hpp

Generated on Tue Jan 24 20:41:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DefaultCaret.hpp Source File

Gui/DefaultCaret.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DefaultCaret_hpp)
00011 #define Apoxi_DefaultCaret_hpp
00015
00016 #include <Gui/Caret.hpp>
00017 #include <Gui/EditorDocument.hpp>
00018 #include <Gui/DrawableObject.hpp>
00019 #include <Auxiliary/TriggerTimer.hpp>
00020
00023 class DefaultCaret : public Caret {
00024     typedef Caret Base;
00025
00026     public:
00027         DefaultCaret();
00028
00032         DefaultCaret(AbstractEditor* editor,
00033                      UINT32 blink_rate,
00034                      Caret::Mode mode = Insert);
00035
00036         virtual ~DefaultCaret();
00037
00039         virtual void SetRow(INT row);
00040
00042         virtual void SetColumn(INT column);
00043
00045         virtual void SetVisible(BOOLEAN visible);
00046
00048         virtual XYDIM GetMinimalWidth() const;
00049
00051         virtual void Draw(DeviceContext* dc,
00052                           const Rect& bounds,
00053                           BOOLEAN right_to_left = FALSE) const;
00054
00057         BOOLEAN IsBlinking() const { return m_blinking; }
00058
00059     private:
00060         friend class TriggerTimer<DefaultCaret>;
00061
00062         BOOLEAN m_blinking;
00063         TriggerTimer<DefaultCaret> m_blinking_timer;
00064
00065         void OnTimer();
00066         void Update();
00067 };
00068
00070 #endif  // Apoxi_DefaultCaret_hpp
00071
00072
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DefaultItemRenderer.cpp File Reference

Gui/DefaultItemRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "PaintDc.hpp"
#include <Config/FontConfig.hpp>
#include <Config/GuiEngineConfig.hpp>
#include "DefaultItemRenderer.hpp"
#include "Locale.hpp"
#include "Bitmap.hpp"

Include dependency graph for DefaultItemRenderer.cpp:

Generated on Tue Jan 24 20:41:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DefaultItemRenderer.hpp File Reference

Gui/DefaultItemRenderer.hpp File Reference

#include <Kernel/Timer.hpp>
#include <Gui/AbstractItemRenderer.hpp>

Include dependency graph for DefaultItemRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DefaultItemRenderer

Defines

#define | Apoxi_DefaultItemRenderer_hpp

Define Documentation

#define Apoxi_DefaultItemRenderer_hpp

Generated on Tue Jan 24 20:41:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DefaultItemRenderer.hpp Source File

Gui/DefaultItemRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DefaultItemRenderer_hpp)
00010 #define Apoxi_DefaultItemRenderer_hpp
00013
00014 class ItemRendererProperties;
00015 class PaintDc;
00016 #include <Kernel/Timer.hpp>
00017 #include <Gui/AbstractItemRenderer.hpp>
00018
00022 class DefaultItemRenderer : public AbstractItemRenderer {
00023     typedef AbstractItemRenderer Base;
00024
00025     public:
00028         DefaultItemRenderer(const ItemRendererProperties* properties = 0);
00029
00030         virtual ~DefaultItemRenderer();
00031
00033         virtual Rect GetIconRect(const Item& item, const Rect& bounds) const;
00034
00036         virtual XYDIM GetItemHeight(INT item_style = DefaultStyle) const;
00037
00039         virtual void DrawBackground(DeviceContext* dc,
00040                                     const Item& item,
00041                                     const Rect& bounds,
00042                                     INT item_style) const;
00043
00045         virtual void DrawItem(DeviceContext* dc,
00046                               const Item& item,
00047                               const Rect& bounds,
00048                               INT item_style) const;
00049
00051         virtual BOOLEAN StartTextScrolling(const Item& item, const Rect& bounds) const;
00052
00054         virtual void StopTextScrolling(const Item& item) const;
00055
00057         virtual BOOLEAN ScrollText() const;
00058
00060         virtual IconState::Size GetIconSizeState(INT item_style = DefaultStyle) const;
00061
00062     protected:
00072         virtual void DrawText(DeviceContext* dc,
00073                               const Item& item,
00074                               const Rect& text_rect,
00075                               INT item_style) const;
00076
00077     private:
00078         mutable BOOLEAN m_first_scroll_cycle;
00079         IconState::Size m_icon_size_state;
00080         XYDIM m_item_height;
00081         XYDIM m_icon_width;
00082         mutable XYDIM m_scroll_pos;
00083
00084         void SetPenColorForText(PaintDc& pdc, const Item& item, INT item_style) const;
00085         void DrawItemContIndicator(DeviceContext* dc, const Rect& bounds, INT item_style) const;
00086         XYDIM GetItemContIndicatorWidth() const { return 6; }       // TODO: should be replaced by a themeable bitmap-width
00087         void DrawBitmap(DeviceContext* dc,
00088                         const Item& item,
00089                         const Rect& bounds,
00090                         INT item_style) const;
00091 };
00092
00094 #endif  // Apoxi_DefaultItemRenderer_hpp
00095
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Desktop.cpp File Reference

Gui/Desktop.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Desktop.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include <Config/DisplayConfig.hpp>
#include "GlassPane.hpp"
#include "Panel.hpp"
#include <Kernel/Application.hpp>

Include dependency graph for Desktop.cpp:

Generated on Tue Jan 24 20:41:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Desktop.hpp File Reference

Gui/Desktop.hpp File Reference

#include <Kernel/UserDispatcher.hpp>
#include <Kernel/Dispatcher.hpp>
#include <Gui/Window.hpp>

Include dependency graph for Desktop.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Desktop
class | Desktop::SectionWindow

Defines

#define | Apoxi_Desktop_hpp

Define Documentation

#define Apoxi_Desktop_hpp

Generated on Tue Jan 24 20:41:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Desktop.hpp Source File

Gui/Desktop.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2003 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Desktop_hpp)
00010 #define Apoxi_Desktop_hpp
00013
00014 #include <Kernel/UserDispatcher.hpp>
00015 #include <Kernel/Dispatcher.hpp>
00016 #include <Gui/Window.hpp>
00017
00018 class GlassPane;
00019
00027 class Desktop : public UserDispatcher {
00028     typedef UserDispatcher Base;
00029
00030     public:
00032         enum PanelAlignment {
00034             PanelOnLeft,
00036             PanelOnRight,
00038             PanelOnTop,
00040             PanelOnBottom
00041         };
00042
00045         enum SectionType {
00047             LeftSection = 0,
00049             TopSection = 1,
00051             RightSection = 2,
00053             BottomSection = 3,
00055             LastSectionEntry = 4
00056         };
00057
00060         enum SectionAlignment {
00063             HorizBorderAlign,
00066             VertBorderAlign
00067         };
00068
00073         static Desktop* CreateInstance(PanelAlignment panel_align = PanelOnBottom,
00074                                        SectionAlignment section_align = HorizBorderAlign);
00075
00077         virtual ~Desktop();
00078
00081         static Desktop* GetInstance() { return m_desktop; }
00082
00084         void Release();
00085
00087         void SetPanelAlignment(PanelAlignment alignment);
00088
00090         PanelAlignment GetPanelAlignment() const { return m_panel_align; }
00091
00093         void SetPanelEnabled(BOOLEAN enable);
00094
00096         BOOLEAN IsPanelEnabled () const { return m_panel_enabled; }
00097
00100         Rect GetPanelBounds() const;
00101
00105         GlassPane* GetGlassPane();
00106
00110         Component* GetSection(SectionType section_type);
00111
00116         void SetCenter(Window* win,
00117                        XYDIM left_gap = 0,
00118                        XYDIM top_gap = 0,
00119                        XYDIM right_gap = 0,
00120                        XYDIM bottom_gap = 0);
00121
00127         Rect GetCenterBounds() const;
00128
00132         Rect GetSectionContainerBounds() const;
00133
00134     protected:
00137         virtual GlassPane* CreateGlassPane();
00138
00142         virtual Component* CreateSection(SectionType section_type);
00143
00145         virtual BOOLEAN OnMessage(const Message& msg);
00146
00148         Desktop(PanelAlignment panel_align,
00149                 SectionAlignment section_align);
00150
00151     private:
00152         // The SectionWindow is a container for all sections.
00153         class SectionWindow : public Window {
00154             public:
00155                 SectionWindow();
00156                 virtual ~SectionWindow();
00157
00158             protected:
00159                 virtual void OnLayoutClient();
00160         };
00161
00162         void LayoutSections();
00163
00164         PanelAlignment m_panel_align;
00165         SectionAlignment m_section_align;
00166         BOOLEAN m_panel_enabled;
00167         XYDIM m_left_gap;
00168         XYDIM m_top_gap;
00169         XYDIM m_right_gap;
00170         XYDIM m_bottom_gap;
00171         GlassPane* m_glass_pane;
00172         Component* m_section[LastSectionEntry];
00173         Window* m_center_win;
00174         SectionWindow* m_section_win;
00175
00176         static Desktop* m_desktop;
00177 };
00178
00179
00181 #endif // Apoxi_Desktop_hpp
00182
00183
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DeviceContext.cpp File Reference

Gui/DeviceContext.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DeviceContext.hpp"
#include "NativeImage.hpp"
#include "BidiManager.hpp"
#include "WindowManager.hpp"
#include "Theme.hpp"
#include "BitmapDc.hpp"
#include "Window.hpp"
#include "PaintDc.hpp"
#include "Locale.hpp"
#include "ThemeManager.hpp"
#include <Devices/Display.hpp>
#include <Kernel/System.hpp>
#include <Config/DisplayConfig.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/RomData.hpp>
#include <Kernel/Application.hpp>
#include <Gui/AbstractTextRenderer.hpp>
#include <Gui/LanguageManager.hpp>
#include <Config/GuiEngineConfig.hpp>

Include dependency graph for DeviceContext.cpp:

Defines

#define | APOXI_CACHED_POLYGON_EDGES_MAX 10
#define | APOXI_POLYGON_EDGES_MAX 50

Define Documentation

#define APOXI_CACHED_POLYGON_EDGES_MAX 10

#define APOXI_POLYGON_EDGES_MAX 50

Generated on Tue Jan 24 20:41:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DeviceContext.hpp File Reference

Gui/DeviceContext.hpp File Reference

#include <Gui/TextFormat.hpp>
#include <Gui/Pen.hpp>
#include <Gui/Brush.hpp>
#include <Gui/Rect.hpp>
#include <Gui/BidiManager.hpp>

Include dependency graph for DeviceContext.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DeviceContext
struct | DeviceContext::ClipStack
class | DeviceContext::StylePainter
struct | DeviceContext::TextLine

Defines

#define | Apoxi_DeviceContext_hpp

Typedefs

typedef DeviceContext::RasterOp | RasterOp

Define Documentation

#define Apoxi_DeviceContext_hpp

Generated on Tue Jan 24 20:42:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DeviceContext.hpp Source File

Gui/DeviceContext.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DeviceContext_hpp)
00010 #define Apoxi_DeviceContext_hpp
00013
00014 class VirtualDisplay;
00015 class Control;
00016 class Font;
00017 class BitmapDc;
00018 class Bitmap;
00019 struct BitmapRes;
00020 #include <Gui/TextFormat.hpp>
00021 #include <Gui/Pen.hpp>
00022 #include <Gui/Brush.hpp>
00023 #include <Gui/Rect.hpp>
00024 #include <Gui/BidiManager.hpp>
00025
00028 class DeviceContext {
00029     public:
00030         // Obsolete - provided for backward compatibility with APOXI-versions < 1.1
00031         enum RasterOp {
00032             OverpaintRop,
00033             AndRop,
00034             OrRop,
00035             XorRop,
00036             NXorRop,
00037             InvertRop
00038         };
00039
00043         enum TransformationMode {
00045             NoTransformation,
00047             MirrorRot180,
00049             Mirror,
00051             Rot180,
00053             MirrorRot270,
00055             Rot90,
00057             Rot270,
00059             MirrorRot90
00060         };
00061
00064         enum AlphaBlendingMode {
00067             MaskAlphaBlending,
00069             ImmediateAlphaBlending
00070         };
00071
00074         DeviceContext();
00075
00076         DeviceContext(const DeviceContext* dc);
00077
00082         DeviceContext(VirtualDisplay* display, Control* control = 0);
00083
00084         virtual ~DeviceContext();
00085
00090         void Init(VirtualDisplay* display, Control* control = 0);
00091
00092         void Init(const DeviceContext* dc);
00093
00096         void SetTextFormat(const TextFormat& text_format) { m_text_format = text_format; }
00097
00100         const TextFormat& GetTextFormat() const { return m_text_format; }
00101
00105         void SetTextAlign(TextAlign text_align) { m_text_format.SetTextAlign(text_align); }
00106
00110         TextAlign GetTextAlign() const { return m_text_format.GetTextAlign(); }
00111
00116         void SetTextAttr(TextAttr text_attr) { m_text_format.SetTextAttr(text_attr); }
00117
00121         TextAttr GetTextAttr() const { return m_text_format.GetTextAttr(); }
00122
00125         void SetFont(const Font& font);
00126
00129         const Font& GetFont() const;
00130
00133         void SetFontAlign(FontAlign font_align) { m_text_format.SetFontAlign(font_align); }
00134
00137         FontAlign GetFontAlign() const { return m_text_format.GetFontAlign(); }
00138
00141         void SetPen(const Pen& pen) { m_pen = pen; }
00142
00145         const Pen& GetPen() const { return m_pen; }
00146
00149         void SetPenColor(const Color& color) { m_pen.SetColor(color); }
00150
00153         void SetPenColor(SystemColorId system_color_id);
00154
00157         const Color& GetPenColor() const { return m_pen.GetColor(); }
00158
00161         void SetPenColorValue(ColorValue color_value) { m_pen.SetColorValue(color_value); }
00162
00165         ColorValue GetPenColorValue() const { return m_pen.GetColorValue(); }
00166
00169         void SetPenColorRgb(UINT8 red,
00170                             UINT8 green,
00171                             UINT8 blue,
00172                             UINT8 alpha = 255) { m_pen.SetColorRgb(red, green, blue, alpha); }
00173
00176         void SetPenColorHsv(UINT8 hue,
00177                             UINT8 saturation,
00178                             UINT8 value,
00179                             UINT8 alpha = 255) { m_pen.SetColorHsv(hue, saturation, value, alpha); }
00180
00183         void SetPenStyle(PenStyle pen_style) { m_pen.SetStyle(pen_style); }
00184
00187         PenStyle GetPenStyle() const { return m_pen.GetStyle(); }
00188
00191         void SetBrush(const Brush& brush) { m_brush = brush; }
00192
00195         const Brush& GetBrush() const { return m_brush; }
00196
00199         void SetBrushColor(const Color& color) { m_brush.SetColor(color); }
00200
00203         void SetBrushColor(SystemColorId system_color_id);
00204
00207         const Color& GetBrushColor() const { return m_brush.GetColor(); }
00208
00211         void SetBrushColorValue(ColorValue color_value) { m_brush.SetColorValue(color_value); }
00212
00215         ColorValue GetBrushColorValue() const { return m_brush.GetColorValue(); }
00216
00219         void SetBrushColorRgb(UINT8 red,
00220                               UINT8 green,
00221                               UINT8 blue,
00222                               UINT8 alpha = 255) { m_brush.SetColorRgb(red, green, blue, alpha); }
00223
00226         void SetBrushColorHsv(UINT8 hue,
00227                               UINT8 saturation,
00228                               UINT8 value,
00229                               UINT8 alpha = 255) { m_brush.SetColorHsv(hue, saturation, value, alpha); }
00230
00233         void SetBrushStyle(BrushStyle brush_style) { m_brush.SetStyle(brush_style); }
00234
00237         BrushStyle GetBrushStyle() const { return m_brush.GetStyle(); }
00238
00248         void SetClipRect(const Rect& clip_rect);
00249
00253         Rect GetClipRect() const;
00254
00258         void BeginUpdate();
00259
00262         void EndUpdate();
00263
00267         void UpdateDisplay() const;
00268
00270         void DrawPixel(XYDIM x, XYDIM y);
00271
00273         Color GetPixelColor(XYDIM x, XYDIM y) const;
00274
00276         void DrawLine(XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2);
00277
00279         void DrawLine(XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, INT thickness);
00280
00284         void DrawRect(const Rect& rect, BOOLEAN fill = FALSE);
00285
00287         void DrawRect(XYDIM left,
00288                       XYDIM top,
00289                       XYDIM right,
00290                       XYDIM bottom,
00291                       BOOLEAN fill = FALSE) { DrawRect(Rect(left, top, right, bottom), fill); }
00292
00294         void FillRect(const Rect& rect);
00295
00297         void FillRect(XYDIM left, XYDIM top, XYDIM right, XYDIM bottom) { FillRect(Rect(left, top, right, bottom)); }
00298
00300         void InvertRect(const Rect& rect);
00301
00303         void InvertRect(XYDIM left, XYDIM top, XYDIM right, XYDIM bottom) { InvertRect(Rect(left, top, right, bottom)); }
00304
00306         void ClearRect(const Rect& rect);
00307
00309         void ClearRect(XYDIM left, XYDIM top, XYDIM right, XYDIM bottom) { ClearRect(Rect(left, top, right, bottom)); }
00310
00317         void DrawCircle(XYDIM x, XYDIM y, XYDIM radius, BOOLEAN fill = FALSE);
00318
00323         void FillCircle(XYDIM x, XYDIM y, XYDIM radius) {
00324             #ifdef APOXI_ENABLE_CIRCLE_DRAWING
00325                 DrawRawCircle(x, y, radius, TRUE);
00326             #endif
00327         }
00328
00336         void DrawPolygon(const XYDIM x[], const XYDIM y[], INT edges_count, BOOLEAN fill = FALSE);
00337
00347         void FillPolygon(const XYDIM x[],
00348                          const XYDIM y[],
00349                          INT edges_count,
00350                          const BitmapRes* texture = 0);
00351
00361         void DrawArc(XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, INT start_angle, INT arc_angle);
00362
00372         void FillArc(XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, INT start_angle, INT arc_angle);
00373
00384         void DrawRoundRect(XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, XYDIM arc_width, XYDIM arc_height);
00385
00396         void FillRoundRect(XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, XYDIM arc_width, XYDIM arc_height);
00397
00402         void Scroll(const Rect& rect, XYDIM dx, XYDIM dy);
00403
00415         void DrawText(XYDIM x,
00416                       XYDIM y,
00417                       const WCHAR* text,
00418                       INT from = 0,
00419                       INT char_count = -1,
00420                       BidiManager::ParagraphContext* context = 0);
00421
00425         void DrawTextInvert(XYDIM x, XYDIM y, const WCHAR* text, INT from = 0, INT char_count = -1);
00426
00438         void DrawTextBox(const Rect& box_rect,
00439                          const WCHAR* text,
00440                          INT from = 0,
00441                          INT char_count = -1,
00442                          BOOLEAN center_vertical = FALSE,
00443                          XYDIM line_gap = 0);
00444
00450         void DrawBitmap(XYDIM x,
00451                         XYDIM y,
00452                         const BitmapRes& bmp,
00453                         TransformationMode trans_mode = NoTransformation);
00454
00456         void DrawGsmBitmap(XYDIM x, XYDIM y, const UINT8* src);
00457
00459         XYDIM GetWidth() const { return m_width; }
00460
00462         XYDIM GetHeight() const { return m_height; }
00463
00465         Size GetTextSize(const WCHAR* text, INT from = 0, INT char_count = -1) const;
00466
00470         VirtualDisplay* GetDisplay() const { return m_display; }
00471
00473         XYDIM GetAbsX() const { return m_abs_x; }
00474
00476         XYDIM GetAbsY() const { return m_abs_y; }
00477
00480         void SetControl(Control* control);
00481
00485         static BOOLEAN Obtain(const Ticks& timeout);
00486
00489         static void Release() { m_sem.Release(); }
00490
00492         void SetAlphaBlendingMode(AlphaBlendingMode mode);
00493
00495         AlphaBlendingMode GetAlphaBlendingMode() const;
00496
00503         BOOLEAN IsInForeground() { return !IsOverlappedDrawing(); }
00504
00507         void SetRasterOp(RasterOp raster_op) {}
00508
00511         RasterOp GetRasterOp() const { return (RasterOp)OverpaintRop; }
00512
00513 #if defined(APOXI_COMPAT_2_9_0)
00514
00515         Size GetTextSizeForFont(const Font& font,
00516                                 const WCHAR* text,
00517                                 TextAttr text_attr = TextFormat::Normal,
00518                                 INT from = 0,
00519                                 INT char_count = -1) const;
00520
00526         INT  GetTextLine(const WCHAR* text,
00527                          INT char_count = -1,
00528                          XYDIM max_width = -1,
00529                          BOOLEAN incl_all_ws_at_eol = FALSE,
00530                          Size* total_size = 0,
00531                          INT* ws_at_eol_nr = 0,
00532                          XYDIM* ws_at_eol_width = 0) const;
00533
00539         INT  GetTextLineForFont(const Font& font,
00540                                 const WCHAR* text,
00541                                 TextAttr text_attr = TextFormat::Normal,
00542                                 INT char_count = -1,
00543                                 XYDIM max_width = -1,
00544                                 BOOLEAN incl_all_ws_at_eol = FALSE,
00545                                 Size* total_size = 0,
00546                                 INT* ws_at_eol_nr = 0,
00547                                 XYDIM* ws_at_eol_width = 0) const;
00548
00550         INT GetMaxTextLen(const WCHAR* text,
00551                           TextAttr text_attr = TextFormat::Normal,
00552                           XYDIM max_width = -1,
00553                           Size* total_size = 0,
00554                           INT from = 0,
00555                           INT char_count = -1) const;
00556 #endif // APOXI_COMPAT_2_9_0
00557
00558     protected:
00559         virtual void SetAbsX(XYDIM abs_x);
00560         virtual void SetAbsY(XYDIM abs_y);
00561         virtual void SetWidth(XYDIM width);
00562         virtual void SetHeight(XYDIM height);
00563         void UpdateAbsPos(XYDIM dx, XYDIM dy);
00564         void SetDisplay(VirtualDisplay* display) { m_display = display; }
00565         Control* GetControl() { return m_control; }
00566         virtual void AdjustBoundingRect();
00567
00568     private:
00569         struct TextLine {
00570             INT index;
00571             INT count;
00572             INT x;
00573         };
00574
00575         struct ClipStack {
00576             Rect prev_clip_rect;
00577             Rect cfc_rect;
00578             Control* prev_control;
00579         };
00580
00581         class StylePainter {
00582             public:
00583                 StylePainter(DeviceContext* dest_dc, const Rect& bounds);
00584                 ~StylePainter();
00585                 BOOLEAN IsValid() const { return m_bitmap_dc != 0; }
00586                 DeviceContext* GetContext() const;
00587
00588             private:
00589                 DeviceContext* m_dest_dc;
00590                 Bitmap* m_bitmap;
00591                 BitmapDc* m_bitmap_dc;
00592                 Rect m_bounds;
00593         };
00594
00595 #ifdef APOXI_ENABLE_ALPHA_BLENDING
00596         AlphaBlendingMode m_alpha_blend_mode;
00597 #endif
00598         UINT8 m_updating;           // > 0 if BeginUpdate has been called
00599         BOOLEAN m_masked;
00600         XYDIM m_abs_x;
00601         XYDIM m_abs_y;
00602         XYDIM m_width;
00603         XYDIM m_height;
00604         VirtualDisplay* m_display;
00605         Pen m_pen;
00606         Brush m_brush;
00607         TextFormat m_text_format;
00608         Rect m_clip_rect;
00609         Control* m_control;         // control where drawing operations happen
00610         Control* m_current_control; // current control used for iterating through all controls in front of m_control
00611
00612         static BOOLEAN m_initialized;
00613         static Semaphore m_sem;
00614         static const INT c_max_drawsync_recursion_depth;    // maximum allowed recursion depth
00615         static INT m_recursion_depth;                       // counts current recursion depth
00616         static ClipStack m_clip_stack[];
00617
00618         void IntersectWithDisplay(Rect& rect) const;
00619
00624         BOOLEAN PrepareForDrawing(Rect& rect);
00625
00626         void DrawDiagLine(XYDIM left, XYDIM top, XYDIM right, XYDIM bottom);
00627         void DrawRawText(XYDIM x,
00628                          XYDIM y,
00629                          const WCHAR* text,
00630                          INT from,
00631                          INT char_count,
00632                          BidiManager::ParagraphContext* context);
00633         void DrawTextLine(XYDIM x1, XYDIM x2, XYDIM y);
00634
00635         #ifdef APOXI_ENABLE_CIRCLE_DRAWING
00636             void DrawRawCircle(XYDIM x, XYDIM y, XYDIM radius, BOOLEAN fill);
00637             void DrawCirclePoints(XYDIM x, XYDIM y, XYDIM x_diff, XYDIM y_diff, BOOLEAN fill);
00638             void DrawClippedCirclePoints(XYDIM x, XYDIM y, XYDIM x_diff, XYDIM y_diff, BOOLEAN fill);
00639         #endif // APOXI_ENABLE_CIRCLE_DRAWING
00640
00641         BOOLEAN IsOverlappedDrawing();
00642         void BeginOverlappedDrawing();
00643         void SetLeftOverlappedClipRect();
00644         void SetTopOverlappedClipRect();
00645         void SetRightOverlappedClipRect();
00646         void SetBottomOverlappedClipRect();
00647         void EndOverlappedDrawing();
00648
00649         // helper methods for clipping a diagonal line
00650         #ifdef APOXI_ENABLE_DIAGONAL_LINE_DRAWING
00651             UINT8 GetClippingCode (XYDIM x, XYDIM y) const;
00652             XYDIM SearchMidpoint (XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, XYDIM stop_val, BOOLEAN search_for_y) const;
00656             BOOLEAN GetClippedPoints(XYDIM &x1, XYDIM &y1, XYDIM &x2, XYDIM &y2) const;
00657         #endif // APOXI_ENABLE_DIAGONAL_LINE_DRAWING
00658
00659         #ifdef APOXI_ENABLE_ARC_DRAWING
00660             // helper methods for drawing an arc
00661             void DrawHorizArcLine(XYDIM x1, XYDIM y, XYDIM x2, BOOLEAN no_clip);
00662             void DrawVertArcLine(XYDIM x, XYDIM y1, XYDIM y2, BOOLEAN no_clip);
00663             void FillArcRect(XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, BOOLEAN no_clip);
00664             void DrawArcPixel(XYDIM x, XYDIM y,BOOLEAN no_clip);
00665         #endif // APOXI_ENABLE_ARC_DRAWING
00666 };  // DeviceContext
00667
00668 typedef DeviceContext::RasterOp RasterOp;
00669
00671 #endif  // Apoxi_DeviceContext_hpp
00672
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DialogWindow.hpp File Reference

Gui/DialogWindow.hpp File Reference

#include <Compat/DialogWindow.hpp>

Include dependency graph for DialogWindow.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:17:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DialogWindow.hpp Source File

Gui/DialogWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 /*  The class DialogWindow has been moved to Compat.
00010 This header-file assures backward-compatibility for
00011 applications written with APOXI-versions smaller than 1.10.*/
00012 #include <Compat/DialogWindow.hpp>
00013
00014
Generated on Tue Jan 24 14:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DisplayDc.cpp File Reference

Gui/DisplayDc.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/DisplayDc.hpp"
#include "Gui/Control.hpp"
#include "Devices/Device.hpp"
#include "Kernel/System.hpp"

Include dependency graph for DisplayDc.cpp:

Generated on Tue Jan 24 20:42:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DisplayDc.hpp File Reference

Gui/DisplayDc.hpp File Reference

#include <Gui/DeviceContext.hpp>

Include dependency graph for DisplayDc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DisplayDc
DeviceContext that encompasses the complete display. More...

Defines

#define | Apoxi_DisplayDc_hpp

Define Documentation

#define Apoxi_DisplayDc_hpp

Generated on Tue Jan 24 20:42:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DisplayDc.hpp Source File

Gui/DisplayDc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DisplayDc_hpp)
00010 #define Apoxi_DisplayDc_hpp
00013
00014 #include <Gui/DeviceContext.hpp>
00015
00016 class Control;
00017
00019 class DisplayDc : public DeviceContext {
00020     typedef DeviceContext Base;
00021
00022     public:
00025         DisplayDc();
00026
00028         DisplayDc(Display* display);
00029
00031         virtual ~DisplayDc();
00032
00034         void Init(Display* display);
00035
00037         virtual void AdjustBoundingRect();
00038 };  // DisplayDc
00039
00041 #endif  // Apoxi_DisplayDc_hpp
00042
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DrawableObject.cpp File Reference

Gui/DrawableObject.cpp File Reference

#include "Gui/PreComp.hpp"
#include "DrawableObject.hpp"
#include "Control.hpp"

Include dependency graph for DrawableObject.cpp:

Generated on Tue Jan 24 20:42:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DrawableObject.hpp File Reference

Gui/DrawableObject.hpp File Reference

#include <Gui/Component.hpp>
#include <Gui/View.hpp>

Include dependency graph for DrawableObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DrawableObject
class | DrawableObjectView

Defines

#define | Apoxi_DrawableObject_hpp

Define Documentation

#define Apoxi_DrawableObject_hpp

Generated on Tue Jan 24 20:42:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/DrawableObject.hpp Source File

Gui/DrawableObject.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DrawableObject_hpp)
00010 #define Apoxi_DrawableObject_hpp
00014
00015 #include <Gui/Component.hpp>
00016 #include <Gui/View.hpp>
00017
00018 class Control;
00019
00027 class DrawableObject : public Component {
00028     typedef Component Base;
00029
00030     public:
00031         enum {
00032             ID = 10
00033         };
00034
00040         enum ParentArea {
00042             ClientArea,
00044             FrameArea
00045         };
00046
00049         DrawableObject();
00050
00060         DrawableObject(Control* parent,
00061                        BOOLEAN add_to_parent = TRUE,
00062                        const View* view = 0);
00063
00065         virtual ~DrawableObject() ;
00066
00076         void Init(Control* parent,
00077                   BOOLEAN add_to_parent = TRUE,
00078                   const View* view = 0);
00079
00082         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00083
00085         virtual BOOLEAN IsInstanceOf(INT id) const;
00086
00088         virtual void SetParent(Control* parent);
00089
00092         void Draw(DeviceContext* dc, const Rect& repaint_rect) const;
00093
00100         void Invalidate(BOOLEAN erase = TRUE);
00101
00106         void SetParentArea(ParentArea parent_area) { m_parent_area = parent_area; }
00107
00110         ParentArea GetParentArea() const { return m_parent_area; }
00111
00114         void SetNext(DrawableObject* next) { m_next = next; }
00115
00118         DrawableObject* GetNext() const { return m_next; }
00119
00121         virtual void AdjustThemeDependencies();
00122
00124         virtual void AdjustStrings();
00125
00128         void SetVisible(BOOLEAN visible);
00129
00131         BOOLEAN IsVisible() const;
00132
00133     protected:
00135         virtual BOOLEAN OnMessage(const Message &msg);
00136
00138         virtual void OnThemeChanged();
00139
00141         virtual void OnLanguageChanged();
00142
00144         virtual void OnMove(XYDIM dx, XYDIM dy);
00145
00147         virtual void OnResize(XYDIM dx, XYDIM dy);
00148
00149     private:
00150         ParentArea m_parent_area;
00151         DrawableObject* m_next;
00152
00153         friend class Control;   // a control must be able to invoke the methods Refresh and Cleanup from a drawable obj.
00154 };
00155
00157 class DrawableObjectView : public View {
00158     typedef View Base;
00159
00160     public:
00162         DrawableObjectView(XYDIM default_width = -1, XYDIM default_height = -1);
00163
00165         virtual ~DrawableObjectView();
00166 };
00167
00169 #endif  // Apoxi_DrawableObject_hpp
00170
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EditorDocument.cpp File Reference

Gui/EditorDocument.cpp File Reference

#include "Gui/PreComp.hpp"
#include "EditorDocument.hpp"
#include "CompoundItem.hpp"
#include "AbstractEditor.hpp"

Include dependency graph for EditorDocument.cpp:

Generated on Tue Jan 24 20:42:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EditorDocument.hpp File Reference

Gui/EditorDocument.hpp File Reference

#include <Auxiliary/ObjectObtainer.hpp>
#include <Auxiliary/Vector.hpp>
#include <Gui/Model.hpp>
#include <Gui/InputMapper.hpp>
#include <Gui/EditorLine.hpp>

Include dependency graph for EditorDocument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EditorDocument
class | EditorDocumentObtainer

Defines

#define | Apoxi_EditorDocument_hpp

Typedefs

typedef EditorDocument::LineAlignment | LineAlignment
typedef EditorDocument::WrapPolicy | WrapPolicy

Define Documentation

#define Apoxi_EditorDocument_hpp

Generated on Tue Jan 24 20:42:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EditorDocument.hpp Source File

Gui/EditorDocument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_EditorDocument_hpp)
00011 #define Apoxi_EditorDocument_hpp
00015
00016 #include <Auxiliary/ObjectObtainer.hpp>
00017 #include <Auxiliary/Vector.hpp>
00018 #include <Gui/Model.hpp>
00019 #include <Gui/InputMapper.hpp>
00020 #include <Gui/EditorLine.hpp>
00021
00022 class AtomItem;     //lint !e763
00023 class CharItem;
00024 class CompoundItem;
00025 class EditorDocument;
00026
00034 class EditorDocumentObtainer : public ObjectObtainer {
00035     typedef ObjectObtainer Base;
00036
00037     public:
00040         EditorDocumentObtainer();
00041
00046         EditorDocumentObtainer(EditorDocument* doc, BOOLEAN disposeable);
00047         virtual ~EditorDocumentObtainer();
00048         EditorDocument* GetEditorDocument() { return m_doc; }
00049         const EditorDocument* GetEditorDocument() const { return m_doc; }
00050
00051     private:
00052         EditorDocument* m_doc;
00053 };
00054
00062 class EditorDocument : public Model, public ObtainableObject {
00063     typedef Model Base;
00064
00065     public:
00067         enum WrapPolicy {
00073             WhitespaceWrap = 0,
00074
00077             StrictWhitespaceWrap = 1,
00078
00086             LeftJustifiedWrap = 2,
00087
00090             CutWrap = 3,
00091
00096             CompactWrap = 4
00097         };
00098
00100         enum LineAlignment {
00103             DefaultAlign,
00105             LeftAlign,
00107             CenteredAlign,
00109             RightAlign
00110         };
00111
00112         EditorDocument();
00113         virtual ~EditorDocument();
00114
00116         virtual INT GetItemCount() const = 0;
00117
00120         virtual INT GetMaxItemCount() const = 0;
00121
00126         virtual BOOLEAN InsertItem(const AtomItem& item, INT item_index = -1) = 0;
00127
00132         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT item_index = -1) = 0;
00133
00135         virtual BOOLEAN RemoveItem(INT item_index = -1) = 0;
00136
00139         virtual INT GetCompoundItemCount() const;
00140
00156         virtual BOOLEAN InsertCompoundItem(CompoundItem* compound_item, INT ci_index = -1);
00157
00174         virtual BOOLEAN InsertCompoundItemBeforeItem(CompoundItem* compound_item, INT item_index = -1);
00175
00181         virtual BOOLEAN RemoveCompoundItem(INT ci_index = -1);
00182
00189         virtual const CompoundItem& GetCompoundItem(INT ci_index, INT* start_item_index = 0) const = 0;
00190
00195         const CompoundItem& GetParentCompoundItem(INT item_index, INT* start_item_index = 0) const;
00196
00203         virtual void Draw(DeviceContext* dc,
00204                           XYDIM x,
00205                           XYDIM y,
00206                           INT item_index,
00207                           INT count) const = 0;
00208
00212         virtual INT WrapLine(INT item_index, XYDIM width, WrapPolicy wrap_policy = WhitespaceWrap) const = 0;
00213
00218         virtual XYDIM GetLineWidth(INT item_index, INT count) const = 0;
00219
00226         virtual XYDIM GetLineHeight(INT item_index, INT count, XYDIM* baseline = 0) const = 0;
00227
00233         virtual LineAlignment GetLineAlignment(INT item_index, INT count) const;
00234
00245         virtual void GetItemScope(INT item_index,
00246                                   INT count,
00247                                   INT sub_index,
00248                                   XYDIM* x,
00249                                   XYDIM* width) const;
00250
00253         virtual BOOLEAN IsEditableAfterLastItem() const;
00254
00256         virtual void Clear();
00257
00261         virtual BOOLEAN IsRightToLeftItem(INT item_index) const;
00262
00264         void SetAlphabet(InputMapper::Alphabet alphabet) { m_alphabet = alphabet; }
00265
00267         InputMapper::Alphabet GetAlphabet() const { return m_alphabet; }
00268
00269         virtual void OnChangedLayout(const Vector<EditorLine>& line, INT from = -1, INT count = 0);
00270
00271     private:
00272         InputMapper::Alphabet   m_alphabet;
00273 };
00274
00275 typedef EditorDocument::WrapPolicy WrapPolicy;
00276 typedef EditorDocument::LineAlignment LineAlignment;
00277
00279 #endif  // Apoxi_EditorDocument_hpp
00280
00281
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EditorLine.cpp File Reference

Gui/EditorLine.cpp File Reference

#include "Gui/PreComp.hpp"
#include "EditorLine.hpp"

Include dependency graph for EditorLine.cpp:

Generated on Tue Jan 24 20:42:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EditorLine.hpp File Reference

Gui/EditorLine.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EditorLine

Defines

#define | Apoxi_EditorLine_hpp

Define Documentation

#define Apoxi_EditorLine_hpp

Generated on Tue Jan 24 20:42:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EditorLine.hpp Source File

Gui/EditorLine.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_EditorLine_hpp)
00011 #define Apoxi_EditorLine_hpp
00016
00017
00020 class EditorLine {
00021     public:
00022         explicit EditorLine(INT start_idx = 0, INT length = 0, XYDIM height = 0);
00023         void SetStartIndex(INT start_idx) { m_start_idx = start_idx; }
00024         INT GetStartIndex() const { return m_start_idx; }
00025         void SetLength(INT length) { m_length = length; }
00026         INT GetLength() const { return m_length; }
00027         void SetHeight(INT height) { m_height = height; }
00028         XYDIM GetHeight() const { return m_height; }
00029
00030     private:
00031         INT m_start_idx;
00032         INT m_length;
00033         XYDIM m_height;
00034 };
00035
00037 #endif  // Apoxi_EditorLine_hpp
00038
00039
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EncodingThreadlet.cpp File Reference

Gui/EncodingThreadlet.cpp File Reference

#include "Gui/PreComp.hpp"
#include "EncodingThreadlet.hpp"
#include "ImageEncoder.hpp"

Include dependency graph for EncodingThreadlet.cpp:

Generated on Tue Jan 24 20:42:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EncodingThreadlet.hpp File Reference

Gui/EncodingThreadlet.hpp File Reference

#include <Kernel/Threadlet.hpp>
#include <Gui/Image.hpp>

Include dependency graph for EncodingThreadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EncodingThreadlet

Defines

#define | Apoxi_EncodingThreadlet_hpp

Define Documentation

#define Apoxi_EncodingThreadlet_hpp

Generated on Tue Jan 24 20:42:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/EncodingThreadlet.hpp Source File

Gui/EncodingThreadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_EncodingThreadlet_hpp)
00011 #define Apoxi_EncodingThreadlet_hpp
00014
00015 class ImageEncoder;
00016 class DataSink;
00017 #include <Kernel/Threadlet.hpp>
00018 #include <Gui/Image.hpp>
00019
00025 class EncodingThreadlet : public Threadlet {
00026     typedef Threadlet Base;
00027
00028     public:
00029         virtual ~EncodingThreadlet();
00030
00035         virtual void ReleaseInstance();
00036
00038         virtual INT Fn();
00039
00040     protected:
00044         EncodingThreadlet(ImageEncoder& encoder, const Image& source, DataSink& dest);
00045
00050         EncodingThreadlet(ImageEncoder& encoder,
00051                           BinData& source,
00052                           const Image::MetaData& src_params,
00053                           DataSink& dest);
00054
00056         ImageEncoder& GetEncoder() { return m_encoder; }
00057
00058         // Returns the source image. 0 is returned if a binary data as source is used.
00059         const Image* GetImage() const { return m_src_image; }
00060
00062         BinData* GetBinData() const { return m_src_data; }
00063
00065         const Image::MetaData* GetMetaData() const { return m_src_params; }
00066
00068         DataSink& GetDataSink() { return m_data_sink; }
00069
00070     private:
00071         // References instead of pointers are used, as it may never be allowed to change
00072         // the properties during the lifetime of the instance and also because the
00073         // properties never may be 0.
00074         ImageEncoder& m_encoder;
00075         DataSink& m_data_sink;
00076
00077         BinData* m_src_data;
00078         const Image::MetaData* m_src_params;
00079         const Image* m_src_image;
00080 };
00081
00083 #endif // Apoxi_EncodingThreadlet_hpp
00084
00085
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FilePack.cpp File Reference

Gui/FilePack.cpp File Reference

#include "Gui/PreComp.hpp"
#include "FilePack.hpp"

Include dependency graph for FilePack.cpp:

Generated on Tue Jan 24 20:42:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FilePack.hpp File Reference

Gui/FilePack.hpp File Reference

#include <Gui/AcacTypes.hpp>
#include <Gui/DataPack.hpp>

Include dependency graph for FilePack.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FilePack

Defines

#define | Apoxi_FilePack_hpp

Define Documentation

#define Apoxi_FilePack_hpp

Generated on Tue Jan 24 20:42:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FilePack.hpp Source File

Gui/FilePack.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FilePack_hpp)
00011 #define Apoxi_FilePack_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014 #include <Gui/DataPack.hpp>
00015
00016 class FilePack : public DataPack {
00017     typedef DataPack Base;
00018
00019     public:
00020         FilePack(const UINT8 *data);
00021         virtual ~FilePack();
00022
00023         const CustFileData *GetFile(UINT16 index);
00024
00025     private:
00026         CustFileData *  m_cust_file_data;
00027 };
00028
00029 #endif  // Apoxi_FilePack_hpp
00030
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FilePackConnector.cpp File Reference

Gui/FilePackConnector.cpp File Reference

#include "Gui/PreComp.hpp"
#include "FilePackConnector.hpp"
#include "BasicPackConnector.hpp"
#include "AcacTypes.hpp"

Include dependency graph for FilePackConnector.cpp:

Generated on Tue Jan 24 20:42:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FilePackConnector.hpp File Reference

Gui/FilePackConnector.hpp File Reference

#include <Gui/FilePack.hpp>
#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for FilePackConnector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FilePackConnector

Defines

#define | Apoxi_FilePackConnector_hpp

Define Documentation

#define Apoxi_FilePackConnector_hpp

Generated on Tue Jan 24 20:42:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FilePackConnector.hpp Source File

Gui/FilePackConnector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FilePackConnector_hpp)
00011 #define Apoxi_FilePackConnector_hpp
00012
00013 #include <Gui/FilePack.hpp>
00014 #include <Auxiliary/MimeTypeTable.hpp>
00015
00016 class FilePackConnector {
00017
00018     public:
00019         static void Init();
00020
00021         static BOOLEAN IsFilePackAvailable();
00022
00023         static INT GetNumberOfFiles();
00024
00025         static const WCHAR *GetFileName(UINT16 index);
00026
00027         static void GetFileNames(const WCHAR **file_names, INT size);
00028
00029         static INT32 GetIndexOfFile(const WCHAR *file_name);
00030
00031         static UINT32 GetFileSize(UINT16 index);
00032
00033         static const UINT8 *GetData(UINT16 index);
00034
00035         static MimeType GetMimeType(UINT16 file_index);
00036
00037         static void CopyData(UINT16 file_index, UINT8 *buffer, UINT32 offset, UINT32 length);
00038
00039     protected:
00040
00041     private:
00042
00043         static FilePack *       m_file_pack;
00044 };
00045
00046 #endif  // Apoxi_FilePackConnector_hpp
00047
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FlowLayout.cpp File Reference

Gui/FlowLayout.cpp File Reference

#include "Gui/PreComp.hpp"
#include "FlowLayout.hpp"
#include <Config/KeyboardConfig.hpp>

Include dependency graph for FlowLayout.cpp:

Generated on Tue Jan 24 20:42:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FlowLayout.hpp File Reference

Gui/FlowLayout.hpp File Reference

#include <Gui/Control.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for FlowLayout.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FlowLayout
struct | FlowLayout::AlignInfo

Defines

#define | Apoxi_FlowLayout_hpp

Define Documentation

#define Apoxi_FlowLayout_hpp

Generated on Tue Jan 24 20:42:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FlowLayout.hpp Source File

Gui/FlowLayout.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_FlowLayout_hpp)
00010 #define Apoxi_FlowLayout_hpp
00013
00014 #include <Gui/Control.hpp>
00015 #include <Auxiliary/Vector.hpp>
00016
00026 class FlowLayout : public Control {
00027     typedef Control Base;
00028
00029     public:
00030         enum {
00031             ID = 38
00032         };
00033
00036         enum Alignment {
00039             Start = 0,
00042             Middle = 1,
00045             End = 2,
00046         };
00047
00050         FlowLayout();
00051
00055         FlowLayout(Control* parent, BOOLEAN horizontal = TRUE);
00056
00057         virtual ~FlowLayout();
00058
00062         void Init(Control* parent, BOOLEAN horizontal = TRUE);
00063
00066         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00067
00073         void AddAlignInfo(Component& comp, Alignment align);
00074
00082         BOOLEAN RemoveAlignInfo(const Component& comp);
00083
00089         BOOLEAN GetAlignInfo(const Component& comp, Alignment& align) const;
00090
00092         virtual BOOLEAN IsInstanceOf(INT id) const;
00093
00094     protected:
00096         virtual void OnLayoutClient();
00097
00099         virtual void OnThemeChanged();
00100
00102         virtual void OnFocusPreviousControl();
00103
00105         virtual void OnFocusNextControl();
00106
00108         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00109
00110     private:
00111         struct AlignInfo {
00112             Component* comp;
00113             Alignment align;
00114         };
00115
00116         BOOLEAN m_horizontal;
00117         Vector<AlignInfo> m_align_info;
00118
00119         BOOLEAN IsComponentEmbedded(const Component& comp) const;
00120         void UpdateNavigationGuidance();
00121         BOOLEAN TreatKeyCode(KeyCode key_code);
00122 };
00123
00124 #endif  //Apoxi_FlowLayout_hpp
00125
Generated on Tue Jan 24 14:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Font.cpp File Reference

Gui/Font.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/Font.hpp"
#include <Gui/LanguageManager.hpp>
#include <Gui/AbstractTextRenderer.hpp>
#include <Config/GuiEngineConfig.hpp>

Include dependency graph for Font.cpp:

Generated on Tue Jan 24 20:42:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Font.hpp File Reference

Gui/Font.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/TextFormat.hpp>

Include dependency graph for Font.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Font
struct | FontRes
struct | Glyph
struct | GlyphHeader
struct | GlyphIndexTab

Defines

#define | Apoxi_Font_hpp
#define | GlyphHeaderPtr GlyphHeader FONT_HUGE*
#define | GlyphIndexTabPtr GlyphIndexTab FONT_HUGE*
#define | GlyphPtr Glyph FONT_HUGE*
#define | GlyphTab struct { GlyphHeader* m_glyph_header; UINT8* m_data; }

Typedefs

typedef Font::SystemFontId | SystemFontId

Define Documentation

#define Apoxi_Font_hpp

Generated on Tue Jan 24 20:43:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Font.hpp Source File

Gui/Font.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Font_hpp)
00010 #define Apoxi_Font_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Gui/TextFormat.hpp>
00016
00017 // Internal
00018 struct Glyph {
00019     INT GetWidth() const { return m_width; }
00020     const UINT8 FONT_HUGE* GetData() const { return m_data; }
00021
00022     INT m_width;                    // Character width in pixels
00023     const UINT8 FONT_HUGE* m_data;  // Pointer to the character bitmap
00024 };
00025
00026 #define GlyphPtr Glyph FONT_HUGE*
00027
00028 // Internal
00029 struct GlyphHeader {
00030     UINT16 m_offset;                // Offset of the bitmap-data
00031     UINT8 m_low_byte;               // Low-byte of unicode-character
00032     UINT8 m_width;                  // Width of the character
00033 };
00034
00035 #define GlyphHeaderPtr GlyphHeader FONT_HUGE*
00036
00037 // The following definition allows a more readable forward-declaration for generated fonts
00038 #define GlyphTab struct { GlyphHeader* m_glyph_header; UINT8* m_data; }
00039
00040 // Internal
00041 struct GlyphIndexTab {
00042     UINT8 m_glyph_count[256];               // Number of glyphs - 1!
00043     const GlyphHeaderPtr m_glyph_tab[256];
00044 };
00045
00046 #define GlyphIndexTabPtr GlyphIndexTab FONT_HUGE*
00047
00048 // Internal
00049 struct FontRes {
00050     XYDIM height;
00051     XYDIM baseline;
00052     XYDIM gap_to_next_char;
00053     const GlyphIndexTabPtr normal_glyph_index_tab;
00054     const GlyphIndexTabPtr italic_glyph_index_tab;
00055     const GlyphIndexTabPtr bold_glyph_index_tab;
00056     const GlyphIndexTabPtr italic_bold_glyph_index_tab;
00057     const WCHAR* name;
00058     Glyph invalid_glyph;
00059 };
00060
00063 class Font {
00064     public:
00068         enum SystemFontId {
00070             Client = 0,
00072             ActiveTitle,
00074             InactiveTitle,
00076             Softkeys,
00078             Menu,
00080             TextEditor,
00081             SystemFontIdCount   // mandatory last entry
00082         };
00083
00085         Font();
00086
00088         virtual ~Font();
00089
00091         virtual const WCHAR* GetName() const = 0;
00092
00095         virtual void GetGlyph(WCHAR chr, TextAttr text_attr, GlyphPtr glyph) const = 0;
00096
00098         virtual INT GetHeight() const = 0;
00099
00101         virtual INT GetBaseline() const = 0;
00102
00104         virtual INT GetGapToNextChar(WCHAR character = 0) const = 0;
00105
00108         virtual BOOLEAN SupportsTextAttr(TextAttr text_attr) const = 0;
00109
00117         INT GetTextWidth(const WCHAR* text,
00118                          TextAttr text_attr,
00119                          INT from = 0,
00120                          INT n_chars = -1,
00121                          BOOLEAN include_gap = FALSE) const;
00122
00123         BOOLEAN operator == (const Font& font) const;
00124
00125         BOOLEAN operator != (const Font& font) const { return !(*this == font); }
00126 };
00127
00128 typedef Font::SystemFontId SystemFontId;
00129
00131 #endif  // Apoxi_Font_hpp
00132
00133
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontEntry.cpp File Reference

Gui/FontEntry.cpp File Reference

#include "Gui/PreComp.hpp"
#include "FontEntry.hpp"

Include dependency graph for FontEntry.cpp:

Generated on Tue Jan 24 20:43:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontEntry.hpp File Reference

Gui/FontEntry.hpp File Reference

#include <Gui/AcacTypes.hpp>
#include <Gui/TextFormat.hpp>
#include <Gui/Font.hpp>

Include dependency graph for FontEntry.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FontEntry

Defines

#define | Apoxi_FontEntry_hpp

Define Documentation

#define Apoxi_FontEntry_hpp

Generated on Tue Jan 24 20:43:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontEntry.hpp Source File

Gui/FontEntry.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FontEntry_hpp)
00011 #define Apoxi_FontEntry_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014 #include <Gui/TextFormat.hpp>
00015 #include <Gui/Font.hpp>
00016
00021 class FontEntry : public Font{
00022     typedef Font Base;
00023
00024     public:
00025
00032         FontEntry(const FontData *data, const GlyphData *glyphs);
00033
00037         virtual ~FontEntry();
00038
00043         EntryId GetId() const { return m_data->id; };
00044
00049         virtual const WCHAR *GetName() const;
00050
00060         virtual void GetGlyph(WCHAR chr, TextAttr text_attr, GlyphPtr glyph) const;
00061
00066         virtual INT GetHeight() const;
00067
00072         virtual INT GetBaseline() const;
00073
00080         virtual INT GetGapToNextChar(WCHAR character = 0) const;
00081
00085         virtual BOOLEAN SupportsTextAttr(TextAttr text_attr) const;
00086
00091         const WCHAR *GetFontFamilyName() const;
00092
00101         BOOLEAN SupportsUnicodeRange(WCHAR from, WCHAR to) const;
00102
00107         UINT16 GetNumGlyphs() const;
00108
00116         BOOLEAN SupportsStyle(WCHAR chr, TextAttr text_attr) const;
00117
00118     protected:
00119         UINT8 *GetGlyphStartPos(WCHAR chr) const;
00120
00121     private:
00122
00124         const FontData *        m_data;
00125
00127         const GlyphData *       m_glyphs;
00128
00130         Glyph                   m_invalid_glyph;
00131 };
00132 #endif //Apoxi_FontEntry_hpp
00133
00134
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontManager.cpp File Reference

Gui/FontManager.cpp File Reference

#include "Gui/PreComp.hpp"
#include "FontManager.hpp"

Include dependency graph for FontManager.cpp:

Generated on Tue Jan 24 20:43:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontManager.hpp File Reference

Gui/FontManager.hpp File Reference

#include <Gui/FontPackConnector.hpp>
#include <Gui/AcacTypes.hpp>
#include <Gui/TextFormat.hpp>

Include dependency graph for FontManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FontManager

Defines

#define | Apoxi_FontManager_hpp

Define Documentation

#define Apoxi_FontManager_hpp

Generated on Tue Jan 24 20:43:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontManager.hpp Source File

Gui/FontManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FontManager_hpp)
00011 #define Apoxi_FontManager_hpp
00012
00013 #include <Gui/FontPackConnector.hpp>
00014 #include <Gui/AcacTypes.hpp>
00015 #include <Gui/TextFormat.hpp>
00016
00020 class FontManager {
00021     public:
00029         static BOOLEAN CanDisplay(WCHAR chr,
00030                                   INT index = m_active_font_index);
00031
00033         static UINT16 GetNumberOfFonts();
00034
00039         static UINT8 GetHeight(INT index = m_active_font_index);
00040
00045         static const FontEntry* GetFont(INT index);
00046
00051         static const FontEntry* GetFont(const WCHAR* name, UINT8 height);
00052
00057         static INT GetIndexOfFont(const WCHAR* name, UINT8 height);
00058
00063         static EntryId GetIdOfFont(const WCHAR *name, UINT8 height);
00064
00071         static BOOLEAN SetActiveFont(INT index);
00072
00075         static INT GetActiveFontIndex();
00076
00084         static BOOLEAN SupportsUnicodeRange(WCHAR from,
00085                                             WCHAR to,
00086                                             INT index = m_active_font_index);
00087
00098         static BOOLEAN GetGlyph(WCHAR chr, Glyph &glyph,
00099                                 TextAttr text_attr = TextFormat::Normal,
00100                                 INT font_index = m_active_font_index);
00101
00113         static BOOLEAN GetGlyphs(const WCHAR *chr,
00114                                 Glyph* glyphs,
00115                                 INT count,
00116                                 TextAttr text_attr = TextFormat::Normal,
00117                                 INT font_index = m_active_font_index);
00118
00125         static BOOLEAN SupportsStyle(WCHAR chr, TextAttr text_attr, INT index = m_active_font_index);
00126
00131         static const WCHAR* GetFontName(INT index = m_active_font_index);
00132
00137         static const WCHAR* GetFontFamilyName(INT index = m_active_font_index);
00138
00143         static UINT8 GetBaseline(INT index = m_active_font_index);
00144
00149         static INT GetNumGlyphs(INT index = m_active_font_index);
00150
00152         static UINT8 GetGapToNextChar(WCHAR chr = 0, INT index = m_active_font_index);
00153
00154         static void SetUseStaticFonts(BOOLEAN value);
00155
00156         static BOOLEAN UseStaticFonts();
00157
00158     private:
00159
00170         static BOOLEAN GetGlyphs(const WCHAR *chr,
00171                                 Glyph *glyphs,
00172                                 INT count,
00173                                 const FontEntry *font_entry,
00174                                 TextAttr text_attr = TextFormat::Normal);
00175
00176
00178         static INT m_active_font_index;
00179
00180         static BOOLEAN m_use_static_fonts;
00181 };
00182 #endif //Apoxi_FontManager_hpp
00183
00184
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontPack.cpp File Reference

Gui/FontPack.cpp File Reference

#include "Gui/PreComp.hpp"
#include "FontPack.hpp"

Include dependency graph for FontPack.cpp:

Generated on Tue Jan 24 20:43:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontPack.hpp File Reference

Gui/FontPack.hpp File Reference

#include <Gui/AcacTypes.hpp>
#include <Gui/FontEntry.hpp>
#include <Gui/DataPack.hpp>

Include dependency graph for FontPack.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FontPack

Defines

#define | Apoxi_FontPack_hpp

Define Documentation

#define Apoxi_FontPack_hpp

Generated on Tue Jan 24 20:43:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontPack.hpp Source File

Gui/FontPack.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FontPack_hpp)
00011 #define Apoxi_FontPack_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014 #include <Gui/FontEntry.hpp>
00015 #include <Gui/DataPack.hpp>
00016
00022 class FontPack : public DataPack {
00023     public:
00024         typedef DataPack Base;
00025
00032         FontPack(UINT8 *data);
00033
00037         virtual ~FontPack();
00038
00045         const FontEntry *GetFont(INT index) const;
00046
00051         const FontEntry **GetFonts() const;
00052
00053     private:
00054
00056         FontPackData *      m_font_pack_data;
00057
00059         FontEntry **        m_fonts;
00060
00061         friend class BasicPackConnector;
00062 };
00063 #endif //Apoxi_FontPack_hpp
00064
00065
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontPackConnector.cpp File Reference

Gui/FontPackConnector.cpp File Reference

#include "Gui/PreComp.hpp"
#include "FontPackConnector.hpp"

Include dependency graph for FontPackConnector.cpp:

Generated on Tue Jan 24 20:43:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontPackConnector.hpp File Reference

Gui/FontPackConnector.hpp File Reference

#include <Gui/AcacTypes.hpp>
#include <Gui/BasicPackConnector.hpp>
#include <Gui/FontEntry.hpp>
#include <Gui/FontPack.hpp>

Include dependency graph for FontPackConnector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FontPackConnector

Defines

#define | Apoxi_FontPackConnector_hpp

Define Documentation

#define Apoxi_FontPackConnector_hpp

Generated on Tue Jan 24 20:43:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FontPackConnector.hpp Source File

Gui/FontPackConnector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FontPackConnector_hpp)
00011 #define Apoxi_FontPackConnector_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014 #include <Gui/BasicPackConnector.hpp>
00015 #include <Gui/FontEntry.hpp>
00016 #include <Gui/FontPack.hpp>
00017
00022 class FontPackConnector {
00023     public:
00028         static void Init();
00029
00034         static BOOLEAN IsFontPackAvailable();
00035
00040         static INT GetNumberOfFonts();
00041
00047         static BOOLEAN GetFontNames(const WCHAR **font_names, INT size);
00048
00055         static BOOLEAN SetActiveFont(const INT index);
00056
00060         static INT GetActiveFontIndex();
00061
00068         static const FontEntry *GetFont(INT index);
00069
00074         static BOOLEAN ContainsFont(FontId id);
00075
00076     private:
00078         static INT                  m_active_font_index;
00079
00081         static FontEntry *          m_active_font;
00082
00084         static FontPack *           m_font_pack;
00085
00086 };
00087 #endif //Apoxi_FontPackConnector_hpp
00088
00089
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FrameDc.cpp File Reference

Gui/FrameDc.cpp File Reference

#include "Gui/PreComp.hpp"
#include "FrameDc.hpp"
#include "Control.hpp"
#include "Devices/Device.hpp"

Include dependency graph for FrameDc.cpp:

Generated on Tue Jan 24 20:43:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FrameDc.hpp File Reference

Gui/FrameDc.hpp File Reference

#include <Gui/ControlDc.hpp>

Include dependency graph for FrameDc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FrameDc
Device context used for drawing the frame of a control. More...

Defines

#define | Apoxi_FrameDc_hpp

Define Documentation

#define Apoxi_FrameDc_hpp

Generated on Tue Jan 24 20:43:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/FrameDc.hpp Source File

Gui/FrameDc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_FrameDc_hpp)
00010 #define Apoxi_FrameDc_hpp
00013
00014 #include <Gui/ControlDc.hpp>
00015
00016 class Control;
00017
00019 class FrameDc : public ControlDc {
00020     typedef ControlDc Base;
00021
00022     public:
00023         FrameDc();
00024         FrameDc(Control* control);
00026         virtual void AdjustBoundingRect();
00027
00028     protected:
00030         void Update(const Rect& abs_rect);
00031 };  // FrameDc
00032
00034 #endif  // Apoxi_FrameDc_hpp
00035
00036
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GlassPane.cpp File Reference

Gui/GlassPane.cpp File Reference

#include "Gui/PreComp.hpp"
#include "GlassPane.hpp"
#include "PaintDc.hpp"
#include "AbstractRenderer.hpp"
#include "WindowManager.hpp"
#include "Window.hpp"
#include <Kernel/MessageRouter.hpp>

Include dependency graph for GlassPane.cpp:

Generated on Tue Jan 24 20:43:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GlassPane.hpp File Reference

Gui/GlassPane.hpp File Reference

#include <Auxiliary/Vector.hpp>

Include dependency graph for GlassPane.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GlassPane
class | PaneObject

Defines

#define | Apoxi_GlassPane_hpp

Define Documentation

#define Apoxi_GlassPane_hpp

Generated on Tue Jan 24 20:43:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GlassPane.hpp Source File

Gui/GlassPane.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2003 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_GlassPane_hpp)
00010 #define Apoxi_GlassPane_hpp
00013
00014 #include <Auxiliary/Vector.hpp>
00015
00016 class AbstractRenderer;
00017 class DeviceContext;
00018
00024 class PaneObject {
00025     public:
00028         PaneObject();
00029
00033         PaneObject(const Rect& bounding_rect, AbstractRenderer* renderer = 0);
00034
00036         ~PaneObject();
00037
00041         void Init(const Rect& bounding_rect, AbstractRenderer* renderer = 0);
00042
00044         void SetPos(XYDIM x, XYDIM y);
00045
00047         Point GetPos() const;
00048
00050         void SetSize(XYDIM width, XYDIM height);
00051
00053         Size GetSize() const;
00054
00056         void SetBoundingRect(const Rect& bounding_rect);
00057
00059         const Rect& GetBoundingRect() const { return m_bounding_rect; }
00060
00064         virtual void Draw(DeviceContext* dc);
00065
00068         void Invalidate();
00069
00070     private:
00071         AbstractRenderer* m_renderer;
00072         Rect m_bounding_rect;
00073 };
00074
00079  class GlassPane {
00080     public:
00082         GlassPane();
00083
00085         virtual ~GlassPane();
00086
00088         void Add(PaneObject* pane_object);
00089
00091         void Remove(PaneObject* pane_object);
00092
00094         void RemoveAllPaneObjects();
00095
00097         BOOLEAN Contains(const PaneObject* pane_object) const;
00098
00101         virtual void Draw(DeviceContext* dc) const;
00102
00104         void SetEnabled(BOOLEAN enabled) { m_enabled = enabled; }
00105
00107         BOOLEAN IsEnabled() const { return m_enabled; }
00108
00109     private:
00110         mutable Vector<PaneObject*> m_pane_objects;
00111         BOOLEAN m_enabled;
00112 };
00113
00114
00116 #endif // Apoxi_GlassPane_hpp
00117
00118
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GridLayout.cpp File Reference

Gui/GridLayout.cpp File Reference

#include "Gui/PreComp.hpp"
#include "GridLayout.hpp"
#include "Layouter.hpp"
#include "DeviceContext.hpp"
#include "PaintDc.hpp"
#include "ClientDc.hpp"
#include "Window.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/LocaleConfig.hpp>
#include <Gui/TextLine.hpp>

Include dependency graph for GridLayout.cpp:

Generated on Tue Jan 24 20:43:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GridLayout.hpp File Reference

Gui/GridLayout.hpp File Reference

#include <Gui/Control.hpp>
#include <Gui/PositionIndicator.hpp>

Include dependency graph for GridLayout.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GridLayout
struct | GridLayout::Cell
struct | GridLayout::LayouterProperties

Defines

#define | Apoxi_GridLayout_hpp

Define Documentation

#define Apoxi_GridLayout_hpp

Generated on Tue Jan 24 20:43:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GridLayout.hpp Source File

Gui/GridLayout.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_GridLayout_hpp)
00010 #define Apoxi_GridLayout_hpp
00014
00015 class Component;
00016 #include <Gui/Control.hpp>
00017 #include <Gui/PositionIndicator.hpp>
00018
00025 class GridLayout : public Control {
00026     typedef Control Base;
00027
00028     public:
00029         enum {
00030             ID = 15
00031         };
00032
00034         enum XAlign {
00036             XDefault,
00038             Left,
00040             Center,
00042             Right
00043         };
00044
00046         enum YAlign {
00048             YDefault,
00050             Top,
00052             Middle,
00054             Bottom
00055         };
00056
00059         enum StretchUnit {
00060             //  Default: Remaining space is used
00061             Default,
00063             Percent,
00065             Pixel
00066         };
00067
00070         GridLayout();
00071
00080         GridLayout(Control* parent, INT row_count, INT col_count = 1, Size min_size = Size(-1, -1));
00081
00083         virtual ~GridLayout();
00084
00093         void Init(Control* parent, INT row_count, INT col_count = 1, Size min_size = Size(-1, -1));
00094
00097         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00098
00100         virtual BOOLEAN IsInstanceOf(INT id) const;
00101
00108         void SetCellProperties(INT row, INT col, Component* component, XAlign x_align = XDefault, YAlign y_align = YDefault);
00109
00114         void SetColumnProperty(INT col, StretchUnit stretch_unit, INT value = 0);
00115
00120         void SetRowProperty(INT row, StretchUnit stretch_unit, INT value = 0);
00121
00123         virtual Rect GetClientRect() const;
00124
00126         Size GetCellSize(INT row, INT column) const;
00127
00129         INT GetRowCount() const { return m_rows; }
00130
00132         INT GetColumnCount() const { return m_cols; }
00133
00134     protected:
00136         virtual void OnLayoutClient();
00137
00139         virtual void OnGetFocus();
00140
00142         virtual void OnFocusPreviousControl();
00143
00145         virtual void OnFocusNextControl();
00146
00148         virtual void OnThemeChanged();
00149
00151         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00152
00154         virtual BOOLEAN OnKeyAutoRepeat(KeyCode key_code);
00155
00156     private:
00157         struct Cell {
00158             Component* component;
00159             XAlign  x_align;
00160             YAlign  y_align;
00161         };
00162
00163         struct LayouterProperties {
00164             StretchUnit unit;
00165             INT value;
00166         };
00167
00168         struct {
00169             UINT initialized            : 1;
00170             UINT rows_initialized       : 1;
00171             UINT columns_initialized    : 1;
00172             UINT vert_pos_ind_needed    : 1;
00173             UINT horiz_pos_ind_needed   : 1;
00174         } m_bits;
00175
00176         Vector<Cell> m_cells;
00177         Vector<LayouterProperties> m_row_properties;
00178         Vector<LayouterProperties> m_col_properties;
00179
00180         INT m_cols;
00181         INT m_rows;
00182
00183         XYDIM m_x_pos;
00184         XYDIM m_y_pos;
00185
00186         Size m_min_size;
00187         PositionIndicator m_vert_pos_ind;
00188         PositionIndicator m_horiz_pos_ind;
00189
00190         KeyCode m_key_code;
00191
00192         WString GetStretchDescr(XYDIM pixels, INT sections, const Vector<LayouterProperties>& properties) const;
00193         void InitProperties(INT rows, INT cols);
00194         void AssureVisibleFocus();
00195         void UpdatePositionIndicators();
00196         BOOLEAN TreatKeyCode(KeyCode key_code);
00197         BOOLEAN FindCellPos(const Component& comp, INT& column, INT& row) const;
00198         void UpdateNavigationGuidance();
00199
00202         BOOLEAN IsCellFocusable(INT column, INT row) const;
00203
00207         BOOLEAN ShowBorder(INT column, INT row) const;
00208 };
00209
00210 #if defined(APOXI_COMPAT_2_4_0)
00211     #if !defined(LayouterControl)
00212         #define LayouterControl GridLayout
00213     #endif
00214 #endif
00215
00216 #endif  //Apoxi_GridLayout_hpp
00217
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiObjectDescr.cpp File Reference

Gui/GuiObjectDescr.cpp File Reference

#include "Gui/PreComp.hpp"
#include "GuiObjectDescr.hpp"

Include dependency graph for GuiObjectDescr.cpp:

Generated on Tue Jan 24 20:43:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiObjectDescr.hpp File Reference

Gui/GuiObjectDescr.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_GuiObjectDescr_hpp

Define Documentation

#define Apoxi_GuiObjectDescr_hpp

Generated on Tue Jan 24 20:43:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiObjectDescr.hpp Source File

Gui/GuiObjectDescr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_GuiObjectDescr_hpp)
00010 #define Apoxi_GuiObjectDescr_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Config/GuiObjectFactory.hpp>
00017
00022 class GuiObjectDescr {
00023     public:
00024
00025         GuiObjectDescr();
00026
00027         GuiObjectDescr(UINT16 id, GuiObjectFactory::ClassType classType, UINT32 binary_pos = 0, UINT32 binary_len = 0);
00028
00029         void SetId(UINT16 id);
00030         UINT16 GetId() const;
00031
00032         void SetClassType(GuiObjectFactory::ClassType class_type);
00033         GuiObjectFactory::ClassType GetClassType() const;
00034
00035         void SetBinaryPos(UINT32 pos);
00036         UINT32 GetBinaryPos() const;
00037
00038         void SetBinaryLen(UINT32 len);
00039         UINT32 GetBinaryLen() const;
00040
00041     private:
00043         UINT16 m_id;
00045         GuiObjectFactory::ClassType m_class_type;
00047         UINT32 m_binary_pos;
00049         UINT32 m_binary_len;
00050 };
00051
00053 #endif // DOXYGEN_SHOULD_SKIP_THIS
00054 #endif // Apoxi_GuiObjectDescr_hpp
00055
00056
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiObjectIterator.cpp File Reference

Gui/GuiObjectIterator.cpp File Reference

#include "Gui/PreComp.hpp"
#include "GuiObjectIterator.hpp"
#include "Control.hpp"

Include dependency graph for GuiObjectIterator.cpp:

Generated on Tue Jan 24 20:43:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiObjectIterator.hpp File Reference

Gui/GuiObjectIterator.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_GuiObjectIterator_hpp

Define Documentation

#define Apoxi_GuiObjectIterator_hpp

Generated on Tue Jan 24 20:43:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiObjectIterator.hpp Source File

Gui/GuiObjectIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_GuiObjectIterator_hpp)
00010 #define Apoxi_GuiObjectIterator_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/GuiObjectDescr.hpp>
00017 #include <Gui/ResourceParser.hpp>
00018 #include <Config/GuiObjectFactory.hpp>
00019
00025 class GuiObjectIterator {
00026     public:
00027
00028         GuiObjectIterator(ResourceParser& parser, BOOLEAN toplevel = FALSE);
00029
00030         ~GuiObjectIterator();
00031
00032         BOOLEAN HasNext();
00033
00034         GuiObjectDescr GetNext();
00035
00037         void Release();
00038
00039     private:
00040         ResourceParser* m_parser;
00041         BOOLEAN m_first;
00042         UINT16 m_obj_count;
00043         UINT32 m_obj_pos;
00044         UINT32 m_obj_len;
00045 };
00046
00048 #endif // DOXYGEN_SHOULD_SKIP_THIS
00049 #endif // Apoxi_GuiObjectIterator_hpp
00050
00051
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiPropertyIdIterator.cpp File Reference

Gui/GuiPropertyIdIterator.cpp File Reference

#include "Gui/PreComp.hpp"
#include "GuiPropertyIdIterator.hpp"
#include "Control.hpp"

Include dependency graph for GuiPropertyIdIterator.cpp:

Generated on Tue Jan 24 20:43:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiPropertyIdIterator.hpp File Reference

Gui/GuiPropertyIdIterator.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_GuiPropertyIdIterator_hpp

Define Documentation

#define Apoxi_GuiPropertyIdIterator_hpp

Generated on Tue Jan 24 20:43:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiPropertyIdIterator.hpp Source File

Gui/GuiPropertyIdIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_GuiPropertyIdIterator_hpp)
00010 #define Apoxi_GuiPropertyIdIterator_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/GuiObjectDescr.hpp>
00017 #include <Gui/ResourceParser.hpp>
00018 #include <Config/GuiObjectFactory.hpp>
00019
00025 class GuiPropertyIdIterator {
00026     public:
00027         GuiPropertyIdIterator(ResourceParser& parser,
00028                               INT object_id);
00029
00030         ~GuiPropertyIdIterator();
00031
00032         BOOLEAN HasNext();
00033
00034         GuiObjectFactory::PropertyId GetNext();
00035
00037         void Release();
00038
00039     private:
00040         ResourceParser* m_parser;
00041         BOOLEAN m_first;
00042         UINT16 m_prop_count;
00043         UINT32 m_prop_len;
00044         UINT32 m_prop_pos;
00045 };
00046
00048 #endif // DOXYGEN_SHOULD_SKIP_THIS
00049 #endif // Apoxi_GuiPropertyIdIterator_hpp
00050
00051
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiPropertyIterator.cpp File Reference

Gui/GuiPropertyIterator.cpp File Reference

#include "Gui/PreComp.hpp"
#include "GuiPropertyIterator.hpp"
#include "Control.hpp"

Include dependency graph for GuiPropertyIterator.cpp:

Generated on Tue Jan 24 20:43:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiPropertyIterator.hpp File Reference

Gui/GuiPropertyIterator.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_GuiPropertyIterator_hpp

Define Documentation

#define Apoxi_GuiPropertyIterator_hpp

Generated on Tue Jan 24 20:43:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiPropertyIterator.hpp Source File

Gui/GuiPropertyIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_GuiPropertyIterator_hpp)
00010 #define Apoxi_GuiPropertyIterator_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Gui/GuiObjectDescr.hpp>
00017 #include <Gui/ResourceParser.hpp>
00018 #include <Gui/GridLayout.hpp>
00019 #include <Gui/FlowLayout.hpp>
00020
00026 class GuiPropertyIterator {
00027
00028     public:
00029         struct CellProps {
00030             INT16 m_row;
00031             INT16 m_column;
00032             GridLayout::XAlign  m_x_align;
00033             GridLayout::YAlign  m_y_align;
00034             UINT16 m_component_id;
00035         };
00036
00037         struct ColumnAndRowProps {
00038             INT m_index;
00039             GridLayout::StretchUnit m_stretch_unit;
00040             INT m_value;
00041         };
00042
00043         struct AlignInfoProps {
00044             UINT16 m_component_id;
00045             FlowLayout::Alignment align;
00046         };
00047
00048         struct TabProps {
00049             UINT16 m_component_id;
00050             BOOLEAN m_enabled;
00051             WString m_text;
00052             String m_icon_uri;
00053         };
00054
00055         struct AmbiguousTextProps {
00056             WString m_text;
00057             UINT8 m_hint;
00058         };
00059
00060         GuiPropertyIterator(ResourceParser& parser,
00061                             INT object_id,
00062                             GuiObjectFactory::PropertyId prop_id);
00063
00064         ~GuiPropertyIterator();
00065
00066         BOOLEAN HasNext();
00067
00068         BOOLEAN GetNext(void* property);
00069
00071         void Release();
00072
00073     private:
00074         ResourceParser* m_parser;
00075         UINT32 m_prop_pos;
00076         UINT16 m_prop_count;
00077         GuiObjectFactory::PropertyId m_prop_id;
00078 };
00079
00081 #endif // DOXYGEN_SHOULD_SKIP_THIS
00082 #endif // Apoxi_GuiPropertyIterator_hpp
00083
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/GuiTemplates.cpp File Reference

Gui/GuiTemplates.cpp File Reference

#include "Gui/PreComp.hpp"
#include <Gui/DefaultCaret.hpp>
#include <Gui/MultiTabInputMapper.hpp>
#include <Gui/AnimatedTextLine.hpp>
#include <Gui/AbstractItemGrid.hpp>
#include <Gui/ImageBox.hpp>
#include <Gui/AbstractMultiLineEditor.hpp>
#include <Gui/GlassPane.hpp>
#include <Gui/GridLayout.hpp>
#include <Gui/IconSet.hpp>
#include <Gui/ItemTree.hpp>
#include <Gui/ResourceManager.hpp>
#include <Gui/ItemMenu.hpp>
#include <Gui/TabControl.hpp>
#include <Gui/WindowManager.hpp>
#include <Gui/FlowLayout.hpp>
#include <Gui/ItemBox.hpp>

Include dependency graph for GuiTemplates.cpp:

Generated on Tue Jan 24 20:43:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/HindiTextRenderer.cpp File Reference

Gui/HindiTextRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "HindiTextRenderer.hpp"

Include dependency graph for HindiTextRenderer.cpp:

Generated on Tue Jan 24 20:43:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/HindiTextRenderer.hpp File Reference

Gui/HindiTextRenderer.hpp File Reference

#include <Gui/AbstractTextRenderer.hpp>

Include dependency graph for HindiTextRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HindiTextRenderer

Defines

#define | Apoxi_HindiTextRenderer_hpp

Define Documentation

#define Apoxi_HindiTextRenderer_hpp

Generated on Tue Jan 24 20:43:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/HindiTextRenderer.hpp Source File

Gui/HindiTextRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_HindiTextRenderer_hpp)
00010 #define Apoxi_HindiTextRenderer_hpp
00013
00014 #include <Gui/AbstractTextRenderer.hpp>
00015
00018 class HindiTextRenderer : public AbstractTextRenderer {
00019     typedef AbstractTextRenderer Base;
00020
00021     public:
00022         virtual ~HindiTextRenderer();
00023
00024         static HindiTextRenderer& GetInstance() { return m_instance; }
00025
00026     protected:
00027         HindiTextRenderer();
00028
00029         virtual Size GetGlyph(const WCHAR* cur_text_pos,
00030                               const WCHAR* substitution_char,
00031                               INT n_chars,
00032                               GlyphPtr glyph,
00033                               INT& parsed_glyphs,
00034                               BOOLEAN& is_diacritic);
00035
00036     private:
00037         static HindiTextRenderer m_instance;
00038 };
00039
00040
00042 #endif // Apoxi_HindiTextRenderer_hpp
00043
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IconSet.cpp File Reference

Gui/IconSet.cpp File Reference

#include "Gui/PreComp.hpp"
#include "IconSet.hpp"
#include "IconState.hpp"
#include "NativeImage.hpp"
#include <Config/GuiEngineConfig.hpp>

Include dependency graph for IconSet.cpp:

Generated on Tue Jan 24 20:43:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IconSet.hpp File Reference

Gui/IconSet.hpp File Reference

#include <Gui/IconState.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for IconSet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IconSet
struct | IconSet::IconElem

Defines

#define | Apoxi_IconSet_hpp

Define Documentation

#define Apoxi_IconSet_hpp

Generated on Tue Jan 24 20:43:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IconSet.hpp Source File

Gui/IconSet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_IconSet_hpp)
00010 #define Apoxi_IconSet_hpp
00013
00014 #include <Gui/IconState.hpp>
00015 #include <Gui/ImageObtainer.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017
00030 class IconSet {
00031     public:
00034         IconSet();
00035
00039         IconSet(const ImageObtainer& default_icon);
00040
00041         ~IconSet(); // non-virtual
00042
00045         void SetDefaultIcon(const ImageObtainer& icon) { m_default_icon = icon; }
00046
00049         const ImageObtainer& GetDefaultIcon() const { return m_default_icon; }
00050
00055         BOOLEAN AddIcon(const IconState& state, const ImageObtainer& icon);
00056
00058         const ImageObtainer& GetIcon(const IconState& state) const;
00059
00062         const ImageObtainer& GetIcon(INT index) const;
00063
00065         INT GetIconCount() const;
00066
00068         void RemoveAllIcons();
00069
00088         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00089
00090         IconSet& operator=(const IconSet& icon_set);
00091
00092 #ifdef APOXI_COMPAT_2_1_0
00093
00094         explicit IconSet(INT id);
00095
00097         INT GetId() const { return 0; }
00098 #endif
00099
00100     private:
00101         struct IconElem {
00102             IconState state;
00103             ImageObtainer icon;
00104         };
00105
00106         ImageObtainer m_default_icon;
00107         Vector<IconElem>* m_icon_vec;
00108
00109         BOOLEAN HasIconForState(const IconState& state) const;
00110
00115         BOOLEAN ConvertToImage(ImageObtainer& icon);
00116 };
00117
00119 #endif // Apoxi_IconSet_hpp
00120
00121
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IconState.cpp File Reference

Gui/IconState.cpp File Reference

#include "Gui/PreComp.hpp"
#include "IconState.hpp"

Include dependency graph for IconState.cpp:

Generated on Tue Jan 24 20:43:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IconState.hpp File Reference

Gui/IconState.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IconState

Defines

#define | Apoxi_IconState_hpp

Define Documentation

#define Apoxi_IconState_hpp

Generated on Tue Jan 24 20:43:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IconState.hpp Source File

Gui/IconState.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_IconState_hpp)
00010 #define Apoxi_IconState_hpp
00013
00014
00021 class IconState {
00022     public:
00024         enum Size {
00026             DefaultSize = 1,
00028             SmallSize = 2,
00030             LargeSize = 4
00031         };
00032
00034         enum Mode {
00036             NormalMode = 8,
00038             DisabledMode = 16,
00040             ActiveMode = 32
00041         };
00042
00045         IconState(Size size = DefaultSize, Mode mode = NormalMode);
00046
00048         void SetSize(Size size);
00049
00051         Size GetSize() const;
00052
00054         void SetMode(Mode mode);
00055
00057         Mode GetMode() const;
00058
00060         BOOLEAN operator==(const IconState& state) const { return m_state == state.m_state; }
00061
00063         BOOLEAN operator!=(const IconState& state) const { return m_state != state.m_state; }
00064
00065     private:
00066         UINT8 m_state;
00067 };
00068
00070 #endif // Apoxi_IconState_hpp
00071
00072
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Image.cpp File Reference

Gui/Image.cpp File Reference

#include "Gui/PreComp.hpp"
#include "PaintDc.hpp"
#include "Image.hpp"
#include "DecodingThreadlet.hpp"
#include "NativeImage.hpp"
#include "BitmapDc.hpp"
#include "MsgTypes.hpp"
#include <Devices/Display.hpp>
#include <Config/OptionalConfig.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/Application.hpp>

Include dependency graph for Image.cpp:

Generated on Tue Jan 24 20:43:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Image.hpp File Reference

Gui/Image.hpp File Reference

#include <Gui/Rect.hpp>
#include <Gui/Color.hpp>
#include <Auxiliary/ObjectObtainer.hpp>
#include <Kernel/Condition.hpp>

Include dependency graph for Image.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Image
class | Image::CleanupDrawingObtainer
class | Image::MetaData
class | ImageIncrementalPdcUpdater
class | IncrementalPdcUpdater

Defines

#define | Apoxi_Image_hpp
#define | GET_16BPP_COLOR_VALUE(red, green, blue) ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)))

Define Documentation

#define Apoxi_Image_hpp

Generated on Tue Jan 24 20:44:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Image.hpp Source File

Gui/Image.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Image_hpp)
00011 #define Apoxi_Image_hpp
00014
00015 #include <Gui/Rect.hpp>
00016 #include <Gui/Color.hpp>
00017 #include <Auxiliary/ObjectObtainer.hpp>
00018 #include <Kernel/Condition.hpp>
00019
00020 class BinData;
00021 class NativeImage;
00022 class PaintDc;
00023 class Display;
00024 class DeviceContext;
00025 class Bitmap;
00026
00027 #define GET_16BPP_COLOR_VALUE(red, green, blue) ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)))
00028
00039 class IncrementalPdcUpdater {
00040     public:
00045         IncrementalPdcUpdater(const void* client, PaintDc& pdc, INT max_delay = 500);
00046
00049         virtual ~IncrementalPdcUpdater();
00050
00056         void Init();
00057
00064         BOOLEAN TimeExpired() const;
00065
00079         BOOLEAN Update(INT total_steps, INT completed_steps);
00080
00093         void Finish() const;
00094
00096         BOOLEAN UpdatesMainDisplay() const;
00097
00098     protected:
00099         const void* m_client;
00100         INT m_max_delay;
00101
00105         virtual void SendProgressMsg(INT total_steps,
00106                                      INT completed_steps) const = 0;
00107
00111         virtual void SendInterruptedMsg() const = 0;
00112
00118         static INT CalcProgress(INT total_steps, INT completed_steps);
00119
00120     private:
00121         mutable Ticks m_ticks;
00122         Display *m_main_display;
00123         BOOLEAN m_to_main_display;
00124         BOOLEAN m_updated_main_display;
00125         mutable BOOLEAN m_finished;
00126 };
00127
00129 class ImageIncrementalPdcUpdater : public IncrementalPdcUpdater {
00130 public:
00135     ImageIncrementalPdcUpdater(const void *client, PaintDc &pdc, INT max_delay = 500);
00136     virtual ~ImageIncrementalPdcUpdater();
00137
00139     virtual void SendProgressMsg(INT total_steps, INT completed_steps) const;
00141     virtual void SendInterruptedMsg() const;
00142 };
00143
00182 class Image : public ObtainableObject {
00183     typedef ObtainableObject Base;
00184
00185     public:
00186         enum {
00187             ID = 43
00188         };
00189
00201         enum ErrorCode {
00203             NoError                         = 0,
00205             UnspecifiedError                = 1,
00207             InvalidSizeError                = 2,
00209             InitializationError             = 3,
00211             ScanlineBufferError             = 4,
00213             MissingDataError                = 5,
00215             IsCurrentlyDecodedError         = 6,
00217             CouldNotAllocateThreadletError  = 7,
00219             ThreadletStoppedError           = 8,
00221             OutOfMemoryError                = 9,
00223             DecodingInterruptedError        = 10
00224
00225         };
00226
00228         enum ValidationResult {
00230             Valid,
00233             Invalid,
00237             InProgress
00238         };
00239
00242         class MetaData {
00243             public:
00247                 enum ColorSpace {
00249                     Rgb565ColorSpace,
00251                     Rgb888ColorSpace,
00253                     Rgba8888ColorSpace,
00254                     Yuv420ColorSpace,
00255                     Yuv422ColorSpace
00256                     #if defined(APOXI_COMPAT_2_8_0)
00257
00258                         , RgbColorSpace,
00260                         YuvColorSpace
00261                     #endif // APOXI_COMPAT_2_8_0
00262                 };
00263
00264                 MetaData();
00265                 ~MetaData();    // not virtual
00266                 void SetWidth(XYDIM width) { m_width = width; }
00267                 XYDIM GetWidth() const  { return m_width; }
00268                 void SetHeight(XYDIM height) { m_height = height; }
00269                 XYDIM GetHeight() const { return m_height; }
00270                 void SetBitsPerPixel(INT8 bpp) { m_bpp = bpp; }
00271                 INT8 GetBitsPerPixel() const { return m_bpp; }
00272                 void SetFrameCount(INT frame_count) { m_frame_count = frame_count; }
00273                 INT GetFrameCount() const { return m_frame_count; }
00274                 void SetRepeatCount(INT repeat_count) { m_repeat_count = repeat_count; }
00275                 INT GetRepeatCount() const { return m_repeat_count; }
00276                 void SetColorSpace(ColorSpace color_space) { m_color_space = (INT8)color_space; }
00277                 ColorSpace GetColorSpace() const { return (ColorSpace)m_color_space; }
00278
00279             private:
00280                 XYDIM m_width;
00281                 XYDIM m_height;
00282                 INT8 m_bpp;
00283                 INT8 m_color_space;
00284                 INT m_frame_count;
00285                 INT m_repeat_count;
00286         };
00287
00288         typedef Bitmap* BitmapPtr;  // this typedef should be private, but the ARM-compiler does not accept this
00289
00290         Image();
00291
00292         virtual ~Image();
00293
00315         virtual BOOLEAN IsInstanceOf(INT id) const;
00316
00334         BOOLEAN ConvertToBitmap(Bitmap* bitmap, INT frame_idx = 0, BOOLEAN block = TRUE);
00335
00354         ValidationResult Validate(INT frame_idx = 0, BOOLEAN block = TRUE);
00355
00370         virtual BOOLEAN Draw(DeviceContext* dc,
00371                              XYDIM x,
00372                              XYDIM y,
00373                              INT frame_idx,
00374                              XYDIM scaled_width = -1,
00375                              XYDIM scaled_height = -1,
00376                              const Rect& clip_rect = Rect()) const;
00377
00379         void Draw(DeviceContext* dc, XYDIM x, XYDIM y) const;
00380
00382         virtual INT GetNextFrame(INT frame_idx) const = 0;
00383
00387         virtual UINT32 GetFrameDelay(INT frame_idx) const = 0;
00388
00391         const MetaData& GetMetaData() const { return m_meta_data; }
00392
00394         virtual const BinData* GetBinData() const;
00395
00400         INT GetRepeatCount() const { return m_meta_data.GetRepeatCount(); }
00401
00404         virtual BOOLEAN IsCopyrighted() const;
00405
00408         INT GetFrameCount() const { return m_meta_data.GetFrameCount(); }
00409
00411         XYDIM GetWidth() const { return m_meta_data.GetWidth(); }
00412
00414         XYDIM GetHeight() const { return m_meta_data.GetHeight(); }
00415
00418         XYDIM GetScaledWidth(XYDIM scaled_height) const;
00419
00422         XYDIM GetScaledHeight(XYDIM scaled_width) const;
00423
00430         INT8 GetBitsPerPixel() const { return m_meta_data.GetBitsPerPixel(); }
00431
00438         void SetErrorCode(UINT8 error_code) const;
00439
00446         UINT8 GetErrorCode() const { return (UINT8)m_bits.error_code; }
00447
00451         BOOLEAN IsCurrentlyDecoded() const { return (BOOLEAN)m_bits.is_currently_decoded; }
00452
00455         void StopDecoding() const;
00456
00460         void WaitUntilDecodingIsFinished() const { StopDecoding(); }
00461
00465         virtual BOOLEAN DecodeSynchronously() const;
00466
00470         virtual BOOLEAN IsBufferingAllowed() const;
00471
00477         void SetBackgroundImage(Bitmap* background, INT frame_idx = 0);
00478
00486         void ObtainBackgroundImages() { m_bits.obtain_bgr_images = TRUE; }
00487
00491         virtual void DrawCorruptImageSign(DeviceContext* dc,
00492                                           XYDIM x,
00493                                           XYDIM y,
00494                                           XYDIM scaled_width,
00495                                           XYDIM scaled_height) const;
00496
00498         void SetProgressMsgEnabled(BOOLEAN progress) {m_bits.send_progress = progress;}
00499
00501         BOOLEAN IsProgressMsgEnabled() const {return (BOOLEAN)m_bits.send_progress;}
00502
00505         Bitmap* GetImageBuffer(INT frame_idx) const;
00506
00507 #if defined(APOXI_COMPAT_2_0_0)
00508
00509         INT GetId() const;
00510 #endif
00511
00512         static const UINT32 c_unlimited;
00513
00514     protected:
00518         class CleanupDrawingObtainer {
00519             public:
00521                 CleanupDrawingObtainer(const Image& image);
00523                 ~CleanupDrawingObtainer();
00525                 BOOLEAN CheckForInterrupt() const;
00526             private:
00527                 const Image& m_image;
00528         };
00529
00543         virtual void* BeginScanlineDrawing(INT frame_idx = 0) const;
00544
00552         virtual void EndScanlineDrawing(void* context) const;
00553
00572         virtual void DrawScanline(void* context,
00573                                   DeviceContext* dc,
00574                                   XYDIM x,
00575                                   XYDIM y,
00576                                   INT scanline_idx,
00577                                   INT old_scanline_idx) const;
00578
00588         virtual XYDIM GetScanlineDiff(void* context,
00589                                       INT scanline_idx,
00590                                       INT old_scanline_idx) const;
00591
00597         virtual BOOLEAN IsTransparent(void* context) const;
00598
00603         virtual BOOLEAN HasAlphaChannel(void* context) const;
00604
00610         virtual ColorValue GetTransparentColor(void* context) const;
00611
00621         virtual BOOLEAN IsFullTraversingEnabled(void* context) const;
00622
00627         virtual XYDIM GetFrameXPos(void* context) const;
00628
00632         virtual XYDIM GetFrameWidth(void* context) const;
00633
00637         virtual XYDIM GetFrameHeight(void* context) const;
00638
00641         void SetMetaData(const MetaData& meta_data);
00642
00644         void SetMetaData(XYDIM width, XYDIM heigth, INT8 bpp, INT frame_count, INT repeat_count);
00645
00647         void SetWidth(XYDIM width) { m_meta_data.SetWidth(width); }
00648
00650         void SetHeight(XYDIM height) { m_meta_data.SetHeight(height); }
00651
00653         void SetFrameCount(INT frame_count);
00654
00656         void SetBitsPerPixel(INT8 bpp) { m_meta_data.SetBitsPerPixel(bpp); }
00657
00659         void SetRepeatCount(INT repeat_count) { m_meta_data.SetRepeatCount(repeat_count); }
00660
00666         void AdjustSize(XYDIM& width, XYDIM& height) const;
00667
00670         BOOLEAN CheckForInterrupt() const;
00671
00675         void SetPreviousFrameBuffering(BOOLEAN previous) const {m_bits.previous_frame = previous;}
00676
00678         BOOLEAN IsPreviousFrameBuffering() const {return m_bits.previous_frame;}
00679
00680     private:
00681         MetaData m_meta_data;
00682
00683         mutable struct {
00684             UINT previous_frame         : 1;    // should previous frame used as basis for current image
00685             UINT is_currently_decoded   : 1;    // TRUE if a threadlet decodes the image
00686             UINT stop_decoding          : 1;    // TRUE if the threadlet should stop the decoding
00687             UINT send_progress          : 1;    // when TRUE, progress messages will be sent. default is TRUE
00688             UINT error_code             : 8;
00689             UINT obtain_bgr_images      : 1;
00690         } m_bits;
00691
00692         mutable INT m_threadlet_count;
00693         mutable BitmapPtr* m_bmp_buffer;
00694
00695         friend class CleanupDrawingObtainer;        // accesses to m_bits.is_currently_decoded and m_bits.stop_decoding
00696 };
00697
00698
00699
00701 #endif // Apoxi_Image_hpp
00702
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageBox.cpp File Reference

Gui/ImageBox.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ImageBox.hpp"
#include "PaintDc.hpp"
#include "DeviceContext.hpp"
#include "BitmapDc.hpp"
#include "Image.hpp"
#include "Window.hpp"
#include "NativeImage.hpp"
#include "Control.hpp"
#include <Config/GuiEngineConfig.hpp>
#include <Kernel/Application.hpp>
#include <Devices/Display.hpp>

Include dependency graph for ImageBox.cpp:

Generated on Tue Jan 24 20:44:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageBox.hpp File Reference

Gui/ImageBox.hpp File Reference

#include <Gui/DrawableObject.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Gui/DeviceContext.hpp>
#include <Auxiliary/TriggerTimer.hpp>

Include dependency graph for ImageBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageBox
class | ImageBoxView

Defines

#define | Apoxi_ImageBox_hpp

Define Documentation

#define Apoxi_ImageBox_hpp

Generated on Tue Jan 24 20:44:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageBox.hpp Source File

Gui/ImageBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ImageBox_hpp)
00010 #define Apoxi_ImageBox_hpp
00014
00015 #include <Gui/DrawableObject.hpp>
00016 #include <Gui/ImageObtainer.hpp>
00017 #include <Gui/DeviceContext.hpp>
00018 #include <Auxiliary/TriggerTimer.hpp>
00019
00020 class Bitmap;
00021
00026 class ImageBox : public DrawableObject {
00027     typedef DrawableObject Base;
00028
00029     public:
00030         enum {
00031             ID = 11
00032         };
00033
00034         typedef Bitmap* BitmapPtr;  // this typedef should be private, but the ARM-compiler does not accept this
00035
00038         ImageBox();
00039
00044         ImageBox(Control* control, const BitmapRes* bitmap = 0);
00045
00078         ImageBox(Control* control,
00079                  const ImageObtainer& obtainer,
00080                  XYDIM width = -1,
00081                  XYDIM height = -1,
00082                  BOOLEAN autostart = TRUE,
00083                  BOOLEAN buffering = TRUE,
00084                  BOOLEAN cleanup_buffer = FALSE);
00085
00086         virtual ~ImageBox();
00087
00094         void Init(Control* control, const BitmapRes* bitmap = 0, XYDIM width = -1, XYDIM height = -1);
00095
00128         void Init(Control* control,
00129                   const ImageObtainer& obtainer,
00130                   XYDIM width = -1,
00131                   XYDIM height = -1,
00132                   BOOLEAN autostart = TRUE,
00133                   BOOLEAN buffering = TRUE,
00134                   BOOLEAN cleanup_buffer = FALSE);
00135
00138         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00139
00141         virtual BOOLEAN IsInstanceOf(INT id) const;
00142
00150         void SetBitmap(const BitmapRes* bitmap, XYDIM width = -1, XYDIM height = -1);
00151
00180         void SetImageObtainer(const ImageObtainer& obtainer,
00181                               XYDIM width = -1,
00182                               XYDIM height = -1,
00183                               BOOLEAN buffering = TRUE);
00184
00186         ImageObtainer& GetImageObtainer() { return m_obtainer; }
00187
00189         const ImageObtainer& GetImageObtainer() const { return m_obtainer; }
00190
00192         virtual XYDIM GetDefaultWidth() const;
00193
00195         virtual XYDIM GetDefaultHeight() const;
00196
00198         INT GetFrame() const { return m_frame; }
00199
00208         void Start(BOOLEAN play_only_once = FALSE);
00209
00211         void Restart();
00212
00214         void Stop();
00215
00220         Bitmap* GetImageBuffer(INT frame_idx) const;
00221
00231         static BOOLEAN IsBufferAvailable(XYDIM scaled_width, XYDIM scaled_height, INT frame_count);
00232
00234         void SetBufferingEnabled(BOOLEAN buffering) { m_bits.buffering_enabled = buffering; }
00235
00238         BOOLEAN IsBufferingEnabled() const {return m_bits.buffering_enabled;}
00239
00243         BOOLEAN IsDecodingFinished() const { return (BOOLEAN)m_bits.finished_decoding;}
00244
00248         BOOLEAN IsDecoding() const {return (BOOLEAN)m_bits.is_decoding;}
00249
00254         BOOLEAN IsPlayOnceEnabled() const { return (BOOLEAN)m_bits.play_only_once; }
00255
00259         BOOLEAN IsPreviewShown() const { return (BOOLEAN)m_bits.show_preview; }
00260
00264         BOOLEAN SetTransformation(DeviceContext::TransformationMode transformation);
00265
00267         DeviceContext::TransformationMode GetTransformation() const { return m_transformation; }
00268
00270         const BitmapRes* GetBitmap() const { return 0; }
00271
00272     protected:
00274         virtual void Refresh(const Rect& rect);
00275
00277         virtual void Cleanup();
00278
00280         virtual BOOLEAN OnMessage(const Message& msg);
00281
00283         virtual void OnMove(XYDIM dx, XYDIM dy);
00284
00286         virtual void OnResize(XYDIM dx, XYDIM dy);
00287
00288     private:
00289         enum State {
00290             Stopped     = 0,
00291             AutoStart   = 1,
00292             Running     = 2,
00293             Finished    = 3
00294         };
00295
00296         struct {
00297             UINT buffering_enabled      : 1;
00298             UINT buffer_available       : 1;
00299             UINT finished_decoding      : 1;
00300             UINT is_decoding            : 1;
00301             UINT bounds_set_by_props    : 1;
00302             UINT cleanup_buffer         : 1;
00303             UINT play_only_once         : 1;
00304             UINT state                  : 2;
00305             UINT registered_dec_msg     : 1;
00306             UINT show_preview           : 1;
00307             UINT rotated                : 1;
00308             UINT currently_rotating     : 1;
00309         } m_bits;
00310
00311         Bitmap** m_bmp_buffer;
00312
00313         INT m_frame;
00314         INT m_frame_count;
00315
00316         UINT8 m_overall_progress;
00317         UINT8 m_decoded_frame;
00318         UINT8 m_repeat_idx;
00319         DeviceContext::TransformationMode m_transformation;
00320
00321         ImageObtainer m_obtainer;
00322         TriggerTimer<ImageBox> m_anim_timer;
00323
00324         static BOOLEAN m_initialized;
00325         static UINT32 m_alloc_buf_count;
00326         static Semaphore m_sem;
00327
00328         void AdjustSize(XYDIM& width, XYDIM& height);
00329         void StopDecoding();
00330         void StartDecoding();
00331         BOOLEAN IsFullBufferingAvailable() const { return (BOOLEAN)m_bits.buffer_available; }
00332         void InitProperties();
00333         void OnTimer();
00334         State GetState() const { return (State)m_bits.state; }
00335         BOOLEAN ObtainBuffer(XYDIM width, XYDIM height);
00336         void ReleaseBuffer(INT frame_idx, BOOLEAN is_decoding);
00337         void ReleaseAllBuffers();
00338         void PrepareImageBuffers();
00339         BOOLEAN CreateNextBufferedFrame();
00340         BOOLEAN IsVisible() const;
00341
00345         void CleanupBuffer();
00346
00350         void GetInternalSize(XYDIM& width, XYDIM& height);
00351
00352         friend class TriggerTimer<ImageBox>;
00353         friend class ImageBoxView;
00354 };
00355
00356 class ImageBoxView : public DrawableObjectView {
00357     typedef DrawableObjectView Base;
00358
00359     public:
00361         virtual ~ImageBoxView();
00362
00363     private:
00364         virtual void Draw(const Component& component,
00365                           DeviceContext* dc,
00366                           const Rect& repaint_rect) const;
00367
00368         void StartAnimTimer(ImageBox& image_box, const Ticks& ticks) const;
00369 };
00370
00372 #endif  // Apoxi_ImageBox_hpp
00373
00374
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageDecoder.cpp File Reference

Gui/ImageDecoder.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ImageDecoder.hpp"

Include dependency graph for ImageDecoder.cpp:

Generated on Tue Jan 24 20:44:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageDecoder.hpp File Reference

Gui/ImageDecoder.hpp File Reference

#include <Gui/Image.hpp>

Include dependency graph for ImageDecoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageDecoder

Defines

#define | Apoxi_ImageDecoder_hpp

Define Documentation

#define Apoxi_ImageDecoder_hpp

Generated on Tue Jan 24 20:44:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageDecoder.hpp Source File

Gui/ImageDecoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageDecoder_hpp)
00011 #define Apoxi_ImageDecoder_hpp
00014
00015 #include <Gui/Image.hpp>
00016
00019 class ImageDecoder {
00020     public:
00032         ImageDecoder(BOOLEAN shared = TRUE, const Ticks& timeout = Ticks(200));
00033
00034         virtual ~ImageDecoder();
00035
00040         virtual BOOLEAN GetMetaData(Image& image, Image::MetaData* meta_data) = 0;
00041
00050         virtual BOOLEAN BeginDecoding(const Image& image, INT frame_idx = 0);
00051
00057         virtual void EndDecoding(const Image& image, INT frame_idx = 0);
00058
00059     private:
00060         BOOLEAN m_shared;
00061         Ticks m_timeout;
00062         Semaphore m_sem;
00063 };
00064
00065
00067 #endif // Apoxi_ImageDecoder_hpp
00068
00069
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageEncoder.cpp File Reference

Gui/ImageEncoder.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ImageEncoder.hpp"
#include <Kernel/Threadlet.hpp>

Include dependency graph for ImageEncoder.cpp:

Generated on Tue Jan 24 20:44:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageEncoder.hpp File Reference

Gui/ImageEncoder.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <Auxiliary/DataSink.hpp>
#include <Gui/Image.hpp>

Include dependency graph for ImageEncoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageEncoder
class | ImageEncoder::EncodingParameters

Defines

#define | Apoxi_ImageEncoder_hpp

Define Documentation

#define Apoxi_ImageEncoder_hpp

Generated on Tue Jan 24 20:44:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageEncoder.hpp Source File

Gui/ImageEncoder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageEncoder_hpp)
00011 #define Apoxi_ImageEncoder_hpp
00012
00013 #include <Auxiliary/BinData.hpp>
00014 #include <Auxiliary/DataSink.hpp>
00015 #include <Gui/Image.hpp>
00016
00019
00022 class ImageEncoder {
00023     public:
00026         class EncodingParameters {
00027             public:
00028                 EncodingParameters(XYDIM width, XYDIM height) : m_width(width), m_height(height) {};
00029                 void SetWidth(XYDIM width) { m_width = width; }
00030                 XYDIM GetWidth() const { return m_width; }
00031                 void SetHeight(XYDIM height) { m_height = height; }
00032                 XYDIM GetHeight() const { return m_height; }
00033
00034             private:
00035                 XYDIM m_width;
00036                 XYDIM m_height;
00037         };
00038
00040         enum Error {
00042             NoError,
00044             EncoderInitError,
00046             FormatNotSupportedError,
00048             OutOfMemoryError,
00050             EncodingError,
00053             DataSinkClosedError,
00055             CouldNotAllocateThreadletError
00056         };
00057
00058         typedef void (*Cb_ImageEncoded)(INT result, void* context, DataSink &dest);
00059
00060         ImageEncoder();
00061
00062         virtual ~ImageEncoder();
00063
00091         virtual BOOLEAN Encode(BinData& src,
00092                                const Image::MetaData& src_params,
00093                                DataSink& dest,
00094                                BOOLEAN block = TRUE,
00095                                void* context = 0,
00096                                Cb_ImageEncoded callback = 0) = 0;
00097
00114         virtual BOOLEAN Encode(const Image& src, DataSink& dest, BOOLEAN block = TRUE) = 0;
00115
00119         const EncodingParameters* GetEncodingParams() const { return m_params; }
00120
00122         Error GetLastError() const { return m_last_error; }
00123
00126         BOOLEAN IsEncoding() const { return m_is_encoding; }
00127
00129         void StopEncoding(BOOLEAN block = TRUE);
00130
00131     protected:
00134         virtual BOOLEAN BeginEncoding(DataSink& dest);
00135
00137         virtual BOOLEAN EndEncoding(DataSink& dest);
00138
00140         void SetEncodingParams(const EncodingParameters* params) { m_params = params; }
00141
00143         void SetLastError(Error error) { m_last_error = error; }
00144
00149         BOOLEAN IsStopEncodingRequested() const { return m_stop_encoding; }
00150
00166         virtual BOOLEAN EncodeSynchronously(BinData& src,
00167                                             const Image::MetaData& src_params,
00168                                             DataSink& dest);
00169
00186         virtual BOOLEAN EncodeSynchronously(const Image& img, DataSink& dest);
00187
00193         BOOLEAN ExecuteThreadlet(Threadlet* threadlet, BOOLEAN block);
00194
00195     private:
00196         BOOLEAN m_is_encoding;          // TRUE if a threadlet encodes an image
00197         BOOLEAN m_stop_encoding;        // TRUE if the threadlet should stop the decoding
00198         const EncodingParameters* m_params;
00199         Error m_last_error;
00200
00201         static BOOLEAN m_initialized;
00202         static Semaphore m_sem;
00203
00204         BOOLEAN InitSemaphore();
00205
00206         friend class EncodingThreadlet; // accesses members m_is_encoding and m_stop_encoding
00207 };
00208
00209
00211 #endif // Apoxi_ImageEncoder_hpp
00212
00213
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageFactory.hpp File Reference

Gui/ImageFactory.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 16:42:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageFactory.hpp Source File

Gui/ImageFactory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class ImageFactory has been moved to AddOns/MultiMedia.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than APOXI 2.1 */
00013
00014 #ifdef APOXI_COMPAT_2_0_0
00015     #include <AddOns/MultiMedia/ImageFactory.hpp>
00016 #endif
00017
00018
Generated on Tue Jan 24 14:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageObtainer.cpp File Reference

Gui/ImageObtainer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ImageObtainer.hpp"
#include "Bitmap.hpp"
#include "Image.hpp"

Include dependency graph for ImageObtainer.cpp:

Generated on Tue Jan 24 20:44:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageObtainer.hpp File Reference

Gui/ImageObtainer.hpp File Reference

#include <Auxiliary/ObjectObtainer.hpp>
#include <Config/GuiObjectFactory.hpp>

Include dependency graph for ImageObtainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageObtainer

Defines

#define | Apoxi_ImageObtainer_hpp

Define Documentation

#define Apoxi_ImageObtainer_hpp

Generated on Tue Jan 24 20:44:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ImageObtainer.hpp Source File

Gui/ImageObtainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageObtainer_hpp)
00011 #define Apoxi_ImageObtainer_hpp
00014
00015 #include <Auxiliary/ObjectObtainer.hpp>
00016 #include <Config/GuiObjectFactory.hpp>
00017
00018 class Image;
00019 class ResourceParser;
00020 struct BitmapRes;
00021 class Bitmap;
00022
00051 class ImageObtainer : public ObjectObtainer {
00052     typedef ObjectObtainer Base;
00053
00054     public:
00057         ImageObtainer();
00058
00063         ImageObtainer(Image* image, BOOLEAN disposeable = FALSE);
00064
00078         ImageObtainer(const BitmapRes& bitmap);
00079
00090         ImageObtainer(const Bitmap& bitmap);
00091
00092         // needed because of a bug in the tasking-compiler
00093         ImageObtainer(const ImageObtainer& img_obt);
00094
00095         virtual ~ImageObtainer();
00096
00099         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00100
00102         Image* GetImage();
00103
00105         const Image* GetImage() const;
00106
00111         const BitmapRes* GetBitmap() const;
00112
00116         XYDIM GetWidth() const;
00117
00121         XYDIM GetHeight() const;
00122 };
00123
00125 #endif // Apoxi_ImageObtainer_hpp
00126
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/InputMapper.cpp File Reference

Gui/InputMapper.cpp File Reference

#include "Gui/PreComp.hpp"
#include "InputMapper.hpp"
#include "DefaultCaret.hpp"
#include "AbstractEditor.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/EditConfig.hpp>

Include dependency graph for InputMapper.cpp:

Generated on Tue Jan 24 20:44:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/InputMapper.hpp File Reference

Gui/InputMapper.hpp File Reference

#include <Gui/Caret.hpp>

Include dependency graph for InputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InputMapper

Defines

#define | Apoxi_InputMapper_hpp

Typedefs

typedef InputMapper::NotificationType | NotificationType

Define Documentation

#define Apoxi_InputMapper_hpp

Generated on Tue Jan 24 20:44:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/InputMapper.hpp Source File

Gui/InputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_InputMapper_hpp)
00011 #define Apoxi_InputMapper_hpp
00015
00016 #include <Gui/Caret.hpp>
00017
00018 class AbstractEditor;
00019
00037 class InputMapper {
00038     public:
00042         enum Id {
00044             Numeric         = 0,
00048             MultiTap        = 1,
00050             MultiTab        = MultiTap,
00053             PhoneNumber     = 2,
00058             Predictive      = 3,
00062             Date            = 4,
00066             Time            = 5,
00068             Calculator      = 6,
00071             IpAddress       = 7,
00073             Zi8             = 8,
00076             Url             = 9,
00079             EMailAddress    = 10,
00081             T9              = 11,
00083             Name            = 12,
00086             Custom          = 99
00087         };
00088
00091         enum Alphabet {
00092             UndefinedAlphabet   = 0,
00093             SevenBitAlphabet    = 1,
00094             EightBitAlphabet    = 2,
00095             Ucs2Alphabet        = 3
00096         };
00097
00098         enum NotificationType {
00099             InsertedItem    = 0,
00100             UpdatedContent  = 1,
00102             SetText         = 1
00103
00104         };
00105
00107         explicit InputMapper(AbstractEditor* editor = 0);
00108
00109         virtual ~InputMapper();
00110
00112         virtual INT GetId() const = 0;
00113
00115         virtual void SetEditor(AbstractEditor* editor);
00116
00122         virtual Caret* GetCaret();
00123
00126         virtual Alphabet GetAlphabet() const;
00127
00131         virtual BOOLEAN Notify(NotificationType type, INT index = 0, const AtomItem* item = 0);
00132
00136         virtual BOOLEAN IsContentValid() const;
00137
00138     protected:
00139         Caret* m_caret;
00140
00142         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00143
00145         virtual BOOLEAN OnKeyUp(KeyCode key_code, UINT32 duration);
00146
00150         virtual BOOLEAN OnLongKeyPress(KeyCode key_code);
00151
00154         virtual void OnGetFocus();
00155
00158         virtual void OnLoseFocus();
00159
00161         AbstractEditor* GetEditor() { return m_editor; }
00162
00164         const AbstractEditor* GetEditor() const { return m_editor; }
00165
00166     private:
00167         // TODO: derive InputMapper from Dispatcher and forward key codes by SendSelf, this
00168         // avoids the following friend declarations
00169         friend class AbstractEditor;            // invokes InputMapper::OnKeyDown
00170         friend class AbstractMultiLineEditor;   // invokes InputMapper::OnKeyDown
00171
00172         AbstractEditor* m_editor;
00173 };
00174
00175 typedef InputMapper::NotificationType NotificationType;
00176
00178 #endif  // Apoxi_InputMapper_hpp
00179
00180
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrCompoundItem.cpp File Reference

Gui/IpAddrCompoundItem.cpp File Reference

#include "Gui/PreComp.hpp"
#include "IpAddrCompoundItem.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for IpAddrCompoundItem.cpp:

Generated on Tue Jan 24 20:44:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrCompoundItem.hpp File Reference

Gui/IpAddrCompoundItem.hpp File Reference

#include <Auxiliary/IpAddr.hpp>
#include <Gui/CompoundItem.hpp>

Include dependency graph for IpAddrCompoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IpAddrCompoundItem
Contains a date. More...

Defines

#define | Apoxi_IpAddrCompoundItem_hpp

Define Documentation

#define Apoxi_IpAddrCompoundItem_hpp

Generated on Tue Jan 24 20:44:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrCompoundItem.hpp Source File

Gui/IpAddrCompoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_IpAddrCompoundItem_hpp)
00011 #define Apoxi_IpAddrCompoundItem_hpp
00015
00016 #include <Auxiliary/IpAddr.hpp>
00017 #include <Gui/CompoundItem.hpp>
00018
00020 class IpAddrCompoundItem : public CompoundItem {
00021     typedef CompoundItem Base;
00022
00023     public:
00024         enum {
00025             ID = 9
00026         };
00027
00029         static IpAddrCompoundItem* CreateInstance(const IpAddr& ip_addr = IpAddr());
00030
00032         virtual ~IpAddrCompoundItem();
00033
00035         virtual INT GetId() const;
00036
00038         void SetIpAddr(UINT32 ip_addr) { m_ip_addr.SetAddr(ip_addr); }
00039
00041         void SetIpAddr(const IpAddr& ip_addr) { m_ip_addr = ip_addr; }
00042
00044         const IpAddr& GetIpAddr() const { return m_ip_addr; }
00045
00047         virtual void Draw(DeviceContext* dc,
00048                           XYDIM x,
00049                           XYDIM y,
00050                           INT index,
00051                           INT count) const;
00052
00054         virtual INT WrapLine(INT index,
00055                              XYDIM width,
00056                              WrapPolicy wrap_policy = EditorDocument::WhitespaceWrap) const;
00057
00059         virtual XYDIM GetLineWidth(INT index, INT count) const;
00060
00062         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const;
00063
00065         virtual INT GetItemCount() const;
00066
00068         virtual BOOLEAN IsInstanceOf(INT id) const;
00069
00070     protected:
00072         IpAddrCompoundItem(const IpAddr& ip_addr = IpAddr());
00073
00074     private:
00075         IpAddr  m_ip_addr;
00076 };
00077
00079 #endif  // Apoxi_IpAddrCompoundItem_hpp
00080
00081
Generated on Tue Jan 24 14:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrEditor.cpp File Reference

Gui/IpAddrEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "IpAddrEditor.hpp"
#include "Gui/DefaultCaret.hpp"
#include <Gui/Control.hpp>
#include "IpAddrInputMapper.hpp"

Include dependency graph for IpAddrEditor.cpp:

Generated on Tue Jan 24 20:44:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrEditor.hpp File Reference

Gui/IpAddrEditor.hpp File Reference

#include <Gui/AbstractLineEditor.hpp>
#include <Gui/IpAddrEditorDocument.hpp>

Include dependency graph for IpAddrEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IpAddrEditor

Defines

#define | Apoxi_IpAddrEditor_hpp

Define Documentation

#define Apoxi_IpAddrEditor_hpp

Generated on Tue Jan 24 20:44:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrEditor.hpp Source File

Gui/IpAddrEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_IpAddrEditor_hpp)
00011 #define Apoxi_IpAddrEditor_hpp
00016
00017 #include <Gui/AbstractLineEditor.hpp>
00018 #include <Gui/IpAddrEditorDocument.hpp>
00019
00020 class DefaultCaret;
00021
00024 class IpAddrEditor : public AbstractLineEditor {
00025     typedef AbstractLineEditor Base;
00026
00027     public:
00028         enum {
00029             ID = 31
00030         };
00031
00034         IpAddrEditor();
00035
00038         explicit IpAddrEditor(Control* parent, const IpAddr& ip_addr = IpAddr());
00039
00040         virtual ~IpAddrEditor();
00041
00044         void Init(Control* parent, const IpAddr& ip_addr = IpAddr());
00045
00048         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00049
00051         virtual BOOLEAN IsInstanceOf(INT id) const;
00052
00054         void SetIpAddr(const IpAddr& ip_addr);
00055
00057         IpAddr GetIpAddr() const;
00058
00059     protected:
00060         virtual Model* CreateModel() const;
00061
00062     private:
00063         BOOLEAN m_valid;
00064
00065         IpAddrEditorDocument* GetMyDocument() { return (IpAddrEditorDocument*)GetModel(); } //lint !e1762
00066         const IpAddrEditorDocument* GetMyDocument() const { return (const IpAddrEditorDocument*)GetModel(); }
00067
00068         DefaultCaret* GetMyCaret() { return (DefaultCaret*)GetCaret(); }
00069 };
00070
00072 #endif  // Apoxi_IpAddrEditor_hpp
00073
00074
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrEditorDocument.cpp File Reference

Gui/IpAddrEditorDocument.cpp File Reference

#include "Gui/PreComp.hpp"
#include "IpAddrEditorDocument.hpp"
#include "PaintDc.hpp"
#include "Font.hpp"
#include <Config/FontConfig.hpp>

Include dependency graph for IpAddrEditorDocument.cpp:

Generated on Tue Jan 24 20:44:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrEditorDocument.hpp File Reference

Gui/IpAddrEditorDocument.hpp File Reference

#include <Gui/TextEditorDocument.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/IpAddrCompoundItem.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/IpAddr.hpp>

Include dependency graph for IpAddrEditorDocument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IpAddrEditorDocument
A IpAddr-Editor-Document contains a IpAddr-Compound-Item. More...

Defines

#define | Apoxi_IpAddrEditorDocument_hpp

Define Documentation

#define Apoxi_IpAddrEditorDocument_hpp

Generated on Tue Jan 24 20:44:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrEditorDocument.hpp Source File

Gui/IpAddrEditorDocument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_IpAddrEditorDocument_hpp)
00011 #define Apoxi_IpAddrEditorDocument_hpp
00015
00016 #include <Gui/TextEditorDocument.hpp>
00017 #include <Gui/CharItem.hpp>
00018 #include <Gui/IpAddrCompoundItem.hpp>
00019 #include <Auxiliary/WString.hpp>
00020 #include <Auxiliary/IpAddr.hpp>
00021
00023 class IpAddrEditorDocument : public TextEditorDocument {
00024     typedef TextEditorDocument Base;
00025
00026     public:
00028         IpAddrEditorDocument();
00029
00031         explicit IpAddrEditorDocument(const IpAddr& ip_addr);
00032
00034         virtual ~IpAddrEditorDocument();
00035
00037         virtual INT GetMaxItemCount() const;
00038
00040         void Init(const IpAddr& ip_addr);
00041
00043         void SetIpAddr(const IpAddr& ip_addr);
00044
00046         IpAddr GetIpAddr() const;
00047
00049         BOOLEAN IsSeparator(INT index) const;
00050
00052         BOOLEAN IsInvalid(INT index) const;
00053 };
00054
00056 #endif  // Apoxi_IpAddrEditorDocument_hpp
00057
00058
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrInputMapper.cpp File Reference

Gui/IpAddrInputMapper.cpp File Reference

#include "Gui/PreComp.hpp"
#include <Config/KeyboardConfig.hpp>
#include "Gui/MessageBox.hpp"
#include "Gui/CharItem.hpp"
#include "IpAddrCompoundItem.hpp"
#include "IpAddrEditor.hpp"
#include "IpAddrInputMapper.hpp"

Include dependency graph for IpAddrInputMapper.cpp:

Generated on Tue Jan 24 20:44:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrInputMapper.hpp File Reference

Gui/IpAddrInputMapper.hpp File Reference

#include <Gui/NumericInputMapper.hpp>

Include dependency graph for IpAddrInputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IpAddrInputMapper
Manages the input of a ip adress. More...

Defines

#define | Apoxi_IpAddrInputMapper_hpp

Define Documentation

#define Apoxi_IpAddrInputMapper_hpp

Generated on Tue Jan 24 20:44:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/IpAddrInputMapper.hpp Source File

Gui/IpAddrInputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_IpAddrInputMapper_hpp)
00011 #define Apoxi_IpAddrInputMapper_hpp
00015
00016 #include <Gui/NumericInputMapper.hpp>
00017
00018 class IpAddrEditor;
00019
00021 class IpAddrInputMapper : public NumericInputMapper {
00022     typedef NumericInputMapper Base;
00023
00024     public:
00027         explicit IpAddrInputMapper(BOOLEAN highlight_field = FALSE);
00028
00029         virtual ~IpAddrInputMapper();
00030
00032         virtual void SetEditor(AbstractEditor* editor);
00033
00035         virtual INT GetId() const;
00036
00039         virtual Alphabet GetAlphabet() const;
00040
00041     protected:
00043         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00044
00046         virtual void OnGetFocus();
00047
00049         virtual void OnLoseFocus();
00050
00051
00052     private:
00053         void DeleteItem(INT index);
00054         void UpdateFieldHighlight();
00055
00056         BOOLEAN m_highlight_field;
00057 };
00058
00060 #endif  // Apoxi_IpAddrInputMapper_hpp
00061
00062
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Item.cpp File Reference

Gui/Item.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Item.hpp"
#include "Bitmap.hpp"
#include "ImageFactory.hpp"
#include <Kernel/Dispatcher.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Config/GuiEngineConfig.hpp>

Include dependency graph for Item.cpp:

Generated on Tue Jan 24 20:44:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Item.hpp File Reference

Gui/Item.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/WString.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Gui/IconState.hpp>
#include <Gui/IconSet.hpp>
#include <Config/GuiObjectFactory.hpp>

Include dependency graph for Item.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Item

Defines

#define | Apoxi_Item_hpp

Define Documentation

#define Apoxi_Item_hpp

Generated on Tue Jan 24 20:44:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Item.hpp Source File

Gui/Item.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Item_hpp)
00010 #define Apoxi_Item_hpp
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/WString.hpp>
00017 #include <Gui/ImageObtainer.hpp>
00018 #include <Gui/IconState.hpp>
00019 #include <Gui/IconSet.hpp>
00020
00021 #include <Config/GuiObjectFactory.hpp>
00022
00023 class Dispatcher;
00024 class ResourceParser;
00025
00048 class Item {
00049     public:
00050         enum {
00051             ID = 0
00052         };
00053
00062         enum ItemPropertyId {
00065             UnspecifiedPropertyId   = -1,
00067             TextPropertyId          = 0,
00069             IconPropertyId          = 1,
00071             EnabledPropertyId       = 2,
00073             SeparatorPropertyId     = 3,
00075             ValuePropertyId         = 4,
00077             MarkedPropertyId        = 5,
00079             CustomPropertyId        = 999
00080         };
00081
00084         Item();
00085
00096         Item(Dispatcher* dispatcher,
00097              const WCHAR* text,
00098              const BitmapRes* icon = 0,
00099              BOOLEAN enabled = TRUE);
00100
00111         Item(Dispatcher* dispatcher,
00112              const WString& text,
00113              const BitmapRes* icon = 0,
00114              BOOLEAN enabled = TRUE);
00115
00126         Item(Dispatcher* dispatcher,
00127              const WString& text,
00128              const ImageObtainer& icon,
00129              BOOLEAN enabled = TRUE);
00130
00131
00147         Item(Dispatcher* dispatcher,
00148              const WString& text,
00149              const IconSet& icon_set,
00150              BOOLEAN enabled = TRUE);
00151
00153         virtual ~Item();
00154
00165         void Init(Dispatcher* dispatcher,
00166                   const WCHAR* text,
00167                   const BitmapRes* icon = 0,
00168                   BOOLEAN enabled = TRUE);
00169
00180         void Init(Dispatcher* dispatcher,
00181                   const WString& text,
00182                   const BitmapRes* icon = 0,
00183                   BOOLEAN enabled = TRUE);
00184
00195         void Init(Dispatcher* dispatcher,
00196                   const WString& text,
00197                   const ImageObtainer& icon,
00198                   BOOLEAN enabled = TRUE);
00199
00215         void Init(Dispatcher* dispatcher,
00216                   const WString& text,
00217                   const IconSet& icon_set,
00218                   BOOLEAN enabled = TRUE);
00219
00222         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00223
00227         virtual void SetText(const WString& text);
00228
00230         void SetText(const WCHAR* text);
00231
00233         virtual const WString& GetText() const;
00234
00238         virtual void SetIcon(const ImageObtainer& icon);
00239
00241         void SetIcon(const BitmapRes* icon);
00242
00246         void SetIcon(const IconSet& icon_set);
00247
00250         const ImageObtainer& GetIcon() const;
00251
00257         virtual const ImageObtainer& GetIcon(const IconState& icon_state) const;
00258
00262         BOOLEAN HasIcon() const;
00263
00268         virtual void SetEnabled(BOOLEAN enabled);
00269
00272         virtual BOOLEAN IsEnabled() const;
00273
00279         void SetSeparator(BOOLEAN is_separator);
00280
00283         BOOLEAN IsSeparator() const { return (BOOLEAN)m_bits.is_separator; }
00284
00289         void SetMarked(BOOLEAN marked);
00290
00293         BOOLEAN IsMarked() const { return (BOOLEAN)m_bits.marked; }
00294
00298         virtual void SetDispatcher(Dispatcher* dispatcher) { m_dispatcher = dispatcher; }
00299
00302         Dispatcher* GetDispatcher() const { return m_dispatcher; }
00303
00313         void SetSyncModeEnabled(BOOLEAN enabled) { m_bits.sync_mode_enabled = enabled; }
00314
00318         BOOLEAN IsSyncModeEnabled() const { return (BOOLEAN)m_bits.sync_mode_enabled; }
00319
00324         void BlockNotification(BOOLEAN block) { m_bits.block_notification = block; }
00325
00328         BOOLEAN IsNotificationBlocked() const { return (BOOLEAN)m_bits.block_notification; }
00329
00335         void SetRetranslateEnabled(BOOLEAN enabled) { m_bits.retranslate_enabled = enabled; }
00336
00339         BOOLEAN IsRetranslateEnabled() const { return (BOOLEAN)m_bits.retranslate_enabled; }
00340
00362         virtual BOOLEAN IsInstanceOf(INT id) const;
00363
00368         virtual BOOLEAN IsEqual(const Item& item) const;
00369
00372         virtual void OnLanguageChanged();
00373
00380         BOOLEAN UsesIconSet(BOOLEAN* contains_only_bmps = 0) const;
00381
00383         INT GetLanguageId() const { return (INT) m_bits.language_id; }
00384
00385     protected:
00393         void NotifyPropertyChange(INT property_id = UnspecifiedPropertyId);
00394
00403         void SetTextProperty(const WString& text) const  { m_text = text; }
00404
00413         void SetIconProperty(const ImageObtainer& icon) const;
00414
00423         void SetEnabledProperty(BOOLEAN enabled) const { m_bits.enabled = enabled; }
00424
00431         void SetLanguageId(INT lang_id) { m_bits.language_id = lang_id; }
00432
00433     private:
00434         mutable struct {
00435             UINT enabled                : 1;
00436             UINT is_separator           : 1;
00437             UINT sync_mode_enabled      : 1;
00438             UINT block_notification     : 1;
00439             UINT retranslate_enabled    : 1;
00440             UINT language_id            : 8;
00441             UINT marked                 : 1;
00442         } m_bits;
00443         Dispatcher* m_dispatcher;
00444         mutable WString m_text;
00445         mutable IconSet m_icon_set;
00446
00447         void InitBitset();
00448 };
00449
00451 #endif  // Apoxi_Item_hpp
00452
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemBox.cpp File Reference

Gui/ItemBox.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ItemBox.hpp"
#include "PaintDc.hpp"
#include "LanguageManager.hpp"
#include "Item.hpp"
#include "AbstractItemRenderer.hpp"
#include "ItemRendererProperties.hpp"
#include "Bitmap.hpp"
#include "TextFormat.hpp"
#include "Image.hpp"
#include <Config/GuiEngineConfig.hpp>

Include dependency graph for ItemBox.cpp:

Generated on Tue Jan 24 20:44:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemBox.hpp File Reference

Gui/ItemBox.hpp File Reference

#include <Gui/DrawableObject.hpp>
#include <Auxiliary/TriggerTimer.hpp>

Include dependency graph for ItemBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ItemBox
class | ItemBoxView

Defines

#define | Apoxi_ItemBox_hpp

Define Documentation

#define Apoxi_ItemBox_hpp

Generated on Tue Jan 24 20:44:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemBox.hpp Source File

Gui/ItemBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ItemBox_hpp)
00010 #define Apoxi_ItemBox_hpp
00014
00015 class ItemRendererProperties;
00016 class AbstractItemRenderer;
00017 class Item;
00018 #include <Gui/DrawableObject.hpp>
00019 #include <Auxiliary/TriggerTimer.hpp>
00020
00022 class ItemBoxView : public DrawableObjectView {
00023     typedef DrawableObjectView Base;
00024
00025     public:
00026         ItemBoxView();
00027         virtual ~ItemBoxView();
00028         virtual void Draw(const Component& component,
00029                           DeviceContext* dc,
00030                           const Rect& repaint_rect) const;
00031
00032     private:
00033         void DrawImage(DeviceContext* dc,
00034                        const Item& item,
00035                        const Rect& bounds) const;
00036 };
00037
00041 class ItemBox : public DrawableObject {
00042     typedef DrawableObject Base;
00043
00044     public:
00045         enum {
00046             ID = 37
00047         };
00048
00051         ItemBox();
00052
00061         ItemBox(Control* control,
00062                 Item* item);
00063
00064         virtual ~ItemBox();
00065
00072         void Init(Control* control,
00073                   Item* item);
00074
00077         Item* GetItem() const { return m_item; }
00078
00090         void SetRenderer(const ItemRendererProperties* properties = 0);
00091
00095         const AbstractItemRenderer* GetRenderer() const { return m_renderer; }
00096
00099         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00100
00102         virtual BOOLEAN IsInstanceOf(INT id) const;
00103
00105         virtual XYDIM GetDefaultWidth() const;
00106
00108         virtual XYDIM GetDefaultHeight() const;
00109
00110     protected:
00112         virtual BOOLEAN OnMessage(const Message& msg);
00113
00115         virtual void Refresh(const Rect& rect);
00116
00118         virtual void Cleanup();
00119
00121         virtual void OnResize(XYDIM dx, XYDIM dy);
00122
00123     private:
00124         friend class TriggerTimer<ItemBox>;
00125
00126         Item* m_item;
00127         AbstractItemRenderer* m_renderer;
00128         TriggerTimer<ItemBox> m_timer;
00129
00130         static ItemBoxView m_view;
00131
00133         void InitProperties(Item* item);
00134
00137         BOOLEAN UseImageSize() const;
00138
00141         void OnTimer();
00142
00145         void StartTextScrolling();
00146 };
00147
00149 #endif  // Apoxi_ItemBox_hpp
00150
00151
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemContainer.cpp File Reference

Gui/ItemContainer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ItemContainer.hpp"

Include dependency graph for ItemContainer.cpp:

Generated on Tue Jan 24 20:44:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemContainer.hpp File Reference

Gui/ItemContainer.hpp File Reference

#include <Gui/AbstractItemContainer.hpp>

Include dependency graph for ItemContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ItemContainer

Defines

#define | Apoxi_ItemContainer_hpp

Define Documentation

#define Apoxi_ItemContainer_hpp

Generated on Tue Jan 24 20:44:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemContainer.hpp Source File

Gui/ItemContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ItemContainer_hpp)
00010 #define Apoxi_ItemContainer_hpp
00014
00015 #include <Gui/AbstractItemContainer.hpp>
00016
00019 class ItemContainer : public AbstractItemContainer {
00020     typedef AbstractItemContainer Base;
00021
00022     public:
00023         enum {
00024             ID = 3
00025         };
00026
00029         ItemContainer();
00030
00042         ItemContainer(Dispatcher* dispatcher,
00043                       const WCHAR* text,
00044                       const BitmapRes* icon = 0,
00045                       BOOLEAN enabled = TRUE);
00046
00058         ItemContainer(Dispatcher* dispatcher,
00059                       const WString& text,
00060                       const BitmapRes* icon = 0,
00061                       BOOLEAN enabled = TRUE);
00062
00074         ItemContainer(Dispatcher* dispatcher,
00075                       const WString& text,
00076                       const ImageObtainer& icon,
00077                       BOOLEAN enabled = TRUE);
00078
00090         ItemContainer(Dispatcher* dispatcher,
00091                       const WString& text,
00092                       const IconSet& icon_set,
00093                       BOOLEAN enabled = TRUE);
00094
00095         virtual ~ItemContainer();
00096
00108         void Init(Dispatcher* dispatcher,
00109                   const WCHAR* text,
00110                   const BitmapRes* icon = 0,
00111                   BOOLEAN enabled = TRUE);
00112
00124         void Init(Dispatcher* dispatcher,
00125                   const WString& text,
00126                   const BitmapRes* icon = 0,
00127                   BOOLEAN enabled = TRUE);
00128
00140         void Init(Dispatcher* dispatcher,
00141                   const WString& text,
00142                   const ImageObtainer& icon,
00143                   BOOLEAN enabled = TRUE);
00144
00156         void Init(Dispatcher* dispatcher,
00157                   const WString& text,
00158                   const IconSet& icon_set,
00159                   BOOLEAN enabled = TRUE);
00160
00163         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00164
00166         virtual BOOLEAN IsInstanceOf(INT id) const;
00167
00169         virtual BOOLEAN AddItem(Item* item);
00170
00172         virtual BOOLEAN InsertItem(INT index, Item* item);
00173
00184         virtual BOOLEAN RemoveItem(INT index);
00185
00203         virtual BOOLEAN RemoveAllItems();
00204
00206         virtual Item* GetItem(INT index) const;
00207
00209         virtual INT GetItemIndex(const Item& item) const;
00210
00212         virtual INT GetItemCount() const;
00213
00215         virtual BOOLEAN SetParentContainer(AbstractItemContainer* container);
00216
00218         virtual AbstractItemContainer* GetParentContainer();
00219
00221         virtual BOOLEAN SetRendererProperties(const ItemRendererProperties* properties);
00222
00224         virtual const ItemRendererProperties* GetRendererProperties() const;
00225
00227         virtual BOOLEAN IsEnabled() const;
00228
00229     private:
00230         Vector<Item*> m_item_vec;
00231         AbstractItemContainer* m_parent_container;
00232         const ItemRendererProperties* m_renderer_properties;
00233
00234         BOOLEAN IsValidIndex(INT index) const;
00235 };
00236
00238 #endif  // Apoxi_Item_hpp
00239
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemGrid.cpp File Reference

Gui/ItemGrid.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ItemGrid.hpp"
#include "AbstractItemRenderer.hpp"
#include <Config/GuiEngineConfig.hpp>

Include dependency graph for ItemGrid.cpp:

Generated on Tue Jan 24 20:44:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemGrid.hpp File Reference

Gui/ItemGrid.hpp File Reference

#include <Kernel/Timer.hpp>
#include <Gui/AbstractItemGrid.hpp>

Include dependency graph for ItemGrid.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ItemGrid

Defines

#define | Apoxi_ItemGrid_hpp

Define Documentation

#define Apoxi_ItemGrid_hpp

Generated on Tue Jan 24 20:44:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemGrid.hpp Source File

Gui/ItemGrid.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ItemGrid_hpp)
00010 #define Apoxi_ItemGrid_hpp
00014
00015 #include <Kernel/Timer.hpp>
00016 #include <Gui/AbstractItemGrid.hpp>
00017
00025 class ItemGrid : public AbstractItemGrid {
00026     typedef AbstractItemGrid Base;
00027
00028     public:
00029         enum {
00030             ID = 12
00031         };
00032
00035         ItemGrid();
00036
00042         ItemGrid(Control* parent, AbstractItemContainer* item_cont = 0);
00043
00044         virtual ~ItemGrid();
00045
00051         void Init(Control* parent, AbstractItemContainer* item_cont = 0);
00052
00055         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00056
00058         virtual BOOLEAN IsInstanceOf(INT id) const;
00059
00065         void SetColumnCount(INT count);
00066
00068         virtual INT GetColumnCount() const;
00069
00070     private:
00071         INT m_column_count;
00072 };
00073
00075 #endif  // Apoxi_ItemGrid_hpp
00076
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemMenu.cpp File Reference

Gui/ItemMenu.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ItemMenu.hpp"
#include "Action.hpp"
#include "Window.hpp"
#include "AbstractItemRenderer.hpp"

Include dependency graph for ItemMenu.cpp:

Generated on Tue Jan 24 20:44:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemMenu.hpp File Reference

Gui/ItemMenu.hpp File Reference

#include <Kernel/Timer.hpp>
#include <Gui/ItemGrid.hpp>
#include <Auxiliary/Vector.hpp>
#include <Gui/ItemContainer.hpp>

Include dependency graph for ItemMenu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ItemMenu
class | ItemMenu::LevelInfo

Defines

#define | Apoxi_ItemMenu_hpp

Define Documentation

#define Apoxi_ItemMenu_hpp

Generated on Tue Jan 24 20:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemMenu.hpp Source File

Gui/ItemMenu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ItemMenu_hpp)
00010 #define Apoxi_ItemMenu_hpp
00014
00015 #include <Kernel/Timer.hpp>
00016 #include <Gui/ItemGrid.hpp>
00017 #include <Auxiliary/Vector.hpp>
00018 #include <Gui/ItemContainer.hpp>
00019
00026 class ItemMenu : public ItemGrid {
00027     typedef ItemGrid Base;
00028
00029     public:
00030         enum {
00031             ID = 13
00032         };
00033
00036         class LevelInfo {
00037             public:
00038                 LevelInfo() : m_item_cont(0) {}
00039                 LevelInfo(const ItemMenu& menu);
00040                 INT GetSelectedIndex() const { return m_selected_idx; }
00041                 INT GetFirstVisibleIndex() const { return m_first_visible_idx; }
00042                 INT GetFirstVisibleColumn() const { return m_first_visible_column; }
00043                 AbstractItemContainer* GetItemContainer() const { return m_item_cont; }
00044
00045             private:
00046                 INT m_selected_idx;
00047                 INT m_first_visible_idx;
00048                 INT m_first_visible_column;
00049                 AbstractItemContainer* m_item_cont;
00050         };
00051
00054         ItemMenu();
00055
00062         ItemMenu(Control* parent,
00063                  AbstractItemContainer* item_cont = 0,
00064                  BOOLEAN adjust_win_title = FALSE);
00065
00067         virtual ~ItemMenu();
00068
00075         void Init(Control* parent,
00076                   AbstractItemContainer* item_cont = 0,
00077                   BOOLEAN adjust_win_title = FALSE);
00078
00081         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00082
00084         virtual BOOLEAN IsInstanceOf(INT id) const;
00085
00095         virtual BOOLEAN Trigger(INT index = -1);
00096
00099         virtual BOOLEAN Back();
00100
00102         INT GetLevel() const { return m_level; }
00103
00109         const LevelInfo* GetLevelInfo(INT level);
00110
00114         void SetAdjustWindowTitle(BOOLEAN flag) { m_adjust_win_title = flag; }
00115
00119         BOOLEAN AdjustWindowTitle() const { return m_adjust_win_title; }
00120
00121 #if defined(APOXI_ENABLE_POSITION_PREVIEW)
00122
00123         virtual WString GetShortcutInfo() const;
00124 #endif
00125
00126     protected:
00133         virtual void OnLevelChange(INT old_level, INT new_level);
00134
00136         virtual void Refresh(const Rect& rect);
00137
00139         virtual void Cleanup();
00140
00142         virtual void OnSelectionChanged();
00143
00144     private:
00145         BOOLEAN m_adjust_win_title;
00146         INT m_level;
00147         Vector<LevelInfo> m_level_info;
00148
00149         void UpdateWindowTitle(const WString& title) const;
00150 };
00151
00153 #endif  // Apoxi_ItemMenu_hpp
00154
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemRendererProperties.cpp File Reference

Gui/ItemRendererProperties.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ItemRendererProperties.hpp"
#include "Bitmap.hpp"
#include <Kernel/Dispatcher.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Auxiliary/WStrUtil.hpp>

Include dependency graph for ItemRendererProperties.cpp:

Generated on Tue Jan 24 20:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemRendererProperties.hpp File Reference

Gui/ItemRendererProperties.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/WString.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Gui/Color.hpp>
#include <Gui/TextFormat.hpp>

Include dependency graph for ItemRendererProperties.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ItemRendererProperties

Defines

#define | Apoxi_ItemRendererProperties_hpp

Define Documentation

#define Apoxi_ItemRendererProperties_hpp

Generated on Tue Jan 24 20:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemRendererProperties.hpp Source File

Gui/ItemRendererProperties.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ItemRendererProperties_hpp)
00010 #define Apoxi_ItemRendererProperties_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/WString.hpp>
00016 #include <Gui/ImageObtainer.hpp>
00017 #include <Gui/Color.hpp>
00018 #include <Gui/TextFormat.hpp>
00019
00020 class Dispatcher;
00021 class ResourceParser;
00022
00033 class ItemRendererProperties {
00034     public:
00035         enum {
00036             ID = 0
00037         };
00038
00041         enum DisplayType {
00044             TextAndIconDisplayType      = 0,
00046             TextDisplayType             = 1,
00048             IconDisplayType             = 2,
00050             TextAboveIconDisplayType    = 3,
00052             TextBelowIconDisplayType    = 4,
00054             TextOverlapsIconDisplayType = 5,
00056             CustomDisplayType           = 99
00057         };
00058
00059
00063         enum AnimType {
00065             NoAnimation                 = 0,
00068             CycleAnimation              = 1,
00071             BounceAnimation             = 2,
00074             BlinkingAnimation           = 3,
00078             IconAnimation               = 4,
00081             OnlyOnceAnimation           = 5,
00083             CustomAnimation             = 99,
00084
00085             // Obsolete - use CycleAnimation instead (whether the
00086             // scrolling is done horizontally or vertically is decided through
00087             // the multiline-mode)
00088             CycleVerticalAnimation      = 1,
00089             // Obsolete - use CycleAnimation instead (whether the
00090             // scrolling is done horizontally or vertically is decided through
00091             // the multiline-mode)
00092             CycleHorizontalAnimation    = 1,
00093             // Obsolete - use CycleAnimation instead.
00094             HardVerticalAnimation       = 1,
00095             // Obsolete - use CycleAnimation instead.
00096             HardHorizontalAnimation     = 1,
00097             // Obsolete - use CycleAnimation instead.
00098             SoftVerticalAnimation       = 1,
00099             // Obsolete - use CycleAnimation instead.
00100             SoftHorizontalAnimation     = 1,
00101         };
00102
00103         ItemRendererProperties();
00104
00145         ItemRendererProperties(INT display_type,
00146                                INT anim_type,
00147                                UINT16 scroll_delay,
00148                                XYDIM scroll_gap,
00149                                const TextFormat& text_format,
00150                                BOOLEAN full_screen_per_item = FALSE,
00151                                BOOLEAN transparent = FALSE,
00152                                BOOLEAN multi_line = FALSE,
00153                                BOOLEAN centered_vertical = TRUE,
00154                                BOOLEAN indicate_item_cont = FALSE,
00155                                const Color& backgr_color = Color(Color::ClientBackground),
00156                                XYDIM height = -1,
00157                                XYDIM gap = 2,
00158                                INT column_count = 1,
00159                                XYDIM selection_height = -1,
00160                                UINT16 start_delay = 0,
00161                                const ImageObtainer& backgr_image = ImageObtainer(),
00162                                const Color* text_color = 0,
00163                                INT renderer_hint = 0);
00164
00165         virtual ~ItemRendererProperties();
00166
00169         BOOLEAN SetProperty(ResourceParser& parser,
00170                             const GuiObjectFactory::PropertyId prop_id);
00171
00193         virtual BOOLEAN IsInstanceOf(INT id) const;
00194
00196         void SetDisplayType(INT display_type) { m_display_type = display_type; }
00197
00199         INT GetDisplayType() const { return m_display_type; }
00200
00202         void SetAnimType(INT anim_type) { m_anim_type = anim_type; }
00203
00205         INT GetAnimType() const { return m_anim_type; }
00206
00209         void SetStartDelay(UINT16 start_delay) { m_start_delay = start_delay; }
00210
00213         UINT16 GetStartDelay() const { return m_start_delay; }
00214
00217         void SetScrollDelay(UINT16 scroll_delay);
00218
00220         UINT16 GetScrollDelay() const { return m_scroll_delay; }
00221
00223         void SetScrollGap(XYDIM scroll_gap);
00224
00226         XYDIM GetScrollGap() const { return m_scroll_gap; }
00227
00230         void SetTextFormat(const TextFormat& text_format) { m_text_format = text_format; }
00231
00234         const TextFormat& GetTextFormat() const { return m_text_format; }
00235
00237         void SetTransparent(BOOLEAN transparent) { m_bits.transparent = transparent; }
00238
00240         BOOLEAN IsTransparent() const { return (BOOLEAN)m_bits.transparent; }
00241
00244         void SetMultiLine(BOOLEAN multi_line) { m_bits.multi_line = multi_line; }
00245
00248         BOOLEAN IsMultiLine() const { return (BOOLEAN)m_bits.multi_line; }
00249
00251         void SetIndicateItemContainer(BOOLEAN flag) { m_bits.indicate_item_cont = flag; }
00252
00254         BOOLEAN IndicateItemContainer() const { return (BOOLEAN)m_bits.indicate_item_cont; }
00255
00259         void SetFullScreenPerItem(BOOLEAN full_screen_per_item) { m_bits.full_screen_per_item = full_screen_per_item; }
00260
00264         BOOLEAN FullScreenPerItem() const { return (BOOLEAN)m_bits.full_screen_per_item; }
00265
00267         void SetVerticalCentered(BOOLEAN vertical_centered) { m_bits.vertical_centered = vertical_centered; }
00268
00270         BOOLEAN IsVerticalCentered() const { return (BOOLEAN)m_bits.vertical_centered; }
00271
00275         void SetTextColor(const Color* text_color);
00276
00279         const Color& GetTextColor() const;
00280
00284         void SetBackgroundColor(const Color& backgr_color);
00285
00289         const Color& GetBackgroundColor() const { return m_backgr_color; }
00290
00294         void SetHeight(XYDIM height) { m_height = height; }
00295
00299         XYDIM GetHeight() const { return m_height; }
00300
00302         void SetGap(XYDIM gap) { m_gap = gap; }
00303
00305         XYDIM GetGap() const { return m_gap; }
00306
00310         void SetColumnCount(INT column_count) { m_column_count = column_count; }
00311
00315         INT GetColumnCount() const { return m_column_count; }
00316
00320         void SetSelectionHeight(XYDIM selection_height) { m_selection_height = selection_height; }
00321
00325         XYDIM GetSelectionHeight() const { return m_selection_height; }
00326
00329         void SetBackgroundImage(const ImageObtainer& backgr_image) { m_backgr_image = backgr_image; }
00330
00332         const ImageObtainer& GetBackgroundImage() const { return m_backgr_image; }
00333
00338         void SetRendererHint(INT renderer_hint) { m_renderer_hint = renderer_hint; }
00339
00342         INT GetRendererHint() const { return m_renderer_hint; }
00343
00344     private:
00345         struct {
00346             UINT transparent          : 1;
00347             UINT multi_line           : 1;
00348             UINT indicate_item_cont   : 1;
00349             UINT full_screen_per_item : 1;
00350             UINT vertical_centered    : 1;
00351             UINT use_default_text_col : 1;
00352         } m_bits;
00353
00354         INT m_display_type;
00355         INT m_anim_type;
00356         UINT16 m_start_delay;
00357         UINT16 m_scroll_delay;
00358         XYDIM m_scroll_gap;
00359         TextFormat m_text_format;
00360         mutable Color m_text_color;
00361         Color m_backgr_color;
00362         XYDIM m_height;
00363         XYDIM m_gap;
00364         INT m_column_count;
00365         XYDIM m_selection_height;
00366         ImageObtainer m_backgr_image;
00367         INT m_renderer_hint;
00368 };
00369
00371 #endif  // Apoxi_ItemRendererProperties_hpp
00372
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemTree.cpp File Reference

Gui/ItemTree.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ItemTree.hpp"
#include <Config/GuiEngineConfig.hpp>
#include "PaintDc.hpp"
#include "Action.hpp"
#include "Locale.hpp"

Include dependency graph for ItemTree.cpp:

Generated on Tue Jan 24 20:44:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemTree.hpp File Reference

Gui/ItemTree.hpp File Reference

#include <Kernel/Timer.hpp>
#include <Gui/AbstractItemGrid.hpp>
#include <Gui/ItemContainer.hpp>

Include dependency graph for ItemTree.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ItemTree

Defines

#define | Apoxi_ItemTree_hpp

Define Documentation

#define Apoxi_ItemTree_hpp

Generated on Tue Jan 24 20:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ItemTree.hpp Source File

Gui/ItemTree.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ItemTree_hpp)
00010 #define Apoxi_ItemTree_hpp
00014
00015 #include <Kernel/Timer.hpp>
00016 #include <Gui/AbstractItemGrid.hpp>
00017 #include <Gui/ItemContainer.hpp>
00018
00025 class ItemTree : public AbstractItemGrid {
00026     typedef AbstractItemGrid Base;
00027
00028     public:
00029         enum {
00030             ID = 14
00031         };
00032
00033         //
00034         ItemTree();
00035
00039         ItemTree(Control* parent, AbstractItemContainer* item_cont = 0);
00040
00042         virtual ~ItemTree();
00043
00047         void Init(Control* parent, AbstractItemContainer* item_cont = 0);
00048
00050         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00051
00053         virtual BOOLEAN IsInstanceOf(INT id) const;
00054
00056         virtual INT GetColumnCount() const;
00057
00066         virtual BOOLEAN Trigger(INT index = -1);
00067
00069         virtual AbstractItemContainer* GetItemContainer() const;
00070
00071     protected:
00073         virtual BOOLEAN OnMessage(const Message& msg);
00074
00076         virtual Rect GetItemRect(INT item_index) const;
00077
00079         virtual void DrawItemBorder(DeviceContext* dc,
00080                                     const Rect& cell_rect,
00081                                     const Rect& item_rect,
00082                                     INT item_index) const;
00083
00085         virtual void Refresh(const Rect& rect);
00086
00088         virtual void Cleanup();
00089
00090     private:
00091         AbstractItemContainer* m_root_cont;
00092         ItemContainer m_view_cont;
00093         Vector<INT> m_level;
00094
00095         void ToggleItemContainer(INT index);
00096
00097         BOOLEAN AddItemToView(Item* item);
00098         BOOLEAN InsertItemToView(INT index, Item* item);
00099         BOOLEAN RemoveItemFromView(INT index);
00100         void RemoveAllItemsFromView();
00101         void CopyRootItemsToView();
00102 };
00103
00105 #endif  // Apoxi_ItemTree_hpp
00106
00107
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/JapaneseTextRenderer.cpp File Reference

Gui/JapaneseTextRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "JapaneseTextRenderer.hpp"

Include dependency graph for JapaneseTextRenderer.cpp:

Generated on Tue Jan 24 20:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/JapaneseTextRenderer.hpp File Reference

Gui/JapaneseTextRenderer.hpp File Reference

#include <Gui/AbstractTextRenderer.hpp>
#include <Gui/EditorDocument.hpp>

Include dependency graph for JapaneseTextRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | JapaneseTextRenderer

Defines

#define | Apoxi_JapaneseTextRenderer_hpp

Define Documentation

#define Apoxi_JapaneseTextRenderer_hpp

Generated on Tue Jan 24 20:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/JapaneseTextRenderer.hpp Source File

Gui/JapaneseTextRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_JapaneseTextRenderer_hpp)
00010 #define Apoxi_JapaneseTextRenderer_hpp
00013
00014 #include <Gui/AbstractTextRenderer.hpp>
00015 #include <Gui/EditorDocument.hpp>
00016
00019 class JapaneseTextRenderer : public AbstractTextRenderer {
00020     typedef AbstractTextRenderer Base;
00021
00022     public:
00023         virtual ~JapaneseTextRenderer();
00024
00025         static JapaneseTextRenderer& GetInstance();
00026
00028         virtual INT WrapLine(const WCHAR* text,
00029                              const Font& font,
00030                              TextAttr text_attr,
00031                              INT char_count,
00032                              XYDIM max_width = -1,
00033                              WrapPolicy policy = (WrapPolicy)0, // this awkward construction is forced on us by the egold compiler. 0 is WhitespaceWrap
00034                              BOOLEAN include_gap_at_end = FALSE,
00035                              Size* total_size = 0,
00036                              INT* ws_at_eol_count = 0,
00037                              XYDIM* ws_at_eol_width = 0,
00038                              INT* last_completely_fitting_word_length = 0);
00039
00040     protected:
00042         virtual Size GetGlyph(const WCHAR* cur_text_pos,
00043                               const WCHAR* substitution_char,
00044                               INT n_chars,
00045                               GlyphPtr glyph,
00046                               INT& parsed_glyphs,
00047                               BOOLEAN& is_diacritic);
00048
00049     private:
00050         JapaneseTextRenderer();
00051
00058         BOOLEAN IsAllowedAsLineStart(WCHAR chr) const;
00059
00066         BOOLEAN IsAllowedAsLineEnd(WCHAR chr) const;
00067 };
00068
00069
00071 #endif // Apoxi_JapaneseTextRenderer_hpp
00072
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/LanguageManager.cpp File Reference

Gui/LanguageManager.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include "BasicPackConnector.hpp"
#include "TextPackConnector.hpp"
#include <Config/LocaleConfig.hpp>
#include <Config/MemoryConfig.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for LanguageManager.cpp:

Functions

const WCHAR * | AmbiguousTr (const WCHAR *text, INT ambiguous_hint)
const WCHAR * | Tr (const WCHAR *text)
Generated on Tue Jan 24 20:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/LanguageManager.hpp File Reference

Gui/LanguageManager.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/TextPackConnector.hpp>

Include dependency graph for LanguageManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LanguageManager

Defines

#define | Apoxi_LanguageManager_hpp
#define | APOXI_MAX_LANGUAGE_COUNT 16

Functions

const WCHAR * | AmbiguousTr (const WCHAR *text, INT ambiguous_hint)
const WCHAR * | Tr (const WCHAR *text)

Define Documentation

#define Apoxi_LanguageManager_hpp

Generated on Tue Jan 24 20:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/LanguageManager.hpp Source File

Gui/LanguageManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_LanguageManager_hpp)
00010 #define Apoxi_LanguageManager_hpp
00013
00014 #if !defined(APOXI_MAX_LANGUAGE_COUNT)
00015 #define APOXI_MAX_LANGUAGE_COUNT 16
00016 #endif
00017
00018 #include <Kernel/Types.hpp>
00019 #include <Gui/TextPackConnector.hpp>
00020
00023 class LanguageManager {
00024     public:
00025         enum LanguageType {
00026             English, German, Chinese, Arabic, Thai, Hebrew, Vietnamese, Japanese,
00027             Hindi, Italian, French, Greek, Afrikaans, Albanian, Armenian, Basque,
00028             Breton, Catalan, Corsican, Croatian, Czech, Danish, Dutch, Esperanto,
00029             Estonian, Finnish, Hungarian, Icelandic, Indonesian, Irish,
00030             Latin, Latvian, Lithuanian, Macedonian, Malay, Maltese, Norwegian,
00031             Polish, Portuguese, Romanian, Serbian, Slovak, Slovenian, Spanish,
00032             Swahili, Swedish, Turkish, Xhosa, Zulu, Bulgarian, Byelorussian,
00033             Russian, SerboCroatian, Ukrainian
00034         };
00035
00046         static void SetActiveLanguage(INT lang_id);
00047
00051         static INT GetActiveLanguage() { return m_active_lang_id; }
00052
00056         static BOOLEAN HasActiveLanguageChanged() { return m_has_lang_changed; }
00057
00065         static void SetActiveLanguageType(LanguageType lang_type);
00066
00070         static LanguageType GetActiveLanguageType();
00071
00082         static const WCHAR* Translate(const WCHAR* text, INT ambiguous_hint = -1);
00083
00089         static const WCHAR* ReTranslate(const WCHAR* text);
00090
00093         static INT MapIso639(const WCHAR* code);
00094
00096         static const WCHAR* GetString(INT index);
00097
00098     private:
00099         static BOOLEAN m_has_lang_changed;
00100         static BOOLEAN m_initialized;
00101         static INT m_active_lang_id;
00102         static INT16 m_last_lang[APOXI_MAX_LANGUAGE_COUNT];
00103 };
00104
00113 extern const WCHAR* Tr(const WCHAR* text);
00114
00128 extern const WCHAR* AmbiguousTr(const WCHAR* text, INT ambiguous_hint);
00129
00131 #endif  // Apoxi_LanguageManager_hpp
00132
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Layouter.cpp File Reference

Gui/Layouter.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Layouter.hpp"
#include "DeviceContext.hpp"
#include "Component.hpp"
#include "PaintDc.hpp"
#include "Locale.hpp"
#include "Control.hpp"

Include dependency graph for Layouter.cpp:

Generated on Tue Jan 24 20:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Layouter.hpp File Reference

Gui/Layouter.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Layouter

Defines

#define | Apoxi_Layouter_hpp

Define Documentation

#define Apoxi_Layouter_hpp

Generated on Tue Jan 24 20:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Layouter.hpp Source File

Gui/Layouter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Layouter_hpp)
00010 #define Apoxi_Layouter_hpp
00013
00014
00015 class DeviceContext;
00016 class Component;
00017
00078 class Layouter {
00079     public:
00081         enum XAlign {
00083             XDefault,
00085             Left,
00087             Center,
00089             Right
00090         };
00091
00093         enum YAlign {
00095             YDefault,
00097             Top,
00099             Middle,
00101             Bottom
00102         };
00103
00105         enum StretchUnit {
00107             Percent,
00109             Pixel
00110         };
00111
00113         Layouter(INT x_cells,
00114                  INT y_cells,
00115                  DeviceContext* dc = 0,
00116                  XAlign x_align = XDefault,
00117                  YAlign y_align = YDefault);
00118
00126         Layouter(INT x_cells,
00127                  INT y_cells,
00128                  const Control* control,
00129                  XAlign x_align = XDefault,
00130                  YAlign y_align = YDefault);
00131
00138         Layouter(INT x_cells,
00139                  INT y_cells,
00140                  const Rect& bounding_rect,
00141                  XAlign x_align = XDefault,
00142                  YAlign y_align = YDefault);
00143
00157         void Arrange(INT x_idx,
00158                      INT y_idx,
00159                      Component* content,
00160                      XAlign x_align = XDefault,
00161                      YAlign y_align = YDefault);
00162
00170         void Arrange(INT x_idx,
00171                      INT y_idx,
00172                      Layouter* layouter);
00173
00191         void StretchXGrid(const WCHAR* stretch_descr, StretchUnit unit = Percent);
00192
00210         void StretchYGrid(const WCHAR* stretch_descr, StretchUnit unit = Percent);
00211
00213         Size GetCellSize(INT row, INT column) const;
00214
00215     private:
00216         /* Target-Compiler makes problems when using this slim structure:
00217         struct {
00218             UINT x_align           : 2;
00219             UINT y_align           : 2;
00220             UINT x_cells           : 5;
00221             UINT y_cells           : 5;
00222             UINT x_stretch_unit : 1;
00223             UINT y_stretch_unit : 1;
00224         } m_bits;
00225         */
00226
00227         XYDIM m_x_pos;
00228         XYDIM m_y_pos;
00229         XYDIM m_cell_width;
00230         XYDIM m_cell_height;
00231
00232         INT m_x_cells;
00233         INT m_y_cells;
00234
00235         XAlign m_x_align;
00236         YAlign m_y_align;
00237
00238         const WCHAR* m_x_stretch_descr;
00239         const WCHAR* m_y_stretch_descr;
00240         StretchUnit m_x_stretch_unit;
00241         StretchUnit m_y_stretch_unit;
00242
00243         XYDIM GetCellWidth(INT index) const;
00244         XYDIM GetCellHeight(INT index) const;
00245         XYDIM GetPixelCount(INT index, BOOLEAN horizontal) const;
00246         XYDIM GetContentXPos(XAlign x_align, INT x_idx, XYDIM content_width) const;
00247         XYDIM GetContentYPos(YAlign y_align, INT y_idx, XYDIM content_height) const;
00248         void AssureValidCellSize();
00249 };
00250
00252 #endif  // Apoxi_Layouter_hpp
00253
00254
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/LayouterControl.hpp File Reference

Gui/LayouterControl.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 20:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/LayouterControl.hpp Source File

Gui/LayouterControl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("The class LayouterControl has been renamed to GridLayout. Please use " \
00010     "Gui/GridLayout.hpp instead.")
00011
00012 #if defined(APOXI_COMPAT_2_4_0)
00013     #include <Gui/GridLayout.hpp>
00014 #else
00015     #error Gui/LayouterControl has been renamed to Gui/GridLayout. Nevertheless, to use it from here define APOXI_COMPAT_2_4_0.
00016 #endif
00017
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Lib.hpp File Reference

Gui/Lib.hpp File Reference

#include <Gui/AbstractEditor.hpp>
#include <Gui/AbstractGrid.hpp>
#include <Gui/AbstractItemGrid.hpp>
#include <Gui/AbstractLineEditor.hpp>
#include <Gui/AbstractMenuList.hpp>
#include <Gui/AbstractMultiLineEditor.hpp>
#include <Gui/Action.hpp>
#include <Gui/Alert.hpp>
#include <Gui/AnimatedTextLine.hpp>
#include <Gui/Bitmap.hpp>
#include <Gui/Brush.hpp>
#include <Gui/CalculatorInputMapper.hpp>
#include <Gui/Caret.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/CheckBox.hpp>
#include <Gui/CheckBoxItem.hpp>
#include <Gui/CheckBoxList.hpp>
#include <Gui/ClientDc.hpp>
#include <Gui/CloseWindowAction.hpp>
#include <Gui/Color.hpp>
#include <Gui/ColorSegmentation.hpp>
#include <Gui/ColorTable.hpp>
#include <Gui/Component.hpp>
#include <Gui/CompoundItem.hpp>
#include <Gui/ContextMenu.hpp>
#include <Gui/Control.hpp>
#include <Gui/ControlDc.hpp>
#include <Gui/ControlFrameView.hpp>
#include <Gui/DateCompoundItem.hpp>
#include <Gui/DateEditor.hpp>
#include <Gui/DateEditorDocument.hpp>
#include <Gui/DateTimeInputMapper.hpp>
#include <Gui/DefaultCaret.hpp>
#include <Gui/DeviceContext.hpp>
#include <Gui/DrawableObject.hpp>
#include <Gui/EditorDocument.hpp>
#include <Gui/AtomItem.hpp>
#include <Gui/EditorLine.hpp>
#include <Gui/Font.hpp>
#include <Gui/FlowLayout.hpp>
#include <Gui/FrameDc.hpp>
#include <Gui/GridLayout.hpp>
#include <Gui/ImageBox.hpp>
#include <Gui/IconSet.hpp>
#include <Gui/IconState.hpp>
#include <Gui/ItemGrid.hpp>
#include <Gui/ItemMenu.hpp>
#include <Gui/ItemTree.hpp>
#include <Gui/InputMapper.hpp>
#include <Gui/LanguageManager.hpp>
#include <Gui/Layouter.hpp>
#include <Gui/LineEditor.hpp>
#include <Gui/Locale.hpp>
#include <Gui/MessageBox.hpp>
#include <Gui/Model.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/MultiLineEditor.hpp>
#include <Gui/MultiTapCaret.hpp>
#include <Gui/MultiTapInputMapper.hpp>
#include <Gui/NativeImage.hpp>
#include <Gui/NumericInputMapper.hpp>
#include <Gui/OpenWindowAction.hpp>
#include <Gui/OpenContextMenuAction.hpp>
#include <Gui/PagingMap.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/PasswordEditor.hpp>
#include <Gui/Pen.hpp>
#include <Gui/PhoneNumberInputMapper.hpp>
#include <Gui/Point.hpp>
#include <Gui/PositionIndicator.hpp>
#include <Gui/PredInputMapper.hpp>
#include <Gui/ProgressBar.hpp>
#include <Gui/ProviderListBox.hpp>
#include <Gui/PushButton.hpp>
#include <Gui/RadioButton.hpp>
#include <Gui/RadioButtonList.hpp>
#include <Gui/RadioButtonItem.hpp>
#include <Gui/Rect.hpp>
#include <Gui/Size.hpp>
#include <Gui/SyncPaintDc.hpp>
#include <Gui/TextBox.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <Gui/TextEditorDocument.hpp>
#include <Gui/TextFormat.hpp>
#include <Gui/TextLine.hpp>
#include <Gui/Theme.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/TimeCompoundItem.hpp>
#include <Gui/TimeEditor.hpp>
#include <Gui/TimeEditorDocument.hpp>
#include <Gui/View.hpp>
#include <Gui/Window.hpp>
#include <Gui/WindowFrameView.hpp>
#include <Gui/AbstractToggleAction.hpp>
#include <Gui/ToggleActionGroup.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <Gui/CheckBoxAction.hpp>
#include <Gui/BidiManager.hpp>

Include dependency graph for Lib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Gui_Lib_hpp

Define Documentation

#define Gui_Lib_hpp

Generated on Tue Jan 24 14:54:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Lib.hpp Source File

Gui/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Gui_Lib_hpp)
00010 #define Gui_Lib_hpp
00013
00014 #include <Gui/AbstractEditor.hpp>
00015 #include <Gui/AbstractGrid.hpp>
00016 #include <Gui/AbstractItemGrid.hpp>
00017 #include <Gui/AbstractLineEditor.hpp>
00018 #include <Gui/AbstractMenuList.hpp>
00019 #include <Gui/AbstractMultiLineEditor.hpp>
00020 #include <Gui/Action.hpp>
00021 #include <Gui/Alert.hpp>
00022 #include <Gui/AnimatedTextLine.hpp>
00023 #include <Gui/Bitmap.hpp>
00024 #include <Gui/Brush.hpp>
00025 #include <Gui/CalculatorInputMapper.hpp>
00026 #include <Gui/Caret.hpp>
00027 #include <Gui/CharItem.hpp>
00028 #include <Gui/CheckBox.hpp>
00029 #include <Gui/CheckBoxItem.hpp>
00030 #include <Gui/CheckBoxList.hpp>
00031 #include <Gui/ClientDc.hpp>
00032 #include <Gui/CloseWindowAction.hpp>
00033 #include <Gui/Color.hpp>
00034 #include <Gui/ColorSegmentation.hpp>
00035 #include <Gui/ColorTable.hpp>
00036 #include <Gui/Component.hpp>
00037 #include <Gui/CompoundItem.hpp>
00038 #include <Gui/ContextMenu.hpp>
00039 #include <Gui/Control.hpp>
00040 #include <Gui/ControlDc.hpp>
00041 #include <Gui/ControlFrameView.hpp>
00042 #include <Gui/DateCompoundItem.hpp>
00043 #include <Gui/DateEditor.hpp>
00044 #include <Gui/DateEditorDocument.hpp>
00045 #include <Gui/DateTimeInputMapper.hpp>
00046 #include <Gui/DefaultCaret.hpp>
00047 #include <Gui/DeviceContext.hpp>
00048 #include <Gui/DrawableObject.hpp>
00049 #include <Gui/EditorDocument.hpp>
00050 #include <Gui/AtomItem.hpp>
00051 #include <Gui/EditorLine.hpp>
00052 #include <Gui/Font.hpp>
00053 #include <Gui/FlowLayout.hpp>
00054 #include <Gui/FrameDc.hpp>
00055 #include <Gui/GridLayout.hpp>
00056 #include <Gui/ImageBox.hpp>
00057 #include <Gui/IconSet.hpp>
00058 #include <Gui/IconState.hpp>
00059 #include <Gui/ItemGrid.hpp>
00060 #include <Gui/ItemMenu.hpp>
00061 #include <Gui/ItemTree.hpp>
00062 #include <Gui/InputMapper.hpp>
00063 #include <Gui/LanguageManager.hpp>
00064 #include <Gui/Layouter.hpp>
00065 #include <Gui/LineEditor.hpp>
00066 #include <Gui/Locale.hpp>
00067 #include <Gui/MessageBox.hpp>
00068 #include <Gui/Model.hpp>
00069 #include <Gui/MsgTypes.hpp>
00070 #include <Gui/MultiLineEditor.hpp>
00071 #include <Gui/MultiTapCaret.hpp>
00072 #include <Gui/MultiTapInputMapper.hpp>
00073 #include <Gui/NativeImage.hpp>
00074 #include <Gui/NumericInputMapper.hpp>
00075 #include <Gui/OpenWindowAction.hpp>
00076 #include <Gui/OpenContextMenuAction.hpp>
00077 #include <Gui/PagingMap.hpp>
00078 #include <Gui/PaintDc.hpp>
00079 #include <Gui/PasswordEditor.hpp>
00080 #include <Gui/Pen.hpp>
00081 #include <Gui/PhoneNumberInputMapper.hpp>
00082 #include <Gui/Point.hpp>
00083 #include <Gui/PositionIndicator.hpp>
00084 #include <Gui/PredInputMapper.hpp>
00085 #include <Gui/ProgressBar.hpp>
00086 #include <Gui/ProviderListBox.hpp>
00087 #include <Gui/PushButton.hpp>
00088 #include <Gui/RadioButton.hpp>
00089 #include <Gui/RadioButtonList.hpp>
00090 #include <Gui/RadioButtonItem.hpp>
00091 #include <Gui/Rect.hpp>
00092 #include <Gui/Size.hpp>
00093 #include <Gui/SyncPaintDc.hpp>
00094 #include <Gui/TextBox.hpp>
00095 #include <Gui/TextCompoundItem.hpp>
00096 #include <Gui/TextEditorDocument.hpp>
00097 #include <Gui/TextFormat.hpp>
00098 #include <Gui/TextLine.hpp>
00099 #include <Gui/Theme.hpp>
00100 #include <Gui/ThemeManager.hpp>
00101 #include <Gui/TimeCompoundItem.hpp>
00102 #include <Gui/TimeEditor.hpp>
00103 #include <Gui/TimeEditorDocument.hpp>
00104 #include <Gui/View.hpp>
00105 #include <Gui/Window.hpp>
00106 #include <Gui/WindowFrameView.hpp>
00107 #include <Gui/AbstractToggleAction.hpp>
00108 #include <Gui/ToggleActionGroup.hpp>
00109 #include <Gui/RadioButtonGroup.hpp>
00110 #include <Gui/RadioButtonAction.hpp>
00111 #include <Gui/CheckBoxAction.hpp>
00112 #include <Gui/BidiManager.hpp>
00113
00114 // Classes which got obsolete with APOXI-version 1.10.0
00115 #ifdef APOXI_COMPAT_1_9_0
00116     #include <Gui/AbstractListBox.hpp>
00117     #include <Gui/AbstractMenuAccessor.hpp>
00118     #include <Gui/ActionExtension.hpp>
00119     #include <Gui/CancelAction.hpp>
00120     #include <Gui/ConfirmAction.hpp>
00121     #include <Gui/DialogWindow.hpp>
00122     #include <Gui/Menu.hpp>
00123     #include <Gui/MenuAccessor.hpp>
00124     #include <Gui/SetLanguageAction.hpp>
00125     #include <Gui/SetThemeAction.hpp>
00126     #include <Gui/SoftkeyBar.hpp>
00127     #include <Gui/TextList.hpp>
00128     #include <Gui/TextMenuAccessor.hpp>
00129 #endif
00130
00131 // Classes which got obsolete with APOXI-version 1.8.0
00132 #ifdef APOXI_COMPAT_1_7_0
00133     #include <Gui/MultiTabInputMapper.hpp>
00134     #include <Gui/Animation.hpp>
00135 #endif
00136
00138 #endif  // Gui_Lib_hpp
00139
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/LineEditor.cpp File Reference

Gui/LineEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Control.hpp"
#include "PaintDc.hpp"
#include "LineEditor.hpp"
#include "DefaultCaret.hpp"
#include "InputMapper.hpp"
#include "NumericInputMapper.hpp"
#include "MultiTapInputMapper.hpp"
#include "PhoneNumberInputMapper.hpp"

Include dependency graph for LineEditor.cpp:

Generated on Tue Jan 24 20:45:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/LineEditor.hpp File Reference

Gui/LineEditor.hpp File Reference

#include <Gui/AbstractLineEditor.hpp>
#include <Gui/TextEditorDocument.hpp>
#include <Gui/InputMapper.hpp>
#include <Gui/View.hpp>

Include dependency graph for LineEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LineEditor

Defines

#define | Apoxi_LineEditor_hpp

Define Documentation

#define Apoxi_LineEditor_hpp

Generated on Tue Jan 24 20:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/LineEditor.hpp Source File

Gui/LineEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_LineEditor_hpp)
00011 #define Apoxi_LineEditor_hpp
00016
00017 #include <Gui/AbstractLineEditor.hpp>
00018 #include <Gui/TextEditorDocument.hpp>
00019 #include <Gui/InputMapper.hpp>
00020 #include <Gui/View.hpp>
00021
00022 class DefaultCaret;
00023
00026 class LineEditor : public AbstractLineEditor {
00027     typedef AbstractLineEditor Base;
00028
00029     public:
00030         enum {
00031             ID = 32
00032         };
00033
00036         LineEditor();
00037
00042         LineEditor(Control* parent,
00043                    INT input_mapper_id,
00044                    const WCHAR* text = 0);
00045
00046         virtual ~LineEditor();
00047
00052         void Init(Control* parent,
00053                   INT input_mapper_id,
00054                   const WCHAR* text = 0);
00055
00058         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00059
00061         virtual BOOLEAN IsInstanceOf(INT id) const;
00062
00064         void SetText(const WCHAR* text);
00065
00067         const WString& GetText() const;
00068
00071         void SetMaxTextLength(INT max_tex_len);
00072
00075         INT GetMaxTextLength() const;
00076
00080         void SetFont(const Font& font);
00081
00085         const Font& GetFont() const;
00086
00087     protected:
00089         virtual Model* CreateModel() const;
00090
00092         virtual XYDIM GetDefaultHeight() const;
00093
00094     private:
00095         TextEditorDocument* GetMyDocument() { return (TextEditorDocument*)GetModel(); } //lint !e1762
00096         const TextEditorDocument* GetMyDocument() const { return (const TextEditorDocument*)GetModel(); }
00097
00098         DefaultCaret* GetMyCaret() { return (DefaultCaret*)GetCaret(); }
00099 };
00100
00102 #endif  // Apoxi_LineEditor_hpp
00103
00104
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Locale.cpp File Reference

Gui/Locale.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Locale.hpp"
#include "BidiManager.hpp"
#include <Config/LocaleConfig.hpp>

Include dependency graph for Locale.cpp:

Generated on Tue Jan 24 20:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Locale.hpp File Reference

Gui/Locale.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>

Include dependency graph for Locale.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Locale
struct | Locale::LocaleData

Defines

#define | Apoxi_Locale_hpp

Define Documentation

#define Apoxi_Locale_hpp

Generated on Tue Jan 24 20:45:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Locale.hpp Source File

Gui/Locale.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Locale_hpp)
00010 #define Apoxi_Locale_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/Date.hpp>
00016 #include <Auxiliary/Time.hpp>
00017
00018 struct PagingMap;
00019
00021 class Locale {
00022     public:
00024         enum TextAlignment {
00026             LeftToRight,
00028             RightToLeft
00029         };
00030
00031         struct LocaleData {
00032             const WCHAR     **times;
00033             const WCHAR     **dates;
00034             WCHAR           decimal_separator;
00035             WCHAR           thousand_separator;
00036             const WCHAR     *currency_symbol;
00037             INT             lang_id;
00038             TextAlignment   text_align;
00039         };
00040
00045         static void Set(const LocaleData& locale_data);
00046
00048         static void SetTimeFormat(TimeFormat time_format, const WCHAR* time_str) { m_locale.times[time_format] = time_str; }
00049
00051         static const WCHAR* GetTimeFormat(TimeFormat time_format) { return m_locale.times[time_format]; }
00052
00054         static void SetDateFormat(DateFormat date_format, const WCHAR* date_str) { m_locale.dates[date_format] = date_str; }
00055
00057         static const WCHAR* GetDateFormat(DateFormat date_format) { return m_locale.dates[date_format]; }
00058
00060         static void SetDecimalSeparator(WCHAR separator) { m_locale.decimal_separator = separator; }
00061
00063         static WCHAR GetDecimalSeparator() { return m_locale.decimal_separator; }
00064
00066         static void SetThousandSeparator(WCHAR separator) { m_locale.thousand_separator = separator; }
00067
00069         static WCHAR GetThousandSeparator() { return m_locale.thousand_separator; }
00070
00072         static void SetCurrencySymbol(const WCHAR* symbol) { m_locale.currency_symbol = symbol; }
00073
00075         static const WCHAR* GetCurrencySymbol() { return m_locale.currency_symbol; }
00076
00078         static void SetLanguage(INT lang_id) { m_locale.lang_id = lang_id; }
00079
00081         static INT GetLanguage() { return m_locale.lang_id; }
00082
00084         static void SetTextAlignment(TextAlignment text_align) { m_locale.text_align = text_align; }
00085
00087         static TextAlignment GetTextAlignment() { return m_locale.text_align; }
00088
00089     private:
00090         static LocaleData m_locale;
00091 };
00092
00094 #endif  // Apoxi_Locale_hpp
00095
00096
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Menu.hpp File Reference

Gui/Menu.hpp File Reference

#include <Compat/Menu.hpp>

Include dependency graph for Menu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:21:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Menu.hpp Source File

Gui/Menu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class Menu has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/Menu.hpp>
00014
00015
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MenuAccessor.hpp File Reference

Gui/MenuAccessor.hpp File Reference

#include <Compat/MenuAccessor.hpp>

Include dependency graph for MenuAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:21:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MenuAccessor.hpp Source File

Gui/MenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class MenuAccessor has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/MenuAccessor.hpp>
00014
00015
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MenuTextIterator.hpp File Reference

Gui/MenuTextIterator.hpp File Reference

#include <Compat/MenuTextIterator.hpp>

Include dependency graph for MenuTextIterator.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:21:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MenuTextIterator.hpp Source File

Gui/MenuTextIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class MenuTextIterator has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/MenuTextIterator.hpp>
00014
00015
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MenuTextPtrArrayIterator.hpp File Reference

Gui/MenuTextPtrArrayIterator.hpp File Reference

#include <Compat/MenuTextPtrArrayIterator.hpp>

Include dependency graph for MenuTextPtrArrayIterator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:21:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MenuTextPtrArrayIterator.hpp Source File

Gui/MenuTextPtrArrayIterator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class MenuTextPtrArrayIterator has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/MenuTextPtrArrayIterator.hpp>
00014
00015
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MessageBox.cpp File Reference

Gui/MessageBox.cpp File Reference

#include "Gui/PreComp.hpp"
#include "MessageBox.hpp"
#include "Desktop.hpp"
#include <Devices/Display.hpp>
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for MessageBox.cpp:

Generated on Tue Jan 24 20:45:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MessageBox.hpp File Reference

Gui/MessageBox.hpp File Reference

#include <Gui/Window.hpp>
#include <Gui/MultiLineEditor.hpp>
#include <Gui/Action.hpp>

Include dependency graph for MessageBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MessageBox

Defines

#define | Apoxi_MessageBox_hpp

Define Documentation

#define Apoxi_MessageBox_hpp

Generated on Tue Jan 24 20:45:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MessageBox.hpp Source File

Gui/MessageBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MessageBox_hpp)
00010 #define Apoxi_MessageBox_hpp
00014
00015 #include <Gui/Window.hpp>
00016 #include <Gui/MultiLineEditor.hpp>
00017 #include <Gui/Action.hpp>
00018
00019 #ifdef APOXI_COMPAT_1_9_0
00020     #include <Gui/SoftkeyBar.hpp>
00021 #endif
00022
00027 class MessageBox : public Window {
00028     typedef Window Base;
00029
00030     public:
00031         enum {
00032             ID = 16
00033         };
00034
00036         enum Type {
00040             Ok,
00042             OkCancel,
00044             YesNo
00045         };
00046
00048         enum ReturnId {
00050             OkId,
00052             CancelId,
00054             YesId,
00056             NoId
00057         };
00058
00061         MessageBox();
00062
00066         MessageBox(Type type, const WCHAR* title = 0, const WCHAR* message = 0);
00067
00068         virtual ~MessageBox();
00069
00073         void Init(Type type, const WCHAR* title = 0, const WCHAR* message = 0);
00074
00077         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00078
00080         virtual BOOLEAN IsInstanceOf(INT id) const;
00081
00086         virtual INT Open(const WCHAR* title = 0, const WCHAR* message = 0);
00087
00088     protected:
00090         virtual void OnActionExecuted(Action* action);
00091
00093         virtual void OnLayoutClient();
00094
00095     private:
00096         Type m_type;
00097         Action m_confirm_action;
00098         Action m_cancel_action;
00099         MultiLineEditor m_msg_container;
00100 #ifdef APOXI_COMPAT_1_9_0
00101         SoftkeyBar m_softkey_bar;
00102 #endif
00103         void InitProperties(MessageBox::Type type, const WCHAR* title, const WCHAR* message);
00104 };
00105
00107 #endif  // Apoxi_MessageBox_hpp
00108
00109
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Model.cpp File Reference

Gui/Model.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Model.hpp"

Include dependency graph for Model.cpp:

Generated on Tue Jan 24 20:45:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Model.hpp File Reference

Gui/Model.hpp File Reference

#include <Kernel/Dispatcher.hpp>

Include dependency graph for Model.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Model

Defines

#define | Apoxi_Model_hpp

Define Documentation

#define Apoxi_Model_hpp

Generated on Tue Jan 24 20:45:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Model.hpp Source File

Gui/Model.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Model_hpp)
00010 #define Apoxi_Model_hpp
00013
00014 #include <Kernel/Dispatcher.hpp>
00015
00020 class Model : public Dispatcher {
00021     public:
00023         Model();
00024
00026         virtual ~Model();
00027
00029         void Init();
00030
00031     protected:
00033         virtual BOOLEAN OnMessage(const Message& msg);
00034 };
00035
00037 #endif  // Apoxi_Model_hpp
00038
00039
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MsgTypes.cpp File Reference

Gui/MsgTypes.cpp File Reference

#include "Gui/PreComp.hpp"
#include "MsgTypes.hpp"
#include <Kernel/Application.hpp>

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MsgTypes.hpp File Reference

Gui/MsgTypes.hpp File Reference

#include <Kernel/MsgTypes.hpp>
#include <Auxiliary/WString.hpp>
#include <Gui/Rect.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AragonMsg
class | CloseWindowMsg
class | ContextMenuClosedMsg
class | DeleteComponentMsg
class | FocusNextControlMsg
class | FocusPreviousControlMsg
class | ImageDecodingProgressMsg
class | ImageDrawingInterruptedMsg
class | ImageEncodingProgressMsg
class | InvalidateMsg
class | ItemRendererPropertiesChangedMsg
class | RedrawDisplayMsg
class | RefreshComponentMsg
class | SelectionChangedMsg
class | T9AddWordMsg
class | T9EnteredUnknownWordMsg
class | T9MatrixModeKeypressed
class | T9NoWordFoundMsg
class | T9SymbolEntryRequestMsg
class | ViewfinderErrorMsg
class | Zi8AddWordMsg
class | Zi8EnteredUnknownWordMsg
class | Zi8NoWordFoundMsg

Defines

#define | MsgTypes_hpp__ST_1092996111155

Define Documentation

#define MsgTypes_hpp__ST_1092996111155

Generated on Tue Jan 24 14:56:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MsgTypes.hpp Source File

Gui/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "apoxi\development\msg\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014 #if !defined(MsgTypes_hpp__ST_1092996111155)
00015 #define MsgTypes_hpp__ST_1092996111155
00016 #include <Kernel/MsgTypes.hpp>
00017 #include <Auxiliary/WString.hpp>
00018 #include <Gui/Rect.hpp>
00019
00020 class ContextMenu;
00021 class Component;
00022 class AbstractMenuAccessor;
00023 class Image;
00024 class Dispatcher;
00025 class Menu;
00026 class Window;
00027 class BinData;
00028 class ImageEncoder;
00029 class AbstractGrid;
00030
00031 /* ----------------------------------------------------------------------
00032     Classes
00033     ---------------------------------------------------------------------- */
00034 /*  ======================================================================
00035     Class FocusNextControlMsg
00036     ====================================================================== */
00039 class FocusNextControlMsg : public ControlMsg {
00040     public:
00041         FocusNextControlMsg(Control* control);
00042         virtual ~FocusNextControlMsg();
00043
00044         virtual const MsgMetaData& GetMetaData() const;
00045         virtual Message* Clone() const;
00046
00047         enum  {
00048             ID = 1100
00049             };
00050
00051     private:
00052         static const MsgMetaData m_meta_data;
00053
00054     };
00055 /*  ======================================================================
00056     Class FocusPreviousControlMsg
00057     ====================================================================== */
00060 class FocusPreviousControlMsg : public ControlMsg {
00061     public:
00062         FocusPreviousControlMsg(Control* control);
00063         virtual ~FocusPreviousControlMsg();
00064
00065         virtual const MsgMetaData& GetMetaData() const;
00066         virtual Message* Clone() const;
00067
00068         enum  {
00069             ID = 1101
00070             };
00071
00072     private:
00073         static const MsgMetaData m_meta_data;
00074
00075     };
00076 /*  ======================================================================
00077     Class SelectionChangedMsg
00078     ====================================================================== */
00082 class SelectionChangedMsg : public ControlMsg {
00083     public:
00084         SelectionChangedMsg(Control* control, INT index, AbstractGrid* sender = 0);
00085         virtual ~SelectionChangedMsg();
00086
00087         virtual const MsgMetaData& GetMetaData() const;
00088         INT GetIndex() const { return m_index; }
00089         const AbstractGrid* GetSender() const { return m_sender; }
00090         virtual Message* Clone() const;
00091
00092         enum  {
00093             ID = 1102
00094             };
00095
00096     private:
00097         static const MsgMetaData m_meta_data;
00098         INT m_index;
00099         AbstractGrid* m_sender;
00100
00101     };
00102 #ifdef APOXI_COMPAT_1_9_0
00103 /*  ======================================================================
00104     Class ConfirmMsg
00105     ====================================================================== */
00108 class ConfirmMsg : public Message {
00109     public:
00110         ConfirmMsg();
00111         virtual ~ConfirmMsg();
00112
00113         virtual const MsgMetaData& GetMetaData() const;
00114         virtual Message* Clone() const;
00115
00116         enum  {
00117             ID = 1011
00118             };
00119
00120     private:
00121         static const MsgMetaData m_meta_data;
00122
00123     };
00124 #endif //APOXI_COMPAT_1_9_0
00125 #ifdef APOXI_COMPAT_1_9_0
00126 /*  ======================================================================
00127     Class CancelMsg
00128     ====================================================================== */
00131 class CancelMsg : public Message {
00132     public:
00133         CancelMsg();
00134         virtual ~CancelMsg();
00135
00136         virtual const MsgMetaData& GetMetaData() const;
00137         virtual Message* Clone() const;
00138
00139         enum  {
00140             ID = 1012
00141             };
00142
00143     private:
00144         static const MsgMetaData m_meta_data;
00145
00146     };
00147 #endif //APOXI_COMPAT_1_9_0
00148 #ifdef APOXI_COMPAT_1_9_0
00149 /*  ======================================================================
00150     Class SoftkeyPressedMsg
00151     ====================================================================== */
00154 class SoftkeyPressedMsg : public Message {
00155     public:
00156         SoftkeyPressedMsg(INT index);
00157         virtual ~SoftkeyPressedMsg();
00158
00159         virtual const MsgMetaData& GetMetaData() const;
00160         void SetIndex(INT index) { m_index = index; }
00161         INT GetIndex() const { return m_index; }
00162         virtual Message* Clone() const;
00163
00164         enum  {
00165             ID = 1013
00166             };
00167
00168     private:
00169         static const MsgMetaData m_meta_data;
00170         INT m_index;
00171
00172     };
00173 #endif //APOXI_COMPAT_1_9_0
00174 #ifdef APOXI_COMPAT_1_9_0
00175 /*  ======================================================================
00176     Class SoftkeyReleasedMsg
00177     ====================================================================== */
00180 class SoftkeyReleasedMsg : public Message {
00181     public:
00182         SoftkeyReleasedMsg(INT index);
00183         virtual ~SoftkeyReleasedMsg();
00184
00185         virtual const MsgMetaData& GetMetaData() const;
00186         void SetIndex(INT index) { m_index = index; }
00187         INT GetIndex() const { return m_index; }
00188         virtual Message* Clone() const;
00189
00190         enum  {
00191             ID = 1014
00192             };
00193
00194     private:
00195         static const MsgMetaData m_meta_data;
00196         INT m_index;
00197
00198     };
00199 #endif //APOXI_COMPAT_1_9_0
00200 #ifdef APOXI_COMPAT_1_9_0
00201 /*  ======================================================================
00202     Class MenuTriggeredMsg
00203     ====================================================================== */
00206 class MenuTriggeredMsg : public Message {
00207     public:
00208         MenuTriggeredMsg(AbstractMenuAccessor* menu_accessor, INT index);
00209         virtual ~MenuTriggeredMsg();
00210
00211         virtual const MsgMetaData& GetMetaData() const;
00212         void SetMenuAccessor(AbstractMenuAccessor* menu_accessor) { m_menu_accessor = menu_accessor; }
00213         AbstractMenuAccessor* GetMenuAccessor() const { return m_menu_accessor; }
00214         void SetIndex(INT index) { m_index = index; }
00215         INT GetIndex() const { return m_index; }
00216         virtual Message* Clone() const;
00217
00218         enum  {
00219             ID = 1115
00220             };
00221
00222     private:
00223         static const MsgMetaData m_meta_data;
00224         AbstractMenuAccessor* m_menu_accessor;
00225         INT m_index;
00226
00227     };
00228 #endif //APOXI_COMPAT_1_9_0
00229 #ifdef APOXI_COMPAT_1_9_0
00230 /*  ======================================================================
00231     Class MenuBackMsg
00232     ====================================================================== */
00235 class MenuBackMsg : public Message {
00236     public:
00237         MenuBackMsg(AbstractMenuAccessor* menu_accessor);
00238         virtual ~MenuBackMsg();
00239
00240         virtual const MsgMetaData& GetMetaData() const;
00241         void SetMenuAccessor(AbstractMenuAccessor* menu_accessor) { m_menu_accessor = menu_accessor; }
00242         AbstractMenuAccessor* GetMenuAccessor() const { return m_menu_accessor; }
00243         virtual Message* Clone() const;
00244
00245         enum  {
00246             ID = 1116
00247             };
00248
00249     private:
00250         static const MsgMetaData m_meta_data;
00251         AbstractMenuAccessor* m_menu_accessor;
00252
00253     };
00254 #endif //APOXI_COMPAT_1_9_0
00255 #ifdef APOXI_COMPAT_1_9_0
00256 /*  ======================================================================
00257     Class IdleModeStateChangedMsg
00258     ====================================================================== */
00262 class IdleModeStateChangedMsg : public Message {
00263     public:
00264         IdleModeStateChangedMsg(BOOLEAN idle);
00265         virtual ~IdleModeStateChangedMsg();
00266
00267         virtual const MsgMetaData& GetMetaData() const;
00268         void SetIdle(BOOLEAN idle) { m_idle = idle; }
00269         BOOLEAN IsIdle() const { return m_idle; }
00270         virtual Message* Clone() const;
00271
00272         enum  {
00273             ID = 1117
00274             };
00275
00276     private:
00277         static const MsgMetaData m_meta_data;
00278         BOOLEAN m_idle;
00279
00280     };
00281 #endif //APOXI_COMPAT_1_9_0
00282 /*  ======================================================================
00283     Class InvalidateMsg
00284     ====================================================================== */
00292 class InvalidateMsg : public Message {
00293     public:
00294         InvalidateMsg(Component* component, Dispatcher* dispatcher, const Rect& rect);
00295         virtual ~InvalidateMsg();
00296
00297         virtual const MsgMetaData& GetMetaData() const;
00298         Component* GetComponent() const { return m_component; }
00299         Dispatcher* GetDispatcher() const { return m_dispatcher; }
00300         const Rect& GetRect() const { return m_rect; }
00301         virtual Message* Clone() const;
00302
00303         enum  {
00304             ID = 1118
00305             };
00306
00307     private:
00308         static const MsgMetaData m_meta_data;
00309         Component* m_component;
00310         Dispatcher* m_dispatcher;
00311         Rect m_rect;
00312
00313     };
00314 #ifdef APOXI_COMPAT_1_9_0
00315 /*  ======================================================================
00316     Class MenuAccessorChangedMsg
00317     ====================================================================== */
00321 class MenuAccessorChangedMsg : public Message {
00322     public:
00323         MenuAccessorChangedMsg(Menu* menu, AbstractMenuAccessor* menu_accessor);
00324         virtual ~MenuAccessorChangedMsg();
00325
00326         virtual const MsgMetaData& GetMetaData() const;
00327         Menu* GetMenu() const { return m_menu; }
00328         AbstractMenuAccessor* GetMenuAccessor() const { return m_menu_accessor; }
00329         virtual Message* Clone() const;
00330
00331         enum  {
00332             ID = 1119
00333             };
00334
00335     private:
00336         static const MsgMetaData m_meta_data;
00337         Menu* m_menu;
00338         AbstractMenuAccessor* m_menu_accessor;
00339
00340     };
00341 #endif //APOXI_COMPAT_1_9_0
00342 /*  ======================================================================
00343     Class ImageDecodingProgressMsg
00344     ====================================================================== */
00348 class ImageDecodingProgressMsg : public Message {
00349     public:
00350         ImageDecodingProgressMsg(const Image* image, INT progress);
00351         virtual ~ImageDecodingProgressMsg();
00352
00353         virtual const MsgMetaData& GetMetaData() const;
00354         const Image* GetImage() const { return m_image; }
00355         INT GetProgress() const { return m_progress; }
00356         virtual Message* Clone() const;
00357
00358         enum  {
00359             ID = 1120
00360             };
00361
00362     private:
00363         static const MsgMetaData m_meta_data;
00364         const Image* m_image;
00365         INT m_progress;
00366
00367     };
00368 /*  ======================================================================
00369     Class ViewfinderErrorMsg
00370     ====================================================================== */
00371 class ViewfinderErrorMsg : public Message {
00372     public:
00373         ViewfinderErrorMsg();
00374         virtual ~ViewfinderErrorMsg();
00375
00376         virtual const MsgMetaData& GetMetaData() const;
00377         virtual Message* Clone() const;
00378
00379         enum  {
00380             ID = 1121
00381             };
00382
00383     private:
00384         static const MsgMetaData m_meta_data;
00385
00386     };
00387 /*  ======================================================================
00388     Class ContextMenuClosedMsg
00389     ====================================================================== */
00391 class ContextMenuClosedMsg : public Message {
00392     public:
00393         ContextMenuClosedMsg(ContextMenu* context_menu);
00394         virtual ~ContextMenuClosedMsg();
00395
00396         virtual const MsgMetaData& GetMetaData() const;
00397         ContextMenu* GetContextMenu() const { return m_context_menu; }
00398         virtual Message* Clone() const;
00399
00400         enum  {
00401             ID = 1122
00402             };
00403
00404     private:
00405         static const MsgMetaData m_meta_data;
00406         ContextMenu* m_context_menu;
00407
00408     };
00409 /*  ======================================================================
00410     Class RefreshComponentMsg
00411     ====================================================================== */
00413 class RefreshComponentMsg : public Message {
00414     public:
00415         RefreshComponentMsg(Component* component);
00416         virtual ~RefreshComponentMsg();
00417
00418         virtual const MsgMetaData& GetMetaData() const;
00419         Component* GetComponent() const { return m_component; }
00420         virtual Message* Clone() const;
00421
00422         enum  {
00423             ID = 1123
00424             };
00425
00426     private:
00427         static const MsgMetaData m_meta_data;
00428         Component* m_component;
00429
00430     };
00431 /*  ======================================================================
00432     Class CloseWindowMsg
00433     ====================================================================== */
00435 class CloseWindowMsg : public Message {
00436     public:
00437         CloseWindowMsg(Window* window, INT exit_code = 0);
00438         virtual ~CloseWindowMsg();
00439
00440         virtual const MsgMetaData& GetMetaData() const;
00441         Window* GetWindow() const { return m_window; }
00442         INT GetExitCode() const { return m_exit_code; }
00443         virtual Message* Clone() const;
00444
00445         enum  {
00446             ID = 1124
00447             };
00448
00449     private:
00450         static const MsgMetaData m_meta_data;
00451         Window* m_window;
00452         INT m_exit_code;
00453
00454     };
00455 /*  ======================================================================
00456     Class AragonMsg
00457     ====================================================================== */
00459 class AragonMsg : public Message {
00460     public:
00461         AragonMsg(UINT32 command, BinData* data);
00462         virtual ~AragonMsg();
00463
00464         virtual const MsgMetaData& GetMetaData() const;
00465         UINT32 GetCommand() const { return m_command; }
00466         BinData* GetData() const { return m_data; }
00467         virtual Message* Clone() const;
00468
00469         enum  {
00470             ID = 1125
00471             };
00472
00473     private:
00474         static const MsgMetaData m_meta_data;
00475         UINT32 m_command;
00476         BinData* m_data;
00477
00478     };
00479 /*  ======================================================================
00480     Class T9NoWordFoundMsg
00481     ====================================================================== */
00484 class T9NoWordFoundMsg : public Message {
00485     public:
00486         T9NoWordFoundMsg(const WString& active_word);
00487         virtual ~T9NoWordFoundMsg();
00488
00489         virtual const MsgMetaData& GetMetaData() const;
00490         void SetActiveWord(const WString& active_word) { m_active_word = active_word; }
00491         const WString& GetActiveWord() const { return m_active_word; }
00492         virtual Message* Clone() const;
00493
00494         enum  {
00495             ID = 30101
00496             };
00497
00498     private:
00499         static const MsgMetaData m_meta_data;
00500         WString m_active_word;
00501
00502     };
00503 /*  ======================================================================
00504     Class T9AddWordMsg
00505     ====================================================================== */
00509 class T9AddWordMsg : public Message {
00510     public:
00511         T9AddWordMsg(const WString& new_word);
00512         virtual ~T9AddWordMsg();
00513
00514         virtual const MsgMetaData& GetMetaData() const;
00515         void SetNewWord(const WString& new_word) { m_new_word = new_word; }
00516         const WString& GetNewWord() const { return m_new_word; }
00517         virtual Message* Clone() const;
00518
00519         enum  {
00520             ID = 30102
00521             };
00522
00523     private:
00524         static const MsgMetaData m_meta_data;
00525         WString m_new_word;
00526
00527     };
00528 /*  ======================================================================
00529     Class T9EnteredUnknownWordMsg
00530     ====================================================================== */
00535 class T9EnteredUnknownWordMsg : public Message {
00536     public:
00537         T9EnteredUnknownWordMsg(const WString& word);
00538         virtual ~T9EnteredUnknownWordMsg();
00539
00540         virtual const MsgMetaData& GetMetaData() const;
00541         void SetWord(const WString& word) { m_word = word; }
00542         const WString& GetWord() const { return m_word; }
00543         virtual Message* Clone() const;
00544
00545         enum  {
00546             ID = 30103
00547             };
00548
00549     private:
00550         static const MsgMetaData m_meta_data;
00551         WString m_word;
00552
00553     };
00554 /*  ======================================================================
00555     Class T9SymbolEntryRequestMsg
00556     ====================================================================== */
00559 class T9SymbolEntryRequestMsg : public Message {
00560     public:
00561         T9SymbolEntryRequestMsg();
00562         virtual ~T9SymbolEntryRequestMsg();
00563
00564         virtual const MsgMetaData& GetMetaData() const;
00565         virtual Message* Clone() const;
00566
00567         enum  {
00568             ID = 30110
00569             };
00570
00571     private:
00572         static const MsgMetaData m_meta_data;
00573
00574     };
00575 /*  ======================================================================
00576     Class T9MatrixModeKeypressed
00577     ====================================================================== */
00581     class T9MatrixModeKeypressed : public Message {
00582     public:
00583         T9MatrixModeKeypressed(const KeyCode& key_code);
00584         virtual ~T9MatrixModeKeypressed();
00585
00586         virtual const MsgMetaData& GetMetaData() const;
00587         void SetKeyCode(const KeyCode& key_code) { m_key_code = key_code; }
00588         const KeyCode& GetKeyCode() const { return m_key_code; }
00589         virtual Message* Clone() const;
00590
00591         enum  {
00592             ID = 30120
00593             };
00594
00595     private:
00596         static const MsgMetaData m_meta_data;
00597         KeyCode m_key_code;
00598
00599     };
00600 /*  ======================================================================
00601     Class Zi8NoWordFoundMsg
00602     ====================================================================== */
00605 class Zi8NoWordFoundMsg : public Message {
00606     public:
00607         Zi8NoWordFoundMsg(const WString& active_word);
00608         virtual ~Zi8NoWordFoundMsg();
00609
00610         virtual const MsgMetaData& GetMetaData() const;
00611         void SetActiveWord(const WString& active_word) { m_active_word = active_word; }
00612         const WString& GetActiveWord() const { return m_active_word; }
00613         virtual Message* Clone() const;
00614
00615         enum  {
00616             ID = 30201
00617             };
00618
00619     private:
00620         static const MsgMetaData m_meta_data;
00621         WString m_active_word;
00622
00623     };
00624 /*  ======================================================================
00625     Class Zi8AddWordMsg
00626     ====================================================================== */
00630 class Zi8AddWordMsg : public Message {
00631     public:
00632         Zi8AddWordMsg(const WString& new_word);
00633         virtual ~Zi8AddWordMsg();
00634
00635         virtual const MsgMetaData& GetMetaData() const;
00636         void SetNewWord(const WString& new_word) { m_new_word = new_word; }
00637         const WString& GetNewWord() const { return m_new_word; }
00638         virtual Message* Clone() const;
00639
00640         enum  {
00641             ID = 30202
00642             };
00643
00644     private:
00645         static const MsgMetaData m_meta_data;
00646         WString m_new_word;
00647
00648     };
00649 /*  ======================================================================
00650     Class Zi8EnteredUnknownWordMsg
00651     ====================================================================== */
00656 class Zi8EnteredUnknownWordMsg : public Message {
00657     public:
00658         Zi8EnteredUnknownWordMsg(const WString& word);
00659         virtual ~Zi8EnteredUnknownWordMsg();
00660
00661         virtual const MsgMetaData& GetMetaData() const;
00662         void SetWord(const WString& word) { m_word = word; }
00663         const WString& GetWord() const { return m_word; }
00664         virtual Message* Clone() const;
00665
00666         enum  {
00667             ID = 30203
00668             };
00669
00670     private:
00671         static const MsgMetaData m_meta_data;
00672         WString m_word;
00673
00674     };
00675 /*  ======================================================================
00676     Class ImageDrawingInterruptedMsg
00677     ====================================================================== */
00681 class ImageDrawingInterruptedMsg : public ContextMsg {
00682     public:
00683         ImageDrawingInterruptedMsg(ExecutionContext* context, Image* image);
00684         virtual ~ImageDrawingInterruptedMsg();
00685
00686         virtual const MsgMetaData& GetMetaData() const;
00687         Image* GetImage() const { return m_image; }
00688         virtual Message* Clone() const;
00689
00690         enum  {
00691             ID = 1126
00692             };
00693
00694     private:
00695         static const MsgMetaData m_meta_data;
00696         Image* m_image;
00697
00698     };
00699 /*  ======================================================================
00700     Class DeleteComponentMsg
00701     ====================================================================== */
00705 class DeleteComponentMsg : public ContextMsg {
00706     public:
00707         DeleteComponentMsg(ExecutionContext* context, Component* component);
00708         virtual ~DeleteComponentMsg();
00709
00710         virtual const MsgMetaData& GetMetaData() const;
00711         Component* GetComponent() const { return m_component; }
00712         virtual Message* Clone() const;
00713
00714         enum  {
00715             ID = 1127
00716             };
00717
00718     private:
00719         static const MsgMetaData m_meta_data;
00720         Component* m_component;
00721
00722     };
00723 /*  ======================================================================
00724     Class ImageEncodingProgressMsg
00725     ====================================================================== */
00728 class ImageEncodingProgressMsg : public Message {
00729 public:
00730     ImageEncodingProgressMsg(const ImageEncoder& encoder, INT progress);
00731     virtual ~ImageEncodingProgressMsg();
00732
00733     virtual const MsgMetaData& GetMetaData() const;
00734     const ImageEncoder& GetEncoder() const { return m_encoder; }
00735     INT GetProgress() const { return m_progress; }
00736     virtual Message* Clone() const;
00737
00738     enum  {
00739         ID = 1128
00740     };
00741
00742 private:
00743     static const MsgMetaData m_meta_data;
00744     const ImageEncoder& m_encoder;
00745     INT m_progress;
00746
00747 };
00748
00749 /*  ======================================================================
00750     Class ItemRendererPropertiesChangedMsg
00751     ====================================================================== */
00752
00755 class ItemRendererPropertiesChangedMsg : public Message {
00756     public:
00757         ItemRendererPropertiesChangedMsg();
00758         virtual ~ItemRendererPropertiesChangedMsg();
00759
00760         virtual const MsgMetaData& GetMetaData() const;
00761         virtual Message* Clone() const;
00762
00763         enum  {
00764             ID = 1129
00765             };
00766
00767     private:
00768         static const MsgMetaData m_meta_data;
00769
00770     };
00771
00772 /*  ======================================================================
00773     Class RedrawDisplayMsg
00774     ====================================================================== */
00775
00778 class RedrawDisplayMsg : public Message {
00779     public:
00780         RedrawDisplayMsg(INT index);
00781         virtual ~RedrawDisplayMsg();
00782
00783         virtual const MsgMetaData& GetMetaData() const;
00784         virtual Message* Clone() const;
00785         INT GetIndex() const { return m_index; }
00786
00787         enum  {
00788             ID = 1130
00789             };
00790
00791     private:
00792         static const MsgMetaData m_meta_data;
00793         INT m_index;
00794     };
00795
00796 #endif // MsgTypes_hpp__ST_1092996111155
00797
00798
Generated on Tue Jan 24 14:44:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiLineEditor.cpp File Reference

Gui/MultiLineEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "MultiLineEditor.hpp"
#include "AtomItem.hpp"
#include "TextEditorDocument.hpp"
#include "DefaultCaret.hpp"

Include dependency graph for MultiLineEditor.cpp:

Generated on Tue Jan 24 20:45:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiLineEditor.hpp File Reference

Gui/MultiLineEditor.hpp File Reference

#include <Gui/AbstractMultiLineEditor.hpp>

Include dependency graph for MultiLineEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MultiLineEditor

Defines

#define | Apoxi_MultiLineEditor_hpp

Define Documentation

#define Apoxi_MultiLineEditor_hpp

Generated on Tue Jan 24 20:45:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiLineEditor.hpp Source File

Gui/MultiLineEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MultiLineEditor_hpp)
00011 #define Apoxi_MultiLineEditor_hpp
00016
00017 #include <Gui/AbstractMultiLineEditor.hpp>
00018
00019 class TextEditorDocument;
00020
00023 class MultiLineEditor : public AbstractMultiLineEditor {
00024     typedef AbstractMultiLineEditor Base;
00025
00026     public:
00027         enum {
00028             ID = 33
00029         };
00030
00033         MultiLineEditor();
00034
00039         MultiLineEditor(Control* parent, INT input_mapper_id, const WCHAR* text = 0);
00040
00041         virtual ~MultiLineEditor();
00042
00047         void Init(Control* parent, INT input_mapper_id, const WCHAR* text = 0);
00048
00051         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00052
00054         virtual BOOLEAN IsInstanceOf(INT id) const;
00055
00057         virtual void SetReadOnly(BOOLEAN read_only);
00058
00060         void SetText(const WCHAR* text);
00061
00063         const WString& GetText() const;
00064
00067         void SetMaxTextLength(INT max_tex_len);
00068
00071         INT GetMaxTextLength() const;
00072
00076         void SetLineHeight(XYDIM line_height);
00077
00082         void SetFont(const Font& font);
00083
00087         const Font& GetFont() const;
00088
00089     protected:
00091         virtual Model* CreateModel() const;
00092
00094         virtual void OnThemeChanged();
00095
00096     private:
00097         TextEditorDocument* GetMyDocument() { return (TextEditorDocument*)GetModel(); } //lint !e1762
00098         const TextEditorDocument* GetMyDocument() const { return (TextEditorDocument*)GetModel(); }
00099 };
00100
00102 #endif  // Apoxi_MultiLineEditor_hpp
00103
00104
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiTabInputMapper.hpp File Reference

Gui/MultiTabInputMapper.hpp File Reference

#include <Gui/MultiTapInputMapper.hpp>

Include dependency graph for MultiTabInputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define MultiTabInputMapper MultiTapInputMapper

Define Documentation

#define MultiTabInputMapper MultiTapInputMapper

Generated on Tue Jan 24 20:45:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiTabInputMapper.hpp Source File

Gui/MultiTabInputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class MultiTabInputMapper has been renamed to MultiTapInputMapper.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.4*/
00013
00014 #define MultiTabInputMapper MultiTapInputMapper
00015 #include <Gui/MultiTapInputMapper.hpp>
00016
00017
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiTapCaret.cpp File Reference

Gui/MultiTapCaret.cpp File Reference

#include "Gui/PreComp.hpp"
#include "MultiTapCaret.hpp"
#include "AbstractEditor.hpp"
#include "EditorDocument.hpp"
#include "AtomItem.hpp"
#include "CharItem.hpp"
#include "PaintDc.hpp"
#include "Locale.hpp"
#include "ClientDc.hpp"

Include dependency graph for MultiTapCaret.cpp:

Variables

const INT c_preview_count = 4

Variable Documentation

const INT c_preview_count = 4

Generated on Tue Jan 24 20:45:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiTapCaret.hpp File Reference

Gui/MultiTapCaret.hpp File Reference

#include <Gui/DefaultCaret.hpp>

Include dependency graph for MultiTapCaret.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MultiTapCaret
Caret specialized for multi-tab input-mode. More...

Defines

#define | Apoxi_MultiTapCaret_hpp

Define Documentation

#define Apoxi_MultiTapCaret_hpp

Generated on Tue Jan 24 20:45:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiTapCaret.hpp Source File

Gui/MultiTapCaret.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MultiTapCaret_hpp)
00011 #define Apoxi_MultiTapCaret_hpp
00015
00016 #include <Gui/DefaultCaret.hpp>
00017
00019 class MultiTapCaret : public DefaultCaret {
00020     typedef DefaultCaret Base;
00021
00022     public:
00024         MultiTapCaret();
00025
00031         MultiTapCaret(AbstractEditor* editor,
00032                       UINT32 blink_rate,
00033                       BOOLEAN show_preview = TRUE,
00034                       Caret::Mode mode = Insert);
00035
00037         virtual ~MultiTapCaret();
00038
00040         virtual XYDIM GetMinimalWidth() const;
00041
00043         virtual void Draw(DeviceContext* dc, const Rect& bounds, BOOLEAN right_to_left = FALSE) const;
00044
00046         virtual void ShowHint() const;
00047
00049         void SetTabbing(BOOLEAN flag) { m_flags.tabbing = flag; }   //lint !e732
00050
00052         BOOLEAN IsTabbing() const { return (BOOLEAN)m_flags.tabbing; }
00053
00055         void SetPreview(const WCHAR* preview, INT index);
00056
00058         const WCHAR* GetPreview(INT* prev_idx = 0) const;
00059
00060     private:
00061         struct {
00062             UINT tabbing        : 1;
00063             UINT show_preview   : 1;
00064         } m_flags;
00065
00066         const WCHAR* m_preview;
00067         INT         m_preview_idx;
00068
00069         Rect GetPreviewRect(const Font& font,
00070                             TextAttr text_attr,
00071                             INT start_idx,
00072                             INT length) const;
00073
00074         XYDIM GetMinGlyphWidth() const { return 8; }
00075
00076         void DrawGlyph(DeviceContext& dc,
00077                        XYDIM x,
00078                        XYDIM y,
00079                        WCHAR chr,
00080                        XYDIM glyph_inc) const;
00081 };
00082
00084 #endif  // Apoxi_MultiTapCaret_hpp
00085
00086
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiTapInputMapper.cpp File Reference

Gui/MultiTapInputMapper.cpp File Reference

#include "Gui/PreComp.hpp"
#include "MultiTapInputMapper.hpp"
#include "MultiTapCaret.hpp"
#include "AbstractEditor.hpp"
#include "CharItem.hpp"
#include "PagingMap.hpp"
#include "CompoundItem.hpp"
#include "TextCompoundItem.hpp"
#include "LanguageManager.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/LocaleConfig.hpp>
#include <Config/EditConfig.hpp>
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for MultiTapInputMapper.cpp:

Generated on Tue Jan 24 20:45:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiTapInputMapper.hpp File Reference

Gui/MultiTapInputMapper.hpp File Reference

#include <Gui/InputMapper.hpp>
#include <Auxiliary/TriggerTimer.hpp>

Include dependency graph for MultiTapInputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MultiTapInputMapper

Defines

#define | Apoxi_MultiTapInputMapper_hpp

Define Documentation

#define Apoxi_MultiTapInputMapper_hpp

Generated on Tue Jan 24 20:45:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/MultiTapInputMapper.hpp Source File

Gui/MultiTapInputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MultiTapInputMapper_hpp)
00011 #define Apoxi_MultiTapInputMapper_hpp
00015
00016 #include <Gui/InputMapper.hpp>
00017 #include <Auxiliary/TriggerTimer.hpp>
00018
00022 class MultiTapInputMapper : public InputMapper {
00023     typedef InputMapper Base;
00024
00025     public:
00027         enum CapitalizationMode {
00029             UserTriggeredCapitalization,
00032             AutoCapitalization,
00035             NameCapitalization
00036         };
00037
00050         explicit MultiTapInputMapper(BOOLEAN show_preview = TRUE,
00051                                      Alphabet alphabet = InputMapper::Ucs2Alphabet,
00052                                      CapitalizationMode capitalization_mode = UserTriggeredCapitalization);
00053
00054         virtual ~MultiTapInputMapper();
00055
00057         virtual void SetEditor(AbstractEditor* editor);
00058
00060         virtual INT GetId() const;
00061
00063         virtual Caret* GetCaret();
00064
00067         virtual Alphabet GetAlphabet() const;
00068
00069     protected:
00071         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00072
00073     private:
00074         friend class TriggerTimer<MultiTapInputMapper>;
00075
00076         struct {
00077             UINT uppercase            : 1;
00078             UINT show_preview         : 1;
00079             UINT alphabet             : 2;
00080             UINT tab_index            : 8;
00081             UINT punctuation_found    : 1;
00082             UINT switch_to_upper      : 1;
00083             UINT capitalization_mode  : 3;
00084         } m_bits;
00085
00086         TriggerTimer<MultiTapInputMapper> m_timer;
00087
00088         void OnTimer();
00089         Alphabet GetCharacterAlphabet(WCHAR chr) const;
00090 };
00091
00093 #endif  // Apoxi_MultiTapInputMapper_hpp
00094
Generated on Tue Jan 24 14:50:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/NativeImage.cpp File Reference

Gui/NativeImage.cpp File Reference

#include "Gui/PreComp.hpp"
#include "NativeImage.hpp"
#include "PaintDc.hpp"
#include <Devices/Display.hpp>
#include <Config/GuiEngineConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include <Auxiliary/RamData.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for NativeImage.cpp:

Defines

#define | NAI_HEADER_SIZE 4
#define | NAI_META_DATA_SIZE 15

Define Documentation

#define NAI_HEADER_SIZE 4

#define NAI_META_DATA_SIZE 15

Generated on Tue Jan 24 20:45:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/NativeImage.hpp File Reference

Gui/NativeImage.hpp File Reference

#include <Gui/ImageDecoder.hpp>
#include <Auxiliary/SwitchedRleCompression.hpp>

Include dependency graph for NativeImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NativeImage

Defines

#define | Apoxi_NativeImage_hpp

Define Documentation

#define Apoxi_NativeImage_hpp

Generated on Tue Jan 24 16:43:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/NativeImage.hpp Source File

Gui/NativeImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_NativeImage_hpp)
00011 #define Apoxi_NativeImage_hpp
00014
00015 #include <Gui/ImageDecoder.hpp>
00016 #include <Auxiliary/SwitchedRleCompression.hpp>
00017
00018 struct BitmapRes;
00019
00020 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00021
00022 /*  Internal class which represents the decoder for
00023     native images. The class may not be used by
00024     the MMI in a direct manner and the interface
00025     may be changed in future releases. */
00026 class NativeImageDecoder : public ImageDecoder {
00027     typedef ImageDecoder Base;
00028
00029     public:
00030         static NativeImageDecoder* GetInstance();
00031
00032         // @see ImageDeocder::GetMetaData
00033         virtual BOOLEAN GetMetaData(Image& image, Image::MetaData* meta_data);
00034
00035         // @see ImageDeocder::BeginDecoding
00036         virtual BOOLEAN BeginDecoding(const Image& image, INT frame_idx = 0);
00037
00038         // @see ImageDeocder::EndDecoding
00039         virtual void EndDecoding(const Image& image, INT frame_idx = 0);
00040
00041         /*  Returns a pointer to the scanline buffer. May only invoked
00042             inside NativeImageDecoder::BeginDecoding and NativeImageDecoder::EndDecoding. */
00043         UINT8* GetScanlineBuffer() const { return m_scanline_buffer; }
00044
00045         /*  Returns the size of the scanline in bytes. May only invoked
00046             inside NativeImageDecoder::BeginDecoding and NativeImageDecoder::EndDecoding. */
00047         UINT GetScanlineSize() const { return m_scanline_size; }
00048
00049         /*  Returns a pointer to the alpha buffer. May only invoked
00050             inside NativeImageDecoder::BeginDecoding and NativeImageDecoder::EndDecoding. */
00051         UINT8* GetAlphaBuffer() const { return m_alpha_buffer; }
00052
00053         /*  Decodes a scanline into the scanline buffer and the alpha buffer. May only invoked
00054             inside NativeImageDecoder::BeginDecoding and NativeImageDecoder::EndDecoding. */
00055         BOOLEAN DecodeScanline(INT scanline_idx,
00056                                INT old_scanline_idx,
00057                                UINT8* dest_buffer = 0);
00058
00059         /*  Returns the frame index where the decoder is used. May only invoked
00060             inside NativeImageDecoder::BeginDecoding and NativeImageDecoder::EndDecoding. */
00061         INT GetFrameIndex() const { return m_frame_idx; }
00062
00063     private:
00064         BOOLEAN m_compressed;
00065         BOOLEAN m_indexed;
00066         UINT32 m_frame_offset;
00067         UINT8 m_alpha_bits;
00068         INT m_frame_idx;
00069         UINT m_scanline_size;
00070         UINT8* m_scanline_buffer;
00071         UINT m_width;
00072         UINT8* m_index_buffer;
00073         UINT8* m_alpha_buffer;
00074         ColorValue* m_local_color_table;
00075         BinData* m_bin_data;
00076         SwitchedRleCompression::Context m_compression_context;
00077
00078         static NativeImageDecoder m_decoder;
00079
00080         NativeImageDecoder();
00081         INT16 GetInt16Value(const UINT8* buffer) const;
00082         INT32 GetInt32Value(const UINT8* buffer) const;
00083         BOOLEAN ReadLocalColorTable();
00084         BOOLEAN DecodeIndexedScanline(INT scanline_idx,
00085                                       INT old_scanline_idx,
00086                                       UINT8* dest_buffer);
00087
00090         UINT GetIndexedAlphaByteCount() const;
00091 };
00092 #endif // DOXYGEN_SHOULD_SKIP_THIS
00093
00100 class NativeImage : public Image {
00101     typedef Image Base;
00102
00103     public:
00104         enum {
00105             ID = 6
00106         };
00107
00110         NativeImage();
00111
00113         NativeImage(Bitmap* bitmap);
00114
00116         NativeImage(const BitmapRes* bitmap_res);
00117
00124         NativeImage(BinData* bin_data);
00125
00132         NativeImage(const BitmapRes* const* animation_res,
00133                     UINT frame_count,
00134                     UINT32 frame_delay = 0);
00135
00136         virtual ~NativeImage();
00137
00139         void Init(Bitmap* bitmap);
00140
00142         void Init(const BitmapRes* bitmap_res);
00143
00150         void Init(BinData* bin_data);
00151
00158         void Init(const BitmapRes* const* animation_res,
00159                   INT frame_count,
00160                   UINT32 frame_delay = 0);
00161
00163         virtual BOOLEAN IsInstanceOf(INT id) const;
00164
00166         virtual BOOLEAN Draw(DeviceContext* dc,
00167                              XYDIM x,
00168                              XYDIM y,
00169                              INT frame_idx,
00170                              XYDIM scaled_width = -1,
00171                              XYDIM scaled_height = -1,
00172                              const Rect& clip_rect = Rect()) const;
00173
00175         virtual const BinData* GetBinData() const;
00176
00178         virtual INT GetNextFrame(INT frame_idx) const;
00179
00182         void SetFrameDelay(UINT32 frame_delay);
00183
00185         virtual UINT32 GetFrameDelay(INT frame_idx) const;
00186
00188         virtual BOOLEAN IsCopyrighted() const;
00189
00191         BOOLEAN IsCompressed(INT frame_idx = 0) const;
00192
00195         virtual BOOLEAN DecodeSynchronously() const;
00196
00197     protected:
00199         virtual void* BeginScanlineDrawing(INT frame_idx) const;
00200
00202         virtual void EndScanlineDrawing(void* context) const;
00203
00205         virtual void DrawScanline(void* context,
00206                                   DeviceContext* dc,
00207                                   XYDIM x,
00208                                   XYDIM y,
00209                                   INT scanline_idx,
00210                                   INT old_scanline_idx) const;
00211
00212
00214         virtual BOOLEAN IsTransparent(void* context) const;
00215
00217         virtual ColorValue GetTransparentColor(void* context) const;
00218
00219     private:
00220         enum ImageType {
00221             SingleImageType,
00222             ConstSingleImageType,
00223             ConstAnimationType,
00224             BinDataType,
00225             UndefinedType
00226         };
00227
00228         struct {
00229             UINT compressed          : 1;
00230             UINT copyrighted         : 1;
00231             UINT transparent         : 1;
00232         } m_bits;
00233
00234         ColorValue m_transparent_color;
00235         ImageType m_type;
00236         UINT16 m_frame_delay;
00237         union {
00238             Bitmap                  *m_bitmap;
00239             const BitmapRes         *m_bitmap_res;
00240             const BitmapRes* const  *m_animation_res;
00241             BinData                 *m_bin_data;
00242         };
00243
00244         void SetTransparent(BOOLEAN transparent) { m_bits.transparent = transparent; }
00245         void SetTransparentColor(ColorValue color_value) { m_transparent_color = color_value; }
00246         void SetCopyrighted(BOOLEAN copyrighted) { m_bits.copyrighted = copyrighted; }
00247         INT16 GetDefaultFrameDelay() const { return 300; }
00248         void InitProperties();
00249         friend class NativeImageDecoder;
00250 };
00251
00253 #endif  //Apoxi_NativeImage_hpp
00254
Generated on Tue Jan 24 14:45:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/NumericInputMapper.cpp File Reference

Gui/NumericInputMapper.cpp File Reference

#include "Gui/PreComp.hpp"
#include "NumericInputMapper.hpp"
#include "AbstractEditor.hpp"
#include "CharItem.hpp"
#include "EditorDocument.hpp"
#include <Config/KeyboardConfig.hpp>

Include dependency graph for NumericInputMapper.cpp:

Generated on Tue Jan 24 20:45:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/NumericInputMapper.hpp File Reference

Gui/NumericInputMapper.hpp File Reference

#include <Gui/InputMapper.hpp>

Include dependency graph for NumericInputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NumericInputMapper

Defines

#define | Apoxi_NumericInputMapper_hpp

Define Documentation

#define Apoxi_NumericInputMapper_hpp

Generated on Tue Jan 24 20:45:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/NumericInputMapper.hpp Source File

Gui/NumericInputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_NumericInputMapper_hpp)
00011 #define Apoxi_NumericInputMapper_hpp
00015
00016 #include <Gui/InputMapper.hpp>
00017
00019 class NumericInputMapper : public InputMapper {
00020     typedef InputMapper Base;
00021
00022     public:
00023         explicit NumericInputMapper();
00024         virtual ~NumericInputMapper();
00025
00027         virtual INT GetId() const;
00028
00031         virtual Alphabet GetAlphabet() const;
00032
00033     protected:
00035         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00036 };
00037
00039 #endif  // Apoxi_NumericInputMapper_hpp
00040
00041
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/OpenContextMenuAction.cpp File Reference

Gui/OpenContextMenuAction.cpp File Reference

#include "Gui/PreComp.hpp"
#include "OpenContextMenuAction.hpp"
#include "ItemContainer.hpp"
#include "ItemRendererProperties.hpp"
#include <Devices/Display.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Application.hpp>
#include <Config/FontConfig.hpp>
#include <Config/GuiEngineConfig.hpp>
#include "Panel.hpp"

Include dependency graph for OpenContextMenuAction.cpp:

Generated on Tue Jan 24 20:45:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/OpenContextMenuAction.hpp File Reference

Gui/OpenContextMenuAction.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/ContextMenu.hpp>

Include dependency graph for OpenContextMenuAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | OpenContextMenuAction

Defines

#define | Apoxi_OpenContextMenuAction_hpp

Define Documentation

#define Apoxi_OpenContextMenuAction_hpp

Generated on Tue Jan 24 20:45:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/OpenContextMenuAction.hpp Source File

Gui/OpenContextMenuAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_OpenContextMenuAction_hpp)
00010 #define Apoxi_OpenContextMenuAction_hpp
00014
00015 class AbstractItemContainer;
00016
00017 #include <Gui/Action.hpp>
00018 #include <Gui/ContextMenu.hpp>
00019
00024 class OpenContextMenuAction : public Action {
00025     typedef Action Base;
00026
00027     public:
00030         OpenContextMenuAction();
00031
00050         OpenContextMenuAction(Dispatcher* dispatcher,
00051                               const WString& text,
00052                               const ImageObtainer& icon,
00053                               BOOLEAN enabled = TRUE,
00054                               AbstractItemContainer* item_cont = 0,
00055                               ContextMenu::Corner corner = ContextMenu::BottomLeft,
00056                               XYDIM x = -1,
00057                               XYDIM y = -1);
00058
00072         OpenContextMenuAction(Dispatcher* dispatcher,
00073                               const WString& text,
00074                               AbstractItemContainer* item_cont = 0,
00075                               ContextMenu::Corner corner = ContextMenu::BottomLeft,
00076                               XYDIM x = -1,
00077                               XYDIM y = -1);
00078
00080         virtual ~OpenContextMenuAction();
00081
00100         void Init(Dispatcher* dispatcher,
00101                   const WString& text,
00102                   const ImageObtainer& icon,
00103                   BOOLEAN enabled = TRUE,
00104                   AbstractItemContainer* item_cont = 0,
00105                   ContextMenu::Corner corner = ContextMenu::BottomLeft,
00106                   XYDIM x = -1,
00107                   XYDIM y = -1);
00108
00109
00123         void Init(Dispatcher* dispatcher,
00124                   const WString& text,
00125                   AbstractItemContainer* item_cont = 0,
00126                   ContextMenu::Corner corner = ContextMenu::BottomLeft,
00127                   XYDIM x = -1,
00128                   XYDIM y = -1);
00129
00131         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00132
00134         AbstractItemContainer* GetItemContainer() const { return m_item_cont; }
00135
00140         BOOLEAN AddItem(Item* item);
00141
00143         virtual BOOLEAN Execute();
00144
00145     private:
00146         BOOLEAN m_allocated_item_cont;
00147         ContextMenu::Corner m_corner;
00148         XYDIM m_x;
00149         XYDIM m_y;
00150         AbstractItemContainer* m_item_cont;
00151 };
00152
00154 #endif  // Apoxi_OpenContextMenuAction_hpp
00155
00156
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/OpenWindowAction.cpp File Reference

Gui/OpenWindowAction.cpp File Reference

#include "Gui/PreComp.hpp"
#include "OpenWindowAction.hpp"

Include dependency graph for OpenWindowAction.cpp:

Generated on Tue Jan 24 20:45:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/OpenWindowAction.hpp File Reference

Gui/OpenWindowAction.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/Window.hpp>
#include <Kernel/MsgTypes.hpp>

Include dependency graph for OpenWindowAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | OpenWindowAction

Defines

#define | Apoxi_OpenWindowAction_hpp

Define Documentation

#define Apoxi_OpenWindowAction_hpp

Generated on Tue Jan 24 20:45:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/OpenWindowAction.hpp Source File

Gui/OpenWindowAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_OpenWindowAction_hpp)
00010 #define Apoxi_OpenWindowAction_hpp
00014
00015 #include <Gui/Action.hpp>
00016 #include <Gui/Window.hpp>
00017 #include <Kernel/MsgTypes.hpp>
00018
00020 class OpenWindowAction : public Action {
00021     typedef Action Base;
00022
00023     public:
00026         OpenWindowAction();
00027
00037         OpenWindowAction(Dispatcher* dispatcher,
00038                          Window* win,
00039                          const WString& text,
00040                          const ImageObtainer& icon = ImageObtainer(),
00041                          BOOLEAN modal = FALSE);
00042
00044         virtual ~OpenWindowAction();
00045
00055         void Init(Dispatcher* dispatcher,
00056                   Window* win,
00057                   const WString& text,
00058                   const ImageObtainer& icon = ImageObtainer(),
00059                   BOOLEAN modal = FALSE);
00060
00062         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00063
00066         virtual BOOLEAN Execute();
00067
00070         OpenWindowAction(Window* win, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00071
00075         OpenWindowAction(Window* win, BOOLEAN modal, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00076
00079         void Init(Window* win, const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00080
00084         void Init(Window* win, BOOLEAN modal,  const WCHAR* text = 0, const BitmapRes* bitmap = 0, BOOLEAN enabled = TRUE);
00085
00087         void SetWindow(Window* win) { m_win = win; }
00088
00089     private:
00090         BOOLEAN m_modal;
00091         Window* m_win;
00092 };
00093
00095 #endif  // Apoxi_OpenWindowAction_hpp
00096
00097
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/OptionalConfigBase.hpp File Reference

Gui/OptionalConfigBase.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | OptionalConfigBase

Defines

#define | Apoxi_OptionalConfigBase_hpp

Define Documentation

#define Apoxi_OptionalConfigBase_hpp

Generated on Tue Jan 24 20:45:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/OptionalConfigBase.hpp Source File

Gui/OptionalConfigBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined (Apoxi_OptionalConfigBase_hpp)
00010 #define Apoxi_OptionalConfigBase_hpp
00013
00014
00016 class OptionalConfigBase {
00017     public:
00020         enum GroupIds {
00021             Display     = 0,
00022             Editor      = 1,
00023             Keyboard    = 2,
00024             Locale      = 3,
00025             Theme       = 4,
00026             GuiEngine   = 5,
00027             Custom      = 1000
00028         };
00029
00032         enum SettingIds {
00033             // -----------------------------------------------------------------------------------
00034             // IDs for the group Display
00035             // -----------------------------------------------------------------------------------
00036             DimmedBacklightBrightness = 0,
00037
00038             // -----------------------------------------------------------------------------------
00039             // IDs for the group GuiEngine
00040             // -----------------------------------------------------------------------------------
00041
00046             ScrollbarAlignment       = 0,
00047
00051             ScrollbarDisplayPolicy   = 1,
00052
00058             MaxDecoderDelay          = 2,
00059
00067             ScrollGap                = 3,
00068
00074             HideClippedText          = 4,
00075
00078             SmoothScrollSteps        = 5,
00079
00081             MaxEncoderDelay          = 6,
00082
00086             HorizontalScrollBehavior = 7,
00087
00090             TabButtonDefaultHeight   = 8,
00091
00094             TabButtonDefaultWidth    = 9,
00095
00098             TabButtonMinimumWidth    = 10,
00099
00102             TabButtonMaximumWidth    = 11,
00103
00107             TabButtonClippedWidth    = 12,
00108
00113             ShowParentPosition       = 13,
00114
00118             PositionSeparator         = 14,
00119
00122             SelectionStyle            = 15
00123         };
00124 };
00125
00127 #endif  // Apoxi_OptionalConfigBase_hpp
00128
00129
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PagingMap.hpp File Reference

Gui/PagingMap.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for PagingMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | PagingMap
struct | PagingMapEntry

Defines

#define | Apoxi_PagingMap_hpp

Define Documentation

#define Apoxi_PagingMap_hpp

Generated on Tue Jan 24 20:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PagingMap.hpp Source File

Gui/PagingMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_PagingMap_hpp)
00010 #define Apoxi_PagingMap_hpp
00011
00012 #include <Kernel/Types.hpp>
00013
00014 // Defines the mapping of a key code to it's character code presentations.
00015 struct PagingMapEntry {
00016     UINT8 GetKeyCode() const { return keycode; }
00017     WCHAR GetNumber() const { return number; }
00018     const WCHAR* GetUpperCaseChar() const { return uppercase; }
00019     const WCHAR* GetLowerCaseChar() const { return lowercase; }
00020     BOOLEAN IsValid() const { return number != 0; }
00021     BOOLEAN IsSwitch() const { return (number != 0) && (uppercase == 0) && (lowercase == 0); }
00022
00023     UINT8 keycode;                      // the code of the key this mapping applies to
00024     WCHAR number;                       // numeric presentation
00025     const WCHAR* uppercase;             // upper case presentations
00026     const WCHAR* lowercase;             // lower case presentations
00027 };
00028
00029 // Defines the key to character mapping for a certain language.
00030 struct PagingMap {
00031     const PagingMapEntry& GetPagingMapEntry(KeyCode key_code) const {
00032         INT i = 0;
00033         while ((m_pme[i].GetNumber() != 0) && (m_pme[i].GetKeyCode() != key_code))
00034             i++;
00035         return m_pme[i];
00036     }
00037
00038     WCHAR GetNumber(KeyCode key_code) const {
00039         return GetPagingMapEntry(key_code).GetNumber();
00040     }
00041
00042     const WCHAR* GetLowerCaseChar(KeyCode key_code) const {
00043         return GetPagingMapEntry(key_code).GetLowerCaseChar();
00044     }
00045
00046     //LanguageId lang_id;               // language the mapping applies to
00047     const PagingMapEntry* m_pme;        // Array of mapping entries. Last entry must be initialized with zero.
00048 };
00049
00050 #endif  // Apoxi_PagingMap_hpp
00051
00052
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PaintDc.cpp File Reference

Gui/PaintDc.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/PaintDc.hpp"

Include dependency graph for PaintDc.cpp:

Generated on Tue Jan 24 20:45:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PaintDc.hpp File Reference

Gui/PaintDc.hpp File Reference

#include <Gui/DeviceContext.hpp>

Include dependency graph for PaintDc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PaintDc

Defines

#define | Apoxi_PaintDc_hpp

Define Documentation

#define Apoxi_PaintDc_hpp

Generated on Tue Jan 24 20:46:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PaintDc.hpp Source File

Gui/PaintDc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_PaintDc_hpp)
00010 #define Apoxi_PaintDc_hpp
00013
00014 #include <Gui/DeviceContext.hpp>
00015
00019 class PaintDc : public DeviceContext {
00020     typedef DeviceContext Base;
00021
00022     public:
00027         PaintDc(DeviceContext* dc);
00028
00030         virtual ~PaintDc();
00031 };
00032
00034 #endif  // Apoxi_PaintDc_hpp
00035
00036
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Panel.cpp File Reference

Gui/Panel.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Panel.hpp"
#include "PaintDc.hpp"
#include "Desktop.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include "Action.hpp"
#include <Config/DisplayConfig.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Kernel/Application.hpp>

Include dependency graph for Panel.cpp:

Generated on Tue Jan 24 20:46:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Panel.hpp File Reference

Gui/Panel.hpp File Reference

#include <Gui/View.hpp>
#include <Gui/Window.hpp>

Include dependency graph for Panel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Panel
class | PanelView
Describes the view of a panel. More...

Defines

#define | Apoxi_Panel_hpp

Define Documentation

#define Apoxi_Panel_hpp

Generated on Tue Jan 24 20:46:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Panel.hpp Source File

Gui/Panel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2003 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Panel_hpp)
00010 #define Apoxi_Panel_hpp
00013
00014 #include <Gui/View.hpp>
00015 #include <Gui/Window.hpp>
00016
00017 class Panel;
00018
00020 class PanelView : public View {
00021     typedef View Base;
00022
00023     public:
00025         PanelView();
00026
00028         PanelView(XYDIM default_height);
00029
00031         virtual ~PanelView();
00032
00034         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00035
00036     protected:
00038         virtual void DrawPanel(const Panel& panel, DeviceContext* dc, const Rect& repaint_rect) const = 0;
00039 };
00040
00048 class Panel : public Window {
00049     typedef Window Base;
00050
00051     public:
00052         enum {
00053             ID = 17
00054         };
00055
00057         Panel();
00058
00060         virtual ~Panel();
00061
00063         XYDIM GetComponentsSize() const;
00064
00066         virtual BOOLEAN IsInstanceOf(INT id) const;
00067
00072         void SetOwner(Window* owner) { m_owner = owner; }
00073
00077         const Window* GetOwner() const { return m_owner; }
00078
00079     protected:
00081         virtual void OnThemeChanged();
00082
00084         virtual void OnLayoutClient();
00085
00086     private:
00087         const Window* m_owner;
00088
00089         void AlignOnDesktop();
00090
00093         void AdjustPosition(Component& comp, XYDIM& x);
00094 };
00095
00097 #endif // Apoxi_Panel_hpp
00098
00099
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PasswordEditor.cpp File Reference

Gui/PasswordEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Control.hpp"
#include "PaintDc.hpp"
#include "PasswordEditor.hpp"
#include "DefaultCaret.hpp"
#include "InputMapper.hpp"
#include "NumericInputMapper.hpp"
#include "MultiTapInputMapper.hpp"
#include "PhoneNumberInputMapper.hpp"

Include dependency graph for PasswordEditor.cpp:

Generated on Tue Jan 24 20:46:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PasswordEditor.hpp File Reference

Gui/PasswordEditor.hpp File Reference

#include <Gui/AbstractLineEditor.hpp>
#include <Gui/TextEditorDocument.hpp>
#include <Gui/InputMapper.hpp>
#include <Gui/View.hpp>

Include dependency graph for PasswordEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PasswordEditor

Defines

#define | Apoxi_PasswordEditor_hpp

Define Documentation

#define Apoxi_PasswordEditor_hpp

Generated on Tue Jan 24 20:46:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PasswordEditor.hpp Source File

Gui/PasswordEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PasswordEditor_hpp)
00011 #define Apoxi_PasswordEditor_hpp
00016
00017 #include <Gui/AbstractLineEditor.hpp>
00018 #include <Gui/TextEditorDocument.hpp>
00019 #include <Gui/InputMapper.hpp>
00020 #include <Gui/View.hpp>
00021
00022 class DefaultCaret;
00023
00028 class PasswordEditor : public AbstractLineEditor {
00029     typedef AbstractLineEditor Base;
00030
00031     public:
00032         enum {
00033             ID = 34
00034         };
00035
00037         PasswordEditor();
00038
00040         PasswordEditor(Control* parent,
00041                        INT input_mapper_id,
00042                        const WCHAR* text = 0,
00043                        BOOLEAN cleartext_mode = FALSE);
00044
00046         virtual ~PasswordEditor();
00047
00049         void Init(Control* parent,
00050                   INT input_mapper_id,
00051                   const WCHAR* text = 0,
00052                   BOOLEAN cleartext_mode = FALSE);
00053
00055         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00056
00058         virtual BOOLEAN IsInstanceOf(INT id) const;
00059
00061         void SetText(const WCHAR* text);
00062
00064         const WString& GetText() const;
00065
00067         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00068
00070         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00071
00073         virtual BOOLEAN RemoveItem(INT index = -1);
00074
00076         virtual BOOLEAN Backspace();
00077
00079         void SetMaxTextLength(INT max_tex_len);
00080
00082         INT GetMaxTextLength() const;
00083
00090         void SetClearTextModeEnabled(BOOLEAN cleartext);
00091
00093         BOOLEAN IsClearTextModeEnabled() { return m_cleartext; }
00094
00095     protected:
00097         virtual Model* CreateModel() const;
00098
00099     private:
00100         WString m_text;
00101         BOOLEAN m_cleartext;
00102
00103         TextEditorDocument* GetMyDocument() { return (TextEditorDocument*)GetModel(); } //lint !e1762
00104         const TextEditorDocument* GetMyDocument() const { return (const TextEditorDocument*)GetModel(); }
00105
00106         DefaultCaret* GetMyCaret() { return (DefaultCaret*)GetCaret(); }
00107 };
00108
00110 #endif  // Apoxi_PasswordEditor_hpp
00111
00112
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Pen.cpp File Reference

Gui/Pen.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Pen.hpp"

Include dependency graph for Pen.cpp:

Generated on Tue Jan 24 20:46:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Pen.hpp File Reference

Gui/Pen.hpp File Reference

#include <Gui/Color.hpp>

Include dependency graph for Pen.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Pen

Defines

#define | Apoxi_Pen_hpp

Typedefs

typedef Pen::PenStyle | PenStyle

Define Documentation

#define Apoxi_Pen_hpp

Generated on Tue Jan 24 20:46:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Pen.hpp Source File

Gui/Pen.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Pen_hpp)
00010 #define Apoxi_Pen_hpp
00013
00014 #include <Gui/Color.hpp>
00015
00018 class Pen {
00019     public:
00021         enum PenStyle {
00023             Solid,
00025             Dotted,
00027             Dashed,
00029             SemiDashed
00030         };
00031
00033         Pen(PenStyle style = Solid, Color color = Color());
00034
00036         void SetStyle(PenStyle style) { m_style = style; }
00037
00039         PenStyle GetStyle() const { return m_style; }
00040
00042         void SetColor(const Color& color) { m_color = color; }
00043
00045         const Color& GetColor() const { return m_color; }
00046
00048         void SetColorValue(ColorValue color_value) { m_color.SetValue(color_value); }
00049
00051         ColorValue GetColorValue() const { return m_color.GetValue(); }
00052
00055         void SetColorRgb(UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha = 255) { m_color.SetRgb(red, green, blue, alpha); }
00056
00059         void SetColorHsv(UINT8 hue, UINT8 saturation, UINT8 value, UINT8 alpha = 255) { m_color.SetHsv(hue, saturation, value, alpha); }
00060
00061     private:
00062         PenStyle    m_style;
00063         Color       m_color;
00064 };
00065
00066 typedef Pen::PenStyle PenStyle;
00067
00069 #endif  // Apoxi_Pen_hpp
00070
00071
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PhoneNumberInputMapper.cpp File Reference

Gui/PhoneNumberInputMapper.cpp File Reference

#include "Gui/PreComp.hpp"
#include "PhoneNumberInputMapper.hpp"
#include "CharItem.hpp"
#include "AbstractEditor.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/EditConfig.hpp>

Include dependency graph for PhoneNumberInputMapper.cpp:

Generated on Tue Jan 24 20:46:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PhoneNumberInputMapper.hpp File Reference

Gui/PhoneNumberInputMapper.hpp File Reference

#include <Gui/NumericInputMapper.hpp>

Include dependency graph for PhoneNumberInputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PhoneNumberInputMapper

Defines

#define | Apoxi_PhoneNumberInputMapper_hpp

Define Documentation

#define Apoxi_PhoneNumberInputMapper_hpp

Generated on Tue Jan 24 20:46:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PhoneNumberInputMapper.hpp Source File

Gui/PhoneNumberInputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PhoneNumberInputMapper_hpp)
00011 #define Apoxi_PhoneNumberInputMapper_hpp
00015
00016 #include <Gui/NumericInputMapper.hpp>
00017
00020 class PhoneNumberInputMapper : public NumericInputMapper {
00021     typedef NumericInputMapper Base;
00022
00023     public:
00024         explicit PhoneNumberInputMapper();
00025         virtual ~PhoneNumberInputMapper();
00026
00028         virtual INT GetId() const;
00029
00032         virtual Alphabet GetAlphabet() const;
00033
00034     protected:
00036         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00037
00039         virtual BOOLEAN OnLongKeyPress(KeyCode key_code);
00040
00041     private:
00042         void InsertChar(WCHAR chr);
00043         void ReplaceChar(WCHAR chr);
00044 };
00045
00047 #endif  // Apoxi_PhoneNumberInputMapper_hpp
00048
00049
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Point.cpp File Reference

Gui/Point.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/Point.hpp"
#include "Gui/Rect.hpp"

Include dependency graph for Point.cpp:

Generated on Tue Jan 24 20:46:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Point.hpp File Reference

Gui/Point.hpp File Reference

#include <Kernel/Os/Os.hpp>

Include dependency graph for Point.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Point
Combines the x- and y-coordinate. More...

Defines

#define | Apoxi_Point_hpp

Define Documentation

#define Apoxi_Point_hpp

Generated on Tue Jan 24 20:47:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Point.hpp Source File

Gui/Point.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Point_hpp)
00010 #define Apoxi_Point_hpp
00013
00014 #include <Kernel/Os/Os.hpp>
00015
00016
00017 class Rect;
00018
00020 class Point {
00021     public:
00023         Point(XYDIM x = 0, XYDIM y = 0) : m_x(x), m_y(y) {}
00024
00026         Point(const Point& point) : m_x(point.GetX()), m_y(point.GetY()) {}
00027
00029         void SetX(XYDIM x) { m_x = x; }
00030
00032         XYDIM GetX() const { return m_x; }
00033
00035         void SetY(XYDIM y) { m_y = y; }
00036
00038         XYDIM GetY() const { return m_y; }
00039
00041         BOOLEAN IsInside(const Rect& rect) const;
00042
00045         void Move(XYDIM dx, XYDIM dy) { m_x += dx; m_y += dy; }
00046
00047     private:
00048         XYDIM m_x;
00049         XYDIM m_y;
00050 };
00051
00053 #endif  // Apoxi_Point_hpp
00054
00055
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PositionIndicator.cpp File Reference

Gui/PositionIndicator.cpp File Reference

#include "Gui/PreComp.hpp"
#include "PositionIndicator.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"

Include dependency graph for PositionIndicator.cpp:

Generated on Tue Jan 24 20:47:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PositionIndicator.hpp File Reference

Gui/PositionIndicator.hpp File Reference

#include <Gui/Model.hpp>
#include <Gui/View.hpp>
#include <Gui/Rect.hpp>
#include <Gui/DrawableObject.hpp>

Include dependency graph for PositionIndicator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PositionIndicator
class | PositionIndicatorView

Defines

#define | Apoxi_PositionIndicator_hpp

Define Documentation

#define Apoxi_PositionIndicator_hpp

Generated on Tue Jan 24 20:47:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PositionIndicator.hpp Source File

Gui/PositionIndicator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_PositionIndicator_hpp)
00010 #define Apoxi_PositionIndicator_hpp
00014
00015 #include <Gui/Model.hpp>
00016 #include <Gui/View.hpp>
00017 #include <Gui/Rect.hpp>
00018 #include <Gui/DrawableObject.hpp>
00019
00026 class PositionIndicator : public DrawableObject {
00027     typedef DrawableObject Base;
00028
00029     public:
00030         enum {
00031             ID = 18
00032         };
00033
00035         enum Orientation {
00037             Horizontal,
00039             Vertical
00040         };
00041
00044         PositionIndicator();
00045
00054         PositionIndicator(Control* control,
00055                           Orientation orientation,
00056                           INT min_value,
00057                           INT max_value,
00058                           INT visible_values_count = -1,
00059                           INT value = -1,
00060                           BOOLEAN auto_draw = TRUE);
00061
00063         virtual ~PositionIndicator();
00064
00073         void Init(Control* control,
00074                   Orientation orientation,
00075                   INT min_value,
00076                   INT max_value,
00077                   INT visible_values_count = -1,
00078                   INT value = -1,
00079                   BOOLEAN auto_draw = TRUE);
00080
00082         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00083
00085         virtual BOOLEAN IsInstanceOf(INT id) const;
00086
00091         void SetOrientation(Orientation orientation);
00092
00094         Orientation GetOrientation() const { return m_orientation; }
00095
00097         void SetMinValue(INT min_value);
00098
00100         INT GetMinValue() const { return m_min_value; }
00101
00103         void SetMaxValue(INT max_value);
00104
00106         INT GetMaxValue() const { return m_max_value; }
00107
00110         void SetRange(INT min_value, INT max_value);
00111
00116         void SetVisibleValuesCount(INT visible_values_count);
00117
00119         INT GetVisibleValuesCount() const { return m_visible_values_count; }
00120
00124         void SetValue(INT value);
00125
00127         INT GetValue() const { return m_value; }
00128
00130         BOOLEAN IsFullsized() const;
00131
00132     protected:
00134         virtual void OnThemeChanged();
00135
00136     private:
00137         INT m_min_value;
00138         INT m_max_value;
00139         INT m_visible_values_count;
00140         INT m_value;
00141         Orientation m_orientation;
00142
00146         void AssureConsistence();
00147 };
00148
00150 class PositionIndicatorView : public DrawableObjectView {
00151     typedef DrawableObjectView Base;
00152
00153     public:
00155         PositionIndicatorView();
00157         PositionIndicatorView(XYDIM size);
00158
00160         virtual ~PositionIndicatorView();
00161
00163         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00164
00166         void SetSize(XYDIM size) { m_size = size; }
00167
00169         XYDIM GetSize() const { return m_size; }
00170
00171     protected:
00177         virtual void DrawPositionIndicator(const PositionIndicator& pos_ind, DeviceContext* dc, const Rect& repaint_rect) const = 0;
00178
00179     private:
00180         XYDIM m_size;
00181 };
00182
00184 #endif  // Apoxi_PositionIndicator_hpp
00185
00186
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PreComp.cpp File Reference

Gui/PreComp.cpp File Reference

#include "Gui/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:06:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PreComp.hpp File Reference

Gui/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Timer.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/InputMap.hpp>
#include <Kernel/Os/Os.hpp>
#include <Auxiliary/Macros.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/NonCloneable.hpp>
#include <Gui/MsgTypes.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PreComp.hpp Source File

Gui/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Kernel/System.hpp>
00011 #include <Kernel/Timer.hpp>
00012 #include <Kernel/Message.hpp>
00013 #include <Kernel/InputMap.hpp>
00014 #include <Kernel/Os/Os.hpp>
00015 #include <Auxiliary/Macros.hpp>
00016 #include <Auxiliary/LinkedList.hpp>
00017 #include <Auxiliary/Linkable.hpp>
00018 #include <Auxiliary/Vector.hpp>
00019 #include <Auxiliary/NonCloneable.hpp>
00020 #include <Gui/MsgTypes.hpp>
00021
00022
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PredInputMapper.cpp File Reference

Gui/PredInputMapper.cpp File Reference

#include "Gui/PreComp.hpp"
#include "PredInputMapper.hpp"
#include <Config/KeyboardConfig.hpp>

Include dependency graph for PredInputMapper.cpp:

Generated on Tue Jan 24 20:47:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PredInputMapper.hpp File Reference

Gui/PredInputMapper.hpp File Reference

#include <Gui/InputMapper.hpp>

Include dependency graph for PredInputMapper.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PredInputMapper
Abstract base class for predictive input-mappers. More...

Defines

#define | Apoxi_PredInputMapper_hpp

Define Documentation

#define Apoxi_PredInputMapper_hpp

Generated on Tue Jan 24 20:47:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PredInputMapper.hpp Source File

Gui/PredInputMapper.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PredInputMapper_hpp)
00011 #define Apoxi_PredInputMapper_hpp
00015
00016 #include <Gui/InputMapper.hpp>
00017
00019 class PredInputMapper : public InputMapper {
00020     typedef InputMapper Base;
00021
00022
00023     public:
00024         enum Type {
00025             T9,
00026             Zi8
00027         };
00028
00030         explicit PredInputMapper(AbstractEditor* editor = 0);
00031
00033         virtual ~PredInputMapper();
00034
00036         virtual Type GetType() const = 0;
00037
00039         //TODO: Why not return a WString? murrayc
00040         virtual const WCHAR* GetStatusInfo() const = 0;
00041
00043         virtual const WCHAR* GetPhonetics(INT* selected_idx = 0) const = 0;
00044
00046         virtual const WCHAR* GetStrokes() const = 0;
00047
00049         virtual const WCHAR* GetSelection() const = 0;
00050
00052         virtual INT GetSelectedIndex() const = 0;
00053
00054
00056         enum PredMode {
00058             PredEnglish,
00060             PredMultiTap,
00062             PredPinyin,
00064             PredSimplifiedChineseStroke,
00066             PredTraditionalChineseStroke,
00068             PredBpmf,
00070             PredNone,
00072             PredSymbol,
00073
00074             PredArabic,
00075
00076             PredThai,
00077
00078             PredThaiMatrix,
00079
00080             PredHebrew
00081         };
00082
00084         virtual BOOLEAN SetMode(PredMode mode) = 0;
00085
00087         virtual PredMode GetMode() const = 0;
00088
00090         virtual BOOLEAN IsModeSupported(PredMode mode) = 0;
00091
00092     protected:
00093         virtual BOOLEAN OnKeyDown (KeyCode key_code);
00094
00095         BOOLEAN m_number_input_mode;
00096 };
00097
00099 #endif  // Apoxi_PredInputMapper_hpp
00100
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ProgressBar.cpp File Reference

Gui/ProgressBar.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ProgressBar.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"

Include dependency graph for ProgressBar.cpp:

Generated on Tue Jan 24 20:47:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ProgressBar.hpp File Reference

Gui/ProgressBar.hpp File Reference

#include <Gui/Model.hpp>
#include <Gui/View.hpp>
#include <Gui/Rect.hpp>
#include <Gui/DrawableObject.hpp>

Include dependency graph for ProgressBar.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ProgressBar
class | ProgressBarView

Defines

#define | Apoxi_ProgressBar_hpp

Define Documentation

#define Apoxi_ProgressBar_hpp

Generated on Tue Jan 24 20:47:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ProgressBar.hpp Source File

Gui/ProgressBar.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ProgressBar_hpp)
00010 #define Apoxi_ProgressBar_hpp
00014
00015 #include <Gui/Model.hpp>
00016 #include <Gui/View.hpp>
00017 #include <Gui/Rect.hpp>
00018 #include <Gui/DrawableObject.hpp>
00019
00022 class ProgressBar : public DrawableObject {
00023     public:
00024         enum {
00025             ID = 19
00026         };
00027
00028         typedef DrawableObject Base;
00029
00032         ProgressBar();
00033
00036         ProgressBar(Control* control, INT progress = 0);
00037
00039         virtual ~ProgressBar();
00040
00043         void Init(Control* control, INT progress = 0);
00044
00046         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00047
00049         virtual BOOLEAN IsInstanceOf(INT id) const;
00050
00052         void SetProgress(INT progress);
00053
00055         INT GetProgress() const { return m_progress; }
00056
00057     protected:
00059         virtual void OnThemeChanged();
00060
00061     private:
00062         INT m_progress;
00063 };
00064
00066 class ProgressBarView : public DrawableObjectView {
00067     typedef DrawableObjectView Base;
00068
00069     public:
00071         ProgressBarView();
00073         ProgressBarView(XYDIM default_height);
00074
00076         virtual ~ProgressBarView();
00077
00079         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00080
00081     protected:
00083         virtual void DrawProgressBar(const ProgressBar& progress_bar, DeviceContext* dc, const Rect& repaint_rect) const = 0;
00084 };
00085
00087 #endif  // Apoxi_ProgressBar_hpp
00088
00089
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ProviderListBox.hpp File Reference

Gui/ProviderListBox.hpp File Reference

#include <Compat/ProviderListBox.hpp>

Include dependency graph for ProviderListBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ProviderListBox.hpp Source File

Gui/ProviderListBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class ProviderListBox has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.*/
00013 #include <Compat/ProviderListBox.hpp>
00014
00015
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PushButton.cpp File Reference

Gui/PushButton.cpp File Reference

#include "Gui/PreComp.hpp"
#include "PushButton.hpp"
#include "Action.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for PushButton.cpp:

Generated on Tue Jan 24 20:47:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PushButton.hpp File Reference

Gui/PushButton.hpp File Reference

#include <Gui/AbstractButton.hpp>
#include <Gui/View.hpp>

Include dependency graph for PushButton.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PushButton
class | PushButtonView
Describes the view of a pushbutton. More...

Defines

#define | Apoxi_PushButton_hpp

Define Documentation

#define Apoxi_PushButton_hpp

Generated on Tue Jan 24 20:47:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/PushButton.hpp Source File

Gui/PushButton.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_PushButton_hpp)
00011 #define Apoxi_PushButton_hpp
00015
00016 class PushButton;
00017 #include <Gui/AbstractButton.hpp>
00018 #include <Gui/View.hpp>
00019
00021 class PushButtonView : public View {
00022     typedef View Base;
00023
00024     public:
00026         PushButtonView();
00027
00029         PushButtonView(XYDIM default_height);
00030
00032         virtual ~PushButtonView();
00033
00035         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00036
00037     protected:
00039         virtual void DrawPushButton(const PushButton& push_button, DeviceContext* dc, const Rect& repaint_rect) const = 0;
00040 };
00041
00044 class PushButton : public AbstractButton {
00045     typedef AbstractButton Base;
00046
00047     public:
00048         enum {
00049             ID = 20
00050         };
00051
00054         PushButton();
00055
00058         PushButton(Control* parent, Action* action);
00059
00061         virtual ~PushButton();
00062
00063
00066         void Init(Control* parent, Action* action);
00067
00069         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00070
00072         virtual BOOLEAN IsInstanceOf(INT id) const;
00073
00075         void SetAction(Action* action) { SetAbstractAction(action); }
00076
00078         Action* GetAction() const { return GetAbstractAction(); }
00079
00080     protected:
00082         virtual void Refresh(const Rect& rect);
00083
00085         virtual void OnThemeChanged();
00086 };
00087
00089 #endif  // Apoxi_PushButton_hpp
00090
00091
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButton.hpp File Reference

Gui/RadioButton.hpp File Reference

#include <Compat/RadioButton.hpp>

Include dependency graph for RadioButton.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButton.hpp Source File

Gui/RadioButton.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class RadioButton has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.2.*/
00013 #include <Compat/RadioButton.hpp>
00014
00015
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonAction.cpp File Reference

Gui/RadioButtonAction.cpp File Reference

#include "Gui/PreComp.hpp"
#include "RadioButtonGroup.hpp"
#include "RadioButtonAction.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"

Include dependency graph for RadioButtonAction.cpp:

Generated on Tue Jan 24 20:47:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonAction.hpp File Reference

Gui/RadioButtonAction.hpp File Reference

#include <Gui/AbstractToggleAction.hpp>

Include dependency graph for RadioButtonAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RadioButtonAction

Defines

#define | Apoxi_RadioButtonAction_hpp

Define Documentation

#define Apoxi_RadioButtonAction_hpp

Generated on Tue Jan 24 20:47:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonAction.hpp Source File

Gui/RadioButtonAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_RadioButtonAction_hpp)
00010 #define Apoxi_RadioButtonAction_hpp
00014
00015 #include <Gui/AbstractToggleAction.hpp>
00016
00017 class RadioButtonGroup;
00018
00026 class RadioButtonAction : public AbstractToggleAction {
00027     typedef AbstractToggleAction Base;
00028
00029     public:
00030         enum {
00031             ID = 6
00032         };
00033
00034         RadioButtonAction();
00035
00048         explicit RadioButtonAction(Dispatcher* dispatcher,
00049                                    RadioButtonGroup* rb_group,
00050                                    const WCHAR* text,
00051                                    BOOLEAN selected = FALSE,
00052                                    BOOLEAN enabled = TRUE,
00053                                    INT value = 0);
00054
00055         virtual ~RadioButtonAction();
00056
00069         void Init(Dispatcher* dispatcher,
00070                   RadioButtonGroup* rb_group,
00071                   const WCHAR* text,
00072                   BOOLEAN selected = FALSE,
00073                   BOOLEAN enabled = TRUE,
00074                   INT value = 0);
00075
00078         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id);
00079
00081         virtual void SetSelected(BOOLEAN select);
00082
00084         virtual BOOLEAN Toggle(BOOLEAN old_state);
00085
00090         void SetGroup(RadioButtonGroup* rb_group);
00091
00096         RadioButtonGroup* GetGroup() { return m_group; }
00097
00099         virtual BOOLEAN IsInstanceOf(INT id) const;
00100
00102         explicit RadioButtonAction(const WCHAR* text,
00103                                    BOOLEAN enabled = TRUE,
00104                                    BOOLEAN selected = FALSE,
00105                                    RadioButtonGroup* rb_group = 0,
00106                                    INT value = 0);
00107
00109         explicit RadioButtonAction(Dispatcher* dispatcher,
00110                                    const WCHAR* text,
00111                                    BOOLEAN enabled = TRUE,
00112                                    BOOLEAN selected = FALSE,
00113                                    RadioButtonGroup* rb_group = 0,
00114                                    INT value = 0);
00115
00117         void Init(const WCHAR* text,
00118                   BOOLEAN enabled = TRUE,
00119                   BOOLEAN selected = FALSE,
00120                   RadioButtonGroup* rb_group = 0,
00121                   INT value = 0);
00122
00124         void Init(Dispatcher* dispatcher,
00125                   const WCHAR* text,
00126                   BOOLEAN enabled = TRUE,
00127                   BOOLEAN selected = FALSE,
00128                   RadioButtonGroup* rb_group = 0,
00129                   INT value = 0);
00130
00132         virtual const BitmapRes* GetSelectedIcon() const;
00133
00135         virtual const BitmapRes* GetDeselectedIcon() const;
00136
00137     private:
00138         RadioButtonGroup* m_group;
00139
00141         void UpdateIcon();
00142 };
00143
00145 #endif // Apoxi_RadioButtonAction_hpp
00146
Generated on Tue Jan 24 14:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonControl.cpp File Reference

Gui/RadioButtonControl.cpp File Reference

#include "Gui/PreComp.hpp"
#include "PaintDc.hpp"
#include "RadioButtonControl.hpp"
#include "ThemeManager.hpp"
#include "RadioButtonGroup.hpp"
#include "Locale.hpp"

Include dependency graph for RadioButtonControl.cpp:

Generated on Tue Jan 24 20:47:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonControl.hpp File Reference

Gui/RadioButtonControl.hpp File Reference

#include <Gui/AbstractButton.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <Gui/View.hpp>

Include dependency graph for RadioButtonControl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RadioButtonControl
class | RadioButtonControlView
Describes the view of a radiobutton-control. More...

Defines

#define | Apoxi_RadioButtonControl_hpp

Define Documentation

#define Apoxi_RadioButtonControl_hpp

Generated on Tue Jan 24 20:47:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonControl.hpp Source File

Gui/RadioButtonControl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_RadioButtonControl_hpp)
00011 #define Apoxi_RadioButtonControl_hpp
00015
00016 #include <Gui/AbstractButton.hpp>
00017 #include <Gui/RadioButtonAction.hpp>
00018 #include <Gui/View.hpp>
00019
00020 class RadioButtonGroup;
00021
00023 class RadioButtonControlView : public View {
00024     typedef View Base;
00025
00026     public:
00028         RadioButtonControlView();
00029
00031         RadioButtonControlView(XYDIM default_height);
00032
00034         virtual ~RadioButtonControlView();
00035
00037         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00038
00040         virtual void Update(const Theme& theme);
00041 };
00042
00049 class RadioButtonControl : public AbstractButton {
00050     typedef AbstractButton Base;
00051
00052     public:
00053         enum {
00054             ID = 21
00055         };
00056
00059         RadioButtonControl();
00060
00066         RadioButtonControl(Control* parent,
00067                            RadioButtonGroup* group,
00068                            const WCHAR* text,
00069                            BOOLEAN selected = FALSE);
00070
00072         virtual ~RadioButtonControl();
00073
00079         void Init(Control* parent,
00080                   RadioButtonGroup* group,
00081                   const WCHAR* text,
00082                   BOOLEAN selected = FALSE);
00083
00085         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00086
00088         virtual BOOLEAN IsInstanceOf(INT id) const;
00089
00091         void SetGroup(RadioButtonGroup* group) { m_radiobutton_action.SetGroup(group); }
00092
00095         void SetSelected(BOOLEAN selected) { m_radiobutton_action.SetSelected(selected); }
00096
00098         BOOLEAN IsSelected() const { return m_radiobutton_action.IsSelected(); }
00099
00101         void SetValue(INT value) { m_radiobutton_action.SetValue(value); }
00102
00104         INT GetValue() const { return m_radiobutton_action.GetValue(); }
00105
00106     protected:
00108         virtual void Refresh(const Rect& rect);
00109
00111         virtual void OnThemeChanged();
00112
00113     private:
00114         RadioButtonAction m_radiobutton_action;
00115         static RadioButtonControlView m_view;
00116 };
00117
00119 #endif  // Apoxi_RadioButtonControl_hpp
00120
00121
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonGroup.cpp File Reference

Gui/RadioButtonGroup.cpp File Reference

#include "Gui/PreComp.hpp"
#include "RadioButtonGroup.hpp"

Include dependency graph for RadioButtonGroup.cpp:

Generated on Tue Jan 24 20:47:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonGroup.hpp File Reference

Gui/RadioButtonGroup.hpp File Reference

#include <Gui/ToggleActionGroup.hpp>
#include <Gui/RadioButtonAction.hpp>

Include dependency graph for RadioButtonGroup.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RadioButtonGroup
Handles deselection of radiobutton-actions. More...

Defines

#define | Apoxi_RadioButtonGroup_hpp

Define Documentation

#define Apoxi_RadioButtonGroup_hpp

Generated on Tue Jan 24 20:47:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonGroup.hpp Source File

Gui/RadioButtonGroup.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_RadioButtonGroup_hpp)
00010 #define Apoxi_RadioButtonGroup_hpp
00014
00015 #include <Gui/ToggleActionGroup.hpp>
00016 #include <Gui/RadioButtonAction.hpp>
00017
00019 class RadioButtonGroup : public ToggleActionGroup {
00020     typedef ToggleActionGroup Base;
00021
00022     public:
00024         RadioButtonGroup();
00025
00027         virtual ~RadioButtonGroup();
00028
00030         void Init();
00031
00033         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00034
00036         void SetSelectedRadioButtonAction(RadioButtonAction* rb) { SetSelectedToggleAction(rb); }
00037
00039         RadioButtonAction* GetSelectedRadioButtonAction() { return (RadioButtonAction*)GetSelectedToggleAction(); }
00040 };
00041
00043 #endif // Apoxi_RadioButtonGroup_hpp
00044
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonItem.hpp File Reference

Gui/RadioButtonItem.hpp File Reference

#include <Compat/RadioButtonItem.hpp>

Include dependency graph for RadioButtonItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonItem.hpp Source File

Gui/RadioButtonItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class RadioButtonItem has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.2.*/
00013 #include <Compat/RadioButtonItem.hpp>
00014
00015
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonList.hpp File Reference

Gui/RadioButtonList.hpp File Reference

#include <Compat/RadioButtonList.hpp>

Include dependency graph for RadioButtonList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RadioButtonList.hpp Source File

Gui/RadioButtonList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class RadioButtonList has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.2.*/
00013 #include <Compat/RadioButtonList.hpp>
00014
00015
Generated on Tue Jan 24 14:49:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Rect.cpp File Reference

Gui/Rect.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/Rect.hpp"

Include dependency graph for Rect.cpp:

Generated on Tue Jan 24 20:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Rect.hpp File Reference

Gui/Rect.hpp File Reference

#include <Gui/Point.hpp>
#include <Gui/Size.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for Rect.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Rect

Defines

#define | Apoxi_Rect_hpp

Define Documentation

#define Apoxi_Rect_hpp

Generated on Tue Jan 24 20:48:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Rect.hpp Source File

Gui/Rect.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Rect_hpp)
00010 #define Apoxi_Rect_hpp
00013
00014 #include <Gui/Point.hpp>
00015 #include <Gui/Size.hpp>
00016 #include <Kernel/Os/Os.hpp>
00017
00018
00021 class Rect {
00022     public:
00025         Rect();
00026
00028         Rect(XYDIM left, XYDIM top, XYDIM right, XYDIM bottom);
00029
00031         Rect(const Point& pos, const Size& size);
00032
00033         // needed because of a bug in the tasking-compiler
00034         Rect(const Rect& rect) { *this = rect; }
00035
00037         void SetLeft(XYDIM left) { m_left = left; }
00038
00040         XYDIM GetLeft() const { return m_left; }
00041
00043         void SetTop(XYDIM top) { m_top = top; }
00044
00046         XYDIM GetTop() const { return m_top; }
00047
00049         void SetRight(XYDIM right)  { m_right = right; }
00050
00052         XYDIM GetRight() const  { return m_right;}
00053
00055         void SetBottom(XYDIM bottom) { m_bottom = bottom; }
00056
00058         XYDIM GetBottom() const { return m_bottom; }
00059
00061         void SetWidth(XYDIM width) { m_right = m_left + width - 1; }
00062
00064         XYDIM GetWidth() const { return m_right - m_left + 1; }
00065
00067         void SetHeight(XYDIM height) { m_bottom = m_top + height - 1; }
00068
00070         XYDIM GetHeight() const { return m_bottom - m_top + 1; }
00071
00073         void SetSize(const Size& size);
00074
00076         void SetSize(XYDIM width, XYDIM height);
00077
00079         Size GetSize() const { return Size(GetWidth(), GetHeight()); }
00080
00082         void Move(XYDIM dx, XYDIM dy);
00083
00085         void SetEmpty();
00086
00090         BOOLEAN IsEmpty() const { return (m_right < m_left || m_bottom < m_top); }
00091
00093         const Rect& Intersect(const Rect& rect);
00094
00096         const Rect& Union(const Rect& rect);
00097
00099         BOOLEAN IsInside(const Rect& rect) const;
00100
00102         void Set(XYDIM left, XYDIM top, XYDIM right, XYDIM bottom);
00103
00105         void Expand(XYDIM left, XYDIM top = 0, XYDIM right = 0, XYDIM bottom = 0);
00106
00108         BOOLEAN operator==(const Rect& rect) const;
00109
00111         BOOLEAN operator!=(const Rect& rect) const;
00112
00114         void SetPos(const Point& pos);
00115
00117         void SetPos(XYDIM x, XYDIM y);
00118
00120         Point GetPos() const;
00121
00123         void SetXPos(XYDIM x);
00124
00126         XYDIM GetXPos() const;
00127
00129         void SetYPos(XYDIM y);
00130
00132         XYDIM GetYPos() const;
00133
00134     protected:
00135         XYDIM m_left;
00136         XYDIM m_top;
00137         XYDIM m_right;
00138         XYDIM m_bottom;
00139 };
00140
00142 #endif  // Apoxi_Rect_hpp
00143
00144
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceManager.cpp File Reference

Gui/ResourceManager.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ResourceManager.hpp"
#include "ResourceParser.hpp"
#include "GuiObjectIterator.hpp"
#include "GuiPropertyIterator.hpp"
#include "GuiPropertyIdIterator.hpp"
#include <Config/GuiObjectFactory.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Afs/Registry.hpp>
#include <Afs/RegistryTypes.hpp>
#include <Auxiliary/DataItem.hpp>

Include dependency graph for ResourceManager.cpp:

Defines

#define ONLINE_RENDER_FILE_VERSION 2;

Define Documentation

#define ONLINE_RENDER_FILE_VERSION 2;

Generated on Tue Jan 24 20:22:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceManager.hpp File Reference

Gui/ResourceManager.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_ResourceManager_hpp

Define Documentation

#define Apoxi_ResourceManager_hpp

Generated on Tue Jan 24 20:22:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceManager.hpp Source File

Gui/ResourceManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ResourceManager_hpp)
00010 #define Apoxi_ResourceManager_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Kernel/Os/Mutex.hpp>
00017 #include <Gui/ResourceReader.hpp>
00018
00025 class ResourceManager {
00026
00027     public:
00029         ~ResourceManager();
00030
00032         static const WCHAR c_uri_separator;
00034         static const WCHAR c_nvp_separator;
00035
00039         static ResourceManager& GetInstance();
00040
00050         void* Construct(const WString& uri,
00051                         UINT16* top_object_id = 0,
00052                         GuiObjectFactory::ClassType* top_object_classtype = 0);
00053
00064         void* Construct(const WString& uri,
00065                         BinData* data,
00066                         ResourceReader::DataType data_type,
00067                         UINT16* top_object_id = 0,
00068                         GuiObjectFactory::ClassType* top_object_classtype = 0);
00069
00077         void* GetFromObjectPool(ResourceParser& parser,
00078                                 const GuiObjectDescr& descr,
00079                                 GuiObjectDescr* returned_object_descr);
00080
00095         BOOLEAN Destruct(const WString& uri,
00096                          void* object = 0);
00097
00105         BOOLEAN Destruct(void* object);
00106
00108         void DestructAll();
00109
00123         void* GetObject(const WString& uri,
00124                         INT id,
00125                         void* object = 0,
00126                         GuiObjectFactory::ClassType* class_type = 0);
00127
00139         ChildBinData* GetData (const WString& uri_in_ctd,
00140                                const WString& resource_uri,
00141                                ResourceReader::DataType* data_type = 0);
00142
00148         BOOLEAN GetDataType(const WString& uri, ResourceReader::DataType& type);
00149
00152         INT GetFileEntryCount(const WString& uri);
00153
00161         BOOLEAN GetDataInfoByIndex(const WString& uri,
00162                                    UINT16 idx,
00163                                    UINT16& id,
00164                                    ResourceReader::DataType& type);
00165
00168         INT GetFileVersion(const WString& uri);
00169
00172         BOOLEAN IsResourceFile(const WString& uri, const WString& device_id = L"rfs");
00173
00177
00184         BOOLEAN AddObject(const WString& uri,
00185                           const GuiObjectDescr& descriptor,
00186                           void* instance = 0);
00187
00201         BOOLEAN SetObjectUntreated(const WString& uri,
00202                                    void* instance,
00203                                    GuiObjectFactory::ClassType class_type,
00204                                    GuiObjectFactory::PropertyId prop_id,
00205                                    UINT16 comp_id);
00206
00207 // old ArmCC versions can't compile these private structs. If it's such an old version,
00208 // make the structs public. If it's a new version, or we're not using ArmCC at all,
00209 // make them private.
00210 #ifdef __ARMCC_VERSION
00211     #if (__ARMCC_VERSION>=200000)
00212         private:
00213     #endif
00214 #else
00215         private:
00216 #endif
00217
00218         struct GuiObject {
00219             INT m_id;
00220             GuiObjectFactory::ClassType m_class_type;
00221             void* m_instance;
00222         };
00223
00231         struct UntreatedGuiObject {
00232             void* m_instance;
00233             GuiObjectFactory::ClassType m_class_type;
00234             GuiObjectFactory::PropertyId m_prop_id; // property that needs to be treated
00235             UINT16 m_comp_id; // id of component that needs to be set
00236         };
00237
00239         struct Instance {
00240             Vector<GuiObject> m_objects;    // objects created from description
00241             Vector<UntreatedGuiObject> m_untreated_objects;
00242         };
00243
00247         struct CtdResource {
00248             UINT16 m_resource_id;   // id in resource file
00249             Vector<Instance> m_instances;
00250         };
00251
00252
00253     private:
00255         static BOOLEAN m_is_initialized;
00256
00258         static Mutex m_mutex;
00259
00261         static WString m_objectpool_uri;
00262
00265         struct ResourceFile {
00266             WString m_uri;
00267             ResourceReader* m_reader;
00268             Vector<CtdResource> m_resources;
00269         };
00270
00273         Vector<ResourceFile> m_files;
00274
00275         INT m_cur_res_idx;
00276         INT m_cur_instance_idx;
00277         WString m_cur_construction_uri;
00278
00280         ResourceManager();
00281
00283         ResourceManager(const ResourceManager& obj);
00284
00286         void Init();
00287
00295         BOOLEAN Destruct(INT16 file_idx,
00296                          INT16 res_idx,
00297                          INT16 instance_idx = -1,
00298                          BOOLEAN force = FALSE);
00299
00308         BOOLEAN CleanupFile(INT16 file_idx);
00309
00320         BOOLEAN Finalize(const WString& uri,
00321                          INT16 file_idx,
00322                          INT16 res_idx,
00323                          INT16 instance_idx);
00324
00325         void* GetFromObjectPoolI(const WString& uri,
00326                                  INT id,
00327                                  GuiObjectDescr* returned_object_descr);
00328
00332         INT16 GetFileIndex(const WString& uri);
00333
00337         INT16 GetResourceIndex(const WString& uri,
00338                                INT16& instance_idx,
00339                                void* object = 0);
00340
00343         UINT16 OpenFile(const WString& uri);
00344
00349         WString GetAbsoluteUri(const WString& uri,
00350                                const WString& resource_uri);
00351
00354         WString RemoveIdFromUri(const WString& uri);
00355
00359         BOOLEAN GetIdFromUri(const WString& uri, UINT16& id);
00360
00363         BOOLEAN IsRelativeUri(const WString& uri);
00364
00366         WString GetTypeCorrectedUri(const WString& uri);
00367
00379         BufferedData* ReadFileFromHostFileSystem(const WString& uri);
00380 };
00381
00383 #endif // DOXYGEN_SHOULD_SKIP_THIS
00384 #endif // Apoxi_ResourceManager_hpp
00385
Generated on Tue Jan 24 14:49:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceParser.cpp File Reference

Gui/ResourceParser.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ResourceParser.hpp"
#include <Auxiliary/IpAddr.hpp>
#include <Gui/ItemRendererProperties.hpp>
#include <Gui/ContextMenu.hpp>
#include <Gui/AnimatedTextLine.hpp>
#include <Gui/MessageBox.hpp>
#include <Gui/InputMapper.hpp>
#include <Gui/PredInputMapper.hpp>
#include <Gui/PositionIndicator.hpp>
#include <Gui/GuiPropertyIterator.hpp>
#include <Gui/ResourceManager.hpp>

Include dependency graph for ResourceParser.cpp:

Generated on Tue Jan 24 20:48:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceParser.hpp File Reference

Gui/ResourceParser.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_ResourceParser_hpp

Define Documentation

#define Apoxi_ResourceParser_hpp

Generated on Tue Jan 24 20:48:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceParser.hpp Source File

Gui/ResourceParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ResourceParser_hpp)
00010 #define Apoxi_ResourceParser_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #ifndef APOXI_ARAGON_MAX_BUFFER_SIZE
00016     // maximum length is calculated as 9 * 256 (9 items in iconset, each path can be 256 chars long)
00017     #define APOXI_ARAGON_MAX_BUFFER_SIZE 2340
00018 #endif
00019
00020 #include <Kernel/Types.hpp>
00021 #include <Auxiliary/BinData.hpp>
00022 #include <Gui/GuiObjectDescr.hpp>
00023 #include <Config/GuiObjectFactory.hpp>
00024
00028 class ResourceParser {
00029     public:
00030
00031         ResourceParser(BinData* bin_data, const WString& resource_uri);
00032
00033         ~ResourceParser();
00034
00036         void Release();
00037
00038         WString GetResourceUri() const { return m_resource_uri; }
00039
00041         INT GetFileVersion() const { return m_file_version; }
00042
00048         BOOLEAN GetPropertyValue(const GuiObjectFactory::PropertyId property_id, void* value);
00049
00050         UINT32 GetPos() const { return m_pos; }
00051
00052         void SetPos(UINT32 pos) { m_pos = pos; }
00053
00054         BOOLEAN Skip(UINT32 bytes);
00055
00056         GuiObjectDescr ReadGuiObjectDescr();
00057
00058         UINT32 ReadCompressedLength();
00059
00060         BOOLEAN ReadBoolean();
00061
00062         String ReadString();
00063         WString ReadWString();
00064
00065         UINT8 ReadUInt8();
00066         UINT16 ReadUInt16();
00067         UINT32 ReadUInt32();
00068
00069         INT8 ReadInt8();
00070         INT16 ReadInt16();
00071         INT32 ReadInt32();
00072
00073     private:
00074         WString m_resource_uri;
00075         BinData* m_bin_data;
00076         UINT32 m_pos;
00077         INT m_file_version;
00078
00079         static CHAR m_buffer[APOXI_ARAGON_MAX_BUFFER_SIZE];
00080 };
00081
00083 #endif // DOXYGEN_SHOULD_SKIP_THIS
00084 #endif // Apoxi_ResourceParser_hpp
00085
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceReader.cpp File Reference

Gui/ResourceReader.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ResourceReader.hpp"
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/FileBinData.hpp>

Include dependency graph for ResourceReader.cpp:

Generated on Tue Jan 24 20:48:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceReader.hpp File Reference

Gui/ResourceReader.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_ResourceReader_hpp

Define Documentation

#define Apoxi_ResourceReader_hpp

Generated on Tue Jan 24 20:48:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ResourceReader.hpp Source File

Gui/ResourceReader.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ResourceReader_hpp)
00010 #define Apoxi_ResourceReader_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Kernel/Types.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017 #include <Auxiliary/ChildBinData.hpp>
00018 #include <Auxiliary/BufferedData.hpp>
00019
00020 class BinData;
00021 class File;
00022 class Path;
00023
00025 typedef NiSharedPtr<File> FilePtr;
00026
00030 class ResourceReader {
00031
00032     public:
00033
00034         enum DataType {
00035             BinaryData = 0,
00036             GuiCtdData,
00037             ThemeCtdData,
00038             ObjectPoolData
00039         };
00040
00041         ResourceReader(const FilePtr& file);
00042
00043         ResourceReader(const Path& file_path);
00044
00045         ~ResourceReader();
00046
00051         ChildBinData* GetData(UINT16 resource_id, DataType* type = 0) const;
00052
00058         ChildBinData* GetDataByIndex(UINT16 idx, DataType* type = 0) const;
00059
00062         BOOLEAN Contains(UINT16 resource_id) const;
00063
00067         BOOLEAN GetDataType(UINT16 resource_id, ResourceReader::DataType& type) const;
00068
00073         BOOLEAN GetDataInfoByIndex(UINT16 idx, UINT16& id, ResourceReader::DataType& type) const;
00074
00076         INT GetFileVersion() const;
00077
00079         BOOLEAN HasResourceFile() const { return m_has_resource_file; }
00080
00082         UINT16 GetEntryCount() const { return m_toccount; }
00083
00084
00085     private:
00087         BOOLEAN ReadToc();
00088
00089         BOOLEAN GetIndex(UINT16 resource_id, UINT16& idx) const;
00090
00091         struct TocEntry {
00092             UINT16 m_id;
00093             UINT32 m_offset;
00094             UINT32 m_length;
00095             DataType m_type;
00096         };
00097
00098         BinData* m_bindata;
00099         UINT8 m_file_version;
00100         UINT16 m_toccount;
00101         TocEntry* m_tocentries;
00102         BOOLEAN m_has_resource_file;
00103 };
00104
00106 #endif // DOXYGEN_SHOULD_SKIP_THIS
00107 #endif // Apoxi_ResourceReader_hpp
00108
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RomFont.cpp File Reference

Gui/RomFont.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/RomFont.hpp"

Include dependency graph for RomFont.cpp:

Generated on Tue Jan 24 20:48:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RomFont.hpp File Reference

Gui/RomFont.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Font.hpp>

Include dependency graph for RomFont.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RomFont

Defines

#define | Apoxi_RomFont_hpp

Define Documentation

#define Apoxi_RomFont_hpp

Generated on Tue Jan 24 20:48:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/RomFont.hpp Source File

Gui/RomFont.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_RomFont_hpp)
00010 #define Apoxi_RomFont_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Gui/Font.hpp>
00016
00019 class RomFont : public Font {
00020     typedef Font Base;
00021
00022     public:
00024         RomFont();
00025
00027         RomFont(const FontRes& font_res);
00028
00030         virtual ~RomFont();
00031
00033         void Set(const FontRes& font_res) { m_font_res = font_res; }
00034
00036         virtual const WCHAR* GetName() const;
00037
00039         virtual void GetGlyph(WCHAR chr, TextAttr text_attr, GlyphPtr glyph) const;
00040
00042         virtual INT GetHeight() const;
00043
00045         virtual INT GetBaseline() const;
00046
00048         virtual INT GetGapToNextChar(WCHAR character = 0) const;
00049
00051         virtual BOOLEAN SupportsTextAttr(TextAttr text_attr) const;
00052
00053     private:
00054         FontRes m_font_res;
00055 };
00056
00058 #endif  // Apoxi_RomFont_hpp
00059
00060
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ScrollBehavior.hpp File Reference

Gui/ScrollBehavior.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_ScrollBehavior_hpp
#define | Behavior ScrollBehavior

Enumerations

enum | ScrollBehavior { DefaultBehavior, BlockScrollBehavior, RotateBehavior, EndlessLoopBehavior }

Define Documentation

#define Apoxi_ScrollBehavior_hpp

Generated on Tue Jan 24 20:48:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ScrollBehavior.hpp Source File

Gui/ScrollBehavior.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ScrollBehavior_hpp)
00011 #define Apoxi_ScrollBehavior_hpp
00014
00015 // provide backward compatibility with older APOXI-version < 1.6.2
00016 #if !defined(Behavior)
00017 #define Behavior ScrollBehavior
00018 #endif
00019
00025 enum ScrollBehavior {
00030     DefaultBehavior,
00034     BlockScrollBehavior,
00040     RotateBehavior,
00046     EndlessLoopBehavior
00047 };
00048
00050 #endif  // Apoxi_Scroll_Behaviour_hpp
00051
00052
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SetLanguageAction.hpp File Reference

Gui/SetLanguageAction.hpp File Reference

#include <Compat/SetLanguageAction.hpp>

Include dependency graph for SetLanguageAction.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SetLanguageAction.hpp Source File

Gui/SetLanguageAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class SetLanguageAction has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/SetLanguageAction.hpp>
00014
00015
Generated on Tue Jan 24 14:49:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SetThemeAction.hpp File Reference

Gui/SetThemeAction.hpp File Reference

#include <Compat/SetThemeAction.hpp>

Include dependency graph for SetThemeAction.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SetThemeAction.hpp Source File

Gui/SetThemeAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class SetThemeAction has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/SetThemeAction.hpp>
00014
00015
Generated on Tue Jan 24 14:49:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SimpleTextRenderer.cpp File Reference

Gui/SimpleTextRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "SimpleTextRenderer.hpp"
#include <Devices/Display.hpp>

Include dependency graph for SimpleTextRenderer.cpp:

Generated on Tue Jan 24 20:48:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SimpleTextRenderer.hpp File Reference

Gui/SimpleTextRenderer.hpp File Reference

#include <Gui/AbstractTextRenderer.hpp>
#include <Gui/EditorDocument.hpp>

Include dependency graph for SimpleTextRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimpleTextRenderer

Defines

#define | Apoxi_SimpleTextRenderer_hpp

Define Documentation

#define Apoxi_SimpleTextRenderer_hpp

Generated on Tue Jan 24 20:48:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SimpleTextRenderer.hpp Source File

Gui/SimpleTextRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SimpleTextRenderer_hpp)
00010 #define Apoxi_SimpleTextRenderer_hpp
00013
00014 #include <Gui/AbstractTextRenderer.hpp>
00015 #include <Gui/EditorDocument.hpp>
00016
00020 class SimpleTextRenderer : public AbstractTextRenderer {
00021     typedef AbstractTextRenderer Base;
00022
00023     public:
00024         virtual ~SimpleTextRenderer();
00025
00027         static SimpleTextRenderer& GetInstance() { return m_instance; }
00028
00030         virtual XYDIM DrawText(DeviceContext* dc,
00031                                const Rect& clip_rect,
00032                                XYDIM x,
00033                                XYDIM y,
00034                                const WCHAR* text,
00035                                INT from,
00036                                INT char_count);
00037
00039         virtual INT GetTextWidth(const WCHAR* text,
00040                                  const Font& font,
00041                                  TextAttr text_attr,
00042                                  INT from,
00043                                  INT char_count,
00044                                  BOOLEAN include_gap = FALSE);
00045
00047         virtual INT WrapLine(const WCHAR* text,
00048                              const Font& font,
00049                              TextAttr text_attr,
00050                              INT char_count,
00051                              XYDIM max_width = -1,
00052                              WrapPolicy policy = (WrapPolicy)0, // this awkward construction is forced on us by the egold compiler. 0 is WhitespaceWrap
00053                              BOOLEAN include_gap_at_end = FALSE,
00054                              Size* total_size = 0,
00055                              INT* ws_at_eol_count = 0,
00056                              XYDIM* ws_at_eol_width = 0,
00057                              INT* last_whitespace_index = 0);
00058
00059     protected:
00060         SimpleTextRenderer();
00061
00063         virtual Size GetGlyph(const WCHAR* cur_text_pos,
00064                               const WCHAR* substitution_char,
00065                               INT char_count,
00066                               GlyphPtr glyph,
00067                               INT& parsed_glyphs,
00068                               BOOLEAN& is_diacritic);
00069
00070     private:
00071         static SimpleTextRenderer m_instance;
00072 };
00073
00074
00076 #endif // Apoxi_SimpleTextRenderer_hpp
00077
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Size.hpp File Reference

Gui/Size.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for Size.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Size

Defines

#define | Apoxi_Size_hpp

Define Documentation

#define Apoxi_Size_hpp

Generated on Tue Jan 24 20:49:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Size.hpp Source File

Gui/Size.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Size_hpp)
00010 #define Apoxi_Size_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00018 class Size {
00019     public:
00020         Size(XYDIM width = 0, XYDIM height = 0) : m_width(width), m_height(height) {}
00021         Size(const Size& size) : m_width(size.GetWidth()), m_height(size.GetHeight()) {}
00022         void SetWidth(XYDIM width) { m_width = width; }
00023         XYDIM GetWidth() const { return m_width; }
00024         void SetHeight(XYDIM height) { m_height = height; }
00025         XYDIM GetHeight() const { return m_height; }
00026
00027     private:
00028         XYDIM m_width;
00029         XYDIM m_height;
00030 };
00031
00033 #endif  // Apoxi_Size_hpp
00034
00035
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SoftkeyBar.hpp File Reference

Gui/SoftkeyBar.hpp File Reference

#include <Compat/SoftkeyBar.hpp>

Include dependency graph for SoftkeyBar.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SoftkeyBar.hpp Source File

Gui/SoftkeyBar.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class SoftkeyBar has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/SoftkeyBar.hpp>
00014
00015
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SyncPaintDc.cpp File Reference

Gui/SyncPaintDc.cpp File Reference

#include "Gui/PreComp.hpp"
#include "SyncPaintDc.hpp"
#include "Control.hpp"
#include "ClientDc.hpp"
#include <Devices/Display.hpp>

Include dependency graph for SyncPaintDc.cpp:

Generated on Tue Jan 24 20:49:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SyncPaintDc.hpp File Reference

Gui/SyncPaintDc.hpp File Reference

#include <Gui/DeviceContext.hpp>

Include dependency graph for SyncPaintDc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SyncPaintDc

Defines

#define | Apoxi_SyncPaintDc_hpp

Define Documentation

#define Apoxi_SyncPaintDc_hpp

Generated on Tue Jan 24 20:49:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/SyncPaintDc.hpp Source File

Gui/SyncPaintDc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SyncPaintDc_hpp)
00010 #define Apoxi_SyncPaintDc_hpp
00013
00014 #include <Gui/DeviceContext.hpp>
00015
00019 class SyncPaintDc : public DeviceContext {
00020     typedef DeviceContext Base;
00021
00022     public:
00028         SyncPaintDc(Control* control);
00029
00031         virtual ~SyncPaintDc();
00032 };
00033
00035 #endif  // Apoxi_SyncPaintDc_hpp
00036
00037
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TabButton.cpp File Reference

Gui/TabButton.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TabButton.hpp"
#include "Bitmap.hpp"
#include "ImageObtainer.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"

Include dependency graph for TabButton.cpp:

Generated on Tue Jan 24 20:49:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TabButton.hpp File Reference

Gui/TabButton.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/AbstractButton.hpp>
#include <Gui/Action.hpp>
#include <Gui/View.hpp>

Include dependency graph for TabButton.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TabButton
class | TabButtonView
Describes the view of a TabButton. More...

Defines

#define | Apoxi_TabButton_hpp

Define Documentation

#define Apoxi_TabButton_hpp

Generated on Tue Jan 24 20:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TabButton.hpp Source File

Gui/TabButton.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TabButton_hpp)
00010 #define Apoxi_TabButton_hpp
00011
00015
00016 #if !defined(APOXI_DISABLE_TAB_CONTROL)
00017
00018 struct BitmapRes;
00019 class TabButton;
00020 class ImageObtainer;
00021
00022 #include <Kernel/Types.hpp>
00023 #include <Gui/AbstractButton.hpp>
00024 #include <Gui/Action.hpp>
00025 #include <Gui/View.hpp>
00026
00028 class TabButtonView : public View {
00029     typedef View Base;
00030
00031     public:
00049         TabButtonView(XYDIM default_height,
00050                       XYDIM default_width = -1,
00051                       XYDIM min_width = -1,
00052                       XYDIM max_width = -1,
00053                       XYDIM clipped_width = 20);
00054
00055         virtual ~TabButtonView();
00056
00058         virtual void Draw(const Component& component,
00059                           DeviceContext* dc,
00060                           const Rect& repaint_rect) const;
00061
00062         XYDIM GetMinimumWidth() const { return m_min_width; }
00063         XYDIM GetMaximumWidth() const { return m_max_width; }
00064         XYDIM GetClippedWidth() const { return m_clipped_width; }
00065
00066     protected:
00068         virtual void DrawTabButton(const TabButton& tab_button,
00069                                    DeviceContext* dc,
00070                                    const Rect& repaint_rect) const = 0;
00071
00072         void SetMinimumWidth(XYDIM min_width) { m_min_width = min_width; }
00073         void SetMaximumWidth(XYDIM max_width) { m_max_width = max_width; }
00074         void SetClippedWidth(XYDIM clipped_width) { m_clipped_width = clipped_width; }
00075
00076     private:
00077         XYDIM m_min_width;
00078         XYDIM m_max_width;
00079         XYDIM m_clipped_width;
00080 };
00081
00086 class TabButton : public AbstractButton {
00087     typedef AbstractButton Base;
00088
00089     public:
00090         enum {
00091             ID = 22
00092         };
00093
00096         enum PositionHint {
00098             LeftPos,
00102             MiddlePos,
00104             RightPos,
00105         };
00106
00109         TabButton();
00110
00114         TabButton(Control* parent, const WString& text, const BitmapRes* icon = 0);
00115
00119         TabButton(Control* parent, const WString& text, const ImageObtainer& icon);
00120
00121         virtual ~TabButton();
00122
00126         void Init(Control* parent, const WString& text, const BitmapRes* icon = 0);
00127
00131         void Init(Control* parent, const WString& text, const ImageObtainer& icon);
00132
00135         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00136
00138         virtual BOOLEAN IsInstanceOf(INT id) const;
00139
00142         void SetActive(BOOLEAN active);
00143
00144         BOOLEAN IsActive() const { return m_active; }
00145
00148         void SetPositionHint(PositionHint pos_hint);
00149
00150         PositionHint GetPositionHint() const { return m_pos_hint; }
00151
00152     protected:
00154         virtual void Refresh(const Rect& rect);
00155
00157         virtual void OnThemeChanged();
00158
00159     private:
00160         BOOLEAN m_active;
00161         PositionHint m_pos_hint;
00162         Action m_action;
00163
00164         void InitProperties(const WString& text, const ImageObtainer& icon);
00165 };
00166
00167 #endif // APOXI_DISABLE_TAB_CONTROL
00168
00170 #endif  // Apoxi_TabButton_hpp
00171
00172
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TabControl.cpp File Reference

Gui/TabControl.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TabControl.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include "TabButton.hpp"
#include "Layouter.hpp"
#include "ImageObtainer.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/LocaleConfig.hpp>
#include <Config/OptionalConfig.hpp>

Include dependency graph for TabControl.cpp:

Generated on Tue Jan 24 20:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TabControl.hpp File Reference

Gui/TabControl.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/View.hpp>
#include <Gui/Control.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for TabControl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TabControl
class | TabControl::Tab
class | TabControlView

Defines

#define | Apoxi_TabControl_hpp

Define Documentation

#define Apoxi_TabControl_hpp

Generated on Tue Jan 24 20:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TabControl.hpp Source File

Gui/TabControl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TabControl_hpp)
00010 #define Apoxi_TabControl_hpp
00014
00015 #if !defined(APOXI_DISABLE_TAB_CONTROL)
00016
00017 class Layouter;
00018 class TabButton;
00019 class TabControl;
00020 class Control;
00021 class WString;
00022 class ImageObtainer;
00023 struct BitmapRes;
00024 #include <Kernel/Types.hpp>
00025 #include <Gui/View.hpp>
00026 #include <Gui/Control.hpp>
00027 #include <Auxiliary/Vector.hpp>
00028
00031 class TabControlView : public View {
00032     typedef View Base;
00033
00034     public:
00041         TabControlView(XYDIM border_size, XYDIM header_height = 0);
00042
00043         virtual ~TabControlView();
00044
00046         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00047
00050         XYDIM GetBorderSize() const { return m_border_size; }
00051
00054         XYDIM GetHeaderHeight() const { return m_header_height; }
00055
00057         virtual void Update(const Theme& theme);
00058
00059     protected:
00061         virtual void DrawTabControl(const TabControl& tab_control,
00062                                     DeviceContext* dc,
00063                                     const Rect& repaint_rect) const = 0;
00064
00065     private:
00066         XYDIM m_border_size;
00067         XYDIM m_header_height;
00068 };
00069
00074 class TabControl : public Control {
00075     typedef Control Base;
00076
00077     public:
00078         enum {
00079             ID = 23
00080         };
00081
00084         TabControl();
00085
00087         TabControl(Control* parent);
00088
00089         virtual ~TabControl();
00090
00092         void Init(Control* parent);
00093
00096         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00097
00099         virtual BOOLEAN IsInstanceOf(INT id) const;
00100
00107         INT AddTab(Control* page, const WString& text, const BitmapRes* icon = 0);
00108
00115         INT AddTab(Control* page, const WString& text, const ImageObtainer& icon);
00116
00126         INT InsertTab(INT index, Control* page, const WString& text, const BitmapRes* icon = 0);
00127
00137         INT InsertTab(INT index, Control* page, const WString& text, const ImageObtainer& icon);
00138
00140         void RemoveTab(INT index);
00141
00145         void SetActiveTab(INT index);
00146
00148         INT GetActiveTab() const { return m_active_tab; }
00149
00153         void SetTabEnabled(INT index, BOOLEAN enabled);
00154
00156         BOOLEAN IsTabEnabled(INT index) const;
00157
00164         void SetHeaderEnabled(BOOLEAN enabled);
00165
00168         BOOLEAN IsHeaderEnabled() const { return m_header_enabled; }
00169
00171         INT GetTabCount() const { return m_tab_vector.GetSize(); }
00172
00174         Control* GetPage(INT index) const;
00175
00177         const WString& GetText(INT index) const;
00178
00180         const ImageObtainer& GetIcon(INT index) const;
00181
00182     protected:
00188         virtual void OnActiveTabChanged(INT old_tab_index);
00189
00191         virtual void Refresh(const Rect& rect);
00192
00194         virtual BOOLEAN OnMessage(const Message& msg);
00195
00197         virtual void OnThemeChanged();
00198
00200         virtual void OnLayoutClient();
00201
00203         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00204
00206         virtual void OnFocusNextControl();
00207
00209         virtual void OnFocusPreviousControl();
00210
00212         virtual void OnLanguageChanged();
00213
00214     private:
00215         class Tab {
00216             public:
00217                 Tab() : m_button(0), m_page(0) {}
00218                 Tab(TabButton* button, Control* page) : m_button(button), m_page(page) {}
00219                 TabButton* GetButton() const { return m_button; }
00220                 Control* GetPage() const { return m_page; }
00221
00222             private:
00223                 TabButton* m_button;
00224                 Control* m_page;
00225         };
00226
00227         BOOLEAN m_header_enabled;
00228         INT m_active_tab;
00229         INT m_first_visible_tab;
00230         Vector<Tab> m_tab_vector;
00231
00232         void InitProperties();
00233         void UpdatePositionHints() const;
00234         BOOLEAN AssureValidIndex(INT& index) const;
00235         void UpdateNavigationGuidance();
00236
00240         void ActivateEnabledTab(BOOLEAN next);
00241
00245         void AdjustFirstVisibleTab();
00246
00249         void LayoutTabButtons();
00250
00258         XYDIM GetTabButtonWidth() const;
00259
00263         XYDIM GetTabButtonHeight() const;
00264 };
00265
00266 #endif // APOXI_DISABLE_TAB_CONTROL
00267
00269 #endif  // Apoxi_TabControl_hpp
00270
Generated on Tue Jan 24 14:50:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextBox.cpp File Reference

Gui/TextBox.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/TextBox.hpp"
#include "Gui/PaintDc.hpp"
#include "Gui/LanguageManager.hpp"

Include dependency graph for TextBox.cpp:

Generated on Tue Jan 24 20:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextBox.hpp File Reference

Gui/TextBox.hpp File Reference

#include <Gui/AbstractTextObject.hpp>

Include dependency graph for TextBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextBox
class | TextBoxView

Defines

#define | Apoxi_TextBox_hpp

Define Documentation

#define Apoxi_TextBox_hpp

Generated on Tue Jan 24 20:49:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextBox.hpp Source File

Gui/TextBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TextBox_hpp)
00010 #define Apoxi_TextBox_hpp
00014
00015 #include <Gui/AbstractTextObject.hpp>
00016
00018 class TextBoxView : public DrawableObjectView {
00019     typedef DrawableObjectView Base;
00020
00021     public:
00022         virtual ~TextBoxView();
00023         virtual void Draw(const Component& component,
00024                           DeviceContext* dc,
00025                           const Rect& repaint_rect) const;
00026 };
00027
00032 class TextBox : public AbstractTextObject {
00033     typedef AbstractTextObject Base;
00034
00035     public:
00036         enum {
00037             ID = 24
00038         };
00039
00042         TextBox();
00043
00052         TextBox(Control* control,
00053                 const WCHAR* text = 0,
00054                 const TextFormat& text_format = TextFormat(),
00055                 BOOLEAN vertical_centered = FALSE);
00056
00057         virtual ~TextBox();
00058
00067         void Init(Control* control,
00068                   const WCHAR* text = 0,
00069                   const TextFormat& text_format = TextFormat(),
00070                   BOOLEAN vertical_centered = FALSE);
00071
00074         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00075
00077         virtual BOOLEAN IsInstanceOf(INT id) const;
00078
00081         void SetVerticalCentered(BOOLEAN vertical_centered);
00082
00085         BOOLEAN IsVerticalCentered() const { return m_vertical_centered; }
00086
00087     private:
00088         BOOLEAN m_vertical_centered;
00089         static TextBoxView m_view;
00090 };
00091
00093 #endif  // Apoxi_TextBox_hpp
00094
00095
Generated on Tue Jan 24 14:50:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextCompoundItem.cpp File Reference

Gui/TextCompoundItem.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TextCompoundItem.hpp"
#include "AtomItem.hpp"
#include "CharItem.hpp"
#include "Font.hpp"
#include "PaintDc.hpp"
#include "ClientDc.hpp"
#include "BidiManager.hpp"
#include <Kernel/System.hpp>
#include <Config/LocaleConfig.hpp>
#include <Config/GuiEngineConfig.hpp>
#include "LanguageManager.hpp"
#include "AbstractTextRenderer.hpp"

Include dependency graph for TextCompoundItem.cpp:

Generated on Tue Jan 24 20:49:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextCompoundItem.hpp File Reference

Gui/TextCompoundItem.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Gui/CompoundItem.hpp>

Include dependency graph for TextCompoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextCompoundItem
Contains a variable number of wide-characters. More...

Defines

#define | Apoxi_TextCompoundItem_hpp

Define Documentation

#define Apoxi_TextCompoundItem_hpp

Generated on Tue Jan 24 20:49:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextCompoundItem.hpp Source File

Gui/TextCompoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TextCompoundItem_hpp)
00011 #define Apoxi_TextCompoundItem_hpp
00015
00016 #include <Auxiliary/WString.hpp>
00017 #include <Gui/CompoundItem.hpp>
00018
00019 class Font;
00020
00022 class TextCompoundItem : public CompoundItem {
00023     typedef CompoundItem Base;
00024
00025     public:
00026         enum {
00027             ID = 6
00028         };
00029
00031         static TextCompoundItem* CreateInstance(const WCHAR* text = 0);
00032
00034         static TextCompoundItem* CreateInstance(const WCHAR* text, const Font& font);
00035
00037         virtual ~TextCompoundItem();
00038
00040         virtual INT GetId() const;
00041
00043         void SetText(const WCHAR* text) { m_text = text; }
00044
00046         const WString& GetText() const { return m_text; }
00047
00049         void Insert(INT index, WCHAR ch) { m_text.insert(index, ch); }
00050
00052         void Replace(INT index, WCHAR ch) { m_text.replace(index, ch); }
00053
00055         void Remove(INT index, INT count = -1) { m_text.erase(index, count); }
00056
00058         void SetFont(const Font& font) { m_font = &font; }
00059
00061         const Font& GetFont() const { ASSERT_DEBUG_HOST(m_font != 0); return *m_font; }
00062
00064         virtual TextAttr GetTextAttr() const;
00065
00072         WCHAR* ExportInternalBuffer(UINT length);
00073
00075         virtual void Draw(DeviceContext* dc,
00076                           XYDIM x,
00077                           XYDIM y,
00078                           INT index,
00079                           INT count) const;
00080
00086         virtual BOOLEAN IsStandaloneCharacter(INT index) const;
00087
00089         virtual INT WrapLine(INT index,
00090                              XYDIM width,
00091                              WrapPolicy wrap_policy = EditorDocument::WhitespaceWrap) const;
00092
00094         virtual XYDIM GetLineWidth(INT index, INT count) const;
00095
00097         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const;
00098
00100         virtual INT GetItemCount() const;
00101
00103         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00104
00106         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00107
00109         virtual BOOLEAN RemoveItem(INT index = -1);
00110
00112         virtual BOOLEAN Split(INT index, CompoundItem** compound_item);
00113
00115         virtual BOOLEAN Merge(const CompoundItem& compound_item);
00116
00118         virtual CompoundItem* Clone() const;
00119
00121         virtual void Clear();
00122
00124         virtual BOOLEAN IsInstanceOf(INT id) const;
00125
00126     protected:
00127         TextCompoundItem(const WCHAR* text = 0);
00128         TextCompoundItem(const WCHAR* text, const Font& font);
00129
00133         void SetDefaultColorHint(BOOLEAN use_default_color) { m_use_default_color = use_default_color; }
00134
00135     private:
00136         BOOLEAN m_use_default_color;
00137         const Font* m_font;
00138         WString m_text;
00139 };
00140
00142 #endif  // Apoxi_TextCompoundItem_hpp
00143
Generated on Tue Jan 24 14:50:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextEditorDocument.cpp File Reference

Gui/TextEditorDocument.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TextEditorDocument.hpp"
#include "AtomItem.hpp"
#include "PaintDc.hpp"
#include "Font.hpp"
#include "Locale.hpp"
#include "BidiManager.hpp"
#include "AbstractEditor.hpp"
#include <Config/FontConfig.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for TextEditorDocument.cpp:

Variables

const WCHAR | c_cr = 0xd
const WCHAR | c_lf = 0xa

Variable Documentation

const WCHAR c_cr = 0xd

const WCHAR c_lf = 0xa

Generated on Tue Jan 24 20:49:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextEditorDocument.hpp File Reference

Gui/TextEditorDocument.hpp File Reference

#include <Gui/EditorDocument.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/TextCompoundItem.hpp>

Include dependency graph for TextEditorDocument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextEditorDocument

Defines

#define | Apoxi_TextEditorDocument_hpp

Define Documentation

#define Apoxi_TextEditorDocument_hpp

Generated on Tue Jan 24 20:49:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextEditorDocument.hpp Source File

Gui/TextEditorDocument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TextEditorDocument_hpp)
00011 #define Apoxi_TextEditorDocument_hpp
00015
00016 #include <Gui/EditorDocument.hpp>
00017 #include <Gui/CharItem.hpp>
00018 #include <Gui/TextCompoundItem.hpp>
00019
00022 class TextEditorDocument : public EditorDocument {
00023     typedef EditorDocument Base;
00024
00025     public:
00027         TextEditorDocument(const WCHAR* text = 0);
00028
00029         virtual ~TextEditorDocument();
00030
00032         void Init(const WCHAR* text = 0);
00033
00035         void SetText(const WCHAR* text);
00036
00038         const WString& GetText() const;
00039
00041         virtual INT GetItemCount() const;
00042
00044         void SetMaxItemCount(INT max_item_count);
00045
00047         virtual INT GetMaxItemCount() const;
00048
00052         void SetCrSupported(BOOLEAN flag) { m_bitfield.cr_supported = flag; }
00053
00056         BOOLEAN IsCrSupported() const { return (BOOLEAN)m_bitfield.cr_supported; }
00057
00059         virtual BOOLEAN InsertItem(const AtomItem& item, INT item_index);
00060
00062         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT item_index);
00063
00065         virtual BOOLEAN RemoveItem(INT item_index);
00066
00068         virtual const CompoundItem& GetCompoundItem(INT ci_index, INT* start_item_index = 0) const;
00069
00071         virtual void Draw(DeviceContext* dc, XYDIM x, XYDIM y,
00072                           INT item_index, INT count) const;
00073
00075         virtual INT WrapLine(INT item_index, XYDIM width, WrapPolicy wrap_policy = WhitespaceWrap) const;
00076
00078         virtual XYDIM GetLineWidth(INT item_index, INT count) const;
00079
00082         void SetFont(const Font& font);
00083
00085         const Font& GetFont() const;
00086
00090         void SetLineHeight(XYDIM line_height) { m_line_height = line_height; }
00091
00095         virtual XYDIM GetLineHeight(INT item_index, INT count, XYDIM* baseline = 0) const;
00096
00098         virtual void GetItemScope(INT item_index,
00099                                   INT count,
00100                                   INT sub_index,
00101                                   XYDIM* x,
00102                                   XYDIM* width) const;
00103
00105         virtual BOOLEAN IsRightToLeftItem(INT item_index) const;
00106
00108         virtual void Clear();
00109
00110     private:
00111         struct {
00112             UINT max_item_count : 15;
00113             UINT cr_supported   : 1;
00114         } m_bitfield;
00115         TextCompoundItem* m_compound_item;
00116         INT m_line_height;
00117 };
00118
00120 #endif  // Apoxi_TextEditorDocument_hpp
00121
00122
Generated on Tue Jan 24 14:50:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextFormat.cpp File Reference

Gui/TextFormat.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TextFormat.hpp"

Include dependency graph for TextFormat.cpp:

Generated on Tue Jan 24 20:49:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextFormat.hpp File Reference

Gui/TextFormat.hpp File Reference

#include <Config/GuiObjectFactory.hpp>

Include dependency graph for TextFormat.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextFormat

Defines

#define | Apoxi_TextFormat_hpp

Typedefs

typedef TextFormat::FontAlign | FontAlign
typedef TextFormat::TextAlign | TextAlign
typedef TextFormat::TextAttr | TextAttr

Define Documentation

#define Apoxi_TextFormat_hpp

Generated on Tue Jan 24 20:50:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextFormat.hpp Source File

Gui/TextFormat.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TextFormat_hpp)
00010 #define Apoxi_TextFormat_hpp
00013
00014 #include <Config/GuiObjectFactory.hpp>
00015
00016 class Font;
00017 class ResourceParser;
00018
00022 class TextFormat {
00023     public:
00025         enum TextAlign {
00028             Default,
00030             Left,
00032             Centered,
00034             Right
00035         };
00036
00037         typedef UINT8 TextAttr;
00038
00043         //  Note: If you extend TextAttr, don't forget to increase the bit-vector in the
00044         //  class TextFormat.
00045         enum TextAttrValues {
00046             Normal          = 0,
00047             Underlined      = (1 << 0),
00048             Italic          = (1 << 1),
00049             Bold            = (1 << 2),
00050             Strikethrough   = (1 << 3)
00051         };
00052
00054         enum FontAlign {
00056             Top,
00058             Baseline,
00060             Bottom
00061         };
00062
00065         TextFormat();
00066
00076         TextFormat(INT system_font_id,
00077                    TextAlign text_align = Default,
00078                    TextAttr text_attr = TextFormat::Normal,
00079                    FontAlign font_align = Top);
00080
00087         TextFormat(const Font& font,
00088                    TextAlign text_align = Default,
00089                    TextAttr text_attr = TextFormat::Normal,
00090                    FontAlign font_align = Top);
00091
00101         void Init(INT system_font_id,
00102                   TextAlign text_align = Default,
00103                   TextAttr text_attr = Normal,
00104                   FontAlign font_align = Top);
00105
00112         void Init(const Font& font,
00113                   TextAlign text_align = Default,
00114                   TextAttr text_attr = Normal,
00115                   FontAlign font_align = Top);
00116
00119         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00120
00124         void SetFont(const Font& font);
00125
00130         void SetFont(INT system_font_id);
00131
00136         const Font& GetFont() const;
00137
00139         void SetTextAlign(TextAlign text_align) { m_bits.text_align = text_align; }
00140
00142         TextAlign GetTextAlign() const { return (TextAlign)m_bits.text_align; }
00143
00147         void SetTextAttr(TextAttr text_attr) { m_bits.text_attr = text_attr; }
00148
00150         TextAttr GetTextAttr() const { return (TextAttr)m_bits.text_attr; }
00151
00153         void SetFontAlign(FontAlign font_align) { m_bits.font_align = font_align; }
00154
00156         FontAlign GetFontAlign() const { return (FontAlign)m_bits.font_align; }
00157
00158         BOOLEAN operator==(const TextFormat& text_format) const;
00159         BOOLEAN operator!=(const TextFormat& text_format) const;
00160
00161     private:
00162         struct {
00163             UINT text_align      : 2;
00164             UINT text_attr       : 4;
00165             UINT font_align      : 2;
00166             UINT use_system_font : 1;
00167         } m_bits;
00168         union {
00169             const Font* m_font;
00170             INT m_system_font_id;
00171         };
00172 };
00173
00174 typedef TextFormat::TextAlign TextAlign;
00175 typedef TextFormat::FontAlign FontAlign;
00176 typedef TextFormat::TextAttr TextAttr;
00177
00179 #endif  // Apoxi_TextFormat_hpp
00180
00181
Generated on Tue Jan 24 14:50:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextLine.cpp File Reference

Gui/TextLine.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TextLine.hpp"
#include "PaintDc.hpp"
#include "LanguageManager.hpp"
#include "Locale.hpp"
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for TextLine.cpp:

Generated on Tue Jan 24 20:50:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextLine.hpp File Reference

Gui/TextLine.hpp File Reference

#include <Gui/Color.hpp>
#include <Gui/AbstractTextObject.hpp>

Include dependency graph for TextLine.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextLine
class | TextLineView
View object which draws a textline. More...

Defines

#define | Apoxi_TextLine_hpp

Define Documentation

#define Apoxi_TextLine_hpp

Generated on Tue Jan 24 20:50:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextLine.hpp Source File

Gui/TextLine.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TextLine_hpp)
00010 #define Apoxi_TextLine_hpp
00014
00015 #include <Gui/Color.hpp>
00016 #include <Gui/AbstractTextObject.hpp>
00017
00019 class TextLineView : public DrawableObjectView {
00020     typedef DrawableObjectView Base;
00021
00022     public:
00023         TextLineView();
00024         virtual ~TextLineView();
00025         void Init();
00026         virtual void Draw(const Component& component,
00027                           DeviceContext* dc,
00028                           const Rect& repaint_rect) const;
00029 };
00030
00033 class TextLine : public AbstractTextObject {
00034     typedef AbstractTextObject Base;
00035
00036     public:
00037         enum {
00038             ID = 25
00039         };
00040
00043         TextLine();
00044
00048         TextLine(Control* control,
00049                  const WCHAR* text = 0,
00050                  const TextFormat& text_format = TextFormat());
00051
00052         virtual ~TextLine();
00053
00057         void Init(Control* control,
00058                   const WCHAR* text = 0,
00059                   const TextFormat& text_format = TextFormat());
00060
00063         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00064
00066         virtual BOOLEAN IsInstanceOf(INT id) const;
00067
00068     private:
00069         static TextLineView m_view;
00070 };
00071
00073 #endif  // Apoxi_TextLine_hpp
00074
00075
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextList.hpp File Reference

Gui/TextList.hpp File Reference

#include <Compat/TextList.hpp>

Include dependency graph for TextList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextList.hpp Source File

Gui/TextList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class TextList has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/TextList.hpp>
00014
00015
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextMenuAccessor.hpp File Reference

Gui/TextMenuAccessor.hpp File Reference

#include <Compat/TextMenuAccessor.hpp>

Include dependency graph for TextMenuAccessor.hpp:

Go to the source code of this file.

Generated on Tue Jan 24 20:22:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextMenuAccessor.hpp Source File

Gui/TextMenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  The class TextMenuAccessor has been moved to Compat.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.10.*/
00013 #include <Compat/TextMenuAccessor.hpp>
00014
00015
Generated on Tue Jan 24 14:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextPack.cpp File Reference

Gui/TextPack.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TextPack.hpp"

Include dependency graph for TextPack.cpp:

Generated on Tue Jan 24 20:50:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextPack.hpp File Reference

Gui/TextPack.hpp File Reference

#include <Gui/AcacTypes.hpp>
#include <Gui/AcacLanguage.hpp>
#include <Gui/DataPack.hpp>

Include dependency graph for TextPack.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextPack

Defines

#define | Apoxi_TextPack_hpp

Define Documentation

#define Apoxi_TextPack_hpp

Generated on Tue Jan 24 20:50:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextPack.hpp Source File

Gui/TextPack.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TextPack_hpp)
00011 #define Apoxi_TextPack_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014 #include <Gui/AcacLanguage.hpp>
00015 #include <Gui/DataPack.hpp>
00016
00022 class TextPack : public DataPack {
00023     public:
00024         typedef DataPack Base;
00025
00031         TextPack(const UINT8 *data);
00032
00036         virtual ~TextPack();
00037
00043         const AcacLanguage *GetLanguage(UINT16 index) const;
00044
00045     private:
00047         TextPackData*       m_text_pack_data;
00048
00050         AcacLanguage **     m_languages;
00051
00052         friend class BasicPackConnector;
00053 };
00054 #endif //Apoxi_TextPack_hpp
00055
00056
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextPackConnector.cpp File Reference

Gui/TextPackConnector.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TextPackConnector.hpp"

Include dependency graph for TextPackConnector.cpp:

Generated on Tue Jan 24 20:50:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextPackConnector.hpp File Reference

Gui/TextPackConnector.hpp File Reference

#include <Gui/AcacTypes.hpp>
#include <Gui/BasicPackConnector.hpp>
#include <Gui/AcacLanguage.hpp>

Include dependency graph for TextPackConnector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TextPackConnector

Defines

#define | Apoxi_TextPackConnector_hpp

Define Documentation

#define Apoxi_TextPackConnector_hpp

Generated on Tue Jan 24 20:50:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TextPackConnector.hpp Source File

Gui/TextPackConnector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TextPackConnector_hpp)
00011 #define Apoxi_TextPackConnector_hpp
00012
00013 #include <Gui/AcacTypes.hpp>
00014 #include <Gui/BasicPackConnector.hpp>
00015 #include <Gui/AcacLanguage.hpp>
00016
00017
00022 class TextPackConnector {
00023     public:
00024
00029         static void Init();
00030
00034         static BOOLEAN IsTextPackAvailable();
00035
00040         static UINT16 GetNumberOfLanguages();
00041
00046         static BOOLEAN GetLanguageNames(const WCHAR **language_names, UINT32 size);
00047
00054         static BOOLEAN SetActiveLanguage(EntryId id);
00055
00061         static BOOLEAN SetActiveLanguageByIndex(UINT16 index);
00062
00070         static BOOLEAN SetActiveLanguage(const AcacLanguage *lang);
00071
00075         static EntryId GetActiveLanguageId();
00076
00080         static INT32 GetIndexOfActiveLanguage();
00081
00085         static const AcacLanguage *GetLanguage(EntryId id);
00086
00090         static const AcacLanguage *GetLanguageAt(UINT16 index);
00091
00095         static const AcacLanguage **GetLanguages();
00096
00100         static const WCHAR *GetText(UINT16 index);
00101
00106         static BOOLEAN ContainsLanguage(EntryId id);
00107
00113         static INT32 GetIndexOfLanguage(const AcacLanguage *language);
00114
00115     private:
00116
00118         static const AcacLanguage *     m_active_language;
00119
00121         static INT32                    m_active_language_index;
00122
00124         static TextPack *               m_language_pack;
00125 };
00126
00127 #endif  // Apoxi_TextPackConnector_hpp
00128
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ThaiTextRenderer.cpp File Reference

Gui/ThaiTextRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ThaiTextRenderer.hpp"
#include <Devices/Display.hpp>
#include <Config/FontConfig.hpp>

Include dependency graph for ThaiTextRenderer.cpp:

Defines

#define APOXI_MAX_THAI_BUFFER_LENGTH 63

Define Documentation

#define APOXI_MAX_THAI_BUFFER_LENGTH 63

Generated on Tue Jan 24 20:51:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ThaiTextRenderer.hpp File Reference

Gui/ThaiTextRenderer.hpp File Reference

#include <Gui/AbstractTextRenderer.hpp>
#include <Gui/EditorDocument.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for ThaiTextRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ThaiTextRenderer
struct | ThaiTextRenderer::ThaiFontHint

Defines

#define | Apoxi_ThaiTextRenderer_hpp

Define Documentation

#define Apoxi_ThaiTextRenderer_hpp

Generated on Tue Jan 24 20:51:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ThaiTextRenderer.hpp Source File

Gui/ThaiTextRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ThaiTextRenderer_hpp)
00010 #define Apoxi_ThaiTextRenderer_hpp
00013
00014 #include <Gui/AbstractTextRenderer.hpp>
00015 #include <Gui/EditorDocument.hpp>
00016 #include <Auxiliary/WString.hpp>
00017
00019 class ThaiTextRenderer : public AbstractTextRenderer {
00020     typedef AbstractTextRenderer Base;
00021
00022     public:
00027         enum CharacterClass {
00028             Ctrl = 0,   // Control character
00029             Non = 1,    // Non-Thai character
00030             Cons = 2,   // Consonant
00031             LV = 3,     // Leading Vowel
00032             FV1 = 4,    // Following Vowel, Type 1
00033             FV2 = 5,    // Following Vowel, Type 2
00034             FV3 = 6,    // Following Vowel, Type 3
00035             BV1 = 7,    // Below Vowel, Type 1
00036             BV2 = 8,    // Below Vowel, Type 2
00037             BD = 9,     // Below Diacritic
00038             Tone = 10,  // Tone
00039             AD1 = 11,   // Above Diacritic, Type 1
00040             AD2 = 12,   // Above Diacritic, Type 2
00041             AD3 = 13,   // Above Diacritic, Type 3
00042             AV1 = 14,   // Above Vowel, Type 1
00043             AV2 = 15,   // Above Vowel, Type 2
00044             AV3 = 16    // Above Vowel, Type 3
00045         };
00046
00048         enum RenderType {
00049             Render = 0,
00050             Compose = 1,
00051             Control = 2
00052         };
00053
00054         virtual ~ThaiTextRenderer();
00055
00057         static ThaiTextRenderer& GetInstance();
00058
00060         virtual XYDIM DrawText(DeviceContext* dc,
00061                                const Rect& clip_rect,
00062                                XYDIM x,
00063                                XYDIM y,
00064                                const WCHAR* text,
00065                                INT from,
00066                                INT char_count);
00067
00069         virtual INT GetTextWidth(const WCHAR* text,
00070                                  const Font& font,
00071                                  TextAttr text_attr,
00072                                  INT from,
00073                                  INT char_count,
00074                                  BOOLEAN include_gap = FALSE);
00075
00077         virtual BOOLEAN IsStandaloneCharacter(const WCHAR* text,
00078                                               INT index);
00079
00081         virtual INT WrapLine(const WCHAR* text,
00082                              const Font& font,
00083                              TextAttr text_attr,
00084                              INT char_count,
00085                              XYDIM max_width = -1,
00086                              WrapPolicy policy = (WrapPolicy)0, // this awkward construction is forced on us by the egold compiler. 0 is WhitespaceWrap
00087                              BOOLEAN include_gap_at_end = FALSE,
00088                              Size* total_size = 0,
00089                              INT* ws_at_eol_count = 0,
00090                              XYDIM* ws_at_eol_width = 0,
00091                              INT* last_completely_fitting_word_length = 0);
00092
00100         struct ThaiFontHint {
00101             XYDIM (*m_cons_offsets)[46];
00102
00103
00104
00105
00106             XYDIM (*m_diacritics_offsets)[19][5];
00107
00108
00109
00110
00111
00112
00113
00114
00115
00116
00117
00118             XYDIM m_above_level_y_offset;
00119             XYDIM m_top_level_y_offset;
00120             XYDIM m_lo_chula_y_offset;
00121             XYDIM m_mai_tho_toplevel_x_offset;
00122
00123             XYDIM m_yo_ying_diacritic_lines;
00124
00125             XYDIM m_tho_than_diacritic_lines;
00126
00127         };
00128
00129     protected:
00130         ThaiTextRenderer();
00131
00137         virtual BOOLEAN BeginGlyphRetrieval(const WCHAR* text_start,
00138                                             const Font& font,
00139                                             TextAttr text_attr);
00140
00146         virtual Size GetGlyph(const WCHAR* cur_text_pos,
00147                               const WCHAR* substitution_char,
00148                               INT char_count,
00149                               GlyphPtr glyph,
00150                               INT& parsed_glyphs,
00151                               BOOLEAN& is_diacritic);
00152
00153     private:
00176         INT PrepareText(const WCHAR* text, INT from, INT char_count);
00177
00182         CharacterClass GetThaiCharacterClass(WCHAR chr) const;
00183
00190         RenderType GetThaiRenderType(WCHAR cur_char, WCHAR prev_char) const;
00191
00199         BOOLEAN HasAscender(WCHAR chr) const;
00200
00205         INT8 GetDiacriticsIndex(WCHAR chr) const;
00206
00208         WString m_buffer;
00209
00211         XYDIM m_prev_x_offset;
00212
00214         ThaiFontHint* m_font_hints;
00215
00219         Glyph m_yo_ying;
00220         UINT8 FONT_HUGE* m_yo_ying_data;
00221         Glyph m_tho_than;
00222         UINT8 FONT_HUGE* m_tho_than_data;
00223
00227         BOOLEAN m_contains_sara_am;
00232         BOOLEAN m_calculate_diacritic_offsets;
00233 };
00234
00235
00237 #endif // Apoxi_SimpleTextRenderer_hpp
00238
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Theme.cpp File Reference

Gui/Theme.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Theme.hpp"
#include "ColorTable.hpp"
#include "View.hpp"
#include <Config/FontConfig.hpp>
#include <Config/ThemeConfig.hpp>

Include dependency graph for Theme.cpp:

Generated on Tue Jan 24 20:51:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Theme.hpp File Reference

Gui/Theme.hpp File Reference

#include <Gui/Font.hpp>
#include <Gui/Color.hpp>

Include dependency graph for Theme.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Theme
class | ThemeViewIterator

Defines

#define | Apoxi_Theme_hpp

Define Documentation

#define Apoxi_Theme_hpp

Generated on Tue Jan 24 20:51:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Theme.hpp Source File

Gui/Theme.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Theme_hpp)
00010 #define Apoxi_Theme_hpp
00013
00014 class WindowFrameView;
00015 class ControlFrameView;
00016 class CheckBoxView;
00017 class RadioButtonView;
00018 class CheckBoxListView;
00019 class RadioButtonListView;
00020 class TextListView;
00021 class PositionIndicatorView;
00022 class ProgressBarView;
00023 class PushButtonView;
00024 class SoftkeyBarView;
00025 class PanelView;
00026 class TabControlView;
00027 class TabButtonView;
00028 class Theme;
00029 class View;
00030
00031 struct ColorTable;
00032 struct BitmapRes;
00033
00034 #include <Gui/Font.hpp>
00035 #include <Gui/Color.hpp>
00036
00037 /*  Internal class, which allows to iterate through all theme views.
00038     The class should not be used by the MMI in a direct manner, as the
00039     interface might get changed in future releases. */
00040 class ThemeViewIterator {
00041     public:
00042         ThemeViewIterator(Theme* theme);
00043         virtual ~ThemeViewIterator();
00044         void Begin();
00045         BOOLEAN Next();
00046         View* GetView() const;
00047
00048     private:
00049         INT m_index;
00050         View* m_view;
00051         Theme* m_theme;
00052 };
00053
00056 class Theme {
00057     public:
00060         enum BitmapResId {
00062             SelectedCheckBoxId,
00064             DeselectedCheckBoxId,
00066             SelectedRadioButtonId,
00068             DeselectedRadioButtonId,
00069         };
00070
00072         virtual const WCHAR* GetName() const;
00073
00078         virtual void Update();
00079
00084         virtual const ColorTable* GetSystemColorTable() const;
00085
00091         virtual ColorValue GetSystemColor(SystemColorId id) const;
00092
00094         INT GetFontId(SystemFontId id) const;
00095
00098         virtual const WindowFrameView* GetWindowFrameView() const = 0;
00099
00102         virtual const ControlFrameView* GetControlFrameView() const = 0;
00103
00106         virtual const PositionIndicatorView* GetPositionIndicatorView() const = 0;
00107
00110         virtual const ProgressBarView* GetProgressBarView() const = 0;
00111
00114         virtual const PushButtonView* GetPushButtonView() const = 0;
00115
00119         virtual const PanelView* GetPanelView() const;
00120
00123         virtual const TabControlView* GetTabControlView() const;
00124
00128         virtual const TabButtonView* GetTabButtonView() const;
00129
00131         virtual const BitmapRes* GetBitmap(BitmapResId id) const;
00132
00133 #ifdef APOXI_COMPAT_1_9_0
00134         // Obsolete
00135         virtual INT GetId() const;
00136
00138         virtual FontId GetSystemFontId(SystemFontId id) const;
00139
00141         virtual const TextListView* GetTextListView() const = 0;
00142
00144         virtual const SoftkeyBarView* GetSoftkeyBarView() const = 0;
00145 #endif
00146
00147 #ifdef APOXI_COMPAT_1_7_0
00148
00149         virtual const CheckBoxView* GetCheckBoxView() const;
00150
00152         virtual const RadioButtonView* GetRadioButtonView() const;
00153
00155         virtual const CheckBoxListView* GetCheckBoxListView() const;
00156
00158         virtual const RadioButtonListView* GetRadioButtonListView() const;
00159 #endif
00160
00161     protected:
00162         Theme();
00163         virtual ~Theme();
00164         void SetSystemColor(SystemColorId id, ColorValue color_value);
00165         void SetFontId(SystemFontId id, INT font_id);
00166
00167     private:
00168         ColorValue m_system_color_table[Color::SystemColorIdCount];
00169         INT m_system_font_table[Font::SystemFontIdCount];
00170 };
00171
00173 #endif  // Apoxi_Theme_hpp
00174
00175
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ThemeManager.cpp File Reference

Gui/ThemeManager.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include "ClientDc.hpp"
#include <Config/ThemeConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include <Kernel/Application.hpp>
#include <Devices/DeviceManager.hpp>

Include dependency graph for ThemeManager.cpp:

Generated on Tue Jan 24 20:51:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ThemeManager.hpp File Reference

Gui/ThemeManager.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ThemeManager
The theme-manager is able to switch between different themes. More...

Defines

#define | Apoxi_ThemeManager_hpp

Define Documentation

#define Apoxi_ThemeManager_hpp

Generated on Tue Jan 24 20:51:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ThemeManager.hpp Source File

Gui/ThemeManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ThemeManager_hpp)
00010 #define Apoxi_ThemeManager_hpp
00013
00014 class Theme;
00015
00017 class ThemeManager {
00018     public:
00020         static void SetActiveTheme(INT active_theme_idx);
00021
00023         static INT GetActiveThemeIndex() { return m_active_theme_idx; }
00024
00026         static const Theme& GetActiveTheme();
00027
00029         static void UpdateThemes();
00030
00031     private:
00032         static INT m_active_theme_idx;
00033         static Semaphore m_sem;
00034         static BOOLEAN m_sem_created;
00035 };
00036
00038 #endif  // Apoxi_ThemeManager_hpp
00039
00040
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeCompoundItem.cpp File Reference

Gui/TimeCompoundItem.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TimeCompoundItem.hpp"
#include <Gui/PaintDc.hpp>

Include dependency graph for TimeCompoundItem.cpp:

Generated on Tue Jan 24 20:51:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeCompoundItem.hpp File Reference

Gui/TimeCompoundItem.hpp File Reference

#include <Gui/CompoundItem.hpp>
#include <Auxiliary/Time.hpp>

Include dependency graph for TimeCompoundItem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TimeCompoundItem
Contains a time. More...

Defines

#define | Apoxi_TimeCompoundItem_hpp

Define Documentation

#define Apoxi_TimeCompoundItem_hpp

Generated on Tue Jan 24 20:51:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeCompoundItem.hpp Source File

Gui/TimeCompoundItem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TimeCompoundItem_hpp)
00011 #define Apoxi_TimeCompoundItem_hpp
00015
00016 #include <Gui/CompoundItem.hpp>
00017 #include <Auxiliary/Time.hpp>
00018
00020 class TimeCompoundItem : public CompoundItem {
00021     typedef CompoundItem Base;
00022
00023     public:
00024         enum {
00025             ID = 7
00026         };
00027
00029         static TimeCompoundItem* CreateInstance(const Time& time = Time());
00030
00032         virtual ~TimeCompoundItem();
00033
00035         virtual INT GetId() const;
00036
00038         void SetTime(const Time& time) { m_time = time; }
00039
00041         const Time& GetTime() const { return m_time; }
00042
00044         virtual void Draw(DeviceContext* dc,
00045                           XYDIM x,
00046                           XYDIM y,
00047                           INT index,
00048                           INT count) const;
00049
00051         virtual INT WrapLine(INT index,
00052                              XYDIM width,
00053                              WrapPolicy wrap_policy = EditorDocument::WhitespaceWrap) const;
00054
00056         virtual XYDIM GetLineWidth(INT index, INT count) const;
00057
00059         virtual XYDIM GetLineHeight(INT index, INT count, XYDIM* baseline = 0) const;
00060
00062         virtual INT GetItemCount() const;
00063
00065         virtual BOOLEAN IsInstanceOf(INT id) const;
00066
00067     protected:
00069         TimeCompoundItem(const Time& time = Time());
00070
00071     private:
00072         Time m_time;
00073 };
00074
00076 #endif  // Apoxi_TimeCompoundItem_hpp
00077
00078
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeEditor.cpp File Reference

Gui/TimeEditor.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TimeEditor.hpp"
#include "DefaultCaret.hpp"
#include "Control.hpp"
#include "DateTimeInputMapper.hpp"
#include "PaintDc.hpp"
#include "ClientDc.hpp"

Include dependency graph for TimeEditor.cpp:

Generated on Tue Jan 24 20:51:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeEditor.hpp File Reference

Gui/TimeEditor.hpp File Reference

#include <Gui/AbstractLineEditor.hpp>
#include <Gui/TimeEditorDocument.hpp>
#include <Gui/View.hpp>
#include <Auxiliary/Time.hpp>

Include dependency graph for TimeEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TimeEditor

Defines

#define | Apoxi_TimeEditor_hpp

Define Documentation

#define Apoxi_TimeEditor_hpp

Generated on Tue Jan 24 20:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeEditor.hpp Source File

Gui/TimeEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TimeEditor_hpp)
00011 #define Apoxi_TimeEditor_hpp
00016
00017 #include <Gui/AbstractLineEditor.hpp>
00018 #include <Gui/TimeEditorDocument.hpp>
00019 #include <Gui/View.hpp>
00020 #include <Auxiliary/Time.hpp>
00021
00022 class DefaultCaret;
00023
00026 class TimeEditor : public AbstractLineEditor {
00027     typedef AbstractLineEditor Base;
00028
00029     public:
00030         enum {
00031             ID = 35
00032         };
00033
00036         TimeEditor();
00037
00040         explicit TimeEditor(Control* parent, const Time& time = Time());
00041
00043         virtual ~TimeEditor();
00044
00047         void Init(Control* parent, const Time& time = Time());
00048
00050         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00051
00053         virtual BOOLEAN IsInstanceOf(INT id) const;
00054
00056         virtual void MoveCaret(INT steps);
00057
00059         void SetTime(const Time& time);
00060
00062         Time GetTime() const;
00063
00064     protected:
00065         virtual Model* CreateModel() const;
00066
00067     private:
00068         TimeEditorDocument* GetMyDocument() { return (TimeEditorDocument*)GetModel(); } //lint !e1762
00069         const TimeEditorDocument* GetMyDocument() const { return (const TimeEditorDocument*)GetModel(); }
00070
00071         DefaultCaret* GetMyCaret() { return (DefaultCaret*)GetCaret(); }
00072 };
00073
00075 #endif  // Apoxi_TimeEditor_hpp
00076
00077
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeEditorDocument.cpp File Reference

Gui/TimeEditorDocument.cpp File Reference

#include "Gui/PreComp.hpp"
#include "TimeEditorDocument.hpp"
#include "PaintDc.hpp"
#include "Font.hpp"
#include "Locale.hpp"
#include <Config/FontConfig.hpp>
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for TimeEditorDocument.cpp:

Generated on Tue Jan 24 20:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeEditorDocument.hpp File Reference

Gui/TimeEditorDocument.hpp File Reference

#include <Gui/EditorDocument.hpp>
#include <Gui/TimeCompoundItem.hpp>
#include <Gui/CharItem.hpp>
#include <Auxiliary/Time.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for TimeEditorDocument.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TimeEditorDocument
A Time-Editor-Document contains a Time-Compound-Item. More...

Defines

#define | Apoxi_TimeEditorDocument_hpp

Define Documentation

#define Apoxi_TimeEditorDocument_hpp

Generated on Tue Jan 24 20:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/TimeEditorDocument.hpp Source File

Gui/TimeEditorDocument.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TimeEditorDocument_hpp)
00011 #define Apoxi_TimeEditorDocument_hpp
00015
00016 #include <Gui/EditorDocument.hpp>
00017 #include <Gui/TimeCompoundItem.hpp>
00018 #include <Gui/CharItem.hpp>
00019 #include <Auxiliary/Time.hpp>
00020 #include <Auxiliary/WString.hpp>
00021
00023 class TimeEditorDocument : public EditorDocument {
00024     typedef EditorDocument Base;
00025
00026     public:
00028         TimeEditorDocument(const Time& time = Time());
00029
00031         virtual ~TimeEditorDocument();
00032
00034         void Init(const Time& time);
00035
00037         virtual INT GetItemCount() const;
00038
00040         virtual INT GetMaxItemCount() const;
00041
00043         virtual BOOLEAN InsertItem(const AtomItem& item, INT item_index);
00044
00046         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT item_index);
00047
00049         virtual BOOLEAN RemoveItem(INT item_index);
00050
00052         virtual const CompoundItem& GetCompoundItem(INT item_index, INT* start_item_index = 0) const;
00053
00055         void SetTime(const Time& time);
00056
00058         const Time& GetTime() const;
00059
00061         virtual void Draw(DeviceContext* dc, XYDIM x, XYDIM y,
00062                           INT item_index, INT count) const;
00063
00065         virtual INT WrapLine(INT item_index, XYDIM width, WrapPolicy wrap_policy = WhitespaceWrap) const;
00066
00068         virtual XYDIM GetLineWidth(INT item_index, INT count) const;
00069
00071         virtual XYDIM GetLineHeight(INT item_index, INT count, XYDIM* baseline = 0) const;
00072
00074         BOOLEAN IsSeparator(INT item_index) const;
00075
00076     private:
00077         TimeCompoundItem* m_compound_item;
00078 };
00079
00081 #endif  // Apoxi_TimeEditorDocument_hpp
00082
00083
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ToggleActionGroup.cpp File Reference

Gui/ToggleActionGroup.cpp File Reference

#include "Gui/PreComp.hpp"
#include "ToggleActionGroup.hpp"

Include dependency graph for ToggleActionGroup.cpp:

Generated on Tue Jan 24 20:51:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ToggleActionGroup.hpp File Reference

Gui/ToggleActionGroup.hpp File Reference

#include <Gui/AbstractToggleAction.hpp>

Include dependency graph for ToggleActionGroup.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ToggleActionGroup
Handles unique selection of abstract toggle actions. More...

Defines

#define | Apoxi_ToggleActionGroup_hpp

Define Documentation

#define Apoxi_ToggleActionGroup_hpp

Generated on Tue Jan 24 20:51:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/ToggleActionGroup.hpp Source File

Gui/ToggleActionGroup.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH&  Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ToggleActionGroup_hpp)
00010 #define Apoxi_ToggleActionGroup_hpp
00014
00015 #include <Gui/AbstractToggleAction.hpp>
00016
00018 class ToggleActionGroup {
00019     public:
00021         ToggleActionGroup();
00022
00024         virtual ~ToggleActionGroup();
00025
00027         void Init();
00028
00030         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00031
00033         void SetSelectedToggleAction(AbstractToggleAction* rb);
00034
00036         AbstractToggleAction* GetSelectedToggleAction() { return m_selected_action; }
00037
00038     private:
00039         AbstractToggleAction* m_selected_action;
00040 };
00041
00043 #endif // Apoxi_ToggleActionGroup_hpp
00044
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/VietnameseTextRenderer.cpp File Reference

Gui/VietnameseTextRenderer.cpp File Reference

#include "Gui/PreComp.hpp"
#include "VietnameseTextRenderer.hpp"

Include dependency graph for VietnameseTextRenderer.cpp:

Generated on Tue Jan 24 20:51:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/VietnameseTextRenderer.hpp File Reference

Gui/VietnameseTextRenderer.hpp File Reference

#include <Gui/AbstractTextRenderer.hpp>

Include dependency graph for VietnameseTextRenderer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VietnameseTextRenderer

Defines

#define | Apoxi_VietnameseTextRenderer_hpp

Define Documentation

#define Apoxi_VietnameseTextRenderer_hpp

Generated on Tue Jan 24 20:51:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/VietnameseTextRenderer.hpp Source File

Gui/VietnameseTextRenderer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_VietnameseTextRenderer_hpp)
00010 #define Apoxi_VietnameseTextRenderer_hpp
00013
00014 #include <Gui/AbstractTextRenderer.hpp>
00015
00023 class VietnameseTextRenderer : public AbstractTextRenderer {
00024     typedef AbstractTextRenderer Base;
00025
00026     public:
00027         virtual ~VietnameseTextRenderer();
00028
00030         static VietnameseTextRenderer& GetInstance();
00031
00033         virtual BOOLEAN IsStandaloneCharacter(const WCHAR* text,
00034                                               INT index);
00035
00036     protected:
00037         VietnameseTextRenderer();
00038
00039         virtual Size GetGlyph(const WCHAR* cur_text_pos,
00040                               const WCHAR* substitution_char,
00041                               INT n_chars,
00042                               GlyphPtr glyph,
00043                               INT& parsed_glyphs,
00044                               BOOLEAN& is_diacritic);
00045
00046     private:
00047         enum VietnameseCharacterType {
00048             Diacritic,
00049             DiacriticBreve,         // can only be combined with a
00050             DiacriticCircumflex,    // can only be combined with a, e, and o
00051             DiacriticHorn,          // can only be combined with o and u
00052
00053             ToneMark,
00054             ToneMarkGrave,
00055             ToneMarkAcute,
00056             ToneMarkTilde,
00057             ToneMarkHookAbove,
00058             ToneMarkDotBelow,
00059
00060             Vowel,
00061             VowelA,
00062             VowelE,
00063             VowelI,
00064             VowelO,
00065             VowelU,
00066             VowelY,
00067
00068             TonemarkCombinableVowel,    // vowels already combined with diacritic, as well as y and i (which cannot be combined with diacritics)
00069             TonemarkCombinableVowelA,
00070             TonemarkCombinableVowelE,
00071             TonemarkCombinableVowelO,
00072             TonemarkCombinableVowelU,
00073
00074             DiacriticCombinableVowel,   // vowels a, e, o, u already combined with tonemark (another tone mark is not possible, only a (specific, depending on the vowel) diacritic)
00075             DiacriticCombinableVowelA,
00076             DiacriticCombinableVowelE,
00077             DiacriticCombinableVowelO,
00078             DiacriticCombinableVowelU,
00079
00080             None                        // used for non-vowels and vowels with both diacritic and tone mark, as well as i and y with tonemark, and non-combinable characters
00081         };
00082
00095         BOOLEAN GetCombinedCharacter(const WCHAR* cur_char, const WCHAR* next_char, WCHAR& combined_char, BOOLEAN& syntax_valid);
00096
00113         VietnameseCharacterType GetCharacterType(const WCHAR* ch,
00114                                                  VietnameseCharacterType& specific_type,
00115                                                  VietnameseCharacterType& modifier_type,
00116                                                  BOOLEAN& is_capital_letter) const;
00117 };
00118
00119
00121 #endif // Apoxi_VietnameseTextRenderer_hpp
00122
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/View.cpp File Reference

Gui/View.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Gui/View.hpp"

Include dependency graph for View.cpp:

Generated on Tue Jan 24 20:51:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/View.hpp File Reference

Gui/View.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | View

Defines

#define | Apoxi_View_hpp

Define Documentation

#define Apoxi_View_hpp

Generated on Tue Jan 24 20:51:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/View.hpp Source File

Gui/View.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_View_hpp)
00010 #define Apoxi_View_hpp
00013
00014 class Model;
00015 class DeviceContext;
00016 class Rect;
00017 class Component;
00018 class Theme;
00019
00024 class View {
00025     public:
00028         View(XYDIM default_width = -1, XYDIM default_height = -1);
00029
00031         virtual ~View();
00032
00039         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const = 0;
00040
00043         XYDIM GetDefaultWidth() const { return m_default_width; }
00044
00047         XYDIM GetDefaultHeight() const { return m_default_height; }
00048
00050         virtual void Update(const Theme& theme);
00051
00052     protected:
00054         void SetDefaultWidth(XYDIM width) { m_default_width = width; }
00055
00057         void SetDefaultHeight(XYDIM height) { m_default_height = height; }
00058
00059     private:
00060         XYDIM m_default_width;
00061         XYDIM m_default_height;
00062 };
00063
00065 #endif  // Apoxi_View_hpp
00066
00067
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Window.cpp File Reference

Gui/Window.cpp File Reference

#include "Gui/PreComp.hpp"
#include "Window.hpp"
#include "SoftkeyBar.hpp"
#include "WindowFrameView.hpp"
#include "ThemeManager.hpp"
#include "Theme.hpp"
#include "Desktop.hpp"
#include "AnimatedTextLine.hpp"
#include "WindowManager.hpp"
#include "Panel.hpp"
#include "Action.hpp"
#include <Kernel/Os/TestWriter.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/Condition.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Devices/Device.hpp>
#include <Kernel/VersionInfo.hpp>

Include dependency graph for Window.cpp:

Functions

ApoxiUseVersionInfo (Gui)

Function Documentation

ApoxiUseVersionInfo ( Gui )

Generated on Tue Jan 24 20:51:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Window.hpp File Reference

Gui/Window.hpp File Reference

#include <Gui/Control.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for Window.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Window

Defines

#define | APOXI_MAX_SOFTKEY_COUNT 2
#define | Apoxi_Window_hpp

Define Documentation

#define Apoxi_Window_hpp

Generated on Tue Jan 24 20:51:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/Window.hpp Source File

Gui/Window.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Window_hpp)
00010 #define Apoxi_Window_hpp
00014
00015 #include <Gui/Control.hpp>
00016 #include <Auxiliary/WString.hpp>
00017
00018 class Action;
00019 class Model;
00020 class View;
00021 class SoftkeyBar;
00022 class WindowFrameView;
00023 class AnimatedTextLine;
00024 class ResourceParser;
00025
00026 #if !defined(APOXI_MAX_SOFTKEY_COUNT)
00027 #define APOXI_MAX_SOFTKEY_COUNT 2
00028 #endif
00029
00032 class Window : public Control {
00033     typedef Control Base;
00034
00035     public:
00036         enum {
00037             ID = 26
00038         };
00039
00043         Window(Control* parent = 0);
00044
00046         virtual ~Window();
00047
00051         void Init(Control* parent = 0);
00052
00055         BOOLEAN SetProperty(ResourceParser& parser, const GuiObjectFactory::PropertyId prop_id);
00056
00058         virtual BOOLEAN IsInstanceOf(INT id) const;
00059
00063         virtual void SetTitle(const WCHAR* title);
00064
00066         void SetTitle(const WString& title);
00067
00072         virtual const WCHAR* GetTitle() const;
00073
00075         virtual XYDIM GetDefaultWidth() const;
00076
00078         virtual XYDIM GetDefaultHeight() const;
00079
00085         virtual Rect GetClientRect() const;
00086
00092         virtual void OpenModeless(const Rect& rect);
00093
00096         void OpenModeless();
00097
00108         virtual INT OpenModal(const Rect& rect);
00109
00112         INT OpenModal();
00113
00114         BOOLEAN IsOpen() const { return (BOOLEAN)m_bits.is_open; }
00115
00122         virtual BOOLEAN Close(INT exit_code = 0);
00123
00131         void SetFocusPriority(UINT8 priority);
00132
00135         UINT8 GetFocusPriority() const { return (UINT8)m_bits.focus_priority; }
00136
00141         virtual void SetSoftkey(INT index, Action* action);
00142
00144         Action* GetSoftkey(INT index) const;
00145
00147         void SetLeftSoftkey(Action* action);
00148
00150         Action* GetLeftSoftkey() const;
00151
00153         void SetRightSoftkey(Action* action);
00154
00156         Action* GetRightSoftkey() const;
00157
00160         virtual void SetDefaultSize();
00161
00165         BOOLEAN HasDefaultSize() const { return (BOOLEAN)m_bits.has_default_size; }
00166
00169         BOOLEAN IsSyncSoftkeysEnabled() const { return (BOOLEAN)m_bits.sync_softkeys; }
00170
00174         BOOLEAN IsTitleAnimated() const;
00175
00177         virtual void Maximize();
00178
00192         void SetTransparent(BOOLEAN enabled);
00193
00196         BOOLEAN IsTransparent() const { return (BOOLEAN)m_bits.is_transparent; }
00197
00208         void AddToTitlebar(DrawableObject& obj, BOOLEAN align_left = TRUE);
00209
00211         void RemoveFromTitlebar(DrawableObject& obj);
00212
00213 #if defined(APOXI_COMPAT_1_8_0)
00214 #if !defined(APOXI_DISABLE_SOFTKEYBAR)
00215
00218         void SetSoftkeyBar(SoftkeyBar* softkey_bar);
00219
00223         SoftkeyBar* GetSoftkeyBar() const { return m_softkey_bar; }
00224 #endif // APOXI_DISABLE_SOFTKEYBAR
00225 #endif // APOXI_COMPAT_1_8_0
00226
00227     protected:
00229         virtual void Refresh(const Rect& rect);
00230
00232         virtual BOOLEAN OnMessage(const Message& msg);
00233
00235         virtual void OnGetFocus();
00236
00238         virtual void OnLoseFocus();
00239
00249         virtual void OnOpen();
00250
00255         virtual void OnClose();
00256
00260         virtual void OnActionExecuted(Action* action);
00261
00263         virtual void OnThemeChanged();
00264
00266         virtual void OnLanguageChanged();
00267
00269         virtual void OnMove(XYDIM dx, XYDIM dy);
00270
00272         virtual void OnResize(XYDIM dx, XYDIM dy);
00273
00275         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00276
00279         virtual const ControlFrameView* GetFrameView() const;
00280
00286         virtual void OnLayoutFrame();
00287
00289         virtual void OnLayoutClient();
00290
00293         void SetSyncSoftkeysEnabled(BOOLEAN enabled) { m_bits.sync_softkeys = enabled; }
00294
00300         void SetDefaultSizeProperty(BOOLEAN has_default_size) { m_bits.has_default_size = has_default_size; }
00301
00302 #if defined(APOXI_COMPAT_1_8_0)
00303 #if !defined(APOXI_DISABLE_SOFTKEYBAR)
00304
00307         virtual BOOLEAN OnSoftkeyPressed(INT idx);
00308 #endif  // APOXI_DISABLE_SOFTKEYBAR
00309 #endif  // APOXI_COMPAT_1_8_0
00310
00311     private:
00312         struct {
00313             UINT is_open            : 1;
00314             UINT modal              : 1;
00315             UINT has_default_size   : 1;
00316             UINT sync_softkeys      : 1;
00317             UINT is_transparent     : 1;
00318             UINT focus_priority     : 8;
00319             UINT keep_anim_title    : 1;
00320             UINT frame_layout_hint  : 2;
00321         } m_bits;
00322         INT m_exit_code;
00323         WString m_title;
00324         Action* m_sk_actions[APOXI_MAX_SOFTKEY_COUNT];
00325
00326 #if defined(APOXI_ENABLE_ANIMATED_TITLE)
00327         AnimatedTextLine* m_anim_title ;
00328 #endif
00329
00330 #if defined(APOXI_COMPAT_1_8_0)
00331 #if !defined(APOXI_DISABLE_SOFTKEYBAR)
00332         SoftkeyBar* m_softkey_bar;      // obsolete - provided for backward-compatibility with version < 1.8.0
00333 #endif  // APOXI_DISABLE_SOFTKEYBAR
00334 #endif  // APOXI_COMPAT_1_8_0
00335
00336         void InitProperties();
00337         void AdjustBounds();
00338         void SynchronizeSoftkeys();
00339         void ForwardFocus();
00340         void PrepareTitleAnimation();
00341
00346         void IndicateAlphaMaskUpdate() const;
00347
00350         void InternalRefresh(const Rect& rect);
00351
00352 #if defined(APOXI_ENABLE_ANIMATED_TITLE)
00353
00355         void UpdateAnimatedTitleColor();
00356 #endif
00357 };
00358
00360 #endif  // Apoxi_Window_hpp
00361
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/WindowFrameView.cpp File Reference

Gui/WindowFrameView.cpp File Reference

#include "Gui/PreComp.hpp"
#include "WindowFrameView.hpp"
#include "Window.hpp"
#include "PaintDc.hpp"
#include "WindowManager.hpp"
#include "DrawableObject.hpp"
#include "Locale.hpp"

Include dependency graph for WindowFrameView.cpp:

Generated on Tue Jan 24 20:51:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/WindowFrameView.hpp File Reference

Gui/WindowFrameView.hpp File Reference

#include <Gui/ControlFrameView.hpp>

Include dependency graph for WindowFrameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WindowFrameView

Defines

#define | Apoxi_WindowFrameView_hpp

Define Documentation

#define Apoxi_WindowFrameView_hpp

Generated on Tue Jan 24 20:51:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/WindowFrameView.hpp Source File

Gui/WindowFrameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_WindowFrameView_hpp)
00010 #define Apoxi_WindowFrameView_hpp
00013
00014 #include <Gui/ControlFrameView.hpp>
00015
00016 class Window;
00017
00020 class WindowFrameView : public ControlFrameView {
00021     typedef ControlFrameView Base;
00022
00023     public:
00024         WindowFrameView();
00025         WindowFrameView(XYDIM left_size,
00026                         XYDIM top_size,
00027                         XYDIM right_size,
00028                         XYDIM bottom_size,
00029                         XYDIM title_height,
00030                         XYDIM softkey_bar_height);
00031         virtual ~WindowFrameView();
00032
00035         XYDIM GetTitleHeight() const { return m_title_height; }
00036
00039         const TextFormat& GetTitleTextFormat() const { return m_title_text_format; }
00040
00042         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00043
00049         BOOLEAN IsActive(const Control& control) const;
00050
00052         XYDIM GetSoftkeyBarHeight() const { return m_softkey_bar_height; }
00053
00054     protected:
00056         virtual void DrawWindowExtensions(const Window& window,
00057                                           DeviceContext* dc,
00058                                           const Rect& repaint_rect) const = 0;
00059
00061         void SetSoftkeyBarHeight(XYDIM height) { m_softkey_bar_height = height; }
00062
00065         void SetTitleHeight(XYDIM height) { m_title_height = height; }
00066
00068         void SetTitleTextFormat(const TextFormat& text_format) { m_title_text_format = text_format; }
00069
00070     private:
00071         XYDIM m_title_height;
00072         XYDIM m_softkey_bar_height;
00073         TextFormat m_title_text_format;
00074 };
00075
00077 #endif  // Apoxi_WindowFrameView_hpp
00078
00079
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/WindowManager.cpp File Reference

Gui/WindowManager.cpp File Reference

#include "Gui/PreComp.hpp"
#include "WindowManager.hpp"
#include "Window.hpp"
#include <Kernel/Application.hpp>
#include <Config/DisplayConfig.hpp>

Include dependency graph for WindowManager.cpp:

Generated on Tue Jan 24 20:51:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/WindowManager.hpp File Reference

Gui/WindowManager.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for WindowManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | WindowHierarchyIterator
class | WindowManager
struct | WindowManager::Node

Defines

#define | Apoxi_WindowManager_hpp

Define Documentation

#define Apoxi_WindowManager_hpp

Generated on Tue Jan 24 20:51:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Gui/WindowManager.hpp Source File

Gui/WindowManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_WindowManager_hpp)
00010 #define Apoxi_WindowManager_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Auxiliary/Vector.hpp>
00016
00017 class Window;
00018 class Application;
00019
00042 class WindowHierarchyIterator {
00043     public:
00047         WindowHierarchyIterator(const Window* win = 0);
00048         ~WindowHierarchyIterator();
00049
00056         BOOLEAN Begin(const Window* win = 0);
00057
00059         WindowHierarchyIterator& operator++();
00060
00062         WindowHierarchyIterator operator++(INT);
00063
00065         WindowHierarchyIterator& operator--();
00066
00068         WindowHierarchyIterator operator--(INT);
00069
00073         Window* Get(Application** app = 0) const;
00074
00077         BOOLEAN Next();
00078
00081         BOOLEAN Previous();
00082
00084         void Release() {}
00085
00086     private:
00087         INT m_pos;
00088 };
00089
00093 class WindowManager {
00094     public:
00098         static Window* GetForegroundWindow() { return m_foreground_win; }
00099
00101         static Window* GetDisplayForegrWin(INT display_idx);
00102
00107         static void Insert(Window* win, Window* foregr_win = 0);
00108
00112         static void Remove(Window* win);
00113
00120         static void SetAlphaMaskEnabled(BOOLEAN flag);
00121
00123         static BOOLEAN IsAlphaMaskEnabled();
00124
00125     private:
00126         struct Node {
00127             Window* win;
00128             Application* app;
00129         };
00130
00131         // m_foreground_win: redundant member to allow a fast access to the foreground-window
00132         // (the method WindowManager::GetForegroundWindow is invoked for each method of the device-context)
00133         static Window* m_foreground_win;
00134         // m_nodes: contains all opened windows of all applications
00135         static Vector<Node> m_nodes;
00136
00137         static BOOLEAN m_initialized;
00138         static Mutex m_mutex;
00139         static INT m_alpha_mask_counter;
00140
00141         WindowManager();
00142         static void InternalInsert(Window* win, Window* foregr_win = 0);
00143         static void InternalRemove(Window* win);
00144         static INT GetWindowIndex(const Window* win);
00145         static BOOLEAN Contains(const Window* win);
00146         static BOOLEAN InitMutex();
00147
00148         friend class WindowHierarchyIterator;
00149 };
00150
00152 #endif  // Apoxi_WindowManager_hpp
00153
00154
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/IrdaTransport.cpp File Reference

Irda/IrdaTransport.cpp File Reference

#include "PreComp.hpp"
#include <stack/extensions.h>
#include "IrdaTransport.hpp"
#include "IrdaTypes.hpp"
#include <parseopts.h>
#include "Auxiliary/HostIniFile.hpp"

Include dependency graph for IrdaTransport.cpp:

Generated on Tue Jan 24 20:52:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/IrdaTransport.hpp File Reference

Irda/IrdaTransport.hpp File Reference

#include <stack/extensions.h>
#include <Devices/AbstractTransport.hpp>

Include dependency graph for IrdaTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IrdaTransport

Defines

#define | Apoxi_IrdaTransport_hpp

Define Documentation

#define Apoxi_IrdaTransport_hpp

Generated on Tue Jan 24 20:52:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/IrdaTransport.hpp Source File

Irda/IrdaTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_IrdaTransport_hpp)
00010 #define Apoxi_IrdaTransport_hpp
00011
00012 #include <stack/extensions.h>
00013
00014 #include <Devices/AbstractTransport.hpp>
00015
00016 class IrdaTransport : public AbstractTransport {
00017
00018     public:
00019
00020         typedef AbstractTransport Base;
00021
00022         enum IrdaSwitchOffTimeout {
00023             default_irda_switch_off_timeout = 600000, // = 10 minutes, default IrDA Hardware switch off time-out when idle
00024         };
00025
00026         enum ConnType
00027         {
00028             IrLap,  // do we have a connection?
00029             IrLmp,  // do we have open IrLmp connections?
00030             IrComm, // do we have open IrComm connections?
00031             IrObex  // do we have open IrObex connections?
00032         };
00033
00035         enum TransportDisableReason
00036         {
00037             TransportDisableReasonNotApplicable,
00038             TransportDisableReasonIdleTimeout,
00039             TransportDisableReasonStackError,
00040             TransportDisableReasonAppRequest,
00041             TransportDisableReasonUnknown
00042         };
00043
00045         IrdaTransport();
00046
00049         ~IrdaTransport();
00050
00052         static inline IrdaTransport & GetInstance() { return m_transport; }
00053
00066         void SetNickname(UINT8 char_set, const CHAR *nickname) const;
00067
00073         void SetHintBits(UINT byte_offset, UINT8 bit_mask) const;
00074
00080         void ClearHintBits(UINT byte_offset, UINT8 bit_mask) const;
00081
00088         virtual void Enable();
00089
00095         void Disable();
00096
00102         virtual AvState GetAvState() const;
00103
00107         TransportDisableReason  GetTransportDisableReason() const;
00108
00115         void                    OnAvStateChanged();
00116
00123         BOOLEAN GetConnState(ConnType type) const;
00124
00140         void SetIrdaHwTimeout(UINT32 irda_hw_timeout) ;
00141
00142         inline BOOLEAN  GetIsWin98Mode() const { return m_is_win98_mode; }
00143         inline void     SetIsWin98Mode(BOOLEAN is_win98_mode)  { m_is_win98_mode = is_win98_mode; }
00144
00145
00146     private:
00147
00148         static void irda_hw_cb(int state);
00149         static void irda_idle_state_cb(int state);
00150         static void irda_obex_state_cb(int state);
00151         static void irda_ircomm_state_cb(int state);
00152         static void irda_peer_cb(unsigned char *buf, int len);
00153
00154         static SystemTimer m_irda_switch_off_timer;
00155         static UINT32 m_irda_switch_off_timeout;
00156         static void OnIrdaSwitchOffTimer(void* arg);
00157
00158         static IrdaTransport        m_transport;
00159         AvState                     m_state;
00160         TransportDisableReason      m_transport_disable_reason;
00161         BOOLEAN                     m_is_win98_mode;
00162 };
00163
00164
00165 #endif  // Apoxi_IrdaTransport_hpp
00166
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/IrdaTypes.hpp File Reference

Irda/IrdaTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_IRDA_CHAR_SET_CODE_ASCII 0
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_1 1
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_2 2
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_3 3
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_4 4
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_5 5
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_6 6
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_7 7
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_8 8
#define | APOXI_IRDA_CHAR_SET_CODE_ISO_8859_9 9
#define | APOXI_IRDA_CHAR_SET_CODE_UNICODE 255
#define | APOXI_IRDA_HINT_COMPUTER 0x04
#define | APOXI_IRDA_HINT_EXT 0x80
#define | APOXI_IRDA_HINT_FAX 0x20
#define | APOXI_IRDA_HINT_FILE 0x02
#define | APOXI_IRDA_HINT_HTTP 0x10
#define | APOXI_IRDA_HINT_IRCOMM 0x04
#define | APOXI_IRDA_HINT_LAN 0x40
#define | APOXI_IRDA_HINT_MESSAGE 0x08
#define | APOXI_IRDA_HINT_MODEM 0x10
#define | APOXI_IRDA_HINT_OBEX 0x20
#define | APOXI_IRDA_HINT_PDA 0x02
#define | APOXI_IRDA_HINT_PNP 0x01
#define | APOXI_IRDA_HINT_PRINTER 0x08
#define | APOXI_IRDA_HINT_TELEPHONY 0x01
#define | APOXI_IRDA_OFFSET_HINT_COMPUTER 0
#define | APOXI_IRDA_OFFSET_HINT_FAX 0
#define | APOXI_IRDA_OFFSET_HINT_FILE 1
#define | APOXI_IRDA_OFFSET_HINT_HTTP 1
#define | APOXI_IRDA_OFFSET_HINT_IRCOMM 1
#define | APOXI_IRDA_OFFSET_HINT_LAN 0
#define | APOXI_IRDA_OFFSET_HINT_MESSAGE 1
#define | APOXI_IRDA_OFFSET_HINT_MODEM 0
#define | APOXI_IRDA_OFFSET_HINT_OBEX 1
#define | APOXI_IRDA_OFFSET_HINT_PDA 0
#define | APOXI_IRDA_OFFSET_HINT_PNP 0
#define | APOXI_IRDA_OFFSET_HINT_PRINTER 0
#define | APOXI_IRDA_OFFSET_HINT_TELEPHONY 1
#define | Apoxi_IrdaTypes_hpp

Define Documentation

#define APOXI_IRDA_CHAR_SET_CODE_ASCII 0

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_1 1

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_2 2

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_3 3

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_4 4

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_5 5

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_6 6

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_7 7

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_8 8

#define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_9 9

#define APOXI_IRDA_CHAR_SET_CODE_UNICODE 255

#define APOXI_IRDA_HINT_COMPUTER 0x04

#define APOXI_IRDA_HINT_EXT 0x80

#define APOXI_IRDA_HINT_FAX 0x20

#define APOXI_IRDA_HINT_FILE 0x02

#define APOXI_IRDA_HINT_HTTP 0x10

#define APOXI_IRDA_HINT_IRCOMM 0x04

#define APOXI_IRDA_HINT_LAN 0x40

#define APOXI_IRDA_HINT_MESSAGE 0x08

#define APOXI_IRDA_HINT_MODEM 0x10

#define APOXI_IRDA_HINT_OBEX 0x20

#define APOXI_IRDA_HINT_PDA 0x02

#define APOXI_IRDA_HINT_PNP 0x01

#define APOXI_IRDA_HINT_PRINTER 0x08

#define APOXI_IRDA_HINT_TELEPHONY 0x01

#define APOXI_IRDA_OFFSET_HINT_COMPUTER 0

#define APOXI_IRDA_OFFSET_HINT_FAX 0

#define APOXI_IRDA_OFFSET_HINT_FILE 1

#define APOXI_IRDA_OFFSET_HINT_HTTP 1

#define APOXI_IRDA_OFFSET_HINT_IRCOMM 1

#define APOXI_IRDA_OFFSET_HINT_LAN 0

#define APOXI_IRDA_OFFSET_HINT_MESSAGE 1

#define APOXI_IRDA_OFFSET_HINT_MODEM 0

#define APOXI_IRDA_OFFSET_HINT_OBEX 1

#define APOXI_IRDA_OFFSET_HINT_PDA 0

#define APOXI_IRDA_OFFSET_HINT_PNP 0

#define APOXI_IRDA_OFFSET_HINT_PRINTER 0

#define APOXI_IRDA_OFFSET_HINT_TELEPHONY 1

#define Apoxi_IrdaTypes_hpp

Generated on Tue Jan 24 20:52:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/IrdaTypes.hpp Source File

Irda/IrdaTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2003 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_IrdaTypes_hpp)
00010 #define Apoxi_IrdaTypes_hpp
00011
00012 /* IrLMP Service Hints */
00013 #define APOXI_IRDA_HINT_PNP                 0x01
00014 #define APOXI_IRDA_HINT_PDA                 0x02
00015 #define APOXI_IRDA_HINT_COMPUTER            0x04
00016 #define APOXI_IRDA_HINT_PRINTER             0x08
00017 #define APOXI_IRDA_HINT_MODEM               0x10
00018 #define APOXI_IRDA_HINT_FAX                 0x20
00019 #define APOXI_IRDA_HINT_LAN                 0x40
00020 #define APOXI_IRDA_HINT_EXT                 0x80
00021
00022 #define APOXI_IRDA_OFFSET_HINT_PNP          0
00023 #define APOXI_IRDA_OFFSET_HINT_PDA          0
00024 #define APOXI_IRDA_OFFSET_HINT_COMPUTER     0
00025 #define APOXI_IRDA_OFFSET_HINT_PRINTER      0
00026 #define APOXI_IRDA_OFFSET_HINT_MODEM        0
00027 #define APOXI_IRDA_OFFSET_HINT_FAX          0
00028 #define APOXI_IRDA_OFFSET_HINT_LAN          0
00029
00030 #define APOXI_IRDA_HINT_TELEPHONY           0x01
00031 #define APOXI_IRDA_HINT_FILE                0x02
00032 #define APOXI_IRDA_HINT_IRCOMM              0x04
00033 #define APOXI_IRDA_HINT_MESSAGE             0x08
00034 #define APOXI_IRDA_HINT_HTTP                0x10
00035 #define APOXI_IRDA_HINT_OBEX                0x20
00036
00037 #define APOXI_IRDA_OFFSET_HINT_TELEPHONY    1
00038 #define APOXI_IRDA_OFFSET_HINT_FILE         1
00039 #define APOXI_IRDA_OFFSET_HINT_IRCOMM       1
00040 #define APOXI_IRDA_OFFSET_HINT_MESSAGE      1
00041 #define APOXI_IRDA_OFFSET_HINT_HTTP         1
00042 #define APOXI_IRDA_OFFSET_HINT_OBEX         1
00043
00044 /* IrLMP Character Code Values */
00045 #define APOXI_IRDA_CHAR_SET_CODE_ASCII        0
00046 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_1   1
00047 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_2   2
00048 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_3   3
00049 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_4   4
00050 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_5   5
00051 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_6   6
00052 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_7   7
00053 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_8   8
00054 #define APOXI_IRDA_CHAR_SET_CODE_ISO_8859_9   9
00055 #define APOXI_IRDA_CHAR_SET_CODE_UNICODE    255
00056
00057 #endif  // Apoxi_IrdaTypes_hpp
00058
00059
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/PreComp.cpp File Reference

Irda/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:07:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/PreComp.hpp File Reference

Irda/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:22:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/PreComp.hpp Source File

Irda/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Adc/Lib.hpp>
00013 #include <Apc/Lib.hpp>
00014 #include <Asc/Lib.hpp>
00015
00016
00017
00018
00019
00020
00021
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexAddr.cpp File Reference

Irda/Obex/IrdaObexAddr.cpp File Reference

#include "PreComp.hpp"
#include "IrdaObexAddr.hpp"

Include dependency graph for IrdaObexAddr.cpp:

Generated on Tue Jan 24 20:52:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexAddr.hpp File Reference

Irda/Obex/IrdaObexAddr.hpp File Reference

#include <stack/extensions.h>
#include <Obex/ObexAddress.hpp>

Include dependency graph for IrdaObexAddr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IrdaObexClientAddr
class | IrdaObexServerAddr

Defines

#define | Apoxi_IrdaObexAddress_hpp

Define Documentation

#define Apoxi_IrdaObexAddress_hpp

Generated on Tue Jan 24 20:52:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexAddr.hpp Source File

Irda/Obex/IrdaObexAddr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_IrdaObexAddress_hpp)
00010 #define Apoxi_IrdaObexAddress_hpp
00011
00012 #include <stack/extensions.h>
00013
00014 #include <Obex/ObexAddress.hpp>
00015
00016 class IrdaObexClientAddr : public ObexClientAddr {
00017
00018     public:
00019         typedef ObexClientAddr Base;
00020
00021         IrdaObexClientAddr(ObexTransportId  transport_id,
00022                            IrDeviceAddr     remote_addr);
00023
00024         virtual ObexResult ToString(String &  obex_url) const;
00025         inline IrDeviceAddr GetRemoteAddr() { return m_remote_addr; }
00026
00027     private:
00028         IrDeviceAddr    m_remote_addr;
00029         U8              m_remote_lsap;
00030 };
00031
00032
00033 class IrdaObexServerAddr : public ObexServerAddr {
00034
00035     public:
00036         typedef ObexServerAddr Base;
00037         IrdaObexServerAddr(ObexTransportId  transport_id,
00038             IrDeviceAddr        remote_addr);
00039
00040
00041         virtual ObexResult  ToString(String &  obex_url) const;
00042         inline IrDeviceAddr GetRemoteAddr() { return m_remote_addr; }
00043
00044     private:
00045         IrDeviceAddr    m_remote_addr;
00046         U8              m_remote_lsap;
00047 };
00048
00049 #endif  // Apoxi_IrdaObexAddress_hpp
00050
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexImpl.cpp File Reference

Irda/Obex/IrdaObexImpl.cpp File Reference

#include "PreComp.hpp"
#include <stack/extensions.h>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Irda/IrdaTransport.hpp>
#include <Irda/IrdaTypes.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexResult.hpp>
#include "IrdaObexTransport.hpp"
#include "IrdaObexImpl.hpp"

Include dependency graph for IrdaObexImpl.cpp:

Defines

#define IRDA_DBG_OUT(arg) DBG_OUT(arg)

Define Documentation

#define IRDA_DBG_OUT ( arg ) DBG_OUT(arg)

Generated on Tue Jan 24 20:52:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexImpl.hpp File Reference

Irda/Obex/IrdaObexImpl.hpp File Reference

#include "IrdaObexAddr.hpp"
#include <stack/extensions.h>
#include <Kernel/Os/Mutex.hpp>
#include <Obex/ObexLayer.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexHeaderBuilder.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexBuffer.hpp>

Include dependency graph for IrdaObexImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IrdaObexImpl
class | IrdaObexImpl::ClientAppContext
class | IrdaObexImpl::ServerAppContext

Defines

#define | APOXI_IRDA_OBEX_HEADER_BUFF_SIZE OBEX_TX_BUFF_SIZE
#define | APOXI_IRDA_OBEX_MAX_CHANNELS 10
#define | Apoxi_IrdaObexImpl_hpp

Define Documentation

#define APOXI_IRDA_OBEX_HEADER_BUFF_SIZE OBEX_TX_BUFF_SIZE

#define APOXI_IRDA_OBEX_MAX_CHANNELS 10

#define Apoxi_IrdaObexImpl_hpp

Generated on Tue Jan 24 20:52:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexImpl.hpp Source File

Irda/Obex/IrdaObexImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) 2005 COMNEON Software GmbH & Co. All rights reserved.
00003 ------------------------------------------------------------------------
00004 This document contains proprietary information belonging to COMNEON.
00005 Passing on and copying of this document, use and communication of its
00006 contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_IrdaObexImpl_hpp)
00010 #define Apoxi_IrdaObexImpl_hpp
00011
00012 #include "IrdaObexAddr.hpp"
00013
00014 #include <stack/extensions.h>
00015
00016 #include <Kernel/Os/Mutex.hpp>
00017
00018 #include <Obex/ObexLayer.hpp>
00019 #include <Obex/ObexChannel.hpp>
00020 #include <Obex/ObexHeaderBuilder.hpp>
00021 #include <Obex/ObexObject.hpp>
00022 #include <Obex/ObexBuffer.hpp>
00023
00024 #define APOXI_IRDA_OBEX_MAX_CHANNELS    10
00025 #define APOXI_IRDA_OBEX_HEADER_BUFF_SIZE OBEX_TX_BUFF_SIZE
00026
00027 class IrdaObexImpl : public ObexLayer {
00028
00029
00030     class ClientAppContext;
00031     class ServerAppContext;
00032
00033     friend class ClientAppContext;
00034     friend class ServerAppContext;
00035
00036     public:
00037
00038         IrdaObexImpl();
00039
00040         /*
00041          * implementation of ObexProtocol
00042          */
00043
00061         virtual ObexResult  AcquireClientChannel(ObexChannel &          result,
00062                                                  const ObexAddrPtr &    addr_ptr,
00063                                                  BOOLEAN                reserve);
00064
00082         virtual ObexResult  AcquireServerChannel(ObexChannel &          result,
00083                                                  const ObexAddrPtr &    addr_ptr,
00084                                                  BOOLEAN                reserve);
00085
00090         virtual ObexResult  ReleaseChannel(ObexChannel &  channel);
00091
00103         virtual void OpenClientChannel(const ObexChannel &  client_chan,
00104                                        ObexOperationId      oper_id,
00105                                        const ObexAddrPtr &  addr_ptr);
00106
00118         virtual void BindServerChannel(const ObexChannel &  server_chan,
00119                                        ObexOperationId      oper_id,
00120                                        const ObexAddrPtr &  addr_ptr);
00121
00131         virtual void CloseChannel(const ObexChannel &  server_chan,
00132                                   ObexOperationId      oper_id);
00133         /*
00134          * implementation of ObexLayer
00135          */
00136
00148         virtual void Connect(const ObexChannel &    client_chan,
00149                              ObexOperationId        oper_id,
00150                              const ObexObject &     conn_req);
00151
00161         virtual void Get(const ObexChannel &    client_chan,
00162                          ObexOperationId        oper_id,
00163                          const ObexObject &     get_req);
00164
00171         virtual void Put(const ObexChannel &    client_chan,
00172                          ObexOperationId        oper_id,
00173                          const ObexObject &     put_req);
00174
00185         virtual void Abort(const ObexChannel &  client_chan,
00186                            ObexOperationId      oper_id,
00187                            const ObexObject &   abort_req);
00188
00195         virtual void SetPath(const ObexChannel &    client_chan,
00196                              ObexOperationId        oper_id,
00197                              const ObexObject &     setp_req);
00198
00204         virtual void Disconnect(const ObexChannel &     client_chan,
00205                                 ObexOperationId         oper_id,
00206                                 const ObexObject &      disc_req);
00207
00216         virtual void ReturnResponse(const ObexChannel &     server_chan,
00217                                     ObexOperationId         oper_id,
00218                                     const ObexObject &      server_resp);
00219
00225         virtual void DataProcessed(const ObexChannel &   channel,
00226                                    ObexOperationId       oper_id,
00227                                    ObexBuffer &      obex_buffer);
00228     private:
00229
00230         /* helper construct to get reference to IrdaObexImpl object
00231            in Extended Systems callback functions */
00232         /* no member templates... */
00233         class ServerAppContext
00234         {
00235             friend class IrdaObexImpl;
00236
00237             public:
00238                 ServerAppContext(IrdaObexImpl & self, UINT index) : m_self(self),
00239                     m_index(index)
00240                 {
00241                     m_self.m_server_app_contexts[m_index] = this;
00242                 }
00243
00244                 ~ServerAppContext() {
00245                         m_self.m_server_app_contexts[m_index] = 0;
00246                 }
00247
00248                 inline IrdaObexImpl & GetSelf() const { return m_self; }
00249                 inline U8 *GetHeaderBuffer() const { return (U8 *) m_header_buffer; }
00250                 inline U16 GetHeaderBufferLen() { return sizeof(m_header_buffer); }
00251                 inline ObexChannel & GetChannel() {
00252                     return m_channel;
00253                 }
00254                 inline void StartOperation(ObexOperationId oper_id) {
00255                     ASSERT_DEBUG(!m_oper_id.IsValid());
00256                     m_oper_id = oper_id;
00257                 }
00258                 inline void StopOperation(ObexResult & result) {
00259                     m_self.OnComplete(m_channel, m_oper_id, result);
00260                     m_oper_id.Invalidate();
00261                 }
00262
00263                 inline BOOLEAN          IsBusy() const
00264                 {
00265                     return  m_oper_id.IsValid();
00266                 }
00267
00268                 void                    Close(ObexOperationId   oper_id);
00269                 void                    OnChannelClosed();
00270
00271             private:
00272                 // must be first member
00273                 ObexServerApp           m_server_app;
00274                 IrdaObexImpl &          m_self;
00275                 U8                      m_header_buffer[APOXI_IRDA_OBEX_HEADER_BUFF_SIZE];
00276                 ObexOperationId         m_oper_id;
00277                 ObexOperationId         m_close_oper_id;
00278                 UINT                    m_index;
00279                 ObexChannel             m_channel;
00280                 ObServerEvent           m_last_event;
00281                 ObexHeaderBuilder       m_oheaderbuilder;
00282                 ObexObject              m_received_obex_obj;
00283                 ObexBuffer              m_buffer;
00284                 ObexObject              m_get_resp_obex_obj;
00285                 ObexBuffer::Size        m_get_offset;
00286         };
00287
00288         /* helper construct to get reference to IrdaObexImpl object
00289            in Extended Systems callback functions */
00290
00291         class ClientAppContext
00292         {
00293             friend class IrdaObexImpl;
00294
00295             public:
00296                 ClientAppContext(IrdaObexImpl & self, UINT index) : m_self(self),
00297                     m_index(index),
00298                     m_tried_irxfer_obex(FALSE)
00299                 {
00300                     m_self.m_client_app_contexts[m_index] = this;
00301                 }
00302
00303                 ~ClientAppContext() {
00304                         m_self.m_client_app_contexts[m_index] = 0;
00305                 }
00306
00307                 inline IrdaObexImpl & GetSelf() const { return m_self; }
00308                 inline U8 *GetHeaderBuffer() const { return (U8 *) m_header_buffer; }
00309                 inline U16 GetHeaderBufferLen() const { return sizeof(m_header_buffer); }
00310                 inline ObexChannel & GetChannel() {
00311                     return m_channel;
00312                 }
00313                 inline void SetAddrPtr(const ObexAddrPtr & addr_ptr) { m_addr_ptr = addr_ptr; }
00314                 inline IrDeviceAddr GetRemoteAddr() const {
00315                     return ((IrdaObexClientAddr &) *m_addr_ptr).GetRemoteAddr(); }
00316                 inline void StartOperation(ObexOperationId oper_id) {
00317                     ASSERT(!m_oper_id.IsValid());
00318                     m_oper_id = oper_id;
00319                 }
00320                 inline void StopOperation(ObexResult & result) {
00321                     m_self.OnComplete(m_channel, m_oper_id, result);
00322                     m_oper_id.Invalidate();
00323                 }
00324
00325                 void                    Close(ObexOperationId   oper_id);
00326                 void                    OnChannelClosed();
00327
00328             private:
00329
00330                 // must be first member
00331                 ObexClientApp           m_client_app;
00332                 IrdaObexImpl &          m_self;
00333                 U8                      m_header_buffer[APOXI_IRDA_OBEX_HEADER_BUFF_SIZE];
00334                 ObexAddrPtr             m_addr_ptr;
00335                 ObexOperationId         m_oper_id;
00336                 ObexOperationId         m_close_oper_id;
00337                 ObexOperationId         m_abort_oper_id;
00338                 UINT                    m_index;
00339                 ObexChannel             m_channel;
00340                 BOOLEAN                 m_tried_irxfer_obex;
00341                 BOOLEAN                 m_is_data_expected;
00342                 ObexHeaderBuilder       m_oheaderbuilder;
00343                 ObexObject              m_received_obex_obj;
00344                 ObexBuffer              m_buffer;
00345                 ObexBuffer::Size        m_get_offset;
00346                 ObexObject              m_get_obex_obj;
00347                 ObexBuffer::Size        m_put_offset;
00348                 ObexObject              m_put_obex_obj;
00349                 ObexObject              m_abort_req;
00350         };
00351
00352         void ObexTpConnect(ClientAppContext & client_context, const U8 *query, U8 len) const;
00353
00354         /*
00355          * Extended Systems specific callback functions
00356          */
00357
00365         static void ObexServerCallback(ObexServerCallbackParms *parms);
00366
00374         static void ObexClientCallback(ObexClientCallbackParms *parms);
00375
00376         /*
00377          * Object Store API functions
00378          */
00379
00394         static ObexRespCode OBSTORE_Read(void *obs, U8 *buff, U16 len);
00395
00410         static ObexRespCode OBSTORE_WriteServer(void *obs, U8 *buff, U16 len);
00411         static ObexRespCode OBSTORE_WriteClient(void *obs, U8 *buff, U16 len);
00412
00424         static U32 OBSTORE_GetObjectLen(void *obs);
00425
00444         static ObexRespCode OBSTORE_ReadFlexServer(void *obs, U8 *buff, U16 *len, BOOL *more);
00445         static ObexRespCode OBSTORE_ReadFlexClient(void *obs, U8 *buff, U16 *len, BOOL *more);
00446
00465         BOOLEAN ComposeHeaders(const ObexObject &   put_req, ObexAppHandle * apphandle  );
00466
00467
00468         /* End of Extended Systems specific callback functions */
00469
00470         UINT GetFreeClientIndex() const;
00471         UINT GetFreeServerIndex() const;
00472
00473
00474         static void OnTimerForceDisconnect(void* arg);
00475         enum force_disconnect_timeout{  c_force_disconnect_timeout = 300 // if after Client ObexDisconnect no Success Response is received during this interval, disconnect is forced.
00476         };
00477
00478
00479         static ObStoreFuncTable     m_obsf_server;
00480         static ObStoreFuncTable     m_obsf_client;
00481
00482         ClientAppContext *          m_client_app_contexts[APOXI_IRDA_OBEX_MAX_CHANNELS];
00483         BOOLEAN                     m_client_app_contexts_is_used[APOXI_IRDA_OBEX_MAX_CHANNELS];
00484         UINT                        m_default_server_index;
00485         UINT                        m_default_server_index_count;
00486         UINT                        m_default_server_index_bound_count;
00487         ServerAppContext *          m_server_app_contexts[APOXI_IRDA_OBEX_MAX_CHANNELS];
00488         Mutex                       m_mutex;
00489         static SystemTimer          m_timer_force_disconnect;
00490 };
00491
00492 #if defined(_DEBUG)
00493 static const char * ObexResultErrorcodeStringtab[] ={
00494     "Success" ,
00495         "ObexError"  ,
00496         "OperationAborted",
00497         "TransportDisconnected" ,"","","","",
00498         "OperationAlreadyRunning"  ,
00499         "OperationNotSupported"     ,
00500         "OperationNotPermitted"  ,
00501         "InvalidHeadersInRequest","","","","",
00502         "ResourceNotAvailable"   ,
00503         "OutOfMemory"       ,"","","","","","","","","","","","","","",
00504         "ServerAlreadyOpen",
00505         "ServerAlreadyClosed","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","",
00506         "ClientAlreadyOpen",
00507         "ClientAlreadyClosed","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","",
00508         "InvalidHeaderId",
00509         "UnknownMimeType","","","", ""
00510         ,"","","","","","","","","",""    ,"","","","","","","","","",""     ,"","","","","","","","","",""     ,"","","","","","","","","",""     ,"","","","","","","","","",""
00511         ,"","","","","","","","","",""    ,"","","","","","","","","",""     ,"","","","","","","","","",""     ,"","","","","","","","","",""     ,"","","","","","","","","",""
00512         ,"","","","","","","","","",""    ,"","","","","","","","","",""     ,"","","","","","","","","",""     ,"","","","","","","","","",""     ,"","","","","","","","","",""
00513         ,"252","253","254",
00514         "Unspecified",
00515 };
00516
00517
00518 static const char * ObexResultResponseCodeStringtab[] ={
00519     "Request" ,  "","","","","","","","","","",   "","","","","","","","","","",   "","","","","","","","","","",  "",
00520         "RespOk"  ,  "","","","","","","","",   "","","","","","","",
00521         // 3xx codes
00522         "RespMultipleChoices" ,
00523         "RespMovedPermanently" ,
00524         "RespMovedTemporarily" ,
00525         "RespSeeOther" ,
00526         "RespNotModified" ,
00527         "RespUseProxy" ,  "","","","","","","",   "","","",
00528         // 4xx codes
00529         "RespBadRequest" ,
00530         "RespUnauthorized" ,
00531         "RespPaymentRequired" ,
00532         "RespForbidden" ,
00533         "RespNotFound" ,
00534         "RespMethodNotAllowed" ,
00535         "RespNotAcceptable" ,
00536         "RespProxyAuthenticationRequired" ,
00537         "RespRequestTimeOut" ,
00538         "RespConflict" ,
00539         "RespGone" ,
00540         "RespLengthRequired" ,
00541         "RespPreconditionFailed" ,
00542         "RespRequestedEntityTooLarge" ,
00543         "RespRequestUrlTooLarge" ,
00544         "RespRequestUnsupportedMediaType" ,
00545         // 5xx codes
00546         "RespInternalServerError" ,
00547         "RespNotImplemented" ,
00548         "RespBadGateWay" ,
00549         "RespServiceUnavailable" ,
00550         "RespGatewayTimeOut" ,
00551         "RespHttpVersionNotSupported" ,   "","","","","","","","","","",
00552         // 6xx codes
00553         "RespDatabaseFull" ,
00554         "RespDatabaseLocked" , "","","","","","","","","","","","","","",
00555         // 7xx codes
00556         "","","","","","","","","","","","","","","","",
00557         // 8xx codes
00558         "","","","","","","","","","","","","","","","",   "","","","","","","","","","","","","","","","",
00559         // Axx codes
00560         "","","","","","","","","","","","","","","","",   "","","","","","","","","","","","","","","","",
00561         // Cxx codes
00562         "","","","","","","","","","","","","","","","",   "","","","","","","","","","","","","","","","",
00563         // Exx codes
00564         "","","","","","","","","","","","","","","","",   "","","","","","","","","","","","","","","","",
00565 };
00566
00567 static const char * ObStatusStringtab[] ={
00568         "OB_STATUS_SUCCESS" ,
00569         "OB_STATUS_FAILED"  ,
00570         "OB_STATUS_PENDING"  ,
00571         "OB_STATUS_DISCONNECT"  ,
00572         "OB_STATUS_NO_CONNECT"  ,
00573         "NN05"  ,
00574         "OB_STATUS_MEDIA_BUSY"  ,
00575         "NN07"  ,
00576         "NN08"  ,
00577         "NN09"  ,
00578         "NN10"  ,
00579         "OB_STATUS_BUSY"  ,
00580         "OB_STATUS_NO_RESOURCES"  ,
00581         "NN13"  ,
00582         "NN14"  ,
00583         "NN15"  ,
00584         "NN16"  ,
00585         "NN17"  ,
00586         "OB_STATUS_INVALID_PARM"  ,
00587         "OB_STATUS_IN_PROGRESS"  ,
00588         "NN20"  ,
00589         "NN21"  ,
00590         "NN22"  ,
00591         "NN23"  ,
00592         "NN24"  ,
00593         "NN25"  ,
00594         "NN26"  ,
00595         "NN27"  ,
00596         "NN28"  ,
00597         "NN29"  ,
00598         "OB_STATUS_INVALID_HANDLE"  ,
00599         "OB_STATUS_PACKET_TOO_SMALL"  ,
00600         "OB_STATUS_NO_SESSION"  ,
00601
00602
00603 };
00604
00605
00606
00607 #endif
00608
00609
00610
00611 #endif // Apoxi_IrdaObexImpl_hpp
00612
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexTransport.cpp File Reference

Irda/Obex/IrdaObexTransport.cpp File Reference

#include "PreComp.hpp"
#include <Irda/IrdaTransport.hpp>
#include "IrdaObexTransport.hpp"

Include dependency graph for IrdaObexTransport.cpp:

Generated on Tue Jan 24 20:52:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexTransport.hpp File Reference

Irda/Obex/IrdaObexTransport.hpp File Reference

#include <Kernel/SubSystem.hpp>
#include <Irda/Obex/IrdaObexImpl.hpp>
#include <Obex/ObexTransport.hpp>
#include <Devices/AbstractTransport.hpp>

Include dependency graph for IrdaObexTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IrConnection
class | IrdaObexSubSystem
class | IrdaObexTransport

Defines

#define | Apoxi_IrdaObexTransport_hpp
#define | C_IR_CONNECTIONS_MAX_NUM 1

Define Documentation

#define Apoxi_IrdaObexTransport_hpp

#define C_IR_CONNECTIONS_MAX_NUM 1

Generated on Tue Jan 24 20:52:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/IrdaObexTransport.hpp Source File

Irda/Obex/IrdaObexTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_IrdaObexTransport_hpp)
00010 #define Apoxi_IrdaObexTransport_hpp
00011
00012 #include <Kernel/SubSystem.hpp>
00013
00014 #include <Irda/Obex/IrdaObexImpl.hpp>
00015
00016 #include <Obex/ObexTransport.hpp>
00017 #include <Devices/AbstractTransport.hpp>
00018
00019 #define C_IR_CONNECTIONS_MAX_NUM 1
00020
00021 #if defined(_DEBUG)
00022 static const char * ir_status_stringtab[] ={
00023         "IR_STATUS_SUCCESS" ,
00024         "IR_STATUS_FAILED"  ,
00025         "IR_STATUS_PENDING",
00026         "IR_STATUS_DISCONNECT" ,
00027         "IR_STATUS_NO_IRLAP"  ,
00028         "IR_STATUS_IN_USE"     ,
00029         "IR_STATUS_MEDIA_BUSY"  ,
00030         "IR_STATUS_MEDIA_NOT_BUSY",
00031         "IR_STATUS_NO_PROGRESS"   ,
00032         "IR_STATUS_LINK_OK"       ,
00033         "IR_STATUS_SDU_OVERRUN"
00034 };
00035 #endif
00036
00037 class IrConnection
00038 {
00039     public:
00040         ObexOperationId m_job_id_client;
00041         BOOLEAN ir_bind_was_succesful;
00042     protected:
00043     private:
00044 };
00045
00046 class IrdaObexTransport : public ObexAbstractTransport {
00047
00048     public:
00049
00050         typedef ObexAbstractTransport Base;
00051
00052         IrdaObexTransport();
00053         virtual ~IrdaObexTransport();
00054
00056         static IrdaObexTransport & GetInstance();
00057
00065         virtual ObexProtocol *  GetProtocol(ObexProtocolId  level);
00066
00082         virtual void    ResolveServerAddr(const String &    server_url,
00083                                           ObexProtocolId    prot_id,
00084                                           BOOLEAN           sdb_autocreate,
00085                                           ObexOperationId   job_id);
00086
00101         virtual void    ResolveClientAddr(const String &    client_url,
00102                                           ObexProtocolId    prot_id,
00103                                           ObexOperationId   job_id);
00104
00105         virtual void    AbortResolveClientAddr(const ObexOperationId &  job_id);
00106
00107
00108             // Callback prototype
00109
00110         static void ServerCallBack(IrConnect* con, IrCallBackParms* parms);
00111         static void ClientCallBack(IrConnect* con, IrCallBackParms* parms);
00112
00113         void UnbindStack(void* arg);
00114         IrConnection irconnections[C_IR_CONNECTIONS_MAX_NUM];
00115         static UINT16 m_client_discovery_poll_repeat_counter;
00116         static SystemTimer m_clienttimer;
00117         static BOOLEAN ir_discoverreq_in_progress;
00118
00119     private:
00120
00121
00122         enum discovery_poll_repeat_interval{  c_ir_discovery_poll_repeat_interval = 4000 // try every 4 second , because IR_STATUS_NO_PROGRESS means that IrLAP has no progress for 3 seconds
00123         };
00124         enum discovery_poll_repeat_number{  c_ir_discovery_poll_repeat_maxnumber = 5, // 5 x 4 second trying
00125                                             c_ir_discovery_finalized = c_ir_discovery_poll_repeat_maxnumber+50
00126         };
00127
00128
00129         IrdaObexImpl    m_obex_impl;
00130         static void OnClientTimer(void* arg);
00131
00132
00133         //IrStackContext m_irstackcontext;
00134         // (Global) IrLMP/Tiny TP connection structure:
00135         IrConnect m_appCon; //assuming this is common for all connections
00136         // Server: Accepting an Incoming IrLMP Connection: Packet structure for responses:
00137         static IrPacket m_appPacket;
00138         static ObexOperationId s_operationid;
00139
00140 };
00141
00142 /*
00143     IrdaObexSubSystem initialises IrdaObexTransport
00144 */
00145 class IrdaObexSubSystem : public SubSystem {
00146     public:
00147         virtual const WCHAR* GetName() const { return L"IrDA Obex"; };
00148         virtual void OnPowerUp();
00149         virtual BootSequenceState InvokeAt() const { return SubSystemManager::c_run_level_1; };
00150     private:
00151         static IrdaObexSubSystem    m_irda_obex_sub_system;
00152 };
00153
00154 #endif  // Apoxi_IrdaObexTransport_hpp
00155
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/PreComp.cpp File Reference

Irda/Obex/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:07:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/PreComp.hpp File Reference

Irda/Obex/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Kernel/SubSystem.hpp>
#include <Auxiliary/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Obex/ObexLayer.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexAddress.hpp>
#include <Obex/ObexTransport.hpp>
#include <Devices/AbstractTransport.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:21:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Irda/Obex/PreComp.hpp Source File

Irda/Obex/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Kernel/SubSystem.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Adc/Lib.hpp>
00013 #include <Apc/Lib.hpp>
00014 #include <Asc/Lib.hpp>
00015
00016 #include <Obex/ObexLayer.hpp>
00017 #include <Obex/ObexChannel.hpp>
00018 #include <Obex/ObexAddress.hpp>
00019 #include <Obex/ObexTransport.hpp>
00020 #include <Devices/AbstractTransport.hpp>
00021
00022
00023
00024
00025
00026
00027
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AbstractExternalData.cpp File Reference

Kernel/AbstractExternalData.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "AbstractExternalData.hpp"

Include dependency graph for AbstractExternalData.cpp:

Generated on Tue Jan 24 20:52:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AbstractExternalData.hpp File Reference

Kernel/AbstractExternalData.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractExternalData

Defines

#define | Kernel_AbstractExternalData_hpp

Define Documentation

#define Kernel_AbstractExternalData_hpp

Generated on Tue Jan 24 20:52:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AbstractExternalData.hpp Source File

Kernel/AbstractExternalData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Kernel_AbstractExternalData_hpp)
00010 #define Kernel_AbstractExternalData_hpp
00013
00014
00016 class AbstractExternalData {
00017     public:
00019         AbstractExternalData();
00021         virtual ~AbstractExternalData();
00022 };
00023
00025 #endif  // Kernel_AbstractExternalData_hpp
00026
00027
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AbstractScheduler.cpp File Reference

Kernel/AbstractScheduler.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Kernel/AbstractScheduler.hpp"
#include "Kernel/Os/Win32/Scheduler.hpp"

Include dependency graph for AbstractScheduler.cpp:

Generated on Tue Jan 24 20:52:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AbstractScheduler.hpp File Reference

Kernel/AbstractScheduler.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>

Include dependency graph for AbstractScheduler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractAppContext
class | AbstractScheduler

Defines

#define | Apoxi_AbstractScheduler_hpp

Define Documentation

#define Apoxi_AbstractScheduler_hpp

Generated on Tue Jan 24 20:57:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AbstractScheduler.hpp Source File

Kernel/AbstractScheduler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AbstractScheduler_hpp)
00010 #define Apoxi_AbstractScheduler_hpp
00013
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/LinkedList.hpp>
00017
00018
00019 class AbstractScheduler;
00020 class AppContainer;
00021 class Condition;
00022 class Message;
00023 class Application;
00024
00028 class AbstractAppContext : public Linkable<AbstractAppContext> {
00029
00030     public:
00034         AbstractAppContext(AbstractScheduler* scheduler, Application* app);
00035
00037         virtual ~AbstractAppContext();
00038
00041         virtual void StartUp();
00042
00044         void Stop() { m_running = FALSE; }
00045
00048         virtual void MsgLoop() = 0;
00049
00052         virtual void SendMsg(Message& msg) = 0;
00053
00056         virtual void Wait(const Condition& cond) = 0;
00057
00060         BOOLEAN IsRunning() const { return m_running; }
00061
00063         const Application* GetApplication() const { return m_app; } ;
00064
00065     protected:
00066         BOOLEAN m_running;
00067         AbstractScheduler* m_scheduler;
00068         Application* m_app;
00069 };
00070
00071
00074 class AbstractScheduler {
00075
00076     public:
00079         AbstractScheduler(AppContainer* cont);
00081         virtual ~AbstractScheduler();
00082
00087         void AddAppContext(Application* app);
00088
00093         void RemoveAppContext(const Application* app);
00094
00097         virtual AbstractAppContext* CreateAppContext(Application* app) = 0;
00098
00101         AbstractAppContext* GetAppContext(const Application* app) const;
00102
00104         virtual void StartUp() = 0;
00105
00109         virtual void SendMsg(const Application* app, Message& msg) = 0;
00110
00112         virtual void Reschedule() = 0;
00113
00118         virtual void Wait(const Application* app, const Condition& cond) = 0;
00119
00121         virtual void ShutDown();
00122
00123     protected:
00124         friend class Os;
00125         friend class AppContainer;
00126
00127         BOOLEAN m_unblock_focus_messages;
00128         AppContainer* m_cont;
00129         LinkedList<AbstractAppContext> m_appcntxt_list;
00130         LinkedList<AbstractAppContext> m_rem_appcntxt_list;
00131 };
00132
00134 #endif
00135
00136
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ActiveWaitDispatcher.cpp File Reference

Kernel/ActiveWaitDispatcher.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "ActiveWaitDispatcher.hpp"
#include "System.hpp"
#include "Application.hpp"
#include "AppContainer.hpp"

Include dependency graph for ActiveWaitDispatcher.cpp:

Generated on Tue Jan 24 20:57:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ActiveWaitDispatcher.hpp File Reference

Kernel/ActiveWaitDispatcher.hpp File Reference

#include <Kernel/MessageMapDispatcher.hpp>
#include <Kernel/Condition.hpp>

Include dependency graph for ActiveWaitDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ActiveWaitDispatcher

Defines

#define | Apoxi_ActiveWaitDispatcher_hpp

Define Documentation

#define Apoxi_ActiveWaitDispatcher_hpp

Generated on Tue Jan 24 20:57:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ActiveWaitDispatcher.hpp Source File

Kernel/ActiveWaitDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_ActiveWaitDispatcher_hpp)
00010 #define Apoxi_ActiveWaitDispatcher_hpp
00013
00014 #include <Kernel/MessageMapDispatcher.hpp>
00015 #include <Kernel/Condition.hpp>
00016
00018 class ActiveWaitDispatcher : public MessageMapDispatcher {
00019     typedef MessageMapDispatcher Base;
00020
00021     public:
00023         ActiveWaitDispatcher(const AbstractMessageMapContainer *msg_map_container = 0, BOOLEAN add_immediately = FALSE);
00024
00025         virtual ~ActiveWaitDispatcher();
00026
00028         void Init(const AbstractMessageMapContainer *msg_map_container);
00029
00032         virtual BOOLEAN Wait(UINT32 timeout = 0);
00033
00035         void Done();
00036
00037     private:
00038         TimeoutCondition m_condition;
00039 };
00040
00042 #endif  // Apoxi_ActiveWaitDispatcher_hpp
00043
00044
Generated on Tue Jan 24 14:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AlarmManager.cpp File Reference

Kernel/AlarmManager.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "AlarmManager.hpp"
#include <Devices/RealTimeClock.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Devices/StartUp.hpp>
#include <Devices/ShutDown.hpp>
#include <Devices/RtcSignalProcessor.hpp>
#include <Afs/Registry.hpp>
#include <Afs/RegistryTypes.hpp>
#include <Auxiliary/DataItem.hpp>

Include dependency graph for AlarmManager.cpp:

Generated on Tue Jan 24 20:57:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AlarmManager.hpp File Reference

Kernel/AlarmManager.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/DateTime.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Kernel/SubSystem.hpp>
#include <AddOns/Services/Service.hpp>
#include <Devices/StartUp.hpp>
#include <Afs/Uri.hpp>

Include dependency graph for AlarmManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AlarmManager
struct | AlarmManager::AlarmList

Defines

#define | Apoxi_AlarmManager_hpp
#define | APOXI_ALARMMANAGER_MAX_ENTRIES 10

Variables

const INT | c_alarm_manager_max_entries = APOXI_ALARMMANAGER_MAX_ENTRIES

Define Documentation

#define Apoxi_AlarmManager_hpp

Generated on Tue Jan 24 20:57:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AlarmManager.hpp Source File

Kernel/AlarmManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_AlarmManager_hpp)
00011 #define Apoxi_AlarmManager_hpp
00012
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Auxiliary/DateTime.hpp>
00018 #include <Kernel/Os/Mutex.hpp>
00019 #include <Kernel/SubSystem.hpp>
00020 #include <AddOns/Services/Service.hpp>  // needed for Guid!
00021 #include <Devices/StartUp.hpp>
00022 #include <Afs/Uri.hpp>
00023
00024 #if !defined(APOXI_ALARMMANAGER_MAX_ENTRIES)
00025     #define APOXI_ALARMMANAGER_MAX_ENTRIES 10
00026 #endif
00027
00028 const INT c_alarm_manager_max_entries = APOXI_ALARMMANAGER_MAX_ENTRIES;
00029
00038 class AlarmManager : private SubSystem {
00039     typedef SubSystem Base;
00040
00041     public:
00043         enum PowerOnBehavior {
00044             Default,
00045             NoPowerOn,
00046             PowerOn
00047         };
00048
00051         //static AlarmManager& GetInstance() { return m_alarm_manager; }
00052
00064         static void Register();
00065
00077         static void SetAlarm(const DateTime& alarm,
00078                       PowerOnBehavior behavior = Default,
00079                       StartUp::Cause startup_cause = StartUp::AlarmOn);
00080
00083         static void ClearAlarm();
00084
00087         static void SetDefaultPowerOnBehavior(PowerOnBehavior behavior);
00088
00089         virtual ~AlarmManager();
00090
00091     private:
00092         struct AlarmList {
00093             ExecutionContext* context;
00094             Guid guid;
00095             UINT32 absolute_seconds;
00096             UINT16 power_on_behavior : 2;
00097             UINT16 startup_cause     : 5;
00098         };
00099
00100         static PowerOnBehavior m_default_behavior;
00101         static const UINT32 c_no_alarm;
00102         static const Uri c_uri;
00103         static Mutex m_mutex;
00104         static AlarmList m_list[c_alarm_manager_max_entries];
00105         static AlarmManager m_alarm_manager;
00106
00107         AlarmManager();
00108
00109         virtual const WCHAR* GetName() const;
00110         virtual void OnPowerUp();
00111         virtual void OnPowerDown();
00112         virtual UINT8 GetPriority() const;
00113         virtual BootSequenceState InvokeAt() const;
00114
00115         static INT GetIdxForGuid(const Guid& guid);
00116         static INT GetIdxForContext(const ExecutionContext& context);
00117         static INT GetIdxFree();
00118         static INT GetIdxNextAlarm();
00119         static INT GetIdxNextPowerOnAlarm();
00120
00121         static void SendNextAlarmToRtc(BOOLEAN power_on, UINT32 abs_sec_now);
00122
00123         static void InitRegistry(Uri& uri);
00124         static void InitRegistryMainNodes(Uri& uri);
00125         static void SaveAlarm(INT idx);
00126         static void LoadAlarm(INT idx);
00127         static void SaveDefaultBehavior();
00128         static void LoadDefaultBehavior();
00129         static Uri NodeUri(const CHAR* node, INT idx);
00130         static void AlarmExpired(INT idx);
00131         static void Clear(INT idx);
00132         static void ClearCb(void* arg);
00133         static void RtcEventCallbackFn();
00134 };
00135
00137 #endif  // Apoxi_AlarmManager_hpp
00138
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Allocator.cpp File Reference

Kernel/Allocator.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Kernel/Allocator.hpp"

Include dependency graph for Allocator.cpp:

Variables

ApoxiNewHandlerFn ApoxiNewHandler
Generated on Tue Jan 24 20:57:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Allocator.hpp File Reference

Kernel/Allocator.hpp File Reference

#include <Kernel/Os/Os.hpp>

Include dependency graph for Allocator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Allocator< T >

Defines

#define | Apoxi_Allocator_hpp

Typedefs

typedef void(* | ApoxiNewHandlerFn )()
typedef void(* | NewHandlerFn )()

Functions

void | operator delete (void *, void *)
void | operator delete (void *p)
void * | operator new (size_t, void *p)
void * | operator new (size_t size)

Variables

ApoxiNewHandlerFn ApoxiNewHandler
NewHandlerFn NewHandler

Define Documentation

#define Apoxi_Allocator_hpp

Generated on Tue Jan 24 20:58:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Allocator.hpp Source File

Kernel/Allocator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Allocator_hpp)
00010 #define Apoxi_Allocator_hpp
00013
00014 #include <Kernel/Os/Os.hpp>
00015
00016 typedef void (*ApoxiNewHandlerFn)();
00017
00018 extern ApoxiNewHandlerFn ApoxiNewHandler;
00019
00020 /*  ------------------------------------------------------------------------
00021                     Global Operator new and delete
00022     ------------------------------------------------------------------------ */
00023
00024 #if defined(APOXI_RTOS_NUC32)
00025     extern void* operator new(size_t size) throw();
00026     extern void operator delete(void* p) throw();
00027 #elif ! defined(APOXI_RTOS_WIN32)
00028     extern void* operator new(size_t size);
00029     extern void operator delete(void* p);
00030 #else
00031     inline void* operator new(size_t size) { return Os::Alloc(size); }
00032     inline void operator delete(void* p) { Os::Free(p); }
00033 #endif
00034
00035 /*  ------------------------------------------------------------------------
00036                                     Types
00037     ------------------------------------------------------------------------ */
00038 typedef void (*NewHandlerFn)();
00039
00040 extern NewHandlerFn NewHandler;
00041
00042 /*  ------------------------------------------------------------------------
00043                     Constructors and Deconstructors
00044     ------------------------------------------------------------------------ */
00045
00046
00047 /*  ------------------------------------------------------------------------
00048                                     Allocator
00049     ------------------------------------------------------------------------ */
00050
00053 inline void* operator new(size_t, void* p) { return p; }
00054
00057 inline void operator delete(void*, void*) { }
00058
00059
00062 template <class T> class Allocator {
00063     public:
00064         typedef Allocator<T> ThisType;
00065
00070         static T* Alloc() {
00071             return((T* ) Os::Alloc(sizeof(T)));
00072             }
00073
00079         static T* Alloc(INT n) {
00080             return((T* ) Os::Alloc(n*  sizeof(T)));
00081             }
00082
00086         static void Free(T* p) {
00087             Os::Free(p);
00088             }
00089
00093         static void Construct(T* p, const T& val) {
00094             new (p) T(val);
00095             }
00096
00100         static void Destruct(T* p) {
00101             p->~T();
00102             }
00103 };
00104
00106 #endif  // Apoxi_Allocator_hpp
00107
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ApoxiKernelVersion.cpp File Reference

Kernel/ApoxiKernelVersion.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <ApoxiVersion.hpp>

Include dependency graph for ApoxiKernelVersion.cpp:

Functions

ApoxiDefVersionInfo (Kernel, APOXIVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | Kernel | ,
 |  | APOXIVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 20:58:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ApoxiThread.cpp File Reference

Kernel/ApoxiThread.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "ApoxiThread.hpp"

Include dependency graph for ApoxiThread.cpp:

Generated on Tue Jan 24 20:58:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ApoxiThread.hpp File Reference

Kernel/ApoxiThread.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Auxiliary/Linkable.hpp>

Include dependency graph for ApoxiThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ApoxiThread

Defines

#define | Apoxi_ApoxiThread_hpp

Define Documentation

#define Apoxi_ApoxiThread_hpp

Generated on Tue Jan 24 20:58:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ApoxiThread.hpp Source File

Kernel/ApoxiThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ApoxiThread_hpp)
00011 #define Apoxi_ApoxiThread_hpp
00014
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Auxiliary/Linkable.hpp>
00017
00018 class ExecutionContext;
00019
00030 class ApoxiThread : public Thread, public Linkable<ApoxiThread> {
00031     typedef Thread Base;
00032
00033     public:
00034         ApoxiThread();
00035         virtual ~ApoxiThread();
00036
00038         virtual ExecutionContext& GetContext() = 0;
00039
00041         virtual const ExecutionContext& GetContext() const = 0;
00042 };
00043
00045 #endif  // Apoxi_ApoxiThread_hpp
00046
00047
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AppContainer.cpp File Reference

Kernel/AppContainer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "AppContainer.hpp"
#include "System.hpp"
#include "Os/MutexObtainer.hpp"
#include "Application.hpp"
#include "SubSystemManager.hpp"
#include "MsgTypes.hpp"
#include "MessageRouter.hpp"
#include <Kernel/Os/Os.hpp>

Include dependency graph for AppContainer.cpp:

Generated on Tue Jan 24 20:59:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AppContainer.hpp File Reference

Kernel/AppContainer.hpp File Reference

#include <Kernel/ApoxiThread.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/Timer.hpp>
#include <Kernel/AppContainerRoutingTable.hpp>
#include <Kernel/MsgQueue.hpp>
#include <Kernel/MsgCategory.hpp>
#include <Kernel/Os/Mutex.hpp>

Include dependency graph for AppContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AppContainer

Defines

#define | Apoxi_AppContainer_hpp

Define Documentation

#define Apoxi_AppContainer_hpp

Generated on Tue Jan 24 20:59:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AppContainer.hpp Source File

Kernel/AppContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AppContainer_hpp)
00010 #define Apoxi_AppContainer_hpp
00013
00014 #include <Kernel/ApoxiThread.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Kernel/Timer.hpp>
00017 #include <Kernel/AppContainerRoutingTable.hpp>
00018 #include <Kernel/MsgQueue.hpp>
00019 #include <Kernel/MsgCategory.hpp>
00020 #include <Kernel/Os/Mutex.hpp>
00021
00022 class Application;
00023 class Message;
00024 class MessageReferrer;
00025 class Condition;
00026
00038 class AppContainer : public ApoxiThread {
00039     typedef ApoxiThread Base;
00040
00041     public:
00043         AppContainer();
00044
00046         virtual ExecutionContext& GetContext();
00047
00049         virtual const ExecutionContext& GetContext() const;
00050
00052         void Run();
00053
00055         virtual INT ThreadFn();
00056
00058         BOOLEAN HasFocus() const;
00059
00061         Application* GetActiveApplication() const { return m_active_app; }
00062
00064         void Attach(Application* app);
00065
00067         void Detach(Application* app);
00068
00070         void MsgLoop();
00071
00073         void Wait(const Condition& cond) { m_scheduler.Wait(GetActiveApplication(), cond); }
00074
00076         void RegisterMessage(Application* app, MsgId msg_id);
00077
00079         void UnregisterMessage(const Application* app, MsgId msg_id);
00080
00082         BOOLEAN IsMessageRegistered(const Message& msg) const;
00083
00085         void AddTimer(Timer* timer) { m_timer_list.Insert(timer); }
00086
00088         void RemoveTimer(Timer* timer) { m_timer_list.Remove(timer); m_msg_queue.DeleteTimerTimeoutMsg(*timer); }
00089
00091         const Timer* NextExpiringTimer() { return m_timer_list.GetFront(); }
00092
00094         BOOLEAN Enqueue(const MessageReferrer& msg_ref);
00095
00097         void TriggerIsrDataProcessing() { m_msg_queue.TriggerIsrDataProcessing(); }
00098
00102         BOOLEAN ContainsUserInputMsg() const;
00103
00105         BOOLEAN IsRunning() { return (m_running || AllApplicationsRunning()); };
00106
00108         void TransferFocus(Application* app) const;
00109
00111         void GrabFocus(Application* app,
00112                        INT priority = -1,
00113                        BOOLEAN assign_to_win = TRUE) const;
00114
00115     private:
00116         friend class Timer;
00117         friend class MsgQueue;
00118         friend class System;
00119         friend void Os::DbgOutStackUsage();
00120
00121         BOOLEAN m_running;
00122         INT m_app_count;            // Number of applications in the container
00123         Application *m_active_app;
00124         Scheduler m_scheduler;
00125         TimerList m_timer_list;
00126         MsgQueue m_msg_queue;
00127         AppContainerRoutingTable m_message_routing_table;
00128         LinkedList<Application> m_app_list;
00129
00130         void RouteMessage(Message& msg);
00131         void RouteRegisteredMessage(Message& msg);
00132         void SendMessage(Application* app, Message& msg);
00133         BOOLEAN AllApplicationsRunning();
00134         BOOLEAN IsShutdownAllowed();
00135 };
00136
00138 #endif  // Apoxi_AppContainer_hpp
00139
00140
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AppContainerRoutingTable.cpp File Reference

Kernel/AppContainerRoutingTable.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "AppContainerRoutingTable.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for AppContainerRoutingTable.cpp:

Generated on Tue Jan 24 20:59:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AppContainerRoutingTable.hpp File Reference

Kernel/AppContainerRoutingTable.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/ElementList.hpp>
#include <Auxiliary/HashTable.hpp>

Include dependency graph for AppContainerRoutingTable.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AppContainerRoutingTableEntry
class | ApplicationListEntry

Defines

#define | Apoxi_AppContainerRoutingTable_hpp

Typedefs

typedef HashTable | AppContainerRoutingTable
typedef ElementList< ApplicationListEntry > | AppElemList

Define Documentation

#define Apoxi_AppContainerRoutingTable_hpp

Generated on Tue Jan 24 20:59:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AppContainerRoutingTable.hpp Source File

Kernel/AppContainerRoutingTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_AppContainerRoutingTable_hpp)
00010 #define Apoxi_AppContainerRoutingTable_hpp
00013
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/LinkedList.hpp>
00016 #include <Auxiliary/ElementList.hpp>
00017 #include <Auxiliary/HashTable.hpp>
00018
00019 class Application;
00020
00022 class ApplicationListEntry : public Linkable<ApplicationListEntry> {
00023     public:
00025         ApplicationListEntry(Application* app) : m_app(app), m_reg_count(1) {}
00027         Application* GetApplication() const { return m_app; }
00029         BOOLEAN operator == (const ApplicationListEntry& app_list_entry) const {
00030             return (m_app == app_list_entry.m_app);
00031         }
00033         void IncrementRegCount() {m_reg_count++;}
00035         void DecrementRegCount() {m_reg_count--;}
00037         BOOLEAN IsEmpty() {return (m_reg_count == 0);}
00038
00039     private:
00040         Application* m_app;
00041         INT m_reg_count;
00042 };
00043
00044 typedef ElementList<ApplicationListEntry> AppElemList;
00045
00047 class AppContainerRoutingTableEntry : public Hashable {
00048     typedef Hashable Base;
00049     public:
00050         AppContainerRoutingTableEntry(const HashKey hash_key);
00051         virtual ~AppContainerRoutingTableEntry();
00052
00053         ApplicationListEntry* GetFirstApplicationListEntry() const {  return (m_application_list.GetFront()); }
00054         INT GetNoOfApplications() const {  return (m_application_list.GetSize()); }
00055
00056         void AddApplication(Application* app);
00057         void RemoveApplication(const Application* app);
00058
00059     private:
00060         LinkedList<ApplicationListEntry> m_application_list;
00061 };
00062
00063 typedef HashTable AppContainerRoutingTable;
00064
00066 #endif  // Apoxi_AppContainerRoutingTable_hpp
00067
00068
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Application.cpp File Reference

Kernel/Application.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Application.hpp"
#include "System.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include "VersionInfo.hpp"
#include <Gui/WindowManager.hpp>
#include <Gui/Desktop.hpp>
#include <Gui/DisplayDc.hpp>
#include "MessageRouter.hpp"
#include <Gui/Window.hpp>
#include "AppContainer.hpp"
#include <Devices/Device.hpp>
#include "SubSystemManager.hpp"
#include <Gui/Panel.hpp>
#include <Gui/MsgTypes.hpp>
#include <Gui/GlassPane.hpp>

Include dependency graph for Application.cpp:

Functions

ApoxiUseVersionInfo (Kernel)

Function Documentation

ApoxiUseVersionInfo ( Kernel )

Generated on Tue Jan 24 20:59:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Application.hpp File Reference

Kernel/Application.hpp File Reference

#include <Kernel/Dispatcher.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Gui/Control.hpp>
#include <Devices/StartUp.hpp>
#include <Kernel/Trace.hpp>
#include <Gui/DeviceContext.hpp>

Include dependency graph for Application.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Application

Defines

#define | Apoxi_Application_hpp

Define Documentation

#define Apoxi_Application_hpp

Generated on Tue Jan 24 20:59:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Application.hpp Source File

Kernel/Application.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Application_hpp)
00010 #define Apoxi_Application_hpp
00013
00014 #include <Kernel/Dispatcher.hpp>
00015 #include <Kernel/ExecutionContext.hpp>
00016 #include <Gui/Control.hpp>
00017 #include <Devices/StartUp.hpp>
00018 #include <Kernel/Trace.hpp>
00019 #include <Gui/DeviceContext.hpp>
00020
00021 class AppContainer;
00022 class Window;
00023 class Panel;
00024 class Timer;
00025
00032 class Application : public Dispatcher, public ExecutionContext, public Linkable<Application> {
00033     typedef Dispatcher Base;
00034
00035     public:
00038         Application(const WCHAR* app_name, UINT stacksize = 0);
00039
00041         virtual ~Application();
00042
00044         virtual Type GetType() const;
00045
00047         virtual void RegisterMessage(MsgId msg_id);
00048
00050         virtual void UnregisterMessage(MsgId msg_id);
00051
00055         void Post(const Message& msg) const;
00056
00064         BOOLEAN GrabFocus();
00065
00071         BOOLEAN HasFocus() const;
00072
00075         Window* GetFocusedWindow() const;
00076
00079         Window* GetFirstWindow() const { return (Window*)m_first_control; }
00080
00083         void AddWindow(Window* win);
00084
00087         void RemoveWindow(Window* win);
00088
00090         BOOLEAN ContainsWindow(const Window* win) const;
00091
00093         void SetName(const WCHAR* name) { m_app_name = name; }
00094
00096         const WCHAR* GetName() const { return m_app_name; }
00097
00099         void SetAppContainer(AppContainer* app_container);
00100
00102         AppContainer* GetAppContainer() const { return m_app_container; }
00103
00105         void UpdateDisplay(INT display_idx = 0);
00106
00108         UINT GetRequestedStackSize() const { return m_requested_stacksize; }
00109
00113         void SetShutdownAllowed(BOOLEAN shutdown_allowed) { m_bits.shutdown_allowed = shutdown_allowed; }
00114
00116         BOOLEAN IsShutdownAllowed() const { return m_bits.shutdown_allowed; }
00117
00119         BOOLEAN IsRunning() const { return m_bits.running; }
00120
00122         BOOLEAN DoesSynchronousDrawing() const { return (BOOLEAN)m_bits.synchronous_drawing; }
00123
00127         Panel* GetPanel() const;
00128
00130         void SetAppName(const WCHAR* app_name) { m_app_name = app_name; }
00131
00133         const WCHAR* GetAppName() const { return m_app_name; }
00134
00136         void TransferFocus();
00137
00139         void GrabFocus(BOOLEAN assign_to_win);
00140
00143         void SetPriority(INT priority);
00144
00147         INT GetPriority() const;
00148
00150         Window* GetForegroundWindow(INT display_idx = 0) const;
00151
00152     protected:
00162         virtual BOOLEAN RouteMessage(const Message& msg);
00163
00166         virtual BOOLEAN OnMessage(const Message& msg);
00167
00169         virtual BOOLEAN AcceptMsg(const Message& msg);
00170
00172         virtual BOOLEAN HandleMsg(const MessageReferrer& msg_ref);
00173
00175         virtual void AddTimer(Timer& timer);
00176
00178         virtual void RemoveTimer(Timer& timer);
00179
00182         virtual void OnStartup();
00183
00190         virtual BOOLEAN OnShutdownRequest();
00191
00193         virtual void OnOpen();
00194
00196         virtual void OnClose();
00197
00200         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00201
00204         virtual BOOLEAN OnKeyUp(KeyCode key_code, UINT32 duration);
00205
00209         virtual BOOLEAN OnLongKeyPress(KeyCode key_code);
00210
00214         virtual BOOLEAN OnVeryLongKeyPress(KeyCode key_code);
00215
00217         virtual BOOLEAN OnKeyAutoRepeat(KeyCode key_code);
00218
00220         virtual BOOLEAN OnLockedKeyDown(KeyCode key_code);
00221
00223         virtual BOOLEAN OnTimeout(const Timer& timer);
00224
00226         virtual void OnThemeChanged();
00227
00229         virtual void OnLanguageChanged();
00230
00232         virtual void OnGetFocus();
00233
00235         virtual void OnLoseFocus();
00236
00239         virtual Panel* CreatePanel() const;
00240
00243         virtual void DestroyPanel(Panel* panel) const;
00244
00245         void SetRequestedStackSize(UINT size);
00246
00247 #if defined(APOXI_COMPAT_2_0_0)
00248         virtual BOOLEAN OnInputChar(WCHAR chr);
00249 #endif
00250
00251     private:
00252         struct {
00253             UINT win_event              : 1;
00254             UINT received_key_down      : 1;
00255             UINT shutdown_allowed       : 1;
00256             UINT running                : 1;
00257             UINT synchronous_drawing    : 1;
00258             UINT has_focus              : 1;    // TRUE if Application::OnGetFocus has been invoked
00259         } m_bits;
00260
00261         UINT                m_requested_stacksize;
00262         const WCHAR         *m_app_name;
00263         AppContainer        *m_app_container;
00264         Control             *m_first_control;
00265         AppTracer           m_app_tracer;
00266         mutable Panel*      m_panel;
00267         static Application* m_app_close_subsystems;
00268
00269         virtual void DoWait(const Condition& cond);
00270
00271         void ProcessWinEvents();
00272         void DrawControls(Control* control);
00273         void ProcessWinEventsFrontFirst(Window* win);
00274
00275         void RemarkWinEvent() { m_bits.win_event = TRUE; };
00276         BOOLEAN HasWinEvent() { return (BOOLEAN) m_bits.win_event; };
00277
00278         void SetRunning(BOOLEAN running) { m_bits.running = running; }
00279         void AdjustFocusOrder();
00280
00281         BOOLEAN HandleMessage(const Message& msg);
00282
00283         friend void Control::PutToForeground();                 // adjusts m_first_control (note: avoid for later releases)
00284         friend void Control::AbsInvalidate(Control* control,    // remarks window event (m_bits.win_event)
00285                                           const Rect& abs_inv_rect,
00286                                           BOOLEAN erase);
00287         friend void DeviceContext::EndUpdate();                 // adjusts m_blit_rect
00288         friend class AppContainer;                              // invokes HasWinEvent() for optimization in MsgLoop()
00289         friend void StartUp::Restart(const StartUp::Data &startup_data);    // for requesting the stacksize via StartUpConfig
00290 };
00291
00293 #endif  // Apoxi_Application_hpp
00294
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ApplicationTracer.cpp File Reference

Kernel/ApplicationTracer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/Os/InternalTracer.hpp>
#include "ApplicationTracer.hpp"
#include "System.hpp"

Include dependency graph for ApplicationTracer.cpp:

Generated on Tue Jan 24 20:59:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ApplicationTracer.hpp File Reference

Kernel/ApplicationTracer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | _ApplicationTracer
class | _NullApplicationTracer

Defines

#define | APOXI_APPLICATION_TRACER_MAX_APPS 50
#define | APPLICATION_TRACER_HPP

Define Documentation

#define APPLICATION_TRACER_HPP

Generated on Tue Jan 24 20:59:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ApplicationTracer.hpp Source File

Kernel/ApplicationTracer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(APPLICATION_TRACER_HPP)
00011 #define APPLICATION_TRACER_HPP
00014
00015 #if !defined(APOXI_APPLICATION_TRACER_MAX_APPS)
00016     #define APOXI_APPLICATION_TRACER_MAX_APPS 50
00017 #endif
00018
00019
00020 class  _NullApplicationTracer {
00021     public:
00022         _NullApplicationTracer(const void* app) {}
00023         void TraceAttach(const void* app, const void* container, const WCHAR* appName) {}
00024         void TraceDetach(const void* app) {}
00025         void TraceMessage(const void* msg) {}
00026         static UINT8 GetCurApplicationID() { return 0; }
00027 };  //_NullApplicationTracer
00028
00029 class  _ApplicationTracer {
00030     public:
00032         _ApplicationTracer(const void* app) {
00033             AddApplication(app);
00034         }
00035
00037         void TraceAttach(const void* app, const void* container, const WCHAR* appName) {
00038             const void* linkreg=0;
00039             #if defined(APOXI_RTOS_NUC32)
00040                 // get linkregister, contains caller address
00041                 #if (__ARMCC_VERSION<200000)
00042                     __asm
00043                     {
00044                         mov linkreg,r14
00045                     }
00046                 #else
00047                     linkreg = (const void*) __return_address();
00048                 #endif
00049             #endif
00050             InternalTracer::TraceAppAttach(linkreg, app, container, appName, GetID(app));
00051         }
00052
00054         void TraceDetach(const void* app) {
00055             const void* linkreg=0;
00056             #if defined(APOXI_RTOS_NUC32)
00057                 // get linkregister, contains caller address
00058                 #if (__ARMCC_VERSION<200000)
00059                     __asm
00060                     {
00061                         mov linkreg,r14
00062                     }
00063                 #else
00064                     linkreg = (const void*) __return_address();
00065                 #endif
00066             #endif
00067             InternalTracer::TraceAppDetach(linkreg, app, GetID(app));
00068         }
00069
00072         static unsigned char GetCurApplicationID();
00073
00074
00075     private:
00076         enum {
00077             MAX_APPS = APOXI_APPLICATION_TRACER_MAX_APPS
00078         };
00079
00080         static const void* g_apps[MAX_APPS];
00081         static UINT8 g_appID;
00082
00083         static void AddApplication(const void* app) {
00084             if (g_appID < MAX_APPS-1)
00085                 g_apps[++g_appID] = app;
00086         }   // AddApplication
00087
00088
00089         static UINT8 GetID(const void* app) {
00090             for (UINT8 i=0; i<=g_appID; i++) {
00091                 if (app == g_apps[i])
00092                     return i;
00093             }
00094             return 0;
00095         }   // GetID
00096
00097 };  // _ApplicationTracer
00098
00099
00101 #endif // APPLICATION_TRACER_HPP
00102
00103
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AppRoutingTable.hpp File Reference

Kernel/AppRoutingTable.hpp File Reference

#include <Kernel/Linkable.hpp>
#include <Kernel/LinkedList.hpp>

Include dependency graph for AppRoutingTable.hpp:

Go to the source code of this file.

Data Structures

class | AppRoutingTableEntry

Defines

#define | Apoxi_AppRoutingTable_hpp

Typedefs

typedef LinkedList< AppRoutingTableEntry > | AppRoutingTable
typedef LinkedList< DispatcherAction > | DispatcherActionList

Define Documentation

#define Apoxi_AppRoutingTable_hpp

Generated on Tue Jan 24 20:59:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/AppRoutingTable.hpp Source File

Kernel/AppRoutingTable.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AppRoutingTable_hpp)
00009 #define Apoxi_AppRoutingTable_hpp
00012
00013 #include <Kernel/Linkable.hpp>
00014 #include <Kernel/LinkedList.hpp>
00015
00016 typedef LinkedList<DispatcherAction> DispatcherActionList;
00017
00018 class AppRoutingTableEntry : public Linkable<AppRoutingTableEntry> {
00019     public:
00020         AppRoutingTableEntry(const MsgId msg_id) : m_msg_id(msg_id) {};
00021
00022         const MsgId GetMsgId() const { return m_msg_id; };
00023
00024         const DispatcherActionList* GetDispatcherActionList() const { return& m_disp_action_list; }
00025
00026         void AddDispatcherAction(DispatcherAction* app_entry) {
00027             m_disp_action_list.PushBack(app_entry);
00028         };
00029
00030     private:
00031         MsgId m_msg_id;
00032         DispatcherActionList m_disp_action_list;
00033 };
00034
00035 typedef LinkedList<AppRoutingTableEntry> AppRoutingTable;
00036
00038 #endif  // Apoxi_AppRoutingTable_hpp
00039
00040
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Condition.cpp File Reference

Kernel/Condition.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Condition.hpp"
#include "System.hpp"
#include "ExecutionContext.hpp"
#include "MessageRouter.hpp"
#include "MsgTypes.hpp"

Include dependency graph for Condition.cpp:

Generated on Tue Jan 24 20:59:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Condition.hpp File Reference

Kernel/Condition.hpp File Reference

#include <Auxiliary/TriggerTimer.hpp>

Include dependency graph for Condition.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BooleanCondition
class | Condition
class | TimeoutCondition

Defines

#define | Apoxi_Condition_hpp

Define Documentation

#define Apoxi_Condition_hpp

Generated on Tue Jan 24 20:59:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Condition.hpp Source File

Kernel/Condition.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Condition_hpp)
00011 #define Apoxi_Condition_hpp
00014
00015 #include <Auxiliary/TriggerTimer.hpp>
00016
00017 class ExecutionContext;
00018
00019
00022 class Condition {
00023     public:
00024         Condition();
00025         virtual ~Condition();
00026
00028         virtual BOOLEAN IsTrue() const = 0;
00029 };
00030
00034 class BooleanCondition : public Condition {
00035     typedef Condition Base;
00036
00037     public:
00039         BooleanCondition();
00040
00042         virtual ~BooleanCondition();
00043
00045         void Init();
00046
00049         void SetTrue();
00050
00052         virtual BOOLEAN IsTrue() const;
00053
00054     private:
00055         BOOLEAN m_is_true;
00056         ExecutionContext* m_context;
00057
00058         static void SetTrueCallback(void* arg);
00059 };
00060
00062 class TimeoutCondition : public BooleanCondition {
00063     typedef BooleanCondition Base;
00064
00065     public:
00067         TimeoutCondition();
00069         TimeoutCondition(UINT32 timeout);
00070
00072         virtual ~TimeoutCondition();
00073
00075         void Init(UINT32 timeout);
00076
00078         BOOLEAN IsTimerExpired() const { return m_timer_expired; }
00079
00080     private:
00081         friend class TriggerTimer<TimeoutCondition>;
00082
00083         BOOLEAN m_timer_expired;
00084         TriggerTimer<TimeoutCondition> m_timer;
00085
00086         virtual void OnTimer();
00087 };
00088
00090 #endif  // Apoxi_Condition_hpp
00091
00092
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/DbgTimingMeasurement.cpp File Reference

Kernel/DbgTimingMeasurement.cpp File Reference

Generated on Tue Jan 24 20:59:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/DbgTimingMeasurement.hpp File Reference

Kernel/DbgTimingMeasurement.hpp File Reference

Go to the source code of this file.

Data Structures

class DbgTimingMeasurement

Generated on Tue Jan 24 20:59:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/DbgTimingMeasurement.hpp Source File

Kernel/DbgTimingMeasurement.hpp

Go to the documentation of this file.
00001 #if defined(APOXI_ENABLE_TIMING_MEASUREMENTS)
00002
00013 class DbgTimingMeasurement {
00014     public:
00017         DbgTimingMeasurement(const CHAR *context) {
00018             m_context = context;
00019             ticks = Os::GetTicks();
00020             // TODO: DBG_OUT has to be replaced with Apoxi trace classes
00021             DBG_OUT((10110, "TimingMeasurement start: %s\n", m_context));
00022         }
00023
00024         ~DbgTimingMeasurement() {
00025             Stop();
00026         }
00027
00029         void Stop() {
00030             if (m_context != 0) {
00031                 // TODO: DBG_OUT has to be replaced with Apoxi trace classes
00032                 DBG_OUT((10110, "TimingMeasurement stop: %s\n. Expired time: %d ms", m_context, ticks.GetExpiredTime()));
00033                 m_context = 0;
00034             }
00035         }
00036
00037     protected:
00038         const CHAR *m_context;
00039         Ticks ticks;
00040 };
00041
00042 #else
00043
00044 class DbgTimingMeasurement {
00045     public:
00046         DbgTimingMeasurement(const CHAR *) { }
00047         void Stop() { }
00048 };
00049
00050 #endif
00051
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Dispatcher.cpp File Reference

Kernel/Dispatcher.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Dispatcher.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for Dispatcher.cpp:

Generated on Tue Jan 24 20:59:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Dispatcher.hpp File Reference

Kernel/Dispatcher.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for Dispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Dispatcher

Defines

#define | Apoxi_Dispatcher_hpp

Define Documentation

#define Apoxi_Dispatcher_hpp

Generated on Tue Jan 24 21:00:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Dispatcher.hpp Source File

Kernel/Dispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Dispatcher_hpp)
00010 #define Apoxi_Dispatcher_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 class Message;
00017
00023 class Dispatcher {
00024     public:
00026         Dispatcher();
00027
00029         virtual ~Dispatcher();
00030
00036         void SendSelf(const Message& msg) {
00037             RouteMessage(msg);
00038         }
00039
00040     protected:
00047         virtual BOOLEAN RouteMessage(const Message& msg);
00048
00052         virtual BOOLEAN OnMessage(const Message& msg) = 0;
00053
00054     private:
00056         Dispatcher(const Dispatcher& dispatcher);
00057
00059         Dispatcher& operator=(const Dispatcher& dispatcher);
00060 };
00061
00063 #endif  // Apoxi_Dispatcher_hpp
00064
00065
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/DispatcherAction.hpp File Reference

Kernel/DispatcherAction.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/LinkedList.hpp>

Include dependency graph for DispatcherAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DispatcherAction

Defines

#define | Apoxi_DispatcherAction_hpp

Typedefs

typedef LinkedList< DispatcherAction > | DispatcherActionList

Define Documentation

#define Apoxi_DispatcherAction_hpp

Generated on Tue Jan 24 21:01:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/DispatcherAction.hpp Source File

Kernel/DispatcherAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_DispatcherAction_hpp)
00010 #define Apoxi_DispatcherAction_hpp
00013
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/LinkedList.hpp>
00016
00017 class Dispatcher;
00018 class Action;
00019
00020 class DispatcherAction : public Linkable<DispatcherAction> {
00021     public:
00022         DispatcherAction(const Dispatcher& dispatcher, Action* action)
00023             : m_dispatcher(dispatcher), m_action(action) {}
00024
00025         Action* GetAction() const { return (m_action); };
00026         const Dispatcher& GetDispatcher() const { return (m_dispatcher); }
00027
00028     private:
00029         const Dispatcher& m_dispatcher;
00030         Action* m_action;
00031 };
00032
00033 typedef LinkedList<DispatcherAction> DispatcherActionList;
00034
00036 #endif  // Apoxi_DispatcherAction_hpp
00037
00038
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ExecutionContext.cpp File Reference

Kernel/ExecutionContext.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "ExecutionContext.hpp"
#include "System.hpp"
#include "UserDispatcher.hpp"
#include "ApoxiThread.hpp"
#include "MsgTypes.hpp"
#include <AddOns/Services/Service.hpp>

Include dependency graph for ExecutionContext.cpp:

Generated on Tue Jan 24 21:01:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ExecutionContext.hpp File Reference

Kernel/ExecutionContext.hpp File Reference

#include <Kernel/MsgCategory.hpp>

Include dependency graph for ExecutionContext.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ExecutionContext

Defines

#define | Apoxi_ExecutionContext_hpp

Define Documentation

#define Apoxi_ExecutionContext_hpp

Generated on Tue Jan 24 21:01:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ExecutionContext.hpp Source File

Kernel/ExecutionContext.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ExecutionContext_hpp)
00011 #define Apoxi_ExecutionContext_hpp
00012
00013 #include <Kernel/MsgCategory.hpp>
00014
00015 class UserDispatcher;
00016 class Condition;
00017 class MessageReferrer;
00018 class Timer;
00019 class Guid;
00020
00028 class ExecutionContext {
00029     public:
00032         enum Type {
00033             APPLICATION,
00034             SERVICE_THREAD
00035         };
00036
00037         ExecutionContext();
00038         virtual ~ExecutionContext();
00039
00041         virtual Type GetType() const = 0;
00042
00046         virtual const Guid& GetGuid() const;
00047
00050         void AddDispatcher(UserDispatcher* disp);
00051
00054         void RemoveDispatcher(UserDispatcher* disp);
00055
00057         BOOLEAN ContainsDispatcher(const UserDispatcher* disp) const;
00058
00061         virtual void RegisterMessage(MsgId msg_id) = 0;
00062
00065         virtual void UnregisterMessage(MsgId msg_id) = 0;
00066
00072         static ExecutionContext& GetCurrentContext();
00073
00077         static BOOLEAN IsInContext(const ExecutionContext* context = 0);
00078
00082         static void Wait(const Condition& cond) { GetCurrentContext().DoWait(cond); }
00083
00084     protected:
00086         virtual BOOLEAN AcceptMsg(const Message& msg) = 0;
00087
00089         virtual BOOLEAN HandleMsg(const MessageReferrer& msg_ref) = 0;
00090
00092         virtual void AddTimer(Timer& timer) = 0;
00093
00095         virtual void RemoveTimer(Timer& timer) = 0;
00096
00097         BOOLEAN HandleDispatcherList(const Message& msg);
00098
00099     private:
00100         friend class MessageRouter;
00101         friend class Timer;
00102
00103         UserDispatcher* m_first_disp;
00104
00105         virtual void DoWait(const Condition& cond) = 0;
00106 };
00107
00108 #endif  // Apoxi_ExecutionContext_hpp
00109
00110
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ExternalCommunicationHandler.cpp File Reference

Kernel/ExternalCommunicationHandler.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "ExternalCommunicationHandler.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for ExternalCommunicationHandler.cpp:

Generated on Tue Jan 24 21:01:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ExternalCommunicationHandler.hpp File Reference

Kernel/ExternalCommunicationHandler.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>

Include dependency graph for ExternalCommunicationHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class ExternalCommunicationHandler

Generated on Tue Jan 24 21:01:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ExternalCommunicationHandler.hpp Source File

Kernel/ExternalCommunicationHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifndef Apoxi_ExternalCommunicationHandler_hpp
00010 #define Apoxi_ExternalCommunicationHandler_hpp
00011
00012 #include <Auxiliary/NonCloneable.hpp>
00013
00014 class MessageReferrer;
00015 class AbstractExternalData;
00016
00018 class ExternalCommunicationHandler : public NonCloneable {
00019     public:
00021         enum HandlerType {
00023             SignalHandlerType,
00025             AtHandlerType,
00027             InvalidHandlerType
00028         };
00029
00031         ExternalCommunicationHandler();
00033         virtual ~ExternalCommunicationHandler();
00034
00036         virtual void Init(const AbstractExternalData* external_data = 0);
00037
00040         virtual void RouteData(const AbstractExternalData& external_data);
00041
00044         virtual void PostMessage(const MessageReferrer& msg_ref);
00045
00046
00048         virtual HandlerType GetHandlerType() const = 0;
00049
00050 }; //class Handler
00051
00052 #endif  // Apoxi_ExternalCommunicationHandler_hpp
00053
00054
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/FunctionTracer.hpp File Reference

Kernel/FunctionTracer.hpp File Reference

#include <Auxiliary/WStrUtil.hpp>

Include dependency graph for FunctionTracer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | _FunctionTracer< mask >
class | _NullFunctionTracer

Defines

#define | FUNCTION_TRACER_HPP

Functions

size_t | strlen (const char *string)
template<class T>
void | TraceDataHelper (InternalTracer::TraceMask mask, const void *linkreg, T *obj)

Define Documentation

#define FUNCTION_TRACER_HPP

Generated on Tue Jan 24 21:01:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/FunctionTracer.hpp Source File

Kernel/FunctionTracer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(FUNCTION_TRACER_HPP)
00011 #define FUNCTION_TRACER_HPP
00014
00015 #include <Auxiliary/WStrUtil.hpp>
00016
00017 #if (__ARMCC_VERSION>=200000)
00018     #include <string.h>
00019 #else
00020     extern "C" size_t strlen(const char *string);
00021 #endif
00022
00023 class _NullFunctionTracer {
00024     public:
00025         _NullFunctionTracer() {}
00026         _NullFunctionTracer(const void* this_ptr) {}
00027         ~_NullFunctionTracer() {}
00028         void TraceCheckPoint() {}
00029         void StackTrace() {}
00030
00031         static void TraceNew(const void* linkreg, const void* ptr, UINT16 size) {}
00032         static void TraceDelete(const void* linkreg, const void* ptr) {}
00033         static void TraceMessage(int id, const void* ptr, UINT16 size) {}
00034         static void TraceVersion(const CHAR* str) {}
00035         static void TraceWarning(const CHAR* str) {}
00036         static void TraceError(const CHAR* str) {}
00037         static void TraceObjectCreate(const void* ptr) {}
00038         static void TraceObjectDestroy(const void* ptr) {}
00039         static void TraceTestState(UINT16 testID, const CHAR* str, const void* linkreg) {}
00040
00041         template<class T>
00042         void TraceVariable(const T& obj) {}
00043 };  // _NullFunctionTracer
00044
00045
00046
00047 template<class T>
00048 void TraceDataHelper(InternalTracer::TraceMask mask, const void* linkreg, T* obj) {
00049     InternalTracer::TraceData(mask, linkreg, obj, sizeof(T));
00050 }
00051
00052
00053
00054 template<InternalTracer::TraceMask mask>
00055 class _FunctionTracer {
00056     public:
00057         _FunctionTracer() {
00058             const void* linkreg=0;
00059             #if defined(APOXI_RTOS_NUC32)
00060                 // get linkregister, contains caller address
00061                 #if (__ARMCC_VERSION<200000)
00062                     __asm
00063                     {
00064                         mov linkreg,r14
00065                     }
00066                 #else
00067                     linkreg = (const void*) __return_address();
00068                 #endif
00069             #endif
00070             InternalTracer::TraceFuncBegin(mask, linkreg, 0);
00071         }
00072
00073         _FunctionTracer(const void* this_ptr) {
00074             const void* linkreg=0;
00075             #if defined(APOXI_RTOS_NUC32)
00076                 // get linkregister, contains caller address
00077                 #if (__ARMCC_VERSION<200000)
00078                     __asm
00079                     {
00080                         mov linkreg,r14
00081                     }
00082                 #else
00083                     linkreg = (const void*) __return_address();
00084                 #endif
00085             #endif
00086             InternalTracer::TraceFuncBegin(mask, linkreg, this_ptr);
00087         }
00088
00089         ~_FunctionTracer() {
00090             const void* linkreg=0;
00091             #if defined(APOXI_RTOS_NUC32)
00092                 // get linkregister, contains caller address
00093                 #if (__ARMCC_VERSION<200000)
00094                     __asm
00095                     {
00096                         mov linkreg,r14
00097                     }
00098                 #else
00099                     linkreg = (const void*) __return_address();
00100                 #endif
00101             #endif
00102             InternalTracer::TraceFuncEnd(mask, linkreg);
00103         }
00104
00105         void TraceCheckPoint() {
00106             const void* linkreg=0;
00107             #if defined(APOXI_RTOS_NUC32)
00108                 // get linkregister, contains caller address
00109                 #if (__ARMCC_VERSION<200000)
00110                     __asm
00111                     {
00112                         mov linkreg,r14
00113                     }
00114                 #else
00115                     linkreg = (const void*) __return_address();
00116                 #endif
00117             #endif
00118             InternalTracer::TraceFuncCheckPoint(mask, linkreg);
00119         }
00120
00121         void StackTrace() {
00122             const void* linkreg=0;
00123             #if defined(APOXI_RTOS_NUC32)
00124                 // get linkregister, contains caller address
00125                 #if (__ARMCC_VERSION<200000)
00126                     __asm
00127                     {
00128                         mov linkreg,r14
00129                     }
00130                 #else
00131                     linkreg = (const void*) __return_address();
00132                 #endif
00133             #endif
00134             InternalTracer::TraceFuncStackTrace(mask, linkreg);
00135         }
00136
00137         static void TraceNew(const void* linkreg, const void* ptr, UINT16 size) {
00138             InternalTracer::TraceNew(linkreg, ptr, size);
00139         }
00140
00141         static void TraceDelete(const void* linkreg, const void* ptr) {
00142             InternalTracer::TraceDelete(linkreg, ptr);
00143         }
00144
00145         static void TraceMessage(UINT16 id, const void* ptr, UINT16 size) {
00146             const void* linkreg=0;
00147             #if defined(APOXI_RTOS_NUC32)
00148                 // get linkregister, contains caller address
00149                 #if (__ARMCC_VERSION<200000)
00150                     __asm
00151                     {
00152                         mov linkreg,r14
00153                     }
00154                 #else
00155                     linkreg = (const void*) __return_address();
00156                 #endif
00157             #endif
00158             InternalTracer::TraceMessage(linkreg, id, ptr, size);
00159         }
00160
00161         static void TraceVersion(const CHAR* str) {
00162             const void* linkreg=0;
00163             #if defined(APOXI_RTOS_NUC32)
00164                 // get linkregister, contains caller address
00165                 #if (__ARMCC_VERSION<200000)
00166                     __asm
00167                     {
00168                         mov linkreg,r14
00169                     }
00170                 #else
00171                     linkreg = (const void*) __return_address();
00172                 #endif
00173             #endif
00174             InternalTracer::TraceBuffer(linkreg, InternalTracer::Version, str, strlen(str)+1);
00175         }
00176
00177         static void TraceWarning(const CHAR* str) {
00178             const void* linkreg=0;
00179             #if defined(APOXI_RTOS_NUC32)
00180                 // get linkregister, contains caller address
00181                 #if (__ARMCC_VERSION<200000)
00182                     __asm
00183                     {
00184                         mov linkreg,r14
00185                     }
00186                 #else
00187                     linkreg = (const void*) __return_address();
00188                 #endif
00189             #endif
00190             InternalTracer::TraceBuffer(linkreg, InternalTracer::Warning, str, strlen(str)+1);
00191         }
00192
00193         static void TraceError(const CHAR* str) {
00194             const void* linkreg=0;
00195             #if defined(APOXI_RTOS_NUC32)
00196                 // get linkregister, contains caller address
00197                 #if (__ARMCC_VERSION<200000)
00198                     __asm
00199                     {
00200                         mov linkreg,r14
00201                     }
00202                 #else
00203                     linkreg = (const void*) __return_address();
00204                 #endif
00205             #endif
00206             InternalTracer::TraceBuffer(linkreg, InternalTracer::Error, str, strlen(str)+1);
00207         }
00208
00209         static void TraceObjectCreate(const void* ptr) {
00210             const void* linkreg=0;
00211             #if defined(APOXI_RTOS_NUC32)
00212                 // get linkregister, contains caller address
00213                 #if (__ARMCC_VERSION<200000)
00214                     __asm
00215                     {
00216                         mov linkreg,r14
00217                     }
00218                 #else
00219                     linkreg = (const void*) __return_address();
00220                 #endif
00221             #endif
00222             InternalTracer::TraceObj(linkreg, InternalTracer::ObjectCreate, ptr);
00223         }
00224
00225         static void TraceObjectDestroy(const void* ptr) {
00226             const void* linkreg=0;
00227             #if defined(APOXI_RTOS_NUC32)
00228                 // get linkregister, contains caller address
00229                 #if (__ARMCC_VERSION<200000)
00230                     __asm
00231                     {
00232                         mov linkreg,r14
00233                     }
00234                 #else
00235                     linkreg = (const void*) __return_address();
00236                 #endif
00237             #endif
00238             InternalTracer::TraceObj(linkreg, InternalTracer::ObjectDestroy, ptr);
00239         }
00240
00241         static void TraceTestState(UINT16 testID, const CHAR* str, const void* linkreg) {
00242             InternalTracer::TraceTestState(linkreg, testID, str, strlen(str)+1);
00243         }
00244
00245
00252         template<class T>
00253             void TraceVariable(const T& obj) {
00254                 const void* linkreg=0;
00255                 #if defined(APOXI_RTOS_NUC32)
00256                     // get linkregister, contains caller address
00257                 #if (__ARMCC_VERSION<200000)
00258                     __asm
00259                     {
00260                         mov linkreg,r14
00261                     }
00262                 #else
00263                     linkreg = (const void*) __return_address();
00264                 #endif
00265                 #endif
00266             TraceDataHelper(mask, linkreg, &obj);
00267         }
00268
00269
00273         void TraceVariable(const long& val) {
00274             const void* linkreg=0;
00275             #if defined(APOXI_RTOS_NUC32)
00276                 // get linkregister, contains caller address
00277                 #if (__ARMCC_VERSION<200000)
00278                     __asm
00279                     {
00280                         mov linkreg,r14
00281                     }
00282                 #else
00283                     linkreg = (const void*) __return_address();
00284                 #endif
00285             #endif
00286             InternalTracer::TraceData(mask, linkreg, InternalTracer::Long, &val, sizeof(long));
00287         }
00288
00289         void TraceVariable(const unsigned long& val) {
00290             const void* linkreg=0;
00291             #if defined(APOXI_RTOS_NUC32)
00292                 // get linkregister, contains caller address
00293                 #if (__ARMCC_VERSION<200000)
00294                     __asm
00295                     {
00296                         mov linkreg,r14
00297                     }
00298                 #else
00299                     linkreg = (const void*) __return_address();
00300                 #endif
00301             #endif
00302             InternalTracer::TraceData(mask, linkreg, InternalTracer::ULong, &val, sizeof(unsigned long));
00303         }
00304
00305         void TraceVariable(const int& val) {
00306             const void* linkreg=0;
00307             #if defined(APOXI_RTOS_NUC32)
00308                 // get linkregister, contains caller address
00309                 #if (__ARMCC_VERSION<200000)
00310                     __asm
00311                     {
00312                         mov linkreg,r14
00313                     }
00314                 #else
00315                     linkreg = (const void*) __return_address();
00316                 #endif
00317             #endif
00318             InternalTracer::TraceData(mask, linkreg, InternalTracer::Int, &val, sizeof(int));
00319         }
00320
00321         void TraceVariable(const unsigned int& val) {
00322             const void* linkreg=0;
00323             #if defined(APOXI_RTOS_NUC32)
00324                 // get linkregister, contains caller address
00325                 #if (__ARMCC_VERSION<200000)
00326                     __asm
00327                     {
00328                         mov linkreg,r14
00329                     }
00330                 #else
00331                     linkreg = (const void*) __return_address();
00332                 #endif
00333             #endif
00334             InternalTracer::TraceData(mask, linkreg, InternalTracer::UInt, &val, sizeof(unsigned int));
00335         }
00336
00337         void TraceVariable(const short& val) {
00338             const void* linkreg=0;
00339             #if defined(APOXI_RTOS_NUC32)
00340                 // get linkregister, contains caller address
00341                 #if (__ARMCC_VERSION<200000)
00342                     __asm
00343                     {
00344                         mov linkreg,r14
00345                     }
00346                 #else
00347                     linkreg = (const void*) __return_address();
00348                 #endif
00349             #endif
00350             InternalTracer::TraceData(mask, linkreg, InternalTracer::Short, &val, sizeof(short));
00351         }
00352
00353         void TraceVariable(const unsigned short& val) {
00354             const void* linkreg=0;
00355             #if defined(APOXI_RTOS_NUC32)
00356                 // get linkregister, contains caller address
00357                 #if (__ARMCC_VERSION<200000)
00358                     __asm
00359                     {
00360                         mov linkreg,r14
00361                     }
00362                 #else
00363                     linkreg = (const void*) __return_address();
00364                 #endif
00365             #endif
00366             InternalTracer::TraceData(mask, linkreg, InternalTracer::UShort, &val, sizeof(unsigned short));
00367         }
00368
00369         void TraceVariable(const char& val) {
00370             const void* linkreg=0;
00371             #if defined(APOXI_RTOS_NUC32)
00372                 // get linkregister, contains caller address
00373                 #if (__ARMCC_VERSION<200000)
00374                     __asm
00375                     {
00376                         mov linkreg,r14
00377                     }
00378                 #else
00379                     linkreg = (const void*) __return_address();
00380                 #endif
00381             #endif
00382             InternalTracer::TraceData(mask, linkreg, InternalTracer::Char, &val, sizeof(char));
00383         }
00384
00385         void TraceVariable(const unsigned char& val) {
00386             const void* linkreg=0;
00387             #if defined(APOXI_RTOS_NUC32)
00388                 // get linkregister, contains caller address
00389                 #if (__ARMCC_VERSION<200000)
00390                     __asm
00391                     {
00392                         mov linkreg,r14
00393                     }
00394                 #else
00395                     linkreg = (const void*) __return_address();
00396                 #endif
00397             #endif
00398             InternalTracer::TraceData(mask, linkreg, InternalTracer::UChar, &val, sizeof(unsigned char));
00399         }
00400
00401         void TraceVariable(const char* str) {
00402             const void* linkreg=0;
00403             #if defined(APOXI_RTOS_NUC32)
00404                 // get linkregister, contains caller address
00405                 #if (__ARMCC_VERSION<200000)
00406                     __asm
00407                     {
00408                         mov linkreg,r14
00409                     }
00410                 #else
00411                     linkreg = (const void*) __return_address();
00412                 #endif
00413             #endif
00414             InternalTracer::TraceData(mask, linkreg, InternalTracer::String, str, strlen(str)+1);
00415         }
00416
00417         void TraceVariable(const WCHAR* str) {
00418             const void* linkreg=0;
00419             #if defined(APOXI_RTOS_NUC32)
00420                 // get linkregister, contains caller address
00421                 #if (__ARMCC_VERSION<200000)
00422                     __asm
00423                     {
00424                         mov linkreg,r14
00425                     }
00426                 #else
00427                     linkreg = (const void*) __return_address();
00428                 #endif
00429             #endif
00430             InternalTracer::TraceData(mask, linkreg, InternalTracer::WString, (char*)str, WStrLen(str)*2+2);
00431         }
00432
00433 };  // _FunctionTracer
00434
00436 #endif // FUNCTION_TRACER_HPP
00437
00438
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/GenericWorkerTask.cpp File Reference

Kernel/GenericWorkerTask.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "GenericWorkerTask.hpp"
#include "Threadlet.hpp"
#include "Os/Mutex.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for GenericWorkerTask.cpp:

Generated on Tue Jan 24 21:01:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/GenericWorkerTask.hpp File Reference

Kernel/GenericWorkerTask.hpp File Reference

#include <Kernel/SubSystem.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for GenericWorkerTask.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GenericWorkerTask
class | GenericWorkerTask::WorkerTaskObtainer

Defines

#define | Apoxi_GenericWorkerTask_hpp

Define Documentation

#define Apoxi_GenericWorkerTask_hpp

Generated on Tue Jan 24 21:01:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/GenericWorkerTask.hpp Source File

Kernel/GenericWorkerTask.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_GenericWorkerTask_hpp)
00011 #define Apoxi_GenericWorkerTask_hpp
00014
00015 #include <Kernel/SubSystem.hpp>
00016 #include <Kernel/Os/Os.hpp>
00017 #include <Kernel/Os/MutexObtainer.hpp>
00018
00019 class Threadlet;
00020
00028 class GenericWorkerTask : public SubSystem, public Thread {
00029     public:
00031         virtual ~GenericWorkerTask();
00032
00034         static GenericWorkerTask& GetInstance() { return m_generic_worker_task; }
00035
00037         virtual const WCHAR* GetName() const;
00038
00040         virtual void OnPowerUp();
00041
00043         virtual void OnPowerDown();
00044
00046         virtual BootSequenceState InvokeAt() const;
00047
00049         virtual INT ThreadFn();
00050
00053         BOOLEAN IsBusy() const;
00054
00055     private:
00056         class WorkerTaskObtainer : public MutexObtainer {
00057             typedef MutexObtainer Base;
00058
00059             public:
00060                 WorkerTaskObtainer();
00061         };
00062
00063         friend class WorkerTaskObtainer;
00064         friend class Threadlet;
00065         friend class Os;
00066
00067         static BOOLEAN m_running;
00068         static LinkedList<Threadlet> m_queue;
00069         static Semaphore m_sem;
00070         static Mutex m_queue_mutex;
00071         static GenericWorkerTask m_generic_worker_task;
00072
00073         GenericWorkerTask();
00074
00075         static void AddThreadlet(Threadlet* threadlet);
00076         static Threadlet* GetThreadlet();
00077         static void RemoveThreadlet();
00078 };
00079
00081 #endif  // Apoxi_GenericWorkerTask_hpp
00082
00083
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HeapManager.cpp File Reference

Kernel/HeapManager.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "HeapManager.hpp"
#include <Config/MemoryConfig.hpp>
#include "Os/Os.hpp"
#include <Auxiliary/Macros.hpp>
#include <stack/stack.h>
#include <Kernel/System.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/ServiceThread.hpp>
#include <Kernel/Os/SimpleSemaphore.hpp>
#include <stdlib.h>
#include <time.h>

Include dependency graph for HeapManager.cpp:

Defines

#define | APOXI_HEAP_TEST

Functions

void | BlockPageTest ()
void | HugeVarPageTest ()
void | RandomHugeFragVarPageTest ()
void | RandomHugeVarPageTest ()
void | RandomVarPageTest ()
void | TestHeaps ()
void | UnlockedDbgOut ()
void | VarPageTest ()

Variables

const INT | c_heapid = 8888
const INT | c_max_mem_ptr = 4*1024

Define Documentation

#define APOXI_HEAP_TEST

Function Documentation

void BlockPageTest ( )

void HugeVarPageTest ( )

void RandomHugeFragVarPageTest ( )

void RandomHugeVarPageTest ( )

void RandomVarPageTest ( )

void UnlockedDbgOut ( )

void VarPageTest ( )

Variable Documentation

const INT c_heapid = 8888

const INT c_max_mem_ptr = 4*1024

Generated on Tue Jan 24 21:01:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HeapManager.hpp File Reference

Kernel/HeapManager.hpp File Reference

#include <Kernel/HeapVector.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for HeapManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HeapManager

Defines

#define | Apoxi_HeapManager_hpp

Functions

void | TestHeaps ()

Define Documentation

#define Apoxi_HeapManager_hpp

Generated on Tue Jan 24 21:01:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HeapManager.hpp Source File

Kernel/HeapManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_HeapManager_hpp)
00010 #define Apoxi_HeapManager_hpp
00013
00014 #include <Kernel/HeapVector.hpp>
00015 #include <Auxiliary/Macros.hpp>
00016
00017
00066 class HeapManager
00067 {
00068     friend class HeapVector;
00069
00070 #if defined(APOXI_HEAP_MEM_ALLOCS_PER_SIZE)
00071
00072     public:
00073         struct HeapLogStruct {
00074             UINT32 m_size;
00075             UINT32 m_allocations;
00076             UINT32 m_frees;
00077             UINT16 m_current;
00078             UINT16 m_peek;
00079         };
00080
00081         enum {
00082             c_max_indexed_size = 16384 / sizeof(HeapLogStruct)
00083         };
00084
00085         enum HeapPageType {
00086             HeapUndefinedPage = 0,
00087             HeapBlockPage = 1,
00088             HeapVarPage   = 2,
00089             HeapHugePage  = 3
00090         };
00091
00092         struct HeapLogGenerateStruct {
00093             UINT32       m_size;
00094             UINT32       m_low;
00095             UINT32       m_high;
00096             UINT32       m_blocksize;
00097             HeapPageType m_pagetype;
00098         };
00099
00100         enum {
00101             c_max_gen_page_no = 200
00102         };
00103
00104 #endif
00105
00106 #if defined(APOXI_HEAP_MEM_CONTEXT_TRACE)
00107     #if ! defined(APOXI_HEAP_MEM_CONTEXT_TRACE_MAX_CTX)
00108         #define APOXI_HEAP_MEM_CONTEXT_TRACE_MAX_CTX 50
00109     #endif
00110         enum {
00111             c_max_context_no = APOXI_HEAP_MEM_CONTEXT_TRACE_MAX_CTX,
00112             c_max_context_name_len = 32
00113         };
00114
00115         struct HeapContextStruct {
00116             UINT32      m_context_identifier;
00117             CHAR        m_name[c_max_context_name_len];
00118             UINT32      m_allocations;
00119             UINT32      m_frees;
00120             UINT32      m_frees_by_other_context;
00121             UINT32      m_mem_allocated;
00122             UINT32      m_mem_used;
00123             UINT32      m_peak_allocated;
00124             UINT32      m_peak_used;
00125         };
00126 #endif
00127
00128
00129     public:
00130         HeapManager();
00131         static void* Allocate(size_t nrofbytes, UINT heapid = 0);
00132         static void* ReAllocate(void*  oldaddress, size_t newsize, BOOLEAN shallcopy);
00133         static void Free(void*  address, UINT virtid = ~0);
00134
00135         static void HUGE*  HugeAllocate(UINT32 nrofbytes, UINT heapid = 0);
00136         static void HUGE*  HugeReAllocate(void HUGE*  oldaddress, UINT32 newsize, BOOLEAN shallcopy);
00137         static void HugeFree(void HUGE* address, UINT virtid = ~0);
00138
00139         static void OverallOverwriteCheck();
00140
00141         static BOOLEAN IsValidAddress(void * address);
00142         static BOOLEAN IsValidHugeAddress(void HUGE* address);
00143
00144         static void DbgOut();
00145         static void Initialize();
00146         static BOOLEAN GetOverallMemUsage(UINT32 & totalram, UINT32 & currentram, UINT32 & peakram);
00147         static HeapVector::Page * GetFirstPageEntry();
00148         static HeapVector::Page * GetNextPageEntry();
00149
00150         static BOOLEAN DumpMemoryConsumptionSnapshot();
00151         static BOOLEAN GenerateMemoryConfig(UINT32 safetypercent = 50);
00152
00153 #if defined(APOXI_HEAP_MEM_ALLOCS_PER_SIZE)
00154         static void RecordAllocation(UINT32 size);
00155         static void RecordFree(UINT32 size);
00156         static void RecordHugeAllocation(UINT32 size);
00157         static void RecordHugeFree(UINT32 size);
00158 #endif
00159
00160 #if defined(APOXI_HEAP_MEM_ACCESS_API)
00161         static HeapVector::HeapTableEntry * GetFirstHeapEntry();
00162         static HeapVector::HeapTableEntry * GetNextHeapEntry();
00163         static HeapVector::Page * GetFirstHeapPageEntry(HeapVector::HeapTableEntry * heap);
00164         static HeapVector::Page * GetNextHeapPageEntry();
00165
00166         static HeapManager::HeapLogStruct * GetFirstHeapLogStruct(BOOLEAN & ishuge);
00167         static HeapManager::HeapLogStruct * GetNextHeapLogStruct(BOOLEAN & ishuge);
00168
00169         static HeapManager::HeapContextStruct * GetFirstHeapContextStruct();
00170         static HeapManager::HeapContextStruct * GetNextHeapContextStruct();
00171 #endif
00172
00173 #if defined(APOXI_HEAP_MEM_CONTEXT_TRACE)
00174         static UINT32 GetCurrentContext();
00175         static HeapVector::ContextId GetCurrentContextId();
00176         static CHAR * GetCurrentContextName();
00177
00178         static HeapVector::ContextId RecordContextAllocation(UINT32 nrofbytes, UINT32 allocated);
00179         static void RecordContextFree(UINT32 nrofbytes, UINT32 allocated, HeapVector::ContextId id);
00180         static HeapContextStruct * GetHeapContextStruct(INT idx) {
00181             ASSERT_DEBUG(idx<c_max_context_no);
00182             return &m_contexts[idx];
00183         }
00184 #endif
00185         static BOOLEAN DumpMemoryContextSnapshot();
00186         static BOOLEAN EnablePeakMemoryContextOutput(BOOLEAN enable = TRUE);
00187         static void DbgOutContextUsage();
00188
00189     private:
00190         static BOOLEAN m_initialized;
00191         static HeapVector::HeapTableEntry * m_iterator_heap;
00192         static HeapVector::Page ** m_iterator_page;
00193
00194 #if defined(APOXI_HEAP_MEM_DETECT_CONFIG)
00195         static void AddGeneratedPage(UINT32 size, UINT32 low, UINT32 high, UINT32 blocksize,
00196                                      HeapPageType pagetype);
00197         static BOOLEAN GenerateBlockPages(BOOLEAN shall16k, UINT32 safetypercent,
00198                                           UINT32 low, UINT32 high, UINT32 prefpagesize);
00199         static BOOLEAN GenerateFixVarPages(BOOLEAN shall16k, UINT32 safetypercent,
00200                                            UINT32 low, UINT32 high, UINT32 blocksize);
00201         static BOOLEAN GenerateDynVarPages(HeapLogStruct * var, BOOLEAN shall16k, UINT32 safetypercent,
00202                                            UINT32 low, UINT32 high, UINT32 blocksize, HeapPageType type);
00203         static BOOLEAN DumpMemoryConfig();
00204 #endif
00205
00206 #if defined(APOXI_HEAP_MEM_ALLOCS_PER_SIZE)
00207         static INT AddVarRecord(HeapLogStruct * var, UINT32 size);
00208         static INT LookupRecord(HeapLogStruct * var, UINT32 size);
00209         static BOOLEAN ConsistencyCheck();
00210
00211         static HeapLogStruct m_fix[c_max_indexed_size];
00212         static HeapLogStruct m_var[c_max_indexed_size];
00213         static HeapLogStruct m_huge[c_max_indexed_size];
00214         static HeapLogGenerateStruct m_genpage[c_max_gen_page_no];
00215         static UINT m_size_iterator_idx;
00216 #endif
00217
00218 #if defined(APOXI_HEAP_MEM_CONTEXT_TRACE)
00219         static HeapContextStruct m_contexts[c_max_context_no];
00220         static INT m_current_context_no;
00221         static BOOLEAN m_peak_value_trace_enabled;
00222         static UINT m_ctx_iterator_idx;
00223 #endif
00224
00225
00226 };
00227
00228 void TestHeaps();
00229
00231 #endif
00232
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HeapVector.cpp File Reference

Kernel/HeapVector.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "HeapVector.hpp"
#include "HeapManager.hpp"
#include <Auxiliary/Macros.hpp>
#include <string.h>

Include dependency graph for HeapVector.cpp:

Defines

#define | BLOCKS_PER_LINE_TRACE 32

Functions

BOOLEAN | CheckComputeUsage (UINT *bitvector, UINT &idx)
UINT | DetectShiftValue (UINT blocksize)
UINT16 | GetBlockCount (UINT16 value)
BOOLEAN | IsFree (UINT16 value)
BOOLEAN | IsUnused (UINT *bitvector, UINT idx)
UINT16 | MakeFree (UINT16 value)
UINT16 | MakeOccupied (UINT16 value)
void | SetUnused (UINT *bitvector, UINT idx)
void | SetUsed (UINT *bitvector, UINT idx)

Variables

const HeapVector::FctTable | g_fcts_block_page
const HeapVector::FctTable | g_fcts_huge_page
const HeapVector::FctTable | g_fcts_var_page

Define Documentation

#define BLOCKS_PER_LINE_TRACE 32

Function Documentation

BOOLEAN CheckComputeUsage | ( | UINT * | bitvector,
 |  | UINT & | idx
 | ) | [inline]

UINT DetectShiftValue ( UINT blocksize )

UINT16 GetBlockCount ( UINT16 value ) [inline]

BOOLEAN IsFree ( UINT16 value ) [inline]

BOOLEAN IsUnused | ( | UINT * | bitvector,
 |  | UINT | idx
 | ) | [inline]

UINT16 MakeFree ( UINT16 value ) [inline]

UINT16 MakeOccupied ( UINT16 value ) [inline]

void SetUnused | ( | UINT * | bitvector,
 |  | UINT | idx
 | ) | [inline]

void SetUsed | ( | UINT * | bitvector,
 |  | UINT | idx
 | ) | [inline]

Generated on Tue Jan 24 21:01:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HeapVector.hpp File Reference

Kernel/HeapVector.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for HeapVector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | HeapVector
struct | HeapVector::BlockPage
struct | HeapVector::FctTable
struct | HeapVector::HeapTableEntry
struct | HeapVector::Page
struct | HeapVector::Stats
struct | HeapVector::VarPage

Defines

#define | APOXI_HEAP_LENGTH_VECTOR
#define | APOXI_HEAP_MEM_ACCESS_CHECK
#define | APOXI_HEAP_MEM_ALLOCS_PER_SIZE
#define | APOXI_HEAP_MEM_DETECT_CONFIG
#define | APOXI_HEAP_NAME(name)
#define | APOXI_HEAP_NAME_PTR(name)
#define | Apoxi_HeapVector_hpp
#define | BLOCK_HEAP_CONTEXT_VECTOR(name, size, high)
#define | BLOCK_HEAP_PAGE(name, size, low, high)
#define | BLOCK_HEAP_SIZE_VECTOR(name, size, high) static UINT16 m_size_vector_##name[(size / high)+1];
#define | GET_HEAP_TABLE() & m_heap_table[0];
#define | HEAP_BYTES_PER_UINT sizeof(UINT)
#define | HEAP_CONTEXT_VECTOR_PTR(name)
#define | HEAP_ENTRY(heapname, id)
#define | HEAP_SIZE_VECTOR_PTR(name) m_size_vector_##name,
#define | HEAP_STAT_STRUCT_VALUES
#define | HEAP_TABLE_BEGIN() static HeapVector::HeapTableEntry m_heap_table[] = {
#define | HEAP_TABLE_END { 0, 0 } };
#define | HUGE_HEAP_PAGE(name, size, blocksize, low, high)
#define | NO_CHECK_BYTES 4
#define | PAGE_ENTRY(name) (HeapVector::Page*)& name,
#define | PAGE_TABLE_BEGIN(heapname) static HeapVector::Page * m_pages_##heapname[] = {
#define | PAGE_TABLE_END 0 };
#define | VAR_HEAP_CONTEXT_VECTOR(name, size, blocksize)
#define | VAR_HEAP_PAGE(name, size, blocksize, low, high)
#define | VAR_HEAP_SIZE_VECTOR(name, size, blocksize) static UINT32 m_size_vector_##name[(size / blocksize)+1];
#define | VIRTUAL_HEAP_ENTRY(heapname, id, virtid, size)

Variables

const HeapVector::ContextId | c_invalid_context_id = ~0
const HeapVector::FctTable | g_fcts_block_page
const HeapVector::FctTable | g_fcts_huge_page
const HeapVector::FctTable | g_fcts_var_page

Define Documentation

#define Apoxi_HeapVector_hpp

Generated on Tue Jan 24 21:01:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HeapVector.hpp Source File

Kernel/HeapVector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_HeapVector_hpp)
00010 #define Apoxi_HeapVector_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #if ! defined(APOXI_HEAP_MEM_ACCESS_CHECK)
00018         #define APOXI_HEAP_MEM_ACCESS_CHECK
00019     #endif
00020     #if ! defined(APOXI_HEAP_MEM_DETECT_CONFIG)
00021         #define APOXI_HEAP_MEM_DETECT_CONFIG
00022     #endif
00023 #endif
00024
00025 #if defined(APOXI_HEAP_MEM_ACCESS_API)
00026     #if ! defined(APOXI_HEAP_MEM_CONTEXT_TRACE)
00027         #define APOXI_HEAP_MEM_CONTEXT_TRACE
00028     #endif
00029     #if ! defined(APOXI_HEAP_MEM_POOL_TRACE)
00030         #define APOXI_HEAP_MEM_POOL_TRACE
00031     #endif
00032 #endif
00033
00034 //
00035 #if defined(APOXI_HEAP_MEM_DETECT_CONFIG) || defined(APOXI_HEAP_MEM_ACCESS_API)
00036     #if ! defined(APOXI_HEAP_MEM_ALLOCS_PER_SIZE)
00037         #define APOXI_HEAP_MEM_ALLOCS_PER_SIZE
00038     #endif
00039 #endif
00040
00041 // this check defines if the length vector shall be used
00042 #if defined(APOXI_HEAP_MEM_ACCESS_CHECK) || defined(APOXI_HEAP_MEM_DETECT_CONFIG)
00043     #if ! defined(APOXI_HEAP_LENGTH_VECTOR)
00044         #define APOXI_HEAP_LENGTH_VECTOR
00045     #endif
00046 #endif
00047
00048 // this check defines if the caller id and length id shall be used inside
00049 #if defined(APOXI_HEAP_MEM_CONTEXT_TRACE)
00050     #if ! defined(APOXI_HEAP_MEM_POOL_TRACE)
00051         #define APOXI_HEAP_MEM_POOL_TRACE
00052     #endif
00053     #if ! defined(APOXI_HEAP_CONTEXT_USAGE)
00054         #define APOXI_HEAP_CONTEXT_USAGE
00055     #endif
00056     #if ! defined(APOXI_HEAP_LENGTH_VECTOR)
00057         #define APOXI_HEAP_LENGTH_VECTOR
00058     #endif
00059 #endif
00060
00061 // this check defines if the pool name shall be created inside memory config
00062 #if defined(APOXI_HEAP_MEM_ALLOC_TRACE) || defined(APOXI_HEAP_MEM_POOL_TRACE)
00063     #if ! defined(APOXI_HEAP_NAME_USAGE)
00064         #define APOXI_HEAP_NAME_USAGE
00065     #endif
00066 #endif
00067
00068 // this check defines if the statistics struct shall be created inside memory config
00069 #if defined(APOXI_HEAP_MEM_POOL_TRACE)
00070     #if ! defined(APOXI_HEAP_STATS_USAGE)
00071         #define APOXI_HEAP_STATS_USAGE
00072     #endif
00073 #endif
00074
00075
00077 class HeapVector
00078 {
00079     public:
00080         enum {
00081             BITS_PER_UINT = sizeof(UINT) * 8
00082         };
00083
00084         struct Page;
00085
00086         // statistic pages
00087         struct Stats {
00088             UINT32  m_allocations;
00089             UINT32  m_frees;
00090             UINT32  m_overflows;
00091             UINT16  m_peak;
00092             UINT16  m_current;
00093             UINT    m_overhead;
00094         };
00095
00096         // ContextId
00097         typedef UINT8 ContextId;
00098
00099         // prototypes of used functions
00100         typedef void (*InitializeFunction)(Page * page);
00101         typedef void*  (*AllocateFunction)(Page * page, size_t nrofbytes);
00102         typedef void*  (*ReAllocateFunction)(Page * page, UINT heapid, void*  oldaddress,
00103                                              size_t newsize, BOOLEAN shallcopy);
00104         typedef void (*FreeFunction)(Page * page, const void*  address);
00105         typedef void (*DbgOutFunction)(Page * page);
00106         typedef INT32 (*SizeFunction)(Page * page, const void*  address);
00107         typedef BOOLEAN (*IsFreePageFunction)(Page * page);
00108         typedef Stats * (*GetStatsFunction)(Page * page);
00109         typedef void (*OverwriteCheckFunction)(Page * page);
00110         typedef void (*DbgOutContextFunction)(Page * page);
00111
00112         // function table, one instance for each page type necessary in heapvector.cpp
00113         struct FctTable {
00114             InitializeFunction      m_init_fct;
00115             AllocateFunction        m_alloc_fct;
00116             ReAllocateFunction      m_realloc_fct;
00117             FreeFunction            m_free_fct;
00118             SizeFunction            m_size_fct;
00119             DbgOutFunction          m_dbgout_fct;
00120             IsFreePageFunction      m_isfree_fct;
00121             GetStatsFunction        m_getstats_fct;
00122             OverwriteCheckFunction  m_overwritecheck_fct;
00123             DbgOutFunction          m_dbgout_context_fct;
00124         };
00125
00126         // the blockpage type
00127         struct BlockPage
00128         {
00129             UINT8 *  m_memory;
00130             UINT *   m_bits;
00131             UINT     m_blockcounter;
00132 #if defined(APOXI_HEAP_LENGTH_VECTOR)
00133             UINT16 * m_sizevector;
00134 #endif
00135 #if defined(APOXI_HEAP_CONTEXT_USAGE)
00136             ContextId * m_contextvector;
00137 #endif
00138             BOOLEAN  m_free;
00139 #if defined(APOXI_HEAP_STATS_USAGE)
00140             Stats    m_stats;
00141 #endif
00142
00143             static void Initialize(Page * page);
00144
00145             static void*  Allocate(Page * page, size_t nrofbytes);
00146             static void*  ReAllocate(Page * page, UINT heapid, void*  oldaddress,
00147                                      size_t newsize, BOOLEAN shallcopy);
00148             static void Free(Page * page, const void*  address);
00149             static INT32 Size(Page * page, const void*  address);
00150
00151             static void DbgOut(Page * page);
00152             static BOOLEAN IsFreePage(Page * page);
00153             static Stats * GetStats(Page * page);
00154             static void OverwriteCheck(Page * page);
00155             static void DbgOutContext(Page * page);
00156         };
00157
00158         struct VarPage
00159         {
00160             UINT8 *      m_memory;
00161             UINT8 HUGE * m_base_huge;
00162             UINT8 HUGE * m_end_huge;
00163
00164             UINT16 *     m_length;
00165             UINT         m_shiftval;
00166 #if defined(APOXI_HEAP_LENGTH_VECTOR)
00167             UINT32 *     m_sizevector;
00168 #endif
00169 #if defined(APOXI_HEAP_CONTEXT_USAGE)
00170             ContextId * m_contextvector;
00171 #endif
00172             BOOLEAN      m_free;
00173 #if defined(APOXI_HEAP_STATS_USAGE)
00174             Stats        m_stats;
00175 #endif
00176
00177
00178             static void Initialize(Page * page);
00179
00180             static void * Allocate(Page * page, size_t nrofbytes);
00181             static void * ReAllocate(Page * page, UINT heapid, void*  oldaddress,
00182                                      size_t newsize, BOOLEAN shallcopy);
00183             static void Free(Page * page, const void*  address);
00184             static INT32 Size(Page * page, const void*  address);
00185
00186             static void HUGE*  HugeAllocate(Page * page, UINT32 nrofbytes);
00187             static void HUGE*  HugeReAllocate(Page * page, UINT heapid, void HUGE*  oldaddress,
00188                                               UINT32 newsize, BOOLEAN shallcopy);
00189
00190             static void HugeFree(Page * page, const void HUGE*  address);
00191
00192             static void DbgOut(Page * page);
00193             static BOOLEAN IsFreePage(Page * page);
00194             static Stats * GetStats(Page * page);
00195             static void OverwriteCheck(Page * page);
00196             static void DbgOutContext(Page * page);
00197
00198             static UINT16 GetBlockNo(Page * vpage, UINT32 nrofbytes, UINT cnt = 0);
00199             static void SubFree(Page * page, UINT32 address, UINT blockno);
00200
00201         };
00202
00203         // the root page which contains the description of a page
00204         struct Page {
00205             BOOLEAN      m_ishuge;
00206 #if defined(APOXI_HEAP_NAME_USAGE)
00207             CHAR *       m_name;
00208 #endif
00209             UINT         m_blocksize;
00210             UINT16       m_low;
00211             UINT32       m_high;
00212             UINT8 *      m_base;
00213             UINT8 *      m_end;
00214             UINT           m_N;
00215             const FctTable *   m_fct_table;
00216             Page *       m_page;
00217         };
00218
00219         struct HeapTableEntry
00220         {
00221             Page ** m_startpage;
00222             UINT   m_heap_id;
00223             UINT   m_virtual_heap_id;
00224             UINT32 m_max_virtual_size;
00225             INT32  m_current_virtual_size;
00226             const CHAR *  m_name;
00227         };
00228
00229 };
00230
00231 // invalid context id
00232 const HeapVector::ContextId c_invalid_context_id = ~0;
00233
00234 // constant fct tables are present in Heapvector.cpp
00235 extern const HeapVector::FctTable g_fcts_block_page;
00236 extern const HeapVector::FctTable g_fcts_var_page;
00237 extern const HeapVector::FctTable g_fcts_huge_page;
00238
00239 #define HEAP_BYTES_PER_UINT sizeof(UINT)
00240
00241 // macros if statistics shall be present in memory config
00242 #if defined(APOXI_HEAP_STATS_USAGE)
00243     #define HEAP_STAT_STRUCT_VALUES ,{ 0, 0, 0, 0, 0 ,0 }
00244 #else
00245     #define HEAP_STAT_STRUCT_VALUES
00246 #endif
00247
00248 // macros if size vector shall be present in memory config
00249 #if defined(APOXI_HEAP_LENGTH_VECTOR)
00250     #define BLOCK_HEAP_SIZE_VECTOR(name, size, high)        static UINT16 m_size_vector_##name[(size / high)+1];
00251     #define VAR_HEAP_SIZE_VECTOR(name, size, blocksize)     static UINT32 m_size_vector_##name[(size / blocksize)+1];
00252     #define HEAP_SIZE_VECTOR_PTR(name)                      m_size_vector_##name,
00253 #else
00254     #define BLOCK_HEAP_SIZE_VECTOR(name, size, high)
00255     #define VAR_HEAP_SIZE_VECTOR(name, size, blocksize)
00256     #define HEAP_SIZE_VECTOR_PTR(name)
00257 #endif
00258
00259 // macros if caller context vector shall be present in memory config
00260 #if defined(APOXI_HEAP_CONTEXT_USAGE)
00261     #define BLOCK_HEAP_CONTEXT_VECTOR(name, size, high)     static HeapVector::ContextId m_context_vector_##name[(size / high)+1];
00262     #define VAR_HEAP_CONTEXT_VECTOR(name, size, blocksize)  static HeapVector::ContextId m_context_vector_##name[(size / blocksize)+1];
00263     #define HEAP_CONTEXT_VECTOR_PTR(name)                   m_context_vector_##name,
00264 #else
00265     #define BLOCK_HEAP_CONTEXT_VECTOR(name, size, high)
00266     #define VAR_HEAP_CONTEXT_VECTOR(name, size, blocksize)
00267     #define HEAP_CONTEXT_VECTOR_PTR(name)
00268 #endif
00269
00270 // macros if the name of a page shall be present in memory config
00271 #if defined(APOXI_HEAP_NAME_USAGE)
00272     #define APOXI_HEAP_NAME(name)       static CHAR m_name_##name[] = #name;
00273     #define APOXI_HEAP_NAME_PTR(name)   m_name_##name,
00274 #else
00275     #define APOXI_HEAP_NAME(name)
00276     #define APOXI_HEAP_NAME_PTR(name)
00277 #endif
00278
00279 // constant of the additional size per blockpage for memory checking
00280 #if defined(APOXI_HEAP_MEM_ACCESS_CHECK)
00281     // dont change that values !!!!!
00282     #define NO_CHECK_BYTES 4
00283 #else
00284     #define NO_CHECK_BYTES 0
00285 #endif
00286
00287
00289 //
00290 //  BLOCK_HEAP_PAGE(name, size, low, high)
00291 //
00293 /* Configuration:
00294     name: name of the page
00295     size: overall size of the memorypool, for C166 shall be smaller then < 16K
00296     low:  elements which are greater equal than low can be held by this page
00297     high: elements which are less equal than high can be held by this page
00298           ATTENTION: high must be a multiple of 2 it represents also the blocksize.
00299
00300     Example:
00301         BLOCK_HEAP_PAGE(page_10, 10*1024,9,10);
00302     will allocate a 10 K page where elements between 9 and 10 bytes can be held.
00303     1024 blocks can be used.
00304 */
00305
00306
00307 #define BLOCK_HEAP_PAGE(name, size, low, high)                          \
00308 const UINT c_add_bytes_##name = ((size / high)+1) * NO_CHECK_BYTES;     \
00309 static UINT m_mem_##name[(size+c_add_bytes_##name)/HEAP_BYTES_PER_UINT];\
00310 static UINT m_bits_##name[(size / high / HeapVector::BITS_PER_UINT)+1]; \
00311 APOXI_HEAP_NAME(name)                                                   \
00312 BLOCK_HEAP_SIZE_VECTOR(name, size, high)                                \
00313 BLOCK_HEAP_CONTEXT_VECTOR(name, size, high)                             \
00314 static HeapVector::BlockPage m_page_##name = {                          \
00315     (UINT8 *)&m_mem_##name[0],                                          \
00316     m_bits_##name,                                                      \
00317     0,                                                                  \
00318     HEAP_SIZE_VECTOR_PTR(name)                                          \
00319     HEAP_CONTEXT_VECTOR_PTR(name)                                       \
00320     TRUE                                                                \
00321     HEAP_STAT_STRUCT_VALUES                                             \
00322 };                                                                      \
00323 static const HeapVector::Page name = {                                  \
00324     FALSE,                                                              \
00325     APOXI_HEAP_NAME_PTR(name)                                           \
00326     high,                                                               \
00327     low,                                                                \
00328     high,                                                               \
00329     (UINT8 *)&m_mem_##name[0],                                          \
00330     ((UINT8 *)&m_mem_##name[0])+size+c_add_bytes_##name,                \
00331     size / high,                                                        \
00332     &g_fcts_block_page,                                                 \
00333     (HeapVector::Page*)&m_page_##name                                   \
00334 };
00335
00337 //
00338 //  VAR_HEAP_PAGE(name, size, blocksize, min, max)
00339 //
00341 /* Configuration:
00342     name: name of the page
00343     size: overall size of the memorypool, for C166 shall be smaller then < 16K
00344     blocksize: used blocksize for the page, ATTENTION: must be a value 2^N,
00345                like 4, 8, 16, 32, 64 etc ... reason for that is faster divison,
00346                through bit shift operation
00347     min:  elements which are greater equal than low can be held by this page
00348     max: elements which are less equal than high can be held by this page, this
00349           value has to be also smaller then the size of the pool
00350
00351     This page is using a best fit algorithm, if a request wants to allocate blocks,
00352     the best position will be found to avoid fragmentation throughout the blocklist.
00353     That means in the case:
00354         5 free, 3 used, 2 free, 4 used ...
00355     allocating of 2 blocks will result in
00356         5 free, 3 used, 2 used, 4 used
00357
00358     Example:
00359         VAR_HEAP_PAGE(page_d1, 64*127,64,64,1024);
00360     will allocate 8128 bytes, with a blocksize of 64 bytes where elements between
00361     64 and 1024 bytes can be held. If 100 bytes shall be allocated 2 blocks have to
00362     be used etc.
00363
00364 */
00365
00366 #define VAR_HEAP_PAGE(name, size, blocksize, low, high)                 \
00367 static UINT   m_mem_##name[(size/HEAP_BYTES_PER_UINT)];                 \
00368 static UINT16 m_length_##name[(size / blocksize)+1];                    \
00369 APOXI_HEAP_NAME(name)                                                   \
00370 VAR_HEAP_SIZE_VECTOR(name, size, blocksize)                             \
00371 VAR_HEAP_CONTEXT_VECTOR(name, size, blocksize)                          \
00372 static HeapVector::VarPage m_page_##name = {                            \
00373     (UINT8 *)&m_mem_##name[0],                                          \
00374     0,                                                                  \
00375     0,                                                                  \
00376     m_length_##name,                                                    \
00377     0,                                                                  \
00378     HEAP_SIZE_VECTOR_PTR(name)                                          \
00379     HEAP_CONTEXT_VECTOR_PTR(name)                                       \
00380     TRUE                                                                \
00381     HEAP_STAT_STRUCT_VALUES                                             \
00382 };                                                                      \
00383 static const HeapVector::Page name = {                                  \
00384     FALSE,                                                              \
00385     APOXI_HEAP_NAME_PTR(name)                                           \
00386     blocksize,                                                          \
00387     low,                                                                \
00388     high,                                                               \
00389     (UINT8 *)&m_mem_##name[0],                                          \
00390     ((UINT8 *)&m_mem_##name[0])+size,                                   \
00391     size / blocksize,                                                   \
00392     &g_fcts_var_page,                                                   \
00393     (HeapVector::Page*)&m_page_##name                                   \
00394 };
00395
00397 //
00398 //  HUGE_HEAP_PAGE(name, size, blocksize, min, max)
00399 //
00401 /* Configuration:
00402     see VAR_HEAP_PAGE but with HUGE memory model
00403 */
00404
00405 #define HUGE_HEAP_PAGE(name, size, blocksize, low, high)                \
00406 static UINT HUGE m_mem_##name[((size+blocksize)/HEAP_BYTES_PER_UINT)];  \
00407 static UINT16 m_length_##name[(size/blocksize)+1];                      \
00408 APOXI_HEAP_NAME(name)                                                   \
00409 VAR_HEAP_SIZE_VECTOR(name, size, blocksize)                             \
00410 VAR_HEAP_CONTEXT_VECTOR(name, size, blocksize)                          \
00411 static HeapVector::VarPage m_page_##name = {                            \
00412     0,                                                                  \
00413     (UINT8 HUGE *)&m_mem_##name[0],                                     \
00414     ((UINT8 HUGE *)&m_mem_##name[0])+size,                              \
00415     m_length_##name,                                                    \
00416     0,                                                                  \
00417     HEAP_SIZE_VECTOR_PTR(name)                                          \
00418     HEAP_CONTEXT_VECTOR_PTR(name)                                       \
00419     TRUE                                                                \
00420     HEAP_STAT_STRUCT_VALUES                                             \
00421 };                                                                      \
00422 static const HeapVector::Page name = {                                  \
00423     TRUE,                                                               \
00424     APOXI_HEAP_NAME_PTR(name)                                           \
00425     blocksize,                                                          \
00426     low,                                                                \
00427     high,                                                               \
00428     0,                                                                  \
00429     0,                                                                  \
00430     size / blocksize,                                                   \
00431     &g_fcts_huge_page,                                                  \
00432     (HeapVector::Page*)&m_page_##name                                   \
00433 };
00434
00436
00437 #define PAGE_TABLE_BEGIN(heapname)  static HeapVector::Page * m_pages_##heapname[] = {
00438 #define PAGE_ENTRY(name) (HeapVector::Page*)& name,
00439 #define PAGE_TABLE_END 0 };
00440
00441
00442 #define HEAP_TABLE_BEGIN()  static HeapVector::HeapTableEntry m_heap_table[] = {
00443
00444 #define HEAP_ENTRY(heapname, id)  {                                     \
00445     (HeapVector::Page**)(HeapVector::Page*)& m_pages_##heapname[0],     \
00446     id,                                                                 \
00447     id,                                                                 \
00448     0,                                                                  \
00449     0,                                                                  \
00450     #heapname                                                           \
00451 },
00452
00453 #define VIRTUAL_HEAP_ENTRY(heapname, id, virtid, size)  {               \
00454     (HeapVector::Page**)(HeapVector::Page*)& m_pages_##heapname[0],     \
00455     id,                                                                 \
00456     virtid,                                                             \
00457     size,                                                               \
00458     0,                                                                  \
00459     #heapname                                                           \
00460 },
00461 #define HEAP_TABLE_END { 0, 0 } };
00462
00463
00464 #define GET_HEAP_TABLE()& m_heap_table[0];
00465
00467 #endif  // Apoxi_HeapVector_hpp
00468
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HookedMessageReferrerList.cpp File Reference

Kernel/HookedMessageReferrerList.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "HookedMessageReferrerList.hpp"
#include "MessageHookList.hpp"
#include "Os/SemObtainer.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for HookedMessageReferrerList.cpp:

Generated on Tue Jan 24 21:01:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HookedMessageReferrerList.hpp File Reference

Kernel/HookedMessageReferrerList.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_HookedMessageReferrerList_hpp

Define Documentation

#define Apoxi_HookedMessageReferrerList_hpp

Generated on Tue Jan 24 21:01:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/HookedMessageReferrerList.hpp Source File

Kernel/HookedMessageReferrerList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003 ------------------------------------------------------------------------
00004 This document contains proprietary information belonging to COMNEON.
00005 Passing on and copying of this document, use and communication of its
00006 contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_HookedMessageReferrerList_hpp)
00010 #define Apoxi_HookedMessageReferrerList_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/LinkedList.hpp>
00017 #include <Kernel/MessageReferrer.hpp>
00018 #include <Kernel/MessageHookList.hpp>
00019
00020 class MessageHook;
00021 class HookedMessageReferrerListIterator;
00022
00024 class HookedMessageReferrer : public Linkable<HookedMessageReferrer>
00025 {
00026     friend class HookedMessageReferrerList;
00027     public:
00029         HookedMessageReferrer(MessageReferrer message_referrer);
00031         virtual ~HookedMessageReferrer();
00032
00034         const MessageReferrer& GetMessageReferrer() const { return (m_message_referrer); }
00035
00037         BOOLEAN IsHooked() { return (!m_message_hook_reference_list.IsEmpty()); }
00038
00040         BOOLEAN AddReference(MessageHook *message_hook);
00042         void RemoveReference(MessageHook *message_hook);
00043
00045         void SetDiscardMessage(BOOLEAN discard_message) { m_discard_message = m_discard_message || discard_message; }
00047         BOOLEAN GetDiscardMessage() const { return (m_discard_message); }
00048
00049     private:
00050         MessageReferrer m_message_referrer;
00051         BOOLEAN m_discard_message;
00052         LinkedList<MessageHookReferrer> m_message_hook_reference_list;
00053 };
00054
00057 class HookedMessageReferrerList
00058 {
00059     public:
00062         static HookedMessageReferrer* Append(const MessageReferrer &message_referrer, const MessageHookReferrer &message_hook_referrer);
00067         static BOOLEAN Remove(HookedMessageReferrer *&hooked_message_referrer, const MessageHookReferrer &message_hook_referrer, BOOLEAN discard_message);
00070         static HookedMessageReferrerListIterator* CreateIterator();
00071
00072     private:
00073         friend class HookedMessageReferrerListIterator;
00074         static LinkedList<HookedMessageReferrer> m_hooked_message_referrer_list;
00075 };
00076
00078 class HookedMessageReferrerListIterator
00079 {
00080     public:
00082         HookedMessageReferrerListIterator() : entry(0) {}
00083
00085         void First() { entry = HookedMessageReferrerList::m_hooked_message_referrer_list.GetFront(); }
00086
00088         void Next() { entry = entry->GetNext(); }
00089
00091         BOOLEAN IsDone() { return (entry == 0); }
00092
00094         HookedMessageReferrer* GetCurrentItem() { return (entry); }
00095
00096     private:
00097         HookedMessageReferrer *entry;
00098 };
00099
00101 #endif // DOXYGEN_SHOULD_SKIP_THIS
00102 #endif // Apoxi_HookedMessageReferrerList_hpp
00103
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/InputMap.cpp File Reference

Kernel/InputMap.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "InputMap.hpp"
#include <Auxiliary/BinarySearch.hpp>

Include dependency graph for InputMap.cpp:

Typedefs

typedef CharCompare< CharInputMapEntry,
CharInputMapItem > 		CharComparePred
typedef Searcher< CharInputMapEntry,
CharInputMapItem, CharComparePred > 		CharMapSearcher
typedef KeyDownCompare< KeyDownInputMapEntry,
KeyDownInputMapItem > 		KeyDownComparePred
typedef Searcher< KeyDownInputMapEntry,
KeyDownInputMapItem, KeyDownComparePred > 		KeyDownMapSearcher
typedef KeyUpCompare< KeyUpInputMapEntry,
KeyUpInputMapItem > 		KeyUpComparePred
typedef Searcher< KeyUpInputMapEntry,
KeyUpInputMapItem, KeyUpComparePred > 		KeyUpMapSearcher

Typedef Documentation

typedef CharCompare<CharInputMapEntry, CharInputMapItem> CharComparePred

typedef Searcher<CharInputMapEntry, CharInputMapItem, CharComparePred> CharMapSearcher

typedef KeyDownCompare<KeyDownInputMapEntry, KeyDownInputMapItem> KeyDownComparePred

typedef Searcher<KeyDownInputMapEntry, KeyDownInputMapItem, KeyDownComparePred> KeyDownMapSearcher

typedef KeyUpCompare<KeyUpInputMapEntry, KeyUpInputMapItem> KeyUpComparePred

typedef Searcher<KeyUpInputMapEntry, KeyUpInputMapItem, KeyUpComparePred> KeyUpMapSearcher

Generated on Tue Jan 24 21:01:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/InputMap.hpp File Reference

Kernel/InputMap.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for InputMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | CharInputMapEntry
class | CharInputMapItem
struct | InputMap
struct | InputMapEntry
class | InputMapItem
struct | KeyDownInputMapEntry
class | KeyDownInputMapItem
struct | KeyUpInputMapEntry
class | KeyUpInputMapItem

Defines

#define | Apoxi_InputMap_hpp

Typedefs

typedef InputMapItem::MapItemType | MapItemType

Variables

const InputMapControlId | c_abstract_menu_list_imid = 5
const InputMapId | c_Cancel_imid = 4
const InputMapControlId | c_check_box_imid = 2
const InputMapControlId | c_check_box_list_imid = 7
const InputMapId | c_CheckBoxChangeStatus_imid = 40
const InputMapId | c_Confirm_imid = 3
const InputMapControlId | c_control_imid = 1
const InputMapControlId | c_edit_box_imid = 4
const InputMapId | c_EditBoxCursorDown_imid = 13
const InputMapId | c_EditBoxCursorLeft_imid = 11
const InputMapId | c_EditBoxCursorRight_imid = 10
const InputMapId | c_EditBoxCursorUp_imid = 12
const InputMapId | c_EditBoxDeleteCharacter_imid = 14
const InputMapId | c_EditBoxDtmfSeparator_imid = 50
const InputMapId | c_EditBoxPlus_imid = 51
const InputMapId | c_EditBoxShiftKey_imid = 15
const InputMapId | c_EditBoxWildcard_imid = 52
const InputMapId | c_FocusNextControl_imid = 1
const InputMapId | c_FocusPreviousControl_imid = 2
const InputMapControlId | c_grid_imid = 10
const InputMapId | c_GridMoveDown_imid = 63
const InputMapId | c_GridMoveLeft_imid = 60
const InputMapId | c_GridMoveRight_imid = 61
const InputMapId | c_GridMoveUp_imid = 62
const InputMapControlId | c_list_box_imid = 3
const InputMapId | c_ListBoxNextItem_imid = 21
const InputMapId | c_ListBoxPreviousItem_imid = 20
const InputMapId | c_MenuItemSelected_imid = 30
const InputMapControlId | c_push_button_imid = 9
const InputMapId | c_PushButtonClick_imid = 70
const InputMapId | c_PushButtonRelease_imid = 71
const InputMapControlId | c_radio_button_imid = 6
const InputMapControlId | c_radio_button_list_imid = 8
const InputMapId | c_RadioButtonNextItem_imid = 81
const InputMapId | c_RadioButtonPreviousItem_imid = 80

Define Documentation

#define Apoxi_InputMap_hpp

Generated on Tue Jan 24 21:01:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/InputMap.hpp Source File

Kernel/InputMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_InputMap_hpp)
00010 #define Apoxi_InputMap_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 const InputMapControlId c_control_imid              =  1;
00017 const InputMapControlId c_check_box_imid            =  2;
00018 const InputMapControlId c_list_box_imid             =  3;
00019 const InputMapControlId c_edit_box_imid             =  4;
00020 const InputMapControlId c_abstract_menu_list_imid   =  5;
00021 const InputMapControlId c_radio_button_imid         =  6;
00022 const InputMapControlId c_check_box_list_imid       =  7;
00023 const InputMapControlId c_radio_button_list_imid    =  8;
00024 const InputMapControlId c_push_button_imid          =  9;
00025 const InputMapControlId c_grid_imid                 = 10;
00026
00027 const InputMapId    c_FocusNextControl_imid         =  1;
00028 const InputMapId    c_FocusPreviousControl_imid     =  2;
00029 const InputMapId    c_Confirm_imid                  =  3;
00030 const InputMapId    c_Cancel_imid                   =  4;
00031
00032 const InputMapId    c_EditBoxCursorRight_imid       = 10;
00033 const InputMapId    c_EditBoxCursorLeft_imid        = 11;
00034 const InputMapId    c_EditBoxCursorUp_imid          = 12;
00035 const InputMapId    c_EditBoxCursorDown_imid        = 13;
00036 const InputMapId    c_EditBoxDeleteCharacter_imid   = 14;
00037 const InputMapId    c_EditBoxShiftKey_imid          = 15;
00038
00039 const InputMapId    c_ListBoxPreviousItem_imid      = 20;
00040 const InputMapId    c_ListBoxNextItem_imid          = 21;
00041
00042 const InputMapId    c_MenuItemSelected_imid         = 30;
00043
00044 const InputMapId    c_CheckBoxChangeStatus_imid     = 40;
00045
00046 const InputMapId    c_EditBoxDtmfSeparator_imid     = 50;
00047 const InputMapId    c_EditBoxPlus_imid              = 51;
00048 const InputMapId    c_EditBoxWildcard_imid          = 52;
00049
00050 const InputMapId    c_GridMoveLeft_imid             = 60;
00051 const InputMapId    c_GridMoveRight_imid            = 61;
00052 const InputMapId    c_GridMoveUp_imid               = 62;
00053 const InputMapId    c_GridMoveDown_imid             = 63;
00054
00055 const InputMapId    c_PushButtonClick_imid          = 70;
00056 const InputMapId    c_PushButtonRelease_imid        = 71;
00057
00058 const InputMapId    c_RadioButtonPreviousItem_imid  = 80;
00059 const InputMapId    c_RadioButtonNextItem_imid      = 81;
00060
00061 /*  ------------------------------------------------------------------------
00062                                     InputMap
00063     ------------------------------------------------------------------------ */
00064
00065 struct InputMapEntry {
00066     InputMapControlId   m_input_map_control_id;
00067     InputMapId          m_input_map_id;
00068 };
00069
00071 class InputMapItem {
00072     public:
00080         enum MapItemType {
00081             KeyDownType,
00082             KeyAutoRepeatType,
00083             KeyUpType,
00084             LongKeyPressType,
00085             InputCharType
00086         };
00087
00088         InputMapItem(MapItemType type) : m_type(type) {};
00089
00090         MapItemType Type() const { return m_type; };
00091
00092     private:
00093         MapItemType m_type;
00094 };
00095
00096 typedef InputMapItem::MapItemType MapItemType;
00097
00099 struct InputMap {
00100     InputMapId GetTriggeredMessage(InputMapControlId map_id, const InputMapItem& item) const;
00101
00102     InputMapEntry   *m_map_entry;
00103     INT             m_size;
00104 };
00105
00106 /*  ------------------------------------------------------------------------
00107                              KeyDownInputMap
00108     ------------------------------------------------------------------------ */
00109
00110 struct KeyDownInputMapEntry {
00111     InputMapEntry   m_map_entry;
00112     KeyCode         m_key_code;
00113 };
00114
00116 class KeyDownInputMapItem : public InputMapItem {
00117     public:
00118         typedef InputMapItem Base;
00119
00120         KeyDownInputMapItem(MapItemType type, KeyCode key_code) : Base(type), m_key_code(key_code) {};
00121
00122         void SetKeyCode(KeyCode key_code) { m_key_code = key_code; };
00123         KeyCode GetKeyCode() const { return m_key_code; };
00124
00125     private:
00126         KeyCode     m_key_code;
00127 };
00128
00129 /*  ------------------------------------------------------------------------
00130                                  KeyUpInputMap
00131     ------------------------------------------------------------------------ */
00132 struct KeyUpInputMapEntry {
00133     InputMapEntry   m_map_entry;
00134     KeyCode         m_key_code;
00135     UINT32          m_duration;
00136 };
00137
00139 class KeyUpInputMapItem : public InputMapItem {
00140     public:
00141         typedef InputMapItem Base;
00142
00143         KeyUpInputMapItem(MapItemType type, KeyCode key_code, UINT32 duration) :
00144             Base(type), m_key_code(key_code), m_duration(duration) {};
00145
00146         void SetKeyCode(KeyCode key_code) { m_key_code = key_code; };
00147         KeyCode GetKeyCode() const { return m_key_code; };
00148
00149         void SetDuration(UINT32 duration) { m_duration = duration; };
00150         UINT32 GetDuration() const { return m_duration; };
00151
00152     private:
00153         KeyCode     m_key_code;
00154         UINT32      m_duration;
00155 };
00156
00157 /*  ------------------------------------------------------------------------
00158                                  CharInputMap
00159     ------------------------------------------------------------------------ */
00160 struct CharInputMapEntry {
00161     InputMapEntry   m_map_entry;
00162     WCHAR           m_char;
00163 };
00164
00166 class CharInputMapItem : public InputMapItem {
00167     public:
00168         typedef InputMapItem Base;
00169
00170         CharInputMapItem(MapItemType type, WCHAR chr) :
00171             Base(type), m_char(chr) {}
00172
00173         void SetChar(WCHAR chr) { m_char = chr; }
00174         WCHAR GetChar() const { return m_char; }
00175
00176     private:
00177         WCHAR   m_char;
00178 };
00179
00181 #endif  // Apoxi_InputMap_hpp
00182
00183
Generated on Tue Jan 24 14:50:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/InputStream.hpp File Reference

Kernel/InputStream.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:21:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/InputStream.hpp Source File

Kernel/InputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if defined(APOXI_COMPILER_MSVC)
00010     #pragma message("Reference to old Kernel/InputStream.hpp. Please use " \
00011         "Compat/InputStream.hpp instead.")
00012 #endif
00013
00014 #if defined(APOXI_COMPAT_2_0_0)
00015     // Kernel/InputStream.hpp moved to Compat.
00016     #include <Compat/InputStream.hpp>
00017 #endif
00018
00019
Generated on Tue Jan 24 14:49:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/KernelTemplates.cpp File Reference

Kernel/KernelTemplates.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/ApoxiThread.hpp>
#include <Kernel/AppContainerRoutingTable.hpp>
#include <Kernel/Timer.hpp>
#include <Kernel/Condition.hpp>

Include dependency graph for KernelTemplates.cpp:

Generated on Tue Jan 24 21:01:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Lib.hpp File Reference

Kernel/Lib.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/MachType.hpp>
#include <Devices/Device.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/Timer.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>
#include <Kernel/ActiveWaitDispatcher.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for Lib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Kernel_Lib_hpp

Define Documentation

#define Kernel_Lib_hpp

Generated on Tue Jan 24 14:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Lib.hpp Source File

Kernel/Lib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Kernel_Lib_hpp)
00009 #define Kernel_Lib_hpp
00010
00011 #include <Auxiliary/Macros.hpp>
00012 #include <Kernel/Types.hpp>
00013 #include <Kernel/MachType.hpp>
00014 #include <Devices/Device.hpp>
00015 #include <Kernel/Application.hpp>
00016 #include <Kernel/Timer.hpp>
00017 #include <Kernel/MsgTypes.hpp>
00018 #include <Kernel/Condition.hpp>
00019 #include <Kernel/AppContainer.hpp>
00020 #include <Kernel/MessageRouter.hpp>
00021 #include <Kernel/System.hpp>
00022 #include <Kernel/ActiveWaitDispatcher.hpp>
00023 #include <Kernel/Os/Mutex.hpp>
00024 #include <Kernel/Os/SemObtainer.hpp>
00025 #include <Kernel/Os/MutexObtainer.hpp>
00026
00027 #endif  // Kernel_Lib_hpp
00028
Generated on Tue Jan 24 14:44:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MachType.hpp File Reference

Kernel/MachType.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for MachType.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BigEndian16Bit
Represents a 16 bit integer in big endian format. More...
class | BigEndian32Bit
Represents a 32 bit integer in big endian format. More...
class | LittleEndian16Bit
Represents a 16 bit integer in little endian format. More...
class | LittleEndian32Bit
Represents a 32 bit integer in big endian format. More...
class | Native16Bit
class | Native32Bit

Defines

#define | APOXI_LITTLE_ENDIAN
#define | Apoxi_MachType_hpp
#define | ApoxiBigEndian16BitConstant(x) ApoxiSwap16Bit(x)
#define | ApoxiBigEndian32BitConstant(x) ApoxiSwap32Bit(x)
#define | ApoxiLittleEndian16BitConstant(x) ((UINT16) (x))
#define | ApoxiLIttleEndian32BitConstant(x) ((UINT32) (x))
#define | ApoxiSwap16Bit(x) ((UINT16) ((((UINT16) (x)) << 8U) | (((UINT16) (x)) >> 8U)))
#define | ApoxiSwap32Bit(x)

Typedefs

typedef LittleEndian16Bit | Native16BitBase
typedef LittleEndian32Bit | Native32BitBase

Define Documentation

#define APOXI_LITTLE_ENDIAN

#define Apoxi_MachType_hpp

#define ApoxiBigEndian16BitConstant ( x ) ApoxiSwap16Bit(x)

#define ApoxiBigEndian32BitConstant ( x ) ApoxiSwap32Bit(x)

#define ApoxiLittleEndian16BitConstant ( x ) ((UINT16) (x))

#define ApoxiLIttleEndian32BitConstant ( x ) ((UINT32) (x))

#define ApoxiSwap16Bit ( x ) ((UINT16) ((((UINT16) (x)) << 8U) | (((UINT16) (x)) >> 8U)))

#define ApoxiSwap32Bit ( x )

Value:

((UINT32) (((UINT32) ApoxiSwap16Bit((UINT16) x)) << 16U) |      \
                                      (((UINT32) ApoxiSwap16Bit((UINT16) (x >> 16U)))))

Typedef Documentation

typedef LittleEndian16Bit Native16BitBase

typedef LittleEndian32Bit Native32BitBase

Generated on Tue Jan 24 21:02:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MachType.hpp Source File

Kernel/MachType.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_MachType_hpp)
00012 #define Apoxi_MachType_hpp
00013
00014 #include <Kernel/Types.hpp>
00015
00016 #if !defined(APOXI_LITTLE_ENDIAN) && ! defined(APOXI_BIG_ENDIAN)
00017 #   if defined(APOXI_RTOS_WIN32)
00018 #       define APOXI_LITTLE_ENDIAN
00019 #   elif defined(APOXI_RTOS_NUC16S) || defined(APOXI_RTOS_NUC16U)
00020 #       define APOXI_LITTLE_ENDIAN
00021 #   elif defined(APOXI_RTOS_OSE166)
00022 #       define APOXI_LITTLE_ENDIAN
00023 #   else
00024 #       error APOXI_LITTLE_ENDIAN or APOXI_BIG_ENDIAN must be specified
00025 #   endif
00026 #endif
00027
00028
00029
00030 /*  -------------------------------------------------------------------------
00031                                     Types
00032     ------------------------------------------------------------------------- */
00033
00034 class BigEndian16Bit;
00035 class BigEndian32Bit;
00036 class LittleEndian16Bit;
00037 class LittleEndian32Bit;
00038
00039
00041 class BigEndian16Bit {
00042     public:
00046         BigEndian16Bit(UINT16 v = 0)  { m_val.m_uint16 = v; }
00047
00051         inline BigEndian16Bit(const LittleEndian16Bit& v);
00052
00055         inline BigEndian16Bit& operator=(const LittleEndian16Bit& v);
00056
00060         union {
00061             UINT8 m_uint8_ar[2];
00062             UINT16 m_uint16;
00063
00064             struct {
00065                 UINT8 m_a;
00066                 UINT8 m_b;
00067             } m_uint8;
00068         } m_val;
00069
00070 };
00071
00072
00074 class BigEndian32Bit {
00075     public:
00079         BigEndian32Bit(UINT32 v = 0) { m_val.m_uint32 = v; }
00080
00084         inline BigEndian32Bit(const LittleEndian32Bit& v);
00085
00088         inline BigEndian32Bit& operator=(const LittleEndian32Bit& v);
00089
00093         union {
00094             UINT8 m_uint8_ar[4];
00095             UINT16 m_uint16_ar[2];
00096             UINT32 m_uint32;
00097
00098             struct {
00099                 UINT8 m_a;
00100                 UINT8 m_b;
00101                 UINT8 m_c;
00102                 UINT8 m_d;
00103             } m_uint8;
00104
00105             struct {
00106                 UINT16 m_a;
00107                 UINT16 m_b;
00108             } m_uint16;
00109         } m_val;
00110 };
00111
00112
00114 class LittleEndian16Bit {
00115     public:
00119         LittleEndian16Bit(UINT16 v = 0) { m_val.m_uint16 = v; }
00120
00124         inline LittleEndian16Bit(const BigEndian16Bit& v);
00125
00128         inline LittleEndian16Bit& operator=(const BigEndian16Bit& v);
00129
00133         union {
00134             UINT8 m_uint8_ar[2];
00135             UINT16 m_uint16;
00136
00137             struct {
00138                 UINT8 m_b;
00139                 UINT8 m_a;
00140             } m_uint8;
00141         } m_val;
00142 };
00143
00144
00146 class LittleEndian32Bit {
00147     public:
00151         LittleEndian32Bit(UINT32 v = 0) { m_val.m_uint32 = v; }
00152
00156         LittleEndian32Bit(const BigEndian32Bit& v);
00157
00160         LittleEndian32Bit& operator=(const BigEndian32Bit& v);
00161
00165         union {
00166             UINT8 m_uint8_ar[4];
00167             UINT16 m_uint16_ar[2];
00168             UINT32 m_uint32;
00169
00170             struct {
00171                 UINT8 m_d;
00172                 UINT8 m_c;
00173                 UINT8 m_b;
00174                 UINT8 m_a;
00175             } m_uint8;
00176
00177             struct {
00178                 UINT16 m_b;
00179                 UINT16 m_a;
00180             } m_uint16;
00181         } m_val;
00182 };
00183
00184
00185 #if defined(APOXI_BIG_ENDIAN)
00186     typedef BigEndian16Bit Native16BitBase;
00187     typedef BigEndian32Bit Native32BitBase;
00188 #else
00189     typedef LittleEndian16Bit Native16BitBase;
00190     typedef LittleEndian32Bit Native32BitBase;
00191 #endif
00192
00193
00196 class Native16Bit : public Native16BitBase {
00197     typedef Native16BitBase Base;
00198
00199     public:
00201         Native16Bit(UINT16 v = 0) : Base(v) { }
00202
00205         Native16Bit(const BigEndian16Bit& v) {* this = v; }
00206
00209         Native16Bit(const LittleEndian16Bit& v) {* this = v; }
00210
00212         inline Native16Bit& operator=(const BigEndian16Bit& v);
00213
00215         inline Native16Bit& operator=(const LittleEndian16Bit& v);
00216 };
00217
00218
00221 class Native32Bit : public Native32BitBase {
00222     typedef Native32BitBase Base;
00223
00224     public:
00226         Native32Bit(UINT32 v = 0) : Base(v) { }
00227
00230         Native32Bit(const BigEndian32Bit& v) {* this = v; }
00231
00234         Native32Bit(const LittleEndian32Bit& v) {* this = v; }
00235
00237         inline Native32Bit& operator=(const BigEndian32Bit& v);
00238
00240         inline Native32Bit& operator=(const LittleEndian32Bit& v);
00241 };
00242
00243
00244 inline Native16Bit& Native16Bit::operator=(const BigEndian16Bit& v)
00245 {
00246     Base::operator=(v);
00247     return* this;
00248 }
00249
00250
00251 inline Native16Bit& Native16Bit::operator=(const LittleEndian16Bit& v)
00252 {
00253     Base::operator=(v);
00254     return* this;
00255 }
00256
00257
00258 inline Native32Bit& Native32Bit::operator=(const BigEndian32Bit& v)
00259 {
00260     Base::operator=(v);
00261     return* this;
00262 }
00263
00264
00265 inline Native32Bit& Native32Bit::operator=(const LittleEndian32Bit& v)
00266 {
00267     Base::operator=(v);
00268     return* this;
00269 }
00270
00271
00272 inline BigEndian16Bit::BigEndian16Bit(const LittleEndian16Bit& v)
00273 {
00274     *this = v;
00275 }
00276
00277 inline BigEndian16Bit& BigEndian16Bit::operator=(const LittleEndian16Bit& v)
00278 {
00279     m_val.m_uint8.m_a = v.m_val.m_uint8.m_a;
00280     m_val.m_uint8.m_b = v.m_val.m_uint8.m_b;
00281     return* this;
00282 }   // operator=
00283
00284
00285 inline BigEndian32Bit::BigEndian32Bit(const LittleEndian32Bit& v)
00286 {
00287     *this = v;
00288 }
00289
00290 inline BigEndian32Bit& BigEndian32Bit::operator=(const LittleEndian32Bit& v)
00291 {
00292     m_val.m_uint8.m_a = v.m_val.m_uint8.m_a;
00293     m_val.m_uint8.m_b = v.m_val.m_uint8.m_b;
00294     m_val.m_uint8.m_c = v.m_val.m_uint8.m_c;
00295     m_val.m_uint8.m_d = v.m_val.m_uint8.m_d;
00296     return* this;
00297 }   // operator=
00298
00299
00300 inline LittleEndian16Bit::LittleEndian16Bit(const BigEndian16Bit& v)
00301 {
00302     *this = v;
00303 }
00304
00305 inline LittleEndian16Bit& LittleEndian16Bit::operator=(const BigEndian16Bit& v)
00306 {
00307     m_val.m_uint8.m_a = v.m_val.m_uint8.m_a;
00308     m_val.m_uint8.m_b = v.m_val.m_uint8.m_b;
00309     return* this;
00310 }   // operator=
00311
00312
00313 inline LittleEndian32Bit::LittleEndian32Bit(const BigEndian32Bit& v)
00314 {
00315     *this = v;
00316 }
00317
00318 inline LittleEndian32Bit& LittleEndian32Bit::operator=(const BigEndian32Bit& v)
00319 {
00320     m_val.m_uint8.m_a = v.m_val.m_uint8.m_a;
00321     m_val.m_uint8.m_b = v.m_val.m_uint8.m_b;
00322     m_val.m_uint8.m_c = v.m_val.m_uint8.m_c;
00323     m_val.m_uint8.m_d = v.m_val.m_uint8.m_d;
00324     return* this;
00325 }   // operator=
00326
00327
00328
00329 /*  -------------------------------------------------------------------------
00330                                     Macros
00331     ------------------------------------------------------------------------- */
00332
00333 #define ApoxiSwap16Bit(x)   ((UINT16) ((((UINT16) (x)) << 8U) | (((UINT16) (x)) >> 8U)))
00334 #define ApoxiSwap32Bit(x)   ((UINT32) (((UINT32) ApoxiSwap16Bit((UINT16) x)) << 16U) |      \
00335                                       (((UINT32) ApoxiSwap16Bit((UINT16) (x >> 16U)))))
00336
00337
00338 // use these macros to define 16/32 bit big / little endian constants
00339 #if defined(APOXI_BIG_ENDIAN)
00340 #   define ApoxiLittleEndian16BitConstant(x) ApoxiSwap16Bit(x)
00341 #   define ApoxiLittleEndian32BitConstant(x) ApoxiSwap32Bit(x)
00342
00343 #   define ApoxiBigEndian16BitConstant(x) ((UINT16) (x))
00344 #   define ApoxiBigEndian32BitConstant(x) ((UINT32) (x))
00345 #else
00346 #   define ApoxiLittleEndian16BitConstant(x) ((UINT16) (x))
00347 #   define ApoxiLIttleEndian32BitConstant(x) ((UINT32) (x))
00348
00349 #   define ApoxiBigEndian16BitConstant(x) ApoxiSwap16Bit(x)
00350 #   define ApoxiBigEndian32BitConstant(x) ApoxiSwap32Bit(x)
00351 #endif
00352
00353 #endif  // Apoxi_MachType_hpp
00354
00355
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Message.cpp File Reference

Kernel/Message.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Message.hpp"
#include "Application.hpp"

Include dependency graph for Message.cpp:

Generated on Tue Jan 24 21:02:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Message.hpp File Reference

Kernel/Message.hpp File Reference

#include <Kernel/DispatcherAction.hpp>
#include <Auxiliary/ObjectReferrer.hpp>
#include <Auxiliary/Macros.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/MsgCategory.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for Message.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContextMsg
class | ControlMsg
class | Message

Defines

#define | Kernel_Message_hpp

Typedefs

typedef ContextMsg | ApplicationMsg
For backwards compatibility only.

Functions

template<class DestClassPointer>
void | CastMsg (DestClassPointer &dest_msg, const Message *src_msg)

Define Documentation

#define Kernel_Message_hpp

Generated on Tue Jan 24 16:57:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Message.hpp Source File

Kernel/Message.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\RootMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Kernel_Message_hpp)
00016 #define Kernel_Message_hpp
00017
00018 #include <Kernel/DispatcherAction.hpp>
00019 #include <Auxiliary/ObjectReferrer.hpp>
00020 #include <Auxiliary/Macros.hpp>
00021 #include <Kernel/Types.hpp>
00022 #include <Kernel/MsgCategory.hpp>
00023 #include <Kernel/MessageRouter.hpp>
00024
00027 class Application;
00028 class Control;
00029 class ExecutionContext;
00030
00031 /* ----------------------------------------------------------------------
00032     Classes
00033     ---------------------------------------------------------------------- */
00034
00035 /*  ======================================================================
00036     Class Message
00037     ====================================================================== */
00038
00069 class Message {
00070     public:
00071         Message();
00072         virtual ~Message();
00073
00074         virtual const MsgMetaData& GetMetaData() const = 0;
00075         MsgId Id() const { return GetMetaData().msg_id; }
00076         MsgCategory Category() const { return GetMetaData().msg_class; }
00077         MsgOrigin Origin() const { return GetMetaData().msg_origin; }
00078         void Post() const { MessageRouter::Post(*this); }
00079         virtual Message* Clone() const = 0;
00080
00081     private:
00082         friend class MessageReferrer;
00083         friend class MessageRouter;
00084         friend class AppContainer;
00085
00086         Message(const Message &msg);                // forbid copy construction
00087         Message& operator=(const Message &msg);     // forbid assignment operation
00088
00089         void AddRef(INT n = 1);
00090
00091         UINT m_focus_transfer   :  1;
00092         INT m_refcount          : 15;
00093
00094     };
00095
00096
00097 /*  ======================================================================
00098     Class ContextMsg
00099     ====================================================================== */
00100
00103 class ContextMsg : public Message {
00104     public:
00105         ContextMsg(ExecutionContext* context);
00106         virtual ~ContextMsg();
00107
00108         virtual const MsgMetaData& GetMetaData() const = 0;
00109         void SetContext(ExecutionContext* context) { m_context = context; }
00110         ExecutionContext* GetContext() const { return m_context; }
00111
00112         // for backward compatibility only
00113         void SetApplication(Application* app);
00114         Application* GetApplication() const;
00115
00116     private:
00117         ExecutionContext* m_context;
00118
00119     };
00120
00121
00122 /*  ======================================================================
00123     Class ControlMsg
00124     ====================================================================== */
00125
00128 class ControlMsg : public Message {
00129     public:
00130         ControlMsg(Control* control);
00131         virtual ~ControlMsg();
00132
00133         virtual const MsgMetaData& GetMetaData() const = 0;
00134         void SetControl(Control* control) { m_control = control; }
00135         Control* GetControl() const { return m_control; }
00136
00137     private:
00138         Control* m_control;
00139
00140     };
00141
00143 typedef ContextMsg ApplicationMsg;
00144
00151 template<class DestClassPointer>
00152 inline void CastMsg(DestClassPointer &dest_msg, const Message *src_msg)
00153 {
00154     ASSERT_DEBUG(src_msg->Id() == DestClassPointer()->ID);
00155     dest_msg = static_cast<DestClassPointer>(const_cast<Message*>(src_msg));
00156 }   // CastMsg
00157
00159 #endif  // Kernel_Message_hpp
00160
Generated on Tue Jan 24 14:46:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHook.cpp File Reference

Kernel/MessageHook.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MessageHook.hpp"
#include "ExecutionContext.hpp"
#include "MessageHookList.hpp"
#include "MessageRouter.hpp"
#include "MsgTypes.hpp"
#include "HookedMessageReferrerList.hpp"
#include "MessageHookNotificationMsg.hpp"
#include "Os/SemObtainer.hpp"
#include "AppContainer.hpp"
#include "Condition.hpp"

Include dependency graph for MessageHook.cpp:

Generated on Tue Jan 24 21:02:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHook.hpp File Reference

Kernel/MessageHook.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/MsgCategory.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Os/Semaphore.hpp>

Include dependency graph for MessageHook.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MessageHook
class | MessageHook::Protector

Defines

#define | Apoxi_MessageHook_hpp

Define Documentation

#define Apoxi_MessageHook_hpp

Generated on Tue Jan 24 21:02:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHook.hpp Source File

Kernel/MessageHook.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MessageHook_hpp)
00010 #define Apoxi_MessageHook_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Condition.hpp>
00016 #include <Kernel/MsgCategory.hpp>
00017 #include <Kernel/Os/Mutex.hpp>
00018 #include <Kernel/Os/Semaphore.hpp>
00019
00020 class ExecutionContext;
00021 class HookedMessageReferrer;
00022 class MessageHookReferrer;
00023 class MessageReferrer;
00024
00026 class MessageHook {
00027     friend class MessageRouter;
00028
00029     public:
00031         enum Mode {
00033             Asynchronous,
00035             Synchronous,
00036         };
00037
00039         MessageHook();
00041         virtual ~MessageHook();
00042
00047         virtual BOOLEAN Attach(MsgId message_id, Mode mode = Asynchronous);
00048
00050         virtual void Detach();
00051
00053         MsgId GetMessageId() const { return (m_message_id); }
00054
00059         ExecutionContext* GetExecutionContext() const { return (m_execution_context); }
00060
00062         BOOLEAN IsAttached() const { return (m_is_attached); }
00063
00065         BOOLEAN IsAsynchronous() const { return (m_mode == Asynchronous); }
00066
00067     protected:
00082         virtual BOOLEAN OnMessage(Message &message) = 0;
00083
00084     private:
00085         BOOLEAN m_marked_for_detach;
00086         BOOLEAN m_is_attached;
00087         MsgId m_message_id;
00088         Mode m_mode;
00089         INT m_refcount;
00090         ExecutionContext *m_execution_context;
00091
00092         class Protector {
00093             public:
00094                 void Lock() {
00095                     static BOOLEAN initialized = FALSE;
00096                     if (!initialized) {
00097                         initialized = TRUE;
00098                         m_mutex.Create(FALSE);
00099                     } // if
00100                     m_mutex.Obtain();
00101                 }
00102
00103                 void Unlock() { m_mutex.Release(); }
00104
00105             private:
00106                 Mutex m_mutex;
00107         };
00108
00109         friend class MessageHookReferrer;
00110         // interface for MessageHookReferrer, to manipulate reference counter (method must be secured by caller)
00111         void AddRef(INT n = 1);
00112         // returns the flag, which signals, that this instance of message hook is marked for deletion from the global message hook list
00113         BOOLEAN IsMarkedForDetach() const { return (m_marked_for_detach); }
00114         // return TRUE, if there is more than one reference (one at least for the global message hook list) to this message hook
00115         BOOLEAN IsReferenced(INT ref_reference = 0) const { return (m_refcount > ref_reference); }
00116         // removes this instance from the global message hook list (method must be secured by caller)
00117         void RemoveFromGlobalList();
00118
00119
00120         // protector for secure list access
00121         static Protector m_protector;
00122
00123         friend class MessageHookNotificationMsg;
00124         // suspends the distribution of the message until the hooking instances have finished their work (MessageHook::OnMessage)
00125         static BOOLEAN Suspend(const MessageReferrer &msg_ref);
00126         /*  calls the message's hooks OnMessage, and returns TRUE, if the hooked message should be released and
00127             dispatched to the official registered recipients. */
00128         static BOOLEAN Notify(HookedMessageReferrer *hooked_message_referrer, const MessageHookReferrer &message_hook_referrer);
00129         // resumes the message hook for the given referrer
00130         static void Resume(HookedMessageReferrer *hooked_message_referrer, const MessageHookReferrer &message_hook_referrer, BOOLEAN discard_message = FALSE);
00131 };
00132
00134 #endif // Apoxi_MessageHook_hpp
00135
00136
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHookList.cpp File Reference

Kernel/MessageHookList.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MessageHookList.hpp"
#include "Os/SemObtainer.hpp"
#include "MessageHook.hpp"

Include dependency graph for MessageHookList.cpp:

Generated on Tue Jan 24 21:02:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHookList.hpp File Reference

Kernel/MessageHookList.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_MessageHookList_hpp

Define Documentation

#define Apoxi_MessageHookList_hpp

Generated on Tue Jan 24 21:02:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHookList.hpp Source File

Kernel/MessageHookList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002 Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003 ------------------------------------------------------------------------
00004 This document contains proprietary information belonging to COMNEON.
00005 Passing on and copying of this document, use and communication of its
00006 contents is not permitted without prior written authorisation.
00007 ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MessageHookList_hpp)
00010 #define Apoxi_MessageHookList_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Auxiliary/LinkedList.hpp>
00017
00018 class MessageHook;
00019 class MessageHookListIterator;
00020
00022 class MessageHookReferrer : public Linkable<MessageHookReferrer>
00023 {
00024     public:
00026         MessageHookReferrer(MessageHook *message_hook = 0);
00028         virtual ~MessageHookReferrer();
00030         MessageHookReferrer(const MessageHookReferrer &message_hook_referrer);
00032         MessageHookReferrer& operator =(const MessageHookReferrer &message_hook_referrer);
00033
00035         BOOLEAN operator ==(const MessageHookReferrer &message_hook_list_entry) const;
00037         BOOLEAN operator !=(const MessageHookReferrer &message_hook_list_entry) const;
00038
00040         MessageHook* GetMessageHook() const { return m_message_hook; }
00042         BOOLEAN IsEqual(MessageHook *message_hook) const;
00043
00044
00045     private:
00046         MessageHook *m_message_hook;
00047 };
00048
00051 class MessageHookList
00052 {
00053     public:
00055         static BOOLEAN Append(MessageHook *message_hook);
00057         static BOOLEAN Remove(MessageHook *message_hook);
00058
00061         static MessageHookListIterator* CreateIterator();
00062
00063     private:
00064         friend class MessageHookListIterator;
00065         static LinkedList<MessageHookReferrer> m_message_hook_list;
00066 };
00067
00069 class MessageHookListIterator
00070 {
00071 public:
00073     MessageHookListIterator() : entry(0) {}
00075     void First() { entry = MessageHookList::m_message_hook_list.GetFront(); }
00077     void Next() { entry = entry->GetNext(); }
00079     BOOLEAN IsDone() { return (entry == 0); }
00081     MessageHookReferrer* GetCurrentItem() { return (entry); }
00082
00083 private:
00084     MessageHookReferrer *entry;
00085 };
00086
00088 #endif // DOXYGEN_SHOULD_SKIP_THIS
00089 #endif // Apoxi_MessageHookList_hpp
00090
00091
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHookNotificationMsg.cpp File Reference

Kernel/MessageHookNotificationMsg.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MessageHookNotificationMsg.hpp"
#include "HookedMessageReferrerList.hpp"
#include "MessageHook.hpp"

Include dependency graph for MessageHookNotificationMsg.cpp:

Generated on Tue Jan 24 21:02:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHookNotificationMsg.hpp File Reference

Kernel/MessageHookNotificationMsg.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_MessageHookNotificationMsg_hpp

Define Documentation

#define Apoxi_MessageHookNotificationMsg_hpp

Generated on Tue Jan 24 21:02:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageHookNotificationMsg.hpp Source File

Kernel/MessageHookNotificationMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MessageHookNotificationMsg_hpp)
00010 #define Apoxi_MessageHookNotificationMsg_hpp
00011 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00014
00015 #include <Kernel/MsgTypes.hpp>
00016 #include <Kernel/MessageHookList.hpp>
00017
00018 class HookedMessageReferrer;
00019
00022 class MessageHookNotificationMsg : public ContextExecuteMsg {
00023     typedef ContextExecuteMsg Base;
00024     public:
00026         MessageHookNotificationMsg(HookedMessageReferrer *hooked_message_referrer, const MessageHookReferrer &message_hook_referrer);
00028         virtual ~MessageHookNotificationMsg();
00029
00031         virtual void Execute();
00032
00034         virtual Message* Clone() const;
00035
00036     private:
00037         HookedMessageReferrer *m_hooked_message_referrer;
00038         MessageHookReferrer m_message_hook_referrer;
00039 };
00040
00042 #endif // DOXYGEN_SHOULD_SKIP_THIS
00043 #endif // Apoxi_MessageHookNotificationMsg_hpp
00044
00045
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageMap.hpp File Reference

Kernel/MessageMap.hpp File Reference

#include <Kernel/System.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Application.hpp>

Include dependency graph for MessageMap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractMessageMapContainer
struct | MessageMap< T >
class | MessageMapContainer< T >

Defines

#define | Apoxi_MessageMap_hpp

Define Documentation

#define Apoxi_MessageMap_hpp

Generated on Tue Jan 24 21:02:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageMap.hpp Source File

Kernel/MessageMap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MessageMap_hpp)
00010 #define Apoxi_MessageMap_hpp
00013
00014 #include <Kernel/System.hpp>
00015 #include <Kernel/MsgTypes.hpp>
00016 #include <Kernel/Application.hpp>
00017
00019 template<class T> struct MessageMap {
00020     MsgId msg_id;
00021     BOOLEAN (T::*func)(const Message &msg);
00022 };
00023
00025 class AbstractMessageMapContainer {
00026     public:
00027         virtual void Register() const = 0;
00028         virtual void Unregister() const = 0;
00029         virtual BOOLEAN Execute(const Message &msg) const = 0;
00030 };
00031
00033 template<class T> class MessageMapContainer : public AbstractMessageMapContainer {
00034     public:
00035         MessageMapContainer(T *dispatcher = 0, const MessageMap<T> *msg_map = 0) :
00036             m_dispatcher(dispatcher), m_msg_map(msg_map) { }
00037
00038         virtual void Init(T *dispatcher, const MessageMap<T> *msg_map) {
00039             m_dispatcher = dispatcher;
00040             m_msg_map = msg_map;
00041         }
00042
00043         virtual void Register() const
00044         {
00045             ASSERT_ALWAYS(m_dispatcher != 0 && m_msg_map != 0);
00046
00047             INT i = 0;
00048             Application* app = System::GetActiveApplication();
00049
00050             while (m_msg_map[i].msg_id != NoMessage::ID) {
00051                 ASSERT_DEBUG(m_msg_map[i].func != 0);
00052                 app->RegisterMessage(m_msg_map[i].msg_id);
00053                 i++;
00054             }
00055         }
00056
00057         virtual void Unregister() const
00058         {
00059             ASSERT_ALWAYS(m_dispatcher != 0 && m_msg_map != 0);
00060
00061             INT i = 0;
00062             Application* app = System::GetActiveApplication();
00063
00064             while (m_msg_map[i].msg_id != NoMessage::ID) {
00065                 ASSERT_DEBUG(m_msg_map[i].func != 0);
00066                 app->UnregisterMessage(m_msg_map[i].msg_id);
00067                 i++;
00068             }
00069         }
00070
00071         virtual BOOLEAN Execute(const Message& msg) const
00072         {
00073             ASSERT_ALWAYS(m_dispatcher != 0 && m_msg_map != 0);
00074
00075             INT i = 0;
00076             while (m_msg_map[i].msg_id != NoMessage::ID) {
00077                 ASSERT_DEBUG(m_msg_map[i].func != 0);
00078                 if (m_msg_map[i].msg_id == msg.Id())
00079                     return (m_dispatcher->*(m_msg_map[i].func))(msg);
00080                 i++;
00081             }
00082
00083             return FALSE;
00084         }
00085
00086     private:
00087         T *m_dispatcher;
00088         const MessageMap<T>* m_msg_map;
00089 };
00090
00092 #endif  // Apoxi_MessageMap_hpp
00093
00094
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageMapDispatcher.cpp File Reference

Kernel/MessageMapDispatcher.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MessageMapDispatcher.hpp"
#include "System.hpp"
#include "MessageMap.hpp"

Include dependency graph for MessageMapDispatcher.cpp:

Generated on Tue Jan 24 21:02:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageMapDispatcher.hpp File Reference

Kernel/MessageMapDispatcher.hpp File Reference

#include <Kernel/UserDispatcher.hpp>

Include dependency graph for MessageMapDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MessageMapDispatcher

Defines

#define | Apoxi_MessageMapDispatcher_hpp

Define Documentation

#define Apoxi_MessageMapDispatcher_hpp

Generated on Tue Jan 24 21:02:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageMapDispatcher.hpp Source File

Kernel/MessageMapDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MessageMapDispatcher_hpp)
00010 #define Apoxi_MessageMapDispatcher_hpp
00013
00014 #include <Kernel/UserDispatcher.hpp>
00015
00016 class AbstractMessageMapContainer;
00017
00023 class MessageMapDispatcher : public UserDispatcher {
00024     typedef UserDispatcher Base;
00025
00026     public:
00028         MessageMapDispatcher(const AbstractMessageMapContainer *msg_map_container = 0);
00029
00031         virtual ~MessageMapDispatcher();
00032
00034         void Init(const AbstractMessageMapContainer *msg_map_container) { m_msg_map_container = msg_map_container; }
00035
00036     protected:
00038         virtual void RegisterMessages() const;
00039
00041         virtual void UnregisterMessages() const;
00042
00044         virtual BOOLEAN OnMessage(const Message& msg);
00045
00046     private:
00047         const AbstractMessageMapContainer *m_msg_map_container;
00048 };
00049
00051 #endif  // Apoxi_MessageMapDispatcher_hpp
00052
00053
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageReferrer.cpp File Reference

Kernel/MessageReferrer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MessageReferrer.hpp"
#include "Message.hpp"

Include dependency graph for MessageReferrer.cpp:

Generated on Tue Jan 24 21:02:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageReferrer.hpp File Reference

Kernel/MessageReferrer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MessageReferrer

Defines

#define | Apoxi_MessageReferrer_hpp

Define Documentation

#define Apoxi_MessageReferrer_hpp

Generated on Tue Jan 24 21:02:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageReferrer.hpp Source File

Kernel/MessageReferrer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MessageReferrer_hpp)
00010 #define Apoxi_MessageReferrer_hpp
00013
00014 class Message;
00015
00017 class MessageReferrer {
00018     public:
00020         MessageReferrer(Message* msg = 0);
00021
00023         MessageReferrer(const MessageReferrer& mr);
00024
00026         virtual ~MessageReferrer();
00027
00029         virtual MessageReferrer& operator=(const MessageReferrer& mr);
00030
00032         Message* GetMessage() const { return m_msg; }
00033
00034     private:
00035         Message* m_msg;
00036 };
00037
00039 #endif  // Apoxi_MessageReferrer_hpp
00040
00041
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageRouter.cpp File Reference

Kernel/MessageRouter.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MessageRouter.hpp"
#include "System.hpp"
#include "ExternalCommunicationHandler.hpp"
#include "MessageReferrer.hpp"
#include "MsgQueue.hpp"
#include "ExecutionContext.hpp"
#include "ApoxiThread.hpp"
#include <Kernel/Os/MutexObtainer.hpp>
#include "AbstractExternalData.hpp"
#include "Message.hpp"
#include "MessageHook.hpp"

Include dependency graph for MessageRouter.cpp:

Generated on Tue Jan 24 21:02:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageRouter.hpp File Reference

Kernel/MessageRouter.hpp File Reference

#include <Auxiliary/SingleArgHook.hpp>

Include dependency graph for MessageRouter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MessageRouter

Defines

#define | Apoxi_MessageRouter_hpp

Define Documentation

#define Apoxi_MessageRouter_hpp

Generated on Tue Jan 24 21:03:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MessageRouter.hpp Source File

Kernel/MessageRouter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MessageRouter_hpp)
00010 #define Apoxi_MessageRouter_hpp
00013
00014 #include <Auxiliary/SingleArgHook.hpp>
00015
00016 class Message;
00017 class MessageReferrer;
00018 class ExternalCommunicationHandler;
00019 class AbstractExternalData;
00020 class MsgQueue;
00021
00025 class MessageRouter {
00026     public:
00028         static void Init(ExternalCommunicationHandler* external_communicator = 0) {
00029             m_external_communicator = external_communicator;
00030         }
00031
00033         static ExternalCommunicationHandler* GetExternalCommunicator() { return m_external_communicator; }
00034
00036         static void Post(const Message& msg);
00037
00039         static void Post(const AbstractExternalData& external_data);
00040
00041         static void PostFocusTransferMsg(const Message& msg);
00042
00044         typedef SingleArgHook<const Message&> PostMsgHook;
00046         typedef PostMsgHook::HookFn PostMsgHookFn;
00047
00052         static BOOLEAN AddPostMsgHook(PostMsgHookFn fn);
00053
00057         static BOOLEAN RemovePostMsgHook(PostMsgHookFn fn);
00058
00059     private:
00060         friend class MessageHook;
00061         friend class StartUp;
00062
00063         static BOOLEAN m_ready_to_post;
00064         static ExternalCommunicationHandler* m_external_communicator;
00065         static PostMsgHook m_post_msg_hook;
00066
00067         static void PostMessage(const MessageReferrer &msg_ref);
00068         static void StartPostingMessages();
00069         static MsgQueue& GetMsgQueue();
00070 };
00071
00072
00074 #endif  // Apoxi_MessageRouter_hpp
00075
00076
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgCategory.cpp File Reference

Kernel/MsgCategory.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MsgCategory.hpp"

Include dependency graph for MsgCategory.cpp:

Generated on Tue Jan 24 21:03:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgCategory.hpp File Reference

Kernel/MsgCategory.hpp File Reference

#include <Auxiliary/ObjectReferrer.hpp>

Include dependency graph for MsgCategory.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | MsgMetaData

Defines

#define | Kernel_MsgCategory_hpp

Typedefs

typedef UINT16 | MsgCategory
typedef UINT16 | MsgId

Enumerations

enum | MsgOrigin { externalMsg, internalMsg }

Variables

const MsgCategory | MC_APP = MC_CONTEXT
const MsgCategory | MC_AT = 0x0080U
const MsgCategory | MC_BROADCAST = 0x0100U
const MsgCategory | MC_CONTEXT = 0x0002U
const MsgCategory | MC_CONTROL = 0x0004U
const MsgCategory | MC_FOCUS = 0x0008U
const MsgCategory | MC_IPC = 0x0020U
const MsgCategory | MC_NOT_VALID = 0U
const MsgCategory | MC_SIGNAL = 0x0040U
const MsgCategory | MC_STACK_CONTROL = 0x0010U
const MsgCategory | MC_SYSTEM = 0x0001U
const MsgCategory | MC_WIN = MC_CONTROL

Define Documentation

#define Kernel_MsgCategory_hpp

Generated on Tue Jan 24 21:04:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgCategory.hpp Source File

Kernel/MsgCategory.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Kernel_MsgCategory_hpp)
00011 #define Kernel_MsgCategory_hpp
00014
00015 #include <Auxiliary/ObjectReferrer.hpp>
00016
00018 typedef UINT16 MsgId;
00019
00021 typedef UINT16 MsgCategory;
00022
00023 enum MsgOrigin{
00024     externalMsg,
00025     internalMsg
00026 };
00027
00029 struct MsgMetaData {
00030     MsgId       msg_id;
00031     MsgCategory msg_class;
00032     MsgOrigin   msg_origin;
00033 };
00034
00035 // common message classes
00036 const MsgCategory MC_NOT_VALID      = 0U;
00037
00039 const MsgCategory MC_SYSTEM         = 0x0001U;
00040
00042 const MsgCategory MC_CONTEXT        = 0x0002U;
00043
00045 const MsgCategory MC_APP = MC_CONTEXT;
00046
00048 const MsgCategory MC_CONTROL        = 0x0004U;
00049
00051 const MsgCategory MC_WIN = MC_CONTROL;
00052
00054 const MsgCategory MC_FOCUS          = 0x0008U;
00055
00057 const MsgCategory MC_BROADCAST      = 0x0100U;
00058
00059
00060 // interprocess communication specific message classes (used internally)
00061
00064 const MsgCategory MC_IPC            = 0x0020U;
00065
00068 const MsgCategory MC_SIGNAL         = 0x0040U;
00069
00071 const MsgCategory MC_AT             = 0x0080U;
00072
00073 // obsolete message classes
00074
00077 const MsgCategory MC_STACK_CONTROL  = 0x0010U;
00078
00079 //ft_old const MsgCategory MC_FOCUS_TRANSFER = 0x1000U;
00080
00082 #endif // Kernel_MsgCategory_hpp
00083
00084
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgClass.hpp File Reference

Kernel/MsgClass.hpp File Reference

#include <Kernel/MsgCategory.hpp>

Include dependency graph for MsgClass.hpp:

Go to the source code of this file.

Defines

#define MsgClass MsgCategory

Define Documentation

#define MsgClass MsgCategory

Generated on Tue Jan 24 21:04:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgClass.hpp Source File

Kernel/MsgClass.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*  MsgClass has been renamed to MsgCategory to avoid confusion with the term 'class'.
00011     This header-file assures backward-compatibility for
00012     applications written with APOXI-versions smaller than 1.6.4 */
00013
00014 #define MsgClass MsgCategory
00015 #include <Kernel/MsgCategory.hpp>
00016
00017
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgQueue.cpp File Reference

Kernel/MsgQueue.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MsgQueue.hpp"
#include "Os/IsrDataManager.hpp"
#include "System.hpp"
#include <Auxiliary/Macros.hpp>
#include "Message.hpp"
#include "AppContainer.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgQueue.cpp:

Defines

#define | APOXI_MSG_QUEUE_YIELD_PERIOD 100

Variables

const UINT32 | c_msg_queue_yield_period = APOXI_MSG_QUEUE_YIELD_PERIOD

Define Documentation

#define APOXI_MSG_QUEUE_YIELD_PERIOD 100

Variable Documentation

const UINT32 c_msg_queue_yield_period = APOXI_MSG_QUEUE_YIELD_PERIOD

Generated on Tue Jan 24 21:04:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgQueue.hpp File Reference

Kernel/MsgQueue.hpp File Reference

#include <Auxiliary/FifoLinkedList.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/MessageReferrer.hpp>

Include dependency graph for MsgQueue.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MsgQueue
class | MsgQueue::QueueEntry

Defines

#define | Apoxi_MsgQueue_hpp

Define Documentation

#define Apoxi_MsgQueue_hpp

Generated on Tue Jan 24 21:04:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgQueue.hpp Source File

Kernel/MsgQueue.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_MsgQueue_hpp)
00010 #define Apoxi_MsgQueue_hpp
00013
00014 #include <Auxiliary/FifoLinkedList.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Kernel/MessageReferrer.hpp>
00017
00018 class Timer;
00019
00021 class MsgQueue {
00022     public:
00024         MsgQueue();
00025
00030         BOOLEAN Push(const MessageReferrer& msg_ref);
00031
00041         BOOLEAN Wait(MessageReferrer& msg_ref, Ticks timeout = Ticks::Infinite());
00042
00044         void TriggerIsrDataProcessing() { m_sem_wait.Release(); }
00045
00047         static BOOLEAN PushFocusMsg(const MessageReferrer& msg_ref);
00048
00052         static BOOLEAN PassBackFocusMsg(const MessageReferrer& msg_ref);
00053
00054         static void SetFocusMsgProcessingBlocked(BOOLEAN block) {
00055             DBG_OUT((122, "MsgQueue: blocking of MC_FOCUS messages %s\n", block ? "starts" : "stops"));
00056             m_block_focus_messages = block;
00057         }
00058
00059         static BOOLEAN IsFocusMsgProcessingBlocked() { return m_block_focus_messages; }
00060
00061     private:
00062         friend class AppContainer;
00063         friend class ServiceThread;
00064
00065         class QueueEntry : public Linkable<QueueEntry> {
00066             public:
00067                 QueueEntry(const MessageReferrer& msg_ref) : m_msg_ref(msg_ref) {}
00068                 const MessageReferrer& GetMessageReferrer() const { return m_msg_ref; }
00069
00070             private:
00071                 MessageReferrer m_msg_ref;
00072         };
00073
00074         static BOOLEAN m_block_focus_messages;
00075         static INT m_key_dn_count;
00076         static INT m_key_up_count;
00077         static Semaphore* m_sem_focus_list;
00078         static LinkedList<QueueEntry>* m_focus_list;
00079     #ifdef APOXI_COMPAT_2_0_0
00080         INT m_yield_count;
00081     #endif
00082         INT m_focus_entry_count;
00083         Semaphore m_sem_wait;
00084         Semaphore m_sem_list;
00085         FifoLinkedList<QueueEntry> m_list;
00086         Ticks m_next_yield;
00087
00088         MsgQueue(const MsgQueue& msg_queue);            // never implemented (non cloneable)
00089         MsgQueue& operator=(const MsgQueue& msg_queue); // never implemented (non cloneable)
00090
00091         BOOLEAN DeleteTimerTimeoutMsg(const Timer& timer);
00092
00093         static BOOLEAN PushFocusEntry(const MessageReferrer& msg_ref, BOOLEAN pass_back = FALSE);
00094         BOOLEAN PopFocusEntry(MessageReferrer& msg_ref);
00095         void Wakeup();
00096 };
00097
00099 #endif  // Apoxi_MsgQueue_hpp
00100
00101
Generated on Tue Jan 24 14:50:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgTypes.cpp File Reference

Kernel/MsgTypes.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MsgTypes.hpp"
#include <Gui/Action.hpp>

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgTypes.hpp File Reference

Kernel/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Kernel/Timer.hpp>
#include <Auxiliary/Time.hpp>
#include <Auxiliary/Date.hpp>
#include <Devices/Keyboard.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ActionExecutedMsg
class | AlarmNotificationMsg
class | AppCloseMsg
class | AppGetFocusMsg
class | AppLoseFocusMsg
class | AppOpenMsg
class | AppUpdateDisplayMsg
class | ContextExecuteMsg
class | ContextWakeupMsg
class | ExternalTimeoutMsg
class | FlipMsg
class | GetFocusMsg
class | InputCharMsg
class | ItemPropertiesChangedMsg
class | KeyAutoRepeatMsg
class | KeyDownMsg
class | KeyUpMsg
class | LanguageChangedMsg
class | LockedKeyDownMsg
class | LockedKeyMsg
class | LongKeyPressMsg
class | LoseFocusMsg
class | NoMessage
class | PenDownMsg
class | PenUpMsg
class | PowerOffMsg
class | PowerOnMsg
class | PowerWakeupMsg
class | RtcAlarmReachedMsg
class | RtcDateChangedMsg
class | RtcTimeChangedMsg
class | ServiceThreadTerminateMsg
class | SharedTimerMsg
class | ShutdownRequestMsg
class | ThemeChangedMsg
class | ThreadletNotificationMsg
class | TimerTimeoutMsg
class | VeryLongKeyPressMsg

Defines

#define | Kernel_MsgTypes_hpp

Typedefs

typedef ItemPropertiesChangedMsg | ActionPropertiesChangedMsg

Define Documentation

#define Kernel_MsgTypes_hpp

Typedef Documentation

typedef ItemPropertiesChangedMsg ActionPropertiesChangedMsg

Generated on Tue Jan 24 14:56:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/MsgTypes.hpp Source File

Kernel/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "src\views\wickhara_apoxitest_pu_sv\lnz_apoxi\Apoxi\Kernel\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(Kernel_MsgTypes_hpp)
00017 #define Kernel_MsgTypes_hpp
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Kernel/Timer.hpp>
00021 #include <Auxiliary/Time.hpp>
00022 #include <Auxiliary/Date.hpp>
00023 #include <Devices/Keyboard.hpp>
00024
00025
00026 class Threadlet;
00027 class Item;
00028 class Action;
00029 class ExecutionContext;
00030
00031 /* ----------------------------------------------------------------------
00032     Classes
00033     ---------------------------------------------------------------------- */
00034
00035 /*  ======================================================================
00036     Class NoMessage
00037     ====================================================================== */
00038
00040 class NoMessage : public Message {
00041     public:
00042         NoMessage();
00043         virtual ~NoMessage();
00044
00045         virtual const MsgMetaData& GetMetaData() const;
00046         virtual Message* Clone() const;
00047
00048         enum  {
00049             ID = 0
00050             };
00051
00052     private:
00053         static const MsgMetaData m_meta_data;
00054
00055     };
00056
00057
00058 /*  ======================================================================
00059     Class PowerOnMsg
00060     ====================================================================== */
00061
00062 class PowerOnMsg : public Message {
00063     public:
00064         PowerOnMsg();
00065         virtual ~PowerOnMsg();
00066
00067         virtual const MsgMetaData& GetMetaData() const;
00068         virtual Message* Clone() const;
00069
00070         enum  {
00071             ID = 1
00072             };
00073
00074     private:
00075         static const MsgMetaData m_meta_data;
00076
00077     };
00078
00079
00080 /*  ======================================================================
00081     Class PowerOffMsg
00082     ====================================================================== */
00083
00084 class PowerOffMsg : public Message {
00085     public:
00086         PowerOffMsg();
00087         virtual ~PowerOffMsg();
00088
00089         virtual const MsgMetaData& GetMetaData() const;
00090         virtual Message* Clone() const;
00091
00092         enum  {
00093             ID = 2
00094             };
00095
00096     private:
00097         static const MsgMetaData m_meta_data;
00098
00099     };
00100
00101
00102 /*  ======================================================================
00103     Class AppOpenMsg
00104     ====================================================================== */
00105
00108 class AppOpenMsg : public Message {
00109     public:
00110         AppOpenMsg();
00111         virtual ~AppOpenMsg();
00112
00113         virtual const MsgMetaData& GetMetaData() const;
00114         virtual Message* Clone() const;
00115
00116         enum  {
00117             ID = 100
00118             };
00119
00120     private:
00121         static const MsgMetaData m_meta_data;
00122
00123     };
00124
00125
00126 /*  ======================================================================
00127     Class AppCloseMsg
00128     ====================================================================== */
00129
00132 class AppCloseMsg : public Message {
00133     public:
00134         AppCloseMsg();
00135         virtual ~AppCloseMsg();
00136
00137         virtual const MsgMetaData& GetMetaData() const;
00138         virtual Message* Clone() const;
00139
00140         enum  {
00141             ID = 101
00142             };
00143
00144     private:
00145         static const MsgMetaData m_meta_data;
00146
00147     };
00148
00149
00150 /*  ======================================================================
00151     Class AppUpdateDisplayMsg
00152     ====================================================================== */
00153
00156 class AppUpdateDisplayMsg : public Message {
00157     public:
00158         AppUpdateDisplayMsg();
00159         virtual ~AppUpdateDisplayMsg();
00160
00161         virtual const MsgMetaData& GetMetaData() const;
00162         virtual Message* Clone() const;
00163
00164         enum  {
00165             ID = 107
00166             };
00167
00168     private:
00169         static const MsgMetaData m_meta_data;
00170
00171     };
00172
00173
00174 /*  ======================================================================
00175     Class ThemeChangedMsg
00176     ====================================================================== */
00177
00179 class ThemeChangedMsg : public Message {
00180     public:
00181         ThemeChangedMsg();
00182         virtual ~ThemeChangedMsg();
00183
00184         virtual const MsgMetaData& GetMetaData() const;
00185         virtual Message* Clone() const;
00186
00187         enum  {
00188             ID = 120
00189             };
00190
00191     private:
00192         static const MsgMetaData m_meta_data;
00193
00194     };
00195
00196
00197 /*  ======================================================================
00198     Class LanguageChangedMsg
00199     ====================================================================== */
00200
00202 class LanguageChangedMsg : public Message {
00203     public:
00204         LanguageChangedMsg();
00205         virtual ~LanguageChangedMsg();
00206
00207         virtual const MsgMetaData& GetMetaData() const;
00208         virtual Message* Clone() const;
00209
00210         enum  {
00211             ID = 121
00212             };
00213
00214     private:
00215         static const MsgMetaData m_meta_data;
00216
00217     };
00218
00219
00220 /*  ======================================================================
00221     Class PowerWakeupMsg
00222     ====================================================================== */
00223
00226 class PowerWakeupMsg : public Message {
00227     public:
00228         PowerWakeupMsg();
00229         virtual ~PowerWakeupMsg();
00230
00231         virtual const MsgMetaData& GetMetaData() const;
00232         virtual Message* Clone() const;
00233
00234         enum  {
00235             ID = 130
00236             };
00237
00238     private:
00239         static const MsgMetaData m_meta_data;
00240
00241     };
00242
00243
00244 /*  ======================================================================
00245     Class KeyDownMsg
00246     ====================================================================== */
00247
00253 class KeyDownMsg : public Message {
00254     public:
00255         KeyDownMsg(const KeyCode& key_code);
00256         virtual ~KeyDownMsg();
00257
00258         virtual const MsgMetaData& GetMetaData() const;
00259         void SetKeyCode(const KeyCode& key_code) { m_key_code = key_code; }
00260         const KeyCode& GetKeyCode() const { return m_key_code; }
00261         virtual Message* Clone() const;
00262
00263         enum  {
00264             ID = 200
00265             };
00266
00267     private:
00268         static const MsgMetaData m_meta_data;
00269         KeyCode m_key_code;
00270
00271     };
00272
00273
00274 /*  ======================================================================
00275     Class KeyUpMsg
00276     ====================================================================== */
00277
00287 class KeyUpMsg : public Message {
00288     public:
00289         KeyUpMsg(const KeyCode& key_code = 0, UINT32 duration = 0);
00290         virtual ~KeyUpMsg();
00291
00292         virtual const MsgMetaData& GetMetaData() const;
00293         void SetKeyCode(const KeyCode& key_code) { m_key_code = key_code; }
00294         const KeyCode& GetKeyCode() const { return m_key_code; }
00295         void SetDuration(UINT32 duration) { m_duration = duration; }
00296         UINT32 GetDuration() const { return m_duration; }
00297         virtual Message* Clone() const;
00298
00299         enum  {
00300             ID = 201
00301             };
00302
00303     private:
00304         static const MsgMetaData m_meta_data;
00305         KeyCode m_key_code;
00306         UINT32 m_duration;
00307
00308     };
00309
00310
00311 /*  ======================================================================
00312     Class LongKeyPressMsg
00313     ====================================================================== */
00314
00317 class LongKeyPressMsg : public Message {
00318     public:
00319         LongKeyPressMsg(const KeyCode& key_code);
00320         virtual ~LongKeyPressMsg();
00321
00322         virtual const MsgMetaData& GetMetaData() const;
00323         void SetKeyCode(const KeyCode& key_code) { m_key_code = key_code; }
00324         const KeyCode& GetKeyCode() const { return m_key_code; }
00325         virtual Message* Clone() const;
00326
00327         enum  {
00328             ID = 202
00329             };
00330
00331     private:
00332         static const MsgMetaData m_meta_data;
00333         KeyCode m_key_code;
00334
00335     };
00336
00337
00338 /*  ======================================================================
00339     Class VeryLongKeyPressMsg
00340     ====================================================================== */
00341
00344 class VeryLongKeyPressMsg : public Message {
00345     public:
00346         VeryLongKeyPressMsg(const KeyCode& key_code);
00347         virtual ~VeryLongKeyPressMsg();
00348
00349         virtual const MsgMetaData& GetMetaData() const;
00350         void SetKeyCode(const KeyCode& key_code) { m_key_code = key_code; }
00351         const KeyCode& GetKeyCode() const { return m_key_code; }
00352         virtual Message* Clone() const;
00353
00354         enum  {
00355             ID = 203
00356             };
00357
00358     private:
00359         static const MsgMetaData m_meta_data;
00360         KeyCode m_key_code;
00361
00362     };
00363
00364
00365 /*  ======================================================================
00366     Class KeyAutoRepeatMsg
00367     ====================================================================== */
00368
00373 class KeyAutoRepeatMsg : public Message {
00374     public:
00375         KeyAutoRepeatMsg(const KeyCode& key_code);
00376         virtual ~KeyAutoRepeatMsg();
00377
00378         virtual const MsgMetaData& GetMetaData() const;
00379         void SetKeyCode(const KeyCode& key_code) { m_key_code = key_code; }
00380         const KeyCode& GetKeyCode() const { return m_key_code; }
00381         virtual Message* Clone() const;
00382
00383         enum  {
00384             ID = 204
00385             };
00386
00387     private:
00388         static const MsgMetaData m_meta_data;
00389         KeyCode m_key_code;
00390
00391     };
00392
00393
00394 /*  ======================================================================
00395     Class FlipMsg
00396     ====================================================================== */
00397
00398 class FlipMsg : public Message {
00399     public:
00400         FlipMsg(BOOLEAN flip_open);
00401         virtual ~FlipMsg();
00402
00403         virtual const MsgMetaData& GetMetaData() const;
00404         BOOLEAN IsFlipOpen() const { return m_flip_open; }
00405         virtual Message* Clone() const;
00406
00407         enum  {
00408             ID = 205
00409             };
00410
00411     private:
00412         static const MsgMetaData m_meta_data;
00413         BOOLEAN m_flip_open;
00414
00415     };
00416
00417
00418 /*  ======================================================================
00419     Class LockedKeyDownMsg
00420     ====================================================================== */
00421
00427 class LockedKeyDownMsg : public Message {
00428     public:
00429         LockedKeyDownMsg(const KeyCode& key_code);
00430         virtual ~LockedKeyDownMsg();
00431
00432         virtual const MsgMetaData& GetMetaData() const;
00433         void SetKeyCode(const KeyCode& key_code) { m_key_code = key_code; }
00434         const KeyCode& GetKeyCode() const { return m_key_code; }
00435         virtual Message* Clone() const;
00436
00437         enum  {
00438             ID = 210
00439             };
00440
00441     private:
00442         static const MsgMetaData m_meta_data;
00443         KeyCode m_key_code;
00444
00445     };
00446
00447
00448 /*  ======================================================================
00449     Class LockedKeyMsg
00450     ====================================================================== */
00451
00457 class LockedKeyMsg : public Message {
00458     public:
00459         LockedKeyMsg(const Keyboard::Flag& flag, const KeyCode& key_code);
00460         virtual ~LockedKeyMsg();
00461
00462         virtual const MsgMetaData& GetMetaData() const;
00463         const Keyboard::Flag& GetFlag() const { return m_flag; }
00464         const KeyCode& GetKeyCode() const { return m_key_code; }
00465         virtual Message* Clone() const;
00466
00467         enum  {
00468             ID = 211
00469             };
00470
00471     private:
00472         static const MsgMetaData m_meta_data;
00473         Keyboard::Flag m_flag;
00474         KeyCode m_key_code;
00475
00476     };
00477
00478
00479 /*  ======================================================================
00480     Class InputCharMsg
00481     ====================================================================== */
00482
00483 class InputCharMsg : public Message {
00484     public:
00485         InputCharMsg(WCHAR character);
00486         virtual ~InputCharMsg();
00487
00488         virtual const MsgMetaData& GetMetaData() const;
00489         void SetCharacter(WCHAR character) { m_character = character; }
00490         WCHAR GetCharacter() const { return m_character; }
00491         virtual Message* Clone() const;
00492
00493         enum  {
00494             ID = 220
00495             };
00496
00497     private:
00498         static const MsgMetaData m_meta_data;
00499         WCHAR m_character;
00500
00501     };
00502
00503
00504 /*  ======================================================================
00505     Class PenDownMsg
00506     ====================================================================== */
00507
00510 class PenDownMsg : public Message {
00511     public:
00512         PenDownMsg(XYDIM pos_x, XYDIM pos_y);
00513         virtual ~PenDownMsg();
00514
00515         virtual const MsgMetaData& GetMetaData() const;
00516         void SetPosX(XYDIM pos_x) { m_pos_x = pos_x; }
00517         XYDIM GetPosX() const { return m_pos_x; }
00518         void SetPosY(XYDIM pos_y) { m_pos_y = pos_y; }
00519         XYDIM GetPosY() const { return m_pos_y; }
00520         virtual Message* Clone() const;
00521
00522         enum  {
00523             ID = 240
00524             };
00525
00526     private:
00527         static const MsgMetaData m_meta_data;
00528         XYDIM m_pos_x;
00529         XYDIM m_pos_y;
00530
00531     };
00532
00533
00534 /*  ======================================================================
00535     Class PenUpMsg
00536     ====================================================================== */
00537
00540 class PenUpMsg : public Message {
00541     public:
00542         PenUpMsg(XYDIM pos_x, XYDIM pos_y);
00543         virtual ~PenUpMsg();
00544
00545         virtual const MsgMetaData& GetMetaData() const;
00546         void SetPosX(XYDIM pos_x) { m_pos_x = pos_x; }
00547         XYDIM GetPosX() const { return m_pos_x; }
00548         void SetPosY(XYDIM pos_y) { m_pos_y = pos_y; }
00549         XYDIM GetPosY() const { return m_pos_y; }
00550         virtual Message* Clone() const;
00551
00552         enum  {
00553             ID = 241
00554             };
00555
00556     private:
00557         static const MsgMetaData m_meta_data;
00558         XYDIM m_pos_x;
00559         XYDIM m_pos_y;
00560
00561     };
00562
00563
00564 /*  ======================================================================
00565     Class ExternalTimeoutMsg
00566     ====================================================================== */
00567
00571 class ExternalTimeoutMsg : public Message {
00572     public:
00573         ExternalTimeoutMsg(Timer* timer);
00574         virtual ~ExternalTimeoutMsg();
00575
00576         virtual const MsgMetaData& GetMetaData() const;
00577         void SetTimer(Timer* timer) { m_timer = timer; }
00578         Timer* GetTimer() const { return m_timer; }
00579         virtual Message* Clone() const;
00580
00581         enum  {
00582             ID = 301
00583             };
00584
00585     private:
00586         static const MsgMetaData m_meta_data;
00587         Timer* m_timer;
00588
00589     };
00590
00591
00592 /*  ======================================================================
00593     Class ItemPropertiesChangedMsg
00594     ====================================================================== */
00595
00598     class ItemPropertiesChangedMsg : public Message {
00599     public:
00600         ItemPropertiesChangedMsg(Item* item, INT property_id);
00601         virtual ~ItemPropertiesChangedMsg();
00602
00603         virtual const MsgMetaData& GetMetaData() const;
00604         Item* GetItem() const { return m_item; }
00605         INT GetPropertyId() const { return m_property_id; }
00606         virtual Message* Clone() const;
00608         Action* GetAction() const;
00609
00610         enum  {
00611             ID = 302
00612             };
00613
00614     private:
00615         static const MsgMetaData m_meta_data;
00616         Item* m_item;
00617         INT m_property_id;
00618
00619     };
00620
00621
00622 /*  ======================================================================
00623     Class ActionExecutedMsg
00624     ====================================================================== */
00625
00628 class ActionExecutedMsg : public Message {
00629     public:
00630         ActionExecutedMsg(Action* action);
00631         virtual ~ActionExecutedMsg();
00632
00633         virtual const MsgMetaData& GetMetaData() const;
00634         Action* GetAction() const { return m_action; }
00635         virtual Message* Clone() const;
00636
00637         enum  {
00638             ID = 303
00639             };
00640
00641     private:
00642         static const MsgMetaData m_meta_data;
00643         Action* m_action;
00644
00645     };
00646
00647
00648 /*  ======================================================================
00649     Class RtcTimeChangedMsg
00650     ====================================================================== */
00651
00653 class RtcTimeChangedMsg : public Message {
00654     public:
00655         RtcTimeChangedMsg();
00656         virtual ~RtcTimeChangedMsg();
00657
00658         virtual const MsgMetaData& GetMetaData() const;
00659         virtual Message* Clone() const;
00660
00661         enum  {
00662             ID = 2911
00663             };
00664
00665     private:
00666         static const MsgMetaData m_meta_data;
00667
00668     };
00669
00670
00671 /*  ======================================================================
00672     Class RtcDateChangedMsg
00673     ====================================================================== */
00674
00675 class RtcDateChangedMsg : public Message {
00676     public:
00677         RtcDateChangedMsg();
00678         virtual ~RtcDateChangedMsg();
00679
00680         virtual const MsgMetaData& GetMetaData() const;
00681         virtual Message* Clone() const;
00682
00683         enum  {
00684             ID = 2912
00685             };
00686
00687     private:
00688         static const MsgMetaData m_meta_data;
00689
00690     };
00691
00692
00693 /*  ======================================================================
00694     Class RtcAlarmReachedMsg
00695     ====================================================================== */
00696
00697 class RtcAlarmReachedMsg : public Message {
00698     public:
00699         RtcAlarmReachedMsg();
00700         virtual ~RtcAlarmReachedMsg();
00701
00702         virtual const MsgMetaData& GetMetaData() const;
00703         virtual Message* Clone() const;
00704
00705         enum  {
00706             ID = 2913
00707             };
00708
00709     private:
00710         static const MsgMetaData m_meta_data;
00711
00712     };
00713
00714
00715 /*  ======================================================================
00716     Class ServiceThreadTerminateMsg
00717     ====================================================================== */
00718
00720 class ServiceThreadTerminateMsg : public ContextMsg {
00721     public:
00722         ServiceThreadTerminateMsg(ExecutionContext* context);
00723         virtual ~ServiceThreadTerminateMsg();
00724
00725         virtual const MsgMetaData& GetMetaData() const;
00726         virtual Message* Clone() const;
00727
00728         enum  {
00729             ID = 102
00730             };
00731
00732     private:
00733         static const MsgMetaData m_meta_data;
00734
00735     };
00736
00737
00738 /*  ======================================================================
00739     Class AppGetFocusMsg
00740     ====================================================================== */
00741
00743 class AppGetFocusMsg : public ContextMsg {
00744     public:
00745         AppGetFocusMsg(ExecutionContext* context);
00746         virtual ~AppGetFocusMsg();
00747
00748         virtual const MsgMetaData& GetMetaData() const;
00749         virtual Message* Clone() const;
00750
00751         enum  {
00752             ID = 105
00753             };
00754
00755     private:
00756         static const MsgMetaData m_meta_data;
00757
00758     };
00759
00760
00761 /*  ======================================================================
00762     Class AppLoseFocusMsg
00763     ====================================================================== */
00764
00766 class AppLoseFocusMsg : public ContextMsg {
00767     public:
00768         AppLoseFocusMsg(ExecutionContext* context);
00769         virtual ~AppLoseFocusMsg();
00770
00771         virtual const MsgMetaData& GetMetaData() const;
00772         virtual Message* Clone() const;
00773
00774         enum  {
00775             ID = 106
00776             };
00777
00778     private:
00779         static const MsgMetaData m_meta_data;
00780
00781     };
00782
00783
00784 /*  ======================================================================
00785     Class SharedTimerMsg
00786     ====================================================================== */
00787
00790 class SharedTimerMsg : public ContextMsg {
00791     public:
00792         SharedTimerMsg(ExecutionContext* context, INT arg);
00793         virtual ~SharedTimerMsg();
00794
00795         virtual const MsgMetaData& GetMetaData() const;
00796         INT GetArg() const { return m_arg; }
00797         virtual Message* Clone() const;
00798
00799         enum  {
00800             ID = 108
00801             };
00802
00803     private:
00804         static const MsgMetaData m_meta_data;
00805         INT m_arg;
00806
00807     };
00808
00809
00810 /*  ======================================================================
00811     Class ThreadletNotificationMsg
00812     ====================================================================== */
00813
00816 class ThreadletNotificationMsg : public ContextMsg {
00817     public:
00818         ThreadletNotificationMsg(ExecutionContext* context, Threadlet* threadlet);
00819         virtual ~ThreadletNotificationMsg();
00820
00821         virtual const MsgMetaData& GetMetaData() const;
00822         Threadlet* GetThreadlet() const { return m_threadlet; }
00823         virtual Message* Clone() const;
00824
00825         enum  {
00826             ID = 109
00827             };
00828
00829     private:
00830         static const MsgMetaData m_meta_data;
00831         Threadlet* m_threadlet;
00832
00833     };
00834
00835
00836 /*  ======================================================================
00837     Class ContextWakeupMsg
00838     ====================================================================== */
00839
00842 class ContextWakeupMsg : public ContextMsg {
00843     public:
00844         ContextWakeupMsg(ExecutionContext* context);
00845         virtual ~ContextWakeupMsg();
00846
00847         virtual const MsgMetaData& GetMetaData() const;
00848         virtual Message* Clone() const;
00849
00850         enum  {
00851             ID = 110
00852             };
00853
00854     private:
00855         static const MsgMetaData m_meta_data;
00856
00857     };
00858
00859
00860 /*  ======================================================================
00861     Class ShutdownRequestMsg
00862     ====================================================================== */
00863
00866 class ShutdownRequestMsg : public ContextMsg {
00867     public:
00868         ShutdownRequestMsg(ExecutionContext* context);
00869         virtual ~ShutdownRequestMsg();
00870
00871         virtual const MsgMetaData& GetMetaData() const;
00872         virtual Message* Clone() const;
00873
00874         enum  {
00875             ID = 111
00876             };
00877
00878     private:
00879         static const MsgMetaData m_meta_data;
00880
00881     };
00882
00883
00884 /*  ======================================================================
00885     Class AlarmNotificationMsg
00886     ====================================================================== */
00887
00889 class AlarmNotificationMsg : public ContextMsg {
00890     public:
00891         AlarmNotificationMsg(ExecutionContext* context);
00892         virtual ~AlarmNotificationMsg();
00893
00894         virtual const MsgMetaData& GetMetaData() const;
00895         virtual Message* Clone() const;
00896
00897         enum  {
00898             ID = 112
00899             };
00900
00901     private:
00902         static const MsgMetaData m_meta_data;
00903
00904     };
00905
00906
00907 /*  ======================================================================
00908     Class TimerTimeoutMsg
00909     ====================================================================== */
00910
00914 class TimerTimeoutMsg : public ContextMsg {
00915     public:
00916         TimerTimeoutMsg(ExecutionContext* context, Timer* timer);
00917         virtual ~TimerTimeoutMsg();
00918
00919         virtual const MsgMetaData& GetMetaData() const;
00920         void SetTimer(Timer* timer) { m_timer = timer; }
00921         Timer* GetTimer() const { return m_timer; }
00922         virtual Message* Clone() const;
00923
00924         enum  {
00925             ID = 300
00926             };
00927
00928     private:
00929         static const MsgMetaData m_meta_data;
00930         Timer* m_timer;
00931
00932     };
00933
00934
00935 /*  ======================================================================
00936     Class ContextExecuteMsg
00937     ====================================================================== */
00938
00942 class ContextExecuteMsg : public ContextMsg {
00943     public:
00944         typedef void (*CallbackFn)(void*);
00945         ContextExecuteMsg(ExecutionContext* context, const CallbackFn fn = 0, void* arg = 0);
00946         virtual ~ContextExecuteMsg();
00947
00948         virtual const MsgMetaData& GetMetaData() const;
00949         virtual void Execute();
00950         virtual Message* Clone() const;
00951
00952         enum  {
00953             ID = 3000
00954             };
00955
00956     private:
00957         static const MsgMetaData m_meta_data;
00958         CallbackFn m_fn;
00959         void* m_arg;
00960
00961     };
00962
00963
00964 /*  ======================================================================
00965     Class GetFocusMsg
00966     ====================================================================== */
00967
00969 class GetFocusMsg : public ControlMsg {
00970     public:
00971         GetFocusMsg(Control* control);
00972         virtual ~GetFocusMsg();
00973
00974         virtual const MsgMetaData& GetMetaData() const;
00975         virtual Message* Clone() const;
00976
00977         enum  {
00978             ID = 1000
00979             };
00980
00981     private:
00982         static const MsgMetaData m_meta_data;
00983
00984     };
00985
00986
00987 /*  ======================================================================
00988     Class LoseFocusMsg
00989     ====================================================================== */
00990
00992 class LoseFocusMsg : public ControlMsg {
00993     public:
00994         LoseFocusMsg(Control* control);
00995         virtual ~LoseFocusMsg();
00996
00997         virtual const MsgMetaData& GetMetaData() const;
00998         virtual Message* Clone() const;
00999
01000         enum  {
01001             ID = 1001
01002             };
01003
01004     private:
01005         static const MsgMetaData m_meta_data;
01006
01007     };
01008
01009 typedef ItemPropertiesChangedMsg ActionPropertiesChangedMsg;
01010
01011 #endif // Kernel_MsgTypes_hpp
01012
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/OutputStream.hpp File Reference

Kernel/OutputStream.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 20:21:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/OutputStream.hpp Source File

Kernel/OutputStream.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if defined(APOXI_COMPILER_MSVC)
00010     #pragma message("Reference to old Kernel/OutputStream.hpp. Please use " \
00011         "Compat/OutputStream.hpp instead.")
00012 #endif
00013
00014 #if defined(APOXI_COMPAT_2_0_0)
00015     // Kernel/OutputStream.hpp moved to Compat.
00016     #include <Compat/OutputStream.hpp>
00017 #endif
00018
00019
Generated on Tue Jan 24 14:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/PreComp.cpp File Reference

Kernel/PreComp.cpp File Reference

#include "Kernel/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:07:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/PreComp.hpp File Reference

Kernel/PreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/Macros.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/FifoLinkedList.hpp>
#include <Auxiliary/ElementList.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Auxiliary/BinarySearch.hpp>
#include <Auxiliary/Time.hpp>
#include <Auxiliary/NonCloneable.hpp>
#include <Devices/AbstractDevice.hpp>
#include <Kernel/AppContainer.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/System.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:22:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/PreComp.hpp Source File

Kernel/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Auxiliary/Macros.hpp>
00011 #include <Auxiliary/LinkedList.hpp>
00012 #include <Auxiliary/FifoLinkedList.hpp>
00013 #include <Auxiliary/ElementList.hpp>
00014 #include <Auxiliary/Linkable.hpp>
00015 #include <Auxiliary/BinarySearch.hpp>
00016 #include <Auxiliary/Time.hpp>
00017 #include <Auxiliary/NonCloneable.hpp>
00018 #include <Devices/AbstractDevice.hpp>
00019 #include <Kernel/AppContainer.hpp>
00020 #include <Kernel/Application.hpp>
00021 #include <Kernel/Condition.hpp>
00022 #include <Kernel/ExecutionContext.hpp>
00023 #include <Kernel/MsgTypes.hpp>
00024 #include <Kernel/Message.hpp>
00025 #include <Kernel/MessageRouter.hpp>
00026 #include <Kernel/System.hpp>
00027
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/RuntimeConfigurator.cpp File Reference

Kernel/RuntimeConfigurator.cpp File Reference

#include "Kernel/PreComp.hpp"

Include dependency graph for RuntimeConfigurator.cpp:

Generated on Tue Jan 24 23:17:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/RuntimeConfigurator.hpp File Reference

Kernel/RuntimeConfigurator.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_RuntimeConfigurator_hpp

Define Documentation

#define Apoxi_RuntimeConfigurator_hpp

Generated on Tue Jan 24 23:17:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/RuntimeConfigurator.hpp Source File

Kernel/RuntimeConfigurator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_RuntimeConfigurator_hpp)
00010 #define Apoxi_RuntimeConfigurator_hpp
00013
00014 #if defined(APOXI_ENABLE_RUNTIME_CONFIGURATION)
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Auxiliary/String.hpp>
00018 #include <Kernel/Os/Semaphore.hpp>
00019 #include <Auxiliary/SimpleMap.hpp>
00020
00043 class RuntimeConfigurator {
00044     public:
00046         typedef BOOLEAN (*CallBackFn)(const String&);
00047
00049         static RuntimeConfigurator& GetInstance();
00050
00055         BOOLEAN Parse(const String& str);
00056
00062         BOOLEAN Register(const String& command_str, CallBackFn fn);
00063
00068         BOOLEAN Unregister(const String& command_str);
00069
00070     private:
00071         Semaphore m_sem;
00072         SimpleMap<String, CallBackFn> m_map;
00073 };
00074
00075 #endif  // APOXI_ENABLE_RUNTIME_CONFIGURATION
00076
00078 #endif  // Apoxi_RuntimeConfigurator_hpp
00079
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ServiceThread.cpp File Reference

Kernel/ServiceThread.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "ServiceThread.hpp"
#include "System.hpp"
#include "MsgCategory.hpp"
#include "Message.hpp"
#include "Condition.hpp"
#include "MsgTypes.hpp"
#include "MessageRouter.hpp"

Include dependency graph for ServiceThread.cpp:

Generated on Tue Jan 24 23:17:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ServiceThread.hpp File Reference

Kernel/ServiceThread.hpp File Reference

#include <Kernel/ApoxiThread.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/MsgQueue.hpp>
#include <Kernel/Timer.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for ServiceThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ServiceThread
Class ServiceThread is used to implement services, i.e. tasks which perform permanent background activity like network services. A service thread does not need any graphical user interface but needs to run as an own thread. It only always awakes from idle when it receives a message or when a timer expires. To handle the message overwrite method OnMessage(). For an automated start-up and shut-down of the service thread use class ServiceThreadStarter. More...

Defines

#define | Apoxi_ServiceThread_hpp

Define Documentation

#define Apoxi_ServiceThread_hpp

Generated on Tue Jan 24 23:17:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ServiceThread.hpp Source File

Kernel/ServiceThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ServiceThread_hpp)
00011 #define Apoxi_ServiceThread_hpp
00012
00015
00016 #include <Kernel/ApoxiThread.hpp>
00017 #include <Kernel/ExecutionContext.hpp>
00018 #include <Kernel/MsgQueue.hpp>
00019 #include <Kernel/Timer.hpp>
00020 #include <Auxiliary/Vector.hpp>
00021
00051 class ServiceThread : private ApoxiThread, public ExecutionContext {
00052     typedef ApoxiThread Base;
00053
00054     public:
00056         ServiceThread();
00057
00059         virtual ~ServiceThread();
00060
00062         BOOLEAN Run(UINT32 stacksize = 4096, void *stack = 0);
00063
00067         void Stop(INT exit_code = 0);
00068
00070         virtual ExecutionContext::Type GetType() const;
00071
00073         virtual void RegisterMessage(MsgId msg_id);
00074
00076         virtual void UnregisterMessage(MsgId msg_id);
00077
00078         using Base::GetPriority;
00079         using Base::SetPriority;
00080         using Base::IncreasePriority;
00081         using Base::DecreasePriority;
00082
00083         using Base::Terminate;
00084
00085     protected:
00086         virtual BOOLEAN AcceptMsg(const Message& msg);
00087
00088         virtual BOOLEAN HandleMsg(const MessageReferrer& msg_ref);
00089
00090         virtual void AddTimer(Timer& timer);
00091
00092         virtual void RemoveTimer(Timer& timer);
00093
00095         virtual void OnPowerUp();
00096
00098         virtual void OnPowerDown();
00099
00101         virtual BOOLEAN OnMessage(const Message& msg);
00102
00104         virtual BOOLEAN OnTimeout(const Timer& timer);
00105
00106     private:
00107         friend class StartUp;
00108
00109         BOOLEAN m_running;
00110         INT m_exit_code;
00111         MsgQueue m_msg_queue;
00112         Vector<MsgId> m_msg_registration;
00113         TimerList m_timer_list;
00114
00115         virtual ExecutionContext& GetContext();
00116         virtual const ExecutionContext& GetContext() const;
00117
00118         virtual void DoWait(const Condition& cond);
00119
00120         virtual INT ThreadFn();
00121
00122         void WaitForMessageOrTimer();
00123         void RouteMessage(Message& msg);
00124 };
00125
00127 #endif  // Apoxi_ServiceThread_hpp
00128
00129
Generated on Tue Jan 24 14:50:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ServiceThreadStarter.cpp File Reference

Kernel/ServiceThreadStarter.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "ServiceThreadStarter.hpp"
#include "ServiceThread.hpp"

Include dependency graph for ServiceThreadStarter.cpp:

Generated on Tue Jan 24 23:17:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ServiceThreadStarter.hpp File Reference

Kernel/ServiceThreadStarter.hpp File Reference

#include <Kernel/SubSystem.hpp>
#include <Kernel/SubSystemManager.hpp>

Include dependency graph for ServiceThreadStarter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ServiceThreadStarter
struct | ServiceThreadStarter::StartParam

Defines

#define | Apoxi_ServiceThreadStarter_hpp

Define Documentation

#define Apoxi_ServiceThreadStarter_hpp

Generated on Tue Jan 24 23:17:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/ServiceThreadStarter.hpp Source File

Kernel/ServiceThreadStarter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ServiceThreadStarter_hpp)
00011 #define Apoxi_ServiceThreadStarter_hpp
00012
00015
00016 #include <Kernel/SubSystem.hpp>
00017 #include <Kernel/SubSystemManager.hpp>
00018
00019 class ServiceThread;
00020
00030 class  ServiceThreadStarter : private SubSystem {
00031     public:
00033         struct StartParam {
00034             INT priority;
00035             UINT32 stacksize;
00036             void* stack;
00037             SubSystemManager::BootSequenceState run_level;
00038         };
00039
00042         ServiceThreadStarter(ServiceThread& service_thread, StartParam* param = 0);
00043         virtual ~ServiceThreadStarter();
00044
00045     private:
00046         ServiceThread& m_service_thread;
00047         StartParam* m_param;
00048
00049         virtual const WCHAR* GetName() const;
00050         virtual void OnPowerUp();
00051         virtual void OnPowerDown();
00052         virtual BootSequenceState InvokeAt() const;
00053 };
00054
00056 #endif  // Apoxi_ServiceThreadStarter_hpp
00057
Generated on Tue Jan 24 14:50:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SimpleScheduler.cpp File Reference

Kernel/SimpleScheduler.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "AppContainer.hpp"
#include "SimpleScheduler.hpp"
#include "Condition.hpp"
#include "Application.hpp"

Include dependency graph for SimpleScheduler.cpp:

Generated on Tue Jan 24 23:17:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SimpleScheduler.hpp File Reference

Kernel/SimpleScheduler.hpp File Reference

#include <Kernel/AbstractScheduler.hpp>

Include dependency graph for SimpleScheduler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimpleAppContext
class | SimpleScheduler

Defines

#define | Apoxi_SimpleScheduler_hpp

Define Documentation

#define Apoxi_SimpleScheduler_hpp

Generated on Tue Jan 24 23:17:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SimpleScheduler.hpp Source File

Kernel/SimpleScheduler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SimpleScheduler_hpp)
00010 #define Apoxi_SimpleScheduler_hpp
00013
00014 #include <Kernel/AbstractScheduler.hpp>
00015
00023 class SimpleScheduler : public AbstractScheduler {
00024
00025     public:
00026         typedef AbstractScheduler Base;
00027
00029         SimpleScheduler(AppContainer* cont);
00030
00032         virtual ~SimpleScheduler();
00033
00036         virtual AbstractAppContext* CreateAppContext(Application* app);
00037
00039         virtual void StartUp();
00040
00044         virtual void SendMsg(const Application* app, Message& msg);
00045
00047         virtual void Reschedule();
00048
00053         virtual void Wait(const Application* app, const Condition& cond);
00054 };
00055
00056
00059 class SimpleAppContext : public AbstractAppContext {
00060     public:
00061         typedef AbstractAppContext Base;
00062
00065         SimpleAppContext(SimpleScheduler* scheduler, Application* app);
00066
00068         virtual ~SimpleAppContext();
00069
00071         virtual void StartUp();
00072
00074         virtual void MsgLoop();
00075
00079         virtual void SendMsg(Message& msg);
00080
00083         virtual void Wait(const Condition& cond);
00084 };
00085
00087 #endif
00088
00089
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SubSystem.cpp File Reference

Kernel/SubSystem.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SubSystem.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for SubSystem.cpp:

Generated on Tue Jan 24 23:17:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SubSystem.hpp File Reference

Kernel/SubSystem.hpp File Reference

#include <Kernel/SubSystemManager.hpp>

Include dependency graph for SubSystem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SubSystem

Defines

#define | Apoxi_SubSystem_hpp

Define Documentation

#define Apoxi_SubSystem_hpp

Generated on Tue Jan 24 23:17:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SubSystem.hpp Source File

Kernel/SubSystem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_SubSystem_hpp)
00012 #define Apoxi_SubSystem_hpp
00015
00016 #include <Kernel/SubSystemManager.hpp>
00017
00018 /*  -------------------------------------------------------------------------
00019                                     Types
00020     ------------------------------------------------------------------------- */
00021
00032 class SubSystem {
00033     public:
00034         typedef SubSystemManager::BootSequenceState BootSequenceState;
00035
00037         SubSystem();
00038
00040         virtual ~SubSystem();
00041
00043         virtual const WCHAR* GetName() const = 0;
00044
00046         virtual void OnPowerUp();
00047
00049         virtual void OnPowerDown();
00050
00052         virtual UINT8 GetPriority() const;
00053
00055         virtual BootSequenceState InvokeAt() const = 0;
00056
00057         friend class SubSystemManager;
00058
00059     private:
00060         SubSystem* m_next;
00061
00063         SubSystem(const SubSystem& sub_system);
00064
00066         SubSystem& operator=(const SubSystem& sub_system);
00067 };
00068
00070 #endif  // Apoxi_SubSystem_hpp
00071
00072
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SubSystemManager.cpp File Reference

Kernel/SubSystemManager.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SubSystemManager.hpp"
#include "SubSystem.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for SubSystemManager.cpp:

Generated on Tue Jan 24 23:17:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SubSystemManager.hpp File Reference

Kernel/SubSystemManager.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for SubSystemManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SubSystemManager

Defines

#define | Apoxi_SubSystemManager_hpp

Define Documentation

#define Apoxi_SubSystemManager_hpp

Generated on Tue Jan 24 23:17:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/SubSystemManager.hpp Source File

Kernel/SubSystemManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SubSystemManager_hpp)
00011 #define Apoxi_SubSystemManager_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017 class SubSystem;
00018
00022 class SubSystemManager {
00023     public:
00025         enum BootSequenceState {
00026             c_run_level_1 = 3,
00027             c_run_level_3 = 2,
00028             c_run_level_5 = 1,
00029             c_run_level_7 = 0
00030         };
00031
00033         static void SendPowerUpNotification(BootSequenceState state);
00034
00036         static void SendPowerDownNotification(BootSequenceState state);
00037
00038         friend class SubSystem;
00039
00040     private:
00041         static SubSystem* m_anchor;
00042
00043         static void Attach(SubSystem* subsys);
00044         static void Detach(SubSystem* subsys);
00045         static void DoPowerDownRecursion(SubSystem* subsys);
00046
00047         static UINT GetKey(const SubSystem* subsys);
00048         static void SortSubSystems();
00049 };
00050
00052 #endif  // Apoxi_SubSystemManager_hpp
00053
00054
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/System.cpp File Reference

Kernel/System.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "System.hpp"
#include "Os/IsrDataManager.hpp"
#include "Os/MutexObtainer.hpp"
#include <Config/FontConfig.hpp>
#include <Gui/ThemeManager.hpp>
#include <Gui/LanguageManager.hpp>
#include <Gui/ClientDc.hpp>
#include <Gui/BidiManager.hpp>
#include <Gui/Theme.hpp>
#include <Gui/Window.hpp>
#include <Config/DisplayConfig.hpp>
#include <Config/LocaleConfig.hpp>
#include <Config/ThemeConfig.hpp>
#include <Devices/ShutDown.hpp>
#include <Devices/Device.hpp>
#include <Devices/DeviceManager.hpp>
#include "MessageRouter.hpp"
#include "MsgCategory.hpp"
#include "Application.hpp"
#include "AppContainer.hpp"
#include "SubSystemManager.hpp"
#include "MsgTypes.hpp"

Include dependency graph for System.cpp:

Generated on Tue Jan 24 23:18:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/System.hpp File Reference

Kernel/System.hpp File Reference

#include <Auxiliary/Macros.hpp>
#include <Auxiliary/LinkedList.hpp>
#include <Kernel/Os/Os.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include <Gui/Color.hpp>
#include <Gui/Font.hpp>
#include <Gui/LanguageManager.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/ShutDown.hpp>

Include dependency graph for System.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FocusObtainer
class | System

Defines

#define | Apoxi_System_hpp

Define Documentation

#define Apoxi_System_hpp

Generated on Tue Jan 24 23:18:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/System.hpp Source File

Kernel/System.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_System_hpp)
00010 #define Apoxi_System_hpp
00013
00014 #include <Auxiliary/Macros.hpp>
00015 #include <Auxiliary/LinkedList.hpp>
00016 #include <Kernel/Os/Os.hpp>
00017 #include <Kernel/Os/SemObtainer.hpp>
00018 #include <Gui/Color.hpp>
00019 #include <Gui/Font.hpp>
00020 #include <Gui/LanguageManager.hpp>
00021 #include <Kernel/Os/Mutex.hpp>
00022 #include <Devices/DeviceManager.hpp>
00023 #include <Devices/ShutDown.hpp>
00024
00025 class Application;
00026 class AppContainer;
00027 class ExternalCommunicationHandler;
00028 class MessageRouter;
00029 class ResourceManager;
00030 class Theme;
00031 class ClientDc;
00032 class Display;
00033 class ApoxiThread;
00034
00036 class System {
00037     public:
00039         static void Init(ExternalCommunicationHandler* external_communicator = 0);
00040
00049         static BOOLEAN ShutDown(BOOLEAN force = FALSE, ShutDown::Mode mode = ShutDown::PowerOff);
00050
00053         static AppContainer* GetFocusedAppContainer();
00054
00056         static AppContainer* GetActiveAppContainer();
00057
00060         static AppContainer* GetFirstAppContainer();
00061
00067         static Application* GetFocusedApplication();
00068
00075         static BOOLEAN GrabFocus(Application* app);
00076
00085         static Application* GetActiveApplication();
00086
00089         static Semaphore* GetSystemSemaphore() { return &m_system_sem; }
00090
00092         static void SetTheme(ThemeId theme_id);
00093
00096         static ColorValue GetColorValue(SystemColorId system_color_id);
00097
00100         static const Font& GetFont(SystemFontId system_font_id);
00101
00103         static const MessageRouter& GetMessageRouter() {
00104             ASSERT_DEBUG(m_initialized);
00105             return m_message_router;
00106         }
00107
00110         static BOOLEAN IsInitialized() { return m_initialized; }
00111
00113         static void AddAppContainer(AppContainer* app_cont);
00114
00116         static void RemoveAppContainer(AppContainer* app_cont);
00117
00118         /*  ********************************************************************
00119             obsolete methods
00120             *******************************************************************/
00121
00123         static INT GetLanguage();
00124
00126         static const Theme& GetTheme();
00127
00129         static INT GetThemeId();
00130
00132         static INT GetCurrentFocusPriority();
00133
00135         static void GrabFocus(Application* app, INT priority, BOOLEAN assign_to_win);
00136
00138         static void InitLanguage(INT lang_id) {
00139             LanguageManager::SetActiveLanguage(lang_id);
00140         }
00141
00143         static void SetLanguage(INT lang_id) {
00144             LanguageManager::SetActiveLanguage(lang_id);
00145         }
00146
00148         static BOOLEAN LanguageChanged() {
00149             return LanguageManager::HasActiveLanguageChanged();
00150         }
00151
00153         static Display* GetDisplay(INT display_idx = 0);
00154
00156         static ClientDc* GetSharedDc(INT display_idx = 0);
00157
00158     private:
00159         friend class FocusObtainer;
00160         friend class StartUp;
00161         friend class ShutDown;
00162         friend class ServiceThread;
00163         friend class MessageRouter;
00164         friend class Os;
00165
00166         static BOOLEAN m_initialized;
00167         static Application* m_focused_app;
00168         static LinkedList<ApoxiThread> m_thread_list;
00169         static MessageRouter m_message_router;
00170         static Mutex m_thread_list_mutex;
00171         static Semaphore m_system_sem;          // global system sem
00172
00173         static void AddApoxiThread(ApoxiThread* thread);
00174         static void RemoveApoxiThread(ApoxiThread* thread);
00175         static ApoxiThread* GetFirstApoxiThread();
00176 };
00177
00178 class FocusObtainer : public SemObtainer {
00179     typedef SemObtainer Base;
00180
00181     public:
00182         FocusObtainer();
00183
00184     private:
00185         friend class System;
00186
00187         static Semaphore m_sem;
00188 };
00189
00191 #endif  // Apoxi_System_hpp
00192
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Threadlet.cpp File Reference

Kernel/Threadlet.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Threadlet.hpp"
#include "GenericWorkerTask.hpp"
#include "ExecutionContext.hpp"
#include "AppContainer.hpp"
#include "MessageRouter.hpp"
#include "MsgTypes.hpp"
#include "Application.hpp"

Include dependency graph for Threadlet.cpp:

Generated on Tue Jan 24 23:18:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Threadlet.hpp File Reference

Kernel/Threadlet.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Kernel/Condition.hpp>

Include dependency graph for Threadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Threadlet

Defines

#define | Apoxi_Threadlet_hpp

Define Documentation

#define Apoxi_Threadlet_hpp

Generated on Tue Jan 24 23:18:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Threadlet.hpp Source File

Kernel/Threadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Threadlet_hpp)
00011 #define Apoxi_Threadlet_hpp
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Kernel/Condition.hpp>
00017
00018 class ExecutionContext;
00019
00023 class Threadlet : public Linkable<Threadlet> {
00024     typedef Linkable<Threadlet> Base;
00025
00026     public:
00028         Threadlet();
00029
00031         virtual ~Threadlet();
00032
00038         void Execute(BOOLEAN block = TRUE);
00039
00042         virtual INT Fn() = 0;
00043
00048         virtual void OnEndOfExecute();
00049
00052         virtual UINT GetReqStackSize() const;
00053
00060         virtual void ReleaseInstance();
00061
00064         BOOLEAN IsBlocking() const { return m_block; }
00065
00066     private:
00067         friend class GenericWorkerTask;
00068
00069         BOOLEAN m_block;
00070         ExecutionContext* m_context;
00071         BooleanCondition m_condition;
00072 };
00073
00075 #endif  // Apoxi_Threadlet_hpp
00076
00077
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Timer.cpp File Reference

Kernel/Timer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Application.hpp"
#include "AppContainer.hpp"
#include "System.hpp"
#include "MessageRouter.hpp"
#include "MsgTypes.hpp"

Include dependency graph for Timer.cpp:

Generated on Tue Jan 24 23:18:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Timer.hpp File Reference

Kernel/Timer.hpp File Reference

#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/Linkable.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for Timer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Timer

Defines

#define | Apoxi_Timer_hpp

Typedefs

typedef SortedLinkedList<
Timer > 		TimerList

Define Documentation

#define Apoxi_Timer_hpp

Generated on Tue Jan 24 23:18:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Timer.hpp Source File

Kernel/Timer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Timer_hpp)
00010 #define Apoxi_Timer_hpp
00013
00014 #include <Auxiliary/LinkedList.hpp>
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Kernel/Os/Os.hpp>
00017
00018 class ExecutionContext;
00019 class Animation;
00020
00024 class Timer : public Linkable<Timer> {
00025     public:
00028         Timer();
00029
00033         Timer(UINT32 timeout, BOOLEAN autotimer = FALSE);
00034
00035         virtual ~Timer();
00036
00040         void Init(UINT32 timeout, BOOLEAN autotimer = FALSE);
00041
00043         void Start();
00044
00047         UINT32 Stop();
00048
00050         void Resume();
00051
00053         void Restart();
00054
00057         void SetTimeout(UINT32 timeout);
00058
00060         UINT32 GetTimeout() { return m_timeout.GetMilliSeconds(); };
00061
00063         BOOLEAN IsActive() const { return m_bits.active; };
00064
00065         BOOLEAN operator <(const Timer& timer) const;
00066
00067     protected:
00068         ExecutionContext* m_context;
00069
00072         virtual void OnTimer();
00073
00074     private:
00075         struct {
00076             UINT autotimer      : 1;
00077             UINT active         : 1;
00078             UINT stopped        : 1;
00079         } m_bits;
00080
00081         Ticks   m_timeout;
00082         Ticks   m_expire;
00083         Ticks ExpireTicks() const { return m_expire; };
00084
00085         void Expired();
00086
00087         friend class AppContainer;
00088         friend class Application;
00089         friend class Animation; // provides backward compatibility with APOXI-versions < 1.4.0
00090         friend class ServiceThread;
00091 };
00092
00093
00094 typedef SortedLinkedList<Timer> TimerList;
00095
00097 #endif  // Apoxi_Timer_hpp
00098
00099
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Trace.hpp File Reference

Kernel/Trace.hpp File Reference

#include <Kernel/Os/InternalTracer.hpp>
#include <Kernel/ApplicationTracer.hpp>
#include <Kernel/FunctionTracer.hpp>

Include dependency graph for Trace.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_TRACE
#define | TRACE_HPP

Typedefs

typedef _FunctionTracer< InternalTracer::Adc > | AdcTracer
typedef _NullFunctionTracer | AdcTracerLevel2
typedef _NullFunctionTracer | AdcTracerLevel3
typedef _FunctionTracer< InternalTracer::Apc > | ApcTracer
typedef _NullFunctionTracer | ApcTracerLevel2
typedef _NullFunctionTracer | ApcTracerLevel3
typedef _FunctionTracer< InternalTracer::App1 > | App1Tracer
typedef _NullFunctionTracer | App1TracerLevel2
typedef _NullFunctionTracer | App1TracerLevel3
typedef _FunctionTracer< InternalTracer::App2 > | App2Tracer
typedef _NullFunctionTracer | App2TracerLevel2
typedef _NullFunctionTracer | App2TracerLevel3
typedef _FunctionTracer< InternalTracer::App3 > | App3Tracer
typedef _NullFunctionTracer | App3TracerLevel2
typedef _NullFunctionTracer | App3TracerLevel3
typedef _FunctionTracer< InternalTracer::App4 > | App4Tracer
typedef _NullFunctionTracer | App4TracerLevel2
typedef _NullFunctionTracer | App4TracerLevel3
typedef _ApplicationTracer | AppTracer
typedef _FunctionTracer< InternalTracer::Asc > | AscTracer
typedef _NullFunctionTracer | AscTracerLevel2
typedef _NullFunctionTracer | AscTracerLevel3
typedef _FunctionTracer< InternalTracer::Aux > | AuxTracer
typedef _NullFunctionTracer | AuxTracerLevel2
typedef _NullFunctionTracer | AuxTracerLevel3
typedef _FunctionTracer< InternalTracer::Gui > | GuiTracer
typedef _NullFunctionTracer | GuiTracerLevel2
typedef _NullFunctionTracer | GuiTracerLevel3
typedef _FunctionTracer< InternalTracer::Kernel > | KernelTracer
typedef _NullFunctionTracer | KernelTracerLevel2
typedef _NullFunctionTracer | KernelTracerLevel3
typedef _FunctionTracer< InternalTracer::Mmi > | MmiTracer
typedef _NullFunctionTracer | MmiTracerLevel2
typedef _NullFunctionTracer | MmiTracerLevel3
typedef _FunctionTracer< InternalTracer::Socket > | SocketTracer
typedef _NullFunctionTracer | SocketTracerLevel2
typedef _NullFunctionTracer | SocketTracerLevel3
typedef _FunctionTracer< InternalTracer::Always > | Tracer

Define Documentation

#define TRACE_HPP

Generated on Tue Jan 24 23:19:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Trace.hpp Source File

Kernel/Trace.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(TRACE_HPP)
00011 #define TRACE_HPP
00014
00015 #include <Kernel/Os/InternalTracer.hpp>
00016 #include <Kernel/ApplicationTracer.hpp>
00017 #include <Kernel/FunctionTracer.hpp>
00018
00019
00031 #if defined(APOXI_TRACE_DISABLED)
00032
00033 #undef APOXI_TRACE
00034 #undef APOXI_TRACE_LEVEL_2
00035 #undef APOXI_TRACE_LEVEL_3
00036 #undef APOXI_TRACE_MEM
00037
00038 #else
00039
00040 // per default, Apoxi Tracing is enabled
00041 #undef APOXI_TRACE
00042 #define APOXI_TRACE
00043
00044 #endif
00045
00046
00047
00048 #if defined(APOXI_TRACE) | defined(APOXI_TRACE_LEVEL_2) | defined(APOXI_TRACE_LEVEL_3)
00049
00050
00051 typedef _ApplicationTracer AppTracer;
00052 typedef _FunctionTracer<InternalTracer::Always> Tracer;
00053
00054 typedef _FunctionTracer<InternalTracer::Adc> AdcTracer;
00055 typedef _FunctionTracer<InternalTracer::Apc> ApcTracer;
00056 typedef _FunctionTracer<InternalTracer::Asc> AscTracer;
00057 typedef _FunctionTracer<InternalTracer::Aux> AuxTracer;
00058 typedef _FunctionTracer<InternalTracer::Gui> GuiTracer;
00059 typedef _FunctionTracer<InternalTracer::Kernel> KernelTracer;
00060 typedef _FunctionTracer<InternalTracer::Socket> SocketTracer;
00061 typedef _FunctionTracer<InternalTracer::Mmi> MmiTracer;
00062 typedef _FunctionTracer<InternalTracer::App1> App1Tracer;
00063 typedef _FunctionTracer<InternalTracer::App2> App2Tracer;
00064 typedef _FunctionTracer<InternalTracer::App3> App3Tracer;
00065 typedef _FunctionTracer<InternalTracer::App4> App4Tracer;
00066
00067 #else
00068
00069 typedef _NullApplicationTracer AppTracer;
00070 typedef _NullFunctionTracer Tracer;
00071
00072 typedef _NullFunctionTracer AdcTracer;
00073 typedef _NullFunctionTracer ApcTracer;
00074 typedef _NullFunctionTracer AscTracer;
00075 typedef _NullFunctionTracer AuxTracer;
00076 typedef _NullFunctionTracer GuiTracer;
00077 typedef _NullFunctionTracer KernelTracer;
00078 typedef _NullFunctionTracer SocketTracer;
00079 typedef _NullFunctionTracer MmiTracer;
00080 typedef _NullFunctionTracer App1Tracer;
00081 typedef _NullFunctionTracer App2Tracer;
00082 typedef _NullFunctionTracer App3Tracer;
00083 typedef _NullFunctionTracer App4Tracer;
00084
00085 #endif
00086
00087
00088
00089
00090 #if defined(APOXI_TRACE_LEVEL_2) | defined(APOXI_TRACE_LEVEL_3)
00091
00092 #if !defined(APOXI_TRACE)
00093 #define APOXI_TRACE
00094 #endif
00095
00096 typedef _FunctionTracer<InternalTracer::Adc> AdcTracerLevel2;
00097 typedef _FunctionTracer<InternalTracer::Apc> ApcTracerLevel2;
00098 typedef _FunctionTracer<InternalTracer::Asc> AscTracerLevel2;
00099 typedef _FunctionTracer<InternalTracer::Aux> AuxTracerLevel2;
00100 typedef _FunctionTracer<InternalTracer::Gui> GuiTracerLevel2;
00101 typedef _FunctionTracer<InternalTracer::Kernel> KernelTracerLevel2;
00102 typedef _FunctionTracer<InternalTracer::Socket> SocketTracerLevel2;
00103 typedef _FunctionTracer<InternalTracer::Mmi> MmiTracerLevel2;
00104 typedef _FunctionTracer<InternalTracer::App1> App1TracerLevel2;
00105 typedef _FunctionTracer<InternalTracer::App2> App2TracerLevel2;
00106 typedef _FunctionTracer<InternalTracer::App3> App3TracerLevel2;
00107 typedef _FunctionTracer<InternalTracer::App4> App4TracerLevel2;
00108
00109 #else
00110
00111 typedef _NullFunctionTracer AdcTracerLevel2;
00112 typedef _NullFunctionTracer ApcTracerLevel2;
00113 typedef _NullFunctionTracer AscTracerLevel2;
00114 typedef _NullFunctionTracer AuxTracerLevel2;
00115 typedef _NullFunctionTracer GuiTracerLevel2;
00116 typedef _NullFunctionTracer KernelTracerLevel2;
00117 typedef _NullFunctionTracer SocketTracerLevel2;
00118 typedef _NullFunctionTracer MmiTracerLevel2;
00119 typedef _NullFunctionTracer App1TracerLevel2;
00120 typedef _NullFunctionTracer App2TracerLevel2;
00121 typedef _NullFunctionTracer App3TracerLevel2;
00122 typedef _NullFunctionTracer App4TracerLevel2;
00123
00124 #endif
00125
00126
00127
00128
00129 #if defined(APOXI_TRACE_LEVEL_3)
00130
00131 #if !defined(APOXI_TRACE)
00132 #define APOXI_TRACE
00133 #endif
00134
00135 typedef _FunctionTracer<InternalTracer::Adc> AdcTracerLevel3;
00136 typedef _FunctionTracer<InternalTracer::Apc> ApcTracerLevel3;
00137 typedef _FunctionTracer<InternalTracer::Asc> AscTracerLevel3;
00138 typedef _FunctionTracer<InternalTracer::Aux> AuxTracerLevel3;
00139 typedef _FunctionTracer<InternalTracer::Gui> GuiTracerLevel3;
00140 typedef _FunctionTracer<InternalTracer::Kernel> KernelTracerLevel3;
00141 typedef _FunctionTracer<InternalTracer::Socket> SocketTracerLevel3;
00142 typedef _FunctionTracer<InternalTracer::Mmi> MmiTracerLevel3;
00143 typedef _FunctionTracer<InternalTracer::App1> App1TracerLevel3;
00144 typedef _FunctionTracer<InternalTracer::App2> App2TracerLevel3;
00145 typedef _FunctionTracer<InternalTracer::App3> App3TracerLevel3;
00146 typedef _FunctionTracer<InternalTracer::App4> App4TracerLevel3;
00147
00148 #else
00149
00150 typedef _NullFunctionTracer AdcTracerLevel3;
00151 typedef _NullFunctionTracer ApcTracerLevel3;
00152 typedef _NullFunctionTracer AscTracerLevel3;
00153 typedef _NullFunctionTracer AuxTracerLevel3;
00154 typedef _NullFunctionTracer GuiTracerLevel3;
00155 typedef _NullFunctionTracer KernelTracerLevel3;
00156 typedef _NullFunctionTracer SocketTracerLevel3;
00157 typedef _NullFunctionTracer MmiTracerLevel3;
00158 typedef _NullFunctionTracer App1TracerLevel3;
00159 typedef _NullFunctionTracer App2TracerLevel3;
00160 typedef _NullFunctionTracer App3TracerLevel3;
00161 typedef _NullFunctionTracer App4TracerLevel3;
00162
00163 #endif
00164
00166 #endif // TRACE_HPP
00167
00168
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Types.hpp File Reference

Kernel/Types.hpp File Reference

#include <Kernel/Types.h>

Include dependency graph for Types.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_Types_hpp

Functions

template<typename T>
T | Absolute (const T &a)
template<typename T1, typename T2>
BOOLEAN | Between (const T1 &a, const T2 &low, const T2 &high)
template<typename T1, typename T2>
T1 | Maximum (const T1 &a, const T2 &b)
template<typename T1, typename T2>
T1 | Minimum (const T1 &a, const T2 &b)
template<typename T>
T | Sign (const T &a)
template<typename T>
BOOLEAN | TestBit (const T &b, const INT &i)

Variables

const BOOLEAN | FALSE = 0
const BOOLEAN | TRUE = 1

Define Documentation

#define Apoxi_Types_hpp

Function Documentation

template<typename T>
T Absolute ( const T & a ) [inline]

template<typename T1, typename T2>
BOOLEAN Between | ( | const T1 & | a,
 |  | const T2 & | low,
 |  | const T2 & | high
 | ) | [inline]

template<typename T1, typename T2>
T1 Maximum | ( | const T1 & | a,
 |  | const T2 & | b
 | ) | [inline]

template<typename T1, typename T2>
T1 Minimum | ( | const T1 & | a,
 |  | const T2 & | b
 | ) | [inline]

template<typename T>
T Sign ( const T & a ) [inline]

template<typename T>
BOOLEAN TestBit | ( | const T & | b,
 |  | const INT & | i
 | ) | [inline]

Variable Documentation

const BOOLEAN FALSE = 0

const BOOLEAN TRUE = 1

Generated on Tue Jan 24 16:19:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Types.hpp Source File

Kernel/Types.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Types_hpp)
00010 #define Apoxi_Types_hpp
00011
00012 #include <Kernel/Types.h>
00013
00014 /*----------------------------------------------------------------
00015                                 Constants
00016   ----------------------------------------------------------------*/
00017
00018 const BOOLEAN TRUE = 1;
00019 const BOOLEAN FALSE = 0;
00020
00021 /*----------------------------------------------------------------
00022                                 Templates
00023   ----------------------------------------------------------------*/
00024
00025 template <typename T> inline
00026 T Sign(const T& a)
00027 {
00028     return (a < 0 ? -1 : 1);
00029 }
00030
00031 template <typename T> inline
00032 T Absolute(const T& a)
00033 {
00034     return (a < 0 ? -a : a);
00035 }
00036
00037 template <typename T1, typename T2> inline
00038 T1 Maximum(const T1& a, const T2& b)
00039 {
00040     return (a > b ? a : b);
00041 }
00042
00043 template <typename T1, typename T2> inline
00044 T1 Minimum(const T1& a, const T2& b)
00045 {
00046     return (a < b ? a : b);
00047 }
00048
00049 template <typename T1, typename T2> inline
00050 BOOLEAN Between(const T1& a, const T2& low, const T2& high)
00051 {
00052     return (a >= low && a <= high);
00053 }
00054
00055 template <typename T> inline
00056 BOOLEAN TestBit(const T& b, const INT& i)
00057 {
00058     return ((b & (1 << i)) != 0);
00059 }
00060
00061 /*----------------------------------------------------------------
00062                                 Casts
00063   ----------------------------------------------------------------*/
00064
00065 #if defined(APOXI_DISABLE_CPP_CASTS)
00066     #define static_cast apoxi_static_cast
00067     #define const_cast apoxi_const_cast
00068     #define reinterpret_cast apoxi_reinterpret_cast
00069
00070     template <typename ToType, typename FromType> inline
00071     ToType apoxi_static_cast(FromType val)
00072     {
00073         return (ToType)val;
00074     }
00075
00076     template <typename ToType, typename FromType> inline
00077     ToType apoxi_const_cast(FromType val)
00078     {
00079         return (ToType)val;
00080     }
00081
00082     template <typename ToType, typename FromType> inline
00083     ToType apoxi_reinterpret_cast(FromType val)
00084     {
00085         return (ToType)val;
00086     }
00087 #endif
00088
00089 #endif  // Apoxi_Types_hpp
00090
Generated on Tue Jan 24 14:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/UserDispatcher.cpp File Reference

Kernel/UserDispatcher.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "UserDispatcher.hpp"

Include dependency graph for UserDispatcher.cpp:

Generated on Tue Jan 24 23:19:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/UserDispatcher.hpp File Reference

Kernel/UserDispatcher.hpp File Reference

#include <Kernel/Dispatcher.hpp>

Include dependency graph for UserDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UserDispatcher

Defines

#define | Apoxi_UserDispatcher_hpp

Define Documentation

#define Apoxi_UserDispatcher_hpp

Generated on Tue Jan 24 23:19:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/UserDispatcher.hpp Source File

Kernel/UserDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_UserDispatcher_hpp)
00011 #define Apoxi_UserDispatcher_hpp
00014
00015 #include <Kernel/Dispatcher.hpp>
00016
00020 class UserDispatcher : public Dispatcher {
00021     typedef Dispatcher Base;
00022
00023     public:
00024         UserDispatcher();
00025         virtual ~UserDispatcher();
00026
00029         void SetNext(UserDispatcher* next) { m_next = next; }
00030
00032         UserDispatcher* GetNext() const { return m_next; }
00033
00034     protected:
00039         virtual void RegisterMessages() const;
00040
00045         virtual void UnregisterMessages() const;
00046
00047     private:
00048         friend class ExecutionContext;
00049
00050         UserDispatcher* m_next;
00051 };
00052
00054 #endif  // Apoxi_UserDispatcher_hpp
00055
00056
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/VersionInfo.cpp File Reference

Kernel/VersionInfo.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "VersionInfo.hpp"
#include "Trace.hpp"
#include <Auxiliary/String.hpp>

Include dependency graph for VersionInfo.cpp:

Generated on Tue Jan 24 23:19:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/VersionInfo.hpp File Reference

Kernel/VersionInfo.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for VersionInfo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VersionInfo
struct | VersionInfo::Data

Defines

#define | ApoxiDefVersionInfo(subsys, ver, flags)
#define | ApoxiUseVersionInfo(subsys)
#define | ApoxiVersionInfo_hpp

Define Documentation

#define ApoxiVersionInfo_hpp

Generated on Tue Jan 24 23:19:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/VersionInfo.hpp Source File

Kernel/VersionInfo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiVersionInfo_hpp)
00011 #define ApoxiVersionInfo_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00024 class VersionInfo {
00025     public:
00026         enum {
00027             c_flag_never_show_on_display = (1U << 0U),
00028             c_flag_hide_in_engineering_mode = (1U << 1U),
00029             c_flag_add_to_trace_info = (1U << 2U),
00030             c_flag_is_build_version = (1U << 3U)
00031         };
00032
00033         struct Data {
00034             UINT m_flags;
00035             const CHAR* m_subsys_name;
00036             const CHAR* m_version_string;
00037             const CHAR* m_build_date;
00038         };
00039
00040         VersionInfo(const Data* data);
00041
00043         UINT GetFlags() const { return m_data->m_flags; }
00044
00046         const CHAR* GetSubSystemName() const { return m_data->m_subsys_name; }
00047
00049         const CHAR* GetVersionString() const { return m_data->m_version_string; }
00050
00052         const CHAR* GetBuildDate() const { return m_data->m_build_date; }
00053
00055         static const VersionInfo* GetFirst() { return m_first; }
00056
00058         const VersionInfo* GetNext() const { return m_next; }
00059
00060     private:
00061         const Data* m_data;
00062         VersionInfo* m_next;
00063
00064         static VersionInfo* m_first;
00065 };
00066
00067
00068
00072 #define ApoxiDefVersionInfo(subsys, ver, flags) \
00073     static const VersionInfo::Data g_##subsys##_version_data = { (flags), #subsys, ver, __DATE__ " " __TIME__ }; \
00074     VersionInfo g_##subsys##_version_obj(&g_##subsys##_version_data) \
00075
00076
00080 #define ApoxiUseVersionInfo(subsys) \
00081     extern VersionInfo g_##subsys##_version_obj; \
00082     VersionInfo*  g_##subsys##_prt =& g_##subsys##_version_obj;
00083
00084
00086 #endif  // ApoxiVersionInfo_hpp
00087
00088
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/AppMutex.cpp File Reference

Kernel/Os/AppMutex.cpp File Reference

#include <Kernel/PreComp.hpp>
#include "AppMutex.hpp"
#include <Kernel/System.hpp>
#include "../Application.hpp"
#include "../AppContainer.hpp"

Include dependency graph for AppMutex.cpp:

Generated on Tue Jan 24 21:04:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/AppMutex.hpp File Reference

Kernel/Os/AppMutex.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for AppMutex.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AppMutex
class | AppMutex::CondListEntry

Defines

#define | Apoxi_AppMutex_hpp

Define Documentation

#define Apoxi_AppMutex_hpp

Generated on Tue Jan 24 21:04:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/AppMutex.hpp Source File

Kernel/Os/AppMutex.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_AppMutex_hpp)
00009 #define Apoxi_AppMutex_hpp
00012
00013 #include <Auxiliary/NonCloneable.hpp>
00014 #include <Kernel/Condition.hpp>
00015 #include <Kernel/Os/Os.hpp>
00016
00023 class AppMutex : public NonCloneable {
00024     public:
00026         AppMutex();
00027
00029         virtual ~AppMutex();
00030
00032         BOOLEAN Create(BOOLEAN locked = TRUE);
00033
00035         BOOLEAN Obtain(const Ticks& timeout = Ticks::Infinite());
00036
00038         void Release();
00039
00040     private:
00041         class CondListEntry : public Linkable<CondListEntry> {
00042             public:
00043                 CondListEntry();
00044                 virtual ~CondListEntry();
00045
00046                 BooleanCondition& GetCondition() { return m_cond; }
00047
00048                 #ifdef _DEBUG
00049                     Application* GetApplication() const { return m_app; }
00050                 #endif
00051
00052             private:
00053                 #ifdef _DEBUG
00054                     Application* m_app;
00055                 #endif
00056
00057                 BooleanCondition m_cond;
00058         };
00059
00060         INT         m_count;
00061         Semaphore   m_sem;
00062         ThreadId    m_thread_id;
00063         Application* m_app;
00064         LinkedList<CondListEntry> m_list;
00065 };
00066
00068 #endif  // Apoxi_AppMutex_hpp
00069
00070
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/InternalTracer.hpp File Reference

Kernel/Os/InternalTracer.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for InternalTracer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InternalTracer
struct | InternalTracer::AttachData
struct | InternalTracer::DataTraceHeader
struct | InternalTracer::DelData
struct | InternalTracer::DetachData
struct | InternalTracer::NewData
struct | InternalTracer::TestStateData
struct | InternalTracer::TraceHeader
struct | InternalTracer::TraceMessageData
struct | InternalTracer::TsStruct
this struct just prevents ms compiler to rearange TraceHeader-struct More...

Defines

#define | DECLARE_CLASS(id) enum CLASS_ID { ID = (id) }; static CLASS_ID GetID() { CLASS_ID _id = ID; return _id; }
#define | INTERNAL_TRACER_HPP

Define Documentation

#define INTERNAL_TRACER_HPP

Generated on Tue Jan 24 21:04:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/InternalTracer.hpp Source File

Kernel/Os/InternalTracer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(INTERNAL_TRACER_HPP)
00011 #define INTERNAL_TRACER_HPP
00014
00015 #include <Kernel/Types.hpp>
00016
00017
00022 #define DECLARE_CLASS(id)       enum CLASS_ID { ID = (id) }; static CLASS_ID GetID() { CLASS_ID _id = ID; return _id; }
00023
00024 #if defined(APOXI_RTOS_WIN32)
00025 #pragma pack( push, InternalTracer, 2 )
00026 #endif
00027
00029 class InternalTracer {
00030     public:
00032         enum TraceMask {
00033             Always  = 0x0000,
00034             Adc     = 0x0001,
00035             Apc     = 0x0002,
00036             Asc     = 0x0004,
00037             Aux     = 0x0008,
00038             Gui     = 0x0010,
00039             Kernel  = 0x0020,
00040             Socket  = 0x0040,
00041             Mmi     = 0x0080,
00042             App1    = 0x0100,
00043             App2    = 0x0200,
00044             App3    = 0x0400,
00045             App4    = 0x0800,
00046
00047             Mem     = 0x1000,
00048             Func    = 0x2000,
00049             Obj     = 0x4000,
00050             Data    = -32768,   // 0x8000
00051
00052 #if defined(APOXI_TRACE_MEM)
00053             DefaultMask = Mem
00054 #else
00055             DefaultMask = 0xFFF | Func | Obj | Data
00056 #endif
00057         };
00058
00060         enum TraceId {
00061             Unknown         = 0x0000,
00062             UChar           = 0x0003,
00063             ULong           = 0x0007,
00064             String          = 0x000e,
00065             Int             = 0x0010,
00066             UInt            = 0x0012,
00067             Char            = 0x0013,
00068             Long            = 0x0014,
00069             Short           = 0x0015,
00070             UShort          = 0x0016,
00071             WString         = 0x001E,
00072
00073             TestState       = 0x00E0,
00074             New             = 0x00F0,
00075             Delete          = 0x00F1,
00076             AppBegin        = 0x00F2,
00077             AppEnd          = 0x00F3,
00078             ObjectCreate    = 0x00F4,
00079             ObjectDestroy   = 0x00F5,
00080             DataTrace       = 0x00F6,
00081             Misc            = 0x00F7,
00082             Message         = 0x00F8,
00083             Version         = 0x00F9,
00084             Warning         = 0x00FA,
00085             FunctionBegin   = 0x00FB,
00086             CheckPoint      = 0x00FC,
00087             FuncStackTrace  = 0x00FD,
00088             FunctionEnd     = 0x00FE,
00089             Error           = 0x00FF
00090         };
00091
00093         enum {
00094             APP_NAME_LENGTH = 20,
00095             STACK_TRACE_DEPTH = 10,
00096             MAX_DATA_LENGTH = 400
00097         };
00098
00100         struct TsStruct {
00101             UINT32 ts;
00102         };
00103
00105         struct TraceHeader {
00106             UINT16 id;          // id, type
00107             UINT8 nestedLevel;  //
00108             UINT8 appId;        // application id, provided by apoxi
00109             TsStruct ts;            // timestamp
00110             const void* codeAdr;
00111         };
00112
00114         static void SetGlobalTraceMask(TraceMask mask) {
00115             g_globalMask = mask;
00116         }
00117
00119         static TraceMask GetGlobalTraceMask() {
00120             return g_globalMask;
00121         }
00122
00124         static void Init();
00126         static void TraceMiscData      (TraceMask mask, const void* linkreg, const void* data, UINT16 len);
00128         static void TraceData          (TraceMask mask, const void* linkreg, const void* data, UINT16 len);
00130         static void TraceData          (TraceMask mask, const void* linkreg, TraceId id, const void* data, UINT16 len);
00132         static void TraceFuncBegin     (TraceMask mask, const void* linkreg, const void* this_ptr);
00134         static void TraceFuncCheckPoint(TraceMask mask, const void* linkreg);
00136         static void TraceFuncStackTrace(TraceMask mask, const void* linkreg);
00138         static void TraceFuncEnd       (TraceMask mask, const void* linkreg);
00140         static void TraceNew      (const void* linkreg, const void* ptr, UINT16 size);
00142         static void TraceDelete   (const void* linkreg, const void* ptr);
00144         static void TraceMessage  (const void* linkreg, UINT16 id, const void* ptr, UINT16 size);
00146         static void TraceBuffer   (const void* linkreg, UINT16 id, const void* str, UINT16 size);
00148         static void TraceAppAttach(const void* linkreg, const void* app, const void* container,
00149                                                         const WCHAR* appName, UINT8 newAppId);
00151         static void TraceAppDetach(const void* linkreg, const void* app, UINT8 newAppId);
00153         static void TraceObj      (const void* linkreg, TraceId id, const void* ptr);
00155         static void TraceTestState(const void* linkreg, UINT16 testID, const void* str, UINT16 len);
00156
00157     protected:
00158         static TraceMask g_globalMask;
00159
00160         InternalTracer() {};
00161
00162         static unsigned char NestedLevel();
00163         static const void* CallStackAdr(INT16 level);
00164
00165     private:
00166         struct DataTraceHeader {
00167             TraceHeader h;
00168             const void* traceHelperAdr;
00169         };
00170
00171         struct TraceMessageData {
00172             TraceHeader h;
00173             UINT16 message_id;
00174         };
00175
00176         struct AttachData {
00177             const void* app;
00178             const void* container;
00179             UINT8 appId;
00180             WCHAR appName[APP_NAME_LENGTH];
00181         };
00182
00183         struct DetachData {
00184             const void* app;
00185             UINT8 appId;
00186         };
00187
00188         struct NewData {
00189             const void* adr1;
00190             const void* ptr;
00191             UINT16 size;
00192         };
00193
00194         struct DelData {
00195             const void* adr1;
00196             const void* ptr;
00197         };
00198
00199         struct TestStateData {
00200             TraceHeader h;
00201             UINT16 testID;
00202         };
00203
00204         // don't allow cloning
00205         InternalTracer(const InternalTracer&);
00206         InternalTracer& operator=(const InternalTracer&);
00207
00208         // don't allow creating on heap
00209         void* operator new(size_t size);
00210         void operator delete(void* ptr);
00211
00212 };  // Tracer
00213
00214
00215
00216 #if defined(APOXI_RTOS_WIN32)
00217 #pragma pack( pop, InternalTracer )
00218 #endif
00219
00220
00222 #endif // INTERNAL_TRACER_HPP
00223
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/IsrDataContainer.hpp File Reference

Kernel/Os/IsrDataContainer.hpp File Reference

Go to the source code of this file.

Data Structures

class | IsrDataContainer< Data, c_queue_size >
struct | IsrDataContainer< Data, c_queue_size >::QueueEntry

Defines

#define | Apoxi_IsrDataContainer_hpp

Define Documentation

#define Apoxi_IsrDataContainer_hpp

Generated on Tue Jan 24 21:04:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/IsrDataContainer.hpp Source File

Kernel/Os/IsrDataContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_IsrDataContainer_hpp)
00012 #define Apoxi_IsrDataContainer_hpp
00013
00014
00015 /*  -------------------------------------------------------------------------
00016                                     Types
00017     ------------------------------------------------------------------------- */
00018
00019 template<class Data, INT c_queue_size = 5> class IsrDataContainer {
00020     public:
00021         IsrDataContainer();
00022
00023         BOOLEAN IsrPushData(const Data& data);
00024         BOOLEAN ThrPopData(Data& data);
00025
00026     private:
00027         struct QueueEntry {
00028             BOOLEAN m_used;
00029             Data m_data;
00030         };
00031
00032         INT m_isr_idx;
00033         INT m_thr_idx;
00034         QueueEntry m_queue[c_queue_size];
00035
00036         void IncIdx(INT& idx) {
00037             if (idx == (c_queue_size - 1))
00038                 idx = 0;
00039             else
00040                 idx++;
00041         }
00042
00043 };
00044
00045
00046
00047 /*  -------------------------------------------------------------------------
00048     IsrDataContainer
00049     ------------------------------------------------------------------------- */
00050 template<class Data, INT c_queue_size>
00051 IsrDataContainer<Data,c_queue_size>::IsrDataContainer() :
00052     m_isr_idx(0),
00053     m_thr_idx(0)
00054 {
00055     for (INT i = 0; i < c_queue_size; i++) {
00056         m_queue[i].m_used = FALSE;
00057     }
00058 }   // IsrDataContainer
00059
00060
00061 /*  -------------------------------------------------------------------------
00062     IsrPushData
00063     ------------------------------------------------------------------------- */
00064 template<class Data, INT c_queue_size>
00065 BOOLEAN IsrDataContainer<Data,c_queue_size>::IsrPushData(const Data& data)
00066 {
00067     if (m_queue[m_isr_idx].m_used)
00068         return FALSE;
00069
00070     m_queue[m_isr_idx].m_data = data;
00071     m_queue[m_isr_idx].m_used = TRUE;
00072     IncIdx(m_isr_idx);
00073
00074     IsrDataManager::SetPendingDataFlag();
00075
00076     ASSERT_DEBUG(System::GetFirstAppContainer() != 0);
00077     System::GetFirstAppContainer()->TriggerIsrDataProcessing();
00078
00079     return TRUE;
00080 }   // IsrPushData
00081
00082
00083 /*  -------------------------------------------------------------------------
00084     ThrPopData
00085     ------------------------------------------------------------------------- */
00086 template<class Data, INT c_queue_size>
00087 BOOLEAN IsrDataContainer<Data,c_queue_size>::ThrPopData(Data& data)
00088 {
00089     if (! m_queue[m_thr_idx].m_used)
00090         return FALSE;
00091
00092     data = m_queue[m_thr_idx].m_data;
00093     m_queue[m_thr_idx].m_used = FALSE;
00094
00095     IncIdx(m_thr_idx);
00096
00097     return TRUE;
00098 }   // ThrPopData
00099
00100
00101
00102 #endif  // Apoxi_IsrDataContainer_hpp
00103
00104
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/IsrDataManager.cpp File Reference

Kernel/Os/IsrDataManager.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "IsrDataManager.hpp"
#include "IsrDataMarshaller.hpp"
#include "SemObtainer.hpp"

Include dependency graph for IsrDataManager.cpp:

Generated on Tue Jan 24 21:04:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/IsrDataManager.hpp File Reference

Kernel/Os/IsrDataManager.hpp File Reference

#include <Kernel/Os/Os.hpp>

Include dependency graph for IsrDataManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IsrDataManager

Defines

#define | Apoxi_IsrDataManager_hpp

Define Documentation

#define Apoxi_IsrDataManager_hpp

Generated on Tue Jan 24 21:04:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/IsrDataManager.hpp Source File

Kernel/Os/IsrDataManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_IsrDataManager_hpp)
00011 #define Apoxi_IsrDataManager_hpp
00012
00013 #include <Kernel/Os/Os.hpp>
00014
00015 class IsrDataMarshaller;
00016
00017 class IsrDataManager {
00018     public:
00019         static void ProcessIsrData();
00020
00021         static BOOLEAN Init();
00022
00023         static BOOLEAN HasPendingData() { return m_data_flag; }
00024         static void SetPendingDataFlag(BOOLEAN set = TRUE) { m_data_flag = set; }
00025
00026     private:
00027         static BOOLEAN m_data_flag;
00028         static IsrDataMarshaller* m_first_idm;
00029         static Semaphore m_sem;
00030
00031         static void Attach(IsrDataMarshaller* idm);
00032         static void Detach(IsrDataMarshaller* idm);
00033
00034         friend class IsrDataMarshaller;
00035 };
00036
00037 #endif  // Apoxi_IsrDataManager_hpp
00038
00039
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/IsrDataMarshaller.cpp File Reference

Kernel/Os/IsrDataMarshaller.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "IsrDataMarshaller.hpp"
#include "IsrDataManager.hpp"

Include dependency graph for IsrDataMarshaller.cpp:

Generated on Tue Jan 24 21:04:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/IsrDataMarshaller.hpp File Reference

Kernel/Os/IsrDataMarshaller.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IsrDataMarshaller

Defines

#define | Apoxi_IsrDataMarshaller_hpp

Define Documentation

#define Apoxi_IsrDataMarshaller_hpp

Generated on Tue Jan 24 21:04:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/IsrDataMarshaller.hpp Source File

Kernel/Os/IsrDataMarshaller.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_IsrDataMarshaller_hpp)
00012 #define Apoxi_IsrDataMarshaller_hpp
00013
00014
00015 /*  -------------------------------------------------------------------------
00016                                     Types
00017     ------------------------------------------------------------------------- */
00018
00019 class IsrDataMarshaller {
00020     public:
00021         IsrDataMarshaller();
00022         virtual ~IsrDataMarshaller();
00023
00024         virtual void Marshall() = 0;
00025
00026     private:
00027         IsrDataMarshaller* m_next;
00028
00029         friend class IsrDataManager;
00030 };
00031
00032
00033
00034 #endif  // Apoxi_IsrDataMarshaller_hpp
00035
00036
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Mutex.cpp File Reference

Kernel/Os/Mutex.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Mutex.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for Mutex.cpp:

Generated on Tue Jan 24 21:04:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Mutex.hpp File Reference

Kernel/Os/Mutex.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Os/Semaphore.hpp>
#include <Kernel/Os/Thread.hpp>

Include dependency graph for Mutex.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Mutex

Defines

#define | Apoxi_Mutex_hpp

Define Documentation

#define Apoxi_Mutex_hpp

Generated on Tue Jan 24 21:05:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Mutex.hpp Source File

Kernel/Os/Mutex.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Mutex_hpp)
00010 #define Apoxi_Mutex_hpp
00013
00014 #include <Auxiliary/NonCloneable.hpp>
00015 #include <Kernel/Os/Semaphore.hpp>
00016 #include <Kernel/Os/Thread.hpp>
00017
00023 class Mutex : public NonCloneable {
00024     public:
00026         Mutex();
00027
00029         virtual ~Mutex();
00030
00033         BOOLEAN Create(BOOLEAN locked = TRUE);
00034
00041         BOOLEAN Obtain(const Ticks& timeout = Ticks::Infinite());
00042
00044         void Release();
00045
00046     private:
00047         INT         m_count;
00048         Semaphore   m_sem;
00049         ThreadId    m_thread_id;
00050 };
00051
00053 #endif  // Apoxi_Mutex_hpp
00054
00055
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/MutexObtainer.cpp File Reference

Kernel/Os/MutexObtainer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "MutexObtainer.hpp"
#include "Mutex.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for MutexObtainer.cpp:

Generated on Tue Jan 24 21:05:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/MutexObtainer.hpp File Reference

Kernel/Os/MutexObtainer.hpp File Reference

#include <Kernel/Os/Os.hpp>

Include dependency graph for MutexObtainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MutexObtainer

Defines

#define | MutexObtainer_hpp

Define Documentation

#define MutexObtainer_hpp

Generated on Tue Jan 24 21:05:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/MutexObtainer.hpp Source File

Kernel/Os/MutexObtainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(MutexObtainer_hpp)
00011 #define MutexObtainer_hpp
00014
00015 #include <Kernel/Os/Os.hpp>
00016
00017 class Mutex;
00018
00021 class MutexObtainer {
00022     public:
00026         MutexObtainer(Mutex* mtx, const Ticks& timeout);
00027
00029         MutexObtainer(Mutex* mtx);
00030
00032         ~MutexObtainer() { Release(); }
00033
00035         BOOLEAN IsObtained() const { return m_obtained; }
00036
00038         BOOLEAN Obtain(const Ticks& timeout);
00039
00041         BOOLEAN Obtain();
00042
00044         void Release();
00045
00046     private:
00047         BOOLEAN m_obtained;
00048         Mutex* m_mutex;
00049 };
00050
00052 #endif  // MutexObtainer_hpp
00053
00054
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Os.cpp File Reference

Kernel/Os/Os.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/Os/Os.hpp>
#include <Kernel/Os/Os.h>

Include dependency graph for Os.cpp:

Functions

void * | ApoxiAlloc (INT size)
void * | ApoxiAllocEx (INT size, UINT heapid)
void | ApoxiFree (void **p)
void HUGE * | ApoxiHugeAlloc (UINT32 size)
void HUGE * | ApoxiHugeAllocEx (UINT32 size, UINT heapid)
void | ApoxiHugeFree (void HUGE **p)
void HUGE * | ApoxiHugeRealloc (void HUGE *oldaddress, UINT32 newsize, BOOLEAN shallcopy)
void * | ApoxiRealloc (void *oldaddress, INT newsize, BOOLEAN shallcopy)
void * | ApoxiStackAlloc (INT size)
void | ApoxiStackFree (void **p)

Function Documentation

void* ApoxiAlloc ( INT size )

void* ApoxiAllocEx | ( | INT | size,
 |  | UINT | heapid
 | ) |

void ApoxiFree ( void ** p )

void HUGE* ApoxiHugeAlloc ( UINT32 size )

void HUGE* ApoxiHugeAllocEx | ( | UINT32 | size,
 |  | UINT | heapid
 | ) |

void ApoxiHugeFree ( void HUGE ** p )

void HUGE* ApoxiHugeRealloc | ( | void HUGE * | oldaddress,
 |  | UINT32 | newsize,
 |  | BOOLEAN | shallcopy
 | ) |

void* ApoxiRealloc | ( | void * | oldaddress,
 |  | INT | newsize,
 |  | BOOLEAN | shallcopy
 | ) |

void* ApoxiStackAlloc ( INT size )

void ApoxiStackFree ( void ** p )

Generated on Tue Jan 24 22:32:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Os.hpp File Reference

Kernel/Os/Os.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Thread.hpp>
#include <Kernel/Os/Semaphore.hpp>
#include <Kernel/Os/Trap.hpp>
#include <Kernel/Os/Scheduler.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Kernel/Os/OsStrLib.hpp>
#include <Kernel/Os/OsClass.hpp>

Include dependency graph for Os.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_Os_hpp
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND 0
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND 0

Variables

const UINT32 | c_apoxi_powersaving_timer_alignment_lower_bound = APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND
const UINT32 | c_apoxi_powersaving_timer_alignment_upper_bound = APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND

Define Documentation

#define Apoxi_Os_hpp

Generated on Tue Jan 24 22:39:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Os.hpp Source File

Kernel/Os/Os.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Os_hpp)
00011 #define Apoxi_Os_hpp
00012
00016
00017 #include <Kernel/Types.hpp>
00018
00019 #if defined(APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE)
00020     #define APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE/2
00021     #define APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE/2
00022 #endif
00023
00024 #if !defined(APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND)
00025     #define APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND 0
00026 #endif
00027
00028 #if !defined(APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND)
00029     #define APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND 0
00030 #endif
00031
00032 const UINT32 c_apoxi_powersaving_timer_alignment_lower_bound = APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND;
00033 const UINT32 c_apoxi_powersaving_timer_alignment_upper_bound = APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND;
00034
00035 #if defined(APOXI_RTOS_WIN32)
00036     // no more include necessary
00037 #elif defined(APOXI_RTOS_OSE166)
00038     // no more include necessary
00039 #elif defined(APOXI_RTOS_NUC32)
00040     // no more include necessary
00041 #else
00042     #error Unknown operating system or no operating system defined!
00043 #endif
00044
00045 #include <Kernel/Os/Thread.hpp>
00046 #include <Kernel/Os/Semaphore.hpp>
00047 #include <Kernel/Os/Trap.hpp>
00048 #include <Kernel/Os/Scheduler.hpp>
00049 #include <Kernel/Os/SystemTimer.hpp>
00050 #include <Kernel/Os/OsStrLib.hpp>
00051 #include <Kernel/Os/OsClass.hpp>
00052
00054
00055 #endif  // Apoxi_Os_hpp
00056
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/OsClass.hpp File Reference

Kernel/Os/OsClass.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Ticks.hpp>

Include dependency graph for OsClass.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Os

Defines

#define | APOXI_CONFIG_DBG_OUT_RANGE_ARRAY 5
#define | Apoxi_OsClass_hpp

Define Documentation

#define Apoxi_OsClass_hpp

Generated on Tue Jan 24 22:50:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/OsClass.hpp Source File

Kernel/Os/OsClass.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_OsClass_hpp)
00011 #define Apoxi_OsClass_hpp
00012
00015
00016 #include <Kernel/Types.hpp>
00017 #include <Kernel/Os/Ticks.hpp>
00018
00019 #if !defined(APOXI_CONFIG_DBG_OUT_RANGE_ARRAY)
00020     #define APOXI_CONFIG_DBG_OUT_RANGE_ARRAY 5
00021 #endif
00022
00023 // Implementation of the following prototypes has to be done in the Os
00024 // dependent files Ose166.cpp, Win32.cpp etc.
00025
00027 class Os {
00028     public:
00030         static BOOLEAN IsWhiteSpace(WCHAR ch);
00032         static BOOLEAN IsLineBreak(WCHAR ch);
00034         static void DbgOut(const WCHAR* fmt, ...);
00036         static void DbgOut(const CHAR* fmt, ...);
00038         static void DbgOut(UINT16 index, const WCHAR* fmt, ...);
00040         static void DbgOut(UINT16 index, const CHAR* fmt, ...);
00042         static void DbgOutStackUsage();
00044         static Ticks GetTicks(void);
00045
00048         static void Sleep(UINT32 timeout);
00049
00051         static void* Alloc(INT size, UINT heapid = 0);
00053         static void* Realloc(void* oldaddress, INT newsize, BOOLEAN shallcopy = FALSE);
00055         static void Free(void* p, UINT virtid = ~0);
00056
00058         static void HUGE* HugeAlloc(UINT32 size, UINT heapid = 0);
00060         static void HUGE* HugeRealloc(void HUGE*  oldaddress, UINT32 newsize, BOOLEAN shallcopy = FALSE);
00062         static void HugeFree(void HUGE* p, UINT virtid = ~0);
00063
00065         static void* StackAlloc(INT size);
00067         static void StackFree(void* p);
00068
00083 };
00084
00085 #if defined(APOXI_ENABLE_RUNTIME_CONFIGURATION)
00086     class String;
00087
00088     class DbgOutConfigurator {
00089         public:
00090             DbgOutConfigurator();
00091
00092             static BOOLEAN IsInRange(UINT idx);
00093
00094         private:
00095             struct Range {
00096                 UINT16 from;
00097                 UINT16 to;
00098             };
00099
00100             static Range m_range[APOXI_CONFIG_DBG_OUT_RANGE_ARRAY];
00101
00102             static BOOLEAN Parse(const String& str);
00103     };
00104 #endif
00105
00107 #endif  // Apoxi_OsClass_hpp
00108
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/OsStrLib.cpp File Reference

Kernel/Os/OsStrLib.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "OsStrLib.hpp"

Include dependency graph for OsStrLib.cpp:

Functions

UINT | GetStringLen (const char *s)
UINT | GetWStringLen (const wchar_t *w)

Function Documentation

UINT GetStringLen ( const char * s )

UINT GetWStringLen ( const wchar_t * w )

Generated on Tue Jan 24 22:50:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/OsStrLib.hpp File Reference

Kernel/Os/OsStrLib.hpp File Reference

#include <Kernel/Types.hpp>
#include <string.h>
#include <limits.h>

Include dependency graph for OsStrLib.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_Os_OsStrLib_hpp

Functions

UINT | GetStringLen (const char *s)
UINT | GetWStringLen (const wchar_t *w)

Define Documentation

#define Apoxi_Os_OsStrLib_hpp

Function Documentation

UINT GetStringLen ( const char * s )

UINT GetWStringLen ( const wchar_t * w )

Generated on Tue Jan 24 23:05:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/OsStrLib.hpp Source File

Kernel/Os/OsStrLib.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Os_OsStrLib_hpp)
00010 #define Apoxi_Os_OsStrLib_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <string.h>
00014 #include <limits.h>
00015
00016 #if defined(APOXI_RTOS_NUC16) | defined(APOXI_RTOS_SIM166)
00017
00018 class OutputStream;
00019 class InputStream;
00020
00021 #endif
00022
00023
00024     UINT GetStringLen(const char* s);
00025     UINT GetWStringLen(const wchar_t* w);
00026
00027 #if defined(APOXI_RTOS_NUC16) | defined(APOXI_RTOS_SIM166)
00028
00029     OutputStream& operator << (OutputStream& ostr, const WCHAR w);
00030     //InputStream& operator >> (InputStream& istr, WCHAR& w);
00031
00032 #endif
00033
00034 #endif // Apoxi_Os_OsStrLib_hpp
00035
00036
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/PreComp.cpp File Reference

Kernel/Os/PreComp.cpp File Reference

#include "Kernel/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:07:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Scheduler.hpp File Reference

Kernel/Os/Scheduler.hpp File Reference

#include <Kernel/Os/Win32/Scheduler.hpp>

Include dependency graph for Scheduler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Os_Scheduler_hpp

Define Documentation

#define Apoxi_Os_Scheduler_hpp

Generated on Tue Jan 24 21:12:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Scheduler.hpp Source File

Kernel/Os/Scheduler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Os_Scheduler_hpp)
00011 #define Apoxi_Os_Scheduler_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Kernel/Os/Win32/Scheduler.hpp>
00018 #elif defined(APOXI_RTOS_OSE166)
00019     #include <Kernel/Os/Ose166/Scheduler.hpp>
00020 #elif defined(APOXI_RTOS_NUC32)
00021     #include <Kernel/Os/Nuc32/Scheduler.hpp>
00022 #else
00023     #error Class Scheduler is not implemented for that operating system!
00024 #endif
00025
00027
00028 #endif  // Apoxi_Os_Scheduler_hpp
00029
00030
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Semaphore.hpp File Reference

Kernel/Os/Semaphore.hpp File Reference

#include <Kernel/Os/Win32/Semaphore.hpp>

Include dependency graph for Semaphore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Os_Semaphore_hpp

Define Documentation

#define Apoxi_Os_Semaphore_hpp

Generated on Tue Jan 24 21:22:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Semaphore.hpp Source File

Kernel/Os/Semaphore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Os_Semaphore_hpp)
00011 #define Apoxi_Os_Semaphore_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Kernel/Os/Win32/Semaphore.hpp>
00018 #elif defined(APOXI_RTOS_OSE166)
00019     #include <Kernel/Os/Ose166/Semaphore.hpp>
00020 #elif defined(APOXI_RTOS_NUC32)
00021     #include <Kernel/Os/Nuc32/Semaphore.hpp>
00022 #else
00023     #error Class Semaphore is not implemented for that operating system!
00024 #endif
00025
00027
00028 #endif  // Apoxi_Os_Semaphore_hpp
00029
00030
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SemObtainer.cpp File Reference

Kernel/Os/SemObtainer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SemObtainer.hpp"

Include dependency graph for SemObtainer.cpp:

Generated on Tue Jan 24 23:05:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SemObtainer.hpp File Reference

Kernel/Os/SemObtainer.hpp File Reference

#include <Kernel/Os/Os.hpp>

Include dependency graph for SemObtainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SemObtainer

Defines

#define | Apoxi_SemObtainer_hpp

Define Documentation

#define Apoxi_SemObtainer_hpp

Generated on Tue Jan 24 23:07:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SemObtainer.hpp Source File

Kernel/Os/SemObtainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_SemObtainer_hpp)
00011 #define Apoxi_SemObtainer_hpp
00014
00015 #include <Kernel/Os/Os.hpp>
00016
00021 class SemObtainer {
00022     public:
00025         SemObtainer(Semaphore* sem, const Ticks& timeout);
00026
00028         SemObtainer(Semaphore* sem);
00029
00031         ~SemObtainer() { Release(); }
00032
00034         BOOLEAN IsObtained() const { return m_obtained; }
00035
00037         BOOLEAN Obtain(const Ticks& timeout);
00038
00040         BOOLEAN Obtain();
00041
00043         void Release();
00044
00045     private:
00046         BOOLEAN m_obtained;
00047         Semaphore* m_sem;
00048 };
00049
00051 #endif  // Apoxi_SemObtainer_hpp
00052
00053
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SimpleMutex.cpp File Reference

Kernel/Os/SimpleMutex.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SimpleMutex.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for SimpleMutex.cpp:

Generated on Tue Jan 24 23:07:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SimpleMutex.hpp File Reference

Kernel/Os/SimpleMutex.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Os/SimpleSemaphore.hpp>
#include <Kernel/Os/Thread.hpp>

Include dependency graph for SimpleMutex.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimpleMutex

Defines

#define | Apoxi_SimpleMutex_hpp

Define Documentation

#define Apoxi_SimpleMutex_hpp

Generated on Tue Jan 24 23:07:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SimpleMutex.hpp Source File

Kernel/Os/SimpleMutex.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SimpleMutex_hpp)
00010 #define Apoxi_SimpleMutex_hpp
00013
00014 #include <Auxiliary/NonCloneable.hpp>
00015 #include <Kernel/Os/SimpleSemaphore.hpp>
00016 #include <Kernel/Os/Thread.hpp>
00017
00023 class SimpleMutex : public NonCloneable {
00024     public:
00026         SimpleMutex();
00027
00029         virtual ~SimpleMutex();
00030
00033         BOOLEAN Create(BOOLEAN locked = TRUE);
00034
00038         void Obtain();
00039
00041         void Release();
00042
00043     private:
00044         INT m_count;
00045         SimpleSemaphore m_sem;
00046         ThreadId m_thread_id;
00047 };
00048
00050 #endif  // Apoxi_SimpleMutex_hpp
00051
00052
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SimpleSemaphore.hpp File Reference

Kernel/Os/SimpleSemaphore.hpp File Reference

#include <Kernel/Os/Win32/SimpleSemaphore.hpp>

Include dependency graph for SimpleSemaphore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Os_SimpleSemaphore_hpp

Define Documentation

#define Apoxi_Os_SimpleSemaphore_hpp

Generated on Tue Jan 24 21:26:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SimpleSemaphore.hpp Source File

Kernel/Os/SimpleSemaphore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Os_SimpleSemaphore_hpp)
00011 #define Apoxi_Os_SimpleSemaphore_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Kernel/Os/Win32/SimpleSemaphore.hpp>
00018 #elif defined(APOXI_RTOS_OSE166)
00019     #include <Kernel/Os/Ose166/SimpleSemaphore.hpp>
00020 #elif defined(APOXI_RTOS_NUC32)
00021     #include <Kernel/Os/Nuc32/SimpleSemaphore.hpp>
00022 #else
00023     #error Class SimpleSemaphore is not implemented for that operating system!
00024 #endif
00025
00027
00028 #endif  // Apoxi_Os_SimpleSemaphore_hpp
00029
00030
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SystemTimer.hpp File Reference

Kernel/Os/SystemTimer.hpp File Reference

#include <Kernel/Os/Win32/SystemTimer.hpp>

Include dependency graph for SystemTimer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Os_SystemTimer_hpp

Define Documentation

#define Apoxi_Os_SystemTimer_hpp

Generated on Tue Jan 24 21:33:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/SystemTimer.hpp Source File

Kernel/Os/SystemTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Os_SystemTimer_hpp)
00011 #define Apoxi_Os_SystemTimer_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Kernel/Os/Win32/SystemTimer.hpp>
00018 #elif defined(APOXI_RTOS_OSE166)
00019     #include <Kernel/Os/Ose166/SystemTimer.hpp>
00020 #elif defined(APOXI_RTOS_NUC32)
00021     #include <Kernel/Os/Nuc32/SystemTimer.hpp>
00022 #else
00023     #error Class SystemTimer is not implemented for that operating system!
00024 #endif
00025
00027
00028 #endif  // Apoxi_Os_SystemTimer_hpp
00029
00030
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/TestWriter.cpp File Reference

Kernel/Os/TestWriter.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/Trace.hpp>
#include <stdio.h>
#include <stdarg.h>
#include <wchar.h>
#include <Kernel/VersionInfo.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/Macros.hpp>
#include "TestWriter.hpp"

Include dependency graph for TestWriter.cpp:

Defines

#define | BUF_MAX 255
#define | INSTRUMENT_NO 1

Define Documentation

#define BUF_MAX 255

#define INSTRUMENT_NO 1

Generated on Tue Jan 24 23:07:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/TestWriter.hpp File Reference

Kernel/Os/TestWriter.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for TestWriter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TestWriter

Defines

#define | Apoxi_TestWriter_hpp
#define | WRITE_STATE(args)
#define | WRITESTATE(eventId, value)

Define Documentation

#define Apoxi_TestWriter_hpp

Generated on Tue Jan 24 23:07:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/TestWriter.hpp Source File

Kernel/Os/TestWriter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_TestWriter_hpp)
00010 #define Apoxi_TestWriter_hpp
00013 #include <Kernel/Types.hpp>
00014
00015 #ifdef APOXI_TESTING
00016
00019 #define WRITESTATE(eventId, value) TestWriter::WriteState (eventId, value)
00020
00021 /* macro used for state output, can be switched on/off by defining/undefining APOXI_TESTING */
00022 #define WRITE_STATE(args) TestWriter::WriteState args
00023
00024 #define WRITE_MSG(byte, bit) if ((TestWriter::array[byte] & (1 << bit)) == 0) TestWriter::array[byte] = TestWriter::array[byte] | (1 << bit);
00025
00026 #else
00027
00029 #define WRITESTATE(eventId, value)
00030
00032 #define WRITE_STATE(args)
00033
00034 #endif
00035
00040 class TestWriter {
00041     public:
00050         static void WriteState(UINT16 eventId, const CHAR* value= "", ...);
00051
00054         static void WriteState(UINT16 eventId, const WCHAR* value = L"", ...);
00055
00056         static void WriteCoverageBuffer();
00057
00060      enum { WINDOW_OPENED_MSG = 11,
00061             WINDOW_CLOSED_MSG = 12,
00062             MENU_OPENED_MSG = 13,
00063             MENU_CLOSED_MSG = 14,
00064             MENU_ACTIVATED_MSG = 15,
00065             MENU_CHANGED_MSG = 16,
00066             SOFTKEY_SHOW_MSG = 17,
00067             SOFTKEY_PRESSED_MSG = 18,
00068             PIC_OUTPUT_MSG = 19,
00069             TEXT_OUTPUT_MSG = 20,
00070             MESSAGE_SENT_MSG = 21,
00071             MESSAGE_RECEIVED_MSG = 22,
00072             ACTION_EXECUTED_MSG = 23,
00073             VARIABLE_CHANGED_MSG = 24,
00074             APP_LOAD_MSG = 25,
00075             APP_EXIT_MSG = 26,
00076             METHOD_CALLED_MSG = 27,
00077             KEY_RECEIVED_MSG = 28,
00078                 ANIM_OUTPUT_MSG = 29,
00079                 ITEM_SELECTED_MSG = 30,
00080                 ITEM_COUNT_MSG = 31,
00081                 RADIO_SELECTED_MSG = 32,
00082                 RADIO_ACTIVE_MSG = 33,
00083                 CHECKBOX_ACTIVE_MSG = 34,
00084                 CHECKBOX_SELECTED_MSG = 35,
00085                 ACTION_DISABLED_MSG = 36
00086     };
00087
00088     static CHAR array[];
00089 }; // TestWriter
00091 #endif
00092
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Thread.hpp File Reference

Kernel/Os/Thread.hpp File Reference

#include <Kernel/Os/Win32/Thread.hpp>

Include dependency graph for Thread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Os_Thread_hpp

Define Documentation

#define Apoxi_Os_Thread_hpp

Generated on Tue Jan 24 21:45:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Thread.hpp Source File

Kernel/Os/Thread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Os_Thread_hpp)
00011 #define Apoxi_Os_Thread_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Kernel/Os/Win32/Thread.hpp>
00018 #elif defined(APOXI_RTOS_OSE166)
00019     #include <Kernel/Os/Ose166/Thread.hpp>
00020 #elif defined(APOXI_RTOS_NUC32)
00021     #include <Kernel/Os/Nuc32/Thread.hpp>
00022 #else
00023     #error Class Thread is not implemented for that operating system!
00024 #endif
00025
00027
00028 #endif  // Apoxi_Os_Thread_hpp
00029
00030
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Ticks.hpp File Reference

Kernel/Os/Ticks.hpp File Reference

#include <Kernel/Os/Win32/Ticks.hpp>

Include dependency graph for Ticks.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Os_Ticks_hpp

Define Documentation

#define Apoxi_Os_Ticks_hpp

Generated on Tue Jan 24 21:57:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Ticks.hpp Source File

Kernel/Os/Ticks.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Os_Ticks_hpp)
00011 #define Apoxi_Os_Ticks_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Kernel/Os/Win32/Ticks.hpp>
00018 #elif defined(APOXI_RTOS_OSE166)
00019     #include <Kernel/Os/Ose166/Ticks.hpp>
00020 #elif defined(APOXI_RTOS_NUC32)
00021     #include <Kernel/Os/Nuc32/Ticks.hpp>
00022 #else
00023     #error Class Ticks is not implemented for that operating system!
00024 #endif
00025
00027
00028 #endif  // Apoxi_Os_Ticks_hpp
00029
00030
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/TickValue.cpp File Reference

Kernel/Os/TickValue.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "TickValue.hpp"

Include dependency graph for TickValue.cpp:

Generated on Tue Jan 24 23:07:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/TickValue.hpp File Reference

Kernel/Os/TickValue.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for TickValue.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TickValue

Defines

#define | Apoxi_TickValue_hpp

Define Documentation

#define Apoxi_TickValue_hpp

Generated on Tue Jan 24 23:17:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/TickValue.hpp Source File

Kernel/Os/TickValue.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TickValue_hpp)
00011 #define Apoxi_TickValue_hpp
00012
00015
00016 #include <Kernel/Types.hpp>
00017
00019 class TickValue {
00020     public:
00022         TickValue() : m_tick_value(0) {}
00023
00025         TickValue(UINT32 tick_value) : m_tick_value(tick_value) {}
00026
00027         void Set(UINT32 tick_value) {m_tick_value = tick_value; }
00028         UINT32 Get() const {return m_tick_value; }
00029
00030     protected:
00031
00032     private:
00033         UINT32 m_tick_value;
00034 };
00035
00037
00038 #endif  // Apoxi_TickValue_hpp
00039
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Trap.hpp File Reference

Kernel/Os/Trap.hpp File Reference

#include <Kernel/Os/Win32/Trap.hpp>

Include dependency graph for Trap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_Os_Trap_hpp

Define Documentation

#define Apoxi_Os_Trap_hpp

Generated on Tue Jan 24 22:20:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Trap.hpp Source File

Kernel/Os/Trap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Os_Trap_hpp)
00011 #define Apoxi_Os_Trap_hpp
00012
00015
00016 #if defined(APOXI_RTOS_WIN32)
00017     #include <Kernel/Os/Win32/Trap.hpp>
00018 #elif defined(APOXI_RTOS_OSE166)
00019     #include <Kernel/Os/Ose166/Trap.hpp>
00020 #elif defined(APOXI_RTOS_NUC32)
00021     #include <Kernel/Os/Nuc32/Trap.hpp>
00022 #else
00023     #error Class Trap is not implemented for that operating system!
00024 #endif
00025
00027
00028 #endif  // Apoxi_Os_Trap_hpp
00029
00030
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/InternalTracer.cpp File Reference

Kernel/Os/Nuc32/InternalTracer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "../InternalTracer.hpp"
#include "../../ApplicationTracer.hpp"

Include dependency graph for InternalTracer.cpp:

Functions

void | hwtrc_send_apoxi_msg (const char *header, int headerLen, const char *msg, int msgLen)
void * | memcpy (void *dest, const void *src, size_t count)
long | RetrieveClock ()

Function Documentation

void hwtrc_send_apoxi_msg | ( | const char * | header,
 |  | int | headerLen,
 |  | const char * | msg,
 |  | int | msgLen
 | ) |

void* memcpy | ( | void * | dest,
 |  | const void * | src,
 |  | size_t | count
 | ) |

long RetrieveClock ( )

Generated on Tue Jan 24 21:06:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Nuc32.cpp File Reference

Kernel/Os/Nuc32/Nuc32.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Kernel/Types.hpp"
#include "Kernel/Application.hpp"
#include "Kernel/Os/Os.hpp"
#include "Kernel/Message.hpp"
#include "Kernel/MsgTypes.hpp"
#include "Kernel/Allocator.hpp"
#include "Kernel/AppContainer.hpp"
#include "Kernel/HeapManager.hpp"
#include "Kernel/Os/Os.h"
#include "RingBuffer.hpp"
#include "Auxiliary/WStrUtil.hpp"
#include "Kernel/System.hpp"
#include <stack/stack.h>
#include "Kernel/GenericWorkerTask.hpp"
#include "Socket/SocketSubSystem.hpp"
#include <nu_boot.h>

Include dependency graph for Nuc32.cpp:

Defines

#define | DBG_OUT_CONFIGURATOR_IS_IN_RANGE FALSE
#define | GLOBAL extern

Variables

const StackAtom | apoxi_stack_init_val

Define Documentation

#define DBG_OUT_CONFIGURATOR_IS_IN_RANGE FALSE

#define GLOBAL extern

Variable Documentation

const StackAtom apoxi_stack_init_val

Initial value:

    TASK_STACK_INIT_VAL << 24 | TASK_STACK_INIT_VAL << 16 | TASK_STACK_INIT_VAL << 8 | TASK_STACK_INIT_VAL

Generated on Tue Jan 24 21:06:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Nuc32.hpp File Reference

Kernel/Os/Nuc32/Nuc32.hpp File Reference

#include <Kernel/Os/Nuc32/NucInc.hpp>

Include dependency graph for Nuc32.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_NEVER_TIMEOUT NU_SUSPEND
#define | Apoxi_Nuc32_hpp

Typedefs

typedef NU_TASK | Task
typedef char * | ThreadName
typedef unsigned char | ThreadPriority

Define Documentation

#define APOXI_NEVER_TIMEOUT NU_SUSPEND

#define Apoxi_Nuc32_hpp

Typedef Documentation

typedef NU_TASK Task

typedef char* ThreadName

typedef unsigned char ThreadPriority

Generated on Tue Jan 24 21:06:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Nuc32.hpp Source File

Kernel/Os/Nuc32/Nuc32.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Nuc32_hpp)
00010 #define Apoxi_Nuc32_hpp
00011
00012 #include <Kernel/Os/Nuc32/NucInc.hpp>
00013
00014 // ----------------------------------------------------------------
00015 //
00016 //                          constants
00017 //
00018 // ----------------------------------------------------------------
00019 #define APOXI_NEVER_TIMEOUT NU_SUSPEND
00020
00021 // ----------------------------------------------------------------
00022 //
00023 //                          types
00024 //
00025 // ----------------------------------------------------------------
00026
00027 typedef unsigned char       ThreadPriority;
00028 typedef char *              ThreadName;
00029 typedef NU_TASK             Task;
00030
00031 #endif  // Apoxi_Nuc32_hpp
00032
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/NucInc.hpp File Reference

Kernel/Os/Nuc32/NucInc.hpp File Reference

#include <string.h>
#include <nucleus.h>
#include <limits.h>

Include dependency graph for NucInc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_Os_NucInc_hpp
#define | BOOLEAN NUCLEUS_H_BOOLEAN
#define | BYTE NUCLEUS_H_BYTE
#define | CHAR NUCLEUS_H_CHAR
#define | INT NUCLEUS_H_INT
#define | INT16 NUCLEUS_H_INT16
#define | INT32 NUCLEUS_H_INT32
#define | INT8 NUCLEUS_H_INT8
#define | LONG NUCLEUS_H_LONG
#define | UINT NUCLEUS_H_UINT
#define | UINT16 NUCLEUS_H_UINT16
#define | UINT32 NUCLEUS_H_UINT32
#define | UINT8 NUCLEUS_H_UINT8
#define | WCHAR NUCLEUS_H_WCHAR

Define Documentation

#define Apoxi_Os_NucInc_hpp

#define BOOLEAN NUCLEUS_H_BOOLEAN

#define BYTE NUCLEUS_H_BYTE

#define CHAR NUCLEUS_H_CHAR

#define INT NUCLEUS_H_INT

#define INT16 NUCLEUS_H_INT16

#define INT32 NUCLEUS_H_INT32

#define INT8 NUCLEUS_H_INT8

#define LONG NUCLEUS_H_LONG

#define UINT NUCLEUS_H_UINT

#define UINT16 NUCLEUS_H_UINT16

#define UINT32 NUCLEUS_H_UINT32

#define UINT8 NUCLEUS_H_UINT8

#define WCHAR NUCLEUS_H_WCHAR

Generated on Tue Jan 24 21:06:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/NucInc.hpp Source File

Kernel/Os/Nuc32/NucInc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Os_NucInc_hpp)
00010 #define Apoxi_Os_NucInc_hpp
00011
00012 #if !defined(APOXI_RTOS_NUC32)
00013     #error Os/NucInc.hpp can only be included with APOXI_RTOS_NUC32 configuration
00014 #endif
00015
00016 #include <string.h>
00017
00018 #undef BOOLEAN
00019 #undef BYTE
00020 #undef CHAR
00021 #undef INT
00022 #undef INT8
00023 #undef INT16
00024 #undef INT32
00025 #undef LONG
00026 #undef UINT
00027 #undef UINT8
00028 #undef UINT16
00029 #undef UINT32
00030 #undef WCHAR
00031
00032 #define BOOLEAN NUCLEUS_H_BOOLEAN
00033 #define BYTE NUCLEUS_H_BYTE
00034 #define CHAR NUCLEUS_H_CHAR
00035 #define INT NUCLEUS_H_INT
00036 #define INT8 NUCLEUS_H_INT8
00037 #define INT16 NUCLEUS_H_INT16
00038 #define INT32 NUCLEUS_H_INT32
00039 #define LONG NUCLEUS_H_LONG
00040 #define UINT NUCLEUS_H_UINT
00041 #define UINT8 NUCLEUS_H_UINT8
00042 #define UINT16 NUCLEUS_H_UINT16
00043 #define UINT32 NUCLEUS_H_UINT32
00044 #define WCHAR NUCLEUS_H_WCHAR
00045
00046 #include <nucleus.h>
00047
00048 #undef BOOLEAN
00049 #undef BYTE
00050 #undef CHAR
00051 #undef INT
00052 #undef INT8
00053 #undef INT16
00054 #undef INT32
00055 #undef LONG
00056 #undef UINT
00057 #undef UINT8
00058 #undef UINT16
00059 #undef UINT32
00060 #undef WCHAR
00061
00062 #include <limits.h>
00063
00064 #endif  // Apoxi_Os_NucInc_hpp
00065
00066
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/PreComp.cpp File Reference

Kernel/Os/Nuc32/PreComp.cpp File Reference

#include "Kernel/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:07:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/RingBuffer.cpp File Reference

Kernel/Os/Nuc32/RingBuffer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "RingBuffer.hpp"

Include dependency graph for RingBuffer.cpp:

Defines

#define | CMAX 99
#define | NMAX 161

Functions

CHAR * | get_ringbuffer (void)
void | put_ringbuffer (CHAR *c)

Define Documentation

#define CMAX 99

#define NMAX 161

Function Documentation

CHAR* get_ringbuffer ( void )

void put_ringbuffer ( CHAR * c )

Generated on Tue Jan 24 21:06:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/RingBuffer.hpp File Reference

Kernel/Os/Nuc32/RingBuffer.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for RingBuffer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_RingBuffer_hpp

Functions

CHAR * | get_ringbuffer (void)
void | put_ringbuffer (CHAR *c)

Define Documentation

#define Apoxi_RingBuffer_hpp

Function Documentation

CHAR* get_ringbuffer ( void )

void put_ringbuffer ( CHAR * c )

Generated on Tue Jan 24 21:06:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/RingBuffer.hpp Source File

Kernel/Os/Nuc32/RingBuffer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_RingBuffer_hpp)
00011 #define Apoxi_RingBuffer_hpp
00012
00013 #include <Kernel/Types.hpp>
00014
00015 CHAR* get_ringbuffer(void);
00016 void put_ringbuffer(CHAR* c);
00017
00018 #endif
00019
00020
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Scheduler.cpp File Reference

Kernel/Os/Nuc32/Scheduler.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Scheduler.hpp"
#include <Kernel/MessageReferrer.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/Condition.hpp>
#include <stack/stack.h>

Include dependency graph for Scheduler.cpp:

Variables

const ULONG c_stack_magic_start = 0xaffe0000

Variable Documentation

const ULONG c_stack_magic_start = 0xaffe0000

Generated on Tue Jan 24 21:06:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Scheduler.hpp File Reference

Kernel/Os/Nuc32/Scheduler.hpp File Reference

#include <setjmp.h>
#include <Kernel/AbstractScheduler.hpp>

Include dependency graph for Scheduler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | _JUMP_BUFFER
class | AppContext
union | JmpBuf
class | Scheduler

Defines

#define | Apoxi_Scheduler_hpp

Typedefs

typedef UINT32 | StackAtom

Define Documentation

#define Apoxi_Scheduler_hpp

Typedef Documentation

typedef UINT32 StackAtom

Generated on Tue Jan 24 21:06:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Scheduler.hpp Source File

Kernel/Os/Nuc32/Scheduler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Scheduler_hpp)
00010 #define Apoxi_Scheduler_hpp
00011
00012 #include <setjmp.h>
00013 #include <Kernel/AbstractScheduler.hpp>
00014
00015
00016 typedef struct  {
00017     jmp_buf buf;
00018 } _JUMP_BUFFER;
00019
00020 union JmpBuf {
00021     jmp_buf jb_std;
00022     _JUMP_BUFFER jb;
00023 };
00024
00025 typedef UINT32 StackAtom;
00026
00033 class Scheduler : public AbstractScheduler {
00034
00035     public:
00036         typedef AbstractScheduler Base;
00037
00040         Scheduler(AppContainer *cont);
00041
00043         virtual ~Scheduler();
00044
00047         virtual AbstractAppContext* CreateAppContext(Application *app);
00048
00051         virtual void StartUp();
00052
00058         virtual void SendMsg(const Application *app, Message &msg);
00059
00062         virtual void Reschedule();
00063
00068         virtual void Wait(const Application *app, const Condition &cond);
00069
00070     private:
00072         JmpBuf m_jmpbuf;
00073 };
00074
00075
00085 class AppContext : public AbstractAppContext {
00086
00087     public:
00088         typedef AbstractAppContext Base;
00089
00093         AppContext(Scheduler *scheduler, Application *app);
00094
00096         virtual ~AppContext();
00097
00100         virtual void StartUp();
00101
00104         virtual void MsgLoop();
00105
00108         virtual void SendMsg(Message &msg) ;
00109
00113         virtual void Wait(const Condition &cond);
00114
00116         StackAtom   *GetAppStackBase();
00118         UINT32      GetAppStackSize();
00119
00120     private:
00121         #if defined(APOXI_ENABLE_STACK_CHECK)
00122             /* Checks the stack for overflows
00123                 @return     TRUE if ok
00124                         FALSE if a stack overflow occured */
00125             BOOLEAN CheckStack() const;
00126         #endif
00127
00130         StackAtom *m_app_stackbase;
00131         UINT32 m_app_stacksize;
00132
00137         JmpBuf m_jmpbuf;
00138
00140         Message* m_msg;
00141 };
00142
00143 #endif
00144
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Semaphore.cpp File Reference

Kernel/Os/Nuc32/Semaphore.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/Types.hpp>
#include <limits.h>
#include "Nuc32.hpp"
#include "Semaphore.hpp"
#include "stack/stack.h"
#include <Auxiliary/Macros.hpp>
#include <stack/driver.h>
#include <Kernel/Os/Os.hpp>

Include dependency graph for Semaphore.cpp:

Defines

#define | Apoxi_Semaphore_cpp
#define | TIMER_SEM_INFINITE ULONG_MAX

Define Documentation

#define Apoxi_Semaphore_cpp

#define TIMER_SEM_INFINITE ULONG_MAX

Generated on Tue Jan 24 21:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Semaphore.hpp File Reference

Kernel/Os/Nuc32/Semaphore.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Os/Nuc32/Ticks.hpp>

Include dependency graph for Semaphore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Semaphore

Defines

#define | Apoxi_Semaphore_hpp

Define Documentation

#define Apoxi_Semaphore_hpp

Generated on Tue Jan 24 21:16:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Semaphore.hpp Source File

Kernel/Os/Nuc32/Semaphore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_Semaphore_hpp)
00011 #define Apoxi_Semaphore_hpp
00012
00013 #include <Auxiliary/NonCloneable.hpp>
00014 #include <Kernel/Os/Nuc32/Ticks.hpp>
00015
00016 struct TimerSem;
00017
00018 /*----------------------------------------------------------------
00019                             Semaphore
00020   ----------------------------------------------------------------*/
00021
00022 class Semaphore : public NonCloneable {
00023     public:
00024         Semaphore();
00025         virtual ~Semaphore();
00026
00027         BOOLEAN Create(INT init_val = 0, INT max_val = -1);
00028         BOOLEAN Obtain(Ticks timeout = Ticks::Infinite());
00029         void Release();
00030
00031     private:
00032         TimerSem* m_sem;
00033
00034         static TimerSem* TimerSemCreate(INT init_val, INT max_val);
00035         static void TimerSemDelete(TimerSem *sem);
00036         static void TimerSemExpired(void *ctx);
00037         static BOOLEAN TimerSemWait(TimerSem *sem, unsigned long timeout);
00038         static void TimerSemSignal(TimerSem *sem);
00039 };
00040
00041
00042 #endif  // Apoxi_Semaphore_hpp
00043
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SimpleSemaphore.cpp File Reference

Kernel/Os/Nuc32/SimpleSemaphore.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SimpleSemaphore.hpp"
#include "Nuc32.hpp"
#include <stack/stack.h>
#include <Auxiliary/Macros.hpp>

Include dependency graph for SimpleSemaphore.cpp:

Defines

#define Apoxi_SimpleSemaphore_cpp

Define Documentation

#define Apoxi_SimpleSemaphore_cpp

Generated on Tue Jan 24 21:26:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SimpleSemaphore.hpp File Reference

Kernel/Os/Nuc32/SimpleSemaphore.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Types.hpp>

Include dependency graph for SimpleSemaphore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimpleSemaphore

Defines

#define | Apoxi_SimpleSemaphore_hpp

Define Documentation

#define Apoxi_SimpleSemaphore_hpp

Generated on Tue Jan 24 21:26:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SimpleSemaphore.hpp Source File

Kernel/Os/Nuc32/SimpleSemaphore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SimpleSemaphore_hpp)
00010 #define Apoxi_SimpleSemaphore_hpp
00011
00012 #include <Auxiliary/NonCloneable.hpp>
00013 #include <Kernel/Types.hpp>
00014
00015 /*----------------------------------------------------------------
00016                             SimpleSemaphore
00017   ----------------------------------------------------------------*/
00018 class SimpleSemaphore : public NonCloneable {
00019     public:
00020         SimpleSemaphore();
00021         virtual ~SimpleSemaphore();
00022
00023         BOOLEAN Create(INT init_val = 0, INT max_val = -1);
00024         void Obtain();
00025         void Release();
00026
00027     private:
00028         void* m_sem;
00029 };
00030
00031 #endif  // Apoxi_SimpleSemaphore_hpp
00032
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SocketPeer.cpp File Reference

Kernel/Os/Nuc32/SocketPeer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SocketPeer.hpp"

Include dependency graph for SocketPeer.cpp:

Generated on Tue Jan 24 21:26:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SocketPeer.hpp File Reference

Kernel/Os/Nuc32/SocketPeer.hpp File Reference

#include <Auxiliary/String.hpp>

Include dependency graph for SocketPeer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketPeer

Defines

#define | Apoxi_Os_SocketPeer_hpp

Define Documentation

#define Apoxi_Os_SocketPeer_hpp

Generated on Tue Jan 24 21:26:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SocketPeer.hpp Source File

Kernel/Os/Nuc32/SocketPeer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Os_SocketPeer_hpp)
00010 #define Apoxi_Os_SocketPeer_hpp
00011
00012 #include <Auxiliary/String.hpp>
00013
00014
00015 class SocketPeer {
00016     public :
00017         SocketPeer();
00018         virtual ~SocketPeer();
00019
00020         BOOLEAN Bind(UINT16 port);
00021         BOOLEAN Connect(const String& address, UINT16 port);
00022         BOOLEAN Accept(const String& address, UINT16 port);
00023         BOOLEAN Listen(INT backlog = 1);
00024         void Close();
00025
00026         BOOLEAN Read(BYTE* data, UINT length);
00027         BOOLEAN Write(const BYTE* data, UINT length);
00028
00029         String GetLocalName() const;
00030         UINT16 GetLocalPort() const;
00031         String GetPeerName() const;
00032         UINT16 GetPeerPort() const;
00033
00034         void SetLinger(BOOLEAN flag, INT timeout);
00035         BOOLEAN IsLingerEnabled();
00036         INT GetLingerTimeout();
00037         void SetBlockingEnabled(BOOLEAN flag);
00038         UINT32 GetAvailableCount();
00039
00040     private:
00041 };
00042
00043
00044 #endif // Apoxi_Os_SocketPeer_hpp
00045
00046
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SystemTimer.cpp File Reference

Kernel/Os/Nuc32/SystemTimer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SystemTimer.hpp"
#include <Auxiliary/Macros.hpp>
#include <stack/driver.h>

Include dependency graph for SystemTimer.cpp:

Generated on Tue Jan 24 21:26:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SystemTimer.hpp File Reference

Kernel/Os/Nuc32/SystemTimer.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for SystemTimer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SystemTimer
struct | SystemTimer::_call_back

Defines

#define | Apoxi_SystemTimer_hpp

Define Documentation

#define Apoxi_SystemTimer_hpp

Generated on Tue Jan 24 21:26:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/SystemTimer.hpp Source File

Kernel/Os/Nuc32/SystemTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SystemTimer_hpp)
00010 #define Apoxi_SystemTimer_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Kernel/Os/Os.hpp>
00014
00015 struct tic_timer_s;
00016
00017 class SystemTimer {
00018     public:
00019         typedef void (*CallBackFn)(void*);
00020
00021         SystemTimer();
00022         SystemTimer(UINT32 timeout, CallBackFn OnTimer, void* arg = 0, BOOLEAN autotimer = FALSE);
00023         ~SystemTimer();
00024
00025         void Init(UINT32 timeout, CallBackFn OnTimer, void* arg = 0, BOOLEAN autotimer = FALSE);
00026
00027         void SetTimeout(UINT32 timeout) { m_timeout = timeout; }
00028         UINT32 GetTimeout() const { return m_timeout; }
00029
00031         void Start();
00032
00035         UINT32 Stop();
00036
00038         void Restart();
00039
00041         BOOLEAN IsActive() const { return m_active; };
00042
00043     private:
00044         BOOLEAN m_active;
00045         BOOLEAN m_autotimer;
00046         UINT32 m_timeout;
00047         tic_timer_s* m_hdl;
00048         Ticks m_started;
00049
00050         struct _call_back {
00051             CallBackFn fn;
00052             void* arg;
00053             SystemTimer* m_system_timer;
00054         } m_callback;
00055
00056         static void OnTimer(void *arg);
00057 };
00058
00059 #endif  // Apoxi_SystemTimer_hpp
00060
00061
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Thread.cpp File Reference

Kernel/Os/Nuc32/Thread.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/Types.hpp>
#include <Auxiliary/NonCloneable.hpp>
#include "Nuc32.hpp"
#include "Thread.hpp"
#include "Trap.hpp"
#include <Auxiliary/Macros.hpp>
#include <stack/stack.h>
#include <nu_boot.h>

Include dependency graph for Thread.cpp:

Defines

#define | GLOBAL extern
#define | THREAD_DATA_SEM_OBTAIN if (m_sem_initialized) os_sem_wait(s_thread_data_sem)
#define | THREAD_DATA_SEM_RELEASE if (m_sem_initialized) os_sem_signal(s_thread_data_sem)

Variables

const StackAtom | apoxi_stack_init_val

Define Documentation

#define GLOBAL extern

#define THREAD_DATA_SEM_OBTAIN if (m_sem_initialized) os_sem_wait(s_thread_data_sem)

#define THREAD_DATA_SEM_RELEASE if (m_sem_initialized) os_sem_signal(s_thread_data_sem)

Variable Documentation

const StackAtom apoxi_stack_init_val

Initial value:

    TASK_STACK_INIT_VAL << 24 | TASK_STACK_INIT_VAL << 16 | TASK_STACK_INIT_VAL << 8 | TASK_STACK_INIT_VAL

Generated on Tue Jan 24 21:39:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Thread.hpp File Reference

Kernel/Os/Nuc32/Thread.hpp File Reference

#include <Auxiliary/SimpleMap.hpp>
#include <Kernel/Os/Nuc32/Scheduler.hpp>

Include dependency graph for Thread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Thread

Defines

#define | Apoxi_Nuc32_Thread_hpp
#define | APOXI_THREAD_PRIORITY_NORMAL 100
#define | c_max_thread_name_length 8

Typedefs

typedef NU_TASK_STRUCT * | ThreadId

Define Documentation

#define Apoxi_Nuc32_Thread_hpp

#define APOXI_THREAD_PRIORITY_NORMAL 100

#define c_max_thread_name_length 8

Typedef Documentation

typedef NU_TASK_STRUCT* ThreadId

Generated on Tue Jan 24 21:39:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Thread.hpp Source File

Kernel/Os/Nuc32/Thread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Nuc32_Thread_hpp)
00010 #define Apoxi_Nuc32_Thread_hpp
00011
00012 #include <Auxiliary/SimpleMap.hpp>
00013 #include <Kernel/Os/Nuc32/Scheduler.hpp>
00014
00015 #define c_max_thread_name_length 8
00016
00017 #if !defined(APOXI_THREAD_PRIORITY_NORMAL)
00018     #define APOXI_THREAD_PRIORITY_NORMAL 100
00019 #endif
00020
00021 struct NU_TASK_STRUCT;
00022
00023 typedef NU_TASK_STRUCT* ThreadId;
00024
00025 class Thread {
00026     public:
00027         enum PriorityLevel {
00028             PriorityBackground5 = APOXI_THREAD_PRIORITY_NORMAL + 5,
00029             PriorityBackground4 = APOXI_THREAD_PRIORITY_NORMAL + 4,
00030             PriorityBackground3 = APOXI_THREAD_PRIORITY_NORMAL + 3,
00031             PriorityBackground2 = APOXI_THREAD_PRIORITY_NORMAL + 2,
00032             PriorityBackground1 = APOXI_THREAD_PRIORITY_NORMAL + 1,
00033             PriorityNormal      = APOXI_THREAD_PRIORITY_NORMAL,
00034             PriorityForeground1 = APOXI_THREAD_PRIORITY_NORMAL - 1,
00035             PriorityForeground2 = APOXI_THREAD_PRIORITY_NORMAL - 2,
00036             PriorityForeground3 = APOXI_THREAD_PRIORITY_NORMAL - 3,
00037             PriorityForeground4 = APOXI_THREAD_PRIORITY_NORMAL - 4,
00038             PriorityForeground5 = APOXI_THREAD_PRIORITY_NORMAL - 5,
00039         };
00040
00041         Thread();
00042         virtual ~Thread();
00043
00044         void SetRequestedStackSize(UINT32 size);
00045         UINT32 GetRequestedStackSize() { return m_requested_stacksize; }
00046
00047         BOOLEAN Run(UINT32 stacksize = 0, void *stack = 0);
00048
00049         virtual INT ThreadFn() = 0;
00050
00051         INT GetPriority() const { return m_priority; }
00052         BOOLEAN SetPriority(INT priority);
00053
00054         BOOLEAN IncreasePriority();
00055         BOOLEAN DecreasePriority();
00056
00057         void SetName(const CHAR* name);
00058         const CHAR* GetName() const { return m_name; };
00059
00060         INT Suspend() const;
00061         INT Resume() const;
00062         INT Yield() const;
00063
00064         BOOLEAN Terminate(INT exit_code = 0);
00065
00066         static ThreadId GetThreadId();
00067         static void SetThreadData(void *data);
00068         static void* GetThreadData();
00069
00070     private:
00071         friend class Os;
00072
00073         enum Status {
00074             THREAD_INVALID,
00075             THREAD_RUNNING,
00076             THREAD_SUSPENDED,
00077             THREAD_TERMINATED
00078         };
00079
00080         mutable Status m_status;
00081         INT m_priority;
00082         UINT32 m_requested_stacksize;
00083         StackAtom* m_stack;
00084         CHAR m_name[c_max_thread_name_length];
00085
00086         NU_TASK_STRUCT* m_thread_data;
00087
00089         Thread(const Thread& thread);
00090         Thread& operator=(const Thread& thread);
00091
00093         static BOOLEAN m_sem_initialized;
00094         static SimpleMap<ThreadId, void *> m_thread_data_map;   // The map storing the thread data.
00095
00096         static void ThreadStartProc(UINT32 argc, void* param);
00097 };
00098
00099 #endif  // Apoxi_Nuc32_Thread_hpp
00100
00101
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Ticks.cpp File Reference

Kernel/Os/Nuc32/Ticks.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Ticks.hpp"
#include <Kernel/Os/OsClass.hpp>

Include dependency graph for Ticks.cpp:

Generated on Tue Jan 24 21:48:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Ticks.hpp File Reference

Kernel/Os/Nuc32/Ticks.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/TickValue.hpp>
#include <limits.h>

Include dependency graph for Ticks.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Ticks
Ticks is a convertion class between OS specific tick values and milliseconds. More...

Defines

#define | Apoxi_Ticks_hpp

Define Documentation

#define Apoxi_Ticks_hpp

Generated on Tue Jan 24 21:48:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Ticks.hpp Source File

Kernel/Os/Nuc32/Ticks.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Ticks_hpp)
00010 #define Apoxi_Ticks_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Kernel/Os/TickValue.hpp>
00014 #include <limits.h>
00015
00017 class Ticks {
00018     public:
00020         Ticks() : m_ticks(0) {}
00021
00023         Ticks(UINT32 ms) { SetMilliSeconds(ms); }
00024
00026         Ticks(const Ticks &ticks) : m_ticks(ticks.m_ticks) {}
00027
00029         explicit Ticks(const TickValue& tick_value) : m_ticks(tick_value.Get()) {}
00030
00032         void SetEmpty() { m_ticks = 0; }
00033
00035         BOOLEAN IsEmpty() const { return m_ticks == 0; }
00036
00038         UINT32 GetExpiredTime() const;
00039
00041         UINT32 GetExpiredTime(const Ticks &ticks) const;
00042
00043         Ticks& operator =(const Ticks &ticks) { m_ticks = ticks.m_ticks; return *this; }
00044
00046         Ticks operator +(const Ticks &ticks) const {
00047             Ticks sum;
00048             sum.m_ticks = m_ticks + ticks.m_ticks;
00049             return sum;
00050         }
00051
00053         Ticks& operator +=(const Ticks &ticks) { m_ticks += ticks.m_ticks; return *this; }
00054
00056         Ticks operator -(const Ticks &ticks) const {
00057             Ticks diff;
00058             diff.m_ticks = m_ticks - ticks.m_ticks;
00059             return diff;
00060         }
00061
00063         Ticks& operator -=(const Ticks &ticks) { m_ticks -= ticks.m_ticks; return *this; }
00064
00066         BOOLEAN operator ==(const Ticks &ticks) const { return m_ticks == ticks.m_ticks; }
00067
00069         BOOLEAN operator !=(const Ticks &ticks) const { return m_ticks != ticks.m_ticks; }
00070
00072         BOOLEAN operator >(const Ticks &ticks) const { return m_ticks > ticks.m_ticks; }
00073
00075         BOOLEAN operator <(const Ticks &ticks) const { return m_ticks < ticks.m_ticks; }
00076
00078         BOOLEAN operator >=(const Ticks &ticks) const { return m_ticks >= ticks.m_ticks; }
00079
00081         BOOLEAN operator <=(const Ticks &ticks) const { return m_ticks <= ticks.m_ticks; }
00082
00084         static Ticks Infinite() {
00085             Ticks ticks;
00086             ticks.m_ticks = ULONG_MAX;
00087             return ticks;
00088         }
00089
00090     private:
00091         UINT32  m_ticks;
00092
00093         void SetMilliSeconds(UINT32 time);
00094
00095         UINT32 GetMilliSeconds() const;
00096
00097         friend class Timer;
00098         friend class Os;
00099         friend class Semaphore;
00100         friend class SysSocket;
00101 };
00102
00103 #endif  // Apoxi_Ticks_hpp
00104
00105
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Trap.cpp File Reference

Kernel/Os/Nuc32/Trap.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Trap.hpp"
#include <Gui/TextFormat.hpp>
#include <Gui/Font.hpp>
#include <Kernel/System.hpp>
#include <Config/FontConfig.hpp>
#include <Config/DisplayConfig.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Auxiliary/Provider.hpp>
#include <stack/stack.h>
#include <stack/driver.h>

Include dependency graph for Trap.cpp:

Variables

const INT c_trap_system_stack_log_size = TRAP_SYSTEM_STACK_LOG_SIZE/sizeof(UINT32)

Variable Documentation

const INT c_trap_system_stack_log_size = TRAP_SYSTEM_STACK_LOG_SIZE/sizeof(UINT32)

Generated on Tue Jan 24 22:07:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Trap.hpp File Reference

Kernel/Os/Nuc32/Trap.hpp File Reference

#include <Kernel/Types.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/Macros.hpp>

Include dependency graph for Trap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Trap

Defines

#define | Apoxi_Trap_hpp

Typedefs

typedef void(* | TrapCB )(CHAR *filename, INT line)

Define Documentation

#define Apoxi_Trap_hpp

Typedef Documentation

typedef void(* TrapCB)(CHAR *filename, INT line)

Generated on Tue Jan 24 22:07:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Nuc32/Trap.hpp Source File

Kernel/Os/Nuc32/Trap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Trap_hpp)
00010 #define Apoxi_Trap_hpp
00011
00012 #include <Kernel/Types.hpp>
00013 #include <Auxiliary/WString.hpp>
00014 #include <Auxiliary/Macros.hpp>
00015
00016 class Provider;
00017
00018 typedef void (* TrapCB)(CHAR * filename, INT line);
00019
00021 class Trap {
00022     public:
00024         static void Init();
00025
00027         static void SetHandler(TrapCB hdl) { m_hdl = hdl; }
00028
00030         static void Assertion(BOOLEAN arg);
00031
00033         static void Assertion(BOOLEAN arg, CHAR * filename, INT line);
00034
00036         static Provider& GetProvider();
00037
00038     private:
00039         static BOOLEAN      m_RunnigClassBTrap;
00040         static BOOLEAN      m_SoftTrap;
00041         static TrapCB       m_hdl;
00042
00043         static INT DrawText(XYDIM, XYDIM, const CHAR*);
00044 };
00045
00046 #endif  // Apoxi_Trap_hpp
00047
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/InternalTracer.cpp File Reference

Kernel/Os/Win32/InternalTracer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/Os/InternalTracer.hpp>
#include <Kernel/ApplicationTracer.hpp>
#include "Win32.hpp"
#include <imagehlp.h>

Include dependency graph for InternalTracer.cpp:

Defines

#define | HWTRC_APOXI_END "\x1B\x21"
#define | HWTRC_APOXI_START "\x1B\x20"
#define | HWTRC_ESCAPE "\x1B\xe4"
#define | HWTRC_INTRO_CHAR 0x1B
#define | TRACE_HOST_NAME "localhost"
#define | TRACE_PORT 6000

Typedefs

typedef unsigned char | UCHAR

Functions

bool | GetCurrentContext (STACKFRAME *callStack)
void | hwtrc_putchars (const void *buffer, int size)
void | hwtrc_send_apoxi_msg (const char *header, int headerLen, const char *msg, int msgLen)
UINT32 | InternalCallStackAdr (STACKFRAME *callStack)

Variables

SOCKET | g_trace_socket = INVALID_SOCKET
bool | g_tracing_initialized = false

Define Documentation

#define HWTRC_APOXI_END "\x1B\x21"

#define HWTRC_APOXI_START "\x1B\x20"

#define HWTRC_ESCAPE "\x1B\xe4"

#define HWTRC_INTRO_CHAR 0x1B

#define TRACE_HOST_NAME "localhost"

#define TRACE_PORT 6000

Typedef Documentation

typedef unsigned char UCHAR

Function Documentation

bool GetCurrentContext ( STACKFRAME * callStack )

void hwtrc_putchars | ( | const void * | buffer,
 |  | int | size
 | ) |

void hwtrc_send_apoxi_msg | ( | const char * | header,
 |  | int | headerLen,
 |  | const char * | msg,
 |  | int | msgLen
 | ) |

UINT32 InternalCallStackAdr ( STACKFRAME * callStack )

Variable Documentation

SOCKET g_trace_socket = INVALID_SOCKET

bool g_tracing_initialized = false

Generated on Tue Jan 24 21:06:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/PreComp.cpp File Reference

Kernel/Os/Win32/PreComp.cpp File Reference

#include "Kernel/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:07:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Scheduler.cpp File Reference

Kernel/Os/Win32/Scheduler.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Scheduler.hpp"
#include <Kernel/MessageReferrer.hpp>
#include <Kernel/Application.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/MsgQueue.hpp>

Include dependency graph for Scheduler.cpp:

Generated on Tue Jan 24 21:06:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Scheduler.hpp File Reference

Kernel/Os/Win32/Scheduler.hpp File Reference

#include <setjmp.h>
#include <Kernel/AbstractScheduler.hpp>

Include dependency graph for Scheduler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AppContext
union | JmpBuf
class | Scheduler

Defines

#define | Apoxi_Scheduler_hpp

Typedefs

typedef UINT32 | StackAtom

Define Documentation

#define Apoxi_Scheduler_hpp

Generated on Tue Jan 24 21:16:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Scheduler.hpp Source File

Kernel/Os/Win32/Scheduler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Scheduler_hpp)
00010 #define Apoxi_Scheduler_hpp
00013
00014 #include <setjmp.h>
00015 #include <Kernel/AbstractScheduler.hpp>
00016
00017 union JmpBuf {
00018     jmp_buf jb_std;
00019     _JUMP_BUFFER jb;
00020 };
00021
00022 typedef UINT32 StackAtom;
00023
00024 static const INT c_stack_size = 10000;
00025
00026
00028 class Scheduler : public AbstractScheduler {
00029
00030     public:
00031         typedef AbstractScheduler Base;
00032
00035         Scheduler(AppContainer *cont);
00036
00038         virtual ~Scheduler();
00039
00042         virtual AbstractAppContext* CreateAppContext(Application *app);
00043
00045         virtual void StartUp();
00046
00050         virtual void SendMsg(const Application *app, Message &msg);
00051
00053         virtual void Reschedule();
00054
00059         virtual void Wait(const Application *app, const Condition &cond);
00060
00061     private:
00063         JmpBuf m_jmpbuf;
00064 };
00065
00066
00070 class AppContext : public AbstractAppContext {
00071
00072     public:
00073         typedef AbstractAppContext Base;
00074
00078         AppContext(Scheduler *scheduler, Application *app);
00079
00081         virtual ~AppContext();
00082
00084         virtual void StartUp();
00085
00087         virtual void MsgLoop();
00088
00091         virtual void SendMsg(Message &msg) ;
00092
00096         virtual void Wait(const Condition &cond);
00097
00098     private:
00100         StackAtom m_stack[c_stack_size];
00102         JmpBuf m_jmpbuf;
00104         Message* m_msg;
00105 };
00106
00108 #endif
00109
00110
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Semaphore.cpp File Reference

Kernel/Os/Win32/Semaphore.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Semaphore.hpp"
#include "Win32.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for Semaphore.cpp:

Generated on Tue Jan 24 21:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Semaphore.hpp File Reference

Kernel/Os/Win32/Semaphore.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Os/Ticks.hpp>

Include dependency graph for Semaphore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Semaphore

Defines

#define | Apoxi_Semaphore_hpp

Define Documentation

#define Apoxi_Semaphore_hpp

Generated on Tue Jan 24 21:26:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Semaphore.hpp Source File

Kernel/Os/Win32/Semaphore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Semaphore_hpp)
00010 #define Apoxi_Semaphore_hpp
00013
00014 #include <Auxiliary/NonCloneable.hpp>
00015 #include <Kernel/Os/Ticks.hpp>
00016
00027 class Semaphore : public NonCloneable {
00028     public:
00030         Semaphore();
00031
00033         virtual ~Semaphore();
00034
00045         BOOLEAN Create(INT init_val = 0, INT max_val = -1);
00046
00057         BOOLEAN Obtain(const Ticks& timeout = Ticks::Infinite());
00058
00062         void Release();
00063
00064     private:
00065         UINT32 m_hdl;
00066 };
00067
00069 #endif  // Apoxi_Semaphore_hpp
00070
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/SimpleSemaphore.cpp File Reference

Kernel/Os/Win32/SimpleSemaphore.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SimpleSemaphore.hpp"
#include "Win32.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for SimpleSemaphore.cpp:

Generated on Tue Jan 24 21:26:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/SimpleSemaphore.hpp File Reference

Kernel/Os/Win32/SimpleSemaphore.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Types.hpp>

Include dependency graph for SimpleSemaphore.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SimpleSemaphore

Defines

#define | Apoxi_SimpleSemaphore_hpp

Define Documentation

#define Apoxi_SimpleSemaphore_hpp

Generated on Tue Jan 24 21:26:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/SimpleSemaphore.hpp Source File

Kernel/Os/Win32/SimpleSemaphore.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SimpleSemaphore_hpp)
00010 #define Apoxi_SimpleSemaphore_hpp
00013
00014 #include <Auxiliary/NonCloneable.hpp>
00015 #include <Kernel/Types.hpp>
00016
00027 class SimpleSemaphore : public NonCloneable {
00028     public:
00030         SimpleSemaphore();
00031
00033         virtual ~SimpleSemaphore();
00034
00045         BOOLEAN Create(INT init_val = 0, INT max_val = -1);
00046
00048         void Obtain();
00049
00053         void Release();
00054
00055     private:
00056         UINT32 m_hdl;
00057 };
00058
00060 #endif  // Apoxi_SimpleSemaphore_hpp
00061
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/SystemTimer.cpp File Reference

Kernel/Os/Win32/SystemTimer.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "SystemTimer.hpp"
#include "../OsClass.hpp"
#include "Win32.hpp"
#include <Auxiliary/Macros.hpp>

Include dependency graph for SystemTimer.cpp:

Generated on Tue Jan 24 21:26:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/SystemTimer.hpp File Reference

Kernel/Os/Win32/SystemTimer.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/Ticks.hpp>

Include dependency graph for SystemTimer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SystemTimer
struct | SystemTimer::CallBack

Defines

#define | Apoxi_SystemTimer_hpp

Define Documentation

#define Apoxi_SystemTimer_hpp

Generated on Tue Jan 24 21:39:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/SystemTimer.hpp Source File

Kernel/Os/Win32/SystemTimer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_SystemTimer_hpp)
00010 #define Apoxi_SystemTimer_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/Ticks.hpp>
00016
00019 class SystemTimer {
00020     public:
00021         typedef void (*CallBackFn)(void*);
00022
00024         SystemTimer();
00025
00031         SystemTimer(UINT32 timeout, CallBackFn OnTimer, void* arg = 0, BOOLEAN autotimer = FALSE);
00032
00034         ~SystemTimer();
00035
00041         void Init(UINT32 timeout, CallBackFn OnTimer, void* arg = 0, BOOLEAN autotimer = FALSE);
00042
00044         void SetTimeout(UINT32 timeout) { m_timeout = timeout; }
00046         UINT32 GetTimeout() const { return m_timeout; }
00047
00049         void Start();
00050
00053         UINT32 Stop();
00054
00056         void Restart();
00057
00059         BOOLEAN IsActive() const { return m_active; }
00060
00061     private:
00062         friend class SystemTimerInternals;
00063
00064         BOOLEAN m_active;
00065         BOOLEAN m_autotimer;
00066         UINT32 m_timeout;
00067         UINT m_timer_id;
00068         Ticks m_started;
00069
00070         struct CallBack {
00071             CallBackFn m_fn;
00072             void* m_arg;
00073             SystemTimer* m_system_timer;
00074         };
00075
00076         CallBack m_callback;
00077 };
00078
00080 #endif  // Apoxi_SystemTimer_hpp
00081
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Thread.cpp File Reference

Kernel/Os/Win32/Thread.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Thread.hpp"
#include <Auxiliary/Macros.hpp>
#include "Win32.hpp"

Include dependency graph for Thread.cpp:

Generated on Tue Jan 24 21:39:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Thread.hpp File Reference

Kernel/Os/Win32/Thread.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Kernel/Types.hpp>

Include dependency graph for Thread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Thread

Defines

#define | Apoxi_Thread_hpp
#define | APOXI_THREAD_PRIORITY_NORMAL 0
#define | c_max_thread_name_length 8

Typedefs

typedef UINT32 | ThreadId

Define Documentation

#define Apoxi_Thread_hpp

Generated on Tue Jan 24 21:48:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Thread.hpp Source File

Kernel/Os/Win32/Thread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Thread_hpp)
00010 #define Apoxi_Thread_hpp
00013
00014 #include <Auxiliary/NonCloneable.hpp>
00015 #include <Kernel/Types.hpp>
00016
00017 #if !defined(APOXI_THREAD_PRIORITY_NORMAL)
00018     #define APOXI_THREAD_PRIORITY_NORMAL 0
00019 #endif
00020
00021 #define c_max_thread_name_length 8
00022
00023 #undef Yield
00024
00025 /*----------------------------------------------------------------
00026                                 Thread
00027   ----------------------------------------------------------------*/
00028
00029 typedef UINT32 ThreadId;
00030
00032 class Thread {
00033     public:
00036         enum PriorityLevel {
00037             PriorityBackground5 = APOXI_THREAD_PRIORITY_NORMAL + 5,
00038             PriorityBackground4 = APOXI_THREAD_PRIORITY_NORMAL + 4,
00039             PriorityBackground3 = APOXI_THREAD_PRIORITY_NORMAL + 3,
00040             PriorityBackground2 = APOXI_THREAD_PRIORITY_NORMAL + 2,
00041             PriorityBackground1 = APOXI_THREAD_PRIORITY_NORMAL + 1,
00042             PriorityNormal      = APOXI_THREAD_PRIORITY_NORMAL,
00043             PriorityForeground1 = APOXI_THREAD_PRIORITY_NORMAL - 1,
00044             PriorityForeground2 = APOXI_THREAD_PRIORITY_NORMAL - 2,
00045             PriorityForeground3 = APOXI_THREAD_PRIORITY_NORMAL - 3,
00046             PriorityForeground4 = APOXI_THREAD_PRIORITY_NORMAL - 4,
00047             PriorityForeground5 = APOXI_THREAD_PRIORITY_NORMAL - 5,
00048         };
00049
00051         Thread();
00052
00054         virtual ~Thread();
00055
00057         void SetRequestedStackSize(UINT32 /*size*/) {}
00058
00060         UINT32 GetRequestedStackSize() { return 0; }
00061
00065         BOOLEAN Run(UINT32 stacksize = 4096, void *stack = 0);
00066
00068         virtual INT ThreadFn() = 0;
00069
00071         INT GetPriority() const { return m_priority; }
00072
00079         BOOLEAN SetPriority(INT priority);
00080
00082         BOOLEAN IncreasePriority();
00083
00085         BOOLEAN DecreasePriority();
00086
00088         void SetName(const CHAR* name);
00089
00091         const CHAR* GetName() const { return m_name; };
00092
00094         INT Suspend() const;
00095
00097         INT Resume() const;
00098
00101         INT Yield() const;
00102
00104         BOOLEAN Terminate(INT exit_code = 0);
00105
00107         static ThreadId GetThreadId();
00108
00110         static void SetThreadData(void *data);
00111
00113         static void* GetThreadData();
00114
00115     private:
00116         INT m_priority;
00117         UINT32 m_hdl;
00118         CHAR m_name[c_max_thread_name_length];
00119
00121         Thread(const Thread& thread);
00122
00124         Thread& operator=(const Thread& thread);
00125
00126 };
00127
00129 #endif  // Apoxi_Thread_hpp
00130
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Ticks.cpp File Reference

Kernel/Os/Win32/Ticks.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Ticks.hpp"
#include "../OsClass.hpp"

Include dependency graph for Ticks.cpp:

Generated on Tue Jan 24 21:48:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Ticks.hpp File Reference

Kernel/Os/Win32/Ticks.hpp File Reference

#include <Kernel/Types.hpp>
#include <Kernel/Os/TickValue.hpp>
#include <limits.h>

Include dependency graph for Ticks.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Ticks
Ticks is a convertion class between OS specific tick values and milliseconds. More...

Defines

#define | Apoxi_Ticks_hpp

Define Documentation

#define Apoxi_Ticks_hpp

Generated on Tue Jan 24 22:07:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Ticks.hpp Source File

Kernel/Os/Win32/Ticks.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH&  Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Ticks_hpp)
00010 #define Apoxi_Ticks_hpp
00013
00014 #include <Kernel/Types.hpp>
00015 #include <Kernel/Os/TickValue.hpp>
00016 #include <limits.h>
00017
00019 class Ticks {
00020     public:
00022         Ticks() : m_ticks(0) {}
00023
00025         Ticks(UINT32 ms) { SetMilliSeconds(ms); }
00026
00028         Ticks(const Ticks &ticks) : m_ticks(ticks.m_ticks) {}
00029
00031         explicit Ticks(const TickValue& tick_value) : m_ticks(tick_value.Get()) {}
00032
00034         void SetEmpty() { m_ticks = 0; }
00035
00037         BOOLEAN IsEmpty() const { return m_ticks == 0; }
00038
00040         UINT32 GetExpiredTime() const;
00041
00043         UINT32 GetExpiredTime(const Ticks &ticks) const { return ticks.m_ticks - m_ticks; }
00044
00046         Ticks& operator =(const Ticks &ticks) { m_ticks = ticks.m_ticks; return *this; }
00047
00049         Ticks operator +(const Ticks &ticks) const {
00050             Ticks sum;
00051             sum.m_ticks = m_ticks + ticks.m_ticks;
00052             return sum;
00053         }
00054
00056         Ticks& operator +=(const Ticks &ticks) { m_ticks += ticks.m_ticks; return *this; }
00057
00059         Ticks operator -(const Ticks &ticks) const {
00060             Ticks diff;
00061             diff.m_ticks = m_ticks - ticks.m_ticks;
00062             return diff;
00063         }
00064
00066         Ticks& operator -=(const Ticks &ticks) { m_ticks -= ticks.m_ticks; return *this; }
00067
00069         BOOLEAN operator ==(const Ticks &ticks) const { return m_ticks == ticks.m_ticks; }
00070
00072         BOOLEAN operator !=(const Ticks &ticks) const { return m_ticks != ticks.m_ticks; }
00073
00075         BOOLEAN operator >(const Ticks &ticks) const { return m_ticks > ticks.m_ticks; }
00076
00078         BOOLEAN operator <(const Ticks &ticks) const { return m_ticks < ticks.m_ticks; }
00079
00081         BOOLEAN operator >=(const Ticks &ticks) const { return m_ticks >= ticks.m_ticks; }
00082
00084         BOOLEAN operator <=(const Ticks &ticks) const { return m_ticks <= ticks.m_ticks; }
00085
00087         static Ticks Infinite() {
00088             Ticks ticks;
00089             ticks.m_ticks = ULONG_MAX;
00090             return ticks;
00091         }
00092
00093     private:
00094         UINT32 m_ticks;
00095
00096         void SetMilliSeconds(UINT32 time) { m_ticks = time; }
00097
00098         UINT32 GetMilliSeconds() const { return m_ticks; }
00099
00100         friend class Timer;
00101         friend class Os;
00102         friend class Semaphore;
00103         friend class SysSocket;
00104 };
00105
00107 #endif  // Apoxi_Ticks_hpp
00108
00109
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Trap.cpp File Reference

Kernel/Os/Win32/Trap.cpp File Reference

#include "Kernel/PreComp.hpp"
#include <Kernel/Os/Win32/Trap.hpp>
#include <Auxiliary/Provider.hpp>

Include dependency graph for Trap.cpp:

Generated on Tue Jan 24 22:07:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Trap.hpp File Reference

Kernel/Os/Win32/Trap.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for Trap.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Trap

Defines

#define | Apoxi_Trap_hpp

Define Documentation

#define Apoxi_Trap_hpp

Generated on Tue Jan 24 22:32:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Trap.hpp Source File

Kernel/Os/Win32/Trap.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Trap_hpp)
00010 #define Apoxi_Trap_hpp
00011
00014
00015 #include <Kernel/Types.hpp>
00016
00017 class Provider;
00018
00020 class Trap {
00021     public:
00023         static void Init();
00024
00036         static void Assertion(BOOLEAN arg);
00037
00120         static Provider& GetProvider();
00121
00122     private:
00123 };
00124
00126 #endif  // Apoxi_Trap_hpp
00127
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Win32.cpp File Reference

Kernel/Os/Win32/Win32.cpp File Reference

#include "Kernel/PreComp.hpp"
#include "Win32.hpp"
#include "../../Os/Os.hpp"
#include "../../HeapManager.hpp"
#include "../../Trace.hpp"
#include <malloc.h>

Include dependency graph for Win32.cpp:

Defines

#define | DBG_OUT_CONFIGURATOR_IS_IN_RANGE FALSE

Functions

BOOLEAN | CheckRange (UINT16 index)

Define Documentation

#define DBG_OUT_CONFIGURATOR_IS_IN_RANGE FALSE

Function Documentation

BOOLEAN CheckRange ( UINT16 index )

Generated on Tue Jan 24 23:17:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Win32.hpp File Reference

Kernel/Os/Win32/Win32.hpp File Reference

#include <Kernel/Os/Win32/WinInc.hpp>

Include dependency graph for Win32.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | SharedMemHdl
struct | Task

Defines

#define | Apoxi_Win32_hpp

Typedefs

typedef CRITICAL_SECTION | CriticalSection
typedef LPVOID | SharedMem
typedef DWORD | ThreadDataIndex
typedef WIN32_WCHAR * | ThreadName
typedef WIN32_INT | ThreadPriority

Define Documentation

#define Apoxi_Win32_hpp

Typedef Documentation

typedef CRITICAL_SECTION CriticalSection

typedef LPVOID SharedMem

typedef DWORD ThreadDataIndex

typedef WIN32_WCHAR* ThreadName

typedef WIN32_INT ThreadPriority

Generated on Tue Jan 24 23:17:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/Win32.hpp Source File

Kernel/Os/Win32/Win32.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Win32_hpp)
00010 #define Apoxi_Win32_hpp
00011
00012 #include <Kernel/Os/Win32/WinInc.hpp>
00013
00014 typedef CRITICAL_SECTION    CriticalSection;
00015 typedef WIN32_INT           ThreadPriority;
00016 typedef DWORD               ThreadDataIndex;
00017 typedef WIN32_WCHAR*        ThreadName;
00018 typedef LPVOID              SharedMem;
00019
00020 struct Task {
00021     HANDLE hdl;
00022 };
00023
00024 struct SharedMemHdl {
00025     HANDLE hdl;
00026 };
00027
00028 #endif  // Apoxi_Win32_hpp
00029
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/WinInc.hpp File Reference

Kernel/Os/Win32/WinInc.hpp File Reference

#include <windows.h>
#include <basetsd.h>
#include <limits.h>
#include <stdio.h>
#include <direct.h>
#include <sys/stat.h>
#include <time.h>
#include <fcntl.h>
#include <io.h>

Include dependency graph for WinInc.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | _WIN32_WINDOWS 0x0410
#define | _WIN32_WINNT 0x0400
#define | Action WIN32_Action
#define | Apoxi_Os_WinInc_hpp
#define | BOOLEAN WIN32_BOOLEAN
#define | CHAR WIN32_CHAR
#define | GLOBAL
#define | INT WIN32_INT
#define | INT16 WIN32_INT16
#define | INT32 WIN32_INT32
#define | INT8 WIN32_INT8
#define | LONG WIN32_LONG
#define | UCHAR WIN32_UCHAR
#define | UINT WIN32_UINT
#define | UINT16 WIN32_UINT16
#define | UINT32 WIN32_UINT32
#define | UINT8 WIN32_UINT8
#define | ULONG WIN32_ULONG
#define | WCHAR WIN32_WCHAR
#define | WIN32_DeleteFile DeleteFileA
#define | WIN32_MessageBox MessageBoxA
#define | WIN32_MoveFile MoveFileA

Define Documentation

#define _WIN32_WINDOWS 0x0410

#define _WIN32_WINNT 0x0400

#define Action WIN32_Action

#define Apoxi_Os_WinInc_hpp

#define BOOLEAN WIN32_BOOLEAN

#define CHAR WIN32_CHAR

#define GLOBAL

#define INT WIN32_INT

#define INT16 WIN32_INT16

#define INT32 WIN32_INT32

#define INT8 WIN32_INT8

#define LONG WIN32_LONG

#define UCHAR WIN32_UCHAR

#define UINT WIN32_UINT

#define UINT16 WIN32_UINT16

#define UINT32 WIN32_UINT32

#define UINT8 WIN32_UINT8

#define ULONG WIN32_ULONG

#define WCHAR WIN32_WCHAR

#define WIN32_DeleteFile DeleteFileA

#define WIN32_MessageBox MessageBoxA

#define WIN32_MoveFile MoveFileA

Generated on Tue Jan 24 23:17:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel/Os/Win32/WinInc.hpp Source File

Kernel/Os/Win32/WinInc.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_Os_WinInc_hpp)
00010 #define Apoxi_Os_WinInc_hpp
00011
00012 #if !defined(APOXI_RTOS_WIN32)
00013     #error Os/WinInc.hpp can only be included with APOXI_RTOS_WIN32 configuration
00014 #endif
00015
00016 // Hide WIN32 types
00017
00018 #define BOOLEAN WIN32_BOOLEAN
00019 #define UCHAR   WIN32_UCHAR
00020 #define CHAR    WIN32_CHAR
00021 #define WCHAR   WIN32_WCHAR
00022
00023 #define INT8    WIN32_INT8
00024 #define UINT8   WIN32_UINT8
00025
00026 #define INT16   WIN32_INT16
00027 #define UINT16  WIN32_UINT16
00028
00029 #define INT32   WIN32_INT32
00030 #define UINT32  WIN32_UINT32
00031
00032 #define INT     WIN32_INT
00033 #define UINT    WIN32_UINT
00034
00035 #define LONG    WIN32_LONG
00036 #define ULONG   WIN32_ULONG
00037
00038 #define Action  WIN32_Action
00039
00040 // our minimal system requirements: win nt 4.0 or win98
00041 // this ensures support of winsock2.h and IsDebuggerPresent()
00042 #define _WIN32_WINNT 0x0400
00043 #define _WIN32_WINDOWS 0x0410
00044
00045 #if defined(_CPPUNWIND)
00046     #error Exception handling is enabled! APOXI requires exception handling to be disabled!
00047 #endif
00048
00049 #if (_MSC_VER >= 1300)
00050     #include <winsock2.h>
00051 #endif
00052
00053 #include <windows.h>
00054 #include <basetsd.h>
00055 #include <limits.h>
00056 #include <stdio.h>
00057 #include <direct.h>
00058 #include <sys/stat.h>
00059 #include <time.h>
00060 #include <fcntl.h>
00061 #include <io.h>
00062
00063 #undef SERVICE_DISABLED     // disable WinNT define in winnt.h
00064 #undef TRANSPARENT          // disable WinNT define in wingdi.h (coming up with gfs v18.11)
00065 #undef O_RDONLY             // disable define in fcntl.h
00066 #undef O_WRONLY             // disable define in fcntl.h
00067 #undef O_RDWR               // disable define in fcntl.h
00068 #undef O_CREAT              // disable define in fcntl.h
00069 #undef O_TRUNC              // disable define in fcntl.h
00070
00071 #undef GLOBAL
00072 #define GLOBAL
00073
00074 #undef BOOLEAN
00075 #undef CHAR
00076 #undef UCHAR
00077 #undef WCHAR
00078 #undef INT8
00079 #undef UINT8
00080 #undef INT16
00081 #undef UINT16
00082 #undef INT32
00083 #undef UINT32
00084 #undef INT
00085 #undef UINT
00086 #undef LONG
00087 #undef ULONG
00088
00089 #undef TRUE
00090 #undef FALSE
00091 #undef Action
00092
00093 #undef GetDateFormat
00094 #undef GetTimeFormat
00095 #undef SendMessage
00096 #undef GetObject
00097
00098 #undef MessageBox
00099 #ifdef UNICODE
00100     #define WIN32_MessageBox MessageBoxW
00101 #else
00102     #define WIN32_MessageBox MessageBoxA
00103 #endif
00104
00105 #undef MoveFile
00106 #ifdef UNICODE
00107     #define WIN32_MoveFile MoveFileW
00108 #else
00109     #define WIN32_MoveFile MoveFileA
00110 #endif
00111
00112 #undef DeleteFile
00113 #ifdef UNICODE
00114     #define WIN32_DeleteFile DeleteFileW
00115 #else
00116     #define WIN32_DeleteFile DeleteFileA
00117 #endif
00118
00119 #endif  // Apoxi_Os_WinInc_hpp
00120
Generated on Tue Jan 24 14:50:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/FsmEngine.cpp File Reference

Obex/FsmEngine.cpp File Reference

#include "PreComp.hpp"
#include "ObexConfig.hpp"
#include "FsmEngine.hpp"

Include dependency graph for FsmEngine.cpp:

Generated on Tue Jan 24 23:19:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/FsmEngine.hpp File Reference

Obex/FsmEngine.hpp File Reference

#include <Auxiliary/ObjectObtainer.hpp>
#include <Auxiliary/NonCloneable.hpp>

Include dependency graph for FsmEngine.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_FsmEngine_hpp

Define Documentation

#define Apoxi_FsmEngine_hpp

Generated on Tue Jan 24 23:19:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/FsmEngine.hpp Source File

Obex/FsmEngine.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FsmEngine_hpp)
00011 #define Apoxi_FsmEngine_hpp
00012
00013 #include <Auxiliary/ObjectObtainer.hpp>
00014 #include <Auxiliary/NonCloneable.hpp>
00015
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018
00019 // Internal utility macros
00020 #define FSM_TRANS_NEXT(classname, actionname, statename) \
00021     { \
00022         (FsmEngine::ActionMemFunPtr) &classname::actionname, \
00023         &classname::s_fsm_state_info_##statename \
00024     }
00025
00026 #define FSM_TRANS_EXIT(classname, actionname) \
00027     { \
00028         (FsmEngine::ActionMemFunPtr) &classname::actionname, \
00029         0 \
00030     }
00031
00032 #define FSM_TRANS_COUNT(classname, statename) \
00033     ( sizeof(classname::s_fsm_trans_list_##statename) / sizeof(FsmEngine::EventInfo) )
00034
00035
00036 #define FSM_INTERNAL_EVENTS \
00037     NoEvent = 0
00038
00039 #define FSM_STATE_FROM_NAME(statename) s_fsm_state_info_##statename
00040
00041 #define FSM_DECLARE_STATE(statename) \
00042     static  const FsmEngine::EventInfo  s_fsm_trans_list_##statename[]; \
00043     static  const FsmEngine::StateInfo  s_fsm_state_info_##statename
00044
00045
00046 #define FSM_DEFINE_STATE(classname, statename) \
00047     const FsmEngine::EventInfo  classname::s_fsm_trans_list_##statename[] =
00048
00049
00050 #define FSM_EVENT_NEXT(classname, eventname, statename, actionname) \
00051     { \
00052         FSM_TRANS_NEXT(classname, actionname, statename), \
00053         eventname \
00054     }
00055
00056
00057 #define FSM_EVENT_EXIT(classname, eventname, actionname) \
00058     { \
00059         FSM_TRANS_EXIT(classname, actionname), \
00060         eventname \
00061     }
00062
00063
00064 #define FSM_STATE_ELSE(classname, statename, actionname) \
00065     ;\
00066     const FsmEngine::StateInfo  classname::s_fsm_state_info_##statename = \
00067     { \
00068         #classname"::"#statename, \
00069         classname::s_fsm_trans_list_##statename, \
00070         FSM_TRANS_COUNT(classname, statename), \
00071         FSM_TRANS_NEXT(classname, actionname, statename) \
00072     }
00073
00074
00075 #define FSM_STATE_EXIT(classname, statename, actionname) \
00076     ;\
00077     const FsmEngine::StateInfo  classname::s_state_info_##statename = \
00078     { \
00079         #classname ".." #statename, \
00080         classname::s_fsm_trans_list_##statename, \
00081         FSM_TRANS_COUNT(classname, statename), \
00082         FSM_TRANS_EXIT(classname, actionname) \
00083     }
00084
00085
00086 class FsmEngine {
00087
00088     public:
00089         typedef INT  EventType;
00090
00091         enum {
00092             FSM_INTERNAL_EVENTS
00093         };
00094
00095         class Actor : public NonCloneable {
00096
00097             public:
00098                 virtual const CHAR *    GetTraceInfo() const;
00099
00100             protected:
00101                 EventType   NoAction(FsmEngine &, EventType, ObjectObtainer &) const
00102                 {
00103                     return NoEvent;
00104                 }
00105         };
00106
00107         typedef EventType   (Actor::*ActionMemFunPtr)
00108                             (FsmEngine &, EventType, ObjectObtainer &);
00109         struct  StateInfo;
00110
00111         struct  TransInfo {
00112             ActionMemFunPtr     action;
00113             const StateInfo *   follow_state;
00114         };
00115
00116         struct  EventInfo {
00117             TransInfo           trans;
00118             EventType           event;
00119         };
00120
00121         struct  StateInfo {
00122             const CHAR *        state_name;
00123             const EventInfo *   trans_tab;
00124             UINT8               trans_cnt;
00125             TransInfo           trans_def;
00126         };
00127
00128         class   StateReferrer {
00129
00130             public:
00131                 inline  StateReferrer();
00132
00133                 inline  StateReferrer(const StateInfo &     state_info,
00134                                       Actor *               actor_ptr);
00135
00136                 inline  void                SetState(const StateInfo &  state_info);
00137                 inline  const StateInfo &   GetState() const;
00138
00139                 inline  Actor &             GetActor() const;
00140
00141             private:
00142                 Actor *                     m_actor_ptr;
00143                 const StateInfo *           m_state_ptr;
00144         };
00145
00147         FsmEngine();
00148
00149         inline  UINT            GetStackDepth() const;
00150
00151         void                    Init(StateReferrer  stack[],
00152                                      UINT           max_depth);
00153
00154         void                    Push(const StateReferrer &  referrer);
00155         void                    Pop();
00156         void                    Super();
00157
00158         BOOLEAN                 IsInState(const StateInfo &     test_state,
00159                                           UINT                  scope = 0) const;
00160
00161         void                    ExternalEvent(const ObjectObtainer &    event_holder);
00162
00163         inline  void            ExternalEvent(EventType             event_type,
00164                                               ObtainableObject *    event_data_ptr);
00165
00166         void                    StateAsString(String &  out_str) const;
00167
00168     private:
00169         UINT                m_max_depth;
00170         UINT                m_fsm_depth;
00171         UINT                m_fsm_scope;
00172         StateReferrer *     m_fsm_stack;
00173
00174         void                TraceState(const CHAR *  name_str) const;
00175         inline  BOOLEAN     IsValidScope(UINT   scope) const;
00176 };
00177
00178
00179 FsmEngine::StateReferrer::StateReferrer() :
00180     m_actor_ptr(0),
00181     m_state_ptr(0)
00182 {
00183 }
00184
00185
00186 FsmEngine::StateReferrer::StateReferrer(const StateInfo &   state_info,
00187                                         Actor *             actor_ptr) :
00188     m_actor_ptr(actor_ptr),
00189     m_state_ptr(&state_info)
00190 {
00191 }
00192
00193
00194 void    FsmEngine::StateReferrer::SetState(const StateInfo &  state_info)
00195 {
00196     m_state_ptr = &state_info;
00197 }
00198
00199
00200 const FsmEngine::StateInfo &    FsmEngine::StateReferrer::GetState()
00201 const
00202 {
00203     ASSERT_DEBUG(m_state_ptr != 0);
00204
00205     return  *m_state_ptr;
00206 }
00207
00208
00209 FsmEngine::Actor &  FsmEngine::StateReferrer::GetActor()
00210 const
00211 {
00212     ASSERT_DEBUG(m_actor_ptr != 0);
00213
00214     return  *m_actor_ptr;
00215 }
00216
00217 void    FsmEngine::ExternalEvent(EventType              event_type,
00218                                  ObtainableObject *     event_data_ptr)
00219 {
00220     ExternalEvent( ObjectObtainer(event_data_ptr, FALSE, event_type) );
00221 }
00222
00223
00224 BOOLEAN     FsmEngine::IsValidScope(UINT    level)
00225 const
00226 {
00227     return  ( (level > 0) && (level <= GetStackDepth()) );
00228 }
00229
00230
00231 UINT  FsmEngine::GetStackDepth()
00232 const
00233 {
00234     return m_fsm_depth;
00235 }
00236
00237 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00238 #endif  // Apoxi_FsmEngine_hpp
00239
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAbstractPort.cpp File Reference

Obex/ObexAbstractPort.cpp File Reference

#include "PreComp.hpp"
#include "Devices/AbstractTransport.hpp"
#include "ObexTransport.hpp"
#include "ObexProtocol.hpp"
#include "ObexAbstractPort.hpp"

Include dependency graph for ObexAbstractPort.cpp:

Functions

FSM_DEFINE_STATE (ObexAbstractPort, s2_closing)
FSM_DEFINE_STATE (ObexAbstractPort, s2_opening)
FSM_DEFINE_STATE (ObexAbstractPort, s2_resolving)
FSM_STATE_ELSE (ObexAbstractPort, s2_closing, NoAction)
FSM_STATE_ELSE (ObexAbstractPort, s2_opening, NoAction)
FSM_STATE_ELSE (ObexAbstractPort, s2_resolving, NoAction)

Function Documentation

FSM_DEFINE_STATE | ( | ObexAbstractPort | ,
 |  | s2_closing |
 | ) |

FSM_DEFINE_STATE | ( | ObexAbstractPort | ,
 |  | s2_opening |
 | ) |

FSM_DEFINE_STATE | ( | ObexAbstractPort | ,
 |  | s2_resolving |
 | ) |

FSM_STATE_ELSE | ( | ObexAbstractPort | ,
 |  | s2_closing | ,
 |  | NoAction |
 | ) |

FSM_STATE_ELSE | ( | ObexAbstractPort | ,
 |  | s2_opening | ,
 |  | NoAction |
 | ) |

FSM_STATE_ELSE | ( | ObexAbstractPort | ,
 |  | s2_resolving | ,
 |  | NoAction |
 | ) |

Generated on Tue Jan 24 23:19:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAbstractPort.hpp File Reference

Obex/ObexAbstractPort.hpp File Reference

#include <Obex/ObexAddrPtr.hpp>
#include <Obex/ObexAddress.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexOperationId.hpp>
#include <Obex/ObexMessages.hpp>
#include <Obex/FsmEngine.hpp>

Include dependency graph for ObexAbstractPort.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexAbstractPort
Internal base class for OBEX transport interfaces. More...
struct | ObexAbstractPort::AddressEvent
Event data type for EvResolveComplete. More...
struct | ObexAbstractPort::CompleteEvent
Event data type for EvOpComplete. More...

Defines

#define | Apoxi_ObexAbstractPort_hpp

Define Documentation

#define Apoxi_ObexAbstractPort_hpp

Generated on Tue Jan 24 23:19:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAbstractPort.hpp Source File

Obex/ObexAbstractPort.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexAbstractPort_hpp)
00011 #define Apoxi_ObexAbstractPort_hpp
00014
00015 #include <Obex/ObexAddrPtr.hpp>
00016 #include <Obex/ObexAddress.hpp>
00017 #include <Obex/ObexChannel.hpp>
00018 #include <Obex/ObexOperationId.hpp>
00019 #include <Obex/ObexMessages.hpp>
00020 #include <Obex/FsmEngine.hpp>
00021
00022 //  Forward declarations of classes.
00023 class ObexAbstractTransport;
00024 class ObexProtocol;
00025
00026
00041 class ObexAbstractPort : public FsmEngine::Actor {
00042     friend class FsmEngine;
00043     public:
00045         virtual ~ObexAbstractPort();
00046
00048         inline  const ObexChannel &     GetChannel() const;
00049
00051         inline  BOOLEAN                 IsBoundTo(const ObexChannel &  ch) const;
00052
00054         inline  ObexProtocol &          GetProtocol();
00055
00060         void                            Open();
00061
00066         void                            Close();
00067
00072         void                            CheckTransportAvailable();
00073
00080         BOOLEAN                         AcceptsMessage(const ObexMsg &      msg);
00081
00088         BOOLEAN                         AcceptsMessage(const ObexAddrMsg &  msg);
00089
00091         enum EventType {
00092             FSM_INTERNAL_EVENTS,
00093
00094             EvOpen,
00095             EvClose,
00096             EvOpComplete,
00097             EvResolveComplete,
00098             EvAvsChanged,
00099
00100             EvAvsReady,
00101             EvAvsIsBad,
00102
00103             EvResolveSuccess,
00104             EvResolveFailure,
00105
00106             EvOpenSuccess,
00107             EvOpenFailure,
00108
00109             EvReleaseComplete
00110         };
00111
00112     protected:
00114         struct  AddressEvent : public ObtainableObject {
00115
00116             AddressEvent(const ObexAddrMsg &    addr_msg) :
00117
00118                 m_addr_msg(addr_msg)
00119             {
00120             }
00121             const ObexAddrMsg &     m_addr_msg;
00122         };
00124         struct  CompleteEvent : public ObtainableObject {
00125
00126             CompleteEvent(const ObexMsg &   obex_msg) :
00127
00128                 c_result(obex_msg.GetResult())
00129             {
00130             }
00131             const ObexResult    c_result;
00132         };
00133
00134         EventType   EvalAvsAction(FsmEngine &, EventType, ObjectObtainer &);
00135
00136         EventType   StartResolveAction(FsmEngine &, EventType, ObjectObtainer &);
00137         EventType   AbortResolveAction(FsmEngine &, EventType, ObjectObtainer &);
00138         EventType   ResolveCompleteAction(FsmEngine &, EventType, ObjectObtainer &);
00139
00140         EventType   OpenAction(FsmEngine &, EventType, ObjectObtainer &);
00141         EventType   OpenCompleteAction(FsmEngine &, EventType, ObjectObtainer &);
00142
00143         EventType   CloseAction(FsmEngine &, EventType, ObjectObtainer &);
00144         EventType   CloseCompleteAction(FsmEngine &, EventType, ObjectObtainer &);
00145
00146         EventType   ReleaseAction(FsmEngine &, EventType, ObjectObtainer &);
00147         EventType   DestroyAction(FsmEngine &, EventType, ObjectObtainer &);
00148
00149         EventType   DefaultAction(FsmEngine &, EventType, ObjectObtainer &);
00150
00152         ObexAbstractPort(ObexAbstractTransport &        transport,
00153                          ObexProtocol &                 protocol,
00154                          const FsmEngine::StateInfo &   initial_state);
00155
00156         inline  ObexAbstractTransport &     GetTransport();
00157         inline  const ObexOperationId &     GetTransportOperId() const;
00158         inline  const ObexAddrPtr &         GetAddress();
00159
00160         inline  void        SetAddress(const ObexAddrPtr &  addr_ptr);
00161         inline  void        ReleaseAddress();
00162
00163         inline  BOOLEAN     IsInState(const FsmEngine::StateInfo &  state) const;
00164
00165         inline  void        ExternalEvent(EventType             ev_type,
00166                                           ObtainableObject *    ev_data_ptr);
00167
00169         ObexOperationId &       StartOperation();
00170
00171         BOOLEAN                 IsAvsReady() const;
00172
00173         virtual const CHAR *    GetTraceInfo() const;
00174
00176         virtual void            StartAddrResolution() = 0;
00177
00179         virtual void            AbortAddrResolution() = 0;
00180
00184         virtual BOOLEAN     AcquireChannel(ObexChannel &        channel,
00185                                            const ObexAddrPtr &  addr_ptr,
00186                                            ObexResult           result) = 0;
00187
00189         virtual void        ReleaseChannel();
00190
00192         virtual void        OpenChannel(const ObexAddrPtr &     addr_ptr) = 0;
00193
00195         virtual void        CloseChannel(ObexResult cause) = 0;
00196
00198         virtual void        OnChannelClosed() = 0;
00199
00201         virtual void        OnChannelOpened(ObexResult  result) = 0;
00202
00203     private:
00204         // Substate: Port is waiting for an address resolved by the transport
00205         FSM_DECLARE_STATE(s2_resolving);
00206
00207         // Substate: Port is waiting for 'OpenChannel()' to complete.
00208         FSM_DECLARE_STATE(s2_opening);
00209
00210         // Substate: Port is waiting for 'CloseChannel()' to complete.
00211         FSM_DECLARE_STATE(s2_closing);
00212
00213         ObexOperationId                 m_oper_id;
00214         ObexChannel                     m_channel;
00215         ObexAbstractTransport &         m_transport;
00216         ObexProtocol &                  m_protocol;
00217         ObexAddrPtr                     m_addr_ptr;
00218         FsmEngine::StateReferrer        m_fsm_stack[2];
00219         FsmEngine                       m_fsm;
00220
00222         ObexAbstractPort(const ObexAbstractPort &);
00224         ObexAbstractPort &  operator=(const ObexAbstractPort &);
00225 };
00226
00227 /*  ----------------------------------------------------------------------
00228     GetChannel
00229     ---------------------------------------------------------------------- */
00230 const ObexChannel &     ObexAbstractPort::GetChannel()
00231 const
00232 {
00233     return  m_channel;
00234 }// GetChannel
00235
00236 /*  ----------------------------------------------------------------------
00237     IsAssociated
00238     ---------------------------------------------------------------------- */
00239 BOOLEAN     ObexAbstractPort::IsBoundTo(const ObexChannel &     channel)
00240 const
00241 {
00242     return ( m_channel == channel );
00243 }// IsAssociated
00244
00245 /*  ----------------------------------------------------------------------
00246     GetProtocol
00247     ---------------------------------------------------------------------- */
00248 ObexProtocol &  ObexAbstractPort::GetProtocol()
00249
00250 {
00251     return  m_protocol;
00252 }// GetProtocol
00253
00254 /*  ----------------------------------------------------------------------
00255     GetTransport
00256     ---------------------------------------------------------------------- */
00257 ObexAbstractTransport &     ObexAbstractPort::GetTransport()
00258 {
00259     return  m_transport;
00260 }// GetTransport
00261
00262 /*  ----------------------------------------------------------------------
00263     GetTransportOperId
00264     ---------------------------------------------------------------------- */
00265 const ObexOperationId &     ObexAbstractPort::GetTransportOperId()
00266 const
00267 {
00268     return  m_oper_id;
00269 }// GetTransportOperId
00270
00271 /*  ----------------------------------------------------------------------
00272     IsInState
00273     ---------------------------------------------------------------------- */
00274 BOOLEAN     ObexAbstractPort::IsInState(const FsmEngine::StateInfo &     state)
00275 const
00276 {
00277     return  m_fsm.IsInState(state);
00278 }// IsInState
00279
00280 /*  ----------------------------------------------------------------------
00281     ExternalEvent
00282     ---------------------------------------------------------------------- */
00283 void    ObexAbstractPort::ExternalEvent(EventType           event_type,
00284                                         ObtainableObject *  event_data_ptr)
00285 {
00286     m_fsm.ExternalEvent( event_type, event_data_ptr );
00287 }// ExternalEvent
00288
00289 /*  ----------------------------------------------------------------------
00290     GetAddress
00291     ---------------------------------------------------------------------- */
00292 const ObexAddrPtr &     ObexAbstractPort::GetAddress()
00293 {
00294     return  m_addr_ptr;
00295 }// GetAddress
00296
00297 /*  ----------------------------------------------------------------------
00298     SetAddress
00299     ---------------------------------------------------------------------- */
00300 void    ObexAbstractPort::SetAddress(const ObexAddrPtr &    addr_ptr)
00301 {
00302     m_addr_ptr = addr_ptr;
00303 }// SetAddress
00304
00305 /*  ----------------------------------------------------------------------
00306     ReleaseAddress
00307     ---------------------------------------------------------------------- */
00308 void    ObexAbstractPort::ReleaseAddress()
00309 {
00310     m_addr_ptr.Clear();
00311 }// ReleaseAddress
00312
00314 #endif  // Apoxi_ObexServerPort_hpp
00315
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAddress.cpp File Reference

Obex/ObexAddress.cpp File Reference

#include "PreComp.hpp"
#include "ObexMngr.hpp"
#include "ObexTransport.hpp"
#include "ObexAddress.hpp"

Include dependency graph for ObexAddress.cpp:

Generated on Tue Jan 24 23:19:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAddress.hpp File Reference

Obex/ObexAddress.hpp File Reference

#include <Auxiliary/ObjectReferrer.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexResult.hpp>

Include dependency graph for ObexAddress.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexAddress
Base class for client- and server address information. More...
class | ObexClientAddr
Base class for client address information classes. More...
class | ObexServerAddr
Base class for server address information classes. More...

Defines

#define | Apoxi_ObexAddress_hpp

Define Documentation

#define Apoxi_ObexAddress_hpp

Generated on Tue Jan 24 23:19:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAddress.hpp Source File

Obex/ObexAddress.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexAddress_hpp)
00010 #define Apoxi_ObexAddress_hpp
00013
00014 #include <Auxiliary/ObjectReferrer.hpp>
00015
00016 #include <Obex/ObexTypes.hpp>
00017 #include <Obex/ObexResult.hpp>
00018
00019 // Forward declarations of classes.
00020 class ObexAbstractTransport;
00021
00022
00027 class ObexAddress : public ReferableObject {
00028
00029     public:
00030         typedef ReferableObject Base;
00031
00033         virtual ObexAddrTypeId      GetTypeId() const = 0;
00034
00039         virtual ObexResult          ToString(String &  obex_url) const;
00040
00042         inline  ObexTransportId     GetTransportId() const;
00043
00045         ObexAbstractTransport &     GetTransport() const;
00046
00047     protected:
00049         ObexAddress(ObexTransportId     transport_id);
00050
00051     private:
00052         const ObexTransportId   c_transport_id;
00053 };
00054
00055
00061 class ObexClientAddr : public ObexAddress {
00062
00063     public:
00064         typedef ObexAddress Base;
00065
00067         virtual ObexAddrTypeId  GetTypeId() const;
00068
00069     protected:
00071         ObexClientAddr(ObexTransportId  transport_id);
00072 };
00073
00074
00080 class ObexServerAddr : public ObexAddress {
00081
00082     public:
00083         typedef ObexAddress Base;
00084
00086         virtual ObexAddrTypeId  GetTypeId() const;
00087
00088         /*  @brief  Tells whether address was auto - registered by transport.
00089
00090             The default implementation returns always \c 'TRUE'.
00091
00092             @return \c 'TRUE' when the transport that created this address has
00093                     registered it with a service discovery database or if no
00094                     such facility exists, \c 'FALSE' if application software
00095                     needs to perform service registration. */
00096         virtual BOOLEAN         IsAutoRegistered() const;
00097
00098     protected:
00100         ObexServerAddr(ObexTransportId  transport_id);
00101 };
00102
00103 /*  ----------------------------------------------------------------------
00104     GetTransportId
00105     ---------------------------------------------------------------------- */
00106 ObexTransportId     ObexAddress::GetTransportId()
00107 const
00108 {
00109     return  c_transport_id;
00110 }
00111
00113 #endif  // Apoxi_ObexAddress_hpp
00114
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAddrPtr.hpp File Reference

Obex/ObexAddrPtr.hpp File Reference

#include <Auxiliary/SharedPtr.hpp>

Include dependency graph for ObexAddrPtr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_ObexAddrPtr_hpp

Typedefs

typedef SharedPtr< ObexAddress > | ObexAddrPtr
Smartpointer used to manage ObexAddress instances.

Define Documentation

#define Apoxi_ObexAddrPtr_hpp

Generated on Tue Jan 24 23:19:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAddrPtr.hpp Source File

Obex/ObexAddrPtr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexAddPtr_hpp)
00010 #define Apoxi_ObexAddrPtr_hpp
00013
00014 #include <Auxiliary/SharedPtr.hpp>
00015
00016 // Forward declaration.
00017 class ObexAddress;
00018
00025 typedef SharedPtr< ObexAddress >  ObexAddrPtr;
00026
00028 #endif  // Apoxi_ObexAddrPtr_hpp
00029
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAppMsg.cpp File Reference

Obex/ObexAppMsg.cpp File Reference

#include "PreComp.hpp"
#include "ObexAppMsg.hpp"

Include dependency graph for ObexAppMsg.cpp:

Generated on Tue Jan 24 23:19:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAppMsg.hpp File Reference

Obex/ObexAppMsg.hpp File Reference

#include <Kernel/Message.hpp>
#include <Obex/ObexTypes.hpp>

Include dependency graph for ObexAppMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexAppMsg

Defines

#define | Obex_ObexAppMsg_hpp

Define Documentation

#define Obex_ObexAppMsg_hpp

Generated on Tue Jan 24 23:19:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexAppMsg.hpp Source File

Obex/ObexAppMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Obex\MsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Obex_ObexAppMsg_hpp)
00014 #define Obex_ObexAppMsg_hpp
00015 #include <Kernel/Message.hpp>
00016 #include <Obex/ObexTypes.hpp>
00017 /* ----------------------------------------------------------------------
00018     Classes
00019     ---------------------------------------------------------------------- */
00020 /*  ======================================================================
00021     Class ObexAppMsg
00022     ====================================================================== */
00024 class ObexAppMsg : public ContextMsg {
00025     public:
00026         ObexAppMsg(ExecutionContext* context, const ObexAppMsgType& msg_type);
00027         virtual ~ObexAppMsg();
00028
00029         virtual const MsgMetaData& GetMetaData() const;
00030         const ObexAppMsgType& GetMsgType() const { return m_msg_type; }
00031         virtual Message* Clone() const;
00032
00033         enum  {
00034             ID = 11005
00035             };
00036
00037     private:
00038         static const MsgMetaData m_meta_data;
00039         ObexAppMsgType m_msg_type;
00040
00041     };
00042 #endif // Obex_ObexAppMsg_hpp
00043
00044
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexBuffer.cpp File Reference

Obex/ObexBuffer.cpp File Reference

#include "PreComp.hpp"
#include "ObexBuffer.hpp"

Include dependency graph for ObexBuffer.cpp:

Generated on Tue Jan 24 23:19:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexBuffer.hpp File Reference

Obex/ObexBuffer.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>

Include dependency graph for ObexBuffer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexBuffer
Provides exclusive access to a buffer holding BODY data. More...
class | ObexBuffer::Factory
Factory class for ObexBuffers with user-defined memory manangement strategy. More...
class | ObexBuffer::Reader
Accessor class to read data from an ObexBuffer. More...
class | ObexBuffer::Writer
Accessor class to write data into an ObexBuffer. More...

Defines

#define | Apoxi_ObexBuffer_hpp

Define Documentation

#define Apoxi_ObexBuffer_hpp

Generated on Tue Jan 24 23:19:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexBuffer.hpp Source File

Obex/ObexBuffer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexBuffer_hpp)
00011 #define Apoxi_ObexBuffer_hpp
00014
00015 #include <Auxiliary/NonCloneable.hpp>
00016
00072 class ObexBuffer {
00073
00074     public:
00075         class   Factory;
00076         class   Reader;
00077         class   Writer;
00078
00079         friend  class Factory;
00080         friend  class Reader;
00081         friend  class Writer;
00082
00083         typedef  UINT8 *        DataPtr;
00084         typedef const  UINT8 *  ConstDataPtr;
00085         typedef UINT32              Size;
00086         typedef UINT32              Offset;
00087
00095         class Factory : public NonCloneable {
00096
00097             public:
00107                 void            Destroy(ObexBuffer &  buffer);
00108
00109             protected:
00111                 Factory();
00112
00113                 void            Construct(ObexBuffer &  init_obj,
00114                                           DataPtr       data_ptr,
00115                                           Size          capacity,
00116                                           Size          size = 0);
00117
00128                 virtual void    OnRelease(DataPtr   user_ptr,
00129                                           Size      capacity) = 0;
00130         };
00131
00133         class Reader {
00134
00135             public:
00137                 Reader(ObexBuffer &  buffer, Size  offset = 0);
00138
00140                 inline  DataPtr GetPtr() const;
00141
00143                 inline  Size            GetOffset() const;
00144
00146                 Size                    GetNoBytesReadable() const;
00147
00149                 void                    Commit(Size  no_bytes);
00150
00167                 Size                    CopyTo(DataPtr  dest_ptr,
00168                                                Size     dest_size);
00169             private:
00171                 Reader(const Reader &);
00172
00174                 Reader &                operator=(const Reader &);
00175
00176                 ObexBuffer &    m_buffer;
00177                 Size            m_offset;
00178         };
00179
00181         class Writer {
00182
00183             public:
00185                 Writer(ObexBuffer &  buffer);
00186
00188                 inline  DataPtr         GetPtr() const;
00189
00191                 inline  Size            GetOffset() const;
00192
00194                 Size                    GetNoBytesWritable() const;
00195
00197                 void                    Commit(Size  no_bytes);
00198
00215                 Size                    CopyFrom(ConstDataPtr   from_ptr,
00216                                                  Size           from_size);
00217             private:
00219                 Writer(const Writer &);
00220
00222                 Writer &                operator=(const Writer &);
00223
00224                 ObexBuffer &    m_buffer;
00225         };
00226
00231         ObexBuffer();
00232
00241         ObexBuffer(Size  capacity);
00242
00249         ObexBuffer(ObexBuffer &  take_from);
00250
00256         ~ObexBuffer();
00257
00264         ObexBuffer &            operator=(ObexBuffer &  take_from);
00265
00267         inline  BOOLEAN         IsValid() const;
00268
00270         inline  Size            GetSize() const;
00271
00273         inline  Size            GetCapacity() const;
00274
00276         inline  void            Empty();
00277
00282         inline  void            Release();
00283
00284     private:
00285         DataPtr     m_data_ptr;
00286         Size        m_capacity;
00287         Size        m_data_size;
00288         BOOLEAN     m_auto_free;
00289
00293         inline  DataPtr         GetPtrAt(Size   where) const;
00294
00296         void                    SetSize(Size  data_size);
00297
00310         ObexBuffer(DataPtr  user_ptr, Size  capacity, Size  size);
00311
00313         void                    Reset();
00314
00318         void                    Dispose();
00319 };
00320
00321 /*  ----------------------------------------------------------------------
00322     Reader::GetPtr
00323
00324     Allows computation of a pointer which points exactly one byte behind
00325     the buffer. GetNoBytesReadable() will return 0 in this case, so a
00326     memcpy() will not read bad data in this case.
00327     ---------------------------------------------------------------------- */
00328 ObexBuffer::DataPtr ObexBuffer::Reader::GetPtr()
00329 const
00330 {
00331     ASSERT_DEBUG( m_offset <= m_buffer.GetSize() );
00332
00333     return  m_buffer.GetPtrAt(m_offset);
00334 }// GetPtr
00335
00336 /*  ----------------------------------------------------------------------
00337     Reader::GetOffset
00338     ---------------------------------------------------------------------- */
00339 ObexBuffer::Size            ObexBuffer::Reader::GetOffset()
00340 const
00341 {
00342     return  m_offset;
00343 }// GetOffset
00344
00345 /*  ----------------------------------------------------------------------
00346     Writer::GetPtr
00347
00348     Allows computation of a pointer which points exactly one byte behind
00349     the buffer. GetNoBytesWritable() will return 0 in this case, so a
00350     memcpy() will not overwrite memory in this case.
00351     ---------------------------------------------------------------------- */
00352 ObexBuffer::DataPtr         ObexBuffer::Writer::GetPtr()
00353 const
00354 {
00355     ASSERT_DEBUG( (m_buffer.GetSize() <= m_buffer.GetCapacity()) );
00356
00357     return  m_buffer.GetPtrAt( m_buffer.GetSize() );
00358 }// GetPtr
00359
00360 /*  ----------------------------------------------------------------------
00361     Writer::GetOffset
00362     ---------------------------------------------------------------------- */
00363 ObexBuffer::Size    ObexBuffer::Writer::GetOffset()
00364 const
00365 {
00366     return  m_buffer.GetSize();
00367 }// GetOffset
00368
00369 /*  ----------------------------------------------------------------------
00370     IsValid
00371     ---------------------------------------------------------------------- */
00372 BOOLEAN     ObexBuffer::IsValid()
00373 const
00374 {
00375     return ( m_data_ptr != 0 );
00376 }// IsValid
00377
00378 /*  ----------------------------------------------------------------------
00379     GetSize
00380     ---------------------------------------------------------------------- */
00381 ObexBuffer::Size    ObexBuffer::GetSize()
00382 const
00383 {
00384     return m_data_size;
00385 }// GetSize
00386
00387 /*  ----------------------------------------------------------------------
00388     GetCapacity
00389     ---------------------------------------------------------------------- */
00390 ObexBuffer::Size    ObexBuffer::GetCapacity()
00391 const
00392 {
00393     return m_capacity;
00394 }// GetCapacity
00395
00396 /*  ----------------------------------------------------------------------
00397     Empty
00398     ---------------------------------------------------------------------- */
00399 void    ObexBuffer::Empty()
00400 {
00401     m_data_size = 0;
00402 }// Empty
00403
00404 /*  ----------------------------------------------------------------------
00405     Release
00406     ---------------------------------------------------------------------- */
00407 void    ObexBuffer::Release()
00408 {
00409     Dispose();
00410     Reset();
00411 }// Release
00412
00413 /*  ----------------------------------------------------------------------
00414     GetPtrAt
00415     ---------------------------------------------------------------------- */
00416 ObexBuffer::DataPtr     ObexBuffer::GetPtrAt(Size   where)
00417 const
00418 {
00419     ASSERT_DEBUG( IsValid() );
00420
00421     return  &( m_data_ptr[where] );
00422 }// GetPtrAt
00423
00425 #endif  // Apoxi_ObexBuffer_hpp
00426
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexChannel.cpp File Reference

Obex/ObexChannel.cpp File Reference

#include "PreComp.hpp"
#include "ObexChannel.hpp"

Include dependency graph for ObexChannel.cpp:

Generated on Tue Jan 24 23:19:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexChannel.hpp File Reference

Obex/ObexChannel.hpp File Reference

#include <Auxiliary/BitField.hpp>
#include <Obex/ObexTypes.hpp>

Include dependency graph for ObexChannel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexChannel
Internal association class used to address an OBEX transport channel. More...

Defines

#define | Apoxi_ObexChannel_hpp

Functions

BOOLEAN | operator!= (const ObexChannel &lhs, const ObexChannel &rhs)
BOOLEAN | operator== (const ObexChannel &lhs, const ObexChannel &rhs)

Define Documentation

#define Apoxi_ObexChannel_hpp

Generated on Tue Jan 24 23:19:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexChannel.hpp Source File

Obex/ObexChannel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexChannel_hpp)
00011 #define Apoxi_ObexChannel_hpp
00014
00015 #include <Auxiliary/BitField.hpp>
00016
00017 #include <Obex/ObexTypes.hpp>
00018
00066 class ObexChannel {
00067
00069     inline  friend BOOLEAN  operator==(const ObexChannel &  lhs,
00070                                        const ObexChannel &  rhs);
00072     inline  friend BOOLEAN  operator!=(const ObexChannel &  lhs,
00073                                        const ObexChannel &  rhs);
00074
00075     public:
00078         inline  ObexChannel();
00079
00096         ObexChannel(ObexTransportId     transport_id,
00097                     ObexProtocolId      protocol_id,
00098                     BOOLEAN             is_server,
00099                     BOOLEAN             is_unique,
00100                     UINT16              impl_index);
00101
00103         inline  ObexChannel(const ObexChannel &);
00104
00106         inline  ObexChannel & operator=(const ObexChannel &);
00107
00109         inline  BOOLEAN             IsValid() const;
00110
00113         inline  void                Invalidate();
00114
00120         inline  BOOLEAN             IsUnique() const;
00121
00126         inline  BOOLEAN             IsClient() const;
00127
00132         inline  BOOLEAN             IsServer() const;
00133
00135         inline  ObexProtocolId      GetProtocolId() const;
00136
00138         inline  ObexTransportId     GetTransportId() const;
00139
00141         inline  UINT16              GetIndex() const;
00142
00143     private:
00144         static  UINT8   s_last_creation_id;
00145
00146         BitField32      m_bitfield;
00147
00148         // Value offsets within bitfield
00149         enum {
00150             OffsIsUnique    =  0,
00151             OffsIsServer    =  1,
00152             OffsTransportId =  2,
00153             OffsProtocolId  =  5,
00154             OffsCreationId  =  8,
00155             OffsImplIndex   = 16
00156         };
00157
00158         // Value masks
00159         enum {
00160             MaskTransportId = ( 0x0007uL << OffsTransportId ),  //  3 bits
00161             MaskProtocolId  = ( 0x0007uL << OffsProtocolId ),   //  3 bits
00162             MaskCreationId  = ( 0x00FFuL << OffsCreationId ),   //  8 bits
00163             MaskImplIndex   = ( 0xFFFFuL << OffsImplIndex )     // 16 bits
00164         };
00165
00166         inline  static  UINT8   NewCreationId();
00167 };
00168
00169 /*  ----------------------------------------------------------------------
00170     Comparison for equality
00171     ---------------------------------------------------------------------- */
00172 BOOLEAN     operator==(const ObexChannel &  lhs,
00173                        const ObexChannel &  rhs)
00174 {
00175     return ( lhs.m_bitfield == rhs.m_bitfield );
00176 }
00177
00178 /*  ----------------------------------------------------------------------
00179     Comparison for inequality
00180     ---------------------------------------------------------------------- */
00181 BOOLEAN     operator!=(const ObexChannel &  lhs,
00182                        const ObexChannel &  rhs)
00183 {
00184     return ! ( lhs.m_bitfield == rhs.m_bitfield );
00185 }
00186
00187 /*  ----------------------------------------------------------------------
00188     NewCreationId
00189     ---------------------------------------------------------------------- */
00190 UINT8   ObexChannel::NewCreationId()
00191 {
00192     return ( ++s_last_creation_id != 0 )
00193            ? s_last_creation_id
00194            : ++s_last_creation_id;  // Wraparound, increment again
00195 }
00196
00197 /*  ----------------------------------------------------------------------
00198     Copy Constructor
00199     ---------------------------------------------------------------------- */
00200 ObexChannel::ObexChannel() :
00201     m_bitfield(0)
00202 {
00203 }
00204
00205 /*  ----------------------------------------------------------------------
00206     Copy Constructor
00207     ---------------------------------------------------------------------- */
00208 ObexChannel::ObexChannel(const ObexChannel &    from) :
00209
00210     m_bitfield( from.m_bitfield )
00211 {
00212 }
00213
00214 /*  ----------------------------------------------------------------------
00215     Assignment
00216     ---------------------------------------------------------------------- */
00217 ObexChannel &   ObexChannel::operator=(const ObexChannel &  from)
00218 {
00219     m_bitfield = from.m_bitfield;
00220     return *this;
00221 }
00222
00223 /*  ----------------------------------------------------------------------
00224     IsValid
00225     ---------------------------------------------------------------------- */
00226 BOOLEAN     ObexChannel::IsValid()
00227 const
00228 {
00229     return  ( m_bitfield.Get(MaskCreationId) != 0 );
00230 }
00231
00232 /*  ----------------------------------------------------------------------
00233     Invalidate
00234     ---------------------------------------------------------------------- */
00235 void        ObexChannel::Invalidate()
00236 {
00237     m_bitfield.Clear();
00238 }// Invalidate
00239
00240 /*  ----------------------------------------------------------------------
00241     IsUnique
00242     ---------------------------------------------------------------------- */
00243 BOOLEAN     ObexChannel::IsUnique()
00244 const
00245 {
00246     return  m_bitfield.GetBit(OffsIsUnique);
00247 }
00248
00249 /*  ----------------------------------------------------------------------
00250     IsClient
00251     ---------------------------------------------------------------------- */
00252 BOOLEAN     ObexChannel::IsClient()
00253 const
00254 {
00255     return  ! m_bitfield.GetBit(OffsIsServer);
00256 }// IsClient
00257
00258 /*  ----------------------------------------------------------------------
00259     IsServer
00260     ---------------------------------------------------------------------- */
00261 BOOLEAN     ObexChannel::IsServer()
00262 const
00263 {
00264     return  m_bitfield.GetBit(OffsIsServer);
00265 }
00266
00267 /*  ----------------------------------------------------------------------
00268     Constructor
00269     ---------------------------------------------------------------------- */
00270 ObexProtocolId      ObexChannel::GetProtocolId() const
00271 {
00272     return (ObexProtocolId) (m_bitfield.Get(MaskProtocolId) >> OffsProtocolId);
00273 }
00274
00275 /*  ----------------------------------------------------------------------
00276     GetTransportId
00277     ---------------------------------------------------------------------- */
00278 ObexTransportId     ObexChannel::GetTransportId() const
00279 {
00280     return (ObexTransportId) (m_bitfield.Get(MaskTransportId) >> OffsTransportId);
00281 }
00282
00283 /*  ----------------------------------------------------------------------
00284     GetIndex
00285     ---------------------------------------------------------------------- */
00286 UINT16              ObexChannel::GetIndex() const
00287 {
00288     return  (UINT16) (m_bitfield.Get(MaskImplIndex) >> OffsImplIndex);
00289 }
00290
00292 #endif  // Apoxi_ObexChannel_hpp
00293
00294
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClient.cpp File Reference

Obex/ObexClient.cpp File Reference

#include "PreComp.hpp"
#include "ObexConfig.hpp"
#include "ObexObject.hpp"
#include "ObexBuffer.hpp"
#include "ObexMessages.hpp"
#include "ObexLayer.hpp"
#include "ObexClientPort.hpp"
#include "ObexClient.hpp"

Include dependency graph for ObexClient.cpp:

Generated on Tue Jan 24 23:19:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClient.hpp File Reference

Obex/ObexClient.hpp File Reference

#include <Obex/ObexObject.hpp>
#include <Obex/ObexClientDispatcher.hpp>

Include dependency graph for ObexClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexClient
Base class for OBEX clients within applications. More...

Defines

#define | Apoxi_ObexClient_hpp

Define Documentation

#define Apoxi_ObexClient_hpp

Generated on Tue Jan 24 23:19:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClient.hpp Source File

Obex/ObexClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexClient_hpp)
00011 #define Apoxi_ObexClient_hpp
00014
00015 #include <Obex/ObexObject.hpp>
00016 #include <Obex/ObexClientDispatcher.hpp>
00017
00018 // Forward declarations of classes.
00019 class ObexBuffer;
00020
00022 class ObexClient : public ObexClientDispatcher {
00023
00024     public:
00025         typedef ObexClientDispatcher Base;
00026
00031         ObexClient();
00032
00041         ObexClient(ExecutionContext *   ctx_ptr);
00042
00044         virtual ~ObexClient();
00045
00051         ObexResult          Connect(const ObexObject &  conn_req);
00052
00058         ObexResult          Disconnect(const ObexObject &  disc_req);
00059
00066         ObexResult          Put(const ObexObject &  put_req);
00067
00074         ObexResult          Get(const ObexObject &  get_req);
00075
00081         ObexResult          Abort(const  ObexObject &  abort_req);
00082
00088         ObexResult          SetPath(const ObexObject &  setpath_req);
00089
00095         ObexResult          DataProcessed(ObexBuffer &  buffer);
00096
00101         inline  UINT32      GetConnectionId() const;
00102
00110         inline  UINT32      GetProgressInBytes() const;
00111
00112     protected:
00113         virtual void        OnOpen(ObexResult   result);
00114         virtual void        OnClose(ObexResult  result);
00115
00116         virtual BOOLEAN     OnChannelsMatch(const ClientPortPtr &   port_ptr,
00117                                             const ObexMsg &         msg);
00118
00125         virtual void        OnConnect(const ObexObject &  conn_resp,
00126                                       ObexResult          result);
00127
00134         virtual void        OnDisconnect(const ObexObject &  disc_resp,
00135                                          ObexResult          result);
00136
00143         virtual void        OnSetPath(const ObexObject &  setp_resp,
00144                                       ObexResult          result);
00145
00150         virtual void        OnPutResponse(const ObexObject &  put_resp);
00151
00156         virtual void        OnPutComplete(ObexResult    result);
00157
00162         virtual void        OnGetResponse(const ObexObject &  get_resp);
00163
00168         virtual void        OnGetComplete(ObexResult    result);
00169
00177         virtual void        OnAbort(const ObexObject &  abort_resp,
00178                                     ObexResult          result);
00179
00186         virtual void        OnDataProcessed(ObexBuffer &    buffer);
00187
00188     private:
00189         enum OperType {
00190             OConnect,
00191             ODisconnect,
00192             OPut,
00193             OGet,
00194             OSetPath,
00195             ONone
00196         };
00197
00198         enum OperState {
00199             SInitial,   // No request being processed
00200             SRequest,   // Request has been sent, waiting for response
00201             SResponse,  // Response has been received, waiting for application
00202             SFinal      // Final response received, waiting for completion
00203         };
00204         ObexObject          m_response;
00205         UINT32              m_connection_id;
00206         UINT32              m_data_progress;
00207         ObexOperationId     m_oper_id;
00208         OperType            m_oper_type;
00209         OperState           m_oper_state;
00210         BOOLEAN             m_abort;
00211         BOOLEAN             m_final;
00212
00213
00214         inline  void        SetOperState(OperState  new_state);
00215
00216         BOOLEAN             HandleBuffer(const ObexMsg &            msg);
00217
00218         BOOLEAN             HandleResult(const ClientPortPtr &      port_ptr,
00219                                          const ObexMsg &            msg);
00220
00221         BOOLEAN             HandleResponse(const ClientPortPtr &    port_ptr,
00222                                            const ObexMsg &          msg);
00223
00224         void                CheckForConnId(const ObexObject &       response);
00225         void                NotifyResponse(const ObexObject &       response);
00226
00227         void                LaunchRequest(OperType                  oper_type,
00228                                           BOOLEAN                   end_of_data);
00229
00230         void                FinalizeOperation();
00231 };
00232
00233 /*  ----------------------------------------------------------------------
00234     GetConnectionId
00235     ---------------------------------------------------------------------- */
00236 UINT32  ObexClient::GetConnectionId()
00237 const
00238 {
00239     return  m_connection_id;
00240 }// GetConnectionId
00241
00242 /*  ----------------------------------------------------------------------
00243     GetProgressInBytes
00244     ---------------------------------------------------------------------- */
00245 UINT32  ObexClient::GetProgressInBytes()
00246 const
00247 {
00248     return  m_data_progress;
00249 }// GetProgressInBytes
00250
00251 /*  ----------------------------------------------------------------------
00252     SetOperState
00253     ---------------------------------------------------------------------- */
00254 void    ObexClient::SetOperState(OperState  new_state)
00255 {
00256     m_oper_state = new_state;
00257 }// SetOperState
00258
00260 #endif  // Apoxi_ObexClient_hpp
00261
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientDispatcher.cpp File Reference

Obex/ObexClientDispatcher.cpp File Reference

#include "PreComp.hpp"
#include "ObexMngr.hpp"
#include "ObexMessages.hpp"
#include "ObexProtocol.hpp"
#include "ObexTransport.hpp"
#include "ObexTransportMsg.hpp"
#include "ObexTransportSet.hpp"
#include "ObexClientPort.hpp"
#include "ObexClientDispatcher.hpp"

Include dependency graph for ObexClientDispatcher.cpp:

Generated on Tue Jan 24 23:19:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientDispatcher.hpp File Reference

Obex/ObexClientDispatcher.hpp File Reference

#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/BitField.hpp>
#include <Obex/ObexResult.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexAddress.hpp>
#include <Obex/ObexAddrPtr.hpp>
#include <Obex/ObexOperationId.hpp>
#include <Obex/ObexDispatcher.hpp>

Include dependency graph for ObexClientDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexClientDispatcher
Internal abstraction of a client OBEX transport connection. More...

Defines

#define | Apoxi_ObexClientDispatcher_hpp

Define Documentation

#define Apoxi_ObexClientDispatcher_hpp

Generated on Tue Jan 24 23:19:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientDispatcher.hpp Source File

Obex/ObexClientDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexClientDispatcher_hpp)
00011 #define Apoxi_ObexClientDispatcher_hpp
00014
00015 #include <Auxiliary/NiSharedPtr.hpp>
00016 #include <Auxiliary/BitField.hpp>
00017
00018 #include <Obex/ObexResult.hpp>
00019 #include <Obex/ObexChannel.hpp>
00020 #include <Obex/ObexAddress.hpp>
00021 #include <Obex/ObexAddrPtr.hpp>
00022 #include <Obex/ObexOperationId.hpp>
00023 #include <Obex/ObexDispatcher.hpp>
00024
00025 // Forward declarations of classes
00026 class ObexClientPort;
00027
00038 class ObexClientDispatcher : public ObexEventHandler {
00039
00040     friend class ObexClientPort;
00041
00042     public:
00043         typedef ObexEventHandler Base;
00044
00046         virtual ~ObexClientDispatcher();
00047
00054         virtual void            Init(ExecutionContext *     ctx_ptr);
00055
00065         virtual ObexResult      Open(const String &  obex_addr_url);
00066
00079         virtual ObexResult      Close();
00080
00088         inline  ObexAddrPtr     GetRemoteAddrPtr() const;
00089
00090     protected:
00091         typedef NiSharedPtr<ObexClientPort> ClientPortPtr;
00092
00097         ClientPortPtr           GetActivePortPtr() const;
00098
00099         static  inline BOOLEAN  IsValidPortPtr(const ClientPortPtr &    port_ptr);
00100
00105         ObexClientDispatcher();
00106
00115         virtual BOOLEAN         IsValidContext() const;
00116
00117         virtual BOOLEAN         OnObexMsg(const ObexMsg &   msg);
00118
00119         virtual BOOLEAN         OnObexAddrMsg(const ObexAddrMsg &   msg);
00120
00121         virtual BOOLEAN         OnObexTransportMsg(const ObexTransportMsg &  msg);
00122
00124         virtual void            OnOpen(ObexResult   result) = 0;
00125
00127         virtual void            OnClose(ObexResult  result) = 0;
00128
00139         virtual BOOLEAN         OnChannelsMatch(const ClientPortPtr &   port_ptr,
00140                                                 const ObexMsg &         msg) = 0;
00141
00169         virtual ObexResult      OpenAction();
00170
00199         virtual ObexResult      CloseAction();
00200
00202         void                    AbortSelection();
00203
00204     private:
00206         enum  ClientFlags {
00207             IsOpenPending,
00208             IsClosePending,
00209             IsOpenNotified,
00210             IsCloseNotified,
00211             IsEventPending,
00212             IsConnected,
00213         };
00214
00215         BitField8               m_client_state;
00216         ObexResult              m_result;
00217         ObexOperationId         m_select_oper_id;
00218         ObexDispatcher          m_dispatcher;
00219         String                  m_obex_url_str;
00220         ClientPortPtr           m_active_port_ptr;
00221
00222         void                    OnPortOpened(ObexResult     result);
00223         void                    OnPortClosed(ObexTransportId    id);
00224         ObexResult              OnTransportSelected(ObexTransportId id);
00225         void                    Notify();
00226         void                    NotifyOpened();
00227         void                    NotifyClosed();
00228         void                    CleanUp();
00229 };
00230
00231 BOOLEAN     ObexClientDispatcher::IsValidPortPtr(const ClientPortPtr &   port_ptr)
00232 {
00233     return  ( port_ptr.Get() != 0 );
00234 }
00235
00236 #if 0
00237 /*  ----------------------------------------------------------------------
00238     GetRemoteAddrPtr
00239     ---------------------------------------------------------------------- */
00240 ObexAddrPtr     ObexClientDispatcher::GetRemoteAddrPtr()
00241 const
00242 {
00243     return  m_addr_ptr;
00244 }// GetRemoteAddrPtr
00245 #endif
00246
00248 #endif  // Apoxi_ObexClientDispatcher_hpp
00249
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientOppImpl.cpp File Reference

Obex/ObexClientOppImpl.cpp File Reference

#include "PreComp.hpp"
#include "ObexMessages.hpp"
#include "ObexClientOppImpl.hpp"

Include dependency graph for ObexClientOppImpl.cpp:

Generated on Tue Jan 24 23:19:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientOppImpl.hpp File Reference

Obex/ObexClientOppImpl.hpp File Reference

#include <Obex/ObexBuffer.hpp>
#include <Obex/ObexClient.hpp>
#include <Obex/ObexOppClient.hpp>

Include dependency graph for ObexClientOppImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexClientOppImpl
Internal client implementation of the OPP profile. More...
class | ObexOppClientOperation
Internal abstraction of an OPP client operation. More...
class | ObexOppClientPull
Internal implementation of an OPP PULL operation.. More...
class | ObexOppClientPush
Internal implementation of an OPP PUSH operation.. More...

Defines

#define | Apoxi_ObexClientOppImpl_hpp

Define Documentation

#define Apoxi_ObexClientOppImpl_hpp

Generated on Tue Jan 24 23:19:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientOppImpl.hpp Source File

Obex/ObexClientOppImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexClientOppImpl_hpp)
00011 #define Apoxi_ObexClientOppImpl_hpp
00014
00015 #include <Obex/ObexBuffer.hpp>
00016 #include <Obex/ObexClient.hpp>
00017 #include <Obex/ObexOppClient.hpp>
00018
00030 class ObexOppClientOperation {
00031
00032     public:
00034         ObexOppClientOperation();
00035
00037         virtual ~ObexOppClientOperation();
00038
00040         virtual ObexResult  Initiate(const ObexObject &     request) const = 0;
00041
00043         virtual void        OnFailure(ObexOppClient &       client,
00044                                       const ObexResult &    result) const = 0;
00045 };
00046
00053 class ObexOppClientPush : public ObexOppClientOperation {
00054     public:
00055         static  inline  ObexOppClientOperation &    GetInstance()
00056         {
00057             return s_instance;
00058         }
00059
00060         virtual ObexResult  Initiate(const ObexObject &     request) const;
00061
00062         virtual void        OnFailure(ObexOppClient &       client,
00063                                       const ObexResult &    result) const;
00064
00065     private:
00066         static  ObexOppClientPush   s_instance;
00067 };
00068
00075 class ObexOppClientPull : public ObexOppClientOperation {
00076     public:
00077         static  inline  ObexOppClientOperation &    GetInstance()
00078         {
00079             return s_instance;
00080         }
00081
00082         virtual ObexResult  Initiate(const ObexObject &     request) const;
00083
00084         virtual void        OnFailure(ObexOppClient &       client,
00085                                       const ObexResult &    result) const;
00086     private:
00087         static  ObexOppClientPull   s_instance;
00088 };
00089
00117 class ObexClientOppImpl : public ObexClient {
00118
00119     public:
00121         static  ObexClientOppImpl &     GetInstance();
00122
00124         inline  BOOLEAN     IsActiveOppClient(const ObexOppClient *  client_ptr)
00125         const
00126         {
00127             return ( m_active_opp_client_ptr == client_ptr );
00128         }
00129
00143         ObexResult          StartOperation(ObexOppClient *  opp_client_ptr);
00144
00146         void                Disconnect();
00147
00149         void                CloseConnection();
00150
00152         ObexResult          Push(const ObexObject &     push_req);
00153
00155         ObexResult          Pull(const ObexObject &     push_req);
00156
00172         ObexResult          Abort(const WString &       desc,
00173                                   BOOLEAN               force_sync);
00174
00180         ObexResult          ProvideData(ObexBuffer &    app_data,
00181                                         BOOLEAN         end_data);
00182
00184         ObexResult          DataProcessed(ObexBuffer &  app_data);
00185
00186     protected:
00187         virtual BOOLEAN     IsValidContext() const;
00188         virtual void        OnOpen(ObexResult   result);
00189         virtual void        OnClose(ObexResult  result);
00190
00191         virtual void        OnConnect(const ObexObject &        conn_resp,
00192                                       ObexResult                result);
00193
00194         virtual void        OnDisconnect(const ObexObject &     disc_resp,
00195                                          ObexResult             result);
00196
00197         virtual void        OnPutResponse(const ObexObject &    put_resp);
00198         virtual void        OnPutComplete(ObexResult            result);
00199         virtual void        OnGetResponse(const ObexObject &    get_resp);
00200         virtual void        OnGetComplete(ObexResult            result);
00201
00202         virtual void        OnAbort(const ObexObject &  abort_resp,
00203                                     ObexResult          result);
00204
00205         virtual void        OnDataProcessed(ObexBuffer &    buffer);
00206
00207     private:
00208         typedef ObexClient  Base;
00209
00211         enum OppState {
00212
00213             SOppAvailable,
00214             SOppOpening,
00215             SOppTransient,
00216             SOppCancelled,
00217             SOppConnected,
00218
00219             SOppAborted,
00220             SOppFinally,
00221
00222             SOppPushInitial,
00223             SOppPushContinued,
00224             SOppPushResponse,
00225
00226             SOppPullInitial,
00227             SOppPullContinued,
00228             SOppPullResponse
00229         };
00230
00231         static  ObexClientOppImpl   s_instance;
00232
00233         OppState                    m_opp_state;
00234         ObexObject::ResponseCode    m_resp_code;
00235         BOOLEAN                     m_is_end_data;  // Only request !
00236         BOOLEAN                     m_is_final;     // Only response !
00237         BOOLEAN                     m_is_api_being_notified;
00238         WString                     m_description;
00239         ObexOppClient *             m_active_opp_client_ptr;
00240         ObexObject                  m_request;
00241         ObexBuffer                  m_buffer;
00242
00243         ObexClientOppImpl();
00244
00245         inline  ObexOppClient &     GetActiveOppClient()
00246         {
00247             ASSERT_DEBUG(m_active_opp_client_ptr != 0);
00248             return *m_active_opp_client_ptr;
00249         }
00250
00251         inline  void        SetActiveOppClient(ObexOppClient *  client_ptr)
00252         {
00253             m_active_opp_client_ptr = client_ptr;
00254         }
00255
00256         inline  void        SetOppState(OppState    new_state)
00257         {
00258             m_opp_state = new_state;
00259         }
00260
00261         inline  OppState    GetOppState() const
00262         {
00263             return  m_opp_state;
00264         }
00265
00266         inline  BOOLEAN     IsInState(OppState  query_state) const
00267         {
00268             return  ( query_state == m_opp_state );
00269         }
00270
00271         void        OnBadResponse(const ObexObject &  bad_resp);
00272
00273         void        SendAbort();
00274
00275         ObexResult  EnqueueData(ObexBuffer &    app_data,
00276                                 BOOLEAN         end_data);
00277
00278         BOOLEAN     OnOppPreComplete(const ObexResult &     result);
00279 };
00280
00282 #endif  // Apoxi_ObexClientOppImpl_hpp
00283
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientPort.cpp File Reference

Obex/ObexClientPort.cpp File Reference

#include "PreComp.hpp"
#include <Devices/AbstractTransport.hpp>
#include "ObexClientDispatcher.hpp"
#include "ObexTransport.hpp"
#include "ObexProtocol.hpp"
#include "ObexClientPort.hpp"

Include dependency graph for ObexClientPort.cpp:

Functions

FSM_DEFINE_STATE (ObexClientPort, s1_connected)
FSM_DEFINE_STATE (ObexClientPort, s1_attaching)
FSM_DEFINE_STATE (ObexClientPort, s1_wait_avs)
FSM_DEFINE_STATE (ObexClientPort, s1_initially)
FSM_STATE_ELSE (ObexClientPort, s1_connected, DefaultAction)
FSM_STATE_ELSE (ObexClientPort, s1_attaching, DefaultAction)
FSM_STATE_ELSE (ObexClientPort, s1_wait_avs, DefaultAction)
FSM_STATE_ELSE (ObexClientPort, s1_initially, DefaultAction)

Function Documentation

FSM_DEFINE_STATE | ( | ObexClientPort | ,
 |  | s1_connected |
 | ) |

FSM_DEFINE_STATE | ( | ObexClientPort | ,
 |  | s1_attaching |
 | ) |

FSM_DEFINE_STATE | ( | ObexClientPort | ,
 |  | s1_wait_avs |
 | ) |

FSM_DEFINE_STATE | ( | ObexClientPort | ,
 |  | s1_initially |
 | ) |

FSM_STATE_ELSE | ( | ObexClientPort | ,
 |  | s1_connected | ,
 |  | DefaultAction |
 | ) |

FSM_STATE_ELSE | ( | ObexClientPort | ,
 |  | s1_attaching | ,
 |  | DefaultAction |
 | ) |

FSM_STATE_ELSE | ( | ObexClientPort | ,
 |  | s1_wait_avs | ,
 |  | DefaultAction |
 | ) |

FSM_STATE_ELSE | ( | ObexClientPort | ,
 |  | s1_initially | ,
 |  | DefaultAction |
 | ) |

Generated on Tue Jan 24 23:19:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientPort.hpp File Reference

Obex/ObexClientPort.hpp File Reference

#include <Obex/ObexAbstractPort.hpp>

Include dependency graph for ObexClientPort.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexClientPort
Internal implementation class for OBEX transport interfaces. More...

Defines

#define | Apoxi_ObexClientPort_hpp

Define Documentation

#define Apoxi_ObexClientPort_hpp

Generated on Tue Jan 24 23:19:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexClientPort.hpp Source File

Obex/ObexClientPort.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexClientPort_hpp)
00011 #define Apoxi_ObexClientPort_hpp
00014
00015 #include <Obex/ObexAbstractPort.hpp>
00016
00017 //  Forward declaration of classes
00018 class ObexClientDispatcher;
00019
00041 class ObexClientPort : public ObexAbstractPort {
00042
00043     public:
00044         typedef ObexAbstractPort    Base;
00045
00057         ObexClientPort(ObexAbstractTransport &  transport,
00058                        ObexProtocol &           protocol,
00059                        ObexClientDispatcher &   client);
00060
00062         inline  BOOLEAN     IsConnected() const;
00063
00064     protected:
00065         virtual void        StartAddrResolution();
00066         virtual void        AbortAddrResolution();
00067
00068         virtual BOOLEAN     AcquireChannel(ObexChannel &        channel,
00069                                            const ObexAddrPtr &  addr_ptr,
00070                                            ObexResult           result);
00071
00072         virtual void        OpenChannel(const ObexAddrPtr &     addr_ptr);
00073         virtual void        CloseChannel(ObexResult cause);
00074
00075         virtual void        OnChannelClosed();
00076         virtual void        OnChannelOpened(ObexResult  result);
00077
00078     private:
00079         EventType   EnableAction(FsmEngine &, EventType, ObjectObtainer &);
00080
00081         // Initial state and state after port has been closed again.
00082         FSM_DECLARE_STATE(s1_initially);
00083
00084         // Port is waiting for availability state to become 'AvsReady'
00085         FSM_DECLARE_STATE(s1_wait_avs);
00086
00087         // Port is detaching from transport (procedure running)
00088         FSM_DECLARE_STATE(s1_detaching);
00089
00090         // Port is attaching to transport (procedure running)
00091         FSM_DECLARE_STATE(s1_attaching);
00092
00093         // Port is connected to a remote server.
00094         FSM_DECLARE_STATE(s1_connected);
00095
00096         ObexClientDispatcher &      m_client;
00097
00098         void                        EnableTransport();
00099 };
00100
00101 /*  ----------------------------------------------------------------------
00102     IsConnected
00103     ---------------------------------------------------------------------- */
00104 BOOLEAN     ObexClientPort::IsConnected()
00105 const
00106 {
00107     return  IsInState( FSM_STATE_FROM_NAME(s1_connected) );
00108 }// IsConnected
00109
00111 #endif  // Apoxi_ObexClientPort_hpp
00112
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexConfig.hpp File Reference

Obex/ObexConfig.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_OBEX_DBG_OUT 40222
Constant for enabling DBG_OUT tracing within APOXI OBEX.
#define | APOXI_OBEX_FTP_DBG 36003
#define | APOXI_OBEX_MAX_NO_SELECTIONS 2
Maximum number of transport selection procedures running concurrently.
#define | APOXI_OBEX_MAX_NO_TRANSPORTS 3
Maximum number of transport implementations to be used with OBEX.
#define | APOXI_OBEX_OPP_DBG 36002
#define | Apoxi_ObexConfig_hpp

Define Documentation

#define Apoxi_ObexConfig_hpp

Generated on Tue Jan 24 23:19:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexConfig.hpp Source File

Obex/ObexConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexConfig_hpp)
00010 #define Apoxi_ObexConfig_hpp
00013
00014
00015 //#define   APOXI_OBEX_DBG_OUT  36001   // OBEX  36000 - 36010
00016 #define APOXI_OBEX_DBG_OUT  40222
00017 #define APOXI_OBEX_OPP_DBG  36002
00018 #define APOXI_OBEX_FTP_DBG  36003
00019
00021 #ifndef APOXI_OBEX_MAX_NO_TRANSPORTS
00022     #define APOXI_OBEX_MAX_NO_TRANSPORTS  3
00023 #endif
00024
00026 #ifndef APOXI_OBEX_MAX_NO_SELECTIONS
00027     #define APOXI_OBEX_MAX_NO_SELECTIONS  2
00028 #endif
00029
00030
00031 /* Sanity checks for definitions - please don't 'customize' them, it will
00032  * break your code !
00033  */
00034 #if (APOXI_OBEX_MAX_NO_TRANSPORTS < 1)
00035     #error "APOXI_OBEX_MAX_NO_TRANSPORTS must be >= 1 when OBEX is used."
00036 #endif
00037
00038 #if (APOXI_OBEX_MAX_NO_SELECTIONS < 1)
00039     #error "APOXI_OBEX_MAX_NO_SELECTIONS must be >= 1 when OBEX is used."
00040 #endif
00041
00043 #endif  // Apoxi_ObexConfig_hpp
00044
Generated on Tue Jan 24 14:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexDataServer.cpp File Reference

Obex/ObexDataServer.cpp File Reference

#include "PreComp.hpp"
#include <Auxiliary/BinData.hpp>
#include <Auxiliary/DataSink.hpp>
#include "ObexDataServer.hpp"

Include dependency graph for ObexDataServer.cpp:

Defines

#define APOXI_OBEX_DATA_SERVER_STATE(state_name)

Functions

APOXI_OBEX_DATA_SERVER_STATE (OperGetProvide)
APOXI_OBEX_DATA_SERVER_STATE (OperGetAccept)
APOXI_OBEX_DATA_SERVER_STATE (OperGetHeaders)
APOXI_OBEX_DATA_SERVER_STATE (OperGetRequest)
APOXI_OBEX_DATA_SERVER_STATE (OperPutAccept)
APOXI_OBEX_DATA_SERVER_STATE (OperPutHeaders)
APOXI_OBEX_DATA_SERVER_STATE (OperPutRequest)
APOXI_OBEX_DATA_SERVER_STATE (OperFinal)
APOXI_OBEX_DATA_SERVER_STATE (OperConfirm)
APOXI_OBEX_DATA_SERVER_STATE (OperIdle)

Define Documentation

#define APOXI_OBEX_DATA_SERVER_STATE ( state_name )

Value:

ObexDataServer::state_name  ObexDataServer::state_name::s_instance; \
    const ObexDataServer::OperState::ApiErrorCodeTab \
    ObexDataServer::state_name::c_api_err_code_tab =

Function Documentation

APOXI_OBEX_DATA_SERVER_STATE ( OperGetProvide )

APOXI_OBEX_DATA_SERVER_STATE ( OperGetAccept )

APOXI_OBEX_DATA_SERVER_STATE ( OperGetHeaders )

APOXI_OBEX_DATA_SERVER_STATE ( OperGetRequest )

APOXI_OBEX_DATA_SERVER_STATE ( OperPutAccept )

APOXI_OBEX_DATA_SERVER_STATE ( OperPutHeaders )

APOXI_OBEX_DATA_SERVER_STATE ( OperPutRequest )

APOXI_OBEX_DATA_SERVER_STATE ( OperFinal )

APOXI_OBEX_DATA_SERVER_STATE ( OperConfirm )

APOXI_OBEX_DATA_SERVER_STATE ( OperIdle )

Generated on Tue Jan 24 23:19:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexDataServer.hpp File Reference

Obex/ObexDataServer.hpp File Reference

#include <Obex/ObexObject.hpp>
#include <Obex/ObexBuffer.hpp>
#include <Obex/ObexServer.hpp>

Include dependency graph for ObexDataServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexDataServer
OBEX server which uses the BinData and DataSink interfaces for transferring data. More...

Defines

#define | Apoxi_ObexDataServer_hpp

Define Documentation

#define Apoxi_ObexDataServer_hpp

Generated on Tue Jan 24 23:19:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexDataServer.hpp Source File

Obex/ObexDataServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexDataServer_hpp)
00011 #define Apoxi_ObexDataServer_hpp
00014
00015 #include <Obex/ObexObject.hpp>
00016 #include <Obex/ObexBuffer.hpp>
00017 #include <Obex/ObexServer.hpp>
00018
00019 // Forward declarations of classes
00020 class ExecutionContext;
00021 class DataSink;
00022 class BinData;
00023
00032 class ObexDataServer : private ObexServer {
00033
00034     private:
00035         typedef ObexServer  Base;
00036
00037     public:
00039         enum {
00040             MinGetFragSize = 256,
00041             DefGetFragSize = 4096
00042         };
00047         ObexDataServer();
00048
00059         ObexDataServer(ExecutionContext *   ctx_ptr);
00060
00062         virtual ~ObexDataServer();
00063
00071         virtual void        Init(ExecutionContext *     ctx_ptr);
00072
00085         void                SetGetFragSize(UINT         frag_size);
00087         using               Base::Open;
00089         using               Base::Close;
00090
00101         ObexHeaderList &    GetResponseHeaderList();
00102
00110         ObexResult          InitResponse(ObexObject::ResponseCode   resp_code);
00111
00121         ObexResult          PostResponse();
00122
00141         ObexResult          AcceptData(DataSink *   data_sink_ptr,
00142                                        UINT32       max_data_size);
00143
00156         ObexResult          ProvideData(BinData *   data_src_ptr);
00157
00165         UINT32              GetProgressInBytes() const;
00166
00167     protected:
00169         using               Base::OnDisconnected;
00171         using               Base::HangUp;
00173         using               Base::OnClose;
00175         using               Base::OnBind;
00177         using               Base::OnRelease;
00178
00179
00197         virtual void        OnConnect(const ObexHeaderList &    headers,
00198                                       UINT8                     flags);
00199
00218         virtual void        OnDisconnect(const ObexHeaderList & headers) {}
00219
00221         virtual void        OnPutIncoming() {}
00222
00224         virtual void        OnGetIncoming() {}
00225
00231         virtual void        OnPutHeaders(const ObexHeaderList & headers) {}
00232
00238         virtual void        OnGetHeaders(const ObexHeaderList & headers) {}
00239
00257         virtual void        OnSetPath(const ObexHeaderList &    headers,
00258                                       UINT8                     flags);
00259
00268         virtual void        OnAbort(const ObexHeaderList &      headers) {}
00269
00275         virtual void        OnDelete();
00276
00286         virtual void        OnDataAvailable();
00287
00307         virtual void        OnDataComplete();
00308
00320         virtual void        OnDataRequested();
00321
00328         virtual void        OnPutComplete(ObexResult    result) {}
00329
00336         virtual void        OnGetComplete(ObexResult    result) {}
00337
00338
00339 //  private: Only public for MSVC 6 compatibility :-(
00340     public:
00341         class OperState;
00342         class OperPutData;
00343         class OperGetData;
00344         class OperIdle;
00345         class OperConfirm;
00346         class OperFinal;
00347         class OperPutRequest;
00348         class OperPutHeaders;
00349         class OperPutAccept;
00350         class OperGetRequest;
00351         class OperGetHeaders;
00352         class OperGetAccept;
00353         class OperGetProvide;
00354
00355     private:
00356         // VC6 :-((
00357         friend class        OperPutData;
00358         friend class        OperGetData;
00359         friend class        OperConfirm;
00360         friend class        OperPutRequest;
00361         friend class        OperGetRequest;
00362
00363         ObexBuffer          m_buffer;
00364         ObexObject          m_request;
00365         ObexObject          m_response;
00366         DataSink *          m_data_snk_ptr;
00367         BinData *           m_data_src_ptr;
00368         const OperState *   m_op_state_ptr;
00369         mutable UINT32      m_data_progress;
00370         UINT32              m_data_size;
00371         UINT                m_frag_size;
00372         BOOLEAN             m_is_event_pending;
00373         BOOLEAN             m_is_event_handled;
00374
00375         void                InitClass();
00376         void                SetOperState(const OperState &  next_state);
00377
00378         BOOLEAN             IsOperationProceeding();
00379
00380         BOOLEAN             IsRequestAcceptable(const ObexObject &  request,
00381                                                 BOOLEAN             is_initial);
00382
00383         void                SendResponse(BOOLEAN    force_final);
00384
00385         void                HandleConfirm();
00386         void                HandlePutHeaders();
00387         void                HandlePutData();
00388         void                HandleGetHeaders();
00389         void                HandleGetData();
00390
00391         void                RejectRequest();
00392
00393         void                PostEvent();
00394         void                HandleEvents();
00395
00396         BOOLEAN             RecvBodyData(const OperState &  cont_req_state);
00397         void                SendBodyData();
00398
00399         void                UpdateProgress() const;
00400
00401         virtual ObexResult  CloseAction();
00402
00403         virtual void        OnConnect(const ObexObject &    conn_req);
00404
00405         virtual void        OnDisconnect(const ObexObject &  disc_req);
00406
00407         virtual void        OnPut(const ObexObject &  put_req,
00408                                   BOOLEAN             initial);
00409
00410         virtual void        OnGet(const ObexObject &  get_req,
00411                                   BOOLEAN             initial);
00412
00413         virtual void        OnAbort(const ObexObject &  abort_req);
00414
00415         virtual void        OnSetPath(const ObexObject &  setp_req);
00416
00417         virtual void        OnComplete(Operation    op,
00418                                        ObexResult   result);
00419
00420         virtual void        OnDataProcessed(ObexBuffer &    buffer);
00421 };
00422
00424 #endif  // Apoxi_ObexDataServer_hpp
00425
Generated on Tue Jan 24 14:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexDispatcher.cpp File Reference

Obex/ObexDispatcher.cpp File Reference

#include "PreComp.hpp"
#include "Kernel/ExecutionContext.hpp"
#include "ObexMessages.hpp"
#include "ObexTransportMsg.hpp"
#include "ObexDispatcher.hpp"

Include dependency graph for ObexDispatcher.cpp:

Defines

#define OBEX_HANDLE_MSG(class_name, msg_name) { msg_name::ID, (BOOLEAN (class_name::*)(const Message &)) &class_name::On##msg_name }

Define Documentation

#define OBEX_HANDLE_MSG | ( | class_name,
 |  | msg_name | ) | { msg_name::ID, (BOOLEAN (class_name::*)(const Message &)) &class_name::On##msg_name }

Generated on Tue Jan 24 23:19:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexDispatcher.hpp File Reference

Obex/ObexDispatcher.hpp File Reference

#include <Kernel/MessageMapDispatcher.hpp>
#include <Kernel/MessageMap.hpp>
#include <Obex/ObexTypes.hpp>

Include dependency graph for ObexDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexDispatcher
Internal OBEX message dispatcher. More...
class | ObexEventHandler
Internal interface for handling OBEX protocol events. More...

Defines

#define | Apoxi_ObexDispatcher_hpp

Define Documentation

#define Apoxi_ObexDispatcher_hpp

Generated on Tue Jan 24 23:19:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexDispatcher.hpp Source File

Obex/ObexDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexDispatcher_hpp)
00011 #define Apoxi_ObexDispatcher_hpp
00014
00015 #include <Kernel/MessageMapDispatcher.hpp>
00016 #include <Kernel/MessageMap.hpp>
00017
00018 #include <Obex/ObexTypes.hpp>
00019
00020 // Forward declarations of classes.
00021 class ExecutionContext;
00022 class ObexMsg;
00023 class ObexAddrMsg;
00024 class ObexTransportMsg;
00025
00044 class ObexEventHandler {
00045
00046     friend class ObexDispatcher;
00047
00048     public:
00050         virtual ~ObexEventHandler() {}
00051
00052     protected:
00054         ObexEventHandler() {}
00055
00067         virtual BOOLEAN     IsValidContext() const = 0;
00068
00070         virtual BOOLEAN     OnObexMsg(const ObexMsg &   msg) = 0;
00072         virtual BOOLEAN     OnObexAddrMsg(const ObexAddrMsg &   msg) = 0;
00074         virtual BOOLEAN     OnObexTransportMsg(const ObexTransportMsg & msg) = 0;
00075 };
00076
00077
00085 class ObexDispatcher : public MessageMapDispatcher {
00086
00087     public:
00091         ObexDispatcher(ObexProtocolId   type_id);
00092
00094         virtual ~ObexDispatcher();
00095
00102         virtual void                Init(ExecutionContext *     ctx_ptr,
00103                                          ObexEventHandler *     handler_ptr);
00104
00109         void                        Attach();
00110
00115         void                        Detach();
00116
00118         BOOLEAN                     IsInValidContext() const;
00119
00120         inline  ObexProtocolId      GetTypeId() const;
00121
00124         inline  Application *       GetAppPtr() const;
00125
00127         inline  ExecutionContext &  GetContext() const;
00128
00129     private:
00130         typedef MessageMapDispatcher                    Base;
00131         typedef MessageMap<ObexEventHandler>            ObexMsgMapElement;
00132         typedef MessageMapContainer<ObexEventHandler>   ObexMsgMapContainer;
00133
00134         static  const ObexMsgMapElement                 c_msg_map[];
00135
00136         ObexMsgMapContainer                             m_msg_map_container;
00137         ExecutionContext *                              m_ctx_ptr;
00138         ObexEventHandler *                              m_handler_ptr;
00139         const ObexProtocolId                            c_type_id;
00140 };
00141
00142 /*  ----------------------------------------------------------------------
00143     GetTypeId
00144     ---------------------------------------------------------------------- */
00145 ObexProtocolId      ObexDispatcher::GetTypeId()
00146 const
00147 {
00148     return  c_type_id;
00149 }// GetTypeId
00150
00151 /*  ----------------------------------------------------------------------
00152     GetAppPtr
00153     ---------------------------------------------------------------------- */
00154 Application *       ObexDispatcher::GetAppPtr()
00155 const
00156 {
00157     return  (Application *) m_ctx_ptr;
00158 }// GetAppPtr
00159
00160 /*  ----------------------------------------------------------------------
00161     GetContext
00162     ---------------------------------------------------------------------- */
00163 ExecutionContext &  ObexDispatcher::GetContext()
00164 const
00165 {
00166     ASSERT_DEBUG(m_ctx_ptr != 0);
00167
00168     return  *m_ctx_ptr;
00169 }// GetContext
00170
00172 #endif  // Apoxi_ObexDispatcher_hpp
00173
Generated on Tue Jan 24 14:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexFtpDataServer.cpp File Reference

Obex/ObexFtpDataServer.cpp File Reference

#include "PreComp.hpp"
#include <Auxiliary/HeapDataSource.hpp>
#include <Auxiliary/DataSourceBinData.hpp>
#include "ObexConfig.hpp"
#include "ObexFtpDataServer.hpp"
#include "ObexFtpServer.hpp"

Include dependency graph for ObexFtpDataServer.cpp:

Generated on Tue Jan 24 23:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexFtpDataServer.hpp File Reference

Obex/ObexFtpDataServer.hpp File Reference

#include <Auxiliary/String.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <Auxiliary/DataSource.hpp>
#include <Auxiliary/HeapDataSink.hpp>
#include <Obex/ObexHeaderList.hpp>
#include <Obex/ObexAddrPtr.hpp>
#include <Obex/ObexResult.hpp>
#include <Obex/ObexDataServer.hpp>

Include dependency graph for ObexFtpDataServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexFtpDataServer
Internal implementation class which handles the OBEX FTP logic used by the class ObexFtpServer. More...

Defines

#define | Apoxi_ObexFtpDataServer_hpp

Define Documentation

#define Apoxi_ObexFtpDataServer_hpp

Generated on Tue Jan 24 23:20:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexFtpDataServer.hpp Source File

Obex/ObexFtpDataServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexFtpDataServer_hpp)
00011 #define Apoxi_ObexFtpDataServer_hpp
00014
00015 #include <Auxiliary/String.hpp>
00016 #include <Auxiliary/SimpleMap.hpp>
00017 #include <Auxiliary/DataSource.hpp>
00018 #include <Auxiliary/HeapDataSink.hpp>
00019
00020 #include <Obex/ObexHeaderList.hpp>
00021 #include <Obex/ObexAddrPtr.hpp>
00022 #include <Obex/ObexResult.hpp>
00023 #include <Obex/ObexDataServer.hpp>
00024
00025 //  Forward declarations of classes
00026 class DataSourceBinData;
00027 class ObexFtpServer;
00028
00035 class ObexFtpDataServer : public ObexDataServer {
00036
00037     typedef ObexDataServer Base;
00038
00039     public:
00044         typedef SimpleMap<String, String> FolderListingEntryProps;
00045
00050         ObexFtpDataServer();
00051
00065         ObexFtpDataServer(ObexFtpServer* frontend, ExecutionContext* ctx_ptr);
00066
00068         virtual ~ObexFtpDataServer();
00069
00080         virtual void Init(ObexFtpServer* frontend, ExecutionContext* ctx_ptr);
00081
00083         const WString& GetCurrentFolder() const;
00084
00086
00087         ObexResult HandleConnectionRequest(ObexObject::ResponseCode resp_code);
00088
00089         ObexResult HandleFolderListingRequest(ObexObject::ResponseCode resp_code);
00090
00091         ObexResult HandleProvideFolderListingEntry(BOOLEAN isFolder,
00092             const String& name, const FolderListingEntryProps& props);
00093
00094         ObexResult HandleProvideFolderListingEntriesFinished();
00095
00096         ObexResult HandleSetCurrentFolderRequest(
00097             ObexObject::ResponseCode resp_code);
00098
00099         ObexResult HandleFilePullRequest(ObexObject::ResponseCode resp_code,
00100             DataSourcePtr data_src_ptr);
00101
00102         ObexResult HandleFilePushRequest(ObexObject::ResponseCode resp_code,
00103             DataSinkPtr data_sink_ptr, UINT32 max_size = 0);
00104
00105         ObexResult HandleDeleteObjectRequest(ObexObject::ResponseCode resp_code);
00106
00107     protected:
00108
00109         // Misc OBEX operations
00110         virtual void OnBind(const ObexAddrPtr& addr_ptr, ObexResult result);
00111         virtual void OnConnect(const ObexHeaderList& headers, UINT8 flags);
00112         virtual void OnDisconnect(const ObexHeaderList& headers);
00113         virtual void OnDisconnected(ObexResult result);
00114         virtual void OnSetPath(const ObexHeaderList& headers, UINT8 flags);
00115
00116         // OBEX GET operation
00117         virtual void OnGetIncoming();
00118         virtual void OnGetHeaders(const ObexHeaderList& headers);
00119         virtual void OnDataRequested();
00120         virtual void OnGetComplete(ObexResult result);
00121
00122         // OBEX PUT operation
00123         virtual void OnPutIncoming();
00124         virtual void OnPutHeaders(const ObexHeaderList& headers);
00125         virtual void OnDataAvailable();
00126         virtual void OnDelete();
00127         virtual void OnPutComplete(ObexResult result);
00128
00129         // Submits an OBEX response code to the client.
00130         ObexResult SubmitResponse(ObexObject::ResponseCode resp_code);
00131
00132         // Extracts all useful header fields out of the given header.
00133         void ExtractHeaderFields(const ObexHeaderList& headers);
00134
00135         // Clears all header field members.
00136         void ClearHeaderFields();
00137
00138     private:
00139
00140         enum Operation {
00141             OperationNone,
00142             OperationFolderListing,
00143             OperationPullObject,
00144             OperationPushObject,
00145             OperationDeleteObject
00146         };
00147
00148         enum FrontendEvent {
00149             FrontendEventOnConnect,
00150             FrontendEventOnGetFolderListing,
00151             FrontendEventOnProvideFolderListingEntries,
00152             FrontendEventOnSetCurrentFolder,
00153             FrontendEventOnFilePull,
00154             FrontendEventOnFilePush,
00155             FrontendEventOnDeleteObject,
00156             FrontendEventNone
00157         };
00158
00159         // Used for checking correct invocation of public HandleXYZ methods.
00160         ObexResult IsInvocationAllowed(FrontendEvent expected_event);
00161         void SetFrontendEvent(FrontendEvent event);
00162
00163     private:
00164         // Pointer to frontend
00165         ObexFtpServer* m_frontend;
00166
00167         // Initialization state flag.
00168         BOOLEAN m_initialized;
00169
00170         // Current operation
00171         Operation m_operation;
00172
00173         // Last fired frontend event.
00174         FrontendEvent m_frontend_event;
00175
00176         // Current & requested path
00177         WString m_cur_path;
00178         WString m_req_path;
00179
00180         // Necessary header fields from PUT/GET operation
00181         BOOLEAN m_header_name_set;
00182         WString m_header_name;
00183         BOOLEAN m_header_length_set;
00184         UINT32 m_header_length;
00185         BOOLEAN m_header_type_set;
00186         String m_header_type;
00187
00188         // Members for object pull/push
00189         DataSinkPtr m_data_sink_ptr;
00190         DataSourceBinData* m_bin_data_src_ptr;
00191
00192         // DataSink for constructing XML folder listing
00193         HeapDataSinkPtr m_folder_listing_ptr;
00194
00195         // Several static string constants, used for building XML folder listing
00196         static const CHAR* const xml_header;
00197         static const CHAR* const xml_parent_folder_entry;
00198         static const CHAR* const xml_folder_entry;
00199         static const CHAR* const xml_file_entry;
00200         static const CHAR* const xml_attribute_assignment;
00201         static const CHAR* const xml_attribute_separator;
00202         static const CHAR* const xml_end_tag_newline;
00203         static const CHAR* const xml_footer;
00204         static const CHAR* const obex_header_folder_listing;
00205
00206         // Root path and path separator
00207         static const WCHAR* const s_root_path;
00208         static const WCHAR* const s_path_separator;
00209 };
00210
00212 #endif // Apoxi_ObexFtpDataServer_hpp
00213
Generated on Tue Jan 24 14:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexFtpServer.cpp File Reference

Obex/ObexFtpServer.cpp File Reference

#include "PreComp.hpp"
#include "ObexFtpServer.hpp"

Include dependency graph for ObexFtpServer.cpp:

Generated on Tue Jan 24 23:20:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexFtpServer.hpp File Reference

Obex/ObexFtpServer.hpp File Reference

#include "ObexFtpDataServer.hpp"

Include dependency graph for ObexFtpServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexFtpServer
OBEX FTP server which offers an abstract interface to be implemented for a specific file system. More...

Defines

#define | Apoxi_ObexFtpServer_hpp

Define Documentation

#define Apoxi_ObexFtpServer_hpp

Generated on Tue Jan 24 23:20:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexFtpServer.hpp Source File

Obex/ObexFtpServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexFtpServer_hpp)
00011 #define Apoxi_ObexFtpServer_hpp
00014
00015 #include "ObexFtpDataServer.hpp"
00016
00027 class ObexFtpServer {
00028
00029     public:
00034         typedef ObexFtpDataServer::FolderListingEntryProps
00035             FolderListingEntryProperties;
00036
00037     public:
00042         ObexFtpServer();
00043
00054         ObexFtpServer(ExecutionContext* ctx_ptr);
00055
00057         virtual ~ObexFtpServer();
00058
00066         virtual void Init(ExecutionContext* ctx_ptr);
00067
00069
00074         inline ObexResult Open();
00075
00087         inline ObexResult Open(const String& obex_addr_url,
00088             UINT8 open_flags = 0);
00089
00095         virtual void OnBind(const ObexAddrPtr& addr_ptr, ObexResult result) {};
00096
00101         inline ObexResult Close();
00102
00104         virtual void OnClose(ObexResult result) {};
00105
00107
00124         virtual void OnConnect(const ObexHeaderList& headers, UINT8 flags) = 0;
00125
00130         inline ObexResult AcceptConnectRequest();
00131
00141         inline ObexResult RejectConnectRequest(
00142             ObexObject::ResponseCode resp_code = ObexObject::RespForbidden);
00143
00145
00158         virtual void OnDisconnected(ObexResult result) = 0;
00159
00161
00174         virtual void OnGetFolderListing(const WString& current_folder) = 0;
00175
00180         inline ObexResult AcceptFolderListingRequest();
00181
00191         inline ObexResult RejectFolderListingRequest(
00192             ObexObject::ResponseCode resp_code = ObexObject::RespForbidden);
00193
00208         virtual void OnProvideFolderListingEntries(
00209             const WString& current_folder) = 0;
00210
00236         inline ObexResult ProvideFolderListingEntry(
00237             BOOLEAN isFolder, const String& name,
00238             const FolderListingEntryProperties& properties);
00239
00252         inline ObexResult ProvideFolderListingEntriesFinished();
00253
00255
00273         virtual void OnSetCurrentFolder(const WString& current_folder,
00274             const WString& new_current_folder, BOOLEAN create) = 0;
00275
00280         inline ObexResult AcceptSetCurrentFolderRequest();
00281
00291         inline ObexResult RejectSetCurrentFolderRequest(
00292             ObexObject::ResponseCode resp_code = ObexObject::RespForbidden);
00293
00295
00309         virtual void OnFilePull(const WString& current_folder,
00310             const WString& filename) = 0;
00311
00319         inline ObexResult AcceptFilePullRequest(DataSourcePtr data_src_ptr);
00320
00330         inline ObexResult RejectFilePullRequest(
00331             ObexObject::ResponseCode resp_code = ObexObject::RespForbidden);
00332
00342         virtual void OnFilePullRequestCompleted(ObexResult result) = 0;
00343
00345
00362         virtual void OnFilePush(const WString& current_folder,
00363             const WString& filename, UINT32 size) = 0;
00364
00376         inline ObexResult AcceptFilePushRequest(DataSinkPtr data_sink_ptr,
00377             UINT32 max_size = 0xFFFFFFFFul);
00378
00388         inline ObexResult RejectFilePushRequest(
00389             ObexObject::ResponseCode resp_code = ObexObject::RespForbidden);
00390
00400         virtual void OnFilePushRequestCompleted(ObexResult result) = 0;
00401
00403
00418         virtual void OnDeleteObject(const WString& current_folder,
00419             const WString& object) = 0;
00420
00425         inline ObexResult AcceptDeleteObjectRequest();
00426
00436         inline ObexResult RejectDeleteObjectRequest(
00437             ObexObject::ResponseCode resp_code = ObexObject::RespForbidden);
00438
00440
00448         inline const WString& GetCurrentFolder() const;
00449
00450     private:
00451         ObexFtpDataServer m_server;
00452 };
00453
00454 /*  ----------------------------------------------------------------------
00455     Open
00456     ---------------------------------------------------------------------- */
00457 ObexResult ObexFtpServer::Open()
00458 {
00459     return Open("*://{target=H'F9EC7BC4-953C-11D2-984E-525400DC9E09'}",
00460         ObexServerDispatcher::SdbAutoRegister);
00461 }   // Open
00462
00463 /*  ----------------------------------------------------------------------
00464     Open
00465     ---------------------------------------------------------------------- */
00466 ObexResult ObexFtpServer::Open(const String& obex_addr_url, UINT8 open_flags)
00467 {
00468     return m_server.Open(obex_addr_url, open_flags);
00469 }   // Open
00470
00471 /*  ----------------------------------------------------------------------
00472     Close
00473     ---------------------------------------------------------------------- */
00474 ObexResult ObexFtpServer::Close()
00475 {
00476     return m_server.Close();
00477 }   // Close
00478
00479 /*  ----------------------------------------------------------------------
00480     AcceptConnection
00481     ---------------------------------------------------------------------- */
00482 ObexResult ObexFtpServer::AcceptConnectRequest()
00483 {
00484     return m_server.HandleConnectionRequest(ObexObject::RespOk);
00485 }   // AcceptConnection
00486
00487 /*  ----------------------------------------------------------------------
00488     RejectConnection
00489     ---------------------------------------------------------------------- */
00490 ObexResult ObexFtpServer::RejectConnectRequest(
00491     ObexObject::ResponseCode resp_code)
00492 {
00493     // To reject a connection an error response code must be passed!
00494     ASSERT_DEBUG(resp_code != ObexObject::RespOk);
00495
00496     return m_server.HandleConnectionRequest(resp_code);
00497 }   // RejectConnection
00498
00499 /*  ----------------------------------------------------------------------
00500     AcceptFolderListingRequest
00501     ---------------------------------------------------------------------- */
00502 ObexResult ObexFtpServer::AcceptFolderListingRequest()
00503 {
00504     return m_server.HandleFolderListingRequest(ObexObject::RespOk);
00505 }   // AcceptConnection
00506
00507 /*  ----------------------------------------------------------------------
00508     RejectFolderListingRequest
00509     ---------------------------------------------------------------------- */
00510 ObexResult ObexFtpServer::RejectFolderListingRequest(
00511     ObexObject::ResponseCode resp_code)
00512 {
00513     // To reject a folder listing request an error response code must be passed!
00514     ASSERT_DEBUG(resp_code != ObexObject::RespOk);
00515
00516     return m_server.HandleFolderListingRequest(resp_code);
00517 }   // RejectConnection
00518
00519 /*  ----------------------------------------------------------------------
00520     ProvideFolderListingEntry
00521     ---------------------------------------------------------------------- */
00522 ObexResult ObexFtpServer::ProvideFolderListingEntry(
00523     BOOLEAN isFolder, const String& name,
00524     const FolderListingEntryProperties& properties)
00525 {
00526     return m_server.HandleProvideFolderListingEntry(isFolder, name, properties);
00527 }   // ProvideFolderListingEntry
00528
00529 /*  ----------------------------------------------------------------------
00530     ProvideFolderListingEntriesFinished
00531     ---------------------------------------------------------------------- */
00532 ObexResult ObexFtpServer::ProvideFolderListingEntriesFinished()
00533 {
00534     return m_server.HandleProvideFolderListingEntriesFinished();
00535 }   // ProvideFolderListingEntriesFinished
00536
00537 /*  ----------------------------------------------------------------------
00538     AcceptSetCurrentFolderRequest
00539     ---------------------------------------------------------------------- */
00540 ObexResult ObexFtpServer::AcceptSetCurrentFolderRequest()
00541 {
00542     return m_server.HandleSetCurrentFolderRequest(ObexObject::RespOk);
00543 }   // AcceptSetCurrentFolderRequest
00544
00545 /*  ----------------------------------------------------------------------
00546     RejectSetCurrentFolderRequest
00547     ---------------------------------------------------------------------- */
00548 ObexResult ObexFtpServer::RejectSetCurrentFolderRequest(
00549     ObexObject::ResponseCode resp_code)
00550 {
00551     // To reject a current folder set request an error response code must be
00552     // passed!
00553     ASSERT_DEBUG(resp_code != ObexObject::RespOk);
00554
00555     return m_server.HandleSetCurrentFolderRequest(resp_code);
00556 }   // RejectSetCurrentFolderRequest
00557
00558 /*  ----------------------------------------------------------------------
00559     AcceptDeleteObjectRequest
00560     ---------------------------------------------------------------------- */
00561 ObexResult ObexFtpServer::AcceptDeleteObjectRequest()
00562 {
00563     return m_server.HandleDeleteObjectRequest(ObexObject::RespOk);
00564 }   // AcceptDeleteObjectRequest
00565
00566 /*  ----------------------------------------------------------------------
00567     RejectDeleteObjectRequest
00568     ---------------------------------------------------------------------- */
00569 ObexResult ObexFtpServer::RejectDeleteObjectRequest(
00570     ObexObject::ResponseCode resp_code)
00571 {
00572     // To reject a delete object request an error response code must be passed!
00573     ASSERT_DEBUG(resp_code != ObexObject::RespOk);
00574
00575     return m_server.HandleDeleteObjectRequest(resp_code);
00576 }   // RejectDeleteObjectRequest
00577
00578 /*  ----------------------------------------------------------------------
00579     AcceptFilePushRequest
00580     ---------------------------------------------------------------------- */
00581 ObexResult ObexFtpServer::AcceptFilePushRequest(DataSinkPtr data_sink_ptr,
00582     UINT32 max_size)
00583 {
00584     return m_server.HandleFilePushRequest(ObexObject::RespOk, data_sink_ptr,
00585         max_size);
00586 }   // AcceptFilePushRequest
00587
00588 /*  ----------------------------------------------------------------------
00589     RejectFilePushRequest
00590     ---------------------------------------------------------------------- */
00591 ObexResult ObexFtpServer::RejectFilePushRequest(
00592     ObexObject::ResponseCode resp_code)
00593 {
00594     // To reject a file push request an error response code must be passed!
00595     ASSERT_DEBUG(resp_code != ObexObject::RespOk);
00596
00597     return m_server.HandleFilePushRequest(resp_code, DataSinkPtr(0));
00598 }   // RejectFilePushRequest
00599
00600 /*  ----------------------------------------------------------------------
00601     AcceptFilePullRequest
00602     ---------------------------------------------------------------------- */
00603 ObexResult ObexFtpServer::AcceptFilePullRequest(DataSourcePtr data_src_ptr)
00604 {
00605     return m_server.HandleFilePullRequest(ObexObject::RespOk, data_src_ptr);
00606 }   // AcceptFilePullRequest
00607
00608 /*  ----------------------------------------------------------------------
00609     RejectFilePullRequest
00610     ---------------------------------------------------------------------- */
00611 ObexResult ObexFtpServer::RejectFilePullRequest(
00612     ObexObject::ResponseCode resp_code)
00613 {
00614     // To reject a file pull request an error response code must be passed!
00615     ASSERT_DEBUG(resp_code != ObexObject::RespOk);
00616
00617     return m_server.HandleFilePullRequest(resp_code, DataSourcePtr(0));
00618 }   // RejectFilePullRequest
00619
00620 /*  ----------------------------------------------------------------------
00621     GetCurrentFolder
00622     ---------------------------------------------------------------------- */
00623 const WString& ObexFtpServer::GetCurrentFolder() const
00624 {
00625     return m_server.GetCurrentFolder();
00626 }   // GetCurrentFolder
00627
00629 #endif  // Apoxi_ObexFtpServer_hpp
00630
Generated on Tue Jan 24 14:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeader.cpp File Reference

Obex/ObexHeader.cpp File Reference

#include "PreComp.hpp"
#include "Kernel/MachType.hpp"
#include "Auxiliary/WString.hpp"
#include "Auxiliary/String.hpp"
#include "Auxiliary/ByteBuffer.hpp"
#include "ObexHeader.hpp"

Include dependency graph for ObexHeader.cpp:

Generated on Tue Jan 24 23:20:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeader.hpp File Reference

Obex/ObexHeader.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Obex/ObexResult.hpp>

Include dependency graph for ObexHeader.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexHeader
Represents an OBEX header. More...
union | ObexHeader::HeaderVariant
Header data variant.

Defines

#define | Apoxi_ObexHeader_hpp

Define Documentation

#define Apoxi_ObexHeader_hpp

Generated on Tue Jan 24 23:20:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeader.hpp Source File

Obex/ObexHeader.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexHeader_hpp)
00011 #define Apoxi_ObexHeader_hpp
00014
00015 #include <Auxiliary/Linkable.hpp>
00016 #include <Obex/ObexResult.hpp>
00017
00018 //  Forward declarations of classes
00019 class ByteBuffer;
00020
00036 class ObexHeader : public Linkable< ObexHeader > {
00037
00038     friend class ObexHeaderList;
00039     friend class ObexHeaderBuilder;
00040
00041     public:
00043         enum {
00044             MaxHeaderLength = 255
00045         };
00046
00048         enum HeaderType {
00049             UnicodeType = 0x00,
00050             ByteSeqType = 0x40,
00051             ByteType    = 0x80,
00052             LongType    = 0xC0
00053         };
00054
00057         enum HeaderId {
00058             Invalid         = 0x00,
00059             Count           = 0x00 | LongType,
00060             Name            = 0x01 | UnicodeType,
00061             Type            = 0x02 | ByteSeqType,
00062             Length          = 0x03 | LongType,
00063
00064             Description     = 0x05 | UnicodeType,
00065             Target          = 0x06 | ByteSeqType,
00066             Http            = 0x07 | ByteSeqType,
00067             Who             = 0x0A | ByteSeqType,
00068             ConnectionId    = 0x0B | LongType,
00069             AppParams       = 0x0C | ByteSeqType,
00070             AuthChallenge   = 0x0D | ByteSeqType,
00071             AuthResponse    = 0x0E | ByteSeqType,
00072             CreatorId       = 0x0F | LongType,
00073             WanUuid         = 0x10 | ByteSeqType,
00074             ObjectClass     = 0x11 | ByteSeqType,
00075             SessionParams   = 0x12 | ByteSeqType,
00076             SessionSeqNum   = 0x13 | ByteType
00077         };
00078
00079         enum {
00081             NoConnectionId  = 0xFFFFFFFF
00082         };
00083
00084         enum ByteOrder {
00085             HostByteOrder,
00086             ObexByteOrder
00087         };
00088
00090         inline  static  HeaderType  TypeOfId(INT id);
00091
00093         inline  BOOLEAN     IsValid() const;
00094
00096         inline  HeaderType  GetType() const;
00097
00099         inline  UINT8       GetId() const;
00100
00102         UINT16              GetSize() const;
00103
00109         const WString &     ToWString() const;
00110
00116         const ByteBuffer &  ToByteBuffer() const;
00117
00127         const String        ToString()  const;
00128
00138         const CHAR *        ToCStr() const;
00139
00145         UINT8               ToByte()    const;
00146
00152         UINT32              ToLong()    const;
00153
00172         ObexResult          PutValue(UINT8      buffer[],
00173                                      UINT16     size,
00174                                      ByteOrder  format = ObexByteOrder) const;
00175     private:
00180         union HeaderVariant {
00181             WString *       unicode_ptr;
00182             ByteBuffer *    byteseq_ptr;
00183             UINT8           byte_value;
00184             UINT32          long_value;
00185         };
00186
00187         static  void    Write(UINT8             buffer[],
00188                               ByteOrder         format,
00189                               const WString &   value);
00190
00191         static  void    Write(UINT8             buffer[],
00192                               ByteOrder         format,
00193                               UINT32            value);
00194
00199         ObexHeader(UINT8    id, const WString &     unicode_data);
00200
00205         ObexHeader(UINT8    id, const String &      string_data);
00206
00212         ObexHeader(UINT8    id, const UINT8 data[], UINT16  data_size);
00213
00218         ObexHeader(UINT8    id, UINT8           byte_data);
00219
00224         ObexHeader(UINT8    id, UINT32          long_data);
00225
00229         virtual ~ObexHeader();
00230
00232         ObexHeader(ObexHeader const &  from);
00233
00235         ObexHeader &    operator=(ObexHeader const &  from);
00236
00237         UINT8           m_hi;
00238         HeaderVariant   m_hv;
00239 };
00240
00241
00242 /*  ----------------------------------------------------------------------
00243     IsValid
00244     ---------------------------------------------------------------------- */
00245 BOOLEAN ObexHeader::IsValid()
00246 const
00247 {
00248     return ( m_hi != Invalid );
00249 }// IsValid
00250
00251 /*  ----------------------------------------------------------------------
00252     GetType
00253     ---------------------------------------------------------------------- */
00254 ObexHeader::HeaderType  ObexHeader::GetType()
00255 const
00256 {
00257     return  TypeOfId(m_hi);
00258 }// GetType
00259
00260 /*  ----------------------------------------------------------------------
00261     GetId
00262     ---------------------------------------------------------------------- */
00263 UINT8   ObexHeader::GetId()
00264 const
00265 {
00266     return m_hi;
00267 }// GetId
00268
00269 /*  ----------------------------------------------------------------------
00270     TypeOfId
00271     ---------------------------------------------------------------------- */
00272 ObexHeader::HeaderType  ObexHeader::TypeOfId(INT id)
00273 {
00274     return HeaderType( (id & 0xC0) );
00275 }// TypeOfId
00276
00278 #endif  // Apoxi_ObexHeader_hpp
00279
Generated on Tue Jan 24 14:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeaderBuilder.cpp File Reference

Obex/ObexHeaderBuilder.cpp File Reference

#include "PreComp.hpp"
#include "ObexHeaderBuilder.hpp"

Include dependency graph for ObexHeaderBuilder.cpp:

Generated on Tue Jan 24 23:20:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeaderBuilder.hpp File Reference

Obex/ObexHeaderBuilder.hpp File Reference

#include <Auxiliary/ByteBuffer.hpp>
#include <Obex/ObexHeader.hpp>

Include dependency graph for ObexHeaderBuilder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexHeaderBuilder
Helps to assemble an OBEX header from several chunks of data. More...

Defines

#define | Apoxi_ObexHeaderBuilder_hpp

Define Documentation

#define Apoxi_ObexHeaderBuilder_hpp

Generated on Tue Jan 24 23:20:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeaderBuilder.hpp Source File

Obex/ObexHeaderBuilder.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexHeaderBuilder_hpp)
00011 #define Apoxi_ObexHeaderBuilder_hpp
00014
00015 #include <Auxiliary/ByteBuffer.hpp>
00016
00017 #include <Obex/ObexHeader.hpp>
00018
00032 class ObexHeaderBuilder {
00033
00034     friend class ObexHeaderList;
00035
00036     public:
00041         ObexHeaderBuilder(ObexHeader::ByteOrder  format = ObexHeader::ObexByteOrder);
00042
00056         ObexResult          NewHeader(UINT8  id, UINT16  max_size = 0);
00057
00065         ObexResult          AppendData(const UINT8  data[], UINT16  length);
00066
00077         ObexResult          SetValue(UINT32     value);
00078
00084         BOOLEAN             IsComplete() const;
00085
00086     private:
00087         BOOLEAN                         m_swap_global;
00088         BOOLEAN                         m_swap_buffer;
00089         UINT8                           m_hi;
00090         UINT16                          m_header_size;
00091         UINT16                          m_append_offs;
00092         ByteBuffer                      m_buffer;
00093
00095         ObexHeaderBuilder(const ObexHeaderBuilder &);
00096
00098         ObexHeaderBuilder &     operator=(const ObexHeaderBuilder &);
00099
00100         ObexHeader *            NewUnicodeHeader();
00101         ObexHeader *            NewByteSeqHeader();
00102         ObexHeader *            NewByteValHeader();
00103         ObexHeader *            NewLongValHeader();
00104
00105         void                    Reset();
00106
00108         ObexHeader *            GetResult();
00109 };
00110
00112 #endif  // Apoxi_ObexHeaderBuilder_hpp
00113
Generated on Tue Jan 24 14:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeaderList.cpp File Reference

Obex/ObexHeaderList.cpp File Reference

#include "PreComp.hpp"
#include "Afs/Rfs/Pathname.hpp"
#include "ObexHeaderBuilder.hpp"
#include "ObexHeaderList.hpp"

Include dependency graph for ObexHeaderList.cpp:

Generated on Tue Jan 24 23:20:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeaderList.hpp File Reference

Obex/ObexHeaderList.hpp File Reference

#include <Auxiliary/LinkedList.hpp>
#include <Auxiliary/MimeTypeTable.hpp>
#include <Obex/ObexResult.hpp>
#include <Obex/ObexHeader.hpp>

Include dependency graph for ObexHeaderList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexHeaderList
Managing list of OBEX headers. More...
class | ObexHeaderList::ConstIterator

Defines

#define | Apoxi_ObexHeaderList_hpp

Define Documentation

#define Apoxi_ObexHeaderList_hpp

Generated on Tue Jan 24 23:20:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexHeaderList.hpp Source File

Obex/ObexHeaderList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexHeaderList_hpp)
00010 #define Apoxi_ObexHeaderList_hpp
00013
00014 #include <Auxiliary/LinkedList.hpp>
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016
00017 #include <Obex/ObexResult.hpp>
00018 #include <Obex/ObexHeader.hpp>
00019
00020 // Forward declarations of classes
00021 class ObexHeaderBuilder;
00022
00066 class ObexHeaderList : private LinkedList< ObexHeader > {
00067
00068     friend class ObexObjectData;
00069
00070     private:
00071         // This is only private (implementation) inheritance !
00072         typedef LinkedList<ObexHeader>  Base;
00073
00074     public:
00075         class ConstIterator {
00076
00077             friend  class  ObexHeaderList;
00078
00079             public:
00081                 inline  ConstIterator();
00082
00084                 inline  ConstIterator(const ConstIterator &  from);
00085
00087                 inline  ConstIterator & operator=(const ConstIterator &  from);
00088
00093                 inline  BOOLEAN     IsValid() const;
00094
00100                 void    Advance();
00101
00106                 inline  ConstIterator &     operator++();
00107
00110                 inline  const ObexHeader &  operator*() const;
00111
00114                 inline  const ObexHeader *  operator->() const;
00115
00116             private:
00117                 const ObexHeader *      m_ptr;
00118
00119                 inline  ConstIterator(const ObexHeader *  obex_hdr_ptr);
00120         };
00121
00123         ObexHeaderList();
00124
00130         ~ObexHeaderList();
00131
00153         ObexResult  AddHeader(INT   id, const WString & unicode_data);
00154
00166         ObexResult  AddHeader(INT   id, const String &  byteseq_data);
00167
00182         ObexResult  AddHeader(INT   id, const UINT8 data[], UINT16  data_size);
00183
00195         ObexResult  AddHeader(INT   id, UINT8   byte_data);
00196
00208         ObexResult  AddHeader(INT   id, UINT32  long_data);
00209
00216         ObexResult  AddHeader(ObexHeaderBuilder &   builder);
00218
00223         ObexResult  AddMimeType(MimeType    mime_type);
00224
00233         MimeType    ObtainMimeType() const;
00234
00239         inline  ConstIterator   Begin() const;
00240
00247         inline  BOOLEAN         Contains(ObexHeader::HeaderId   id,
00248                                          ConstIterator          from) const;
00249
00255         inline  BOOLEAN         Contains(ObexHeader::HeaderId   id) const;
00256
00263         ConstIterator           Find(ObexHeader::HeaderId   id,
00264                                      ConstIterator          from) const;
00265
00272         inline  ConstIterator   Find(ObexHeader::HeaderId   id) const;
00273
00275         using                   Base::IsEmpty;
00276
00277     private:
00279         ObexHeaderList(const ObexHeaderList &);
00280
00282         ObexHeaderList &        operator=(const ObexHeaderList &);
00283
00293         ObexResult              Append(ObexHeader *  obex_header_ptr);
00294
00296         void                    Release();
00297 };
00298
00299 /*  ----------------------------------------------------------------------
00300     Default constructor
00301     ---------------------------------------------------------------------- */
00302 ObexHeaderList::ConstIterator::ConstIterator() :
00303     m_ptr( 0 )
00304 {
00305 }// Constructor
00306
00307 /*  ----------------------------------------------------------------------
00308     Constructor
00309     ---------------------------------------------------------------------- */
00310 ObexHeaderList::ConstIterator::ConstIterator(const ObexHeader *  obex_hdr_ptr) :
00311     m_ptr( obex_hdr_ptr )
00312 {
00313 }// Constructor
00314
00315 /*  ----------------------------------------------------------------------
00316     Constructor
00317     ---------------------------------------------------------------------- */
00318 ObexHeaderList::ConstIterator::ConstIterator(const ConstIterator &  from) :
00319     m_ptr( from.m_ptr )
00320 {
00321 }// Constructor
00322
00323 /*  ----------------------------------------------------------------------
00324     operator=
00325     ---------------------------------------------------------------------- */
00326 ObexHeaderList::ConstIterator &
00327 ObexHeaderList::ConstIterator::operator=(const ConstIterator &  from)
00328 {
00329     m_ptr = from.m_ptr;
00330     return *this;
00331 }// operator=
00332
00333 /*  ----------------------------------------------------------------------
00334     IsValid
00335     ---------------------------------------------------------------------- */
00336 BOOLEAN     ObexHeaderList::ConstIterator::IsValid()
00337 const
00338 {
00339     return ( m_ptr != 0 );
00340 }// IsValid
00341
00342 /*  ----------------------------------------------------------------------
00343     operator++()
00344     ---------------------------------------------------------------------- */
00345 ObexHeaderList::ConstIterator &  ObexHeaderList::ConstIterator::operator++()
00346 {
00347     Advance();
00348     return *this;
00349 }// operator++()
00350
00351 /*  ----------------------------------------------------------------------
00352     operator*
00353     ---------------------------------------------------------------------- */
00354 const ObexHeader &  ObexHeaderList::ConstIterator::operator*()
00355 const
00356 {
00357     ASSERT_DEBUG( IsValid() );
00358     return *m_ptr;
00359 }// operator*
00360
00361 /*  ----------------------------------------------------------------------
00362     operator->
00363     ---------------------------------------------------------------------- */
00364 const ObexHeader *  ObexHeaderList::ConstIterator::operator->()
00365 const
00366 {
00367     ASSERT_DEBUG( IsValid() );
00368     return m_ptr;
00369 }// operator->
00370
00371 /*  ----------------------------------------------------------------------
00372     Begin
00373     ---------------------------------------------------------------------- */
00374 ObexHeaderList::ConstIterator   ObexHeaderList::Begin()
00375 const
00376 {
00377     return  ConstIterator( Base::GetFront() );
00378 }// Begin
00379
00380 /*  ----------------------------------------------------------------------
00381     Contains
00382     ---------------------------------------------------------------------- */
00383 BOOLEAN  ObexHeaderList::Contains(ObexHeader::HeaderId  id,
00384                                   ConstIterator         from)
00385 const
00386 {
00387     return Find( id, from ).IsValid();
00388 }// Contains
00389
00390 /*  ----------------------------------------------------------------------
00391     Contains
00392     ---------------------------------------------------------------------- */
00393 BOOLEAN  ObexHeaderList::Contains(ObexHeader::HeaderId  id)
00394 const
00395 {
00396     return Find( id, Begin() ).IsValid();
00397 }// Contains
00398
00399 /*  ----------------------------------------------------------------------
00400     Find
00401     ---------------------------------------------------------------------- */
00402 ObexHeaderList::ConstIterator   ObexHeaderList::Find(ObexHeader::HeaderId   id)
00403 const
00404 {
00405     return Find( id, Begin() );
00406 }// Find
00407
00409 #endif  // Apoxi_ObexHeaderList_hpp
00410
Generated on Tue Jan 24 14:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexLayer.cpp File Reference

Obex/ObexLayer.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/MessageRouter.hpp>
#include <Auxiliary/ByteBuffer.hpp>
#include "ObexHeaderList.hpp"
#include "ObexHeader.hpp"
#include "ObexMessages.hpp"
#include "ObexServer.hpp"
#include "ObexOppServer.hpp"
#include "ObexBuffer.hpp"
#include "ObexMngr.hpp"
#include "ObexServerMngr.hpp"
#include "ObexServerVisitor.hpp"
#include "ObexLayer.hpp"

Include dependency graph for ObexLayer.cpp:

Generated on Tue Jan 24 23:20:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexLayer.hpp File Reference

Obex/ObexLayer.hpp File Reference

#include <Obex/ObexServerInfo.hpp>
#include <Obex/ObexProtocol.hpp>

Include dependency graph for ObexLayer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexLayer
Internal interface base class for direct access to the OBEX layer. More...

Defines

#define | Apoxi_ObexLayer_hpp

Define Documentation

#define Apoxi_ObexLayer_hpp

Generated on Tue Jan 24 23:20:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexLayer.hpp Source File

Obex/ObexLayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexLayer_hpp)
00011 #define Apoxi_ObexLayer_hpp
00012
00015 #include <Obex/ObexServerInfo.hpp>
00016 #include <Obex/ObexProtocol.hpp>
00017
00018 //  Forward declarations of classes
00019 class ObexObject;
00020 class ObexBuffer;
00021 class ObexMsg;
00022 class ObexHeaderList;
00023
00067 class ObexLayer : public ObexProtocol {
00068
00069     public:
00081         virtual void Connect(const ObexChannel &    client_chan,
00082                              ObexOperationId        oper_id,
00083                              const ObexObject &     conn_req) = 0;
00084
00094         virtual void Get(const ObexChannel &    client_chan,
00095                          ObexOperationId        oper_id,
00096                          const ObexObject &     get_req) = 0;
00097
00104         virtual void Put(const ObexChannel &    client_chan,
00105                          ObexOperationId        oper_id,
00106                          const ObexObject &     put_req) = 0;
00107
00118         virtual void Abort(const ObexChannel &  client_chan,
00119                            ObexOperationId      oper_id,
00120                            const ObexObject &   abort_req) = 0;
00121
00128         virtual void SetPath(const ObexChannel &    client_chan,
00129                              ObexOperationId        oper_id,
00130                              const ObexObject &     setp_req) = 0;
00131
00137         virtual void Disconnect(const ObexChannel &     client_chan,
00138                                 ObexOperationId         oper_id,
00139                                 const ObexObject &      disc_req) = 0;
00140
00149         virtual void ReturnResponse(const ObexChannel &     server_chan,
00150                                     ObexOperationId         oper_id,
00151                                     const ObexObject &      server_resp) = 0;
00152
00158         virtual void DataProcessed(const ObexChannel &   channel,
00159                                    ObexOperationId       oper_id,
00160                                    ObexBuffer &          obex_buffer) = 0;
00161     protected:
00162         ObexLayer();
00163
00176         void    OnResponse(const ObexChannel &  client_chan,
00177                            ObexOperationId      oper_id,
00178                            const ObexObject &   server_resp);
00179
00194         void OnConnect(const ObexChannel &  server_chan,
00195                        ObexOperationId      oper_id,
00196                        const ObexObject &   conn_req);
00197
00211         void OnDisconnect(const ObexChannel &  server_chan,
00212                           ObexOperationId      oper_id,
00213                           const ObexObject &   disc_req);
00214
00229         void OnSetPath(const ObexChannel &  server_chan,
00230                        ObexOperationId      oper_id,
00231                        const ObexObject &   setp_req);
00232
00258         ObexServerId    OnGet(const ObexChannel &   server_chan,
00259                               ObexOperationId       oper_id,
00260                               const ObexObject &    get_req);
00261
00287         ObexServerId    OnPut(const ObexChannel &   server_chan,
00288                               ObexOperationId       oper_id,
00289                               const ObexObject &    put_req);
00290
00313         void OnAbort(const ObexChannel &    server_chan,
00314                      ObexOperationId        oper_id,
00315                      const ObexObject &     abort_req,
00316                      ObexServerId           server_id = ObexServerInfo::NoServerId);
00317
00330         void OnDataProcessed(const ObexChannel &  channel,
00331                              ObexOperationId      oper_id,
00332                              ObexBuffer &         app_buffer);
00333
00334     private:
00335         ObexServerId    DispatchByTarget(BOOLEAN &              has_target,
00336                                          const ObexChannel &    server_chan,
00337                                          const ObexHeaderList & headers);
00338
00339         ObexServerId    DispatchRequest(const ObexChannel &     server_chan,
00340                                         const ObexObject &      request,
00341                                         BOOLEAN                 is_disc);
00342
00343         void            RejectRequest(const ObexChannel &       server_chan,
00344                                       const ObexOperationId &   oper_id,
00345                                       const ObexObject &        obex_req);
00346 };
00347
00349 #endif  // Apoxi_ObexLayer_hpp
00350
Generated on Tue Jan 24 14:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexMessages.cpp File Reference

Obex/ObexMessages.cpp File Reference

#include "PreComp.hpp"
#include "ObexMessages.hpp"

Include dependency graph for ObexMessages.cpp:

Generated on Tue Jan 24 23:20:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexMessages.hpp File Reference

Obex/ObexMessages.hpp File Reference

#include <Kernel/Message.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexChannel.hpp>
#include <Obex/ObexAddress.hpp>
#include <Obex/ObexAddrPtr.hpp>
#include <Obex/ObexOperationId.hpp>

Include dependency graph for ObexMessages.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexAddrMsg
class | ObexMsg
class | ObexTriggerMsg

Defines

#define | Obex_ObexMessages_hpp

Define Documentation

#define Obex_ObexMessages_hpp

Generated on Tue Jan 24 23:20:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexMessages.hpp Source File

Obex/ObexMessages.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Obex\MsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Obex_ObexMessages_hpp)
00014 #define Obex_ObexMessages_hpp
00015 #include <Kernel/Message.hpp>
00016 #include <Obex/ObexTypes.hpp>
00017 #include <Obex/ObexObject.hpp>
00018 #include <Obex/ObexChannel.hpp>
00019 #include <Obex/ObexAddress.hpp>
00020 #include <Obex/ObexAddrPtr.hpp>
00021 #include <Obex/ObexOperationId.hpp>
00022 /* ----------------------------------------------------------------------
00023     Classes
00024     ---------------------------------------------------------------------- */
00025 /*  ======================================================================
00026     Class ObexMsg
00027     ====================================================================== */
00029 class ObexMsg : public Message {
00030     public:
00031         ObexMsg(const ObexMsgType& msg_type, const ObexServerId& server_id, const ObexResult& result, const ObexOperationId& operation_id, const ObexChannel& channel, const ObexObject& object = ObexObject());
00032         virtual ~ObexMsg();
00033
00034         virtual const MsgMetaData& GetMetaData() const;
00035         const ObexMsgType& GetMsgType() const { return m_msg_type; }
00036         const ObexServerId& GetServerId() const { return m_server_id; }
00037         const ObexResult& GetResult() const { return m_result; }
00038         const ObexOperationId& GetOperationId() const { return m_operation_id; }
00039         const ObexChannel& GetChannel() const { return m_channel; }
00040         const ObexObject& GetObject() const { return m_object; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 11000
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         ObexMsgType m_msg_type;
00050         ObexServerId m_server_id;
00051         ObexResult m_result;
00052         ObexOperationId m_operation_id;
00053         ObexChannel m_channel;
00054         ObexObject m_object;
00055
00056     };
00057 /*  ======================================================================
00058     Class ObexTriggerMsg
00059     ====================================================================== */
00061 class ObexTriggerMsg : public Message {
00062     public:
00063         ObexTriggerMsg(const ObexProtocolId& protocol_id);
00064         virtual ~ObexTriggerMsg();
00065
00066         virtual const MsgMetaData& GetMetaData() const;
00067         const ObexProtocolId& GetProtocolId() const { return m_protocol_id; }
00068         virtual Message* Clone() const;
00069
00070         enum  {
00071             ID = 11001
00072             };
00073
00074     private:
00075         static const MsgMetaData m_meta_data;
00076         ObexProtocolId m_protocol_id;
00077
00078     };
00079 /*  ======================================================================
00080     Class ObexAddrMsg
00081     ====================================================================== */
00083 class ObexAddrMsg : public Message {
00084     public:
00085         ObexAddrMsg(const ObexResult& result, const ObexOperationId& operation_id, const ObexAddrPtr& addr_ptr = ObexAddrPtr());
00086         virtual ~ObexAddrMsg();
00087
00088         virtual const MsgMetaData& GetMetaData() const;
00089         const ObexResult& GetResult() const { return m_result; }
00090         const ObexOperationId& GetOperationId() const { return m_operation_id; }
00091         const ObexAddrPtr& GetAddrPtr() const { return m_addr_ptr; }
00092         virtual Message* Clone() const;
00093
00094         enum  {
00095             ID = 11002
00096             };
00097
00098     private:
00099         static const MsgMetaData m_meta_data;
00100         ObexResult m_result;
00101         ObexOperationId m_operation_id;
00102         ObexAddrPtr m_addr_ptr;
00103
00104     };
00105 #endif // Obex_ObexMessages_hpp
00106
00107
Generated on Tue Jan 24 14:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexMngr.cpp File Reference

Obex/ObexMngr.cpp File Reference

#include "PreComp.hpp"
#include "ObexTransport.hpp"
#include "ObexTransportMsg.hpp"
#include "ObexAppMsg.hpp"
#include "ObexServerMngr.hpp"
#include "ObexMngr.hpp"

Include dependency graph for ObexMngr.cpp:

Generated on Tue Jan 24 23:20:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexMngr.hpp File Reference

Obex/ObexMngr.hpp File Reference

#include <Obex/ObexResult.hpp>
#include <Obex/ObexOperationId.hpp>
#include <Obex/ObexTransportSet.hpp>

Include dependency graph for ObexMngr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexMngr
OBEX Manager. Singleton. Facade to global APOXI OBEX functionality. More...
class | ObexMngr::SelectCommand
Internal class representing a transport selection request.
class | ObexMngr::TransportMngr
Internal registry for Transport Adapters.
class | ObexMngr::TransportVisitor
Internal visitor interface for visiting transports.

Defines

#define | Apoxi_ObexMngr_hpp

Define Documentation

#define Apoxi_ObexMngr_hpp

Generated on Tue Jan 24 23:20:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexMngr.hpp Source File

Obex/ObexMngr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexMngr_hpp)
00010 #define Apoxi_ObexMngr_hpp
00011
00195
00196
00197 #include <Obex/ObexResult.hpp>
00198 #include <Obex/ObexOperationId.hpp>
00199 #include <Obex/ObexTransportSet.hpp>
00200
00201 // Forward declaration of of classes.
00202 class ObexChannel;
00203 class ObexProtocol;
00204 class ObexServerMngr;
00205
00244 class ObexMngr {
00245
00246     class   TransportManager;
00247
00249     friend  class ObexAbstractTransport;
00250     friend  class TransportManager;
00251     friend  class ObexServerInfo;
00252     friend  class ObexServer;
00253     friend  class ObexOppServer;
00254     friend  class ObexLayer;
00255     friend  class ObexOppServerTest;
00256
00257     public:
00258         static const CHAR *     c_any_url;
00259
00261         static ObexMngr &   GetInstance();
00262
00278         ObexOperationId         StartSelection(ObexTransportSet sel_from);
00279
00286         void                    AbortSelection(ObexOperationId  oper_id);
00287
00297         ObexAbstractTransport & GetTransport(const ObexChannel &  channel) const;
00298
00308         ObexAbstractTransport & GetTransport(ObexTransportId    transport_id) const;
00309
00320         ObexProtocol &          GetProtocol(const ObexChannel &  channel) const;
00321
00329         void                        RegisterObexApp(Application &   obex_app);
00330
00334         inline  ObexTransportSet    EnumTransports(const String &   filter_url = c_any_url) const;
00335
00348         ObexResult              SelectTransport(ObexAbstractTransport *  selected);
00349
00350     private:
00351         class TransportVisitor;
00352         class TransportFilter;
00353         class TransportFinder;
00354         class TransportLister;
00355
00360         class TransportMngr {
00361
00362             public:
00364                 TransportMngr();
00365
00367                 void                        Init();
00368
00374                 ObexTransportId             Register(ObexAbstractTransport &  t);
00375
00380                 ObexAbstractTransport *     Get(ObexTransportId  id) const;
00381
00386                 ObexAbstractTransport *     Get(const String &  scheme_url) const;
00387
00391                 ObexTransportSet            Enum(const String &  filter_url) const;
00392
00393             private:
00394                 ObexAbstractTransport *     m_xport_arr[APOXI_OBEX_MAX_NO_TRANSPORTS];
00395                 ObexTransportId             m_first_id_available;
00396
00398                 TransportMngr(const TransportMngr &);
00399
00401                 TransportMngr &     operator=(const TransportMngr &);
00402
00403                 void                ForEach(TransportVisitor &  v)  const;
00404         };
00405
00410         class TransportVisitor : public NonCloneable {
00411
00412             friend class  TransportMngr;
00413
00414             protected:
00416                 TransportVisitor();
00417
00418             private:
00419                 /*  @brief  Method called for each node being visited.
00420
00421                     @param  t   Reference to transport currently visited.
00422                     @return \c 'TRUE' to stop visiting additional nodes,
00423                             \c 'FALSE' tp continue. */
00424                 virtual BOOLEAN     Visit(ObexAbstractTransport &  t) = 0;
00425         };
00426
00428         class SelectCommand {
00429             public:
00431                 SelectCommand() {}
00432
00434                 SelectCommand(ObexTransportSet  ts,
00435                               ObexOperationId   id) :
00436                     m_from_ts(ts),
00437                     m_oper_id(id)
00438                 {
00439                 }
00441                 inline  const ObexOperationId &     GetOperationId() const;
00442
00444                 inline  BOOLEAN                     IsPending() const;
00445
00447                 void    Execute(Application *       obex_app_ptr);
00448
00450                 void    Complete(ObexTransportId    transport_id);
00451
00452             private:
00453                 ObexTransportSet    m_from_ts;
00454                 ObexOperationId     m_oper_id;
00455         };
00456
00457         static ObexMngr     s_obex_mngr;
00458
00459         TransportMngr       m_xport_mngr;
00460         SelectCommand       m_select_queue[APOXI_OBEX_MAX_NO_SELECTIONS];
00461         Application *       m_obex_app_ptr;
00462         UINT8               m_head_queue_indx;
00463         UINT8               m_tail_queue_indx;
00464         BOOLEAN             m_select_abort;
00465
00467         ObexMngr(const ObexMngr &);
00468
00470         ObexMngr &          operator=(const ObexMngr &);
00471
00473         ObexMngr();
00474
00476         void                Init();
00477
00482         inline  ObexTransportId     RegisterTransport(ObexAbstractTransport &  t);
00483
00484         ObexServerMngr &            GetServerMngr();
00485 };
00486
00487 /*  ----------------------------------------------------------------------
00488     SelectCommand::GetOperationId
00489     ---------------------------------------------------------------------- */
00490 const ObexOperationId &     ObexMngr::SelectCommand::GetOperationId()
00491 const
00492 {
00493     return  m_oper_id;
00494 }// GetOperationId
00495
00496 /*  ----------------------------------------------------------------------
00497     SelectCommand::IsPending
00498     ---------------------------------------------------------------------- */
00499 BOOLEAN     ObexMngr::SelectCommand::IsPending()
00500 const
00501 {
00502     return  m_oper_id.IsValid();
00503 }// IsPending
00504
00505 /*  ----------------------------------------------------------------------
00506     EnumTransports
00507     ---------------------------------------------------------------------- */
00508 ObexTransportSet    ObexMngr::EnumTransports(const String &     filter_url)
00509 const
00510 {
00511     return  m_xport_mngr.Enum(filter_url);
00512 }// EnumTransports
00513
00514 /*  ----------------------------------------------------------------------
00515     RegisterTransport
00516     ---------------------------------------------------------------------- */
00517 ObexTransportId     ObexMngr::RegisterTransport(ObexAbstractTransport &  t)
00518 {
00519     return  m_xport_mngr.Register(t);
00520 }// RegisterTransport
00521
00523
00524 #endif  // Apoxi_ObexMngr_hpp
00525
Generated on Tue Jan 24 14:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexObject.cpp File Reference

Obex/ObexObject.cpp File Reference

#include "PreComp.hpp"
#include "ObexObjectData.hpp"
#include "ObexBuffer.hpp"
#include "ObexObject.hpp"

Include dependency graph for ObexObject.cpp:

Generated on Tue Jan 24 23:20:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexObject.hpp File Reference

Obex/ObexObject.hpp File Reference

#include <Obex/ObexHeaderList.hpp>

Include dependency graph for ObexObject.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexObject
Handle class which provides access to OBEX protocol data. More...

Defines

#define | Apoxi_ObexObject_hpp

Define Documentation

#define Apoxi_ObexObject_hpp

Generated on Tue Jan 24 23:20:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexObject.hpp Source File

Obex/ObexObject.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexObject_hpp)
00010 #define Apoxi_ObexObject_hpp
00013
00014 #include <Obex/ObexHeaderList.hpp>
00015
00016 //  Forward declaration of classes
00017 class ObexObjectData;
00018 class ObexBuffer;
00019
00033 class ObexObject {
00034     public:
00036         enum ResponseCode {
00037             Request                         = 0,
00038
00040             RespOk                          = 0x20,
00041
00042             // 3xx codes
00043             RespMultipleChoices             = 0x30,
00044             RespMovedPermanently            = 0x31,
00045             RespMovedTemporarily            = 0x32,
00046             RespSeeOther                    = 0x33,
00047             RespNotModified                 = 0x34,
00048             RespUseProxy                    = 0x35,
00049
00050             // 4xx codes
00051             RespBadRequest                  = 0x40,
00052             RespUnauthorized                = 0x41,
00053             RespPaymentRequired             = 0x42,
00054             RespForbidden                   = 0x43,
00055             RespNotFound                    = 0x44,
00056             RespMethodNotAllowed            = 0x45,
00057             RespNotAcceptable               = 0x46,
00058             RespProxyAuthenticationRequired = 0x47,
00059             RespRequestTimeOut              = 0x48,
00060             RespConflict                    = 0x49,
00061             RespGone                        = 0x4A,
00062             RespLengthRequired              = 0x4B,
00063             RespPreconditionFailed          = 0x4C,
00064             RespRequestedEntityTooLarge     = 0x4D,
00065             RespRequestUrlTooLarge          = 0x4E,
00066             RespRequestUnsupportedMediaType = 0x4F,
00067
00068             // 5xx codes
00069             RespInternalServerError         = 0x50,
00070             RespNotImplemented              = 0x51,
00071             RespBadGateWay                  = 0x52,
00072             RespServiceUnavailable          = 0x53,
00073             RespGatewayTimeOut              = 0x54,
00074             RespHttpVersionNotSupported     = 0x55,
00075
00076             // 6xx codes
00077             RespDatabaseFull                = 0x60,
00078             RespDatabaseLocked              = 0x61
00079         };
00080
00082         enum ConnectFlags {
00083             ConnMultipleIrlmpLsapSel = 0x01
00084         };
00085
00087         enum SetPathFlags {
00088             SetpBackup      = 0x01,
00089             SetpDontCreate  = 0x02
00090         };
00091
00098         ObexObject();
00099
00107         ObexObject(ObexObject const &  from);
00108
00115         ObexObject &  operator=(ObexObject const &  rhs);
00116
00121         ~ObexObject();
00122
00131         void                Release();
00132
00149         ObexResult          Init(ResponseCode   response_code = Request);
00150
00164         inline  ObexResult  Init(ObexBuffer &   source_buffer);
00165
00180         ObexResult          Init(ResponseCode   response_code,
00181                                  ObexBuffer &   source_buffer);
00182
00184         inline  BOOLEAN     IsValid() const;
00185
00192         BOOLEAN             IsWritable() const;
00193
00195         inline  BOOLEAN     IsSuccessResponse() const;
00196
00198         ObexHeaderList &    GetHeaderList() const;
00199
00202         ResponseCode        GetResponseCode() const;
00203
00211         void                SetResponseCode(ResponseCode  r);
00212
00216         UINT8               GetRequestFlags() const;
00217
00225         void                SetRequestFlags(UINT8   req_flags);
00226
00229         BOOLEAN             IsEndOfData() const;
00230
00241         void                SetEndOfData(BOOLEAN    end_of_data = TRUE);
00242
00253         BOOLEAN             ObtainBuffer(ObexBuffer &   target_buffer);
00254
00259         void                CommitBuffer(ObexBuffer &   source_buffer);
00260
00269         UINT32              GetDataFractionSize() const;
00270
00271     private:
00272         ObexObjectData *    m_data_ptr;
00273
00275         void                Attach();
00276
00278         void                Detach();
00279 };
00280
00281 /*  ----------------------------------------------------------------------
00282     IsValid
00283     ---------------------------------------------------------------------- */
00284 BOOLEAN     ObexObject::IsValid() const
00285 {
00286     return ( m_data_ptr != 0 );
00287 }// IsValid
00288
00289 /*  ----------------------------------------------------------------------
00290     IsSuccessResponse
00291     ---------------------------------------------------------------------- */
00292 BOOLEAN     ObexObject::IsSuccessResponse() const
00293 {
00294     return ( GetResponseCode() == RespOk );
00295 }// IsSuccessResponse
00296
00297 /*  ----------------------------------------------------------------------
00298     Init
00299     ---------------------------------------------------------------------- */
00300 ObexResult  ObexObject::Init(ObexBuffer &   source_buffer)
00301 {
00302     return  Init(Request, source_buffer);
00303 }// Init                                                #
00304
00306 #endif  // Apoxi_ObexObject_hpp
00307
Generated on Tue Jan 24 14:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexObjectData.hpp File Reference

Obex/ObexObjectData.hpp File Reference

#include <Kernel/Os/Semaphore.hpp>
#include <Auxiliary/ObjectReferrer.hpp>
#include <Obex/ObexBuffer.hpp>
#include <Obex/ObexObject.hpp>

Include dependency graph for ObexObjectData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexObjectData
Internal body class for OBEX objects. More...
class | ObexObjectData::LockObtainer
Can Contain a SemObtainer or MutexObtainer.

Defines

#define | Apoxi_ObexObjectData_hpp

Define Documentation

#define Apoxi_ObexObjectData_hpp

Generated on Tue Jan 24 23:20:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexObjectData.hpp Source File

Obex/ObexObjectData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexObjectData_hpp)
00010 #define Apoxi_ObexObjectData_hpp
00013
00014 #include <Kernel/Os/Semaphore.hpp>
00015 #include <Auxiliary/ObjectReferrer.hpp>
00016
00017 #include <Obex/ObexBuffer.hpp>
00018 #include <Obex/ObexObject.hpp>
00019
00033 class ObexObjectData : public ReferableObject {
00034
00035     friend class ObexObject;
00036
00037     public:
00038         typedef ReferableObject Base;
00039
00040     private:
00042         class LockObtainer : public NonCloneable {
00043             public:
00044                 LockObtainer();
00045
00046             private:
00047                 // Place to hold a mutex - or semobtainer
00048                 static Semaphore        s_sem;
00049                 SemObtainer             m_lock_obtainer;
00050
00051                 static  Semaphore *     GetLock();
00052         };
00053
00054         BOOLEAN                     m_end_of_data;
00055         UINT8                       m_req_flags;
00056         ObexObject::ResponseCode    m_resp_code;
00057         ObexHeaderList              m_header_list;
00058         ObexBuffer                  m_buffer;
00059
00063         ObexObjectData(ObexObject::ResponseCode     response_code);
00064
00066         ObexObjectData(ObexObject::ResponseCode     response_code,
00067                        ObexBuffer &                 source_buffer);
00068
00069         static ObexObjectData * Init(ObexObjectData *           obj_data_ptr,
00070                                      ObexObject::ResponseCode   response_code);
00071
00072         static ObexObjectData * Init(ObexObjectData *           obj_data_ptr,
00073                                      ObexObject::ResponseCode   response_code,
00074                                      ObexBuffer &               source_buffer);
00076         virtual void    AddRef() const;
00078         virtual void    Release() const;
00079
00080         UINT32          GetDataFractionSize() const;
00081
00082         void            SetBuffer(ObexBuffer &  source_buffer);
00083         BOOLEAN         GetBuffer(ObexBuffer &  target_buffer);
00084
00085         void    SetResponseCode(ObexObject::ResponseCode    response_code);
00086         void    SetRequestFlags(UINT8                       request_flags);
00087         void    SetEndOfData(BOOLEAN                        end_of_data);
00088
00090         inline  BOOLEAN                     HasSingleReferrer() const;
00091
00092         inline  const ObexHeaderList &      GetHeaderList() const;
00093         inline  ObexHeaderList &            GetHeaderList();
00094
00095         inline  ObexObject::ResponseCode    GetResponseCode() const;
00096         inline  UINT8                       GetRequestFlags() const;
00097         inline  BOOLEAN                     IsEndOfData() const;
00098 };
00099
00100 /*  ----------------------------------------------------------------------
00101     HasMultipleReferrers
00102     ---------------------------------------------------------------------- */
00103 BOOLEAN     ObexObjectData::HasSingleReferrer()
00104 const
00105 {
00106     return ( RefCount() == 1 );
00107 }
00108
00109 /*  ----------------------------------------------------------------------
00110     GetHeaderList
00111     ---------------------------------------------------------------------- */
00112 ObexHeaderList const &  ObexObjectData::GetHeaderList()
00113 const
00114 {
00115     return  m_header_list;
00116 }
00117
00118
00119 /*  ----------------------------------------------------------------------
00120     GetHeaderList
00121     ---------------------------------------------------------------------- */
00122 ObexHeaderList &    ObexObjectData::GetHeaderList()
00123 {
00124     return  m_header_list;
00125 }
00126
00127 /*  ----------------------------------------------------------------------
00128     GetResponseCode
00129     ---------------------------------------------------------------------- */
00130 ObexObject::ResponseCode    ObexObjectData::GetResponseCode()
00131 const
00132 {
00133     return  m_resp_code;
00134 }
00135
00136 /*  ----------------------------------------------------------------------
00137     GetRequestFlags
00138     ---------------------------------------------------------------------- */
00139 UINT8       ObexObjectData::GetRequestFlags()
00140 const
00141 {
00142     return  m_req_flags;
00143 }
00144
00145 /*  ----------------------------------------------------------------------
00146     IsEndOfData
00147     ---------------------------------------------------------------------- */
00148 BOOLEAN     ObexObjectData::IsEndOfData()
00149 const
00150 {
00151     return  m_end_of_data;
00152 }
00153
00155 #endif  // Apoxi_ObexObjectData_hpp
00156
Generated on Tue Jan 24 14:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOperationId.cpp File Reference

Obex/ObexOperationId.cpp File Reference

#include "PreComp.hpp"
#include "ObexOperationId.hpp"

Include dependency graph for ObexOperationId.cpp:

Generated on Tue Jan 24 23:20:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOperationId.hpp File Reference

Obex/ObexOperationId.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ObexOperationId.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexOperationId
Internal association class for requests and responses related to an operation. More...

Defines

#define | Apoxi_ObexOperationId_hpp

Functions

BOOLEAN | operator!= (const ObexOperationId &lhs, const ObexOperationId &rhs)
BOOLEAN | operator== (const ObexOperationId &lhs, const ObexOperationId &rhs)

Define Documentation

#define Apoxi_ObexOperationId_hpp

Generated on Tue Jan 24 23:20:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOperationId.hpp Source File

Obex/ObexOperationId.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexOperationId_hpp)
00011 #define Apoxi_ObexOperationId_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00047 class ObexOperationId {
00048     public:
00050         inline  ObexOperationId();
00051
00053         inline  ObexOperationId(const ObexOperationId &  from);
00054
00056         inline  ObexOperationId &   operator=(const ObexOperationId &  from);
00057
00059         inline  friend  BOOLEAN     operator==(const ObexOperationId &  lhs,
00060                                                const ObexOperationId &  rhs);
00061
00063         inline  friend  BOOLEAN     operator!=(const ObexOperationId &  lhs,
00064                                                const ObexOperationId &  rhs);
00065
00067         inline  static  ObexOperationId     Create();
00068
00073         inline  BOOLEAN     IsValid() const;
00074
00080         inline  void        Invalidate();
00081
00087         inline  UINT16      GetSeqNr() const;
00088
00089     private:
00090         static  UINT16  s_seq_nr_last;
00091
00092         UINT16          m_seq_nr;
00093
00095         inline  ObexOperationId(UINT16  seq_nr);
00096 };
00097
00098
00099 /*  ----------------------------------------------------------------------
00100     ObexOperationId
00101     ---------------------------------------------------------------------- */
00102 ObexOperationId::ObexOperationId() :
00103     m_seq_nr(0)
00104 {
00105 }// ObexOperationId
00106
00107 /*  ----------------------------------------------------------------------
00108     ObexOperationId
00109     ---------------------------------------------------------------------- */
00110 ObexOperationId::ObexOperationId(const ObexOperationId &  from) :
00111     m_seq_nr( from.m_seq_nr )
00112 {
00113 }// ObexOperationId
00114
00115 /*  ----------------------------------------------------------------------
00116     ObexOperationId
00117     ---------------------------------------------------------------------- */
00118 ObexOperationId::ObexOperationId(UINT16  seq_nr) :
00119     m_seq_nr( seq_nr )
00120 {
00121 }// ObexOperationId
00122
00123 /*  ----------------------------------------------------------------------
00124     operator=
00125     ---------------------------------------------------------------------- */
00126 ObexOperationId &  ObexOperationId::operator=(const ObexOperationId &  from)
00127 {
00128     m_seq_nr = from.m_seq_nr;
00129     return *this;
00130 }// operator=
00131
00132 /*  ----------------------------------------------------------------------
00133     Create
00134     ---------------------------------------------------------------------- */
00135 ObexOperationId  ObexOperationId::Create()
00136 {
00137     return ObexOperationId( ++s_seq_nr_last );
00138 }// Create
00139
00140 /*  ----------------------------------------------------------------------
00141     operator==
00142     ---------------------------------------------------------------------- */
00143 BOOLEAN operator==(const ObexOperationId &  lhs,
00144                    const ObexOperationId &  rhs)
00145 {
00146     return (lhs.m_seq_nr == rhs.m_seq_nr);
00147 }// operator==
00148
00149 /*  ----------------------------------------------------------------------
00150     operator!=
00151     ---------------------------------------------------------------------- */
00152 BOOLEAN operator!=(const ObexOperationId &  lhs,
00153                    const ObexOperationId &  rhs)
00154 {
00155     return (lhs.m_seq_nr != rhs.m_seq_nr);
00156 }// operator!=
00157
00158 /*  ----------------------------------------------------------------------
00159     IsValid
00160     ---------------------------------------------------------------------- */
00161 BOOLEAN ObexOperationId::IsValid()
00162 const
00163 {
00164     return (m_seq_nr != 0);
00165 }// IsValid
00166
00167 /*  ----------------------------------------------------------------------
00168     Invalidate
00169     ---------------------------------------------------------------------- */
00170 void    ObexOperationId::Invalidate()
00171 {
00172     m_seq_nr = 0;
00173 }// Invalidate
00174
00175 /*  ----------------------------------------------------------------------
00176     GetSeqNr
00177     ---------------------------------------------------------------------- */
00178 UINT16  ObexOperationId::GetSeqNr()
00179 const
00180 {
00181     return  m_seq_nr;
00182 }// GetSeqNr
00183
00185 #endif  // Apoxi_ObexOperationId_hpp
00186
00187
Generated on Tue Jan 24 14:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppBinDataPushClient.cpp File Reference

Obex/ObexOppBinDataPushClient.cpp File Reference

#include "PreComp.hpp"
#include "Auxiliary/BinData.hpp"
#include "ObexBuffer.hpp"
#include "ObexOppBinDataPushClient.hpp"

Include dependency graph for ObexOppBinDataPushClient.cpp:

Generated on Tue Jan 24 23:20:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppBinDataPushClient.hpp File Reference

Obex/ObexOppBinDataPushClient.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Obex/ObexOppClient.hpp>

Include dependency graph for ObexOppBinDataPushClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexOppBinDataPushClient
Reads data from a BinData instance and pushes it towards a remote OPP server. More...

Defines

#define | Apoxi_ObexOppBinDataPushClient_hpp

Define Documentation

#define Apoxi_ObexOppBinDataPushClient_hpp

Generated on Tue Jan 24 23:20:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppBinDataPushClient.hpp Source File

Obex/ObexOppBinDataPushClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexOppBinDataPushClient_hpp)
00011 #define Apoxi_ObexOppBinDataPushClient_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016
00017 #include <Obex/ObexOppClient.hpp>
00018
00019 // Forward declarations of classes
00020 class ExecutionContext;
00021 class BinData;
00022
00055 class ObexOppBinDataPushClient : private ObexOppClient {
00056
00057     typedef ObexOppClient   Base;
00058
00059     public:
00069         enum {
00070             DefFragSize = 4096
00071         };
00076         ObexOppBinDataPushClient();
00077
00088         ObexOppBinDataPushClient(ExecutionContext *     ctx_ptr);
00089
00091         virtual ~ObexOppBinDataPushClient();
00092
00093         using   Base::Init;
00094         using   Base::GetProgressInBytes;
00095
00110         ObexResult      Abort(const WString &   desc,
00111                               BOOLEAN           force_sync = FALSE);
00112
00134         ObexResult      Push(const String &     obex_url,
00135                              BinData *          obj_src_ptr,
00136                              MimeType           obj_type,
00137                              const WString &    obj_name,
00138                              const WString &    obj_desc = L"");
00139
00140     protected:
00187         virtual void    OnPushComplete(ObexResult               result,
00188                                        ObexObject::ResponseCode resp_code,
00189                                        const WString &          push_desc);
00190
00191     private:
00192         BinData *       m_data_src_ptr;
00193         UINT32          m_data_offset;
00194
00195         virtual void    OnPushConfirmed();
00196         virtual void    OnDataProcessed(ObexBuffer &    app_data);
00197
00198         void            SendData(ObexBuffer &   buffer);
00199         void            CleanUp();
00200 };
00201
00203 #endif  // Apoxi_ObexOppBinDataPushClient_hpp
00204
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppClient.cpp File Reference

Obex/ObexOppClient.cpp File Reference

#include "PreComp.hpp"
#include "ObexMessages.hpp"
#include "ObexClientOppImpl.hpp"

Include dependency graph for ObexOppClient.cpp:

Generated on Tue Jan 24 23:20:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppClient.hpp File Reference

Obex/ObexOppClient.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexDispatcher.hpp>

Include dependency graph for ObexOppClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexOppClient
Base class for OPP clients within applications. More...
class | ObexOppClient::OppDispatcher
Internal dispatcher for OBEX messages related to OPP.

Defines

#define | Apoxi_ObexOppClient_hpp

Define Documentation

#define Apoxi_ObexOppClient_hpp

Generated on Tue Jan 24 23:20:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppClient.hpp Source File

Obex/ObexOppClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexOppClient_hpp)
00011 #define Apoxi_ObexOppClient_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016
00017 #include <Obex/ObexObject.hpp>
00018 #include <Obex/ObexDispatcher.hpp>
00019
00020 // Forward declarations of classes
00021 class ObexBuffer;
00022 class ObexTriggerMsg;
00023 class ObexClientOppImpl;
00024 class ObexOppClientOperation;
00025
00026
00040 class ObexOppClient {
00041
00042     class   OppDispatcher;
00043
00044     friend  class OppDispatcher;
00045     friend  class ObexClientOppImpl;
00046     friend  class ObexOppClientPush;
00047     friend  class ObexOppClientPull;
00048
00049     public:
00054         ObexOppClient();
00055
00061         ObexOppClient(Application *  app_ptr);
00062
00064         virtual ~ObexOppClient();
00065
00072         virtual void        Init(Application *  app_ptr);
00073
00085        ObexResult           Open(const String &     obex_url);
00086
00088        ObexResult           Close();
00089
00099         ObexResult  Push(const String &     obex_url,
00100                          const WString &    obj_name,
00101                          MimeType           obj_type,
00102                          const WString &    obj_desc,
00103                          UINT32             obj_size);
00104
00109         ObexResult  Pull(const String &     obex_url,
00110                          MimeType           obj_type = c_mime_unknown,
00111                          const WString &    obj_name = L"");
00112
00120         ObexResult  ProvideData(ObexBuffer &    app_data,
00121                                 BOOLEAN         end_data = FALSE);
00122
00128         ObexResult  DataProcessed(ObexBuffer &  app_data);
00129
00145         ObexResult      Abort(const WString &   desc,
00146                               BOOLEAN           force_sync = FALSE);
00147
00155         UINT32          GetProgressInBytes() const;
00156
00157     protected:
00162         virtual void    OnPushConfirmed();
00163
00170         virtual void    OnDataProcessed(ObexBuffer &    app_data);
00171
00181         virtual void    OnPushComplete(ObexResult                   result,
00182                                        ObexObject::ResponseCode     resp_code,
00183                                        const WString &              push_desc);
00184
00195         virtual void    OnPullConfirmed(const WString &     obj_name,
00196                                         const WString &     obj_desc,
00197                                         UINT32              obj_size);
00198
00210         virtual void    OnDataAvailable(ObexBuffer &    app_data,
00211                                         BOOLEAN         end_data);
00212
00223         virtual void    OnPullComplete(ObexResult                   result,
00224                                        ObexObject::ResponseCode     resp_code,
00225                                        const WString &              pull_desc);
00226
00227     private:
00233         class OppDispatcher : public ObexDispatcher {
00234
00235             public:
00236                 OppDispatcher(ObexOppClient *   opp_clnt_ptr);
00237
00238             protected:
00239                 virtual BOOLEAN         OnMessage(const Message &   msg);
00240
00241                 virtual void            RegisterMessages() const;
00242                 virtual void            UnregisterMessages() const;
00243
00244             private:
00245                 typedef ObexDispatcher  Base;
00246
00247                 ObexOppClient *         m_actual_client_ptr;
00248         };
00249
00250         BOOLEAN                         m_opp_hold_conn;
00251         BOOLEAN                         m_opp_initiated;
00252         OppDispatcher                   m_dispatcher;
00253         ObexObject                      m_request;
00254         String                          m_url;
00255         const ObexOppClientOperation *  m_opp_oper_ptr;
00256         mutable UINT32                  m_opp_progress;
00257
00258         BOOLEAN                 OnObexTriggerMsg(const ObexTriggerMsg &     msg);
00259
00260         void                    OnOppInitiated();
00261         void                    OnOppCompleted();
00262         void                    OnOppConnected();
00263         void                    OnOppCancelled(ObexResult   result);
00264
00265         ObexResult              CheckOperation(const String &   obex_url);
00266         ObexResult              StartOperation(const ObexOppClientOperation &   op);
00267
00268         inline  const String &  GetUrl() const
00269         {
00270              return m_url;
00271         }
00272
00273         inline  BOOLEAN         IsInValidContext() const
00274         {
00275             return  m_dispatcher.IsInValidContext();
00276         }
00277
00278         inline  BOOLEAN         IsOperationPending() const
00279         {
00280              return ( m_opp_oper_ptr != 0 );
00281         }
00282
00283         inline  BOOLEAN         HoldsConnection() const
00284         {
00285              return m_opp_hold_conn;
00286         }
00287
00288         void                    UpdateProgress() const;
00289 };
00290
00292 #endif  // Apoxi_ObexOppClient_hpp
00293
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppDataSinkPushServer.cpp File Reference

Obex/ObexOppDataSinkPushServer.cpp File Reference

#include "PreComp.hpp"
#include <Afs/Rfs/Pathname.hpp>
#include <Auxiliary/DataSink.hpp>
#include "ObexBuffer.hpp"
#include "ObexOppDataSinkPushServer.hpp"

Include dependency graph for ObexOppDataSinkPushServer.cpp:

Generated on Tue Jan 24 23:20:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppDataSinkPushServer.hpp File Reference

Obex/ObexOppDataSinkPushServer.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Obex/ObexOppServer.hpp>

Include dependency graph for ObexOppDataSinkPushServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexOppDataSinkPushServer
Receives data pushed in by a remote OPP client and saves it to a to a DataSink instance. More...
class | ObexOppDataSinkPushServer::OppImpl

Defines

#define | Apoxi_ObexOppDataSinkPushServer_hpp

Define Documentation

#define Apoxi_ObexOppDataSinkPushServer_hpp

Generated on Tue Jan 24 23:20:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppDataSinkPushServer.hpp Source File

Obex/ObexOppDataSinkPushServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexOppDataSinkPushServer_hpp)
00011 #define Apoxi_ObexOppDataSinkPushServer_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016
00017 #include <Obex/ObexOppServer.hpp>
00018
00019 // Forward declarations of classes
00020 class ExecutionContext;
00021 class DataSink;
00022
00058 class ObexOppDataSinkPushServer : private ObexOppServer {
00059
00060     private:
00061         typedef ObexOppServer   Base;
00062
00063     public:
00068         ObexOppDataSinkPushServer();
00069
00083         ObexOppDataSinkPushServer(MimeType              mime_type,
00084                                   ExecutionContext *    ctx_ptr);
00085
00087         virtual ~ObexOppDataSinkPushServer();
00088
00100             virtual void    Init(ExecutionContext *     ctx_ptr,
00101                                  MimeType               mime_type);
00102
00120         inline  ObexResult  BindToMimeType(MimeType     mime_type);
00121
00134         inline  ObexResult  UnbindMimeType(MimeType     mime_type);
00135
00140         inline  ObexResult  Open();
00141
00148         inline  ObexResult  Close();
00149
00161         inline  ObexResult  Accept(DataSink *   obj_sink_ptr,
00162                                    UINT32       max_obj_size = 0xFFFFFFFFul);
00163
00173         inline  ObexResult  Cancel(ObexObject::ResponseCode     resp_code,
00174                                    const WString &              resp_desc = L"");
00175
00180         inline  ObexResult  Confirm();
00181
00189         inline  UINT32      GetProgressInBytes() const;
00190
00191 //  protected:
00210         virtual void    OnPushIncoming(const WString &  obj_name,
00211                                        MimeType         obj_type,
00212                                        const WString &  obj_desc,
00213                                        UINT32           obj_size) = 0;
00214
00231         virtual void    OnDataComplete();
00232
00242         virtual void    OnPushComplete(ObexResult       result,
00243                                        const WString &  description) = 0;
00244
00245     private:
00246         class OppImpl : public ObexOppServer {
00247
00248             public:
00249                 OppImpl(ObexOppDataSinkPushServer &     frontend);
00250
00251                 ObexResult      Accept(DataSink *   obj_sink_ptr,
00252                                        UINT32       max_obj_size = 0xFFFFFFFFul);
00253
00254                 ObexResult      CloseOppServer();
00255
00256 //          protected:
00257                 virtual void    OnPush(const WString &  obj_name,
00258                                        const String &   obj_type,
00259                                        const WString &  obj_desc,
00260                                        UINT32           obj_size);
00261
00262                 virtual void    OnDataAvailable(ObexBuffer &    app_data,
00263                                                 BOOLEAN         end_data);
00264
00265                 virtual void    OnPushComplete(ObexResult       result,
00266                                                const WString &  description);
00267
00268             private:
00269                 ObexOppDataSinkPushServer &     m_frontend;
00270                 DataSink *                      m_sink_ptr;
00271                 UINT32                          m_sink_size;    // Max. object size
00272                 BOOLEAN                         m_is_accepted;
00273
00274                 void                            CleanUp();
00275         };
00276
00277         OppImpl                                 m_impl;
00278 };
00279
00280 /*  ----------------------------------------------------------------------
00281     BindToMimeType
00282     ---------------------------------------------------------------------- */
00283 ObexResult  ObexOppDataSinkPushServer::BindToMimeType(MimeType  mime_type)
00284 {
00285     return  m_impl.BindToMimeType(mime_type);
00286 }// BindToMimeType
00287
00288 /*  ----------------------------------------------------------------------
00289     UnbindMimeType
00290     ---------------------------------------------------------------------- */
00291 ObexResult  ObexOppDataSinkPushServer::UnbindMimeType(MimeType  mime_type)
00292 {
00293     return  m_impl.UnbindMimeType(mime_type);
00294 }// UnbindMimeType
00295
00296 /*  ----------------------------------------------------------------------
00297     Open
00298     ---------------------------------------------------------------------- */
00299 ObexResult  ObexOppDataSinkPushServer::Open()
00300 {
00301     return  m_impl.Open();
00302 }// Open
00303
00304 /*  ----------------------------------------------------------------------
00305     Close
00306     ---------------------------------------------------------------------- */
00307 ObexResult  ObexOppDataSinkPushServer::Close()
00308 {
00309     return  m_impl.CloseOppServer();
00310 }// Close
00311
00312 /*  ----------------------------------------------------------------------
00313     Accept
00314     ---------------------------------------------------------------------- */
00315 ObexResult  ObexOppDataSinkPushServer::Accept(DataSink *    obj_sink_ptr,
00316                                               UINT32        max_obj_size)
00317 {
00318     return  m_impl.Accept(obj_sink_ptr, max_obj_size);
00319 }// Accept
00320
00321 /*  ----------------------------------------------------------------------
00322     Cancel
00323     ---------------------------------------------------------------------- */
00324 ObexResult  ObexOppDataSinkPushServer::Cancel(ObexObject::ResponseCode  resp_code,
00325                                               const WString &           resp_desc)
00326 {
00327     return  m_impl.CancelOperation(resp_code, resp_desc);
00328 }// Cancel
00329
00330 /*  ----------------------------------------------------------------------
00331     Confirm
00332     ---------------------------------------------------------------------- */
00333 ObexResult  ObexOppDataSinkPushServer::Confirm()
00334 {
00335     // Buffer still owned by ObexOppServer instance !
00336     return  m_impl.DataProcessed();
00337 }// Confirm
00338
00339 /*  ----------------------------------------------------------------------
00340     GetProgressInBytes
00341     ---------------------------------------------------------------------- */
00342 UINT32      ObexOppDataSinkPushServer::GetProgressInBytes()
00343 const
00344 {
00345     return  m_impl.GetProgressInBytes();
00346 }// GetProgressInBytes
00347
00349 #endif  // Apoxi_ObexOppDataSinkPushServer_hpp
00350
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppLayer.cpp File Reference

Obex/ObexOppLayer.cpp File Reference

#include "PreComp.hpp"
#include "ObexOppLayer.hpp"

Include dependency graph for ObexOppLayer.cpp:

Generated on Tue Jan 24 23:20:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppLayer.hpp File Reference

Obex/ObexOppLayer.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_ObexOppLayer_hpp

Define Documentation

#define Apoxi_ObexOppLayer_hpp

Generated on Tue Jan 24 23:20:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppLayer.hpp Source File

Obex/ObexOppLayer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexOppLayer_hpp)
00011 #define Apoxi_ObexOppLayer_hpp
00012
00013 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00016
00017 #include <Obex/ObexProtocol.hpp>
00018
00019 //  Forward declarations of classes
00020 class ObexObject;
00021 class ObexBuffer;
00022
00024 class ObexOppLayer : public ObexProtocol {
00025
00026     public:
00033         virtual void Push(const ObexChannel &   client_chan,
00034                           ObexOperationId       oper_id,
00035                           const ObexObject &    push_req) = 0;
00036
00042         virtual void Pull(const ObexChannel &   client_chan,
00043                           ObexOperationId       oper_id,
00044                           const ObexObject &    pull_req) = 0;
00045
00050         virtual void Abort(const ObexChannel &  client_chan,
00051                            ObexOperationId      oper_id,
00052                            const ObexObject &   abort_req) = 0;
00053
00059         virtual void DataProcessed(const ObexChannel &  channel,
00060                                    ObexOperationId      oper_id,
00061                                    ObexBuffer &         obex_buffer) = 0;
00062     protected:
00063         ObexOppLayer(TypeId  prot_type);
00064
00073         void OnPush(const ObexChannel & server_chan,
00074                     ObexOperationId     oper_id,
00075                     const ObexObject &  push_req);
00076
00085         void OnPull(const ObexChannel & server_chan,
00086                     ObexOperationId     oper_id,
00087                     const ObexObject &  pull_req);
00088
00095         void OnAbort(const ObexChannel &  server_chan,
00096                      ObexOperationId      oper_id,
00097                      const ObexObject &   abort_req);
00098
00109         void OnResponse(const ObexChannel &     client_chan,
00110                         ObexOperationId         oper_id,
00111                         const ObexObject &      server_resp);
00112
00118         void OnDataProcessed(const ObexChannel &  server_chan,
00119                              ObexOperationId      oper_id,
00120                              ObexBuffer &         app_buffer);
00121 };
00122
00124 #endif  // DOXYGEN_SHOULD_SKIP_THIS
00125
00126 #endif  // Apoxi_ObexOppLayer_hpp
00127
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppServer.cpp File Reference

Obex/ObexOppServer.cpp File Reference

#include "PreComp.hpp"
#include "ObexMngr.hpp"
#include "ObexMessages.hpp"
#include "ObexServerMngr.hpp"
#include "ObexServerVisitor.hpp"
#include "ObexServerOppImpl.hpp"
#include "ObexOppServer.hpp"

Include dependency graph for ObexOppServer.cpp:

Generated on Tue Jan 24 23:20:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppServer.hpp File Reference

Obex/ObexOppServer.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>
#include <Auxiliary/DynamicBitVector.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexDispatcher.hpp>
#include <Obex/ObexServerInfo.hpp>

Include dependency graph for ObexOppServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexOppServer
Base class for OPP servers within applications. More...
class | ObexOppServer::OppDispatcher
Internal dispatcher for OBEX messages related to OPP.
class | ObexOppServer::ServerInfo
ServerInfo record used to register with the Server Manager.

Defines

#define | Apoxi_ObexOppServer_hpp

Define Documentation

#define Apoxi_ObexOppServer_hpp

Generated on Tue Jan 24 23:20:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexOppServer.hpp Source File

Obex/ObexOppServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexOppServer_hpp)
00011 #define Apoxi_ObexOppServer_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016 #include <Auxiliary/DynamicBitVector.hpp>
00017
00018 #include <Obex/ObexObject.hpp>
00019 #include <Obex/ObexDispatcher.hpp>
00020 #include <Obex/ObexServerInfo.hpp>
00021
00022 // Forward declarations of classes
00023 class ExecutionContext;
00024 class ObexBuffer;
00025 class ObexChannel;
00026 class ObexOperationId;
00027
00050 class ObexOppServer {
00051
00052     class  DupeChecker;
00053     class  InstanceFinder;
00054
00055     friend class ObexServerOppImpl;
00056     friend class DupeChecker;
00057
00058     public:
00063         ObexOppServer();
00064
00073         ObexOppServer(ExecutionContext *    ctx_ptr,
00074                       MimeType              mime_type);
00075
00084         virtual void    Init(ExecutionContext *     ctx_ptr,
00085                              MimeType               mime_type);
00086
00104         ObexResult      BindToMimeType(MimeType     mime_type);
00105
00118         ObexResult      UnbindMimeType(MimeType     mime_type);
00119
00121         ObexResult      Open();
00122
00124         ObexResult      Close();
00125
00127         ObexResult      AcceptPush();
00128
00136         ObexResult      AcceptPull(const WString &  obj_name,
00137                                    const WString &  obj_desc,
00138                                    UINT32           obj_size);
00139
00145         ObexResult      ProvideData(ObexBuffer &    app_data,
00146                                     BOOLEAN         end_data = FALSE);
00147
00155         ObexResult      DataProcessed(ObexBuffer &  app_data);
00156
00160         ObexResult      DataProcessed();
00161
00167         ObexResult      CancelOperation(ObexObject::ResponseCode    resp_code,
00168                                         const WString &             resp_desc = WString());
00169
00177         UINT32          GetProgressInBytes() const;
00178
00180         BOOLEAN         IsActiveOperation(const ObexOperationId oper_id) const;
00181
00183         BOOLEAN         IsBoundToChannel(const ObexChannel &    channel) const;
00184
00186         BOOLEAN         IsBoundToMimeType(MimeType  mime_type) const;
00187
00189         BOOLEAN         IsBoundToServerId(ObexServerId  id) const
00190         {
00191             return  ( m_server_info.GetServerId() == id );
00192         }
00193
00194     protected:
00205         virtual void    OnPush(const WString &  obj_name,
00206                                const String &   obj_type,
00207                                const WString &  obj_desc,
00208                                UINT32           obj_size);
00209
00217         virtual void    OnPull(const WString &  obj_name,
00218                                const String &   obj_type);
00219
00222         virtual void    OnAbort();
00223
00235         virtual void    OnDataAvailable(ObexBuffer &    app_data,
00236                                         BOOLEAN         end_data);
00237
00244         virtual void    OnDataProcessed(ObexBuffer &    buffer);
00245
00255         virtual void    OnPushComplete(ObexResult       result,
00256                                        const WString &  description);
00257
00267         virtual void    OnPullComplete(ObexResult       result,
00268                                        const WString &  description);
00269
00270     private:
00276         class OppDispatcher : public ObexDispatcher {
00277
00278             public:
00279                 OppDispatcher(ObexOppServer *   opp_srvr_ptr);
00280
00281                 inline  ObexOppServer *     GetServerPtr() const
00282                 {
00283                     return  m_server_ptr;
00284                 }
00285
00286             private:
00287                 typedef ObexDispatcher      Base;
00288
00289                 ObexOppServer *             m_server_ptr;
00290         };
00291
00293         class ServerInfo : public ObexServerInfo {
00294             public:
00295                 ServerInfo(ObexOppServer &  server);
00296
00297                 virtual BOOLEAN     Accept(ObexServerVisitor &  v);
00298
00299             private:
00300                 ObexOppServer &     m_server;
00301         };
00302
00303         OppDispatcher               m_dispatcher;
00304         ServerInfo                  m_server_info;
00305         mutable UINT32              m_opp_progress;
00306         DynamicBitVector            m_mime_type_set;
00307         BOOLEAN                     m_is_open;
00308
00309         static  ObexOppServer *     FindInstance(ObexServerId   server_id);
00310
00311         inline  BOOLEAN             IsAmbigous(const DynamicBitVector & mime_type_set)
00312         const
00313         {
00314             return  m_mime_type_set.Intersects(mime_type_set);
00315         }
00316
00317         BOOLEAN                     IsRequestForMe(const ObexMsg &      msg,
00318                                                    ObexDispatcher * &   dispatcher_ptr);
00319
00320         void                        InitClass(ExecutionContext *    ctx_ptr,
00321                                               MimeType              mime_type);
00322
00323         void                        UpdateProgress() const;
00324 };
00325
00327 #endif  // Apoxi_ObexOppServer_hpp
00328
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexProtocol.cpp File Reference

Obex/ObexProtocol.cpp File Reference

#include "PreComp.hpp"
#include "Kernel/MessageRouter.hpp"
#include "ObexMessages.hpp"
#include "ObexProtocol.hpp"

Include dependency graph for ObexProtocol.cpp:

Generated on Tue Jan 24 23:20:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexProtocol.hpp File Reference

Obex/ObexProtocol.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexResult.hpp>
#include <Obex/ObexAddrPtr.hpp>
#include <Obex/ObexOperationId.hpp>

Include dependency graph for ObexProtocol.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexProtocol
Internal interface base class for protocol layer abstractions. More...

Defines

#define | Apoxi_ObexProtocol_hpp

Define Documentation

#define Apoxi_ObexProtocol_hpp

Generated on Tue Jan 24 23:20:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexProtocol.hpp Source File

Obex/ObexProtocol.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexProtocol_hpp)
00011 #define Apoxi_ObexProtocol_hpp
00014
00015 #include <Auxiliary/NonCloneable.hpp>
00016
00017 #include <Obex/ObexTypes.hpp>
00018 #include <Obex/ObexResult.hpp>
00019 #include <Obex/ObexAddrPtr.hpp>
00020 #include <Obex/ObexOperationId.hpp>
00021
00022 // Forward declarations of classes.
00023 class ObexChannel;
00024
00048 class ObexProtocol : public NonCloneable {
00049
00050     public:
00051         typedef ObexProtocolId TypeId;
00052
00054         inline TypeId       GetTypeId() const;
00055
00073         virtual ObexResult  AcquireClientChannel(ObexChannel &        result,
00074                                                  const ObexAddrPtr &  addr_ptr,
00075                                                  BOOLEAN              reserve) = 0;
00076
00099         virtual ObexResult  AcquireServerChannel(ObexChannel &        result,
00100                                                  const ObexAddrPtr &  addr_ptr,
00101                                                  BOOLEAN              reserve) = 0;
00102
00107         virtual ObexResult  ReleaseChannel(ObexChannel &  channel) = 0;
00108
00120         virtual void OpenClientChannel(const ObexChannel &  client_chan,
00121                                        ObexOperationId      oper_id,
00122                                        const ObexAddrPtr &  addr_ptr) = 0;
00123
00135         virtual void BindServerChannel(const ObexChannel &  server_chan,
00136                                        ObexOperationId      oper_id,
00137                                        const ObexAddrPtr &  addr_ptr) = 0;
00138
00153         virtual void CloseChannel(const ObexChannel &  channel,
00154                                   ObexOperationId      oper_id) = 0;
00155
00156     protected:
00162         ObexProtocol(TypeId  type_id);
00163
00178         void    OnTransportError(const ObexChannel &    channel,
00179                                  ObexOperationId        oper_id,
00180                                  ObexResult             status);
00181
00192         void    OnComplete(const ObexChannel &  channel,
00193                            ObexOperationId      oper_id,
00194                            ObexResult           result);
00195     private:
00196         const TypeId  m_type_id;
00197 };
00198
00199
00200 /*  ----------------------------------------------------------------------
00201     GetTypeId
00202     ---------------------------------------------------------------------- */
00203 ObexProtocol::TypeId  ObexProtocol::GetTypeId()
00204 const
00205 {
00206     return m_type_id;
00207 }// GetTypeId
00208
00210 #endif  // Apoxi_ObexProtocol_hpp
00211
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexResult.hpp File Reference

Obex/ObexResult.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexResult
Indicates success or failure of OBEX API functions and operations. More...

Defines

#define | Apoxi_ObexResult_hpp

Define Documentation

#define Apoxi_ObexResult_hpp

Generated on Tue Jan 24 23:20:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexResult.hpp Source File

Obex/ObexResult.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexResult_hpp)
00011 #define Apoxi_ObexResult_hpp
00014
00015
00025 class ObexResult
00026 {
00027     public:
00028         enum ErrorCode {
00029             // Success
00030             Success                     =   0,
00031
00032             // Spontaneous events
00033             ObexError                   =   1,
00034             OperationAborted            =   2,
00035             TransportDisconnected       =   3,
00036
00037             // Errors related to an operation
00038             OperationAlreadyRunning     =   8,
00039             OperationAlreadyComplete    =   9,
00040             OperationNotSupported       =  10,
00041             OperationNotPermitted       =  11,
00042             InvalidHeadersInRequest     =  14,
00043
00044             // Errors caused by lack of resources
00045             ResourceNotAvailable        =  16,
00046             OutOfMemory                 =  17,
00047
00048             // Server-specific errors
00049             ServerAlreadyOpen           =  32,
00050             ServerAlreadyClosed         =  33,
00051             ServerAlreadyKnown          =  34,
00052
00053             // Client-specific errors
00054             ClientAlreadyOpen           =  64,
00055             ClientAlreadyClosed         =  65,
00056
00057             // Internal errors
00058             InvalidHeaderId             =  96,
00059             UnknownMimeType             =  97,
00060             ObjectNotWritable           =  98,
00061
00062             // OBEX Url parsing errors
00063             SyntaxErrorInUrl            = 128,
00064             UnknownParameterInUrl       = 129,
00065             InvalidParameterInUrl       = 130,
00066
00067             // API function errors
00068             InvalidExecutionContext     = 192,
00069
00070             // Unspecified error
00071             Unspecified                 = 255
00072         };
00073
00075         static inline   ObexResult  Ok();
00076
00081         inline          ObexResult(ErrorCode  e = Unspecified);
00082
00084         inline          ObexResult(const ObexResult &  from);
00085
00087         inline          ObexResult &    operator=(const ObexResult &  from);
00088
00090         inline          BOOLEAN         IsError() const;
00091
00093         inline          BOOLEAN         IsOk() const;
00094
00099         inline          operator        BOOLEAN() const;
00100
00102         inline          ErrorCode       GetErrorCode() const;
00103
00104     private:
00105         ErrorCode       m_code;
00106 };
00107
00108
00109 /*  ----------------------------------------------------------------------
00110     Ok
00111     ---------------------------------------------------------------------- */
00112 ObexResult  ObexResult::Ok()
00113 {
00114     return  ObexResult(Success);
00115 }// Ok
00116
00117 /*  ----------------------------------------------------------------------
00118     ObexResult
00119     ---------------------------------------------------------------------- */
00120 ObexResult::ObexResult(ErrorCode  e) :
00121     m_code( e )
00122 {
00123 }// ObexResult
00124
00125 /*  ----------------------------------------------------------------------
00126     ObexResult
00127     ---------------------------------------------------------------------- */
00128 ObexResult::ObexResult(const ObexResult &  from) :
00129     m_code( from.m_code )
00130 {
00131 }// ObexResult
00132
00133 /*  ----------------------------------------------------------------------
00134     operator=
00135     ---------------------------------------------------------------------- */
00136 ObexResult &    ObexResult::operator=(const ObexResult &  from)
00137 {
00138     // Self - assignment doesn't hurt here, so we don't check for it !
00139     m_code = from.m_code;
00140     return *this;
00141 }// operator=
00142
00143 /*  ----------------------------------------------------------------------
00144     IsError
00145     ---------------------------------------------------------------------- */
00146 BOOLEAN ObexResult::IsError()
00147 const
00148 {
00149     return (m_code != Success);
00150 }// IsError
00151
00152 /*  ----------------------------------------------------------------------
00153     IsOk
00154     ---------------------------------------------------------------------- */
00155 BOOLEAN ObexResult::IsOk()
00156 const
00157 {
00158     return (m_code == Success);
00159 }// IsOk
00160
00161 /*  ----------------------------------------------------------------------
00162     operator BOOLEAN
00163     ---------------------------------------------------------------------- */
00164 ObexResult::operator BOOLEAN()
00165 const
00166 {
00167     return IsOk();
00168 }// BOOLEAN
00169
00170 /*  ----------------------------------------------------------------------
00171     GetErrorCode
00172     ---------------------------------------------------------------------- */
00173 ObexResult::ErrorCode   ObexResult::GetErrorCode()
00174 const
00175 {
00176     return m_code;
00177 }// GetErrorCode
00178
00180 #endif  // Apoxi_ObexResult_hpp
00181
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServer.cpp File Reference

Obex/ObexServer.cpp File Reference

#include "PreComp.hpp"
#include "Auxiliary/StrUtil.hpp"
#include "ObexConfig.hpp"
#include "ObexObject.hpp"
#include "ObexBuffer.hpp"
#include "ObexLayer.hpp"
#include "ObexMessages.hpp"
#include "ObexMngr.hpp"
#include "ObexUrlParser.hpp"
#include "ObexServerPort.hpp"
#include "ObexServerMngr.hpp"
#include "ObexServerVisitor.hpp"
#include "ObexServer.hpp"

Include dependency graph for ObexServer.cpp:

Generated on Tue Jan 24 23:20:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServer.hpp File Reference

Obex/ObexServer.hpp File Reference

#include <Auxiliary/ByteBuffer.hpp>
#include <Obex/ObexObject.hpp>
#include <Obex/ObexOperationId.hpp>
#include <Obex/ObexServerInfo.hpp>
#include <Obex/ObexServerDispatcher.hpp>

Include dependency graph for ObexServer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexServer
Internal base class for OBEX servers within applications. More...
class | ObexServer::ServerInfo
ServerInfo record used to register with the Server Manager.

Defines

#define | Apoxi_ObexServer_hpp

Define Documentation

#define Apoxi_ObexServer_hpp

Generated on Tue Jan 24 23:20:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServer.hpp Source File

Obex/ObexServer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexServer_hpp)
00011 #define Apoxi_ObexServer_hpp
00014
00015 #include <Auxiliary/ByteBuffer.hpp>
00016
00017 #include <Obex/ObexObject.hpp>
00018 #include <Obex/ObexOperationId.hpp>
00019 #include <Obex/ObexServerInfo.hpp>
00020 #include <Obex/ObexServerDispatcher.hpp>
00021
00022 // Forward declarations of classes
00023 class ObexObject;
00024 class ObexBuffer;
00025
00038 class ObexServer : public ObexServerDispatcher {
00039
00040     public:
00041         typedef ObexServerDispatcher Base;
00042
00044         enum Operation {
00045             OConnect,
00046             ODisconnect,
00047             OPut,
00048             OGet,
00049             OSetPath,
00050             OAbort,
00051             ONone
00052         };
00053
00058         ObexServer();
00059
00068         ObexServer(ExecutionContext *   ctx_ptr);
00069
00071         virtual ~ObexServer();
00072
00080         virtual void        Init(ExecutionContext *     ctx_ptr);
00081
00087         ObexResult  ReturnResponse(const ObexObject &  obex_resp);
00088
00100         ObexResult  DataProcessed(ObexBuffer &  buffer,
00101                                   BOOLEAN       proceed = FALSE);
00102
00110         UINT32                      GetProgressInBytes() const;
00111
00113         inline  BOOLEAN             IsConnected() const;
00114
00122         inline  UINT32              GetConnectionId() const;
00123
00125         inline  const ByteBuffer &  GetTarget() const;
00126
00128         inline  BOOLEAN         IsBoundToServerId(ObexServerId  id) const
00129         {
00130             return  ( m_server_info.GetServerId() == id );
00131         }
00132
00133         BOOLEAN                 IsActiveOperation(const ObexOperationId &   oper_id) const;
00134         BOOLEAN                 IsBoundToTarget(const ByteBuffer &  target) const;
00135         BOOLEAN                 IsBoundToTarget() const;
00136
00137     protected:
00138         virtual BOOLEAN         OnChannelsMatch(const ServerPortPtr &   port_ptr,
00139                                                 const ObexMsg &         msg);
00140
00151         virtual void            OnConnect(const ObexObject &  conn_req);
00152
00162         virtual void            OnDisconnect(const ObexObject &  disc_req);
00163
00180         virtual void            OnPut(const ObexObject &  put_req,
00181                                       BOOLEAN             initial);
00182
00200         virtual void            OnGet(const ObexObject &  get_req,
00201                                       BOOLEAN             initial);
00202
00212         virtual void            OnAbort(const ObexObject &  abort_req);
00213
00224         virtual void            OnSetPath(const ObexObject &  setp_req);
00225
00229         virtual void            OnComplete(Operation    op,
00230                                            ObexResult   result);
00231
00238         virtual void            OnDataProcessed(ObexBuffer &    buffer);
00239
00252         virtual void            OnDisconnected(ObexResult   result) {}
00253
00255         virtual ObexResult      OpenAction();
00257         virtual ObexResult      CloseAction();
00259         virtual BOOLEAN         IsRequestForMe(const ObexMsg &      msg,
00260                                                ObexDispatcher * &   dispatcher_ptr);
00262         virtual void            OnBeginOperation(ObexDispatcher *   dispatcher_ptr) {}
00263
00265         virtual ObexServerId    GetDefaultServerId() const;
00266
00267     private:
00269         class ServerInfo : public ObexServerInfo {
00270             public:
00271                 ServerInfo(ObexServer &     server);
00272
00273                 ObexResult          SetTarget(const String &    url_str);
00274
00275                 const ByteBuffer &  GetTarget() const
00276                 {
00277                     return m_target;
00278                 }
00279
00280                 virtual BOOLEAN     Accept(ObexServerVisitor &  v);
00281
00282             private:
00283                 ObexServer &        m_server;
00284                 ByteBuffer          m_target;
00285         };
00286
00287         class   DupeChecker;
00288
00289         enum OperState {
00290             SInitial,   // No request being processed
00291             SRequest,   // Request being processed
00292             SResponse,  // Response has been sent, waiting for request
00293             SFinal      // Final response has been sent, waiting for completion
00294         };
00295
00296         ServerInfo          m_server_info;
00297         ObexObject          m_abort_request;
00298         UINT32              m_connection_id;
00299         UINT32              m_data_progress;
00300         ObexOperationId     m_active_oper_id;
00301         Operation           m_active_oper_type;
00302         BOOLEAN             m_connected;
00303         BOOLEAN             m_final_response;   // Next response will be final.
00304         OperState           m_oper_state;
00305
00306     private:
00307         BOOLEAN     IsBadRequest(const ServerPortPtr &      port_ptr,
00308                                  const ObexMsg &            msg,
00309                                  Operation                  oper_type);
00310
00311         void        AcceptRequest(const ServerPortPtr &     port_ptr,
00312                                   const ObexMsg &           msg,
00313                                   Operation                 oper_type,
00314                                   BOOLEAN                   simple_op);
00315
00316         void        RejectRequest(const ServerPortPtr &     port_ptr,
00317                                   const ObexMsg &           obex_msg,
00318                                   ObexObject::ResponseCode  cause);
00319
00320         void        AssignConnectionId();
00321
00322         void        SetOperState(OperState  new_state);
00323
00324         BOOLEAN     HandleBuffer(const ObexMsg &            msg);
00325         BOOLEAN     HandleResult(const ObexMsg &            msg);
00326
00327         BOOLEAN     HandleConnect(const ServerPortPtr &     port_ptr,
00328                                   const ObexMsg &           msg);
00329
00330         BOOLEAN     HandleDisconnect(const ServerPortPtr &  port_ptr,
00331                                      const ObexMsg  &       msg);
00332
00333         BOOLEAN     HandlePut(const ServerPortPtr &         port_ptr,
00334                               const ObexMsg &               msg);
00335
00336         BOOLEAN     HandleGet(const ServerPortPtr &         port_ptr,
00337                               const ObexMsg &               msg);
00338
00339         BOOLEAN     HandleSetPath(const ServerPortPtr &     port_ptr,
00340                                   const ObexMsg &           msg);
00341
00342         BOOLEAN     HandleAbort(const ServerPortPtr &       port_ptr,
00343                                 const ObexMsg &             msg);
00344
00345         BOOLEAN     HandleBadResult(const ObexResult &      result,
00346                                     BOOLEAN                 in_operation);
00347
00348         Operation   FinishOperation();
00349         void        DisposeBodyData(ObexObject  data_obj);
00350         void        ServiceNotImplemented(const CHAR *  dbg_str);
00351 };
00352
00353 /*  ----------------------------------------------------------------------
00354     GetTarget
00355     ---------------------------------------------------------------------- */
00356 const ByteBuffer &  ObexServer::GetTarget()
00357 const
00358 {
00359     return  m_server_info.GetTarget();
00360 }// GetTarget
00361
00362 /*  ----------------------------------------------------------------------
00363     IsConnected
00364     ---------------------------------------------------------------------- */
00365 BOOLEAN             ObexServer::IsConnected()
00366 const
00367 {
00368     return  m_connected;
00369 }// IsConnected
00370
00371 /*  ----------------------------------------------------------------------
00372     GetConnectionId
00373     ---------------------------------------------------------------------- */
00374 UINT32              ObexServer::GetConnectionId()
00375 const
00376 {
00377     return  m_connection_id;
00378 }// GetConnectionId
00379
00381 #endif  // Apoxi_ObexServer_hpp
00382
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerDispatcher.cpp File Reference

Obex/ObexServerDispatcher.cpp File Reference

#include "PreComp.hpp"
#include "ObexMngr.hpp"
#include "ObexTransport.hpp"
#include "ObexTransportSet.hpp"
#include "ObexTransportMsg.hpp"
#include "ObexServerPort.hpp"
#include "ObexServerDispatcher.hpp"

Include dependency graph for ObexServerDispatcher.cpp:

Generated on Tue Jan 24 23:20:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerDispatcher.hpp File Reference

Obex/ObexServerDispatcher.hpp File Reference

#include <Auxiliary/BitField.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexConfig.hpp>
#include <Obex/ObexResult.hpp>
#include <Obex/ObexAddrPtr.hpp>
#include <Obex/ObexTransportSet.hpp>
#include <Obex/ObexDispatcher.hpp>

Include dependency graph for ObexServerDispatcher.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexServerDispatcher
Internal abstraction of an OBEX server at transport level. More...

Defines

#define | Apoxi_ObexServerDispatcher_hpp

Define Documentation

#define Apoxi_ObexServerDispatcher_hpp

Generated on Tue Jan 24 23:20:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerDispatcher.hpp Source File

Obex/ObexServerDispatcher.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexServerDispatcher_hpp)
00011 #define Apoxi_ObexServerDispatcher_hpp
00014
00015 #include <Auxiliary/BitField.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017
00018 #include <Obex/ObexTypes.hpp>
00019 #include <Obex/ObexConfig.hpp>
00020 #include <Obex/ObexResult.hpp>
00021 #include <Obex/ObexAddrPtr.hpp>
00022 #include <Obex/ObexTransportSet.hpp>
00023
00024 #include <Obex/ObexDispatcher.hpp>
00025
00026 // Forward declarations of classes
00027 class ObexServerPort;
00028 class ObexChannel;
00029
00030
00050 class ObexServerDispatcher : public ObexEventHandler {
00051
00052     friend class ObexServerPort;
00053
00054     public:
00055         typedef ObexEventHandler Base;
00056
00061         enum OpenFlags {
00062
00063             SdbAutoRegister  = 1,
00064
00065
00066             PrivateTransport = 2,
00067
00068         };
00069
00071         virtual ~ObexServerDispatcher();
00072
00079         virtual void        Init(ExecutionContext *     ctx_ptr);
00080
00095         virtual ObexResult  Open(const String &             obex_addr_url,
00096                                  UINT8                      open_flags     = 0,
00097                                  const ObexTransportSet &   excl_xport_set = ObexTransportSet() );
00098
00103         virtual ObexResult  Close();
00104
00112         inline  UINT8       GetNrOfOpenedTransports() const;
00113
00115         BOOLEAN             IsBoundToChannel(const ObexChannel &  channel) const;
00116
00117     protected:
00118         typedef NiSharedPtr<ObexServerPort> ServerPortPtr;
00119
00121         static  inline BOOLEAN  IsPortPtrValid(const ServerPortPtr &    port_ptr);
00122
00127         ObexServerDispatcher();
00128
00130         inline const String &   GetUrlStr() const;
00131
00136         inline  BOOLEAN     IsActive() const;
00137
00142         inline  BOOLEAN     IsActive(const ServerPortPtr &  port_ptr) const;
00143
00148         inline  BOOLEAN     IsShuttingDown() const;
00149
00151         virtual BOOLEAN     IsValidContext() const;
00153         virtual BOOLEAN     OnObexMsg(const ObexMsg &   msg);
00155         virtual BOOLEAN     OnObexAddrMsg(const ObexAddrMsg &   msg);
00157         virtual BOOLEAN     OnObexTransportMsg(const ObexTransportMsg & msg);
00158
00160         virtual void        HangUp();
00161
00167         virtual void        OnBind(const ObexAddrPtr &  addr_ptr,
00168                                    ObexResult           result);
00169
00177         virtual void        OnRelease(const ObexAddrPtr &  addr_ptr,
00178                                       ObexResult           result);
00179
00180         /* @brief   Indicates completion of a Close() operation.
00181
00182             @param  result  When 'result' evaluates to \c 'TRUE' it
00183                             indicates successful completion of a \c Close()
00184                             operation, otherwise it was shut down spontaneously.
00185                             Check the error code in the latter case. */
00186         virtual void        OnClose(ObexResult  result);
00187
00188         /*  @brief  Indicates reception of an OBEX protocol event.
00189
00190             This notification method is called whenever an ObexMsg is received
00191             which is originated from one of the transport channels the current
00192             \c ObexServerDispatcher instance is listening to.
00193             Derived classes mut implement it to dispatch the various events
00194             resulting from communication using an OBEX-based protocol.
00195
00196             @param  port_ptr    Port from which the OBEX event was received.
00197             @param  msg         ObexMsg containing the event type and data. */
00198         virtual BOOLEAN     OnChannelsMatch(const ServerPortPtr &   port_ptr,
00199                                             const ObexMsg &         msg) = 0;
00200
00201         virtual ObexResult  OpenAction();
00202         virtual ObexResult  CloseAction();
00203
00208         ServerPortPtr       GetActivePortPtr() const;
00209
00211         BOOLEAN             IsAcceptable(const ServerPortPtr &  port_ptr) const;
00212
00214         void                SetActive(const ServerPortPtr &     port_ptr);
00215
00217         void                SetIdle();
00218
00219     private:
00220         enum  ServerFlags {
00221             IsClosePending,
00222             IsCloseNotified,
00223             IsEventPending,
00224             IsListening
00225         };
00226
00227         BitField8           m_server_state;
00228         UINT8               m_server_flags;
00229         ObexTransportSet    m_server_excl_set;
00230         UINT8               m_server_port_cnt;
00231         ObexDispatcher      m_dispatcher;
00232         String              m_obex_url_str;
00233         ServerPortPtr       m_active_port_ptr;
00234         ServerPortPtr       m_server_port_tab[APOXI_OBEX_MAX_NO_TRANSPORTS];
00235
00236
00237         void                OnPortClosed(ObexTransportId    id);
00238
00239         void                CleanUp();
00240         void                Notify();
00241         void                NotifyClosed();
00242 };
00243
00244 /*  ----------------------------------------------------------------------
00245     GetNrOfOpenedTransports
00246     ---------------------------------------------------------------------- */
00247 inline  UINT8   ObexServerDispatcher::GetNrOfOpenedTransports()
00248 const
00249 {
00250     return  m_server_port_cnt;
00251 }// GetNrOfOpenedTransports
00252
00253 BOOLEAN     ObexServerDispatcher::IsPortPtrValid(const ServerPortPtr &   port_ptr)
00254 {
00255     return  ( port_ptr.Get() != 0 );
00256 }
00257
00258 BOOLEAN     ObexServerDispatcher::IsActive()
00259 const
00260 {
00261     return IsPortPtrValid(m_active_port_ptr);
00262 }
00263
00264 BOOLEAN     ObexServerDispatcher::IsActive(const ServerPortPtr &    port_ptr)
00265 const
00266 {
00267     return  ( m_active_port_ptr.Get() ==  port_ptr.Get() );
00268 }
00269
00270 /*  ----------------------------------------------------------------------
00271     IsShuttingDown
00272     ---------------------------------------------------------------------- */
00273 BOOLEAN     ObexServerDispatcher::IsShuttingDown()
00274 const
00275 {
00276     return  m_server_state.GetBit(IsClosePending);
00277 }// IsShuttingDown
00278
00279 const String &  ObexServerDispatcher::GetUrlStr()
00280 const
00281 {
00282     return  m_obex_url_str;
00283 }
00284
00286 #endif  // Apoxi_ObexServerDispatcher_hpp
00287
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerInfo.cpp File Reference

Obex/ObexServerInfo.cpp File Reference

#include "PreComp.hpp"
#include "ObexMngr.hpp"
#include "ObexServerMngr.hpp"
#include "ObexServerInfo.hpp"

Include dependency graph for ObexServerInfo.cpp:

Generated on Tue Jan 24 23:20:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerInfo.hpp File Reference

Obex/ObexServerInfo.hpp File Reference

#include <Auxiliary/Linkable.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexResult.hpp>

Include dependency graph for ObexServerInfo.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexServerInfo
Internal interface used to register OBEX servers with the Server Registry. More...

Defines

#define | Apoxi_ObexServerInfo_hpp

Define Documentation

#define Apoxi_ObexServerInfo_hpp

Generated on Tue Jan 24 23:20:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerInfo.hpp Source File

Obex/ObexServerInfo.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexServerInfo_hpp)
00010 #define Apoxi_ObexServerInfo_hpp
00013
00014 #include <Auxiliary/Linkable.hpp>
00015
00016 #include <Obex/ObexTypes.hpp>
00017 #include <Obex/ObexResult.hpp>
00018
00019 //  Forward declarartions of classes
00020 class ObexServerVisitor;
00021
00042 class ObexServerInfo : public Linkable<ObexServerInfo> {
00043
00044     friend  class ObexServerMngr;
00045
00046     public:
00048         enum {
00049             NoServerId    =   0,
00050             FirstServerId =   1,
00051             DefaultServerId = 254,
00052             OppImplServerId = 255
00053         };
00054
00056         ObexServerInfo();
00057
00059         virtual ~ObexServerInfo();
00060
00074         virtual BOOLEAN         Accept(ObexServerVisitor &  v) = 0;
00075
00076         /*  @brief  Registers a server information record with the server
00077                     manager.
00078
00079             @param  checker     An ObexServerVisitor which performs an ambiguity
00080                                 check on the record to be registered.
00081                                 If ambiguity is detected, \c Accept(checker) shall
00082                                 return \c 'FALSE'.
00083
00084             @param  propose_id  Permits specifying a reserved id, like for OPP
00085                                 or the default inbox. When \c 'FirstServerId'
00086                                 is passed, a regular entry is assumed and the
00087                                 id is assigned by \c ObexServerMngr. */
00088         ObexResult  Register(ObexServerVisitor &    checker,
00089                              ObexServerId           propose_id = FirstServerId);
00090
00092         void        Deregister();
00093
00094         /*  @brief  Returns the ObexServerId assigned at registration time.
00095
00096             @return \c ObexServerId assigned by the server manager or
00097                     \c NoServerId when currectly not registered. */
00098         inline  ObexServerId    GetServerId() const;
00099
00100     private:
00101         ObexServerId            m_server_id;
00102
00103         inline  void            SetServerId(ObexServerId    server_id);
00104 };
00105
00106 /*  ----------------------------------------------------------------------
00107     GetServerId
00108     ---------------------------------------------------------------------- */
00109 ObexServerId    ObexServerInfo::GetServerId()
00110 const
00111 {
00112     return  m_server_id;
00113 }// GetServerId
00114
00115 /*  ----------------------------------------------------------------------
00116     SetServerId
00117     ---------------------------------------------------------------------- */
00118 void    ObexServerInfo::SetServerId(ObexServerId    server_id)
00119 {
00120     m_server_id = server_id;
00121 }// SetServerId
00122
00124 #endif  // Apoxi_ObexServerInfo_hpp
00125
00126
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerMngr.cpp File Reference

Obex/ObexServerMngr.cpp File Reference

#include "PreComp.hpp"
#include "ObexServerInfo.hpp"
#include "ObexServerMngr.hpp"

Include dependency graph for ObexServerMngr.cpp:

Generated on Tue Jan 24 23:20:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerMngr.hpp File Reference

Obex/ObexServerMngr.hpp File Reference

#include <Auxiliary/LinkedList.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexResult.hpp>
#include <Obex/ObexServerInfo.hpp>

Include dependency graph for ObexServerMngr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexServerMngr
Internal implementation of an OBEX Server Registry. More...

Defines

#define | Apoxi_ObexServerMngr_hpp

Define Documentation

#define Apoxi_ObexServerMngr_hpp

Generated on Tue Jan 24 23:20:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerMngr.hpp Source File

Obex/ObexServerMngr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexServerMngr_hpp)
00010 #define Apoxi_ObexServerMngr_hpp
00013
00014 #include <Auxiliary/LinkedList.hpp>
00015
00016 #include <Obex/ObexTypes.hpp>
00017 #include <Obex/ObexResult.hpp>
00018 #include <Obex/ObexServerInfo.hpp>
00019
00020 //  Forward declarartions of classes
00021 class ObexServer;
00022 class ObexOppServer;
00023 class ObexServerVisitor;
00024
00045 class ObexServerMngr
00046 {
00047     public:
00049         ObexServerMngr();
00050
00061         ObexServerId    Register(ObexServerInfo &       info_item,
00062                                  ObexServerVisitor &    checker,
00063                                  ObexServerId           special_id);
00064
00069         void            Deregister(ObexServerInfo &     server_info);
00070
00083         ObexServerId    Iterate(ObexServerVisitor &     visitor);
00084
00085     private:
00086         typedef LinkedList<ObexServerInfo>  ServerInfoList;
00087
00088         ServerInfoList  m_server_info_list;
00089 };
00090
00092 #endif  // Apoxi_ObexServerMngr_hpp
00093
Generated on Tue Jan 24 14:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerOppImpl.cpp File Reference

Obex/ObexServerOppImpl.cpp File Reference

#include "PreComp.hpp"
#include "ObexMessages.hpp"
#include "ObexOppServer.hpp"
#include "ObexServerOppImpl.hpp"

Include dependency graph for ObexServerOppImpl.cpp:

Generated on Tue Jan 24 23:20:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerOppImpl.hpp File Reference

Obex/ObexServerOppImpl.hpp File Reference

#include "ObexBuffer.hpp"
#include "ObexObject.hpp"
#include "ObexServer.hpp"

Include dependency graph for ObexServerOppImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexServerOppImpl
Internal server implementation of the OPP profile. More...
class | ObexServerOppImpl::HeaderCollector
Internal helper class for accumulatig headers split over multiple packets.

Defines

#define | Apoxi_ObexServerOppImpl_hpp

Define Documentation

#define Apoxi_ObexServerOppImpl_hpp

Generated on Tue Jan 24 23:20:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerOppImpl.hpp Source File

Obex/ObexServerOppImpl.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexServerOppImpl_hpp)
00011 #define Apoxi_ObexServerOppImpl_hpp
00014
00015 #include "ObexBuffer.hpp"
00016 #include "ObexObject.hpp"
00017 #include "ObexServer.hpp"
00018
00019 // Forward declarations of classes
00020 class ObexOppServer;
00021
00022
00046 class ObexServerOppImpl : public ObexServer {
00047
00048     public:
00050         static  ObexServerOppImpl &     GetInstance();
00051
00053         inline  BOOLEAN     IsActiveOppServer(const ObexOppServer *  srvr_ptr)
00054         const
00055         {
00056             return  ( srvr_ptr == m_active_opp_server_ptr );
00057         }
00058
00060         ObexResult  AttachOppServer(ObexOppServer *     self_ptr);
00061
00063         void        DetachOppServer(ObexOppServer *     self_ptr);
00064
00066         ObexResult  AcceptPush();
00067
00075         ObexResult  AcceptPull(const WString &  obj_name,
00076                                const WString &  obj_desc,
00077                                UINT32           obj_size);
00078
00080         ObexResult  ProvideData(ObexBuffer &    app_data,
00081                                 BOOLEAN         end_data);
00082
00084         ObexResult  DataProcessed(ObexBuffer &  app_data);
00085
00087         ObexResult  DataProcessed();
00088
00095         ObexResult  CancelOperation(ObexObject::ResponseCode    resp_code,
00096                                     const WString &             resp_desc);
00097
00098     protected:
00100         virtual BOOLEAN         IsValidContext() const;
00102         virtual void            OnConnect(const ObexObject &  conn_req);
00104         virtual void            OnDisconnect(const ObexObject &  disc_req);
00106         virtual void            OnPut(const ObexObject & put_req, BOOLEAN   initial);
00108         virtual void            OnGet(const ObexObject & put_req, BOOLEAN   initial);
00110         virtual void            OnAbort(const ObexObject &  abort_req);
00112         virtual void            OnComplete(Operation    op, ObexResult  result);
00114         virtual void            OnDataProcessed(ObexBuffer &    buffer);
00116         virtual BOOLEAN         IsRequestForMe(const ObexMsg &      msg,
00117                                                ObexDispatcher * &   dispatcher_ptr);
00119         virtual void            OnBeginOperation(ObexDispatcher *   dispatcher_ptr);
00121         virtual ObexServerId    GetDefaultServerId() const;
00122
00123     private:
00124         typedef ObexServer  Base;
00125
00126         enum OppState {
00127
00128             SOppAvailable,
00129             SOppAborted,
00130             SOppFinally,
00131
00132             SOppPushRequest,
00133             SOppPushContinued,
00134             SOppPushResponse,
00135
00136             SOppPullRequest,
00137             SOppPullContinued,
00138             SOppPullResponse,
00139         };
00140
00142         class HeaderCollector {
00143
00144             public:
00146                 HeaderCollector() : m_size(0)
00147                 {
00148                 }
00150                 void                        Reset();
00151
00153                 BOOLEAN                     Parse(const ObexHeaderList &    headers);
00154
00156                 inline  UINT32              GetSize() const
00157                 {
00158                     return  m_size;
00159                 }
00161                 inline  const WString &     GetName() const
00162                 {
00163                     return  m_name;
00164                 }
00166                 inline  const String &      GetType() const
00167                 {
00168                     return  m_type;
00169                 }
00171                 inline  const WString &     GetDescription() const
00172                 {
00173                     return  m_desc;
00174                 }
00175
00176             private:
00177                 UINT32              m_size;
00178                 WString             m_name;
00179                 String              m_type;
00180                 WString             m_desc;
00181
00183                 HeaderCollector(const HeaderCollector &);
00185                 HeaderCollector &   operator=(const HeaderCollector &);
00186         };
00187
00188         static  ObexServerOppImpl   s_instance;
00189
00190         OppState                    m_opp_state;
00191         BOOLEAN                     m_is_accepted;
00192         BOOLEAN                     m_is_end_data;  // Only response !
00193         BOOLEAN                     m_is_final;     // Only request !
00194         ObexObject::ResponseCode    m_resp_code;
00195         UINT8                       m_active_opp_server_cnt;
00196         WString                     m_description;
00197         ObexObject                  m_response;
00198         ObexBuffer                  m_buffer;
00199         ObexOppServer *             m_active_opp_server_ptr;
00200         const ExecutionContext *    m_active_context_ptr;
00201         HeaderCollector             m_opp_headers;
00202
00203         ObexServerOppImpl();
00204
00205         inline  ObexOppServer &     GetActiveOppServer()
00206         {
00207             ASSERT_DEBUG(m_active_opp_server_ptr != 0);
00208             return *m_active_opp_server_ptr;
00209         }
00210
00211         inline  BOOLEAN     IsApiActive() const
00212         {
00213             return  ( m_active_opp_server_ptr != 0 );
00214         }
00215
00216         inline  void        SetOppState(OppState    new_state)
00217         {
00218             m_opp_state = new_state;
00219         }
00220
00221         inline  OppState    GetOppState()const
00222         {
00223             return  m_opp_state;
00224         }
00225
00226         inline  BOOLEAN     IsInState(OppState  query_state) const
00227         {
00228             return  ( query_state == m_opp_state );
00229         }
00230
00231         inline BOOLEAN      IsOperationCancelled() const
00232         {
00233             return ( m_resp_code != ObexObject::RespOk );
00234         }
00235
00236         ObexOppServer *     FindOppServer(ObexServerId  server_id);
00237
00238         void                BeginOppRequest(ObexObject  request);
00239
00240         ObexResult          EnqueueData(ObexBuffer &    app_data,
00241                                         BOOLEAN         end_data);
00242
00243         void                DequeueData();
00244
00245         ObexResult          SendResponse(OppState       next_state);
00246         ObexResult          ReturnBuffer(ObexBuffer &   app_data);
00247 };
00248
00250 #endif  // Apoxi_ObexServerOppImpl_hpp
00251
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerPort.cpp File Reference

Obex/ObexServerPort.cpp File Reference

#include "PreComp.hpp"
#include "ObexServerDispatcher.hpp"
#include "ObexTransport.hpp"
#include "ObexProtocol.hpp"
#include "ObexServerPort.hpp"

Include dependency graph for ObexServerPort.cpp:

Functions

FSM_DEFINE_STATE (ObexServerPort, s1_listening)
FSM_DEFINE_STATE (ObexServerPort, s1_attaching)
FSM_DEFINE_STATE (ObexServerPort, s1_detaching)
FSM_DEFINE_STATE (ObexServerPort, s1_wait_avs)
FSM_DEFINE_STATE (ObexServerPort, s1_initially)
FSM_STATE_ELSE (ObexServerPort, s1_listening, DefaultAction)
FSM_STATE_ELSE (ObexServerPort, s1_attaching, DefaultAction)
FSM_STATE_ELSE (ObexServerPort, s1_detaching, DefaultAction)
FSM_STATE_ELSE (ObexServerPort, s1_wait_avs, DefaultAction)
FSM_STATE_ELSE (ObexServerPort, s1_initially, DefaultAction)

Function Documentation

FSM_DEFINE_STATE | ( | ObexServerPort | ,
 |  | s1_listening |
 | ) |

FSM_DEFINE_STATE | ( | ObexServerPort | ,
 |  | s1_attaching |
 | ) |

FSM_DEFINE_STATE | ( | ObexServerPort | ,
 |  | s1_detaching |
 | ) |

FSM_DEFINE_STATE | ( | ObexServerPort | ,
 |  | s1_wait_avs |
 | ) |

FSM_DEFINE_STATE | ( | ObexServerPort | ,
 |  | s1_initially |
 | ) |

FSM_STATE_ELSE | ( | ObexServerPort | ,
 |  | s1_listening | ,
 |  | DefaultAction |
 | ) |

FSM_STATE_ELSE | ( | ObexServerPort | ,
 |  | s1_attaching | ,
 |  | DefaultAction |
 | ) |

FSM_STATE_ELSE | ( | ObexServerPort | ,
 |  | s1_detaching | ,
 |  | DefaultAction |
 | ) |

FSM_STATE_ELSE | ( | ObexServerPort | ,
 |  | s1_wait_avs | ,
 |  | DefaultAction |
 | ) |

FSM_STATE_ELSE | ( | ObexServerPort | ,
 |  | s1_initially | ,
 |  | DefaultAction |
 | ) |

Generated on Tue Jan 24 23:20:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerPort.hpp File Reference

Obex/ObexServerPort.hpp File Reference

#include <Obex/ObexAbstractPort.hpp>

Include dependency graph for ObexServerPort.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexServerPort
Internal implementation class for OBEX transport interfaces. More...

Defines

#define | Apoxi_ObexServerPort_hpp

Define Documentation

#define Apoxi_ObexServerPort_hpp

Generated on Tue Jan 24 23:20:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerPort.hpp Source File

Obex/ObexServerPort.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexServerPort_hpp)
00011 #define Apoxi_ObexServerPort_hpp
00014
00015 #include <Obex/ObexAbstractPort.hpp>
00016
00017 //  Forward declaration of classes.
00018 class ObexServerDispatcher;
00019
00042 class ObexServerPort : public ObexAbstractPort {
00043
00044     public:
00045         typedef ObexAbstractPort    Base;
00046
00058         ObexServerPort(ObexAbstractTransport &  transport,
00059                        ObexProtocol &           protocol,
00060                        ObexServerDispatcher &   server);
00061
00063         inline  BOOLEAN     IsListening() const;
00064
00069         void                Reset();
00070
00071     protected:
00072         virtual void        StartAddrResolution();
00073         virtual void        AbortAddrResolution();
00074
00078         virtual BOOLEAN     AcquireChannel(ObexChannel &        channel,
00079                                            const ObexAddrPtr &  addr_ptr,
00080                                            ObexResult           result);
00081
00082         virtual void        OpenChannel(const ObexAddrPtr &     addr_ptr);
00083         virtual void        CloseChannel(ObexResult cause);
00084
00085         virtual void        OnChannelClosed();
00086         virtual void        OnChannelOpened(ObexResult  result);
00087
00088     private:
00089         // Initial state and state after port has been closed again.
00090         FSM_DECLARE_STATE(s1_initially);
00091
00092         // Port is waiting for availability state to become 'AvsReady'
00093         FSM_DECLARE_STATE(s1_wait_avs);
00094
00095         // Port is detaching from transport (procedure running)
00096         FSM_DECLARE_STATE(s1_detaching);
00097
00098         // Port is attaching to transport (procedure running)
00099         FSM_DECLARE_STATE(s1_attaching);
00100
00101         // Port is listening to incoming connections.
00102         FSM_DECLARE_STATE(s1_listening);
00103
00104         ObexServerDispatcher &      m_server;
00105 };
00106
00107 BOOLEAN     ObexServerPort::IsListening()
00108 const
00109 {
00110     return  IsInState( FSM_STATE_FROM_NAME(s1_listening) );
00111 }
00112
00114 #endif  // Apoxi_ObexServerPort_hpp
00115
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerVisitor.cpp File Reference

Obex/ObexServerVisitor.cpp File Reference

#include "PreComp.hpp"
#include "ObexServerVisitor.hpp"

Include dependency graph for ObexServerVisitor.cpp:

Generated on Tue Jan 24 23:20:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerVisitor.hpp File Reference

Obex/ObexServerVisitor.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexServerVisitor
Internal interface used to scan the OBEX Server Registry. More...

Defines

#define | Apoxi_ObexServerVisitor_hpp

Define Documentation

#define Apoxi_ObexServerVisitor_hpp

Generated on Tue Jan 24 23:20:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexServerVisitor.hpp Source File

Obex/ObexServerVisitor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexServerVisitor_hpp)
00010 #define Apoxi_ObexServerVisitor_hpp
00013
00014 //  Forward declarartions of classes
00015 class ObexServer;
00016 class ObexOppServer;
00017
00041 class ObexServerVisitor {
00042
00043     public:
00045         virtual ~ObexServerVisitor();
00046
00048         virtual BOOLEAN     VisitObexServer(const ObexServer &  server);
00049
00051         virtual BOOLEAN     VisitOppServer(const ObexOppServer &  server);
00052
00053     protected:
00054         //  Default constructor. Forbids direct instantiation of the class.
00055         ObexServerVisitor();
00056 };
00057
00059 #endif  // Apoxi_ObexServerVisitor_hpp
00060
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTemplates.cpp File Reference

Obex/ObexTemplates.cpp File Reference

#include "Obex/PreComp.hpp"
#include <Obex/ObexAddress.hpp>
#include <Obex/ObexServerPort.hpp>
#include <Obex/ObexClientPort.hpp>

Include dependency graph for ObexTemplates.cpp:

Generated on Tue Jan 24 23:20:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransport.cpp File Reference

Obex/ObexTransport.cpp File Reference

#include "PreComp.hpp"
#include "Kernel/MessageRouter.hpp"
#include "Devices/AbstractTransport.hpp"
#include "ObexMngr.hpp"
#include "ObexMessages.hpp"
#include "ObexTransportMsg.hpp"
#include "ObexTransport.hpp"

Include dependency graph for ObexTransport.cpp:

Generated on Tue Jan 24 23:20:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransport.hpp File Reference

Obex/ObexTransport.hpp File Reference

#include <Auxiliary/Observer.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexConfig.hpp>
#include <Obex/ObexResult.hpp>
#include <Obex/ObexAddrPtr.hpp>
#include <Obex/ObexOperationId.hpp>

Include dependency graph for ObexTransport.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexAbstractTransport
Internal abstract interface base class for OBEX transports. More...

Defines

#define | Apoxi_ObexTransport_hpp

Define Documentation

#define Apoxi_ObexTransport_hpp

Generated on Tue Jan 24 23:20:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransport.hpp Source File

Obex/ObexTransport.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexTransport_hpp)
00010 #define Apoxi_ObexTransport_hpp
00013
00014 #include <Auxiliary/Observer.hpp>
00015
00016 #include <Obex/ObexTypes.hpp>
00017 #include <Obex/ObexConfig.hpp>
00018 #include <Obex/ObexResult.hpp>
00019 #include <Obex/ObexAddrPtr.hpp>
00020 #include <Obex/ObexOperationId.hpp>
00021
00022 // Forward declarations of classes
00023 class ObexProtocol;
00024 class AbstractTransport;
00025
00061 class ObexAbstractTransport : public Observer {
00062
00063     public:
00068         typedef ObexTransportId     ObjectId;
00069
00070         enum {
00071             ClientAddrTypeId = 0,
00072             ServerAddrTypeId = 0x80
00073         };
00074
00075         enum {
00077             NoObjectId = APOXI_OBEX_MAX_NO_TRANSPORTS
00078         };
00079
00081         inline  ObjectId                GetObjectId() const;
00082
00092         inline  ObexAddrTypeId          GetClientAddrTypeId() const;
00093
00103         inline  ObexAddrTypeId          GetServerAddrTypeId() const;
00104
00106         inline  AbstractTransport &     GetDeviceAbstraction() const;
00107
00109         inline  const CHAR *    GetUrlScheme() const;
00110
00116         BOOLEAN                 IsMatchedByUrl(const String &  obex_url) const;
00117
00125         virtual ObexProtocol *  GetProtocol(ObexProtocolId  level) = 0;
00126
00143         virtual void    ResolveServerAddr(const String &    local_url,
00144                                           ObexProtocolId    prot_id,
00145                                           BOOLEAN           sdb_autocreate,
00146                                           ObexOperationId   job_id) = 0;
00147
00163         virtual void    ResolveClientAddr(const String &    remote_url,
00164                                           ObexProtocolId    prot_id,
00165                                           ObexOperationId   job_id) = 0;
00166
00170         virtual void    AbortResolveClientAddr(const ObexOperationId &  job_id) {}
00171
00172     protected:
00178         ObexAbstractTransport();
00179
00191         void            Init(AbstractTransport &    device_abs,
00192                              const CHAR *           scheme_url);
00193
00199         void            Register();
00200
00214         void            ReturnObexAddress(const ObexAddrPtr &   addr_ptr,
00215                                           ObexOperationId       oper_id,
00216                                           ObexResult            result);
00218         virtual void    OnUpdate(ObservableObject *     obs_obj);
00219
00220     private:
00221         const CHAR *            m_scheme_ptr;
00222         AbstractTransport *     m_abs_xp_ptr;
00223         ObjectId                m_object_id;
00224
00226         ObexAbstractTransport(const ObexAbstractTransport &);
00227
00229         ObexAbstractTransport &     operator=(const ObexAbstractTransport &);
00230
00232         inline  BOOLEAN             IsRegistered() const;
00233 };
00234
00235
00236 /*  ----------------------------------------------------------------------
00237     GetObjectId
00238     ---------------------------------------------------------------------- */
00239 ObexAbstractTransport::ObjectId     ObexAbstractTransport::GetObjectId()
00240 const
00241 {
00242     return m_object_id;
00243 }// GetObjectId
00244
00245 /*  ----------------------------------------------------------------------
00246     GetClientAddrTypeId
00247     ---------------------------------------------------------------------- */
00248 ObexAddrTypeId  ObexAbstractTransport::GetClientAddrTypeId()
00249 const
00250 {
00251     return ( ClientAddrTypeId + GetObjectId() );
00252 }// GetClientAddrTypeId
00253
00254 /*  ----------------------------------------------------------------------
00255     GetServerAddrTypeId
00256     ---------------------------------------------------------------------- */
00257 ObexAddrTypeId  ObexAbstractTransport::GetServerAddrTypeId()
00258 const
00259 {
00260     return ( ServerAddrTypeId + GetObjectId() );
00261 }// GetServerAddrTypeId
00262
00263 /*  ----------------------------------------------------------------------
00264     GetDeviceAbstraction
00265     ---------------------------------------------------------------------- */
00266 AbstractTransport &     ObexAbstractTransport::GetDeviceAbstraction()
00267 const
00268 {
00269     ASSERT_DEBUG_HOST(m_abs_xp_ptr != 0);
00270
00271     return  *m_abs_xp_ptr;
00272 }// GetDeviceAbstraction
00273
00274 /*  ----------------------------------------------------------------------
00275     GetUrlSchemePtr
00276     ---------------------------------------------------------------------- */
00277 const CHAR *    ObexAbstractTransport::GetUrlScheme()
00278 const
00279 {
00280     return m_scheme_ptr;
00281 }
00282
00283 /*  ----------------------------------------------------------------------
00284     IsRegistered
00285     ---------------------------------------------------------------------- */
00286 BOOLEAN     ObexAbstractTransport::IsRegistered()
00287 const
00288 {
00289     return  ( GetObjectId() != NoObjectId );
00290 }
00291
00293 #endif  // Apoxi_ObexTransport_hpp
00294
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransportMsg.cpp File Reference

Obex/ObexTransportMsg.cpp File Reference

#include "PreComp.hpp"
#include "ObexTransportMsg.hpp"

Include dependency graph for ObexTransportMsg.cpp:

Generated on Tue Jan 24 23:20:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransportMsg.hpp File Reference

Obex/ObexTransportMsg.hpp File Reference

#include <Kernel/Message.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexOperationId.hpp>

Include dependency graph for ObexTransportMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexTransportMsg

Defines

#define | Obex_ObexTransportMsg_hpp

Define Documentation

#define Obex_ObexTransportMsg_hpp

Generated on Tue Jan 24 23:20:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransportMsg.hpp Source File

Obex/ObexTransportMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_apoxi\Apoxi\Obex\MsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Obex_ObexTransportMsg_hpp)
00014 #define Obex_ObexTransportMsg_hpp
00015 #include <Kernel/Message.hpp>
00016 #include <Obex/ObexTypes.hpp>
00017 #include <Obex/ObexOperationId.hpp>
00018 /* ----------------------------------------------------------------------
00019     Classes
00020     ---------------------------------------------------------------------- */
00021 /*  ======================================================================
00022     Class ObexTransportMsg
00023     ====================================================================== */
00025 class ObexTransportMsg : public Message {
00026     public:
00027         ObexTransportMsg(const ObexTransportMsgType& msg_type, const ObexTransportId& transport_id, const ObexOperationId& operation_id = ObexOperationId());
00028         virtual ~ObexTransportMsg();
00029
00030         virtual const MsgMetaData& GetMetaData() const;
00031         const ObexTransportMsgType& GetMsgType() const { return m_msg_type; }
00032         const ObexTransportId& GetTransportId() const { return m_transport_id; }
00033         const ObexOperationId& GetOperationId() const { return m_operation_id; }
00034         virtual Message* Clone() const;
00035
00036         enum  {
00037             ID = 11004
00038             };
00039
00040     private:
00041         static const MsgMetaData m_meta_data;
00042         ObexTransportMsgType m_msg_type;
00043         ObexTransportId m_transport_id;
00044         ObexOperationId m_operation_id;
00045
00046     };
00047 #endif // Obex_ObexTransportMsg_hpp
00048
00049
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransportSet.cpp File Reference

Obex/ObexTransportSet.cpp File Reference

#include "PreComp.hpp"
#include "ObexMngr.hpp"
#include "ObexTransport.hpp"
#include "ObexTransportSet.hpp"

Include dependency graph for ObexTransportSet.cpp:

Generated on Tue Jan 24 23:21:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransportSet.hpp File Reference

Obex/ObexTransportSet.hpp File Reference

#include <Auxiliary/BitField.hpp>
#include <Obex/ObexTypes.hpp>
#include <Obex/ObexConfig.hpp>

Include dependency graph for ObexTransportSet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexTransportSet
Set representing multiple transport media to be used with APOXI OBEX. More...
class | ObexTransportSet::Iterator
Utility class to iterate over set elements. More...

Defines

#define | Apoxi_ObexTransportSet_hpp

Define Documentation

#define Apoxi_ObexTransportSet_hpp

Generated on Tue Jan 24 23:21:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTransportSet.hpp Source File

Obex/ObexTransportSet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexTransportSet_hpp)
00010 #define Apoxi_ObexTransportSet_hpp
00013
00014 #include <Auxiliary/BitField.hpp>
00015
00016 #include <Obex/ObexTypes.hpp>
00017 #include <Obex/ObexConfig.hpp>
00018
00019 // Forward declarations of classes.
00020 class ObexAbstractTransport;
00021
00051 class ObexTransportSet {
00052
00053     public:
00055         class Iterator {
00056
00057             friend  class ObexTransportSet;
00058
00059             public:
00061                 inline  Iterator();
00062
00064                 inline  Iterator(const Iterator & from);
00065
00067                 inline  Iterator &          operator=(const Iterator & from);
00068
00071                 ObexAbstractTransport &     operator*() const;
00072
00075                 ObexAbstractTransport *     operator->() const;
00076
00082                 inline  BOOLEAN             IsValid() const;
00083
00088                 inline  Iterator &          operator++();
00089
00095                 void                        Advance();
00096
00097             private:
00104                 Iterator(ObexTransportSet &     set,
00105                          ObexTransportId        pos = 0);
00106
00107                 ObexTransportSet *  m_ptr;
00108                 ObexTransportId     m_pos;
00109         };
00110
00115         inline  ObexTransportSet() {}
00116
00118         inline  ObexTransportSet(const ObexTransportSet &  from);
00119
00121         inline  ObexTransportSet &  operator=(const ObexTransportSet &  from);
00122
00124         inline  Iterator            Begin();
00125
00133         inline  BOOLEAN             IsEmpty() const;
00134
00136         inline  BOOLEAN             Contains(ObexTransportId    id) const;
00137
00139         UINT8                       GetCount() const;
00140
00144         void                        Include(const ObexAbstractTransport &   xp);
00145
00159         void                        Include(const String &                  scheme);
00160
00164         inline void                 Include(const ObexTransportSet &        xs);
00165
00171         inline  void                Exclude(const ObexTransportSet &        xs);
00172
00173     private:
00174         BitField8   m_bitset;
00175 };
00176
00177 /*  ----------------------------------------------------------------------
00178     Iterator    Default constructor.
00179     ---------------------------------------------------------------------- */
00180 ObexTransportSet::Iterator::Iterator() :
00181     m_ptr( 0 ),
00182     m_pos( APOXI_OBEX_MAX_NO_TRANSPORTS )
00183 {
00184 }// Constructor
00185
00186 /*  ----------------------------------------------------------------------
00187     Iterator    Copy constructor.
00188     ---------------------------------------------------------------------- */
00189 ObexTransportSet::Iterator::Iterator(const Iterator & from) :
00190     m_ptr( from.m_ptr ),
00191     m_pos( from.m_pos )
00192 {
00193 }// Constructor
00194
00195 /*  ----------------------------------------------------------------------
00196     Iterator    Assignment operator.
00197     ---------------------------------------------------------------------- */
00198 ObexTransportSet::Iterator &
00199 ObexTransportSet::Iterator::operator=(const Iterator & from)
00200 {
00201     m_ptr = from.m_ptr;
00202     m_pos = from.m_pos;
00203     return * this;
00204 }// Assignment
00205
00206 /*  ----------------------------------------------------------------------
00207     Iterator::IsValid
00208     ---------------------------------------------------------------------- */
00209 BOOLEAN     ObexTransportSet::Iterator::IsValid()
00210 const
00211 {
00212     return ( (m_ptr != 0) &&
00213              (m_pos < APOXI_OBEX_MAX_NO_TRANSPORTS) );
00214 }// IsValid
00215
00216 /*  ----------------------------------------------------------------------
00217     Iterator::operator++()
00218     ---------------------------------------------------------------------- */
00219 ObexTransportSet::Iterator &
00220 ObexTransportSet::Iterator::operator++()
00221 {
00222     Advance();
00223     return *this;
00224 }// operator++()
00225
00226 /*  ----------------------------------------------------------------------
00227     ObexTransportSet Copy
00228     ---------------------------------------------------------------------- */
00229 ObexTransportSet::ObexTransportSet(const ObexTransportSet &  from) :
00230     m_bitset( from.m_bitset )
00231 {
00232 }// ObexTransportSet
00233
00234 /*  ----------------------------------------------------------------------
00235     ObexTransportSet Assignment
00236     ---------------------------------------------------------------------- */
00237 ObexTransportSet &  ObexTransportSet::operator=(const ObexTransportSet &  from)
00238 {
00239     m_bitset = from.m_bitset;
00240     return *this;
00241 }// operator=
00242
00243 /*  ----------------------------------------------------------------------
00244     Begin
00245     ---------------------------------------------------------------------- */
00246 ObexTransportSet::Iterator  ObexTransportSet::Begin()
00247 {
00248     return Iterator(*this);
00249 }// Begin
00250
00251 /*  ----------------------------------------------------------------------
00252     IsEmpty
00253     ---------------------------------------------------------------------- */
00254 BOOLEAN     ObexTransportSet::IsEmpty()
00255 const
00256 {
00257     return ( m_bitset.Get() == 0 );
00258 }// IsEmpty
00259
00260 /*  ----------------------------------------------------------------------
00261     Contains
00262     ---------------------------------------------------------------------- */
00263 BOOLEAN     ObexTransportSet::Contains(ObexTransportId  id)
00264 const
00265 {
00266     return m_bitset.GetBit(id);
00267 }// Contains
00268
00269 /*  ----------------------------------------------------------------------
00270     Include
00271     ---------------------------------------------------------------------- */
00272 void    ObexTransportSet::Include(const ObexTransportSet &  xp_set)
00273 {
00274     m_bitset.Set( m_bitset.Get() | xp_set.m_bitset.Get() );
00275 }// Include
00276
00277 /*  ----------------------------------------------------------------------
00278     Exclude
00279     ---------------------------------------------------------------------- */
00280 void    ObexTransportSet::Exclude(const ObexTransportSet &  xp_set)
00281 {
00282     m_bitset.Set( m_bitset.Mask( ~xp_set.m_bitset.Get() ) );
00283 }// Exclude
00284
00286 #endif  // Apoxi_ObexTransportSet_hpp
00287
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTypes.hpp File Reference

Obex/ObexTypes.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for ObexTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_ObexTypes_hpp

Typedefs

typedef UINT8 | ObexAddrTypeId
This type id uniquely identifies a polymorphic class derived from either ObexClientAddr or ObexServerAddr.
typedef UINT8 | ObexServerId
Uniquely identifies an OBEX service endpoint.
typedef UINT8 | ObexTransportId
Transport Identifier uniquely identifies an ObexTransport implementation that has registered with ObexMngr.

Enumerations

enum | ObexAppMsgType { ObexAppMsgTransportSelectionReq }
Message opcodes for ObexMsg. More...
enum ObexMsgType {
ObexMsgResult, ObexMsgBuffer, ObexMsgResponse, ObexMsgPut,
ObexMsgGet, ObexMsgConnect, ObexMsgDisconnect, ObexMsgSetPath,
ObexMsgAbort
}
Message opcodes for ObexMsg. More...
enum | ObexProtocolId { ObexPrIdObex, ObexPrIdOpp }
Protocol Identifier definitions for classes derived from ObexProtocol. More...
enum | ObexTransportMsgType { ObexTrAvStateChanged, ObexTrEnableRejected, ObexTrSelectionResult }
Message opcodes for ObexTransportMsg. More...

Define Documentation

#define Apoxi_ObexTypes_hpp

Generated on Tue Jan 24 23:21:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexTypes.hpp Source File

Obex/ObexTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ObexTypes_hpp)
00011 #define Apoxi_ObexTypes_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00017
00020 typedef UINT8   ObexTransportId;
00021
00024 typedef UINT8   ObexAddrTypeId;
00025
00029 typedef UINT8   ObexServerId;
00030
00032 enum  ObexProtocolId {
00033
00034     ObexPrIdObex,
00035     ObexPrIdOpp
00036 };
00037
00039 enum  ObexMsgType {
00040
00041     // Common opcodes
00042     ObexMsgResult,
00043     ObexMsgBuffer,
00044
00045     // OBEX opcodes
00046     ObexMsgResponse,
00047     ObexMsgPut,
00048     ObexMsgGet,
00049     ObexMsgConnect,
00050     ObexMsgDisconnect,
00051     ObexMsgSetPath,
00052     ObexMsgAbort
00053 };
00054
00056 enum  ObexAppMsgType {
00057
00060     ObexAppMsgTransportSelectionReq
00061 };
00062
00064 enum  ObexTransportMsgType {
00065
00068     ObexTrAvStateChanged,
00069
00072     ObexTrEnableRejected,
00073
00079     ObexTrSelectionResult
00080 };
00081
00083 #endif  // Apoxi_ObexTypes_hpp
00084
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexUrlParser.cpp File Reference

Obex/ObexUrlParser.cpp File Reference

#include "PreComp.hpp"
#include <Auxiliary/StrUtil.hpp>
#include "ObexUrlParser.hpp"

Include dependency graph for ObexUrlParser.cpp:

Generated on Tue Jan 24 23:21:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexUrlParser.hpp File Reference

Obex/ObexUrlParser.hpp File Reference

#include "Auxiliary/String.hpp"
#include "Auxiliary/ByteBuffer.hpp"
#include "Obex/ObexResult.hpp"

Include dependency graph for ObexUrlParser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexUrlStrParser
Internal utility class used to parse an OBEX URL. More...

Defines

#define | Apoxi_ObexUrlParser_hpp

Define Documentation

#define Apoxi_ObexUrlParser_hpp

Generated on Tue Jan 24 23:21:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexUrlParser.hpp Source File

Obex/ObexUrlParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #if !defined(Apoxi_ObexUrlParser_hpp)
00010 #define Apoxi_ObexUrlParser_hpp
00013
00014 #include "Auxiliary/String.hpp"
00015 #include "Auxiliary/ByteBuffer.hpp"
00016
00017 #include "Obex/ObexResult.hpp"
00018
00029 class   ObexUrlStrParser {
00030     public:
00034         ObexUrlStrParser(const String &     url_str) :
00035             m_url_str(url_str),
00036             m_pos(0)
00037         {
00038         }
00039
00049         ObexResult  ParseTarget(ByteBuffer &    out_val);
00050
00051     protected:
00053         inline  BOOLEAN     IsAtEnd() const
00054         {
00055             return ( m_pos == - 1 );
00056         }
00057
00058         BOOLEAN         StartSymbol(char                symbol);
00059         BOOLEAN         MatchSymbol(char                symbol);
00060         BOOLEAN         MatchString(const CHAR *        key_str);
00061
00062         BOOLEAN         ScanAsciiString(ByteBuffer &    out_val);
00063         BOOLEAN         ScanOctetString(ByteBuffer &    out_val);
00064
00065     private:
00066         ByteBuffer      m_buffer;
00067         const String &  m_url_str;
00068         INT             m_pos;
00069 };
00070
00072 #endif  // Apoxi_ObexUrlParser_hpp
00073
00074
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexVCardMsg.cpp File Reference

Obex/ObexVCardMsg.cpp File Reference

#include "PreComp.hpp"
#include "ObexVCardMsg.hpp"

Include dependency graph for ObexVCardMsg.cpp:

Functions

OutputStream & | operator<< (OutputStream &ostr, const ObexVCardMsg &cls)
InputStream & | operator>> (InputStream &istr, ObexVCardMsg &cls)

Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const ObexVCardMsg & | cls
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | ObexVCardMsg & | cls
 | ) |

Generated on Tue Jan 24 23:21:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexVCardMsg.hpp File Reference

Obex/ObexVCardMsg.hpp File Reference

#include <Kernel/Message.hpp>
#include <Obex/VCard.hpp>
#include <Kernel/InputStream.hpp>
#include <Kernel/OutputStream.hpp>

Include dependency graph for ObexVCardMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexVCardMsg

Defines

#define | Obex_ObexVCardMsg_hpp

Define Documentation

#define Obex_ObexVCardMsg_hpp

Generated on Tue Jan 24 23:21:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/ObexVCardMsg.hpp Source File

Obex/ObexVCardMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\ObEx\ObexVCardMsg.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Obex_ObexVCardMsg_hpp)
00016 #define Obex_ObexVCardMsg_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Obex/VCard.hpp>
00020 #include <Kernel/InputStream.hpp>
00021 #include <Kernel/OutputStream.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class ObexVCardMsg
00030     ====================================================================== */
00031
00033 class ObexVCardMsg : public Message {
00034     public:
00035         ObexVCardMsg(const VCard& vCard);
00036         virtual ~ObexVCardMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         const VCard& GetVCard() const { return m_vCard; }
00040         virtual Message* Clone() const;
00041 #if !defined(APOXI_NOSTREAMING)
00042         friend OutputStream& operator << (OutputStream& ostr, const ObexVCardMsg& cls);
00043 #endif // APOXI_NOSTREAMING
00044 #if !defined(APOXI_NOSTREAMING)
00045         friend InputStream& operator >> (InputStream& istr, ObexVCardMsg& cls);
00046 #endif // APOXI_NOSTREAMING
00047
00048         enum {
00049             ID = 22001
00050             };
00051
00052     protected:
00053
00054 #if !defined(APOXI_NOSTREAMING)
00055         virtual void Dump(OutputStream& ostr) const;
00056 #endif // APOXI_NOSTREAMING
00057
00058     private:
00059         static const MsgMetaData m_meta_data;
00060         VCard m_vCard;
00061
00062     };
00063
00064 #endif // Obex_ObexVCardMsg_hpp
00065
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/PreComp.cpp File Reference

Obex/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:07:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/PreComp.hpp File Reference

Obex/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:22:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/PreComp.hpp Source File

Obex/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011
00012
00013
00014
00015
00016
00017
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/VCard.hpp File Reference

Obex/VCard.hpp File Reference

#include <Auxiliary/VCard.hpp>

Include dependency graph for VCard.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 19:40:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obex/VCard.hpp Source File

Obex/VCard.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #pragma message("The class VCard has been moved from Obex to Auxiliary. Please use #include <Auxiliary/VCard.hpp> instead of #include <Obex/VCard.hpp>.")
00010 #include <Auxiliary/VCard.hpp>
00011
Generated on Tue Jan 24 14:48:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/CsdDataConn.cpp File Reference

Socket/CsdDataConn.cpp File Reference

#include "Socket/PreComp.hpp"
#include "CsdDataConn.hpp"
#include "SocketMsg.hpp"
#include "CsdDataConnProfile.hpp"
#include <Asc/DataCallHdl.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for CsdDataConn.cpp:

Generated on Tue Jan 24 23:21:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/CsdDataConn.hpp File Reference

Socket/CsdDataConn.hpp File Reference

#include <Socket/PppDataConn.hpp>
#include <Asc/DataCallControl.hpp>
#include <Asc/Types.hpp>

Include dependency graph for CsdDataConn.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CsdDataConn

Defines

#define | Apoxi_CsdDataConn_hpp

Define Documentation

#define Apoxi_CsdDataConn_hpp

Generated on Tue Jan 24 23:21:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/CsdDataConn.hpp Source File

Socket/CsdDataConn.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_CsdDataConn_hpp)
00011 #define Apoxi_CsdDataConn_hpp
00014
00015 #include <Socket/PppDataConn.hpp>
00016 #include <Asc/DataCallControl.hpp>
00017 #include <Asc/Types.hpp>
00018
00019 class CsdDataConnProfile;
00020
00021 class CsdDataConn : public PppDataConn, public DataCallControl
00022 {
00023     typedef PppDataConn Base;
00024
00025     friend class NiSharedPtr<DataConn>;
00026     friend class DataConnProfile;
00027
00028     public:
00030         virtual void OnSetupCompleted(DcError error);
00031
00033         virtual void OnReleaseCompleted(DcError error);
00034
00035     protected:
00039         CsdDataConn(const DataConnProfilePtr &profile);
00040
00041         virtual ~CsdDataConn();
00042
00043     protected:
00044         virtual void PostInfoMsg(MessageType type) const;
00045
00047         virtual void OnBeforePppSetup();
00048
00050         virtual void OnAfterPppRelease();
00051
00052         void ReleaseDataCall();
00053
00054         virtual void Cleanup();
00055
00056     protected:
00057         const CsdDataConnProfile& MyProfile() const {
00058             return (const CsdDataConnProfile &)Base::MyProfile();
00059         }
00060
00061     protected:
00062         DcError m_dc_err;
00063         CallApiRc m_dch_err;
00064
00065     private:
00067         BOOLEAN m_csd_active;
00068
00069     private:
00070         void PostDataConnInfoMsg(DataConnInfoMsgType msg, DcError csd_err,
00071             CallApiRc csd_dial_err) const;
00072 };
00073
00075 #endif  // Apoxi_CsdDataConn_hpp
00076
00077
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/CsdDataConnProfile.cpp File Reference

Socket/CsdDataConnProfile.cpp File Reference

#include "Socket/PreComp.hpp"
#include "CsdDataConnProfile.hpp"
#include "PersistDataConnProfile.hpp"
#include "CsdDataConn.hpp"

Include dependency graph for CsdDataConnProfile.cpp:

Generated on Tue Jan 24 23:21:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/CsdDataConnProfile.hpp File Reference

Socket/CsdDataConnProfile.hpp File Reference

#include <Socket/DataConnProfile.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Asc/DataCallContext.hpp>

Include dependency graph for CsdDataConnProfile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CsdDataConnProfile
struct | CsdDataConnProfile::Bit
struct | CsdDataConnProfile::Persist

Defines

#define | Apoxi_CsdDataConnProfile_hpp

Define Documentation

#define Apoxi_CsdDataConnProfile_hpp

Generated on Tue Jan 24 23:21:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/CsdDataConnProfile.hpp Source File

Socket/CsdDataConnProfile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_CsdDataConnProfile_hpp)
00011 #define Apoxi_CsdDataConnProfile_hpp
00014
00015 #include <Socket/DataConnProfile.hpp>
00016 #include <Auxiliary/PhoneNumber.hpp>
00017 #include <Asc/DataCallContext.hpp>
00018
00021 class CsdDataConnProfile : public DataConnProfile
00022 {
00023     typedef DataConnProfile Base;
00024
00025     public:
00026         enum CallType {
00027             c_isdn = 0,
00028             c_analog = 1
00029         };
00030
00031         enum DataRate {
00032             c_data_rate_2400 = 1,
00033             c_data_rate_4800 = 2,
00034             c_data_rate_9600 = 4,
00035             c_data_rate_14400 = 6,
00036             c_data_rate_19200 = 8,
00037             c_data_rate_28800 = 12
00038         };
00039
00040         struct Bit {
00041             UINT m_call_type    :  1;
00042             UINT m_data_rate    :  4;
00043         };
00044
00045     public:
00046         CsdDataConnProfile();
00047         virtual ~CsdDataConnProfile();
00048
00050         CallType GetCallType() const
00051             { return (CallType)m_bit.m_call_type; }
00052
00054         void SetCallType(CallType ct)
00055             { m_bit.m_call_type = ct; }
00056
00058         DataRate GetDataRate() const
00059             { return (DataRate)m_bit.m_data_rate; }
00060
00063         void SetDataRate(DataRate dr)
00064             { m_bit.m_data_rate = dr; }
00065
00068         UINT32 GetDataBaudRate() const
00069             { return ((UINT32)m_bit.m_data_rate) * 2400UL; }
00070
00072         const PhoneNumber& GetPhoneNumber() const
00073             { return m_phone_no; }
00074
00076         void SetPhoneNumber(const PhoneNumber &pn)
00077             { m_phone_no = pn; }
00078
00080         const DataCallContext& GetDataCallContext() const
00081             { return m_context; }
00082
00084         void SetDataCallContext(const DataCallContext &context)
00085             { m_context = context; }
00086
00087     protected:
00088         virtual void SaveFrom(const PersistDataConnProfile &bpp);
00089         virtual void SaveTo(PersistDataConnProfile &bpp) const;
00090
00093         virtual DataConnProfile* New() const;
00094
00097         virtual void Assign(const DataConnProfile& from_dcp);
00098
00099     private:
00100         Bit m_bit;
00101         PhoneNumber m_phone_no;
00102         DataCallContext m_context;
00103
00104     public:
00105         struct Persist {
00106             UINT8 m_phone_no[c_max_bcd_number_size];
00107             Bit m_bit;
00108         };
00109 };
00110
00112 #endif  // Apoxi_CsdDataConnProfile_hpp
00113
00114
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConn.cpp File Reference

Socket/DataConn.cpp File Reference

#include "Socket/PreComp.hpp"
#include "DataConn.hpp"
#include "SocketMsg.hpp"
#include "SocketRxThread.hpp"
#include "SocketData.hpp"
#include "SocketSubSystem.hpp"
#include "DataConnProfileManager.hpp"
#include "Sys/ApoxiBsdSocket.h"
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/MsgTypes.hpp>
#include "DataConnManager.hpp"

Include dependency graph for DataConn.cpp:

Generated on Tue Jan 24 23:21:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConn.hpp File Reference

Socket/DataConn.hpp File Reference

#include <Auxiliary/StateMachine.hpp>
#include <Auxiliary/EventData.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/MsgTypes.hpp>
#include <Socket/DataConnProfile.hpp>

Include dependency graph for DataConn.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConn
struct | DataConn::ReleaseEventData
struct | DataConn::SocketEventData

Defines

#define | Apoxi_DataConn_hpp

Define Documentation

#define Apoxi_DataConn_hpp

Generated on Tue Jan 24 23:21:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConn.hpp Source File

Socket/DataConn.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DataConn_hpp)
00011 #define Apoxi_DataConn_hpp
00014
00015 #include <Auxiliary/StateMachine.hpp>
00016 #include <Auxiliary/EventData.hpp>
00017 #include <Kernel/Condition.hpp>
00018 #include <Kernel/MsgTypes.hpp>
00019 #include <Socket/DataConnProfile.hpp>
00020
00021 #if defined(APOXI_COMPAT_1_13_0)
00022     #include <Socket/DataConnManager.hpp>
00023 #endif
00024
00025 class SocketData;
00026
00030 class DataConn : public StateMachine
00031 {
00032     typedef StateMachine Base;
00033
00034     friend class NiSharedPtr<DataConn>;
00035     friend class DataConnManager;
00036     friend class DataConnProfile;
00037
00038     private:
00040         struct SocketEventData : public EventData
00041         {
00042             SocketData &m_sd;
00043             SocketEventData(SocketData &sd);
00044         };
00045
00047         struct ReleaseEventData : public EventData
00048         {
00049             BOOLEAN &m_do_release;
00050             BOOLEAN &m_do_block;
00051             ReleaseEventData(BOOLEAN &do_release, BOOLEAN &do_block);
00052         };
00053
00054     protected:
00057         enum DataConnState {
00058             st_inactive = 0,
00059
00060             st_start_setup,
00061             st_in_setup,
00062             st_set_on_wait_for_setup,
00063             st_check_cancel,
00064             st_set_on_cancel,
00065             st_setup_success,
00066             st_setup_failure,
00067
00068             st_active,
00069             st_idle_timeout,
00070             st_in_hold,
00071             st_reactivate,
00072             st_deactivate,
00073
00074             st_in_trigger_release,
00075             st_start_release,
00076             st_in_release,
00077             st_ignore_setup_req,
00078             st_released,
00079
00080             st_max_states
00081         };
00082
00083     private:
00084         /* State machine state functions for all phases. */
00085
00087         void ST_inactive(EventData *);
00088
00090         void ST_start_setup(EventData /*SocketEventData*/ *);
00091         void ST_in_setup(EventData *);
00092         void ST_set_on_wait_for_setup(EventData /*SocketEventData*/ *);
00093         void ST_check_cancel(EventData /*SocketEventData*/ *);
00094         void ST_set_on_cancel(EventData *);
00095         void ST_setup_success(EventData *);
00096         void ST_setup_failure(EventData *);
00097
00099         void ST_active(EventData *);
00100         void ST_idle_timeout(EventData *);
00101         void ST_in_hold(EventData *);
00102         void ST_reactivate(EventData /*SocketEventData*/ *);
00103         void ST_deactivate(EventData /*SocketEventData*/ *);
00104
00105         // Release phase.
00106         void ST_in_trigger_release(EventData *);
00107         void ST_start_release(EventData /*ReleaseEventData*/ *);
00108         void ST_in_release(EventData *);
00109         void ST_ignore_setup_req(EventData /*SocketEventData*/ *);
00110         void ST_released(EventData *);
00111
00113         BEGIN_STATE_MAP
00114             STATE_MAP_ENTRY(&DataConn::ST_inactive)
00115
00116             STATE_MAP_ENTRY(&DataConn::ST_start_setup)
00117             STATE_MAP_ENTRY(&DataConn::ST_in_setup)
00118             STATE_MAP_ENTRY(&DataConn::ST_set_on_wait_for_setup)
00119             STATE_MAP_ENTRY(&DataConn::ST_check_cancel)
00120             STATE_MAP_ENTRY(&DataConn::ST_set_on_cancel)
00121             STATE_MAP_ENTRY(&DataConn::ST_setup_success)
00122             STATE_MAP_ENTRY(&DataConn::ST_setup_failure)
00123
00124             STATE_MAP_ENTRY(&DataConn::ST_active)
00125             STATE_MAP_ENTRY(&DataConn::ST_idle_timeout)
00126             STATE_MAP_ENTRY(&DataConn::ST_in_hold)
00127             STATE_MAP_ENTRY(&DataConn::ST_reactivate)
00128             STATE_MAP_ENTRY(&DataConn::ST_deactivate)
00129
00130             STATE_MAP_ENTRY(&DataConn::ST_in_trigger_release)
00131             STATE_MAP_ENTRY(&DataConn::ST_start_release)
00132             STATE_MAP_ENTRY(&DataConn::ST_in_release)
00133             STATE_MAP_ENTRY(&DataConn::ST_ignore_setup_req)
00134             STATE_MAP_ENTRY(&DataConn::ST_released)
00135         END_STATE_MAP
00136
00137         enum TimerFlag {
00138             IdleTimeoutFlag     = 1,
00139             TriggerReleaseFlag  = 2
00140         };
00141
00142     private:
00144         const DataConnProfilePtr m_profile;
00145
00146     protected:
00150         DataConn(const DataConnProfilePtr &profile);
00151
00152         virtual ~DataConn();
00153
00154     public:
00163         BOOLEAN Setup(SocketData &sd);
00164
00173         BOOLEAN Release(SocketData &sd);
00174
00180         BOOLEAN Setup();
00181
00191         BOOLEAN Release(BOOLEAN block = FALSE);
00192
00194         DataConnProfilePtr GetProfile() const
00195             { return m_profile; }
00196
00198         DataConnProfile::ProfileType GetProfileType() const
00199             { return m_profile->GetType(); }
00200
00203         void ResetIdleTimer();
00204
00207         BOOLEAN IsConnected() const
00208             { const DataConnState dcs = GetState();
00209               return dcs == st_active || dcs == st_in_hold; }
00210
00213         BOOLEAN IsDisconnected() const
00214             { return !IsConnected(); }
00215
00218         BOOLEAN IsInactive() const
00219             { return GetState() == st_inactive; }
00220
00223         BOOLEAN IsInSetup() const
00224             { return GetState() == st_in_setup; }
00225
00228         BOOLEAN IsActive() const
00229            { return GetState() == st_active; }
00230
00233         BOOLEAN IsInHold() const
00234             { return GetState() == st_in_hold; }
00235
00238         BOOLEAN IsInRelease() const
00239             { const DataConnState dcs = GetState();
00240               return dcs == st_in_trigger_release || dcs == st_in_release; }
00241
00244         BOOLEAN IsCancelled() const;
00245
00249         virtual UINT8 GetNsapi() const;
00250
00254         virtual BOOLEAN GetIpAddress(IpAddr &addr) const = 0;
00255
00259         const IpAddr& GetPrimaryDnsServerAddress() const
00260             { return m_primary_dns_server_address; }
00261
00265         const IpAddr& GetSecondaryDnsServerAddress() const
00266             { return m_secondary_dns_server_address; }
00267
00268 #if defined(APOXI_COMPAT_2_2_0)
00269
00271         const IpAddr& GetDnsServerAddress() const
00272             { return GetPrimaryDnsServerAddress(); }
00273 #endif
00274
00275 #if defined(APOXI_COMPAT_1_13_0)
00276
00278         DataConnManager::DataConnState GetCompatState() const;
00279 #endif
00280
00281     protected:
00282
00284         DataConnState GetState() const;
00285
00287         void SetPrimaryDnsServerAddress(const IpAddr& primary_dns_addr)
00288             { m_primary_dns_server_address = primary_dns_addr; }
00289
00291         void SetSecondaryDnsServerAddress(const IpAddr& secondary_dns_addr)
00292             { m_secondary_dns_server_address = secondary_dns_addr; }
00293
00296         void CheckTimers();
00297
00299         void SetupSucceededEvent();
00300
00302         void SetupFailedEvent(SocketControlMsgType error_msg);
00303
00306         void ReleasedEvent();
00307
00310         void BearerDisconnectedEvent(SocketControlMsgType error_msg);
00311
00317         BOOLEAN WaitForSetup(SocketData &sd);
00318
00319     private:
00323         void IdleTimeoutEvent();
00324
00325     private:
00327         BooleanCondition m_setup_cond;
00329         BooleanCondition m_release_cond;
00330
00331     private:
00332         void SetTimerFlag(TimerFlag flag)
00333             { m_timer_flag |= flag; }
00334
00335         void ClearTimerFlag(TimerFlag flag)
00336             { m_timer_flag &= ~flag; }
00337
00338         BOOLEAN IsTimerFlag(TimerFlag flag)
00339             { return (m_timer_flag & flag) != 0; }
00340
00341     private:
00343         SystemTimer m_idle_timer;
00345         SystemTimer m_linger_timer;
00346
00348         SystemTimer m_release_trigger_timer;
00349
00351         INT m_timer_flag;
00352
00354         IpAddr m_primary_dns_server_address;
00355         IpAddr m_secondary_dns_server_address;
00356
00358         BOOLEAN m_cancel_requested;
00359
00361         SocketData *m_dc_sd;
00362
00363     private:
00371         BOOLEAN EnableIdleTimer();
00372
00374         inline void DisableIdleTimer();
00375
00383         BOOLEAN EnableLingerTimer();
00384
00386         inline void DisableLingerTimer();
00387
00388 #if defined(APOXI_COMPAT_1_13_0)
00389
00390         void ResetLingerTimer(UINT32 value);
00391 #endif
00392
00393         static void IdleTimeoutCallback(void *pDataConn);
00394         static void TriggerReleaseCallback(void *pDataConn);
00395
00396     protected:
00402         virtual BOOLEAN DataConnIsBlocked() const
00403             { return FALSE; }
00404
00410         BOOLEAN CheckCancelRequest(BOOLEAN internal = FALSE);
00411
00416         void InvalidateSockets() const;
00417
00418     protected:
00419         enum MessageType {
00421             mt_data_conn_init = 0,
00423             mt_data_conn_established,
00425             mt_data_conn_setup_failed,
00427             mt_data_conn_init_release,
00429             mt_data_conn_released,
00431             mt_data_conn_setup_blocked
00432         };
00433
00434     protected:
00435         virtual void PostInfoMsg(MessageType type) const = 0;
00436
00439         static void PostSocketControlMsg(SocketData &sd,
00440             SocketControlMsgType control_type);
00441
00447         void PostSocketControlMsg(SocketControlMsgType control_type);
00448
00452         void Init()
00453             { Cleanup(); }
00454
00460         virtual BOOLEAN SetupContext();
00461
00467         virtual BOOLEAN TeardownContext();
00468
00470         virtual void DoSetup() = 0;
00471
00473         virtual void DoRelease() = 0;
00474
00484         virtual BOOLEAN CancelSetup() { return FALSE; }
00485
00487         virtual void Cleanup();
00488
00490         SocketData &GetSocketData() const
00491             { ASSERT_DEBUG(m_dc_sd != 0); return *m_dc_sd; }
00492
00493     private:
00495         void SetSocketData(SocketData *sd);
00496
00502         BOOLEAN IsReferenced(BOOLEAN by_listener = FALSE) const;
00503
00504     protected:
00505         const DataConnProfile& MyProfile() const {
00506             return *m_profile;
00507         }
00508
00509     private:
00511         SocketError m_socket_err;
00514         SocketControlMsgType m_ctrl_err_msg;
00515
00516 #if defined(APOXI_COMPAT_1_13_0)
00517         BOOLEAN m_forced_release;
00518 #endif
00519
00520     private:
00521         friend class DataConnCtrlCbs;
00522
00523     protected:
00524         typedef ContextExecuteMsg::CallbackFn DataConnCtrlCb;
00525         void PostDataConnControlMsg(const DataConnCtrlCb cb);
00526 };
00527
00529 #endif  // Apoxi_DataConn_hpp
00530
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnManager.cpp File Reference

Socket/DataConnManager.cpp File Reference

#include "Socket/PreComp.hpp"
#include "DataConnManager.hpp"
#include "Sys/SysSocket.hpp"
#include "DnsClient.hpp"
#include "DataConn.hpp"
#include "DataConnProfileManager.hpp"

Include dependency graph for DataConnManager.cpp:

Generated on Tue Jan 24 23:21:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnManager.hpp File Reference

Socket/DataConnManager.hpp File Reference

#include <Kernel/Os/Semaphore.hpp>
#include <Socket/DataConnProfile.hpp>
#include <Auxiliary/SimpleMap.hpp>

Include dependency graph for DataConnManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnManager

Defines

#define | Apoxi_DataConnManager_hpp

Define Documentation

#define Apoxi_DataConnManager_hpp

Generated on Tue Jan 24 23:21:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnManager.hpp Source File

Socket/DataConnManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DataConnManager_hpp)
00011 #define Apoxi_DataConnManager_hpp
00014
00015 #include <Kernel/Os/Semaphore.hpp>
00016 #include <Socket/DataConnProfile.hpp>
00017 #include <Auxiliary/SimpleMap.hpp>
00018
00019 #if defined(APOXI_COMPAT_1_13_0)
00020     class DataConn;
00021
00023     #include <Socket/DataConnProfileManager.hpp>
00024     #include <Socket/SerDataConnProfile.hpp>
00025
00027     class SerDataConnProfile;
00028 #endif
00029
00032 class DataConnManager
00033 {
00034     friend class SocketRxThread;
00035
00036     private:
00038         DataConnManager();
00039
00041         DataConnManager(const DataConnManager &);
00042
00044         DataConnManager& operator=(const DataConnManager &);
00045
00047         void Init();
00048
00049     public:
00051         static DataConnManager& Get();
00052
00055         BOOLEAN IsDataConnRegistered(DataConnProfileId id) const;
00056
00065         BOOLEAN RegisterDataConn(DataConnProfileId id);
00066
00075         BOOLEAN UnregisterDataConn(DataConnProfileId id);
00076
00085         const DataConn& GetDataConn(DataConnProfileId id) const;
00086
00095        DataConn& GetDataConn(DataConnProfileId id);
00096
00098         UINT GetDataConnCount() const;
00099
00102         UINT GetDataConnCount(DataConnProfile::ProfileType type) const;
00103
00108         DataConnPtr GetDataConnByIdx(UINT idx) const;
00109
00115         DataConnPtr GetDataConnByIdxAndType(UINT idx,
00116             DataConnProfile::ProfileType type) const;
00117
00118     private:
00120         void CheckDataConnTimers() const;
00121
00122         /* Helper smart-pointer used for unregistering a data connection. */
00123         DataConnPtr m_dc_in_release;
00124
00126         typedef SimpleMap<DataConnProfileId, DataConnPtr> TDataConnMap;
00127
00129         TDataConnMap m_data_connections;
00130
00132         mutable Semaphore m_sem;
00133
00134 #if defined(APOXI_COMPAT_1_13_0)
00135
00136     public:
00143
00145         enum {
00146             c_profile_count = c_data_conn_profile_count,
00147             c_invalid_id = c_invalid_data_conn_profile_id,
00148             c_default_id = c_default_data_conn_profile_id
00149         };
00150
00152         enum DataConnState {
00153             c_data_conn_inactive,
00154             c_data_conn_in_setup,
00155             c_data_conn_in_release,
00156             c_data_conn_in_forced_release,
00157             c_data_conn_in_hold,
00158             c_data_conn_active
00159         };
00160
00161         typedef DataConnProfileManager::ProfileInfo ProfileInfo;
00162         typedef DataConnProfileId ProfileId;
00163         typedef DataConnProfileIdSet ProfileIdSet;
00164
00166         inline static ProfileId GetDefProfileId()
00167             { return DataConnProfileManager::Get().GetDefProfileId(); }
00168
00170         inline static BOOLEAN SetDefProfileId(ProfileId id)
00171             { return DataConnProfileManager::Get().SetDefProfileId(id); }
00172
00174         inline static BOOLEAN GetProfileIdSet(ProfileIdSet &pis)
00175             { return DataConnProfileManager::Get().GetProfileIdSet(pis); }
00176
00178         inline static BOOLEAN AddProfile(DataConnProfile &dcp, BOOLEAN as_default = FALSE) {
00179             BOOLEAN rc = DataConnProfileManager::Get().AddProfile(dcp);
00180             if (rc && as_default)
00181                 rc = DataConnProfileManager::Get().SetDefProfileId(dcp.GetId());
00182             return rc;
00183         }
00184
00186         inline static BOOLEAN SaveProfile(DataConnProfile &dcp, BOOLEAN as_default = FALSE) {
00187             BOOLEAN rc = DataConnProfileManager::Get().SaveProfile(dcp);
00188             if (rc && as_default)
00189                 rc = DataConnProfileManager::Get().SetDefProfileId(dcp.GetId());
00190             return rc;
00191         }
00192
00194         inline static BOOLEAN DeleteProfile(ProfileId id)
00195             { return DataConnProfileManager::Get().DeleteProfile(id); }
00196
00198         inline static BOOLEAN GetProfileInfo(ProfileId id, ProfileInfo &pi)
00199             { return DataConnProfileManager::Get().GetProfileInfo(id, pi); }
00200
00202         inline static BOOLEAN GetProfile(ProfileId id, CsdDataConnProfile &csd)
00203             { return GetProfileOfType(id, csd, DataConnProfile::c_profile_type_csd); }
00204
00206         inline static BOOLEAN GetProfile(ProfileId id, PsdDataConnProfile &psd)
00207             { return GetProfileOfType(id, psd, DataConnProfile::c_profile_type_psd); }
00208
00210         inline static BOOLEAN GetProfile(ProfileId id, SerDataConnProfile &ser)
00211             { return GetProfileOfType(id, ser, DataConnProfile::c_profile_type_ser); }
00212
00214         inline static BOOLEAN ResetToFactoryDefaults()
00215             { return DataConnProfileManager::Get().ResetToFactoryDefaults(); }
00216
00218         inline static BOOLEAN AttachStorage(DataConnProfileStorage *storage)
00219             { return DataConnProfileManager::Get().AttachStorage(storage); }
00220
00222         inline static INT GetCsdDataConnCount()
00223             { return DataConnManager::Get().GetDataConnCount(DataConnProfile::c_profile_type_csd); }
00224
00226         inline static BOOLEAN GetCsdDataConnState(INT idx, ProfileId *id, DataConnState *state)
00227             { return GetDataConnState(idx, id, state, DataConnProfile::c_profile_type_csd); }
00228
00230         inline static INT GetPsdDataConnCount()
00231             { return DataConnManager::Get().GetDataConnCount(DataConnProfile::c_profile_type_psd); }
00232
00234         inline static BOOLEAN GetPsdDataConnState(INT idx, ProfileId *id, DataConnState *state)
00235             { return GetDataConnState(idx, id, state, DataConnProfile::c_profile_type_psd); }
00236
00238         static BOOLEAN GetPsdIpAddress(INT idx, IpAddr &addr);
00239
00241         inline static INT GetSerDataConnCount()
00242             { return DataConnManager::Get().GetDataConnCount(DataConnProfile::c_profile_type_ser); }
00243
00245         inline static BOOLEAN GetSerDataConnState(INT idx, ProfileId *id, DataConnState *state)
00246             { return GetDataConnState(idx, id, state, DataConnProfile::c_profile_type_ser); }
00247
00249         inline static void CsdClose(UINT idx = 0) {
00250             ReleaseNthDataConnOfType(idx, DataConnProfile::c_profile_type_csd);
00251         }
00252
00254         inline static void PsdClose(UINT idx = 0) {
00255             ReleaseNthDataConnOfType(idx, DataConnProfile::c_profile_type_psd);
00256         }
00257
00259         inline static void SerClose(UINT idx = 0) {
00260             ReleaseNthDataConnOfType(idx, DataConnProfile::c_profile_type_ser);
00261         }
00262
00264         inline static UINT32 CsdStatus(UINT idx = 0)
00265             { return GetStatusOfNthDataConnOfType(idx, DataConnProfile::c_profile_type_csd); }
00266
00268         inline static UINT32 PsdStatus(UINT idx = 0)
00269             { return GetStatusOfNthDataConnOfType(idx, DataConnProfile::c_profile_type_psd); }
00270
00272         inline static UINT32 SerStatus(UINT idx = 0)
00273             { return GetStatusOfNthDataConnOfType(idx, DataConnProfile::c_profile_type_ser); }
00274
00276         inline static void SetCsdDetachTimer(UINT32 value, UINT idx = 0)
00277             { SetDetachTimerOfNthDataConnOfType(idx, DataConnProfile::c_profile_type_csd, value); }
00278
00280         inline static void SetPsdDetachTimer(UINT32 value, UINT idx = 0)
00281             { SetDetachTimerOfNthDataConnOfType(idx, DataConnProfile::c_profile_type_psd, value); }
00282
00284         inline static void SetSerDetachTimer(UINT32 value, UINT idx = 0)
00285             { SetDetachTimerOfNthDataConnOfType(idx, DataConnProfile::c_profile_type_ser, value); }
00286
00288         inline static void CheckTimers()
00289             { DataConnManager::Get().CheckTimers(); }
00290
00292         static void DataConnCancel(BOOLEAN cancel);
00293
00295         static BOOLEAN IsDataConnCancelled();
00296
00297     private:
00298         static BOOLEAN GetProfileOfType(ProfileId id, DataConnProfile &dcp,
00299             DataConnProfile::ProfileType type);
00300
00301         static BOOLEAN GetDataConnState(INT idx, ProfileId *id,
00302             DataConnState *state, DataConnProfile::ProfileType type);
00303
00304         static UINT32 GetStatusOfNthDataConnOfType(UINT idx,
00305             DataConnProfile::ProfileType type);
00306
00307         static void SetDetachTimerOfNthDataConnOfType(UINT idx,
00308             DataConnProfile::ProfileType type, UINT32 value);
00309
00310         static void ReleaseNthDataConnOfType(UINT idx,
00311             DataConnProfile::ProfileType type);
00312
00314
00315 #endif
00316
00317 };
00318
00320 #endif  // Apoxi_DataConnManager_hpp
00321
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfile.cpp File Reference

Socket/DataConnProfile.cpp File Reference

#include "Socket/PreComp.hpp"
#include "DataConnProfile.hpp"
#include "PersistDataConnProfile.hpp"
#include "CsdDataConn.hpp"
#include "PsdDataConn.hpp"

Include dependency graph for DataConnProfile.cpp:

Generated on Tue Jan 24 23:21:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfile.hpp File Reference

Socket/DataConnProfile.hpp File Reference

#include <Socket/SocketTypes.hpp>
#include <Auxiliary/WString.hpp>
#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for DataConnProfile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnProfile
struct | DataConnProfile::Bit
struct | DataConnProfile::Persist

Defines

#define | Apoxi_DataConnProfile_hpp

Typedefs

typedef NiSharedPtr< DataConnProfile > | DataConnProfilePtr
typedef NiSharedPtr< DataConn > | DataConnPtr

Define Documentation

#define Apoxi_DataConnProfile_hpp

Generated on Tue Jan 24 23:21:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfile.hpp Source File

Socket/DataConnProfile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DataConnProfile_hpp)
00011 #define Apoxi_DataConnProfile_hpp
00014
00015 #include <Socket/SocketTypes.hpp>
00016 #include <Auxiliary/WString.hpp>
00017 #include <Auxiliary/IpAddr.hpp>
00018 #include <Auxiliary/NiSharedPtr.hpp>
00019
00020 class DataConn;
00021 typedef NiSharedPtr<DataConn> DataConnPtr;
00022
00023 class DataConnProfile;
00024 typedef NiSharedPtr<DataConnProfile> DataConnProfilePtr;
00025
00026 class PersistDataConnProfile;
00027
00029 class DataConnProfile
00030 {
00031     friend class DataConnManager;
00032     friend class DataConnProfileManager;
00033     friend class PersistDataConnProfile;
00034
00035     public:
00036         enum {
00037             c_account_len_max = APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX,
00038             c_passwd_len_max = APOXI_BEARER_PROFILE_PASSWD_LEN_MAX
00039 #if defined(APOXI_COMPAT_1_13_0)
00040             , c_invalid_id = c_invalid_data_conn_profile_id,
00041             c_default_id = c_default_data_conn_profile_id
00042 #endif
00043         };
00044
00045 #if defined(APOXI_COMPAT_1_13_0)
00046         typedef DataConnProfileId Id;
00047 #endif
00048
00049         enum ProfileType {
00050             c_profile_type_psd = 0,
00051             c_profile_type_csd = 1
00052
00053 #if defined(APOXI_SER_DATACONN_SUPPORT) || defined(APOXI_COMPAT_1_13_0)
00054             , c_profile_type_ser = 2
00055 #endif
00056         };
00057
00058         enum TimeoutValue {
00059             c_default_idle_timeout = 120,
00060             c_default_linger_timeout = 30,
00061             c_infinite_timeout = 1023,
00062             c_no_timeout = 0
00063         };
00064
00065         struct Bit {
00066             UINT m_type             : 2;
00067             UINT m_passwd_query     : 1;
00068             UINT m_readonly         : 1;
00069             UINT m_id               : (sizeof(DataConnProfileId) * 8U);
00070             UINT m_idle_timeout     : 10;
00071             UINT m_linger_timeout   : 10;
00072         };
00073
00074     protected:
00075         DataConnProfile(ProfileType type);
00076
00077     public:
00078         virtual ~DataConnProfile();
00079
00081         const WString& GetName() const
00082             { return m_name; }
00083
00086         DataConnProfileId GetId() const
00087             { return m_bit.m_id; }
00088
00091         void SetName(const WString &name)
00092             { m_name = name; }
00093
00095         ProfileType GetType() const
00096             { return (ProfileType)m_bit.m_type; }
00097
00099         BOOLEAN IsReadOnly() const
00100             { return m_bit.m_readonly; }
00101
00103         void SetReadOnly()
00104             { m_bit.m_readonly = TRUE; }
00105
00107         const String& GetAccount() const
00108             { return m_account; }
00109
00112         void SetAccount(const String &account)
00113             { m_account = account; }
00114
00116         const String& GetPasswd() const
00117             { return m_passwd; }
00118
00122         void SetPasswd(const String &passwd)
00123             { m_passwd = passwd; }
00124
00126         BOOLEAN QueryForPasswd() const
00127             { return m_bit.m_passwd_query; }
00128
00130         void EnablePasswdQuery(BOOLEAN enable = TRUE)
00131             { m_bit.m_passwd_query = enable; }
00132
00134         const IpAddr& GetPrimaryDnsServerAddress() const
00135             { return m_primary_dns; }
00136
00138         const IpAddr& GetSecondaryDnsServerAddress() const
00139             { return m_secondary_dns; }
00140
00143         void SetPrimaryDnsServerAddress(const IpAddr &primary_dns)
00144             { m_primary_dns = primary_dns; }
00145
00148         void SetSecondaryDnsServerAddress(const IpAddr &secondary_dns)
00149             { m_secondary_dns = secondary_dns; }
00150
00151 #if defined(APOXI_COMPAT_2_2_0)
00152
00153         const IpAddr& GetDnsAddr() const
00154             { return GetPrimaryDnsServerAddress(); }
00155
00157         void SetDnsAddr(const IpAddr &dns)
00158             { SetPrimaryDnsServerAddress(dns); }
00159 #endif
00160
00161 #if defined(APOXI_COMPAT_1_13_0)
00162
00163         inline UINT GetIdleTimer() const
00164             { return GetIdleTimeout(); }
00165
00167         inline void SetIdleTimer(UINT timeout)
00168             { SetIdleTimeout(timeout); }
00169 #endif
00170
00174         UINT16 GetIdleTimeout() const
00175             { return m_bit.m_idle_timeout; }
00176
00179         void SetIdleTimeout(UINT16 timeout)
00180             { m_bit.m_idle_timeout = timeout; }
00181
00189         UINT16 GetLingerTimeout() const
00190             { return m_bit.m_linger_timeout; }
00191
00194         void SetLingerTimeout(UINT16 timeout)
00195             { m_bit.m_linger_timeout = timeout; }
00196
00197         virtual void SaveFrom(const PersistDataConnProfile &bpp);
00198         virtual void SaveTo(PersistDataConnProfile &bpp) const;
00199
00201         DataConnProfilePtr Clone() const;
00202
00203     protected:
00211         static DataConnPtr CreateDataConn(const DataConnProfilePtr &profile);
00212
00215         virtual DataConnProfile* New() const = 0;
00216
00219         virtual void Assign(const DataConnProfile &from_dcp);
00220
00221     private:
00222         String m_account;
00223         String m_passwd;
00224         WString m_name;
00225         IpAddr m_primary_dns;
00226         IpAddr m_secondary_dns;
00227         Bit m_bit;
00228
00229     public:
00230         struct Persist {
00231             CHAR m_account[c_account_len_max + 1];
00232             CHAR m_passwd[c_passwd_len_max + 1];
00233             WCHAR m_name[c_host_name_len_max + 1];
00234             IpAddr::Persist m_primary_dns;
00235             IpAddr::Persist m_secondary_dns;
00236             Bit m_bit;
00237         };
00238 };
00239
00240 #if defined(APOXI_COMPAT_1_13_0)
00241     #include <Socket/CsdDataConnProfile.hpp>
00242     #include <Socket/PsdDataConnProfile.hpp>
00243     #include <Socket/SerDataConnProfile.hpp>
00244 #endif
00245
00247 #endif  // Apoxi_DataConnProfile_hpp
00248
00249
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfileManager.cpp File Reference

Socket/DataConnProfileManager.cpp File Reference

#include "Socket/PreComp.hpp"
#include "DataConnProfileManager.hpp"
#include "SocketDataLock.hpp"
#include "DnsClient.hpp"
#include "DataConnManager.hpp"
#include "SocketMsg.hpp"
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for DataConnProfileManager.cpp:

Generated on Tue Jan 24 23:21:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfileManager.hpp File Reference

Socket/DataConnProfileManager.hpp File Reference

#include <Socket/DataConnProfile.hpp>
#include <Socket/PersistDataConnProfile.hpp>
#include <Socket/DataConnProfileStorage.hpp>
#include <Auxiliary/SimpleMap.hpp>

Include dependency graph for DataConnProfileManager.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnProfileManager
class | DataConnProfileManager::ProfileInfo
struct | DataConnProfileManager::ProfileInfo::Bit

Defines

#define | Apoxi_DataConnProfileManager_hpp

Define Documentation

#define Apoxi_DataConnProfileManager_hpp

Generated on Tue Jan 24 23:21:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfileManager.hpp Source File

Socket/DataConnProfileManager.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DataConnProfileManager_hpp)
00011 #define Apoxi_DataConnProfileManager_hpp
00014
00015 #include <Socket/DataConnProfile.hpp>
00016 #include <Socket/PersistDataConnProfile.hpp>
00017 #include <Socket/DataConnProfileStorage.hpp>
00018 #include <Auxiliary/SimpleMap.hpp>
00019
00022 class DataConnProfileManager
00023 {
00024     private:
00026         DataConnProfileManager();
00027
00029         DataConnProfileManager(const DataConnProfileManager &);
00030
00032         DataConnProfileManager& operator=(const DataConnProfileManager &);
00033
00034     public:
00037         class ProfileInfo
00038         {
00039             friend class DataConnProfileManager;
00040
00041             public:
00044                 BOOLEAN IsReadOnly() const { return m_bit.m_readonly; }
00045
00048                 BOOLEAN IsTemporary() const { return m_bit.m_temporary; }
00049
00052                 DataConnProfile::ProfileType GetType() const
00053                     { return (DataConnProfile::ProfileType) m_bit.m_type; }
00054
00056                 const WString& GetName() const { return m_name; }
00057
00058             private:
00059
00060                 struct Bit {
00061                     UINT m_type                 : 2;
00062                     UINT m_readonly             : 1;
00063                     UINT m_temporary            : 1;
00064                 };
00065
00066                 Bit m_bit;
00067                 WString m_name;
00068         };
00069
00070     public:
00073         static DataConnProfileManager& Get();
00074
00080         static DataConnProfileId GetCanonicalProfileId(DataConnProfileId id);
00081
00083         BOOLEAN StorageIsAttached() const
00084             { return m_storage != 0; }
00085
00087         DataConnProfileId GetDefProfileId() const;
00088
00090         BOOLEAN SetDefProfileId(DataConnProfileId id);
00091
00094         BOOLEAN GetProfileIdSet(DataConnProfileIdSet &pis) const;
00095
00098         BOOLEAN GetTemporaryProfileIdSet(DataConnTempProfileIdSet &pis) const;
00099
00102         BOOLEAN AddProfile(DataConnProfile &dcp);
00103
00104 #if defined(APOXI_COMPAT_2_0_0)
00105
00108         BOOLEAN AddProfile(DataConnProfile &dcp, BOOLEAN as_default)
00109         {
00110             BOOLEAN rc = AddProfile(dcp);
00111             if (rc && as_default)
00112                 rc = SetDefProfileId(dcp.GetId());
00113             return rc;
00114         }
00115 #endif
00116
00119         BOOLEAN AddTemporaryProfile(DataConnProfile &dcp);
00120
00122         BOOLEAN SaveProfile(const DataConnProfile &dcp);
00123
00124 #if defined(APOXI_COMPAT_2_0_0)
00125
00128         BOOLEAN SaveProfile(const DataConnProfile &dcp, BOOLEAN as_default)
00129         {
00130             BOOLEAN rc = SaveProfile(dcp);
00131             if (rc && as_default)
00132                 rc = SetDefProfileId(dcp.GetId());
00133             return rc;
00134         }
00135 #endif
00136
00138         BOOLEAN DeleteProfile(DataConnProfileId id);
00139
00141         BOOLEAN GetProfileInfo(DataConnProfileId id, ProfileInfo &pi);
00142
00155         DataConnProfilePtr GetProfile(DataConnProfileId &id);
00156
00160         BOOLEAN ResetToFactoryDefaults();
00161
00171         BOOLEAN AttachStorage(DataConnProfileStorage *storage);
00172
00175         BOOLEAN IsTemporaryProfileId(DataConnProfileId id) const;
00176
00182         BOOLEAN UpdateProfile(DataConnProfile &dcp);
00183
00184     private:
00186         mutable DataConnProfileStorage::Header m_header;
00188         mutable PersistDataConnProfile m_cache;
00190         mutable INT m_cache_recno;
00192         mutable SimpleMap<DataConnProfileId, DataConnProfilePtr>
00193             m_temp_profiles;
00195         mutable DataConnProfileId m_last_temp_id;
00196
00198         DataConnProfileStorage *m_storage;
00199
00202         INT GetRecNo(DataConnProfileId id) const;
00203
00207         BOOLEAN ReadProfile(INT recno) const;
00208
00212         BOOLEAN WriteProfile(INT recno);
00213
00216         BOOLEAN ReadProfile(DataConnProfileId id,
00217             PersistDataConnProfile &cache) const;
00218
00234         BOOLEAN GetPersistDataConnProfile(DataConnProfileId &id,
00235             PersistDataConnProfile &persist_profile) const;
00236
00239         BOOLEAN IsInPersistentProfileIdRange(DataConnProfileId id) const;
00240
00243         void PostDataConnProfileInfoMsg(DataConnProfileId id,
00244             DataConnProfileInfoMsgType msg, const WString &name) const;
00245 };
00246
00248 #endif  // Apoxi_DataConnProfileManager_hpp
00249
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfileStorage.cpp File Reference

Socket/DataConnProfileStorage.cpp File Reference

#include "Socket/PreComp.hpp"
#include "DataConnProfileStorage.hpp"
#include "PersistDataConnProfile.hpp"

Include dependency graph for DataConnProfileStorage.cpp:

Generated on Tue Jan 24 23:21:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfileStorage.hpp File Reference

Socket/DataConnProfileStorage.hpp File Reference

#include <Socket/DataConnProfile.hpp>

Include dependency graph for DataConnProfileStorage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnProfileStorage
class | DataConnProfileStorage::Header

Defines

#define | Apoxi_DataConnProfileStorage_hpp

Define Documentation

#define Apoxi_DataConnProfileStorage_hpp

Generated on Tue Jan 24 23:21:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DataConnProfileStorage.hpp Source File

Socket/DataConnProfileStorage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DataConnProfileStorage_hpp)
00011 #define Apoxi_DataConnProfileStorage_hpp
00014
00015 #include <Socket/DataConnProfile.hpp>
00016
00026 class DataConnProfileStorage
00027 {
00028     public:
00032         class Header
00033         {
00034             public:
00035                 enum {
00036                     c_file_version = 1
00037                 };
00038
00039                 UINT8 m_version;
00040                 UINT8 m_rec_max_count;
00041                 UINT8 m_free[10];
00042                 UINT16 m_profile_rec_size;
00043                 DataConnProfileId m_def_profile;
00044                 DataConnProfileId m_last_id;
00045                 DataConnProfileIdSet m_profile_id;
00046
00047                 Header();
00048         };
00049
00053         virtual BOOLEAN Open() { return TRUE; }
00054
00057         virtual void Close() { }
00058
00063         virtual BOOLEAN Read(Header &header) { return FALSE; }
00064
00067         virtual BOOLEAN Write(const Header &header) { return FALSE; }
00068
00072         virtual BOOLEAN Read(INT recno, PersistDataConnProfile &pdcp)
00073             { return FALSE; }
00074
00078         virtual BOOLEAN Write(INT recno, const PersistDataConnProfile &pdcp)
00079             { return FALSE; }
00080
00086         virtual BOOLEAN ResetToFactoryDefaults();
00087 };
00088
00090 #endif  // Apoxi_DataConnProfileStorage_hpp
00091
00092
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DnsClient.cpp File Reference

Socket/DnsClient.cpp File Reference

#include "Socket/PreComp.hpp"
#include "DnsClient.hpp"
#include "DnsClientTypes.hpp"
#include "DataConn.hpp"
#include "DataConnManager.hpp"
#include "DataConnProfileManager.hpp"

Include dependency graph for DnsClient.cpp:

Generated on Tue Jan 24 23:21:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DnsClient.hpp File Reference

Socket/DnsClient.hpp File Reference

#include <Socket/DataConnProfile.hpp>

Include dependency graph for DnsClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DnsClient

Defines

#define | Apoxi_DnsClient_hpp

Define Documentation

#define Apoxi_DnsClient_hpp

Generated on Tue Jan 24 23:21:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DnsClient.hpp Source File

Socket/DnsClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DnsClient_hpp)
00011 #define Apoxi_DnsClient_hpp
00014
00015 #include <Socket/DataConnProfile.hpp>
00016
00017 class SysDnsClient;
00018
00021 class DnsClient
00022 {
00023     friend class SysDnsClient;
00024
00025     public:
00028         static void Init() { }
00029
00032         static void Shutdown() { }
00033
00034 #if defined(APOXI_COMPAT_1_13_0)
00035
00036         inline static void ShutDown() { Shutdown(); }
00037 #endif
00038
00041         static UINT16 GetHostByName(const String &name, IpAddr &ip_addr,
00042             const DataConnProfile *dc_prof = 0);
00043
00046         static UINT16 GetHostByAddr(const IpAddr &ip_addr, String &name,
00047             const DataConnProfile *dc_prof = 0);
00048
00049     public:
00050
00051 #if defined(APOXI_COMPAT_1_13_0)
00052
00053         DnsClient(const DataConnProfile *dc_prof = 0);
00054
00057         DnsClient(const DataConnProfilePtr &dc_prof);
00058 #else
00059
00061         DnsClient(const DataConnProfilePtr &dc_prof = DataConnProfilePtr());
00062 #endif
00063
00065         virtual ~DnsClient();
00066
00071         BOOLEAN GetHostByNameAsync(const String &name);
00072
00077         BOOLEAN GetHostByAddrAsync(const IpAddr &ip_addr);
00078
00079     protected:
00084         virtual void OnNameResponse(const String &name, UINT16 error_no) {};
00085
00090         virtual void OnAddrResponse(const IpAddr &ip_addr, UINT16 error_no) {};
00091
00092     private:
00096         static DataConnPtr ActivateDataConn(DataConnProfileId &dcp_id);
00097
00099         SysDnsClient *m_sys_dns_client;
00100
00102         DataConnPtr m_dc_ptr;
00103
00105         DataConnProfileId m_profile_id;
00106 };
00107
00109 #endif  // Apoxi_DnsClient_hpp
00110
00111
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DnsClientTest.cpp File Reference

Socket/DnsClientTest.cpp File Reference

#include "Socket/PreComp.hpp"
#include "DnsClientTest.hpp"

Include dependency graph for DnsClientTest.cpp:

Generated on Tue Jan 24 23:21:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DnsClientTest.hpp File Reference

Socket/DnsClientTest.hpp File Reference

#include <Socket/DnsClient.hpp>

Include dependency graph for DnsClientTest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DnsClientTest

Defines

#define | Apoxi_DnsClientTest_hpp

Define Documentation

#define Apoxi_DnsClientTest_hpp

Generated on Tue Jan 24 23:21:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DnsClientTest.hpp Source File

Socket/DnsClientTest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_DnsClientTest_hpp)
00011 #define Apoxi_DnsClientTest_hpp
00014
00015 #include <Socket/DnsClient.hpp>
00016
00018 class DnsClientTest : public DnsClient
00019 {
00020     public:
00023         DnsClientTest();
00024
00026         virtual ~DnsClientTest();
00027
00028     protected:
00030         virtual void OnNameResponse(const String & name, UINT16 error_no);
00031
00033         virtual void OnAddrResponse(const IpAddr & ip_addr, UINT16 error_no);
00034 };
00035
00037 #endif //Apoxi_DnsClientTest_hpp
00038
00039
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DnsClientTypes.hpp File Reference

Socket/DnsClientTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_Socket_DnsClientTypes_hpp
#define | EDNSC_ERR 1
#define | EDNSC_OK 0

Define Documentation

#define Apoxi_Socket_DnsClientTypes_hpp

#define EDNSC_ERR 1

#define EDNSC_OK 0

Generated on Tue Jan 24 23:21:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/DnsClientTypes.hpp Source File

Socket/DnsClientTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_Socket_DnsClientTypes_hpp)
00012 #define Apoxi_Socket_DnsClientTypes_hpp
00013
00014 #define EDNSC_OK 0
00015 #define EDNSC_ERR 1  /* Not appropriate DataConnProfile */
00016
00017 #endif
00018
00019
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/InetSocket.cpp File Reference

Socket/InetSocket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketTypes.hpp"
#include "Sys/SysSocket.hpp"
#include "InetSocket.hpp"
#include "SocketDataLock.hpp"
#include "DataConnManager.hpp"
#include "SocketRxThread.hpp"
#include "DataConn.hpp"

Include dependency graph for InetSocket.cpp:

Generated on Tue Jan 24 23:21:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/InetSocket.hpp File Reference

Socket/InetSocket.hpp File Reference

#include <Socket/Socket.hpp>
#include <Socket/SocketData.hpp>

Include dependency graph for InetSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InetSocket

Defines

#define | Apoxi_InetSocket_hpp

Define Documentation

#define Apoxi_InetSocket_hpp

Generated on Tue Jan 24 23:21:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/InetSocket.hpp Source File

Socket/InetSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_InetSocket_hpp)
00011 #define Apoxi_InetSocket_hpp
00014
00015 #include <Socket/Socket.hpp>
00016 #include <Socket/SocketData.hpp>
00017
00021 class InetSocket : public Socket
00022 {
00023     friend class SocketHandler;
00024     friend class TcpServerSocket;
00025
00026     public:
00030         enum Type {
00032             c_type_dgram = SysSocket::c_type_dgram,
00034             c_type_stream = SysSocket::c_type_stream,
00036             c_type_raw = SysSocket::c_type_raw,
00037
00039             c_type_default = c_type_dgram
00040         };
00041
00045         enum ShutdownMode {
00047             c_shutdown_stop_rx = SysSocket::c_shutdown_stop_rx,
00049             c_shutdown_stop_tx = SysSocket::c_shutdown_stop_tx,
00051             c_shutdown_stop_rx_tx = SysSocket::c_shutdown_stop_rx_tx
00052         };
00053
00054         virtual ~InetSocket();
00055
00057         virtual BOOLEAN IsOpen() const { return m_sd != 0; }
00058
00065         SocketError GetError() const
00066             { return m_sd != 0 ? m_sd->GetError() : c_socket_enotsock; }
00067
00069         BOOLEAN Shutdown(ShutdownMode how);
00070
00072         virtual BOOLEAN Close();
00073
00075         BOOLEAN Bind(const InetSocketAddr &addr);
00076
00078         BOOLEAN GetPeer(InetSocketAddr &addr);
00079
00084         BOOLEAN GetLocal(InetSocketAddr &addr);
00085
00087         ExecutionContext* GetOwnerContext() const;
00088
00089         virtual BOOLEAN IsBlocking() const;
00090         virtual BOOLEAN SetBlocking(BOOLEAN block = FALSE);
00091
00095         INT GetInBufByteCount();
00096
00098         BOOLEAN GetSoTypeOption(Type &type);
00099
00101         BOOLEAN GetSoDebugOption(BOOLEAN &dbg) {
00102             return GetBoolOption(SysSocket::c_option_debug, dbg);
00103         }
00104
00106         BOOLEAN SetSoDebugOption(BOOLEAN dbg) {
00107             return SetBoolOption(SysSocket::c_option_debug, dbg);
00108         }
00109
00112         BOOLEAN GetSoReuseAddrOption(BOOLEAN &reuse) {
00113             return GetBoolOption(SysSocket::c_option_reuse_addr, reuse);
00114         }
00115
00118         BOOLEAN SetSoReuseAddrOption(BOOLEAN reuse) {
00119             return SetBoolOption(SysSocket::c_option_reuse_addr, reuse);
00120         }
00121
00123         BOOLEAN GetSoKeepAliveOption(BOOLEAN &keep_alive) {
00124             return GetBoolOption(SysSocket::c_option_keep_alive, keep_alive);
00125         }
00126
00128         BOOLEAN SetSoKeepAliveOption(BOOLEAN keep_alive) {
00129             return SetBoolOption(SysSocket::c_option_keep_alive, keep_alive);
00130         }
00131
00133         BOOLEAN GetSoLingerOption(SysSocket::LingerSetting &linger_setting) {
00134             return SetError(m_sd->GetLingerOption(linger_setting));
00135         }
00136
00138         BOOLEAN SetSoLingerOption(
00139             const SysSocket::LingerSetting &linger_setting)
00140         {
00141             return SetError(m_sd->SetLingerOption(linger_setting));
00142         }
00143
00145         BOOLEAN GetSoDontRouteOption(BOOLEAN &dont_route) {
00146             return GetBoolOption(SysSocket::c_option_dont_route, dont_route);
00147         }
00148
00150         BOOLEAN SetSoDontRouteOption(BOOLEAN dont_route) {
00151             return SetBoolOption(SysSocket::c_option_dont_route, dont_route);
00152         }
00153
00156         BOOLEAN GetSoBroadcastOption(BOOLEAN &broadcast) {
00157             return GetBoolOption(SysSocket::c_option_broadcast, broadcast);
00158         }
00159
00162         BOOLEAN SetSoBroadcastOption(BOOLEAN broadcast) {
00163             return SetBoolOption(SysSocket::c_option_broadcast, broadcast);
00164         }
00165
00168         BOOLEAN GetSoSndBufOption(INT &bufsize) {
00169             return SetError(
00170                 m_sd->GetOption(SysSocket::c_option_snd_buf, bufsize));
00171         }
00172
00175         BOOLEAN SetSoSndBufOption(INT bufsize) {
00176             return SetError(
00177                 m_sd->SetOption(SysSocket::c_option_snd_buf, bufsize));
00178         }
00179
00182         BOOLEAN GetSoRcvBufOption(INT &bufsize) {
00183             return SetError(
00184                 m_sd->GetOption(SysSocket::c_option_rcv_buf, bufsize));
00185         }
00186
00189         BOOLEAN SetSoRcvBufOption(INT bufsize) {
00190             return SetError(
00191                 m_sd->SetOption(SysSocket::c_option_rcv_buf, bufsize));
00192         }
00193
00196         DataConnProfileId GetDataConnProfileId() const;
00197
00202         BOOLEAN SetDataConnProfileId(DataConnProfileId id) const;
00203
00209         BOOLEAN IsDataConnEstablished() const {
00210             return (IsOpen() && m_sd->IsDaCoActive());
00211         }
00212
00222         void SetReadEventNotification(BOOLEAN enable);
00223
00224     protected:
00225         SocketData *m_sd;
00226
00227         BOOLEAN m_read_event_notification;
00228
00229         typedef SysSocket::OptionType OptionType;
00230
00234         void ResetDataConnIdleTimer() const;
00235
00243         virtual void OnAsyncEvent(Event event) { }
00244
00245         virtual void OnControlMsg(const SocketControlMsg &msg) = 0;
00246
00247         BOOLEAN GetBoolOption(OptionType type, BOOLEAN &val);
00248         BOOLEAN SetBoolOption(OptionType type, BOOLEAN val);
00249
00250         BOOLEAN WaitForDataRecv() { return m_sd->WaitForDataRecv(); }
00251         BOOLEAN WaitForDataSent() { return m_sd->WaitForDataSent(); }
00252
00253         BOOLEAN SetError(BOOLEAN ok) {
00254             ASSERT_DEBUG(IsOpen());
00255             return m_sd->SetError(ok);
00256         }
00257
00258         BOOLEAN SetError(SocketError err) {
00259             ASSERT_DEBUG(IsOpen());
00260             return m_sd->SetError(err);
00261         }
00262
00263         BOOLEAN EnsureContext();
00264
00265         SocketData* GetSd() const { return m_sd; }
00266
00267         void Attach(SocketData *sd);
00268         void Detach();
00269
00285         BOOLEAN HandOver(InetSocket &to_socket);
00286
00287         BOOLEAN SetupDataConn();
00288
00289         InetSocket();
00290
00294         BOOLEAN Open(Type type, const InetSocketAddr *local_addr,
00295             BOOLEAN may_reuse_addr);
00296
00303         INT Read(void *buf, INT buflen, InetSocketAddr *from);
00304         virtual INT Read(void *buf, INT buflen) {
00305             return Read(buf, buflen, 0);
00306         }
00307
00315         INT Write(const void *buf, INT buflen, const InetSocketAddr *to);
00316         virtual INT Write(const void *buf, INT buflen) {
00317             return Write(buf, buflen, 0);
00318         }
00319
00320 #ifdef APOXI_SOCKET_OPERATION_LOCK
00321
00325         BOOLEAN m_operation_pending;
00326
00329         class OperationLock {
00330             public:
00333                 OperationLock(BOOLEAN &operation_pending);
00334
00336                 ~OperationLock();
00337
00340                 BOOLEAN LockAcquired() const
00341                     { return m_lock_acquired; }
00342
00343             private:
00344                 // External socket operation pending flag.
00345                 BOOLEAN &m_operation_pending;
00346
00347                 // Flag indicating if the operation lock could be acquired or
00348                 // not.
00349                 BOOLEAN m_lock_acquired;
00350
00351                 // Global operation lock semaphore for all active sockets.
00352                 static Semaphore s_sem;
00353
00354                 // Semaphore initialization flag.
00355                 static BOOLEAN s_sem_init;
00356         };
00357
00358 #endif  // APOXI_SOCKET_OPERATION_LOCK
00359
00360 };
00361
00363 #endif  // Apoxi_InetSocket_hpp
00364
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/InetSocketAddr.cpp File Reference

Socket/InetSocketAddr.cpp File Reference

#include "Socket/PreComp.hpp"
#include "InetSocketAddr.hpp"

Include dependency graph for InetSocketAddr.cpp:

Generated on Tue Jan 24 23:21:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/InetSocketAddr.hpp File Reference

Socket/InetSocketAddr.hpp File Reference

#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/IpPortNo.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for InetSocketAddr.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InetSocketAddr

Defines

#define | Apoxi_InetSocketAddr_hpp

Define Documentation

#define Apoxi_InetSocketAddr_hpp

Generated on Tue Jan 24 23:21:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/InetSocketAddr.hpp Source File

Socket/InetSocketAddr.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_InetSocketAddr_hpp)
00011 #define Apoxi_InetSocketAddr_hpp
00014
00015 #include <Auxiliary/IpAddr.hpp>
00016 #include <Auxiliary/IpPortNo.hpp>
00017 #include <Auxiliary/String.hpp>
00018
00020 class InetSocketAddr
00021 {
00022     public:
00023         InetSocketAddr(const IpAddr &ip = IpAddr(), const IpPortNo &port = IpPortNo());
00024
00025         IpPortNo GetPortNo() const { return m_port; }
00026         void SetPortNo(const IpPortNo &port) { m_port = port; }
00027
00028         IpAddr GetIpAddr() const { return m_addr; }
00029         void SetIpAddr(const IpAddr &ip) { m_addr = ip; }
00030
00031         String Verbose() const;
00032
00033     private:
00034         IpAddr m_addr;
00035         IpPortNo m_port;
00036 };
00037
00039 #endif  // Apoxi_InetSocketAddr_hpp
00040
00041
Generated on Tue Jan 24 14:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/NetAdapterHandler.cpp File Reference

Socket/NetAdapterHandler.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketTypes.hpp"
#include "NetAdapterHandler.hpp"
#include <Kernel/Os/SemObtainer.hpp>
#include <Socket/InetSocketAddr.hpp>

Include dependency graph for NetAdapterHandler.cpp:

Generated on Tue Jan 24 23:21:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/NetAdapterHandler.hpp File Reference

Socket/NetAdapterHandler.hpp File Reference

#include <Kernel/Os/Semaphore.hpp>
#include <Auxiliary/NonCloneable.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/IpPortNo.hpp>
#include <Socket/InetSocketAddr.hpp>
#include <Socket/UdpSocket.hpp>
#include <Socket/TcpSocket.hpp>

Include dependency graph for NetAdapterHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ClientNetAdapter
class | NetAdapter
struct | NetAdapter::DataReceivedEventArgs
struct | NetAdapter::DataSentEventArgs
struct | NetAdapter::EventArgs
class | NetAdapterHandler
class | TcpNetAdapter
class | UdpNetAdapter

Defines

#define | Apoxi_NetAdapterHandler_hpp

Define Documentation

#define Apoxi_NetAdapterHandler_hpp

Generated on Tue Jan 24 23:21:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/NetAdapterHandler.hpp Source File

Socket/NetAdapterHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_NetAdapterHandler_hpp)
00010 #define Apoxi_NetAdapterHandler_hpp
00011
00012 #include <Kernel/Os/Semaphore.hpp>
00013 #include <Auxiliary/NonCloneable.hpp>
00014 #include <Auxiliary/SimpleMap.hpp>
00015 #include <Auxiliary/NiSharedPtr.hpp>
00016 #include <Auxiliary/IpAddr.hpp>
00017 #include <Auxiliary/IpPortNo.hpp>
00018 #include <Socket/InetSocketAddr.hpp>
00019 #include <Socket/UdpSocket.hpp>
00020 #include <Socket/TcpSocket.hpp>
00021
00022 class InetSocket;
00023 class NetAdapterHandler;
00024
00025 class NetAdapter : public NonCloneable {
00026
00027     public:
00029         typedef UINT Id;
00030
00032         enum Type {
00033             c_type_udp,
00034             c_type_tcp
00035         };
00036
00038         enum Event {
00039             c_event_data_sent,
00040             c_event_data_received,
00041             c_event_adapter_closed
00042         };
00043
00045         struct DataSentEventArgs;
00046         struct DataReceivedEventArgs;
00047
00048         struct EventArgs {
00049             virtual const DataSentEventArgs& GetDataSentEventArgs() const
00050             { ASSERT_ALWAYS(FALSE); return static_cast<const DataSentEventArgs&>(*this); };
00051             virtual const DataReceivedEventArgs& GetDataReceivedEventArgs() const
00052             { ASSERT_ALWAYS(FALSE); return static_cast<const DataReceivedEventArgs&>(*this); };
00053         };
00054
00055         struct DataSentEventArgs : public EventArgs {
00056
00057             virtual const DataSentEventArgs& GetDataSentEventArgs() const
00058             { return static_cast<const DataSentEventArgs&>(*this); }
00059
00060             UINT32 m_data_len;
00061         };
00062
00063         struct DataReceivedEventArgs : public EventArgs {
00064
00065             virtual const DataReceivedEventArgs& GetDataReceivedEventArgs() const
00066             { return static_cast<const DataReceivedEventArgs&>(*this); }
00067
00068             UINT32 m_data_len;
00069             UINT8* m_buffer;
00070             InetSocketAddr m_recv_from;
00071         };
00072
00073     public:
00074         NetAdapter(
00075             NetAdapterHandler* handler,
00076             Id id,
00077             Type type);
00078
00079         Id GetId() const {
00080             return m_id;
00081         }
00082
00083         Type GetType() const {
00084             return m_type;
00085         }
00086
00087     protected:
00088         NetAdapterHandler* m_handler;
00089         Id  m_id;
00090         Type m_type;
00091         // ToDo: Add this to all constructors.
00092         // BOOLEAN  m_is_server;
00093 };
00094
00096
00097 class NetAdapterHandler : public NonCloneable {
00098
00099     friend class NetAdapter;
00100     friend class ClientNetAdapter;
00101
00102     public:
00103         typedef NiSharedPtr<NetAdapter> NetAdapterPtr;
00104
00106         typedef void (*NetAdapterHandlerCallback)(void* client_arg,
00107             NetAdapterHandler &handler, NetAdapter &net_adapter,
00108             NetAdapter::Event event, const NetAdapter::EventArgs &event_args);
00109
00111         NetAdapterHandler(NetAdapterHandlerCallback callback, void* client_arg, UINT32 recv_buffer_size = 512);
00112
00114         ~NetAdapterHandler();
00115
00116         NetAdapter::Id OpenClientNetAdapter(DataConnProfileId dc_id,
00117             NetAdapter::Type net_adapter_type,
00118             const IpAddr& remote_address, const IpPortNo& remote_port, IpPortNo* local_port = 0);
00119
00120         NetAdapter::Id OpenServerNetAdapter(DataConnProfileId dc_id,
00121             NetAdapter::Type net_adapter_type,
00122             const IpPortNo& local_port);
00123
00124         BOOLEAN Send(NetAdapter::Id id, const UINT8* buffer, UINT32 len, InetSocketAddr *to = 0)
00125             const;
00126
00127         NetAdapterPtr GetNetAdapter(NetAdapter::Id id) const;
00128
00129         // Closes the given NetAdapter.
00130         BOOLEAN CloseNetAdapter(NetAdapter::Id id);
00131
00132         // Closes all NetAdapters.
00133         void CloseAllNetAdapters();
00134
00136         static UINT GetInvalidNetAdapterId() { return static_cast<UINT>(-1); }
00137
00138     protected:
00139
00141         // Application overrides
00142
00143         virtual void OnDataReceived(NetAdapter &netadapter, const NetAdapter::DataReceivedEventArgs& args)
00144             { InvokeCallBack(netadapter, NetAdapter::c_event_data_received, args); }
00145
00146         virtual void OnDataSent(NetAdapter &netadapter, const NetAdapter::DataSentEventArgs& args)
00147             { InvokeCallBack(netadapter, NetAdapter::c_event_data_sent, args); }
00148
00149         virtual void OnNetAdapterClosed(NetAdapter &netadapter)
00150             { InvokeCallBack(netadapter, NetAdapter::c_event_adapter_closed); }
00151
00153
00154     private:
00155
00157         NetAdapterPtr CreateNetAdapter(NetAdapter::Type type);
00158
00159         void InvokeCallBack(NetAdapter &net_adapter, NetAdapter::Event event,
00160             const NetAdapter::EventArgs &args = NetAdapter::EventArgs());
00161
00162         NetAdapter::Id OpenNetAdapter(DataConnProfileId dc_id,
00163             NetAdapter::Type net_adapter_type, const IpAddr& remote_address,
00164             const IpPortNo& remote_port, IpPortNo* local_port, BOOLEAN is_server);
00165
00166         BOOLEAN OpenNetAdapter(
00167             NetAdapterPtr net_adapter, DataConnProfileId dc_id,
00168             const IpAddr& remote_address, const IpPortNo& remote_port,
00169             IpPortNo* local_port, BOOLEAN is_server);
00170
00172         void* m_client_arg;
00173
00176         NetAdapterHandlerCallback m_callback;
00177
00179         mutable Semaphore m_map_sem;
00180
00182         typedef SimpleMap<NetAdapter::Id, NetAdapterPtr> NetAdapterMap;
00183         NetAdapterMap m_net_adapter_map;
00184
00186         const UINT32 m_recv_buffer_size;
00187 };
00188
00190
00191 class ClientNetAdapter : public NetAdapter {
00192     typedef NetAdapter Base;
00193
00194     public:
00195         ClientNetAdapter(
00196             NetAdapterHandler* handler,
00197             NetAdapter::Id id,
00198             NetAdapter::Type type);
00199
00200         virtual ~ClientNetAdapter();
00201
00202         virtual BOOLEAN Send(const UINT8* data, UINT32 len, InetSocketAddr *to = 0);
00203         void HandleOnAsyncEvent(InetSocket::Event event);
00204
00205         virtual INT Read(void *buf, INT buflen, InetSocketAddr *from = 0) = 0;
00206         virtual INT Write(const void *buf, INT buflen, InetSocketAddr *to = 0) = 0;
00207         virtual INT GetInBufByteCount() = 0;
00208         virtual SocketError GetError() const = 0;
00209
00210     protected:
00212         UINT8* m_recv_buffer;
00213
00215         UINT8* m_send_buffer;
00216         UINT32 m_send_buffer_size;
00217         UINT32 m_send_buffer_offset;
00218         UINT32 m_data_sent;
00219
00221         Semaphore m_send_sem;
00222 };
00223
00226 class UdpNetAdapter : public UdpSocket, public ClientNetAdapter {
00227
00228     typedef UdpSocket Base;
00229
00230     public:
00231         UdpNetAdapter(
00232             NetAdapterHandler* handler,
00233             NetAdapter::Id id,
00234             NetAdapter::Type type);
00235
00236         virtual INT Read(void *buf, INT buflen, InetSocketAddr *from = 0)
00237         { return Base::Read(buf, buflen, from); }
00238
00239         virtual INT Write(const void *buf, INT buflen, InetSocketAddr *to = 0)
00240         { return Base::Write(buf, buflen, to);  }
00241
00242         virtual INT GetInBufByteCount()
00243         { return Base::GetInBufByteCount(); }
00244
00245         virtual SocketError GetError() const
00246         { return Base::GetError(); }
00247
00248     protected:
00250         virtual void OnAsyncEvent(InetSocket::Event event)
00251         { ClientNetAdapter::HandleOnAsyncEvent(event); }
00252 };
00253
00256 class TcpNetAdapter : public TcpSocket, public ClientNetAdapter {
00257
00258     typedef TcpSocket Base;
00259
00260     public:
00261         TcpNetAdapter(
00262             NetAdapterHandler* handler,
00263             NetAdapter::Id id,
00264             NetAdapter::Type type);
00265
00266         virtual INT Read(void *buf, INT buflen, InetSocketAddr *from = 0)
00267         { return Base::Read(buf, buflen); }
00268
00269         virtual INT Write(const void *buf, INT buflen, InetSocketAddr *to = 0)
00270         { return Base::Write(buf, buflen);  }
00271
00272         virtual INT GetInBufByteCount()
00273         { return Base::GetInBufByteCount(); }
00274
00275         virtual SocketError GetError() const
00276         { return Base::GetError(); }
00277
00278     protected:
00280         virtual void OnAsyncEvent(InetSocket::Event event)
00281         { ClientNetAdapter::HandleOnAsyncEvent(event); }
00282 };
00283
00284 #endif   // Apoxi_NetAdapterHandler_hpp
00285
Generated on Tue Jan 24 14:50:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PersistDataConnProfile.cpp File Reference

Socket/PersistDataConnProfile.cpp File Reference

#include "Socket/PreComp.hpp"
#include "PersistDataConnProfile.hpp"

Include dependency graph for PersistDataConnProfile.cpp:

Generated on Tue Jan 24 23:21:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PersistDataConnProfile.hpp File Reference

Socket/PersistDataConnProfile.hpp File Reference

#include <Socket/CsdDataConnProfile.hpp>
#include <Socket/PsdDataConnProfile.hpp>

Include dependency graph for PersistDataConnProfile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PersistDataConnProfile

Defines

#define | Apoxi_PersistDataConnProfile_hpp

Define Documentation

#define Apoxi_PersistDataConnProfile_hpp

Generated on Tue Jan 24 23:21:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PersistDataConnProfile.hpp Source File

Socket/PersistDataConnProfile.hpp

Go to the documentation of this file.
00001  /*    ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PersistDataConnProfile_hpp)
00011 #define Apoxi_PersistDataConnProfile_hpp
00014
00015 #include <Socket/CsdDataConnProfile.hpp>
00016 #include <Socket/PsdDataConnProfile.hpp>
00017
00021 class PersistDataConnProfile
00022 {
00023     friend class DataConnProfile;
00024     friend class CsdDataConnProfile;
00025     friend class PsdDataConnProfile;
00026     friend class DataConnProfileManager;
00027
00028     public:
00029         PersistDataConnProfile()
00030             { memset(this, 0, sizeof(*this)); }
00031
00038         DataConnProfilePtr CreateDataConnProfile() const;
00039
00040     private:
00041         UINT8 m_free[8];
00042         DataConnProfile::Persist m_common;
00043
00044         union {
00045             CsdDataConnProfile::Persist m_csd_data;
00046             PsdDataConnProfile::Persist m_psd_data;
00047         } m_data;
00048 };
00049
00051 #endif  // Apoxi_PersistDataConnProfile_hpp
00052
00053
Generated on Tue Jan 24 14:50:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PppDataConn.cpp File Reference

Socket/PppDataConn.cpp File Reference

#include "Socket/PreComp.hpp"
#include "PppDataConn.hpp"
#include "Sys/SysSocket.hpp"
#include "Sys/SysSocketBase.hpp"

Include dependency graph for PppDataConn.cpp:

Generated on Tue Jan 24 23:21:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PppDataConn.hpp File Reference

Socket/PppDataConn.hpp File Reference

#include <Socket/DataConn.hpp>

Include dependency graph for PppDataConn.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PppDataConn

Defines

#define | Apoxi_PppDataConn_hpp

Define Documentation

#define Apoxi_PppDataConn_hpp

Generated on Tue Jan 24 23:21:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PppDataConn.hpp Source File

Socket/PppDataConn.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PppDataConn_hpp)
00011 #define Apoxi_PppDataConn_hpp
00014
00015 #include <Socket/DataConn.hpp>
00016
00017 struct PppCallBackData;
00018 struct PppSetupCallBackData;
00019
00021 class PppDataConn : public DataConn
00022 {
00023     typedef DataConn Base;
00024
00025     protected:
00029         PppDataConn(const DataConnProfilePtr &profile);
00030
00031         virtual ~PppDataConn();
00032
00033     protected:
00034         virtual void DoSetup()
00035             { OnBeforePppSetup(); }
00036
00042         virtual void OnBeforePppSetup()
00043             { DoStartPppSetup(); }
00044
00048         void DoStartPppSetup();
00049
00050         virtual void DoRelease()
00051             { DoStartPppRelease(); }
00052
00053         virtual BOOLEAN CancelSetup();
00054
00058         void DoStartPppRelease();
00059
00064         virtual void OnAfterPppRelease()
00065             { ReleasedEvent(); }
00066
00071         void OnPppSetup(INT error, const PppSetupCallBackData* data);
00072
00075         void OnPppStop(INT error);
00076
00077         void ReleasePPP();
00078
00079         virtual void Cleanup();
00080
00085         virtual BOOLEAN GetIpAddress(IpAddr &addr) const;
00086
00087     private:
00089         IpAddr m_ip_address;
00090
00091     private:
00092         static void PppSetupCallbackHandler(INT error, PppDataConn &dc,
00093             const PppCallBackData *data);
00094         static void PppStopCallbackHandler(INT error, PppDataConn &dc,
00095             const PppCallBackData *data);
00096 };
00097
00099 #endif  // Apoxi_PppDataConn_hpp
00100
Generated on Tue Jan 24 14:50:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PreComp.cpp File Reference

Socket/PreComp.cpp File Reference

#include "Socket/PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:08:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PreComp.hpp File Reference

Socket/PreComp.hpp File Reference

#include <Kernel/Os/Win32/Win32.hpp>
#include <Kernel/Types.hpp>
#include <Kernel/Allocator.hpp>
#include <Kernel/Condition.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/Message.hpp>
#include <Kernel/MessageRouter.hpp>
#include <Kernel/Os/Mutex.hpp>
#include <Kernel/Os/MutexObtainer.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include <Kernel/Os/Semaphore.hpp>
#include <Kernel/SubSystem.hpp>
#include <Kernel/System.hpp>
#include <Kernel/Timer.hpp>
#include <Kernel/UserDispatcher.hpp>
#include <Auxiliary/EventData.hpp>
#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/IpPortNo.hpp>
#include <Auxiliary/Macros.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/SimpleMap.hpp>
#include <Auxiliary/StateMachine.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/TriggerTimer.hpp>
#include <Auxiliary/WString.hpp>
#include <Adc/DataHandler.hpp>
#include <Asc/DataCallContext.hpp>
#include <Asc/DataCallControl.hpp>
#include <Asc/DataCallHdl.hpp>
#include <Asc/PdpContext.hpp>
#include <Asc/PdpContextControl.hpp>
#include <Asc/PdpContextManager.hpp>
#include <Asc/Types.hpp>
#include <Socket/CsdDataConnProfile.hpp>
#include <Socket/DataConn.hpp>
#include <Socket/DataConnManager.hpp>
#include <Socket/DataConnProfile.hpp>
#include <Socket/DataConnProfileManager.hpp>
#include <Socket/DataConnProfileStorage.hpp>
#include <Socket/DnsClient.hpp>
#include <Socket/InetSocket.hpp>
#include <Socket/PersistDataConnProfile.hpp>
#include <Socket/PppDataConn.hpp>
#include <Socket/PsdDataConnProfile.hpp>
#include <Socket/SerDataConnProfile.hpp>
#include <Socket/SocketData.hpp>
#include <Socket/SocketRxThread.hpp>
#include <Socket/SocketSubSystem.hpp>
#include <Socket/SocketTypes.hpp>
#include <Socket/Sys/SysSocket.hpp>
#include <Socket/Sys/SysSocketBase.hpp>
#include <Socket/TcpSocketBase.hpp>
#include <Socket/UdpSocket.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:22:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PreComp.hpp Source File

Socket/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if defined(APOXI_RTOS_WIN32)
00010     #include <Kernel/Os/Win32/Win32.hpp>
00011 #endif
00012
00013 #include <Kernel/Types.hpp>
00014 #include <Kernel/Allocator.hpp>
00015 #include <Kernel/Condition.hpp>
00016 #include <Kernel/ExecutionContext.hpp>
00017 #include <Kernel/Message.hpp>
00018 #include <Kernel/MessageRouter.hpp>
00019 #include <Kernel/Os/Mutex.hpp>
00020 #include <Kernel/Os/MutexObtainer.hpp>
00021 #include <Kernel/Os/SemObtainer.hpp>
00022 #include <Kernel/Os/Semaphore.hpp>
00023 #include <Kernel/SubSystem.hpp>
00024 #include <Kernel/System.hpp>
00025 #include <Kernel/Timer.hpp>
00026 #include <Kernel/UserDispatcher.hpp>
00027
00028 #include <Auxiliary/EventData.hpp>
00029 #include <Auxiliary/IpAddr.hpp>
00030 #include <Auxiliary/IpPortNo.hpp>
00031 #include <Auxiliary/Macros.hpp>
00032 #include <Auxiliary/NiSharedPtr.hpp>
00033 #include <Auxiliary/PhoneNumber.hpp>
00034 #include <Auxiliary/SimpleMap.hpp>
00035 #include <Auxiliary/StateMachine.hpp>
00036 #include <Auxiliary/String.hpp>
00037 #include <Auxiliary/TriggerTimer.hpp>
00038 #include <Auxiliary/WString.hpp>
00039
00040 #include <Adc/DataHandler.hpp>
00041 #include <Asc/DataCallContext.hpp>
00042 #include <Asc/DataCallControl.hpp>
00043 #include <Asc/DataCallHdl.hpp>
00044 #include <Asc/PdpContext.hpp>
00045 #include <Asc/PdpContextControl.hpp>
00046 #include <Asc/PdpContextManager.hpp>
00047 #include <Asc/Types.hpp>
00048 #include <Socket/CsdDataConnProfile.hpp>
00049 #include <Socket/DataConn.hpp>
00050 #include <Socket/DataConnManager.hpp>
00051 #include <Socket/DataConnProfile.hpp>
00052 #include <Socket/DataConnProfileManager.hpp>
00053 #include <Socket/DataConnProfileStorage.hpp>
00054 #include <Socket/DnsClient.hpp>
00055 #include <Socket/InetSocket.hpp>
00056 #include <Socket/PersistDataConnProfile.hpp>
00057 #include <Socket/PppDataConn.hpp>
00058 #include <Socket/PsdDataConnProfile.hpp>
00059 #include <Socket/SerDataConnProfile.hpp>
00060 #include <Socket/SocketData.hpp>
00061 #include <Socket/SocketRxThread.hpp>
00062 #include <Socket/SocketSubSystem.hpp>
00063 #include <Socket/SocketTypes.hpp>
00064 #include <Socket/Sys/SysSocket.hpp>
00065 #include <Socket/Sys/SysSocketBase.hpp>
00066 #include <Socket/TcpSocketBase.hpp>
00067 #include <Socket/UdpSocket.hpp>
00068
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PsdDataConn.cpp File Reference

Socket/PsdDataConn.cpp File Reference

#include "Socket/PreComp.hpp"
#include "PsdDataConn.hpp"
#include "Sys/SysSocket.hpp"
#include "SocketMsg.hpp"
#include "PsdDataConnProfile.hpp"
#include <Adc/DataHandler.hpp>
#include <Asc/Types.hpp>
#include <Socket/DataConnManager.hpp>
#include <Kernel/ExecutionContext.hpp>
#include <Kernel/System.hpp>

Include dependency graph for PsdDataConn.cpp:

Defines

#define RESPONSE_TRACE(pdp_err, success_msg, failure_msg)

Define Documentation

#define RESPONSE_TRACE | ( | pdp_err,
 |  | success_msg,
 |  | failure_msg | )

Value:

if (pdp_err == PdpContext::NoError) {                                   \
        SocketTrace((c_socket_data_conn_trace_no, success_msg));            \
    }                                                                       \
    else {                                                                  \
        SocketTrace((c_socket_data_conn_trace_no, failure_msg, pdp_err));   \
    }

Generated on Tue Jan 24 23:21:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PsdDataConn.hpp File Reference

Socket/PsdDataConn.hpp File Reference

#include <Socket/DataConn.hpp>
#include <Asc/PdpContextControl.hpp>
#include <Asc/PdpContextManager.hpp>

Include dependency graph for PsdDataConn.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PsdDataConn

Defines

#define | Apoxi_PsdDataConn_hpp

Define Documentation

#define Apoxi_PsdDataConn_hpp

Generated on Tue Jan 24 23:21:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PsdDataConn.hpp Source File

Socket/PsdDataConn.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PsdDataConn_hpp)
00011 #define Apoxi_PsdDataConn_hpp
00014
00015 #include <Socket/DataConn.hpp>
00016 #include <Asc/PdpContextControl.hpp>
00017 #include <Asc/PdpContextManager.hpp>
00018
00019 class PsdDataConnProfile;
00020 class IpAddr;
00021
00022 class PsdDataConn : public DataConn, public PdpContextControl
00023 {
00024     typedef DataConn Base;
00025
00026     friend class NiSharedPtr<DataConn>;
00027     friend class DataConnProfile;
00028
00029     public:
00030         virtual void OnDefineCompleted(PdpContext::ErrorCause cause);
00031         virtual void OnUndefineCompleted(PdpContext::ErrorCause cause);
00032         virtual void OnAuthenticateCompleted(PdpContext::ErrorCause cause);
00033         virtual void OnSetQualityOfServiceCompleted(
00034             PdpContext::ErrorCause cause);
00035         virtual void OnDeactivateCompleted(PdpContext::ErrorCause cause);
00036         virtual void OnConnectCompleted(PdpContext::ErrorCause cause);
00037
00038         virtual void OnDeactivateIndication(PdpContext::ErrorCause cause,
00039             PdpContext::Origin origin = PdpContext::UnknownOrigin);
00040
00041         virtual void OnSetPacketFilterCompleted(PdpContext::ErrorCause cause);
00042
00043         virtual void OnSetCounterCompleted(PdpContext::ErrorCause cause);
00044         virtual void OnReadCounterCompleted(PdpContext::ErrorCause cause);
00045
00046         virtual void OnSetAutomaticDnsServerNegotiationCompleted(
00047             PdpContext::ErrorCause cause);
00048         virtual void OnReadNegotiatedDnsServerAddressCompleted(
00049             PdpContext::ErrorCause cause);
00050
00051         virtual void OnPsdLinkUpCompleted(INT error);
00052         virtual void OnPsdLinkDownCompleted(INT error);
00053
00055         BOOLEAN GetDataCounters(UINT32 &session_sent, UINT32 &session_received,
00056             UINT32 &total_sent, UINT32 &total_received) const;
00057
00060         BOOLEAN SetDataCounters(UINT32 total_sent = 0, UINT32 total_received = 0);
00061
00065         virtual UINT8 GetNsapi() const;
00066
00072         virtual BOOLEAN GetIpAddress(IpAddr &addr) const;
00073
00074 #if defined(APOXI_COMPAT_2_2_0)
00075
00077         BOOLEAN GetIpAddr(IpAddr &addr) const {
00078             return GetIpAddress(addr);
00079         }
00080 #endif
00081
00082     protected:
00083         PdpContext *m_pdp_context;
00084         PdpContext::ErrorCause m_pdp_error;
00085
00086         BOOLEAN m_context_defined;
00087         BOOLEAN m_context_active;
00088         BOOLEAN m_psd_linked_up;
00089
00090     protected:
00094         PsdDataConn(const DataConnProfilePtr &profile);
00095
00096         virtual ~PsdDataConn();
00097
00098     protected:
00099         virtual BOOLEAN DataConnIsBlocked() const;
00100
00101         virtual void PostInfoMsg(MessageType type) const;
00102
00103         virtual void DoSetup()
00104             { CreatePdpContext(); }
00105
00106         void OnSetupResponse(PdpContext::ErrorCause cause,
00107             SocketControlMsgType success_scmt,
00108             DataConnCtrlCb on_success_callback);
00109
00110         void OnReleaseResponse(PdpContext::ErrorCause cause,
00111             SocketControlMsgType success_scmt,
00112             DataConnCtrlCb on_release_callback);
00113
00114         void CreatePdpContext();
00115         void DefinePdpContext();
00116         void SetAutomaticDnsServerNegotiation();
00117         void SetPacketFilter();
00118         void SetQualityOfService();
00119         void Authenticate();
00120         void Connect();
00121         void ReadNegotiatedDnsServerAddress();
00122         void LinkUp();
00123         void DeactivateContext();
00124         void LinkDown();
00125         void UndefineContext();
00126
00127         virtual void DoRelease();
00128
00129         virtual void Cleanup();
00130
00131     protected:
00132         const PsdDataConnProfile& MyProfile() const {
00133             return (const PsdDataConnProfile &)Base::MyProfile();
00134         }
00135
00136     private:
00137         friend class PsdDataConnCtrlCbs;
00138
00139         void PostDataConnInfoMsg(DataConnInfoMsgType msg,
00140             PdpContext::ErrorCause pdp_err) const;
00141
00142         mutable Semaphore m_data_counters_sem;
00143         mutable BooleanCondition m_data_counters_condition;
00144         PdpContextManager::DataCounters m_data_counters;
00146         UINT8 m_nsapi_linked_up;
00147
00149         UINT8 m_cur_packet_filter_id;
00150
00151      private:
00152         static void PsdIfStartCallbackHandler(INT error, void *client_arg);
00153         static void PsdIfStopCallbackHandler(INT error, void *client_arg);
00154 };
00155
00157 #endif  // Apoxi_PsdDataConn_hpp
00158
00159
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PsdDataConnProfile.cpp File Reference

Socket/PsdDataConnProfile.cpp File Reference

#include "Socket/PreComp.hpp"
#include "PsdDataConnProfile.hpp"
#include "PersistDataConnProfile.hpp"
#include "PsdDataConn.hpp"
#include "DataConnProfileManager.hpp"

Include dependency graph for PsdDataConnProfile.cpp:

Generated on Tue Jan 24 23:21:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PsdDataConnProfile.hpp File Reference

Socket/PsdDataConnProfile.hpp File Reference

#include <Socket/DataConnProfile.hpp>
#include <Asc/PdpContext.hpp>
#include <Auxiliary/NiSharedPtr.hpp>

Include dependency graph for PsdDataConnProfile.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PsdDataConnProfile
struct | PsdDataConnProfile::Bit
struct | PsdDataConnProfile::Persist

Defines

#define | Apoxi_PsdDataConnProfile_hpp

Typedefs

typedef NiSharedPtr< PdpContext::PacketFilter > | PdpPacketFilterPtr

Define Documentation

#define Apoxi_PsdDataConnProfile_hpp

Generated on Tue Jan 24 23:21:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/PsdDataConnProfile.hpp Source File

Socket/PsdDataConnProfile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_PsdDataConnProfile_hpp)
00011 #define Apoxi_PsdDataConnProfile_hpp
00014
00015 #include <Socket/DataConnProfile.hpp>
00016 #include <Asc/PdpContext.hpp>
00017 #include <Auxiliary/NiSharedPtr.hpp>
00018
00019 typedef NiSharedPtr<PdpContext::PacketFilter> PdpPacketFilterPtr;
00020
00023 class PsdDataConnProfile : public DataConnProfile
00024 {
00025     typedef DataConnProfile Base;
00026
00027     public:
00028         typedef PdpContext::Authentication::Type AuthType;
00029         typedef PdpContext::QualityOfService::Precedence QosPrecedence;
00030         typedef PdpContext::QualityOfService::Delay QosDelay;
00031         typedef PdpContext::QualityOfService::Reliability QosReliability;
00032         typedef PdpContext::QualityOfService::PeakRate QosPeakRate;
00033         typedef PdpContext::QualityOfService::MeanRate QosMeanRate;
00034
00035         struct Bit {
00036             UINT m_auth_type                : 2;
00037             UINT m_data_compr               : 1;
00038             UINT m_header_compr             : 1;
00039             UINT m_qos_precedence           : 2;
00040             UINT m_qos_delay                : 3;
00041             UINT m_qos_reliability          : 3;
00042             UINT m_qos_peak_rate            : 4;
00043             UINT m_qos_mean_rate            : 5;
00044 #if defined(APOXI_RAT_UMTS) || defined(APOXI_RAT_DUAL)
00045             UINT m_present_3g               : 1;
00046             UINT m_traffic_class            : 8;
00047             UINT m_delivery_order           : 8;
00048             UINT m_error_sdu_delivery       : 8;
00049             UINT m_max_sdu_size             : 8;
00050             UINT m_max_bit_rate_up          : 8;
00051             UINT m_max_bit_rate_down        : 8;
00052             UINT m_residual_ber             : 8;
00053             UINT m_sdu_error_ratio          : 8;
00054             UINT m_transfer_delay           : 8;
00055             UINT m_traffic_priority         : 8;
00056             UINT m_guaranteed_bit_rate_up   : 8;
00057             UINT m_guaranteed_bit_rate_down : 8;
00058 #endif  // APOXI_RAT_UMTS || APOXI_RAT_DUAL
00059         };
00060
00061     public:
00062         PsdDataConnProfile();
00063         virtual ~PsdDataConnProfile();
00064
00066         const String& GetApnName() const
00067             { return m_apn; }
00068
00071         void SetApnName(const String &apn)
00072             { m_apn = apn; }
00073
00077         const IpAddr& GetLocalAddr() const
00078             { return m_local; }
00079
00082         void SetLocalAddr(const IpAddr &local)
00083             { m_local = local; }
00084
00086         AuthType GetAuthType() const
00087             { return (AuthType)m_bit.m_auth_type; }
00088
00090         void SetAuthType(AuthType at)
00091             { m_bit.m_auth_type = at; }
00092
00095         BOOLEAN DoDataCompr() const
00096             { return m_bit.m_data_compr; }
00097
00099         void EnableDataCompr(BOOLEAN enable = TRUE)
00100             { m_bit.m_data_compr = enable; }
00101
00104         BOOLEAN DoHeaderCompr() const
00105             { return m_bit.m_header_compr; }
00106
00108         void EnableHeaderCompr(BOOLEAN enable = TRUE)
00109             { m_bit.m_header_compr = enable; }
00110
00117         BOOLEAN SetPrimaryProfileId(DataConnProfileId profile_id);
00118
00124         DataConnProfileId GetPrimaryProfileId() const
00125             { return m_primary_id; }
00126
00132         BOOLEAN UsesSecondaryPdpContext() const {
00133             return GetPrimaryProfileId() != c_invalid_data_conn_profile_id;
00134         }
00135
00143         BOOLEAN SetPacketFilter(const PdpPacketFilterPtr &filter);
00144
00150         BOOLEAN UnsetPacketFilter(UINT8 id);
00151
00155         PdpPacketFilterPtr GetPacketFilter(UINT8 id) const;
00156
00157         QosPrecedence GetQosPrecedence() const
00158             { return (QosPrecedence)m_bit.m_qos_precedence; }
00159         void SetQosPrecedence(QosPrecedence qp)
00160             { m_bit.m_qos_precedence = qp; }
00161
00162         QosDelay GetQosDelay() const
00163             { return (QosDelay)m_bit.m_qos_delay; }
00164         void SetQosDelay(QosDelay qd)
00165             { m_bit.m_qos_delay = qd; }
00166
00167         QosReliability GetQosReliability() const
00168             { return (QosReliability)m_bit.m_qos_reliability; }
00169         void SetQosReliability(QosReliability qr)
00170             { m_bit.m_qos_reliability = qr; }
00171
00172         QosPeakRate GetQosPeakRate() const
00173             { return (QosPeakRate)m_bit.m_qos_peak_rate; }
00174         void SetQosPeakRate(QosPeakRate qpr)
00175             { m_bit.m_qos_peak_rate = qpr; }
00176
00177         QosMeanRate GetQosMeanRate() const
00178             { return (QosMeanRate)m_bit.m_qos_mean_rate; }
00179         void SetQosMeanRate(QosMeanRate qmr)
00180             { m_bit.m_qos_mean_rate = qmr; }
00181
00182 #if defined(APOXI_RAT_UMTS) || defined(APOXI_RAT_DUAL)
00183         INT GetQos3GPresent() const
00184             { return (INT) m_bit.m_present_3g; }
00185         void SetQos3GPresent(INT present_3g)
00186             { m_bit.m_present_3g = present_3g; }
00187
00188         INT GetQosTrafficClass() const
00189             { return (INT) m_bit.m_traffic_class; }
00190         void SetQosTrafficClass(INT traffic_class)
00191             { m_bit.m_traffic_class = traffic_class; }
00192
00193         INT GetQosDeliveryOrder() const
00194             { return (INT) m_bit.m_delivery_order; }
00195         void SetQosDeliveryOrder(INT delivery_order)
00196             { m_bit.m_delivery_order = delivery_order; }
00197
00198         INT GetQosErrorSduDelivery() const
00199             { return (INT) m_bit.m_error_sdu_delivery; }
00200         void SetQosErrorSduDelivery(INT error_sdu_delivery)
00201             { m_bit.m_error_sdu_delivery = error_sdu_delivery; }
00202
00203         INT GetQosMaxSduSize() const
00204             { return (INT) m_bit.m_max_sdu_size; }
00205         void SetQosMaxSduSize(INT max_sdu_size)
00206             { m_bit.m_max_sdu_size = max_sdu_size; }
00207
00208         INT GetQosBitRateUp() const
00209             { return (INT) m_bit.m_max_bit_rate_up; }
00210         void SetQosBitRateUp(INT max_bit_rate_up)
00211             { m_bit.m_max_bit_rate_up = max_bit_rate_up; }
00212
00213         INT GetQosBitRateDown() const
00214             { return (INT) m_bit.m_max_bit_rate_down; }
00215         void SetQosBitRateDown(INT max_bit_rate_down)
00216             { m_bit.m_max_bit_rate_down = max_bit_rate_down; }
00217
00218         INT GetQosResidualBer() const
00219             { return (INT) m_bit.m_residual_ber; }
00220         void SetQosResidualBer(INT residual_ber)
00221             { m_bit.m_residual_ber = residual_ber; }
00222
00223         INT GetQosSduErrorRatio() const
00224             { return (INT) m_bit.m_sdu_error_ratio; }
00225         void SetQosSduErrorRatio(INT sdu_error_ratio)
00226             { m_bit.m_sdu_error_ratio = sdu_error_ratio; }
00227
00228         INT GetQosTransferDelay() const
00229             { return (INT) m_bit.m_transfer_delay; }
00230         void SetQosTransferDelay(INT transfer_delay)
00231             { m_bit.m_transfer_delay = transfer_delay; }
00232
00233         INT GetQosTrafficPriority() const
00234             { return (INT) m_bit.m_traffic_priority; }
00235         void SetQosTrafficPriority(INT traffic_priority)
00236             { m_bit.m_traffic_priority = traffic_priority; }
00237
00238         INT GetQosGuaranteedBitRateUp() const
00239             { return (INT) m_bit.m_guaranteed_bit_rate_up; }
00240         void SetQosGuaranteedBitRateUp(INT guaranteed_bit_rate_up)
00241             { m_bit.m_guaranteed_bit_rate_up = guaranteed_bit_rate_up; }
00242
00243         INT GetQosGuaranteedBitRateDown() const
00244             { return (INT) m_bit.m_guaranteed_bit_rate_down; }
00245         void SetQosGuaranteedBitRateDown(INT guaranteed_bit_rate_down)
00246             { m_bit.m_guaranteed_bit_rate_down = guaranteed_bit_rate_down; }
00247 #endif  // APOXI_RAT_UMTS || APOXI_RAT_DUAL
00248
00249     protected:
00250         virtual void SaveFrom(const PersistDataConnProfile &bpp);
00251         virtual void SaveTo(PersistDataConnProfile &bpp) const;
00252
00255         virtual DataConnProfile* New() const;
00256
00259         virtual void Assign(const DataConnProfile& from_dcp);
00260
00261     private:
00262         Bit m_bit;
00263         String m_apn;
00264         IpAddr m_local;
00266         DataConnProfileId m_primary_id;
00268         PdpPacketFilterPtr m_packet_filter[8];
00269
00270     public:
00271         struct Persist {
00272             CHAR m_apn[c_apn_name_len_max + 1];
00273             Bit m_bit;
00274             IpAddr::Persist m_local;
00275         };
00276 };
00277
00279 #endif  // Apoxi_PsdDataConnProfile_hpp
00280
00281
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SerDataConn.cpp File Reference

Socket/SerDataConn.cpp File Reference

#include "Socket/PreComp.hpp"

Include dependency graph for SerDataConn.cpp:

Generated on Tue Jan 24 23:21:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SerDataConn.hpp File Reference

Socket/SerDataConn.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 23:21:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SerDataConn.hpp Source File

Socket/SerDataConn.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if defined(APOXI_SER_DATACONN_SUPPORT) || defined(APOXI_COMPAT_1_13_0)
00011
00012 #if !defined(Apoxi_SerDataConn_hpp)
00013 #define Apoxi_SerDataConn_hpp
00016
00017 #include <Socket/PppDataConn.hpp>
00018
00019 class SerDataConn : public PppDataConn
00020 {
00021     typedef PppDataConn Base;
00022
00023     friend class NiSharedPtr<DataConn>;
00024     friend class DataConnProfile;
00025
00026     protected:
00030         SerDataConn(const DataConnProfilePtr &profile);
00031
00032         virtual ~SerDataConn();
00033
00034     protected:
00035         virtual void PostInfoMsg(MessageType type) const;
00036
00037     private:
00038         void PostDataConnInfoMsg(DataConnInfoMsgType msg) const;
00039 };
00040
00042 #endif  // Apoxi_SerDataConn_hpp
00043
00044 #endif  // APOXI_SER_DATACONN_SUPPORT || APOXI_COMPAT_1_13_0
00045
00046
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SerDataConnProfile.cpp File Reference

Socket/SerDataConnProfile.cpp File Reference

#include "Socket/PreComp.hpp"

Include dependency graph for SerDataConnProfile.cpp:

Generated on Tue Jan 24 23:21:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SerDataConnProfile.hpp File Reference

Socket/SerDataConnProfile.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 23:21:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SerDataConnProfile.hpp Source File

Socket/SerDataConnProfile.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if defined(APOXI_SER_DATACONN_SUPPORT) || defined(APOXI_COMPAT_1_13_0)
00011
00012 #if !defined(Apoxi_SerDataConnProfile_hpp)
00013 #define Apoxi_SerDataConnProfile_hpp
00016
00017 #include <Socket/DataConnProfile.hpp>
00018
00021 class SerDataConnProfile : public DataConnProfile
00022 {
00023     typedef DataConnProfile Base;
00024
00025     public:
00026         SerDataConnProfile();
00027         virtual ~SerDataConnProfile();
00028
00029     protected:
00032         virtual DataConnProfile* New() const;
00033 };
00034
00036 #endif  // Apoxi_SerDataConnProfile_hpp
00037
00038 #endif  // APOXI_SER_DATACONN_SUPPORT || APOXI_COMPAT_1_13_0
00039
00040
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Socket.cpp File Reference

Socket/Socket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "Socket.hpp"
#include "SocketMsg.hpp"

Include dependency graph for Socket.cpp:

Generated on Tue Jan 24 23:22:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Socket.hpp File Reference

Socket/Socket.hpp File Reference

#include <Auxiliary/NonCloneable.hpp>
#include <Auxiliary/Vector.hpp>

Include dependency graph for Socket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | Socket
class | SocketEventListener

Defines

#define | Apoxi_Socket_hpp

Define Documentation

#define Apoxi_Socket_hpp

Generated on Tue Jan 24 23:22:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Socket.hpp Source File

Socket/Socket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Socket_hpp)
00011 #define Apoxi_Socket_hpp
00014
00015 #include <Auxiliary/NonCloneable.hpp>
00016 #include <Auxiliary/Vector.hpp>
00017
00018 class SocketControlMsg;
00019 class SocketEventListener;
00020
00022 class Socket : public NonCloneable
00023 {
00024     friend class SocketHandler;
00025
00026     public:
00027         enum Event {
00029             c_event_data_received,
00031             c_event_data_sent,
00034             c_event_conn_established,
00037             c_event_conn_failed,
00040             c_event_conn_closed,
00043             c_event_conn_req_pending,
00046             c_event_bearer_lost
00047         };
00048
00049     public:
00051         Socket();
00052
00054         virtual ~Socket();
00055
00056         virtual BOOLEAN IsOpen() const = 0;
00057         virtual BOOLEAN Close() = 0;
00058
00060         virtual BOOLEAN IsBlocking() const = 0;
00061
00067         virtual BOOLEAN SetBlocking(BOOLEAN block = FALSE) = 0;
00068
00074         virtual INT Read(void *buf, INT buflen) = 0;
00075
00081         virtual INT Write(const void *buf, INT buflen) = 0;
00082
00089         static BOOLEAN IsInstanceValid(const Socket *socket);
00090
00096         virtual void SetSocketEventListener(SocketEventListener *listener) {
00097             m_listener = listener;
00098         }
00099
00100     protected:
00104         virtual void OnControlMsg(const SocketControlMsg &msg);
00105
00107         SocketEventListener* GetSocketEventListener() const {
00108             return m_listener;
00109         }
00110
00111     private:
00113         SocketEventListener* m_listener;
00114
00116         static Vector<const Socket *>& GetVector();
00117 };
00118
00123 class SocketEventListener
00124 {
00125     public:
00126         SocketEventListener();
00127         virtual ~SocketEventListener();
00128
00136         virtual void OnSocketEvent(Socket::Event event, Socket *socket) = 0;
00137 };
00138
00140 #endif // Apoxi_Socket_hpp
00141
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketData.cpp File Reference

Socket/SocketData.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketData.hpp"
#include "DataConnProfileManager.hpp"
#include "SocketRxThread.hpp"
#include "DataConnManager.hpp"
#include "DataConn.hpp"
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for SocketData.cpp:

Generated on Tue Jan 24 23:22:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketData.hpp File Reference

Socket/SocketData.hpp File Reference

#include <Socket/Sys/SysSocket.hpp>
#include <Socket/DataConnProfile.hpp>
#include <Kernel/Condition.hpp>

Include dependency graph for SocketData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketData
class | SocketData::SdCond

Defines

#define | Apoxi_SocketData_hpp

Define Documentation

#define Apoxi_SocketData_hpp

Generated on Tue Jan 24 23:22:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketData.hpp Source File

Socket/SocketData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SocketData_hpp)
00011 #define Apoxi_SocketData_hpp
00014
00015 #include <Socket/Sys/SysSocket.hpp>
00016 #include <Socket/DataConnProfile.hpp>
00017 #include <Kernel/Condition.hpp>
00018
00019 class InetSocket;
00020 class ExecutionContext;
00021
00023 class SocketData : public SysSocket
00024 {
00025     typedef SysSocket Base;
00026
00027     friend class InetSocket;
00028     friend class UdpSocket;
00029     friend class TcpSocket;
00030     friend class TcpServerSocket;
00031     friend class SocketSubSystem;
00032     friend class DataConn;
00033     friend class SerialSocketData;
00034
00035     public:
00036         InetSocket* GetAttachedSocket() const { return m_socket; }
00037         ExecutionContext* GetContext() const { return m_context; }
00038
00039         BOOLEAN IsInUse() const { return m_socket != 0; }
00040
00041         DataConnProfileId GetDataConnProfileId() const { return m_daco_id; }
00042         void SetDataConnProfileId(DataConnProfileId id) { m_daco_id = id; }
00043
00044         SocketError GetError() const { return m_err; }
00045         BOOLEAN SetError(SocketError err) {
00046             m_err = err;
00047             return err == c_socket_no_error;
00048         }
00049
00050         BOOLEAN SetError(BOOLEAN ok) {
00051             m_err = ok ? c_socket_no_error : GetSysError();
00052             return ok;
00053         }
00054
00056         BOOLEAN SetupDataConn();
00057
00059         BOOLEAN ReleaseDataConn();
00060
00064         void ResetDataConnIdleTimer() const;
00065
00068         DataConn& GetDataConn() const;
00069
00071         BOOLEAN Listen(INT backlog);
00072
00074         BOOLEAN Close();
00075
00076     private:
00077         class SdCond : public BooleanCondition {
00078             typedef BooleanCondition Base;
00079             public:
00080                 SdCond() : m_in_use(FALSE) { }
00081                 void Init() { Base::Init(); m_in_use = TRUE; }
00082                 BOOLEAN IsInUse() const { return m_in_use; }
00083                 void SetUnused() { m_in_use = FALSE; }
00084             private:
00085                 BOOLEAN m_in_use;
00086         };
00087
00088         DataConnProfileId m_active_daco_id;
00089         DataConnProfileId m_daco_id;
00090         SocketError m_err;
00091         InetSocket *m_socket;
00092         ExecutionContext *m_context;
00093         BOOLEAN m_is_listening;
00094
00095         SdCond m_recv_cond;
00096         SdCond m_send_cond;
00097
00098         SocketData();
00099
00100         void Attach(InetSocket *s);
00101         void Detach(InetSocket *s);
00102         void HandOver(InetSocket &to_socket);
00103
00104         BOOLEAN IsDaCoActive() const
00105             { return m_active_daco_id != c_invalid_data_conn_profile_id; }
00106
00107         DataConnProfileId GetActiveDaCoProfileId() const
00108             { return m_active_daco_id; }
00109         void SetActiveDaCoProfileId(DataConnProfileId id)
00110             { m_active_daco_id = id; }
00111
00112         BOOLEAN IsWaitingForDataRecv() const { return m_recv_cond.IsInUse(); }
00113         BOOLEAN WaitForDataRecv();
00114         void UnblockDataRecv();
00115
00116         void OnDataRecv() {
00117             if (m_recv_cond.IsInUse()) {
00118                 m_recv_cond.SetTrue();
00119             }
00120         }
00121
00122         BOOLEAN IsWaitingForDataSent() const { return m_send_cond.IsInUse(); }
00123         BOOLEAN WaitForDataSent();
00124         void UnblockDataSend();
00125
00126         void OnDataSent() {
00127             if (m_send_cond.IsInUse()) {
00128                 m_send_cond.SetTrue();
00129             }
00130         }
00131
00132 };
00133
00135 #endif  // Apoxi_SocketData_hpp
00136
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketDataLock.hpp File Reference

Socket/SocketDataLock.hpp File Reference

#include <Socket/SocketSubSystem.hpp>
#include <Kernel/Os/MutexObtainer.hpp>

Include dependency graph for SocketDataLock.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketDataLock

Defines

#define | Apoxi_SocketDataLock_hpp

Define Documentation

#define Apoxi_SocketDataLock_hpp

Generated on Tue Jan 24 23:22:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketDataLock.hpp Source File

Socket/SocketDataLock.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SocketDataLock_hpp)
00011 #define Apoxi_SocketDataLock_hpp
00014
00015 #include <Socket/SocketSubSystem.hpp>
00016 #include <Kernel/Os/MutexObtainer.hpp>
00017
00020 class SocketDataLock : public MutexObtainer
00021 {
00022     public:
00023         SocketDataLock() : MutexObtainer(&SocketSubSystem::m_mutex_socket)
00024             {}
00025 };
00026
00028 #endif  // Apoxi_SocketDataLock_hpp
00029
00030
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketHandler.cpp File Reference

Socket/SocketHandler.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketHandler.hpp"
#include "SocketMsg.hpp"
#include "SocketData.hpp"
#include "InetSocket.hpp"
#include <Kernel/ExecutionContext.hpp>

Include dependency graph for SocketHandler.cpp:

Generated on Tue Jan 24 23:22:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketHandler.hpp File Reference

Socket/SocketHandler.hpp File Reference

#include <Kernel/UserDispatcher.hpp>

Include dependency graph for SocketHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketHandler

Defines

#define | Apoxi_SocketHandler_hpp

Define Documentation

#define Apoxi_SocketHandler_hpp

Generated on Tue Jan 24 23:22:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketHandler.hpp Source File

Socket/SocketHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SocketHandler_hpp)
00011 #define Apoxi_SocketHandler_hpp
00014
00015 #include <Kernel/UserDispatcher.hpp>
00016
00020 class SocketHandler : private UserDispatcher
00021 {
00022     public:
00023         SocketHandler();
00024         virtual ~SocketHandler();
00025
00028         void Init();
00029
00032         void Release();
00033
00034     private:
00035         virtual BOOLEAN OnMessage(const Message &msg);
00036 };
00037
00039 #endif  // Apoxi_SocketHandler_hpp
00040
00041
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketMsg.cpp File Reference

Socket/SocketMsg.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketMsg.hpp"
#include "Socket.hpp"
#include "InetSocket.hpp"
#include "SocketData.hpp"

Include dependency graph for SocketMsg.cpp:

Generated on Tue Jan 24 23:22:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketMsg.hpp File Reference

Socket/SocketMsg.hpp File Reference

#include <Kernel/Message.hpp>
#include <Socket/SocketTypes.hpp>
#include <Asc/PdpContext.hpp>
#include <Asc/Types.hpp>

Include dependency graph for SocketMsg.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnInfoMsg
class | DataConnProfileInfoMsg
class | SocketControlMsg

Defines

#define | SocketMsg_hpp__ST_1044273316690

Define Documentation

#define SocketMsg_hpp__ST_1044273316690

Generated on Tue Jan 24 23:22:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketMsg.hpp Source File

Socket/SocketMsg.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "linz\socket_dev\src\Apoxi\Socket\MsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014 #if !defined(SocketMsg_hpp__ST_1044273316690)
00015 #define SocketMsg_hpp__ST_1044273316690
00016
00017 #include <Kernel/Message.hpp>
00018 #include <Socket/SocketTypes.hpp>
00019 #include <Asc/PdpContext.hpp>
00020 #include <Asc/Types.hpp>
00021
00022 class ExecutionContext;
00023 class SocketData;
00024 class Socket;
00025
00026 /* ----------------------------------------------------------------------
00027     Classes
00028     ---------------------------------------------------------------------- */
00029 /*  ======================================================================
00030     Class SocketControlMsg
00031     ====================================================================== */
00032
00034 class SocketControlMsg : public ContextMsg {
00035     public:
00036         SocketControlMsg(ExecutionContext* context, UINT32 msg_id, SocketData* socket_data, const SocketControlMsgType& control_type);
00037         SocketControlMsg(ExecutionContext* context, UINT32 msg_id, Socket* socket, const SocketControlMsgType& control_type);
00038         virtual ~SocketControlMsg();
00039
00040         virtual const MsgMetaData& GetMetaData() const;
00041         UINT32 GetMsgId() const { return m_msg_id; }
00042         void SetSocketData(SocketData* socket_data) { m_socket_data = socket_data; }
00043         SocketData* GetSocketData() const { return m_socket_data; }
00044         Socket* GetSocket() const;
00045         void SetControlType(const SocketControlMsgType& control_type) { m_control_type = control_type; }
00046         const SocketControlMsgType& GetControlType() const { return m_control_type; }
00047         virtual Message* Clone() const;
00048
00049         enum {
00050             ID = 19101
00051             };
00052
00053     private:
00054         static const MsgMetaData m_meta_data;
00055         UINT32 m_msg_id;
00056         SocketData* m_socket_data;
00057         Socket* m_socket;
00058         SocketControlMsgType m_control_type;
00059
00060     };
00061
00062 /*  ======================================================================
00063     Class DataConnInfoMsg
00064     ====================================================================== */
00066 class DataConnInfoMsg : public Message {
00067     public:
00068         DataConnInfoMsg(const DataConnInfoMsgType& type,
00069             const DataConnProfileId& profile,
00070             DcError csd_err = NoCallError,
00071             CallApiRc csd_dial_err = NoError,
00072             PdpContext::ErrorCause psd_err = PdpContext::NoError);
00073         virtual ~DataConnInfoMsg();
00074
00075         virtual const MsgMetaData& GetMetaData() const;
00076         void SetType(const DataConnInfoMsgType& type) { m_type = type; }
00077         const DataConnInfoMsgType& GetType() const { return m_type; }
00078         void SetProfile(const DataConnProfileId& profile) { m_profile = profile; }
00079         const DataConnProfileId& GetProfile() const { return m_profile; }
00080         virtual Message* Clone() const;
00083         DcError GetCsdError() { return m_csd_err; }
00086         CallApiRc GetCsdDialError() { return m_csd_dial_err; }
00089         PdpContext::ErrorCause GetPsdError() { return m_psd_err; }
00090
00091         enum {
00092             ID = 19102
00093             };
00094
00095     private:
00096         static const MsgMetaData m_meta_data;
00097         DataConnInfoMsgType m_type;
00098         DataConnProfileId m_profile;
00099         DcError m_csd_err;
00100         PdpContext::ErrorCause m_psd_err;
00101         CallApiRc m_csd_dial_err;
00102     };
00103
00104 /*  ======================================================================
00105     Class DataConnProfileInfoMsg
00106     ====================================================================== */
00108 class DataConnProfileInfoMsg : public Message {
00109     public:
00110         DataConnProfileInfoMsg(const DataConnProfileInfoMsgType& type, const DataConnProfileId& profileId, const WString& profileName, BOOLEAN temporaryProfile);
00111         virtual ~DataConnProfileInfoMsg();
00112
00113         virtual const MsgMetaData& GetMetaData() const;
00114         void SetType(const DataConnProfileInfoMsgType& type) { m_type = type; }
00115         const DataConnProfileInfoMsgType& GetType() const { return m_type; }
00116         void SetProfileId(const DataConnProfileId& profileId) { m_profileId = profileId; }
00117         const DataConnProfileId& GetProfileId() const { return m_profileId; }
00118         void SetProfileName(const WString& profileName) { m_profileName = profileName; }
00119         const WString& GetProfileName() const { return m_profileName; }
00120         void SetTemporaryProfile(BOOLEAN temporaryProfile) { m_temporaryProfile = temporaryProfile; }
00121         BOOLEAN IsTemporaryProfile() const { return m_temporaryProfile; }
00122         virtual Message* Clone() const;
00123
00124         enum  {
00125             ID = 19103
00126             };
00127
00128     private:
00129         static const MsgMetaData m_meta_data;
00130         DataConnProfileInfoMsgType m_type;
00131         DataConnProfileId m_profileId;
00132         WString m_profileName;
00133         BOOLEAN m_temporaryProfile;
00134
00135     };
00136
00137 #endif // SocketMsg_hpp__ST_1044273316690
00138
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketRxThread.cpp File Reference

Socket/SocketRxThread.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketRxThread.hpp"
#include "SocketDataLock.hpp"
#include "SocketMsg.hpp"
#include "DataConnManager.hpp"
#include <Kernel/System.hpp>
#include <Kernel/MessageRouter.hpp>

Include dependency graph for SocketRxThread.cpp:

Generated on Tue Jan 24 23:22:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketRxThread.hpp File Reference

Socket/SocketRxThread.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Socket/Sys/SysSocket.hpp>

Include dependency graph for SocketRxThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketRxThread

Defines

#define | Apoxi_SocketRxThread_hpp

Define Documentation

#define Apoxi_SocketRxThread_hpp

Generated on Tue Jan 24 23:22:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketRxThread.hpp Source File

Socket/SocketRxThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SocketRxThread_hpp)
00011 #define Apoxi_SocketRxThread_hpp
00014
00015 #include <Kernel/Os/Os.hpp>
00016 #include <Socket/Sys/SysSocket.hpp>
00017
00018 class SocketData;
00019
00021 class SocketRxThread : public Thread
00022 {
00023     public:
00024         SocketRxThread();
00025
00026         BOOLEAN Init();
00027
00028         static BOOLEAN NotifyOnDataRecv(const SocketData *sd, BOOLEAN enable = TRUE);
00029         static BOOLEAN NotifyOnReadyToSend(const SocketData *sd, BOOLEAN enable = TRUE);
00030         static BOOLEAN StopNotifications(const SocketData *sd);
00031         static BOOLEAN Wakeup();
00032         static BOOLEAN Shutdown();
00033
00034     private:
00035         typedef SysSocket::FdSet FdSet;
00036
00037         static BOOLEAN m_quit;
00038         static INT m_socket_count;
00039         static UINT32 m_msg_id;
00040         static Semaphore m_sem_wait;
00041         static FdSet m_read_fds;
00042         static FdSet m_write_fds;
00043         static FdSet m_sel_read_fds;
00044         static FdSet m_sel_write_fds;
00045
00046         virtual INT ThreadFn();
00047
00048         static void TraceFdSet();
00049
00050         static BOOLEAN AddToFds(const SocketData *s, FdSet &fds);
00051         static BOOLEAN RemoveFromFds(const SocketData *s, FdSet &fds);
00052 };
00053
00055 #endif  // Apoxi_SocketRxThread_hpp
00056
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketSubSystem.cpp File Reference

Socket/SocketSubSystem.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketSubSystem.hpp"

Include dependency graph for SocketSubSystem.cpp:

Generated on Tue Jan 24 23:22:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketSubSystem.hpp File Reference

Socket/SocketSubSystem.hpp File Reference

#include <Kernel/Os/Mutex.hpp>
#include <Kernel/SubSystem.hpp>
#include <Kernel/ServiceThread.hpp>
#include <Socket/SocketData.hpp>
#include <Socket/SocketRxThread.hpp>

Include dependency graph for SocketSubSystem.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketSubSystem

Defines

#define | Apoxi_SocketSubSystem_hpp

Define Documentation

#define Apoxi_SocketSubSystem_hpp

Generated on Tue Jan 24 23:22:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketSubSystem.hpp Source File

Socket/SocketSubSystem.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SocketSubSystem_hpp)
00011 #define Apoxi_SocketSubSystem_hpp
00014
00015 #include <Kernel/Os/Mutex.hpp>
00016 #include <Kernel/SubSystem.hpp>
00017 #include <Kernel/ServiceThread.hpp>
00018 #include <Socket/SocketData.hpp>
00019 #include <Socket/SocketRxThread.hpp>
00020
00024 class SocketSubSystem : public SubSystem
00025 {
00026     friend class InetSocket;
00027     friend class SocketRxThread;
00028     friend class SocketDataLock;
00029     friend class TcpServerSocket;
00030     friend class SysSocket;
00031     friend class DataConn;
00032     friend class Os;
00033
00034     public:
00035         SocketSubSystem();
00036
00037         static SocketSubSystem* GetInstance() { return m_instance; }
00038
00039         virtual const WCHAR* GetName() const { return L"INET"; }
00040         virtual void OnPowerUp();
00041         virtual void OnPowerDown();
00042
00043         virtual BootSequenceState InvokeAt() const;
00044
00045     private:
00046         static SocketSubSystem *m_instance;
00047         static SocketRxThread m_rx;
00048         static ServiceThread m_dc_srv_thread;
00049         static Mutex m_mutex_socket;
00050         static SocketData m_sd[c_max_inet_socket_count];
00051
00052         static SocketData& GetSocketData(UINT idx) {
00053             ASSERT(idx < c_max_inet_socket_count);
00054             return m_sd[idx];
00055         }
00056
00057         static SocketData* GetFreeSocketDataEntry();
00058 };
00059
00061 #endif  // Apoxi_SocketSubSystem_hpp
00062
00063
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketTemplates.cpp File Reference

Socket/SocketTemplates.cpp File Reference

#include "Socket/PreComp.hpp"
#include <Socket/DataConnManager.hpp>
#include <Socket/DataConn.hpp>
#include <Socket/DataConnProfileManager.hpp>
#include <Socket/DataConnProfile.hpp>
#include <Socket/NetAdapterHandler.hpp>
#include <Socket/Socket.hpp>
#include <Socket/PsdDataConnProfile.hpp>

Include dependency graph for SocketTemplates.cpp:

Generated on Tue Jan 24 23:22:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketTypes.cpp File Reference

Socket/SocketTypes.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketTypes.hpp"

Include dependency graph for SocketTypes.cpp:

Generated on Tue Jan 24 23:22:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketTypes.hpp File Reference

Socket/SocketTypes.hpp File Reference

#include <Kernel/Types.hpp>

Include dependency graph for SocketTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_APN_NAME_LEN_MAX 99
#define | APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX 25
#define | APOXI_BEARER_PROFILE_NAME_LEN_MAX 20
#define | APOXI_BEARER_PROFILE_PASSWD_LEN_MAX 15
#define | APOXI_DATA_CONN_PROFILE_COUNT 5
#define | APOXI_DATA_CONN_TEMP_PROFILE_COUNT 15
#define | APOXI_HOST_NAME_LEN_MAX 64
#define | APOXI_MAX_INET_SOCKET_COUNT 16
#define | Apoxi_SocketTypes_hpp
#define | SocketTrace(x)

Typedefs

typedef UINT8 | DataConnProfileId
typedef DataConnProfileId | DataConnProfileIdSet [c_data_conn_profile_count]
typedef DataConnProfileId | DataConnTempProfileIdSet [c_data_conn_temp_profile_count]

Enumerations

enum DataConnInfoMsgType {
c_csd_data_conn_init, c_csd_data_conn_established, c_csd_data_conn_setup_failed, c_csd_data_conn_init_release,
c_csd_data_conn_released, c_csd_data_conn_setup_blocked, c_psd_data_conn_init, c_psd_data_conn_established,
c_psd_data_conn_setup_failed, c_psd_data_conn_init_release, c_psd_data_conn_released, c_psd_data_conn_setup_blocked,
c_ser_data_conn_init, c_ser_data_conn_established, c_ser_data_conn_setup_failed, c_ser_data_conn_init_release,
c_ser_data_conn_released, c_ser_data_conn_setup_blocked
}
enum | DataConnProfileInfoMsgType { c_data_conn_profile_created, c_data_conn_profile_changed, c_data_conn_profile_deleted, c_data_conn_profile_set_as_default }
enum SocketControlMsgType {
c_scmt_rx_data_arrived, c_scmt_tx_data_ready, c_scmt_ppp_setup_err, c_scmt_ppp_setup,
c_scmt_ppp_stop_err, c_scmt_ppp_stop, c_scmt_csd_setup_err, c_scmt_csd_datacall_setup,
c_scmt_csd_datacall_setup_success, c_scmt_csd_datacall_setup_fail, c_scmt_csd_datacall_release, c_scmt_csd_lost,
c_scmt_psd_setup_err, c_scmt_psd_ctx_defined, c_scmt_psd_ctx_undefined, c_scmt_psd_ctx_dns_neg_set,
c_scmt_psd_ctx_packet_filter_set, c_scmt_psd_ctx_authenticated, c_scmt_psd_ctx_qos_set, c_scmt_psd_ctx_deactivated,
c_scmt_psd_ctx_connected, c_scmt_psd_ctx_neg_dns_read, c_scmt_psd_ctx_link_up, c_scmt_psd_ctx_link_down,
c_scmt_psd_lost, c_scmt_data_conn_established, c_scmt_idle_timeout, c_scmt_init_context_err,
c_scmt_data_conn_cancelled, c_scmt_control_data_available, c_scmt_undefined
}
enum SocketError {
c_socket_no_error = 0, c_socket_unknown_error = 1, c_socket_no_bearer = 2, c_socket_bearer_busy = 3,
c_socket_bearer_not_supported = 4, c_socket_fatal_system_error = 5, c_socket_wrong_execution_context = 6, c_socket_subsystem_not_init = 7,
c_socket_no_data_conn_profile = 8, c_socket_conn_setup_failed = 9, c_socket_conn_in_release = 10, c_socket_conn_in_setup = 11,
c_socket_conn_blocked = 12, c_socket_conn_perform_setup = 13, c_socket_conn_timed_out = 14, c_socket_conn_lost = 15,
c_socket_wait_for_send_unblocked = 16, c_socket_wait_for_recv_unblocked = 17, c_socket_ebadf = 100, c_socket_eintr = 101,
c_socket_einval = 102, c_socket_enotsock = 103, c_socket_eopnotsupp = 104, c_socket_ewouldblock = 105,
c_socket_eaddrnotavail = 106, c_socket_eacces = 107, c_socket_eisconn = 108, c_socket_etimedout = 109,
c_socket_econnrefused = 110, c_socket_enetunreach = 111, c_socket_eaddrinuse = 112, c_socket_ealready = 113,
c_socket_einprogress = 114, c_socket_enotconn = 115, c_socket_emsgsize = 116, c_socket_enobufs = 117,
c_socket_enoprotoopt = 118, c_socket_emfile = 119, c_socket_econnreset = 120, c_socket_ehostunreach = 121,
c_socket_econnaborted = 122, c_socket_efault = 123, c_socket_edestaddrreq = 124, c_socket_eprototype = 125,
c_socket_eprotonosupport = 126, c_socket_esocktnosupport = 127, c_socket_epfnosupport = 128, c_socket_eafnosupport = 129,
c_socket_enetdown = 130, c_socket_enetreset = 131, c_socket_eshutdown = 132, c_socket_ehostdown = 133
}

Variables

const UINT | c_apn_name_len_max = APOXI_APN_NAME_LEN_MAX
const UINT | c_data_conn_profile_count = APOXI_DATA_CONN_PROFILE_COUNT
const UINT | c_data_conn_temp_profile_count = APOXI_DATA_CONN_TEMP_PROFILE_COUNT
const DataConnProfileId | c_default_data_conn_profile_id = c_invalid_data_conn_profile_id
const UINT | c_host_name_len_max = APOXI_HOST_NAME_LEN_MAX
const DataConnProfileId | c_invalid_data_conn_profile_id = 0
const DataConnProfileId | c_max_data_conn_profile_id = (1 << (sizeof(DataConnProfileId) * 8 - 1)) - 1
const UINT | c_max_inet_socket_count = APOXI_MAX_INET_SOCKET_COUNT

Define Documentation

#define Apoxi_SocketTypes_hpp

Generated on Tue Jan 24 23:22:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/SocketTypes.hpp Source File

Socket/SocketTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SocketTypes_hpp)
00011 #define Apoxi_SocketTypes_hpp
00014
00015 #include <Kernel/Types.hpp>
00016
00021 typedef UINT8 DataConnProfileId;
00022
00026 enum SocketError {
00027     c_socket_no_error = 0,
00028
00030     c_socket_unknown_error = 1,
00031     c_socket_no_bearer = 2,
00032     c_socket_bearer_busy = 3,
00033     c_socket_bearer_not_supported = 4,
00034     c_socket_fatal_system_error = 5,
00035     c_socket_wrong_execution_context = 6,
00036     c_socket_subsystem_not_init = 7,
00037     c_socket_no_data_conn_profile = 8,
00038     c_socket_conn_setup_failed = 9,
00039     c_socket_conn_in_release = 10,
00040     c_socket_conn_in_setup = 11,
00041     c_socket_conn_blocked = 12,
00042     c_socket_conn_perform_setup = 13,
00043     c_socket_conn_timed_out = 14,
00044     c_socket_conn_lost = 15,
00045     c_socket_wait_for_send_unblocked = 16,
00046     c_socket_wait_for_recv_unblocked = 17,
00047
00049     c_socket_ebadf = 100,
00050     c_socket_eintr = 101,
00051
00052     c_socket_einval = 102,
00053
00054     c_socket_enotsock = 103,
00055
00056     c_socket_eopnotsupp = 104,
00057
00058     c_socket_ewouldblock = 105,
00059
00060     c_socket_eaddrnotavail = 106,
00061
00062     c_socket_eacces = 107,
00063
00064     c_socket_eisconn = 108,
00065
00066     c_socket_etimedout = 109,
00067
00068     c_socket_econnrefused = 110,
00069
00070     c_socket_enetunreach = 111,
00071
00072     c_socket_eaddrinuse = 112,
00073
00074     c_socket_ealready = 113,
00075
00076     c_socket_einprogress = 114,
00077
00078     c_socket_enotconn = 115,
00079
00080     c_socket_emsgsize = 116,
00081
00082     c_socket_enobufs = 117,
00083
00084     c_socket_enoprotoopt = 118,
00085
00086     c_socket_emfile = 119,
00087
00088     c_socket_econnreset = 120,
00089
00090     c_socket_ehostunreach = 121,
00091
00092     c_socket_econnaborted = 122,
00093
00094     c_socket_efault = 123,
00095
00096     c_socket_edestaddrreq = 124,
00097
00098     c_socket_eprototype = 125,
00099
00100     c_socket_eprotonosupport = 126,
00101
00102     c_socket_esocktnosupport = 127,
00103
00104     c_socket_epfnosupport = 128,
00105
00106     c_socket_eafnosupport = 129,
00107
00108     c_socket_enetdown = 130,
00109
00110     c_socket_enetreset = 131,
00111
00112     c_socket_eshutdown = 132,
00113
00114     c_socket_ehostdown =133
00115
00116 };
00117
00119 enum SocketControlMsgType {
00120     c_scmt_rx_data_arrived,
00121     c_scmt_tx_data_ready,
00122
00123     c_scmt_ppp_setup_err,
00124     c_scmt_ppp_setup,
00125     c_scmt_ppp_stop_err,
00126     c_scmt_ppp_stop,
00127
00128     c_scmt_csd_setup_err,
00129     c_scmt_csd_datacall_setup,
00130     c_scmt_csd_datacall_setup_success,
00131     c_scmt_csd_datacall_setup_fail,
00132     c_scmt_csd_datacall_release,
00133     c_scmt_csd_lost,
00134
00135     c_scmt_psd_setup_err,
00136     c_scmt_psd_ctx_defined,
00137     c_scmt_psd_ctx_undefined,
00138     c_scmt_psd_ctx_dns_neg_set,
00139     c_scmt_psd_ctx_packet_filter_set,
00140     c_scmt_psd_ctx_authenticated,
00141     c_scmt_psd_ctx_qos_set,
00142     c_scmt_psd_ctx_deactivated,
00143     c_scmt_psd_ctx_connected,
00144     c_scmt_psd_ctx_neg_dns_read,
00145     c_scmt_psd_ctx_link_up,
00146     c_scmt_psd_ctx_link_down,
00147     c_scmt_psd_lost,
00148
00149     c_scmt_data_conn_established,
00150     c_scmt_idle_timeout,
00151     c_scmt_init_context_err,
00152
00153     c_scmt_data_conn_cancelled,
00154
00156     c_scmt_control_data_available,
00157
00158     c_scmt_undefined
00159 };
00160
00162 enum DataConnInfoMsgType {
00163     c_csd_data_conn_init,
00164     c_csd_data_conn_established,
00165     c_csd_data_conn_setup_failed,
00166     c_csd_data_conn_init_release,
00167     c_csd_data_conn_released,
00168     c_csd_data_conn_setup_blocked,
00169
00170     c_psd_data_conn_init,
00171     c_psd_data_conn_established,
00172     c_psd_data_conn_setup_failed,
00173     c_psd_data_conn_init_release,
00174     c_psd_data_conn_released,
00175     c_psd_data_conn_setup_blocked,
00176
00177     c_ser_data_conn_init,
00178     c_ser_data_conn_established,
00179     c_ser_data_conn_setup_failed,
00180     c_ser_data_conn_init_release,
00181     c_ser_data_conn_released,
00182     c_ser_data_conn_setup_blocked
00183 };
00184
00186 enum DataConnProfileInfoMsgType {
00187     c_data_conn_profile_created,
00188     c_data_conn_profile_changed,
00189     c_data_conn_profile_deleted,
00190     c_data_conn_profile_set_as_default
00191 };
00192
00193 /*  -------------------------------------------------------------------------
00194                                     Constants
00195     ------------------------------------------------------------------------- */
00196 #if !defined(APOXI_MAX_INET_SOCKET_COUNT)
00197 #    define APOXI_MAX_INET_SOCKET_COUNT 16
00198 #endif
00199
00200 #if !defined(APOXI_DATA_CONN_PROFILE_COUNT)
00201 #    define APOXI_DATA_CONN_PROFILE_COUNT 5
00202 #endif
00203
00204 #if !defined(APOXI_DATA_CONN_TEMP_PROFILE_COUNT)
00205 #    define APOXI_DATA_CONN_TEMP_PROFILE_COUNT 15
00206 #endif
00207
00208 #if !defined(APOXI_HOST_NAME_LEN_MAX)
00209 #    define APOXI_HOST_NAME_LEN_MAX 64
00210 #endif
00211
00212 #if !defined(APOXI_APN_NAME_LEN_MAX)    // see UTP: PAX6000000190
00213 #    define APOXI_APN_NAME_LEN_MAX 99
00214 #endif
00215
00216 #if !defined(APOXI_BEARER_PROFILE_NAME_LEN_MAX)
00217 #    define APOXI_BEARER_PROFILE_NAME_LEN_MAX 20
00218 #endif
00219
00220 #if !defined(APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX)
00221 #    define APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX 25
00222 #endif
00223
00224 #if !defined(APOXI_BEARER_PROFILE_PASSWD_LEN_MAX)
00225 #    define APOXI_BEARER_PROFILE_PASSWD_LEN_MAX 15
00226 #endif
00227
00230 const UINT c_max_inet_socket_count = APOXI_MAX_INET_SOCKET_COUNT;
00231
00234 const UINT c_host_name_len_max = APOXI_HOST_NAME_LEN_MAX;
00235
00238 const UINT c_apn_name_len_max = APOXI_APN_NAME_LEN_MAX; // see UTP: PAX6000000190
00239
00242 const UINT c_data_conn_profile_count = APOXI_DATA_CONN_PROFILE_COUNT;
00243
00246 const UINT c_data_conn_temp_profile_count = APOXI_DATA_CONN_TEMP_PROFILE_COUNT;
00247
00250 const DataConnProfileId c_invalid_data_conn_profile_id = 0;
00251
00254 const DataConnProfileId c_default_data_conn_profile_id = c_invalid_data_conn_profile_id;
00255
00266 const DataConnProfileId c_max_data_conn_profile_id = (1 << (sizeof(DataConnProfileId) * 8 - 1)) - 1;
00267
00269 typedef DataConnProfileId DataConnProfileIdSet[c_data_conn_profile_count];
00270
00272 typedef DataConnProfileId DataConnTempProfileIdSet[c_data_conn_temp_profile_count];
00273
00274 /*  -------------------------------------------------------------------------
00275                                     Macros
00276     ------------------------------------------------------------------------- */
00277 // Enable extended safety & debug features in paranoia mode.
00278 #if defined (APOXI_SOCKET_PARANOIA)
00279     #if !defined (APOXI_SOCKET_ENSURE_CONTEXT)
00280         #define APOXI_SOCKET_ENSURE_CONTEXT
00281     #endif
00282     #if !defined (APOXI_SOCKET_OPERATION_LOCK)
00283         #define APOXI_SOCKET_OPERATION_LOCK
00284     #endif
00285     #if !defined (APOXI_TRACE_SOCKETS)
00286         #define APOXI_TRACE_SOCKETS
00287     #endif
00288     #if !defined (APOXI_SOCKET_EXTENDED_TRACE)
00289         #define APOXI_SOCKET_EXTENDED_TRACE
00290     #endif
00291 #endif
00292
00293 #if defined(APOXI_TRACE_SOCKETS)
00294
00295     enum SocketTraceId {
00296         c_socket_trace_no_start = 25030,
00297         c_socket_trace_no_end = 25039,
00298
00299         c_socket_generic_trace_no = 25030,
00300         c_socket_sys_trace_no = 25031,
00301         c_socket_rx_trace_no = 25032,
00302         c_socket_tx_trace_no = 25033,
00303         c_socket_udp_trace_no = 25034,
00304         c_socket_tcp_trace_no = 25035,
00305         c_socket_data_conn_trace_no = 25036
00306     };
00307
00308     #if defined (APOXI_SOCKET_EXTENDED_TRACE)
00309
00316         void SocketExtendedDbgOut(UINT16 idx, const CHAR *fmt, ...);
00317
00318         #define SocketTrace(x)  SocketExtendedDbgOut x
00319     #else
00320         #define SocketTrace(x)  DBG_OUT(x)
00321     #endif
00322 #else
00323     #define SocketTrace(x)
00324 #endif
00325
00327 #endif  // Apoxi_SocketTypes_hpp
00328
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/TcpServerSocket.cpp File Reference

Socket/TcpServerSocket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketTypes.hpp"
#include "Sys/SysSocket.hpp"
#include "SocketMsg.hpp"
#include "SocketDataLock.hpp"
#include "TcpSocket.hpp"
#include "TcpServerSocket.hpp"

Include dependency graph for TcpServerSocket.cpp:

Generated on Tue Jan 24 23:22:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/TcpServerSocket.hpp File Reference

Socket/TcpServerSocket.hpp File Reference

#include <Socket/TcpSocketBase.hpp>

Include dependency graph for TcpServerSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TcpServerSocket

Defines

#define | Apoxi_TcpServerSocket_hpp

Define Documentation

#define Apoxi_TcpServerSocket_hpp

Generated on Tue Jan 24 23:22:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/TcpServerSocket.hpp Source File

Socket/TcpServerSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TcpServerSocket_hpp)
00011 #define Apoxi_TcpServerSocket_hpp
00014
00015 #include <Socket/TcpSocketBase.hpp>
00016
00017 class TcpSocket;
00018
00020 class TcpServerSocket : public TcpSocketBase
00021 {
00022     typedef TcpSocketBase Base;
00023
00024     public:
00025         enum {
00026             c_default_max_pending_requests = 5
00027         };
00028
00029 #if defined(APOXI_COMPAT_1_13_0)
00030
00031         inline BOOLEAN Init(const InetSocketAddr &local_addr,
00032             BOOLEAN may_reuse_addr = TRUE)
00033         {
00034             return Open(local_addr, may_reuse_addr);
00035         }
00036 #endif
00037
00043         BOOLEAN Open(const InetSocketAddr &local_addr,
00044             BOOLEAN may_reuse_addr = TRUE);
00045
00050         BOOLEAN Listen(INT backlog = c_default_max_pending_requests);
00051
00057         BOOLEAN Accept(TcpSocket &socket, InetSocketAddr *peer_addr = 0);
00058
00074         BOOLEAN HandOver(TcpServerSocket &to_socket)
00075             { return Base::HandOver(to_socket); }
00076
00077     protected:
00078         virtual void OnControlMsg(const SocketControlMsg &msg);
00079 };
00080
00082 #endif  // Apoxi_TcpServerSocket_hpp
00083
Generated on Tue Jan 24 14:50:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/TcpSocket.cpp File Reference

Socket/TcpSocket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketMsg.hpp"
#include "TcpSocket.hpp"
#include "InetSocketAddr.hpp"
#include "SocketRxThread.hpp"

Include dependency graph for TcpSocket.cpp:

Generated on Tue Jan 24 23:22:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/TcpSocket.hpp File Reference

Socket/TcpSocket.hpp File Reference

#include <Socket/TcpSocketBase.hpp>

Include dependency graph for TcpSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TcpSocket

Defines

#define | Apoxi_TcpSocket_hpp

Define Documentation

#define Apoxi_TcpSocket_hpp

Generated on Tue Jan 24 23:22:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/TcpSocket.hpp Source File

Socket/TcpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TcpSocket_hpp)
00011 #define Apoxi_TcpSocket_hpp
00014
00015 #include <Socket/TcpSocketBase.hpp>
00016
00018 class TcpSocket : public TcpSocketBase
00019 {
00020     typedef TcpSocketBase Base;
00021
00022     public:
00023
00024         TcpSocket();
00025
00026 #if defined(APOXI_COMPAT_1_13_0)
00027
00028         inline BOOLEAN Init(const InetSocketAddr *local_addr = 0, BOOLEAN may_reuse_addr = TRUE) {
00029             return Open(local_addr, may_reuse_addr);
00030         }
00031 #endif
00032
00036         BOOLEAN Open(const InetSocketAddr *local_addr = 0, BOOLEAN may_reuse_addr = TRUE) {
00037             return Base::Open(local_addr, may_reuse_addr);
00038         }
00039
00049         BOOLEAN Connect(const InetSocketAddr &to, BOOLEAN event = FALSE);
00050
00054         INT Read(void *buf, INT buflen)
00055             { return Base::Read(buf, buflen, 0); }
00056
00060         INT Write(const void *buf, INT buflen)
00061             { return Base::Write(buf, buflen, 0); }
00062
00078         BOOLEAN HandOver(TcpSocket &to_socket)
00079             { return Base::HandOver(to_socket); }
00080
00081     protected:
00082         virtual void OnControlMsg(const SocketControlMsg &msg);
00083
00084     private:
00085         BOOLEAN m_async_connect;    // Flag for handling asynchronous connect.
00086 };
00087
00089 #endif  // Apoxi_TcpSocket_hpp
00090
00091
Generated on Tue Jan 24 14:51:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/TcpSocketBase.hpp File Reference

Socket/TcpSocketBase.hpp File Reference

#include <Socket/InetSocket.hpp>

Include dependency graph for TcpSocketBase.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TcpSocketBase

Defines

#define | Apoxi_TcpSocketBase_hpp

Define Documentation

#define Apoxi_TcpSocketBase_hpp

Generated on Tue Jan 24 23:22:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/TcpSocketBase.hpp Source File

Socket/TcpSocketBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_TcpSocketBase_hpp)
00011 #define Apoxi_TcpSocketBase_hpp
00014
00015 #include <Socket/InetSocket.hpp>
00016
00017 /*  -------------------------------------------------------------------------
00018                                     Types
00019     ------------------------------------------------------------------------- */
00020
00022 class TcpSocketBase : public InetSocket
00023 {
00024     typedef InetSocket Base;
00025
00026     public:
00027         BOOLEAN GetTcpNoDelayOption(BOOLEAN &nodelay) {
00028             return GetBoolOption(SysSocket::c_option_tcp_no_delay, nodelay);
00029         }
00030
00031         BOOLEAN SetTcpNoDelayOption(BOOLEAN nodelay) {
00032             return SetBoolOption(SysSocket::c_option_tcp_no_delay, nodelay);
00033         }
00034
00035         BOOLEAN GetTcpMaxSetOption(BOOLEAN &nodelay) {
00036             return GetBoolOption(SysSocket::c_option_tcp_max_seg, nodelay);
00037         }
00038
00039         BOOLEAN SetTcpMaxSetOption(BOOLEAN nodelay) {
00040             return SetBoolOption(SysSocket::c_option_tcp_max_seg, nodelay);
00041         }
00042
00043     protected:
00044         BOOLEAN Open(const InetSocketAddr *local_addr, BOOLEAN may_reuse_addr) {
00045             return Base::Open(c_type_stream, local_addr, may_reuse_addr);
00046         }
00047 };
00048
00050 #endif  // Apoxi_TcpSocketBase_hpp
00051
00052
Generated on Tue Jan 24 14:51:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/UdpSocket.cpp File Reference

Socket/UdpSocket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketMsg.hpp"
#include "UdpSocket.hpp"
#include "InetSocketAddr.hpp"
#include "SocketRxThread.hpp"

Include dependency graph for UdpSocket.cpp:

Generated on Tue Jan 24 23:22:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/UdpSocket.hpp File Reference

Socket/UdpSocket.hpp File Reference

#include <Socket/InetSocket.hpp>

Include dependency graph for UdpSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UdpSocket

Defines

#define | Apoxi_UdpSocket_hpp

Define Documentation

#define Apoxi_UdpSocket_hpp

Generated on Tue Jan 24 23:22:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/UdpSocket.hpp Source File

Socket/UdpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_UdpSocket_hpp)
00011 #define Apoxi_UdpSocket_hpp
00014
00015 #include <Socket/InetSocket.hpp>
00016
00018 class UdpSocket : public InetSocket
00019 {
00020     typedef InetSocket Base;
00021
00022     public:
00023
00024 #if defined(APOXI_COMPAT_1_13_0)
00025
00026         inline BOOLEAN Init(const InetSocketAddr *local_addr = 0,
00027             BOOLEAN may_reuse_addr = TRUE)
00028         {
00029             return Open(local_addr, may_reuse_addr);
00030         }
00031 #endif
00032
00037         BOOLEAN Open(const InetSocketAddr *local_addr = 0,
00038             BOOLEAN may_reuse_addr = TRUE);
00039
00044         BOOLEAN SetPeer(const InetSocketAddr &addr);
00045
00050         INT Read(void *buf, INT buflen, InetSocketAddr *from = 0)
00051             { return Base::Read(buf, buflen, from); }
00052
00059         INT Write(const void *buf, INT buflen, const InetSocketAddr *to = 0)
00060             { return Base::Write(buf, buflen, to); }
00061
00077         BOOLEAN HandOver(UdpSocket &to_socket)
00078             { return Base::HandOver(to_socket); }
00079
00080     protected:
00081         virtual void OnControlMsg(const SocketControlMsg &msg);
00082 };
00083
00085 #endif  // Apoxi_UdpSocket_hpp
00086
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/SysSocket.hpp File Reference

Socket/Sys/SysSocket.hpp File Reference

#include <Socket/SocketTypes.hpp>
#include <Socket/Sys/GlWin32/Win32SysSocket.hpp>

Include dependency graph for SysSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APOXI_SOCKET_SYSTEM_WIN32
#define | Apoxi_SysSock_hpp

Define Documentation

#define Apoxi_SysSock_hpp

Generated on Tue Jan 24 23:22:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/SysSocket.hpp Source File

Socket/Sys/SysSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SysSock_hpp)
00011 #define Apoxi_SysSock_hpp
00014
00015 #include <Socket/SocketTypes.hpp>
00016
00017 /*  ------------------------------------------------------------------------
00018                                     Types
00019     ------------------------------------------------------------------------ */
00020
00021 #if !defined(APOXI_SOCKET_SYSTEM_USNET) && \
00022     !defined(APOXI_SOCKET_SYSTEM_LWIP) && \
00023     !defined(APOXI_SOCKET_SYSTEM_WIN32) && \
00024     !defined(APOXI_SOCKET_SYSTEM_DUMMY) && \
00025     !defined(APOXI_SOCKET_SYSTEM_BSD)
00026
00027     #if defined(APOXI_RTOS_OSE166) || defined(APOXI_RTOS_NUC32)
00028         #define APOXI_SOCKET_SYSTEM_LWIP
00029     #elif defined(APOXI_RTOS_WIN32)
00030         #define APOXI_SOCKET_SYSTEM_WIN32
00031     #elif defined(APOXI_RTOS_LINUX)
00032         #define APOXI_SOCKET_SYSTEM_BSD
00033     #else
00034         #error Could not determine system socket type
00035     #endif
00036 #endif
00037
00038 #if defined(APOXI_SOCKET_SYSTEM_USNET)
00039     #include <Socket/Sys/GlUsnet/UsnetSysSocket.hpp>
00040 #elif defined(APOXI_SOCKET_SYSTEM_LWIP)
00041     #include <Socket/Sys/GlLwip/LwipSysSocket.hpp>
00042 #elif defined(APOXI_SOCKET_SYSTEM_BSD)
00043     #include <Socket/Sys/GlBsd/BsdSysSocket.hpp>
00044 #elif defined(APOXI_SOCKET_SYSTEM_WIN32)
00045     #include <Socket/Sys/GlWin32/Win32SysSocket.hpp>
00046 #elif defined(APOXI_SOCKET_SYSTEM_DUMMY)
00047     #include <Socket/Sys/GlDummy/DummySysSocket.hpp>
00048 #else
00049     #error Unknown setting for socket system
00050 #endif
00051
00053 #endif  // Apoxi_SysSock_hpp
00054
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/SysSocketBase.cpp File Reference

Socket/Sys/SysSocketBase.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SysSocketBase.hpp"

Include dependency graph for SysSocketBase.cpp:

Generated on Tue Jan 24 23:22:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/SysSocketBase.hpp File Reference

Socket/Sys/SysSocketBase.hpp File Reference

#include <Auxiliary/IpAddr.hpp>

Include dependency graph for SysSocketBase.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | PppCallBackData
Types needed for lwIP PPP connections. More...
struct | PppSetupCallBackData
class | SysSocketBase
Base SysSocket. More...
struct | SysSocketBase::LingerSetting

Defines

#define | Apoxi_SysSocketBase_hpp

Typedefs

typedef void(* | PppCallback )(INT error, PppDataConn &dc, const PppCallBackData *data)
typedef void(* | PsdIfCallback )(INT error, void *client_arg)

Define Documentation

#define Apoxi_SysSocketBase_hpp

Generated on Tue Jan 24 23:22:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/SysSocketBase.hpp Source File

Socket/Sys/SysSocketBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SysSocketBase_hpp)
00011 #define Apoxi_SysSocketBase_hpp
00014
00015 #include <Auxiliary/IpAddr.hpp>
00016
00017 class PppDataConn;
00018 class PsdDataConn;
00019
00021 struct PppCallBackData {};
00022
00023 struct PppSetupCallBackData : public PppCallBackData {
00024
00025     void Reset() {
00026         m_interface_address.SetAddr(0);
00027         m_primary_dns_server_address.SetAddr(0);
00028         m_secondary_dns_server_address.SetAddr(0);
00029     }
00030
00031     IpAddr m_interface_address;
00032     IpAddr m_primary_dns_server_address;
00033     IpAddr m_secondary_dns_server_address;
00034 };
00035
00036 typedef void (*PppCallback)(INT error, PppDataConn &dc, const PppCallBackData *data);
00037
00038 typedef void (*PsdIfCallback)(INT error, void *client_arg);
00039
00041 class SysSocketBase
00042 {
00043     public:
00044
00046         enum Type {
00047             c_type_dgram,
00048             c_type_stream,
00049             c_type_raw
00050         };
00051
00054         enum AddrFamily {
00055             c_addr_family_inet,
00056             c_addr_family_unspec
00057         };
00058
00061         enum ShutdownMode {
00062             c_shutdown_stop_rx,
00063             c_shutdown_stop_tx,
00064             c_shutdown_stop_rx_tx
00065         };
00066
00069         enum OptionType {
00070             c_option_error,
00071             c_option_debug,
00072             c_option_reuse_addr,
00073             c_option_keep_alive,
00074             c_option_linger,
00075             c_option_dont_route,
00076             c_option_broadcast,
00077             c_option_snd_buf,
00078             c_option_rcv_buf,
00079             c_option_type,
00080             c_option_tcp_no_delay,
00081             c_option_tcp_max_seg
00082         };
00083
00087         struct LingerSetting {
00091             BOOLEAN m_on_off;
00093             INT32 m_timeout;
00094         };
00095
00096     protected:
00097         static PppCallback          m_ppp_callback;
00098         static PppDataConn         *m_ppp_callback_dc;
00099         static PppCallBackData     *m_ppp_callback_data;
00100         static PppSetupCallBackData m_ppp_callback_data_setup;
00101 };
00102
00104 #endif  // Apoxi_SysSocketBase_hpp
00105
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlBsd/BsdSysSocket.cpp File Reference

Socket/Sys/GlBsd/BsdSysSocket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketTypes.hpp"
#include "InetSocketAddr.hpp"
#include "Sys/SysSocket.hpp"

Include dependency graph for BsdSysSocket.cpp:

Defines

#define ErrMapEntry(a, w) { c_socket_##a, w }

Define Documentation

#define ErrMapEntry | ( | a,
 |  | w | ) | { c_socket_##a, w }

Generated on Tue Jan 24 23:22:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlBsd/BsdSysSocket.hpp File Reference

Socket/Sys/GlBsd/BsdSysSocket.hpp File Reference

#include <sys/types.h>
#include <sys/socket.h>
#include <Socket/Sys/SysSocketBase.hpp>

Include dependency graph for BsdSysSocket.hpp:

Go to the source code of this file.

Data Structures

class | SysSocket
class | SysSocket::FdSet

Defines

#define | Apoxi_Sys_BsdSysSocket_hpp

Define Documentation

#define Apoxi_Sys_BsdSysSocket_hpp

Generated on Tue Jan 24 23:22:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlBsd/BsdSysSocket.hpp Source File

Socket/Sys/GlBsd/BsdSysSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_Sys_BsdSysSocket_hpp)
00012 #define Apoxi_Sys_BsdSysSocket_hpp
00013
00014 #include <sys/types.h>
00015 #include <sys/socket.h>
00016 #include <Socket/Sys/SysSocketBase.hpp>
00017
00018 /*  -------------------------------------------------------------------------
00019                                         Types
00020     ------------------------------------------------------------------------- */
00021
00022
00027 class SysSocket : public SysSocketBase
00028 {
00029     friend class SocketRxThread;
00030     friend class DataConn;
00031
00032     public:
00033         class FdSet : public fd_set {
00034             public:
00035                 FdSet() { Reset(); }
00036
00037                 BOOLEAN TestFor(const SysSocket &s) const { return FD_ISSET(s.GetHdl(), this); }
00038                 void Add(const SysSocket &s) { FD_SET(s.GetHdl(), this); }
00039                 void Remove(const SysSocket &s) { FD_CLR(s.GetHdl(), this); }
00040                 void Reset() { FD_ZERO(this); }
00041
00042                 FdSet& operator=(const FdSet &fds) {
00043                     memcpy((fd_set *) this, &(const fd_set &) fds, sizeof(fd_set));
00044                     return *this;
00045                 }
00046         };
00047
00048         typedef int SocketHdl;
00049
00050         enum Type {
00051             c_type_dgram = SOCK_DGRAM,
00052             c_type_stream = SOCK_STREAM,
00053             c_type_raw = SOCK_RAW
00054         };
00055
00056         enum AddrFamily {
00057             c_addr_family_inet = AF_INET,
00058             c_addr_family_unspec = AF_UNSPEC
00059         };
00060
00061         enum {
00062             c_pref_stack_size = 3000            // preferred stack size for SocketRxThread
00063         };
00064
00065         typedef int Protocol;
00066
00067         SysSocket(SocketHdl socket = -1);
00068
00069         BOOLEAN IsValid() const { return m_socket != -1; }
00070         SocketHdl GetHdl() const { return m_socket; }
00071
00072         static SocketHdl GetInvalidHdl() { return -1; }
00073
00074         BOOLEAN Init(INT af, INT type, INT protocol);
00075         INT Close();
00076
00077         BOOLEAN Accept(SysSocket *s, InetSocketAddr *peer);
00078         INT Bind(const InetSocketAddr &addr);
00079         INT Connect(const InetSocketAddr &peer);
00080
00081         INT Listen(INT backlog) { return listen(m_socket, backlog); }
00082         INT Recv(void *buf, INT buflen, INT flags) { return recv(m_socket, (CHAR *) buf, buflen, flags); }
00083         INT RecvFrom(void *buf, INT buflen, INT flags, InetSocketAddr &peer);
00084
00085         INT Send(const void *buf, INT buflen, INT flags) { return send(m_socket, (CHAR *) buf, buflen, flags); }
00086         INT SendTo(const void *buf, INT buflen, INT flags, const InetSocketAddr &peer);
00087
00088         INT Shutdown(INT how) { return shutdown(m_socket, how); }
00089
00090         INT GetLocal(InetSocketAddr &local);
00091         INT GetPeer(InetSocketAddr &peer);
00092
00093         INT GetInBufByteCount(UINT &arg) { return ioctl(m_socket, FIONREAD, &arg); }
00094
00095         INT GetOption(OptionType type, INT &val);
00096         INT SetOption(OptionType type, INT val);
00097
00098         SocketError GetSysError();
00099
00100     private:
00101         SocketHdl m_socket;
00102
00103         static INT Select(SysSocket::FdSet &readfds, SysSocket::FdSet &writefds, const Ticks *t_timeout = 0);
00104         static INT SignalSelect();
00105
00106         static SocketError MapSysErrorCode(INT err);
00107         static BOOLEAN MapOptionType(SysSocket::OptionType type, INT &so_level, INT &so_type);
00108
00109         static INT SystemInit() { return 0; }
00110         static INT PppConnSetup(BOOLEAN serial, const CHAR *account, const CHAR *pwd, PppConnSetupDone callback) {
00111             callback(0);
00112             return 0;
00113         };
00114         static INT PppStop(PppConnSetupDone callback) {
00115             callback(0);
00116             return 0;
00117         };
00118         static INT PsdLinkUp(const UINT8 nsapi, BOOLEAN ackmode, UINT32 ipaddr) {
00119             return 0;
00120         };
00121         static INT PsdLinkDown(const UINT8 nsapi) {
00122             return 0;
00123         };
00124 };
00125
00126
00127
00128 #endif  // Apoxi_Sys_BsdSysSocket_hpp
00129
00130
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlDummy/DummyDnsClient.hpp File Reference

Socket/Sys/GlDummy/DummyDnsClient.hpp File Reference

Go to the source code of this file.

Data Structures

class | SysDnsClient

Defines

#define | Apoxi_Os_Win32_DnsClient_hpp

Define Documentation

#define Apoxi_Os_Win32_DnsClient_hpp

Generated on Tue Jan 24 23:22:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlDummy/DummyDnsClient.hpp Source File

Socket/Sys/GlDummy/DummyDnsClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_Os_Win32_DnsClient_hpp)
00012 #define Apoxi_Os_Win32_DnsClient_hpp
00013
00014
00015 class DnsClient;
00016 class DataConnProfile;
00017
00022 class SysDnsClient
00023 {
00024     friend class DnsClient;
00025
00026     public:
00027         static void Init() {}
00028
00030         static UINT16 GetHostByName(const String & name, IpAddr & ip_addr,
00031                                     DataConnProfile * dc_profile) {
00032             return 0;
00033         }
00034
00036         static UINT16 GetHostByAddr(const IpAddr & ip_addr, String & name,
00037                                     DataConnProfile * dc_profile) {
00038             return 0;
00039         }
00040
00041         void OnTimer() {}
00042
00043     protected:
00046         SysDnsClient(DataConnProfile * dc_profile) {}
00047
00048         ~SysDnsClient() {}
00049
00051         BOOLEAN GetHostByNameAsync(DnsClient* dnsc, const String & name) {
00052             return FALSE;
00053         }
00054
00056         BOOLEAN GetHostByAddrAsync(DnsClient* dnsc, const IpAddr & ip_addr) {
00057             return FALSE;
00058         }
00059
00060 };
00061
00062
00063
00064 #endif  // Apoxi_Os_Win32_DnsClient_hpp
00065
00066
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlDummy/DummySysSocket.hpp File Reference

Socket/Sys/GlDummy/DummySysSocket.hpp File Reference

#include <Socket/Sys/SysSocketBase.hpp>

Include dependency graph for DummySysSocket.hpp:

Go to the source code of this file.

Data Structures

class | SysSocket
class | SysSocket::FdSet

Defines

#define | Apoxi_Sys_Dummy_SysSocket_hpp

Define Documentation

#define Apoxi_Sys_Dummy_SysSocket_hpp

Generated on Tue Jan 24 23:22:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlDummy/DummySysSocket.hpp Source File

Socket/Sys/GlDummy/DummySysSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_Sys_Dummy_SysSocket_hpp)
00012 #define Apoxi_Sys_Dummy_SysSocket_hpp
00013
00014
00015 #include <Socket/Sys/SysSocketBase.hpp>
00016
00017
00018 /*  -------------------------------------------------------------------------
00019                                         Types
00020     ------------------------------------------------------------------------- */
00021
00024 class SysSocket : public SysSocketBase
00025 {
00026     friend class SocketRxThread;
00027     friend class DataConn;
00028
00029     public:
00030         class FdSet {
00031             public:
00032                 FdSet() { }
00033
00034                 BOOLEAN TestFor(const SysSocket &s) const { return FALSE; }
00035                 void Add(const SysSocket &s) {  }
00036                 void Remove(const SysSocket &s) { }
00037                 void Reset() { }
00038
00039                 FdSet& operator=(const FdSet &fds) {
00040                     return *this;
00041                 }
00042         };
00043
00044         typedef int SocketHdl;
00045
00046         enum Type {
00047             c_type_dgram,
00048             c_type_stream,
00049             c_type_raw
00050         };
00051
00052         enum AddrFamily {
00053             c_addr_family_inet,
00054             c_addr_family_unspec
00055         };
00056
00057         enum {
00058             c_pref_stack_size = 1000            // preferred stack size for SocketRxThread
00059         };
00060
00061         typedef int Protocol;
00062
00063         SysSocket(SocketHdl socket = -1) { }
00064
00065         BOOLEAN IsValid() const { return -1; }
00066         SocketHdl GetHdl() const { return -1; }
00067
00068         static SocketHdl GetInvalidHdl() { return -1; }
00069
00070         BOOLEAN Init(INT af, INT type, INT protocol) { return FALSE; }
00071         INT Close() { return -1; }
00072
00073         BOOLEAN Accept(SysSocket *s, InetSocketAddr *peer) { return FALSE; }
00074         INT Bind(const InetSocketAddr &addr) { return -1; }
00075         INT Connect(const InetSocketAddr &peer) { return -1; }
00076
00077         INT Listen(INT backlog) { return -1; }
00078         INT Recv(void *buf, INT buflen, INT flags) { return -1; }
00079         INT RecvFrom(void *buf, INT buflen, INT flags, InetSocketAddr &peer) { return -1; }
00080
00081         INT Send(const void *buf, INT buflen, INT flags) { return -1; }
00082         INT SendTo(const void *buf, INT buflen, INT flags, const InetSocketAddr &peer) { return -1; }
00083
00084         INT Shutdown(INT) { return -1; }
00085
00086         INT GetLocal(InetSocketAddr &local) { return -1; }
00087         INT GetPeer(InetSocketAddr &peer) { return -1; }
00088
00089         INT GetInBufByteCount(UINT &arg) { return -1; }
00090
00091         INT GetOption(OptionType type, INT &val) { return -1; }
00092         INT SetOption(OptionType type, INT val) { return -1; }
00093
00094         SocketError GetSysError() { return c_socket_fatal_system_error; }
00095
00096         static INT PsdLinkInit(const UINT8 nsapi) {
00097             return 0;
00098         };
00099
00100         static INT PsdLinkUp(const UINT8 nsapi, BOOLEAN ackmode, UINT32 ipaddr) {
00101             return 0;
00102         };
00103
00104         static INT PsdLinkStop(const UINT8 nsapi) {
00105             return 0;
00106         };
00107
00108     private:
00109         static INT Select(SysSocket::FdSet &readfds, SysSocket::FdSet &writefds, const Ticks *t_timeout = 0) { return -1; }
00110         static INT SignalSelect() { return -1; }
00111
00112         static INT SystemInit() { return 0; }
00113         static INT PppConnSetup(BOOLEAN serial, const CHAR *account, const CHAR *pwd, PppConnSetupDone callback) {
00114             callback(0);
00115             return 0;
00116         };
00117         static INT PppStop(PppConnSetupDone callback) {
00118             callback(0);
00119             return 0;
00120         };
00121 };
00122
00123
00124
00125 #endif  // Apoxi_Sys_Dummy_SysSocket_hpp
00126
00127
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlLwip/LwipSysDnsClient.cpp File Reference

Socket/Sys/GlLwip/LwipSysDnsClient.cpp File Reference

#include "../../PreComp.hpp"
#include "LwipSysDnsClient.hpp"
#include "../../DataConn.hpp"
#include "../../DnsClient.hpp"
#include "../../DnsClientTypes.hpp"
#include <lwIP/ares/netdb.h>
#include <lwIP/dist/src/include/lwip/opt.h>
#include <lwIP/dist/src/include/lwip/arch.h>
#include <lwIP/dist/src/include/lwip/api.h>
#include <lwIP/dist/src/include/lwip/sockets.h>

Include dependency graph for LwipSysDnsClient.cpp:

Defines

#define DNS_WAIT_TIME_100MS 100

Define Documentation

#define DNS_WAIT_TIME_100MS 100

Generated on Tue Jan 24 23:22:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlLwip/LwipSysDnsClient.hpp File Reference

Socket/Sys/GlLwip/LwipSysDnsClient.hpp File Reference

#include <Kernel/Os/SystemTimer.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for LwipSysDnsClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SysDnsClient

Defines

#define | Apoxi_Lwip_SysDnsClient_hpp

Typedefs

typedef NiSharedPtr< DataConn > | DataConnPtr

Define Documentation

#define Apoxi_Lwip_SysDnsClient_hpp

Generated on Tue Jan 24 23:22:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlLwip/LwipSysDnsClient.hpp Source File

Socket/Sys/GlLwip/LwipSysDnsClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Lwip_SysDnsClient_hpp)
00011 #define Apoxi_Lwip_SysDnsClient_hpp
00014
00015 #include <Kernel/Os/SystemTimer.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017 #include <Auxiliary/IpAddr.hpp>
00018 #include <Auxiliary/String.hpp>
00019
00020 class DnsClient;
00021 struct hostent;
00022
00023 class DataConn;
00024 typedef NiSharedPtr<DataConn> DataConnPtr;
00025
00030 class SysDnsClient
00031 {
00032     friend class DnsClient;
00033
00034     public:
00037         static INT GetHostByName(const String &name, IpAddr &ip_addr,
00038             const DataConnPtr &dc_ptr);
00039
00042         static INT GetHostByAddr(const IpAddr &ip_addr, String &name,
00043             const DataConnPtr &dc_ptr);
00044
00045     protected:
00048         SysDnsClient(DnsClient* dns_client);
00049
00052         virtual ~SysDnsClient();
00053
00056         INT GetHostByNameAsync(const String &name);
00057
00060         INT GetHostByAddrAsync(const IpAddr &ip_addr);
00061
00062     private:
00064         DnsClient* m_dns_client;
00065
00069         static BOOLEAN CheckDcAndUpdateNameServers(const DataConnPtr &dc_ptr);
00070
00073         static void AsyncDnsHostByNameCallback(void* client_args,
00074             INT status, struct hostent *host);
00075
00078         static void AsyncDnsHostByAddrCallback(void* client_args,
00079             INT status, struct hostent *host);
00080
00082         static void OnTimer(void *args);
00083
00085         static SystemTimer s_timer;
00086
00087 };
00088
00090 #endif  // Apoxi_Lwip_SysDnsClient_hpp
00091
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlLwip/LwipSysSocket.cpp File Reference

Socket/Sys/GlLwip/LwipSysSocket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "LwipSysSocket.hpp"
#include "../../InetSocketAddr.hpp"
#include "../../SocketSubSystem.hpp"
#include <lwIP/dist/src/include/lwip/opt.h>
#include <lwIP/dist/src/include/lwip/arch.h>
#include <lwIP/dist/src/include/lwip/api.h>
#include <lwIP/dist/src/include/lwip/sockets.h>
#include <lwIP/dist/src/include/lwip/debug.h>
#include <lwIP/dist/src/include/lwip/mem.h>
#include <lwIP/dist/src/include/lwip/memp.h>
#include <lwIP/dist/src/include/lwip/sys.h>
#include <lwIP/dist/src/include/lwip/stats.h>
#include <lwIP/dist/src/include/lwip/tcpip.h>
#include <lwIP/dist/src/include/netif/loopif.h>
#include <lwIP/netif/psdif.h>
#include <lwIP/ares/netdb.h>
#include <stack/stack.h>
#include <sio_scc.h>

Include dependency graph for LwipSysSocket.cpp:

Defines

#define | ErrMapEntry(a, w) { c_socket_##a, w }
#define | GLOBAL
#define | NET_INITIALIZED 0x01
#define | NET_PPP_IN_USE 0x02
#define | NET_PPP_STOP 0x04

Define Documentation

#define ErrMapEntry | ( | a,
 |  | w | ) | { c_socket_##a, w }

#define GLOBAL

#define NET_INITIALIZED 0x01

#define NET_PPP_IN_USE 0x02

#define NET_PPP_STOP 0x04

Generated on Tue Jan 24 23:22:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlLwip/LwipSysSocket.hpp File Reference

Socket/Sys/GlLwip/LwipSysSocket.hpp File Reference

#include <Socket/Sys/SysSocketBase.hpp>
#include <Socket/SocketTypes.hpp>

Include dependency graph for LwipSysSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SysSocket
class | SysSocket::FdSet

Defines

#define | Apoxi_Lwip_SysSocket_hpp

Define Documentation

#define Apoxi_Lwip_SysSocket_hpp

Generated on Tue Jan 24 23:22:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlLwip/LwipSysSocket.hpp Source File

Socket/Sys/GlLwip/LwipSysSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Lwip_SysSocket_hpp)
00011 #define Apoxi_Lwip_SysSocket_hpp
00014
00015 #if !defined(APOXI_SOCKET_SYSTEM_LWIP)
00016     #error incorrect include of LWIP specific header file
00017 #endif
00018
00019 #include <Socket/Sys/SysSocketBase.hpp>
00020 #include <Socket/SocketTypes.hpp>
00021
00022 class InetSocketAddr;
00023 class Ticks;
00024 struct fd_set;
00025
00029 class SysSocket : public SysSocketBase
00030 {
00031     friend class SocketRxThread;
00032     friend class DataConnManager;
00033     friend class PppDataConn;
00034     friend class PsdDataConn;
00035
00036     public:
00037         typedef int SocketHdl;
00038
00039         enum {
00041             c_pref_stack_size = 2000
00042         };
00043
00044         typedef int Protocol;
00045
00046         SysSocket(SocketHdl socket = GetInvalidHdl());
00047
00048         BOOLEAN IsValid() const;
00049         SocketHdl GetHdl() const { return m_socket; }
00050
00051         static SocketHdl GetInvalidHdl();
00052         static UINT8 GetInvalidNsapi();
00053
00054         BOOLEAN Open(AddrFamily af, Type type, Protocol protocol);
00055         BOOLEAN SetNsapi(UINT8 nsapi);
00056         BOOLEAN Close();
00057
00060         BOOLEAN IsBlocking() const;
00061
00065         BOOLEAN SetBlocking(BOOLEAN blocking = TRUE);
00066
00067         BOOLEAN Accept(SysSocket *s, InetSocketAddr *peer);
00068         BOOLEAN Bind(const InetSocketAddr &addr);
00069         BOOLEAN Connect(const InetSocketAddr &peer);
00070         BOOLEAN Listen(INT backlog);
00071
00072         INT Recv(void *buf, INT buflen, INT flags);
00073         INT RecvFrom(void *buf, INT buflen, INT flags, InetSocketAddr &peer);
00074
00075         INT Send(const void *buf, INT buflen, INT flags);
00076         INT SendTo(const void *buf, INT buflen, INT flags,
00077             const InetSocketAddr &peer);
00078
00079         BOOLEAN Shutdown(ShutdownMode how);
00080
00081         BOOLEAN GetLocal(InetSocketAddr &local) const;
00082         BOOLEAN GetPeer(InetSocketAddr &peer) const;
00083
00084         BOOLEAN GetInBufByteCount(UINT &arg) const;
00085
00086         BOOLEAN GetOption(OptionType type, INT &val) const;
00087         BOOLEAN SetOption(OptionType type, INT val);
00088
00089         BOOLEAN GetLingerOption(LingerSetting &linger_setting) const;
00090         BOOLEAN SetLingerOption(const LingerSetting &linger_setting);
00091
00092         SocketError GetSysError(BOOLEAN include_global_errors = TRUE) const;
00093
00097         typedef void (*LwipPppConnSetupDone)(int error);
00098
00102         static void LwipPppSetConnInformation(const void *info);
00103
00104     protected:
00105         SocketError GetSysErr(BOOLEAN check_errno) const;
00106
00107     private:
00108         class FdSet
00109         {
00110             friend class SysSocket;
00111
00112             public:
00113                 FdSet();
00114                 FdSet(const FdSet &fds);
00115                 ~FdSet();
00116
00117                 BOOLEAN TestFor(const SysSocket &s) const;
00118                 void Add(const SysSocket &s);
00119                 void Remove(const SysSocket &s);
00120                 void Reset();
00121
00122                 FdSet& operator=(const FdSet &fds);
00123
00124             private:
00125                 fd_set* m_fd_set;
00126         };
00127
00128         void SetSocket(SocketHdl socket) { m_socket = socket; }
00129
00130         static INT Select(FdSet &readfds, FdSet &writefds,
00131             const Ticks *t_timeout = 0);
00132         static BOOLEAN SignalSelect();
00133
00136         static INT MapType(Type type);
00137         static INT MapAddrFamily(AddrFamily addr_family);
00138         static INT MapShutdownMode(ShutdownMode mode);
00139
00140         static BOOLEAN MapOptionType(OptionType type, INT &so_level,
00141             INT &so_type);
00142
00143         static INT SystemInit();
00144
00145         static INT PppConnSetup(BOOLEAN serial, const CHAR *account,
00146             const CHAR *pwd, PppCallback callback, PppDataConn &dc);
00147
00148         static INT PppCancel();
00149
00150         static INT PppStop(PppCallback callback, PppDataConn &dc);
00151
00152         static INT PsdLinkUp(UINT8 nsapi, BOOLEAN ackmode, UINT32 ipaddr,
00153             BOOLEAN is_umts, PsdIfCallback callback, PsdDataConn &dc);
00154
00155         static INT PsdLinkStop(UINT8 nsapi, PsdIfCallback callback,
00156             PsdDataConn &dc);
00157
00159         static void LwipPppCallBack(int err);
00160
00162
00164         SocketHdl m_socket;
00165
00167         BOOLEAN m_blocking;
00168
00169         // Code signaling the callback function successful PPP setup.
00170         static const int c_ppp_setup_success;
00171
00172         // Code signaling the callback function successful PPP stop.
00173         static const int c_ppp_stop_success;
00174
00176         static LwipPppConnSetupDone m_lwip_ppp_callback;
00177 };
00178
00180 #endif  // Apoxi_Lwip_SysSocket_hpp
00181
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlUsnet/UsnetSysSocket.cpp File Reference

Socket/Sys/GlUsnet/UsnetSysSocket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "SocketTypes.hpp"
#include "InetSocketAddr.hpp"
#include "Sys/SysSocket.hpp"

Include dependency graph for UsnetSysSocket.cpp:

Defines

#define ErrMapEntry(a, w) { c_socket_##a, w }

Define Documentation

#define ErrMapEntry | ( | a,
 |  | w | ) | { c_socket_##a, w }

Generated on Tue Jan 24 23:22:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlUsnet/UsnetSysSocket.hpp File Reference

Socket/Sys/GlUsnet/UsnetSysSocket.hpp File Reference

#include <usnet/local.h>
#include <usnet/socket.h>
#include <Socket/Sys/SysSocketBase.hpp>

Include dependency graph for UsnetSysSocket.hpp:

Go to the source code of this file.

Data Structures

class | SysSocket
class | SysSocket::FdSet

Defines

#define | Apoxi_Sys_BsdSysSocket_hpp

Define Documentation

#define Apoxi_Sys_BsdSysSocket_hpp

Generated on Tue Jan 24 23:22:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlUsnet/UsnetSysSocket.hpp Source File

Socket/Sys/GlUsnet/UsnetSysSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Apoxi_Sys_BsdSysSocket_hpp)
00012 #define Apoxi_Sys_BsdSysSocket_hpp
00013
00014
00015 #if !defined(APOXI_SOCKET_SYSTEM_USNET)
00016     #error incorrect include of USNET specific header file
00017 #endif
00018
00019 extern "C" {                // include usnet files - adopt include path in makefile
00020 #include <usnet/local.h>
00021 #include <usnet/socket.h>
00022 }
00023
00024
00025 #if defined(APOXI_RTOS_OSE166)
00026     #include <usnet/usnet_ose166.h>
00027 #else
00028     #error Unsupported operating system for USNET SysSocket
00029 #endif
00030
00031 #include <Socket/Sys/SysSocketBase.hpp>
00032
00033 /*  -------------------------------------------------------------------------
00034                                         Types
00035     ------------------------------------------------------------------------- */
00036
00037
00041 class SysSocket : public SysSocketBase
00042 {
00043     friend class SocketRxThread;
00044     friend class DataConn;
00045
00046     public:
00047         class FdSet : public fd_set {
00048             public:
00049                 FdSet() { Reset(); }
00050
00051                 BOOLEAN TestFor(const SysSocket &s) const { return FD_ISSET(s.GetHdl(), this); }
00052                 void Add(const SysSocket &s) { FD_SET(s.GetHdl(), this); }
00053                 void Remove(const SysSocket &s) { FD_CLR(s.GetHdl(), this); }
00054                 void Reset() { FD_ZERO(this); }
00055
00056                 FdSet& operator=(const FdSet &fds) {
00057                     memcpy((fd_set *) this, &(const fd_set &) fds, sizeof(fd_set));
00058                     return *this;
00059                 }
00060         };
00061
00062         typedef int SocketHdl;
00063
00064         enum Type {
00065             c_type_dgram = SOCK_DGRAM,
00066             c_type_stream = SOCK_STREAM,
00067             c_type_raw = SOCK_RAW
00068         };
00069
00070         enum AddrFamily {
00071             c_addr_family_inet = AF_INET,
00072             c_addr_family_unspec = AF_UNSPEC
00073         };
00074
00075         enum {
00076             c_pref_stack_size = 2000            // preferred stack size for SocketRxThread
00077         };
00078
00079         typedef int Protocol;
00080
00081         SysSocket(SocketHdl socket = -1);
00082
00083         BOOLEAN IsValid() const { return m_socket != -1; }
00084         SocketHdl GetHdl() const { return m_socket; }
00085
00086         static SocketHdl GetInvalidHdl() { return -1; }
00087
00088         BOOLEAN Init(INT af, INT type, INT protocol);
00089         INT Close();
00090
00091         BOOLEAN Accept(SysSocket *s, InetSocketAddr *peer);
00092         INT Bind(const InetSocketAddr &addr);
00093         INT Connect(const InetSocketAddr &peer);
00094
00095         INT Listen(INT backlog) { return listen(m_socket, backlog); }
00096         INT Recv(void *buf, INT buflen, INT flags) { return recv(m_socket, (CHAR *) buf, buflen, flags); }
00097         INT RecvFrom(void *buf, INT buflen, INT flags, InetSocketAddr &peer);
00098
00099         INT Send(const void *buf, INT buflen, INT flags) { return send(m_socket, (CHAR *) buf, buflen, flags); }
00100         INT SendTo(const void *buf, INT buflen, INT flags, const InetSocketAddr &peer);
00101
00102         INT Shutdown(INT how) { return shutdown(m_socket, how); }
00103
00104         INT GetLocal(InetSocketAddr &local);
00105         INT GetPeer(InetSocketAddr &peer);
00106
00107         INT GetInBufByteCount(UINT &arg) { return ioctlsocket(m_socket, FIONREAD, &arg); }
00108
00109         INT GetOption(OptionType type, INT &val);
00110         INT SetOption(OptionType type, INT val);
00111
00112         SocketError GetSysError();
00113
00114     private:
00115         SocketHdl m_socket;
00116
00117         static INT Select(SysSocket::FdSet &readfds, SysSocket::FdSet &writefds, const Ticks *t_timeout = 0);
00118         static INT SignalSelect();
00119
00120         static SocketError MapSysErrorCode(INT err);
00121         static BOOLEAN MapOptionType(SysSocket::OptionType type, INT &so_level, INT &so_type);
00122
00123         static INT SystemInit() { return net_Init(); }
00124         static INT PppConnSetup(const CHAR *account, const CHAR *pwd, PppConnSetupDone callback);
00125         static void PppCallBack(NetError err);
00126         static INT PppStop(PppConnSetupDone callback) {
00127             callback(0);
00128             return 0;
00129         };
00130 };
00131
00132
00133
00134 #endif  // Apoxi_Sys_BsdSysSocket_hpp
00135
00136
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlWin32/Win32SysDnsClient.cpp File Reference

Socket/Sys/GlWin32/Win32SysDnsClient.cpp File Reference

#include "Socket/PreComp.hpp"
#include "Win32SysDnsClient.hpp"
#include "../../DataConn.hpp"
#include "../../DnsClient.hpp"
#include "../../DnsClientTypes.hpp"
#include <Kernel/Os/Win32/Win32.hpp>
#include <Kernel/Os/SemObtainer.hpp>

Include dependency graph for Win32SysDnsClient.cpp:

Defines

#define DNS_WAIT_TIME_100MS 100

Define Documentation

#define DNS_WAIT_TIME_100MS 100

Generated on Tue Jan 24 23:22:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlWin32/Win32SysDnsClient.hpp File Reference

Socket/Sys/GlWin32/Win32SysDnsClient.hpp File Reference

#include <Kernel/Os/Semaphore.hpp>
#include <Kernel/Os/SystemTimer.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Auxiliary/Vector.hpp>
#include <Auxiliary/IpAddr.hpp>
#include <Auxiliary/String.hpp>

Include dependency graph for Win32SysDnsClient.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SysDnsClient
struct | SysDnsClient::AsyncDnsRequest

Defines

#define | Apoxi_Win32_SysDnsClient_hpp

Typedefs

typedef NiSharedPtr< DataConn > | DataConnPtr

Define Documentation

#define Apoxi_Win32_SysDnsClient_hpp

Generated on Tue Jan 24 23:22:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlWin32/Win32SysDnsClient.hpp Source File

Socket/Sys/GlWin32/Win32SysDnsClient.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Win32_SysDnsClient_hpp)
00011 #define Apoxi_Win32_SysDnsClient_hpp
00014
00015 #include <Kernel/Os/Semaphore.hpp>
00016 #include <Kernel/Os/SystemTimer.hpp>
00017 #include <Auxiliary/NiSharedPtr.hpp>
00018 #include <Auxiliary/Vector.hpp>
00019 #include <Auxiliary/IpAddr.hpp>
00020 #include <Auxiliary/String.hpp>
00021
00022 class DnsClient;
00023 struct hostent;
00024
00025 class DataConn;
00026 typedef NiSharedPtr<DataConn> DataConnPtr;
00027
00032 class SysDnsClient
00033 {
00034     friend class DnsClient;
00035
00036     public:
00039         static INT GetHostByName(const String &name, IpAddr &ip_addr,
00040             const DataConnPtr &dc_ptr);
00041
00044         static INT GetHostByAddr(const IpAddr &ip_addr, String &name,
00045             const DataConnPtr &dc_ptr);
00046
00047     protected:
00050         SysDnsClient(DnsClient* dns_client);
00051
00054         virtual ~SysDnsClient();
00055
00058         INT GetHostByNameAsync(const String &name);
00059
00062         INT GetHostByAddrAsync(const IpAddr &ip_addr);
00063
00064     private:
00066         DnsClient* m_dns_client;
00067
00071         static BOOLEAN CheckDcAndUpdateNameServers(const DataConnPtr &dc_ptr);
00072
00075         static void AsyncDnsHostByNameCallback(void* client_args,
00076             INT status, struct hostent *host);
00077
00080         static void AsyncDnsHostByAddrCallback(void* client_args,
00081             INT status, struct hostent *host);
00082
00084         static void OnTimer(void *args);
00085
00087         static SystemTimer s_timer;
00088
00090
00092         static Semaphore s_async_sem;
00093         static BOOLEAN s_async_sem_init;
00094
00096         struct AsyncDnsRequest {
00097             DnsClient* m_dns_client;
00098             BOOLEAN m_is_host_by_name;
00099             String m_name;
00100             IpAddr m_ip_addr;
00101         };
00102
00104         static Vector<AsyncDnsRequest> s_dns_requests;
00105
00108         static INT AddAsyncDnsRequest(DnsClient* dns_client,
00109             BOOLEAN m_is_host_by_name, const String &name,
00110             const IpAddr &ip_addr);
00111
00114         static INT ProcessAsyncDnsRequests();
00115
00119         static void RemoveAsyncDnsRequests(DnsClient* dns_client);
00120
00121 };
00122
00124 #endif  // Apoxi_Win32_SysDnsClient_hpp
00125
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlWin32/Win32SysSocket.cpp File Reference

Socket/Sys/GlWin32/Win32SysSocket.cpp File Reference

#include "Socket/PreComp.hpp"
#include "Win32SysSocket.hpp"
#include "../../InetSocketAddr.hpp"
#include "../../SocketSubSystem.hpp"
#include <Kernel/Os/SemObtainer.hpp>
#include <Kernel/Os/Win32/Win32.hpp>

Include dependency graph for Win32SysSocket.cpp:

Defines

#define ErrMapEntry(a, w) { c_socket_##a, WSA##w }

Define Documentation

#define ErrMapEntry | ( | a,
 |  | w | ) | { c_socket_##a, WSA##w }

Generated on Tue Jan 24 23:22:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlWin32/Win32SysSocket.hpp File Reference

Socket/Sys/GlWin32/Win32SysSocket.hpp File Reference

#include <Socket/Sys/SysSocketBase.hpp>
#include <Socket/SocketTypes.hpp>

Include dependency graph for Win32SysSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SysSocket
class | SysSocket::FdSet

Defines

#define | Apoxi_Win32_SysSocket_hpp

Define Documentation

#define Apoxi_Win32_SysSocket_hpp

Generated on Tue Jan 24 23:22:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Sys/GlWin32/Win32SysSocket.hpp Source File

Socket/Sys/GlWin32/Win32SysSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_Win32_SysSocket_hpp)
00011 #define Apoxi_Win32_SysSocket_hpp
00014
00015 #include <Socket/Sys/SysSocketBase.hpp>
00016 #include <Socket/SocketTypes.hpp>
00017
00018 class InetSocketAddr;
00019 struct fd_set;
00020 class Ticks;
00021
00025 class SysSocket : public SysSocketBase
00026 {
00027     friend class SocketRxThread;
00028     friend class DataConnManager;
00029     friend class PppDataConn;
00030     friend class PsdDataConn;
00031
00032     public:
00033         typedef UINT32 SocketHdl;
00034
00035         enum {
00037             c_pref_stack_size = 100000
00038         };
00039
00040         typedef INT Protocol;
00041
00042         SysSocket(SocketHdl socket = GetInvalidHdl());
00043
00044         BOOLEAN IsValid() const;
00045         SocketHdl GetHdl() const { return m_socket; }
00046
00047         static SocketHdl GetInvalidHdl();
00048         static UINT8 GetInvalidNsapi();
00049
00050         BOOLEAN Open(AddrFamily af, Type type, Protocol protocol);
00051         BOOLEAN SetNsapi(UINT8 nsapi);
00052         BOOLEAN Close();
00053
00056         BOOLEAN IsBlocking() const;
00057
00061         BOOLEAN SetBlocking(BOOLEAN blocking = TRUE);
00062
00063         BOOLEAN Accept(SysSocket *s, InetSocketAddr *peer);
00064         BOOLEAN Bind(const InetSocketAddr &addr);
00065         BOOLEAN Connect(const InetSocketAddr &peer);
00066         BOOLEAN Listen(INT backlog);
00067
00068         INT Recv(void *buf, INT buflen, INT flags);
00069         INT RecvFrom(void *buf, INT buflen, INT flags, InetSocketAddr &peer);
00070
00071         INT Send(const void *buf, INT buflen, INT flags);
00072         INT SendTo(const void *buf, INT buflen, INT flags,
00073             const InetSocketAddr &peer);
00074
00075         BOOLEAN Shutdown(ShutdownMode how);
00076
00077         BOOLEAN GetLocal(InetSocketAddr &local) const;
00078         BOOLEAN GetPeer(InetSocketAddr &peer) const;
00079
00080         BOOLEAN GetInBufByteCount(UINT &arg) const;
00081
00082         BOOLEAN GetOption(OptionType type, INT &val) const;
00083         BOOLEAN SetOption(OptionType type, INT val);
00084
00085         BOOLEAN GetLingerOption(LingerSetting &linger_setting) const;
00086         BOOLEAN SetLingerOption(const LingerSetting &linger_setting);
00087
00088         SocketError GetSysError(BOOLEAN include_global_errors = TRUE) const;
00089
00090     protected:
00091         SocketError GetSysErr(BOOLEAN check_errno) const;
00092
00093     private:
00094         class FdSet
00095         {
00096             friend class SysSocket;
00097
00098             public:
00099                 FdSet();
00100                 FdSet(const FdSet &fds);
00101                 ~FdSet();
00102
00103                 BOOLEAN TestFor(const SysSocket &s) const;
00104                 void Add(const SysSocket &s);
00105                 void Remove(const SysSocket &s);
00106                 void Reset();
00107
00108                 FdSet& operator=(const FdSet &fds);
00109
00110             private:
00111                 fd_set *m_fd_set;
00112         };
00113
00114         void SetSocket(SocketHdl socket) { m_socket = socket; }
00115
00116         static BOOLEAN InitCmdSockets();
00117
00118         static INT Select(FdSet &readfds, FdSet &writefds,
00119             const Ticks *t_timeout = 0);
00120         static BOOLEAN SignalSelect();
00121
00124         static INT MapType(Type type);
00125         static INT MapAddrFamily(AddrFamily addr_family);
00126         static INT MapShutdownMode(ShutdownMode mode);
00127
00128         static BOOLEAN MapOptionType(OptionType type, INT &so_level,
00129             INT &so_type);
00130
00131         static INT SystemInit() { return 0; }
00132
00133         static INT PppConnSetup(BOOLEAN serial, const CHAR *account,
00134             const CHAR *pwd, PppCallback callback, PppDataConn &dc);
00135
00136         static INT PppStop(PppCallback callback, PppDataConn &dc) {
00137             callback(c_ppp_stop_success, dc, 0);
00138             return 0;
00139         }
00140
00141         static INT PppCancel() {
00142             return 0;
00143         }
00144
00145         static INT PsdLinkUp(UINT8 nsapi, BOOLEAN ackmode, UINT32 ipaddr,
00146             BOOLEAN is_umts, PsdIfCallback callback, PsdDataConn &dc)
00147         {
00148             callback(0, static_cast<void*>(&dc)); // Simulate good case.
00149             return 0;
00150         }
00151
00152         static INT PsdLinkStop(UINT8 nsapi, PsdIfCallback callback,
00153             PsdDataConn &dc) {
00154             callback(0, static_cast<void*>(&dc)); // Simulate good case.
00155             return 0;
00156         }
00157
00159
00161         SocketHdl m_socket;
00162
00164         BOOLEAN m_blocking;
00165
00167         static const int c_ppp_setup_success;
00168
00170         static const int c_ppp_stop_success;
00171 };
00172
00174 #endif  // Apoxi_Win32_SysSocket_hpp
00175
Generated on Tue Jan 24 14:50:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket/Test/UdpServer/UdpServer.cpp File Reference

Socket/Test/UdpServer/UdpServer.cpp File Reference

#include <netinet/in.h>
#include <arpa/inet.h>
#include <sys/time.h>
#include <sys/types.h>
#include <sys/socket.h>
#include <stdlib.h>
#include <stdio.h>
#include <unistd.h>
#include <string.h>
#include <signal.h>
#include <errno.h>

Include dependency graph for UdpServer.cpp:

Functions

int | main (int argc, char *argv[])

Variables

bool | g_echo_mode = true
sockaddr_in | g_local_addr
bool | g_random_packets = true

Function Documentation

int main | ( | int | argc,
 |  | char * | argv[]
 | ) |

Variable Documentation

bool g_echo_mode = true

sockaddr_in g_local_addr

bool g_random_packets = true

Generated on Tue Jan 24 23:22:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/AsyncUnitTestCase.cpp File Reference

UnitTest/AsyncUnitTestCase.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for AsyncUnitTestCase.cpp:

Generated on Tue Jan 24 23:22:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/AsyncUnitTestCase.hpp File Reference

UnitTest/AsyncUnitTestCase.hpp File Reference

Go to the source code of this file.

Defines

#define Apoxi_UnitTestCaseAsync_hpp

Define Documentation

#define Apoxi_UnitTestCaseAsync_hpp

Generated on Tue Jan 24 23:22:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/AsyncUnitTestCase.hpp Source File

UnitTest/AsyncUnitTestCase.hpp

Go to the documentation of this file.
00001      /* ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTestCaseAsync_hpp)
00010 #define Apoxi_UnitTestCaseAsync_hpp
00013
00014 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00015 #ifdef APOXI_UNITTEST
00016
00017 #include "UnitTest.hpp"
00018 #include "UnitTestCase.hpp"
00019 #include "MsgTypes.hpp"
00020
00021 #include <Kernel/UserDispatcher.hpp>
00022 #include <Auxiliary/TriggerTimer.hpp>
00023
00024 /*  ------------------------------------------------------------------------
00025     BEGIN_ASYNC_UNIT_TEST_CASE
00026     ------------------------------------------------------------------------ */
00027
00028 #ifdef APOXI_UNITTEST_NO_TESTNAMES
00029     #define BEGIN_ASYNC_UNITTEST_CLASS(TestClass) \
00030         public: \
00031             static UnitTest* CreateInstance() { return new TestClass(); } \
00032             static BOOLEAN (*GetDescendantsAccessMethod()) (UINT16, UnitTestSuiteData *) {return 0;}; \
00033         protected:\
00034             APOXI_UNITTEST_INSTANCE_PER_TEST_METHODS(TestClass) \
00035         private: \
00036             BOOLEAN _Execute(UnitTestResult& test_result) \
00037             {\
00038                 \
00039                 BOOLEAN success = TRUE;\
00040                 Init(); \
00041                 m_test_result = &test_result
00042 #else
00043     #define BEGIN_ASYNC_UNITTEST_CLASS(TestClass) \
00044         public: \
00045             static UnitTest* CreateInstance() { return new TestClass(); } \
00046             static BOOLEAN (*GetDescendantsAccessMethod()) (UINT16, UnitTestSuiteData *) {return 0;}; \
00047             static const CHAR* const GetName() { return #TestClass; } \
00048         protected:\
00049             APOXI_UNITTEST_INSTANCE_PER_TEST_METHODS(TestClass) \
00050         private: \
00051             BOOLEAN _Execute(UnitTestResult& test_result) \
00052             {\
00053                 \
00054                 BOOLEAN success = TRUE;\
00055                 Init(); \
00056                 m_test_result = &test_result
00057 #endif
00058 // BEGIN_ASYNC_UNITTEST_CASE
00059
00060
00061 /*  ------------------------------------------------------------------------
00062     END_ASYNC_UNITTEST_CLASS
00063     ------------------------------------------------------------------------ */
00064
00065
00066 #define END_ASYNC_UNITTEST_CLASS \
00067         ClearStatusText();\
00068         return success;\
00069         };
00070
00071
00072 // END_ASYNC_UNITTEST_CLASS
00073
00074
00075
00076
00077
00078
00085 class AsyncUnitTestCase : public UnitTestCase, public UserDispatcher {
00086
00087     public:
00088         AsyncUnitTestCase();
00089         virtual ~AsyncUnitTestCase();
00090
00091     protected:
00093         virtual BOOLEAN OnMessage(const Message &msg);
00094
00104         const Message* WaitForMessage(UINT16 message_id, UINT32 timeout);
00105
00106
00117         const Message* WaitForFirstCaughtMessage(const UINT16 message_ids[], UINT16 nr_of_messages, UINT32 timeout);
00118
00130         const Message* WaitForAllMessages(const UINT16 message_ids[], UINT16 nr_of_messages, UINT32 timeout);
00131
00132
00133     protected:
00135         void ClearStatusText();
00136     private:
00137
00139         void SetTimeoutStatusText(UINT32 m_timeout);
00140
00142         BOOLEAN CatchOneMessage(const Message &msg);
00143
00145         BOOLEAN CatchOneOfNMessage(const Message &msg);
00146
00148         BOOLEAN CatchAllOfNMessage(const Message &msg);
00149
00151         UINT16 m_wait_for_message_id;
00152
00154         const Message* m_received_message;
00155
00157         BooleanCondition m_resume;
00158
00159         friend class TriggerTimer<AsyncUnitTestCase>;
00161         TriggerTimer<AsyncUnitTestCase> m_timer;
00162
00164         void OnTimer();
00165
00166         // starts timer and waits for timeout
00167         const Message* Wait(UINT32 timeout);
00168
00169         // checks if the current message is within the messages we are waiting for
00170         void UpdateCaughtMessagesIndicator(const Message &msg);
00171
00172         // checks if all required messages are received
00173         BOOLEAN CaughtAllMessages();
00174
00176         UINT32  m_timeout;
00177
00179         Application* m_application;
00180
00182         AsyncUnitTestMsg m_waiting_for_timeout_msg;
00183
00184         UINT16 const * m_message_ids;
00185         UINT16 m_nr_of_messages;
00186         BOOLEAN m_multimessage_wait;
00187         BOOLEAN m_wait_for_all;
00188
00190         WString  m_waiting_for_timeout_msg_text;
00191
00192         BOOLEAN * m_caught_messages_indicator;
00193 };
00194 #endif //APOXI_UNITTEST
00195 #endif //DOXYGEN_SHOULD_SKIP_THIS
00196
00198 #endif  // Apoxi_UnitTestCaseAsyn_hpp
00199
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/Decorator.cpp File Reference

UnitTest/Decorator.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for Decorator.cpp:

Generated on Tue Jan 24 23:23:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/Decorator.hpp File Reference

UnitTest/Decorator.hpp File Reference

Go to the source code of this file.

Defines

#define Apoxi_UnitTestDecorator_hpp

Define Documentation

#define Apoxi_UnitTestDecorator_hpp

Generated on Tue Jan 24 23:23:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/Decorator.hpp Source File

UnitTest/Decorator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTestDecorator_hpp)
00010 #define Apoxi_UnitTestDecorator_hpp
00013
00014 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00015 #ifdef APOXI_UNITTEST
00016
00017 #include "UnitTest.hpp"
00018 #include "UnitTestResult.hpp"
00019
00022 class Decorator : public UnitTest {
00023
00024     public:
00025         virtual ~Decorator() {};
00026     protected:
00027         Decorator(UnitTestHandle unit_test_case) {
00028             _unit_test_case = unit_test_case;
00029         }
00030
00031     protected:
00032         UnitTestHandle _unit_test_case;
00033
00035         virtual BOOLEAN _Execute(UnitTestResult& test_result) = 0;
00036 };
00037
00038
00041 class RepeatedUnitTest : public Decorator {
00042     typedef Decorator Base;
00043
00044     public:
00045         virtual ~RepeatedUnitTest() {};
00046
00047
00048     protected:
00049         RepeatedUnitTest(UnitTestHandle unit_test_case, INT loops) : Base(unit_test_case) {
00050             m_loops = loops;
00051         }
00052
00053         INT m_loops;
00054
00056         virtual BOOLEAN _Execute(UnitTestResult& test_result);
00057 };
00058
00059 /*  ------------------------------------------------------------------------
00060     DEFINE_REPEATED_UNITTEST
00061     ------------------------------------------------------------------------ */
00062 #define DEFINE_REPEATED_UNITTEST(RepeatedUnitTestClass, UnitTestClass, loops) \
00063 class RepeatedUnitTestClass : public RepeatedUnitTest {\
00064         typedef RepeatedUnitTest Base;\
00065         \
00066         private:\
00067             RepeatedUnitTestClass(UnitTestHandle unit_test_case) : Base(unit_test_case, loops) {} \
00068         public: \
00069             static BOOLEAN (*GetDescendantsAccessMethod()) (UINT16, UnitTestSuiteData *) {return UnitTestClass::GetDescendantsAccessMethod();}; \
00070             static UnitTest* CreateInstance() { \
00071                 return new RepeatedUnitTestClass(GET_UNITTEST_HANDLE(UnitTestClass)); \
00072             } \
00073     } \
00074
00075
00076
00077 #endif //APOXI_UNITTEST
00078 #endif //DOXYGEN_SHOULD_SKIP_THIS
00079
00081 #endif  // Apoxi_UnitTestDecorator_hpp
00082
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/MsgTypes.cpp File Reference

UnitTest/MsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/MsgTypes.hpp File Reference

UnitTest/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AsyncUnitTestMsg
class | UtcStatusMessage

Defines

#define | UnitTest_MsgTypes_hpp

Define Documentation

#define UnitTest_MsgTypes_hpp

Generated on Tue Jan 24 14:56:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/MsgTypes.hpp Source File

UnitTest/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Apoxi\UnitTest\MsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(UnitTest_MsgTypes_hpp)
00014 #define UnitTest_MsgTypes_hpp
00015 #include <Kernel/Message.hpp>
00016 #include <Auxiliary/WString.hpp>
00017 /* ----------------------------------------------------------------------
00018     Classes
00019     ---------------------------------------------------------------------- */
00020 /*  ======================================================================
00021     Class AsyncUnitTestMsg
00022     ====================================================================== */
00023 class AsyncUnitTestMsg : public ApplicationMsg {
00024     public:
00025         AsyncUnitTestMsg(Application* application, const WString& MessageText);
00026         virtual ~AsyncUnitTestMsg();
00027
00028         virtual const MsgMetaData& GetMetaData() const;
00029         void SetMessageText(const WString& MessageText) { m_MessageText = MessageText; }
00030         const WString& GetMessageText() const { return m_MessageText; }
00031         virtual Message* Clone() const;
00032
00033         enum  {
00034             ID = 19300
00035             };
00036
00037     private:
00038         static const MsgMetaData m_meta_data;
00039         WString m_MessageText;
00040
00041     };
00042 /*  ======================================================================
00043     Class UtcStatusMessage
00044     ====================================================================== */
00045 class UtcStatusMessage : public ApplicationMsg {
00046     public:
00047         UtcStatusMessage(Application* application, const WString& MessageText, BOOLEAN ConnectionLost);
00048         virtual ~UtcStatusMessage();
00049
00050         virtual const MsgMetaData& GetMetaData() const;
00051         void SetMessageText(const WString& MessageText) { m_MessageText = MessageText; }
00052         const WString& GetMessageText() const { return m_MessageText; }
00053         void SetConnectionLost(BOOLEAN ConnectionLost) { m_ConnectionLost = ConnectionLost; }
00054         BOOLEAN IsConnectionLost() const { return m_ConnectionLost; }
00055         virtual Message* Clone() const;
00056
00057         enum  {
00058             ID = 19301
00059             };
00060
00061     private:
00062         static const MsgMetaData m_meta_data;
00063         WString m_MessageText;
00064         BOOLEAN m_ConnectionLost;
00065
00066     };
00067 #endif // UnitTest_MsgTypes_hpp
00068
00069
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/PreComp.cpp File Reference

UnitTest/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:08:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/PreComp.hpp File Reference

UnitTest/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:22:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/PreComp.hpp Source File

UnitTest/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012
00013
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTest.cpp File Reference

UnitTest/UnitTest.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTest.cpp:

Generated on Tue Jan 24 23:23:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTest.hpp File Reference

UnitTest/UnitTest.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_UnitTest_hpp

Define Documentation

#define Apoxi_UnitTest_hpp

Generated on Tue Jan 24 23:23:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTest.hpp Source File

UnitTest/UnitTest.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTest_hpp)
00010 #define Apoxi_UnitTest_hpp
00013
00014 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00015 #ifdef APOXI_UNITTEST
00016 #include "UnitTestResult.hpp"
00017
00018 /*  ------------------------------------------------------------------------
00019     GET_UNITTEST_HANDLE
00020     ------------------------------------------------------------------------ */
00021 #define GET_UNITTEST_HANDLE(TestClass)  TestClass::CreateInstance
00022 // GET_UNITTEST_HANDLE
00023
00026 class UnitTest {
00027
00028 public:
00029     UnitTest() {};
00030     virtual ~UnitTest() {};
00031
00036     BOOLEAN Run(UnitTestResult& test_result) { return _Execute(test_result); }
00037
00038
00039 protected:
00040
00041
00042
00049     virtual BOOLEAN _Execute(UnitTestResult& test_result) = 0;
00050
00051     BOOLEAN m_track_errors;
00052
00053     BOOLEAN m_error_occured;
00054
00055 }; // UnitTest
00056
00057 typedef UnitTest* (*UnitTestHandle)();
00058
00059
00060 #endif //APOXI_UNITTEST
00061 #endif //DOXYGEN_SHOULD_SKIP_THIS
00062
00063 #endif  // Apoxi_UnitTest_hpp
00064
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestAutoRepository.cpp File Reference

UnitTest/UnitTestAutoRepository.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestAutoRepository.cpp:

Generated on Tue Jan 24 23:23:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestAutoRepository.hpp File Reference

UnitTest/UnitTestAutoRepository.hpp File Reference

#include "UnitTestRepository.hpp"

Include dependency graph for UnitTestAutoRepository.hpp:

Go to the source code of this file.

Defines

#define Apoxi_UnitTestAutoRepository_hpp

Define Documentation

#define Apoxi_UnitTestAutoRepository_hpp

Generated on Tue Jan 24 23:23:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestAutoRepository.hpp Source File

UnitTest/UnitTestAutoRepository.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTestAutoRepository_hpp)
00010 #define Apoxi_UnitTestAutoRepository_hpp
00013
00014 #include "UnitTestRepository.hpp"
00015
00016 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00017 #ifdef APOXI_UNITTEST
00018 #ifndef APOXI_UNITTEST_STATIC_REPOSITORY
00019
00020 /*  ------------------------------------------------------------------------
00021     DEFINES TO FORCE LINKER TO KEEP TESTCLASS CODE
00022     ------------------------------------------------------------------------ */
00023 #ifdef APOXI_TARGETSYSTEM_HOST
00024     #define SYMBOL_DECORATOR_START() /include:?c_test_data_
00025     #define APPEND_TO_SYMBOL_NAME(className) className
00026     #ifdef REGISTER_UNITTESTSUITE
00027         #define SYMBOL_DECORATOR_END @@3VUnitTestSuiteData@@B
00028     #else
00029         #define SYMBOL_DECORATOR_END @@3VUnitTestData@@B
00030     #endif
00031     #define ASSEMBLE_DECORATOR(decorator) QUOTE_DECORATOR(decorator)
00032     #define QUOTE_DECORATOR(decorator) #decorator
00033     #define INCLUDE_SYMBOL(className) comment (linker, ASSEMBLE_DECORATOR(SYMBOL_DECORATOR_START()APPEND_TO_SYMBOL_NAME(className)SYMBOL_DECORATOR_END))
00034     #define END_INCLUDE_SYMBOL comment( user, "")
00035 #else
00036     #ifdef APOXI_COMPILER_C166
00037         // Using the pragmas no_global_dead_store_elim and global_dead_store_elim. Tasking Compiler doesnot perform preprocessor macro substituions for pragmas.
00038         // Thus, pragmas are directly added to UnitTestRegistrar.hpp
00039         #define INCLUDE_SYMBOL(className)
00040     #endif
00041     #ifdef APOXI_COMPILER_RVCT
00042         // Use the -keep linker command line option to prevent linker from optimizing out (wrongly detected) unused code
00043         #define INCLUDE_SYMBOL(className)
00044     #endif
00045     #ifdef APOXI_COMPILER_ADS
00046         // Use the -keep linker command line option to prevent linker from optimizing out (wrongly detected) unused code
00047         #define INCLUDE_SYMBOL(className)
00048     #endif
00049 #endif // APOXI_TARGETSYSTEM_HOST
00050 // DEFINES TO FORCE LINKER TO KEEP TESTCLASS CODE
00051
00052
00053
00054 /*  ------------------------------------------------------------------------
00055     DEFINES FOR THE DYNAMIC REPOSITORY
00056     ------------------------------------------------------------------------ */
00057
00058 #ifdef APOXI_TARGETSYSTEM_HOST
00059     #undef DECLARATION_START_EXP
00060     #ifdef REGISTER_UNITTESTSUITE
00061         #define DECLARATION_START_EXP(ClassName) extern const UnitTestSuiteData c_test_data_##ClassName
00062     #else
00063         #define DECLARATION_START_EXP(ClassName) extern const UnitTestData c_test_data_##ClassName
00064     #endif
00065     #define DECLARATION_START(ClassName) DECLARATION_START_EXP(ClassName)
00066     #undef REGISTER_UNITTEST
00067     #ifdef APOXI_UNITTEST_NO_TESTNAMES
00068         #ifdef REGISTER_UNITTESTSUITE
00069             #define REGISTER_UNITTEST(ClassName) DECLARATION_START(ClassName)(ClassName::CreateInstance, UnitTestData::m_instance_counter, UnitTestData::m_latest_instance, ClassName::GetTestAtStatic);
00070         #else
00071             #define REGISTER_UNITTEST(ClassName) DECLARATION_START(ClassName)(ClassName::CreateInstance, UnitTestData::m_instance_counter, UnitTestData::m_latest_instance);
00072         #endif
00073     #else
00074         #define STRINGIZE_NAME_EXP(ClassName) L###ClassName
00075         #define STRINGIZE_NAME(ClassName) STRINGIZE_NAME_EXP(ClassName)
00076         #undef REGISTER_UNITTEST
00077         #ifdef REGISTER_UNITTESTSUITE
00078             #define REGISTER_UNITTEST(ClassName) DECLARATION_START(ClassName)(ClassName::CreateInstance, STRINGIZE_NAME(ClassName), UnitTestData::m_instance_counter, UnitTestData::m_latest_instance, ClassName::GetTestAtStatic);
00079         #else
00080             #define REGISTER_UNITTEST(ClassName) DECLARATION_START(ClassName)(ClassName::CreateInstance, STRINGIZE_NAME(ClassName), UnitTestData::m_instance_counter, UnitTestData::m_latest_instance);
00081         #endif
00082     #endif
00083 #else
00084     #undef DECLARATION_START_EXP
00085     #ifdef REGISTER_UNITTESTSUITE
00086         #define DECLARATION_START_EXP(ClassName) extern const UnitTestSuiteData c_test_data_##ClassName
00087     #else
00088         #define DECLARATION_START_EXP(ClassName) extern const UnitTestData c_test_data_##ClassName
00089     #endif
00090     #define DECLARATION_START(ClassName) DECLARATION_START_EXP(ClassName)
00091     #undef REGISTER_UNITTEST
00092     #ifdef APOXI_UNITTEST_NO_TESTNAMES
00093         #ifdef REGISTER_UNITTESTSUITE
00094             #define REGISTER_UNITTEST(ClassName) DECLARATION_START(ClassName)(ClassName::CreateInstance, UnitTestData::m_instance_counter, UnitTestData::m_latest_instance, ClassName::GetTestAtStatic);
00095         #else
00096             #define REGISTER_UNITTEST(ClassName) DECLARATION_START(ClassName)(ClassName::CreateInstance, UnitTestData::m_instance_counter, UnitTestData::m_latest_instance);
00097         #endif
00098     #else
00099         #define STRINGIZE_NAME_EXP(ClassName) L###ClassName
00100         #define STRINGIZE_NAME(ClassName) STRINGIZE_NAME_EXP(ClassName)
00101         #ifdef REGISTER_UNITTESTSUITE
00102             #define REGISTER_UNITTEST(ClassName) DECLARATION_START(ClassName)(ClassName::CreateInstance, STRINGIZE_NAME(ClassName), UnitTestData::m_instance_counter, UnitTestData::m_latest_instance, ClassName::GetTestAtStatic);
00103         #else
00104             #define REGISTER_UNITTEST(ClassName) DECLARATION_START(ClassName)(ClassName::CreateInstance, STRINGIZE_NAME(ClassName), UnitTestData::m_instance_counter, UnitTestData::m_latest_instance);
00105         #endif
00106     #endif
00107 #endif
00108
00109 // DEFINES FOR THE DYNAMIC REPOSITORY
00110
00114 class UnitTestAutoRepository: public UnitTestRepository{
00115     friend UnitTestRepository;
00116     public:
00117         virtual ~UnitTestAutoRepository();
00118
00123         UINT16 GetTestCount() const { return m_count; }
00124
00130         const UnitTestData* GetTestAt(UINT16 index) const;
00136         const UnitTestData* GetTestAt(void* address) const;
00137
00144         BOOLEAN CopyHandleToBuffer(void* buffer, UINT16 index) const;
00145
00146     protected:
00147         UnitTestAutoRepository();
00148     private:
00149
00150         static UnitTestAutoRepository* m_instance;
00151
00152         static const UnitTestData*  m_unit_test_data_anchor;
00153         static UINT16 m_count;
00154
00155
00156 };
00157
00158
00160 #endif //APOXI_UNITTEST_STATIC_REPOSITORY
00161 #endif //APOXI_UNITTEST
00162 #endif //DOXYGEN_SHOULD_SKIP_THIS
00163 #endif  // Apoxi_UnitTestAutoRepository_hpp
00164
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestCase.cpp File Reference

UnitTest/UnitTestCase.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestCase.cpp:

Generated on Tue Jan 24 23:23:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestCase.hpp File Reference

UnitTest/UnitTestCase.hpp File Reference

Go to the source code of this file.

Defines

#define Apoxi_UnitTestCase_hpp

Define Documentation

#define Apoxi_UnitTestCase_hpp

Generated on Tue Jan 24 23:23:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestCase.hpp Source File

UnitTest/UnitTestCase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Apoxi_UnitTestCase_hpp)
00011 #define Apoxi_UnitTestCase_hpp
00014
00015 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00016 #ifdef APOXI_UNITTEST
00017
00018 #include "UnitTest.hpp"
00019 #include "UnitTestResult.hpp"
00020
00021 class UnitTestSuiteData;
00022 /*  ------------------------------------------------------------------------
00023     UNITTEST_ERROR
00024     ------------------------------------------------------------------------ */
00025 #if defined APOXI_UNITTEST_NO_FILENAMES
00026     #define UNITTEST_ERROR(file, line, msg) \
00027         Error();
00028 #elif defined APOXI_UNITTEST_NO_MESSAGES
00029     #define UNITTEST_ERROR(file, line, msg) \
00030         Error(file, line);
00031 #else
00032     #define UNITTEST_ERROR(file, line, msg) \
00033         Error(file, line, msg);
00034 #endif
00035 // UNITTEST_ERROR
00036
00037
00038 /*  ------------------------------------------------------------------------
00039     CLAIM_TRUE
00040     ------------------------------------------------------------------------ */
00041 #define CLAIM_TRUE(condition) \
00042     if (!(condition)) { \
00043         UNITTEST_ERROR(__FILE__,__LINE__, #condition);  \
00044         return; \
00045     }
00046 // CLAIM_TRUE
00047
00048
00049 /*  ------------------------------------------------------------------------
00050     CLAIM_TRUE_INFO
00051     ------------------------------------------------------------------------ */
00052 #define CLAIM_TRUE_INFO(condition, msg) \
00053     if (!(condition)) { \
00054         UNITTEST_ERROR(__FILE__,__LINE__, #msg);    \
00055         return; \
00056     }
00057 // CLAIM_TRUE_INFO
00058
00059 /*  ------------------------------------------------------------------------
00060     CLAIM_FALSE
00061     ------------------------------------------------------------------------ */
00062 #define CLAIM_FALSE(condition) \
00063     if ((condition)) {  \
00064         UNITTEST_ERROR(__FILE__,__LINE__, #condition);  \
00065         return; \
00066     }
00067 // CLAIM_FALSE
00068
00069 /*  ------------------------------------------------------------------------
00070     CLAIM_FALSE_INFO
00071     ------------------------------------------------------------------------ */
00072 #define CLAIM_FALSE_INFO(condition, msg) \
00073     if ((condition)) {  \
00074         UNITTEST_ERROR(__FILE__,__LINE__, #msg);    \
00075         return; \
00076     }
00077 // CLAIM_FALSE_INFO
00078
00079
00080 /*  ------------------------------------------------------------------------
00081     CLAIM_NOT_NULL
00082     ------------------------------------------------------------------------ */
00083 #define CLAIM_NOT_NULL(pointer) \
00084     if (pointer == 0) { \
00085         UNITTEST_ERROR(__FILE__,__LINE__, #pointer);    \
00086         return; \
00087     }
00088 // CLAIM_NOT_NULL
00089
00090 /*  ------------------------------------------------------------------------
00091     CLAIM_NOT_NULL_INFO
00092     ------------------------------------------------------------------------ */
00093 #define CLAIM_NOT_NULL_INFO(pointer, msg) \
00094     if (pointer == 0) { \
00095         UNITTEST_ERROR(__FILE__,__LINE__, msg); \
00096         return; \
00097     }
00098 // CLAIM_NOT_NULL_INFO
00099
00100 /*  ------------------------------------------------------------------------
00101     CLAIM_NULL
00102     ------------------------------------------------------------------------ */
00103 #define CLAIM_NULL(pointer) \
00104     if (pointer != 0) { \
00105         UNITTEST_ERROR(__FILE__,__LINE__, #pointer);    \
00106         return; \
00107     }
00108 // CLAIM_NULL
00109
00110 /*  ------------------------------------------------------------------------
00111     CLAIM_NULL_INFO
00112     ------------------------------------------------------------------------ */
00113 #define CLAIM_NULL_INFO(pointer, msg) \
00114     if (pointer != 0) { \
00115         UNITTEST_ERROR(__FILE__,__LINE__, #msg);    \
00116         return; \
00117     }
00118 // CLAIM_NULL_INFO
00119
00120 /*  ------------------------------------------------------------------------
00121     APOXI_UNITTEST_INSTANCE_PER_TEST_METODS
00122     ------------------------------------------------------------------------ */
00123 # define APOXI_UNITTEST_INSTANCE_PER_TEST_METHODS(TestClass) \
00124             TestClass* m_single_test_instance; \
00125             void CreateSingleTestInstance() { m_single_test_instance = new TestClass(); } \
00126             TestClass* GetSingleTestInstance() { return m_single_test_instance; } \
00127             void DeleteSingleTestInstance() { delete m_single_test_instance; m_single_test_instance = 0;} \
00128             void SetUnitTestResult (UnitTestResult* test_result) { m_test_result = test_result; } \
00129             BOOLEAN GetCurrentTestSuccess() { return m_current_test_success; } \
00130             void SetCurrentTestSuccess(BOOLEAN current_test_success) { m_current_test_success = current_test_success; } \
00131             \
00132
00133 // APOXI_UNITTEST_INSTANCE_PER_TEST_METODS
00134
00135 /*  ------------------------------------------------------------------------
00136     BEGIN_UNITTEST_CLASS
00137     ------------------------------------------------------------------------ */
00138 #ifdef APOXI_UNITTEST_NO_TESTNAMES
00139     #define BEGIN_UNITTEST_CLASS(TestClass) \
00140         public: \
00141             static UnitTest* CreateInstance() { return new TestClass(); } \
00142             static BOOLEAN (*GetDescendantsAccessMethod()) (UINT16, UnitTestSuiteData *) {return 0;}; \
00143         protected: \
00144             APOXI_UNITTEST_INSTANCE_PER_TEST_METHODS(TestClass) \
00145             \
00146             BOOLEAN _Execute(UnitTestResult& test_result) \
00147             {\
00148                 \
00149                 BOOLEAN success = TRUE;\
00150                 Init();\
00151                 m_test_result = &test_result
00152 #else
00153     #define BEGIN_UNITTEST_CLASS(TestClass) \
00154         public: \
00155             static UnitTest* CreateInstance() { return new TestClass(); } \
00156             static BOOLEAN (*GetDescendantsAccessMethod()) (UINT16, UnitTestSuiteData *) {return 0;}; \
00157             virtual const CHAR* GetName() { return #TestClass; } \
00158             \
00159         protected: \
00160             APOXI_UNITTEST_INSTANCE_PER_TEST_METHODS(TestClass) \
00161 \
00162             BOOLEAN _Execute(UnitTestResult& test_result) \
00163             {\
00164                 \
00165                 BOOLEAN success = TRUE; \
00166                 Init();\
00167                 m_test_result = &test_result
00168 #endif
00169
00170 // BEGIN_UNITTEST_CLASS
00171
00172 /*  ------------------------------------------------------------------------
00173     ADD_TEST_CASE
00174     ------------------------------------------------------------------------ */
00175 #define ADD_TEST_CASE(TestMethod) \
00176         CreateSingleTestInstance(); \
00177         GetSingleTestInstance()->SetUnitTestResult(&test_result); \
00178         GetSingleTestInstance()->SetCurrentTestSuccess(TRUE); \
00179         GetSingleTestInstance()->EnterSetup(); \
00180         GetSingleTestInstance()->Setup(); \
00181         GetSingleTestInstance()->LeaveSetup(); \
00182         if (!GetSingleTestInstance()->SetupErrorOccured()) { \
00183             GetSingleTestInstance()->TestMethod(); \
00184             if (GetSingleTestInstance()->GetCurrentTestSuccess()) { \
00185                 m_current_test_success = true; \
00186                 test_result.AddSuccess(); \
00187             } \
00188             else { \
00189                 m_current_test_success = false; \
00190                 success = FALSE; \
00191             } \
00192         } \
00193         GetSingleTestInstance()->EnterTeardown(); \
00194         GetSingleTestInstance()->Teardown(); \
00195         GetSingleTestInstance()->LeaveTeardown(); \
00196         DeleteSingleTestInstance();
00197
00198 // ADD_TEST_CASE
00199
00200 /*  ------------------------------------------------------------------------
00201     END_UNITTEST_CLASS
00202     ------------------------------------------------------------------------ */
00203 #define END_UNITTEST_CLASS \
00204             return success; \
00205                 };
00206 // END_UNITTEST_CLASS
00207
00208
00211 class UnitTestCase : public UnitTest {
00212
00213     public:
00214
00215         UnitTestCase() :
00216           m_in_teardown(false), m_in_setup(false),
00217           m_teardown_error_occured(false), m_setup_error_occured(false)
00218         {};
00219         virtual ~UnitTestCase() {};
00220
00224         virtual void Setup() {};
00228         virtual void Teardown() {};
00229
00232         virtual void Init() {};
00233
00238         void EnterSetup() {m_in_setup = true;};
00242         void LeaveSetup() {m_in_setup = false;};
00243
00245         BOOLEAN SetupErrorOccured() const {return m_setup_error_occured;};
00246
00250         void EnterTeardown() {m_in_teardown = true;};
00251
00255         void LeaveTeardown() {m_in_teardown = false;};
00256
00258         BOOLEAN TeardownErrorOccured() const {return m_teardown_error_occured;};
00259
00260     protected:
00266 #if defined APOXI_UNITTEST_NO_FILENAMES
00267         void Error();
00268 #elif defined APOXI_UNITTEST_NO_MESSAGES
00269         void Error(const CHAR* file_name, INT line_number);
00270 #else
00271         void Error(const CHAR* file_name, INT line_number, const CHAR* condition);
00272 #endif //APOXI_UNITTEST_NO_FILENAMES,APOXI_UNITTEST_NO_MESSAGES
00273
00274 #if (defined APOXI_TARGETSYSTEM_HOST || defined APOXI_UNITTEST_TRACE)
00275         static String m_error_message;
00276 #endif
00277
00278     protected:
00279         UnitTestResult* m_test_result;
00280         BOOLEAN m_current_test_success;
00281         BOOLEAN m_in_teardown;
00282         BOOLEAN m_in_setup;
00283         BOOLEAN m_teardown_error_occured;
00284         BOOLEAN m_setup_error_occured;
00285
00286
00287
00288 };
00289 #endif //APOXI_UNITTEST
00290 #endif //DOXYGEN_SHOULD_SKIP_THIS
00291
00293 #endif  // Apoxi_UnitTestCase_hpp
00294
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestCommunicator.cpp File Reference

UnitTest/UnitTestCommunicator.cpp File Reference

#include "PreComp.hpp"
#include "UnitTestMacros.hpp"
#include "UnitTestRunner.hpp"
#include "UnitTestRepository.hpp"
#include "UnitTestCommunicator.hpp"
#include <Socket/SerDataConnProfile.hpp>
#include <Socket/DataConnProfileManager.hpp>

Include dependency graph for UnitTestCommunicator.cpp:

Generated on Tue Jan 24 23:23:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestCommunicator.hpp File Reference

UnitTest/UnitTestCommunicator.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_UnitTestCommunicator_hpp

Define Documentation

#define Apoxi_UnitTestCommunicator_hpp

Generated on Tue Jan 24 23:23:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestCommunicator.hpp Source File

UnitTest/UnitTestCommunicator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_UnitTestCommunicator_hpp)
00011 #define Apoxi_UnitTestCommunicator_hpp
00014
00015 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00016 #ifdef APOXI_UNITTEST
00017 #ifdef APOXI_UNITTEST_TCPIP
00018
00019 #include <Socket/SocketHandler.hpp>
00020 #include <Socket/InetSocketAddr.hpp>
00021
00022 #include <UnitTest/UnitTestData.hpp>
00023 #include <UnitTest/MsgTypes.hpp>
00024 #include <UnitTest/UTTcpSocket.hpp>
00025
00026
00027 //WARING: IMPORTANT: Do not change this buffer for some reason, because this buffer
00028 //is strictly dependent on the buffersize on the Unit Test Management Tools (host tools).
00029 //The socket communication on the X60 target is highly instable, when the host
00030 //tool reads faster than the socket can write. this can cause your X60 to crash.
00031 //this buffer sends 25 test handles at once, then the host tools waits for some time
00032 //to let the buffer be refilled.
00033 #define c_test_case_handle_buffer_size 100
00034
00035
00041 class UnitTestCommunicator {
00042     private:
00043         UnitTestCommunicator();
00044     public:
00045         ~UnitTestCommunicator();
00046
00048         static UnitTestCommunicator* GetInstance();
00050         void Init();
00051
00053         void Communicate();
00054
00060         BOOLEAN OpenConnection(const IpAddr &ipAddr);
00061
00063         void CloseConnection();
00064
00066         void ConnectionLost();
00067
00068
00070         static BOOLEAN SendTestDataAction(const UnitTestData * test_data);
00071
00073         static BOOLEAN FindTestDataAction(const UnitTestData * test_data);
00074
00075     private:
00076
00077         BOOLEAN SendTestCases();
00078         BOOLEAN RunTest();
00079
00080         BYTE* m_test_case_handle_buffer;
00081         void SocketWrite(BYTE* buffer, UINT16 buffer_size);
00082         void SocketFlush();
00083         void SocketClear();
00084         UINT16 m_socket_buffer_pos;
00085
00086         UTTcpSocket m_tcpSocket;
00087         InetSocketAddr m_clientAddr;
00088         SocketHandler m_handler;
00089
00091         BooleanCondition m_no_communication_in_progress;
00092
00093         enum OrderType {
00094             GetTestCases = 0,
00095             RunTestCase = 1,
00096             Invalid
00097         };
00098
00099         static UnitTestCommunicator m_instance;
00100
00101         const CHAR* GetLastSlashPos(const CHAR* str);
00102         const CHAR* GetNullTerminationPos(const CHAR* str);
00103
00104
00105
00106         UtcStatusMessage m_utc_status_message;
00107
00108         UINT32 m_requested_test_address;
00109
00110         UnitTestData m_execute_ut_data;
00111
00112         BYTE m_read_command_byte;
00113
00114         DataConnProfileId m_dcp_id;
00115     };
00116 #endif //APOXI_UNITTEST_TCPIP
00117 #endif //APOXI_UNITTEST
00118 #endif //DOXYGEN_SHOULD_SKIP_THIS
00119
00121 #endif  // Apoxi_UnitTestApp_hpp
00122
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestData.cpp File Reference

UnitTest/UnitTestData.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestData.cpp:

Generated on Tue Jan 24 23:23:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestData.hpp File Reference

UnitTest/UnitTestData.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_UnitTestData_hpp

Define Documentation

#define Apoxi_UnitTestData_hpp

Generated on Tue Jan 24 23:23:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestData.hpp Source File

UnitTest/UnitTestData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTestData_hpp)
00010 #define Apoxi_UnitTestData_hpp
00013
00014 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00015 #ifdef APOXI_UNITTEST
00016
00017 #include "UnitTest.hpp"
00018
00022 class UnitTestData {
00023     public:
00024 #ifdef APOXI_UNITTEST_NO_TESTNAMES
00025
00026         UnitTestData(const UnitTestHandle unit_test_handle, const INT id, const UnitTestData* next);
00027 #else
00028
00029         UnitTestData(const UnitTestHandle unit_test_handle, const WCHAR* name, const INT id, const UnitTestData* next);
00030 #endif // APOXI_UNITTEST_NO_TESTNAMES
00031
00032         UnitTestData():next(0) {};
00033
00035         UnitTest* (*CreateTest)();
00036
00038         INT m_id;
00039
00041         BOOLEAN m_is_testsuite;
00042
00044         static INT m_instance_counter;
00045
00046         static const UnitTestData* m_latest_instance;
00047         const UnitTestData* const next;
00048 #ifndef APOXI_UNITTEST_NO_TESTNAMES
00049
00050         const WCHAR* m_name;
00051 #endif // APOXI_UNITTEST_NO_TESTNAMES
00052 };
00053
00057 class UnitTestSuiteData : public UnitTestData {
00058     public:
00059 #ifdef APOXI_UNITTEST_NO_TESTNAMES
00060
00061         UnitTestSuiteData(const UnitTestHandle unit_test_handle, const INT id, const UnitTestData* next, BOOLEAN (*get_test_at_static)(UINT16, UnitTestSuiteData *));
00062 #else
00063
00064         UnitTestSuiteData(const UnitTestHandle unit_test_handle, const WCHAR* name, const INT id, const UnitTestData* next, BOOLEAN (*get_test_at_static)(UINT16, UnitTestSuiteData *));
00065 #endif // APOXI_UNITTEST_NO_TESTNAMES
00066
00067         UnitTestSuiteData():UnitTestData(){};
00068
00070         BOOLEAN (*m_get_test_at_static)(UINT16, UnitTestSuiteData *);
00071 };
00072
00073
00074
00076 #endif //APOXI_UNITTEST
00077 #endif //DOXYGEN_SHOULD_SKIP_THIS
00078 #endif  // Apoxi_UnitTestData_hpp
00079
00080
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestMacros.cpp File Reference

UnitTest/UnitTestMacros.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestMacros.cpp:

Generated on Tue Jan 24 23:23:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestMacros.hpp File Reference

UnitTest/UnitTestMacros.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define UnitTestMacros_hpp

Define Documentation

#define UnitTestMacros_hpp

Generated on Tue Jan 24 23:23:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestMacros.hpp Source File

UnitTest/UnitTestMacros.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(UnitTestMacros_hpp)
00010 #define UnitTestMacros_hpp
00011
00012 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00013 #ifdef APOXI_UNITTEST
00014
00015 /*  ------------------------------------------------------------------------
00016     System Settings
00017     ------------------------------------------------------------------------ */
00018 #ifdef APOXI_TARGETSYSTEM_HOST
00019     #define APOXI_UNITTEST_PATH_SEPARATOR_CHAR '\\'
00020     #define APOXI_UNIT_MAX_ERROR_HARD_LIMIT 500
00021 #else //APOXI_TARGETSYSTEM_HOST
00022     #define APOXI_UNITTEST_PATH_SEPARATOR_CHAR '/'
00023     #define APOXI_UNIT_MAX_ERROR_HARD_LIMIT 30
00024 #endif
00025
00026 /*  ------------------------------------------------------------------------
00027     Display Settings
00028     ------------------------------------------------------------------------ */
00029 #define ASYNC_TEST_STATUS_TEXT_INTERVAL 500
00030
00031 #ifdef APOXI_UNITTEST_TCPIP
00032     #define APOXI_UNITTEST_HOST_IP_ADDR_FILE_NAME "/unit_test_properties"
00033     #define APOXI_UNITTEST_PROPERTIES_FILE_SIZE 15
00034 #endif //APOXI_UNITTEST_TCPIP
00035
00036
00037 /*  ------------------------------------------------------------------------
00038     Keyboard Configuration
00039     ------------------------------------------------------------------------ */
00040 #define APOXI_UNIT_SHORTCUT_HELP 7
00041 #define APOXI_UNIT_SHORTCUT_SELECT_ALL 1
00042 #define APOXI_UNIT_SHORTCUT_SELECT_NONE 2
00043 #define APOXI_UNIT_SHORTCUT_RUN_TESTS 3
00044 #define APOXI_UNIT_SHORTCUT_CONNECT 9
00045
00046
00047
00048 /*  ------------------------------------------------------------------------
00049     Errors and Warnings, if compile settings do not match
00050     ------------------------------------------------------------------------ */
00051 #ifdef APOXI_UNITTEST_MMI
00052     #ifdef APOXI_UNITTEST_NO_TESTNAMES
00053     #error APOXI_UNITTEST_NO_TESTNAMES may not be defined, when using APOXI_UNITTEST_MMI
00054     #endif //APOXI_UNITTEST_NO_TESTNAMES
00055 #endif //APOXI_UNITTEST_MMI
00056
00057 #ifdef APOXI_UNITTEST_NO_FILENAMES
00058     #ifndef APOXI_UNITTEST_NO_MESSAGES
00059     #error APOXI_UNITTEST_NO_FILENAMES may not defined without defining APOXI_UNITTEST_NO_MESSAGES. First try to eliminate the messages to save memory, not the file names
00060     #endif //APOXI_UNITTEST_NO_MESSAGES
00061 #endif //APOXI_UNITTEST_NO_FILENAMES
00062
00063 #ifdef APOXI_UNITTEST_TRACE
00064     #if !defined(APOXI_TRACE) & !defined(APOXI_TRACE_LEVEL_2) & !defined(APOXI_TRACE_LEVEL_3) | defined(APOXI_TRACE_DISABLED)
00065         #pragma message ("APOXI_UNITTEST_TRACE will not produce any output without enabling the APOXI_TRACE options")
00066     #endif //APOXI_UNITTEST_NO_MESSAGES
00067 #endif //APOXI_UNITTEST_NO_FILENAMES
00068
00069 #if !defined(APOXI_TARGETSYSTEM_HOST) & defined(APOXI_UNITTEST_TRACE) & defined(APOXI_UNITTEST_TCPIP)
00070     #pragma message ("APOXI_UNITTEST_TRACE and APOXI_UNITTEST_TCPIP will not properly work togehter on the target. you will not be able to use the TCP connection while using trace! you can disable trace-out using AT-commands")
00071 #endif
00072
00073 #if !defined(APOXI_TARGETSYSTEM_HOST) & defined(APOXI_UNITTEST_TCPIP) & !defined(APPLICATION_DATACONN)
00074     #pragma message ("APOXI_UNITTEST_TCPIP will not work without the DataConn-Application on the target")
00075 #endif
00076
00077
00078
00079 #endif //APOXI_UNITTEST
00080 #endif //DOXYGEN_SHOULD_SKIP_THIS
00081
00082 #endif  // UnitTestMacros_hpp
00083
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestRegistrar.hpp File Reference

UnitTest/UnitTestRegistrar.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 23:23:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestRegistrar.hpp Source File

UnitTest/UnitTestRegistrar.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00010     #ifdef APOXI_UNITTEST
00011         #ifndef APOXI_UNITTEST_STATIC_REPOSITORY
00012             #include <UnitTest/UnitTestAutoRepository.hpp>
00013             #ifdef TEST_NAME
00014                 #ifdef APOXI_TARGETSYSTEM_HOST
00015                     #pragma INCLUDE_SYMBOL(TEST_NAME)
00016                 #else
00017                     #ifdef APOXI_COMPILER_C166
00018                         #pragma no_global_dead_store_elim
00019                     #endif
00020                     #ifdef APOXI_COMPILER_RVCT
00021                         // Use the -keep linker command line option to prevent linker from optimizing out (wrongly detected) unused code
00022                     #endif
00023                     #ifdef APOXI_COMPILER_ADS
00024                         // Use the -keep linker command line option to prevent linker from optimizing out (wrongly detected) unused code
00025                     #endif
00026                     #ifndef APOXI_COMPILER_C166
00027                         #ifndef APOXI_COMPILER_RVCT
00028                             #ifndef APOXI_COMPILER_ADS
00029                                 #error UnitTest automatic test registration does not work with this compiler
00030                             #endif
00031                         #endif
00032                     #endif
00033                 #endif // APOXI_TARGETSYSTEM_HOST
00034                 REGISTER_UNITTEST(TEST_NAME)
00035                 #ifdef REGISTER_UNITTESTSUITE
00036                     //void TEST_NAME::dummy() {};
00037                     #undef REGISTER_UNITTESTSUITE
00038                 #endif
00039                 #ifdef APOXI_TARGETSYSTEM_HOST
00040                     #pragma END_INCLUDE_SYMBOL
00041                 #else
00042                     #ifdef APOXI_COMPILER_C166
00043                         #pragma global_dead_store_elim
00044                     #endif
00045                     #ifdef APOXI_COMPILER_RVCT
00046                         // Use the -keep linker command line option to prevent linker from optimizing out (wrongly detected) unused code
00047                     #endif
00048                     #ifdef APOXI_COMPILER_ADS
00049                         // Use the -keep linker command line option to prevent linker from optimizing out (wrongly detected) unused code
00050                     #endif
00051                     #ifndef APOXI_COMPILER_C166
00052                         #ifndef APOXI_COMPILER_RVCT
00053                             #ifndef APOXI_COMPILER_ADS
00054                                 #error UnitTest automatic test registration does not work with this compiler
00055                             #endif
00056                         #endif
00057                     #endif
00058                 #endif // APOXI_TARGETSYSTEM_HOST
00059             #else
00060                 #error Use TEST_NAME to define the name of yout test class. example: #define TEST_NAME StringTest
00061             #endif // TEST_NAME
00062         #endif // APOXI_UNITTEST_STATIC_REPOSITORY
00063     #endif // APOXI_UNITTEST
00064 #endif // DOXYGEN_SHOULD_SKIP_THIS
00065
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestRepository.cpp File Reference

UnitTest/UnitTestRepository.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestRepository.cpp:

Generated on Tue Jan 24 23:23:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestRepository.hpp File Reference

UnitTest/UnitTestRepository.hpp File Reference

#include "UnitTestData.hpp"

Include dependency graph for UnitTestRepository.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_UnitTestRepository_hpp

Define Documentation

#define Apoxi_UnitTestRepository_hpp

Generated on Tue Jan 24 23:23:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestRepository.hpp Source File

UnitTest/UnitTestRepository.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTestRepository_hpp)
00010 #define Apoxi_UnitTestRepository_hpp
00013
00014 #include "UnitTestData.hpp"
00015
00016 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00017 #ifdef APOXI_UNITTEST
00018
00022 class UnitTestRepository {
00023
00024     public:
00025         static UnitTestRepository* GetInstance();
00026
00027         virtual ~UnitTestRepository();
00028
00034         UINT16 GetTestCount() const;
00035
00036
00042         UINT16 GetTestCountDeep() const;
00043
00049         const UnitTestData* GetTestAt(UINT16 index) const;
00055         const UnitTestData* GetTestAt(void* address) const;
00056
00063         BOOLEAN CopyHandleToBuffer(void* buffer, UINT16 index) const;
00064
00074         BOOLEAN Travert(BOOLEAN (*test_action) (const UnitTestData * data), BOOLEAN perform_action_on_suites, BOOLEAN perform_action_on_tests) const;
00075
00088         BOOLEAN TravertTestSuite(BOOLEAN (*test_action) (const UnitTestData * data), const UnitTestSuiteData* suite_data, BOOLEAN perform_action_on_suites, BOOLEAN perform_action_on_tests, UINT16* size = 0) const;
00089
00090     protected:
00091         UnitTestRepository();
00092     private:
00093         static BOOLEAN IncrementTestCountAction(const UnitTestData * test_data);
00094
00095
00096
00097         static UnitTestRepository* m_instance;
00098         UINT16 m_count_deep;
00099 };
00100
00102 #endif //APOXI_UNITTEST
00103 #endif //DOXYGEN_SHOULD_SKIP_THIS
00104 #endif // Apoxi_UnitTestRepository_hpp
00105
00106
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestResult.cpp File Reference

UnitTest/UnitTestResult.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestResult.cpp:

Generated on Tue Jan 24 23:23:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestResult.hpp File Reference

UnitTest/UnitTestResult.hpp File Reference

Go to the source code of this file.

Defines

#define Apoxi_UnitTestResult_hpp

Define Documentation

#define Apoxi_UnitTestResult_hpp

Generated on Tue Jan 24 23:23:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestResult.hpp Source File

UnitTest/UnitTestResult.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTestResult_hpp)
00010 #define Apoxi_UnitTestResult_hpp
00013
00014 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00015 #ifdef APOXI_UNITTEST
00016
00017 #include "UnitTestMacros.hpp"
00018 #include <Auxiliary/Vector.hpp>
00019
00020
00024 class UnitTestError {
00025 public:
00026
00027     UnitTestError(const CHAR* file_name, INT line_number, BOOLEAN setup_error, BOOLEAN teardown_error);
00028     UnitTestError(BOOLEAN setup_error, BOOLEAN teardown_error);
00029     virtual ~UnitTestError();
00030     const CHAR* GetFileName() const { return m_file_name;};
00031     INT GetLineNumber() const { return m_line_number;};
00032     BOOLEAN IsSetupError() const { return m_setup_error;};
00033     BOOLEAN IsTeardownError() const { return m_teardown_error;};
00034 private:
00036     CHAR* m_file_name;
00038     INT     m_line_number;
00039     BOOLEAN m_setup_error;
00040     BOOLEAN m_teardown_error;
00041 };
00042
00047 class UnitTestResult {
00048
00049     public:
00050         virtual ~UnitTestResult();
00051         static UnitTestResult& GetInstance();
00052         void AddError(UnitTestError* test_error);
00053         void AddSuccess() { m_successes++; }
00054         void SetMaxErrorCount(INT max_error);
00055         void Clear();
00056
00057         UINT16 GetFailureCount() const { return m_failures; }
00058         UINT16 GetSuccessCount() const { return m_successes; }
00059         UINT16 GetSetupErrorCount() const { return m_setup_errors; }
00060         UINT16 GetTeardownErrorCount() const { return m_teardown_errors; }
00061
00062         UINT16 GetDetailedErrorCount() { return m_detailed_error_count; }
00063         UnitTestError* GetDetailedError(UINT16 index) { return m_error_list[index]; }
00064
00065     private:
00066
00067         UnitTestError* m_error_list[APOXI_UNIT_MAX_ERROR_HARD_LIMIT];
00068         UINT16 m_detailed_error_count;
00069         UINT16 m_successes;
00070         UINT16 m_max_error;
00071         UINT16 m_failures;
00072         UINT16 m_setup_errors;
00073         UINT16 m_teardown_errors;
00074         static UnitTestResult m_instance;
00075         static BOOLEAN m_initialized;
00076         UnitTestResult();
00077 };
00078
00079 #endif //APOXI_UNITTEST
00080 #endif //DOXYGEN_SHOULD_SKIP_THIS
00081
00083 #endif  // Apoxi_UnitTestResult_hpp
00084
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestRunner.cpp File Reference

UnitTest/UnitTestRunner.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestRunner.cpp:

Generated on Tue Jan 24 23:23:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestRunner.hpp File Reference

UnitTest/UnitTestRunner.hpp File Reference

#include "UnitTest.hpp"

Include dependency graph for UnitTestRunner.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Apoxi_UnitTestRunner_hpp

Define Documentation

#define Apoxi_UnitTestRunner_hpp

Generated on Tue Jan 24 23:23:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestRunner.hpp Source File

UnitTest/UnitTestRunner.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_UnitTestRunner_hpp)
00011 #define Apoxi_UnitTestRunner_hpp
00014
00015 #include "UnitTest.hpp"
00016
00017 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00018 #ifdef APOXI_UNITTEST
00019
00023 class UnitTestRunner {
00024
00025 private:
00026     UnitTestRunner();
00027     virtual ~UnitTestRunner();
00028
00029 public:
00035     static void Run(UnitTestHandle test_hdl, UnitTestResult& test_result);
00036
00043     static void Run(UnitTestHandle test_hdl, UnitTestResult& test_result, UINT8 repetitions);
00044
00045
00046
00047 };
00048 #endif //APOXI_UNITTEST
00049 #endif //DOXYGEN_SHOULD_SKIP_THIS
00050
00051 #endif  // Apoxi_UnitTestRunner_hpp
00052
00053
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestStaticRepository.cpp File Reference

UnitTest/UnitTestStaticRepository.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestStaticRepository.cpp:

Generated on Tue Jan 24 23:23:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestStaticRepository.hpp File Reference

UnitTest/UnitTestStaticRepository.hpp File Reference

#include "UnitTestData.hpp"
#include "UnitTestRepository.hpp"

Include dependency graph for UnitTestStaticRepository.hpp:

Go to the source code of this file.

Defines

#define Apoxi_UnitTestStaticRepository_hpp

Define Documentation

#define Apoxi_UnitTestStaticRepository_hpp

Generated on Tue Jan 24 23:23:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestStaticRepository.hpp Source File

UnitTest/UnitTestStaticRepository.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTestStaticRepository_hpp)
00010 #define Apoxi_UnitTestStaticRepository_hpp
00013
00014 #include "UnitTestData.hpp"
00015 #include "UnitTestRepository.hpp"
00016 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00017 #ifdef APOXI_UNITTEST
00018 #ifdef APOXI_UNITTEST_STATIC_REPOSITORY
00019 /*  ------------------------------------------------------------------------
00020     DEFINES FOR THE REPOSITORY
00021     ------------------------------------------------------------------------ */
00022 #define BEGIN_UNITTEST_REPOSITORY UnitTestData UnitTestStaticRepository::m_unit_test_table[] = {
00023 #ifdef APOXI_TARGETSYSTEM_HOST
00024     #ifdef APOXI_UNITTEST_NO_TESTNAMES
00025         #define ADD_TEST(ClassName) UnitTestData(ClassName::CreateInstance, 0, 0),
00026     #else
00027         #define ADD_TEST(ClassName) UnitTestData(ClassName::CreateInstance, L#ClassName, 0, 0),
00028     #endif
00029 #else
00030     #ifdef APOXI_UNITTEST_NO_TESTNAMES
00031         #define ADD_TEST(ClassName) UnitTestData(ClassName::CreateInstance, 0, 0),
00032     #else
00033         #define ADD_TEST(ClassName) UnitTestData(ClassName::CreateInstance, L#ClassName, 0, 0),
00034     #endif
00035 #endif
00036
00037 #ifdef APOXI_UNITTEST_NO_TESTNAMES
00038     #define END_UNITTEST_REPOSITORY UnitTestData(0, 0, 0) };
00039 #else
00040     #define END_UNITTEST_REPOSITORY UnitTestData(0, (WCHAR*)0, 0, 0) };
00041 #endif
00042
00043 // DEFINES FOR THE REPOSITORY
00044
00045
00050 class UnitTestStaticRepository: public UnitTestRepository {
00051
00052     public:
00053         friend UnitTestRepository;
00054
00055
00056         virtual ~UnitTestStaticRepository();
00057
00062         UINT16 GetTestCount() const { return m_count; }
00063
00069         const UnitTestData* GetTestAt(UINT16 index) const;
00075         const UnitTestData* GetTestAt(void* address) const;
00076
00083         BOOLEAN CopyHandleToBuffer(void* buffer, UINT16 index) const;
00084
00085         void Travert(BOOLEAN (*test_action) (UnitTestData * data), BOOLEAN travert_suites, BOOLEAN travert_tests) {};
00086
00087     private:
00088         UnitTestStaticRepository();
00089         static UnitTestStaticRepository* m_instance;
00090
00091         static UnitTestData m_unit_test_table[];
00092         static UINT16 m_count;
00093 };
00094
00096 #endif //APOXI_UNITTEST_STATIC_REPOSITORY
00097 #endif //APOXI_UNITTEST
00098 #endif //DOXYGEN_SHOULD_SKIP_THIS
00099 #endif  // Apoxi_UnitTestStaticRepository_hpp
00100
00101
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestSuite.cpp File Reference

UnitTest/UnitTestSuite.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for UnitTestSuite.cpp:

Generated on Tue Jan 24 23:23:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestSuite.hpp File Reference

UnitTest/UnitTestSuite.hpp File Reference

#include "UnitTest.hpp"
#include "UnitTestData.hpp"
#include "UnitTestRunner.hpp"

Include dependency graph for UnitTestSuite.hpp:

Go to the source code of this file.

Defines

#define Apoxi_UnitTestSuite_hpp

Define Documentation

#define Apoxi_UnitTestSuite_hpp

Generated on Tue Jan 24 23:23:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UnitTestSuite.hpp Source File

UnitTest/UnitTestSuite.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Apoxi_UnitTestSuite_hpp)
00010 #define Apoxi_UnitTestSuite_hpp
00013
00014 #include "UnitTest.hpp"
00015 #include "UnitTestData.hpp"
00016 #include "UnitTestRunner.hpp"
00017
00018 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00019 #ifdef APOXI_UNITTEST
00020 #ifndef REGISTER_UNITTESTSUITE
00021     #define REGISTER_UNITTESTSUITE
00022 #endif
00023 /*  ------------------------------------------------------------------------
00024     BEGIN_UNITTEST_SUITE
00025     ------------------------------------------------------------------------ */
00026 #ifdef APOXI_UNITTEST_NO_TESTNAMES
00027     #define BEGIN_UNITTEST_SUITE(TestClass) \
00028         class TestClass : public UnitTestSuite { \
00029             public: \
00030                 TestClass() {}; \
00031                 virtual ~TestClass() {}; \
00032                 \
00033                 static UnitTest* CreateInstance() { return new TestClass(); } \
00034                 static BOOLEAN (*GetDescendantsAccessMethod()) (UINT16, UnitTestSuiteData *) {return TestClass::GetTestAtStatic;}; \
00035                 const UnitTestSuiteData* GetTestAt(UINT16 index) {  \
00036                     if (GetTestAtStatic(index, &m_test_suite_data)) \
00037                     { \
00038                         return &m_test_suite_data;\
00039                     } \
00040                      else \
00041                     { \
00042                         return 0;\
00043                     }\
00044                 } \
00045                 static BOOLEAN GetTestAtStatic(UINT16 index, UnitTestSuiteData* test_suite_data ) { \
00046                     UINT16 l_index; \
00047                     l_index = 0;
00048
00049 #else
00050     #define BEGIN_UNITTEST_SUITE(TestClass) \
00051         class TestClass : public UnitTestSuite { \
00052             public: \
00053                 TestClass() {}; \
00054                 virtual ~TestClass() {}; \
00055                 \
00056                 static UnitTest* CreateInstance() { return new TestClass(); } \
00057                 static BOOLEAN (*GetDescendantsAccessMethod()) (UINT16, UnitTestSuiteData *) {return TestClass::GetTestAtStatic;}; \
00058                 \
00059                 static const CHAR* const GetName() { return #TestClass; } \
00060                 \
00061                 const UnitTestSuiteData* GetTestAt(UINT16 index) {  \
00062                     if (GetTestAtStatic(index, &m_test_suite_data)) \
00063                     { \
00064                         return &m_test_suite_data;\
00065                     } \
00066                      else \
00067                     { \
00068                         return 0;\
00069                     }\
00070                 } \
00071                 static BOOLEAN GetTestAtStatic(UINT16 index, UnitTestSuiteData* test_suite_data ) { \
00072                     UINT16 l_index; \
00073                     l_index = 0;
00074
00075 #endif // APOXI_UNITTEST_NO_TESTNAMES
00076 // BEGIN_UNITTEST_SUITE
00077
00078 /*  ------------------------------------------------------------------------
00079     ADD_UNITTEST_CLASS
00080     ------------------------------------------------------------------------ */
00081 #ifdef APOXI_UNITTEST_NO_TESTNAMES
00082     #define ADD_TEST_CLASS(UnitTestClass) \
00083                 if (l_index == index) \
00084                 { \
00085                     test_suite_data->CreateTest = UnitTestClass::CreateInstance; \
00086                     if (UnitTestClass::GetDescendantsAccessMethod() != 0) {\
00087                         test_suite_data->m_is_testsuite = TRUE;\
00088                     } else {\
00089                         test_suite_data->m_is_testsuite = FALSE;\
00090                     }\
00091                     test_suite_data->m_get_test_at_static = UnitTestClass::GetDescendantsAccessMethod();\
00092                     /*index of subtestcase is only unique within the scope of the TestSuite*/ \
00093                     test_suite_data->m_id = l_index; \
00094                     return TRUE; \
00095                 } \
00096                 l_index++;
00097 #else
00098     #define ADD_TEST_CLASS(UnitTestClass) \
00099                 if (l_index == index) \
00100                 { \
00101                     test_suite_data->CreateTest = UnitTestClass::CreateInstance; \
00102                     if (UnitTestClass::GetDescendantsAccessMethod() != 0) {\
00103                         test_suite_data->m_is_testsuite = TRUE;\
00104                     } else {\
00105                         test_suite_data->m_is_testsuite = FALSE;\
00106                     }\
00107                     test_suite_data->m_get_test_at_static = UnitTestClass::GetDescendantsAccessMethod();\
00108                     test_suite_data->m_name = L###UnitTestClass;\
00109                     /*index of subtestcase is only unique within the scope of the TestSuite*/ \
00110                     test_suite_data->m_id = l_index; \
00111                     return TRUE; \
00112                 } \
00113                 l_index++;
00114
00115 #endif // APOXI_UNITTEST_NO_TESTNAMES
00116 // ADD_UNITTEST_CLASS
00117
00118
00119 /*  ------------------------------------------------------------------------
00120     END_UNITTEST_SUITE
00121     ------------------------------------------------------------------------ */
00122 #define END_UNITTEST_SUITE \
00123         return FALSE;\
00124         } \
00125     };
00126 // END_UNITTEST_SUITE
00127
00128
00132 class UnitTestSuite : public UnitTest {
00133     public:
00134         UnitTestSuite();
00135         virtual ~UnitTestSuite();
00136
00138         virtual const UnitTestSuiteData* GetTestAt(UINT16 index) = 0;
00139
00140     protected:
00141         virtual BOOLEAN _Execute(UnitTestResult& test_result);
00143         UnitTestSuiteData m_test_suite_data;
00144     private:
00146         static BOOLEAN ExecuteDescendantTestAction(const UnitTestData * test_data);
00147
00148 };
00149
00150
00151
00152 #endif //APOXI_UNITTEST
00153 #endif //DOXYGEN_SHOULD_SKIP_THIS
00154
00156 #endif  // Apoxi_UnitTestSuite_hpp
00157
00158
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UTTcpSocket.cpp File Reference

UnitTest/UTTcpSocket.cpp File Reference

#include "PreComp.hpp"
#include "UTTcpSocket.hpp"
#include "UnitTestCommunicator.hpp"

Include dependency graph for UTTcpSocket.cpp:

Generated on Tue Jan 24 23:23:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UTTcpSocket.hpp File Reference

UnitTest/UTTcpSocket.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define UTTcpSocket_hpp

Define Documentation

#define UTTcpSocket_hpp

Generated on Tue Jan 24 23:23:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest/UTTcpSocket.hpp Source File

UnitTest/UTTcpSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(UTTcpSocket_hpp)
00011 #define UTTcpSocket_hpp
00012
00013 #ifdef APOXI_UNITTEST
00014 #ifdef APOXI_UNITTEST_TCPIP
00015
00016 #include <Socket/DataConnManager.hpp>
00017 #include <Socket/TcpSocket.hpp>
00018
00019 class UTTcpSocket: public TcpSocket {
00020     typedef TcpSocket Base;
00021
00022     public:
00024         UTTcpSocket() {};
00026         virtual ~UTTcpSocket() {};
00027
00028     public:
00030         virtual void OnAsyncEvent(Event event);
00031
00032 };//class UTTcpSocket
00033
00034
00035 #endif //APOXI_UNITTEST_TCPIP
00036 #endif //APOXI_UNITTEST
00037 #endif //UTTcpSocket_hpp
00038
00039
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbAction.cpp File Reference

Applications/AdvPhonebook/AdvPbAction.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/FindProvider.hpp>
#include <AdvPhonebook/PbAbstractWin.hpp>
#include "AdvPbApp.hpp"
#include <AdvPhonebook/PbDetails.hpp>
#include "AdvPbAction.hpp"

Include dependency graph for AdvPbAction.cpp:

Generated on Tue Jan 24 23:24:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbAction.hpp File Reference

Applications/AdvPhonebook/AdvPbAction.hpp File Reference

#include <AdvPhonebook/PbAction.hpp>

Include dependency graph for AdvPbAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AdvPbAction
class | PbAddPhoneNoAction
class | PbAdvDetailAction
class | PbCancelAddNoAction
class | PbChangeNoTypeAction
class | PbConfirmAddNoAction
class | PbDelPhonenoAction
class | PbSelectGroupAction
class | SyncPhoneAction
class | SyncPhoneAllAction
class | SyncSimAction
class | SyncSimAllAction

Defines

#define | Mmi_AdvPbAction_hpp

Define Documentation

#define Mmi_AdvPbAction_hpp

Generated on Tue Jan 24 23:24:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbAction.hpp Source File

Applications/AdvPhonebook/AdvPbAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_AdvPbAction_hpp)
00009 #define Mmi_AdvPbAction_hpp
00013
00014 #include <AdvPhonebook/PbAction.hpp>
00015
00016 class AdvPbApp;
00017 class AdvPbAction : public PbSecuredAction {
00018     typedef PbSecuredAction Base;
00019
00020     public:
00021         AdvPbAction();
00022         virtual ~AdvPbAction();
00023
00024         void Init(AdvPbApp *pb_app, const WCHAR *text);
00025
00026         AdvPbApp* GetPbApplication() { return (AdvPbApp*) Base::GetPbApplication(); }
00027 };
00028
00029 class PbAdvDetails;
00030 class PbAdvDetailAction : public PbSecuredAction {
00031     typedef PbSecuredAction Base;
00032
00033     public:
00034         PbAdvDetailAction();
00035         PbAdvDetailAction(PbAdvDetails *detail_win, const WCHAR *text);
00036         virtual ~PbAdvDetailAction();
00037
00038         void Init(PbAdvDetails *detail_win, const WCHAR *text);
00039
00040         PbAdvDetails* GetDetailWin() { return m_detail_win; };
00041
00042     private:
00043         PbAdvDetails    *m_detail_win;
00044 };
00045
00046 class PbAddPhoneNoAction : public PbAdvDetailAction {
00047     typedef PbAdvDetailAction Base;
00048
00049     public:
00050         virtual BOOLEAN Execute();
00051
00052 };
00053
00054 class PbConfirmAddNoAction : public PbAdvDetailAction {
00055     typedef PbAdvDetailAction Base;
00056
00057     public:
00058         virtual BOOLEAN Execute();
00059 };
00060
00061 class PbCancelAddNoAction : public PbAdvDetailAction {
00062     typedef PbAdvDetailAction Base;
00063
00064     public:
00065         virtual BOOLEAN Execute();
00066 };
00067
00068 class PbDelPhonenoAction : public AdvPbAction {
00069     typedef AdvPbAction Base;
00070
00071     public:
00072         virtual BOOLEAN Execute();
00073 };
00074
00075 class PbChangeNoTypeAction : public AdvPbAction {
00076     typedef AdvPbAction Base;
00077
00078     public:
00079         virtual BOOLEAN Execute();
00080
00081 };
00082
00083 class PbSelectGroupAction : public AdvPbAction {
00084     typedef AdvPbAction Base;
00085
00086     public:
00087         virtual BOOLEAN Execute();
00088 };
00089
00090 class SyncSimAllAction : public AdvPbAction {
00091     typedef AdvPbAction Base;
00092
00093     public:
00094         virtual BOOLEAN Execute();
00095
00096 };
00097
00098 class SyncPhoneAllAction : public AdvPbAction {
00099     typedef AdvPbAction Base;
00100
00101     public:
00102         virtual BOOLEAN Execute();
00103 };
00104
00105 class SyncSimAction : public AdvPbAction {
00106     typedef AdvPbAction Base;
00107
00108     public:
00109         virtual BOOLEAN Execute();
00110
00111 };
00112
00113 class SyncPhoneAction : public AdvPbAction {
00114     typedef AdvPbAction Base;
00115
00116     public:
00117         virtual BOOLEAN Execute();
00118 };
00119
00121 #endif  // Mmi_AdvPbAction_hpp
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbApp.cpp File Reference

Applications/AdvPhonebook/AdvPbApp.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <AdvPhonebook/AdvPbMsgTypes.hpp>
#include "AdvPbApp.hpp"
#include <Config/MenuResConfig.hpp>

Include dependency graph for AdvPbApp.cpp:

Generated on Tue Jan 24 23:24:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbApp.hpp File Reference

Applications/AdvPhonebook/AdvPbApp.hpp File Reference

#include <Gui/Window.hpp>
#include <Gui/ConfirmAction.hpp>
#include <Auxiliary/MainProvider.hpp>
#include <GuiExtensions/MmiInfoBox.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AdvPhonebook/AdvPbWin.hpp>
#include <AdvPhonebook/PhonebookApp.hpp>
#include <AdvPhonebook/PbAdvDataHandler.hpp>
#include <AdvPhonebook/PbSelectNoType.hpp>
#include <AdvPhonebook/PbSelectGroup.hpp>
#include <AdvPhonebook/PbManualSynchronizer.hpp>
#include <AdvPhonebook/SyncPhoneThreadlet.hpp>

Include dependency graph for AdvPbApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AdvPbApp

Defines

#define | Mmi_AdvPbApp_hpp

Define Documentation

#define Mmi_AdvPbApp_hpp

Generated on Tue Jan 24 23:24:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbApp.hpp Source File

Applications/AdvPhonebook/AdvPbApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_AdvPbApp_hpp)
00009 #define Mmi_AdvPbApp_hpp
00012
00013 #include <Gui/Window.hpp>
00014 #include <Gui/ConfirmAction.hpp>
00015
00016 #include <Auxiliary/MainProvider.hpp>
00017
00018 #include <GuiExtensions/MmiInfoBox.hpp>
00019 #include <AddOns/Services/ServiceBroker.hpp>
00020 #include <AdvPhonebook/AdvPbWin.hpp>
00021 #include <AdvPhonebook/PhonebookApp.hpp>
00022 #include <AdvPhonebook/PbAdvDataHandler.hpp>
00023 #include <AdvPhonebook/PbSelectNoType.hpp>
00024 #include <AdvPhonebook/PbSelectGroup.hpp>
00025 #include <AdvPhonebook/PbManualSynchronizer.hpp>
00026 #include <AdvPhonebook/SyncPhoneThreadlet.hpp>
00027
00028 class AdvPbApp : public PhonebookApp {
00029     typedef PhonebookApp  Base;
00030
00031     public:
00032
00034         virtual ~AdvPbApp();
00035
00037         static AdvPbApp* GetInstance();
00038
00040         virtual ServiceResult SelectEmailAddress(WString &email, const WString &title = WString());
00041
00043         void SelectNoType();
00044
00046         void SelectGroup();
00047
00049         virtual void DisplayMemory();
00050
00052         BOOLEAN SyncSimAll();
00053
00055         BOOLEAN SyncPhoneAll();
00056
00058         BOOLEAN SyncSim();
00059
00061         BOOLEAN SyncPhone();
00062
00064         virtual void UpdateEnabledActions();
00065
00067         Action* GetDelPhonenoAction() { return &m_del_phoneno_action; }
00068
00070         Action* GetSelectGroupAction() { return &m_group_action; }
00071
00073         Action* GetNoTypeAction() { return &m_no_type_action; }
00074
00076         virtual INT GetMaxPhonenos();
00077
00078         BOOLEAN IsPbAvailable();
00079
00080 //CN200013749
00081         UINT32 GetLastDeletedUniqueId(){
00082             return m_pb_data_control.GetLastDeletedUniqueId();}
00083 //END CN200013749
00084     protected:
00085         virtual void OnSimReady();
00086         virtual void OnSimNotPresent();
00087         virtual void OnSimPresent();
00088         virtual void OnPbWindowClosed(const PbAbstractWin *win);
00089         virtual BOOLEAN OnMessage(const Message &msg);
00090
00091         virtual BOOLEAN ServiceReady();
00092
00093         virtual PbDataHandler* GetPbDataControl();
00094         virtual PbSynchronizer* GetSynchronizer();
00095         virtual PhonebookWin* GetPhonebook();
00096
00097     private:
00098         AdvPbApp();
00099
00100         virtual void OnTriggerNotification (INT16 type);
00101         virtual void EnableSimActions(BOOLEAN flag);
00102         void SyncTerminated(BOOLEAN successful);
00103
00104         static AdvPbWin             m_phonebook;
00105
00106         static PbAdvDataHandler     m_pb_data_control;
00107         static PbManualSynchronizer m_sim_synchronizer;
00108         static SyncPhoneThreadlet   m_sync_threadlet;
00109
00110         ConfirmAction           m_confirm_action;
00111
00112         PbSelectGroupAction     m_group_action;
00113         PbChangeNoTypeAction    m_no_type_action;
00114         PbDelPhonenoAction      m_del_phoneno_action;
00115
00116         SyncSimAllAction        m_sync_sim_all_action;
00117         SyncPhoneAllAction      m_sync_phone_all_action;
00118         SyncSimAction           m_sync_sim_action;
00119         SyncPhoneAction         m_sync_phone_action;
00120         SyncPhoneAllAction      m_load_from_sim_action;
00121         OpenWindowAction        m_show_sim_action;
00122
00123         PbSelectNoType          m_sel_no_type_win;
00124         PbSelectGroup           m_sel_group_win;
00125
00126         static BasicPbWin               m_sim_pb;
00127 //      MmiAlert                m_memory_win;
00128         MmiInfoBox              m_info_box;
00129
00130         static MmiAdvancedProgressBox   m_sync_listener;
00131
00132         static PbBaseWin        m_select_email;
00133         BooleanCondition        m_email_selected;
00134
00135         static AdvPbApp         m_app;
00136 };
00137
00139 #endif  // Mmi_AdvPbApp_hpp
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbMsgTypes.cpp File Reference

Applications/AdvPhonebook/AdvPbMsgTypes.cpp File Reference

#include "AdvPhonebook/AdvPbPreComp.hpp"
#include "AdvPbMsgTypes.hpp"

Include dependency graph for AdvPbMsgTypes.cpp:

Generated on Tue Jan 24 23:25:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbMsgTypes.hpp File Reference

Applications/AdvPhonebook/AdvPbMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>
#include <AdvPhonebook/PbAbstractWin.hpp>

Include dependency graph for AdvPbMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | JumpToRowMsg
class | OpenPbWinMsg
class | PhonebookRenumberedMsg
class | ProviderUpdateMsg
class | SaveEntryInPhonebookMsg
class | SyncProgressMsg

Defines

#define | Applications_AdvPbMsgTypes_hpp

Define Documentation

#define Applications_AdvPbMsgTypes_hpp

Generated on Tue Jan 24 23:25:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbMsgTypes.hpp Source File

Applications/AdvPhonebook/AdvPbMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "bhisel_view_snap\lnz_apps_int\Applications\AdvPhonebook\MagTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Applications_AdvPbMsgTypes_hpp)
00016 #define Applications_AdvPbMsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Auxiliary/PhoneNumber.hpp>
00020 #include <Auxiliary/Date.hpp>
00021 #include <Auxiliary/Time.hpp>
00022 #include <AdvPhonebook/PbAbstractWin.hpp>
00023
00024
00025 /* ----------------------------------------------------------------------
00026     Classes
00027     ---------------------------------------------------------------------- */
00028
00029 /*  ======================================================================
00030     Class JumpToRowMsg
00031     ====================================================================== */
00032
00034 class JumpToRowMsg : public ControlMsg {
00035     public:
00036         JumpToRowMsg(Control* control);
00037         virtual ~JumpToRowMsg();
00038
00039         virtual const MsgMetaData& GetMetaData() const;
00040         virtual Message* Clone() const;
00041
00042         enum  {
00043             ID = 30003
00044             };
00045
00046     private:
00047         static const MsgMetaData m_meta_data;
00048
00049     };
00050
00051
00052 /*  ======================================================================
00053     Class OpenPbWinMsg
00054     ====================================================================== */
00055
00057 class OpenPbWinMsg : public ContextMsg {
00058     public:
00059         OpenPbWinMsg(ExecutionContext* context, PbAbstractWin* win);
00060         virtual ~OpenPbWinMsg();
00061
00062         virtual const MsgMetaData& GetMetaData() const;
00063         void SetWin(PbAbstractWin* win) { m_win = win; }
00064         PbAbstractWin* GetWin() const { return m_win; }
00065         virtual Message* Clone() const;
00066
00067         enum  {
00068             ID = 30004
00069             };
00070
00071     private:
00072         static const MsgMetaData m_meta_data;
00073         PbAbstractWin* m_win;
00074
00075     };
00076
00077
00078 /*  ======================================================================
00079     Class SaveEntryInPhonebookMsg
00080     ====================================================================== */
00081
00083 class SaveEntryInPhonebookMsg : public ContextMsg {
00084     public:
00085         SaveEntryInPhonebookMsg(ExecutionContext* context, const WString& name, const PhoneNumber& phone_no, const WString& email);
00086         virtual ~SaveEntryInPhonebookMsg();
00087
00088         virtual const MsgMetaData& GetMetaData() const;
00089         void SetName(const WString& name) { m_name = name; }
00090         const WString& GetName() const { return m_name; }
00091         void SetPhoneNo(const PhoneNumber& phone_no) { m_phone_no = phone_no; }
00092         const PhoneNumber& GetPhoneNo() const { return m_phone_no; }
00093         void SetEmail(const WString& email) { m_email = email; }
00094         const WString& GetEmail() const { return m_email; }
00095         virtual Message* Clone() const;
00096
00097         enum  {
00098             ID = 30005
00099             };
00100
00101     private:
00102         static const MsgMetaData m_meta_data;
00103         WString m_name;
00104         PhoneNumber m_phone_no;
00105         WString m_email;
00106
00107     };
00108
00109
00110 /*  ======================================================================
00111     Class SyncProgressMsg
00112     ====================================================================== */
00113
00115 class SyncProgressMsg : public ContextMsg {
00116     public:
00117         SyncProgressMsg(ExecutionContext* context, INT progress);
00118         virtual ~SyncProgressMsg();
00119
00120         virtual const MsgMetaData& GetMetaData() const;
00121         void SetProgress(INT progress) { m_progress = progress; }
00122         INT GetProgress() const { return m_progress; }
00123         virtual Message* Clone() const;
00124
00125         enum  {
00126             ID = 30006
00127             };
00128
00129     private:
00130         static const MsgMetaData m_meta_data;
00131         INT m_progress;
00132
00133     };
00134
00135
00136 /*  ======================================================================
00137     Class ProviderUpdateMsg
00138     ====================================================================== */
00139
00141 class ProviderUpdateMsg : public ContextMsg {
00142     public:
00143         ProviderUpdateMsg(ExecutionContext* context, Provider* provider, INT state);
00144         virtual ~ProviderUpdateMsg();
00145
00146         virtual const MsgMetaData& GetMetaData() const;
00147         void SetProvider(Provider* provider) { m_provider = provider; }
00148         Provider* GetProvider() const { return m_provider; }
00149         void SetState(INT state) { m_state = state; }
00150         INT GetState() const { return m_state; }
00151         virtual Message* Clone() const;
00152
00153         enum  {
00154             ID = 30007
00155             };
00156
00157     private:
00158         static const MsgMetaData m_meta_data;
00159         Provider* m_provider;
00160         INT m_state;
00161
00162     };
00163
00164
00165 /*  ======================================================================
00166     Class PhonebookRenumberedMsg
00167     ====================================================================== */
00168
00170 class PhonebookRenumberedMsg : public Message {
00171     public:
00172         PhonebookRenumberedMsg();
00173         virtual ~PhonebookRenumberedMsg();
00174
00175         virtual const MsgMetaData& GetMetaData() const;
00176         virtual Message* Clone() const;
00177
00178         enum  {
00179             ID = 30008
00180             };
00181
00182     private:
00183         static const MsgMetaData m_meta_data;
00184
00185     };
00186
00187 #endif // Applications_AdvPbMsgTypes_hpp
00188
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbPreComp.cpp File Reference

Applications/AdvPhonebook/AdvPbPreComp.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>

Include dependency graph for AdvPbPreComp.cpp:

Generated on Tue Jan 24 23:25:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbPreComp.hpp File Reference

Applications/AdvPhonebook/AdvPbPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for AdvPbPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 23:25:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbPreComp.hpp Source File

Applications/AdvPhonebook/AdvPbPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Adc/Lib.hpp>
00013 #include <Asc/Lib.hpp>
00014
00015 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbWin.cpp File Reference

Applications/AdvPhonebook/AdvPbWin.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AdvPhonebook/PbProvIds.hpp>
#include <AdvPhonebook/ProvListBoxWin.hpp>
#include "AdvPbApp.hpp"
#include "AdvPbWin.hpp"

Include dependency graph for AdvPbWin.cpp:

Generated on Tue Jan 24 23:25:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbWin.hpp File Reference

Applications/AdvPhonebook/AdvPbWin.hpp File Reference

#include <Auxiliary/FilterProvider.hpp>
#include <AdvPhonebook/PhonebookWin.hpp>
#include <AdvPhonebook/PbAdvDetails.hpp>

Include dependency graph for AdvPbWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AdvPbWin

Defines

#define | Mmi_AdvPbWin_hpp

Define Documentation

#define Mmi_AdvPbWin_hpp

Generated on Tue Jan 24 23:26:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/AdvPbWin.hpp Source File

Applications/AdvPhonebook/AdvPbWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_AdvPbWin_hpp)
00009 #define Mmi_AdvPbWin_hpp
00012
00013 #include <Auxiliary/FilterProvider.hpp>
00014
00015 #include <AdvPhonebook/PhonebookWin.hpp>
00016 #include <AdvPhonebook/PbAdvDetails.hpp>
00017
00018 class AdvPbApp;
00019 class AdvPbWin : public PhonebookWin {
00020     typedef PhonebookWin Base;
00021
00022     public:
00024         AdvPbWin();
00026         virtual ~AdvPbWin();
00027
00029         void Init(AdvPbApp* pb_app, Provider* pb_provider = 0, INT sort_colid = c_name_id, BOOLEAN read_only = FALSE);
00030
00032         virtual INT GetSelectedRow();
00033
00035         virtual Provider* GetMyPbProvider();
00036
00038         virtual PbDetails* GetDetailWin();
00039
00040     protected:
00042         virtual INT GetListBoxRow(INT prov_row);
00043
00044     private:
00045         Provider*               m_pb_provider;
00046         PbAdvDetails            m_detail_win;
00047         static const INT        m_detail_columns[5];
00048
00049         FilterProvider          m_filtered_prov;
00050         EqualsRule              m_rule;
00051 };
00052
00054 #endif  // Mmi_AdvPbWin_hpp
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/ApbVersion.cpp File Reference

Applications/AdvPhonebook/ApbVersion.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Kernel/VersionInfo.hpp>
#include <ApbVersion.hpp>

Include dependency graph for ApbVersion.cpp:

Functions

ApoxiDefVersionInfo (Mmi, APBVERSION, VersionInfo::c_flag_add_to_trace_info)
unsigned char | get_sw_version ()
UINT8 | get_sw_version_text (char *ver_text, UINT8 max_len)
void | MmiSendGddViewfinderEnabled ()

Function Documentation

ApoxiDefVersionInfo | ( | Mmi | ,
 |  | APBVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

unsigned char get_sw_version ( )

UINT8 get_sw_version_text | ( | char * | ver_text,
 |  | UINT8 | max_len
 | ) |

void MmiSendGddViewfinderEnabled ( )

Generated on Tue Jan 24 23:26:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/ApbVersion.hpp File Reference

Applications/AdvPhonebook/ApbVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | APBVERSION "2.10.0_TIV_04"
#define | ApbVersion_hpp

Functions

unsigned char | get_sw_version ()
UINT8 | get_sw_version_text (char *ver_text, UINT8 max_len)

Define Documentation

#define APBVERSION "2.10.0_TIV_04"

#define ApbVersion_hpp

Function Documentation

unsigned char get_sw_version ( )

UINT8 get_sw_version_text | ( | char * | ver_text,
 |  | UINT8 | max_len
 | ) |

Generated on Tue Jan 24 23:26:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/ApbVersion.hpp Source File

Applications/AdvPhonebook/ApbVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ApbVersion_hpp)
00010 #define ApbVersion_hpp
00011
00012
00013 /*
00014 ApbVersion.hpp contains the official Apb Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define APBVERSION "2.10.0_TIV_04"
00019
00020 // Add for Version
00021 extern "C" unsigned char get_sw_version();
00022 // Add for AT Command Version
00023 extern "C" UINT8 get_sw_version_text(char *ver_text, UINT8 max_len);
00024
00025 #endif  // ApbVersion_hpp
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/BasicPbWin.cpp File Reference

Applications/AdvPhonebook/BasicPbWin.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include "PbProvIds.hpp"
#include "ProvListBoxWin.hpp"
#include "PhonebookApp.hpp"
#include "BasicPbWin.hpp"

Include dependency graph for BasicPbWin.cpp:

Generated on Tue Jan 24 23:26:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/BasicPbWin.hpp File Reference

Applications/AdvPhonebook/BasicPbWin.hpp File Reference

#include <AdvPhonebook/PhonebookWin.hpp>
#include <AdvPhonebook/PbDetails.hpp>

Include dependency graph for BasicPbWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BasicPbWin

Defines

#define | Mmi_BasicPbWin_hpp

Define Documentation

#define Mmi_BasicPbWin_hpp

Generated on Tue Jan 24 23:26:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/BasicPbWin.hpp Source File

Applications/AdvPhonebook/BasicPbWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_BasicPbWin_hpp)
00009 #define Mmi_BasicPbWin_hpp
00012
00013 #include <AdvPhonebook/PhonebookWin.hpp>
00014 #include <AdvPhonebook/PbDetails.hpp>
00015
00016 class PhonebookApp;
00017 class BasicPbWin : public PhonebookWin {
00018     public:
00019         typedef PhonebookWin Base;
00020
00021         BasicPbWin();
00022         virtual ~BasicPbWin();
00023
00024         void Init(Provider* pb_provider = 0, INT sort_colid = c_name_id, BOOLEAN read_only = FALSE);
00025
00026     protected:
00027         virtual PbDetails* GetDetailWin();
00028
00029     private:
00030         PbDetails               m_detail_win;
00031         static const INT        m_detail_columns[3];
00032 };
00033
00035 #endif  // Mmi_BasicPbWin_hpp
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/CopyHandler.cpp File Reference

Applications/AdvPhonebook/CopyHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <GuiExtensions/MmiAdvancedProgressBox.hpp>
#include "PbDetailFilterProvider.hpp"
#include "CopyHandler.hpp"

Include dependency graph for CopyHandler.cpp:

Generated on Tue Jan 24 23:26:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/CopyHandler.hpp File Reference

Applications/AdvPhonebook/CopyHandler.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CopyHandler
class | PbCopyHandler

Defines

#define | Mmi_CopyHandler_hpp

Define Documentation

#define Mmi_CopyHandler_hpp

Generated on Tue Jan 24 23:26:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/CopyHandler.hpp Source File

Applications/AdvPhonebook/CopyHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #if !defined(Mmi_CopyHandler_hpp)
00012 #define Mmi_CopyHandler_hpp
00015
00016 class MmiAdvancedProgressBox;
00017 class CopyHandler {
00018
00019     public:
00020         CopyHandler();
00021         CopyHandler(Provider *src_prov, Provider *dst_prov);
00022         virtual ~CopyHandler();
00023
00024         void Init(Provider *src_prov, Provider *dst_prov);
00025
00026         BOOLEAN CopyAll(MmiAdvancedProgressBox *listener = 0);
00027
00028         BOOLEAN CopyRow(INT row);
00029
00030     private:
00031         Provider *  m_src_prov;
00032         Provider *  m_dst_prov;
00033 };
00034
00035 class PbProvider;
00036 class PbCopyHandler : public CopyHandler {
00037     typedef CopyHandler Base;
00038
00039     public:
00040         PbCopyHandler();
00041         virtual ~PbCopyHandler();
00042
00043         void Init(Provider *src_prov, Provider *dst_prov);
00044
00045         BOOLEAN CopyPbRow(INT row);
00046
00047     private:
00048         Provider *m_src_prov;
00049
00050 };
00051
00053 #endif  // Mmi_PbCopyHandler_hpp
00054
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/GroupProvider.cpp File Reference

Applications/AdvPhonebook/GroupProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "GroupProvider.hpp"

Include dependency graph for GroupProvider.cpp:

Generated on Tue Jan 24 23:27:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/GroupProvider.hpp File Reference

Applications/AdvPhonebook/GroupProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>
#include <Config/Config.hpp>

Include dependency graph for GroupProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GroupProvider
struct | GroupProvider::GroupRec

Defines

#define | Mmi_GroupProvider_hpp

Variables

const INT | c_max_groups = 10

Define Documentation

#define Mmi_GroupProvider_hpp

Generated on Tue Jan 24 23:27:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/GroupProvider.hpp Source File

Applications/AdvPhonebook/GroupProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_GroupProvider_hpp)
00015 #define Mmi_GroupProvider_hpp
00018
00019 #include <Auxiliary/Provider.hpp>
00020 #include <Config/Config.hpp>
00021
00022 const INT c_max_groups = 10;
00023
00024 /*------------------------------------------------------------------
00025                             GroupProvider
00026  ------------------------------------------------------------------*/
00027
00028 class GroupProvider : public Provider {
00029
00030     public:
00031
00032         struct GroupRec {
00033             INT         id;
00034             WString     name;
00035         };
00036
00037         typedef Provider Base;
00038
00040         GroupProvider();
00042         virtual ~GroupProvider();
00043
00045         void Init();
00046
00048         virtual INT GetProviderId() const;
00050         virtual INT RowCount();
00051
00053         virtual BOOLEAN GetDataItem(IN INT columnid,
00054                                     IN INT row,
00055                                     OUT DataItem & item);
00056
00057
00058     private:
00059         GroupRec m_groups[c_max_groups];
00060 };
00061
00063 #endif
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAbstractWin.cpp File Reference

Applications/AdvPhonebook/PbAbstractWin.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Config/MmiGuiEngineConfig.hpp>
#include "AdvPbMsgTypes.hpp"
#include <AdvPhonebook/PhonebookApp.hpp>
#include <AdvPhonebook/PbAbstractWin.hpp>

Include dependency graph for PbAbstractWin.cpp:

Generated on Tue Jan 24 23:27:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAbstractWin.hpp File Reference

Applications/AdvPhonebook/PbAbstractWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <AdvPhonebook/PbProvListBox.hpp>

Include dependency graph for PbAbstractWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbAbstractWin

Defines

#define | Mmi_PbAbstractWin_hpp

Define Documentation

#define Mmi_PbAbstractWin_hpp

Generated on Tue Jan 24 23:27:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAbstractWin.hpp Source File

Applications/AdvPhonebook/PbAbstractWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbAbstractWin_hpp)
00010 #define Mmi_PbAbstractWin_hpp
00013
00014 #include <GuiExtensions/MmiWindow.hpp>
00015 #include <AdvPhonebook/PbProvListBox.hpp>
00016
00017 class PhonebookApp;
00018 class PbAbstractWin : public MmiWindow {
00019
00020     typedef MmiWindow Base;
00021
00022     public:
00023         enum MenuIndex {
00024             MainMenu    = 1,
00025             SubMenu     = 2
00026         };
00027
00028         PbAbstractWin();
00029         virtual ~PbAbstractWin();
00030
00031         void Init();
00032
00033         PhonebookApp* GetPbApplication() const { return (PhonebookApp*) GetApplication(); };
00034
00035         virtual Provider* GetMyPbProvider();
00036
00037         virtual void SetSelectedRow(INT );
00038
00039         virtual INT GetSelectedRow() = 0;
00040         virtual void GetSelectedItem(INT colid, DataItem &item) = 0;
00041
00042         virtual void UpdateWin(BOOLEAN win_only = FALSE);
00043
00044         void AddMenuAction(INT idx, Action *action, BOOLEAN separate = FALSE);
00045
00046         void ChangeMenuAction(INT idx, Action *old_action, Action *new_action);
00047
00048         void SetDisplaySimPos(BOOLEAN display_simpos) { m_display_simpos = display_simpos; }
00049         BOOLEAN GetDisplaySimPos() { return m_display_simpos; }
00050
00051         void SetPbTitle(const WString &title);
00052         const WString& GetPbTitle() { return m_title; }
00053
00054         BOOLEAN IsConfirmed() { return m_confirmed; }
00055
00056         virtual BOOLEAN IsReadOnly() { return FALSE; }
00057
00058         void SetPbProvider(Provider* provider) { m_pb_provider = provider; }
00059
00060         Provider* GetPbProvider() { return m_pb_provider; }
00061
00062     protected:
00063         virtual void OnOpen();
00064         virtual void OnGetFocus();
00065         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00066         virtual BOOLEAN OnConfirm();
00067         virtual BOOLEAN OnCancel();
00068         virtual void OnClose();
00069         virtual void OnLanguageChanged();
00070         virtual BOOLEAN OnSoftkeyPressed(INT idx);
00071
00072         virtual void UpdateEnabledActions();
00073         virtual void DisplaySimPos();
00074
00075         void RestoreSoftkeys();
00076
00077         ActionAccessor* GetAccessor(INT idx);
00078
00079     private:
00080         INT GetAffectedRow();
00081
00082         ActionAccessor          m_main_accessor;
00083         ActionAccessor          m_sub_accessor;
00084
00085         MenuAction              m_popup_action;
00086         CancelAction            m_cancel_action;
00087
00088         BOOLEAN                 m_confirmed;
00089         BOOLEAN                 m_display_simpos;
00090         WString                 m_title;
00091
00092         INT                     m_popup_sep_idx;
00093         INT                     m_close_sep_idx;
00094
00095         Provider*               m_pb_provider;
00096 };
00097
00099 #endif  // Mmi_PbAbstractWin_hpp
Generated on Tue Jan 24 14:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAction.cpp File Reference

Applications/AdvPhonebook/PbAction.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/FindProvider.hpp>
#include <Common/SecurityControl.hpp>
#include <Common/SecurityManager.hpp>
#include "PhonebookApp.hpp"
#include "PbDetails.hpp"
#include "PbAbstractWin.hpp"
#include "PbAction.hpp"

Include dependency graph for PbAction.cpp:

Generated on Tue Jan 24 23:27:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAction.hpp File Reference

Applications/AdvPhonebook/PbAction.hpp File Reference

#include <Gui/CheckBoxAction.hpp>

Include dependency graph for PbAction.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AddAllToFdnAction
class | AddEntryToFdnAction
class | AddNumberToFdnAction
class | CopyToPbAction
class | DisplayMemoryAction
class | PbAction
class | PbAddAction
class | PbCallAction
class | PbCancelEditAction
class | PbConfirmEditAction
class | PbDelAllAction
class | PbDeleteAction
class | PbDetailAction
class | PbEditDetailAction
class | PbSecuredAction
class | PbToggleAction
class | SyncAction

Defines

#define | Mmi_PbAction_hpp

Define Documentation

#define Mmi_PbAction_hpp

Generated on Tue Jan 24 23:27:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAction.hpp Source File

Applications/AdvPhonebook/PbAction.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbAction_hpp)
00009 #define Mmi_PbAction_hpp
00012
00013 #include <Gui/CheckBoxAction.hpp>
00014
00015 class PhonebookApp;
00016 class PbAbstractWin;
00017
00018 class PbAction : public Action {
00019     typedef Action Base;
00020
00021     public:
00022         PbAction();
00023         virtual ~PbAction();
00024
00025         void Init(PhonebookApp *pb_app, const WCHAR *text, const BitmapRes* bitmap = 0);
00026
00027         virtual BOOLEAN Execute();
00028
00029         PhonebookApp* GetPbApplication() { return m_pb_app; }
00030
00031     private:
00032         static PhonebookApp *m_pb_app;
00033 };
00034
00035 class PbToggleAction : public CheckBoxAction {
00036     typedef CheckBoxAction Base;
00037
00038     public:
00039         PbToggleAction();
00040         virtual ~PbToggleAction();
00041
00042         void Init(PhonebookApp *pb_app, const WCHAR *text);
00043
00044         PhonebookApp* GetPbApplication() { return m_pb_app; }
00045
00046     private:
00047         static PhonebookApp *m_pb_app;
00048 };
00049
00050 class PbSecuredAction : public PbAction {
00051     typedef PbAction Base;
00052
00053     public:
00054         PbSecuredAction();
00055         virtual ~PbSecuredAction();
00056         virtual BOOLEAN Execute();
00057         BOOLEAN IsExecuting() { return m_is_executing; }
00058
00059     private:
00060         BOOLEAN m_is_executing;
00061 };
00062
00063 class PbDetails;
00064 class PbDetailAction : public PbSecuredAction {
00065     typedef PbSecuredAction Base;
00066
00067     public:
00068         PbDetailAction();
00069         PbDetailAction(PbDetails *detail_win, const WCHAR *text);
00070         virtual ~PbDetailAction();
00071
00072         void Init(PbDetails *detail_win, const WCHAR *text);
00073
00074         PbDetails* GetDetailWin() { return m_detail_win; };
00075
00076     private:
00077         PbDetails   *m_detail_win;
00078 };
00079
00080 class PbAddAction : public PbSecuredAction {
00081     typedef PbSecuredAction Base;
00082
00083     public:
00084         virtual BOOLEAN Execute();
00085 };
00086
00087 class PbEditDetailAction : public PbDetailAction {
00088     typedef PbDetailAction Base;
00089
00090     public:
00091         virtual BOOLEAN Execute();
00092
00093 };
00094
00095 class PbConfirmEditAction : public PbDetailAction {
00096     typedef PbDetailAction Base;
00097
00098     public:
00099         virtual BOOLEAN Execute();
00100 };
00101
00102 class PbCancelEditAction : public PbDetailAction {
00103     typedef PbDetailAction Base;
00104
00105     public:
00106         virtual BOOLEAN Execute();
00107 };
00108
00109 class PbCallAction : public PbAction {
00110     public:
00111         typedef PbAction Base;
00112
00113         virtual BOOLEAN Execute();
00114 };
00115
00116 class PbDeleteAction : public PbSecuredAction {
00117     typedef PbSecuredAction Base;
00118
00119     public:
00120         virtual BOOLEAN Execute();
00121 };
00122
00123 class PbDelAllAction : public PbSecuredAction {
00124     typedef PbSecuredAction Base;
00125
00126     public:
00127         virtual BOOLEAN Execute();
00128 };
00129
00130 class SyncAction : public PbAction {
00131     typedef PbAction Base;
00132
00133     public:
00134         virtual BOOLEAN Execute();
00135 };
00136
00137 class DisplayMemoryAction : public PbAction {
00138     typedef PbAction Base;
00139
00140     public:
00141         virtual BOOLEAN Execute();
00142 };
00143
00144 class AddAllToFdnAction : public PbSecuredAction {
00145     typedef PbSecuredAction Base;
00146
00147     public:
00148         virtual BOOLEAN Execute();
00149 };
00150
00151 class AddEntryToFdnAction : public PbSecuredAction {
00152     typedef PbSecuredAction Base;
00153
00154     public:
00155         virtual BOOLEAN Execute();
00156 };
00157
00158 class AddNumberToFdnAction : public PbSecuredAction {
00159     typedef PbSecuredAction Base;
00160
00161     public:
00162         virtual BOOLEAN Execute();
00163 };
00164
00165 class CopyToPbAction : public PbSecuredAction {
00166     typedef PbSecuredAction Base;
00167
00168     public:
00169         virtual BOOLEAN Execute();
00170 };
00171
00173 #endif  // Mmi_PbAction_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvAddEditEntry.cpp File Reference

Applications/AdvPhonebook/PbAdvAddEditEntry.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/AlphaCoding.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Config/PhonebookConfig.hpp>
#include "PbAdvAddEditEntry.hpp"

Include dependency graph for PbAdvAddEditEntry.cpp:

Variables

LineEditor g_mail_editor
TextLine g_mail_text

Variable Documentation

LineEditor g_mail_editor

TextLine g_mail_text

Generated on Tue Jan 24 23:28:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvAddEditEntry.hpp File Reference

Applications/AdvPhonebook/PbAdvAddEditEntry.hpp File Reference

#include <AdvPhonebook/PbNameEditBox.hpp>
#include <AdvPhonebook/PbConfig.hpp>
#include <GuiExtensions/MmiDialog.hpp>
#include <Gui/LineEditor.hpp>

Include dependency graph for PbAdvAddEditEntry.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbAdvAddEditEntry

Defines

#define | Mmi_PbAdvAddEditEntry_hpp

Define Documentation

#define Mmi_PbAdvAddEditEntry_hpp

Generated on Tue Jan 24 23:28:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvAddEditEntry.hpp Source File

Applications/AdvPhonebook/PbAdvAddEditEntry.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbAdvAddEditEntry_hpp)
00010 #define Mmi_PbAdvAddEditEntry_hpp
00013
00014 #include <AdvPhonebook/PbNameEditBox.hpp>
00015 #include <AdvPhonebook/PbConfig.hpp>
00016 #include <GuiExtensions/MmiDialog.hpp>
00017 #include <Gui/LineEditor.hpp>
00018
00019 class PbAdvAddEditEntry : public MmiDialog {
00020     typedef MmiDialog Base;
00021
00022     public:
00023         //
00024         PbAdvAddEditEntry();
00025
00026         //
00027         void Init();
00028
00029         //
00030         void SetName(const WString &name);
00031
00032         //
00033         const WString& GetName() const;
00034
00035         //
00036         void SetPhoneNo(const PhoneNumber &phone_no);
00037
00038         //
00039         PhoneNumber GetPhoneNo() const;
00040
00041         //
00042         void SetMaxAlphaTagSize(INT ats);
00043
00044     protected:
00045         virtual void OnOpen();
00046         virtual void OnLayoutClient();
00047         virtual BOOLEAN OnConfirm();
00048
00049     private:
00050         TextLine            m_name_text;
00051         PbNameEditBox       m_name_editor;
00052
00053         TextLine            m_phone_no_text;
00054         LineEditor          m_phone_no_editor;
00055 };
00056
00058 #endif  // Mmi_PbAdvAddEditEntry_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvDataHandler.cpp File Reference

Applications/AdvPhonebook/PbAdvDataHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <AdvPhonebook/PhonebookApp.hpp>
#include <AdvPhonebook/PbProviderListener.hpp>
#include "PbAdvDataHandler.hpp"

Include dependency graph for PbAdvDataHandler.cpp:

Generated on Tue Jan 24 23:28:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvDataHandler.hpp File Reference

Applications/AdvPhonebook/PbAdvDataHandler.hpp File Reference

#include <Adc/DataHandler.hpp>
#include <AddOns/AuxExtensions/JoinRule.hpp>
#include <AdvPhonebook/PbNameFilterProvider.hpp>
#include <AdvPhonebook/PbFfsNameHandler.hpp>
#include <AdvPhonebook/PbNameProvider.hpp>
#include <AdvPhonebook/PbFfsNumberHandler.hpp>
#include <AdvPhonebook/PbNumberProvider.hpp>
#include <AdvPhonebook/PbSimProvider.hpp>
#include <AdvPhonebook/GroupProvider.hpp>
#include <AdvPhonebook/PbMergeProvider.hpp>
#include <AdvPhonebook/PbDataHandler.hpp>

Include dependency graph for PbAdvDataHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbAdvDataHandler

Defines

#define | Mmi_PbAdvDataHandler_hpp

Define Documentation

#define Mmi_PbAdvDataHandler_hpp

Generated on Tue Jan 24 23:28:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvDataHandler.hpp Source File

Applications/AdvPhonebook/PbAdvDataHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbAdvDataHandler_hpp)
00009 #define Mmi_PbAdvDataHandler_hpp
00013
00014 #include <Adc/DataHandler.hpp>
00015 #include <AddOns/AuxExtensions/JoinRule.hpp>
00016
00017 #include <AdvPhonebook/PbNameFilterProvider.hpp>
00018
00019 #include <AdvPhonebook/PbFfsNameHandler.hpp>
00020 #include <AdvPhonebook/PbNameProvider.hpp>
00021 #include <AdvPhonebook/PbFfsNumberHandler.hpp>
00022 #include <AdvPhonebook/PbNumberProvider.hpp>
00023 #include <AdvPhonebook/PbSimProvider.hpp>
00024
00025 #include <AdvPhonebook/GroupProvider.hpp>
00026 #include <AdvPhonebook/PbMergeProvider.hpp>
00027 #include <AdvPhonebook/PbDataHandler.hpp>
00028
00029 class PbAdvDataHandler : public PbDataHandler {
00030     typedef PbDataHandler Base;
00031
00032     public:
00033
00034         PbAdvDataHandler();
00035         virtual ~PbAdvDataHandler();
00036
00037         void Init();
00038
00039         virtual Provider* GetPbProvider();
00040         virtual Provider* GetDistinctNameProvider();
00041         Provider* GetNameProvider() { return &m_name_provider; }
00042         Provider* GetNumberProvider() { return &m_no_provider; }
00043
00044         virtual void UpdateProvider(ProviderListener *listener = 0);
00045         void ObserveProvider(BOOLEAN observe);
00046 //CN200013749
00047         UINT32 GetLastDeletedUniqueId(){
00048             return m_pb_provider.GetLastDeletedUniqueId();}
00049 //END CN200013749
00050
00051     private:
00052         void InitIccFilter();
00053
00054         PbFfsNameHandler        m_name_handler;
00055         PbFfsNumberHandler      m_number_handler;
00056         PbMergeProvider         m_pb_provider;
00057         PbNameProvider          m_name_provider;
00058         PbNumberProvider        m_no_provider;
00059         FilterProvider          m_name_icc_provider;
00060         StandardJoinRule        m_join_rule;
00061         EqualsRule              m_rule;
00062         Protector               m_protector;
00063         GroupProvider           m_group_provider;
00064
00065 };
00066
00068 #endif
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvDetails.cpp File Reference

Applications/AdvPhonebook/PbAdvDetails.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "AdvPbApp.hpp"
#include "PbAdvDetails.hpp"

Include dependency graph for PbAdvDetails.cpp:

Generated on Tue Jan 24 23:28:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvDetails.hpp File Reference

Applications/AdvPhonebook/PbAdvDetails.hpp File Reference

#include <AdvPhonebook/AdvPbAction.hpp>
#include <AdvPhonebook/PbDetails.hpp>

Include dependency graph for PbAdvDetails.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbAdvDetails

Defines

#define | Mmi_PbAdvDetails_hpp

Define Documentation

#define Mmi_PbAdvDetails_hpp

Generated on Tue Jan 24 23:28:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbAdvDetails.hpp Source File

Applications/AdvPhonebook/PbAdvDetails.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbAdvDetails_hpp)
00010 #define Mmi_PbAdvDetails_hpp
00013
00014 #include <AdvPhonebook/AdvPbAction.hpp>
00015 #include <AdvPhonebook/PbDetails.hpp>
00016
00017 class AdvPbApp;
00018 class AdvPbWin;
00019 class PbAdvDetails : public PbDetails {
00020     typedef PbDetails Base;
00021
00022     public:
00023
00024         PbAdvDetails();
00025         virtual ~PbAdvDetails();
00026
00027         void Init(AdvPbApp* pb_app, AdvPbWin *parent, const INT* detail_columns);
00028
00029         virtual void AddNumber();
00030         virtual void CancelAddNumber();
00031
00032         virtual INT GetSelectedRow();
00033
00034     protected:
00035         virtual PbDetailProvider * GetDetailProvider();
00036         virtual void GetUpdatedItem(INT colid, DataItem &item);
00037         virtual const WString   GetSavedText(INT colid);
00038
00039     private:
00040         virtual void UpdateWin();
00041         virtual void UpdateEnabledActions();
00042
00043         AdvPbApp*               m_pb_app;
00044
00045         PbAddPhoneNoAction      m_add_phoneno_action;
00046         PbCancelAddNoAction     m_cancel_add_no_action;
00047         PbChangeNoTypeAction    m_no_type_action;
00048 //      static const INT        m_more_detail_columns[5];
00049
00050         PbNumberFilterProvider  m_no_filter;
00051         INT                     m_phoneno_cnt;
00052 };
00053
00055 #endif  // Mmi_PbAdvDetails_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbBaseWin.cpp File Reference

Applications/AdvPhonebook/PbBaseWin.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Config/MmiGuiEngineConfig.hpp>
#include "PhonebookApp.hpp"
#include "AdvPbMsgTypes.hpp"
#include "PbBaseWin.hpp"
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for PbBaseWin.cpp:

Generated on Tue Jan 24 23:29:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbBaseWin.hpp File Reference

Applications/AdvPhonebook/PbBaseWin.hpp File Reference

#include <AdvPhonebook/PbConfig.hpp>
#include <AdvPhonebook/ProvListBoxWin.hpp>
#include <Gui/LineEditor.hpp>

Include dependency graph for PbBaseWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbBaseWin
class | SearchBox

Defines

#define | Mmi_PbBaseWin_hpp

Define Documentation

#define Mmi_PbBaseWin_hpp

Generated on Tue Jan 24 23:29:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbBaseWin.hpp Source File

Applications/AdvPhonebook/PbBaseWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbBaseWin_hpp)
00009 #define Mmi_PbBaseWin_hpp
00012
00013 #include <AdvPhonebook/PbConfig.hpp>
00014 #include <AdvPhonebook/ProvListBoxWin.hpp>
00015 #include <Gui/LineEditor.hpp>
00016
00018 class SearchBox : public LineEditor {
00019     typedef LineEditor Base;
00020
00021     public:
00022         //
00023         SearchBox();
00024         virtual ~SearchBox();
00025
00026         //
00027         void Init(Window *win);
00028
00029         virtual void MoveCaret(INT steps);
00030
00031     protected:
00033         //virtual void OnPagingTimer();
00034         //virtual BOOLEAN OnKeyDown(KeyCode key_code);
00035 };
00036
00037 class PbBaseWin : public ProvColListBoxWin {
00038     public:
00039         typedef ProvColListBoxWin Base;
00040
00041         PbBaseWin();
00042         virtual ~PbBaseWin();
00043
00044         void Init(Provider* pb_provider = 0, INT sort_colid = c_name_id);
00045
00046         virtual Provider* GetMyPbProvider();
00047
00048         virtual INT GetSelectedRow();
00049
00050     protected:
00051         virtual INT GetListBoxRow(INT prov_row);
00052
00053         virtual BOOLEAN OnMessage(const Message &msg);
00054         virtual void OnLayoutClient();
00055         virtual void OnGetFocus();
00056         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00057         virtual BOOLEAN OnConfirm();
00058         virtual BOOLEAN OnCancel();
00059
00060     private:
00061         INT SearchRow(const WString &string);
00062
00063         INT                     m_sort_colid;
00064         QuickSortProvider       m_sorted_pb_provider;
00065
00066         SearchBox               m_search_box;
00067         ImageBox                m_search_image;
00068         BOOLEAN                 m_searchbox_visible;
00069 };
00070
00072 #endif  // Mmi_PbBaseWin_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbConfig.hpp File Reference

Applications/AdvPhonebook/PbConfig.hpp File Reference

#include <Phonebook/PbTypes.hpp>

Include dependency graph for PbConfig.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Mmi_PbConfig_hpp

Variables

const WString | c_empty_string = Tr(L"< empty >")
const INT | c_max_email_len = 30
const INT | c_max_name_len = 25
const INT | c_max_pb_name_entries = 100
const INT | c_max_pb_number_entries = 200
const INT | c_max_phonenos = 2

Define Documentation

#define Mmi_PbConfig_hpp

Variable Documentation

const WString c_empty_string = Tr(L"< empty >")

const INT c_max_email_len = 30

const INT c_max_name_len = 25

const INT c_max_pb_name_entries = 100

const INT c_max_pb_number_entries = 200

const INT c_max_phonenos = 2

Generated on Tue Jan 24 23:29:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbConfig.hpp Source File

Applications/AdvPhonebook/PbConfig.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbConfig_hpp)
00009 #define Mmi_PbConfig_hpp
00010
00011 #include <Phonebook/PbTypes.hpp>
00012
00013 //#define APOXI_SIM_ONLY
00014
00015 const INT c_max_name_len = 25;
00016 const INT c_max_email_len = 30;
00017 const INT c_max_pb_name_entries = 100;
00018 const INT c_max_pb_number_entries = 200;
00019 const WString c_empty_string = Tr(L"< empty >");
00020
00021 const INT c_max_phonenos = 2;
00022
00023 #endif  // Mmi_PbConfig_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDataHandler.cpp File Reference

Applications/AdvPhonebook/PbDataHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Config/Config.hpp>
#include "PhonebookApp.hpp"
#include "PbProviderListener.hpp"
#include "PbDataHandler.hpp"

Include dependency graph for PbDataHandler.cpp:

Generated on Tue Jan 24 23:29:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDataHandler.hpp File Reference

Applications/AdvPhonebook/PbDataHandler.hpp File Reference

#include <Auxiliary/QuickSortProvider.hpp>
#include <AdvPhonebook/PbSimProvider.hpp>

Include dependency graph for PbDataHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbDataHandler

Defines

#define | Mmi_PbDataHandler_hpp

Define Documentation

#define Mmi_PbDataHandler_hpp

Generated on Tue Jan 24 23:29:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDataHandler.hpp Source File

Applications/AdvPhonebook/PbDataHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbDataHandler_hpp)
00009 #define Mmi_PbDataHandler_hpp
00012
00013 #include <Auxiliary/QuickSortProvider.hpp>
00014 #include <AdvPhonebook/PbSimProvider.hpp>
00015
00016 class PbDataHandler {
00017
00018     public:
00019
00020         PbDataHandler();
00021         virtual ~PbDataHandler();
00022
00023         void Init();
00024         virtual Provider * GetPbProvider();
00025         virtual Provider * GetDistinctNameProvider();
00026
00027         Provider * GetAdnProvider() { return &m_adn_provider; }
00028         Provider * GetFdnProvider() { return &m_fdn_provider; }
00029         Provider * GetMsIsdnProvider() { return &m_msisdn_provider; }
00030         Provider * GetBdnProvider() { return &m_bdn_provider; }
00031         Provider * GetSdnProvider() { return &m_sdn_provider; }
00032
00033         virtual SortProvider * GetSortedNumberProvider();
00034
00035         virtual void UpdateProvider(ProviderListener *listener = 0);
00036         virtual void UpdateSortedProvider(ProviderListener *listener = 0);
00037
00038     private:
00039         void Update(Provider* provider, ProviderListener *listener = 0);
00040
00041         PbSimProvider           m_adn_provider;
00042         PbSimProvider           m_fdn_provider;
00043         PbSimProvider           m_msisdn_provider;
00044         PbSimProvider           m_bdn_provider;
00045         PbSimProvider           m_sdn_provider;
00046
00047         QuickSortProvider       m_sorted_no_prov;
00048
00049
00050 };
00051
00053 #endif
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetailFilterProvider.cpp File Reference

Applications/AdvPhonebook/PbDetailFilterProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbProvIds.hpp"
#include "PbDetailFilterProvider.hpp"

Include dependency graph for PbDetailFilterProvider.cpp:

Generated on Tue Jan 24 23:29:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetailFilterProvider.hpp File Reference

Applications/AdvPhonebook/PbDetailFilterProvider.hpp File Reference

#include <Auxiliary/FilterProvider.hpp>

Include dependency graph for PbDetailFilterProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbDetailProvider
class | PbNumberFilterProvider

Defines

#define | Mmi_PbDetailFilterProvider_hpp

Define Documentation

#define Mmi_PbDetailFilterProvider_hpp

Generated on Tue Jan 24 23:29:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetailFilterProvider.hpp Source File

Applications/AdvPhonebook/PbDetailFilterProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PbDetailFilterProvider_hpp)
00015 #define Mmi_PbDetailFilterProvider_hpp
00018
00019 #include <Auxiliary/FilterProvider.hpp>
00020
00021 class PbDetailProvider : public AbstractDelegationProvider {
00022     typedef AbstractDelegationProvider Base;
00023
00024     public:
00025         PbDetailProvider();
00026         PbDetailProvider(Provider *provider, INT detail_row = c_no_row);
00027
00028         ~PbDetailProvider();
00029
00030         void Init(Provider *provider, INT detail_row = c_no_row);
00031
00032         void SetProvider(Provider* provider) { m_provider = provider; }
00033
00034         virtual void SetDetailRow(INT detail_row);
00035         virtual INT GetDetailRow();
00036
00037         void SetKeyItem(const DataItem &key_item) { m_key_item = key_item; }
00038         const DataItem& GetKeyItem() { return m_key_item; }
00039
00040         virtual INT RowCount();
00041
00042         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem &item);
00043
00044         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00045
00046         virtual BOOLEAN Update(ProviderListener *listener = 0);
00047
00048     protected:
00049
00050     private:
00051         Provider *  m_provider;
00052         INT         m_detail_row;
00053         DataItem    m_key_item;
00054 };
00055
00056 class PbProvider;
00057 class PbNumberFilterProvider : public PbDetailProvider {
00058     typedef PbDetailProvider Base;
00059
00060     public:
00061         PbNumberFilterProvider();
00062         PbNumberFilterProvider(Provider *provider, INT name_row = c_no_row);
00063
00064         ~PbNumberFilterProvider();
00065
00066         void Init(Provider *provider, INT name_row = c_no_row);
00067
00068         virtual INT RowCount();
00069
00070         virtual INT GetProviderId() const;
00071
00072         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem &item);
00073
00074         virtual BOOLEAN GetChildRow(INT & childrow, INT row);
00075
00076         virtual BOOLEAN Update(ProviderListener *listener = 0);
00077
00078         virtual BOOLEAN SetParameter(const DataItem& item);
00079
00080         virtual Status GetStatus() const;
00081
00082     private:
00083         Provider *          m_pb_provider;
00084         INT                 m_name_row;
00085
00086         FilterProvider      m_filter;
00087         QuickSortProvider   m_sort_prov;
00088         EqualsRule          m_rule;
00089         DataItem            m_filt_item;
00090         DataItem            m_old_key_item;
00091
00092         BOOLEAN             m_both_affected;
00093 };
00094
00096 #endif
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetailListBox.cpp File Reference

Applications/AdvPhonebook/PbDetailListBox.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/WString.hpp>
#include <Config/Config.hpp>
#include "PbProvIds.hpp"
#include "PhonebookApp.hpp"
#include "PbDetailListBox.hpp"

Include dependency graph for PbDetailListBox.cpp:

Generated on Tue Jan 24 23:30:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetailListBox.hpp File Reference

Applications/AdvPhonebook/PbDetailListBox.hpp File Reference

#include <AdvPhonebook/PbProvListBox.hpp>

Include dependency graph for PbDetailListBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbDetailListBox
class | PbDetailListBoxModel

Defines

#define | Mmi_PbDetail_ListBox_hpp

Define Documentation

#define Mmi_PbDetail_ListBox_hpp

Generated on Tue Jan 24 23:30:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetailListBox.hpp Source File

Applications/AdvPhonebook/PbDetailListBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbDetail_ListBox_hpp)
00010 #define Mmi_PbDetail_ListBox_hpp
00013
00014 #include <AdvPhonebook/PbProvListBox.hpp>
00015
00016 class PbProvider;
00017 class PbDetailListBoxModel : public PbProvListBoxModel {
00018     typedef PbProvListBoxModel Base;
00019
00020     public:
00021         PbDetailListBoxModel();
00022         PbDetailListBoxModel(DrawableObjectListBox *listbox, const INT* detail_columns, INT filt_colid = c_phone_no_id);
00023
00024         void Init(DrawableObjectListBox *listbox, const INT* detail_columns, INT filt_colid = c_phone_no_id);
00025
00026         void SetDetailColumns(const INT *detail_columns);
00027
00028         virtual void UpdateNoOfItems();
00029
00030         INT GetSelectedNoIndex(INT index = -1);
00031         void SetSelectedNoIndex(INT no_index);
00032
00033         INT GetSelectedNoRow(INT index = -1);
00034
00035     protected:
00036         virtual INT GetRow(INT index);
00037         virtual INT GetColumnId(INT index);
00038
00039     private:
00040         INT GetColIdIndex(INT colid) const;
00041
00042         INT                     m_name_row;
00043         INT                     m_column_cnt;
00044         DataItem                m_key_item;
00045         const INT *             m_detail_columns;
00046         INT                     m_filt_colid;
00047 };
00048
00049 class PbDetailListBox : public PbProvListBox {
00050     typedef PbProvListBox Base;
00051
00052     public:
00053         PbDetailListBox();
00054         PbDetailListBox(ProvListBoxWin *parent, const INT* detail_columns, INT filt_colid = c_phone_no_id);
00055
00056         virtual ~PbDetailListBox();
00057
00058         void Init(ProvListBoxWin *parent, const INT* detail_columns, INT filt_colid = c_phone_no_id);
00059
00060         XYDIM GetSelectedYPos() const;
00061
00062         const WCHAR* GetSelectedText() { return GetMyModel()->GetProvText(GetSelectedIndex()); };
00063
00064         INT GetSelectedNoRow() { return GetMyModel()->GetSelectedNoRow(); };
00065
00066         INT GetSelectedNoIndex() { return GetMyModel()->GetSelectedNoIndex(); };
00067         void SetSelectedNoIndex(INT no_idx) { GetMyModel()->SetSelectedNoIndex(no_idx); };
00068
00069         void SetDetailColumns(const INT *detail_columns) { GetMyModel()->SetDetailColumns(detail_columns); }
00070
00071     protected:
00072         virtual Model* CreateModel() const;
00073
00074     private:
00075         PbDetailListBoxModel* GetMyModel() const { return (PbDetailListBoxModel *)GetModel(); }
00076 };
00077
00079 #endif  // Mmi_PbDetailListBox_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetails.cpp File Reference

Applications/AdvPhonebook/PbDetails.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbDetails.hpp"
#include "PbProvIds.hpp"
#include "PhonebookApp.hpp"
#include <Config/MmiGuiEngineConfig.hpp>
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for PbDetails.cpp:

Generated on Tue Jan 24 23:30:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetails.hpp File Reference

Applications/AdvPhonebook/PbDetails.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <AdvPhonebook/PbNameEditBox.hpp>
#include <AdvPhonebook/PbDetailListBox.hpp>
#include <AdvPhonebook/ProvListBoxWin.hpp>
#include <AdvPhonebook/PbAction.hpp>

Include dependency graph for PbDetails.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbDetailEditBox
class | PbDetails

Defines

#define | Mmi_PbDetails_hpp

Define Documentation

#define Mmi_PbDetails_hpp

Generated on Tue Jan 24 23:30:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbDetails.hpp Source File

Applications/AdvPhonebook/PbDetails.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbDetails_hpp)
00010 #define Mmi_PbDetails_hpp
00013
00014 #include <GuiExtensions/MmiWindow.hpp>
00015 #include <AdvPhonebook/PbNameEditBox.hpp>
00016 #include <AdvPhonebook/PbDetailListBox.hpp>
00017 #include <AdvPhonebook/ProvListBoxWin.hpp>
00018 #include <AdvPhonebook/PbAction.hpp>
00019
00020 class PbDetails;
00021 class PbDetailEditBox : public PbNameEditBox {
00022     typedef PbNameEditBox Base;
00023
00024     public:
00025         PbDetailEditBox();
00026         virtual ~PbDetailEditBox();
00027
00028     protected:
00029         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00030 };
00031
00032 class PbDetails : public ProvDetailListBoxWin {
00033     typedef ProvDetailListBoxWin Base;
00034
00035     public:
00036
00037         PbDetails();
00038         virtual ~PbDetails();
00039
00040         void Init(ProvListBoxWin *parent, const INT* detail_columns);
00041
00042         virtual void EditDetail();
00043         virtual void SaveEdit();
00044         virtual void CancelEdit() { CloseEditbox(); }
00045
00046         virtual Provider* GetMyPbProvider();
00047
00048     protected:
00049         // *************************************************
00050         // CN200006158 and CN200009448
00051         // Edited/Fixed by Christoph Minkwitz
00052         // virtual void Refresh(const Rect &rect);
00053         virtual void OnGetFocus();
00054
00055         virtual PbDetailProvider * GetDetailProvider() { return &m_detail_provider; }
00056
00057         virtual void GetUpdatedItem(INT colid, DataItem &item);
00058         virtual void DisplaySimPos();
00059
00060         void SwitchToEditboxMenu();
00061         void OpenEditBox();
00062         void CloseEditbox();
00063
00064         PbEditDetailAction      m_edit_detail_action;
00065
00066         PbDetailListBox *       m_detail_listbox;
00067         PbDetailEditBox         m_editbox;
00068
00069         PbConfirmEditAction     m_confirm_edit_action;
00070         PbCancelEditAction      m_cancel_editbox_action;
00071         virtual const WString       GetSavedText(INT colid);
00072
00073
00074     private:
00075         PbDetailProvider        m_detail_provider;
00076
00077         WString                 m_simpos_title;
00078         BOOLEAN                 m_is_open;
00079 };
00080
00082 #endif  // Mmi_PbDetails_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbFfsNameHandler.cpp File Reference

Applications/AdvPhonebook/PbFfsNameHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Devices/Device.hpp>
#include <Adc/RootFileSystem.hpp>
#include <Adc/StorageDevice.hpp>
#include <Config/Config.hpp>
#include "PbFfsNameHandler.hpp"

Include dependency graph for PbFfsNameHandler.cpp:

Generated on Tue Jan 24 23:30:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbFfsNameHandler.hpp File Reference

Applications/AdvPhonebook/PbFfsNameHandler.hpp File Reference

#include <AdvPhonebook/PbRecord.hpp>
#include <AdvPhonebook/PbRecordHandler.hpp>

Include dependency graph for PbFfsNameHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbFfsNameHandler

Defines

#define | Mmi_PbFfsNameHandler_hpp

Define Documentation

#define Mmi_PbFfsNameHandler_hpp

Generated on Tue Jan 24 23:30:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbFfsNameHandler.hpp Source File

Applications/AdvPhonebook/PbFfsNameHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbFfsNameHandler_hpp)
00010 #define Mmi_PbFfsNameHandler_hpp
00014
00015 #include <AdvPhonebook/PbRecord.hpp>
00016 #include <AdvPhonebook/PbRecordHandler.hpp>
00017
00020 class PbFfsNameHandler : public PbRecordHandler {
00021     typedef PbRecordHandler Base;
00022
00023     public:
00025         PbFfsNameHandler();
00026
00028         virtual ~PbFfsNameHandler();
00029
00032         virtual void Init();
00033
00036         virtual INT MaxRowCount();
00037
00038     protected:
00039         virtual RecordHandler* GetDataRecordHandler() { return &m_record_handler; }
00040         virtual Record* GetDataRecord() { return &m_rec; }
00041
00042     private:
00043         RecordHandler   m_record_handler;
00044         PbRecord        m_rec;
00045         PbRecord        m_delete_rec;
00046 };
00047
00049 #endif
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbFfsNumberHandler.cpp File Reference

Applications/AdvPhonebook/PbFfsNumberHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Adc/RootFileSystem.hpp>
#include <Adc/StorageDevice.hpp>
#include <Config/Config.hpp>
#include "PbFfsNumberHandler.hpp"

Include dependency graph for PbFfsNumberHandler.cpp:

Generated on Tue Jan 24 23:31:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbFfsNumberHandler.hpp File Reference

Applications/AdvPhonebook/PbFfsNumberHandler.hpp File Reference

#include <AdvPhonebook/PbRecord.hpp>
#include <AdvPhonebook/PbRecordHandler.hpp>

Include dependency graph for PbFfsNumberHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbFfsNumberHandler

Defines

#define | Mmi_PbFfsNumberHandler_hpp

Define Documentation

#define Mmi_PbFfsNumberHandler_hpp

Generated on Tue Jan 24 23:31:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbFfsNumberHandler.hpp Source File

Applications/AdvPhonebook/PbFfsNumberHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbFfsNumberHandler_hpp)
00010 #define Mmi_PbFfsNumberHandler_hpp
00014
00015 #include <AdvPhonebook/PbRecord.hpp>
00016 #include <AdvPhonebook/PbRecordHandler.hpp>
00017
00020 class PbFfsNumberHandler : public PbRecordHandler {
00021     typedef PbRecordHandler Base;
00022
00023     public:
00024
00026         PbFfsNumberHandler();
00027
00029         virtual ~PbFfsNumberHandler();
00030
00033         void Init();
00034
00037         virtual INT MaxRowCount();
00038
00039     protected:
00040
00041         virtual RecordHandler* GetDataRecordHandler();
00042
00043         virtual Record* GetDataRecord();
00044
00045     private:
00046         RecordHandler       m_record_handler;
00047         PbNumberRecord      m_rec;
00048         PbNumberRecord      m_delete_rec;
00049 };
00050
00052 #endif
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbLazySynchronizer.cpp File Reference

Applications/AdvPhonebook/PbLazySynchronizer.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbLazySynchronizer.hpp"

Include dependency graph for PbLazySynchronizer.cpp:

Generated on Tue Jan 24 23:31:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbLazySynchronizer.hpp File Reference

Applications/AdvPhonebook/PbLazySynchronizer.hpp File Reference

#include <AdvPhonebook/PbSynchronizer.hpp>

Include dependency graph for PbLazySynchronizer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbLazySynchronizer

Defines

#define | Mmi_PbLazySynchronizer_hpp

Define Documentation

#define Mmi_PbLazySynchronizer_hpp

Generated on Tue Jan 24 23:31:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbLazySynchronizer.hpp Source File

Applications/AdvPhonebook/PbLazySynchronizer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_PbLazySynchronizer_hpp)
00011 #define Mmi_PbLazySynchronizer_hpp
00014
00015 #include <AdvPhonebook/PbSynchronizer.hpp>
00016
00017 class PbLazySynchronizer : public PbSynchronizer {
00018     typedef PbSynchronizer Base;
00019
00020     public:
00021
00022         PbLazySynchronizer();
00023         virtual ~PbLazySynchronizer();
00024
00025         virtual BOOLEAN AutoSyncSim(INT phone_row);
00026         virtual BOOLEAN AutoSyncPhone(INT sim_row);
00027
00028         virtual BOOLEAN AutoDeleteSim(INT phone_row);
00029         virtual BOOLEAN AutoDeletePhone(INT sim_row);
00030
00031     protected:
00032         virtual BOOLEAN SyncSim(INT );
00033         virtual BOOLEAN SyncPhone(INT );
00034 };
00035
00037 #endif  // Mmi_PbLazySynchronizer_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbManualSynchronizer.cpp File Reference

Applications/AdvPhonebook/PbManualSynchronizer.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/FilterRule.hpp>
#include <Common/PhoneNumberMatchRule.hpp>
#include <AdvPhonebook/PbDetailFilterProvider.hpp>
#include <AdvPhonebook/PbProvIds.hpp>
#include <AdvPhonebook/PhonebookApp.hpp>
#include "PbManualSynchronizer.hpp"

Include dependency graph for PbManualSynchronizer.cpp:

Generated on Tue Jan 24 23:31:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbManualSynchronizer.hpp File Reference

Applications/AdvPhonebook/PbManualSynchronizer.hpp File Reference

#include <AdvPhonebook/PbLazySynchronizer.hpp>

Include dependency graph for PbManualSynchronizer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbManualSynchronizer

Defines

#define | Mmi_PbManualSynchronizer_hpp

Define Documentation

#define Mmi_PbManualSynchronizer_hpp

Generated on Tue Jan 24 23:31:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbManualSynchronizer.hpp Source File

Applications/AdvPhonebook/PbManualSynchronizer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_PbManualSynchronizer_hpp)
00011 #define Mmi_PbManualSynchronizer_hpp
00014
00015 #include <AdvPhonebook/PbLazySynchronizer.hpp>
00016
00017 class PhonebookApp;
00018
00019 class PbManualSynchronizer : public PbLazySynchronizer {
00020     typedef PbLazySynchronizer Base;
00021
00022     public:
00023
00024         PbManualSynchronizer();
00025         virtual ~PbManualSynchronizer();
00026
00027         void Init(PhonebookApp *app, Provider *pb_prov, Provider *sim_prov);
00028
00029         virtual void Update();
00030
00031     protected:
00032
00033         virtual BOOLEAN SyncSim(INT no_row);
00034         virtual BOOLEAN SyncPhone(INT no_row);
00035
00036         BOOLEAN AddPbEntry(const DataItem &name, const DataItem &phoneno, const DataItem &sim_pos);
00037         BOOLEAN AddSimEntry(const DataItem &name, const DataItem &phoneno);
00038         BOOLEAN AddNumber(INT name_row, const DataItem &phoneno, const DataItem &simpos);
00039         BOOLEAN UpdateItem(Provider *prov, INT row, const DataItem &item, INT column_id);
00040
00041         BOOLEAN EqualName(INT pb_no_row, INT sim_row);
00042         BOOLEAN EqualNumber(INT sim_row, INT pb_row);
00043
00044         INT GetProvRow(Provider *prov, const DataItem &item, INT column_id) const;
00045         INT FindRow(Provider *prov, const DataItem &name, const DataItem &phoneno) const;
00046
00047         BOOLEAN DoAddNumber(INT name_row);
00048
00049         BOOLEAN AlphaTagSizeError(const WString &str);
00050         void ShrinkString(WString &str);
00051         void GetUniqueString(WString &str);
00052
00053 //      IndexTable<INT>* GetSimPosTable() { return &m_simpos_table; }
00054
00055     private:
00056         BOOLEAN ExistName(const WString &name_str);
00057         void IncreaseSimposTable(INT row);
00058
00059         PhonebookApp* m_app;
00060         QuickSortProvider m_sort_simpos_prov;
00061         IndexTable<INT>  m_simpos_table;
00062 };
00063
00065 #endif  // Mmi_PbManualSynchronizer_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbMergeProvider.cpp File Reference

Applications/AdvPhonebook/PbMergeProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <AdvPhonebook/PbDetailFilterProvider.hpp>
#include <AdvPhonebook/PbProviderListener.hpp>
#include <AdvPhonebook/AdvPbMsgTypes.hpp>
#include <AdvPhonebook/AdvPbApp.hpp>
#include "PbNameProvider.hpp"
#include "PbNumberProvider.hpp"
#include "PbMergeProvider.hpp"

Include dependency graph for PbMergeProvider.cpp:

Generated on Tue Jan 24 23:32:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbMergeProvider.hpp File Reference

Applications/AdvPhonebook/PbMergeProvider.hpp File Reference

#include <AddOns/AuxExtensions/MergeProvider.hpp>
#include <AddOns/AuxExtensions/JoinRule.hpp>
#include <AdvPhonebook/PbNextFreeIdRecord.hpp>
#include <Phonebook/PbProvIds.hpp>
#include <Config/Config.hpp>

Include dependency graph for PbMergeProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbMergeProvider

Defines

#define | Mmi_PbMergeProvider_hpp

Variables

const UINT32 | c_max_unique_id = 0xFFFFFFFF

Define Documentation

#define Mmi_PbMergeProvider_hpp

Generated on Tue Jan 24 23:32:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbMergeProvider.hpp Source File

Applications/AdvPhonebook/PbMergeProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PbMergeProvider_hpp)
00015 #define Mmi_PbMergeProvider_hpp
00019
00020 #include <AddOns/AuxExtensions/MergeProvider.hpp>
00021 #include <AddOns/AuxExtensions/JoinRule.hpp>
00022 //CN200013749
00023 #include <AdvPhonebook/PbNextFreeIdRecord.hpp>
00024 //END CN200013749
00025
00026 #include <Phonebook/PbProvIds.hpp>
00027 #include <Config/Config.hpp>
00028
00029 /*------------------------------------------------------------------
00030                             PbMergeProvider
00031  ------------------------------------------------------------------*/
00032 //CN200013749
00033 const UINT32 c_max_unique_id = 0xFFFFFFFF;
00034 //END CN200013749
00035 class PbNameProvider;
00036 class PbNumberProvider;
00037 class PbMergeProvider : public MergeProvider {
00038     typedef MergeProvider Base;
00039
00040     public:
00041
00042         PbMergeProvider();
00043         virtual ~PbMergeProvider();
00044
00045         void Init(PbNameProvider* name_prov, PbNumberProvider* no_prov);
00046
00047         virtual BOOLEAN GetDefaultDataItem(INT columnid, INT row, DataItem & item);
00048
00049         virtual BOOLEAN AppendRow();
00050         virtual BOOLEAN DeleteRow(INT row);
00051         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00052         virtual BOOLEAN Update(ProviderListener *listener = 0);
00053
00054         virtual BOOLEAN SetParameter(const DataItem &item);
00055
00056         virtual INT MaxRowCount();
00057
00058 //CN200013749
00061         UINT32 GetLastDeletedUniqueId(){return m_last_deleted_unique_id;}
00062 //END CN200013749
00063     private:
00064         BOOLEAN     PbPerformMerge(ProviderListener *listener);
00065         Provider*           m_name_prov;
00066         Provider*           m_no_prov;
00067         BOOLEAN             m_both_affected;
00068         StandardJoinRule    m_join_rule;
00069
00070         INT                 m_rollback_row;
00071 //CN200013749
00072         PbNextFreeIdRecord  m_next_free_id_record;
00073         UINT32 m_last_deleted_unique_id;
00074         //RecordHandler instance is used to access data stroed on FFS.
00075         RecordHandler       m_handler;
00076         //Renumbers the unique ids in Number Provider
00077         void  RenumberUniqueIds();
00078 //END CN200013749
00079 };
00080
00082 #endif
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameEditBox.cpp File Reference

Applications/AdvPhonebook/PbNameEditBox.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/AlphaCoding.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include "PbNameEditBox.hpp"

Include dependency graph for PbNameEditBox.cpp:

Generated on Tue Jan 24 23:32:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameEditBox.hpp File Reference

Applications/AdvPhonebook/PbNameEditBox.hpp File Reference

#include <Gui/LineEditor.hpp>

Include dependency graph for PbNameEditBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNameEditBox

Defines

#define | Mmi_PbNameEditBox_hpp

Define Documentation

#define Mmi_PbNameEditBox_hpp

Generated on Tue Jan 24 23:32:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameEditBox.hpp Source File

Applications/AdvPhonebook/PbNameEditBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbNameEditBox_hpp)
00010 #define Mmi_PbNameEditBox_hpp
00013
00014 #include <Gui/LineEditor.hpp>
00015
00017 class PbNameEditBox : public LineEditor {
00018     typedef LineEditor Base;
00019
00020     public:
00021         PbNameEditBox();
00022         virtual ~PbNameEditBox();
00023
00025         void Init(Control* parent);
00026
00028         void SetMaxAlphaTagSize(INT max_ats) { m_max_ats = max_ats; }
00029
00030     protected:
00032         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00033
00034     private:
00036         INT m_max_ats;
00037         INT m_old_key;
00038 };
00039
00041 #endif  // Mmi_PbNameEditBox_hpp
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameFilterProvider.cpp File Reference

Applications/AdvPhonebook/PbNameFilterProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbNameFilterProvider.hpp"

Include dependency graph for PbNameFilterProvider.cpp:

Generated on Tue Jan 24 23:32:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameFilterProvider.hpp File Reference

Applications/AdvPhonebook/PbNameFilterProvider.hpp File Reference

#include <Auxiliary/FilterProvider.hpp>
#include <Config/Config.hpp>

Include dependency graph for PbNameFilterProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNameFilterProvider

Defines

#define | Mmi_PbNameFilterProvider_hpp

Define Documentation

#define Mmi_PbNameFilterProvider_hpp

Generated on Tue Jan 24 23:32:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameFilterProvider.hpp Source File

Applications/AdvPhonebook/PbNameFilterProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbNameFilterProvider_hpp)
00009 #define Mmi_PbNameFilterProvider_hpp
00012
00013 #include <Auxiliary/FilterProvider.hpp>
00014 #include <Config/Config.hpp>
00015
00016 class PbNameFilterProvider : public FilterProvider {
00017     public:
00018         typedef FilterProvider Base;
00019
00020         PbNameFilterProvider();
00021         PbNameFilterProvider(Provider * provider,
00022                              FilterRule * rule,
00023                              INT columnid = 0,
00024                              BOOLEAN negation = FALSE);
00025
00026         virtual ~PbNameFilterProvider();
00027
00028         virtual INT GetProviderId() const;
00029
00030         virtual Status GetStatus() const;
00031
00032         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00033
00034         virtual BOOLEAN SetParameter(const DataItem &item);
00035
00036         virtual BOOLEAN Update(ProviderListener *listener);
00037
00038     private:
00039         PhoneNumber m_phoneno;
00040         BOOLEAN     m_new_param;
00041 };
00042
00044 #endif
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameHandler.cpp File Reference

Applications/AdvPhonebook/PbNameHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include "PbNameHandler.hpp"

Include dependency graph for PbNameHandler.cpp:

Generated on Tue Jan 24 23:33:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameHandler.hpp File Reference

Applications/AdvPhonebook/PbNameHandler.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <AddOns/AdcExtensions/DataRecordHandler.hpp>
#include <AdvPhonebook/PbRecord.hpp>
#include <AdvPhonebook/PbRecordHandler.hpp>

Include dependency graph for PbNameHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNameHandler

Defines

#define | Mmi_PbNameHandler_hpp

Define Documentation

#define Mmi_PbNameHandler_hpp

Generated on Tue Jan 24 23:33:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameHandler.hpp Source File

Applications/AdvPhonebook/PbNameHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbNameHandler_hpp)
00010 #define Mmi_PbNameHandler_hpp
00011
00012 #include <Auxiliary/WString.hpp>
00013 #include <Auxiliary/PhoneNumber.hpp>
00014 #include <AddOns/AdcExtensions/DataRecordHandler.hpp>
00015 #include <AdvPhonebook/PbRecord.hpp>
00016 #include <AdvPhonebook/PbRecordHandler.hpp>
00017
00018 class PbNameHandler : public PbRecordHandler {
00019     typedef PbRecordHandler Base;
00020
00021     public:
00022         PbNameHandler();
00023         virtual ~PbNameHandler();
00024
00025         virtual void Init();
00026
00027     protected:
00028         virtual DataRecordHandler* GetDataRecordHandler() { return &m_record_handler; }
00029         virtual DataRecord* GetDataRecord() { return &m_rec; }
00030
00031     private:
00032         void InitFile();
00033         FfsDataRecordHandler    m_record_handler;
00034         PbRecord                m_rec;
00035 };
00036
00037
00038 #endif
Generated on Tue Jan 24 14:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameNumberProvider.cpp File Reference

Applications/AdvPhonebook/PbNameNumberProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbProvIds.hpp"
#include "PbNameNumberProvider.hpp"

Include dependency graph for PbNameNumberProvider.cpp:

Generated on Tue Jan 24 23:33:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameNumberProvider.hpp File Reference

Applications/AdvPhonebook/PbNameNumberProvider.hpp File Reference

#include <Auxiliary/AbstractDelegationProvider.hpp>
#include <Config/Config.hpp>

Include dependency graph for PbNameNumberProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNameNumberProvider

Defines

#define | Mmi_PbNameNumberProvider_hpp

Define Documentation

#define Mmi_PbNameNumberProvider_hpp

Generated on Tue Jan 24 23:33:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameNumberProvider.hpp Source File

Applications/AdvPhonebook/PbNameNumberProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PbNameNumberProvider_hpp)
00015 #define Mmi_PbNameNumberProvider_hpp
00018
00019 #include <Auxiliary/AbstractDelegationProvider.hpp>
00020 #include <Config/Config.hpp>
00021
00023
00024 class PbNameNumberProvider : public AbstractDelegationProvider
00025 {
00026     public:
00027         typedef AbstractDelegationProvider Base;
00028
00029         PbNameNumberProvider();
00030         PbNameNumberProvider(Provider *provider);
00031         virtual ~PbNameNumberProvider();
00032
00033         void Init(Provider *provider);
00034
00035         virtual INT GetProviderId() const;
00036
00037         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem &item);
00038
00039         virtual BOOLEAN GetChildRow(INT & child_row, INT row);
00040
00041     private:
00042         Provider *   m_prov;
00043 };
00044
00046 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameProvider.cpp File Reference

Applications/AdvPhonebook/PbNameProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <AdvPhonebook/PbProvIds.hpp>
#include "PbNameProvider.hpp"
#include "PbRecordHandler.hpp"

Include dependency graph for PbNameProvider.cpp:

Generated on Tue Jan 24 23:33:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameProvider.hpp File Reference

Applications/AdvPhonebook/PbNameProvider.hpp File Reference

#include <AdvPhonebook/PbRecord.hpp>
#include <AdvPhonebook/PbRecordProvider.hpp>
#include <Config/Config.hpp>

Include dependency graph for PbNameProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNameProvider

Defines

#define | Mmi_PbNameProvider_hpp

Define Documentation

#define Mmi_PbNameProvider_hpp

Generated on Tue Jan 24 23:33:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNameProvider.hpp Source File

Applications/AdvPhonebook/PbNameProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PbNameProvider_hpp)
00015 #define Mmi_PbNameProvider_hpp
00019
00020 #include <AdvPhonebook/PbRecord.hpp>
00021 #include <AdvPhonebook/PbRecordProvider.hpp>
00022 #include <Config/Config.hpp>
00023
00026 class PbNameProvider : public PbRecordProvider {
00027
00028     public:
00029         typedef PbRecordProvider Base;
00030
00032         PbNameProvider();
00033
00038         PbNameProvider(Protector *protector, PbRecordHandler *name_handler);
00039
00041         virtual ~PbNameProvider();
00042
00048         void Init(Protector *protector, PbRecordHandler *name_handler);
00049
00052         virtual INT GetProviderId() const;
00053
00060         virtual BOOLEAN GetDataItem(IN INT columnid,
00061                                     IN INT row,
00062                                     OUT DataItem & item);
00063
00069         virtual BOOLEAN SetDataItem(IN const DataItem & item,
00070                                     IN INT columnid);
00071
00075         virtual BOOLEAN DeleteRow(INT row);
00076
00079         virtual BOOLEAN AppendRow();
00080
00083         virtual BOOLEAN DeleteAllRows(ProviderListener *listener = 0);
00084
00089         virtual BOOLEAN Update(ProviderListener *listener = 0);
00090
00091         /*Gets a corresponding Name row for the given record Number*/
00092         INT GetNameRowForRecNo(Number record_number);
00093
00094     protected:
00095         virtual Record* GetDataRecord();
00096         virtual void InitRecord();
00097
00098     private:
00099         void DeleteNoRows(INT row);
00100         INT GetDefaultNoRow(INT row);
00101
00102         PbRecord            m_pb_record;
00103         Provider *          m_grp_prov;
00104
00105         INT                 m_icc_id;
00106 };
00107
00109 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNextFreeIdRecord.cpp File Reference

Applications/AdvPhonebook/PbNextFreeIdRecord.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbNextFreeIdRecord.hpp"

Include dependency graph for PbNextFreeIdRecord.cpp:

Generated on Tue Jan 24 23:34:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNextFreeIdRecord.hpp File Reference

Applications/AdvPhonebook/PbNextFreeIdRecord.hpp File Reference

#include <AddOns/AdcExtensions/Record.hpp>

Include dependency graph for PbNextFreeIdRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNextFreeIdRecord
struct | PbNextFreeIdRecord::Persist

Defines

#define | Mmi_PbNextFreeIdRecord_hpp

Define Documentation

#define Mmi_PbNextFreeIdRecord_hpp

Generated on Tue Jan 24 23:34:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNextFreeIdRecord.hpp Source File

Applications/AdvPhonebook/PbNextFreeIdRecord.hpp

Go to the documentation of this file.
00001 /*------------------------------------------------------------------------
00002 Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003 All rights reserved.
00004 ------------------------------------------------------------------------
00005 This document contains proprietary information belonging to COMNEON.
00006 Passing on and copying of this document, use and communication of its
00007 contents is not permitted without prior written authorisation.
00008 ------------------------------------------------------------------------ */
00009 #if !defined(Mmi_PbNextFreeIdRecord_hpp)
00010 #define Mmi_PbNextFreeIdRecord_hpp
00014
00015 // Included header file for the super class.
00016 #include <AddOns/AdcExtensions/Record.hpp>
00017
00021 class PbNextFreeIdRecord : public Record
00022 {
00023     public:
00024
00027         PbNextFreeIdRecord();
00028
00031         virtual const UINT8* GetData();
00032
00036         virtual void SetData(const UINT8* data);
00037
00040         virtual INT GetPersistentSize();
00041
00045         void    SetNextFreeUniqueId(UINT32 next_free_unique_id){
00046             m_data.m_next_free_unique_id = next_free_unique_id;}
00047
00050         UINT32 GetNextFreeUniqueId(){return m_data.m_next_free_unique_id;}
00051     private:
00052
00053         struct Persist{
00054             UINT32                  m_next_free_unique_id;
00055         }m_data;
00056 };
00058 #endif //Mmi_PbNextFreeIdRecord_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNumberHandler.cpp File Reference

Applications/AdvPhonebook/PbNumberHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include "PbNumberHandler.hpp"
#include "PbNameProvider.hpp"

Include dependency graph for PbNumberHandler.cpp:

Generated on Tue Jan 24 23:34:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNumberHandler.hpp File Reference

Applications/AdvPhonebook/PbNumberHandler.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <AddOns/AdcExtensions/FfsDataRecordHandler.hpp>
#include <AdvPhonebook/PbRecord.hpp>
#include <AdvPhonebook/PbRecordHandler.hpp>

Include dependency graph for PbNumberHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNumberHandler

Defines

#define | Mmi_PbNumberHandler_hpp

Define Documentation

#define Mmi_PbNumberHandler_hpp

Generated on Tue Jan 24 23:34:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNumberHandler.hpp Source File

Applications/AdvPhonebook/PbNumberHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbNumberHandler_hpp)
00010 #define Mmi_PbNumberHandler_hpp
00011
00012 #include <Auxiliary/WString.hpp>
00013 #include <Auxiliary/PhoneNumber.hpp>
00014 #include <AddOns/AdcExtensions/FfsDataRecordHandler.hpp>
00015 #include <AdvPhonebook/PbRecord.hpp>
00016 #include <AdvPhonebook/PbRecordHandler.hpp>
00017
00018
00019 class PbNameProvider;
00020 class PbNumberHandler : public PbRecordHandler {
00021     typedef PbRecordHandler Base;
00022
00023     public:
00024
00025         PbNumberHandler();
00026         PbNumberHandler(DataRecordHandler * record_handler);
00027         virtual ~PbNumberHandler();
00028
00029         //tmp
00030         void InitFile(PbNameProvider* name_prov);
00031
00032     protected:
00033         virtual DataRecord* GetDataRecord() { return &m_rec; }
00034         virtual DataRecordHandler* GetDataRecordHandler() { return &m_record_handler; }
00035
00036     private:
00037         FfsDataRecordHandler    m_record_handler;
00038         PbNumberRecord          m_rec;
00039
00040
00041 };
00042
00043
00044 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNumberProvider.cpp File Reference

Applications/AdvPhonebook/PbNumberProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include <AdvPhonebook/PbProvIds.hpp>
#include "PbRecordHandler.hpp"
#include "PbNumberProvider.hpp"

Include dependency graph for PbNumberProvider.cpp:

Generated on Tue Jan 24 23:34:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNumberProvider.hpp File Reference

Applications/AdvPhonebook/PbNumberProvider.hpp File Reference

#include <AdvPhonebook/PbRecord.hpp>
#include <AdvPhonebook/PbRecordProvider.hpp>
#include <Config/Config.hpp>

Include dependency graph for PbNumberProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNumberProvider

Defines

#define | Mmi_PbNumberProvider_hpp

Define Documentation

#define Mmi_PbNumberProvider_hpp

Generated on Tue Jan 24 23:34:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNumberProvider.hpp Source File

Applications/AdvPhonebook/PbNumberProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PbNumberProvider_hpp)
00015 #define Mmi_PbNumberProvider_hpp
00019
00020 #include <AdvPhonebook/PbRecord.hpp>
00021 #include <AdvPhonebook/PbRecordProvider.hpp>
00022 #include <Config/Config.hpp>
00023
00027 class PbNumberProvider : public PbRecordProvider {
00028
00029     public:
00030         typedef PbRecordProvider Base;
00031
00033         PbNumberProvider();
00034
00039         PbNumberProvider(Protector *protector, PbRecordHandler *no_handler);
00040
00042         virtual ~PbNumberProvider();
00043
00049         void Init(Protector *protector, PbRecordHandler *m_handler);
00050
00053         virtual INT GetProviderId() const;
00054
00061         virtual BOOLEAN GetDataItem(IN INT columnid,
00062                                     IN INT row,
00063                                     OUT DataItem & item);
00064
00070         virtual BOOLEAN SetDataItem(IN const DataItem & item,
00071                                     IN INT columnid);
00072
00075         virtual BOOLEAN AppendRow();
00076
00080         virtual BOOLEAN DeleteRow(INT row);
00081
00084         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00085
00089         virtual BOOLEAN Update(ProviderListener *listener = 0);
00090
00091     protected:
00092         virtual Record* GetDataRecord();
00093         virtual void InitRecord();
00094
00095     private:
00096         BOOLEAN UpdNumberIds(const DataItem &key_item, UINT8 no_id, BOOLEAN increase);
00097
00098         PbNumberRecord  m_no_record;
00099 };
00100
00102 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNvRamNameHandler.cpp File Reference

Applications/AdvPhonebook/PbNvRamNameHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbNvRamNameHandler.hpp"

Include dependency graph for PbNvRamNameHandler.cpp:

Generated on Tue Jan 24 23:34:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNvRamNameHandler.hpp File Reference

Applications/AdvPhonebook/PbNvRamNameHandler.hpp File Reference

#include <AddOns/AdcExtensions/NvRamDataRecordHandler.hpp>
#include <AdvPhonebook/PbRecord.hpp>
#include <AdvPhonebook/PbRecordHandler.hpp>

Include dependency graph for PbNvRamNameHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNvRamNameHandler

Defines

#define | Mmi_PbNvRamNameHandler_hpp

Define Documentation

#define Mmi_PbNvRamNameHandler_hpp

Generated on Tue Jan 24 23:34:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNvRamNameHandler.hpp Source File

Applications/AdvPhonebook/PbNvRamNameHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbNvRamNameHandler_hpp)
00010 #define Mmi_PbNvRamNameHandler_hpp
00011
00012 #include <AddOns/AdcExtensions/NvRamDataRecordHandler.hpp>
00013 #include <AdvPhonebook/PbRecord.hpp>
00014 #include <AdvPhonebook/PbRecordHandler.hpp>
00015
00016 class PbNvRamNameHandler : public PbRecordHandler {
00017     typedef PbRecordHandler Base;
00018
00019     public:
00020         PbNvRamNameHandler();
00021         virtual ~PbNvRamNameHandler();
00022
00023         virtual void Init();
00024
00025         virtual INT MaxRowCount() { return c_max_pb_name_entries; }
00026
00027     protected:
00028         virtual DataRecordHandler* GetDataRecordHandler() { return &m_record_handler; }
00029         virtual DataRecord* GetDataRecord() { return &m_rec; }
00030
00031     private:
00032         NvRamDataRecordHandler  m_record_handler;
00033         PbRecord                m_rec;
00034 };
00035
00036
00037 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNvRamNumberHandler.cpp File Reference

Applications/AdvPhonebook/PbNvRamNumberHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include "PbNvRamNumberHandler.hpp"

Include dependency graph for PbNvRamNumberHandler.cpp:

Generated on Tue Jan 24 23:35:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNvRamNumberHandler.hpp File Reference

Applications/AdvPhonebook/PbNvRamNumberHandler.hpp File Reference

#include <AddOns/AdcExtensions/NvRamDataRecordHandler.hpp>
#include <AdvPhonebook/PbRecord.hpp>
#include <AdvPhonebook/PbRecordHandler.hpp>

Include dependency graph for PbNvRamNumberHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNvRamNumberHandler

Defines

#define | Mmi_PbNvRamNumberHandler_hpp

Define Documentation

#define Mmi_PbNvRamNumberHandler_hpp

Generated on Tue Jan 24 23:35:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbNvRamNumberHandler.hpp Source File

Applications/AdvPhonebook/PbNvRamNumberHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbNvRamNumberHandler_hpp)
00010 #define Mmi_PbNvRamNumberHandler_hpp
00011
00012 #include <AddOns/AdcExtensions/NvRamDataRecordHandler.hpp>
00013 #include <AdvPhonebook/PbRecord.hpp>
00014 #include <AdvPhonebook/PbRecordHandler.hpp>
00015
00016 class PbNvRamNumberHandler : public PbRecordHandler {
00017     typedef PbRecordHandler Base;
00018
00019     public:
00020
00021         PbNvRamNumberHandler();
00022         PbNvRamNumberHandler(DataRecordHandler * record_handler);
00023         virtual ~PbNvRamNumberHandler();
00024
00025         void Init();
00026
00027         virtual INT MaxRowCount() { return c_max_pb_number_entries; }
00028
00029     protected:
00030         virtual DataRecordHandler* GetDataRecordHandler() { return &m_record_handler; }
00031         virtual DataRecord* GetDataRecord() { return &m_rec; }
00032
00033     private:
00034         NvRamDataRecordHandler  m_record_handler;
00035         PbNumberRecord          m_rec;
00036
00037
00038 };
00039
00040
00041 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbPhoneNumberPrompt.cpp File Reference

Applications/AdvPhonebook/PbPhoneNumberPrompt.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PhonebookApp.hpp"
#include "PbPhoneNumberPrompt.hpp"
#include <GuiExtensions/MmiDialog.hpp>

Include dependency graph for PbPhoneNumberPrompt.cpp:

Generated on Tue Jan 24 23:35:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp File Reference

Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp File Reference

#include <GuiExtensions/MmiPhoneNumberPrompt.hpp>

Include dependency graph for PbPhoneNumberPrompt.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbPhoneNumberPrompt
class | SaveNoAction

Defines

#define | Mmi_PbPhoneNumberPrompt_hpp

Define Documentation

#define Mmi_PbPhoneNumberPrompt_hpp

Generated on Tue Jan 24 23:35:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp Source File

Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbPhoneNumberPrompt_hpp)
00010 #define Mmi_PbPhoneNumberPrompt_hpp
00013
00014 #include <GuiExtensions/MmiPhoneNumberPrompt.hpp>
00015
00016 class PbPhoneNumberPrompt;
00017 class SaveNoAction : public Action {
00018     typedef Action Base;
00019
00020     public:
00021         SaveNoAction(PbPhoneNumberPrompt *win);
00022         virtual ~SaveNoAction();
00023
00024         BOOLEAN Execute();
00025
00026     private:
00027         PbPhoneNumberPrompt *m_parent;
00028 };
00029
00030 class PbPhoneNumberPrompt : public MmiPhoneNumberPrompt {
00031     typedef MmiPhoneNumberPrompt Base;
00032
00033     public:
00034
00035         PbPhoneNumberPrompt();
00036         virtual ~PbPhoneNumberPrompt();
00037
00038         //
00039         void Init();
00040
00041         //
00042         void SavePhoneNo();
00043
00044     protected:
00045         virtual void OnOpen();
00046
00047     private:
00048         SaveNoAction        m_save_no_action;
00049
00050 };
00051
00053 #endif  // Mmi_PbPhoneNumberPrompt_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbProviderListener.cpp File Reference

Applications/AdvPhonebook/PbProviderListener.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbProviderListener.hpp"

Include dependency graph for PbProviderListener.cpp:

Generated on Tue Jan 24 23:35:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbProviderListener.hpp File Reference

Applications/AdvPhonebook/PbProviderListener.hpp File Reference

#include <Auxiliary/ProviderListener.hpp>

Include dependency graph for PbProviderListener.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbProviderListener

Defines

#define | Mmi_PbProvider_hpp

Define Documentation

#define Mmi_PbProvider_hpp

Generated on Tue Jan 24 23:35:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbProviderListener.hpp Source File

Applications/AdvPhonebook/PbProviderListener.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PbProvider_hpp)
00015 #define Mmi_PbProvider_hpp
00018
00019 #include <Auxiliary/ProviderListener.hpp>
00020
00021 /*------------------------------------------------------------------
00022                             PbProviderListener
00023  ------------------------------------------------------------------*/
00024 class PbProviderListener : public ProviderListener {
00025     public:
00026         PbProviderListener(ProviderListener * child_listener);
00027
00028         virtual ~PbProviderListener();
00029
00030         virtual void OnStarted(Provider *prov);
00031         virtual void OnExecuting();
00032
00033         void SetChildListener(ProviderListener* listener) { m_child_listener = listener; }
00034
00035 private:
00036         ProviderListener * m_child_listener;
00037
00038 };
00039
00041 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbProvIds.hpp File Reference

Applications/AdvPhonebook/PbProvIds.hpp File Reference

#include <Adc/ProvIds.hpp>

Include dependency graph for PbProvIds.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Mmi_PbProvIds_hpp

Variables

const INT | c_email_id = 2205
const INT | c_grp_prov_id = 2204
const INT | c_icc_id_id = 2206
const INT | c_last_deleted_unique_id = 2216
const INT | c_name_key_id = 2201
const INT | c_name_prov_id = 2214
const INT | c_new_recno_id = 2202
const INT | c_no_id_id = 2210
const INT | c_no_prov_id = 2203
const INT | c_on_sim_id = 2213
const INT | c_phoneno_type_id = 2211
const INT | c_recno_id = 2200
const INT | c_sim_recno_id = 2212
const INT | c_unique_id = 2215

Define Documentation

#define Mmi_PbProvIds_hpp

Generated on Tue Jan 24 23:35:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbProvIds.hpp Source File

Applications/AdvPhonebook/PbProvIds.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Mmi_PbProvIds_hpp)
00015 #define Mmi_PbProvIds_hpp
00018
00019 #include <Adc/ProvIds.hpp>
00020
00021 const INT c_recno_id        = 2200;
00022 const INT c_name_key_id     = 2201;
00023 const INT c_new_recno_id    = 2202;
00024
00025 /*------------------------------------------------------------------
00026                             PbNameProvider Columns
00027  ------------------------------------------------------------------*/
00028
00029 const INT c_no_prov_id      = 2203;
00030 const INT c_grp_prov_id     = 2204;
00031 const INT c_email_id        = 2205;
00032 const INT c_icc_id_id       = 2206;
00033
00034 /*------------------------------------------------------------------
00035                             PbNumberProvider Columns
00036  ------------------------------------------------------------------*/
00037
00038 const INT c_no_id_id            = 2210;
00039 const INT c_phoneno_type_id     = 2211;
00040 const INT c_sim_recno_id        = 2212;
00041 const INT c_on_sim_id           = 2213;
00042 const INT c_name_prov_id        = 2214;
00043 const INT c_unique_id           = 2215;
00044 const INT c_last_deleted_unique_id  = 2216;
00046 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbProvListBox.cpp File Reference

Applications/AdvPhonebook/PbProvListBox.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PhonebookApp.hpp"
#include <Kernel/Os/TestWriter.hpp>
#include "PbConfig.hpp"
#include "PbProvIds.hpp"
#include "ProvListBoxWin.hpp"
#include "PbProvListBox.hpp"
#include <Config/MmiGuiEngineConfig.hpp>

Include dependency graph for PbProvListBox.cpp:

Generated on Tue Jan 24 23:36:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbProvListBox.hpp File Reference

Applications/AdvPhonebook/PbProvListBox.hpp File Reference

#include <Auxiliary/SortProvider.hpp>
#include <GuiExtensions/LabelListBoxModel.hpp>
#include <AdvPhonebook/PbTypes.hpp>

Include dependency graph for PbProvListBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbProvColListBox
class | PbProvColListBoxModel
class | PbProvListBox
class | PbProvListBoxModel

Defines

#define | Mmi_PbProvListBox_hpp

Define Documentation

#define Mmi_PbProvListBox_hpp

Generated on Tue Jan 24 23:36:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbProvListBox.hpp Source File

Applications/AdvPhonebook/PbProvListBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbProvListBox_hpp)
00010 #define Mmi_PbProvListBox_hpp
00013
00014 #include <Auxiliary/SortProvider.hpp>
00015 #include <GuiExtensions/LabelListBoxModel.hpp>
00016 #include <AdvPhonebook/PbTypes.hpp>
00017
00018 class PhonebookApp;
00019 class PbProvider;
00020
00021 class PbProvListBoxModel : public LabelListBoxModel {
00022     typedef LabelListBoxModel Base;
00023
00024     public:
00025         PbProvListBoxModel();
00026         PbProvListBoxModel(DrawableObjectListBox *listbox);
00027         virtual ~PbProvListBoxModel();
00028
00029         virtual const WCHAR* GetCellText(INT index, BOOLEAN highlighted);
00030         virtual const BitmapRes* GetCellIcon(INT index, BOOLEAN highlighted);
00031
00032         virtual void UpdateNoOfItems();
00033
00034         virtual void SetProvider(Provider *provider);
00035         virtual Provider* GetProvider();
00036
00037         virtual void SetSelectedRow(INT recno);
00038
00039         virtual INT GetSelectedProvRow();
00040         virtual INT GetSelectedColumnId();
00041
00042         const WCHAR* GetProvText(INT index);
00043
00044     protected:
00045         virtual INT GetRow(INT index);
00046         virtual INT GetColumnId(INT index) = 0;
00047         virtual INT GetProvRow(INT index);
00048
00049     private:
00050         Provider    *m_provider;
00051         WString     m_text;
00052
00053 };
00054
00055 class PbProvColListBoxModel : public PbProvListBoxModel {
00056     typedef PbProvListBoxModel Base;
00057
00058     public:
00059         PbProvColListBoxModel();
00060         PbProvColListBoxModel(DrawableObjectListBox *listbox, INT colid, INT sort_colid);
00061         virtual ~PbProvColListBoxModel();
00062
00063         void Init(DrawableObjectListBox *listbox, INT colid, INT sort_colid);
00064
00065         virtual const BitmapRes* GetCellIcon(INT index, BOOLEAN highlighted);
00066
00067         void SetColumnId(INT colid) { m_column_id = colid; }
00068
00069 //      virtual void SetSelectedRow(INT row);
00070
00071 //      virtual void SetProvider(Provider *provider);
00072 //      virtual Provider* GetProvider() { return &m_sort_provider; }
00073
00074     protected:
00075         virtual INT GetColumnId(INT index) { return m_column_id; }
00076 //      virtual INT GetProvRow(INT index);
00077
00078     private:
00079         INT                 m_column_id;
00080         INT                 m_sort_column_id;
00081 //      QuickSortProvider   m_sort_provider;
00082 };
00083
00084 class ProvListBoxWin;
00085 class PbProvListBox : public DrawableObjectListBox {
00086     typedef DrawableObjectListBox Base;
00087
00088     public:
00089
00090         PbProvListBox();
00091         PbProvListBox(ProvListBoxWin *parent);
00092         virtual ~PbProvListBox();
00093
00094         void Init(ProvListBoxWin *parent);
00095
00096         Provider* GetProvider() { return GetMyModel()->GetProvider(); }
00097         void SetProvider(Provider *provider) { GetMyModel()->SetProvider(provider); }
00098
00099         virtual void Update(INT item_count = -1);
00100
00101         void SetSelectedRow(INT row);
00102         INT GetSelectedRow() const { return GetMyModel()->GetSelectedProvRow(); };
00103
00104         INT GetSelectedColumnId() const { return GetMyModel()->GetSelectedColumnId(); };
00105
00106     protected:
00107         virtual void OnSelectionChanged();
00108         ProvListBoxWin * GetParent() { return m_parent; }
00109
00110     private:
00111         PbProvListBoxModel* GetMyModel() const { return (PbProvListBoxModel *)GetModel(); }
00112         ProvListBoxWin *    m_parent;
00113 };
00114
00115 class PbProvColListBox : public PbProvListBox {
00116     typedef PbProvListBox Base;
00117
00118     public:
00119         void Init(ProvListBoxWin *parent, INT colid, INT sort_colid);
00120
00121         void SetColumnId(INT colid) const { GetMyModel()->SetColumnId(colid); }
00122
00123     protected:
00124         virtual Model* CreateModel() const;
00125
00126     private:
00127         PbProvColListBoxModel* GetMyModel() const { return (PbProvColListBoxModel *)GetModel(); }
00128 };
00129
00131 #endif  // Mmi_PbProvListBox_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecord.cpp File Reference

Applications/AdvPhonebook/PbRecord.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Config/NvRamConfig.hpp>
#include "PbRecord.hpp"

Include dependency graph for PbRecord.cpp:

Generated on Tue Jan 24 23:36:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecord.hpp File Reference

Applications/AdvPhonebook/PbRecord.hpp File Reference

#include <AddOns/AdcExtensions/Record.hpp>
#include <AdvPhonebook/PbTypes.hpp>
#include <AdvPhonebook/PbConfig.hpp>

Include dependency graph for PbRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbNumberRecord
struct | PbNumberRecord::Persist
class | PbRecord
struct | PbRecord::Persist

Defines

#define | Mmi_PbRecord_hpp

Define Documentation

#define Mmi_PbRecord_hpp

Generated on Tue Jan 24 23:36:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecord.hpp Source File

Applications/AdvPhonebook/PbRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbRecord_hpp)
00009 #define Mmi_PbRecord_hpp
00013 #include <AddOns/AdcExtensions/Record.hpp>
00014 #include <AdvPhonebook/PbTypes.hpp>
00015 #include <AdvPhonebook/PbConfig.hpp>
00016
00020 class PbRecord : public Record {
00021     typedef Record Base;
00022
00023     public:
00024         PbRecord();
00025
00028         void SetName(const WString &name) { WStrCpy(m_data.m_name, name); }
00029
00032         const WCHAR * GetName() const { return m_data.m_name; }
00033
00036         void SetEmail(const String &email) { strcpy(m_data.m_email, email.c_str()); }
00037
00040         const CHAR * GetEmail() const { return m_data.m_email; }
00041
00044         void SetGroupId(UINT grp_id) { m_data.m_bits.group_id = grp_id; }
00045
00048         const UINT GetGroupId() const { return m_data.m_bits.group_id; }
00049
00053         void SetIccId(INT icc_id) { m_data.m_bits.icc_id = icc_id; }
00054
00058         const INT GetIccId() { return m_data.m_bits.icc_id; }
00059
00061         void SetValid(BOOLEAN valid) { m_data.m_bits.valid = valid; }
00062
00064         BOOLEAN IsValid() { return m_data.m_bits.valid; }
00065
00068         virtual const UINT8* GetData();
00069
00072         virtual void SetData(const UINT8* data);
00073
00076         virtual INT GetPersistentSize();
00077
00082         virtual void MarkDeleted();
00083
00086         virtual BOOLEAN IsRecordDeleted();
00087
00088         struct Persist {
00089             UINT8       type;
00090             WCHAR       m_name[c_max_name_len + 1];
00091             CHAR        m_email[c_max_email_len + 1];
00092             struct {
00093                 UINT    group_id    : 4;
00094                 INT     icc_id      : 2;
00095                 BOOLEAN valid       : 1;
00096                 BOOLEAN deleted     : 1;
00097             } m_bits;
00098         }m_data;
00099 };
00100
00103 class PbNumberRecord : public Record {
00104     typedef Record Base;
00105
00106     public:
00107         PbNumberRecord();
00108
00112         void SetNameRecNo(UINT16 name_recno) { m_data.m_name_recno = name_recno; }
00113
00116         const UINT16 GetNameRecNo() const { return m_data.m_name_recno; }
00117
00121         void SetNoId(UINT no_id) { m_data.m_bits.no_id = no_id; }
00122
00126         const UINT GetNoId() const { return m_data.m_bits.no_id; }
00127
00130         void SetPhoneNumber(const PhoneNumber &phoneno) { phoneno >> m_data.m_phoneno_persist; }
00131
00134         const PhoneNumber GetPhoneNumber() const;
00135
00138         void SetPhoneNoType(PhoneNoType no_type) { m_data.m_bits.phoneno_type = no_type; }
00139
00143         const PhoneNoType GetPhoneNoType() const { return m_data.m_bits.phoneno_type; }
00144
00148         void SetSimRecNo(UINT16 sim_recno) { m_data.m_sim_recno = sim_recno; }
00149
00152         const UINT GetSimRecNo() const { return m_data.m_sim_recno; }
00153
00157         void SetIsOnSim(BOOLEAN on_sim) { m_data.m_bits.is_on_sim = on_sim; }
00158
00162         const BOOLEAN IsOnSim() const { return m_data.m_bits.is_on_sim; }
00163
00165         void SetValid(BOOLEAN valid) { m_data.m_bits.valid = valid; }
00166
00168         BOOLEAN IsValid() { return m_data.m_bits.valid; }
00169
00172         virtual const UINT8* GetData();
00173
00176         virtual void SetData(const UINT8* data);
00177
00180         virtual INT GetPersistentSize();
00181
00186         virtual void MarkDeleted();
00187
00190         virtual BOOLEAN IsRecordDeleted();
00191
00192 //CN200013749
00194         void SetUniqueId(UINT32 unique_id) { m_data.m_unique_id = unique_id; }
00195
00197         const UINT32 GetUniqueId() const { return m_data.m_unique_id; }
00198 //END CN200013749
00199         //  Phone numbers data field definition
00200         struct Persist {
00201             PhoneNumber::Persist    m_phoneno_persist;
00202             UINT16      m_name_recno;
00203             UINT16      m_sim_recno;
00204             UINT8       type;
00205 //CN200013749
00206             UINT32          m_unique_id;
00207 //END CN200013749
00208             struct {
00209                 UINT        no_id           : 4;
00210                 PhoneNoType phoneno_type    : 4;// CN200007163 old 3 bit
00211                 BOOLEAN     is_on_sim       : 1;
00212                 BOOLEAN     valid           : 1;
00213                 BOOLEAN     deleted         : 1;
00214             } m_bits;
00215         }m_data;
00216 };
00217
00219 #endif  // Mmi_PbRecord_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecordHandler.cpp File Reference

Applications/AdvPhonebook/PbRecordHandler.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include "PbRecordHandler.hpp"

Include dependency graph for PbRecordHandler.cpp:

Generated on Tue Jan 24 23:36:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecordHandler.hpp File Reference

Applications/AdvPhonebook/PbRecordHandler.hpp File Reference

#include <AddOns/AdcExtensions/RecordHandler.hpp>

Include dependency graph for PbRecordHandler.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbRecordHandler

Defines

#define | Mmi_PbRecordHandler_hpp

Define Documentation

#define Mmi_PbRecordHandler_hpp

Generated on Tue Jan 24 23:36:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecordHandler.hpp Source File

Applications/AdvPhonebook/PbRecordHandler.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_PbRecordHandler_hpp)
00010 #define Mmi_PbRecordHandler_hpp
00014
00015 #include <AddOns/AdcExtensions/RecordHandler.hpp>
00016
00017 class Record;
00018 class RecordHandler;
00019 class PbRecordHandler {
00020
00021     public:
00022
00023         PbRecordHandler();
00024         virtual ~PbRecordHandler();
00025
00026         virtual void Init();
00027
00029         BOOLEAN Lock();
00030
00032         BOOLEAN Unlock();
00033
00034         virtual INT MaxRowCount() = 0;
00035
00036         INT RowCount()
00037             { return GetDataRecordHandler()->GetRowCount(); };
00038
00039         INT GetProgress() const { return m_progress; };
00040
00041         virtual BOOLEAN DeleteEntries(ProviderListener * listener = 0);
00042
00043         BOOLEAN ExistsEntry(INT recno)
00044             { return GetDataRecordHandler()->ExistsRecord(recno); };
00045
00046         virtual BOOLEAN GetEntry(INT recno, Record *pb_rec);
00047         virtual BOOLEAN UpdateEntry(INT recno, Record *pb_entry);
00048         virtual BOOLEAN DeleteEntry(INT recno);
00049
00050     protected:
00051         virtual Record* GetDataRecord() = 0;
00052         virtual RecordHandler* GetDataRecordHandler() = 0;
00053
00054
00055     private:
00056         INT                     m_progress;
00057
00058 };
00059
00061 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecordProvider.cpp File Reference

Applications/AdvPhonebook/PbRecordProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/ProviderListener.hpp>
#include <AdvPhonebook/PbProvIds.hpp>
#include "PbRecordHandler.hpp"
#include "PbRecordProvider.hpp"

Include dependency graph for PbRecordProvider.cpp:

Generated on Tue Jan 24 23:37:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecordProvider.hpp File Reference

Applications/AdvPhonebook/PbRecordProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>
#include <AdvPhonebook/PbRecord.hpp>

Include dependency graph for PbRecordProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbRecordProvider

Defines

#define | Mmi_PbRecordProvider_hpp

Define Documentation

#define Mmi_PbRecordProvider_hpp

Generated on Tue Jan 24 23:37:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbRecordProvider.hpp Source File

Applications/AdvPhonebook/PbRecordProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PbRecordProvider_hpp)
00015 #define Mmi_PbRecordProvider_hpp
00019
00020 #include <Auxiliary/Provider.hpp>
00021 #include <AdvPhonebook/PbRecord.hpp>
00022
00023 class ProviderListener;
00024 class PbRecordHandler;
00025 class PbRecordProvider : public ThreadSafeProvider {
00026
00027     public:
00028         typedef ThreadSafeProvider Base;
00029
00030         enum LastChange {
00031             Append,
00032             Commit,
00033             Delete,
00034             DeleteAll,
00035             None
00036         };
00037
00038         PbRecordProvider();
00039         PbRecordProvider(Protector *protector, PbRecordHandler *m_handler);
00040         virtual ~PbRecordProvider();
00041
00042         void Init(Protector *protector, PbRecordHandler *m_handler);
00043
00045         virtual BOOLEAN Lock();
00046
00048         virtual BOOLEAN Unlock();
00049
00050         virtual INT RowCount();
00051
00052         virtual INT MaxRowCount();
00053
00054         virtual BOOLEAN GetDataItem(IN INT columnid,
00055                                     IN INT row,
00056                                     OUT DataItem & item) = 0;
00057
00058         virtual BOOLEAN SetDataItem(IN const DataItem & item,
00059                                     IN INT columnid) = 0;
00060
00061
00062         virtual BOOLEAN SelectRow(INT row);
00063
00064         virtual BOOLEAN CommitRow(INT row);
00065         virtual BOOLEAN AppendRow();
00066         virtual BOOLEAN DeleteRow(INT row);
00067         virtual BOOLEAN DeleteAllRows(ProviderListener * listener = 0);
00068         virtual BOOLEAN Update(ProviderListener * listener = 0);
00069         INT GetKeyId() const { return m_key_id; };
00070
00071     protected:
00072         virtual Record* GetDataRecord() = 0;
00073         PbRecordHandler* GetHandler() { ASSERT(m_handler != 0); return m_handler; }
00074         virtual void InitRecord() = 0;
00075
00076         const IndexTable<INT>* GetRowTable() { return &m_row_table; }
00077         INT GetFirstFreeRecNo();
00078
00079     private:
00080         void InitRowTable(INT start = 0);
00081         void UpdateRowTable();
00082
00083         INT                 m_key_id;
00084         PbRecordHandler *   m_handler;
00085
00086         IndexTable<INT>     m_row_table;
00087
00088         INT                 m_new_recno;
00089         LastChange          m_last_change;
00090
00091 };
00092
00094 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectGroup.cpp File Reference

Applications/AdvPhonebook/PbSelectGroup.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <GuiExtensions/MmiDialog.hpp>
#include <Config/MmiGuiEngineConfig.hpp>
#include "PbSelectGroup.hpp"

Include dependency graph for PbSelectGroup.cpp:

Generated on Tue Jan 24 23:37:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectGroup.hpp File Reference

Applications/AdvPhonebook/PbSelectGroup.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/RadioButtonListBoxModel.hpp>
#include <GuiExtensions/DrawableObjectListBox.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <AdvPhonebook/GroupProvider.hpp>

Include dependency graph for PbSelectGroup.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbSelectGroup

Defines

#define | MAX_GROUP_COUNT 10
#define | Test_PbSelectGroup_hpp

Define Documentation

#define Test_PbSelectGroup_hpp

Generated on Tue Jan 24 23:37:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectGroup.hpp Source File

Applications/AdvPhonebook/PbSelectGroup.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Test_PbSelectGroup_hpp)
00010 #define Test_PbSelectGroup_hpp
00013
00014 #include <GuiExtensions/MmiWindow.hpp>
00015 #include <GuiExtensions/RadioButtonListBoxModel.hpp>
00016 #include <GuiExtensions/DrawableObjectListBox.hpp>
00017 #include <Gui/RadioButtonAction.hpp>
00018 #include <AdvPhonebook/GroupProvider.hpp>
00019
00020 #define MAX_GROUP_COUNT 10
00021
00023 class PbSelectGroup : public MmiWindow {
00024     typedef MmiWindow Base;
00025
00026     public:
00027         //
00028         PbSelectGroup();
00029
00030         //
00031         virtual ~PbSelectGroup();
00032
00033         //
00034         void Init();
00035
00037         void SetSelectedGroupIndex(INT index);
00038
00040         INT GetSelectedGroupIndex() const;
00041
00042
00043     protected:
00045         virtual void OnActionExecuted(Action *action);
00046
00047     private:
00048         DrawableObjectListBox m_listbox;
00049         RadioButtonListBoxModel m_model;
00050         RadioButtonAction m_rb_action[MAX_GROUP_COUNT];
00051         WString m_grp_str[MAX_GROUP_COUNT];
00052         Action m_close_win_action;
00053         GroupProvider       m_group_prov;
00054 };
00055
00057 #endif  // Test_PbAddEditEntry_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectNoType.cpp File Reference

Applications/AdvPhonebook/PbSelectNoType.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <GuiExtensions/MmiDialog.hpp>
#include <Config/MmiGuiEngineConfig.hpp>
#include "PbSelectNoType.hpp"

Include dependency graph for PbSelectNoType.cpp:

Generated on Tue Jan 24 23:37:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectNoType.hpp File Reference

Applications/AdvPhonebook/PbSelectNoType.hpp File Reference

#include <AdvPhonebook/PbTypes.hpp>
#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/RadioButtonListBoxModel.hpp>
#include <GuiExtensions/DrawableObjectListBox.hpp>
#include <Gui/RadioButtonAction.hpp>

Include dependency graph for PbSelectNoType.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbSelectNoType

Defines

#define | Test_PbSelectNoType_hpp

Define Documentation

#define Test_PbSelectNoType_hpp

Generated on Tue Jan 24 23:37:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectNoType.hpp Source File

Applications/AdvPhonebook/PbSelectNoType.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Test_PbSelectNoType_hpp)
00010 #define Test_PbSelectNoType_hpp
00013
00014 #include <AdvPhonebook/PbTypes.hpp>
00015 #include <GuiExtensions/MmiWindow.hpp>
00016 #include <GuiExtensions/RadioButtonListBoxModel.hpp>
00017 #include <GuiExtensions/DrawableObjectListBox.hpp>
00018 #include <Gui/RadioButtonAction.hpp>
00019
00021 class PbSelectNoType : public MmiWindow {
00022     typedef MmiWindow Base;
00023
00024     public:
00026         PbSelectNoType();
00027
00029         virtual ~PbSelectNoType();
00030
00032         void Init();
00033
00035         void SetSelectedNumberTypeIndex(INT index);
00036
00038         INT GetSelectedNumberTypeIndex() const;
00039
00040     protected:
00042         virtual void OnActionExecuted(Action *action);
00043
00044     private:
00045         enum NumberTypeId {
00046             NoTypeId = 0,
00047             MobileId,
00048             HomeId,
00049             OfficeId,
00050             FaxId,
00051             LastId  // mandatory last entry
00052         };
00053
00054         DrawableObjectListBox m_listbox;
00055         RadioButtonListBoxModel m_model;
00056         RadioButtonAction m_rb_action[LastId];
00057         Action m_close_win_action;
00058 };
00059
00061 #endif  // Test_PbAddEditEntry_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectNumberWin.cpp File Reference

Applications/AdvPhonebook/PbSelectNumberWin.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "ProvListBoxWin.hpp"
#include "PbSelectNumberWin.hpp"
#include "AdvPbMsgTypes.hpp"
#include "PbProvIds.hpp"
#include "PhonebookApp.hpp"

Include dependency graph for PbSelectNumberWin.cpp:

Generated on Tue Jan 24 23:38:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectNumberWin.hpp File Reference

Applications/AdvPhonebook/PbSelectNumberWin.hpp File Reference

#include <Gui/Lib.hpp>
#include <Gui/Action.hpp>
#include <AdvPhonebook/PbPhoneNumberPrompt.hpp>
#include <AdvPhonebook/PbBaseWin.hpp>
#include <AdvPhonebook/ProvListBoxWin.hpp>

Include dependency graph for PbSelectNumberWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbSelectNumberWin

Defines

#define | Mmi_PbSelectNumberWin_hpp

Define Documentation

#define Mmi_PbSelectNumberWin_hpp

Generated on Tue Jan 24 23:38:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSelectNumberWin.hpp Source File

Applications/AdvPhonebook/PbSelectNumberWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbSelectNumberWin_hpp)
00009 #define Mmi_PbSelectNumberWin_hpp
00012
00013 #include <Gui/Lib.hpp>
00014
00015 #include <Gui/Action.hpp>
00016 #include <AdvPhonebook/PbPhoneNumberPrompt.hpp>
00017 #include <AdvPhonebook/PbBaseWin.hpp>
00018 #include <AdvPhonebook/ProvListBoxWin.hpp>
00019
00020
00021 class PbSelectNumberWin : public PbBaseWin {
00022     public:
00023         typedef PbBaseWin Base;
00024
00025         PbSelectNumberWin();
00026         virtual ~PbSelectNumberWin();
00027
00028         void Init(Provider *pb_provider = 0);
00029
00030         void EnterNumber();
00031
00032         PhoneNumber GetSelectedNumber() const { return m_selected_number; };
00033
00034     protected:
00035         virtual void OnOpen();
00036         virtual BOOLEAN OnConfirm();
00037         virtual BOOLEAN OnCancel();
00038         virtual void OnActionExecuted(Action *action);
00039
00040     private:
00041         PhoneNumber             m_selected_number;
00042
00043         ConfirmAction           m_confirm_action;
00044         Action                  m_enter_no_action;
00045
00046         PbPhoneNumberPrompt     m_enter_no_win;
00047         ProvColListBoxWin       m_no_win;
00048
00049 };
00050
00052 #endif  // Mmi_PbSelectNumberWin_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSimProvider.cpp File Reference

Applications/AdvPhonebook/PbSimProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Config/Config.hpp>
#include "PbProvIds.hpp"
#include "PbTypes.hpp"
#include "PbSimProvider.hpp"

Include dependency graph for PbSimProvider.cpp:

Generated on Tue Jan 24 23:38:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSimProvider.hpp File Reference

Applications/AdvPhonebook/PbSimProvider.hpp File Reference

#include <Auxiliary/AbstractDelegationProvider.hpp>

Include dependency graph for PbSimProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbSimProvider

Defines

#define | Mmi_PbSimProvider_hpp

Define Documentation

#define Mmi_PbSimProvider_hpp

Generated on Tue Jan 24 23:38:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSimProvider.hpp Source File

Applications/AdvPhonebook/PbSimProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PbSimProvider_hpp)
00015 #define Mmi_PbSimProvider_hpp
00018
00019 #include <Auxiliary/AbstractDelegationProvider.hpp>
00020
00021 class PbSimProvider : public AbstractDelegationProvider
00022 {
00023     public:
00024         typedef AbstractDelegationProvider Base;
00025
00026         PbSimProvider();
00027         PbSimProvider(Provider *provider, INT provider_id = c_invalid_colid);
00028         virtual ~PbSimProvider();
00029
00030         void Init(Provider *provider = 0, INT provider_id = c_invalid_colid);
00031
00032         virtual INT GetProviderId() const;
00033
00034         virtual INT ColumnCount() const;
00035
00036         virtual const ColumnInfo * GetColumnInfo(INT column);
00037
00038         BOOLEAN ExistColumn(INT colid) { return Provider::ExistColumn(colid); }
00039
00040         INT GetColumnId(INT column) { return Provider::GetColumnId(column); }
00041
00042         const ColumnInfo * GetColumnInfoPerId(INT id) { return Provider::GetColumnInfoPerId(id); }
00043
00044         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem &item);
00045
00046         virtual BOOLEAN GetChildRow(INT & child_row, INT row);
00047
00048         virtual Status GetStatus() const;
00049
00050         virtual INT GetProgress();
00051
00052     private:
00053         INT m_provider_id;
00054 };
00055
00057 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSortedProvider.cpp File Reference

Applications/AdvPhonebook/PbSortedProvider.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbSortedProvider.hpp"

Include dependency graph for PbSortedProvider.cpp:

Generated on Tue Jan 24 23:38:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSortedProvider.hpp File Reference

Applications/AdvPhonebook/PbSortedProvider.hpp File Reference

#include <Auxiliary/QuickSortProvider.hpp>

Include dependency graph for PbSortedProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbSortedProvider

Defines

#define | Mmi_PbSortedProvider_hpp

Define Documentation

#define Mmi_PbSortedProvider_hpp

Generated on Tue Jan 24 23:38:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSortedProvider.hpp Source File

Applications/AdvPhonebook/PbSortedProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PbSortedProvider_hpp)
00009 #define Mmi_PbSortedProvider_hpp
00012
00013 #include <Auxiliary/QuickSortProvider.hpp>
00014
00015 class PbSortedProvider : public QuickSortProvider {
00016     public:
00017         typedef QuickSortProvider Base;
00018
00019         PbSortedProvider();
00020         virtual ~PbSortedProvider();
00021
00022         virtual BOOLEAN DeleteAllRows(ProviderListener *listener);
00023
00024         virtual Status GetStatus() const;
00025
00026         virtual BOOLEAN Update(ProviderListener *listener);
00027
00028 };
00029
00031 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSynchronizer.cpp File Reference

Applications/AdvPhonebook/PbSynchronizer.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Auxiliary/FilterRule.hpp>
#include <Common/PhoneNumberMatchRule.hpp>
#include "AdvPbMsgTypes.hpp"
#include "PbDetailFilterProvider.hpp"
#include "PbSynchronizer.hpp"
#include "PbProvIds.hpp"

Include dependency graph for PbSynchronizer.cpp:

Generated on Tue Jan 24 23:39:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSynchronizer.hpp File Reference

Applications/AdvPhonebook/PbSynchronizer.hpp File Reference

#include <GuiExtensions/MmiAdvancedProgressBox.hpp>
#include <AdvPhonebook/PbSimProvider.hpp>

Include dependency graph for PbSynchronizer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PbSynchronizer

Defines

#define | Mmi_PbSynchronizer_hpp

Define Documentation

#define Mmi_PbSynchronizer_hpp

Generated on Tue Jan 24 23:39:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbSynchronizer.hpp Source File

Applications/AdvPhonebook/PbSynchronizer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_PbSynchronizer_hpp)
00011 #define Mmi_PbSynchronizer_hpp
00014
00015 #include <GuiExtensions/MmiAdvancedProgressBox.hpp>
00016 #include <AdvPhonebook/PbSimProvider.hpp>
00017
00018 class PbSynchronizer {
00019
00020     public:
00021
00022         PbSynchronizer();
00023         virtual ~PbSynchronizer();
00024
00025         void Init(Application *app, Provider *pb_prov, Provider *sim_prov);
00026
00027         virtual BOOLEAN Synchronize(MmiAdvancedProgressBox *sync_progress_box = 0);
00028
00029         virtual BOOLEAN SyncSimAll(MmiAdvancedProgressBox *sync_progress_box = 0);
00030         virtual BOOLEAN SyncPhoneAll(MmiAdvancedProgressBox *sync_progress_box = 0);
00031
00032         virtual BOOLEAN SyncSimOne(INT phone_row);
00033         virtual BOOLEAN SyncPhoneOne(INT sim_row);
00034
00035         virtual BOOLEAN AutoSyncSim(INT phone_row) = 0;
00036         virtual BOOLEAN AutoSyncPhone(INT sim_row) = 0;
00037
00038         virtual BOOLEAN AutoDeleteSim(INT phone_row) = 0;
00039         virtual BOOLEAN AutoDeletePhone(INT sim_row) = 0;
00040
00041         BOOLEAN IsSynchronizing() const { return m_is_synchronizing; };
00042         BOOLEAN IsSynchronized() const { return m_is_synchronized; };
00043
00044         INT GetProgress() { return m_progress; }
00045
00046         Provider* GetSimProvider() { return m_sim_prov; }
00047         Provider* GetPbProvider() { return m_pb_prov; }
00048
00049         virtual void Update();
00050
00051         void SetCanceled(BOOLEAN cancel) { m_is_canceled = cancel; }
00052         BOOLEAN IsCanceled() { return m_is_canceled; }
00053         void SetPbHasGrown(BOOLEAN grown) { m_pb_entries_added = grown; }
00054         BOOLEAN HasPbGrown() { return m_pb_entries_added; }
00055
00056     protected:
00057
00058         virtual BOOLEAN SyncSim(INT no_row) = 0;
00059         virtual BOOLEAN SyncPhone(INT no_row) = 0;
00060
00061         void SetSynchronizing(BOOLEAN sync) { m_is_synchronizing = sync; }
00062         void SetSynchronized(BOOLEAN sync) { m_is_synchronized = sync; }
00063
00064         Application* GetApplication() const { return m_app; }
00065
00066     private:
00067         Application *           m_app;
00068         Provider *              m_sim_prov;
00069         Provider *              m_pb_prov;
00070
00071         INT                     m_progress;
00072
00073         BOOLEAN                 m_is_synchronizing;
00074         BOOLEAN                 m_is_synchronized;
00075
00076         Semaphore               m_sem;
00077
00078         BOOLEAN                 m_is_canceled;
00079         BOOLEAN                 m_pb_entries_added;
00080 };
00081
00083 #endif  // Mmi_PbSynchronizer_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbTypes.hpp File Reference

Applications/AdvPhonebook/PbTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Mmi_PbTypes_hpp

Enumerations

enum PhoneNoType {
NoType = 0, Mobil = 1, Home = 2, Office = 3,
Fax = 4, MaxNoType = 5
}

Define Documentation

#define Mmi_PbTypes_hpp

Enumeration Type Documentation

enum PhoneNoType

Enumerator:
NoType
Mobil
Home
Office
Fax
MaxNoType

Generated on Tue Jan 24 23:39:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PbTypes.hpp Source File

Applications/AdvPhonebook/PbTypes.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Mmi_PbTypes_hpp)
00015 #define Mmi_PbTypes_hpp
00016
00018
00019 enum PhoneNoType {
00020     NoType = 0,
00021     Mobil = 1,
00022     Home = 2,
00023     Office = 3,
00024     Fax = 4,
00025     MaxNoType = 5 //CN200007163
00026 };
00027 #endif
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PhonebookApp.cpp File Reference

Applications/AdvPhonebook/PhonebookApp.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <AddOns/AuxExtensions/MergeProvider.hpp>
#include <Config/MmiGuiEngineConfig.hpp>
#include <Config/MenuResConfig.hpp>
#include <Config/Config.hpp>
#include <Common/ApplicationManager.hpp>
#include <Common/SecurityControl.hpp>
#include <Common/SecurityManager.hpp>
#include <GuiExtensions/MmiInfoBox.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <AdvPhonebook/PbAdvAddEditEntry.hpp>
#include "PbSynchronizer.hpp"
#include "AdvPbMsgTypes.hpp"
#include "PbProvIds.hpp"
#include "PhonebookApp.hpp"

Include dependency graph for PhonebookApp.cpp:

Variables

LineEditor g_mail_editor
TextLine g_mail_text

Variable Documentation

LineEditor g_mail_editor

TextLine g_mail_text

Generated on Tue Jan 24 23:39:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PhonebookApp.hpp File Reference

Applications/AdvPhonebook/PhonebookApp.hpp File Reference

#include <Gui/Window.hpp>
#include <Gui/CheckBoxAction.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <Common/MmiApplication.hpp>
#include <GuiExtensions/MenuAction.hpp>
#include <GuiExtensions/MmiProviderProgressBox.hpp>
#include <GuiExtensions/MmiAdvancedProgressBox.hpp>
#include <GuiExtensions/MmiWaitingBox.hpp>
#include <AdvPhonebook/PhonebookWin.hpp>
#include <AdvPhonebook/PbAdvAddEditEntry.hpp>
#include <AdvPhonebook/PbSelectNumberWin.hpp>
#include <AdvPhonebook/PbDataHandler.hpp>
#include <AdvPhonebook/PbAction.hpp>
#include <AdvPhonebook/BasicPbWin.hpp>
#include <AdvPhonebook/CopyHandler.hpp>
#include <Common/MmiServices.hpp>
#include <AdvPhonebook/UpdatePbThreadlet.hpp>

Include dependency graph for PhonebookApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PhonebookApp

Defines

#define | Mmi_PhonebookApp_hpp

Define Documentation

#define Mmi_PhonebookApp_hpp

Generated on Tue Jan 24 23:39:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PhonebookApp.hpp Source File

Applications/AdvPhonebook/PhonebookApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_PhonebookApp_hpp)
00009 #define Mmi_PhonebookApp_hpp
00012
00013 #include <Gui/Window.hpp>
00014
00015 #include <Gui/CheckBoxAction.hpp>
00016 #include <AddOns/Services/ServiceBroker.hpp>
00017 #include <Common/MmiApplication.hpp>
00018 #include <GuiExtensions/MenuAction.hpp>
00019 #include <GuiExtensions/MmiProviderProgressBox.hpp>
00020 #include <GuiExtensions/MmiAdvancedProgressBox.hpp>
00021 #include <GuiExtensions/MmiWaitingBox.hpp>
00022 #include <AdvPhonebook/PhonebookWin.hpp>
00023 #include <AdvPhonebook/PbAdvAddEditEntry.hpp>
00024 #include <AdvPhonebook/PbSelectNumberWin.hpp>
00025 #include <AdvPhonebook/PbDataHandler.hpp>
00026 #include <AdvPhonebook/PbAction.hpp>
00027 #include <AdvPhonebook/BasicPbWin.hpp>
00028 #include <AdvPhonebook/CopyHandler.hpp>
00029 #include <Common/MmiServices.hpp>
00030 #include <AdvPhonebook/UpdatePbThreadlet.hpp>
00031
00032 class PbSynchronizer;
00033 class PhonebookApp : public MmiApplication, public PhonebookService {
00034     typedef MmiApplication Base;
00035
00036     public:
00037
00038         PhonebookApp(UINT stacksize = 0);
00039         virtual ~PhonebookApp();
00040
00041         enum AffectedProvider {
00042             NameProv,
00043             NumberProv,
00044             Both
00045         };
00046
00047         // Services
00048         virtual ServiceResult InvokePhonebook();
00049         virtual ServiceResult SelectPhoneNumber(PhoneNumber &phoneno, const WString &title = WString());
00050         virtual ServiceResult SelectEmailAddress(WString &email, const WString &title = WString());
00051         virtual ServiceResult SaveNumberInPhonebook(const PhoneNumber &phoneno);
00052         virtual ServiceResult SaveEntryInPhonebook(const WString &name, const PhoneNumber &phoneno);
00053         virtual ServiceResult SaveEntryInPhonebook(const WString &name, const WString& email_address);
00054         virtual ServiceResult SelectSimPos(INT sim_pos);
00055         virtual ServiceResult GetName(const PhoneNumber &phoneno, WString &name);
00056
00057         BOOLEAN Synchronize();
00058
00059         BOOLEAN AddPbEntry(const WString &name, const PhoneNumber &phoneno, const WString &email); // CN200009289 G.Ragavan
00060         BOOLEAN AddNumber(INT name_row, const PhoneNumber &phoneno, INT no_id);
00061         BOOLEAN UpdatePbEntry(INT colid, const DataItem &item);
00062         BOOLEAN DeleteSelectedNumber(BOOLEAN feedback = TRUE);
00063         BOOLEAN DeleteSelectedPbEntry(BOOLEAN feedback = TRUE);
00064         void CallSelectedNumber();
00065         BOOLEAN DeleteAllEntries();
00066         virtual void DisplayMemory();
00067         void SwitchDisplaySimPos();
00068         BOOLEAN AddAllToFdn();
00069         BOOLEAN AddEntryToFdn();
00070         BOOLEAN AddNumberToFdn();
00071         BOOLEAN CopyToPb();
00072
00073         void EnterNewEntry(const WString &default_name, const PhoneNumber &default_phoneno, const WString &default_mail); // CN200009289 G.Ragavan
00074
00075 //      PbProvider* GetPbProvider() { ASSERT(m_pb_data_control != 0); return m_pb_data_control->GetPbProvider(); }
00076 //      PbProvider* GetWindowProvider();
00077
00078         Provider* GetPbProvider() { return GetPbDataControl()->GetPbProvider(); }
00079         Provider* GetWindowProvider();
00080         INT GetSelectedRow() { ASSERT(m_active_win != 0); return m_active_win->GetSelectedRow(); }
00081
00082         INT GetSelectedPbRow() { ASSERT(m_phonebook != 0); return m_phonebook->GetSelectedRow(); };
00083
00084         //
00085         void GetSelectedItem(INT colid, DataItem &item) { m_active_win->GetSelectedItem(colid, item); };
00086
00087         void SetActiveWin(PbAbstractWin* win) { m_active_win = win; }
00088         PbAbstractWin* GetActiveWin() { return m_active_win; }
00089
00090         virtual void UpdateEnabledActions();
00091
00092         Action* GetCallAction() { return &m_call_action; }
00093         Action* GetAddAction() { return &m_add_action; }
00094         Action* GetDeleteAction() { return &m_delete_action; }
00095         Action* GetDelAllAction() { return &m_del_all_action; }
00096
00097         BOOLEAN IsEmptyRow(Provider *prov, INT row);
00098
00099         virtual INT GetMaxPhonenos() = 0;
00100         INT NumberCount(INT name_row);
00101
00102         virtual PhonebookWin* GetPhonebook() = 0;
00103
00104         INT SearchRow(SortProvider *prov, const DataItem &item, INT col_id);
00105
00106         void StartWaitingAnimation();
00107         void StopWaitingAnimation();
00108
00109         virtual BOOLEAN IsPbAvailable() { return TRUE; }
00110
00111         enum ProviderUpdateState{
00112             Started,
00113             Finished
00114         };
00115     protected:
00116         virtual void OnStartup();
00117         virtual void OnOpen();
00118         virtual void OnClose();
00119         virtual BOOLEAN OnMessage(const Message &msg);
00120         virtual void OnSimChanged(SimChangeType chg_type);
00121         virtual void OnSimStateChanged(SimIndicator sim_ind);
00122         virtual void OnSimReady();
00123         virtual void OnSimPresent() {};
00124         virtual void OnSimNotPresent() {};
00125         virtual void OnPbWindowClosed(const PbAbstractWin *win);
00126
00127         virtual void OnTriggerNotification (INT16 type);
00128
00129         virtual BOOLEAN ServiceReady();
00130
00131         BOOLEAN NewSim() { return m_new_sim; }
00132
00133         virtual void UpdatePbs(DataControlType data_type);
00134
00135         void OpenPhonebook();
00136         void EnablePhonebook(BOOLEAN flag) { m_open_pb_action.SetEnabled(flag); }
00137
00138         virtual void EnableSimActions(BOOLEAN flag);
00139
00140         BOOLEAN NoEntrySelected();
00141
00142         virtual PbDataHandler* GetPbDataControl() = 0;
00143         virtual PbSynchronizer* GetSynchronizer() = 0;
00144
00145         MmiProviderProgressBox* GetProgressBox() { return &m_prov_listener; }
00146
00147         BOOLEAN ProvShowsEmptyRows(Provider *prov);
00148
00149         OpenWindowAction* GetOpenPbWinAction() { return &m_open_pb_win_action; }
00150
00151         static UpdatePbThreadlet    m_update_threadlet;
00152
00153     private:
00154         INT FindPbNameRow(const WString &name);
00155         BOOLEAN IsPhonebookEmpty();
00156
00157         // Phonebook data handling
00158         PbDataHandler *         m_pb_data_control;
00159         PhonebookWin *          m_phonebook;
00160         PbSynchronizer *        m_sim_synchronizer;
00161
00162         PbAbstractWin *         m_active_win;
00163
00164         Provider *              m_pb_provider;
00165
00166         MmiProviderProgressBox  m_provider_listener;
00167
00168         // Actions
00169         PbCallAction            m_call_action;
00170         PbAddAction             m_add_action;
00171         PbDeleteAction          m_delete_action;
00172         PbDelAllAction          m_del_all_action;
00173         DisplayMemoryAction     m_display_mem_action;
00174
00175         AddAllToFdnAction       m_all_to_fdn_action;
00176         AddEntryToFdnAction     m_entry_to_fdn_action;
00177         AddNumberToFdnAction    m_no_to_fdn_action;
00178         OpenWindowAction        m_show_fdn_action;
00179         CopyToPbAction          m_fdn_to_pb_action;
00180         OpenWindowAction        m_show_bdn_action;
00181
00182         MenuAction              m_open_pb_action;
00183         OpenWindowAction        m_open_pb_win_action;
00184         OpenWindowAction        m_show_msisdn_action;
00185         OpenWindowAction        m_show_sdn_action;
00186
00187         // Windows
00188         BasicPbWin              m_msisdn_pb;
00189         BasicPbWin              m_fdn_pb;
00190         PbBaseWin               m_sim_win;
00191         BasicPbWin              m_bdn_pb;
00192         BasicPbWin              m_sdn_pb;
00193         PbSelectNumberWin       m_select_no_win;
00194         PbAdvAddEditEntry           m_add_entry_win;
00195
00196         BOOLEAN                 m_sync_sim;
00197
00198         SyncAction              m_sync_action;
00199
00200         PbCopyHandler           m_copy_to_fdn_handler;
00201
00202         MmiProviderProgressBox  m_prov_listener;
00203         MmiAdvancedProgressBox  m_sync_listener;
00204
00205         BooleanCondition        m_number_selected_cond;
00206         BooleanCondition        m_pb_prov_updated_cond;
00207
00208         MmiWaitingBox           m_wait_box;
00209
00210         BOOLEAN                 m_new_sim;
00211
00212         BOOLEAN                 m_fdnEnabled;
00213
00214         friend class PbAbstractWin;
00215 };
00216
00218 #endif  // Mmi_PhonebookApp_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PhonebookWin.cpp File Reference

Applications/AdvPhonebook/PhonebookWin.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include "PbProvIds.hpp"
#include "PhonebookApp.hpp"
#include "PhonebookWin.hpp"

Include dependency graph for PhonebookWin.cpp:

Generated on Tue Jan 24 23:39:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PhonebookWin.hpp File Reference

Applications/AdvPhonebook/PhonebookWin.hpp File Reference

#include <AdvPhonebook/PbBaseWin.hpp>

Include dependency graph for PhonebookWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PhonebookWin

Defines

#define | PhonebookWin_hpp

Define Documentation

#define PhonebookWin_hpp

Generated on Tue Jan 24 23:39:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/PhonebookWin.hpp Source File

Applications/AdvPhonebook/PhonebookWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(PhonebookWin_hpp)
00009 #define PhonebookWin_hpp
00012
00013 #include <AdvPhonebook/PbBaseWin.hpp>
00014
00015 class PbDetails;
00016 class PhonebookWin : public PbBaseWin {
00017     public:
00018         typedef PbBaseWin Base;
00019
00020         PhonebookWin();
00021         virtual ~PhonebookWin();
00022
00023         void Init(Provider* pb_provider = 0, INT sort_colid = c_name_id, BOOLEAN read_only = FALSE);
00024
00025         virtual void SetDisplaySimPos(BOOLEAN display_simpos);
00026
00027         void AddDetailMenuAction(Action *action, BOOLEAN separate = FALSE);
00028
00029         void Update();
00030
00031         virtual BOOLEAN IsReadOnly();
00032
00033         virtual PbDetails* GetDetailWin() = 0;
00034
00035     protected:
00036         virtual void UpdateEnabledActions();
00037
00038     private:
00039         OpenWindowAction        m_open_detail_action;
00040         BOOLEAN m_read_only;
00041 };
00042
00044 #endif  // PhonebookWin_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/ProvListBoxWin.cpp File Reference

Applications/AdvPhonebook/ProvListBoxWin.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <AdvPhonebook/AdvPbMsgTypes.hpp>
#include <AdvPhonebook/PbProvIds.hpp>
#include <AdvPhonebook/PhonebookApp.hpp>
#include <AdvPhonebook/ProvListBoxWin.hpp>
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for ProvListBoxWin.cpp:

Generated on Tue Jan 24 23:40:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/ProvListBoxWin.hpp File Reference

Applications/AdvPhonebook/ProvListBoxWin.hpp File Reference

#include <GuiExtensions/DrawableObjectListBox.hpp>
#include <AdvPhonebook/PbProvListBox.hpp>
#include <AdvPhonebook/PbDetailListBox.hpp>
#include <AdvPhonebook/PbAbstractWin.hpp>
#include <GuiExtensions/MmiWindow.hpp>
#include <AdvPhonebook/PbDetailFilterProvider.hpp>

Include dependency graph for ProvListBoxWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ProvColListBoxWin
class | ProvDetailListBoxWin
class | ProvListBoxWin

Defines

#define | Mmi_ProvListBoxWin_hpp

Define Documentation

#define Mmi_ProvListBoxWin_hpp

Generated on Tue Jan 24 23:40:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/ProvListBoxWin.hpp Source File

Applications/AdvPhonebook/ProvListBoxWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_ProvListBoxWin_hpp)
00009 #define Mmi_ProvListBoxWin_hpp
00012
00013 #include <GuiExtensions/DrawableObjectListBox.hpp>
00014 #include <AdvPhonebook/PbProvListBox.hpp>
00015 #include <AdvPhonebook/PbDetailListBox.hpp>
00016 #include <AdvPhonebook/PbAbstractWin.hpp>
00017 #include <GuiExtensions/MmiWindow.hpp>
00018 #include <AdvPhonebook/PbDetailFilterProvider.hpp>
00019
00020 class ProvListBoxWin : public PbAbstractWin {
00021     typedef PbAbstractWin Base;
00022
00023     public:
00024         ProvListBoxWin();
00025         virtual ~ProvListBoxWin();
00026
00028         virtual void SetSelectedRow(INT row);
00029
00031         virtual INT GetSelectedRow();
00032
00033         virtual void SetProvider(Provider *provider);
00034
00035         virtual Provider* GetProvider();
00036
00037         virtual void UpdateWin(BOOLEAN win_only = FALSE);
00038
00039         virtual void GetSelectedItem(INT colid, DataItem &item);
00040     protected:
00041         virtual PbProvListBox * GetListBox() = 0;
00042         virtual INT GetListBoxRow(INT row);
00043
00044         virtual void Refresh(const Rect &rect);
00045         virtual void OnGetFocus();
00046         virtual BOOLEAN OnMessage(const Message& msg);
00047
00048
00049     private:
00050         INT m_selected_row;
00051         BOOLEAN m_prov_updating;
00052 };
00053
00054 class ProvColListBoxWin : public ProvListBoxWin {
00055     typedef ProvListBoxWin Base;
00056
00057     public:
00058         ProvColListBoxWin();
00059         ProvColListBoxWin(INT column_id);
00060         virtual ~ProvColListBoxWin();
00061
00063         void Init(INT column_id, INT sort_colid = c_invalid_colid);
00064         virtual Provider* GetMyPbProvider();
00065
00066     protected:
00067         virtual PbProvListBox * GetListBox();
00068
00069     private:
00070         PbProvColListBox        m_prov_listbox;
00071 };
00072
00073 class ProvDetailListBoxWin : public ProvListBoxWin {
00074     typedef ProvListBoxWin Base;
00075
00076     public:
00077         ProvDetailListBoxWin();
00078         ProvDetailListBoxWin(ProvListBoxWin *parent, const INT *detail_columns, INT filt_colid);
00079         virtual ~ProvDetailListBoxWin();
00080
00082         void Init(ProvListBoxWin *parent, const INT *detail_columns, INT filt_colid);
00083
00084         virtual Provider* GetMyPbProvider();
00085
00086         virtual INT GetSelectedRow();
00087
00089         virtual void SetProvider(Provider *provider);
00090
00091         void SetRow(int row);
00092         void SetDetailColumns(const INT *detail_columns) { m_detail_listbox.SetDetailColumns(detail_columns); }
00093
00094         virtual void UpdateEnabledActions();
00095
00096         virtual void UpdateWin(BOOLEAN win_only = FALSE);
00097
00098     protected:
00099         virtual void Refresh(const Rect &rect);
00100         virtual void UpdateTitle();
00101
00102         virtual PbProvListBox * GetListBox();
00103         virtual PbDetailProvider * GetDetailProvider() = 0;
00104         virtual ProvListBoxWin * GetParent();
00105
00106     private:
00107         ProvListBoxWin *        m_parent;
00108         const INT *             m_detail_columns;
00109         PbDetailListBox         m_detail_listbox;
00110         Provider *              m_provider;
00111         INT                     m_filt_colid;
00112 };
00113
00115 #endif  // Mmi_ProvListBoxWin_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/SyncPhoneThreadlet.cpp File Reference

Applications/AdvPhonebook/SyncPhoneThreadlet.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Kernel/Os/SemObtainer.hpp>
#include "SyncPhoneThreadlet.hpp"
#include <Config/Config.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <AdvPhonebook/PbSynchronizer.hpp>
#include <AdvPhonebook/PhonebookApp.hpp>
#include <AdvPhonebook/AdvPbMsgTypes.hpp>

Include dependency graph for SyncPhoneThreadlet.cpp:

Generated on Tue Jan 24 23:40:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/SyncPhoneThreadlet.hpp File Reference

Applications/AdvPhonebook/SyncPhoneThreadlet.hpp File Reference

#include <Kernel/Threadlet.hpp>

Include dependency graph for SyncPhoneThreadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SyncPhoneThreadlet

Defines

#define | Mmi_SyncPhoneThreadlet_hpp

Define Documentation

#define Mmi_SyncPhoneThreadlet_hpp

Generated on Tue Jan 24 23:40:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/SyncPhoneThreadlet.hpp Source File

Applications/AdvPhonebook/SyncPhoneThreadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_SyncPhoneThreadlet_hpp)
00011 #define Mmi_SyncPhoneThreadlet_hpp
00014
00015 #include <Kernel/Threadlet.hpp>
00016
00017 class PbSynchronizer;
00018 class Application;
00019 class SyncPhoneThreadlet : public Threadlet {
00020     typedef Threadlet Base;
00021
00022     public:
00023         //
00024         SyncPhoneThreadlet();
00025
00026         //
00027         virtual ~SyncPhoneThreadlet();
00028
00029         //
00030         void Init(Application *app, PbSynchronizer *synchronizer);
00031
00034         virtual INT Fn();
00035
00036         virtual void OnEndOfExecute();
00037
00038         BOOLEAN IsRunning() { return m_is_running; }
00039
00040         BOOLEAN SyncSucceeded() { return m_successful; }
00041
00042     private:
00043         Application*    m_pb_app;
00044         PbSynchronizer* m_synchronizer;
00045         BOOLEAN         m_successful;
00046         BOOLEAN         m_is_running;
00047 };
00048
00050 #endif  // Apoxi_Threadlet_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/UpdatePbThreadlet.cpp File Reference

Applications/AdvPhonebook/UpdatePbThreadlet.cpp File Reference

#include <AdvPhonebook/AdvPbPreComp.hpp>
#include <Config/Config.hpp>
#include <AdvPhonebook/AdvPbMsgTypes.hpp>
#include <AdvPhonebook/PhonebookApp.hpp>
#include <AdvPhonebook/UpdatePbThreadlet.hpp>

Include dependency graph for UpdatePbThreadlet.cpp:

Generated on Tue Jan 24 23:40:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/UpdatePbThreadlet.hpp File Reference

Applications/AdvPhonebook/UpdatePbThreadlet.hpp File Reference

#include <Kernel/Threadlet.hpp>
#include <Auxiliary/MainProvider.hpp>

Include dependency graph for UpdatePbThreadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UpdatePbThreadlet

Defines

#define | Mmi_UpdatePbThreadlet_hpp

Define Documentation

#define Mmi_UpdatePbThreadlet_hpp

Generated on Tue Jan 24 23:40:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/AdvPhonebook/UpdatePbThreadlet.hpp Source File

Applications/AdvPhonebook/UpdatePbThreadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_UpdatePbThreadlet_hpp)
00010 #define Mmi_UpdatePbThreadlet_hpp
00013
00014 #include <Kernel/Threadlet.hpp>
00015 #include <Auxiliary/MainProvider.hpp>
00016
00017 class UpdatePbThreadlet : public Threadlet {
00018     typedef Threadlet Base;
00019
00020     public:
00021         //
00022         UpdatePbThreadlet();
00023
00024         virtual ~UpdatePbThreadlet();
00025
00026         void Init(Application* app, Provider* provider);
00027
00030         virtual INT Fn();
00031
00032         virtual void OnEndOfExecute();
00033
00034         BOOLEAN IsRunning() { return m_is_running; }
00035
00036     private:
00037         Application*        m_app;
00038         Provider*           m_provider;
00039         BOOLEAN             m_is_running;
00040 };
00041
00043 #endif  // Mmi_UpdatePbThreadlet_hpp
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.cpp File Reference

Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.cpp File Reference

#include "BtAvrcpPreComp.hpp"
#include "BtAvrcpAlertMessageWindow.hpp"

Include dependency graph for BtAvrcpAlertMessageWindow.cpp:

Generated on Tue Jan 24 23:40:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.hpp File Reference

#include <GuiExtensions/MmiAlert.hpp>

Include dependency graph for BtAvrcpAlertMessageWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpAlertMessageWindow

Defines

#define | BtAvrcpAlertMessageWindow_hpp

Define Documentation

#define BtAvrcpAlertMessageWindow_hpp

Generated on Tue Jan 24 23:40:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtAvrcpAlertMessageWindow_hpp)
00010 #define BtAvrcpAlertMessageWindow_hpp
00011
00012 #include <GuiExtensions/MmiAlert.hpp>
00013
00014
00015 /*  ************************************************************************
00016     <em>BtAvrcpAlertMessageWindow<em> alert window used to display some alert message
00017     to inform user about the status or result of the progress.
00018     ************************************************************************ */
00019 class BtAvrcpAlertMessageWindow : public MmiAlert
00020 {
00021     private:
00022         typedef MmiAlert Base;
00023
00024     public:
00025         // Enumeration for text display in allert box
00026         typedef enum
00027         {
00028             // BT AVRCP registration notification
00029             BtAmwAvrcpRegister,
00030             // BT AVRCP deregistration notification
00031             BtAmwAvrcpDeRegister,
00032             // BT AVRCP connection established notification
00033             BtAmwAvrcpConnect,
00034             // BT AVRCP connection released notification
00035             BtAmwAvrcpDisconnect,
00036             // BT AVRCP panel pass through notification
00037             BtAmwAvrcpPanelPassthrough,
00038             // BT AVRCP raw frame notification
00039             BtAmwAvrcpRawFrame,
00040             // BT AVRCP unit info notification
00041             BtAmwAvrcpUnitInfo,
00042             // BT AVRCP subunit info notification
00043             BtAmwAvrcpSubunitInfo,
00044             // BT AVRCP not congested
00045             BtAmwNotCongested,
00046             // BT AVRCP device selected
00047             BtAmwAvrcpDeviceSelected
00048         } BtAmwType;
00049
00052         BtAvrcpAlertMessageWindow();
00053
00056         virtual ~BtAvrcpAlertMessageWindow();
00057
00060         void Init();
00061
00064         void Display(BtAmwType amw_type, BOOLEAN success);
00065 };
00066
00067 #endif /* BtAvrcpAlertMessageWindow_hpp*/
00068
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpCommandInterface.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpCommandInterface.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpCommandInterface

Defines

#define | BtAvrcpCommandInterface_hpp

Enumerations

enum AvrcpCommand {
ACKey0, ACKey1, ACKey2, ACKey3,
ACKey4, ACKey5, ACKey6, ACKey7,
ACKey8, ACKey9, ACDot, ACEnter,
ACClear, ACSoundSelect, ACInputSelect, ACDisplayInformation,
ACHelp, ACPower, ACPlay, ACStop,
ACPause, ACRecord, ACRewind, ACFastForward,
ACEject, ACForward, ACBackward, ACAngle,
ACSubpicture, ACF1, ACF2, ACF3,
ACF4, ACF5, ACNotDefined
}
enum AvrcpResponse {
ARNotImplemented, ARAccepted, ARRejected, ARInTransition,
ARImplementedStable, ARResponseChanged, ARInterim
}

Define Documentation

#define BtAvrcpCommandInterface_hpp

Enumeration Type Documentation

enum AvrcpCommand

Enumerator:
ACKey0
ACKey1
ACKey2
ACKey3
ACKey4
ACKey5
ACKey6
ACKey7
ACKey8
ACKey9
ACDot
ACEnter
ACClear
ACSoundSelect
ACInputSelect
ACDisplayInformation
ACHelp
ACPower
ACPlay
ACStop
ACPause
ACRecord
ACRewind
ACFastForward
ACEject
ACForward
ACBackward
ACAngle
ACSubpicture
ACF1
ACF2
ACF3
ACF4
ACF5
ACNotDefined

enum AvrcpResponse

Enumerator:
ARNotImplemented
ARAccepted
ARRejected
ARInTransition
ARImplementedStable
ARResponseChanged
ARInterim

Generated on Tue Jan 24 23:40:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpCommandInterface.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpCommandInterface.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if ! defined(BtAvrcpCommandInterface_hpp)
00010 #define BtAvrcpCommandInterface_hpp
00011
00012 /*  AvrcpCommand mandatory and optional commands for Category 1. */
00013 enum AvrcpCommand {
00014     ACKey0,
00015     ACKey1,
00016     ACKey2,
00017     ACKey3,
00018     ACKey4,
00019     ACKey5,
00020     ACKey6,
00021     ACKey7,
00022     ACKey8,
00023     ACKey9,
00024     ACDot,
00025     ACEnter,
00026     ACClear,
00027     ACSoundSelect,
00028     ACInputSelect,
00029     ACDisplayInformation,
00030     ACHelp,
00031     ACPower,
00032     ACPlay,
00033     ACStop,
00034     ACPause,
00035     ACRecord,
00036     ACRewind,
00037     ACFastForward,
00038     ACEject,
00039     ACForward,
00040     ACBackward,
00041     ACAngle,
00042     ACSubpicture,
00043     ACF1,
00044     ACF2,
00045     ACF3,
00046     ACF4,
00047     ACF5,
00048     ACNotDefined
00049 };
00050
00051 /*  AvrcpResponse will be returned by media player plugin as a return value to the function call OnAvrcpCommand(). */
00052 enum AvrcpResponse {
00053     ARNotImplemented,
00054     ARAccepted,
00055     ARRejected,
00056     ARInTransition,
00057     ARImplementedStable,
00058     ARResponseChanged,
00059     ARInterim
00060 };
00061
00062 /*
00063     BtAvrcpCommandInterface defines the virtual functions that are to be implemented by
00064     Media App Plugins. Mmi panel application invokes these functions using the
00065     reference passed through the service interface AvrcpPanelService::RegsiterAvrcpApp().
00066 */
00067 class BtAvrcpCommandInterface {
00068
00069     public:
00070
00074         virtual AvrcpResponse OnAvrcpCommand (AvrcpCommand cmd) const = 0;
00075 };
00076
00077 #endif //#define BtAvrcpCommandInterface_hpp
00078
Generated on Tue Jan 24 14:51:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.cpp File Reference

Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.cpp File Reference

#include "BtAvrcpPreComp.hpp"
#include <Bluetooth/AVRCP/BtTypes.hpp>
#include "BtAvrcpPanelApplication.hpp"
#include "BtAvrcpControllerApplicationWindows.hpp"

Include dependency graph for BtAvrcpControllerApplicationWindows.cpp:

Defines

#define | AUDIO_DEVICE L"Audio device"
#define | DEVICE_ADDRESS_CAPTION L"Device Address:"
#define | DEVICE_CONECTED_CAPTION L"Device Connected:"
#define | DEVICE_NAME_CAPTION L"Device Name:"
#define | DEVICE_PLAYING_CAPTION L"Device Playing:"
#define | DEVICE_TEXT_NO L"No"
#define | DEVICE_TEXT_NO_ACTIVE_DEVICE L"No active device"
#define | DEVICE_TEXT_NO_PAIRED_DEVICE L"No paired device"
#define | DEVICE_TEXT_YES L"Yes"
#define | NOT_AVAILALBE L"not available"
#define | SUB_UNIT_INFO L"Subunit info:"

Define Documentation

#define AUDIO_DEVICE L"Audio device"

#define DEVICE_ADDRESS_CAPTION L"Device Address:"

#define DEVICE_CONECTED_CAPTION L"Device Connected:"

#define DEVICE_NAME_CAPTION L"Device Name:"

#define DEVICE_PLAYING_CAPTION L"Device Playing:"

#define DEVICE_TEXT_NO L"No"

#define DEVICE_TEXT_NO_ACTIVE_DEVICE L"No active device"

#define DEVICE_TEXT_NO_PAIRED_DEVICE L"No paired device"

#define DEVICE_TEXT_YES L"Yes"

#define NOT_AVAILALBE L"not available"

#define SUB_UNIT_INFO L"Subunit info:"

Generated on Tue Jan 24 23:41:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp File Reference

#include <Common/MmiWindow.hpp>
#include <Common/MmiWaitingBox.hpp>
#include <Gui/MultiLineEditor.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtDeviceList.hpp>
#include <Bluetooth/BtDeviceListIterator.hpp>
#include "BtAvrcpAlertMessageWindow.hpp"
#include "BtAvrcpControllerDeviceListWindow.hpp"

Include dependency graph for BtAvrcpControllerApplicationWindows.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpControllerApplicationWindow
class | BtAvrcpControllerDeviceListItem

Defines

#define | BtAvrcpControllerApplicationWindow_hpp

Define Documentation

#define BtAvrcpControllerApplicationWindow_hpp

Generated on Tue Jan 24 23:41:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtAvrcpControllerApplicationWindow_hpp)
00010 #define BtAvrcpControllerApplicationWindow_hpp
00011
00012 #include <Common/MmiWindow.hpp>
00013 #include <Common/MmiWaitingBox.hpp>
00014 #include <Gui/MultiLineEditor.hpp>
00015
00016 #include <Bluetooth/BtDevice.hpp>
00017 #include <Bluetooth/BtDeviceList.hpp>
00018 #include <Bluetooth/BtDeviceListIterator.hpp>
00019
00020 #include "BtAvrcpAlertMessageWindow.hpp"
00021 #include "BtAvrcpControllerDeviceListWindow.hpp"
00022
00023 /*  ************************************************************************
00024     <em>BtAvrcpControllerDeviceListItem<em> is to show the BT device name in AtlItemListWindow
00025     ************************************************************************ */
00026 class BtAvrcpControllerDeviceListItem: public Item
00027 {
00028     private:
00029         typedef Item Base;
00030
00031     public:
00034         BtAvrcpControllerDeviceListItem(Dispatcher* dispatcher, const WString& device_name, const BtDeviceAddress& device_address);
00035
00038         virtual ~BtAvrcpControllerDeviceListItem();
00039
00042         const BtDeviceAddress& GetDeviceAddress() const;
00043
00046         BOOLEAN IsControllerConnected();
00047
00050         const BtDevice& GetTargetDevice() const;
00051
00054         void SetTargetDevice(const BtDevice& target_device);
00055
00058         BtAvrcpProfileOperationService* GetOperationService();
00059
00062         void SetOperationService(BtAvrcpProfileOperationService* avrcp_operation_service);
00063
00064         void SetPlayActive(BOOLEAN active_flag);
00065
00066         BOOLEAN GetPlayActive();
00067
00068         void SetLastPanelPassThroughRequest(UINT last_panel_passthrough_request);
00069
00070         UINT GetLastPanelPassThroughRequest();
00071
00072     private:
00074         BtDeviceAddress m_device_address;
00075
00077         BtAvrcpProfileOperationService* m_avrcp_operation_service; // owns an instance
00078
00080         BOOLEAN m_play_active;
00081
00083         UINT m_last_panel_passthrough_request;
00084
00085 };
00086
00087 /*  ************************************************************************
00088     <em>BtAvrcpControllerApplicationWindow<em> MmiWindow window used to display the Controller information.
00089     ************************************************************************ */
00090 //Forward declaration
00091 class BtAvrcpPanelApplication;
00092 class BtAvrcpAlertMessageWindow;
00093 class BtAvrcpProfileOperationService;
00094
00095 class BtAvrcpControllerApplicationWindow : public MmiWindow
00096 {
00097     typedef MmiWindow Base;
00098
00099     public:
00100
00101         enum
00102         {
00103             AvrcpNotSelected = 0,
00104             AvrcpNotConnected,
00105             AvrcpConnected,
00106             AvrcpConnectedAndActive
00107         };
00108
00111         BtAvrcpControllerApplicationWindow();
00112
00115         virtual ~BtAvrcpControllerApplicationWindow();
00116
00119         void DeleteAllDeviceListItems();
00120
00123         void Init(BtAvrcpPanelApplication* avrcp_panel_app);
00124
00127         void ControllerConnectRequest();
00128
00131         void OnConnectRequestFinished(BOOLEAN success);
00132
00135         void ControllerDisconnectRequest();
00136
00139         void OnDisconnectRequestFinished(BOOLEAN success);
00140
00143         void OnPanelPassthroughRequestFinished(BOOLEAN success);
00144
00147         void ControllerSetActiveDeviceRequest();
00148
00151         void ControllerSetInactiveDeviceRequest();
00152
00155         void ControllerSubUnitInfoRequest();
00156
00159         void OnSubUnitInfoRequestFinished(BOOLEAN success);
00160
00163         void ControllerSelectDeviceRequest();
00164
00167         INT GetDeviceCount();
00168
00171         INT GetPairedDeviceCount();
00172
00175         INT GetSelectedDeviceState();
00176
00177     protected:
00180         virtual void OnOpen();
00181
00184         virtual void OnGetFocus();
00185
00188         virtual BOOLEAN OnConfirm();
00189
00192         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00193
00194     private:
00197         void PrepareDeviceListContainer();
00198
00201         void OnSelectKeyDown();
00202
00205         void OnCancelKeyDown();
00206
00209         void DisplayControllerInfo(BOOLEAN display_subunitinfo=FALSE);
00210
00212         BtAvrcpPanelApplication* m_avrcp_panel_app;//does not own
00213
00215         BtAvrcpAlertMessageWindow   m_alert_message_window;
00216
00218         MultiLineEditor m_display;
00219
00221         MmiWaitingBox   m_waiting_box;
00222
00224         BtAvrcpControllerDeviceListWindow m_controller_device_list_window;
00225
00227         ItemContainer m_devicelist_container;
00228
00230         BtDeviceList m_device_list;
00231
00233         BtDeviceAndServiceClass m_device_and_service_class;
00234
00236         BtDevice m_selected_device;
00237
00239         BtAvrcpControllerDeviceListItem* m_active_device;// only reference
00240
00241 };
00242
00243 #endif /* BtAvrcpControllerApplicationWindow_hpp */
00244
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.cpp File Reference

Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.cpp File Reference

#include "BtAvrcpPreComp.hpp"
#include "BtAvrcpPanelApplication.hpp"
#include "BtAvrcpControllerDeviceListWindow.hpp"

Include dependency graph for BtAvrcpControllerDeviceListWindow.cpp:

Generated on Tue Jan 24 23:41:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.hpp File Reference

#include <Atl/Gui/AtlItemListWindow.hpp>

Include dependency graph for BtAvrcpControllerDeviceListWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpControllerDeviceListWindow

Defines

#define | BtAvrcpControllerDeviceListWindow_hpp

Define Documentation

#define BtAvrcpControllerDeviceListWindow_hpp

Generated on Tue Jan 24 23:41:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtAvrcpControllerDeviceListWindow_hpp)
00010 #define BtAvrcpControllerDeviceListWindow_hpp
00011
00012 #include <Atl/Gui/AtlItemListWindow.hpp>
00013
00014 /*  ************************************************************************
00015     <em>BtAvrcpControllerDeviceListWindow<em> AltItemList window.
00016     ************************************************************************ */
00017 //Forward declaration
00018 class BtAvrcpPanelApplication;
00019
00020 class BtAvrcpControllerDeviceListWindow : public AtlItemListWindow
00021 {
00022     typedef AtlItemListWindow Base;
00023
00024     public:
00027         BtAvrcpControllerDeviceListWindow();
00028
00031         virtual ~BtAvrcpControllerDeviceListWindow();
00032
00035         void Init(BtAvrcpPanelApplication* avrcp_panel_app, AbstractItemContainer* item_container);
00036
00037     protected:
00040         virtual void OnOpen();
00041
00044         virtual void OnSelectionChanged();
00045
00048         virtual void OnGetFocus();
00049
00052         virtual BOOLEAN OnConfirm();
00053
00054     private:
00056         BtAvrcpPanelApplication* m_avrcp_panel_app;//does not own
00057
00058 };
00059
00060 #endif /* BtAvrcpControllerDeviceListWindow_hpp*/
00061
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelApplication.cpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPanelApplication.cpp File Reference

#include "BtAvrcpPreComp.hpp"
#include <Common/CommonMsgTypes.hpp>
#include <Common/BtAvrcpPanelService.hpp>
#include <Atl/Features/FeaturePool.hpp>
#include "BtAvrcpPanelApplication.hpp"

Include dependency graph for BtAvrcpPanelApplication.cpp:

Defines

#define COMPANY_ID_IFIN_AP 0x000319

Define Documentation

#define COMPANY_ID_IFIN_AP 0x000319

Generated on Tue Jan 24 23:41:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp File Reference

#include <Common/MmiApplication.hpp>
#include <Common/MmiWaitingBox.hpp>
#include <AddOns/Services/Service.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp>
#include <Bluetooth/AVRCP/BtTypes.hpp>
#include <Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp>
#include <Atl/Features/Feature.hpp>
#include <Atl/Features/FeatureID.hpp>
#include "BtAvrcpPanelServiceImpl.hpp"
#include "BtAvrcpCommandInterface.hpp"
#include "BtAvrcpPanelApplicationWindows.hpp"
#include "BtAvrcpProfileService.hpp"
#include "BtAvrcpControllerApplicationWindows.hpp"
#include "BtAvrcpAlertMessageWindow.hpp"

Include dependency graph for BtAvrcpPanelApplication.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpPanelApplication
class | SubUnitReference

Defines

#define | BtAvrcpPanelApplication_hpp

Define Documentation

#define BtAvrcpPanelApplication_hpp

Generated on Tue Jan 24 23:41:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if ! defined(BtAvrcpPanelApplication_hpp)
00010 #define BtAvrcpPanelApplication_hpp
00011
00012 #include <Common/MmiApplication.hpp>
00013 #include <Common/MmiWaitingBox.hpp>
00014
00015 #include <AddOns/Services/Service.hpp>
00016 #include <AddOns/Services/ServiceBroker.hpp>
00017
00018 #include <Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp>
00019 #include <Bluetooth/AVRCP/BtTypes.hpp>
00020 #include <Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp>
00021
00022 #include <Atl/Features/Feature.hpp>
00023 #include <Atl/Features/FeatureID.hpp>
00024
00025 #include "BtAvrcpPanelServiceImpl.hpp"
00026 #include "BtAvrcpCommandInterface.hpp"
00027 #include "BtAvrcpPanelApplicationWindows.hpp"
00028 #include "BtAvrcpProfileService.hpp"
00029 #include "BtAvrcpControllerApplicationWindows.hpp"
00030 #include "BtAvrcpAlertMessageWindow.hpp"
00031
00032
00036 class SubUnitReference : public Item
00037 {
00038     public:
00042         SubUnitReference(BtAvrcpCommandInterface* app_ref, WString app_name) : Item(NULL, app_name)
00043         {
00044             m_avrcp_app_ref=app_ref;
00045             m_avrcp_operation_service=NULL;
00046         }
00047
00051         ~SubUnitReference()
00052         {
00053             delete m_avrcp_operation_service;
00054         }
00055
00059         BtAvrcpCommandInterface* GetAvrcpAppReference() const
00060         {
00061             return m_avrcp_app_ref;
00062         }
00063
00068         BtAvrcpProfileOperationService* GetAvrcpOperationService() const
00069         {
00070             return m_avrcp_operation_service;
00071         }
00072
00078         void SetAvrcpOperationService(BtAvrcpProfileOperationService* avrcp_operation_service)
00079         {
00080             m_avrcp_operation_service=avrcp_operation_service;
00081         }
00082
00086         void InitAvrcpOperationService()
00087         {
00088             if(m_avrcp_operation_service)
00089                     m_avrcp_operation_service->Init();
00090         }
00091
00096         void ConnectResponse(btapi_avrcp_handle_t avrcp_handle)
00097         {
00098             if(m_avrcp_operation_service)
00099                 m_avrcp_operation_service->ConnectResponse(avrcp_handle);
00100         }
00101
00102     private:
00104         BtAvrcpCommandInterface* m_avrcp_app_ref;//Doesnot own, its only reference
00106         BtAvrcpProfileOperationService* m_avrcp_operation_service;// owns the object pointed to.
00107 };
00108
00114 class BtAvrcpPanelApplication : public MmiApplication
00115 {
00116     typedef MmiApplication Base;
00117
00118     public:
00120         enum BtAvrcpPanelAppFeatures
00121         {
00122             // must start with 0 and must be continously
00124             BtAvrcpPanelSetActiveSubUnit = 0,
00126             BtAvrcpOpenControllerWindow,
00128             BtAvrcpControllerSelectDeviceRequest, //Used in Controller window to open device list
00130             BtAvrcpControllerConnectRequest, //Used in Controller device list window
00132             BtAvrcpControllerDisconnectRequest, //Used in Controller device list window
00134             BtAvrcpControllerSubUnitInfoRequest, //Used in Controller device list window
00136             BtAvrcpControllerSetActiveDeviceRequest, //Used in Controller device list window
00138             BtAvrcpControllerSetInactiveDeviceRequest, //Used in Controller device list window
00140             BtAvrcpPanelFeatureCount    // mandatory last entry
00141         };
00142
00146         virtual ~BtAvrcpPanelApplication();
00147
00151         static BtAvrcpPanelApplication* GetInstance();
00152
00157         virtual void OnStartup();
00158
00162         BOOLEAN RegisterAvrcpApp (WString& app_name, BtAvrcpCommandInterface& cmd_handle, MmiSubUnitType sub_unit_info);
00163
00167         BOOLEAN DeregisterAvrcpApp (WString & app_name);
00168
00172         BtAvrcpResponseType OnPanelPassThrough(BtAvrcpPanelPassThroughParams ppt_params);
00173
00179         void UpdateContext();
00180
00184         BOOLEAN ChangeActiveDevice(INT idx);
00185
00189         void UpdateControllerFeaturesAvailable();
00190
00194         void UpdateControllerDeviceListFeaturesAvailable();
00195
00196     protected:
00199         virtual void OnOpen();
00200
00203         virtual void OnClose();
00204
00207         virtual BOOLEAN OnMessage(const Message &message);
00208
00211         virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00212
00216         BOOLEAN OnAvrcpNotification(const BtAvrcpNotificationMessage& avrcp_notification_message);
00217
00221         //virtual void RegisterAvrcpMessages() const;
00222
00226         //virtual void UnregisterAvrcpMessages() const;
00227
00232         void RegisterPanelToApoxiAvrcp();
00233
00238         virtual void UnregisterPanelToApoxiAvrcp();
00239
00243         BtAvrcpSubunitType GetBtApoxiAvrcpSubunitInfo(MmiSubUnitType sub_unit_info);
00244
00248         AvrcpCommand ConvertBtApoxiOperationToMmiCommand(BtAvrcpOperation bt_apoxi_operation);
00249
00253         BtAvrcpResponseType ConvertMmiResponseToApoxiResponse(AvrcpResponse mmi_response);
00254
00255     private:
00259         BtAvrcpPanelApplication();
00260
00264         void OnConnectNotification(btapi_avrcp_connect_handle_t hdl);
00265
00269         void OnDisconnectNotification(void* app_hdl);
00270
00274         void RegisterFeatures(const CHAR* feat_ids[], INT feat_count, Feature feat_items[]);
00275
00280         Feature m_features[BtAvrcpPanelFeatureCount];
00281
00286         static const CHAR* m_feature_ids[BtAvrcpPanelFeatureCount];
00287
00289         static BtAvrcpPanelApplication  m_bt_avrcp_panel_app;
00290
00292         BtAvrcpPanelServiceImpl     m_service;
00293
00295         ItemContainer   m_subunits_container;
00296
00298         BtAvrcpDeviceListWin m_subunits_list_win;
00299
00301         SubUnitReference*   m_active_subunit;// only reference
00302
00304         BtAvrcpSubunitInfoEntry*    m_subunitinfo_entry; // owns objects
00305
00307         BtAvrcpProfileRegistrationService   m_avrcp_registration_service;
00308
00310         BtAvrcpAlertMessageWindow   m_alert_message_window;
00311
00313         MmiWaitingBox   m_waiting_box;
00314
00316         BtAvrcpControllerApplicationWindow m_controller_window;
00317 };
00318 #endif //#define BtAvrcpPanelApplication_hpp
00319
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.cpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.cpp File Reference

#include "BtAvrcpPreComp.hpp"
#include "BtAvrcpPanelApplication.hpp"
#include "BtAvrcpPanelApplicationWindows.hpp"

Include dependency graph for BtAvrcpPanelApplicationWindows.cpp:

Generated on Tue Jan 24 23:41:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.hpp File Reference

#include <Atl/Gui/AtlItemListWindow.hpp>

Include dependency graph for BtAvrcpPanelApplicationWindows.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpDeviceListWin

Defines

#define | BtAvrcpPanelApplicationWindows_hpp

Define Documentation

#define BtAvrcpPanelApplicationWindows_hpp

Generated on Tue Jan 24 23:41:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(BtAvrcpPanelApplicationWindows_hpp)
00010 #define BtAvrcpPanelApplicationWindows_hpp
00011
00012 #include <Atl/Gui/AtlItemListWindow.hpp>
00013
00014 /*  ************************************************************************
00015     <em>BtAvrcpDeviceListWin<em> AltItemList window used to display the subunit(device) names
00016     in order to prompt the user to set one of the device as active.
00017     ************************************************************************ */
00018 //Forward declaration
00019 class BtAvrcpPanelApplication;
00020
00021 class BtAvrcpDeviceListWin : public AtlItemListWindow
00022 {
00023     typedef AtlItemListWindow Base;
00024
00025     public:
00028         BtAvrcpDeviceListWin();
00029
00032         virtual ~BtAvrcpDeviceListWin();
00033
00036         void Init(BtAvrcpPanelApplication* avrcp_panel_app, AbstractItemContainer* item_container);
00037
00038     protected:
00041         virtual void OnOpen();
00042
00045         virtual void OnSelectionChanged();
00046
00049         virtual void OnGetFocus();
00050
00053         virtual BOOLEAN OnConfirm();
00054
00055     private:
00057         BtAvrcpPanelApplication*    m_avrcp_panel_app;//does not own
00058 };
00059
00060 #endif /* BtAvrcpPanelApplicationWindows_hpp*/
00061
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelService.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPanelService.hpp File Reference

#include "BtAvrcpPreComp.hpp"
#include "BtAvrcpCommandInterface.hpp"

Include dependency graph for BtAvrcpPanelService.hpp:

Go to the source code of this file.

Data Structures

class | BtAvrcpPanelService

Defines

#define | BtAvrcpPanelService_hpp

Enumerations

enum MmiSubUnitType {
MSUMonitor, MSUAudio, MSUPrinter, MSUDisc,
MSUTapeRecPlayer, MSUTuner, MSUCa, MSUCamera,
MSUPanel, MSUBulletinBoard, MSUCameraStorage, MSUVendorUnique,
MSUBtAstUnit
}

Define Documentation

#define BtAvrcpPanelService_hpp

Enumeration Type Documentation

enum MmiSubUnitType

Enumerator:
MSUMonitor
MSUAudio
MSUPrinter
MSUDisc
MSUTapeRecPlayer
MSUTuner
MSUCa
MSUCamera
MSUPanel
MSUBulletinBoard
MSUCameraStorage
MSUVendorUnique
MSUBtAstUnit

Generated on Tue Jan 24 23:41:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelService.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpPanelService.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if ! defined(BtAvrcpPanelService_hpp)
00010 #define BtAvrcpPanelService_hpp
00011
00012 #include "BtAvrcpPreComp.hpp"
00013 #include "BtAvrcpCommandInterface.hpp"
00014
00015 /*  MmiSubUnitType specifies the type of Sub Unit.
00016    For example: Media Player is a sub-unit which is of type Audio*/
00017 enum MmiSubUnitType {
00018     MSUMonitor,
00019     MSUAudio,
00020     MSUPrinter,
00021     MSUDisc,
00022     MSUTapeRecPlayer,
00023     MSUTuner,
00024     MSUCa,
00025     MSUCamera,
00026     MSUPanel,
00027     MSUBulletinBoard,
00028     MSUCameraStorage,
00029     MSUVendorUnique,
00030     MSUBtAstUnit
00031 };
00032
00033 /*
00034     AvrcpPanelService is a service interface exposed which is used by plugin applications to register themselves to Panel application
00035     MMI Panel application inherits this class to implement virtual functions defined in this class.
00036 */
00037 class BtAvrcpPanelService
00038 {
00039     public:
00041         virtual BOOLEAN RegisterAvrcpApp (WString& app_name, BtAvrcpCommandInterface& cmd_handle, MmiSubUnitType sub_unit_info) const;
00043         virtual BOOLEAN DeregisterAvrcpApp (WString& app_name) const;
00044
00045 };
00046
00048 #endif //#define BtAvrcpPanelService_hpp
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.cpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.cpp File Reference

#include "BtAvrcpPreComp.hpp"
#include "BtAvrcpPanelApplication.hpp"
#include "BtAvrcpCommandInterface.hpp"
#include "BtAvrcpPanelServiceImpl.hpp"

Include dependency graph for BtAvrcpPanelServiceImpl.cpp:

Generated on Tue Jan 24 23:41:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.hpp File Reference

#include <Common/BtAvrcpPanelService.hpp>

Include dependency graph for BtAvrcpPanelServiceImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpPanelServiceImpl

Defines

#define | BtAvrcpPanelServiceImpl_hpp

Define Documentation

#define BtAvrcpPanelServiceImpl_hpp

Generated on Tue Jan 24 23:41:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008
00009 #if ! defined(BtAvrcpPanelServiceImpl_hpp)
00010 #define BtAvrcpPanelServiceImpl_hpp
00011
00012 #include <Common/BtAvrcpPanelService.hpp>
00013
00014 class Application;
00015 class BtAvrcpCommandInterface;
00016
00017 class BtAvrcpPanelServiceImpl : public BtAvrcpPanelService
00018 {
00019     public:
00020
00022         BtAvrcpPanelServiceImpl();
00023
00025         virtual ~BtAvrcpPanelServiceImpl();
00026
00028         void Init(Application* app);
00029
00031         virtual ServiceResult RegisterAvrcpApp (WString& app_name, BtAvrcpCommandInterface& cmd_handle, MmiSubUnitType sub_unit_info) const;
00032
00034         virtual ServiceResult DeregisterAvrcpApp (WString& app_name) const;
00035
00036     private:
00037         Application* m_app;
00038
00039 };
00040
00041 #endif // BtAvrcpPanelServiceImpl_hpp
00042
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPreComp.cpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPreComp.cpp File Reference

#include "BtAvrcpPreComp.hpp"

Include dependency graph for BtAvrcpPreComp.cpp:

Generated on Tue Jan 24 23:41:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPreComp.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpPreComp.hpp File Reference

#include <Common/CommonMsgTypes.hpp>

Include dependency graph for BtAvrcpPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Mmi_BtAvrcpPreComp_hpp

Define Documentation

#define Mmi_BtAvrcpPreComp_hpp

Generated on Tue Jan 24 23:41:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpPreComp.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_BtAvrcpPreComp_hpp)
00010 #define Mmi_BtAvrcpPreComp_hpp
00011
00012 //#include <Kernel/Os/Win32/Win32.hpp>
00013 //#include <Kernel/Lib.hpp>
00014 //#include <Auxiliary/Lib.hpp>
00015 //#include <Gui/Lib.hpp>
00016 //#include <Asc/Lib.hpp>
00017 #include <Common/CommonMsgTypes.hpp>
00018
00019 #endif// Mmi_BtAvrcpPreComp_hpp
00020
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpProfileService.cpp File Reference

Applications/BluetoothAvrcp/BtAvrcpProfileService.cpp File Reference

#include "BtAvrcpPreComp.hpp"
#include "BtAvrcpPanelApplication.hpp"
#include "BtAvrcpProfileService.hpp"

Include dependency graph for BtAvrcpProfileService.cpp:

Generated on Tue Jan 24 23:41:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp File Reference

Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp File Reference

#include <Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp>
#include <Bluetooth/AVRCP/BtAvrcpOperationService.hpp>
#include "BtAvrcpAlertMessageWindow.hpp"

Include dependency graph for BtAvrcpProfileService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAvrcpProfileOperationService
class | BtAvrcpProfileRegistrationService

Defines

#define | BtAvrcpPanelProfileService_hpp

Define Documentation

#define BtAvrcpPanelProfileService_hpp

Generated on Tue Jan 24 23:41:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp Source File

Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtAvrcpPanelProfileService_hpp)
00009 #define BtAvrcpPanelProfileService_hpp
00010
00011 #include <Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp>
00012 #include <Bluetooth/AVRCP/BtAvrcpOperationService.hpp>
00013 #include "BtAvrcpAlertMessageWindow.hpp"
00014
00015 /*  ------------------------------------------------------------------------
00016     forward declartions
00017     ------------------------------------------------------------------------ */
00018 class BtAvrcpAlertMessageWindow;
00019 class BtAvrcpControllerApplicationWindow;
00020
00021 /*  ------------------------------------------------------------------------
00022     BtAvrcpProfileRegistrationService
00023     ------------------------------------------------------------------------ */
00024 class BtAvrcpProfileRegistrationService: public BtAvrcpRegistrationService
00025 {
00026     private:
00027         typedef BtAvrcpRegistrationService Base;
00028
00029     public:
00032         BtAvrcpProfileRegistrationService(BtAvrcpAlertMessageWindow& alert_message_window);
00033
00036         virtual ~BtAvrcpProfileRegistrationService();
00037
00038     protected:
00041         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00042
00045         void OnRegister(BtRequestState old_request_state, BtRequestState new_request_state);
00046
00049         void OnDeRegister(BtRequestState old_request_state, BtRequestState new_request_state);
00050     private:
00052         BtAvrcpAlertMessageWindow& m_alert_message_window;
00053 };
00054
00055 /*  ------------------------------------------------------------------------
00056     BtAvrcpProfileOperationService
00057     ------------------------------------------------------------------------ */
00058 class BtAvrcpProfileOperationService: public BtAvrcpOperationService
00059 {
00060     private:
00061         typedef BtAvrcpOperationService Base;
00062
00063     public:
00066         BtAvrcpProfileOperationService(BtAvrcpPanelApplication& panel_app, BtAvrcpAlertMessageWindow& alert_message_window, BtAvrcpControllerApplicationWindow& controller_win);
00067
00070         virtual ~BtAvrcpProfileOperationService();
00071
00072     protected:
00075         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00076
00079         void OnConnect(BtRequestState old_request_state, BtRequestState new_request_state);
00080
00083         void OnDisconnect(BtRequestState old_request_state, BtRequestState new_request_state);
00084
00087         void OnPanelPassthrough(BtRequestState old_request_state, BtRequestState new_request_state);
00088
00091         void OnRawFrame(BtRequestState old_request_state, BtRequestState new_request_state);
00092
00095         void OnUnitInfo(BtRequestState old_request_state, BtRequestState new_request_state);
00096
00099         void OnSubunitInfo(BtRequestState old_request_state, BtRequestState new_request_state);
00100
00103         virtual void OnPanelPassThrough(BtAvrcpPanelPassThroughParams ppt_params);
00104
00107         virtual void OnRawFrame(BtAvrcpRawFrameParams raw_frame_paras);
00108
00109     private:
00111         BtAvrcpAlertMessageWindow& m_alert_message_window;
00113         BtAvrcpPanelApplication& m_panel_app;
00115         BtAvrcpControllerApplicationWindow& m_controller_win;
00116
00117 };
00118
00119 #endif /* BtAvrcpPanelProfileService_hpp */
00120
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtActiveDeviceWindow.cpp File Reference

Applications/BtApp/BtActiveDeviceWindow.cpp File Reference

#include "PreComp.hpp"
#include "BtActiveDeviceWindow.hpp"
#include "BtMsgTypes.hpp"

Include dependency graph for BtActiveDeviceWindow.cpp:

Generated on Tue Jan 24 23:41:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtActiveDeviceWindow.hpp File Reference

Applications/BtApp/BtActiveDeviceWindow.hpp File Reference

#include <Gui/Action.hpp>
#include <GuiExtensions/MmiWindow.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <BtApp/BtApplicationWindows.hpp>
#include <BtApp/BtApplicationRequests.hpp>

Include dependency graph for BtActiveDeviceWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtActiveDeviceWindow

Defines

#define | BtActiveDeviceWindow_hpp

Define Documentation

#define BtActiveDeviceWindow_hpp

Generated on Tue Jan 24 23:41:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtActiveDeviceWindow.hpp Source File

Applications/BtApp/BtActiveDeviceWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtActiveDeviceWindow_hpp)
00009 #define BtActiveDeviceWindow_hpp
00010
00011 #include <Gui/Action.hpp>
00012 #include <GuiExtensions/MmiWindow.hpp>
00013 #include <Bluetooth/BtDevice.hpp>
00014 #include <BtApp/BtApplicationWindows.hpp>
00015 #include <BtApp/BtApplicationRequests.hpp>
00016
00020 class BtActiveDeviceWindow : public MmiWindow
00021 {
00022     private:
00023         typedef MmiWindow Base;
00024
00025     public:
00027         BtActiveDeviceWindow();
00028
00030         virtual ~BtActiveDeviceWindow();
00031
00033
00035         void Init();
00036
00038
00040         void SetActiveDevice(const BtDevice& active_device);
00041
00043
00045         BtDevice& GetActiveDevice() { return m_active_device;}
00046
00047
00048     protected:
00050
00052         virtual void OnOpen();
00053
00054
00055     private:
00056
00057
00058         BtDevice                m_active_device;
00059
00060         TextBox                 m_text_box;
00061
00062         WString                 m_device_name;
00063
00064 };
00065
00066
00067 #endif /* BtActiveDeviceWindow_hpp */
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplication.cpp File Reference

Applications/BtApp/BtApplication.cpp File Reference

#include "PreComp.hpp"
#include <Atl/AtlMsgTypes.hpp>
#include <Atl/Properties/PropertyItem.hpp>
#include <Common/MmiInfoBox.hpp>
#include <Common/FeatureBroker/FeaturePool.hpp>
#include <BtApp/BtMsgTypes.hpp>
#include "BtLocalSettingsWindows.hpp"
#include "BtDeviceListsWindows.hpp"
#include "BtApplication.hpp"

Include dependency graph for BtApplication.cpp:

Generated on Tue Jan 24 23:41:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplication.hpp File Reference

Applications/BtApp/BtApplication.hpp File Reference

#include <Common/MmiApplication.hpp>
#include <Bluetooth/BtLocalSettings.hpp>
#include <BtApp/BtLocalSettingsWindows.hpp>
#include <BtApp/BtDeviceListsWindows.hpp>
#include <BtApp/BtApplicationRequests.hpp>
#include <Bluetooth/BtGapAndSdapApplicationMessage.hpp>
#include <BtApp/BtActiveDeviceWindow.hpp>
#include <Atl/Features/Feature.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Bluetooth/BtTypes.hpp>

Include dependency graph for BtApplication.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtApplication

Defines

#define | Bt_Application_hpp

Define Documentation

#define Bt_Application_hpp

Generated on Tue Jan 24 23:41:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplication.hpp Source File

Applications/BtApp/BtApplication.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Bt_Application_hpp)
00009 #define Bt_Application_hpp
00010
00011 #include <Common/MmiApplication.hpp>
00012
00013 #include <Bluetooth/BtLocalSettings.hpp>
00014 #include <BtApp/BtLocalSettingsWindows.hpp>
00015 #include <BtApp/BtDeviceListsWindows.hpp>
00016 #include <BtApp/BtApplicationRequests.hpp>
00017 #include <Bluetooth/BtGapAndSdapApplicationMessage.hpp>
00018 #include <BtApp/BtActiveDeviceWindow.hpp>
00019 #include <Atl/Features/Feature.hpp>
00020 #include <Atl/Features/FeatureBroker.hpp>
00021 #include <Bluetooth/BtTypes.hpp>
00022
00023
00024
00029 class BtApplication : public MmiApplication
00030 {
00031     private:
00032         typedef MmiApplication Base;
00033
00034     public:
00036
00038         static BtApplication* GetInstance();
00039
00041         virtual ~BtApplication();
00042
00043
00044         BtActiveDeviceWindow* GetActiveDeviceWindow(){return &m_active_device_window;}
00045
00046         BtDeviceListWindow* GetDeviceListWindow(){return &m_device_list_window;}
00047         BtLocalSettings* GetLocalSettings() {return &m_local_settings;}
00048         virtual void OnStartup();
00049         void BtFeatureSetAvailable(const FeatureID &feature_id, BOOLEAN available);
00050         void BtRemoteDeviceListOptions();
00051         void SetIndicatorVisible(const String& str, BOOLEAN visible);
00052
00053
00054     private:
00056
00058         BtApplication();
00059
00060     protected:
00062
00064         virtual void OnOpen();
00065
00067
00069         virtual void OnClose();
00070
00072
00074         virtual BOOLEAN OnMessage(const Message &message);
00076         virtual BOOLEAN OnPropertyNotification(const Property::Notification notification, const Property* property, const DataItem &value);
00078         virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00079
00085         BOOLEAN OnPasskeyRequired(const BtPasskeyRequiredMessage& message);
00086
00087
00096         BOOLEAN OnAuthorizationRequired(const BtAuthorizationRequiredMessage& message);
00097
00098         // Is called, when a bt service has been actived(such as DUN,FAX...)
00099         virtual void OnBtActivated(BtProfile profile, BOOLEAN connected);
00100
00101
00102
00103     private:
00105
00107         void CreateFeatureItems(void);
00108
00109         BOOLEAN OnRequestOperation(BtOperationPtr operation);
00110     private:
00111         // enum type for FeatureItems
00112         enum BtItemIds
00113         {
00115             BtDeviceListFeature,
00117             BtActiveDeviceFeature,
00119             BtOnOffFeature,
00121             BtSearchDeviceFeature,
00123             BtSearchProfileFeature,
00125             BtPairFeature,
00127             BtUnpairFeature,
00129             BtTrustFeature,
00131             BtUntrustFeature,
00133             BtShowDetailsFeature,
00135             BtObexSelectFeature,
00137             BtDeviceSearchMode,
00139             BtLastFeature
00140         };
00141
00142         //enum for properties
00143         enum BtProperty {
00144             BtLocalName,
00145             BtDiscoverable,
00146             BtPairable,
00147             BtConnectable,
00148             BtSetRemoteName,
00149             BtPropertyCnt
00150         };
00151
00152
00153         INT GetPropertyID(FeatureID id) const;
00154
00155         //Feature Items
00156         Feature     m_feature[BtLastFeature];
00157
00158         //Property Items
00159         Property            m_property[BtPropertyCnt];
00160
00162         BtPasskeyRequiredWindow         m_passkey_required_window;
00163
00165         BtAuthorizationRequiredWindow   m_authorization_required_window;
00166
00168         BtDeviceListWindow              m_device_list_window;
00169
00171         BtActiveDeviceWindow            m_active_device_window;
00172
00174         BtDeviceList                    m_device_list;
00175
00177         BtLocalSettings                 m_local_settings;
00179         BtTurnOnOffWindow        m_turn_on_off_window;
00180         BtDevice                  m_device;
00181         BtDeviceSearchModeWindow  m_device_search_mode_window;
00183         static BtApplication m_application;
00184
00185 };
00186
00187 #endif  // BtApp_hpp
00188
00189
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplicationRequests.cpp File Reference

Applications/BtApp/BtApplicationRequests.cpp File Reference

#include "PreComp.hpp"
#include "BtApplication.hpp"
#include "BtApplicationRequests.hpp"
#include <Common/MmiAlert.hpp>

Include dependency graph for BtApplicationRequests.cpp:

Generated on Tue Jan 24 23:42:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplicationRequests.hpp File Reference

Applications/BtApp/BtApplicationRequests.hpp File Reference

#include <Bluetooth/BtSendPasskeyRequest.hpp>
#include <Bluetooth/BtRespondAuthorizationRequest.hpp>
#include <Bluetooth/BtDevicePairRequest.hpp>
#include <Bluetooth/BtDeviceUnpairRequest.hpp>
#include <Bluetooth/BtDeviceTrustRequest.hpp>
#include <Bluetooth/BtDeviceUntrustRequest.hpp>
#include <Bluetooth/BtSetRemoteDeviceNameRequest.hpp>
#include <Bluetooth/BtQuerySupportedProfilesRequest.hpp>
#include <Bluetooth/BtDeviceSearchRequest.hpp>
#include <Bluetooth/BtServiceVerifyRequest.hpp>

Include dependency graph for BtApplicationRequests.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtApplicationDevicePairRequest
class | BtApplicationDeviceSearchRequest
class | BtApplicationDeviceTrustRequest
class | BtApplicationDeviceUnpairRequest
class | BtApplicationDeviceUntrustRequest
class | BtApplicationQuerySupportedProfilesRequest
class | BtApplicationRespondAuthorizationRequest
class | BtApplicationSendPasskeyRequest
class | BtApplicationServiceVerifyRequest
class | BtApplicationSetRemoteDeviceNameRequest

Defines

#define | BtApplicationRequests_hpp

Define Documentation

#define BtApplicationRequests_hpp

Generated on Tue Jan 24 23:42:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplicationRequests.hpp Source File

Applications/BtApp/BtApplicationRequests.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtApplicationRequests_hpp)
00009 #define BtApplicationRequests_hpp
00010
00011 #include <Bluetooth/BtSendPasskeyRequest.hpp>
00012 #include <Bluetooth/BtRespondAuthorizationRequest.hpp>
00013 #include <Bluetooth/BtDevicePairRequest.hpp>
00014 #include <Bluetooth/BtDeviceUnpairRequest.hpp>
00015 #include <Bluetooth/BtDeviceTrustRequest.hpp>
00016 #include <Bluetooth/BtDeviceUntrustRequest.hpp>
00017 #include <Bluetooth/BtSetRemoteDeviceNameRequest.hpp>
00018 #include <Bluetooth/BtQuerySupportedProfilesRequest.hpp>
00019 #include <Bluetooth/BtDeviceSearchRequest.hpp>
00020 #include <Bluetooth/BtServiceVerifyRequest.hpp>
00021
00022 class BtDeviceListWindow;
00023 class BtDeviceDetailWindow;
00024 class BtServiceSupportedWindow;
00025
00026 /*  ------------------------------------------------------------------------
00027     BtApplicationSendPasskeyRequest
00028     ------------------------------------------------------------------------ */
00029
00032 class BtApplicationSendPasskeyRequest : public BtSendPasskeyRequest
00033 {
00034     private:
00035         typedef BtSendPasskeyRequest Base;
00036
00037     public:
00039         BtApplicationSendPasskeyRequest();
00040
00042         virtual ~BtApplicationSendPasskeyRequest();
00043
00044
00045     protected:
00047
00049         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00050
00051 };
00052
00053 /*  ------------------------------------------------------------------------
00054     BtApplicationRespondAuthorizationRequest
00055     ------------------------------------------------------------------------ */
00056
00059 class BtApplicationRespondAuthorizationRequest : public BtRespondAuthorizationRequest
00060 {
00061     private:
00062         typedef BtRespondAuthorizationRequest Base;
00063
00064     public:
00066         BtApplicationRespondAuthorizationRequest();
00067
00069         virtual ~BtApplicationRespondAuthorizationRequest();
00070
00071     protected:
00073
00075         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00076 };
00077
00078 /*  ------------------------------------------------------------------------
00079     BtApplicationDevicePairRequest
00080     ------------------------------------------------------------------------ */
00081
00085 class BtApplicationDevicePairRequest : public BtDevicePairRequest
00086 {
00087     private:
00088         typedef BtDevicePairRequest Base;
00089
00090     public:
00092         BtApplicationDevicePairRequest(BtDeviceListWindow* device_list_window);
00093
00095         virtual ~BtApplicationDevicePairRequest();
00096
00097     protected:
00099
00101         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00102
00103     private:
00105         BtDeviceListWindow* m_device_list_window;
00106 };
00107
00108 /*  ------------------------------------------------------------------------
00109     BtApplicationDevicePairRequest
00110     ------------------------------------------------------------------------ */
00111
00114 class BtApplicationDeviceUnpairRequest : public BtDeviceUnpairRequest
00115 {
00116     private:
00117         typedef BtDeviceUnpairRequest Base;
00118
00119     public:
00121         BtApplicationDeviceUnpairRequest(BtDeviceListWindow* device_list_window);
00122
00124         virtual ~BtApplicationDeviceUnpairRequest();
00125
00126     protected:
00128
00130         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00131
00132     private:
00134         BtDeviceListWindow* m_device_list_window;
00135 };
00136
00137 /*  ------------------------------------------------------------------------
00138     BtApplicationDeviceTrustRequest
00139     ------------------------------------------------------------------------ */
00140
00143 class BtApplicationDeviceTrustRequest : public BtDeviceTrustRequest
00144 {
00145     private:
00146         typedef BtDeviceTrustRequest Base;
00147
00148     public:
00150         BtApplicationDeviceTrustRequest(BtDeviceListWindow* device_list_window);
00151
00153         virtual ~BtApplicationDeviceTrustRequest();
00154
00155     protected:
00157
00159         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00160
00161     private:
00163         BtDeviceListWindow* m_device_list_window;
00164 };
00165
00166 /*  ------------------------------------------------------------------------
00167     BtApplicationDeviceUntrustRequest
00168     ------------------------------------------------------------------------ */
00169
00172 class BtApplicationDeviceUntrustRequest : public BtDeviceUntrustRequest
00173 {
00174     private:
00175         typedef BtDeviceUntrustRequest Base;
00176
00177     public:
00179         BtApplicationDeviceUntrustRequest(BtDeviceListWindow* device_list_window);
00180
00182         virtual ~BtApplicationDeviceUntrustRequest();
00183
00184     protected:
00186
00188         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00189
00190     private:
00192         BtDeviceListWindow* m_device_list_window;
00193 };
00194
00195 /*  ------------------------------------------------------------------------
00196     BtApplicationQuerySupportedProfilesRequest
00197     ------------------------------------------------------------------------ */
00198
00201 class BtApplicationQuerySupportedProfilesRequest : public BtQuerySupportedProfilesRequest
00202 {
00203     private:
00204         typedef BtQuerySupportedProfilesRequest Base;
00205
00206     public:
00208         BtApplicationQuerySupportedProfilesRequest(BtDeviceDetailWindow* device_detail_window);
00209         BtApplicationQuerySupportedProfilesRequest(BtDeviceListWindow* device_list_window);
00210
00211         enum BtQueryRequestSupportWinType
00212         {
00213             TDeviceDetail,
00214             TDeviceList
00215         };
00217         virtual ~BtApplicationQuerySupportedProfilesRequest();
00218
00219     protected:
00221
00223         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00224
00225     private:
00226         BtQueryRequestSupportWinType m_type;
00228         BtDeviceDetailWindow* m_device_detail_window;
00229         BtDeviceListWindow* m_device_list_window;
00230 };
00231
00232 /*  ------------------------------------------------------------------------
00233     BtApplicationSetRemoteDeviceNameRequest
00234     ------------------------------------------------------------------------ */
00235
00238 class BtApplicationSetRemoteDeviceNameRequest : public BtSetRemoteDeviceNameRequest
00239 {
00240     private:
00241         typedef BtSetRemoteDeviceNameRequest Base;
00242
00243     public:
00245         BtApplicationSetRemoteDeviceNameRequest(BtDeviceListWindow* device_list_window);
00246
00248         virtual ~BtApplicationSetRemoteDeviceNameRequest();
00249
00250     protected:
00252
00254         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00255
00256     private:
00258         BtDeviceListWindow* m_device_list_window;
00259
00260 };
00261
00262 /*  ------------------------------------------------------------------------
00263     BtApplicationDeviceSearchRequest
00264     ------------------------------------------------------------------------ */
00265
00268 class BtApplicationDeviceSearchRequest : public BtDeviceSearchRequest
00269 {
00270     private:
00271         typedef BtDeviceSearchRequest Base;
00272
00273     public:
00275         BtApplicationDeviceSearchRequest(BtDeviceListWindow* device_list_window);
00276
00278         virtual ~BtApplicationDeviceSearchRequest();
00279
00281         void CancelSearchRequest();
00282
00283     protected:
00285
00287         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00288
00290         virtual void OnRemoteDeviceName(const BtDevice& remote_device, const WString& remote_device_name);
00291
00292     private:
00294         BtDeviceListWindow* m_device_list_window;
00295 };
00296
00297 /*  ------------------------------------------------------------------------
00298     BtApplicationServiceVerifyRequest
00299     ------------------------------------------------------------------------ */
00300
00303 class BtApplicationServiceVerifyRequest: public BtServiceVerifyRequest
00304 {
00305     private:
00306         typedef BtServiceVerifyRequest Base;
00307
00308     public:
00310         BtApplicationServiceVerifyRequest(BtDeviceListWindow* device_list_window);
00311
00313         virtual ~BtApplicationServiceVerifyRequest();
00314
00315     protected:
00317
00319         virtual void OnRequestStateChange(BtRequestState old_request_state, BtRequestState new_request_state);
00320
00321     private:
00323         BtDeviceListWindow* m_device_list_window;
00324 };
00325
00326 #endif /* BtApplicationRequests_hpp */
00327
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplicationWindows.cpp File Reference

Applications/BtApp/BtApplicationWindows.cpp File Reference

#include "PreComp.hpp"
#include "BtApplicationWindows.hpp"

Include dependency graph for BtApplicationWindows.cpp:

Generated on Tue Jan 24 23:42:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplicationWindows.hpp File Reference

Applications/BtApp/BtApplicationWindows.hpp File Reference

#include <Common/MmiAlert.hpp>
#include <Common/MmiWaitingBox.hpp>
#include <BtApp/BtApplicationRequests.hpp>

Include dependency graph for BtApplicationWindows.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtAlertMessageWindow
class | BtAuthorizationRequiredWindow
class | BtPasskeyRequiredWindow
class | BtRequestRunningWindow

Defines

#define | BtApplicationWindows_hpp

Define Documentation

#define BtApplicationWindows_hpp

Generated on Tue Jan 24 23:42:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtApplicationWindows.hpp Source File

Applications/BtApp/BtApplicationWindows.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtApplicationWindows_hpp)
00009 #define BtApplicationWindows_hpp
00010
00011 #include <Common/MmiAlert.hpp>
00012 #include <Common/MmiWaitingBox.hpp>
00013 #include <BtApp/BtApplicationRequests.hpp>
00014
00018 class BtAlertMessageWindow : public MmiAlert
00019 {
00020     private:
00021         typedef MmiAlert Base;
00022
00023     public:
00024         // Enumeration for text display in allert box
00025         typedef enum
00026         {
00027             // Pairing
00028             BtAmwPair,
00029             // Unpairing
00030             BtAmwUnpair,
00031             // Trusing
00032             BtAmwTrust,
00033             // Untrusting
00034             BtAmwUntrust,
00035             // Setting remote device name
00036             BtAmwSetName,
00037             // Querying the supported accessory profiles
00038             BtAmwQuerySupportedProfiles,
00039             // DUN connection established notification
00040             BtAmwDunConnect,
00041             // DUN connection released notification
00042             BtAmwDunDisconnect,
00043             //HS connection established notification
00044             BtAmwHsConnect,
00045             //HS connection released notification
00046             BtAmwHsDisconnect,
00047             //HS call transfer to phone notification
00048             BtAmwHsCallTransferToPhone,
00049             //HS call transfer to headset notification
00050             BtAmwHsCallTransferToHeadset,
00051             //
00052             BtAmwHfConnect,
00053             //
00054             BtAmwHfDisconnect,
00055             //
00056             BtAmwHfAudio2Phone,
00057             //
00058             BtAmwHfAudio2Hf,
00059             //FAX connection established notification
00060             BtAmwFaxConnect,
00061             //FAX connection released notification
00062             BtAmwFaxDisconnect,
00063             // to inform use supported profile
00064             BtAmwSupportedProfile,
00065             // Service Verify
00066             BtAmwServiceVerify
00067
00068         } BtAmwType;
00069
00071         BtAlertMessageWindow();
00072
00074         virtual ~BtAlertMessageWindow();
00075
00077
00079         void Init();
00080
00082
00084         void Display(BtAmwType amw_type, BOOLEAN success);
00085 };
00086
00091 class BtRequestRunningWindow : public MmiWaitingBox
00092 {
00093     private:
00094         typedef MmiWaitingBox Base;
00095
00096     public:
00097         // Enumeration for text display in allert box
00098         typedef enum
00099         {
00100             // Unknwon Request running
00101             BtRrwUnknown = -1,
00102             // Pairing
00103             BtRrwPair,
00104             // Unpairing
00105             BtRrwUnpair,
00106             // Trusing
00107             BtRrwTrust,
00108             // Untrusting
00109             BtRrwUntrust,
00110             // Setting remote device name
00111             BtRrwSetName,
00112             // Querying the supported accessory profiles
00113             BtRrwQuerySupportedProfiles,
00114             // Searching devices
00115             BtRrwDeviceSearch,
00116             // Dun disconnect
00117             BtRrwDunDisconnect,
00118             //HS connect
00119             BtRrwHsConnect,
00120             //HS disconnect
00121             BtRrwHsDisconnect,
00122             //HS call transfer to phone
00123             BtRrwHsCallTransferToPhone,
00124             //HS call transfer to headset
00125             BtRrwHsCallTransferToHeadset,
00126             //
00127             BtRrwHfConnect,
00128             //
00129             BtRrwHfDisconnect,
00130             //
00131             BtRrwHfAudio2Hf,
00132             //
00133             BtRrwHfAudio2Phone,
00134             //FAX disconnect
00135             BtRrwFaxDisconnect,
00136             // Service Verify
00137             BtRrwServiceVerify
00138         } BtRrwType;
00139
00140     public:
00142         BtRequestRunningWindow();
00143
00145         virtual ~BtRequestRunningWindow();
00146
00148
00150         void Init();
00151
00153
00155         void SetType(BtRrwType type);
00156
00158
00160         void SetCancelableRequest(BtCancelableRequest* cancelable_request);
00161
00163
00165         BtCancelableRequest* GetCancelableRequest();
00166
00168
00170         const BtCancelableRequest* GetCancelableRequest() const;
00171
00172     protected:
00174
00176         virtual void OnOpen();
00177
00179
00181         virtual BOOLEAN OnCancel();
00182
00184
00186     //  virtual BOOLEAN OnMessage(const Message& message);
00187         void OnRequestCancel();
00188
00189
00190     private:
00192         BtRrwType m_type;
00193
00195         BtCancelableRequest* m_cancelable_request;
00196 };
00197
00200 class BtPasskeyRequiredWindow : public MmiWindow
00201 {
00202     private:
00203         typedef MmiWindow Base;
00204
00205     public:
00207         BtPasskeyRequiredWindow();
00208
00210         virtual ~BtPasskeyRequiredWindow();
00211
00213
00215         void Init();
00216
00218
00220         void SetRemoteDeviceAddress(const BtDeviceAddress& remote_device_address);
00221
00223
00225         void SetRemoteDeviceName(const WString& remote_device_name);
00226
00227     protected:
00229
00231         virtual BOOLEAN OnTimeout(const Timer &timer);
00232
00234
00236         virtual BOOLEAN OnMessage(const Message& message);
00237
00239
00241         virtual void OnOpen();
00242
00244
00246         virtual void OnLayoutClient();
00247
00249
00251         virtual BOOLEAN OnConfirm();
00252
00254
00256         virtual BOOLEAN OnKeyDown(KeyCode code);
00257
00258         virtual BOOLEAN OnCancel();
00259
00260     private:
00261         void Cleanup();
00263         BtDeviceAddress m_remote_device_address;
00264         WString         m_remote_device_name;
00265
00267         TextBox        m_passkey_caption;
00268         PasswordEditor m_passkey_edit;
00269
00270         Timer           m_timer;
00272         BtApplicationSendPasskeyRequest m_send_passkey_request;
00273 };
00274
00278 class BtAuthorizationRequiredWindow : public MmiWindow
00279 {
00280     private:
00281         typedef MmiWindow Base;
00282
00283     public:
00285         BtAuthorizationRequiredWindow();
00286
00288         virtual ~BtAuthorizationRequiredWindow();
00289
00291
00293         void Init();
00294
00296
00298         void SetRemoteDeviceAddress(const BtDeviceAddress& remote_device_address);
00299
00301
00303         void SetRemoteDeviceName(const WString& remote_device_name);
00304
00306
00308         void SetProfile(BtProfile profile);
00309
00310     protected:
00312
00314         virtual void OnOpen();
00315
00317
00319         virtual void OnLayoutClient();
00320
00322
00324         virtual BOOLEAN OnConfirm();
00325
00327
00329         virtual BOOLEAN OnKeyDown(KeyCode code);
00330
00331         virtual BOOLEAN OnCancel();
00332
00333
00334
00335     private:
00336
00337         void Cleanup();
00338
00339         BtDeviceAddress m_remote_device_address;
00340         WString         m_remote_device_name;
00341         BtProfile       m_profile;
00342
00344         TextBox m_authorization_caption;
00345
00347         ItemMenu m_item_menu;
00348
00350         RadioButtonGroup  m_radio_button_group;
00351         RadioButtonAction m_trust_action;
00352         RadioButtonAction m_untrust_action;
00353
00355         BtApplicationRespondAuthorizationRequest m_respond_authorization_request;
00356 };
00357
00358
00359
00360 #endif /* BtApplicationWindows_hpp*/
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDeviceDetailWindow.cpp File Reference

Applications/BtApp/BtDeviceDetailWindow.cpp File Reference

#include "PreComp.hpp"
#include <Common/MmiInfoBox.hpp>
#include "BtDeviceDetailWindow.hpp"
#include "BtMsgTypes.hpp"

Include dependency graph for BtDeviceDetailWindow.cpp:

Generated on Tue Jan 24 23:43:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDeviceDetailWindow.hpp File Reference

Applications/BtApp/BtDeviceDetailWindow.hpp File Reference

#include <Common/MmiWindow.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <BtApp/BtApplicationWindows.hpp>
#include <BtApp/BtApplicationRequests.hpp>

Include dependency graph for BtDeviceDetailWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceDetailWindow

Defines

#define | BtDeviceDetailWindow_hpp

Define Documentation

#define BtDeviceDetailWindow_hpp

Generated on Tue Jan 24 23:43:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDeviceDetailWindow.hpp Source File

Applications/BtApp/BtDeviceDetailWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceDetailWindow_hpp)
00009 #define BtDeviceDetailWindow_hpp
00010
00011 #include <Common/MmiWindow.hpp>
00012 #include <Bluetooth/BtDevice.hpp>
00013 #include <BtApp/BtApplicationWindows.hpp>
00014 #include <BtApp/BtApplicationRequests.hpp>
00015
00016
00020 class BtDeviceDetailWindow : public MmiWindow
00021 {
00022     private:
00023         typedef MmiWindow Base;
00024
00025     public:
00027         BtDeviceDetailWindow();
00028
00030         virtual ~BtDeviceDetailWindow();
00031
00033
00035         void Init();
00036
00038
00040         const BtDevice& GetDevice();
00041
00043
00045         void SetDevice(const BtDevice& device);
00046
00047         void OnSupportedProfileSearch();
00048
00049
00050
00051     protected:
00053
00055         virtual void OnOpen();
00056
00057         void OnRequestFinished(BOOLEAN success);
00058
00059
00060     private:
00061
00063
00065         void GetDeviceAndServiceClassString();
00066
00067
00068     private:
00069
00071         BtDevice m_device;
00072
00073         enum CaptionList
00074         {
00075             MaCaptionDeviceName,
00076             MaCaptionDeviceAddress,
00077             MaCaptionDeviceStatus,
00078             MaCaptionConnected,
00079             MaCaptionMajorDeviceClass,
00080             MaCaptionServiceClass,
00081             MaCaptionLast
00082         };
00083
00085         WString     m_caption_list[MaCaptionLast];
00086
00087         enum ValueList
00088         {
00089             MaValueDeviceName,
00090             MaValueDeviceAddress,
00091             MaValueDeviceStatus,
00092             MaValueConnected,
00093             MaValueMajorDeviceClass,
00094             MaValueServiceClass,
00095             MaValueLast
00096         };
00097
00099         WString     m_value_list[MaValueLast];
00100
00101
00102         WString     m_device_name;
00103         WString     m_device_address;
00104
00105
00106         MultiLineEditor     m_multiline_editor;
00107
00108         WString     m_editor_string;
00109
00111         BtAlertMessageWindow m_alert_message_window;
00112         BtRequestRunningWindow m_request_running_window;
00113
00115         BtApplicationQuerySupportedProfilesRequest m_query_supported_profiles_request;
00116
00117     private:
00118         friend class BtApplicationQuerySupportedProfilesRequest;
00119 };
00120
00121
00122
00123 #endif /* BtDeviceListsWindows_hpp */
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDeviceListsWindows.cpp File Reference

Applications/BtApp/BtDeviceListsWindows.cpp File Reference

#include "PreComp.hpp"
#include "BtDeviceListsWindows.hpp"
#include "BtMsgTypes.hpp"
#include "BtApplication.hpp"
#include <Config/MmiGuiEngineConfig.hpp>
#include <Common/MmiInfoBox.hpp>
#include <Atl/AtlMsgTypes.hpp>

Include dependency graph for BtDeviceListsWindows.cpp:

Variables

const GenericTypeId | bt_device_address_generic_object_type_id = c_user_base_gentypes + 100
const unsigned int | bt_device_list_address_column_id = 10002
const unsigned int | bt_device_list_device_major_class_column_id = 10003
const unsigned int | bt_device_list_device_minor_class_column_id = 10004
const unsigned int | bt_device_list_name_column_id = 10001
const unsigned int | bt_device_list_provider_id = 10000

Variable Documentation

const GenericTypeId bt_device_address_generic_object_type_id = c_user_base_gentypes + 100

const unsigned int bt_device_list_address_column_id = 10002

const unsigned int bt_device_list_device_major_class_column_id = 10003

const unsigned int bt_device_list_device_minor_class_column_id = 10004

const unsigned int bt_device_list_name_column_id = 10001

const unsigned int bt_device_list_provider_id = 10000

Generated on Tue Jan 24 23:43:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDeviceListsWindows.hpp File Reference

Applications/BtApp/BtDeviceListsWindows.hpp File Reference

#include <Auxiliary/Provider.hpp>
#include <Auxiliary/GenericObject.hpp>
#include <Gui/ItemMenu.hpp>
#include <Atl/Gui/AtlItemListWindow.hpp>
#include <Atl/Features/ProviderProxyContainer.hpp>
#include <Bluetooth/BtDevice.hpp>
#include <Bluetooth/BtDeviceList.hpp>
#include <Bluetooth/BtDeviceListIterator.hpp>
#include <Bluetooth/BtLocalSettings.hpp>
#include <Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp>
#include <Bluetooth/BtOperationSelectDevice.hpp>
#include <BtApp/BtApplicationWindows.hpp>
#include <BtApp/BtApplicationRequests.hpp>
#include <BtApp/BtDeviceDetailWindow.hpp>

Include dependency graph for BtDeviceListsWindows.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceAddressGenericObject
class | BtDeviceListItem
class | BtDeviceListProvider
class | BtDeviceListWindow

Defines

#define | BtDeviceListsWindows_hpp

Define Documentation

#define BtDeviceListsWindows_hpp

Generated on Tue Jan 24 23:43:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDeviceListsWindows.hpp Source File

Applications/BtApp/BtDeviceListsWindows.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDeviceListsWindows_hpp)
00009 #define BtDeviceListsWindows_hpp
00010
00011 #include <Auxiliary/Provider.hpp>
00012 #include <Auxiliary/GenericObject.hpp>
00013 #include <Gui/ItemMenu.hpp>
00014 #include <Atl/Gui/AtlItemListWindow.hpp>
00015 #include <Atl/Features/ProviderProxyContainer.hpp>
00016 #include <Bluetooth/BtDevice.hpp>
00017 #include <Bluetooth/BtDeviceList.hpp>
00018 #include <Bluetooth/BtDeviceListIterator.hpp>
00019 #include <Bluetooth/BtLocalSettings.hpp>
00020 #include <Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp>
00021 #include <Bluetooth/BtOperationSelectDevice.hpp>
00022 #include <BtApp/BtApplicationWindows.hpp>
00023 #include <BtApp/BtApplicationRequests.hpp>
00024 #include <BtApp/BtDeviceDetailWindow.hpp>
00025
00026
00027
00030 class BtDeviceAddressGenericObject : public GenericObject
00031 {
00032     private:
00033         typedef GenericObject Base;
00034
00035     public:
00037         BtDeviceAddressGenericObject();
00038
00040
00042         BtDeviceAddressGenericObject(const BtDeviceAddressGenericObject& generic_object);
00043
00045
00047         BtDeviceAddressGenericObject(const BtDeviceAddress& device_address);
00048
00050         virtual ~BtDeviceAddressGenericObject();
00051
00053
00055         virtual GenericObject* Copy() const;
00056
00058
00060         virtual BOOLEAN IsEqual(GenericObject* object);
00061
00063
00065         virtual GenericTypeId GetTypeId();
00066
00069         const BtDeviceAddress& GetDeviceAddress() const;
00070
00071     private:
00073         BtDeviceAddress m_device_address;
00074 };
00075
00078 class BtDeviceListProvider : public Provider
00079 {
00080     private:
00081         typedef Provider Base;
00082
00083     public:
00085
00087         BtDeviceListProvider(const BtDeviceList* device_list);
00088
00090         virtual ~BtDeviceListProvider();
00091
00093
00095         void SetDeviceList(const BtDeviceList* device_list);
00096
00098
00100         virtual INT GetProviderId() const;
00101
00103
00105         virtual Status GetStatus() const;
00106
00108
00110         virtual INT RowCount();
00111
00113
00115         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem& data_item);
00116
00117     protected:
00119
00121         BOOLEAN GetDeviceName(INT index, DataItem& data_item);
00122
00124
00126         BOOLEAN GetDeviceAddress(INT index, DataItem& data_item);
00127
00129
00131         BOOLEAN GetDeviceMajorClass(INT index, DataItem& data_item);
00133
00135         BOOLEAN GetDeviceMinorClass(INT index, DataItem& data_item);
00136
00138
00140         BtDeviceListConstantIterator GetDeviceAtIndex(INT index);
00141
00142     private:
00143         const BtDeviceList* m_device_list;
00144 };
00145
00146
00150 class BtDeviceListItem: public Item
00151 {
00152     private:
00153         typedef Item Base;
00154
00155     public:
00157         BtDeviceListItem(Dispatcher* dispatcher, const WString& device_name, const BtDeviceAddress& device_address);
00158
00160         virtual ~BtDeviceListItem();
00161
00163
00165         const BtDeviceAddress& GetDeviceAddress() const;
00166
00167     private:
00169         BtDeviceAddress m_device_address;
00170 };
00171
00172
00175 class BtDeviceListWindow : public AtlItemListWindow
00176 {
00177     private:
00178         typedef AtlItemListWindow Base;
00179
00180     public:
00183         typedef enum
00184         {
00186             BtDlwPairedDevices,
00188             BtDlwFoundDevices
00189
00190         } BtDeviceListWindowType;
00191
00192     public:
00194         BtDeviceListWindow();
00196         virtual ~BtDeviceListWindow();
00198         void Init();
00200         BtDeviceListWindowType GetType();
00202         void SetType(BtDeviceListWindowType type);
00204         void UpdateConnectProfileSelectedWindow(BOOLEAN open);
00206
00207         BOOLEAN OnFeatureTriggered(const FeatureID &feature_id);
00208
00209         void OnShowDetailsActionExecuted();
00211         void OnPairDeviceActionExecuted();
00213         void OnUnpairDeviceActionExecuted();
00215         void OnTrustDeviceActionExecuted();
00217         void OnUntrustDeviceActionExecuted();
00219         void OnSetDeviceNameActionExecuted();
00221         void OnSearchAgainActionExecuted();
00223         void OnConnectActionExecuted();
00225         void OnRemoteDeviceSetNameNotification(BtDevice device, WString device_name);
00227         void OnRequestFinished(BOOLEAN success);
00229         void OnSupportedProfileSearch();
00232         const WString& GetDeviceName(INT index, Provider* prov);
00234         const BtDeviceAddress& GetDeviceAddress(INT index,  Provider* prov);
00236         const BtDeviceAndServiceClass& GetDeviceClass(INT index, Provider* prov);
00238         const BitmapRes* GetDeviceIcon(INT index, Provider* prov);
00240         void UpdateDeviceList();
00242         BtDeviceListProvider* GetDeviceListProvider() { return &m_device_list_provider; }
00244
00246         BOOLEAN DoRequestOperation(BtOperationPtr operation);
00248         void SetCanSelect(BOOLEAN can_select);
00250         void OnServiceVerifyRequestFinished(BOOLEAN success);
00253         BOOLEAN GetImmediateSearch();
00254         void SetImmediateSearch(BOOLEAN immediate_search);
00255
00256         void OnDeviceNameFound();
00257         void DeviceSearchCancelRequest();
00258         void UpdateOptionMenu(INT index);
00260         void UpdateConnectOptions(BOOLEAN enable);
00262         void OnDeviceSelectActionExecuted();
00264         BtDevice GetSelectedDevice() { return m_selected_device; }
00265
00266     protected:
00268         virtual void OnOpen();
00270         void OnPairDeviceActionFinished(BOOLEAN success);
00272         void OnUnpairDeviceActionFinished(BOOLEAN success);
00274         void OnTrustDeviceActionFinished(BOOLEAN success);
00276         void OnUntrustDeviceActionFinished(BOOLEAN success);
00278         void OnSearchAgainActionFinished(BOOLEAN success);
00280         void OnQuerySupportedProfileFinished(BOOLEAN success);
00282         void UpdateList(void);
00285         void OnServiceVerifyRequestExecuted(const BtDevice& device, const BtUUID* services_to_verify, UINT8 number_of_services_to_verify, const BtAttributeId* attributes_requested, UINT8 number_of_attributes_requested);
00287         void DoOperation(const BtDeviceFilter& device_filter);
00289         void OnOperationFinished();
00291
00292     private:
00293         void ValidateRequest();
00295         BtDeviceListWindowType m_type;
00296         BtDevice m_selected_device;
00297         BtDevice m_obex_selected_device;
00298         BtDeviceList m_device_list;
00299         BtDeviceListProvider m_device_list_provider;
00300
00301         AtlItemListWindow           m_device_list_win;
00302         ProviderProxyContainer      m_device_list_container;
00303         ItemContainer               m_item_cont;
00304         Item                        m_item;
00305         BtApplicationSetRemoteDeviceNameRequest m_set_remote_device_name_request;
00306
00307         BtAlertMessageWindow m_alert_message_window;
00308         BtRequestRunningWindow m_request_running_window;
00309         BtDeviceDetailWindow m_device_detail_window;
00310         BtApplicationDevicePairRequest m_device_pair_request;
00311         BtApplicationDeviceUnpairRequest m_device_unpair_request;
00312         BtApplicationDeviceTrustRequest m_device_trust_request;
00313         BtApplicationDeviceUntrustRequest m_device_untrust_request;
00314         BtApplicationDeviceSearchRequest m_device_search_request;
00315
00316         BtApplicationQuerySupportedProfilesRequest m_query_supported_profiles_request;
00318         BOOLEAN m_can_select;
00319         BtApplicationServiceVerifyRequest m_service_verify_request;
00320         BtOperationPtr m_operation;
00321         BtDeviceAndServiceClass m_device_and_service_class;
00322         BtRequestState m_state;
00323         BtLocalSettings*                    m_local_settings;
00325
00326         WString m_selection_device_name;
00328         BtDeviceAndServiceClass m_device_class;
00330         BtDeviceAddress m_selection_device_address;
00331
00332     private:
00333
00334         friend class BtApplicationDevicePairRequest;
00335         friend class BtApplicationDeviceUnpairRequest;
00336         friend class BtApplicationDeviceSearchRequest;
00337         friend class BtApplicationDeviceTrustRequest;
00338         friend class BtApplicationDeviceUntrustRequest;
00339         friend class BtApplicationQuerySupportedProfilesRequest;
00340         friend class BtApplicationServiceVerifyRequest;
00341 };
00342
00343
00344
00345
00346 #endif /* BtDeviceListsWindows_hpp */
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtLocalSettingsWindows.cpp File Reference

Applications/BtApp/BtLocalSettingsWindows.cpp File Reference

#include "PreComp.hpp"
#include "BtLocalSettingsWindows.hpp"
#include <Afs/Registry.hpp>

Include dependency graph for BtLocalSettingsWindows.cpp:

Generated on Tue Jan 24 23:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtLocalSettingsWindows.hpp File Reference

Applications/BtApp/BtLocalSettingsWindows.hpp File Reference

#include <Gui/Item.hpp>
#include <Gui/Action.hpp>
#include <Gui/ItemMenu.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <Gui/TextLine.hpp>
#include <Gui/LineEditor.hpp>
#include <Common/MmiWindow.hpp>
#include <Bluetooth/BtLocalSettings.hpp>
#include <BtApp/BtDeviceListsWindows.hpp>

Include dependency graph for BtLocalSettingsWindows.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDeviceSearchModeWindow
class | BtTurnOnOffWindow

Defines

#define | BtSettingsDisplayInfoWindow_hpp

Define Documentation

#define BtSettingsDisplayInfoWindow_hpp

Generated on Tue Jan 24 23:50:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtLocalSettingsWindows.hpp Source File

Applications/BtApp/BtLocalSettingsWindows.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtSettingsDisplayInfoWindow_hpp)
00009 #define BtSettingsDisplayInfoWindow_hpp
00010
00011 #include <Gui/Item.hpp>
00012 #include <Gui/Action.hpp>
00013 #include <Gui/ItemMenu.hpp>
00014 #include <Gui/RadioButtonGroup.hpp>
00015 #include <Gui/RadioButtonAction.hpp>
00016 #include <Gui/TextLine.hpp>
00017 #include <Gui/LineEditor.hpp>
00018 #include <Common/MmiWindow.hpp>
00019 #include <Bluetooth/BtLocalSettings.hpp>
00020 #include <BtApp/BtDeviceListsWindows.hpp>
00021
00022 /*  ------------------------------------------------------------------------
00023     BtTurnOnOffWindow
00024     ------------------------------------------------------------------------ */
00025
00028 class BtTurnOnOffWindow : public MmiWindow
00029 {
00030     private:
00031         typedef MmiWindow Base;
00032
00033     public:
00035
00037         BtTurnOnOffWindow();
00038
00040         virtual ~BtTurnOnOffWindow();
00041
00043
00045         void Init(BtLocalSettings* local_settings);
00046
00047     protected:
00049
00051         virtual void OnOpen();
00052
00054
00056         virtual BOOLEAN OnConfirm();
00057
00058
00059     private:
00061         BtLocalSettings* m_local_settings;
00062
00064         ItemMenu m_item_menu;
00065
00067         RadioButtonGroup  m_radio_button_group;
00068         RadioButtonAction m_on_action;
00069         RadioButtonAction m_off_action;
00070
00071 };
00072
00073
00074 /*  ------------------------------------------------------------------------
00075     BtDeviceSearchModeWindow
00076     ------------------------------------------------------------------------ */
00077 static const CHAR* c_bt_device_searchmode_uri = "./BtApp";
00078 static const CHAR* c_bt_device_searchmode_path = "./BtApp/BtAppDeviceListSearchMode";
00079
00082 class BtDeviceSearchModeWindow : public MmiWindow
00083 {
00084     private:
00085         typedef MmiWindow Base;
00086
00087     public:
00089
00091         BtDeviceSearchModeWindow();
00092
00094         virtual ~BtDeviceSearchModeWindow();
00095
00097
00099         void Init(BtDeviceListWindow* device_list_window);
00100
00101     protected:
00103
00105         virtual void OnOpen();
00106
00108
00110         virtual BOOLEAN OnConfirm();
00111
00112     private:
00114         BtDeviceListWindow* m_device_list_window;
00115
00117         ItemMenu m_item_menu;
00118
00120         RadioButtonGroup  m_radio_button_group;
00121         RadioButtonAction m_immediate_action;
00122         RadioButtonAction m_delayed_action;
00123 };
00124
00125
00126 #endif // BtSettingsDisplayInfoWindow_hpp
00127
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtMsgTypes.cpp File Reference

Applications/BtApp/BtMsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "BtMsgTypes.hpp"

Include dependency graph for BtMsgTypes.cpp:

Generated on Tue Jan 24 23:50:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtMsgTypes.hpp File Reference

Applications/BtApp/BtMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Bluetooth/BtTypes.hpp>
#include <Bluetooth/BtDevice.hpp>

Include dependency graph for BtMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtIndicatorMsg

Defines

#define | BtApplication_BtMsgTypes_hpp

Define Documentation

#define BtApplication_BtMsgTypes_hpp

Generated on Tue Jan 24 23:50:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtMsgTypes.hpp Source File

Applications/BtApp/BtMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "UserData\project\huangtr_view_apoxi22\lnz_apps_int\Applications\BtApp\BtMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(BtApplication_BtMsgTypes_hpp)
00016 #define BtApplication_BtMsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Bluetooth/BtTypes.hpp>
00020 #include <Bluetooth/BtDevice.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class BtIndicatorMsg
00029     ====================================================================== */
00030
00032 class BtIndicatorMsg : public Message {
00033     public:
00034         BtIndicatorMsg(const BtProfile& profile, BOOLEAN connected);
00035         virtual ~BtIndicatorMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         const BtProfile& GetProfile() const { return m_profile; }
00039         BOOLEAN IsConnected() const { return m_connected; }
00040         virtual Message* Clone() const;
00041
00042         enum  {
00043             ID = 22500
00044             };
00045
00046     private:
00047         static const MsgMetaData m_meta_data;
00048         BtProfile m_profile;
00049         BOOLEAN m_connected;
00050
00051     };
00052
00053 #endif // BtApplication_BtMsgTypes_hpp
00054
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/PreComp.cpp File Reference

Applications/BtApp/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:16:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/PreComp.hpp File Reference

Applications/BtApp/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Bluetooth/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:25:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/PreComp.hpp Source File

Applications/BtApp/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Gui/Lib.hpp>
00012 #include <Asc/Lib.hpp>
00013 #include <Bluetooth/Lib.hpp>
00014
00015 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.cpp File Reference

Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.cpp File Reference

#include "PreComp.hpp"
#include "BtDunAppPlugin.hpp"
#include <GuiExtensions/MmiAlert.hpp>
#include <BtApp/BtMsgTypes.hpp>

Include dependency graph for BtDunAppPlugin.cpp:

Generated on Tue Jan 24 23:44:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.hpp File Reference

Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.hpp File Reference

#include <Common/MmiApplicationPlugin.hpp>
#include <BtApp/BtApplication.hpp>
#include <BtApp/BtApplicationWindows.hpp>
#include <Bluetooth/DUN/BtDunApplicationMessage.hpp>
#include "BtDunProfileService.hpp"

Include dependency graph for BtDunAppPlugin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDunAppPlugin

Defines

#define | Mmi_BtDunAppPlugin_hpp

Define Documentation

#define Mmi_BtDunAppPlugin_hpp

Generated on Tue Jan 24 23:44:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.hpp Source File

Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_BtDunAppPlugin_hpp)
00009 #define Mmi_BtDunAppPlugin_hpp
00012 #include <Common/MmiApplicationPlugin.hpp>
00013 #include <BtApp/BtApplication.hpp>
00014 #include <BtApp/BtApplicationWindows.hpp>
00015 #include <Bluetooth/DUN/BtDunApplicationMessage.hpp>
00016 #include "BtDunProfileService.hpp"
00017
00018 class BtDunAppPlugin : public MmiApplicationPlugin
00019 {
00020     typedef MmiApplicationPlugin Base;
00021
00022     public:
00023
00024         virtual ~BtDunAppPlugin();
00025
00026         void Init(Application* app);
00027
00028         static BtDunAppPlugin* GetInstance();
00029
00030         virtual BOOLEAN OnMessage(const Message &msg);
00031
00033         /*Remote device and local device both can initiate dun disconnect. In this function
00034         the added menu and indicator should be remove.
00035         */
00036         void OnDunDisconnectRequestFinished(BOOLEAN success);
00037
00038     protected:
00041         virtual void OnAppOpen();
00044         virtual void OnAppClose();
00045         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00046
00047     private:
00048
00049         BtDunAppPlugin();
00050
00052
00056         BOOLEAN OnDunConnect(BtResultCode result, const BtDevice& device);
00057         BOOLEAN OnDunDisconnect(BtResultCode result);
00058         void DoDunDisconnect();
00059
00060
00061     private:
00062
00063         //Action m_dun_disconnect_action;
00064         Feature m_dun_disconnect_feature;
00065         Property m_dun_prop;
00066         static BtDunAppPlugin m_plugin;
00067
00068         BtApplication* m_host_app;
00069
00070         BtDunProfileService m_dun_profile_service;
00071         BtAlertMessageWindow m_alert_message_window;
00072
00073         BtRequestRunningWindow m_request_running_window;
00074
00075
00076 };
00078 #endif  // Mmi_AppPlugin_hpp
00079
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/BtDunProfileService.cpp File Reference

Applications/BtApp/BtDunAppPlugin/BtDunProfileService.cpp File Reference

#include "PreComp.hpp"
#include "BtDunProfileService.hpp"
#include "BtDunAppPlugin.hpp"

Include dependency graph for BtDunProfileService.cpp:

Generated on Tue Jan 24 23:44:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/BtDunProfileService.hpp File Reference

Applications/BtApp/BtDunAppPlugin/BtDunProfileService.hpp File Reference

#include <Bluetooth/DUN/BtDunService.hpp>

Include dependency graph for BtDunProfileService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtDunProfileService

Defines

#define | BtDunProfileService_hpp

Define Documentation

#define BtDunProfileService_hpp

Generated on Tue Jan 24 23:44:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/BtDunProfileService.hpp Source File

Applications/BtApp/BtDunAppPlugin/BtDunProfileService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtDunProfileService_hpp)
00009 #define BtDunProfileService_hpp
00010
00011 #include <Bluetooth/DUN/BtDunService.hpp>
00012
00015 class BtDunProfileService : public BtDunService{
00016     private:
00017
00018     typedef BtDunService Base;
00019
00020     public:
00022         BtDunProfileService();
00023
00025         virtual ~BtDunProfileService();
00026
00027     protected:
00029
00034         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00035 };
00036
00037 #endif /* BtDunProfileService_hpp */
Generated on Tue Jan 24 14:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/PreComp.cpp File Reference

Applications/BtApp/BtDunAppPlugin/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:09:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/PreComp.hpp File Reference

Applications/BtApp/BtDunAppPlugin/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Bluetooth/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:23:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtDunAppPlugin/PreComp.hpp Source File

Applications/BtApp/BtDunAppPlugin/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Gui/Lib.hpp>
00012 #include <Asc/Lib.hpp>
00013 #include <Bluetooth/Lib.hpp>
00014
00015 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.cpp File Reference

Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.cpp File Reference

#include "PreComp.hpp"
#include "BtFaxAppPlugin.hpp"
#include <BtApp/BtMsgTypes.hpp>

Include dependency graph for BtFaxAppPlugin.cpp:

Generated on Tue Jan 24 23:44:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.hpp File Reference

Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.hpp File Reference

#include <Common/MmiApplicationPlugin.hpp>
#include <Bluetooth/FAX/BtFaxApplicationMessage.hpp>
#include <BtApp/BtApplicationWindows.hpp>
#include <BtApp/BtApplication.hpp>
#include "BtFaxProfileService.hpp"

Include dependency graph for BtFaxAppPlugin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtFaxAppPlugin

Defines

#define | Mmi_BtFaxAppPlugin_hpp

Define Documentation

#define Mmi_BtFaxAppPlugin_hpp

Generated on Tue Jan 24 23:44:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.hpp Source File

Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_BtFaxAppPlugin_hpp)
00009 #define Mmi_BtFaxAppPlugin_hpp
00012
00013 #include <Common/MmiApplicationPlugin.hpp>
00014 #include <Bluetooth/FAX/BtFaxApplicationMessage.hpp>
00015 #include <BtApp/BtApplicationWindows.hpp>
00016 #include <BtApp/BtApplication.hpp>
00017 #include "BtFaxProfileService.hpp"
00018
00019 class BtFaxAppPlugin : public MmiApplicationPlugin
00020 {
00021     typedef MmiApplicationPlugin Base;
00022
00023     public:
00024
00025         virtual ~BtFaxAppPlugin();
00026
00027         void Init(Application* app);
00028
00029         static BtFaxAppPlugin* GetInstance();
00030
00031         virtual BOOLEAN OnMessage(const Message &msg);
00032
00033         void OnFaxDisconnectRequestFinished(BOOLEAN success);
00034
00035
00036     protected:
00039         virtual void OnAppOpen();
00042         virtual void OnAppClose();
00043         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00044
00045     private:
00046
00047         BtFaxAppPlugin();
00048
00050
00054         BOOLEAN OnFaxConnect(BtResultCode result, const BtDevice& device);
00055
00057         /*In this function the added menu and indicator should be remove.
00058         */
00059         BOOLEAN OnFaxDisconnect(BtResultCode result);
00060         void DoFaxDisconnect();
00061
00062     private:
00063
00064        // Action m_fax_disconnect_action;
00065         Feature m_fax_disconnect_feature;
00066         Property m_fax_prop;
00067
00068         static BtFaxAppPlugin m_plugin;
00069
00070         BtApplication* m_host_app;
00071
00072         BtFaxProfileService m_fax_profile_service;
00073
00074         BtAlertMessageWindow m_alert_message_window;
00075
00076         BtRequestRunningWindow m_request_running_window;
00077
00078 };
00080 #endif  // Mmi_AppPlugin_hpp
00081
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.cpp File Reference

Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.cpp File Reference

#include "PreComp.hpp"
#include "BtFaxProfileService.hpp"
#include "BtFaxAppPlugin.hpp"

Include dependency graph for BtFaxProfileService.cpp:

Generated on Tue Jan 24 23:45:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.hpp File Reference

Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.hpp File Reference

#include <Bluetooth/FAX/BtFaxService.hpp>

Include dependency graph for BtFaxProfileService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtFaxProfileService

Defines

#define | BtFaxProfileService_hpp

Define Documentation

#define BtFaxProfileService_hpp

Generated on Tue Jan 24 23:45:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.hpp Source File

Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtFaxProfileService_hpp)
00009 #define BtFaxProfileService_hpp
00010
00011 #include <Bluetooth/FAX/BtFaxService.hpp>
00012
00015 class BtFaxProfileService : public BtFaxService{
00016     private:
00017
00018     typedef BtFaxService Base;
00019
00020     public:
00022         BtFaxProfileService();
00023
00025         virtual ~BtFaxProfileService();
00026
00027     protected:
00029
00034         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00035 };
00036
00037 #endif /* BtFaxProfileService_hpp */
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/PreComp.cpp File Reference

Applications/BtApp/BtFaxAppPlugin/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:10:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/PreComp.hpp File Reference

Applications/BtApp/BtFaxAppPlugin/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Bluetooth/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:23:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtFaxAppPlugin/PreComp.hpp Source File

Applications/BtApp/BtFaxAppPlugin/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Gui/Lib.hpp>
00012 #include <Asc/Lib.hpp>
00013 #include <Bluetooth/Lib.hpp>
00014
00015 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.cpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.cpp File Reference

#include "PreComp.hpp"
#include "BtHfAppPlugin.hpp"
#include <BtApp/BtMsgTypes.hpp>

Include dependency graph for BtHfAppPlugin.cpp:

Generated on Tue Jan 24 23:45:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.hpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.hpp File Reference

#include <Atl/Properties/Property.hpp>
#include <Common/MmiProgressBox.hpp>
#include <Common/MmiApplicationPlugin.hpp>
#include <Bluetooth/HF/BtHfNotificationMessage.hpp>
#include <BtApp/BtApplication.hpp>
#include "BtHfVolumeSettingsWin.hpp"
#include "BtHfProfileService.hpp"
#include "BtHfProfileWindows.hpp"
#include "BtHfAudioPathWindow.hpp"
#include "BtHfInbandSettingWin.hpp"

Include dependency graph for BtHfAppPlugin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfAppPlugin

Defines

#define | BTHF_AUDIO_2_HF "BtHfAudioTransferToHandsfree"
#define | BTHF_AUDIO_2_PHONE "BtHfAudioTransferToPhone"
#define | BtHfAppPlugin_hpp
#define | CHANGE_CURRENT_AUDIO_PATH "BtHfCurrentAudioPath"
#define | CONNECT_DEVICE "BtHfConnect"
#define | DEFAULT_AUDIO_PATH "BtHfDefaultAudioPath"
#define | DISCONNECT_DEVICE "BtHfDisconnect"
#define | HF_DEVICE_FEATURES "BtHfDeviceFeatures"
#define | HF_INBAND_SETTING "BtHfInbandSetting"
#define | REMOTE_VOLUME_SETTING "BtHfRemoteVolumeSetting"

Define Documentation

#define BTHF_AUDIO_2_HF "BtHfAudioTransferToHandsfree"

#define BTHF_AUDIO_2_PHONE "BtHfAudioTransferToPhone"

#define BtHfAppPlugin_hpp

#define CHANGE_CURRENT_AUDIO_PATH "BtHfCurrentAudioPath"

#define CONNECT_DEVICE "BtHfConnect"

#define DEFAULT_AUDIO_PATH "BtHfDefaultAudioPath"

#define DISCONNECT_DEVICE "BtHfDisconnect"

#define HF_DEVICE_FEATURES "BtHfDeviceFeatures"

#define HF_INBAND_SETTING "BtHfInbandSetting"

#define REMOTE_VOLUME_SETTING "BtHfRemoteVolumeSetting"

Generated on Tue Jan 24 23:45:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.hpp Source File

Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if ! defined(BtHfAppPlugin_hpp)
00011 #define BtHfAppPlugin_hpp
00012
00013 #include <Atl/Properties/Property.hpp>
00014 #include <Common/MmiProgressBox.hpp>
00015 #include <Common/MmiApplicationPlugin.hpp>
00016
00017 #include <Bluetooth/HF/BtHfNotificationMessage.hpp>
00018 #include <BtApp/BtApplication.hpp>
00019 #include "BtHfVolumeSettingsWin.hpp"
00020 #include "BtHfProfileService.hpp"
00021 #include "BtHfProfileWindows.hpp"
00022 #include "BtHfAudioPathWindow.hpp"
00023 #include "BtHfInbandSettingWin.hpp"
00024
00025 #define DISCONNECT_DEVICE "BtHfDisconnect"
00026 #define CONNECT_DEVICE "BtHfConnect"
00027 #define DEFAULT_AUDIO_PATH "BtHfDefaultAudioPath"
00028 #define CHANGE_CURRENT_AUDIO_PATH "BtHfCurrentAudioPath"
00029 #define REMOTE_VOLUME_SETTING "BtHfRemoteVolumeSetting"
00030 #define HF_DEVICE_FEATURES "BtHfDeviceFeatures"
00031 #define HF_INBAND_SETTING "BtHfInbandSetting"
00032 #define BTHF_AUDIO_2_PHONE "BtHfAudioTransferToPhone"
00033 #define BTHF_AUDIO_2_HF "BtHfAudioTransferToHandsfree"
00034
00035
00036 class BtHfAppPlugin : public MmiApplicationPlugin {
00037     typedef MmiApplicationPlugin Base;
00038
00039     public:
00041         virtual ~BtHfAppPlugin();
00042
00044         static BtHfAppPlugin* GetInstance();
00045
00047         virtual void Init(Application* bt_app);
00048
00050         void AddMenuFeature(FeatureID feature, BOOLEAN success);
00051
00053         void RemoveMenuFeature(FeatureID feature, BOOLEAN success);
00054
00055     protected:
00057         virtual void OnAppOpen();
00058
00060         virtual void OnAppClose();
00061
00063         virtual BOOLEAN OnMessage(const Message &msg);
00064
00066         BOOLEAN OnHfNotification(const BtHfNotificationMessage& hf_notification_message);
00067
00069         void OnConnectNotification(BtResultCode result, const BtDevice& device);
00070
00072         void OnDisconnectNotification(BtResultCode result);
00073
00075         void OnTransferAudioToAccessoryNotification(BtResultCode result);
00076
00078         void OnTransferAudioToPhoneNotification();
00079
00081         virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00082
00084         virtual BOOLEAN OnContextFeatureTriggered(const FeatureID& feature_id, const DataItem& context_item);
00085
00086
00090         virtual void RegisterHfMessages() const;
00091
00095         virtual void UnregisterHfMessages() const;
00096
00098         virtual BOOLEAN BtHfInsertPhoneNr();
00099
00100     private:
00101         BtHfAppPlugin();
00102
00103         static BtHfAppPlugin    m_bthf_plugin;
00104
00105         BtHfVolumeSettingsWin   m_bthf_vol_setting_win;
00106
00107         BtHfProfileWindow       m_bt_hf_service_win;
00108         BtHfProfileService      m_bt_hf_service;
00109
00110         BtHfAudioPathWindow     m_audio_path_win;
00111         BtHfFeatureListWin      m_hf_device_feature_win;
00112         BtHfInbandSettingWin    m_hf_inband_setting_win;
00113
00114         Feature         m_hf_default_path_feature;
00115         Feature         m_change_current_path_feature;
00116         Feature         m_remote_volume_feature;
00117         Feature         m_disconnect_feature;
00118         Feature         m_hf_device_list_feature;
00119         Feature         m_hf_inband_setting_feature;
00120         Feature         m_audio_2_phone_feature;
00121         Feature         m_audio_2_hf_feature;
00122         ContextFeature  m_connect_feature;
00123
00124         Property        m_hf_prop;
00125
00126         BtApplication*  m_app;
00127
00128         BtAlertMessageWindow        m_alert_message_window;
00129         BtRequestRunningWindow  m_request_running_window;
00130
00131 };
00132
00134 #endif //#define BtHfAppPlugin_hpp
00135
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.cpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.cpp File Reference

#include "PreComp.hpp"
#include "BtHfAudioPathWindow.hpp"
#include "BtHfAppPlugin.hpp"
#include <Common/MmiDialog.hpp>

Include dependency graph for BtHfAudioPathWindow.cpp:

Generated on Tue Jan 24 23:46:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.hpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.hpp File Reference

#include <Gui/Item.hpp>
#include <Gui/Action.hpp>
#include <Gui/ItemMenu.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <Gui/TextLine.hpp>
#include <Gui/LineEditor.hpp>
#include <GuiExtensions/MmiWindow.hpp>
#include "BtHfProfileService.hpp"
#include "BtHfProvider.hpp"

Include dependency graph for BtHfAudioPathWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfAudioPathWindow

Defines

#define | Mmi_BtHfAudioPathWin_hpp

Define Documentation

#define Mmi_BtHfAudioPathWin_hpp

Generated on Tue Jan 24 23:46:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.hpp Source File

Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_BtHfAudioPathWin_hpp)
00010 #define Mmi_BtHfAudioPathWin_hpp
00011
00012 #include <Gui/Item.hpp>
00013 #include <Gui/Action.hpp>
00014 #include <Gui/ItemMenu.hpp>
00015 #include <Gui/RadioButtonGroup.hpp>
00016 #include <Gui/RadioButtonAction.hpp>
00017 #include <Gui/TextLine.hpp>
00018 #include <Gui/LineEditor.hpp>
00019 #include <GuiExtensions/MmiWindow.hpp>
00020 #include "BtHfProfileService.hpp"
00021 #include "BtHfProvider.hpp"
00022
00023
00024 /*  ------------------------------------------------------------------------
00025     BtHfAudioPathWindow
00026     ------------------------------------------------------------------------ */
00029 class BtHfAudioPathWindow : public MmiWindow
00030 {
00031     private:
00032         typedef MmiWindow Base;
00033
00034     public:
00035         enum BtHfPath
00036         {
00037             CurrentAudioPath,
00038             DefaultAudioPath
00039         };
00040
00042
00044         BtHfAudioPathWindow(BtHfProfileService& service);
00045
00047         virtual ~BtHfAudioPathWindow();
00048
00050
00052         void Init();
00053
00054         void OpenCurrentPathWindow(void);
00055
00056         void OpenDefaultPathWindow(void);
00057
00058     protected:
00060
00062         virtual void OnOpen();
00063
00065
00067         virtual BOOLEAN OnConfirm();
00068
00070
00072         virtual BOOLEAN OnCancel();
00073
00074     private:
00076         BtHfProfileService &bt_hf_service;
00077
00078         BtHfPath m_current_path;
00079
00081         ItemMenu m_item_menu;
00082
00084         RadioButtonGroup  m_radio_button_group;
00085         RadioButtonAction m_phone_action;
00086         RadioButtonAction m_bthf_action;
00087
00088         BtHfProvider m_provider;
00089 };
00090
00092 #endif  //Mmi_BtHfAudioPathWin_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.cpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.cpp File Reference

#include "PreComp.hpp"
#include "BtHfInbandSettingWin.hpp"
#include <Afs/Registry.hpp>

Include dependency graph for BtHfInbandSettingWin.cpp:

Generated on Tue Jan 24 23:46:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.hpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.hpp File Reference

#include <Gui/ItemMenu.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <GuiExtensions/MmiWindow.hpp>
#include "BtHfProfileService.hpp"

Include dependency graph for BtHfInbandSettingWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfInbandSettingWin

Defines

#define | BtHfInbandSettingWin_hpp

Define Documentation

#define BtHfInbandSettingWin_hpp

Generated on Tue Jan 24 23:46:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.hpp Source File

Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfInbandSettingWin_hpp)
00009 #define BtHfInbandSettingWin_hpp
00010
00011 #include <Gui/ItemMenu.hpp>
00012 #include <Gui/RadioButtonGroup.hpp>
00013 #include <Gui/RadioButtonAction.hpp>
00014 #include <GuiExtensions/MmiWindow.hpp>
00015
00016 #include "BtHfProfileService.hpp"
00017
00018 static const CHAR* c_bthfplugin_uri = "./BtHfAppPlugin";
00019 static const CHAR* c_bthfplugin_path = "./BtHfAppPlugin/HfInbandSetting";
00020
00021 /*  ------------------------------------------------------------------------
00022     BtHfInbandSettingWin
00023     ------------------------------------------------------------------------ */
00024
00027 class BtHfInbandSettingWin : public MmiWindow
00028 {
00029     private:
00030         typedef MmiWindow Base;
00031
00032     public:
00034
00036         BtHfInbandSettingWin(BtHfProfileService& service);
00037
00039         virtual ~BtHfInbandSettingWin();
00040
00042
00044         void Init();
00045
00046     protected:
00048
00050         virtual void OnOpen();
00051
00053
00055         virtual BOOLEAN OnConfirm();
00056
00057
00058     private:
00060         BtHfProfileService      &m_bt_hf_service;
00061
00063         ItemMenu m_item_menu;
00064
00066         RadioButtonGroup  m_radio_button_group;
00067         RadioButtonAction m_on_action;
00068         RadioButtonAction m_off_action;
00069
00070 };
00071
00072 #endif // BtHfInbandSettingWin_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProfileService.cpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfProfileService.cpp File Reference

#include "PreComp.hpp"
#include "BtHfProfileWindows.hpp"
#include "BtHfProfileService.hpp"

Include dependency graph for BtHfProfileService.cpp:

Generated on Tue Jan 24 23:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProfileService.hpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfProfileService.hpp File Reference

#include <Bluetooth/HF/BtHfService.hpp>

Include dependency graph for BtHfProfileService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfProfileService

Defines

#define | BtHfProfileService_hpp

Define Documentation

#define BtHfProfileService_hpp

Generated on Tue Jan 24 23:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProfileService.hpp Source File

Applications/BtApp/BtHfAppPlugin/BtHfProfileService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfProfileService_hpp)
00009 #define BtHfProfileService_hpp
00010
00011 #include <Bluetooth/HF/BtHfService.hpp>
00012
00013 /*  ------------------------------------------------------------------------
00014     forward declartions
00015     ------------------------------------------------------------------------ */
00016
00017 class BtHfProfileWindow;
00018
00021 class BtHfProfileService : public BtHfService
00022 {
00023     private:
00024         typedef BtHfService Base;
00025
00026     public:
00028         BtHfProfileService(BtHfProfileWindow& hf_profile_window);
00029
00031         virtual ~BtHfProfileService();
00032
00033     protected:
00035
00037         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00038
00040
00042         virtual void OnPhoneNumberRequired(BtResultCode result);
00043
00044     private:
00046         BtHfProfileWindow& m_hf_profile_window;
00047 };
00048
00049 #endif /* BtHfProfileService_hpp */
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.cpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.cpp File Reference

#include "PreComp.hpp"
#include "BtHfProfileWindows.hpp"
#include "BtHfAppPlugin.hpp"
#include <Common/MmiApplication.hpp>
#include <Common/MmiDialog.hpp>
#include <BtApp/BtMsgTypes.hpp>

Include dependency graph for BtHfProfileWindows.cpp:

Defines

#define | DEVICE_SUPPORTED_FEATURES L"Supported features"
#define | FEATURE_AVAILABLE_NO L" No"
#define | FEATURE_AVAILABLE_YES L" Yes"
#define | FEATURE_CLI_PRESENTATION " CLI Presentation"
#define | FEATURE_EC_NR " EC & NR"
#define | FEATURE_REMOTE_VOLUME_CTRL " Remote Volume Ctrl"
#define | FEATURE_THREE_WAY_CALL " Three Way Call"
#define | FEATURE_VOICE_REC " Voice Recognition"
#define | HF_SETTINGS L"Handsfree settings"
#define | MASK_3_WAY_CALL 2
#define | MASK_CLI_PRESENTATION 4
#define | MASK_EC_NR 1
#define | MASK_REMOTE_VOLUME_CTRL 16
#define | MASK_VOICE_REC 8

Define Documentation

#define DEVICE_SUPPORTED_FEATURES L"Supported features"

#define FEATURE_AVAILABLE_NO L" No"

#define FEATURE_AVAILABLE_YES L" Yes"

#define FEATURE_CLI_PRESENTATION " CLI Presentation"

#define FEATURE_EC_NR " EC & NR"

#define FEATURE_REMOTE_VOLUME_CTRL " Remote Volume Ctrl"

#define FEATURE_THREE_WAY_CALL " Three Way Call"

#define FEATURE_VOICE_REC " Voice Recognition"

#define HF_SETTINGS L"Handsfree settings"

#define MASK_3_WAY_CALL 2

#define MASK_CLI_PRESENTATION 4

#define MASK_EC_NR 1

#define MASK_REMOTE_VOLUME_CTRL 16

#define MASK_VOICE_REC 8

Generated on Tue Jan 24 23:47:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/TextLine.hpp>
#include <BtApp/BtApplicationWindows.hpp>
#include <Atl/Features/FeatureItem.hpp>
#include "BtHfProfileService.hpp"
#include <BtApp/BtDeviceListsWindows.hpp>

Include dependency graph for BtHfProfileWindows.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfFeatureListWin
class | BtHfProfileWindow

Defines

#define | BtHfProfileWindows_hpp

Define Documentation

#define BtHfProfileWindows_hpp

Generated on Tue Jan 24 23:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp Source File

Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHfProfileWindows_hpp)
00009 #define BtHfProfileWindows_hpp
00010
00011 #include <Gui/Action.hpp>
00012 #include <Gui/TextLine.hpp>
00013 #include <BtApp/BtApplicationWindows.hpp>
00014 #include <Atl/Features/FeatureItem.hpp>
00015
00016 #include "BtHfProfileService.hpp"
00017
00018 #include <BtApp/BtDeviceListsWindows.hpp>
00019
00022 class BtHfFeatureListWin: public MmiWindow
00023 {
00024     private:
00025         typedef MmiWindow Base;
00026
00027     public:
00029
00031         BtHfFeatureListWin(BtHfProfileService& service);
00032
00034         virtual ~BtHfFeatureListWin();
00035
00037
00039         void Init();
00040
00041     protected:
00043
00045         virtual void OnOpen();
00046
00048
00050         virtual BOOLEAN OnConfirm();
00051
00054         virtual BOOLEAN OnCancel();
00055
00056     private:
00058         BtHfProfileService& m_service;
00059
00061         MultiLineEditor m_feature_display;
00062
00063 };
00064
00065 class BtHfProfileWindow : public MmiWindow
00066 {
00067     private:
00068         typedef MmiWindow Base;
00069
00070     public:
00072
00074         BtHfProfileWindow(BtHfProfileService& service);
00075
00077         virtual ~BtHfProfileWindow();
00078
00080
00082         void Init();
00083
00085
00087         const BtDevice& GetTargetDevice() const;
00088
00090
00092         void SetTargetDevice(const BtDevice& target_device);
00093
00095
00097         //void OnConnect(const BtDevice& target_device);
00098
00100
00102         //void OnDisconnect();
00103
00106         void OnUserConnect();
00107
00110         void OnUserDisconnect();
00111
00114         void OnTransferCallToHandsfree();
00115
00118         void OnTransferCallToPhone();
00119
00122         void OnRemoteConnect(BOOLEAN result);
00123
00126         void OnRemoteDisconnect(BOOLEAN result);
00127
00128
00129     protected:
00130
00132         void OnDeviceListWindowClose(void);
00133
00135         void OnHfSettingsWindowClosed(void);
00136
00139         void OnTransferCallToPhoneFinished(BOOLEAN success);
00140
00143         void OnTransferCallToHandsfreeFinished(BOOLEAN success);
00144
00147         void OnUserConnectFinished(BOOLEAN success);
00148
00151         void OnUserDisconnectFinished(BOOLEAN success);
00152
00155         void OnPhoneNumberRequired(BtResultCode result);
00156
00157     private:
00159         TextLine m_target_device_name_header;
00160         TextLine m_target_device_name_display;
00161         TextLine m_target_device_address_header;
00162         TextLine m_target_device_address_display;
00163         TextLine m_connected_header;
00164         TextLine m_connected_display;
00165
00167         Action m_disconnect_action;
00168
00170         BtAlertMessageWindow m_alert_message_window;
00171         BtRequestRunningWindow m_request_running_window;
00172
00174         CloseWindowAction m_close_window_action;
00175
00177         BtHfProfileService  &m_hf_profile_service;
00178
00180         BtDeviceListWindow m_device_list_window;
00181
00182         BOOLEAN     m_current_audio_request;    //TRUE audio 2 phone - FALSE audio 2 HF
00183         FeatureItem m_hf_feature_to_handsfree;
00184         FeatureItem m_hf_feature_to_phone;
00185
00186     private:
00187         friend class BtHfProfileService;
00188 };
00189
00190 #endif // BtHfProfileWindows_hpp
00191
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProvider.cpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfProvider.cpp File Reference

#include "PreComp.hpp"
#include "BtHfProvider.hpp"
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Config/Config.hpp>

Include dependency graph for BtHfProvider.cpp:

Generated on Tue Jan 24 23:47:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProvider.hpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfProvider.hpp File Reference

#include <AddOns/AdcExtensions/RecordHandler.hpp>
#include <Common/SettingsProvider.hpp>
#include "BtHfRecord.hpp"

Include dependency graph for BtHfProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfProvider

Defines

#define | Mmi_BtHfProvider_hpp

Enumerations

enum | BtHfColIds { c_default_audiopath_id }

Define Documentation

#define Mmi_BtHfProvider_hpp

Enumeration Type Documentation

enum BtHfColIds

Enumerator:
c_default_audiopath_id

Generated on Tue Jan 24 23:47:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfProvider.hpp Source File

Applications/BtApp/BtHfAppPlugin/BtHfProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_BtHfProvider_hpp)
00009 #define Mmi_BtHfProvider_hpp
00010
00011 #include <AddOns/AdcExtensions/RecordHandler.hpp>
00012 #include <Common/SettingsProvider.hpp>
00013 #include "BtHfRecord.hpp"
00014
00015 enum BtHfColIds {
00016     c_default_audiopath_id
00017 };
00018
00019
00021 class BtHfProvider : public SettingsProvider {
00022     typedef SettingsProvider Base;
00023     public:
00025         BtHfProvider();
00027         virtual ~BtHfProvider();
00029         void Init();
00030
00032         virtual INT MaxRowCount();
00034         virtual INT GetProviderId() const;
00036         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00038         virtual BOOLEAN SetDataItem(const DataItem &item, INT column_id);
00040         virtual BOOLEAN SelectRow(INT row);
00042         virtual BOOLEAN CommitRow(INT row);
00044         virtual void RestoreFactorySettings();
00045
00046     private:
00047         RecordHandler   m_handler;
00048         BtHfRecord      m_record;
00049         BtHfRecord      m_commit_record;
00050 };
00051
00053 #endif  // Mmi_BtHfProvider_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfRecord.cpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfRecord.cpp File Reference

#include "PreComp.hpp"
#include "BtHfRecord.hpp"

Include dependency graph for BtHfRecord.cpp:

Generated on Tue Jan 24 23:47:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp File Reference

#include <AddOns/AdcExtensions/Record.hpp>
#include <Devices/Device.hpp>

Include dependency graph for BtHfRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfRecord
struct | BtHfRecord::Persist

Defines

#define | Mmi_BtHfRecord_hpp

Define Documentation

#define Mmi_BtHfRecord_hpp

Generated on Tue Jan 24 23:47:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp Source File

Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_BtHfRecord_hpp)
00009 #define Mmi_BtHfRecord_hpp
00013
00014 #include <AddOns/AdcExtensions/Record.hpp>
00015 #include <Devices/Device.hpp>
00016
00017
00019 class BtHfRecord : public Record {
00020     typedef Record Base;
00021     public:
00023         BtHfRecord(
00024             BOOLEAN phone_audio_path = FALSE);
00025
00027         ~BtHfRecord() { };
00028
00030         virtual const UINT8* GetData();
00032         virtual void SetData(const UINT8* data);
00034         virtual INT GetPersistentSize();
00035 #if 0
00036
00037         void SetAudioPath(BOOLEAN phone_path) { m_data.audio_at_phone = phone_path; }
00039         BOOLEAN GetAudioPath() { return (BOOLEAN)m_data.audio_at_phone; }
00040         private:
00041 #endif
00042
00043         struct Persist {
00044             BOOLEAN audio_at_phone;
00045         } m_data;
00046
00047 };
00048
00050 #endif  // Mmi_BtHfRecord_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.cpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.cpp File Reference

#include "PreComp.hpp"
#include "BtHfVolumeSettingsWin.hpp"
#include <GuiExtensions/MmiAlert.hpp>
#include "BtHfAppPlugin.hpp"

Include dependency graph for BtHfVolumeSettingsWin.cpp:

Generated on Tue Jan 24 23:48:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.hpp File Reference

Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.hpp File Reference

#include <Gui/Lib.hpp>
#include <Gui/ItemMenu.hpp>
#include <Common/MmiWindow.hpp>
#include <Common/AudioRequest.hpp>
#include "BtHfProfileService.hpp"

Include dependency graph for BtHfVolumeSettingsWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHfVolumeSettingsWin

Defines

#define | MAX_VOLUME_LEVEL 15
#define | MIN_VOLUME_LEVEL 0
#define | Mmi_BtHfVolumeSettingsWin_hpp

Define Documentation

#define MAX_VOLUME_LEVEL 15

#define MIN_VOLUME_LEVEL 0

#define Mmi_BtHfVolumeSettingsWin_hpp

Generated on Tue Jan 24 23:48:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.hpp Source File

Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_BtHfVolumeSettingsWin_hpp)
00010 #define Mmi_BtHfVolumeSettingsWin_hpp
00011
00012 #include <Gui/Lib.hpp>
00013
00014 #include <Gui/ItemMenu.hpp>
00015 #include <Common/MmiWindow.hpp>
00016 #include <Common/AudioRequest.hpp>
00017
00018 #include "BtHfProfileService.hpp"
00019
00020 // Define min & max audio volume level as defined in Bluetooth SIG
00021 #define MIN_VOLUME_LEVEL 0
00022 #define MAX_VOLUME_LEVEL 15
00023
00025 class BtHfVolumeSettingsWin : public MmiWindow {
00026     typedef MmiWindow Base;
00027
00028     public:
00030         BtHfVolumeSettingsWin(BtHfProfileService& service);
00031
00033         virtual ~BtHfVolumeSettingsWin();
00034
00036         void Init();
00037
00038         enum AudioGain
00039         {
00040             MicGain = 0,
00041             SpeakerGain
00042         };
00043
00044     protected:
00045
00047         virtual BOOLEAN OnMessage(const Message &msg);
00049         virtual void OnLayoutClient();
00051         virtual void OnOpen();
00053         virtual BOOLEAN OnConfirm();
00055         virtual BOOLEAN OnCancel();
00056
00057     private:
00059         void DecreaseBtHfVolume();
00060
00062         void IncreaseBtHfVolume();
00063
00065         BOOLEAN SwitchBtHfVolume();
00066
00068         void UpdateProgressBar();
00069
00070         Item m_speaker_item;
00071         Item m_microphone_item;
00072         ItemMenu                m_item_menu;
00073         AudioGain               m_mic_speaker;
00074         ProgressBar             m_progress_bar;
00075         UINT8                   m_speaker_gain;
00076         UINT8                   m_microphone_gain;
00077
00078         BtHfProfileService      &m_bt_hf_service;
00079 };
00080
00082 #endif  // Mmi_BtHfVolumeSettingsWin_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/PreComp.cpp File Reference

Applications/BtApp/BtHfAppPlugin/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:13:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/PreComp.hpp File Reference

Applications/BtApp/BtHfAppPlugin/PreComp.hpp File Reference

#include <Auxiliary/Lib.hpp>
#include <Kernel/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Bluetooth/Lib.hpp>
#include <Bluetooth/HF/Lib.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/Services/Service.hpp>
#include <GuiExtensions/MmiPhoneNumberPrompt.hpp>
#include <Common/MmiServices.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Mmi_BtHfPluginPreComp_hpp

Define Documentation

#define Mmi_BtHfPluginPreComp_hpp

Generated on Tue Jan 24 15:24:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHfAppPlugin/PreComp.hpp Source File

Applications/BtApp/BtHfAppPlugin/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_BtHfPluginPreComp_hpp)
00010 #define Mmi_BtHfPluginPreComp_hpp
00014
00015 #include <Auxiliary/Lib.hpp>
00016 #include <Kernel/Lib.hpp>
00017 #include <Apc/Lib.hpp>
00018 #include <Asc/Lib.hpp>
00019 #include <Adc/Lib.hpp>
00020 #include <Gui/Lib.hpp>
00021 #include <Bluetooth/Lib.hpp>
00022 #include <Bluetooth/HF/Lib.hpp>
00023 #include <AddOns/Services/ServiceBroker.hpp>
00024 #include <AddOns/Services/Service.hpp>
00025 #include <GuiExtensions/MmiPhoneNumberPrompt.hpp>
00026 #include <Common/MmiServices.hpp>
00027
00028 //#include <Kernel/MsgTypes.hpp>
00029 //#include <Kernel/Os/TestWriter.hpp>
00030 //#include <Common/CommonMsgTypes.hpp>
00031 //#include <Common/Items/ItemObj.hpp>
00032
00034
00035 #endif// Mmi_BtHfPluginPreComp_hpp
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.cpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.cpp File Reference

#include "PreComp.hpp"
#include "BtHsAppPlugin.hpp"
#include <BtApp/BtMsgTypes.hpp>
#include <Common/FeatureBroker/FeatureBroker.hpp>

Include dependency graph for BtHsAppPlugin.cpp:

Generated on Tue Jan 24 23:48:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.hpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.hpp File Reference

#include <Common/MmiApplicationPlugin.hpp>
#include <Bluetooth/HS/BtHsNotificationMessage.hpp>
#include <Bluetooth/HS/BtHsNotificationMessageArgument.hpp>
#include <BtApp/BtApplication.hpp>
#include <BtApp/BtApplicationWindows.hpp>
#include "BtHsProfileService.hpp"
#include "BtHsVolumeSettingsWin.hpp"
#include "BtHsConnectionSettingWin.hpp"
#include "BtHsInbandSettingWin.hpp"

Include dependency graph for BtHsAppPlugin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsAppPlugin

Defines

#define | Mmi_BtHsAppPlugin_hpp

Define Documentation

#define Mmi_BtHsAppPlugin_hpp

Generated on Tue Jan 24 23:48:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.hpp Source File

Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_BtHsAppPlugin_hpp)
00009 #define Mmi_BtHsAppPlugin_hpp
00012
00013 #include <Common/MmiApplicationPlugin.hpp>
00014 #include <Bluetooth/HS/BtHsNotificationMessage.hpp>
00015 #include <Bluetooth/HS/BtHsNotificationMessageArgument.hpp>
00016 #include <BtApp/BtApplication.hpp>
00017 #include <BtApp/BtApplicationWindows.hpp>
00018 #include "BtHsProfileService.hpp"
00019 #include "BtHsVolumeSettingsWin.hpp"
00020 #include "BtHsConnectionSettingWin.hpp"
00021 #include "BtHsInbandSettingWin.hpp"
00022 class BtHsAppPlugin : public MmiApplicationPlugin
00023 {
00024     typedef MmiApplicationPlugin Base;
00025
00026     public:
00027
00028         virtual ~BtHsAppPlugin();
00029
00030         void Init(Application* app);
00031
00032         static BtHsAppPlugin* GetInstance();
00033
00034         virtual BOOLEAN OnMessage(const Message &msg);
00035
00038         void OnHsDisconnectRequestFinished(BOOLEAN success);
00039
00040         void OnHsConnectRequestFinished(BOOLEAN success);
00041
00042         void OnHsCallTransferToPhoneRequestFinished(BOOLEAN success);
00043
00044         void OnHsCallTransferToHeadsetRequestFinished(BOOLEAN success);
00045
00046
00047     protected:
00050         virtual void OnAppOpen();
00053         virtual void OnAppClose();
00054
00055         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00056         virtual BOOLEAN OnContextFeatureTriggered (const FeatureID& feature_id, const DataItem& context_item);
00057
00058
00059
00060     private:
00061
00062         BtHsAppPlugin();
00063
00064         void OnHsNotification(const BtHsNotificationMessage& notification_message);
00065
00067
00071         BOOLEAN OnHsConnectNotification(BtResultCode result, const BtDevice& target_device);
00073         /*Remote device and local device both can initiate Hs disconnect. In this function
00074         the added menu and indicator should be remove.
00075         */
00076         BOOLEAN OnHsDisconnectNotification(BtResultCode result);
00077
00078
00080         BOOLEAN OnHsCallTransferToHeadsetNotification(BtResultCode result);
00081
00082         BOOLEAN OnHsCallEventNotification(BtHsCallEvent call_event);
00083
00084
00086         void OnConnectActionExecuted(const BtDevice& device);
00087
00088         void OnDisconnectActionExecuted();
00089
00090         void OnCallTransferToPhoneFeature();
00091
00092         void OnCallTransferToHeadsetFeature();
00093
00094     private:
00095
00096         Feature m_hs_disconnect_feature;
00097         Feature m_call_transfer_to_phone_feature;
00098         Feature m_call_transfer_to_hs_feature;
00099         Feature m_vol_setting_hs_feature;
00100         Feature m_connection_on_call_hs_feature;
00101         Feature m_inband_setting_hs_feature;
00102         ContextFeature m_hs_connect_context_feature;
00103         Property m_hs_prop;
00104
00105         static BtHsAppPlugin m_plugin;
00106
00107         BtDevice m_target_device;
00108
00109         BtApplication* m_host_app;
00110         BtHsProfileService m_hs_profile_service;
00111         BtAlertMessageWindow m_alert_message_window;
00112         BtRequestRunningWindow m_request_running_window;
00113         BtHsVolumeSettingsWin m_bths_vol_setting_win;
00114         BtHsConnectionSettingWin m_hs_connection_on_call_window;
00115         BtHsInbandSettingWin m_hs_inband_setting_win;
00116 };
00118 #endif  // Mmi_AppPlugin_hpp
00119
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.cpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.cpp File Reference

#include "PreComp.hpp"
#include "BtHsConnectionSettingWin.hpp"

Include dependency graph for BtHsConnectionSettingWin.cpp:

Generated on Tue Jan 24 23:48:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.hpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.hpp File Reference

#include <Gui/ItemMenu.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <GuiExtensions/MmiWindow.hpp>
#include "BtHsProfileService.hpp"

Include dependency graph for BtHsConnectionSettingWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsConnectionSettingWin

Defines

#define | BtHsConnectionSettingWin_hpp

Define Documentation

#define BtHsConnectionSettingWin_hpp

Generated on Tue Jan 24 23:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.hpp Source File

Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsConnectionSettingWin_hpp)
00009 #define BtHsConnectionSettingWin_hpp
00010
00011 #include <Gui/ItemMenu.hpp>
00012 #include <Gui/RadioButtonGroup.hpp>
00013 #include <Gui/RadioButtonAction.hpp>
00014 #include <GuiExtensions/MmiWindow.hpp>
00015
00016 #include "BtHsProfileService.hpp"
00017
00018 /*  ------------------------------------------------------------------------
00019     BtHsConnectionSettingWin
00020     ------------------------------------------------------------------------ */
00021
00024 class BtHsConnectionSettingWin : public MmiWindow
00025 {
00026     private:
00027         typedef MmiWindow Base;
00028
00029     public:
00031
00033         BtHsConnectionSettingWin(BtHsProfileService& service);
00034
00036         virtual ~BtHsConnectionSettingWin();
00037
00039
00041         void Init();
00042
00043     protected:
00045
00047         virtual void OnOpen();
00048
00050
00052         virtual BOOLEAN OnConfirm();
00053
00054
00055     private:
00057         BtHsProfileService &m_hs_profile_service;
00058
00060         ItemMenu m_item_menu;
00061
00063         RadioButtonGroup  m_radio_button_group;
00064         RadioButtonAction m_on_action;
00065         RadioButtonAction m_off_action;
00066
00067 };
00068
00069 #endif // BtHsConnectionSettingWin_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.cpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.cpp File Reference

#include "PreComp.hpp"
#include "BtHsInbandSettingWin.hpp"
#include <Afs/Registry.hpp>

Include dependency graph for BtHsInbandSettingWin.cpp:

Generated on Tue Jan 24 23:49:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.hpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.hpp File Reference

#include <Gui/ItemMenu.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <GuiExtensions/MmiWindow.hpp>
#include "BtHsProfileService.hpp"

Include dependency graph for BtHsInbandSettingWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsInbandSettingWin

Defines

#define | BtHsInbandSettingWin_hpp

Define Documentation

#define BtHsInbandSettingWin_hpp

Generated on Tue Jan 24 23:49:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.hpp Source File

Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsInbandSettingWin_hpp)
00009 #define BtHsInbandSettingWin_hpp
00010
00011 #include <Gui/ItemMenu.hpp>
00012 #include <Gui/RadioButtonGroup.hpp>
00013 #include <Gui/RadioButtonAction.hpp>
00014 #include <GuiExtensions/MmiWindow.hpp>
00015
00016 #include "BtHsProfileService.hpp"
00017
00018 static const CHAR* c_bthsplugin_uri = "./BtHsAppPlugin";
00019 static const CHAR* c_bthsplugin_path = "./BtHsAppPlugin/HsInbandSetting";
00020
00021 /*  ------------------------------------------------------------------------
00022     BtHsInbandSettingWin
00023     ------------------------------------------------------------------------ */
00024
00027 class BtHsInbandSettingWin : public MmiWindow
00028 {
00029     private:
00030         typedef MmiWindow Base;
00031
00032     public:
00034
00036         BtHsInbandSettingWin(BtHsProfileService& service);
00037
00039         virtual ~BtHsInbandSettingWin();
00040
00042
00044         void Init();
00045
00046     protected:
00048
00050         virtual void OnOpen();
00051
00053
00055         virtual BOOLEAN OnConfirm();
00056
00057
00058     private:
00060         BtHsProfileService      &m_bt_hs_service;
00061
00063         ItemMenu m_item_menu;
00064
00066         RadioButtonGroup  m_radio_button_group;
00067         RadioButtonAction m_on_action;
00068         RadioButtonAction m_off_action;
00069
00070 };
00071
00072 #endif // BtHsInbandSettingWin_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsProfileService.cpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsProfileService.cpp File Reference

#include "PreComp.hpp"
#include "BtHsProfileService.hpp"
#include "BtHsAppPlugin.hpp"

Include dependency graph for BtHsProfileService.cpp:

Generated on Tue Jan 24 23:49:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsProfileService.hpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsProfileService.hpp File Reference

#include <Bluetooth/HS/BtHsService.hpp>

Include dependency graph for BtHsProfileService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsProfileService

Defines

#define | BtHsProfileService_hpp

Define Documentation

#define BtHsProfileService_hpp

Generated on Tue Jan 24 23:49:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsProfileService.hpp Source File

Applications/BtApp/BtHsAppPlugin/BtHsProfileService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(BtHsProfileService_hpp)
00009 #define BtHsProfileService_hpp
00010
00011 #include <Bluetooth/HS/BtHsService.hpp>
00012
00015 class BtHsProfileService : public BtHsService{
00016     private:
00017
00018     typedef BtHsService Base;
00019
00020     public:
00022         BtHsProfileService();
00023
00025         virtual ~BtHsProfileService();
00026
00027     protected:
00029
00034         virtual void OnRequestStateChange(BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state);
00036
00038         void OnConnect(BtRequestState old_request_state, BtRequestState new_request_state);
00039
00041
00043         void OnDisonnect(BtRequestState old_request_state, BtRequestState new_request_state);
00044
00046
00048         void OnCallTransferToPhone(BtRequestState old_request_state, BtRequestState new_request_state);
00049
00051
00053         void OnCallTransferToHeadset(BtRequestState old_request_state, BtRequestState new_request_state);
00054
00055 };
00056
00057 #endif /* BtHsProfileService_hpp */
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.cpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.cpp File Reference

#include "PreComp.hpp"
#include "BtHsVolumeSettingsWin.hpp"
#include <GuiExtensions/MmiAlert.hpp>

Include dependency graph for BtHsVolumeSettingsWin.cpp:

Generated on Tue Jan 24 23:50:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.hpp File Reference

Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.hpp File Reference

#include <Gui/Lib.hpp>
#include <Gui/ItemMenu.hpp>
#include <Common/MmiWindow.hpp>
#include <Common/AudioRequest.hpp>
#include "BtHsProfileService.hpp"

Include dependency graph for BtHsVolumeSettingsWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BtHsVolumeSettingsWin

Defines

#define | MAX_VOLUME_LEVEL 15
#define | MIN_VOLUME_LEVEL 0
#define | Mmi_BtHsVolumeSettingsWin_hpp

Define Documentation

#define MAX_VOLUME_LEVEL 15

#define MIN_VOLUME_LEVEL 0

#define Mmi_BtHsVolumeSettingsWin_hpp

Generated on Tue Jan 24 23:50:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.hpp Source File

Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_BtHsVolumeSettingsWin_hpp)
00010 #define Mmi_BtHsVolumeSettingsWin_hpp
00011
00012 #include <Gui/Lib.hpp>
00013
00014 #include <Gui/ItemMenu.hpp>
00015 #include <Common/MmiWindow.hpp>
00016 #include <Common/AudioRequest.hpp>
00017
00018 #include "BtHsProfileService.hpp"
00019
00020 // Define min & max audio volume level as defined in Bluetooth SIG
00021 #define MIN_VOLUME_LEVEL 0
00022 #define MAX_VOLUME_LEVEL 15
00023
00025 class BtHsVolumeSettingsWin : public MmiWindow {
00026     typedef MmiWindow Base;
00027
00028     public:
00030         BtHsVolumeSettingsWin(BtHsProfileService& service);
00031
00033         virtual ~BtHsVolumeSettingsWin();
00034
00036         void Init();
00037
00038         enum AudioGain
00039         {
00040             MicGain = 0,
00041             SpeakerGain
00042         };
00043
00044     protected:
00045
00047         virtual BOOLEAN OnMessage(const Message &msg);
00049         virtual void OnLayoutClient();
00051         virtual void OnOpen();
00053         virtual BOOLEAN OnConfirm();
00055         virtual BOOLEAN OnCancel();
00056
00057     private:
00059         void DecreaseBtHsVolume();
00060
00062         void IncreaseBtHsVolume();
00063
00065         BOOLEAN SwitchBtHsVolume();
00066
00068         void UpdateProgressBar();
00069
00070         Item m_speaker_item;
00071         Item m_microphone_item;
00072         ItemMenu                m_item_menu;
00073         AudioGain               m_mic_speaker;
00074         ProgressBar             m_progress_bar;
00075         UINT8                   m_speaker_gain;
00076         UINT8                   m_microphone_gain;
00077
00078         BtHsProfileService      &m_bt_hs_service;
00079 };
00080
00081 #endif  // Mmi_BtHsVolumeSettingsWin_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/PreComp.cpp File Reference

Applications/BtApp/BtHsAppPlugin/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:14:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/PreComp.hpp File Reference

Applications/BtApp/BtHsAppPlugin/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Bluetooth/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:24:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/BtApp/BtHsAppPlugin/PreComp.hpp Source File

Applications/BtApp/BtHsAppPlugin/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Auxiliary/Lib.hpp>
00011 #include <Gui/Lib.hpp>
00012 #include <Asc/Lib.hpp>
00013 #include <Bluetooth/Lib.hpp>
00014
00015 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarAddRecordWin.cpp File Reference

Applications/Calendar/CalendarAddRecordWin.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarAddRecordWin.hpp"
#include "CalendarApp.hpp"
#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for CalendarAddRecordWin.cpp:

Generated on Tue Jan 24 23:50:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarAddRecordWin.hpp File Reference

Applications/Calendar/CalendarAddRecordWin.hpp File Reference

#include "CalendarRecord.hpp"
#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/LabelListBoxModel.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include "CalendarDialogWin.hpp"

Include dependency graph for CalendarAddRecordWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarAddRecordWin

Defines

#define | CalendarAddRecordWin_hpp

Define Documentation

#define CalendarAddRecordWin_hpp

Generated on Tue Jan 24 23:50:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarAddRecordWin.hpp Source File

Applications/Calendar/CalendarAddRecordWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     -------------------------------------------------------- */
00008 #if !defined(CalendarAddRecordWin_hpp)
00009 #define CalendarAddRecordWin_hpp
00010
00011 #include "CalendarRecord.hpp"
00012 #include <GuiExtensions/MmiWindow.hpp>
00013 #include <GuiExtensions/LabelListBoxModel.hpp>
00014 #include <GuiExtensions/ActionAccessor.hpp>
00015 #include "CalendarDialogWin.hpp"
00016
00017
00018
00019 class CalendarAddRecordWin : public MmiWindow {
00020     typedef MmiWindow Base;
00021
00022     public:
00023
00025         CalendarAddRecordWin();
00026
00028         virtual ~CalendarAddRecordWin();
00029
00031         void Init();
00032
00034         void SetDate(Date day);
00035
00037         void SetData(CalendarRecord rec);
00038
00040         void OnLayoutClient();
00041
00043         void StoreAppointment();
00044
00046         void SetCategory();
00047
00049         void SetRecurrence();
00050
00051     protected:
00052
00054         virtual void OnClose();
00055
00056     private:
00057
00058         CalendarRecord  m_new_calendar_record;
00059
00060         TextLine            m_date_text;
00061         TextLine            m_time_text;
00062         TextLine            m_category_text;
00063         TextLine            m_recurrence_text;
00064
00065         DateEditor          m_date_editor;
00066         TimeEditor          m_time_editor;
00067         MultiLineEditor     m_main_record_editor;
00068 };
00069
00070 #endif
00071
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarApp.cpp File Reference

Applications/Calendar/CalendarApp.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarApp.hpp"
#include <Common/ApplicationManager.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Adc/DataHandler.hpp>
#include <Config/MenuResConfig.hpp>

Include dependency graph for CalendarApp.cpp:

Generated on Tue Jan 24 23:51:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarApp.hpp File Reference

Applications/Calendar/CalendarApp.hpp File Reference

#include "CalendarRecord.hpp"
#include "CalendarAddRecordWin.hpp"
#include "CalendarProvider.hpp"
#include "CalendarMonthWin.hpp"
#include <GuiExtensions/MenuAction.hpp>
#include <GuiExtensions/MmiInfoBox.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <GuiExtensions/MmiPasswordPrompt.hpp>
#include <Auxiliary/QuickSortProvider.hpp>
#include <Common/MmiApplication.hpp>

Include dependency graph for CalendarApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarApp

Defines

#define | CalendarApp_hpp

Define Documentation

#define CalendarApp_hpp

Generated on Tue Jan 24 23:51:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarApp.hpp Source File

Applications/Calendar/CalendarApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(CalendarApp_hpp)
00009 #define CalendarApp_hpp
00010
00011 #include "CalendarRecord.hpp"
00012 #include "CalendarAddRecordWin.hpp"
00013 #include "CalendarProvider.hpp"
00014 #include "CalendarMonthWin.hpp"
00015
00016 #include <GuiExtensions/MenuAction.hpp>
00017 #include <GuiExtensions/MmiInfoBox.hpp>
00018
00019 #include <GuiExtensions/MmiAlert.hpp>
00020 #include <GuiExtensions/ActionAccessor.hpp>
00021 #include <GuiExtensions/MmiPasswordPrompt.hpp>
00022
00023 #include <Auxiliary/QuickSortProvider.hpp>
00024 #include <Common/MmiApplication.hpp>
00025
00026
00027 /*  ========================================================================
00028     App
00029     ======================================================================== */
00030 class CalendarApp : public MmiApplication
00031 {
00032     typedef MmiApplication Base;
00033
00034     public:
00035
00037         CalendarApp();
00038
00040         virtual ~CalendarApp();
00041
00043         static CalendarApp* GetInstance();
00044
00046         BOOLEAN SaveCalendarRecord(CalendarRecord* record);
00047
00049         void SetCurrentRecordIdx(INT idx) {m_current_record = idx;}
00050
00052         void AbortCalendarRecordIns();
00053
00055         void UpdateAlarmList();
00056
00058         BOOLEAN IsAlarmDay(Date date);
00059
00061         CalendarProvider* GetCalendarProvider(){return &m_cal_provider;};
00062
00063
00064     protected:
00065
00067         virtual void OnOpen();
00068
00070         virtual void OnStartup();
00071
00073         BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00074
00075     private:
00076
00077         enum FeatureItemIds {
00078             Calendar,
00079             CalendarAdd,
00080             CalendarGotoDay,
00081             CalendarViewDay,
00082             CalendarViewAll,
00083             CalendarStore,
00084             CalendarSetCategory,
00085             CalendarSetRecurrence,
00086             CalendarModify,
00087             CalendarDelete,
00088             CalendarDeleteAll,
00089             CalendarFeatureCnt
00090         };
00091
00092         static CalendarApp          m_instance;
00093         CalendarMonthWin            m_month_win;
00094         Protector                   m_protector;
00095         CalendarProvider            m_cal_provider;
00096         INT                         m_current_record;
00097         QuickSortProvider           m_sort_by_date;
00098         FilterProvider              m_filter_by_date;
00099         EqualsRule                  m_equal_rule;
00100         Feature                     m_items[CalendarFeatureCnt];
00101 };
00102
00103 #endif  // CalendarApp_hpp
00104
00105
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarAppPreComp.cpp File Reference

Applications/Calendar/CalendarAppPreComp.cpp File Reference

#include "CalendarAppPreComp.hpp"

Include dependency graph for CalendarAppPreComp.cpp:

Generated on Tue Jan 24 23:51:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarAppPreComp.hpp File Reference

Applications/Calendar/CalendarAppPreComp.hpp File Reference

#include <Kernel/Types.hpp>
#include <Gui/Lib.hpp>
#include <Kernel/System.hpp>

Include dependency graph for CalendarAppPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 23:51:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarAppPreComp.hpp Source File

Applications/Calendar/CalendarAppPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Types.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Kernel/System.hpp>
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarDialogWin.cpp File Reference

Applications/Calendar/CalendarDialogWin.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarDialogWin.hpp"
#include <Common/MmiAlert.hpp>
#include <Common/ContextID.hpp>

Include dependency graph for CalendarDialogWin.cpp:

Generated on Tue Jan 24 23:51:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarDialogWin.hpp File Reference

Applications/Calendar/CalendarDialogWin.hpp File Reference

#include <Common/MmiDialog.hpp>
#include "CalendarRecord.hpp"
#include <Auxiliary/Vector.hpp>

Include dependency graph for CalendarDialogWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarDialogWin

Defines

#define | CalendarDialogWin_hpp

Variables

const INT | c_max_rb_size = ((CalendarRecord::CategoryCounts >= CalendarRecord::RecurrenceCounts) ? CalendarRecord::CategoryCounts : CalendarRecord::RecurrenceCounts)

Define Documentation

#define CalendarDialogWin_hpp

Variable Documentation

const INT c_max_rb_size = ((CalendarRecord::CategoryCounts >= CalendarRecord::RecurrenceCounts) ? CalendarRecord::CategoryCounts : CalendarRecord::RecurrenceCounts)

Generated on Tue Jan 24 23:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarDialogWin.hpp Source File

Applications/Calendar/CalendarDialogWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     -------------------------------------------------------- */
00008 #if !defined(CalendarDialogWin_hpp)
00009 #define CalendarDialogWin_hpp
00010
00011
00012 #include <Common/MmiDialog.hpp>
00013 #include "CalendarRecord.hpp"
00014 #include <Auxiliary/Vector.hpp>
00015
00016 /* must to be alligned with CategoryEnum */
00017 static const WCHAR* CategoryInfo[CalendarRecord::CategoryCounts] = {Tr(L"Memo"), Tr(L"Meeting"), Tr(L"Birthday"), Tr(L"Call"), Tr(L"Anniversary"), Tr(L"Other")};
00018
00019 /* must to be alligned with RecurrenceEnum */
00020 static const WCHAR* RecurrenceInfo[CalendarRecord::RecurrenceCounts] = {Tr(L"No repeat"), Tr(L"Daily"), Tr(L"Weekly"), Tr(L"Monthly"), Tr(L"Yearly")};
00021
00022 const INT c_max_rb_size = ((CalendarRecord::CategoryCounts >= CalendarRecord::RecurrenceCounts) ? CalendarRecord::CategoryCounts : CalendarRecord::RecurrenceCounts);
00023
00024 class CalendarDialogWin: public MmiDialog {
00025     typedef MmiDialog   Base;
00026
00027     public:
00028
00030         void Init();
00031
00033         BOOLEAN OnConfirm();
00034
00036         INT GetData();
00037
00039         void SetData(INT value);
00040
00042         void OnOpen();
00043
00044     private:
00045         RadioButtonAction           m_rb_action[c_max_rb_size];
00046         RadioButtonGroup            m_rb_group;
00047         ItemMenu                    m_rb_menu;
00048         INT                         m_value;
00049 };
00050
00051
00052 #endif
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarGotoDateWin.cpp File Reference

Applications/Calendar/CalendarGotoDateWin.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarGrid.hpp"
#include "CalendarGotoDateWin.hpp"

Include dependency graph for CalendarGotoDateWin.cpp:

Generated on Tue Jan 24 23:51:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarGotoDateWin.hpp File Reference

Applications/Calendar/CalendarGotoDateWin.hpp File Reference

#include "CalendarGrid.hpp"
#include "CalendarMonthSelector.hpp"
#include "CalendarAddRecordWin.hpp"
#include "CalendarMonthWin.hpp"
#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/LabelListBoxModel.hpp>
#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for CalendarGotoDateWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarGotoDateWin

Defines

#define | CalendarGotoDateWin_hpp

Define Documentation

#define CalendarGotoDateWin_hpp

Generated on Tue Jan 24 23:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarGotoDateWin.hpp Source File

Applications/Calendar/CalendarGotoDateWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     -------------------------------------------------------- */
00008 #if !defined(CalendarGotoDateWin_hpp)
00009 #define CalendarGotoDateWin_hpp
00010
00011 #include "CalendarGrid.hpp"
00012 #include "CalendarMonthSelector.hpp"
00013 #include "CalendarAddRecordWin.hpp"
00014 #include "CalendarMonthWin.hpp"
00015
00016 #include <GuiExtensions/MmiWindow.hpp>
00017 #include <GuiExtensions/LabelListBoxModel.hpp>
00018 #include <GuiExtensions/ActionAccessor.hpp>
00019
00020
00021 class CalendarMonthWin;
00022
00023 class CalendarGotoDateWin : public MmiWindow {
00024     typedef MmiWindow Base;
00025
00026     public:
00028         CalendarGotoDateWin();
00029
00031         virtual ~CalendarGotoDateWin();
00032
00034         void Init(CalendarMonthWin* parent);
00035
00036     protected:
00038         virtual BOOLEAN OnCancel();
00039
00041         virtual BOOLEAN OnConfirm();
00042
00044         void OnLayoutClient();
00045
00046     private:
00047         CalendarMonthWin*   m_parent_win;
00048         DateEditor          m_date_editor;
00049 };
00050
00051 #endif
00052
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarGrid.cpp File Reference

Applications/Calendar/CalendarGrid.cpp File Reference

#include "Gui/PreComp.hpp"
#include "CalendarAppPreComp.hpp"
#include "CalendarApp.hpp"
#include "CalendarGrid.hpp"
#include "CalendarMonthWin.hpp"
#include <Config/KeyboardConfig.hpp>
#include <Gui/PaintDc.hpp>
#include <Gui/ScrollBehavior.hpp>
#include <Config/FontConfig.hpp>
#include <Config/MmiGuiEngineConfig.hpp>
#include <Config/IdeaIndicatorConfig.hpp>

Include dependency graph for CalendarGrid.cpp:

Generated on Tue Jan 24 23:51:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarGrid.hpp File Reference

Applications/Calendar/CalendarGrid.hpp File Reference

#include <Gui/View.hpp>
#include <Gui/AbstractGrid.hpp>
#include <Kernel/Os/Os.hpp>
#include <Auxiliary/Date.hpp>

Include dependency graph for CalendarGrid.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarGrid
class | CalendarGridView

Defines

#define | Apoxi_CalendarGrid_hpp
#define | no_cols 8
#define | no_rows 7

Define Documentation

#define Apoxi_CalendarGrid_hpp

Generated on Tue Jan 24 23:51:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarGrid.hpp Source File

Applications/Calendar/CalendarGrid.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_CalendarGrid_hpp)
00011 #define Apoxi_CalendarGrid_hpp
00015
00016 #include <Gui/View.hpp>
00017 #include <Gui/AbstractGrid.hpp>
00018 #include <Kernel/Os/Os.hpp>
00019
00020 #include <Auxiliary/Date.hpp>
00021
00023 #define no_rows 7
00024 #define no_cols 8
00025
00026 class CalendarGrid;
00027
00028 class CalendarGridView : public View {
00029     typedef View Base;
00030
00031     public:
00033         CalendarGridView();
00034
00036         virtual ~CalendarGridView();
00037
00039         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00040
00041 };
00042
00043
00044 class AbstractMenuAccessor;
00045
00049 class CalendarGrid : public AbstractGrid {
00050     typedef AbstractGrid Base;
00051
00052     public:
00053
00055         CalendarGrid();
00056
00058         virtual ~CalendarGrid();
00059
00061
00063         void Init(Control* parent);
00064
00066         virtual INT GetCellCount() const {return no_cols*no_rows;}
00067
00069         virtual INT GetColumnCount() const {return no_cols;}
00070
00072         virtual XYDIM GetCellWidth() const;
00073
00075         virtual XYDIM GetCellHeight() const;
00076
00078         BOOLEAN OnInputMap(const InputMapItem& input_map_item);
00079
00081         Date GetCurrentSelectedDay(){return m_current_selected_day;}
00082
00084         void SetCurrentSelectedDay(Date date){m_current_selected_day = date;}
00085
00087         void Invalidate(const Rect& rect = Rect(), BOOLEAN erase = TRUE);
00088
00089     protected:
00091         void OnGetFocus();
00092
00094         BOOLEAN OnKeyDown(KeyCode key_code);
00095
00096     private:
00097         INT                         m_item_count;
00098         Date                        m_current_selected_day;
00099         static CalendarGridView     m_month_view;
00100         XYDIM                       m_grid_height;
00101         XYDIM                       m_grid_width;
00102 };
00103
00105 #endif  // Apoxi_CalendarGrid_hpp
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarListWin.cpp File Reference

Applications/Calendar/CalendarListWin.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarListWin.hpp"
#include <Config/Config.hpp>
#include "CalendarProvider.hpp"
#include "CalendarApp.hpp"

Include dependency graph for CalendarListWin.cpp:

Generated on Tue Jan 24 23:51:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarListWin.hpp File Reference

Applications/Calendar/CalendarListWin.hpp File Reference

#include <GuiExtensions/MmiItemListWindow.hpp>
#include <Gui/ItemContainer.hpp>
#include <Auxiliary/MainProvider.hpp>
#include <Auxiliary/QuickSortProvider.hpp>
#include <Auxiliary/FilterProvider.hpp>
#include <Auxiliary/FilterRule.hpp>
#include "CalendarAddRecordWin.hpp"
#include <Common/Items/ProviderProxyContainer.hpp>

Include dependency graph for CalendarListWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarListWin
This class declares a new kind of window derived from class MmiItemListWindow. More...

Defines

#define | Mmi_CalendarListWin_hpp

Define Documentation

#define Mmi_CalendarListWin_hpp

Generated on Tue Jan 24 23:51:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarListWin.hpp Source File

Applications/Calendar/CalendarListWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_CalendarListWin_hpp)
00010 #define Mmi_CalendarListWin_hpp
00013
00014 #include <GuiExtensions/MmiItemListWindow.hpp>
00015 #include <Gui/ItemContainer.hpp>
00016
00017 #include <Auxiliary/MainProvider.hpp>
00018 #include <Auxiliary/QuickSortProvider.hpp>
00019 #include <Auxiliary/FilterProvider.hpp>
00020 #include <Auxiliary/FilterRule.hpp>
00021
00022 #include "CalendarAddRecordWin.hpp"
00023 #include <Common/Items/ProviderProxyContainer.hpp>
00024
00029 class CalendarListWin : public MmiItemListWindow {
00030
00031     typedef MmiItemListWindow Base;
00032
00033     public:
00034
00036         CalendarListWin();
00037
00039         virtual ~CalendarListWin();
00040
00042         void Init(Provider* provider);
00043
00045         void SetType(Date date);
00046
00048         BOOLEAN ModifySelectedItem();
00049
00051         void SetWindow(CalendarAddRecordWin& win);
00052
00054         BOOLEAN DeleteAllItems();
00055
00057         BOOLEAN DeleteSelectedItem();
00058
00059
00060     protected:
00062         virtual void OnOpen();
00063
00065         virtual void OnClose();
00066
00068         virtual void OnGetFocus();
00069
00070     private:
00071
00073         void Update(Date date);
00074
00075         ProviderProxyContainer      m_provider_cont;
00076         INT                         m_selected_index;
00077         Provider                    *m_provider;
00078         AbstractDelegationProvider  *m_current_provider;
00079         Date                        m_date;
00080         INT                         m_updated_row;
00081         MainProvider                m_main_provider;
00082         QuickSortProvider           m_sort_date_provider;
00083         QuickSortProvider           m_sort_time_provider;
00084         FilterProvider              m_filter_by_day_provider;
00085         EqualsRule                  m_rule;
00086         CalendarAddRecordWin*       m_modify_record_win;
00087 };
00088
00090 #endif
00091
00092
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarMonthSelector.cpp File Reference

Applications/Calendar/CalendarMonthSelector.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarGrid.hpp"
#include "CalendarMonthSelector.hpp"
#include "CalendarMonthWin.hpp"
#include "CalendarApp.hpp"

Include dependency graph for CalendarMonthSelector.cpp:

Generated on Tue Jan 24 23:51:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarMonthSelector.hpp File Reference

Applications/Calendar/CalendarMonthSelector.hpp File Reference

#include "CalendarGrid.hpp"
#include <Gui/View.hpp>
#include <Gui/AbstractGrid.hpp>
#include <Kernel/Os/Os.hpp>
#include <Auxiliary/Date.hpp>

Include dependency graph for CalendarMonthSelector.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarMonthSelector
class | CalendarMonthSelectorView
Describes the view of a radiobutton-control. More...

Defines

#define | CalendarMonthSelector_hpp

Define Documentation

#define CalendarMonthSelector_hpp

Generated on Tue Jan 24 23:51:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarMonthSelector.hpp Source File

Applications/Calendar/CalendarMonthSelector.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     -------------------------------------------------------- */
00008 #if !defined(CalendarMonthSelector_hpp)
00009 #define CalendarMonthSelector_hpp
00010
00011 #include "CalendarGrid.hpp"
00012
00013
00014 #include <Gui/View.hpp>
00015 #include <Gui/AbstractGrid.hpp>
00016 #include <Kernel/Os/Os.hpp>
00017
00018 #include <Auxiliary/Date.hpp>
00019
00020 class CalendarMonthSelector;
00021
00022
00024 class CalendarMonthSelectorView : public View {
00025     typedef View Base;
00026
00027     public:
00029         CalendarMonthSelectorView();
00030
00032         virtual ~CalendarMonthSelectorView();
00033
00035         virtual void Draw(const Component& component, DeviceContext* dc, const Rect& repaint_rect) const;
00036 };
00037
00038 class CalendarMonthSelector : public AbstractGrid {
00039     typedef AbstractGrid Base;
00040
00041     public:
00043         CalendarMonthSelector();
00044
00046         virtual ~CalendarMonthSelector();
00047
00049         void Init(Control* parent);
00050
00052         virtual INT GetCellCount() const {return 1;}
00053
00055         virtual INT GetColumnCount() const {return 1;}
00056
00058         virtual XYDIM GetCellHeight() const {return 16;}
00059
00061         BOOLEAN OnInputMap(const InputMapItem& input_map_item);
00062
00063     private:
00065         BOOLEAN OnKeyDown(KeyCode key_code);
00066
00067
00068         static CalendarMonthSelectorView m_view;
00069         TextLine            m_text_line;
00070 };
00071
00072 #endif
00073
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarMonthWin.cpp File Reference

Applications/Calendar/CalendarMonthWin.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarGrid.hpp"
#include "CalendarMonthWin.hpp"
#include "CalendarApp.hpp"

Include dependency graph for CalendarMonthWin.cpp:

Generated on Tue Jan 24 23:51:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarMonthWin.hpp File Reference

Applications/Calendar/CalendarMonthWin.hpp File Reference

#include "CalendarGrid.hpp"
#include "CalendarMonthSelector.hpp"
#include "CalendarAddRecordWin.hpp"
#include "CalendarGotoDateWin.hpp"
#include "CalendarRecordsList.hpp"
#include "CalendarListWin.hpp"
#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/MmiPrompt.hpp>
#include <GuiExtensions/LabelListBoxModel.hpp>
#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for CalendarMonthWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarMonthWin

Defines

#define | CalendarMonthWin_hpp

Define Documentation

#define CalendarMonthWin_hpp

Generated on Tue Jan 24 23:51:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarMonthWin.hpp Source File

Applications/Calendar/CalendarMonthWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     -------------------------------------------------------- */
00008 #if !defined(CalendarMonthWin_hpp)
00009 #define CalendarMonthWin_hpp
00010
00011 #include "CalendarGrid.hpp"
00012 #include "CalendarMonthSelector.hpp"
00013 #include "CalendarAddRecordWin.hpp"
00014 #include "CalendarGotoDateWin.hpp"
00015 #include "CalendarRecordsList.hpp"
00016 #include "CalendarListWin.hpp"
00017
00018
00019 #include <GuiExtensions/MmiWindow.hpp>
00020 #include <GuiExtensions/MmiPrompt.hpp>
00021 #include <GuiExtensions/LabelListBoxModel.hpp>
00022 #include <GuiExtensions/ActionAccessor.hpp>
00023
00024 class CalendarMonthWin : public MmiWindow {
00025     typedef MmiWindow Base;
00026
00027     public:
00028
00030         CalendarMonthWin();
00031
00033         virtual ~CalendarMonthWin();
00034
00036         void Init();
00037
00039         void OnOpen();
00040
00042         BOOLEAN Update();
00043
00045         void OnLayoutClient();
00046
00048         void SetCurrentDate(Date date);
00049
00051         Date GetCurrentDate() const {return m_current_date;}
00052
00054         void AddRecord();
00055
00057         void GotoDay();
00058
00060         void ViewSelectedDay();
00061
00063         void ViewAll();
00064
00066         CalendarAddRecordWin* GetCalendarAddWin() {return &m_add_record_win;}
00067
00069         CalendarListWin* GetCalendarListWin(){return &m_calendar_rec_list_win;}
00070
00071
00072     protected:
00073
00075         virtual BOOLEAN OnCancel();
00076
00077     private:
00078
00079         Date                    m_current_date; // to choose the month to show
00080         CalendarGrid            m_month_grid;
00081         CalendarMonthSelector   m_select_month_control;
00082         CalendarAddRecordWin    m_add_record_win;
00083         CalendarListWin         m_calendar_rec_list_win;
00084 };
00085
00086 #endif
00087
Generated on Tue Jan 24 14:51:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarProvider.cpp File Reference

Applications/Calendar/CalendarProvider.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarProvider.hpp"
#include <Adc/Lib.hpp>

Include dependency graph for CalendarProvider.cpp:

Generated on Tue Jan 24 23:51:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarProvider.hpp File Reference

Applications/Calendar/CalendarProvider.hpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarRecord.hpp"
#include <Auxiliary/IndexTable.hpp>
#include <AddOns/AdcExtensions/RecordHandler.hpp>
#include <Auxiliary/Protector.hpp>
#include <Auxiliary/ThreadSafeProvider.hpp>
#include <Config/Config.hpp>

Include dependency graph for CalendarProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarProvider

Defines

#define | CalendarProvider_hpp

Enumerations

enum CalendarRecordColumnId {
c_cal_category_id, c_cal_date_id, c_cal_time_id, c_cal_recurrence_id,
c_cal_description_id, c_cal_text_for_list_item_id
}

Define Documentation

#define CalendarProvider_hpp

Enumeration Type Documentation

enum CalendarRecordColumnId

Enumerator:
c_cal_category_id
c_cal_date_id
c_cal_time_id
c_cal_recurrence_id
c_cal_description_id
c_cal_text_for_list_item_id

Generated on Tue Jan 24 23:51:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarProvider.hpp Source File

Applications/Calendar/CalendarProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(CalendarProvider_hpp)
00015 #define CalendarProvider_hpp
00016
00017 #include "CalendarAppPreComp.hpp"
00018
00019 #include "CalendarRecord.hpp"
00020
00021 #include <Auxiliary/IndexTable.hpp>
00022 #include <AddOns/AdcExtensions/RecordHandler.hpp>
00023 #include <Auxiliary/Protector.hpp>
00024 #include <Auxiliary/ThreadSafeProvider.hpp>
00025 #include <Config/Config.hpp>
00026
00027 /*------------------------------------------------------------------
00028                         Calendar provider
00029 ------------------------------------------------------------------*/
00030
00031 enum CalendarRecordColumnId{
00032     c_cal_category_id,
00033     c_cal_date_id,
00034     c_cal_time_id,
00035     c_cal_recurrence_id,
00036     c_cal_description_id,
00037     c_cal_text_for_list_item_id
00038 };
00039
00040 class CalendarProvider : public ThreadSafeProvider {
00041     public:
00042         typedef ThreadSafeProvider Base;
00043
00045         CalendarProvider();
00046
00048         virtual ~CalendarProvider();
00049
00051         void Init(Protector *protector);
00052
00054         INT GetProviderId() const { return c_calendar_provider_id; }
00055
00057         INT RowCount();
00058
00060         INT MaxRowCount() { return c_max_calendar_records; }
00061
00063         BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00064
00066         BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00067
00069         BOOLEAN GetRecordData(INT row, CalendarRecord *dst);
00070
00072         BOOLEAN SelectRow(INT row);
00073
00075         BOOLEAN CommitRow(INT row);
00076
00078         BOOLEAN DeleteRow(INT row);
00079
00081         BOOLEAN DeleteAllRows();
00082
00084         BOOLEAN AppendRow();
00085
00087         void SetDateIsValid(BOOLEAN valid);
00088
00089     protected:
00090
00091         INT             m_row_count;
00092         CalendarRecord  m_current_calendar_record;
00093         CalendarRecord  m_delete_record;
00094         RecordHandler   m_handler;
00095         BOOLEAN         m_date_is_valid;
00096 };
00097
00098 #endif  //CalendarProvider_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecord.cpp File Reference

Applications/Calendar/CalendarRecord.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarProvider.hpp"
#include <Auxiliary/String.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>

Include dependency graph for CalendarRecord.cpp:

Generated on Tue Jan 24 23:51:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecord.hpp File Reference

Applications/Calendar/CalendarRecord.hpp File Reference

#include "CalendarAppPreComp.hpp"
#include <AddOns/AdcExtensions/Record.hpp>
#include <Auxiliary/String.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>
#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for CalendarRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarRecord
struct | CalendarRecord::Persist

Defines

#define | CalendarRecord_hpp

Variables

const INT | max_calendar_description_len = 25

Define Documentation

#define CalendarRecord_hpp

Variable Documentation

const INT max_calendar_description_len = 25

Generated on Tue Jan 24 23:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecord.hpp Source File

Applications/Calendar/CalendarRecord.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(CalendarRecord_hpp)
00015 #define CalendarRecord_hpp
00016 #include "CalendarAppPreComp.hpp"
00017
00018 #include <AddOns/AdcExtensions/Record.hpp>
00019 #include <Auxiliary/String.hpp>
00020 #include <Auxiliary/Date.hpp>
00021 #include <Auxiliary/Time.hpp>
00022 #include <GuiExtensions/ActionAccessor.hpp>
00023
00024 const INT max_calendar_description_len = 25;
00025
00026
00027 class CalendarRecord: public Record {
00028
00029     typedef Record Base;
00030
00031     public:
00032         enum CalendarCategory{
00033             Memo,
00034             Meeting,
00035             Birthday,
00036             CallRemind,
00037             Anniversary,
00038             Other,
00039             CategoryCounts
00040         };
00041
00042         enum CalendarRecurrence{
00043             NoRepeat,
00044             Daily,
00045             Weekly,
00046             Monthly,
00047             Yearly,
00048             RecurrenceCounts
00049         };
00050
00051         // constructors
00053         CalendarRecord();
00054
00056         CalendarRecord(Date date, Time time, WString txt, CalendarCategory cat = Memo, CalendarRecurrence recurr = NoRepeat);
00057
00058         //descrturctor
00060         virtual ~CalendarRecord();
00061
00063         void Init();
00064
00066         void SetCategory(CalendarCategory cat){m_data.category = cat;}
00067
00069         CalendarCategory GetCategory(){return m_data.category;}
00070
00072         void SetDate(Date date){m_data.date = date;}
00073
00075         Date GetDate(){return m_data.date;}
00076
00078         void SetTime(Time time){m_data.time = time;}
00079
00081         Time GetTime(){return m_data.time;}
00082
00084         void SetRecurrence(CalendarRecurrence recurr){m_data.recurrence = recurr;}
00085
00087         CalendarRecurrence GetRecurrence(){return m_data.recurrence;}
00088
00090         void SetDescription(const WString &txt){WStrCpy(m_data.description, txt);}
00091
00093         const WCHAR *  GetDescription() const {return m_data.description;}
00094
00096         virtual const UINT8* GetData();
00097
00099         virtual void SetData(const UINT8* data);
00100
00102         virtual INT GetPersistentSize();
00103
00105         virtual void MarkDeleted();
00106
00108         virtual BOOLEAN IsRecordDeleted();
00109
00110
00111     protected:
00112         struct Persist {
00113             CalendarCategory    category;
00114             Date                date;
00115             Time                time;
00116             CalendarRecurrence  recurrence;
00117             WCHAR               description[max_calendar_description_len+1];
00118         } m_data;
00119
00120 };
00121
00122 #endif  //CalendarRecord_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecordsList.cpp File Reference

Applications/Calendar/CalendarRecordsList.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarRecordsList.hpp"
#include <Common/CommonMsgTypes.hpp>
#include <GuiExtensions/MmiAlert.hpp>

Include dependency graph for CalendarRecordsList.cpp:

Generated on Tue Jan 24 23:51:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecordsList.hpp File Reference

Applications/Calendar/CalendarRecordsList.hpp File Reference

#include <Gui/Lib.hpp>
#include "CalendarRecordsListBox.hpp"
#include "CalendarAddRecordWin.hpp"
#include "CalendarRecord.hpp"
#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for CalendarRecordsList.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarRecordsList

Defines

#define | Mmi_CalendarRecordsList_hpp

Define Documentation

#define Mmi_CalendarRecordsList_hpp

Generated on Tue Jan 24 23:51:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecordsList.hpp Source File

Applications/Calendar/CalendarRecordsList.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_CalendarRecordsList_hpp)
00011 #define Mmi_CalendarRecordsList_hpp
00014
00015 #include <Gui/Lib.hpp>
00016 #include "CalendarRecordsListBox.hpp"
00017 #include "CalendarAddRecordWin.hpp"
00018 #include "CalendarRecord.hpp"
00019 #include <GuiExtensions/MmiWindow.hpp>
00020 #include <GuiExtensions/ActionAccessor.hpp>
00021
00022 class CalendarRecordsList;
00023
00025 class CalendarRecordsList : public MmiWindow {
00026     typedef MmiWindow Base;
00027
00028     public:
00030         CalendarRecordsList();
00032         void Init();
00033
00035         void SetType(Date date);
00036
00038         INT GetEntryCount(Date date) {
00039             return m_listbox_model.GetEntryCount(date);
00040         }
00041
00043         BOOLEAN DeleteSelectedItem();
00045         BOOLEAN DeleteAllItems();
00046         //
00047         BOOLEAN ModifySelectedItem();
00048
00050         void UpdateView();
00051
00053         void SetWindow(CalendarAddRecordWin& win);
00054
00055     protected:
00057         virtual void OnOpen();
00058
00060         virtual BOOLEAN OnMessage(const Message &msg);
00061
00062     private:
00063         DrawableObjectListBox       m_listbox;
00064         CalendarRecordsListBoxModel m_listbox_model;
00065         CalendarAddRecordWin*       m_modify_record_win;
00066         CalendarRecord              m_record_to_modify;
00067         WString                     m_title;
00068 };
00069
00071 #endif  // Mmi_CalendarRecordsList_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecordsListBox.cpp File Reference

Applications/Calendar/CalendarRecordsListBox.cpp File Reference

#include "CalendarAppPreComp.hpp"
#include "CalendarProvider.hpp"
#include "CalendarRecordsListBox.hpp"
#include <AddOns/Services/ServiceBroker.hpp>
#include <Common/MmiServices.hpp>
#include <Auxiliary/Date.hpp>
#include <Auxiliary/Time.hpp>
#include <Auxiliary/FilterRule.hpp>
#include "CalendarApp.hpp"

Include dependency graph for CalendarRecordsListBox.cpp:

Generated on Tue Jan 24 23:51:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecordsListBox.hpp File Reference

Applications/Calendar/CalendarRecordsListBox.hpp File Reference

#include "CalendarRecord.hpp"
#include <GuiExtensions/LabelListBoxModel.hpp>
#include <Auxiliary/MainProvider.hpp>
#include <Auxiliary/QuickSortProvider.hpp>
#include <Auxiliary/FilterProvider.hpp>
#include <Auxiliary/FilterRule.hpp>

Include dependency graph for CalendarRecordsListBox.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CalendarRecordsListBoxModel

Defines

#define | Mmi_CalendarRecordsListBox_hpp

Define Documentation

#define Mmi_CalendarRecordsListBox_hpp

Generated on Tue Jan 24 23:51:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Calendar/CalendarRecordsListBox.hpp Source File

Applications/Calendar/CalendarRecordsListBox.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_CalendarRecordsListBox_hpp)
00011 #define Mmi_CalendarRecordsListBox_hpp
00012
00013 #include "CalendarRecord.hpp"
00014 #include <GuiExtensions/LabelListBoxModel.hpp>
00015 #include <Auxiliary/MainProvider.hpp>
00016 #include <Auxiliary/QuickSortProvider.hpp>
00017 #include <Auxiliary/FilterProvider.hpp>
00018 #include <Auxiliary/FilterRule.hpp>
00019
00021 class CalendarRecordsListBoxModel : public LabelListBoxModel {
00022     typedef LabelListBoxModel Base;
00023
00024     public:
00025         CalendarRecordsListBoxModel();
00026
00027         explicit CalendarRecordsListBoxModel(DrawableObjectListBox *listbox);
00028
00029         void Init(DrawableObjectListBox *listbox);
00030
00031         virtual const WCHAR* GetCellText(INT index, BOOLEAN highlighted);
00032
00033         virtual const BitmapRes* GetCellIcon(INT index, BOOLEAN highlighted);
00034
00035         void SetType(Date date);
00036
00037         INT GetEntryCount(Date date);
00038
00039         void UpdateRow(INT row);
00040
00041         WString GetNote();
00042
00043         void DeleteItem(INT index);
00044
00045         void DeleteAllItems();
00046
00047         BOOLEAN GetCalendarRecord(INT index, CalendarRecord *rec);
00048
00049     private:
00050         Provider            *m_provider;
00051         AbstractDelegationProvider *m_current_provider;
00052         Date                m_date;
00053         INT                 m_updated_row;
00054         MainProvider        m_main_provider;
00055         QuickSortProvider   m_sort_date_provider;
00056         QuickSortProvider   m_sort_time_provider;
00057         FilterProvider      m_filter_by_day_provider;
00058         EqualsRule          m_rule;
00059
00060         Vector<WString>     m_name_buf;
00061
00062         void                Update(Date);
00063 };
00064
00065 #endif  // Mmi_CalendarRecordsListBox_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraApp.cpp File Reference

Applications/Camera/CameraApp.cpp File Reference

#include "CameraPreComp.hpp"
#include <Auxiliary/RamData.hpp>
#include <Auxiliary/BufferPoolManager.hpp>
#include <AddOns/AfsRam/RamDataSink.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Atl/Properties/PropertyID.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/StillCamera.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Common/MmiInfoBox.hpp>
#include <Camera/CameraApp.hpp>
#include <Camera/CameraViewFinderWin.hpp>
#include <Config/MmiPropertyConfig.hpp>
#include <Config/FactorySettingsConfig.hpp>

Include dependency graph for CameraApp.cpp:

Generated on Tue Jan 24 23:51:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraApp.hpp File Reference

Applications/Camera/CameraApp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <Common/MmiApplication.hpp>
#include <Common/MmiServices.hpp>
#include <Camera/CameraViewFinderWin.hpp>

Include dependency graph for CameraApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CameraApp

Defines

#define | MAX_INDEX_FILE_SINK_ARRAY (0)
#define | Mmi_CameraApp_hpp

Define Documentation

#define MAX_INDEX_FILE_SINK_ARRAY (0)

#define Mmi_CameraApp_hpp

Generated on Tue Jan 24 23:52:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraApp.hpp Source File

Applications/Camera/CameraApp.hpp

Go to the documentation of this file.
00001 #if !defined(Mmi_CameraApp_hpp)
00002 #define Mmi_CameraApp_hpp
00003
00004 #include <Kernel/Lib.hpp>
00005 #include <AddOns/MultiMedia/JpegImage.hpp>
00006 #include <Common/MmiApplication.hpp>
00007 #include <Common/MmiServices.hpp>
00008 #include <Camera/CameraViewFinderWin.hpp>
00009
00010
00011 #define MAX_INDEX_FILE_SINK_ARRAY (0)
00012
00013 class CameraCaptureWin;
00014
00015 class CameraApp : public MmiApplication, public CameraService
00016 {
00017     typedef MmiApplication Base;
00018
00019     enum CameraPicAdjType
00020     {
00021         DOWN = -1,
00022         UP = 1
00023     };
00024
00026     enum FeatureIds {
00027         CamOpenViewfinder,  //open the viewfinder window "OpenViewfinder"
00028         CamZoomIn,
00029         CamZoomOut,
00030         CamNextSetting,
00031         CamPrevSetting,
00032         CamNextOption,
00033         CamPrevOption,
00034         CamIncrBrightness,
00035         CamDecrBrightness,
00036         CamClickPhoto,
00037         CamSelectOption,
00038         CamTimerToggle,
00039         CamFlashToggle,
00040         CamSettingsModeToggle,
00041         CamFeatureCnt
00042     };
00043
00045     enum PropertyIds {
00046         CamMultishot,       //Select the number of multishot photos to be taken "Multishot"
00047         CamResolution,      //Set the camera resolution (set)   "Resolution"
00048         CamWhiteBalance,    //set the white balance (set)   "WhiteBalance"
00049         CamColourFilter,    //set the colour    (set?)  "ColourFilter"
00050         CamAntiFlicker,
00051         CamTransform,
00052         CamTimer,           //store the amount of time before the photo is taken "Timer"
00053         CamFlash,           //Store the Flash settings
00054         CamTwilight,        //Store the Twilight settings
00055         CamTimerEnable,     //checkbox to enable/disable the timer feature "TimerEnable"
00056         CamFlashEnable,     //checkbox to enable/diable the flash
00057         CamTwilightEnable,  //checkbox to enable/diable Twilight
00058         CamContrast,        //set the contrast  (progress) "Contrast"
00059         CamJPEGQuality,     //set the JPEG quality (set) "JPEGQuality"
00060         //CamShutterTone,   //select the sound to be played when the photo is taken "ShutterTone"
00061         CamPropertyCnt
00062     };
00063
00064     CameraViewFinderWin     m_cameraviewfinder_window;  //instance of the viewfinder window
00065     CameraSettings          m_camerasettings_object;
00066
00067     static CameraApp        m_camera_app;   //static instance of the camera application
00068     UINT                    m_current_camera_idx;
00069     BOOLEAN                 m_settings_mode_enabled;
00070
00071     StillCamera*            m_camera_ref;
00072     DataSink*               m_File_Sink_Array[MAX_INDEX_FILE_SINK_ARRAY+1];
00073     JpegImage               m_jpeg_image;
00074
00075     UINT8                   m_current_selected_setting; //for properties 0 - 4
00076     UINT8                   m_current_selected_option;
00077
00078     Feature m_items[CamFeatureCnt];
00079     Property m_property[CamPropertyCnt];
00080
00081     public:
00083         static CameraApp* GetInstance();
00084
00085         StillCamera* GetCameraReference();
00086
00087         void LoadCameraSettings();
00088
00090         virtual ~CameraApp();
00091
00092         static void cb_image_captured(INT result, void* context, UINT16 frame);
00093         static void cb_image_encoded(INT result, void* context, UINT16 frame);
00094         static void cb_capture_finished(INT result, void* context, UINT16 frame);
00095
00096     protected:
00098         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00099
00101         virtual BOOLEAN OnPropertyNotification(const Property::Notification notification,
00102                                                const Property* property,
00103                                                const DataItem& value);
00104
00106         virtual void OnOpen();
00107
00109         virtual void OnClose();
00110
00112         virtual BOOLEAN OnMessage(const Message &msg);
00113
00114         virtual void OnStartup();
00115
00116     private:
00118         CameraApp(const WCHAR* app_name);
00119
00120         virtual ServiceResult CaptureImage(ImageObtainer &);
00121
00122         BOOLEAN GetCurrentJpegImage(JpegImage *pjpeg_image);
00123
00124         BOOLEAN SavePicture();
00125
00126         //New capture related funcs
00127         void ResetFileSink();
00128         BOOLEAN FillDataSinkObjects();
00129         BOOLEAN OpenAllFiles();
00130         void SetPreCaptureImageSize();
00131         BOOLEAN FreezePicture();
00132         void FreeDataSinkMemory();
00133
00134         //Viewfinder functions
00135         void SetViewfinderSettingModeText();
00136
00137         PropertyIds MatchPropertyString(const FeatureID &id);
00138
00139         BOOLEAN SetCameraDeviceProperty(PropertyIds id, DataItem value);
00140         BOOLEAN ToggleFlash(const DataItem& value);
00141         BOOLEAN ToggleTwilight(const DataItem& value);
00142 };
00143 #endif  // Mmi_CameraApp_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraCaptureWin.cpp File Reference

Applications/Camera/CameraCaptureWin.cpp File Reference

#include "CameraPreComp.hpp"
#include "CameraCaptureWin.hpp"
#include "CameraApp.hpp"
#include "MsgTypes.hpp"
#include <Config/CameraConfig.hpp>
#include <Devices/DeviceManager.hpp>
#include <Devices/StillCamera.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/AfsRam/RamDataSink.hpp>
#include <Afs/Rfs/FileBinData.hpp>

Include dependency graph for CameraCaptureWin.cpp:

Defines

#define | CLOSE_TEXT_SOFTKEY Tr(L"Close")
#define | DEBUG_CAMERA_CAPTURE_WIN_CPP
#define | DEBUG_CAMERA_CAPTURE_WIN_CPP_FILE (0)
#define | StillCameraTestCode

Functions

BOOLEAN | GetStoredCameraBuffer (UINT8 HUGE **captured_buffer, UINT32 *size)

Define Documentation

#define CLOSE_TEXT_SOFTKEY Tr(L"Close")

#define DEBUG_CAMERA_CAPTURE_WIN_CPP

#define DEBUG_CAMERA_CAPTURE_WIN_CPP_FILE (0)

#define StillCameraTestCode

Function Documentation

BOOLEAN GetStoredCameraBuffer | ( | UINT8 HUGE ** | captured_buffer,
 |  | UINT32 * | size
 | ) |

Generated on Tue Jan 24 23:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraCaptureWin.hpp File Reference

Applications/Camera/CameraCaptureWin.hpp File Reference

#include <Common/CommonMsgTypes.hpp>
#include <Camera/CameraApp.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/AfsRam/RamDataSink.hpp>
#include <Afs/Rfs/FileBinData.hpp>

Include dependency graph for CameraCaptureWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CameraCaptureWin

Defines

#define | MAX_INDEX_FILE_SINK_ARRAY (0)
#define | Mmi_CameraCaptureWin_hpp

Define Documentation

#define MAX_INDEX_FILE_SINK_ARRAY (0)

#define Mmi_CameraCaptureWin_hpp

Generated on Tue Jan 24 23:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraCaptureWin.hpp Source File

Applications/Camera/CameraCaptureWin.hpp

Go to the documentation of this file.
00001 #if !defined(Mmi_CameraCaptureWin_hpp)
00002 #define Mmi_CameraCaptureWin_hpp
00003
00004 #include <Common/CommonMsgTypes.hpp>
00005 #include <Camera/CameraApp.hpp>
00006
00007 #include <Auxiliary/RamData.hpp>
00008 #include <AddOns/AfsRam/RamDataSink.hpp>
00009 #include <Afs/Rfs/FileBinData.hpp>
00010
00011 #define MAX_INDEX_FILE_SINK_ARRAY (0)
00012
00013 class CameraCaptureWin : public MmiWindow
00014 {
00015     typedef MmiWindow Base;
00016
00017 public:
00018     virtual void Init(CameraApp *pcamera_app);
00019     BOOLEAN CancelCamera(INT status); //HaJo 29.08.2005
00020
00021         static void cb_image_captured(INT result, void* context, UINT16 frame);   //HaJo
00022         static void cb_image_encoded(INT result, void* context, UINT16 frame);    //HaJo
00023         static void cb_capture_finished(INT result, void* context, UINT16 frame); //HaJo
00024
00025 protected:
00026     virtual void OnOpen();
00027     virtual void OnClose();
00028     virtual void OnLoseFocus();
00029     virtual void OnGetFocus();
00030     virtual void OnPaint(const Rect& repaint_rect);
00031         virtual BOOLEAN OnMessage(const Message &msg);
00032
00033         Path    GetNewPath(Pathname  &path_name_1, WString &deviceIdStr) const;
00034
00035     StillCamera*            m_camera;   //HaJo
00036     UINT            m_current_camera_idx;
00037
00038     BOOLEAN                 m_camera_capture_canceling; //HaJo 29.08.2005
00039
00040     DataSink*           m_File_Sink_Array[MAX_INDEX_FILE_SINK_ARRAY+1];
00041
00042     CameraApp*      m_pcamera_app;
00043     JpegImage           m_jpeg_image;
00044 };
00045
00046 #endif //Mmi_CameraCaptureWin_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraLayoutSettingsWin.cpp File Reference

Applications/Camera/CameraLayoutSettingsWin.cpp File Reference

#include "CameraPreComp.hpp"
#include <Devices/Device.hpp>
#include <Auxiliary/WString.hpp>
#include "CameraSettingsWin.hpp"
#include "CameraViewFinderWin.hpp"
#include "CameraApp.hpp"
#include "CameraCaptureWinApplication.hpp"
#include "CameraCaptureWinService.hpp"
#include "cam_debug.h"

Include dependency graph for CameraLayoutSettingsWin.cpp:

Generated on Tue Jan 24 23:52:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraOptionSettingsWin.cpp File Reference

Applications/Camera/CameraOptionSettingsWin.cpp File Reference

#include "CameraPreComp.hpp"
#include <GuiExtensions/MmiAlert.hpp>
#include "CameraOptionSettingsWin.hpp"

Include dependency graph for CameraOptionSettingsWin.cpp:

Generated on Tue Jan 24 23:52:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraOptionSettingsWin.hpp File Reference

Applications/Camera/CameraOptionSettingsWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <Gui/RadioButtonControl.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include "CameraSettings.hpp"

Include dependency graph for CameraOptionSettingsWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CameraOptionSettingsWin

Defines

#define | CameraOptionSettingsWin_hpp

Define Documentation

#define CameraOptionSettingsWin_hpp

Generated on Tue Jan 24 23:52:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraOptionSettingsWin.hpp Source File

Applications/Camera/CameraOptionSettingsWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) Danish Wireless Design A/S. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(CameraOptionSettingsWin_hpp)
00010 #define CameraOptionSettingsWin_hpp
00011
00012 #include <GuiExtensions/MmiWindow.hpp>
00013 #include <Gui/RadioButtonControl.hpp>
00014 #include <Gui/RadioButtonGroup.hpp>
00015
00016 #include "CameraSettings.hpp"
00017
00018 class CameraOptionSettingsWin : public MmiWindow
00019 {
00020     typedef MmiWindow Base;
00021
00022 public:
00023     enum
00024     {
00025         MaFlsAuto,
00026         MaFlsOff,
00027         MaFlsRedEye,
00028         MaFlsLast
00029     }FlsType;
00030     enum
00031     {
00032         MaFliOff,
00033         MaFli50Hz,
00034         MaFli60Hz,
00035         MaFliLast
00036     }FliType;
00037     enum
00038     {
00039         MaWbAuto,
00040         MaWbOutdoor,
00041         MaWbIndoor,
00042         MaWbLast
00043     }WbType;
00044
00045     typedef enum
00046     {
00047         FlashType,
00048         WhiteBalanceType,
00049         AntiFlickerType,
00050     }WindowType;
00051
00052
00053     CameraOptionSettingsWin();
00054     virtual ~CameraOptionSettingsWin();
00055
00056     void Init(WindowType type);
00057
00058 protected:
00059     //this function is called before the window opens
00060     void OnOpen();
00061
00062     virtual void OnActionExecuted(Action *action);
00063     virtual void OnLayoutClient();
00064
00065 private:
00066     //Camera handler used to access the camera driver
00067 //  CameraHandler           *m_cam_handler;
00068
00069     Action          m_select_action;
00070     Action          m_cancel_action;
00071
00072 //  RadioButtonAction m_rb_action[MaSizeLast];
00073     RadioButtonControl m_rb_control[MaFlsLast];
00074     RadioButtonGroup    m_rb_list;
00075     StillCamera::FlashType m_map_fls[MaFlsLast]; //HaJo
00076     Camera::AntiFlickerType m_map_fli[MaFliLast];
00077     CameraSettings::WhiteBalanceType    m_map_wb[MaWbLast];
00078     //enum type
00079     WindowType              m_type;
00080 };
00081
00082 #endif
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraPreComp.cpp File Reference

Applications/Camera/CameraPreComp.cpp File Reference

#include "CameraPreComp.hpp"

Include dependency graph for CameraPreComp.cpp:

Generated on Tue Jan 24 23:52:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraPreComp.hpp File Reference

Applications/Camera/CameraPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>

Include dependency graph for CameraPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 23:52:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraPreComp.hpp Source File

Applications/Camera/CameraPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraSettings.cpp File Reference

Applications/Camera/CameraSettings.cpp File Reference

#include "CameraPreComp.hpp"
#include "CameraSettings.hpp"
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/File.hpp>
#include <Devices/DeviceManager.hpp>

Include dependency graph for CameraSettings.cpp:

Generated on Tue Jan 24 23:52:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraSettings.hpp File Reference

Applications/Camera/CameraSettings.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CameraSettings

Defines

#define | Mmi_CameraSettings_hpp

Define Documentation

#define Mmi_CameraSettings_hpp

Generated on Tue Jan 24 23:52:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraSettings.hpp Source File

Applications/Camera/CameraSettings.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_CameraSettings_hpp)
00010 #define Mmi_CameraSettings_hpp
00011
00012 /*
00013     This class exists only to provide an interface with the Apoxi/StillCamera class.
00014
00015     This allows us to put the functionality in another class without having to clutter
00016     up the CameraApp class. All functions directly/indirectly call the interfaces provided
00017     by CameraInterface.hpp file. As a result, all the functions of this class are public.
00018
00019     There is one member variable that is aa reference to the StillCamera class. This is because
00020     it would be easier to store the reference once than to make function calls to retrieve the
00021     reference (either from CameraApp or from DeviceManager) everytime it has to be used.
00022 */
00023 class CameraSettings
00024 {
00025
00026 public:
00027
00028     //Not really needed, just for debug info
00029     CameraSettings();
00030
00031     //Not really needed, but just there for completeness
00032     ~CameraSettings();
00033
00034     BOOLEAN                 Init(StillCamera* stillcamera_ref, UINT8 display_idx);
00035
00036     BOOLEAN                 SetBrightness(INT brightness);
00037     INT                     GetBrightness() const;
00038
00039     BOOLEAN                 SetContrast(INT contrast);
00040     INT                     GetContrast() const;
00041
00042     BOOLEAN                 SetZoom(Camera::ActionType zoom);
00043     INT                     GetZoom() const;    //Not supported by Apoxi yet
00044
00045     BOOLEAN                 SetImageSize(Camera::ImageSizeType size);
00046     Camera::ImageSizeType   GetImageSize() const;
00047
00048     BOOLEAN                 SetFlash(StillCamera::FlashType flash);
00049     StillCamera::FlashType      GetFlash() const;
00050
00051     BOOLEAN                 SetAntiFlicker(Camera::AntiFlickerType antiflicker);
00052     Camera::AntiFlickerType GetAntiFlicker() const;
00053
00054     BOOLEAN                 SetWhiteBalance(Camera::WhiteBalanceType wb);
00055     //WhiteBalanceType      GetWhiteBalance();  //Not supported by the interface right now
00056
00057     BOOLEAN                 SetTwilight(Camera::TwilightType twilight);
00058     Camera::TwilightType        GetTwilight() const;
00059
00060      BOOLEAN                SetJPEGQuality(INT quality);
00061      INT                                GetJPEGQuality() const;
00062
00063      BOOLEAN                    SetTransformation(Camera::TransformationType transType);
00064      Camera::TransformationType GetTransformation() const;
00065
00066      BOOLEAN                SetFilter(Camera::FilterType filter);
00067      Camera::FilterType     GetFilter() const;
00068
00069
00070
00071 private:
00072     StillCamera*    m_camera_ref;
00073     INT             m_zoom_level;
00074     UINT8           m_display_idx;
00075 };
00076
00077
00078 #endif
00079
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraSettingsWin.cpp File Reference

Applications/Camera/CameraSettingsWin.cpp File Reference

#include "CameraPreComp.hpp"
#include <GuiExtensions/MmiAlert.hpp>
#include <Config/CameraConfig.hpp>
#include <Devices/DeviceManager.hpp>
#include "CameraSettingsWin.hpp"

Include dependency graph for CameraSettingsWin.cpp:

Defines

#define | DEBUG_CAMERA_SETTINGS_WIN_CPP
#define | DEBUG_CAMERA_SETTINGS_WIN_CPP_FILE (0)
#define | ENABLE_ONLY_THE_TEST_APPLICATION

Define Documentation

#define DEBUG_CAMERA_SETTINGS_WIN_CPP

#define DEBUG_CAMERA_SETTINGS_WIN_CPP_FILE (0)

#define ENABLE_ONLY_THE_TEST_APPLICATION

Generated on Tue Jan 24 23:52:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraSettingsWin.hpp File Reference

Applications/Camera/CameraSettingsWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <Gui/RadioButtonControl.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include "CameraSettings.hpp"
#include "HorizontalListControl.hpp"

Include dependency graph for CameraSettingsWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CameraSettingsWin

Defines

#define | CameraSettingsWin_hpp

Define Documentation

#define CameraSettingsWin_hpp

Generated on Tue Jan 24 23:52:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraSettingsWin.hpp Source File

Applications/Camera/CameraSettingsWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) Danish Wireless Design A/S. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(CameraSettingsWin_hpp)
00010 #define CameraSettingsWin_hpp
00011
00012 #include <GuiExtensions/MmiWindow.hpp>
00013 #include <Gui/RadioButtonControl.hpp>
00014 #include <Gui/RadioButtonGroup.hpp>
00015 #include "CameraSettings.hpp"
00016 #include "HorizontalListControl.hpp"
00017
00018
00019
00020 class CameraSettingsWin : public MmiWindow
00021 {
00022     typedef MmiWindow Base;
00023
00024 public:
00025
00026     CameraSettingsWin();
00027     virtual ~CameraSettingsWin();
00028
00029     void Init();
00030
00031 protected:
00032     //this function is called before the window opens
00033     void OnOpen();
00034     void OnClose();
00035
00036     virtual void OnActionExecuted(Action *action);
00037     virtual void OnLayoutClient();
00038 //  virtual BOOLEAN OnKeyDown(KeyCode key_code);
00039
00040 private:
00041     Action          m_select_action;
00042     Action          m_cancel_action;
00043
00044
00045     TextLine        m_label_1;
00046     TextLine        m_label_2;
00047     TextLine        m_label_3;
00048         TextLine        m_label_4;  //HaJo 15.09.2005
00049
00050     HorizontalListControl   m_select_1;
00051     HorizontalListControl   m_select_2;
00052     HorizontalListControl   m_select_3;
00053         HorizontalListControl   m_select_4; //HaJo 15.09.2005
00054
00055     WString             m_size_list[MAX_ENTRY_COUNT];
00056     Camera::ImageSizeType       m_size_map[MAX_ENTRY_COUNT];
00057     WString             m_color_list[MAX_ENTRY_COUNT];
00058     //HaJo
00059     /*
00060     Camera::ColorFormatType     m_color_map[MAX_ENTRY_COUNT];
00061     */
00062     WString             m_jpeg_list[MAX_ENTRY_COUNT];
00063     INT                         m_jpeg_map[MAX_ENTRY_COUNT]; //HaJo 21.09.2005
00064
00065     WString             m_transformation_list[MAX_ENTRY_COUNT]; //HaJo 15.09.2005
00066     Camera::TransformationType  m_transformation_map[MAX_ENTRY_COUNT];  //HaJo 15.09.2005
00067
00068 };
00069
00070 #endif
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraViewFinderWin.cpp File Reference

Applications/Camera/CameraViewFinderWin.cpp File Reference

#include "CameraPreComp.hpp"
#include <Config/MmiGuiEngineConfig.hpp>
#include <Devices/Device.hpp>
#include <Devices/StillCamera.hpp>
#include <Devices/DeviceManager.hpp>
#include <Auxiliary/WString.hpp>
#include <Common/MmiInfoBox.hpp>
#include "CameraViewFinderWin.hpp"
#include "CameraApp.hpp"

Include dependency graph for CameraViewFinderWin.cpp:

Defines

#define CAMERA_VIEW_FINDER_TITLE Tr(L"Camera ViewFinder")

Define Documentation

#define CAMERA_VIEW_FINDER_TITLE Tr(L"Camera ViewFinder")

Generated on Tue Jan 24 23:52:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraViewFinderWin.hpp File Reference

Applications/Camera/CameraViewFinderWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <Common/CommonMsgTypes.hpp>
#include "CameraSettings.hpp"

Include dependency graph for CameraViewFinderWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CameraViewFinderWin

Defines

#define | Mmi_CameraViewFinderWin_hpp

Define Documentation

#define Mmi_CameraViewFinderWin_hpp

Generated on Tue Jan 24 23:52:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/CameraViewFinderWin.hpp Source File

Applications/Camera/CameraViewFinderWin.hpp

Go to the documentation of this file.
00001 #if !defined(Mmi_CameraViewFinderWin_hpp)
00002 #define Mmi_CameraViewFinderWin_hpp
00003
00004 #include <GuiExtensions/MmiWindow.hpp>
00005 #include <GuiExtensions/MmiAlert.hpp>
00006 #include <Common/CommonMsgTypes.hpp>
00007 #include "CameraSettings.hpp"
00008
00009 class CameraApp;
00010
00011 //class CameraViewFinderWin : public CameraLayoutSettingsWin
00012 class CameraViewFinderWin : public MmiWindow
00013 {
00014     //typedef CameraLayoutSettingsWin Base;
00015     typedef MmiWindow Base;
00016
00017
00018
00019 public:
00020     void Init(CameraApp *pcamera_app);
00021     void SetViewFinderRectToNewFormat(Rect& vf_rect, Camera::ImageSizeType size_type);
00022
00023     void SetSettingModeTextline(const WString &);
00024     void RefreshViewFinder();
00025
00026 protected:
00027     void OnOpen();
00028     void OnClose();
00029
00030     virtual void OnLayoutClient(); //copied from CameraLayoutSettingsWin.hpp
00031     virtual void OnLoseFocus();
00032     virtual void OnGetFocus();
00033     virtual void OnPaint(const Rect& repaint_rect);
00034
00035     void RedrawStatusLine();    //copied from CameraLayoutSettingsWin.hpp
00036
00037     //copied from CameraLayoutSettingsWin.hpp
00038     WString                 m_wstr_settingmode;
00039     TextLine                m_textline_settingmode;
00040     ImageBox                m_arrow_prev;
00041     ImageBox                m_arrow_next;
00042
00043 private:
00044
00045
00046     StillCamera*                m_camera_ref;   //HaJo
00047     UINT                    m_current_camera_idx;
00048
00049     CameraApp               *m_pcamera_app;
00050
00051     BOOLEAN                 m_init;
00052 };
00053
00054 #endif //Mmi_CameraViewFinderWin_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/MsgTypes.cpp File Reference

Applications/Camera/MsgTypes.cpp File Reference

#include "CameraPreComp.hpp"
#include "MsgTypes.hpp"

Include dependency graph for MsgTypes.cpp:

Generated on Tue Jan 24 14:55:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/MsgTypes.hpp File Reference

Applications/Camera/MsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for MsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CameraMsgStartViewfinding
class | CameraMsgStopViewfinding

Defines

#define | Common_MsgTypes_hpp

Define Documentation

#define Common_MsgTypes_hpp

Generated on Tue Jan 24 14:56:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Camera/MsgTypes.hpp Source File

Applications/Camera/MsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\Ehlersh_MP1E_Multi_V1\lnz_apps_int\Applications\Camera\MsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Common_MsgTypes_hpp)
00014 #define Common_MsgTypes_hpp
00015 #include <Kernel/Message.hpp>
00016 #include <Auxiliary/WString.hpp>
00017 /* ----------------------------------------------------------------------
00018     Classes
00019     ---------------------------------------------------------------------- */
00020 /*  ======================================================================
00021     Class CameraMsgStartViewfinding
00022     ====================================================================== */
00023 class CameraMsgStartViewfinding : public ContextMsg {
00024     public:
00025         CameraMsgStartViewfinding(ExecutionContext* context);
00026         virtual ~CameraMsgStartViewfinding();
00027
00028         virtual const MsgMetaData& GetMetaData() const;
00029         virtual Message* Clone() const;
00030
00031         enum  {
00032             ID = 22700
00033             };
00034
00035     private:
00036         static const MsgMetaData m_meta_data;
00037
00038     };
00039 /*  ======================================================================
00040     Class CameraMsgStopViewfinding
00041     ====================================================================== */
00042 class CameraMsgStopViewfinding : public ContextMsg {
00043     public:
00044         CameraMsgStopViewfinding(ExecutionContext* context);
00045         virtual ~CameraMsgStopViewfinding();
00046
00047         virtual const MsgMetaData& GetMetaData() const;
00048         virtual Message* Clone() const;
00049
00050         enum  {
00051             ID = 22701
00052             };
00053
00054     private:
00055         static const MsgMetaData m_meta_data;
00056
00057     };
00058 #endif // Common_MsgTypes_hpp
Generated on Tue Jan 24 14:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/CsdDataConnProvider.cpp File Reference

Applications/DataConn/CsdDataConnProvider.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Socket/DataConnProfileManager.hpp>
#include "DataConnApp.hpp"
#include "CsdDataConnProvider.hpp"

Include dependency graph for CsdDataConnProvider.cpp:

Generated on Tue Jan 24 23:53:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/CsdDataConnProvider.hpp File Reference

Applications/DataConn/CsdDataConnProvider.hpp File Reference

#include <Socket/CsdDataConnProfile.hpp>
#include <DataConn/DataConnProvider.hpp>

Include dependency graph for CsdDataConnProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CsdDataConnProvider

Defines

#define | Mmi_CsdDataConnProvider_hpp

Define Documentation

#define Mmi_CsdDataConnProvider_hpp

Generated on Tue Jan 24 23:53:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/CsdDataConnProvider.hpp Source File

Applications/DataConn/CsdDataConnProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_CsdDataConnProvider_hpp)
00015 #define Mmi_CsdDataConnProvider_hpp
00019
00020 #include <Socket/CsdDataConnProfile.hpp>
00021
00022 #include <DataConn/DataConnProvider.hpp>
00023
00024 class CsdDataConnProvider : public DataConnProvider
00025 {
00026     public:
00027         typedef DataConnProvider Base;
00028
00031         CsdDataConnProvider();
00032
00034         virtual ~CsdDataConnProvider();
00035
00036         virtual INT GetProviderId() const { return c_invalid_colid; }
00037
00039         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00040
00042         virtual BOOLEAN SetDataItem(const DataItem & item, INT column);
00043
00044     protected:
00045         virtual DataConnProfile* GetProfileInstance() { return &m_csd_profile; }
00046         virtual void ClearProfile();
00047
00048     private:
00049         CsdDataConnProfile  m_csd_profile;
00050 };
00051
00053 #endif
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnAccessor.cpp File Reference

Applications/DataConn/DataConnAccessor.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Asc/PdpContext.hpp>
#include <Socket/DataConnManager.hpp>
#include <Auxiliary/IpAddr.hpp>
#include <GuiExtensions/MmiPhoneNumberPrompt.hpp>
#include <GuiExtensions/MmiPasswordPrompt.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Socket/SerDataConnProfile.hpp>
#include "DataConnApp.hpp"
#include "DataConnAccessor.hpp"
#include "IpAddrPrompt.hpp"
#include "NumberPrompt.hpp"
#include "DataConnTextMaps.hpp"

Include dependency graph for DataConnAccessor.cpp:

Generated on Tue Jan 24 23:53:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnAccessor.hpp File Reference

Applications/DataConn/DataConnAccessor.hpp File Reference

#include <Socket/SocketTypes.hpp>
#include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
#include <GuiExtensions/MmiPrompt.hpp>
#include <DataConn/DataConnOptionWin.hpp>

Include dependency graph for DataConnAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CsdDataConnAccessor
class | DataConnAccessor
class | PsdDataConnAccessor
class | SerDataConnAccessor

Defines

#define | ApoxiRb_DataConnAccessor_hpp

Variables

const INT | c_psd_menu_item_count = 10
const INT | c_ser_menu_item_count = 2

Define Documentation

#define ApoxiRb_DataConnAccessor_hpp

Generated on Tue Jan 24 23:53:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnAccessor.hpp Source File

Applications/DataConn/DataConnAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiRb_DataConnAccessor_hpp)
00011 #define ApoxiRb_DataConnAccessor_hpp
00014
00015 #include <Socket/SocketTypes.hpp>
00016 #include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
00017 #include <GuiExtensions/MmiPrompt.hpp>
00018 #include <DataConn/DataConnOptionWin.hpp>
00019
00020
00021 #if defined (APOXI_STACK_UMTS)
00022     const INT c_psd_menu_item_count = 24;
00023 #else
00024     const INT c_psd_menu_item_count = 10;
00025 #endif
00026
00027 #if !defined(DATA_CONN_APP_EXCLUDE_SERIAL)
00028     const INT c_ser_menu_item_count = 2;
00029 #endif
00030 class DataConnProfile;
00031 class CsdDataConnProfile;
00032 class PsdDataConnProfile;
00033
00034 class DataConnAccessor : public AbstractMmiMenuAccessor {
00035     typedef AbstractMmiMenuAccessor Base;
00036
00037     public:
00038         DataConnAccessor(DataConnProfile *profile);
00039         virtual ~DataConnAccessor();
00040
00041         void Init();
00042
00043         virtual BOOLEAN First();
00044         virtual BOOLEAN Next();
00045
00047         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00048
00049         virtual INT CountSettings() const;
00050
00051         virtual void Update();
00052
00053         virtual BOOLEAN IsEnabled();
00054
00055     protected:
00056         DataConnProfileId GetProfileId() { return m_profile_id; }
00057         virtual INT GetIndex() { return m_it; }
00058
00059         virtual void OnTrigger(INT selected_idx);
00060
00061     private:
00062         WString             m_settings[10];
00063         INT                 m_it;
00064         DataConnProfileId   m_profile_id;
00065         DataConnProfile     *m_profile;
00066 };
00067
00068 class CsdDataConnAccessor : public DataConnAccessor {
00069     typedef DataConnAccessor Base;
00070
00071     public:
00072         CsdDataConnAccessor(CsdDataConnProfile *profile);
00073         virtual ~CsdDataConnAccessor();
00074
00075         void Init();
00076
00078         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00079
00080         virtual void Update();
00081
00082     protected:
00083         virtual INT CountSettings() const;
00084         virtual void OnTrigger(INT selected_idx);
00085
00086     private:
00087         CsdDataConnProfile *m_profile;
00088         WString             m_add_settings[10];
00089 };
00090
00091 class PsdDataConnAccessor : public DataConnAccessor {
00092     typedef DataConnAccessor Base;
00093
00094     public:
00095         PsdDataConnAccessor(PsdDataConnProfile *profile);
00096         virtual ~PsdDataConnAccessor();
00097
00098         void Init();
00099
00101         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00102
00103         virtual void Update();
00104
00105     protected:
00106         virtual INT CountSettings() const;
00107         virtual void OnTrigger(INT selected_idx);
00108
00109     private:
00110         PsdDataConnProfile *    m_profile;
00111         WString                 m_add_settings[c_psd_menu_item_count];
00112 };
00113
00114 #if !defined(DATA_CONN_APP_EXCLUDE_SERIAL)
00115 class SerDataConnProfile;
00116 class SerDataConnAccessor : public DataConnAccessor {
00117     typedef DataConnAccessor Base;
00118
00119     public:
00120         SerDataConnAccessor(SerDataConnProfile *profile);
00121         virtual ~SerDataConnAccessor();
00122
00123         void Init();
00124
00126         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00127
00128         virtual void Update();
00129
00130     protected:
00131         virtual INT CountSettings() const;
00132         virtual void OnTrigger(INT selected_idx);
00133
00134     private:
00135         SerDataConnProfile *    m_profile;
00136         WString                 m_add_settings[c_ser_menu_item_count];
00137 };
00138 #endif
00139
00141 #endif  // ApoxiRb_DataConnAccessor_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnApp.cpp File Reference

Applications/DataConn/DataConnApp.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Socket/DataConnProfileManager.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Kernel/VersionInfo.hpp>
#include <Config/DataConnConfig.hpp>
#include <Atl/Properties/PropertyItem.hpp>
#include "DataConnApp.hpp"

Include dependency graph for DataConnApp.cpp:

Functions

ApoxiUseVersionInfo (DataCon)

Variables

DataConnApp::EditableSettingTable c_common_setting_editable []
DataConnApp::EditableSettingTable c_csd_setting_editable []
DataConnApp::EditableSettingTable c_psd_setting_editable []

Function Documentation

ApoxiUseVersionInfo ( DataCon )

Variable Documentation

DataConnApp::EditableSettingTable c_common_setting_editable[]

Initial value:

 {
    { DataConnApp::PropName, FALSE },
    { DataConnApp::PropAccount, TRUE },
    { DataConnApp::PropPasswd, TRUE },
    { DataConnApp::PropQueryPasswd, TRUE },
    { DataConnApp::PropPrimaryDnsServerAddress, TRUE },
    { DataConnApp::PropSecondaryDnsServerAddress, TRUE },
    { DataConnApp::PropInvalidId, FALSE }
}

DataConnApp::EditableSettingTable c_csd_setting_editable[]

Initial value:

 {
    { DataConnApp::PropCallType, FALSE },
    { DataConnApp::PropPhoneNo, FALSE },
    { DataConnApp::PropDataRate, TRUE },
    { DataConnApp::PropIdleTimer, TRUE },
    { DataConnApp::PropLingerTimer, TRUE },
    { DataConnApp::PropInvalidId, FALSE }
}

DataConnApp::EditableSettingTable c_psd_setting_editable[]

Initial value:

 {
    { DataConnApp::PropApnName, FALSE },
    { DataConnApp::PropLocalAddr, FALSE },
    { DataConnApp::PropAuthType, FALSE },
    { DataConnApp::PropDataCompr, TRUE },
    { DataConnApp::PropQosPrecedence, TRUE },
    { DataConnApp::PropQosDelay, TRUE },
    { DataConnApp::PropQosReliability, TRUE },
    { DataConnApp::PropQosPeakRate, TRUE },
    { DataConnApp::PropQosMeanRate, TRUE },

    { DataConnApp::PropInvalidId, FALSE }
}

Generated on Tue Jan 24 23:53:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnApp.hpp File Reference

Applications/DataConn/DataConnApp.hpp File Reference

#include <Atl/Gui/AtlItemMenuWindow.hpp>
#include <Atl/Gui/AtlItemListWindow.hpp>
#include <Atl/Features/ProviderProxyContainer.hpp>
#include <Atl/Features/FeatureID.hpp>
#include <Common/MmiApplication.hpp>
#include <Config/DataConnConfig.hpp>
#include <DataConn/MyDataConnProfileStorage.hpp>
#include <DataConn/DataConnProvider.hpp>
#include <DataConn/CsdDataConnProvider.hpp>
#include <DataConn/PsdDataConnProvider.hpp>
#include <DataConn/SerDataConnProvider.hpp>
#include <Socket/SerDataConnProfile.hpp>

Include dependency graph for DataConnApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnApp
class | DataConnApp::DataConnDescription
struct | DataConnApp::EditableSettingTable

Defines

#define | Mmi_DataConnApp_hpp

Typedefs

typedef DataConnProfile::ProfileType | DataConnProfileType
typedef DataConnConfig::PropertyType | DataConnPropertyType

Define Documentation

#define Mmi_DataConnApp_hpp

Generated on Tue Jan 24 23:53:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnApp.hpp Source File

Applications/DataConn/DataConnApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_DataConnApp_hpp)
00009 #define Mmi_DataConnApp_hpp
00012 #include <Atl/Gui/AtlItemMenuWindow.hpp>
00013 #include <Atl/Gui/AtlItemListWindow.hpp>
00014 #include <Atl/Features/ProviderProxyContainer.hpp>
00015 #include <Atl/Features/FeatureID.hpp>
00016
00017 #include <Common/MmiApplication.hpp>
00018 #include <Config/DataConnConfig.hpp>
00019
00020 #include <DataConn/MyDataConnProfileStorage.hpp>
00021 #include <DataConn/DataConnProvider.hpp>
00022 #include <DataConn/CsdDataConnProvider.hpp>
00023 #include <DataConn/PsdDataConnProvider.hpp>
00024 #include <DataConn/SerDataConnProvider.hpp>
00025
00026 #if !defined(DATA_CONN_APP_EXCLUDE_SERIAL)
00027     #include <Socket/SerDataConnProfile.hpp>
00028 #endif
00029
00030 class Property;
00031
00032 typedef DataConnProfile::ProfileType DataConnProfileType;
00033 typedef DataConnConfig::PropertyType DataConnPropertyType;
00034
00035 class DataConnApp : public MmiApplication {
00036     typedef MmiApplication Base;
00037
00038     public:
00039         virtual ~DataConnApp();
00040         static DataConnApp* GetInstance();
00041
00042         struct EditableSettingTable {
00043             INT type;
00044             BOOLEAN always_editable;
00045         };
00046
00047         class DataConnDescription {
00048             public:
00049                 DataConnDescription(Property* property, INT prop_cnt, DataConnProfileType profile_type,
00050                                 DataConnProvider* provider, EditableSettingTable* editable_table = 0, BOOLEAN allocated_dynamically = TRUE);
00051
00052                 Property* GetFirstProperty() const { return m_property; }
00053                 INT GetPropCnt() const { return m_prop_cnt; }
00054                 DataConnProfileType GetDataConnProfileType() const { return m_type; }
00055                 DataConnProvider* GetProvider() const { return m_provider; }
00056                 EditableSettingTable* GetEditableTable() const { return m_editable_table; }
00057                 BOOLEAN IsAllocatedDynamically() const { return m_allocated_dynamically; }
00058             private:
00059                 Property* m_property;
00060                 INT m_prop_cnt;
00061                 DataConnProfileType m_type;
00062                 DataConnProvider* m_provider;
00063                 EditableSettingTable* m_editable_table;
00064                 BOOLEAN m_allocated_dynamically;
00065         };
00066
00067         enum FeatureId {
00068             FeatViewDataConnList,
00069             FeatEditProfile,
00070             FeatDeleteProfile,
00071             FeatSaveProfile,
00072             FeatSetDefaultProfile,
00073             FeatureCnt
00074         };
00075
00076         enum { PropInvalidId = -1 };
00077
00078         enum CommonPropertyId {
00079             PropName,
00080             PropAccount,
00081             PropPasswd,
00082             PropQueryPasswd,
00083             PropPrimaryDnsServerAddress,
00084             PropSecondaryDnsServerAddress,
00085             CommonPropCount
00086         };
00087
00088         enum CsdPropertyId {
00089             PropCallType,
00090             PropPhoneNo,
00091             PropDataRate,
00092             PropIdleTimer,
00093             PropLingerTimer,
00094             CsdPropCount
00095         };
00096
00097         enum PsdPropertyId {
00098             PropApnName,
00099             PropLocalAddr,
00100             PropAuthType,
00101             PropDataCompr,
00102             PropQosPrecedence,
00103             PropQosDelay,
00104             PropQosReliability,
00105             PropQosPeakRate,
00106             PropQosMeanRate,
00107 #ifdef APOXI_STACK_UMTS
00108             Prop3GPresent,
00109             PropTrafficClass,
00110             PropDeliveryOrder,
00111             PropErrorSduDelivery,
00112             PropMaxSduSize,
00113             PropBitRateUp,
00114             PropBitRateDown,
00115             PropResidualBer,
00116             PropSduErrorRatio,
00117             PropTransferDelay,
00118             PropTrafficPriority,
00119             PropGuaranteedBitRateUp,
00120             PropGuaranteedBitRateDown,
00121 #endif
00122             PsdPropCount
00123         };
00124
00125         enum SerPropertyId {
00126 #if !defined(DATA_CONN_APP_EXCLUDE_SERIAL)
00127             PropSerIdleTimer,
00128             PropSerLingerTimer,
00129 #endif
00130             SerPropCount
00131         };
00132
00134         virtual void OnStartup();
00135
00137         virtual BOOLEAN UpdateItem(Item* item);
00138
00140         void AddDataConnDescription(DataConnDescription* dataconn_desc);
00141
00142     protected:
00144         virtual void OnOpen();
00145
00147         virtual void OnClose();
00148
00150         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00152         virtual BOOLEAN OnContextFeatureTriggered (const FeatureID& feature_id, const DataItem& context_item);
00153
00154     private:
00155         DataConnApp();
00156
00157         INT AddProfile(DataConnProfile::ProfileType profile_type);
00158         void EditProfile(INT row);
00159         void UpdateProperties(DataConnProfileType type, INT row);
00160         void UpdateProperties(Property* property, INT prop_cnt, Provider* provider, INT row, INT id_offset);
00161         BOOLEAN IsMyFeatureItem(Item* item) const;
00162         INT GetPropertyId(DataConnPropertyType type, const FeatureID& property_id) const;
00163         DataConnProvider* GetDataConnProvider(INT row);
00164
00165         BOOLEAN SettingAlwaysEditable(EditableSettingTable* table, INT setting);
00166         void UpdateAvailableProperties(DataConnProfileType actual_type);
00167         DataConnDescription* GetDataConnDescription(DataConnProfileType type) const;
00168         void CommitProperties(INT row);
00169         void CommitProperties(Property* property, INT prop_cnt, Provider* provider, INT id_offset);
00170
00171         BOOLEAN IsReadOnly(INT row, INT prop_id);
00172
00173         ContextFeature m_new_profile;
00174         Feature m_features[FeatureCnt];
00175         static const CHAR* m_feature_strings[FeatureCnt + CommonPropCount + CsdPropCount + PsdPropCount + SerPropCount];
00176         Property m_common_properties[CommonPropCount];
00177         Property m_csd_properties[CsdPropCount];
00178         Property m_psd_properties[PsdPropCount];
00179 #if !defined(DATA_CONN_APP_EXCLUDE_SERIAL)
00180         Property m_ser_properties[SerPropCount];
00181         SerDataConnProvider m_ser_provider;
00182 #endif
00183
00184         AtlItemListWindow m_list_win;
00185         AtlItemMenuWindow m_edit_win;
00186         ProviderProxyContainer m_item_cont;
00187         CsdDataConnProvider m_csd_provider;
00188         PsdDataConnProvider m_psd_provider;
00189
00190         Vector<DataConnDescription*> m_dataconn_desc_vec;
00191
00192         MyDataConnProfileStorage        m_storage;
00193 };
00194
00196 #endif  // Mmi_DataConnApp_hpp
00197
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnOptionWin.cpp File Reference

Applications/DataConn/DataConnOptionWin.cpp File Reference

#include "DataConnPreComp.hpp"
#include "DataConnOptionWin.hpp"

Include dependency graph for DataConnOptionWin.cpp:

Generated on Tue Jan 24 23:54:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnOptionWin.hpp File Reference

Applications/DataConn/DataConnOptionWin.hpp File Reference

#include <GuiExtensions/MmiDialog.hpp>
#include <GuiExtensions/RadioButtonListBoxModel.hpp>
#include <GuiExtensions/DrawableObjectListBox.hpp>

Include dependency graph for DataConnOptionWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnOptionWin

Defines

#define | Apoxi_DataConnOptionWin_hpp

Define Documentation

#define Apoxi_DataConnOptionWin_hpp

Generated on Tue Jan 24 23:54:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnOptionWin.hpp Source File

Applications/DataConn/DataConnOptionWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_DataConnOptionWin_hpp)
00009 #define Apoxi_DataConnOptionWin_hpp
00012
00013 #include <GuiExtensions/MmiDialog.hpp>
00014 #include <GuiExtensions/RadioButtonListBoxModel.hpp>
00015 #include <GuiExtensions/DrawableObjectListBox.hpp>
00016
00017 class DataConnOptionWin : public MmiDialog {
00018     public:
00019         typedef MmiDialog Base;
00020
00021         DataConnOptionWin();
00022         virtual ~DataConnOptionWin();
00023
00024         void Init();
00025
00026         void AddAction(RadioButtonAction *action) { m_lb_model.Add(action); }
00027
00028         void SetSelectedRadioButton(INT value);
00029
00030         INT GetSelectedValue();
00031
00032     protected:
00033         virtual BOOLEAN OnConfirm();
00034
00035     private:
00036         RadioButtonListBoxModel m_lb_model;
00037         DrawableObjectListBox   m_lb;
00038 };
00039
00041 #endif  // Apoxi_DataConnWin_hpp
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnPreComp.cpp File Reference

Applications/DataConn/DataConnPreComp.cpp File Reference

#include "DataConnPreComp.hpp"

Include dependency graph for DataConnPreComp.cpp:

Generated on Tue Jan 24 23:54:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnPreComp.hpp File Reference

Applications/DataConn/DataConnPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for DataConnPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 23:54:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnPreComp.hpp Source File

Applications/DataConn/DataConnPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Asc/Lib.hpp>
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnProvider.cpp File Reference

Applications/DataConn/DataConnProvider.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Socket/DataConnProfileManager.hpp>
#include <Config/MmiConfig.hpp>
#include <Config/MmiGuiEngineConfig.hpp>
#include <Atl/Gui/ImgObtObj.hpp>
#include "DataConnApp.hpp"
#include "DataConnProvider.hpp"

Include dependency graph for DataConnProvider.cpp:

Generated on Tue Jan 24 23:55:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnProvider.hpp File Reference

Applications/DataConn/DataConnProvider.hpp File Reference

#include <Auxiliary/Provider.hpp>

Include dependency graph for DataConnProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnProvider

Defines

#define | Mmi_DataConnProvider_hpp

Enumerations

enum DataConnColids {
c_dataconn_icon_id = 100, c_dataconn_display_text_id, c_dataconn_profile_id, c_dataconn_profile_count_id,
c_dataconn_profile_type_id, c_dataconn_next_free_row_id, c_dataconn_is_readonly_id
}

Define Documentation

#define Mmi_DataConnProvider_hpp

Generated on Tue Jan 24 23:55:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnProvider.hpp Source File

Applications/DataConn/DataConnProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_DataConnProvider_hpp)
00015 #define Mmi_DataConnProvider_hpp
00018
00019 #include <Auxiliary/Provider.hpp>
00020
00021 class DataItem;
00022
00023 enum DataConnColids {
00024     c_dataconn_icon_id = 100,
00025     c_dataconn_display_text_id,
00026     c_dataconn_profile_id,
00027     c_dataconn_profile_count_id,
00028     c_dataconn_profile_type_id,
00029     c_dataconn_next_free_row_id,
00030     c_dataconn_is_readonly_id
00031 };
00032
00033 class DataConnProfileManager;
00034 class DataConnProvider : public Provider
00035 {
00036     public:
00037         typedef Provider Base;
00038
00041         DataConnProvider();
00042
00044         virtual ~DataConnProvider();
00045
00046         virtual INT GetProviderId() const;
00047
00049         virtual INT RowCount();
00050
00052         virtual BOOLEAN SelectRow(INT row);
00053
00055         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00056
00058         virtual BOOLEAN SetDataItem(const DataItem & item, INT column);
00059
00061         virtual BOOLEAN CommitRow(INT row);
00062
00064         virtual BOOLEAN DeleteRow(INT row);
00065
00067         virtual BOOLEAN AppendRow();
00068
00069     protected:
00070         virtual DataConnProfile* GetProfileInstance() = 0;
00071         virtual void ClearProfile() = 0;
00072
00073         DataConnProfileManager* GetProfileManager() { return m_profile_manager; }
00074
00075         DataConnProfileId GetProfileId(INT row) const;
00076         DataConnProfile* GetProfile()  { return m_actual_profile_ptr.Get(); }
00077         DataConnProfile* GetProfile(DataConnProfileId profile_id);
00078         DataConnProfile::ProfileType GetProfileType(INT row) const;
00079
00080     private:
00081         DataConnProfileManager* m_profile_manager;
00082
00083         INT GetProfileCount() const;
00084         DataConnProfileId GetFirstUsedProfileId() const;
00085         INT GetFirstFreeProfileRow() const;
00086
00087         DataConnProfilePtr m_actual_profile_ptr;
00088         DataConnProfilePtr m_profile_ptr;
00089 };
00090
00092 #endif
Generated on Tue Jan 24 14:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnSettings.hpp File Reference

Applications/DataConn/DataConnSettings.hpp File Reference

Go to the source code of this file.

Generated on Tue Jan 24 23:55:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnSettings.hpp Source File

Applications/DataConn/DataConnSettings.hpp

Go to the documentation of this file.
Generated on Tue Jan 24 14:51:20 2006 for APOXI by

  doxygen  1.4.6-NO


APOXI: Applications/DataConn/DataConnTextMaps.cpp File Reference

Applications/DataConn/DataConnTextMaps.cpp File Reference

#include "DataConnPreComp.hpp"
#include "DataConnTextMaps.hpp"
#include "DataConnApp.hpp"

Include dependency graph for DataConnTextMaps.cpp:

Generated on Tue Jan 24 23:55:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnTextMaps.hpp File Reference

Applications/DataConn/DataConnTextMaps.hpp File Reference

#include <Asc/PdpContext.hpp>
#include <Socket/DataConnProfile.hpp>
#include <Kernel/Types.hpp>
#include <Common/EnumTextMap.hpp>
#include <DataConn/DataConnApp.hpp>

Include dependency graph for DataConnTextMaps.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | CallTypeTable
class | CsdSettingsTable
class | DataConnCommonSettingsTable
class | DataRateTable
class | PdpAuthTable
class | PdpQoSDelayTable
class | PdpQoSMeanRateTable
class | PdpQoSPeakRateTable
class | PdpQoSPrecedenceTable
class | PdpQoSReliabilityTable
class | PsdSettingsTable
class | SerSettingsTable

Defines

#define | Mmi_DataConnTextMaps_hpp

Typedefs

typedef PdpContext::Authentication::Type | AuthType
typedef PdpContext::QualityOfService | QoS

Define Documentation

#define Mmi_DataConnTextMaps_hpp

Generated on Tue Jan 24 23:55:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnTextMaps.hpp Source File

Applications/DataConn/DataConnTextMaps.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003    ------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted without prior written authorisation.
00007    ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_DataConnTextMaps_hpp)
00010 #define Mmi_DataConnTextMaps_hpp
00013
00014 #include <Asc/PdpContext.hpp>
00015 #include <Socket/DataConnProfile.hpp>
00016 #include <Kernel/Types.hpp>
00017 #include <Common/EnumTextMap.hpp>
00018 #include <DataConn/DataConnApp.hpp>
00019
00020
00021 typedef PdpContext::QualityOfService QoS;
00022 typedef PdpContext::Authentication::Type AuthType;
00023
00024 class DataConnCommonSettingsTable : public EnumTextMap
00025 {
00026     typedef EnumTextMap Base;
00027
00028     public:
00029         static const WCHAR* GetSetting(DataConnApp::BasicSettingsTypeId setting) {
00030             return Base::GetText(m_common_settings, m_common_settings_size, setting); }
00031
00032     private:
00033         static const UINT m_common_settings_size;
00034         static const EnumTextTableEntry m_common_settings[];
00035 };
00036
00037 class CsdSettingsTable : public EnumTextMap
00038 {
00039     typedef EnumTextMap Base;
00040
00041     public:
00042         static const WCHAR* GetSetting(DataConnApp::CsdSettingsTypeId setting) {
00043             return Base::GetText(m_csd_settings, m_csd_settings_size, setting); }
00044
00045     private:
00046         static const UINT m_csd_settings_size;
00047         static const EnumTextTableEntry m_csd_settings[];
00048 };
00049
00050 #if !defined(DATA_CONN_APP_EXCLUDE_SERIAL)
00051 class SerSettingsTable : public EnumTextMap
00052 {
00053     typedef EnumTextMap Base;
00054
00055     public:
00056         static const WCHAR* GetSetting(DataConnApp::SerSettingsTypeId setting) {
00057             return Base::GetText(m_ser_settings, m_ser_settings_size, setting); }
00058
00059     private:
00060         static const UINT m_ser_settings_size;
00061         static const EnumTextTableEntry m_ser_settings[];
00062 };
00063 #endif
00064
00065 class PsdSettingsTable : public EnumTextMap
00066 {
00067     typedef EnumTextMap Base;
00068
00069     public:
00070
00071         static const WCHAR* GetSetting(DataConnApp::PsdSettingsTypeId setting) {
00072             return Base::GetText(m_psd_settings, m_psd_settings_size, setting); }
00073
00074     private:
00075         static const UINT m_psd_settings_size;
00076         static const EnumTextTableEntry m_psd_settings[];
00077 };
00078
00079 class PdpQoSReliabilityTable : public EnumTextMap
00080 {
00081     typedef EnumTextMap Base;
00082
00083     public:
00084         static const UINT GetSize() { return m_size; }
00085         static QoS::Reliability GetQoSType(INT idx) { return (QoS::Reliability) m_qos[idx].code; }
00086         static const WCHAR* GetQoS(QoS::Reliability qos_reliability) {
00087             return Base::GetText(m_qos, m_size, qos_reliability); }
00088
00089     private:
00090         static const UINT m_size;
00091         static const EnumTextTableEntry m_qos[];
00092 };
00093
00094 class PdpQoSDelayTable : public EnumTextMap
00095 {
00096     typedef EnumTextMap Base;
00097
00098     public:
00099         static const UINT GetSize() { return m_size; }
00100         static QoS::Delay GetQoSType(INT idx) { return (QoS::Delay) m_qos[idx].code; }
00101         static const WCHAR* GetQoS(QoS::Delay qos_delay) {
00102             return Base::GetText(m_qos, m_size, qos_delay); }
00103
00104     private:
00105         static const UINT m_size;
00106         static const EnumTextTableEntry m_qos[];
00107 };
00108
00109 class PdpQoSPrecedenceTable : public EnumTextMap
00110 {
00111     typedef EnumTextMap Base;
00112
00113     public:
00114         static const UINT GetSize() { return m_size; }
00115         static QoS::Precedence GetQoSType(INT idx) { return (QoS::Precedence) m_qos[idx].code; }
00116         static const WCHAR* GetQoS(QoS::Precedence qos_precedence) {
00117             return Base::GetText(m_qos, m_size, qos_precedence); }
00118
00119     private:
00120         static const UINT m_size;
00121         static const EnumTextTableEntry m_qos[];
00122 };
00123
00124 class PdpQoSMeanRateTable : public EnumTextMap
00125 {
00126     typedef EnumTextMap Base;
00127
00128     public:
00129         static const UINT GetSize() { return m_size; }
00130         static QoS::MeanRate GetQoSType(INT idx) { return (QoS::MeanRate) m_qos[idx].code; }
00131         static const WCHAR* GetQoS(PdpContext::QualityOfService::MeanRate qos_mean_rate) {
00132             return Base::GetText(m_qos, m_size, qos_mean_rate); }
00133
00134     private:
00135         static const UINT m_size;
00136         static const EnumTextTableEntry m_qos[];
00137 };
00138
00139 class PdpQoSPeakRateTable : public EnumTextMap
00140 {
00141     typedef EnumTextMap Base;
00142
00143     public:
00144         static const UINT GetSize() { return m_size; }
00145         static QoS::PeakRate GetQoSType(INT idx) { return (QoS::PeakRate) m_qos[idx].code; }
00146         static const WCHAR* GetQoS(PdpContext::QualityOfService::PeakRate qos_peak_rate) {
00147             return Base::GetText(m_qos, m_size, qos_peak_rate); }
00148
00149     private:
00150         static const UINT m_size;
00151         static const EnumTextTableEntry m_qos[];
00152 };
00153
00154 class PdpAuthTable : public EnumTextMap
00155 {
00156     typedef EnumTextMap Base;
00157
00158     public:
00159         static const UINT GetSize() { return m_size; }
00160         static AuthType GetAuthType(INT idx) { return (AuthType) m_auth[idx].code; }
00161         static const WCHAR* GetAuthentication(AuthType auth_type) {
00162             return Base::GetText(m_auth, m_size, auth_type); }
00163
00164     private:
00165         static const UINT m_size;
00166         static const EnumTextTableEntry m_auth[];
00167 };
00168
00169 class DataRateTable : public EnumTextMap
00170 {
00171     typedef EnumTextMap Base;
00172
00173     public:
00174         static const UINT GetSize() { return m_size; }
00175         static CsdDataConnProfile::DataRate GetDataRateType(INT idx) { return (CsdDataConnProfile::DataRate) m_data_rate[idx].code; }
00176         static const WCHAR* GetDataRate(CsdDataConnProfile::DataRate data_rate) {
00177             return Base::GetText(m_data_rate, m_size, data_rate); }
00178
00179     private:
00180         static const UINT m_size;
00181         static const EnumTextTableEntry m_data_rate[];
00182 };
00183
00184 class CallTypeTable : public EnumTextMap
00185 {
00186     typedef EnumTextMap Base;
00187
00188     public:
00189         static const UINT GetSize() { return m_size; }
00190         static const WCHAR* GetCallType(CsdDataConnProfile::CallType call_type) {
00191             return Base::GetText(m_call_type, m_size, call_type); }
00192
00193     private:
00194         static const UINT m_size;
00195         static const EnumTextTableEntry m_call_type[];
00196 };
00197
00199 #endif  //Mmi_DataConnTextMaps_hpp
00200
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnTypeWin.cpp File Reference

Applications/DataConn/DataConnTypeWin.cpp File Reference

#include "DataConnPreComp.hpp"
#include "DataConnTypeWin.hpp"

Include dependency graph for DataConnTypeWin.cpp:

Generated on Tue Jan 24 23:55:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnTypeWin.hpp File Reference

Applications/DataConn/DataConnTypeWin.hpp File Reference

#include <Socket/DataConnProfile.hpp>
#include <GuiExtensions/MmiDialog.hpp>

Include dependency graph for DataConnTypeWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnTypeWin

Defines

#define | Apoxi_DataConnTypeWin_hpp

Define Documentation

#define Apoxi_DataConnTypeWin_hpp

Generated on Tue Jan 24 23:55:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnTypeWin.hpp Source File

Applications/DataConn/DataConnTypeWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_DataConnTypeWin_hpp)
00009 #define Apoxi_DataConnTypeWin_hpp
00012
00013 #include <Socket/DataConnProfile.hpp>
00014 #include <GuiExtensions/MmiDialog.hpp>
00015
00016 class DataConnTypeWin : public MmiDialog {
00017     public:
00018         typedef MmiDialog Base;
00019
00020         DataConnTypeWin();
00021         virtual ~DataConnTypeWin();
00022
00023         void Init();
00024
00025         DataConnProfile::ProfileType GetProfileType() { return (DataConnProfile::ProfileType) m_rb_list.GetPressedItem()->GetValue(); }
00026
00027     private:
00028         RadioButtonList m_rb_list;
00029         RadioButtonItem m_csd_item;
00030         RadioButtonItem m_psd_item;
00031
00032 };
00033
00035 #endif  // Apoxi_DataConnTypeWin_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnVersion.cpp File Reference

Applications/DataConn/DataConnVersion.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include "DataConnVersion.hpp"

Include dependency graph for DataConnVersion.cpp:

Functions

ApoxiDefVersionInfo (DataCon, DATACONNVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | DataCon | ,
 |  | DATACONNVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Tue Jan 24 23:55:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnVersion.hpp File Reference

Applications/DataConn/DataConnVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | DATACONNVERSION "2.10.0_TIV_04"
#define | DataConnVersion_hpp

Define Documentation

#define DATACONNVERSION "2.10.0_TIV_04"

#define DataConnVersion_hpp

Generated on Tue Jan 24 23:55:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnVersion.hpp Source File

Applications/DataConn/DataConnVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(DataConnVersion_hpp)
00010 #define DataConnVersion_hpp
00011
00012
00013 /*
00014 DataConnVersion.hpp contains the official DataConn Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018
00019 #define DATACONNVERSION "2.10.0_TIV_04"
00020
00021 #endif  // DataConnVersion_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnWin.cpp File Reference

Applications/DataConn/DataConnWin.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Config/MmiGuiEngineConfig.hpp>
#include <Gui/Panel.hpp>
#include "DataConnApp.hpp"
#include "DataConnWin.hpp"

Include dependency graph for DataConnWin.cpp:

Generated on Tue Jan 24 23:56:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnWin.hpp File Reference

Applications/DataConn/DataConnWin.hpp File Reference

#include <Socket/DataConnProfileManager.hpp>
#include <Common/MmiWindow.hpp>
#include <MmiCompat/DrawableObjectListBox.hpp>
#include <MmiCompat/LabelListBoxModel.hpp>
#include <MmiCompat/ActionMenuAccessor.hpp>

Include dependency graph for DataConnWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | DataConnLbModel
class | DataConnWin

Defines

#define | Apoxi_DataConnWin_hpp

Define Documentation

#define Apoxi_DataConnWin_hpp

Generated on Tue Jan 24 23:56:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/DataConnWin.hpp Source File

Applications/DataConn/DataConnWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_DataConnWin_hpp)
00009 #define Apoxi_DataConnWin_hpp
00012
00013 #include <Socket/DataConnProfileManager.hpp>
00014
00015 #include <Common/MmiWindow.hpp>
00016 #include <MmiCompat/DrawableObjectListBox.hpp>
00017 #include <MmiCompat/LabelListBoxModel.hpp>
00018 #include <MmiCompat/ActionMenuAccessor.hpp>
00019
00020 class DataConnWin;
00021 class DataConnLbModel : public LabelListBoxModel {
00022     typedef LabelListBoxModel Base;
00023
00024     public:
00025         DataConnLbModel();
00026         explicit DataConnLbModel(DrawableObjectListBox *parent);
00027         virtual ~DataConnLbModel();
00028
00029         void Init(DataConnWin *win, DrawableObjectListBox *parent);
00030
00031         virtual const WCHAR* GetCellText(INT index, BOOLEAN highlighted);
00032         virtual const BitmapRes* GetCellIcon(INT index, BOOLEAN highlighted);
00033
00034         void Update();
00035
00036         DataConnProfileId GetSelectedProfileId() { return m_pis[GetSelectedIndex()]; }
00037         DataConnProfileManager::ProfileInfo GetSelectedProfileInfo() { return m_pinfo[GetSelectedIndex()]; }
00038
00039         INT GetProfileCount() { return m_count; }
00040
00041     protected:
00042         virtual void OnSelectionChanged(INT selected_index);
00043
00044     private:
00045         DataConnProfileIdSet    m_pis;
00046         DataConnProfileManager::ProfileInfo m_pinfo[c_data_conn_profile_count];
00047         WString                         m_data_conn_names[c_data_conn_profile_count];
00048         DataConnWin*                    m_win;
00049         DrawableObjectListBox*          m_parent;
00050
00051         INT                             m_count;
00052 };
00053
00054 class DataConnApp;
00055 class DataConnWin : public MmiWindow {
00056     public:
00057         typedef MmiWindow Base;
00058
00059         DataConnWin();
00060         virtual ~DataConnWin();
00061
00062         void Init(DataConnApp *app);
00063
00064         DataConnApp* GetConnApplication() { return m_app; }
00065
00066         DataConnProfileId GetSelectedProfileId() { return m_lb_model.GetSelectedProfileId(); }
00067
00068         void Update();
00069         void UpdateEnabledActions();
00070
00071     protected:
00072         virtual void OnOpen();
00073
00074     private:
00075         enum {
00076             Edit = 0,
00077             New = 1,
00078             Delete = 2,
00079             SetAsDefault = 3,
00080             action_cnt = 4
00081         };
00082
00083         DataConnApp *           m_app;
00084         DrawableObjectListBox   m_listbox;
00085         DataConnLbModel         m_lb_model;
00086
00087         //Actions
00088         CloseWindowAction       m_close_action;
00089         ActionAccessor          m_menu;
00090         MenuAction              m_menu_actions[action_cnt];
00091 };
00092
00094 #endif  // Apoxi_DataConnWin_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/IpAddrPrompt.cpp File Reference

Applications/DataConn/IpAddrPrompt.cpp File Reference

#include "DataConnPreComp.hpp"
#include "IpAddrPrompt.hpp"

Include dependency graph for IpAddrPrompt.cpp:

Generated on Tue Jan 24 23:56:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/IpAddrPrompt.hpp File Reference

Applications/DataConn/IpAddrPrompt.hpp File Reference

#include <GuiExtensions/AbstractMmiPrompt.hpp>
#include <Gui/IpAddrEditor.hpp>

Include dependency graph for IpAddrPrompt.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IpAddrPrompt

Defines

#define | Apoxi_IpAddrPrompt_hpp

Define Documentation

#define Apoxi_IpAddrPrompt_hpp

Generated on Tue Jan 24 23:56:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/IpAddrPrompt.hpp Source File

Applications/DataConn/IpAddrPrompt.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_IpAddrPrompt_hpp)
00009 #define Apoxi_IpAddrPrompt_hpp
00012
00013 #include <GuiExtensions/AbstractMmiPrompt.hpp>
00014 #include <Gui/IpAddrEditor.hpp>
00015
00016 class IpAddrPrompt : public AbstractMmiPrompt {
00017     public:
00018         typedef AbstractMmiPrompt Base;
00019
00020         IpAddrPrompt();
00021         virtual ~IpAddrPrompt();
00022
00023         void Init(const WCHAR* title = 0);
00024
00025         void SetIpAddr(const IpAddr &ip_addr) { m_editor.SetIpAddr(ip_addr); }
00026         IpAddr GetIpAddr() { return m_editor.GetIpAddr(); }
00027
00028     protected:
00029         virtual AbstractEditor* GetEditor() { return &m_editor; }
00030
00031     private:
00032         IpAddrEditor    m_editor;
00033 };
00034
00036 #endif  // Apoxi_IpAddrPrompt_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/MyDataConnProfileStorage.cpp File Reference

Applications/DataConn/MyDataConnProfileStorage.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Config/Config.hpp>
#include "MyDataConnProfileStorage.hpp"
#include <Socket/DataConnProfileManager.hpp>
#include <Socket/PersistDataConnProfile.hpp>

Include dependency graph for MyDataConnProfileStorage.cpp:

Generated on Tue Jan 24 23:57:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/MyDataConnProfileStorage.hpp File Reference

Applications/DataConn/MyDataConnProfileStorage.hpp File Reference

#include <Socket/DataConnProfile.hpp>
#include <Socket/PersistDataConnProfile.hpp>
#include <Socket/DataConnProfileStorage.hpp>
#include <Afs/Ffs/FlsFile.hpp>

Include dependency graph for MyDataConnProfileStorage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsDataConnProfileStorage

Defines

#define | APOXI_DATA_CONN_PROFILE_FFS_FILE_ID 1000
#define | APOXI_DATA_CONN_PROFILE_FFS_USER_TYPE 0
#define | Apoxi_MyDataConnProfileStorage_hpp

Typedefs

typedef FfsDataConnProfileStorage | MyDataConnProfileStorage

Variables

const UINT32 | c_fsize_data_conn_profiles

Define Documentation

#define Apoxi_MyDataConnProfileStorage_hpp

Generated on Tue Jan 24 23:57:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/MyDataConnProfileStorage.hpp Source File

Applications/DataConn/MyDataConnProfileStorage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_MyDataConnProfileStorage_hpp)
00009 #define Apoxi_MyDataConnProfileStorage_hpp
00012
00013 #include <Socket/DataConnProfile.hpp>
00014 #include <Socket/PersistDataConnProfile.hpp>
00015 #include <Socket/DataConnProfileStorage.hpp>
00016
00017 #if defined(APOXI_RTOS_WIN32) || defined(FFS_PRESENT)
00018 #include <Afs/Ffs/FlsFile.hpp>
00019
00020 #if !defined(APOXI_DATA_CONN_PROFILE_FFS_FILE_ID)
00021 #define APOXI_DATA_CONN_PROFILE_FFS_FILE_ID 1000
00022 #endif
00023 #if !defined(APOXI_DATA_CONN_PROFILE_FFS_USER_TYPE)
00024 #define APOXI_DATA_CONN_PROFILE_FFS_USER_TYPE 0
00025 #endif
00026
00027 const UINT32 c_fsize_data_conn_profiles = sizeof(DataConnProfileStorage::Header) +
00028                                           (UINT32) c_data_conn_profile_count *
00029                                           (UINT32) sizeof(PersistDataConnProfile);
00030
00031
00032 class FfsDataConnProfileStorage : public DataConnProfileStorage {
00033     public:
00034         FfsDataConnProfileStorage();
00035
00036         virtual BOOLEAN Open() { return TRUE; }
00037
00038         virtual void Close();
00039
00040         virtual BOOLEAN Read(Header &header);
00041         virtual BOOLEAN Write(const Header &header);
00042
00043         virtual BOOLEAN Read(INT recno, PersistDataConnProfile &pdcp);
00044         virtual BOOLEAN Write(INT recno, const PersistDataConnProfile &pdcp);
00045
00046     public:
00047         BOOLEAN OpenFfsFile();
00048
00049         FlsFile m_file;
00050
00051         UINT32 GetProfileOffset(INT recno) const {
00052             return (UINT32) sizeof(Header) +
00053                    (UINT32) recno * (UINT32) sizeof(PersistDataConnProfile);
00054         }
00055 };
00056
00057 typedef FfsDataConnProfileStorage MyDataConnProfileStorage;
00058
00059 #else
00060
00061 class RamDataConnProfileStorage : public DataConnProfileStorage {
00062     public:
00063         virtual BOOLEAN Open() { return TRUE; }
00064         virtual void Close() { };
00065
00066         virtual BOOLEAN Read(Header &header) {
00067             header = m_header;
00068             return TRUE;
00069         }
00070
00071         virtual BOOLEAN Write(const Header &header) {
00072             m_header = header;
00073             return TRUE;
00074         }
00075
00076         virtual BOOLEAN Read(INT recno, PersistDataConnProfile &pdcp) {
00077             pdcp = m_pdcp[recno];
00078             return TRUE;
00079         }
00080
00081         virtual BOOLEAN Write(INT recno, const PersistDataConnProfile &pdcp) {
00082             m_pdcp[recno] = pdcp;
00083             return TRUE;
00084         }
00085
00086     public:
00087         static Header m_header;
00088         static PersistDataConnProfile m_pdcp[c_data_conn_profile_count];
00089
00090 };
00091
00092 typedef RamDataConnProfileStorage MyDataConnProfileStorage;
00093
00094 #endif
00095
00097 #endif  // Apoxi_DataConnProfileStorage_hpp
00098
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/NumberPrompt.cpp File Reference

Applications/DataConn/NumberPrompt.cpp File Reference

#include "DataConnPreComp.hpp"
#include "NumberPrompt.hpp"

Include dependency graph for NumberPrompt.cpp:

Generated on Tue Jan 24 23:57:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/NumberPrompt.hpp File Reference

Applications/DataConn/NumberPrompt.hpp File Reference

#include <GuiExtensions/MmiPrompt.hpp>

Include dependency graph for NumberPrompt.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | NumberPrompt

Defines

#define | Apoxi_NumberPrompt_hpp

Define Documentation

#define Apoxi_NumberPrompt_hpp

Generated on Tue Jan 24 23:57:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/NumberPrompt.hpp Source File

Applications/DataConn/NumberPrompt.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_NumberPrompt_hpp)
00009 #define Apoxi_NumberPrompt_hpp
00012
00013 #include <GuiExtensions/MmiPrompt.hpp>
00014
00015 class NumberPrompt : public MmiPrompt {
00016     public:
00017         typedef MmiPrompt Base;
00018
00019         NumberPrompt();
00020         virtual ~NumberPrompt();
00021
00022         void Init(const WCHAR* title = 0);
00023
00024         void SetUInt(UINT ui);
00025         UINT GetUInt() const;
00026
00027         void SetInt(INT i);
00028         INT GetInt() const;
00029 };
00030
00032 #endif  // Apoxi_DataConnWin_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/PsdDataConnProvider.cpp File Reference

Applications/DataConn/PsdDataConnProvider.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Socket/DataConnProfileManager.hpp>
#include "DataConnApp.hpp"
#include "PsdDataConnProvider.hpp"

Include dependency graph for PsdDataConnProvider.cpp:

Generated on Tue Jan 24 23:57:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/PsdDataConnProvider.hpp File Reference

Applications/DataConn/PsdDataConnProvider.hpp File Reference

#include <Socket/PsdDataConnProfile.hpp>
#include <DataConn/DataConnProvider.hpp>

Include dependency graph for PsdDataConnProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PsdDataConnProvider

Defines

#define | Mmi_PsdDataConnProvider_hpp

Define Documentation

#define Mmi_PsdDataConnProvider_hpp

Generated on Tue Jan 24 23:57:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/PsdDataConnProvider.hpp Source File

Applications/DataConn/PsdDataConnProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_PsdDataConnProvider_hpp)
00015 #define Mmi_PsdDataConnProvider_hpp
00018
00019 #include <Socket/PsdDataConnProfile.hpp>
00020
00021 #include <DataConn/DataConnProvider.hpp>
00022
00023 class PsdDataConnProvider : public DataConnProvider
00024 {
00025     public:
00026         typedef DataConnProvider Base;
00027
00030         PsdDataConnProvider();
00031
00033         virtual ~PsdDataConnProvider();
00034
00035         virtual INT GetProviderId() const { return c_invalid_colid; }
00036
00038         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00039
00041         virtual BOOLEAN SetDataItem(const DataItem & item, INT column);
00042
00043     protected:
00044         virtual DataConnProfile* GetProfileInstance() { return &m_psd_profile; }
00045         virtual void ClearProfile();
00046
00047     private:
00048         PsdDataConnProfile  m_psd_profile;
00049 };
00050
00052 #endif
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/SerDataConnProvider.cpp File Reference

Applications/DataConn/SerDataConnProvider.cpp File Reference

#include "DataConnPreComp.hpp"
#include <Socket/DataConnProfileManager.hpp>
#include "DataConnApp.hpp"
#include "SerDataConnProvider.hpp"

Include dependency graph for SerDataConnProvider.cpp:

Generated on Tue Jan 24 23:58:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/SerDataConnProvider.hpp File Reference

Applications/DataConn/SerDataConnProvider.hpp File Reference

#include <Socket/SerDataConnProfile.hpp>
#include <DataConn/DataConnProvider.hpp>

Include dependency graph for SerDataConnProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SerDataConnProvider

Defines

#define | Mmi_SerDataConnProvider_hpp

Define Documentation

#define Mmi_SerDataConnProvider_hpp

Generated on Tue Jan 24 23:58:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/DataConn/SerDataConnProvider.hpp Source File

Applications/DataConn/SerDataConnProvider.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(Mmi_SerDataConnProvider_hpp)
00015 #define Mmi_SerDataConnProvider_hpp
00018
00019 #include <Socket/SerDataConnProfile.hpp>
00020
00021 #include <DataConn/DataConnProvider.hpp>
00022
00023 class SerDataConnProvider : public DataConnProvider
00024 {
00025     public:
00026         typedef DataConnProvider Base;
00027
00030         SerDataConnProvider();
00031
00033         virtual ~SerDataConnProvider();
00034
00035         virtual INT GetProviderId() const { return c_invalid_colid; }
00036
00038         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem & item);
00039
00041         virtual BOOLEAN SetDataItem(const DataItem & item, INT column);
00042
00043     protected:
00044         virtual DataConnProfile* GetProfileInstance() { return &m_ser_profile; }
00045         virtual void ClearProfile();
00046
00047     private:
00048         SerDataConnProfile  m_ser_profile;
00049 };
00050
00052 #endif
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsApp.cpp File Reference

Applications/Ems/EmsApp.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Gui/TextEditorDocument.hpp>
#include <Kernel/VersionInfo.hpp>
#include "EmsApp.hpp"
#include "EmsResourceMaps.hpp"

Include dependency graph for EmsApp.cpp:

Functions

ApoxiUseVersionInfo (Ems)

Function Documentation

ApoxiUseVersionInfo ( Ems )

Generated on Tue Jan 24 23:58:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsApp.hpp File Reference

Applications/Ems/EmsApp.hpp File Reference

#include <Apc/SimDataTypes.hpp>
#include <Sms/AbstractSmsApp.hpp>
#include <Ems/EmsComposeWin.hpp>
#include <Ems/EmsViewerWin.hpp>
#include <Ems/EmsInsertPrompt.hpp>
#include <GuiExtensions/MmiTextFormatChooser.hpp>

Include dependency graph for EmsApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsApp

Defines

#define | Mmi_EmsApp_hpp

Define Documentation

#define Mmi_EmsApp_hpp

Generated on Tue Jan 24 23:58:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsApp.hpp Source File

Applications/Ems/EmsApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_EmsApp_hpp)
00010 #define Mmi_EmsApp_hpp
00011
00012 #include <Apc/SimDataTypes.hpp>
00013
00014 #include <Sms/AbstractSmsApp.hpp>
00015 #include <Ems/EmsComposeWin.hpp>
00016 #include <Ems/EmsViewerWin.hpp>
00017 #include <Ems/EmsInsertPrompt.hpp>
00018 #include <GuiExtensions/MmiTextFormatChooser.hpp>
00019
00020 class EmsApp : public AbstractSmsApp {
00021     typedef AbstractSmsApp Base;
00022
00023     public:
00024         static EmsApp* GetInstance();
00025         virtual ~EmsApp();
00026
00027         virtual void ForwardSms(Provider* provider, INT act_row);
00028         virtual void ReplySms(Provider* provider, INT act_row);
00029
00030         static EmsCreator* GetEmsCreator() { return &m_creator; }
00031         virtual AbstractSmsComposeWin* GetSmsComposer();
00032
00033     protected:
00034         virtual void OnOpen();
00035         virtual void OnStartup();
00036
00037         virtual AbstractSmsViewerWin* GetSmsViewer();
00038
00039         virtual SmsFactory* GetSmsFactory() { return &m_ems_factory; }
00040
00042         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00043
00046         virtual void StoreImpl(const SmsContext& profile, const EditorDocumentObtainer& obtainer);
00047
00050         virtual void SendImpl(const SmsContext& profile, const EditorDocumentObtainer& obtainer);
00051
00052         virtual void OnExportConfirmation(SmsExportType export_type, Sms::Result result_code, const SmsContext& profile, INT pending_segement_count = 0);
00053
00054         virtual void SendToManyRecipient(SmsContext *profile,INT nCnt, const EditorDocumentObtainer& obtainer);
00055
00056     private:
00057
00058         enum FeatureItemIds {
00059             EmsFormat,
00060             EmsInsert,
00061             EmsFeatureCnt
00062         };
00063
00064         EmsApp();   //lint !e1704
00065         static EmsApp m_app;
00066
00067 //      void RelaySms(Provider* provider, INT act_row, BOOLEAN grab_destination);
00068
00069         static SmsFactory           m_ems_factory;
00070         static EmsCreator           m_creator;
00071
00072         static MmiTextFormatChooser m_font_chooser;
00073         static EmsInsertPrompt      m_insert_prompt;
00074
00075         static EmsComposeWin        m_compose_win;
00076         static EmsViewerWin         m_viewer_win;
00077
00078         const EditorDocument*       m_doc_cache;
00079
00080         Feature                 m_items[EmsFeatureCnt];
00081
00082 };
00083
00085 #endif  // Mmi_EmsApp_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsComposeWin.cpp File Reference

Applications/Ems/EmsComposeWin.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Config/FontConfig.hpp>
#include "EmsApp.hpp"
#include "EmsResourceMaps.hpp"
#include "EmsComposeWin.hpp"

Include dependency graph for EmsComposeWin.cpp:

Generated on Tue Jan 24 23:59:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsComposeWin.hpp File Reference

Applications/Ems/EmsComposeWin.hpp File Reference

#include <Asc/SmsContext.hpp>
#include <AddOns/MultiMedia/MultiMediaEditor.hpp>
#include <AddOns/MultiMedia/RichTextCompoundItem.hpp>
#include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>
#include <AddOns/MultiMedia/MultiMediaEditorDocument.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
#include <GuiExtensions/MenuAction.hpp>
#include <GuiExtensions/ActionMenuAccessor.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include <Sms/AbstractSmsComposeWin.hpp>
#include <Ems/EmsEditor.hpp>
#include <Ems/EmsCreator.hpp>
#include <Ems/EmsIeParser.hpp>
#include <Ems/EmsEditorListener.hpp>

Include dependency graph for EmsComposeWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsComposeWin

Defines

#define | Mmi_EmsComposeWin_hpp

Define Documentation

#define Mmi_EmsComposeWin_hpp

Generated on Tue Jan 24 23:59:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsComposeWin.hpp Source File

Applications/Ems/EmsComposeWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_EmsComposeWin_hpp)
00010 #define Mmi_EmsComposeWin_hpp
00013
00014 #include <Asc/SmsContext.hpp>
00015 #include <AddOns/MultiMedia/MultiMediaEditor.hpp>
00016 #include <AddOns/MultiMedia/RichTextCompoundItem.hpp>
00017 #include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>
00018 #include <AddOns/MultiMedia/MultiMediaEditorDocument.hpp>
00019 #include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
00020 #include <GuiExtensions/MenuAction.hpp>
00021 #include <GuiExtensions/ActionMenuAccessor.hpp>
00022 #include <Gui/RadioButtonGroup.hpp>
00023 #include <Sms/AbstractSmsComposeWin.hpp>
00024 #include <Ems/EmsEditor.hpp>
00025 #include <Ems/EmsCreator.hpp>
00026 #include <Ems/EmsIeParser.hpp>
00027 #include <Ems/EmsEditorListener.hpp>
00028
00029 #ifdef APOXI_INCLUDE_T9
00030 #include <AddOns/T9/T9PredictiveInputBox.hpp>
00031 #endif
00032
00033 class EmsApp;
00034
00035 class EmsComposeWin : public AbstractSmsComposeWin, public EmsEditorListener {
00036     typedef AbstractSmsComposeWin Base;
00037
00038     public:
00039
00040         EmsComposeWin();
00041         virtual ~EmsComposeWin();
00042
00043         virtual void Init(EmsApp* ems_app);
00044
00045         virtual EditorDocumentObtainer GetDocumentObtainer() const;
00046         virtual void SetDocumentObtainer(const EditorDocumentObtainer& obtainer);
00047
00048         virtual void RelaySms(Provider* provider, INT row, BOOLEAN reply = FALSE);
00049
00050         EmsEditor* GetEditor()  { return &m_editor; }
00051
00052         void InsertImage();
00053         void InsertSound();
00054
00055         virtual void OnInputModeChanged(PredInputMapper::PredMode mode);
00056
00057         virtual AbstractPredictiveInputBox* GetPredInputBox();
00058
00059     protected:
00060         virtual void OnLayoutClient();
00061         virtual void OnDocumentChanged(const EditorDocument* doc);
00062         virtual void OpenModeless(const Rect& rect = Rect());
00063
00064
00065     private:
00066         enum EmsTriggerType {
00067             TriggerFormat = 32,
00068             TriggerInsert
00069         };
00070
00071
00072         // Customer specific implementation
00073         ImageObtainer GetSelectedImage() const;
00074         // Customer specific implementation
00075         SoundObtainer GetSelectedSound() const;
00076
00077         EmsEditor           m_editor;
00078         SmsContext          m_sms_context;
00079 #ifdef APOXI_INCLUDE_T9
00080         T9PredictiveInputBox    m_input_box;
00081 #endif
00082         static Label        m_counter_display;
00083         static WString      m_counter_text;
00084
00085         static EmsIeParser          m_parser;
00086
00087         INT     m_pdu_count;
00088         INT     m_free_chars;
00089 };
00090
00092 #endif // Mmi_EmsComposeWin_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsCreator.cpp File Reference

Applications/Ems/EmsCreator.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Apc/UserData.hpp>
#include "EmsResourceMaps.hpp"
#include "EmsCreator.hpp"

Include dependency graph for EmsCreator.cpp:

Generated on Tue Jan 24 23:59:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsCreator.hpp File Reference

Applications/Ems/EmsCreator.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/Provider.hpp>
#include <Auxiliary/BufferedData.hpp>
#include <Apc/Sms.hpp>
#include <Apc/BaseInformationElement.hpp>
#include <Apc/InformationElement.hpp>
#include <Adc/CompoundSmsItem.hpp>
#include <Asc/SmsContext.hpp>
#include <Asc/SmsFactory.hpp>
#include <Gui/EditorDocument.hpp>
#include <Gui/Color.hpp>
#include <Gui/Font.hpp>
#include <Gui/CharItem.hpp>
#include <Gui/IpAddrCompoundItem.hpp>
#include <Gui/DateCompoundItem.hpp>
#include <Gui/TimeCompoundItem.hpp>
#include <Gui/TextCompoundItem.hpp>
#include <AddOns/MultiMedia/GeneralCompoundItem.hpp>
#include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>
#include <AddOns/MultiMedia/ParagraphMarker.hpp>
#include <AddOns/MultiMedia/RichTextCompoundItem.hpp>
#include <AddOns/MultiMedia/ImageItem.hpp>
#include <AddOns/MultiMedia/SoundItem.hpp>
#include <AddOns/MultiMedia/IMelody.hpp>
#include <Ems/EmsImage.hpp>
#include <Ems/PredefinedEmsSound.hpp>
#include <Ems/PredefinedEmsImage.hpp>

Include dependency graph for EmsCreator.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsCreator
struct | EmsCreator::SpaceInfo

Defines

#define | Ems_EmsCreator_hpp

Define Documentation

#define Ems_EmsCreator_hpp

Generated on Tue Jan 24 23:59:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsCreator.hpp Source File

Applications/Ems/EmsCreator.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Ems_EmsCreator_hpp)
00010 #define Ems_EmsCreator_hpp
00013
00014 #include <Auxiliary/WString.hpp>
00015 #include <Auxiliary/Provider.hpp>
00016 #include <Auxiliary/BufferedData.hpp>
00017 #include <Apc/Sms.hpp>
00018 #include <Apc/BaseInformationElement.hpp>
00019 #include <Apc/InformationElement.hpp>
00020 #include <Adc/CompoundSmsItem.hpp>
00021 #include <Asc/SmsContext.hpp>
00022 #include <Asc/SmsFactory.hpp>
00023
00024 #include <Gui/EditorDocument.hpp>
00025 #include <Gui/Color.hpp>
00026 #include <Gui/Font.hpp>
00027 #include <Gui/CharItem.hpp>
00028 #include <Gui/IpAddrCompoundItem.hpp>
00029 #include <Gui/DateCompoundItem.hpp>
00030 #include <Gui/TimeCompoundItem.hpp>
00031 #include <Gui/TextCompoundItem.hpp>
00032 #include <AddOns/MultiMedia/GeneralCompoundItem.hpp>
00033 #include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>
00034 #include <AddOns/MultiMedia/ParagraphMarker.hpp>
00035 #include <AddOns/MultiMedia/RichTextCompoundItem.hpp>
00036 #include <AddOns/MultiMedia/ImageItem.hpp>
00037 #include <AddOns/MultiMedia/SoundItem.hpp>
00038
00039 #include <AddOns/MultiMedia/IMelody.hpp>
00040 #include <Ems/EmsImage.hpp>
00041 #include <Ems/PredefinedEmsSound.hpp>
00042 #include <Ems/PredefinedEmsImage.hpp>
00043
00044 class EmsCreator {
00045     public:
00046         struct SpaceInfo {
00048             UINT8   m_pdu_count;
00050             UINT8   m_free_chars;
00051         };
00052
00053         EmsCreator();
00054         ~EmsCreator();  // not virtual!
00055
00056         SpaceInfo GetSpaceInfo(const EditorDocument& document, const SmsContext* context);
00057         BOOLEAN CreateMessages(const EditorDocument& document, const SmsContext* context, SmsFactory* factory);
00058
00059
00060     private:
00061         BOOLEAN ProcessDocument(const EditorDocument& document);
00062         BOOLEAN TraverseDocument(const EditorDocument& document);
00063         BOOLEAN TraverseDocument(const CompoundItem& parent);
00064         BOOLEAN AnalyseItem(const AbstractEditorItem& item);
00065         BOOLEAN ProcessImage(const Image* image);
00066         BOOLEAN ProcessSound(const Sound* sound);
00067         BOOLEAN ProcessFormattedText(const RichTextCompoundItem& item);
00068         BOOLEAN ProcessText(const WString& str, InformationElement* ie = 0);
00069         /* Calculates the remaining space if inserting of the give <em>InformationElement</em>
00070             is possible. In calc-mode (m_factory == 0) only the identifier of the given <em>ie</em>
00071             is needed and the additional size <em>add_size</em> is also included. If the
00072             inserting into the current PDU is not possible, <em>FALSE</em> is returned and
00073             no counter values are changed. */
00074         BOOLEAN ProcessAtomicIe(InformationElement& ie, UINT8 add_size);
00075         /* Calculates the remaining space if inserting of the give <em>InformationElement</em>
00076             and text is possible. <em>ie</em> may be <em>0</em> to indicate plain text.
00077             Retruns the number of processed characters or a value less than 0 if the
00078             text could not be inserted. */
00079         INT ProcessTextIe(InformationElement* ie, const WString& text, INT text_size);
00080
00081
00082         void ResetCounters();
00083         UINT8 CalcFreeChars() const;
00084         BOOLEAN TerminateSegment();
00085
00086         UINT8 GetMaxPduSize() const { return SmsSubmit::c_max_guaranteed_user_data_size;}
00087         UINT8 CalcHeaderSize(UINT8 add_size) const { return m_header_size + add_size + (m_header_size == 0 && add_size > 0 ? 1 : 0); }
00088
00089         static BOOLEAN          m_concatinated;
00090         static UINT8            m_header_size;  // size of user data header, always in bytes
00091         static UINT8            m_text_length;  // size of text, alphabet dependend (septets, octets, words)
00092         static UINT8            m_text_pos;     // size of text, number of characters
00093         static UINT8            m_concatinated_buffer[];
00094         static UINT8            m_buffer[];
00095         InformationElement::TextAlignment m_alignment;
00096         static WString          m_pdu_text;     // Text of a single pdu
00097         SmsFactory*             m_factory;
00098         const SmsContext*       m_context;
00099         SpaceInfo               m_space;
00100         InformationElement      m_concatinated_ie;
00101 };
00102
00104 #endif // Ems_EmsCreator_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsEditor.cpp File Reference

Applications/Ems/EmsEditor.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <AddOns/MultiMedia/RichTextCompoundItem.hpp>
#include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>
#include <AddOns/MultiMedia/SoundItem.hpp>
#include <AddOns/MultiMedia/ImageItem.hpp>
#include <AddOns/MultiMedia/MultiMediaEditorDocument.hpp>
#include "EmsResourceMaps.hpp"
#include "EmsEditor.hpp"

Include dependency graph for EmsEditor.cpp:

Generated on Tue Jan 24 23:59:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsEditor.hpp File Reference

Applications/Ems/EmsEditor.hpp File Reference

#include <Gui/TextFormat.hpp>
#include <Ems/EmsEditorListener.hpp>
#include <AddOns/MultiMedia/MultiMediaEditor.hpp>
#include <AddOns/MultiMedia/AudioContext.hpp>

Include dependency graph for EmsEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsEditor

Defines

#define | Ems_EmsEditor_hpp

Define Documentation

#define Ems_EmsEditor_hpp

Generated on Tue Jan 24 23:59:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsEditor.hpp Source File

Applications/Ems/EmsEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Ems_EmsEditor_hpp)
00011 #define Ems_EmsEditor_hpp
00014
00015 #include <Gui/TextFormat.hpp>
00016 #include <Ems/EmsEditorListener.hpp>
00017 #include <AddOns/MultiMedia/MultiMediaEditor.hpp>
00018 #include <AddOns/MultiMedia/AudioContext.hpp>
00019
00020 class CompoundItem;
00021 class ParagraphCompoundItem;
00022
00024 class EmsEditor : public MultiMediaEditor {
00025     typedef MultiMediaEditor Base;
00026
00027     public:
00028
00030         EmsEditor();
00031
00033         virtual ~EmsEditor();
00034
00036         void Init(Control *parent, InputMapper::Id input_mapper_id);
00037
00039         void SetObtainedDocument(EditorDocumentObtainer obtainer);
00040
00042         EditorDocumentObtainer GetObtainedDocument() const;
00043
00045         virtual BOOLEAN InsertItem(const AtomItem &item, INT index = -1);
00046
00048         virtual BOOLEAN ReplaceItem(const AtomItem& item, INT index = -1);
00049
00051         virtual BOOLEAN RemoveItem(INT index = -1);
00052
00054         virtual BOOLEAN InsertCompoundItem(CompoundItem *compound_item, INT index = -1);
00055
00057         virtual BOOLEAN RemoveCompoundItem(INT index = -1);
00058
00060         virtual BOOLEAN Backspace();
00061
00063         virtual void StartTextFormatting(const TextFormat& format, const Color& text_color, const Color& bg_color);
00064
00066         virtual void OnItemMarked(const AbstractEditorItem *item);
00067
00069         void SetEditorListener(EmsEditorListener* lstn) { m_editor_listener = lstn; }
00070
00071     protected:
00073         virtual Model* CreateModel() const;
00074
00076         virtual BOOLEAN DestroyModel(Model *model);
00077
00078     private:
00079         CompoundItem*           m_text_item;
00080         ParagraphCompoundItem*  m_pg_item;
00081         EmsEditorListener*      m_editor_listener;
00082         EditorDocumentObtainer  m_obtainer;
00083
00084         static AudioContext     m_audio_context;    // ToDo: Move to Kernel/System to make it common available
00085 };
00086
00088 #endif  // Ems_EmsEditor_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsEditorListener.cpp File Reference

Applications/Ems/EmsEditorListener.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "EmsEditorListener.hpp"

Include dependency graph for EmsEditorListener.cpp:

Generated on Wed Jan 25 00:00:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsEditorListener.hpp File Reference

Applications/Ems/EmsEditorListener.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsEditorListener

Defines

#define | Ems_EmsEditorListener_hpp

Define Documentation

#define Ems_EmsEditorListener_hpp

Generated on Wed Jan 25 00:00:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsEditorListener.hpp Source File

Applications/Ems/EmsEditorListener.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Ems_EmsEditorListener_hpp)
00011 #define Ems_EmsEditorListener_hpp
00014
00015 class EditorDocument;
00016
00018 class EmsEditorListener {
00019     public:
00021         EmsEditorListener();
00022
00024         virtual ~EmsEditorListener();
00025
00026     protected:
00027         virtual void OnDocumentChanged(const EditorDocument* document) = 0;
00028
00029     private:
00030         friend class EmsEditor;
00031 };
00032
00034 #endif  // Ems_EmsEditorListener_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsIeParser.cpp File Reference

Applications/Ems/EmsIeParser.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Config/FontConfig.hpp>
#include "EmsResourceMaps.hpp"
#include "EmsIeParser.hpp"
#include <Config/MmiGuiEngineConfig.hpp>

Include dependency graph for EmsIeParser.cpp:

Generated on Wed Jan 25 00:00:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsIeParser.hpp File Reference

Applications/Ems/EmsIeParser.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/Provider.hpp>
#include <Auxiliary/BufferedData.hpp>
#include <Apc/BaseInformationElement.hpp>
#include <Apc/InformationElement.hpp>
#include <Adc/CompoundSmsItem.hpp>
#include <Gui/EditorDocument.hpp>
#include <Gui/CompoundItem.hpp>
#include <Gui/Color.hpp>
#include <Gui/Font.hpp>
#include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>
#include <AddOns/MultiMedia/RichTextCompoundItem.hpp>
#include <AddOns/MultiMedia/ImageItem.hpp>
#include <AddOns/MultiMedia/SoundItem.hpp>
#include <AddOns/MultiMedia/IMelody.hpp>
#include <Ems/EmsImage.hpp>
#include <Ems/PredefinedEmsSound.hpp>
#include <Ems/PredefinedEmsImage.hpp>

Include dependency graph for EmsIeParser.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EditorItemNode
class | EmsIeParser

Defines

#define | Ems_EmsIeParser_hpp

Define Documentation

#define Ems_EmsIeParser_hpp

Generated on Wed Jan 25 00:00:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsIeParser.hpp Source File

Applications/Ems/EmsIeParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Ems_EmsIeParser_hpp)
00010 #define Ems_EmsIeParser_hpp
00013
00014 #include <Auxiliary/WString.hpp>
00015 #include <Auxiliary/Provider.hpp>
00016 #include <Auxiliary/BufferedData.hpp>
00017 #include <Apc/BaseInformationElement.hpp>
00018 #include <Apc/InformationElement.hpp>
00019 #include <Adc/CompoundSmsItem.hpp>
00020 #include <Gui/EditorDocument.hpp>
00021 #include <Gui/CompoundItem.hpp>
00022 #include <Gui/Color.hpp>
00023 #include <Gui/Font.hpp>
00024 #include <AddOns/MultiMedia/ParagraphCompoundItem.hpp>
00025 #include <AddOns/MultiMedia/RichTextCompoundItem.hpp>
00026 #include <AddOns/MultiMedia/ImageItem.hpp>
00027 #include <AddOns/MultiMedia/SoundItem.hpp>
00028 #include <AddOns/MultiMedia/IMelody.hpp>
00029
00030 #include <Ems/EmsImage.hpp>
00031 #include <Ems/PredefinedEmsSound.hpp>
00032 #include <Ems/PredefinedEmsImage.hpp>
00033
00034 class EditorItemNode {
00035     public:
00036         enum ItemType {
00037             DefaultTextFormattingIe,
00038             ParagraphItem,
00039             TextItem,
00040             AtomicItem,
00041             InvalidItem
00042         };
00043
00044         EditorItemNode();
00045         ~EditorItemNode(); // not virual !!
00046
00047         void SetItemType(ItemType type) { m_type = type; }
00048         ItemType GetItemType() const { return m_type; }
00049         void SetPosition(INT pos) { m_pos = pos; }
00050         INT GetPosition () const { return m_pos; }
00051         void SetLength(INT length) { m_length = length; }
00052         INT GetLength() const { return m_length; }
00053         void SetCompoundItem(CompoundItem* item);
00054         CompoundItem* GetCompoundItem();
00055         void SetEditorItem(AtomItem* item);
00056         AtomItem* GetEditorItem();
00057         void SetTextFormatting(UINT8 mode, UINT8 colour);
00058         InformationElement GetTextFormattingElement();
00059
00060     private:
00061         enum UnionType {
00062             CompoundItemType,
00063             EditorItemType,
00064             TextFormattingType,
00065             InvalidType
00066         };
00067
00068         ItemType    m_type;
00069         UnionType   m_union_type;
00070         INT         m_pos;
00071         INT         m_length;
00072         union {
00073             CompoundItem*   m_compound_item;
00074             AtomItem*       m_editor_item;
00075             UINT16          m_text_formatting;
00076         };
00077 };
00078
00079 class EmsIeParser {
00080     public:
00081         EmsIeParser();
00082         virtual ~EmsIeParser();
00083
00084         void Parse(CompoundSmsItem* sms_item, EditorDocument& document, BOOLEAN append = FALSE, BOOLEAN mark_missing = TRUE);
00085
00086     private:
00087
00088         enum PredefinedMediaType {
00089             PredefinedSoundType,
00090             PredefinedAnimationType,
00091         };
00092
00093         void GenerateDocument(EditorDocument& document, const WString& text);
00094
00095         void ParseInformationElement(const InformationElement& ie);
00096         void ParseTextFormatting(const InformationElement& ie);
00097         void ParsePredefinedMedia(INT rel_start_pos, PredefinedMediaType id, INT type);
00098
00099         ParagraphCompoundItem* CreateParagraphItem(const InformationElement& ie, ParagraphCompoundItem* prev_pg = 0) const;
00100         TextCompoundItem* CreateTextItem(const InformationElement& ie) const;
00101         TextCompoundItem* CloneTextItem(const TextCompoundItem* item) const;
00102
00103         void AppendImageItem(INT rel_start_pos, UINT16 width, UINT16 height, UINT8* data, UINT8 data_length, UINT8 frames);
00104         void AppendImageItem(INT rel_start_pos, Image* image);
00105         void AppendSoundItem(INT rel_start_pos, UINT8* data, UINT8 data_length);
00106         void AppendSoundItem(INT rel_start_pos, Sound* snd);
00107
00108         BOOLEAN SupportsItem(EditorDocument& document, CompoundItem* item);
00109         void ResetParser();
00110         void MarkMissingPdu(INT rel_start_pos);
00111
00112         void AddItemNode(const EditorItemNode& node);
00113         EditorItemNode* GetPreviousItemNode(EditorItemNode::ItemType type, INT text_pos);
00114
00115         struct {
00116             BOOLEAN supports_paragraphs : 2;
00117             BOOLEAN supports_rich_text  : 2;
00118         } m_flags;
00119
00120         INT                     m_offset;
00121         Vector<EditorItemNode>  m_items;
00122 };
00123
00125 #endif // Ems_EmsIeParser_hpp
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsImage.cpp File Reference

Applications/Ems/EmsImage.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "EmsImage.hpp"

Include dependency graph for EmsImage.cpp:

Generated on Wed Jan 25 00:00:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsImage.hpp File Reference

Applications/Ems/EmsImage.hpp File Reference

#include <Gui/Image.hpp>
#include <Auxiliary/BinData.hpp>

Include dependency graph for EmsImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsImage

Defines

#define | Ems_EmsImage_hpp

Define Documentation

#define Ems_EmsImage_hpp

Generated on Wed Jan 25 00:00:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsImage.hpp Source File

Applications/Ems/EmsImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Ems_EmsImage_hpp)
00011 #define Ems_EmsImage_hpp
00014
00015 #include <Gui/Image.hpp>
00016 #include <Auxiliary/BinData.hpp>
00017
00018 class EmsImage : public Image
00019 {
00020     typedef Image Base;
00021     public:
00022
00023         enum {
00024             ID = 3
00025         };
00026
00027         EmsImage(XYDIM width, XYDIM height, UINT8 frames, BinData* data, UINT8 anim_control = 0);
00028         virtual ~EmsImage();
00029
00030         virtual INT GetId() const;
00031         virtual void Draw(DeviceContext* dc, XYDIM x, XYDIM y, INT frame_idx, const Rect& clip_rect) const;
00032         virtual INT GetNextFrame(INT frame_idx) const;
00033         virtual UINT32 GetFrameDelay(INT frame_idx) const;
00034
00036         BinData* GetPlainData() { return m_data; }
00038         virtual const BinData* GetBinData() const;
00039
00040     private:
00041         /*
00042         INT ConvertToMonochrome(INT offset, UINT8* pixel_buffer, INT buffer_length);
00043         INT ConvertTo2BitGs(INT offset, UINT8* pixel_buffer, INT buffer_length);
00044         INT ConvertTo4BitColor(INT offset, UINT8* pixel_buffer, INT buffer_length);
00045         INT ConvertTo4BitGs(INT offset, UINT8* pixel_buffer, INT buffer_length);
00046         INT ConvertTo8BitColor(INT offset, UINT8* pixel_buffer, INT buffer_length);
00047         INT ConvertTo8BitGs(INT offset, UINT8* pixel_buffer, INT buffer_length);
00048         INT ConvertTo16BitColor(INT offset, UINT8* pixel_buffer, INT buffer_length);
00049         INT ConvertTo24BitColor(INT offset, INT frame_idx, UINT8* pixel_buffer, INT buffer_length);
00050         INT ConvertTo32BitColor(INT offset, INT frame_idx, UINT8* pixel_buffer, INT buffer_length);
00051         */
00052         BinData*    m_data;
00053         UINT32      m_delay;
00054 };
00055
00057 #endif // Ems_EmsImage_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsInsertPrompt.cpp File Reference

Applications/Ems/EmsInsertPrompt.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <GuiExtensions/AnimatedLabel.hpp>
#include "EmsInsertPrompt.hpp"

Include dependency graph for EmsInsertPrompt.cpp:

Generated on Wed Jan 25 00:01:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsInsertPrompt.hpp File Reference

Applications/Ems/EmsInsertPrompt.hpp File Reference

#include <Gui/Action.hpp>
#include <Gui/Font.hpp>
#include <Gui/Color.hpp>
#include <Gui/AbstractToggleAction.hpp>
#include <Auxiliary/WString.hpp>
#include <GuiExtensions/ActionListBoxModel.hpp>
#include <GuiExtensions/Label.hpp>
#include <GuiExtensions/MmiDialog.hpp>

Include dependency graph for EmsInsertPrompt.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsInsertPrompt
class | EmsInsertPromptListBoxModel

Defines

#define | Ems_EmsInsertPrompt_hpp

Define Documentation

#define Ems_EmsInsertPrompt_hpp

Generated on Wed Jan 25 00:01:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsInsertPrompt.hpp Source File

Applications/Ems/EmsInsertPrompt.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Ems_EmsInsertPrompt_hpp)
00010 #define Ems_EmsInsertPrompt_hpp
00013
00014 #include <Gui/Action.hpp>
00015 #include <Gui/Font.hpp>
00016 #include <Gui/Color.hpp>
00017 #include <Gui/AbstractToggleAction.hpp>
00018 #include <Auxiliary/WString.hpp>
00019
00020 #include <GuiExtensions/ActionListBoxModel.hpp>
00021 #include <GuiExtensions/Label.hpp>
00022 #include <GuiExtensions/MmiDialog.hpp>
00023
00024 class EmsInsertPrompt;
00025
00026 class EmsInsertPromptListBoxModel : public LabelListBoxModel {
00027     typedef LabelListBoxModel Base;
00028
00029     public:
00030         EmsInsertPromptListBoxModel();
00031         virtual ~EmsInsertPromptListBoxModel();
00032
00033         void Init(DrawableObjectListBox *parent);
00034
00035         virtual const WCHAR* GetCellText(INT index, BOOLEAN highlighted);
00036 };
00037
00038 class EmsInsertPrompt : public MmiDialog {
00039     typedef MmiDialog Base;
00040
00041     public:
00042         enum EmsInsertType {
00043             InsertImageType = 0,
00044             InsertSoundType = 1
00045         };
00046
00047         EmsInsertPrompt();
00048         virtual ~EmsInsertPrompt();
00049
00050         void Init();
00051         EmsInsertPrompt::EmsInsertType GetSelectedType() const;
00052
00053     private:
00054         DrawableObjectListBox       m_listbox;
00055         EmsInsertPromptListBoxModel m_listbox_model;
00056 };
00057
00059 #endif // Ems_EmsInsertPrompt_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsPreComp.cpp File Reference

Applications/Ems/EmsPreComp.cpp File Reference

#include "EmsPreComp.hpp"

Include dependency graph for EmsPreComp.cpp:

Generated on Wed Jan 25 00:01:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsPreComp.hpp File Reference

Applications/Ems/EmsPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for EmsPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:01:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsPreComp.hpp Source File

Applications/Ems/EmsPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 //lint -esymb{text(ios &)}
00010
00011 #include <Kernel/Lib.hpp>
00012 #include <Gui/Lib.hpp>
00013 #include <Auxiliary/Lib.hpp>
00014 #include <Adc/Lib.hpp>
00015 #include <Apc/Lib.hpp>
00016 #include <Asc/Lib.hpp>
00017
00018 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsResourceMaps.cpp File Reference

Applications/Ems/EmsResourceMaps.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Config/FontConfig.hpp>
#include "EmsResourceMaps.hpp"
#include <Config/MmiGuiEngineConfig.hpp>

Include dependency graph for EmsResourceMaps.cpp:

Generated on Wed Jan 25 00:02:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsResourceMaps.hpp File Reference

Applications/Ems/EmsResourceMaps.hpp File Reference

#include <Gui/Color.hpp>
#include <Gui/Font.hpp>
#include <Gui/EditorDocument.hpp>
#include <Apc/InformationElement.hpp>

Include dependency graph for EmsResourceMaps.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsResourceMaps
struct | EmsResourceMaps::AnimNode

Defines

#define | COLOR_COUNT 16
#define | Ems_EmsResourceMaps_hpp

Define Documentation

#define Ems_EmsResourceMaps_hpp

Generated on Wed Jan 25 00:02:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsResourceMaps.hpp Source File

Applications/Ems/EmsResourceMaps.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Ems_EmsResourceMaps_hpp)
00010 #define Ems_EmsResourceMaps_hpp
00013
00014 #include <Gui/Color.hpp>
00015 #include <Gui/Font.hpp>
00016 #include <Gui/EditorDocument.hpp>
00017 #include <Apc/InformationElement.hpp>
00018
00019 #define COLOR_COUNT 16
00020
00021 class EmsResourceMaps {
00022     public:
00023         struct AnimNode {
00024             const BitmapRes* const * m_anim;
00025             UINT8 m_frame_count;
00026         };
00027
00028         static EditorDocument::LineAlignment MapTextAlignment(InformationElement::TextAlignment val);
00029         static InformationElement::TextAlignment MapTextAlignment(EditorDocument::LineAlignment val);
00030
00031         static EditorDocument::LineAlignment MapLineAlignment(TextFormat::TextAlign val);
00032         static TextFormat::TextAlign MapLineAlignment(EditorDocument::LineAlignment val);
00033
00035         static InformationElement::FontSize MapFont(const Font& font);
00037         static const Font& MapFont(InformationElement::FontSize size);
00038
00040         static const Color& MapTextColor(InformationElement::TextColour val);
00041
00043         static InformationElement::TextColour MapTextColor(const Color& val);
00044
00045         // initializes ems color map. Must be invoked once retreiving ems colors.
00046         static void         InitEmsColors();
00048         static const Color* GetEmsColors();
00050         static UINT8        GetEmsColorCount();
00054         static const WCHAR** GetEmsColorNames();
00055
00057         static AnimNode MapAnimation(InformationElement::PredefinedAnimationType type);
00058
00060         static Audio::AudioToneId MapSound(InformationElement::PredefinedSoundType type);
00061
00062     private:
00063         // do not instanciate!
00064         EmsResourceMaps();  //lint !e1704
00065         virtual ~EmsResourceMaps();
00066         static Color        m_colors[COLOR_COUNT];
00067         static const WCHAR*     m_color_names[];
00068 };
00069
00071 #endif // Ems_EmsResourceMaps_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsVersion.cpp File Reference

Applications/Ems/EmsVersion.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Kernel/VersionInfo.hpp>
#include <EmsVersion.hpp>

Include dependency graph for EmsVersion.cpp:

Functions

ApoxiDefVersionInfo (Ems, EMSVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | Ems | ,
 |  | EMSVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:02:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsVersion.hpp File Reference

Applications/Ems/EmsVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | EMSVERSION "2.10.0_TIV_04"
#define | EmsVersion_hpp

Define Documentation

#define EMSVERSION "2.10.0_TIV_04"

#define EmsVersion_hpp

Generated on Wed Jan 25 00:02:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsVersion.hpp Source File

Applications/Ems/EmsVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(EmsVersion_hpp)
00010 #define EmsVersion_hpp
00011
00012
00013 /*
00014 EmsVersion.hpp contains the official Ems Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define EMSVERSION "2.10.0_TIV_04"
00019
00020 #endif  // EmsVersion_hpp
00021
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsViewerWin.cpp File Reference

Applications/Ems/EmsViewerWin.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "EmsApp.hpp"
#include "EmsViewerWin.hpp"
#include <Config/FontConfig.hpp>
#include <Config/KeyboardConfig.hpp>

Include dependency graph for EmsViewerWin.cpp:

Generated on Wed Jan 25 00:02:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsViewerWin.hpp File Reference

Applications/Ems/EmsViewerWin.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Auxiliary/Provider.hpp>
#include <Adc/CompoundSmsItem.hpp>
#include <Sms/SmsActions.hpp>
#include <Sms/AbstractSmsViewerWin.hpp>
#include <Ems/EmsIeParser.hpp>
#include <Ems/EmsEditor.hpp>

Include dependency graph for EmsViewerWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | EmsViewerWin

Defines

#define | Mmi_EmsViewerWin_hpp

Define Documentation

#define Mmi_EmsViewerWin_hpp

Generated on Wed Jan 25 00:02:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/EmsViewerWin.hpp Source File

Applications/Ems/EmsViewerWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_EmsViewerWin_hpp)
00010 #define Mmi_EmsViewerWin_hpp
00013
00014 #include <Auxiliary/WString.hpp>
00015 #include <Auxiliary/Provider.hpp>
00016 #include <Adc/CompoundSmsItem.hpp>
00017
00018 #include <Sms/SmsActions.hpp>
00019 #include <Sms/AbstractSmsViewerWin.hpp>
00020 #include <Ems/EmsIeParser.hpp>
00021 #include <Ems/EmsEditor.hpp>
00022
00023 class EmsApp;
00024
00025 class EmsViewerWin : public AbstractSmsViewerWin {
00026     typedef AbstractSmsViewerWin Base;
00027
00028     public:
00029         EmsViewerWin();
00030         void Init(EmsApp* sms_app);
00031         virtual ~EmsViewerWin();
00032
00033         virtual const EditorDocument* GetDocument() const;
00034         virtual void SetDocument(const EditorDocument* doc);
00035
00036     protected:
00037         virtual void OnDisplaySms(Provider* provider, INT row);
00038
00039     private:
00040         EmsEditor   m_editor;
00041         EmsIeParser m_parser;
00042 };
00043
00045 #endif // Mmi_EmsViewerWin_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/PredefinedEmsImage.cpp File Reference

Applications/Ems/PredefinedEmsImage.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "EmsResourceMaps.hpp"
#include "PredefinedEmsImage.hpp"

Include dependency graph for PredefinedEmsImage.cpp:

Generated on Wed Jan 25 00:03:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/PredefinedEmsImage.hpp File Reference

Applications/Ems/PredefinedEmsImage.hpp File Reference

#include <Apc/InformationElement.hpp>
#include <AddOns/MultiMedia/NativeImage.hpp>

Include dependency graph for PredefinedEmsImage.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PredefinedEmsImage

Defines

#define | Ems_PredefinedEmsImage_hpp

Define Documentation

#define Ems_PredefinedEmsImage_hpp

Generated on Wed Jan 25 00:03:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/PredefinedEmsImage.hpp Source File

Applications/Ems/PredefinedEmsImage.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Ems_PredefinedEmsImage_hpp)
00011 #define Ems_PredefinedEmsImage_hpp
00014
00015 #include <Apc/InformationElement.hpp>
00016 #include <AddOns/MultiMedia/NativeImage.hpp>
00017
00018 class PredefinedEmsImage : public NativeImage
00019 {
00020     typedef NativeImage Base;
00021     public:
00022         enum {
00023             ID = 4
00024         };
00025
00026         explicit PredefinedEmsImage(InformationElement::PredefinedAnimationType type);
00027         virtual ~PredefinedEmsImage();
00028
00029         virtual INT GetId() const;
00030         InformationElement::PredefinedAnimationType GetPredefinedType() const { return m_type; }
00031
00032     private:
00033         InformationElement::PredefinedAnimationType m_type;
00034
00035 };
00036
00038 #endif // Ems_PredefinedEmsImage_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/PredefinedEmsSound.cpp File Reference

Applications/Ems/PredefinedEmsSound.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "EmsResourceMaps.hpp"
#include "PredefinedEmsSound.hpp"

Include dependency graph for PredefinedEmsSound.cpp:

Generated on Wed Jan 25 00:03:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/PredefinedEmsSound.hpp File Reference

Applications/Ems/PredefinedEmsSound.hpp File Reference

#include <AddOns/MultiMedia/PreparedSound.hpp>

Include dependency graph for PredefinedEmsSound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | PredefinedEmsSound

Defines

#define | Ems_PredefinedEmsSound_hpp

Define Documentation

#define Ems_PredefinedEmsSound_hpp

Generated on Wed Jan 25 00:03:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/PredefinedEmsSound.hpp Source File

Applications/Ems/PredefinedEmsSound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Ems_PredefinedEmsSound_hpp)
00011 #define Ems_PredefinedEmsSound_hpp
00014
00015 #include <AddOns/MultiMedia/PreparedSound.hpp>
00016
00018 class PredefinedEmsSound : public PreparedSound
00019 {
00020     typedef PreparedSound Base;
00021
00022     public:
00024         enum {
00025             ID = 4
00026         };
00027
00029         explicit PredefinedEmsSound(InformationElement::PredefinedSoundType type);
00031         virtual ~PredefinedEmsSound();
00032
00034         virtual INT GetId() const;
00035         InformationElement::PredefinedSoundType GetPredefinedType() const { return m_type; }
00036
00037     private:
00038         InformationElement::PredefinedSoundType m_type;
00039 };
00040
00042 #endif // Ems_PredefinedEmsSound_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsApp.cpp File Reference

Applications/Ems/Sms/AbstractSmsApp.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/Services/Service.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
#include <Asc/BootHandler.hpp>
#include <Common/AudioManager.hpp>
#include <Common/AudioRequest.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Common/Items/ItemObj.hpp>
#include <Common/ContextManager.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include <Config/UibConfig.hpp>
#include "SmsIndicationState.hpp"
#include "AbstractSmsApp.hpp"
#include <Common/MainSettingsProvider.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Atl/Properties/PropertyID.hpp>
#include <Config/SmsCustomizationConfig.hpp>
#include <Sms/AbstractSmsUtiltyProcessor.hpp>
#include <Common/PhoneNumberUtil.hpp>
#include <Common/LineInfoDescriptor.hpp>
#include <Config/MmiGuiEngineConfig.hpp>

Include dependency graph for AbstractSmsApp.cpp:

Generated on Wed Jan 25 00:04:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsApp.hpp File Reference

Applications/Ems/Sms/AbstractSmsApp.hpp File Reference

#include <Config/SmsCustomizationConfig.hpp>
#include <Common/MmiApplication.hpp>
#include <Atl/Gui/AtlItemListWindow.hpp>
#include <Atl/Gui/AtlItemMenuWindow.hpp>
#include <Atl/Features/ProviderProxyItem.hpp>
#include <Atl/Properties/PropertyItem.hpp>
#include <Common/MmiProviderProgressBox.hpp>
#include <Common/Items/ProviderProxyContainer.hpp>
#include <Common/MmiWaitingBox.hpp>
#include <Config/SmsConfig.hpp>
#include <Sms/SmsMsgTypes.hpp>
#include <Sms/SmsService.hpp>
#include <Sms/AbstractSmsComposeWin.hpp>
#include <Sms/AbstractSmsViewerWin.hpp>
#include <Sms/SmsAlerts.hpp>
#include <Sms/SmsSendingConfirmDialog.hpp>
#include <Sms/SmsTextMaps.hpp>
#include <Sms/SmsBasicProvider.hpp>
#include <Sms/SmsTemplateProvider.hpp>
#include <Sms/SmsSettingsProvider.hpp>
#include <Sms/SmsFolderProvider.hpp>
#include <Common/AudioRequest.hpp>
#include <Common/Properties/Descriptors/BooleanPropertyDescriptor.hpp>
#include <Sms/SmsIndicationState.hpp>
#include <Atl/Properties/PropertyDescriptor.hpp>
#include <Common/Properties/Descriptors/SetPropertyDescriptor.hpp>
#include <Atl/Properties/PropertyEditorFactory.hpp>
#include <Common/MmiPhoneNumberPrompt.hpp>
#include <Common/WildcardMultiLineEditor.hpp>
#include <Common/MmiDialog.hpp>
#include <Asc/SmsContext.hpp>

Include dependency graph for AbstractSmsApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractSmsApp

Defines

#define | Mmi_AbstractSmsApp_hpp

Define Documentation

#define Mmi_AbstractSmsApp_hpp

Generated on Wed Jan 25 00:04:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsApp.hpp Source File

Applications/Ems/Sms/AbstractSmsApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_AbstractSmsApp_hpp)
00010 #define Mmi_AbstractSmsApp_hpp
00013
00014 #include <Config/SmsCustomizationConfig.hpp>
00015
00016 #include <Common/MmiApplication.hpp>
00017 #include <Atl/Gui/AtlItemListWindow.hpp>
00018 #include <Atl/Gui/AtlItemMenuWindow.hpp>
00019 #include <Atl/Features/ProviderProxyItem.hpp>
00020 #include <Atl/Properties/PropertyItem.hpp>
00021
00022 #include <Common/MmiProviderProgressBox.hpp>
00023 #include <Common/Items/ProviderProxyContainer.hpp>
00024 #include <Common/MmiWaitingBox.hpp>
00025
00026 #include <Config/SmsConfig.hpp>
00027
00028 #include <Sms/SmsMsgTypes.hpp>
00029 #include <Sms/SmsService.hpp>
00030 #include <Sms/AbstractSmsComposeWin.hpp>
00031 #include <Sms/AbstractSmsViewerWin.hpp>
00032 #include <Sms/SmsAlerts.hpp>
00033 #include <Sms/SmsSendingConfirmDialog.hpp>
00034 #include <Sms/SmsTextMaps.hpp>
00035
00036 #include <Sms/SmsBasicProvider.hpp>
00037 #include <Sms/SmsTemplateProvider.hpp>
00038 #include <Sms/SmsSettingsProvider.hpp>
00039
00040 /* uib support */
00041 #if defined (APPLICATION_UNIFIEDINBOX)
00042     #include <Sms/SmsFolderProvider.hpp>
00043 #endif/* uib support */
00044 #include <Common/AudioRequest.hpp>
00045 #include <Common/Properties/Descriptors/BooleanPropertyDescriptor.hpp>
00046 #include <Sms/SmsIndicationState.hpp>
00047 #include <Atl/Properties/PropertyDescriptor.hpp>
00048 #include <Common/Properties/Descriptors/SetPropertyDescriptor.hpp>
00049 #include <Atl/Properties/PropertyEditorFactory.hpp>
00050 #include <Common/MmiPhoneNumberPrompt.hpp>
00051 class AbstractSmsUtilityProcessor;
00052 #include <Common/WildcardMultiLineEditor.hpp>
00053 #include <Common/MmiDialog.hpp>
00054 #include <Asc/SmsContext.hpp>
00055
00059 class AbstractSmsApp : public MmiApplication {
00060     typedef MmiApplication Base;
00061
00062     public:
00064         enum SmsServiceType {
00065             ComposeSmsType,
00066             SendSmsType,
00067             SendInternalSmsType,
00068             StoreSmsType
00069         };
00071         enum SmsExportType {
00072             ExportSendType,
00073             ExportStoreType
00074         };
00075
00076         enum SmsSendingAnimationType {
00077
00078             SendingAnimationType
00079         };
00080
00081         enum SmsStorageType{
00082             SmsSimPreferred,
00083             SmsFlashPreferred
00084         };
00085
00086         enum SmsValidtyPeriodType{
00087             One_hour = 11, // 1 hour
00088             Twelve_Hour = 143, // 12 hours
00089             One_Day = 167,  // 1 day
00090             One_Week = 173, // 1 week
00091             Thirty_Days = 196,  // 30 days (~1 month)
00092             Three_Months = 205, // 3 months (13 weeks)
00093             Maximum = 255 // Maximum (63 weeks)
00094
00095         };
00096
00097         enum PeriodData {
00098             PeriodCount = 7
00099         };
00100         explicit AbstractSmsApp(const WCHAR* app_name, UINT stacksize = 0); //lint !e1704
00102         virtual ~AbstractSmsApp();
00103
00107         Provider* GetInboxProvider() const          { return m_inbox_provider; }
00111         Provider* GetInboxUnreadProvider() const { return m_sms_inbox_unread_provider; }
00115         Provider* GetOutboxProvider() const         { return m_outbox_provider; }
00116
00120         Provider* GetArchiveProvider() const        { return m_archive_provider; }
00121
00125         Provider* GetStatusReportProvider() const   { return m_statrep_provider; }
00126
00130         Provider* GetArrivedProvider() const        { return m_arrived_provider; }
00131
00132
00136         Provider* GetTemplateProvider() const       { return &m_template_provider; }
00137
00138
00142         Provider* GetReadProvider()                 { return DataControl::GetMainProvider()->GetProvider(c_sms_read_provider_id); }
00143
00147         Provider* GetUnreadProvider()               { return DataControl::GetMainProvider()->GetProvider(c_sms_unread_provider_id); }
00148
00152         Provider* GetSentProvider()                 { return DataControl::GetMainProvider()->GetProvider(c_sms_sent_provider_id); }
00153
00157         Provider* GetUnsentProvider()               { return DataControl::GetMainProvider()->GetProvider(c_sms_unsent_provider_id); }
00158
00162         Provider* GetSmsClass0Provider()            { return DataControl::GetMainProvider()->GetProvider(c_sms_class0_provider_id); }
00163
00167         Provider* GetSettingsProvider() const       { return &m_settings_provider; }
00168
00172         Provider* GetProfileProvider() const        { return m_profile_provider; }
00173
00177         Provider* GetSmsProvider() const            { return m_sms_provider; }
00178
00182         SmsBasicProvider* GetSmsBasicProvider() const           { return &m_sms_basic_provider; }
00183         AbstractSmsUtilityProcessor*    GetUtilityProcessor()       { return    m_utlp;}
00184
00185
00189         virtual void ShowSms(Provider* provider, INT act_row);
00191
00194         virtual void DeleteSms(Provider* provider, INT act_row);
00195
00200         virtual void ForwardSms(Provider* provider, INT act_row);
00201
00206         virtual void ReplySms(Provider* provider, INT act_row);
00207
00212         virtual void ComposeSms (const PhoneNumber* destination = 0, BOOLEAN clear = TRUE);
00218         virtual void ComposeSms (const EditorDocumentObtainer& obtainer, const PhoneNumber* destination = 0, BOOLEAN clear = TRUE);
00219
00221         virtual void StoreSms(const EditorDocumentObtainer& obtainer, const PhoneNumber* destination = 0);
00222
00224         virtual void StoreSms(const Tpdu& tpdu);
00225
00227         virtual void StoreSentSms(const SmsContext& profile);
00228
00230         virtual void SendSms(const EditorDocumentObtainer& obtainer, const PhoneNumber* destination = 0, const PhoneNumber* service_center = 0);
00231
00235         virtual void ShowArrivedSms(BOOLEAN show_status_report = FALSE);
00236
00238         virtual BOOLEAN IsServiceAvailable(SmsServiceType type) const;
00239
00241         WString GetNameForNumber(const PhoneNumber& phoneNr) const;
00242
00249         void    SwitchReadStatus(Provider* provider, INT row, BOOLEAN switch_to_read, BOOLEAN immediate_update = FALSE);
00251         void    MoveSmsToArchive(Provider* provider, INT row);
00255         INT     GetCapacity() const;
00257         INT     GetExistentSmsCount() const { return m_valid_sms_cnt; }
00259         INT     GetFreeSmsCount() const;
00261         virtual BOOLEAN Update(ProviderListener* listener = 0, BOOLEAN update_providers = TRUE);
00263         virtual void UpdateSettings(ProviderListener* listener = 0);
00265         void    SetWaitingBoxVisible(BOOLEAN flag) const;
00267         BOOLEAN GetProviderData(Provider* provider, INT id, INT row, DataItem& item) const;
00269         //BOOLEAN IsVoiceBoxNumberApplied();
00271         BOOLEAN             SetPreferredStorageType(Sms::StorageType storage_type);
00273         Sms::StorageType    GetPreferredStorageType();
00275         BOOLEAN             IsGprsAvailable();
00277         static DataCodingScheme::Alphabet MapAlphabet(const EditorDocumentObtainer& obtainer);
00279         static InputMapper::Alphabet MapAlphabet(DataCodingScheme::Alphabet alphabet);
00281         void RememberRepliedTpdu(CompoundTpduItem* tpdu) { m_replied_tpdu = tpdu; }
00283         void SetEditEnable(BOOLEAN enable);
00285         //void UpdateSettingsOptions(BOOLEAN available);
00287         //void EditSettingsDisabled(BOOLEAN enable);
00289         virtual void    OnIndicateIncoming(SmsConfig::SmsIndicationType type);
00290         virtual void    OnExportConfirmation(SmsExportType export_type, Sms::Result result_code, const SmsContext& profile, INT pending_segment_count = 0);
00291         BOOLEAN IsReadyForSendingSms(const SmsContext& profile, INT segment_count = -1);
00292         BOOLEAN IsSmsComposeEnabled() const { return m_items[SmsComposeMessage].IsEnabled(); }
00293         void RegisterUtility(AbstractSmsUtilityProcessor *utlp);
00294         virtual void RelaySms(Provider* provider, INT act_row, BOOLEAN reply);
00295         virtual void    OnOpen();
00296
00297         BOOLEAN WildCharHandler(PhoneNumber& number);
00298         BOOLEAN ValidateValidityPeriod(ValidityPeriod &period);
00299         BOOLEAN ValidateProtocolIdentifier(ProtocolIdentifier &protocol_identifier);
00300         void    ValidateServiceCenterAddress();
00301
00302         BOOLEAN     IsRequestReplyPath()    { return m_request_reply_path;}
00303         BOOLEAN     IsRequestStatusReport() { return m_request_status_report;}
00304         BOOLEAN     GetPeriodManual()       { return m_period_manual;}
00305         BOOLEAN     GetDeviceManual()       { return m_device_manual; }
00306         INT         GetDefaultProfile() const;
00307         SmsContext* GetSmsProfile()         { return &m_sms_profile;}
00309         void InitiateCall(const WString &text);
00311         void StoreInPhonebook(const WString &text);
00313         void ConnectToUrl(const WString &text);
00315         void AddBookmark(const WString &text);
00317         void StoreEmailInPhonebook(const WString &text);
00319         void SendEmail(const WString &text);
00320
00324         BOOLEAN UpdateVoiceMailboxNumbers(PhoneNumber& voiceMailbox, LineSelector line, BOOLEAN read_write_number);
00325     protected:
00326
00328         virtual void OnLanguageChanged();
00329
00331         virtual BOOLEAN UpdateItem(Item* item);
00332
00333 //      virtual void UpdateContextItem(ContextFeatureItem* item);
00335         virtual void    OnStartup();
00337
00339         virtual void    OnClose();
00341         virtual void    OnLoseFocus();
00343         virtual BOOLEAN OnMessage(const Message &msg);
00345         virtual void    OnSmsService (SmsServiceType type, EditorDocumentObtainer obtainer, const PhoneNumber& number);
00351         virtual void    OnSimSmsReady();
00353         virtual void    OnSimRemoved();
00354
00356         BOOLEAN IsSendingSmsConfirmed(const SmsContext& profile, INT segment_count = -1) const;
00358
00360         void    SetSmsComposeEnabled(BOOLEAN flag);
00362
00363
00365         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00366
00368         virtual BOOLEAN OnContextFeatureTriggered (const FeatureID& feature_id, const DataItem& context_item);
00369
00370         virtual BOOLEAN OnPropertyNotification(const Property::Notification notification,
00371                                                const Property* property,
00372                                                const DataItem& value);
00373
00374     private:
00376         enum FeatureIds {
00377             SmsOpenTemplates = 0,
00378             SmsOpenMainSettings,
00379             SmsSend,
00380             SmsStore,
00381             SmsDeleteInbox,
00382             SmsDeleteOutbox,
00383             SmsDeleteReports,
00384             SmsDeleteArchive,
00385             SmsChangeSettings,
00386             SmsSelectSettings,
00387             SmsEditSettings,
00388             SmsChangeCommonSettings,
00389             SmsEditProfileSettings,
00390 //          SmsSendAgain,
00391 //          SmsSave,
00392
00393             SmsT9Disabled,
00394             SmsT9English,
00395             SmsT9SimpChinese,
00396             SmsT9TradChinese,
00397             SmsT9Pinyin,
00398             SmsT9BoPoMoFo,
00399             SmsComposeMessage,
00400             SmsOpenInbox,
00401             SmsOpenOutbox,
00402             SmsOpenArchive,
00403             SmsOpenStatusReports,
00404             SmsOpenSettings,
00405             SmsShowArrivedMessage,
00406             SmsInsertTemplate,
00407             SmsTextInitiateCall,
00408             SmsTextStoreInPhoneBook,
00409             SmsTextSendSms,
00410             SmsTextConnectToURL,
00411             SmsTextAddBookMark,
00412             SmsTextStoreEmailInPhoneBook,
00413             SmsTextSendEmail,
00414             SmsViewGreenKey,
00415             SmsFeatureCnt
00416         };
00418         enum ContextFeatureIds {
00419             SmsView,
00420             SmsDelete,
00421             SmsReply,
00422             SmsEdit,
00423             SmsForward,
00424             SmsCreate,
00425             SmsUseNumber,
00426             SmsFirst,
00427             SmsPrevious,
00428             SmsNext,
00429             SmsLast,
00430             SmsPerformCall,
00431             SmsToggleReadMode,
00432             SmsToPhonebook,
00433             SmsToArchive,
00434             SmsInsertTemplateText,
00435             SmsEmbItemPrevious,
00436             SmsEmbItemNext,
00437             SmsContextFeatureCnt
00438         };
00440         enum PropertyIds {
00441             SmsStartNumberProperty = 0,
00442             SmsInboxProperty = SmsStartNumberProperty,
00443             SmsOutboxProperty,
00444             SmsArchiveProperty,
00445             SmsTemplatesProperty,
00446             SmsStatusReportsProperty,
00447             UnreadInboxProperty,
00448             TotalInboxProperty,
00449             SmsStartBooleanPropertyInitiallyTrue,
00450             ToggleRreadModeProperty = SmsStartBooleanPropertyInitiallyTrue,
00451             SmsStartStringProperty,
00452             ShowArrivedMsgProperty = SmsStartStringProperty,
00453             SmsStartOtherProperties,
00454             SmsVoiceboxNumberProperty = SmsStartOtherProperties,
00455             ServiceCenterTypeProperty,
00456             DefaultDestinationTypeProperty,
00457             SmsStartOtherNumberProperty,
00458             SmsConnectionProperty = SmsStartOtherNumberProperty,
00459             SmsStoreAtProperty,
00460             TelematicDeviceTypeProperty,
00461             ValidityPeriodTypeProperty,
00462             SmsStartBooleanPropertyInitiallyFalse,
00463             SmsReplyPathProperty = SmsStartBooleanPropertyInitiallyFalse,
00464             SmsDeliverReportProperty,
00465             SmsShowDeliverReportsOnIdleScreenProperty,
00466             SmsAutoStoreSentProperty,
00467             SmsConfirmProperty,
00468             SmsMandatorySendingPreviewProperty,
00469             SmsStartOtherStringProperty,
00470             ProfileNameProperty = SmsStartOtherStringProperty,
00471             SmsPropertyCnt
00472         };
00474         /*enum ProviderIds {
00475             SmsBaseIbxProvId = 1036,
00476             SmsBaseObxProvId,
00477             SmsBaseAchveProvId,
00478             SmsBaseStatRepProvId,
00479             SmsBaseUnrdProvId,
00480             SmsTmplteProvId = 7046,
00481             SmsCountProvId = 1020,
00482             SmsProvId = 1013,
00483             SstProvId = 1010,
00484             StatProvId = 1007,
00485             SmsParamProvId = 1018,
00486         };*/
00487
00488
00489         void UpdateSmsNavigationOption(INT current_row, INT last_row);
00490
00492         void UpdateSmsEmbItemsOption();
00494
00495         PropertyIds GetPropertyId(const FeatureID &id) const;
00496         DataItem GetContextDataItem(ContextFeature* feature);
00498         void InitProperty();
00499
00500         void Change(PropertyIds type, BOOLEAN flag);
00501
00502         static const WCHAR* GetProtocolIdentifierName(const ProtocolIdentifier& pi);
00503         AbstractSmsApp();
00504
00505         // Singleton. No need for a copy constructor. Made it private
00506
00508         INT     GetActualCount(Provider* provider, ProviderListener* listener = 0, BOOLEAN update_providers = TRUE) const;
00510         void    RegisterSettingsProvider();
00512         INT     SingleUpdate(Provider* provider, ProviderListener* lstn,
00513                           WString* buffer = 0, const WCHAR* text = 0,
00514                           PropertyIds fid = SmsPropertyCnt, Provider* low_provider = 0, BOOLEAN update_providers = TRUE);
00516         BOOLEAN UpdateStorageType();
00518         void UpdateIndication();
00520         void RemoveReplyPathFlag(CompoundTpduItem* tpdu);
00522         /* uib support */
00523         #if defined (APPLICATION_UNIFIEDINBOX)
00524         AbstractDelegationProvider* GetExportedProvider(INT provider_id);
00525         #endif
00526         /* uib support */
00528         void UpdateIncoming(AudioRequest::ToneType, SmsAlert::SmsAlertType, BOOLEAN force_update);
00529
00532         struct {
00533             UINT actual_sms_stored          : 2;
00534         } m_flags;
00536         void NavigateViewSms(Provider* provider, const FeatureID& feature_id);
00537         void NavigateSmsEmbItems(Provider* provider, const FeatureID& feature_id);
00538         void DisplaySettingsOptions();
00539         void SwitchDefaultProfile();
00540         void RestoreDefaultProfile();
00541         void UpdateProfilePrompt(Provider* p, INT col_id, PropertyIds prop_id);
00542         void UpdateCommonSettingsOption(Provider* p, INT col_id, PropertyIds prop_id);
00543         UINT8   GetValidtyPeriod(UINT8 index);
00545         static INT  m_valid_sms_cnt;
00547         static INT  m_waiting_cnt;
00549         static SmsContext           m_sms_profile;
00551
00553         static SmsBasicProvider     m_sms_basic_provider;
00554         static Provider*            m_sms_provider;
00555         static Provider*            m_archive_provider;
00556         static Provider*            m_inbox_provider;
00557         static Provider*            m_outbox_provider;
00558         static SmsTemplateProvider  m_template_provider;
00559         static Provider*            m_statrep_provider;
00560         static Provider*            m_arrived_provider;
00561         static SmsSettingsProvider  m_settings_provider;
00562         static Provider*            m_sms_inbox_unread_provider;
00563
00565         static Provider*            m_profile_provider;
00567         /* uib support */
00568         #if defined (APPLICATION_UNIFIEDINBOX)
00569         static SmsFolderProvider    m_uib_provider;
00570         #endif
00571         /* uib support */
00573         SmsConfig::SmsIndicationType            m_new_message_type;
00575         BasicSmsService             m_service;
00577         static MmiProviderProgressBox   m_progress_alert;
00579         WString                     m_menu_text;
00581         WString                     m_inbox_text;
00583         WString                     m_outbox_text;
00585         WString                     m_archive_text;
00587         WString                     m_template_text;
00589         WString                     m_statrep_text;
00591         static MmiWaitingBox        m_waiting_alert;
00593         static SmsInfoBox           m_info_box;
00595         static SmsAlert             m_alert;
00597         static SmsSendingConfirmDialog m_sending_confirm_dlg;
00599         AudioRequest                m_sms_audio;
00601         CompoundTpduItem*           m_replied_tpdu;
00602
00608         UINT8                       m_update_state;
00610         AtlItemListWindow           m_sms_box_win;
00612         ProviderProxyContainer      m_sms_box_cont;
00613
00615         Feature                     m_items[SmsFeatureCnt];
00617         ContextFeature              m_context_items[SmsContextFeatureCnt];
00619         Property                    m_property[SmsPropertyCnt];
00624         BooleanPropertyDescriptor   m_desc;
00626         SmsIndicationState          m_indication_state;
00629         ProviderProxyItem           m_ppi;
00631         INT                         m_ppi_selected_index;
00632         AtlItemMenuWindow           m_menu_window;
00633         FeatureItemContainer        m_feat_item_cont;
00634         AtlItemListWindow           m_list_win;
00635         ItemContainer               m_item_cont;
00636         Item                        m_item[c_sms_max_profile];
00637         BOOLEAN                         m_manual;
00638         BOOLEAN                         m_save_on_commit;
00639         ProtocolIdentifier              m_pis[7];
00640         const UINT8                     m_pi_cnt;
00641         static BOOLEAN                  m_period_manual;
00642         static BOOLEAN                  m_device_manual;
00643         DataItem                        m_period_item;
00644         DataItem                        m_protocol_item;
00645         DataItem                        m_svc_ctr_item;
00646         static BOOLEAN                  m_request_reply_path;
00647         static BOOLEAN                  m_request_status_report;
00648         BOOLEAN                         m_preview_mandatory;
00649         BOOLEAN                         m_auto_store;
00650         PropertyItem                    m_phonenumber_prompt;
00651         PropertyItem                    m_period_prompt;
00652         PropertyItem                    m_device_prompt;
00653         static AbstractSmsUtilityProcessor      *m_utlp;
00654
00655         WildcardMultiLineEditor         m_wildcards_editor;
00656         MmiDialog                       m_pn_win;
00657
00658         BOOLEAN                     m_als_supported;
00659 };
00660
00662 #endif  // Mmi_AbstractSmsApp_hpp
00663
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsComposeWin.cpp File Reference

Applications/Ems/Sms/AbstractSmsComposeWin.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>
#include "AbstractSmsApp.hpp"
#include "AbstractSmsComposeWin.hpp"

Include dependency graph for AbstractSmsComposeWin.cpp:

Generated on Wed Jan 25 00:04:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsComposeWin.hpp File Reference

Applications/Ems/Sms/AbstractSmsComposeWin.hpp File Reference

#include <Atl/AtlWindow.hpp>

Include dependency graph for AbstractSmsComposeWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractSmsComposeWin

Defines

#define | Mmi_AbstractSmsComposeWin_hpp

Define Documentation

#define Mmi_AbstractSmsComposeWin_hpp

Generated on Wed Jan 25 00:04:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsComposeWin.hpp Source File

Applications/Ems/Sms/AbstractSmsComposeWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_AbstractSmsComposeWin_hpp)
00010 #define Mmi_AbstractSmsComposeWin_hpp
00013
00014
00015 class AbstractSmsApp;
00016 class AbstractPredictiveInputBox;
00017
00018 #include <Atl/AtlWindow.hpp>
00019
00022 class AbstractSmsComposeWin : public AtlWindow {
00023         typedef AtlWindow Base;
00024
00025     public:
00027         AbstractSmsComposeWin();
00029         void Init(AbstractSmsApp* sms_app, const WCHAR* title);
00031         virtual ~AbstractSmsComposeWin();
00033         virtual EditorDocumentObtainer GetDocumentObtainer() const = 0;
00035         virtual void SetDocumentObtainer(const EditorDocumentObtainer& obtainer) = 0;
00037         virtual void InsertText(const WString& text) = 0;
00039         void SetDestinationAddress(const PhoneNumber* number);
00041         const PhoneNumber& GetDestinationAddress() const { return m_destination; }
00043         void SetServiceCenter(const PhoneNumber* service_center) { m_service_center = service_center; }
00045         const PhoneNumber& GetServiceCenter() const { return m_service_center; }
00046
00050         virtual void OnInputModeChanged(PredInputMapper::PredMode mode);
00052         virtual AbstractPredictiveInputBox* GetPredInputBox() = 0;
00053
00055         virtual void RelaySms(Provider* provider, INT row, BOOLEAN reply = FALSE);
00056
00057     private:
00059         AbstractSmsComposeWin(const AbstractSmsComposeWin &ascw);
00060
00062         AbstractSmsComposeWin& operator=(const AbstractSmsComposeWin&);
00065         PhoneNumber         m_destination;
00068         PhoneNumber         m_service_center;
00069 };
00070
00072 #endif // Mmi_AbstractSmsComposeWin_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsUtiltyProcessor.hpp File Reference

Applications/Ems/Sms/AbstractSmsUtiltyProcessor.hpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Sms/AbstractSmsComposeWin.hpp>
#include <Sms/AbstractSmsViewerWin.hpp>

Include dependency graph for AbstractSmsUtiltyProcessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractSmsUtilityProcessor

Defines

#define | Mmi_AbstractSmsUtilityProcessor_hpp

Define Documentation

#define Mmi_AbstractSmsUtilityProcessor_hpp

Generated on Wed Jan 25 00:04:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsUtiltyProcessor.hpp Source File

Applications/Ems/Sms/AbstractSmsUtiltyProcessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_AbstractSmsUtilityProcessor_hpp)
00010 #define Mmi_AbstractSmsUtilityProcessor_hpp
00013 #include <Sms/SmsPreComp.hpp>
00014 //#include <Sms/AbstractSmsApp.hpp>
00015 #include <Sms/AbstractSmsComposeWin.hpp>
00016 #include <Sms/AbstractSmsViewerWin.hpp>
00017
00020 class AbstractSmsApp;
00021 class AbstractSmsUtilityProcessor  {
00022
00023     public:
00024
00025         virtual void SendImpl(const SmsContext& profile, const EditorDocumentObtainer& obtainer) = 0;
00026         virtual AbstractSmsComposeWin* GetSmsComposer() = 0;
00027         virtual AbstractSmsViewerWin* GetSmsViewer() = 0;
00028         virtual SmsFactory* GetSmsFactory() = 0;
00029         virtual void StoreImpl(const SmsContext& profile, const EditorDocumentObtainer& obtainer) = 0;
00030         virtual void OnExportConfirmation(AbstractSmsApp::SmsExportType export_type, Sms::Result result_code, const SmsContext& profile, INT pending_segment_count = 0) = 0;
00031         virtual void RelaySms(Provider* provider, INT act_row, BOOLEAN reply) = 0;
00032
00033 };
00034
00036 #endif  // Mmi_SmsApp_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsViewerWin.cpp File Reference

Applications/Ems/Sms/AbstractSmsViewerWin.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "AbstractSmsApp.hpp"
#include "AbstractSmsViewerWin.hpp"
#include <Config/SmsCustomizationConfig.hpp>

Include dependency graph for AbstractSmsViewerWin.cpp:

Generated on Wed Jan 25 00:05:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsViewerWin.hpp File Reference

Applications/Ems/Sms/AbstractSmsViewerWin.hpp File Reference

#include <Atl/AtlWindow.hpp>
#include <Sms/SmsTextParser.hpp>

Include dependency graph for AbstractSmsViewerWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AbstractSmsViewerWin

Defines

#define | Mmi_AbstractSmsViewerWin_hpp

Define Documentation

#define Mmi_AbstractSmsViewerWin_hpp

Generated on Wed Jan 25 00:05:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/AbstractSmsViewerWin.hpp Source File

Applications/Ems/Sms/AbstractSmsViewerWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_AbstractSmsViewerWin_hpp)
00010 #define Mmi_AbstractSmsViewerWin_hpp
00011
00014 class AbstractSmsApp;
00015 #include <Atl/AtlWindow.hpp>
00016 #include <Sms/SmsTextParser.hpp>
00017
00020 class AbstractSmsViewerWin : public AtlWindow {
00021     typedef AtlWindow Base;
00022
00023     public:
00025         enum Direction {
00026             First = 64,
00027             Prev,
00028             Next,
00029             Last,
00030         };
00031
00033         AbstractSmsViewerWin();
00034
00036         void Init(AbstractSmsApp* sms_app, const WCHAR* title);
00037
00039         virtual ~AbstractSmsViewerWin();
00040
00045         virtual INT GoToSms(Direction dir);
00046
00050         virtual void GoToSmsEmbItems(Direction dir) = 0;
00051
00052         virtual SmsTextEntry GetSelectedSmsEmbItem() = 0;
00053
00055         virtual const EditorDocument* GetDocument() const = 0;
00056
00058         virtual void SetDocument(const EditorDocument* doc) = 0;
00059
00061         Provider* GetProvider() const;
00062
00064         INT GetSelectedSms() const;
00065
00067         virtual void SetSelectedSms(Provider* provider, INT selected_row = 0);
00068
00070         void UpdateDisplayedSms();
00071
00072         // Remove when EMS has been adapted to plugin
00073  #if defined (APPLICATION_EMS) || defined (APPLICATION_ADVEMS)
00074
00075         AbstractSmsApp* GetSmsApplication() const { return (AbstractSmsApp*) GetApplication(); }
00076
00078         void    SetTitleText(const WCHAR* title) { SetTitle(title); }
00079
00081         virtual void SwitchReadStatus(BOOLEAN switch_to_read) {  }
00082
00083         #endif
00084
00086         void SetUpdateOnClose(BOOLEAN state);
00087     protected:
00089         virtual void OnClose();
00091         virtual void OnDisplaySms(Provider* provider, INT row, INT set_index = -1) = 0;
00092
00093     private:
00095         AbstractSmsViewerWin(const AbstractSmsViewerWin &ascw);
00096
00098         AbstractSmsViewerWin& operator=(const AbstractSmsViewerWin&);
00099
00101         void PerformAutoDeletion(INT index);
00102
00104         Provider*       m_provider;
00105
00107         INT             m_selected_row;
00108
00110         Number          m_selected_record;
00111
00113         BOOLEAN m_update_on_close;
00114 };
00115
00117 #endif // Mmi_AbstractSmsViewerWin_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsAlerts.cpp File Reference

Applications/Ems/Sms/SmsAlerts.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Kernel/Os/TestWriter.hpp>
#include "AbstractSmsApp.hpp"
#include "SmsAlerts.hpp"
#include "SmsTextMaps.hpp"
#include <Config/Resources/sms_sending_anim_01.hpp>
#include <Config/Resources/sms_sending_anim_02.hpp>
#include <Config/Resources/sms_sending_anim_03.hpp>
#include <Config/Resources/sms_sending_anim_04.hpp>
#include <Config/Resources/sms_sending_anim_05.hpp>
#include <Config/Resources/sms_sending_anim_06.hpp>
#include <Config/Resources/sms_sending_anim_07.hpp>
#include <Config/Resources/sms_sending_anim_08.hpp>
#include <Config/Resources/sms_sending_anim_09.hpp>
#include <Config/Resources/sms_sending_anim_10.hpp>
#include <Config/Resources/sms_sending_anim_11.hpp>
#include <Config/Resources/sms_sending_anim_12.hpp>
#include <Config/Resources/sms_sending_anim_13.hpp>
#include <Config/Resources/sms_sending_anim_14.hpp>
#include <Config/Resources/sms_sending_anim_15.hpp>
#include <Config/Resources/sms_sending_anim_16.hpp>
#include <Config/Resources/sms_sending_anim_17.hpp>

Include dependency graph for SmsAlerts.cpp:

Generated on Wed Jan 25 00:05:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsAlerts.hpp File Reference

Applications/Ems/Sms/SmsAlerts.hpp File Reference

#include <Common/MmiInfoBox.hpp>
#include <Common/MmiAlert.hpp>

Include dependency graph for SmsAlerts.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsAlert
class | SmsInfoBox
struct | SmsSendingAnimation
sending animation More...

Defines

#define | Mmi_SmsAlerts_hpp

Define Documentation

#define Mmi_SmsAlerts_hpp

Generated on Wed Jan 25 00:05:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsAlerts.hpp Source File

Applications/Ems/Sms/SmsAlerts.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsAlerts_hpp)
00010 #define Mmi_SmsAlerts_hpp
00013
00014 #include <Common/MmiInfoBox.hpp>
00015 #include <Common/MmiAlert.hpp>
00016
00018 struct SmsSendingAnimation {
00019     const static UINT32 c_sms_sending_anim_speed;
00020     const static BitmapRes* m_bmps[17];
00021     const static INT c_sms_sending_anim_img_cnt;
00022 };
00023
00027 class SmsAlert : public MmiAlert {
00028     typedef MmiAlert Base;
00029     public:
00031         enum SmsAlertType {
00032             SmsSentOkType,
00033             SmsReceivedSmsType,
00034             SmsPendingSmsType,
00035             SmsReceivedStatRepType,
00036             SmsMemoryFullType,
00037             SmsSimFullType,
00038             SmsStoredOkType,
00039             SmsBoxEmpty
00040         };
00042         SmsAlert();
00044         ~SmsAlert();
00046         void Init();
00048         void SetSmsAlertType(SmsAlertType type, INT pending_seg_count = -1);
00049
00050     private:
00052         SmsAlert(const SmsAlert &);
00054         SmsAlert& operator=(const SmsAlert&);
00056         WString m_text;
00057 };
00058
00059
00064 class SmsInfoBox : public MmiInfoBox {
00065     typedef MmiInfoBox Base;
00066     public:
00068         enum SmsInfoBoxType {
00069                 SmsClass0Type,
00070                 SmsSendingType,
00071                 SmsPendingType,
00072                 SmsAddToPhonebookErrorType,
00073                 SmsSetupCallErrorType,
00074                 SmsDeleteMessage,
00075                 SmsDeleteAllInbox,
00076                 SmsDeleteAllOutbox,
00077                 SmsDeleteAllReports,
00078                 SmsDeleteAllArchive,
00079                 SmsSendType,
00080                 SmsStoreType,
00081                 SmsRejectType,
00082                 SmsSendErrorType,
00083                 SmsSendErrorStoreOptionType,
00084                 SmsStoreErrorType,
00085                 SmsDeleteError
00086             };
00088         SmsInfoBox();
00090         ~SmsInfoBox();
00092         void Init();
00094         void SetSmsInfoBoxType(const SmsInfoBoxType &type);
00096         void SetErrorInfo(const SmsInfoBoxType &type, Sms::Result result_code, INT pending_seg_count);
00097
00098         Tpdu& GetTpdu() {return m_tpdu;}
00099     private:
00100         virtual BOOLEAN OnConfirm();
00102         SmsInfoBox(const SmsInfoBox &);
00104         SmsInfoBox& operator=(const SmsInfoBox&);
00106         SmsSendingAnimation m_sending_anim;
00108         Tpdu m_tpdu;
00109 };
00110
00112 #endif // Mmi_SmsAlerts_hpp
00113
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsApp.cpp File Reference

Applications/Ems/Sms/SmsApp.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsApp.hpp"

Include dependency graph for SmsApp.cpp:

Generated on Wed Jan 25 00:05:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsApp.hpp File Reference

Applications/Ems/Sms/SmsApp.hpp File Reference

#include <Sms/AbstractSmsApp.hpp>
#include <Sms/SmsComposeWin.hpp>
#include <Sms/SmsViewerWin.hpp>
#include <Sms/SmsUtility.hpp>

Include dependency graph for SmsApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsApp

Defines

#define | Mmi_SmsApp_hpp

Define Documentation

#define Mmi_SmsApp_hpp

Generated on Wed Jan 25 00:05:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsApp.hpp Source File

Applications/Ems/Sms/SmsApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsApp_hpp)
00010 #define Mmi_SmsApp_hpp
00013
00014 #include <Sms/AbstractSmsApp.hpp>
00015 #include <Sms/SmsComposeWin.hpp>
00016 #include <Sms/SmsViewerWin.hpp>
00017 #include <Sms/SmsUtility.hpp>
00018
00021 class SmsApp : public AbstractSmsApp {
00022     typedef AbstractSmsApp Base;
00023
00024     public:
00026         static SmsApp* GetInstance();
00028         ~SmsApp();
00029
00030     private:
00032         void OnOpen();
00034         SmsApp();
00035
00037         static SmsApp m_app;
00039
00040         static SmsUtility                   m_sms_utility;
00041 };
00042
00044 #endif  // Mmi_SmsApp_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsBasicProvider.cpp File Reference

Applications/Ems/Sms/SmsBasicProvider.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsBasicProvider.hpp"
#include <Config/Resources/sms_msg_waiting_unread_icon.hpp>
#include <Config/Resources/sms_msg_waiting_read_icon.hpp>
#include <Config/Resources/sms_read_icon.hpp>
#include <Config/Resources/sms_unread_icon.hpp>
#include <Config/Resources/sms_sent_icon.hpp>
#include <Config/Resources/sms_stored_icon.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <Common/MmiServices.hpp>
#include <GuiExtensions/ImgObtObj.hpp>

Include dependency graph for SmsBasicProvider.cpp:

Generated on Wed Jan 25 00:06:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsBasicProvider.hpp File Reference

Applications/Ems/Sms/SmsBasicProvider.hpp File Reference

#include <AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp>
#include <AddOns/AuxExtensions/JoinRule.hpp>
#include <Auxiliary/AbstractDelegationProvider.hpp>
#include <Gui/Bitmap.hpp>
#include <Config/Config.hpp>

Include dependency graph for SmsBasicProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsBasicProvider

Defines

#define | Mmi_SmsBasicProvider_hpp

Define Documentation

#define Mmi_SmsBasicProvider_hpp

Generated on Wed Jan 25 00:06:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsBasicProvider.hpp Source File

Applications/Ems/Sms/SmsBasicProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsBasicProvider_hpp)
00010 #define Mmi_SmsBasicProvider_hpp
00013
00014 #include <AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp>
00015 #include <AddOns/AuxExtensions/JoinRule.hpp>
00016 #include <Auxiliary/AbstractDelegationProvider.hpp>
00017 #include <Gui/Bitmap.hpp>
00018
00019 #include <Config/Config.hpp>
00020
00028 class SmsBasicProvider : public AbstractDelegationProvider
00029 {
00030     typedef AbstractDelegationProvider Base;
00031
00032     public:
00033         SmsBasicProvider();
00034         virtual ~SmsBasicProvider();
00035
00042         void Init(Provider *sms_provider);
00043
00047         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00048
00054         virtual BOOLEAN GetChildRow(INT& childrow, INT row);
00055
00056         void SetProvider(Provider *provider);
00057
00058         void SetStatusChanged() { m_status = Provider::changed; }
00059
00060     protected:
00061         virtual BOOLEAN IsPhoneNumberTextDefaultData(INT columnid, INT row);
00062         virtual BOOLEAN Lock();
00063         virtual BOOLEAN Unlock();
00064
00065     private:
00068         BOOLEAN IsWaitingMessage(const INT16 &row);
00069         const ImageObtainer GetIcon(const INT16 &row);
00070
00071
00072         BOOLEAN             m_is_locked;
00073 };
00074
00076 #endif // Mmi_SmsBasicProvider_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsComposeWin.cpp File Reference

Applications/Ems/Sms/SmsComposeWin.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsApp.hpp"
#include "SmsComposeWin.hpp"
#include <Config/FontConfig.hpp>
#include <Config/SmsCustomizationConfig.hpp>

Include dependency graph for SmsComposeWin.cpp:

Generated on Wed Jan 25 00:06:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsComposeWin.hpp File Reference

Applications/Ems/Sms/SmsComposeWin.hpp File Reference

#include <Gui/TextLine.hpp>
#include <Sms/AbstractSmsComposeWin.hpp>
#include <Sms/SmsEditor.hpp>

Include dependency graph for SmsComposeWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsComposeWin

Defines

#define | Mmi_SmsComposeWin_hpp

Define Documentation

#define Mmi_SmsComposeWin_hpp

Generated on Wed Jan 25 00:06:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsComposeWin.hpp Source File

Applications/Ems/Sms/SmsComposeWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsComposeWin_hpp)
00010 #define Mmi_SmsComposeWin_hpp
00013
00014 class SmsApp;
00015 #include <Gui/TextLine.hpp>
00016
00017 #if defined(APOXI_INCLUDE_T9)
00018     #include <AddOns/T9/T9PredictiveInputBox.hpp>
00019 #elif defined(APOXI_INCLUDE_ZI8)
00020     #include <AddOns/Zi8/Zi8PredictiveInputBox.hpp>
00021 #endif
00022
00023 #include <Sms/AbstractSmsComposeWin.hpp>
00024 #include <Sms/SmsEditor.hpp>
00025
00026
00029 class SmsComposeWin : public AbstractSmsComposeWin {
00030     typedef AbstractSmsComposeWin Base;
00031
00032     public:
00034         SmsComposeWin();
00035
00037         virtual ~SmsComposeWin();
00038
00040         void Init(AbstractSmsApp* sms_app);
00041
00043         virtual EditorDocumentObtainer GetDocumentObtainer() const;
00044
00046         virtual void SetDocumentObtainer(const EditorDocumentObtainer& obtainer);
00047
00048         virtual void InsertText(const WString& text);
00049
00055         void SetCounterText(int segment, int freecounter);
00056
00059         UINT8 GetCharactersPerSegment();
00060
00061     protected:
00063         virtual AbstractPredictiveInputBox* GetPredInputBox();
00065         virtual void OnOpen();
00067
00069         virtual void OnLayoutClient();
00070
00071
00072
00073 #if defined(APOXI_INCLUDE_T9) || defined (APOXI_INCLUDE_ZI8)
00074
00076         virtual void OnInputModeChanged(PredInputMapper::PredMode mode);
00077 #endif
00078
00079     private:
00081         SmsComposeWin(const SmsComposeWin &ascw);
00082
00084         SmsComposeWin& operator=(const SmsComposeWin&);
00085
00086 #if defined(APOXI_INCLUDE_T9)
00087         T9PredictiveInputBox    m_input_box;
00088 #elif defined (APOXI_INCLUDE_ZI8)
00089         Zi8PredictiveInputBox   m_input_box;
00090 #endif
00091
00092         SmsEditor       m_editor;
00093
00095         TextLine    m_counter_display;
00097         WString     m_counter_text;
00098 };
00099
00101 #endif // Mmi_SmsComposeWin_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsEditor.cpp File Reference

Applications/Ems/Sms/SmsEditor.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Sms/SmsEditor.hpp>
#include <Config/IndicatorConfig.hpp>
#include <Config/LocaleConfig.hpp>
#include <Sms/SmsComposeWin.hpp>
#include <Ems/EmsApp.hpp>

Include dependency graph for SmsEditor.cpp:

Generated on Wed Jan 25 00:06:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsEditor.hpp File Reference

Applications/Ems/Sms/SmsEditor.hpp File Reference

#include <Config/SmsCustomizationConfig.hpp>

Include dependency graph for SmsEditor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsEditor

Defines

#define | Mmi_SmsEditor_hpp

Define Documentation

#define Mmi_SmsEditor_hpp

Generated on Wed Jan 25 00:07:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsEditor.hpp Source File

Applications/Ems/Sms/SmsEditor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_SmsEditor_hpp)
00011 #define Mmi_SmsEditor_hpp
00012
00017
00018 /*
00019 #include <Gui/LineEditor.hpp>
00020 #include <Gui/TextEditorDocument.hpp>
00021 #include "GuiExtensions/MmiWindow.hpp"
00022 #include <Gui/InputMapper.hpp>
00023 #include <Gui/View.hpp>
00024 #include <Apc/Sms.hpp>
00025 */
00026 class DefaultCaret;
00027 class AbstractMmiPrompt;
00028 class SmsComposeWin;
00029
00030 #include <Config/SmsCustomizationConfig.hpp>
00031
00034 class SmsEditor : public MultiLineEditor {
00035     typedef MultiLineEditor Base;
00036
00037     public:
00039         SmsEditor();
00040
00048             SmsEditor(Control* parent,
00049                    INT input_mapper_id,
00050                    INT max_char_limit = 10,
00051                    const WCHAR* text = 0);
00052
00054         virtual ~SmsEditor();
00055
00062         void Init(Control* parent,
00063                   INT input_mapper_id,
00064                   INT max_char_limit = 10,
00065                   const WCHAR* text = 0);
00066
00067     public:
00068
00070         virtual BOOLEAN InsertItem(const AtomItem& item, INT index = -1);
00071
00072
00074         virtual BOOLEAN RemoveItem(INT index = -1);
00075
00077         virtual BOOLEAN Backspace();
00078
00080         virtual void OnGetFocus();
00081
00083         virtual SmsComposeWin* GetComposeWin();
00084
00086         virtual void ResetCounter();
00087
00088
00089
00090         UINT8 CalcFreeChars(InputMapper::Alphabet mode);
00091
00092         UINT8 GetMaxPduSize() const { return SmsSubmit::c_max_guaranteed_user_data_size;}
00093
00094     private:
00095         INT32       m_max_chars;
00096
00097         INT32       m_count;
00098
00099         INT32       m_seg_count;
00100
00101         INT32       m_totalseg_count;
00102
00103         INT32       m_free_char;
00104
00105         INT32       m_last_cnt;
00106
00107         // << Fix for SMS00044556
00108         INT32       m_char_in_segment_1;
00109         INT32       m_char_in_segment_2;
00110         INT32       m_char_in_segment_rest;
00111         // >> Fix for SMS00044556
00112
00113         static INT32        m_current_segment_count;
00114
00115         WString m_str;
00116 };
00117
00119 #endif  // Mmi_SmsEditor_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsFolderProvider.cpp File Reference

Applications/Ems/Sms/SmsFolderProvider.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsFolderProvider.hpp"
#include <Config/Config.hpp>
#include <Config/UibConfig.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Atl/Gui/ImgObtObj.hpp>

Include dependency graph for SmsFolderProvider.cpp:

Generated on Wed Jan 25 00:07:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsFolderProvider.hpp File Reference

Applications/Ems/Sms/SmsFolderProvider.hpp File Reference

#include "SmsBasicProvider.hpp"

Include dependency graph for SmsFolderProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsFolderProvider

Defines

#define | Mmi_SmsFolderProvider_hpp

Define Documentation

#define Mmi_SmsFolderProvider_hpp

Generated on Wed Jan 25 00:07:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsFolderProvider.hpp Source File

Applications/Ems/Sms/SmsFolderProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsFolderProvider_hpp)
00010 #define Mmi_SmsFolderProvider_hpp
00011
00012 #include "SmsBasicProvider.hpp"
00015
00016
00017 class SmsFolderProvider : public AbstractDelegationProvider
00018 {
00019     typedef AbstractDelegationProvider Base;
00020
00021     public:
00022         SmsFolderProvider();
00023         virtual ~SmsFolderProvider();
00024
00025         void Init(Provider *provider);
00026
00027         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem& item);
00028
00029         virtual BOOLEAN GetChildRow(INT& childrow, INT row);
00030
00031     protected:
00032         virtual INT GetMappedColumnId(INT colid);
00033
00034     private:
00035         UINT8 GetUibStatus(Tpdu::Status sms_status);
00036         SmsBasicProvider m_basic_provider;
00037 };
00038
00040 #endif  // Mmi_SmsFolderProvider_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsIndicationState.cpp File Reference

Applications/Ems/Sms/SmsIndicationState.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsIndicationState.hpp"
#include "AbstractSmsApp.hpp"

Include dependency graph for SmsIndicationState.cpp:

Generated on Wed Jan 25 00:07:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsIndicationState.hpp File Reference

Applications/Ems/Sms/SmsIndicationState.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsIndicationState

Defines

#define | Mmi_SmsIndicationState_hpp

Variables

const int | c_msg_waiting_priority = 2
const int | c_new_sms_priority = 3
const int | c_new_status_report_priority = 4
const int | c_pending_priority = 1

Define Documentation

#define Mmi_SmsIndicationState_hpp

Generated on Wed Jan 25 00:07:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsIndicationState.hpp Source File

Applications/Ems/Sms/SmsIndicationState.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2004 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsIndicationState_hpp)
00010 #define Mmi_SmsIndicationState_hpp
00013
00014 class AbstractSmsApp;
00015 const int c_pending_priority = 1;
00016 const int c_msg_waiting_priority = 2;
00017 const int c_new_sms_priority = 3;
00018 const int c_new_status_report_priority = 4;
00019
00024 class SmsIndicationState {
00025     public:
00026
00027         SmsIndicationState(AbstractSmsApp* app);
00028         virtual ~SmsIndicationState();
00029
00030         enum Indication {
00031             PendingIndication = c_pending_priority,
00032             MsgWaitingIndication = c_msg_waiting_priority,
00033             NewSmsIndication = c_new_sms_priority,
00034             NewStatRepIndication = c_new_status_report_priority,
00035             NoIndication
00036         };
00037
00038         void SetFlagState(BOOLEAN &flag, const BOOLEAN& enable, Indication cu);
00039         void SetMsgWaitingState(BOOLEAN enable);
00040         void SetPendingState(BOOLEAN enable);
00041         void SetNewSmsState(BOOLEAN enable);
00042         void SetNewStatRepState(BOOLEAN enable);
00043         void SetCurrentIndication(Indication li) {m_current_ind = li; }
00044
00045         BOOLEAN GetMsgWaitingState() {return m_msg_waiting_state;}
00046         BOOLEAN GetPendingState() {return m_pending_state;}
00047         BOOLEAN GetNewSmsState() {return m_new_sms_state;}
00048         BOOLEAN GetNewStatRepState() {return m_new_status_report_state;}
00049         Indication GetCurrentIndication() {return m_current_ind;}
00050
00051         virtual void SetNewCurrentIndication();
00052     private:
00053         Indication m_current_ind;
00054         BOOLEAN m_msg_waiting_state;
00055         BOOLEAN m_pending_state;
00056         BOOLEAN m_new_sms_state;
00057         BOOLEAN m_new_status_report_state;
00058         AbstractSmsApp* p_app;
00059 };
00061 #endif  // Mmi_SmsIndicationState_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsMsgTypes.cpp File Reference

Applications/Ems/Sms/SmsMsgTypes.cpp File Reference

#include "Sms/SmsPreComp.hpp"
#include "SmsMsgTypes.hpp"

Include dependency graph for SmsMsgTypes.cpp:

Generated on Wed Jan 25 00:07:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsMsgTypes.hpp File Reference

Applications/Ems/Sms/SmsMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/PhoneNumber.hpp>
#include <Auxiliary/WString.hpp>
#include <Gui/EditorDocument.hpp>

Include dependency graph for SmsMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SendSmsMsg
class | SmsServiceDocumentMsg
class | SmsServiceMsg

Defines

#define | Sms_SmsMsgTypes_hpp

Define Documentation

#define Sms_SmsMsgTypes_hpp

Generated on Wed Jan 25 00:07:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsMsgTypes.hpp Source File

Applications/Ems/Sms/SmsMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "datey_RefMMI_2\lnz_mmi\Mmi\Sms\SmsMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Sms_SmsMsgTypes_hpp)
00014 #define Sms_SmsMsgTypes_hpp
00015 #include <Kernel/Message.hpp>
00016 #include <Auxiliary/PhoneNumber.hpp>
00017 #include <Auxiliary/WString.hpp>
00018 #include <Gui/EditorDocument.hpp>
00019 /* ----------------------------------------------------------------------
00020     Classes
00021     ---------------------------------------------------------------------- */
00022 /*  ======================================================================
00023     Class SmsServiceMsg
00024     ====================================================================== */
00026 class SmsServiceMsg : public ContextMsg {
00027     public:
00028         SmsServiceMsg(ExecutionContext* context, INT16 arg, const WString& text, const PhoneNumber& phone_number);
00029         virtual ~SmsServiceMsg();
00030
00031         virtual const MsgMetaData& GetMetaData() const;
00032         void SetArg(INT16 arg) { m_arg = arg; }
00033         INT16 GetArg() const { return m_arg; }
00034         void SetText(const WString& text) { m_text = text; }
00035         const WString& GetText() const { return m_text; }
00036         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00037         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00038         virtual Message* Clone() const;
00039
00040         enum  {
00041             ID = 21500
00042             };
00043
00044     private:
00045         static const MsgMetaData m_meta_data;
00046         INT16 m_arg;
00047         WString m_text;
00048         PhoneNumber m_phone_number;
00049
00050     };
00051 /*  ======================================================================
00052     Class SmsServiceDocumentMsg
00053     ====================================================================== */
00055 class SmsServiceDocumentMsg : public ContextMsg {
00056     public:
00057         SmsServiceDocumentMsg(ExecutionContext* context, INT16 arg, const EditorDocumentObtainer& document_obtainer, const PhoneNumber& phone_number);
00058         virtual ~SmsServiceDocumentMsg();
00059
00060         virtual const MsgMetaData& GetMetaData() const;
00061         void SetArg(INT16 arg) { m_arg = arg; }
00062         INT16 GetArg() const { return m_arg; }
00063         const EditorDocumentObtainer& GetDocumentObtainer() const { return m_document_obtainer; }
00064         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00065         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00066         virtual Message* Clone() const;
00067
00068         enum  {
00069             ID = 21501
00070             };
00071
00072     private:
00073         static const MsgMetaData m_meta_data;
00074         INT16 m_arg;
00075         EditorDocumentObtainer m_document_obtainer;
00076         PhoneNumber m_phone_number;
00077
00078     };
00079 /*  ======================================================================
00080     Class SendSmsMsg
00081     ====================================================================== */
00082 class SendSmsMsg : public ContextMsg {
00083     public:
00084         SendSmsMsg(ExecutionContext* context, const EditorDocumentObtainer& document_obtainer, const PhoneNumber& phone_number, const PhoneNumber& service_center);
00085         virtual ~SendSmsMsg();
00086
00087         virtual const MsgMetaData& GetMetaData() const;
00088         const EditorDocumentObtainer& GetDocumentObtainer() const { return m_document_obtainer; }
00089         void SetPhoneNumber(const PhoneNumber& phone_number) { m_phone_number = phone_number; }
00090         const PhoneNumber& GetPhoneNumber() const { return m_phone_number; }
00091         void SetServiceCenter(const PhoneNumber& service_center) { m_service_center = service_center; }
00092         const PhoneNumber& GetServiceCenter() const { return m_service_center; }
00093         virtual Message* Clone() const;
00094
00095         enum  {
00096             ID = 21502
00097             };
00098
00099     private:
00100         static const MsgMetaData m_meta_data;
00101         EditorDocumentObtainer m_document_obtainer;
00102         PhoneNumber m_phone_number;
00103         PhoneNumber m_service_center;
00104
00105     };
00106 #endif // Sms_SmsMsgTypes_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsPreComp.cpp File Reference

Applications/Ems/Sms/SmsPreComp.cpp File Reference

#include <Sms/SmsPreComp.hpp>

Include dependency graph for SmsPreComp.cpp:

Generated on Wed Jan 25 00:08:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsPreComp.hpp File Reference

Applications/Ems/Sms/SmsPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for SmsPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:08:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsPreComp.hpp Source File

Applications/Ems/Sms/SmsPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 //lint -library
00009 //lint -esymb(416,text)
00010 #if !defined(APOXI_SMS_NEW_PROVIDERS)
00011     #error define SYSTEM_DEFS = APOXI_SMS_NEW_PROVIDERS.
00012 #endif
00013 #include <Kernel/Lib.hpp>
00014 #include <Gui/Lib.hpp>
00015 #include <Auxiliary/Lib.hpp>
00016 #include <Adc/Lib.hpp>
00017 #include <Apc/Lib.hpp>
00018 #include <Asc/Lib.hpp>
00019
00020 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSendingConfirmDialog.cpp File Reference

Applications/Ems/Sms/SmsSendingConfirmDialog.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsSendingConfirmDialog.hpp"
#include <Kernel/Os/TestWriter.hpp>

Include dependency graph for SmsSendingConfirmDialog.cpp:

Generated on Wed Jan 25 00:08:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSendingConfirmDialog.hpp File Reference

Applications/Ems/Sms/SmsSendingConfirmDialog.hpp File Reference

#include <Common/MmiDialog.hpp>

Include dependency graph for SmsSendingConfirmDialog.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsSendingConfirmDialog

Defines

#define | Mmi_SmsSendingConfirmDialog_hpp

Define Documentation

#define Mmi_SmsSendingConfirmDialog_hpp

Generated on Wed Jan 25 00:08:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSendingConfirmDialog.hpp Source File

Applications/Ems/Sms/SmsSendingConfirmDialog.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsSendingConfirmDialog_hpp)
00010 #define Mmi_SmsSendingConfirmDialog_hpp
00013
00014 #include <Common/MmiDialog.hpp>
00015
00018 class SmsSendingConfirmDialog : public MmiDialog {
00019     typedef MmiDialog Base;
00020
00021     public:
00023         SmsSendingConfirmDialog();
00025         ~SmsSendingConfirmDialog();
00027         void Init();
00029         void SetAddressText(const WString& text)            { m_address = text; }
00031         void SetTelematicDeviceText(const WString& text)    { m_device = text; }
00033         void SetValidityPeriod(const ValidityPeriod& vp);
00035         void SetSegmentCount(INT segment_count);
00036
00037     protected:
00039         void OnOpen();
00040
00041     private:
00043         SmsSendingConfirmDialog(const SmsSendingConfirmDialog& cds);
00045         SmsSendingConfirmDialog& operator=(const SmsSendingConfirmDialog& cds);
00047         WString m_address;
00049         WString m_device;
00051         WString m_period;
00053         WString m_segment_info;
00055         WString m_text;
00057         MultiLineEditor m_text_area;
00058 };
00059
00061 #endif  // Mmi_SmsSendingConfirmDialog_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsService.cpp File Reference

Applications/Ems/Sms/SmsService.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Gui/EditorDocument.hpp>
#include "AbstractSmsApp.hpp"
#include "SmsService.hpp"

Include dependency graph for SmsService.cpp:

Generated on Wed Jan 25 00:09:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsService.hpp File Reference

Applications/Ems/Sms/SmsService.hpp File Reference

#include <Common/MmiServices.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Sms/SmsMsgTypes.hpp>

Include dependency graph for SmsService.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BasicSmsService

Defines

#define | Mmi_SmsService_hpp

Define Documentation

#define Mmi_SmsService_hpp

Generated on Wed Jan 25 00:09:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsService.hpp Source File

Applications/Ems/Sms/SmsService.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsService_hpp)
00010 #define Mmi_SmsService_hpp
00013
00014 #include <Common/MmiServices.hpp>
00015 #include <Common/CommonMsgTypes.hpp>
00016 #include <Common/MmiServices.hpp>
00017 #include <Sms/SmsMsgTypes.hpp>
00018
00019 class AbstractSmsApp;
00020
00021 class BasicSmsService : public SmsService {
00022     typedef SmsService Base;
00023     public:
00024         BasicSmsService(AbstractSmsApp* implementing_app);
00025         virtual ~BasicSmsService();
00026
00027         virtual ServiceResult ComposeSms(const WString* text = 0, const PhoneNumber* destination = 0) const;
00028         virtual ServiceResult ComposeSms(const PhoneNumber* destination = 0) const;
00029         virtual ServiceResult ComposeSms(const EditorDocumentObtainer& obtainer, const PhoneNumber* destination = 0) const;
00030
00031         virtual ServiceResult StoreSms(const WString* text, const PhoneNumber* destination = 0) const;
00032         virtual ServiceResult StoreSms(const EditorDocumentObtainer& obtainer, const PhoneNumber* destination = 0) const;
00033
00034         virtual ServiceResult SendSms(const WString* text, const PhoneNumber* destination = 0) const;
00035         virtual ServiceResult SendSms(const EditorDocumentObtainer& obtainer, const PhoneNumber* destination = 0) const;
00036
00037     private:
00038         ServiceResult SendMessage(INT type, const WString* text, const PhoneNumber* destination) const;
00039         ServiceResult SendMessage(INT type, const EditorDocumentObtainer& obtainer, const PhoneNumber* destination) const;
00040         AbstractSmsApp* m_app;
00041
00042 };
00043
00045 #endif // Mmi_SmsService_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSettingsProvider.cpp File Reference

Applications/Ems/Sms/SmsSettingsProvider.cpp File Reference

#include "Sms/SmsPreComp.hpp"
#include "SmsSettingsProvider.hpp"
#include <Afs/Rfs/RootFileSystem.hpp>

Include dependency graph for SmsSettingsProvider.cpp:

Generated on Wed Jan 25 00:09:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSettingsProvider.hpp File Reference

Applications/Ems/Sms/SmsSettingsProvider.hpp File Reference

#include <AddOns/AdcExtensions/RecordHandler.hpp>
#include <Common/SettingsProvider.hpp>
#include <Config/Config.hpp>
#include <Sms/SmsSettingsRecord.hpp>

Include dependency graph for SmsSettingsProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsSettingsProvider

Defines

#define | Mmi_SmsSettingsProvider_hpp

Define Documentation

#define Mmi_SmsSettingsProvider_hpp

Generated on Wed Jan 25 00:09:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSettingsProvider.hpp Source File

Applications/Ems/Sms/SmsSettingsProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsSettingsProvider_hpp)
00010 #define Mmi_SmsSettingsProvider_hpp
00013
00014 #include <AddOns/AdcExtensions/RecordHandler.hpp>
00015 // ************************************************
00016 // CN200002234
00017 // Edited/Fixed by Christoph Minkwitz
00018 #include <Common/SettingsProvider.hpp>
00019 #include <Config/Config.hpp>
00020 #include <Sms/SmsSettingsRecord.hpp>
00021
00051 class SmsSettingsProvider : public SettingsProvider{
00052     typedef SettingsProvider Base;
00053
00054     public:
00055
00057         SmsSettingsProvider();
00058
00060         virtual ~SmsSettingsProvider();
00061
00064         void Init();
00065
00068         virtual INT GetProviderId() const;
00069
00071         virtual INT MaxRowCount();
00072
00074         virtual void RestoreFactorySettings();
00075
00078         virtual INT RowCount();
00079
00086         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00087
00093         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00094
00098         virtual BOOLEAN SelectRow(INT row);
00099
00105         virtual BOOLEAN Update(ProviderListener * listener = 0);
00106
00110         virtual BOOLEAN CommitRow(INT row);
00111
00112     private:
00113         SmsSettingsRecord   m_record;           // SMS provider settings read from FFS will by stored here.
00114         SmsSettingsRecord   m_buffer_record;    // SMS provider settings changed by the user will be stored here.
00115         RecordHandler       m_handler;          // Record Handler to read and write data
00116 };
00117
00119 #endif // Mmi_SmsSettingsProvider_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSettingsRecord.cpp File Reference

Applications/Ems/Sms/SmsSettingsRecord.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsSettingsRecord.hpp"
#include <Config/FactorySettingsConfig.hpp>

Include dependency graph for SmsSettingsRecord.cpp:

Functions

OutputStream & | operator<< (OutputStream &ostr, const SmsSettingsRecord &val)
InputStream & | operator>> (InputStream &istr, SmsSettingsRecord &val)

Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const SmsSettingsRecord & | val
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | SmsSettingsRecord & | val
 | ) |

Generated on Wed Jan 25 00:09:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSettingsRecord.hpp File Reference

Applications/Ems/Sms/SmsSettingsRecord.hpp File Reference

#include <AddOns/AdcExtensions/Record.hpp>

Include dependency graph for SmsSettingsRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsSettingsRecord
struct | SmsSettingsRecord::Persist

Defines

#define | Mmi_SmsSettingsRecord_hpp

Typedefs

typedef SmsSettingsRecord::Box | SmsBox

Define Documentation

#define Mmi_SmsSettingsRecord_hpp

Generated on Wed Jan 25 00:09:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsSettingsRecord.hpp Source File

Applications/Ems/Sms/SmsSettingsRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsSettingsRecord_hpp)
00010 #define Mmi_SmsSettingsRecord_hpp
00013
00014 #include <AddOns/AdcExtensions/Record.hpp>
00015
00018 class SmsSettingsRecord : public Record {
00019     typedef Record Base;
00020
00021     public:
00022         enum Box {
00023             Inbox,
00024             Outbox,
00025             Archive,
00026             StatusReport
00027         };
00028
00030         SmsSettingsRecord();
00031
00033         void        SetDefault();
00034
00038         void        SetReplyPathRequested(BOOLEAN flag)         { m_data.flags.reply_path = flag; }
00039
00043         BOOLEAN     IsReplyPathRequested() const                { return m_data.flags.reply_path; }
00044
00048         void        SetStatusReportEnabled(BOOLEAN flag)        { m_data.flags.status_report = flag; }
00049
00053         BOOLEAN     IsStatusReportEnabled() const               { return m_data.flags.status_report; }
00054
00058         void        SetStatusReportOnIdleScreen(BOOLEAN flag)   { m_data.flags.statrep_on_idlescreen = flag; }
00059
00063         BOOLEAN     IsStatusReportOnIdleScreen() const          { return m_data.flags.status_report && m_data.flags.statrep_on_idlescreen; }
00064
00068         void        SetGsmService(GsmService service)           { m_data.gsm_service = service; }
00069
00072         GsmService  GetGsmService() const                       { return (GsmService)m_data.gsm_service; }
00073
00077         void        SetSendingConfirmationEnabled(BOOLEAN flag) { m_data.flags.sending_confirmation = flag; }
00078
00082         BOOLEAN     IsSendingConfirmationEnabled() const        { return m_data.flags.sending_confirmation; }
00083
00087         void        SetAutoStoreEnabled(BOOLEAN flag)           { m_data.flags.autostore = flag; }
00088
00092         BOOLEAN     IsAutoStorageEnabled() const                { return m_data.flags.autostore; }
00093
00097         void        SetSendPreviewMandatory(BOOLEAN flag)       { m_data.flags.preview_mandatory = flag; }
00098
00102         BOOLEAN     IsSendPreviewMandatory() const              { return m_data.flags.preview_mandatory; }
00103
00107         void        SetLine2VoiceBoxNumber(const PhoneNumber& number){ number >> m_data.line2_voicebox_number; }
00108
00111         PhoneNumber GetLine2VoiceBoxNumber() const;
00112
00116         void        SetVoiceBoxNumber(const PhoneNumber& number){ number >> m_data.voicebox_number; }
00117
00120         PhoneNumber GetVoiceBoxNumber() const;
00121
00127         void        SetSorting(Box box, INT colid, BOOLEAN ascending = TRUE);
00128
00132         INT         GetSortingColumnId(Box box) const;
00133
00137         BOOLEAN     IsAscendingOrder(Box box) const;
00138
00141         void        SetDefaultProfile(UINT8 profile) { m_data.profile = profile; }
00142
00145         UINT8       GetDefaultProfile() { return m_data.profile; }
00146
00149         void        SetStorageLocation(UINT8 storage_location) { m_data.storage_location = storage_location; }
00150
00153         UINT8       GetStorageLocation() { return m_data.storage_location; }
00154
00158         void        SetPredInputEnabled(BOOLEAN flag)           { m_data.flags.pred_input = flag; }
00159
00163         BOOLEAN     IsPredInputEnabled() const              { return m_data.flags.pred_input; }
00164
00165         // SMS settings data field definition
00166         struct Persist {
00167             struct {
00168                 BOOLEAN sending_confirmation    : 2;    // true, confirmation dialog should be displayed before sending
00169                 BOOLEAN reply_path              : 2;    // true, if reply path is requested
00170                 BOOLEAN status_report           : 2;    // enables or disables receiving status reports
00171                 BOOLEAN statrep_on_idlescreen   : 2;    // true, if status reports should be displayed immediately on idle screen
00172                 BOOLEAN autostore               : 2;    // true, if all sent SMS should be stored automatically
00173                 BOOLEAN preview_mandatory       : 2;    // true, if all SMS sent by a service should be displayed before sending
00174                 BOOLEAN inbox_ascending_order   : 2;    // true, if inbox sort order is ascending
00175                 BOOLEAN outbox_ascending_order  : 2;    // true, if outbox sort order is ascending
00176                 BOOLEAN archive_ascending_order : 2;    // true, if archive sort order is ascending
00177                 BOOLEAN statrep_ascending_order : 2;    // true, if status report sort order is ascending
00178                 BOOLEAN pred_input              : 2;    // true, if pred input is enabled
00179             } flags;
00180             UINT8       profile;
00181             UINT8       storage_location;
00182             INT8        gsm_service;
00183             INT         inbox_sorting_colid;
00184             INT         outbox_sorting_colid;
00185             INT         archive_sorting_colid;
00186             INT         statrep_sorting_colid;
00187             PhoneNumber::Persist    voicebox_number;
00188             PhoneNumber::Persist    line2_voicebox_number;
00189         } m_data;
00190
00193         virtual const UINT8* GetData();
00194
00197         virtual void SetData(const UINT8* data);
00198
00201         virtual INT GetPersistentSize();
00202
00204         virtual void MarkDeleted();
00205
00207         virtual BOOLEAN IsRecordDeleted();
00208
00209         #ifndef APOXI_NOSTREAMING
00210             friend InputStream& operator >>(InputStream &istr, SmsSettingsRecord &tpdu);
00211             friend OutputStream& operator <<(OutputStream &ostr, const SmsSettingsRecord &tpdu);
00212         #endif
00213 };
00214
00215 typedef SmsSettingsRecord::Box SmsBox;
00216
00218 #endif  // Mmi_SmsSettingsRecord_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTemplateProvider.cpp File Reference

Applications/Ems/Sms/SmsTemplateProvider.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsTextMaps.hpp"
#include "SmsTemplateProvider.hpp"
#include <Config/Resources/sms_unread_icon.hpp>
#include <GuiExtensions/ImgObtObj.hpp>

Include dependency graph for SmsTemplateProvider.cpp:

Generated on Wed Jan 25 00:10:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTemplateProvider.hpp File Reference

Applications/Ems/Sms/SmsTemplateProvider.hpp File Reference

#include <Config/Config.hpp>

Include dependency graph for SmsTemplateProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsTemplateProvider

Defines

#define | Mmi_SmsTemplateProvider_hpp

Define Documentation

#define Mmi_SmsTemplateProvider_hpp

Generated on Wed Jan 25 00:10:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTemplateProvider.hpp Source File

Applications/Ems/Sms/SmsTemplateProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsTemplateProvider_hpp)
00010 #define Mmi_SmsTemplateProvider_hpp
00013
00014 #include <Config/Config.hpp>
00015
00032 class SmsTemplateProvider : public Provider
00033 {
00034     typedef Provider Base;
00035
00036     public:
00037         SmsTemplateProvider();
00038         virtual ~SmsTemplateProvider();
00039
00040         void Init();
00041
00042         virtual INT GetProviderId() const;
00043
00045         virtual INT RowCount();
00046
00048         virtual BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00049
00050 };
00051
00053 #endif  // Mmi_SmsTemplateProvider_hpp
Generated on Tue Jan 24 14:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTextMaps.cpp File Reference

Applications/Ems/Sms/SmsTextMaps.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsTextMaps.hpp"

Include dependency graph for SmsTextMaps.cpp:

Generated on Wed Jan 25 00:10:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTextMaps.hpp File Reference

Applications/Ems/Sms/SmsTextMaps.hpp File Reference

#include <Common/EnumTextMap.hpp>

Include dependency graph for SmsTextMaps.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsConcatStatusTextMap
Sms concatenation status. More...
class | SmsGsmServiceTextMap
Sms service names. More...
class | SmsMsgTypeTextMap
Sms message types. More...
class | SmsMsgTypeUsageTextMap
Sms message type usage. More...
class | SmsResultTextMap
Sms result texts. More...
class | SmsStatusReportTextMap
Status report state and reson texts. More...
class | SmsStatusTextMap
Sms status. More...
class | SmsStorageTypeTextMap
Sms storage types. More...
class | SmsTelematicDeviceNameTable
Telematice device names. More...
class | SmsTemplateTextMap
Sms templates. More...

Defines

#define | Mmi_SmsTextMaps_hpp

Define Documentation

#define Mmi_SmsTextMaps_hpp

Generated on Wed Jan 25 00:10:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTextMaps.hpp Source File

Applications/Ems/Sms/SmsTextMaps.hpp

Go to the documentation of this file.
00001 /* ------------------------------------------------------------------------
00002    Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003    ------------------------------------------------------------------------
00004    This document contains proprietary information belonging to COMNEON.
00005    Passing on and copying of this document, use and communication of its
00006    contents is not permitted without prior written authorisation.
00007    ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsTextMaps_hpp)
00010 #define Mmi_SmsTextMaps_hpp
00013
00014 #include <Common/EnumTextMap.hpp>
00015
00017 class SmsTelematicDeviceNameTable : public EnumTextMap
00018 {
00019     typedef EnumTextMap Base;
00020
00021     public:
00022         static const WCHAR* GetDeviceName(ProtocolIdentifier::TelematicDevice device) {
00023             return Base::GetText(m_devices, m_devices_size, device); }
00024
00025     private:
00026         static const UINT m_devices_size;
00027         static const EnumTextTableEntry m_devices[];
00028 };
00029
00031 class SmsResultTextMap : public EnumTextMap
00032 {
00033     typedef EnumTextMap Base;
00034
00035     public:
00036         static const WCHAR* GetResult(Sms::Result result) { return Base::GetText(m_results, m_results_size, (INT)result); }
00037
00038     private:
00039         static const UINT m_results_size;
00040         static const EnumTextTableEntry m_results[];
00041 };
00042
00044 class SmsStatusReportTextMap : public EnumTextMap
00045 {
00046     typedef EnumTextMap Base;
00047
00048     public:
00049         static const WCHAR* GetStatus(ShortMessageStatus::Status state) { return Base::GetText(m_states, m_states_size, (INT)state); }
00050         static const WCHAR* GetReason(ShortMessageStatus::Reason reason) { return Base::GetText(m_reasons, m_reasons_size, (INT)reason); }
00051
00052     private:
00053         static const UINT m_states_size;
00054         static const UINT m_reasons_size;
00055         static const EnumTextTableEntry m_states[];
00056         static const EnumTextTableEntry m_reasons[];
00057
00058 };
00059
00061 class SmsTemplateTextMap : public EnumTextMap
00062 {
00063     typedef EnumTextMap Base;
00064
00065     public:
00066         static const WCHAR* GetTemplateTitle(INT index) { return Base::GetText(m_template_titles, m_template_count, index); }
00067         static const WCHAR* GetTemplateText(INT index) { return Base::GetText(m_templates, m_template_count, index); }
00068         static UINT GetTemplateCount() { return m_template_count; }
00069
00070     private:
00071         static const UINT m_template_count;
00072         static const EnumTextTableEntry m_templates[];
00073         static const EnumTextTableEntry m_template_titles[];
00074 };
00075
00077 class SmsStorageTypeTextMap : public EnumTextMap
00078 {
00079     typedef EnumTextMap Base;
00080
00081     public:
00082         static const WCHAR* GetStorageTypeName(INT index) { return Base::GetText(m_storage_types, m_storage_type_count, index); }
00083         static UINT GetStorageTypeCount() { return m_storage_type_count; }
00084
00085     private:
00086         static const UINT m_storage_type_count;
00087         static const EnumTextTableEntry m_storage_types[];
00088 };
00089
00091 class SmsGsmServiceTextMap : public EnumTextMap
00092 {
00093     typedef EnumTextMap Base;
00094
00095     public:
00096         static const WCHAR* GetGsmServiceName(INT index) { return Base::GetText(m_gsm_services, m_gsm_service_count, index); }
00097         static UINT GetGsmServiceCount() { return m_gsm_service_count; }
00098
00099     private:
00100         static const UINT m_gsm_service_count;
00101         static const EnumTextTableEntry m_gsm_services[];
00102 };
00103
00105 class SmsMsgTypeTextMap : public EnumTextMap
00106 {
00107     typedef EnumTextMap Base;
00108
00109     public:
00110         static const WCHAR* GetMsgTypeName(INT index) { return Base::GetText(m_msg_types, m_msg_type_count, index); }
00111         static UINT GetMsgTypeCount() { return m_msg_type_count; }
00112
00113     private:
00114         static const UINT m_msg_type_count;
00115         static const EnumTextTableEntry m_msg_types[];
00116 };
00117
00119 class SmsMsgTypeUsageTextMap : public EnumTextMap
00120 {
00121     typedef EnumTextMap Base;
00122
00123     public:
00124         static const WCHAR* GetMsgTypeUsageName(INT index) { return Base::GetText(m_msg_type_usages, m_msg_type_usage_count, index); }
00125         static UINT GetMsgTypeUsageCount() { return m_msg_type_usage_count; }
00126
00127     private:
00128         static const UINT m_msg_type_usage_count;
00129         static const EnumTextTableEntry m_msg_type_usages[];
00130 };
00131
00133 class SmsStatusTextMap : public EnumTextMap
00134 {
00135     typedef EnumTextMap Base;
00136
00137     public:
00138         static const WCHAR* GetStatusName(INT index) { return Base::GetText(m_stati, m_status_count, index); }
00139         static UINT GetStatusCount() { return m_status_count; }
00140
00141     private:
00142         static const UINT m_status_count;
00143         static const EnumTextTableEntry m_stati[];
00144 };
00145
00147 class SmsConcatStatusTextMap : public EnumTextMap
00148 {
00149     typedef EnumTextMap Base;
00150
00151     public:
00152         static const WCHAR* GetStatusName(INT index) { return Base::GetText(m_stati, m_status_count, index); }
00153         static UINT GetStatusCount() { return m_status_count; }
00154
00155     private:
00156         static const UINT m_status_count;
00157         static const EnumTextTableEntry m_stati[];
00158 };
00159
00161 #endif  //Mmi_SmsTextMaps_hpp
00162
Generated on Tue Jan 24 14:52:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTextParser.cpp File Reference

Applications/Ems/Sms/SmsTextParser.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsTextParser.hpp"

Include dependency graph for SmsTextParser.cpp:

Generated on Wed Jan 25 00:10:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTextParser.hpp File Reference

Applications/Ems/Sms/SmsTextParser.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | SmsTextEntry
class | SmsTextParser
struct | SmsTextParser::SmsTextItemAttributes

Defines

#define | Mmi_SmsTextParser_hpp

Enumerations

enum | SmsTextItemType { SmsTextItemType_PhoneNumber, SmsTextItemType_Url, SmsTextItemType_Email }

Define Documentation

#define Mmi_SmsTextParser_hpp

Generated on Wed Jan 25 00:10:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsTextParser.hpp Source File

Applications/Ems/Sms/SmsTextParser.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsTextParser_hpp)
00010 #define Mmi_SmsTextParser_hpp
00013
00014 enum SmsTextItemType {
00015     SmsTextItemType_PhoneNumber,
00016     SmsTextItemType_Url,
00017     SmsTextItemType_Email
00018 };
00019
00020 struct SmsTextEntry {
00021     INT         idxPos;
00022     SmsTextItemType type;
00023     WString         text;
00024 };
00025
00026 class SmsTextParser {
00027     struct SmsTextItemAttributes {
00028         INT phoneNrType;
00029         INT colonPos;
00030         INT firstSlashPos;
00031         INT secondSlashPos;
00032         INT atPos;
00033         INT firstPeriodPos;
00034         INT secondPeriodPos;
00035         INT lastPeriodPos;
00036     };
00037
00038     public:
00039
00040         virtual ~SmsTextParser();
00042         void Scan(const WString& text);
00043
00045         INT GetItemCount() const;
00046
00048         const SmsTextEntry& GetItem(const INT index) const;
00049     private:
00051         void SkipSpaces();
00052
00054         void ParseWordAndFillTextItemAttributes();
00055
00057         void GenerateTextEntryBasedOnTextItemAttributes();
00058
00059         const WString* m_pSmsText;
00060         INT m_textPosition;
00061         WString m_currentWord;
00062         INT m_wordPosition;
00063         SmsTextItemAttributes m_textItemAttrib;
00064         Vector<SmsTextEntry> m_textEntries;
00065 };
00066
00068 #endif  // Mmi_SmsTextParser_hpp
Generated on Tue Jan 24 14:52:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsUtility.cpp File Reference

Applications/Ems/Sms/SmsUtility.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include <Gui/TextEditorDocument.hpp>
#include "SmsUtility.hpp"
#include <Sms/AbstractSmsUtiltyProcessor.hpp>
#include "SmsApp.hpp"

Include dependency graph for SmsUtility.cpp:

Generated on Wed Jan 25 00:10:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsUtility.hpp File Reference

Applications/Ems/Sms/SmsUtility.hpp File Reference

#include <Sms/AbstractSmsApp.hpp>
#include <Sms/SmsComposeWin.hpp>
#include <Sms/SmsViewerWin.hpp>
#include <Sms/AbstractSmsUtiltyProcessor.hpp>

Include dependency graph for SmsUtility.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsUtility

Defines

#define | Mmi_SmsUtility_hpp

Define Documentation

#define Mmi_SmsUtility_hpp

Generated on Wed Jan 25 00:11:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsUtility.hpp Source File

Applications/Ems/Sms/SmsUtility.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsUtility_hpp)
00010 #define Mmi_SmsUtility_hpp
00013
00014 #include <Sms/AbstractSmsApp.hpp>
00015 #include <Sms/SmsComposeWin.hpp>
00016 #include <Sms/SmsViewerWin.hpp>
00017 #include <Sms/AbstractSmsUtiltyProcessor.hpp>
00021 class SmsUtility : public AbstractSmsUtilityProcessor {
00022     typedef AbstractSmsUtilityProcessor Base;
00023
00024     public:
00026         SmsUtility();
00027         static SmsUtility* GetInstance();
00029         ~SmsUtility();
00032         void SendImpl(const SmsContext& profile, const EditorDocumentObtainer& obtainer);
00034         AbstractSmsComposeWin* GetSmsComposer() { return &m_compose_win; }
00035         void Init();
00036     private:
00038         //void OnOpen();
00039
00041         AbstractSmsViewerWin* GetSmsViewer() {return &m_viewer_win;}
00043         SmsFactory* GetSmsFactory() { return &m_sms_factory; }
00044
00047         void StoreImpl(const SmsContext& profile, const EditorDocumentObtainer& obtainer);
00048
00050         void OnExportConfirmation(AbstractSmsApp::SmsExportType export_type, Sms::Result result_code, const SmsContext& profile, INT pending_segment_count = 0);
00052         void RelaySms(Provider* provider, INT act_row, BOOLEAN reply);
00053
00055         //void SendToManyRecipient(SmsContext *profile,INT nCnt, const EditorDocumentObtainer& obtainer);
00056
00058
00060         void CreateBodyText(const EditorDocumentObtainer& obtainer);
00061
00063         static SmsUtility m_app;
00065         static SmsFactory           m_sms_factory;
00067         static SmsComposeWin        m_compose_win;
00069         static SmsViewerWin         m_viewer_win;
00071         WString                     m_sms_body;
00072
00074         AbstractSmsApp              *p_app;
00075
00076 };
00077
00079 #endif  // Mmi_SmsUtility_hpp
Generated on Tue Jan 24 14:52:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsViewerWin.cpp File Reference

Applications/Ems/Sms/SmsViewerWin.cpp File Reference

#include <Sms/SmsPreComp.hpp>
#include "SmsApp.hpp"
#include "SmsViewerWin.hpp"
#include <Config/Resources/confirm_icon.hpp>
#include <Config/Resources/cancel_icon.hpp>
#include <Config/FontConfig.hpp>
#include <AddOns/Services/ServiceBroker.hpp>

Include dependency graph for SmsViewerWin.cpp:

Generated on Wed Jan 25 00:11:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsViewerWin.hpp File Reference

Applications/Ems/Sms/SmsViewerWin.hpp File Reference

#include <Sms/AbstractSmsViewerWin.hpp>
#include <Gui/ImageBox.hpp>
#include <Sms/SmsTextParser.hpp>

Include dependency graph for SmsViewerWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SmsViewerWin

Defines

#define | Mmi_SmsViewerWin_hpp

Define Documentation

#define Mmi_SmsViewerWin_hpp

Generated on Wed Jan 25 00:11:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Ems/Sms/SmsViewerWin.hpp Source File

Applications/Ems/Sms/SmsViewerWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SmsViewerWin_hpp)
00010 #define Mmi_SmsViewerWin_hpp
00013
00014 #include <Sms/AbstractSmsViewerWin.hpp>
00015 #include <Gui/ImageBox.hpp>
00016 #include <Sms/SmsTextParser.hpp>
00017
00018 class SmsApp;
00019
00022 class SmsViewerWin : public AbstractSmsViewerWin {
00023     typedef AbstractSmsViewerWin Base;
00024
00025     public:
00027         SmsViewerWin();
00029         void Init(SmsApp* sms_app);
00031         virtual ~SmsViewerWin();
00033         virtual const EditorDocument* GetDocument() const;
00035         virtual void SetDocument(const EditorDocument* doc);
00036
00037         void GoToSmsEmbItems(Direction dir);
00038
00039         SmsTextEntry GetSelectedSmsEmbItem();
00040
00041         virtual void OnGetFocus();
00042
00043     protected:
00045         virtual void OnDisplaySms(Provider* provider, INT row, INT set_index = -1);
00046
00048         virtual void OnLayoutClient();
00049
00050     private:
00052         SmsViewerWin(const SmsViewerWin &ascw);
00053
00055         SmsViewerWin& operator=(const SmsViewerWin&);
00057         MultiLineEditor     m_text_area;
00059         WString             m_message;
00061         SmsTextParser   m_parser;
00063         INT             m_parsed_item_idx;
00064
00065         WString         m_ph_no;
00066         INT             m_idx_msg_txt;
00067         PhoneNumber     m_from_to_ph_no;
00068
00071         ImageBox            m_conc_display;
00072
00076         INT m_row_to_set;
00077
00081         INT m_current_row;
00083         INT m_set_index;
00084 };
00085
00087 #endif // Mmi_SmsViewerWin_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioApplication.cpp File Reference

Applications/FmRadio/FmRadioApplication.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include <GuiExtensions/MmiAlert.hpp>
#include <Common/MmiServices.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/Services/Service.hpp>
#include <Asc/PreComp.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <Devices/ChargerMsgTypes.hpp>
#include <Apc/Accessory.hpp>
#include <Devices/AudioDeviceManager.hpp>
#include <Devices/AudioPathManager.hpp>
#include <Kernel/VersionInfo.hpp>
#include <Gui/Panel.hpp>
#include <Audio/Messages/AudioMessages.hpp>
#include "FmRadioApplication.hpp"

Include dependency graph for FmRadioApplication.cpp:

Functions

ApoxiUseVersionInfo (FmRadio)

Function Documentation

ApoxiUseVersionInfo ( FmRadio )

Generated on Wed Jan 25 00:11:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioApplication.hpp File Reference

Applications/FmRadio/FmRadioApplication.hpp File Reference

#include <Common/MmiApplication.hpp>
#include "FmRadioWindow.hpp"
#include "FmRadioSettingsProvider.hpp"
#include "FmRadioStationsProvider.hpp"
#include "FmRadioSelectStrongerFreq.hpp"
#include "FmRadioEditWin.hpp"
#include <Common/Properties/Descriptors/SetPropertyDescriptor.hpp>

Include dependency graph for FmRadioApplication.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FmRadioApplication

Defines

#define | Mmi_FmRadioApp_hpp

Define Documentation

#define Mmi_FmRadioApp_hpp

Generated on Wed Jan 25 00:11:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioApplication.hpp Source File

Applications/FmRadio/FmRadioApplication.hpp

Go to the documentation of this file.
00001 #if !defined(Mmi_FmRadioApp_hpp)
00002 #define Mmi_FmRadioApp_hpp
00003
00004 #include <Common/MmiApplication.hpp>
00005 #include "FmRadioWindow.hpp"
00006
00007 #include "FmRadioSettingsProvider.hpp"
00008 #include "FmRadioStationsProvider.hpp"
00009 #include "FmRadioSelectStrongerFreq.hpp"
00010 #include "FmRadioEditWin.hpp"
00011
00012 #include <Common/Properties/Descriptors/SetPropertyDescriptor.hpp>
00013
00014 class FmRadioApplication : public MmiApplication
00015 {
00016     typedef MmiApplication Base;
00017
00018 public:
00019         typedef enum
00020         {
00021             RadioFmOff,
00022             RadioFmOn,
00023             RadioFmOnMinimized,
00024             RadioFmToRestart
00025         }RadioFmState;
00026
00027     virtual ~FmRadioApplication();
00028     static FmRadioApplication* GetInstance();
00029         RadioFmState GetRadioOn(void){ return m_fmradio_state; }
00030         void SetRadioOn(RadioFmState State){ m_fmradio_state = State; }
00031         void CloseMinimizedRadio(void){ m_fmradio_state = RadioFmToRestart; m_fmradio_win.Close(); }
00032         //RadioAudioDevice* GetRadioDevice(void){ return m_device_radio; }
00033
00034         FmRadioSettingsProvider * GetFmRadioSettingsProv(void){ return &m_fmradio_settings_prov; }
00035         FmRadioStationsProvider * GetFmRadioStationsProv(void){ return &m_fmradio_stations_prov; }
00036         FmRadioWindow * GetFmRadioWin(void) { return &m_fmradio_win; }
00037
00038 protected:
00039         virtual void OnStartup();
00040     virtual void OnOpen();
00041     virtual void OnClose();
00042     virtual BOOLEAN OnMessage(const Message &msg);
00043         virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00044
00045         virtual BOOLEAN OnPropertyNotification(const Property::Notification notification,
00046                                                 const Property* property,
00047                                                 const DataItem& value);
00048
00049 private:
00050         enum FeatureItemIds {
00051                 FmRadio,
00052                 FmRadioIdle,
00053                 MinimizeFeature,
00054                 MuteFeature,
00055                 UnmuteFeature,
00056                 SkMuteFeature,
00057                 SkUnmuteFeature,
00058                 MonoFeature,
00059                 StereoFeature,
00060                 ListSavedFeature,
00061                 EditFreqFeature,
00062                 CloseFeature,
00063                 FmRadioFeatureCnt
00064             };
00065
00066     FmRadioApplication();
00067
00068         Feature                     m_items[FmRadioFeatureCnt];
00069
00070     static FmRadioApplication m_app;
00071         RadioFmState                m_fmradio_state;
00072         //RadioAudioDevice *            m_device_radio;
00073         FmRadioWindow               m_fmradio_win;
00074
00075         FmRadioSettingsProvider     m_fmradio_settings_prov;
00076         FmRadioStationsProvider     m_fmradio_stations_prov;
00077         FmRadioSelectStrongerFreq   m_fmradio_freq_list_win;
00078         FmRadioEditWin              m_fmradio_edit_win;
00079
00080         Property                    m_set_level_property;
00081         Property                    m_set_band_property;
00082         SetPropertyDescriptor       m_set_level_descriptor;
00083         SetPropertyDescriptor       m_set_band_descriptor;
00084         Property                    m_radio_prop;
00085 };
00086
00087 #endif // Mmi_FmRadioApp_hpp
00088
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioApplicationPreComp.cpp File Reference

Applications/FmRadio/FmRadioApplicationPreComp.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"

Include dependency graph for FmRadioApplicationPreComp.cpp:

Generated on Wed Jan 25 00:11:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioApplicationPreComp.hpp File Reference

Applications/FmRadio/FmRadioApplicationPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>

Include dependency graph for FmRadioApplicationPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:12:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioApplicationPreComp.hpp Source File

Applications/FmRadio/FmRadioApplicationPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioEditWin.cpp File Reference

Applications/FmRadio/FmRadioEditWin.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include "FmRadioEditWin.hpp"
#include "FmRadioApplication.hpp"

Include dependency graph for FmRadioEditWin.cpp:

Generated on Wed Jan 25 00:12:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioEditWin.hpp File Reference

Applications/FmRadio/FmRadioEditWin.hpp File Reference

#include <Common/MmiWindow.hpp>

Include dependency graph for FmRadioEditWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FmRadioEditWin

Defines

#define | FmRadioEditWin_hpp

Define Documentation

#define FmRadioEditWin_hpp

Generated on Wed Jan 25 00:12:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioEditWin.hpp Source File

Applications/FmRadio/FmRadioEditWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     -------------------------------------------------------- */
00008 #if !defined(FmRadioEditWin_hpp)
00009 #define FmRadioEditWin_hpp
00010
00011 #include <Common/MmiWindow.hpp>
00012
00013 class FmRadioEditWin : public MmiWindow {
00014     typedef MmiWindow Base;
00015
00016     public:
00017         FmRadioEditWin();
00018         ~FmRadioEditWin();
00019
00020         void Init(INT BandLim);
00021
00022     protected:
00023         BOOLEAN OnCancel();
00024         BOOLEAN OnConfirm();
00025         void OnLayoutClient();
00026
00027     private:
00028 //      RadioAudioDevice::BandLimits m_band_lim;
00029         TextLine            m_phone_no_text;
00030         LineEditor          m_freq_editor;
00031 };
00032
00033 #endif
00034
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSelectStrongerFreq.cpp File Reference

Applications/FmRadio/FmRadioSelectStrongerFreq.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include "FmRadioSelectStrongerFreq.hpp"
#include "FmRadioStationsProvider.hpp"
#include "FmRadioApplication.hpp"

Include dependency graph for FmRadioSelectStrongerFreq.cpp:

Generated on Wed Jan 25 00:12:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSelectStrongerFreq.hpp File Reference

Applications/FmRadio/FmRadioSelectStrongerFreq.hpp File Reference

#include <Atl/Gui/AtlItemListWindow.hpp>
#include <Atl/Features/ProviderProxyContainer.hpp>

Include dependency graph for FmRadioSelectStrongerFreq.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FmRadioSelectStrongerFreq

Defines

#define | FmRadio_SelectStrongerFreq_hpp

Define Documentation

#define FmRadio_SelectStrongerFreq_hpp

Generated on Wed Jan 25 00:12:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSelectStrongerFreq.hpp Source File

Applications/FmRadio/FmRadioSelectStrongerFreq.hpp

Go to the documentation of this file.
00001
00002 #if !defined(FmRadio_SelectStrongerFreq_hpp)
00003 #define FmRadio_SelectStrongerFreq_hpp
00004
00005 #include <Atl/Gui/AtlItemListWindow.hpp>
00006 #include <Atl/Features/ProviderProxyContainer.hpp>
00007
00008 class FmRadioSelectStrongerFreq : public AtlItemListWindow {
00009     typedef AtlItemListWindow Base;
00010
00011     public:
00012         FmRadioSelectStrongerFreq();
00013         ~FmRadioSelectStrongerFreq();
00014         void Init(Provider *fmradio_stat_prov);
00015
00016     protected:
00017         BOOLEAN OnConfirm();
00018
00019         BOOLEAN OnCancel();
00020
00021         void OnOpen();
00022
00023     private:
00024         ProviderProxyContainer  m_fmradio_stat_cont;
00025         NotEqualsRule           m_rule;
00026         FilterProvider          m_fmradio_stat_filtered_prov;
00027 };
00028
00029 #endif  // FmRadio_SelectStrongerFreq_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSettingsProvider.cpp File Reference

Applications/FmRadio/FmRadioSettingsProvider.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include <Afs/Rfs/RootFileSystem.hpp>
#include "FmRadioSettingsProvider.hpp"

Include dependency graph for FmRadioSettingsProvider.cpp:

Generated on Wed Jan 25 00:12:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSettingsProvider.hpp File Reference

Applications/FmRadio/FmRadioSettingsProvider.hpp File Reference

#include <AddOns/AdcExtensions/RecordHandler.hpp>
#include <Common/SettingsProvider.hpp>
#include <Config/Config.hpp>
#include "FmRadioSettingsRecord.hpp"

Include dependency graph for FmRadioSettingsProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FmRadioSettingsProvider

Defines

#define | Mmi_FmRadioSettingsProvider_hpp

Enumerations

enum | FmRadioSettingsColIds { c_radio_last_freq, c_radio_last_volume }

Define Documentation

#define Mmi_FmRadioSettingsProvider_hpp

Enumeration Type Documentation

enum FmRadioSettingsColIds

Provider for settings of the FmRadio application.
Provider ID: c_fmradio_settings_provider_id

The following columns are available:
ID | Type | Description
c_radio_last_freq | NumberType | (INT) Last value of radio frequency.
c_radio_last_volume | NumberType | (INT) Last value of radio volume.

Enumerator:
c_radio_last_freq
c_radio_last_volume

Generated on Wed Jan 25 00:12:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSettingsProvider.hpp Source File

Applications/FmRadio/FmRadioSettingsProvider.hpp

Go to the documentation of this file.
00001
00002 /*  ------------------------------------------------------------------------
00003     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_FmRadioSettingsProvider_hpp)
00011 #define Mmi_FmRadioSettingsProvider_hpp
00012
00013 #include <AddOns/AdcExtensions/RecordHandler.hpp>
00014 #include <Common/SettingsProvider.hpp>
00015 #include <Config/Config.hpp>
00016
00017 #include "FmRadioSettingsRecord.hpp"
00030 enum FmRadioSettingsColIds {
00031
00032     c_radio_last_freq,
00033     c_radio_last_volume
00034 };
00035
00036
00037 class FmRadioSettingsProvider : public SettingsProvider
00038 {
00039     typedef Provider Base;
00040
00041     public:
00042
00043         FmRadioSettingsProvider();
00044         virtual ~FmRadioSettingsProvider();
00046         void Init();
00047
00049         virtual INT GetProviderId() const;
00050
00052         virtual INT MaxRowCount();
00053
00055         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00056
00058         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00059
00061         virtual BOOLEAN SelectRow(INT row = 0);
00062
00064         virtual BOOLEAN CommitRow(INT row = 0);
00065
00067         virtual void RestoreFactorySettings();
00068
00069     private:
00070         FmRadioSettingsRecord   m_record;
00071         FmRadioSettingsRecord   m_commit_record;
00072         RecordHandler           m_handler;
00073 };
00074
00075 #endif // Mmi_FmRadioSettingsProvider_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSettingsRecord.cpp File Reference

Applications/FmRadio/FmRadioSettingsRecord.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include "FmRadioSettingsRecord.hpp"
#include <Config/FactorySettingsConfig.hpp>

Include dependency graph for FmRadioSettingsRecord.cpp:

Generated on Wed Jan 25 00:12:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSettingsRecord.hpp File Reference

Applications/FmRadio/FmRadioSettingsRecord.hpp File Reference

#include <AddOns/AdcExtensions/Record.hpp>

Include dependency graph for FmRadioSettingsRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FmRadioSettingsRecord
struct | FmRadioSettingsRecord::Persist

Defines

#define | Mmi_FmRadioSettingsRecord_hpp

Define Documentation

#define Mmi_FmRadioSettingsRecord_hpp

Generated on Wed Jan 25 00:12:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioSettingsRecord.hpp Source File

Applications/FmRadio/FmRadioSettingsRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Mmi_FmRadioSettingsRecord_hpp)
00011 #define Mmi_FmRadioSettingsRecord_hpp
00012
00013 #include <AddOns/AdcExtensions/Record.hpp>
00014
00015 class FmRadioSettingsRecord : public Record {
00016     typedef Record Base;
00017
00018     public:
00019         FmRadioSettingsRecord( UINT8 radio_last_volume,
00020                                     UINT32 radio_last_freq );
00021
00022         FmRatioSettingsRecord();    //added for restore factory settings
00023         void SetDefault();          //added for restore factory settings
00024
00025         struct Persist {
00026             UINT8 radio_last_volume;
00027             UINT32 radio_last_freq;
00028         } m_data;
00029
00030         virtual const UINT8* GetData();
00031         virtual void SetData(const UINT8* data);
00032         virtual INT GetPersistentSize();
00033
00034         void SetRadioLastVolume(UINT8 radio_last_volume) { m_data.radio_last_volume = radio_last_volume; }
00035         UINT8 GetRadioLastVolume() { return m_data.radio_last_volume; }
00036
00037         void SetRadioLastFreq(UINT32 radio_last_freq) { m_data.radio_last_freq = radio_last_freq; }
00038         UINT32 GetRadioLastFreq() { return m_data.radio_last_freq; }
00039 };
00040
00041 #endif  // Mmi_FmRadioSettingsRecord_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioStationsProvider.cpp File Reference

Applications/FmRadio/FmRadioStationsProvider.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include <Afs/Rfs/RootFileSystem.hpp>
#include "FmRadioStationsProvider.hpp"

Include dependency graph for FmRadioStationsProvider.cpp:

Generated on Wed Jan 25 00:12:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioStationsProvider.hpp File Reference

Applications/FmRadio/FmRadioStationsProvider.hpp File Reference

#include <AddOns/AdcExtensions/RecordHandler.hpp>
#include <Common/SettingsProvider.hpp>
#include <Config/Config.hpp>
#include "FmRadioStationsRecord.hpp"

Include dependency graph for FmRadioStationsProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FmRadioStationsProvider

Defines

#define | Mmi_FmRadioStationsProvider_hpp

Enumerations

enum | FmRadioStationsColIds { c_radio_freq, c_radio_stat_text }

Define Documentation

#define Mmi_FmRadioStationsProvider_hpp

Enumeration Type Documentation

enum FmRadioStationsColIds

Provider for stations of the fmRadio application.
Provider ID: c_fmradio_stations_provider_id

The following columns are available:
ID | Type | Description
c_radio_freq | NumberType | (INT) FmRadio frequency.
c_radio_stat_text | WStringType | (WString) FmRadio station/frequency formatted text.

Enumerator:
c_radio_freq
c_radio_stat_text

Generated on Wed Jan 25 00:12:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioStationsProvider.hpp Source File

Applications/FmRadio/FmRadioStationsProvider.hpp

Go to the documentation of this file.
00001
00002 /*  ------------------------------------------------------------------------
00003     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_FmRadioStationsProvider_hpp)
00011 #define Mmi_FmRadioStationsProvider_hpp
00012
00013 #include <AddOns/AdcExtensions/RecordHandler.hpp>
00014 #include <Common/SettingsProvider.hpp>
00015 #include <Config/Config.hpp>
00016
00017 #include "FmRadioStationsRecord.hpp"
00031 enum FmRadioStationsColIds {
00032
00033     c_radio_freq,
00034     c_radio_stat_text
00035 };
00036
00037
00038 class FmRadioStationsProvider : public SettingsProvider
00039 {
00040     typedef Provider Base;
00041
00042     public:
00043
00044         FmRadioStationsProvider();
00045         virtual ~FmRadioStationsProvider();
00047         void Init();
00048
00050         virtual INT GetProviderId() const;
00051
00053         virtual INT MaxRowCount();
00054
00056         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem & item);
00057
00059         virtual BOOLEAN SetDataItem(const DataItem & item, INT columnid);
00060
00062         virtual BOOLEAN SelectRow(INT row);
00063
00065         virtual BOOLEAN CommitRow(INT row);
00066
00068         virtual INT RowCount();
00069
00071         virtual void RestoreFactorySettings();
00072
00074         virtual BOOLEAN Update(ProviderListener * listener = 0);
00075
00076     private:
00077         FmRadioStationsRecord   m_record;
00078         FmRadioStationsRecord   m_commit_record;
00079         RecordHandler           m_handler;
00080 };
00081
00082 #endif // Mmi_FmRadioStationsProvider_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioStationsRecord.cpp File Reference

Applications/FmRadio/FmRadioStationsRecord.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include "FmRadioStationsRecord.hpp"

Include dependency graph for FmRadioStationsRecord.cpp:

Generated on Wed Jan 25 00:12:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioStationsRecord.hpp File Reference

Applications/FmRadio/FmRadioStationsRecord.hpp File Reference

#include <AddOns/AdcExtensions/Record.hpp>

Include dependency graph for FmRadioStationsRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FmRadioStationsRecord
struct | FmRadioStationsRecord::Persist

Defines

#define | Mmi_FmRadioStationsRecord_hpp

Define Documentation

#define Mmi_FmRadioStationsRecord_hpp

Generated on Wed Jan 25 00:12:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioStationsRecord.hpp Source File

Applications/FmRadio/FmRadioStationsRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if !defined(Mmi_FmRadioStationsRecord_hpp)
00011 #define Mmi_FmRadioStationsRecord_hpp
00012
00013 #include <AddOns/AdcExtensions/Record.hpp>
00014
00015 class FmRadioStationsRecord : public Record {
00016     typedef Record Base;
00017
00018     public:
00019         FmRadioStationsRecord( UINT32 radio_freq = 0L );
00020
00021         struct Persist {
00022             UINT32 radio_freq;
00023         } m_data;
00024
00025         virtual const UINT8* GetData();
00026         virtual void SetData(const UINT8* data);
00027         virtual INT GetPersistentSize();
00028
00029         void SetRadioFreq(UINT32 radio_freq) { m_data.radio_freq = radio_freq; }
00030         UINT32 GetRadioFreq() { return m_data.radio_freq; }
00031 };
00032
00033 #endif  // Mmi_FmRadioStationsRecord_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioVersion.cpp File Reference

Applications/FmRadio/FmRadioVersion.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include "FmRadioVersion.hpp"

Include dependency graph for FmRadioVersion.cpp:

Functions

ApoxiDefVersionInfo (FmRadio, FMRADIOVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | FmRadio | ,
 |  | FMRADIOVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:12:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioVersion.hpp File Reference

Applications/FmRadio/FmRadioVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | FMRADIOVERSION "2.10.0_TIV_04"
#define | FmRadioVersion_hpp

Define Documentation

#define FMRADIOVERSION "2.10.0_TIV_04"

#define FmRadioVersion_hpp

Generated on Wed Jan 25 00:12:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioVersion.hpp Source File

Applications/FmRadio/FmRadioVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(FmRadioVersion_hpp)
00010 #define FmRadioVersion_hpp
00011
00012
00013 /*
00014 FmRadioVersion.hpp contains the official FmRadioVersion which should be used in the
00015 different FmRadioVersion.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018
00019 #define FMRADIOVERSION "2.10.0_TIV_04"
00020
00021 #endif  // FmRadioVersion_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioWindow.cpp File Reference

Applications/FmRadio/FmRadioWindow.cpp File Reference

#include "FmRadioApplicationPreComp.hpp"
#include <Gui/ProgressBar.hpp>
#include "FmRadioWindow.hpp"
#include "FmRadioApplication.hpp"
#include <Config/MmiGuiEngineConfig.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Atl/Features/FeatureBroker.hpp>
#include <Audio/GenericFeatureData.hpp>
#include <Config/FontConfig.hpp>
#include <Config/AudioConfig.hpp>
#include <Gui/MessageBox.hpp>

Include dependency graph for FmRadioWindow.cpp:

Generated on Wed Jan 25 00:12:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioWindow.hpp File Reference

Applications/FmRadio/FmRadioWindow.hpp File Reference

#include <Common/MmiWindow.hpp>
#include <Devices/AudioDeviceManager.hpp>

Include dependency graph for FmRadioWindow.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FmRadioWindow

Defines

#define | VOLUME_STEPS 10

Define Documentation

#define VOLUME_STEPS 10

Generated on Wed Jan 25 00:12:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/FmRadio/FmRadioWindow.hpp Source File

Applications/FmRadio/FmRadioWindow.hpp

Go to the documentation of this file.
00001 #ifndef _FMRADIOWINDOW_H
00002 #define _FMRADIOWINDOW_H
00003
00004 #include <Common/MmiWindow.hpp>
00005 #include <Devices/AudioDeviceManager.hpp>
00006
00007 class FmRadioApplication;
00008
00009 class FmRadioWindow : public MmiWindow {
00010     typedef MmiWindow Base;
00011
00012
00013 public:
00015     FmRadioWindow();
00016
00017     ~FmRadioWindow();
00018
00019     void Init();
00020
00022     void CloseMinimized(void);
00023
00025     void SetFrequency(UINT32 edited_freq);
00026
00028     void HandleRadioAudioNotification(void);
00029
00031     void UpdateRadioDisplay(void);
00032
00033 protected:
00034     void SetFrequency(KeyCode key_code);
00035     void OnLayoutClient();
00036     void OnOpen();
00037     void OnClose();
00038     void SwitchOff();
00039     BOOLEAN OnMessage(const Message &msg);
00040     BOOLEAN SaveFrequency(KeyCode key_code);
00041
00042 private:
00043     #define VOLUME_STEPS 10
00044
00046     void LoadSavedData();
00047
00048     TextBox                         m_frequency;
00049     TextBox                         m_info;
00050     TextBox                         m_vol_text;
00051
00052     ProgressBar                     m_volume_bar;
00053
00054     TextFormat                      m_freq_format;
00055     TextFormat                      m_vol_format;
00056     INT                             m_volume;
00057
00058     WCHAR                           m_freq_str[11];
00059     WCHAR                           m_mem_str[11];
00060     UINT32                          m_stored_freq[c_max_fmradio_stations_records];
00061
00062     ImageBox                        up_down_image;
00063     ImageBox                        stereo_image;
00064
00065     BOOLEAN                         m_is_fmradio_running;
00066
00067     RadioAudioDevice::StationInfo   m_radio_info;
00068
00069     FmRadioApplication *            m_fmradio_app;
00070 };
00071 #endif
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserApp.cpp File Reference

Applications/ImageBrowser/ImageBrowserApp.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include <AddOns/Services/ServiceBroker.hpp>
#include <Auxiliary/BufferedData.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <AddOns/MultiMedia/GifImage.hpp>
#include <AddOns/MultiMedia/WbmpImage.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <AddOns/MultiMedia/PngImage.hpp>
#include <AddOns/MultiMedia/BmpImage.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Kernel/VersionInfo.hpp>
#include <Config/MenuResConfig.hpp>
#include <ImageBrowser/Common/MediaBrowserUtils.hpp>
#include <AddOns/MultiMedia/ImageItem.hpp>
#include "ImageBrowserApp.hpp"
#include "ImageBrowserMsgTypes.hpp"
#include "ImageRefGenContainer.hpp"
#include <Ems/EmsImage.hpp>

Include dependency graph for ImageBrowserApp.cpp:

Functions

ApoxiUseVersionInfo (ImageBrowser)

Function Documentation

ApoxiUseVersionInfo ( ImageBrowser )

Generated on Wed Jan 25 00:15:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserApp.hpp File Reference

Applications/ImageBrowser/ImageBrowserApp.hpp File Reference

#include <Afs/Rfs/StorageDevice.hpp>
#include <Common/MmiServices.hpp>
#include <Common/MmiApplication.hpp>
#include <Common/MmiWaitingBox.hpp>
#include <ImageBrowser/Common/BrowserSaveWin.hpp>
#include <ImageBrowser/Common/MediaFilter.hpp>
#include <ImageBrowser/Common/RenameFileDialog.hpp>
#include <Atl/Gui/MmiItemListWindow.hpp>
#include "ImageBrowserDetailWin.hpp"
#include "ImageRefContainer.hpp"

Include dependency graph for ImageBrowserApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageBrowserApp

Defines

#define | Apoxi_ImageBrowserApp_hpp

Define Documentation

#define Apoxi_ImageBrowserApp_hpp

Generated on Wed Jan 25 00:15:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserApp.hpp Source File

Applications/ImageBrowser/ImageBrowserApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageBrowserApp_hpp)
00011 #define Apoxi_ImageBrowserApp_hpp
00014 #include <Afs/Rfs/StorageDevice.hpp>
00015 #include <Common/MmiServices.hpp>
00016 #include <Common/MmiApplication.hpp>
00017 #include <Common/MmiWaitingBox.hpp>
00018 #include <ImageBrowser/Common/BrowserSaveWin.hpp>
00019 #include <ImageBrowser/Common/MediaFilter.hpp>
00020 #include <ImageBrowser/Common/RenameFileDialog.hpp>
00021 #include <Atl/Gui/MmiItemListWindow.hpp>
00022
00023 #include "ImageBrowserDetailWin.hpp"
00024
00025 #include "ImageRefContainer.hpp"
00026
00027 class ImageRef;
00028 class ImageRefContainer;
00029 class ImageFilter;
00030
00032 class ImageBrowserApp : public MmiApplication, public ImageManagementService
00033 {
00034     typedef MmiApplication Base;
00035
00036     public:
00037
00039         virtual ~ImageBrowserApp();
00040
00042         static ImageBrowserApp* GetInstance() { return &m_app; }
00043
00045         virtual void OnStartup();
00046
00047        BOOLEAN  m_mirrored;
00048         BOOLEAN  m_reversed;
00056         ServiceResult SelectImage(MediaRefPtr &img_ref,
00057             const ImageFilter &img_filter = ImageFilter());
00058
00059
00072         ServiceResult SaveImage(const BinData *raw_data, const Path &path, DrmMimeType drm_mime_type, MimeType mime_type);
00082         ServiceResult SaveImage(const Image *image, const Path &path);
00090         ServiceResult GetResourceNames(Vector<Path>& paths, const ImageFilter& image_filter = ImageFilter());
00091
00092
00093     protected:
00094
00096         virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00097
00099         virtual DataItem GetContextDataItem(ContextFeature *feature);
00100
00102         void OnOpen();
00103
00105         void OnClose();
00106
00108         BOOLEAN OnMessage(const Message &msg);
00109
00111     private:
00112
00114         ImageBrowserApp();
00115
00117         Image* ProcessDrmImage(FfsDrmAttrib &attrib,ImageRef &img_ref);
00118
00120         INT AddToImageDb(MediaRefPtr &image_ref_ptr,FfsDrmAttrib &attrib);
00121
00122
00124         void OpenBrowser();
00125
00127         void ShowImage();
00128
00130         void Delete();
00131
00133         void Rename();
00134
00136         void Select();
00137
00139         void DisplayInfo(BOOLEAN is_media_info = TRUE) const;
00140
00141         // Updates the item container
00142         void UpdateItemContainer(INT idx = -1, BOOLEAN delete_elem = FALSE);
00143
00144         // Updates the Image List
00145         void UpdateImageList(BOOLEAN app_filer = FALSE);
00146         //
00147         void SendAsMms();
00148         //
00149         void HandleErrImg(UINT8 err_no);
00151     #if defined(APOXI_INCLUDE_DRM)
00152         INT HandleDcf(MediaRefPtr &img_ref_ptr);
00153     #endif
00154
00155         void HandleSelectImage();
00156         void HandleSaveImage();
00157         void HandleMmc();
00158         void HandleImg();
00159
00161     private:
00162
00164         enum OpenMode {
00165             NotOpen,
00166             OpenSelectionService,
00167             OpenSaveService,
00168             OpenApplication
00169         };
00170
00172         enum FeatureItemIds {
00173             IbImageBrowser,
00174             IbMmc,
00175             IbSelect,
00176             IbShow,
00177             IbRename,
00178             IbDelete,
00179             IbScreenSaver, //shown as menu item in ScreenSaver Settings
00180             IbWallPaper,
00181             IbInfo,
00182 #if defined(APOXI_INCLUDE_DRM)
00183             IbDrmInfo,
00184 #endif
00185             IbSendAsMms,
00186             IbClose,
00187             Mirror,
00188             Reverse,
00189             Start,
00190             Stop,
00191             IbFeatureCnt
00192         };
00193
00195         enum ServiceState {
00196             NoService,
00197             SelectService,
00198             SaveService
00199         };
00200
00201         Feature m_items[IbFeatureCnt];
00202         OpenMode m_mode;
00203
00204         static ImageBrowserApp m_app;
00205         BrowserSaveWin m_browser_save_win;
00206
00207         static BooleanCondition s_condition_sel;
00208         MmiWaitingBox m_saving_pro_win;
00209
00210         ImageRefContainer *m_img_refs;
00211
00212         ItemContainer* m_item_cont;
00213         MmiItemListWindow m_media_list_win;
00214         RenameFileDialog m_rename_file_dialog;
00215
00216         ServiceState m_srv_state;
00217         BOOLEAN m_srv_success;
00218
00219         MediaFilter *p_image_filter;
00220
00221         const BinData *m_bin_data;
00222         const Image *m_image;
00223         DrmMimeType m_drm_mime_type;
00224         MimeType    m_mime_type;
00225         Path        m_path;
00226
00227         ImageBrowserDetailWin image_win;
00228
00229
00230 }; // ImageBrowserApp
00231
00233 #endif  // Apoxi_ImageBrowserApp_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserDetailWin.cpp File Reference

Applications/ImageBrowser/ImageBrowserDetailWin.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageBrowserDetailWin.hpp"
#include "ImageBrowserApp.hpp"
#include "ImageBrowserMsgTypes.hpp"
#include <Auxiliary/RamData.hpp>

Include dependency graph for ImageBrowserDetailWin.cpp:

Defines

#define | XSTEP 30
#define | YSTEP 30

Define Documentation

#define XSTEP 30

#define YSTEP 30

Generated on Wed Jan 25 00:15:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserDetailWin.hpp File Reference

Applications/ImageBrowser/ImageBrowserDetailWin.hpp File Reference

#include <Atl/AtlWindow.hpp>
#include <Gui/Image.hpp>

Include dependency graph for ImageBrowserDetailWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageBrowserDetailWin

Defines

#define | Apoxi_ImageBrowserDetailWin_hpp

Define Documentation

#define Apoxi_ImageBrowserDetailWin_hpp

Generated on Wed Jan 25 00:15:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserDetailWin.hpp Source File

Applications/ImageBrowser/ImageBrowserDetailWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageBrowserDetailWin_hpp)
00011 #define Apoxi_ImageBrowserDetailWin_hpp
00014
00015 #include <Atl/AtlWindow.hpp>
00016 #include <Gui/Image.hpp>
00017
00021 class ImageBrowserDetailWin : public AtlWindow {
00022     typedef AtlWindow Base;
00023
00024     public:
00025         ImageBrowserDetailWin();
00026         virtual ~ImageBrowserDetailWin();
00027
00032         void Init(Image *image);
00036         void StartStop(BOOLEAN start);
00040         BOOLEAN SetTransformation(DeviceContext::TransformationMode transformation);
00041     protected:
00043         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00045         virtual void OnLayoutClient();
00047         virtual BOOLEAN OnCancel();
00049         virtual void OnOpen();
00051         virtual void OnClose();
00053
00058         void RepositionImage();
00059
00060     private:
00061         ImageBox                m_image_box;
00062
00066         XYDIM                   m_XPos,m_YPos;
00070         XYDIM                   m_Height,m_Width;
00074         XYDIM                   m_MaxXPos, m_MaxYPos;
00075 };
00076
00078 #endif  // Apoxi_ImageBrowserDetailWin_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserMsgTypes.cpp File Reference

Applications/ImageBrowser/ImageBrowserMsgTypes.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageBrowserMsgTypes.hpp"

Include dependency graph for ImageBrowserMsgTypes.cpp:

Generated on Wed Jan 25 00:15:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserMsgTypes.hpp File Reference

Applications/ImageBrowser/ImageBrowserMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Afs/Rfs/Path.hpp>
#include <ImageBrowser/Common/MediaFilter.hpp>
#include <ImageBrowser/ImageRef.hpp>

Include dependency graph for ImageBrowserMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageBrowserDeleteImageMsg
class | ImageBrowserRenameImageMsg
class | ImageBrowserServiceMsg

Defines

#define | Common_ImageBrowserMsgTypes_hpp

Define Documentation

#define Common_ImageBrowserMsgTypes_hpp

Generated on Wed Jan 25 00:15:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserMsgTypes.hpp Source File

Applications/ImageBrowser/ImageBrowserMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\nageshra_BP2_2.5\lnz_apps_int\Applications\ImageBrowser\ImageBrowserMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Common_ImageBrowserMsgTypes_hpp)
00014 #define Common_ImageBrowserMsgTypes_hpp
00015 #include <Kernel/Message.hpp>
00016 #include <Afs/Rfs/Path.hpp>
00017 #include <ImageBrowser/Common/MediaFilter.hpp>
00018 #include <ImageBrowser/ImageRef.hpp>
00019 /* ----------------------------------------------------------------------
00020     Classes
00021     ---------------------------------------------------------------------- */
00022 /*  ======================================================================
00023     Class ImageBrowserDeleteImageMsg
00024     ====================================================================== */
00026 class ImageBrowserDeleteImageMsg : public Message {
00027     public:
00028         ImageBrowserDeleteImageMsg();
00029         virtual ~ImageBrowserDeleteImageMsg();
00030
00031         virtual const MsgMetaData& GetMetaData() const;
00032         virtual Message* Clone() const;
00033
00034         enum  {
00035             ID = 21352
00036             };
00037
00038     private:
00039         static const MsgMetaData m_meta_data;
00040
00041     };
00042 /*  ======================================================================
00043     Class ImageBrowserRenameImageMsg
00044     ====================================================================== */
00046 class ImageBrowserRenameImageMsg : public Message {
00047     public:
00048         ImageBrowserRenameImageMsg(const WString& new_name);
00049         virtual ~ImageBrowserRenameImageMsg();
00050
00051         virtual const MsgMetaData& GetMetaData() const;
00052         const WString& GetNewName() const { return m_new_name; }
00053         virtual Message* Clone() const;
00054
00055         enum  {
00056             ID = 21353
00057             };
00058
00059     private:
00060         static const MsgMetaData m_meta_data;
00061         WString m_new_name;
00062
00063     };
00064 /*  ======================================================================
00065     Class ImageBrowserServiceMsg
00066     ====================================================================== */
00068 class ImageBrowserServiceMsg : public ContextMsg {
00069     public:
00070         ImageBrowserServiceMsg(ExecutionContext* context);
00071         virtual ~ImageBrowserServiceMsg();
00072
00073         virtual const MsgMetaData& GetMetaData() const;
00074         virtual Message* Clone() const;
00075
00076         enum  {
00077             ID = 21354
00078             };
00079
00080     private:
00081         static const MsgMetaData m_meta_data;
00082
00083     };
00084 #endif // Common_ImageBrowserMsgTypes_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserPreComp.cpp File Reference

Applications/ImageBrowser/ImageBrowserPreComp.cpp File Reference

#include "ImageBrowserPreComp.hpp"

Include dependency graph for ImageBrowserPreComp.cpp:

Generated on Wed Jan 25 00:15:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserPreComp.hpp File Reference

Applications/ImageBrowser/ImageBrowserPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for ImageBrowserPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:16:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserPreComp.hpp Source File

Applications/ImageBrowser/ImageBrowserPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Kernel/Lib.hpp>
00011 #include <Gui/Lib.hpp>
00012 #include <Adc/Lib.hpp>
00013 #include <Afs/Ffs/FfsHandler.hpp>
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserTestWin.cpp File Reference

Applications/ImageBrowser/ImageBrowserTestWin.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageBrowserTestWin.hpp"
#include <Common/MmiServices.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/MultiMedia/GifImage.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <AddOns/MultiMedia/WbmpImage.hpp>
#include <AddOns/MultiMedia/PngImage.hpp>
#include <Auxiliary/RamData.hpp>
#include <AddOns/MultiMedia/SmafSound.hpp>
#include <AddOns/MultiMedia/MidiSound.hpp>
#include <ImageBrowser/SampleImages.hpp>
#include <ImageBrowser/ImageRef.hpp>
#include <AddOns/MultiMedia/IMelody.hpp>
#include <SoundBrowser/SampleIMelodies.hpp>
#include <SoundBrowser/SoundRef.hpp>
#include <ImageBrowser/Common/MediaFilter.hpp>
#include <ImageBrowser/Common/MediaRefContainer.hpp>

Include dependency graph for ImageBrowserTestWin.cpp:

Generated on Wed Jan 25 00:16:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserTestWin.hpp File Reference

Applications/ImageBrowser/ImageBrowserTestWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for ImageBrowserTestWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageBrowserTestWin

Defines

#define | Apoxi_ImageBrowserTestWin_hpp

Define Documentation

#define Apoxi_ImageBrowserTestWin_hpp

Generated on Wed Jan 25 00:16:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserTestWin.hpp Source File

Applications/ImageBrowser/ImageBrowserTestWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageBrowserTestWin_hpp)
00011 #define Apoxi_ImageBrowserTestWin_hpp
00014
00015 #include <GuiExtensions/MmiWindow.hpp>
00016 #include <GuiExtensions/ActionAccessor.hpp>
00017
00018 class IMelody;
00019
00020 class ImageBrowserTestWin : public MmiWindow
00021 {
00022     typedef MmiWindow Base;
00023
00024     public:
00025         ImageBrowserTestWin();
00026         virtual ~ImageBrowserTestWin();
00027
00028         void Init();
00029
00030     protected:
00031         virtual BOOLEAN OnCancel();
00032         virtual void OnLayoutClient();
00033         virtual void OnActionExecuted(Action *action);
00034
00035     private:
00036         ImageBox m_image_box;
00037         TextBox m_text_box;
00038
00039         ActionAccessor m_accessor;
00040
00041         // For sounds.
00042         Action m_select_snd_action;
00043         Action m_save_snd_action;
00044         Action m_get_cnt_snd_action;
00045         Action m_get_names_snd_action;
00046
00047         // For images.
00048         Action m_select_img_action;
00049         Action m_save_img_action;
00050         Action m_get_cnt_img_action;
00051         Action m_get_names_img_action;
00052
00053         CancelAction m_cancel_action;
00054
00055         INT m_current_image;
00056         Image *m_images[4];
00057         INT m_current_sound;
00058         IMelody *m_sounds[3];
00059 };
00060
00062 #endif  // Apoxi_ImageBrowserTestWin_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserWin.cpp File Reference

Applications/ImageBrowser/ImageBrowserWin.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "GuiExtensions/MmiInfoBox.hpp"
#include "GuiExtensions/MmiAlert.hpp"
#include "ImageBrowserWin.hpp"
#include "ImageBrowserApp.hpp"
#include "ImageRefContainer.hpp"
#include "ImageBrowserMsgTypes.hpp"
#include "ImageBrowserDetailWin.hpp"

Include dependency graph for ImageBrowserWin.cpp:

Generated on Wed Jan 25 00:16:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserWin.hpp File Reference

Applications/ImageBrowser/ImageBrowserWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <Common/MmiWaitingBox.hpp>
#include <ImageBrowser/Common/BrowserViewContainer.hpp>
#include <ImageBrowser/Common/RenameFileDialog.hpp>
#include <ImageBrowser/Common/FileNameView.hpp>
#include <ImageBrowser/ImageView.hpp>
#include <ImageBrowser/Common/InfoDialog.hpp>

Include dependency graph for ImageBrowserWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageBrowserWin

Defines

#define | Apoxi_ImageBrowserWin_hpp

Define Documentation

#define Apoxi_ImageBrowserWin_hpp

Generated on Wed Jan 25 00:16:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageBrowserWin.hpp Source File

Applications/ImageBrowser/ImageBrowserWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageBrowserWin_hpp)
00011 #define Apoxi_ImageBrowserWin_hpp
00014
00015 #include <GuiExtensions/MmiWindow.hpp>
00016 #include <GuiExtensions/ActionAccessor.hpp>
00017 #include <Common/MmiWaitingBox.hpp>
00018 #include <ImageBrowser/Common/BrowserViewContainer.hpp>
00019 #include <ImageBrowser/Common/RenameFileDialog.hpp>
00020 #include <ImageBrowser/Common/FileNameView.hpp>
00021 #include <ImageBrowser/ImageView.hpp>
00022 #include <ImageBrowser/Common/InfoDialog.hpp>
00023
00024
00025 class ImageRef;
00026 class ImageRefContainer;
00027 class ImageFilter;
00028
00032 class ImageBrowserWin : public MmiWindow
00033 {
00034     typedef MmiWindow Base;
00035
00036     public:
00037         ImageBrowserWin();
00038         virtual ~ImageBrowserWin();
00039
00042         void Init(BooleanCondition &condition, ImageRefContainer &img_refs);
00043
00050         BOOLEAN SetImageFilter(const ImageFilter &img_filter, BOOLEAN show_select_button);
00051
00054         MediaRefPtr& GetSelectedImageRef();
00055
00058         BOOLEAN GetSuccess() const;
00059
00060         BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00061
00062     protected:
00063         BOOLEAN OnKeyDown(KeyCode key_code);
00064         void OnLayoutClient();
00065         BOOLEAN OnCancel();
00066         BOOLEAN OnConfirm();
00067         void OnOpen();
00068         void OnClose();
00069
00070     private:
00071         void DisplayAlert(const WCHAR *msg);
00072         void HandleErrImg(UINT8 err_no);
00073         BrowserViewContainer m_views;
00074         FileNameView m_fnv;
00075         ImageView m_img_view;
00076         MmiWaitingBox m_waiting_box;
00077
00078         ImageRefContainer *m_img_refs;
00079
00080         BooleanCondition *m_condition;
00081         BOOLEAN m_success;
00082         BOOLEAN m_show_select_button;
00083
00084         RenameFileDialog m_rename_file_dialog;
00085         InfoDialog m_info_dialog;
00086 };
00088
00089
00090 #endif  // Apoxi_ImageBrowserWin_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageListBoxModel.cpp File Reference

Applications/ImageBrowser/ImageListBoxModel.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageListBoxModel.hpp"

Include dependency graph for ImageListBoxModel.cpp:

Generated on Wed Jan 25 00:16:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageListBoxModel.hpp File Reference

Applications/ImageBrowser/ImageListBoxModel.hpp File Reference

#include <GuiExtensions/DrawableObjectListBox.hpp>

Include dependency graph for ImageListBoxModel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageListBoxModel
Base class of a model for showing images. More...

Defines

#define | Apoxi_ImageListBoxModel_hpp

Define Documentation

#define Apoxi_ImageListBoxModel_hpp

Generated on Wed Jan 25 00:16:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageListBoxModel.hpp Source File

Applications/ImageBrowser/ImageListBoxModel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageListBoxModel_hpp)
00011 #define Apoxi_ImageListBoxModel_hpp
00014
00015 #include <GuiExtensions/DrawableObjectListBox.hpp>
00016
00018 class ImageListBoxModel : public DrawableObjectListBoxModel
00019 {
00020     typedef DrawableObjectListBoxModel Base;
00021
00022     public:
00023         ImageListBoxModel();
00024         ImageListBoxModel(DrawableObjectListBox *control);
00025         virtual ~ImageListBoxModel();
00026
00030         void Init(DrawableObjectListBox *control);
00031
00033         virtual void AdjustThemeDependencies();
00034
00039         virtual DrawableObject* GetItem(INT index, BOOLEAN highlighted);
00040
00045         virtual DrawableObjectView* GetRenderingView(INT index, BOOLEAN highlighted);
00046
00048         virtual void Update(INT item_count = -1);
00049
00051         void SetImageChanged(BOOLEAN changed = TRUE);
00052
00054         virtual void NotifyDelete();
00055
00056     protected:
00059         virtual ImageObtainer GetSelectedImage(INT index) = 0;
00060
00062         virtual void OnSelectionChanged(INT selected_index);
00063
00064     private:
00065
00066         ImageBox        *m_imagebox;
00067         BOOLEAN m_image_changed;
00068 };
00069
00071 #endif  // Apoxi_ImageListBoxModel_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageMetaData.cpp File Reference

Applications/ImageBrowser/ImageMetaData.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageMetaData.hpp"
#include "ImageRef.hpp"

Include dependency graph for ImageMetaData.cpp:

Generated on Wed Jan 25 00:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageMetaData.hpp File Reference

Applications/ImageBrowser/ImageMetaData.hpp File Reference

#include <ImageBrowser/Common/MetaData.hpp>

Include dependency graph for ImageMetaData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageMetaData
struct | ImageMetaDataRecord

Defines

#define | Apoxi_ImageMetaData_hpp

Define Documentation

#define Apoxi_ImageMetaData_hpp

Generated on Wed Jan 25 00:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageMetaData.hpp Source File

Applications/ImageBrowser/ImageMetaData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageMetaData_hpp)
00011 #define Apoxi_ImageMetaData_hpp
00014
00015 #include <ImageBrowser/Common/MetaData.hpp>
00016
00017 //const UINT8 img_browser_thumbnail_width = 30;
00018 //const UINT8 img_browser_thumbnail_height = 30;
00019
00020 struct ImageMetaDataRecord : public MetaDataRecord {
00021     UINT16 m_width;
00022     UINT16 m_height;
00023     UINT8 m_frame;
00024     //UINT8 m_use_thumbnail;
00025
00026     ImageMetaDataRecord(UINT16 width = 0, UINT16 height= 0, INT frame = 0);
00027     virtual ~ImageMetaDataRecord();
00028 };
00029
00032 class ImageMetaData : public MetaData
00033 {
00034     typedef MetaData Base;
00035
00036     public:
00037         ImageMetaData();
00038
00039 #if defined(APOXI_INCLUDE_DRM)
00040         ImageMetaData(const Path &path, const DrmInfo &drm_info = DrmInfo(),
00041             UINT32 size = 0, XYDIM width = 0, XYDIM height = 0, INT frame = 0);
00042 #else
00043         ImageMetaData(const Path &path, UINT32 size = 0, XYDIM width = 0,
00044             XYDIM height = 0, INT frame = 0);
00045 #endif
00046
00047         virtual ~ImageMetaData();
00048
00049 #if defined(APOXI_INCLUDE_DRM)
00050         void Init(const Path &path, const DrmInfo &drm_info = DrmInfo(),
00051             UINT32 size = 0, XYDIM width = 0, XYDIM height = 0, INT frame = 0);
00052 #else
00053         void Init(const Path &path, UINT32 size = 0, XYDIM width = 0,
00054             XYDIM height = 0, INT frame = 0);
00055 #endif
00056
00057         virtual MetaDataRecord& GetMetaDataRecord();
00058
00059         virtual const MetaDataRecord& GetMetaDataRecord() const;
00060
00062         //BOOLEAN UseThumbnail() const;
00063
00065         //void SetUseThumbnail(BOOLEAN use);
00066
00068         //Path GetThumbnailPath() const;
00069
00071         UINT16 GetWidth() const;
00072
00074         void SetWidth(UINT16 width);
00075
00077         UINT16 GetHeight() const;
00078
00080         void SetHeight(UINT16 height);
00081
00083         UINT8 GetFrame() const;
00084
00086         void SetFrame(UINT8 frame);
00087
00088         virtual WString GetInfoText() const;
00089
00090     private:
00091         ImageMetaDataRecord m_data;
00092 };
00093
00095 #endif  // Apoxi_ImageMetaData_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRef.cpp File Reference

Applications/ImageBrowser/ImageRef.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageRef.hpp"
#include <Auxiliary/BufferedData.hpp>
#include <Auxiliary/Date.hpp>
#include <AddOns/MultiMedia/GifImage.hpp>
#include <AddOns/MultiMedia/WbmpImage.hpp>
#include <AddOns/MultiMedia/JpegImage.hpp>
#include <AddOns/MultiMedia/PngImage.hpp>
#include <AddOns/MultiMedia/BmpImage.hpp>
#include <AddOns/MultiMedia/ImageFactory.hpp>
#include <MmiPlugins/Sms/EmsPlugin/EmsImage.hpp>
#include <Gui/BitmapDc.hpp>
#include <Ems/EmsImage.hpp>
#include <ImageBrowser/Common/MediaBrowserUtils.hpp>

Include dependency graph for ImageRef.cpp:

Generated on Wed Jan 25 00:16:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRef.hpp File Reference

Applications/ImageBrowser/ImageRef.hpp File Reference

#include <Afs/Ffs/FfsTypes.hpp>
#include <ImageBrowser/Common/MediaRef.hpp>
#include <ImageBrowser/ImageMetaData.hpp>
#include <Afs/Rfs/FileBinData.hpp>

Include dependency graph for ImageRef.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageRef

Defines

#define | Apoxi_ImageRef_hpp

Define Documentation

#define Apoxi_ImageRef_hpp

Generated on Wed Jan 25 00:16:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRef.hpp Source File

Applications/ImageBrowser/ImageRef.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageRef_hpp)
00011 #define Apoxi_ImageRef_hpp
00014
00015 #include <Afs/Ffs/FfsTypes.hpp>
00016 #include <ImageBrowser/Common/MediaRef.hpp>
00017 #include <ImageBrowser/ImageMetaData.hpp>
00018 #include <Afs/Rfs/FileBinData.hpp>
00019
00020 class Image;
00021
00025 class ImageRef : public MediaRef
00026 {
00027     typedef MediaRef Base;
00028
00029     public:
00030         ImageRef();
00031
00032 #if defined(APOXI_INCLUDE_DRM)
00033         ImageRef(const DrmInfo &drm_info);
00034 #endif
00035
00036         virtual ~ImageRef();
00037
00039         virtual MetaData& GetMetaData();
00041         virtual const MetaData& GetMetaData() const;
00042
00044         virtual void SetMetaData(const MetaData &meta_data);
00045
00046 #if defined(APOXI_INCLUDE_DRM)
00047         virtual WString GetAssetInfo();
00048 #endif
00049
00054         Image* GetImage(BOOLEAN buffer_to_ram = TRUE);
00055
00056         const ImageObtainer GetImageObtainer();
00058         void SetImage(Image *image);
00059
00061         BOOLEAN IsImageInitialized() const;
00062
00064         void ReleaseImage();
00065
00067         //ImageObtainer GetThumbnail();
00068
00070         Image* CreateImageObject(BinData *bd,BOOLEAN buffer_to_ram = TRUE);
00071
00073         Image* CreateImageObject(const BinData *bd,BOOLEAN buffer_to_ram = TRUE);
00074
00075
00076 #if defined(APOXI_INCLUDE_DRM)
00077         Image* CreateImageObject(BinData *fbd,FfsDrmAttrib attrib);
00078 #endif
00079
00081         void ReleaseThumbnail();
00082
00089         //const ImageObtainer CreateThumbnail();
00090
00094         //BOOLEAN SaveThumbnail(const ImageObtainer& img_obtainer);
00095
00096     private:
00097         ImageMetaData m_meta_data;
00098         Image *m_image;
00099         FileBinData *m_fbd;
00100
00101
00102 #if defined(APOXI_INCLUDE_DRM)
00103
00104         Image * ValidateImage(BinData *bd);
00105         //
00106         Image* CreateImageObject(FfsDrmAttrib attrib);
00107 #endif
00108
00109         Image* ConstructImage(BinData *bd);
00110         //
00111         Image* CreateImageObject(BOOLEAN buffer_to_ram = TRUE);
00112 };
00113
00115 #endif  // Apoxi_ImageRef_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRefContainer.cpp File Reference

Applications/ImageBrowser/ImageRefContainer.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageRefContainer.hpp"
#include "ImageRef.hpp"
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/FileFilter.hpp>

Include dependency graph for ImageRefContainer.cpp:

Generated on Wed Jan 25 00:17:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRefContainer.hpp File Reference

Applications/ImageBrowser/ImageRefContainer.hpp File Reference

#include <ImageBrowser/Common/MediaRefContainer.hpp>
#include <ImageBrowser/ImageMetaData.hpp>

Include dependency graph for ImageRefContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageRefContainer

Defines

#define | Apoxi_ImageRefContainer_hpp

Define Documentation

#define Apoxi_ImageRefContainer_hpp

Generated on Wed Jan 25 00:17:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRefContainer.hpp Source File

Applications/ImageBrowser/ImageRefContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageRefContainer_hpp)
00011 #define Apoxi_ImageRefContainer_hpp
00014
00015 #include <ImageBrowser/Common/MediaRefContainer.hpp>
00016 #include <ImageBrowser/ImageMetaData.hpp>
00017
00018 class ImageRef;
00019 class ImageMetaData;
00020
00023 class ImageRefContainer : public MediaRefContainer
00024 {
00025     typedef MediaRefContainer Base;
00026
00027     public:
00028         ImageRefContainer();
00029         ImageRefContainer(const Path &database_path);
00030         virtual ~ImageRefContainer();
00031
00035         virtual BOOLEAN Add(MediaRefPtr &media_ref,BOOLEAN free=TRUE);
00036
00040         virtual BOOLEAN Delete(MediaRefPtr &media_ref,
00041             BOOLEAN delete_file = FALSE);
00042
00046         virtual BOOLEAN Rename(MediaRefPtr &media_ref, const WString &new_name);
00047
00049         virtual UINT32 GetSizeOfRecord() const;
00050     protected:
00052         virtual MediaRefPtr CreateMediaRef() const;
00053
00054
00055
00057         virtual FileFilterPtr GetMediaFileFilter() const;
00058
00060         virtual BOOLEAN SetupMediaObject(MediaRefPtr &media_ref);
00061 };
00062
00064 #endif  // Apoxi_ImageRefContainer_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRefGenContainer.cpp File Reference

Applications/ImageBrowser/ImageRefGenContainer.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageRefGenContainer.hpp"

Include dependency graph for ImageRefGenContainer.cpp:

Generated on Wed Jan 25 00:17:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRefGenContainer.hpp File Reference

Applications/ImageBrowser/ImageRefGenContainer.hpp File Reference

#include <Auxiliary/GenericObject.hpp>
#include "ImageRef.hpp"

Include dependency graph for ImageRefGenContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageRefGenContainer

Defines

#define | Apoxi_ImageRefGenContainer_hpp

Variables

const GenericTypeId | c_image_ref_ptr_type = c_user_base_gentypes + 4804

Define Documentation

#define Apoxi_ImageRefGenContainer_hpp

Variable Documentation

const GenericTypeId c_image_ref_ptr_type = c_user_base_gentypes + 4804

Generated on Wed Jan 25 00:17:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageRefGenContainer.hpp Source File

Applications/ImageBrowser/ImageRefGenContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 /*
00011 * This template class GenricContainer can be used to contain object of any type.
00012 * GenricContainer itself derives from class GenericObject and one of it's
00013 * usage can be to contain objects which are not GenericObject and they
00014 * need to be set into DataItem.
00015 */
00016
00017 #if !defined(Apoxi_ImageRefGenContainer_hpp)
00018 #define Apoxi_ImageRefGenContainer_hpp
00019
00020 #include <Auxiliary/GenericObject.hpp>
00021 #include "ImageRef.hpp"
00022
00023 const GenericTypeId c_image_ref_ptr_type = c_user_base_gentypes + 4804;
00024
00025 class ImageRefGenContainer : public GenericObject
00026 {
00027     public:
00028     virtual ~ImageRefGenContainer(){}
00029
00030     ImageRefGenContainer(const ImageRef& img_obt): m_genobj(img_obt){}
00031
00032     virtual GenericObject* Copy() const;
00033
00034     virtual BOOLEAN IsEqual(GenericObject* object);
00035     virtual GenericTypeId GetTypeId();
00036
00037     ImageRef& GetImageRefObj();
00038     void SetImageRefObj(const ImageRef& gen_obt);
00039
00040
00041     private:
00042         ImageRef m_genobj;
00043 };
00044
00045 #endif  // Mmi_GenricContainer_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageView.cpp File Reference

Applications/ImageBrowser/ImageView.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageView.hpp"
#include "ImageBrowserMsgTypes.hpp"
#include "ImageBrowserWin.hpp"
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for ImageView.cpp:

Generated on Wed Jan 25 00:17:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageView.hpp File Reference

Applications/ImageBrowser/ImageView.hpp File Reference

#include <ImageBrowser/Common/BrowserView.hpp>
#include <ImageBrowser/Common/MediaRef.hpp>
#include <ImageBrowser/ImageViewListBoxModel.hpp>

Include dependency graph for ImageView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageListBoxView
class | ImageView

Defines

#define | Apoxi_ImageView_hpp
#define | IMAGE_ITEM_HEIGHT 36

Define Documentation

#define Apoxi_ImageView_hpp

Generated on Wed Jan 25 00:17:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageView.hpp Source File

Applications/ImageBrowser/ImageView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageView_hpp)
00011 #define Apoxi_ImageView_hpp
00014
00015 #include <ImageBrowser/Common/BrowserView.hpp>
00016 #include <ImageBrowser/Common/MediaRef.hpp>
00017 #include <ImageBrowser/ImageViewListBoxModel.hpp>
00018
00019 #define IMAGE_ITEM_HEIGHT           36  /*Item height of thumbnail view*/
00020
00023 class ImageListBoxView : public AbstractListBoxView
00024 {
00025     typedef AbstractListBoxView Base;
00026
00027     public:
00028         ImageListBoxView();
00029         ImageListBoxView(XYDIM item_height);
00030
00033         void Init(XYDIM item_height);
00034
00036         void DrawItem(const AbstractListBox &listbox, DeviceContext *dc,
00037             INT index, const Rect &item_rect) const;
00038 };
00039
00042 class ImageView : public BrowserView
00043 {
00044     typedef BrowserView Base;
00045
00046     public:
00047         ImageView();
00048         virtual ~ImageView();
00049
00055         void Init(Control *control, MediaRefContainer &media_refs);
00056
00057         virtual void NotifyDelete();
00058
00059         ImageViewListBoxModel* GetModel() {return &m_list_model;};
00060
00061     protected:
00063         virtual BOOLEAN OnMessage(const Message &msg);
00064
00066         virtual void OnGetFocus();
00067
00068     private:
00069         ImageViewListBoxModel m_list_model;
00070         static ImageListBoxView m_view;
00071 };
00072
00074 #endif  // Apoxi_ImageView_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageViewListBoxModel.cpp File Reference

Applications/ImageBrowser/ImageViewListBoxModel.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "ImageViewListBoxModel.hpp"
#include "ImageMetaData.hpp"
#include <Afs/Rfs/File.hpp>

Include dependency graph for ImageViewListBoxModel.cpp:

Generated on Wed Jan 25 00:17:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageViewListBoxModel.hpp File Reference

Applications/ImageBrowser/ImageViewListBoxModel.hpp File Reference

#include <Gui/Image.hpp>
#include <ImageBrowser/ImageListBoxModel.hpp>
#include <ImageBrowser/ImageRef.hpp>
#include <ImageBrowser/Common/MediaRefContainer.hpp>

Include dependency graph for ImageViewListBoxModel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageViewListBoxModel
Class to serve as a model for the ImageView. More...

Defines

#define | Apoxi_ImageViewListBoxModel_hpp

Define Documentation

#define Apoxi_ImageViewListBoxModel_hpp

Generated on Wed Jan 25 00:17:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImageViewListBoxModel.hpp Source File

Applications/ImageBrowser/ImageViewListBoxModel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImageViewListBoxModel_hpp)
00011 #define Apoxi_ImageViewListBoxModel_hpp
00014
00015 #include <Gui/Image.hpp>
00016 #include <ImageBrowser/ImageListBoxModel.hpp>
00017 #include <ImageBrowser/ImageRef.hpp>
00018 #include <ImageBrowser/Common/MediaRefContainer.hpp>
00019
00021 class ImageViewListBoxModel : public ImageListBoxModel
00022 {
00023     typedef ImageListBoxModel Base;
00024
00025     public:
00026         ImageViewListBoxModel();
00027         ImageViewListBoxModel(DrawableObjectListBox *control,
00028             const MediaRefContainer &media_refs);
00029         virtual ~ImageViewListBoxModel();
00030
00036         void Init(DrawableObjectListBox *control,
00037             const MediaRefContainer &media_refs);
00038
00043         virtual DrawableObject* GetItem(INT index, BOOLEAN highlighted);
00044
00045         virtual const WString GetCellText(INT index, BOOLEAN highlighted);
00046         virtual void NotifyDelete();
00047         const WString GetResolution(INT index, BOOLEAN highlighted);
00048
00049     protected:
00052         virtual ImageObtainer GetSelectedImage(INT index);
00053
00055         virtual void OnSelectionChanged(INT selected_index);
00056
00057     private:
00058         INT m_prev_image;
00059         INT m_current_image;
00060         const MediaRefContainer *m_media_refs;
00061 };
00062
00064 #endif  // Apoxi_ImageViewListBoxModel_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImgbrVersion.cpp File Reference

Applications/ImageBrowser/ImgbrVersion.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include "ImgbrVersion.hpp"

Include dependency graph for ImgbrVersion.cpp:

Functions

ApoxiDefVersionInfo (ImageBrowser, IMGBRVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | ImageBrowser | ,
 |  | IMGBRVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:17:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImgbrVersion.hpp File Reference

Applications/ImageBrowser/ImgbrVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IMGBRVERSION "2.10.0_TIV_04"
#define | ImgbrVersion_hpp

Define Documentation

#define IMGBRVERSION "2.10.0_TIV_04"

#define ImgbrVersion_hpp

Generated on Wed Jan 25 00:17:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/ImgbrVersion.hpp Source File

Applications/ImageBrowser/ImgbrVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ImgbrVersion_hpp)
00010 #define ImgbrVersion_hpp
00011
00012 /*
00013
00014 ImgbrVersion.hpp contains the official Uib Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define IMGBRVERSION "2.10.0_TIV_04"
00019
00020 #endif  // ImgbrVersion_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/SampleImages.cpp File Reference

Applications/ImageBrowser/SampleImages.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "SampleImages.hpp"

Include dependency graph for SampleImages.cpp:

Variables

UINT8 | devil [devil_size]
UINT8 | g_drm_cd_j1k_data [1936]
UINT8 | g_drm_cd_res2_data [2716]
UINT8 | g_drm_fl_res2_data [2363]
UINT8 HUGE | gif_image [gif_image_size]
UINT8 HUGE | jpeg_image [jpeg_image_size]
UINT8 | kissing [kissing_size]
UINT8 HUGE | png_image []
UINT8 | wow [wow_size]
Generated on Wed Jan 25 00:17:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/SampleImages.hpp File Reference

Applications/ImageBrowser/SampleImages.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_SampleImages_hpp

Variables

UINT8 | devil [devil_size]
const UINT | devil_size = 61
UINT8 | g_drm_cd_j1k_data [1936]
UINT8 | g_drm_cd_res2_data [2716]
UINT8 | g_drm_fl_res2_data [2363]
UINT8 HUGE | gif_image [gif_image_size]
const UINT HUGE | gif_image_size = 1851
UINT8 HUGE | jpeg_image [jpeg_image_size]
const UINT HUGE | jpeg_image_size = 16035
UINT8 | kissing [kissing_size]
const UINT | kissing_size = 61
UINT8 HUGE | png_image [png_image_size]
const UINT HUGE | png_image_size = 978
UINT8 | wow [wow_size]
const UINT | wow_size = 64

Define Documentation

#define Apoxi_SampleImages_hpp

Generated on Wed Jan 25 00:17:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/SampleImages.hpp Source File

Applications/ImageBrowser/SampleImages.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SampleImages_hpp)
00011 #define Apoxi_SampleImages_hpp
00014
00015 const UINT devil_size = 61;
00016 const UINT wow_size = 64;
00017 const UINT kissing_size = 61;
00018 const UINT HUGE gif_image_size = 1851;
00019 const UINT HUGE jpeg_image_size = 16035;
00020 const UINT HUGE png_image_size = 978;
00021
00022 extern UINT8 devil[devil_size];
00023 extern UINT8 wow[wow_size];
00024 extern UINT8 kissing[kissing_size];
00025 extern UINT8 HUGE gif_image[gif_image_size];
00026 extern UINT8 HUGE jpeg_image[jpeg_image_size];
00027 extern UINT8 HUGE png_image[png_image_size];
00028
00029 extern UINT8 g_drm_fl_res2_data[2363];
00030 extern UINT8 g_drm_cd_j1k_data[1936];
00031 extern UINT8 g_drm_cd_res2_data[2716];
00032
00033
00035 #endif  // Apoxi_SampleImages_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/SavingProgressWin.cpp File Reference

Applications/ImageBrowser/SavingProgressWin.cpp File Reference

#include "ImageBrowserPreComp.hpp"
#include "SavingProgressWin.hpp"

Include dependency graph for SavingProgressWin.cpp:

Generated on Wed Jan 25 00:18:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/SavingProgressWin.hpp File Reference

Applications/ImageBrowser/SavingProgressWin.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SavingProgressWin

Defines

#define | Mmi_SavingProgressWin_hpp

Define Documentation

#define Mmi_SavingProgressWin_hpp

Generated on Wed Jan 25 00:18:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/SavingProgressWin.hpp Source File

Applications/ImageBrowser/SavingProgressWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_SavingProgressWin_hpp)
00011 #define Mmi_SavingProgressWin_hpp
00014
00015 class SavingProgressWin : public Window {
00016     typedef Window Base;
00017
00018     public:
00019         SavingProgressWin();
00020         ~SavingProgressWin();
00021         void Init();
00022
00023     protected:
00024         virtual void OnLayoutClient();
00025         virtual BOOLEAN OnMessage(const Message &msg);
00026         virtual void OnOpen();
00027         virtual void OnClose();
00028
00029     private:
00030         TextLine m_text_line;
00031         ProgressBar m_progress_bar;
00032 };
00033
00035 #endif  // Mmi_SavingProgressWin_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserSaveWin.cpp File Reference

Applications/ImageBrowser/Common/BrowserSaveWin.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "BrowserSaveWin.hpp"
#include "MediaRefContainer.hpp"
#include "RenameFileDialog.hpp"
#include <Afs/Rfs/Path.hpp>
#include <ImageBrowser/Common/MediaBrowserUtils.hpp>

Include dependency graph for BrowserSaveWin.cpp:

Generated on Wed Jan 25 00:12:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserSaveWin.hpp File Reference

Applications/ImageBrowser/Common/BrowserSaveWin.hpp File Reference

#include <GuiExtensions/MmiDialog.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>

Include dependency graph for BrowserSaveWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BrowserSaveWin

Defines

#define | Apoxi_ImgBrowserSaveWin_hpp

Define Documentation

#define Apoxi_ImgBrowserSaveWin_hpp

Generated on Wed Jan 25 00:12:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserSaveWin.hpp Source File

Applications/ImageBrowser/Common/BrowserSaveWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImgBrowserSaveWin_hpp)
00011 #define Apoxi_ImgBrowserSaveWin_hpp
00014
00015 #include <GuiExtensions/MmiDialog.hpp>
00016 #include <Afs/Rfs/RootFileSystem.hpp>
00017
00018 class MediaRefContainer;
00019
00020 class BrowserSaveWin : public MmiDialog
00021 {
00022     typedef MmiDialog Base;
00023
00024     public:
00025         BrowserSaveWin();
00026         virtual ~BrowserSaveWin();
00027
00031         void Init(BooleanCondition &condition,
00032             const MediaRefContainer &media_refs);
00033
00035         Path GetNewPath() const;
00036
00038         void SetTargetPath(const Path &path);
00039
00041         BOOLEAN GetSuccess() const {
00042             return m_success;
00043         }
00044
00045     protected:
00047         virtual void OnOpen();
00048
00050         virtual void OnLayoutClient();
00051
00053         virtual BOOLEAN OnConfirm();
00054
00056         virtual BOOLEAN OnCancel();
00057
00058
00059     private:
00060         BOOLEAN m_success;
00061
00062         // TO DO enhance dialog for also asking for the storage device Id.
00063         static const WCHAR *m_deviceId;
00064         LineEditor m_file_name;
00065         TextBox m_name;
00066         TextBox m_error_tb;
00067
00068         BooleanCondition *m_condition;
00069         const MediaRefContainer *m_media_refs;
00070         MimeType m_mime_type;
00071 };
00072
00074 #endif  // Apoxi_ImgBrowserSaveWin_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserView.cpp File Reference

Applications/ImageBrowser/Common/BrowserView.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "BrowserView.hpp"
#include "MediaRefContainer.hpp"
#include <Afs/Rfs/File.hpp>

Include dependency graph for BrowserView.cpp:

Generated on Wed Jan 25 00:12:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserView.hpp File Reference

Applications/ImageBrowser/Common/BrowserView.hpp File Reference

#include <GuiExtensions/DrawableObjectListBox.hpp>
#include "MediaRefContainer.hpp"

Include dependency graph for BrowserView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BrowserView

Defines

#define | Apoxi_BrowserView_hpp

Define Documentation

#define Apoxi_BrowserView_hpp

Generated on Wed Jan 25 00:13:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserView.hpp Source File

Applications/ImageBrowser/Common/BrowserView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BrowserView_hpp)
00011 #define Apoxi_BrowserView_hpp
00014
00015 #include <GuiExtensions/DrawableObjectListBox.hpp>
00016 #include "MediaRefContainer.hpp"
00017
00018 //struct MediaRefPtr;
00019 class MediaRefContainer;
00020
00023 class BrowserView : public DrawableObjectListBox
00024 {
00025     typedef DrawableObjectListBox Base;
00026
00027     public:
00028         BrowserView();
00029         virtual ~BrowserView();
00030
00036         void Init(Control *parent, MediaRefContainer &media_refs,
00037             DrawableObjectListBoxModel *model);
00038
00041         virtual void NotifyDelete();
00042
00044         MediaRefPtr& GetSelectedMediaRef();
00045
00047         const MediaRefPtr& GetSelectedMediaRef() const;
00048
00049     private:
00050         MediaRefContainer *m_media_refs;
00051 };
00052
00054 #endif  // Apoxi_BrowserView_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserViewContainer.cpp File Reference

Applications/ImageBrowser/Common/BrowserViewContainer.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "BrowserViewContainer.hpp"
#include <Afs/Rfs/File.hpp>

Include dependency graph for BrowserViewContainer.cpp:

Generated on Wed Jan 25 00:13:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserViewContainer.hpp File Reference

Applications/ImageBrowser/Common/BrowserViewContainer.hpp File Reference

#include "BrowserView.hpp"

Include dependency graph for BrowserViewContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BrowserViewContainer

Defines

#define | Apoxi_BrowserViewContainer_hpp

Define Documentation

#define Apoxi_BrowserViewContainer_hpp

Generated on Wed Jan 25 00:13:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/BrowserViewContainer.hpp Source File

Applications/ImageBrowser/Common/BrowserViewContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BrowserViewContainer_hpp)
00011 #define Apoxi_BrowserViewContainer_hpp
00014
00015 #include "BrowserView.hpp"
00016
00020 class BrowserViewContainer : public DrawableObject
00021 {
00022     typedef DrawableObject Base;
00023
00024     public:
00025         BrowserViewContainer();
00026         BrowserViewContainer(Control *parent, BrowserView &browser_view);
00027         virtual ~BrowserViewContainer();
00028
00033         void Init(Control *parent, BrowserView &browser_view);
00034
00037         virtual void AddView(BrowserView &browser_view);
00038
00041         virtual BOOLEAN RemoveView(BrowserView &browser_view);
00042
00045         virtual void SetActiveView(INT index);
00046
00049         virtual void ToggleView();
00050
00052         virtual INT GetViewCount();
00053
00055         virtual BrowserView *GetActiveView() const;
00056
00059         virtual void Update(INT item_count);
00060
00062         virtual void NotifyDelete();
00063
00064     private:
00065         BrowserView *m_views[5];
00066         INT m_view_cnt;
00067         INT m_active_view;
00068 };
00069
00071 #endif  // Apoxi_BrowserViewContainer_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/FileNameListBoxModel.cpp File Reference

Applications/ImageBrowser/Common/FileNameListBoxModel.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "FileNameListBoxModel.hpp"
#include "MediaRefContainer.hpp"
#include "MetaData.hpp"

Include dependency graph for FileNameListBoxModel.cpp:

Generated on Wed Jan 25 00:13:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/FileNameListBoxModel.hpp File Reference

Applications/ImageBrowser/Common/FileNameListBoxModel.hpp File Reference

#include <GuiExtensions/LabelListBoxModel.hpp>

Include dependency graph for FileNameListBoxModel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileNameListBoxModel
Model for showing filenames stored in a MediaRefContainer. More...

Defines

#define | Apoxi_FileNameListBoxModel_hpp

Define Documentation

#define Apoxi_FileNameListBoxModel_hpp

Generated on Wed Jan 25 00:13:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/FileNameListBoxModel.hpp Source File

Applications/ImageBrowser/Common/FileNameListBoxModel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileNameListBoxModel_hpp)
00011 #define Apoxi_FileNameListBoxModel_hpp
00014
00015 #include <GuiExtensions/LabelListBoxModel.hpp>
00016
00017 class MediaRefContainer;
00018
00020 class FileNameListBoxModel : public LabelListBoxModel
00021 {
00022     typedef LabelListBoxModel Base;
00023
00024     public:
00025         FileNameListBoxModel();
00026         FileNameListBoxModel(DrawableObjectListBox *control,
00027             const MediaRefContainer &media_refs);
00028         virtual ~FileNameListBoxModel();
00029
00030         void Init(DrawableObjectListBox *control,
00031             const MediaRefContainer &media_refs);
00032
00037         virtual const WCHAR* GetCellText(INT index, BOOLEAN highlighted);
00038
00039     private:
00040         const MediaRefContainer *m_media_refs;
00041 };
00042
00044 #endif  // Apoxi_FileNameListBoxModel_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/FileNameView.cpp File Reference

Applications/ImageBrowser/Common/FileNameView.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "FileNameView.hpp"
#include "MediaRefContainer.hpp"

Include dependency graph for FileNameView.cpp:

Generated on Wed Jan 25 00:13:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/FileNameView.hpp File Reference

Applications/ImageBrowser/Common/FileNameView.hpp File Reference

#include "BrowserView.hpp"
#include "FileNameListBoxModel.hpp"

Include dependency graph for FileNameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileNameView
View for showing filenames by the use of a FileNameListBoxModel. More...

Defines

#define | Apoxi_FileNameView_hpp

Define Documentation

#define Apoxi_FileNameView_hpp

Generated on Wed Jan 25 00:13:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/FileNameView.hpp Source File

Applications/ImageBrowser/Common/FileNameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileNameView_hpp)
00011 #define Apoxi_FileNameView_hpp
00014
00015 #include "BrowserView.hpp"
00016 #include "FileNameListBoxModel.hpp"
00017
00019 class FileNameView : public BrowserView
00020 {
00021     typedef BrowserView Base;
00022
00023     public:
00024         FileNameView();
00025         virtual ~FileNameView();
00026
00031         void Init(Control *parent, MediaRefContainer &media_refs);
00032
00033     protected:
00034         virtual BOOLEAN OnMessage(const Message &msg);
00035         virtual void OnGetFocus();
00036
00037     private:
00038         FileNameListBoxModel m_list_model;
00039 };
00040
00042 #endif  // Apoxi_FileNameView_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/InfoDialog.cpp File Reference

Applications/ImageBrowser/Common/InfoDialog.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "InfoDialog.hpp"

Include dependency graph for InfoDialog.cpp:

Generated on Wed Jan 25 00:13:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/InfoDialog.hpp File Reference

Applications/ImageBrowser/Common/InfoDialog.hpp File Reference

#include <GuiExtensions/MmiDialog.hpp>
#include <Gui/TextBox.hpp>

Include dependency graph for InfoDialog.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InfoDialog
Dialog showing some information only. More...

Defines

#define | Apoxi_InfoDialog_hpp

Define Documentation

#define Apoxi_InfoDialog_hpp

Generated on Wed Jan 25 00:13:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/InfoDialog.hpp Source File

Applications/ImageBrowser/Common/InfoDialog.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_InfoDialog_hpp)
00011 #define Apoxi_InfoDialog_hpp
00014
00015 #include <GuiExtensions/MmiDialog.hpp>
00016 #include <Gui/TextBox.hpp>
00017
00019 class InfoDialog : public MmiDialog
00020 {
00021     typedef MmiDialog Base;
00022
00023     public:
00024         InfoDialog();
00025         virtual ~InfoDialog();
00026
00027         void Init();
00028
00030         void SetText(const WString &text);
00031
00032     protected:
00034         virtual BOOLEAN OnConfirm();
00035
00037         virtual void OnLayoutClient();
00038
00039     private:
00040         TextList m_text_box;
00041         WString m_text;
00042 };
00043
00045 #endif  // Apoxi_InfoDialog_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaBrowserPreComp.cpp File Reference

Applications/ImageBrowser/Common/MediaBrowserPreComp.cpp File Reference

#include "MediaBrowserPreComp.hpp"

Include dependency graph for MediaBrowserPreComp.cpp:

Generated on Wed Jan 25 00:13:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaBrowserPreComp.hpp File Reference

Applications/ImageBrowser/Common/MediaBrowserPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for MediaBrowserPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:14:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaBrowserPreComp.hpp Source File

Applications/ImageBrowser/Common/MediaBrowserPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Kernel/Lib.hpp>
00011 #include <Gui/Lib.hpp>
00012 #include <Afs/Ffs/FfsHandler.hpp>
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaBrowserUtils.cpp File Reference

Applications/ImageBrowser/Common/MediaBrowserUtils.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "MediaBrowserUtils.hpp"

Include dependency graph for MediaBrowserUtils.cpp:

Generated on Wed Jan 25 00:14:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaBrowserUtils.hpp File Reference

Applications/ImageBrowser/Common/MediaBrowserUtils.hpp File Reference

#include <GuiExtensions/MmiInfoBox.hpp>

Include dependency graph for MediaBrowserUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaBrowserUtils
Utility class for SB and IB. More...

Defines

#define | Apoxi_MediaBrowserUtils_hpp

Define Documentation

#define Apoxi_MediaBrowserUtils_hpp

Generated on Wed Jan 25 00:14:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaBrowserUtils.hpp Source File

Applications/ImageBrowser/Common/MediaBrowserUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaBrowserUtils_hpp)
00011 #define Apoxi_MediaBrowserUtils_hpp
00014
00015 #include <GuiExtensions/MmiInfoBox.hpp>
00016
00018 class MediaBrowserUtils
00019 {
00020     public:
00021
00023         ~MediaBrowserUtils();
00024
00026         static MediaBrowserUtils* GetInstance();
00027
00028 #if defined(APOXI_INCLUDE_DRM)
00029
00030         WString GetDrmErrorString(INT error_code) const;
00031 #endif
00032
00034         MmiDialog::ReturnId DisplayDlg(const WString& msg,
00035                                         MmiInfoBox::MmiInfoBoxType type = MmiInfoBox::Error) const;
00036
00038         BOOLEAN ValidateFileName(const WString& name);
00039
00040
00042     private:
00043
00045         MediaBrowserUtils();
00046
00048     private:
00049
00051         static MediaBrowserUtils* m_app;
00052
00053 }; // MediaBrowserUtils
00054
00056 #endif // Apoxi_MediaBrowserUtils_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaFilter.cpp File Reference

Applications/ImageBrowser/Common/MediaFilter.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "MediaFilter.hpp"
#include "MediaRef.hpp"
#include "MetaData.hpp"

Include dependency graph for MediaFilter.cpp:

Generated on Wed Jan 25 00:14:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaFilter.hpp File Reference

Applications/ImageBrowser/Common/MediaFilter.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for MediaFilter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageFilter
Base class for filters concerning image references. More...
class | MediaFilter
Base class for filter that can be used by the image or sound browser. More...
class | MimeTypeFilter
class | SoundFilter
Base class for filters concerning sound references. More...

Defines

#define | Apoxi_MediaFilter_hpp

Define Documentation

#define Apoxi_MediaFilter_hpp

Generated on Wed Jan 25 00:14:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaFilter.hpp Source File

Applications/ImageBrowser/Common/MediaFilter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaFilter_hpp)
00011 #define Apoxi_MediaFilter_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016
00017 class MediaRef;
00018
00020 class MediaFilter
00021 {
00022     public:
00023         MediaFilter();
00024         virtual ~MediaFilter();
00025
00027         virtual BOOLEAN IsAllowed(const MediaRef &media_ref) const;
00028 };
00029
00031 class ImageFilter : public MediaFilter
00032 {
00033     public:
00034         ImageFilter();
00035         virtual ~ImageFilter();
00036
00038         virtual BOOLEAN IsAllowed(const MediaRef &media_ref) const;
00039 };
00040
00042 class SoundFilter : public MediaFilter
00043 {
00044     public:
00045         SoundFilter();
00046         virtual ~SoundFilter();
00047
00049         virtual BOOLEAN IsAllowed(const MediaRef &snd_ref) const;
00050 };
00051
00054 class MimeTypeFilter : public MediaFilter
00055 {
00056     typedef MediaFilter Base;
00057
00058     public:
00059         MimeTypeFilter(MimeType mime_type);
00060         virtual ~MimeTypeFilter();
00061
00063         virtual BOOLEAN IsAllowed(const MediaRef &media_ref) const;
00064
00066         virtual void SetMimeType(MimeType mime_type);
00067
00068     private:
00069         MimeType m_mime_type;
00070 };
00071
00073 #endif  // Apoxi_MediaFilter_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaRef.cpp File Reference

Applications/ImageBrowser/Common/MediaRef.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Auxiliary/RamData.hpp>
#include <Auxiliary/Date.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/Services/Service.hpp>
#include <AddOns/Drm/DrmMessage.hpp>
#include <AddOns/MultiMedia/MultiMediaEditorDocument.hpp>
#include <Gui/EditorDocument.hpp>
#include <Common/MmiServices.hpp>
#include <Common/MmiInfoBox.hpp>
#include "MediaRef.hpp"
#include "MetaData.hpp"

Include dependency graph for MediaRef.cpp:

Generated on Wed Jan 25 00:14:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaRef.hpp File Reference

Applications/ImageBrowser/Common/MediaRef.hpp File Reference

#include <Afs/Ffs/FfsTypes.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Auxiliary/BufferedData.hpp>

Include dependency graph for MediaRef.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaRef

Defines

#define | Apoxi_MediaRef_hpp

Define Documentation

#define Apoxi_MediaRef_hpp

Generated on Wed Jan 25 00:14:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaRef.hpp Source File

Applications/ImageBrowser/Common/MediaRef.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaRef_hpp)
00011 #define Apoxi_MediaRef_hpp
00014 #include <Afs/Ffs/FfsTypes.hpp>
00015 #include <Afs/Rfs/Path.hpp>
00016 #if defined(APOXI_INCLUDE_DRM)
00017     #include <Auxiliary/DrmAsset.hpp>
00018 #endif
00019 #include <Auxiliary/BufferedData.hpp>
00020
00021 class MetaData;
00022
00026 class MediaRef
00027 {
00028     protected:
00029         MediaRef();
00030
00031     public:
00032         virtual ~MediaRef();
00033
00035         virtual MetaData& GetMetaData() = 0;
00037         virtual const MetaData& GetMetaData() const = 0;
00038
00040         virtual void SetMetaData(const MetaData &meta_data) = 0;
00041
00042 #if defined(APOXI_INCLUDE_DRM)
00043         virtual WString GetAssetInfo() = 0;
00044 #endif
00045
00047         BOOLEAN operator==(const MediaRef &media_ref) const;
00048
00050         BOOLEAN IsDrmMedia( FfsDrmAttrib &attrib);
00051
00053         BOOLEAN IsDrmMedia();
00054
00055 #if defined(APOXI_INCLUDE_DRM)
00056
00057         INT GetLastDrmError() { return m_last_drm_error; }
00058
00060         void SetLastDrmError(INT drm_error);
00061
00063         DrmAsset* GetDrmAsset();
00064
00067         void OpenRightsIssuerUrl();
00068
00069
00070
00071
00073         const BinData * GetDcf();
00074 #endif
00075
00078         BOOLEAN SendAsMms(const AtomItem* item);
00079
00080
00081
00082     private:
00083 #if defined(APOXI_INCLUDE_DRM)
00084         INT m_last_drm_error;
00085         DrmAsset m_drm_asset;
00086 #endif
00087         AtomItem    *m_ptr_item;
00088
00089 };
00090
00092 #endif  // Apoxi_MediaRef_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaRefContainer.cpp File Reference

Applications/ImageBrowser/Common/MediaRefContainer.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "MediaRefContainer.hpp"
#include "MediaFilter.hpp"
#include "MetaData.hpp"
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for MediaRefContainer.cpp:

Generated on Wed Jan 25 00:14:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaRefContainer.hpp File Reference

Applications/ImageBrowser/Common/MediaRefContainer.hpp File Reference

#include <Auxiliary/ElementList.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Afs/Rfs/Path.hpp>
#include "MediaRef.hpp"
#include "MediaVisitor.hpp"

Include dependency graph for MediaRefContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaRefContainer
struct | MediaRefLinkable
The Linkable wrapping a MediaRef smart pointer. More...

Defines

#define | Apoxi_MediaRefContainer_hpp

Typedefs

typedef NiSharedPtr< File > | FilePtr
typedef NiSharedPtr< MediaRef > | MediaRefPtr

Define Documentation

#define Apoxi_MediaRefContainer_hpp

Generated on Wed Jan 25 00:14:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaRefContainer.hpp Source File

Applications/ImageBrowser/Common/MediaRefContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaRefContainer_hpp)
00011 #define Apoxi_MediaRefContainer_hpp
00014
00015 #include <Auxiliary/ElementList.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017 #include <Afs/Rfs/Path.hpp>
00018 #include "MediaRef.hpp"
00019 #include "MediaVisitor.hpp"
00020
00021
00022 class File;
00023 class MediaFilter;
00024 class ImageBrowserApp;
00025 class SoundBrowserApp;
00026
00027
00028 typedef NiSharedPtr<File> FilePtr;
00029 typedef NiSharedPtr<MediaRef> MediaRefPtr;
00030
00032 struct MediaRefLinkable : public Linkable<MediaRefLinkable>
00033 {
00034     MediaRefPtr m_elem;
00035
00036     explicit MediaRefLinkable(MediaRefPtr &elem) :
00037         m_elem(elem) {}
00038
00039     const MediaRefPtr& operator*() const { return m_elem; }
00040     MediaRefPtr& operator*() { return m_elem; }
00041
00042     BOOLEAN operator==(const MediaRefLinkable &rhs) const {
00043         return m_elem.Get() == rhs.m_elem.Get();
00044     }
00045
00046 };
00047
00048
00058 class MediaRefContainer
00059 {
00060     protected:
00061         MediaRefContainer();
00062         MediaRefContainer(const Path &path);
00063
00064     public:
00066         virtual ~MediaRefContainer();
00067
00071         void Init(const Path &database_path);
00072
00077         virtual BOOLEAN Add(MediaRefPtr &media_ref);
00078
00086         virtual BOOLEAN Delete(MediaRefPtr &media_ref,
00087             BOOLEAN delete_file = FALSE);
00088
00095         BOOLEAN DeleteAt(INT index, BOOLEAN delete_file = FALSE);
00096
00101         virtual BOOLEAN Rename(MediaRefPtr &media_ref, const WString &new_name);
00102
00104         void Clear();
00105
00108         MediaRefPtr& GetElementAt(INT index);
00109
00112         const MediaRefPtr& GetElementAt(INT index) const;
00113
00115         INT GetSize() const { return m_elems.GetSize(); }
00116
00119         INT GetIndex(const MediaRefPtr &media_ref) const;
00120
00124         BOOLEAN MediaRefExists(const Path &path) const;
00125
00130         BOOLEAN ApplyFilter(const MediaFilter &media_filter);
00131
00136         void ApplyVisitorFilter(MediaVisitor* media_visitor, const MediaFilter &media_filter);
00137
00139         void Refresh(MediaFilter *filter = 0);
00140
00146         static BOOLEAN SaveMedia(MediaRefPtr &media_ref, const UINT8 HUGE *content, UINT32 length);
00147
00151         virtual UINT32 GetSizeOfRecord() const = 0;
00152
00157         void SearchForFiles(MediaFilter *app_filter = 0, const WString& storage_device_Id = L"ffs");
00161         void SetDbPath(const Path &path){m_path = path;}
00162
00163     protected:
00164
00165
00166         // Returns a new media reference object of the derived class.
00167         virtual MediaRefPtr CreateMediaRef() const = 0;
00168
00170         virtual FileFilterPtr GetMediaFileFilter() const = 0;
00171
00174         virtual BOOLEAN SetupMediaObject(MediaRefPtr &media_ref) = 0;
00175
00177         virtual BOOLEAN IsInDatabase(const Path& path) const;
00178
00180         Path m_path;
00181
00182     private:
00183
00184         friend class ImageBrowserApp;
00185         friend class SoundBrowserApp;
00186
00188         BOOLEAN Read(MediaFilter *filter  = 0 );
00189
00193         MediaRefPtr ReadMediaRef(INT index, const FilePtr &file) const;
00194
00196         BOOLEAN Write() const;
00197
00203         BOOLEAN WriteMediaRef(INT index, const FilePtr &file) const;
00204
00205         ElementList<MediaRefLinkable> m_elems;
00206         INT32 m_index_counter;
00207 };
00208
00210 #endif  // Apoxi_MediaRefContainer_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaVisitor.cpp File Reference

Applications/ImageBrowser/Common/MediaVisitor.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "MediaVisitor.hpp"
#include "MetaData.hpp"

Include dependency graph for MediaVisitor.cpp:

Generated on Wed Jan 25 00:14:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaVisitor.hpp File Reference

Applications/ImageBrowser/Common/MediaVisitor.hpp File Reference

#include "MediaRef.hpp"
#include "Afs/Rfs/Path.hpp"
#include "Auxiliary/Vector.hpp"

Include dependency graph for MediaVisitor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaPathnameVisitor
class | MediaVisitor

Defines

#define | Apoxi_MediaVisitor_hpp

Define Documentation

#define Apoxi_MediaVisitor_hpp

Generated on Wed Jan 25 00:14:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MediaVisitor.hpp Source File

Applications/ImageBrowser/Common/MediaVisitor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaVisitor_hpp)
00011 #define Apoxi_MediaVisitor_hpp
00014
00015 #include "MediaRef.hpp"
00016 #include "Afs/Rfs/Path.hpp"
00017 #include "Auxiliary/Vector.hpp"
00018
00022 class MediaVisitor
00023 {
00024
00025 protected:
00026     MediaVisitor();
00027
00028 public:
00029     virtual ~MediaVisitor();
00030
00031     // visit a media ref object
00032     virtual void Visit(const MediaRef& media_ref) = 0;
00033 };
00034
00035
00036
00037
00038
00039 class MediaPathnameVisitor : public MediaVisitor
00040 {
00041 public:
00042     MediaPathnameVisitor();
00043
00044     virtual ~MediaPathnameVisitor();
00045
00046     // visit a media ref object
00047     void Visit(const MediaRef& media_ref);
00048
00049     // returns a path array of the visited paths
00050     void GetPaths(Vector<Path> &paths);
00051
00052 private:
00053     Vector<Path> m_paths;
00054 };
00055
00056
00058 #endif  // Apoxi_MediaVisitor_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MetaData.cpp File Reference

Applications/ImageBrowser/Common/MetaData.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include <Afs/Rfs/File.hpp>
#include "MetaData.hpp"

Include dependency graph for MetaData.cpp:

Generated on Wed Jan 25 00:15:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MetaData.hpp File Reference

Applications/ImageBrowser/Common/MetaData.hpp File Reference

#include <Afs/Rfs/PathProfile.hpp>

Include dependency graph for MetaData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MetaData
struct | MetaDataRecord

Defines

#define | Apoxi_MetaData_hpp

Define Documentation

#define Apoxi_MetaData_hpp

Generated on Wed Jan 25 00:15:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/MetaData.hpp Source File

Applications/ImageBrowser/Common/MetaData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MetaData_hpp)
00011 #define Apoxi_MetaData_hpp
00014
00015 #if defined(APOXI_INCLUDE_DRM)
00016     #include <Auxiliary/DrmInfo.hpp>
00017 #endif
00018 #include <Afs/Rfs/PathProfile.hpp>
00019
00024 struct MetaDataRecord {
00025     UINT8 m_mark_delete;
00026     INT32 m_index;
00027     PathProfile m_resource_path_profile;
00028 #if defined(APOXI_INCLUDE_DRM)
00029     DrmInfoPersistStructure m_drm_info;
00030 #endif
00031     UINT32 m_size;
00032
00033     MetaDataRecord();
00034     virtual ~MetaDataRecord();
00035 };
00036
00041 class MetaData
00042 {
00043     public:
00044         MetaData();
00045
00046         virtual ~MetaData();
00047
00048 #if defined(APOXI_INCLUDE_DRM)
00049         void Init(const Path &path, const DrmInfo &drm_info = DrmInfo(),
00050             UINT32 size = 0);
00051 #else
00052         void Init(const Path &path, UINT32 size = 0);
00053 #endif
00054
00055         virtual MetaDataRecord& GetMetaDataRecord() = 0;
00056
00058         virtual const MetaDataRecord& GetMetaDataRecord() const = 0;
00059
00061         Path GetPath() const { return GetMetaDataRecord().m_resource_path_profile; }
00062
00064         void SetPath(const Path &path) { path.WriteTo(GetMetaDataRecord().m_resource_path_profile); }
00065
00066 #if defined(APOXI_INCLUDE_DRM)
00067
00068         void GetDrmInfo(DrmInfo &drm_info) const { drm_info.ReadFrom(GetMetaDataRecord().m_drm_info); }
00069
00071         void SetDrmInfo(const DrmInfo &drm_info) { drm_info.WriteTo(&GetMetaDataRecord().m_drm_info); }
00072 #endif
00073
00075         UINT32 GetSize() const { return GetMetaDataRecord().m_size; }
00076
00078         void SetSize(UINT32 size) { GetMetaDataRecord().m_size = size; }
00079
00081         MimeType GetMimeType() const { return GetPath().GetMimeType(); }
00082
00084         virtual WString GetInfoText() const;
00085
00087         void SetDisplayedName(const WString &displayed_name) {  m_displayed_name = displayed_name; }
00088
00090         const WString& GetDisplayedName() const { return m_displayed_name; }
00091
00092         void SetMarkDelete(BOOLEAN mark_delete);
00093
00094         BOOLEAN GetMarkDelete() const { return GetMetaDataRecord().m_mark_delete; }
00095
00096         void SetIndex(INT32 index) { GetMetaDataRecord().m_index= index; }
00097
00098         INT32 GetIndex() const { return GetMetaDataRecord().m_index; }
00099     private:
00100
00101         WString m_displayed_name;
00102 };
00103
00105 #endif  // Apoxi_MetaData_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/RenameFileDialog.cpp File Reference

Applications/ImageBrowser/Common/RenameFileDialog.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "RenameFileDialog.hpp"
#include <ImageBrowser/Common/MediaBrowserUtils.hpp>

Include dependency graph for RenameFileDialog.cpp:

Generated on Wed Jan 25 00:15:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/RenameFileDialog.hpp File Reference

Applications/ImageBrowser/Common/RenameFileDialog.hpp File Reference

#include <GuiExtensions/MmiDialog.hpp>
#include <Afs/Rfs/Path.hpp>

Include dependency graph for RenameFileDialog.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RenameFileDialog
Dialog for renaming a file with the media browser. More...

Defines

#define | Apoxi_RenameDialog_hpp

Define Documentation

#define Apoxi_RenameDialog_hpp

Generated on Wed Jan 25 00:15:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ImageBrowser/Common/RenameFileDialog.hpp Source File

Applications/ImageBrowser/Common/RenameFileDialog.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RenameDialog_hpp)
00011 #define Apoxi_RenameDialog_hpp
00014
00015 #include <GuiExtensions/MmiDialog.hpp>
00016 #include <Afs/Rfs/Path.hpp>
00017
00019 class RenameFileDialog : public MmiDialog
00020 {
00021     typedef MmiDialog Base;
00022
00023     public:
00024         RenameFileDialog();
00025         virtual ~RenameFileDialog();
00026
00027         void Init();
00028         void Init(Control *control);
00029
00031         WString GetNewFilename() const;
00032
00036         void SetCurrentPath(const Path &current_path);
00037
00039         BOOLEAN GetSuccess() const;
00040
00041     protected:
00043         virtual void OnOpen();
00044
00046         virtual BOOLEAN OnConfirm();
00047
00049         virtual BOOLEAN OnCancel();
00050
00052         virtual void OnLayoutClient();
00053
00054     private:
00055         //TextBox m_current_name;
00056         //TextBox m_file_name;
00057         TextBox m_new_name;
00058         TextBox m_extension;
00059         TextBox m_error_tb;
00060         LineEditor m_new_file_name;
00061         TextBox m_new_extension;
00062
00063         WString m_str_full_file_name;
00064         WString m_str_file_name;
00065         WString m_str_file_extension;
00066
00067
00068         BOOLEAN m_success;
00069
00070 };
00071
00073 #endif  // Apoxi_RenameDialog_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaApp.cpp File Reference

Applications/IrdaApp/IrdaApp.cpp File Reference

#include "IrdaAppPreComp.hpp"
#include <Common/MmiInfoBox.hpp>
#include <Common/MmiAlert.hpp>
#include <Devices/Messages/TransportNotificationMsg.hpp>
#include <Devices/AbstractTransport.hpp>
#include <Irda/IrdaTransport.hpp>
#include <Kernel/VersionInfo.hpp>
#include "IrdaApp.hpp"

Include dependency graph for IrdaApp.cpp:

Functions

ApoxiUseVersionInfo (IrdaApp)

Function Documentation

ApoxiUseVersionInfo ( IrdaApp )

Generated on Wed Jan 25 00:18:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaApp.hpp File Reference

Applications/IrdaApp/IrdaApp.hpp File Reference

#include <Common/MmiApplication.hpp>
#include <Kernel/Timer.hpp>
#include <Devices/AbstractTransport.hpp>

Include dependency graph for IrdaApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IrdaApp

Defines

#define | Mmi_IrdaApp_hpp

Define Documentation

#define Mmi_IrdaApp_hpp

Generated on Wed Jan 25 00:18:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaApp.hpp Source File

Applications/IrdaApp/IrdaApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_IrdaApp_hpp)
00009 #define Mmi_IrdaApp_hpp
00012
00013 #include <Common/MmiApplication.hpp>
00014 #include <Kernel/Timer.hpp>
00015 #include <Devices/AbstractTransport.hpp>
00016
00018
00019
00020 class IrdaApp : public MmiApplication {
00021     typedef MmiApplication Base;
00022
00023     public:
00024
00025
00027         virtual ~IrdaApp();
00028
00030         static IrdaApp * GetInstance() {return &m_irda_app;}
00031
00032     protected:
00033
00035         virtual BOOLEAN OnPropertyNotification(const Property::Notification notification, const Property* property,
00036                                                const DataItem& value);
00037
00038         virtual BOOLEAN OnMessage(const Message &msg);
00040         virtual void OnOpen();
00041
00042
00043     private:
00044         Property m_disable_prop;
00045
00047         static IrdaApp m_irda_app;
00048
00050         IrdaApp();
00051
00053 //      MenuAction m_irda_action;
00056         AbstractTransport::AvState m_state;
00057
00058         Property m_irda_prop;
00059
00060
00061 #if defined(MMI_COMPAT_2_6_0)
00062
00064         void ToggleIndicator(BOOLEAN visible);
00065
00066 #endif
00067 };
00069 #endif  // Mmi_IrdaApp_hpp
00070
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaAppPreComp.cpp File Reference

Applications/IrdaApp/IrdaAppPreComp.cpp File Reference

#include "IrdaAppPreComp.hpp"

Include dependency graph for IrdaAppPreComp.cpp:

Generated on Wed Jan 25 00:18:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaAppPreComp.hpp File Reference

Applications/IrdaApp/IrdaAppPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for IrdaAppPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:19:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaAppPreComp.hpp Source File

Applications/IrdaApp/IrdaAppPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Apc/Lib.hpp>
00013 #include <Adc/Lib.hpp>
00014 #include <Asc/Lib.hpp>
00015
00016 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaAppVersion.cpp File Reference

Applications/IrdaApp/IrdaAppVersion.cpp File Reference

#include "IrdaAppPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include "IrdaAppVersion.hpp"

Include dependency graph for IrdaAppVersion.cpp:

Functions

ApoxiDefVersionInfo (IrdaApp, IRDAVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | IrdaApp | ,
 |  | IRDAVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:19:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaAppVersion.hpp File Reference

Applications/IrdaApp/IrdaAppVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IrdaAppVersion_hpp
#define | IRDAVERSION "2.10.0_TIV_04"

Define Documentation

#define IrdaAppVersion_hpp

#define IRDAVERSION "2.10.0_TIV_04"

Generated on Wed Jan 25 00:19:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaAppVersion.hpp Source File

Applications/IrdaApp/IrdaAppVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(IrdaAppVersion_hpp)
00010 #define IrdaAppVersion_hpp
00011
00012
00013 /*
00014 IrdaAppVersion.hpp contains the official IrdaApp Version which should be used in the
00015 different IrdaAppVersion.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define IRDAVERSION "2.10.0_TIV_04"
00019
00020 #endif  // IrdaAppVersion_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaWin.cpp File Reference

Applications/IrdaApp/IrdaWin.cpp File Reference

#include "IrdaAppPreComp.hpp"
#include <Config/MmiGuiEngineConfig.hpp>
#include <Common/MmiAlert.hpp>
#include <Irda/IrdaTransport.hpp>
#include "IrdaApp.hpp"
#include "IrdaWin.hpp"

Include dependency graph for IrdaWin.cpp:

Generated on Wed Jan 25 00:19:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaWin.hpp File Reference

Applications/IrdaApp/IrdaWin.hpp File Reference

#include <Gui/CheckBoxAction.hpp>
#include <GuiExtensions/MmiMenuWindow.hpp>
#include <GuiExtensions/MmiProgressBox.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <Devices/AbstractTransport.hpp>

Include dependency graph for IrdaWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IrdaWin

Defines

#define | Mmi_IrdaWin_hpp

Define Documentation

#define Mmi_IrdaWin_hpp

Generated on Wed Jan 25 00:19:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/IrdaApp/IrdaWin.hpp Source File

Applications/IrdaApp/IrdaWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_IrdaWin_hpp)
00009 #define Mmi_IrdaWin_hpp
00012
00013 #include <Gui/CheckBoxAction.hpp>
00014 #include <GuiExtensions/MmiMenuWindow.hpp>
00015 #include <GuiExtensions/MmiProgressBox.hpp>
00016 #include <GuiExtensions/ActionAccessor.hpp>
00017 #include <Devices/AbstractTransport.hpp>
00018
00019 class IrdaWin : public MmiMenuWindow {
00020     typedef MmiWindow Base;
00021     public:
00022
00023
00024         IrdaWin();
00025         ~IrdaWin();
00026         void Init();
00027         void ToggleSelection();
00028     protected:
00029         virtual void OnActionExecuted(Action *action);
00030         virtual void OnClose();
00031         virtual void OnOpen();
00032     private:
00034         CheckBoxAction m_disable_action;
00035         MmiProgressBox m_hour_glass;
00036         Action m_select_action;
00037         Action m_close_action;
00038         ActionAccessor m_accessor;
00039         AbstractTransport::AvState m_state;
00040
00041         void DisplayAlert(const WCHAR *msg);
00042
00043
00044 };
00046 #endif  // Mmi_IrdaApp_hpp
00047
00048
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppMsgTypes.cpp File Reference

Applications/Lcs/LcsAppMsgTypes.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LcsAppMsgTypes.hpp"

Include dependency graph for LcsAppMsgTypes.cpp:

Generated on Wed Jan 25 00:19:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppMsgTypes.hpp File Reference

Applications/Lcs/LcsAppMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>
#include <Applications/Lcs/LcsFeatTypes.hpp>
#include <Applications/Lcs/ResultWinBase.hpp>

Include dependency graph for LcsAppMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsAppRegisterForMtlrMsg
class | LcsAppResWinMsg
class | LcsAppTransferLocMsg

Defines

#define | Lcs_LcsAppMsgTypes_hpp

Define Documentation

#define Lcs_LcsAppMsgTypes_hpp

Generated on Wed Jan 25 00:19:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppMsgTypes.hpp Source File

Applications/Lcs/LcsAppMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "APOXI_1.10.0\src\Applications\Lcs\LcsAppMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(Lcs_LcsAppMsgTypes_hpp)
00016 #define Lcs_LcsAppMsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00020 #include <Applications/Lcs/LcsFeatTypes.hpp>
00021 #include <Applications/Lcs/ResultWinBase.hpp>
00022
00023
00024 /* ----------------------------------------------------------------------
00025     Classes
00026     ---------------------------------------------------------------------- */
00027
00028 /*  ======================================================================
00029     Class LcsAppTransferLocMsg
00030     ====================================================================== */
00031
00033 class LcsAppTransferLocMsg : public ApplicationMsg {
00034     public:
00035         LcsAppTransferLocMsg(Application* application, const ClientId& client_id, const MlcNumber& mlc_number);
00036         virtual ~LcsAppTransferLocMsg();
00037
00038         virtual const MsgMetaData& GetMetaData() const;
00039         const ClientId& GetClientId() const { return m_client_id; }
00040         const MlcNumber& GetMlcNumber() const { return m_mlc_number; }
00041         virtual Message* Clone() const;
00042
00043         enum  {
00044             ID = 22232
00045             };
00046
00047     private:
00048         static const MsgMetaData m_meta_data;
00049         ClientId m_client_id;
00050         MlcNumber m_mlc_number;
00051
00052     };
00053
00054
00055 /*  ======================================================================
00056     Class LcsAppRegisterForMtlrMsg
00057     ====================================================================== */
00058
00060 class LcsAppRegisterForMtlrMsg : public ApplicationMsg {
00061     public:
00062         LcsAppRegisterForMtlrMsg(Application* application);
00063         virtual ~LcsAppRegisterForMtlrMsg();
00064
00065         virtual const MsgMetaData& GetMetaData() const;
00066         virtual Message* Clone() const;
00067
00068         enum  {
00069             ID = 22236
00070             };
00071
00072     private:
00073         static const MsgMetaData m_meta_data;
00074
00075     };
00076
00077
00078 /*  ======================================================================
00079     Class LcsAppResWinMsg
00080     ====================================================================== */
00081
00083 class LcsAppResWinMsg : public ApplicationMsg {
00084     public:
00085         LcsAppResWinMsg(Application* application, const ResultWinBase::ResWinAction& event_code);
00086         virtual ~LcsAppResWinMsg();
00087
00088         virtual const MsgMetaData& GetMetaData() const;
00089         const ResultWinBase::ResWinAction& GetEventCode() const { return m_event_code; }
00090         virtual Message* Clone() const;
00091
00092         enum  {
00093             ID = 22237
00094             };
00095
00096     private:
00097         static const MsgMetaData m_meta_data;
00098         ResultWinBase::ResWinAction m_event_code;
00099
00100     };
00101
00102 #endif // Lcs_LcsAppMsgTypes_hpp
00103
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppPreComp.cpp File Reference

Applications/Lcs/LcsAppPreComp.cpp File Reference

#include "LcsAppPreComp.hpp"

Include dependency graph for LcsAppPreComp.cpp:

Generated on Wed Jan 25 00:20:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppPreComp.hpp File Reference

Applications/Lcs/LcsAppPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for LcsAppPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:20:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppPreComp.hpp Source File

Applications/Lcs/LcsAppPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Asc/Lib.hpp>
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppUtils.cpp File Reference

Applications/Lcs/LcsAppUtils.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LcsAppUtils.hpp"
#include "LcsWapIntf.hpp"
#include <AddOns/Lcs/Common/LcsProvider.hpp>
#include <LcsTransports/Settings/LcsRegUri.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <Afs/Registry.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for LcsAppUtils.cpp:

Generated on Wed Jan 25 00:20:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppUtils.hpp File Reference

Applications/Lcs/LcsAppUtils.hpp File Reference

#include <Gui/MessageBox.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for LcsAppUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsAppUtils

Defines

#define | Mmi_LcsAppUtils_hpp

Define Documentation

#define Mmi_LcsAppUtils_hpp

Generated on Wed Jan 25 00:20:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsAppUtils.hpp Source File

Applications/Lcs/LcsAppUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsAppUtils_hpp)
00010 #define Mmi_LcsAppUtils_hpp
00011
00012 #include <Gui/MessageBox.hpp>
00013 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00014
00015 class WString;
00016 struct LcsMmiQos;
00017 struct ClientId;
00018 struct MlcNumber;
00019
00022 class LcsAppUtils
00023 {
00024     public:
00025
00027         ~LcsAppUtils();
00028
00030         static LcsAppUtils* GetInstance();
00031
00033         static void ReleaseInstance();
00034
00036         void DisplayMsg() const;
00037
00039         void DisplayMsg(const WCHAR* err_str) const;
00040
00042         BOOLEAN IsReqSent() { return m_is_req_sent; }
00043
00045         void SetReqSent(BOOLEAN flag) { m_is_req_sent = flag; }
00046
00048         BOOLEAN GetData(const CHAR* data_type, WString& data);
00049
00051         BOOLEAN GetData(const CHAR* data_type, INT32& data);
00052
00054         BOOLEAN StoreData(const CHAR* data_type, const WString& data) const;
00055
00057         void ProcessSelfLocation();
00058
00060         void ProcessTransferLocation(const ClientId& client_id, const MlcNumber& mlc_number);
00061
00063         void SendAbortReq() const;
00064
00066         void ProcessLocationError(LcsErrorCode err_code);
00067
00069         void ProcessDispMapDecision(BOOLEAN feature_wai);
00070
00072         BOOLEAN FormQos(LcsMmiQos& lcs_mmi_qos);
00073
00074
00076     private:
00077
00079         LcsAppUtils();
00080
00082     private:
00083
00085         static LcsAppUtils* m_self;
00086
00089         MessageBox m_err_msg_box;
00090
00092         BOOLEAN m_is_req_sent;
00093
00094 }; // LcsAppUtils
00095
00096 #endif // Mmi_LcsAppUtils_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsFeatTypes.hpp File Reference

Applications/Lcs/LcsFeatTypes.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Mmi_LcsFeatType_hpp

Enumerations

enum | FeatureType { GpsReceiver = 0, WhereAmI, FriendFinder }

Define Documentation

#define Mmi_LcsFeatType_hpp

Enumeration Type Documentation

enum FeatureType

Enumerator:
GpsReceiver
WhereAmI
FriendFinder

Generated on Wed Jan 25 00:20:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsFeatTypes.hpp Source File

Applications/Lcs/LcsFeatTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsFeatType_hpp)
00010 #define Mmi_LcsFeatType_hpp
00011
00012 enum FeatureType
00013 {
00014     GpsReceiver = 0,
00015     WhereAmI,
00016     FriendFinder
00017 };
00018
00019 #endif // Mmi_LcsFeatType_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsMainApp.cpp File Reference

Applications/Lcs/LcsMainApp.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LcsMainApp.hpp"
#include "LcsAppMsgTypes.hpp"
#include "LcsWString.hpp"
#include "LcsAppUtils.hpp"
#include "LcsWapIntf.hpp"
#include "LocResController.hpp"
#include <AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>
#include <AddOns/Lcs/GLTP/GltpMsgTypes.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>
#include <AddOns/Lcs/Common/LcsProvider.hpp>
#include <Common/MmiInfoBox.hpp>

Include dependency graph for LcsMainApp.cpp:

Generated on Wed Jan 25 00:21:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsMainApp.hpp File Reference

Applications/Lcs/LcsMainApp.hpp File Reference

#include <Common/MmiApplication.hpp>
#include "LocationResultWin.hpp"
#include "TransferLocationDialogWin.hpp"

Include dependency graph for LcsMainApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsMainApp

Defines

#define | Mmi_LcsMainApp_hpp

Define Documentation

#define Mmi_LcsMainApp_hpp

Generated on Wed Jan 25 00:21:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsMainApp.hpp Source File

Applications/Lcs/LcsMainApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsMainApp_hpp)
00010 #define Mmi_LcsMainApp_hpp
00011
00012 #include <Common/MmiApplication.hpp>
00013
00014 #include "LocationResultWin.hpp"
00015 #include "TransferLocationDialogWin.hpp"
00016
00017 struct GpsFixData;
00018
00024 class LcsMainApp : public MmiApplication
00025 {
00026     typedef MmiApplication Base;
00027
00029     public:
00030
00032         virtual ~LcsMainApp();
00033
00035         static LcsMainApp* GetInstance();
00036
00037
00039     protected:
00040
00042         virtual void OnStartup();
00043
00045         virtual BOOLEAN OnMessage(const Message& msg);
00046
00048         virtual void OnOpen();
00049
00051         virtual void OnClose();
00052
00054         virtual BOOLEAN OnTimeout(const Timer& timer);
00055
00057         virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00058
00060         virtual BOOLEAN OnContextFeatureTriggered(const FeatureID& feature_id, const DataItem& context_item);
00061
00062
00064     private:
00065
00067         LcsMainApp();
00068
00070         void ProcessNotificationInvoke(const Message& msg);
00071
00073         void ProcessLocationResult(const Message& msg);
00074
00076         void ProcessGpsFixData(const GpsFixData& gps_fix_data, WString& fix_data_text, WString& sv_text);
00077
00078
00080     private:
00081
00083         static LcsMainApp m_lcs_app;
00084
00086         enum LcsFeatureId {
00087             SelfLocation,
00088             TransferLocation,
00089             WhereAmI,
00090             FriendFinder,
00091             LcsFeatureCnt
00092         };
00093
00095         Feature m_features[LcsFeatureCnt];
00096
00098         INT m_feature_invoked;
00099
00101         enum LcsContextFeatureId {
00102             LcsPrevResult,
00103             LcsNextResult,
00104             LcsPauseResultUpdate,
00105             LcsCloseResultWin,
00106             LcsAbortPosnFix,
00107             LcsContextFeatureCnt
00108         };
00109
00111         ContextFeature m_context_features[LcsContextFeatureCnt];
00112
00115         TransferLocationDialog m_transfer_loc_dlg;
00116
00117 }; // LcsMainApp
00118
00119 #endif // Mmi_LcsMainApp_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsMainMenuWin.cpp File Reference

Applications/Lcs/LcsMainMenuWin.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LcsMainMenuWin.hpp"
#include "LcsAppMsgTypes.hpp"
#include "LcsAppUtils.hpp"
#include "LcsWapIntf.hpp"

Include dependency graph for LcsMainMenuWin.cpp:

Generated on Wed Jan 25 00:21:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsMainMenuWin.hpp File Reference

Applications/Lcs/LcsMainMenuWin.hpp File Reference

#include "LcsOptionsMenuWin.hpp"
#include <GuiExtensions/MmiMenuWindow.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <Gui/Action.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for LcsMainMenuWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsMainMenuWin

Defines

#define | Mmi_LcsMainMenuWin_hpp

Define Documentation

#define Mmi_LcsMainMenuWin_hpp

Generated on Wed Jan 25 00:21:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsMainMenuWin.hpp Source File

Applications/Lcs/LcsMainMenuWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsMainMenuWin_hpp)
00010 #define Mmi_LcsMainMenuWin_hpp
00011
00012 #include "LcsOptionsMenuWin.hpp"
00013
00014 #include <GuiExtensions/MmiMenuWindow.hpp>
00015 #include <GuiExtensions/ActionAccessor.hpp>
00016 #include <Gui/Action.hpp>
00017 #include <Auxiliary/WString.hpp>
00018
00025 class LcsMainMenuWin : public MmiMenuWindow
00026 {
00027     typedef MmiMenuWindow Base;
00028
00030     public:
00031
00033         LcsMainMenuWin();
00034
00036         virtual ~LcsMainMenuWin();
00037
00039         void Init();
00040
00042         void SetStatus(INT status);
00043
00045         void SetTime(WString time_str);
00046
00047
00049     protected:
00050
00052         virtual void OnOpen();
00053
00055         virtual void OnGetFocus();
00056
00058         virtual void OnActionExecuted(Action *action);
00059
00060
00062     private:
00063
00065         ActionAccessor m_accessor;
00066
00068         Action m_gps_recv_action;
00069
00071         Action m_wai_action;
00072
00074         Action m_ff_action;
00075
00077         LcsOptionsMenuWin m_lcs_options_dlg;
00078
00080         INT m_status;
00081
00083         WString m_real_time;
00084
00085 }; // LcsMainMenuWin
00086
00087 #endif // Mmi_LcsMainMenuWin_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsOptionsMenuWin.cpp File Reference

Applications/Lcs/LcsOptionsMenuWin.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LcsOptionsMenuWin.hpp"
#include "LcsAppMsgTypes.hpp"

Include dependency graph for LcsOptionsMenuWin.cpp:

Generated on Wed Jan 25 00:21:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsOptionsMenuWin.hpp File Reference

Applications/Lcs/LcsOptionsMenuWin.hpp File Reference

#include "TransferLocationDialogWin.hpp"
#include <GuiExtensions/MmiMenuWindow.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <Gui/Action.hpp>

Include dependency graph for LcsOptionsMenuWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsOptionsMenuWin

Defines

#define | Mmi_LcsOptionsMenuWin_hpp

Define Documentation

#define Mmi_LcsOptionsMenuWin_hpp

Generated on Wed Jan 25 00:21:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsOptionsMenuWin.hpp Source File

Applications/Lcs/LcsOptionsMenuWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsOptionsMenuWin_hpp)
00010 #define Mmi_LcsOptionsMenuWin_hpp
00011
00012 #include "TransferLocationDialogWin.hpp"
00013
00014 #include <GuiExtensions/MmiMenuWindow.hpp>
00015 #include <GuiExtensions/ActionAccessor.hpp>
00016 #include <Gui/Action.hpp>
00017
00023 class LcsOptionsMenuWin : public MmiMenuWindow
00024 {
00025     typedef MmiMenuWindow Base;
00026
00028     public:
00029
00031         LcsOptionsMenuWin();
00032
00034         virtual ~LcsOptionsMenuWin();
00035
00037         void Init();
00038
00040         void SetStatus(INT status);
00041
00043         void SetTime(WString time_str);
00044
00045
00047     protected:
00048
00050         virtual void OnOpen();
00051
00053         virtual void OnActionExecuted(Action *action);
00054
00055
00057     private:
00058
00060         ActionAccessor m_accessor;
00061
00063         Action m_self_loc_action;
00064
00066         Action m_transfer_loc_action;
00067
00070         TransferLocationDialog m_transfer_loc_dlg;
00071
00073         INT m_status;
00074
00076         WString m_real_time;
00077
00078 }; // LcsOptionsMenuWin
00079
00080 #endif // Mmi_LcsOptionsMenuWin_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsWapIntf.cpp File Reference

Applications/Lcs/LcsWapIntf.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LcsWapIntf.hpp"
#include "LcsAppUtils.hpp"
#include <LcsTransports/Settings/LcsRegUri.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for LcsWapIntf.cpp:

Generated on Wed Jan 25 00:22:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsWapIntf.hpp File Reference

Applications/Lcs/LcsWapIntf.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsWapIntf

Defines

#define | Mmi_LcsWapIntf_hpp

Define Documentation

#define Mmi_LcsWapIntf_hpp

Generated on Wed Jan 25 00:22:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsWapIntf.hpp Source File

Applications/Lcs/LcsWapIntf.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsWapIntf_hpp)
00010 #define Mmi_LcsWapIntf_hpp
00011
00014 class LcsWapIntf
00015 {
00016     public:
00017
00019         ~LcsWapIntf();
00020
00022         static LcsWapIntf* GetInstance();
00023
00025         static void ReleaseInstance();
00026
00028         BOOLEAN DisplayMap(BOOLEAN feature_wai);
00029
00031         BOOLEAN IsDispMapAllowed() { return m_is_disp_allowed; }
00032
00034         BOOLEAN IsBrowserOpen() { return m_is_open; }
00035
00037         void SetBrowserOpen(BOOLEAN is_open) { m_is_open = is_open; }
00038
00040         void SetDispMapAllowed(BOOLEAN is_disp_allowed) { m_is_disp_allowed = is_disp_allowed; }
00041
00043     private:
00044
00046         LcsWapIntf();
00047
00049     private:
00050
00052         static LcsWapIntf* m_self;
00053
00056         BOOLEAN m_is_disp_allowed;
00057
00059         BOOLEAN m_is_open;
00060
00061 }; // LcsWapIntf
00062
00063 #endif // Mmi_LcsWapIntf_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsWString.cpp File Reference

Applications/Lcs/LcsWString.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LcsWString.hpp"
#include <Auxiliary/String.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for LcsWString.cpp:

Generated on Wed Jan 25 00:22:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsWString.hpp File Reference

Applications/Lcs/LcsWString.hpp File Reference

#include <Auxiliary/WString.hpp>

Include dependency graph for LcsWString.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsWString

Defines

#define | Mmi_LcsWString_hpp

Define Documentation

#define Mmi_LcsWString_hpp

Generated on Wed Jan 25 00:22:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LcsWString.hpp Source File

Applications/Lcs/LcsWString.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsWString_hpp)
00010 #define Mmi_LcsWString_hpp
00011
00012 #include <Auxiliary/WString.hpp>
00013
00014 struct ClientId;
00015 struct ClientName;
00016
00017 class LcsWString : public WString
00018 {
00019     typedef WString Base;
00020
00022     public:
00023
00025         LcsWString();
00026
00028         LcsWString(const WString& rhs);
00029
00031         ~LcsWString();
00032
00034         LcsWString& operator =(const WString& rhs);
00035
00037         LcsWString& operator <<(const CHAR* rhs);
00038
00040         LcsWString& operator <<(UINT16 invoke_id);
00041
00043         LcsWString& operator <<(const ClientId& client_id);
00044
00046         LcsWString& operator <<(const ClientName& client_name);
00047
00049         operator UINT32() const;
00050
00052         operator INT32() const;
00053
00055         void ConvertToBcd(BYTE* type, INT size);
00056
00057 }; // LcsWString
00058
00059 #endif // Mmi_LcsWString_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocationResultWin.cpp File Reference

Applications/Lcs/LocationResultWin.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LocationResultWin.hpp"

Include dependency graph for LocationResultWin.cpp:

Variables

const WCHAR * | c_fix_data_title_text = L"Fix Data"
const WCHAR * | c_loc_res_title_text = L"Result"

Variable Documentation

const WCHAR* c_fix_data_title_text = L"Fix Data"

const WCHAR* c_loc_res_title_text = L"Result"

Generated on Wed Jan 25 00:22:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocationResultWin.hpp File Reference

Applications/Lcs/LocationResultWin.hpp File Reference

#include "ResultWinBase.hpp"
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for LocationResultWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LocationResultWin
This window displays the position fix data. More...

Defines

#define | Mmi_LocationResultWin_hpp

Define Documentation

#define Mmi_LocationResultWin_hpp

Generated on Wed Jan 25 00:22:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocationResultWin.hpp Source File

Applications/Lcs/LocationResultWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LocationResultWin_hpp)
00010 #define Mmi_LocationResultWin_hpp
00011
00012 #include "ResultWinBase.hpp"
00013
00014 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00015
00017 class LocationResultWin : public ResultWinBase
00018 {
00019     typedef ResultWinBase Base;
00020
00022     public:
00023
00025         LocationResultWin();
00026
00028         virtual ~LocationResultWin();
00029
00031         void Init();
00032
00034         void SetLocationEstimate(const LocationEstimate& loc_estimate, BOOLEAN first_half);
00035
00037         void SetGpsFixData(const GpsFixData& gps_fix_data, BOOLEAN first_half);
00038
00040         const WString& GetTitleText() const { return m_title_text; }
00041
00042
00044     protected:
00045
00047         virtual void OnLayoutClient();
00048
00049
00051     private:
00052
00054         TextBox m_label5;
00055
00057         TextBox m_data5;
00058
00060         WString m_title_text;
00061
00062 }; // LocationResultWin
00063
00064 #endif // Mmi_LocationResultWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocationVerifWin.cpp File Reference

Applications/Lcs/LocationVerifWin.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LocationVerifWin.hpp"
#include "LcsAppMsgTypes.hpp"
#include <Config/MmiGuiEngineConfig.hpp>

Include dependency graph for LocationVerifWin.cpp:

Generated on Wed Jan 25 00:23:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocationVerifWin.hpp File Reference

Applications/Lcs/LocationVerifWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <Gui/Action.hpp>

Include dependency graph for LocationVerifWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LocationVerifWin

Defines

#define | Mmi_LocationVerifWin_hpp

Define Documentation

#define Mmi_LocationVerifWin_hpp

Generated on Wed Jan 25 00:23:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocationVerifWin.hpp Source File

Applications/Lcs/LocationVerifWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LocationVerifWin_hpp)
00010 #define Mmi_LocationVerifWin_hpp
00011
00012 #include <GuiExtensions/MmiWindow.hpp>
00013 #include <Gui/Action.hpp>
00014
00017 class LocationVerifWin : public MmiWindow
00018 {
00019     typedef MmiWindow Base;
00020
00022     public:
00023
00025         LocationVerifWin();
00026
00028         virtual ~LocationVerifWin();
00029
00031         void Init();
00032
00034         void SetData(INT invoke_id, const WString& text) { m_invoke_id = invoke_id; m_verif_text = text; }
00035
00037         void SetTime(WString time_str);
00038
00039
00040     // Implementation for derived classes
00041     protected:
00042
00044         virtual void OnOpen();
00045
00047         virtual BOOLEAN OnConfirm();
00048
00050         virtual BOOLEAN OnCancel();
00051
00052
00054     private:
00055
00057         TextBox m_verif_text_box;
00058
00060         WString m_verif_text;
00061
00063         UINT16 m_invoke_id;
00064
00066         ConfirmAction m_resp_yes_action;
00067
00069         CancelAction m_resp_no_action;
00070
00072         SoftkeyBar  m_softkey_bar;
00073
00075         WString m_real_time;
00076
00077 }; // LocationVerifWin
00078
00079 #endif // Mmi_LocationVerifWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocResController.cpp File Reference

Applications/Lcs/LocResController.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "LocResController.hpp"
#include <Auxiliary/WString.hpp>

Include dependency graph for LocResController.cpp:

Variables

const INT | c_crossover_win_id = c_max_loc_win_id + 1
const INT | c_max_loc_win_id = 4
const INT | c_show_satellite_graph = 1

Variable Documentation

const INT c_crossover_win_id = c_max_loc_win_id + 1

const INT c_max_loc_win_id = 4

const INT c_show_satellite_graph = 1

Generated on Wed Jan 25 00:23:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocResController.hpp File Reference

Applications/Lcs/LocResController.hpp File Reference

#include "LocationResultWin.hpp"
#include "SatteliteInfoWin.hpp"
#include "SatteliteGraphWin.hpp"
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for LocResController.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LocResController
Class for controling position fix data display. More...

Defines

#define | Mmi_LocResController_hpp

Define Documentation

#define Mmi_LocResController_hpp

Generated on Wed Jan 25 00:23:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/LocResController.hpp Source File

Applications/Lcs/LocResController.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LocResController_hpp)
00010 #define Mmi_LocResController_hpp
00011
00012 #include "LocationResultWin.hpp"
00013 #include "SatteliteInfoWin.hpp"
00014 #include "SatteliteGraphWin.hpp"
00015
00016 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00017
00019 class LocResController
00020 {
00022     public:
00023
00025         virtual ~LocResController();
00026
00028         static LocResController* GetInstance();
00029
00031         static void ReleaseInstance();
00032
00034         void Init();
00035
00037         void HandleWinEvent(ResultWinBase::ResWinAction event_code);
00038
00040         void Open(const LocationEstimate& loc_estimate);
00041
00043         void UpdateTitle();
00044
00046         void SetStatus(INT32 conn_status);
00047
00048
00050     private:
00051
00053         static LocResController* m_self;
00054
00056         enum LocResWinState {
00058             InLocationWin,
00060             CrossLocWinToSatGraph,
00062             CrossSatGraphToLocWin,
00064             CrossSatGraphToSatData,
00066             CrossSatDataToSatGraph,
00068             InSatDataWin,
00070             Invalid
00071         };
00072
00078         UINT8 m_counter;
00079
00081         BOOLEAN m_pause;
00082
00084         INT32 m_conn_status;
00085
00087         LocationEstimate m_old_loc_estimate;
00088
00090         LocationEstimate m_new_loc_estimate;
00091
00093         LocationResultWin m_loc_res_win;
00094
00096         SatteliteGraphWin m_sat_graph_win;
00097
00099         SatteliteInfoWin m_sat_info_win;
00100
00103         Timer m_timer;
00104
00105
00106     private:
00107
00109         LocResController();
00110
00112         void DisplaySatelliteInfo();
00113
00115         void DisplayPositionInfo();
00116
00118         void ProcessWinState(LocResWinState win_state);
00119
00120 }; // LocResController
00121
00122 #endif // Mmi_LocResController_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/ResultWinBase.cpp File Reference

Applications/Lcs/ResultWinBase.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "ResultWinBase.hpp"

Include dependency graph for ResultWinBase.cpp:

Generated on Wed Jan 25 00:23:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/ResultWinBase.hpp File Reference

Applications/Lcs/ResultWinBase.hpp File Reference

#include <Common/MmiWindow.hpp>

Include dependency graph for ResultWinBase.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ResultWinBase

Defines

#define | Mmi_ResultWinBase_hpp

Define Documentation

#define Mmi_ResultWinBase_hpp

Generated on Wed Jan 25 00:23:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/ResultWinBase.hpp Source File

Applications/Lcs/ResultWinBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_ResultWinBase_hpp)
00010 #define Mmi_ResultWinBase_hpp
00011
00012 #include <Common/MmiWindow.hpp>
00013
00017 class ResultWinBase : public MmiWindow
00018 {
00019     typedef MmiWindow Base;
00020
00022     public:
00023
00024         enum ResWinAction
00025         {
00026             ViewPrevious = 0,
00027             ViewNext,
00028             Pause,
00029             CloseWindow,
00030             Invalid
00031         };
00032
00033
00035         ResultWinBase();
00036
00038         virtual ~ResultWinBase();
00039
00041         void Init();
00042
00043
00045     protected:
00046
00048         TextBox m_label1;
00049
00051         TextBox m_label2;
00052
00054         TextBox m_label3;
00055
00057         TextBox m_label4;
00058
00060         TextBox m_data1;
00061
00063         TextBox m_data2;
00064
00066         TextBox m_data3;
00067
00069         TextBox m_data4;
00070
00071 }; // ResultWinBase
00072
00073 #endif // Mmi_ResultWinBase_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/SatteliteGraphWin.cpp File Reference

Applications/Lcs/SatteliteGraphWin.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "SatteliteGraphWin.hpp"
#include <Gui/TextFormat.hpp>

Include dependency graph for SatteliteGraphWin.cpp:

Variables

const WCHAR * c_sat_graph_title_text = L"SV Strength"

Variable Documentation

const WCHAR* c_sat_graph_title_text = L"SV Strength"

Generated on Wed Jan 25 00:23:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/SatteliteGraphWin.hpp File Reference

Applications/Lcs/SatteliteGraphWin.hpp File Reference

#include <AddOns/Lcs/Common/LcsTypes.hpp>
#include <Common/MmiWindow.hpp>

Include dependency graph for SatteliteGraphWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SatteliteGraphWin
This window displays the position fix data. More...
struct | SatteliteGraphWin::SatelliteBar
Satellite info to be shown for each bar of the graph.

Defines

#define | Mmi_SatteliteGraphWin_hpp

Define Documentation

#define Mmi_SatteliteGraphWin_hpp

Generated on Wed Jan 25 00:23:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/SatteliteGraphWin.hpp Source File

Applications/Lcs/SatteliteGraphWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SatteliteGraphWin_hpp)
00010 #define Mmi_SatteliteGraphWin_hpp
00011
00012 #include <AddOns/Lcs/Common/LcsTypes.hpp>
00013 #include <Common/MmiWindow.hpp>
00014
00016 class SatteliteGraphWin : public MmiWindow
00017 {
00018     typedef MmiWindow Base;
00019
00021     public:
00022
00024         SatteliteGraphWin();
00025
00027         virtual ~SatteliteGraphWin();
00028
00030         void Init();
00031
00033         void SetGraphData(SatelliteInfo sat_info[], UINT8 num_sats);
00034
00036         const WCHAR* GetTitleText() const;
00037
00038
00040     protected:
00041
00043         virtual void OnPaint(const Rect& repaint_rect);
00044
00045
00047     private:
00048
00050         struct SatelliteBar {
00051             // Id of the tracked satellite
00052             UINT8 m_sat_id;
00053             // Strength (in dB) of the tracked satellite
00054             INT16 m_sig_strength;
00055         } m_sat_bar[MAX_SATS];
00056
00057 }; // SatteliteGraphWin
00058
00059 #endif // Mmi_SatteliteGraphWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/SatteliteInfoWin.cpp File Reference

Applications/Lcs/SatteliteInfoWin.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "SatteliteInfoWin.hpp"
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for SatteliteInfoWin.cpp:

Variables

const WCHAR * c_sat_info_title_text = L"SV Info"

Variable Documentation

const WCHAR* c_sat_info_title_text = L"SV Info"

Generated on Wed Jan 25 00:24:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/SatteliteInfoWin.hpp File Reference

Applications/Lcs/SatteliteInfoWin.hpp File Reference

#include "ResultWinBase.hpp"

Include dependency graph for SatteliteInfoWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SatteliteInfoWin
This window displays the position fix data. More...

Defines

#define | Mmi_SatteliteInfoWin_hpp

Define Documentation

#define Mmi_SatteliteInfoWin_hpp

Generated on Wed Jan 25 00:24:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/SatteliteInfoWin.hpp Source File

Applications/Lcs/SatteliteInfoWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SatteliteInfoWin_hpp)
00010 #define Mmi_SatteliteInfoWin_hpp
00011
00012 #include "ResultWinBase.hpp"
00013
00014 struct SatelliteInfo;
00015
00017 class SatteliteInfoWin : public ResultWinBase
00018 {
00019     typedef ResultWinBase Base;
00020
00022     public:
00023
00025         SatteliteInfoWin();
00026
00028         virtual ~SatteliteInfoWin();
00029
00031         void Init();
00032
00034         void SetSatelliteData(const SatelliteInfo& sat_info);
00035
00037         const WCHAR* GetTitleText() const;
00038
00039
00041     protected:
00042
00044         virtual void OnLayoutClient();
00045
00046
00048     private:
00049
00051         TextBox m_label5;
00052
00054         TextBox m_label6;
00055
00057         TextBox m_label7;
00058
00060         TextBox m_data5;
00061
00063         TextBox m_data6;
00064
00066         TextBox m_data7;
00067
00068 }; // SatteliteInfoWin
00069
00070 #endif // Mmi_SatteliteInfoWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/TransferLocationDialogWin.cpp File Reference

Applications/Lcs/TransferLocationDialogWin.cpp File Reference

#include "LcsAppPreComp.hpp"
#include "TransferLocationDialogWin.hpp"
#include "LcsAppMsgTypes.hpp"
#include "LcsWString.hpp"
#include "LcsAppUtils.hpp"
#include <LcsTransports/Settings/LcsRegUri.hpp>
#include <AddOns/Lcs/Common/LcsTypes.hpp>

Include dependency graph for TransferLocationDialogWin.cpp:

Generated on Wed Jan 25 00:24:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/TransferLocationDialogWin.hpp File Reference

Applications/Lcs/TransferLocationDialogWin.hpp File Reference

#include <Common/MmiWindow.hpp>

Include dependency graph for TransferLocationDialogWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TransferLocationDialog
Class for transfer location window. More...

Defines

#define | Mmi_TransferLocationDialogWin_hpp

Define Documentation

#define Mmi_TransferLocationDialogWin_hpp

Generated on Wed Jan 25 00:24:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/Lcs/TransferLocationDialogWin.hpp Source File

Applications/Lcs/TransferLocationDialogWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_TransferLocationDialogWin_hpp)
00010 #define Mmi_TransferLocationDialogWin_hpp
00011
00012 #include <Common/MmiWindow.hpp>
00013
00015 class TransferLocationDialog : public MmiWindow
00016 {
00017     typedef MmiWindow Base;
00018
00020     public:
00021
00023         TransferLocationDialog();
00024
00026         virtual ~TransferLocationDialog();
00027
00029         void Init();
00030
00031
00033     protected:
00034
00036         virtual void OnOpen();
00037
00039         virtual void OnClose();
00040
00042         virtual BOOLEAN OnConfirm();
00043
00045         virtual BOOLEAN OnCancel();
00046
00048         virtual void OnLayoutClient();
00049
00050
00052     private:
00053
00055         TextBox m_label_mlc_number;
00056
00058         TextBox m_label_client_id;
00059
00061         LineEditor m_client_id;
00062
00064         LineEditor m_mlc_number;
00065
00066 }; // TransferLocationDialog
00067
00068 #endif // Mmi_TransferLocationDialogWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpAppMsgTypes.cpp File Reference

Applications/LcsTransports/GLTP/GltpAppMsgTypes.cpp File Reference

#include "GltpAppPreComp.hpp"
#include "GltpAppMsgTypes.hpp"

Include dependency graph for GltpAppMsgTypes.cpp:

Functions

OutputStream & | operator<< (OutputStream &ostr, const OnDataRcvdMsg &cls)
InputStream & | operator>> (InputStream &istr, OnDataRcvdMsg &cls)

Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const OnDataRcvdMsg & | cls
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | OnDataRcvdMsg & | cls
 | ) |

Generated on Wed Jan 25 00:24:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpAppMsgTypes.hpp File Reference

Applications/LcsTransports/GLTP/GltpAppMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Kernel/InputStream.hpp>
#include <Kernel/OutputStream.hpp>

Include dependency graph for GltpAppMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | OnDataRcvdMsg

Defines

#define | LcsTransports_GLTP_GltpAppMsgTypes_hpp

Define Documentation

#define LcsTransports_GLTP_GltpAppMsgTypes_hpp

Generated on Wed Jan 25 00:24:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpAppMsgTypes.hpp Source File

Applications/LcsTransports/GLTP/GltpAppMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "APOXI_1.10.0\src\Applications\LcsTransports\GLTP\GltpAppMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(LcsTransports_GLTP_GltpAppMsgTypes_hpp)
00016 #define LcsTransports_GLTP_GltpAppMsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Kernel/InputStream.hpp>
00020 #include <Kernel/OutputStream.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class OnDataRcvdMsg
00029     ====================================================================== */
00030
00032 class OnDataRcvdMsg : public ApplicationMsg {
00033     public:
00034         OnDataRcvdMsg(Application* application, BYTE* buffer, INT size);
00035         virtual ~OnDataRcvdMsg();
00036
00037         virtual const MsgMetaData& GetMetaData() const;
00038         BYTE* GetBuffer() const { return m_buffer; }
00039         INT GetSize() const { return m_size; }
00040         virtual Message* Clone() const;
00041 #if !defined(APOXI_NOSTREAMING)
00042         friend OutputStream& operator << (OutputStream& ostr, const OnDataRcvdMsg& cls);
00043 #endif // APOXI_NOSTREAMING
00044 #if !defined(APOXI_NOSTREAMING)
00045         friend InputStream& operator >> (InputStream& istr, OnDataRcvdMsg& cls);
00046 #endif // APOXI_NOSTREAMING
00047
00048         enum {
00049             ID = 22235
00050             };
00051
00052     protected:
00053
00054 #if !defined(APOXI_NOSTREAMING)
00055         virtual void Dump(OutputStream& ostr) const;
00056 #endif // APOXI_NOSTREAMING
00057
00058     private:
00059         static const MsgMetaData m_meta_data;
00060         BYTE* m_buffer;
00061         INT m_size;
00062
00063     };
00064
00065 #endif // LcsTransports_GLTP_GltpAppMsgTypes_hpp
00066
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpAppPreComp.cpp File Reference

Applications/LcsTransports/GLTP/GltpAppPreComp.cpp File Reference

#include "GltpAppPreComp.hpp"

Include dependency graph for GltpAppPreComp.cpp:

Generated on Wed Jan 25 00:25:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpAppPreComp.hpp File Reference

Applications/LcsTransports/GLTP/GltpAppPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for GltpAppPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:25:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpAppPreComp.hpp Source File

Applications/LcsTransports/GLTP/GltpAppPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Asc/Lib.hpp>
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpConnApp.cpp File Reference

Applications/LcsTransports/GLTP/GltpConnApp.cpp File Reference

#include "GltpAppPreComp.hpp"
#include "GltpConnApp.hpp"
#include "GltpAppMsgTypes.hpp"
#include "LcsSocket.hpp"
#include <Socket/InetSocketAddr.hpp>
#include <AddOns/Lcs/GLTP/GltpMsgTypes.hpp>
#include <AddOns/Lcs/GLTP/GltpProviderImpl.hpp>
#include <AddOns/Lcs/GLTP/AidDataRequests.hpp>
#include <AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>

Include dependency graph for GltpConnApp.cpp:

Generated on Wed Jan 25 00:25:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpConnApp.hpp File Reference

Applications/LcsTransports/GLTP/GltpConnApp.hpp File Reference

#include <Kernel/Application.hpp>
#include <Socket/DataConnProfile.hpp>
#include <Socket/DataConnProfileManager.hpp>
#include <Socket/SocketHandler.hpp>

Include dependency graph for GltpConnApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpConnApp
This class handles the socket based communication for Gltp protocol. More...

Defines

#define | Mmi_GltpConnApp_hpp

Define Documentation

#define Mmi_GltpConnApp_hpp

Generated on Wed Jan 25 00:25:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/GltpConnApp.hpp Source File

Applications/LcsTransports/GLTP/GltpConnApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_GltpConnApp_hpp)
00010 #define Mmi_GltpConnApp_hpp
00011
00012 #include <Kernel/Application.hpp>
00013 #include <Socket/DataConnProfile.hpp>
00014 #include <Socket/DataConnProfileManager.hpp>
00015 #include <Socket/SocketHandler.hpp>
00016
00017 class LcsSocket;
00018 class GltpProviderImpl;
00019
00021 class GltpConnApp : public Application
00022 {
00023     typedef Application Base;
00024
00026     public:
00027
00029         ~GltpConnApp();
00030
00032         static GltpConnApp* GetInstance();
00033
00034
00036     protected:
00037
00039         virtual void OnStartup();
00040
00042         virtual BOOLEAN OnMessage(const Message& msg);
00043
00045         virtual void OnOpen();
00046
00048         virtual void OnClose();
00049
00050
00052     private:
00053
00055         GltpConnApp();
00056
00059         BOOLEAN Setup();
00060
00062         BOOLEAN Send(const BYTE* request, INT size);
00063
00065         BOOLEAN Close();
00066
00067
00069     private:
00070
00072         static GltpConnApp m_self;
00073
00075         GltpProviderImpl* m_provider;
00076
00081         enum { INVALID_PROF_ID = 0 };
00082         DataConnProfileId m_prof_id;
00083
00088         SocketHandler sock_handler;
00089
00091         LcsSocket* m_socket;
00092
00093 }; // GltpConnApp
00094
00095 #endif // Mmi_GltpConnApp_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/LcsSocket.cpp File Reference

Applications/LcsTransports/GLTP/LcsSocket.cpp File Reference

#include "GltpAppPreComp.hpp"
#include "LcsSocket.hpp"
#include "GltpAppMsgTypes.hpp"
#include <LcsTransports/Settings/LcsRegUri.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <Afs/Registry.hpp>
#include <Auxiliary/DataItem.hpp>

Include dependency graph for LcsSocket.cpp:

Generated on Wed Jan 25 00:26:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/LcsSocket.hpp File Reference

Applications/LcsTransports/GLTP/LcsSocket.hpp File Reference

#include <Socket/DataConnProfile.hpp>
#include <Socket/UdpSocket.hpp>
#include <Socket/InetSocketAddr.hpp>

Include dependency graph for LcsSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsSocket

Defines

#define | Mmi_LcsSocket_hpp

Define Documentation

#define Mmi_LcsSocket_hpp

Generated on Wed Jan 25 00:26:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/GLTP/LcsSocket.hpp Source File

Applications/LcsTransports/GLTP/LcsSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsSocket_hpp)
00010 #define Mmi_LcsSocket_hpp
00011
00012 #include <Socket/DataConnProfile.hpp>
00013 #include <Socket/UdpSocket.hpp>
00014 #include <Socket/InetSocketAddr.hpp>
00016 class LcsSocket : public UdpSocket
00017 {
00018     typedef UdpSocket Base;
00019
00021     public:
00022
00024         LcsSocket();
00025
00027         ~LcsSocket();
00028
00030         BOOLEAN Init(DataConnProfileId prof_id);
00031
00033         INT Write(const void *buf, INT buflen);
00034
00035
00037     protected:
00038
00043         virtual void OnAsyncEvent(Event event);
00044
00045
00047     private:
00048
00050         InetSocketAddr m_gl_svr_addr;
00051
00052 }; // LcsSocket
00053
00054 #endif // Mmi_LcsSocket_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/AidingDataWin.cpp File Reference

Applications/LcsTransports/Settings/AidingDataWin.cpp File Reference

#include "LcsSettingsAppPreComp.hpp"
#include "AidingDataWin.hpp"
#include "LcsSettingsUtils.hpp"
#include "LcsRegUri.hpp"
#include <AddOns/Lcs/GLTP/GltpProviderImpl.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for AidingDataWin.cpp:

Variables

const INT32 | c_gltp_mode_value = 1
const INT32 | c_latitude_value = 49429090
const INT32 | c_longitude_value = 11017610
const INT32 | c_rep_interval_value = -1
const INT32 | c_unit_id_value = 4008

Variable Documentation

const INT32 c_gltp_mode_value = 1

const INT32 c_latitude_value = 49429090

const INT32 c_longitude_value = 11017610

const INT32 c_rep_interval_value = -1

const INT32 c_unit_id_value = 4008

Generated on Wed Jan 25 00:26:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/AidingDataWin.hpp File Reference

Applications/LcsTransports/Settings/AidingDataWin.hpp File Reference

#include <Common/MmiWindow.hpp>

Include dependency graph for AidingDataWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | GltpAidingDataWin

Defines

#define | Mmi_GltpAidingDataWin_hpp

Define Documentation

#define Mmi_GltpAidingDataWin_hpp

Generated on Wed Jan 25 00:26:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/AidingDataWin.hpp Source File

Applications/LcsTransports/Settings/AidingDataWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_GltpAidingDataWin_hpp)
00010 #define Mmi_GltpAidingDataWin_hpp
00011
00012 #include <Common/MmiWindow.hpp>
00013
00020 class GltpAidingDataWin : public MmiWindow
00021 {
00022     typedef MmiWindow Base;
00023
00025     public:
00026
00028         GltpAidingDataWin();
00029
00031         virtual ~GltpAidingDataWin();
00032
00034         void Init();
00035
00036
00038     protected:
00039
00041         virtual void OnOpen();
00042
00044         virtual BOOLEAN OnConfirm();
00045
00047         virtual BOOLEAN OnCancel();
00048
00050         virtual void OnLayoutClient();
00051
00052
00054     private:
00055
00057         TextBox m_label_latitude;
00058
00060         LineEditor m_latitude;
00061
00063         TextBox m_label_longitude;
00064
00066         LineEditor m_longitude;
00067
00069         TextBox m_label_unit_id;
00070
00072         LineEditor m_unit_id;
00073
00075         TextBox m_label_agps_mode;
00076
00078         LineEditor m_agps_mode;
00079
00081         TextBox m_label_repeat_interval;
00082
00084         LineEditor m_repeat_interval;
00085
00086
00087 }; // GltpAidingDataWin
00088
00089 #endif // Mmi_GltpAidingDataWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsRegUri.hpp File Reference

Applications/LcsTransports/Settings/LcsRegUri.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Mmi_LcsRegUri_hpp

Define Documentation

#define Mmi_LcsRegUri_hpp

Generated on Wed Jan 25 00:26:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsRegUri.hpp Source File

Applications/LcsTransports/Settings/LcsRegUri.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsRegUri_hpp)
00010 #define Mmi_LcsRegUri_hpp
00011
00013
00014 // Interior nodes for protocols
00015 static const CHAR* c_lcs_root           = "./Lcs";
00016 static const CHAR* c_gltp_root          = "./Gltp";
00017 static const CHAR* c_3gpp_root          = "./Gpp";
00018
00019 // Chile nodes for LCS specific parameters
00020 static const CHAR* c_active_protocol    = "./Lcs/ActiveProtocol";       // Stored in INT format
00021
00022 // Chile nodes for GLTP parameters
00023 static const CHAR* c_gl_server_ip       = "./Gltp/GLServerAddress";     // Stored in String format
00024 static const CHAR* c_wai_server_add     = "./Gltp/WAIServerAddress";    // Stored in String format
00025 static const CHAR* c_ff_server_add      = "./Gltp/FFServerAddress";     // Stored in String format
00026 static const CHAR* c_gltp_mode          = "./Gltp/GltpMode";            // Stored in INT format
00027 static const CHAR* c_gltp_rep_interval  = "./Gltp/GltpRepeatInterval";  // Stored in INT format
00028
00029 // Chile nodes for 3GPP parameters
00030 static const CHAR* c_horiz_acc          = "./Gpp/HorizontalAccuracy";   // Stored in INT format
00031 static const CHAR* c_vert_acc           = "./Gpp/VerticalAccuracy";     // Stored in INT format
00032 static const CHAR* c_resp_time_category = "./Gpp/RespTimeCategory";     // Stored in INT format
00033 static const CHAR* c_lcs_cost_criteria  = "./Gpp/CostCriteria";         // Stored in INT format
00034 static const CHAR* c_lcs_rep_interval   = "./Gpp/LcsRepeatInterval";    // Stored in INT format
00035 static const CHAR* c_client_id          = "./Gpp/ClientId";             // Stored in String format
00036 static const CHAR* c_mlc_number         = "./Gpp/MlcNumber";            // Stored in String format
00037
00038 #endif // Mmi_LcsRegUri_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsApp.cpp File Reference

Applications/LcsTransports/Settings/LcsSettingsApp.cpp File Reference

#include "LcsSettingsAppPreComp.hpp"
#include "LcsSettingsApp.hpp"
#include "LcsRegUri.hpp"
#include "LcsSettingsUtils.hpp"
#include <Common/ApplicationManager.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <AddOns/Lcs/Common/LcsProvider.hpp>
#include <Atl/Features/FeatureItemContainer.hpp>
#include <Common/MmiInfoBox.hpp>
#include <Kernel/VersionInfo.hpp>

Include dependency graph for LcsSettingsApp.cpp:

Generated on Wed Jan 25 00:26:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsApp.hpp File Reference

Applications/LcsTransports/Settings/LcsSettingsApp.hpp File Reference

#include <Common/MmiApplication.hpp>
#include <Atl/Properties/Property.hpp>
#include <Common/Properties/Descriptors/SetPropertyDescriptor.hpp>
#include <Atl/Gui/AtlItemMenuWindow.hpp>
#include "AidingDataWin.hpp"
#include "ServerAddressWin.hpp"
#include "SelfLocationDialogWin.hpp"

Include dependency graph for LcsSettingsApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsSettingsApp

Defines

#define | Mmi_LcsSettingsApp_hpp

Define Documentation

#define Mmi_LcsSettingsApp_hpp

Generated on Wed Jan 25 00:26:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsApp.hpp Source File

Applications/LcsTransports/Settings/LcsSettingsApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsSettingsApp_hpp)
00010 #define Mmi_LcsSettingsApp_hpp
00011
00012 #include <Common/MmiApplication.hpp>
00013 #include <Atl/Properties/Property.hpp>
00014 #include <Common/Properties/Descriptors/SetPropertyDescriptor.hpp>
00015 #include <Atl/Gui/AtlItemMenuWindow.hpp>
00016
00017 #include "AidingDataWin.hpp"
00018 #include "ServerAddressWin.hpp"
00019 #include "SelfLocationDialogWin.hpp"
00020
00022 class LcsSettingsApp : public MmiApplication
00023 {
00024     typedef MmiApplication Base;
00025
00027     public:
00028
00030         virtual ~LcsSettingsApp();
00031
00033         static LcsSettingsApp* GetInstance();
00034
00036     protected:
00037
00039         virtual void OnStartup();
00040
00042         virtual BOOLEAN OnMessage(const Message& msg);
00043
00045         virtual void OnOpen();
00046
00048         virtual void OnClose();
00049
00051         virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00052
00054         virtual BOOLEAN OnPropertyNotification(const Property::Notification notification,
00055                                                 const Property* property,
00056                                                 const DataItem& value);
00057
00058
00060     private:
00061
00063         LcsSettingsApp();
00064
00066         void RegisterProperties();
00067
00068
00070     private:
00071
00073         static LcsSettingsApp m_lcs_settings_app;
00074
00076         enum LcsSettingsFeatureId {
00077             GltpServers,
00078             GltpPosnFixCfg,
00079             LcsVersionInfo,
00080             LcsSettingsFeatureCnt
00081         };
00082
00084         Feature m_features[LcsSettingsFeatureCnt];
00085
00087         GltpAidingDataWin m_pos_fix_data_win;
00088
00090         ServerAddressWin m_server_address_win;
00091
00094         SelfLocationDialog m_self_loc_dlg;
00095
00097         WString m_version_info;
00098
00100         Property m_prop_protocols;
00101         SetPropertyDescriptor m_prop_desc_protocols;
00102
00104         AtlItemMenuWindow m_gtlp_menu_win;
00105
00107         enum UartSettingsPropertyId {
00108             NmeaBaudRate,
00109             NmeaDataBits,
00110             NmeaParity,
00111             NmeaStopBits,
00112             NmeaFlowControl,
00113             UartSettingsPropertyCnt
00114         };
00115
00117         Property m_prop_uart_settings[UartSettingsPropertyCnt];
00118         SetPropertyDescriptor m_prop_desc_uart[UartSettingsPropertyCnt];
00119
00121         Property m_prop_nmea_switch;
00122
00123 }; // LcsSettingsApp
00124
00125 #endif // Mmi_LcsSettingsApp_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsAppPreComp.cpp File Reference

Applications/LcsTransports/Settings/LcsSettingsAppPreComp.cpp File Reference

#include "LcsSettingsAppPreComp.hpp"

Include dependency graph for LcsSettingsAppPreComp.cpp:

Generated on Wed Jan 25 00:27:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsAppPreComp.hpp File Reference

Applications/LcsTransports/Settings/LcsSettingsAppPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for LcsSettingsAppPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:27:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsAppPreComp.hpp Source File

Applications/LcsTransports/Settings/LcsSettingsAppPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Asc/Lib.hpp>
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsUtils.cpp File Reference

Applications/LcsTransports/Settings/LcsSettingsUtils.cpp File Reference

#include "LcsSettingsAppPreComp.hpp"
#include "LcsSettingsUtils.hpp"
#include "LcsRegUri.hpp"
#include <GuiExtensions/MmiAlert.hpp>
#include <Afs/Registry.hpp>
#include <Auxiliary/DataItem.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for LcsSettingsUtils.cpp:

Generated on Wed Jan 25 00:27:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsUtils.hpp File Reference

Applications/LcsTransports/Settings/LcsSettingsUtils.hpp File Reference

#include <GuiExtensions/MmiAlert.hpp>

Include dependency graph for LcsSettingsUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | LcsSettingsUtils

Defines

#define | Mmi_LcsSettingsUtils_hpp

Define Documentation

#define Mmi_LcsSettingsUtils_hpp

Generated on Wed Jan 25 00:27:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/LcsSettingsUtils.hpp Source File

Applications/LcsTransports/Settings/LcsSettingsUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_LcsSettingsUtils_hpp)
00010 #define Mmi_LcsSettingsUtils_hpp
00011
00012 #include <GuiExtensions/MmiAlert.hpp>
00013
00014 class WString;
00015
00018 class LcsSettingsUtils
00019 {
00020     public:
00021
00023         ~LcsSettingsUtils();
00024
00026         static LcsSettingsUtils* GetInstance();
00027
00029         static void ReleaseInstance();
00030
00032         void DisplayMsg(const WCHAR* str = NULL);
00033
00035         BOOLEAN GetData(const CHAR* data_type, WString& data);
00036
00038         BOOLEAN GetData(const CHAR* data_type, INT32& data);
00039
00041         BOOLEAN StoreData(const CHAR* data_type, const WString& data) const;
00042
00044         BOOLEAN StoreData(const CHAR* data_type, INT32 data) const;
00045
00046
00048     private:
00049
00051         LcsSettingsUtils();
00052
00054     private:
00055
00057         static LcsSettingsUtils* m_self;
00058
00059 }; // LcsSettingsUtils
00060
00061 #endif // Mmi_LcsSettingsUtils_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/SelfLocationDialogWin.cpp File Reference

Applications/LcsTransports/Settings/SelfLocationDialogWin.cpp File Reference

#include "LcsSettingsAppPreComp.hpp"
#include "SelfLocationDialogWin.hpp"
#include "LcsRegUri.hpp"
#include "LcsSettingsUtils.hpp"

Include dependency graph for SelfLocationDialogWin.cpp:

Generated on Wed Jan 25 00:28:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/SelfLocationDialogWin.hpp File Reference

Applications/LcsTransports/Settings/SelfLocationDialogWin.hpp File Reference

#include <Common/MmiWindow.hpp>

Include dependency graph for SelfLocationDialogWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SelfLocationDialog
Class for the self location window. This window takes user input for QoS from the user. More...

Defines

#define | Mmi_SelfLocationDialogWin_hpp

Define Documentation

#define Mmi_SelfLocationDialogWin_hpp

Generated on Wed Jan 25 00:28:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/SelfLocationDialogWin.hpp Source File

Applications/LcsTransports/Settings/SelfLocationDialogWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_SelfLocationDialogWin_hpp)
00010 #define Mmi_SelfLocationDialogWin_hpp
00011
00012 #include <Common/MmiWindow.hpp>
00013
00015 class SelfLocationDialog : public MmiWindow
00016 {
00017     typedef MmiWindow Base;
00018
00020     public:
00021
00023         SelfLocationDialog();
00024
00026         virtual ~SelfLocationDialog();
00027
00029         void Init();
00030
00031
00033     protected:
00034
00036         virtual void OnOpen();
00037
00039         virtual BOOLEAN OnConfirm();
00040
00042         virtual BOOLEAN OnCancel();
00043
00045         virtual void OnLayoutClient();
00046
00047
00049     private:
00050
00052         TextBox m_label_qos;
00053
00055         TextBox m_label_hor_acc;
00056
00058         TextBox m_label_vert_acc;
00059
00061         TextBox m_label_rsp_time_cat;
00062
00064         MultiLineEditor m_horiz_accuracy;
00065
00067         MultiLineEditor m_vert_accuracy;
00068
00070         MultiLineEditor m_rsp_time_cat;
00071
00073         TextBox m_label_lcs_cost;
00074
00076         TextBox m_label_repeat_interval;
00077
00079         MultiLineEditor m_lcs_cost;
00080
00082         MultiLineEditor m_repeat_interval;
00083
00084 }; // SelfLocationDialog
00085
00086 #endif // Mmi_SelfLocationDialogWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/ServerAddressWin.cpp File Reference

Applications/LcsTransports/Settings/ServerAddressWin.cpp File Reference

#include "LcsSettingsAppPreComp.hpp"
#include "ServerAddressWin.hpp"
#include "LcsRegUri.hpp"
#include "LcsSettingsUtils.hpp"
#include <Auxiliary/IpAddr.hpp>

Include dependency graph for ServerAddressWin.cpp:

Variables

const WCHAR * | c_ff_svr_addr = L"http://glappseu.globallocate.com/glapps/ffmap4008.htm"
const WCHAR * | c_gl_aid_svr_addr = L"216.74.182.168"
const WCHAR * | c_wai_svr_addr = L"http://glappseu.globallocate.com/glapps/wapmap4008.htm"

Variable Documentation

const WCHAR* c_ff_svr_addr = L"http://glappseu.globallocate.com/glapps/ffmap4008.htm"

const WCHAR* c_gl_aid_svr_addr = L"216.74.182.168"

const WCHAR* c_wai_svr_addr = L"http://glappseu.globallocate.com/glapps/wapmap4008.htm"

Generated on Wed Jan 25 00:28:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/ServerAddressWin.hpp File Reference

Applications/LcsTransports/Settings/ServerAddressWin.hpp File Reference

#include <Common/MmiWindow.hpp>
#include <Gui/IpAddrEditor.hpp>

Include dependency graph for ServerAddressWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ServerAddressWin

Defines

#define | Mmi_ServerAddressWin_hpp

Define Documentation

#define Mmi_ServerAddressWin_hpp

Generated on Wed Jan 25 00:28:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/LcsTransports/Settings/ServerAddressWin.hpp Source File

Applications/LcsTransports/Settings/ServerAddressWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_ServerAddressWin_hpp)
00010 #define Mmi_ServerAddressWin_hpp
00011
00012 #include <Common/MmiWindow.hpp>
00013 #include <Gui/IpAddrEditor.hpp>
00014
00020 class ServerAddressWin : public MmiWindow
00021 {
00022     typedef MmiWindow Base;
00023
00025     public:
00026
00028         ServerAddressWin();
00029
00031         virtual ~ServerAddressWin();
00032
00034         void Init();
00035
00036
00038     protected:
00039
00041         virtual void OnOpen();
00042
00044         virtual void OnClose();
00045
00047         virtual BOOLEAN OnConfirm();
00048
00050         virtual BOOLEAN OnCancel();
00051
00053         virtual void OnLayoutClient();
00054
00055
00057     private:
00058
00060         TextBox m_label_gl_server_addr;
00061
00063         IpAddrEditor m_gl_server_addr;
00064
00066         TextBox m_label_wai_address;
00067
00069         LineEditor m_wai_address;
00070
00072         TextBox m_label_ff_address;
00073
00075         LineEditor m_ff_address;
00076
00077 }; // ServerAddressWin
00078
00079 #endif // Mmi_ServerAddressWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexApp.cpp File Reference

Applications/ObexApp/ObexApp.cpp File Reference

#include "ObexAppPreComp.hpp"
#include <GuiExtensions/MmiAlert.hpp>
#include <Kernel/VersionInfo.hpp>
#include "ObexApp.hpp"
#include "ObexTransportWin.hpp"

Include dependency graph for ObexApp.cpp:

Functions

ApoxiUseVersionInfo (ObexApp)

Function Documentation

ApoxiUseVersionInfo ( ObexApp )

Generated on Wed Jan 25 00:28:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexApp.hpp File Reference

Applications/ObexApp/ObexApp.hpp File Reference

#include <Common/MmiApplication.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Obex/ObexMngr.hpp>
#include <Obex/ObexTransportSet.hpp>
#include <Obex/ObexAppMsg.hpp>
#include <Obex/ObexTransport.hpp>
#include <ObexApp/ObexTransportWin.hpp>

Include dependency graph for ObexApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexApp

Defines

#define | Mmi_ObexApp_hpp

Define Documentation

#define Mmi_ObexApp_hpp

Generated on Wed Jan 25 00:28:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexApp.hpp Source File

Applications/ObexApp/ObexApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_ObexApp_hpp)
00009 #define Mmi_ObexApp_hpp
00012
00013 #include <Common/MmiApplication.hpp>
00014 #include <Common/CommonMsgTypes.hpp>
00015 #include <Obex/ObexMngr.hpp>
00016 #include <Obex/ObexTransportSet.hpp>
00017 #include <Obex/ObexAppMsg.hpp>
00018 #include <Obex/ObexTransport.hpp>
00019
00020 #include <ObexApp/ObexTransportWin.hpp>
00021
00022
00023 class ObexApp : public MmiApplication {
00024     typedef MmiApplication Base;
00025
00026     public:
00027         static ObexApp* GetInstance();
00028
00029         void Init();
00031         virtual ~ObexApp();
00032
00033     protected:
00034         virtual BOOLEAN OnMessage(const Message &msg);
00035         virtual void OnOpen();
00036
00037     private:
00039         ObexApp();
00040
00041         ObexTransportWin m_transport_win;
00042         static ObexApp m_obex_app;
00043
00044 };
00046 #endif  // Mmi_VoiceMemoApp_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexAppPreComp.cpp File Reference

Applications/ObexApp/ObexAppPreComp.cpp File Reference

#include "ObexAppPreComp.hpp"

Include dependency graph for ObexAppPreComp.cpp:

Generated on Wed Jan 25 00:29:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexAppPreComp.hpp File Reference

Applications/ObexApp/ObexAppPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for ObexAppPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:29:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexAppPreComp.hpp Source File

Applications/ObexApp/ObexAppPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Apc/Lib.hpp>
00013 #include <Adc/Lib.hpp>
00014 #include <Asc/Lib.hpp>
00015
00016 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexAppVersion.cpp File Reference

Applications/ObexApp/ObexAppVersion.cpp File Reference

#include "ObexAppPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include "ObexAppVersion.hpp"

Include dependency graph for ObexAppVersion.cpp:

Functions

ApoxiDefVersionInfo (ObexApp, OBEXVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | ObexApp | ,
 |  | OBEXVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:29:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexAppVersion.hpp File Reference

Applications/ObexApp/ObexAppVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | ObexAppVersion_hpp
#define | OBEXVERSION "2.10.0_TIV_04"

Define Documentation

#define ObexAppVersion_hpp

#define OBEXVERSION "2.10.0_TIV_04"

Generated on Wed Jan 25 00:29:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexAppVersion.hpp Source File

Applications/ObexApp/ObexAppVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(ObexAppVersion_hpp)
00010 #define ObexAppVersion_hpp
00011
00012
00013 /*
00014 ObexappVersion.hpp contains the official Obexapp Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define OBEXVERSION "2.10.0_TIV_04"
00019
00020 #endif  // ObexappVersion_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexTransportWin.cpp File Reference

Applications/ObexApp/ObexTransportWin.cpp File Reference

#include "ObexAppPreComp.hpp"
#include <Config/MmiGuiEngineConfig.hpp>
#include <GuiExtensions/MmiInfoBox.hpp>
#include <Obex/ObexMngr.hpp>
#include <Obex/ObexTransportSet.hpp>
#include <Devices/AbstractTransport.hpp>
#include "ObexTransportWin.hpp"

Include dependency graph for ObexTransportWin.cpp:

Generated on Wed Jan 25 00:30:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexTransportWin.hpp File Reference

Applications/ObexApp/ObexTransportWin.hpp File Reference

#include <Gui/RadioButtonControl.hpp>
#include <Gui/ItemGrid.hpp>
#include <Obex/ObexConfig.hpp>
#include <Obex/ObexTransport.hpp>

Include dependency graph for ObexTransportWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ObexTransportWin

Defines

#define | Mmi_ObexTransportWin_hpp

Define Documentation

#define Mmi_ObexTransportWin_hpp

Generated on Wed Jan 25 00:30:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ObexApp/ObexTransportWin.hpp Source File

Applications/ObexApp/ObexTransportWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_ObexTransportWin_hpp)
00009 #define Mmi_ObexTransportWin_hpp
00012 //#include <GuiExtensions/MmiMenuWindow.hpp>
00013 #include <Gui/RadioButtonControl.hpp>
00014 #include <Gui/ItemGrid.hpp>
00015 #include <Obex/ObexConfig.hpp>
00016 #include <Obex/ObexTransport.hpp>
00017
00018 class ObexTransportWin : public MmiWindow {
00019     typedef MmiWindow Base;
00020
00021     public:
00023         ObexTransportWin();
00025         virtual ~ObexTransportWin();
00027         void Init();
00028
00029     protected:
00030
00032         virtual BOOLEAN OnConfirm();
00033
00035         virtual BOOLEAN OnCancel();
00037         virtual void OnClose();
00039         virtual void OnLayoutClient();
00041         BOOLEAN OnKeyDown(KeyCode key_code);
00042
00043     private:
00044
00045         RadioButtonAction m_rb_action[APOXI_OBEX_MAX_NO_TRANSPORTS];
00046         RadioButtonGroup    m_rb_group;
00047         ItemGrid m_item_grid;
00048
00049
00050 };
00052 #endif  // Mmi_ObexTransportWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegApp.cpp File Reference

Applications/RegEditorClient/RegApp.cpp File Reference

#include "RegAppPreComp.hpp"
#include "RegApp.hpp"
#include "RegAppWin.hpp"
#include <Afs/AfsMsgTypes.hpp>

Include dependency graph for RegApp.cpp:

Generated on Wed Jan 25 00:30:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegApp.hpp File Reference

Applications/RegEditorClient/RegApp.hpp File Reference

#include <Common/MmiApplication.hpp>
#include "RegAppFirstWin.hpp"

Include dependency graph for RegApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegApp

Defines

#define | Mmi_RegApp_hpp

Define Documentation

#define Mmi_RegApp_hpp

Generated on Wed Jan 25 00:30:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegApp.hpp Source File

Applications/RegEditorClient/RegApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_RegApp_hpp)
00010 #define Mmi_RegApp_hpp
00011
00012 #include <Common/MmiApplication.hpp>
00013 #include "RegAppFirstWin.hpp"
00014
00015 class RegApp : public MmiApplication
00016 {
00017     typedef MmiApplication Base;
00018
00019 public:
00020
00022     RegApp();
00023
00025     virtual ~RegApp();
00026
00028     void Init();
00029
00031     static RegApp* GetInstance();
00032
00033
00034 protected:
00035
00037     virtual void OnOpen();
00038
00040     virtual void OnClose();
00041
00043     virtual BOOLEAN OnMessage(const Message &msg);
00044
00046     virtual void OnStartup();
00047
00049     virtual BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00050
00051
00052 private:
00053
00055     static RegApp m_reg_app;
00056
00058     RegAppFirstWin  m_result_first_win;
00059
00061     Feature m_feature;
00062
00063 };
00064
00065 #endif
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppCommon.cpp File Reference

Applications/RegEditorClient/RegAppCommon.cpp File Reference

#include "RegAppPreComp.hpp"
#include "RegAppCommon.hpp"

Include dependency graph for RegAppCommon.cpp:

Generated on Wed Jan 25 00:30:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppCommon.hpp File Reference

Applications/RegEditorClient/RegAppCommon.hpp File Reference

#include <Afs/Uri.hpp>
#include <Auxiliary/DataItem.hpp>
#include "RegEncoderDecoder.hpp"

Include dependency graph for RegAppCommon.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegAppCommon

Defines

#define | Mmi_RegAppCommon_hpp

Define Documentation

#define Mmi_RegAppCommon_hpp

Generated on Wed Jan 25 00:30:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppCommon.hpp Source File

Applications/RegEditorClient/RegAppCommon.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Mmi_RegAppCommon_hpp)
00015 #define Mmi_RegAppCommon_hpp
00016
00017 #include <Afs/Uri.hpp>
00018 #include <Auxiliary/DataItem.hpp>
00019
00020 #include "RegEncoderDecoder.hpp"
00021
00022 class RegAppCommon
00023 {
00024     public:
00025
00026 #if REGAPP_USE_NEW
00027         static Init();
00028         static Close();
00029 #endif
00030
00031
00032         static RegEncoderDecoder::Mobile2PCMsg* GetInstanceMobile2PC();
00033         static RegEncoderDecoder::PC2MobileMsg* GetInstancePC2Mobile();
00034         static DataItem* GetInstanceDataItem();
00035         static RegEncoderDecoder::IteratorObjResult* GetInstanceIteratorObj();
00036         static Uri* GetInstanceUri();
00037
00038
00039
00040     private:
00041
00042 #if REGAPP_USE_NEW
00043         static RegEncoderDecoder::Mobile2PCMsg      *m_mob2pcmsg;
00044         static RegEncoderDecoder::PC2MobileMsg      *m_pc2mobMsg;
00045         static DataItem                             *m_dataitem;
00046         static RegEncoderDecoder::IteratorObjResult *m_iterator_obj;
00047         static Uri                                  *m_uri;
00048 #else
00049         static RegEncoderDecoder::Mobile2PCMsg      m_mob2pcmsg;
00050         static RegEncoderDecoder::PC2MobileMsg      m_pc2mobMsg;
00051         static DataItem                             m_dataitem;
00052         static RegEncoderDecoder::IteratorObjResult m_iterator_obj;
00053         static Uri                                  m_uri;
00054
00055 #endif
00056 };
00057
00058
00059 #endif
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppFirstWin.cpp File Reference

Applications/RegEditorClient/RegAppFirstWin.cpp File Reference

#include "RegAppPreComp.hpp"
#include "RegAppFirstWin.hpp"
#include "RegAppWin.hpp"

Include dependency graph for RegAppFirstWin.cpp:

Generated on Wed Jan 25 00:31:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppFirstWin.hpp File Reference

Applications/RegEditorClient/RegAppFirstWin.hpp File Reference

#include <Gui/IpAddrEditor.hpp>
#include <GuiExtensions/MmiDialog.hpp>

Include dependency graph for RegAppFirstWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegAppFirstWin

Defines

#define | Mmi_RegAppFirstWin_hpp

Define Documentation

#define Mmi_RegAppFirstWin_hpp

Generated on Wed Jan 25 00:31:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppFirstWin.hpp Source File

Applications/RegEditorClient/RegAppFirstWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_RegAppFirstWin_hpp)
00011 #define Mmi_RegAppFirstWin_hpp
00012
00013 #include <Gui/IpAddrEditor.hpp>
00014 #include <GuiExtensions/MmiDialog.hpp>
00015
00016 class RegAppWin;
00017
00018 class RegAppFirstWin : public MmiDialog
00019 {
00020     typedef MmiDialog Base;
00021
00022 public:
00023
00025     RegAppFirstWin();
00026
00028     virtual ~RegAppFirstWin();
00029
00031     void Init();
00032
00034     RegAppWin   *m_result_win1;
00035
00036
00037 protected:
00038
00040     virtual void OnLayoutClient();
00041
00043     virtual BOOLEAN OnConfirm();
00044
00046     virtual void OnOpen();
00047
00048 #if REGAPP_USE_NEW
00049     virtual BOOLEAN Close();
00050 #endif
00051
00052
00053 private:
00054
00055     LineEditor      m_line_editor;
00056     IpAddrEditor    m_ip_editor;
00057
00058     TextLine    m_port_text;
00059     TextLine    m_ip_text;
00060
00061 };
00062
00063 #endif
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppPreComp.cpp File Reference

Applications/RegEditorClient/RegAppPreComp.cpp File Reference

#include "RegAppPreComp.hpp"

Include dependency graph for RegAppPreComp.cpp:

Generated on Wed Jan 25 00:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppPreComp.hpp File Reference

Applications/RegEditorClient/RegAppPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for RegAppPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:31:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppPreComp.hpp Source File

Applications/RegEditorClient/RegAppPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Asc/Lib.hpp>
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppWin.cpp File Reference

Applications/RegEditorClient/RegAppWin.cpp File Reference

#include "RegAppPreComp.hpp"
#include "RegAppWin.hpp"
#include <Config/MmiGuiEngineConfig.hpp>
#include <Socket/DnsClient.hpp>
#include <Socket/InetSocketAddr.hpp>
#include "RegAppCommon.hpp"
#include "RegInterface.hpp"

Include dependency graph for RegAppWin.cpp:

Variables

const INT BUFFER_SIZE = 4101

Variable Documentation

const INT BUFFER_SIZE = 4101

Generated on Wed Jan 25 00:32:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppWin.hpp File Reference

Applications/RegEditorClient/RegAppWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/RadioButtonListBoxModel.hpp>
#include <GuiExtensions/DrawableObjectListBox.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <Socket/SocketHandler.hpp>
#include <Socket/TcpSocket.hpp>
#include "RegEncoderDecoder.hpp"

Include dependency graph for RegAppWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegAppWin
class | RegTcpSocket

Defines

#define | Mmi_RegAppWin_hpp

Define Documentation

#define Mmi_RegAppWin_hpp

Generated on Wed Jan 25 00:32:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegAppWin.hpp Source File

Applications/RegEditorClient/RegAppWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Mmi_RegAppWin_hpp)
00011 #define Mmi_RegAppWin_hpp
00012
00013
00014 #include <GuiExtensions/MmiWindow.hpp>
00015 #include <GuiExtensions/RadioButtonListBoxModel.hpp>
00016 #include <GuiExtensions/DrawableObjectListBox.hpp>
00017 #include <Gui/RadioButtonAction.hpp>
00018 #include <Socket/SocketHandler.hpp>
00019 #include <Socket/TcpSocket.hpp>
00020
00021 #include "RegEncoderDecoder.hpp"
00022
00023
00024 class RegTcpSocket : public TcpSocket
00025 {
00026     typedef TcpSocket Base;
00027
00029     public:
00030
00032         RegTcpSocket();
00033
00035         ~RegTcpSocket();
00036
00038     protected:
00039
00042         virtual void OnAsyncEvent(Event event);
00043 };
00044
00045
00046 class RegAppWin : public MmiWindow
00047 {
00048     typedef MmiWindow Base;
00049
00050 public:
00051
00053     RegAppWin();
00054
00056     ~RegAppWin();
00057
00059     void Init();
00060
00062     static RegAppWin* GetInstance();
00063
00065     void InitSocket();
00066
00068     void HandleByteStream(UINT8* ptr);
00069
00071     void ConnectToPC(const IpAddr& ip_addr, UINT16 port_no);
00072
00074     BOOLEAN SendSetUpMsgToPC();
00075
00077     void SendRegisterNotification(const Uri& uri);
00078
00080 #if !defined(APOXI_RTOS_WIN32)
00081
00082     DataConnProfileId m_profileId;
00083
00084 #endif
00085
00086     void FindDataConnProfiles();
00087
00088     static BOOLEAN m_socket_connected;
00089     static INT16   m_lock_id;
00090
00091
00092 protected:
00093
00095     virtual void OnOpen();
00096
00097
00098 private:
00099
00101     static RegAppWin m_RegAppWin;
00102
00104     static RegEncoderDecoder *pRegCoder;
00105
00107     RegEncoderDecoder::Mobile2PCMsg* m_Mob2PCMsg;
00108
00110     RegEncoderDecoder::PC2MobileMsg* m_PC2MobMsg;
00111
00113     DrawableObjectListBox mListBox;
00114
00116     RadioButtonListBoxModel mRadioButtonListBoxModel;
00117
00119     RadioButtonAction mRadioButtonAction[3];
00120
00122     CloseWindowAction mCloseWinAction;
00123
00125     BOOLEAN EncodeAndSendDataToPC(UINT8* buffer, RegEncoderDecoder::Mobile2PCMsg& m_Mob2PCMsg, UINT8 packet_number);
00126
00128     BOOLEAN SendDataToPC(UINT8* buffer, UINT16 BytesToWrite);
00129
00131     BOOLEAN HandleConnectionClose(UINT8* buffer, RegEncoderDecoder::Mobile2PCMsg& m_Mob2PCMsg);
00132
00134     BOOLEAN HandleBigBlob(UINT8* buffer,RegEncoderDecoder::Mobile2PCMsg& m_Mob2PCMsg);
00135
00137     static RegTcpSocket tcp_Sock;
00138
00140     SocketHandler sock_handler_tcp;
00141
00142 }; // RegAppWin
00143
00144 #endif // Mmi_RegAppWin_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegEncoderDecoder.cpp File Reference

Applications/RegEditorClient/RegEncoderDecoder.cpp File Reference

#include "RegAppPreComp.hpp"
#include <Auxiliary/MimeTypeTable.hpp>
#include <Afs/Registry.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include "RegEncoderDecoder.hpp"
#include "RegAppCommon.hpp"

Include dependency graph for RegEncoderDecoder.cpp:

Generated on Wed Jan 25 00:32:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegEncoderDecoder.hpp File Reference

Applications/RegEditorClient/RegEncoderDecoder.hpp File Reference

#include <Afs/RegIterator.hpp>
#include <Afs/Uri.hpp>
#include <Afs/RegDefines.hpp>

Include dependency graph for RegEncoderDecoder.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RegEncoderDecoder
struct | RegEncoderDecoder::IteratorObjResult
struct | RegEncoderDecoder::Mobile2PCMsg
union | RegEncoderDecoder::Mobile2PCMsg::msg
struct | RegEncoderDecoder::Payload
struct | RegEncoderDecoder::PC2MobileMsg
union | RegEncoderDecoder::PC2MobileMsg::msg
struct | RegEncoderDecoder::RegIteratorNodeType
struct | RegEncoderDecoder::Response
struct | RegEncoderDecoder::SetUpMsg
struct | RegEncoderDecoder::UriAndPayload

Defines

#define | Mmi_RegEncoderDecoder_hpp

Typedefs

typedef BOOLEAN | FLAG

Define Documentation

#define Mmi_RegEncoderDecoder_hpp

Typedef Documentation

typedef BOOLEAN FLAG

Generated on Wed Jan 25 00:32:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegEncoderDecoder.hpp Source File

Applications/RegEditorClient/RegEncoderDecoder.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if !defined(Mmi_RegEncoderDecoder_hpp)
00015 #define Mmi_RegEncoderDecoder_hpp
00016
00017 #include <Afs/RegIterator.hpp>
00018 #include <Afs/Uri.hpp>
00019 #include <Afs/RegDefines.hpp>
00020
00021 //Constants to define little and big endian
00022 static const INT32 c_reg_little_endian   = 0x00;
00023 static const INT32 c_reg_big_endian      = 0x18;
00024 static const CHAR c_reg_protocol_version = 0x01;
00025 static const CHAR c_processor_type       = 0x00;
00026
00027 static const INT16 c_max_buffer_size = 0x1000;
00028
00029 static UINT8 buffer[c_max_buffer_size];
00030
00031 typedef BOOLEAN FLAG;
00032
00033 static const UINT8 c_reg_16_bit = 0x00;
00034 static const UINT8 c_reg_32_bit = 0x01;
00035
00036
00037 class RegEncoderDecoder
00038 {
00039 public:
00040
00041
00042     enum ResponseType
00043     {
00044         RegSuccess              = 0x00,
00045         RegError                = 0x01,
00046         NoData                  = 0x03,
00047         Locked                  = 0x04,
00048         Unlocked                = 0x05,
00049         RegNoService            = 0x06,
00050         UnSuppotedType          = 0x07,
00051         RegResNoGetOnInterior   = 0x08,
00052         RegResNodeAlreadyExists = 0x09,
00053         RegResChildLocked       = 0x0A,
00054         InvalidRequest          = 0xF0
00055     };
00056
00057     /*
00058     enum ProtocolPayloadType
00059     {
00060         Boolean             = 0x0A,
00061         Integer             = 0x01,
00062         String              = 0x03,
00063         Blob                = 0x09,
00064         Uri                 = 0x20,
00065         NumberOfChildren    = 0x21,
00066         InteriorOrLeaf      = 0x22,
00067     };
00068
00069     */
00070
00071     enum MsgID
00072     {
00073         //Mobile --> PC
00074         MobileShutdown      = 0x01,
00075         Notification        = 0x02,
00076         ResponseMessage     = 0x03,
00077
00078         //PC --->Mobile
00079
00080         Get                 = 0x80,
00081         Set                 = 0x81,
00082         CreateInterior      = 0x82,
00083         Delete              = 0x83,
00084         Lock                = 0x84,
00085         Unlock              = 0x85,
00086         RegisterNotify      = 0x86,
00087         ConnectionClose     = 0x87,
00088         ConnectionResponse  = 0x88,
00089         BlobResponse        = 0x89,
00090         SetExtn             = 0x90,
00091
00092         //Iterator
00093         GetIterator         = 0xC0,
00094         SetIterator         = 0xC1,
00095         TraverseNext        = 0xC2,
00096         TraverseUp          = 0xC3,
00097         TraverseDown        = 0xC4,
00098         GetLeafMetaData     = 0xC5,
00099         GetInteriorMetaData = 0xC6,
00100
00101         //Transaction
00102         EnableTransaction   = 0xD0,
00103         Commit              = 0xD1
00104
00105     };
00106
00107      enum PayloadType
00108      {
00109         PayloadDataItem,
00110         PayloadIteratorObj,
00111         PayloadInteger = 0x30
00112      };
00113
00114
00115      enum IteratorType
00116      {
00117         IteratorUri                 = 0x20,
00118         IteratorInteriorMetaData    = 0x21,
00119         IteratorNodeType            = 0x22,
00120         IteratorLeafMetaData        = 0x23
00121      };
00122
00123
00124     struct RegIteratorNodeType {
00125          RegIterator::NodeType          m_node_type; //Bool or Number or Generic etc
00126          Uri                            *m_uri;
00127     };
00128
00129
00130      struct IteratorObjResult
00131      {
00132         IteratorType    m_iterator_type;
00133
00134         union
00135         {
00136             Uri                             *m_uri;
00137             RegIteratorNodeType             m_iter_nodetype;
00138     #if 0
00139             RegIterator::NodeType           m_node_type;
00140     #endif
00141             RegIterator::LeafMetaData       m_leaf_meta_data;
00142             RegIterator::InteriorMetaData   m_interior_meta_data;
00143         } m_iterator_obj;
00144      };
00145
00146      struct Payload
00147      {
00148         PayloadType m_type; // dataitem or iterator
00149         union
00150         {
00151             DataItem            *m_dataitem;
00152             IteratorObjResult   *m_iterator_res_obj;
00153             INT16               m_lockinfo;
00154         } payload_obj;
00155      };
00156
00157
00158     typedef struct Response
00159     {
00160         ResponseType    m_res_type;
00161         UINT8           m_additional_info;
00162         Payload         m_payload;
00163     }Response;
00164
00165
00166
00167     typedef struct UriAndPayload
00168     {
00169         Uri             *m_uri;
00170         Payload         m_payload;
00171     }UriAndPayload;
00172
00173
00174
00175     typedef struct Mobile2PCMsg
00176     {
00177         MsgID   m_msg_id;
00178
00179         union msg
00180         {
00181             Uri         *m_uri;
00182             Response    m_response;
00183
00184         }msg;
00185
00186     }Mobile2PCMsg;
00187
00188     typedef struct PC2MobileMsg
00189     {
00190         MsgID   msg_id;
00191
00192         union msg
00193         {
00194             Uri                 *m_uri;
00195             UriAndPayload       m_uri_payload;
00196             ResponseType        m_res_type;
00197             INT16               m_lock_id;
00198         }msg;
00199     }PC2MobileMsg;
00200
00201     typedef struct SetUpMsg
00202     {
00203         UINT8       m_endianess;
00204         UINT8       m_protocol_version;
00205         UINT8       m_processor_type;
00206         INT16       m_max_message_size;
00207         INT16       m_max_blob_size;
00208     }SetUpMsg;
00209
00210
00211
00212     static UINT8 extra_bytes;
00213
00214
00215
00217     ~RegEncoderDecoder(){}
00218
00220     BOOLEAN EncodeSetupMsg(UINT8 *buffer, UINT16* NoOfBytesEncoded);
00221
00222
00223     BOOLEAN Encode(UINT8* buffer, Mobile2PCMsg& msg, UINT8 packetnumber, UINT16* NoOfBytesEncoded);
00224     //NoOfBytesEncoded will be output parameter
00225     //In case of blob objects, RegApp will give the packet number to encode to Encode()
00226
00227
00229     BOOLEAN Decode(UINT8* buffer, PC2MobileMsg&, FLAG& in_out);
00230     //- flag is in/out parameter
00231     //Flag will be FALSSE initially, but decode will make TRUE if the blob size is more than 4K
00233
00234     static RegEncoderDecoder* GetInstance();
00235
00236 private:
00238
00239     BOOLEAN EncodePayload(UINT8* buffer, Payload& payload, UINT8 packetnumber, UINT16* NoOfBytesEncoded);
00240
00241     BOOLEAN EncodeDataItem(UINT8* buffer, Payload& payload, UINT8 packetnumber, UINT16* NoOfBytesEncoded);
00242
00243     BOOLEAN EncodeIteratorObj(UINT8* buffer, Payload& payload, UINT16* NoOfBytesEncoded);
00244
00245     BOOLEAN DecodeDataItem(UINT8 *buffer, PC2MobileMsg& pc_2_mob, FLAG& in_out);
00246
00247     BOOLEAN DecodeSetExtn(UINT8 *buffer, PC2MobileMsg& pc_2_mob, FLAG& in_out);
00248
00249     RegEncoderDecoder(){}
00250
00251     static RegEncoderDecoder m_encoder_decoder_obj;
00252     static INT32 blob_size;
00253 };
00254
00255 #endif
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegInterface.cpp File Reference

Applications/RegEditorClient/RegInterface.cpp File Reference

#include "RegAppPreComp.hpp"
#include "RegInterface.hpp"
#include "RegAppCommon.hpp"

Include dependency graph for RegInterface.cpp:

Generated on Wed Jan 25 00:32:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegInterface.hpp File Reference

Applications/RegEditorClient/RegInterface.hpp File Reference

#include "Adc/FlsFile.hpp"
#include <Afs/Registry.hpp>
#include <Afs/Uri.hpp>
#include <Afs/AfsMsgTypes.hpp>
#include <Auxiliary/RegBlobObject.hpp>
#include <Afs/RegIterator.hpp>
#include "RegEncoderDecoder.hpp"

Include dependency graph for RegInterface.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class RegistryInterface

Generated on Wed Jan 25 00:32:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/RegEditorClient/RegInterface.hpp Source File

Applications/RegEditorClient/RegInterface.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010
00011 #include "Adc/FlsFile.hpp"
00012 #include <Afs/Registry.hpp>
00013 #include <Afs/Uri.hpp>
00014 #include <Afs/AfsMsgTypes.hpp>
00015 #include <Auxiliary/RegBlobObject.hpp>
00016
00017 #include <Afs/RegIterator.hpp>
00018
00019 #include "RegEncoderDecoder.hpp"
00020
00021 class RegistryInterface
00022 {
00023 public:
00024
00025     RegistryInterface();
00026     ~RegistryInterface();
00027
00029     static RegIterator m_regiterator;
00030
00031     //static Mobile2PCMsg& RegInterface(PC2MobileMsg& );
00032     static UINT8 RegInterface(RegEncoderDecoder::PC2MobileMsg&, RegEncoderDecoder::Mobile2PCMsg&);
00033
00034 private:
00035
00036     static RegResult DataItemInterface(const RegEncoderDecoder::PC2MobileMsg&,RegEncoderDecoder::Mobile2PCMsg&);
00037     static RegResult RegIterator(const RegEncoderDecoder::PC2MobileMsg&,RegEncoderDecoder::Mobile2PCMsg&);
00038     static RegResult RegTransaction(const RegEncoderDecoder::PC2MobileMsg&,RegEncoderDecoder::Mobile2PCMsg&);
00039     static RegResult UnlockInterface(const RegEncoderDecoder::PC2MobileMsg&, RegEncoderDecoder::Mobile2PCMsg&);
00040     static RegResult RegIteratorGetUri(const RegEncoderDecoder::PC2MobileMsg&, RegEncoderDecoder::Mobile2PCMsg&);
00041 };
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsMenu.cpp File Reference

Applications/SocketTest/FfsMenu.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestApp.hpp"
#include "FfsTestDispWin.hpp"

Include dependency graph for FfsMenu.cpp:

Generated on Wed Jan 25 00:32:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsMenu.hpp File Reference

Applications/SocketTest/FfsMenu.hpp File Reference

#include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
#include <SocketTest/FfsTestMenu.hpp>
#include <SocketTest/FfsTestDispWin.hpp>
#include <SocketTest/FfsTestResultsMenu.hpp>

Include dependency graph for FfsMenu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsMenu

Defines

#define | ApoxiApp_FfsMenu_hpp

Define Documentation

#define ApoxiApp_FfsMenu_hpp

Generated on Wed Jan 25 00:33:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsMenu.hpp Source File

Applications/SocketTest/FfsMenu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsMenu_hpp)
00011 #define ApoxiApp_FfsMenu_hpp
00012
00013 #include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
00014 #include <SocketTest/FfsTestMenu.hpp>
00015 #include <SocketTest/FfsTestDispWin.hpp>
00016 #include <SocketTest/FfsTestResultsMenu.hpp>
00017
00021 class FfsMenu : public AbstractMmiMenuAccessor
00022 {
00023     typedef AbstractMmiMenuAccessor Base;
00024
00025     public:
00026         FfsMenu();
00027         virtual ~FfsMenu();
00028
00029         void Init();
00030
00031         BOOLEAN First();
00032         BOOLEAN Next();
00033
00034         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00035         virtual const BitmapRes* GetItemIcon(BOOLEAN highlighted);
00036
00037     protected:
00038         virtual void OnTrigger(INT selected_idx);
00039
00040     private:
00042         enum State {
00043             ChooseTests,
00044             StartStop,
00045             Results,
00046             DisableAll,
00047             Default,
00048             ItemCnt
00049         };
00050
00051     protected:
00052         INT GetIndex() const { return m_idx; }
00053
00054     private:
00055         INT             m_idx;
00056
00057         MmiMenuWindow           m_ffs_settings_win;
00058         FfsTestMenu             m_ffs_settings_menu;
00059
00060         FfsTestResultsMenu      m_ffs_results_menu;
00061         MmiMenuWindow           m_ffs_results_win;
00062
00063         FfsTestDispWin      m_ffs_display_win;
00064 };
00065 #endif  // ApoxiApp_FfsMenu_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestBase.cpp File Reference

Applications/SocketTest/FfsTestBase.cpp File Reference

#include "PreComp.hpp"
#include "FfsTestBase.hpp"

Include dependency graph for FfsTestBase.cpp:

Generated on Wed Jan 25 00:33:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestBase.hpp File Reference

Applications/SocketTest/FfsTestBase.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | FfsTestBase::FfsTestInfo

Defines

#define | _SLEEP(x) Sleep(x);
#define | ADLER_JUPITER
#define | ApoxiApp_FfsTestBase_hpp

Define Documentation

#define _SLEEP ( x ) Sleep(x);

#define ADLER_JUPITER

#define ApoxiApp_FfsTestBase_hpp

Generated on Wed Jan 25 00:33:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestBase.hpp Source File

Applications/SocketTest/FfsTestBase.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsTestBase_hpp)
00011 #define ApoxiApp_FfsTestBase_hpp
00012
00013 #if defined(APOXI_RTOS_WIN32)
00014     #define _SLEEP(x) Sleep(x);
00015 #else
00016     #include <Kernel/Os/Os.hpp>
00017     #define _SLEEP(x) Os::Sleep(x);
00018 #endif
00019
00020 #define ADLER_JUPITER // define for Jupiter release only
00021
00022 class FfsTestBase
00023 {
00024 public:
00025     enum Status {
00026         Passed,
00027         Failed
00028     };
00029
00030     enum eTotalNumberOfTests
00031     {
00032         m_OpenClose,
00033         m_WriteRead,
00034         m_Overwrite,
00035         m_Append,
00036         m_Rename,
00037         m_Copy,
00038         m_nTotalNumberOfTests,
00039     };
00040
00044     struct FfsTestInfo {
00045         WCHAR   m_wsName[20];
00046         BOOLEAN m_bTestEnabled;
00047         UINT32      m_nIterationsTotal;
00048         UINT32      m_nIterationsDone;
00049         UINT32      m_nIterationsSuccessfull;
00050         UINT32      m_nErrorCode;
00051         Status  m_nStatus;
00052     };
00053
00054 public:
00055     FfsTestBase();
00056     virtual ~FfsTestBase();
00057
00058     FfsTestInfo m_FfsTests[m_nTotalNumberOfTests];
00059
00060     UINT32      GetTotalNumberOfTests() { return m_nTotalTests; }
00061     UINT32      GetNumberOfEnabledTests() { return m_nEnabledTests; }
00062     UINT32      GetNumberOfFinishedTests() { return m_nFinishedTests; }
00063     UINT32      GetNumberOfPassedTests() { return m_nPassedTests; }
00064     void        CalculateNumberOfEnabledTests();
00065     void        AddFinished() { m_nFinishedTests++; }
00066     void        AddPassed()   {m_nPassedTests++; }
00067
00068     void    SetDefaultTests();
00069     void    DisableAllTests();
00070
00071     void    StartTestSet();
00072
00073 private:
00074     UINT32 m_nTotalTests;
00075     UINT32 m_nEnabledTests;
00076     UINT32 m_nFinishedTests;
00077     UINT32 m_nPassedTests;
00078
00079     static const struct FfsTestInfo DefaultTestValues[m_nTotalNumberOfTests];
00080 };
00081
00082 #endif // ApoxiApp_FfsTestBase_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestDispWin.cpp File Reference

Applications/SocketTest/FfsTestDispWin.cpp File Reference

#include "PreComp.hpp"
#include "FfsTestDispWin.hpp"
#include "FfsTestThreadlet.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for FfsTestDispWin.cpp:

Generated on Wed Jan 25 00:33:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestDispWin.hpp File Reference

Applications/SocketTest/FfsTestDispWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <SocketTest/FfsTestThreadlet.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <GuiExtensions/CommonMessageBox.hpp>
#include <Kernel/Os/Os.hpp>

Include dependency graph for FfsTestDispWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsTestDispWin

Defines

#define | ApoxiApp_FfsTestDispWin_hpp

Define Documentation

#define ApoxiApp_FfsTestDispWin_hpp

Generated on Wed Jan 25 00:33:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestDispWin.hpp Source File

Applications/SocketTest/FfsTestDispWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsTestDispWin_hpp)
00011 #define ApoxiApp_FfsTestDispWin_hpp
00012
00013 #include <GuiExtensions/MmiWindow.hpp>
00014 #include <SocketTest/FfsTestThreadlet.hpp>
00015 #include <GuiExtensions/ActionAccessor.hpp>
00016
00017 #if !defined(ADLER_JUPITER)
00018     #include <GuiExtensions/CommonMessageBox.hpp>
00019 #endif
00020
00021 #include <Kernel/Os/Os.hpp>
00022
00027 class FfsTestDispWin : public MmiWindow
00028 {
00029     typedef MmiWindow Base;
00030
00031     public:
00032         FfsTestDispWin();
00033         virtual ~FfsTestDispWin();
00034
00035         void Init();
00036
00037         void RefreshScreen();
00038
00039         void OnTimer();
00040
00041         static FfsTestThreadlet* GetThreadlet() { return  m_threadlet; }
00042         static void ClearThreadlet() { m_threadlet = NULL; }
00043
00044         FfsTestBase* GetFfsTestBase() { return m_tests; }
00045         Mutex&       GetMutex() { return m_mutex; }
00046
00047     protected:
00048         virtual void OnOpen();
00049         virtual void OnClose();
00050         virtual void OnPaint(const Rect& repaint_rect);
00051         virtual BOOLEAN OnSoftkeyPressed(INT idx);
00052
00053     private:
00054         ActionAccessor m_left_menu;
00055         ActionAccessor m_right_menu;
00056         Action m_stop_action;
00057         Action m_start_action;
00058
00059         friend class TriggerTimer<FfsTestDispWin>;
00060         TriggerTimer<FfsTestDispWin> m_refresh_timer;
00061
00062 #if !defined(ADLER_JUPITER)
00063         CommonMessageBox m_wait_msgbox;
00064 #endif
00065         static FfsTestThreadlet* m_threadlet;
00066
00067         FfsTestBase* m_tests;
00068
00069         BOOLEAN m_start_testing;
00070
00071         Mutex m_mutex;
00072
00073         void CloseThreadlet();
00074 };
00075
00076 #endif  // ApoxiApp_FfsTestDispWin_hpp
00077
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestError.hpp File Reference

Applications/SocketTest/FfsTestError.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | ApoxiApp_FfsTestError_hpp

Typedefs

typedef eFfsTestErr | ffsError

Enumerations

enum eFfsTestErr {
FfsTestOK = 100, FfsMemAllocErr, FfsDeleteFileErr, CreateErr = FfsTestOK + 100,
FileSizeErr, OpenErr, CloseErr, FileRenameErr,
FileCopyErr, StringCmpErr, WriteErr = CreateErr + 100, ReadErr,
AppendErr = WriteErr + 100
}

Define Documentation

#define ApoxiApp_FfsTestError_hpp

Typedef Documentation

typedef eFfsTestErr ffsError

Enumeration Type Documentation

enum eFfsTestErr

Enumerator:
FfsTestOK
FfsMemAllocErr
FfsDeleteFileErr
CreateErr
FileSizeErr
OpenErr
CloseErr
FileRenameErr
FileCopyErr
StringCmpErr
WriteErr
ReadErr
AppendErr

Generated on Wed Jan 25 00:33:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestError.hpp Source File

Applications/SocketTest/FfsTestError.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsTestError_hpp)
00011 #define ApoxiApp_FfsTestError_hpp
00012
00013 enum eFfsTestErr
00014 {
00015     FfsTestOK = 100,
00016     FfsMemAllocErr,
00017     FfsDeleteFileErr,
00018     CreateErr = FfsTestOK + 100,
00019     FileSizeErr,
00020     OpenErr,
00021     CloseErr,
00022     FileRenameErr,
00023     FileCopyErr,
00024     StringCmpErr,
00025     WriteErr = CreateErr + 100,
00026     ReadErr,
00027     AppendErr = WriteErr + 100
00028 };
00029
00030 typedef eFfsTestErr ffsError;
00031
00032 #endif // ApoxiApp_FfsTestError_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestMenu.cpp File Reference

Applications/SocketTest/FfsTestMenu.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestApp.hpp"
#include "FfsTestMenu.hpp"
#include <Config/MmiGuiEngineConfig.hpp>

Include dependency graph for FfsTestMenu.cpp:

Generated on Wed Jan 25 00:33:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestMenu.hpp File Reference

Applications/SocketTest/FfsTestMenu.hpp File Reference

#include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
#include <GuiExtensions/MmiPrompt.hpp>
#include <SocketTest/FfsTestBase.hpp>

Include dependency graph for FfsTestMenu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsTestMenu
class | FfsTestSubMenu

Defines

#define | ApoxiApp_FfsTestMenu_hpp

Define Documentation

#define ApoxiApp_FfsTestMenu_hpp

Generated on Wed Jan 25 00:33:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestMenu.hpp Source File

Applications/SocketTest/FfsTestMenu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsTestMenu_hpp)
00011 #define ApoxiApp_FfsTestMenu_hpp
00012
00013 #include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
00014 #include <GuiExtensions/MmiPrompt.hpp>
00015 #include <SocketTest/FfsTestBase.hpp>
00016
00022 class FfsTestSubMenu : public AbstractMmiMenuAccessor
00023 {
00024     typedef AbstractMmiMenuAccessor Base;
00025
00026     public:
00027         FfsTestSubMenu();
00028         virtual ~FfsTestSubMenu();
00029
00030         void Init(INT test = -1);
00031
00032         BOOLEAN First();
00033         BOOLEAN Next();
00034
00035         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00036         virtual const BitmapRes* GetItemIcon(BOOLEAN highlighted);
00037
00038     protected:
00039         virtual void OnTrigger(INT selected_idx);
00040
00041     protected:
00042         INT GetIndex() const { return m_idx; }
00043
00044     private:
00045         INT             m_idx;
00046         INT             m_test_number;
00047
00048         MmiPrompt       m_iterations_prompt;
00049
00050         FfsTestBase *m_tests;
00051
00053         enum State {
00054             Enabled,
00055             FirstSubtest,
00056             ItemCnt = 2
00057         };
00058 };
00059
00064 class FfsTestMenu : public AbstractMmiMenuAccessor
00065 {
00066     typedef AbstractMmiMenuAccessor Base;
00067
00068     public:
00069         FfsTestMenu();
00070         virtual ~FfsTestMenu();
00071
00072         void Init();
00073
00074         BOOLEAN First();
00075         BOOLEAN Next();
00076
00077         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00078         virtual const BitmapRes* GetItemIcon(BOOLEAN highlighted);
00079
00080     protected:
00081         virtual void OnTrigger(INT selected_idx);
00082
00083     private:
00084         FfsTestSubMenu      m_submenu_menu;
00085         MmiMenuWindow       m_submenu_win;
00086
00088         enum State {
00089             FirstSubTest,
00090             ItemCnt  = 4
00091         };
00092
00093         FfsTestBase *m_tests;
00094
00095     protected:
00096         INT GetIndex() const { return m_idx; }
00097
00098     private:
00099         INT             m_idx;
00100 };
00101
00102 #endif  // ApoxiApp_FfsTestMenu_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestResultsMenu.cpp File Reference

Applications/SocketTest/FfsTestResultsMenu.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestApp.hpp"
#include "FfsTestResultsMenu.hpp"

Include dependency graph for FfsTestResultsMenu.cpp:

Generated on Wed Jan 25 00:34:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestResultsMenu.hpp File Reference

Applications/SocketTest/FfsTestResultsMenu.hpp File Reference

#include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
#include <GuiExtensions/MmiPrompt.hpp>
#include <SocketTest/FfsTestBase.hpp>

Include dependency graph for FfsTestResultsMenu.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsTestResultsMenu
class | FfsTestResultsSubMenu

Defines

#define | ApoxiApp_FfsTestResultsMenu_hpp

Define Documentation

#define ApoxiApp_FfsTestResultsMenu_hpp

Generated on Wed Jan 25 00:34:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestResultsMenu.hpp Source File

Applications/SocketTest/FfsTestResultsMenu.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsTestResultsMenu_hpp)
00011 #define ApoxiApp_FfsTestResultsMenu_hpp
00012
00013 #include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
00014 #include <GuiExtensions/MmiPrompt.hpp>
00015 #include <SocketTest/FfsTestBase.hpp>
00016
00020 class FfsTestResultsSubMenu : public AbstractMmiMenuAccessor
00021 {
00022     typedef AbstractMmiMenuAccessor Base;
00023
00024     public:
00025         FfsTestResultsSubMenu();
00026         virtual ~FfsTestResultsSubMenu();
00027
00028         void Init(INT test = -1);
00029
00030         BOOLEAN First();
00031         BOOLEAN Next();
00032
00033         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00034
00035     protected:
00036         virtual void OnTrigger(INT selected_idx);
00037
00038     protected:
00039         INT GetIndex() const { return m_idx; }
00040
00041     private:
00042         INT             m_idx;
00043         INT             m_test_number;
00044
00045         FfsTestBase *m_tests;
00046
00048         enum State {
00049             Total,
00050             Successfull,
00051             Failed,
00052             ErrorCode,
00053             ItemCnt
00054         };
00055 };
00056
00060 class FfsTestResultsMenu : public AbstractMmiMenuAccessor
00061 {
00062     typedef AbstractMmiMenuAccessor Base;
00063
00064     public:
00065         FfsTestResultsMenu();
00066         virtual ~FfsTestResultsMenu();
00067
00068         void Init();
00069
00070         BOOLEAN First();
00071         BOOLEAN Next();
00072
00073         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00074         virtual const BitmapRes* GetItemIcon(BOOLEAN highlighted);
00075
00076     protected:
00077         virtual void OnTrigger(INT selected_idx);
00078
00079     private:
00081         enum State {
00082             ItemCnt  = FfsTestBase::m_nTotalNumberOfTests
00083         };
00084
00085         FfsTestBase *m_tests;
00086
00087         FfsTestResultsSubMenu m_submenu_menu;
00088         MmiMenuWindow            m_submenu_win;
00089
00090     protected:
00091         INT GetIndex() const { return m_idx; }
00092
00093     private:
00094         INT             m_idx;
00095 };
00096
00097 #endif  // ApoxiApp_FfsTestResultsMenu_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTests.cpp File Reference

Applications/SocketTest/FfsTests.cpp File Reference

#include "PreComp.hpp"
#include <Afs/Ffs/FfsTypes.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include "SocketTestApp.hpp"
#include "FfsTests.hpp"

Include dependency graph for FfsTests.cpp:

Variables

const CHAR | append_text_sample [] = "This sample text is appended to the file."
const CHAR | copy_text_sample [] = "This sample text is a copy from origin file."
const CHAR | file_name [] = "FfsTestFileName"
const CHAR | new_file_name [] = "NewFfsTestFileName"
const CHAR | overwrite_text_sample [] = "This sample text overwrites some data in the file."
const CHAR | rename_text_sample [] = "This sample text is written into the origin file."
const CHAR | write_text_sample [] = "This sample text is written into the file."

Variable Documentation

const CHAR append_text_sample[] = "This sample text is appended to the file."

const CHAR copy_text_sample[] = "This sample text is a copy from origin file."

const CHAR file_name[] = "FfsTestFileName"

const CHAR new_file_name[] = "NewFfsTestFileName"

const CHAR overwrite_text_sample[] = "This sample text overwrites some data in the file."

const CHAR rename_text_sample[] = "This sample text is written into the origin file."

const CHAR write_text_sample[] = "This sample text is written into the file."

Generated on Wed Jan 25 00:34:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTests.hpp File Reference

Applications/SocketTest/FfsTests.hpp File Reference

#include <Adc/FlsFile.hpp>
#include <SocketTest/FfsTestError.hpp>
#include <SocketTest/FfsTestBase.hpp>

Include dependency graph for FfsTests.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsTests

Defines

#define | ApoxiApp_FfsTests_hpp

Define Documentation

#define ApoxiApp_FfsTests_hpp

Generated on Wed Jan 25 00:34:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTests.hpp Source File

Applications/SocketTest/FfsTests.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsTests_hpp)
00011 #define ApoxiApp_FfsTests_hpp
00012
00013 #include <Adc/FlsFile.hpp>
00014 #include <SocketTest/FfsTestError.hpp>
00015 #include <SocketTest/FfsTestBase.hpp>
00016
00017 class FfsTests
00018 {
00019     public:
00021         FfsTests();
00022         virtual ~FfsTests();
00023
00024         UINT32 FfsTest_T1();
00025         UINT32 FfsTest_T2();
00026         UINT32 FfsTest_T3();
00027         UINT32 FfsTest_T4();
00028         UINT32 FfsTest_T5();
00029         UINT32 FfsTest_T6();
00030
00031     private:
00032         FlsFile m_file;
00033         UINT32 m_req_filesize;
00034
00035         UINT32 OpenTestFile(const CHAR *a_file_name);
00036 };
00037
00038 #endif // ApoxiApp_FfsTests_hpp
Generated on Tue Jan 24 14:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestThread.cpp File Reference

Applications/SocketTest/FfsTestThread.cpp File Reference

#include "PreComp.hpp"
#include "FfsTestThread.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for FfsTestThread.cpp:

Generated on Wed Jan 25 00:34:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestThread.hpp File Reference

Applications/SocketTest/FfsTestThread.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <SocketTest/FfsTests.hpp>

Include dependency graph for FfsTestThread.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsTestThread

Defines

#define | ApoxiApp_FfsTestThread_hpp

Define Documentation

#define ApoxiApp_FfsTestThread_hpp

Generated on Wed Jan 25 00:34:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestThread.hpp Source File

Applications/SocketTest/FfsTestThread.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsTestThread_hpp)
00011 #define ApoxiApp_FfsTestThread_hpp
00012
00013 #include <Kernel/Os/Os.hpp>
00014 #include <SocketTest/FfsTests.hpp>
00015
00016 class FfsTestThread : public Thread
00017 {
00018     typedef Thread Base;
00019
00020     public:
00022         FfsTestThread();
00023         virtual ~FfsTestThread();
00024
00026         virtual INT ThreadFn();
00027
00028         static void SetRunning(BOOLEAN bRunning) { m_running = bRunning;
00029                                                     m_nCurrentTest = 0; };
00030
00031         static BOOLEAN GetRunning() { return m_running; }
00032         static UINT32 GetCurrentTest() { return m_nCurrentTest; }
00033
00034         void UpdateTestInfo(UINT32 aError);
00035
00036         void SetMutex(Mutex* aMutex) {  ASSERT_DEBUG(aMutex != NULL);
00037                                             m_disp_mutex = aMutex; }
00038
00039     private:
00040         void ExecuteTests();
00041         BOOLEAN IsEnable();
00042
00043         static BOOLEAN m_running;
00044         static UINT32 m_nCurrentTest;
00045
00046         FfsTests m_tests;
00047         Mutex *m_disp_mutex;
00048         FfsTestBase* m_test_info;
00049 };
00050
00051 #endif // ApoxiApp_FfsTestThread_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestThreadlet.cpp File Reference

Applications/SocketTest/FfsTestThreadlet.cpp File Reference

#include "PreComp.hpp"
#include "FfsTestThreadlet.hpp"
#include "FfsTestDispWin.hpp"

Include dependency graph for FfsTestThreadlet.cpp:

Generated on Wed Jan 25 00:35:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestThreadlet.hpp File Reference

Applications/SocketTest/FfsTestThreadlet.hpp File Reference

#include <Kernel/Os/Os.hpp>
#include <Kernel/Threadlet.hpp>
#include <SocketTest/FfsTests.hpp>

Include dependency graph for FfsTestThreadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FfsTestThreadlet

Defines

#define | ApoxiApp_FfsTestThreadlet_hpp

Define Documentation

#define ApoxiApp_FfsTestThreadlet_hpp

Generated on Wed Jan 25 00:35:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/FfsTestThreadlet.hpp Source File

Applications/SocketTest/FfsTestThreadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_FfsTestThreadlet_hpp)
00011 #define ApoxiApp_FfsTestThreadlet_hpp
00012
00013 #include <Kernel/Os/Os.hpp>
00014 #include <Kernel/Threadlet.hpp>
00015 #include <SocketTest/FfsTests.hpp>
00016
00017 class FfsTestDispWin;
00018
00019 class FfsTestThreadlet : public Threadlet
00020 {
00021     typedef Threadlet Base;
00022
00023     public:
00026         static FfsTestThreadlet* CreateInstance(FfsTestDispWin* dispWin);
00027
00028         virtual void ReleaseInstance();
00029
00031         virtual INT Fn();
00032
00033         static void SetRunning(BOOLEAN bRunning) { m_running = bRunning;
00034                                                     m_nCurrentTest = 0; };
00035
00036         static BOOLEAN GetRunning() { return m_running; }
00037         static UINT32 GetCurrentTest() { return m_nCurrentTest; }
00038
00039     private:
00040         FfsTestThreadlet(FfsTestDispWin* dispWin);
00041
00042         void ExecuteTests();
00043         BOOLEAN IsEnable();
00044
00045         void UpdateTestInfo(UINT32 aError);
00046
00047         static BOOLEAN m_running;
00048         static UINT32 m_nCurrentTest;
00049
00050         FfsTests m_tests;
00051         FfsTestBase* m_test_info;
00052         FfsTestDispWin* m_FfsTestDispWin;
00053 };
00054
00055 #endif // ApoxiApp_FfsTestThreadlet_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/IpAddrPrompt.cpp File Reference

Applications/SocketTest/IpAddrPrompt.cpp File Reference

#include "PreComp.hpp"
#include "IpAddrPrompt.hpp"

Include dependency graph for IpAddrPrompt.cpp:

Generated on Tue Jan 24 23:56:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/IpAddrPrompt.hpp File Reference

Applications/SocketTest/IpAddrPrompt.hpp File Reference

#include <GuiExtensions/AbstractMmiPrompt.hpp>
#include <Gui/IpAddrEditor.hpp>

Include dependency graph for IpAddrPrompt.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | IpAddrPrompt

Defines

#define | Apoxi_IpAddrPrompt_hpp

Define Documentation

#define Apoxi_IpAddrPrompt_hpp

Generated on Tue Jan 24 23:56:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/IpAddrPrompt.hpp Source File

Applications/SocketTest/IpAddrPrompt.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Apoxi_IpAddrPrompt_hpp)
00009 #define Apoxi_IpAddrPrompt_hpp
00012
00013 #include <GuiExtensions/AbstractMmiPrompt.hpp>
00014 #include <Gui/IpAddrEditor.hpp>
00015
00016 class IpAddrPrompt : public AbstractMmiPrompt {
00017     public:
00018         typedef AbstractMmiPrompt Base;
00019
00020         IpAddrPrompt();
00021         virtual ~IpAddrPrompt();
00022
00023         void Init(const WCHAR* title = 0);
00024
00025         void SetIpAddr(const IpAddr &ip_addr) { m_editor.SetIpAddr(ip_addr); }
00026         IpAddr GetIpAddr() { return m_editor.GetIpAddr(); }
00027
00028     protected:
00029         virtual AbstractEditor* GetEditor() { return &m_editor; }
00030
00031     private:
00032         IpAddrEditor    m_editor;
00033 };
00034
00036 #endif  // Apoxi_IpAddrPrompt_hpp
00037
Generated on Tue Jan 24 14:51:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/PreComp.cpp File Reference

Applications/SocketTest/PreComp.cpp File Reference

#include "PreComp.hpp"

Include dependency graph for PreComp.cpp:

Generated on Tue Jan 24 15:16:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/PreComp.hpp File Reference

Applications/SocketTest/PreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Asc/Lib.hpp>

Include dependency graph for PreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Tue Jan 24 15:25:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/PreComp.hpp Source File

Applications/SocketTest/PreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Adc/Lib.hpp>
00013 #include <Apc/Lib.hpp>
00014 #include <Asc/Lib.hpp>
Generated on Tue Jan 24 14:44:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestApp.cpp File Reference

Applications/SocketTest/SocketTestApp.cpp File Reference

#include "PreComp.hpp"
#include <Common/CommonMsgTypes.hpp>
#include <Common/ApplicationManager.hpp>
#include <Socket/DataConnProfileManager.hpp>
#include "SocketTestMsgTypes.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for SocketTestApp.cpp:

Variables

UINT | s_continue_msgs_handled = 0
UINT | s_continue_msgs_sent = 0

Variable Documentation

UINT s_continue_msgs_handled = 0

UINT s_continue_msgs_sent = 0

Generated on Wed Jan 25 00:35:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestApp.hpp File Reference

Applications/SocketTest/SocketTestApp.hpp File Reference

#include <Common/MmiApplication.hpp>
#include <GuiExtensions/MenuAction.hpp>
#include <Socket/SocketHandler.hpp>
#include <SocketTest/SocketTestWin.hpp>
#include <SocketTest/SocketTestTests.hpp>

Include dependency graph for SocketTestApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestApp
struct | SocketTestApp::menuItems

Defines

#define | ApoxiApp_SocketTestApp_hpp

Define Documentation

#define ApoxiApp_SocketTestApp_hpp

Generated on Wed Jan 25 00:35:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestApp.hpp Source File

Applications/SocketTest/SocketTestApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestApp_hpp)
00011 #define ApoxiApp_SocketTestApp_hpp
00012
00013 #include <Common/MmiApplication.hpp>
00014 #include <GuiExtensions/MenuAction.hpp>
00015 #include <Socket/SocketHandler.hpp>
00016 #include <SocketTest/SocketTestWin.hpp>
00017 #include <SocketTest/SocketTestTests.hpp>
00018
00022 class SocketTestApp : public MmiApplication
00023 {
00024     typedef MmiApplication Base;
00025
00026     public:
00027         virtual ~SocketTestApp();
00028
00029         static SocketTestApp* GetInstance() { return &m_app; }
00030
00031         void Init();
00032
00033         struct menuItems {
00034             IpAddr m_ipGatewayAddr;
00035             IpPortNo m_nGatewayPort;
00036             UINT32 m_nMaxTCPPacketSize;
00037             UINT32 m_nMaxUDPPacketSize;
00038             UINT32 m_nMaxTCPSockets;
00039             UINT32 m_nMaxUDPSockets;
00040             UINT32 m_nTimeout;
00041         } *m_settings;
00042
00043         SocketTestTests *GetTests() { return m_tests; }
00044         FfsTestBase* GetFfsTestBase() { return m_FfsTestBase; }
00045
00046         void    StartTests();
00047         void    StopTests();
00048         BOOLEAN areTestsFinished() { return !m_bTestsRunning;}
00049         void    SkipCurrentTest();
00050
00051         INT GetCurrentTestNr() { return m_nCurrentTestNr; }
00052         INT GetCurrentTestID() { return ((m_nCurrentTestGroup + 1) * 100 + m_nCurrentTestNr + 1); }
00053         INT GetCurrentTestGroup() { return m_nCurrentTestGroup; }
00054         SocketTestT::Status     GetLastStatus() { return m_tests->m_sTests[m_nCurrentTestGroup].m_nStatus[m_nCurrentTestNr]; }
00055         UINT32      GetTotalIterations() { return m_tests->m_sTests[m_nCurrentTestGroup].m_nIterationsTotal[m_nCurrentTestNr]; }
00056         UINT32      GetSuccessfullIterations() { return m_tests->m_sTests[m_nCurrentTestGroup].m_nIterationsSuccessfull[m_nCurrentTestNr]; }
00057         UINT32      GetLastIteration() { return m_tests->m_sTests[m_nCurrentTestGroup].m_nIterationsDone[m_nCurrentTestNr]; }
00058         INT     GetLastError() { return m_tests->m_sTests[m_nCurrentTestGroup].m_nErrorCode[m_nCurrentTestNr]; }
00059
00060         void    StartTimeoutTimer() { if (m_settings->m_nTimeout) { m_timer.Init(&m_app, 1000*m_settings->m_nTimeout); m_timer.Start(); } }
00061         void    StopTimeoutTimer() { if (m_timer.IsActive()) m_timer.Stop(); }
00062
00063         DataConnProfileId   m_nPSDid;
00064         DataConnProfileId   m_nCSDid;
00065         DataConnProfileId   m_nSERid;
00066
00067         void                FindDataConnProfiles();
00068
00069     protected:
00070         static SocketTestApp        m_app;
00071
00072         virtual void OnStartup();
00073         void OnOpen();
00074
00075         BOOLEAN OnMessage(const Message &msg);
00076         void OnTriggerNotification (INT16 arg);
00077
00078 #if !defined(ADLER_JUPITER)
00079         CommonMessageBox m_wait_msgbox;
00080 #endif
00081
00082 //      INT m_nDownloadTime;
00083         virtual void OnTimer();
00084
00085     private:
00086         friend class TriggerTimer<SocketTestApp>;
00087         TriggerTimer<SocketTestApp> m_timer;
00088
00089         void ExecuteSocketTest(UINT group, UINT test, BOOLEAN finish = FALSE);
00090         void ExecuteNextSocketTest();
00091         BOOLEAN m_bTestsRunning;
00092         INT m_nCurrentTestNr;
00093         INT m_nCurrentTestGroup;
00094         SocketTestApp();
00095
00096         SocketTestWin       m_socket_test_win;
00097         MenuAction          m_open_sockettest_action;
00098
00099         SocketTestTests     *m_tests;
00100         FfsTestBase         *m_FfsTestBase;
00101
00102         SocketHandler       m_socket_handler;
00103 };
00104
00105 #endif // ApoxiApp_SocketTestApp_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestDefines.hpp File Reference

Applications/SocketTest/SocketTestDefines.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | ApoxiApp_SocketTestDefines_hpp
#define | KBYTE 1024

Enumerations

enum ErrorCode {
ST_ERR_ALLOCATION = 200, ST_ERR_SOCKALLOC = 201, ST_ERR_CLOSE = 202, ST_ERR_WRONGDATA = 203,
ST_ERR_USERINTERRUPT = 204, ST_ERR_WRITESOCK_CONTEXT = 205, ST_ERR_WRITESOCK_UNKNOWN = 206, ST_ERR_NOT_ALL_PACKETS_RECEIVED = 207,
ST_ERR_SET_DATACONN_PROFILE_ID = 208, ST_ERR_SERVER_SOCK_LISTEN = 209
}

Define Documentation

#define ApoxiApp_SocketTestDefines_hpp

#define KBYTE 1024

Enumeration Type Documentation

enum ErrorCode

ErrorCode Error codes that can occur during tests.

Enumerator:
ST_ERR_ALLOCATION | Error during memory allocation.
ST_ERR_SOCKALLOC | Error during socket allocation.
ST_ERR_CLOSE | Error while closing socket.
ST_ERR_WRONGDATA | Wrong data received on socket.
ST_ERR_USERINTERRUPT | User or timeout stopped test.
ST_ERR_WRITESOCK_CONTEXT | Lost context or data connection.
ST_ERR_WRITESOCK_UNKNOWN | Error during writing data if GetError() returns 0.
ST_ERR_NOT_ALL_PACKETS_RECEIVED | Socket did not receive all packets.
ST_ERR_SET_DATACONN_PROFILE_ID | Setting the data connection profile ID to the socket failed.
ST_ERR_SERVER_SOCK_LISTEN | Putting a server socket into listen state failed.

Generated on Wed Jan 25 00:35:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestDefines.hpp Source File

Applications/SocketTest/SocketTestDefines.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestDefines_hpp)
00011 #define ApoxiApp_SocketTestDefines_hpp
00012
00017 enum ErrorCode {
00018     ST_ERR_ALLOCATION               = 200,
00019     ST_ERR_SOCKALLOC                = 201,
00020     ST_ERR_CLOSE                    = 202,
00021     ST_ERR_WRONGDATA                = 203,
00022     ST_ERR_USERINTERRUPT            = 204,
00023     ST_ERR_WRITESOCK_CONTEXT        = 205,
00024     ST_ERR_WRITESOCK_UNKNOWN        = 206,
00025     ST_ERR_NOT_ALL_PACKETS_RECEIVED = 207,
00026     ST_ERR_SET_DATACONN_PROFILE_ID  = 208,
00027     ST_ERR_SERVER_SOCK_LISTEN       = 209
00028 };
00029
00030 #define KBYTE 1024
00031
00032 #endif // ApoxiApp_SocketTestDefines_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestMsgTypes.cpp File Reference

Applications/SocketTest/SocketTestMsgTypes.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestMsgTypes.hpp"

Include dependency graph for SocketTestMsgTypes.cpp:

Generated on Wed Jan 25 00:35:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestMsgTypes.hpp File Reference

Applications/SocketTest/SocketTestMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/WString.hpp>

Include dependency graph for SocketTestMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ContinueSocketTestMsg
class | NextSocketTestMsg
class | SkipSocketTestMsg
class | StartSocketTestMsg
class | StopSocketTestMsg

Defines

#define | SocketTestMsgTypes_hpp__ST_1092045237546

Define Documentation

#define SocketTestMsgTypes_hpp__ST_1092045237546

Generated on Wed Jan 25 00:35:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestMsgTypes.hpp Source File

Applications/SocketTest/SocketTestMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     --------------------------------------------------------
00009     ========================================================
00010     This file was generated with ApoxiMessageGenerator as
00011     defined in "src\koglerm_host\lnz_development\src\Applications\SocketTest\SocketTestMsgTypes.xml"
00012     DO NOT CHANGE IT MANUALLY!
00013     --------------------------------------------------------------*/
00014
00015
00016 #if !defined(SocketTestMsgTypes_hpp__ST_1092045237546)
00017 #define SocketTestMsgTypes_hpp__ST_1092045237546
00018
00019 #include <Kernel/Message.hpp>
00020 #include <Auxiliary/WString.hpp>
00021
00022
00023 /* ----------------------------------------------------------------------
00024     Classes
00025     ---------------------------------------------------------------------- */
00026
00027 /*  ======================================================================
00028     Class StartSocketTestMsg
00029     ====================================================================== */
00030
00031 class StartSocketTestMsg : public ContextMsg {
00032     public:
00033         StartSocketTestMsg(ExecutionContext* context);
00034         virtual ~StartSocketTestMsg();
00035
00036         virtual const MsgMetaData& GetMetaData() const;
00037         virtual Message* Clone() const;
00038
00039         enum  {
00040             ID = 21900
00041             };
00042
00043     private:
00044         static const MsgMetaData m_meta_data;
00045
00046     };
00047
00048
00049 /*  ======================================================================
00050     Class NextSocketTestMsg
00051     ====================================================================== */
00052
00053 class NextSocketTestMsg : public ContextMsg {
00054     public:
00055         NextSocketTestMsg(ExecutionContext* context);
00056         virtual ~NextSocketTestMsg();
00057
00058         virtual const MsgMetaData& GetMetaData() const;
00059         virtual Message* Clone() const;
00060
00061         enum  {
00062             ID = 21901
00063             };
00064
00065     private:
00066         static const MsgMetaData m_meta_data;
00067
00068     };
00069
00070
00071 /*  ======================================================================
00072     Class ContinueSocketTestMsg
00073     ====================================================================== */
00074
00075 class ContinueSocketTestMsg : public ContextMsg {
00076     public:
00077         ContinueSocketTestMsg(ExecutionContext* context);
00078         virtual ~ContinueSocketTestMsg();
00079
00080         virtual const MsgMetaData& GetMetaData() const;
00081         virtual Message* Clone() const;
00082
00083         enum  {
00084             ID = 21902
00085             };
00086
00087     private:
00088         static const MsgMetaData m_meta_data;
00089
00090     };
00091
00092
00093 /*  ======================================================================
00094     Class StopSocketTestMsg
00095     ====================================================================== */
00096
00097 class StopSocketTestMsg : public ContextMsg {
00098     public:
00099         StopSocketTestMsg(ExecutionContext* context);
00100         virtual ~StopSocketTestMsg();
00101
00102         virtual const MsgMetaData& GetMetaData() const;
00103         virtual Message* Clone() const;
00104
00105         enum  {
00106             ID = 21903
00107             };
00108
00109     private:
00110         static const MsgMetaData m_meta_data;
00111
00112     };
00113
00114
00115 /*  ======================================================================
00116     Class SkipSocketTestMsg
00117     ====================================================================== */
00118
00119 class SkipSocketTestMsg : public ContextMsg {
00120     public:
00121         SkipSocketTestMsg(ExecutionContext* context);
00122         virtual ~SkipSocketTestMsg();
00123
00124         virtual const MsgMetaData& GetMetaData() const;
00125         virtual Message* Clone() const;
00126
00127         enum  {
00128             ID = 21904
00129             };
00130
00131     private:
00132         static const MsgMetaData m_meta_data;
00133
00134     };
00135
00136 #endif // SocketTestMsgTypes_hpp__ST_1092045237546
00137
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestProgressWin.cpp File Reference

Applications/SocketTest/SocketTestProgressWin.cpp File Reference

#include "PreComp.hpp"
#include <Phonebook/PbPreComp.hpp>
#include "SocketTestProgressWin.hpp"
#include "SocketTestApp.hpp"
#include <Common/MmiServices.hpp>

Include dependency graph for SocketTestProgressWin.cpp:

Generated on Wed Jan 25 00:36:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestProgressWin.hpp File Reference

Applications/SocketTest/SocketTestProgressWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/MmiMenuWindow.hpp>
#include <GuiExtensions/PopupMenu.hpp>
#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for SocketTestProgressWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestProgressWin

Defines

#define | ApoxiApp_SocketTestProgressWin_hpp

Define Documentation

#define ApoxiApp_SocketTestProgressWin_hpp

Generated on Wed Jan 25 00:36:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestProgressWin.hpp Source File

Applications/SocketTest/SocketTestProgressWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestProgressWin_hpp)
00011 #define ApoxiApp_SocketTestProgressWin_hpp
00012
00013 #include <GuiExtensions/MmiWindow.hpp>
00014 #include <GuiExtensions/MmiMenuWindow.hpp>
00015 #include <GuiExtensions/PopupMenu.hpp>
00016 #include <GuiExtensions/ActionAccessor.hpp>
00017
00022 class SocketTestProgressWin : public MmiWindow
00023 {
00024     typedef MmiWindow Base;
00025
00026     public:
00027         SocketTestProgressWin();
00028         virtual ~SocketTestProgressWin();
00029
00030         void Init();
00031
00032         void RefreshScreen();
00033
00034         void OnTimer();
00035
00036     protected:
00037         virtual void OnOpen();
00038         virtual void OnClose();
00039         virtual void OnPaint(const Rect &repaint_rect);
00040         virtual void OnActionExecuted(Action *action);
00041
00042     private:
00043         ActionAccessor m_left_menu;
00044         ActionAccessor m_right_menu;
00045         Action m_stop_action;
00046         Action m_next_action;
00047
00048         friend class TriggerTimer<SocketTestProgressWin>;
00049         TriggerTimer<SocketTestProgressWin> m_refresh_timer;
00050 };
00051
00052 #endif  // ApoxiApp_SocketTestProgressWin_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestResultsWin.cpp File Reference

Applications/SocketTest/SocketTestResultsWin.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestResultsWin.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for SocketTestResultsWin.cpp:

Generated on Wed Jan 25 00:36:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestResultsWin.hpp File Reference

Applications/SocketTest/SocketTestResultsWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>

Include dependency graph for SocketTestResultsWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestResultsWin

Defines

#define | ApoxiApp_SocketTestResultsWin_hpp

Define Documentation

#define ApoxiApp_SocketTestResultsWin_hpp

Generated on Wed Jan 25 00:36:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestResultsWin.hpp Source File

Applications/SocketTest/SocketTestResultsWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestResultsWin_hpp)
00011 #define ApoxiApp_SocketTestResultsWin_hpp
00012
00013 #include <GuiExtensions/MmiWindow.hpp>
00014
00015 class SocketTestResultsWin : public MmiWindow {
00016     typedef MmiWindow Base;
00017
00018     public:
00019         SocketTestResultsWin();
00020         virtual ~SocketTestResultsWin();
00021
00022         void Init();
00023
00024     protected:
00025         virtual void OnActionExecuted(Action* action);
00026
00027     private:
00028         Action m_select_action;
00029         Action m_close_action;
00030         ItemMenu m_menu;
00031
00032         void AddTestItems();
00033 };
00034
00035 #endif  // ApoxiApp_SocketTestResultsWin_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestSettingsWin.cpp File Reference

Applications/SocketTest/SocketTestSettingsWin.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestSettingsWin.hpp"
#include <SocketTest/SocketTestApp.hpp>
#include <Config/MmiGuiEngineConfig.hpp>

Include dependency graph for SocketTestSettingsWin.cpp:

Generated on Wed Jan 25 00:36:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestSettingsWin.hpp File Reference

Applications/SocketTest/SocketTestSettingsWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/MmiMenuWindow.hpp>
#include <GuiExtensions/MmiPrompt.hpp>
#include "IpAddrPrompt.hpp"

Include dependency graph for SocketTestSettingsWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestSettingsWin

Defines

#define | ApoxiaPP_SocketTestSettingsWin_hpp

Define Documentation

#define ApoxiaPP_SocketTestSettingsWin_hpp

Generated on Wed Jan 25 00:36:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestSettingsWin.hpp Source File

Applications/SocketTest/SocketTestSettingsWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiaPP_SocketTestSettingsWin_hpp)
00011 #define ApoxiaPP_SocketTestSettingsWin_hpp
00012
00013 #include <GuiExtensions/MmiWindow.hpp>
00014 #include <GuiExtensions/MmiMenuWindow.hpp>
00015 #include <GuiExtensions/MmiPrompt.hpp>
00016 #include "IpAddrPrompt.hpp"
00017
00018 class SocketTestSettingsWin : public MmiWindow {
00019     typedef MmiWindow Base;
00020
00021     public:
00022         SocketTestSettingsWin();
00023         virtual ~SocketTestSettingsWin();
00024
00025         void Init();
00026
00027     protected:
00028         virtual void OnActionExecuted(Action* action);
00029
00030     private:
00031         Action m_select_action;
00032         Action m_close_action;
00033
00034         ItemContainer m_choose_tests_item_container;
00035         Action m_disable_all_tests_action;
00036         Action m_choose_default_tests_action;
00037         Action m_gateway_ip_action;
00038         Action m_gateway_port_action;
00039         Action m_max_tcp_packet_size_action;
00040         Action m_max_udp_packet_size_action;
00041         Action m_max_tcp_sockets_action;
00042         Action m_max_udp_sockets_action;
00043         Action m_timeout_action;
00044
00045         ItemMenu m_menu;
00046
00047         IpAddrPrompt m_gateway_ip_prompt;
00048         MmiPrompt m_prompt;
00049
00050         void UpdateGatewayIp();
00051         void UpdateGatewayPort();
00052         void UpdateMaxTcpPacketSize();
00053         void UpdateMaxUdpPacketSize();
00054         void UpdateMaxTcpSockets();
00055         void UpdateMaxUdpSockets();
00056         void UpdateTimeout();
00057         void EnterValue(const WCHAR*title, UINT32 &value);
00058
00059         void AddChooseTestsItems();
00060 };
00061
00062 #endif  // ApoxiaPP_SocketTestSettingsWin_hpp
00063
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT.cpp File Reference

Applications/SocketTest/SocketTestT.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for SocketTestT.cpp:

Generated on Wed Jan 25 00:36:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT.hpp File Reference

Applications/SocketTest/SocketTestT.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | DownloadSettings
class | SocketTestMessage
class | SocketTestT

Defines

#define | ApoxiApp_SocketTestT_hpp

Enumerations

enum testMessageType {
SEND_UDP, SEND_TCP, REPORT, FINAL_REPORT,
RESPONSE, STOP_UDP, STOP_TCP, STOP_ALL
}

Define Documentation

#define ApoxiApp_SocketTestT_hpp

Enumeration Type Documentation

enum testMessageType

Enumerator:
SEND_UDP
SEND_TCP
REPORT
FINAL_REPORT
RESPONSE
STOP_UDP
STOP_TCP
STOP_ALL

Generated on Wed Jan 25 00:37:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT.hpp Source File

Applications/SocketTest/SocketTestT.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT_hpp)
00011 #define ApoxiApp_SocketTestT_hpp
00012
00013 class SocketTestT
00014 {
00015 public:
00016     enum Status {
00017         Skipped,
00018         InProgress,
00019         Passed,
00020         Failed
00021     };
00022
00023     enum internalStatus {
00024         NotStarted,
00025         FinishedOK,
00026         FinishedErr,
00027         Started,
00028         WaitingForInit,
00029         WaitingForConnect,
00030         Write,
00031         WaitingForWrite,
00032         WaitingForRead,
00033         WaitingForClose
00034     };
00035
00036     SocketTestT();
00037     virtual ~SocketTestT();
00038
00039     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00040     virtual internalStatus  TestB(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00041     virtual internalStatus  TestC(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00042     virtual internalStatus  TestD(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00043     virtual internalStatus  TestE(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00044     virtual internalStatus  TestF(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00045     virtual internalStatus  TestG(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00046     virtual internalStatus  TestH(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00047     virtual internalStatus  TestI(internalStatus instatus, INT &ErrorCode) { return NotStarted; }
00048     virtual void FinishGroup() { }
00049
00050 protected:
00051     UINT32 Random(UINT32 start, UINT32 end) { return rand() % (end - start + 1) + start; }
00052 };
00053
00054 enum testMessageType {
00055     SEND_UDP,
00056     SEND_TCP,
00057     REPORT,
00058     FINAL_REPORT,
00059     RESPONSE,
00060     STOP_UDP,
00061     STOP_TCP,
00062     STOP_ALL
00063 };
00064
00065 typedef struct
00066 {
00067     UINT32 m_nDataSize;
00068     UINT32 m_nPacketSize;
00069     UINT32 m_nServerDelay;
00070     UINT32 m_nDownloadTime;
00071 } DownloadSettings;
00072
00077 class SocketTestMessage
00078 {
00079 public:
00080     SocketTestMessage(INT size);
00081     SocketTestMessage();
00082     ~SocketTestMessage();
00083
00084     INT GetSize() { return m_nSize; }
00085     char* GetMessage() { return m_pMessage; }
00086     BOOLEAN AddToMessage(enum testMessageType type, UINT32 size = 0, UINT32 packets = 1, UINT32 freq = 0);
00087     void Clean();
00088
00089 private:
00090     INT  m_nSize;
00091     char *m_pMessage;
00092     void AddPreviousTests(String &tmpstring, INT last_group);
00093 };
00094
00095 #endif // ApoxiApp_SocketTestT_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT1.cpp File Reference

Applications/SocketTest/SocketTestT1.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT1.hpp"
#include "SocketTestDefines.hpp"
#include <Socket/UdpSocket.hpp>
#include <Socket/TcpSocket.hpp>

Include dependency graph for SocketTestT1.cpp:

Generated on Wed Jan 25 00:37:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT1.hpp File Reference

Applications/SocketTest/SocketTestT1.hpp File Reference

#include <SocketTest/SocketTestT.hpp>

Include dependency graph for SocketTestT1.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestT1

Defines

#define | ApoxiApp_SocketTestT1_hpp

Define Documentation

#define ApoxiApp_SocketTestT1_hpp

Generated on Wed Jan 25 00:37:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT1.hpp Source File

Applications/SocketTest/SocketTestT1.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT1_hpp)
00011 #define ApoxiApp_SocketTestT1_hpp
00012
00013 #include <SocketTest/SocketTestT.hpp>
00014
00015 class TcpSocket;
00016 class UdpSocket;
00017
00021 class SocketTestT1 : public SocketTestT
00022 {
00023 public:
00024     SocketTestT1() { }
00025     virtual ~SocketTestT1() { }
00026
00027     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode);
00028     virtual internalStatus  TestB(internalStatus instatus, INT &ErrorCode);
00029
00030 private:
00031     internalStatus CloseTcpSocket(TcpSocket **socket, INT &ErrorCode);
00032     internalStatus OpenTcpSocket(TcpSocket **socket, INT &ErrorCode);
00033     internalStatus CloseUdpSocket(UdpSocket **socket, INT &ErrorCode);
00034     internalStatus OpenUdpSocket(UdpSocket **socket, INT &ErrorCode);
00035 };
00036
00037 #endif // ApoxiApp_SocketTestT1_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT2.cpp File Reference

Applications/SocketTest/SocketTestT2.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT2.hpp"
#include "SocketTestApp.hpp"
#include "SocketTestDefines.hpp"
#include "UdpTestSocket.hpp"
#include <Socket/Sys/SysSocket.hpp>

Include dependency graph for SocketTestT2.cpp:

Generated on Wed Jan 25 00:37:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT2.hpp File Reference

Applications/SocketTest/SocketTestT2.hpp File Reference

#include <SocketTest/SocketTestT.hpp>

Include dependency graph for SocketTestT2.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestT2

Defines

#define | ApoxiApp_SocketTestT2_hpp

Define Documentation

#define ApoxiApp_SocketTestT2_hpp

Generated on Wed Jan 25 00:37:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT2.hpp Source File

Applications/SocketTest/SocketTestT2.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT2_hpp)
00011 #define ApoxiApp_SocketTestT2_hpp
00012
00013 #include <SocketTest/SocketTestT.hpp>
00014
00015 class InetSocketAddr;
00016 class SysSocket;
00017
00021 class SocketTestT2 : public SocketTestT
00022 {
00023 public:
00024     SocketTestT2();
00025     virtual ~SocketTestT2();
00026
00027     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode);
00028     virtual internalStatus TestB(internalStatus instatus, INT &ErrorCode);
00029
00030     void CleanUdpSocket(INT &ErrorCode, SocketTestMessage *&pMessage);
00031
00032     INT ClientSend(const void *buf, INT buflen);
00033     INT ServerRead(void *buf, INT buflen, SysSocket *aSocket);
00034
00035     void CleanTcpSocket(INT &ErrorCode, SysSocket *aSocket, SocketTestMessage *&pMessage);
00036
00037 private:
00038     SysSocket *m_pUdpSocket;
00039     SysSocket *m_pTcpServer;
00040     SysSocket *m_pTcpClient;
00041 };
00042
00043 #endif // ApoxiApp_SocketTestT2_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT3.cpp File Reference

Applications/SocketTest/SocketTestT3.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT3.hpp"
#include "SocketTestApp.hpp"
#include "SocketTestDefines.hpp"
#include "UdpTestSocket.hpp"

Include dependency graph for SocketTestT3.cpp:

Generated on Wed Jan 25 00:37:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT3.hpp File Reference

Applications/SocketTest/SocketTestT3.hpp File Reference

#include <SocketTest/SocketTestT.hpp>
#include <Socket/SocketTypes.hpp>
#include <Socket/InetSocketAddr.hpp>

Include dependency graph for SocketTestT3.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestT3

Defines

#define | ApoxiApp_SocketTestT3_hpp

Define Documentation

#define ApoxiApp_SocketTestT3_hpp

Generated on Wed Jan 25 00:37:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT3.hpp Source File

Applications/SocketTest/SocketTestT3.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT3_hpp)
00011 #define ApoxiApp_SocketTestT3_hpp
00012
00013 #include <SocketTest/SocketTestT.hpp>
00014 #include <Socket/SocketTypes.hpp>
00015 #include <Socket/InetSocketAddr.hpp>
00016
00017 class UdpTestSocket;
00018
00022 class SocketTestT3 : public SocketTestT
00023 {
00024 public:
00025     SocketTestT3();
00026
00027     virtual ~SocketTestT3();
00028
00029     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode);
00030     virtual internalStatus  TestB(internalStatus instatus, INT &ErrorCode);
00031     virtual internalStatus  TestC(internalStatus instatus, INT &ErrorCode);
00032     virtual internalStatus  TestD(internalStatus instatus, INT &ErrorCode);
00033     virtual internalStatus  TestE(internalStatus instatus, INT &ErrorCode);
00034     virtual void FinishGroup();
00035
00036     DownloadSettings m_PsdDownloadSettings;
00037
00038 protected:
00039     internalStatus  TestABCD(internalStatus instatus, INT &ErrorCode, BOOLEAN selfTest=FALSE, BOOLEAN download=FALSE);
00040     UINT32 m_nNumberOfPackets;
00041     UINT m_nNumberOfSockets;
00042     DataConnProfileId m_profileId;
00043     void SendFinalReport(DataConnProfileId profileId);
00044
00045 private:
00046     SocketTestMessage *m_pMessage;
00047     UINT32 m_nlenIn;
00048     UINT32 m_nFrequency;
00049     InetSocketAddr m_addressOut;
00050
00051     INT m_nCurrentSocket;
00052     UdpTestSocket *m_ppUdpSocket[15];
00053     INT m_nWaitingForSockets;
00054     UdpTestSocket *m_pUdpReportSocket;
00055 };
00056
00057 #endif // ApoxiApp_SocketTestT3_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT4.cpp File Reference

Applications/SocketTest/SocketTestT4.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT4.hpp"
#include "SocketTestApp.hpp"
#include "SocketTestDefines.hpp"
#include "TcpTestSocket.hpp"
#include "TcpServerTestSocket.hpp"

Include dependency graph for SocketTestT4.cpp:

Generated on Wed Jan 25 00:38:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT4.hpp File Reference

Applications/SocketTest/SocketTestT4.hpp File Reference

#include <SocketTest/SocketTestT.hpp>
#include <Socket/SocketTypes.hpp>

Include dependency graph for SocketTestT4.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestT4

Defines

#define | ApoxiApp_SocketTestT4_hpp

Define Documentation

#define ApoxiApp_SocketTestT4_hpp

Generated on Wed Jan 25 00:38:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT4.hpp Source File

Applications/SocketTest/SocketTestT4.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT4_hpp)
00011 #define ApoxiApp_SocketTestT4_hpp
00012
00013 #include <SocketTest/SocketTestT.hpp>
00014 #include <Socket/SocketTypes.hpp>
00015
00016 class TcpTestSocket;
00017 class TcpServerTestSocket;
00018
00022 class SocketTestT4 : public SocketTestT
00023 {
00024 public:
00025     SocketTestT4();
00026
00027     virtual ~SocketTestT4();
00028
00029     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode);
00030     virtual internalStatus  TestB(internalStatus instatus, INT &ErrorCode);
00031     virtual internalStatus  TestC(internalStatus instatus, INT &ErrorCode);
00032     virtual internalStatus  TestD(internalStatus instatus, INT &ErrorCode);
00033     virtual void FinishGroup();
00034
00035 protected:
00036     UINT32 m_nNumberOfPackets;
00037     UINT m_nNumberOfSockets;
00038     DataConnProfileId m_profileId;
00039
00040 protected:
00041     internalStatus  TestBCD(internalStatus instatus, INT &ErrorCode);
00042     internalStatus  TestAA(internalStatus instatus, INT &ErrorCode);
00043     void SendFinalReport(DataConnProfileId profileId);
00044
00045     TcpTestSocket *m_pTcpOutSocket;
00046     TcpServerTestSocket *m_pTcpServerSocket;
00047     TcpTestSocket *m_pTcpInSocket;
00048     SocketTestMessage *m_pMessage;
00049     UINT32 m_nlenIn;
00050     UINT m_nStartNumber;
00051
00052     INT m_nCurrentSocket;
00053     TcpTestSocket *m_ppTcpSocket[15];
00054     INT m_nWaitingForSockets;
00055     TcpTestSocket *m_pTcpReportSocket;
00056 };
00057
00058 #endif // ApoxiApp_SocketTestT4_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT5.cpp File Reference

Applications/SocketTest/SocketTestT5.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT5.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for SocketTestT5.cpp:

Generated on Wed Jan 25 00:38:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT5.hpp File Reference

Applications/SocketTest/SocketTestT5.hpp File Reference

#include <SocketTest/SocketTestT3.hpp>

Include dependency graph for SocketTestT5.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestT5

Defines

#define | ApoxiApp_SocketTestT5_hpp

Define Documentation

#define ApoxiApp_SocketTestT5_hpp

Generated on Wed Jan 25 00:38:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT5.hpp Source File

Applications/SocketTest/SocketTestT5.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT5_hpp)
00011 #define ApoxiApp_SocketTestT5_hpp
00012
00013 #include <SocketTest/SocketTestT3.hpp>
00014
00018 class SocketTestT5 : public SocketTestT3
00019 {
00020 public:
00021     SocketTestT5() { }
00022
00023     virtual ~SocketTestT5() { }
00024
00025     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode);
00026     virtual internalStatus  TestB(internalStatus instatus, INT &ErrorCode);
00027     virtual internalStatus  TestC(internalStatus instatus, INT &ErrorCode);
00028     virtual internalStatus  TestD(internalStatus instatus, INT &ErrorCode);
00029     virtual internalStatus  TestE(internalStatus instatus, INT &ErrorCode);
00030
00031     virtual void FinishGroup();
00032
00033     DownloadSettings m_CsdDownloadSettings;
00034 };
00035
00036 #endif // ApoxiApp_SocketTestT5_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT6.cpp File Reference

Applications/SocketTest/SocketTestT6.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT6.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for SocketTestT6.cpp:

Generated on Wed Jan 25 00:38:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT6.hpp File Reference

Applications/SocketTest/SocketTestT6.hpp File Reference

#include <SocketTest/SocketTestT4.hpp>

Include dependency graph for SocketTestT6.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestT6

Defines

#define | ApoxiApp_SocketTestT6_hpp

Define Documentation

#define ApoxiApp_SocketTestT6_hpp

Generated on Wed Jan 25 00:38:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT6.hpp Source File

Applications/SocketTest/SocketTestT6.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT6_hpp)
00011 #define ApoxiApp_SocketTestT6_hpp
00012
00013 #include <SocketTest/SocketTestT4.hpp>
00014
00018 class SocketTestT6 : public SocketTestT4
00019 {
00020 public:
00021     SocketTestT6() { }
00022
00023     virtual ~SocketTestT6() { }
00024
00025     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode);
00026     virtual internalStatus  TestB(internalStatus instatus, INT &ErrorCode);
00027     virtual internalStatus  TestC(internalStatus instatus, INT &ErrorCode);
00028     virtual internalStatus  TestD(internalStatus instatus, INT &ErrorCode);
00029     virtual void FinishGroup();
00030 };
00031
00032 #endif // ApoxiApp_SocketTestT6_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT7.cpp File Reference

Applications/SocketTest/SocketTestT7.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT7.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for SocketTestT7.cpp:

Generated on Wed Jan 25 00:39:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT7.hpp File Reference

Applications/SocketTest/SocketTestT7.hpp File Reference

#include <SocketTest/SocketTestT3.hpp>

Include dependency graph for SocketTestT7.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestT7

Defines

#define | ApoxiApp_SocketTestT7_hpp

Define Documentation

#define ApoxiApp_SocketTestT7_hpp

Generated on Wed Jan 25 00:39:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT7.hpp Source File

Applications/SocketTest/SocketTestT7.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT7_hpp)
00011 #define ApoxiApp_SocketTestT7_hpp
00012
00013 #include <SocketTest/SocketTestT3.hpp>
00014
00018 class SocketTestT7 : public SocketTestT3
00019 {
00020 public:
00021     SocketTestT7() { }
00022
00023     virtual ~SocketTestT7() { }
00024
00025     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode);
00026     virtual internalStatus  TestB(internalStatus instatus, INT &ErrorCode);
00027     virtual internalStatus  TestC(internalStatus instatus, INT &ErrorCode);
00028     virtual internalStatus  TestD(internalStatus instatus, INT &ErrorCode);
00029     virtual void FinishGroup();
00030 };
00031
00032 #endif // ApoxiApp_SocketTestT7_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT8.cpp File Reference

Applications/SocketTest/SocketTestT8.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestT8.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for SocketTestT8.cpp:

Generated on Wed Jan 25 00:39:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT8.hpp File Reference

Applications/SocketTest/SocketTestT8.hpp File Reference

#include <SocketTest/SocketTestT4.hpp>

Include dependency graph for SocketTestT8.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestT8

Defines

#define | ApoxiApp_SocketTestT8_hpp

Define Documentation

#define ApoxiApp_SocketTestT8_hpp

Generated on Wed Jan 25 00:39:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestT8.hpp Source File

Applications/SocketTest/SocketTestT8.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestT8_hpp)
00011 #define ApoxiApp_SocketTestT8_hpp
00012
00013 #include <SocketTest/SocketTestT4.hpp>
00014
00018 class SocketTestT8 : public SocketTestT4
00019 {
00020 public:
00021     SocketTestT8() { }
00022
00023     virtual ~SocketTestT8() { }
00024
00025     virtual internalStatus  TestA(internalStatus instatus, INT &ErrorCode);
00026     virtual internalStatus  TestB(internalStatus instatus, INT &ErrorCode);
00027     virtual internalStatus  TestC(internalStatus instatus, INT &ErrorCode);
00028     virtual internalStatus  TestD(internalStatus instatus, INT &ErrorCode);
00029     virtual void FinishGroup();
00030 };
00031
00032 #endif // ApoxiApp_SocketTestT8_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestTests.cpp File Reference

Applications/SocketTest/SocketTestTests.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestTests.hpp"
#include "SocketTestDefines.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for SocketTestTests.cpp:

Generated on Wed Jan 25 00:39:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestTests.hpp File Reference

Applications/SocketTest/SocketTestTests.hpp File Reference

#include <SocketTest/SocketTestT1.hpp>
#include <SocketTest/SocketTestT2.hpp>
#include <SocketTest/SocketTestT5.hpp>
#include <SocketTest/SocketTestT6.hpp>
#include <SocketTest/SocketTestT7.hpp>
#include <SocketTest/SocketTestT8.hpp>

Include dependency graph for SocketTestTests.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | SocketTestTests::TestGroupInfo

Defines

#define | ApoxiApp_SocketTestTests_hpp

Define Documentation

#define ApoxiApp_SocketTestTests_hpp

Generated on Wed Jan 25 00:39:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestTests.hpp Source File

Applications/SocketTest/SocketTestTests.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestTests_hpp)
00011 #define ApoxiApp_SocketTestTests_hpp
00012
00013 #include <SocketTest/SocketTestT1.hpp>
00014 #include <SocketTest/SocketTestT2.hpp>
00015 #include <SocketTest/SocketTestT5.hpp>
00016 #include <SocketTest/SocketTestT6.hpp>
00017 #include <SocketTest/SocketTestT7.hpp>
00018 #include <SocketTest/SocketTestT8.hpp>
00019
00020 class SocketTestTests
00021 {
00022 public:
00023     enum defs {
00024         m_nNrOfTestGroups = 8,
00025         m_nMaxNrOfTestsInGroup = 10
00026     };
00027
00031     struct TestGroupInfo {
00032         WCHAR m_wsName[16];
00033         BOOLEAN m_bTestEnabled;
00034         UINT m_nNrOfSubtests;
00035         UINT32 m_nIterationsTotal[m_nMaxNrOfTestsInGroup];
00036         UINT32 m_nIterationsDone[m_nMaxNrOfTestsInGroup];
00037         UINT32 m_nIterationsSuccessfull[m_nMaxNrOfTestsInGroup];
00038         SocketTestT::Status m_nStatus[m_nMaxNrOfTestsInGroup];
00039         SocketTestT::internalStatus m_nInternalStatus[m_nMaxNrOfTestsInGroup];
00040         INT m_nErrorCode[m_nMaxNrOfTestsInGroup];
00041         BOOLEAN m_bReportSent[m_nMaxNrOfTestsInGroup];
00042     };
00043
00044 public:
00045     BOOLEAN ExecuteTest(INT group, INT test, BOOLEAN finish = FALSE);
00046     void FinishGroup(INT group);
00047
00048     SocketTestTests();
00049     virtual ~SocketTestTests();
00050
00051     TestGroupInfo m_sTests[m_nNrOfTestGroups];
00052
00053     UINT    GetTotalNumberOfTests() { return m_nTotalTests; }
00054     UINT    GetNumberOfEnabledTests() { return m_nEnabledTests; }
00055     void    CalculateNumberOfEnabledTests();
00056     UINT    GetNumberOfFinishedTests() { return m_nFinishedTests; }
00057     UINT    GetNumberOfPassedTests() { return m_nPassedTests; }
00058
00059     void    SetDefaultTests();
00060     void    DisableAllTests();
00061
00062     void    StartTest();
00063
00064     BOOLEAN GetTestInProgress(INT &group, INT &test);
00065
00066     SocketTestT3& GetSocketTestT3() { return m_testT3;}
00067     SocketTestT5& GetSocketTestT5() { return m_testT5;}
00068     static const DownloadSettings* GetDownloadDefaultValues() { return &DownloadDefaultValues;}
00069
00070 private:
00071     UINT    m_nTotalTests;
00072     UINT    m_nEnabledTests;
00073     UINT    m_nFinishedTests;
00074     UINT    m_nPassedTests;
00075
00076     INT m_nCurrentGroup;
00077     INT m_nCurrentTest;
00078
00079     SocketTestT1    m_testT1;
00080     SocketTestT2    m_testT2;
00081     SocketTestT3    m_testT3;
00082     SocketTestT4    m_testT4;
00083     SocketTestT5    m_testT5;
00084     SocketTestT6    m_testT6;
00085     SocketTestT7    m_testT7;
00086     SocketTestT8    m_testT8;
00087
00088     static const struct TestGroupInfo DefaultTestValues[m_nNrOfTestGroups];
00089     static const DownloadSettings DownloadDefaultValues;
00090 };
00091
00092 #endif // ApoxiApp_SocketTestTests_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestVersion.cpp File Reference

Applications/SocketTest/SocketTestVersion.cpp File Reference

#include "PreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <SocketTestVersion.hpp>

Include dependency graph for SocketTestVersion.cpp:

Functions

ApoxiDefVersionInfo (Mmi, SOCKETVERSION, VersionInfo::c_flag_add_to_trace_info)
unsigned char | get_sw_version ()
UINT8 | get_sw_version_text (char *ver_text, UINT8 max_len)
void | MmiSendGddViewfinderEnabled ()

Function Documentation

ApoxiDefVersionInfo | ( | Mmi | ,
 |  | SOCKETVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

unsigned char get_sw_version ( )

UINT8 get_sw_version_text | ( | char * | ver_text,
 |  | UINT8 | max_len
 | ) |

void MmiSendGddViewfinderEnabled ( )

Generated on Wed Jan 25 00:40:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestVersion.hpp File Reference

Applications/SocketTest/SocketTestVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | SocketTestVersion_hpp
#define | SOCKETVERSION "2.10.0_TIV_04"

Functions

unsigned char | get_sw_version ()
UINT8 | get_sw_version_text (char *ver_text, UINT8 max_len)

Define Documentation

#define SocketTestVersion_hpp

#define SOCKETVERSION "2.10.0_TIV_04"

Function Documentation

unsigned char get_sw_version ( )

UINT8 get_sw_version_text | ( | char * | ver_text,
 |  | UINT8 | max_len
 | ) |

Generated on Wed Jan 25 00:40:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestVersion.hpp Source File

Applications/SocketTest/SocketTestVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(SocketTestVersion_hpp)
00010 #define SocketTestVersion_hpp
00011
00012
00013 /*
00014 SocketTestVersion.hpp contains the official Uib Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define SOCKETVERSION "2.10.0_TIV_04"
00019
00020 // Add for Version
00021 extern "C" unsigned char get_sw_version();
00022 // Add for AT Command Version
00023 extern "C" UINT8 get_sw_version_text(char *ver_text, UINT8 max_len);
00024
00025 #endif  // SocketTestVersion_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestWin.cpp File Reference

Applications/SocketTest/SocketTestWin.cpp File Reference

#include "PreComp.hpp"
#include "SocketTestWin.hpp"
#include "SocketTestApp.hpp"
#include <Common/MmiServices.hpp>

Include dependency graph for SocketTestWin.cpp:

Generated on Wed Jan 25 00:40:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestWin.hpp File Reference

Applications/SocketTest/SocketTestWin.hpp File Reference

#include <GuiExtensions/MmiMenuWindow.hpp>
#include <SocketTest/SocketTestProgressWin.hpp>
#include <SocketTest/SocketTestSettingsWin.hpp>
#include <SocketTest/FfsMenu.hpp>
#include <SocketTest/SocketTestResultsWin.hpp>

Include dependency graph for SocketTestWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SocketTestWin

Defines

#define | ApoxiApp_SocketTestWin_hpp

Define Documentation

#define ApoxiApp_SocketTestWin_hpp

Generated on Wed Jan 25 00:40:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/SocketTestWin.hpp Source File

Applications/SocketTest/SocketTestWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_SocketTestWin_hpp)
00011 #define ApoxiApp_SocketTestWin_hpp
00012
00013 #include <GuiExtensions/MmiMenuWindow.hpp>
00014 #include <SocketTest/SocketTestProgressWin.hpp>
00015 #include <SocketTest/SocketTestSettingsWin.hpp>
00016 #include <SocketTest/FfsMenu.hpp>
00017 #include <SocketTest/SocketTestResultsWin.hpp>
00018
00022 class SocketTestWin : public MmiWindow
00023 {
00024     typedef MmiWindow Base;
00025
00026     public:
00027         SocketTestWin();
00028         virtual ~SocketTestWin();
00029
00030         void Init();
00031
00032     protected:
00033         virtual void OnOpen();
00034         virtual void OnPaint(const Rect& repaint_rect);
00035         virtual void OnActionExecuted(Action* action);
00036
00037     private:
00038         SocketTestResultsWin m_results_win;
00039         SocketTestProgressWin m_progress_win;
00040         SocketTestSettingsWin m_settings_win;
00041
00042         MmiMenuWindow           m_ffs_win;
00043         FfsMenu                 m_ffs_menu;
00044
00045         OpenContextMenuAction m_menu_action;
00046
00047         Action m_start_action;
00048         OpenWindowAction m_results_action;
00049         OpenWindowAction m_ffs_test_action;
00050         OpenWindowAction m_settings_action;
00051         CloseWindowAction m_close_action;
00052
00053         void RefreshScreen();
00054 };
00055
00056 #endif  // ApoxiApp_SocketTestWin_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/TcpServerTestSocket.cpp File Reference

Applications/SocketTest/TcpServerTestSocket.cpp File Reference

#include "PreComp.hpp"
#include "TcpServerTestSocket.hpp"
#include "SocketTestMsgTypes.hpp"
#include "SocketTestApp.hpp"

Include dependency graph for TcpServerTestSocket.cpp:

Variables

UINT s_continue_msgs_sent

Variable Documentation

UINT s_continue_msgs_sent

Generated on Wed Jan 25 00:40:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/TcpServerTestSocket.hpp File Reference

Applications/SocketTest/TcpServerTestSocket.hpp File Reference

#include <Socket/TcpServerSocket.hpp>

Include dependency graph for TcpServerTestSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TcpServerTestSocket

Defines

#define | ApoxiApp_TcpServerTestSocket_hpp

Define Documentation

#define ApoxiApp_TcpServerTestSocket_hpp

Generated on Wed Jan 25 00:40:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/TcpServerTestSocket.hpp Source File

Applications/SocketTest/TcpServerTestSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_TcpServerTestSocket_hpp)
00011 #define ApoxiApp_TcpServerTestSocket_hpp
00012
00013 #include <Socket/TcpServerSocket.hpp>
00014
00015 class TcpServerTestSocket : public TcpServerSocket
00016 {
00017 public:
00018     TcpServerTestSocket();
00019     virtual ~TcpServerTestSocket();
00020
00021 protected:
00022         virtual void OnAsyncEvent(Event event);
00023 };
00024
00025 #endif // ApoxiApp_TcpServerTestSocket_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/TcpTestSocket.cpp File Reference

Applications/SocketTest/TcpTestSocket.cpp File Reference

#include "PreComp.hpp"
#include "TcpTestSocket.hpp"
#include "SocketTestMsgTypes.hpp"
#include "SocketTestApp.hpp"
#include "SocketTestDefines.hpp"
#include <stdio.h>

Include dependency graph for TcpTestSocket.cpp:

Variables

UINT s_continue_msgs_sent

Variable Documentation

UINT s_continue_msgs_sent

Generated on Wed Jan 25 00:41:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/TcpTestSocket.hpp File Reference

Applications/SocketTest/TcpTestSocket.hpp File Reference

#include <Socket/TcpSocket.hpp>

Include dependency graph for TcpTestSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | TcpTestSocket

Defines

#define | ApoxiApp_TcpTestSocket_hpp

Define Documentation

#define ApoxiApp_TcpTestSocket_hpp

Generated on Wed Jan 25 00:41:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/TcpTestSocket.hpp Source File

Applications/SocketTest/TcpTestSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_TcpTestSocket_hpp)
00011 #define ApoxiApp_TcpTestSocket_hpp
00012
00013 #include <Socket/TcpSocket.hpp>
00014
00018 class TcpTestSocket : public TcpSocket
00019 {
00020 public:
00021     TcpTestSocket(BOOLEAN send_continue_msg = TRUE);
00022     virtual ~TcpTestSocket();
00023
00024     void CollectPackets(INT testid, INT nr_of_packets, INT messageSize);
00025     UINT32 GetReceivedPackets() { return m_nPacketsReceived; }
00026
00027     enum _constants { m_nHeaderSize = 32 };
00028
00029 protected:
00030     virtual void OnAsyncEvent(Event event);
00031
00032     UINT32 m_nWaitingForPackets;
00033     BOOLEAN *m_nPacketsCollected;
00034     UINT32 m_nPacketsReceived;
00035
00036     const BOOLEAN m_send_continue_msg;
00037     INT m_nTestID;
00038     INT m_nMessageSize;
00039     CHAR* m_nMessageBody; // Temporary buffer for current message.
00040     INT m_nMessagePos;    // Temporary input counter.
00041 };
00042
00043 #endif // ApoxiApp_TcpTestSocket_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/UdpTestSocket.cpp File Reference

Applications/SocketTest/UdpTestSocket.cpp File Reference

#include "PreComp.hpp"
#include "UdpTestSocket.hpp"
#include "SocketTestMsgTypes.hpp"
#include "SocketTestApp.hpp"
#include "SocketTestDefines.hpp"
#include <stdio.h>

Include dependency graph for UdpTestSocket.cpp:

Variables

UINT s_continue_msgs_sent

Variable Documentation

UINT s_continue_msgs_sent

Generated on Wed Jan 25 00:41:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/UdpTestSocket.hpp File Reference

Applications/SocketTest/UdpTestSocket.hpp File Reference

#include <Socket/UdpSocket.hpp>
#include <Socket/InetSocketAddr.hpp>

Include dependency graph for UdpTestSocket.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UdpTestSocket

Defines

#define | ApoxiApp_UdpTestSocket_hpp

Define Documentation

#define ApoxiApp_UdpTestSocket_hpp

Generated on Wed Jan 25 00:41:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SocketTest/UdpTestSocket.hpp Source File

Applications/SocketTest/UdpTestSocket.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(ApoxiApp_UdpTestSocket_hpp)
00011 #define ApoxiApp_UdpTestSocket_hpp
00012
00013 #include <Socket/UdpSocket.hpp>
00014 #include <Socket/InetSocketAddr.hpp>
00015
00019 class UdpTestSocket : public UdpSocket
00020 {
00021 public:
00022     UdpTestSocket(BOOLEAN send_continue_msg = TRUE);
00023     virtual ~UdpTestSocket();
00024
00025     void CollectPackets(int testid, int nr_of_packets);
00026     UINT32 GetReceivedPackets() { return m_nPacketsReceived; }
00027
00028     enum _constants { m_nHeaderSize = 32 };
00029
00030 protected:
00031     virtual void OnAsyncEvent(Event event);
00032
00033     UINT32 m_nWaitingForPackets;
00034     BOOLEAN *m_nPacketsCollected;
00035     UINT32 m_nPacketsReceived;
00036
00037     const BOOLEAN m_send_continue_msg;
00038     INT m_nTestID;
00039     INT m_nMessageSize;
00040
00041     Ticks m_ticks;
00042
00043     InetSocketAddr m_addressOut;
00044 };
00045
00046 #endif // ApoxiApp_UdpTestSocket_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/AmrSound.cpp File Reference

Applications/SoundBrowser/AmrSound.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include "AmrSound.hpp"

Include dependency graph for AmrSound.cpp:

Generated on Wed Jan 25 00:41:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/AmrSound.hpp File Reference

Applications/SoundBrowser/AmrSound.hpp File Reference

#include <Auxiliary/BinData.hpp>
#include <AddOns/MultiMedia/Melody.hpp>

Include dependency graph for AmrSound.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | AmrSound
Class to handle and decode MIDI sounds. More...

Defines

#define | MultiMedia_AmrSound_hpp

Define Documentation

#define MultiMedia_AmrSound_hpp

Generated on Wed Jan 25 00:41:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/AmrSound.hpp Source File

Applications/SoundBrowser/AmrSound.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(MultiMedia_AmrSound_hpp)
00011 #define MultiMedia_AmrSound_hpp
00015
00016 #include <Auxiliary/BinData.hpp>
00017 #include <AddOns/MultiMedia/Melody.hpp>
00018
00020 class AmrSound : public Melody {
00021     typedef Melody Base;
00022
00023     public:
00024         enum {
00025             ID = 4
00026         };
00027
00030         AmrSound();
00031
00038         explicit AmrSound(BinData* bin_data);
00039
00041         virtual ~AmrSound();
00042
00049         void Init(BinData* bin_data);
00050
00052         virtual INT GetId() const;
00053
00055         virtual const BinData* GetBinData() const;
00056
00057     private:
00058         BinData* m_bin_data;
00059 };
00060
00062 #endif // MultiMedia_AmrSound_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SampleIMelodies.cpp File Reference

Applications/SoundBrowser/SampleIMelodies.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include "SampleIMelodies.hpp"

Include dependency graph for SampleIMelodies.cpp:

Variables

UINT8 | knockyourhead [knockyourhead_size]
UINT8 | mambo [mambo_size]
UINT8 | withoutme [withoutme_size]
Generated on Wed Jan 25 00:41:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SampleIMelodies.hpp File Reference

Applications/SoundBrowser/SampleIMelodies.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | Apoxi_SampleIMelodies_hpp

Variables

UINT8 | knockyourhead [knockyourhead_size]
const UINT | knockyourhead_size = 353
UINT8 | mambo [mambo_size]
const UINT | mambo_size = 128
UINT8 | withoutme [withoutme_size]
const UINT | withoutme_size = 296

Define Documentation

#define Apoxi_SampleIMelodies_hpp

Generated on Wed Jan 25 00:41:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SampleIMelodies.hpp Source File

Applications/SoundBrowser/SampleIMelodies.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SampleIMelodies_hpp)
00011 #define Apoxi_SampleIMelodies_hpp
00014
00015 const UINT mambo_size = 128;
00016 const UINT withoutme_size = 296;
00017 const UINT knockyourhead_size = 353;
00018
00019 extern UINT8 mambo[mambo_size];
00020 extern UINT8 withoutme[withoutme_size];
00021 extern UINT8 knockyourhead[knockyourhead_size];
00022
00024 #endif  // Apoxi_SampleIMelodies_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserApp.cpp File Reference

Applications/SoundBrowser/SoundBrowserApp.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include <Auxiliary/BufferedData.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/MultiMedia/AudioItem.hpp>
#include <Kernel/VersionInfo.hpp>
#include <Devices/Messages/AudioErrorMsg.hpp>
#include <Devices/Messages/AudioStoppedMsg.hpp>
#include <Common/MediaBrowserUtils.hpp>
#include "SoundBrowserApp.hpp"
#include "SoundRefContainer.hpp"
#include "SoundRef.hpp"
#include "SoundBrowserMsgTypes.hpp"
#include <Audio/CustomRingerAudioReference.hpp>
#include <Audio/StreamAudioReference.hpp>
#include <Audio/AudioActiveReference.hpp>
#include <Audio/AudioDeviceManager.hpp>

Include dependency graph for SoundBrowserApp.cpp:

Functions

ApoxiUseVersionInfo (SoundBrowser)

Function Documentation

ApoxiUseVersionInfo ( SoundBrowser )

Generated on Wed Jan 25 00:41:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserApp.hpp File Reference

Applications/SoundBrowser/SoundBrowserApp.hpp File Reference

#include <Common/MmiServices.hpp>
#include <Common/MmiApplication.hpp>
#include <ImageBrowser/Common/RenameFileDialog.hpp>
#include <ImageBrowser/Common/MediaRefContainer.hpp>
#include <ImageBrowser/Common/BrowserSaveWin.hpp>
#include <ImageBrowser/Common/MediaFilter.hpp>
#include <Atl/Gui/MmiItemListWindow.hpp>

Include dependency graph for SoundBrowserApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoundBrowserApp

Defines

#define | Apoxi_SoundBrowserApp_hpp

Define Documentation

#define Apoxi_SoundBrowserApp_hpp

Generated on Wed Jan 25 00:41:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserApp.hpp Source File

Applications/SoundBrowser/SoundBrowserApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SoundBrowserApp_hpp)
00011 #define Apoxi_SoundBrowserApp_hpp
00014
00015 #include <Common/MmiServices.hpp>
00016 #include <Common/MmiApplication.hpp>
00017 #include <ImageBrowser/Common/RenameFileDialog.hpp>
00018 #include <ImageBrowser/Common/MediaRefContainer.hpp>
00019 #include <ImageBrowser/Common/BrowserSaveWin.hpp>
00020 #include <ImageBrowser/Common/MediaFilter.hpp>
00021 #include <Atl/Gui/MmiItemListWindow.hpp>
00022
00023 class SoundRef;
00024 class SoundRefContainer;
00025
00027 class SoundBrowserApp : public MmiApplication, public SoundManagementService
00028 {
00029     typedef MmiApplication Base;
00030
00031     public:
00032
00034         virtual ~SoundBrowserApp();
00035
00037         static SoundBrowserApp* GetInstance() { return &m_app; }
00038
00045         ServiceResult SelectSound(MediaRefPtr &media_ref_ptr,
00046             const SoundFilter &snd_filter = SoundFilter());
00047
00058         ServiceResult SaveSound(const BinData *raw_data, const Path &path, DrmMimeType drm_mime_type, MimeType mime_type);
00059
00067         ServiceResult GetResourceNames(Vector<Path>& paths, const SoundFilter& sound_filter = SoundFilter());
00068
00069
00070         //
00071         virtual BOOLEAN UpdateItem(Item* item);
00072
00073
00074     protected:
00075
00077         BOOLEAN OnFeatureTriggered(const FeatureID& feature_id);
00079         virtual DataItem GetContextDataItem(ContextFeature *feature);
00080
00082         void OnStartup();
00083
00085         void OnOpen();
00086
00088         void OnClose();
00090         BOOLEAN OnMessage(const Message &msg);
00091
00093     private:
00094
00096         SoundBrowserApp();
00097
00099         void OpenBrowser();
00100
00102         void PlaySelectedSound();
00103
00105         void StopSound();
00106
00108         void Delete();
00109
00111         void Rename();
00112
00114         void DisplayInfo(BOOLEAN is_media_info = TRUE) const;
00115
00116         // Updates the item container
00117         void UpdateItemContainer(INT idx = -1, BOOLEAN delete_elem = FALSE);
00118         //
00119         void SendAsMms();
00120
00121         //
00122         void Select();
00123
00124         // Updates the Image List
00125         void UpdateSoundList(BOOLEAN filter = FALSE);
00126
00128         void OnErrorNotification(const SharedPtr<AudioReference>& audio_reference,
00129                                 AudioError::ErrorType err_no);
00130
00132         void OnStopNotification(const SharedPtr<AudioActiveReference>& active_reference, BOOLEAN auto_stop);
00133         //
00134         void HandleSelectSound();
00135         //
00136         void HandleSaveSound();
00137
00139     private:
00140
00142         enum OpenMode {
00143             NotOpen,
00144             OpenSelectionService,
00145             OpenSaveService,
00146             OpenApplication
00147
00148         };
00149
00151         enum FeatureItemIds {
00152             SbSoundBrowser,
00153             SbSelect,
00154             SbPlay,
00155             SbStop,
00156             SbRename,
00157             SbDelete,
00158             SbSendAsMms,
00159             SbInfo,
00160 #if defined(APOXI_INCLUDE_DRM)
00161             SbDrmInfo,
00162 #endif
00163             SbKeyUpDown,
00164             SbClose,
00165             SbFeatureCnt
00166         };
00167
00168         enum SndServiceState {
00169             NoSndService,
00170             SelectSndService,
00171             SaveSndService
00172         };
00174         Feature m_items[SbFeatureCnt];
00175
00177         static SoundBrowserApp m_app;
00178
00180         BrowserSaveWin m_browser_save_win;
00181
00183         static BooleanCondition m_condition_sav;
00184
00186         SoundRefContainer *m_snd_refs;
00187
00189         OpenMode m_mode;
00190
00192         ItemContainer* m_item_cont;
00193
00195         MmiItemListWindow m_media_list_win;
00196
00198         RenameFileDialog m_rename_file_dialog;
00199
00201         SharedPtr<AudioActiveReference> m_active_file_ref;
00202
00204         UINT8 HUGE* m_current_sound_buffer;
00205
00206
00207         static BooleanCondition s_condition_sel;
00208
00209
00211         BOOLEAN m_success;
00212
00214         SoundRef* m_current_sound_ref;
00215
00216         BOOLEAN m_sndsrv_success;
00217         SndServiceState m_snd_state;
00218
00219         const BinData   *m_snd_bin_data;
00220         DrmMimeType     m_snd_drm_mime_type;
00221         Path            m_snd_path;
00222         SoundFilter     *p_sound_filter;
00223
00224 }; // SoundBrowserApp
00225
00227 #endif  // Apoxi_SoundBrowserApp_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserMsgTypes.cpp File Reference

Applications/SoundBrowser/SoundBrowserMsgTypes.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include "SoundBrowserMsgTypes.hpp"

Include dependency graph for SoundBrowserMsgTypes.cpp:

Generated on Wed Jan 25 00:41:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserMsgTypes.hpp File Reference

Applications/SoundBrowser/SoundBrowserMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Afs/Rfs/Path.hpp>
#include <SoundBrowser/Common/MediaFilter.hpp>
#include <SoundBrowser/SoundRef.hpp>

Include dependency graph for SoundBrowserMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoundBrowserServiceMsg

Defines

#define | Common_SoundBrowserMsgTypes_hpp

Define Documentation

#define Common_SoundBrowserMsgTypes_hpp

Generated on Wed Jan 25 00:41:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserMsgTypes.hpp Source File

Applications/SoundBrowser/SoundBrowserMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "views\nageshra_win_2.5\lnz_apps_int\Applications\SoundBrowser\SoundBrowserMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013 #if !defined(Common_SoundBrowserMsgTypes_hpp)
00014 #define Common_SoundBrowserMsgTypes_hpp
00015 #include <Kernel/Message.hpp>
00016 #include <Afs/Rfs/Path.hpp>
00017 #include <SoundBrowser/Common/MediaFilter.hpp>
00018 #include <SoundBrowser/SoundRef.hpp>
00019 /* ----------------------------------------------------------------------
00020     Classes
00021     ---------------------------------------------------------------------- */
00022 /*  ======================================================================
00023     Class SoundBrowserServiceMsg
00024     ====================================================================== */
00026 class SoundBrowserServiceMsg : public ContextMsg {
00027     public:
00028         SoundBrowserServiceMsg(ExecutionContext* context);
00029         virtual ~SoundBrowserServiceMsg();
00030
00031         virtual const MsgMetaData& GetMetaData() const;
00032         virtual Message* Clone() const;
00033
00034         enum  {
00035             ID = 21355
00036             };
00037
00038     private:
00039         static const MsgMetaData m_meta_data;
00040
00041     };
00042 #endif // Common_SoundBrowserMsgTypes_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserPreComp.cpp File Reference

Applications/SoundBrowser/SoundBrowserPreComp.cpp File Reference

#include "SoundBrowserPreComp.hpp"

Include dependency graph for SoundBrowserPreComp.cpp:

Generated on Wed Jan 25 00:41:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserPreComp.hpp File Reference

Applications/SoundBrowser/SoundBrowserPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for SoundBrowserPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:42:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserPreComp.hpp Source File

Applications/SoundBrowser/SoundBrowserPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Kernel/Lib.hpp>
00011 #include <Gui/Lib.hpp>
00012 #include <Afs/Ffs/FfsHandler.hpp>
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserTestWin.cpp File Reference

Applications/SoundBrowser/SoundBrowserTestWin.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include "SoundBrowserTestWin.hpp"
#include <Common/MmiServices.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/MultiMedia/WbmpImage.hpp>
#include <AddOns/MultiMedia/IMelody.hpp>
#include <SoundBrowser/SampleIMelodies.hpp>
#include <SoundBrowser/SoundRef.hpp>
#include <SoundBrowser/Common/MediaFilter.hpp>

Include dependency graph for SoundBrowserTestWin.cpp:

Generated on Wed Jan 25 00:42:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserTestWin.hpp File Reference

Applications/SoundBrowser/SoundBrowserTestWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for SoundBrowserTestWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoundBrowserTestWin

Defines

#define | Apoxi_SoundBrowserTestWin_hpp

Define Documentation

#define Apoxi_SoundBrowserTestWin_hpp

Generated on Wed Jan 25 00:42:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserTestWin.hpp Source File

Applications/SoundBrowser/SoundBrowserTestWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SoundBrowserTestWin_hpp)
00011 #define Apoxi_SoundBrowserTestWin_hpp
00014
00015 #include <GuiExtensions/MmiWindow.hpp>
00016 #include <GuiExtensions/ActionAccessor.hpp>
00017
00018 class IMelody;
00019
00020 class SoundBrowserTestWin : public MmiWindow
00021 {
00022     typedef MmiWindow Base;
00023
00024     public:
00025         SoundBrowserTestWin();
00026         virtual ~SoundBrowserTestWin();
00027
00028         void Init();
00029
00030     protected:
00031         virtual BOOLEAN OnCancel();
00032         virtual void OnLayoutClient();
00033         virtual void OnActionExecuted(Action *action);
00034
00035     private:
00036         ImageBox m_image_box;
00037         TextBox m_text_box;
00038
00039         ActionAccessor m_accessor;
00040
00041         Action m_select_action;
00042         Action m_save_action;
00043
00044         CancelAction m_cancel_action;
00045
00046         INT m_current_sound;
00047         IMelody *m_sounds[3];
00048 };
00049
00051 #endif  // Apoxi_SoundBrowserTestWin_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserVersion.cpp File Reference

Applications/SoundBrowser/SoundBrowserVersion.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include "SoundBrowserVersion.hpp"

Include dependency graph for SoundBrowserVersion.cpp:

Functions

ApoxiDefVersionInfo (SoundBrowser, SNDBRVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | SoundBrowser | ,
 |  | SNDBRVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:42:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserVersion.hpp File Reference

Applications/SoundBrowser/SoundBrowserVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | SNDBRVERSION "2.10.0_TIV_04"
#define | SoundBrowserVersion_hpp

Define Documentation

#define SNDBRVERSION "2.10.0_TIV_04"

#define SoundBrowserVersion_hpp

Generated on Wed Jan 25 00:42:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserVersion.hpp Source File

Applications/SoundBrowser/SoundBrowserVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(SoundBrowserVersion_hpp)
00010 #define SoundBrowserVersion_hpp
00011
00012
00013 /*
00014 SoundBrowserVersion.hpp contains the official Uib Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define SNDBRVERSION "2.10.0_TIV_04"
00019
00020 #endif  // SoundBrowserVersion_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserWin.cpp File Reference

Applications/SoundBrowser/SoundBrowserWin.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include "GuiExtensions/MmiInfoBox.hpp"
#include "GuiExtensions/MmiAlert.hpp"
#include <Auxiliary/DrmAsset.hpp>
#include <Devices/AudioDeviceManager.hpp>
#include <Devices/StreamAudioReference.hpp>
#include "SoundBrowserWin.hpp"
#include "SoundBrowserApp.hpp"
#include "SoundRefContainer.hpp"
#include "SoundRef.hpp"
#include "SoundMetaData.hpp"
#include "SoundBrowserMsgTypes.hpp"

Include dependency graph for SoundBrowserWin.cpp:

Generated on Wed Jan 25 00:42:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserWin.hpp File Reference

Applications/SoundBrowser/SoundBrowserWin.hpp File Reference

#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <Common/MmiWaitingBox.hpp>
#include <Devices/AudioActiveReference.hpp>
#include <SoundBrowser/Common/BrowserViewContainer.hpp>
#include <SoundBrowser/Common/RenameFileDialog.hpp>
#include <SoundBrowser/Common/FileNameView.hpp>
#include <ImageBrowser/Common/InfoDialog.hpp>
#include <SoundBrowser/SoundRef.hpp>

Include dependency graph for SoundBrowserWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoundBrowserWin

Defines

#define | Apoxi_SoundBrowserWin_hpp

Define Documentation

#define Apoxi_SoundBrowserWin_hpp

Generated on Wed Jan 25 00:42:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundBrowserWin.hpp Source File

Applications/SoundBrowser/SoundBrowserWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SoundBrowserWin_hpp)
00011 #define Apoxi_SoundBrowserWin_hpp
00014
00015 #include <GuiExtensions/MmiWindow.hpp>
00016 #include <GuiExtensions/ActionAccessor.hpp>
00017 #include <Common/MmiWaitingBox.hpp>
00018 #include <Devices/AudioActiveReference.hpp>
00019 #include <SoundBrowser/Common/BrowserViewContainer.hpp>
00020 #include <SoundBrowser/Common/RenameFileDialog.hpp>
00021 #include <SoundBrowser/Common/FileNameView.hpp>
00022
00023 #include <ImageBrowser/Common/InfoDialog.hpp>
00024 #include <SoundBrowser/SoundRef.hpp>
00025
00026 class SoundRef;
00027 class SoundRefContainer;
00028 class SoundFilter;
00029
00033 class SoundBrowserWin : public MmiWindow
00034 {
00035     typedef MmiWindow Base;
00036
00037     public:
00038         SoundBrowserWin();
00039         virtual ~SoundBrowserWin();
00040
00043         void Init(BooleanCondition &condition, SoundRefContainer &snd_refs);
00044
00051         BOOLEAN SetSoundFilter(const SoundFilter &snd_filter, BOOLEAN show_select_button);
00052
00055         MediaRefPtr& GetSelectedSoundRef();
00056
00059         BOOLEAN GetSuccess() const;
00062         void OnErrorNotification(const SharedPtr<AudioReference>& audio_reference,
00063                                 AudioError::ErrorType err_no);
00064
00067         void OnStopNotification(const SharedPtr<AudioActiveReference>& active_reference, BOOLEAN auto_stop);
00068
00069     protected:
00070         virtual void OnLayoutClient();
00071         virtual BOOLEAN OnCancel();
00072         virtual BOOLEAN OnConfirm();
00073         void OnOpen();
00074         virtual void OnClose();
00075         virtual void OnActionExecuted(Action *action);
00076         virtual BOOLEAN OnMessage(const Message & msg);
00077
00078         virtual BOOLEAN OnKeyDown(KeyCode key_code);
00079
00080
00081         void PlaySelectedSound();
00082         void StopSound();
00083
00084     private:
00085         void DisplayAlert(const WCHAR *msg);
00086
00087         ConfirmAction m_confirm_action;
00088         CancelAction m_cancel_action;
00089         Action m_delete_action;
00090         Action m_rename_action;
00091         Action m_play_action;
00092         Action m_stop_action;
00093         ActionAccessor m_accessor;
00094         Action m_info_action;
00095         Action m_drm_info_action;
00096         MmiWaitingBox m_waiting_box;
00097
00098         BrowserViewContainer m_views;
00099         FileNameView m_fnv;
00100
00101         SoundRefContainer *m_snd_refs;
00102
00103         BooleanCondition *m_condition;
00104         BOOLEAN m_success;
00105
00106         SharedPtr<AudioActiveReference> m_active_file_ref;
00107
00108         UINT8 HUGE* m_current_sound_buffer;
00109         BOOLEAN m_is_sound_playing;
00110
00111         RenameFileDialog m_rename_file_dialog;
00112         SoundRef* m_current_sound_ref;
00113         InfoDialog m_info_dialog;
00114 };
00115
00117 #endif  // Apoxi_SoundBrowserWin_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundMetaData.cpp File Reference

Applications/SoundBrowser/SoundMetaData.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include "SoundMetaData.hpp"
#include "SoundRef.hpp"

Include dependency graph for SoundMetaData.cpp:

Generated on Wed Jan 25 00:42:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundMetaData.hpp File Reference

Applications/SoundBrowser/SoundMetaData.hpp File Reference

#include <SoundBrowser/Common/MetaData.hpp>

Include dependency graph for SoundMetaData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoundMetaData
struct | SoundMetaDataRecord

Defines

#define | Apoxi_SoundMetaData_hpp

Define Documentation

#define Apoxi_SoundMetaData_hpp

Generated on Wed Jan 25 00:42:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundMetaData.hpp Source File

Applications/SoundBrowser/SoundMetaData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SoundMetaData_hpp)
00011 #define Apoxi_SoundMetaData_hpp
00014
00015 #include <SoundBrowser/Common/MetaData.hpp>
00016
00017 struct SoundMetaDataRecord : public MetaDataRecord {
00018 };
00019
00022 class SoundMetaData : public MetaData
00023 {
00024     typedef MetaData Base;
00025
00026     public:
00027         SoundMetaData();
00028 #if defined(APOXI_INCLUDE_DRM)
00029         SoundMetaData(const Path &path, const DrmInfo &drm_info = DrmInfo(),
00030             UINT32 size = 0);
00031 #else
00032         SoundMetaData(const Path &path, UINT32 size = 0);
00033 #endif
00034         virtual ~SoundMetaData();
00035
00037         virtual MetaDataRecord& GetMetaDataRecord();
00038
00040         virtual const MetaDataRecord& GetMetaDataRecord() const;
00041
00042     private:
00043         SoundMetaDataRecord m_data;
00044 };
00045
00047 #endif  // Apoxi_SoundMetaData_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundRef.cpp File Reference

Applications/SoundBrowser/SoundRef.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include "SoundRef.hpp"
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Rfs/File.hpp>

Include dependency graph for SoundRef.cpp:

Generated on Wed Jan 25 00:42:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundRef.hpp File Reference

Applications/SoundBrowser/SoundRef.hpp File Reference

#include <Afs/Ffs/FfsTypes.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <SoundBrowser/Common/MediaRef.hpp>
#include <SoundBrowser/SoundMetaData.hpp>

Include dependency graph for SoundRef.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoundRef

Defines

#define | Apoxi_SoundRef_hpp

Define Documentation

#define Apoxi_SoundRef_hpp

Generated on Wed Jan 25 00:42:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundRef.hpp Source File

Applications/SoundBrowser/SoundRef.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SoundRef_hpp)
00011 #define Apoxi_SoundRef_hpp
00014
00015 #include <Afs/Ffs/FfsTypes.hpp>
00016 #include <Afs/Rfs/FileBinData.hpp>
00017 #include <SoundBrowser/Common/MediaRef.hpp>
00018 #include <SoundBrowser/SoundMetaData.hpp>
00019
00020 class Sound;
00021
00025 class SoundRef : public MediaRef
00026 {
00027     typedef MediaRef Base;
00028
00029     public:
00030         SoundRef();
00031         virtual ~SoundRef();
00032
00034         virtual MetaData& GetMetaData();
00036         virtual const MetaData& GetMetaData() const;
00037
00039         virtual void SetMetaData(const MetaData &meta_data);
00040
00041 #if defined(APOXI_INCLUDE_DRM)
00042         virtual WString GetAssetInfo();
00043 #endif
00044
00045         BinData* GetSoundBuffer(MimeType &mime_type);
00046
00051 #if defined(APOXI_COMPAT_1_11_0)
00052         Sound* GetSound(BOOLEAN buffer_to_ram = TRUE);
00053
00054
00056         void SetSound(Sound *sound){m_sound = sound;}
00057
00059         BOOLEAN IsSoundInitialized() const {return m_sound != 0; }
00060
00062         void ReleaseSound();
00063
00064         Sound* CreateSoundObject(BOOLEAN buffer_to_ram);
00065 #endif
00066
00067
00069 #if defined(APOXI_INCLUDE_DRM)
00070     #if defined(APOXI_COMPAT_1_11_0)
00071         Sound* CreateSoundObject(FfsDrmAttrib attrib);
00072     #endif
00073 #endif
00074
00075     private:
00076         SoundMetaData m_meta_data;
00077         FileBinData *m_fbd;
00078
00079 #if defined(APOXI_COMPAT_1_11_0)
00080
00081         Sound *m_sound;
00082         Sound * ConstructSoundObject(const MimeType& mType, BinData* bin_data);
00083 #endif
00084
00086
00088         BufferedData* GetFileData();
00089 };
00090
00092 #endif  // Apoxi_SoundRef_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundRefContainer.cpp File Reference

Applications/SoundBrowser/SoundRefContainer.cpp File Reference

#include "SoundBrowserPreComp.hpp"
#include "SoundRefContainer.hpp"
#include "SoundRef.hpp"
#include <Afs/Rfs/FileFilter.hpp>

Include dependency graph for SoundRefContainer.cpp:

Generated on Wed Jan 25 00:42:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundRefContainer.hpp File Reference

Applications/SoundBrowser/SoundRefContainer.hpp File Reference

#include <SoundBrowser/Common/MediaRefContainer.hpp>

Include dependency graph for SoundRefContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | SoundRefContainer

Defines

#define | Apoxi_SoundRefContainer_hpp

Define Documentation

#define Apoxi_SoundRefContainer_hpp

Generated on Wed Jan 25 00:42:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/SoundRefContainer.hpp Source File

Applications/SoundBrowser/SoundRefContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_SoundRefContainer_hpp)
00011 #define Apoxi_SoundRefContainer_hpp
00014
00015 #include <SoundBrowser/Common/MediaRefContainer.hpp>
00016
00019 class SoundRefContainer : public MediaRefContainer
00020 {
00021     typedef MediaRefContainer Base;
00022
00023     public:
00024         SoundRefContainer();
00025         SoundRefContainer(const Path &database_path);
00026         virtual ~SoundRefContainer();
00027
00030         virtual BOOLEAN Add(MediaRefPtr &media_ref);
00031
00032     protected:
00033         // @see MediaRefContainer::CreateMediaRef()
00034         virtual MediaRefPtr CreateMediaRef() const;
00035
00036         // @see MediaRefContainer::GetSizeOfRecord()
00037         virtual UINT32 GetSizeOfRecord() const;
00038
00040         virtual FileFilterPtr GetMediaFileFilter() const;
00041
00043         virtual BOOLEAN SetupMediaObject(MetaData &metadata);
00045         virtual BOOLEAN SetupMediaObject(MediaRefPtr &media_ref);
00046
00047 };
00048
00050 #endif  // Apoxi_SoundRefContainer_hpp
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserSaveWin.cpp File Reference

Applications/SoundBrowser/Common/BrowserSaveWin.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "BrowserSaveWin.hpp"
#include "MediaRefContainer.hpp"
#include "RenameFileDialog.hpp"
#include <Afs/Rfs/Path.hpp>
#include <ImageBrowser/Common/MediaBrowserUtils.hpp>

Include dependency graph for BrowserSaveWin.cpp:

Generated on Wed Jan 25 00:12:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserSaveWin.hpp File Reference

Applications/SoundBrowser/Common/BrowserSaveWin.hpp File Reference

#include <GuiExtensions/MmiDialog.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>

Include dependency graph for BrowserSaveWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BrowserSaveWin

Defines

#define | Apoxi_ImgBrowserSaveWin_hpp

Define Documentation

#define Apoxi_ImgBrowserSaveWin_hpp

Generated on Wed Jan 25 00:12:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserSaveWin.hpp Source File

Applications/SoundBrowser/Common/BrowserSaveWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_ImgBrowserSaveWin_hpp)
00011 #define Apoxi_ImgBrowserSaveWin_hpp
00014
00015 #include <GuiExtensions/MmiDialog.hpp>
00016 #include <Afs/Rfs/RootFileSystem.hpp>
00017
00018 class MediaRefContainer;
00019
00020 class BrowserSaveWin : public MmiDialog
00021 {
00022     typedef MmiDialog Base;
00023
00024     public:
00025         BrowserSaveWin();
00026         virtual ~BrowserSaveWin();
00027
00031         void Init(BooleanCondition &condition,
00032             const MediaRefContainer &media_refs);
00033
00035         Path GetNewPath() const;
00036
00038         void SetTargetPath(const Path &path);
00039
00041         BOOLEAN GetSuccess() const {
00042             return m_success;
00043         }
00044
00045     protected:
00047         virtual void OnOpen();
00048
00050         virtual void OnLayoutClient();
00051
00053         virtual BOOLEAN OnConfirm();
00054
00056         virtual BOOLEAN OnCancel();
00057
00058
00059     private:
00060         BOOLEAN m_success;
00061
00062         // TO DO enhance dialog for also asking for the storage device Id.
00063         static const WCHAR *m_deviceId;
00064         LineEditor m_file_name;
00065         TextBox m_name;
00066         TextBox m_error_tb;
00067
00068         BooleanCondition *m_condition;
00069         const MediaRefContainer *m_media_refs;
00070         MimeType m_mime_type;
00071 };
00072
00074 #endif  // Apoxi_ImgBrowserSaveWin_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserView.cpp File Reference

Applications/SoundBrowser/Common/BrowserView.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "BrowserView.hpp"
#include "MediaRefContainer.hpp"
#include <Afs/Rfs/File.hpp>

Include dependency graph for BrowserView.cpp:

Generated on Wed Jan 25 00:13:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserView.hpp File Reference

Applications/SoundBrowser/Common/BrowserView.hpp File Reference

#include <GuiExtensions/DrawableObjectListBox.hpp>
#include "MediaRefContainer.hpp"

Include dependency graph for BrowserView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BrowserView

Defines

#define | Apoxi_BrowserView_hpp

Define Documentation

#define Apoxi_BrowserView_hpp

Generated on Wed Jan 25 00:13:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserView.hpp Source File

Applications/SoundBrowser/Common/BrowserView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BrowserView_hpp)
00011 #define Apoxi_BrowserView_hpp
00014
00015 #include <GuiExtensions/DrawableObjectListBox.hpp>
00016 #include "MediaRefContainer.hpp"
00017
00018 //struct MediaRefPtr;
00019 class MediaRefContainer;
00020
00023 class BrowserView : public DrawableObjectListBox
00024 {
00025     typedef DrawableObjectListBox Base;
00026
00027     public:
00028         BrowserView();
00029         virtual ~BrowserView();
00030
00036         void Init(Control *parent, MediaRefContainer &media_refs,
00037             DrawableObjectListBoxModel *model);
00038
00041         virtual void NotifyDelete();
00042
00044         MediaRefPtr& GetSelectedMediaRef();
00045
00047         const MediaRefPtr& GetSelectedMediaRef() const;
00048
00049     private:
00050         MediaRefContainer *m_media_refs;
00051 };
00052
00054 #endif  // Apoxi_BrowserView_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserViewContainer.cpp File Reference

Applications/SoundBrowser/Common/BrowserViewContainer.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "BrowserViewContainer.hpp"
#include <Afs/Rfs/File.hpp>

Include dependency graph for BrowserViewContainer.cpp:

Generated on Wed Jan 25 00:13:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserViewContainer.hpp File Reference

Applications/SoundBrowser/Common/BrowserViewContainer.hpp File Reference

#include "BrowserView.hpp"

Include dependency graph for BrowserViewContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | BrowserViewContainer

Defines

#define | Apoxi_BrowserViewContainer_hpp

Define Documentation

#define Apoxi_BrowserViewContainer_hpp

Generated on Wed Jan 25 00:13:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/BrowserViewContainer.hpp Source File

Applications/SoundBrowser/Common/BrowserViewContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_BrowserViewContainer_hpp)
00011 #define Apoxi_BrowserViewContainer_hpp
00014
00015 #include "BrowserView.hpp"
00016
00020 class BrowserViewContainer : public DrawableObject
00021 {
00022     typedef DrawableObject Base;
00023
00024     public:
00025         BrowserViewContainer();
00026         BrowserViewContainer(Control *parent, BrowserView &browser_view);
00027         virtual ~BrowserViewContainer();
00028
00033         void Init(Control *parent, BrowserView &browser_view);
00034
00037         virtual void AddView(BrowserView &browser_view);
00038
00041         virtual BOOLEAN RemoveView(BrowserView &browser_view);
00042
00045         virtual void SetActiveView(INT index);
00046
00049         virtual void ToggleView();
00050
00052         virtual INT GetViewCount();
00053
00055         virtual BrowserView *GetActiveView() const;
00056
00059         virtual void Update(INT item_count);
00060
00062         virtual void NotifyDelete();
00063
00064     private:
00065         BrowserView *m_views[5];
00066         INT m_view_cnt;
00067         INT m_active_view;
00068 };
00069
00071 #endif  // Apoxi_BrowserViewContainer_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/FileNameListBoxModel.cpp File Reference

Applications/SoundBrowser/Common/FileNameListBoxModel.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "FileNameListBoxModel.hpp"
#include "MediaRefContainer.hpp"
#include "MetaData.hpp"

Include dependency graph for FileNameListBoxModel.cpp:

Generated on Wed Jan 25 00:13:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/FileNameListBoxModel.hpp File Reference

Applications/SoundBrowser/Common/FileNameListBoxModel.hpp File Reference

#include <GuiExtensions/LabelListBoxModel.hpp>

Include dependency graph for FileNameListBoxModel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileNameListBoxModel
Model for showing filenames stored in a MediaRefContainer. More...

Defines

#define | Apoxi_FileNameListBoxModel_hpp

Define Documentation

#define Apoxi_FileNameListBoxModel_hpp

Generated on Wed Jan 25 00:13:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/FileNameListBoxModel.hpp Source File

Applications/SoundBrowser/Common/FileNameListBoxModel.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileNameListBoxModel_hpp)
00011 #define Apoxi_FileNameListBoxModel_hpp
00014
00015 #include <GuiExtensions/LabelListBoxModel.hpp>
00016
00017 class MediaRefContainer;
00018
00020 class FileNameListBoxModel : public LabelListBoxModel
00021 {
00022     typedef LabelListBoxModel Base;
00023
00024     public:
00025         FileNameListBoxModel();
00026         FileNameListBoxModel(DrawableObjectListBox *control,
00027             const MediaRefContainer &media_refs);
00028         virtual ~FileNameListBoxModel();
00029
00030         void Init(DrawableObjectListBox *control,
00031             const MediaRefContainer &media_refs);
00032
00037         virtual const WCHAR* GetCellText(INT index, BOOLEAN highlighted);
00038
00039     private:
00040         const MediaRefContainer *m_media_refs;
00041 };
00042
00044 #endif  // Apoxi_FileNameListBoxModel_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/FileNameView.cpp File Reference

Applications/SoundBrowser/Common/FileNameView.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "FileNameView.hpp"
#include "MediaRefContainer.hpp"

Include dependency graph for FileNameView.cpp:

Generated on Wed Jan 25 00:13:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/FileNameView.hpp File Reference

Applications/SoundBrowser/Common/FileNameView.hpp File Reference

#include "BrowserView.hpp"
#include "FileNameListBoxModel.hpp"

Include dependency graph for FileNameView.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | FileNameView
View for showing filenames by the use of a FileNameListBoxModel. More...

Defines

#define | Apoxi_FileNameView_hpp

Define Documentation

#define Apoxi_FileNameView_hpp

Generated on Wed Jan 25 00:13:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/FileNameView.hpp Source File

Applications/SoundBrowser/Common/FileNameView.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_FileNameView_hpp)
00011 #define Apoxi_FileNameView_hpp
00014
00015 #include "BrowserView.hpp"
00016 #include "FileNameListBoxModel.hpp"
00017
00019 class FileNameView : public BrowserView
00020 {
00021     typedef BrowserView Base;
00022
00023     public:
00024         FileNameView();
00025         virtual ~FileNameView();
00026
00031         void Init(Control *parent, MediaRefContainer &media_refs);
00032
00033     protected:
00034         virtual BOOLEAN OnMessage(const Message &msg);
00035         virtual void OnGetFocus();
00036
00037     private:
00038         FileNameListBoxModel m_list_model;
00039 };
00040
00042 #endif  // Apoxi_FileNameView_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/InfoDialog.cpp File Reference

Applications/SoundBrowser/Common/InfoDialog.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "InfoDialog.hpp"

Include dependency graph for InfoDialog.cpp:

Generated on Wed Jan 25 00:13:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/InfoDialog.hpp File Reference

Applications/SoundBrowser/Common/InfoDialog.hpp File Reference

#include <GuiExtensions/MmiDialog.hpp>
#include <Gui/TextBox.hpp>

Include dependency graph for InfoDialog.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | InfoDialog
Dialog showing some information only. More...

Defines

#define | Apoxi_InfoDialog_hpp

Define Documentation

#define Apoxi_InfoDialog_hpp

Generated on Wed Jan 25 00:13:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/InfoDialog.hpp Source File

Applications/SoundBrowser/Common/InfoDialog.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_InfoDialog_hpp)
00011 #define Apoxi_InfoDialog_hpp
00014
00015 #include <GuiExtensions/MmiDialog.hpp>
00016 #include <Gui/TextBox.hpp>
00017
00019 class InfoDialog : public MmiDialog
00020 {
00021     typedef MmiDialog Base;
00022
00023     public:
00024         InfoDialog();
00025         virtual ~InfoDialog();
00026
00027         void Init();
00028
00030         void SetText(const WString &text);
00031
00032     protected:
00034         virtual BOOLEAN OnConfirm();
00035
00037         virtual void OnLayoutClient();
00038
00039     private:
00040         TextList m_text_box;
00041         WString m_text;
00042 };
00043
00045 #endif  // Apoxi_InfoDialog_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaBrowserPreComp.cpp File Reference

Applications/SoundBrowser/Common/MediaBrowserPreComp.cpp File Reference

#include "MediaBrowserPreComp.hpp"

Include dependency graph for MediaBrowserPreComp.cpp:

Generated on Wed Jan 25 00:13:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaBrowserPreComp.hpp File Reference

Applications/SoundBrowser/Common/MediaBrowserPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for MediaBrowserPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:14:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaBrowserPreComp.hpp Source File

Applications/SoundBrowser/Common/MediaBrowserPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #include <Kernel/Lib.hpp>
00011 #include <Gui/Lib.hpp>
00012 #include <Afs/Ffs/FfsHandler.hpp>
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaBrowserUtils.cpp File Reference

Applications/SoundBrowser/Common/MediaBrowserUtils.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "MediaBrowserUtils.hpp"

Include dependency graph for MediaBrowserUtils.cpp:

Generated on Wed Jan 25 00:14:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaBrowserUtils.hpp File Reference

Applications/SoundBrowser/Common/MediaBrowserUtils.hpp File Reference

#include <GuiExtensions/MmiInfoBox.hpp>

Include dependency graph for MediaBrowserUtils.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaBrowserUtils
Utility class for SB and IB. More...

Defines

#define | Apoxi_MediaBrowserUtils_hpp

Define Documentation

#define Apoxi_MediaBrowserUtils_hpp

Generated on Wed Jan 25 00:14:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaBrowserUtils.hpp Source File

Applications/SoundBrowser/Common/MediaBrowserUtils.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaBrowserUtils_hpp)
00011 #define Apoxi_MediaBrowserUtils_hpp
00014
00015 #include <GuiExtensions/MmiInfoBox.hpp>
00016
00018 class MediaBrowserUtils
00019 {
00020     public:
00021
00023         ~MediaBrowserUtils();
00024
00026         static MediaBrowserUtils* GetInstance();
00027
00028 #if defined(APOXI_INCLUDE_DRM)
00029
00030         WString GetDrmErrorString(INT error_code) const;
00031 #endif
00032
00034         MmiDialog::ReturnId DisplayDlg(const WString& msg,
00035                                         MmiInfoBox::MmiInfoBoxType type = MmiInfoBox::Error) const;
00036
00038         BOOLEAN ValidateFileName(const WString& name);
00039
00040
00042     private:
00043
00045         MediaBrowserUtils();
00046
00048     private:
00049
00051         static MediaBrowserUtils* m_app;
00052
00053 }; // MediaBrowserUtils
00054
00056 #endif // Apoxi_MediaBrowserUtils_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaFilter.cpp File Reference

Applications/SoundBrowser/Common/MediaFilter.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "MediaFilter.hpp"
#include "MediaRef.hpp"
#include "MetaData.hpp"

Include dependency graph for MediaFilter.cpp:

Generated on Wed Jan 25 00:14:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaFilter.hpp File Reference

Applications/SoundBrowser/Common/MediaFilter.hpp File Reference

#include <Auxiliary/MimeTypeTable.hpp>

Include dependency graph for MediaFilter.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ImageFilter
Base class for filters concerning image references. More...
class | MediaFilter
Base class for filter that can be used by the image or sound browser. More...
class | MimeTypeFilter
class | SoundFilter
Base class for filters concerning sound references. More...

Defines

#define | Apoxi_MediaFilter_hpp

Define Documentation

#define Apoxi_MediaFilter_hpp

Generated on Wed Jan 25 00:14:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaFilter.hpp Source File

Applications/SoundBrowser/Common/MediaFilter.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaFilter_hpp)
00011 #define Apoxi_MediaFilter_hpp
00014
00015 #include <Auxiliary/MimeTypeTable.hpp>
00016
00017 class MediaRef;
00018
00020 class MediaFilter
00021 {
00022     public:
00023         MediaFilter();
00024         virtual ~MediaFilter();
00025
00027         virtual BOOLEAN IsAllowed(const MediaRef &media_ref) const;
00028 };
00029
00031 class ImageFilter : public MediaFilter
00032 {
00033     public:
00034         ImageFilter();
00035         virtual ~ImageFilter();
00036
00038         virtual BOOLEAN IsAllowed(const MediaRef &media_ref) const;
00039 };
00040
00042 class SoundFilter : public MediaFilter
00043 {
00044     public:
00045         SoundFilter();
00046         virtual ~SoundFilter();
00047
00049         virtual BOOLEAN IsAllowed(const MediaRef &snd_ref) const;
00050 };
00051
00054 class MimeTypeFilter : public MediaFilter
00055 {
00056     typedef MediaFilter Base;
00057
00058     public:
00059         MimeTypeFilter(MimeType mime_type);
00060         virtual ~MimeTypeFilter();
00061
00063         virtual BOOLEAN IsAllowed(const MediaRef &media_ref) const;
00064
00066         virtual void SetMimeType(MimeType mime_type);
00067
00068     private:
00069         MimeType m_mime_type;
00070 };
00071
00073 #endif  // Apoxi_MediaFilter_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaRef.cpp File Reference

Applications/SoundBrowser/Common/MediaRef.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Rfs/FileBinData.hpp>
#include <Auxiliary/RamData.hpp>
#include <Auxiliary/Date.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/Services/Service.hpp>
#include <AddOns/Drm/DrmMessage.hpp>
#include <AddOns/MultiMedia/MultiMediaEditorDocument.hpp>
#include <Gui/EditorDocument.hpp>
#include <Common/MmiServices.hpp>
#include <Common/MmiInfoBox.hpp>
#include "MediaRef.hpp"
#include "MetaData.hpp"

Include dependency graph for MediaRef.cpp:

Generated on Wed Jan 25 00:14:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaRef.hpp File Reference

Applications/SoundBrowser/Common/MediaRef.hpp File Reference

#include <Afs/Ffs/FfsTypes.hpp>
#include <Afs/Rfs/Path.hpp>
#include <Auxiliary/BufferedData.hpp>

Include dependency graph for MediaRef.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaRef

Defines

#define | Apoxi_MediaRef_hpp

Define Documentation

#define Apoxi_MediaRef_hpp

Generated on Wed Jan 25 00:14:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaRef.hpp Source File

Applications/SoundBrowser/Common/MediaRef.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaRef_hpp)
00011 #define Apoxi_MediaRef_hpp
00014 #include <Afs/Ffs/FfsTypes.hpp>
00015 #include <Afs/Rfs/Path.hpp>
00016 #if defined(APOXI_INCLUDE_DRM)
00017     #include <Auxiliary/DrmAsset.hpp>
00018 #endif
00019 #include <Auxiliary/BufferedData.hpp>
00020
00021 class MetaData;
00022
00026 class MediaRef
00027 {
00028     protected:
00029         MediaRef();
00030
00031     public:
00032         virtual ~MediaRef();
00033
00035         virtual MetaData& GetMetaData() = 0;
00037         virtual const MetaData& GetMetaData() const = 0;
00038
00040         virtual void SetMetaData(const MetaData &meta_data) = 0;
00041
00042 #if defined(APOXI_INCLUDE_DRM)
00043         virtual WString GetAssetInfo() = 0;
00044 #endif
00045
00047         BOOLEAN operator==(const MediaRef &media_ref) const;
00048
00050         BOOLEAN IsDrmMedia( FfsDrmAttrib &attrib);
00051
00053         BOOLEAN IsDrmMedia();
00054
00055 #if defined(APOXI_INCLUDE_DRM)
00056
00057         INT GetLastDrmError() { return m_last_drm_error; }
00058
00060         void SetLastDrmError(INT drm_error);
00061
00063         DrmAsset* GetDrmAsset();
00064
00067         void OpenRightsIssuerUrl();
00068
00069
00070
00071
00073         const BinData * GetDcf();
00074 #endif
00075
00078         BOOLEAN SendAsMms(const AtomItem* item);
00079
00080
00081
00082     private:
00083 #if defined(APOXI_INCLUDE_DRM)
00084         INT m_last_drm_error;
00085         DrmAsset m_drm_asset;
00086 #endif
00087         AtomItem    *m_ptr_item;
00088
00089 };
00090
00092 #endif  // Apoxi_MediaRef_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaRefContainer.cpp File Reference

Applications/SoundBrowser/Common/MediaRefContainer.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "MediaRefContainer.hpp"
#include "MediaFilter.hpp"
#include "MetaData.hpp"
#include <Afs/Rfs/RootFileSystem.hpp>
#include <Afs/Rfs/File.hpp>
#include <Afs/Rfs/DirectoryIterator.hpp>
#include <Afs/Rfs/FileFilter.hpp>
#include <Afs/Ffs/FfsHandler.hpp>

Include dependency graph for MediaRefContainer.cpp:

Generated on Wed Jan 25 00:14:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaRefContainer.hpp File Reference

Applications/SoundBrowser/Common/MediaRefContainer.hpp File Reference

#include <Auxiliary/ElementList.hpp>
#include <Auxiliary/NiSharedPtr.hpp>
#include <Afs/Rfs/Path.hpp>
#include "MediaRef.hpp"
#include "MediaVisitor.hpp"

Include dependency graph for MediaRefContainer.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaRefContainer
struct | MediaRefLinkable
The Linkable wrapping a MediaRef smart pointer. More...

Defines

#define | Apoxi_MediaRefContainer_hpp

Typedefs

typedef NiSharedPtr< File > | FilePtr
typedef NiSharedPtr< MediaRef > | MediaRefPtr

Define Documentation

#define Apoxi_MediaRefContainer_hpp

Generated on Wed Jan 25 00:14:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaRefContainer.hpp Source File

Applications/SoundBrowser/Common/MediaRefContainer.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaRefContainer_hpp)
00011 #define Apoxi_MediaRefContainer_hpp
00014
00015 #include <Auxiliary/ElementList.hpp>
00016 #include <Auxiliary/NiSharedPtr.hpp>
00017 #include <Afs/Rfs/Path.hpp>
00018 #include "MediaRef.hpp"
00019 #include "MediaVisitor.hpp"
00020
00021
00022 class File;
00023 class MediaFilter;
00024 class ImageBrowserApp;
00025 class SoundBrowserApp;
00026
00027
00028 typedef NiSharedPtr<File> FilePtr;
00029 typedef NiSharedPtr<MediaRef> MediaRefPtr;
00030
00032 struct MediaRefLinkable : public Linkable<MediaRefLinkable>
00033 {
00034     MediaRefPtr m_elem;
00035
00036     explicit MediaRefLinkable(MediaRefPtr &elem) :
00037         m_elem(elem) {}
00038
00039     const MediaRefPtr& operator*() const { return m_elem; }
00040     MediaRefPtr& operator*() { return m_elem; }
00041
00042     BOOLEAN operator==(const MediaRefLinkable &rhs) const {
00043         return m_elem.Get() == rhs.m_elem.Get();
00044     }
00045
00046 };
00047
00048
00058 class MediaRefContainer
00059 {
00060     protected:
00061         MediaRefContainer();
00062         MediaRefContainer(const Path &path);
00063
00064     public:
00066         virtual ~MediaRefContainer();
00067
00071         void Init(const Path &database_path);
00072
00077         virtual BOOLEAN Add(MediaRefPtr &media_ref);
00078
00086         virtual BOOLEAN Delete(MediaRefPtr &media_ref,
00087             BOOLEAN delete_file = FALSE);
00088
00095         BOOLEAN DeleteAt(INT index, BOOLEAN delete_file = FALSE);
00096
00101         virtual BOOLEAN Rename(MediaRefPtr &media_ref, const WString &new_name);
00102
00104         void Clear();
00105
00108         MediaRefPtr& GetElementAt(INT index);
00109
00112         const MediaRefPtr& GetElementAt(INT index) const;
00113
00115         INT GetSize() const { return m_elems.GetSize(); }
00116
00119         INT GetIndex(const MediaRefPtr &media_ref) const;
00120
00124         BOOLEAN MediaRefExists(const Path &path) const;
00125
00130         BOOLEAN ApplyFilter(const MediaFilter &media_filter);
00131
00136         void ApplyVisitorFilter(MediaVisitor* media_visitor, const MediaFilter &media_filter);
00137
00139         void Refresh(MediaFilter *filter = 0);
00140
00146         static BOOLEAN SaveMedia(MediaRefPtr &media_ref, const UINT8 HUGE *content, UINT32 length);
00147
00151         virtual UINT32 GetSizeOfRecord() const = 0;
00152
00157         void SearchForFiles(MediaFilter *app_filter = 0, const WString& storage_device_Id = L"ffs");
00161         void SetDbPath(const Path &path){m_path = path;}
00162
00163     protected:
00164
00165
00166         // Returns a new media reference object of the derived class.
00167         virtual MediaRefPtr CreateMediaRef() const = 0;
00168
00170         virtual FileFilterPtr GetMediaFileFilter() const = 0;
00171
00174         virtual BOOLEAN SetupMediaObject(MediaRefPtr &media_ref) = 0;
00175
00177         virtual BOOLEAN IsInDatabase(const Path& path) const;
00178
00180         Path m_path;
00181
00182     private:
00183
00184         friend class ImageBrowserApp;
00185         friend class SoundBrowserApp;
00186
00188         BOOLEAN Read(MediaFilter *filter  = 0 );
00189
00193         MediaRefPtr ReadMediaRef(INT index, const FilePtr &file) const;
00194
00196         BOOLEAN Write() const;
00197
00203         BOOLEAN WriteMediaRef(INT index, const FilePtr &file) const;
00204
00205         ElementList<MediaRefLinkable> m_elems;
00206         INT32 m_index_counter;
00207 };
00208
00210 #endif  // Apoxi_MediaRefContainer_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaVisitor.cpp File Reference

Applications/SoundBrowser/Common/MediaVisitor.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "MediaVisitor.hpp"
#include "MetaData.hpp"

Include dependency graph for MediaVisitor.cpp:

Generated on Wed Jan 25 00:14:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaVisitor.hpp File Reference

Applications/SoundBrowser/Common/MediaVisitor.hpp File Reference

#include "MediaRef.hpp"
#include "Afs/Rfs/Path.hpp"
#include "Auxiliary/Vector.hpp"

Include dependency graph for MediaVisitor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MediaPathnameVisitor
class | MediaVisitor

Defines

#define | Apoxi_MediaVisitor_hpp

Define Documentation

#define Apoxi_MediaVisitor_hpp

Generated on Wed Jan 25 00:14:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MediaVisitor.hpp Source File

Applications/SoundBrowser/Common/MediaVisitor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MediaVisitor_hpp)
00011 #define Apoxi_MediaVisitor_hpp
00014
00015 #include "MediaRef.hpp"
00016 #include "Afs/Rfs/Path.hpp"
00017 #include "Auxiliary/Vector.hpp"
00018
00022 class MediaVisitor
00023 {
00024
00025 protected:
00026     MediaVisitor();
00027
00028 public:
00029     virtual ~MediaVisitor();
00030
00031     // visit a media ref object
00032     virtual void Visit(const MediaRef& media_ref) = 0;
00033 };
00034
00035
00036
00037
00038
00039 class MediaPathnameVisitor : public MediaVisitor
00040 {
00041 public:
00042     MediaPathnameVisitor();
00043
00044     virtual ~MediaPathnameVisitor();
00045
00046     // visit a media ref object
00047     void Visit(const MediaRef& media_ref);
00048
00049     // returns a path array of the visited paths
00050     void GetPaths(Vector<Path> &paths);
00051
00052 private:
00053     Vector<Path> m_paths;
00054 };
00055
00056
00058 #endif  // Apoxi_MediaVisitor_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MetaData.cpp File Reference

Applications/SoundBrowser/Common/MetaData.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include <Afs/Rfs/File.hpp>
#include "MetaData.hpp"

Include dependency graph for MetaData.cpp:

Generated on Wed Jan 25 00:15:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MetaData.hpp File Reference

Applications/SoundBrowser/Common/MetaData.hpp File Reference

#include <Afs/Rfs/PathProfile.hpp>

Include dependency graph for MetaData.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | MetaData
struct | MetaDataRecord

Defines

#define | Apoxi_MetaData_hpp

Define Documentation

#define Apoxi_MetaData_hpp

Generated on Wed Jan 25 00:15:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/MetaData.hpp Source File

Applications/SoundBrowser/Common/MetaData.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_MetaData_hpp)
00011 #define Apoxi_MetaData_hpp
00014
00015 #if defined(APOXI_INCLUDE_DRM)
00016     #include <Auxiliary/DrmInfo.hpp>
00017 #endif
00018 #include <Afs/Rfs/PathProfile.hpp>
00019
00024 struct MetaDataRecord {
00025     UINT8 m_mark_delete;
00026     INT32 m_index;
00027     PathProfile m_resource_path_profile;
00028 #if defined(APOXI_INCLUDE_DRM)
00029     DrmInfoPersistStructure m_drm_info;
00030 #endif
00031     UINT32 m_size;
00032
00033     MetaDataRecord();
00034     virtual ~MetaDataRecord();
00035 };
00036
00041 class MetaData
00042 {
00043     public:
00044         MetaData();
00045
00046         virtual ~MetaData();
00047
00048 #if defined(APOXI_INCLUDE_DRM)
00049         void Init(const Path &path, const DrmInfo &drm_info = DrmInfo(),
00050             UINT32 size = 0);
00051 #else
00052         void Init(const Path &path, UINT32 size = 0);
00053 #endif
00054
00055         virtual MetaDataRecord& GetMetaDataRecord() = 0;
00056
00058         virtual const MetaDataRecord& GetMetaDataRecord() const = 0;
00059
00061         Path GetPath() const { return GetMetaDataRecord().m_resource_path_profile; }
00062
00064         void SetPath(const Path &path) { path.WriteTo(GetMetaDataRecord().m_resource_path_profile); }
00065
00066 #if defined(APOXI_INCLUDE_DRM)
00067
00068         void GetDrmInfo(DrmInfo &drm_info) const { drm_info.ReadFrom(GetMetaDataRecord().m_drm_info); }
00069
00071         void SetDrmInfo(const DrmInfo &drm_info) { drm_info.WriteTo(&GetMetaDataRecord().m_drm_info); }
00072 #endif
00073
00075         UINT32 GetSize() const { return GetMetaDataRecord().m_size; }
00076
00078         void SetSize(UINT32 size) { GetMetaDataRecord().m_size = size; }
00079
00081         MimeType GetMimeType() const { return GetPath().GetMimeType(); }
00082
00084         virtual WString GetInfoText() const;
00085
00087         void SetDisplayedName(const WString &displayed_name) {  m_displayed_name = displayed_name; }
00088
00090         const WString& GetDisplayedName() const { return m_displayed_name; }
00091
00092         void SetMarkDelete(BOOLEAN mark_delete);
00093
00094         BOOLEAN GetMarkDelete() const { return GetMetaDataRecord().m_mark_delete; }
00095
00096         void SetIndex(INT32 index) { GetMetaDataRecord().m_index= index; }
00097
00098         INT32 GetIndex() const { return GetMetaDataRecord().m_index; }
00099     private:
00100
00101         WString m_displayed_name;
00102 };
00103
00105 #endif  // Apoxi_MetaData_hpp
Generated on Tue Jan 24 14:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/RenameFileDialog.cpp File Reference

Applications/SoundBrowser/Common/RenameFileDialog.cpp File Reference

#include "MediaBrowserPreComp.hpp"
#include "RenameFileDialog.hpp"
#include <ImageBrowser/Common/MediaBrowserUtils.hpp>

Include dependency graph for RenameFileDialog.cpp:

Generated on Wed Jan 25 00:15:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/RenameFileDialog.hpp File Reference

Applications/SoundBrowser/Common/RenameFileDialog.hpp File Reference

#include <GuiExtensions/MmiDialog.hpp>
#include <Afs/Rfs/Path.hpp>

Include dependency graph for RenameFileDialog.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | RenameFileDialog
Dialog for renaming a file with the media browser. More...

Defines

#define | Apoxi_RenameDialog_hpp

Define Documentation

#define Apoxi_RenameDialog_hpp

Generated on Wed Jan 25 00:15:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/SoundBrowser/Common/RenameFileDialog.hpp Source File

Applications/SoundBrowser/Common/RenameFileDialog.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH & Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(Apoxi_RenameDialog_hpp)
00011 #define Apoxi_RenameDialog_hpp
00014
00015 #include <GuiExtensions/MmiDialog.hpp>
00016 #include <Afs/Rfs/Path.hpp>
00017
00019 class RenameFileDialog : public MmiDialog
00020 {
00021     typedef MmiDialog Base;
00022
00023     public:
00024         RenameFileDialog();
00025         virtual ~RenameFileDialog();
00026
00027         void Init();
00028         void Init(Control *control);
00029
00031         WString GetNewFilename() const;
00032
00036         void SetCurrentPath(const Path &current_path);
00037
00039         BOOLEAN GetSuccess() const;
00040
00041     protected:
00043         virtual void OnOpen();
00044
00046         virtual BOOLEAN OnConfirm();
00047
00049         virtual BOOLEAN OnCancel();
00050
00052         virtual void OnLayoutClient();
00053
00054     private:
00055         //TextBox m_current_name;
00056         //TextBox m_file_name;
00057         TextBox m_new_name;
00058         TextBox m_extension;
00059         TextBox m_error_tb;
00060         LineEditor m_new_file_name;
00061         TextBox m_new_extension;
00062
00063         WString m_str_full_file_name;
00064         WString m_str_file_name;
00065         WString m_str_file_extension;
00066
00067
00068         BOOLEAN m_success;
00069
00070 };
00071
00073 #endif  // Apoxi_RenameDialog_hpp
Generated on Tue Jan 24 14:52:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoApp.cpp File Reference

Applications/ToDo/ToDoApp.cpp File Reference

#include "ToDoPreComp.hpp"
#include "ToDoApp.hpp"
#include <Common/MmiAlert.hpp>
#include <Common/MainSettingsProvider.hpp>
#include <GuiInputExtensions/AbstractPredictiveInputBox.hpp>

Include dependency graph for ToDoApp.cpp:

Generated on Wed Jan 25 00:42:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoApp.hpp File Reference

Applications/ToDo/ToDoApp.hpp File Reference

#include <Common/MmiApplication.hpp>
#include "ToDoListWin.hpp"
#include "ToDoProvider.hpp"
#include "ToDoDialogWin.hpp"
#include "ToDoComposeWin.hpp"

Include dependency graph for ToDoApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ToDoApp

Defines

#define | ToDoApp_hpp

Define Documentation

#define ToDoApp_hpp

Generated on Wed Jan 25 00:42:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoApp.hpp Source File

Applications/ToDo/ToDoApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(ToDoApp_hpp)
00009 #define ToDoApp_hpp
00010
00011 #include <Common/MmiApplication.hpp>
00012 #include "ToDoListWin.hpp"
00013 #include "ToDoProvider.hpp"
00014 #include "ToDoDialogWin.hpp"
00015 #include "ToDoComposeWin.hpp"
00016
00017
00018 /*  ========================================================================
00019     App
00020     ======================================================================== */
00021 class ToDoApp : public MmiApplication
00022 {
00023     typedef MmiApplication Base;
00024
00025     public:
00027         virtual ~ToDoApp();
00028
00032         static ToDoApp* GetInstance();
00033
00034
00035     protected:
00037         virtual void OnStartup();
00038
00040         virtual void OnOpen();
00041
00043         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00044
00046         virtual BOOLEAN OnMessage(const Message &msg);
00047
00048     private:
00050         ToDoApp();
00051
00053         void InsertToDoItem();
00054
00056         void SetToDoOptionMenuFeature (BOOLEAN flag);
00057
00059         void OpenToDoMainWindow();
00060
00062         void SaveToDoItem();
00063
00065         void MarkUnmarkToDoItem();
00066
00068         void ViewToDoItem();
00069
00071         void EditToDoItem();
00072
00074         void OpenToDoInsertItemWins();
00075
00077         void SaveToDoItemPriority();
00078
00080         void DeleteToDoItem();
00081
00083         void DeleteAllToDoItems();
00084
00085
00086         enum FeatureItemIds {
00087             ToDo,
00088             ToDoView,
00089             ToDoNew,
00090             ToDoEdit,
00091             ToDoDelete,
00092             ToDoDeleteAll,
00093             ToDoMarkUnmark,
00094             ToDoPriority,
00095             ToDoStore,
00096             ToDoPredInput,
00097             ToDoT9Disabled,
00098             ToDoT9English,
00099             ToDoT9SimpChinese,
00100             ToDoT9TradChinese,
00101             ToDoT9Pinyin,
00102             ToDoT9BoPoMoFo,
00103             ToDoFeatureCnt
00104         };
00105
00106         Feature                     m_items[ToDoFeatureCnt];
00107         static ToDoApp              m_instance;
00108         ToDoListWin                 m_todo_list_window;
00109         ToDoProvider                m_todo_provider;
00110         ToDoRecord                  m_tmp_record;
00111         ToDoDateDialogWin           m_todo_date_dialog_win;
00112         ToDoPriorityDialogWin       m_todo_priority_dialog_win;
00113         ToDoComposeWin              m_editor_win;
00114         BOOLEAN                     m_is_a_new_todo_item;
00115         INT                         m_selected_idx;
00116 };
00117
00118 #endif  // ToDoPlugin_hpp
00119
00120
Generated on Tue Jan 24 14:52:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoComposeWin.cpp File Reference

Applications/ToDo/ToDoComposeWin.cpp File Reference

#include "ToDoPreComp.hpp"
#include "ToDoComposeWin.hpp"
#include <Config/FontConfig.hpp>
#include "ToDoApp.hpp"
#include <Gui/PredInputMapper.hpp>

Include dependency graph for ToDoComposeWin.cpp:

Generated on Wed Jan 25 00:43:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoComposeWin.hpp File Reference

Applications/ToDo/ToDoComposeWin.hpp File Reference

#include <Common/MmiWindow.hpp>
#include <Gui/MultiLineEditor.hpp>

Include dependency graph for ToDoComposeWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ToDoComposeWin

Defines

#define | ToDoComposeWin_hpp

Define Documentation

#define ToDoComposeWin_hpp

Generated on Wed Jan 25 00:43:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoComposeWin.hpp Source File

Applications/ToDo/ToDoComposeWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     -------------------------------------------------------- */
00008 #if !defined(ToDoComposeWin_hpp)
00009 #define ToDoComposeWin_hpp
00010
00011 #include <Common/MmiWindow.hpp>
00012 #include <Gui/MultiLineEditor.hpp>
00013 #ifdef APOXI_INCLUDE_T9
00014 #include <AddOns/T9/T9PredictiveInputBox.hpp>
00015 #endif
00016
00017 //#include "AbstractToDoComposeWin.hpp"
00018
00019 class ToDoApp;
00020 class AbstractPredictiveInputBox;
00021
00022 class ToDoComposeWin : public MmiWindow /*AbstractToDoComposeWin*/{
00023     //typedef AbstractToDoComposeWin Base;
00024     typedef MmiWindow Base;
00025
00026     public:
00028         ToDoComposeWin();
00029
00031         virtual ~ToDoComposeWin();
00032
00034         void Init(ToDoApp* todo_app);
00035
00037         virtual EditorDocumentObtainer GetDocumentObtainer() const;
00038
00040         virtual void SetDocumentObtainer(const EditorDocumentObtainer& obtainer);
00041
00043         //virtual void SetEnabled(BOOLEAN is_T9_enabled, BOOLEAN is_save_enabled);
00044
00046         ToDoApp* GetToDoApplication() const { return m_todo_app; };
00047
00049         void OnClose();
00050
00052         void Clean();
00053
00055         void SetProrityDisplay (INT priority);
00056
00058         void SetDateDisplay(Date date);
00059
00061         void SetReadOnlyMode (BOOLEAN read_only);
00062
00064         void SetNoteDisplay(WCHAR *note);
00065
00067         virtual AbstractPredictiveInputBox* GetPredInputBox();
00068
00070         virtual void OnInputModeChanged(PredInputMapper::PredMode mode);
00071
00072
00073     protected:
00074
00076         virtual void OnLayoutClient();
00077
00078     private:
00080         void OnOpen();
00081
00082         MultiLineEditor         m_editor;
00083 #ifdef APOXI_INCLUDE_T9
00084         T9PredictiveInputBox    m_input_box;
00085 #endif
00086         ToDoApp*                m_todo_app;
00087         Label                   m_priority_display;
00088         Label                   m_date_display;
00089         WString                 m_priority_text;
00090         WString                 m_date_text;
00091 };
00092 #endif
00093
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoDialogWin.cpp File Reference

Applications/ToDo/ToDoDialogWin.cpp File Reference

#include "ToDoPreComp.hpp"
#include "ToDoDialogWin.hpp"
#include <Common/MmiAlert.hpp>
#include <Common/ContextID.hpp>

Include dependency graph for ToDoDialogWin.cpp:

Generated on Wed Jan 25 00:43:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoDialogWin.hpp File Reference

Applications/ToDo/ToDoDialogWin.hpp File Reference

#include <Common/MmiDialog.hpp>
#include "ToDoRecord.hpp"

Include dependency graph for ToDoDialogWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ToDoDateDialogWin
class | ToDoPriorityDialogWin

Defines

#define | ToDoDialogWin_hpp

Define Documentation

#define ToDoDialogWin_hpp

Generated on Wed Jan 25 00:43:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoDialogWin.hpp Source File

Applications/ToDo/ToDoDialogWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     -------------------------------------------------------- */
00008 #if !defined(ToDoDialogWin_hpp)
00009 #define ToDoDialogWin_hpp
00010
00011
00012 #include <Common/MmiDialog.hpp>
00013 #include "ToDoRecord.hpp"
00014
00015
00016 class ToDoDateDialogWin: public MmiDialog {
00017     typedef MmiDialog   Base;
00018
00019     public:
00020
00022         ToDoDateDialogWin();
00023
00025         virtual ~ToDoDateDialogWin();
00026
00028         void Init();
00029
00031         void OnOpen();
00032
00034         BOOLEAN OnConfirm();
00035
00037         void OnLayoutClient();
00038
00040         DateEditor* GetDate();
00041
00043         virtual BOOLEAN OnCancel();
00044
00046         void Clean();
00047
00049         void SetDate (Date date);
00050
00051     private:
00052         DateEditor                  m_date_editor;
00053 };
00054
00055 class ToDoPriorityDialogWin: public MmiDialog {
00056     typedef MmiDialog   Base;
00057
00058     public:
00059         void Init();
00060         BOOLEAN OnConfirm();
00061         INT GetPriority() {return m_priority;};
00062         void SetPriority(ToDoRecord::ToDoRecProrityLevel priority);
00063         void OnOpen();
00064
00065     private:
00066         RadioButtonAction           m_low_action;
00067         RadioButtonAction           m_medium_action;
00068         RadioButtonAction           m_high_action;
00069         RadioButtonGroup            m_priority_group;
00070         ItemMenu                    m_item_menu;
00071         INT                         m_priority;
00072 };
00073
00074
00075 #endif
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoListWin.cpp File Reference

Applications/ToDo/ToDoListWin.cpp File Reference

#include "ToDoPreComp.hpp"
#include "ToDoListWin.hpp"
#include <Config/Config.hpp>
#include "ToDoProvider.hpp"

Include dependency graph for ToDoListWin.cpp:

Generated on Wed Jan 25 00:43:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoListWin.hpp File Reference

Applications/ToDo/ToDoListWin.hpp File Reference

#include <GuiExtensions/MmiItemListWindow.hpp>
#include <Common/Items/ProviderProxyContainer.hpp>

Include dependency graph for ToDoListWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ToDoListWin
This class declares a new kind of window derived from class MmiItemListWindow. More...

Defines

#define | Mmi_ToDoListWin_hpp

Define Documentation

#define Mmi_ToDoListWin_hpp

Generated on Wed Jan 25 00:43:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoListWin.hpp Source File

Applications/ToDo/ToDoListWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_ToDoListWin_hpp)
00010 #define Mmi_ToDoListWin_hpp
00013
00014 #include <GuiExtensions/MmiItemListWindow.hpp>
00015 #include <Common/Items/ProviderProxyContainer.hpp>
00016
00021 class ToDoListWin : public MmiItemListWindow {
00022
00023     typedef MmiItemListWindow Base;
00024
00025     public:
00026
00028         ToDoListWin();
00029
00031         virtual ~ToDoListWin();
00032
00037         void Init(Dispatcher* dispatcher, Provider* provider = 0);
00038
00040         void UpdateProvider();
00041
00043         INT GetSelectedIndex() {return m_selected_index;};
00044
00045
00046     protected:
00048         virtual void OnOpen();
00049
00051         virtual void OnClose();
00052
00054         virtual void OnGetFocus();
00055
00057         void OnSelectionChanged(INT selected_index);
00058
00060         BOOLEAN OnMessage(const Message& message);
00061
00062     private:
00063         ProviderProxyContainer      m_provider_cont;
00064         INT                         m_selected_index;
00065 };
00066
00068 #endif
00069
00070
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoPreComp.cpp File Reference

Applications/ToDo/ToDoPreComp.cpp File Reference

#include "ToDoPreComp.hpp"

Include dependency graph for ToDoPreComp.cpp:

Generated on Wed Jan 25 00:44:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoPreComp.hpp File Reference

Applications/ToDo/ToDoPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for ToDoPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:44:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoPreComp.hpp Source File

Applications/ToDo/ToDoPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Apc/Lib.hpp>
00013 #include <Adc/Lib.hpp>
00014 #include <Asc/Lib.hpp>
00015
00016 #include <Common/CommonMsgTypes.hpp>
00017
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoProvider.cpp File Reference

Applications/ToDo/ToDoProvider.cpp File Reference

#include "ToDoPreComp.hpp"
#include "ToDoProvider.hpp"
#include <Adc/RootFileSystem.hpp>
#include <Adc/FlashStorageDeviceImp.hpp>
#include <Adc/File.hpp>
#include <Config/Config.hpp>
#include <Atl/Gui/ImgObtObj.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Config/MmiGuiEngineConfig.hpp>

Include dependency graph for ToDoProvider.cpp:

Variables

const BitmapRes * c_mark_unmark_icon_table [2] = {MmiGuiEngineConfig::GetIcon("CheckBoxIconDisabled").GetBitmap(),MmiGuiEngineConfig::GetIcon("CheckBoxIconActive").GetBitmap()}

Variable Documentation

const BitmapRes* c_mark_unmark_icon_table[2] = {MmiGuiEngineConfig::GetIcon("CheckBoxIconDisabled").GetBitmap(),MmiGuiEngineConfig::GetIcon("CheckBoxIconActive").GetBitmap()}

Generated on Wed Jan 25 00:44:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoProvider.hpp File Reference

Applications/ToDo/ToDoProvider.hpp File Reference

#include "ToDoRecord.hpp"
#include <Config/Config.hpp>
#include <Mmi/Common/SettingsProvider.hpp>
#include <Auxiliary/Protector.hpp>
#include <Auxiliary/IndexTable.hpp>
#include <AddOns/AdcExtensions/RecordHandler.hpp>

Include dependency graph for ToDoProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ToDoProvider

Defines

#define | Mmi_ToDoProvider_hpp

Variables

const INT | c_max_char_visible_in_listbox_todolist = 30

Define Documentation

#define Mmi_ToDoProvider_hpp

Variable Documentation

const INT c_max_char_visible_in_listbox_todolist = 30

Generated on Wed Jan 25 00:44:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoProvider.hpp Source File

Applications/ToDo/ToDoProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_ToDoProvider_hpp)
00009 #define Mmi_ToDoProvider_hpp
00010
00011 #include "ToDoRecord.hpp"
00012 #include <Config/Config.hpp>
00013 #include <Mmi/Common/SettingsProvider.hpp>
00014 #include <Auxiliary/Protector.hpp>
00015 #include <Auxiliary/IndexTable.hpp>
00016 #include <AddOns/AdcExtensions/RecordHandler.hpp>
00017
00018 const INT c_max_char_visible_in_listbox_todolist = 30;
00019
00020 class ToDoProvider : public SettingsProvider {
00021     typedef SettingsProvider Base;
00022     public:
00024         ToDoProvider();
00025
00027         ~ToDoProvider();
00028
00030         void Init();
00031
00033         INT GetProviderId() const {return c_todo_provider_id;}
00034
00036         INT RowCount();
00037
00039         INT MaxRowCount() {return c_max_todo_records;};
00040
00042         BOOLEAN GetDataItem(INT column, INT row, DataItem &item);
00043
00045         BOOLEAN SetDataItem(const DataItem &item, INT column_id);
00046
00048         BOOLEAN SelectRow(INT row);
00049
00051         BOOLEAN CommitRow(INT row);
00052
00054         BOOLEAN AppendRow();
00055
00057         void RestoreFactorySettings();
00058
00060         BOOLEAN DeleteEntry(INT recno);
00061
00063         BOOLEAN DeleteAllRows();
00064
00066         BOOLEAN GetDataRecord(INT row, ToDoRecord *record);
00067
00069         BOOLEAN DeleteRow(INT row);
00070
00072         BOOLEAN ExistsRecord(INT row);
00073
00074     private:
00075
00077         const BitmapRes* GetMarkUnmarkIcon(INT idx);
00078
00079         ToDoRecord          m_record;
00080         ToDoRecord          m_commit_record;
00081         RecordHandler       m_handler;
00082 };
00083 #endif  // Mmi_MmiSettingsProvider_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoRecord.cpp File Reference

Applications/ToDo/ToDoRecord.cpp File Reference

#include "ToDoPreComp.hpp"
#include "ToDoRecord.hpp"

Include dependency graph for ToDoRecord.cpp:

Generated on Wed Jan 25 00:45:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoRecord.hpp File Reference

Applications/ToDo/ToDoRecord.hpp File Reference

#include <AddOns/AdcExtensions/Record.hpp>
#include <Auxiliary/Date.hpp>

Include dependency graph for ToDoRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | ToDoRecord
struct | ToDoRecord::Persist

Defines

#define | Mmi_ToDoRecord_hpp

Variables

const Date | c_invalid_date (99, 99, 9999)
const INT | c_note_max_length = 160

Define Documentation

#define Mmi_ToDoRecord_hpp

Generated on Wed Jan 25 00:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/ToDo/ToDoRecord.hpp Source File

Applications/ToDo/ToDoRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2001 COMNEON Software GmbH & Co. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_ToDoRecord_hpp)
00009 #define Mmi_ToDoRecord_hpp
00013
00014 #include <AddOns/AdcExtensions/Record.hpp>
00015 #include <Auxiliary/Date.hpp>
00016
00017
00018 const INT c_note_max_length = 160;
00019 const Date c_invalid_date(99, 99, 9999);
00020
00021 class ToDoRecord : public Record {
00022     typedef Record Base;
00023     public:
00024         enum ToDoRecMarkLevel{
00025               unmarked = 0,
00026               marked = 1
00027         };
00028
00029         enum ToDoRecProrityLevel{
00030                Low = 0,
00031                Medium = 1,
00032                High = 2,
00033                PriorityCount = 3
00034         };
00035
00036         enum Type {
00037             Deleted = 0,
00038             Used = 1
00039             };
00040
00041
00042         ToDoRecord (Type type = Deleted,
00043                          ToDoRecProrityLevel priorityLevel = Low,
00044                          Date toDoListDateTime = Date::Today,
00045                          ToDoRecMarkLevel markLevel = unmarked,
00046                              WString note = L"\0");
00047
00048
00050         virtual const UINT8* GetData();
00051
00053         virtual void SetData(const UINT8* data);
00054
00056         virtual INT GetPersistentSize();
00057
00059         void SetType(Type type) { m_data.type = type; }
00060
00062         Type GetType() const { return (Type)m_data.type; }
00063
00065         BOOLEAN IsRecordDeleted();
00066
00068         void MarkDeleted();
00069
00070
00071         struct Persist {
00072             Type type;
00073             ToDoRecProrityLevel priorityLevel;
00074             Date toDoListDateTime;
00075             ToDoRecMarkLevel markLevel;
00076             WCHAR note[c_note_max_length + 1];
00077         } m_data;
00078
00079 };
00081 #endif  // Mmi_ToDoListRecord_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibActionAccessor.cpp File Reference

Applications/UnifiedInbox/UibActionAccessor.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include "UibActionAccessor.hpp"

Include dependency graph for UibActionAccessor.cpp:

Generated on Wed Jan 25 00:45:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibActionAccessor.hpp File Reference

Applications/UnifiedInbox/UibActionAccessor.hpp File Reference

#include <GuiExtensions/ActionAccessor.hpp>

Include dependency graph for UibActionAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibActionAccessor

Defines

#define | UnifiedInbox_UibActionAccessor_hpp

Define Documentation

#define UnifiedInbox_UibActionAccessor_hpp

Generated on Wed Jan 25 00:45:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibActionAccessor.hpp Source File

Applications/UnifiedInbox/UibActionAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(UnifiedInbox_UibActionAccessor_hpp)
00010 #define UnifiedInbox_UibActionAccessor_hpp
00014
00015 #include <GuiExtensions/ActionAccessor.hpp>
00016
00024 class UibActionAccessor : public ActionAccessor {
00025     typedef ActionAccessor Base;
00026
00027     public:
00030         UibActionAccessor();
00031
00033         ~UibActionAccessor();
00034
00036         virtual Action* GetAction();
00037
00039         virtual INT GetActionCount() const;
00040
00042         virtual void InsertAction(INT index, Action *action);
00043
00045         virtual void RemoveAction(INT index);
00046
00048         virtual void RemoveAllActions();
00049
00051         virtual Action* GetAction(INT index) const;
00052
00054         virtual INT GetActionIndex(const Action &action) const;
00055
00057         void SetAccessor(AbstractActionAccessor* accessor) { m_accessor = accessor; }
00058
00060         void RemoveAccessor() { m_accessor = 0; }
00061
00062     private:
00063         INT AccActionCnt() const;
00064         Action* GetAccAction(INT index) const;
00065
00066         AbstractActionAccessor*         m_accessor;
00067 };
00068
00070 #endif  // Mmi_ActionAccessor_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibApp.cpp File Reference

Applications/UnifiedInbox/UibApp.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Asc/StackIndicationMsgTypes.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <Common/MmiInfoBox.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Common/Items/ItemObj.hpp>
#include <Atl/Features/ProviderProxyItem.hpp>
#include <Atl/Features/FeatureItemContainer.hpp>
#include <Config/UibConfig.hpp>
#include <Config/Config.hpp>
#include <Kernel/VersionInfo.hpp>
#include "UibMsgTypes.hpp"
#include "UibApp.hpp"
#include <Common/AudioManager.hpp>
#include <Common/AudioRequest.hpp>

Include dependency graph for UibApp.cpp:

Functions

ApoxiUseVersionInfo (UnifiedInbox)

Function Documentation

ApoxiUseVersionInfo ( UnifiedInbox )

Generated on Wed Jan 25 00:45:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibApp.hpp File Reference

Applications/UnifiedInbox/UibApp.hpp File Reference

#include <AddOns/AuxExtensions/AppendProvider.hpp>
#include <Auxiliary/QuickSortProvider.hpp>
#include <Gui/Action.hpp>
#include <Common/MmiApplication.hpp>
#include <Common/Items/ProviderProxyContainer.hpp>
#include <Common/Items/FeatureItem.hpp>
#include <Common/Items/ContextFeatureItem.hpp>
#include <Common/FeatureBroker/FeatureBroker.hpp>
#include <Atl/Gui/AtlItemListWindow.hpp>
#include <Common/MmiWaitingBox.hpp>
#include <Common/MmiAlert.hpp>
#include <Common/FireMsgAction.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Config/UibConfig.hpp>
#include "UibInboxProvider.hpp"
#include <Config/ContextConfig.hpp>
#include <UnifiedInbox/UibServiceImpl.hpp>
#include <UnifiedInbox/UibSettingsWin.hpp>
#include <UnifiedInbox/UibFolderWin.hpp>
#include <UnifiedInbox/UibSettingsProvider.hpp>
#include <Atl/Gui/ImgObtObj.hpp>

Include dependency graph for UibApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibApp

Defines

#define | UnifiedInbox_UibApp_hpp

Define Documentation

#define UnifiedInbox_UibApp_hpp

Generated on Wed Jan 25 00:45:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibApp.hpp Source File

Applications/UnifiedInbox/UibApp.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if ! defined(UnifiedInbox_UibApp_hpp)
00011 #define UnifiedInbox_UibApp_hpp
00014
00015 #include <AddOns/AuxExtensions/AppendProvider.hpp>
00016 #include <Auxiliary/QuickSortProvider.hpp>
00017 #include <Gui/Action.hpp>
00018
00019 #include <Common/MmiApplication.hpp>
00020 // start
00021 #include <Common/Items/ProviderProxyContainer.hpp>
00022 #include <Common/Items/FeatureItem.hpp>
00023 #include <Common/Items/ContextFeatureItem.hpp>
00024 #include <Common/FeatureBroker/FeatureBroker.hpp>
00025 #include <Atl/Gui/AtlItemListWindow.hpp>
00026 // end
00027
00028 #if defined(MMI_COMPAT_2_10_0)
00029 #include <MmiCompat/ContextMenuActionFeature.hpp>
00030 #include <MmiCompat/ContextMenuAction.hpp>
00031 #include <MmiCompat/BitmapResPtr.hpp>
00032 #endif //MMI_COMPAT_2_10_0
00033
00034 #include <Common/MmiWaitingBox.hpp>
00035 #include <Common/MmiAlert.hpp>
00036 #include <Common/FireMsgAction.hpp>
00037 #include <Common/CommonMsgTypes.hpp>
00038
00039 #include <Config/UibConfig.hpp>
00040 #include "UibInboxProvider.hpp"
00041
00042 // start
00043 #include <Config/ContextConfig.hpp>
00044 // end
00045 #if defined(MMI_COMPAT_2_10_0)
00046 #include <MmiCompat/MenuAction.hpp>
00047 #include <UnifiedInbox/UibActionAccessor.hpp>
00048 #endif //MMI_COMPAT_2_10_0
00049 #include <UnifiedInbox/UibServiceImpl.hpp>
00050 #include <UnifiedInbox/UibSettingsWin.hpp>
00051 #include <UnifiedInbox/UibFolderWin.hpp>
00052 #include <UnifiedInbox/UibSettingsProvider.hpp>
00053 #include <Atl/Gui/ImgObtObj.hpp>
00054
00055
00056 #ifdef MMI_UNIT_TEST_ENABLED
00057 #include <UnifiedInbox/UibUnitTests/UibAccessorTest.hpp>
00058 #include <UnifiedInbox/UibUnitTests/UibInboxTest.hpp>
00059 #include <UnifiedInbox/UibUnitTests/UibMsgDisplayTest.hpp>
00060 #include <UnifiedInbox/UibUnitTests/UibNotifyTest.hpp>
00061 #include <UnifiedInbox/UibUnitTests/UibPerformanceTest.hpp>
00062 #include <UnifiedInbox/UibUnitTests/UibSettingsTest.hpp>
00063 #include <UnifiedInbox/UibUnitTests/UibSortingTest.hpp>
00064 #include <MmiTest/MmiUnitTest/MmiUnitTestSuite.hpp>
00065 #endif
00066
00071 class UibInboxProvider;
00072
00073 class UibApp : public MmiApplication {
00074
00075     typedef MmiApplication Base;
00076
00077     public:
00078
00079         enum UibServiceType {
00080             RegisterType,
00081             NotifyType
00082         };
00083
00085         static UibApp* GetInstance();
00086
00088         virtual ~UibApp();
00089
00091         void DeleteAllMsg(UibConfig::UibFolderTypes folder_type);
00092
00095 //      void OnIndicateIncoming(UibMessageTypes msg_type);
00096
00097         SortProvider* GetSortedFolderProvider(UibConfig::UibFolderTypes folder_type);
00098
00100         INT GetSortColid(UibConfig::UibFolderTypes folder_type);
00101
00103         void UpdateFolderProvider(UibConfig::UibFolderTypes folder_type);
00104
00105         #if defined(MMI_COMPAT_2_10_0)
00106
00107         ActionAccessor* GetContextMenu() { return &m_context_menu_acc; }
00109         BOOLEAN UpdateContextMenu(INT index);
00110         #endif //MMI_COMPAT_2_10_0
00111
00113         Provider* GetSettingsProvider() { return &m_settings_provider; }
00114
00115         void OnSortingChanged(UibConfig::UibFolderTypes folder_type);
00116
00117         void ShowWaitingBox(BOOLEAN flag);
00118
00119         INT GetMessageType(INT index);
00120
00121         virtual DataItem GetContextDataItem(ContextFeature* feature);
00122
00123
00124
00125
00126     protected:
00127
00128         //handles the message request from the service interface
00129         virtual BOOLEAN OnMessage(const Message &msg);
00130
00132         virtual void OnStartup();
00133
00134         virtual void OnOpen();
00135
00136         virtual void OnClose();
00137
00138         virtual void OnUibRegisterService(UINT8 box_type, Provider* provider);
00139
00140         virtual void OnUibNotifyService();
00141
00142         //const WCHAR* GetTextForMsgType(UibConfig::UibMessageTypes msg_type) const;
00143
00144         // start
00145         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00146
00147         virtual BOOLEAN OnContextFeatureTriggered (const FeatureID& feature_id, const DataItem& context_item);
00148
00149         virtual BOOLEAN OnPropertyNotification(const Property::Notification notification,
00150                             const Property* property,
00151                             const DataItem& value);
00152
00153
00154         virtual void OnGetFocus();
00155         virtual void OnLoseFocus();
00156
00157
00158
00159         // end
00160
00161     private:
00162         enum TriggerNotification {
00163             TrOpenInbox,
00164             TrDeleteAll,
00165             TrOpenSettings,
00166             TriggerArrivedMsg,
00167             TrCnt
00168         };
00169
00170         // start
00171         enum FeatureItemIds {
00172                 UibOpenInbox,
00173                 UibSortByTimeStamp,
00174                 UibSortByMsgType,
00175                 UibSortAscending,
00176                 UibFeatureCnt
00177         };
00178
00179         enum ContextFeatureItemIds {
00180             UibDeleteInbox,
00181             UibSettings,
00182             UibContextFeatureCnt
00183         };
00184
00185         // end
00186
00187         INT GetFirstUnreadMsg();
00188         INT GetAllUnreadMessages();
00189         void GetMsgTone(INT msg_type);
00190
00191         //void UpdateContextMenuActions(INT index);
00192         BOOLEAN FolderWindowOpen(UibConfig::UibFolderTypes folder_type);
00193
00194         static UibApp           m_uib_app;
00195         MmiAlert                m_alert;
00196
00197         //static FireMsgAction  m_msg_indication_action;
00198         //TriggerNotificationMsg    m_indication_msg;
00199 #if defined(MMI_COMPAT_2_10_0)
00200         MenuAction              m_uib_actions[TrCnt];
00201         UibActionAccessor       m_context_menu_acc;
00202 #endif //MMI_COMPAT_2_10_0
00203         // start
00204         Feature                 m_items[UibFeatureCnt];
00205         ContextFeature          m_context_items[UibContextFeatureCnt];
00206
00207         ProviderProxyContainer  m_proxy_cont;
00208         //AtlItemListWindow     m_folder_win;
00209         UibFolderWin            m_folder_win;
00210         INT                     m_sel_row;
00211         // end
00212
00213         UibApp();
00214
00215         UibServiceImpl          m_service;
00216         //static AppendProvider m_inbox_provider;
00217         static UibInboxProvider m_inbox_provider;
00218
00219         //UibFolderWin          m_folder_win;
00220         UibConfig::UibFolderTypes   m_folder_type;
00221         UibSettingsWin          m_settings_win;
00222
00223         WString                 m_menu_text;
00224         WString                 m_inbox_text;
00225
00226         UibSettingsProvider     m_settings_provider;
00227
00228         QuickSortProvider       m_sorted_inbox_provider;
00229
00230         MmiWaitingBox           m_waiting_box;
00231         WString                 m_action_text;
00232
00233         DataItem                m_item;
00234         EqualsRule              m_rule;
00235
00236         BOOLEAN                 m_waiting_cnt;
00237
00238         BOOLEAN                 m_sort_asc;
00239
00240         #if defined(MMI_COMPAT_2_10_0)
00241         ContextMenuActionFeature        *m_context_menu_action_feat;
00242         INT                     m_menu_count;
00243         Vector<ContextMenuActionFeature*>   m_contxt_menu;
00244
00245         void BuildFeatureTable(Provider* provider);
00246         AbstractActionAccessor* GetActionAccessor(INT index, DataItem &data_item);
00247         BOOLEAN IsMenuExist(FeatureItemContainer* feat_item_cont, INT index);
00248         ContextMenuActionFeature* GetFeatureItem(Action* action);
00249         #endif //MMI_COMPAT_2_10_0
00250
00251         #ifdef MMI_UNIT_TEST_ENABLED
00252             MmiUnitTestSuite        m_uib_suite;
00253             UibMsgDisplayTest       m_test_msg_display;
00254             UibAccessorTest         m_test_accessor;
00255             UibSettingsTest         m_uib_settings_test;
00256             UibInboxTest            m_uib_inbox_test;
00257             UibSortingTest          m_uib_sorting_test;
00258             UibNotifyTest           m_uib_notify_test;
00259             UibPerformanceTest      m_uib_performance_test;
00260             void InitUnitTests();
00261         #endif
00262
00263 };
00264
00265
00266
00267
00268
00269 #endif // UnifiedInbox_UibApp_hpp
00270
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibFolderWin.cpp File Reference

Applications/UnifiedInbox/UibFolderWin.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include "UibFolderWin.hpp"
#include "UibApp.hpp"
#include "UibMsgTypes.hpp"
#include <Auxiliary/FilterProvider.hpp>

Include dependency graph for UibFolderWin.cpp:

Generated on Wed Jan 25 00:45:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibFolderWin.hpp File Reference

Applications/UnifiedInbox/UibFolderWin.hpp File Reference

#include <Auxiliary/WString.hpp>
#include <Atl/Gui/AtlItemListWindow.hpp>
#include <Config/UibConfig.hpp>

Include dependency graph for UibFolderWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibFolderWin

Defines

#define | UnifiedInbox_UibFolderWin_hpp

Define Documentation

#define UnifiedInbox_UibFolderWin_hpp

Generated on Wed Jan 25 00:45:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibFolderWin.hpp Source File

Applications/UnifiedInbox/UibFolderWin.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008
00009
00010 #if ! defined(UnifiedInbox_UibFolderWin_hpp)
00011 #define UnifiedInbox_UibFolderWin_hpp
00014
00015 #include <Auxiliary/WString.hpp>
00016 #include <Atl/Gui/AtlItemListWindow.hpp>
00017 #include <Config/UibConfig.hpp>
00018
00023 class UibApp;
00024
00025 class UibFolderWin : public AtlItemListWindow {
00026
00027     typedef AtlItemListWindow Base;
00028
00029     public:
00031         UibFolderWin();
00032
00034         virtual ~UibFolderWin();
00035
00038         void Init(UibApp* uib_app, UibConfig::UibFolderTypes folder_type, AbstractItemContainer* item_cont);
00039
00041         INT GetSelectedMsg();
00042
00044         void SetFolderType(UibConfig::UibFolderTypes folder_type);
00045
00047         UibConfig::UibFolderTypes GetFolderType() const { return m_folder_type; }
00048
00050     //  DrawableObjectListBox* GetListboxModel() { return &m_listbox; }
00051
00053         void Update();
00054
00055         void SetUibContextId();
00056
00057     protected:
00058
00059         virtual BOOLEAN OnMessage(const Message& msg);
00060
00061         virtual void OnOpen();
00062
00064         // virtual BOOLEAN OnSoftkeyPressed(INT index);
00065
00066         virtual void OnUpdate(ObservableObject* obs_obj);
00067
00068         virtual void OnSelectionChanged();
00069
00070         virtual void OnGetFocus();
00071
00072     private:
00073         void UpdateTitle();
00074         INT GetMsgCount(UibConfig::UibFolderTypes folder_type);
00075         INT GetUnreadMsgCount(UibConfig::UibFolderTypes folder_type);
00076
00077
00078         UibApp*                 m_uib_app;
00079         //UibListBoxModel           m_listbox_model;
00080         //DrawableObjectListBox m_listbox;
00081         //CloseWindowAction     m_close_action;
00082
00083         UibConfig::UibFolderTypes m_folder_type;
00084         WString                 m_title;
00085
00086 };
00087
00088 #endif // UnifiedInbox_UibFolderWin_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibInboxProvider.cpp File Reference

Applications/UnifiedInbox/UibInboxProvider.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <GuiExtensions/BitmapResPtr.hpp>
#include <Atl/Gui/ImgObtObj.hpp>
#include <Config/Config.hpp>
#include "UibInboxProvider.hpp"

Include dependency graph for UibInboxProvider.cpp:

Generated on Wed Jan 25 00:46:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibInboxProvider.hpp File Reference

Applications/UnifiedInbox/UibInboxProvider.hpp File Reference

#include <AddOns/AuxExtensions/AppendProvider.hpp>

Include dependency graph for UibInboxProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibInboxProvider

Defines

#define | UnifiedInbox_UibInboxProvider_hpp

Define Documentation

#define UnifiedInbox_UibInboxProvider_hpp

Generated on Wed Jan 25 00:46:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibInboxProvider.hpp Source File

Applications/UnifiedInbox/UibInboxProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(UnifiedInbox_UibInboxProvider_hpp)
00010 #define UnifiedInbox_UibInboxProvider_hpp
00013
00014
00015 #include <AddOns/AuxExtensions/AppendProvider.hpp>
00016
00017
00018 class UibInboxProvider: public AppendProvider {
00019             typedef AppendProvider Base;
00020     public:
00021
00022     UibInboxProvider();
00023
00024     ~UibInboxProvider();
00025
00026     virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem& item);
00027     protected:
00029         virtual void OnUpdate(ObservableObject *obs_obj){};
00030
00031 };
00032
00034 #endif  // Mmi_UnifiedInboxProvider_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibListBoxModel.cpp File Reference

Applications/UnifiedInbox/UibListBoxModel.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include "UibListBoxModel.hpp"
#include "UibApp.hpp"
#include "GuiExtensions/BitmapResPtr.hpp"

Include dependency graph for UibListBoxModel.cpp:

Generated on Wed Jan 25 00:46:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibListBoxModel.hpp File Reference

Applications/UnifiedInbox/UibListBoxModel.hpp File Reference

#include <GuiExtensions/LabelListBoxModel.hpp>
#include <Auxiliary/Provider.hpp>
#include <Config/Config.hpp>

Include dependency graph for UibListBoxModel.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibListBoxModel

Defines

#define | UnifiedInbox_UibListBoxModel_hpp

Define Documentation

#define UnifiedInbox_UibListBoxModel_hpp

Generated on Wed Jan 25 00:46:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibListBoxModel.hpp Source File

Applications/UnifiedInbox/UibListBoxModel.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if ! defined(UnifiedInbox_UibListBoxModel_hpp)
00011 #define UnifiedInbox_UibListBoxModel_hpp
00014
00015 #include <GuiExtensions/LabelListBoxModel.hpp>
00016 #include <Auxiliary/Provider.hpp>
00017
00018 #include <Config/Config.hpp>
00019
00020 class UibInboxWin;
00021
00022 class UibListBoxModel : public LabelListBoxModel {
00023
00024     typedef LabelListBoxModel Base;
00025
00026     public:
00027
00029         UibListBoxModel();
00030
00032         virtual ~UibListBoxModel();
00033
00035         void Init(DrawableObjectListBox* list_box, Provider* provider);
00036
00040         virtual const BitmapRes* GetCellIcon(INT index, BOOLEAN highlighted);
00041
00045         virtual const WCHAR* GetCellText(INT index, BOOLEAN highlighted);
00046
00047         virtual void Update(INT item_count = -1);
00048
00049         void SetProvider(Provider* provider) { m_provider = provider; }
00050
00051         Provider* GetProvider() { return m_provider; }
00052
00053     private:
00054         Provider* m_provider;
00055         WString m_text;
00056 };
00057
00058 #endif // UnifiedInbox_UibListBoxModel_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibMsgTypes.cpp File Reference

Applications/UnifiedInbox/UibMsgTypes.cpp File Reference

#include "UnifiedInbox/UibPreComp.hpp"
#include "UibMsgTypes.hpp"

Include dependency graph for UibMsgTypes.cpp:

Functions

OutputStream & | operator<< (OutputStream &ostr, const UibUpdateMsg &cls)
OutputStream & | operator<< (OutputStream &ostr, const UibNotifyMsg &cls)
OutputStream & | operator<< (OutputStream &ostr, const UibRegisterMsg &cls)
InputStream & | operator>> (InputStream &istr, UibUpdateMsg &cls)
InputStream & | operator>> (InputStream &istr, UibNotifyMsg &cls)
InputStream & | operator>> (InputStream &istr, UibRegisterMsg &cls)

Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const UibUpdateMsg & | cls
 | ) |

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const UibNotifyMsg & | cls
 | ) |

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const UibRegisterMsg & | cls
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | UibUpdateMsg & | cls
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | UibNotifyMsg & | cls
 | ) |

InputStream& operator>> | ( | InputStream & | istr,
 |  | UibRegisterMsg & | cls
 | ) |

Generated on Wed Jan 25 00:46:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibMsgTypes.hpp File Reference

Applications/UnifiedInbox/UibMsgTypes.hpp File Reference

#include <Kernel/Message.hpp>
#include <Auxiliary/Provider.hpp>
#include <Auxiliary/WString.hpp>
#include <Gui/EditorDocument.hpp>
#include <Kernel/InputStream.hpp>
#include <Kernel/OutputStream.hpp>

Include dependency graph for UibMsgTypes.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibNotifyMsg
class | UibRegisterMsg
class | UibUpdateMsg

Defines

#define | UnifiedInbox_UibMsgTypes_hpp

Define Documentation

#define UnifiedInbox_UibMsgTypes_hpp

Generated on Wed Jan 25 00:46:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibMsgTypes.hpp Source File

Applications/UnifiedInbox/UibMsgTypes.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     --------------------------------------------------------
00008     ========================================================
00009     This file was generated with ApoxiMessageGenerator as
00010     defined in "lnz_development\src\Applications\UnifiedInbox\UibMsgTypes.xml"
00011     DO NOT CHANGE IT MANUALLY!
00012     --------------------------------------------------------------*/
00013
00014
00015 #if !defined(UnifiedInbox_UibMsgTypes_hpp)
00016 #define UnifiedInbox_UibMsgTypes_hpp
00017
00018 #include <Kernel/Message.hpp>
00019 #include <Auxiliary/Provider.hpp>
00020 #include <Auxiliary/WString.hpp>
00021 #include <Gui/EditorDocument.hpp>
00022 #include <Kernel/InputStream.hpp>
00023 #include <Kernel/OutputStream.hpp>
00024
00025
00026 /* ----------------------------------------------------------------------
00027     Classes
00028     ---------------------------------------------------------------------- */
00029
00030 /*  ======================================================================
00031     Class UibRegisterMsg
00032     ====================================================================== */
00033
00034 class UibRegisterMsg : public ApplicationMsg {
00035     public:
00036         UibRegisterMsg(Application* application, UINT8 box_type, Provider* folder);
00037         virtual ~UibRegisterMsg();
00038
00039         virtual const MsgMetaData& GetMetaData() const;
00040         void SetBoxType(UINT8 box_type) { m_box_type = box_type; }
00041         UINT8 GetBoxType() const { return m_box_type; }
00042         void SetFolder(Provider* folder) { m_folder = folder; }
00043         Provider* GetFolder() const { return m_folder; }
00044         virtual Message* Clone() const;
00045 #if !defined(APOXI_NOSTREAMING)
00046         friend OutputStream& operator << (OutputStream& ostr, const UibRegisterMsg& cls);
00047 #endif // APOXI_NOSTREAMING
00048 #if !defined(APOXI_NOSTREAMING)
00049         friend InputStream& operator >> (InputStream& istr, UibRegisterMsg& cls);
00050 #endif // APOXI_NOSTREAMING
00051
00052         enum {
00053             ID = 30000
00054             };
00055
00056     protected:
00057
00058 #if !defined(APOXI_NOSTREAMING)
00059         virtual void Dump(OutputStream& ostr) const;
00060 #endif // APOXI_NOSTREAMING
00061
00062     private:
00063         static const MsgMetaData m_meta_data;
00064         UINT8 m_box_type;
00065         Provider* m_folder;
00066
00067     };
00068
00069
00070 /*  ======================================================================
00071     Class UibNotifyMsg
00072     ====================================================================== */
00073
00074 class UibNotifyMsg : public ApplicationMsg {
00075     public:
00076         UibNotifyMsg(Application* application);
00077         virtual ~UibNotifyMsg();
00078
00079         virtual const MsgMetaData& GetMetaData() const;
00080         virtual Message* Clone() const;
00081 #if !defined(APOXI_NOSTREAMING)
00082         friend OutputStream& operator << (OutputStream& ostr, const UibNotifyMsg& cls);
00083 #endif // APOXI_NOSTREAMING
00084 #if !defined(APOXI_NOSTREAMING)
00085         friend InputStream& operator >> (InputStream& istr, UibNotifyMsg& cls);
00086 #endif // APOXI_NOSTREAMING
00087
00088         enum {
00089             ID = 30001
00090             };
00091
00092     protected:
00093
00094 #if !defined(APOXI_NOSTREAMING)
00095         virtual void Dump(OutputStream& ostr) const;
00096 #endif // APOXI_NOSTREAMING
00097
00098     private:
00099         static const MsgMetaData m_meta_data;
00100
00101     };
00102
00103
00104 /*  ======================================================================
00105     Class UibUpdateMsg
00106     ====================================================================== */
00107
00108 class UibUpdateMsg : public ApplicationMsg {
00109     public:
00110         UibUpdateMsg(Application* application);
00111         virtual ~UibUpdateMsg();
00112
00113         virtual const MsgMetaData& GetMetaData() const;
00114         virtual Message* Clone() const;
00115 #if !defined(APOXI_NOSTREAMING)
00116         friend OutputStream& operator << (OutputStream& ostr, const UibUpdateMsg& cls);
00117 #endif // APOXI_NOSTREAMING
00118 #if !defined(APOXI_NOSTREAMING)
00119         friend InputStream& operator >> (InputStream& istr, UibUpdateMsg& cls);
00120 #endif // APOXI_NOSTREAMING
00121
00122         enum {
00123             ID = 30002
00124             };
00125
00126     protected:
00127
00128 #if !defined(APOXI_NOSTREAMING)
00129         virtual void Dump(OutputStream& ostr) const;
00130 #endif // APOXI_NOSTREAMING
00131
00132     private:
00133         static const MsgMetaData m_meta_data;
00134
00135     };
00136
00137 #endif // UnifiedInbox_UibMsgTypes_hpp
00138
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibPreComp.cpp File Reference

Applications/UnifiedInbox/UibPreComp.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>

Include dependency graph for UibPreComp.cpp:

Generated on Wed Jan 25 00:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibPreComp.hpp File Reference

Applications/UnifiedInbox/UibPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Adc/Lib.hpp>
#include <AddOns/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for UibPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:46:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibPreComp.hpp Source File

Applications/UnifiedInbox/UibPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Apc/Lib.hpp>
00012 #include <Auxiliary/Lib.hpp>
00013 #include <Adc/Lib.hpp>
00014 #include <AddOns/Lib.hpp>
00015
00016 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibServiceImpl.cpp File Reference

Applications/UnifiedInbox/UibServiceImpl.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include "UibMsgTypes.hpp"
#include "UibServiceImpl.hpp"
#include "UibApp.hpp"

Include dependency graph for UibServiceImpl.cpp:

Generated on Wed Jan 25 00:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibServiceImpl.hpp File Reference

Applications/UnifiedInbox/UibServiceImpl.hpp File Reference

#include <Common/MmiServices.hpp>
#include <Config/UibConfig.hpp>

Include dependency graph for UibServiceImpl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibServiceImpl

Defines

#define | UnifiedInbox_UibServiceImpl_hpp

Define Documentation

#define UnifiedInbox_UibServiceImpl_hpp

Generated on Wed Jan 25 00:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibServiceImpl.hpp Source File

Applications/UnifiedInbox/UibServiceImpl.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if ! defined(UnifiedInbox_UibServiceImpl_hpp)
00011 #define UnifiedInbox_UibServiceImpl_hpp
00014
00015 #include <Common/MmiServices.hpp>
00016 #include <Config/UibConfig.hpp>
00017
00018
00019 class UibServiceImpl : public UibService
00020 {
00021     public:
00022
00024         virtual ~UibServiceImpl();
00025
00027         UibServiceImpl();
00028
00030         void Init(Application* app);
00031
00036         virtual ServiceResult NotifyArrival() const;
00037
00041         virtual ServiceResult Register(UINT8 box_type, Provider* folder) const;
00042
00043     private:
00044         Application* m_app;
00045
00046 };
00047
00048 #endif // UnifiedInbox_UibServiceImpl_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsProvider.cpp File Reference

Applications/UnifiedInbox/UibSettingsProvider.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Afs/Rfs/RootFileSystem.hpp>
#include <AddOns/AfsFfs/FlashStorageDeviceImp.hpp>
#include <Config/Config.hpp>
#include <Config/UibConfig.hpp>
#include "UibSettingsProvider.hpp"

Include dependency graph for UibSettingsProvider.cpp:

Generated on Wed Jan 25 00:47:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsProvider.hpp File Reference

Applications/UnifiedInbox/UibSettingsProvider.hpp File Reference

#include <AddOns/AdcExtensions/RecordHandler.hpp>
#include <Common/SettingsProvider.hpp>
#include <UnifiedInbox/UibSettingsRecord.hpp>

Include dependency graph for UibSettingsProvider.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibSettingsProvider

Defines

#define | UibSettingsProvider_hpp

Define Documentation

#define UibSettingsProvider_hpp

Generated on Wed Jan 25 00:47:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsProvider.hpp Source File

Applications/UnifiedInbox/UibSettingsProvider.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if ! defined(UibSettingsProvider_hpp)
00010 #define UibSettingsProvider_hpp
00011
00014
00015 #include <AddOns/AdcExtensions/RecordHandler.hpp>
00016 #include <Common/SettingsProvider.hpp>
00017
00018 #include <UnifiedInbox/UibSettingsRecord.hpp>
00019
00020 /*  UibSettingsProvider provides settings data of the UIB.
00021     This Provider consists of two columns:
00022     c_uib_sort_crit_colid
00023     c_uib_sort_asc_colid */
00024 class UibSettingsProvider : public SettingsProvider {
00025
00026     typedef SettingsProvider Base;
00027
00028     public:
00030         UibSettingsProvider();
00031
00033         virtual ~UibSettingsProvider();
00034
00035         virtual INT GetProviderId() const;
00036
00038         void Init();
00039
00041         virtual void RestoreFactorySettings();
00042
00044         virtual INT RowCount();
00045
00047         virtual BOOLEAN GetDataItem(INT columnid, INT row, DataItem &item);
00048
00050         virtual BOOLEAN SetDataItem(const DataItem& item, INT columnid);
00051
00053         virtual BOOLEAN SelectRow(INT row);
00054
00056         virtual BOOLEAN CommitRow(INT row);
00057
00058     private:
00059         RecordHandler m_handler;
00060         UibSettingsRecord m_record;
00061         UibSettingsRecord m_commit_record;
00062 };
00063
00064 #endif /* UibSettingsProvider_hpp */
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsRecord.cpp File Reference

Applications/UnifiedInbox/UibSettingsRecord.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Config/UibConfig.hpp>
#include "UibSettingsRecord.hpp"

Include dependency graph for UibSettingsRecord.cpp:

Generated on Wed Jan 25 00:47:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsRecord.hpp File Reference

Applications/UnifiedInbox/UibSettingsRecord.hpp File Reference

#include <AddOns/AdcExtensions/Record.hpp>

Include dependency graph for UibSettingsRecord.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibSettingsRecord
struct | UibSettingsRecord::Persist

Defines

#define | Mmi_UibSettingsRecord_hpp

Define Documentation

#define Mmi_UibSettingsRecord_hpp

Generated on Wed Jan 25 00:47:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsRecord.hpp Source File

Applications/UnifiedInbox/UibSettingsRecord.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_UibSettingsRecord_hpp)
00010 #define Mmi_UibSettingsRecord_hpp
00011
00012 #include <AddOns/AdcExtensions/Record.hpp>
00013
00014 class UibSettingsRecord : public Record {
00015     typedef Record Base;
00016
00017     public:
00018         UibSettingsRecord(UINT8 sort_key = 0, BOOLEAN sort_asc = TRUE);
00019
00021         UINT8 GetSortKey() const { return m_data.m_bits.sort_key; }
00022
00024         void SetSortKey(UINT8 value) { m_data.m_bits.sort_key = value; }
00025
00027         void SetSortAsc(BOOLEAN flag) { m_data.m_bits.sort_asc = flag; }
00028
00030         BOOLEAN IsSortAsc() const { return m_data.m_bits.sort_asc; }
00031
00033         void SetDefault();
00034
00037         virtual const UINT8* GetData();
00038
00041         virtual void SetData(const UINT8* data);
00042
00045         virtual INT GetPersistentSize();
00046
00048         virtual void MarkDeleted();
00049
00051         virtual BOOLEAN IsRecordDeleted();
00052
00053     private:
00054         struct Persist {
00055             struct {
00056                 UINT8 sort_key : 7;
00057                 UINT8 sort_asc : 1;
00058             } m_bits;
00059         } m_data;
00060 };
00061
00062 #endif /* Mmi_UibSettingsRecord_hpp */
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsWin.cpp File Reference

Applications/UnifiedInbox/UibSettingsWin.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Config/Config.hpp>
#include <UnifiedInbox/UibApp.hpp>
#include "UibSettingsWin.hpp"

Include dependency graph for UibSettingsWin.cpp:

Generated on Wed Jan 25 00:47:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsWin.hpp File Reference

Applications/UnifiedInbox/UibSettingsWin.hpp File Reference

#include <Gui/ItemMenu.hpp>
#include <Gui/RadioButtonAction.hpp>
#include <Gui/CheckBoxAction.hpp>
#include <Gui/RadioButtonGroup.hpp>
#include <Common/MmiWindow.hpp>
#include <Config/UibConfig.hpp>
#include <UnifiedInbox/UibSettingsProvider.hpp>

Include dependency graph for UibSettingsWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibSettingsWin

Defines

#define | UnifiedInbox_UibSettingsWin_hpp

Define Documentation

#define UnifiedInbox_UibSettingsWin_hpp

Generated on Wed Jan 25 00:47:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibSettingsWin.hpp Source File

Applications/UnifiedInbox/UibSettingsWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if ! defined(UnifiedInbox_UibSettingsWin_hpp)
00010 #define UnifiedInbox_UibSettingsWin_hpp
00013
00014 #include <Gui/ItemMenu.hpp>
00015 #include <Gui/RadioButtonAction.hpp>
00016 #include <Gui/CheckBoxAction.hpp>
00017 #include <Gui/RadioButtonGroup.hpp>
00018 //#include <GuiExtensions/MmiMenuWindow.hpp>
00019 #include <Common/MmiWindow.hpp>
00020 //#include <MmiCompat/MmiMenuWindow.hpp>
00021 //#include <MmiCompat/ActionAccessor.hpp>
00022
00023 #include <Config/UibConfig.hpp>
00024
00025 #include <UnifiedInbox/UibSettingsProvider.hpp>
00026
00027 class UibApp;
00028
00029 class UibSettingsWin : public MmiWindow {
00030
00031     typedef MmiWindow Base;
00032
00033     public:
00034
00036         UibSettingsWin(Provider* settings_provider = 0);
00037
00039         virtual ~UibSettingsWin();
00040
00045         void Init(Provider* settings_provider);
00046
00047         void SetFolderType(UibConfig::UibFolderTypes folder_type) { m_folder_type = folder_type; }
00048
00049     protected:
00050         virtual void OnOpen();
00051         virtual void OnClose();
00052         virtual BOOLEAN OnConfirm();
00053
00054     private:
00056         RadioButtonAction   m_rb_sort_key[UibConfig::UibInvalidSortKey];
00057
00058         CheckBoxAction      m_cb_sort_order;
00059
00060         ItemMenu m_item_menu;
00061
00062         RadioButtonGroup    m_rb_group;
00063
00064         Provider*           m_settings_provider;
00065         UibConfig::UibFolderTypes m_folder_type;
00066
00067         UINT8               m_old_sort_key;
00068         BOOLEAN             m_old_asc;
00069 };
00070
00071 #endif // UnifiedInbox_UibSettingsWin_hpp/
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUpdateThreadlet.cpp File Reference

Applications/UnifiedInbox/UibUpdateThreadlet.cpp File Reference

#include "UnifiedInbox/UibPreComp.hpp"
#include "UibUpdateThreadlet.hpp"

Include dependency graph for UibUpdateThreadlet.cpp:

Generated on Wed Jan 25 00:49:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUpdateThreadlet.hpp File Reference

Applications/UnifiedInbox/UibUpdateThreadlet.hpp File Reference

#include <Kernel/Threadlet.hpp>
#include <Auxiliary/Provider.hpp>

Include dependency graph for UibUpdateThreadlet.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibUpdateThreadlet

Defines

#define | UibUpdateThreadlet_hpp

Define Documentation

#define UibUpdateThreadlet_hpp

Generated on Wed Jan 25 00:49:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUpdateThreadlet.hpp Source File

Applications/UnifiedInbox/UibUpdateThreadlet.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON electronic technology GmbH&  Co. OHG.
00003     All rights reserved.
00004     ------------------------------------------------------------------------
00005     This document contains proprietary information belonging to COMNEON.
00006     Passing on and copying of this document, use and communication of its
00007     contents is not permitted without prior written authorisation.
00008     ------------------------------------------------------------------------ */
00009
00010 #if !defined(UibUpdateThreadlet_hpp)
00011 #define UibUpdateThreadlet_hpp
00014
00015 #include <Kernel/Threadlet.hpp>
00016 #include <Auxiliary/Provider.hpp>
00017
00021 class UibUpdateThreadlet : public Threadlet {
00022     typedef Threadlet Base;
00023
00024     public:
00026         UibUpdateThreadlet();
00027
00029         virtual ~UibUpdateThreadlet();
00030
00032         void Init(Provider* provider) { m_provider = provider; }
00033
00035         void SetProvider(Provider* provider) { m_provider = provider; }
00036
00038         virtual INT Fn();
00039
00040     private:
00041         Provider* m_provider;
00042 };
00043
00045 #endif  // Apoxi_UibUpdateThreadlet_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibVersion.cpp File Reference

Applications/UnifiedInbox/UibVersion.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Kernel/VersionInfo.hpp>
#include "UibVersion.hpp"

Include dependency graph for UibVersion.cpp:

Functions

ApoxiDefVersionInfo (UnifiedInbox, UIBVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | UnifiedInbox | ,
 |  | UIBVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibVersion.hpp File Reference

Applications/UnifiedInbox/UibVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | UIBVERSION "2.10.0_TIV_04"
#define | UibVersion_hpp

Define Documentation

#define UIBVERSION "2.10.0_TIV_04"

#define UibVersion_hpp

Generated on Wed Jan 25 00:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibVersion.hpp Source File

Applications/UnifiedInbox/UibVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(UibVersion_hpp)
00010 #define UibVersion_hpp
00011
00012
00013 /*
00014 UibVersion.hpp contains the official Uib Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define UIBVERSION "2.10.0_TIV_04"
00019
00020 #endif  // UibVersion_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include "UibAccessorTest.hpp"
#include <MmiTest/TestApp.hpp>

Include dependency graph for UibAccessorTest.cpp:

Generated on Wed Jan 25 00:47:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.hpp File Reference

#include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
#include <UnifiedInbox/UibActionAccessor.hpp>

Include dependency graph for UibAccessorTest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibAccessorTest

Defines

#define | _Mmi_UibAccessorTest_hpp

Define Documentation

#define _Mmi_UibAccessorTest_hpp

Generated on Wed Jan 25 00:47:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if ! defined(UnifiedInobx_UibAccessorTest_hpp)
00011 #define _Mmi_UibAccessorTest_hpp
00014
00015
00016 /*#if defined(_DEBUG)
00017     #define VERIFY(cond, text)  MmiVerification::Verfiy(cond, __FILE__, __LINE__, text);
00018 #endif
00019 */
00020
00021
00022 #include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
00023 #include <UnifiedInbox/UibActionAccessor.hpp>
00024
00025 class TestApp;
00026
00027 class UibAccessorTest : public MmiUnitTest {
00028
00029     typedef MmiUnitTest Base;
00030
00031     public:
00032
00034         UibAccessorTest();
00035
00036         UibAccessorTest(MmiUnitTestSuite* suite, BOOLEAN proceed_on_failed = TRUE);
00037
00039         virtual ~UibAccessorTest();
00040
00042         void Init(MmiUnitTestSuite* suite, BOOLEAN proceed_on_failed = TRUE);
00043
00045         const WCHAR* GetName() { return L"Message Presentation"; }
00046
00048         virtual TestResult Run();
00049
00050     protected:
00051
00052         void SetPreconditions();
00053
00054         void TestSetAccessor(ActionAccessor* accessor);
00055
00056         void TestRemoveAccessor();
00057
00058         void TestGetActionCount();
00059
00060         void TestGetAction();
00061
00062         void TestInsertAction(INT index);
00063
00064         void TestRemoveAllActions();
00065
00066         void TestRemoveAction(INT index);
00067
00068         void TestGetActionIndex(const Action &action);
00069
00070     private:
00071
00072         UibActionAccessor   m_uib_accessor;
00073         ActionAccessor      m_accessor;
00074
00075         Action              m_view_action;
00076         Action              m_delete_action;
00077         Action              m_reply_action;
00078
00079         Action              m_forward_action;
00080         Action              m_details_action;
00081
00082         Action              m_delete_all_action;
00083         OpenWindowAction    m_open_settings;
00084
00085 };
00086
00087 #endif //#define Mmi_UibAccessorTest_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibInboxTest.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibInboxTest.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <GuiExtensions/AbstractActionAccessorPtr.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Config/UibConfig.hpp>
#include <UnifiedInbox/UibApp.hpp>
#include "MmiTest/TestApp.hpp"
#include "UibInboxTest.hpp"

Include dependency graph for UibInboxTest.cpp:

Generated on Wed Jan 25 00:48:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibInboxTest.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibInboxTest.hpp File Reference

#include <Kernel/Timer.hpp>
#include <Kernel/Condition.hpp>
#include <GuiExtensions/ContextMenuAction.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
#include <MmiTest/TestChildProvider1.hpp>
#include <MmiTest/TestChildProvider2.hpp>
#include <AddOns/AuxExtensions/AppendProvider.hpp>
#include <UnifiedInbox/UibFolderWin.hpp>

Include dependency graph for UibInboxTest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibInboxTest

Defines

#define | UibInboxTest_hpp

Define Documentation

#define UibInboxTest_hpp

Generated on Wed Jan 25 00:48:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibInboxTest.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibInboxTest.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if !defined(UibInboxTest_hpp)
00011 #define UibInboxTest_hpp
00012
00013 #include <Kernel/Timer.hpp>
00014 #include <Kernel/Condition.hpp>
00015
00016 #include <GuiExtensions/ContextMenuAction.hpp>
00017 #include <GuiExtensions/ActionAccessor.hpp>
00018
00019 #include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
00020 #include <MmiTest/TestChildProvider1.hpp>
00021 #include <MmiTest/TestChildProvider2.hpp>
00022 #include <AddOns/AuxExtensions/AppendProvider.hpp>
00023
00024 #include <UnifiedInbox/UibFolderWin.hpp>
00025
00026 class UibInboxTest : public MmiUnitTest, public Observer {
00027     typedef MmiUnitTest Base;
00028
00029     public:
00030         enum ContextActions {
00031             Action1,
00032             Action2,
00033             Action3,
00034             ActionCnt
00035         };
00036
00038         UibInboxTest() {};
00039
00041         virtual ~UibInboxTest();
00042
00044         void Init(WCHAR* name, MmiUnitTestSuite* suite);
00045
00047         virtual TestResult Run();
00048
00049     protected:
00050         virtual BOOLEAN OnMessage(const Message &msg);
00051
00052         virtual void OnUpdate(ObservableObject* obs_obj);
00053
00054     private:
00055         enum TriggeredAction {
00056             TrDeleteOneEntry = 10,
00057             TrAddEntry = 11,
00058         };
00059
00060         void TestDisplay();
00061         void TestContextMenu(INT index);
00062         void TestContextActionExecution(UibConfig::UibMessageTypes msg_type, UibInboxTest::ContextActions context_action);
00063         void TestUpdate(TriggeredAction prov_action);
00064
00065         void DeleteEntry(INT index);
00066         void AddEntry();
00067
00068         void TestDeleteAllMsg(UibConfig::UibFolderTypes folder_type);
00069
00070         const WCHAR* GetTextForMsgType(UibConfig::UibMessageTypes msg_type) const;
00071
00072         UibFolderWin m_inbox_win;
00073         UibServiceImpl m_uib_service;
00074
00075         ContextMenuAction m_context_actions[ActionCnt];
00076         ActionAccessor  m_acc_prov1;
00077         ActionAccessor m_acc_prov2;
00078
00079         Timer m_timeout_timer;
00080
00081         UibInboxTest::ContextActions m_triggered_action;
00082
00083         BooleanCondition m_cond;
00084         BOOLEAN m_flag;
00085
00086         Provider* m_prov1;
00087         Provider* m_prov2;
00088         UibApp* m_uib_app;
00089 };
00090
00091 #endif /* UibInboxTest_hpp */
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include "UibMsgDisplayTest.hpp"
#include <UnifiedInbox/UibMsgTypes.hpp>
#include <MmiTest/TestApp.hpp>

Include dependency graph for UibMsgDisplayTest.cpp:

Generated on Wed Jan 25 00:48:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.hpp File Reference

#include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
#include <UnifiedInbox/UibServiceImpl.hpp>
#include <MmiTest/TestChildProvider1.hpp>
#include <MmiTest/TestChildProvider2.hpp>
#include <Kernel/Condition.hpp>

Include dependency graph for UibMsgDisplayTest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibMsgDisplayTest

Defines

#define | UnifiedInobx_UibMsgDisplayTest_hpp

Define Documentation

#define UnifiedInobx_UibMsgDisplayTest_hpp

Generated on Wed Jan 25 00:48:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.hpp

Go to the documentation of this file.
00001  /* ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009
00010 #if ! defined(UnifiedInbox_UibMsgDisplayTest_hpp)
00011 #define UnifiedInobx_UibMsgDisplayTest_hpp
00014
00015
00016 /*#if defined(_DEBUG)
00017     #define VERIFY(cond, text)  MmiVerification::Verfiy(cond, __FILE__, __LINE__, text);
00018 #endif
00019 */
00020
00021
00022 #include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
00023 #include <UnifiedInbox/UibServiceImpl.hpp>
00024 #include <MmiTest/TestChildProvider1.hpp>
00025 #include <MmiTest/TestChildProvider2.hpp>
00026 #include <Kernel/Condition.hpp>
00027
00028 class TestApp;
00029
00030 class UibMsgDisplayTest : public MmiUnitTest {
00031
00032     typedef MmiUnitTest Base;
00033
00034     public:
00035
00037         UibMsgDisplayTest();
00038
00039         UibMsgDisplayTest(MmiUnitTestSuite* suite, BOOLEAN proceed_on_failed = TRUE);
00040
00042         virtual ~UibMsgDisplayTest();
00043
00045         void Init(MmiUnitTestSuite* suite, BOOLEAN proceed_on_failed = TRUE);
00046
00048         const WCHAR* GetName() { return L"Message Presentation"; }
00049
00051         virtual TestResult Run();
00052
00053     protected:
00054
00055         void SetPreconditions();
00056
00057         virtual BOOLEAN OnMessage(const Message &msg);
00058
00059     private:
00060
00061         UibServiceImpl      m_service;
00062         TestChildProvider1  m_provider1;
00063         TestChildProvider2  m_provider2;
00064         BooleanCondition    m_cond;
00065
00066 };
00067
00068 #endif //#define Mmi_UibMsgDisplayTest_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Config/UibConfig.hpp>
#include <UnifiedInbox/UibApp.hpp>
#include <UnifiedInbox/UibMsgTypes.hpp>
#include "MmiTest/TestApp.hpp"
#include "UibNotifyTest.hpp"

Include dependency graph for UibNotifyTest.cpp:

Generated on Wed Jan 25 00:48:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.hpp File Reference

#include <Kernel/Timer.hpp>
#include <Kernel/Condition.hpp>
#include <GuiExtensions/ContextMenuAction.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
#include <MmiTest/TestChildProvider1.hpp>
#include <MmiTest/TestChildProvider2.hpp>
#include <AddOns/AuxExtensions/AppendProvider.hpp>

Include dependency graph for UibNotifyTest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibNotifyTest

Defines

#define | UibNotifyTest_hpp

Define Documentation

#define UibNotifyTest_hpp

Generated on Wed Jan 25 00:48:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if !defined(UibNotifyTest_hpp)
00011 #define UibNotifyTest_hpp
00012
00013 #include <Kernel/Timer.hpp>
00014 #include <Kernel/Condition.hpp>
00015
00016 #include <GuiExtensions/ContextMenuAction.hpp>
00017 #include <GuiExtensions/ActionAccessor.hpp>
00018
00019 #include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
00020 #include <MmiTest/TestChildProvider1.hpp>
00021 #include <MmiTest/TestChildProvider2.hpp>
00022 #include <AddOns/AuxExtensions/AppendProvider.hpp>
00023
00024 class UibNotifyTest : public MmiUnitTest {
00025     typedef MmiUnitTest Base;
00026
00027     public:
00029         UibNotifyTest() {};
00030
00032         virtual ~UibNotifyTest();
00033
00035         void Init(WCHAR* name, MmiUnitTestSuite* suite);
00036
00038         virtual TestResult Run();
00039
00040     protected:
00041
00042         void SetPreconditions();
00043
00044         virtual BOOLEAN OnMessage(const Message &msg);
00045
00046     private:
00047
00048         UibServiceImpl  m_uib_service;
00049
00050 //      BooleanCondition m_cond;
00051
00052         Provider*       m_prov1;
00053         Provider*       m_prov2;
00054         AppendProvider  m_append_prov;
00055 };
00056
00057 #endif /* UibInboxTest_hpp */
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Auxiliary/FindProvider.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <Config/Config.hpp>
#include <Config/UibConfig.hpp>
#include <GuiExtensions/AbstractActionAccessorPtr.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <UnifiedInbox/UibApp.hpp>
#include <MmiTest/TestApp.hpp>
#include "UibPerformanceTest.hpp"

Include dependency graph for UibPerformanceTest.cpp:

Variables

const INT c_max_allowed_time_for_uib_update = 1

Variable Documentation

const INT c_max_allowed_time_for_uib_update = 1

Generated on Wed Jan 25 00:48:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.hpp File Reference

#include <Auxiliary/QuickSortProvider.hpp>
#include <Kernel/Condition.hpp>
#include <AddOns/AuxExtensions/AppendProvider.hpp>
#include <GuiExtensions/ContextMenuAction.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <MmiTest/TestChildProvider1.hpp>
#include <MmiTest/TestChildProvider2.hpp>
#include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>

Include dependency graph for UibPerformanceTest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibPerformanceTest

Defines

#define | UibPerformanceTest_hpp

Define Documentation

#define UibPerformanceTest_hpp

Generated on Wed Jan 25 00:48:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if !defined(UibPerformanceTest_hpp)
00011 #define UibPerformanceTest_hpp
00012
00013 #include <Auxiliary/QuickSortProvider.hpp>
00014 #include <Kernel/Condition.hpp>
00015
00016 #include <AddOns/AuxExtensions/AppendProvider.hpp>
00017
00018 #include <GuiExtensions/ContextMenuAction.hpp>
00019 #include <GuiExtensions/MmiAlert.hpp>
00020
00021 #include <MmiTest/TestChildProvider1.hpp>
00022 #include <MmiTest/TestChildProvider2.hpp>
00023
00024 #include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
00025
00026 class UibPerformanceTest : public MmiUnitTest, public Observer {
00027     typedef MmiUnitTest Base;
00028     public:
00030         UibPerformanceTest() {};
00031
00033         virtual ~UibPerformanceTest();
00034
00036         void Init(WCHAR* name, MmiUnitTestSuite* suite);
00037
00039         virtual TestResult Run();
00040
00042         void TestUpdateTime(INT sort_colid);
00043
00045         void TestAddEntryPerf();
00046
00048         void TestDeleteEntryPerf(INT id);
00049
00051 //      void TestViewMsgPerf(INT id);
00052
00053     protected:
00055         BOOLEAN OnMessage(const Message &msg);
00056
00058         virtual void OnUpdate(ObservableObject* obs_obj);
00059
00060         const WCHAR* GetTextForMsgType(UibConfig::UibMessageTypes msg_type) const;
00061
00062     private:
00063         enum ContextActionTypes {
00064             CaView,
00065             CaAdd,
00066             CaDelete
00067         };
00068
00069         const WCHAR* GetSortKeyText(INT sort_colid);
00070
00071         void OnContextTriggerNotification(INT type, INT id, INT provider_id);
00072         void ViewMsg(Provider* prov, INT id);
00073         void AddEntry(Provider* prov);
00074         void DeleteEntry(Provider* prov, INT id);
00075
00076         QuickSortProvider m_sort_prov;
00077         AppendProvider m_append_prov;
00078         TestChildProvider1* m_prov1;
00079         TestChildProvider2* m_prov2;
00080
00081         ContextMenuAction   m_context_actions1[3];
00082         ContextMenuAction   m_context_actions2[3];
00083
00084         ActionAccessor      m_accessor1;
00085         ActionAccessor      m_accessor2;
00086
00087         BooleanCondition    m_cond;
00088         BOOLEAN             m_flag;
00089         BOOLEAN             m_testing;
00090
00091         Timer               m_timeout_timer;
00092         MmiAlert            m_alert;
00093 };
00094
00095 #endif /* UibPerformanceTest_hpp */
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Config/Config.hpp>
#include <Config/UibConfig.hpp>
#include <GuiExtensions/MmiInfoBox.hpp>
#include "UibSettingsTest.hpp"

Include dependency graph for UibSettingsTest.cpp:

Generated on Wed Jan 25 00:49:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.hpp File Reference

#include <UnifiedInbox/UibSettingsProvider.hpp>
#include <UnifiedInbox/UibSettingsWin.hpp>
#include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>

Include dependency graph for UibSettingsTest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibSettingsTest

Defines

#define | UibSettingsTest_hpp

Define Documentation

#define UibSettingsTest_hpp

Generated on Wed Jan 25 00:49:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if !defined(UibSettingsTest_hpp)
00011 #define UibSettingsTest_hpp
00012
00013 #include <UnifiedInbox/UibSettingsProvider.hpp>
00014 #include <UnifiedInbox/UibSettingsWin.hpp>
00015
00016 #include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
00017
00018 class UibSettingsTest : public MmiUnitTest {
00019     typedef MmiUnitTest Base;
00020     public:
00022         UibSettingsTest() {};
00023
00025         virtual ~UibSettingsTest();
00026
00028         void Init(WCHAR* name, MmiUnitTestSuite* suite);
00029
00031         virtual TestResult Run();
00032
00033         void TestSettingsProvider(const DataItem& sort_crit, const DataItem& sort_asc);
00034
00035         void TestSettingsDisplay();
00036         void TestPredefinedSettings();
00037         void TestSettingsModification(const DataItem& sort_crit, const DataItem& sort_asc);
00038
00039     private:
00040         const WCHAR* GetSortKeyText(UINT8 sort_crit);
00041
00042         UibSettingsProvider m_settings_provider;
00043         UibSettingsWin m_settings_win;
00044
00045 };
00046
00047 #endif /* UibSettingsTest_hpp */
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibSortingTest.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibSortingTest.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <Config/Config.hpp>
#include <GuiExtensions/MmiInfoBox.hpp>
#include <UnifiedInbox/UibApp.hpp>
#include "MmiTest/TestApp.hpp"
#include "UibSortingTest.hpp"

Include dependency graph for UibSortingTest.cpp:

Generated on Wed Jan 25 00:49:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibSortingTest.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibSortingTest.hpp File Reference

#include <AddOns/AuxExtensions/AppendProvider.hpp>
#include <UnifiedInbox/UibSettingsProvider.hpp>
#include <UnifiedInbox/UibServiceImpl.hpp>
#include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
#include <MmiTest/TestChildProvider1.hpp>
#include <MmiTest/TestChildProvider2.hpp>

Include dependency graph for UibSortingTest.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibSortingTest

Defines

#define | UibSortingTest_hpp

Define Documentation

#define UibSortingTest_hpp

Generated on Wed Jan 25 00:49:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibSortingTest.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibSortingTest.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if !defined(UibSortingTest_hpp)
00011 #define UibSortingTest_hpp
00012
00013 #include <AddOns/AuxExtensions/AppendProvider.hpp>
00014
00015 #include <UnifiedInbox/UibSettingsProvider.hpp>
00016 #include <UnifiedInbox/UibServiceImpl.hpp>
00017
00018 #include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
00019 #include <MmiTest/TestChildProvider1.hpp>
00020 #include <MmiTest/TestChildProvider2.hpp>
00021
00022 class UibSortingTest : public MmiUnitTest {
00023     typedef MmiUnitTest Base;
00024     public:
00026         UibSortingTest() {};
00027
00029         virtual ~UibSortingTest();
00030
00032         void Init(WCHAR* name, MmiUnitTestSuite* suite);
00033
00035         virtual TestResult Run();
00036
00037     private:
00038         void ChangeSorting(UINT8 sort_crit, BOOLEAN asc);
00039         void CheckProvider(Provider* prov);
00040         void UpdateSortedProvider(INT sort_colid, BOOLEAN asc);
00041
00042         Provider* m_prov1;
00043         Provider* m_prov2;
00044         QuickSortProvider m_ref_prov;
00045         AppendProvider m_append_prov;
00046
00047         UINT8   m_sort_key;
00048         BOOLEAN m_sort_asc;
00049
00050         UibServiceImpl m_service;
00051 };
00052
00053 #endif /* UibSortingTest_hpp */
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibTestControl.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibTestControl.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include <MmiTest/MmiUnitTest/MmiUnitTestSuite.hpp>
#include "UibTestControl.hpp"

Include dependency graph for UibTestControl.cpp:

Generated on Wed Jan 25 00:49:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibTestControl.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibTestControl.hpp File Reference

#include <MmiTest/MmiUnitTest/MmiUnitTestSuite.hpp>

Include dependency graph for UibTestControl.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define UnifiedInbox_UibTestControl_hpp

Define Documentation

#define UnifiedInbox_UibTestControl_hpp

Generated on Wed Jan 25 00:49:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibTestControl.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibTestControl.hpp

Go to the documentation of this file.
00001 /* =============================================================================
00002 ** Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 ** =============================================================================
00004 **
00005 ** =============================================================================
00006 **
00007 ** This document contains proprietary information belonging to COMNEON.
00008 ** Passing on and copying of this document, use and communication of its
00009 ** contents is not permitted without prior written authorisation.
00010 **
00011 ** =============================================================================
00012 */
00013
00014 #if ! defined(UnifideInbox_UibTestControl_hpp)
00015 #define UnifiedInbox_UibTestControl_hpp
00016
00017
00018 #include <MmiTest/MmiUnitTest/MmiUnitTestSuite.hpp>
00019
00020 //#include <MmiTest/UibUnitTests/UibDataTest.hpp>
00021
00022 /*
00023 static MmiUnitTestSuite     g_uib_tests;
00024 static TestUibData          g_test_uib_data;
00025 */
00026 # endif // _Mmi_UibTestControl_hpp
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibTests.cpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibTests.cpp File Reference

#include <UnifiedInbox/UibPreComp.hpp>
#include "UibTests.hpp"

Include dependency graph for UibTests.cpp:

Generated on Wed Jan 25 00:49:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibTests.hpp File Reference

Applications/UnifiedInbox/UibUnitTests/UibTests.hpp File Reference

#include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>

Include dependency graph for UibTests.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UibTest1
class | UibTest2

Generated on Wed Jan 25 00:49:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UnifiedInbox/UibUnitTests/UibTests.hpp Source File

Applications/UnifiedInbox/UibUnitTests/UibTests.hpp

Go to the documentation of this file.
00001 // /*   ------------------------------------------------------------------------
00002 //  Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003 //  ------------------------------------------------------------------------
00004 //  This document contains proprietary information belonging to COMNEON.
00005 //  Passing on and copying of this document, use and communication of its
00006 //  contents is not permitted without prior written authorisation.
00007 //  ------------------------------------------------------------------------ */
00008 //
00009
00010 #if defined (_MSC_VER) && (_MSC_VER >= 1000)
00011 #pragma once
00012 #endif
00013 #ifndef _INC_UIBTEST1_3FC1F1BC023A_INCLUDED
00014 #define _INC_UIBTEST1_3FC1F1BC023A_INCLUDED
00015
00016 #include <MmiTest/MmiUnitTest/MmiUnitTest.hpp>
00017
00018 class UibTest1 : public MmiUnitTest {
00019     typedef MmiUnitTest Base;
00020     public:
00022         UibTest1() {};
00023
00025         virtual ~UibTest1();
00026
00028         void Init(WCHAR* name, MmiUnitTestSuite* suite);
00029
00031         virtual TestResult Run();
00032
00033 };
00034
00035 class UibTest2 : public MmiUnitTest {
00036     typedef MmiUnitTest Base;
00037     public:
00039         UibTest2() {};
00040
00042         virtual ~UibTest2();
00043
00045         void Init(WCHAR* name, MmiUnitTestSuite* suite);
00046
00048         virtual TestResult Run();
00049
00050 };
00051
00052
00053 #endif /* _INC_UIBTEST1_3FC1F1BC023A_INCLUDED */
Generated on Tue Jan 24 14:52:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbApp.cpp File Reference

Applications/UsbApp/UsbApp.cpp File Reference

#include "UsbAppPreComp.hpp"
#include <Devices/Messages/TransportNotificationMsg.hpp>
#include <Devices/AbstractTransport.hpp>
#include <Kernel/VersionInfo.hpp>
#include <AddOns/Usb/UsbSubSystem.hpp>
#include <AddOns/Usb/UsbTransport.hpp>
#include <AddOns/Usb/UsbMsgTypes.hpp>
#include <Common/MmiAlert.hpp>
#include "UsbApp.hpp"

Include dependency graph for UsbApp.cpp:

Functions

ApoxiUseVersionInfo (UsbApp)

Function Documentation

ApoxiUseVersionInfo ( UsbApp )

Generated on Wed Jan 25 00:50:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbApp.hpp File Reference

Applications/UsbApp/UsbApp.hpp File Reference

#include <Common/MmiApplication.hpp>
#include <AddOns/Usb/UsbTransport.hpp>

Include dependency graph for UsbApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | UsbApp

Defines

#define | Mmi_UsbApp_hpp

Define Documentation

#define Mmi_UsbApp_hpp

Generated on Wed Jan 25 00:50:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbApp.hpp Source File

Applications/UsbApp/UsbApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_UsbApp_hpp)
00009 #define Mmi_UsbApp_hpp
00012
00013 #include <Common/MmiApplication.hpp>
00014 #include <AddOns/Usb/UsbTransport.hpp>
00015
00017
00018 class UsbApp : public MmiApplication {
00019     typedef MmiApplication Base;
00020
00021     public:
00022         static UsbApp* GetInstance();
00023
00024         void Init();
00026         virtual ~UsbApp();
00027
00028
00029     protected:
00030
00031         virtual BOOLEAN OnMessage(const Message &msg);
00032
00033         virtual void OnOpen();
00034
00035     private:
00036
00037         static UsbApp m_usb_app;
00038         Property m_usb_connection;
00040         UsbApp();
00042         void HandleUsbNotification(UsbTransport::UsbConnectionInfo &con_info);
00044         void DisplayAlert(WString &message);
00045
00046 };
00048 #endif  // Mmi_UsbApp_hpp
00049
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbAppPreComp.cpp File Reference

Applications/UsbApp/UsbAppPreComp.cpp File Reference

#include "UsbAppPreComp.hpp"

Include dependency graph for UsbAppPreComp.cpp:

Generated on Wed Jan 25 00:50:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbAppPreComp.hpp File Reference

Applications/UsbApp/UsbAppPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Asc/Lib.hpp>
#include <Common/CommonMsgTypes.hpp>

Include dependency graph for UsbAppPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Generated on Wed Jan 25 00:50:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbAppPreComp.hpp Source File

Applications/UsbApp/UsbAppPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #include <Kernel/Lib.hpp>
00010 #include <Gui/Lib.hpp>
00011 #include <Auxiliary/Lib.hpp>
00012 #include <Apc/Lib.hpp>
00013 #include <Adc/Lib.hpp>
00014 #include <Asc/Lib.hpp>
00015
00016 #include <Common/CommonMsgTypes.hpp>
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbVersion.cpp File Reference

Applications/UsbApp/UsbVersion.cpp File Reference

#include "UsbAppPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <UsbVersion.hpp>

Include dependency graph for UsbVersion.cpp:

Functions

ApoxiDefVersionInfo (UsbApp, USBVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | UsbApp | ,
 |  | USBVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbVersion.hpp File Reference

Applications/UsbApp/UsbVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | USBVERSION "2.10.0_TIV_04"
#define | UsbVersion_hpp

Define Documentation

#define USBVERSION "2.10.0_TIV_04"

#define UsbVersion_hpp

Generated on Wed Jan 25 00:51:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/UsbApp/UsbVersion.hpp Source File

Applications/UsbApp/UsbVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(UsbVersion_hpp)
00010 #define UsbVersion_hpp
00011
00012
00013 /*
00014 UsbVersion.hpp contains the official Usb Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018
00019 #define USBVERSION "2.10.0_TIV_04"
00020
00021 #endif  // UsbVersion_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoApp.cpp File Reference

Applications/VoiceMemo/VoiceMemoApp.cpp File Reference

#include "VoiceMemoPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp>
#include <Audio/Messages/AudioMessages.hpp>
#include <Audio/Messages/AudioErrorMsg.hpp>
#include "VoiceMemoApp.hpp"
#include "Mmi/Call/CallMsgTypes.hpp"

Include dependency graph for VoiceMemoApp.cpp:

Functions

ApoxiUseVersionInfo (VoiceMemo)

Function Documentation

ApoxiUseVersionInfo ( VoiceMemo )

Generated on Wed Jan 25 00:51:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoApp.hpp File Reference

Applications/VoiceMemo/VoiceMemoApp.hpp File Reference

#include <AddOns/Services/ServiceBroker.hpp>
#include <Common/MmiServices.hpp>
#include <Common/MmiApplication.hpp>
#include <Common/CommonMsgTypes.hpp>
#include <Audio/Messages/AudioStoppedMsg.hpp>
#include <VoiceMemo/VoiceMemoRecordWin.hpp>

Include dependency graph for VoiceMemoApp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VoiceMemoApp

Defines

#define | Mmi_VoiceMemoApp_hpp

Define Documentation

#define Mmi_VoiceMemoApp_hpp

Generated on Wed Jan 25 00:51:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoApp.hpp Source File

Applications/VoiceMemo/VoiceMemoApp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_VoiceMemoApp_hpp)
00009 #define Mmi_VoiceMemoApp_hpp
00012 #include <AddOns/Services/ServiceBroker.hpp>
00013
00014 #include <Common/MmiServices.hpp>
00015 #include <Common/MmiApplication.hpp>
00016 #include <Common/CommonMsgTypes.hpp>
00017 #include <Audio/Messages/AudioStoppedMsg.hpp>
00018 #include <VoiceMemo/VoiceMemoRecordWin.hpp>
00019
00021 class VoiceMemoApp : public MmiApplication,
00022                      public VoiceMemoService {
00023     typedef MmiApplication Base;
00024
00025     public:
00026         static VoiceMemoApp *GetInstance();
00027
00029         virtual ~VoiceMemoApp();
00030
00032         virtual ServiceResult StartRecording(SharedPtr<AudioActiveReference> &voicememo_ref);
00033
00035         virtual ServiceResult StopRecording();
00036
00038         virtual ServiceResult PauseRecording();
00039
00041         virtual ServiceResult ResumeRecording();
00042         void OnErrorNotification(const SharedPtr<AudioActiveReference>&);
00043
00044     protected:
00046         virtual void OnOpen();
00048         virtual void OnClose();
00050         virtual BOOLEAN OnMessage(const Message &msg);
00052         virtual void OnStartup();
00054         virtual BOOLEAN OnFeatureTriggered (const FeatureID& feature_id);
00055
00056     private:
00057         static  VoiceMemoApp                m_voicememo_app;
00058         //VoiceMemoWin                      m_voicememo_win;
00059         VoiceMemoRecordWin                  m_voicememo_record_win;
00060 //      MenuAction                          m_voicememo_action;
00061
00062
00063         enum FeatureItemIds{
00064             VmVoiceMemo,
00065             VmRecordvm,
00066             VmStopRecordvm,
00067             VmFeatureCnt
00068         };
00069
00070         Feature m_items[VmFeatureCnt];
00071
00073         VoiceMemoApp();
00074 };
00076 #endif  // Mmi_VoiceMemoApp_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoMenuAccessor.cpp File Reference

Applications/VoiceMemo/VoiceMemoMenuAccessor.cpp File Reference

#include "VoiceMemoPreComp.hpp"
#include "VoiceMemoMenuAccessor.hpp"

Include dependency graph for VoiceMemoMenuAccessor.cpp:

Generated on Wed Jan 25 00:51:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoMenuAccessor.hpp File Reference

Applications/VoiceMemo/VoiceMemoMenuAccessor.hpp File Reference

#include <GuiExtensions/MmiAlert.hpp>
#include <GuiExtensions/AbstractMmiMenuAccessor.hpp>

Include dependency graph for VoiceMemoMenuAccessor.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VoiceMemoMenuAccessor

Defines

#define | Mmi_VoiceMemoMenuAccessor_hpp

Define Documentation

#define Mmi_VoiceMemoMenuAccessor_hpp

Generated on Wed Jan 25 00:51:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoMenuAccessor.hpp Source File

Applications/VoiceMemo/VoiceMemoMenuAccessor.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_VoiceMemoMenuAccessor_hpp)
00009 #define Mmi_VoiceMemoMenuAccessor_hpp
00012
00013 #include <GuiExtensions/MmiAlert.hpp>
00014 #include <GuiExtensions/AbstractMmiMenuAccessor.hpp>
00015
00017 class VoiceMemoMenuAccessor : public AbstractMmiMenuAccessor {
00018     typedef AbstractMmiMenuAccessor Base;
00019
00020     public:
00022         VoiceMemoMenuAccessor();
00023
00025         virtual ~VoiceMemoMenuAccessor();
00026
00028         void Init();
00029
00031         virtual BOOLEAN First();
00032
00034         virtual BOOLEAN Next();
00035
00037         virtual const WCHAR* GetItemText(BOOLEAN highlighted);
00038
00040         virtual const WCHAR* GetHiglightedText();
00041
00042     private:
00043         FfsFileId               m_id;
00044 };
00045
00047 #endif  // Mmi_VoiceMemoMenuAccessor_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoPreComp.cpp File Reference

Applications/VoiceMemo/VoiceMemoPreComp.cpp File Reference

#include "VoiceMemoPreComp.hpp"

Include dependency graph for VoiceMemoPreComp.cpp:

Generated on Wed Jan 25 00:52:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoPreComp.hpp File Reference

Applications/VoiceMemo/VoiceMemoPreComp.hpp File Reference

#include <Kernel/Lib.hpp>
#include <Gui/Lib.hpp>
#include <Auxiliary/Lib.hpp>
#include <Adc/Lib.hpp>
#include <Afs/Ffs/FfsTypes.hpp>
#include <Afs/Ffs/FfsHandler.hpp>
#include <Afs/Ffs/FlsFile.hpp>
#include <Asc/Lib.hpp>
#include <Apc/Lib.hpp>
#include <Auxiliary/SharedPtr.hpp>
#include <Auxiliary/WStrUtil.hpp>
#include <Devices/AudioDeviceManager.hpp>
#include <Devices/VoiceMemoAudioReference.hpp>
#include <Devices/AudioActiveReference.hpp>

Include dependency graph for VoiceMemoPreComp.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define Mmi_VoiceMemoPreComp_hpp

Define Documentation

#define Mmi_VoiceMemoPreComp_hpp

Generated on Wed Jan 25 00:52:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoPreComp.hpp Source File

Applications/VoiceMemo/VoiceMemoPreComp.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(Mmi_VoiceMemoPreComp_hpp)
00010 #define Mmi_VoiceMemoPreComp_hpp
00014 #include <Kernel/Lib.hpp>
00015 #include <Gui/Lib.hpp>
00016 #include <Auxiliary/Lib.hpp>
00017 #include <Adc/Lib.hpp>
00018 #include <Afs/Ffs/FfsTypes.hpp>
00019 #include <Afs/Ffs/FfsHandler.hpp>
00020 #include <Afs/Ffs/FlsFile.hpp>
00021 #include <Asc/Lib.hpp>
00022 #include <Apc/Lib.hpp>
00023 #include <Auxiliary/SharedPtr.hpp>
00024 #include <Auxiliary/WStrUtil.hpp>
00025 #include <Devices/AudioDeviceManager.hpp>
00026 #include <Devices/VoiceMemoAudioReference.hpp>
00027 #include <Devices/AudioActiveReference.hpp>
00028
00030
00031 #endif// Mmi_VoiceMemoPreComp_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoRecordWin.cpp File Reference

Applications/VoiceMemo/VoiceMemoRecordWin.cpp File Reference

#include "VoiceMemoPreComp.hpp"
#include "VoiceMemoRecordWin.hpp"
#include <GuiExtensions/MmiInfoBox.hpp>
#include "Mmi/Call/CallMsgTypes.hpp"
#include <Config/FileBrowserConfig.hpp>
#include "VoiceMemoApp.hpp"

Include dependency graph for VoiceMemoRecordWin.cpp:

Variables

const CHAR c_filebrowser_for_voicememo [] = { "/ffs/user_data/Sounds/" }

Variable Documentation

const CHAR c_filebrowser_for_voicememo[] = { "/ffs/user_data/Sounds/" }

Generated on Wed Jan 25 00:52:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoRecordWin.hpp File Reference

Applications/VoiceMemo/VoiceMemoRecordWin.hpp File Reference

#include <Auxiliary/WStrUtil.hpp>
#include <Auxiliary/DrmInfo.hpp>
#include <AddOns/Services/ServiceBroker.hpp>
#include <AddOns/Services/Service.hpp>
#include <Common/MmiServices.hpp>
#include <GuiExtensions/MmiWindow.hpp>
#include <GuiExtensions/MmiAlert.hpp>
#include <Devices/VoiceMemoAudioPlayer.hpp>
#include <Devices/VoiceMemoAudioReference.hpp>

Include dependency graph for VoiceMemoRecordWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VoiceMemoRecordWin

Defines

#define | Mmi_VoiceMemoRecordWin_hpp

Define Documentation

#define Mmi_VoiceMemoRecordWin_hpp

Generated on Wed Jan 25 00:52:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoRecordWin.hpp Source File

Applications/VoiceMemo/VoiceMemoRecordWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_VoiceMemoRecordWin_hpp)
00009 #define Mmi_VoiceMemoRecordWin_hpp
00012
00013 #include <Auxiliary/WStrUtil.hpp>
00014 #include <Auxiliary/DrmInfo.hpp>
00015 #include <AddOns/Services/ServiceBroker.hpp>
00016 #include <AddOns/Services/Service.hpp>
00017
00018 #include <Common/MmiServices.hpp>
00019 #include <GuiExtensions/MmiWindow.hpp>
00020 #include <GuiExtensions/MmiAlert.hpp>
00021 #include <Devices/VoiceMemoAudioPlayer.hpp>
00022 #include <Devices/VoiceMemoAudioReference.hpp>
00023
00024 class VoiceMemoRecordWin : public MmiWindow {
00025     typedef MmiWindow Base;
00026
00027     public:
00029         VoiceMemoRecordWin();
00031         ~VoiceMemoRecordWin();
00033         void Init();
00035         SharedPtr<AudioActiveReference> Record(
00036                                     VoiceMemoAudioReference::Mode mode);
00038         BOOLEAN StopRecord(VoiceMemoAudioReference::Mode mode);
00040         BOOLEAN PauseRecord();
00042         BOOLEAN ResumeRecord();
00043
00044         SharedPtr<AudioActiveReference>& GetAudioRef() { return m_audio_ref; }
00045
00046     private:
00047         TextBox     m_time_elapsed;
00048         Timer       m_timer;
00049         TextBox     m_file;
00050         TextBox     m_filename;
00051         //TextBox       m_used_space;
00052
00053
00054         UINT32      m_counter;
00055
00056         SharedPtr<AudioActiveReference>     m_audio_ref;
00057         SharedPtr<StreamAudioReference>     m_voicememo_ref;
00058         VoiceMemoAudioPlayer*               m_voicememo_player;
00059         WString                             m_user_file_name;
00060
00061         void ShowAlert(const WString& str);
00062
00063     protected:
00064         virtual void OnLayoutClient();
00065         virtual void OnClose();
00066         virtual BOOLEAN  OnTimeout(const Timer& timer);
00067 };
00068
00070 #endif  // Mmi_VoiceMemoRecordWin_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoVersion.cpp File Reference

Applications/VoiceMemo/VoiceMemoVersion.cpp File Reference

#include "VoiceMemoPreComp.hpp"
#include <Kernel/VersionInfo.hpp>
#include <VoiceMemoVersion.hpp>

Include dependency graph for VoiceMemoVersion.cpp:

Functions

ApoxiDefVersionInfo (VoiceMemo, VOICEVERSION, VersionInfo::c_flag_add_to_trace_info)

Function Documentation

ApoxiDefVersionInfo | ( | VoiceMemo | ,
 |  | VOICEVERSION | ,
 |  | VersionInfo::c_flag_add_to_trace_info |
 | ) |

Generated on Wed Jan 25 00:53:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoVersion.hpp File Reference

Applications/VoiceMemo/VoiceMemoVersion.hpp File Reference

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | VOICEVERSION "2.10.0_TIV_04"
#define | VoiceVersion_hpp

Define Documentation

#define VOICEVERSION "2.10.0_TIV_04"

#define VoiceVersion_hpp

Generated on Wed Jan 25 00:53:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoVersion.hpp Source File

Applications/VoiceMemo/VoiceMemoVersion.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) COMNEON Software GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008
00009 #if !defined(VoiceVersion_hpp)
00010 #define VoiceVersion_hpp
00011
00012
00013 /*
00014 VoiceVersion.hpp contains the official Uib Version which should be used in the
00015 different <Module>Version.cpp files as long as those Modules are not versioned and
00016 released separately
00017 */
00018 #define VOICEVERSION "2.10.0_TIV_04"
00019 #endif  // VoiceVersion_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoWin.cpp File Reference

Applications/VoiceMemo/VoiceMemoWin.cpp File Reference

#include "VoiceMemoPreComp.hpp"
#include "VoiceMemoWin.hpp"

Include dependency graph for VoiceMemoWin.cpp:

Generated on Wed Jan 25 00:53:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoWin.hpp File Reference

Applications/VoiceMemo/VoiceMemoWin.hpp File Reference

#include <GuiExtensions/MmiMenuWindow.hpp>
#include <GuiExtensions/ActionAccessor.hpp>
#include <VoiceMemo/VoiceMemoMenuAccessor.hpp>
#include <VoiceMemo/VoiceMemoRecordWin.hpp>

Include dependency graph for VoiceMemoWin.hpp:

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

class | VoiceMemoWin

Defines

#define | Mmi_VoiceMemoWin_hpp

Define Documentation

#define Mmi_VoiceMemoWin_hpp

Generated on Wed Jan 25 00:53:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Applications/VoiceMemo/VoiceMemoWin.hpp Source File

Applications/VoiceMemo/VoiceMemoWin.hpp

Go to the documentation of this file.
00001 /*  ------------------------------------------------------------------------
00002     Copyright (C) 2000 COMNEON GmbH & Co. OHG. All rights reserved.
00003     ------------------------------------------------------------------------
00004     This document contains proprietary information belonging to COMNEON.
00005     Passing on and copying of this document, use and communication of its
00006     contents is not permitted without prior written authorisation.
00007     ------------------------------------------------------------------------ */
00008 #if !defined(Mmi_VoiceMemoWin_hpp)
00009 #define Mmi_VoiceMemoWin_hpp
00012
00013 #include <GuiExtensions/MmiMenuWindow.hpp>
00014 #include <GuiExtensions/ActionAccessor.hpp>
00015
00016 #include <VoiceMemo/VoiceMemoMenuAccessor.hpp>
00017 #include <VoiceMemo/VoiceMemoRecordWin.hpp>
00018
00020 class VoiceMemoWin : public MmiMenuWindow {
00021     typedef MmiMenuWindow Base;
00022
00023     public:
00025         VoiceMemoWin();
00027         virtual ~VoiceMemoWin();
00029         void Init();
00031         SharedPtr<AudioActiveReference> Record();
00033         BOOLEAN StopRecord();
00035         BOOLEAN PauseRecord();
00037         BOOLEAN ResumeRecord();
00038
00039     protected:
00041         virtual void OnActionExecuted(Action *action);
00042
00043     private:
00044         VoiceMemoMenuAccessor               m_accessor;
00045         Action                              m_new;
00046         Action                              m_close;
00047         VoiceMemoRecordWin                  m_record_win;
00048 };
00049
00051 #endif  // Mmi_VoiceMemoWin_hpp
Generated on Tue Jan 24 14:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Structures

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

APOXI Data Structures

Here are the data structures with brief descriptions:
_ApplicationTracer |
_FunctionTracer< mask > |
_JUMP_BUFFER |
_NullApplicationTracer |
_NullFunctionTracer |
AbortResArg |
AbortResMsg |
AbstractActionMenuAccessor |
AbstractAppContext |
AbstractButton |
AbstractDelegationProvider |
AbstractDevice |
AbstractDevice::ControlArg |
AbstractEditBox | Obsolete - use MultiLineEditor or LineEditor from Gui instead
AbstractEditBoxModel | Describes the model of an editbox
AbstractEditBoxView | Describes the view of an editbox
AbstractEditor | Abstract base class for all editors
AbstractEditorItem |
AbstractExternalData |
AbstractGrid | Simple grid functionality for arranging items on the screen in rows and columns
AbstractGrid::SmoothScrollInfo |
AbstractIMelodyParser |
AbstractItemContainer |
AbstractItemGrid |
AbstractItemRenderer |
AbstractLineEditor |
AbstractLineEditorView |
AbstractListBox |
AbstractListBox::SmoothScrollInfo |
AbstractListBoxModel | Obsolete, as the class AbstractListBox has been replaced by the class ItemGrid
AbstractListBoxView |
AbstractLockableDevice | Abstract base class for all hardware devices
AbstractMenuAccessor |
AbstractMenuList | Is an abstract listbox, which is the base for MenuList, CheckBoxList, RadioButtonList, ..
AbstractMenuListModel< Item > |
AbstractMessageMapContainer |
AbstractMultiLineEditor | Abstract base class for all multiline editors
AbstractMultiLineEditorView | View which shows the content of a multiline editor
AbstractPredictiveInputBox |
AbstractRenderer |
AbstractScheduler |
AbstractSmsApp |
AbstractSmsComposeWin |
AbstractSmsUtilityProcessor |
AbstractSmsViewerWin |
AbstractStackMsgArgMapContainer |
AbstractTextObject |
AbstractTextRenderer |
AbstractToggleAction |
AbstractTransport | Abstract representation of communication hardware
AcacLanguage |
AccDispatcher |
AccessorAction |
AccessorActionExtension |
Accessory |
AccessoryIndArg |
AccessoryIndMsg |
AccHandler |
AckNackCnt |
AckNackParamList |
AckNackTestparamCnt |
Acm |
Action |
ActionExecutedMsg |
ActionExtension |
ActionMenuAccessor |
ActiveWaitDispatcher |
AddAllToFdnAction |
AddEntryToFdnAction |
AddInfo |
AddNumberToFdnAction |
AdvPbAction |
AdvPbApp |
AdvPbWin |
AesCrypt |
AidingData |
AlarmManager |
AlarmMsg |
AlarmNotificationMsg |
Alert |
Allocator< T > |
AlphaCoding |
AmplifierAudioDevice |
AmrSound | Class to handle and decode MIDI sounds
AnimatedTextLine |
AnimatedTextLineView |
Animation | Obsolete - use class ImageBox from GUI instead
AnimationBmpArrayIterator |
AnimationBmpIterator |
AnimationBmpPointerArrayIterator |
AnimationModel | Describes the model of an animated bitmap
AnimationView | Describes the view of an animated bitmap
AocChargeData |
AocChargingStatusMsg |
AocDispatcher |
AocHandler |
AocIndArg |
apoxi_emcpp_OBEXAdapter |
ApoxiCommandAction |
ApoxiThread |
AppActionExecutedMsg |
AppCloseMsg |
AppContainer |
AppContainerRoutingTableEntry |
AppContext |
AppendProvider |
AppFeatureID |
AppGetFocusMsg |
Application |
ApplicationAction |
ApplicationListEntry |
AppLoseFocusMsg |
AppMutex |
AppOpenMsg |
AppRoutingTableEntry |
AppUpdateDisplayMsg |
ArabicTextRenderer |
AragonMsg |
ArgumentDestroyEntry |
ArgumentDestroyEntryCompare |
AsTestparamDatabase |
AsyncUnitTestMsg |
AtAccessoryNotificationIndArg |
AtAccessoryRegisterCnfArg |
AtAccessoryRegisterReqArg |
AtAlphaTagCnfArg |
AtAlphaTagReqArg |
AtcDispatcher |
AtcHandler |
AtCommand |
AtCommandData |
AtCommandInfoTable |
AtCommandMetaInfo |
AtGenericCmdIndArg |
AtGenericCmdReqArg |
AtGenericCmdType |
AtiAudioCapturerEncoder |
AtiAudioDecoderRenderer |
AtiAudioPlayerRtStreamingConn |
AtiAudioPlayerRtStreamingSink |
AtiCodecsLib |
AtiMpeg4Decoder |
AtiMpeg4Encoder |
AtKeyParser |
AtlApplication | Baseclass for a ReferenceMmi Application
AtlApplicationPlugin |
AtlApplicationPluginStartup |
AtlApplicationPluginStartup::Table |
AtlConfig |
AtlItemBox |
AtlItemGrid |
AtlItemGridWindow |
AtlItemListWindow |
AtlItemMenu |
AtlItemMenuWindow |
AtlItemRenderer |
AtlLabelListWindow |
AtlWindow |
AtomItem |
AtPbInfoIndArg |
AtPbListCnfArg |
AtPbListReqArg |
AtPbSelectCnfArg |
AtPbSelectReqArg |
AtResponse |
AtResponseInfoTable |
AtResponseIterator |
AtResponseMetaInfo | Structure to hold responses and their string representation
AtResponseParameter |
AttachAllowedIndArg |
AttachCnfArg |
AttachRejArg |
AttachReqArg |
Audio |
Audio::SingleTone |
Audio::SingleTone |
Audio::SingleTone |
Audio::SingleTone |
Audio::SingleTone |
Audio::ToneData |
Audio::ToneData |
Audio::ToneData |
Audio::ToneData |
Audio::ToneData |
AudioAccessoryConnectedMsg |
AudioAccessoryDetails |
AudioAccessoryStore |
AudioActiveReference |
AudioCapturerEncoder |
AudioContext |
AudioDecoder |
AudioDecoderRenderer |
AudioDeviceBase |
AudioDeviceManager |
AudioDeviceStatusMsg |
AudioEncoder |
AudioError |
AudioErrorMsg |
AudioFastForwardStartedMsg |
AudioFmRadioRdsAlternativeFrequenciesMsg |
AudioFmRadioRdsInfoMsg |
AudioFmRadioRdsRadioTextMsg |
AudioFmRadioRdsRawDataMsg |
AudioFmRadioRdsStationNameMsg |
AudioFmRadioRssiMsg |
AudioFmRadioSeekMsg |
AudioGatiServer |
AudioGetPlayPositionMsg |
AudioItem |
AudioMapiManager |
AudioMapiManager::MapiCommandType |
AudioMapiManager::RequestOutcomeType | Return type for IFX_MAPI()
AudioMsg |
AudioPath |
AudioPathManager |
AudioPlayer |
AudioPlayerEvent |
AudioPlayerStore |
AudioPlayerStore::DataFormatDataSource |
AudioPlayTimeMsg |
AudioPreset |
AudioPresetStore |
AudioRadioDeviceNotificationMsg |
AudioRecordingStoppedMsg |
AudioReference |
AudioReference::TotalPlayTimeContainer | Total play time container
AudioRestartedMsg |
AudioResumedMsg |
AudioRewindStartedMsg |
AudioStartedMsg |
AudioStoppedMsg |
AudioStreamingSyncMsg |
AudioSuspendedMsg |
AudioTone |
AudioToneDuration |
AudioUserDefinedMsg |
AudioUtility |
AudioVibratorDevice |
AudioVoiceMemoOutOfSpaceMsg |
AuthProvider |
AutoCallRestrictIndArg |
AuxProvider |
BackLight | Back light device
BackToIdleFeature | Platform feature "BackToIdleScreen"
BackupFileHandler | RegBackUp FileHandler
BandSelectionIndArg |
BandSelectionMsg |
BandSelectionReqArg |
BandStatusMsg |
BarringInfoReceivedArg | Contains data of the indication of received CallBarringInfo
BarringInfoReceivedMsg |
BarringSsAction |
Base64Coder |
BaseDataHandler |
BaseInformationElement |
BasicPackConnector |
BasicPbWin |
BasicSmsService |
BatteryLoadLevelMsg |
BcdPlmn |
BdnIndArg |
BdnReqArg |
BidiManager |
BidiManager::ParagraphContext |
BigEndian16Bit | Represents a 16 bit integer in big endian format
BigEndian32Bit | Represents a 32 bit integer in big endian format
BinData |
BinDataDataSource |
BinDataInReadStatusInfo |
BitField< T > |
Bitmap |
BitmapDc | Device-context for a Bitmap
BitmapRes |
BitVector< N > |
BlackAndWhiteTheme | Obsolete theme - replaced by themes in Apoxi/GlobalThemes
BlerTrchInfo |
BlerTrchInfoList |
BlobObject |
BlobPtr |
BlockData |
BlueSkyCheckBoxListView |
BlueSkyCheckBoxView |
BlueSkyChineseTheme | Obsolete theme - replaced by themes in Apoxi/GlobalThemes
BlueSkyControlFrameView |
BlueSkyPositionIndicatorView |
BlueSkyProgressBarView |
BlueSkyPushButtonView |
BlueSkyRadioButtonListView |
BlueSkyRadioButtonView |
BlueSkySoftkeyBarView |
BlueSkyTextListView |
BlueSkyTheme | Obsolete theme - replaced by themes in Apoxi/GlobalThemes
BlueSkyWindowFrameView |
BmpImage |
BooleanCondition |
BootControl |
BootDispatcher |
BootDispatchingArg |
BootHandler |
BootState |
BoundedItem |
BrowserRegisterReqArg |
BrowserSaveWin |
BrowserTermEventArg |
BrowserView |
BrowserViewContainer |
Brush |
BtActiveDeviceWindow |
BtAlertMessageWindow |
BtApplication |
BtApplicationDevicePairRequest |
BtApplicationDeviceSearchRequest |
BtApplicationDeviceTrustRequest |
BtApplicationDeviceUnpairRequest |
BtApplicationDeviceUntrustRequest |
BtApplicationMessage |
BtApplicationQuerySupportedProfilesRequest |
BtApplicationRespondAuthorizationRequest |
BtApplicationSendPasskeyRequest |
BtApplicationServiceVerifyRequest |
BtApplicationSetRemoteDeviceNameRequest |
BtAttributeId |
BtAudioAccessoryService |
BtAuthorizationRequiredMessage |
BtAuthorizationRequiredWindow |
BtAvrcpAlertMessageWindow |
BtAvrcpCommandInterface |
BtAvrcpConnectResponse |
BtAvrcpControllerApplicationWindow |
BtAvrcpControllerDeviceListItem |
BtAvrcpControllerDeviceListWindow |
BtAvrcpDeRegisterRequest |
BtAvrcpDeviceListWin |
BtAvrcpMessageArgumentsDestroyTableNode |
BtAvrcpNmaConnect |
BtAvrcpNmaDisconnect |
BtAvrcpNmaPanelPassThrough |
BtAvrcpNmaRawFrame |
BtAvrcpNotificationMessage |
BtAvrcpOperationRequestResponse |
BtAvrcpOperationService |
BtAvrcpOperationServiceMessage |
BtAvrcpPanelApplication |
BtAvrcpPanelPassThroughParams |
BtAvrcpPanelPassThroughRequest |
BtAvrcpPanelService |
BtAvrcpPanelServiceImpl |
BtAvrcpProfileOperationService |
BtAvrcpProfileRegistrationService |
BtAvrcpRawFrameParams |
BtAvrcpRawFrameRequest |
BtAvrcpRegisterParams |
BtAvrcpRegisterRequest |
BtAvrcpRegistrationService |
BtAvrcpRequest |
BtAvrcpRequestStateChangedMessage |
BtAvrcpService |
BtAvrcpSubunitInfoEntry |
BtAvrcpSubunitInfoParams |
BtAvrcpSubunitInfoRequest |
BtAvrcpUnitInfoParams |
BtAvrcpUnitInfoRequest |
BtBipAbortIndArg | Abort Indication
BtBipAttachment | An attachment
BtBipAttachmentDesc | Attachment descriptor
BtBipAttachmentFormat | Format of an attachment
BtBipClientService |
BtBipConnectIndArg | Connect Indication
BtBipDeleteImageIndArg | Delete Image Request Indication
BtBipDisconnectIndArg | Disconnect Indication
BtBipGetImageInd | Get Image Request Indication
BtBipGetImageIndArg | Get Image Request Indication
BtBipGetImagePropertiesInd | Get Image Properties Request Indication
BtBipGetImagePropertiesIndArg | Get Images List Request Indication
BtBipGetImagesListInd | Get Images List Request Indication
BtBipGetImagesListIndArg | Get Images List Request Indication
BtBipGetImagingCapabilitesIndArg | Get Imaging Capabilities Request Indication
BtBipGetImagingCapabilitiesIndArg | Get Imaging Capabilities Request Indication
BtBipGetLinkedAttachmentInd | Get Linked Attachment Request Indication
BtBipGetLinkedAttachmentIndArg | Get Images List Request Indication
BtBipGetLinkedThumbnailInd | Get Linked Thumbnail Image Request Indication
BtBipGetLinkedThumbnailIndArg | Get Images List Request Indication
BtBipImage | An image
BtBipImageDesc | Image Desc
BtBipImageFormat | Image format
BtBipImageFormat::ImageDim |
BtBipImageHdl |
BtBipImageHdlDesc | Image Handle Desc
BtBipImageList | List of images
BtBipImageProperties | Image properties
BtBipImagingCapabilities | Imaging Capabilities
BtBipMsgArg | Base class for all notification arguments of Bt BIP profile
BtBipOpFinishedArg | Get Images List Request Indication
BtBipProgressMsg |
BtBipPutImageCompleteArg | Put Image Complete
BtBipPutImageIndArg | Put Image Request Indication
BtBipPutLinkedAttachmentCompleteArg | Put Image Complete
BtBipPutLinkedAttachmentInd | Put Linked Attachment Request Indication
BtBipPutLinkedAttachmentIndArg | Put Image Request Indication
BtBipPutLinkedThumbnailCompleteArg | Put Image Complete
BtBipPutLinkedThumbnailIndArg | Put Linked Thumbnail Request Indication
BtBipServerNotificationMsgArg |
BtBipServerService | BIP Server Service (imaging responder)
BtBppClientService |
BtBppController |
BtBppReq |
BtBppRequestStateChangedMessage |
BtBppServerService |
BtBppService | Base class for BIP service classes
BtBppSndAbortReqRequest |
BtBppSndFilePushReqRequest |
BtBppSndGetRefObjRspRequest |
BtCancelableBroadcastRequest |
BtCancelableMulticastRequest |
BtCancelableRequest |
BtCancelSearchMessage |
BtCancelVerifyMessage |
BtChipBmscr |
BtChipBmu |
BtChipVersion |
BtCloseMessage |
BtConnectabilityMessage |
BtConnectionBasedController |
BtConnectionlessController |
BtConnectRequest |
BtController |
BtDevice |
BtDeviceAddress |
BtDeviceAddressGenericObject |
BtDeviceAndServiceClass |
BtDeviceDetailWindow |
BtDeviceFilter |
BtDeviceList |
BtDeviceList::BtDeviceListBidirectionalIterator |
BtDeviceList::BtDeviceListNode |
BtDeviceListConstantIterator |
BtDeviceListConstantReverseIterator |
BtDeviceListItem |
BtDeviceListIterator |
BtDeviceListProvider |
BtDeviceListReverseIterator |
BtDeviceListWindow |
BtDevicePairMessage |
BtDevicePairRequest |
BtDeviceSearchMessage |
BtDeviceSearchModeWindow |
BtDeviceSearchRequest |
BtDeviceTrustMessage |
BtDeviceTrustRequest |
BtDeviceUnpairMessage |
BtDeviceUnpairRequest |
BtDeviceUntrustMessage |
BtDeviceUntrustRequest |
BtDisconnectRequest |
BtDiscoverabilityMessage |
BtDunApplicationMessage |
BtDunAppPlugin |
BtDunConnectMessage |
BtDunDisconnectMessage |
BtDunProfileService |
BtDunRequestStateChangedMessage |
BtDunService |
BtEvent |
BtFaxApplicationMessage |
BtFaxAppPlugin |
BtFaxConnectMessage |
BtFaxDisconnectMessage |
BtFaxProfileService |
BtFaxRequestStateChangedMessage |
BtFaxService |
BtGapAndSdapApplicationMessage |
BtGapAndSdapNotificationMessage |
BtGapAndSdapRemoteRequestMessage |
BtGapAndSdapRequestMessage |
BtHfAppPlugin |
BtHfAudioPathWindow |
BtHfCmaAtChldOneCommandReceived |
BtHfCmaAudioAsynchronous |
BtHfCmaCheckPendingAudioCallback |
BtHfCmaMOC |
BtHfCmaMTC |
BtHfCmaPhoneNumberRequired |
BtHfFeatureListWin |
BtHfInbandSettingWin |
BtHfMessageArgumentsDestroyTableNode |
BtHfNmaAudioConnectionLost |
BtHfNmaCallEvent |
BtHfNmaConnect |
BtHfNmaDisconnect |
BtHfNmaLowPowerModeNotPossible |
BtHfNmaMicrophoneGain |
BtHfNmaSpeakerGain |
BtHfNmaTransferAudioToAccessory |
BtHfNmaTransferAudioToPhone |
BtHfNotificationMessage |
BtHfProfileService |
BtHfProfileWindow |
BtHfProvider |
BtHfRecord |
BtHfRecord::Persist |
BtHfRequestStateChangedMessage |
BtHfService |
BtHfSupportedProfileMessage |
BtHfVolumeSettingsWin |
BtHsAppPlugin |
BtHsCmaAudioAsynchronous |
BtHsCmaAudioTransferOutOfCall |
BtHsCmaCheckPendingAudioCallback |
BtHsCmaEnterLowPowerMode |
BtHsCmaHangUp |
BtHsConnectionSettingWin |
BtHsInbandSettingWin |
BtHsMessageArgumentsDestroyTableNode |
BtHsNmaAudioConnectionLost |
BtHsNmaCallEvent |
BtHsNmaConnect |
BtHsNmaDisconnect |
BtHsNmaLowPowerModeNotPossible |
BtHsNmaMicrophoneGain |
BtHsNmaSpeakerGain |
BtHsNmaTransferAudioToAccessory |
BtHsNmaTransferAudioToPhone |
BtHsNotificationMessage |
BtHsProfileService |
BtHsRequestStateChangedMessage |
BtHsService |
BtHsSupportedProfileMessage |
BtHsVolumeSettingsWin |
BtIndicatorMsg |
BtJsr82Url |
BtJsr82Url::Token |
BtJsr82Url::Token::Keyword |
BtLocalNameMessage |
BtLocalRequest |
BtLocalSettings |
BtLocalSettingsMessage |
BtMultiConnectionController |
BtMultiConnectionController::BtConnection |
BtObexAbortRequest |
BtObexClientAbortEvent |
BtObexClientAddr |
BtObexClientAddrResultNotifier |
BtObexClientConnectEvent |
BtObexClientDisconnectEvent |
BtObexClientEvent |
BtObexClientGetEvent |
BtObexClientNmaDataBufferIndication |
BtObexClientNmaDataInidication |
BtObexClientNmaHeaderIndication |
BtObexClientNmaHeaderSent |
BtObexClientNmaTransportDisconnect |
BtObexClientNotificationMessage |
BtObexClientObserverImpl | This class contains the implementation of the Client Service Observer, related to the Bt stack/controller callbacks for Obex Client operations (Connect, Put, Get, ...)
BtObexClientOperationEvent |
BtObexClientOperationRequest |
BtObexClientPutEvent |
BtObexClientRequestStateChangedMessage |
BtObexClientService |
BtObexClientServiceImpl | This class contains the extension of the BtObexClientService class
BtObexClientServiceObserver |
BtObexClientSetPathEvent |
BtObexConnectRequest |
BtObexController |
BtObexController::BtObexConnection |
BtObexDataBufferIndicationEvent |
BtObexDataIndicationEvent |
BtObexDisconnectRequest |
BtObexEvent |
BtObexGetRequest |
BtObexHeader |
BtObexHeaderIndicationEvent |
BtObexHeaderSentEvent |
BtObexImpl | This class contains the implementation of Obex related operations (Connect, Put, Get, ...) for both Client and Server connections
BtObexMessageArgumentsDestroyTableNode |
BtObexPutRequest |
BtObexRegisterClientEvent |
BtObexRegisterClientRequest |
BtObexRegisterServerEvent |
BtObexRegisterServerRequest |
BtObexRequest |
BtObexResponseCode | Indicates success or failure of an OBEX operation
BtObexSddbImpl |
BtObexSddbServiceObserverImpl | This class contains the implementation of the BtSddb Service Observer, related to the Bt stack/controller callbacks for Sddb operations (Register, Reregister, Unregister)
BtObexServerAbortIndicationEvent |
BtObexServerAddr |
BtObexServerConnectIndicationEvent |
BtObexServerDisconnectIndicationEvent |
BtObexServerEvent |
BtObexServerGetIndicationEvent |
BtObexServerNmaAbort |
BtObexServerNmaConnect |
BtObexServerNmaDataBufferIndication |
BtObexServerNmaDataInidication |
BtObexServerNmaDisconnect |
BtObexServerNmaGet |
BtObexServerNmaHeaderIndication |
BtObexServerNmaHeaderSent |
BtObexServerNmaPut |
BtObexServerNmaSetPath |
BtObexServerNmaTransportDisconnect |
BtObexServerNotificationMessage |
BtObexServerObserverImpl | This class contains the implementation of the Server Service Observer, related to the Bt stack/controller callbacks for Obex Server operations (Put, Get, ...)
BtObexServerPutIndicationEvent |
BtObexServerRequestStateChangedMessage |
BtObexServerService |
BtObexServerServiceImpl | This class contains the extension of the BtObexServerService class
BtObexServerServiceObserver |
BtObexServerSetPathIndicationEvent |
BtObexService |
BtObexServiceObserver |
BtObexServiceTable |
BtObexServiceTable::Entry |
BtObexServiceTable::ObexTarget |
BtObexServiceTable::Security |
BtObexServiceTable::ServiceInfo |
BtObexSetPathRequest |
BtObexSubSystem |
BtObexTransport |
BtObexTransportDisconnectEvent |
BtObexUnregisterClientRequest |
BtObexUnregisterEvent |
BtObexUnregisterServerRequest |
BtObservableService |
BtOpenMessage |
BtOperationBase |
BtOperationSelectDevice |
BtOperationSelectDeviceAndPerformServiceVerify |
BtPairabilityMessage |
BtPasskeyRequiredMessage |
BtPasskeyRequiredWindow |
BtPaSupportedProfileMessage |
BtProfileActivationMessage |
BtQuerySupportedProfilesMessage |
BtQuerySupportedProfilesRequest |
BtRemoteDeviceMessage |
BtRemoteDeviceNameMessage |
BtRemoteDevicePairMessage |
BtRequest |
BtRequestMessage |
BtRequestOperationMessage |
BtRequestRespondRequest |
BtRequestRunningWindow |
BtRequestStateChangedMessage |
BtRespondAuthorizationMessage |
BtRespondAuthorizationRequest |
BtSddbDataElement |
BtSddbDataElementFactory |
BtSddbDeAlternative |
BtSddbDeBaseCType |
BtSddbDeBigSintBase |
BtSddbDeBigUintBase |
BtSddbDeBoolean |
BtSddbDeByteBlockType |
BtSddbDeContainer |
BtSddbDeNil |
BtSddbDeOneByteDescriptionType |
BtSddbDeSequence |
BtSddbDeSint128 |
BtSddbDeSint16 |
BtSddbDeSint32 |
BtSddbDeSint64 |
BtSddbDeSint8 |
BtSddbDeSintBase |
BtSddbDeString |
BtSddbDeUint128 |
BtSddbDeUint16 |
BtSddbDeUint32 |
BtSddbDeUint64 |
BtSddbDeUint8 |
BtSddbDeUintBase |
BtSddbDeUrl |
BtSddbDeUuid128 |
BtSddbDeUuid16 |
BtSddbDeUuid32 |
BtSddbDeUuidBase |
BtSddbDeVariableLengthType |
BtSddbEvent |
BtSddbRegisterServiceEvent |
BtSddbRequestStateChangedMessage |
BtSddbService |
BtSddbServiceAttribute |
BtSddbServiceObserver |
BtSddbServiceRecord |
BtSddbUnregisterServiceEvent |
BtSendPasskeyMessage |
BtSendPasskeyRequest |
BtService |
BtServiceMessage |
BtServiceObserver |
BtServiceRequest |
BtServiceVerifyMessage |
BtServiceVerifyRequest |
BtServiceVerifyResult |
BtServiceVerifyResultMessage |
BtSetRemoteDeviceNameMessage |
BtSetRemoteDeviceNameRequest |
BtSingleConnectionController |
BtStateChangedMessage |
BtSvrDataElement |
BtSvrServiceAttribute |
BtSvrServiceRecord |
BtTransport |
BtTurnOnOffWindow |
BtUncancelablePointToPointRequest |
BtUncancelableRequest |
BtUUID |
BubbleSortProvider |
BufferedData |
BufferedOutputStream |
BufferPoolManager |
ByteBuffer |
CachingSortProvider |
CalculatorInputMapper | Manages the input of numbers and a decimal point
CalendarAddRecordWin |
CalendarApp |
CalendarDialogWin |
CalendarGotoDateWin |
CalendarGrid |
CalendarGridView |
CalendarListWin | This class declares a new kind of window derived from class MmiItemListWindow
CalendarMonthSelector |
CalendarMonthSelectorView | Describes the view of a radiobutton-control
CalendarMonthWin |
CalendarProvider |
CalendarRecord |
CalendarRecord::Persist |
CalendarRecordsList |
CalendarRecordsListBoxModel |
CallAcceptMsg |
CallBarredMsg |
CallBarringActivatedMsg |
CallBarringDeactivatedMsg |
CallBarringFeature |
CallBarringFeatureList |
CallBarringHandler | CallBarringHandler is a Supplementary Service handler responsible for activating, deactivating and interrogating the Call Waiting SS
CallBarringInfo |
CallBarringPasswordChangedMsg |
CallBarringStatusMsg |
CallControlIndMsg |
CallControlInfoMsg |
CallControlSetupIndArg |
CallControlSsIndArg |
CallControlUssdIndArg |
CallDeflectionErrIndicationMsg |
CallDeflectionHandler |
CallDeflectionIndArg |
CallDeflectionIndMsg |
CallDeflectionRejectedMsg |
CallDeflectSsReqArg |
CallDiscIndArg |
CallDisconnectedMsg |
CallDisconnectingArg |
CallDisconnectingMsg |
CallDiscReqArg |
CalledPartyAlertingMsg |
CallEvent | A simple structure providing information on an event happened to a particular call
CallEventMsg |
CallForwardingActivatedMsg |
CallForwardingActiveMsg |
CallForwardingDeactivatedMsg |
CallForwardingErasedMsg |
CallForwardingHandler |
CallForwardingRegisteredMsg |
CallForwardingStatusMsg |
CallHandler |
CallHdl |
CallHdlBase |
CallHeldMsg |
CallHoldCnfArg |
CallHoldRejArg |
CallHoldRejectedMsg |
CallIndArg |
CallIndCallControlInfoArg |
CallInfoArg | Structure which will never be sent in this environment!!!
CallInfoMsg |
CallingName |
CallIsWaitingMsg |
CallNotifyMsg |
CallOnHoldMsg |
CallProgressIndArg |
CallRelatedSsCnfArg |
CallRelatedSsRejArg |
CallRelatedSsReqArg |
CallRelCnfArg |
CallReleaseMsg |
CallRelIndArg |
CallRetrievedMsg |
CallSetupBySimtTkReqArg |
CallSetupProgressArg | Structure indicating the progress during setup phase of a call
CallSetupProgressMsg |
CallSsAction |
CallTypeTable |
CallWaitingActivatedMsg |
CallWaitingDeactivatedMsg |
CallWaitingHandler |
CallWaitingStatusMsg |
Camera |
Camera::ParameterLimits |
CameraApp |
CameraCaptureWin |
CameraMsgStartViewfinding |
CameraMsgStopViewfinding |
CameraOptionSettingsWin |
CameraSettings |
CameraSettingsWin |
CameraViewFinderWin |
CamWin32 |
CancelAction |
Caret |
CArray< T > |
CbmiData |
CbmiProvider |
CbmiRange |
CbmiRangeProvider |
Cbs |
Cbs::Filter |
Cbs::SerialNumber | Serial Number - 3GPP TS 23.041 V4.1.0 [9.4.1.2.1]
CbsDispatcher |
CbsFilterList |
CbsFilterList::CbsFilterListEntry |
CbsHandler |
CbsLimitIndArg |
CbsLimitMsg |
CbsNewDataIndArg |
CbsNewDataMsg |
CbsNewDataRejArg |
CbsStartCnfArg |
CbsStartDispatcher |
CbsStartRejArg |
CbsStartReqArg |
CbsStopCnfArg |
CbsStopDispatcher |
CbsStopRejArg |
CbsStopReqArg |
CcbsEntry |
CcbsList |
CcbsRecallMsg |
CcbsResultMsg |
CcbsStatusMsg |
CcpData |
Cell | Combines the row and column of a matrix
CellChangeCnts |
CellInfoIndArg |
CellInfoMsg |
CellParam |
CenteredTextIndicator | Indicator that displays a text width maximized width
CfuDataIndArg |
CfuService |
CfuServiceArray |
CfuStatusMsg |
ChannelData_s |
ChannelDataArray |
ChargeIndArg |
Charger |
ChargeReqArg |
ChargerInfoMsg |
ChargerSignalMapTableNode |
ChargerSignalProcessor |
ChargeUnitsIndArg |
ChargeUnitsReqArg |
CharInputMapEntry |
CharInputMapItem |
CharItem | Editor-Item which contains a wide-character
CheckBox | Obsolete - use the class CheckBoxControl from GUI instead
CheckBoxAction |
CheckBoxControl |
CheckBoxControlView | Describes the view of a checkbox-control
CheckBoxItem |
CheckBoxList |
CheckBoxListView | Describes the view of a checkbox-list
CheckBoxModel | Describes the model of a checkbox
CheckBoxView | Describes the view of a checkbox
ChildBinData |
ChineseQuickSortProvider |
ChineseT9InputMapper |
ChineseT9Wrapper |
Chv1DisableIndArg |
Chv1DisableReqArg |
Chv1EnableIndArg |
Chv1EnableReqArg |
ChvAttemptsStruct |
ChvChangedMsg |
ChvChangeIndArg |
ChvChangeReqArg |
ChvData |
ChvProvider |
ChvRefreshIndArg |
ChvUnblockIndArg |
ChvUnblockReqArg |
ChvVerifyIndArg |
ChvVerifyReqArg |
CiTestParam |
CiTestParamList |
ClearBlackListCnfArg |
ClearBlacklistReqArg |
ClientDc |
ClientDeregistrationArg |
ClientId | Stores the Client Id information
ClientInfo |
ClientName | Stores the client name
ClientNetAdapter |
ClientRegistrationArg |
ClipAction |
ClipHandler |
ClipStatusMsg |
ClirAction |
CliRestrictionInfo |
ClirHandler |
ClirNotSurpressedMsg |
ClirStatusMsg |
CloseAllMsg |
CloseDataConnMsg |
CloseWindowAction |
CloseWindowMsg |
CmiProvider |
CmiRecord |
CnapAction |
CnapHandler |
CnapInfoReceivedMsg |
CnapStatusMsg |
CodecDevice |
CodecDevice::AudioChannel |
CodecDevice::AudioCodecCapabilities |
CodecDevice::AudioDecoderParameters |
CodecDevice::AudioEncoderParameters |
CodecDevice::AudioIOBuffer |
CodecDevice::AudioStreamInfo |
CodecDevice::Properties |
CodecDevice::VideoCodecCapabilities |
CodecDevice::VideoDecoderInfo |
CodecDevice::VideoDecoderParameters |
CodecDevice::VideoEncoderInfo |
CodecDevice::VideoEncoderParameters |
CodecDevice::VideoStreamInfo |
CodecManager |
CodedTimeStamp | (ServiceCentreTimeStamp) 3GPP 23.040 V5.1.0 [9.2.3.11] -
Color |
ColorSegmentation |
ColorTable |
ColpAction |
ColpHandler |
ColpStatusMsg |
ColrAction |
ColrHandler |
ColrStatusMsg |
ColumnInfo |
comm_root_cert |
comm_user_cert |
CommandType | 3GPP TS 23.040 V5.1.0 [9.2.3.19]
CommonSignalMapTableNode |
CommonSignalProcessor |
CommonStackMsgArgsDestroyTableNode |
CommonStackMsgMapTableNode |
CommonStackMsgProcessor |
Component |
CompoundItem |
CompoundItemIterator |
CompoundItemReferrer |
CompoundSmsItem |
CompoundTpduItem |
Condition |
ConfirmAction |
ConnectionIndArg |
ConnectionStatusMsg |
ContextDescription |
ContextExecuteMsg |
ContextFeature | Special feature, which requires a context item as feature invocation argument
ContextFeatureHandle |
ContextFeatureItem |
ContextFeatureTriggerMsg |
ContextManager | This singleton handles context switches and applies context descriptions to new contexts
ContextMenu |
ContextMenuClosedMsg |
ContextMsg |
ContextTable |
ContextTableEntry |
ContextTableNode |
ContextWakeupMsg |
ContinueSocketTestMsg |
Control |
Control::ComponentIterator |
Control::NavigationGuidance |
ControlDc |
ControlFrameView |
ControlHwDataOnlyArg |
ControlMsg |
Conversion |
CopyHandler |
CopyToPbAction |
CountryProvider |
COverIList |
CphsAuxProvider |
CphsCfufArray |
CphsCfufReadIndArg |
CphsCfufReadReqArg |
CphsCfufUpdIndArg |
CphsCfufUpdReqArg |
CphsCspArray |
CphsCspReadIndArg |
CphsCspReadReqArg |
CphsCspUpdIndArg |
CphsCspUpdReqArg |
CphsIstArray |
CphsIstReadIndArg |
CphsIstReadReqArg |
CphsOnmName |
CphsOnmReadIndArg |
CphsOnmReadReqArg |
CphsOnsName |
CphsOnsReadIndArg |
CphsOnsReadReqArg |
CphsServPflProvider |
CphsVmwfArray |
CphsVmwfReadIndArg |
CphsVmwfReadReqArg |
CphsVmwfUpdIndArg |
CphsVmwfUpdReqArg |
CrssHandler |
CsdDataConn |
CsdDataConnAccessor |
CsdDataConnProfile |
CsdDataConnProfile::Bit |
CsdDataConnProfile::Persist |
CsdDataConnProvider |
CsdSettingsTable |
CTControlFrameView |
CtmInfoIndArg |
CtmInfoIndMsg |
CTPanelView |
CTPositionIndicatorView |
CTProgressBarView |
CTPushButtonView |
CTResourcePack |
CTWindowFrameView |
CugCallMsg |
CugDescriptor |
CurrencyCode |
CurrentCallMeterMsg |
CurrentChargeDataMsg |
CustomizableTheme |
CustomRingerAudioReference |
CustomSmafPhraseAudioReference |
CustomToneAudioReference |
DataCallContext |
DataCallControl |
DataCallHdl |
DataCallSignalMapTableNode |
DataCallSignalProcessor |
DataCoding |
DataCodingScheme | 3GPP TS 23.038 V4.3.0 (2001-09)
DataCodingSchemeRange | Used for cell broadcast filter
DataConn |
DataConnAccessor |
DataConnApp |
DataConnApp::DataConnDescription |
DataConnApp::EditableSettingTable |
DataConnCommonSettingsTable |
DataConnInfoMsg |
DataConnLbModel |
DataConnManager |
DataConnOptionWin |
DataConnProfile |
DataConnProfile::Bit |
DataConnProfile::Persist |
DataConnProfileInfoMsg |
DataConnProfileManager |
DataConnProfileManager::ProfileInfo |
DataConnProfileStorage |
DataConnProfileStorage::Header |
DataConnProvider |
DataConnTypeWin |
DataConnWin |
DataControl |
DataControlBootMsg |
DataControlBootProgressMsg |
DataControlEndBootMsg |
DataControlModificationMsg |
DataControlPhonebookStateMsg |
DataControlStartBootMsg |
DataHandler |
DataItem |
DataPack |
DataRateTable |
DataRecord |
DataRecordHandler |
DataSink |
DataSource |
DataSourceBinData |
DataSourceRtStreamingSource |
Date | Date is used to represent a single date
Date::Persist |
DateCompoundItem | Contains a date
DateEditBox | Obsolete - use DateEditor from Gui instead
DateEditBoxModel | Describes the model of a date editbox
DateEditBoxView | Describes the view of a date editbox
DateEditor |
DateEditorDocument | A Date-Editor-Document contains a Date-Compound-Item
DateEditorView |
DateStr |
datestr |
DateTime |
DateTime::Persist |
DateTimeInputMapper |
DbgDump |
DbgTimingMeasurement |
DBItemChangedMsg |
DBService |
DBService::DBItemIterator |
DchReport |
DcsLanguageFilterRule |
DebugOutputStream |
DecodingThreadlet |
DefaultCaret |
DefaultCheckBoxListView | Obsolete since APOXI-1.6.2
DefaultCheckBoxView | Obsolete since APOXI-1.6.2
DefaultChineseTheme | Obsolete theme - replaced by themes in Apoxi/GlobalThemes
DefaultControlFrameView |
DefaultDisplay |
DefaultItemRenderer |
DefaultPanelView |
DefaultPositionIndicatorView |
DefaultProgressBarView |
DefaultPushButtonView |
DefaultRadioButtonListView | Obsolete since APOXI-1.6.2
DefaultRadioButtonView | Obsolete since APOXI-1.6.2
DefaultSoftkeyBarView |
DefaultTabButtonView | Implements the drawing of the TabButton
DefaultTabControlView | Implements the drawing of the TabControl
DefaultTextListView |
DefaultTheme | Obsolete theme - replaced by themes in Apoxi/GlobalThemes
DefaultWindowFrameView |
DelegationProviderListener |
DeleteComponentMsg |
DeletedNode |
DeletedNodeList |
Desktop |
DetachCnfArg |
DetachReqArg |
DeviceContext |
DeviceManager |
DeviceManager::Iterator |
DhChannelChangeStatusEventArg |
DhChannelChangeStatusResArg |
DhChannelChangeStatusResMsg |
DhChannelCloseIndArg |
DhChannelCloseReqArg |
DhChannelCloseReqMsg |
DhChannelDataAvailableResArg |
DhChannelDataAvailableResMsg |
DhChannelDataAvailEventArg |
DhChannelOpenCnfArg |
DhChannelOpenRejArg |
DhChannelOpenReqArg |
DhChannelOpenReqMsg |
DhChannelReceiveIndArg |
DhChannelReceiveReqArg |
DhChannelReceiveReqMsg |
DhChannelSendIndArg |
DhChannelSendReqArg |
DhChannelSendReqMsg |
DiagnosticIndArg |
DiagnosticIndMsg |
DialogWindow |
DirectoryIterator | Client interface and base class for directory iterators
DirtyFileHandler |
DisabledFeatureTriggeredMsg |
Dispatcher |
DispatcherAction |
Display |
Display::CustomFrameBuffer |
DisplayConfig |
DisplayDc | DeviceContext that encompasses the complete display
DisplayInfoMsg |
DisplayMemoryAction |
DisplaySettings |
DisplayTextReqArg |
DisplayTextRspArg |
DistinctProvider |
DistinctRule |
DnsClient |
DnsClientTest |
DownloadSettings |
DrawableObject |
DrawableObjectView |
DrmAsset |
DrmConstraint |
DrmDcfHeader |
DrmDcfHeaderData |
DrmDcfParser |
DrmInfo |
DrmInfoPersistStructure |
DrmMediaObject |
DrmMessage |
DrmPermission |
DrmRelParser |
DrmRightsMapTableEntry |
DrmRightsObject |
DrmRightsObjectContainer |
DrmRightsObjectFile |
DrmRightsObjectStore |
DrmROStoreSingleton |
DrmSecurity |
DrmSubsystem |
DrmUtils |
DrmWapPushMsg |
dstat |
DtmfBufferCleanedMsg |
DtmfBufferClearedIndArg |
DtmfRejectArg | Structure keeping DTMF rejection cause and respective call index of the call
DtmfRejectMsg |
DtmfStartCnfArg | Structure keeping information for DTMF tone generation
DtmfStartCnfMsg |
DtmfStopCnfMsg |
DualFilterProvider |
DummyVrEngineParams |
DwdDevice |
DwdPlayer |
DynamicBitVector |
DynamicMenuPool |
EccArray |
EccCategory |
EccCustomization |
EccListIndArg |
EccNetworkArray |
EccNetworkElement |
EccNetworkNumber |
EccProvider |
EctActiveMsg |
EctAlertingMsg |
EctCnfArg |
EctIndicator |
EditBox | Obsolete - use MultiLineEditor or LineEditor from Gui instead
EditBoxBlinkTimer |
EditBoxModel | Describes the model of a date editbox
EditBoxPagingTimer |
EditBoxView | Describes the view of a date editbox
EditConfig |
EditLine |
EditorDocument |
EditorDocumentObtainer |
EditorItemNode |
EditorLine |
ElementList< T > |
ElementListBase |
emcpp_apoxi_OBEXAdapter |
EmlppAction |
EmlppHandler |
EmlppPriority |
EmlppRegisteredMsg |
EmlppStatusMsg |
EmsApp |
EmsComposeWin |
EmsCreator |
EmsCreator::SpaceInfo |
EmsEditor |
EmsEditorListener |
EmServThreadMsg |
EmsIeParser |
EmsImage |
EmsInsertPrompt |
EmsInsertPromptListBoxModel |
EmsResourceMaps |
EmsResourceMaps::AnimNode |
EmsViewerWin |
EmzAacDecoder |
EmzAacDecoderThread |
EmzCodecsLib |
EmzH264Decoder |
EmzH264DecoderThread |
EmzMp3Decoder |
EmzMp3DecoderThread |
EmzMpeg4Decoder |
EmzMpeg4DecoderThread |
EmzMpeg4Encoder |
EmzMpeg4EncoderThread |
EmzSbcEncoder |
EmzSbcEncoderThread |
EmzUtils |
EmzUtils::Queue< T > |
EmzUtils::Queue< T > |
EncodingThreadlet |
EndSimToolkitIndArg |
EngineeringModeControlRequestArg |
EngineeringModeControlResponseArg |
EngineeringModeControlResponseMsg |
EngineeringReportMsg |
EnglishT9InputMapper |
EngModeAction |
EnumTextMap |
EnumTextTableEntry |
EnumTranslationTable |
EqualsRule | EqualsRule checks whether data item equal to rule item
EquivPlmnLists |
EventData |
ExecutionContext |
ExternalCommunicationHandler |
ExternalPdpContextInfoMsg |
ExternalTimeoutMsg |
ExtLanguage |
ExtLanguageArray |
ExtProactiveCmdCnfArg |
ExtProactiveCmdIndArg |
ExtProactiveCmdReqArg |
ExtPsdContextListener_SerialTerminal |
ExtPsdContextListener_SerialTerminalListener |
ExtPsdContextListener_SioGlueSignalListener |
ExtPsdContextListener_SioGlueWrapper |
ExtPsdContextListener_SioGlueWrapper::SioCommId |
ExtPsdContextListener_SioGlueWrapper::TermIos |
ExtPsdContextListenerImpl_SerialTerminalListener |
FatDirectoryIteratorImp | Directory iterator implementation for FAT storage device
FatFile |
FatFileImp | File implementation for FAT filesystem (FAT) storage devices
FatFileInfo |
FatFindData |
FatFsUsbMassStorageReleaseMsg |
FatFsUsbMassStorageRequestMsg |
FatHandler |
FatStorageDeviceImp | Storage device implementation for FAT storage devices
FdnIndArg |
FdnReqArg |
Feature | Represents pure functionality, will be wrapped by a feature item
FeatureBroker |
FeatureChangedMsg |
FeatureHandle |
FeatureItem |
FeatureItemContainer |
FeaturePool |
FeatureTriggerMsg |
ffs_drm_attrib_type |
ffs_file_info_type |
ffs_ref_type |
ffs_time_record_type |
FfsDataConnProfileStorage |
FfsDrmAttrib | FfsDrmAttrib contains the digital rights management attribute
FfsFile |
FfsFileInfo |
FfsHandler |
FfsMenu |
FfsMimeTypeMap |
FfsMimeTypeMapEntry |
FfsRefType |
FfsTestBase::FfsTestInfo |
FfsTestDispWin |
FfsTestMenu |
FfsTestResultsMenu |
FfsTestResultsSubMenu |
FfsTests |
FfsTestSubMenu |
FfsTestThread |
FfsTestThreadlet |
FfsTimeRecord | FfsTimeRecord is updated after every modification of a file
FifoLinkedList< T > |
File | Client interface and base class for files
File::Attributes |
File::FileState | Structure holding the state of the file
FileBinData |
FileChunkOperationProgressMsg |
FileChunkOperator |
FileDataSink |
FileDataSource |
FileFilter | Base class for file filters
FileInfo_s |
FileInfoInternal_s |
FileInputStream |
FileInReadStatusInfo |
FileNameListBoxModel | Model for showing filenames stored in a MediaRefContainer
FileNameView | View for showing filenames by the use of a FileNameListBoxModel
FileOutputStream |
FilePack |
FilePackConnector |
FileVisitor | Base class for file visitors
FilterProvider |
FilterRule |
Find2Provider |
FindProvider |
FixedPtrArray< T > |
FlagCaretaker |
FlashDirectoryIteratorImp | Directory iterator implementation for flash storage device
FlashFileImp | File implementation for flash file system (FFS) storage device
FlashStorageDeviceImp | Storage device implementation for flash storage device
FlipMsg |
FlowLayout |
FlsFile |
FmRadioApplication |
FmRadioEditWin |
FmRadioSelectStrongerFreq |
FmRadioSettingsProvider |
FmRadioSettingsRecord |
FmRadioSettingsRecord::Persist |
FmRadioStationsProvider |
FmRadioStationsRecord |
FmRadioStationsRecord::Persist |
FmRadioWindow |
FocusNextControlMsg |
FocusObtainer |
FocusPreviousControlMsg |
FoggyPanelView |
FoggyPositionIndicatorView |
FoggyPushButtonView |
FoggySoftkeyBarView |
FoggyTheme | Obsolete theme - replaced by themes in Apoxi/GlobalThemes
FoggyWindowFrameView |
Font |
FontConfig |
FontEntry |
FontManager |
FontPack |
FontPackConnector |
FontRes |
ForwardedCallIncomingMsg |
ForwardingFeature |
ForwardingFeatureList |
ForwardingInfo |
ForwardingInfoReceivedArg | Contains the data related ForwardingInfoReceivedMsg
ForwardingInfoReceivedMsg |
ForwardingSsAction |
Fota |
Fraction |
FrameDc | Device context used for drawing the frame of a control
FromStackMsg |
fs_registered_info_type |
fs_stat |
FsRegistrationInfo |
FtpAuthProvider |
FtpClient |
FtpConnectMessage |
FtpDataServerSocket |
FtpDataSocket |
FtpDisconnectMessage |
FtpErrorMessage |
FtpInTransfer |
FtpOutTransfer |
FtpRequest |
FtpRequestMessage |
FtpServer |
FtpServerConfig |
FtpServerSocket |
FtpServiceMessage |
FtpSocket |
FtpTransfer |
FtpTransferMessage |
FunctionalityIndicator | 3GPP 23.040 V5.1.0 [9.2.3.12.3]
GatiManager |
GatiServer |
GeneralCompoundItem | Represents a simple container for Bounded-Editor-Items
GenericAudioDevice |
GenericFeatureData |
GenericFeatureData::GenericTrackInfo | This structure is used for setting/getting the track information of a sound
GenericObject |
GenericWorkerTask |
GetFocusMsg |
GetInkeyReqArg |
GetInkeyRspArg |
GetInputReqArg |
GetInputRspArg |
GetPasswordMsg |
GifImage |
GlassPane |
GltpAidDataRequests |
GltpAidingDataWin |
GltpAidingRequest |
GltpAssistanceData |
GltpConnApp | This class handles the socket based communication for Gltp protocol
GltpConnStatusMsg |
GltpHelloRequest |
GltpMsgProcessor | This class sends the Gltp requests to the Lcs Stack
GltpMsmtRequest |
GltpPositionRequest |
GltpProviderImpl | The implementation of the GLTP protocol provider
GltpRequest |
GltpSignalMapTableNode |
GltpSignalProcessor |
GltpStackMsgArgsDestroyTableNode |
Glyph |
GlyphHeader |
GlyphIndexTab |
GmmParam |
GprsAttachStatusMsg |
GprsClassIndArg |
GprsClassReqArg |
GprsParam |
GprsStatusMsg |
GpsFixData |
GpsFixDataInt | This structure stores the GPS fix data for internal conversion later
GreaterRule | IsGreaterRule checks whether data item is larger than the rule item
Grid | Obsolete - use AbstractGrid or Menu from GUI instead
GridLayout |
GridModel | A matixbox-model describes the data of the widget grid
GridView |
GroupProvider |
GroupProvider::GroupRec |
GsmBandList |
GsmBandStateMsg |
Guid |
GuidServiceTable |
GuidUriTable |
GuiEngineConfig |
GuiObjectFactory |
HandlerData |
HandlerFactory |
HandlerListEntry |
Hashable |
HashTable |
HeaderData |
HeadSet |
HeapArrayObject< T > |
HeapDataSink |
HeapDataSource |
HeapManager |
HeapObject< T > |
HeapVector |
HeapVector::BlockPage |
HeapVector::FctTable |
HeapVector::HeapTableEntry |
HeapVector::Page |
HeapVector::Stats |
HeapVector::VarPage |
HindiTextRenderer |
HlrDataCorruptedMsg |
HlrSsDataCorruptMsg |
HomezoneIndArg |
HomezoneMsg |
HomezoneText |
HostDebugTimeStamp |
HostFatFsDeviceDescriptor |
HostFileStatType |
HostIniFile |
HostIterStatType |
HttpApplication |
HttpApplicationSupplier |
HttpAuthProvider |
HttpClient |
HttpConnectMessage |
HttpDisconnectMessage |
HttpErrorMessage |
HttpHandler |
HttpRequest |
HttpRequest::ParamPair |
HttpRequestMessage |
HttpResponse |
HttpServer |
HttpServerConfig |
HttpServerSocket |
HttpServiceMessage |
HttpSocket |
HttpWapMgr |
HttpWapMgrBase |
HttpWapMgrPlugin |
Iana |
IccId |
IconDescReadIndArg |
IconDescReadReqArg |
IconIndicator | Indicator that displays an icon
IconSet |
IconState |
IconTextIndicator | Indicator that displays an icon and text
IconValueIndicator | Indicator that displays icon assigned for iterator values
IdentifierHandler |
IdleScreenAvailEventArg |
Image |
Image::CleanupDrawingObtainer |
Image::MetaData |
ImageBox |
ImageBoxView |
ImageBrowserApp |
ImageBrowserDeleteImageMsg |
ImageBrowserDetailWin |
ImageBrowserRenameImageMsg |
ImageBrowserServiceMsg |
ImageBrowserTestWin |
ImageBrowserWin |
ImageDecoder |
ImageDecodingProgressMsg |
ImageDrawingInterruptedMsg |
ImageEncoder |
ImageEncoder::EncodingParameters |
ImageEncodingProgressMsg |
ImageFactory |
ImageFileFilter | File filter filtering image files
ImageFilter | Base class for filters concerning image references
ImageIncrementalPdcUpdater |
ImageItem |
ImageListBoxModel | Base class of a model for showing images
ImageListBoxView |
ImageMetaData |
ImageMetaDataRecord |
ImageObtainer |
ImageReadIndArg |
ImageReadReqArg |
ImageRef |
ImageRefContainer |
ImageRefGenContainer |
ImageView |
ImageViewListBoxModel | Class to serve as a model for the ImageView
Imei |
ImeiReadIndArg |
ImeiReadReqArg |
ImeiShowAction |
IMelody |
IMelodyData | Holds parsed IMelody data
ImgObtObj |
Imsi |
IncomingCallForwardedMsg |
IncrementalPdcUpdater |
IndexTable< T > |
Indicator | Base class of indicators to be used in IndicatorBars
IndicatorBar |
IndicatorBarPaneObject |
IndicatorBarUpdateMsg |
IndicatorBarView |
IndicatorDescription |
IndicatorItem |
IndicatorLocation |
IndicatorPaneObject |
InetSocket |
InetSocketAddr |
InfoDialog | Dialog showing some information only
InformationElement |
InputAction |
InputActionList |
InputActionPtr |
InputAnalyzer |
InputCharMsg |
InputContext |
InputMap |
InputMapEntry |
InputMapItem |
InputMapper |
InputMapperFactory |
InputParser |
InputStream |
InteriorNodeRecord | InteriorNodeRecord
InternalTracer |
InternalTracer::TraceHeader |
InternalTracer::TsStruct | This struct just prevents ms compiler to rearange TraceHeader-struct
InterrogateCcbsResult |
InterrogateSsResult |
InterrogationResultArg | Contains the interrogation result, containing supplementary service status
InterrogationResultMsg |
InvalidateMsg |
InvokeId | This class generates a new invoke id whenever it's instantiated
IpAddr |
IpAddrCompoundItem | Contains a date
IpAddrEditor |
IpAddrEditorDocument | A IpAddr-Editor-Document contains a IpAddr-Compound-Item
IpAddrInputMapper | Manages the input of a ip adress
IpAddrPrompt |
IpPortNo |
IrConnection |
IrdaApp |
IrdaObexClientAddr |
IrdaObexImpl |
IrdaObexServerAddr |
IrdaObexSubSystem |
IrdaObexTransport |
IrdaTransport |
IrdaWin |
IrSocketAddr |
IsrDataContainer< Data, c_queue_size > |
IsrDataManager |
IsrDataMarshaller |
Item |
ItemBox |
ItemBoxView |
ItemContainer |
ItemGrid |
ItemLabel | DrawableObject, which shows text
ItemLabelView |
ItemMenu |
ItemMenu::LevelInfo |
ItemObj |
ItemPropertiesChangedMsg |
ItemRendererProperties |
ItemRendererPropertiesChangedMsg |
ItemTree |
JapaneseTextRenderer |
JapaneseTranscoder |
JarBinDataStatusInfo |
JarFileGlobalInfo_s |
JarFileStatusInfo |
JmpBuf |
JoinProvider |
JoinProviderListener |
JoinRule |
JpegEncoder |
JpegEncoder::EncodingParameters |
JpegEncodingThreadlet |
JpegImage | Class to contain, decompress and draw a JPEG compatible image
JumpToRowMsg |
KeyAutoRepeatMsg |
Keyboard | Keyboard
KeyboardConfig |
KeyDownInputMapEntry |
KeyDownInputMapItem |
KeyDownMsg |
KeyManager |
KeyMapping |
KeymapTableEntry |
KeyMsgGenerator |
KeyMsgGenerator::Key | One key-object which is extracted by the AtKeyParser and used as input for the KeyMsgGenerator
KeySequence |
KeySequenceCandidate |
KeyToneAudioDevice |
KeyToneAudioDevice::StartParam | Start parameter
KeyUpInputMapEntry |
KeyUpInputMapItem |
KeyUpMsg |
L1Param |
L2CapSocketAddr |
Lai |
LanguageArray |
LanguageChangedMsg |
LanguageCodeTableEntry |
LanguageManager |
LanguageProvider |
LanguageResetAction |
LanguageSelectEventArg |
LanguageSettingIndArg |
LanguageSettingReqArg |
LastLocationEstimate | Stores the last known location estimate along with the timestamp
LaunchBrowserIndArg |
LaunchBrowserPromptIndArg |
Layouter |
LcsAppRegisterForMtlrMsg |
LcsAppResWinMsg |
LcsAppTransferLocMsg |
LcsAppUtils |
LcsArc | Stores location estimate in 'point' format with uncertainty of type 'arc'
LcsCommonMsgProcessor | This class sends the abortion request to Lcs stack
LcsCommonSignalMapTableNode |
LcsCommonSignalProcessor |
LcsCommonStackMsgArgsDestroyTableNode |
LcsMainApp |
LcsMainMenuWin |
LcsMmiQos | The Qos structure to be filled by user inputs
LcsMolrResultArg |
LcsMsgProcessor | Forms SDL signal from the parameters sent and sends it to MN
LcsOptionsMenuWin |
LcsPoint | Stores location estimate in 'point' format
LcsPointAltitudeUncertEllipsoid | Stores location estimate in 'point' format with uncertainty of type 'ellpsoid'
LcsPointUncertCircle | Stores location estimate in 'point' format with uncertainty of type 'circle'
LcsPointUncertEllipse | Stores location estimate in 'point' format with uncertainty of type 'ellipse'
LcsProvider |
LcsProviderImpl | This class implements the 3GPP protocol specific methods
LcsProviderImplBase | The abstract base class of all the provider implementations
LcsQos | Structure containing the Qos in the format required to fill in the SDL signal
LcsRepeatTimer | Timer used for repeated self location requests
LcsReqProcessor | The centralized storage for MO-LR and MT-LR requests from all providers
LcsSettingsApp |
LcsSettingsUtils |
LcsSignalMapTableNode |
LcsSignalProcessor |
LcsSocket |
LcsStackMsgArgsDestroyTableNode |
LcsTimer | Timer class for MO-LR and MT-LR request timeouts
LcsUtils | This is a utility Class,used by all providers for miscellaneous operations
LcsWapIntf |
LcsWString |
Led | Back light device
Led::Color |
Led::Frame |
Led::Stream |
Led::StreamField |
LedNotificationMsg |
LedSignalMapTableNode |
LedSignalProcessor |
LessRule | RangeRule checks whether data item is less than the rule item
LexAnalyzer |
LineEditor |
Linkable< T > |
LinkableBase |
LinkedList< T > |
LinkedListBase |
ListPropertyDescriptor |
LittleEndian16Bit | Represents a 16 bit integer in little endian format
LittleEndian32Bit | Represents a 32 bit integer in big endian format
LocalDataStore |
Locale |
Locale::LocaleData |
LocaleConfig |
LocationErrMsg |
LocationEstimate | Contains the decoded location estimate
LocationNotifInvokeArg |
LocationNotifInvokeMsg |
LocationResMsg |
LocationResultWin | This window displays the position fix data
LocationVerifWin |
LociData |
LockedKeyDownMsg |
LockedKeyMsg |
LockProvider |
LockTable |
LockTableEntry | Structure to store uri and application pointer that locked the uri
LockTableList |
LocResController | Class for controling position fix data display
LongKeyPressMsg |
LookupAlphaIdExtension |
LoseFocusMsg |
LsaIdentifier |
LsaIdentifierArray |
LsaIdentityMsg |
MainDesktop | Default desktop which displays indicators inside the desktop sections
MainHandler | The main handler is the entry point to the ASC library
MainHandlerAccess |
MainProvider |
MapiAudioPlayer |
MapiAudioReference |
MappingPolicy |
MbiProvider |
MCServiceInterfaceMsg |
MdhDeletionCmd | MdhDeletionCmd (ms.h: T_DR_DEL_CMD_FLAGS)
MdhDeregistrationCnfArg |
MdhDeregistrationReqArg |
MdhExtendedData |
MdhGors | MdhGors (ms.h: T_DATA Group Operation Result Set, internal use)
MdhMakeViewCnfArg |
MdhMakeViewReqArg |
MdhNewStatusReportIndArg |
MdhRegistrationCnfArg |
MdhRegistrationReqArg |
MdhRemoveViewCnfArg |
MdhRemoveViewReqArg |
MdhResult | MdhResult (ms.h: T_DR_RESULT)
MdhSetConfigCnfArg |
MdhSetConfigReqArg |
MdhSetStorageCnfArg |
MdhSetStorageReqArg |
MdhSetWaitIndicator | MdhSetWaitIndicator (ms.h: T_DR_SET_WAIT_IND_RQ)
MdhSetWaitIndicatorArray | MdhSetWaitIndicatorArray (ms.h: T_DR_SET_WAIT_IND_REQ)
MdhSmsConcRefNumIndArg |
MdhSmsConcRefNumReqArg |
MdhSmsDeletionIndArg |
MdhSmsDeletionReqArg |
MdhSmsExtendedDataIndArg |
MdhSmsExtendedDataReqArg |
MdhSmsInitFinishedIndArg |
MdhSmsNewMessageIndArg |
MdhSmsReadIndArg |
MdhSmsReadReqArg |
MdhSmsRefreshIndArg |
MdhSmsReportReadIndArg |
MdhSmsReportReadReqArg |
MdhSmsSetWaitingReqArg |
MdhSmsStatusIndArg |
MdhSmsStatusReqArg |
MdhSmsStorageRefreshIndArg |
MdhSmsTransmitAckArg |
MdhSmsTransmitIndArg |
MdhSmsTransmitStartAckArg |
MdhSmsTransmitStartIndArg |
MdhSmsTransmitStopIndArg |
MdhSmsUpdStatusIndArg |
MdhSmsUpdStatusRefreshIndArg |
MdhSmsUpdStatusReqArg |
MdhSmsWaitingIndArg |
MdhSmsWriteCnfArg |
MdhSmsWriteReqArg |
MdhViewConfig | MdhViewConfig (ms.h: T_DR_SM_VIEW_CONFIG)
MdhWaitIndicator | MdhWaitIndicator (ms.h: T_DR_WAIT_INDICATOR)
MdhWaitIndicatorArray | MdhWaitIndicator (ms.h: T_DR_WAIT_INDICATOR_ARR)
MeasurementData |
MeasurementDataArg |
Media |
Media::Parameters |
MediaBox |
MediaBoxView |
MediaBrowserUtils | Utility class for SB and IB
MediaFilter | Base class for filter that can be used by the image or sound browser
MediaFrameworkCaps |
MediaInfo |
MediaInfo::AudioTrackInfo |
MediaInfo::ClipInfo |
MediaInfo::MediaTrackInfo |
MediaInfo::VideoTrackInfo |
MediaManager |
MediaManagerMsg |
MediaObtainer |
MediaPathnameVisitor |
MediaPlayer |
MediaRecorder |
MediaRef |
MediaRefContainer |
MediaRefLinkable | The Linkable wrapping a MediaRef smart pointer
MediaVisitor |
Melody |
MemMap |
MemoryConfig |
MemPool |
MemPoolEntry |
Menu |
MenuAccessor |
MenuDesc |
MenuDescObj |
MenuIdObj |
MenuItem |
MenuList | Obsolete - use Menu and MenuAccessor from Gui instead
MenuListView |
MenuPool |
MenuPool::FeatureItemContainerContentTableEntry |
MenuPool::FeatureItemContainerTableEntry |
MenuPool::MenuTableEntry |
MenuProperties |
MenuSelectionRejArg |
MenuSelectionReqArg |
MenuTable |
MenuTableNode |
MenuTextIterator |
MenuTextPtrArrayIterator |
MenuView |
MenuWindow |
MePhonebookDescription |
MePhonebookDescriptor |
MergeProvider |
Message |
MessageBox |
MessageHook |
MessageIdentifier | Message Identifier - 3GPP TS 23.041 V4.1.0 [9.4.1.2.2]
MessageIdentifierContainer | Used for cell broadcast filter, this class is only used internally
MessageIdentifierContainer::MessageIdentifierPair |
MessageIdentifierRange | Used for cell broadcast filter
MessageMap< T > |
MessageMapContainer< T > |
MessageMapDispatcher |
MessageReferrer |
MessageRouter |
MessageTypeIndicator |
MetaData |
MetaDataRecord |
MexeDescriptor |
MidiSound |
MimeCoder |
MimeCoding |
MimeTypeFilter |
MimeTypeTable | User-extendable MIME type registry
MimeTypeTable::Partition | Represents a partition of the APOXI MimeTypeTable
MimeTypeTableEntry | MIME type description record
MinuteTickMsg |
MiscAudioDevice |
MiscAudioDevice::AvailableHW | Available HW. If a member variable is TRUE the hardware is available
MiscAudioDevice::PowerStatus | Power status. If a member variable is TRUE the device is powered on
MlcNumber | Unique Number of the GMLC through which the transfer location is routed
MmAocChargingStatusMsg |
MmCallAcceptMsg |
MmCallDisconnectingMsg |
MmCallDispatcher |
MmCallHandler |
MmCallHdl | Class to establish and release Mm calls. Calls are identified by a call_index
MmCallInfo |
MmCallInfoMsg |
MmCallNotifyMsg |
MmCallReleaseMsg |
MmCallSerialTerminalListener |
MmCallSetupProgressMsg |
MmCallStatusMsg |
MmCellChangeCnts |
MmCoordParam |
MmcsParam |
MmCurrentCallMeterMsg |
MmCurrentChargeDataMsg |
MmfPlayer |
MmfPlayer::MediaPlayerInstanceData |
MmiSimClient |
MmiSimMsg | MmiSimMsg consist of a unique id and four MmiSimMsgArgs
MmiSimMsgArg | MmiSimMsgArg contains a generic MmiSimMsg argument
MmiSimServer |
MmMocSetupAcceptMsg |
MnInformationIndArg |
MnNetworkSearchModeReqArg |
MnTriggerReqArg |
MobileOriginatedUssdHandler |
MocAlertIndArg |
MoCallAction |
MocSetupAccArg |
MocSetupAcceptMsg |
MocSetupCnfArg |
MocSetupRejArg |
MocSetupRejectIndMsg |
MocSetupRejIndArg |
MocSetupReqArg |
Model |
MolrInfo |
MolrParams | This class is used to fill the MN_SS_LCS_MOLR_REQ SDL signal
MolrRepeatInfo |
Mp3AudioDevice |
Mp3AudioDevice::StartParam | Start parameter
MP3AudioPlayer |
MP3AudioReference |
Mp3Header |
Mp3Param |
MptyCallHdl |
MptyCallReleaseMsg |
MptyCnfArg |
MptyHoldRejectedMsg |
MptyOnHoldMsg |
MsapPackedData_s |
MsgMetaData |
MsgQueue |
MtcAcceptArg |
MtcAcceptRejArg |
MtcAlertReqArg |
MtcArrivedMsg |
MtcConfIndArg |
MtcReadyMsg |
MtcSetupComplArg |
MtcSetupIndArg |
MtlrInfo |
MultiLineEditor |
MultiMediaEditor |
MultiMediaEditorDocument |
MultiMediaEditorDocument::TextManager |
MultiPartData |
MultipartParser |
MultiPartyCallInvokedMsg |
MultiSlotDispatcher | Active Wait Dispatcher to catch the OmRatChangeCnf-Message-Arg
MultiSlotHandler |
MultiSlotMode |
MultiTapCaret | Caret specialized for multi-tab input-mode
MultiTapInputMapper |
Mutex |
MutexObtainer |
NameIndicator |
NamePatternFileFilter | File filter filtering files by a name pattern
NamePatternStorageDeviceFilter | Storage device filter filtering storage devices by a name pattern
Native16Bit |
Native32Bit |
NativeImage |
NeighbourCell |
NeighbourCellList |
NetAdapter |
NetAdapter::DataReceivedEventArgs |
NetAdapter::DataSentEventArgs |
NetAdapter::EventArgs |
NetAdapterHandler |
NetworkDispatcher |
NetworkHandler |
NetworkInformationMsg |
NetworkSsErrorMsg |
NetworkSsRejectedMsg |
NextSocketTestMsg |
NiSharedPtr< X > |
NmeaUartSettings | UART Settings for NMEA data transfer
NodeFileHandler |
NoMessage |
NonCloneable |
NonCopyable |
NonsharedBinDataDataSource |
NoStackMsgArg |
NotEqualsRule | NotEqualsRule checks whether data item is not equal to rule item
NotificationArray |
NotificationTable |
NotificationTableEntry | NotificationTableEntry contains the URI -> Callback/App_ptr mapping
NotifyIndArg |
NotifySsArg |
NRegStateIndArg |
NumberIdentificationAction |
NumberPrompt |
NumericInputMapper |
NvRamBlockInfo |
NvRamDataRecordHandler |
NvRamStorage |
NwDiscStartIndMsg |
ObexAbstractPort | Internal base class for OBEX transport interfaces
ObexAbstractPort::AddressEvent | Event data type for EvResolveComplete
ObexAbstractPort::CompleteEvent | Event data type for EvOpComplete
ObexAbstractTransport | Internal abstract interface base class for OBEX transports
ObexAddress | Base class for client- and server address information
ObexAddrMsg |
ObexApp |
ObexAppMsg |
ObexBuffer | Provides exclusive access to a buffer holding BODY data
ObexBuffer::Factory | Factory class for ObexBuffers with user-defined memory manangement strategy
ObexBuffer::Reader | Accessor class to read data from an ObexBuffer
ObexBuffer::Writer | Accessor class to write data into an ObexBuffer
ObexChannel | Internal association class used to address an OBEX transport channel
ObexClient | Base class for OBEX clients within applications
ObexClientAddr | Base class for client address information classes
ObexClientDispatcher | Internal abstraction of a client OBEX transport connection
ObexClientOppImpl | Internal client implementation of the OPP profile
ObexClientPort | Internal implementation class for OBEX transport interfaces
ObexDataServer | OBEX server which uses the BinData and DataSink interfaces for transferring data
ObexDispatcher | Internal OBEX message dispatcher
ObexEventHandler | Internal interface for handling OBEX protocol events
ObexFtpDataServer | Internal implementation class which handles the OBEX FTP logic used by the class ObexFtpServer
ObexFtpServer | OBEX FTP server which offers an abstract interface to be implemented for a specific file system
ObexHeader | Represents an OBEX header
ObexHeaderBuilder | Helps to assemble an OBEX header from several chunks of data
ObexHeaderList | Managing list of OBEX headers
ObexHeaderList::ConstIterator |
ObexLayer | Internal interface base class for direct access to the OBEX layer
ObexMngr | OBEX Manager. Singleton. Facade to global APOXI OBEX functionality
ObexMsg |
ObexObject | Handle class which provides access to OBEX protocol data
ObexObjectData | Internal body class for OBEX objects
ObexOperationId | Internal association class for requests and responses related to an operation
ObexOppBinDataPushClient | Reads data from a BinData instance and pushes it towards a remote OPP server
ObexOppClient | Base class for OPP clients within applications
ObexOppClientOperation | Internal abstraction of an OPP client operation
ObexOppClientPull | Internal implementation of an OPP PULL operation.
ObexOppClientPush | Internal implementation of an OPP PUSH operation.
ObexOppDataSinkPushServer | Receives data pushed in by a remote OPP client and saves it to a to a DataSink instance
ObexOppServer | Base class for OPP servers within applications
ObexProtocol | Internal interface base class for protocol layer abstractions
ObexResult | Indicates success or failure of OBEX API functions and operations
ObexServer | Internal base class for OBEX servers within applications
ObexServerAddr | Base class for server address information classes
ObexServerDispatcher | Internal abstraction of an OBEX server at transport level
ObexServerInfo | Internal interface used to register OBEX servers with the Server Registry
ObexServerMngr | Internal implementation of an OBEX Server Registry
ObexServerOppImpl | Internal server implementation of the OPP profile
ObexServerPort | Internal implementation class for OBEX transport interfaces
ObexServerVisitor | Internal interface used to scan the OBEX Server Registry
ObexTransportMsg |
ObexTransportSet | Set representing multiple transport media to be used with APOXI OBEX
ObexTransportSet::Iterator | Utility class to iterate over set elements
ObexTransportWin |
ObexTriggerMsg |
ObexUrlStrParser | Internal utility class used to parse an OBEX URL
ObexVCardMsg |
ObjectDataConverter |
ObjectObtainer |
ObjectTreeService |
ObservableObject |
Observer |
ObtainableObject | Base class for objects, that can be controled by an ObjectObtainer
OmBandStatusCnfArg |
OmBandStatusReqArg |
OmControlIndArg |
OmFactoryResetIndArg |
OmGetTermProfileCnfArg |
OmGetTermProfileReqArg |
OmMultiSlotIndArg |
OmMultiSlotIndMsg |
OmMultiSlotReqArg |
OmPowerUpArg |
OmRatChangeCnfArg |
OmRatChangeIndArg |
OmRatChangeReqArg |
OmSetTermProfileCnfArg |
OmSetTermProfileRejArg |
OmSetTermProfileReqArg |
OnDataRcvdMsg |
OpenContextMenuAction |
OpenPbWinMsg |
OpenWindowAction |
OplEntry |
OptionalConfig |
OptionalConfigBase |
Os |
OutgoingCallForwardedMsg |
OutputStream |
PackedTimePeriod | 3GPP 23.040 V5.1.0 [9.2.3.12.1]
PagingMap |
PagingMapEntry |
PaintDc |
Palette |
Panel |
PanelView | Describes the view of a panel
PaneObject |
ParagraphCompoundItem |
ParagraphMarker | Represents the marker at the end of each Paragraph
ParameterIndicator | 3GPP TS 23.040 V5.1.0 [9.2.3.27]
PasswordChangeSsAction |
PasswordEditor |
PasswordInquiryMsg |
PasswordReceivedArg | Indication of received password, echoed by the network
PasswordReceivedMsg |
PasswordRejectedMsg |
Path | Path identifying a file throughout the system
Pathname | Pathname identifying a file relative to a storage device
Pathname::Iterator | Iterates over segments of a pathname
Pathname::ReverseIterator | Iterates over segments of a pathname in reverse order
PathProfile | Utility class to persist a path
PathProfile::Persist | The structure to persist a path profile
PbAbstractWin |
PbAction |
PbAddAction |
PbAddPhoneNoAction |
PbAdvAddEditEntry |
PbAdvDataHandler |
PbAdvDetailAction |
PbAdvDetails |
PbAlphaTagRequestMsg |
PbBaseProvider |
PbBaseWin |
PbCallAction |
PbCancelAddNoAction |
PbCancelEditAction |
PbChangeNoTypeAction |
PbConfirmAddNoAction |
PbConfirmEditAction |
PbCopyHandler |
PbCountIndArg |
PbCountReqArg |
PbDataHandler |
PbDelAllAction |
PbDeleteAction |
PbDelPhonenoAction |
PbDetailAction |
PbDetailEditBox |
PbDetailListBox |
PbDetailListBoxModel |
PbDetailProvider |
PbDetails |
PbEditDetailAction |
PbEntryReadIndArg |
PbEntryReadReqArg |
PbEntryRequestMsg |
PbEntryShowAction |
PbEntryUpdIndArg |
PbEntryUpdReqArg |
PbFfsNameHandler |
PbFfsNumberHandler |
PbInfoReadIndArg |
PbInfoReadReqArg |
PbLazySynchronizer |
PbManualSynchronizer |
PbMergeProvider |
PbNameEditBox |
PbNameFilterProvider |
PbNameHandler |
PbNameNumberProvider |
PbNameProvider |
PbNextFreeIdRecord |
PbNumberFilterProvider |
PbNumberHandler |
PbNumberProvider |
PbNumberRecord |
PbNumberRecord::Persist |
PbNvRamNameHandler |
PbNvRamNumberHandler |
PbPhoneNumberPrompt |
PbProvColListBox |
PbProvColListBoxModel |
PbProviderListener |
PbProvListBox |
PbProvListBoxModel |
PbRecord |
PbRecord::Persist |
PbRecordHandler |
PbRecordProvider |
PbSecuredAction |
PbSelectGroup |
PbSelectGroupAction |
PbSelectNoType |
PbSelectNumberWin |
PbSimProvider |
PbSizeRequestMsg |
PbSortedProvider |
PbSynchronizer |
PbToggleAction |
PcmParam |
PdpAuthTable |
PdpContext |
PdpContext::ActivationStatus |
PdpContext::Address |
PdpContext::Authentication |
PdpContext::PacketFilter | PacketFilter, (see 3GPP TS 23.060)
PdpContext::PacketFilter::AddressAndMask |
PdpContext::QualityOfService |
PdpContextActivationStatusMsg |
PdpContextControl |
PdpContextManager |
PdpContextManager::AttachStatus |
PdpContextManager::DataCounters |
PdpContextManagerControl |
PdpContextSignalMapTableNode |
PdpContextSignalProcessor |
PdpQoSDelayTable |
PdpQoSMeanRateTable |
PdpQoSPeakRateTable |
PdpQoSPrecedenceTable |
PdpQoSReliabilityTable |
Pen |
PenDownMsg |
PenUpMsg |
PersistDataConnProfile |
PhonebookApp |
PhoneBookInfo |
PhonebookRenumberedMsg |
PhonebookWin |
PhoneNumber | PhoneNumber implements bcd coded phone numbers regarding to GSM 04.08
PhoneNumber::Persist |
PhoneNumberInputMapper |
PhoneNumberJoinRule |
PhoneNumberMatchRule | PhoneNumberMatchRule: Compares two PhoneNumbers by using the PhoneNumber::IsMatching method
PhoneNumberMergeProvider |
PinAction |
PinDisableIndArg |
PinDisableReqArg |
PinEnableIndArg |
PinEnableReqArg |
PlayToneReqArg |
PlayToneRspArg |
Plmn |
PlmnDispatcher |
PlmnHandler |
PlmnInfoReqArg |
PlmnListAbortArg |
PlmnListCnfArg |
PlmnListEntry | Plmn list entry (ms.h: T_SEL_SINGLE_PLMN)
PlmnListRejArg |
PlmnListReqArg |
PlmnProvider |
PlmnRatDispatcher | Active Wait Dispatcher to catch the OmRatChangeCnf-Message-Arg
PlmnScanDispatcher |
PlmnScanFinishedMsg |
PngDecoder | Class for decoding PNG images
PngEncoder |
PngEncoder::EncodingParameters |
PngEncodingThreadlet |
PngImage | Class to contain, decompress and draw a PNG compatible image
PnnEntry |
Point | Combines the x- and y-coordinate
PortHeaderInformation |
PositionIndicator |
PositionIndicatorView |
PowerDispatcher |
PowerDownCnfArg |
PowerDownDispatcher |
PowerDownIndArg |
PowerDownReqArg |
PowerHandler |
PowerModeIndMsg |
PowerOffMsg |
PowerOnMsg |
PowerWakeupMsg |
PppCallBackData | Types needed for lwIP PPP connections
PppDataConn |
PppFrame |
PppSetupCallBackData |
PredefinedEmsImage |
PredefinedEmsSound |
PredInputMapper | Abstract base class for predictive input-mappers
PrefExtLangProvider |
PrefLangProvider |
PrefPlmnChangeArg |
PrefPlmnProvider |
PrefServiceSetReqArg |
PreparedSound |
PresetAudioReference |
ProactiveCauseMapper |
ProcessMolrMsg |
ProcessNode | ProcessNode maintains the global SDL process pointer
ProgressBar |
ProgressBarView |
Property |
PropertyDescriptor |
PropertyEditor | Interface for property editors
PropertyEditorFactory | Singleton class for handling property editors
PropertyItem | Encapsulates a property. The PropertyItem can be used for GUI controls
PropertyTriggerMsg |
Protector |
ProtocolIdentifier | 3GPP TS 23.040 V5.1.0 [9.2.3.9]
ProvColListBoxWin |
ProvDetailListBoxWin |
Provider |
Provider::Modification |
ProviderChangedMsg |
ProviderListBox | Abstract ListBox, which shows a WString row of a provider
ProviderListBoxModel | Describes the model of a ProviderListBox
ProviderListBoxView | Describes the view of a ProviderListBox
ProviderListener |
ProviderProxyContainer |
ProviderProxyItem |
ProviderPtr |
ProviderUpdateMsg |
ProvListBoxWin |
PsdDataConn |
PsdDataConnAccessor |
PsdDataConnProfile |
PsdDataConnProfile::Bit |
PsdDataConnProfile::Persist |
PsdDataConnProvider |
PsdSettingsTable |
PsLociData |
Puct |
PushButton |
PushButtonView | Describes the view of a pushbutton
QuickSortProvider |
QuotedPrintableCoder |
RadioAudioDevice | APOXI interface to FM Radio device
RadioAudioDevice::StationInfo | Structure for info about a station
RadioButtonAction |
RadioButtonControl |
RadioButtonControlView | Describes the view of a radiobutton-control
RadioButtonGroup | Handles deselection of radiobutton-actions
RadioButtonItem |
RadioButtonList |
RadioButtonListView | Describes the view of a RadioButtonList
RadioButtonModel |
RadioButtonView |
RamBlockData |
RamData |
RamDataSink |
RamDataSource |
RamDirectoryIteratorImp |
RamFile |
RamFileImp | File implementation for random access memory (RAM) storage device
RamFileInfo |
RamFileNode |
RamFileObj |
RamFileSystem |
RamHandler |
RamStorageDeviceImp | Storage device implementation for RAM storage device
RamStorageMapper |
RangeMappingPolicy |
RangeRule | RangeRule checks whether data item is between rule item and rule2item
RatChangeModeChangedMsg |
RatStateMsg |
Rdn |
RealTimeClock |
RealTimeClock::DateAndTime |
Record |
RecordHandler |
RecordSettings |
Rect |
RedialIndArg |
RediallingDisabledIndArg |
RedialQueryReqArg |
RedialRejArg |
RedialSetupIndArg |
RedialSetupMsg |
RedialStartedMsg |
RedialStatusIndArg |
RedialStatusMsg |
RedialStopIndArg |
RedialStoppedMsg |
RedialSuccessMsg |
RedrawDisplayMsg |
ReferableObject |
ReferenceLocation |
ReferenceTime |
RefreshComponentMsg |
RegApp |
RegAppCommon |
RegAppFirstWin |
RegAppWin |
RegBlobObject |
RegCbNotifyMsg |
RegDeletionBufferEntry |
RegDirtyFile | Structure of dirty file
RegEncoderDecoder |
RegEncoderDecoder::IteratorObjResult |
RegEncoderDecoder::Mobile2PCMsg |
RegEncoderDecoder::Mobile2PCMsg::msg |
RegEncoderDecoder::Payload |
RegEncoderDecoder::PC2MobileMsg |
RegEncoderDecoder::PC2MobileMsg::msg |
RegEncoderDecoder::RegIteratorNodeType |
RegEncoderDecoder::Response |
RegEncoderDecoder::SetUpMsg |
RegEncoderDecoder::UriAndPayload |
RegFileHeader | RegFileHeader
RegistrationAllowedMsg |
RegistrationChangeMsg |
RegistrationSuccessMsg |
Registry |
RegistryInterface |
RegIterator |
RegIterator::InteriorMetaData | Holds interior metadata
RegIterator::LeafMetaData | Holds leaf metadata
RegManager |
RegMemoryBuffer |
RegMemoryPool |
RegNodeBuffer | Structure of reg node buffer
RegNodeFileHeader | Nodefile header structure
RegNodeRecord | Nodefile record structure
RegNotifyMsg |
RegObjectData | The object data structure
RegStateIndArg |
RegTcpSocket |
RegUriMapFile | Structure of urimapfile
RejectCallsIndArg |
RemotePartyActionMsg |
RenameFileDialog | Dialog for renaming a file with the media browser
ResourceID |
ResourceManager | Obsolete (comments from methods describe the replacement)
ResultWinBase |
RfcommSocketAddr |
RfsMediaAvailableStatusMsg |
RfsObexFtpServer | A basic OBEX FTP server for the root file system (RFS)
RfsStorageDeviceRegistrationStatusMsg |
RichTextCompoundItem |
RingerAudioDevice |
RingerAudioDevice::RingerToneInfo | Detailed information to a fixed ringer tone. See enum ToneId
RingerAudioDevice::StartParam | Start parameter
RomData |
RomDataRes |
RomFont |
RootDirectoryIteratorImp | Directory iterator implementation for root storage device
RootFileImp | File implementation for virtual root storage device
RootFileSystem | Client interface for root file system access
RootStorageDeviceImp | Storage device implementation for virtual root storage device
RootStorageDeviceIterator | Device iterator implementation for virtual root storage device
RrcParam |
RrcProcessState |
RrParam |
RtcAlarmReachedMsg |
RtcDateChangedMsg |
RtcInfoMsg |
RtcSignalMapTableNode |
RtcSignalProcessor |
RtcTimeChangedMsg |
RtStreamingBuffer | Assignable data buffer with transfer-of-ownership semantics
RtStreamingConn |
RtStreamingEndPoint | Base class for RtStreamingSource and RtStreamingSink
RtStreamingEndPoint::BufferInfo | Contains parameters required for proper buffering
RtStreamingSink |
RtStreamingSource |
S_SvgFixPointTrans |
SaLocationErrArg |
SaMolrResultArg |
SaMsgProcessor |
SaProviderImpl |
SaSignalMapTableNode |
SaSignalProcessor |
SaStackMsgArgsDestroyTableNode |
SatelliteInfo | Contains information about a visible (& possibly tracked) satellite
SatteliteGraphWin | This window displays the position fix data
SatteliteInfoWin | This window displays the position fix data
SaveEntryInPhonebookMsg |
SaveNoAction |
SavingProgressWin |
ScanlineAccessor |
Scheduler |
ScicosCodecIfLib |
ScicosMpeg4VideoDecoder |
ScicosMpeg4VideoEncoder |
SearchBox |
SecLockCode |
SecLockCommand |
SecLockDescriptor |
SecLocks |
SecLockStates |
SecMmiConfigData |
SelectedLineRetriever |
SelectionBox |
SelectionBoxView |
SelectionChangedMsg |
SelectItemReqArg |
SelectItemRspArg |
SelfLocationDialog | Class for the self location window. This window takes user input for QoS from the user
Semaphore |
SemObtainer |
SendRequestMsg |
SendSmsMsg |
SerDataConnAccessor |
SerDataConnProvider |
SerialClientSocket |
SerialIoAdapter |
SerialIoAdapter::SioErrorDesc |
SerialIoSet | Maintains fd set for the socket operations
SerialServerSocket |
SerialSocket |
SerialSocketData |
SerialSocketDataLock |
SerialSocketSubSystem |
SerialSocketThread |
SerialTerminal |
SerialTerminalArg |
SerialTerminalListener |
SerialTerminalMsgArgsDestroyTableNode |
SerialTerminalSocket |
SerSettingsTable |
Server |
ServerAddressWin |
ServerClient |
ServerConfig |
Service |
ServiceBroker |
ServiceProviderStruct |
ServicePtr< T > |
ServiceThread | Class ServiceThread is used to implement services, i.e. tasks which perform permanent background activity like network services. A service thread does not need any graphical user interface but needs to run as an own thread. It only always awakes from idle when it receives a message or when a timer expires. To handle the message overwrite method OnMessage(). For an automated start-up and shut-down of the service thread use class ServiceThreadStarter
ServiceThreadStarter |
ServiceThreadStarter::StartParam |
ServiceThreadTerminateMsg |
SetAutoChargeArg |
SetChargeUnitsArg |
SetLanguageAction |
SetThemeAction |
SettingsProvider |
SetupDataConnMsg |
SetupEventCnfArg |
SetupIdleModeTextReqArg |
SetupIdleModeTextRspArg |
SetupMenuReqArg |
SetupMenuRspArg |
SharedMemHdl |
SharedPtr< T_obj > |
SharedTimer |
SharedTimerMsg |
SharedTriggerTimer< T > |
ShortMessageFailureCause | 3GPP TS 23.040 V5.1.0 [9.2.3.22]
ShortMessageStatus | 3GPP TS 23.040 V5.1.0 [9.2.3.15]
ShutDown |
ShutdownRequestMsg |
SiBearerDesc_s |
SiBearerDescArray |
SiBearerList_s |
SiBearerListArray |
SiChannelCloseInfoIndArg |
SiChannelCloseInfoIndMsg |
SiChannelCloseInfoResArg |
SiChannelCloseReqArg |
SiChannelOpenPromptReqArg |
SiChannelOpenPromptReqMsg |
SiChannelOpenPromptResArg |
SiChannelReceiveInfoIndArg |
SiChannelReceiveInfoIndMsg |
SiChannelReceiveInfoResArg |
SiChannelSendInfoIndArg |
SiChannelSendInfoIndMsg |
SiChannelSendInfoResArg |
SiDuration_s |
SigDispatcher |
SigHandler |
SignalHandler |
SignalMapTable |
SignalMapTableEntry |
SignalMapTableNode |
SignalQualityLevelMsg |
SignalStrengthLevelIndArg |
SignalStrengthLevelMsg |
SignedValue | Structure for storing signed values
SiIpAddress_s |
SiIpAddressArray |
SimAccessor |
SimAcmMaxReadIndArg |
SimAcmMaxReadReqArg |
SimAcmMaxUpdIndArg |
SimAcmMaxUpdReqArg |
SimAcmReadIndArg |
SimAcmReadReqArg |
SimAcmUpdIndArg |
SimAcmUpdReqArg |
SimAlphaIdentifier | Tlv alpha identifier - GSM 11.14 [12.2]
SimApdu |
SimApduData |
SimAtom< T > |
SimAuxHandler |
SimBrowserTermResArg |
SimBrowserTermResMsg |
SimCallSetupMsg |
SimCallSetupRejectedMsg |
SimCbmiReadIndArg |
SimCbmiReadReqArg |
SimCbmirReadIndArg |
SimCbmirReadReqArg |
SimCbmirUpdIndArg |
SimCbmirUpdReqArg |
SimCbmiUpdIndArg |
SimCbmiUpdReqArg |
SimCcpReadIndArg |
SimCcpReadReqArg |
SimCcpUpdIndArg |
SimCcpUpdReqArg |
SimChvHandler |
SimClutEntry |
SimCmiReadIndArg |
SimCmiReadReqArg |
SimCphsHandler |
SimData |
SimDfParameters |
SimDispatcher |
SimDisplayTextMsg |
SimDisplayTextOptions | Describes how the display string should be represented
SimEfOrangeParam |
SimEfParameters |
SimEfRefresh |
SimEfRefreshTable |
SimEndTransactionMsg |
SimErrorIndArg |
SimErrorMsg |
SimEventList |
SimExtLangReadIndArg |
SimExtLangReadReqArg |
SimExtLangUpdIndArg |
SimExtLangUpdReqArg |
SimFileInfoIndArg |
SimFileInfoReqArg |
SimFullAccessIndArg |
SimGenericIndArg |
SimGenericReqArg |
SimGetInkeyMsg |
SimGetInkeyOptions |
SimGetInputMsg |
SimGetInputOptions |
SimHandler |
SimIconDescription |
SimIconIdentifier |
SimIconQualifier | Icon specific options
SimImage |
SimImageDescriptor |
SimInfo |
SimInfoIndArg |
SimInitIndArg |
SimItemId | Plain sim item id
SimItemIdentifier |
SimLangReadIndArg |
SimLangReadReqArg |
SimLangUpdIndArg |
SimLangUpdReqArg |
SimLaunchBrowserPromptReq_s |
SimLaunchBrowserPromptReqArg |
SimLaunchBrowserPromptReqMsg |
SimLaunchBrowserReqArg |
SimLaunchBrowserReqMsg |
SimLockStates |
SimLockStatusIndArg |
SimLockStatusMsg |
SimMccMncIndArg |
SimMenuItemSelectionFailedMsg |
SimMexeCertificate |
SimModifyLockIndArg |
SimModifyLockReqArg |
SimMruPropertyRefreshIndArg |
SimMruPropertyUpdCnfArg |
SimMruPropertyUpdReqArg |
SimNextActionIdentifier | Representing tlv items next action indicator - GSM 11.14 [12.24]
SimODyn2ReadIndArg |
SimODyn2ReadReqArg |
SimODyn2UpdIndArg |
SimODyn2UpdReqArg |
SimODynReadIndArg |
SimODynReadReqArg |
SimODynUpdIndArg |
SimODynUpdReqArg |
SimPbBaseHandler |
SimPbEntry |
SimPbEntryCont |
SimPduHandler |
SimPhoneBookEntry |
SimPlayToneMsg |
SimpleAppContext |
SimpleAudioDevice |
SimpleMap< TKey, TValue > |
SimpleMap< TKey, TValue >::Iterator |
SimpleMapElem< TKey, TValue > |
SimpleMutex |
SimpleScheduler |
SimpleSemaphore |
SimpleTextRenderer |
SimPuctReadIndArg |
SimPuctReadReqArg |
SimPuctUpdIndArg |
SimPuctUpdReqArg |
SimRefreshIndArg |
SimRefreshMsg |
SimRefreshReqArg |
SimRefreshResetMsg |
SimResetConfirmationMsg |
SimResetDoneMsg |
SimSelectItemMsg |
SimSelectItemOptions |
SimServices |
SimServiceTable |
SimSetupIdleModeTextMsg |
SimSetupIdleModeTextOptions |
SimSetupMenuMsg |
SimSetupMenuOptions |
SimSmsParameter |
SimSmsParameter::Record |
SimSmsParamHandler |
SimSmsrReadIndArg |
SimSmsrReadReqArg |
SimSmsrUpdIndArg |
SimSmsrUpdReqArg |
SimSmsSentMsg |
SimSpnReadIndArg |
SimSpnReadReqArg |
SimSsSentMsg |
SimSstReadIndArg |
SimSstReadReqArg |
SimStateChangedMsg |
SimSubAddress |
SimTextString | Representing tlv text string - GSM 11.14 [12.15]
SimTkCallSetupAccArg |
SimTkCallSetupIndArg |
SimTkCallSetupRejArg |
SimTkHandler |
SimTkInterfaceIndArg |
SimTkLanguageNotificationIndArg |
SimTkLanguageNotificationMsg |
SimTkLceService |
SimTkMainMenuProvider |
SimTkProfile |
SimTkProfileGetCnfMsg |
SimTkProfileSetCnfMsg |
SimTkProfileSetRejMsg |
SimTkRefreshCnfIndArg |
SimTkRefreshCnfReqArg |
SimTkRefreshNewReqArg |
SimTkRefreshNewRspArg |
SimTkRefreshQueryReqArg |
SimTkRefreshQueryResArg |
SimTkRefreshReqArg |
SimTkRefreshResetReqArg |
SimTkRefreshResetRspArg |
SimTkRefreshRspArg |
SimTkRefreshStartMsg |
SimTkResetCnfArg |
SimTkResetCnfIndArg |
SimTkResetCnfReqArg |
SimTkRunAtCmdInfoIndArg |
SimTkRunAtCmdInfoIndMsg |
SimTkRunAtCmdInfoResArg |
SimTkSendDtmfCnfArg |
SimTkSendDtmfEndIndArg |
SimTkSendDtmfEndIndMsg |
SimTkSendDtmfIndArg |
SimTkSendDtmfIndMsg |
SimTkSetupEventMsg |
SimTkSetupEventReqArg |
SimTkSmsPpIndArg |
SimTkSmsPpRspArg |
SimTkSsIndArg |
SimTkSsRspArg |
SimTkStopSendDtmfReqArg |
SimTkTransactionId |
SimUserDispatcher |
SingleArgHook< T > |
SioGlueSignalListener |
SioGlueWrapper |
SioGlueWrapper::SioCommId |
SioGlueWrapper::TermIos |
SioSocketAdapter |
SioSocketAdapter::SioSocketCallbacks |
SiProvFileRef_s |
SiProvFileRefArray |
SiText_s |
SiTextArray |
SiUrlArray |
Size |
SkipSocketTestMsg |
SmafSound |
Sms |
SmsAlert |
SmsApp |
SmsBasicProvider |
SmsCapacityAvailableArg |
SmsCapacityExceededArg |
SmsClass0Provider |
SmsCommand |
SmsComposeWin |
SmsConcatStatusTextMap | Sms concatenation status
SmsConfigIndArg |
SmsContext |
SmsControlIndArg |
SmsControlIndMsg |
SmsCountProvider |
SmsDeliver |
SmsDispatcher |
SmsEditor |
SmsFactory |
SmsFolderProvider |
SmsGetMoreMessageStatusIndArg |
SmsGetMoreMessageStatusReqArg |
SmsGsmServiceTextMap | Sms service names
SmsHandler |
SmsIndicationState |
SmsInfoBox |
SmsMessageWaitingChangedMsg |
SmsMsgTypeTextMap | Sms message types
SmsMsgTypeUsageTextMap | Sms message type usage
SmsMsgWaitingProvider |
SmsNewMessageIndArg |
SmsNewMessageMsg |
SmsNewSocketDataMsg |
SmsNewStatusReportIndArg |
SmsNewStatusReportMsg |
SmsParamProvider |
SmsParamRecord |
SmsPortDataRecvMsg |
SmsPrefStorageMediaChangedMsg |
SmsProvider |
SmsrData |
SmsReadProvider |
SmsResultTextMap | Sms result texts
SmsSendCnfArg |
SmsSendConfirmMsg |
SmsSendDispatcher |
SmsSendingAnimation | Sending animation
SmsSendingConfirmDialog |
SmsSendRejArg |
SmsSendRejectMsg |
SmsSendReqArg |
SmsSentProvider |
SmsServiceDocumentMsg |
SmsServiceMsg |
SmsSetMoreMessageReqArg |
SmsSettingsProvider |
SmsSettingsRecord |
SmsSettingsRecord::Persist |
SmsSocket |
SmsSocketListener | Registration of SMS sockets to the system and manages all registered SMS sockets
SmsSocketSignalMapTableNode |
SmsSpaceAvailableMsg |
SmsSpaceExceededMsg |
SmsStatus |
SmsStatusReport |
SmsStatusReportTextMap | Status report state and reson texts
SmsStatusTextMap | Sms status
SmsStorageTypeTextMap | Sms storage types
SmsSubmit |
SmsTelematicDeviceNameTable | Telematice device names
SmsTemplateProvider |
SmsTemplateTextMap | Sms templates
SmsTextEntry |
SmsTextParser |
SmsUnreadProvider |
SmsUnsentProvider |
SmsUtility |
SmsViewerWin |
SmsWStringCache |
SmsWStringCache::Entry |
Socket |
SocketAddr |
SocketControlMsg |
SocketData |
SocketDataLock |
SocketEventListener |
SocketHandler |
SocketPeer |
SocketRxThread |
SocketSerialTerminalListener |
SocketSubSystem |
SocketTestApp |
SocketTestApp::menuItems |
SocketTestMessage |
SocketTestProgressWin |
SocketTestResultsWin |
SocketTestSettingsWin |
SocketTestT |
SocketTestT1 |
SocketTestT2 |
SocketTestT3 |
SocketTestT4 |
SocketTestT5 |
SocketTestT6 |
SocketTestT7 |
SocketTestT8 |
SocketTestTests::TestGroupInfo |
SocketTestWin |
SoftkeyBar |
SoftkeyBarView | Describes the view of a Softkey-Bar
SoftkeyDesc |
SoftkeyDescTableEntry |
SortedElementList< T > |
SortedLinkedList< T > |
SortedLinkedListBase |
SortProvider |
Sound |
SoundBrowserApp |
SoundBrowserServiceMsg |
SoundBrowserTestWin |
SoundBrowserWin |
SoundFileFilter | File filter filtering sound files
SoundFilter | Base class for filters concerning sound references
SoundItem |
SoundMetaData |
SoundMetaDataRecord |
SoundObtainer |
SoundRef |
SoundRefContainer |
SpeechAudioDevice |
SpeechSimpleAudioDevice |
SsBarringIndArg |
SsBeginAccArg |
SsCallBarringActionImpl |
SsCallForwardingActionImpl |
SsCallWaitingActionImpl |
SsCauseIndArg |
SsCcbsDispatcher |
SsCcbsHandler |
SsCcbsInvokeArg |
SsCcbsReCallIndArg |
SsCcbsReCallRequestArg |
SsCcbsRejectArg |
SsCcbsResultIndArg |
SsCcbsStatusIndArg |
SsClientRejArg |
SsClipActionImpl |
SsClirActionImpl |
SsCnapActionImpl |
SsColpActionImpl |
SsColrActionImpl |
SsControlIndMsg |
SsData |
SsDataIndArg |
SsDataReceivedArg | Indication of received supplementary service data
SsDataReceivedMsg |
SsDispatcher |
SsEmlppActionImpl |
SsEndIndArg |
SsEndMsg |
SsErrIndArg |
SsErrIndicationMsg |
SsErrorCode | Error Codes, [GSM 04.80, 4.5]
SsErrorMsg |
SsErrReqArg |
SsFacilityIndArg |
SsFacilityRejArg |
SsFacilityRejectedMsg |
SsForwardingIndArg |
SsForwcheckIndArg |
SsGetPasswordIndArg |
SsGetPasswordRejArg |
SsGetPasswordRspArg |
SsGroup |
SsGroupList |
SsHandler |
SsInfoMsg |
SsInterrogateIndArg |
SsMessage |
SsNotification | Supplementary Service Status [GSM 09.02, 14.7.4]
SsNotificationArg | Indication of an executed supplementary service (also remote)
SsNotificationMsg |
SsNotifyIndArg |
SsPasswordChangeActionImpl |
SsPasswordIndArg |
SsRejArg |
SsRejectedMsg |
SsRejReqArg |
SsRequestAcceptedMsg |
SsRequestRejectedMsg |
SsRequestSentMsg |
SsRetResIndArg |
SsSendEndReqArg |
SsSendReqArg |
SsStatus | Supplementary Service Status [GSM 09.02, 14.7.4]
SsSuccessMsg |
SstProvider |
SsUnstructIndArg |
SsUssdActionImpl |
SsUssdIndArg |
SsUssdReqArg |
SsUssdResentIndArg |
SsUus1IndArg |
SsUus1QueryIndArg |
SsUus1QueryRejArg |
SsUus1QueryReqArg |
SsUus1ReqArg |
SsWaitDispatcher |
StackControl |
StackInterface |
StackMsgActiveWaitDispatcher |
StackMsgArgDestroyTableNode |
StackMsgArgMap< T > |
StackMsgArgMapContainer< T > |
StackMsgArgument |
StackMsgDispatcher | Base for all normal dispatchers, which are used in ASC
StackMsgMapTable |
StackMsgMapTableEntry |
StackMsgMapTableNode |
StackMsgProcessor |
StackSsRejectedMsg |
StackTranslator |
StackWrapper |
StandardJoinRule | StandardJoinRule is a paramaterizable rule for standard relations
StartDtmfCnfArg |
StartDtmfRejArg |
StartDtmfReqArg |
StartSignalStrengthListeningArg |
StartSocketTestMsg |
StartUp |
StartUp::Data |
StartUp::Table |
StateMachine |
StateStruct |
StatusDispatcher |
StatusProvider |
StillCamera |
StopBatteryLoadListeningArg |
StopDtmfCnfArg |
StopDtmfReqArg |
StopSignalStrengthListeningArg |
StopSocketTestMsg |
StorageDevice | Client interface and base class for storage devices
StorageDeviceFilter | Base class for storage device filters
StorageDeviceIterator | Storage device iterator
StorageDeviceVisitor | Base class for storage device visitors
StrData |
Stream |
StreamAudioPlayer |
StreamAudioReference |
StreamingCallback |
StreamingInfo |
StreamingReadInfo |
StreamingWriteInfo |
StreamObexImpl |
StreamObexTransport |
StreamReader |
StreamWriter |
String |
StringDataSink |
StrokeBox |
StrokeBoxView |
Subaddress |
SubMenuAction |
SubstitutedText |
SubSystem |
SubSystemManager |
SubUnitReference |
SvgDecodingFinishedMsg |
SvgFileWrapper |
SvgGzFileWrapper |
SvgHyperlinkSelectMsg |
SvgImage |
SvgImageFileWrapper |
SvgIoWrapper |
SvgMimeUtil |
SvgPlayer |
SvgStatusMsg |
SwitchedRleCompression |
SwitchedRleCompression::Context |
SyncAction |
SyncMLCTCap |
SyncMLCTParam |
SyncMLCTProp |
SyncMLCTTypeVerCT |
SyncMLCTValueDef |
SyncMLDataStoreProps |
SyncMLDynamicProps |
SyncMLItemMetaInfo |
SyncMLManager |
SyncPaintDc |
SyncPhoneAction |
SyncPhoneAllAction |
SyncPhoneThreadlet |
SyncProgressMsg |
SyncSimAction |
SyncSimAllAction |
SysDnsClient |
SysSocket |
SysSocket::FdSet |
SysSocket::FdSet |
SysSocket::FdSet |
SysSocketBase | Base SysSocket
SysSocketBase::LingerSetting |
System |
SystemTimer |
T9AddWordMsg |
T9EnteredUnknownWordMsg |
T9InputConfig |
T9InputMapper |
T9MatrixModeKeypressed |
T9NoWordFoundMsg |
T9Pack |
T9PackConnector |
T9PinyinBox |
T9PinyinBoxView |
T9PredictiveInputBox |
T9SymbolEntryRequestMsg |
T9ThaiMatrixModeWindowInterface |
T_PB_CHANGED_FIELD |
T_PB_CLIENT_FLAGS |
T_PB_DESCRIPTOR |
T_PB_FILE_A |
T_PB_FILE_DESC |
T_PB_FILE_IN_SLICE |
T_PB_FILL_STATUS |
T_PB_GROUP_NUMBER |
T_PB_GROUPING |
T_PB_LOC_REPORT |
T_PB_RECORD |
T_PB_REF_FILE |
T_PB_REF_FILE_FILL_STATUS |
T_PB_REF_FILE_FILL_STATUS_A |
T_PB_REF_RECORD |
T_PB_REFERENCE |
T_PB_STATE |
T_PB_UNIQUE_FILE |
T_PB_UNIQUE_FILE_FILL_STATUS |
T_STK_TRANSACTION_ID |
TabButton |
TabButtonView | Describes the view of a TabButton
TabControl |
TabControlView |
tagCPGlyph |
tagCustFileData |
tagCustomizationPack |
tagDataPackHeader |
tagFilePackData |
tagFont |
tagFontFamily |
tagFontPack |
TaggedProblemCode | Supplementary Service Problem Tag [GSM 04.80, 3.6.7, Table 3.13]
tagGlyphData |
tagLanguage |
tagLdbData |
tagT9Pack |
tagTextPack |
tagTranslationTable |
TAlphaIdentifier_s |
TAlphaIdentifierArray |
Task |
TcpNetAdapter |
TcpServerSocket |
TcpServerTestSocket |
TcpSocket |
TcpSocketBase |
TcpTestSocket |
TelecaVrEngineParams |
TermRspCnfArg |
TermRspCnfMsg |
TestCheckBoxListView |
TestCheckBoxView |
TestControlFrameView |
TestparamReport |
TestparamReportArg |
TestparamReqArg |
TestPositionIndicatorView |
TestPushButtonView |
TestRadioButtonListView |
TestRadioButtonView |
TestSoftkeyBarView |
TestTheme | Obsolete theme - replaced by themes in Apoxi/GlobalThemes
TestWindowFrameView |
TestWriter |
TextBox |
TextBoxView |
TextCompoundItem | Contains a variable number of wide-characters
TextEditorDocument |
TextFormat |
TextIconPairArray |
TextIconPairArray::TextIconPair |
TextIndicator | Indicator that displays an text
TextLine |
TextLineView | View object which draws a textline
TextList |
TextListLine |
TextListModel | Describes the model of a textlist
TextListView | Describes the view of a textlist
TextMenuAccessor |
TextPack |
TextPackConnector |
ThaiTextRenderer |
ThaiTextRenderer::ThaiFontHint |
Theme |
ThemeChangedMsg |
ThemeConfig |
ThemeManager | The theme-manager is able to switch between different themes
ThemeViewIterator |
Thread |
Threadlet |
ThreadletNotificationMsg |
ThreadSafeProvider |
Ticks | Ticks is a convertion class between OS specific tick values and milliseconds
TickValue |
Time |
Time::Persist |
TimeCompoundItem | Contains a time
TimeEditBox | Obsolete - use TimeEditor from Gui instead
TimeEditBoxModel | Describes the model of a time editbox
TimeEditBoxView | Describes the view of a time editbox
TimeEditor |
TimeEditorDocument | A Time-Editor-Document contains a Time-Compound-Item
TimeFeatureObject |
TimeoutCondition |
Timer |
TimerTimeoutMsg |
TimeSpan |
TimeZone |
TimeZoneAndTime |
TimeZoneMsg |
TipdBasedActiveWaitDispatcher |
Tlv | Simple TLV (TagLengthValue) objects - GSM 11.14 [12]
TMsapPackedDataArray |
ToDoApp |
ToDoComposeWin |
ToDoDateDialogWin |
ToDoListWin | This class declares a new kind of window derived from class MmiItemListWindow
ToDoPriorityDialogWin |
ToDoProvider |
ToDoRecord |
ToDoRecord::Persist |
ToggleActionGroup | Handles unique selection of abstract toggle actions
ToneAudioDevice |
ToneAudioDevice::StartParam | Start paramter
ToneAudioDevice::UserTone | User tone
TopLevelMenu |
ToStackMsg |
Tpdu |
TpduCache |
TpduConc | TpduConc (ms.h: T_PDU_CONCATENATED)
TpduHeaderInformation |
TpduNode | TpduNode (ms.h: T_PDU_NODE)
TpduPhoneNumberPersist |
TraceOutputStream |
TRadioButtonItem< Content > |
TRadioButtonList< Content > |
Transaction |
TransferLocationDialog | Class for transfer location window
TransportNotificationMsg |
Trap |
TriggerKeyFeature | This features posts a key down message with a given key code. It can be used to send key events from a menu item, since this feature can be used in a menu
TriggerTimer< T > |
TSiIconID_s |
TSiUrl_s |
TtyInterface |
TypeOfAddress | Type-of-Address (TON/NPI) - 3GPP TS 23.040 V5.1.0 [9.2.3.9]
UdpNetAdapter |
UdpSocket |
UdpTestSocket |
UibAccessorTest |
UibActionAccessor |
UibApp |
UibFolderWin |
UibInboxProvider |
UibInboxTest |
UibListBoxModel |
UibMsgDisplayTest |
UibNotifyMsg |
UibNotifyTest |
UibPerformanceTest |
UibRegisterMsg |
UibServiceImpl |
UibSettingsProvider |
UibSettingsRecord |
UibSettingsTest |
UibSettingsWin |
UibSortingTest |
UibTest1 |
UibTest2 |
UibUpdateMsg |
UibUpdateThreadlet |
UmtsCellList |
UmtsMeasEvalParam |
UmtsMeasIdParam |
UmtsNcellParam |
UmtsNcellParamList |
UmtsRrcScellParam |
UndefinedSsAction |
UnlockAction |
UnsignedValue | Structure for storing unsigned values
Unzipper |
UpdateContextItemMsg |
UpdateItemMsg |
UpdatePbThreadlet |
Uplmn |
Uri | Uri class defines the functionalities fo the class
UriMappingTable | UriMappingTable
UsbApp |
UsbObexServerAddr |
UsbObexTransport |
UsbSubSystem |
UsbTransport |
UserActivityEventArg |
UserActivityListener |
UserData |
UserDataHeader |
UserDispatcher |
UsimCardTypeReadIndArg |
UsimCardTypeReadReqArg |
UsimCsLociReadIndArg |
UsimCsLociReadReqArg |
UsimEccReadIndArg |
UsimEccReadReqArg |
UsimEccRecord |
UsimEst |
UsimEstReadIndArg |
UsimEstReadReqArg |
UsimFileProperty |
UsimFilePropertyIndArg |
UsimFilePropertyReqArg |
UsimLangReadIndArg |
UsimLangReadReqArg |
UsimLanguage |
UsimLanguageList |
UsimLangUpdIndArg |
UsimLangUpdReqArg |
UsimPbChangedField |
UsimPbFillStatus |
UsimPbFillStatusReqArg |
UsimPbFillStatusResArg |
UsimPbGroups |
UsimPbLocationIndArg |
UsimPbLocationReqArg |
UsimPbLocReport |
UsimPbReadAsyncIndArg |
UsimPbReadCnfArg |
UsimPbReadDataAsyncIndArg |
UsimPbReadDataReqArg |
UsimPbReadDataResArg |
UsimPbReadRefAsyncIndArg |
UsimPbReadRefReqArg |
UsimPbReadRefResArg |
UsimPbReadReqArg |
UsimPbReadResArg |
UsimPbReadyIndArg |
UsimPbReadyMsg |
UsimPbRefRecord |
UsimPbResetedMsg |
UsimPbRwRecord |
UsimPbSelectReqArg |
UsimPbSelectResArg |
UsimPbStopReqArg |
UsimPbStopResArg |
UsimPbUidRefreshIndArg |
UsimPbUpdDataReqArg |
UsimPbUpdDataResArg |
UsimPbUpdRefReqArg |
UsimPbUpdRefResArg |
UsimPbUpdReqArg |
UsimPbUpdResArg |
UsimPlmn |
UsimPlmnList |
UsimPlmnReadIndArg |
UsimPlmnReadReqArg |
UsimPlmnUpdIndArg |
UsimPlmnUpdReqArg |
UsimPsLociReadIndArg |
UsimPsLociReadReqArg |
UsimReadRecordRejArg |
UsimReadRejArg |
UsimSmsParamExtIndArg |
UsimSmsParamReadIndArg |
UsimSmsParamReadReqArg |
UsimSmsParamUpdIndArg |
UsimSmsParamUpdReqArg |
UsimUpdCnfArg |
UsimUpdRejArg |
UsimUst |
UsimUstReadIndArg |
UsimUstReadReqArg |
UssdAction |
UssdAnswerIndArg |
UssdAnswerMsg |
UssDataArg | Indication of received unstrucured supplementary service data
UssDataReceivedMsg |
UssdBeginMsg |
UssdControlIndMsg |
UssdDataMsg |
UssdEndMsg |
UssdHandler |
UssdIndicationMsg |
UssdNotifyMsg |
UssdRequestMsg |
UssdRequestResentMsg |
UssdResentMsg |
UtcStatusMessage |
UtcTime |
UusErasedMsg |
UusHandler |
UusNotificationMsg |
UusQueryRejectedMsg |
UusRegisteredMsg |
UusStatusMsg |
UusText |
ValidityPeriod |
ValidityPeriodFormat | 3GPP 23.040 V5.1.0 [9.2.3.3]
ValueIndicator | Indicator that has several qualities
ValueMappingPropertyDescriptor< T_Container > |
ValueTextMap |
ValueTextMap::Table |
VCard |
VCardItem |
VCardParser |
VCardWriter |
Vector< T > |
Vector< T >::Iterator | Iterator can be used to iterate elements of a vector
VersionInfo |
VersionInfo::Data |
VeryLongKeyPressMsg |
VibratorDevice |
VideoCamera |
VideoCaptureParameters |
VideoChannel |
VideoDecoder |
VideoEncoder |
VideoEncoder::VideoEncoderDynParameters |
VietnameseTextRenderer |
View |
ViewfinderErrorMsg |
VirtualDisplay |
VmParam |
VoiceMemoApp |
VoiceMemoAudioDevice |
VoiceMemoAudioDevice::StartParam | Start paramter
VoiceMemoMenuAccessor |
VoiceMemoRecordWin |
VoiceMemoWin |
VrAbortEngineIndArg |
VrEngineParams |
VrErrorIndArg |
VrErrorMsg |
VrG2AResultIndArg |
VrHandler | Interface for Apoxi VR usage
VrInitCnfArg |
VrIntrmRecResultIndArg |
VrLoadTemplateReqArg |
VrParamReqArg |
VrPlaybackFinishedMsg |
VrPromptMsg |
VrPropertyResultIndArg |
VrRecognitionAbortedMsg |
VrRecognitionFailedMsg |
VrRecognitionStoppedMsg |
VrRecogResultIndArg |
VrResultMsg |
VrSayNameIndArg |
VrStackMsgArgTableDestroyTableNode |
VrStopRecogIndArg |
VrStoreTemplateReqArg |
VrTrainingAbortedMsg |
VrTrainingFailedMsg |
VrTrainingResultMsg |
VrTrainResultIndArg |
VrWarningIndArg |
VrWarningMsg |
WaitSsAction |
WapHandler |
WapProfile |
WapProfile::Ipv4E164 |
WapProfile::PxLogicalCharacs |
WapProfile::PxLogicalCharacs::PxAuthInfoCharacs |
WapProfile::PxLogicalCharacs::PxPhysicalCharacs |
WapProfile::PxLogicalCharacs::PxPortCharacs |
WapProfileMgr |
WapProfileMgr::WapProfileInfo |
WbmpImage |
WbxmlParserRel |
WbxmlRelHandler |
WbxmlVector< T > |
Window |
WindowFrameView |
WindowHierarchyIterator |
WindowManager |
WinMenuItem |
WinRect |
WStrData |
WString |
XCallInfoResponseParser |
XMLParser |
XmlParserRel |
Zi8AddWordMsg |
Zi8AlphabetBox |
Zi8AlphabetBoxView |
Zi8EnteredUnknownWordMsg |
Zi8InputConfig |
Zi8InputMapper |
Zi8NoWordFoundMsg |
Zi8PredictiveInputBox |
Zi8SelectionBox |
Zi8SelectionBoxView |
Zi8StrokeBox |
Zi8StrokeBoxView |
Zi8Wrapper |
Generated on Wed Jan 25 00:53:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: _ApplicationTracer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

_ApplicationTracer Class Reference
[Kernel]

#include <Apoxi/Kernel/ApplicationTracer.hpp>

Public Member Functions

_ApplicationTracer (const void *app)
void | TraceAttach (const void *app, const void *container, const WCHAR *appName)
void | TraceDetach (const void *app)

Static Public Member Functions

static unsigned char | GetCurApplicationID ()

Constructor & Destructor Documentation

_ApplicationTracer::_ApplicationTracer ( const void * app ) [inline]

creates a unique ID for the application

Member Function Documentation

UINT8 _ApplicationTracer::GetCurApplicationID ( ) [static]

returns the Application ID of the current application context This method is used by all trace methods to determine the context

void _ApplicationTracer::TraceAttach | ( | const void * | app,
 |  | const void * | container,
 |  | const WCHAR * | appName
 | ) | [inline]

Has to be called when the application has attached to a container

void _ApplicationTracer::TraceDetach ( const void * app ) [inline]

Has to be called when the application is detached

The documentation for this class was generated from the following files:
  • Kernel/ApplicationTracer.hpp
  • Kernel/ApplicationTracer.cpp
Generated on Wed Jan 25 00:54:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: _FunctionTracer< mask > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

_FunctionTracer< mask > Class Template Reference
[Kernel]

#include <Apoxi/Kernel/FunctionTracer.hpp>

Public Member Functions

_FunctionTracer (const void *this_ptr)
_FunctionTracer ()
void | StackTrace ()
void | TraceCheckPoint ()
void | TraceVariable (const WCHAR *str)
void | TraceVariable (const char *str)
void | TraceVariable (const unsigned char &val)
void | TraceVariable (const char &val)
void | TraceVariable (const unsigned short &val)
void | TraceVariable (const short &val)
void | TraceVariable (const unsigned int &val)
void | TraceVariable (const int &val)
void | TraceVariable (const unsigned long &val)
void | TraceVariable (const long &val)
template<class T>
void | TraceVariable (const T &obj)
~_FunctionTracer ()

Static Public Member Functions

static void | TraceDelete (const void *linkreg, const void *ptr)
static void | TraceError (const CHAR *str)
static void | TraceMessage (UINT16 id, const void *ptr, UINT16 size)
static void | TraceNew (const void *linkreg, const void *ptr, UINT16 size)
static void | TraceObjectCreate (const void *ptr)
static void | TraceObjectDestroy (const void *ptr)
static void | TraceTestState (UINT16 testID, const CHAR *str, const void *linkreg)
static void | TraceVersion (const CHAR *str)
static void | TraceWarning (const CHAR *str)

template<InternalTracer::TraceMask mask>
class _FunctionTracer< mask >

Constructor & Destructor Documentation

template<InternalTracer::TraceMask mask>
_FunctionTracer< mask >::_FunctionTracer ( ) [inline]

template<InternalTracer::TraceMask mask>
_FunctionTracer< mask >::_FunctionTracer ( const void * this_ptr ) [inline]

template<InternalTracer::TraceMask mask>
_FunctionTracer< mask >::~_FunctionTracer ( ) [inline]

Member Function Documentation

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::StackTrace ( ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceCheckPoint ( ) [inline]

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceDelete | ( | const void * | linkreg,
 |  | const void * | ptr
 | ) | [inline, static]

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceError ( const CHAR * str ) [inline, static]

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceMessage | ( | UINT16 | id,
 |  | const void * | ptr,
 |  | UINT16 | size
 | ) | [inline, static]

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceNew | ( | const void * | linkreg,
 |  | const void * | ptr,
 |  | UINT16 | size
 | ) | [inline, static]

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceObjectCreate ( const void * ptr ) [inline, static]

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceObjectDestroy ( const void * ptr ) [inline, static]

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceTestState | ( | UINT16 | testID,
 |  | const CHAR * | str,
 |  | const void * | linkreg
 | ) | [inline, static]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const WCHAR * str ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const char * str ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const unsigned char & val ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const char & val ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const unsigned short & val ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const short & val ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const unsigned int & val ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const int & val ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const unsigned long & val ) [inline]

template<InternalTracer::TraceMask mask>
void _FunctionTracer< mask >::TraceVariable ( const long & val ) [inline]

Writes the current value of the variable to the trace output For each integral type there exists a method

template<InternalTracer::TraceMask mask>
template<class T>
void _FunctionTracer< mask >::TraceVariable ( const T & obj ) [inline]

Writes the current internal state of all members of the given object to the trace output. When the object contains pointer to types only the address is written. If the pointer values are also needed, successive calls of TraceVariable for the pointer members have to be done.

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceVersion ( const CHAR * str ) [inline, static]

template<InternalTracer::TraceMask mask>
static void _FunctionTracer< mask >::TraceWarning ( const CHAR * str ) [inline, static]

The documentation for this class was generated from the following file:
  • Kernel/FunctionTracer.hpp
Generated on Wed Jan 25 00:54:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: _JUMP_BUFFER Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

_JUMP_BUFFER Struct Reference

#include <Apoxi/Kernel/Os/Nuc32/Scheduler.hpp>

Data Fields

jmp_buf buf

Field Documentation

jmp_buf _JUMP_BUFFER::buf

The documentation for this struct was generated from the following file:
  • Kernel/Os/Nuc32/Scheduler.hpp
Generated on Wed Jan 25 00:54:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: _NullApplicationTracer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

_NullApplicationTracer Class Reference
[Kernel]

#include <Apoxi/Kernel/ApplicationTracer.hpp>

Public Member Functions

_NullApplicationTracer (const void *app)
void | TraceAttach (const void *app, const void *container, const WCHAR *appName)
void | TraceDetach (const void *app)
void | TraceMessage (const void *msg)

Static Public Member Functions

static UINT8 | GetCurApplicationID ()

Constructor & Destructor Documentation

_NullApplicationTracer::_NullApplicationTracer ( const void * app ) [inline]

Member Function Documentation

static UINT8 _NullApplicationTracer::GetCurApplicationID ( ) [inline, static]

void _NullApplicationTracer::TraceAttach | ( | const void * | app,
 |  | const void * | container,
 |  | const WCHAR * | appName
 | ) | [inline]

void _NullApplicationTracer::TraceDetach ( const void * app ) [inline]

void _NullApplicationTracer::TraceMessage ( const void * msg ) [inline]

The documentation for this class was generated from the following file:
  • Kernel/ApplicationTracer.hpp
Generated on Wed Jan 25 00:54:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: _NullFunctionTracer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

_NullFunctionTracer Class Reference
[Kernel]

#include <Apoxi/Kernel/FunctionTracer.hpp>

Public Member Functions

_NullFunctionTracer (const void *this_ptr)
_NullFunctionTracer ()
void | StackTrace ()
void | TraceCheckPoint ()
template<class T>
void | TraceVariable (const T &obj)
~_NullFunctionTracer ()

Static Public Member Functions

static void | TraceDelete (const void *linkreg, const void *ptr)
static void | TraceError (const CHAR *str)
static void | TraceMessage (int id, const void *ptr, UINT16 size)
static void | TraceNew (const void *linkreg, const void *ptr, UINT16 size)
static void | TraceObjectCreate (const void *ptr)
static void | TraceObjectDestroy (const void *ptr)
static void | TraceTestState (UINT16 testID, const CHAR *str, const void *linkreg)
static void | TraceVersion (const CHAR *str)
static void | TraceWarning (const CHAR *str)

Constructor & Destructor Documentation

_NullFunctionTracer::_NullFunctionTracer ( ) [inline]

_NullFunctionTracer::_NullFunctionTracer ( const void * this_ptr ) [inline]

_NullFunctionTracer::~_NullFunctionTracer ( ) [inline]

Member Function Documentation

void _NullFunctionTracer::StackTrace ( ) [inline]

void _NullFunctionTracer::TraceCheckPoint ( ) [inline]

static void _NullFunctionTracer::TraceDelete | ( | const void * | linkreg,
 |  | const void * | ptr
 | ) | [inline, static]

static void _NullFunctionTracer::TraceError ( const CHAR * str ) [inline, static]

static void _NullFunctionTracer::TraceMessage | ( | int | id,
 |  | const void * | ptr,
 |  | UINT16 | size
 | ) | [inline, static]

static void _NullFunctionTracer::TraceNew | ( | const void * | linkreg,
 |  | const void * | ptr,
 |  | UINT16 | size
 | ) | [inline, static]

static void _NullFunctionTracer::TraceObjectCreate ( const void * ptr ) [inline, static]

static void _NullFunctionTracer::TraceObjectDestroy ( const void * ptr ) [inline, static]

static void _NullFunctionTracer::TraceTestState | ( | UINT16 | testID,
 |  | const CHAR * | str,
 |  | const void * | linkreg
 | ) | [inline, static]

template<class T>
void _NullFunctionTracer::TraceVariable ( const T & obj ) [inline]

static void _NullFunctionTracer::TraceVersion ( const CHAR * str ) [inline, static]

static void _NullFunctionTracer::TraceWarning ( const CHAR * str ) [inline, static]

The documentation for this class was generated from the following file:
  • Kernel/FunctionTracer.hpp
Generated on Wed Jan 25 00:54:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbortResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbortResArg Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonArgs.hpp>

Inheritance diagram for AbortResArg:

[legend]
Collaboration diagram for AbortResArg:

[legend]

Public Types

enum | { ID = 4200 }

Public Member Functions

AbortResArg ()
~AbortResArg ()

Static Public Member Functions

static const AbortResArg & | Cast (const StackMsgArgument &arg)

Friends

class | LcsCommonStackMsgArgsDestroyTableNode

Detailed Description

This argument is sent to the dispatcher on receipt of MN_LCS_ABORT_RSP SDL signal from Lcs stack

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AbortResArg::AbortResArg ( )

AbortResArg::~AbortResArg ( )

Member Function Documentation

const AbortResArg & AbortResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class LcsCommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonArgs.hpp
  • AddOns/Lcs/Common/LcsCommonArgs.cpp
Generated on Wed Jan 25 00:54:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbortResMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbortResMsg Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>

Inheritance diagram for AbortResMsg:

[legend]
Collaboration diagram for AbortResMsg:

[legend]

Public Types

enum | { ID = 4208 }

Public Member Functions

AbortResMsg (ExecutionContext *context)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AbortResMsg ()

Detailed Description

This message is sent to the MMI application upon the receipt of abortion response

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AbortResMsg::AbortResMsg ( ExecutionContext * context )

AbortResMsg::~AbortResMsg ( ) [virtual]

Member Function Documentation

Message * AbortResMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AbortResMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonMsgTypes.hpp
  • AddOns/Lcs/Common/LcsCommonMsgTypes.cpp
Generated on Wed Jan 25 00:54:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractActionMenuAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractActionMenuAccessor Class Reference
[GUI Menu Accessors]

#include <Apoxi/AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp>

Inheritance diagram for AbstractActionMenuAccessor:

[legend]
Collaboration diagram for AbstractActionMenuAccessor:

[legend]

Public Member Functions

AbstractActionMenuAccessor (const WCHAR *title)
AbstractActionMenuAccessor ()
virtual Action * | GetAction ()=0
virtual const BitmapRes * | GetItemIcon (BOOLEAN highlighted)
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
void | Init (const WCHAR *title)
virtual BOOLEAN | IsEnabled ()
virtual void | Trigger (Menu *menu)
~AbstractActionMenuAccessor ()

Protected Member Functions

virtual AbstractMenuAccessor * | GetChild ()
virtual void | OnLanguageChanged ()
virtual void | OnTrigger (INT selected_idx)

Detailed Description

Obsolete - the class Menu, which uses the AbstractActionMenuAccessor, has been replaced by the classes ItemMenu and ItemTree.

Abstract base class for a menu-accessor based on Actions. The methods MenuAccessor::First, MenuAccessor::Next and AbstractActionMenuAccessor::GetAction must be implemented.

See also:
MenuAccessor

ActionMenuAccessor

Constructor & Destructor Documentation

AbstractActionMenuAccessor::AbstractActionMenuAccessor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractActionMenuAccessor::AbstractActionMenuAccessor ( const WCHAR * title )

AbstractActionMenuAccessor::~AbstractActionMenuAccessor ( )

Member Function Documentation

virtual Action* AbstractActionMenuAccessor::GetAction ( ) [pure virtual]

Implemented in ActionMenuAccessor.

AbstractMenuAccessor * AbstractActionMenuAccessor::GetChild ( ) [protected, virtual]

See also:
AbstractMenuAccessor::GetChild

Reimplemented from MenuAccessor.

const BitmapRes * AbstractActionMenuAccessor::GetItemIcon ( BOOLEAN highlighted ) [virtual]

See also:
MenuAccessor::GetItemIcon

Reimplemented from MenuAccessor.

const WCHAR * AbstractActionMenuAccessor::GetItemText ( BOOLEAN highlighted ) [virtual]

See also:
MenuAccessor::GetItemText

Reimplemented from MenuAccessor.

void AbstractActionMenuAccessor::Init ( const WCHAR * title )

Reimplemented from MenuAccessor.

BOOLEAN AbstractActionMenuAccessor::IsEnabled ( ) [virtual]

See also:
AbstractMenuAccessor::IsEnabled

Reimplemented from AbstractMenuAccessor.

void AbstractActionMenuAccessor::OnLanguageChanged ( ) [protected, virtual]

See also:
AbstractMenuAccessor::OnLanguageChanged

Reimplemented from MenuAccessor.

void AbstractActionMenuAccessor::OnTrigger ( INT selected_idx ) [protected, virtual]

See also:
AbstractMenuAccessor::OnTrigger

Reimplemented from MenuAccessor.

Reimplemented in ActionMenuAccessor.

void AbstractActionMenuAccessor::Trigger ( Menu * menu ) [virtual]

See also:
AbstractMenuAccessor::Trigger

Reimplemented from MenuAccessor.

The documentation for this class was generated from the following files:
  • AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.hpp
  • AddOns/GuiMenuAccessors/AbstractActionMenuAccessor.cpp
Generated on Wed Jan 25 00:54:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractAppContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractAppContext Class Reference
[Kernel]

#include <Apoxi/Kernel/AbstractScheduler.hpp>

Inheritance diagram for AbstractAppContext:

[legend]
Collaboration diagram for AbstractAppContext:

[legend]

Public Member Functions

AbstractAppContext (AbstractScheduler *scheduler, Application *app)
const Application * | GetApplication () const
BOOLEAN | IsRunning () const
virtual void | MsgLoop ()=0
virtual void | SendMsg (Message &msg)=0
virtual void | StartUp ()
void | Stop ()
virtual void | Wait (const Condition &cond)=0
virtual | ~AbstractAppContext ()

Protected Attributes

Application * m_app
BOOLEAN | m_running
AbstractScheduler * m_scheduler

Detailed Description

An AbstractAppContext is attached to each Application by the Scheduler. AbstractAppContext provides the general interface and default implementations, and is meant to be extended by its subclasses.

Constructor & Destructor Documentation

AbstractAppContext::AbstractAppContext | ( | AbstractScheduler * | scheduler,
 |  | Application * | app
 | ) |

Creates an AbstractAppContext

Parameters:
scheduler | pointer to the Scheduler that runs the AbstractAppContext
app | pointer to the Application that will be attached

AbstractAppContext::~AbstractAppContext ( ) [virtual]

Destroys the AbstractAppContext

Member Function Documentation

const Application* AbstractAppContext::GetApplication ( ) const [inline]

Returns:
The attached Application.

BOOLEAN AbstractAppContext::IsRunning ( ) const [inline]

Returns:
TRUE if the AbstractAppContext has been started, and its attached Application is ready to receive Messages.

virtual void AbstractAppContext::MsgLoop ( ) [pure virtual]

Subclasses implement this Message loop, which waits for Messages to be sent. Implementation dependent.

Implemented in AppContext, AppContext, and SimpleAppContext.

virtual void AbstractAppContext::SendMsg ( Message & msg ) [pure virtual]

Wakes up and sends a message to the attached Application. Implementation dependent.

Parameters:
msg A Reference to the Message to be sent

Implemented in AppContext, AppContext, and SimpleAppContext.

void AbstractAppContext::StartUp ( ) [virtual]

Sets up the AbstractAppContext for the attached Application. Subclass implementations should enter MsgLoop when done.

Reimplemented in AppContext, AppContext, and SimpleAppContext.

void AbstractAppContext::Stop ( void ) [inline]

Stops the context. Subclass implementations should stop its MsgLoop.

virtual void AbstractAppContext::Wait ( const Condition & cond ) [pure virtual]

Stops program flow and waits for the Condition to become true. Implementation dependent.

Parameters:
cond A Reference to the Condition to wait for

Implemented in AppContext, AppContext, and SimpleAppContext.

Field Documentation

Application* AbstractAppContext::m_app [protected]

BOOLEAN AbstractAppContext::m_running [protected]

AbstractScheduler* AbstractAppContext::m_scheduler [protected]

The documentation for this class was generated from the following files:
  • Kernel/AbstractScheduler.hpp
  • Kernel/AbstractScheduler.cpp
Generated on Wed Jan 25 00:54:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractButton Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractButton Class Reference
[Components]

#include <Apoxi/Gui/AbstractButton.hpp>

Inheritance diagram for AbstractButton:

[legend]
Collaboration diagram for AbstractButton:

[legend]

Public Types

enum | { ID = 0 }

Public Member Functions

AbstractButton (Control *parent, Action *action)
AbstractButton ()
Action * | GetAction () const
Returns a pointer to the action which will be executed if the button has been released.
const BitmapRes * | GetBitmap () const
Wrapper-method for button.GetAction()->GetBitmap().
const WCHAR * | GetText () const
Wrapper-method for button.GetAction()->GetText().
void | Init (Control *parent, Action *action)
BOOLEAN | IsEnabled () const
Wrapper-method for button.GetAction()->IsEnabled().
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsPressed () const
void | SetAction (Action *action)
void | SetBitmap (const BitmapRes *bitmap)
Wrapper-method for button.GetAction()->SetBitmap(bitmap).
void | SetEnabled (BOOLEAN enabled)
Wrapper-method for button.GetAction()->SetEnabled(enabled).
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetText (const WCHAR *text)
Wrapper-method for button.GetAction()->SetText(text).
void | Trigger ()
virtual | ~AbstractButton ()

Protected Member Functions

Action * | GetAbstractAction () const
Obsolete - use AbstractAction::GetAction instead.
virtual void | OnClick ()
Is called, if the button goes down.
virtual void | OnLanguageChanged ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnRelease ()
Is called, if the button goes up.
void | SetAbstractAction (Action *action)
Obsolete - use AbstractAction::SetAction instead.

Detailed Description

Is the abstract base class of button controls. Every button control may have an instance of the class Action, which is executed when the button control is triggered.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Control.

Constructor & Destructor Documentation

AbstractButton::AbstractButton ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractButton::AbstractButton | ( | Control * | parent,
 |  | Action * | action
 | ) |

Parameters:
parent | Pointer to the window, which embedds the PushButton.
action | Action, which will be executed, if the button has been released.

AbstractButton::~AbstractButton ( ) [virtual]

Member Function Documentation

Action* AbstractButton::GetAbstractAction ( ) const [inline, protected]

Obsolete - use AbstractAction::GetAction instead.

Action* AbstractButton::GetAction ( ) const [inline]

Returns a pointer to the action which will be executed if the button has been released.

Reimplemented in PushButton.

const BitmapRes * AbstractButton::GetBitmap ( ) const

Wrapper-method for button.GetAction()->GetBitmap().

const WCHAR * AbstractButton::GetText ( ) const

Wrapper-method for button.GetAction()->GetText().

void AbstractButton::Init | ( | Control * | parent,
 |  | Action * | action
 | ) |

Parameters:
parent | Pointer to the window, which embedds the PushButton.
action | Action, which will be executed, if the button has been released.

Reimplemented in PushButton.

BOOLEAN AbstractButton::IsEnabled ( ) const

Wrapper-method for button.GetAction()->IsEnabled().

BOOLEAN AbstractButton::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Control.

Reimplemented in CheckBoxControl, PushButton, RadioButtonControl, and TabButton.

BOOLEAN AbstractButton::IsPressed ( ) const [inline]

Returns TRUE, if the button is pressed, which means that OnClick has been triggered.

void AbstractButton::OnClick ( ) [protected, virtual]

Is called, if the button goes down.

void AbstractButton::OnLanguageChanged ( ) [protected, virtual]

Translates the text of the action.

See also:
Control::OnLanguageChanged

Reimplemented from Control.

BOOLEAN AbstractButton::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Component.

void AbstractButton::OnRelease ( ) [protected, virtual]

Is called, if the button goes up.

void AbstractButton::SetAbstractAction ( Action * action ) [inline, protected]

Obsolete - use AbstractAction::SetAction instead.

void AbstractButton::SetAction ( Action * action )

Sets the action which will be executed if the button has been released.

Reimplemented in PushButton.

void AbstractButton::SetBitmap ( const BitmapRes * bitmap )

Wrapper-method for button.GetAction()->SetBitmap(bitmap).

void AbstractButton::SetEnabled ( BOOLEAN enabled )

Wrapper-method for button.GetAction()->SetEnabled(enabled).

BOOLEAN AbstractButton::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from Control.

Reimplemented in CheckBoxControl, PushButton, RadioButtonControl, and TabButton.

void AbstractButton::SetText ( const WCHAR * text )

Wrapper-method for button.GetAction()->SetText(text).

void AbstractButton::Trigger ( )

Invokes the methods OnClick and OnRelease, which is useful when the button should be triggered externally by e. g. a softkey.

The documentation for this class was generated from the following files:
  • Gui/AbstractButton.hpp
  • Gui/AbstractButton.cpp
Generated on Wed Jan 25 00:54:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractDelegationProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractDelegationProvider Class Reference

#include <Apoxi/Auxiliary/AbstractDelegationProvider.hpp>

Inheritance diagram for AbstractDelegationProvider:

[legend]
Collaboration diagram for AbstractDelegationProvider:

[legend]

Public Types

typedef Provider | Base

Public Member Functions

AbstractDelegationProvider (Provider *child_provider)
AbstractDelegationProvider ()
virtual BOOLEAN | AppendRow ()
virtual INT | ColumnCount () const
virtual BOOLEAN | CommitRow (INT row)
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
virtual BOOLEAN | DeleteRow (INT row)
virtual INT | GetBaseRow (INT row)
Provider * | GetChildProvider () const
GetChildProvider returns the underlaying child-provider.
virtual BOOLEAN | GetChildRow (INT &childrow, INT row)=0
virtual const ColumnInfo * | GetColumnInfo (INT id)
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)=0
INT | GetNewChildRow () const
virtual INT | GetProgress ()
virtual INT | GetProviderId () const
GetProviderId() reflects the provider Id of the child-provider.
virtual INT | GetSortedColumnId () const
If the provider is sorted, overwrite GetSortedColumnId and return the column id of the sorted column.
void | Init (Provider *child_provider)
The same interface as the constructor.
virtual BOOLEAN | InsertRow (INT row)
virtual BOOLEAN | IsWStringDataCached () const
Overwrite IsWStringDataCached if the WString data is cached in RAM (necessary for faster sorting).
virtual BOOLEAN | Lock ()
Lock locks the child-provider.
virtual INT | MaxRowCount ()
virtual void | OnExecutingListener (Provider *provider=0)
virtual INT | RowCount ()
virtual BOOLEAN | SelectRow (INT row)
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | SetParameter (const DataItem &item)
virtual BOOLEAN | ToggleRow (INT row)
virtual BOOLEAN | Unlock ()
Unlock unlocks the child-provider.
virtual BOOLEAN | Update (ProviderListener *listener=0)
virtual | ~AbstractDelegationProvider ()

Protected Member Functions

INT | GetIndexTableIndex (IndexTable< INT > *table, INT child_row)
virtual BOOLEAN | GetMappedRow (INT &mappedrow, INT row)
virtual void | OnChildProviderModification (Provider *provider, const Provider::Modification &modification)
virtual void | OnUpdate (ObservableObject *obs_obj)
void | SetChildProvider (Provider *child_provider)
virtual void | SetProgress (INT progress)
Sets the current progress.
void | ShiftIndexTableDown (IndexTable< INT > *idx_table, INT start, INT end)
void | ShiftIndexTableUp (IndexTable< INT > *idx_table, INT start, INT end)
void | ShiftIndexTableValues (IndexTable< INT > *idx_table, INT threshold, BOOLEAN up)
BOOLEAN | UpdateChildProvider ()

Detailed Description

A DelegationProvider is the abstract base class of providers that uses a child-provider, i.e. AbstractDelegationProvider or SortProvider. For this reason, it reflects the columns of the underlaying child-provider.

Member Typedef Documentation

typedef Provider AbstractDelegationProvider::Base

Reimplemented in BubbleSortProvider, CachingSortProvider, ChineseQuickSortProvider, DistinctProvider, FilterProvider, Find2Provider, FindProvider, QuickSortProvider, SortProvider, PbNameFilterProvider, PbNameNumberProvider, PbSimProvider, and PbSortedProvider.

Constructor & Destructor Documentation

AbstractDelegationProvider::AbstractDelegationProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractDelegationProvider::AbstractDelegationProvider ( Provider * child_provider )

On construction the following parameters have to be specified: child_provider: The provider which should be manipulated.

AbstractDelegationProvider::~AbstractDelegationProvider ( ) [virtual]

Member Function Documentation

BOOLEAN AbstractDelegationProvider::AppendRow ( ) [virtual]

AppendRow reflects AppendRow of the child-provider. or FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in AppendProvider, MergeProvider, and PbMergeProvider.

INT AbstractDelegationProvider::ColumnCount ( ) const [virtual]

ColumnCount reflects ColumnCount of the child-provider or 0 if no child-provider was set.

Reimplemented from Provider.

Reimplemented in MergeProvider, and PbSimProvider.

BOOLEAN AbstractDelegationProvider::CommitRow ( INT row ) [virtual]

CommitRow reflects CommitRow of the child-provider. according to GetMappedRow. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in MergeProvider, and DistinctProvider.

BOOLEAN AbstractDelegationProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

DeleteAllRows reflects DeleteAllRows of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in AppendProvider, MergeProvider, FilterProvider, FindProvider, PbMergeProvider, and PbSortedProvider.

BOOLEAN AbstractDelegationProvider::DeleteRow ( INT row ) [virtual]

DeleteRow reflects DeleteRow of the child-provider. according to GetMappedRow. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in MergeProvider, DistinctProvider, and PbMergeProvider.

INT AbstractDelegationProvider::GetBaseRow ( INT row ) [virtual]

GetBaseRow returns the row of the last child-provider or 0 if no child-provider was set.

Reimplemented from Provider.

Provider* AbstractDelegationProvider::GetChildProvider ( ) const [inline]

GetChildProvider returns the underlaying child-provider.

virtual BOOLEAN AbstractDelegationProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [pure virtual]

GetChildRow returns the effective row of the child-provider.

Reimplemented from Provider.

Implemented in AppendProvider, MergeProvider, DistinctProvider, FilterProvider, FindProvider, SortProvider, PbDetailProvider, PbNumberFilterProvider, PbNameNumberProvider, PbSimProvider, SmsBasicProvider, and SmsFolderProvider.

const ColumnInfo * AbstractDelegationProvider::GetColumnInfo ( INT id ) [virtual]

GetColumnInfo reflects GetColumnInfo of the child-provider. Returns 0 if no child-provider was set.

Reimplemented from Provider.

Reimplemented in MergeProvider, and PbSimProvider.

virtual BOOLEAN AbstractDelegationProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [pure virtual]

See also:
Provider::GetDataItem

Implements Provider.

Implemented in AppendProvider, MergeProvider, DistinctProvider, FilterProvider, FindProvider, SortProvider, PbDetailProvider, PbNumberFilterProvider, PbNameFilterProvider, PbNameNumberProvider, PbSimProvider, SmsBasicProvider, SmsFolderProvider, and UibInboxProvider.

INT AbstractDelegationProvider::GetIndexTableIndex | ( | IndexTable< INT > * | table,
 |  | INT | child_row
 | ) | [protected]

BOOLEAN AbstractDelegationProvider::GetMappedRow | ( | INT & | mappedrow,
 |  | INT | row
 | ) | [protected, virtual]

Reflects by default GetChildRow. If a derived provider class implements a multistage manipulation on the child-provider, the child row of the very first stage must be returned.

Reimplemented in AppendProvider, and DistinctProvider.

INT AbstractDelegationProvider::GetNewChildRow ( ) const [inline]

INT AbstractDelegationProvider::GetProgress ( ) [virtual]

GetProgress reflects GetProgress of the child-provider. Returns 0 if no child-provider was set.

Reimplemented from Provider.

Reimplemented in AppendProvider, and PbSimProvider.

INT AbstractDelegationProvider::GetProviderId ( ) const [virtual]

GetProviderId() reflects the provider Id of the child-provider.

Implements Provider.

Reimplemented in AppendProvider, MergeProvider, PbNumberFilterProvider, PbNameFilterProvider, PbNameNumberProvider, and PbSimProvider.

INT AbstractDelegationProvider::GetSortedColumnId ( ) const [virtual]

If the provider is sorted, overwrite GetSortedColumnId and return the column id of the sorted column.

Reimplemented from Provider.

Reimplemented in AppendProvider.

void AbstractDelegationProvider::Init ( Provider * child_provider )

The same interface as the constructor.

Reimplemented in PbNameNumberProvider, SmsBasicProvider, and SmsFolderProvider.

BOOLEAN AbstractDelegationProvider::InsertRow ( INT row ) [virtual]

InsertRow reflects InsertRow of the child-provider. according to GetMappedRow. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in MergeProvider, FilterProvider, and SortProvider.

BOOLEAN AbstractDelegationProvider::IsWStringDataCached ( ) const [virtual]

Overwrite IsWStringDataCached if the WString data is cached in RAM (necessary for faster sorting).

Reimplemented from Provider.

BOOLEAN AbstractDelegationProvider::Lock ( ) [virtual]

Lock locks the child-provider.

Reimplemented from Provider.

Reimplemented in AppendProvider, MergeProvider, and SmsBasicProvider.

INT AbstractDelegationProvider::MaxRowCount ( ) [virtual]

RowCount reflects MaxRowCount of the child-provider or 0 if no child-provider was set.

Reimplemented from Provider.

Reimplemented in AppendProvider, and PbMergeProvider.

void AbstractDelegationProvider::OnChildProviderModification | ( | Provider * | provider,
 |  | const Provider::Modification & | modification
 | ) | [protected, virtual]

Reimplemented in AppendProvider, MergeProvider, FilterProvider, FindProvider, and SortProvider.

void AbstractDelegationProvider::OnExecutingListener ( Provider * provider = 0 ) [virtual]

Called by DelegationProviderListener to modify the progress value. The current version reflects the progress value of the specified provider, or if it is 0, the progress value of the child-provider.

Reimplemented in AppendProvider, MergeProvider, FilterProvider, FindProvider, and SortProvider.

void AbstractDelegationProvider::OnUpdate ( ObservableObject * obs_obj ) [protected, virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from Observer.

Reimplemented in UibInboxProvider.

INT AbstractDelegationProvider::RowCount ( ) [virtual]

RowCount reflects RowCount of the child-provider or 0 if no child-provider was set.

Implements Provider.

Reimplemented in AppendProvider, FilterProvider, FindProvider, PbDetailProvider, and PbNumberFilterProvider.

BOOLEAN AbstractDelegationProvider::SelectRow ( INT row ) [virtual]

SelectRow reflects SelectRow of the child-provider. according to GetMappedRow. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in MergeProvider.

void AbstractDelegationProvider::SetChildProvider ( Provider * child_provider ) [protected]

BOOLEAN AbstractDelegationProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

SetDataItem reflects SetDataItem of the child-provider. according to GetMappedRow. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in MergeProvider, and DistinctProvider.

BOOLEAN AbstractDelegationProvider::SetParameter ( const DataItem & item ) [virtual]

GetColumnInfoPerId reflects GetColumnInfoPerId of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in AppendProvider, DualFilterProvider, MergeProvider, FilterProvider, PbNumberFilterProvider, PbMergeProvider, and PbNameFilterProvider.

void AbstractDelegationProvider::SetProgress ( INT progress ) [protected, virtual]

Sets the current progress.

void AbstractDelegationProvider::ShiftIndexTableDown | ( | IndexTable< INT > * | idx_table,
 |  | INT | start,
 |  | INT | end
 | ) | [protected]

void AbstractDelegationProvider::ShiftIndexTableUp | ( | IndexTable< INT > * | idx_table,
 |  | INT | start,
 |  | INT | end
 | ) | [protected]

void AbstractDelegationProvider::ShiftIndexTableValues | ( | IndexTable< INT > * | idx_table,
 |  | INT | threshold,
 |  | BOOLEAN | up
 | ) | [protected]

BOOLEAN AbstractDelegationProvider::ToggleRow ( INT row ) [virtual]

ToggleRow reflects ToggleRow of the child-provider. according to GetMappedRow. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in MergeProvider.

BOOLEAN AbstractDelegationProvider::Unlock ( ) [virtual]

Unlock unlocks the child-provider.

Reimplemented from Provider.

Reimplemented in AppendProvider, MergeProvider, and SmsBasicProvider.

BOOLEAN AbstractDelegationProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update updates the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from Provider.

Reimplemented in AppendProvider, MergeProvider, BubbleSortProvider, CachingSortProvider, ChineseQuickSortProvider, DistinctProvider, FilterProvider, Find2Provider, FindProvider, QuickSortProvider, SortProvider, PbDetailProvider, PbNumberFilterProvider, PbMergeProvider, PbNameFilterProvider, and PbSortedProvider.

BOOLEAN AbstractDelegationProvider::UpdateChildProvider ( ) [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/AbstractDelegationProvider.hpp
  • Auxiliary/AbstractDelegationProvider.cpp
Generated on Wed Jan 25 00:54:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractDevice Class Reference
[Devices]

#include <Apoxi/Devices/AbstractDevice.hpp>

Inheritance diagram for AbstractDevice:

[legend]
Collaboration diagram for AbstractDevice:

[legend]

Public Types

enum Category {
DisplayCategory = 0, StillCameraCategory = 1, VideoCameraCategory = 2, KeyboardCategory = 3,
LedCategory = 4, ChargerCategory = 5, RealTimeClockCategory = 6, CodecCategory = 7,
CustomCategory = 100
}

Public Member Functions

AbstractDevice (INT category=CustomCategory, INT index=0)
ControlArg | Control (INT command, ControlArg arg)
INT | GetCategory () const
INT | GetIndex () const
virtual const WCHAR * | GetName () const =0
virtual | ~AbstractDevice ()

Protected Member Functions

virtual void | OnStart ()
virtual void | OnStop ()

Friends

class | DeviceManager

Data Structures

union | ControlArg

Detailed Description

Abstract base class for all hardware devices. Each device can have a name and is part of a device category.
See also:
DeviceManager.

Member Enumeration Documentation

enum AbstractDevice::Category

Each device is part of a category. The category describes the purpose of the device. Several instances of devices for one category might exist. The categories can be extended by using values > 100 (see AbstractDevice::GetCategory)

Enumerator:
DisplayCategory
StillCameraCategory
VideoCameraCategory
KeyboardCategory
LedCategory
ChargerCategory
RealTimeClockCategory
CodecCategory
CustomCategory

Constructor & Destructor Documentation

AbstractDevice::AbstractDevice | ( | INT | category = CustomCategory,
 |  | INT | index = 0
 | ) | [explicit]

Parameters:
category | Category of the device (see AbstractDevice::Category). Custom values can be defined, but the values 0 - 100 are reserved for APOXI.
index | Index of the device in relation to the category. One device category can have a variable number of devices. The device category and the device index are a unique key for getting a device instance.

AbstractDevice::~AbstractDevice ( ) [virtual]

Member Function Documentation

ControlArg AbstractDevice::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) |

Generic interface for additional functionality. This method is never called and should be considered as a template for derived Devices.

Parameters:
command | ID for commands
arg | user defined argument
Returns:
user defined return value

INT AbstractDevice::GetCategory ( ) const [inline]

Returns the category of the device (see AbstractDevice::Category). One category can have more than one instance of a device. Per default CustomCategory is returned.

See also:
AbstractDevice::GetIndex

INT AbstractDevice::GetIndex ( ) const [inline]

Returns the index of the device in relation to the category. One device category can have a variable number of devices. The device category and the device index are a unique key for getting a device instance. Per default 0 is returned.

virtual const WCHAR* AbstractDevice::GetName ( ) const [pure virtual]

Returns the name of a device. The name must not be unique and should just give a short description of the device.

Implemented in Audio, Audio, Audio, Audio, Audio, DefaultDisplay, VirtualDisplay, Charger, Fota, Keyboard, Led, BackLight, DefaultDisplay, VirtualDisplay, BackLight, DefaultDisplay, DefaultDisplay, VirtualDisplay, RealTimeClock, BackLight, DefaultDisplay, VirtualDisplay, StillCamera, VideoCamera, AmplifierAudioDevice, DefaultDisplay, GenericAudioDevice, KeyToneAudioDevice, MiscAudioDevice, Mp3AudioDevice, RingerAudioDevice, SpeechAudioDevice, ToneAudioDevice, VirtualDisplay, and VoiceMemoAudioDevice.

void AbstractDevice::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented in Charger, DefaultDisplay, Keyboard, Led, RealTimeClock, Charger, DefaultDisplay, Keyboard, Led, RealTimeClock, Charger, DefaultDisplay, DefaultDisplay, Keyboard, Led, RealTimeClock, Charger, DefaultDisplay, Keyboard, Led, RealTimeClock, Charger, DefaultDisplay, Led, and RealTimeClock.

void AbstractDevice::OnStop ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is shut down. It is recommended that the device removes itself from the DeviceManager by invoking DeviceManager::RemoveDevice(*this) in its destructor.

Reimplemented in DefaultDisplay, RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, DefaultDisplay, RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, and RealTimeClock.

Friends And Related Function Documentation

friend class DeviceManager [friend]

The documentation for this class was generated from the following files:
  • Devices/AbstractDevice.hpp
  • Devices/AbstractDevice.cpp
Generated on Wed Jan 25 00:54:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractDevice::ControlArg Union Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
AbstractDevice::ControlArg

AbstractDevice::ControlArg Union Reference

#include <Apoxi/Devices/AbstractDevice.hpp>

Public Member Functions

ControlArg (void *val)
ControlArg (WCHAR *val)
ControlArg (CHAR *val)
ControlArg (INT32 val)
ControlArg (UINT32 val)
ControlArg (INT16 val)
ControlArg (UINT16 val)
ControlArg (INT8 val)
ControlArg (UINT8 val)
ControlArg (BOOLEAN val)
ControlArg ()

Data Fields

BOOLEAN | m_boolean
CHAR * | m_char_ptr
INT16 | m_int16
INT32 | m_int32
INT8 | m_int8
UINT16 | m_uint16
UINT32 | m_uint32
UINT8 | m_uint8
void * | m_void_ptr
WCHAR * | m_wchar_ptr

Detailed Description

Union for passing parameters to the method AbstractDevice::Control.

Constructor & Destructor Documentation

AbstractDevice::ControlArg::ControlArg ( ) [inline]

AbstractDevice::ControlArg::ControlArg ( BOOLEAN val ) [inline]

AbstractDevice::ControlArg::ControlArg ( UINT8 val ) [inline]

AbstractDevice::ControlArg::ControlArg ( INT8 val ) [inline]

AbstractDevice::ControlArg::ControlArg ( UINT16 val ) [inline]

AbstractDevice::ControlArg::ControlArg ( INT16 val ) [inline]

AbstractDevice::ControlArg::ControlArg ( UINT32 val ) [inline]

AbstractDevice::ControlArg::ControlArg ( INT32 val ) [inline]

AbstractDevice::ControlArg::ControlArg ( CHAR * val ) [inline]

AbstractDevice::ControlArg::ControlArg ( WCHAR * val ) [inline]

AbstractDevice::ControlArg::ControlArg ( void * val ) [inline]

Field Documentation

BOOLEAN AbstractDevice::ControlArg::m_boolean

CHAR* AbstractDevice::ControlArg::m_char_ptr

INT16 AbstractDevice::ControlArg::m_int16

INT32 AbstractDevice::ControlArg::m_int32

INT8 AbstractDevice::ControlArg::m_int8

UINT16 AbstractDevice::ControlArg::m_uint16

UINT32 AbstractDevice::ControlArg::m_uint32

UINT8 AbstractDevice::ControlArg::m_uint8

void* AbstractDevice::ControlArg::m_void_ptr

WCHAR* AbstractDevice::ControlArg::m_wchar_ptr

The documentation for this union was generated from the following file:
  • Devices/AbstractDevice.hpp
Generated on Wed Jan 25 00:54:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractEditBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractEditBox Class Reference

Obsolete - use MultiLineEditor or LineEditor from Gui instead. More...

#include <Apoxi/Compat/AbstractEditBox.hpp>

Inheritance diagram for AbstractEditBox:

[legend]
Collaboration diagram for AbstractEditBox:

[legend]

Public Types

enum | CaptionPos { CaptionOnLeft, CaptionOnTop }
Defines the position of the editors caption. More...

Public Member Functions

AbstractEditBox (Control *parent=0, WCHAR *buffer=0, INT max_text_len=0, const WCHAR *caption=0, CaptionPos caption_pos=CaptionOnTop, BOOLEAN password_mode=FALSE)
WCHAR * | GetBuffer () const
const WCHAR * | GetCaption () const
INT | GetMaxTextLength () const
WCHAR * | GetText () const
void | Init (Control *parent, WCHAR *buffer, INT max_text_len=0, const WCHAR *caption=0, CaptionPos caption_pos=CaptionOnTop, BOOLEAN password_mode=FALSE)
void | SetBuffer (WCHAR *buff)
void | SetCaption (const WCHAR *caption)
void | SetCursorPos (INT cursor_pos)
void | SetMaxTextLength (INT max_text_len)
void | SetPasswordMode (BOOLEAN password_mode)
void | SetText (const WCHAR *text)
virtual | ~AbstractEditBox ()

Protected Member Functions

virtual BOOLEAN | AcceptChar (WCHAR ch, INT insert_idx) const
void | DrawCursor ()
Makes the Cursor visible.
void | EraseCursor ()
Makes the cursor invisible.
WCHAR | GetChar (INT idx=-1) const
XYDIM | GetLineWidth () const
INT | GetNoOfFittingChars (INT start_index, XYDIM width)
const PagingMapEntry & | GetPagingMapEntry (KeyCode key_code) const
virtual const AbstractEditBoxView * | GetView () const =0
BOOLEAN | InsertChar (WCHAR ch, INT insert_idx=-1)
void | InvalidateCursor ()
Causes a repaint of the Cursor.
void | InvalidateText ()
Causes a repaint of the visible input text.
void | InvertCursor ()
Inverts the visibility of the cursor.
BOOLEAN | IsCursorVisible (INT cursor_pos=-1)
BOOLEAN | IsInputValid () const
void | Layout (INT line_index)
virtual void | MoveCursor (INT inc)
void | MoveCursorToLine (INT line)
virtual void | OnBlinkTimer ()
Called, if the cursor should change it's blinking-state.
virtual void | OnCursorDown ()
Called, if the cursor should move one line down.
virtual void | OnCursorLeft ()
Called, if the cursor should move one character left.
virtual void | OnCursorRight ()
Called, if the cursor should move one character right.
virtual void | OnCursorUp ()
Called, if the cursor should move one line up.
virtual void | OnDeleteChar ()
Called, if a character should be deleted.
virtual void | OnGetFocus ()
virtual BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
virtual void | OnLoseFocus ()
virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)
BOOLEAN | ReplaceChar (WCHAR ch, INT replace_idx=-1)
void | SetCursorMode (BOOLEAN paging)
void | SetInputValid (BOOLEAN input_valid)
Each derived editbox has to decide if the currently entered text is valid.

Friends

class | EditBoxBlinkTimer

Detailed Description

Obsolete - use MultiLineEditor or LineEditor from Gui instead.

Member Enumeration Documentation

enum AbstractEditBox::CaptionPos

Defines the position of the editors caption.

Enumerator:
CaptionOnLeft | Caption is on the left side of the edtibox input area.
CaptionOnTop | Caption is above the editbox input area.

Constructor & Destructor Documentation

AbstractEditBox::AbstractEditBox | ( | Control * | parent = 0,
 |  | WCHAR * | buffer = 0,
 |  | INT | max_text_len = 0,
 |  | const WCHAR * | caption = 0,
 |  | CaptionPos | caption_pos = CaptionOnTop,
 |  | BOOLEAN | password_mode = FALSE
 | ) |

Parameters:
model | Pointer to the model of the editor.
parent | Pointer to the window, which embedds the editor.
buffer | Pointer to the text buffer.
max_text_len | Maximal length of the text to edit (Attention: include the terminal zero).
caption | Pointer to the caption.
caption_pos | See description of AbstractEditBox::CaptionPos.

AbstractEditBox::~AbstractEditBox ( ) [virtual]

Member Function Documentation

virtual BOOLEAN AbstractEditBox::AcceptChar | ( | WCHAR | ch,
 |  | INT | insert_idx
 | ) | const [inline, protected, virtual]

Overwrite this method to control the input of each character.

Parameters:
ch | Character to be checked.
insert_idx | Position of the character to be checked.
Returns:
TRUE, if character is accepted.

void AbstractEditBox::DrawCursor ( ) [protected]

Makes the Cursor visible.

void AbstractEditBox::EraseCursor ( ) [protected]

Makes the cursor invisible.

WCHAR* AbstractEditBox::GetBuffer ( ) const [inline]

const WCHAR* AbstractEditBox::GetCaption ( ) const [inline]

Returns:
Pointer to the caption of the EditBox.

WCHAR AbstractEditBox::GetChar ( INT idx = -1 ) const [protected]

Parameters:
idx Position of the character.
Returns:
Character on position idx in the editors buffer.

XYDIM AbstractEditBox::GetLineWidth ( ) const [protected]

Returns:
Maximal width in pixels of any line inside the editbox.

INT AbstractEditBox::GetMaxTextLength ( ) const [inline]

Returns the maximum of allowed characters for the text-buffer. Note that the '' is not counted, hence the size of the text-buffer must be max_text_len + 1.

INT AbstractEditBox::GetNoOfFittingChars | ( | INT | start_index,
 |  | XYDIM | width
 | ) | [protected]

Parameters:
start_index | Index of first character.
width | Area width in pixel.
Returns:
Numer of characters fitting into the given area.

const PagingMapEntry & AbstractEditBox::GetPagingMapEntry ( KeyCode key_code ) const [protected]

Paging means to rotate through a list of characters if a numeric key is pressed repeatedly (only in alphanumeric mode).

Parameters:
key_code Usually the currenty pressed key
Returns:
List of characters to page through for the pressed key.

WCHAR* AbstractEditBox::GetText ( ) const [inline]

Returns:
Gets the editable text.

virtual const AbstractEditBoxView* AbstractEditBox::GetView ( ) const [protected, pure virtual]

Returns:
Currently active view of the editbox.

Reimplemented from Component.

Implemented in DateEditBox, EditBox, and TimeEditBox.

void AbstractEditBox::Init | ( | Control * | parent,
 |  | WCHAR * | buffer,
 |  | INT | max_text_len = 0,
 |  | const WCHAR * | caption = 0,
 |  | CaptionPos | caption_pos = CaptionOnTop,
 |  | BOOLEAN | password_mode = FALSE
 | ) |

See also:
AbstractEditBox::AbstractEditBox

BOOLEAN AbstractEditBox::InsertChar | ( | WCHAR | ch,
 |  | INT | insert_idx = -1
 | ) | [protected]

Parameters:
ch | Character to be replaced.
insert_idx | Position of the character to be inserterd (-1, if the position is the current cursor position).

void AbstractEditBox::InvalidateCursor ( ) [protected]

Causes a repaint of the Cursor.

void AbstractEditBox::InvalidateText ( ) [protected]

Causes a repaint of the visible input text.

void AbstractEditBox::InvertCursor ( ) [protected]

Inverts the visibility of the cursor.

BOOLEAN AbstractEditBox::IsCursorVisible ( INT cursor_pos = -1 ) [protected]

Checks if any part of the Cursor is visible.

Parameters:
cursor_pos Cursor position to check (-1 meams current cursor position).

BOOLEAN AbstractEditBox::IsInputValid ( ) const [inline, protected]

See also:
SetInputValid

Reimplemented in DateEditBox, and TimeEditBox.

void AbstractEditBox::Layout ( INT line_index ) [protected]

The layout of the input text will be refreshed (new word wrapping and line breaking).

Parameters:
line_index Index of line to start the new layouting. Previous lines are left unchanged.

void AbstractEditBox::MoveCursor ( INT inc ) [protected, virtual]

Parameters:
inc Number of characters to move the cursor forward (negative to move backward).

Reimplemented in DateEditBox, EditBox, and TimeEditBox.

void AbstractEditBox::MoveCursorToLine ( INT line ) [protected]

Parameters:
line Moves the cursor to this input line (in multiline editors).

void AbstractEditBox::OnBlinkTimer ( ) [protected, virtual]

Called, if the cursor should change it's blinking-state.

void AbstractEditBox::OnCursorDown ( ) [protected, virtual]

Called, if the cursor should move one line down.

void AbstractEditBox::OnCursorLeft ( ) [protected, virtual]

Called, if the cursor should move one character left.

void AbstractEditBox::OnCursorRight ( ) [protected, virtual]

Called, if the cursor should move one character right.

void AbstractEditBox::OnCursorUp ( ) [protected, virtual]

Called, if the cursor should move one line up.

virtual void AbstractEditBox::OnDeleteChar ( ) [inline, protected, virtual]

Called, if a character should be deleted.

Reimplemented in DateEditBox, EditBox, and TimeEditBox.

void AbstractEditBox::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from Control.

Reimplemented in EditBox.

BOOLEAN AbstractEditBox::OnInputMap ( const InputMapItem & input_map_item ) [protected, virtual]

See also:
Control::OnInputMap

Reimplemented from Control.

Reimplemented in EditBox.

void AbstractEditBox::OnLoseFocus ( ) [protected, virtual]

See also:
Control::OnLoseFocus

Reimplemented from Control.

Reimplemented in EditBox.

void AbstractEditBox::OnThemeChanged ( ) [protected, virtual]

See also:
Winodw::OnThemeChanged

Reimplemented from Control.

void AbstractEditBox::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect &rect)

Reimplemented from Control.

BOOLEAN AbstractEditBox::ReplaceChar | ( | WCHAR | ch,
 |  | INT | replace_idx = -1
 | ) | [protected]

Parameters:
ch | Character to be replaced.
replace_idx | Position of the character to be replaced (-1, if the position is the current cursor position).

void AbstractEditBox::SetBuffer ( WCHAR * buff ) [inline]

void AbstractEditBox::SetCaption ( const WCHAR * caption )

Parameters:
caption Pointer to the caption of the EditBox.

void AbstractEditBox::SetCursorMode ( BOOLEAN paging ) [protected]

Parameters:
paging TRUE, if the cursor should stay on its positon and page through the PagingMapEntry of the currently pressed key. FALSE: no paging.
See also:
GetPagingMapEntry

void AbstractEditBox::SetCursorPos ( INT cursor_pos )

Parameters:
cursor_pos Moves the cursor to the character with this index.

void AbstractEditBox::SetInputValid ( BOOLEAN input_valid ) [inline, protected]

Each derived editbox has to decide if the currently entered text is valid.

void AbstractEditBox::SetMaxTextLength ( INT max_text_len ) [inline]

Sets the maximum of allowed characters for the text-buffer. Note that the '' is not counted, hence the size of the text-buffer must be max_text_len + 1.

void AbstractEditBox::SetPasswordMode ( BOOLEAN password_mode ) [inline]

Parameters:
password_mode If TRUE, all input characters will be presented with '*'.

void AbstractEditBox::SetText ( const WCHAR * text )

Parameters:
text Pointer to the text, which will be copied into the buffer of the editor.

Friends And Related Function Documentation

friend class EditBoxBlinkTimer [friend]

The documentation for this class was generated from the following files:
  • Compat/AbstractEditBox.hpp
  • Compat/AbstractEditBox.cpp
Generated on Wed Jan 25 00:54:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractEditBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractEditBoxModel Class Reference

Describes the model of an editbox. More...

#include <Apoxi/Compat/AbstractEditBox.hpp>

Inheritance diagram for AbstractEditBoxModel:

[legend]
Collaboration diagram for AbstractEditBoxModel:

[legend]

Public Types

typedef Model | Base

Public Member Functions

AbstractEditBoxModel (WCHAR *buff=0, INT max_text_len=0, const WCHAR *caption=0, UINT caption_type=0, BOOLEAN password_mode=FALSE)
void | AppendEmptyLine ()
Appends an empty line to the end of all lines.
void | DeleteChar (INT idx=-1)
WCHAR * | GetBuffer () const
const WCHAR * | GetCaption () const
UINT | GetCaptionType () const
WCHAR | GetChar (INT idx=-1) const
INT | GetCursorPos () const
Returns the position of the cursor (index starts at 0).
INT | GetFirstVisibleIndex () const
INT | GetFirstVisibleLine () const
INT | GetLastVisibleIndex () const
INT | GetLastVisibleLine () const
INT | GetLine (INT char_idx=-1) const
INT | GetLineIndex (INT line) const
INT | GetLineLength (INT line) const
Returns the length of the line line in characters.
INT | GetMaxTextLength () const
INT | GetNoOfLines () const
INT | GetNoOfVisibleLines () const
WCHAR * | GetText () const
Returns a pointer to the text buffer.
INT | GetTextLength () const
void | Init (WCHAR *buff=0, INT max_text_len=0, const WCHAR *caption=0, UINT caption_type=0, BOOLEAN password_mode=FALSE)
BOOLEAN | InsertChar (WCHAR ch, INT insert_idx=-1)
BOOLEAN | IsCursorVisible () const
BOOLEAN | IsIndexVisible (INT index) const
BOOLEAN | IsInputValid () const
Returns TRUE, if the input is valid.
BOOLEAN | IsPaging () const
BOOLEAN | IsPasswordMode () const
void | RemoveEmptyLines ()
Removes empty lines if text is shrinking.
BOOLEAN | ReplaceChar (WCHAR ch, INT replace_idx=-1)
void | Reset ()
void | SetBuffer (WCHAR *buff)
void | SetCaption (const WCHAR *caption)
void | SetCaptionType (UINT caption_type)
void | SetCursorPos (INT i)
Sets the position of the cursor to i (index starts at 0).
void | SetCursorVisible (BOOLEAN state)
void | SetFirstVisibleLine (INT line)
void | SetInputValid (BOOLEAN input_valid)
void | SetLineIndex (INT line, INT index)
void | SetLineLength (INT line, INT length)
void | SetMaxTextLength (INT max_text_len)
void | SetNoOfVisibleLines (INT lines)
void | SetPaging (BOOLEAN paging)
void | SetPasswordMode (BOOLEAN password_mode)
void | SetText (const WCHAR *text)
Sets the text buffer to text.
void | SetTextLength (INT text_len)
virtual | ~AbstractEditBoxModel ()

Detailed Description

Describes the model of an editbox.

Member Typedef Documentation

typedef Model AbstractEditBoxModel::Base

Constructor & Destructor Documentation

AbstractEditBoxModel::AbstractEditBoxModel | ( | WCHAR * | buff = 0,
 |  | INT | max_text_len = 0,
 |  | const WCHAR * | caption = 0,
 |  | UINT | caption_type = 0,
 |  | BOOLEAN | password_mode = FALSE
 | ) |

AbstractEditBoxModel::~AbstractEditBoxModel ( ) [virtual]

Member Function Documentation

void AbstractEditBoxModel::AppendEmptyLine ( )

Appends an empty line to the end of all lines.

void AbstractEditBoxModel::DeleteChar ( INT idx = -1 )

Deletes character, which is under the cursor. For deleting another character, specify idx.

WCHAR* AbstractEditBoxModel::GetBuffer ( ) const [inline]

const WCHAR* AbstractEditBoxModel::GetCaption ( ) const [inline]

UINT AbstractEditBoxModel::GetCaptionType ( ) const [inline]

WCHAR AbstractEditBoxModel::GetChar ( INT idx = -1 ) const

Returns the character of the current cursor-position. For getting a character of another index, specify idx.

INT AbstractEditBoxModel::GetCursorPos ( ) const [inline]

Returns the position of the cursor (index starts at 0).

INT AbstractEditBoxModel::GetFirstVisibleIndex ( ) const [inline]

INT AbstractEditBoxModel::GetFirstVisibleLine ( ) const [inline]

INT AbstractEditBoxModel::GetLastVisibleIndex ( ) const [inline]

INT AbstractEditBoxModel::GetLastVisibleLine ( ) const

INT AbstractEditBoxModel::GetLine ( INT char_idx = -1 ) const

Returns the number of the line which contains the cursor. If the number of the line of a character should be returned, specify the index of the character by char_idx.

INT AbstractEditBoxModel::GetLineIndex ( INT line ) const [inline]

For the first character in the line line the index related to the text buffer is returned.

INT AbstractEditBoxModel::GetLineLength ( INT line ) const [inline]

Returns the length of the line line in characters.

INT AbstractEditBoxModel::GetMaxTextLength ( ) const [inline]

Returns the maximum of allowed characters for the text-buffer. Note that the '' is not counted, hence the size of the text-buffer must be max_text_len + 1.

INT AbstractEditBoxModel::GetNoOfLines ( ) const [inline]

INT AbstractEditBoxModel::GetNoOfVisibleLines ( ) const [inline]

WCHAR* AbstractEditBoxModel::GetText ( ) const [inline]

Returns a pointer to the text buffer.

INT AbstractEditBoxModel::GetTextLength ( ) const [inline]

Returns the length of the text. Note that the '' is not counted.

void AbstractEditBoxModel::Init | ( | WCHAR * | buff = 0,
 |  | INT | max_text_len = 0,
 |  | const WCHAR * | caption = 0,
 |  | UINT | caption_type = 0,
 |  | BOOLEAN | password_mode = FALSE
 | ) |

BOOLEAN AbstractEditBoxModel::InsertChar | ( | WCHAR | ch,
 |  | INT | insert_idx = -1
 | ) |

Inserts the character ch into the current cursor-position. For inserting to another position, specify insert_idx.

BOOLEAN AbstractEditBoxModel::IsCursorVisible ( ) const [inline]

BOOLEAN AbstractEditBoxModel::IsIndexVisible ( INT index ) const [inline]

BOOLEAN AbstractEditBoxModel::IsInputValid ( ) const [inline]

Returns TRUE, if the input is valid.

BOOLEAN AbstractEditBoxModel::IsPaging ( ) const [inline]

BOOLEAN AbstractEditBoxModel::IsPasswordMode ( ) const [inline]

Returns:
See AbstractEditBox::SetPasswordMode.

void AbstractEditBoxModel::RemoveEmptyLines ( )

Removes empty lines if text is shrinking.

BOOLEAN AbstractEditBoxModel::ReplaceChar | ( | WCHAR | ch,
 |  | INT | replace_idx = -1
 | ) |

Replaces the character positioned on the current position with ch. For replacing another character, specify replace_idx.

void AbstractEditBoxModel::Reset ( )

void AbstractEditBoxModel::SetBuffer ( WCHAR * buff ) [inline]

void AbstractEditBoxModel::SetCaption ( const WCHAR * caption ) [inline]

void AbstractEditBoxModel::SetCaptionType ( UINT caption_type ) [inline]

void AbstractEditBoxModel::SetCursorPos ( INT i ) [inline]

Sets the position of the cursor to i (index starts at 0).

void AbstractEditBoxModel::SetCursorVisible ( BOOLEAN state ) [inline]

void AbstractEditBoxModel::SetFirstVisibleLine ( INT line ) [inline]

void AbstractEditBoxModel::SetInputValid ( BOOLEAN input_valid ) [inline]

Indicates that the input is valid, if input_valid is set to TRUE. Whether an input is valid or not, should be decided by the control.

void AbstractEditBoxModel::SetLineIndex | ( | INT | line,
 |  | INT | index
 | ) | [inline]

Sets the start index related to the text buffer for the first character of the line line to index.

void AbstractEditBoxModel::SetLineLength | ( | INT | line,
 |  | INT | length
 | ) | [inline]

Sets the length of the line line in characters. This means that if the index of the first character of the line is e. g. 5 and the length is 3, the characters with the index 5 to 7 are indicessed by the line.

void AbstractEditBoxModel::SetMaxTextLength ( INT max_text_len )

Sets the maximum of allowed characters for the text-buffer. Note that the '' is not counted, hence the size of the text-buffer must be max_text_len + 1.

void AbstractEditBoxModel::SetNoOfVisibleLines ( INT lines ) [inline]

void AbstractEditBoxModel::SetPaging ( BOOLEAN paging ) [inline]

void AbstractEditBoxModel::SetPasswordMode ( BOOLEAN password_mode ) [inline]

Parameters:
password_mode If TRUE, all input characters will be presented with '*'.

void AbstractEditBoxModel::SetText ( const WCHAR * text )

Sets the text buffer to text.

void AbstractEditBoxModel::SetTextLength ( INT text_len )

Sets the length of the text. Note that the '' is not counted.

The documentation for this class was generated from the following files:
  • Compat/AbstractEditBox.hpp
  • Compat/AbstractEditBox.cpp
Generated on Wed Jan 25 00:54:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractEditBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractEditBoxView Class Reference

Describes the view of an editbox. More...

#include <Apoxi/Compat/AbstractEditBox.hpp>

Inheritance diagram for AbstractEditBoxView:

[legend]
Collaboration diagram for AbstractEditBoxView:

[legend]

Public Member Functions

AbstractEditBoxView (XYDIM line_height, XYDIM caption_gap, XYDIM caption_width, XYDIM caption_height, XYDIM edit_box_frame_size, XYDIM default_width=-1, XYDIM default_height=-1)
AbstractEditBoxView ()
XYDIM | GetCaptionGap () const
XYDIM | GetCaptionHeight () const
XYDIM | GetCaptionWidth () const
Rect | GetCursorRect (const AbstractEditBoxModel &model, const DeviceContext &dc, INT cursor_pos=-1) const
XYDIM | GetFrameSize () const
XYDIM | GetLineHeight () const
virtual | ~AbstractEditBoxView ()

Protected Member Functions

void | DrawCursor (const AbstractEditBoxModel &model, DeviceContext *dc) const

Protected Attributes

XYDIM | m_caption_gap
XYDIM | m_caption_height
XYDIM | m_caption_width
XYDIM | m_frame_size
XYDIM | m_line_height

Detailed Description

Describes the view of an editbox.

Constructor & Destructor Documentation

AbstractEditBoxView::AbstractEditBoxView ( )

AbstractEditBoxView::AbstractEditBoxView | ( | XYDIM | line_height,
 |  | XYDIM | caption_gap,
 |  | XYDIM | caption_width,
 |  | XYDIM | caption_height,
 |  | XYDIM | edit_box_frame_size,
 |  | XYDIM | default_width = -1,
 |  | XYDIM | default_height = -1
 | ) |

AbstractEditBoxView::~AbstractEditBoxView ( ) [virtual]

Member Function Documentation

void AbstractEditBoxView::DrawCursor | ( | const AbstractEditBoxModel & | model,
 |  | DeviceContext * | dc
 | ) | const [protected]

XYDIM AbstractEditBoxView::GetCaptionGap ( ) const [inline]

XYDIM AbstractEditBoxView::GetCaptionHeight ( ) const [inline]

XYDIM AbstractEditBoxView::GetCaptionWidth ( ) const [inline]

Rect AbstractEditBoxView::GetCursorRect | ( | const AbstractEditBoxModel & | model,
 |  | const DeviceContext & | dc,
 |  | INT | cursor_pos = -1
 | ) | const

XYDIM AbstractEditBoxView::GetFrameSize ( ) const [inline]

XYDIM AbstractEditBoxView::GetLineHeight ( ) const [inline]

Field Documentation

XYDIM AbstractEditBoxView::m_caption_gap [protected]

XYDIM AbstractEditBoxView::m_caption_height [protected]

XYDIM AbstractEditBoxView::m_caption_width [protected]

XYDIM AbstractEditBoxView::m_frame_size [protected]

XYDIM AbstractEditBoxView::m_line_height [protected]

The documentation for this class was generated from the following files:
  • Compat/AbstractEditBox.hpp
  • Compat/AbstractEditBox.cpp
Generated on Wed Jan 25 00:54:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractEditor Class Reference
[Editors]

Abstract base class for all editors. More...

#include <Apoxi/Gui/AbstractEditor.hpp>

Inheritance diagram for AbstractEditor:

[legend]
Collaboration diagram for AbstractEditor:

[legend]

Public Types

enum | { ID = 27 }
enum | SelectionStyle { InvertedSelection = 0, TransparentSelection = 1 }

Public Member Functions

AbstractEditor (Control *parent, INT input_mapper_id)
AbstractEditor ()
virtual BOOLEAN | Backspace ()
virtual void | DrawSelection (DeviceContext *dc, const Rect &bounds) const
const Caret * | GetCaret () const
Returns a const-pointer to the Caret.
Caret * GetCaret ()
Returns a pointer to the Caret.
virtual INT | GetCaretIndex () const =0
const EditorDocument * | GetDocument () const
EditorDocument * GetDocument ()
Caret::Mode | GetEditMode () const
const InputMapper * | GetInputMapper () const
Returns the const-pointer to the input-mapper of the editor.
InputMapper * GetInputMapper ()
Returns the pointer to the input-mapper of the editor.
INT | GetItemCount () const
virtual Rect | GetItemRect (INT index) const =0
INT | GetMaxItemCount () const
void | GetSelection (INT *item_index, INT *count) const
SelectionStyle | GetSelectionStyle () const
BOOLEAN | HasSelection () const
Returns TRUE, if one or more items are selected.
void | Init (Control *parent, INT input_mapper_id)
BOOLEAN | InsertCompoundItem (CompoundItem *compound_item, INT comp_item_index=-1)
BOOLEAN | InsertCompoundItemBeforeItem (CompoundItem *compound_item, INT item_index=-1)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
BOOLEAN | IsCaretAlwaysVisible () const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsReadOnly () const
virtual BOOLEAN | IsStandaloneItem (INT index) const
virtual void | MoveCaret (INT steps)
BOOLEAN | RemoveCompoundItem (INT comp_item_index=-1)
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
void | SetCaretAlwaysVisible (BOOLEAN visible)
void | SetCaretIndex (INT index)
void | SetEditMode (Caret::Mode mode)
void | SetInputMapper (INT input_mapper_id)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual void | SetReadOnly (BOOLEAN read_only)
void | SetSelection (INT item_index, INT count)
void | SetSelectionStyle (SelectionStyle style)
void | StartSelection ()
void | StopSelection ()
virtual void | Update ()
void | UpdateDocumentAlphabet (InputMapper::Alphabet alphabet)
virtual | ~AbstractEditor ()

Protected Member Functions

void | AssureValidCaretIndex (INT &index)
void | AssureValidIndex (INT &index) const
virtual void | Cleanup ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual BOOLEAN | OnKeyUp (KeyCode key_code, UINT32 duration)
virtual BOOLEAN | OnLongKeyPress (KeyCode key_code)
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnPaint (const Rect &repaint_rect)
virtual void | Refresh (const Rect &rect)

Detailed Description

Abstract base class for all editors.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Control.

enum AbstractEditor::SelectionStyle

Defines the style of selected items. The default style can be configured inside the class OptionalConfig by adjusting the parameter OptionalConfigBase::SelectionStyle. The selection style can be changed dynamically for each instance by invoking AbstractEditor::SetSelectionStyle(). The look of the selection style can be customized by overwriting AbstractEditor::DrawSelection().

Enumerator:
InvertedSelection | The selected items are inverted by an XOR operation.
TransparentSelection | The selected items are transparent by using the color Color::SelectionBackground. As alpha blending is used, this style is more expensive from a performance point of view than AbstractEditor::InvertedSelection.

Constructor & Destructor Documentation

AbstractEditor::AbstractEditor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractEditor::AbstractEditor | ( | Control * | parent,
 |  | INT | input_mapper_id
 | ) |

Parameters:
parent | Parent control which embeds the component.
input_mapper_id | ID of the input mapper. See InputMapper::Id for details. The corresponding instance of the input mapper can be defined in EditConfig::CreateInputMapper().

AbstractEditor::~AbstractEditor ( ) [virtual]

Member Function Documentation

void AbstractEditor::AssureValidCaretIndex ( INT & index ) [protected]

Assures that the index is corrected in a way that the caret is on a valid position (the maximum item count of the document and the edit mode is respected).

void AbstractEditor::AssureValidIndex ( INT & index ) const [protected]

Assures that the index is corrected in a way that it is has a valid position (the maximum item count of the document is respected).

BOOLEAN AbstractEditor::Backspace ( ) [virtual]

Deletes the item left of the caret. If the caret is on the first item, no item is deleted.

Reimplemented in MultiMediaEditor, AbstractLineEditor, AbstractMultiLineEditor, PasswordEditor, EmsEditor, and SmsEditor.

void AbstractEditor::Cleanup ( ) [protected, virtual]

See also:
Control::Cleanup

Reimplemented from Control.

Reimplemented in MultiMediaEditor.

void AbstractEditor::DrawSelection | ( | DeviceContext * | dc,
 |  | const Rect & | bounds
 | ) | const [virtual]

Draws a selection above the area marked as bounds. The default implementation respects the styles AbstractEditor::InvertedSelection and AbstractEditor::TransparentSelection. Usually this method is invoked by the view object of editors and it should not be necessary for applications to invoke this method directly.

const Caret * AbstractEditor::GetCaret ( ) const

Returns a const-pointer to the Caret.

Caret * AbstractEditor::GetCaret ( )

Returns a pointer to the Caret.

virtual INT AbstractEditor::GetCaretIndex ( ) const [pure virtual]

Returns:
Index of item where caret is positioned. -1 is returned, if caret is on an invalid position.

Implemented in AbstractLineEditor, and AbstractMultiLineEditor.

const EditorDocument* AbstractEditor::GetDocument ( ) const [inline]

Returns:
Const-pointer to the document of the editor.

EditorDocument* AbstractEditor::GetDocument ( ) [inline]

Returns:
Pointer to the document of the editor.

Caret::Mode AbstractEditor::GetEditMode ( ) const

Returns:
Caret::Insert, if the editor is in insert-mode, Caret::Overwrite, if the editor is in overwrite-mode.

const InputMapper* AbstractEditor::GetInputMapper ( ) const [inline]

Returns the const-pointer to the input-mapper of the editor.

InputMapper* AbstractEditor::GetInputMapper ( ) [inline]

Returns the pointer to the input-mapper of the editor.

INT AbstractEditor::GetItemCount ( ) const

Returns:
Number of items of the document.

virtual Rect AbstractEditor::GetItemRect ( INT index ) const [pure virtual]

Returns the bounding rectangle of the item with the specified index.

Parameters:
index Index of the item.
Returns:
Rectangle of the item given by the index. If the index is smaller than zero, an empty rectangle is returned.

Implemented in AbstractLineEditor, and AbstractMultiLineEditor.

INT AbstractEditor::GetMaxItemCount ( ) const

Returns:
Number of maximum items which can be inserted into the document. -1 is returned, if there is no specified limit.

void AbstractEditor::GetSelection | ( | INT * | item_index,
 |  | INT * | count
 | ) | const

Returns the selection-range.

Parameters:
item_index | Output-parameter, which indicates the index of the item where the selection starts.
count | Output-parameter, which indicates the number of selected items. 0 means, that no selection has been done.

SelectionStyle AbstractEditor::GetSelectionStyle ( ) const [inline]

Returns the style for selected items (see AbstractEditor::SelectionStyle).

BOOLEAN AbstractEditor::HasSelection ( ) const [inline]

Returns TRUE, if one or more items are selected.

void AbstractEditor::Init | ( | Control * | parent,
 |  | INT | input_mapper_id
 | ) |

Parameters:
parent | Parent control which embeds the component.
input_mapper_id | ID of the input mapper. See InputMapper::Id for details. The corresponding instance of the input mapper can be defined in EditConfig::CreateInputMapper().

Reimplemented in MultiMediaEditor, AbstractLineEditor, and AbstractMultiLineEditor.

BOOLEAN AbstractEditor::InsertCompoundItem | ( | CompoundItem * | compound_item,
 |  | INT | comp_item_index = -1
 | ) |

Wrapper-method for EditorDocument::InsertCompoundItem(). Additionally AbstractEditor::Update() is invoked to assure a consistent state of the editor with it's document.

See also:
EditorDocument::InsertCompoundItem()

Reimplemented in EmsEditor.

BOOLEAN AbstractEditor::InsertCompoundItemBeforeItem | ( | CompoundItem * | compound_item,
 |  | INT | item_index = -1
 | ) |

Wrapper-method for EditorDocument::InsertCompoundItemBeforeItem(). Additionally AbstractEditor::Update() is invoked to assure a consistent state of the editor with it's document.

Parameters:
compound_item | Pointer to the Compound-Item, which should be inserted.
item_index | Index of the item, where the Compound-Item should be inserted. If the index is smaller zero, the item is inserted at the position of the caret.
Returns:
TRUE, if the inserting has been successful.
See also:
EditorDocument::InsertCompoundItemBeforeItem()

BOOLEAN AbstractEditor::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

Inserts an item on the specified index.

Parameters:
item | Item which should be inserted.
index | Index of the item, where item should be inserted. If the index is smaller zero, the item is inserted at the position of the caret.

Reimplemented in MultiMediaEditor, AbstractLineEditor, AbstractMultiLineEditor, PasswordEditor, EmsEditor, and SmsEditor.

BOOLEAN AbstractEditor::IsCaretAlwaysVisible ( ) const [inline]

Returns TRUE, if the caret is always visible, even the editor does not have the focus. Per default FALSE is returned.

See also:
SetCaretVisible

BOOLEAN AbstractEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Control.

Reimplemented in MultiMediaEditor, AbstractLineEditor, AbstractMultiLineEditor, DateEditor, IpAddrEditor, LineEditor, MultiLineEditor, PasswordEditor, and TimeEditor.

BOOLEAN AbstractEditor::IsReadOnly ( ) const [inline]

Returns TRUE, if the editor is in the read-only mode, which means that the the content can't be changed by the user.

BOOLEAN AbstractEditor::IsStandaloneItem ( INT index ) const [virtual]

Tests if an item at the given index is rendered standalone or not. For text, it can be that the character is a diacritic that modifies preceding or following characters. Other items will always return TRUE.

Parameters:
index the index of the character to be tested
Returns:
TRUE if the item is a non-character, or if the character is rendered standalone, FALSE otherwise

Reimplemented in AbstractMultiLineEditor.

void AbstractEditor::MoveCaret ( INT steps ) [virtual]

Moves the caret a number of steps left or right. Scrolling and assigning of the right column of the caret is done by the editor. It is assured, that after invoking this method the caret is always fully visible and has a valid index.

Parameters:
steps If smaller than zero, the caret is moved left as often as specified. If greater than zero, the caret is moved right as often as specified.

Reimplemented in AbstractLineEditor, AbstractMultiLineEditor, DateEditor, TimeEditor, and SearchBox.

void AbstractEditor::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from Control.

Reimplemented in AbstractMultiLineEditor, and SmsEditor.

BOOLEAN AbstractEditor::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from Control.

Reimplemented in MultiMediaEditor, AbstractLineEditor, AbstractMultiLineEditor, PbDetailEditBox, and PbNameEditBox.

BOOLEAN AbstractEditor::OnKeyUp | ( | KeyCode | key_code,
 |  | UINT32 | duration
 | ) | [protected, virtual]

See also:
Control::OnKeyUp

Reimplemented from Control.

BOOLEAN AbstractEditor::OnLongKeyPress ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnLongKeyPress

Reimplemented from Control.

void AbstractEditor::OnLoseFocus ( ) [protected, virtual]

See also:
Control::OnLoseFocus

Reimplemented from Control.

BOOLEAN AbstractEditor::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Component.

void AbstractEditor::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

See also:
Control::OnPaint

Reimplemented from Control.

Reimplemented in MultiMediaEditor, and AbstractMultiLineEditor.

void AbstractEditor::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from Control.

Reimplemented in MultiMediaEditor, AbstractMultiLineEditor, and DateEditor.

BOOLEAN AbstractEditor::RemoveCompoundItem ( INT comp_item_index = -1 )

Wrapper-method for EditorDocument::RemoveCompoundItem(). Additionally AbstractEditor::Update() is invoked to assure a consistent state of the editor with it's document.

See also:
EditorDocument::RemoveCompoundItem()

Reimplemented in EmsEditor.

BOOLEAN AbstractEditor::RemoveItem ( INT index = -1 ) [virtual]

Deletes the item with the specified index.

Parameters:
index Index of the item which should be deleted. If the index is smaller than zero, the item beyound the caret is deleted.

Reimplemented in MultiMediaEditor, AbstractLineEditor, AbstractMultiLineEditor, PasswordEditor, EmsEditor, and SmsEditor.

BOOLEAN AbstractEditor::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

Replaces the item on the specified index.

Parameters:
item | Item which should replace another item.
index | Index of the item, which should be replaced. If the index is smaller zero, the item beyound the caret is replaced.

Reimplemented in MultiMediaEditor, AbstractLineEditor, AbstractMultiLineEditor, PasswordEditor, and EmsEditor.

void AbstractEditor::SetCaretAlwaysVisible ( BOOLEAN visible )

If visible is TRUE, the caret is always visible, even the editor does not have the focus. This might be useful, when having e. g. a virtual keyboard-control, which delegates its input to the editor. Per default the caret is not visible, when the editor loses the focus.

void AbstractEditor::SetCaretIndex ( INT index )

Wrapper method for setting the caret to the item with the index index by invoking MoveCaret(-GetCaretIndex() + index).

void AbstractEditor::SetEditMode ( Caret::Mode mode )

Parameters:
mode Mode of the editor: Caret::Insert means that a new item is inserted before the item beyound the caret, Caret::Overwrite means that a new item replaces the item beyound the caret.

void AbstractEditor::SetInputMapper ( INT input_mapper_id )

Sets the input-mapper of the editor to the input-mapper given by input_mapper_id. The mapping from the input-mapper-id to the input-mapper-class is done by the class EditConfig (see Config/EditConfig).

BOOLEAN AbstractEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Control.

Reimplemented in MultiMediaEditor, AbstractLineEditor, AbstractMultiLineEditor, DateEditor, IpAddrEditor, LineEditor, MultiLineEditor, PasswordEditor, and TimeEditor.

void AbstractEditor::SetReadOnly ( BOOLEAN read_only ) [virtual]

Parameters:
read_only TRUE means that the content can't be changed by the user.

Reimplemented in MultiMediaEditor, and MultiLineEditor.

void AbstractEditor::SetSelection | ( | INT | item_index,
 |  | INT | count
 | ) |

Sets a selection from the item with the index item_index for count items.

void AbstractEditor::SetSelectionStyle ( SelectionStyle style )

Sets the style for selected items (see AbstractEditor::SelectionStyle). The default style can be configured inside the class OptionalConfig by adjusting the parameter OptionalConfigBase::SelectionStyle.

void AbstractEditor::StartSelection ( )

Starts the selection on the item specified by the caret. The selection is automatically modified when moving the caret, until StopSelection has been invoked.

See also:
GetSelection

void AbstractEditor::StopSelection ( )

Stops the selection, which has been started by StartSelection.

See also:
StartSelection

void AbstractEditor::Update ( ) [virtual]

Updates the internal data of the editor and leads to a redraw. Use this method only when changing the content of the document or its compound-items directly by e. g. the input-mapper to inform the editor about the change. Changing the document or its compound-items directly may allow better performance for operations on a large number of items in one time.

Reimplemented in MultiMediaEditor, AbstractLineEditor, and AbstractMultiLineEditor.

void AbstractEditor::UpdateDocumentAlphabet ( InputMapper::Alphabet alphabet )

Updates the alphabet used by the document. Invoking this method is useful when an input mapper changes the used alphabet coding from e. g. seven bit to UCS2.

The documentation for this class was generated from the following files:
  • Gui/AbstractEditor.hpp
  • Gui/AbstractEditor.cpp
Generated on Wed Jan 25 00:54:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractEditorItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractEditorItem Class Reference
[Editors]

#include <Apoxi/Gui/AbstractEditorItem.hpp>

Inheritance diagram for AbstractEditorItem:

[legend]

Public Member Functions

AbstractEditorItem ()
virtual INT | GetId () const =0
virtual BOOLEAN | IsInstanceOf (INT id) const =0
virtual | ~AbstractEditorItem ()

Detailed Description

Abstract base class for all items which can be embedded into an Editor-Document. Every Abstract-Editor-Item has a unique ID.

Currently used IDs (the IDs from 0 to 999 are reserved for APOXI):

  • 0 ... AtomItem
  • 1 ... CompoundItem
  • 2 ... CharItem
  • 3 ... BoundedItem
  • 4 ... ImageItem
  • 5 ... SoundItem
  • 6 ... TextCompoundItem
  • 7 ... TimeCompoundItem
  • 8 ... DateCompoundItem
  • 9 ... IpAddrCompoundItem
  • 10 ... RichTextCompoundItem
  • 11 ... ParagraphCompoundItem
  • 12 ... GeneralCompoundItem
  • 13 ... ParagraphMarker
  • 14 ... VCardItem
  • 15 ... AudioItem

Constructor & Destructor Documentation

AbstractEditorItem::AbstractEditorItem ( )

AbstractEditorItem::~AbstractEditorItem ( ) [virtual]

Member Function Documentation

virtual INT AbstractEditorItem::GetId ( ) const [pure virtual]

Returns:
Unique ID of the item.

Implemented in AudioItem, BoundedItem, GeneralCompoundItem, ImageItem, ParagraphCompoundItem, ParagraphMarker, RichTextCompoundItem, VCardItem, SoundItem, AtomItem, CharItem, CompoundItem, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

virtual BOOLEAN AbstractEditorItem::IsInstanceOf ( INT id ) const [pure virtual]

Returns:
TRUE, if the Abstract-Editor-Item item is an instance of the object where the method has been invoked.

Implemented in AudioItem, BoundedItem, GeneralCompoundItem, ImageItem, ParagraphCompoundItem, ParagraphMarker, RichTextCompoundItem, VCardItem, SoundItem, AtomItem, CharItem, CompoundItem, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

The documentation for this class was generated from the following files:
  • Gui/AbstractEditorItem.hpp
  • Gui/AbstractEditorItem.cpp
Generated on Wed Jan 25 00:54:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractExternalData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractExternalData Class Reference
[Kernel]

#include <Apoxi/Kernel/AbstractExternalData.hpp>

Inheritance diagram for AbstractExternalData:

[legend]

Public Member Functions

AbstractExternalData ()
virtual ~AbstractExternalData ()

Detailed Description

AbstractExternalData maintains the incoming data for the ExternalCommunicationHandler.

Constructor & Destructor Documentation

AbstractExternalData::AbstractExternalData ( )

AbstractExternalData::~AbstractExternalData ( ) [virtual]

The documentation for this class was generated from the following files:
  • Kernel/AbstractExternalData.hpp
  • Kernel/AbstractExternalData.cpp
Generated on Wed Jan 25 00:54:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractGrid Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractGrid Class Reference
[Components]

Simple grid functionality for arranging items on the screen in rows and columns. More...

#include <Apoxi/Gui/AbstractGrid.hpp>

Inheritance diagram for AbstractGrid:

[legend]
Collaboration diagram for AbstractGrid:

[legend]

Public Types

enum | { ID = 1 }
enum MoveDirection {
Left, Right, Up, Down,
PageUp, PageDown
}

Public Member Functions

AbstractGrid (Control *parent=0)
virtual INT | GetCellCount () const =0
virtual XYDIM | GetCellHeight () const =0
Rect | GetCellRect (INT idx) const
virtual XYDIM | GetCellWidth () const
virtual INT | GetColumnCount () const =0
INT | GetCompleteVisibleRowCount () const
INT | GetFirstVisibleColumn () const
INT | GetFirstVisibleIndex () const
virtual XYDIM | GetHeaderHeight () const
Rect | GetHeaderRect (INT column_idx) const
INT | GetLastCompleteVisibleIndex () const
INT | GetLastVisibleIndex () const
INT | GetRowCount () const
virtual ScrollBehavior | GetScrollBehavior () const
INT | GetSelectedIndex () const
virtual XYDIM | GetSelectionHeight () const
const SmoothScrollInfo * | GetSmoothScrollInfo () const
INT | GetVisibleRowCount () const
virtual BOOLEAN | HasHeader () const
void | Init (Control *parent=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual BOOLEAN | IsPositionIndicatorShown () const
virtual void | MoveSelectedIndex (MoveDirection move_dir)
void | SetFirstVisibleColumn (INT column)
void | SetFirstVisibleIndex (INT idx, BOOLEAN respect_scroll_gap=TRUE)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual void | SetSelectedIndex (INT idx)
virtual | ~AbstractGrid ()

Protected Member Functions

void | AssureVisibleSelection (BOOLEAN respect_scroll_gap=TRUE)
void | CancelSmoothScrolling (INT new_selected_idx)
void | DrawPositionIndicator (const Rect &repaint_rect)
INT | GetSelectedIndexProperty () const
BOOLEAN | IsPositionIndicatorLeftAligned () const
Returns TRUE, if the position-indicator is aligned on the left side.
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyAutoRepeat (KeyCode key_code)
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
virtual void | OnPaint (const Rect &repaint_rect)
virtual void | OnSelectionChanged ()
virtual void | OnThemeChanged ()
virtual BOOLEAN | OnTimeout (const Timer &timer)
virtual void | Refresh (const Rect &rect)
void | UpdateNavigationGuidance ()
void | UpdatePositionIndicator ()

Data Structures

class | SmoothScrollInfo

Detailed Description

Simple grid functionality for arranging items on the screen in rows and columns.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Control.

enum AbstractGrid::MoveDirection

Enumerator:
Left | Moving one cell to the left.
Right | Moving one cell to the right.
Up | Moving one cell up.
Down | Moving one cell down.
PageUp | Move one page up, which means that the first visible index is decreased by the number of full visible items.
PageDown | Move one page down, which means that the first visible index is increased by the number of full visible items.

Constructor & Destructor Documentation

AbstractGrid::AbstractGrid ( Control * parent = 0 )

AbstractGrid::~AbstractGrid ( ) [virtual]

Member Function Documentation

void AbstractGrid::AssureVisibleSelection ( BOOLEAN respect_scroll_gap = TRUE ) [protected]

Assures, that the selected idx is fully visible by adjusting the first visible index when necessary.

Parameters:
respect_scroll_gap If set to TRUE, it is assured that the scroll gap defined by inside the class OptionalConfig is respected. When using block scrolling by pressing page up/down keys it might be useful that the scroll gap is not respected.

void AbstractGrid::CancelSmoothScrolling ( INT new_selected_idx ) [protected]

Cancels the smooth scrolling and sets the selected index to new_selected_idx. Using this method instead of AbstractGrid::SetSelectedIndex is useful if e. g. the whole content has been changed and no smooth scrolling is wanted in this case.

void AbstractGrid::DrawPositionIndicator ( const Rect & repaint_rect ) [protected]

Draws the positionindicator. Usually invoking this method is not required, as the drawing is done in AbstractGrid::OnPaint per default.

virtual INT AbstractGrid::GetCellCount ( ) const [pure virtual]

Returns:
Defines the number of cells for the grid.

Implemented in Menu, AbstractItemGrid, CalendarGrid, and CalendarMonthSelector.

virtual XYDIM AbstractGrid::GetCellHeight ( ) const [pure virtual]

Returns:
Defines the height of all cells.

Implemented in Menu, AbstractItemGrid, CalendarGrid, and CalendarMonthSelector.

Rect AbstractGrid::GetCellRect ( INT idx ) const

Parameters:
idx Index of the cell.
Returns:
Position and dimension of the inquired cell.

XYDIM AbstractGrid::GetCellWidth ( ) const [virtual]

Returns:
Defines the width for all cells. -1 automatically sets the cell width depending on the number of columns.

Reimplemented in Menu, and CalendarGrid.

virtual INT AbstractGrid::GetColumnCount ( ) const [pure virtual]

Returns:
Defines the number of columns for the grid.

Implemented in Menu, ItemGrid, ItemTree, CalendarGrid, and CalendarMonthSelector.

INT AbstractGrid::GetCompleteVisibleRowCount ( ) const

Returns:
The number of currently complete visible cells inside the grid. "Complete visible" means that they are not clipped.

INT AbstractGrid::GetFirstVisibleColumn ( ) const [inline]

Returns:
Index of the first visible column

INT AbstractGrid::GetFirstVisibleIndex ( ) const [inline]

Returns:
Index of the first visible cell.

XYDIM AbstractGrid::GetHeaderHeight ( ) const [virtual]

Returns:
Defines the height of the header. Per default 0 is returned.

Reimplemented in AbstractItemGrid.

Rect AbstractGrid::GetHeaderRect ( INT column_idx ) const

Parameters:
column_idx Index of the header-column.
Returns:
Postition and dimension of the header. An empty rectangle is returned, if AbstractGrid::GetHeaderHeight returns a value <= 0.

INT AbstractGrid::GetLastCompleteVisibleIndex ( ) const

Returns:
Index of the last visible cell, which is not clipped.

INT AbstractGrid::GetLastVisibleIndex ( ) const

Returns:
Index of the last visible cell. This cell may be clipped.

INT AbstractGrid::GetRowCount ( ) const

Returns:
The number of rows, which is calculated due to using the methods AbstractGrid::GetCellCount and AbstractGrid::GetColumnCount.

ScrollBehavior AbstractGrid::GetScrollBehavior ( ) const [virtual]

Returns:
The scrollbehavior defined in GuiEngineConfig::GetScrollBehavior, which represents the default scroll-behavior. This method may be overwritten if another scrollbehavior is wanted.

INT AbstractGrid::GetSelectedIndex ( ) const

Returns:
Index of the selected cell.

INT AbstractGrid::GetSelectedIndexProperty ( ) const [inline, protected]

Returns the selected index property. It is recommended to use the method AbstractGrid::GetSelectedIndex for getting the selected index, as a range check is done to assure that the selected index is always >= 0 and < the number of cells. Anyway derived controls might require the internal selected index property which might temporary be < 0 or >= the number of cells.

XYDIM AbstractGrid::GetSelectionHeight ( ) const [virtual]

Returns:
The height of the selected item in pixels. Per default -1 is returned, which means that the height of the cell (see AbstractGrid::GetCellHeight) is used. The selection height is only respected, if the number of columns is 1 (see AbstractGrid::GetColumnCount).

Reimplemented in AbstractItemGrid.

const AbstractGrid::SmoothScrollInfo * AbstractGrid::GetSmoothScrollInfo ( ) const

Returns information about the smooth scrolling. 0 is returned if smooth scrolling is not enabled.

INT AbstractGrid::GetVisibleRowCount ( ) const

Returns:
The number of currently visible cells inside the grid. The cells might be clipped.

BOOLEAN AbstractGrid::HasHeader ( ) const [virtual]

Returns:
TRUE, if the header should be shown. Per default FALSE is returned.

Reimplemented in AbstractItemGrid.

void AbstractGrid::Init ( Control * parent = 0 )

Parameters:
parent Control which embeds the AbstractGrid.

Reimplemented in CalendarGrid, and CalendarMonthSelector.

BOOLEAN AbstractGrid::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Control.

Reimplemented in AbstractItemGrid, ItemGrid, ItemMenu, and ItemTree.

BOOLEAN AbstractGrid::IsPositionIndicatorLeftAligned ( ) const [protected]

Returns TRUE, if the position-indicator is aligned on the left side.

BOOLEAN AbstractGrid::IsPositionIndicatorShown ( ) const [virtual]

Returns:
TRUE, if the position-indicator should be shown corresponding to the display-policy defined in OptionalConfig.

void AbstractGrid::MoveSelectedIndex ( MoveDirection move_dir ) [virtual]

After pressing an arrow-key this method is invoked with the corresponding move-direction as input-parameter. Sets the selected index and respects the scroll-behavior. This method may be overwritten if another behavior is wanted.

void AbstractGrid::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from Control.

Reimplemented in AbstractItemGrid, and CalendarGrid.

BOOLEAN AbstractGrid::OnKeyAutoRepeat ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyAutoRepeat

Reimplemented from Control.

BOOLEAN AbstractGrid::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from Control.

Reimplemented in CalendarGrid.

void AbstractGrid::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Control.

void AbstractGrid::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

See also:
Control::OnPaint

Reimplemented from Control.

Reimplemented in AbstractItemGrid.

void AbstractGrid::OnSelectionChanged ( ) [protected, virtual]

Is called, each time the selector has been moved. The method also is invoked once when the parent-window containing the abstract grid is opened.

Reimplemented in Menu, AbstractItemGrid, and ItemMenu.

void AbstractGrid::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from Control.

Reimplemented in AbstractItemGrid.

BOOLEAN AbstractGrid::OnTimeout ( const Timer & timer ) [protected, virtual]

See also:
Control::OnTimeout

Reimplemented from Control.

Reimplemented in AbstractItemGrid.

void AbstractGrid::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh()

Reimplemented from Control.

Reimplemented in Menu, AbstractItemGrid, ItemMenu, and ItemTree.

void AbstractGrid::SetFirstVisibleColumn ( INT column )

void AbstractGrid::SetFirstVisibleIndex | ( | INT | idx,
 |  | BOOLEAN | respect_scroll_gap = TRUE
 | ) |

Parameters:
idx | Index of the first visible cell.
respect_scroll_gap | If set to TRUE, it is assured that the scroll gap defined by inside the class OptionalConfig is respected. When using block scrolling by pressing page up/down keys it might be useful that the scroll gap is not respected.

BOOLEAN AbstractGrid::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Control.

Reimplemented in AbstractItemGrid, ItemGrid, ItemMenu, and ItemTree.

void AbstractGrid::SetSelectedIndex ( INT idx ) [virtual]

Sets the selected index to idx, invokes OnSelectionChanged and sends the message SelectionChangedMsg to the parent-window of the control

Parameters:
idx Index of the selected cell.

Reimplemented in AbstractItemGrid.

void AbstractGrid::UpdateNavigationGuidance ( ) [protected]

Updated the navigation guidance, which depends on the number of cells and columns.

Reimplemented from Control.

void AbstractGrid::UpdatePositionIndicator ( ) [protected]

Updates the position-indicator to indicate the position and visible section corresponding to the number of cells.

The documentation for this class was generated from the following files:
  • Gui/AbstractGrid.hpp
  • Gui/AbstractGrid.cpp
Generated on Wed Jan 25 00:54:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractGrid::SmoothScrollInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
AbstractGrid::SmoothScrollInfo

AbstractGrid::SmoothScrollInfo Class Reference

#include <Apoxi/Gui/AbstractGrid.hpp>

Collaboration diagram for AbstractGrid::SmoothScrollInfo:

[legend]

Public Member Functions

XYDIM | GetDiff () const
XYDIM | GetInc () const
const Timer & | GetTimer () const
BOOLEAN | IsHorizontal () const
BOOLEAN | IsMirrored () const
BOOLEAN | IsSelector () const
SmoothScrollInfo ()
~SmoothScrollInfo ()

Friends

class | AbstractGrid

Detailed Description

Contains information about smooth scrolling and can be retrieved by derived classes by invoking AbstractGrid::GetSmoothScrollInfo. Usually it is not necessary to care about this information, but might be useful if additional components must be coordinated with the smooth scrolling.

Constructor & Destructor Documentation

AbstractGrid::SmoothScrollInfo::SmoothScrollInfo ( )

AbstractGrid::SmoothScrollInfo::~SmoothScrollInfo ( )

Member Function Documentation

XYDIM AbstractGrid::SmoothScrollInfo::GetDiff ( ) const [inline]

Returns the current difference in pixels of the original placement in comparison to the smooth scrolled placement. The value is always smaller than the height/width of a cell.

XYDIM AbstractGrid::SmoothScrollInfo::GetInc ( ) const [inline]

Returns the increment which is added when the scroll timer expires.

const Timer& AbstractGrid::SmoothScrollInfo::GetTimer ( ) const [inline]

Returns the timer which triggers the smooth scrolling.

BOOLEAN AbstractGrid::SmoothScrollInfo::IsHorizontal ( ) const [inline]

Returns TRUE, if the smooth scrolling is done horizontally, FALSE if it's done vertically.

BOOLEAN AbstractGrid::SmoothScrollInfo::IsMirrored ( ) const [inline]

Returns TRUE, if the selector has a mirrored clone. This might happen e. g. on an 3 x 3 grid if the selection is moved left on item 0. In this case the selection is visible on item 0 and mirrored on item 8.

BOOLEAN AbstractGrid::SmoothScrollInfo::IsSelector ( ) const [inline]

Returns TRUE, if the selector is scrolled smoothly. Otherwise the whole content will be scrolled.

Friends And Related Function Documentation

friend class AbstractGrid [friend]

The documentation for this class was generated from the following files:
  • Gui/AbstractGrid.hpp
  • Gui/AbstractGrid.cpp
Generated on Wed Jan 25 00:54:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractIMelodyParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractIMelodyParser Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/AbstractIMelodyParser.hpp>

Public Member Functions

AbstractIMelodyParser ()
virtual INT | GetToneCount (BinData *data)=0
Calculates the number of single tones coded in the IMelody given in data.
virtual void | Parse (BinData *data, IMelodyData &parsed_data)=0
virtual | ~AbstractIMelodyParser ()

Detailed Description

Obsolete - all sound classes from AddOns/MultiMedia have been replaced by a new audio concept. Use the AudioDeviceManager instead for playing sounds.

Constructor & Destructor Documentation

AbstractIMelodyParser::AbstractIMelodyParser ( )

AbstractIMelodyParser::~AbstractIMelodyParser ( ) [virtual]

Member Function Documentation

virtual INT AbstractIMelodyParser::GetToneCount ( BinData * data ) [pure virtual]

Calculates the number of single tones coded in the IMelody given in data.

virtual void AbstractIMelodyParser::Parse | ( | BinData * | data,
 |  | IMelodyData & | parsed_data
 | ) | [pure virtual]

Parses the IMelody given in data into parsed_data. The memory for parsed_data.m_tone_data.tones is allocated. parsed_data.m_tone_data.nof_tones is set to the maximum numbers of SingleTones which can be stored. This is the only valid value in parsed_data.
Note: The global volume value as defined in IMelody spec. must be the first SingleTones in parsed_data.m_tone_data.nof_tones if it is set.
If the given data cannot be parsed, parsed_data.m_tone_data.nof_tones should be set to 0.

The documentation for this class was generated from the following files:
  • Compat/AbstractIMelodyParser.hpp
  • Compat/AbstractIMelodyParser.cpp
Generated on Wed Jan 25 00:54:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractItemContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractItemContainer Class Reference

#include <Apoxi/Gui/AbstractItemContainer.hpp>

Inheritance diagram for AbstractItemContainer:

[legend]
Collaboration diagram for AbstractItemContainer:

[legend]

Public Types

enum | { ID = 2 }
enum | AbstractItemContainerPropertyId { ItemPropertyId = 4, RendererPropertyId = 5 }

Public Member Functions

AbstractItemContainer (Dispatcher *dispatcher, const WString &text, const IconSet &icon_set, BOOLEAN enabled=TRUE)
AbstractItemContainer (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE)
AbstractItemContainer (Dispatcher *dispatcher, const WString &text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
AbstractItemContainer (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
AbstractItemContainer ()
virtual BOOLEAN | AddItem (Item *item)=0
BOOLEAN | ContainsItem (const Item &item) const
virtual Item * | GetItem (INT index) const =0
virtual INT | GetItemCount () const =0
Returns the number of items of the item-grid.
virtual INT | GetItemIndex (const Item &item) const =0
virtual AbstractItemContainer * | GetParentContainer ()=0
Returns the parent container.
virtual const ItemRendererProperties * | GetRendererProperties () const
void | Init (Dispatcher *dispatcher, const WString &text, const IconSet &icon_set, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WString &text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
virtual BOOLEAN | InsertItem (INT index, Item *item)=0
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual BOOLEAN | RemoveAllItems ()=0
virtual BOOLEAN | RemoveItem (INT index)=0
virtual BOOLEAN | SetParentContainer (AbstractItemContainer *container)=0
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual BOOLEAN | SetRendererProperties (const ItemRendererProperties *properties)
virtual | ~AbstractItemContainer ()

Detailed Description

Defines an interface for an item, which can contain a variable number of other items. An item-container can be used for describing e. g. a menu hierarchy.
See also:
ItemMenu

ItemTree

ItemGrid

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Item.

enum AbstractItemContainer::AbstractItemContainerPropertyId

Enumerator:
ItemPropertyId When a property of an item has been changed, the message ItemPropertiesChanged will be send to the dispatcher, which is assigned to the item. The message contains a property-index, which indicates the changed property or property-group. The property-indices 0 to 999 are reserved for APOXI. Additional defined ids:
  • 5: FeatureItem::FeaturePropertyId
RendererPropertyId

Constructor & Destructor Documentation

AbstractItemContainer::AbstractItemContainer ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractItemContainer::AbstractItemContainer | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

AbstractItemContainer::AbstractItemContainer | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

AbstractItemContainer::AbstractItemContainer | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

AbstractItemContainer::AbstractItemContainer | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const IconSet & | icon_set,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon_set | Icon set of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

AbstractItemContainer::~AbstractItemContainer ( ) [virtual]

Member Function Documentation

virtual BOOLEAN AbstractItemContainer::AddItem ( Item * item ) [pure virtual]

Adds the item item after the already added items. NotifyPropertyChanged(ItemPropertyId) should be invoked if the operation has been successful.

Implemented in FeatureItemContainer, ProviderProxyContainer, and ItemContainer.

BOOLEAN AbstractItemContainer::ContainsItem ( const Item & item ) const

Returns TRUE, if the item item is part of the item-container. Is a wrapper-method which uses AbstractItemContainer::GetItemIndex to check whether the item is part of the item-container.

virtual Item* AbstractItemContainer::GetItem ( INT index ) const [pure virtual]

Returns the item of the index index.

Implemented in FeatureItemContainer, and ItemContainer.

virtual INT AbstractItemContainer::GetItemCount ( ) const [pure virtual]

Returns the number of items of the item-grid.

Implemented in FeatureItemContainer, and ItemContainer.

virtual INT AbstractItemContainer::GetItemIndex ( const Item & item ) const [pure virtual]

Returns the index of the item item. If the item is not part of the item-grid, -1 is returned.

Implemented in FeatureItemContainer, and ItemContainer.

virtual AbstractItemContainer* AbstractItemContainer::GetParentContainer ( ) [pure virtual]

Returns the parent container.

Implemented in ProviderProxyContainer, and ItemContainer.

const ItemRendererProperties * AbstractItemContainer::GetRendererProperties ( ) const [virtual]

Returns a pointer to the item renderer properties, which should be used for rendering the items inside the item container. Per default 0 is returned.

Reimplemented in ItemContainer.

void AbstractItemContainer::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const IconSet & | icon_set,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon_set | Icon set of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented from Item.

Reimplemented in ItemContainer.

void AbstractItemContainer::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented from Item.

Reimplemented in ItemContainer.

void AbstractItemContainer::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented from Item.

Reimplemented in ItemContainer.

void AbstractItemContainer::Init | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented from Item.

Reimplemented in ItemContainer.

virtual BOOLEAN AbstractItemContainer::InsertItem | ( | INT | index,
 |  | Item * | item
 | ) | [pure virtual]

Inserts the item item at the index index NotifyPropertyChanged(ItemPropertyId) should be invoked if the operation has been successful.

Implemented in FeatureItemContainer, ProviderProxyContainer, and ItemContainer.

BOOLEAN AbstractItemContainer::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from Item.

Reimplemented in FeatureItemContainer, ProviderProxyContainer, and ItemContainer.

virtual BOOLEAN AbstractItemContainer::RemoveAllItems ( ) [pure virtual]

Removes all items. NotifyPropertyChanged(ItemPropertyId) should be invoked if the operation has been successful.

Implemented in FeatureItemContainer, ProviderProxyContainer, and ItemContainer.

virtual BOOLEAN AbstractItemContainer::RemoveItem ( INT index ) [pure virtual]

Removes the item item at the index index. NotifyPropertyChanged(ItemPropertyId) should be invoked if the operation has been successful.

Implemented in FeatureItemContainer, ProviderProxyContainer, and ItemContainer.

virtual BOOLEAN AbstractItemContainer::SetParentContainer ( AbstractItemContainer * container ) [pure virtual]

Sets the parent container. FALSE is returned, if the setting of a parent-container is not supported or has been failed.

Implemented in ProviderProxyContainer, and ItemContainer.

BOOLEAN AbstractItemContainer::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Item.

Reimplemented in FeatureItemContainer, and ItemContainer.

BOOLEAN AbstractItemContainer::SetRendererProperties ( const ItemRendererProperties * properties ) [virtual]

Sets the item renderer properties, which should be used for rendering the items inside the item container. FALSE is returned, if the setting of item renderer properties is not supported or has been failed. Per default FALSE is returned.

Reimplemented in ItemContainer.

The documentation for this class was generated from the following files:
  • Gui/AbstractItemContainer.hpp
  • Gui/AbstractItemContainer.cpp
Generated on Wed Jan 25 00:54:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractItemGrid Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractItemGrid Class Reference
[Components]

#include <Apoxi/Gui/AbstractItemGrid.hpp>

Inheritance diagram for AbstractItemGrid:

[legend]
Collaboration diagram for AbstractItemGrid:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

AbstractItemGrid (Control *parent, AbstractItemContainer *item_cont=0)
AbstractItemGrid ()
BOOLEAN | AddItem (Item *item)
virtual INT | GetCellCount () const
virtual XYDIM | GetCellHeight () const
virtual XYDIM | GetHeaderHeight () const
Item * | GetHeaderItem (INT column) const
Returns the item for the header column column.
virtual AbstractItemContainer * | GetItemContainer () const
const AbstractItemRenderer * | GetRenderer () const
Returns the renderer which is used for drawing the items.
Item * | GetSelectedItem () const
virtual XYDIM | GetSelectionHeight () const
virtual BOOLEAN | HasHeader () const
void | Init (Control *parent, AbstractItemContainer *item_cont=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual void | MoveSelectedIndex (MoveDirection move_dir)
void | SetHeaderItem (INT column, Item *item)
void | SetItemContainer (AbstractItemContainer *item_cont)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetRenderer (const ItemRendererProperties *properties=0)
virtual void | SetSelectedIndex (INT idx)
virtual | ~AbstractItemGrid ()

Protected Member Functions

virtual void | Cleanup ()
void | CleanupImageCache ()
virtual void | DrawItemBorder (DeviceContext *dc, const Rect &cell_rect, const Rect &item_rect, INT item_index) const
virtual Rect | GetItemRect (INT item_index) const
virtual void | OnGetFocus ()
virtual void | OnLanguageChanged ()
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnPaint (const Rect &repaint_rect)
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | OnSelectionChanged ()
virtual void | OnThemeChanged ()
virtual BOOLEAN | OnTimeout (const Timer &timer)
virtual void | Refresh (const Rect &rect)
void | RefreshImageCache ()
void | SwitchItemContainer (AbstractItemContainer *item_cont)

Friends

class | TriggerTimer< AbstractItemGrid >

Detailed Description

An abstract item grid may contain a variable number of items, which are displayed inside a vertically scrollable grid. If the item grid only has one column, it behaves like a listbox.

The rendering of the items is defined by an instance of the class AbstractItemRenderer, which may be changed by AbstractItemGrid::SetRenderer.

The method AbstractGrid::GetColumnCount must be overwritten to be able to instantiate the class.

See also:
AbstractItemRenderer

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractGrid.

Constructor & Destructor Documentation

AbstractItemGrid::AbstractItemGrid ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractItemGrid::AbstractItemGrid | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0
 | ) |

Parameters:
parent | Parent control where the abstract item grid is embedded.
item_cont | Item container, which specifies the items which should be part of the abstract item grid. If no item container is specified, an item container is allocated automatically internally.

AbstractItemGrid::~AbstractItemGrid ( ) [virtual]

Member Function Documentation

BOOLEAN AbstractItemGrid::AddItem ( Item * item )

Adds the item item after the already added items. For other item operations use AbstractItemGrid::GetItemContainer and invoke the corresponding methods of the AbstractItemGrid interface.

void AbstractItemGrid::Cleanup ( ) [protected, virtual]

See also:
Control::Cleanup

Reimplemented from Control.

Reimplemented in ItemMenu, and ItemTree.

void AbstractItemGrid::CleanupImageCache ( ) [protected]

Cleans up the image cache to an empty state, which means that no image is in the cache anymore.

void AbstractItemGrid::DrawItemBorder | ( | DeviceContext * | dc,
 |  | const Rect & | cell_rect,
 |  | const Rect & | item_rect,
 |  | INT | item_index
 | ) | const [protected, virtual]

Draws the item-border between the cell-rectangle and the item-rectangle for the item with the index item_index. Usually the cell-rectangle is equal to the item-rectangle, but this can be adjusted (see AbstractItemGrid::GetItemRect).

Reimplemented in ItemTree.

INT AbstractItemGrid::GetCellCount ( ) const [virtual]

See also:
AbstractGrid::GetCellCount

Implements AbstractGrid.

XYDIM AbstractItemGrid::GetCellHeight ( ) const [virtual]

Returns the item-height defined by the item-renderer.

See also:
AbstractItemGrid::SetRenderer

AbstractGrid::GetCellHeight

Implements AbstractGrid.

XYDIM AbstractItemGrid::GetHeaderHeight ( ) const [virtual]

See also:
AbstractGrid::GetHeaderHeight

Reimplemented from AbstractGrid.

Item * AbstractItemGrid::GetHeaderItem ( INT column ) const

Returns the item for the header column column.

AbstractItemContainer * AbstractItemGrid::GetItemContainer ( ) const [virtual]

Returns the item-container, which specifies the items that are part of the item grid.

Reimplemented in ItemTree.

Rect AbstractItemGrid::GetItemRect ( INT item_index ) const [protected, virtual]

Returns the boundaries for the item with the index item_index. Per default the boundaries of the cell-rectangle are returned (see AbstractGrid::GetCellRect). If this method will be overwritten to return different boundaries, it must be assured the the item-rectangle is a subset of the cell-rectangle.

Reimplemented in ItemTree.

const AbstractItemRenderer* AbstractItemGrid::GetRenderer ( ) const [inline]

Returns the renderer which is used for drawing the items.

Item * AbstractItemGrid::GetSelectedItem ( ) const

Returns the currently selected item. 0 is returned if the abstract item grid does not contain any item.

XYDIM AbstractItemGrid::GetSelectionHeight ( ) const [virtual]

See also:
AbstractGrid::GetSelectionHeight

Reimplemented from AbstractGrid.

BOOLEAN AbstractItemGrid::HasHeader ( ) const [virtual]

Returns TRUE, if a header has been set for a column with AbstractItemGrid::SetHeader

See also:
AbstractGrid::HasHeader

Reimplemented from AbstractGrid.

void AbstractItemGrid::Init | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0
 | ) |

Parameters:
parent | Parent control where the abstract item grid is embedded.
item_cont | Item container, which specifies the items which should be part of the abstract item grid. If no item container is specified, an item container is allocated automatically internally.

Reimplemented in AtlItemGrid, ItemGrid, and ItemTree.

BOOLEAN AbstractItemGrid::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractGrid.

Reimplemented in ItemGrid, ItemMenu, and ItemTree.

void AbstractItemGrid::MoveSelectedIndex ( MoveDirection move_dir ) [virtual]

See also:
AbstractGrid::MoveSelectedIndex

void AbstractItemGrid::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from AbstractGrid.

void AbstractItemGrid::OnLanguageChanged ( ) [protected, virtual]

See also:
Component::OnLanguageChanged

Reimplemented from Control.

void AbstractItemGrid::OnLoseFocus ( ) [protected, virtual]

See also:
Control::OnLoseFocus

Reimplemented from Control.

BOOLEAN AbstractItemGrid::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Component.

Reimplemented in AtlItemGrid, AtlItemMenu, and ItemTree.

void AbstractItemGrid::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

See also:
Control::OnPaint

Reimplemented from AbstractGrid.

void AbstractItemGrid::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnResize()

Reimplemented from Control.

void AbstractItemGrid::OnSelectionChanged ( ) [protected, virtual]

See also:
AbstractGrid::OnSelectionChanged

Reimplemented from AbstractGrid.

Reimplemented in ItemMenu.

void AbstractItemGrid::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged

Reimplemented from AbstractGrid.

BOOLEAN AbstractItemGrid::OnTimeout ( const Timer & timer ) [protected, virtual]

See also:
Control::OnTimeout

Reimplemented from AbstractGrid.

void AbstractItemGrid::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from AbstractGrid.

Reimplemented in ItemMenu, and ItemTree.

void AbstractItemGrid::RefreshImageCache ( ) [protected]

Refreshs the internal image cache which is used for buffering "expensive" images like JPEG or PNG. It is not necessary to invoke this method when the items have a proper dispatcher. But sometimes it might be more efficient to set the dispatcher of items temporary to 0, update the items, adjust the dispatcher and refresh the image cache in one step.

void AbstractItemGrid::SetHeaderItem | ( | INT | column,
 |  | Item * | item
 | ) |

Sets a header specified by item to the given column. The header is displayed as first row of the grid and is always visible.

void AbstractItemGrid::SetItemContainer ( AbstractItemContainer * item_cont )

Sets the item container item_cont as root item container for displaying.

BOOLEAN AbstractItemGrid::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractGrid.

Reimplemented in ItemGrid, ItemMenu, and ItemTree.

void AbstractItemGrid::SetRenderer ( const ItemRendererProperties * properties = 0 )

Sets the renderer which is used for drawing the items with the specified properties. If this method is not invoked, the default-properties specified by GuiEngineConfig::GetDefaultItemRendererProperties are used.

Parameters:
properties Item-renderer-properties which are used by the renderer.

void AbstractItemGrid::SetSelectedIndex ( INT idx ) [virtual]

See also:
AbstractGrid::SetSelectedIndex

Reimplemented from AbstractGrid.

void AbstractItemGrid::SwitchItemContainer ( AbstractItemContainer * item_cont ) [protected]

Switch to the given item container for displaying, which is useful for derived classes like ItemMenu and ItemTree, as they temporary show a sub item container. It is important to restore the old item container before deleting the item grid by invoking AbstractItemGrid::SwitchItemContainer(old_item_cont).

Friends And Related Function Documentation

friend class TriggerTimer< AbstractItemGrid > [friend]

The documentation for this class was generated from the following files:
  • Gui/AbstractItemGrid.hpp
  • Gui/AbstractItemGrid.cpp
Generated on Wed Jan 25 00:54:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractItemRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractItemRenderer Class Reference
[GUI]

#include <Apoxi/Gui/AbstractItemRenderer.hpp>

Inheritance diagram for AbstractItemRenderer:

[legend]
Collaboration diagram for AbstractItemRenderer:

[legend]

Public Types

enum ItemStyle {
DefaultStyle = 0, SelectedStyle = 1, HeaderStyle = 2, AnimatedStyle = 3,
CustomStyle = 100
}

Public Member Functions

AbstractItemRenderer (const ItemRendererProperties *properties=0)
virtual void | DrawBackground (DeviceContext *dc, const Item &item, const Rect &bounds, INT item_style) const =0
virtual void | DrawItem (DeviceContext *dc, const Item &item, const Rect &bounds, INT item_style) const =0
virtual Rect | GetIconRect (const Item &item, const Rect &bounds) const =0
virtual IconState::Size | GetIconSizeState (INT item_style=DefaultStyle) const
virtual XYDIM | GetItemHeight (INT item_style=DefaultStyle) const =0
const ItemRendererProperties * | GetProperties () const
virtual BOOLEAN | ScrollText () const
virtual BOOLEAN | StartTextScrolling (const Item &item, const Rect &bounds) const
virtual void | StopTextScrolling (const Item &item) const
virtual | ~AbstractItemRenderer ()

Protected Member Functions

void | SetProperties (const ItemRendererProperties *properties)

Detailed Description

An abstract item-renderer is used for rendering the items of any GUI-component. The renderer defines the position, size, look and animation-behavior of the item-icon and item-text.

Usually an icon of an item is represented by an APOXI-bitmap, which allows a fast drawing. But the icon may also be represented by complex image-formats like JPEG, GIF or PNG. To avoid that the item-renderer has to implement the complex rendering and animation of such images, this must be done inside the GUI-component itself by using an ImageBox, which does the rendering inside a separate thread.

The rendering and animation of the item-text must be done by the item-renderer itself.

A GUI-component using a renderer should provide the following points:

  • Obtain the renderer in Component::Refresh by invoking renderer = GuiEngineConfig::ObtainItemRenderer(renderer_properties)
  • Release the renderer in Component::Cleanup by invoking GuiEngineConfig::ReleaseItemRenderer(renderer)
  • Provide a timer, which uses the properties of the renderer as delay and triggers AbstractItemRenderer::ScrollText and AbstractItemRenderer::StartTextScrolling.
  • If the icon is represented by an image, it is recommended to use an ImageBox for the drawing (if the icon is represented by a bitmap, the renderer does the drawing automatically).

See also:
Item

AbstractItemGrid

Member Enumeration Documentation

enum AbstractItemRenderer::ItemStyle

Defines the style of the item. The item style is passed as input parameter in the methods AbstractItemRenderer::DrawBackground and AbstractItemRenderer::DrawItem.

Enumerator:
DefaultStyle | Default style. Usually animations are not handled by this style.
SelectedStyle | Style for selected items. Usually animations are handled by this style. The style is used for the selected item inside lists and menus.
HeaderStyle | Items which are part of a header. For example it is possible to define header item inside lists and menus. Usually animations are not handled by this style.
AnimatedStyle | Is like the default style, but animations are handled by this style.
CustomStyle | Values above 100 can be used for custom styles.

Constructor & Destructor Documentation

AbstractItemRenderer::AbstractItemRenderer ( const ItemRendererProperties * properties = 0 )

AbstractItemRenderer::~AbstractItemRenderer ( ) [virtual]

Member Function Documentation

virtual void AbstractItemRenderer::DrawBackground | ( | DeviceContext * | dc,
 |  | const Item & | item,
 |  | const Rect & | bounds,
 |  | INT | item_style
 | ) | const [pure virtual]

The drawing of an item is done in 3 steps: 1. draw the item-background by AbstractItemRenderer::DrawBackground 2. draw the item-icon, if it is an image 3. draw the item by AbstractItemRenderer::DrawItem

DrawBackground draws the background of each item. Usually the background of an item having another item-style (indicated by the parameter item_style) is done in a different color. Per default the whole grid-background is filled with the background-color defined in the ItemRendererProperties.

Parameters:
dc | Device-context where the drawing is done.
item | The item which will be drawn above the background.
bounds | The bounding-rectangle where the drawing of the background must be done. It is not allowed to do any drawing outside this rectangle.
item_style | Specifies the style of the item (see ItemStyle).

Implemented in AtlItemRenderer, and DefaultItemRenderer.

virtual void AbstractItemRenderer::DrawItem | ( | DeviceContext * | dc,
 |  | const Item & | item,
 |  | const Rect & | bounds,
 |  | INT | item_style
 | ) | const [pure virtual]

The drawing of an item is done in 3 steps: 1. draw the item-background by AbstractItemRenderer::DrawBackground 2. draw the item-icon, if it is an image 3. draw the item by AbstractItemRenderer::DrawItem

DrawItem draws the item itself. The icon is drawn too if it is represented by a bitmap. If the icon is an image, the control using the renderer must draw this image itself by embedding an image-box.

Parameters:
dc | Device-context where the drawing is done.
item | The item which should be drawn.
bounds | The bounding-rectangle where the drawing of the item must be done. It is not allowed to do any drawing outside this rectangle.
item_style | Specifies the style of the item (see ItemStyle).

Implemented in AtlItemRenderer, and DefaultItemRenderer.

virtual Rect AbstractItemRenderer::GetIconRect | ( | const Item & | item,
 |  | const Rect & | bounds
 | ) | const [pure virtual]

Returns the icon-rectangle where the item-grid does the drawing of the item-icon. The icon-rectangle must be inside the rectangle defined by bounds.

Parameters:
item | Item which contains the icon that should be drawn.
bounds | bounding-rectangle of the area where the drawing of the whole item should be done.

Implemented in AtlItemRenderer, and DefaultItemRenderer.

IconState::Size AbstractItemRenderer::GetIconSizeState ( INT item_style = DefaultStyle ) const [virtual]

Returns the state of the icon size: DefaultSize, SmallSize or LargeSize dependant from the given item_style item_style (see AbstractItemRenderer::ItemStyle). Per default DefaultSize is returned.

Reimplemented in DefaultItemRenderer.

virtual XYDIM AbstractItemRenderer::GetItemHeight ( INT item_style = DefaultStyle ) const [pure virtual]

Returns the height of an item in pixels dependant from the item_style (see AbstradtItemRenderer::ItemStyle).

Implemented in DefaultItemRenderer.

const ItemRendererProperties* AbstractItemRenderer::GetProperties ( ) const [inline]

BOOLEAN AbstractItemRenderer::ScrollText ( ) const [virtual]

Should be invoked after AbstractItemRenderer::StartTextScrolling each time the scroll-timer exceeds. The exceeding time of the scroll-timer is defined inside the animation-properties (see AbstractItemRenderer::GetProperties) in milliseconds.

Usually the implementation of this method just increases the internal scroll-position (e. g. mutable XYDIM m_scroll_pos), which will be initialized in AbstractItemRenderer::StartTextScrolling and used for the drawing in AbstractItemRenderer::DrawItem.

Returns:
TRUE, if the scrolling has been done. If FALSE is returned (e. g. when OnlyOnceAnimation is set), invoking this method does no further scrolling until AbstractItemRenderer::StartTextScrolling has been invoked before.

Reimplemented in DefaultItemRenderer.

void AbstractItemRenderer::SetProperties ( const ItemRendererProperties * properties ) [inline, protected]

BOOLEAN AbstractItemRenderer::StartTextScrolling | ( | const Item & | item,
 |  | const Rect & | bounds
 | ) | const [virtual]

Should be invoked if the scrolling of the text should be started. Note that this method may not invoked if the animation-properties (see AbstractItemRenderer::GetProperties) define that the text should not be animated.

Usually the implementation of this method just has to initialize an internal scroll-position (e. g. mutable XYDIM m_scroll_pos), which will be increased in AbstractItemRenderer::ScrollText and used for the drawing in AbstractItemRenderer::DrawItem.

Parameters:
item | Item whichs text should be scrolled.
bounds | The bounding-rectangle where the drawing of the item must be done. It is not allowed to do any drawing outside this rectangle.
Returns:
TRUE, if the scrolling should be started and the scroll-timer should invoke AbstractItemRenderer::ScrollText after exceeding. Usually FALSE should be returned, if the text fits into the rectangle defined by bounds.

Reimplemented in AtlItemRenderer, and DefaultItemRenderer.

void AbstractItemRenderer::StopTextScrolling ( const Item & item ) const [virtual]

Should be invoked, if the scrolling of the text should be stopped.

Reimplemented in AtlItemRenderer, and DefaultItemRenderer.

The documentation for this class was generated from the following files:
  • Gui/AbstractItemRenderer.hpp
  • Gui/AbstractItemRenderer.cpp
Generated on Wed Jan 25 00:54:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractLineEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractLineEditor Class Reference
[Editors]

#include <Apoxi/Gui/AbstractLineEditor.hpp>

Inheritance diagram for AbstractLineEditor:

[legend]
Collaboration diagram for AbstractLineEditor:

[legend]

Public Types

enum | { ID = 28 }

Public Member Functions

AbstractLineEditor (Control *parent, INT input_mapper_id)
AbstractLineEditor ()
virtual BOOLEAN | Backspace ()
virtual INT | GetCaretIndex () const
INT | GetFirstVisibleIndex () const
virtual Rect | GetItemRect (INT index) const
INT | GetVisibleItemCount () const
void | Init (Control *parent, INT input_mapper_id)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual void | MoveCaret (INT steps)
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
void | SetFirstVisibleIndex (INT index)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual void | Update ()
virtual | ~AbstractLineEditor ()

Protected Member Functions

virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Detailed Description

Abstract base class for all singleline editors. Derived classes only have to provide a document by overwriting Component::CreateModel.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractEditor.

Constructor & Destructor Documentation

AbstractLineEditor::AbstractLineEditor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractLineEditor::AbstractLineEditor | ( | Control * | parent,
 |  | INT | input_mapper_id
 | ) |

Parameters:
parent | Parent control which embeds the component.
input_mapper_id | ID of the input mapper. See InputMapper::Id for details. The corresponding instance of the input mapper can be defined in EditConfig::CreateInputMapper().

AbstractLineEditor::~AbstractLineEditor ( ) [virtual]

Member Function Documentation

BOOLEAN AbstractLineEditor::Backspace ( ) [virtual]

See also:
AbstractEditor::Backspace()

Reimplemented from AbstractEditor.

Reimplemented in PasswordEditor.

INT AbstractLineEditor::GetCaretIndex ( ) const [virtual]

See also:
AbstractEditor::GetCaretIndex()

Implements AbstractEditor.

INT AbstractLineEditor::GetFirstVisibleIndex ( ) const [inline]

Returns the first visible index of the editor. The first visible index indicates the index of the item which is visible on the upper left of the editor.

Rect AbstractLineEditor::GetItemRect ( INT index ) const [virtual]

See also:
AbstractEditor::GetItemRect()

Implements AbstractEditor.

INT AbstractLineEditor::GetVisibleItemCount ( ) const

Returns:
Number of visible items in a line (a clipped item at the right border is counted too).

void AbstractLineEditor::Init | ( | Control * | parent,
 |  | INT | input_mapper_id
 | ) |

Parameters:
parent | Parent control which embeds the component.
input_mapper_id | ID of the input mapper. See InputMapper::Id for details. The corresponding instance of the input mapper can be defined in EditConfig::CreateInputMapper().

Reimplemented from AbstractEditor.

BOOLEAN AbstractLineEditor::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::InsertItem()

Reimplemented from AbstractEditor.

Reimplemented in PasswordEditor.

BOOLEAN AbstractLineEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractEditor.

Reimplemented in DateEditor, IpAddrEditor, LineEditor, PasswordEditor, and TimeEditor.

void AbstractLineEditor::MoveCaret ( INT steps ) [virtual]

See also:
AbstractEditor::MoveCaret()

Reimplemented from AbstractEditor.

Reimplemented in DateEditor, TimeEditor, and SearchBox.

BOOLEAN AbstractLineEditor::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from AbstractEditor.

Reimplemented in PbDetailEditBox, and PbNameEditBox.

BOOLEAN AbstractLineEditor::RemoveItem ( INT index = -1 ) [virtual]

See also:
AbstractEditor::RemoveItem()

Reimplemented from AbstractEditor.

Reimplemented in PasswordEditor.

BOOLEAN AbstractLineEditor::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::ReplaceItem()

Reimplemented from AbstractEditor.

Reimplemented in PasswordEditor.

void AbstractLineEditor::SetFirstVisibleIndex ( INT index )

Sets the first visible index of the editor to index. The first visible index indicates the index of the item which is visible on the upper left of the editor.

BOOLEAN AbstractLineEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractEditor.

Reimplemented in DateEditor, IpAddrEditor, LineEditor, PasswordEditor, and TimeEditor.

void AbstractLineEditor::Update ( ) [virtual]

See also:
AbstractEditor::Update()

Reimplemented from AbstractEditor.

The documentation for this class was generated from the following files:
  • Gui/AbstractLineEditor.hpp
  • Gui/AbstractLineEditor.cpp
Generated on Wed Jan 25 00:54:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractLineEditorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractLineEditorView Class Reference
[Editors]

#include <Apoxi/Gui/AbstractLineEditor.hpp>

Inheritance diagram for AbstractLineEditorView:

[legend]
Collaboration diagram for AbstractLineEditorView:

[legend]

Public Member Functions

AbstractLineEditorView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
void | Init ()
virtual | ~AbstractLineEditorView ()

Detailed Description

Displays the content of a line editor.

Constructor & Destructor Documentation

AbstractLineEditorView::AbstractLineEditorView ( ) [explicit]

AbstractLineEditorView::~AbstractLineEditorView ( ) [virtual]

Member Function Documentation

void AbstractLineEditorView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

Reimplemented in DateEditorView.

void AbstractLineEditorView::Init ( )

The documentation for this class was generated from the following files:
  • Gui/AbstractLineEditor.hpp
  • Gui/AbstractLineEditor.cpp
Generated on Wed Jan 25 00:54:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractListBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractListBox Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/AbstractListBox.hpp>

Inheritance diagram for AbstractListBox:

[legend]
Collaboration diagram for AbstractListBox:

[legend]

Public Member Functions

AbstractListBox (Control *parent, INT item_count, ScrollBehavior behavior, INT selected_index=0)
AbstractListBox (Control *parent)
AbstractListBox ()
Behavior | GetBehavior () const
Obsolete - use GuiEngineConfig::GetScrollBehavior() instead.
INT | GetFirstVisibleIndex () const
INT | GetItemCount () const
XYDIM | GetItemHeight () const
Returns the height of an item in the listbox.
XYDIM | GetItemWidth () const
Returns the width of an item in the listbox.
INT | GetLastVisibleIndex () const
INT | GetMaxVisibleItems () const
INT | GetNoOfItems () const
Obsolete - use GetItemCount instead.
const PositionIndicator & | GetPositionIndicator () const
virtual ScrollBehavior | GetScrollBehavior () const
INT | GetSelectedIndex () const
const SmoothScrollInfo * | GetSmoothScrollInfo () const
void | Init (Control *parent, INT item_count, ScrollBehavior behavior, INT selected_index=0)
void | Init (Control *parent)
BOOLEAN | IsFocusPassingEnabled () const
virtual BOOLEAN | IsPositionIndicatorShown () const
void | SetBehavior (Behavior behavior)
void | SetFirstVisibleIndex (INT index)
void | SetFocusPassingEnabled (BOOLEAN flag)
void | SetItemCount (INT item_count)
void | SetItemHeight (XYDIM item_height)
void | SetNoOfItems (INT item_count)
Obsolete - use SetItemCount instead.
void | SetSelectedIndex (INT index)
virtual | ~AbstractListBox ()

Protected Member Functions

void | IndicateSelectionChanged ()
void | InvalidateSelectedItem ()
virtual BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
virtual void | OnLayoutClient ()
virtual void | OnNextItem ()
Is called, if the next item has been selected.
virtual void | OnPaint (const Rect &repaint_rect)
virtual BOOLEAN | OnPenDown (const Point &pen_pos)
virtual void | OnPreviousItem ()
Is called, if the previous item has been selected.
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | OnSelectionChanged ()
virtual void | OnThemeChanged ()
virtual BOOLEAN | OnTimeout (const Timer &timer)
virtual void | Refresh (const Rect &rect)
void | UpdatePositionIndicator ()
Updates values of position-indicator.

Data Structures

class | SmoothScrollInfo

Detailed Description

Obsolete - use the class ItemGrid instead, as it allows in an easier but more flexible way to create a listbox without the need to derive a subclass.

Constructor & Destructor Documentation

AbstractListBox::AbstractListBox ( )

AbstractListBox::AbstractListBox ( Control * parent )

Parameters:
parent Pointer to the window, which embedds the AbstractListBox.

AbstractListBox::~AbstractListBox ( ) [virtual]

AbstractListBox::AbstractListBox | ( | Control * | parent,
 |  | INT | item_count,
 |  | ScrollBehavior | behavior,
 |  | INT | selected_index = 0
 | ) |

Obsolete constructor - behavior is defined in GuiEngineConfig and shared by all controls for a consistent user interface.

Member Function Documentation

Behavior AbstractListBox::GetBehavior ( ) const

Obsolete - use GuiEngineConfig::GetScrollBehavior() instead.

INT AbstractListBox::GetFirstVisibleIndex ( ) const [inline]

Returns:
Index of the first visible listbox item.

INT AbstractListBox::GetItemCount ( ) const

Returns:
Number of listbox items.

XYDIM AbstractListBox::GetItemHeight ( ) const

Returns the height of an item in the listbox.

XYDIM AbstractListBox::GetItemWidth ( ) const

Returns the width of an item in the listbox.

INT AbstractListBox::GetLastVisibleIndex ( ) const

Returns:
Index of the last visible listbox item. The item may be clipped.

INT AbstractListBox::GetMaxVisibleItems ( ) const

INT AbstractListBox::GetNoOfItems ( ) const [inline]

Obsolete - use GetItemCount instead.

const PositionIndicator& AbstractListBox::GetPositionIndicator ( ) const [inline]

ScrollBehavior AbstractListBox::GetScrollBehavior ( ) const [virtual]

Returns:
The scrollbehavior defined in GuiEngineConfig::GetScrollBehavior, which represents the default scroll-behavior. This method may be overwritten when another scrollbehavior is wanted.

INT AbstractListBox::GetSelectedIndex ( ) const

Returns:
Index of the selected listbox item.

const AbstractListBox::SmoothScrollInfo * AbstractListBox::GetSmoothScrollInfo ( ) const

Returns information about the smooth scrolling. 0 is returned if smooth scrolling is not enabled.

void AbstractListBox::IndicateSelectionChanged ( ) [protected]

Invokes OnSelectionChanged and sends the message SelectionChangedMsg to the parent-window of the control.

void AbstractListBox::Init | ( | Control * | parent,
 |  | INT | item_count,
 |  | ScrollBehavior | behavior,
 |  | INT | selected_index = 0
 | ) |

Obsolete - behavior is defined in GuiEngineConfig and shared by all controls for a consistent user interface.

void AbstractListBox::Init ( Control * parent )

Parameters:
parent Pointer to the window, which embedds the AbstractListBox.

Reimplemented in CheckBoxList, and RadioButtonList.

void AbstractListBox::InvalidateSelectedItem ( ) [protected]

BOOLEAN AbstractListBox::IsFocusPassingEnabled ( ) const [inline]

Returns, whether to focus is passed to another control, if the selection exceeds the top or the bottom of the listbox.

BOOLEAN AbstractListBox::IsPositionIndicatorShown ( ) const [virtual]

Returns:
TRUE, if the position-indicator should be shown corresponding to the display-policy defined in OptionalConfig.

BOOLEAN AbstractListBox::OnInputMap ( const InputMapItem & input_map_item ) [protected, virtual]

See also:
Control::OnInputMap

Reimplemented from Control.

Reimplemented in AbstractMenuList.

void AbstractListBox::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Control.

Reimplemented in TextList.

void AbstractListBox::OnNextItem ( ) [protected, virtual]

Is called, if the next item has been selected.

Reimplemented in TextList.

void AbstractListBox::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

See also:
Control::OnPaint()

Reimplemented from Control.

BOOLEAN AbstractListBox::OnPenDown ( const Point & pen_pos ) [protected, virtual]

See also:
Control::OnPenDown

void AbstractListBox::OnPreviousItem ( ) [protected, virtual]

Is called, if the previous item has been selected.

Reimplemented in TextList.

void AbstractListBox::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Control::OnResize

Reimplemented from Control.

void AbstractListBox::OnSelectionChanged ( ) [protected, virtual]

Is called, if the selector has been moved. This method is only invoked when the parent-window is open.

void AbstractListBox::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from Control.

Reimplemented in CheckBoxList, MenuList, RadioButtonList, and TextList.

BOOLEAN AbstractListBox::OnTimeout ( const Timer & timer ) [protected, virtual]

See also:
Control::OnTimeout

Reimplemented from Control.

void AbstractListBox::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect& rect)

Reimplemented from Control.

Reimplemented in CheckBoxList, MenuList, RadioButtonList, and TextList.

void AbstractListBox::SetBehavior ( Behavior behavior )

Obsolete - behavior is defined in GuiEngineConfig and shared by all controls for a consistent user interface.

void AbstractListBox::SetFirstVisibleIndex ( INT index )

void AbstractListBox::SetFocusPassingEnabled ( BOOLEAN flag ) [inline]

If flag is set to TRUE, the focus is passed to another control, if the selection exceeds the top or the bottom of the listbox. Per default the focus-passing is disabled.

void AbstractListBox::SetItemCount ( INT item_count )

Parameters:
item_count Number of listbox items.

void AbstractListBox::SetItemHeight ( XYDIM item_height ) [inline]

Sets the height for each item of the listbox. If no height is assigned, the default-height from the View is used.

void AbstractListBox::SetNoOfItems ( INT item_count ) [inline]

Obsolete - use SetItemCount instead.

void AbstractListBox::SetSelectedIndex ( INT index )

Parameters:
index Index of the listbox item to be selected.

void AbstractListBox::UpdatePositionIndicator ( ) [protected]

Updates values of position-indicator.

The documentation for this class was generated from the following files:
  • Compat/AbstractListBox.hpp
  • Compat/AbstractListBox.cpp
Generated on Wed Jan 25 00:54:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractListBox::SmoothScrollInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
AbstractListBox::SmoothScrollInfo

AbstractListBox::SmoothScrollInfo Class Reference

#include <Apoxi/Compat/AbstractListBox.hpp>

Collaboration diagram for AbstractListBox::SmoothScrollInfo:

[legend]

Public Member Functions

XYDIM | GetDiff () const
XYDIM | GetInc () const
const Timer & | GetTimer () const
BOOLEAN | IsSelector () const

Friends

class | AbstractListBox

Detailed Description

Contains information about smooth scrolling and can be retrieved by derived classes by invoking AbstractListBox::GetSmoothScrollInfo. Usually it is not necessary to care about this information, but might be useful if additional components must be coordinated with the smooth scrolling.

Member Function Documentation

XYDIM AbstractListBox::SmoothScrollInfo::GetDiff ( ) const [inline]

Returns the current difference in pixels of the original placement in comparison to the smooth scrolled placement. The value is always smaller than the height/width of a cell.

XYDIM AbstractListBox::SmoothScrollInfo::GetInc ( ) const [inline]

Returns the increment which is added when the scroll timer expires.

const Timer& AbstractListBox::SmoothScrollInfo::GetTimer ( ) const [inline]

Returns the timer which triggers the smooth scrolling.

BOOLEAN AbstractListBox::SmoothScrollInfo::IsSelector ( ) const [inline]

Returns TRUE, if the selector is scrolled smoothly. Otherwise the whole content will be scrolled.

Friends And Related Function Documentation

friend class AbstractListBox [friend]

The documentation for this class was generated from the following file:
  • Compat/AbstractListBox.hpp
Generated on Wed Jan 25 00:54:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractListBoxModel Class Reference
[Obsolete GUI classes]

Obsolete, as the class AbstractListBox has been replaced by the class ItemGrid. More...

#include <Apoxi/Compat/AbstractListBox.hpp>

Inheritance diagram for AbstractListBoxModel:

[legend]
Collaboration diagram for AbstractListBoxModel:

[legend]

Public Member Functions

AbstractListBoxModel (INT item_count, INT selected_index)
AbstractListBoxModel (INT item_count)
AbstractListBoxModel ()
INT | GetFirstVisibleIndex () const
Obsolete - use AbstractListBox::GetFirstVisibleIndex instead.
INT | GetItemCount () const
AbstractListBox * | GetListBox () const
Returns a pointer to the listbox the model belongs to.
INT | GetMaxVisibleItems () const
Obsolete - use AbstractListBox::GetMaxVisibleItems instead.
INT | GetNoOfItems () const
Obsolete - use GetItemCount instead.
INT | GetSelectedIndex () const
Obsolete - use AbstractListBox::GetSelectedIndex instead.
void | Init (INT item_count, INT selected_index)
void | Init (INT item_count)
void | SetFirstVisibleIndex (INT index)
Obsolete - use AbstractListBox::SetFirstVisibleIndex instead.
void | SetItemCount (INT item_count)
void | SetListBox (AbstractListBox *list_box)
Sets the listbox the model belongs to.
void | SetMaxVisibleItems (INT max_visible_items)
Obsolete - use AbstractListBox::SetMaxVisibleItems instead.
void | SetNoOfItems (INT item_count)
Obsolete - use SetItemCount instead.
void | SetSelectedIndex (INT index)
Obsolete - use AbstractListBox::SetSelectedIndex instead.
virtual | ~AbstractListBoxModel ()

Detailed Description

Obsolete, as the class AbstractListBox has been replaced by the class ItemGrid.

Constructor & Destructor Documentation

AbstractListBoxModel::AbstractListBoxModel ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractListBoxModel::AbstractListBoxModel ( INT item_count )

AbstractListBoxModel::~AbstractListBoxModel ( ) [virtual]

AbstractListBoxModel::AbstractListBoxModel | ( | INT | item_count,
 |  | INT | selected_index
 | ) |

Obsolete - selected index is ignored. Use AbstractListBox::SetSelectedIndex() instead.

Member Function Documentation

INT AbstractListBoxModel::GetFirstVisibleIndex ( ) const

Obsolete - use AbstractListBox::GetFirstVisibleIndex instead.

INT AbstractListBoxModel::GetItemCount ( ) const [inline]

AbstractListBox* AbstractListBoxModel::GetListBox ( ) const [inline]

Returns a pointer to the listbox the model belongs to.

INT AbstractListBoxModel::GetMaxVisibleItems ( ) const

Obsolete - use AbstractListBox::GetMaxVisibleItems instead.

INT AbstractListBoxModel::GetNoOfItems ( ) const [inline]

Obsolete - use GetItemCount instead.

INT AbstractListBoxModel::GetSelectedIndex ( ) const

Obsolete - use AbstractListBox::GetSelectedIndex instead.

void AbstractListBoxModel::Init | ( | INT | item_count,
 |  | INT | selected_index
 | ) |

Obsolete - selected index is ignored. Use AbstractListBox::SetSelectedIndex() instead.

Reimplemented in AbstractMenuListModel< Item >.

void AbstractListBoxModel::Init ( INT item_count )

Reimplemented in AbstractMenuListModel< Item >.

void AbstractListBoxModel::SetFirstVisibleIndex ( INT index )

Obsolete - use AbstractListBox::SetFirstVisibleIndex instead.

void AbstractListBoxModel::SetItemCount ( INT item_count )

void AbstractListBoxModel::SetListBox ( AbstractListBox * list_box ) [inline]

Sets the listbox the model belongs to.

void AbstractListBoxModel::SetMaxVisibleItems ( INT max_visible_items )

Obsolete - use AbstractListBox::SetMaxVisibleItems instead.

void AbstractListBoxModel::SetNoOfItems ( INT item_count ) [inline]

Obsolete - use SetItemCount instead.

void AbstractListBoxModel::SetSelectedIndex ( INT index )

Obsolete - use AbstractListBox::SetSelectedIndex instead.

The documentation for this class was generated from the following files:
  • Compat/AbstractListBox.hpp
  • Compat/AbstractListBox.cpp
Generated on Wed Jan 25 00:54:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractListBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractListBoxView Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/AbstractListBox.hpp>

Inheritance diagram for AbstractListBoxView:

[legend]
Collaboration diagram for AbstractListBoxView:

[legend]

Public Member Functions

AbstractListBoxView (XYDIM default_item_height)
AbstractListBoxView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
Draws the listbox.
virtual void | DrawItem (const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const
XYDIM | GetDefaultItemHeight () const
Returns the item-height of the listbox.
Rect | GetItemRect (const AbstractListBox &listbox, INT index) const
void | Init (XYDIM default_item_height)
BOOLEAN | IsBackgrDrawingEnabled () const
void | SetDefaultItemHeight (XYDIM default_item_height)
Sets the item-height of the listbox.
virtual | ~AbstractListBoxView ()

Constructor & Destructor Documentation

AbstractListBoxView::AbstractListBoxView ( )

AbstractListBoxView::AbstractListBoxView ( XYDIM default_item_height )

virtual AbstractListBoxView::~AbstractListBoxView ( ) [inline, virtual]

Member Function Documentation

void AbstractListBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Draws the listbox.

Implements View.

void AbstractListBoxView::DrawItem | ( | const AbstractListBox & | listbox,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [virtual]

Reimplemented in CheckBoxListView, MenuListView, ProviderListBoxView, RadioButtonListView, TextListView, and ImageListBoxView.

XYDIM AbstractListBoxView::GetDefaultItemHeight ( ) const [inline]

Returns the item-height of the listbox.

Rect AbstractListBoxView::GetItemRect | ( | const AbstractListBox & | listbox,
 |  | INT | index
 | ) | const

void AbstractListBoxView::Init ( XYDIM default_item_height )

Reimplemented in ImageListBoxView.

BOOLEAN AbstractListBoxView::IsBackgrDrawingEnabled ( ) const [inline]

void AbstractListBoxView::SetDefaultItemHeight ( XYDIM default_item_height ) [inline]

Sets the item-height of the listbox.

The documentation for this class was generated from the following files:
  • Compat/AbstractListBox.hpp
  • Compat/AbstractListBox.cpp
Generated on Wed Jan 25 00:54:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractLockableDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractLockableDevice Class Reference
[Devices]

Abstract base class for all hardware devices. More...

#include <Apoxi/Devices/AbstractLockableDevice.hpp>

Inheritance diagram for AbstractLockableDevice:

[legend]
Collaboration diagram for AbstractLockableDevice:

[legend]

Public Member Functions

AbstractLockableDevice (INT category, INT device_id)
virtual BOOLEAN | Lock ()
virtual BOOLEAN | Unlock ()

Protected Member Functions

virtual BOOLEAN & | GetLock ()=0

Detailed Description

Abstract base class for all hardware devices.

Constructor & Destructor Documentation

AbstractLockableDevice::AbstractLockableDevice | ( | INT | category,
 |  | INT | device_id
 | ) | [inline]

Member Function Documentation

virtual BOOLEAN& AbstractLockableDevice::GetLock ( ) [protected, pure virtual]

Implemented in Camera, Camera, Camera, Camera, Camera, and Camera.

BOOLEAN AbstractLockableDevice::Lock ( ) [virtual]

Locks an device for exclusive using

Returns:
TRUE if locking was successful, FALSE if device is locked by another application

BOOLEAN AbstractLockableDevice::Unlock ( ) [virtual]

Unlocks a previously locked device

Returns:
TRUE if unlocking was successful, FALSE if not

The documentation for this class was generated from the following files:
  • Devices/AbstractLockableDevice.hpp
  • Devices/AbstractLockableDevice.cpp
Generated on Wed Jan 25 00:54:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractMenuAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractMenuAccessor Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/AbstractMenuAccessor.hpp>

Inheritance diagram for AbstractMenuAccessor:

[legend]
Collaboration diagram for AbstractMenuAccessor:

[legend]

Public Member Functions

AbstractMenuAccessor ()
virtual void | Back (Menu *menu)=0
virtual void | Draw (DeviceContext *dc, const Rect &draw_rect, BOOLEAN highlighted)=0
virtual BOOLEAN | First ()=0
virtual INT | GetColumnCount () const
virtual XYDIM | GetItemHeight () const =0
virtual XYDIM | GetItemWidth () const
void | Init ()
virtual BOOLEAN | IsEnabled ()
virtual BOOLEAN | IsRoot ()
virtual BOOLEAN | Next ()=0
virtual void | Trigger (Menu *menu)=0
virtual | ~AbstractMenuAccessor ()

Protected Member Functions

virtual void | OnActivate (Menu *menu, AbstractMenuAccessor *parent_accessor)
This method will be called every time the MenuAccessor will be activated (after changing a menu level).
virtual void | OnDeactivate (Menu *menu)
This method will be called every time the MenuAccessor will be deactivated (before changing a menu level).
virtual void | OnLanguageChanged ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnSelectionChanged (INT selected_idx)
This method will be called every time the selection of the menu changes.

Friends

class | Menu

Detailed Description

Obsolete - the class Menu, which uses the AbstractMenuAccessor, has been replaced by the classes ItemMenu and ItemTree.

Constructor & Destructor Documentation

AbstractMenuAccessor::AbstractMenuAccessor ( )

The documentation for this class was generated from the following files:
  • Compat/AbstractMenuAccessor.hpp
  • Compat/AbstractMenuAccessor.cpp
Generated on Wed Jan 25 00:54:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractMenuList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractMenuList Class Reference

Is an abstract listbox, which is the base for MenuList, CheckBoxList, RadioButtonList, ... More...

#include <Apoxi/Compat/AbstractMenuList.hpp>

Inheritance diagram for AbstractMenuList:

[legend]
Collaboration diagram for AbstractMenuList:

[legend]

Public Member Functions

AbstractMenuList (Control *parent, INT n_items=0, Behavior behavior=DefaultBehavior, INT selected_index=0)
AbstractMenuList ()
virtual | ~AbstractMenuList ()

Protected Member Functions

virtual BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
virtual void | OnItemSelected ()
Is called, if an item of the menu has been selected.
virtual BOOLEAN | OnPenUp (const Point &pen_pos)
virtual BOOLEAN | OnSoftkeyPressed (INT idx)

Detailed Description

Is an abstract listbox, which is the base for MenuList, CheckBoxList, RadioButtonList, ...

Constructor & Destructor Documentation

AbstractMenuList::AbstractMenuList ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractMenuList::AbstractMenuList | ( | Control * | parent,
 |  | INT | n_items = 0,
 |  | Behavior | behavior = DefaultBehavior,
 |  | INT | selected_index = 0
 | ) |

See also:
AbstractListBox::AbstractListBox

AbstractMenuList::~AbstractMenuList ( ) [virtual]

Member Function Documentation

BOOLEAN AbstractMenuList::OnInputMap ( const InputMapItem & input_map_item ) [protected, virtual]

See also:
Control::OnInputMap

Reimplemented from AbstractListBox.

void AbstractMenuList::OnItemSelected ( ) [protected, virtual]

Is called, if an item of the menu has been selected.

Reimplemented in CheckBoxList, MenuList, and RadioButtonList.

BOOLEAN AbstractMenuList::OnPenUp ( const Point & pen_pos ) [protected, virtual]

See also:
Window OnPenUp

BOOLEAN AbstractMenuList::OnSoftkeyPressed ( INT idx ) [protected, virtual]

See also:
Control::OnSoftkeyPressed()

Reimplemented in RadioButtonList.

The documentation for this class was generated from the following files:
  • Compat/AbstractMenuList.hpp
  • Compat/AbstractMenuList.cpp
Generated on Wed Jan 25 00:55:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractMenuListModel< Item > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractMenuListModel< Item > Class Template Reference

#include <Apoxi/Compat/AbstractMenuList.hpp>

Inheritance diagram for AbstractMenuListModel< Item >:

[legend]
Collaboration diagram for AbstractMenuListModel< Item >:

[legend]

Public Member Functions

AbstractMenuListModel (INT n_items)
AbstractMenuListModel (INT n_items, INT selected_index)
AbstractMenuListModel ()
void | AddItem (Item *item)
void | AddItem (Item *item, Item *after)
Item * | GetFirstItem () const
Returns the first item of the item-list.
Item * | GetItemForIndex (INT index) const
void | Init (INT n_items)
void | Init (INT n_items, INT selected_index)
void | RemoveAllItems ()
Removes all items.
void | RemoveItem (Item *item)
Removes the item item from the menu-list.

template<class Item>
class AbstractMenuListModel< Item >

Constructor & Destructor Documentation

template<class Item>
AbstractMenuListModel< Item >::AbstractMenuListModel ( )

template<class Item>
AbstractMenuListModel< Item >::AbstractMenuListModel | ( | INT | n_items,
 |  | INT | selected_index
 | ) |

template<class Item>
AbstractMenuListModel< Item >::AbstractMenuListModel ( INT n_items )

Member Function Documentation

template<class Item>
void AbstractMenuListModel< Item >::AddItem ( Item * item ) [inline]

template<class Item>
void AbstractMenuListModel< Item >::AddItem | ( | Item * | item,
 |  | Item * | after
 | ) |

Adds the item item into the menu-list. By default the item is appended to the end of the menu-list. If you want to insert the item after an other item, hand over this item in item.

template<class Item>
Item * AbstractMenuListModel< Item >::GetFirstItem ( ) const

Returns the first item of the item-list.

template<class Item>
Item * AbstractMenuListModel< Item >::GetItemForIndex ( INT index ) const

template<class Item>
void AbstractMenuListModel< Item >::Init ( INT n_items ) [inline]

Reimplemented from AbstractListBoxModel.

template<class Item>
void AbstractMenuListModel< Item >::Init | ( | INT | n_items,
 |  | INT | selected_index
 | ) |

Obsolete - selected index is ignored. Use AbstractListBox::SetSelectedIndex() instead.

Reimplemented from AbstractListBoxModel.

template<class Item>
void AbstractMenuListModel< Item >::RemoveAllItems ( )

Removes all items.

template<class Item>
void AbstractMenuListModel< Item >::RemoveItem ( Item * item )

Removes the item item from the menu-list.

The documentation for this class was generated from the following file:
  • Compat/AbstractMenuList.hpp
Generated on Wed Jan 25 00:55:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractMessageMapContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractMessageMapContainer Class Reference
[Kernel]

#include <Apoxi/Kernel/MessageMap.hpp>

Inheritance diagram for AbstractMessageMapContainer:

[legend]

Public Member Functions

virtual BOOLEAN | Execute (const Message &msg) const =0
virtual void | Register () const =0
virtual void | Unregister () const =0

Member Function Documentation

virtual BOOLEAN AbstractMessageMapContainer::Execute ( const Message & msg ) const [pure virtual]

Implemented in MessageMapContainer< T >, and MessageMapContainer< StackMsgActiveWaitDispatcher >.

virtual void AbstractMessageMapContainer::Register ( ) const [pure virtual]

Implemented in MessageMapContainer< T >, and MessageMapContainer< StackMsgActiveWaitDispatcher >.

virtual void AbstractMessageMapContainer::Unregister ( ) const [pure virtual]

Implemented in MessageMapContainer< T >, and MessageMapContainer< StackMsgActiveWaitDispatcher >.

The documentation for this class was generated from the following file:
  • Kernel/MessageMap.hpp
Generated on Wed Jan 25 00:55:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractMultiLineEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractMultiLineEditor Class Reference
[Editors]

Abstract base class for all multiline editors. More...

#include <Apoxi/Gui/AbstractMultiLineEditor.hpp>

Inheritance diagram for AbstractMultiLineEditor:

[legend]
Collaboration diagram for AbstractMultiLineEditor:

[legend]

Public Types

enum | { ID = 29 }
enum | CaretAction { CaretLeft, CaretRight, CaretLineUp, CaretLineDown }

Public Member Functions

AbstractMultiLineEditor (Control *parent, INT input_mapper_id)
AbstractMultiLineEditor ()
virtual BOOLEAN | Backspace ()
virtual INT | GetCaretIndex () const
virtual BOOLEAN | GetCharItem (INT index, WCHAR &chr) const
XYDIM | GetContentLeft () const
INT | GetFirstVisibleLineIndex () const
Returns the first visible line index shown on the upper border.
virtual Rect | GetItemRect (INT index) const
const EditorLine & | GetLine (INT line_idx) const
Return the line description of the line line_idx.
XYDIM | GetLineAlignInc (INT index, INT count, XYDIM width) const
INT | GetLineCount () const
XYDIM | GetMaxContentWidth () const
INT | GetVisibleLineCount (BOOLEAN *line_clipped=0) const
WrapPolicy | GetWrapPolicy () const
void | Init (Control *parent, INT input_mapper_id)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsPositionIndicatorEnabled () const
BOOLEAN | IsPositionIndicatorLeftAligned () const
Returns TRUE, if the position-indicator is aligned on the left side.
virtual BOOLEAN | IsStandaloneItem (INT index) const
BOOLEAN | IsUpDownPermitted () const
virtual void | MoveCaret (INT steps)
virtual void | NavigateCaret (CaretAction caret_action)
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
virtual void | SetFirstVisibleLineIndex (INT line_idx)
void | SetPositionIndicatorEnabled (BOOLEAN flag)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetUpDownPermitted (BOOLEAN flag)
void | SetWrapPolicy (WrapPolicy wrap_policy)
virtual void | Update ()
virtual | ~AbstractMultiLineEditor ()

Protected Member Functions

void | Layout (INT line_idx=0, INT added_items=-1)
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
virtual void | OnPaint (const Rect &repaint_rect)
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | Refresh (const Rect &rect)

Detailed Description

Abstract base class for all multiline editors.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractEditor.

enum AbstractMultiLineEditor::CaretAction

Defines the command which can given to the method AbstractMultiLineEditor::NavigateCaret.

Enumerator:
CaretLeft | The caret will be moved one item to the left. If the caret is on the left most border, it will be aligned on the last item of the previous line.
CaretRight | The caret will be moved one item to the right. If the caret is on the right most border, it will be aligned on the first item of the next line.
CaretLineUp | The caret will be moved to the previous line at the same horizontal position if possible.
CaretLineDown | The caret will be moved to the next line at the same horizontal position if possible.

Constructor & Destructor Documentation

AbstractMultiLineEditor::AbstractMultiLineEditor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractMultiLineEditor::AbstractMultiLineEditor | ( | Control * | parent,
 |  | INT | input_mapper_id
 | ) |

Parameters:
parent | Pointer to parent control, which includes the control as child.
input_mapper_id | Describes the input mapper which should be used when for the textinput. See InputMapper::Id for details.

AbstractMultiLineEditor::~AbstractMultiLineEditor ( ) [virtual]

Member Function Documentation

BOOLEAN AbstractMultiLineEditor::Backspace ( ) [virtual]

See also:
AbstractEditor::Backspace()

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor, EmsEditor, and SmsEditor.

INT AbstractMultiLineEditor::GetCaretIndex ( ) const [virtual]

See also:
AbstractEditor::GetCaretIndex()

Implements AbstractEditor.

BOOLEAN AbstractMultiLineEditor::GetCharItem | ( | INT | index,
 |  | WCHAR & | chr
 | ) | const [virtual]

Returns the character at the position index into the output parameter chr.

Parameters:
index | Index of the item.
chr | Output parameter, which contains the character if the item is an instance of a character.
Returns:
TRUE, if the item on the given index is an instance of a character.

Reimplemented in MultiMediaEditor.

XYDIM AbstractMultiLineEditor::GetContentLeft ( ) const

Returns the number of pixels from the left, where the content starts. Normally 0 is returned except the position-indicator is aligned on the left side.

INT AbstractMultiLineEditor::GetFirstVisibleLineIndex ( ) const [inline]

Returns the first visible line index shown on the upper border.

Rect AbstractMultiLineEditor::GetItemRect ( INT index ) const [virtual]

See also:
AbstractEditor::GetItemRect()

Implements AbstractEditor.

const EditorLine& AbstractMultiLineEditor::GetLine ( INT line_idx ) const [inline]

Return the line description of the line line_idx.

XYDIM AbstractMultiLineEditor::GetLineAlignInc | ( | INT | index,
 |  | INT | count,
 |  | XYDIM | width
 | ) | const

Parameters:
index | Start-index of first Item in the line.
count | Number of Items in the line.
width | Available width in pixels for the line.
Returns:
x-increment for the line dependant from the current set line-alignment of the document for this line.

INT AbstractMultiLineEditor::GetLineCount ( ) const [inline]

Returns:
Total number of lines inside the editor. For getting the number of visible lines, use AbstractMultiLineEditor::GetVisibleLineCount.

XYDIM AbstractMultiLineEditor::GetMaxContentWidth ( ) const

Returns the maximum width in pixels of the content. The width is different from the client-width because of the position-indicator.

INT AbstractMultiLineEditor::GetVisibleLineCount ( BOOLEAN * line_clipped = 0 ) const

Parameters:
line_clipped Optional output-parameter, which is TRUE, when the last visible line is clipped.
Returns:
Number of currently visible lines.

WrapPolicy AbstractMultiLineEditor::GetWrapPolicy ( ) const [inline]

Returns the wrapping policy which is used for aligning the lines of the document. (see EditorDocument::WrapPolicy for details). Per default EditorDocument::WhitespaceWrap is returned.

void AbstractMultiLineEditor::Init | ( | Control * | parent,
 |  | INT | input_mapper_id
 | ) |

Parameters:
parent | Pointer to parent control, which includes the control as child.
input_mapper_id | Describes the input mapper which should be used when for the textinput. See InputMapper::Id for details.

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor.

BOOLEAN AbstractMultiLineEditor::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::InsertItem()

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor, EmsEditor, and SmsEditor.

BOOLEAN AbstractMultiLineEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor, and MultiLineEditor.

BOOLEAN AbstractMultiLineEditor::IsPositionIndicatorEnabled ( ) const [inline]

Returns, whether the position-indicator is enabled.

See also:
SetPositionIndicatorEnabled

BOOLEAN AbstractMultiLineEditor::IsPositionIndicatorLeftAligned ( ) const

Returns TRUE, if the position-indicator is aligned on the left side.

BOOLEAN AbstractMultiLineEditor::IsStandaloneItem ( INT index ) const [virtual]

See also:
AbstractEditor::IsStandaloneItem

Reimplemented from AbstractEditor.

BOOLEAN AbstractMultiLineEditor::IsUpDownPermitted ( ) const [inline]

Returns:
TRUE, if the arrow keys for up and down are permitted and hence not ignored.

void AbstractMultiLineEditor::Layout | ( | INT | line_idx = 0,
 |  | INT | added_items = -1
 | ) | [protected]

Triggers a layouting of all lines starting from the line given by line_idx. If items have been added this hint can be given by added_items, which usually results in an optimized layouting performance.

void AbstractMultiLineEditor::MoveCaret ( INT steps ) [virtual]

See also:
AbstractEditor::MoveCaret()

Reimplemented from AbstractEditor.

void AbstractMultiLineEditor::NavigateCaret ( CaretAction caret_action ) [virtual]

void AbstractMultiLineEditor::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from AbstractEditor.

Reimplemented in SmsEditor.

BOOLEAN AbstractMultiLineEditor::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor.

void AbstractMultiLineEditor::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Control.

Reimplemented in MultiMediaEditor.

void AbstractMultiLineEditor::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

See also:
Control::OnPaint

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor.

void AbstractMultiLineEditor::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnResize

Reimplemented from Control.

void AbstractMultiLineEditor::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor.

BOOLEAN AbstractMultiLineEditor::RemoveItem ( INT index = -1 ) [virtual]

See also:
AbstractEditor::RemoveItem()

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor, EmsEditor, and SmsEditor.

BOOLEAN AbstractMultiLineEditor::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::ReplaceItem()

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor, and EmsEditor.

void AbstractMultiLineEditor::SetFirstVisibleLineIndex ( INT line_idx ) [virtual]

Sets the first visible line index shown on the upper border. The position of the caret won't be modified.

Reimplemented in MultiMediaEditor.

void AbstractMultiLineEditor::SetPositionIndicatorEnabled ( BOOLEAN flag )

Allows to enable or disable the position-indicator. Per default the position-indicator is enabled and hence always shown. Note that it is not possible to show the position-indicator on demand, which means dependend whether the content fits into one page or not.

There are two reasons for this:

  1. The most expensive operation concerning runtime is the layouting of the content, which means calculating the line-breaks dependend on the available width of the editor. To find out, whether a position-indicator has to be shown a layouting has to be done with the maximum width. If the content does not fit into one page, the width decreases by the width of the position-indicator and the layouting has to be redone. This means when editing long texts the layouting has to be done twice, which may result to runtime problems especially for editors with complex content like the multi-media-editor.
  2. Additionally to this runtime problem a usability-problem would be introduced, when the position-indicator is shown dynamically: meanwhile typing a text at the bottom of a page a complete relayout would be the result as soon as the position-indicator is shown, which is quite confusing. This is also the reason why all editors on big desktop-systems don't have a dynamic position-indicator too.

BOOLEAN AbstractMultiLineEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor, and MultiLineEditor.

void AbstractMultiLineEditor::SetUpDownPermitted ( BOOLEAN flag ) [inline]

If flag is FALSE, the multi-line-editor ignores the arrow-keys for up and down. This might be wanted when a multi-line-editor shares a window with other controls to enable a navigation between the controls by the arrow-keys.

void AbstractMultiLineEditor::SetWrapPolicy ( WrapPolicy wrap_policy )

Sets the wrapping policy which is used for aligning the lines of the document (see EditorDocument::WrapPolicy for details). Per default EditorDocument::WhitespaceWrap is used.

void AbstractMultiLineEditor::Update ( ) [virtual]

See also:
AbstractEditor::Update()

Reimplemented from AbstractEditor.

Reimplemented in MultiMediaEditor.

The documentation for this class was generated from the following files:
  • Gui/AbstractMultiLineEditor.hpp
  • Gui/AbstractMultiLineEditor.cpp
Generated on Wed Jan 25 00:55:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractMultiLineEditorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractMultiLineEditorView Class Reference
[Editors]

View which shows the content of a multiline editor. More...

#include <Apoxi/Gui/AbstractMultiLineEditor.hpp>

Inheritance diagram for AbstractMultiLineEditorView:

[legend]
Collaboration diagram for AbstractMultiLineEditorView:

[legend]

Public Member Functions

AbstractMultiLineEditorView (XYDIM default_width=-1, XYDIM default_height=-1)
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual | ~AbstractMultiLineEditorView ()

Detailed Description

View which shows the content of a multiline editor.

Constructor & Destructor Documentation

AbstractMultiLineEditorView::AbstractMultiLineEditorView | ( | XYDIM | default_width = -1,
 |  | XYDIM | default_height = -1
 | ) | [explicit]

AbstractMultiLineEditorView::~AbstractMultiLineEditorView ( ) [virtual]

Member Function Documentation

void AbstractMultiLineEditorView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

The documentation for this class was generated from the following files:
  • Gui/AbstractMultiLineEditor.hpp
  • Gui/AbstractMultiLineEditor.cpp
Generated on Wed Jan 25 00:55:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractPredictiveInputBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractPredictiveInputBox Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp>

Inheritance diagram for AbstractPredictiveInputBox:

[legend]
Collaboration diagram for AbstractPredictiveInputBox:

[legend]

Public Types

enum | PredBitmapId { UpDownArrowBitmapId, DownArrowBitmapId, UpArrowBitmapId, SelectBitmapId }
Specifies the bitmaps used by the input-boxes. More...
enum PredFontId {
SelectionBoxIndexId, SelectionBoxSimpId, SelectionBoxTradId, SelectionBoxChineseId,
StrokeBoxId, PinyinBoxNumbersId, SelectionBoxComponentsId, PinyinBoxCharsId
}
Specifies the font used by the input-boxes. More...

Public Member Functions

AbstractPredictiveInputBox (Control *parent, AbstractMultiLineEditor *m_editor, Window *add_word_to_dict_win=0, Window *ext_punc_win=0)
AbstractPredictiveInputBox ()
virtual BOOLEAN | AddNewWordToUdb (const WString &word)=0
virtual INT | GetCapsStatus () const =0
PredInputMapper::PredMode | GetMode () const
void | Init (Control *parent, AbstractMultiLineEditor *m_editor, Window *add_word_to_dict_win=0, Window *ext_punc_win=0)
virtual BOOLEAN | IsModeSupported (PredInputMapper::PredMode mode)
virtual BOOLEAN | SetMode (PredInputMapper::PredMode mode)
virtual | ~AbstractPredictiveInputBox ()

Protected Member Functions

virtual void | OnGetFocus ()
virtual void | UpdateDrawableObjects ()=0

Protected Attributes

Window * m_add_word_to_dict_win
AbstractMultiLineEditor * m_editor
Window * m_ext_punc_win

Member Enumeration Documentation

enum AbstractPredictiveInputBox::PredBitmapId

Specifies the bitmaps used by the input-boxes.

Enumerator:
UpDownArrowBitmapId | Bitmap for displaying the up/down arrow.
DownArrowBitmapId | Bitmap for displaying the down arrow.
UpArrowBitmapId | Bitmap for displaying the Up arrow.
SelectBitmapId | Obsolete - Bitmap for indicating the selection in pinyin.

enum AbstractPredictiveInputBox::PredFontId

Specifies the font used by the input-boxes.

Enumerator:
SelectionBoxIndexId
SelectionBoxSimpId
SelectionBoxTradId
SelectionBoxChineseId
StrokeBoxId
PinyinBoxNumbersId
SelectionBoxComponentsId
PinyinBoxCharsId

Constructor & Destructor Documentation

AbstractPredictiveInputBox::AbstractPredictiveInputBox ( )

AbstractPredictiveInputBox::AbstractPredictiveInputBox | ( | Control * | parent,
 |  | AbstractMultiLineEditor * | m_editor,
 |  | Window * | add_word_to_dict_win = 0,
 |  | Window * | ext_punc_win = 0
 | ) |

AbstractPredictiveInputBox::~AbstractPredictiveInputBox ( ) [virtual]

Member Function Documentation

virtual BOOLEAN AbstractPredictiveInputBox::AddNewWordToUdb ( const WString & word ) [pure virtual]

Implemented in T9PredictiveInputBox, and Zi8PredictiveInputBox.

virtual INT AbstractPredictiveInputBox::GetCapsStatus ( ) const [pure virtual]

Implemented in T9PredictiveInputBox, and Zi8PredictiveInputBox.

PredInputMapper::PredMode AbstractPredictiveInputBox::GetMode ( ) const

void AbstractPredictiveInputBox::Init | ( | Control * | parent,
 |  | AbstractMultiLineEditor * | m_editor,
 |  | Window * | add_word_to_dict_win = 0,
 |  | Window * | ext_punc_win = 0
 | ) |

Reimplemented in T9PredictiveInputBox, and Zi8PredictiveInputBox.

BOOLEAN AbstractPredictiveInputBox::IsModeSupported ( PredInputMapper::PredMode mode ) [virtual]

void AbstractPredictiveInputBox::OnGetFocus ( ) [protected, virtual]

Is called, if the control gets the focus. When a Control has the focus, all messages of the type MC_FOCUS are forwarded to this Control.

Reimplemented from Control.

BOOLEAN AbstractPredictiveInputBox::SetMode ( PredInputMapper::PredMode mode ) [virtual]

Reimplemented in T9PredictiveInputBox, and Zi8PredictiveInputBox.

virtual void AbstractPredictiveInputBox::UpdateDrawableObjects ( ) [protected, pure virtual]

Implemented in T9PredictiveInputBox, and Zi8PredictiveInputBox.

Field Documentation

Window* AbstractPredictiveInputBox::m_add_word_to_dict_win [protected]

AbstractMultiLineEditor* AbstractPredictiveInputBox::m_editor [protected]

Window* AbstractPredictiveInputBox::m_ext_punc_win [protected]

The documentation for this class was generated from the following files:
  • AddOns/GuiInputExtensions/AbstractPredictiveInputBox.hpp
  • AddOns/GuiInputExtensions/AbstractPredictiveInputBox.cpp
Generated on Wed Jan 25 00:55:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractRenderer Class Reference
[GUI]

#include <Apoxi/Gui/AbstractRenderer.hpp>

Public Member Functions

AbstractRenderer ()
virtual void | Draw (DeviceContext *dc) const =0
virtual | ~AbstractRenderer ()

Constructor & Destructor Documentation

AbstractRenderer::AbstractRenderer ( )

AbstractRenderer::~AbstractRenderer ( ) [virtual]

Member Function Documentation

virtual void AbstractRenderer::Draw ( DeviceContext * dc ) const [pure virtual]

The documentation for this class was generated from the following files:
  • Gui/AbstractRenderer.hpp
  • Gui/AbstractRenderer.cpp
Generated on Wed Jan 25 00:55:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractScheduler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractScheduler Class Reference
[Kernel]

#include <Apoxi/Kernel/AbstractScheduler.hpp>

Inheritance diagram for AbstractScheduler:

[legend]
Collaboration diagram for AbstractScheduler:

[legend]

Public Member Functions

AbstractScheduler (AppContainer *cont)
void | AddAppContext (Application *app)
virtual AbstractAppContext * | CreateAppContext (Application *app)=0
AbstractAppContext * | GetAppContext (const Application *app) const
void | RemoveAppContext (const Application *app)
virtual void | Reschedule ()=0
virtual void | SendMsg (const Application *app, Message &msg)=0
virtual void | ShutDown ()
virtual void | StartUp ()=0
virtual void | Wait (const Application *app, const Condition &cond)=0
virtual | ~AbstractScheduler ()
Destroys the AbstractScheduler.

Protected Attributes

LinkedList< AbstractAppContext > m_appcntxt_list
AppContainer * m_cont
LinkedList< AbstractAppContext > m_rem_appcntxt_list
BOOLEAN | m_unblock_focus_messages

Friends

class | AppContainer
class | Os

Detailed Description

AbstractScheduler is the base class for each concrete, OS-dependent Scheduler implementation. It provides some common functionality, like holding a list of AbstractAppContexts.

Constructor & Destructor Documentation

AbstractScheduler::AbstractScheduler ( AppContainer * cont )

Creates the AbstractAppContext

Parameters:
cont the AppContainer that runs the AbstractScheduler.

AbstractScheduler::~AbstractScheduler ( ) [virtual]

Destroys the AbstractScheduler.

Member Function Documentation

void AbstractScheduler::AddAppContext ( Application * app )

Creates an appropriate AppContext for the Application and adds it to the list of AppContexts. Currently we only support Application attachment BEFORE the Scheduler is being started, and detachment WHEN the Scheduler is being shut down.

Parameters:
app the Application to be added

virtual AbstractAppContext* AbstractScheduler::CreateAppContext ( Application * app ) [pure virtual]

Creates an appropriate AppContext for the Application. Implementation dependent.

Parameters:
app the Application that should be attached to the created AppContext

Implemented in Scheduler, Scheduler, and SimpleScheduler.

AbstractAppContext * AbstractScheduler::GetAppContext ( const Application * app ) const

Returns the Application's AppContext

Parameters:
app the Application whose AppContext should be returned

void AbstractScheduler::RemoveAppContext ( const Application * app )

Remove the Application's AppContext from the list of AppContexts. Currently we only support Application attachment BEFORE the Scheduler is being started, and detachment WHEN the Scheduler is being shut down.

Parameters:
app the Application to be removed

virtual void AbstractScheduler::Reschedule ( ) [pure virtual]

Takes away control from the currently active Application, and lets the next Application resume.

Implemented in Scheduler, Scheduler, and SimpleScheduler.

virtual void AbstractScheduler::SendMsg | ( | const Application * | app,
 |  | Message & | msg
 | ) | [pure virtual]

Wakes up on and sends a Message to the Application. Implementation dependent.

Parameters:
app | the receiving Application
msg | the Message to be sent

Implemented in Scheduler, Scheduler, and SimpleScheduler.

void AbstractScheduler::ShutDown ( ) [virtual]

Shuts down the Scheduler and all associated Applications.

virtual void AbstractScheduler::StartUp ( ) [pure virtual]

Starts all AppContexts, which are then ready to receive messages. Implementation dependent.

Implemented in Scheduler, Scheduler, and SimpleScheduler.

virtual void AbstractScheduler::Wait | ( | const Application * | app,
 |  | const Condition & | cond
 | ) | [pure virtual]

Takes away control from the Application until the next Messages arrives. Will return once the Condition becomes TRUE.

Parameters:
app | the Application that will wait for the Condition
cond | the Condition to wait for

Implemented in Scheduler, Scheduler, and SimpleScheduler.

Friends And Related Function Documentation

friend class AppContainer [friend]

friend class Os [friend]

Field Documentation

LinkedList<AbstractAppContext> AbstractScheduler::m_appcntxt_list [protected]

AppContainer* AbstractScheduler::m_cont [protected]

LinkedList<AbstractAppContext> AbstractScheduler::m_rem_appcntxt_list [protected]

BOOLEAN AbstractScheduler::m_unblock_focus_messages [protected]

The documentation for this class was generated from the following files:
  • Kernel/AbstractScheduler.hpp
  • Kernel/AbstractScheduler.cpp
Generated on Wed Jan 25 00:55:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractSmsApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractSmsApp Class Reference
[SMS]

#include <Applications/Ems/Sms/AbstractSmsApp.hpp>

Inheritance diagram for AbstractSmsApp:

[legend]
Collaboration diagram for AbstractSmsApp:

[legend]

Public Types

enum | PeriodData { PeriodCount = 7 }
enum | SmsExportType { ExportSendType, ExportStoreType }
enum | SmsSendingAnimationType { SendingAnimationType }
enum | SmsServiceType { ComposeSmsType, SendSmsType, SendInternalSmsType, StoreSmsType }
enum | SmsStorageType { SmsSimPreferred, SmsFlashPreferred }
enum SmsValidtyPeriodType {
One_hour = 11, Twelve_Hour = 143, One_Day = 167, One_Week = 173,
Thirty_Days = 196, Three_Months = 205, Maximum = 255
}

Public Member Functions

AbstractSmsApp (const WCHAR *app_name, UINT stacksize=0)
void | AddBookmark (const WString &text)
virtual void | ComposeSms (const EditorDocumentObtainer &obtainer, const PhoneNumber *destination=0, BOOLEAN clear=TRUE)
virtual void | ComposeSms (const PhoneNumber *destination=0, BOOLEAN clear=TRUE)
void | ConnectToUrl (const WString &text)
virtual void | DeleteSms (Provider *provider, INT act_row)
virtual void | ForwardSms (Provider *provider, INT act_row)
Provider * | GetArchiveProvider () const
Provider * | GetArrivedProvider () const
INT | GetCapacity () const
INT | GetDefaultProfile () const
BOOLEAN | GetDeviceManual ()
INT | GetExistentSmsCount () const
INT | GetFreeSmsCount () const
Provider * | GetInboxProvider () const
Provider * | GetInboxUnreadProvider () const
WString | GetNameForNumber (const PhoneNumber &phoneNr) const
Provider * | GetOutboxProvider () const
BOOLEAN | GetPeriodManual ()
Sms::StorageType GetPreferredStorageType ()
Provider * | GetProfileProvider () const
BOOLEAN | GetProviderData (Provider *provider, INT id, INT row, DataItem &item) const
Provider * GetReadProvider ()
Provider * GetSentProvider ()
Provider * | GetSettingsProvider () const
SmsBasicProvider * | GetSmsBasicProvider () const
Provider * GetSmsClass0Provider ()
SmsContext * GetSmsProfile ()
Provider * | GetSmsProvider () const
Provider * | GetStatusReportProvider () const
Provider * | GetTemplateProvider () const
Provider * GetUnreadProvider ()
Provider * GetUnsentProvider ()
AbstractSmsUtilityProcessor * GetUtilityProcessor ()
void | InitiateCall (const WString &text)
BOOLEAN | IsGprsAvailable ()
BOOLEAN | IsReadyForSendingSms (const SmsContext &profile, INT segment_count=-1)
BOOLEAN | IsRequestReplyPath ()
BOOLEAN | IsRequestStatusReport ()
virtual BOOLEAN | IsServiceAvailable (SmsServiceType type) const
BOOLEAN | IsSmsComposeEnabled () const
void | MoveSmsToArchive (Provider *provider, INT row)
virtual void | OnExportConfirmation (SmsExportType export_type, Sms::Result result_code, const SmsContext &profile, INT pending_segment_count=0)
virtual void | OnIndicateIncoming (SmsConfig::SmsIndicationType type)
virtual void | OnOpen ()
void | RegisterUtility (AbstractSmsUtilityProcessor *utlp)
virtual void | RelaySms (Provider *provider, INT act_row, BOOLEAN reply)
void | RememberRepliedTpdu (CompoundTpduItem *tpdu)
virtual void | ReplySms (Provider *provider, INT act_row)
void | SendEmail (const WString &text)
virtual void | SendSms (const EditorDocumentObtainer &obtainer, const PhoneNumber *destination=0, const PhoneNumber *service_center=0)
void | SetEditEnable (BOOLEAN enable)
BOOLEAN | SetPreferredStorageType (Sms::StorageType storage_type)
void | SetWaitingBoxVisible (BOOLEAN flag) const
virtual void | ShowArrivedSms (BOOLEAN show_status_report=FALSE)
virtual void | ShowSms (Provider *provider, INT act_row)
void | StoreEmailInPhonebook (const WString &text)
void | StoreInPhonebook (const WString &text)
virtual void | StoreSentSms (const SmsContext &profile)
virtual void | StoreSms (const Tpdu &tpdu)
virtual void | StoreSms (const EditorDocumentObtainer &obtainer, const PhoneNumber *destination=0)
void | SwitchReadStatus (Provider *provider, INT row, BOOLEAN switch_to_read, BOOLEAN immediate_update=FALSE)
virtual BOOLEAN | Update (ProviderListener *listener=0, BOOLEAN update_providers=TRUE)
virtual void | UpdateSettings (ProviderListener *listener=0)
BOOLEAN | UpdateVoiceMailboxNumbers (PhoneNumber &voiceMailbox, LineSelector line, BOOLEAN read_write_number)
BOOLEAN | ValidateProtocolIdentifier (ProtocolIdentifier &protocol_identifier)
void | ValidateServiceCenterAddress ()
BOOLEAN | ValidateValidityPeriod (ValidityPeriod &period)
BOOLEAN | WildCharHandler (PhoneNumber &number)
virtual | ~AbstractSmsApp ()

Static Public Member Functions

static InputMapper::Alphabet | MapAlphabet (DataCodingScheme::Alphabet alphabet)
static DataCodingScheme::Alphabet | MapAlphabet (const EditorDocumentObtainer &obtainer)

Protected Member Functions

BOOLEAN | IsSendingSmsConfirmed (const SmsContext &profile, INT segment_count=-1) const
virtual void | OnClose ()
virtual BOOLEAN | OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &context_item)
Routed via Base class MmiApplication.
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
Routed via Base class MmiApplication.
virtual void | OnLanguageChanged ()
Is called, if the language has been changed.
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)
virtual void | OnSimRemoved ()
virtual void | OnSimSmsReady ()
virtual void | OnSmsService (SmsServiceType type, EditorDocumentObtainer obtainer, const PhoneNumber &number)
virtual void | OnStartup ()
void | SetSmsComposeEnabled (BOOLEAN flag)
virtual BOOLEAN | UpdateItem (Item *item)
Is called from MMI Application and used to update the text of a Feature.

Detailed Description

This class is the main class for the SmsApplication

Member Enumeration Documentation

enum AbstractSmsApp::PeriodData

Enumerator:
PeriodCount

enum AbstractSmsApp::SmsExportType

Enumerator:
ExportSendType
ExportStoreType

enum AbstractSmsApp::SmsSendingAnimationType

Enumerator:
SendingAnimationType

enum AbstractSmsApp::SmsServiceType

Enumerator:
ComposeSmsType
SendSmsType
SendInternalSmsType
StoreSmsType

enum AbstractSmsApp::SmsStorageType

Enumerator:
SmsSimPreferred
SmsFlashPreferred

enum AbstractSmsApp::SmsValidtyPeriodType

Enumerator:
One_hour
Twelve_Hour
One_Day
One_Week
Thirty_Days
Three_Months
Maximum

Constructor & Destructor Documentation

AbstractSmsApp::AbstractSmsApp | ( | const WCHAR * | app_name,
 |  | UINT | stacksize = 0
 | ) | [explicit]

AbstractSmsApp::~AbstractSmsApp ( ) [virtual]

Member Function Documentation

void AbstractSmsApp::AddBookmark ( const WString & text )

void AbstractSmsApp::ComposeSms | ( | const EditorDocumentObtainer & | obtainer,
 |  | const PhoneNumber * | destination = 0,
 |  | BOOLEAN | clear = TRUE
 | ) | [virtual]

Parameters:
obtainer.
destination
clear,: states whether to clear the content of the current sms

void AbstractSmsApp::ComposeSms | ( | const PhoneNumber * | destination = 0,
 |  | BOOLEAN | clear = TRUE
 | ) | [virtual]

Parameters:
destination.
clear,: states whether to clear the content of the current sms

void AbstractSmsApp::ConnectToUrl ( const WString & text )

void AbstractSmsApp::DeleteSms | ( | Provider * | provider,
 |  | INT | act_row
 | ) | [virtual]

delete the SMS specified in the row

Parameters:
provider.
act_row In which row is the SMS located.

void AbstractSmsApp::ForwardSms | ( | Provider * | provider,
 |  | INT | act_row
 | ) | [virtual]

forward specified SMS

Parameters:
provider.
act_row,: row, in which the SMS located.

Reimplemented in EmsApp.

Provider* AbstractSmsApp::GetArchiveProvider ( ) const [inline]

returns the ArchiveProvider

Returns:
OutboxProvider

Provider* AbstractSmsApp::GetArrivedProvider ( ) const [inline]

returns the ArrivedProvider

Returns:
ArrivedProvider

INT AbstractSmsApp::GetCapacity ( ) const

INT AbstractSmsApp::GetDefaultProfile ( ) const

BOOLEAN AbstractSmsApp::GetDeviceManual ( ) [inline]

INT AbstractSmsApp::GetExistentSmsCount ( ) const [inline]

INT AbstractSmsApp::GetFreeSmsCount ( ) const

Provider* AbstractSmsApp::GetInboxProvider ( ) const [inline]

returns the InboxProvider

Returns:
InboxProvider

Provider* AbstractSmsApp::GetInboxUnreadProvider ( ) const [inline]

returns the InboxUndreasProvider

Returns:
InBoxUnreadProvider

WString AbstractSmsApp::GetNameForNumber ( const PhoneNumber & phoneNr ) const

Provider* AbstractSmsApp::GetOutboxProvider ( ) const [inline]

returns the OutboxProvider

Returns:
OutboxProvider

BOOLEAN AbstractSmsApp::GetPeriodManual ( ) [inline]

Sms::StorageType AbstractSmsApp::GetPreferredStorageType ( )

Provider* AbstractSmsApp::GetProfileProvider ( ) const [inline]

returns the ProfileProvider

Returns:
ProfileProvider

BOOLEAN AbstractSmsApp::GetProviderData | ( | Provider * | provider,
 |  | INT | id,
 |  | INT | row,
 |  | DataItem & | item
 | ) | const

Provider* AbstractSmsApp::GetReadProvider ( ) [inline]

returns the ReadProvider

Returns:
ReadProvider

Provider* AbstractSmsApp::GetSentProvider ( ) [inline]

returns the SentProvider

Returns:
SentProvider

Provider* AbstractSmsApp::GetSettingsProvider ( ) const [inline]

returns the SettingsProvider

Returns:
SettingsProvider

SmsBasicProvider* AbstractSmsApp::GetSmsBasicProvider ( ) const [inline]

returns the SmsBasicProvider

Returns:
SmsBasicProvider

Provider* AbstractSmsApp::GetSmsClass0Provider ( ) [inline]

returns the SmsClass0Provider

Returns:
SmsClass0Provider

SmsContext* AbstractSmsApp::GetSmsProfile ( ) [inline]

Provider* AbstractSmsApp::GetSmsProvider ( ) const [inline]

returns the SmsProvider

Returns:
SmsProvider

Provider* AbstractSmsApp::GetStatusReportProvider ( ) const [inline]

returns the OutboxProvider

Returns:
OutboxProvider

Provider* AbstractSmsApp::GetTemplateProvider ( ) const [inline]

returns the TemplateProvider

Returns:
TemplateProvider

Provider* AbstractSmsApp::GetUnreadProvider ( ) [inline]

returns the UnreadProvider

Returns:
UnreadProvider

Provider* AbstractSmsApp::GetUnsentProvider ( ) [inline]

returns the UnsentProvider

Returns:
UnsentProvider

AbstractSmsUtilityProcessor* AbstractSmsApp::GetUtilityProcessor ( ) [inline]

void AbstractSmsApp::InitiateCall ( const WString & text )

BOOLEAN AbstractSmsApp::IsGprsAvailable ( )

BOOLEAN AbstractSmsApp::IsReadyForSendingSms | ( | const SmsContext & | profile,
 |  | INT | segment_count = -1
 | ) |

BOOLEAN AbstractSmsApp::IsRequestReplyPath ( ) [inline]

BOOLEAN AbstractSmsApp::IsRequestStatusReport ( ) [inline]

BOOLEAN AbstractSmsApp::IsSendingSmsConfirmed | ( | const SmsContext & | profile,
 |  | INT | segment_count = -1
 | ) | const [protected]

BOOLEAN AbstractSmsApp::IsServiceAvailable ( SmsServiceType type ) const [virtual]

BOOLEAN AbstractSmsApp::IsSmsComposeEnabled ( ) const [inline]

InputMapper::Alphabet AbstractSmsApp::MapAlphabet ( DataCodingScheme::Alphabet alphabet ) [static]

DataCodingScheme::Alphabet AbstractSmsApp::MapAlphabet ( const EditorDocumentObtainer & obtainer ) [static]

void AbstractSmsApp::MoveSmsToArchive | ( | Provider * | provider,
 |  | INT | row
 | ) |

void AbstractSmsApp::OnClose ( ) [protected, virtual]

BOOLEAN AbstractSmsApp::OnContextFeatureTriggered | ( | const FeatureID & | feature_id,
 |  | const DataItem & | context_item
 | ) | [protected, virtual]

Routed via Base class MmiApplication.

void AbstractSmsApp::OnExportConfirmation | ( | SmsExportType | export_type,
 |  | Sms::Result | result_code,
 |  | const SmsContext & | profile,
 |  | INT | pending_segment_count = 0
 | ) | [virtual]

BOOLEAN AbstractSmsApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

Routed via Base class MmiApplication.

Reimplemented in EmsApp.

void AbstractSmsApp::OnIndicateIncoming ( SmsConfig::SmsIndicationType type ) [virtual]

void AbstractSmsApp::OnLanguageChanged ( ) [protected, virtual]

Is called, if the language has been changed.

void AbstractSmsApp::OnLoseFocus ( ) [protected, virtual]

BOOLEAN AbstractSmsApp::OnMessage ( const Message & msg ) [protected, virtual]

void AbstractSmsApp::OnOpen ( ) [virtual]

Reimplemented in EmsApp.

BOOLEAN AbstractSmsApp::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [protected, virtual]

void AbstractSmsApp::OnSimRemoved ( ) [protected, virtual]

void AbstractSmsApp::OnSimSmsReady ( ) [protected, virtual]

The OnSimSmsReady-methods is triggered by a Stack Signal and is responsible to initialize Sms Handling. The SmsApplication will be registered to load Sms from Sim and FFS. It will be told to react on Messages, such as if a new message has been arrived.

void AbstractSmsApp::OnSmsService | ( | SmsServiceType | type,
 |  | EditorDocumentObtainer | obtainer,
 |  | const PhoneNumber & | number
 | ) | [protected, virtual]

void AbstractSmsApp::OnStartup ( ) [protected, virtual]

Reimplemented in EmsApp.

void AbstractSmsApp::RegisterUtility ( AbstractSmsUtilityProcessor * utlp )

void AbstractSmsApp::RelaySms | ( | Provider * | provider,
 |  | INT | act_row,
 |  | BOOLEAN | reply
 | ) | [virtual]

void AbstractSmsApp::RememberRepliedTpdu ( CompoundTpduItem * tpdu ) [inline]

void AbstractSmsApp::ReplySms | ( | Provider * | provider,
 |  | INT | act_row
 | ) | [virtual]

replies Sms

Parameters:
provider.
act_row,: row, in which the SMS located.

Reimplemented in EmsApp.

void AbstractSmsApp::SendEmail ( const WString & text )

void AbstractSmsApp::SendSms | ( | const EditorDocumentObtainer & | obtainer,
 |  | const PhoneNumber * | destination = 0,
 |  | const PhoneNumber * | service_center = 0
 | ) | [virtual]

void AbstractSmsApp::SetEditEnable ( BOOLEAN enable )

BOOLEAN AbstractSmsApp::SetPreferredStorageType ( Sms::StorageType storage_type )

void AbstractSmsApp::SetSmsComposeEnabled ( BOOLEAN flag ) [protected]

void AbstractSmsApp::SetWaitingBoxVisible ( BOOLEAN flag ) const

void AbstractSmsApp::ShowArrivedSms ( BOOLEAN show_status_report = FALSE ) [virtual]

Checks if unread SMS or Status Report is available, if so call method to show this

Parameters:
show_status_report,: If true, check for unread status reports. If false, check for unread sms

void AbstractSmsApp::ShowSms | ( | Provider * | provider,
 |  | INT | act_row
 | ) | [virtual]

Opens a window and displays the content of the SMS in a viewer window(

See also:
AbstractViewerWin)
Parameters:
provider.
act_row In which row is the SMS located.

void AbstractSmsApp::StoreEmailInPhonebook ( const WString & text )

void AbstractSmsApp::StoreInPhonebook ( const WString & text )

void AbstractSmsApp::StoreSentSms ( const SmsContext & profile ) [virtual]

void AbstractSmsApp::StoreSms ( const Tpdu & tpdu ) [virtual]

void AbstractSmsApp::StoreSms | ( | const EditorDocumentObtainer & | obtainer,
 |  | const PhoneNumber * | destination = 0
 | ) | [virtual]

void AbstractSmsApp::SwitchReadStatus | ( | Provider * | provider,
 |  | INT | row,
 |  | BOOLEAN | switch_to_read,
 |  | BOOLEAN | immediate_update = FALSE
 | ) |

Switches read status

Parameters:
provider,: Provider
row,: row
switch_to_read,: If true Sms shall be read, if false sms shall be unread
immediate_update,: After state change,

BOOLEAN AbstractSmsApp::Update | ( | ProviderListener * | listener = 0,
 |  | BOOLEAN | update_providers = TRUE
 | ) | [virtual]

BOOLEAN AbstractSmsApp::UpdateItem ( Item * item ) [protected, virtual]

Is called from MMI Application and used to update the text of a Feature.

void AbstractSmsApp::UpdateSettings ( ProviderListener * listener = 0 ) [virtual]

BOOLEAN AbstractSmsApp::UpdateVoiceMailboxNumbers | ( | PhoneNumber & | voiceMailbox,
 |  | LineSelector | line,
 |  | BOOLEAN | read_write_number
 | ) |

voiceMailbox is read/written from/to SIM cphs mailbox files for line1 or line2. line indicates Line1 or Line2 read_write_number, TRUE for read and FALSE for write

BOOLEAN AbstractSmsApp::ValidateProtocolIdentifier ( ProtocolIdentifier & protocol_identifier )

void AbstractSmsApp::ValidateServiceCenterAddress ( )

BOOLEAN AbstractSmsApp::ValidateValidityPeriod ( ValidityPeriod & period )

BOOLEAN AbstractSmsApp::WildCharHandler ( PhoneNumber & number )

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/AbstractSmsApp.hpp
  • Applications/Ems/Sms/AbstractSmsApp.cpp
Generated on Wed Jan 25 00:55:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractSmsComposeWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractSmsComposeWin Class Reference
[SMS]

#include <Applications/Ems/Sms/AbstractSmsComposeWin.hpp>

Inheritance diagram for AbstractSmsComposeWin:

[legend]
Collaboration diagram for AbstractSmsComposeWin:

[legend]

Public Member Functions

AbstractSmsComposeWin ()
const PhoneNumber & | GetDestinationAddress () const
virtual EditorDocumentObtainer | GetDocumentObtainer () const =0
virtual AbstractPredictiveInputBox * | GetPredInputBox ()=0
const PhoneNumber & | GetServiceCenter () const
void | Init (AbstractSmsApp *sms_app, const WCHAR *title)
virtual void | InsertText (const WString &text)=0
virtual void | OnInputModeChanged (PredInputMapper::PredMode mode)
virtual void | RelaySms (Provider *provider, INT row, BOOLEAN reply=FALSE)
RelaySms is used to reply or forward the SMS.
void | SetDestinationAddress (const PhoneNumber *number)
virtual void | SetDocumentObtainer (const EditorDocumentObtainer &obtainer)=0
void | SetServiceCenter (const PhoneNumber *service_center)
virtual | ~AbstractSmsComposeWin ()

Detailed Description

AbstractSmsComposeWin is the abstract base class for composing Window. Consists of two Action objects to perform send or store SMS.

Constructor & Destructor Documentation

AbstractSmsComposeWin::AbstractSmsComposeWin ( )

AbstractSmsComposeWin::~AbstractSmsComposeWin ( ) [virtual]

Member Function Documentation

const PhoneNumber& AbstractSmsComposeWin::GetDestinationAddress ( ) const [inline]

virtual EditorDocumentObtainer AbstractSmsComposeWin::GetDocumentObtainer ( ) const [pure virtual]

Implemented in EmsComposeWin, and SmsComposeWin.

virtual AbstractPredictiveInputBox* AbstractSmsComposeWin::GetPredInputBox ( ) [pure virtual]

Implemented in EmsComposeWin, and SmsComposeWin.

const PhoneNumber& AbstractSmsComposeWin::GetServiceCenter ( ) const [inline]

void AbstractSmsComposeWin::Init | ( | AbstractSmsApp * | sms_app,
 |  | const WCHAR * | title
 | ) |

virtual void AbstractSmsComposeWin::InsertText ( const WString & text ) [pure virtual]

Implemented in SmsComposeWin.

void AbstractSmsComposeWin::OnInputModeChanged ( PredInputMapper::PredMode mode ) [virtual]

Is invoked, when the mode of the predictive input has been changed. This allows e. g. setting the corresponding font for Chinese input if needed.

Reimplemented in EmsComposeWin.

void AbstractSmsComposeWin::RelaySms | ( | Provider * | provider,
 |  | INT | row,
 |  | BOOLEAN | reply = FALSE
 | ) | [virtual]

RelaySms is used to reply or forward the SMS.

Reimplemented in EmsComposeWin.

void AbstractSmsComposeWin::SetDestinationAddress ( const PhoneNumber * number )

virtual void AbstractSmsComposeWin::SetDocumentObtainer ( const EditorDocumentObtainer & obtainer ) [pure virtual]

Implemented in EmsComposeWin, and SmsComposeWin.

void AbstractSmsComposeWin::SetServiceCenter ( const PhoneNumber * service_center ) [inline]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/AbstractSmsComposeWin.hpp
  • Applications/Ems/Sms/AbstractSmsComposeWin.cpp
Generated on Wed Jan 25 00:55:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractSmsUtilityProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractSmsUtilityProcessor Class Reference
[SMS]

#include <Applications/Ems/Sms/AbstractSmsUtiltyProcessor.hpp>

Inheritance diagram for AbstractSmsUtilityProcessor:

[legend]

Public Member Functions

virtual AbstractSmsComposeWin * | GetSmsComposer ()=0
virtual SmsFactory * | GetSmsFactory ()=0
virtual AbstractSmsViewerWin * | GetSmsViewer ()=0
virtual void | OnExportConfirmation (AbstractSmsApp::SmsExportType export_type, Sms::Result result_code, const SmsContext &profile, INT pending_segment_count=0)=0
virtual void | RelaySms (Provider *provider, INT act_row, BOOLEAN reply)=0
virtual void | SendImpl (const SmsContext &profile, const EditorDocumentObtainer &obtainer)=0
virtual void | StoreImpl (const SmsContext &profile, const EditorDocumentObtainer &obtainer)=0

Member Function Documentation

virtual AbstractSmsComposeWin* AbstractSmsUtilityProcessor::GetSmsComposer ( ) [pure virtual]

Implemented in SmsUtility.

virtual SmsFactory* AbstractSmsUtilityProcessor::GetSmsFactory ( ) [pure virtual]

virtual AbstractSmsViewerWin* AbstractSmsUtilityProcessor::GetSmsViewer ( ) [pure virtual]

virtual void AbstractSmsUtilityProcessor::OnExportConfirmation | ( | AbstractSmsApp::SmsExportType | export_type,
 |  | Sms::Result | result_code,
 |  | const SmsContext & | profile,
 |  | INT | pending_segment_count = 0
 | ) | [pure virtual]

virtual void AbstractSmsUtilityProcessor::RelaySms | ( | Provider * | provider,
 |  | INT | act_row,
 |  | BOOLEAN | reply
 | ) | [pure virtual]

virtual void AbstractSmsUtilityProcessor::SendImpl | ( | const SmsContext & | profile,
 |  | const EditorDocumentObtainer & | obtainer
 | ) | [pure virtual]

Implemented in SmsUtility.

virtual void AbstractSmsUtilityProcessor::StoreImpl | ( | const SmsContext & | profile,
 |  | const EditorDocumentObtainer & | obtainer
 | ) | [pure virtual]

The documentation for this class was generated from the following file:
  • Applications/Ems/Sms/AbstractSmsUtiltyProcessor.hpp
Generated on Wed Jan 25 00:55:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractSmsViewerWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractSmsViewerWin Class Reference
[SMS]

#include <Applications/Ems/Sms/AbstractSmsViewerWin.hpp>

Inheritance diagram for AbstractSmsViewerWin:

[legend]
Collaboration diagram for AbstractSmsViewerWin:

[legend]

Public Types

enum | Direction { First = 64, Prev, Next, Last }
Defines four variables corresponding to four SmsWindowAction members respectively. More...

Public Member Functions

AbstractSmsViewerWin ()
virtual const EditorDocument * | GetDocument () const =0
Provider * | GetProvider () const
INT | GetSelectedSms () const
Returns currently selected row.
virtual SmsTextEntry | GetSelectedSmsEmbItem ()=0
AbstractSmsApp * | GetSmsApplication () const
virtual INT | GoToSms (Direction dir)
virtual void | GoToSmsEmbItems (Direction dir)=0
void | Init (AbstractSmsApp *sms_app, const WCHAR *title)
virtual void | SetDocument (const EditorDocument *doc)=0
virtual void | SetSelectedSms (Provider *provider, INT selected_row=0)
void | SetTitleText (const WCHAR *title)
void | SetUpdateOnClose (BOOLEAN state)
virtual void | SwitchReadStatus (BOOLEAN switch_to_read)
void | UpdateDisplayedSms ()
virtual | ~AbstractSmsViewerWin ()

Protected Member Functions

virtual void | OnClose ()
virtual void | OnDisplaySms (Provider *provider, INT row, INT set_index=-1)=0
basic operation, when Sms shall be displayed

Detailed Description

AbstractSmsViewerWin is the base class of all the windows which displays the content of an SMS when the user selects to view it.

Member Enumeration Documentation

enum AbstractSmsViewerWin::Direction

Defines four variables corresponding to four SmsWindowAction members respectively.

Enumerator:
First
Prev
Next
Last

Constructor & Destructor Documentation

AbstractSmsViewerWin::AbstractSmsViewerWin ( )

AbstractSmsViewerWin::~AbstractSmsViewerWin ( ) [virtual]

Member Function Documentation

virtual const EditorDocument* AbstractSmsViewerWin::GetDocument ( ) const [pure virtual]

Implemented in EmsViewerWin, and SmsViewerWin.

Provider * AbstractSmsViewerWin::GetProvider ( ) const

INT AbstractSmsViewerWin::GetSelectedSms ( ) const

Returns currently selected row.

virtual SmsTextEntry AbstractSmsViewerWin::GetSelectedSmsEmbItem ( ) [pure virtual]

Implemented in SmsViewerWin.

AbstractSmsApp* AbstractSmsViewerWin::GetSmsApplication ( ) const [inline]

INT AbstractSmsViewerWin::GoToSms ( Direction dir ) [virtual]

Switch to next or previous Sms

Parameters:
dir,: Direction to go
Returns:
the value of the selected row

virtual void AbstractSmsViewerWin::GoToSmsEmbItems ( Direction dir ) [pure virtual]

Switch to next or previous selectable items in the Sms

Parameters:
dir,: Direction to go

void AbstractSmsViewerWin::Init | ( | AbstractSmsApp * | sms_app,
 |  | const WCHAR * | title
 | ) |

void AbstractSmsViewerWin::OnClose ( ) [protected, virtual]

Is called, if the window will get closed and represents an entry-point for cleaning up things. When the window has the focus child-controls and the window itself will lose the focus after OnClose has been executed.

Reimplemented from Window.

virtual void AbstractSmsViewerWin::OnDisplaySms | ( | Provider * | provider,
 |  | INT | row,
 |  | INT | set_index = -1
 | ) | [protected, pure virtual]

basic operation, when Sms shall be displayed

Implemented in SmsViewerWin.

virtual void AbstractSmsViewerWin::SetDocument ( const EditorDocument * doc ) [pure virtual]

Implemented in EmsViewerWin, and SmsViewerWin.

void AbstractSmsViewerWin::SetSelectedSms | ( | Provider * | provider,
 |  | INT | selected_row = 0
 | ) | [virtual]

void AbstractSmsViewerWin::SetTitleText ( const WCHAR * title ) [inline]

void AbstractSmsViewerWin::SetUpdateOnClose ( BOOLEAN state )

sets if an update on close shall be triggered (e.g. when status is changing from unread to read

virtual void AbstractSmsViewerWin::SwitchReadStatus ( BOOLEAN switch_to_read ) [inline, virtual]

void AbstractSmsViewerWin::UpdateDisplayedSms ( )

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/AbstractSmsViewerWin.hpp
  • Applications/Ems/Sms/AbstractSmsViewerWin.cpp
Generated on Wed Jan 25 00:55:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractStackMsgArgMapContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractStackMsgArgMapContainer Class Reference

#include <Apoxi/Apc/StackMsgArgument.hpp>

Inheritance diagram for AbstractStackMsgArgMapContainer:

[legend]

Public Member Functions

virtual BOOLEAN Execute (const StackMsgArgument &arg) const =0

Member Function Documentation

virtual BOOLEAN AbstractStackMsgArgMapContainer::Execute ( const StackMsgArgument & arg ) const [pure virtual]

Implemented in StackMsgArgMapContainer< T >, StackMsgArgMapContainer< AocDispatcher >, StackMsgArgMapContainer< PowerDownDispatcher >, StackMsgArgMapContainer< PlmnRatDispatcher >, StackMsgArgMapContainer< NetworkDispatcher >, StackMsgArgMapContainer< SsDispatcher >, StackMsgArgMapContainer< PlmnScanDispatcher >, StackMsgArgMapContainer< SmsSendDispatcher >, StackMsgArgMapContainer< SsCcbsDispatcher >, StackMsgArgMapContainer< GltpProviderImpl >, StackMsgArgMapContainer< StatusDispatcher >, StackMsgArgMapContainer< BootDispatcher >, StackMsgArgMapContainer< CbsStartDispatcher >, StackMsgArgMapContainer< SaProviderImpl >, StackMsgArgMapContainer< MmCallDispatcher >, StackMsgArgMapContainer< AccDispatcher >, StackMsgArgMapContainer< MultiSlotDispatcher >, StackMsgArgMapContainer< PlmnDispatcher >, StackMsgArgMapContainer< SsWaitDispatcher >, StackMsgArgMapContainer< LcsProviderImpl >, StackMsgArgMapContainer< PowerDispatcher >, StackMsgArgMapContainer< CbsDispatcher >, StackMsgArgMapContainer< CbsStopDispatcher >, StackMsgArgMapContainer< SmsDispatcher >, StackMsgArgMapContainer< AtcDispatcher >, StackMsgArgMapContainer< SimDispatcher >, and StackMsgArgMapContainer< SigDispatcher >.

The documentation for this class was generated from the following file:
  • Apc/StackMsgArgument.hpp
Generated on Wed Jan 25 00:55:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractTextObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractTextObject Class Reference
[Components]

#include <Apoxi/Gui/AbstractTextObject.hpp>

Inheritance diagram for AbstractTextObject:

[legend]
Collaboration diagram for AbstractTextObject:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

AbstractTextObject (Control *control, const View *view, const WCHAR *text=0, const TextFormat &text_format=TextFormat())
AbstractTextObject ()
const Color & | GetColor () const
Returns the color which is used for drawing the text.
const Font & | GetFont () const
Returns the font which is used for drawing the text.
const WString & | GetText () const
const TextFormat & | GetTextFormat () const
Returns the format which is used for drawing the text.
void | Init (Control *control, const View *view, const WCHAR *text=0, const TextFormat &text_format=TextFormat())
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetColor (const Color &color)
virtual void | SetFont (const Font &font)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetText (const WString &text)
Wrapper method for SetText(w_str.GetCString()).
virtual void | SetText (const WCHAR *text)
virtual void | SetTextFormat (const TextFormat &text_format)
Sets the format which is used for drawing the text.
virtual | ~AbstractTextObject ()

Protected Member Functions

virtual void | OnLanguageChanged ()
virtual void | OnThemeChanged ()

Detailed Description

Base class for a drawable object, which contains a text. The text may have it's own format and color.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

AbstractTextObject::AbstractTextObject ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AbstractTextObject::AbstractTextObject | ( | Control * | control,
 |  | const View * | view,
 |  | const WCHAR * | text = 0,
 |  | const TextFormat & | text_format = TextFormat()
 | ) |

Parameters:
control | Control which embeds the text object
view | View object which draws the text object
text | Text of the object.
text_format | Format of the text.

AbstractTextObject::~AbstractTextObject ( ) [virtual]

Member Function Documentation

const Color& AbstractTextObject::GetColor ( ) const [inline]

Returns the color which is used for drawing the text.

const Font & AbstractTextObject::GetFont ( ) const

Returns the font which is used for drawing the text.

const WString& AbstractTextObject::GetText ( ) const [inline]

const TextFormat& AbstractTextObject::GetTextFormat ( ) const [inline]

Returns the format which is used for drawing the text.

void AbstractTextObject::Init | ( | Control * | control,
 |  | const View * | view,
 |  | const WCHAR * | text = 0,
 |  | const TextFormat & | text_format = TextFormat()
 | ) |

Parameters:
control | Control which embeds the text object
view | View object which draws the text object
text | Text of the object.
text_format | Format of the text.

BOOLEAN AbstractTextObject::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from DrawableObject.

Reimplemented in AnimatedTextLine, TextBox, and TextLine.

void AbstractTextObject::OnLanguageChanged ( ) [protected, virtual]

See also:
Component::OnLanguageChanged

Reimplemented from DrawableObject.

void AbstractTextObject::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged

Reimplemented from DrawableObject.

void AbstractTextObject::SetColor ( const Color & color )

Sets the color of the text. Per default the system color of Color::ClientForeground is used.

void AbstractTextObject::SetFont ( const Font & font ) [virtual]

Sets the font which is used for drawing the text. Per default the system font Font::Client is used.

Reimplemented in AnimatedTextLine.

BOOLEAN AbstractTextObject::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from DrawableObject.

Reimplemented in AnimatedTextLine, TextBox, and TextLine.

void AbstractTextObject::SetText ( const WString & text )

Wrapper method for SetText(w_str.GetCString()).

void AbstractTextObject::SetText ( const WCHAR * text ) [virtual]

Sets the text of the object. It's in the hand of the view object whether the text will be wrapped or not at the boundaries.

Reimplemented in AnimatedTextLine.

void AbstractTextObject::SetTextFormat ( const TextFormat & text_format ) [virtual]

Sets the format which is used for drawing the text.

Reimplemented in AnimatedTextLine.

The documentation for this class was generated from the following files:
  • Gui/AbstractTextObject.hpp
  • Gui/AbstractTextObject.cpp
Generated on Wed Jan 25 00:55:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractTextRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractTextRenderer Class Reference
[GUI]

#include <Apoxi/Gui/AbstractTextRenderer.hpp>

Inheritance diagram for AbstractTextRenderer:

[legend]
Collaboration diagram for AbstractTextRenderer:

[legend]

Public Member Functions

virtual XYDIM | DrawText (DeviceContext *dc, const Rect &clip_rect, XYDIM x, XYDIM y, const WCHAR *text, INT from, INT char_count)
virtual INT | GetTextWidth (const WCHAR *text, const Font &font, TextAttr text_attr, INT from, INT char_count, BOOLEAN include_gap=FALSE)
virtual BOOLEAN | IsStandaloneCharacter (const WCHAR *text, INT index)
virtual INT | WrapLine (const WCHAR *text, const Font &font, TextAttr text_attr, INT char_count, XYDIM max_width=-1, WrapPolicy policy=(WrapPolicy) 0, BOOLEAN include_gap_at_end=FALSE, Size *total_size=0, INT *ws_at_eol_count=0, XYDIM *ws_at_eol_width=0, INT *last_whitespace_index=0)
virtual | ~AbstractTextRenderer ()

Static Public Member Functions

static XYDIM | GetItalicIncrement (INT font_height)
static Vector< INT > | GetWrapPositions (const WCHAR *text, const Font &font, TextAttr text_attr, WrapPolicy policy, XYDIM width)

Protected Member Functions

AbstractTextRenderer ()
Constructor. It is protected because text renderers are singletons.
virtual BOOLEAN | BeginGlyphRetrieval (const WCHAR *text_start, const Font &font, TextAttr text_attr)
void | DrawGlyphInItalic (VirtualDisplay *display, INT font_height, const Glyph &glyph, XYDIM x, XYDIM y, const Rect &clip_rect)
virtual void | EndGlyphRetrieval ()
virtual Size | GetGlyph (const WCHAR *cur_text_pos, const WCHAR *substitution_char, INT char_count, GlyphPtr glyph, INT &parsed_glyphs, BOOLEAN &is_diacritic)=0
BOOLEAN | ObtainMutex ()
Obtains the mutex.
void | ReleaseMutex ()
Releases the mutex.

Protected Attributes

const Font * | m_font
pointer to the current font
TextAttr m_text_attr
Current text attributes.
const WCHAR * | m_text_start
pointer to the text start

Detailed Description

The AbstractTextRenderer is the abstract base class used to implement text drawing. TextRenderers are implemented as singletons, i.e. they must have a static GetInstance() method.

In order to implement a text renderer for a language, usually all that has to be done is override the GetGlyph method.

Before text rendering is started, the BeginGlyphRetrieval method is called to initialize some start parameters. The DrawText method then iterates over all characters in a given text, calls GetGlyph to retrieve the correct glyph, and draws it. Afterwards EndGlyphRetrieval is invoked.

The GetTextWidth and WrapLine methods work analog to the DrawText method, without rendering the text on the display.

The GetGlyph method is used to retrieve the correct glyph for a given language and a character's position within the text. It is an abstract method that subclasses must override.

Constructor & Destructor Documentation

AbstractTextRenderer::~AbstractTextRenderer ( ) [virtual]

AbstractTextRenderer::AbstractTextRenderer ( ) [protected]

Constructor. It is protected because text renderers are singletons.

Member Function Documentation

BOOLEAN AbstractTextRenderer::BeginGlyphRetrieval | ( | const WCHAR * | text_start,
 |  | const Font & | font,
 |  | TextAttr | text_attr
 | ) | [protected, virtual]

Before iterating over the characters to retrieve the appropriate glyphs, this method must be called. Its parameters are stored in member variables, as they are needed with every call of GetGlyph().

When this class is extended, this method can be used to e.g. allocate memory, etc.

Parameters:
text_start | Pointer to the start of the text.
font | The font used for the glyphs.
text_attr | The current text attributes.
Returns:
TRUE if everything was ok, FALSE otherwise.

Reimplemented in ThaiTextRenderer.

void AbstractTextRenderer::DrawGlyphInItalic | ( | VirtualDisplay * | display,
 |  | INT | font_height,
 |  | const Glyph & | glyph,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | const Rect & | clip_rect
 | ) | [protected]

Draws a glyph in italic style if no italic glyph table is available.

XYDIM AbstractTextRenderer::DrawText | ( | DeviceContext * | dc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | const WCHAR * | text,
 |  | INT | from,
 |  | INT | char_count
 | ) | [virtual]

A generic method for drawing text. It iterates over all characters in the text, retrieves the glyph for each character and draws it.

Parameters:
dc | the DeviceContext where the text must be drawn.
clip_rect | the clipping rectangle of the device context.
See also:
DeviceContext::DrawRawText calls the DrawText method with its internal clip_rect, because the absolute coordinates are needed, and it is faster than retrieving the clipping rectangle from the DeviceContext, and restoring the absolute coordinates.
Parameters:
x | the x position of the text
y | the y position of the text
text | a pointer to the text. Text must be 0 terminated.
from | position of the first character in the text to be drawn
char_count | the number of character starting from from to be drawn.
Returns:
the x position behind the last drawn character. The value is relative to the devicecontext, and not an absolute (display) value.

Reimplemented in ArabicTextRenderer, SimpleTextRenderer, and ThaiTextRenderer.

void AbstractTextRenderer::EndGlyphRetrieval ( ) [protected, virtual]

After retrieving glyphs is finished, this method is called. It resets the member variables.

When this class is extended, this method can be used to e.g. free memory allocated in

See also:
BeginGlyphEncoding.

virtual Size AbstractTextRenderer::GetGlyph | ( | const WCHAR * | cur_text_pos,
 |  | const WCHAR * | substitution_char,
 |  | INT | char_count,
 |  | GlyphPtr | glyph,
 |  | INT & | parsed_glyphs,
 |  | BOOLEAN & | is_diacritic
 | ) | [protected, pure virtual]

Get the correct glyph for a character. This may depend on its position within in the text, the characters preceding and/or following it. This method, in essence, implements the brunt work for correctly rendering text.

Parameters:
cur_text_pos | Pointer to the current character position within the text.
substitution_char | Pointer to a character that should be used instead of the character at cur_text_pos. If it is 0, then the character pointed to by cur_text_pos is used.
char_count | Number of remaining characters.
glyph | A GlyphPointer where the glyph data is stored (output parameter).
parsed_glyph | Stores the number of parsed glyphs (output parameter). This is used by DrawText to determine if characters can be skipped, e.g. if an 'a' is followed by an '`', and the implementing renderer unifies the character to 'ß', then parsed_glyphs is 2. The DrawText algorithm will then not attempt to get a glyph for the '`' character, but skip it and continue with the one following it.
is_diacritic | After calling the method, is_diacritic will reflect whether the character for the glyph is a diacritic or not. This must be respected by callers insofar as diacritics are drawn in the previous character's cell and thus those characters' width must not be considered when drawing text or calculating the text width.
Returns:
The x/y offset for the current glyph. This is used to change the position of the drawn glyph. Thus, using the example above, if the 'a' and '`' are not unified as one character, then the 'a' can be drawn on its own, and the '`' is drawn on its own at a position above the 'a', where the position is specified by the returned Size value. Usually, however, it is (0,0).

Implemented in ArabicTextRenderer, HindiTextRenderer, JapaneseTextRenderer, SimpleTextRenderer, ThaiTextRenderer, and VietnameseTextRenderer.

XYDIM AbstractTextRenderer::GetItalicIncrement ( INT font_height ) [static]

Returns the number of pixels a glyph is incremented horizontally if the glyph should be shown in italic.

INT AbstractTextRenderer::GetTextWidth | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | from,
 |  | INT | char_count,
 |  | BOOLEAN | include_gap = FALSE
 | ) | [virtual]

A generic method for getting a text's width.

Parameters:
text | Pointer to the text.
font | Font which is used for the text.
text_attr | Text attributes (e.g. bold increases the text width)
from | Start index for counting (index starts at 0).
char_count | Number of characters to count. A value <= 0 means counting all characters.
include_gap | If set to TRUE, the gap after the last character of the text is included to the length.
Returns:
The width of the text in pixels.

Reimplemented in ArabicTextRenderer, SimpleTextRenderer, and ThaiTextRenderer.

Vector< INT > AbstractTextRenderer::GetWrapPositions | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | WrapPolicy | policy,
 |  | XYDIM | width
 | ) | [static]

Helper methods for getting the wrap positions of a text which should fit into a given width. The method uses the currently activated text renderer for the wrapping. Sample code:

void MyWindow::OnPaint(const Rect& repaint_rect)
{
    Window::OnPaint(repaint_rect);

    PaintDc pdc(GetDeviceContext());
    const WCHAR* text = L"This is the text which should get wrapped.";
    const Font& font = pdc.GetFont();
    Vector<INT> wrap_positions = AbstractTextRenderer::GetWrapPositions(text,
                                                                        font,
                                                                        pdc.GetTextAttr(),
                                                                        EditorDocument::LeftJustifiedWrap,
                                                                        GetClientWidth());

    XYDIM y = 0;
    const INT count = wrap_positions.GetSize();
    for (INT i = 0; i < count; ++i) {
        const INT start = wrap_positions[i];
        INT end = -1;
        if (i < count - 1) {
            end = wrap_positions[i + 1] - start;
        }
        pdc.DrawText(0, y, text, start, end);
        y += font.GetHeight();
    }
}
Parameters:
text | Text which should get wrapped.
font | Font of the text used for the wrapping. It is recommended that the same font is used for drawing the text.
text_attr | Text attribute of the text. It is recommended that the same text attribute is used for drawing the text.
policy | Wrap policy (see EditorDocument::WrapPolicy).
width | Available width in pixels used for the wrapping. If -1 is used, the current display width is used.
Returns:
A vector containing the start indicess for each wrapped line. The number of lines can be retrieved by Vector::GetSize().

BOOLEAN AbstractTextRenderer::IsStandaloneCharacter | ( | const WCHAR * | text,
 |  | INT | index
 | ) | [virtual]

Tests if a given character is rendered standalone in the text, or whether it is a diacritic that modifies preceding characters.

This needs only to be implemented by complex text renderers that do some glyph/character rearrangement or work with diacritic characters, e.g. Thai, Vietnamese, etc. The default implementation in AbstractTextRenderer will always return TRUE, which is sufficient and true for all simple scripts (Latin, Cyrillic,...).

Parameters:
text | pointer to the text
index | the index of the character that is tested
Returns:
TRUE if the character is can rendered standalone, FALSE otherwise

Reimplemented in ThaiTextRenderer, and VietnameseTextRenderer.

BOOLEAN AbstractTextRenderer::ObtainMutex ( ) [inline, protected]

Obtains the mutex.

See also:
Mutex::Obtain

void AbstractTextRenderer::ReleaseMutex ( ) [inline, protected]

Releases the mutex.

See also:
Mutex::Release

INT AbstractTextRenderer::WrapLine | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | char_count,
 |  | XYDIM | max_width = -1,
 |  | WrapPolicy | policy = (WrapPolicy) 0,
 |  | BOOLEAN | include_gap_at_end = FALSE,
 |  | Size * | total_size = 0,
 |  | INT * | ws_at_eol_count = 0,
 |  | XYDIM * | ws_at_eol_width = 0,
 |  | INT * | last_whitespace_index = 0
 | ) | [virtual]

Finds the index in the text where wrapping is possible given the maximum width of the line and the wrapping policy.

Parameters:
text | Pointer to the text.
font | Font which is used for the text.
text_attr | Text attributes (e.g. bold increases the text width)
char_count | maximum number of characters to parse
max_width | maximum width for textline. Is display width per default
policy | is WhitespaceWrap per default. For options, see
See also:
EditorDocument::WrapPolicy
Parameters:
include_gap_at_end | if TRUE, then the font's font gap will be included at the end of the line
total_size | Optionally contains width and height of text line
ws_at_eol_count | Optionally contains number of whitespaces on end of line
ws_at_eol_width | Optionally contains width of whitespaces on end of line
last_whitespace_index | Optionally containes the index of the last whitespace before the wrapping index, or -1 if no whitespace was found
Returns:
the index in the text where it can be wrapped

Reimplemented in ArabicTextRenderer, JapaneseTextRenderer, SimpleTextRenderer, and ThaiTextRenderer.

Field Documentation

const Font* AbstractTextRenderer::m_font [protected]

pointer to the current font

TextAttr AbstractTextRenderer::m_text_attr [protected]

Current text attributes.

const WCHAR* AbstractTextRenderer::m_text_start [protected]

pointer to the text start

The documentation for this class was generated from the following files:
  • Gui/AbstractTextRenderer.hpp
  • Gui/AbstractTextRenderer.cpp
Generated on Wed Jan 25 00:55:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractToggleAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractToggleAction Class Reference
[Items]

#include <Apoxi/Gui/AbstractToggleAction.hpp>

Inheritance diagram for AbstractToggleAction:

[legend]
Collaboration diagram for AbstractToggleAction:

[legend]

Public Types

enum | { ID = 4 }
enum | AbstractToogleActionPropertyId { SelectedPropertyId = 3, ValuePropertyId = 4 }

Public Member Functions

AbstractToggleAction (const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE, INT value=0)
AbstractToggleAction (Dispatcher *dispatcher, const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE, INT value=0)
AbstractToggleAction ()
virtual BOOLEAN | Execute ()
virtual const BitmapRes * | GetDeselectedIcon () const
virtual const BitmapRes * | GetSelectedIcon () const
INT | GetValue () const
void | Init (const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE, INT value=0)
void | Init (Dispatcher *dispatcher, const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE, INT value=0)
virtual BOOLEAN | IsEqual (const Item &item) const
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual BOOLEAN | IsSelected () const
Returns the current selection state of the action.
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual void | SetSelected (BOOLEAN selected)
Alters the selection state of the action, even it is disabled.
void | SetValue (INT value)
virtual BOOLEAN | Toggle (BOOLEAN old_state)=0
Returns the new selection state according to the previous selection state given in old_state.
virtual | ~AbstractToggleAction ()

Detailed Description

Is an abstract base class for actions, which may be toggled between selected and deselected and provide an icon for each state. It's also possible to assign an integer value as value for the action, which is useful when the name or position of a toggle action is not sufficient.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Action.

enum AbstractToggleAction::AbstractToogleActionPropertyId

See also:
Action::ActionPropertyId
Enumerator:
SelectedPropertyId
ValuePropertyId Indicates that the 'value' property has been changed.

Constructor & Destructor Documentation

AbstractToggleAction::AbstractToggleAction ( )

AbstractToggleAction::AbstractToggleAction | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE,
 |  | INT | value = 0
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.
selected | Specifies whether the toggle action is in the selected or non selected state.
value | Value to the toggle action. This is useful when the name or position of a toggle action is not sufficient.

AbstractToggleAction::~AbstractToggleAction ( ) [virtual]

AbstractToggleAction::AbstractToggleAction | ( | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE,
 |  | INT | value = 0
 | ) |

Obsolete - use constructor having a dispatcher as input parameter instead.

Member Function Documentation

BOOLEAN AbstractToggleAction::Execute ( ) [virtual]

See also:
Action::Execute

Reimplemented from Action.

const BitmapRes * AbstractToggleAction::GetDeselectedIcon ( ) const [virtual]

Obsolete - the deselected icon must be set by Item::SetIcon when overwriting AbstractToggleAction::Toggle.

Reimplemented in CheckBoxAction, and RadioButtonAction.

const BitmapRes * AbstractToggleAction::GetSelectedIcon ( ) const [virtual]

Obsolete - the selected icon must be set by Item::SetIcon when overwriting AbstractToggleAction::Toggle.

Reimplemented in CheckBoxAction, and RadioButtonAction.

INT AbstractToggleAction::GetValue ( ) const [inline]

Returns the value which has been assigned by AbstractToggleAction::SetValue. Having a value is useful when the name or position of a toggle action is not sufficient.

void AbstractToggleAction::Init | ( | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE,
 |  | INT | value = 0
 | ) |

Obsolete - use Init having a dispatcher as input parameter instead.

void AbstractToggleAction::Init | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE,
 |  | INT | value = 0
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.
selected | Specifies whether the toggle action is in the selected or non selected state.
value | Value to the toggle action. This is useful when the name or position of a toggle action is not sufficient.

BOOLEAN AbstractToggleAction::IsEqual ( const Item & item ) const [virtual]

See also:
Item::IsEqual

Reimplemented from Item.

BOOLEAN AbstractToggleAction::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from Action.

Reimplemented in CheckBoxAction, and RadioButtonAction.

BOOLEAN AbstractToggleAction::IsSelected ( ) const [virtual]

Returns the current selection state of the action.

BOOLEAN AbstractToggleAction::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from Action.

Reimplemented in CheckBoxAction, and RadioButtonAction.

void AbstractToggleAction::SetSelected ( BOOLEAN selected ) [virtual]

Alters the selection state of the action, even it is disabled.

Reimplemented in CheckBoxAction, and RadioButtonAction.

void AbstractToggleAction::SetValue ( INT value )

Assigns a value to the toggle action. This is useful when the name or position of a toggle action is not sufficient.

virtual BOOLEAN AbstractToggleAction::Toggle ( BOOLEAN old_state ) [pure virtual]

Returns the new selection state according to the previous selection state given in old_state.

Implemented in CheckBoxAction, and RadioButtonAction.

The documentation for this class was generated from the following files:
  • Gui/AbstractToggleAction.hpp
  • Gui/AbstractToggleAction.cpp
Generated on Wed Jan 25 00:55:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AbstractTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AbstractTransport Class Reference

Abstract representation of communication hardware. More...

#include <Apoxi/Devices/AbstractTransport.hpp>

Inheritance diagram for AbstractTransport:

[legend]
Collaboration diagram for AbstractTransport:

[legend]

Public Types

enum | AvState { AvsReady, AvsBusy, AvsConflict, AvsDisabled }
Availability state. More...
typedef ObservableObject | Base
enum | NotificationMsgType { NotifyAvStateChanged }

Public Member Functions

virtual void | Enable ()=0
Request enabling of the transport (asynchronously).
virtual AvState | GetAvState () const =0
Returns the availability state of the transport.
WString | GetMmiName () const
Returns the friendly name of the transport.
BOOLEAN | RegisterTransportApp (Application *app_ptr)
Registers an application as transport application.

Protected Member Functions

AbstractTransport (const WCHAR *mmi_name_str)
Application * | GetAppPtr () const
Returns the application pointer of the transport application.
void | OnAvStateChanged ()
Indicates change in the availability state of the transport.

Detailed Description

Abstract representation of communication hardware.

Must be implemented for every transport subsystem like Bluetooth, IrDA, etc. Since internal APOXI objects (like ObexTransport instances) are not able to receive messages the class implements the ObservableObject interface, therefore enabling other objects to attach to AbstractTransport derivatives and be notified via method invokation.

Member Typedef Documentation

typedef ObservableObject AbstractTransport::Base

Reimplemented in IrdaTransport.

Member Enumeration Documentation

enum AbstractTransport::AvState

Availability state.

Enumerator:
AvsReady | Can be used without restrictions.
AvsBusy | Temporarily unavailable.
AvsConflict | Not available due to resource conflict.
AvsDisabled | Intentionally disabled.

enum AbstractTransport::NotificationMsgType

Enumerator:
NotifyAvStateChanged AvState has changed !

Constructor & Destructor Documentation

AbstractTransport::AbstractTransport ( const WCHAR * mmi_name_str ) [protected]

Restrict construction to derived classes.

Parameters:
mmi_name_str Friendly name for use by the MMI.

Member Function Documentation

virtual void AbstractTransport::Enable ( ) [pure virtual]

Request enabling of the transport (asynchronously).

This method attempts to enable the transport, posibly involving conflict management intervention or MMI activity. Therefore, every implementation is expected to deliver the result asynchronously by calling OnAvStateChanged().

Implemented in UsbTransport, BtTransport, and IrdaTransport.

Application * AbstractTransport::GetAppPtr ( ) const [inline, protected]

Returns the application pointer of the transport application.

virtual AvState AbstractTransport::GetAvState ( ) const [pure virtual]

Returns the availability state of the transport.

Since state handling can be different for each implementation, this is an abstract method. However, any internal state must be representable by the type AvState

See also:
AvState.

Implemented in UsbTransport, BtTransport, and IrdaTransport.

WString AbstractTransport::GetMmiName ( ) const [inline]

Returns the friendly name of the transport.

Can be used by MMI applications when the user must be prompted to select a transport media.

void AbstractTransport::OnAvStateChanged ( ) [protected]

Indicates change in the availability state of the transport.

This method must be called by every implementation whenever the availability of the transport is changed. This will generate a TransportNotificationMsg which tells subscribers about the state change.

Reimplemented in IrdaTransport.

BOOLEAN AbstractTransport::RegisterTransportApp ( Application * app_ptr )

Registers an application as transport application.

By calling this method and supplying its 'this' pointer as parameter an application becomes the transport application of this transport.

Returns:
'TRUE' in case of success, 'FALSE' is case of error (an application is already registered).

The documentation for this class was generated from the following files:
  • Devices/AbstractTransport.hpp
  • Devices/AbstractTransport.cpp
Generated on Wed Jan 25 00:55:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AcacLanguage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AcacLanguage Class Reference

#include <Apoxi/Gui/AcacLanguage.hpp>

Collaboration diagram for AcacLanguage:

[legend]

Public Member Functions

AcacLanguage (const LanguageData *data)
EntryId | GetId () const
INT32 | GetIndexOf (const WCHAR *text) const
const WCHAR * | GetName () const
const WCHAR * | GetNativeName () const
UINT16 | GetNumberOfStrings () const
const WCHAR * | GetText (UINT16 index) const
virtual | ~AcacLanguage ()

Detailed Description

AcacLanguage provides functionality for the TextPackConnector to access the data of a TextPack.

Constructor & Destructor Documentation

AcacLanguage::AcacLanguage ( const LanguageData * data )

The constructor for AcacLanguage initializes the data member of the object.

Parameters:
data Pointer to the data of one language in the customization pack.

AcacLanguage::~AcacLanguage ( ) [virtual]

Destructur for AcacLanguage.

Member Function Documentation

EntryId AcacLanguage::GetId ( ) const [inline]

Returns the unique id of the language.

Returns:
unique id of language.

INT32 AcacLanguage::GetIndexOf ( const WCHAR * text ) const

Returns the position for a given text. If the string is not found or the text parameter is NULL, -1 is returned.

Parameters:
text The text that should be searched.
Returns:
The index of the text given in the parameter text. -1 if the text is not found.

const WCHAR* AcacLanguage::GetName ( ) const [inline]

Returns the name of the language (e.g. German)

Returns:
Pointer to the name of the language in english.

const WCHAR* AcacLanguage::GetNativeName ( ) const [inline]

Returns the native name of the language (e.g. Deutsch)

Returns:
Pointer to the native name of the language.

UINT16 AcacLanguage::GetNumberOfStrings ( ) const [inline]

Returns the number of strings contained in the translation table.

Returns:
The number of strings contained in the language.

const WCHAR * AcacLanguage::GetText ( UINT16 index ) const

Returns the string at position index.

Returns:
the string at position index in the string table.

The documentation for this class was generated from the following files:
  • Gui/AcacLanguage.hpp
  • Gui/AcacLanguage.cpp
Generated on Wed Jan 25 00:55:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AccDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AccDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/AccDispatcher.hpp>

Inheritance diagram for AccDispatcher:

[legend]
Collaboration diagram for AccDispatcher:

[legend]

Public Member Functions

AccDispatcher ()
virtual | ~AccDispatcher ()

Protected Member Functions

BOOLEAN | OnAccessoryInd (const StackMsgArgument &arg)

Constructor & Destructor Documentation

AccDispatcher::AccDispatcher ( )

AccDispatcher::~AccDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN AccDispatcher::OnAccessoryInd ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/AccDispatcher.hpp
  • Asc/AccDispatcher.cpp
Generated on Wed Jan 25 00:55:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AccessorAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AccessorAction Class Reference
[GUI Menu Accessors]

#include <Apoxi/AddOns/GuiMenuAccessors/AccessorAction.hpp>

Inheritance diagram for AccessorAction:

[legend]
Collaboration diagram for AccessorAction:

[legend]

Public Member Functions

AccessorAction (Dispatcher *dispatcher, AbstractMenuAccessor *accessor, const WCHAR *text, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
AccessorAction ()
virtual const ActionExtension * | GetExtension () const
AbstractMenuAccessor * GetMenuAccessor ()
void | Init (Dispatcher *dispatcher, AbstractMenuAccessor *accessor, const WCHAR *text, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
virtual | ~AccessorAction ()

Detailed Description

Obsolete - the class Menu, which uses the AccessorAction, has been replaced by the classes ItemMenu and ItemTree.

May contain a menu-accessor and allows together with the class AbstractActionMenuAccessor the implementation of a menu-hierarchy. When an accessor-action is triggered inside a menu, the current accessor of the menu is replaced by the accessor from accessor-action, which means traversing down the menu-hierarchy.

Constructor & Destructor Documentation

AccessorAction::AccessorAction ( )

AccessorAction::AccessorAction | ( | Dispatcher * | dispatcher,
 |  | AbstractMenuAccessor * | accessor,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

AccessorAction::~AccessorAction ( ) [virtual]

Member Function Documentation

const ActionExtension * AccessorAction::GetExtension ( ) const [virtual]

AbstractMenuAccessor* AccessorAction::GetMenuAccessor ( ) [inline]

void AccessorAction::Init | ( | Dispatcher * | dispatcher,
 |  | AbstractMenuAccessor * | accessor,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/GuiMenuAccessors/AccessorAction.hpp
  • AddOns/GuiMenuAccessors/AccessorAction.cpp
Generated on Wed Jan 25 00:55:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AccessorActionExtension Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AccessorActionExtension Class Reference
[GUI Menu Accessors]

#include <Apoxi/AddOns/GuiMenuAccessors/AccessorActionExtension.hpp>

Inheritance diagram for AccessorActionExtension:

[legend]
Collaboration diagram for AccessorActionExtension:

[legend]

Public Types

enum | { ID = 0 }

Public Member Functions

AccessorActionExtension ()
virtual INT | GetId () const
AbstractMenuAccessor * | GetMenuAccessor () const
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetMenuAccessor (AbstractMenuAccessor *accessor)
virtual | ~AccessorActionExtension ()

Detailed Description

Obsolete - action-extensions are not needed anymore, as each Action may contain now a RTTI by providing the method Action::IsInstanceOf.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AccessorActionExtension::AccessorActionExtension ( )

AccessorActionExtension::~AccessorActionExtension ( ) [virtual]

Member Function Documentation

INT AccessorActionExtension::GetId ( ) const [virtual]

Implements ActionExtension.

AbstractMenuAccessor* AccessorActionExtension::GetMenuAccessor ( ) const [inline]

BOOLEAN AccessorActionExtension::IsInstanceOf ( INT id ) const [virtual]

Returns TRUE, if the ActionExtension is an instance of the ActionExtension with the ID id.

Implements ActionExtension.

void AccessorActionExtension::SetMenuAccessor ( AbstractMenuAccessor * accessor ) [inline]

The documentation for this class was generated from the following files:
  • AddOns/GuiMenuAccessors/AccessorActionExtension.hpp
  • AddOns/GuiMenuAccessors/AccessorActionExtension.cpp
Generated on Wed Jan 25 00:55:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Accessory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Accessory Class Reference

#include <Apoxi/Apc/Accessory.hpp>

Public Types

enum Type {
None = 0x0000, HeadSet = 0x0001, ServicePlug = 0x0002, AcDcAdaptor = 0x0004,
GpsModule = 0x0008, DataCable = 0x0010, StereoHeadSet = 0x0020, HandsFreeCarKit = 0x0040,
Unknown = 0x7FFF
}

Public Member Functions

Accessory (UINT16 *data=0)
UINT16 | GetParam (INT i) const
Type | GetType () const
void | SetParam (INT i, UINT16 param)
void | SetType (Type type)

Friends

class | HeadSet

Member Enumeration Documentation

enum Accessory::Type

Enumerator:
None
HeadSet
ServicePlug
AcDcAdaptor
GpsModule
DataCable
StereoHeadSet
HandsFreeCarKit
Unknown

Constructor & Destructor Documentation

Accessory::Accessory ( UINT16 * data = 0 ) [inline]

Member Function Documentation

UINT16 Accessory::GetParam ( INT i ) const [inline]

Type Accessory::GetType ( ) const [inline]

void Accessory::SetParam | ( | INT | i,
 |  | UINT16 | param
 | ) | [inline]

void Accessory::SetType ( Type type ) [inline]

Friends And Related Function Documentation

friend class HeadSet [friend]

The documentation for this class was generated from the following file:
  • Apc/Accessory.hpp
Generated on Wed Jan 25 00:55:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AccessoryIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AccessoryIndArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for AccessoryIndArg:

[legend]
Collaboration diagram for AccessoryIndArg:

[legend]

Public Types

enum | { ID = 1111 }

Public Member Functions

AccessoryIndArg ()
const Accessory & | GetAccessory () const
void | SetAccessory (const Accessory &accessory)

Static Public Member Functions

static const AccessoryIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ImeiReadIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AccessoryIndArg::AccessoryIndArg ( )

Member Function Documentation

const AccessoryIndArg & AccessoryIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Accessory& AccessoryIndArg::GetAccessory ( ) const [inline]

void AccessoryIndArg::SetAccessory ( const Accessory & accessory ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 00:55:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AccessoryIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AccessoryIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for AccessoryIndMsg:

[legend]
Collaboration diagram for AccessoryIndMsg:

[legend]

Public Types

enum | { ID = 18005 }

Public Member Functions

AccessoryIndMsg (ExecutionContext *context, const Accessory &accessory)
virtual Message * | Clone () const
const Accessory & | GetAccessory () const
virtual const MsgMetaData & | GetMetaData () const
void | SetAccessory (const Accessory &accessory)
virtual | ~AccessoryIndMsg ()

Detailed Description

AccessoryMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AccessoryIndMsg::AccessoryIndMsg | ( | ExecutionContext * | context,
 |  | const Accessory & | accessory
 | ) |

AccessoryIndMsg::~AccessoryIndMsg ( ) [virtual]

Member Function Documentation

Message * AccessoryIndMsg::Clone ( ) const [virtual]

Implements Message.

const Accessory& AccessoryIndMsg::GetAccessory ( ) const [inline]

const MsgMetaData & AccessoryIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void AccessoryIndMsg::SetAccessory ( const Accessory & accessory ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 00:55:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AccHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AccHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/AccHandler.hpp>

Collaboration diagram for AccHandler:

[legend]

Public Types

enum | { ID = AccHandlerId }

Public Member Functions

AccHandler ()
virtual HandlerId | GetHandlerId () const
virtual | ~AccHandler ()

Detailed Description

The AccHandler holds the functionality for receiving Accessory load level.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AccHandler::AccHandler ( )

AccHandler::~AccHandler ( ) [virtual]

Member Function Documentation

HandlerId AccHandler::GetHandlerId ( ) const [virtual]

The documentation for this class was generated from the following files:
  • Asc/AccHandler.hpp
  • Asc/AccHandler.cpp
Generated on Wed Jan 25 00:55:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AckNackCnt Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AckNackCnt Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

AckNackCnt ()
BOOLEAN | IsAckBlocksInvalid ()
BOOLEAN | IsNackBlocksInvalid ()
AckNackCnt | operator= (T_ACK_NACK_CNT ack_nack_cnt)

Data Fields

INT | ack_blocks
INT | nack_blocks

Constructor & Destructor Documentation

AckNackCnt::AckNackCnt ( ) [inline]

Member Function Documentation

BOOLEAN AckNackCnt::IsAckBlocksInvalid ( ) [inline]

BOOLEAN AckNackCnt::IsNackBlocksInvalid ( ) [inline]

AckNackCnt AckNackCnt::operator= ( T_ACK_NACK_CNT ack_nack_cnt )

Field Documentation

INT AckNackCnt::ack_blocks

INT AckNackCnt::nack_blocks

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 00:55:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AckNackParamList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AckNackParamList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for AckNackParamList:

[legend]

Public Types

enum | { LengthOfAckNackTestParamCntArray = TESTPARAM_CI_CS_COUNT }

Public Member Functions

BOOLEAN | IsEmpty ()
AckNackParamList | operator= (T_ACK_NACK_PARAM_LIST ack_nack_param_list)
AckNackTestparamCnt & | operator[] (INT index)

Data Fields

AckNackTestparamCnt | ack_nack_testparam_cnt_array [LengthOfAckNackTestParamCntArray]
INT | length

Member Enumeration Documentation

anonymous enum

Enumerator:
LengthOfAckNackTestParamCntArray

Member Function Documentation

BOOLEAN AckNackParamList::IsEmpty ( )

AckNackParamList AckNackParamList::operator= ( T_ACK_NACK_PARAM_LIST ack_nack_param_list )

AckNackTestparamCnt & AckNackParamList::operator[] ( INT index )

Field Documentation

AckNackTestparamCnt AckNackParamList::ack_nack_testparam_cnt_array[LengthOfAckNackTestParamCntArray]

INT AckNackParamList::length

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 00:55:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AckNackTestparamCnt Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AckNackTestparamCnt Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for AckNackTestparamCnt:

[legend]

Public Member Functions

AckNackTestparamCnt operator= (T_ACK_NACK_TESTPARAM_CNT ack_nack_testparam_cnt)

Data Fields

AckNackCnt dl_blocks
AckNackCnt ul_blocks

Member Function Documentation

AckNackTestparamCnt AckNackTestparamCnt::operator= ( T_ACK_NACK_TESTPARAM_CNT ack_nack_testparam_cnt )

Field Documentation

AckNackCnt AckNackTestparamCnt::dl_blocks

AckNackCnt AckNackTestparamCnt::ul_blocks

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 00:55:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Acm Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Acm Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [3]

Field Documentation

UINT8 Acm::val[3]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 00:55:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Action Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Action Class Reference
[Items]

#include <Apoxi/Gui/Action.hpp>

Inheritance diagram for Action:

[legend]
Collaboration diagram for Action:

[legend]

Public Types

enum | { ID = 1 }
typedef void(Dispatcher::* | ExecFn )()

Public Member Functions

Action (Dispatcher *dispatcher, const WString &text, ExecFn exec_fn)
Action (Dispatcher *dispatcher, const WString &text, const IconSet &icon_set, BOOLEAN enabled=TRUE)
Action (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE)
Action (Dispatcher *dispatcher, const WString &text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
Action (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
Action ()
virtual BOOLEAN | Execute ()
ExecFn | GetExecFn () const
void | Init (Dispatcher *dispatcher, const WString &text, ExecFn exec_fn)
void | Init (Dispatcher *dispatcher, const WString &text, const IconSet &icon_set, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WString &text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetExecFn (ExecFn exec_fn)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual | ~Action ()

Detailed Description

The class Action provides an abstract user interface action that can appear in GUI-components. In GUI applications many commands can be invoked by e. g. menus, softkeys or push-buttons. Since the same action can be invoked by different GUI-components it is useful to represent a command as an Action to ensure a consistent state of the command and its representation. Every instance of the class Action has a text, may contain a bitmap and may be enabled/disabled. If an action is provided by a dispatcher-pointer when initializing, the dispatcher will be informed by messages when a property has been changed or the action has been executed. It is also possible to execute a member function of the given dispatcher.

The following example shows how usually actions are used within a window:

class MyWindow : public Window {
    public:
        void Init();

    private:
        Action m_add;
        Action m_delete;
        Action m_rename;
        Action m_close;

        void Add() { ... }
        void Delete() { ... }
        void Rename() { ... }
        void Close() { ... }
}

In the implementation of the method Init the actions are initialized:

#include "MyWindow.hpp"
...

void MyWindow::Init()
{
    ...
    m_add.Init(this, Tr(L"Add"), (Action:ExecFn)&MyWindow::Add);
    m_delete.Init(this, Tr(L"Delete"), (Action::ExecFn)&MyWindow::Delete);
    m_rename.Init(this, Tr(L"Rename"), (Action::ExecFn)&MyWindow::Rename);
    m_close.Init(this, Tr(L"Close"), (Action::ExecFn)&MyWindow::Close);
    ....
}
So when the action m_add is executed by e. g. selecting a menu entry, the method MyWindow::Add will be executed.

Member Typedef Documentation

typedef void(Dispatcher::* Action::ExecFn)()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Item.

Constructor & Destructor Documentation

Action::Action ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

Action::Action | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by a bitmap.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Action::Action | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by a bitmap.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Action::Action | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by an image obtainer.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Action::Action | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const IconSet & | icon_set,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by an icon set.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Action::Action | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | ExecFn | exec_fn
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
exec_fn Pointer to a member function with the signature void Func() of the dispatcher, which should be executed when Action::Execute has been invoked. Example, where an instance of the class MyWindow acts as dispatcher and has the method void MyWindow::AddXxx:
Action* action = new Action(my_window, Tr(L"Add Xxx"), (Action::ExecFn)&MyWindow::AddXxx);

Action::~Action ( ) [virtual]

Member Function Documentation

BOOLEAN Action::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented in ApplicationAction, ContextFeatureItem, FeatureItem, IndicatorItem, PropertyItem, CancelAction, ConfirmAction, SetLanguageAction, SetThemeAction, AbstractToggleAction, CloseWindowAction, OpenContextMenuAction, OpenWindowAction, PbAddPhoneNoAction, PbConfirmAddNoAction, PbCancelAddNoAction, PbDelPhonenoAction, PbChangeNoTypeAction, PbSelectGroupAction, SyncSimAllAction, SyncPhoneAllAction, SyncSimAction, SyncPhoneAction, PbAction, PbSecuredAction, PbAddAction, PbEditDetailAction, PbConfirmEditAction, PbCancelEditAction, PbCallAction, PbDeleteAction, PbDelAllAction, SyncAction, DisplayMemoryAction, AddAllToFdnAction, AddEntryToFdnAction, AddNumberToFdnAction, CopyToPbAction, and SaveNoAction.

ExecFn Action::GetExecFn ( ) const [inline]

Returns a pointer to the member function which should be executed, when Action::Execute has been invoked.

void Action::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | ExecFn | exec_fn
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
exec_fn Pointer to a member function with the signature void Func() of the dispatcher, which should be executed when Action::Execute has been invoked. Example, where an instance of the class MyWindow acts as dispatcher and has the method void MyWindow::AddXxx:
Action* action = new Action(my_window, Tr(L"Add Xxx"), (Action::ExecFn)&MyWindow::AddXxx);

void Action::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const IconSet & | icon_set,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by an icon set.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Reimplemented from Item.

void Action::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by an image obtainer.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Reimplemented from Item.

void Action::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by a bitmap.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Reimplemented from Item.

void Action::Init | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by a bitmap.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Reimplemented from Item.

Reimplemented in SubMenuAction.

BOOLEAN Action::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from Item.

Reimplemented in ContextFeatureItem, FeatureItem, IndicatorItem, PropertyItem, AbstractToggleAction, CheckBoxAction, and RadioButtonAction.

void Action::SetExecFn ( ExecFn exec_fn ) [inline]

Sets the member function which should be executed, when Action::Execute has been invoked. The member function must be part of the dispatcher which has been assigned to the action. Assuming that an instance of the class MyWindow acts as dispatcher, and has the method void MyWindow::AddXxx, then the member function can be set by:

action.SetExecFn((Action::ExecFn)&MyWindow::AddXxx)

BOOLEAN Action::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Item.

Reimplemented in ContextFeatureItem, FeatureItem, IndicatorItem, PropertyItem, AbstractToggleAction, CheckBoxAction, CloseWindowAction, OpenContextMenuAction, OpenWindowAction, and RadioButtonAction.

The documentation for this class was generated from the following files:
  • Gui/Action.hpp
  • Gui/Action.cpp
Generated on Wed Jan 25 00:55:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ActionExecutedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ActionExecutedMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ActionExecutedMsg:

[legend]
Collaboration diagram for ActionExecutedMsg:

[legend]

Public Types

enum | { ID = 303 }

Public Member Functions

ActionExecutedMsg (Action *action)
virtual Message * | Clone () const
Action * | GetAction () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~ActionExecutedMsg ()

Detailed Description

This message is sent from an Action, when it has been executed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ActionExecutedMsg::ActionExecutedMsg ( Action * action )

ActionExecutedMsg::~ActionExecutedMsg ( ) [virtual]

Member Function Documentation

Message * ActionExecutedMsg::Clone ( ) const [virtual]

Implements Message.

Action* ActionExecutedMsg::GetAction ( ) const [inline]

const MsgMetaData & ActionExecutedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 00:55:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ActionExtension Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ActionExtension Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/ActionExtension.hpp>

Inheritance diagram for ActionExtension:

[legend]

Public Member Functions

ActionExtension ()
virtual INT | GetId () const =0
virtual BOOLEAN | IsInstanceOf (INT id) const =0
virtual | ~ActionExtension ()

Detailed Description

Obsolete - as each Action supports now RTTI by the method IsInstance the ActionExtension-concept is not needed anymore.

Constructor & Destructor Documentation

ActionExtension::ActionExtension ( )

ActionExtension::~ActionExtension ( ) [virtual]

Member Function Documentation

virtual INT ActionExtension::GetId ( ) const [pure virtual]

Implemented in AccessorActionExtension.

virtual BOOLEAN ActionExtension::IsInstanceOf ( INT id ) const [pure virtual]

Returns TRUE, if the ActionExtension is an instance of the ActionExtension with the ID id.

Implemented in AccessorActionExtension.

The documentation for this class was generated from the following files:
  • Compat/ActionExtension.hpp
  • Compat/ActionExtension.cpp
Generated on Wed Jan 25 00:55:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ActionMenuAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ActionMenuAccessor Class Reference
[GUI Menu Accessors]

#include <Apoxi/AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp>

Inheritance diagram for ActionMenuAccessor:

[legend]
Collaboration diagram for ActionMenuAccessor:

[legend]

Public Member Functions

ActionMenuAccessor (const WCHAR *title, INT action_count=4)
ActionMenuAccessor ()
void | AddAction (Action *action)
BOOLEAN | ContainsAction (const Action &action) const
virtual BOOLEAN | First ()
Action * | GetAction (INT index) const
virtual Action * | GetAction ()
INT | GetActionCount () const
INT | GetActionIndex (const Action &action) const
void | Init (const WCHAR *title, INT action_count=4)
void | InsertAction (INT index, Action *action)
virtual BOOLEAN | Next ()
void | RemoveAction (INT index)
void | RemoveAllActions ()
void | SetAction (INT index, Action *action)
~ActionMenuAccessor ()

Protected Member Functions

virtual void | OnTrigger (INT selected_idx)

Detailed Description

Obsolete - the class Menu, which uses the ActionMenuAccessor, has been replaced by the classes ItemMenu and ItemTree.

Provides a menu-accessor based on actions. One action represents one menu-item, hence every menu-item can have a text, an icon and may be enabled/disabled. When triggering a menu-item, the Action representing the item will be executed.

See also:
Action

Constructor & Destructor Documentation

ActionMenuAccessor::ActionMenuAccessor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ActionMenuAccessor::ActionMenuAccessor | ( | const WCHAR * | title,
 |  | INT | action_count = 4
 | ) |

Parameters:
title | Title which will be used for the Menu using the ActionMenuAccessor.
action_count | Optional parameter which gives the ActionMenuAccessor a hint how many Actions will be added. Using this parameter reduces the number of allocations when adding Actions.

ActionMenuAccessor::~ActionMenuAccessor ( )

Member Function Documentation

void ActionMenuAccessor::AddAction ( Action * action )

Adds the Action action at the end of the menu-list described by the ActionMenuAccessor.

BOOLEAN ActionMenuAccessor::ContainsAction ( const Action & action ) const

BOOLEAN ActionMenuAccessor::First ( ) [virtual]

See also:
AbstractMenuAccessor::First

Implements AbstractMenuAccessor.

Action * ActionMenuAccessor::GetAction ( INT index ) const

Action * ActionMenuAccessor::GetAction ( ) [virtual]

See also:
AbstractActionMenuAccessor::GetAction

Implements AbstractActionMenuAccessor.

INT ActionMenuAccessor::GetActionCount ( ) const

INT ActionMenuAccessor::GetActionIndex ( const Action & action ) const

void ActionMenuAccessor::Init | ( | const WCHAR * | title,
 |  | INT | action_count = 4
 | ) |

Parameters:
title | Title which will be used for the Menu using the ActionMenuAccessor.
action_count | Optional parameter which gives the ActionMenuAccessor a hint how many Actions will be added. Using this parameter reduces the number of allocations when adding Actions.

void ActionMenuAccessor::InsertAction | ( | INT | index,
 |  | Action * | action
 | ) |

BOOLEAN ActionMenuAccessor::Next ( ) [virtual]

See also:
AbstractMenuAccessor::Next

Implements AbstractMenuAccessor.

void ActionMenuAccessor::OnTrigger ( INT selected_idx ) [protected, virtual]

See also:
MenuAccessor::OnTrigger

Reimplemented from AbstractActionMenuAccessor.

void ActionMenuAccessor::RemoveAction ( INT index )

void ActionMenuAccessor::RemoveAllActions ( )

void ActionMenuAccessor::SetAction | ( | INT | index,
 |  | Action * | action
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/GuiMenuAccessors/ActionMenuAccessor.hpp
  • AddOns/GuiMenuAccessors/ActionMenuAccessor.cpp
Generated on Wed Jan 25 00:55:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ActiveWaitDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ActiveWaitDispatcher Class Reference
[Kernel]

#include <Apoxi/Kernel/ActiveWaitDispatcher.hpp>

Inheritance diagram for ActiveWaitDispatcher:

[legend]
Collaboration diagram for ActiveWaitDispatcher:

[legend]

Public Member Functions

ActiveWaitDispatcher (const AbstractMessageMapContainer *msg_map_container=0, BOOLEAN add_immediately=FALSE)
void | Done ()
void | Init (const AbstractMessageMapContainer *msg_map_container)
virtual BOOLEAN | Wait (UINT32 timeout=0)
virtual | ~ActiveWaitDispatcher ()

Detailed Description

MessageMapDispatcher with a ready-to-use active wait implementation.

Constructor & Destructor Documentation

ActiveWaitDispatcher::ActiveWaitDispatcher | ( | const AbstractMessageMapContainer * | msg_map_container = 0,
 |  | BOOLEAN | add_immediately = FALSE
 | ) |

ActiveWaitDispatcher::~ActiveWaitDispatcher ( ) [virtual]

Member Function Documentation

void ActiveWaitDispatcher::Done ( )

void ActiveWaitDispatcher::Init ( const AbstractMessageMapContainer * msg_map_container )

Reimplemented from MessageMapDispatcher.

BOOLEAN ActiveWaitDispatcher::Wait ( UINT32 timeout = 0 ) [virtual]

Parameters:
timeout timeout period in milliseconds to return from Wait without fulfilling the condition.
Returns:
TRUE if the condition has been fulfilled, FALSE if the timer is expired.

The documentation for this class was generated from the following files:
  • Kernel/ActiveWaitDispatcher.hpp
  • Kernel/ActiveWaitDispatcher.cpp
Generated on Wed Jan 25 00:55:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddAllToFdnAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AddAllToFdnAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for AddAllToFdnAction:

[legend]
Collaboration diagram for AddAllToFdnAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN AddAllToFdnAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 00:55:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddEntryToFdnAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AddEntryToFdnAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for AddEntryToFdnAction:

[legend]
Collaboration diagram for AddEntryToFdnAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN AddEntryToFdnAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 00:55:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AddInfo Struct Reference

#include <Apoxi/Apc/SimMiscTypes.hpp>

Data Fields

UINT8 val [4]

Field Documentation

UINT8 AddInfo::val[4]

The documentation for this struct was generated from the following file:
  • Apc/SimMiscTypes.hpp
Generated on Wed Jan 25 00:55:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AddNumberToFdnAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AddNumberToFdnAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for AddNumberToFdnAction:

[legend]
Collaboration diagram for AddNumberToFdnAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN AddNumberToFdnAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 00:55:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AdvPbAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AdvPbAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for AdvPbAction:

[legend]
Collaboration diagram for AdvPbAction:

[legend]

Public Member Functions

AdvPbAction ()
AdvPbApp * GetPbApplication ()
void | Init (AdvPbApp *pb_app, const WCHAR *text)
virtual | ~AdvPbAction ()

Constructor & Destructor Documentation

AdvPbAction::AdvPbAction ( )

AdvPbAction::~AdvPbAction ( ) [virtual]

Member Function Documentation

AdvPbApp* AdvPbAction::GetPbApplication ( ) [inline]

Reimplemented from PbAction.

void AdvPbAction::Init | ( | AdvPbApp * | pb_app,
 |  | const WCHAR * | text
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 00:55:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AdvPbApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AdvPbApp Class Reference
[AdvPhonebook]

#include <Applications/AdvPhonebook/AdvPbApp.hpp>

Inheritance diagram for AdvPbApp:

[legend]
Collaboration diagram for AdvPbApp:

[legend]

Public Member Functions

virtual void | DisplayMemory ()
Action * GetDelPhonenoAction ()
UINT32 | GetLastDeletedUniqueId ()
virtual INT | GetMaxPhonenos ()
Action * GetNoTypeAction ()
Action * GetSelectGroupAction ()
BOOLEAN | IsPbAvailable ()
virtual ServiceResult | SelectEmailAddress (WString &email, const WString &title=WString())
void | SelectGroup ()
void | SelectNoType ()
BOOLEAN | SyncPhone ()
BOOLEAN | SyncPhoneAll ()
BOOLEAN | SyncSim ()
BOOLEAN | SyncSimAll ()
virtual void | UpdateEnabledActions ()
virtual | ~AdvPbApp ()

Static Public Member Functions

static AdvPbApp * | GetInstance ()

Protected Member Functions

virtual PbDataHandler * | GetPbDataControl ()
virtual PhonebookWin * | GetPhonebook ()
virtual PbSynchronizer * | GetSynchronizer ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnPbWindowClosed (const PbAbstractWin *win)
virtual void | OnSimNotPresent ()
virtual void | OnSimPresent ()
virtual void | OnSimReady ()
virtual BOOLEAN | ServiceReady ()

Constructor & Destructor Documentation

AdvPbApp::~AdvPbApp ( ) [virtual]

Member Function Documentation

void AdvPbApp::DisplayMemory ( ) [virtual]

Reimplemented from PhonebookApp.

Action* AdvPbApp::GetDelPhonenoAction ( ) [inline]

AdvPbApp * AdvPbApp::GetInstance ( ) [static]

UINT32 AdvPbApp::GetLastDeletedUniqueId ( ) [inline]

INT AdvPbApp::GetMaxPhonenos ( ) [virtual]

Implements PhonebookApp.

Action* AdvPbApp::GetNoTypeAction ( ) [inline]

PbDataHandler * AdvPbApp::GetPbDataControl ( ) [protected, virtual]

Implements PhonebookApp.

PhonebookWin * AdvPbApp::GetPhonebook ( ) [protected, virtual]

Implements PhonebookApp.

Action* AdvPbApp::GetSelectGroupAction ( ) [inline]

PbSynchronizer * AdvPbApp::GetSynchronizer ( ) [protected, virtual]

Implements PhonebookApp.

BOOLEAN AdvPbApp::IsPbAvailable ( ) [virtual]

Reimplemented from PhonebookApp.

BOOLEAN AdvPbApp::OnMessage ( const Message & msg ) [protected, virtual]

Reimplemented from PhonebookApp.

void AdvPbApp::OnPbWindowClosed ( const PbAbstractWin * win ) [protected, virtual]

Reimplemented from PhonebookApp.

void AdvPbApp::OnSimNotPresent ( ) [protected, virtual]

Reimplemented from PhonebookApp.

void AdvPbApp::OnSimPresent ( ) [protected, virtual]

Reimplemented from PhonebookApp.

void AdvPbApp::OnSimReady ( ) [protected, virtual]

Reimplemented from PhonebookApp.

ServiceResult AdvPbApp::SelectEmailAddress | ( | WString & | email,
 |  | const WString & | title = WString()
 | ) | [virtual]

Reimplemented from PhonebookApp.

void AdvPbApp::SelectGroup ( )

void AdvPbApp::SelectNoType ( )

BOOLEAN AdvPbApp::ServiceReady ( ) [protected, virtual]

Reimplemented from PhonebookApp.

BOOLEAN AdvPbApp::SyncPhone ( )

BOOLEAN AdvPbApp::SyncPhoneAll ( )

BOOLEAN AdvPbApp::SyncSim ( )

BOOLEAN AdvPbApp::SyncSimAll ( )

void AdvPbApp::UpdateEnabledActions ( ) [virtual]

Reimplemented from PhonebookApp.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbApp.hpp
  • Applications/AdvPhonebook/AdvPbApp.cpp
Generated on Wed Jan 25 00:55:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AdvPbWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AdvPbWin Class Reference
[AdvPhonebook]

#include <Applications/AdvPhonebook/AdvPbWin.hpp>

Inheritance diagram for AdvPbWin:

[legend]
Collaboration diagram for AdvPbWin:

[legend]

Public Member Functions

AdvPbWin ()
virtual PbDetails * | GetDetailWin ()
virtual Provider * | GetMyPbProvider ()
virtual INT | GetSelectedRow ()
void | Init (AdvPbApp *pb_app, Provider *pb_provider=0, INT sort_colid=c_name_id, BOOLEAN read_only=FALSE)
virtual | ~AdvPbWin ()

Protected Member Functions

virtual INT | GetListBoxRow (INT prov_row)

Constructor & Destructor Documentation

AdvPbWin::AdvPbWin ( )

AdvPbWin::~AdvPbWin ( ) [virtual]

Member Function Documentation

PbDetails * AdvPbWin::GetDetailWin ( ) [virtual]

Implements PhonebookWin.

INT AdvPbWin::GetListBoxRow ( INT prov_row ) [protected, virtual]

Reimplemented from PbBaseWin.

Provider * AdvPbWin::GetMyPbProvider ( ) [virtual]

Reimplemented from PbBaseWin.

INT AdvPbWin::GetSelectedRow ( ) [virtual]

Reimplemented from PbBaseWin.

void AdvPbWin::Init | ( | AdvPbApp * | pb_app,
 |  | Provider * | pb_provider = 0,
 |  | INT | sort_colid = c_name_id,
 |  | BOOLEAN | read_only = FALSE
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbWin.hpp
  • Applications/AdvPhonebook/AdvPbWin.cpp
Generated on Wed Jan 25 00:55:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AesCrypt Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AesCrypt Class Reference

#include <Apoxi/AddOns/Aes/AesCryptInterface.hpp>

Public Types

enum | PaddingMethod { PaddingMethod2630, PaddingMethodNone }
Padding methods. More...

Public Member Functions

AesCrypt ()
INT | DecryptBuffer (const BYTE *in, BYTE *out, UINT buf_len, PaddingMethod pad_method, UINT start_block=0, UINT end_block=0)
AesError | GetLastAesError () const
void | SetKey (const UINT8 *key)
~AesCrypt ()

Detailed Description

AES module

- AES implementation for APOXI

AES

AES (Advanced Encryption Standard) is a standard recommended by specs such as DRM for content encryption. It is a block cipher supporting many different block sizes like 128 bits, 256 bits etc.

of the C Implementation

The algorithm / implementation used here is by Dr. Brian Gladman and released as free to be used by proprietary and open source software Web Link : http://fp.gladman.plus.com/AES/index.htm

The directory AddOns\ has the APOXI wrapper and AddOns has the C code from Brian Gladman. For copyright details refer to the header files under Aes

Wrapper

The class AesCrypt offers limited functionality keeping in mind the requirements for OMA DRM v1.0. The following section lists the limitations.

AES

Currently AES supports the following features

  • Decryption only
  • Key Size 128 bit
  • Block Size 128 bit
  • CBC mode

Using voice recognition

To decrypt a buffer encrypted using AES, you need the following

  • A 128 bit key used to encrypt the buffer
  • A 128 bit initialisation vector used for encryption (as the first 128 bits of the encrypted buffer)

AES

To use the APIs, the block numbers are calculated as follows

Incoming buffer: +----+----+----+----.......----+ | | | | | | 0 | 1 | 2 | | | IV | | | | +----+----+----+----.......----+

In the above, since block 0 of the incoming buffer is the IV, it won't be present in the decrypted buffer. And hence block 1 in the incoming buffer is referred as block 0 of the output buffer. And hence the start_block and end_block can have values from 0 to (n-1). And the output buffer will have [end_block - start_block] number of blocks.

Member Enumeration Documentation

enum AesCrypt::PaddingMethod

Padding methods.

Enumerator:
PaddingMethod2630
PaddingMethodNone

Constructor & Destructor Documentation

AesCrypt::AesCrypt ( ) [inline]

AesCrypt::~AesCrypt ( ) [inline]

Member Function Documentation

INT AesCrypt::DecryptBuffer | ( | const BYTE * | in,
 |  | BYTE * | out,
 |  | UINT | buf_len,
 |  | PaddingMethod | pad_method,
 |  | UINT | start_block = 0,
 |  | UINT | end_block = 0
 | ) |

Decrypts an AES encrypted buffer (using CBC mode). Actual size of the decrypted buffer will be a maximum of input buffer size minus 16 bytes (the initialisation vector). It might be little lesser depending on the padding mode.

Parameters:
in | Input buffer (bytes)
out | Output buffer (bytes). The Output buffer is allocated and freed by the caller. The caller must allocate a minimum of buf_len-16 bytes of memory for this operation.
buf_len | Input buffer length
pad_method | Padding method (enumerator
See also:
PaddingMethod)
Parameters:
start_block | Starting block number
end_block | Ending block number
Returns:
Size of the decrypted buffer

AesError AesCrypt::GetLastAesError ( ) const [inline]

Gets the last error code

Parameters:
None
Returns:
Error code as enumerator
See also:
AesError

void AesCrypt::SetKey ( const UINT8 * key )

Sets the key to be used

Parameters:
key A 128 bit key to be used
Returns:
None

The documentation for this class was generated from the following files:
  • AddOns/Aes/AesCryptInterface.hpp
  • AddOns/Aes/AesCryptInterface.cpp
Generated on Wed Jan 25 00:55:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AidingData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AidingData Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpTypes.hpp>

Public Member Functions

AidingData (INT length, const BYTE *aid_data)
Argument constructor.
const T_BYTE_STR & GetAidingData () const
~AidingData ()
Destructor.

Constructor & Destructor Documentation

AidingData::AidingData | ( | INT | length,
 |  | const BYTE * | aid_data
 | ) | [inline]

Argument constructor.

AidingData::~AidingData ( ) [inline]

Destructor.

Member Function Documentation

const T_BYTE_STR& AidingData::GetAidingData ( ) const [inline]

The documentation for this class was generated from the following file:
  • AddOns/Lcs/GLTP/GltpTypes.hpp
Generated on Wed Jan 25 00:55:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AlarmManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AlarmManager Class Reference
[Kernel]

#include <Apoxi/Kernel/AlarmManager.hpp>

Inheritance diagram for AlarmManager:

[legend]
Collaboration diagram for AlarmManager:

[legend]

Public Types

enum | PowerOnBehavior { Default, NoPowerOn, PowerOn }

Public Member Functions

virtual | ~AlarmManager ()

Static Public Member Functions

static void | ClearAlarm ()
static void | Register ()
static void | SetAlarm (const DateTime &alarm, PowerOnBehavior behavior=Default, StartUp::Cause startup_cause=StartUp::AlarmOn)
static void | SetDefaultPowerOnBehavior (PowerOnBehavior behavior)

Data Structures

struct | AlarmList

Detailed Description

  • Alarm manager handles one alarm request per application. This means it holds a list of each applications next alarm time stamp.
    • Applications which receive Alarm Notification Message have to send its next alarm request (if it has one).
    • If multiple applications are requesting an alarm with the same point of time the alarm manager sends the Alarm Notification Message to all applications.
    • When powering on, the Alarm Manager sends the Alarm Notification Message to all Applications which have missed an alarm during power off.

Member Enumeration Documentation

enum AlarmManager::PowerOnBehavior

Is used to define the power-on-behavior for alarms.

Enumerator:
Default
NoPowerOn | The default behavior set by AlarmManager::SetDefaultPowerOnBehavior.
PowerOn | The real time clock will power on the phone when the alarm expires.

Constructor & Destructor Documentation

AlarmManager::~AlarmManager ( ) [virtual]

Member Function Documentation

void AlarmManager::ClearAlarm ( ) [static]

This method has to be called, if an application wants to clear its stored ('next') alarm.

void AlarmManager::Register ( ) [static]

Has to be called during start-up by each execution context which wants to use the alarm manager. All these execution contexts has to overwrite the new virtual method ExecutionContext::GetGuid() by returning a GUID. The GUID is necessary to re-identify all execution contexts after each re-boot. Registration is mandatory, as in case of dynamically allocated execution context objects or future firmware update over the air AlarmManager can not identify the context (application, service thread) by its memory address (application / context pointer). The alarm manager stores the list of requested alarms if the APOXI registry and therefor application pointers can change with the next system start.

void AlarmManager::SetAlarm | ( | const DateTime & | alarm,
 |  | PowerOnBehavior | behavior = Default,
 |  | StartUp::Cause | startup_cause = StartUp::AlarmOn
 | ) | [static]

This method has to be called by the execution context to request an alarm. When one context is calling SetAlarm multiple times, alarms with a later time stamps than the stored one are ignored. In other words: only the 'next' alarm of each execution context is handled by the alarm manager.

Parameters:
alarm | Point of time for the alarm. Attention: Second information (e.g. 12:17:44) will be ignored and set to zero (->12:17:00).
behavior | See AlarmManager::PowerOnBehavior.
startup_cause | Defines the startup cause for the alarm, currently only StartUp::NormalOn and StartUp::AlarmOn are allowed.

void AlarmManager::SetDefaultPowerOnBehavior ( PowerOnBehavior behavior ) [static]

This method defines the power-on-behavior of all alarms, which are set to Default.

The documentation for this class was generated from the following files:
  • Kernel/AlarmManager.hpp
  • Kernel/AlarmManager.cpp
Generated on Wed Jan 25 00:55:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AlarmMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AlarmMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for AlarmMsg:

[legend]
Collaboration diagram for AlarmMsg:

[legend]

Public Types

enum | { ID = 18020 }

Public Member Functions

AlarmMsg ()
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AlarmMsg ()

Detailed Description

AlarmMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AlarmMsg::AlarmMsg ( )

AlarmMsg::~AlarmMsg ( ) [virtual]

Member Function Documentation

Message * AlarmMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AlarmMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 00:55:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AlarmNotificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AlarmNotificationMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for AlarmNotificationMsg:

[legend]
Collaboration diagram for AlarmNotificationMsg:

[legend]

Public Types

enum | { ID = 112 }

Public Member Functions

AlarmNotificationMsg (ExecutionContext *context)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AlarmNotificationMsg ()

Detailed Description

This message will be sent to the alarm manager detects an expired alaram.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AlarmNotificationMsg::AlarmNotificationMsg ( ExecutionContext * context )

AlarmNotificationMsg::~AlarmNotificationMsg ( ) [virtual]

Member Function Documentation

Message * AlarmNotificationMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AlarmNotificationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 00:55:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Alert Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Alert Class Reference
[Components]

#include <Apoxi/Gui/Alert.hpp>

Inheritance diagram for Alert:

[legend]
Collaboration diagram for Alert:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

Alert (const WString &text, INT delay=-1)
Alert (const WCHAR *text, INT delay=-1)
Alert ()
BOOLEAN | CloseImmediately ()
INT | GetDelay () const
const WString & | GetText () const
const TextFormat & | GetTextFormat () const
void | Init (const WString &text, INT delay=-1)
void | Init (const WCHAR *text, INT delay=-1)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual INT | OpenModal (const Rect &rect=Rect())
virtual void | OpenModeless (const Rect &rect=Rect())
void | SetDelay (INT delay)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetText (const WString &text)
void | SetText (const WCHAR *text)
void | SetTextFormat (const TextFormat &text_format)
virtual | ~Alert ()

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnPaint (const Rect &repaint_rect)
virtual BOOLEAN | OnTimeout (const Timer &timer)

Data Structures

class | CloseCondition

Detailed Description

An Alert is a Window, which displays a text and closes itself automatically after a certain time. An Alert can be opened modal or modeless. The time until the Alert closes itself can be specified by SetDelay or the constructor. When opened modeless and invoking Alert::Close() the Alert will not be closed until the set delay has been timed out.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Window.

Constructor & Destructor Documentation

Alert::Alert ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

Alert::Alert | ( | const WCHAR * | text,
 |  | INT | delay = -1
 | ) |

Initializes the alert with text and delay.

Parameters:
text | Text which should be displayed.
delay | Delay in milliseconds.

Alert::Alert | ( | const WString & | text,
 |  | INT | delay = -1
 | ) |

Initializes the alert with text and delay.

Parameters:
text | Text which should be displayed.
delay | Delay in milliseconds.

Alert::~Alert ( ) [virtual]

Member Function Documentation

BOOLEAN Alert::CloseImmediately ( )

Ignores the remaining delay and closes the alert immediately. Usually it should be avoided to close an alert this way, as it might make it impossible for the user to read the text.

INT Alert::GetDelay ( void ) const [inline]

const WString& Alert::GetText ( ) const [inline]

const TextFormat& Alert::GetTextFormat ( ) const [inline]

void Alert::Init | ( | const WString & | text,
 |  | INT | delay = -1
 | ) |

Initializes the alert with text and delay.

Parameters:
text | Text which should be displayed.
delay | Delay in milliseconds.

void Alert::Init | ( | const WCHAR * | text,
 |  | INT | delay = -1
 | ) |

Initializes the alert with text and delay.

Parameters:
text | Text which should be displayed.
delay | Delay in milliseconds.

BOOLEAN Alert::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Window.

void Alert::OnClose ( ) [protected, virtual]

See also:
Window::OnClose

Reimplemented from Window.

BOOLEAN Alert::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Window.

void Alert::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

See also:
Window::OnPaint

Reimplemented from Control.

BOOLEAN Alert::OnTimeout ( const Timer & timer ) [protected, virtual]

See also:
Window::OnTimeout

Reimplemented from Control.

INT Alert::OpenModal ( const Rect & rect = Rect() ) [virtual]

See also:
Window::OpenModal()

Reimplemented from Window.

void Alert::OpenModeless ( const Rect & rect = Rect() ) [virtual]

See also:
Window::OpenModeless()

Reimplemented from Window.

void Alert::SetDelay ( INT delay )

Sets the delay in milliseconds until the alert should get closed. If the alert is still open and SetDelay is invoked again, the old delay will be replaced by the new one.

BOOLEAN Alert::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from Window.

void Alert::SetText ( const WString & text )

void Alert::SetText ( const WCHAR * text )

void Alert::SetTextFormat ( const TextFormat & text_format ) [inline]

The documentation for this class was generated from the following files:
  • Gui/Alert.hpp
  • Gui/Alert.cpp
Generated on Wed Jan 25 00:55:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Allocator< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Allocator< T > Class Template Reference
[Kernel]

#include <Apoxi/Kernel/Allocator.hpp>

Inheritance diagram for Allocator< T >:

[legend]

Public Types

typedef Allocator< T > | ThisType

Static Public Member Functions

static T * | Alloc (INT n)
static T * | Alloc ()
static void | Construct (T *p, const T &val)
static void | Destruct (T *p)
static void | Free (T *p)

Detailed Description

template<class T>
class Allocator< T >

Allocator is the standard dynamic memory manager of APOXI system.

Member Typedef Documentation

template<class T>
typedef Allocator<T> Allocator< T >::ThisType

Member Function Documentation

template<class T>
static T* Allocator< T >::Alloc ( INT n ) [inline, static]

Allocate memory for n objects of type T. Note that memory is only allocated - ctor of type T wont be executed

Parameters:
n Number of objects to allocate
Returns:
returns a pointer to memory allocated for n instances of type T returns 0 (Null) in error case

template<class T>
static T* Allocator< T >::Alloc ( ) [inline, static]

Allocate memory for type T. Note that memory is only allocated - ctor of type T wont be executed

Returns:
returns a pointer to memory allocated for an instance of type T returns 0 (Null) in error case

template<class T>
static void Allocator< T >::Construct | ( | T * | p,
 |  | const T & | val
 | ) | [inline, static]

Constructs an object of type T (i.e. calls ctor of T)

Parameters:
p | Pointer to memory where object should be constructed
val | Initialization value of newly created object

template<class T>
static void Allocator< T >::Destruct ( T * p ) [inline, static]

Destructs an object of type T (i.e. calls dtor of T)

Parameters:
p Pointer to a valid object of type T, this object must been formaly created with Allocator<T>::Construct

template<class T>
static void Allocator< T >::Free ( T * p ) [inline, static]

Frees memory for previously allocated by Allocator<T>::Alloc. Note that memory is only freed - dtor of type T wont be executed

Parameters:
p pointer to memory to dellocate, can be 0 (Null)

The documentation for this class was generated from the following file:
  • Kernel/Allocator.hpp
Generated on Wed Jan 25 00:55:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AlphaCoding Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AlphaCoding Class Reference

#include <Apoxi/Auxiliary/AlphaCoding.hpp>

Public Member Functions

AlphaCoding ()
~AlphaCoding ()

Static Public Member Functions

static WString | DecodeAlphaField (const UINT8 *buffer, const INT len, const INT prealloclen=0)
static void | EnableUsagePureUcs2Encoding (BOOLEAN enable=TRUE)
static BOOLEAN | EncodeAlphaField (const WString &str, UINT8 *buffer, INT len, INT &strlen, INT &efflen)
static BOOLEAN | EncodeAlphaField (const WString &str, UINT8 *buffer, INT len)
static INT | GetCodedAlphaFieldLen (const WString &wstr)

Constructor & Destructor Documentation

AlphaCoding::AlphaCoding ( )

AlphaCoding::~AlphaCoding ( )

Member Function Documentation

WString AlphaCoding::DecodeAlphaField | ( | const UINT8 * | buffer,
 |  | const INT | len,
 |  | const INT | prealloclen = 0
 | ) | [static]

Decodes a byte buffer coded with GSM 11.11 Annex B and returns a wstring object. prealloclen defines the length of the pre allocated string buffer.

void AlphaCoding::EnableUsagePureUcs2Encoding ( BOOLEAN enable = TRUE ) [static]

Controls if only UCS2 coding scheme 0x80 shall be used for encoding unicode characters. The encoding of 7-bit characters remain unchanged from this setting. This setting influences the behaviour of GetCodedAlphaFieldLen and EncodeAlphaField methods, by meaning it is garantueed that UCS2 scheme 0x81 and 0x82 are not taken into account. The default value is FALSE, this means 0x81 and 0x82 are used when not calling this method.

BOOLEAN AlphaCoding::EncodeAlphaField | ( | const WString & | str,
 |  | UINT8 * | buffer,
 |  | INT | len,
 |  | INT & | strlen,
 |  | INT & | efflen
 | ) | [static]

BOOLEAN AlphaCoding::EncodeAlphaField | ( | const WString & | str,
 |  | UINT8 * | buffer,
 |  | INT | len
 | ) | [static]

Fills a byte buffer in an optimal way dependend of the content of the wstring object. All four coding schemes might be used for coding the unicode string dependend of the setting of EnableUsagePureUcs2Encoding method.

INT AlphaCoding::GetCodedAlphaFieldLen ( const WString & wstr ) [static]

Retrieves the alpha coded length of a given Unicode string, dependend of the setting of EnableUsagePureUcs2Encoding method.

The documentation for this class was generated from the following files:
  • Auxiliary/AlphaCoding.hpp
  • Auxiliary/AlphaCoding.cpp
Generated on Wed Jan 25 00:55:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AmplifierAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AmplifierAudioDevice Class Reference

#include <Apoxi/Devices/Win32/AmplifierAudioDevice.hpp>

Inheritance diagram for AmplifierAudioDevice:

[legend]
Collaboration diagram for AmplifierAudioDevice:

[legend]

Public Member Functions

AmplifierAudioDevice ()
virtual const WCHAR * | GetName () const
virtual AudioReturnCode | Init (Priority prio)
virtual AudioReturnCode | Start (BOOLEAN auto_release=TRUE)
virtual AudioReturnCode | Stop (UINT8 channel=0)
virtual | ~AmplifierAudioDevice ()

Detailed Description

Class AmplifierAudioDevice
Class for external amplifier access.

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Constructor & Destructor Documentation

AmplifierAudioDevice::AmplifierAudioDevice ( )

AmplifierAudioDevice::~AmplifierAudioDevice ( ) [virtual]

Member Function Documentation

const WCHAR * AmplifierAudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from GenericAudioDevice.

AmplifierAudioDevice::AudioReturnCode AmplifierAudioDevice::Init ( Priority prio ) [virtual]

See also:
AudioDevice::Init

AmplifierAudioDevice::AudioReturnCode AmplifierAudioDevice::Start ( BOOLEAN auto_release = TRUE ) [virtual]

See also:
GenericAudioDevice::Start
Note: auto_release is not used.

Reimplemented from GenericAudioDevice.

AmplifierAudioDevice::AudioReturnCode AmplifierAudioDevice::Stop ( UINT8 channel = 0 ) [virtual]

See also:
GenericAudioDevice::Stop

Reimplemented from GenericAudioDevice.

The documentation for this class was generated from the following files:
  • Devices/Win32/AmplifierAudioDevice.hpp
  • Devices/Win32/AmplifierAudioDevice.cpp
Generated on Wed Jan 25 00:55:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AmrSound Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AmrSound Class Reference
[MultiMedia]

Class to handle and decode MIDI sounds. More...

#include <Applications/SoundBrowser/AmrSound.hpp>

Inheritance diagram for AmrSound:

[legend]
Collaboration diagram for AmrSound:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

AmrSound (BinData *bin_data)
AmrSound ()
virtual const BinData * | GetBinData () const
Returns the i-melody data in the ems specific format.
virtual INT | GetId () const
void | Init (BinData *bin_data)
virtual | ~AmrSound ()

Detailed Description

Class to handle and decode MIDI sounds.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AmrSound::AmrSound ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AmrSound::AmrSound ( BinData * bin_data ) [explicit]

Initializes an MIDI sound with the given bin_data.

Parameters:
bin_data Pointer to a binary data stream which contains the i-melody data. After passing the binary data stream, the stream is obtained by the MIDI sound and hence automatically released in the destructor of the MIDI sound.

AmrSound::~AmrSound ( ) [virtual]

Member Function Documentation

const BinData * AmrSound::GetBinData ( ) const [virtual]

Returns the i-melody data in the ems specific format.

Reimplemented from Sound.

INT AmrSound::GetId ( ) const [virtual]

See also:
Sound::GetId

Implements Sound.

void AmrSound::Init ( BinData * bin_data )

Initializes an MIDI sound with the given bin_data.

Parameters:
bin_data Pointer to a binary data stream which contains the i-melody data. After passing the binary data stream, the stream is obtained by the MIDI sound and hence automatically released in the destructor of the MIDI sound.

The documentation for this class was generated from the following files:
  • Applications/SoundBrowser/AmrSound.hpp
  • Applications/SoundBrowser/AmrSound.cpp
Generated on Wed Jan 25 00:55:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AnimatedTextLine Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AnimatedTextLine Class Reference
[Components]

#include <Apoxi/Gui/AnimatedTextLine.hpp>

Inheritance diagram for AnimatedTextLine:

[legend]
Collaboration diagram for AnimatedTextLine:

[legend]

Public Types

enum | { ID = 5 }
enum | Type { Bounce, Cycle, OnlyOnce }

Public Member Functions

AnimatedTextLine (Control *control, const WCHAR *text=0, const TextFormat &text_format=TextFormat(), Type anim_type=Cycle, UINT16 start_delay=300, UINT16 anim_speed=200, XYDIM step=2, BOOLEAN auto_start=FALSE)
AnimatedTextLine ()
INT | GetOffset () const
Returns the horizontal offset in pixels from the animation.
XYDIM | GetStep () const
XYDIM | GetTextGap () const
Type | GetType () const
Returns the type of the animation: Bounce, Cycle or OnlyOnce.
void | Init (Control *control, const WCHAR *text=0, const TextFormat &text_format=TextFormat(), Type anim_type=Cycle, UINT16 start_delay=300, UINT16 anim_speed=200, XYDIM step=2, BOOLEAN auto_start=FALSE)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsStarted () const
Returns whether the animation has been started.
virtual void | SetFont (const Font &font)
void | SetHighlighted (BOOLEAN highlighted) const
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual void | SetText (const WCHAR *text)
virtual void | SetTextFormat (const TextFormat &text_format)
void | Start ()
void | Stop ()
Stops the animation.
virtual | ~AnimatedTextLine ()

Protected Member Functions

virtual void | Cleanup ()
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | Refresh (const Rect &rect)

Friends

class | TriggerTimer< AnimatedTextLine >

Detailed Description

An AnimatedTextLine is a drawable object, which contains a text having its own textformat and color. If the text does not fit into the available width of the drawable object, the text starts to scroll.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from TextLine.

enum AnimatedTextLine::Type

Enumerator:
Bounce | The text scrolls between the borders.
Cycle | The text scrolls only in one direction.
OnlyOnce | The text scrolls only once in in one direction.

Constructor & Destructor Documentation

AnimatedTextLine::AnimatedTextLine ( )

If the default constructor is used the animated text line must be initialized by the method Init.

AnimatedTextLine::AnimatedTextLine | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const TextFormat & | text_format = TextFormat(),
 |  | Type | anim_type = Cycle,
 |  | UINT16 | start_delay = 300,
 |  | UINT16 | anim_speed = 200,
 |  | XYDIM | step = 2,
 |  | BOOLEAN | auto_start = FALSE
 | ) |

Parameters:
control | Parent control where the animated text line should be embedded.
text | Pointer to the text which should be displayed.
text_format | Textformat of the text.
anim_type | When the text does not fit into the available width, a scrolling is started. The kind of scroll animation is defined by the anim_type.
start_delay | Delay in milliseconds until the scrolling of the text starts.
anim_speed | Delay in milliseconds until the next scroll step is done.
step | Number of pixels which are used to move the text to the next scroll position.
auto_start | If set to TRUE, the animation is started automatically as soon as the text does not fit into the available width.

AnimatedTextLine::~AnimatedTextLine ( ) [virtual]

Member Function Documentation

void AnimatedTextLine::Cleanup ( ) [protected, virtual]

See also:
Component::Cleanup

Reimplemented from Component.

INT AnimatedTextLine::GetOffset ( ) const [inline]

Returns the horizontal offset in pixels from the animation.

XYDIM AnimatedTextLine::GetStep ( ) const [inline]

Returns the number of pixels which are used to move the text to the next scroll position.

XYDIM AnimatedTextLine::GetTextGap ( ) const

Returns the gap in pixels which is used for displaying the animated text from the right if it the original text disappears on the left.

Type AnimatedTextLine::GetType ( ) const [inline]

Returns the type of the animation: Bounce, Cycle or OnlyOnce.

void AnimatedTextLine::Init | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const TextFormat & | text_format = TextFormat(),
 |  | Type | anim_type = Cycle,
 |  | UINT16 | start_delay = 300,
 |  | UINT16 | anim_speed = 200,
 |  | XYDIM | step = 2,
 |  | BOOLEAN | auto_start = FALSE
 | ) |

Parameters:
control | Parent control where the animated text line should be embedded.
text | Pointer to the text which should be displayed.
text_format | Textformat of the text.
anim_type | When the text does not fit into the available width, a scrolling is started. The kind of scroll animation is defined by the anim_type.
start_delay | Delay in milliseconds until the scrolling of the text starts.
anim_speed | Delay in milliseconds until the next scroll step is done.
step | Number of pixels which are used to move the text to the next scroll position.
auto_start | If set to TRUE, the animation is started automatically as soon as the text does not fit into the available width.

BOOLEAN AnimatedTextLine::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from TextLine.

BOOLEAN AnimatedTextLine::IsStarted ( ) const [inline]

Returns whether the animation has been started.

void AnimatedTextLine::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnResize

Reimplemented from DrawableObject.

void AnimatedTextLine::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from Component.

void AnimatedTextLine::SetFont ( const Font & font ) [virtual]

Sets the font and restarts the animation.

Reimplemented from AbstractTextObject.

void AnimatedTextLine::SetHighlighted ( BOOLEAN highlighted ) const

Parameters:
highlighted turns highlighting on or off

BOOLEAN AnimatedTextLine::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by Aragon to fill the properties by reading out a resource file. It should not be necessary for the application developer to invoke this method in a direct manner.

Reimplemented from TextLine.

void AnimatedTextLine::SetText ( const WCHAR * text ) [virtual]

Sets the text and restarts the animation.

Reimplemented from AbstractTextObject.

void AnimatedTextLine::SetTextFormat ( const TextFormat & text_format ) [virtual]

Sets the textformat and restarts the animation.

Reimplemented from AbstractTextObject.

void AnimatedTextLine::Start ( )

Starts the animation immediately if the text does not fit in the current line. If the line is wide enough, the started flag is set, but the animation timer is not started. The timer (and hence the animation) is started as soon as the line is not wide enough any more (e. g. if the textline or its parent component is resized).

void AnimatedTextLine::Stop ( )

Stops the animation.

Friends And Related Function Documentation

friend class TriggerTimer< AnimatedTextLine > [friend]

The documentation for this class was generated from the following files:
  • Gui/AnimatedTextLine.hpp
  • Gui/AnimatedTextLine.cpp
Generated on Wed Jan 25 00:55:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AnimatedTextLineView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AnimatedTextLineView Class Reference
[Components]

#include <Apoxi/Gui/AnimatedTextLine.hpp>

Inheritance diagram for AnimatedTextLineView:

[legend]
Collaboration diagram for AnimatedTextLineView:

[legend]

Public Member Functions

AnimatedTextLineView ()
virtual ~AnimatedTextLineView ()

Detailed Description

View object for drawing an animated textline.
See also:
AnimatedTextLine

Constructor & Destructor Documentation

AnimatedTextLineView::AnimatedTextLineView ( )

AnimatedTextLineView::~AnimatedTextLineView ( ) [virtual]

The documentation for this class was generated from the following files:
  • Gui/AnimatedTextLine.hpp
  • Gui/AnimatedTextLine.cpp
Generated on Wed Jan 25 00:55:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Animation Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Animation Class Reference

Obsolete - use class ImageBox from GUI instead. More...

#include <Apoxi/Compat/Animation.hpp>

Inheritance diagram for Animation:

[legend]
Collaboration diagram for Animation:

[legend]

Public Types

enum | AnimationType { Cycle, Oscillate, Once }
typedef DrawableObject | Base

Public Member Functions

Animation (Control *control, const AnimationBmpIterator *bmp_it, UINT32 timeout=0, AnimationType type=Cycle)
Animation ()
const AnimationBmpIterator * | GetBmpIterator () const
Get bitmap iterator object.
virtual XYDIM | GetDefaultHeight () const
virtual XYDIM | GetDefaultWidth () const
INT | GetIndex () const
Returns the index of the currently active bitmap.
void | Init (Control *control, const AnimationBmpIterator *bmp_it, UINT32 timeout=0, AnimationType type=Cycle)
void | SetBmpIterator (const AnimationBmpIterator *bmp_it)
Set bitmap iterator object.
void | SetIndex (INT index)
Sets the index of the currently active bitmap and the animation stops.
void | Start ()
Starts the animation.
virtual | ~Animation ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual void | OnThemeChanged ()
virtual void | OnTimer ()
Called, if the timer has been exceeded.

Detailed Description

Obsolete - use class ImageBox from GUI instead.

Member Typedef Documentation

typedef DrawableObject Animation::Base

Reimplemented from DrawableObject.

Member Enumeration Documentation

enum Animation::AnimationType

The type of an animated bitmap describes in which order the bitmaps are displayed.

Example: An animated bitmap contains the bitmaps 0, 1 and 2.
CYCLE - 0, 1, 2, 0, 1, 2, ...
OSCILLATE - 0, 1, 2, 1, 0, 1, 2, 1, 0, ...
ONCE - 0, 1, 2.

Enumerator:
Cycle
Oscillate
Once

Constructor & Destructor Documentation

Animation::Animation ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

Animation::Animation | ( | Control * | control,
 |  | const AnimationBmpIterator * | bmp_it,
 |  | UINT32 | timeout = 0,
 |  | AnimationType | type = Cycle
 | ) |

Animation::~Animation ( ) [virtual]

Member Function Documentation

Model * Animation::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

const AnimationBmpIterator * Animation::GetBmpIterator ( ) const

Get bitmap iterator object.

XYDIM Animation::GetDefaultHeight ( ) const [virtual]

See also:
Component::GetDefaultHeight

Reimplemented from Component.

XYDIM Animation::GetDefaultWidth ( ) const [virtual]

See also:
Component::GetDefaultWidth

Reimplemented from Component.

INT Animation::GetIndex ( ) const

Returns the index of the currently active bitmap.

void Animation::Init | ( | Control * | control,
 |  | const AnimationBmpIterator * | bmp_it,
 |  | UINT32 | timeout = 0,
 |  | AnimationType | type = Cycle
 | ) |

void Animation::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged()

Reimplemented from DrawableObject.

void Animation::OnTimer ( ) [protected, virtual]

Called, if the timer has been exceeded.

Reimplemented from Timer.

void Animation::SetBmpIterator ( const AnimationBmpIterator * bmp_it )

Set bitmap iterator object.

void Animation::SetIndex ( INT index )

Sets the index of the currently active bitmap and the animation stops.

void Animation::Start ( )

Starts the animation.

Reimplemented from Timer.

The documentation for this class was generated from the following files:
  • Compat/Animation.hpp
  • Compat/Animation.cpp
Generated on Wed Jan 25 00:55:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AnimationBmpArrayIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AnimationBmpArrayIterator Class Reference

#include <Apoxi/Compat/Animation.hpp>

Inheritance diagram for AnimationBmpArrayIterator:

[legend]
Collaboration diagram for AnimationBmpArrayIterator:

[legend]

Public Member Functions

AnimationBmpArrayIterator (INT bmp_count=0, const BitmapRes *bmp=0)
virtual INT | BitmapCount () const
void | Init (INT bmp_count, const BitmapRes *bmp)
virtual const BitmapRes * | operator() (INT idx) const

Constructor & Destructor Documentation

AnimationBmpArrayIterator::AnimationBmpArrayIterator | ( | INT | bmp_count = 0,
 |  | const BitmapRes * | bmp = 0
 | ) |

Member Function Documentation

virtual INT AnimationBmpArrayIterator::BitmapCount ( ) const [inline, virtual]

Implements AnimationBmpIterator.

void AnimationBmpArrayIterator::Init | ( | INT | bmp_count,
 |  | const BitmapRes * | bmp
 | ) | [inline]

virtual const BitmapRes* AnimationBmpArrayIterator::operator() ( INT idx ) const [inline, virtual]

Implements AnimationBmpIterator.

The documentation for this class was generated from the following files:
  • Compat/Animation.hpp
  • Compat/Animation.cpp
Generated on Wed Jan 25 00:55:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AnimationBmpIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AnimationBmpIterator Class Reference

#include <Apoxi/Compat/Animation.hpp>

Inheritance diagram for AnimationBmpIterator:

[legend]

Public Member Functions

virtual INT | BitmapCount () const =0
virtual const BitmapRes * | operator() (INT idx) const =0

Member Function Documentation

virtual INT AnimationBmpIterator::BitmapCount ( ) const [pure virtual]

Implemented in AnimationBmpArrayIterator, and AnimationBmpPointerArrayIterator.

virtual const BitmapRes* AnimationBmpIterator::operator() ( INT idx ) const [pure virtual]

Implemented in AnimationBmpArrayIterator, and AnimationBmpPointerArrayIterator.

The documentation for this class was generated from the following file:
  • Compat/Animation.hpp
Generated on Wed Jan 25 00:55:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AnimationBmpPointerArrayIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AnimationBmpPointerArrayIterator Class Reference

#include <Apoxi/Compat/Animation.hpp>

Inheritance diagram for AnimationBmpPointerArrayIterator:

[legend]
Collaboration diagram for AnimationBmpPointerArrayIterator:

[legend]

Public Types

typedef const BitmapRes * | CBitmapResPtr

Public Member Functions

AnimationBmpPointerArrayIterator (INT bmp_count=0, const CBitmapResPtr *bmp=0)
virtual INT | BitmapCount () const
void | Init (INT bmp_count, const CBitmapResPtr *bmp)
virtual const BitmapRes * | operator() (INT idx) const

Member Typedef Documentation

typedef const BitmapRes* AnimationBmpPointerArrayIterator::CBitmapResPtr

Constructor & Destructor Documentation

AnimationBmpPointerArrayIterator::AnimationBmpPointerArrayIterator | ( | INT | bmp_count = 0,
 |  | const CBitmapResPtr * | bmp = 0
 | ) |

Member Function Documentation

virtual INT AnimationBmpPointerArrayIterator::BitmapCount ( ) const [inline, virtual]

Implements AnimationBmpIterator.

void AnimationBmpPointerArrayIterator::Init | ( | INT | bmp_count,
 |  | const CBitmapResPtr * | bmp
 | ) | [inline]

virtual const BitmapRes* AnimationBmpPointerArrayIterator::operator() ( INT idx ) const [inline, virtual]

Implements AnimationBmpIterator.

The documentation for this class was generated from the following files:
  • Compat/Animation.hpp
  • Compat/Animation.cpp
Generated on Wed Jan 25 00:55:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AnimationModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AnimationModel Class Reference

Describes the model of an animated bitmap. More...

#include <Apoxi/Compat/Animation.hpp>

Inheritance diagram for AnimationModel:

[legend]
Collaboration diagram for AnimationModel:

[legend]

Public Member Functions

AnimationModel ()
const BitmapRes & | GetActiveBitmap () const
Returns the currently active bitmap.
const AnimationBmpIterator * | GetBmpIterator () const
INT | GetIndex () const
Returns the index of the currently active bitmap.
void | SetBmpIterator (const AnimationBmpIterator *bmp_it)
void | SetIndex (INT index)
Sets the index of the currently active bitmap.

Detailed Description

Describes the model of an animated bitmap.

Constructor & Destructor Documentation

AnimationModel::AnimationModel ( )

Member Function Documentation

const BitmapRes& AnimationModel::GetActiveBitmap ( ) const [inline]

Returns the currently active bitmap.

const AnimationBmpIterator* AnimationModel::GetBmpIterator ( ) const [inline]

INT AnimationModel::GetIndex ( ) const [inline]

Returns the index of the currently active bitmap.

void AnimationModel::SetBmpIterator ( const AnimationBmpIterator * bmp_it ) [inline]

void AnimationModel::SetIndex ( INT index ) [inline]

Sets the index of the currently active bitmap.

The documentation for this class was generated from the following files:
  • Compat/Animation.hpp
  • Compat/Animation.cpp
Generated on Wed Jan 25 00:55:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AnimationView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AnimationView Class Reference

Describes the view of an animated bitmap. More...

#include <Apoxi/Compat/Animation.hpp>

Inheritance diagram for AnimationView:

[legend]
Collaboration diagram for AnimationView:

[legend]

Public Types

typedef DrawableObjectView | Base

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual | ~AnimationView ()

Detailed Description

Describes the view of an animated bitmap.

Member Typedef Documentation

typedef DrawableObjectView AnimationView::Base

Reimplemented from DrawableObjectView.

Constructor & Destructor Documentation

AnimationView::~AnimationView ( ) [virtual]

Member Function Documentation

void AnimationView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

The documentation for this class was generated from the following files:
  • Compat/Animation.hpp
  • Compat/Animation.cpp
Generated on Wed Jan 25 00:55:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AocChargeData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AocChargeData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

ULONG | charge_value
INT | exponent

Field Documentation

ULONG AocChargeData::charge_value

INT AocChargeData::exponent

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 00:55:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AocChargingStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AocChargingStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for AocChargingStatusMsg:

[legend]
Collaboration diagram for AocChargingStatusMsg:

[legend]

Public Types

enum | { ID = 18419 }

Public Member Functions

AocChargingStatusMsg (ExecutionContext *context, const CallHdl &call_hdl, const AocChargingStatus &status)
virtual Message * | Clone () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
const AocChargingStatus & | GetStatus () const
void | SetCallHdl (const CallHdl &call_hdl)
void | SetStatus (const AocChargingStatus &status)
virtual | ~AocChargingStatusMsg ()

Detailed Description

AocChargingStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AocChargingStatusMsg::AocChargingStatusMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl,
 |  | const AocChargingStatus & | status
 | ) |

AocChargingStatusMsg::~AocChargingStatusMsg ( ) [virtual]

Member Function Documentation

Message * AocChargingStatusMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& AocChargingStatusMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & AocChargingStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const AocChargingStatus& AocChargingStatusMsg::GetStatus ( ) const [inline]

void AocChargingStatusMsg::SetCallHdl ( const CallHdl & call_hdl ) [inline]

void AocChargingStatusMsg::SetStatus ( const AocChargingStatus & status ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 00:55:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AocDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AocDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/AocDispatcher.hpp>

Inheritance diagram for AocDispatcher:

[legend]
Collaboration diagram for AocDispatcher:

[legend]

Public Member Functions

AocDispatcher ()
virtual | ~AocDispatcher ()

Protected Member Functions

BOOLEAN | OnAocInd (const StackMsgArgument &arg)
BOOLEAN | OnChargeInd (const StackMsgArgument &arg)
BOOLEAN | OnChargeUnitsInd (const StackMsgArgument &arg)

Constructor & Destructor Documentation

AocDispatcher::AocDispatcher ( )

AocDispatcher::~AocDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN AocDispatcher::OnAocInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN AocDispatcher::OnChargeInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN AocDispatcher::OnChargeUnitsInd ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/AocDispatcher.hpp
  • Asc/AocDispatcher.cpp
Generated on Wed Jan 25 00:55:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AocHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AocHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/AocHandler.hpp>

Collaboration diagram for AocHandler:

[legend]

Public Types

enum | { ID = AocHandlerId }

Public Member Functions

AocHandler ()
virtual HandlerId | GetHandlerId () const
void | ReportChargeUnits (BOOLEAN activate)
void | ReportCurrentCharge (BOOLEAN activate)
CallApiRc | RequestChargeUnits (CallIndex call_index)
CallApiRc | RequestCurrentCharge (CallIndex call_index)
virtual | ~AocHandler ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AocHandler::AocHandler ( )

AocHandler::~AocHandler ( ) [virtual]

Member Function Documentation

HandlerId AocHandler::GetHandlerId ( ) const [virtual]

void AocHandler::ReportChargeUnits ( BOOLEAN activate )

void AocHandler::ReportCurrentCharge ( BOOLEAN activate )

CallApiRc AocHandler::RequestChargeUnits ( CallIndex call_index )

CallApiRc AocHandler::RequestCurrentCharge ( CallIndex call_index )

The documentation for this class was generated from the following files:
  • Asc/AocHandler.hpp
  • Asc/AocHandler.cpp
Generated on Wed Jan 25 00:55:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AocIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AocIndArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for AocIndArg:

[legend]
Collaboration diagram for AocIndArg:

[legend]

Public Types

enum | { ID = 1066 }

Public Member Functions

AocIndArg ()
const CallRelatedSsCode & | GetStatus () const
const Tipd & | GetTipd () const
void | SetStatus (const CallRelatedSsCode &status)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const AocIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AocIndArg: reflects arguments of signal MN_AOC_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AocIndArg::AocIndArg ( )

Member Function Documentation

const AocIndArg & AocIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallRelatedSsCode& AocIndArg::GetStatus ( ) const [inline]

const Tipd& AocIndArg::GetTipd ( ) const [inline]

void AocIndArg::SetStatus ( const CallRelatedSsCode & status ) [inline]

void AocIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 00:55:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: apoxi_emcpp_OBEXAdapter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

apoxi_emcpp_OBEXAdapter Class Reference

#include <Apoxi/AddOns/StreamObex/apoxi_emcpp_OBEXAdapter.hpp>

Public Member Functions

apoxi_emcpp_OBEXAdapter (emcpp_apoxi_OBEXAdapter &back)
int | handle_response (unsigned char response_code, const ObexObject &response)
const Private & | private_implementation () const
Private & | private_implementation ()
~apoxi_emcpp_OBEXAdapter ()

Constructor & Destructor Documentation

apoxi_emcpp_OBEXAdapter::apoxi_emcpp_OBEXAdapter ( emcpp_apoxi_OBEXAdapter & back )

apoxi_emcpp_OBEXAdapter::~apoxi_emcpp_OBEXAdapter ( )

Member Function Documentation

int apoxi_emcpp_OBEXAdapter::handle_response | ( | unsigned char | response_code,
 |  | const ObexObject & | response
 | ) |

const Private& apoxi_emcpp_OBEXAdapter::private_implementation ( ) const [inline]

Private& apoxi_emcpp_OBEXAdapter::private_implementation ( ) [inline]

The documentation for this class was generated from the following file:
  • AddOns/StreamObex/apoxi_emcpp_OBEXAdapter.hpp
Generated on Wed Jan 25 00:55:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ApoxiCommandAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ApoxiCommandAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for ApoxiCommandAction:

[legend]
Collaboration diagram for ApoxiCommandAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
ApoxiCommandAction ()
virtual InputActionType | GetActionType () const
Returns the type of the action.
UINT | GetCommandId () const
const WString & | GetCommandString () const
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual | ~ApoxiCommandAction ()

Detailed Description

ApoxiCommandAction analyzes if the input string has the meaning of an APOXI command string, that means it fullfills the following syntax: ****cmdno* [cmdstring*], where cmdno is an integer in the range from 1 to 99999 and cmdstring is a optional commandstring which must be finished by a '*'.

Constructor & Destructor Documentation

ApoxiCommandAction::ApoxiCommandAction ( )

ApoxiCommandAction::~ApoxiCommandAction ( ) [virtual]

Member Function Documentation

InputAction * ApoxiCommandAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType ApoxiCommandAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

UINT ApoxiCommandAction::GetCommandId ( ) const [inline]

const WString& ApoxiCommandAction::GetCommandString ( ) const [inline]

BOOLEAN ApoxiCommandAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 00:55:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ApoxiThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ApoxiThread Class Reference
[Kernel]

#include <Apoxi/Kernel/ApoxiThread.hpp>

Inheritance diagram for ApoxiThread:

[legend]
Collaboration diagram for ApoxiThread:

[legend]

Public Member Functions

ApoxiThread ()
virtual const ExecutionContext & | GetContext () const =0
virtual ExecutionContext & | GetContext ()=0
virtual | ~ApoxiThread ()

Detailed Description

ApoxiThread is the abstract base class for all threads which provide an ExecutionContext. It is derived from class Thread and therefore it maps to one operating system thread.
Currently two implementations exist:
  • AppContainer
    An application container holds a number of applications which share the processing time of this thread.
  • ServiceThread
    A service thread exclusively uses the whole processing time of this thread.

Constructor & Destructor Documentation

ApoxiThread::ApoxiThread ( )

ApoxiThread::~ApoxiThread ( ) [virtual]

Member Function Documentation

virtual const ExecutionContext& ApoxiThread::GetContext ( ) const [pure virtual]

Implemented in AppContainer.

virtual ExecutionContext& ApoxiThread::GetContext ( ) [pure virtual]

Implemented in AppContainer.

The documentation for this class was generated from the following files:
  • Kernel/ApoxiThread.hpp
  • Kernel/ApoxiThread.cpp
Generated on Wed Jan 25 00:55:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppActionExecutedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppActionExecutedMsg Class Reference

#include <Apoxi/AddOns/GuiMenuAccessors/MsgTypes.hpp>

Inheritance diagram for AppActionExecutedMsg:

[legend]
Collaboration diagram for AppActionExecutedMsg:

[legend]

Public Types

enum | { ID = 4000 }

Public Member Functions

AppActionExecutedMsg (ExecutionContext *context, Action *action)
virtual Message * | Clone () const
Action * | GetAction () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AppActionExecutedMsg ()

Detailed Description

This message will be sent by an instance of an ApplicationAction, when it has been executed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AppActionExecutedMsg::AppActionExecutedMsg | ( | ExecutionContext * | context,
 |  | Action * | action
 | ) |

AppActionExecutedMsg::~AppActionExecutedMsg ( ) [virtual]

Member Function Documentation

Message * AppActionExecutedMsg::Clone ( ) const [virtual]

Implements Message.

Action* AppActionExecutedMsg::GetAction ( ) const [inline]

const MsgMetaData & AppActionExecutedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/GuiMenuAccessors/MsgTypes.hpp
  • AddOns/GuiMenuAccessors/MsgTypes.cpp
Generated on Wed Jan 25 00:55:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppCloseMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppCloseMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for AppCloseMsg:

[legend]
Collaboration diagram for AppCloseMsg:

[legend]

Public Types

enum | { ID = 101 }

Public Member Functions

AppCloseMsg ()
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AppCloseMsg ()

Detailed Description

This message is sent upon application termination. No arguments.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AppCloseMsg::AppCloseMsg ( )

AppCloseMsg::~AppCloseMsg ( ) [virtual]

Member Function Documentation

Message * AppCloseMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AppCloseMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 00:55:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppContainer Class Reference
[Kernel]

#include <Apoxi/Kernel/AppContainer.hpp>

Inheritance diagram for AppContainer:

[legend]
Collaboration diagram for AppContainer:

[legend]

Public Member Functions

void | AddTimer (Timer *timer)
AppContainer ()
void | Attach (Application *app)
BOOLEAN | ContainsUserInputMsg () const
void | Detach (Application *app)
BOOLEAN | Enqueue (const MessageReferrer &msg_ref)
Application * | GetActiveApplication () const
virtual const ExecutionContext & | GetContext () const
virtual ExecutionContext & | GetContext ()
void | GrabFocus (Application *app, INT priority=-1, BOOLEAN assign_to_win=TRUE) const
Obsolete - use Application::GrabFocus instead.
BOOLEAN | HasFocus () const
BOOLEAN | IsMessageRegistered (const Message &msg) const
BOOLEAN | IsRunning ()
void | MsgLoop ()
const Timer * | NextExpiringTimer ()
void | RegisterMessage (Application *app, MsgId msg_id)
void | RemoveTimer (Timer *timer)
void | Run ()
virtual INT | ThreadFn ()
void | TransferFocus (Application *app) const
Obsolete - use Application::GrabFocus instead.
void | TriggerIsrDataProcessing ()
void | UnregisterMessage (const Application *app, MsgId msg_id)
void | Wait (const Condition &cond)

Friends

class | MsgQueue
void | Os::DbgOutStackUsage ()
class | System
class | Timer

Detailed Description

An application container is an ApoxiThread and maps to one operating system thread.
An application container holds a variable number of applications. These applications are managed by an internal and resource-friendly APOXI scheduler, which assigns the threads processing time to the applications in a cooperative way.

When receiving a message, the application container determines all the applications which are registered for this message. Sequentially, each application is called to handle this message. During an application is handling a message, this application is considered as the active application.

Constructor & Destructor Documentation

AppContainer::AppContainer ( )

Member Function Documentation

void AppContainer::AddTimer ( Timer * timer ) [inline]

void AppContainer::Attach ( Application * app )

Attaches an application to the application container.

BOOLEAN AppContainer::ContainsUserInputMsg ( ) const

Returns TRUE, if the message queue contains a user input message like e. g. a key-down message. This may be useful for blocking operations, which might be quited when a user input message is in the message queue.

void AppContainer::Detach ( Application * app )

Detaches an application from the application container.

BOOLEAN AppContainer::Enqueue ( const MessageReferrer & msg_ref )

Application* AppContainer::GetActiveApplication ( ) const [inline]

Returns:
The currently active application.

const ExecutionContext & AppContainer::GetContext ( ) const [virtual]

Implements ApoxiThread.

ExecutionContext & AppContainer::GetContext ( ) [virtual]

Implements ApoxiThread.

void AppContainer::GrabFocus | ( | Application * | app,
 |  | INT | priority = -1,
 |  | BOOLEAN | assign_to_win = TRUE
 | ) | const

Obsolete - use Application::GrabFocus instead.

BOOLEAN AppContainer::HasFocus ( ) const

Returns:
TRUE if one application of the application container has the focus.

BOOLEAN AppContainer::IsMessageRegistered ( const Message & msg ) const

BOOLEAN AppContainer::IsRunning ( ) [inline]

Returns:
TRUE if all attached applications are up and running.

void AppContainer::MsgLoop ( )

const Timer* AppContainer::NextExpiringTimer ( ) [inline]

void AppContainer::RegisterMessage | ( | Application * | app,
 |  | MsgId | msg_id
 | ) |

void AppContainer::RemoveTimer ( Timer * timer ) [inline]

void AppContainer::Run ( )

Starts the thread

INT AppContainer::ThreadFn ( ) [virtual]

Implements Thread.

void AppContainer::TransferFocus ( Application * app ) const

Obsolete - use Application::GrabFocus instead.

void AppContainer::TriggerIsrDataProcessing ( ) [inline]

void AppContainer::UnregisterMessage | ( | const Application * | app,
 |  | MsgId | msg_id
 | ) |

void AppContainer::Wait ( const Condition & cond ) [inline]

Friends And Related Function Documentation

friend class MsgQueue [friend]

void Os::DbgOutStackUsage ( ) [friend]

friend class System [friend]

friend class Timer [friend]

The documentation for this class was generated from the following files:
  • Kernel/AppContainer.hpp
  • Kernel/AppContainer.cpp
Generated on Wed Jan 25 00:55:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppContainerRoutingTableEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppContainerRoutingTableEntry Class Reference
[Kernel]

#include <Apoxi/Kernel/AppContainerRoutingTable.hpp>

Inheritance diagram for AppContainerRoutingTableEntry:

[legend]
Collaboration diagram for AppContainerRoutingTableEntry:

[legend]

Public Member Functions

void | AddApplication (Application *app)
AppContainerRoutingTableEntry (const HashKey hash_key)
ApplicationListEntry * | GetFirstApplicationListEntry () const
INT | GetNoOfApplications () const
void | RemoveApplication (const Application *app)
virtual | ~AppContainerRoutingTableEntry ()

Constructor & Destructor Documentation

AppContainerRoutingTableEntry::AppContainerRoutingTableEntry ( const HashKey hash_key )

AppContainerRoutingTableEntry::~AppContainerRoutingTableEntry ( ) [virtual]

Member Function Documentation

void AppContainerRoutingTableEntry::AddApplication ( Application * app )

ApplicationListEntry* AppContainerRoutingTableEntry::GetFirstApplicationListEntry ( ) const [inline]

INT AppContainerRoutingTableEntry::GetNoOfApplications ( ) const [inline]

void AppContainerRoutingTableEntry::RemoveApplication ( const Application * app )

The documentation for this class was generated from the following files:
  • Kernel/AppContainerRoutingTable.hpp
  • Kernel/AppContainerRoutingTable.cpp
Generated on Wed Jan 25 00:55:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppContext Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/Nuc32/Scheduler.hpp>

Inheritance diagram for AppContext:

[legend]
Collaboration diagram for AppContext:

[legend]

Public Types

typedef AbstractAppContext | Base
typedef AbstractAppContext | Base

Public Member Functions

AppContext (Scheduler *scheduler, Application *app)
AppContext (Scheduler *scheduler, Application *app)
StackAtom * GetAppStackBase ()
Returns AppContext's stack base.
UINT32 | GetAppStackSize ()
Returns AppContext's stack size.
virtual void | MsgLoop ()
virtual void | MsgLoop ()
virtual void | SendMsg (Message &msg)
virtual void | SendMsg (Message &msg)
virtual void | StartUp ()
virtual void | StartUp ()
virtual void | Wait (const Condition &cond)
virtual void | Wait (const Condition &cond)
virtual | ~AppContext ()
virtual | ~AppContext ()
Destroyes the AppContext.

Detailed Description

AppContext (Nucleus) goes hand in hand with Scheduler (Nucleus). It takes control from the Scheduler and starts its own context with the attached Application. Each AppContext has its own Stack as a member variable, m_stack, which is used by the attached Application. All the context information including the Stack pointer to the m_stack is kept within a JmpBuf. So when context switch happens, the Stack pointer to m_stack is retrived from the jump buffer and that m_stack is used by the application for its local data storage. The AppContext also contains a pointer to the current Message, which is then passed to the attached Application on context switch.

Member Typedef Documentation

typedef AbstractAppContext AppContext::Base

Reimplemented from Linkable< AbstractAppContext >.

typedef AbstractAppContext AppContext::Base

Reimplemented from Linkable< AbstractAppContext >.

Constructor & Destructor Documentation

AppContext::AppContext | ( | Scheduler * | scheduler,
 |  | Application * | app
 | ) |

Creates a AppContext (Nucleus)

Parameters:
scheduler | pointer to the Scheduler (Nucleus) that runs the AppContext
app | pointer to the Application that will be attached

AppContext::~AppContext ( ) [virtual]

Destroyes the AppContext.

AppContext::AppContext | ( | Scheduler * | scheduler,
 |  | Application * | app
 | ) |

Creates a AppContext

Parameters:
scheduler | pointer to the Scheduler that runs the AppContext
app | pointer to the Application that will be attached

virtual AppContext::~AppContext ( ) [virtual]

Member Function Documentation

StackAtom * AppContext::GetAppStackBase ( )

Returns AppContext's stack base.

UINT32 AppContext::GetAppStackSize ( )

Returns AppContext's stack size.

virtual void AppContext::MsgLoop ( ) [virtual]

Wakes up on Messages and sends them to the attached Application.

Implements AbstractAppContext.

void AppContext::MsgLoop ( ) [virtual]

Wakes up on Messages and sends them to the attached Application by calling SendSelf. After processing the Message, it saves the context and switches back to Scheduler's context.

Implements AbstractAppContext.

virtual void AppContext::SendMsg ( Message & msg ) [virtual]

Wakes up and sends a message to the attached Application.

Parameters:
msg a reference to the Message to be sent

Implements AbstractAppContext.

void AppContext::SendMsg ( Message & msg ) [virtual]

Wakes up on context switching and sends a message to the attached Application.

Parameters:
msg a reference to the Message to be sent

Implements AbstractAppContext.

virtual void AppContext::StartUp ( ) [virtual]

Sets up the AppContext for the attached Application and enters MsgLoop.

Reimplemented from AbstractAppContext.

void AppContext::StartUp ( ) [virtual]

Starts up the AppContext for the attached Application and goes back to Scheduler's context. Next time it gets back the context it enters into MsgLoop.

Reimplemented from AbstractAppContext.

virtual void AppContext::Wait ( const Condition & cond ) [virtual]

Stops program flow and waits for the Condition to become TRUE. Incoming Messages will continue to trigger Applications.

Parameters:
cond a reference to the Condition to wait for

Implements AbstractAppContext.

void AppContext::Wait ( const Condition & cond ) [virtual]

Stops program flow and saves the state and waits in a loop for the Condition to become TRUE. Once the condition becomes true, it will process the incoming Messages.

Parameters:
cond a reference to the Condition to wait for

Implements AbstractAppContext.

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/Scheduler.hpp
  • Kernel/Os/Win32/Scheduler.hpp
  • Kernel/Os/Nuc32/Scheduler.cpp
  • Kernel/Os/Win32/Scheduler.cpp
Generated on Wed Jan 25 00:55:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppendProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppendProvider Class Reference
[AuxExtensions]

#include <Apoxi/AddOns/AuxExtensions/AppendProvider.hpp>

Inheritance diagram for AppendProvider:

[legend]
Collaboration diagram for AppendProvider:

[legend]

Public Member Functions

virtual BOOLEAN | AddChildProvider (Provider *provider)
em>RemoveChildProvider from the Vector<Provider*> of the AppendProvider
AppendProvider ()
Constructor.
virtual BOOLEAN | AppendRow ()
em>DeleteAllRows of the AppendProvider
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
em>AddChildProvider to the Vector<Provider*> of the AppendProvider
virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
em>GetChildRow returns GetMappedRow
virtual INT | GetProgress ()
GetProgress of the ProviderListener
virtual INT | GetProviderId () const
Returns the ProviderId.
virtual INT | GetSortedColumnId () const
void | Init ()
virtual BOOLEAN | Lock ()
Lock locks the child-provider.
virtual INT | MaxRowCount ()
Returns the RowCount of the AppendProvider.
virtual void | OnExecutingListener (Provider *provider=0)
virtual BOOLEAN | RemoveChildProvider (Provider *provider)
virtual INT | RowCount ()
Returns the RowCount of the AppendProvider.
virtual BOOLEAN | SetParameter (const DataItem &item)
void | SetProviderId (INT provider_id)
SetProviderId of AppendProvider.
virtual BOOLEAN | Unlock ()
Unlock unlocks the child-provider.
virtual BOOLEAN | Update (ProviderListener *listener=0)
virtual | ~AppendProvider ()
Destructor.

Protected Member Functions

virtual BOOLEAN | GetMappedRow (INT &mappedrow, INT row)
virtual void | OnChildProviderModification (Provider *provider, const Provider::Modification &modification)

Detailed Description

A AppendProvider provides a view over all registered Provider. This requires that all child provider have the same structure. Therefore the UIB provides a special Provider interface. The AppendProvider puts a new index over all rows. Data modifications and read of data happens in the child provider, the AppendProvider knows the child-provider and can determine the mapped row in the child-provider.

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/AppendProvider.hpp
  • AddOns/AuxExtensions/AppendProvider.cpp
Generated on Wed Jan 25 00:55:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppFeatureID Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppFeatureID Struct Reference

#include <Apoxi/Atl/Features/AppFeatureID.hpp>

Collaboration diagram for AppFeatureID:

[legend]

Public Member Functions

AppFeatureID (const CHAR *app_id, const CHAR *feature_id)
AppFeatureID (ApplicationID app_id, FeatureID feature_id)
AppFeatureID ()

Data Fields

ApplicationID m_app_id
FeatureID m_feature_id

Constructor & Destructor Documentation

AppFeatureID::AppFeatureID ( )

AppFeatureID::AppFeatureID | ( | ApplicationID | app_id,
 |  | FeatureID | feature_id
 | ) |

AppFeatureID::AppFeatureID | ( | const CHAR * | app_id,
 |  | const CHAR * | feature_id
 | ) | [explicit]

Field Documentation

ApplicationID AppFeatureID::m_app_id

FeatureID AppFeatureID::m_feature_id

The documentation for this struct was generated from the following files:
  • Atl/Features/AppFeatureID.hpp
  • Atl/Features/AppFeatureID.cpp
Generated on Wed Jan 25 00:55:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppGetFocusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppGetFocusMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for AppGetFocusMsg:

[legend]
Collaboration diagram for AppGetFocusMsg:

[legend]

Public Types

enum | { ID = 105 }

Public Member Functions

AppGetFocusMsg (ExecutionContext *context)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AppGetFocusMsg ()

Detailed Description

This message will be sent to the application when it gets the focus

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AppGetFocusMsg::AppGetFocusMsg ( ExecutionContext * context )

AppGetFocusMsg::~AppGetFocusMsg ( ) [virtual]

Member Function Documentation

Message * AppGetFocusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AppGetFocusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 00:55:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Application Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Application Class Reference
[Kernel]

#include <Apoxi/Kernel/Application.hpp>

Inheritance diagram for Application:

[legend]
Collaboration diagram for Application:

[legend]

Public Member Functions

void | AddWindow (Window *win)
Application (const WCHAR *app_name, UINT stacksize=0)
BOOLEAN | ContainsWindow (const Window *win) const
BOOLEAN | DoesSynchronousDrawing () const
AppContainer * | GetAppContainer () const
const WCHAR * | GetAppName () const
Obsolete - use Application::GetName instead.
Window * | GetFirstWindow () const
Window * | GetFocusedWindow () const
Window * | GetForegroundWindow (INT display_idx=0) const
Obsolete - use Application::GetFocusedWindow or Application::GetFirstWindow instead.
const WCHAR * | GetName () const
Panel * | GetPanel () const
INT | GetPriority () const
UINT | GetRequestedStackSize () const
virtual Type | GetType () const
void | GrabFocus (BOOLEAN assign_to_win)
Obsolete - the parameter assign_to_win is ignored. Use Application::GrabFocus() instead.
BOOLEAN | GrabFocus ()
BOOLEAN | HasFocus () const
BOOLEAN | IsRunning () const
BOOLEAN | IsShutdownAllowed () const
void | Post (const Message &msg) const
virtual void | RegisterMessage (MsgId msg_id)
void | RemoveWindow (Window *win)
void | SetAppContainer (AppContainer *app_container)
void | SetAppName (const WCHAR *app_name)
Obsolete - use Application::SetName instead.
void | SetName (const WCHAR *name)
void | SetPriority (INT priority)
void | SetShutdownAllowed (BOOLEAN shutdown_allowed)
void | TransferFocus ()
Obsolete - use Application::GrabFocus instead to move the focus.
virtual void | UnregisterMessage (MsgId msg_id)
void | UpdateDisplay (INT display_idx=0)
virtual | ~Application ()

Protected Member Functions

virtual BOOLEAN | AcceptMsg (const Message &msg)
virtual void | AddTimer (Timer &timer)
virtual Panel * | CreatePanel () const
virtual void | DestroyPanel (Panel *panel) const
virtual BOOLEAN | HandleMsg (const MessageReferrer &msg_ref)
virtual void | OnClose ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyAutoRepeat (KeyCode key_code)
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual BOOLEAN | OnKeyUp (KeyCode key_code, UINT32 duration)
virtual void | OnLanguageChanged ()
virtual BOOLEAN | OnLockedKeyDown (KeyCode key_code)
virtual BOOLEAN | OnLongKeyPress (KeyCode key_code)
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual BOOLEAN | OnShutdownRequest ()
virtual void | OnStartup ()
virtual void | OnThemeChanged ()
virtual BOOLEAN | OnTimeout (const Timer &timer)
virtual BOOLEAN | OnVeryLongKeyPress (KeyCode key_code)
virtual void | RemoveTimer (Timer &timer)
virtual BOOLEAN | RouteMessage (const Message &msg)
void | SetRequestedStackSize (UINT size)

Friends

class | AppContainer
void | Control::AbsInvalidate (Control *control, const Rect &abs_inv_rect, BOOLEAN erase)
void | Control::PutToForeground ()
void | DeviceContext::EndUpdate ()
void | StartUp::Restart (const StartUp::Data &startup_data)

Detailed Description

An Application is the central instance for handling and routing messages. All incoming messages are treated in OnMessage and routed to user-dispatchers and windows. Every application is part of an application-container and can have one or more windows. To extend the handling and routing of messages in an easy manner it is possible to add user-defined dispatchers to an application.

Constructor & Destructor Documentation

Application::Application | ( | const WCHAR * | app_name,
 |  | UINT | stacksize = 0
 | ) |

Parameters:
app_name | Pointer to the name of the Application.
stacksize | Stack size for the application in Bytes.

Application::~Application ( ) [virtual]

Member Function Documentation

BOOLEAN Application::AcceptMsg ( const Message & msg ) [protected, virtual]

Tells if msg is accepted.

Implements ExecutionContext.

void Application::AddTimer ( Timer & timer ) [protected, virtual]

Adds the timer to the context.

Implements ExecutionContext.

void Application::AddWindow ( Window * win )

Adds a window to the application. It should not be necessary to invoke this method, as it is invoked automatically when opening a window.

BOOLEAN Application::ContainsWindow ( const Window * win ) const

Panel * Application::CreatePanel ( ) const [protected, virtual]

Factory method for creating a panel. Per default an instance of the class Panel is allocated dynamically and returned.

void Application::DestroyPanel ( Panel * panel ) const [protected, virtual]

Counterpart to Application::CreatePanel. Per default the panel will be destroyed by invoking 'delete'.

BOOLEAN Application::DoesSynchronousDrawing ( ) const [inline]

Returns:
TRUE if the application currently does a synchronous update of its windows.

AppContainer* Application::GetAppContainer ( ) const [inline]

const WCHAR* Application::GetAppName ( ) const [inline]

Obsolete - use Application::GetName instead.

Window* Application::GetFirstWindow ( ) const [inline]

Returns a pointer to the first window of the application. The next window can be retrieved by invoking Application::GetNext().

Window * Application::GetFocusedWindow ( ) const

Returns a pointer to the focused window of the application. 0 is returned, if no window has the focus.

Window * Application::GetForegroundWindow ( INT display_idx = 0 ) const

Obsolete - use Application::GetFocusedWindow or Application::GetFirstWindow instead.

const WCHAR* Application::GetName ( ) const [inline]

Panel * Application::GetPanel ( ) const

Returns the panel of the application. Per default each application has one instance of a panel, which is responsible for displaying the state of currently focused windows. See also Application::CreatePanel.

INT Application::GetPriority ( ) const

Obsolete - the priority is treated on window-level now. See Window::SetFocusPriority and Window::GetFocusPriority for details.

UINT Application::GetRequestedStackSize ( ) const [inline]

ExecutionContext::Type Application::GetType ( ) const [virtual]

Returns:
Type of ExectionContext.

Implements ExecutionContext.

void Application::GrabFocus ( BOOLEAN assign_to_win )

Obsolete - the parameter assign_to_win is ignored. Use Application::GrabFocus() instead.

BOOLEAN Application::GrabFocus ( )

Tries to grab the focus for the application.

Returns:
TRUE is returned, if the application will get the focus. Note that the focus will be assigned asynchronously and is not assigned immediatly after invoking Application::GrabFocus. See also Application::OnGetFocus for details. FALSE is returned, if an application with a higher focus-priority has the focus.

BOOLEAN Application::HandleMsg ( const MessageReferrer & msg_ref ) [protected, virtual]

Handles the message which the message referrer msg_ref points to.

Implements ExecutionContext.

BOOLEAN Application::HasFocus ( ) const

Returns TRUE if the application currently has the focus. Only one application can have the focus. Note that TRUE does not necessarily mean that Application::OnGetFocus has already been invoked, as the message routing is done asynchronously. But it is assured that if an application is marked as focused the method Application::OnGetFocus will be invoked later.

BOOLEAN Application::IsRunning ( ) const [inline]

Returns:
TRUE if the application is attached to an application_container and is up running.

BOOLEAN Application::IsShutdownAllowed ( ) const [inline]

void Application::OnClose ( ) [protected, virtual]

Is called, if the application is closed.

Reimplemented in AtlApplication, and GltpConnApp.

void Application::OnGetFocus ( ) [protected, virtual]

Is called, if the application gets the focus

BOOLEAN Application::OnKeyAutoRepeat ( KeyCode key_code ) [protected, virtual]

BOOLEAN Application::OnKeyDown ( KeyCode key_code ) [protected, virtual]

Is called, if a key has been pressed and is still holded. The code of the key is given by key_code.

BOOLEAN Application::OnKeyUp | ( | KeyCode | key_code,
 |  | UINT32 | duration
 | ) | [protected, virtual]

Is called, if a key has been released. The code of the key is given by key_code.

void Application::OnLanguageChanged ( ) [protected, virtual]

Is called, if the language has been changed.

BOOLEAN Application::OnLockedKeyDown ( KeyCode key_code ) [protected, virtual]

Is called, if the keyboard is locked and a key has been pressed.

BOOLEAN Application::OnLongKeyPress ( KeyCode key_code ) [protected, virtual]

Is called, if a key has been pressed and the duration exceeded the long-key-press limit. The code of the key is given by key_code.

void Application::OnLoseFocus ( ) [protected, virtual]

Is called, if the application loses the focus

BOOLEAN Application::OnMessage ( const Message & msg ) [protected, virtual]

Every message send to an application may be dispatched in OnMessage.

See also:
Dispatcher::OnMessage

Implements Dispatcher.

Reimplemented in AtlApplication, and GltpConnApp.

void Application::OnOpen ( ) [protected, virtual]

Is called after the default initialization process.

Reimplemented in AtlApplication, and GltpConnApp.

BOOLEAN Application::OnShutdownRequest ( ) [protected, virtual]

Is invoked when the system wants to shutdown, but the application wants to block the shutdown (see SetShutdownAllowed() and IsShutdownAllowed for details). The standard implementation of that method returns FALSE to prevent a shutting down. This method maybe overwritten to e. g. open a modal window to ask "Do you really want to shutdown?".

Returns:
TRUE continues the shutdown, FALSE blocks the shutdown.

void Application::OnStartup ( ) [protected, virtual]

Is called after attaching the application to an AppContainer for pre-start initialization.

Reimplemented in AtlApplication, and GltpConnApp.

void Application::OnThemeChanged ( ) [protected, virtual]

Is called, if the theme has been changed.

BOOLEAN Application::OnTimeout ( const Timer & timer ) [protected, virtual]

Is called, if a timer expires.

BOOLEAN Application::OnVeryLongKeyPress ( KeyCode key_code ) [protected, virtual]

Is called, if a key has been pressed and the duration exceeded the very-long-key-press limit. The code of the key is given by key_code.

void Application::Post ( const Message & msg ) const

Posts the message msg asynchronous to the message-router-queue, which will broadcast the message to all applications, which have subscribed for this message.

void Application::RegisterMessage ( MsgId msg_id ) [virtual]

Registers a message to the ExecutionContext. Only registered messages are accepted and handled.

Implements ExecutionContext.

void Application::RemoveTimer ( Timer & timer ) [protected, virtual]

Removes the timer from the context.

Implements ExecutionContext.

void Application::RemoveWindow ( Window * win )

Removes a window from the application. It should not be necessary to invoke this method, as it is invoked automatically when closing a window.

BOOLEAN Application::RouteMessage ( const Message & msg ) [protected, virtual]

Routing messages on application level is working the following way:

  • First of all Application::OnMessage is called.
  • Afterwards the message is routed to all attached UserDispatchers.
  • Messages of class MC_FOCUS are routed to the focused Window.
  • Messages of class MC_CONTROL are routed to the specific Control.
  • All other messages are routed to all Windows of the Application.
  • At the end the base class Application itself handles the message and triggers the calls of the OnX methods (e.g. KeyDownMsg -> OnKeyDown). This sequence will be interrupted immediately if any of the involved methods is returning TRUE.

Reimplemented from Dispatcher.

Reimplemented in AtlApplication.

void Application::SetAppContainer ( AppContainer * app_container )

void Application::SetAppName ( const WCHAR * app_name ) [inline]

Obsolete - use Application::SetName instead.

void Application::SetName ( const WCHAR * name ) [inline]

void Application::SetPriority ( INT priority )

Obsolete - the priority is treated on window-level now. See Window::SetFocusPriority and Window::GetFocusPriority for details.

void Application::SetRequestedStackSize ( UINT size ) [protected]

void Application::SetShutdownAllowed ( BOOLEAN shutdown_allowed ) [inline]

Parameters:
shutdown_allowed TRUE allows a shutdown, FALSE blocks a shutdown (in this case, the system sends out the message ShutdownRequestMsg).
See also:
Application::OnShutdownRequest

void Application::TransferFocus ( )

Obsolete - use Application::GrabFocus instead to move the focus.

void Application::UnregisterMessage ( MsgId msg_id ) [virtual]

Unregisters a message from the ExecutionContext. Messages with ID msg_id are no more accepted.

Implements ExecutionContext.

void Application::UpdateDisplay ( INT display_idx = 0 )

Friends And Related Function Documentation

friend class AppContainer [friend]

void Control::AbsInvalidate | ( | Control * | control,
 |  | const Rect & | abs_inv_rect,
 |  | BOOLEAN | erase
 | ) | [friend]

void Control::PutToForeground ( ) [friend]

void DeviceContext::EndUpdate ( ) [friend]

void StartUp::Restart ( const StartUp::Data & startup_data ) [friend]

The documentation for this class was generated from the following files:
  • Kernel/Application.hpp
  • Kernel/Application.cpp
Generated on Wed Jan 25 00:55:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ApplicationAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ApplicationAction Class Reference
[GUI Menu Accessors]

#include <Apoxi/AddOns/GuiMenuAccessors/ApplicationAction.hpp>

Inheritance diagram for ApplicationAction:

[legend]
Collaboration diagram for ApplicationAction:

[legend]

Public Member Functions

ApplicationAction (Dispatcher *dispatcher, Application *app, const WCHAR *text, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
ApplicationAction ()
virtual BOOLEAN | Execute ()
Application * GetApplication ()
void | Init (Dispatcher *dispatcher, Application *app, const WCHAR *text, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
virtual | ~ApplicationAction ()

Detailed Description

Obsolete - the class Menu, which might use the ApplicationAction, has been replaced by the classes ItemMenu and ItemTree.

Informs a variable application, when the action has been executed by sending the message AppActionExecutedMsg asynchronously. Usually when an action has been executed, the message ActionExecutedMsg is send synchronously to the dispatcher of the action. But when embedding an action of one application into a menu of another application, a synchronous call is not allowed between applications, because each application may be represented by its own thread.

Constructor & Destructor Documentation

ApplicationAction::ApplicationAction ( )

ApplicationAction::ApplicationAction | ( | Dispatcher * | dispatcher,
 |  | Application * | app,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

ApplicationAction::~ApplicationAction ( ) [virtual]

Member Function Documentation

BOOLEAN ApplicationAction::Execute ( ) [virtual]

Sends the message AppActionExecutedMsg asynchronously to the application specified in the constructor. Note that the base-implementation, which sends the message ActionExecutedMsg to the dispatcher, is invoked too.

See also:
Action::Execute

Reimplemented from Action.

Application* ApplicationAction::GetApplication ( ) [inline]

void ApplicationAction::Init | ( | Dispatcher * | dispatcher,
 |  | Application * | app,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/GuiMenuAccessors/ApplicationAction.hpp
  • AddOns/GuiMenuAccessors/ApplicationAction.cpp
Generated on Wed Jan 25 00:55:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ApplicationListEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ApplicationListEntry Class Reference
[Kernel]

#include <Apoxi/Kernel/AppContainerRoutingTable.hpp>

Inheritance diagram for ApplicationListEntry:

[legend]
Collaboration diagram for ApplicationListEntry:

[legend]

Public Member Functions

ApplicationListEntry (Application *app)
void | DecrementRegCount ()
Application * | GetApplication () const
void | IncrementRegCount ()
BOOLEAN | IsEmpty ()
BOOLEAN | operator== (const ApplicationListEntry &app_list_entry) const

Constructor & Destructor Documentation

ApplicationListEntry::ApplicationListEntry ( Application * app ) [inline]

Member Function Documentation

void ApplicationListEntry::DecrementRegCount ( ) [inline]

Application* ApplicationListEntry::GetApplication ( ) const [inline]

void ApplicationListEntry::IncrementRegCount ( ) [inline]

BOOLEAN ApplicationListEntry::IsEmpty ( ) [inline]

BOOLEAN ApplicationListEntry::operator== ( const ApplicationListEntry & app_list_entry ) const [inline]

The documentation for this class was generated from the following file:
  • Kernel/AppContainerRoutingTable.hpp
Generated on Wed Jan 25 00:55:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppLoseFocusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppLoseFocusMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for AppLoseFocusMsg:

[legend]
Collaboration diagram for AppLoseFocusMsg:

[legend]

Public Types

enum | { ID = 106 }

Public Member Functions

AppLoseFocusMsg (ExecutionContext *context)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AppLoseFocusMsg ()

Detailed Description

This message will be sent to the application when it loses the focus

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AppLoseFocusMsg::AppLoseFocusMsg ( ExecutionContext * context )

AppLoseFocusMsg::~AppLoseFocusMsg ( ) [virtual]

Member Function Documentation

Message * AppLoseFocusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AppLoseFocusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 00:55:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppMutex Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppMutex Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/AppMutex.hpp>

Inheritance diagram for AppMutex:

[legend]
Collaboration diagram for AppMutex:

[legend]

Public Member Functions

AppMutex ()
BOOLEAN | Create (BOOLEAN locked=TRUE)
BOOLEAN | Obtain (const Ticks &timeout=Ticks::Infinite())
void | Release ()
virtual | ~AppMutex ()

Data Structures

class | CondListEntry

Detailed Description

AppMutex ensures exclusive access on Application level. When two or more applications need to access a shared resource at the same time, synchronization is a coordination process to ensure that the resource is used by only one Application at a time. This can happen if inside a code section which should be protected by mutual exlusion the application is pending in an active wait (AppContainer::Wait). Then a Mutex can not block another Application which runs in the same AppContainer context - so an AppMutex has to be used.

Constructor & Destructor Documentation

AppMutex::AppMutex ( )

AppMutex::~AppMutex ( ) [virtual]

Member Function Documentation

BOOLEAN AppMutex::Create ( BOOLEAN locked = TRUE )

See also:
Mutex::Create

BOOLEAN AppMutex::Obtain ( const Ticks & timeout = Ticks::Infinite() )

See also:
Mutex::Obtain

void AppMutex::Release ( )

See also:
Mutex::Release

The documentation for this class was generated from the following files:
  • Kernel/Os/AppMutex.hpp
  • Kernel/Os/AppMutex.cpp
Generated on Wed Jan 25 00:55:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppOpenMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppOpenMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for AppOpenMsg:

[legend]
Collaboration diagram for AppOpenMsg:

[legend]

Public Types

enum | { ID = 100 }

Public Member Functions

AppOpenMsg ()
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AppOpenMsg ()

Detailed Description

This message is sent upon application startup. No arguments.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AppOpenMsg::AppOpenMsg ( )

AppOpenMsg::~AppOpenMsg ( ) [virtual]

Member Function Documentation

Message * AppOpenMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AppOpenMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 00:55:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppRoutingTableEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppRoutingTableEntry Class Reference
[Kernel]

#include <Apoxi/Kernel/AppRoutingTable.hpp>

Inheritance diagram for AppRoutingTableEntry:

[legend]
Collaboration diagram for AppRoutingTableEntry:

[legend]

Public Member Functions

void | AddDispatcherAction (DispatcherAction *app_entry)
AppRoutingTableEntry (const MsgId msg_id)
const DispatcherActionList * | GetDispatcherActionList () const
const MsgId | GetMsgId () const

Constructor & Destructor Documentation

AppRoutingTableEntry::AppRoutingTableEntry ( const MsgId msg_id ) [inline]

Member Function Documentation

void AppRoutingTableEntry::AddDispatcherAction ( DispatcherAction * app_entry ) [inline]

const DispatcherActionList* AppRoutingTableEntry::GetDispatcherActionList ( ) const [inline]

const MsgId AppRoutingTableEntry::GetMsgId ( ) const [inline]

The documentation for this class was generated from the following file:
  • Kernel/AppRoutingTable.hpp
Generated on Wed Jan 25 00:55:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AppUpdateDisplayMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AppUpdateDisplayMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for AppUpdateDisplayMsg:

[legend]
Collaboration diagram for AppUpdateDisplayMsg:

[legend]

Public Types

enum | { ID = 107 }

Public Member Functions

AppUpdateDisplayMsg ()
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AppUpdateDisplayMsg ()

Detailed Description

This message is tells an application to update its display data. No arguments.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AppUpdateDisplayMsg::AppUpdateDisplayMsg ( )

AppUpdateDisplayMsg::~AppUpdateDisplayMsg ( ) [virtual]

Member Function Documentation

Message * AppUpdateDisplayMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AppUpdateDisplayMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 00:55:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ArabicTextRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ArabicTextRenderer Class Reference
[GUI]

#include <Apoxi/Gui/ArabicTextRenderer.hpp>

Inheritance diagram for ArabicTextRenderer:

[legend]
Collaboration diagram for ArabicTextRenderer:

[legend]

Public Member Functions

virtual XYDIM | DrawText (DeviceContext *dc, const Rect &clip_rect, XYDIM x, XYDIM y, const WCHAR *text, INT from, INT char_count)
virtual INT | GetTextWidth (const WCHAR *text, const Font &font, TextAttr text_attr, INT from, INT char_count, BOOLEAN include_gap=FALSE)
virtual INT | WrapLine (const WCHAR *text, const Font &font, TextAttr text_attr, INT char_count, XYDIM max_width=-1, WrapPolicy policy=(WrapPolicy) 0, BOOLEAN include_gap_at_end=FALSE, Size *total_size=0, INT *ws_at_eol_count=0, XYDIM *ws_at_eol_width=0, INT *last_whitespace_index=0)
virtual | ~ArabicTextRenderer ()

Static Public Member Functions

static ArabicTextRenderer & | GetInstance ()
Returns the instance of the Arabic text renderer.

Protected Member Functions

ArabicTextRenderer ()
virtual Size | GetGlyph (const WCHAR *cur_text_pos, const WCHAR *substitution_char, INT n_chars, GlyphPtr glyph, INT &parsed_glyphs, BOOLEAN &is_diacritic)

Detailed Description

Text renderer for Arabic text.

Constructor & Destructor Documentation

ArabicTextRenderer::~ArabicTextRenderer ( ) [virtual]

ArabicTextRenderer::ArabicTextRenderer ( ) [protected]

Member Function Documentation

XYDIM ArabicTextRenderer::DrawText | ( | DeviceContext * | dc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | const WCHAR * | text,
 |  | INT | from,
 |  | INT | char_count
 | ) | [virtual]

Text that is passed to DrawText must be bidi-fied, i.e. the BidiManager must already have processed the text.

For more information,

See also:
AbstractTextRenderer::DrawText.

Reimplemented from AbstractTextRenderer.

Size ArabicTextRenderer::GetGlyph | ( | const WCHAR * | cur_text_pos,
 |  | const WCHAR * | substitution_char,
 |  | INT | n_chars,
 |  | GlyphPtr | glyph,
 |  | INT & | parsed_glyphs,
 |  | BOOLEAN & | is_diacritic
 | ) | [protected, virtual]

Rules for determining which character to choose (inital, medial, final, isolated) have been taken from http://acl.ldc.upenn.edu/W/W98/W98-1004.pdf

Implements AbstractTextRenderer.

ArabicTextRenderer & ArabicTextRenderer::GetInstance ( ) [static]

Returns the instance of the Arabic text renderer.

INT ArabicTextRenderer::GetTextWidth | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | from,
 |  | INT | char_count,
 |  | BOOLEAN | include_gap = FALSE
 | ) | [virtual]

Text that is passed to GetTextWidth must be bidi-fied, i.e. the BidiManager must already have processed the text.

For more information,

See also:
AbstractTextRenderer::GetTextWidth.

Reimplemented from AbstractTextRenderer.

INT ArabicTextRenderer::WrapLine | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | char_count,
 |  | XYDIM | max_width = -1,
 |  | WrapPolicy | policy = (WrapPolicy) 0,
 |  | BOOLEAN | include_gap_at_end = FALSE,
 |  | Size * | total_size = 0,
 |  | INT * | ws_at_eol_count = 0,
 |  | XYDIM * | ws_at_eol_width = 0,
 |  | INT * | last_whitespace_index = 0
 | ) | [virtual]

Text that is passed to WrapLine MUST NOT be bidi-fied, i.e. the text must be passed to WrapLine in its original order!

For more information,

See also:
AbstractTextRenderer::WrapLine.

Reimplemented from AbstractTextRenderer.

The documentation for this class was generated from the following files:
  • Gui/ArabicTextRenderer.hpp
  • Gui/ArabicTextRenderer.cpp
Generated on Wed Jan 25 00:55:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AragonMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AragonMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for AragonMsg:

[legend]
Collaboration diagram for AragonMsg:

[legend]

Public Types

enum | { ID = 1125 }

Public Member Functions

AragonMsg (UINT32 command, BinData *data)
virtual Message * | Clone () const
UINT32 | GetCommand () const
BinData * | GetData () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AragonMsg ()

Detailed Description

This message is send by the ARAGON tool server.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AragonMsg::AragonMsg | ( | UINT32 | command,
 |  | BinData * | data
 | ) |

AragonMsg::~AragonMsg ( ) [virtual]

Member Function Documentation

Message * AragonMsg::Clone ( ) const [virtual]

Implements Message.

UINT32 AragonMsg::GetCommand ( ) const [inline]

BinData* AragonMsg::GetData ( ) const [inline]

const MsgMetaData & AragonMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 00:55:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ArgumentDestroyEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ArgumentDestroyEntry Struct Reference

#include <Apoxi/Apc/StackMsgArgument.hpp>

Data Fields

void(* destroy_func )(StackMsgArgument *arg)
StackMsgArgId id

Field Documentation

void(* ArgumentDestroyEntry::destroy_func)(StackMsgArgument *arg)

StackMsgArgId ArgumentDestroyEntry::id

The documentation for this struct was generated from the following file:
  • Apc/StackMsgArgument.hpp
Generated on Wed Jan 25 00:55:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ArgumentDestroyEntryCompare Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ArgumentDestroyEntryCompare Struct Reference

#include <Apoxi/Apc/StackMsgArgument.hpp>

Public Member Functions

INT Compare (StackMsgArgId id, const ArgumentDestroyEntry &entry) const

Member Function Documentation

INT ArgumentDestroyEntryCompare::Compare | ( | StackMsgArgId | id,
 |  | const ArgumentDestroyEntry & | entry
 | ) | const [inline]

The documentation for this struct was generated from the following file:
  • Apc/StackMsgArgument.hpp
Generated on Wed Jan 25 00:55:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AsTestparamDatabase Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AsTestparamDatabase Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for AsTestparamDatabase:

[legend]

Public Member Functions

AsTestparamDatabase | operator= (T_AS_TESTPARAM_DATABASE as_testparam_database)

Data Fields

UINT8 | as_error_code
CellChangeCnts cell_change_ind
MmRrReason chn_rel_cause
BOOLEAN | cipher_on
BOOLEAN | limited_service
BOOLEAN | out_of_service
PowerSavingMode power_saving_mode
BOOLEAN | ps_transfer
BOOLEAN | reset_em
RrcProcessState rrcbp_state
RrcProcessState rrcdc_state
RrcProcessState rrcm_state
UINT8 | ul_meas_cnt

Member Function Documentation

AsTestparamDatabase AsTestparamDatabase::operator= ( T_AS_TESTPARAM_DATABASE as_testparam_database )

Field Documentation

UINT8 AsTestparamDatabase::as_error_code

CellChangeCnts AsTestparamDatabase::cell_change_ind

MmRrReason AsTestparamDatabase::chn_rel_cause

BOOLEAN AsTestparamDatabase::cipher_on

BOOLEAN AsTestparamDatabase::limited_service

BOOLEAN AsTestparamDatabase::out_of_service

PowerSavingMode AsTestparamDatabase::power_saving_mode

BOOLEAN AsTestparamDatabase::ps_transfer

BOOLEAN AsTestparamDatabase::reset_em

RrcProcessState AsTestparamDatabase::rrcbp_state

RrcProcessState AsTestparamDatabase::rrcdc_state

RrcProcessState AsTestparamDatabase::rrcm_state

UINT8 AsTestparamDatabase::ul_meas_cnt

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 00:55:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AsyncUnitTestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AsyncUnitTestMsg Class Reference

#include <Apoxi/UnitTest/MsgTypes.hpp>

Inheritance diagram for AsyncUnitTestMsg:

[legend]
Collaboration diagram for AsyncUnitTestMsg:

[legend]

Public Types

enum | { ID = 19300 }

Public Member Functions

AsyncUnitTestMsg (Application *application, const WString &MessageText)
virtual Message * | Clone () const
const WString & | GetMessageText () const
virtual const MsgMetaData & | GetMetaData () const
void | SetMessageText (const WString &MessageText)
virtual | ~AsyncUnitTestMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AsyncUnitTestMsg::AsyncUnitTestMsg | ( | Application * | application,
 |  | const WString & | MessageText
 | ) |

AsyncUnitTestMsg::~AsyncUnitTestMsg ( ) [virtual]

Member Function Documentation

Message * AsyncUnitTestMsg::Clone ( ) const [virtual]

Implements Message.

const WString& AsyncUnitTestMsg::GetMessageText ( ) const [inline]

const MsgMetaData & AsyncUnitTestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void AsyncUnitTestMsg::SetMessageText ( const WString & MessageText ) [inline]

The documentation for this class was generated from the following files:
  • UnitTest/MsgTypes.hpp
  • UnitTest/MsgTypes.cpp
Generated on Wed Jan 25 00:55:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtAccessoryNotificationIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtAccessoryNotificationIndArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtAccessoryNotificationIndArg:

[legend]
Collaboration diagram for AtAccessoryNotificationIndArg:

[legend]

Public Types

enum | { ID = 2155 }

Public Member Functions

AtAccessoryNotificationIndArg ()
AtAccessoryNotificationIndArg (const AtGenericCmdType &cmd)
const AtGenericCmdType & | GetCmd () const
void | SetCmd (const AtGenericCmdType &cmd)

Static Public Member Functions

static const AtAccessoryNotificationIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtAccessoryNotificationIndArg: reflects arguments of signal MIAT_ACC_NOTIFICATION_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtAccessoryNotificationIndArg::AtAccessoryNotificationIndArg ( const AtGenericCmdType & cmd )

AtAccessoryNotificationIndArg::AtAccessoryNotificationIndArg ( )

Member Function Documentation

const AtAccessoryNotificationIndArg & AtAccessoryNotificationIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const AtGenericCmdType& AtAccessoryNotificationIndArg::GetCmd ( ) const [inline]

void AtAccessoryNotificationIndArg::SetCmd ( const AtGenericCmdType & cmd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:55:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtAccessoryRegisterCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtAccessoryRegisterCnfArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtAccessoryRegisterCnfArg:

[legend]
Collaboration diagram for AtAccessoryRegisterCnfArg:

[legend]

Public Types

enum | { ID = 2156 }

Public Member Functions

AtAccessoryRegisterCnfArg ()
AtAccessoryRegisterCnfArg (const AtStatusType &status)
const AtStatusType & | GetStatus () const
void | SetStatus (const AtStatusType &status)

Static Public Member Functions

static const AtAccessoryRegisterCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtAccessoryRegisterCnfArg: reflects arguments of signal MIAT_ACC_REGISTER_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtAccessoryRegisterCnfArg::AtAccessoryRegisterCnfArg ( const AtStatusType & status )

AtAccessoryRegisterCnfArg::AtAccessoryRegisterCnfArg ( )

Member Function Documentation

const AtAccessoryRegisterCnfArg & AtAccessoryRegisterCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const AtStatusType& AtAccessoryRegisterCnfArg::GetStatus ( ) const [inline]

void AtAccessoryRegisterCnfArg::SetStatus ( const AtStatusType & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:55:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtAccessoryRegisterReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtAccessoryRegisterReqArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtAccessoryRegisterReqArg:

[legend]
Collaboration diagram for AtAccessoryRegisterReqArg:

[legend]

Public Types

enum | { ID = 1154 }

Public Member Functions

AtAccessoryRegisterReqArg ()
AtAccessoryRegisterReqArg (BOOLEAN enabled)
BOOLEAN | IsEnabled () const
void | SetEnabled (BOOLEAN enabled)

Static Public Member Functions

static const AtAccessoryRegisterReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtGenericCmdIndArg: reflects arguments of signal ATMI_ACC_REGISTER_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtAccessoryRegisterReqArg::AtAccessoryRegisterReqArg ( BOOLEAN enabled )

AtAccessoryRegisterReqArg::AtAccessoryRegisterReqArg ( )

Member Function Documentation

const AtAccessoryRegisterReqArg & AtAccessoryRegisterReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN AtAccessoryRegisterReqArg::IsEnabled ( ) const [inline]

void AtAccessoryRegisterReqArg::SetEnabled ( BOOLEAN enabled ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:55:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtAlphaTagCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtAlphaTagCnfArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtAlphaTagCnfArg:

[legend]
Collaboration diagram for AtAlphaTagCnfArg:

[legend]

Public Types

enum | { ID = 2150 }

Public Member Functions

AtAlphaTagCnfArg ()
AtAlphaTagCnfArg (const WString &alpha_id, const PhoneNumber &phone_number)
const WString & | GetAlphaId () const
const PhoneNumber & | GetPhoneNumber () const
void | SetAlphaId (const WString &alpha_id)
void | SetPhoneNumber (const PhoneNumber &phone_number)

Static Public Member Functions

static const AtAlphaTagCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtAlphaTagCnfArg: reflects arguments of signal MIAT_ALPHA_TAG_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtAlphaTagCnfArg::AtAlphaTagCnfArg | ( | const WString & | alpha_id,
 |  | const PhoneNumber & | phone_number
 | ) |

AtAlphaTagCnfArg::AtAlphaTagCnfArg ( )

Member Function Documentation

const AtAlphaTagCnfArg & AtAlphaTagCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& AtAlphaTagCnfArg::GetAlphaId ( ) const [inline]

const PhoneNumber& AtAlphaTagCnfArg::GetPhoneNumber ( ) const [inline]

void AtAlphaTagCnfArg::SetAlphaId ( const WString & alpha_id ) [inline]

void AtAlphaTagCnfArg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:55:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtAlphaTagReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtAlphaTagReqArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtAlphaTagReqArg:

[legend]
Collaboration diagram for AtAlphaTagReqArg:

[legend]

Public Types

enum | { ID = 1150 }

Public Member Functions

AtAlphaTagReqArg ()
const PhoneNumber & | GetPhoneNumber () const
void | SetPhoneNumber (const PhoneNumber &phone_number)

Static Public Member Functions

static const AtAlphaTagReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtAlphaTagReqArg: reflects arguments of signal MIAT_ALPHA_TAG_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtAlphaTagReqArg::AtAlphaTagReqArg ( )

Member Function Documentation

const AtAlphaTagReqArg & AtAlphaTagReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PhoneNumber& AtAlphaTagReqArg::GetPhoneNumber ( ) const [inline]

void AtAlphaTagReqArg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:55:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtcDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtcDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/AtcDispatcher.hpp>

Inheritance diagram for AtcDispatcher:

[legend]
Collaboration diagram for AtcDispatcher:

[legend]

Public Member Functions

AtcDispatcher ()
virtual | ~AtcDispatcher ()

Static Public Member Functions

static PbRequestBehaviour | GetPbAlphaTagRequestBehaviour ()

Protected Member Functions

BOOLEAN | OnAtAlphaTagReq (const StackMsgArgument &arg)
BOOLEAN | OnAtPbListReq (const StackMsgArgument &arg)
BOOLEAN | OnAtPbSelectReq (const StackMsgArgument &arg)

Friends

class | AtcHandler

Constructor & Destructor Documentation

AtcDispatcher::AtcDispatcher ( )

AtcDispatcher::~AtcDispatcher ( ) [virtual]

Member Function Documentation

static PbRequestBehaviour AtcDispatcher::GetPbAlphaTagRequestBehaviour ( ) [inline, static]

BOOLEAN AtcDispatcher::OnAtAlphaTagReq ( const StackMsgArgument & arg ) [protected]

BOOLEAN AtcDispatcher::OnAtPbListReq ( const StackMsgArgument & arg ) [protected]

BOOLEAN AtcDispatcher::OnAtPbSelectReq ( const StackMsgArgument & arg ) [protected]

Friends And Related Function Documentation

friend class AtcHandler [friend]

The documentation for this class was generated from the following files:
  • Asc/AtcDispatcher.hpp
  • Asc/AtcDispatcher.cpp
Generated on Wed Jan 25 00:56:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtcHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtcHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/AtcHandler.hpp>

Collaboration diagram for AtcHandler:

[legend]

Public Types

enum | { ID = AtcHandlerId }

Public Member Functions

AtcHandler ()
BOOLEAN | CommitPbInformation (const MePhonebookDescription &description)
BOOLEAN | ConfirmPbAlphaTagRequest (const WString &alphatag, const PhoneNumber &phno, BOOLEAN apoxilookup=FALSE)
BOOLEAN | ConfirmPbEntryRequest (BOOLEAN capable, MePhoneBookType type, INT recordnumber, const WString &alphaidentifier, const PhoneNumber &phno)
BOOLEAN | ConfirmPbSizeRequest (BOOLEAN capable, MePhoneBookType type, INT usedrecords, INT totalrecords=0)
virtual HandlerId | GetHandlerId () const
void | SetPbAlphaTagRequestBehaviour (PbRequestBehaviour behaviour)
void | SetPbRecordRequestBehaviour (BOOLEAN mmicontrolled)
virtual | ~AtcHandler ()

Detailed Description

The ATC handler AtcHandler provides an interface for the application to interact on AT requests from protocol stack.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtcHandler::AtcHandler ( )

AtcHandler::~AtcHandler ( ) [virtual]

Member Function Documentation

BOOLEAN AtcHandler::CommitPbInformation ( const MePhonebookDescription & description ) [inline]

The method CommitPbInformation() sends the description of phonebooks to the ATC, so that it knows which phonebooks are available within the MMI

BOOLEAN AtcHandler::ConfirmPbAlphaTagRequest | ( | const WString & | alphatag,
 |  | const PhoneNumber & | phno,
 |  | BOOLEAN | apoxilookup = FALSE
 | ) | [inline]

The method ConfirmPbAlphaTagRequest() sends the alphatag back to the AT, apoxilookup controls if a lookup shall be done also by APOXI in case the alphatag is not empty, the phno must be retrieved from the PbAlphaTagRequestMsg

BOOLEAN AtcHandler::ConfirmPbEntryRequest | ( | BOOLEAN | capable,
 |  | MePhoneBookType | type,
 |  | INT | recordnumber,
 |  | const WString & | alphaidentifier,
 |  | const PhoneNumber & | phno
 | ) | [inline]

The method ConfirmPbEntryRequest() sends a record entry of a certain phonebook back to the AT. It has to be called by the MMI if it has previously received the Message PbEntryRequestMsg

BOOLEAN AtcHandler::ConfirmPbSizeRequest | ( | BOOLEAN | capable,
 |  | MePhoneBookType | type,
 |  | INT | usedrecords,
 |  | INT | totalrecords = 0
 | ) | [inline]

The method ConfirmPbSizeRequest() sends the size of a certain phonebook back to the AT. It has to be called by the MMI if it has previously received the Message PbSizeRequestMsg

HandlerId AtcHandler::GetHandlerId ( ) const [virtual]

void AtcHandler::SetPbAlphaTagRequestBehaviour ( PbRequestBehaviour behaviour ) [inline]

The method SetPbAlphaTagRequestBehaviour() set the behaviour of answering AT alpha identifier requests

void AtcHandler::SetPbRecordRequestBehaviour ( BOOLEAN mmicontrolled ) [inline]

The method SetPbRecordRequestBehaviour() has to be called with parameter TRUE if the MMI is capably to answer the phone book requests.

The documentation for this class was generated from the following files:
  • Asc/AtcHandler.hpp
  • Asc/AtcHandler.cpp
Generated on Wed Jan 25 00:56:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtCommand Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtCommand Class Reference

#include <Apoxi/AddOns/MmCall/AtCommand.hpp>

Collaboration diagram for AtCommand:

[legend]

Public Types

enum Type {
At = 1, Atd, Ata, Ath,
AtCops, AtCbst, AtCrc, AtChld,
AtColp, AtClip, AtClir, AtCmee,
AtCeer, AtClcc, AtXcallstat, AtXservice,
AtXceer, AtXcallrefuse, AtXprogress, AtCgactQuery,
AtCgact, AtXcaoc, AtTypeInvalid
}
Types of AT command. More...

Public Member Functions

AtCommand (Type type, const String parameters[], UINT8 param_cnt)
Type | GetType () const
Returns the type of the Command.
const String | ToString () const
~AtCommand ()

Static Public Member Functions

static BOOLEAN | IsTerminatingResponse (AtCommand::Type cmd, AtResponse::ResponseType resp)

Detailed Description

This class represents an AT command with its optional Parameters. NOTE: It is not allowed to derive from AtResponseParameter (no virtual destructor).

Member Enumeration Documentation

enum AtCommand::Type

Types of AT command.

Enumerator:
At
Atd
Ata
Ath
AtCops
AtCbst
AtCrc
AtChld
AtColp
AtClip
AtClir
AtCmee
AtCeer
AtClcc
AtXcallstat
AtXservice
AtXceer
AtXcallrefuse
AtXprogress
AtCgactQuery
AtCgact
AtXcaoc
AtTypeInvalid

Constructor & Destructor Documentation

AtCommand::AtCommand | ( | Type | type,
 |  | const String | parameters[],
 |  | UINT8 | param_cnt
 | ) |

Constructor

Parameters:
type | Type of the command (e.g. ATD, ATA)
parameters | CHAR array of parameters for the command
param_cnt | Number of parameters for the command

AtCommand::~AtCommand ( )

Destructor

Member Function Documentation

Type AtCommand::GetType ( ) const [inline]

Returns the type of the Command.

BOOLEAN AtCommand::IsTerminatingResponse | ( | AtCommand::Type | cmd,
 |  | AtResponse::ResponseType | resp
 | ) | [static]

Returns TRUE if response is terminating a specific command, FALSE otherwise.

Parameters:
cmd | Type of an AT command
resp | Type of a command response

const String AtCommand::ToString ( ) const

Creates a CHAR* representation of the command, including all parameters

Parameters:
buffer | Buffer for the command-string. Buffer must be longer than 32 bytes.
buff_length | Length of the command-string
Returns:
The length of the command-string

The documentation for this class was generated from the following files:
  • AddOns/MmCall/AtCommand.hpp
  • AddOns/MmCall/AtCommand.cpp
Generated on Wed Jan 25 00:56:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtCommandData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtCommandData Struct Reference

#include <Apoxi/AddOns/MmCall/AtCommand.hpp>

Data Fields

AtCommand::Type m_command_type
INT | m_number_of_params
CHAR * | m_parameters [c_max_at_cmd_params]

Detailed Description

Holds the command type and the necessary parameters

Field Documentation

AtCommand::Type AtCommandData::m_command_type

INT AtCommandData::m_number_of_params

CHAR* AtCommandData::m_parameters[c_max_at_cmd_params]

The documentation for this struct was generated from the following file:
  • AddOns/MmCall/AtCommand.hpp
Generated on Wed Jan 25 00:56:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtCommandInfoTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtCommandInfoTable Struct Reference

#include <Apoxi/AddOns/MmCall/AtCommand.hpp>

Collaboration diagram for AtCommandInfoTable:

[legend]

Static Public Member Functions

static const AtCommandMetaInfo * | GetElementAt (INT index)
static INT | GetNumberOfEntries ()

Detailed Description

Class that holds the at command information and is able to return the number of entries.

Member Function Documentation

static const AtCommandMetaInfo* AtCommandInfoTable::GetElementAt ( INT index ) [inline, static]

Returns the element at position index

Parameters:
index element's position in the AtCommandInfoTable that should be retrieved.
Returns:
element identified by index.

static INT AtCommandInfoTable::GetNumberOfEntries ( ) [inline, static]

Returns the number of entries available in the AtCommandInfoTable

Returns:
number of entries

The documentation for this struct was generated from the following files:
  • AddOns/MmCall/AtCommand.hpp
  • AddOns/MmCall/AtCommand.cpp
Generated on Wed Jan 25 00:56:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtCommandMetaInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtCommandMetaInfo Struct Reference

#include <Apoxi/AddOns/MmCall/AtCommand.hpp>

Data Fields

AtCommand::Type m_command_type
INT | m_specific_resp_cnt
AtResponse::ResponseType m_specific_responses [c_max_specific_at_resp_params]
CHAR * | m_str_presentation

Detailed Description

Structure that holds AtCommand, its presentation and specific responses that can arrive for the command

Field Documentation

AtCommand::Type AtCommandMetaInfo::m_command_type

INT AtCommandMetaInfo::m_specific_resp_cnt

AtResponse::ResponseType AtCommandMetaInfo::m_specific_responses[c_max_specific_at_resp_params]

CHAR* AtCommandMetaInfo::m_str_presentation

The documentation for this struct was generated from the following file:
  • AddOns/MmCall/AtCommand.hpp
Generated on Wed Jan 25 00:56:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtGenericCmdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtGenericCmdIndArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtGenericCmdIndArg:

[legend]
Collaboration diagram for AtGenericCmdIndArg:

[legend]

Public Types

enum | { ID = 2154 }

Public Member Functions

AtGenericCmdIndArg ()
AtGenericCmdIndArg (const AtStatusType &status, BOOLEAN final, const AtGenericCmdType &cmd)
const AtGenericCmdType & | GetCmd () const
const AtStatusType & | GetStatus () const
BOOLEAN | IsFinal () const
void | SetCmd (const AtGenericCmdType &cmd)
void | SetFinal (BOOLEAN final)
void | SetStatus (const AtStatusType &status)

Static Public Member Functions

static const AtGenericCmdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtGenericCmdIndArg: reflects arguments of signal MIAT_COMMAND_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtGenericCmdIndArg::AtGenericCmdIndArg | ( | const AtStatusType & | status,
 |  | BOOLEAN | final,
 |  | const AtGenericCmdType & | cmd
 | ) |

AtGenericCmdIndArg::AtGenericCmdIndArg ( )

Member Function Documentation

const AtGenericCmdIndArg & AtGenericCmdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const AtGenericCmdType& AtGenericCmdIndArg::GetCmd ( ) const [inline]

const AtStatusType& AtGenericCmdIndArg::GetStatus ( ) const [inline]

BOOLEAN AtGenericCmdIndArg::IsFinal ( ) const [inline]

void AtGenericCmdIndArg::SetCmd ( const AtGenericCmdType & cmd ) [inline]

void AtGenericCmdIndArg::SetFinal ( BOOLEAN final ) [inline]

void AtGenericCmdIndArg::SetStatus ( const AtStatusType & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtGenericCmdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtGenericCmdReqArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtGenericCmdReqArg:

[legend]
Collaboration diagram for AtGenericCmdReqArg:

[legend]

Public Types

enum | { ID = 1153 }

Public Member Functions

AtGenericCmdReqArg ()
const AtGenericCmdType & | GetCmd () const
void | SetCmd (const AtGenericCmdType &cmd)

Static Public Member Functions

static const AtGenericCmdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtGenericCmdReqArg : reflects arguments of signal ATMI_COMMAND_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtGenericCmdReqArg::AtGenericCmdReqArg ( )

Member Function Documentation

const AtGenericCmdReqArg & AtGenericCmdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const AtGenericCmdType& AtGenericCmdReqArg::GetCmd ( ) const [inline]

void AtGenericCmdReqArg::SetCmd ( const AtGenericCmdType & cmd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtGenericCmdType Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtGenericCmdType Class Reference

#include <Apoxi/Apc/AtcTypes.hpp>

Public Member Functions

AtGenericCmdType (const AtGenericCmdType &cmd)
AtGenericCmdType ()
void | Push (INT length, const UINT8 *data_ptr)
~AtGenericCmdType ()

Data Fields

UINT8 * | m_data_ptr
INT | m_length

Constructor & Destructor Documentation

AtGenericCmdType::AtGenericCmdType ( ) [inline]

AtGenericCmdType::AtGenericCmdType ( const AtGenericCmdType & cmd ) [inline]

AtGenericCmdType::~AtGenericCmdType ( ) [inline]

Member Function Documentation

void AtGenericCmdType::Push | ( | INT | length,
 |  | const UINT8 * | data_ptr
 | ) | [inline]

Field Documentation

UINT8* AtGenericCmdType::m_data_ptr

INT AtGenericCmdType::m_length

The documentation for this class was generated from the following file:
  • Apc/AtcTypes.hpp
Generated on Wed Jan 25 00:56:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtiAudioCapturerEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtiAudioCapturerEncoder Class Reference
[CodecManager]

#include <Apoxi/Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.hpp>

Inheritance diagram for AtiAudioCapturerEncoder:

[legend]
Collaboration diagram for AtiAudioCapturerEncoder:

[legend]

Public Member Functions

virtual void | Close ()
virtual ResultType | ConfigureAAC (AacFormat aac_encoding_format, UINT16 sampling_rate, EncQualityConfig quality_config, MonoSteroConfig monostero_config, UINT32 max_buffer_size)
virtual ResultType | ConfigureAMR (AmrIfFormat amr_if_format, EncQualityConfig quality_config, AmrDtxConfig dtx_config, UINT32 max_buffer_size)
virtual ResultType | GetAudioChannelId (AudioChannel &audio_channel)
virtual ResultType | GetBuffer (AudioIOBuffer **buffer)
virtual ResultType | GetProperties (Properties &properties)
virtual ResultType | Open (AudioChannel &audio_channel)
virtual ResultType | RegisterCallbackFunctions (void *context, CbReady cb_data_available)
virtual | ~AtiAudioCapturerEncoder ()

Protected Member Functions

virtual ResultType | SetCodec (CodecType codec)

Friends

class | AtiCodecsLib

Data Structures

struct | StateFlags

Detailed Description

Audio Capturer and Encoder interface for the ATI W2x82 multimedia companion chip.

Constructor & Destructor Documentation

AtiAudioCapturerEncoder::~AtiAudioCapturerEncoder ( ) [virtual]

Destructor

Member Function Documentation

void AtiAudioCapturerEncoder::Close ( ) [virtual]

See also:
AudioCapturerEncoder::Close

Implements AudioCapturerEncoder.

CodecDevice::ResultType AtiAudioCapturerEncoder::ConfigureAAC | ( | AacFormat | aac_encoding_format,
 |  | UINT16 | sampling_rate,
 |  | EncQualityConfig | quality_config,
 |  | MonoSteroConfig | monostero_config,
 |  | UINT32 | max_buffer_size
 | ) | [virtual]

See also:
AudioCapturerEncoder::ConfigureAAC

Implements AudioCapturerEncoder.

CodecDevice::ResultType AtiAudioCapturerEncoder::ConfigureAMR | ( | AmrIfFormat | amr_if_format,
 |  | EncQualityConfig | quality_config,
 |  | AmrDtxConfig | dtx_config,
 |  | UINT32 | max_buffer_size
 | ) | [virtual]

See also:
AudioCapturerEncoder::ConfigureAMR

Implements AudioCapturerEncoder.

CodecDevice::ResultType AtiAudioCapturerEncoder::GetAudioChannelId ( AudioChannel & audio_channel ) [virtual]

See also:
AudioCapturerEncoder::GetAudioChannelId

Implements AudioCapturerEncoder.

CodecDevice::ResultType AtiAudioCapturerEncoder::GetBuffer ( AudioIOBuffer ** buffer ) [virtual]

See also:
AudioCapturerEncoder::GetBuffer

Implements AudioCapturerEncoder.

CodecDevice::ResultType AtiAudioCapturerEncoder::GetProperties ( Properties & properties ) [virtual]

See also:
CodecDevice::GetProperties

CodecDevice::ResultType AtiAudioCapturerEncoder::Open ( AudioChannel & audio_channel ) [virtual]

See also:
AudioCapturerEncoder::Open

Implements AudioCapturerEncoder.

CodecDevice::ResultType AtiAudioCapturerEncoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbReady | cb_data_available
 | ) | [virtual]

See also:
AudioCapturerEncoder::RegisterCallbackFunctions

CodecDevice::ResultType AtiAudioCapturerEncoder::SetCodec ( CodecType codec ) [protected, virtual]

See also:
CodecDevice::SetCodec

Friends And Related Function Documentation

friend class AtiCodecsLib [friend]

The documentation for this class was generated from the following files:
  • Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.hpp
  • Devices/MPEU/Extensions/AtiW2282/AtiAudioCapturerEncoder.cpp
Generated on Wed Jan 25 00:56:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtiAudioDecoderRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtiAudioDecoderRenderer Class Reference
[Devices]

#include <Apoxi/Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.hpp>

Inheritance diagram for AtiAudioDecoderRenderer:

[legend]
Collaboration diagram for AtiAudioDecoderRenderer:

[legend]

Public Member Functions

virtual void | Close ()
virtual ResultType | DecodeRenderBuffer (AudioIOBuffer *buffer)
virtual ResultType | GetAudioChannelId (AudioChannel &audio_channel)
virtual ResultType | GetProperties (Properties &properties)
virtual ResultType | Open (AudioChannel &audio_channel)
virtual ResultType | RegisterCallbackFunctions (void *context, CbReady cb_ready_for_data, CbResult cb_all_buffers_processed)
virtual | ~AtiAudioDecoderRenderer ()

Protected Member Functions

virtual ResultType | SetCodec (CodecType codec)

Friends

class | AtiCodecsLib
class | CodecManager

Data Structures

struct | StateFlags

Detailed Description

Combined audio decoder and encoder interface for the ATI W2x82 multimedia companion chip.

Constructor & Destructor Documentation

AtiAudioDecoderRenderer::~AtiAudioDecoderRenderer ( ) [virtual]

Destructor

Member Function Documentation

void AtiAudioDecoderRenderer::Close ( ) [virtual]

See also:
AudioDecoderRenderer::Close

Implements AudioDecoderRenderer.

CodecDevice::ResultType AtiAudioDecoderRenderer::DecodeRenderBuffer ( AudioIOBuffer * buffer ) [virtual]

See also:
AudioDecoderRenderer::DecodeRenderBuffer

Implements AudioDecoderRenderer.

CodecDevice::ResultType AtiAudioDecoderRenderer::GetAudioChannelId ( AudioChannel & audio_channel ) [virtual]

See also:
AudioDecoderRenderer::GetAudioChannelId

Implements AudioDecoderRenderer.

CodecDevice::ResultType AtiAudioDecoderRenderer::GetProperties ( Properties & properties ) [virtual]

See also:
CodecDevice::GetProperties

CodecDevice::ResultType AtiAudioDecoderRenderer::Open ( AudioChannel & audio_channel ) [virtual]

See also:
AudioDecoderRenderer::Open

Implements AudioDecoderRenderer.

CodecDevice::ResultType AtiAudioDecoderRenderer::RegisterCallbackFunctions | ( | void * | context,
 |  | CbReady | cb_ready_for_data,
 |  | CbResult | cb_all_buffers_processed
 | ) | [virtual]

See also:
AudioDecoderRenderer::RegisterCallbackFunctions

CodecDevice::ResultType AtiAudioDecoderRenderer::SetCodec ( CodecType codec ) [protected, virtual]

See also:
CodecDevice::SetCodec

Friends And Related Function Documentation

friend class AtiCodecsLib [friend]

friend class CodecManager [friend]

Reimplemented from AudioDecoderRenderer.

The documentation for this class was generated from the following files:
  • Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.hpp
  • Devices/MPEU/Extensions/AtiW2282/AtiAudioDecoderRenderer.cpp
Generated on Wed Jan 25 00:56:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtiAudioPlayerRtStreamingConn Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtiAudioPlayerRtStreamingConn Class Reference

#include <Apoxi/Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.hpp>

Inheritance diagram for AtiAudioPlayerRtStreamingConn:

[legend]
Collaboration diagram for AtiAudioPlayerRtStreamingConn:

[legend]

Public Member Functions

AtiAudioPlayerRtStreamingConn (AtiAudioPlayerRtStreamingSink *snk, DataSourceRtStreamingSource *src)

Constructor & Destructor Documentation

AtiAudioPlayerRtStreamingConn::AtiAudioPlayerRtStreamingConn | ( | AtiAudioPlayerRtStreamingSink * | snk,
 |  | DataSourceRtStreamingSource * | src
 | ) |

The documentation for this class was generated from the following files:
  • Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.hpp
  • Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingConn.cpp
Generated on Wed Jan 25 00:56:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtiAudioPlayerRtStreamingSink Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtiAudioPlayerRtStreamingSink Class Reference

#include <Apoxi/Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.hpp>

Inheritance diagram for AtiAudioPlayerRtStreamingSink:

[legend]
Collaboration diagram for AtiAudioPlayerRtStreamingSink:

[legend]

Public Member Functions

AtiAudioPlayerRtStreamingSink (AudioActiveReference &audio_ref)
AtiAudioPlayerRtStreamingSink ()
void | ReleaseSemaphore ()

Protected Member Functions

virtual BOOLEAN | CloseAction ()
Implements the concrete Close() behaviour.
virtual void | GetBufferInfo (BufferInfo &buf_info) const
virtual BOOLEAN | OpenAction ()
Implements the concrete Open() behaviour.
virtual BOOLEAN | StartAction ()
virtual BOOLEAN | StopAction (RtStreamingConn::StopCause cause)
virtual void | StopOnCause (RtStreamingConn::StopCause cause)

Protected Attributes

RtStreamingBuffer | m_buffers [2]

Friends

class | AtiAudioPlayer
class | AtiAudioPlayerSinkThread

Constructor & Destructor Documentation

AtiAudioPlayerRtStreamingSink::AtiAudioPlayerRtStreamingSink ( )

AtiAudioPlayerRtStreamingSink::AtiAudioPlayerRtStreamingSink ( AudioActiveReference & audio_ref )

Member Function Documentation

BOOLEAN AtiAudioPlayerRtStreamingSink::CloseAction ( ) [protected, virtual]

Implements the concrete Close() behaviour.

Implements RtStreamingEndPoint.

void AtiAudioPlayerRtStreamingSink::GetBufferInfo ( BufferInfo & buf_info ) const [protected, virtual]

< Time required to process one buffer

< Buffer size

Implements RtStreamingSink.

BOOLEAN AtiAudioPlayerRtStreamingSink::OpenAction ( ) [protected, virtual]

Implements the concrete Open() behaviour.

Implements RtStreamingEndPoint.

void AtiAudioPlayerRtStreamingSink::ReleaseSemaphore ( ) [inline]

BOOLEAN AtiAudioPlayerRtStreamingSink::StartAction ( ) [protected, virtual]

Implements RtStreamingSink.

BOOLEAN AtiAudioPlayerRtStreamingSink::StopAction ( RtStreamingConn::StopCause cause ) [protected, virtual]

Implements RtStreamingSink.

void AtiAudioPlayerRtStreamingSink::StopOnCause ( RtStreamingConn::StopCause cause ) [protected, virtual]

Implements RtStreamingSink.

Friends And Related Function Documentation

friend class AtiAudioPlayer [friend]

friend class AtiAudioPlayerSinkThread [friend]

Field Documentation

RtStreamingBuffer AtiAudioPlayerRtStreamingSink::m_buffers[2] [protected]

The documentation for this class was generated from the following files:
  • Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.hpp
  • Devices/MPEU/Extensions/AtiW2282/AtiAudioPlayerRtStreamingSink.cpp
Generated on Wed Jan 25 00:56:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtiCodecsLib Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtiCodecsLib Class Reference
[Config]

#include <Apoxi/Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.hpp>

Friends

class CodecConfig

Detailed Description

Emuzed Video Decoder & Encoder Interface Library class.

Friends And Related Function Documentation

friend class CodecConfig [friend]

The documentation for this class was generated from the following files:
  • Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.hpp
  • Devices/MPEU/Extensions/AtiW2282/AtiCodecsLib.cpp
Generated on Wed Jan 25 00:56:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtiMpeg4Decoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtiMpeg4Decoder Class Reference
[Devices]

#include <Apoxi/Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.hpp>

Inheritance diagram for AtiMpeg4Decoder:

[legend]
Collaboration diagram for AtiMpeg4Decoder:

[legend]

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual ResultType | Close ()
virtual ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags, UINT32 time_stamp)
virtual ResultType | DecodePacket (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual ResultType | FlushBuffers (CbResult cb_video_decoder_flushed, void *context)
virtual ResultType | GetCapabilities (VideoCodecCapabilities &caps)
virtual ResultType | GetCurrentVideoClockTime (UINT32 &time_ms)
virtual ResultType | GetProperties (Properties &properties)
virtual ResultType | Open (VideoDecoderInfo &dec_info)
virtual ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded, CbInBufferFree cb_in_buf_free)
virtual ResultType | ReleaseOutputBuffer (const UINT8 HUGE *out_buf)
virtual ResultType | SetAssociatedAudioCh (UINT32 audio_channel)
virtual ResultType | SetConfig (const UINT8 *config_stream, UINT32 &config_len, const VideoDecoderParameters &params, VideoStreamInfo &stream_info)
virtual ResultType | SetVideoClockTime (UINT32 time_ms)
virtual ResultType | Start (CbResultAndTimeInfo cb_video_decoder_started, void *context)
virtual ResultType | Stop (CbResult cb_video_decoder_stopped, void *context)
virtual | ~AtiMpeg4Decoder ()

Protected Member Functions

virtual ResultType | SetCodec (CodecType codec)

Friends

class | AtiCodecsLib

Data Structures

struct | StateFlags

Detailed Description

MPEG-4 Simple Profile and H.263 Baseline video decoder interface for the ATI W2x82 multimedia companion chip.

Constructor & Destructor Documentation

AtiMpeg4Decoder::~AtiMpeg4Decoder ( ) [virtual]

Destructor.

Member Function Documentation

CodecDevice::ResultType AtiMpeg4Decoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoDecoder::AllocateOutputBuffers

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::Close ( ) [virtual]

See also:
VideoDecoder::Close

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags,
 |  | UINT32 | time_stamp
 | ) | [virtual]

See also:
VideoDecoder::DecodeFrame

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::DecodePacket | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

See also:
VideoDecoder::DecodePacket

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::FlushBuffers | ( | CbResult | cb_video_decoder_flushed,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::FlushBuffers

Implements VideoDecoder.

virtual ResultType AtiMpeg4Decoder::GetCapabilities ( VideoCodecCapabilities & caps ) [virtual]

See also:
VideoDecoder::GetCapabilities

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::GetCurrentVideoClockTime ( UINT32 & time_ms ) [virtual]

See also:
VideoDecoder::GetCurrentVideoClockTime

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::GetProperties ( Properties & properties ) [virtual]

see CodecDevice::GetProperties

CodecDevice::ResultType AtiMpeg4Decoder::Open ( VideoDecoderInfo & dec_info ) [virtual]

See also:
VideoDecoder::Open

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded,
 |  | CbInBufferFree | cb_in_buf_free
 | ) | [virtual]

See also:
VideoDecoder::RegisterCallbackFunctions

CodecDevice::ResultType AtiMpeg4Decoder::ReleaseOutputBuffer ( const UINT8 HUGE * out_buf ) [virtual]

See also:
VideoDecoder::ReleaseOutputBuffer

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::SetAssociatedAudioCh ( UINT32 audio_channel ) [virtual]

See also:
VideoDecoder::SetAssociatedAudioCh

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::SetCodec ( CodecType codec ) [protected, virtual]

See also:
CodecDevice::SetCodec

CodecDevice::ResultType AtiMpeg4Decoder::SetConfig | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const VideoDecoderParameters & | params,
 |  | VideoStreamInfo & | stream_info
 | ) | [virtual]

See also:
VideoDecoder::SetConfig

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::SetVideoClockTime ( UINT32 time_ms ) [virtual]

See also:
VideoDecoder::SetVideoClockTime

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::Start | ( | CbResultAndTimeInfo | cb_video_decoder_started,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::Start

Implements VideoDecoder.

CodecDevice::ResultType AtiMpeg4Decoder::Stop | ( | CbResult | cb_video_decoder_stopped,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::Stop

Implements VideoDecoder.

Friends And Related Function Documentation

friend class AtiCodecsLib [friend]

The documentation for this class was generated from the following files:
  • Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.hpp
  • Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Decoder.cpp
Generated on Wed Jan 25 00:56:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtiMpeg4Encoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtiMpeg4Encoder Class Reference
[Devices]

#include <Apoxi/Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.hpp>

Inheritance diagram for AtiMpeg4Encoder:

[legend]
Collaboration diagram for AtiMpeg4Encoder:

[legend]

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual ResultType | Close ()
virtual ResultType | EncodeFrame (UINT8 HUGE *in_buf, UINT32 time_stamp, UINT32 key_frame_ind)
virtual ResultType | FlushBuffers (CbResult cb_video_encoder_flushed, void *context)
virtual ResultType | GetCapabilities (VideoCodecCapabilities &caps)
virtual ResultType | GetConfigStream (UINT8 HUGE *&out_buf, UINT32 &out_buf_len)
virtual ResultType | GetProperties (Properties &properties)
virtual ResultType | InsertKeyFrame ()
virtual ResultType | Open ()
virtual ResultType | RegisterCallbackFunctions (void *context, CbVideoFrameEncoded cb_video_frame_encoded)
virtual ResultType | ReleaseConfigStreamBuffer (UINT8 HUGE *buf)
virtual ResultType | ReleaseOutputBuffer (UINT8 HUGE *out_buf)
virtual ResultType | SetConfig (const VideoEncoderParameters &params, UINT32 &out_buf_max_len)
virtual ResultType | SetDynamicConfig (VideoEncoderDynParameters &params)
virtual ResultType | Start ()
virtual ResultType | Stop (CbResult cb_video_encoder_stopped, void *context)
virtual | ~AtiMpeg4Encoder ()

Protected Member Functions

virtual ResultType | SetCodec (CodecType codec)

Friends

class | AtiCodecsLib

Data Structures

struct | StateFlags

Detailed Description

MPEG-4 Simple Profile and H.263 Baseline video encoder interface for the ATI W2x82 multimedia companion chip.

Constructor & Destructor Documentation

AtiMpeg4Encoder::~AtiMpeg4Encoder ( ) [virtual]

Destructor

Member Function Documentation

CodecDevice::ResultType AtiMpeg4Encoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoEncoder::AllocateOutputBuffers

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::Close ( ) [virtual]

See also:
VideoEncoder::Close

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::EncodeFrame | ( | UINT8 HUGE * | in_buf,
 |  | UINT32 | time_stamp,
 |  | UINT32 | key_frame_ind
 | ) | [virtual]

See also:
VideoEncoder::EncodeFrame

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::FlushBuffers | ( | CbResult | cb_video_encoder_flushed,
 |  | void * | context
 | ) | [virtual]

See also:
VideoEncoder::FlushBuffers

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::GetCapabilities ( VideoCodecCapabilities & caps ) [virtual]

See also:
VideoEncoder::GetCapabilities

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::GetConfigStream | ( | UINT8 HUGE *& | out_buf,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoEncoder::GetConfigStream

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::GetProperties ( Properties & properties ) [virtual]

see CodecDevice::GetProperties

CodecDevice::ResultType AtiMpeg4Encoder::InsertKeyFrame ( ) [virtual]

See also:
VideoEncoder::InsertKeyFrame

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::Open ( ) [virtual]

See also:
VideoEncoder::Open

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbVideoFrameEncoded | cb_video_frame_encoded
 | ) | [virtual]

See also:
VideoEncoder::RegisterCallbackFunctions

CodecDevice::ResultType AtiMpeg4Encoder::ReleaseConfigStreamBuffer ( UINT8 HUGE * buf ) [virtual]

See also:
VideoEncoder::ReleaseConfigStreamBuffer

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::ReleaseOutputBuffer ( UINT8 HUGE * out_buf ) [virtual]

See also:
VideoEncoder::ReleaseOutputBuffer

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::SetCodec ( CodecType codec ) [protected, virtual]

See also:
CodecDevice::SetCodec

CodecDevice::ResultType AtiMpeg4Encoder::SetConfig | ( | const VideoEncoderParameters & | params,
 |  | UINT32 & | out_buf_max_len
 | ) | [virtual]

See also:
VideoEncoder::SetConfig

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::SetDynamicConfig ( VideoEncoderDynParameters & params ) [virtual]

See also:
VideoEncoder::SetDynamicConfig

CodecDevice::ResultType AtiMpeg4Encoder::Start ( ) [virtual]

See also:
VideoEncoder::Start

Implements VideoEncoder.

CodecDevice::ResultType AtiMpeg4Encoder::Stop | ( | CbResult | cb_video_encoder_stopped,
 |  | void * | context
 | ) | [virtual]

See also:
VideoEncoder::Stop

Implements VideoEncoder.

Friends And Related Function Documentation

friend class AtiCodecsLib [friend]

The documentation for this class was generated from the following files:
  • Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.hpp
  • Devices/MPEU/Extensions/AtiW2282/AtiMpeg4Encoder.cpp
Generated on Wed Jan 25 00:56:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtKeyParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtKeyParser Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/AtKeyParser.hpp>

Public Member Functions

AtKeyParser (INT length, UINT8 *key_string, INT time, INT pause)
initializes the Parser with a AT+ckpd string
BOOLEAN | GetFirstKey (KeyMsgGenerator::Key &key)
returns the first key object of the string
BOOLEAN | GetNextKey (KeyMsgGenerator::Key &key)
iterates through the string
~AtKeyParser ()

Constructor & Destructor Documentation

AtKeyParser::AtKeyParser | ( | INT | length,
 |  | UINT8 * | key_string,
 |  | INT | time,
 |  | INT | pause
 | ) |

initializes the Parser with a AT+ckpd string

AtKeyParser::~AtKeyParser ( )

Member Function Documentation

BOOLEAN AtKeyParser::GetFirstKey ( KeyMsgGenerator::Key & key )

returns the first key object of the string

BOOLEAN AtKeyParser::GetNextKey ( KeyMsgGenerator::Key & key )

iterates through the string

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/AtKeyParser.hpp
  • Apc/SignalHandler/AtKeyParser.cpp
Generated on Wed Jan 25 00:56:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlApplication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlApplication Class Reference
[APOXI Template Layer]

Baseclass for a ReferenceMmi Application. More...

#include <Apoxi/Atl/AtlApplication.hpp>

Inheritance diagram for AtlApplication:

[legend]
Collaboration diagram for AtlApplication:

[legend]

Public Member Functions

AtlApplication (const WCHAR *app_name, UINT stacksize=0)
virtual DataItem | GetContextDataItem (ContextFeature *feature)
FeaturePool * GetFeaturePool ()
virtual ApplicationID | GetID () const
void | OnOpenMenu (FeatureItemContainer *item_cont)
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)
virtual void | OnStartup ()
Registers this application with Feature Broker.
void | TriggerFeatureItemUpdate (FeatureItem *item)
virtual | ~AtlApplication ()

Protected Member Functions

AtlApplication ()
void | AttachAtlApplicationPlugin (AtlApplicationPlugin *plugin)
const ContextID * | GetContextId ()
virtual void | OnClose ()
virtual BOOLEAN | OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &context_item)
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual BOOLEAN | RouteMessage (const Message &msg)
Involves the KeyManager in order to map key codes, before routed according to focus.
virtual void | UpdateContextItem (ContextFeatureItem *item)
virtual BOOLEAN | UpdateItem (Item *item)

Static Protected Member Functions

static void | PropagateUserActivity ()
static void | RegisterUserActivityListener (UserActivityListener *useractivity)
static void | UnregisterUserActivityListener (UserActivityListener *useractivity)

Friends

class | AtlApplicationPlugin
class | KeyManager

Detailed Description

Baseclass for a ReferenceMmi Application.

Constructor & Destructor Documentation

AtlApplication::AtlApplication | ( | const WCHAR * | app_name,
 |  | UINT | stacksize = 0
 | ) |

AtlApplication::~AtlApplication ( ) [virtual]

AtlApplication::AtlApplication ( ) [protected]

Member Function Documentation

void AtlApplication::AttachAtlApplicationPlugin ( AtlApplicationPlugin * plugin ) [protected]

Parameters:
key_code | Play key tone for the given key, according to active key tone type
plugin | Plugins attached to this application are stored for propagation of Property Notification

DataItem AtlApplication::GetContextDataItem ( ContextFeature * feature ) [virtual]

Parameters:
feature The feature-using application must supply the context item matching for the given context feature
Returns:
Context item

const ContextID* AtlApplication::GetContextId ( ) [inline, protected]

Returns:
Currently active context

FeaturePool * AtlApplication::GetFeaturePool ( )

Returns:
The feature pool instance of this application

ApplicationID AtlApplication::GetID ( ) const [virtual]

void AtlApplication::OnClose ( ) [protected, virtual]

Is called, if the application is closed.

Reimplemented from Application.

BOOLEAN AtlApplication::OnContextFeatureTriggered | ( | const FeatureID & | feature_id,
 |  | const DataItem & | context_item
 | ) | [protected, virtual]

Parameters:
feature_id | The context feature with given feature_id has been triggered.
context_item | The context item as feature invocation argument
Returns:
TRUE, if the triggered feature is handled by this application

BOOLEAN AtlApplication::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

Parameters:
feature_id The feature with given feature_id has been triggered.
Returns:
TRUE, if the triggered feature is handled by this application

BOOLEAN AtlApplication::OnMessage ( const Message & msg ) [protected, virtual]

Handles following messages:

  • Feature, context feature, or property trigger messages
  • UpdateContextItem msg: Feature-using application to supply context item
  • UpdateItem msg: Feature-providing application or plugin to update the state of the item
  • KeyDown message, if softkey codes => Softkey action is executed
    Returns:
    TRUE, if the message has been handled

Reimplemented from Application.

void AtlApplication::OnOpen ( ) [protected, virtual]

Is called after the default initialization process.

Reimplemented from Application.

void AtlApplication::OnOpenMenu ( FeatureItemContainer * item_cont )

Parameters:
item_cont Before opening a context menu, the features of the given container must be updated.

BOOLEAN AtlApplication::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [virtual]

Both application and all attached plugins receive this validation request.

Parameters:
notification Notification rule
  • Notify_Validate_Set - value contains the new value to be set by the property editor
  • Notify_PreviewChanged - value contains the value chosen by the property editor and not yet set
  • Notify_Set - value contains the value set to the property by the property editor
property | Property containing the previous value
value | Property's new value
Returns:
FALSE, if either application or any plugin does not validate the new value.

void AtlApplication::OnStartup ( ) [virtual]

Registers this application with Feature Broker.

Reimplemented from Application.

void AtlApplication::PropagateUserActivity ( ) [static, protected]

void AtlApplication::RegisterUserActivityListener ( UserActivityListener * useractivity ) [static, protected]

BOOLEAN AtlApplication::RouteMessage ( const Message & msg ) [protected, virtual]

Involves the KeyManager in order to map key codes, before routed according to focus.

Reimplemented from Application.

void AtlApplication::TriggerFeatureItemUpdate ( FeatureItem * item )

Parameters:
item If item is a context feature item with not fixed context, the feature-using application or plugin must be asked to supply the context item. Further, the feature-providing application or plugin is asked to update the state of the item.

void AtlApplication::UnregisterUserActivityListener ( UserActivityListener * useractivity ) [static, protected]

void AtlApplication::UpdateContextItem ( ContextFeatureItem * item ) [protected, virtual]

Parameters:
item The feature-using application must set the context item

BOOLEAN AtlApplication::UpdateItem ( Item * item ) [protected, virtual]

Parameters:
item The feature-providing application is able to update the state of the item.
Returns:
TRUE, if the item belongs to the application

Friends And Related Function Documentation

friend class AtlApplicationPlugin [friend]

friend class KeyManager [friend]

The documentation for this class was generated from the following files:
  • Atl/AtlApplication.hpp
  • Atl/AtlApplication.cpp
Generated on Wed Jan 25 00:56:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlApplicationPlugin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlApplicationPlugin Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/AtlApplicationPlugin.hpp>

Inheritance diagram for AtlApplicationPlugin:

[legend]
Collaboration diagram for AtlApplicationPlugin:

[legend]

Public Member Functions

void | Attach ()
Attaches the plugin to its host application.
void | Detach ()
Detaches the plugin from its host application.
Application * GetApplication ()
const WCHAR * | GetPluginName () const
virtual void | Init (Application *host_application)
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)
virtual void | OnUpdateContextItem (ContextFeatureItem *item)
void | SetPluginName (const WCHAR *plugin_name)
virtual | ~AtlApplicationPlugin ()

Protected Member Functions

AtlApplicationPlugin ()
virtual BOOLEAN | OnActionExecuted (Action *action)
Is called upon receipt of the OnActionExecuted message.
virtual void | OnAppClose ()
Is called when then the host application is closed */.
virtual void | OnAppGetFocus ()
Is called when the host application gets the focus.
virtual void | OnAppLoseFocus ()
Is called when the host application loses the focus.
virtual void | OnAppOpen ()
Is called when then the host application is openend */.
virtual BOOLEAN | OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &item)
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnInputChar (WCHAR chr)
virtual BOOLEAN | OnKeyAutoRepeat (KeyCode key_code)
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual BOOLEAN | OnKeyUp (KeyCode key_code, UINT32 duration)
virtual void | OnLanguageChanged ()
Is called, if the language has been changed.
virtual BOOLEAN | OnLongKeyPress (KeyCode key_code)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnThemeChanged ()
Is called, if the theme has been changed.
virtual BOOLEAN | OnTimeout (const Timer &timer)
Is called, if a timer expires.
virtual BOOLEAN | OnVeryLongKeyPress (KeyCode key_code)
virtual BOOLEAN | UpdateItem (Item *item)

Protected Attributes

Application * m_app
const WCHAR * | m_plugin_name

Constructor & Destructor Documentation

AtlApplicationPlugin::~AtlApplicationPlugin ( ) [virtual]

AtlApplicationPlugin::AtlApplicationPlugin ( ) [protected]

Member Function Documentation

void AtlApplicationPlugin::Attach ( )

Attaches the plugin to its host application.

void AtlApplicationPlugin::Detach ( )

Detaches the plugin from its host application.

Application* AtlApplicationPlugin::GetApplication ( ) [inline]

Returns:
Host application of the plugin

const WCHAR* AtlApplicationPlugin::GetPluginName ( ) const [inline]

Returns:
Name of the plugin

void AtlApplicationPlugin::Init ( Application * host_application ) [virtual]

BOOLEAN AtlApplicationPlugin::OnActionExecuted ( Action * action ) [protected, virtual]

Is called upon receipt of the OnActionExecuted message.

void AtlApplicationPlugin::OnAppClose ( ) [protected, virtual]

Is called when then the host application is closed */.

void AtlApplicationPlugin::OnAppGetFocus ( ) [protected, virtual]

Is called when the host application gets the focus.

void AtlApplicationPlugin::OnAppLoseFocus ( ) [protected, virtual]

Is called when the host application loses the focus.

void AtlApplicationPlugin::OnAppOpen ( ) [protected, virtual]

Is called when then the host application is openend */.

BOOLEAN AtlApplicationPlugin::OnContextFeatureTriggered | ( | const FeatureID & | feature_id,
 |  | const DataItem & | item
 | ) | [protected, virtual]

Parameters:
feature_id | The context feature with given feature_id has been triggered.
context_item | The context item as feature invocation argument
Returns:
TRUE, if the triggered feature is handled by this plugin

BOOLEAN AtlApplicationPlugin::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

Parameters:
feature_id The feature with given feature_id has been triggered.
Returns:
TRUE, if the triggered feature is handled by this plugin

BOOLEAN AtlApplicationPlugin::OnInputChar ( WCHAR chr ) [protected, virtual]

BOOLEAN AtlApplicationPlugin::OnKeyAutoRepeat ( KeyCode key_code ) [protected, virtual]

BOOLEAN AtlApplicationPlugin::OnKeyDown ( KeyCode key_code ) [protected, virtual]

Is called, if a key has been pressed and is still held. The code of the key is given by key_code.

BOOLEAN AtlApplicationPlugin::OnKeyUp | ( | KeyCode | key_code,
 |  | UINT32 | duration
 | ) | [protected, virtual]

Is called, if a key has been released. The code of the key is given by key_code.

void AtlApplicationPlugin::OnLanguageChanged ( ) [protected, virtual]

Is called, if the language has been changed.

BOOLEAN AtlApplicationPlugin::OnLongKeyPress ( KeyCode key_code ) [protected, virtual]

Is called, if a key has been pressed and the duration exceeded the long-key-press limit. The code of the key is given by key_code.

BOOLEAN AtlApplicationPlugin::OnMessage ( const Message & msg ) [protected, virtual]

Is invoked for any message the host application receives and does not dispatch itself

Implements Dispatcher.

BOOLEAN AtlApplicationPlugin::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [virtual]

See also:
AtlApplication

void AtlApplicationPlugin::OnThemeChanged ( ) [protected, virtual]

Is called, if the theme has been changed.

BOOLEAN AtlApplicationPlugin::OnTimeout ( const Timer & timer ) [protected, virtual]

Is called, if a timer expires.

void AtlApplicationPlugin::OnUpdateContextItem ( ContextFeatureItem * item ) [virtual]

Parameters:
item The feature-using plugin must set the context item

BOOLEAN AtlApplicationPlugin::OnVeryLongKeyPress ( KeyCode key_code ) [protected, virtual]

Is called, if a key has been pressed and the duration exceeded the very-long-key-press limit. The code of the key is given by key_code.

void AtlApplicationPlugin::SetPluginName ( const WCHAR * plugin_name ) [inline]

Parameters:
plugin_name Name of the plugin

BOOLEAN AtlApplicationPlugin::UpdateItem ( Item * item ) [protected, virtual]

Parameters:
item The feature-providing plugin is able to update the state of the item.
Returns:
TRUE, if the item belongs to the plugin

Field Documentation

Application* AtlApplicationPlugin::m_app [protected]

const WCHAR* AtlApplicationPlugin::m_plugin_name [protected]

The documentation for this class was generated from the following files:
  • Atl/AtlApplicationPlugin.hpp
  • Atl/AtlApplicationPlugin.cpp
Generated on Wed Jan 25 00:56:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlApplicationPluginStartup Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlApplicationPluginStartup Class Reference

#include <Apoxi/Atl/AtlApplicationPluginStartup.hpp>

Static Public Member Functions

static void | InitPlugins (const Table *)

Data Structures

struct | Table

Member Function Documentation

void AtlApplicationPluginStartup::InitPlugins ( const Table * ) [static]

The documentation for this class was generated from the following files:
  • Atl/AtlApplicationPluginStartup.hpp
  • Atl/AtlApplicationPluginStartup.cpp
Generated on Wed Jan 25 00:56:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlApplicationPluginStartup::Table Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
AtlApplicationPluginStartup::Table

AtlApplicationPluginStartup::Table Struct Reference

#include <Apoxi/Atl/AtlApplicationPluginStartup.hpp>

Collaboration diagram for AtlApplicationPluginStartup::Table:

[legend]

Data Fields

AtlApplication * app
AtlApplicationPlugin * plugin

Field Documentation

AtlApplication* AtlApplicationPluginStartup::Table::app

AtlApplicationPlugin* AtlApplicationPluginStartup::Table::plugin

The documentation for this struct was generated from the following file:
  • Atl/AtlApplicationPluginStartup.hpp
Generated on Wed Jan 25 00:56:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlConfig Class Reference
[Config]

#include <AtlConfig.hpp>

Collaboration diagram for AtlConfig:

[legend]

Static Public Member Functions

static PropertyEditor * | CreateEditor (const PropertyEditorID &id)
static MenuPool * | GetMenuPool ()
static FeatureItem * | GetPlatformFeatureItem (FeatureID &featureID)

Friends

class | ContextManager

Detailed Description

Allows accessing the configuration for ATL. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static PropertyEditor* AtlConfig::CreateEditor ( const PropertyEditorID & id ) [static]

Returns:
A newly created PropertEditor instance. The receiver must take care of deleting the instance.

static MenuPool* AtlConfig::GetMenuPool ( ) [static]

Returns:
The menu pool.

static FeatureItem* AtlConfig::GetPlatformFeatureItem ( FeatureID & featureID ) [static]

Returns:
A PlatformFeatureItem to be used directly in Menus or on Softkeys.

Friends And Related Function Documentation

friend class ContextManager [friend]

The documentation for this class was generated from the following file:
  • AtlConfig.hpp
Generated on Wed Jan 25 00:56:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlItemBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlItemBox Class Reference
[Components]

#include <Apoxi/Atl/Gui/AtlItemBox.hpp>

Inheritance diagram for AtlItemBox:

[legend]
Collaboration diagram for AtlItemBox:

[legend]

Public Types

enum | { ID = 101 }

Public Member Functions

AtlItemBox (Control *control, Item *item)
AtlItemBox ()
void | Init (Control *control, Item *item)
virtual | ~AtlItemBox ()

Protected Member Functions

virtual void | OnFeatureChanged (Feature *changed_feature, INT property_id)
virtual BOOLEAN | OnMessage (const Message &msg)
Handles FeatureChangedMsg in order to react on state and value changes of the value item's property.
virtual void | Refresh (const Rect &rect=Rect())

Friends

class | FeatureListener

Data Structures

class | FeatureListener

Detailed Description

AtlItemBox handles items of type IndicatorItem in a special way: The box is only part of its parent control, if the feature of the value item is available. If the value of the value item changes, text and icon to be displayed are updated.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from ItemBox.

Constructor & Destructor Documentation

AtlItemBox::AtlItemBox ( )

AtlItemBox::AtlItemBox | ( | Control * | control,
 |  | Item * | item
 | ) |

AtlItemBox::~AtlItemBox ( ) [virtual]

Member Function Documentation

void AtlItemBox::Init | ( | Control * | control,
 |  | Item * | item
 | ) |

Parameters:
control | Parent control where the item box is embedded. Usually the parent control is an instance of the class Window.
item | Item which should be displayed. Changing the properties of this item automatically leads to a redrawing of the item box.

Reimplemented from ItemBox.

void AtlItemBox::OnFeatureChanged | ( | Feature * | changed_feature,
 |  | INT | property_id
 | ) | [protected, virtual]

If the property becomes available, the item box is added to its parent control. If it becomes unavailable, the item box is removed from its parent control. Instead of it, a feature listener is added as dispatcher to the active application. This way, the feature listener is able to add the item box back to the parent control, when the value item's property becomes available, again. In case the property is available, text and icon of the value item must be updated, because the property value has changed.

BOOLEAN AtlItemBox::OnMessage ( const Message & msg ) [protected, virtual]

Handles FeatureChangedMsg in order to react on state and value changes of the value item's property.

Reimplemented from ItemBox.

void AtlItemBox::Refresh ( const Rect & rect = Rect() ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from ItemBox.

Friends And Related Function Documentation

friend class FeatureListener [friend]

The documentation for this class was generated from the following files:
  • Atl/Gui/AtlItemBox.hpp
  • Atl/Gui/AtlItemBox.cpp
Generated on Wed Jan 25 00:56:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlItemGrid Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlItemGrid Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/AtlItemGrid.hpp>

Inheritance diagram for AtlItemGrid:

[legend]
Collaboration diagram for AtlItemGrid:

[legend]

Public Member Functions

AtlItemGrid (Control *parent, AbstractItemContainer *item_cont=0)
AtlItemGrid ()
void | Init (Control *parent, AbstractItemContainer *item_cont=0)
virtual | ~AtlItemGrid ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)

Detailed Description

An item-grid may contain a variable number of items, which are displayed inside a vertically scrollable grid. The number of columns may be adjusted dynamically. If the item-grid only has one column, it behaves like a listbox.

The rendering of the items is defined by an instance of the class AbstractItemRenderer, which may be changed by AbstractAtlItemGrid::SetRenderer.

Constructor & Destructor Documentation

AtlItemGrid::AtlItemGrid ( )

AtlItemGrid::AtlItemGrid | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0
 | ) |

Parameters:
parent | Parent-control, where the AtlItemGrid is attached.
item_cont | Item-container, which specifies the items which should be part of the AbstractAtlItemGrid.

AtlItemGrid::~AtlItemGrid ( ) [virtual]

Member Function Documentation

void AtlItemGrid::Init | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0
 | ) |

Parameters:
parent | Parent-control, where the AtlItemGrid is attached.
item_cont | Item-container, which specifies the items which should be part of the AbstractAtlItemGrid.

Reimplemented from ItemGrid.

BOOLEAN AtlItemGrid::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from AbstractItemGrid.

The documentation for this class was generated from the following files:
  • Compat/AtlItemGrid.hpp
  • Compat/AtlItemGrid.cpp
Generated on Wed Jan 25 00:56:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlItemGridWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlItemGridWindow Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Gui/AtlItemGridWindow.hpp>

Inheritance diagram for AtlItemGridWindow:

[legend]
Collaboration diagram for AtlItemGridWindow:

[legend]

Public Types

enum | { ID = 42 }

Public Member Functions

AtlItemGridWindow (ItemGrid *item_grid)
AtlItemGridWindow ()
virtual const ContextID & | GetContextId () const
INT | GetSelectedIndex () const
Item * | GetSelectedItem () const
void | Init (ItemGrid *item_grid=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetSelectedIndex (INT idx)
virtual | ~AtlItemGridWindow ()
Destructor.

Protected Member Functions

virtual void | ApplyContext ()
INT | GetCurrentDisplayType ()
const ContextID & | GetWindowContextId () const
virtual void | OnClose ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnSelectionChanged ()
every selection change in the containing item grid is handled in this method.

Detailed Description

The AtlItemGridWindow is the base class for AtlItemMenuWindow and AtlItemListWindow and contains the handling of featureitems and contexts. Each FeatureItem can have a specified context id, which overwrites the context of the window. Sub-ItemContainers are not handled.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AtlWindow.

Constructor & Destructor Documentation

AtlItemGridWindow::AtlItemGridWindow ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AtlItemGridWindow::AtlItemGridWindow ( ItemGrid * item_grid )

Constructor

Parameters:
item_grid grid, which will be used. This grid has to be initialized and filled with items. AtlItemMenuWindow uses an ItemMenu, AtlItemListWindow uses an ItemGrid

AtlItemGridWindow::~AtlItemGridWindow ( ) [virtual]

Destructor.

Member Function Documentation

void AtlItemGridWindow::ApplyContext ( ) [protected, virtual]

Apply correct context: if item is a feature_item which has a context, this context is used, if the item_container is a FeatureItemContainer which has a context, this context is used, otherwise context of window is used.

Reimplemented in AtlItemMenuWindow.

const ContextID & AtlItemGridWindow::GetContextId ( ) const [virtual]

See also:
AtlWindow

Reimplemented from AtlWindow.

INT AtlItemGridWindow::GetCurrentDisplayType ( ) [protected]

Returns:
current type of display (TextDisplayType, IconDisplayType, ...)

INT AtlItemGridWindow::GetSelectedIndex ( ) const [inline]

Returns:
index of item, which is currently selected

Item* AtlItemGridWindow::GetSelectedItem ( ) const [inline]

Returns:
item, which is currently selected

const ContextID& AtlItemGridWindow::GetWindowContextId ( ) const [inline, protected]

void AtlItemGridWindow::Init ( ItemGrid * item_grid = 0 )

Initialize AtlItemGridWindow

Parameters:
item_grid item_grid (fully initialized), which will be used

BOOLEAN AtlItemGridWindow::IsInstanceOf ( INT id ) const [virtual]

See also:
Window

Reimplemented from AtlWindow.

Reimplemented in AtlItemListWindow, and AtlItemMenuWindow.

void AtlItemGridWindow::OnClose ( ) [protected, virtual]

See also:
Control::OnClose

Reimplemented from Window.

void AtlItemGridWindow::OnGetFocus ( ) [protected, virtual]

When getting the focus, the correct context id has to be set. This can be the context of the selected FeatureItem, the context of the current FeatureItemContainer or the context of the window.

Reimplemented from AtlWindow.

Reimplemented in BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, and UibFolderWin.

BOOLEAN AtlItemGridWindow::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from AtlWindow.

Reimplemented in AtlItemMenuWindow.

BOOLEAN AtlItemGridWindow::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from AtlWindow.

Reimplemented in AtlItemMenuWindow, AtlLabelListWindow, and UibFolderWin.

void AtlItemGridWindow::OnOpen ( ) [protected, virtual]

See also:
Control::OnOpen

Reimplemented from AtlWindow.

Reimplemented in AtlItemListWindow, AtlItemMenuWindow, AtlLabelListWindow, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, BtDeviceListWindow, FmRadioSelectStrongerFreq, and UibFolderWin.

void AtlItemGridWindow::OnSelectionChanged ( ) [protected, virtual]

every selection change in the containing item grid is handled in this method.

Reimplemented in AtlItemListWindow, AtlItemMenuWindow, AtlLabelListWindow, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, and UibFolderWin.

void AtlItemGridWindow::SetSelectedIndex ( INT idx )

Set selected Item (if the window is not open, the index is stored and set when opening it)

Parameters:
idx index of item which should be selected

The documentation for this class was generated from the following files:
  • Atl/Gui/AtlItemGridWindow.hpp
  • Atl/Gui/AtlItemGridWindow.cpp
Generated on Wed Jan 25 00:56:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlItemListWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlItemListWindow Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Gui/AtlItemListWindow.hpp>

Inheritance diagram for AtlItemListWindow:

[legend]
Collaboration diagram for AtlItemListWindow:

[legend]

Public Types

enum | { ID = 41 }

Public Member Functions

AtlItemListWindow (AbstractItemContainer *item_container)
AtlItemListWindow ()
AbstractItemContainer * | GetItemContainer () const
ItemGrid & GetList ()
INT | GetSelectedRow () const
void | Init (AbstractItemContainer *item_container=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetItemContainer (AbstractItemContainer *item_container)
void | SetSelectedRow (INT idx)
virtual | ~AtlItemListWindow ()
destructor

Protected Member Functions

virtual void | OnOpen ()
virtual void | OnSelectionChanged ()
Notifies Context Manager about selection change events.

Detailed Description

AtlItemListWindow is a basic list window containing an AtlItemGrid. An item container must be set, which contains the items for the AtlItemGrid.

See also:
ContextManager

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AtlItemGridWindow.

Constructor & Destructor Documentation

AtlItemListWindow::AtlItemListWindow ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

AtlItemListWindow::AtlItemListWindow ( AbstractItemContainer * item_container )

Constructor

Parameters:
item_container itemcontainer, which will be used.

AtlItemListWindow::~AtlItemListWindow ( ) [virtual]

destructor

Member Function Documentation

AbstractItemContainer* AtlItemListWindow::GetItemContainer ( ) const [inline]

Returns:
ItemContainer, which is used in AtlItemListWindow

ItemGrid& AtlItemListWindow::GetList ( ) [inline]

Returns:
ItemGrid control

INT AtlItemListWindow::GetSelectedRow ( ) const [inline]

Returns:
row which is currently selected

void AtlItemListWindow::Init ( AbstractItemContainer * item_container = 0 )

Initialize AtlItemListWindow

Parameters:
item_container item_container, which will be used

BOOLEAN AtlItemListWindow::IsInstanceOf ( INT id ) const [virtual]

See also:
Window

Reimplemented from AtlItemGridWindow.

void AtlItemListWindow::OnOpen ( ) [protected, virtual]

See also:
Control::OnOpen

Reimplemented from AtlItemGridWindow.

Reimplemented in AtlLabelListWindow, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, BtDeviceListWindow, FmRadioSelectStrongerFreq, and UibFolderWin.

void AtlItemListWindow::OnSelectionChanged ( ) [protected, virtual]

Notifies Context Manager about selection change events.

Reimplemented from AtlItemGridWindow.

Reimplemented in AtlLabelListWindow, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, and UibFolderWin.

void AtlItemListWindow::SetItemContainer ( AbstractItemContainer * item_container )

Parameters:
item_container ItemContainer, which should be used (displayed)

void AtlItemListWindow::SetSelectedRow ( INT idx )

This method calls SetSelectedIndex(idx) of AtlItemGridWindow.

See also:
AtlItemGridWindow::SetSelectedIndex(idx)

The documentation for this class was generated from the following files:
  • Atl/Gui/AtlItemListWindow.hpp
  • Atl/Gui/AtlItemListWindow.cpp
Generated on Wed Jan 25 00:56:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlItemMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlItemMenu Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/AtlItemMenu.hpp>

Inheritance diagram for AtlItemMenu:

[legend]
Collaboration diagram for AtlItemMenu:

[legend]

Public Member Functions

AtlItemMenu (Control *parent, AbstractItemContainer *item_cont=0, BOOLEAN adjust_win_title=FALSE)
AtlItemMenu ()
virtual | ~AtlItemMenu ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)

Detailed Description

Extends the item-grid to allow traversing a hierarchical menu. A menu is defined by an instance of the class ItemContainer, which may contain a variable number of items. As an ItemContainer is also an instance of the class Item, it is possible to recursively embedd item-containers inside other item-containers, which leads to a hierarchical item-tree.

Constructor & Destructor Documentation

AtlItemMenu::AtlItemMenu ( )

AtlItemMenu::AtlItemMenu | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0,
 |  | BOOLEAN | adjust_win_title = FALSE
 | ) |

Parameters:
parent | Parent-control, where the ItemMenu is attached.
item_cont | Item-container, which specifies the items which should be part of the AbstractItemGrid.
adjust_win_title | If set to TRUE, the title of the window where the item-menu is embedded will be adjusted automatically to the text of the currently shown item-container.

AtlItemMenu::~AtlItemMenu ( ) [virtual]

Member Function Documentation

BOOLEAN AtlItemMenu::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from AbstractItemGrid.

The documentation for this class was generated from the following files:
  • Compat/AtlItemMenu.hpp
  • Compat/AtlItemMenu.cpp
Generated on Wed Jan 25 00:56:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlItemMenuWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlItemMenuWindow Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Gui/AtlItemMenuWindow.hpp>

Inheritance diagram for AtlItemMenuWindow:

[legend]
Collaboration diagram for AtlItemMenuWindow:

[legend]

Public Types

enum | { ID = 40 }

Public Member Functions

AtlItemMenuWindow (const MenuID &menu_id)
AtlItemMenuWindow ()
Standard Constructor.
const MenuID & | GetMenuID ()
INT | GetMenuType ()
void | Init (const MenuID &menu_id)
void | Init ()
Initialize AtlItemMenuWindow.
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetMenuID (const MenuID &menu_id)
void | SetParentWindow (Window *win)
virtual | ~AtlItemMenuWindow ()
Destructor.

Protected Member Functions

virtual void | ApplyContext ()
ItemMenu * GetMenu ()
virtual void | OnContextSwitched ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnSelectionChanged ()
void | TriggerMenuItem (INT idx)

Detailed Description

AtlItemMenuWindow is a special atl window which handles feature items and feature item containers. It is used to display full sized menus and popup menus. It must be parameterized with a MenuID. With this MenuID, it gets the corresponding feature item container from the static menu pool. The AtlItemMenuWindow uses an ItemMenu of Apoxi/Gui to display the feature item container and it's feature items. Each menu entry (FeatureItem or FeatureItemContainer) can have a specified context id, which overwrites the context of the window.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AtlItemGridWindow.

Constructor & Destructor Documentation

AtlItemMenuWindow::AtlItemMenuWindow ( )

Standard Constructor.

AtlItemMenuWindow::AtlItemMenuWindow ( const MenuID & menu_id )

Constructor

Parameters:
menu_id menu, which will be used

AtlItemMenuWindow::~AtlItemMenuWindow ( ) [virtual]

Destructor.

Member Function Documentation

void AtlItemMenuWindow::ApplyContext ( ) [protected, virtual]

See also:
AtlItemGridWindow

Reimplemented from AtlItemGridWindow.

ItemMenu* AtlItemMenuWindow::GetMenu ( ) [inline, protected]

Returns:
item menu, which is used in AtlItemMenuWindow

const MenuID& AtlItemMenuWindow::GetMenuID ( ) [inline]

Returns:
id of menu, which is used in AtlItemMenuWindow

INT AtlItemMenuWindow::GetMenuType ( ) [inline]

Returns:
type of menu, FullSize or PopUp

void AtlItemMenuWindow::Init ( const MenuID & menu_id )

Initialize AtlItemMenuWindow

Parameters:
menu_id menu, which will be used

void AtlItemMenuWindow::Init ( )

Initialize AtlItemMenuWindow.

BOOLEAN AtlItemMenuWindow::IsInstanceOf ( INT id ) const [virtual]

See also:
Window

Reimplemented from AtlItemGridWindow.

void AtlItemMenuWindow::OnContextSwitched ( ) [protected, virtual]

See also:
AtlWindow

Reimplemented from AtlWindow.

BOOLEAN AtlItemMenuWindow::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control

Reimplemented from AtlItemGridWindow.

void AtlItemMenuWindow::OnLoseFocus ( ) [protected, virtual]

Before opening an AtlItemMenuWindow the foreground window of the active application is set as parent window. If the parent window is closed (eg. active call gets disconnected) the AtlItemMenuWindow should also be closed.

Reimplemented from AtlWindow.

BOOLEAN AtlItemMenuWindow::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher

Reimplemented from AtlItemGridWindow.

void AtlItemMenuWindow::OnOpen ( ) [protected, virtual]

See also:
Control

Reimplemented from AtlItemGridWindow.

void AtlItemMenuWindow::OnSelectionChanged ( ) [protected, virtual]

See also:
AtlItemGridWindow

Reimplemented from AtlItemGridWindow.

void AtlItemMenuWindow::SetMenuID ( const MenuID & menu_id )

Parameters:
menu_id menu, which will be used

void AtlItemMenuWindow::SetParentWindow ( Window * win ) [inline]

Parameters:
win window, which is opening a popup menu (if AtlItemMenuWindow is used as popup-menu)

void AtlItemMenuWindow::TriggerMenuItem ( INT idx ) [protected]

Triggers a menu item in the AtlItemMenuWindow

Parameters:
idx idx, which menu item has to be triggered

The documentation for this class was generated from the following files:
  • Atl/Gui/AtlItemMenuWindow.hpp
  • Atl/Gui/AtlItemMenuWindow.cpp
Generated on Wed Jan 25 00:56:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlItemRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlItemRenderer Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/AtlItemRenderer.hpp>

Inheritance diagram for AtlItemRenderer:

[legend]
Collaboration diagram for AtlItemRenderer:

[legend]

Public Member Functions

AtlItemRenderer (const ItemRendererProperties *properties=0)
virtual void | DrawBackground (DeviceContext *dc, const Item &item, const Rect &bounds, INT item_style) const
virtual void | DrawItem (DeviceContext *dc, const Item &item, const Rect &bounds, INT item_style) const
virtual Rect | GetIconRect (const Item &item, const Rect &bounds) const
virtual BOOLEAN | StartTextScrolling (const Item &item, const Rect &bounds) const
virtual void | StopTextScrolling (const Item &item) const
virtual | ~AtlItemRenderer ()

Detailed Description

The atl item-renderer is a singleton which may be shared by several item-grids. The atl-item-renderer automatically scrolls the text of the selected item, if it does not fit into the boundaries.

Constructor & Destructor Documentation

AtlItemRenderer::AtlItemRenderer ( const ItemRendererProperties * properties = 0 )

AtlItemRenderer::~AtlItemRenderer ( ) [virtual]

Member Function Documentation

void AtlItemRenderer::DrawBackground | ( | DeviceContext * | dc,
 |  | const Item & | item,
 |  | const Rect & | bounds,
 |  | INT | item_style
 | ) | const [virtual]

See also:
AbstractItemRenderer::DrawBackground

Reimplemented from DefaultItemRenderer.

void AtlItemRenderer::DrawItem | ( | DeviceContext * | dc,
 |  | const Item & | item,
 |  | const Rect & | bounds,
 |  | INT | item_style
 | ) | const [virtual]

See also:
AbstractItemRenderer::DrawItem

Reimplemented from DefaultItemRenderer.

Rect AtlItemRenderer::GetIconRect | ( | const Item & | item,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AbstractItemRenderer::GetIconRect

Reimplemented from DefaultItemRenderer.

BOOLEAN AtlItemRenderer::StartTextScrolling | ( | const Item & | item,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AbstractItemRenderer::StartTextScrolling

Reimplemented from DefaultItemRenderer.

void AtlItemRenderer::StopTextScrolling ( const Item & item ) const [virtual]

See also:
AbstractItemRenderer::StopTextScrolling

Reimplemented from DefaultItemRenderer.

The documentation for this class was generated from the following files:
  • Compat/AtlItemRenderer.hpp
  • Compat/AtlItemRenderer.cpp
Generated on Wed Jan 25 00:56:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlLabelListWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlLabelListWindow Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Gui/AtlLabelListWindow.hpp>

Inheritance diagram for AtlLabelListWindow:

[legend]
Collaboration diagram for AtlLabelListWindow:

[legend]

Public Member Functions

AtlLabelListWindow (AbstractItemContainer *item_container, const Item &label, BOOLEAN is_numbered=TRUE)
AtlLabelListWindow ()
const Item & | GetLabel ()
void | Init (AbstractItemContainer *item_container, const Item &label, BOOLEAN is_numbered=TRUE)
void | SetLabel (const Item &label)
virtual | ~AtlLabelListWindow ()

Protected Member Functions

virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnSelectionChanged ()
Notifies Context Manager about selection change events.

Detailed Description

Obsolete with APOXI 2.9 The AtlLabelListWindow adds a label to the list entries. The items are displayed one by one (only one item is visible on the screen) together with the specified label. As this is a very specific solution, which cannot meet all customer requirements, the AtlLabelListWindow is now marked as obsolete and will not be maintained anymore. The concrete requirements for such a window are highly customer dependent, hence the desired behaviour should be provided by the MMI itself

Constructor & Destructor Documentation

AtlLabelListWindow::AtlLabelListWindow ( )

AtlLabelListWindow::AtlLabelListWindow | ( | AbstractItemContainer * | item_container,
 |  | const Item & | label,
 |  | BOOLEAN | is_numbered = TRUE
 | ) |

AtlLabelListWindow::~AtlLabelListWindow ( ) [virtual]

Member Function Documentation

const Item& AtlLabelListWindow::GetLabel ( ) [inline]

void AtlLabelListWindow::Init | ( | AbstractItemContainer * | item_container,
 |  | const Item & | label,
 |  | BOOLEAN | is_numbered = TRUE
 | ) |

void AtlLabelListWindow::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Window.

BOOLEAN AtlLabelListWindow::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from AtlItemGridWindow.

void AtlLabelListWindow::OnOpen ( ) [protected, virtual]

See also:
Control::OnOpen

Reimplemented from AtlItemListWindow.

void AtlLabelListWindow::OnSelectionChanged ( ) [protected, virtual]

Notifies Context Manager about selection change events.

Reimplemented from AtlItemListWindow.

void AtlLabelListWindow::SetLabel ( const Item & label )

The documentation for this class was generated from the following files:
  • Atl/Gui/AtlLabelListWindow.hpp
  • Atl/Gui/AtlLabelListWindow.cpp
Generated on Wed Jan 25 00:56:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtlWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtlWindow Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/AtlWindow.hpp>

Inheritance diagram for AtlWindow:

[legend]
Collaboration diagram for AtlWindow:

[legend]

Public Types

enum | { ID = 39 }

Public Member Functions

AtlWindow ()
virtual const ContextID & | GetContextId () const
Dispatcher * GetDispatcher ()
void | Init (Dispatcher *dispatcher=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetContextId (const CHAR *id)
void | SetContextId (const ContextID &id)
virtual void | SetDefaultSize ()
void | SetDispatcher (Dispatcher *dispatcher)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual void | SetSoftkey (INT index, Action *action)
virtual void | SetTitle (const WCHAR *title)
virtual | ~AtlWindow ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
only for APOXI Tester compatiblity
virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnContextSwitched ()
method is a hook for derived classes to notify context switches
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLanguageChanged ()
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnThemeChanged ()

Detailed Description

Represents the template window use by the MMI. Extends the class window with the ability to dispatch IDEA contexts.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Window.

Constructor & Destructor Documentation

AtlWindow::AtlWindow ( )

AtlWindow::~AtlWindow ( ) [virtual]

Member Function Documentation

virtual const ContextID& AtlWindow::GetContextId ( ) const [inline, virtual]

This method is virtual because in some cases (e.g. AtlItemGridWindow) the contextid has to be calculated.

Returns:
ContextId which is currently active

Reimplemented in AtlItemGridWindow.

Dispatcher* AtlWindow::GetDispatcher ( ) [inline]

void AtlWindow::Init ( Dispatcher * dispatcher = 0 )

The window can be initialized with a dispatcher (e.g. a Plugin), which will be provided by messages send to the AtlWindow.

BOOLEAN AtlWindow::IsInstanceOf ( INT id ) const [virtual]

See also:
Window

Reimplemented from Window.

Reimplemented in AtlItemGridWindow, AtlItemListWindow, and AtlItemMenuWindow.

void AtlWindow::OnActionExecuted ( Action * action ) [protected, virtual]

only for APOXI Tester compatiblity

Reimplemented from Window.

BOOLEAN AtlWindow::OnCancel ( ) [protected, virtual]

Reimplemented in PropertyEditor, FmRadioSelectStrongerFreq, and ImageBrowserDetailWin.

BOOLEAN AtlWindow::OnConfirm ( ) [protected, virtual]

Reimplemented in BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, and FmRadioSelectStrongerFreq.

void AtlWindow::OnContextSwitched ( ) [protected, virtual]

method is a hook for derived classes to notify context switches

Reimplemented in AtlItemMenuWindow.

void AtlWindow::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from Window.

Reimplemented in AtlItemGridWindow, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, SmsViewerWin, and UibFolderWin.

BOOLEAN AtlWindow::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from Window.

Reimplemented in AtlItemGridWindow, AtlItemMenuWindow, PropertyEditor, and ImageBrowserDetailWin.

void AtlWindow::OnLanguageChanged ( ) [protected, virtual]

See also:
Component::OnLanguageChanged

Reimplemented from Window.

void AtlWindow::OnLoseFocus ( ) [protected, virtual]

See also:
Control::OnLoseFocus

Reimplemented from Window.

Reimplemented in AtlItemMenuWindow.

BOOLEAN AtlWindow::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Window.

Reimplemented in AtlItemGridWindow, AtlItemMenuWindow, AtlLabelListWindow, and UibFolderWin.

void AtlWindow::OnOpen ( ) [protected, virtual]

See also:
Window::OnOpen

Reimplemented from Window.

Reimplemented in AtlItemGridWindow, AtlItemListWindow, AtlItemMenuWindow, AtlLabelListWindow, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, BtDeviceListWindow, SmsComposeWin, FmRadioSelectStrongerFreq, ImageBrowserDetailWin, and UibFolderWin.

void AtlWindow::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged

Reimplemented from Window.

void AtlWindow::SetContextId ( const CHAR * id )

void AtlWindow::SetContextId ( const ContextID & id )

void AtlWindow::SetDefaultSize ( ) [virtual]

See also:
Window::SetDefaultSize

Reimplemented from Window.

void AtlWindow::SetDispatcher ( Dispatcher * dispatcher ) [inline]

BOOLEAN AtlWindow::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from Window.

void AtlWindow::SetSoftkey | ( | INT | index,
 |  | Action * | action
 | ) | [virtual]

See also:
Window::SetSoftkey

Reimplemented from Window.

void AtlWindow::SetTitle ( const WCHAR * title ) [virtual]

See also:
Window::SetTitle

Reimplemented from Window.

The documentation for this class was generated from the following files:
  • Atl/AtlWindow.hpp
  • Atl/AtlWindow.cpp
Generated on Wed Jan 25 00:56:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtomItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtomItem Class Reference
[Editors]

#include <Apoxi/Gui/AtomItem.hpp>

Inheritance diagram for AtomItem:

[legend]
Collaboration diagram for AtomItem:

[legend]

Public Types

enum | { ID = 0 }

Public Member Functions

AtomItem ()
virtual AtomItem * | Clone () const =0
virtual void | Draw (DeviceContext *dc, const Rect &bounds) const =0
Draws the item in the specified bounding-rectangle.
virtual INT | GetId () const
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual | ~AtomItem ()

Detailed Description

Base class for atomar items which can be inserted into the document of the editor. An Atom-Item can not be wrapped or splitted. Every item can be drawn on a specified position and may get cloned.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtomItem::AtomItem ( )

AtomItem::~AtomItem ( ) [virtual]

Member Function Documentation

virtual AtomItem* AtomItem::Clone ( ) const [pure virtual]

Returns:
A pointer to a copy of this object. It is in the hand of the implementation of derived classes, whether a flat copy or deep copy is made. Read the documentation to Clone in the corresponding class for further details.

Implemented in AudioItem, ImageItem, VCardItem, SoundItem, and CharItem.

virtual void AtomItem::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds
 | ) | const [pure virtual]

Draws the item in the specified bounding-rectangle.

Implemented in AudioItem, ImageItem, VCardItem, SoundItem, and CharItem.

INT AtomItem::GetId ( ) const [virtual]

See also:
AbstractEditorItem::GetId

Implements AbstractEditorItem.

Reimplemented in AudioItem, BoundedItem, ImageItem, VCardItem, SoundItem, and CharItem.

BOOLEAN AtomItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Implements AbstractEditorItem.

Reimplemented in AudioItem, BoundedItem, ImageItem, VCardItem, SoundItem, and CharItem.

The documentation for this class was generated from the following files:
  • Gui/AtomItem.hpp
  • Gui/AtomItem.cpp
Generated on Wed Jan 25 00:56:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtPbInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtPbInfoIndArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtPbInfoIndArg:

[legend]
Collaboration diagram for AtPbInfoIndArg:

[legend]

Public Types

enum | { ID = 2153 }

Public Member Functions

AtPbInfoIndArg ()
AtPbInfoIndArg (const MePhonebookDescription &desc)
const MePhonebookDescription & | GetDesc () const
void | SetDesc (const MePhonebookDescription &desc)

Static Public Member Functions

static const AtPbInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtPbInfoIndArg : reflects arguments of signal MIAT_PB_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtPbInfoIndArg::AtPbInfoIndArg ( const MePhonebookDescription & desc )

AtPbInfoIndArg::AtPbInfoIndArg ( )

Member Function Documentation

const AtPbInfoIndArg & AtPbInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MePhonebookDescription& AtPbInfoIndArg::GetDesc ( ) const [inline]

void AtPbInfoIndArg::SetDesc ( const MePhonebookDescription & desc ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtPbListCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtPbListCnfArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtPbListCnfArg:

[legend]
Collaboration diagram for AtPbListCnfArg:

[legend]

Public Types

enum | { ID = 2152 }

Public Member Functions

AtPbListCnfArg ()
AtPbListCnfArg (const MePhoneBookStatus &status, const MePhoneBookType &me_phone_book_type, INT record_number, const WString &alpha_identifier, const PhoneNumber &phone_number)
const WString & | GetAlphaIdentifier () const
const MePhoneBookType & | GetMePhoneBookType () const
const PhoneNumber & | GetPhoneNumber () const
INT | GetRecordNumber () const
const MePhoneBookStatus & | GetStatus () const
void | SetAlphaIdentifier (const WString &alpha_identifier)
void | SetMePhoneBookType (const MePhoneBookType &me_phone_book_type)
void | SetPhoneNumber (const PhoneNumber &phone_number)
void | SetRecordNumber (INT record_number)
void | SetStatus (const MePhoneBookStatus &status)

Static Public Member Functions

static const AtPbListCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtPbListCnfArg : reflects arguments of signal MIAT_PB_LIST_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtPbListCnfArg::AtPbListCnfArg | ( | const MePhoneBookStatus & | status,
 |  | const MePhoneBookType & | me_phone_book_type,
 |  | INT | record_number,
 |  | const WString & | alpha_identifier,
 |  | const PhoneNumber & | phone_number
 | ) |

AtPbListCnfArg::AtPbListCnfArg ( )

Member Function Documentation

const AtPbListCnfArg & AtPbListCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& AtPbListCnfArg::GetAlphaIdentifier ( ) const [inline]

const MePhoneBookType& AtPbListCnfArg::GetMePhoneBookType ( ) const [inline]

const PhoneNumber& AtPbListCnfArg::GetPhoneNumber ( ) const [inline]

INT AtPbListCnfArg::GetRecordNumber ( ) const [inline]

const MePhoneBookStatus& AtPbListCnfArg::GetStatus ( ) const [inline]

void AtPbListCnfArg::SetAlphaIdentifier ( const WString & alpha_identifier ) [inline]

void AtPbListCnfArg::SetMePhoneBookType ( const MePhoneBookType & me_phone_book_type ) [inline]

void AtPbListCnfArg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

void AtPbListCnfArg::SetRecordNumber ( INT record_number ) [inline]

void AtPbListCnfArg::SetStatus ( const MePhoneBookStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtPbListReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtPbListReqArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtPbListReqArg:

[legend]
Collaboration diagram for AtPbListReqArg:

[legend]

Public Types

enum | { ID = 1152 }

Public Member Functions

AtPbListReqArg ()
const MePhoneBookType & | GetMePhoneBookType () const
INT | GetRecordNumber () const
void | SetMePhoneBookType (const MePhoneBookType &me_phone_book_type)
void | SetRecordNumber (INT record_number)

Static Public Member Functions

static const AtPbListReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtPbListReqArg : reflects arguments of signal ATMI_PB_LIST_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtPbListReqArg::AtPbListReqArg ( )

Member Function Documentation

const AtPbListReqArg & AtPbListReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MePhoneBookType& AtPbListReqArg::GetMePhoneBookType ( ) const [inline]

INT AtPbListReqArg::GetRecordNumber ( ) const [inline]

void AtPbListReqArg::SetMePhoneBookType ( const MePhoneBookType & me_phone_book_type ) [inline]

void AtPbListReqArg::SetRecordNumber ( INT record_number ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtPbSelectCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtPbSelectCnfArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtPbSelectCnfArg:

[legend]
Collaboration diagram for AtPbSelectCnfArg:

[legend]

Public Types

enum | { ID = 2151 }

Public Member Functions

AtPbSelectCnfArg ()
AtPbSelectCnfArg (const MePhoneBookStatus &status, const MePhoneBookType &me_phone_book_type, INT used_entries, INT total_entries, INT max_alpha_length)
INT | GetMaxAlphaLength () const
const MePhoneBookType & | GetMePhoneBookType () const
const MePhoneBookStatus & | GetStatus () const
INT | GetTotalEntries () const
INT | GetUsedEntries () const
void | SetMaxAlphaLength (INT max_alpha_length)
void | SetMePhoneBookType (const MePhoneBookType &me_phone_book_type)
void | SetStatus (const MePhoneBookStatus &status)
void | SetTotalEntries (INT total_entries)
void | SetUsedEntries (INT used_entries)

Static Public Member Functions

static const AtPbSelectCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtPbSelectCnfArg : reflects arguments of signal MIAT_PB_SELECT_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtPbSelectCnfArg::AtPbSelectCnfArg | ( | const MePhoneBookStatus & | status,
 |  | const MePhoneBookType & | me_phone_book_type,
 |  | INT | used_entries,
 |  | INT | total_entries,
 |  | INT | max_alpha_length
 | ) |

AtPbSelectCnfArg::AtPbSelectCnfArg ( )

Member Function Documentation

const AtPbSelectCnfArg & AtPbSelectCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT AtPbSelectCnfArg::GetMaxAlphaLength ( ) const [inline]

const MePhoneBookType& AtPbSelectCnfArg::GetMePhoneBookType ( ) const [inline]

const MePhoneBookStatus& AtPbSelectCnfArg::GetStatus ( ) const [inline]

INT AtPbSelectCnfArg::GetTotalEntries ( ) const [inline]

INT AtPbSelectCnfArg::GetUsedEntries ( ) const [inline]

void AtPbSelectCnfArg::SetMaxAlphaLength ( INT max_alpha_length ) [inline]

void AtPbSelectCnfArg::SetMePhoneBookType ( const MePhoneBookType & me_phone_book_type ) [inline]

void AtPbSelectCnfArg::SetStatus ( const MePhoneBookStatus & status ) [inline]

void AtPbSelectCnfArg::SetTotalEntries ( INT total_entries ) [inline]

void AtPbSelectCnfArg::SetUsedEntries ( INT used_entries ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtPbSelectReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtPbSelectReqArg Class Reference

#include <Apoxi/Apc/AtcStackMsgArgs.hpp>

Inheritance diagram for AtPbSelectReqArg:

[legend]
Collaboration diagram for AtPbSelectReqArg:

[legend]

Public Types

enum | { ID = 1151 }

Public Member Functions

AtPbSelectReqArg ()
const MePhoneBookType & | GetMePhoneBookType () const
void | SetMePhoneBookType (const MePhoneBookType &me_phone_book_type)

Static Public Member Functions

static const AtPbSelectReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AtPbSelectReqArg : reflects arguments of signal ATMI_PB_SELECT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AtPbSelectReqArg::AtPbSelectReqArg ( )

Member Function Documentation

const AtPbSelectReqArg & AtPbSelectReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MePhoneBookType& AtPbSelectReqArg::GetMePhoneBookType ( ) const [inline]

void AtPbSelectReqArg::SetMePhoneBookType ( const MePhoneBookType & me_phone_book_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/AtcStackMsgArgs.hpp
  • Apc/AtcStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtResponse Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtResponse Class Reference

#include <Apoxi/AddOns/MmCall/AtResponse.hpp>

Collaboration diagram for AtResponse:

[legend]

Public Types

enum ResponseType {
Ok, Connect, Ring, NoCarrier,
Error, NoDialtone, Busy, NoAnswer,
Calv, Ccwa, Ccwv, Cdev,
Cdip, Ciev, Ckev, Clav,
Clip, CmeError, Colp, Cr,
Creg, Cring, Cssi, Cssu,
Ctzv, Cusd, Clcc, Cuus1i,
Cuus1u, Dr, Ilrr, Xcallstat,
Xcallinfo, Xceer, Xcallrefuse, Xprogress,
Cgact, Xcaoc, Xcharge, Xcccm,
Xccharge, XaocService, UnknownResponse, FatalError
}
Type of AT respnse, e.g. OK, CONNECT etc. More...

Public Member Functions

AtResponse (const AtResponse &response)
Copy Constructor.
AtResponse ()
Constructor.
INT | GetNrOfParameters () const
Get number of parameters.
const AtResponseParameter & | GetParameterAt (const UINT8 index) const
ResponseType | GetResponseType () const
Get response type.
AtResponse & | operator= (const AtResponse &response)
Assignment Operator.
void | SetResponseType (ResponseType type)
Set response type.
~AtResponse ()
Destructor.

Static Public Member Functions

static const String | GetResponseString (AtResponse::ResponseType type)
Returns the string of a response of the given type.

Data Fields

friend | AtResponseIterator

Detailed Description

Holds structured information about an AT response, like response type, number of parameters, parameter values of response. NOTE: It is not allowed to derive from AtResponseParameter (no virtual destructor).

Member Enumeration Documentation

enum AtResponse::ResponseType

Type of AT respnse, e.g. OK, CONNECT etc.

Enumerator:
Ok
Connect
Ring
NoCarrier
Error
NoDialtone
Busy
NoAnswer
Calv
Ccwa
Ccwv
Cdev
Cdip
Ciev
Ckev
Clav
Clip
CmeError
Colp
Cr
Creg
Cring
Cssi
Cssu
Ctzv
Cusd
Clcc
Cuus1i
Cuus1u
Dr
Ilrr
Xcallstat
Xcallinfo
Xceer
Xcallrefuse
Xprogress
Cgact
Xcaoc
Xcharge
Xcccm
Xccharge
XaocService
UnknownResponse | Is set if the response that has been received is not in the list of response types.
FatalError | Is returned if something unexpected happens - default value of AtResponse.

Constructor & Destructor Documentation

AtResponse::AtResponse ( )

Constructor.

AtResponse::AtResponse ( const AtResponse & response )

Copy Constructor.

AtResponse::~AtResponse ( )

Destructor.

Member Function Documentation

INT AtResponse::GetNrOfParameters ( ) const [inline]

Get number of parameters.

const AtResponseParameter& AtResponse::GetParameterAt ( const UINT8 index ) const [inline]

Get the parameter of response at position index

Parameters:
index Index of returned parameter
Returns:
Pointer to Object holding parameter or 0 if index is out of bounds, or the parameter value is empty (e.g. AT response contained ",,")

const String AtResponse::GetResponseString ( AtResponse::ResponseType type ) [static]

Returns the string of a response of the given type.

ResponseType AtResponse::GetResponseType ( ) const [inline]

Get response type.

AtResponse & AtResponse::operator= ( const AtResponse & response )

Assignment Operator.

void AtResponse::SetResponseType ( ResponseType type ) [inline]

Set response type.

Field Documentation

friend AtResponse::AtResponseIterator

The documentation for this class was generated from the following files:
  • AddOns/MmCall/AtResponse.hpp
  • AddOns/MmCall/AtResponse.cpp
Generated on Wed Jan 25 00:56:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtResponseInfoTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtResponseInfoTable Struct Reference

#include <Apoxi/AddOns/MmCall/AtResponse.hpp>

Collaboration diagram for AtResponseInfoTable:

[legend]

Static Public Member Functions

static const AtResponseMetaInfo * | GetElementAt (INT index)
static INT | GetNumberOfEntries ()

Detailed Description

Class that holds the response information and is able to return the number of entries.

Member Function Documentation

static const AtResponseMetaInfo* AtResponseInfoTable::GetElementAt ( INT index ) [inline, static]

Returns the element at position index

Parameters:
index element's position in the AtResponseInfoTable that should be retrieved.
Returns:
element identified by index.

static INT AtResponseInfoTable::GetNumberOfEntries ( ) [inline, static]

Returns the number of entries available in the AtResponseInfoTable

Returns:
number of entries

The documentation for this struct was generated from the following files:
  • AddOns/MmCall/AtResponse.hpp
  • AddOns/MmCall/AtResponse.cpp
Generated on Wed Jan 25 00:56:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtResponseIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtResponseIterator Class Reference

#include <Apoxi/AddOns/MmCall/AtResponseIterator.hpp>

Collaboration diagram for AtResponseIterator:

[legend]

Public Member Functions

AtResponseIterator (SerialTerminal *terminal)
Constructor.
const AtResponse | GetNextResponse ()
BOOLEAN | HasMoreResponses ()
virtual | ~AtResponseIterator ()
Destructor.

Detailed Description

AtResponseIterator provides an iterator like interface to retrieve AT responses. Data is read from a teminal and interpreted as AT response. NOTE: It is not allowed to derive from AtResponseParameter (no virtual destructor).

Constructor & Destructor Documentation

AtResponseIterator::AtResponseIterator ( SerialTerminal * terminal )

Constructor.

AtResponseIterator::~AtResponseIterator ( ) [virtual]

Destructor.

Member Function Documentation

const AtResponse AtResponseIterator::GetNextResponse ( )

Reads date from the socket until the next response delimiter (
) is read, and returns a structured response representing the received response

BOOLEAN AtResponseIterator::HasMoreResponses ( )

Returns false if the last received response was "CONNECT" or no more data for reading is available at the socket

The documentation for this class was generated from the following files:
  • AddOns/MmCall/AtResponseIterator.hpp
  • AddOns/MmCall/AtResponseIterator.cpp
Generated on Wed Jan 25 00:56:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtResponseMetaInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtResponseMetaInfo Struct Reference

Structure to hold responses and their string representation. More...

#include <Apoxi/AddOns/MmCall/AtResponse.hpp>

Data Fields

AtResponse::ResponseType m_response_type
CHAR * m_str_presentation

Detailed Description

Structure to hold responses and their string representation.

Field Documentation

AtResponse::ResponseType AtResponseMetaInfo::m_response_type

CHAR* AtResponseMetaInfo::m_str_presentation

The documentation for this struct was generated from the following file:
  • AddOns/MmCall/AtResponse.hpp
Generated on Wed Jan 25 00:56:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtResponseParameter Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AtResponseParameter Struct Reference

#include <Apoxi/AddOns/MmCall/AtResponse.hpp>

Collaboration diagram for AtResponseParameter:

[legend]

Public Types

enum | ParamType { PtNumeric, PtString, PtNoValue }
Type for parameters - either string, numeric or novalue. More...

Public Member Functions

AtResponseParameter (const AtResponseParameter &parameter)
Copy Constructor.
AtResponseParameter ()
Constructor.
INT32 | GetIntegerValue () const
Return the value of the parameter, interpreted as Integer.
ParamType | GetParameterType () const
Get Parameter type.
const String & | GetStringValue () const
Return the value of the parameter, interpreted as String.
AtResponseParameter & | operator= (const AtResponseParameter &parameter)
Assignment Operator.
~AtResponseParameter ()
Destructor.

Data Fields

friend | AtResponseIterator

Detailed Description

Structure to encapsulate AT response parameters. Response parameters can be either numeric or strings NOTE: It is not allowed to derive from AtResponseParameter (no virtual destructor).

Member Enumeration Documentation

enum AtResponseParameter::ParamType

Type for parameters - either string, numeric or novalue.

Enumerator:
PtNumeric | For all numeric parameters that fit into the range of INT32.
PtString | For all other parameters that have a value.
PtNoValue | Only allowed if the parameter.

Constructor & Destructor Documentation

AtResponseParameter::AtResponseParameter ( )

Constructor.

AtResponseParameter::AtResponseParameter ( const AtResponseParameter & parameter )

Copy Constructor.

AtResponseParameter::~AtResponseParameter ( )

Destructor.

Member Function Documentation

INT32 AtResponseParameter::GetIntegerValue ( ) const [inline]

Return the value of the parameter, interpreted as Integer.

ParamType AtResponseParameter::GetParameterType ( ) const [inline]

Get Parameter type.

const String& AtResponseParameter::GetStringValue ( ) const [inline]

Return the value of the parameter, interpreted as String.

AtResponseParameter & AtResponseParameter::operator= ( const AtResponseParameter & parameter )

Assignment Operator.

Field Documentation

friend AtResponseParameter::AtResponseIterator

The documentation for this struct was generated from the following files:
  • AddOns/MmCall/AtResponse.hpp
  • AddOns/MmCall/AtResponse.cpp
Generated on Wed Jan 25 00:56:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AttachAllowedIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AttachAllowedIndArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for AttachAllowedIndArg:

[legend]
Collaboration diagram for AttachAllowedIndArg:

[legend]

Public Types

enum | { ID = 5365 }

Public Member Functions

AttachAllowedIndArg ()
BOOLEAN | IsAllowed () const
void | SetAllowed (BOOLEAN allowed)

Static Public Member Functions

static const AttachAllowedIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AttachAllowedIndArg: reflects arguments of signal MN_ATTACH_ALLOWED_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AttachAllowedIndArg::AttachAllowedIndArg ( )

Member Function Documentation

const AttachAllowedIndArg & AttachAllowedIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN AttachAllowedIndArg::IsAllowed ( ) const [inline]

void AttachAllowedIndArg::SetAllowed ( BOOLEAN allowed ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AttachCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AttachCnfArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for AttachCnfArg:

[legend]
Collaboration diagram for AttachCnfArg:

[legend]

Public Types

enum | { ID = 5362 }

Public Member Functions

AttachCnfArg ()
const GsmBand & | GetGsmBand () const
const RegisterMode & | GetMode () const
const Plmn & | GetPlmn () const
const RadioAccessTechnology & | GetRadioAccessTechnology () const
void | SetGsmBand (const GsmBand &gsm_band)
void | SetMode (const RegisterMode &mode)
void | SetPlmn (const Plmn &plmn)
void | SetRadioAccessTechnology (const RadioAccessTechnology &radio_access_technology)

Static Public Member Functions

static const AttachCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AttachCnfArg: reflects arguments of signal MN_ATTACH_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AttachCnfArg::AttachCnfArg ( )

Member Function Documentation

const AttachCnfArg & AttachCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GsmBand& AttachCnfArg::GetGsmBand ( ) const [inline]

const RegisterMode& AttachCnfArg::GetMode ( ) const [inline]

const Plmn& AttachCnfArg::GetPlmn ( ) const [inline]

const RadioAccessTechnology& AttachCnfArg::GetRadioAccessTechnology ( ) const [inline]

void AttachCnfArg::SetGsmBand ( const GsmBand & gsm_band ) [inline]

void AttachCnfArg::SetMode ( const RegisterMode & mode ) [inline]

void AttachCnfArg::SetPlmn ( const Plmn & plmn ) [inline]

void AttachCnfArg::SetRadioAccessTechnology ( const RadioAccessTechnology & radio_access_technology ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AttachRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AttachRejArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for AttachRejArg:

[legend]
Collaboration diagram for AttachRejArg:

[legend]

Public Types

enum | { ID = 5363 }

Public Member Functions

AttachRejArg ()
const RegisterRejectCause & | GetCause () const
void | SetCause (const RegisterRejectCause &cause)

Static Public Member Functions

static const AttachRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PlmnRegCnfArg: reflects arguments of signal MN_ATTACH_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AttachRejArg::AttachRejArg ( )

Member Function Documentation

const AttachRejArg & AttachRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const RegisterRejectCause& AttachRejArg::GetCause ( ) const [inline]

void AttachRejArg::SetCause ( const RegisterRejectCause & cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AttachReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AttachReqArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for AttachReqArg:

[legend]
Collaboration diagram for AttachReqArg:

[legend]

Public Types

enum | { ID = 6360 }

Public Member Functions

AttachReqArg ()
AttachReqArg (const RegisterMode &mode, const PlmnIndicator &indicator, const Plmn &plmn, const RadioAccessTechnology &rat)
const PlmnIndicator & | GetIndicator () const
const RegisterMode & | GetMode () const
const Plmn & | GetPlmn () const
const RadioAccessTechnology & | GetRat () const
void | SetIndicator (const PlmnIndicator &indicator)
void | SetMode (const RegisterMode &mode)
void | SetPlmn (const Plmn &plmn)
void | SetRat (const RadioAccessTechnology &rat)

Static Public Member Functions

static const AttachReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AttachReqArg: reflects arguments of signal MN_ATTACH_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AttachReqArg::AttachReqArg | ( | const RegisterMode & | mode,
 |  | const PlmnIndicator & | indicator,
 |  | const Plmn & | plmn,
 |  | const RadioAccessTechnology & | rat
 | ) |

AttachReqArg::AttachReqArg ( )

Member Function Documentation

const AttachReqArg & AttachReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PlmnIndicator& AttachReqArg::GetIndicator ( ) const [inline]

const RegisterMode& AttachReqArg::GetMode ( ) const [inline]

const Plmn& AttachReqArg::GetPlmn ( ) const [inline]

const RadioAccessTechnology& AttachReqArg::GetRat ( ) const [inline]

void AttachReqArg::SetIndicator ( const PlmnIndicator & indicator ) [inline]

void AttachReqArg::SetMode ( const RegisterMode & mode ) [inline]

void AttachReqArg::SetPlmn ( const Plmn & plmn ) [inline]

void AttachReqArg::SetRat ( const RadioAccessTechnology & rat ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 00:56:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Audio Class Reference
[Devices]

#include <Apoxi/Compat/Devices/BP30/Audio.hpp>

Inheritance diagram for Audio:

[legend]
Collaboration diagram for Audio:

[legend]

Public Types

enum AudioDevice {
DeviceNone = 0x0000, DeviceBuzzer = 0x0001, DeviceEarPiece = 0x0002, DeviceTrembler = 0x0004,
DeviceOut = 0x000f, DeviceMic = 0x0010, DeviceIn = 0x00f0
}
enum AudioDevice {
DeviceNone = 0x0000, DeviceBuzzer = 0x0001, DeviceEarPiece = 0x0002, DeviceTrembler = 0x0004,
DeviceOut = 0x000f, DeviceMic = 0x0010, DeviceIn = 0x00f0
}
enum AudioDevice {
DeviceNone = 0x0000, DeviceBuzzer = 0x0001, DeviceEarPiece = 0x0002, DeviceTrembler = 0x0004,
DeviceOut = 0x000f, DeviceMic = 0x0010, DeviceIn = 0x00f0
}
enum AudioDevice {
DeviceNone = 0x0000, DeviceBuzzer = 0x0001, DeviceEarPiece = 0x0002, DeviceTrembler = 0x0004,
DeviceOut = 0x000f, DeviceMic = 0x0010, DeviceIn = 0x00f0
}
enum AudioDevice {
DeviceNone = 0x0000, DeviceBuzzer = 0x0001, DeviceEarPiece = 0x0002, DeviceTrembler = 0x0004,
DeviceOut = 0x000f, DeviceMic = 0x0010, DeviceIn = 0x00f0
}
enum | AudioMode { ModeNormal, ModeHeadset, ModeHandsfree, ModeBluetoothHeadset }
enum | AudioMode { ModeNormal, ModeHeadset, ModeHandsfree }
enum | AudioMode { ModeNormal, ModeHeadset, ModeHandsfree }
enum | AudioMode { ModeNormal, ModeHeadset, ModeHandsfree }
enum | AudioMode { ModeNormal, ModeHeadset, ModeHandsfree }
enum | AudioPriority { PriorityHigh = 3, PriorityMedium = 2, PriorityLow = 1, PriorityNone = 0 }
enum | AudioPriority { PriorityHigh = 3, PriorityMedium = 2, PriorityLow = 1, PriorityNone = 0 }
enum | AudioPriority { PriorityHigh = 3, PriorityMedium = 2, PriorityLow = 1, PriorityNone = 0 }
enum | AudioPriority { PriorityHigh = 3, PriorityMedium = 2, PriorityLow = 1, PriorityNone = 0 }
enum | AudioPriority { PriorityHigh = 3, PriorityMedium = 2, PriorityLow = 1, PriorityNone = 0 }
enum AudioToneId {
ToneDtmf0 = 0, ToneDtmf1, ToneDtmf2, ToneDtmf3,
ToneDtmf4, ToneDtmf5, ToneDtmf6, ToneDtmf7,
ToneDtmf8, ToneDtmf9, ToneDtmfHash, ToneDtmfStar,
ToneSupervisorySubsciberBusy, ToneSupervisoryCongestion, ToneSupervisoryRadioPathAck, ToneSupervisoryRadioPathNotAvail,
ToneSupervisoryError, ToneSupervisoryCallWaiting, ToneInfoFree, ToneInfoLowBat,
ToneInfoConnection, ToneInfoDisconnect, ToneInfoPowerOn, ToneInfoPowerOff,
ToneInfoDeviceIn, ToneInfoDeviceOut, ToneInfoMsgFull, ToneInfoUssd,
ToneKey1, ToneKey2, ToneKey3, ToneKey4,
ToneBroadcast1, ToneBroadcast2, ToneBroadcast3, ToneBroadcast4,
ToneMessage1, ToneMessage2, ToneMessage3, ToneMessage4,
ToneMessage5, ToneMessage6, ToneMessage7, ToneMessage8,
ToneMessage9, ToneMessage10, ToneMessageSingleBeep, ToneRinging1,
ToneRinging2, ToneRinging3, ToneRinging4, ToneRinging5,
ToneRinging6, ToneRinging7, ToneRinging8, ToneRinging9,
ToneRinging10, ToneRinging11, ToneRinging12, ToneRinging13,
ToneRinging14, ToneRinging15, ToneRinging16, ToneRinging17,
ToneRinging18, ToneRinging19, ToneRinging20, ToneRinging21,
ToneRinging22, ToneRinging23, ToneRinging24, ToneRinging25,
ToneRinging26, ToneRinging27, ToneRinging28, ToneRinging29,
ToneRinging30, ToneRinging31, ToneRinging32, ToneRinging33,
ToneRinging34, ToneRinging35, ToneRinging36, ToneRinging37,
ToneRinging38, ToneRinging39, ToneRinging40, ToneRinging41,
ToneRinging42, ToneRinging43, ToneRinging44, ToneRinging45,
ToneRinging46, ToneRinging47, ToneRinging48, ToneUserDefined,
ToneAlarm1, AudioInvalidTone
}
enum AudioToneId {
ToneDtmf0 = 0, ToneDtmf1, ToneDtmf2, ToneDtmf3,
ToneDtmf4, ToneDtmf5, ToneDtmf6, ToneDtmf7,
ToneDtmf8, ToneDtmf9, ToneDtmfHash, ToneDtmfStar,
ToneSupervisorySubsciberBusy, ToneSupervisoryCongestion, ToneSupervisoryRadioPathAck, ToneSupervisoryRadioPathNotAvail,
ToneSupervisoryError, ToneSupervisoryCallWaiting, ToneInfoFree, ToneInfoLowBat,
ToneInfoConnection, ToneInfoDisconnect, ToneInfoPowerOn, ToneInfoPowerOff,
ToneInfoDeviceIn, ToneInfoDeviceOut, ToneInfoMsgFull, ToneInfoUssd,
ToneInfoMinuteBeep, ToneInfoSmsReceived, ToneInfoBroadcast, ToneInfoAlarm,
ToneInfoAutoRedial, ToneInfoNetworkAttention, ToneInfoDialTone, ToneInfoLowBatInCall,
ToneKey1, ToneKey2, ToneKey3, ToneKey4,
ToneBroadcast1, ToneBroadcast2, ToneBroadcast3, ToneBroadcast4,
ToneMessage1, ToneMessage2, ToneMessage3, ToneMessage4,
ToneMessage5, ToneMessage6, ToneMessage7, ToneMessage8,
ToneMessage9, ToneMessage10, ToneMessageSingleBeep, ToneRinging1,
ToneRinging2, ToneRinging3, ToneRinging4, ToneRinging5,
ToneRinging6, ToneRinging7, ToneRinging8, ToneRinging9,
ToneRinging10, ToneRinging11, ToneRinging12, ToneRinging13,
ToneRinging14, ToneRinging15, ToneRinging16, ToneRinging17,
ToneRinging18, ToneRinging19, ToneRinging20, ToneRinging21,
ToneRinging22, ToneRinging23, ToneRinging24, ToneRinging25,
ToneRinging26, ToneRinging27, ToneRinging28, ToneRinging29,
ToneRinging30, ToneRinging31, ToneRinging32, ToneRinging33,
ToneRinging34, ToneRinging35, ToneRinging36, ToneRinging37,
ToneRinging38, ToneRinging39, ToneRinging40, ToneRinging41,
ToneRinging42, ToneRinging43, ToneRinging44, ToneRinging45,
ToneRinging46, ToneRinging47, ToneRinging48, ToneUserDefined,
ToneAlarm1, AudioInvalidTone
}
enum AudioToneId {
ToneDtmf0 = 0, ToneDtmf1, ToneDtmf2, ToneDtmf3,
ToneDtmf4, ToneDtmf5, ToneDtmf6, ToneDtmf7,
ToneDtmf8, ToneDtmf9, ToneDtmfHash, ToneDtmfStar,
ToneSupervisorySubsciberBusy, ToneSupervisoryCongestion, ToneSupervisoryRadioPathAck, ToneSupervisoryRadioPathNotAvail,
ToneSupervisoryError, ToneSupervisoryCallWaiting, ToneInfoFree, ToneInfoLowBat,
ToneInfoConnection, ToneInfoDisconnect, ToneInfoPowerOn, ToneInfoPowerOff,
ToneInfoDeviceIn, ToneInfoDeviceOut, ToneInfoMsgFull, ToneInfoUssd,
ToneInfoMinuteBeep, ToneInfoSmsReceived, ToneInfoBroadcast, ToneInfoAlarm,
ToneInfoAutoRedial, ToneInfoNetworkAttention, ToneInfoDialTone, ToneInfoLowBatInCall,
ToneKey1, ToneKey2, ToneKey3, ToneKey4,
ToneBroadcast1, ToneBroadcast2, ToneBroadcast3, ToneBroadcast4,
ToneMessage1, ToneMessage2, ToneMessage3, ToneMessage4,
ToneMessage5, ToneMessage6, ToneMessage7, ToneMessage8,
ToneMessage9, ToneMessage10, ToneMessageSingleBeep, ToneRinging1,
ToneRinging2, ToneRinging3, ToneRinging4, ToneRinging5,
ToneRinging6, ToneRinging7, ToneRinging8, ToneRinging9,
ToneRinging10, ToneRinging11, ToneRinging12, ToneRinging13,
ToneRinging14, ToneRinging15, ToneRinging16, ToneRinging17,
ToneRinging18, ToneRinging19, ToneRinging20, ToneRinging21,
ToneRinging22, ToneRinging23, ToneRinging24, ToneRinging25,
ToneRinging26, ToneRinging27, ToneRinging28, ToneRinging29,
ToneRinging30, ToneRinging31, ToneRinging32, ToneRinging33,
ToneRinging34, ToneRinging35, ToneRinging36, ToneRinging37,
ToneRinging38, ToneRinging39, ToneRinging40, ToneRinging41,
ToneRinging42, ToneRinging43, ToneRinging44, ToneRinging45,
ToneRinging46, ToneRinging47, ToneRinging48, ToneUserDefined,
ToneAlarm1, AudioInvalidTone
}
enum AudioToneId {
ToneDtmf0 = 0, ToneDtmf1, ToneDtmf2, ToneDtmf3,
ToneDtmf4, ToneDtmf5, ToneDtmf6, ToneDtmf7,
ToneDtmf8, ToneDtmf9, ToneDtmfHash, ToneDtmfStar,
ToneSupervisorySubsciberBusy, ToneSupervisoryCongestion, ToneSupervisoryRadioPathAck, ToneSupervisoryRadioPathNotAvail,
ToneSupervisoryError, ToneSupervisoryCallWaiting, ToneInfoFree, ToneInfoLowBat,
ToneInfoConnection, ToneInfoDisconnect, ToneInfoPowerOn, ToneInfoPowerOff,
ToneInfoDeviceIn, ToneInfoDeviceOut, ToneInfoMsgFull, ToneInfoUssd,
ToneInfoMinuteBeep, ToneInfoSmsReceived, ToneInfoBroadcast, ToneInfoAlarm,
ToneInfoAutoRedial, ToneInfoNetworkAttention, ToneInfoDialTone, ToneInfoLowBatInCall,
ToneKey1, ToneKey2, ToneKey3, ToneKey4,
ToneBroadcast1, ToneBroadcast2, ToneBroadcast3, ToneBroadcast4,
ToneMessage1, ToneMessage2, ToneMessage3, ToneMessage4,
ToneMessage5, ToneMessage6, ToneMessage7, ToneMessage8,
ToneMessage9, ToneMessage10, ToneMessageSingleBeep, ToneRinging1,
ToneRinging2, ToneRinging3, ToneRinging4, ToneRinging5,
ToneRinging6, ToneRinging7, ToneRinging8, ToneRinging9,
ToneRinging10, ToneRinging11, ToneRinging12, ToneRinging13,
ToneRinging14, ToneRinging15, ToneRinging16, ToneRinging17,
ToneRinging18, ToneRinging19, ToneRinging20, ToneRinging21,
ToneRinging22, ToneRinging23, ToneRinging24, ToneRinging25,
ToneRinging26, ToneRinging27, ToneRinging28, ToneRinging29,
ToneRinging30, ToneRinging31, ToneRinging32, ToneRinging33,
ToneRinging34, ToneRinging35, ToneRinging36, ToneRinging37,
ToneRinging38, ToneRinging39, ToneRinging40, ToneRinging41,
ToneRinging42, ToneRinging43, ToneRinging44, ToneRinging45,
ToneRinging46, ToneRinging47, ToneRinging48, ToneUserDefined,
ToneAlarm1, AudioInvalidTone
}
enum AudioToneId {
ToneDtmf0 = 0, ToneDtmf1, ToneDtmf2, ToneDtmf3,
ToneDtmf4, ToneDtmf5, ToneDtmf6, ToneDtmf7,
ToneDtmf8, ToneDtmf9, ToneDtmfHash, ToneDtmfStar,
ToneSupervisorySubsciberBusy, ToneSupervisoryCongestion, ToneSupervisoryRadioPathAck, ToneSupervisoryRadioPathNotAvail,
ToneSupervisoryError, ToneSupervisoryCallWaiting, ToneInfoFree, ToneInfoLowBat,
ToneInfoConnection, ToneInfoDisconnect, ToneInfoPowerOn, ToneInfoPowerOff,
ToneInfoDeviceIn, ToneInfoDeviceOut, ToneInfoMsgFull, ToneInfoUssd,
ToneInfoMinuteBeep, ToneInfoSmsReceived, ToneInfoBroadcast, ToneInfoAlarm,
ToneInfoAutoRedial, ToneInfoNetworkAttention, ToneInfoDialTone, ToneInfoLowBatInCall,
ToneKey1, ToneKey2, ToneKey3, ToneKey4,
ToneBroadcast1, ToneBroadcast2, ToneBroadcast3, ToneBroadcast4,
ToneMessage1, ToneMessage2, ToneMessage3, ToneMessage4,
ToneMessage5, ToneMessage6, ToneMessage7, ToneMessage8,
ToneMessage9, ToneMessage10, ToneMessageSingleBeep, ToneRinging1,
ToneRinging2, ToneRinging3, ToneRinging4, ToneRinging5,
ToneRinging6, ToneRinging7, ToneRinging8, ToneRinging9,
ToneRinging10, ToneRinging11, ToneRinging12, ToneRinging13,
ToneRinging14, ToneRinging15, ToneRinging16, ToneRinging17,
ToneRinging18, ToneRinging19, ToneRinging20, ToneRinging21,
ToneRinging22, ToneRinging23, ToneRinging24, ToneRinging25,
ToneRinging26, ToneRinging27, ToneRinging28, ToneRinging29,
ToneRinging30, ToneRinging31, ToneRinging32, ToneRinging33,
ToneRinging34, ToneRinging35, ToneRinging36, ToneRinging37,
ToneRinging38, ToneRinging39, ToneRinging40, ToneRinging41,
ToneRinging42, ToneRinging43, ToneRinging44, ToneRinging45,
ToneRinging46, ToneRinging47, ToneRinging48, ToneUserDefined,
ToneAlarm1, AudioInvalidTone
}
enum | MuteDirection { MuteUplink = aud_direction_uplink, MuteDownlink = aud_direction_downlink, MuteTch = aud_direction_updownlink }
enum | MuteDirection { MuteUplink = aud_direction_uplink, MuteDownlink = aud_direction_downlink, MuteTch = aud_direction_updownlink }
enum | MuteDirection { MuteUplink = aud_direction_uplink, MuteDownlink = aud_direction_downlink, MuteTch = aud_direction_updownlink }
enum | MuteDirection { MuteUplink = aud_direction_uplink, MuteDownlink = aud_direction_downlink, MuteTch = aud_direction_updownlink }
enum | MuteDirection { MuteUplink = aud_direction_uplink, MuteDownlink = aud_direction_downlink, MuteTch = aud_direction_updownlink }
enum SpeechVolume {
SpeechVolume1 = aud_speech_volume_1, SpeechVolume2 = aud_speech_volume_2, SpeechVolume3 = aud_speech_volume_3, SpeechVolume4 = aud_speech_volume_4,
SpeechVolume5 = aud_speech_volume_5, SpeechVolume6 = aud_speech_volume_6, SpeechVolume7 = aud_speech_volume_7, SpeechVolume8 = aud_speech_volume_8
}
enum SpeechVolume {
SpeechVolume1 = aud_speech_volume_1, SpeechVolume2 = aud_speech_volume_2, SpeechVolume3 = aud_speech_volume_3, SpeechVolume4 = aud_speech_volume_4,
SpeechVolume5 = aud_speech_volume_5, SpeechVolume6 = aud_speech_volume_6, SpeechVolume7 = aud_speech_volume_7, SpeechVolume8 = aud_speech_volume_8
}
enum SpeechVolume {
SpeechVolume1 = aud_speech_volume_1, SpeechVolume2 = aud_speech_volume_2, SpeechVolume3 = aud_speech_volume_3, SpeechVolume4 = aud_speech_volume_4,
SpeechVolume5 = aud_speech_volume_5, SpeechVolume6 = aud_speech_volume_6, SpeechVolume7 = aud_speech_volume_7, SpeechVolume8 = aud_speech_volume_8
}
enum SpeechVolume {
SpeechVolume1 = aud_speech_volume_1, SpeechVolume2 = aud_speech_volume_2, SpeechVolume3 = aud_speech_volume_3, SpeechVolume4 = aud_speech_volume_4,
SpeechVolume5 = aud_speech_volume_5, SpeechVolume6 = aud_speech_volume_6, SpeechVolume7 = aud_speech_volume_7, SpeechVolume8 = aud_speech_volume_8
}
enum SpeechVolume {
SpeechVolume1 = aud_speech_volume_1, SpeechVolume2 = aud_speech_volume_2, SpeechVolume3 = aud_speech_volume_3, SpeechVolume4 = aud_speech_volume_4,
SpeechVolume5 = aud_speech_volume_5, SpeechVolume6 = aud_speech_volume_6, SpeechVolume7 = aud_speech_volume_7, SpeechVolume8 = aud_speech_volume_8
}
enum | VibratorMode { VibratorModeAsync1 = Aud_vibrator_mode_async_1, VibratorModeAsync2 = Aud_vibrator_mode_async_2, VibratorModeSync1 = Aud_vibrator_mode_sync_1, VibratorModeSync2 = Aud_vibrator_mode_sync_2 }
enum | VibratorMode { VibratorModeAsync1 = Aud_vibrator_mode_async_1, VibratorModeAsync2 = Aud_vibrator_mode_async_2, VibratorModeSync1 = Aud_vibrator_mode_sync_1, VibratorModeSync2 = Aud_vibrator_mode_sync_2 }
enum | VibratorMode { VibratorModeAsync1 = Aud_vibrator_mode_async_1, VibratorModeAsync2 = Aud_vibrator_mode_async_2, VibratorModeSync1 = Aud_vibrator_mode_sync_1, VibratorModeSync2 = Aud_vibrator_mode_sync_2 }
enum | VibratorMode { VibratorModeAsync1 = Aud_vibrator_mode_async_1, VibratorModeAsync2 = Aud_vibrator_mode_async_2, VibratorModeSync1 = Aud_vibrator_mode_sync_1, VibratorModeSync2 = Aud_vibrator_mode_sync_2 }
enum | VibratorMode { VibratorModeAsync1 = Aud_vibrator_mode_async_1, VibratorModeAsync2 = Aud_vibrator_mode_async_2, VibratorModeSync1 = Aud_vibrator_mode_sync_1, VibratorModeSync2 = Aud_vibrator_mode_sync_2 }
enum VibratorOffTime {
VibratorOffTime200ms = Aud_vibrator_off_200ms, VibratorOffTime300ms = Aud_vibrator_off_300ms, VibratorOffTime400ms = Aud_vibrator_off_400ms, VibratorOffTime600ms = Aud_vibrator_off_600ms,
VibratorOffTimeOff = Aud_vibrator_off
}
enum VibratorOffTime {
VibratorOffTime200ms = Aud_vibrator_off_200ms, VibratorOffTime300ms = Aud_vibrator_off_300ms, VibratorOffTime400ms = Aud_vibrator_off_400ms, VibratorOffTime600ms = Aud_vibrator_off_600ms,
VibratorOffTimeOff = Aud_vibrator_off
}
enum VibratorOffTime {
VibratorOffTime200ms = Aud_vibrator_off_200ms, VibratorOffTime300ms = Aud_vibrator_off_300ms, VibratorOffTime400ms = Aud_vibrator_off_400ms, VibratorOffTime600ms = Aud_vibrator_off_600ms,
VibratorOffTimeOff = Aud_vibrator_off
}
enum VibratorOffTime {
VibratorOffTime200ms = Aud_vibrator_off_200ms, VibratorOffTime300ms = Aud_vibrator_off_300ms, VibratorOffTime400ms = Aud_vibrator_off_400ms, VibratorOffTime600ms = Aud_vibrator_off_600ms,
VibratorOffTimeOff = Aud_vibrator_off
}
enum VibratorOffTime {
VibratorOffTime200ms = Aud_vibrator_off_200ms, VibratorOffTime300ms = Aud_vibrator_off_300ms, VibratorOffTime400ms = Aud_vibrator_off_400ms, VibratorOffTime600ms = Aud_vibrator_off_600ms,
VibratorOffTimeOff = Aud_vibrator_off
}
enum VibratorOnTime {
VibratorOnTime400ms = Aud_vibrator_on_400ms, VibratorOnTime600ms = Aud_vibrator_on_600ms, VibratorOnTime800ms = Aud_vibrator_on_800ms, VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
VibratorOnTimeOn = Aud_vibrator_on
}
enum VibratorOnTime {
VibratorOnTime400ms = Aud_vibrator_on_400ms, VibratorOnTime600ms = Aud_vibrator_on_600ms, VibratorOnTime800ms = Aud_vibrator_on_800ms, VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
VibratorOnTimeOn = Aud_vibrator_on
}
enum VibratorOnTime {
VibratorOnTime400ms = Aud_vibrator_on_400ms, VibratorOnTime600ms = Aud_vibrator_on_600ms, VibratorOnTime800ms = Aud_vibrator_on_800ms, VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
VibratorOnTimeOn = Aud_vibrator_on
}
enum VibratorOnTime {
VibratorOnTime400ms = Aud_vibrator_on_400ms, VibratorOnTime600ms = Aud_vibrator_on_600ms, VibratorOnTime800ms = Aud_vibrator_on_800ms, VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
VibratorOnTimeOn = Aud_vibrator_on
}
enum VibratorOnTime {
VibratorOnTime400ms = Aud_vibrator_on_400ms, VibratorOnTime600ms = Aud_vibrator_on_600ms, VibratorOnTime800ms = Aud_vibrator_on_800ms, VibratorOnTime1000ms = Aud_vibrator_on_1000ms,
VibratorOnTimeOn = Aud_vibrator_on
}

Public Member Functions

Audio ()

Audio ()

Audio ()

Audio ()

Audio ()

virtual const WCHAR * | GetName () const
See.
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual | ~Audio ()

virtual | ~Audio ()

virtual | ~Audio ()

virtual | ~Audio ()

virtual | ~Audio ()

Static Public Member Functions

static void | Init ()
static void | Init ()
static void | Init ()
static void | Init ()
static void | Init ()
static BOOLEAN | InitSpeech ()
static BOOLEAN | InitSpeech ()
static BOOLEAN | InitSpeech ()
static BOOLEAN | InitSpeech ()
static BOOLEAN | InitSpeech ()
static BOOLEAN | IsEnabled ()
Get the speech device's status.
static BOOLEAN | IsEnabled ()
Get the speech device's status.
static BOOLEAN | IsEnabled ()
Get the speech device's status.
static BOOLEAN | IsEnabled ()
Get the speech device's status.
static BOOLEAN | IsTremblerOn ()
This is deprecated. Please use the IsVibratorOn() method.
static BOOLEAN | IsTremblerOn ()
This is deprecated. Please use the IsVibratorOn() method.
static BOOLEAN | IsTremblerOn ()
This is deprecated. Please use the IsVibratorOn() method.
static BOOLEAN | IsTremblerOn ()
This is deprecated. Please use the IsVibratorOn() method.
static BOOLEAN | IsTremblerOn ()
This is deprecated. Please use the IsVibratorOn() method.
static BOOLEAN | IsVibratorOn ()
static BOOLEAN | IsVibratorOn ()
static BOOLEAN | IsVibratorOn ()
static BOOLEAN | IsVibratorOn ()
static BOOLEAN | IsVibratorOn ()
static BOOLEAN | MuteSpeech (BOOLEAN mute, MuteDirection dir)
static BOOLEAN | MuteSpeech (BOOLEAN mute, MuteDirection dir)
static BOOLEAN | MuteSpeech (BOOLEAN mute, MuteDirection dir)
static BOOLEAN | MuteSpeech (BOOLEAN mute, MuteDirection dir)
static BOOLEAN | MuteSpeech (BOOLEAN mute, MuteDirection dir)
static BOOLEAN | ReleaseSpeech ()
static BOOLEAN | ReleaseSpeech ()
static BOOLEAN | ReleaseSpeech ()
static BOOLEAN | ReleaseSpeech ()
static BOOLEAN | ReleaseSpeech ()
static void | SetAudioMode (AudioMode audio_mode)
static void | SetAudioMode (AudioMode audio_mode)
static void | SetAudioMode (AudioMode audio_mode)
static void | SetAudioMode (AudioMode audio_mode)
static void | SetAudioMode (AudioMode audio_mode)
static void | SetMute (BOOLEAN mute, AudioDevice device)
static void | SetMute (BOOLEAN mute, AudioDevice device)
static void | SetMute (BOOLEAN mute, AudioDevice device)
static void | SetMute (BOOLEAN mute, AudioDevice device)
static void | SetMute (BOOLEAN mute, AudioDevice device)
static void | SetVolume (UINT8 volume, AudioDevice device)
static void | SetVolume (UINT8 volume, AudioDevice device)
static void | SetVolume (UINT8 volume, AudioDevice device)
static void | SetVolume (UINT8 volume, AudioDevice device)
static void | SetVolume (UINT8 volume, AudioDevice device)
static BOOLEAN | SetVolumeSpeech (SpeechVolume vol)
static BOOLEAN | SetVolumeSpeech (SpeechVolume vol)
static BOOLEAN | SetVolumeSpeech (SpeechVolume vol)
static BOOLEAN | SetVolumeSpeech (SpeechVolume vol)
static BOOLEAN | SetVolumeSpeech (SpeechVolume vol)
static BOOLEAN | StartTone (const ToneData *tone_data, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (AudioToneId tone_id, INT nof_repeats=0, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (const ToneData *tone_data, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (AudioToneId tone_id, INT nof_repeats=0, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (const ToneData *tone_data, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (AudioToneId tone_id, INT nof_repeats=0, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (const ToneData *tone_data, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (AudioToneId tone_id, INT nof_repeats=0, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (const ToneData *tone_data, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartTone (AudioToneId tone_id, INT nof_repeats=0, AudioDevice device=DeviceBuzzer, AudioPriority priority=PriorityNone)
static BOOLEAN | StartVibrator (VibratorMode mode=VibratorModeAsync1, VibratorOnTime on=VibratorOnTimeOn, VibratorOffTime off=VibratorOffTimeOff)
static BOOLEAN | StartVibrator (VibratorMode mode=VibratorModeAsync1, VibratorOnTime on=VibratorOnTimeOn, VibratorOffTime off=VibratorOffTimeOff)
static BOOLEAN | StartVibrator (VibratorMode mode=VibratorModeAsync1, VibratorOnTime on=VibratorOnTimeOn, VibratorOffTime off=VibratorOffTimeOff)
static BOOLEAN | StartVibrator (VibratorMode mode=VibratorModeAsync1, VibratorOnTime on=VibratorOnTimeOn, VibratorOffTime off=VibratorOffTimeOff)
static BOOLEAN | StartVibrator (VibratorMode mode=VibratorModeAsync1, VibratorOnTime on=VibratorOnTimeOn, VibratorOffTime off=VibratorOffTimeOff)
static void | StopTone ()
static void | StopTone ()
static void | StopTone ()
static void | StopTone ()
static void | StopTone ()
static void | StopVibrator ()
static void | StopVibrator ()
static void | StopVibrator ()
static void | StopVibrator ()
static void | StopVibrator ()

Data Structures

struct | SingleTone
struct | SingleTone
struct | SingleTone
struct | SingleTone
struct | SingleTone
struct | ToneData
struct | ToneData
struct | ToneData
struct | ToneData
struct | ToneData

Member Enumeration Documentation

enum Audio::AudioDevice

Enumerator:
DeviceNone
DeviceBuzzer
DeviceEarPiece
DeviceTrembler DeviceTrembler is deprecated. Please use the StartVibrator() method instead.
DeviceOut
DeviceMic
DeviceIn

enum Audio::AudioDevice

Enumerator:
DeviceNone
DeviceBuzzer
DeviceEarPiece
DeviceTrembler DeviceTrembler is deprecated. Please use the StartVibrator() method instead.
DeviceOut
DeviceMic
DeviceIn

enum Audio::AudioDevice

Enumerator:
DeviceNone
DeviceBuzzer
DeviceEarPiece
DeviceTrembler DeviceTrembler is deprecated. Please use the StartVibrator() method instead.
DeviceOut
DeviceMic
DeviceIn

enum Audio::AudioDevice

Enumerator:
DeviceNone
DeviceBuzzer
DeviceEarPiece
DeviceTrembler DeviceTrembler is deprecated. Please use the StartVibrator() method instead.
DeviceOut
DeviceMic
DeviceIn

enum Audio::AudioDevice

Enumerator:
DeviceNone
DeviceBuzzer
DeviceEarPiece
DeviceTrembler DeviceTrembler is deprecated. Please use the StartVibrator() method instead.
DeviceOut
DeviceMic
DeviceIn

enum Audio::AudioMode

Enumerator:
ModeNormal
ModeHeadset
ModeHandsfree
ModeBluetoothHeadset

enum Audio::AudioMode

Enumerator:
ModeNormal
ModeHeadset
ModeHandsfree

enum Audio::AudioMode

Enumerator:
ModeNormal
ModeHeadset
ModeHandsfree

enum Audio::AudioMode

Enumerator:
ModeNormal
ModeHeadset
ModeHandsfree

enum Audio::AudioMode

Enumerator:
ModeNormal
ModeHeadset
ModeHandsfree

enum Audio::AudioPriority

Enumerator:
PriorityHigh
PriorityMedium
PriorityLow
PriorityNone

enum Audio::AudioPriority

Enumerator:
PriorityHigh
PriorityMedium
PriorityLow
PriorityNone

enum Audio::AudioPriority

Enumerator:
PriorityHigh
PriorityMedium
PriorityLow
PriorityNone

enum Audio::AudioPriority

Enumerator:
PriorityHigh
PriorityMedium
PriorityLow
PriorityNone

enum Audio::AudioPriority

Enumerator:
PriorityHigh
PriorityMedium
PriorityLow
PriorityNone

enum Audio::AudioToneId

Enumerator:
ToneDtmf0
ToneDtmf1
ToneDtmf2
ToneDtmf3
ToneDtmf4
ToneDtmf5
ToneDtmf6
ToneDtmf7
ToneDtmf8
ToneDtmf9
ToneDtmfHash
ToneDtmfStar
ToneSupervisorySubsciberBusy
ToneSupervisoryCongestion
ToneSupervisoryRadioPathAck
ToneSupervisoryRadioPathNotAvail
ToneSupervisoryError
ToneSupervisoryCallWaiting
ToneInfoFree
ToneInfoLowBat
ToneInfoConnection
ToneInfoDisconnect
ToneInfoPowerOn
ToneInfoPowerOff
ToneInfoDeviceIn
ToneInfoDeviceOut
ToneInfoMsgFull
ToneInfoUssd
ToneKey1
ToneKey2
ToneKey3
ToneKey4
ToneBroadcast1
ToneBroadcast2
ToneBroadcast3
ToneBroadcast4
ToneMessage1
ToneMessage2
ToneMessage3
ToneMessage4
ToneMessage5
ToneMessage6
ToneMessage7
ToneMessage8
ToneMessage9
ToneMessage10
ToneMessageSingleBeep
ToneRinging1
ToneRinging2
ToneRinging3
ToneRinging4
ToneRinging5
ToneRinging6
ToneRinging7
ToneRinging8
ToneRinging9
ToneRinging10
ToneRinging11
ToneRinging12
ToneRinging13
ToneRinging14
ToneRinging15
ToneRinging16
ToneRinging17
ToneRinging18
ToneRinging19
ToneRinging20
ToneRinging21
ToneRinging22
ToneRinging23
ToneRinging24
ToneRinging25
ToneRinging26
ToneRinging27
ToneRinging28
ToneRinging29
ToneRinging30
ToneRinging31
ToneRinging32
ToneRinging33
ToneRinging34
ToneRinging35
ToneRinging36
ToneRinging37
ToneRinging38
ToneRinging39
ToneRinging40
ToneRinging41
ToneRinging42
ToneRinging43
ToneRinging44
ToneRinging45
ToneRinging46
ToneRinging47
ToneRinging48
ToneUserDefined
ToneAlarm1
AudioInvalidTone

enum Audio::AudioToneId

Enumerator:
ToneDtmf0
ToneDtmf1
ToneDtmf2
ToneDtmf3
ToneDtmf4
ToneDtmf5
ToneDtmf6
ToneDtmf7
ToneDtmf8
ToneDtmf9
ToneDtmfHash
ToneDtmfStar
ToneSupervisorySubsciberBusy
ToneSupervisoryCongestion
ToneSupervisoryRadioPathAck
ToneSupervisoryRadioPathNotAvail
ToneSupervisoryError
ToneSupervisoryCallWaiting
ToneInfoFree
ToneInfoLowBat
ToneInfoConnection
ToneInfoDisconnect
ToneInfoPowerOn
ToneInfoPowerOff
ToneInfoDeviceIn
ToneInfoDeviceOut
ToneInfoMsgFull
ToneInfoUssd
ToneInfoMinuteBeep
ToneInfoSmsReceived
ToneInfoBroadcast
ToneInfoAlarm
ToneInfoAutoRedial
ToneInfoNetworkAttention
ToneInfoDialTone
ToneInfoLowBatInCall
ToneKey1
ToneKey2
ToneKey3
ToneKey4
ToneBroadcast1
ToneBroadcast2
ToneBroadcast3
ToneBroadcast4
ToneMessage1
ToneMessage2
ToneMessage3
ToneMessage4
ToneMessage5
ToneMessage6
ToneMessage7
ToneMessage8
ToneMessage9
ToneMessage10
ToneMessageSingleBeep
ToneRinging1
ToneRinging2
ToneRinging3
ToneRinging4
ToneRinging5
ToneRinging6
ToneRinging7
ToneRinging8
ToneRinging9
ToneRinging10
ToneRinging11
ToneRinging12
ToneRinging13
ToneRinging14
ToneRinging15
ToneRinging16
ToneRinging17
ToneRinging18
ToneRinging19
ToneRinging20
ToneRinging21
ToneRinging22
ToneRinging23
ToneRinging24
ToneRinging25
ToneRinging26
ToneRinging27
ToneRinging28
ToneRinging29
ToneRinging30
ToneRinging31
ToneRinging32
ToneRinging33
ToneRinging34
ToneRinging35
ToneRinging36
ToneRinging37
ToneRinging38
ToneRinging39
ToneRinging40
ToneRinging41
ToneRinging42
ToneRinging43
ToneRinging44
ToneRinging45
ToneRinging46
ToneRinging47
ToneRinging48
ToneUserDefined
ToneAlarm1
AudioInvalidTone

enum Audio::AudioToneId

Enumerator:
ToneDtmf0
ToneDtmf1
ToneDtmf2
ToneDtmf3
ToneDtmf4
ToneDtmf5
ToneDtmf6
ToneDtmf7
ToneDtmf8
ToneDtmf9
ToneDtmfHash
ToneDtmfStar
ToneSupervisorySubsciberBusy
ToneSupervisoryCongestion
ToneSupervisoryRadioPathAck
ToneSupervisoryRadioPathNotAvail
ToneSupervisoryError
ToneSupervisoryCallWaiting
ToneInfoFree
ToneInfoLowBat
ToneInfoConnection
ToneInfoDisconnect
ToneInfoPowerOn
ToneInfoPowerOff
ToneInfoDeviceIn
ToneInfoDeviceOut
ToneInfoMsgFull
ToneInfoUssd
ToneInfoMinuteBeep
ToneInfoSmsReceived
ToneInfoBroadcast
ToneInfoAlarm
ToneInfoAutoRedial
ToneInfoNetworkAttention
ToneInfoDialTone
ToneInfoLowBatInCall
ToneKey1
ToneKey2
ToneKey3
ToneKey4
ToneBroadcast1
ToneBroadcast2
ToneBroadcast3
ToneBroadcast4
ToneMessage1
ToneMessage2
ToneMessage3
ToneMessage4
ToneMessage5
ToneMessage6
ToneMessage7
ToneMessage8
ToneMessage9
ToneMessage10
ToneMessageSingleBeep
ToneRinging1
ToneRinging2
ToneRinging3
ToneRinging4
ToneRinging5
ToneRinging6
ToneRinging7
ToneRinging8
ToneRinging9
ToneRinging10
ToneRinging11
ToneRinging12
ToneRinging13
ToneRinging14
ToneRinging15
ToneRinging16
ToneRinging17
ToneRinging18
ToneRinging19
ToneRinging20
ToneRinging21
ToneRinging22
ToneRinging23
ToneRinging24
ToneRinging25
ToneRinging26
ToneRinging27
ToneRinging28
ToneRinging29
ToneRinging30
ToneRinging31
ToneRinging32
ToneRinging33
ToneRinging34
ToneRinging35
ToneRinging36
ToneRinging37
ToneRinging38
ToneRinging39
ToneRinging40
ToneRinging41
ToneRinging42
ToneRinging43
ToneRinging44
ToneRinging45
ToneRinging46
ToneRinging47
ToneRinging48
ToneUserDefined
ToneAlarm1
AudioInvalidTone

enum Audio::AudioToneId

Enumerator:
ToneDtmf0
ToneDtmf1
ToneDtmf2
ToneDtmf3
ToneDtmf4
ToneDtmf5
ToneDtmf6
ToneDtmf7
ToneDtmf8
ToneDtmf9
ToneDtmfHash
ToneDtmfStar
ToneSupervisorySubsciberBusy
ToneSupervisoryCongestion
ToneSupervisoryRadioPathAck
ToneSupervisoryRadioPathNotAvail
ToneSupervisoryError
ToneSupervisoryCallWaiting
ToneInfoFree
ToneInfoLowBat
ToneInfoConnection
ToneInfoDisconnect
ToneInfoPowerOn
ToneInfoPowerOff
ToneInfoDeviceIn
ToneInfoDeviceOut
ToneInfoMsgFull
ToneInfoUssd
ToneInfoMinuteBeep
ToneInfoSmsReceived
ToneInfoBroadcast
ToneInfoAlarm
ToneInfoAutoRedial
ToneInfoNetworkAttention
ToneInfoDialTone
ToneInfoLowBatInCall
ToneKey1
ToneKey2
ToneKey3
ToneKey4
ToneBroadcast1
ToneBroadcast2
ToneBroadcast3
ToneBroadcast4
ToneMessage1
ToneMessage2
ToneMessage3
ToneMessage4
ToneMessage5
ToneMessage6
ToneMessage7
ToneMessage8
ToneMessage9
ToneMessage10
ToneMessageSingleBeep
ToneRinging1
ToneRinging2
ToneRinging3
ToneRinging4
ToneRinging5
ToneRinging6
ToneRinging7
ToneRinging8
ToneRinging9
ToneRinging10
ToneRinging11
ToneRinging12
ToneRinging13
ToneRinging14
ToneRinging15
ToneRinging16
ToneRinging17
ToneRinging18
ToneRinging19
ToneRinging20
ToneRinging21
ToneRinging22
ToneRinging23
ToneRinging24
ToneRinging25
ToneRinging26
ToneRinging27
ToneRinging28
ToneRinging29
ToneRinging30
ToneRinging31
ToneRinging32
ToneRinging33
ToneRinging34
ToneRinging35
ToneRinging36
ToneRinging37
ToneRinging38
ToneRinging39
ToneRinging40
ToneRinging41
ToneRinging42
ToneRinging43
ToneRinging44
ToneRinging45
ToneRinging46
ToneRinging47
ToneRinging48
ToneUserDefined
ToneAlarm1
AudioInvalidTone

enum Audio::AudioToneId

Enumerator:
ToneDtmf0
ToneDtmf1
ToneDtmf2
ToneDtmf3
ToneDtmf4
ToneDtmf5
ToneDtmf6
ToneDtmf7
ToneDtmf8
ToneDtmf9
ToneDtmfHash
ToneDtmfStar
ToneSupervisorySubsciberBusy
ToneSupervisoryCongestion
ToneSupervisoryRadioPathAck
ToneSupervisoryRadioPathNotAvail
ToneSupervisoryError
ToneSupervisoryCallWaiting
ToneInfoFree
ToneInfoLowBat
ToneInfoConnection
ToneInfoDisconnect
ToneInfoPowerOn
ToneInfoPowerOff
ToneInfoDeviceIn
ToneInfoDeviceOut
ToneInfoMsgFull
ToneInfoUssd
ToneInfoMinuteBeep
ToneInfoSmsReceived
ToneInfoBroadcast
ToneInfoAlarm
ToneInfoAutoRedial
ToneInfoNetworkAttention
ToneInfoDialTone
ToneInfoLowBatInCall
ToneKey1
ToneKey2
ToneKey3
ToneKey4
ToneBroadcast1
ToneBroadcast2
ToneBroadcast3
ToneBroadcast4
ToneMessage1
ToneMessage2
ToneMessage3
ToneMessage4
ToneMessage5
ToneMessage6
ToneMessage7
ToneMessage8
ToneMessage9
ToneMessage10
ToneMessageSingleBeep
ToneRinging1
ToneRinging2
ToneRinging3
ToneRinging4
ToneRinging5
ToneRinging6
ToneRinging7
ToneRinging8
ToneRinging9
ToneRinging10
ToneRinging11
ToneRinging12
ToneRinging13
ToneRinging14
ToneRinging15
ToneRinging16
ToneRinging17
ToneRinging18
ToneRinging19
ToneRinging20
ToneRinging21
ToneRinging22
ToneRinging23
ToneRinging24
ToneRinging25
ToneRinging26
ToneRinging27
ToneRinging28
ToneRinging29
ToneRinging30
ToneRinging31
ToneRinging32
ToneRinging33
ToneRinging34
ToneRinging35
ToneRinging36
ToneRinging37
ToneRinging38
ToneRinging39
ToneRinging40
ToneRinging41
ToneRinging42
ToneRinging43
ToneRinging44
ToneRinging45
ToneRinging46
ToneRinging47
ToneRinging48
ToneUserDefined
ToneAlarm1
AudioInvalidTone

enum Audio::MuteDirection

Enumerator:
MuteUplink
MuteDownlink
MuteTch

enum Audio::MuteDirection

Enumerator:
MuteUplink
MuteDownlink
MuteTch

enum Audio::MuteDirection

Enumerator:
MuteUplink
MuteDownlink
MuteTch

enum Audio::MuteDirection

Enumerator:
MuteUplink
MuteDownlink
MuteTch

enum Audio::MuteDirection

Enumerator:
MuteUplink
MuteDownlink
MuteTch

enum Audio::SpeechVolume

Enumerator:
SpeechVolume1
SpeechVolume2
SpeechVolume3
SpeechVolume4
SpeechVolume5
SpeechVolume6
SpeechVolume7
SpeechVolume8

enum Audio::SpeechVolume

Enumerator:
SpeechVolume1
SpeechVolume2
SpeechVolume3
SpeechVolume4
SpeechVolume5
SpeechVolume6
SpeechVolume7
SpeechVolume8

enum Audio::SpeechVolume

Enumerator:
SpeechVolume1
SpeechVolume2
SpeechVolume3
SpeechVolume4
SpeechVolume5
SpeechVolume6
SpeechVolume7
SpeechVolume8

enum Audio::SpeechVolume

Enumerator:
SpeechVolume1
SpeechVolume2
SpeechVolume3
SpeechVolume4
SpeechVolume5
SpeechVolume6
SpeechVolume7
SpeechVolume8

enum Audio::SpeechVolume

Enumerator:
SpeechVolume1
SpeechVolume2
SpeechVolume3
SpeechVolume4
SpeechVolume5
SpeechVolume6
SpeechVolume7
SpeechVolume8

enum Audio::VibratorMode

Enumerator:
VibratorModeAsync1
VibratorModeAsync2
VibratorModeSync1
VibratorModeSync2

enum Audio::VibratorMode

Enumerator:
VibratorModeAsync1
VibratorModeAsync2
VibratorModeSync1
VibratorModeSync2

enum Audio::VibratorMode

Enumerator:
VibratorModeAsync1
VibratorModeAsync2
VibratorModeSync1
VibratorModeSync2

enum Audio::VibratorMode

Enumerator:
VibratorModeAsync1
VibratorModeAsync2
VibratorModeSync1
VibratorModeSync2

enum Audio::VibratorMode

Enumerator:
VibratorModeAsync1
VibratorModeAsync2
VibratorModeSync1
VibratorModeSync2

enum Audio::VibratorOffTime

Enumerator:
VibratorOffTime200ms
VibratorOffTime300ms
VibratorOffTime400ms
VibratorOffTime600ms
VibratorOffTimeOff

enum Audio::VibratorOffTime

Enumerator:
VibratorOffTime200ms
VibratorOffTime300ms
VibratorOffTime400ms
VibratorOffTime600ms
VibratorOffTimeOff

enum Audio::VibratorOffTime

Enumerator:
VibratorOffTime200ms
VibratorOffTime300ms
VibratorOffTime400ms
VibratorOffTime600ms
VibratorOffTimeOff

enum Audio::VibratorOffTime

Enumerator:
VibratorOffTime200ms
VibratorOffTime300ms
VibratorOffTime400ms
VibratorOffTime600ms
VibratorOffTimeOff

enum Audio::VibratorOffTime

Enumerator:
VibratorOffTime200ms
VibratorOffTime300ms
VibratorOffTime400ms
VibratorOffTime600ms
VibratorOffTimeOff

enum Audio::VibratorOnTime

Enumerator:
VibratorOnTime400ms
VibratorOnTime600ms
VibratorOnTime800ms
VibratorOnTime1000ms
VibratorOnTimeOn

enum Audio::VibratorOnTime

Enumerator:
VibratorOnTime400ms
VibratorOnTime600ms
VibratorOnTime800ms
VibratorOnTime1000ms
VibratorOnTimeOn

enum Audio::VibratorOnTime

Enumerator:
VibratorOnTime400ms
VibratorOnTime600ms
VibratorOnTime800ms
VibratorOnTime1000ms
VibratorOnTimeOn

enum Audio::VibratorOnTime

Enumerator:
VibratorOnTime400ms
VibratorOnTime600ms
VibratorOnTime800ms
VibratorOnTime1000ms
VibratorOnTimeOn

enum Audio::VibratorOnTime

Enumerator:
VibratorOnTime400ms
VibratorOnTime600ms
VibratorOnTime800ms
VibratorOnTime1000ms
VibratorOnTimeOn

Constructor & Destructor Documentation

Audio::Audio ( )

Audio::~Audio ( ) [virtual]

Audio::Audio ( )

virtual Audio::~Audio ( ) [virtual]

Audio::Audio ( )

virtual Audio::~Audio ( ) [virtual]

Audio::Audio ( )

virtual Audio::~Audio ( ) [virtual]

Audio::Audio ( )

virtual Audio::~Audio ( ) [virtual]

Member Function Documentation

virtual const WCHAR* Audio::GetName ( ) const [virtual]

See.

See also:
AbstractDevice::GetName

Implements AbstractDevice.

virtual const WCHAR* Audio::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

virtual const WCHAR* Audio::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

virtual const WCHAR* Audio::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

const WCHAR * Audio::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

static void Audio::Init ( ) [inline, static]

static void Audio::Init ( ) [static]

static void Audio::Init ( ) [static]

static void Audio::Init ( ) [static]

void Audio::Init ( ) [static]

static BOOLEAN Audio::InitSpeech ( ) [static]

static BOOLEAN Audio::InitSpeech ( ) [static]

static BOOLEAN Audio::InitSpeech ( ) [static]

static BOOLEAN Audio::InitSpeech ( ) [static]

BOOLEAN Audio::InitSpeech ( ) [static]

static BOOLEAN Audio::IsEnabled ( ) [static]

Get the speech device's status.

static BOOLEAN Audio::IsEnabled ( ) [static]

Get the speech device's status.

static BOOLEAN Audio::IsEnabled ( ) [static]

Get the speech device's status.

BOOLEAN Audio::IsEnabled ( ) [static]

Get the speech device's status.

static BOOLEAN Audio::IsTremblerOn ( ) [inline, static]

This is deprecated. Please use the IsVibratorOn() method.

static BOOLEAN Audio::IsTremblerOn ( ) [inline, static]

This is deprecated. Please use the IsVibratorOn() method.

static BOOLEAN Audio::IsTremblerOn ( ) [inline, static]

This is deprecated. Please use the IsVibratorOn() method.

static BOOLEAN Audio::IsTremblerOn ( ) [inline, static]

This is deprecated. Please use the IsVibratorOn() method.

static BOOLEAN Audio::IsTremblerOn ( ) [inline, static]

This is deprecated. Please use the IsVibratorOn() method.

static BOOLEAN Audio::IsVibratorOn ( ) [inline, static]

Returns:
status of Vibrator (on or off).

static BOOLEAN Audio::IsVibratorOn ( ) [inline, static]

Returns:
status of Vibrator (on or off).

static BOOLEAN Audio::IsVibratorOn ( ) [inline, static]

Returns:
status of Vibrator (on or off).

static BOOLEAN Audio::IsVibratorOn ( ) [inline, static]

Returns:
status of Vibrator (on or off).

static BOOLEAN Audio::IsVibratorOn ( ) [inline, static]

Returns:
status of Vibrator (on or off).

static BOOLEAN Audio::MuteSpeech | ( | BOOLEAN | mute,
 |  | MuteDirection | dir
 | ) | [static]

static BOOLEAN Audio::MuteSpeech | ( | BOOLEAN | mute,
 |  | MuteDirection | dir
 | ) | [static]

static BOOLEAN Audio::MuteSpeech | ( | BOOLEAN | mute,
 |  | MuteDirection | dir
 | ) | [static]

static BOOLEAN Audio::MuteSpeech | ( | BOOLEAN | mute,
 |  | MuteDirection | dir
 | ) | [static]

BOOLEAN Audio::MuteSpeech | ( | BOOLEAN | mute,
 |  | MuteDirection | dir
 | ) | [static]

static BOOLEAN Audio::ReleaseSpeech ( ) [static]

static BOOLEAN Audio::ReleaseSpeech ( ) [static]

static BOOLEAN Audio::ReleaseSpeech ( ) [static]

static BOOLEAN Audio::ReleaseSpeech ( ) [static]

BOOLEAN Audio::ReleaseSpeech ( ) [static]

static void Audio::SetAudioMode ( AudioMode audio_mode ) [static]

static void Audio::SetAudioMode ( AudioMode audio_mode ) [static]

static void Audio::SetAudioMode ( AudioMode audio_mode ) [static]

static void Audio::SetAudioMode ( AudioMode audio_mode ) [static]

void Audio::SetAudioMode ( AudioMode audio_mode ) [static]

static void Audio::SetMute | ( | BOOLEAN | mute,
 |  | AudioDevice | device
 | ) | [static]

static void Audio::SetMute | ( | BOOLEAN | mute,
 |  | AudioDevice | device
 | ) | [static]

static void Audio::SetMute | ( | BOOLEAN | mute,
 |  | AudioDevice | device
 | ) | [static]

static void Audio::SetMute | ( | BOOLEAN | mute,
 |  | AudioDevice | device
 | ) | [static]

void Audio::SetMute | ( | BOOLEAN | mute,
 |  | AudioDevice | device
 | ) | [static]

static void Audio::SetVolume | ( | UINT8 | volume,
 |  | AudioDevice | device
 | ) | [static]

static void Audio::SetVolume | ( | UINT8 | volume,
 |  | AudioDevice | device
 | ) | [static]

static void Audio::SetVolume | ( | UINT8 | volume,
 |  | AudioDevice | device
 | ) | [static]

static void Audio::SetVolume | ( | UINT8 | volume,
 |  | AudioDevice | device
 | ) | [static]

void Audio::SetVolume | ( | UINT8 | volume,
 |  | AudioDevice | device
 | ) | [static]

static BOOLEAN Audio::SetVolumeSpeech ( SpeechVolume vol ) [static]

static BOOLEAN Audio::SetVolumeSpeech ( SpeechVolume vol ) [static]

static BOOLEAN Audio::SetVolumeSpeech ( SpeechVolume vol ) [static]

static BOOLEAN Audio::SetVolumeSpeech ( SpeechVolume vol ) [static]

BOOLEAN Audio::SetVolumeSpeech ( SpeechVolume vol ) [static]

static BOOLEAN Audio::StartTone | ( | const ToneData * | tone_data,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

static BOOLEAN Audio::StartTone | ( | AudioToneId | tone_id,
 |  | INT | nof_repeats = 0,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

static BOOLEAN Audio::StartTone | ( | const ToneData * | tone_data,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

static BOOLEAN Audio::StartTone | ( | AudioToneId | tone_id,
 |  | INT | nof_repeats = 0,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

static BOOLEAN Audio::StartTone | ( | const ToneData * | tone_data,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

static BOOLEAN Audio::StartTone | ( | AudioToneId | tone_id,
 |  | INT | nof_repeats = 0,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

static BOOLEAN Audio::StartTone | ( | const ToneData * | tone_data,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

static BOOLEAN Audio::StartTone | ( | AudioToneId | tone_id,
 |  | INT | nof_repeats = 0,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

BOOLEAN Audio::StartTone | ( | const ToneData * | tone_data,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

BOOLEAN Audio::StartTone | ( | AudioToneId | tone_id,
 |  | INT | nof_repeats = 0,
 |  | AudioDevice | device = DeviceBuzzer,
 |  | AudioPriority | priority = PriorityNone
 | ) | [static]

static BOOLEAN Audio::StartVibrator | ( | VibratorMode | mode = VibratorModeAsync1,
 |  | VibratorOnTime | on = VibratorOnTimeOn,
 |  | VibratorOffTime | off = VibratorOffTimeOff
 | ) | [static]

Start the Vibrator, also known as the Trembler.

static BOOLEAN Audio::StartVibrator | ( | VibratorMode | mode = VibratorModeAsync1,
 |  | VibratorOnTime | on = VibratorOnTimeOn,
 |  | VibratorOffTime | off = VibratorOffTimeOff
 | ) | [static]

Start the Vibrator, also known as the Trembler.

static BOOLEAN Audio::StartVibrator | ( | VibratorMode | mode = VibratorModeAsync1,
 |  | VibratorOnTime | on = VibratorOnTimeOn,
 |  | VibratorOffTime | off = VibratorOffTimeOff
 | ) | [static]

Start the Vibrator, also known as the Trembler.

static BOOLEAN Audio::StartVibrator | ( | VibratorMode | mode = VibratorModeAsync1,
 |  | VibratorOnTime | on = VibratorOnTimeOn,
 |  | VibratorOffTime | off = VibratorOffTimeOff
 | ) | [static]

Start the Vibrator, also known as the Trembler.

BOOLEAN Audio::StartVibrator | ( | VibratorMode | mode = VibratorModeAsync1,
 |  | VibratorOnTime | on = VibratorOnTimeOn,
 |  | VibratorOffTime | off = VibratorOffTimeOff
 | ) | [static]

Start the Vibrator, also known as the Trembler.

static void Audio::StopTone ( ) [static]

static void Audio::StopTone ( ) [static]

static void Audio::StopTone ( ) [static]

static void Audio::StopTone ( ) [static]

void Audio::StopTone ( ) [static]

static void Audio::StopVibrator ( ) [static]

Stop the Vibrator, also known as the Trembler.

static void Audio::StopVibrator ( ) [static]

Stop the Vibrator, also known as the Trembler.

static void Audio::StopVibrator ( ) [static]

Stop the Vibrator, also known as the Trembler.

static void Audio::StopVibrator ( ) [static]

Stop the Vibrator, also known as the Trembler.

void Audio::StopVibrator ( ) [static]

Stop the Vibrator, also known as the Trembler.

The documentation for this class was generated from the following files:
  • Compat/Devices/BP30/Audio.hpp
  • Compat/Devices/MPE/Audio.hpp
  • Compat/Devices/MPEU/Audio.hpp
  • Compat/Devices/SGold/Audio.hpp
  • Compat/Devices/Win32/Audio.hpp
  • Compat/Devices/BP30/Audio.cpp
  • Compat/Devices/MPE/Audio.cpp
  • Compat/Devices/MPEU/Audio.cpp
  • Compat/Devices/SGold/Audio.cpp
  • Compat/Devices/Win32/Audio.cpp
Generated on Wed Jan 25 00:56:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio::SingleTone Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Audio::SingleTone

Audio::SingleTone Struct Reference

#include <Apoxi/Compat/Devices/BP30/Audio.hpp>

The documentation for this struct was generated from the following file:
  • Compat/Devices/BP30/Audio.hpp
Generated on Wed Jan 25 00:56:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio::ToneData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Audio::ToneData

Audio::ToneData Struct Reference

#include <Apoxi/Compat/Devices/BP30/Audio.hpp>

The documentation for this struct was generated from the following file:
  • Compat/Devices/BP30/Audio.hpp
Generated on Wed Jan 25 00:56:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioAccessoryConnectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioAccessoryConnectedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioAccessoryConnectedMsg:

[legend]
Collaboration diagram for AudioAccessoryConnectedMsg:

[legend]

Public Types

enum | { ID = 9014 }

Public Member Functions

AudioAccessoryConnectedMsg (const AudioAccessoryDetails::AudioAccessoryConfigurationType &accessory_configuration_type, BOOLEAN connected)
virtual Message * | Clone () const
const AudioAccessoryDetails::AudioAccessoryConfigurationType & | GetAccessoryConfigurationType () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsConnected () const
void | SetAccessoryConfigurationType (const AudioAccessoryDetails::AudioAccessoryConfigurationType &accessory_configuration_type)
void | SetConnected (BOOLEAN connected)
virtual | ~AudioAccessoryConnectedMsg ()

Detailed Description

This message will be emitted when an accessory is connected or disconnected.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioAccessoryConnectedMsg::AudioAccessoryConnectedMsg | ( | const AudioAccessoryDetails::AudioAccessoryConfigurationType & | accessory_configuration_type,
 |  | BOOLEAN | connected
 | ) |

AudioAccessoryConnectedMsg::~AudioAccessoryConnectedMsg ( ) [virtual]

Member Function Documentation

Message * AudioAccessoryConnectedMsg::Clone ( ) const [virtual]

Implements Message.

const AudioAccessoryDetails::AudioAccessoryConfigurationType& AudioAccessoryConnectedMsg::GetAccessoryConfigurationType ( ) const [inline]

const MsgMetaData & AudioAccessoryConnectedMsg::GetMetaData ( ) const [virtual]

Implements Message.

BOOLEAN AudioAccessoryConnectedMsg::IsConnected ( ) const [inline]

void AudioAccessoryConnectedMsg::SetAccessoryConfigurationType ( const AudioAccessoryDetails::AudioAccessoryConfigurationType & accessory_configuration_type ) [inline]

void AudioAccessoryConnectedMsg::SetConnected ( BOOLEAN connected ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioAccessoryDetails Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioAccessoryDetails Class Reference
[Audio]

#include <Apoxi/Audio/AudioAccessoryDetails.hpp>

Inheritance diagram for AudioAccessoryDetails:

[legend]
Collaboration diagram for AudioAccessoryDetails:

[legend]

Public Types

enum AudioAccessoryConfigurationType {
AudioAccessoryCfgNormal = 0x1, AudioAccessoryCfgHeadset = 0x2, AudioAccessoryCfgStereoPhones = 0x4, AudioAccessoryCfgBackspeaker_NormalMic = 0x8,
AudioAccessoryCfgBluetoothHeadset = 0x10, AudioAccessoryCfgBluetoothHandsfree = 0x20, AudioAccessoryCfgTTY = 0x40, AudioAccessoryCfgCarKit = 0x80,
AudioAccessoryCfgBluetoothHeadsetRinger = 0x100, AudioAccessoryCfgExtRingerHeadset = 0x200, AudioAccessoryCfgExtRingerStereoPhones = 0x400, AudioAccessoryCfgExtRingerBackspeaker = 0x800,
AudioAccessoryCfgRecordingNormal = 0x1000, AudioAccessoryCfgRecordingBackspeaker = 0x2000, AudioAccessoryCfgUserDefined1 = 0x4000, AudioAccessoryCfgUserDefined2 = 0x8000,
AudioAccessoryCfgUserDefined3 = 0x10000, AudioAccessoryCfgUserDefined4 = 0x20000, AudioAccessoryCfgUserDefined5 = 0x40000, AudioAccessoryCfgUserDefined6 = 0x80000,
AudioAccessoryCfgUserDefined7 = 0x100000, AudioAccessoryCfgUserDefined8 = 0x200000, AudioAccessoryCfgUserDefined9 = 0x400000, AudioAccessoryCfgUserDefined11 = 0x800000,
AudioAccessoryCfgUserDefined12 = 0x1000000, AudioAccessoryCfgUserDefined13 = 0x2000000, AudioAccessoryCfgUserDefined14 = 0x4000000, AudioAccessoryCfgUserDefined15 = 0x8000000,
AudioAccessoryCfgUserDefined16 = 0x10000000, AudioAccessoryCfgUserDefined17 = 0x20000000, AudioAccessoryCfgUserDefined18 = 0x40000000, AudioAccessoryCfgUserDefined19 = 0x80000000,
CompatibleWithEverything = 0xFFFFFFFF
}
Audio Accessory configuration type. More...
typedef UINT32 | ConnectedAccessoriesType

Public Member Functions

AudioAccessoryDetails (const AudioAccessoryConfigurationType configuration, const AudioPath &uplink, const AudioPath &downlink, BOOLEAN active, const UINT compat_setting, const WString &type_name, const WString &actual_name="")
BOOLEAN | CanActivateAudioPaths () const
void | EnableEcNr (BOOLEAN ecnr)
WString | GetActualName () const
Get the actual name of the accessory that can be changed runtime. For instance, "Bob's office Bluetooth headset".
UINT | GetCompatibilitySettings () const
Get the compatibility settings given through the constructor.
AudioAccessoryDetails::AudioAccessoryConfigurationType | GetConfigurationType () const
Get the configuration/accessory ID.
BOOLEAN | GetConnected () const
AudioPath & | GetDownlinkPath () const
Get the downlink path for this configuration. See AudioPathManager for more path management details.
WString | GetName () const
Get the name of the accessory defined at the registration time. For instance, "Bluetooth headset".
BOOLEAN | GetUpdatePath () const
AudioPath & | GetUplinkPath () const
Get the uplink path for this configuration. See AudioPathManager for more path management details.
virtual AudioDeviceBase::VolumeLevel | GetVolume () const
Get volume level in percentages.
BOOLEAN | IsActive () const
Indicate whether the accessory device is active or not.
BOOLEAN | IsEcNrActive ()
void | SetActualName (const WString &actual_name)
See GetActualName().
void | SetConnected (BOOLEAN connected, BOOLEAN update_path=TRUE)
void | SetConnectedOld (BOOLEAN connected, BOOLEAN update_path=TRUE, AudioDeviceBase::AudioSourceType audio_source=AudioDeviceBase::DspAudioSource)
virtual void | SetVolume (AudioDeviceBase::VolumeLevel val)
Set volume level in percentages.
virtual void | TurnVolume (BOOLEAN turn_up)
void | UpdateConfiguration ()

Static Public Member Functions

static ConnectedAccessoriesType | GetConnectedAccessories ()

Protected Attributes

AudioAccessoryConfigurationType m_accessory_id
BOOLEAN | m_active
WString m_actual_name
UINT | m_compat_setting
AudioPath m_downlinkPath
BOOLEAN | m_enable_ecnr
BOOLEAN | m_paths_active
WString m_type_name
BOOLEAN | m_update_path
AudioPath m_uplinkPath

Detailed Description

This is the base class providing the accessory information and setting up any particular capabilities such as volume level in case of bluetooth handsfree.

Note:
In the current concept an accessory is also considered as being the default phone configuration (earpiece/handset mic), in other words any audio path configuration is considered as being an accessory.
accessory registration The customization of the accessory is done per each project and can be seen in the AudioAccessoriesRegistration.cpp file. The creation of the accessory objects is done in the AudioAccessoryStore during power on. The order of creation is very important since the priority is assigned in the order of adding to the list,the first accessory having the higher priority

 AddItem(AudioAccessoryDetails::AudioAccessoryCfgBluetoothHandsfree,
         AudioPath::UplinkPathI2S1_Rx,
         AudioPath::DownlinkPathI2S1_Tx,
         FALSE,
         AudioAccessoryDetails::AudioAccessoryCfgHeadset | AudioAccessoryDetails::AudioAccessoryCfgStereoPhones,
         Tr(L"Bluetooth Handsfree"));

 AddItem(AudioAccessoryDetails::AudioAccessoryCfgNormal,
         AudioPath::UplinkPathHandsetMic,
         AudioPath::DownlinkPathEarpiece,
         TRUE, // this "accessory" always exists in the system
         0, //Does not work in any other combination
         Tr(L"Normal"));

In the above example the BT handsfree accessory has higher priority

accessory handling Once the accessory objects are created any application can enable/disable then.

 //Get the bluetooth handsfree accessory
 AudioAccessoryDetails* accessory = AudioAccessoryStore::GetInstance()->GetAccessoryByCfgType(AudioAccessoryDetails::AudioAccessoryCfgBluetoothHandsfree);

 //Enable the accessory (the BT device has been already conected, here the audio paths are set up)
 accessory->SetConnected(TRUE);

Member Typedef Documentation

typedef UINT32 AudioAccessoryDetails::ConnectedAccessoriesType

Member Enumeration Documentation

enum AudioAccessoryDetails::AudioAccessoryConfigurationType

Audio Accessory configuration type.

Enumerator:
AudioAccessoryCfgNormal | Normal, handset microphone/earpiece Use this variant of the "normal" accessory for the "available" column in the lookup table; In the "desired" column, use this variant for voice call
AudioAccessoryCfgHeadset | Headset, headset microphone/mono headset.
AudioAccessoryCfgStereoPhones | Stereo phones, headset microphone/stereo headset.
AudioAccessoryCfgBackspeaker_NormalMic | backspeacker, handset microphone/backspeacker Use this variant of the "backspeaker" accessory for the "available" column in the lookup table; In the "desired" column, use this variant for voice call
AudioAccessoryCfgBluetoothHeadset | Bluetooth headset, I2S1 rx/I2S1 tx.
AudioAccessoryCfgBluetoothHandsfree | Bluetooth handsfree, I2S1 rx/I2S1 tx.
AudioAccessoryCfgTTY | CTM/TTY, tty uplink/tty downlink, Available on SGOLD platforms only.
AudioAccessoryCfgCarKit | Car kit.
AudioAccessoryCfgBluetoothHeadsetRinger | Bluetooth Headset - Direct Audio playing ringtone.
AudioAccessoryCfgExtRingerHeadset | External ringer - Headset, headset microphone/mono headset.
AudioAccessoryCfgExtRingerStereoPhones | External ringer - Stereo phones, stereo headset.
AudioAccessoryCfgExtRingerBackspeaker | External ringer - BackSpeaker.
AudioAccessoryCfgRecordingNormal | Use this variant of the "normal" accessory only for the "desired" column of the lookup table, for the recording use cases (path control mode RecordingMode)
AudioAccessoryCfgRecordingBackspeaker | Use this variant of the "backspeaker" accessory only for the "desired" column of the lookup table, for the recording use cases (path control mode RecordingMode)
AudioAccessoryCfgUserDefined1 | User defined.
AudioAccessoryCfgUserDefined2
AudioAccessoryCfgUserDefined3
AudioAccessoryCfgUserDefined4
AudioAccessoryCfgUserDefined5
AudioAccessoryCfgUserDefined6
AudioAccessoryCfgUserDefined7
AudioAccessoryCfgUserDefined8
AudioAccessoryCfgUserDefined9
AudioAccessoryCfgUserDefined11
AudioAccessoryCfgUserDefined12
AudioAccessoryCfgUserDefined13
AudioAccessoryCfgUserDefined14
AudioAccessoryCfgUserDefined15
AudioAccessoryCfgUserDefined16
AudioAccessoryCfgUserDefined17
AudioAccessoryCfgUserDefined18
AudioAccessoryCfgUserDefined19
CompatibleWithEverything

Constructor & Destructor Documentation

AudioAccessoryDetails::AudioAccessoryDetails | ( | const AudioAccessoryConfigurationType | configuration,
 |  | const AudioPath & | uplink,
 |  | const AudioPath & | downlink,
 |  | BOOLEAN | active,
 |  | const UINT | compat_setting,
 |  | const WString & | type_name,
 |  | const WString & | actual_name = ""
 | ) |

Parameters:
configuration | The configuration type
uplink | The uplink path to be used for this configuration
downlink | The downlink path to be used for this configuration
active | Indicates whether at the power up the accessory is already active/present or not
compat_setting | The compatibility information indicating with what accessory AudioAccessoryDetails::AudioAccessoryConfigurationType can be active at the same time. It can be also a combination of more than one accessory. Ex: AudioAccessoryDetails::AudioAccessoryCfgHeadset | AudioAccessoryDetails::AudioAccessoryCfgCarKit
type_name | The name of the accessory. For instance, "Bluetooth Headset"
actual_name | The name of the actual accessory. For instance, "Bob's office Bluetooth Headset".

Member Function Documentation

BOOLEAN AudioAccessoryDetails::CanActivateAudioPaths ( ) const

Check whether in case of connection the AudioPathManager will activate the accessory's audio paths. It is dependent of the priority of the accessory. If an accessory with higher priority is already active and its compatibility settings do not match with the ones of the current one, then SetConnected() will not have any efect with regards to audio paths, the audio paths will not be set up due to priority conflict

Returns:
TRUE if no priority conflict
Note:
TBD, in the future this function should also check for HW resource conflicts

void AudioAccessoryDetails::EnableEcNr ( BOOLEAN ecnr ) [inline]

Enable or disable Echo Cancelation and Noise Reduction when the accessory is connected.

WString AudioAccessoryDetails::GetActualName ( ) const

Get the actual name of the accessory that can be changed runtime. For instance, "Bob's office Bluetooth headset".

UINT AudioAccessoryDetails::GetCompatibilitySettings ( ) const

Get the compatibility settings given through the constructor.

AudioAccessoryDetails::AudioAccessoryConfigurationType AudioAccessoryDetails::GetConfigurationType ( ) const

Get the configuration/accessory ID.

BOOLEAN AudioAccessoryDetails::GetConnected ( ) const

AudioAccessoryDetails::ConnectedAccessoriesType AudioAccessoryDetails::GetConnectedAccessories ( ) [static]

AudioPath & AudioAccessoryDetails::GetDownlinkPath ( ) const

Get the downlink path for this configuration. See AudioPathManager for more path management details.

WString AudioAccessoryDetails::GetName ( ) const

Get the name of the accessory defined at the registration time. For instance, "Bluetooth headset".

BOOLEAN AudioAccessoryDetails::GetUpdatePath ( ) const

Return the status of the audio path update flag that indicates whether the audio path has to be updated once the accessory is being connected using SetConnected() function

Returns:
TRUE if audio paths will be setup after the connection

AudioPath & AudioAccessoryDetails::GetUplinkPath ( ) const

Get the uplink path for this configuration. See AudioPathManager for more path management details.

AudioDeviceBase::VolumeLevel AudioAccessoryDetails::GetVolume ( ) const [virtual]

Get volume level in percentages.

BOOLEAN AudioAccessoryDetails::IsActive ( ) const

Indicate whether the accessory device is active or not.

BOOLEAN AudioAccessoryDetails::IsEcNrActive ( ) [inline]

Check if Echo Cancelation and Noise Reduction is enabled for this accessory.

void AudioAccessoryDetails::SetActualName ( const WString & actual_name )

See GetActualName().

void AudioAccessoryDetails::SetConnected | ( | BOOLEAN | connected,
 |  | BOOLEAN | update_path = TRUE
 | ) |

Activate the accessory from the audio point of view. Once this function is called the audio path configuration will be updated considering also the compatible configurations specified through the constructor

Parameters:
connected | TRUE if has to be connected
update_path | TRUE if AudioPathManager has to add/remove the audio paths coresponding to this accessory FALSE, audio path will not be added.removed. This will be used for instance in case of TTY or BT accessories.
Note:
It is not enough to update_path as being TRUE to have the audio paths connected, there should not be a priority conflict as well, CanSetupAudioPaths()

void AudioAccessoryDetails::SetConnectedOld | ( | BOOLEAN | connected,
 |  | BOOLEAN | update_path = TRUE,
 |  | AudioDeviceBase::AudioSourceType | audio_source = AudioDeviceBase::DspAudioSource
 | ) |

void AudioAccessoryDetails::SetVolume ( AudioDeviceBase::VolumeLevel val ) [virtual]

Set volume level in percentages.

void AudioAccessoryDetails::TurnVolume ( BOOLEAN turn_up ) [virtual]

Turn the volume level up or down

Parameters:
turn_up TRUE if volume has to be increasead

void AudioAccessoryDetails::UpdateConfiguration ( )

Called by audio path manager before linking the accessory to update the audio path setting in case of runtime configurable audio paths, ex TTY can have different sets of audio paths depending on some MMI settings

Field Documentation

AudioAccessoryConfigurationType AudioAccessoryDetails::m_accessory_id [protected]

BOOLEAN AudioAccessoryDetails::m_active [protected]

WString AudioAccessoryDetails::m_actual_name [protected]

UINT AudioAccessoryDetails::m_compat_setting [protected]

AudioPath AudioAccessoryDetails::m_downlinkPath [protected]

BOOLEAN AudioAccessoryDetails::m_enable_ecnr [protected]

BOOLEAN AudioAccessoryDetails::m_paths_active [protected]

WString AudioAccessoryDetails::m_type_name [protected]

BOOLEAN AudioAccessoryDetails::m_update_path [protected]

AudioPath AudioAccessoryDetails::m_uplinkPath [protected]

The documentation for this class was generated from the following files:
  • Audio/AudioAccessoryDetails.hpp
  • Audio/AudioAccessoryDetails.cpp
Generated on Wed Jan 25 00:56:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioAccessoryStore Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioAccessoryStore Class Reference
[Audio]

#include <Apoxi/Audio/AudioAccessoryStore.hpp>

Collaboration diagram for AudioAccessoryStore:

[legend]

Public Types

typedef LinkedList< AudioAccessoryDetails > | AccessoryList
Discover what accessories are available.

Public Member Functions

void | AddItem (const AudioAccessoryDetails::AudioAccessoryConfigurationType configuration, const AudioPath::UplinkPathType uplinkPath, const AudioPath::DownlinkPathType downlinkPath, BOOLEAN active, const UINT compat_setting, const WString &type_name, const WString &actual_name="")
AudioAccessoryDetails * | GetAccessoryByCfgType (const AudioAccessoryDetails::AudioAccessoryConfigurationType configuration) const
AudioAccessoryDetails * | GetAccessoryByName (const WString &accessory_type_name, const WString &accessory_actual_name="") const
const AccessoryList & | GetAccessoryList () const
const AudioAccessoryDetails * | GetActiveAccessory_HighestPriority () const
Get the the active accessory having the highest priority and the audio paths set up as well. See AudioAccessoryDetails::SetConnected().
virtual const WCHAR * | GetName () const
BOOLEAN | UseAccessory (AudioAccessoryDetails *accessory)
virtual | ~AudioAccessoryStore ()

Static Public Member Functions

static AudioAccessoryStore * | GetInstance ()

Protected Member Functions

AudioAccessoryStore ()

Protected Attributes

AccessoryList m_accessory_list

Static Protected Attributes

static AudioAccessoryStore | m_instance

Detailed Description

Lists all the accessories available on this mobile phone.

The instance will be Initialized during OnPowerUp(), called by the SubSystemManager(), because the SubSystem constructor will register itself with the SubSystemManager.

Member Typedef Documentation

typedef LinkedList<AudioAccessoryDetails> AudioAccessoryStore::AccessoryList

Discover what accessories are available.

Constructor & Destructor Documentation

AudioAccessoryStore::AudioAccessoryStore ( ) [protected]

AudioAccessoryStore::~AudioAccessoryStore ( ) [virtual]

Member Function Documentation

void AudioAccessoryStore::AddItem | ( | const AudioAccessoryDetails::AudioAccessoryConfigurationType | configuration,
 |  | const AudioPath::UplinkPathType | uplinkPath,
 |  | const AudioPath::DownlinkPathType | downlinkPath,
 |  | BOOLEAN | active,
 |  | const UINT | compat_setting,
 |  | const WString & | type_name,
 |  | const WString & | actual_name = ""
 | ) |

Add an acessory to the store. This is normally called from project-specific or factory-customization configuration code.

AudioAccessoryDetails * AudioAccessoryStore::GetAccessoryByCfgType ( const AudioAccessoryDetails::AudioAccessoryConfigurationType configuration ) const

Get the accessory information for an accesssory, by configuration type

AudioAccessoryDetails * AudioAccessoryStore::GetAccessoryByName | ( | const WString & | accessory_type_name,
 |  | const WString & | accessory_actual_name = ""
 | ) | const

Get the accessory information for an accesssory, by name.

const AudioAccessoryStore::AccessoryList & AudioAccessoryStore::GetAccessoryList ( ) const

const AudioAccessoryDetails * AudioAccessoryStore::GetActiveAccessory_HighestPriority ( ) const

Get the the active accessory having the highest priority and the audio paths set up as well. See AudioAccessoryDetails::SetConnected().

AudioAccessoryStore * AudioAccessoryStore::GetInstance ( ) [static]

const WCHAR * AudioAccessoryStore::GetName ( ) const [virtual]

BOOLEAN AudioAccessoryStore::UseAccessory ( AudioAccessoryDetails * accessory )

Replace an already registered object with the one passed through the parameter

Parameters:
accessory The new accessory to be used
Returns:
TRUE if the accessory has been replaced.
Note:
The function if the accessory ID provided as parameter already exists in the list. If not, then the function will return FALSE, otherwise the accessory will be replaced. This function is used to avoid dependencies with modules such us BT. In case a derived accessory object has to be used then this function shall be used to "plug in" the new class type

Field Documentation

AccessoryList AudioAccessoryStore::m_accessory_list [protected]

AudioAccessoryStore AudioAccessoryStore::m_instance [static, protected]

The documentation for this class was generated from the following files:
  • Audio/AudioAccessoryStore.hpp
  • Audio/AudioAccessoryStore.cpp
Generated on Wed Jan 25 00:56:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioActiveReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioActiveReference Class Reference
[Audio]

#include <Apoxi/Audio/AudioActiveReference.hpp>

Inheritance diagram for AudioActiveReference:

[legend]
Collaboration diagram for AudioActiveReference:

[legend]

Public Types

enum | enumClassType { ClassType_AudioActiveReference }
For RTTI, without dynamic_cast<>. More...
typedef AudioReference::VolumeLevel | VolumeLevel

Public Member Functions

const AudioReference * | GetAudioReference () const
virtual enumClassType | GetClassType () const
For RTTI, without dynamic_cast<>.
const AudioDeviceBase * | GetDevice () const
AudioDeviceBase * GetDevice ()
SharedPtr< const AudioReference > | GetReference () const
VolumeLevel | GetVolume () const
Gets MMI volume.
BOOLEAN | GetVolumeSet () const
bool | operator== (const AudioActiveReference &other) const
BOOLEAN | Resume ()
BOOLEAN | SetChannelVolume (VolumeLevel val)
void | SetDevice (AudioDeviceBase *audio_player)
void | SetReference (AudioReference &audio_ref)
BOOLEAN | SetVolume (VolumeLevel val)
void | Stop ()
BOOLEAN | Suspend ()
virtual | ~AudioActiveReference ()

Static Public Member Functions

static SharedPtr< AudioActiveReference > | Create ()

Detailed Description

Member Typedef Documentation

typedef AudioReference::VolumeLevel AudioActiveReference::VolumeLevel

Member Enumeration Documentation

enum AudioActiveReference::enumClassType

For RTTI, without dynamic_cast<>.

Enumerator:
ClassType_AudioActiveReference

Constructor & Destructor Documentation

AudioActiveReference::~AudioActiveReference ( ) [virtual]

Member Function Documentation

SharedPtr< AudioActiveReference > AudioActiveReference::Create ( ) [static]

const AudioReference * AudioActiveReference::GetAudioReference ( ) const

AudioActiveReference::enumClassType AudioActiveReference::GetClassType ( ) const [virtual]

For RTTI, without dynamic_cast<>.

const AudioDeviceBase * AudioActiveReference::GetDevice ( ) const

AudioDeviceBase * AudioActiveReference::GetDevice ( )

SharedPtr< const AudioReference > AudioActiveReference::GetReference ( ) const

VolumeLevel AudioActiveReference::GetVolume ( ) const [inline]

Gets MMI volume.

BOOLEAN AudioActiveReference::GetVolumeSet ( ) const [inline]

Whether the SetVolume() was called.

bool AudioActiveReference::operator== ( const AudioActiveReference & other ) const

BOOLEAN AudioActiveReference::Resume ( )

Reimplemented from Timer.

BOOLEAN AudioActiveReference::SetChannelVolume ( VolumeLevel val )

void AudioActiveReference::SetDevice ( AudioDeviceBase * audio_player )

void AudioActiveReference::SetReference ( AudioReference & audio_ref )

BOOLEAN AudioActiveReference::SetVolume ( VolumeLevel val )

Sets MMI volume.

Parameters:
val The desired volume - the valid range is between 0 and 100. Setting the value 0 means silent.
Returns:
TRUE if successful

void AudioActiveReference::Stop ( )

Stops the timer and returns the remaining time to the expiration of the timer (in milliseconds)

Reimplemented from Timer.

BOOLEAN AudioActiveReference::Suspend ( )

The documentation for this class was generated from the following files:
  • Audio/AudioActiveReference.hpp
  • Audio/AudioActiveReference.cpp
Generated on Wed Jan 25 00:56:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioCapturerEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioCapturerEncoder Class Reference
[CodecManager]

#include <Apoxi/AddOns/CodecManager/AudioCapturerEncoder.hpp>

Inheritance diagram for AudioCapturerEncoder:

[legend]
Collaboration diagram for AudioCapturerEncoder:

[legend]

Public Types

typedef void(* | CbReady )(void *context)

Public Member Functions

virtual void | Close ()=0
virtual ResultType | ConfigureAAC (AacFormat aac_encoding_format, UINT16 sampling_rate, EncQualityConfig quality_config, MonoSteroConfig monostero_config, UINT32 max_buffer_size)=0
virtual ResultType | ConfigureAMR (AmrIfFormat amr_if_format, EncQualityConfig quality_config, AmrDtxConfig dtx_config, UINT32 max_buffer_size)=0
virtual ResultType | GetAudioChannelId (AudioChannel &audio_channel)=0
virtual ResultType | GetBuffer (AudioIOBuffer **buffer)=0
virtual ResultType | Open (AudioChannel &audio_channel)=0
virtual ResultType | RegisterCallbackFunctions (void *context, CbReady cb_data_available)=0

Friends

class | CodecManager

Detailed Description

Abstract audio capturer & encoder base class. The sub-classes of this class provide the actual audio encoder functionality API. The AudioCapturerEncoder sub-class instances are accessed by the clients via the CodecManager API.
See also:
CodecManager::ObtainDecoder

CodecManager::ReleaseDecoder

Member Typedef Documentation

typedef void(* AudioCapturerEncoder::CbReady)(void *context)

Callback function which is called when the audio capturer encoder is ready with the encoded data.

Parameters:
context A context (e.g. this pointer) that has been passed to the CodecDevice object when AudioCapturerEncoder::RegisterCallbackFunctions function has been invoked.
See also:
RegisterCallbackFunctions

Member Function Documentation

virtual void AudioCapturerEncoder::Close ( ) [pure virtual]

Closes and releases the audio capturer encoder. This method should be invoked as soon as the audio capturer encoder is not needed anymore to allow other audio capturer encoder to access the resources.

See also:
Open

Implemented in AtiAudioCapturerEncoder.

virtual ResultType AudioCapturerEncoder::ConfigureAAC | ( | AacFormat | aac_encoding_format,
 |  | UINT16 | sampling_rate,
 |  | EncQualityConfig | quality_config,
 |  | MonoSteroConfig | monostero_config,
 |  | UINT32 | max_buffer_size
 | ) | [pure virtual]

Configures the AudioCapturerEncoder device for AMR type.

Parameters:
aac_encoding_format | Requested AAC encoding format.
sampling_rate | Sampling rate.
quality_config | Recording quality, will be used to adjust recording bit rate.
monostero_config | Mono/Stero configuration.
max_buffer_size | Maximum size of buffers to be provided.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
RegisterCallbackFunctions

Implemented in AtiAudioCapturerEncoder.

virtual ResultType AudioCapturerEncoder::ConfigureAMR | ( | AmrIfFormat | amr_if_format,
 |  | EncQualityConfig | quality_config,
 |  | AmrDtxConfig | dtx_config,
 |  | UINT32 | max_buffer_size
 | ) | [pure virtual]

Configures the AudioCapturerEncoder device for AAC type.

Parameters:
amr_if_format | Requested AMR I/F.
quality_config | Recording quality, will be used to adjust recording bit rate.
dtx_config | Specifies if DTX is enabled or disabled.
max_buffer_size | Maximum size of buffers to be provided.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
RegisterCallbackFunctions

Implemented in AtiAudioCapturerEncoder.

virtual ResultType AudioCapturerEncoder::GetAudioChannelId ( AudioChannel & audio_channel ) [pure virtual]

This function retrieves the current audio channel ID.

Parameters:
audio_channel On return, the audio channel ID.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in AtiAudioCapturerEncoder.

virtual ResultType AudioCapturerEncoder::GetBuffer ( AudioIOBuffer ** buffer ) [pure virtual]

Provides the buffer which contains the encoded data.

Parameters:
buffer Pointer to the encoded data buffer.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
RegisterCallbackFunctions

Implemented in AtiAudioCapturerEncoder.

virtual ResultType AudioCapturerEncoder::Open ( AudioChannel & audio_channel ) [pure virtual]

Opens the audio encoder. In general, when a capturer encoder is opened, it is reserved for the caller and cannot be used by another caller. Thus, as soon as the audio capturer encoder is not needed anymore, it shall be released by using Close.

Parameters:
audio_channel On return, the audio channel ID.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Close

Implemented in AtiAudioCapturerEncoder.

virtual ResultType AudioCapturerEncoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbReady | cb_data_available
 | ) | [pure virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the AudioDecoderRenderer. This context is then passed as an argument of all callback functions invoked by the AudioCapturerEncoder.
cb_data_available | A pointer to a callback function that is invoked by the AudioCapturerEncoder when a frame has been encoded and the data available.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbReady

CodecDevice::CbResult

Friends And Related Function Documentation

friend class CodecManager [friend]

Reimplemented from CodecDevice.

The documentation for this class was generated from the following file:
  • AddOns/CodecManager/AudioCapturerEncoder.hpp
Generated on Wed Jan 25 00:56:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioContext Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/AudioContext.hpp>

Public Member Functions

AudioContext (Audio::AudioDevice device=Audio::DeviceBuzzer)
Audio::AudioDevice | GetDevice () const
Returns the currently set audio device.
Audio::AudioMode | GetMode () const
Returns the mode for the current device.
Audio::AudioPriority | GetPriority () const
Returns the current priority.
UINT8 | GetVolume () const
Retruns the currently set volume.
BOOLEAN | IsMute () const
Returns TRUE if the current device is mute, FALSE otherwise.
virtual BOOLEAN | PlaySound (Audio::ToneData *sound)
virtual BOOLEAN | PlaySound (Audio::AudioToneId sound, INT repeats=1)
void | SetAudioMode (Audio::AudioMode mode)
void | SetMute (BOOLEAN mute)
TRUE turns the current device off, FALSE turns it on.
void | SetPriority (Audio::AudioPriority priority)
void | SetVolume (UINT8 volume)
Sets the volume for the actual device.
virtual void | StopSound ()
Stops playing any sound.
virtual | ~AudioContext ()

Detailed Description

Obsolete - all sound classes from AddOns/MultiMedia have been replaced by a new audio concept. Use the AudioDeviceManager instead for playing sounds.

Constructor & Destructor Documentation

AudioContext::AudioContext ( Audio::AudioDevice device = Audio::DeviceBuzzer )

Constructs an AudioContext for the desired audio device.

See also:
Audio::AudioDevice

AudioContext::~AudioContext ( ) [virtual]

Member Function Documentation

Audio::AudioDevice AudioContext::GetDevice ( ) const [inline]

Returns the currently set audio device.

Audio::AudioMode AudioContext::GetMode ( ) const [inline]

Returns the mode for the current device.

Audio::AudioPriority AudioContext::GetPriority ( ) const [inline]

Returns the current priority.

UINT8 AudioContext::GetVolume ( ) const [inline]

Retruns the currently set volume.

BOOLEAN AudioContext::IsMute ( ) const [inline]

Returns TRUE if the current device is mute, FALSE otherwise.

BOOLEAN AudioContext::PlaySound ( Audio::ToneData * sound ) [virtual]

Plays the given sound with the current settings. Returns whether or not the sound could be played.

BOOLEAN AudioContext::PlaySound | ( | Audio::AudioToneId | sound,
 |  | INT | repeats = 1
 | ) | [virtual]

Plays the given predefined sound with the current settings. Returns whether or not the sound could be played.

void AudioContext::SetAudioMode ( Audio::AudioMode mode )

Sets the audio mode for all devices. Default mode is normal mode.

See also:
Audio::AudioMode

void AudioContext::SetMute ( BOOLEAN mute )

TRUE turns the current device off, FALSE turns it on.

void AudioContext::SetPriority ( Audio::AudioPriority priority ) [inline]

Sets the priority a sound should be played with. Default priority is low priority.

See also:
Audio::AudioPriority

void AudioContext::SetVolume ( UINT8 volume )

Sets the volume for the actual device.

void AudioContext::StopSound ( ) [virtual]

Stops playing any sound.

The documentation for this class was generated from the following files:
  • Compat/AudioContext.hpp
  • Compat/AudioContext.cpp
Generated on Wed Jan 25 00:56:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioDecoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioDecoder Class Reference
[CodecManager]

#include <Apoxi/AddOns/CodecManager/AudioDecoder.hpp>

Inheritance diagram for AudioDecoder:

[legend]
Collaboration diagram for AudioDecoder:

[legend]

Public Types

enum | AacFormatType { AacRawFormat, AacAdifOrAdtsFormat, AacAdtsWithOneRawDataBlockFormat }
typedef void(* | CbFrameDecoded )(ResultType result, void *context, const UINT8 HUGE *out_buf, UINT32 out_buf_len, UINT32 in_buf_used)
enum | DecodingFunctionType { DecodeBufferFct, DecodeFrameFct }
enum | ParameterType { QualityLevel, Format, EndOfParameterType }

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len, DecodingFunctionType &dec_fct)=0
virtual void | Close ()=0
virtual ResultType | DecodeBuffer (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)=0
virtual ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)=0
virtual ResultType | GetCapabilities (AudioCodecCapabilities &caps)=0
virtual ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)=0
virtual ResultType | Open ()=0
virtual ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded)=0
virtual ResultType | SetConfig (const UINT8 *config_stream, UINT32 &config_len, const AudioDecoderParameters &params, AudioStreamInfo &stream_info)=0
virtual ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)=0

Friends

class | CodecManager

Detailed Description

Abstract audio decoder base class. The sub-classes of this class provide the actual audio decoder functionality API. The AudioDecoder sub-class instances are accessed by the clients via the CodecManager API.
See also:
CodecManager::ObtainDecoder

CodecManager::ReleaseDecoder

Member Typedef Documentation

typedef void(* AudioDecoder::CbFrameDecoded)(ResultType result, void *context, const UINT8 HUGE *out_buf, UINT32 out_buf_len, UINT32 in_buf_used)

Callback function that is invoked by the AudioDecoder when a frame has been decoded and is ready for rendering.

Parameters:
result | A result (error) code: Success if the operation was successful. Otherwise, an appropriate error code.
context | A context (e.g. this pointer) that has been passed to the AudioDecoder object when AudioDecoder::RegisterCallbackFunctions has been invoked.
out_buf | Pointer to the audio output buffer with the decoded frame.
out_buf_len | Length of the audio data in the output buffer (in bytes).
in_buf_used | Number of bytes of the input buffer that were used (consumed) by the decoder.
See also:
DecodeFrame

RegisterCallbackFunctions

Member Enumeration Documentation

enum AudioDecoder::AacFormatType

AAC input data format type.

Enumerator:
AacRawFormat | Input is in raw format preceeded with config information.
AacAdifOrAdtsFormat | Input is in ADIF foramt or ADTS format (used in case of more than one raw data blocks per frame.
AacAdtsWithOneRawDataBlockFormat | Input is in ADTS format and number of raw data blocks per frame is fixed to be 1 with a maximum of two channels.

enum AudioDecoder::DecodingFunctionType

Decoding function type.

Enumerator:
DecodeBufferFct
DecodeFrameFct

enum AudioDecoder::ParameterType

Parameter type. It is used by the AudioDecoder::SetParameters and AudioDecoder::GetParameters functions.

Enumerator:
QualityLevel This parameter has to be casted to UINT16. It defines the quality level of the decoder. The greater this value, the better the quality. 0 corresponds to default settings. If the value is greater than the maximum supported quality level (which can be retrieved via AudioDecoder::GetCapabilities), the maximum level shall be set. Only for AudioDecoder::SetParameters function.
Format Format parameter type. This parameter is intepreted in different way dependending on the actual audio decoder. It has to be casted to the type specific for a given audio codec:
For AAC it has to be casted to AudioDecoder::AacFormatType enum.
EndOfParameterType

Member Function Documentation

virtual ResultType AudioDecoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len,
 |  | DecodingFunctionType & | dec_fct
 | ) | [pure virtual]

Allocates a number of output buffers that are used to store the decoded frames. The array will be freed (deallocated) when using CodecManager::StopAudioDecoder.

Parameters:
out_buf_array | On return, a pointer to the output buffer array (the elements of the array are pointers to the actual buffers).
out_buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e. the AudioDecoder adapt the number passed in by the caller if necessary.
out_buf_len | On return, the actual buffer length, i.e. the AudioDecoder.
dec_fct | The caller informs the audio decoder about the function that it wants to be used for decoding (since the output buffers length and number depends on the decoding funtion). On return, contains the actually used value (e.g. if the desired decoding function is not supported).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CodecManager::StopAudioDecoder

virtual void AudioDecoder::Close ( ) [pure virtual]

Closes and releases the audio decoder. This method should be invoked as soon as the audio decoder is not needed anymore to allow other audio decoders to access the resources.

See also:
Open

Implemented in EmzAacDecoder, and EmzMp3Decoder.

virtual ResultType AudioDecoder::DecodeBuffer | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [pure virtual]

Decodes an audio buffer. The input buffer shall contain at least one complete frame. This function continues decoding until there is no complete frame in the input buffer or not enough space in the output buffer. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbFrameDecoded will be invoked. Note: In the callback function the number of consumed bytes (of the input buffer) will be returned.

Parameters:
in_buf | Pointer to the audio input buffer (containing the encoded frames).
in_buf_len | Length of the audio input buffer (in bytes).
out_buf | Pointer to the audio output buffer (containing the decoded frames).
out_buf_len | Length of the audio output buffer (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

Implemented in EmzAacDecoder, EmzMp3Decoder, EmzAacDecoder, and EmzMp3Decoder.

virtual ResultType AudioDecoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [pure virtual]

Decodes an audio frame. The input buffer contains always one complete frame. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbFrameDecoded will be invoked. Note: In the callback function the number of consumed bytes (of the input buffer) will be returned.
DecodeBuffer shall be preferred to this function.

Parameters:
in_buf | Pointer to the audio input buffer (containing the encoded frame).
in_buf_len | Length of the audio input buffer (in bytes).
out_buf | Pointer to the audio output buffer (containing the decoded frame).
out_buf_len | Length of the audio output buffer (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

DecodeBuffer

Implemented in EmzAacDecoder, EmzMp3Decoder, EmzAacDecoder, and EmzMp3Decoder.

virtual ResultType AudioDecoder::GetCapabilities ( AudioCodecCapabilities & caps ) [pure virtual]

This function is used to retrieve the capabilities of the audio decoder (AudioDecoder sub-class).

Parameters:
caps On return, it contains the capabilities.
Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the AudioDecoder sub-class.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in EmzAacDecoder, and EmzMp3Decoder.

virtual ResultType AudioDecoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [pure virtual]

This function retrieves the values of specified parameters in the audio decoder.

Parameters:
types_array | Array of the parameter types that specify the parameters to be retrieved.
values_array | On return, array of the retrieved parameter values. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type. The caller has to allocate memory for this array before invoking of this function. The existing elements of the array are then filled with the corresponding parameter values by the audio decoder.
array_count | Length (number of elements) of the types_array and types_array i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType AudioDecoder::Open ( ) [pure virtual]

Opens the audio decoder. In general, when a decoder is opened, it is reserved for the caller and cannot be used by another caller. Thus, as soon as the audio decoder is not needed anymore, it shall be released by using Close.

Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Close

Implemented in EmzAacDecoder, and EmzMp3Decoder.

virtual ResultType AudioDecoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded
 | ) | [pure virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the AudioDecoder. This context is then passed as an argument of all callback functions invoked by the AudioDecoder.
cb_frame_decoded | A pointer to a callback function that is invoked by the AudioDecoder when a frame has been decoded (and post-processed) and is ready for rendering.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType AudioDecoder::SetConfig | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const AudioDecoderParameters & | params,
 |  | AudioStreamInfo & | stream_info
 | ) | [pure virtual]

Configures the audio decoder.

Parameters:
config_stream | Pointer to the configuration stream for audio decoder.
config_len | Length of the configuration stream config_stream in number of bytes. On return it contains the number of bytes consumed.
params | Audio decoder parameters. The parameter audio_codec indicates the audio codec (if known to the caller) that shall be used for decoding. If the audio codec is not known to the caller, this parameter shall be set to CodecManager::UnknownCodec or CodecManager::DefaultCodec and the AudioDecoder sub-class shall find out the appropriate codec (if supported). The same applies if the passed audio codec is not valid.
stream_info | On return, it contains the encoded stream info.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in EmzAacDecoder, and EmzMp3Decoder.

virtual ResultType AudioDecoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [pure virtual]

Sets dynamically one or more decoder parameters.

Parameters:
types_array | Array of the parameter types that specify the parameters to be changed. The corresponding values to be set are delivered in values_array.
values_array | Array of the values to which the corresponding parameters have to be set. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type.
array_count | Length (number of elements) of the types_array and values_array, i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Friends And Related Function Documentation

friend class CodecManager [friend]

Reimplemented from CodecDevice.

The documentation for this class was generated from the following file:
  • AddOns/CodecManager/AudioDecoder.hpp
Generated on Wed Jan 25 00:56:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioDecoderRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioDecoderRenderer Class Reference
[CodecManager]

#include <Apoxi/AddOns/CodecManager/AudioDecoderRenderer.hpp>

Inheritance diagram for AudioDecoderRenderer:

[legend]
Collaboration diagram for AudioDecoderRenderer:

[legend]

Public Types

typedef void(* | CbReady )(void *context)

Public Member Functions

virtual void | Close ()=0
virtual ResultType | DecodeRenderBuffer (AudioIOBuffer *buffer)=0
virtual ResultType | GetAudioChannelId (AudioChannel &audio_channel)=0
virtual ResultType | Open (AudioChannel &audio_channel)=0
virtual ResultType | RegisterCallbackFunctions (void *context, CbReady cb_ready_for_data, CbResult cb_all_buffers_processed)=0

Friends

class | CodecManager

Detailed Description

Abstract audio decoder & renderer base class. The sub-classes of this class provide the actual audio decoder functionality API. The AudioDecoderRenderer sub-class instances are accessed by the clients via the CodecManager API.
See also:
CodecManager::ObtainDecoder

CodecManager::ReleaseDecoder

Member Typedef Documentation

typedef void(* AudioDecoderRenderer::CbReady)(void *context)

Callback function which is called when the audio decoder is ready to be fed with new input (encoded) data.

Parameters:
context A context (e.g. this pointer) that has been passed to the CodecDevice object when AudioDecoderRenderer::RegisterCallbackFunctions function has been invoked.
See also:
RegisterCallbackFunctions

Member Function Documentation

virtual void AudioDecoderRenderer::Close ( ) [pure virtual]

Closes and releases the audio decoder. This method should be invoked as soon as the audio decoder is not needed anymore to allow other audio decoders to access the resources.

See also:
Open

Implemented in AtiAudioDecoderRenderer.

virtual ResultType AudioDecoderRenderer::DecodeRenderBuffer ( AudioIOBuffer * buffer ) [pure virtual]

Decodes and renders an audio buffer. The input buffer shall contain at least one complete frame. When next input data are requested the callback function CbReady is called.

Parameters:
buffer Structure containing pointer to the audio input buffer (containing the encoded frames) amongst other required buffer information.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbReady

RegisterCallbackFunctions

Implemented in AtiAudioDecoderRenderer.

virtual ResultType AudioDecoderRenderer::GetAudioChannelId ( AudioChannel & audio_channel ) [pure virtual]

This function retrieves the current audio channel ID.

Parameters:
audio_channel On return, the audio channel ID.

Implemented in AtiAudioDecoderRenderer.

virtual ResultType AudioDecoderRenderer::Open ( AudioChannel & audio_channel ) [pure virtual]

Opens the audio decoder. In general, when a decoder is opened, it is reserved for the caller and cannot be used by another caller. Thus, as soon as the audio decoder is not needed anymore, it shall be released by using Close.

Parameters:
audio_channel On return, the audio channel ID.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Close

Implemented in AtiAudioDecoderRenderer.

virtual ResultType AudioDecoderRenderer::RegisterCallbackFunctions | ( | void * | context,
 |  | CbReady | cb_ready_for_data,
 |  | CbResult | cb_all_buffers_processed
 | ) | [pure virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the AudioDecoderRenderer. This context is then passed as an argument of all callback functions invoked by the AudioDecoderRenderer.
cb_ready_for_data | A pointer to a callback function that is invoked by the AudioDecoderRenderer when a frame has been decoded (and post-processed) and is ready for rendering.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbReady

CodecDevice::CbResult

Friends And Related Function Documentation

friend class CodecManager [friend]

Reimplemented from CodecDevice.

Reimplemented in AtiAudioDecoderRenderer.

The documentation for this class was generated from the following file:
  • AddOns/CodecManager/AudioDecoderRenderer.hpp
Generated on Wed Jan 25 00:56:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioDeviceBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioDeviceBase Class Reference
[Audio]

#include <Apoxi/Audio/AudioDeviceBase.hpp>

Inheritance diagram for AudioDeviceBase:

[legend]
Collaboration diagram for AudioDeviceBase:

[legend]

Public Types

enum | AudioDeviceStatus { StatusEnabled, StatusDisabled }
List of audio device status. More...
enum | AudioErrorType { NoErrorType = 0, FileOperationErrorType, InvalidFormatErrorType, GeneralErrorType }
typedef INT | Feature
enum | MuteDirection { UplinkDirection, DownlinkDirection, UpDownlinkDirection }
enum PredefinedFeature {
SetTimeFeature, GetTimeFeature, MmfSuspendFeature, MmfResumeFeature,
GenericFastForward, GenericRewind, GenericGetTrackInfo, MmfGetAudioTrackInfo,
FmRadioSeekStationFeature, FmRadioSetStationFeature, FmRadioRssiLevelFeature, FmRadioRdsFeature,
FmRadioRdsStationNameFeature, FmRadioRdsRadioTextFeature, FmRadioRdsRawDataFeature, FmRadioRdsAlternativeFrequenciesFeature,
PredefinedFeatureEnd
}
Predefined values for Feature. More...
enum StopCause {
InvalidCause = 0, DriverCause, VoluntaryCause, PriorityManagementCause,
TimerCause
}
typedef AudioReference::VolumeLevel | VolumeLevel
See volume concept documentation.

Public Member Functions

AudioDeviceBase ()
virtual BOOLEAN | ExecuteFeature (Feature feature, GenericObject *data=0)
virtual UINT16 | GetDeviceID () const =0
Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).
VolumeLevel | GetDeviceVolume () const
VolumeLevel | GetMasterVolume () const
VolumeLevel | GetVolume () const
Deprecated, use GetDeviceVolume instead.
virtual BOOLEAN | IsFeatureSupported (Feature feature, MimeType mime_type=c_mime_unknown, AudioReference::SoundDataSource sound_data_source=AudioReference::InvalidSoundDataSource) const
BOOLEAN | SetDeviceVolume (VolumeLevel volume)
BOOLEAN | SetMasterVolume (VolumeLevel volume)
virtual BOOLEAN | SetMute (BOOLEAN enable=TRUE, MuteDirection direction=UpDownlinkDirection)
BOOLEAN | SetVolume (VolumeLevel volume)
Deprecated, use SetDeviceVolume instead.
virtual BOOLEAN | UpdateReferenceVolume (const AudioActiveReference &active_reference)
virtual | ~AudioDeviceBase ()

Protected Member Functions

virtual BOOLEAN | ApplyDeviceVolume ()
virtual BOOLEAN | ApplyMasterVolume ()
VolumeLevel | GetVolume_Specific (const AudioReference &audio_ref)
Returns the specific volume, or the player's default volume if no specific volume was specified.

Static Protected Member Functions

static Mutex * | GetMutex ()

Protected Attributes

BOOLEAN | m_mute
Volume of a sound that is currently playing.

Detailed Description

AudioDeviceBase is the base class for AudioPlayers and SimpleAudioDevices (including the speech device). An AudioDeviceBase supports changing volume, muting, and querying and execution of generic features. Usually, an AudioDeviceBase corresponds to some piece of hardware, and should be implemented as a singleton.

Member Typedef Documentation

typedef INT AudioDeviceBase::Feature

Uniquely identifies a feature that a device may support. Extension (non-predefined) values must avoid overlap (with predefined values and among each other).

typedef AudioReference::VolumeLevel AudioDeviceBase::VolumeLevel

See volume concept documentation.

Member Enumeration Documentation

enum AudioDeviceBase::AudioDeviceStatus

List of audio device status.

Enumerator:
StatusEnabled | Enabled.
StatusDisabled | Disabled.

enum AudioDeviceBase::AudioErrorType

Audio Error codes that can be sent to applications. Used in AudioStoppedMsg

Enumerator:
NoErrorType | No error.
FileOperationErrorType | File operation error.
InvalidFormatErrorType | Invalid format error.
GeneralErrorType | General error.

enum AudioDeviceBase::MuteDirection

Enumerator:
UplinkDirection | mute/unmute uplink
DownlinkDirection | mute/unmute downlink
UpDownlinkDirection | mute/unmute both uplink and downlink

enum AudioDeviceBase::PredefinedFeature

Predefined values for Feature.

Enumerator:
SetTimeFeature
GetTimeFeature
MmfSuspendFeature
MmfResumeFeature
GenericFastForward Used for fast forward - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x is the rate of fast forward data.SetActiveReference(y); where y is the active reference to apply fast forward

To resume normal playback this feature has to be executed again with data.SetNumber(0);

When fast forward has started, a message is sent containing the active reference: AudioFastForwardStartedMsg

If the end of the file is reached during fast forward the sound will be stopped and a message will be sent: AudioStoppedMsg

Please be aware that executing this feature has no effect if the sound is in suspended or stopped state

GenericRewind Used for rewind - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x is the rate of rewind data.SetActiveReference(y); where y is the active reference to apply rewind

To resume normal playback this feature has to be executed again with data.SetNumber(0);

When rewind has started, a message is sent containing the active reference: AudioRewindStartedMsg

If the begin of the file is reached during rewind the sound will be stopped and a message will be sent: AudioStoppedMsg

Please be aware that executing this feature has no effect if the sound is in suspended or stopped state

GenericGetTrackInfo Used to get the track info of a sound - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetActiveReference(x); where x is the active reference

The track info will be returned in the GenericFeatureData object.

For further information regarding the available information please have a look at the structure GenericTrackInfo which is defined in the class GenericFeatureData

Please be aware that executing this feature has no effect if the sound is in stopped state

MmfGetAudioTrackInfo Used to get the "multimedia framework specific" track info of a sound - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetActiveReference(x); where x is the active reference

The track info will be returned as a pointer which is accessible by calling: MediaInfo::AudioTrackInfo* track_info = (MediaInfo::AudioTrackInfo*)data.GetDataPtr();

For further information regarding the available information please have a look at the documentation of MediaInfo::AudioTrackInfo.

Please be aware that executing this feature has no effect if the sound is in stopped state

FmRadioSeekStationFeature Used to seek for a radio station - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x is the seek direction

To seek up, set the value 0. To seek down, set the value 1.

FmRadioSetStationFeature Used to set a radio station - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x is the frequency of the radio station in Hertz

Example: To set the station 88.8 MHz set the value 88800000.

FmRadioRssiLevelFeature Used to subscribe to/unsubscribe from RSSI notification - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x enables/disables the subscription

To subscribe, set the value 1. To unsubscribe, set the value 0.

If the RSSI level changes, the message AudioFmRadioRssiMsg will be sent. The message contains the following information: The signal level as UINT8. Mono/Stereo as BOOLEAN.

FmRadioRdsFeature Used to basically enable/disable RDS data decoding - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x enables/disables RDS decoding

To enable RDS decoding, set the value 1. To disable RDS decoding, set the value 0.

If the selected radio station sends RDS data, the message AudioFmRadioRdsInfoMsg will be sent containing basic information about the radio station.

FmRadioRdsStationNameFeature Used to enable/disable decoding of the station name - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x enables/disables station name decoding

To enable station name decoding, set the value 1. To disable station name decoding, set the value 0.

If the station is decoded successfully, the message AudioFmRadioRdsStationNameMsg will be sent containing station name.

Please be aware that decoding the station name only works if the feature FmRadioRdsFeature is enabled as well.

FmRadioRdsRadioTextFeature Used to enable/disable decoding of the radio text - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x enables/disables radio text decoding

To enable radio text decoding, set the value 1. To disable radio text decoding, set the value 0.

The message AudioFmRadioRdsRadioTextMsg will be sent regularly containing the decoded parts of the radio text.

Please be aware that decoding the radio text only works if the feature FmRadioRdsFeature is enabled as well.

FmRadioRdsRawDataFeature Used to enable/disable sending the raw RDS data - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x enables/disables sending the RDS raw data

To enable sending the raw data, set the value 1. To disable sending the raw data, set the value 0.

The message AudioFmRadioRdsRawDataMsg will be sent regularly containing the raw RDS data.

Please be aware that sending the raw data only works if the feature FmRadioRdsFeature is enabled as well. Additionally, the receiver of the message has to take care of deleting the allocated memory of the buffer which is sent in the message.

FmRadioRdsAlternativeFrequenciesFeature Used to enable/disable decoding alternative frequencies - the following members have to set in the GenericFeatureData object which has to be passed when executing the feature: data.SetNumber(x); where x enables/disables decoding alternative frequencies

To enable decoding alternative frequencies, set the value 1. To disable decoding alternative frequencies, set the value 0.

The message AudioFmRadioRdsAlternativeFrequenciesMsg will be sent regularly containing the currently available alternative frequencies.

Please be aware that decoding alternative frequencies only works if the feature FmRadioRdsFeature is enabled as well. Additionally, the receiver of the message has to take care of deleting the allocated memory of the buffer which is sent in the message.

PredefinedFeatureEnd

enum AudioDeviceBase::StopCause

Stop cause if audio has stopped playing. Used in AudioStoppedMsg

Enumerator:
InvalidCause
DriverCause
VoluntaryCause
PriorityManagementCause
TimerCause

Constructor & Destructor Documentation

AudioDeviceBase::AudioDeviceBase ( )

AudioDeviceBase::~AudioDeviceBase ( ) [virtual]

Member Function Documentation

BOOLEAN AudioDeviceBase::ApplyDeviceVolume ( ) [protected, virtual]

Reimplemented in MmfPlayer, and SpeechSimpleAudioDevice.

BOOLEAN AudioDeviceBase::ApplyMasterVolume ( ) [protected, virtual]

virtual BOOLEAN AudioDeviceBase::ExecuteFeature | ( | Feature | feature,
 |  | GenericObject * | data = 0
 | ) | [inline, virtual]

Executes the feature using the supplied data. The device should check whether it is getting the kind of data it expects using the mechanisms of GenericObject. The effects of executing the feature are not specified here, and can be freely specified by the device.

Parameters:
feature | identifies the feature.
data | feature-specific data. The feature implementation and feature clients have to agree on this.
Returns:
TRUE if the request could be made successfully.

Reimplemented in MmfPlayer.

virtual UINT16 AudioDeviceBase::GetDeviceID ( ) const [pure virtual]

Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).

Implemented in MapiAudioPlayer, AudioVibratorDevice, and MmfPlayer.

VolumeLevel AudioDeviceBase::GetDeviceVolume ( ) const [inline]

VolumeLevel AudioDeviceBase::GetMasterVolume ( ) const [inline]

Mutex * AudioDeviceBase::GetMutex ( ) [static, protected]

AudioDeviceBase::VolumeLevel AudioDeviceBase::GetVolume ( ) const

Deprecated, use GetDeviceVolume instead.

AudioDeviceBase::VolumeLevel AudioDeviceBase::GetVolume_Specific ( const AudioReference & audio_ref ) [protected]

Returns the specific volume, or the player's default volume if no specific volume was specified.

virtual BOOLEAN AudioDeviceBase::IsFeatureSupported | ( | Feature | feature,
 |  | MimeType | mime_type = c_mime_unknown,
 |  | AudioReference::SoundDataSource | sound_data_source = AudioReference::InvalidSoundDataSource
 | ) | const [inline, virtual]

Queries the device whether it supports the feature.

Parameters:
feature | identifies the feature.
mime_type | the mime type for which support is queried. The default means the feature has to be supported for all mime types.
sound_data_source | the SoundDataSource for which support is queried. The default means the feature has to be supported for all SoundDataSources.
Returns:
TRUE if the feature is supported for the supplied mime type and SoundDataSource.

Reimplemented in MmfPlayer.

BOOLEAN AudioDeviceBase::SetDeviceVolume ( VolumeLevel volume )

Sets device volume. See volume concept doc.

Parameters:
volume volume to be set
Returns:
TRUE for success

BOOLEAN AudioDeviceBase::SetMasterVolume ( VolumeLevel volume )

Sets master volume. See volume concept doc.

Parameters:
volume volume to be set
Returns:
TRUE for success

BOOLEAN AudioDeviceBase::SetMute | ( | BOOLEAN | enable = TRUE,
 |  | MuteDirection | direction = UpDownlinkDirection
 | ) | [virtual]

Mutes or unmutes the device.

Parameters:
enable | TRUE mutes the device. When mute is disabled (using FALSE), the last volume setting will be used.
direction | Determines whether the uplink, downlink, or both are affected.
Returns:
TRUE indicates success.
Note:
For master mute use AudioDeviceBaseManager::EnableMasterMute()

BOOLEAN AudioDeviceBase::SetVolume ( VolumeLevel volume )

Deprecated, use SetDeviceVolume instead.

BOOLEAN AudioDeviceBase::UpdateReferenceVolume ( const AudioActiveReference & active_reference ) [virtual]

Field Documentation

BOOLEAN AudioDeviceBase::m_mute [protected]

Volume of a sound that is currently playing.

The documentation for this class was generated from the following files:
  • Audio/AudioDeviceBase.hpp
  • Audio/AudioDeviceBase.cpp
Generated on Wed Jan 25 00:56:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioDeviceManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioDeviceManager Class Reference
[Audio]

#include <Apoxi/Audio/AudioDeviceManager.hpp>

Collaboration diagram for AudioDeviceManager:

[legend]

Public Types

typedef AudioAccessoryStore::AccessoryList | AccessoryList
enum AudioDeviceID {
ToneDeviceID, RingerDeviceID, MIDIRingerDeviceID, VoiceMemoDeviceID,
PCMDeviceID, MP3DeviceID, SpeechDeviceID, VibratorDeviceID,
RadioDeviceID, YamahaMapiId, AudioDeviceEndId
}
List of audio devices available. Note: Not all devices are lised here. See GetDevice. More...
typedef void(* | OnAudioMessageCallback )(const Message *message, void *pUserData)
typedef AudioPlayer::AudioSourceType | SourceType

Public Member Functions

SharedPtr< AudioReference > | CreateAudioReferenceFromBinData (MimeType mime_type, BinData *bin_data)
SharedPtr< AudioReference > | CreateAudioReferenceFromExtensionSoundDataSource (MimeType mime_type, AudioReference::SoundDataSource sound_data_source)
SharedPtr< AudioReference > | CreateAudioReferenceFromFFS (const String &filename)
SharedPtr< AudioReference > | CreateAudioReferenceFromPreset (MimeType mime_type, AudioPreset::AudioPresetSoundToneId tone_id)
SharedPtr< AudioReference > | CreateAudioReferenceFromRamBuffer (MimeType mime_type, AudioPlayer::ConstBuffer buffer, UINT32 buffer_size)
SharedPtr< AudioReference > | CreateAudioReferenceFromRamBuffer (MimeType mime_type, AudioPlayer::Buffer buffer, UINT32 buffer_size)
SharedPtr< AudioReference > | CreateAudioReferenceFromRFS (const Path &path)
SharedPtr< AudioReference > | CreateAudioReferenceFromStream (MimeType mime_type, AudioPlayer::GetAudioBufferFunction func, void *user_data=0)
const AccessoryList | GetAccessoryList () const
AudioPlayer * | GetAudioPlayer (const AudioReference &file_reference)
AudioDeviceBase * | GetDevice (AudioDeviceID device)
Get a player for this device-ID.
AudioAccessoryDetails::AudioAccessoryConfigurationType | GetLinkedAccessory (SourceType source) const
BOOLEAN | LinkAccessory (SourceType source, AudioAccessoryDetails &accessory)
Obsolete. Use AudioAccessoryDetails::SetConnected.
void | SubscribeAudioMessageCallback (OnAudioMessageCallback func, void *pUserData=0)
void | UnsubscribeAudioMessageCallback (OnAudioMessageCallback func, void *pUserData=0)
virtual | ~AudioDeviceManager ()

Static Public Member Functions

static BOOLEAN | EnableMasterMute (BOOLEAN enable=TRUE)
static AudioDeviceManager & | GetInstance ()
static BOOLEAN | GetMasterMute ()
static AudioDeviceBase::VolumeLevel | GetMasterVolume ()
static void | MapAndUpdateVolumes ()
static SharedPtr< AudioActiveReference > | Play (const AudioReference &file_reference)
static void | PostAudioUserDefinedMessage (UINT8 messageID, UINT16 senderID=0, UINT32 param1=0, UINT32 param2=0, UINT32 param3=0, UINT32 param4=0)
static BOOLEAN | SetMasterVolume (AudioDeviceBase::VolumeLevel volume)
static SharedPtr< AudioActiveReference > | StartRecording (const AudioReference &audio_ref)
static void | StopAllSounds ()
static void | StopRecording (AudioActiveReference &active_reference)
static void | SuspendAllPlayingSounds ()

Protected Attributes

AudioAccessoryDetails::AudioAccessoryConfigurationType m_accessory
AudioVibratorDevice m_device_vibrator

Static Protected Attributes

static BOOLEAN | m_ecnr_state = TRUE
static AudioDeviceManager | m_Instance
static BOOLEAN | m_master_mute = FALSE
static AudioDeviceBase::VolumeLevel | m_master_volume = 100

Detailed Description

This is the main starting point for the APOXI Audio API. This is a singleton - use GetInstance().

Member Typedef Documentation

typedef AudioAccessoryStore::AccessoryList AudioDeviceManager::AccessoryList

typedef void(* AudioDeviceManager::OnAudioMessageCallback)(const Message *message, void *pUserData)

This is the type of callback functions that can be registered as audio message handlers. See SubscribeAudioMessageCallback.

Parameters:
Message | the message to be handled
The | pUserData parameter previously provided to SubscribeAudioMessageCallback().

typedef AudioPlayer::AudioSourceType AudioDeviceManager::SourceType

Member Enumeration Documentation

enum AudioDeviceManager::AudioDeviceID

List of audio devices available. Note: Not all devices are lised here. See GetDevice.

Enumerator:
ToneDeviceID | DSP tone player.
RingerDeviceID | External ringer player.
MIDIRingerDeviceID | Internal ringer player.
VoiceMemoDeviceID | Voice memo (AMR) player.
PCMDeviceID | PCM player.
MP3DeviceID | MP3 player.
SpeechDeviceID | Speech channel.
VibratorDeviceID | VibratorDeviceID is used only for E-Gold based platforms.
RadioDeviceID | FM radio device.
YamahaMapiId | device for Yamaha music API (MAPI)
AudioDeviceEndId

Constructor & Destructor Documentation

AudioDeviceManager::~AudioDeviceManager ( ) [virtual]

Member Function Documentation

SharedPtr< AudioReference > AudioDeviceManager::CreateAudioReferenceFromBinData | ( | MimeType | mime_type,
 |  | BinData * | bin_data
 | ) |

Creates an AudioReference to audio data from a BinData.

Parameters:
mime_type | The mime type of the audio data
bin_data | The pointer to the BinData object which contains the audio data. The desctruction of the BinData is in responsibility of the application.
Note:
The non standard MIME types are defined as AudioCustomMimeTypeId in Project.hpp

SharedPtr< AudioReference > AudioDeviceManager::CreateAudioReferenceFromExtensionSoundDataSource | ( | MimeType | mime_type,
 |  | AudioReference::SoundDataSource | sound_data_source
 | ) |

This method is introduced to support the creation of AudioReferences from data sources which are not covered by the four methods above (basically for future needs).

Note:
The non standard MIME types are defined as AudioCustomMimeTypeId in Project.hpp

SharedPtr< AudioReference > AudioDeviceManager::CreateAudioReferenceFromFFS ( const String & filename )

This function is obsolete. Use CreateAudioReferenceFromRFS instead

Deprecated:
Get an AudioReference for the file in the Flash File System.
Parameters:
filename Flash File System file.
Returns:
A new AudioReference.

SharedPtr< AudioReference > AudioDeviceManager::CreateAudioReferenceFromPreset | ( | MimeType | mime_type,
 |  | AudioPreset::AudioPresetSoundToneId | tone_id
 | ) |

Creates an AudioReference to a preset audio data.

Note:
The non standard MIME types are defined as AudioCustomMimeTypeId in Project.hpp

SharedPtr< AudioReference > AudioDeviceManager::CreateAudioReferenceFromRamBuffer | ( | MimeType | mime_type,
 |  | AudioPlayer::ConstBuffer | buffer,
 |  | UINT32 | buffer_size
 | ) |

Creates an AudioReference to audio data from a RAM buffer. The returned reference should be used for playback.

Note:
The non standard MIME types are defined as AudioCustomMimeTypeId in Project.hpp

SharedPtr< AudioReference > AudioDeviceManager::CreateAudioReferenceFromRamBuffer | ( | MimeType | mime_type,
 |  | AudioPlayer::Buffer | buffer,
 |  | UINT32 | buffer_size
 | ) |

Creates an AudioReference to audio data from a RAM buffer. The returned reference should be used for recording.

Note:
The non standard MIME types are defined as AudioCustomMimeTypeId in Project.hpp

SharedPtr< AudioReference > AudioDeviceManager::CreateAudioReferenceFromRFS ( const Path & path )

Get an AudioReference for the file in the Root File System.

Parameters:
path Root File System file.
Returns:
A new AudioReference.
This function creates an Audio Reference in RFS (FFS or MMC).

For the supported formats see the following table:
Extension | MIME Type | Audio Type
.mmf | application/x-smaf | Yamaha SMAF and SMAF/Phrase
.spf | application/vnd.yamaha.smaf-phrase | Yamaha SMAF/Phrase
.amr | audio/amr | Adaptive multi rate
.imy | audio/imelody | Imelody
.mid | audio/midi | MIDI
.midi | audio/midi | MIDI
.mp3 | audio/mpeg | MPEG Layer-3
.wav | audio/x-wav | PCM

SharedPtr< AudioReference > AudioDeviceManager::CreateAudioReferenceFromStream | ( | MimeType | mime_type,
 |  | AudioPlayer::GetAudioBufferFunction | func,
 |  | void * | user_data = 0
 | ) |

Creates an AudioReference to audio data in streaming mode.

Note:
The non standard MIME types are defined as AudioCustomMimeTypeId in Project.hpp

BOOLEAN AudioDeviceManager::EnableMasterMute ( BOOLEAN enable = TRUE ) [static]

Mutes/unmutes master volume.

Note:
This function should be used for muting the volume for all devices. If there is a need to mute volume for some particular device, use AudioDeviceBase::Mute() for that device
Parameters:
mute if TRUE mute, else unmute
Returns:
indicates success.

const AudioDeviceManager::AccessoryList AudioDeviceManager::GetAccessoryList ( ) const

AudioPlayer * AudioDeviceManager::GetAudioPlayer ( const AudioReference & file_reference )

This function is obsolete. For the same reasons as GetDevice, see there.

Deprecated:
Get an AudioPlayer capable of playing this reference:
Parameters:
file_reference - an audio reference.
Returns:
A suitable AudioPlayer.

AudioDeviceBase * AudioDeviceManager::GetDevice ( AudioDeviceID device )

Get a player for this device-ID.

Deprecated, use at your own risk. An application should never have to obtain an AudioPlayer in this way; instead, it should use AudioActiveReference::GetDevice. The danger in using AudioDeviceManager::GetDevice for obtaining the AudioPlayer that is used to play an AudioReference is that you have to guess, and you may guess wrong; player selection is done at Play() time, and before that there is, in general, no guaranteed correspondence between references and players. For obtaining non-AudioPlayer devices like the speech device, use SpeechSimpleAudioDevice::GetInstance etc. instead.

Deprecated:
Parameters:
device ID of device
Returns:
device instance
Note:
VibratorDeviceID is used to access Vibrator class only for E-Gold based platforms (AudioVibratorDevice class) On all other platforms use directly the VibratorDevice class

AudioDeviceManager & AudioDeviceManager::GetInstance ( ) [static]

AudioAccessoryDetails::AudioAccessoryConfigurationType AudioDeviceManager::GetLinkedAccessory ( SourceType source ) const

Obsolete, use at your own risk. Returns the accessory that was last linked to this source using LinkAccessory.

Deprecated:

BOOLEAN AudioDeviceManager::GetMasterMute ( ) [static]

Gets master mute status.

Returns:
TRUE - mute enabled, FALSE - mute disabled

AudioDeviceBase::VolumeLevel AudioDeviceManager::GetMasterVolume ( ) [static]

Gets master volume.

Returns:
volume Value between 0-100

BOOLEAN AudioDeviceManager::LinkAccessory | ( | SourceType | source,
 |  | AudioAccessoryDetails & | accessory
 | ) |

Obsolete. Use AudioAccessoryDetails::SetConnected.

Deprecated:

static void AudioDeviceManager::MapAndUpdateVolumes ( ) [static]

SharedPtr< AudioActiveReference > AudioDeviceManager::Play ( const AudioReference & file_reference ) [static]

This is a convenience method, so that there is no need to get the player for the reference.

Parameters:
reference to be played
Returns:
NULL if unsuccessfull, otherwise AudioActiveReference which can control and stop the playback

Below is the table which contains all the messages which could be emitted by APOXI at the beginning, during and at the end of playback

AudioStartedMsg | This message will be emitted when a sound has started playing, i.e. the driver function to start playing has been called successfully
AudioStoppedMsg | This message will be emitted when a sound stops playing, it will not be emitted when the sound has been explicitly stopped
AudioSuspendedMsg | This message will be sent when sound is suspended by the audio priority manager, it will not be emitted when the sound has been explicitly suspended
AudioResumedMsg | This message will be emitted when a sound is resumed by the audio priority manager, it will not be emitted when the sound has been explicitly resumed
AudioRestartedMsg | This message will be emitted when a repeated sound is restarted
AudioStreamingSyncMsg | If the streaming instance was created using StreamAudioReference::CreateStream() function, the AudioStreamingSyncMsg APOXI Message will be sent after the first buffer is passed to DSP to be played

void AudioDeviceManager::PostAudioUserDefinedMessage | ( | UINT8 | messageID,
 |  | UINT16 | senderID = 0,
 |  | UINT32 | param1 = 0,
 |  | UINT32 | param2 = 0,
 |  | UINT32 | param3 = 0,
 |  | UINT32 | param4 = 0
 | ) | [static]

Post the AudioUserDefinedMsg APOXI message.

Parameters:
messageID | The user defined message ID, the meaning has to be defined at application level
senderID | The sender ID, can be used when more application are sending the same user defined message ID, the meaning has to be defined at application level
param1 | An user defined parameter, the meaning has to be defined at application level
param2 | An user defined parameter, the meaning has to be defined at application level
param3 | An user defined parameter, the meaning has to be defined at application level
param4 | An user defined parameter, the meaning has to be defined at application level
Note:
This function sends an SDL signal to the PMI process and the receiving function will broadcast the AudioUserDefinedMsg APOXI message. The calling context of this function can be either an OS task or an OS HISR. It cannot be invoked from a LIHR. If the sender is supposed to be always an APOXI application then System::GetMessageRouter().Post method has to be used

BOOLEAN AudioDeviceManager::SetMasterVolume ( AudioDeviceBase::VolumeLevel volume ) [static]

Sets the master volume. Master volume affects all sounds.

Parameters:
volume Value between 0-100
Returns:
indicates success.

SharedPtr< AudioActiveReference > AudioDeviceManager::StartRecording ( const AudioReference & audio_ref ) [static]

Starts recording.

Parameters:
audio_ref The reference to the location to which the sound should be recorded.
Returns:
The reference to the active recording, for use with StopRecording().

void AudioDeviceManager::StopAllSounds ( ) [static]

Stops all sounds, regardless of priority.

void AudioDeviceManager::StopRecording ( AudioActiveReference & active_reference ) [static]

Stops recording.

Parameters:
active_reference The reference to the active recording (obtained from StartRecording)

void AudioDeviceManager::SubscribeAudioMessageCallback | ( | OnAudioMessageCallback | func,
 |  | void * | pUserData = 0
 | ) |

THIS FUNCTION IS OBSOLETE - If calling module is not an APOXI application, MessageHook should be used to receive the messages. Subscribes a message handler function that will be called in order to receive audio notifications. The registration of this function should be done only if the APOXI calling module is not an APOXI application so it cannot receive APOXI messages. Ex. Multimedia framework.

Parameters:
func | The callback function to subscribe.
pUserData | Opaque data that will be sent as a parameter to the callback function.

void AudioDeviceManager::SuspendAllPlayingSounds ( ) [static]

Suspends all playing sounds, regardless of priority. Sounds that cannot be suspended are stopped.

void AudioDeviceManager::UnsubscribeAudioMessageCallback | ( | OnAudioMessageCallback | func,
 |  | void * | pUserData = 0
 | ) |

Unsubscribe the registered callback. See SubscribeAudioMessageCallback()

Parameters:
func The callback function to unsubscribe, previously provided to SubscribeAudioMessageCallback() pUserData The opaque data that was provided with SubscribeAudioMessageCallback()

Field Documentation

AudioAccessoryDetails::AudioAccessoryConfigurationType AudioDeviceManager::m_accessory [protected]

AudioVibratorDevice AudioDeviceManager::m_device_vibrator [protected]

BOOLEAN AudioDeviceManager::m_ecnr_state = TRUE [static, protected]

AudioDeviceManager AudioDeviceManager::m_Instance [static, protected]

BOOLEAN AudioDeviceManager::m_master_mute = FALSE [static, protected]

AudioDeviceBase::VolumeLevel AudioDeviceManager::m_master_volume = 100 [static, protected]

The documentation for this class was generated from the following files:
  • Audio/AudioDeviceManager.hpp
  • Audio/AudioDeviceManager.cpp
Generated on Wed Jan 25 00:56:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioDeviceStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioDeviceStatusMsg Class Reference

#include <Apoxi/Audio/Messages/AudioDeviceStatusMsg.hpp>

Inheritance diagram for AudioDeviceStatusMsg:

[legend]
Collaboration diagram for AudioDeviceStatusMsg:

[legend]

Public Types

enum | { ID = 9005 }

Public Member Functions

AudioDeviceStatusMsg (const AudioDeviceManager::AudioDeviceID &device_id, const AudioDeviceBase::AudioDeviceStatus &device_status)
virtual Message * | Clone () const
const AudioDeviceManager::AudioDeviceID & | GetDeviceId () const
const AudioDeviceBase::AudioDeviceStatus & | GetDeviceStatus () const
virtual const MsgMetaData & | GetMetaData () const
void | SetDeviceId (const AudioDeviceManager::AudioDeviceID &device_id)
void | SetDeviceStatus (const AudioDeviceBase::AudioDeviceStatus &device_status)
virtual | ~AudioDeviceStatusMsg ()

Detailed Description

This message will be sent when the status of a device has been changed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioDeviceStatusMsg::AudioDeviceStatusMsg | ( | const AudioDeviceManager::AudioDeviceID & | device_id,
 |  | const AudioDeviceBase::AudioDeviceStatus & | device_status
 | ) |

AudioDeviceStatusMsg::~AudioDeviceStatusMsg ( ) [virtual]

Member Function Documentation

Message * AudioDeviceStatusMsg::Clone ( ) const [virtual]

Implements Message.

const AudioDeviceManager::AudioDeviceID& AudioDeviceStatusMsg::GetDeviceId ( ) const [inline]

const AudioDeviceBase::AudioDeviceStatus& AudioDeviceStatusMsg::GetDeviceStatus ( ) const [inline]

const MsgMetaData & AudioDeviceStatusMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioDeviceStatusMsg::SetDeviceId ( const AudioDeviceManager::AudioDeviceID & device_id ) [inline]

void AudioDeviceStatusMsg::SetDeviceStatus ( const AudioDeviceBase::AudioDeviceStatus & device_status ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioDeviceStatusMsg.hpp
  • Audio/Messages/AudioDeviceStatusMsg.cpp
Generated on Wed Jan 25 00:56:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioEncoder Class Reference
[CodecManager]

#include <Apoxi/AddOns/CodecManager/AudioEncoder.hpp>

Inheritance diagram for AudioEncoder:

[legend]
Collaboration diagram for AudioEncoder:

[legend]

Public Types

enum | BitAllocationMethodType { LoudnessAllocation, SnrAllocation }
typedef void(* | CbFrameEncoded )(ResultType result, void *context, const UINT8 HUGE *in_buf, UINT32 in_buf_used, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
enum | ChannelModeType { MonoChannelMode, DualChannelMode, StereoChannelMode, JointStereoChannelMode }
enum | EncodingFunctionType { EncodeBufferFct, EncodeFrameFct }
enum | ParameterType { BitPool, FilterBankBlockLength, EndOfParameterType }

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len, EncodingFunctionType &enc_fct)=0
virtual void | Close ()=0
virtual ResultType | EncodeBuffer (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)=0
virtual ResultType | EncodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)=0
virtual ResultType | GetCapabilities (AudioCodecCapabilities &caps)=0
virtual ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)=0
virtual ResultType | Open ()=0
virtual ResultType | RegisterCallbackFunctions (void *context, CbFrameEncoded cb_frame_encoded)=0
virtual ResultType | SetConfig (const AudioEncoderParameters &params)=0
virtual ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)=0

Friends

class | CodecManager

Detailed Description

Abstract audio encoder base class. The sub-classes of this class provide the actual audio encoder functionality API. The AudioEncoder sub-class instances are accessed by the clients via the CodecManager API.
See also:
CodecManager::ObtainEncoder

CodecManager::ReleaseEncoder

Member Typedef Documentation

typedef void(* AudioEncoder::CbFrameEncoded)(ResultType result, void *context, const UINT8 HUGE *in_buf, UINT32 in_buf_used, const UINT8 HUGE *out_buf, UINT32 out_buf_len)

Callback function that is invoked by the AudioEncoder when a frame (or more frames) has been encoded.

Parameters:
result | A result (error) code: Success if the operation was successful. Otherwise, an appropriate error code.
context | A context (e.g. this pointer) that has been passed to the AudioEncoder object when AudioEncoder::RegisterCallbackFunctions has been invoked.
in_buf | Pointer to the audio input buffer.
in_buf_used | Number of bytes of the input buffer that were used (consumed) by the encoder.
out_buf | Pointer to the audio output buffer with the encoded frame.
out_buf_len | Length of the encoded audio data in the output buffer (in bytes).
See also:
EncodeFrame

EncodeBuffer

RegisterCallbackFunctions

Member Enumeration Documentation

enum AudioEncoder::BitAllocationMethodType

Bit allocation method type. It defines which parameter the bit allocation is based on.

Enumerator:
LoudnessAllocation
SnrAllocation

enum AudioEncoder::ChannelModeType

Channel mode type.

Enumerator:
MonoChannelMode
DualChannelMode
StereoChannelMode
JointStereoChannelMode

enum AudioEncoder::EncodingFunctionType

Encoding function type.

Enumerator:
EncodeBufferFct
EncodeFrameFct

enum AudioEncoder::ParameterType

Parameter type. It is used by the AudioEncoder::SetParameters and AudioEncoder::GetParameters functions.

Enumerator:
BitPool | This parameter applies to the SBC encoder. It defines the bit pool value. Bit pool is proportional to the bit-rate of operation (used for variable bit-rate encoding). Only for AudioEncoder::SetParameters function.
FilterBankBlockLength | This parameter applies to the SBC encoder. Block length for the filter bank. Only for AudioEncoder::SetParameters function.
EndOfParameterType

Member Function Documentation

virtual ResultType AudioEncoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len,
 |  | EncodingFunctionType & | enc_fct
 | ) | [pure virtual]

Allocates a number of output buffers that are used to store the encoded frames. The array will be freed (deallocated) when using AudioEncoder::Close.

Parameters:
out_buf_array | On return, a pointer to the output buffer array (the elements of the array are pointers to the actual buffers).
out_buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e. the AudioEncoder adapt the number passed in by the caller if necessary.
out_buf_len | On return, the actual buffer length, i.e. the AudioEncoder.
enc_fct | The caller informs the audio encoder about the function that it wants to be used for encoding (since the output buffers length and number depends on the encoding funtion). On return, contains the actually used value (e.g. if the desired encoding function is not supported).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
AudioEncoder::Close

virtual void AudioEncoder::Close ( ) [pure virtual]

Closes and releases the audio encoder. This method should be invoked as soon as the audio encoder is not needed anymore to allow other audio encoders to access the resources.

See also:
Open

virtual ResultType AudioEncoder::EncodeBuffer | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [pure virtual]

Encodes an audio buffer. The input buffer shall contain at least one complete frame. This function continues encoding until there is no complete frame in the input buffer or not enough space in the output buffer. The actual encoding is done asynchronously, i.e., when the encoding process has finished, the callback function CbFrameEncoded will be invoked. Note: In the callback function the number of consumed bytes (of the input buffer) will be returned.

Parameters:
in_buf | Pointer to the audio input buffer (containing the encoded frames).
in_buf_len | Length of the audio input buffer (in bytes).
out_buf | Pointer to the audio output buffer (containing the encoded frames).
out_buf_len | Length of the audio output buffer (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameEncoded

Implemented in EmzSbcEncoder.

virtual ResultType AudioEncoder::EncodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [pure virtual]

Encodes an audio frame. The input buffer contains always one complete frame. The actual encoding is done asynchronously, i.e., when the encoding process has finished, the callback function CbFrameEncoded will be invoked. Note: In the callback function the number of consumed bytes (of the input buffer) will be returned.
EncodeBuffer shall be preferred to this function.

Parameters:
in_buf | Pointer to the audio input buffer (containing the encoded frame).
in_buf_len | Length of the audio input buffer (in bytes).
out_buf | Pointer to the audio output buffer (containing the encoded frame).
out_buf_len | Length of the audio output buffer (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameEncoded

EncodeBuffer

Implemented in EmzSbcEncoder.

virtual ResultType AudioEncoder::GetCapabilities ( AudioCodecCapabilities & caps ) [pure virtual]

This function is used to retrieve the capabilities of the audio encoder (AudioEncoder sub-class).

Parameters:
caps On return, it contains the capabilities.
Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the AudioEncoder sub-class.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType AudioEncoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [pure virtual]

This function retrieves the values of specified parameters in the audio encoder.

Parameters:
types_array | Array of the parameter types that specify the parameters to be retrieved.
values_array | On return, array of the retrieved parameter values. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type. The caller has to allocate memory for this array before invoking of this function. The existing elements of the array are then filled with the corresponding parameter values by the audio encoder.
array_count | Length (number of elements) of the types_array and types_array i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType AudioEncoder::Open ( ) [pure virtual]

Opens the audio encoder. In general, when a encoder is opened, it is reserved for the caller and cannot be used by another caller. Thus, as soon as the audio encoder is not needed anymore, it shall be released by using Close.

Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Close

virtual ResultType AudioEncoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameEncoded | cb_frame_encoded
 | ) | [pure virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the AudioEncoder. This context is then passed as an argument of all callback functions invoked by the AudioEncoder.
cb_frame_encoded | A pointer to a callback function that is invoked by the AudioEncoder when a frame has been encoded (and post-processed) and is ready for rendering.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType AudioEncoder::SetConfig ( const AudioEncoderParameters & params ) [pure virtual]

Configures the audio encoder.

Parameters:
params | Audio encoder parameters to be set.
stream_info | On return, it contains the encoded stream info.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType AudioEncoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [pure virtual]

Sets dynamically one or more encoder parameters.

Parameters:
types_array | Array of the parameter types that specify the parameters to be changed. The corresponding values to be set are delivered in values_array.
values_array | Array of the values to which the corresponding parameters have to be set. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type.
array_count | Length (number of elements) of the types_array and values_array, i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Friends And Related Function Documentation

friend class CodecManager [friend]

Reimplemented from CodecDevice.

The documentation for this class was generated from the following file:
  • AddOns/CodecManager/AudioEncoder.hpp
Generated on Wed Jan 25 00:56:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioError Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioError Class Reference
[Audio]

#include <Apoxi/Audio/AudioError.hpp>

Inheritance diagram for AudioError:

[legend]
Collaboration diagram for AudioError:

[legend]

Public Types

typedef INT8 | AudReturnCode
enum ErrorType {
ErrorUnknown, ErrorResourceInUse, ErrorResourceConflict, ErrorHandleNotUsed,
ErrorNoHwSupport, ErrorSharingViolation, ErrorParameterOutOfRange, ErrorFormatNotSupported,
ErrorAudioDriverDisabled, ErrorRingerToneError, ErrorVmFFSProblems, ErrorVmPerformanceProblems,
ErrorRingerSuspendresumeError, ErrorMissingDspResource, ErrorUnknownPosition, ErrorNoPlayback,
ErrorNoPlaytime, ErrorPerformanceProblems
}

Public Member Functions

virtual | ~AudioError ()

Static Public Member Functions

static AudioError & | GetInstance ()

Member Typedef Documentation

typedef INT8 AudioError::AudReturnCode

Member Enumeration Documentation

enum AudioError::ErrorType

The audio error types The AudioErrorMsg APOXI message containing the error type will be sent when an error occur

Enumerator:
ErrorUnknown | Unknown.
ErrorResourceInUse | Resourse in use.
ErrorResourceConflict | Resource conflict.
ErrorHandleNotUsed | Handle not used.
ErrorNoHwSupport | No hardware support.
ErrorSharingViolation | Sharing violation.
ErrorParameterOutOfRange | Parameter out of range.
ErrorFormatNotSupported | Format not supported.
ErrorAudioDriverDisabled | Audio driver is disabled.
ErrorRingerToneError | Ringer tone error.
ErrorVmFFSProblems | FFS problems.
ErrorVmPerformanceProblems | Voice memo performance problems.
ErrorRingerSuspendresumeError | Ringer suspend resume error.
ErrorMissingDspResource | Missing DSP resource.
ErrorUnknownPosition | Unknown position.
ErrorNoPlayback | No playback error.
ErrorNoPlaytime | No playtime.
ErrorPerformanceProblems

Constructor & Destructor Documentation

AudioError::~AudioError ( ) [virtual]

Member Function Documentation

AudioError & AudioError::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Audio/AudioError.hpp
  • Audio/AudioError.cpp
Generated on Wed Jan 25 00:56:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioErrorMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioErrorMsg Class Reference

#include <Apoxi/Audio/Messages/AudioErrorMsg.hpp>

Inheritance diagram for AudioErrorMsg:

[legend]
Collaboration diagram for AudioErrorMsg:

[legend]

Public Types

enum | { ID = 9004 }

Public Member Functions

AudioErrorMsg (const SharedPtr< AudioReference > &audio_reference, const AudioError::ErrorType &audio_error)
virtual Message * | Clone () const
const AudioError::ErrorType & | GetAudioError () const
const SharedPtr< AudioReference > & | GetAudioReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetAudioError (const AudioError::ErrorType &audio_error)
void | SetAudioReference (const SharedPtr< AudioReference > &audio_reference)
virtual | ~AudioErrorMsg ()

Detailed Description

This message will be sent when an error occurs when calling the audio driver

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioErrorMsg::AudioErrorMsg | ( | const SharedPtr< AudioReference > & | audio_reference,
 |  | const AudioError::ErrorType & | audio_error
 | ) |

AudioErrorMsg::~AudioErrorMsg ( ) [virtual]

Member Function Documentation

Message * AudioErrorMsg::Clone ( ) const [virtual]

Implements Message.

const AudioError::ErrorType& AudioErrorMsg::GetAudioError ( ) const [inline]

const SharedPtr<AudioReference>& AudioErrorMsg::GetAudioReference ( void ) const [inline]

const MsgMetaData & AudioErrorMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioErrorMsg::SetAudioError ( const AudioError::ErrorType & audio_error ) [inline]

void AudioErrorMsg::SetAudioReference ( const SharedPtr< AudioReference > & audio_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioErrorMsg.hpp
  • Audio/Messages/AudioErrorMsg.cpp
Generated on Wed Jan 25 00:56:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioFastForwardStartedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioFastForwardStartedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioFastForwardStartedMsg:

[legend]
Collaboration diagram for AudioFastForwardStartedMsg:

[legend]

Public Types

enum | { ID = 9022 }

Public Member Functions

AudioFastForwardStartedMsg (const SharedPtr< AudioActiveReference > &active_reference)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
virtual | ~AudioFastForwardStartedMsg ()

Detailed Description

This message will be sent when fast forward of a player has started.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioFastForwardStartedMsg::AudioFastForwardStartedMsg ( const SharedPtr< AudioActiveReference > & active_reference )

AudioFastForwardStartedMsg::~AudioFastForwardStartedMsg ( ) [virtual]

Member Function Documentation

Message * AudioFastForwardStartedMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioFastForwardStartedMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioFastForwardStartedMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioFastForwardStartedMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioFmRadioRdsAlternativeFrequenciesMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioFmRadioRdsAlternativeFrequenciesMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioFmRadioRdsAlternativeFrequenciesMsg:

[legend]
Collaboration diagram for AudioFmRadioRdsAlternativeFrequenciesMsg:

[legend]

Public Types

enum | { ID = 9021 }

Public Member Functions

AudioFmRadioRdsAlternativeFrequenciesMsg (UINT8 numberOfFrequencies, UINT32 *frequencies)
virtual Message * | Clone () const
UINT32 * | GetFrequencies () const
virtual const MsgMetaData & | GetMetaData () const
UINT8 | GetNumberOfFrequencies () const
virtual | ~AudioFmRadioRdsAlternativeFrequenciesMsg ()

Detailed Description

This message will be sent from the FmRadioAudioPlayer when alternative frequencies for the current station were decoded successfully and sending the message is requested.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioFmRadioRdsAlternativeFrequenciesMsg::AudioFmRadioRdsAlternativeFrequenciesMsg | ( | UINT8 | numberOfFrequencies,
 |  | UINT32 * | frequencies
 | ) |

AudioFmRadioRdsAlternativeFrequenciesMsg::~AudioFmRadioRdsAlternativeFrequenciesMsg ( ) [virtual]

Member Function Documentation

Message * AudioFmRadioRdsAlternativeFrequenciesMsg::Clone ( ) const [virtual]

Implements Message.

UINT32* AudioFmRadioRdsAlternativeFrequenciesMsg::GetFrequencies ( ) const [inline]

const MsgMetaData & AudioFmRadioRdsAlternativeFrequenciesMsg::GetMetaData ( ) const [virtual]

Implements Message.

UINT8 AudioFmRadioRdsAlternativeFrequenciesMsg::GetNumberOfFrequencies ( ) const [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioFmRadioRdsInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioFmRadioRdsInfoMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioFmRadioRdsInfoMsg:

[legend]
Collaboration diagram for AudioFmRadioRdsInfoMsg:

[legend]

Public Types

enum | { ID = 9020 }

Public Member Functions

AudioFmRadioRdsInfoMsg (UINT16 programIdentifier, UINT8 programType, BOOLEAN trafficProgramSet)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UINT16 | GetProgramIdentifier () const
UINT8 | GetProgramType () const
BOOLEAN | IsTrafficProgramSet () const
virtual | ~AudioFmRadioRdsInfoMsg ()

Detailed Description

This message will be sent from the FmRadioAudioPlayer when RDS info was decoded successfully and sending the message is requested.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioFmRadioRdsInfoMsg::AudioFmRadioRdsInfoMsg | ( | UINT16 | programIdentifier,
 |  | UINT8 | programType,
 |  | BOOLEAN | trafficProgramSet
 | ) |

AudioFmRadioRdsInfoMsg::~AudioFmRadioRdsInfoMsg ( ) [virtual]

Member Function Documentation

Message * AudioFmRadioRdsInfoMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AudioFmRadioRdsInfoMsg::GetMetaData ( ) const [virtual]

Implements Message.

UINT16 AudioFmRadioRdsInfoMsg::GetProgramIdentifier ( ) const [inline]

UINT8 AudioFmRadioRdsInfoMsg::GetProgramType ( ) const [inline]

BOOLEAN AudioFmRadioRdsInfoMsg::IsTrafficProgramSet ( ) const [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioFmRadioRdsRadioTextMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioFmRadioRdsRadioTextMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioFmRadioRdsRadioTextMsg:

[legend]
Collaboration diagram for AudioFmRadioRdsRadioTextMsg:

[legend]

Public Types

enum | { ID = 9019 }

Public Member Functions

AudioFmRadioRdsRadioTextMsg (const WString &radioText)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetRadioText () const
virtual | ~AudioFmRadioRdsRadioTextMsg ()

Detailed Description

This message will be sent from the FmRadioAudioPlayer when RDS radio text was decoded successfully and sending the message is requested.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioFmRadioRdsRadioTextMsg::AudioFmRadioRdsRadioTextMsg ( const WString & radioText )

AudioFmRadioRdsRadioTextMsg::~AudioFmRadioRdsRadioTextMsg ( ) [virtual]

Member Function Documentation

Message * AudioFmRadioRdsRadioTextMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AudioFmRadioRdsRadioTextMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& AudioFmRadioRdsRadioTextMsg::GetRadioText ( ) const [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioFmRadioRdsRawDataMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioFmRadioRdsRawDataMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioFmRadioRdsRawDataMsg:

[legend]
Collaboration diagram for AudioFmRadioRdsRawDataMsg:

[legend]

Public Types

enum | { ID = 9017 }

Public Member Functions

AudioFmRadioRdsRawDataMsg (UINT8 *buffer, UINT16 buffer_size)
virtual Message * | Clone () const
UINT8 * | GetBuffer () const
UINT16 | GetBufferSize () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AudioFmRadioRdsRawDataMsg ()

Detailed Description

This message will be sent from the FmRadioAudioPlayer when raw data is required by application. The application has to take care of freeing the memory.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioFmRadioRdsRawDataMsg::AudioFmRadioRdsRawDataMsg | ( | UINT8 * | buffer,
 |  | UINT16 | buffer_size
 | ) |

AudioFmRadioRdsRawDataMsg::~AudioFmRadioRdsRawDataMsg ( ) [virtual]

Member Function Documentation

Message * AudioFmRadioRdsRawDataMsg::Clone ( ) const [virtual]

Implements Message.

UINT8* AudioFmRadioRdsRawDataMsg::GetBuffer ( ) const [inline]

UINT16 AudioFmRadioRdsRawDataMsg::GetBufferSize ( ) const [inline]

const MsgMetaData & AudioFmRadioRdsRawDataMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioFmRadioRdsStationNameMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioFmRadioRdsStationNameMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioFmRadioRdsStationNameMsg:

[legend]
Collaboration diagram for AudioFmRadioRdsStationNameMsg:

[legend]

Public Types

enum | { ID = 9018 }

Public Member Functions

AudioFmRadioRdsStationNameMsg (const WString &stationName, BOOLEAN trafficAnnouncementSet)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetStationName () const
BOOLEAN | IsTrafficAnnouncementSet () const
virtual | ~AudioFmRadioRdsStationNameMsg ()

Detailed Description

This message will be sent from the FmRadioAudioPlayer when RDS station name was decoded successfully and sending the message is requested.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioFmRadioRdsStationNameMsg::AudioFmRadioRdsStationNameMsg | ( | const WString & | stationName,
 |  | BOOLEAN | trafficAnnouncementSet
 | ) |

AudioFmRadioRdsStationNameMsg::~AudioFmRadioRdsStationNameMsg ( ) [virtual]

Member Function Documentation

Message * AudioFmRadioRdsStationNameMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AudioFmRadioRdsStationNameMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& AudioFmRadioRdsStationNameMsg::GetStationName ( ) const [inline]

BOOLEAN AudioFmRadioRdsStationNameMsg::IsTrafficAnnouncementSet ( ) const [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioFmRadioRssiMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioFmRadioRssiMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioFmRadioRssiMsg:

[legend]
Collaboration diagram for AudioFmRadioRssiMsg:

[legend]

Public Types

enum | { ID = 9016 }

Public Member Functions

AudioFmRadioRssiMsg (UINT8 signalLevel, BOOLEAN stereo)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UINT8 | GetSignalLevel () const
BOOLEAN | IsStereo () const
virtual | ~AudioFmRadioRssiMsg ()

Detailed Description

This message will be sent from the FmRadioAudioPlayer when the received signal strength indication changed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioFmRadioRssiMsg::AudioFmRadioRssiMsg | ( | UINT8 | signalLevel,
 |  | BOOLEAN | stereo
 | ) |

AudioFmRadioRssiMsg::~AudioFmRadioRssiMsg ( ) [virtual]

Member Function Documentation

Message * AudioFmRadioRssiMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AudioFmRadioRssiMsg::GetMetaData ( ) const [virtual]

Implements Message.

UINT8 AudioFmRadioRssiMsg::GetSignalLevel ( ) const [inline]

BOOLEAN AudioFmRadioRssiMsg::IsStereo ( ) const [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioFmRadioSeekMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioFmRadioSeekMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioFmRadioSeekMsg:

[legend]
Collaboration diagram for AudioFmRadioSeekMsg:

[legend]

Public Types

enum | { ID = 9015 }

Public Member Functions

AudioFmRadioSeekMsg (BOOLEAN success, UINT32 frequency)
virtual Message * | Clone () const
UINT32 | GetFrequency () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsSuccess () const
virtual | ~AudioFmRadioSeekMsg ()

Detailed Description

This message will be sent from the FmRadioAudioPlayer when the seek operation is finished.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioFmRadioSeekMsg::AudioFmRadioSeekMsg | ( | BOOLEAN | success,
 |  | UINT32 | frequency
 | ) |

AudioFmRadioSeekMsg::~AudioFmRadioSeekMsg ( ) [virtual]

Member Function Documentation

Message * AudioFmRadioSeekMsg::Clone ( ) const [virtual]

Implements Message.

UINT32 AudioFmRadioSeekMsg::GetFrequency ( ) const [inline]

const MsgMetaData & AudioFmRadioSeekMsg::GetMetaData ( ) const [virtual]

Implements Message.

BOOLEAN AudioFmRadioSeekMsg::IsSuccess ( ) const [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:56:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioGatiServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioGatiServer Class Reference

#include <Apoxi/Devices/Win32/HostAudioGatiServer.hpp>

Inheritance diagram for AudioGatiServer:

[legend]
Collaboration diagram for AudioGatiServer:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

virtual void | Destroy ()
virtual INT | GetId () const
virtual void | OnConnect ()
virtual void | OnDataReceived (UINT32 cmd, UINT32 length, void *data)
virtual void | OnDisconnect ()
void | SendData (UINT32 cmd, UINT32 length, void *data)
virtual | ~AudioGatiServer ()

Static Public Member Functions

static GatiServer * | CreateInstance ()
static AudioGatiServer & | GetInstance ()

Detailed Description

Implements a GATI server for the Host Audio Process.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

virtual AudioGatiServer::~AudioGatiServer ( ) [virtual]

Destructor

Member Function Documentation

GatiServer * AudioGatiServer::CreateInstance ( ) [static]

void AudioGatiServer::Destroy ( ) [virtual]

See also:
GatiServer::Destroy

Implements GatiServer.

INT AudioGatiServer::GetId ( ) const [virtual]

See also:
GatiServer::GetId

Implements GatiServer.

AudioGatiServer & AudioGatiServer::GetInstance ( ) [static]

Returns the singelton instance of the class AudioGatiServer.

Returns:
a reference to singleton AudioGatiServer instance.

void AudioGatiServer::OnConnect ( ) [virtual]

See also:
GatiServer::OnConnect

Implements GatiServer.

void AudioGatiServer::OnDataReceived | ( | UINT32 | cmd,
 |  | UINT32 | length,
 |  | void * | data
 | ) | [virtual]

Method to react on incoming data (from external to internal).

Returns:
TRUE if sucessful, FALSE otherwise.

Implements GatiServer.

void AudioGatiServer::OnDisconnect ( ) [virtual]

See also:
GatiServer::OnDisconnect

Implements GatiServer.

void AudioGatiServer::SendData | ( | UINT32 | cmd,
 |  | UINT32 | length,
 |  | void * | data
 | ) |

The documentation for this class was generated from the following files:
  • Devices/Win32/HostAudioGatiServer.hpp
  • Devices/Win32/HostAudioGatiServer.cpp
Generated on Wed Jan 25 00:56:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioGetPlayPositionMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioGetPlayPositionMsg Class Reference

#include <Apoxi/Audio/Messages/AudioGetPlayPositionMsg.hpp>

Inheritance diagram for AudioGetPlayPositionMsg:

[legend]
Collaboration diagram for AudioGetPlayPositionMsg:

[legend]

Public Types

enum | { ID = 9011 }

Public Member Functions

AudioGetPlayPositionMsg (const SharedPtr< AudioActiveReference > &active_reference, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetParam1 () const
UINT32 | GetParam2 () const
UINT32 | GetParam3 () const
UINT32 | GetParam4 () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
void | SetParam1 (UINT32 param1)
void | SetParam2 (UINT32 param2)
void | SetParam3 (UINT32 param3)
void | SetParam4 (UINT32 param4)
virtual | ~AudioGetPlayPositionMsg ()

Detailed Description

This message is used to transfer play positions to an upper layer.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioGetPlayPositionMsg::AudioGetPlayPositionMsg | ( | const SharedPtr< AudioActiveReference > & | active_reference,
 |  | UINT32 | param1,
 |  | UINT32 | param2,
 |  | UINT32 | param3,
 |  | UINT32 | param4
 | ) |

AudioGetPlayPositionMsg::~AudioGetPlayPositionMsg ( ) [virtual]

Member Function Documentation

Message * AudioGetPlayPositionMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioGetPlayPositionMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioGetPlayPositionMsg::GetMetaData ( ) const [virtual]

Implements Message.

UINT32 AudioGetPlayPositionMsg::GetParam1 ( ) const [inline]

UINT32 AudioGetPlayPositionMsg::GetParam2 ( ) const [inline]

UINT32 AudioGetPlayPositionMsg::GetParam3 ( ) const [inline]

UINT32 AudioGetPlayPositionMsg::GetParam4 ( ) const [inline]

void AudioGetPlayPositionMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

void AudioGetPlayPositionMsg::SetParam1 ( UINT32 param1 ) [inline]

void AudioGetPlayPositionMsg::SetParam2 ( UINT32 param2 ) [inline]

void AudioGetPlayPositionMsg::SetParam3 ( UINT32 param3 ) [inline]

void AudioGetPlayPositionMsg::SetParam4 ( UINT32 param4 ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioGetPlayPositionMsg.hpp
  • Audio/Messages/AudioGetPlayPositionMsg.cpp
Generated on Wed Jan 25 00:56:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioItem Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/AudioItem.hpp>

Inheritance diagram for AudioItem:

[legend]
Collaboration diagram for AudioItem:

[legend]

Public Types

enum | { ID = 15 }

Public Member Functions

AudioItem (SharedPtr< AudioReference > audio_ref)
virtual AtomItem * | Clone () const
virtual void | Draw (DeviceContext *dc, const Rect &bounds) const
SharedPtr< AudioReference > | GetAudioReference () const
Returns the embedded audio reference.
virtual XYDIM | GetHeight () const
virtual INT | GetId () const
virtual XYDIM | GetWidth () const
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual | ~AudioItem ()

Detailed Description

Represents a bounded item which can get a audio reference as input.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BoundedItem.

Constructor & Destructor Documentation

AudioItem::AudioItem ( SharedPtr< AudioReference > audio_ref ) [explicit]

Parameters:
audio_ref Audio reference which should be displayed. Due to the limitations of the class SharedPtr, it is required to do a recast when passing the parameter (see SharedPtr for details). Example code:
SharedPtr<PresetAudioReference> preset_audio_ref = AudioPresetStore::GetInstance()->CreateReference("DTMF 1");
SharedPtr<AudioReference> audio_ref = SharedPtr<AudioReference>(&(*preset_audio_ref));
AudioItem audio_item(audio_ref);
editor->InsertItem(audio_item);
Note that the audio item itself gets cloned when the inserting has been successful. This cloned audio item is obtained by the editor and hence the original audio item can get deleted at any time.

AudioItem::~AudioItem ( ) [virtual]

Member Function Documentation

AtomItem * AudioItem::Clone ( ) const [virtual]

Returns a pointer to a flat copy of this object, hence the cloned object and the original object are pointing to the same VCard.

See also:
AtomItem::Clone();

Implements AtomItem.

void AudioItem::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AtomItem::Draw

Implements AtomItem.

SharedPtr<AudioReference> AudioItem::GetAudioReference ( void ) const [inline]

Returns the embedded audio reference.

XYDIM AudioItem::GetHeight ( ) const [virtual]

See also:
BoundedItem::GetHeight

Implements BoundedItem.

INT AudioItem::GetId ( ) const [virtual]

See also:
AtomItem::GetId()

Reimplemented from BoundedItem.

XYDIM AudioItem::GetWidth ( ) const [virtual]

See also:
BoundedItem::GetWidth

Implements BoundedItem.

BOOLEAN AudioItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from BoundedItem.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/AudioItem.hpp
  • AddOns/MultiMedia/AudioItem.cpp
Generated on Wed Jan 25 00:56:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioMapiManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioMapiManager Class Reference

#include <Apoxi/AddOns/YamahaMapi/AudioMapiManager.hpp>

Public Types

enum MapiCommandCodeType {
CommandGetMode = 0, CommandSetMode = 1, CommandResetMode = 2, CommandInitialize = 3,
CommandTerminate = 4, CommandCheckLoad = 5, CommandCheckUnload = 6, CommandGetContentsData = 7,
CommandGetPhraseList = 8, CommandRealtimeMidiOpen = 9, CommandRealtimeMidiSendCh = 10, CommandRealtimeStartTimer = 11,
CommandRealtimeStopTimer = 12, CommandRealtimeMidiClose = 13, CommandRealtimeMidiSendSysExMessage = 14, CommandRealtimeMidiSetApiVolume = 15,
CommandRealtimeMidiGetChVolume = 16, CommandPhraseAudioLoad = 17, CommandPhraseAudioOpen = 18, CommandPhraseAudioStandby = 19,
CommandPhraseAudioControl = 20, CommandPhraseAudioStart = 21, CommandPhraseAudioStop = 22, CommandPhraseAudioClose = 23,
CommandPhraseAudioUnload = 24, CommandPhraseGetPosition = 25, CommandPhraseSetEvHandler = 26, CommandPhraseGetLink = 27,
CommandPhraseSetLink = 28, CommandPhraseKill = 29, CommandPhraseSetData = 30, CommandPhraseSeek = 31,
CommandPhraseGetLength = 32, CommandPhraseSetVolume = 33, CommandPhraseSetPanpot = 34, CommandPhrasePlay = 35,
CommandPhraseStop = 36, CommandPhraseRemoveData = 37, CommandPhraseGetStatus = 38, CommandPhrasePause = 39,
CommandPhraseRestart = 40, CommandMelodyControl = 41, CommandMelodyOpenArgInit = 42, CommandMelodyOpen = 43,
CommandMelodyStandby = 44, CommandMelodyWaitReady = 45, CommandMelodyStart = 46, CommandMelodyStop = 47,
CommandMelodySeek = 48, CommandMelodyClose = 49, CommandMelodyLoad = 50, CommandMelodyUnload = 51,
CommandDeviceControl = 52, CommandInvalid = 0xff, CommandEnd
}
Command codes / names as listed in the PMC requirements document "Music API for Panasonic". More...
enum RequestAcceptanceType {
RequestExecuted = 0, RequestRejected = 1, RequestUnexpectedCommand = 100, RequestTimeout = 101,
RequestAudMapiFailure = 102
}
Outcome of a request sent to the priority manager. More...

Static Public Member Functions

static RequestOutcomeType | IFX_MAPI (MapiCommandCodeType command_code, UINT32 parm1, UINT32 parm2, UINT32 parm3, UINT32 parm4, UINT32 parm5, UINT32 parm6, UINT32 parm7)
static void | SetStopCallback (BOOLEAN(*cb_stop)(const AudioActiveReference &active_ref))

Data Structures

struct | MapiCommandType
struct | RequestOutcomeType
Return type for IFX_MAPI(). More...

Member Enumeration Documentation

enum AudioMapiManager::MapiCommandCodeType

Command codes / names as listed in the PMC requirements document "Music API for Panasonic".

Enumerator:
CommandGetMode
CommandSetMode
CommandResetMode
CommandInitialize
CommandTerminate
CommandCheckLoad
CommandCheckUnload
CommandGetContentsData
CommandGetPhraseList
CommandRealtimeMidiOpen
CommandRealtimeMidiSendCh
CommandRealtimeStartTimer
CommandRealtimeStopTimer
CommandRealtimeMidiClose
CommandRealtimeMidiSendSysExMessage
CommandRealtimeMidiSetApiVolume
CommandRealtimeMidiGetChVolume
CommandPhraseAudioLoad
CommandPhraseAudioOpen
CommandPhraseAudioStandby
CommandPhraseAudioControl
CommandPhraseAudioStart
CommandPhraseAudioStop
CommandPhraseAudioClose
CommandPhraseAudioUnload
CommandPhraseGetPosition
CommandPhraseSetEvHandler
CommandPhraseGetLink
CommandPhraseSetLink
CommandPhraseKill
CommandPhraseSetData
CommandPhraseSeek
CommandPhraseGetLength
CommandPhraseSetVolume
CommandPhraseSetPanpot
CommandPhrasePlay
CommandPhraseStop
CommandPhraseRemoveData
CommandPhraseGetStatus
CommandPhrasePause
CommandPhraseRestart
CommandMelodyControl
CommandMelodyOpenArgInit
CommandMelodyOpen
CommandMelodyStandby
CommandMelodyWaitReady
CommandMelodyStart
CommandMelodyStop
CommandMelodySeek
CommandMelodyClose
CommandMelodyLoad
CommandMelodyUnload
CommandDeviceControl
CommandInvalid
CommandEnd

enum AudioMapiManager::RequestAcceptanceType

Outcome of a request sent to the priority manager.

Enumerator:
RequestExecuted
RequestRejected
RequestUnexpectedCommand
RequestTimeout
RequestAudMapiFailure

Member Function Documentation

AudioMapiManager::RequestOutcomeType AudioMapiManager::IFX_MAPI | ( | MapiCommandCodeType | command_code,
 |  | UINT32 | parm1,
 |  | UINT32 | parm2,
 |  | UINT32 | parm3,
 |  | UINT32 | parm4,
 |  | UINT32 | parm5,
 |  | UINT32 | parm6,
 |  | UINT32 | parm7
 | ) | [static]

Requests a MAPI extension command to be executed (acceptance of the request is up to APOXI audio priority management).

Parameters:
command_code | identifies the kind of command to be executed, see enum CommandCodeType
parm1..6 | MAPI parameters, cast to UINT32
parm7 | address of priority info struct (PriorityInfoType*) for commands that need priority
Returns:
outcome of the request to APOXI audio priority management, and MAPI return value (meaningful only if the command was actually executed), see enum RequestOutcomeType

void AudioMapiManager::SetStopCallback ( BOOLEAN(*)(const AudioActiveReference &active_ref) cb_stop ) [static]

The documentation for this class was generated from the following files:
  • AddOns/YamahaMapi/AudioMapiManager.hpp
  • AddOns/YamahaMapi/AudioMapiManager.cpp
Generated on Wed Jan 25 00:56:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioMapiManager::MapiCommandType Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
AudioMapiManager::MapiCommandType

AudioMapiManager::MapiCommandType Struct Reference

#include <Apoxi/AddOns/YamahaMapi/AudioMapiManager.hpp>

Data Fields

MapiCommandCodeType command_code
UINT32 | parm1
UINT32 | parm2
UINT32 | parm3
UINT32 | parm4
UINT32 | parm5
UINT32 | parm6
UINT32 | parm7

Field Documentation

MapiCommandCodeType AudioMapiManager::MapiCommandType::command_code

UINT32 AudioMapiManager::MapiCommandType::parm1

UINT32 AudioMapiManager::MapiCommandType::parm2

UINT32 AudioMapiManager::MapiCommandType::parm3

UINT32 AudioMapiManager::MapiCommandType::parm4

UINT32 AudioMapiManager::MapiCommandType::parm5

UINT32 AudioMapiManager::MapiCommandType::parm6

UINT32 AudioMapiManager::MapiCommandType::parm7

The documentation for this struct was generated from the following file:
  • AddOns/YamahaMapi/AudioMapiManager.hpp
Generated on Wed Jan 25 00:56:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioMapiManager::RequestOutcomeType Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
AudioMapiManager::RequestOutcomeType

AudioMapiManager::RequestOutcomeType Struct Reference

Return type for IFX_MAPI(). More...

#include <Apoxi/AddOns/YamahaMapi/AudioMapiManager.hpp>

Data Fields

RequestAcceptanceType acceptance_outcome
INT32 mapi_return_value

Detailed Description

Return type for IFX_MAPI().

Field Documentation

RequestAcceptanceType AudioMapiManager::RequestOutcomeType::acceptance_outcome

INT32 AudioMapiManager::RequestOutcomeType::mapi_return_value

The documentation for this struct was generated from the following file:
  • AddOns/YamahaMapi/AudioMapiManager.hpp
Generated on Wed Jan 25 00:56:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMsg.hpp>

Inheritance diagram for AudioMsg:

[legend]
Collaboration diagram for AudioMsg:

[legend]

Public Types

enum | { ID = 9000 }

Public Member Functions

AudioMsg (UINT8 handle, UINT16 drv_id, UINT16 funk_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4)
virtual Message * | Clone () const
UINT16 | GetDrvId () const
UINT16 | GetFunkId () const
UINT8 | GetHandle () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetParam1 () const
UINT32 | GetParam2 () const
UINT32 | GetParam3 () const
UINT32 | GetParam4 () const
INT8 | GetReturnCode () const
void | SetDrvId (UINT16 drv_id)
void | SetFunkId (UINT16 funk_id)
void | SetHandle (UINT8 handle)
void | SetParam1 (UINT32 param1)
void | SetParam2 (UINT32 param2)
void | SetParam3 (UINT32 param3)
void | SetParam4 (UINT32 param4)
void | SetReturnCode (INT8 return_code)
virtual | ~AudioMsg ()

Detailed Description

This message is defined only for backward compatibility. It should not be used anymore!!!

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioMsg::AudioMsg | ( | UINT8 | handle,
 |  | UINT16 | drv_id,
 |  | UINT16 | funk_id,
 |  | INT8 | return_code,
 |  | UINT32 | param1,
 |  | UINT32 | param2,
 |  | UINT32 | param3,
 |  | UINT32 | param4
 | ) |

AudioMsg::~AudioMsg ( ) [virtual]

Member Function Documentation

Message * AudioMsg::Clone ( ) const [virtual]

Implements Message.

UINT16 AudioMsg::GetDrvId ( ) const [inline]

UINT16 AudioMsg::GetFunkId ( ) const [inline]

UINT8 AudioMsg::GetHandle ( ) const [inline]

const MsgMetaData & AudioMsg::GetMetaData ( ) const [virtual]

Implements Message.

UINT32 AudioMsg::GetParam1 ( ) const [inline]

UINT32 AudioMsg::GetParam2 ( ) const [inline]

UINT32 AudioMsg::GetParam3 ( ) const [inline]

UINT32 AudioMsg::GetParam4 ( ) const [inline]

INT8 AudioMsg::GetReturnCode ( ) const [inline]

void AudioMsg::SetDrvId ( UINT16 drv_id ) [inline]

void AudioMsg::SetFunkId ( UINT16 funk_id ) [inline]

void AudioMsg::SetHandle ( UINT8 handle ) [inline]

void AudioMsg::SetParam1 ( UINT32 param1 ) [inline]

void AudioMsg::SetParam2 ( UINT32 param2 ) [inline]

void AudioMsg::SetParam3 ( UINT32 param3 ) [inline]

void AudioMsg::SetParam4 ( UINT32 param4 ) [inline]

void AudioMsg::SetReturnCode ( INT8 return_code ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMsg.hpp
  • Audio/Messages/AudioMsg.cpp
Generated on Wed Jan 25 00:56:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPath Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioPath Class Reference
[Audio]

#include <Apoxi/Audio/AudioPath.hpp>

Inheritance diagram for AudioPath:

[legend]
Collaboration diagram for AudioPath:

[legend]

Public Types

enum | AudioPathType { AudioPathDownlink, AudioPathUplink }
enum DownlinkPathType {
DownlinkPathEarpiece = 0x1, DownlinkPathMonoHeadset = 0x2, DownlinkPathStereoHeadset = 0x4, DownlinkPathBackspeaker = 0x8,
DownlinkPathI2S1_Tx = 0x10, DownlinkPathTTY = 0x20, DownlinkCarKit = 0x40, DownlinkPathExtRingerMonoHeadset = 0x80,
DownlinkPathExtRingerStereoHeadset = 0x100, DownlinkPathExtRingerBackspeaker = 0x200, DownlinkPathExtRingerI2S1_Tx = 0x400, DownlinkPathBackspeakerStereo = 0x800,
DownlinkPathFmRadioBackspeaker = 0x1000, DownlinkPathFmRadioHeadset = 0x2000, DownlinkPathNone = 0x0
}
The audio downlink paths, On EGOLD platforms the definitions include both downlink/uplink. More...
enum UplinkPathType {
UplinkPathHandsetMic = 0x1, UplinkPathHeadsetMic = 0x2, UplinkCarKit = 0x4, UplinkPathI2S1_Rx = 0x8,
UplinkPathTTY = 0x10, UplinkPathRecordingHandsetMic = 0x20, UplinkPathDthfMic = 0x40, UplinkPathI2S1InbandRx = 0x80,
UplinkPathNone = 0x0
}
The audio uplink paths. Applicable on SGOLD platforms only. More...

Public Member Functions

AudioPath (const DownlinkPathType downlinkPath)
The downlink path constructor.
AudioPath (const UplinkPathType uplinkPath)
The uplink path constructor.
AudioPath (const AudioPath &path)
The copy constructor.
AudioPath::AudioPathType | GetAudioPathType () const
AudioDeviceBase::AudioSourceType | GetAudioSourceType () const
UINT16 | GetPath () const
Get the audio path. Use GetAudioPathType() to get the path type.
AudioPath & | operator= (const AudioPath::DownlinkPathType path)
AudioPath & | operator= (const AudioPath::UplinkPathType path)
BOOLEAN | operator== (const AudioPath &path) const

Member Enumeration Documentation

enum AudioPath::AudioPathType

The audio uplink/downlink concept applies to SGOLD platforms. Audio path type

Enumerator:
AudioPathDownlink | Downlink.
AudioPathUplink | Uplink.

enum AudioPath::DownlinkPathType

The audio downlink paths, On EGOLD platforms the definitions include both downlink/uplink.

Enumerator:
DownlinkPathEarpiece | Handset speaker.
DownlinkPathMonoHeadset | Mono headset speaker.
DownlinkPathStereoHeadset | Stereo headset speakers.
DownlinkPathBackspeaker | Handsfree speaker / Backspeaker.
DownlinkPathI2S1_Tx | Bluetooth headset.
DownlinkPathTTY | Tty downlink device.
DownlinkCarKit | Handsfree car kit.
DownlinkPathExtRingerMonoHeadset | External ringer - Mono headset speaker.
DownlinkPathExtRingerStereoHeadset | External ringer - Stereo headset speakers.
DownlinkPathExtRingerBackspeaker | External ringer - Handsfree speaker / Backspeaker.
DownlinkPathExtRingerI2S1_Tx | External ringer - Bluetooth headset.
DownlinkPathBackspeakerStereo | Stereo Backspeaker.
DownlinkPathFmRadioBackspeaker | Fm Radio Backspeaker.
DownlinkPathFmRadioHeadset | Fm Radio Headset.
DownlinkPathNone | This value should be used for accessories that have no downlink path.

enum AudioPath::UplinkPathType

The audio uplink paths. Applicable on SGOLD platforms only.

Enumerator:
UplinkPathHandsetMic | Handset microphone.
UplinkPathHeadsetMic | Headset microphone.
UplinkCarKit
UplinkPathI2S1_Rx | Bluetooth headset.
UplinkPathTTY | Tty uplink device.
UplinkPathRecordingHandsetMic | Uplink path for handset when used for recording (as opposed to voice call).
UplinkPathDthfMic
UplinkPathI2S1InbandRx
UplinkPathNone | This value should be used for accessories that have no uplink path.

Constructor & Destructor Documentation

AudioPath::AudioPath ( const AudioPath & path )

The copy constructor.

AudioPath::AudioPath ( const UplinkPathType uplinkPath )

The uplink path constructor.

AudioPath::AudioPath ( const DownlinkPathType downlinkPath )

The downlink path constructor.

Member Function Documentation

AudioPath::AudioPathType AudioPath::GetAudioPathType ( ) const

Get the type of the audio path

Returns:
the AudioPath::AudioPathType

AudioDeviceBase::AudioSourceType AudioPath::GetAudioSourceType ( ) const

UINT16 AudioPath::GetPath ( ) const

Get the audio path. Use GetAudioPathType() to get the path type.

AudioPath & AudioPath::operator= ( const AudioPath::DownlinkPathType path )

AudioPath & AudioPath::operator= ( const AudioPath::UplinkPathType path )

BOOLEAN AudioPath::operator== ( const AudioPath & path ) const

The documentation for this class was generated from the following files:
  • Audio/AudioPath.hpp
  • Audio/AudioPath.cpp
Generated on Wed Jan 25 00:57:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPathManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioPathManager Class Reference
[Audio]

#include <Apoxi/Audio/AudioPathManager.hpp>

Public Member Functions

BOOLEAN | AddAudioPath (AudioPath &path)
BOOLEAN | CanLinkAudioPath (AudioPath &path)
BOOLEAN | Enable3dSound (BOOLEAN enable=TRUE)
void | EnableUplinkAudioPaths (BOOLEAN enable=TRUE)
BOOLEAN | IsCallActive ()
Returns TRUE if the call is active.
BOOLEAN | IsPathActive (AudioPath &path)
BOOLEAN | LinkAccessory (const AudioDeviceBase::AudioSourceType source, AudioAccessoryDetails &accessory)
void | RemoveAllAudioPaths (BOOLEAN upLink=TRUE, BOOLEAN downLink=TRUE)
BOOLEAN | RemoveAudioPath (AudioPath &path)
void | UpdateAudioPaths (AudioDeviceBase::AudioSourceType requester_audio_source=AudioDeviceBase::DspAudioSource)
Updates the system's audio paths.
virtual | ~AudioPathManager ()

Static Public Member Functions

static AudioPathManager * | GetInstance ()

Protected Member Functions

AudioPathManager ()

Detailed Description

This is the audio path manager dealing with uplink/downlink path control This is a singleton - use GetInstance().

The MMI will have 100% freedom to setup any kind of combination for the Uplink and Downlink audio path.

All combinations of pathÆs can be configured, but the following combinations will result in a HW conflict:
Uplink: None of the paths UplinkPathHandsetMic, UplinkPathHeadsetMic, UplinkPathI2S1_Rx (bluetooth) and UplinkPathTTY can be enabled in parallel.
Downlink: 1. DownlinkPathMonoHeadset and DownlinkPathStereoHeadset cannot be enabled in parallel.
2. DownlinkPathTTY cannot run in parallel with any of the downlink paths.
All other combinations are allowed.

Constructor & Destructor Documentation

AudioPathManager::AudioPathManager ( ) [protected]

AudioPathManager::~AudioPathManager ( ) [virtual]

Member Function Documentation

BOOLEAN AudioPathManager::AddAudioPath ( AudioPath & path )

Activate the path. Use RemoveAudioPath(AudioPath& path) to deactivate the path. The path will be active besides the already active paths.

Parameters:
path The path to be activated
Returns:
FALSE if the path is already active or cannot be activated due to a resource conflict
Note:
On EGOLD platforms it is not possible to have more than one active paths at the same time so the function will return FALSE if there is already an active path. Use RemoveAllAudioPaths() before calling this function or call AudioDeviceManager::LinkAccessory() that will do all for you.

BOOLEAN AudioPathManager::CanLinkAudioPath ( AudioPath & path )

Check if there is a conflict beetwen the specified audio path and the current activated paths enabled using AddAudioPath(AudioPath& path)

Parameters:
path The path to be checked
Returns:
TRUE if the path can be linked

BOOLEAN AudioPathManager::Enable3dSound ( BOOLEAN enable = TRUE )

Enables "3D enhanced stereo" of the downlink audio paths. Supported downlink paths are stereo headset and stereo backspeaker.

Parameters:
enable TRUE - enable the 3D mode, FALSE - disable the 3D mode
Returns:
TRUE - if succeded and hardware supports this feature, otherwise FALSE

void AudioPathManager::EnableUplinkAudioPaths ( BOOLEAN enable = TRUE )

Enables the uplink audio paths. Uplink paths are only needed when there is a call or when a sound is being recorded. If the uplink path is enabled in some other case, there is a background noise. So the uplink paths are only going to be enabled when really needed.

Parameters:
enable TRUE - enable the uplink audio paths, FALSE - disable the uplink audio paths

AudioPathManager * AudioPathManager::GetInstance ( ) [static]

Singleton

BOOLEAN AudioPathManager::IsCallActive ( )

Returns TRUE if the call is active.

BOOLEAN AudioPathManager::IsPathActive ( AudioPath & path )

Check whether the path is active or not

Parameters:
path The path to be checked
Returns:
TRUE if the path is active

BOOLEAN AudioPathManager::LinkAccessory | ( | const AudioDeviceBase::AudioSourceType | source,
 |  | AudioAccessoryDetails & | accessory
 | ) |

Activate and set up the new uplink/downlink paths for the selected accessory See AudioAccessoryDetails class

Parameters:
source | Not used. this is for further use
accessory | The accessory configuration to be set up
Returns:
TRUE when path was successfuly activated

void AudioPathManager::RemoveAllAudioPaths | ( | BOOLEAN | upLink = TRUE,
 |  | BOOLEAN | downLink = TRUE
 | ) |

Remove all the audio path linuplink/downlink paths

Parameters:
upLink | TRUE if all active uplink paths have to be removed
downLink | TRUE if all active dawnlink paths have to be removed

BOOLEAN AudioPathManager::RemoveAudioPath ( AudioPath & path )

Deactivate the path previoustly activated using AddAudioPath(AudioPath& path).

Parameters:
path The path to be removed/deactivated
Returns:
TRUE if the path has been found in the active path list

void AudioPathManager::UpdateAudioPaths ( AudioDeviceBase::AudioSourceType requester_audio_source = AudioDeviceBase::DspAudioSource )

Updates the system's audio paths.

The documentation for this class was generated from the following files:
  • Audio/AudioPathManager.hpp
  • Audio/AudioPathManager.cpp
Generated on Wed Jan 25 00:57:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPlayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioPlayer Class Reference
[Audio]

#include <Apoxi/Audio/AudioPlayer.hpp>

Inheritance diagram for AudioPlayer:

[legend]
Collaboration diagram for AudioPlayer:

[legend]

Public Member Functions

AudioPlayer ()
virtual ~AudioPlayer ()

Detailed Description

The responsibility of an AudioPlayer is to play sounds (represented by AudioReferences/AudioActiveReferences) at the request of the AudioPriorityManager (PM), and to notify the PM of changes in playback state.

Constructor & Destructor Documentation

AudioPlayer::AudioPlayer ( )

AudioPlayer::~AudioPlayer ( ) [virtual]

The documentation for this class was generated from the following files:
  • Audio/AudioPlayer.hpp
  • Audio/AudioPlayer.cpp
Generated on Wed Jan 25 00:57:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPlayerEvent Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioPlayerEvent Struct Reference
[Audio]

#include <Apoxi/Audio/AudioPlayerEvent.hpp>

Collaboration diagram for AudioPlayerEvent:

[legend]

Public Types

enum | Reason { InvalidReason = 0, CommandReason, NaturalReason, DriverReason }
The reason causing the event, also in an "in-response-to" sense for commands. More...

Public Member Functions

AudioPlayerEvent ()

Data Fields

AudioError::AudReturnCode m_error_code
The error code for the AudioErrorMsg (if a message should be sent).
AudioActiveReference::HandleInsidePlayer | m_handle
The handle uniquely identifying the sound within the player.
AudioActiveReference::PlaybackState | m_playback_state
AudioPlayer * m_player
The player playing the sound.
Reason m_reason
The reason causing the event, also in an "in-response-to" sense for commands.
BOOLEAN | m_send_error_message
AudioPriorityManager will send an AudioErrorMsg if this is TRUE.

Member Enumeration Documentation

enum AudioPlayerEvent::Reason

The reason causing the event, also in an "in-response-to" sense for commands.

Enumerator:
InvalidReason
CommandReason
NaturalReason
DriverReason

Constructor & Destructor Documentation

AudioPlayerEvent::AudioPlayerEvent ( ) [inline]

Field Documentation

AudioError::AudReturnCode AudioPlayerEvent::m_error_code

The error code for the AudioErrorMsg (if a message should be sent).

AudioActiveReference::HandleInsidePlayer AudioPlayerEvent::m_handle

The handle uniquely identifying the sound within the player.

AudioActiveReference::PlaybackState AudioPlayerEvent::m_playback_state

The state that the sound is in ("driver truth"). AudioPriorityManager will use this to keep in sync with driver truth.

AudioPlayer* AudioPlayerEvent::m_player

The player playing the sound.

Reason AudioPlayerEvent::m_reason

The reason causing the event, also in an "in-response-to" sense for commands.

BOOLEAN AudioPlayerEvent::m_send_error_message

AudioPriorityManager will send an AudioErrorMsg if this is TRUE.

The documentation for this struct was generated from the following file:
  • Audio/AudioPlayerEvent.hpp
Generated on Wed Jan 25 00:57:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPlayerStore Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioPlayerStore Class Reference
[Audio]

#include <Apoxi/Audio/AudioPlayerStore.hpp>

Collaboration diagram for AudioPlayerStore:

[legend]

Public Member Functions

BOOLEAN | AddPlayer (AudioPlayer *player)
BOOLEAN | ExcludePlayer (AudioPlayer *player, MimeType type, AudioReference::SoundDataSource source)
BOOLEAN | PrioritizePlayer (AudioPlayer *player, MimeType type, AudioReference::SoundDataSource source)
~AudioPlayerStore ()

Static Public Member Functions

static AudioPlayerStore * | GetInstance ()

Protected Member Functions

AudioPlayerStore ()

Protected Attributes

SimpleMap< DataFormatDataSource,
Vector< AudioPlayer * > > 		m_mime_to_source_to_players

Static Protected Attributes

static AudioPlayerStore | m_instance

Data Structures

struct | DataFormatDataSource

Detailed Description

The AudioPlayerStore is used for the registration and configuration of the available AudioPlayers.

Constructor & Destructor Documentation

AudioPlayerStore::AudioPlayerStore ( ) [protected]

AudioPlayerStore::~AudioPlayerStore ( )

Member Function Documentation

BOOLEAN AudioPlayerStore::AddPlayer ( AudioPlayer * player )

Adds a player to the store. The order of adding the players reflects their default priority: The player which is added first has the highest priority. (first in - first out)

Parameters:
player The player to be added.
Returns:
Indicates, if the player was successfully added to the store.

BOOLEAN AudioPlayerStore::ExcludePlayer | ( | AudioPlayer * | player,
 |  | MimeType | type,
 |  | AudioReference::SoundDataSource | source
 | ) |

Allows to exclude a player for a concrete format and data source. Please note, that this method should only be called after the players are added to the store. Calling this method removes the player from the prioritized list of players for the given format and data source.

Parameters:
player | The player which has to be excluded.
type | The format for which the player has to be excluded.
source | The data source for which the player has to be excluded.
Returns:
Indicates, if the priorization was successful.

AudioPlayerStore * AudioPlayerStore::GetInstance ( ) [static]

BOOLEAN AudioPlayerStore::PrioritizePlayer | ( | AudioPlayer * | player,
 |  | MimeType | type,
 |  | AudioReference::SoundDataSource | source
 | ) |

Allows to change the default priority of players for a concrete format and data source. Please note, that this method should only be called after the players are added to the store. Calling this method gives the player the highest priority for the given format and data source. (last in - first out)

Parameters:
player | The player whose priority has to be changed.
type | The format for which the player has to be prioritized.
source | The data source for which the player has to be prioritized.
Returns:
Indicates, if the priorization was successful.

Field Documentation

AudioPlayerStore AudioPlayerStore::m_instance [static, protected]

SimpleMap<DataFormatDataSource, Vector<AudioPlayer*> > AudioPlayerStore::m_mime_to_source_to_players [protected]

The documentation for this class was generated from the following files:
  • Audio/AudioPlayerStore.hpp
  • Audio/AudioPlayerStore.cpp
Generated on Wed Jan 25 00:57:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPlayerStore::DataFormatDataSource Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
AudioPlayerStore::DataFormatDataSource

AudioPlayerStore::DataFormatDataSource Struct Reference

#include <Apoxi/Audio/AudioPlayerStore.hpp>

Public Member Functions

BOOLEAN operator== (const DataFormatDataSource &other)

Data Fields

MimeType mime_type
mime type, see Auxiliary/MimeTypeTable.hpp
AudioReference::SoundDataSource source

Member Function Documentation

BOOLEAN AudioPlayerStore::DataFormatDataSource::operator== ( const DataFormatDataSource & other ) [inline]

Field Documentation

MimeType AudioPlayerStore::DataFormatDataSource::mime_type

mime type, see Auxiliary/MimeTypeTable.hpp

AudioReference::SoundDataSource AudioPlayerStore::DataFormatDataSource::source

The documentation for this struct was generated from the following file:
  • Audio/AudioPlayerStore.hpp
Generated on Wed Jan 25 00:57:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPlayTimeMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioPlayTimeMsg Class Reference

#include <Apoxi/Audio/Messages/AudioPlayTimeMsg.hpp>

Inheritance diagram for AudioPlayTimeMsg:

[legend]
Collaboration diagram for AudioPlayTimeMsg:

[legend]

Public Types

enum | { ID = 9009 }

Public Member Functions

AudioPlayTimeMsg (UINT32 play_time)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetPlayTime () const
void | SetPlayTime (UINT32 play_time)
virtual | ~AudioPlayTimeMsg ()

Detailed Description

This message will be sent as asyncronous response to the QueryPlayTime function call

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioPlayTimeMsg::AudioPlayTimeMsg ( UINT32 play_time )

AudioPlayTimeMsg::~AudioPlayTimeMsg ( ) [virtual]

Member Function Documentation

Message * AudioPlayTimeMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AudioPlayTimeMsg::GetMetaData ( ) const [virtual]

Implements Message.

UINT32 AudioPlayTimeMsg::GetPlayTime ( ) const [inline]

void AudioPlayTimeMsg::SetPlayTime ( UINT32 play_time ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioPlayTimeMsg.hpp
  • Audio/Messages/AudioPlayTimeMsg.cpp
Generated on Wed Jan 25 00:57:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPreset Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioPreset Class Reference
[Audio]

#include <Apoxi/Audio/AudioPreset.hpp>

Inheritance diagram for AudioPreset:

[legend]
Collaboration diagram for AudioPreset:

[legend]

Public Types

enum AudioPresetSoundToneId {
PresetSoundToneDTMF0, PresetSoundToneDTMF1, PresetSoundToneDTMF2, PresetSoundToneDTMF3,
PresetSoundToneDTMF4, PresetSoundToneDTMF5, PresetSoundToneDTMF6, PresetSoundToneDTMF7,
PresetSoundToneDTMF8, PresetSoundToneDTMF9, PresetSoundToneDTMFHash, PresetSoundToneDTMFAsterix,
PresetSoundToneKeyTone1, PresetSoundToneKeyTone2, PresetSoundToneKeyTone3, PresetSoundToneKeyTone4,
PresetSoundToneKeyTone5, PresetSoundToneSvSubscriberBusy, PresetSoundToneSvCongestion, PresetSoundToneSvRadioPatAck,
PresetSoundToneSvRadioPathNotAvail, PresetSoundToneSvErrorInfo, PresetSoundToneSvCallWaiting, PresetSoundToneInfoFreeTone,
PresetSoundToneInfoConnection, PresetSoundToneInfoDisconnect, PresetSoundToneInfoDeviceIn, PresetSoundToneInfoDeviceOut,
PresetSoundToneInfoMsgFull, PresetSoundToneInfoUssd, PresetSoundToneInfoMinutteMinder, PresetSoundToneInfoError1,
PresetSoundToneInfoError2, PresetSoundToneInfoSmsInCall, PresetSoundToneInfoBroadcastInCall, PresetSoundToneInfoAlarmInCall,
PresetSoundToneInfoLowBatInCall, PresetSoundToneInfoPowerOff, PresetSoundToneInfoPowerOn, PresetSoundToneInfoSingleBeep,
PresetSoundToneInfoPositiveAcknowledgement, PresetSoundToneInfoNegativeAcknowledgement, PresetSoundToneInfoAutoRedial, PresetSoundToneInfoNetworkAttention,
PresetSoundToneInfoDialTone, PresetSoundToneInfoLowBat, PresetSoundToneRinger1, PresetSoundToneUnknown
}
enum | PresetToneType { NoToneType, ToneType, RingerType }
typedef UINT | ToneID

Public Member Functions

AudioPreset (const WString &name, ToneID tone_id, PresetToneType tone_type, BOOLEAN ignore_management=FALSE, AudioPresetSoundToneId apoxi_tone_id=PresetSoundToneUnknown)
AudioPreset ()
AudioPresetSoundToneId | GetApoxiToneID () const
BOOLEAN | GetIgnoreManagement () const
See See AudioReference::SetIgnoreManagement().
WString | GetName () const
ToneID | GetToneID () const
PresetToneType | GetToneType () const
virtual | ~AudioPreset ()

Protected Attributes

AudioPresetSoundToneId m_apoxi_tone_id
BOOLEAN | m_ignore_management
WString m_name
ToneID m_tone_id
PresetToneType m_tone_type

Detailed Description

Details about a particular preset sound. Used by AudioPresetStore.

Member Typedef Documentation

typedef UINT AudioPreset::ToneID

Member Enumeration Documentation

enum AudioPreset::AudioPresetSoundToneId

Enumerator:
PresetSoundToneDTMF0
PresetSoundToneDTMF1
PresetSoundToneDTMF2
PresetSoundToneDTMF3
PresetSoundToneDTMF4
PresetSoundToneDTMF5
PresetSoundToneDTMF6
PresetSoundToneDTMF7
PresetSoundToneDTMF8
PresetSoundToneDTMF9
PresetSoundToneDTMFHash
PresetSoundToneDTMFAsterix
PresetSoundToneKeyTone1
PresetSoundToneKeyTone2
PresetSoundToneKeyTone3
PresetSoundToneKeyTone4
PresetSoundToneKeyTone5
PresetSoundToneSvSubscriberBusy
PresetSoundToneSvCongestion
PresetSoundToneSvRadioPatAck
PresetSoundToneSvRadioPathNotAvail
PresetSoundToneSvErrorInfo
PresetSoundToneSvCallWaiting
PresetSoundToneInfoFreeTone
PresetSoundToneInfoConnection
PresetSoundToneInfoDisconnect
PresetSoundToneInfoDeviceIn
PresetSoundToneInfoDeviceOut
PresetSoundToneInfoMsgFull
PresetSoundToneInfoUssd
PresetSoundToneInfoMinutteMinder
PresetSoundToneInfoError1
PresetSoundToneInfoError2
PresetSoundToneInfoSmsInCall
PresetSoundToneInfoBroadcastInCall
PresetSoundToneInfoAlarmInCall
PresetSoundToneInfoLowBatInCall
PresetSoundToneInfoPowerOff
PresetSoundToneInfoPowerOn
PresetSoundToneInfoSingleBeep
PresetSoundToneInfoPositiveAcknowledgement
PresetSoundToneInfoNegativeAcknowledgement
PresetSoundToneInfoAutoRedial
PresetSoundToneInfoNetworkAttention
PresetSoundToneInfoDialTone
PresetSoundToneInfoLowBat
PresetSoundToneRinger1
PresetSoundToneUnknown this will used if the user didn't choose a tone

enum AudioPreset::PresetToneType

Enumerator:
NoToneType
ToneType
RingerType

Constructor & Destructor Documentation

AudioPreset::AudioPreset ( )

AudioPreset::AudioPreset | ( | const WString & | name,
 |  | ToneID | tone_id,
 |  | PresetToneType | tone_type,
 |  | BOOLEAN | ignore_management = FALSE,
 |  | AudioPresetSoundToneId | apoxi_tone_id = PresetSoundToneUnknown
 | ) |

AudioPreset::~AudioPreset ( ) [virtual]

Member Function Documentation

AudioPreset::AudioPresetSoundToneId AudioPreset::GetApoxiToneID ( ) const

BOOLEAN AudioPreset::GetIgnoreManagement ( ) const

See See AudioReference::SetIgnoreManagement().

WString AudioPreset::GetName ( ) const

AudioPreset::ToneID AudioPreset::GetToneID ( ) const

AudioPreset::PresetToneType AudioPreset::GetToneType ( ) const

Field Documentation

AudioPresetSoundToneId AudioPreset::m_apoxi_tone_id [protected]

BOOLEAN AudioPreset::m_ignore_management [protected]

WString AudioPreset::m_name [protected]

ToneID AudioPreset::m_tone_id [protected]

PresetToneType AudioPreset::m_tone_type [protected]

The documentation for this class was generated from the following files:
  • Audio/AudioPreset.hpp
  • Audio/AudioPreset.cpp
Generated on Wed Jan 25 00:57:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioPresetStore Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioPresetStore Class Reference
[Audio]

#include <Apoxi/Audio/AudioPresetStore.hpp>

Inheritance diagram for AudioPresetStore:

[legend]
Collaboration diagram for AudioPresetStore:

[legend]

Public Types

typedef LinkedList< AudioPreset > | PresetList
Discover what presets are available.
typedef AudioPreset::PresetToneType | PresetToneType
typedef AudioPreset::ToneID | ToneID

Public Member Functions

void | AddItem (const WString &name, AudioPreset::AudioPresetSoundToneId apoxi_tone_id, ToneID tone_id, PresetToneType tone_type, BOOLEAN ignore_mangement=FALSE)
void | AddItem (const WString &name, ToneID tone_id, PresetToneType tone_type, BOOLEAN ignore_mangement=FALSE)
SharedPtr< PresetAudioReference > | CreateReference (AudioPreset::AudioPresetSoundToneId apoxi_tone_id) const
SharedPtr< PresetAudioReference > | CreateReference (const WString &preset_name) const
Instantiate an AudioReference so you can play this preset.
virtual const WCHAR * | GetName () const
override
const PresetList & | GetPresetList () const
WString | GetPresetName (const PresetAudioReference &file_reference) const
virtual BootSequenceState | InvokeAt () const
override
virtual void | OnPowerUp ()
override. Initializes the data.
virtual | ~AudioPresetStore ()

Static Public Member Functions

static AudioPresetStore * | GetInstance ()

Protected Member Functions

AudioPresetStore ()
const AudioPreset * | GetPresetByID (AudioPreset::AudioPresetSoundToneId preset_ID) const
const AudioPreset * | GetPresetForName (const WString &preset_name) const

Protected Attributes

PresetList m_preset_list

Static Protected Attributes

static AudioPresetStore | m_instance

Detailed Description

Lists all hardware-present preset sounds available on this mobile phone.

This is not necessarily the same list of preset sounds that a user would see, because an MMI implementation will probably have its own list of sounds that it would show to the user. That might actually be a mixture of driver presets, statically-compiled sound data, and factory-installed FFS sound files.

This allows you to show the list to the user and allow him to select one. Use CreateReference() to get an AudioReference for the selected preset sound.

If you don't want a preset sound then you should directly instantiate a Custom*Reference instance instead.

The instance will be Initialized during OnPowerUp(), called by the SubSystemManager(), because the SubSystem constructor will register itself with the SubSystemManager.

Member Typedef Documentation

typedef LinkedList<AudioPreset> AudioPresetStore::PresetList

Discover what presets are available.

typedef AudioPreset::PresetToneType AudioPresetStore::PresetToneType

typedef AudioPreset::ToneID AudioPresetStore::ToneID

Constructor & Destructor Documentation

AudioPresetStore::AudioPresetStore ( ) [protected]

AudioPresetStore::~AudioPresetStore ( ) [virtual]

Member Function Documentation

void AudioPresetStore::AddItem | ( | const WString & | name,
 |  | AudioPreset::AudioPresetSoundToneId | apoxi_tone_id,
 |  | ToneID | tone_id,
 |  | PresetToneType | tone_type,
 |  | BOOLEAN | ignore_mangement = FALSE
 | ) |

Add a preset sound to the store. This is normally called from project-specific or factory-customization configuration code.

void AudioPresetStore::AddItem | ( | const WString & | name,
 |  | ToneID | tone_id,
 |  | PresetToneType | tone_type,
 |  | BOOLEAN | ignore_mangement = FALSE
 | ) |

Obsolete. Add a preset sound to the store. This is normally called from project-specific or factory-customization configuration code.

SharedPtr< PresetAudioReference > AudioPresetStore::CreateReference ( AudioPreset::AudioPresetSoundToneId apoxi_tone_id ) const

SharedPtr< PresetAudioReference > AudioPresetStore::CreateReference ( const WString & preset_name ) const

Instantiate an AudioReference so you can play this preset.

Instantiate an AudioReference so you can play this preset. In other words, this is a factory. Remember that AudioReferences are reference-counted, so you must call Unreference() on it when you have finished with it.

AudioPresetStore * AudioPresetStore::GetInstance ( ) [static]

const WCHAR * AudioPresetStore::GetName ( ) const [virtual]

override

Implements SubSystem.

const AudioPreset * AudioPresetStore::GetPresetByID ( AudioPreset::AudioPresetSoundToneId preset_ID ) const [protected]

const AudioPreset * AudioPresetStore::GetPresetForName ( const WString & preset_name ) const [protected]

const AudioPresetStore::PresetList & AudioPresetStore::GetPresetList ( ) const

WString AudioPresetStore::GetPresetName ( const PresetAudioReference & file_reference ) const

Retrieve the preset name for an PresetAudioReference that you previously obtained from this AudioPresetStore. This is just a convenience - you could remember the name in your own code, along with the PresetAudioReference.

SubSystemManager::BootSequenceState AudioPresetStore::InvokeAt ( ) const [virtual]

override

Implements SubSystem.

void AudioPresetStore::OnPowerUp ( ) [virtual]

override. Initializes the data.

Reimplemented from SubSystem.

Field Documentation

AudioPresetStore AudioPresetStore::m_instance [static, protected]

PresetList AudioPresetStore::m_preset_list [protected]

The documentation for this class was generated from the following files:
  • Audio/AudioPresetStore.hpp
  • Audio/AudioPresetStore.cpp
Generated on Wed Jan 25 00:57:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioRadioDeviceNotificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioRadioDeviceNotificationMsg Class Reference

#include <Apoxi/Audio/Messages/AudioRadioDeviceNotificationMsg.hpp>

Inheritance diagram for AudioRadioDeviceNotificationMsg:

[legend]
Collaboration diagram for AudioRadioDeviceNotificationMsg:

[legend]

Public Types

enum | { ID = 9007 }

Public Member Functions

AudioRadioDeviceNotificationMsg (const RadioAudioDevice::NotificationType &type)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const RadioAudioDevice::NotificationType & | GetType () const
virtual | ~AudioRadioDeviceNotificationMsg ()

Detailed Description

This message will be sent when the status of the radio device has been changed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioRadioDeviceNotificationMsg::AudioRadioDeviceNotificationMsg ( const RadioAudioDevice::NotificationType & type )

AudioRadioDeviceNotificationMsg::~AudioRadioDeviceNotificationMsg ( ) [virtual]

Member Function Documentation

Message * AudioRadioDeviceNotificationMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AudioRadioDeviceNotificationMsg::GetMetaData ( ) const [virtual]

Implements Message.

const RadioAudioDevice::NotificationType& AudioRadioDeviceNotificationMsg::GetType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioRadioDeviceNotificationMsg.hpp
  • Audio/Messages/AudioRadioDeviceNotificationMsg.cpp
Generated on Wed Jan 25 00:57:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioRecordingStoppedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioRecordingStoppedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioRecordingStoppedMsg:

[legend]
Collaboration diagram for AudioRecordingStoppedMsg:

[legend]

Public Types

enum | { ID = 9013 }

Public Member Functions

AudioRecordingStoppedMsg (const SharedPtr< AudioActiveReference > &active_reference)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
virtual | ~AudioRecordingStoppedMsg ()

Detailed Description

This message will be emitted when the recording has stopped for some reason. It will not be emmitted when you explictly stop the recording.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioRecordingStoppedMsg::AudioRecordingStoppedMsg ( const SharedPtr< AudioActiveReference > & active_reference )

AudioRecordingStoppedMsg::~AudioRecordingStoppedMsg ( ) [virtual]

Member Function Documentation

Message * AudioRecordingStoppedMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioRecordingStoppedMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioRecordingStoppedMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioRecordingStoppedMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:57:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioReference Class Reference
[Audio]

#include <Apoxi/Audio/AudioReference.hpp>

Inheritance diagram for AudioReference:

[legend]
Collaboration diagram for AudioReference:

[legend]

Public Types

typedef INT16 | BalanceLevel
typedef UINT8 | ChannelNumber
enum enumClassType {
ClassType_AudioReference, ClassType_CustomRingerAudioReference, ClassType_CustomSmafPhraseAudioReference, ClassType_CustomSmafMelodyAudioReference,
ClassType_CustomToneAudioReference, ClassType_PresetAudioReference, ClassType_RingerAudioReference, ClassType_SimpleAudioReference,
ClassType_ToneAudioReference, ClassType_VoiceMemoAudioReference, ClassType_PCMAudioReference, ClassType_CustomIMelodyAudioReference,
ClassType_MP3AudioReference, ClassType_CombinedDeviceAudioReference, ClassType_End
}
For RTTI without dynamic_cast<>. More...
enum PredefinedSoundDataSource {
InvalidSoundDataSource = 0, FileSoundDataSource, RamSoundDataSource, StreamSoundDataSource,
PresetSoundDataSource, BinDataSoundDataSource, UnknownSoundDataSource, FmRadioSoundDataSource,
PredefinedSoundDataSourceEnd
}
Predefined values for SoundDataSource. More...
typedef UINT | PriorityGroupType
typedef UINT | PriorityType
typedef INT | SoundDataSource
typedef INT16 | ToneLevel
typedef UINT | VolumeLevel

Public Member Functions

AudioReference ()
virtual BOOLEAN | CanPlayTogetherWith (const AudioReference &audio_ref) const
virtual BalanceLevel | GetBalance () const
ChannelNumber | GetChannel () const
See SetChannel().
virtual VolumeLevel | GetChannelVolume () const
If the sound to be played has only one channel then this is the same as calling GetVolume().
virtual enumClassType | GetClassType () const =0
BOOLEAN | GetContinue () const
Gets the continue flag.
INT | GetExclusionGroup () const
BOOLEAN | GetIgnoreManagement () const
See SetIgnoreManagement().
virtual ChannelNumber | GetNumberOfChannels () const
AudioPathControl::AudioPathControlModeType | GetPathControlMode () const
INT32 | GetPitch () const
MIDP2.0, gets pitch.
void | GetPitchRange (INT32 &minPitch, INT32 &maxPitch) const
MIDP2.0, gets pitch range.
PriorityType | GetPriority () const
PriorityGroupType | GetPriorityGroup () const
INT32 | GetRate () const
MIDP2.0, gets rate.
void | GetRateRange (INT32 &minRate, INT32 &maxRate) const
MIDP2.0, gets rate range.
BOOLEAN | GetRepeatable () const
UINT16 | GetRepeatCount () const
Gets the repeat count.
UINT32 | GetStartPosition () const
MIDP2.0, gets start position.
INT32 | GetTempo () const
MIDP2.0, gets tempo.
UINT32 | GetTimeout () const
Get the time-out previously set using SetTimeout().
virtual ToneLevel | GetTone () const
Not supported, this is for future use.
BOOLEAN | GetTotalPlayTime (UINT32 &total1, UINT32 &total2, UINT32 &total3, UINT32 &total4)
MIDP2.0, get total play time.
VolumeLevel | GetVolume () const
BOOLEAN | GetVolumeSet () const
void | InitGetTotalPlayTimeWaitCondition (UINT32 time)
MIDP2.0, helper function. Init wait condition and sets the flag.
BOOLEAN | InProgress () const
virtual void | SetBalance (BalanceLevel value)
void | SetChannel (ChannelNumber val)
virtual void | SetChannelVolume (VolumeLevel val)
If the sound to be played has only one channel then this is the same as calling SetVolume().
void | SetContinue (BOOLEAN val=TRUE)
void | SetExclusionGroup (INT exclusion_group)
void | SetGetTotalPlayTimeWaitCondition (const UINT32 totalPlayTime1, const UINT32 totalPlayTime2, const UINT32 totalPlayTime3, const UINT32 totalPlayTime4, BOOLEAN val=TRUE)
MIDP2.0, helper function. Releases wait condition and resets the flag.
void | SetIgnoreManagement (BOOLEAN val=TRUE)
void | SetPathControlMode (AudioPathControl::AudioPathControlModeType mode)
void | SetPitch (const INT32 pitch)
MIDP2.0, sets pitch.
void | SetPriority (PriorityType val)
Use a higher priority to allow your sound to interrupt another lower-priority sound that is currently playing.
void | SetPriorityGroup (PriorityGroupType group)
void | SetRate (const INT32 rate)
MIDP2.0, sets rate.
void | SetRepeatCount (UINT16 repeat_count=0)
void | SetStartPosition (const UINT32 startPosition)
MIDP2.0.
void | SetTempo (const INT32 tempo)
MIDP2.0, sets tempo.
void | SetTimeout (UINT32 timeout)
virtual void | SetTone (ToneLevel value)
Not supported, this is for future use.
void | SetVolume (VolumeLevel val)
virtual | ~AudioReference ()

Friends

class | AudioPriorityManager
class | RingerAudioPlayer
class | ToneAudioPlayer

Data Structures

class | TotalPlayTimeContainer
Total play time container. More...

Member Typedef Documentation

typedef INT16 AudioReference::BalanceLevel

typedef UINT8 AudioReference::ChannelNumber

typedef UINT AudioReference::PriorityGroupType

typedef UINT AudioReference::PriorityType

typedef INT AudioReference::SoundDataSource

Specifies where and how sound data is obtained. See PredefinedSoundDataSource. Extension (non-predefined) values must avoid overlap (with predefined values and among each other).

typedef INT16 AudioReference::ToneLevel

typedef UINT AudioReference::VolumeLevel

Member Enumeration Documentation

enum AudioReference::enumClassType

For RTTI without dynamic_cast<>.

Enumerator:
ClassType_AudioReference
ClassType_CustomRingerAudioReference
ClassType_CustomSmafPhraseAudioReference
ClassType_CustomSmafMelodyAudioReference
ClassType_CustomToneAudioReference
ClassType_PresetAudioReference
ClassType_RingerAudioReference
ClassType_SimpleAudioReference
ClassType_ToneAudioReference
ClassType_VoiceMemoAudioReference
ClassType_PCMAudioReference
ClassType_CustomIMelodyAudioReference
ClassType_MP3AudioReference
ClassType_CombinedDeviceAudioReference
ClassType_End

enum AudioReference::PredefinedSoundDataSource

Predefined values for SoundDataSource.

Enumerator:
InvalidSoundDataSource | Should not be used by the application.
FileSoundDataSource | File based playback.
RamSoundDataSource | RAM based playback.
StreamSoundDataSource | Streaming based playback.
PresetSoundDataSource | Audio driver built-in sounds.
BinDataSoundDataSource | BinData based playback.
UnknownSoundDataSource | Unknown sound data source.
FmRadioSoundDataSource | FM Radio playback.
PredefinedSoundDataSourceEnd | Any user defined data sources should use this as baseline.

Constructor & Destructor Documentation

AudioReference::AudioReference ( )

AudioReference::~AudioReference ( ) [virtual]

Member Function Documentation

BOOLEAN AudioReference::CanPlayTogetherWith ( const AudioReference & audio_ref ) const [virtual]

Reimplemented in CustomSmafPhraseAudioReference.

AudioReference::BalanceLevel AudioReference::GetBalance ( ) const [virtual]

Not supported, this is for future use. Gets the current balance setting. The returned value is in the range -100 to +100. -100 means the sound is output only on the left speaker. Per default the sound is centered.

Returns:
balance setting

AudioReference::ChannelNumber AudioReference::GetChannel ( ) const

See SetChannel().

AudioReference::VolumeLevel AudioReference::GetChannelVolume ( ) const [virtual]

If the sound to be played has only one channel then this is the same as calling GetVolume().

Reimplemented in CustomSmafPhraseAudioReference.

virtual enumClassType AudioReference::GetClassType ( ) const [pure virtual]

Implemented in MapiAudioReference, CustomRingerAudioReference, CustomSmafPhraseAudioReference, CustomToneAudioReference, PresetAudioReference, and StreamAudioReference.

BOOLEAN AudioReference::GetContinue ( ) const [inline]

Gets the continue flag.

INT AudioReference::GetExclusionGroup ( ) const [inline]

BOOLEAN AudioReference::GetIgnoreManagement ( ) const [inline]

See SetIgnoreManagement().

AudioReference::ChannelNumber AudioReference::GetNumberOfChannels ( ) const [virtual]

Gets the number of channels. The base class returns 1 because only SMAF/PhraseL1 have channels. See SetChannel().

Reimplemented in CustomSmafPhraseAudioReference.

AudioPathControl::AudioPathControlModeType AudioReference::GetPathControlMode ( ) const

Getter for path control mode.

INT32 AudioReference::GetPitch ( ) const

MIDP2.0, gets pitch.

MIDP2.0 support. GetPitch, it gets pitch.

Parameters:
No params.
Returns:
pitch.

void AudioReference::GetPitchRange | ( | INT32 & | minPitch,
 |  | INT32 & | maxPitch
 | ) | const

MIDP2.0, gets pitch range.

MIDP2.0 support. GetPitchRange, it gets pitch range.

Parameters:
minPitch. | Pitch minimum value.
maxPitch. | Pitch maximum value.
Returns:
No return value. Note: Not supported.

AudioReference::PriorityType AudioReference::GetPriority ( ) const

AudioReference::PriorityGroupType AudioReference::GetPriorityGroup ( ) const

INT32 AudioReference::GetRate ( ) const

MIDP2.0, gets rate.

MIDP2.0 support. GetRate, it gets rate.

Parameters:
No params.
Returns:
INT32 rate.

void AudioReference::GetRateRange | ( | INT32 & | minRate,
 |  | INT32 & | maxRate
 | ) | const

MIDP2.0, gets rate range.

MIDP2.0 support. GetRateRange, it gets rate range.

Parameters:
minRate. | Rate minimum value.
maxRate. | Rate maximum value.
Returns:
No return value. Note: Not supported.

BOOLEAN AudioReference::GetRepeatable ( ) const

UINT16 AudioReference::GetRepeatCount ( ) const [inline]

Gets the repeat count.

UINT32 AudioReference::GetStartPosition ( ) const

MIDP2.0, gets start position.

MIDP2.0 support. GetStartPosition, it gets start position.

Parameters:
No params.
Returns:
UINT32 start position.

INT32 AudioReference::GetTempo ( ) const

MIDP2.0, gets tempo.

MIDP2.0 support. GetTempo, it gets tempo.

Parameters:
No params.
Returns:
tempo.

UINT32 AudioReference::GetTimeout ( ) const

Get the time-out previously set using SetTimeout().

AudioReference::ToneLevel AudioReference::GetTone ( ) const [virtual]

Not supported, this is for future use.

BOOLEAN AudioReference::GetTotalPlayTime | ( | UINT32 & | total1,
 |  | UINT32 & | total2,
 |  | UINT32 & | total3,
 |  | UINT32 & | total4
 | ) |

MIDP2.0, get total play time.

MIDP2.0 support. GetTotalPlayTime, it gets total play times.

Deprecated:
Parameters:
total1 | - total play time for the first channel.
total2 | - total play time for the second channel.
total3 | - total play time for the third channel.
total4 | - total play time for the fourth channel.
Returns:
TRUE on success, FALSE otherwise.

AudioReference::VolumeLevel AudioReference::GetVolume ( ) const

Returns the current volume in the range 0-100.

BOOLEAN AudioReference::GetVolumeSet ( ) const

Whether the SetVolume() was called.

void AudioReference::InitGetTotalPlayTimeWaitCondition ( UINT32 time )

MIDP2.0, helper function. Init wait condition and sets the flag.

GetRateRange, it gets rate range.

Parameters:
minRate. | Rate minimum value.
maxRate. | Rate maximum value.
Returns:
No return value.

BOOLEAN AudioReference::InProgress ( ) const

InProgress, it checks getting total play times status, i.e. the flag.

Parameters:
no params.
Returns:
TRUE if progress, FALSE otherwise.

void AudioReference::SetBalance ( BalanceLevel value ) [virtual]

Not supported, this is for future use. see GetBalance for range of value. If a value out of range is supplied it is corrected to be in-range.

void AudioReference::SetChannel ( ChannelNumber val )

If this type of sound can be played simultaneously with another sound, then the various sounds play on channels. The channel index starts at 1. See GetNumberOfChannels().

void AudioReference::SetChannelVolume ( VolumeLevel val ) [virtual]

If the sound to be played has only one channel then this is the same as calling SetVolume().

void AudioReference::SetContinue ( BOOLEAN val = TRUE ) [inline]

Set the continue flag of a audio reference (used internally by the priority manager).

Parameters:
val Please consult the priority policy documentation

void AudioReference::SetExclusionGroup ( INT exclusion_group ) [inline]

void AudioReference::SetGetTotalPlayTimeWaitCondition | ( | const UINT32 | totalPlayTime1,
 |  | const UINT32 | totalPlayTime2,
 |  | const UINT32 | totalPlayTime3,
 |  | const UINT32 | totalPlayTime4,
 |  | BOOLEAN | val = TRUE
 | ) |

MIDP2.0, helper function. Releases wait condition and resets the flag.

SetGetTotalPlayTimeWaitCondition, it sets total play times and resets the flag and the condition.

Parameters:
total1 | - total play time for the first channel.
total2 | - total play time for the second channel.
total3 | - total play time for the third channel.
total4 | - total play time for the fourth channel.
Returns:
No return.

void AudioReference::SetIgnoreManagement ( BOOLEAN val = TRUE ) [inline]

This function may not be called directly by code outside of APOXI.

void AudioReference::SetPathControlMode ( AudioPathControl::AudioPathControlModeType mode )

Setter for path control mode.

void AudioReference::SetPitch ( const INT32 pitch )

MIDP2.0, sets pitch.

MIDP2.0 support. SetPitch, it sets pitch.

Parameters:
pitch. Audio reference pitch.
Returns:
No return value.

void AudioReference::SetPriority ( PriorityType val )

Use a higher priority to allow your sound to interrupt another lower-priority sound that is currently playing.

void AudioReference::SetPriorityGroup ( PriorityGroupType group )

Sets the priority group. The default value is always 1.

Note:
Definition of the priority group: A gruop is a family of sounds defined by application layer that are supposed to be prioritized using SetPriority(). The sounds being part of the same group will not be allowed to play in parallel. If a use case requires a parallel playback and the actual hardware supports it, a second priority group can be defined. The priority manager will allow the playback of two sounds from two different priority groups at the same time. The maximum number of parallel groups is determined depending on hardware capabilities. Example: Hardware supports two midi sounds played in parallel Sound A (midi type) played from SoundBrowser Sound B (midi type) played as a key tone
Use case requires that Sound A and B played simultaneously

Resolution: SoundA::SetPriorityGroup(1); SoundB::SetPriorityGroup(2);

void AudioReference::SetRate ( const INT32 rate )

MIDP2.0, sets rate.

MIDP2.0 support. SetRate, it sets rate.

Parameters:
rate. Audio reference rate.
Returns:
No return value.

void AudioReference::SetRepeatCount ( UINT16 repeat_count = 0 ) [inline]

Sets the repeat count. Note: It is the responsibility of the AudioPlayer to play the sound as many times as the repeat count specifies.

Parameters:
repeat_count The sound will be repeated repeat_count times. If 0 then repeat indefinitely (until stopped).

void AudioReference::SetStartPosition ( const UINT32 startPosition )

MIDP2.0.

MIDP2.0 support. SetStartPosition, it sets start position.

Parameters:
startPosition. Audio reference start position.
Returns:
No return value.

void AudioReference::SetTempo ( const INT32 tempo )

MIDP2.0, sets tempo.

MIDP2.0 support. SetTempo, it sets tempo.

Parameters:
tempo. Audio reference tempo.
Returns:
No return value.

void AudioReference::SetTimeout ( UINT32 timeout )

Set the time-out in milliseconds. When the time-out occur the playing instance will be stopped. By default there is no time-out. Due to resource consumption the time-out option should be used only if really needed

void AudioReference::SetTone ( ToneLevel value ) [virtual]

Not supported, this is for future use.

void AudioReference::SetVolume ( VolumeLevel val )

If this method is not used, the AudioPlayer's volume will be used.

Parameters:
val The desired volume - the valid range is between 0 and 100. Setting the value 0 means silent.

Friends And Related Function Documentation

friend class AudioPriorityManager [friend]

Reimplemented in StreamAudioReference.

friend class RingerAudioPlayer [friend]

friend class ToneAudioPlayer [friend]

The documentation for this class was generated from the following files:
  • Audio/AudioReference.hpp
  • Audio/AudioReference.cpp
Generated on Wed Jan 25 00:57:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioReference::TotalPlayTimeContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
AudioReference::TotalPlayTimeContainer

AudioReference::TotalPlayTimeContainer Class Reference

Total play time container. More...

#include <Apoxi/Audio/AudioReference.hpp>

Data Fields

UINT32 | m_total_play_time_1
UINT32 | m_total_play_time_2
UINT32 | m_total_play_time_3
UINT32 | m_total_play_time_4

Detailed Description

Total play time container.

Field Documentation

UINT32 AudioReference::TotalPlayTimeContainer::m_total_play_time_1

UINT32 AudioReference::TotalPlayTimeContainer::m_total_play_time_2

UINT32 AudioReference::TotalPlayTimeContainer::m_total_play_time_3

UINT32 AudioReference::TotalPlayTimeContainer::m_total_play_time_4

The documentation for this class was generated from the following file:
  • Audio/AudioReference.hpp
Generated on Wed Jan 25 00:57:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioRestartedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioRestartedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioRestartedMsg.hpp>

Inheritance diagram for AudioRestartedMsg:

[legend]
Collaboration diagram for AudioRestartedMsg:

[legend]

Public Types

enum | { ID = 9006 }

Public Member Functions

AudioRestartedMsg (const SharedPtr< AudioActiveReference > &active_reference)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
virtual | ~AudioRestartedMsg ()

Detailed Description

This message will be emitted when a repeated sound is restarted

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioRestartedMsg::AudioRestartedMsg ( const SharedPtr< AudioActiveReference > & active_reference )

AudioRestartedMsg::~AudioRestartedMsg ( ) [virtual]

Member Function Documentation

Message * AudioRestartedMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioRestartedMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioRestartedMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioRestartedMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioRestartedMsg.hpp
  • Audio/Messages/AudioRestartedMsg.cpp
Generated on Wed Jan 25 00:57:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioResumedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioResumedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioResumedMsg.hpp>

Inheritance diagram for AudioResumedMsg:

[legend]
Collaboration diagram for AudioResumedMsg:

[legend]

Public Types

enum | { ID = 9010 }

Public Member Functions

AudioResumedMsg (const SharedPtr< AudioActiveReference > &active_reference)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
virtual | ~AudioResumedMsg ()

Detailed Description

This message will be emitted when a sound is resumed by the audio priority manager

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioResumedMsg::AudioResumedMsg ( const SharedPtr< AudioActiveReference > & active_reference )

AudioResumedMsg::~AudioResumedMsg ( ) [virtual]

Member Function Documentation

Message * AudioResumedMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioResumedMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioResumedMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioResumedMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioResumedMsg.hpp
  • Audio/Messages/AudioResumedMsg.cpp
Generated on Wed Jan 25 00:57:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioRewindStartedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioRewindStartedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioRewindStartedMsg:

[legend]
Collaboration diagram for AudioRewindStartedMsg:

[legend]

Public Types

enum | { ID = 9023 }

Public Member Functions

AudioRewindStartedMsg (const SharedPtr< AudioActiveReference > &active_reference)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
virtual | ~AudioRewindStartedMsg ()

Detailed Description

This message will be sent when rewind of a player has started.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioRewindStartedMsg::AudioRewindStartedMsg ( const SharedPtr< AudioActiveReference > & active_reference )

AudioRewindStartedMsg::~AudioRewindStartedMsg ( ) [virtual]

Member Function Documentation

Message * AudioRewindStartedMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioRewindStartedMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioRewindStartedMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioRewindStartedMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:57:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioStartedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioStartedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioStartedMsg.hpp>

Inheritance diagram for AudioStartedMsg:

[legend]
Collaboration diagram for AudioStartedMsg:

[legend]

Public Types

enum | { ID = 9009 }

Public Member Functions

AudioStartedMsg (const SharedPtr< AudioActiveReference > &active_reference)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
virtual | ~AudioStartedMsg ()

Detailed Description

This message will be emitted when a sound is started, i.e. the driver function to start playing has been called successfully

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioStartedMsg::AudioStartedMsg ( const SharedPtr< AudioActiveReference > & active_reference )

AudioStartedMsg::~AudioStartedMsg ( ) [virtual]

Member Function Documentation

Message * AudioStartedMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioStartedMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioStartedMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioStartedMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioStartedMsg.hpp
  • Audio/Messages/AudioStartedMsg.cpp
Generated on Wed Jan 25 00:57:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioStoppedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioStoppedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioStoppedMsg.hpp>

Inheritance diagram for AudioStoppedMsg:

[legend]
Collaboration diagram for AudioStoppedMsg:

[legend]

Public Types

enum | { ID = 9001 }

Public Member Functions

AudioStoppedMsg (const SharedPtr< AudioActiveReference > &active_reference, BOOLEAN auto_stopped, const AudioDeviceBase::StopCause &stop_cause, const AudioDeviceBase::AudioErrorType &audio_error_type)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
const AudioDeviceBase::AudioErrorType & | GetAudioErrorType () const
virtual const MsgMetaData & | GetMetaData () const
const AudioDeviceBase::StopCause & | GetStopCause () const
BOOLEAN | IsAutoStopped () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
void | SetAudioErrorType (const AudioDeviceBase::AudioErrorType &audio_error_type)
void | SetAutoStopped (BOOLEAN auto_stopped)
void | SetStopCause (const AudioDeviceBase::StopCause &stop_cause)
virtual | ~AudioStoppedMsg ()

Detailed Description

This message will be emitted when a sound stops playing, when it reaches the end. It will not be emmitted when you explictly stop the sound. This message replaces the deprecated AudioMsg class.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioStoppedMsg::AudioStoppedMsg | ( | const SharedPtr< AudioActiveReference > & | active_reference,
 |  | BOOLEAN | auto_stopped,
 |  | const AudioDeviceBase::StopCause & | stop_cause,
 |  | const AudioDeviceBase::AudioErrorType & | audio_error_type
 | ) |

AudioStoppedMsg::~AudioStoppedMsg ( ) [virtual]

Member Function Documentation

Message * AudioStoppedMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioStoppedMsg::GetActiveReference ( ) const [inline]

const AudioDeviceBase::AudioErrorType& AudioStoppedMsg::GetAudioErrorType ( ) const [inline]

const MsgMetaData & AudioStoppedMsg::GetMetaData ( ) const [virtual]

Implements Message.

const AudioDeviceBase::StopCause& AudioStoppedMsg::GetStopCause ( ) const [inline]

BOOLEAN AudioStoppedMsg::IsAutoStopped ( ) const [inline]

void AudioStoppedMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

void AudioStoppedMsg::SetAudioErrorType ( const AudioDeviceBase::AudioErrorType & audio_error_type ) [inline]

void AudioStoppedMsg::SetAutoStopped ( BOOLEAN auto_stopped ) [inline]

void AudioStoppedMsg::SetStopCause ( const AudioDeviceBase::StopCause & stop_cause ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioStoppedMsg.hpp
  • Audio/Messages/AudioStoppedMsg.cpp
Generated on Wed Jan 25 00:57:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioStreamingSyncMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioStreamingSyncMsg Class Reference

#include <Apoxi/Audio/Messages/AudioStreamingSyncMsg.hpp>

Inheritance diagram for AudioStreamingSyncMsg:

[legend]
Collaboration diagram for AudioStreamingSyncMsg:

[legend]

Public Types

enum | { ID = 9008 }

Public Member Functions

AudioStreamingSyncMsg ()
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~AudioStreamingSyncMsg ()

Detailed Description

This message will be emitted after the first buffer is passed to DSP to be played when running in streaming mode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioStreamingSyncMsg::AudioStreamingSyncMsg ( )

AudioStreamingSyncMsg::~AudioStreamingSyncMsg ( ) [virtual]

Member Function Documentation

Message * AudioStreamingSyncMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & AudioStreamingSyncMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioStreamingSyncMsg.hpp
  • Audio/Messages/AudioStreamingSyncMsg.cpp
Generated on Wed Jan 25 00:57:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioSuspendedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioSuspendedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioSuspendedMsg.hpp>

Inheritance diagram for AudioSuspendedMsg:

[legend]
Collaboration diagram for AudioSuspendedMsg:

[legend]

Public Types

enum | { ID = 9003 }

Public Member Functions

AudioSuspendedMsg (const SharedPtr< AudioActiveReference > &active_reference)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
virtual | ~AudioSuspendedMsg ()

Detailed Description

This message will be sent when sound is suspended by the audio priority manager

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioSuspendedMsg::AudioSuspendedMsg ( const SharedPtr< AudioActiveReference > & active_reference )

AudioSuspendedMsg::~AudioSuspendedMsg ( ) [virtual]

Member Function Documentation

Message * AudioSuspendedMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioSuspendedMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioSuspendedMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioSuspendedMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioSuspendedMsg.hpp
  • Audio/Messages/AudioSuspendedMsg.cpp
Generated on Wed Jan 25 00:57:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioTone Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioTone Class Reference

#include <Apoxi/Apc/AudioTypes.hpp>

Public Member Functions

AudioTone (const SdlByte sdl_tone_type, const T_DURATION &sdl_duration)
AudioTone (const AudioToneType tone_type, const INT duration)
AudioTone ()
AudioPreset::AudioPresetSoundToneId | GetAudioDeviceToneId () const
const SharedPtr< PresetAudioReference > | GetAudioDeviceToneRef () const
returns the reference to a audio file
INT32 | GetDuration () const
returns tone duration in milliseconds
AudioToneType | GetToneType () const
returns the type of the tone (GSM 02.40)

Constructor & Destructor Documentation

AudioTone::AudioTone ( )

AudioTone::AudioTone | ( | const AudioToneType | tone_type,
 |  | const INT | duration
 | ) |

AudioTone::AudioTone | ( | const SdlByte | sdl_tone_type,
 |  | const T_DURATION & | sdl_duration
 | ) |

Member Function Documentation

AudioPreset::AudioPresetSoundToneId AudioTone::GetAudioDeviceToneId ( ) const

const SharedPtr< PresetAudioReference > AudioTone::GetAudioDeviceToneRef ( ) const

returns the reference to a audio file

INT32 AudioTone::GetDuration ( ) const [inline]

returns tone duration in milliseconds

AudioToneType AudioTone::GetToneType ( ) const [inline]

returns the type of the tone (GSM 02.40)

The documentation for this class was generated from the following files:
  • Apc/AudioTypes.hpp
  • Apc/AudioTypes.cpp
Generated on Wed Jan 25 00:57:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioToneDuration Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioToneDuration Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 | interval
UINT8 | units

Field Documentation

UINT8 AudioToneDuration::interval

UINT8 AudioToneDuration::units

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 00:57:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioUserDefinedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioUserDefinedMsg Class Reference

#include <Apoxi/Audio/Messages/AudioMessages.hpp>

Inheritance diagram for AudioUserDefinedMsg:

[legend]
Collaboration diagram for AudioUserDefinedMsg:

[legend]

Public Types

enum | { ID = 9012 }

Public Member Functions

AudioUserDefinedMsg (UINT8 messageID, UINT16 senderID, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4)
virtual Message * | Clone () const
UINT8 | GetMessageID () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetParam1 () const
UINT32 | GetParam2 () const
UINT32 | GetParam3 () const
UINT32 | GetParam4 () const
UINT16 | GetSenderID () const
void | SetMessageID (UINT8 messageID)
void | SetParam1 (UINT32 param1)
void | SetParam2 (UINT32 param2)
void | SetParam3 (UINT32 param3)
void | SetParam4 (UINT32 param4)
void | SetSenderID (UINT16 senderID)
virtual | ~AudioUserDefinedMsg ()

Detailed Description

This message is defined to be used by the applications to exchange any user defined audio events.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioUserDefinedMsg::AudioUserDefinedMsg | ( | UINT8 | messageID,
 |  | UINT16 | senderID,
 |  | UINT32 | param1,
 |  | UINT32 | param2,
 |  | UINT32 | param3,
 |  | UINT32 | param4
 | ) |

AudioUserDefinedMsg::~AudioUserDefinedMsg ( ) [virtual]

Member Function Documentation

Message * AudioUserDefinedMsg::Clone ( ) const [virtual]

Implements Message.

UINT8 AudioUserDefinedMsg::GetMessageID ( ) const [inline]

const MsgMetaData & AudioUserDefinedMsg::GetMetaData ( ) const [virtual]

Implements Message.

UINT32 AudioUserDefinedMsg::GetParam1 ( ) const [inline]

UINT32 AudioUserDefinedMsg::GetParam2 ( ) const [inline]

UINT32 AudioUserDefinedMsg::GetParam3 ( ) const [inline]

UINT32 AudioUserDefinedMsg::GetParam4 ( ) const [inline]

UINT16 AudioUserDefinedMsg::GetSenderID ( ) const [inline]

void AudioUserDefinedMsg::SetMessageID ( UINT8 messageID ) [inline]

void AudioUserDefinedMsg::SetParam1 ( UINT32 param1 ) [inline]

void AudioUserDefinedMsg::SetParam2 ( UINT32 param2 ) [inline]

void AudioUserDefinedMsg::SetParam3 ( UINT32 param3 ) [inline]

void AudioUserDefinedMsg::SetParam4 ( UINT32 param4 ) [inline]

void AudioUserDefinedMsg::SetSenderID ( UINT16 senderID ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioMessages.hpp
  • Audio/Messages/AudioMessages.cpp
Generated on Wed Jan 25 00:57:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioUtility Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioUtility Class Reference
[Audio]

#include <Apoxi/Audio/AudioUtility.hpp>

Public Types

enum AudioDataType {
AudioDataTypeMidi = 0, AudioDataTypeMp3, AudioDataTypeSmaf, AudioDataTypeSmafPhrase,
AudioDataTypeImelody, AudioDataTypeUnknown
}
File formats, defined by enum. More...

Public Member Functions

virtual | ~AudioUtility ()=0

Static Public Member Functions

static UINT32 | CalculatePlayTime (BinData *bin_data, MimeType mime_type)
static BOOLEAN | FindAudioDataOffset (const UINT8 *buffer, const UINT32 bufferSize, const AudioDataType audioDataType, UINT32 &offset)
static BOOLEAN | FindAudioDataOffset (const Path &path, const AudioDataType audioDataType, UINT32 &offset)
static UINT16 | GetCallVolume (const UINT16 &volume)
static BOOLEAN | GetNumbersOfFrames (const UINT8 *buffer, const UINT32 bufferSize, const AudioDataType audioDataType, const UINT32 offset, UINT32 &numberOfFrames)
static BOOLEAN | GetNumbersOfFrames (const Path &path, const AudioDataType audioDataType, const UINT32 offset, UINT32 &numberOfFrames)
static UINT32 | GetUint32FromUint8Array (const UINT8 *data)
static BOOLEAN | ValidateAudioData (const Path &path, const AudioDataType audioDataType)
static BOOLEAN | ValidateAudioData (const UINT8 *buffer, const AudioDataType audioDataType)

Detailed Description

Audio utility class.

Member Enumeration Documentation

enum AudioUtility::AudioDataType

File formats, defined by enum.

Enumerator:
AudioDataTypeMidi | Midi file format tag.
AudioDataTypeMp3 | Mp3 file format tag.
AudioDataTypeSmaf | Smaf file format tag.
AudioDataTypeSmafPhrase | Smaf/Phrase file format tag.
AudioDataTypeImelody | IMelody file format tag.
AudioDataTypeUnknown | Unknown file format tag.

Constructor & Destructor Documentation

AudioUtility::~AudioUtility ( ) [pure virtual]

AudioUtility destructor - virtual;

Member Function Documentation

UINT32 AudioUtility::CalculatePlayTime | ( | BinData * | bin_data,
 |  | MimeType | mime_type
 | ) | [static]

Calculates the playtime of audio data

Parameters:
bin_data | Audio data
mime_type | Mime type of the audio data
Returns:
UINT32 Playtime in milliseconds, 0 if unsuccessfull
Note:
Curently it supports AMR and WAVE formats

BOOLEAN AudioUtility::FindAudioDataOffset | ( | const UINT8 * | buffer,
 |  | const UINT32 | bufferSize,
 |  | const AudioDataType | audioDataType,
 |  | UINT32 & | offset
 | ) | [static]

Finds an offset for the given audio data type, i.e. beginning of the first frame.

Parameters:
buffer | The pointer to the input data.
bufferSize | The size of the input buffer.
audioDataType | The audio data type.
offset | Offset, relative to the input buffer, the result, number of bytes.
Returns:
BOOLEAN True on success, zero otherwise.

BOOLEAN AudioUtility::FindAudioDataOffset | ( | const Path & | path,
 |  | const AudioDataType | audioDataType,
 |  | UINT32 & | offset
 | ) | [static]

Finds an offset for the given audio data type, i.e. beginning of the first frame.

Parameters:
path | The path of the file that should be checked.
audioDataType | The audio data type.
offset | Offset, relative to the input buffer, the result, number of bytes.
Returns:
BOOLEAN True on success, zero otherwise.

UINT16 AudioUtility::GetCallVolume ( const UINT16 & volume ) [static]

Check if there is an ongoing call and adjust the volume

Parameters:
volume | Volume intensity
volumeMin | Min Volume intensity
volumeMax | Max Volume intensity
Returns:
UINT16 The volume to be used during an active call.
Note:
If speech channel is open, the volume level will be limited as follows: The value for the volume will be calculated as the percentage of the speech volume. If the given volume is less than the calculated volume the same volume that was passed in the parameter will be returned, otherwise the calculated value. If speech channel is closed the same value that was passed in the parameter will be returned.

BOOLEAN AudioUtility::GetNumbersOfFrames | ( | const UINT8 * | buffer,
 |  | const UINT32 | bufferSize,
 |  | const AudioDataType | audioDataType,
 |  | const UINT32 | offset,
 |  | UINT32 & | numberOfFrames
 | ) | [static]

Finds the number of frames for the given audio record.

Parameters:
buffer | Input record buffer that should be scaned.
buffer_size | The size of the input record, i.e. buffer.
audioDataType | The audio data type.
offset | Offset, relative to the input record, number of bytes.
numberOfFrames | Result value, number of frames.
Returns:
BOOLEAN True on success, zero otherwise.

BOOLEAN AudioUtility::GetNumbersOfFrames | ( | const Path & | path,
 |  | const AudioDataType | audioDataType,
 |  | const UINT32 | offset,
 |  | UINT32 & | numberOfFrames
 | ) | [static]

Finds the number of frames for the given audio record.

Parameters:
path | The path of the file that should be checked.
audioDataType | The audio data type.
offset | Offset, relative to the input record, number of bytes.
numberOfFrames | Result value, number of frames.
Returns:
BOOLEAN True on success, zero otherwise.

UINT32 AudioUtility::GetUint32FromUint8Array ( const UINT8 * data ) [static]

BOOLEAN AudioUtility::ValidateAudioData | ( | const Path & | path,
 |  | const AudioDataType | audioDataType
 | ) | [static]

Checks the input file format.

Parameters:
path | The path of the file that should be checked.
fileType | The audio data that should be checked. If AudioDataTypeUnknown is given, type will be extracted from MIME type of the file.
Returns:
BOOLEAN FALSE if the header data is corrupted.
Note:
This function currently checks only the header data for following audio file formats: MIDI, SMAF, SMAF Phrase and IMelody. It returns false only if header data is corrupted. For any other sound format function allways returns TRUE.

BOOLEAN AudioUtility::ValidateAudioData | ( | const UINT8 * | buffer,
 |  | const AudioDataType | audioDataType
 | ) | [static]

Checks the format of the sound in the buffer.

Parameters:
buffer | The pointer to the buffer that should be checked.
fileType | The audio data type that should be checked.
Returns:
BOOLEAN FALSE if the header data is corrupted.
Note:
This function currently checks only the header data for following audio formats: MIDI, SMAF, SMAF Phrase and IMelody. It returns FALSE only if header data is corrupted. For any other sound format function allways returns TRUE.

The documentation for this class was generated from the following files:
  • Audio/AudioUtility.hpp
  • Audio/AudioUtility.cpp
Generated on Wed Jan 25 00:57:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioVibratorDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioVibratorDevice Class Reference
[Audio]

#include <Apoxi/Audio/AudioVibratorDevice.hpp>

Inheritance diagram for AudioVibratorDevice:

[legend]
Collaboration diagram for AudioVibratorDevice:

[legend]

Public Types

enum | VibratorMode { VibratorModeAsync1, VibratorModeAsync2, VibratorModeSync1, VibratorModeSync2 }

Public Member Functions

virtual AudioSourceType | GetSource () const
BOOLEAN | IsVibratorOn ()
virtual BOOLEAN | Play_Allocate (AudioActiveReference &active_reference)
BOOLEAN | StartVibrator (VibratorMode mode=VibratorModeAsync2, INT16 on=-1, INT16 off=0)
void | StopVibrator ()

Protected Types

typedef INT8 | AudReturnCode

Protected Member Functions

virtual UINT16 | GetDeviceID () const
Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).

Protected Attributes

SharedPtr< AudioActiveReference > m_active_ref

Member Typedef Documentation

typedef INT8 AudioVibratorDevice::AudReturnCode [protected]

Member Enumeration Documentation

enum AudioVibratorDevice::VibratorMode

Operating mode of vibrator. Tells which mode the vibrator should be working in. At present only VibratorModeAsync2 mode is implemented by DWD.

Enumerator:
VibratorModeAsync1 | Not implemented yet.
VibratorModeAsync2 The vibrator is controlled asynchronously with the ringer.
The vibrator is on and off for fixed periods of time.
VibratorModeSync1 | Not implemented yet.
VibratorModeSync2 | Not implemented yet.

Member Function Documentation

UINT16 AudioVibratorDevice::GetDeviceID ( ) const [protected, virtual]

Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).

Implements AudioDeviceBase.

AudioDeviceBase::AudioSourceType AudioVibratorDevice::GetSource ( ) const [virtual]

BOOLEAN AudioVibratorDevice::IsVibratorOn ( )

Returns:
status of Vibrator (on or off).

BOOLEAN AudioVibratorDevice::Play_Allocate ( AudioActiveReference & active_reference ) [virtual]

Implements DwdDevice.

BOOLEAN AudioVibratorDevice::StartVibrator | ( | VibratorMode | mode = VibratorModeAsync2,
 |  | INT16 | on = -1,
 |  | INT16 | off = 0
 | ) |

Start the Vibrator, also known as the Trembler. If the device is getting an invalid time for on or off the function chooses the nearest legal value.

Parameters:
mode | Mode the vibrator is working
on | On time of the vibrator in ms. Currently supported: 400, 600, 800, 1000ms
off | Off time of the vibrator in ms. Currently supported: 200, 300, 400, 600ms
Returns:
TRUE if successful

void AudioVibratorDevice::StopVibrator ( )

Stop the Vibrator, also known as the Trembler.

Returns:
TRUE is successful

Field Documentation

SharedPtr<AudioActiveReference> AudioVibratorDevice::m_active_ref [protected]

The documentation for this class was generated from the following files:
  • Audio/AudioVibratorDevice.hpp
  • Audio/AudioVibratorDevice.cpp
Generated on Wed Jan 25 00:57:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AudioVoiceMemoOutOfSpaceMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AudioVoiceMemoOutOfSpaceMsg Class Reference

#include <Apoxi/Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp>

Inheritance diagram for AudioVoiceMemoOutOfSpaceMsg:

[legend]
Collaboration diagram for AudioVoiceMemoOutOfSpaceMsg:

[legend]

Public Types

enum | { ID = 9002 }

Public Member Functions

AudioVoiceMemoOutOfSpaceMsg (const SharedPtr< AudioActiveReference > &active_reference)
virtual Message * | Clone () const
const SharedPtr< AudioActiveReference > & | GetActiveReference () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveReference (const SharedPtr< AudioActiveReference > &active_reference)
virtual | ~AudioVoiceMemoOutOfSpaceMsg ()

Detailed Description

This message will be emitted when a voice memo is being recorded and either the end of the RAM buffer has been reached, or the Flash File System is full.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AudioVoiceMemoOutOfSpaceMsg::AudioVoiceMemoOutOfSpaceMsg ( const SharedPtr< AudioActiveReference > & active_reference )

AudioVoiceMemoOutOfSpaceMsg::~AudioVoiceMemoOutOfSpaceMsg ( ) [virtual]

Member Function Documentation

Message * AudioVoiceMemoOutOfSpaceMsg::Clone ( ) const [virtual]

Implements Message.

const SharedPtr<AudioActiveReference>& AudioVoiceMemoOutOfSpaceMsg::GetActiveReference ( ) const [inline]

const MsgMetaData & AudioVoiceMemoOutOfSpaceMsg::GetMetaData ( ) const [virtual]

Implements Message.

void AudioVoiceMemoOutOfSpaceMsg::SetActiveReference ( const SharedPtr< AudioActiveReference > & active_reference ) [inline]

The documentation for this class was generated from the following files:
  • Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.hpp
  • Audio/Messages/AudioVoiceMemoOutOfSpaceMsg.cpp
Generated on Wed Jan 25 00:57:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AuthProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AuthProvider Class Reference
[SERVER]

#include <Apoxi/AddOns/Server/AuthProvider.hpp>

Inheritance diagram for AuthProvider:

[legend]

Public Member Functions

virtual BOOLEAN | AuthorizeUser (const String &username)=0
virtual BOOLEAN | AuthorizeUserPassword (const String &username, const String &password)=0
AuthProvider ()
virtual BOOLEAN | IsAccessGranted (const String &username, const Path &path)=0
virtual | ~AuthProvider ()

Constructor & Destructor Documentation

AuthProvider::AuthProvider ( )

Constructor. Initializes all member variables with the default values.

AuthProvider::~AuthProvider ( ) [virtual]

Destructor. Deallocates used resources.

Member Function Documentation

virtual BOOLEAN AuthProvider::AuthorizeUser ( const String & username ) [pure virtual]

Method for authorizing a certain user. Must be implemented in derived classes.

Parameters:
username Name of a certain user to authorize.

Implemented in FtpAuthProvider, and HttpAuthProvider.

virtual BOOLEAN AuthProvider::AuthorizeUserPassword | ( | const String & | username,
 |  | const String & | password
 | ) | [pure virtual]

Method for authorizing a certain user with a certain password. Must be implemented in derived classes.

Parameters:
username | Name of a certain user to authorize.
password | Password for a certain user account.

Implemented in FtpAuthProvider, and HttpAuthProvider.

virtual BOOLEAN AuthProvider::IsAccessGranted | ( | const String & | username,
 |  | const Path & | path
 | ) | [pure virtual]

Returns whether a certain user is allowed to access the specified path.

Parameters:
username | Name of a certain user to authorize.
pathname | Path name to check.

Implemented in FtpAuthProvider, and HttpAuthProvider.

The documentation for this class was generated from the following files:
  • AddOns/Server/AuthProvider.hpp
  • AddOns/Server/AuthProvider.cpp
Generated on Wed Jan 25 00:57:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AutoCallRestrictIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AutoCallRestrictIndArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for AutoCallRestrictIndArg:

[legend]
Collaboration diagram for AutoCallRestrictIndArg:

[legend]

Public Types

enum | { ID = 1147 }

Public Member Functions

AutoCallRestrictIndArg ()
BOOLEAN | IsRestricted () const
void | SetRestricted (BOOLEAN restricted)

Static Public Member Functions

static const AutoCallRestrictIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

AutoCallRestrictIndArg: reflects the signal MNMI_AUTO_CALL_RESTRICT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

AutoCallRestrictIndArg::AutoCallRestrictIndArg ( )

Member Function Documentation

const AutoCallRestrictIndArg & AutoCallRestrictIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN AutoCallRestrictIndArg::IsRestricted ( ) const [inline]

void AutoCallRestrictIndArg::SetRestricted ( BOOLEAN restricted ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 00:57:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AuxProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

AuxProvider Class Reference
[Provider]

#include <Apoxi/Adc/AuxProvider.hpp>

Inheritance diagram for AuxProvider:

[legend]
Collaboration diagram for AuxProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

AuxProvider ()
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *aux_handler, Protector *protector)
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~AuxProvider ()

Detailed Description

AuxProvider is the provider to retrieve different kind of data from the mobile station. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_aux_provider_id

Following column ids are defined: c_imsi_id :WStringType: IMSI as a string. c_imei_id :WStringType: IMEI as a string. c_mcc_id :NumberType: mobile country code contained in the imsi. c_mnc_id :NumberType: mobile network code contained in the imsi. c_mnc_threedigits_id :NumberType: cast to BOOLEAN, tells if MNC has three digits. c_sim_ind_id :NumberType: sim indication state, cast to SimIndicator. c_icc_id :WStringType: ICCID as a string. c_sim_ind_id :NumberType: c_sim_type_id :NumberType: type of the sim, cast to SimType. c_sim_phase_id :NumberType: value of the sim phase as defined in GSM 11.11 c_lang_pref_id :NumberType: prefered language, mandatory language in as defined GSM 11.11 V8.2.0 10.3.1 c_fdn_state_id :NumberType: cast to SimInitResult (FDN State) c_spn_id :WStringType: service provider name as defined in GSM 11.11 V8.2.0 10.3.11 c_spn_display_condition_id :NumberType: display condition of the spn as defined in GSM 11.11 V8.2.0 10.3.11, cast to BOOLEAN c_acm_id :NumberType: acm value c_acm2_id :NumberType: acm value for line2 c_acmmax_id :NumberType: acm maximum value as defined in GSM 11.11 V8.2.0 10.3.6 c_currency_code_id :WStringType: currency code as a wstring, defined in GSM 11.11 V8.2.0 10.3.12 c_currency_exp_id :NumberType: currency exponent, defined in GSM 11.11 V8.2.0 10.3.12 c_currency_eppu_id :NumberType: elementary price per unit, defined in GSM 11.11 V8.2.0 10.3.12 c_network_lockstate_id :NumberType: network lockstate, cast to LockStatus. c_sp_lockstate_id :NumberType: service provider lockstate, cast to LockStatus. c_sim_lockstate_id :NumberType: sim lockstate, cast to LockStatus. c_corporate_lockstate_id :NumberType: network lockstate, cast to LockStatus. c_sim_errorcode_id :NumberType: c_loci_update_status_id :NumberType: cast to LocationUpdateStatus enum. c_loci_mcc_id :NumberType: MCC of the LOCI file. c_loci_mnc_id :NumberType: MNC of the LOCI file. c_loci_mnc_threedigits_id :NumberType: cast to BOOLEAN, tells if LOCI-MNC has three digits. c_loci_lac_id :NumberType: LAI of the LOCI file. c_acm_chv_id :NumberType: cast to ChvNo c_acmmax_chv_id :NumberType: cast to ChvNo c_puct_chv_id :NumberType: cast to ChvNo c_ofm_to_be_activated_id :NumberType: cast to BOOLEAN, TRUE if b1=1 of EF-AD Byte 3, regarding GSM 11.11,10.3.18

This provider only consists of one fixed row.

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider AuxProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

AuxProvider::AuxProvider ( )

AuxProvider::~AuxProvider ( ) [virtual]

Member Function Documentation

BOOLEAN AuxProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN AuxProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT AuxProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void AuxProvider::Init | ( | SimAuxHandler * | aux_handler,
 |  | Protector * | protector
 | ) |

INT AuxProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN AuxProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN AuxProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/AuxProvider.hpp
  • Adc/AuxProvider.cpp
Generated on Wed Jan 25 00:57:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BackLight Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BackLight Class Reference

Back light device. More...

#include <Apoxi/Devices/MPE/BackLight.hpp>

Inheritance diagram for BackLight:

[legend]
Collaboration diagram for BackLight:

[legend]

Public Types

enum | BackLightMode { BackLightOn, BackLightOff }
enum | BackLightMode { BackLightOn, BackLightOff }
enum | BackLightMode { BackLightOn, BackLightOff }

Public Member Functions

virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const

Static Public Member Functions

static void | CleanUp ()
static void | CleanUp ()
static void | CleanUp ()
static BOOLEAN | GetStatus ()
static BOOLEAN | GetStatus ()
static BOOLEAN | GetStatus ()
static void | Init ()
Init.
static void | Init ()
Init.
static void | Init ()
Init.
static void | Switch (BackLightMode mode)
static void | Switch (BackLightMode mode)
static void | Switch (BackLightMode mode)

Detailed Description

Back light device.

Member Enumeration Documentation

enum BackLight::BackLightMode

Enumerator:
BackLightOn
BackLightOff

enum BackLight::BackLightMode

Enumerator:
BackLightOn
BackLightOff

enum BackLight::BackLightMode

Enumerator:
BackLightOn
BackLightOff

Member Function Documentation

static void BackLight::CleanUp ( ) [inline, static]

static void BackLight::CleanUp ( ) [inline, static]

static void BackLight::CleanUp ( ) [inline, static]

virtual const WCHAR* BackLight::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

virtual const WCHAR* BackLight::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

const WCHAR * BackLight::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

static BOOLEAN BackLight::GetStatus ( ) [static]

static BOOLEAN BackLight::GetStatus ( ) [static]

BOOLEAN BackLight::GetStatus ( ) [static]

static void BackLight::Init ( ) [static]

Init.

static void BackLight::Init ( ) [static]

Init.

void BackLight::Init ( ) [static]

Init.

static void BackLight::Switch ( BackLightMode mode ) [static]

static void BackLight::Switch ( BackLightMode mode ) [static]

void BackLight::Switch ( BackLightMode mode ) [static]

The documentation for this class was generated from the following files:
  • Devices/MPE/BackLight.hpp
  • Devices/MPEU/BackLight.hpp
  • Devices/SGold/BackLight.hpp
  • Devices/MPE/BackLight.cpp
  • Devices/MPEU/BackLight.cpp
  • Devices/SGold/BackLight.cpp
Generated on Wed Jan 25 00:57:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BackToIdleFeature Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BackToIdleFeature Class Reference
[APOXI Template Layer]

Platform feature "BackToIdleScreen". More...

#include <Apoxi/Atl/Features/BackToIdleFeature.hpp>

Inheritance diagram for BackToIdleFeature:

[legend]
Collaboration diagram for BackToIdleFeature:

[legend]

Public Types

enum | { ID = 106 }

Public Member Functions

BackToIdleFeature ()
virtual BOOLEAN | Execute ()
Posts a CloseAllMsg, in order to close all windows except IdleScreen.
virtual INT | GetID () const
void | Init ()
virtual BOOLEAN | IsEqual (const Feature &feature) const
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual | ~BackToIdleFeature ()

Detailed Description

Platform feature "BackToIdleScreen".

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Feature.

Constructor & Destructor Documentation

BackToIdleFeature::BackToIdleFeature ( )

BackToIdleFeature::~BackToIdleFeature ( ) [virtual]

Member Function Documentation

BOOLEAN BackToIdleFeature::Execute ( ) [virtual]

Posts a CloseAllMsg, in order to close all windows except IdleScreen.

Reimplemented from Feature.

INT BackToIdleFeature::GetID ( ) const [virtual]

Reimplemented from Feature.

void BackToIdleFeature::Init ( )

BOOLEAN BackToIdleFeature::IsEqual ( const Feature & feature ) const [virtual]

Reimplemented from Feature.

BOOLEAN BackToIdleFeature::IsInstanceOf ( INT id ) const [virtual]

See also:
Item

Reimplemented from Feature.

The documentation for this class was generated from the following files:
  • Atl/Features/BackToIdleFeature.hpp
  • Atl/Features/BackToIdleFeature.cpp
Generated on Wed Jan 25 00:57:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BackupFileHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BackupFileHandler Class Reference
[Afs]

RegBackUp FileHandler. More...

#include <Apoxi/Afs/BackupFileHandler.hpp>

Static Public Member Functions

static BOOLEAN | CreateBackupFile (INT16 org_file_id, INT16 &backup_fileid, INT16 transaction_id)
static BOOLEAN | DeleteBackupFile (INT16 backup_file_id)
static BOOLEAN | RollBackTransaction (INT16 transaction_id)

Detailed Description

RegBackUp FileHandler.

 -----------------------------------------------------------------
                    REGISTRY BACKUP NODE FILE
  ----------------------------------------------------------------

  +-------------------------------------------------------------------+
  | 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8|
  +----------+---+-+----------------+----------------+----------------+
  |     Version    |    File Type   |         Node Count (n)          |
  +----------------+----------------+---------------------------------+
  |          Original File Id         |                                 |
  +----------+---+------------------+---------------------------------+
  |                           Transaction Id                          |
  +-------------------------------------------------------------------+
  |                                                                   |
  |                       Registry  Node File                         |
  |                                                                   |
  +-------------------------------------------------------------------+

Member Function Documentation

BOOLEAN BackupFileHandler::CreateBackupFile | ( | INT16 | org_file_id,
 |  | INT16 & | backup_fileid,
 |  | INT16 | transaction_id
 | ) | [static]

BOOLEAN BackupFileHandler::DeleteBackupFile ( INT16 backup_file_id ) [static]

BOOLEAN BackupFileHandler::RollBackTransaction ( INT16 transaction_id ) [static]

The documentation for this class was generated from the following files:
  • Afs/BackupFileHandler.hpp
  • Afs/BackupFileHandler.cpp
Generated on Wed Jan 25 00:57:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BandSelectionIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BandSelectionIndArg Class Reference

#include <Apoxi/Apc/NetworkStackMsgArgs.hpp>

Inheritance diagram for BandSelectionIndArg:

[legend]
Collaboration diagram for BandSelectionIndArg:

[legend]

Public Types

enum | { ID = 2184 }

Public Member Functions

BandSelectionIndArg ()
BOOLEAN | IsConfirmed () const
void | SetConfirmed (BOOLEAN confirmed)

Static Public Member Functions

static const BandSelectionIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BandSelectionIndArg: indicates whether OM_BAND_CNF and OM_BAND_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BandSelectionIndArg::BandSelectionIndArg ( )

Member Function Documentation

const BandSelectionIndArg & BandSelectionIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN BandSelectionIndArg::IsConfirmed ( ) const [inline]

void BandSelectionIndArg::SetConfirmed ( BOOLEAN confirmed ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/NetworkStackMsgArgs.hpp
  • Apc/NetworkStackMsgArgs.cpp
Generated on Wed Jan 25 00:57:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BandSelectionMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BandSelectionMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for BandSelectionMsg:

[legend]
Collaboration diagram for BandSelectionMsg:

[legend]

Public Types

enum | { ID = 18604 }

Public Member Functions

BandSelectionMsg (ExecutionContext *context, BOOLEAN confirmed)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsConfirmed () const
void | SetConfirmed (BOOLEAN confirmed)
virtual | ~BandSelectionMsg ()

Detailed Description

BandSelectionMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BandSelectionMsg::BandSelectionMsg | ( | ExecutionContext * | context,
 |  | BOOLEAN | confirmed
 | ) |

BandSelectionMsg::~BandSelectionMsg ( ) [virtual]

Member Function Documentation

Message * BandSelectionMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & BandSelectionMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BOOLEAN BandSelectionMsg::IsConfirmed ( ) const [inline]

void BandSelectionMsg::SetConfirmed ( BOOLEAN confirmed ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 00:57:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BandSelectionReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BandSelectionReqArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for BandSelectionReqArg:

[legend]
Collaboration diagram for BandSelectionReqArg:

[legend]

Public Types

enum | { ID = 2105 }

Public Member Functions

BandSelectionReqArg ()
BandSelectionReqArg (const GsmBandList &gsm_band_list)
const GsmBandList & | GetGsmBandList () const
void | SetGsmBandList (const GsmBandList &gsm_band_list)

Static Public Member Functions

static const BandSelectionReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BandSelectionReqArg: reflects arguments of signal OM_BAND_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BandSelectionReqArg::BandSelectionReqArg ( const GsmBandList & gsm_band_list )

BandSelectionReqArg::BandSelectionReqArg ( )

Member Function Documentation

const BandSelectionReqArg & BandSelectionReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GsmBandList& BandSelectionReqArg::GetGsmBandList ( ) const [inline]

void BandSelectionReqArg::SetGsmBandList ( const GsmBandList & gsm_band_list ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 00:57:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BandStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BandStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for BandStatusMsg:

[legend]
Collaboration diagram for BandStatusMsg:

[legend]

Public Types

enum | { ID = 18610 }

Public Member Functions

BandStatusMsg (ExecutionContext *context, const GsmBandList &supported_band_list, const GsmBandList &used_band_list)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const GsmBandList & | GetSupportedBandList () const
const GsmBandList & | GetUsedBandList () const
void | SetSupportedBandList (const GsmBandList &supported_band_list)
void | SetUsedBandList (const GsmBandList &used_band_list)
virtual | ~BandStatusMsg ()

Detailed Description

BandStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BandStatusMsg::BandStatusMsg | ( | ExecutionContext * | context,
 |  | const GsmBandList & | supported_band_list,
 |  | const GsmBandList & | used_band_list
 | ) |

BandStatusMsg::~BandStatusMsg ( ) [virtual]

Member Function Documentation

Message * BandStatusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & BandStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const GsmBandList& BandStatusMsg::GetSupportedBandList ( ) const [inline]

const GsmBandList& BandStatusMsg::GetUsedBandList ( ) const [inline]

void BandStatusMsg::SetSupportedBandList ( const GsmBandList & supported_band_list ) [inline]

void BandStatusMsg::SetUsedBandList ( const GsmBandList & used_band_list ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 00:57:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BarringInfoReceivedArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BarringInfoReceivedArg Struct Reference
[APOXI Stack Control]

Contains data of the indication of received CallBarringInfo. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for BarringInfoReceivedArg:

[legend]

Data Fields

CallBarringInfo barring_info
This type is used to pass information, received in a CallBarringInfo type, to MI.
SsOperationCode operation_code
The respective call independent supplementary operation code.

Detailed Description

Contains data of the indication of received CallBarringInfo.

Field Documentation

CallBarringInfo BarringInfoReceivedArg::barring_info

This type is used to pass information, received in a CallBarringInfo type, to MI.

SsOperationCode BarringInfoReceivedArg::operation_code

The respective call independent supplementary operation code.

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 00:57:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BarringInfoReceivedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BarringInfoReceivedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for BarringInfoReceivedMsg:

[legend]
Collaboration diagram for BarringInfoReceivedMsg:

[legend]

Public Types

enum | { ID = 18501 }

Public Member Functions

BarringInfoReceivedMsg (ExecutionContext *context, const BarringInfoReceivedArg &arg)
virtual Message * | Clone () const
const BarringInfoReceivedArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const BarringInfoReceivedArg &arg)
virtual | ~BarringInfoReceivedMsg ()

Detailed Description

BarringInfoReceivedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BarringInfoReceivedMsg::BarringInfoReceivedMsg | ( | ExecutionContext * | context,
 |  | const BarringInfoReceivedArg & | arg
 | ) |

BarringInfoReceivedMsg::~BarringInfoReceivedMsg ( ) [virtual]

Member Function Documentation

Message * BarringInfoReceivedMsg::Clone ( ) const [virtual]

Implements Message.

const BarringInfoReceivedArg& BarringInfoReceivedMsg::GetArg ( ) const [inline]

const MsgMetaData & BarringInfoReceivedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void BarringInfoReceivedMsg::SetArg ( const BarringInfoReceivedArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 00:57:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BarringSsAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BarringSsAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for BarringSsAction:

[legend]
Collaboration diagram for BarringSsAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
BarringSsAction ()
virtual InputActionType | GetActionType () const
Returns the type of the action.
InputParser::BasicServiceMmiCode | GetBasicServiceMmiCode () const
Returns the basic service group.
const WString & | GetPassword () const
Returns the password.
InputParser::SsCode | GetSsCode () const
Returns the ss code.
InputParser::SsProcedure | GetSsProcedure () const
Returns the procedure type.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual | ~BarringSsAction ()

Detailed Description

BarringSsAction analyzes if the input string has the meaning of activation, deactivation or interrogation of Barring Services as defined in 3GPP TS 22.088. Execute has to be overwritten to implement the sending of the SS string.

Constructor & Destructor Documentation

BarringSsAction::BarringSsAction ( )

BarringSsAction::~BarringSsAction ( ) [virtual]

Member Function Documentation

InputAction * BarringSsAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType BarringSsAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

InputParser::BasicServiceMmiCode BarringSsAction::GetBasicServiceMmiCode ( ) const [inline]

Returns the basic service group.

const WString& BarringSsAction::GetPassword ( ) const [inline]

Returns the password.

InputParser::SsCode BarringSsAction::GetSsCode ( ) const [inline]

Returns the ss code.

InputParser::SsProcedure BarringSsAction::GetSsProcedure ( ) const [inline]

Returns the procedure type.

BOOLEAN BarringSsAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 00:57:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Base64Coder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Base64Coder Class Reference

#include <Apoxi/AddOns/AuxExtensions/MimeCoding.hpp>

Inheritance diagram for Base64Coder:

[legend]
Collaboration diagram for Base64Coder:

[legend]

Public Member Functions

Base64Coder (CHAR *buffer=0, INT buffer_length=0, BOOLEAN is_text=TRUE)
INT | DecodeEnd ()
BOOLEAN | DecodePush (CHAR data)
BOOLEAN | DecodePush6Bits (INT code)
INT | EncodeEnd ()
BOOLEAN | EncodePush (CHAR data)

Constructor & Destructor Documentation

Base64Coder::Base64Coder | ( | CHAR * | buffer = 0,
 |  | INT | buffer_length = 0,
 |  | BOOLEAN | is_text = TRUE
 | ) |

Member Function Documentation

INT Base64Coder::DecodeEnd ( )

BOOLEAN Base64Coder::DecodePush ( CHAR data )

BOOLEAN Base64Coder::DecodePush6Bits ( INT code )

INT Base64Coder::EncodeEnd ( )

BOOLEAN Base64Coder::EncodePush ( CHAR data )

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/MimeCoding.hpp
  • AddOns/AuxExtensions/MimeCoding.cpp
Generated on Wed Jan 25 00:57:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BaseDataHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BaseDataHandler Class Reference
[Middle Layer]

#include <Apoxi/Adc/BaseDataHandler.hpp>

Inheritance diagram for BaseDataHandler:

[legend]
Collaboration diagram for BaseDataHandler:

[legend]

Public Member Functions

BaseDataHandler ()
void | Init (SimAccessor *handler)
BOOLEAN | IsSimAccessAllowed () const
BOOLEAN | IsSimPresent () const
BOOLEAN | IsUsimInserted () const
virtual | ~BaseDataHandler ()

Protected Attributes

SimAccessor * m_sim_handler

Constructor & Destructor Documentation

BaseDataHandler::BaseDataHandler ( )

BaseDataHandler::~BaseDataHandler ( ) [virtual]

Member Function Documentation

void BaseDataHandler::Init ( SimAccessor * handler )

Reimplemented in SimPduHandler.

BOOLEAN BaseDataHandler::IsSimAccessAllowed ( ) const [inline]

Reimplemented in SimPbBaseHandler.

BOOLEAN BaseDataHandler::IsSimPresent ( ) const [inline]

BOOLEAN BaseDataHandler::IsUsimInserted ( ) const [inline]

Field Documentation

SimAccessor* BaseDataHandler::m_sim_handler [protected]

The documentation for this class was generated from the following files:
  • Adc/BaseDataHandler.hpp
  • Adc/BaseDataHandler.cpp
Generated on Wed Jan 25 00:57:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BaseInformationElement Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BaseInformationElement Class Reference

#include <Apoxi/Apc/BaseInformationElement.hpp>

Collaboration diagram for BaseInformationElement:

[legend]

Public Types

enum Type {
WStringIE, UserDataHeaderIE, MissingPduIE, EndOfPduIE,
Invalid
}

Public Member Functions

BaseInformationElement (UINT8 *buffer)
BaseInformationElement (const InformationElement &udhie)
BaseInformationElement (const WString &wstr)
BaseInformationElement (Type type)
BaseInformationElement (const BaseInformationElement &BaseInformationElement)
BaseInformationElement ()
const InformationElement & | GetInformationElement () const
Type | GetType () const
const WString & | GetWString () const
BOOLEAN | IsValid () const
BaseInformationElement & | operator= (const BaseInformationElement &item)
virtual | ~BaseInformationElement ()

Member Enumeration Documentation

enum BaseInformationElement::Type

Enumerator:
WStringIE | contains a unicode string
UserDataHeaderIE | contains a user data header information element
MissingPduIE | signs that a pdu is missing
EndOfPduIE | end of pdu is reached
Invalid | Invalid.

Constructor & Destructor Documentation

BaseInformationElement::BaseInformationElement ( )

BaseInformationElement::BaseInformationElement ( const BaseInformationElement & BaseInformationElement )

BaseInformationElement::BaseInformationElement ( Type type )

BaseInformationElement::BaseInformationElement ( const WString & wstr )

BaseInformationElement::BaseInformationElement ( const InformationElement & udhie )

BaseInformationElement::BaseInformationElement ( UINT8 * buffer )

BaseInformationElement::~BaseInformationElement ( ) [virtual]

Member Function Documentation

const InformationElement& BaseInformationElement::GetInformationElement ( ) const [inline]

Type BaseInformationElement::GetType ( ) const [inline]

const WString& BaseInformationElement::GetWString ( ) const [inline]

BOOLEAN BaseInformationElement::IsValid ( ) const [inline]

BaseInformationElement & BaseInformationElement::operator= ( const BaseInformationElement & item )

The documentation for this class was generated from the following files:
  • Apc/BaseInformationElement.hpp
  • Apc/BaseInformationElement.cpp
Generated on Wed Jan 25 00:57:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BasicPackConnector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BasicPackConnector Class Reference

#include <Apoxi/Gui/BasicPackConnector.hpp>

Collaboration diagram for BasicPackConnector:

[legend]

Static Public Member Functions

static BOOLEAN | ContainsDataPack (DataPackId datapack_id)
static const DataPack * | GetDataPack (DataPackId datapack_id)
static UINT16 | GetNumberOfEntries (DataPackId datapack_id)
static UINT32 | GetSizeOfDataPack (DataPackId datapack_id)
static void | Init ()

Protected Member Functions

BasicPackConnector ()
virtual | ~BasicPackConnector ()

Detailed Description

The BasicPackConnector class provides functionality for accessing the data packs of the customization pack.

Constructor & Destructor Documentation

BasicPackConnector::BasicPackConnector ( ) [protected]

Constructor for BasicPackConnector. Protected as the BasicPackConnector only contains static methods.

BasicPackConnector::~BasicPackConnector ( ) [protected, virtual]

Destructor for BasicPackConnector.

Member Function Documentation

BOOLEAN BasicPackConnector::ContainsDataPack ( DataPackId datapack_id ) [static]

Returns true if the customization pack contains a data pack with the id given in parameter id.

Parameters:
datapack_id id of the datapack that should be contained.
Returns:
returns true if the customization pack contains the datapack with the id given in datapack_id.

const DataPack * BasicPackConnector::GetDataPack ( DataPackId datapack_id ) [static]

Returns a DataPack with the id given in parameter id.

Parameters:
datapack_id id of the datapack that should be returned.
Returns:
returns a pointer to a DataPack with the given parameter.

UINT16 BasicPackConnector::GetNumberOfEntries ( DataPackId datapack_id ) [static]

Returns the number of entries of a data pack with the id given in parameter id.

Parameters:
datapack_id id of the datapack of which the entry count should be retrieved.
Returns:
the number of entries contained in the datapack with the datapack_id.

UINT32 BasicPackConnector::GetSizeOfDataPack ( DataPackId datapack_id ) [static]

Returns the size of the data pack with the id given in parameter id.

Parameters:
datapack_id id of the datapack of which the size should be retrieved.
Returns:
returns the size of the datapack with the id given in the parameter.

void BasicPackConnector::Init ( ) [static]

Reads the data of the customization pack from a file. TODO: Reimplement this method for the use with the target for dynamic address resolution. (NOV)

The documentation for this class was generated from the following files:
  • Gui/BasicPackConnector.hpp
  • Gui/BasicPackConnector.cpp
Generated on Wed Jan 25 00:57:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BasicPbWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BasicPbWin Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/BasicPbWin.hpp>

Inheritance diagram for BasicPbWin:

[legend]
Collaboration diagram for BasicPbWin:

[legend]

Public Types

typedef PhonebookWin | Base

Public Member Functions

BasicPbWin ()
void | Init (Provider *pb_provider=0, INT sort_colid=c_name_id, BOOLEAN read_only=FALSE)
virtual | ~BasicPbWin ()

Protected Member Functions

virtual PbDetails * | GetDetailWin ()

Member Typedef Documentation

typedef PhonebookWin BasicPbWin::Base

Reimplemented from PhonebookWin.

Constructor & Destructor Documentation

BasicPbWin::BasicPbWin ( )

BasicPbWin::~BasicPbWin ( ) [virtual]

Member Function Documentation

PbDetails * BasicPbWin::GetDetailWin ( ) [protected, virtual]

Implements PhonebookWin.

void BasicPbWin::Init | ( | Provider * | pb_provider = 0,
 |  | INT | sort_colid = c_name_id,
 |  | BOOLEAN | read_only = FALSE
 | ) |

Reimplemented from PhonebookWin.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/BasicPbWin.hpp
  • Applications/AdvPhonebook/BasicPbWin.cpp
Generated on Wed Jan 25 00:57:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BasicSmsService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BasicSmsService Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsService.hpp>

Collaboration diagram for BasicSmsService:

[legend]

Public Member Functions

BasicSmsService (AbstractSmsApp *implementing_app)
virtual ServiceResult | ComposeSms (const EditorDocumentObtainer &obtainer, const PhoneNumber *destination=0) const
virtual ServiceResult | ComposeSms (const PhoneNumber *destination=0) const
virtual ServiceResult | ComposeSms (const WString *text=0, const PhoneNumber *destination=0) const
virtual ServiceResult | SendSms (const EditorDocumentObtainer &obtainer, const PhoneNumber *destination=0) const
virtual ServiceResult | SendSms (const WString *text, const PhoneNumber *destination=0) const
virtual ServiceResult | StoreSms (const EditorDocumentObtainer &obtainer, const PhoneNumber *destination=0) const
virtual ServiceResult | StoreSms (const WString *text, const PhoneNumber *destination=0) const
virtual | ~BasicSmsService ()

Constructor & Destructor Documentation

BasicSmsService::BasicSmsService ( AbstractSmsApp * implementing_app )

BasicSmsService::~BasicSmsService ( ) [virtual]

Member Function Documentation

ServiceResult BasicSmsService::ComposeSms | ( | const EditorDocumentObtainer & | obtainer,
 |  | const PhoneNumber * | destination = 0
 | ) | const [virtual]

ServiceResult BasicSmsService::ComposeSms ( const PhoneNumber * destination = 0 ) const [virtual]

ServiceResult BasicSmsService::ComposeSms | ( | const WString * | text = 0,
 |  | const PhoneNumber * | destination = 0
 | ) | const [virtual]

ServiceResult BasicSmsService::SendSms | ( | const EditorDocumentObtainer & | obtainer,
 |  | const PhoneNumber * | destination = 0
 | ) | const [virtual]

ServiceResult BasicSmsService::SendSms | ( | const WString * | text,
 |  | const PhoneNumber * | destination = 0
 | ) | const [virtual]

ServiceResult BasicSmsService::StoreSms | ( | const EditorDocumentObtainer & | obtainer,
 |  | const PhoneNumber * | destination = 0
 | ) | const [virtual]

ServiceResult BasicSmsService::StoreSms | ( | const WString * | text,
 |  | const PhoneNumber * | destination = 0
 | ) | const [virtual]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsService.hpp
  • Applications/Ems/Sms/SmsService.cpp
Generated on Wed Jan 25 00:57:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BatteryLoadLevelMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BatteryLoadLevelMsg Class Reference

#include <Apoxi/Devices/ChargerMsgTypes.hpp>

Inheritance diagram for BatteryLoadLevelMsg:

[legend]
Collaboration diagram for BatteryLoadLevelMsg:

[legend]

Public Types

enum | { ID = 9151 }

Public Member Functions

BatteryLoadLevelMsg (const BatteryLoadLevel &arg)
virtual Message * | Clone () const
const BatteryLoadLevel & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const BatteryLoadLevel &arg)
virtual | ~BatteryLoadLevelMsg ()

Detailed Description

BatteryLoadLevelMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BatteryLoadLevelMsg::BatteryLoadLevelMsg ( const BatteryLoadLevel & arg )

BatteryLoadLevelMsg::~BatteryLoadLevelMsg ( ) [virtual]

Member Function Documentation

Message * BatteryLoadLevelMsg::Clone ( ) const [virtual]

Implements Message.

const BatteryLoadLevel& BatteryLoadLevelMsg::GetArg ( ) const [inline]

const MsgMetaData & BatteryLoadLevelMsg::GetMetaData ( ) const [virtual]

Implements Message.

void BatteryLoadLevelMsg::SetArg ( const BatteryLoadLevel & arg ) [inline]

The documentation for this class was generated from the following files:
  • Devices/ChargerMsgTypes.hpp
  • Devices/ChargerMsgTypes.cpp
Generated on Wed Jan 25 00:57:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BcdPlmn Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BcdPlmn Class Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

BcdPlmn (const T_PLMN &plmn)
BcdPlmn (const BcdPlmn &plmn)
BcdPlmn (BcdMcc _mcc, BcdMnc _mnc)
BcdPlmn ()
void | Init (BcdMcc _mcc, BcdMnc _mnc)
BOOLEAN | IsEqual (const BcdPlmn &plmn) const
BOOLEAN | IsInvalid () const
BcdPlmn | operator= (const T_PLMN &plmn)
BcdPlmn | operator= (const BcdPlmn &plmn)
void | SetInvalid ()

Data Fields

BcdMcc mcc
BcdMnc mnc

Constructor & Destructor Documentation

BcdPlmn::BcdPlmn ( ) [inline]

BcdPlmn::BcdPlmn | ( | BcdMcc | _mcc,
 |  | BcdMnc | _mnc
 | ) | [inline]

BcdPlmn::BcdPlmn ( const BcdPlmn & plmn ) [inline]

BcdPlmn::BcdPlmn ( const T_PLMN & plmn ) [inline]

Member Function Documentation

void BcdPlmn::Init | ( | BcdMcc | _mcc,
 |  | BcdMnc | _mnc
 | ) | [inline]

BOOLEAN BcdPlmn::IsEqual ( const BcdPlmn & plmn ) const [inline]

BOOLEAN BcdPlmn::IsInvalid ( ) const [inline]

BcdPlmn BcdPlmn::operator= ( const T_PLMN & plmn ) [inline]

BcdPlmn BcdPlmn::operator= ( const BcdPlmn & plmn ) [inline]

void BcdPlmn::SetInvalid ( ) [inline]

Field Documentation

BcdMcc BcdPlmn::mcc

BcdMnc BcdPlmn::mnc

The documentation for this class was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 00:57:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BdnIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BdnIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for BdnIndArg:

[legend]
Collaboration diagram for BdnIndArg:

[legend]

Public Types

enum | { ID = 1485 }

Public Member Functions

BdnIndArg ()
const BdnState & | GetBdnState () const
UINT8 | GetFileStatus () const
const SimUpdateStatus & | GetSimUpdateStatus () const
void | SetBdnState (const BdnState &bdn_state)
void | SetFileStatus (UINT8 file_status)
void | SetSimUpdateStatus (const SimUpdateStatus &sim_update_status)

Static Public Member Functions

static const BdnIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BdnIndArg: reflects arguments of signal MN_BDN_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BdnIndArg::BdnIndArg ( )

Member Function Documentation

const BdnIndArg & BdnIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const BdnState& BdnIndArg::GetBdnState ( ) const [inline]

UINT8 BdnIndArg::GetFileStatus ( ) const [inline]

const SimUpdateStatus& BdnIndArg::GetSimUpdateStatus ( ) const [inline]

void BdnIndArg::SetBdnState ( const BdnState & bdn_state ) [inline]

void BdnIndArg::SetFileStatus ( UINT8 file_status ) [inline]

void BdnIndArg::SetSimUpdateStatus ( const SimUpdateStatus & sim_update_status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 00:57:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BdnReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BdnReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for BdnReqArg:

[legend]
Collaboration diagram for BdnReqArg:

[legend]

Public Types

enum | { ID = 2471 }

Public Member Functions

BdnReqArg ()
BdnReqArg (const BdnState &bdn_state)
const BdnState & | GetBdnState () const
void | SetBdnState (const BdnState &bdn_state)

Static Public Member Functions

static const BdnReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BdnReqArg: reflects arguments of signal MN_BDN_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BdnReqArg::BdnReqArg ( const BdnState & bdn_state )

BdnReqArg::BdnReqArg ( )

Member Function Documentation

const BdnReqArg & BdnReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const BdnState& BdnReqArg::GetBdnState ( ) const [inline]

void BdnReqArg::SetBdnState ( const BdnState & bdn_state ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 00:57:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BidiManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BidiManager Class Reference
[GUI]

#include <Apoxi/Gui/BidiManager.hpp>

Collaboration diagram for BidiManager:

[legend]

Public Types

enum | CharType { NeutralType, LeftToRightType, RightToLeftType }

Public Member Functions

ParagraphContext * | BeginProcessing (const WCHAR *text, INT from=0, INT count=-1)
void | EndProcessing (ParagraphContext *context)
CharType | GetCharType (WCHAR chr) const
const INT * | GetConvertedPositions (ParagraphContext *context, INT from=0) const
const WCHAR * | GetConvertedText (ParagraphContext *context, INT from=0, INT count=-1, INT *cursor_pos=0)
BOOLEAN | IsActive () const
Returns TRUE, if the bidi-manager is activated.
INT | RemoveFormattingCodes (WCHAR *text, INT char_count)
void | SetActive (BOOLEAN flag)

Static Public Member Functions

static BidiManager * | GetInstance ()
Returns an instance of the class BidiManager.

Data Structures

struct | ParagraphContext

Detailed Description

The class BidiManager allows to prepare strings for languages, which require a bidirectional output. Usually the characters of a string are aligned in logical order and must be converted into a string representing the visual order.

Member Enumeration Documentation

enum BidiManager::CharType

Enumerator:
NeutralType
LeftToRightType
RightToLeftType

Member Function Documentation

BidiManager::ParagraphContext * BidiManager::BeginProcessing | ( | const WCHAR * | text,
 |  | INT | from = 0,
 |  | INT | count = -1
 | ) |

void BidiManager::EndProcessing ( ParagraphContext * context )

BidiManager::CharType BidiManager::GetCharType ( WCHAR chr ) const

const INT* BidiManager::GetConvertedPositions | ( | ParagraphContext * | context,
 |  | INT | from = 0
 | ) | const [inline]

Returns a pointer to an integer-array, which contains the new position for each character in the converted text.

const WCHAR * BidiManager::GetConvertedText | ( | ParagraphContext * | context,
 |  | INT | from = 0,
 |  | INT | count = -1,
 |  | INT * | cursor_pos = 0
 | ) |

Converts the text text given in logical order into a text representing the visual order.

BidiManager * BidiManager::GetInstance ( ) [static]

Returns an instance of the class BidiManager.

BOOLEAN BidiManager::IsActive ( ) const [inline]

Returns TRUE, if the bidi-manager is activated.

INT BidiManager::RemoveFormattingCodes | ( | WCHAR * | text,
 |  | INT | char_count
 | ) |

Removes formatting codes from text. This method can be used to remove formatting codes so the ordering of the string can be compared to implementations that remove formatting codes. This implementation is limited to the pseudo alphabet used for the demo version.

void BidiManager::SetActive ( BOOLEAN flag ) [inline]

Activates the bidi-manager, if flag is TRUE. When the bidi-manager is activated, all APOXI-components display the text in the correct bidirectional-format. Because the conversion from a logical text to a bidi-formatted text takes some time, it might be useful the deactivate the bidi-manager for languages which don't support bidirectional texts.

The documentation for this class was generated from the following files:
  • Gui/BidiManager.hpp
  • Gui/BidiManager.cpp
Generated on Wed Jan 25 00:57:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BidiManager::ParagraphContext Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BidiManager::ParagraphContext

BidiManager::ParagraphContext Struct Reference

#include <Apoxi/Gui/BidiManager.hpp>

Data Fields

INT | base_level
INT | count
INT * | dest_pos
WCHAR * | dest_text
INT | from
INT * | levels
INT * | types

Field Documentation

INT BidiManager::ParagraphContext::base_level

INT BidiManager::ParagraphContext::count

INT* BidiManager::ParagraphContext::dest_pos

WCHAR* BidiManager::ParagraphContext::dest_text

INT BidiManager::ParagraphContext::from

INT* BidiManager::ParagraphContext::levels

INT* BidiManager::ParagraphContext::types

The documentation for this struct was generated from the following file:
  • Gui/BidiManager.hpp
Generated on Wed Jan 25 00:57:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BigEndian16Bit Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BigEndian16Bit Class Reference

Represents a 16 bit integer in big endian format. More...

#include <Apoxi/Kernel/MachType.hpp>

Public Member Functions

BigEndian16Bit (const LittleEndian16Bit &v)
BigEndian16Bit (UINT16 v=0)
BigEndian16Bit & operator= (const LittleEndian16Bit &v)

Data Fields

union {
UINT16 m_uint16
struct {
UINT8 m_a
UINT8 m_b
} m_uint8
UINT8 m_uint8_ar [2]
} m_val

Detailed Description

Represents a 16 bit integer in big endian format.

Constructor & Destructor Documentation

BigEndian16Bit::BigEndian16Bit ( UINT16 v = 0 ) [inline]

Constructs a BigEndian16Bit object from an unsigned 16 bit integer value in big endian format.

Parameters:
v 16 bit value in big endian format

BigEndian16Bit::BigEndian16Bit ( const LittleEndian16Bit & v ) [inline]

Constructs a BigEndian16Bit object from an unsigned 16 bit integer value in little endian format.

Parameters:
v 16 bit value in little endian format

Member Function Documentation

BigEndian16Bit & BigEndian16Bit::operator= ( const LittleEndian16Bit & v ) [inline]

Assigns an unsigned 16 bit integer value in little endian format.

Parameters:
v 16 bit value in big endian format

Field Documentation

UINT8 BigEndian16Bit::m_a

UINT8 BigEndian16Bit::m_b

UINT16 BigEndian16Bit::m_uint16

struct { ... } BigEndian16Bit::m_uint8

UINT8 BigEndian16Bit::m_uint8_ar[2]

union { ... } BigEndian16Bit::m_val

Data union member which defines several access methods to the big endian number Byte member access (m_a, m_b) gives access to byte components in ascending order (i.e. BigEndian16Bit(Native16Bit(0xaabb)) will result in m_a = 0xaa, m_b = 0xbb)

The documentation for this class was generated from the following file:
  • Kernel/MachType.hpp
Generated on Wed Jan 25 00:57:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BigEndian32Bit Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BigEndian32Bit Class Reference

Represents a 32 bit integer in big endian format. More...

#include <Apoxi/Kernel/MachType.hpp>

Public Member Functions

BigEndian32Bit (const LittleEndian32Bit &v)
BigEndian32Bit (UINT32 v=0)
BigEndian32Bit & operator= (const LittleEndian32Bit &v)

Data Fields

union {
struct {
UINT16 m_a
UINT16 m_b
} m_uint16
UINT16 m_uint16_ar [2]
UINT32 m_uint32
struct {
UINT8 m_a
UINT8 m_b
UINT8 m_c
UINT8 m_d
} m_uint8
UINT8 m_uint8_ar [4]
} m_val

Detailed Description

Represents a 32 bit integer in big endian format.

Constructor & Destructor Documentation

BigEndian32Bit::BigEndian32Bit ( UINT32 v = 0 ) [inline]

Constructs a BigEndian32Bit object from an unsigned 32 bit integer value in big endian format.

Parameters:
v 32 bit value in big endian format

BigEndian32Bit::BigEndian32Bit ( const LittleEndian32Bit & v ) [inline]

Constructs a BigEndian32Bit object from an unsigned 32 bit integer value in little endian format.

Parameters:
v 32 bit value in big endian format

Member Function Documentation

BigEndian32Bit & BigEndian32Bit::operator= ( const LittleEndian32Bit & v ) [inline]

Assigns an unsigned 32 bit integer value in little endian format.

Parameters:
v 32 bit value in big endian format

Field Documentation

UINT16 BigEndian32Bit::m_a

UINT8 BigEndian32Bit::m_a

UINT16 BigEndian32Bit::m_b

UINT8 BigEndian32Bit::m_b

UINT8 BigEndian32Bit::m_c

UINT8 BigEndian32Bit::m_d

struct { ... } BigEndian32Bit::m_uint16

UINT16 BigEndian32Bit::m_uint16_ar[2]

UINT32 BigEndian32Bit::m_uint32

struct { ... } BigEndian32Bit::m_uint8

UINT8 BigEndian32Bit::m_uint8_ar[4]

union { ... } BigEndian32Bit::m_val

Data union member which defines several access methods to the big endian number Byte member access (m_a, m_b, m_c, m_d) gives access to byte components in ascending order (i.e. BigEndian32Bit(Native32Bit(0xaabbccdd)) will result in m_a = 0xaa, m_b = 0xbb, m_c = 0xcc, m_d = 0xdd)

The documentation for this class was generated from the following file:
  • Kernel/MachType.hpp
Generated on Wed Jan 25 00:57:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BinData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BinData Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/BinData.hpp>

Inheritance diagram for BinData:

[legend]
Collaboration diagram for BinData:

[legend]

Public Types

typedef void HUGE * | BufPtr
typedef UINT8 HUGE * | Uint8BufPtr

Public Member Functions

virtual BinData * | Clone () const
const DrmAsset & | GetDrmAsset () const
virtual UINT32 | GetLength () const =0
Returns the number of bytes which are hold by this object.
MemMap * | GetMemMap (UINT32 idx, UINT32 size) const
Obsolete - use ObtainMemMap instead.
virtual MemMap * | ObtainMemMap (UINT32 idx, UINT32 size) const
virtual UINT32 | Read (UINT32 idx, void *buf, UINT32 byte_count) const =0
virtual BOOLEAN | Read (UINT32 idx, UINT8 &val) const =0
virtual void | ReleaseInstance ()
virtual void | ReleaseMemMap (MemMap **h_map) const

Protected Member Functions

BinData (DrmLocalId id=c_drm_invalid_local_id)
virtual | ~BinData ()

Detailed Description

BinData defines an interface to access binary data in a way that releases the user from memory management. Usually an instance is created from some class but handled and obtained from another class. Therefor instances should not be constructed directly using a constructor. Any derived classes must provide a static method to create an instance, i.e static BinData* CreateInstance();. A instance must be destructed by invoking the ReleaseInstance(...) method.

Member Typedef Documentation

typedef void HUGE* BinData::BufPtr

typedef UINT8 HUGE* BinData::Uint8BufPtr

Constructor & Destructor Documentation

BinData::BinData ( DrmLocalId id = c_drm_invalid_local_id ) [protected]

BinData::~BinData ( ) [protected, virtual]

Member Function Documentation

BinData * BinData::Clone ( ) const [virtual]

Clones the BinData object. Cloning is useful if a BinData object is already obtained by one object, but another object wants to access the same data too. The cloned BinData object must be released by BinData::ReleaseInstance if it is not needed anymore. 0 is returned if the cloning has failed.

Reimplemented in FileBinData, BufferedData, and RamData.

const DrmAsset& BinData::GetDrmAsset ( ) const [inline]

Returns the DRM asset to process and validate DRM constraints and permissions.

virtual UINT32 BinData::GetLength ( ) const [pure virtual]

Returns the number of bytes which are hold by this object.

Implemented in FileBinData, ChildBinData, DataSourceBinData, RamData, and RomData.

MemMap* BinData::GetMemMap | ( | UINT32 | idx,
 |  | UINT32 | size
 | ) | const [inline]

Obsolete - use ObtainMemMap instead.

MemMap * BinData::ObtainMemMap | ( | UINT32 | idx,
 |  | UINT32 | size
 | ) | const [virtual]

Obtains a memory map from the given index idx with the specified size size. A size of -1 returns a MemMap to the end of data. 0 is returned if obtaining a memory map is not supported on the bin data object.

Reimplemented in FileBinData, DataSourceBinData, and RamData.

virtual UINT32 BinData::Read | ( | UINT32 | idx,
 |  | void * | buf,
 |  | UINT32 | byte_count
 | ) | const [pure virtual]

Reads byte_count bytes starting from the offset idx into buffer buf. Returns the number of read bytes.

Implemented in FileBinData, ChildBinData, DataSourceBinData, RamData, and RomData.

virtual BOOLEAN BinData::Read | ( | UINT32 | idx,
 |  | UINT8 & | val
 | ) | const [pure virtual]

Returns a single byte in val at the given index idx. val is not changed if idx does not exist.

Returns:
TRUE if a value at the index exists, FALSE otherwise.

Implemented in FileBinData, ChildBinData, DataSourceBinData, RamData, and RomData.

void BinData::ReleaseInstance ( ) [virtual]

Releases any allocated resources from BinData and deletes the object.

Reimplemented in BufferedData.

void BinData::ReleaseMemMap ( MemMap ** h_map ) const [virtual]

Releases a MemMap which has been obtained by BinData::ObtainMemMap.

Reimplemented in FileBinData, DataSourceBinData, and RamData.

The documentation for this class was generated from the following files:
  • Auxiliary/BinData.hpp
  • Auxiliary/BinData.cpp
Generated on Wed Jan 25 00:57:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BinDataDataSource Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BinDataDataSource Class Reference

#include <Apoxi/Auxiliary/BinDataDataSource.hpp>

Inheritance diagram for BinDataDataSource:

[legend]
Collaboration diagram for BinDataDataSource:

[legend]

Public Member Functions

BinDataDataSource (const BinDataPtr bin_data)
virtual BOOLEAN | Close ()
virtual BOOLEAN | GetSize (UINT32 &size) const
virtual BOOLEAN | IsOpen () const
virtual BOOLEAN | Open ()
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 count)
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 count)
virtual | ~BinDataDataSource ()

Protected Attributes

BinDataPtr | m_bin_data
BOOLEAN | m_is_open
UINT32 | m_offset

Detailed Description

Class DataSourceBinData wraps a data source into the BinData interface. The DataSource-derived instance is given to and controlled by this class via a smart-pointer to ease the ownership problem of the provided data source.

Constructor & Destructor Documentation

BinDataDataSource::BinDataDataSource ( const BinDataPtr bin_data )

Creates a BinData data source instance. This data source reads from the BinData. To ensure, that the BinData object isn't destroyed before the DataSource, a shared pointer is used.

Parameters:
bin_data Shared pointer to BinData

BinDataDataSource::~BinDataDataSource ( ) [virtual]

Destroys the BinData data source.

Member Function Documentation

BOOLEAN BinDataDataSource::Close ( ) [virtual]

Closes the data source. After closing the data source it can not be read any more.

Returns:
Success of operation.

Implements DataSource.

BOOLEAN BinDataDataSource::GetSize ( UINT32 & size ) const [virtual]

Returns the size of the data source in terms of bytes.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN BinDataDataSource::IsOpen ( ) const [virtual]

Returns whether the data source is currently open or closed.

Returns:
Whether the data source is open or not.

Implements DataSource.

BOOLEAN BinDataDataSource::Open ( ) [virtual]

Opens the data source for reading. Opening sets the current read position to the beginning of the data source. The read methods that do not use an offset argument always start to read at the current read position. A data source can only be read if it has been opened before.

Returns:
Success of operation.

Implements DataSource.

BOOLEAN BinDataDataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [virtual]

Reads up to max_count bytes from this data source starting at offset and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. parameter offset is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! Note that this method does not affect the current read position. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadRandomDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 offset = 0;
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(offset, buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...

                    // Increase offset where to read next.
                    offset += bytes_read;
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN BinDataDataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [virtual]

Reads exactly count bytes from this data source starting at offset and copies them to the provided buffer. Note that this method does not affect the current read position.

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN BinDataDataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [virtual]

Reads up to max_count bytes from this data source starting at the current read position and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. the current read position is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! The current read position is updated. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadSequentialDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN BinDataDataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [virtual]

Reads exactly count bytes from this data source starting at the current read position and copies them to the provided buffer. The current read position is updated.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implements DataSource.

Field Documentation

BinDataPtr BinDataDataSource::m_bin_data [protected]

BOOLEAN BinDataDataSource::m_is_open [protected]

UINT32 BinDataDataSource::m_offset [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/BinDataDataSource.hpp
  • Auxiliary/BinDataDataSource.cpp
Generated on Wed Jan 25 00:57:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BinDataInReadStatusInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BinDataInReadStatusInfo Struct Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/UnzipBinData.hpp>

Collaboration diagram for BinDataInReadStatusInfo:

[legend]

Data Fields

UINT32 | byte_before_the_zipfile
UINT32 | compression_method
UINT32 | crc32
UINT32 | crc32_wait
BinData * jar_bin_data
UINT32 | offset_local_extrafield
UINT32 | pos_in_zipfile
UINT32 | pos_local_extrafield
CHAR * | read_buffer
UINT32 | rest_read_compressed
UINT32 | rest_read_uncompressed
UINT | size_local_extrafield
z_stream | stream
UINT32 | stream_initialised

Field Documentation

UINT32 BinDataInReadStatusInfo::byte_before_the_zipfile

UINT32 BinDataInReadStatusInfo::compression_method

UINT32 BinDataInReadStatusInfo::crc32

UINT32 BinDataInReadStatusInfo::crc32_wait

BinData* BinDataInReadStatusInfo::jar_bin_data

UINT32 BinDataInReadStatusInfo::offset_local_extrafield

UINT32 BinDataInReadStatusInfo::pos_in_zipfile

UINT32 BinDataInReadStatusInfo::pos_local_extrafield

CHAR* BinDataInReadStatusInfo::read_buffer

UINT32 BinDataInReadStatusInfo::rest_read_compressed

UINT32 BinDataInReadStatusInfo::rest_read_uncompressed

UINT BinDataInReadStatusInfo::size_local_extrafield

z_stream BinDataInReadStatusInfo::stream

UINT32 BinDataInReadStatusInfo::stream_initialised

The documentation for this struct was generated from the following file:
  • AddOns/MultiMedia/UnzipBinData.hpp
Generated on Wed Jan 25 00:57:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BitField< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BitField< T > Class Template Reference

#include <Apoxi/Auxiliary/BitField.hpp>

Inheritance diagram for BitField< T >:

[legend]
Collaboration diagram for BitField< T >:

[legend]

Public Types

enum | { NrOfBits = sizeof(T) * 8 }

Public Member Functions

BitField (const T &bit_field=0)
void | Clear ()
resets the whole bit-field (every bit is set to 0).
T | Get () const
returns the bit field.
T | Get (const T &mask) const
returns the bit field viewed by the masked section.
BOOLEAN | GetBit (INT bit_index) const
sets one bit on position bit_index.
INT | GetNrOfBits () const
get mamimum number of available bit in this bit-field.
BOOLEAN | IsEqual (const BitField< T > &bit_field) const
BOOLEAN | IsEqual (const T &bit_field, const T &mask) const
BOOLEAN | IsSet (const T &bit_field) const
T | Mask (const T &mask) const
masks the whole bit-field it with parameter mask.
BitField & | operator<< (INT shift_pos)
shifts the bit-field for n_shifts-positions to the left.
BOOLEAN | operator== (const BitField &bit_field) const
BitField & | operator>> (INT n_shifts)
shifts the bit-field for n_shifts-positions to the right.
void | Set (T bit_field)
writes the bit-field.
void | Set (T bit_field, T mask)
writes the bit-field in masked section.
void | SetBit (INT bit_index)
void | SetBit (INT bit_index, BOOLEAN set)
void | SetFalse (INT bit_index)
void | SetTrue (INT bit_index)

Detailed Description

template<class T>
class BitField< T >

BitField is used to represent a scalar type as a bit field.

Member Enumeration Documentation

template<class T>
anonymous enum

Enumerator:
NrOfBits

Constructor & Destructor Documentation

template<class T>
BitField< T >::BitField ( const T & bit_field = 0 ) [inline]

Member Function Documentation

template<class T>
void BitField< T >::Clear ( ) [inline]

resets the whole bit-field (every bit is set to 0).

template<class T>
T BitField< T >::Get ( ) const [inline]

returns the bit field.

template<class T>
T BitField< T >::Get ( const T & mask ) const [inline]

returns the bit field viewed by the masked section.

template<class T>
BOOLEAN BitField< T >::GetBit ( INT bit_index ) const [inline]

sets one bit on position bit_index.

template<class T>
INT BitField< T >::GetNrOfBits ( ) const [inline]

get mamimum number of available bit in this bit-field.

template<class T>
BOOLEAN BitField< T >::IsEqual ( const BitField< T > & bit_field ) const [inline]

checks if all bits are equal.

template<class T>
BOOLEAN BitField< T >::IsEqual | ( | const T & | bit_field,
 |  | const T & | mask
 | ) | const [inline]

checks if all bits are equal in the selected section of mask.

template<class T>
BOOLEAN BitField< T >::IsSet ( const T & bit_field ) const [inline]

checks if all (set) bits of the parameter mask are also set in the bit-field.

template<class T>
T BitField< T >::Mask ( const T & mask ) const [inline]

masks the whole bit-field it with parameter mask.

template<class T>
BitField& BitField< T >::operator<< ( INT shift_pos ) [inline]

shifts the bit-field for n_shifts-positions to the left.

template<class T>
BOOLEAN BitField< T >::operator== ( const BitField< T > & bit_field ) const [inline]

template<class T>
BitField& BitField< T >::operator>> ( INT n_shifts ) [inline]

shifts the bit-field for n_shifts-positions to the right.

template<class T>
void BitField< T >::Set ( T bit_field ) [inline]

writes the bit-field.

template<class T>
void BitField< T >::Set | ( | T | bit_field,
 |  | T | mask
 | ) | [inline]

writes the bit-field in masked section.

template<class T>
void BitField< T >::SetBit ( INT bit_index ) [inline]

sets one the bit on position bit_index

template<class T>
void BitField< T >::SetBit | ( | INT | bit_index,
 |  | BOOLEAN | set
 | ) | [inline]

sets one the bit on position bit_index if parameter set is TRUE, otherwise the bit will be reseted (->0).

template<class T>
void BitField< T >::SetFalse ( INT bit_index ) [inline]

resets the bit on position bit_index

template<class T>
void BitField< T >::SetTrue ( INT bit_index ) [inline]

sets one the bit on position bit_index

The documentation for this class was generated from the following file:
  • Auxiliary/BitField.hpp
Generated on Wed Jan 25 00:57:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bitmap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Bitmap Class Reference
[GUI]

#include <Apoxi/Gui/Bitmap.hpp>

Public Member Functions

Bitmap (XYDIM width, XYDIM height, BOOLEAN transparent=FALSE, ColorValue transparent_color=0, BOOLEAN compressed=FALSE, BOOLEAN copyrighted=FALSE, INT display_idx=0, DDrvAtomPtr external_buffer=0, BOOLEAN free_external_buffer=FALSE, BOOLEAN create_alpha_mask=FALSE)
Bitmap ()
DDrvAtomPtr | GetAlphaMask () const
UINT8 | GetAlphaValue (XYDIM x, XYDIM y) const
Returns the alpha value for the point [x, y]. If no alpha mask exists, 255 is returned.
DDrvAtomPtr | GetBits () const
Returns the pointer to the bits of the bitmap.
XYDIM | GetHeight () const
Returns the height of the bitmap.
ColorValue | GetTransparentColor () const
XYDIM | GetWidth () const
Returns the width of the bitmap.
BOOLEAN | HasNativeImageData () const
Returns TRUE, if the data of the bitmap have the format of a NativeImage.
BOOLEAN | IsAlphaBlendingEnabled () const
BOOLEAN | IsCompressed () const
BOOLEAN | IsCopyrighted () const
BOOLEAN | IsTransparent () const
BOOLEAN | IsValid () const
operator BitmapRes () const
void | SetAlphaBlendingEnabled (BOOLEAN alpha_enabled)
void | SetAlphaMask (DDrvAtomPtr alphamask)
void | SetAlphaValue (XYDIM x, XYDIM y, UINT8 alpha_value)
Sets the alpha value at point [x, y] to alpha_value. If no alpha mask exists, it is created.
void | SetBits (DDrvAtomPtr bits, BOOLEAN free_external_buffer=FALSE)
void | SetHeight (XYDIM height)
Sets the height of the bitmap.
void | SetTransparent (BOOLEAN flag)
void | SetTransparentColor (ColorValue color)
void | SetWidth (XYDIM width)
Sets the width of the bitmap.
~Bitmap ()

Static Public Member Functions

static UINT32 | GetBufferByteCount (XYDIM width, XYDIM height, INT display_idx=0)

Detailed Description

A Bitmap represents a writable bitmap resource. Every bitmap has a size, a color depth and bitmap data. Per default each bitmap has the same data format as the display, which allows a very fast drawing.

Constructor & Destructor Documentation

Bitmap::Bitmap ( )

Bitmap::Bitmap | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | BOOLEAN | transparent = FALSE,
 |  | ColorValue | transparent_color = 0,
 |  | BOOLEAN | compressed = FALSE,
 |  | BOOLEAN | copyrighted = FALSE,
 |  | INT | display_idx = 0,
 |  | DDrvAtomPtr | external_buffer = 0,
 |  | BOOLEAN | free_external_buffer = FALSE,
 |  | BOOLEAN | create_alpha_mask = FALSE
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
transparent | Indicates, whether the bitmap contains transparent pixels.
transparent_color | Color-value of the pixels, which should be transparent. The parameter transparent must be set to TRUE.
compressed | Indicates, whether the data of the bitmap is compressed. Currently only RLE-compressed bitmaps are supported.
copyrighted | Indicates, whether the bitmap is copyrighted.
display_idx | Index of the display, where the bitmap should be drawn.
external_buffer | Per default a buffer is allocated, which contains the pixel-data of the bitmap (this buffer is automatically freed in the destructor). An already pre-allocated external buffer can be assigned by providing a pointer to this buffer. The size of the needed buffer can be retrieved by invoking Bitmap::GetBufferByteCount(). Note that the external buffer is only freed if parameter free_external_buffer states so, otherwise the client has to destroy the external buffer.
Attention: In order to not change the interface too much (because external buffers will probably be deprecated in the medium term), when using an external buffer for the bitmap data it is necessary that the alphamask is also an external buffer. The external alphamask buffer must be set with the SetAlphaMask() method. I. e. if an external bitmap buffer is used, the allocation the allocation and destruction of the alpha mask has to be done outside. If an external buffer is used but no alpha mask is required nothing further has to be done.
Parameters:
free_external_buffer | Indicates, whether the external buffer provided should be freed on destruction.
create_alpha_mask | If set to TRUE, an alpha mask is created as soon as the first Bitmap::SetAlphaValue is invoked. The alpha mask is destructed automatically in the destructor.

Bitmap::~Bitmap ( )

Member Function Documentation

DDrvAtomPtr Bitmap::GetAlphaMask ( ) const [inline]

UINT8 Bitmap::GetAlphaValue | ( | XYDIM | x,
 |  | XYDIM | y
 | ) | const

Returns the alpha value for the point [x, y]. If no alpha mask exists, 255 is returned.

DDrvAtomPtr Bitmap::GetBits ( ) const [inline]

Returns the pointer to the bits of the bitmap.

UINT32 Bitmap::GetBufferByteCount | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | display_idx = 0
 | ) | [static]

Returns the number of bytes needed for the buffer of the bitmap, which can be set in the constructor.

XYDIM Bitmap::GetHeight ( ) const [inline]

Returns the height of the bitmap.

ColorValue Bitmap::GetTransparentColor ( ) const [inline]

Returns:
Value of transparent color. The transparent color is only respected when Bitmap::IsTransparent returns TRUE.

XYDIM Bitmap::GetWidth ( ) const [inline]

Returns the width of the bitmap.

BOOLEAN Bitmap::HasNativeImageData ( ) const [inline]

Returns TRUE, if the data of the bitmap have the format of a NativeImage.

BOOLEAN Bitmap::IsAlphaBlendingEnabled ( ) const [inline]

BOOLEAN Bitmap::IsCompressed ( ) const [inline]

Returns:
TRUE, if the bitmap is compressed.

BOOLEAN Bitmap::IsCopyrighted ( ) const [inline]

Returns:
TRUE, if the bitmap is copyrighted.

BOOLEAN Bitmap::IsTransparent ( ) const [inline]

Returns:
TRUE, if the bitmap contains transparent pixels.

BOOLEAN Bitmap::IsValid ( ) const [inline]

Returns:
TRUE, if the bitmap buffer is valid. Valid means that the bitmap buffer could be allocated or is already available. When creating a bitmap it should always be checked whether the bitmap buffer is valid.

Bitmap::operator BitmapRes ( ) const

void Bitmap::SetAlphaBlendingEnabled ( BOOLEAN alpha_enabled ) [inline]

void Bitmap::SetAlphaMask ( DDrvAtomPtr alphamask )

void Bitmap::SetAlphaValue | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | UINT8 | alpha_value
 | ) |

Sets the alpha value at point [x, y] to alpha_value. If no alpha mask exists, it is created.

void Bitmap::SetBits | ( | DDrvAtomPtr | bits,
 |  | BOOLEAN | free_external_buffer = FALSE
 | ) |

Sets the pointer to the bits of the bitmap. The current memory pointed to is deleted if it either was automatically allocated or it was provided externally and stated that it should be deleted when required. If free_external_buffer is TRUE then the memory pointed to will be freed on destruction or before setting new bits.

void Bitmap::SetHeight ( XYDIM height ) [inline]

Sets the height of the bitmap.

void Bitmap::SetTransparent ( BOOLEAN flag ) [inline]

void Bitmap::SetTransparentColor ( ColorValue color ) [inline]

void Bitmap::SetWidth ( XYDIM width ) [inline]

Sets the width of the bitmap.

The documentation for this class was generated from the following files:
  • Gui/Bitmap.hpp
  • Gui/Bitmap.cpp
Generated on Wed Jan 25 00:57:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BitmapDc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BitmapDc Class Reference
[GUI]

Device-context for a Bitmap. More...

#include <Apoxi/Gui/BitmapDc.hpp>

Inheritance diagram for BitmapDc:

[legend]
Collaboration diagram for BitmapDc:

[legend]

Public Member Functions

virtual void | AdjustBoundingRect ()
BitmapDc (Bitmap *bitmap)
BitmapDc ()
void | Init (Bitmap *bitmap)
virtual | ~BitmapDc ()

Detailed Description

Device-context for a Bitmap.

Constructor & Destructor Documentation

BitmapDc::BitmapDc ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

BitmapDc::BitmapDc ( Bitmap * bitmap )

BitmapDc::~BitmapDc ( ) [virtual]

Member Function Documentation

void BitmapDc::AdjustBoundingRect ( ) [virtual]

See also:
DeviceContext::InitBoundingRect()

Reimplemented from DeviceContext.

void BitmapDc::Init ( Bitmap * bitmap )

The documentation for this class was generated from the following files:
  • Gui/BitmapDc.hpp
  • Gui/BitmapDc.cpp
Generated on Wed Jan 25 00:57:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BitmapRes Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BitmapRes Struct Reference
[GUI]

#include <Apoxi/Gui/Bitmap.hpp>

Public Member Functions

const DDrvAtomPtr | GetAlphaMask () const
Returns the pointer to the bits of the bitmap.
const DDrvAtomPtr | GetBits () const
Returns the pointer to the bits of the bitmap.
XYDIM | GetHeight () const
Returns the height of the bitmap.
ColorValue | GetTransparentColor () const
XYDIM | GetWidth () const
Returns the width of the bitmap.
BOOLEAN | HasNativeImageData () const
Returns TRUE, if the data of the bitmap have the format of a NativeImage.
BOOLEAN | IsAlphaBlendingEnabled () const
BOOLEAN | IsCompressed () const
BOOLEAN | IsCopyrighted () const
BOOLEAN | IsTransparent () const

Data Fields

const DDrvAtomPtr | m_bits
struct {
UINT compressed: 1
UINT copyrighted: 1
UINT has_native_img_data: 1
UINT transparent: 1
} m_flags
XYDIM | m_height
ColorValue m_transparent_color
XYDIM | m_width

Detailed Description

Defines the internal format for bitmap resources. Every bitmap resource has a size, a color depth and bitmap data. Per default each bitmap has the same data format as the display, which allows a very fast drawing. The class BitmapRes allows only read access to its properties.

Member Function Documentation

const DDrvAtomPtr BitmapRes::GetAlphaMask ( ) const [inline]

Returns the pointer to the bits of the bitmap.

const DDrvAtomPtr BitmapRes::GetBits ( ) const [inline]

Returns the pointer to the bits of the bitmap.

XYDIM BitmapRes::GetHeight ( ) const [inline]

Returns the height of the bitmap.

ColorValue BitmapRes::GetTransparentColor ( ) const [inline]

Returns:
Value of transparent color.

XYDIM BitmapRes::GetWidth ( ) const [inline]

Returns the width of the bitmap.

BOOLEAN BitmapRes::HasNativeImageData ( ) const [inline]

Returns TRUE, if the data of the bitmap have the format of a NativeImage.

BOOLEAN BitmapRes::IsAlphaBlendingEnabled ( ) const [inline]

BOOLEAN BitmapRes::IsCompressed ( ) const [inline]

Returns:
TRUE, if the bitmap is compressed.

BOOLEAN BitmapRes::IsCopyrighted ( ) const [inline]

Returns:
TRUE, if the bitmap is copyrighted.

BOOLEAN BitmapRes::IsTransparent ( ) const [inline]

Returns:
TRUE, if the bitmap contains transparent pixels.

Field Documentation

UINT BitmapRes::compressed

UINT BitmapRes::copyrighted

UINT BitmapRes::has_native_img_data

const DDrvAtomPtr BitmapRes::m_bits

struct { ... } BitmapRes::m_flags

XYDIM BitmapRes::m_height

ColorValue BitmapRes::m_transparent_color

XYDIM BitmapRes::m_width

UINT BitmapRes::transparent

The documentation for this struct was generated from the following file:
  • Gui/Bitmap.hpp
Generated on Wed Jan 25 00:57:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BitVector< N > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BitVector< N > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/BitVector.hpp>

Inheritance diagram for BitVector< N >:

[legend]

Public Member Functions

BitVector ()
BOOLEAN | GetBit (INT idx) const
void | SetBit (INT idx)
void | SetBit (INT idx, BOOLEAN set)

Detailed Description

template<INT N>
class BitVector< N >

BitVector is used to represent a bit field with N bits.

Constructor & Destructor Documentation

template<INT N>
BitVector< N >::BitVector ( ) [inline]

Member Function Documentation

template<INT N>
BOOLEAN BitVector< N >::GetBit ( INT idx ) const [inline]

template<INT N>
void BitVector< N >::SetBit ( INT idx ) [inline]

template<INT N>
void BitVector< N >::SetBit | ( | INT | idx,
 |  | BOOLEAN | set
 | ) | [inline]

The documentation for this class was generated from the following file:
  • Auxiliary/BitVector.hpp
Generated on Wed Jan 25 00:57:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlackAndWhiteTheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlackAndWhiteTheme Class Reference

Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

#include <Apoxi/Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.hpp>

Inheritance diagram for BlackAndWhiteTheme:

[legend]
Collaboration diagram for BlackAndWhiteTheme:

[legend]

Public Member Functions

BlackAndWhiteTheme ()
virtual const CheckBoxListView * | GetCheckBoxListView () const
virtual const CheckBoxView * | GetCheckBoxView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const RadioButtonListView * | GetRadioButtonListView () const
virtual const RadioButtonView * | GetRadioButtonView () const
virtual const SoftkeyBarView * | GetSoftkeyBarView () const
virtual const SystemColor | GetSystemColor (SystemColorId id) const
virtual const FontId | GetSystemFontId (SystemFontId id) const
virtual const TextListView * | GetTextListView () const
virtual const WindowFrameView * | GetWindowFrameView () const
virtual | ~BlackAndWhiteTheme ()

Detailed Description

Obsolete theme - replaced by themes in Apoxi/GlobalThemes.

Constructor & Destructor Documentation

BlackAndWhiteTheme::BlackAndWhiteTheme ( )

BlackAndWhiteTheme::~BlackAndWhiteTheme ( ) [virtual]

Member Function Documentation

const CheckBoxListView * BlackAndWhiteTheme::GetCheckBoxListView ( ) const [virtual]

const CheckBoxView * BlackAndWhiteTheme::GetCheckBoxView ( ) const [virtual]

const ControlFrameView * BlackAndWhiteTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const PositionIndicatorView * BlackAndWhiteTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

const ProgressBarView * BlackAndWhiteTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

const PushButtonView * BlackAndWhiteTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const RadioButtonListView * BlackAndWhiteTheme::GetRadioButtonListView ( ) const [virtual]

const RadioButtonView * BlackAndWhiteTheme::GetRadioButtonView ( ) const [virtual]

const SoftkeyBarView * BlackAndWhiteTheme::GetSoftkeyBarView ( ) const [virtual]

const SystemColor BlackAndWhiteTheme::GetSystemColor ( SystemColorId id ) const [virtual]

Returns a color-value of the system-color with the id id specified by the system-color-table. This method must not be overwritten by derived themes, when GetSystemColorTable has been overwritten. To stay backward-compatible with older versions of APOXI, 0 is returned if no system-color-table is provided.

Reimplemented from Theme.

const FontId BlackAndWhiteTheme::GetSystemFontId ( SystemFontId id ) const [virtual]

const TextListView * BlackAndWhiteTheme::GetTextListView ( ) const [virtual]

const WindowFrameView * BlackAndWhiteTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.hpp
  • Compat/GlobalThemes/BlackAndWhiteTheme/BlackAndWhiteTheme.cpp
Generated on Wed Jan 25 00:57:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlerTrchInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlerTrchInfo Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Data Fields

UINT8 | meas_bler
UINT16 | nof_crc_err
ULONG | tot_nof_blocks
UINT8 | trch_id

Field Documentation

UINT8 BlerTrchInfo::meas_bler

UINT16 BlerTrchInfo::nof_crc_err

ULONG BlerTrchInfo::tot_nof_blocks

UINT8 BlerTrchInfo::trch_id

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 00:57:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlerTrchInfoList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlerTrchInfoList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for BlerTrchInfoList:

[legend]

Public Types

enum | { LengthOfBlerArray = MAX_TRCH }

Public Member Functions

BOOLEAN | IsEmpty ()
BlerTrchInfoList | operator= (T_BLER_TRCH_INFO_ARRAY bler_array)
BlerTrchInfo & | operator[] (INT index)

Data Fields

INT | length
BlerTrchInfo | plmn_array [LengthOfBlerArray]

Member Enumeration Documentation

anonymous enum

Enumerator:
LengthOfBlerArray

Member Function Documentation

BOOLEAN BlerTrchInfoList::IsEmpty ( )

BlerTrchInfoList BlerTrchInfoList::operator= ( T_BLER_TRCH_INFO_ARRAY bler_array )

BlerTrchInfo& BlerTrchInfoList::operator[] ( INT index )

Field Documentation

INT BlerTrchInfoList::length

BlerTrchInfo BlerTrchInfoList::plmn_array[LengthOfBlerArray]

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 00:57:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlobObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlobObject Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/BlobObject.hpp>

Inheritance diagram for BlobObject:

[legend]
Collaboration diagram for BlobObject:

[legend]

Public Types

typedef BlobPtr | Base

Public Member Functions

void | Allocate (INT length)
Allocates memory for the data, existing data will be removed!
void | Append (const UINT8 *data, INT length)
Appends data to the end of BlobObject, existing data will not be lost!
BlobObject (const BlobObject &obj)
Copy Constructor.
BlobObject (const UINT8 *data, INT length)
Constructor which initializes the object with a pointer to data and the data length.
BlobObject ()
Default Constructor.
void | Clear ()
Clears the data.
virtual GenericObject * | Copy () const
Creates a copy of the object itself. Also the data pointed to and the length is copied.
void | CutOff (INT length)
Cuts off the given length of bytes from the beginning of the data.
virtual GenericTypeId | GetTypeId ()
Returns the identity of the BlobObject class.
BOOLEAN | IsEmpty () const
Retruns TRUE, if data is.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself, must be of the same type BlobObject.
BlobObject & | operator= (const BlobObject &szCopy)
Assignment operator.
INT | Peek (INT offset, UINT8 *&data, INT length)
INT | Poke (INT offset, const UINT8 *data, INT length)
void | Reallocate (INT length)
Reallocates memory for the data, existing data will not be lost!
void | Update (const UINT8 *data, INT length)
Update the data, existing data will be removed!
virtual | ~BlobObject ()
Destructor of the object. The data pointed to is deleted.

Detailed Description

BlobObject contains a pointer to allocated data and the length of this data. It can be used to export data from a provider where data inside the provider is changed during the usage of the BlobObject object. All data is copied during construction time and deleted during destruction time.

Member Typedef Documentation

typedef BlobPtr BlobObject::Base

Reimplemented from BlobPtr.

Reimplemented in RegBlobObject.

Constructor & Destructor Documentation

BlobObject::BlobObject ( )

Default Constructor.

BlobObject::BlobObject | ( | const UINT8 * | data,
 |  | INT | length
 | ) |

Constructor which initializes the object with a pointer to data and the data length.

BlobObject::BlobObject ( const BlobObject & obj )

Copy Constructor.

BlobObject::~BlobObject ( ) [virtual]

Destructor of the object. The data pointed to is deleted.

Member Function Documentation

void BlobObject::Allocate ( INT length )

Allocates memory for the data, existing data will be removed!

Reimplemented in RegBlobObject.

void BlobObject::Append | ( | const UINT8 * | data,
 |  | INT | length
 | ) |

Appends data to the end of BlobObject, existing data will not be lost!

Reimplemented in RegBlobObject.

void BlobObject::Clear ( )

Clears the data.

Reimplemented in RegBlobObject.

GenericObject * BlobObject::Copy ( ) const [virtual]

Creates a copy of the object itself. Also the data pointed to and the length is copied.

Reimplemented from BlobPtr.

Reimplemented in RegBlobObject.

void BlobObject::CutOff ( INT length )

Cuts off the given length of bytes from the beginning of the data.

Reimplemented in RegBlobObject.

GenericTypeId BlobObject::GetTypeId ( ) [virtual]

Returns the identity of the BlobObject class.

Reimplemented from BlobPtr.

Reimplemented in RegBlobObject.

BOOLEAN BlobObject::IsEmpty ( ) const [inline]

Retruns TRUE, if data is.

Reimplemented in RegBlobObject.

BOOLEAN BlobObject::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object instance itself, must be of the same type BlobObject.

Reimplemented from BlobPtr.

Reimplemented in RegBlobObject.

BlobObject & BlobObject::operator= ( const BlobObject & szCopy )

Assignment operator.

INT BlobObject::Peek | ( | INT | offset,
 |  | UINT8 *& | data,
 |  | INT | length
 | ) |

Reads data with given length out from the BlobObject (starting with offset). If length == -1, then the maximum possible data (from offset to end of data) is returned. Returns the number of read bytes.

Reimplemented in RegBlobObject.

INT BlobObject::Poke | ( | INT | offset,
 |  | const UINT8 * | data,
 |  | INT | length
 | ) |

Writes data into the BlobObject (starting with offset). Data will be truncated, if there is no more space to store in BlobObject. Returns the number of written bytes.

Reimplemented in RegBlobObject.

void BlobObject::Reallocate ( INT length )

Reallocates memory for the data, existing data will not be lost!

Reimplemented in RegBlobObject.

void BlobObject::Update | ( | const UINT8 * | data,
 |  | INT | length
 | ) |

Update the data, existing data will be removed!

The documentation for this class was generated from the following files:
  • Auxiliary/BlobObject.hpp
  • Auxiliary/BlobObject.cpp
Generated on Wed Jan 25 00:57:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlobPtr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlobPtr Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/BlobPtr.hpp>

Inheritance diagram for BlobPtr:

[legend]
Collaboration diagram for BlobPtr:

[legend]

Public Types

typedef GenericObject | Base

Public Member Functions

BlobPtr (const BlobPtr &obj)
BlobPtr (UINT8 *data, INT length)
Constructor which initializes the object with a pointer to data and the data length.
BlobPtr ()
Default Constructor.
virtual GenericObject * | Copy () const
Creates a copy of the object itself. Only the pointer and the length is copied.
UINT8 * | GetDataPtr () const
Returns the pointer to the data.
INT | GetLength () const
Returns the length of the data.
virtual GenericTypeId | GetTypeId ()
Returns the identity of the BlobPtr class.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself, must be of the same type BlobPtr.
BlobPtr & | operator= (const BlobPtr &szCopy)
Assignment operator.
virtual | ~BlobPtr ()

Protected Attributes

UINT8 * | m_data
INT | m_length

Detailed Description

BlobPtr conatins a pointer to data and the length of the data. It can be used to export data from a provider where data inside the provider is not changed during the usage of the BlobPtr object.

Member Typedef Documentation

typedef GenericObject BlobPtr::Base

Reimplemented in BlobObject, and RegBlobObject.

Constructor & Destructor Documentation

BlobPtr::BlobPtr ( )

Default Constructor.

BlobPtr::BlobPtr | ( | UINT8 * | data,
 |  | INT | length
 | ) |

Constructor which initializes the object with a pointer to data and the data length.

BlobPtr::BlobPtr ( const BlobPtr & obj )

BlobPtr::~BlobPtr ( ) [virtual]

Member Function Documentation

GenericObject * BlobPtr::Copy ( ) const [virtual]

Creates a copy of the object itself. Only the pointer and the length is copied.

Implements GenericObject.

Reimplemented in BlobObject, and RegBlobObject.

UINT8* BlobPtr::GetDataPtr ( ) const [inline]

Returns the pointer to the data.

INT BlobPtr::GetLength ( ) const [inline]

Returns the length of the data.

GenericTypeId BlobPtr::GetTypeId ( ) [virtual]

Returns the identity of the BlobPtr class.

Implements GenericObject.

Reimplemented in BlobObject, and RegBlobObject.

BOOLEAN BlobPtr::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object instance itself, must be of the same type BlobPtr.

Implements GenericObject.

Reimplemented in BlobObject, and RegBlobObject.

BlobPtr & BlobPtr::operator= ( const BlobPtr & szCopy )

Assignment operator.

Field Documentation

UINT8* BlobPtr::m_data [protected]

INT BlobPtr::m_length [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/BlobPtr.hpp
  • Auxiliary/BlobPtr.cpp
Generated on Wed Jan 25 00:57:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlockData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlockData Struct Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/Drm.hpp>

Data Fields

INT | m_block_size
INT | m_end_block_num
INT | m_start_block_num

Detailed Description

BlockData Structure Total DRM Message is broken into blocks INT Start block number - This is the first block number in the whole data. INT End block number - Last block number of data required.

Field Documentation

INT BlockData::m_block_size

INT BlockData::m_end_block_num

INT BlockData::m_start_block_num

The documentation for this struct was generated from the following file:
  • AddOns/Drm/Drm.hpp
Generated on Wed Jan 25 00:57:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyCheckBoxListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyCheckBoxListView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp>

Inheritance diagram for BlueSkyCheckBoxListView:

[legend]
Collaboration diagram for BlueSkyCheckBoxListView:

[legend]

Public Member Functions

BlueSkyCheckBoxListView (CheckBoxView *cb_view, XYDIM item_height)
virtual | ~BlueSkyCheckBoxListView ()

Protected Member Functions

virtual void | DrawCheckBoxItem (const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const

Constructor & Destructor Documentation

BlueSkyCheckBoxListView::BlueSkyCheckBoxListView | ( | CheckBoxView * | cb_view,
 |  | XYDIM | item_height
 | ) |

virtual BlueSkyCheckBoxListView::~BlueSkyCheckBoxListView ( ) [inline, virtual]

Member Function Documentation

void BlueSkyCheckBoxListView::DrawCheckBoxItem | ( | const CheckBoxItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

Implements CheckBoxListView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxListView.cpp
Generated on Wed Jan 25 00:57:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyCheckBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyCheckBoxView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp>

Inheritance diagram for BlueSkyCheckBoxView:

[legend]
Collaboration diagram for BlueSkyCheckBoxView:

[legend]

Public Types

typedef CheckBoxView | Base

Public Member Functions

BlueSkyCheckBoxView (XYDIM default_height, XYDIM left_gap, XYDIM middle_gap)
virtual | ~BlueSkyCheckBoxView ()

Protected Member Functions

virtual void | DrawCheckBox (const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShiftedCheckBox (const Rect &shift_rect, const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Member Typedef Documentation

typedef CheckBoxView BlueSkyCheckBoxView::Base

Reimplemented from CheckBoxView.

Constructor & Destructor Documentation

BlueSkyCheckBoxView::BlueSkyCheckBoxView | ( | XYDIM | default_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

virtual BlueSkyCheckBoxView::~BlueSkyCheckBoxView ( ) [inline, virtual]

Member Function Documentation

void BlueSkyCheckBoxView::DrawCheckBox | ( | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements CheckBoxView.

void BlueSkyCheckBoxView::DrawShiftedCheckBox | ( | const Rect & | shift_rect,
 |  | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements CheckBoxView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyCheckBoxView.cpp
Generated on Wed Jan 25 00:57:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyChineseTheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyChineseTheme Class Reference

Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

#include <Apoxi/Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.hpp>

Inheritance diagram for BlueSkyChineseTheme:

[legend]
Collaboration diagram for BlueSkyChineseTheme:

[legend]

Public Member Functions

BlueSkyChineseTheme ()
virtual const CheckBoxListView * | GetCheckBoxListView () const
virtual const CheckBoxView * | GetCheckBoxView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const RadioButtonListView * | GetRadioButtonListView () const
virtual const RadioButtonView * | GetRadioButtonView () const
virtual const SoftkeyBarView * | GetSoftkeyBarView () const
virtual const SystemColor | GetSystemColor (SystemColorId id) const
virtual const FontId | GetSystemFontId (SystemFontId id) const
virtual const TextListView * | GetTextListView () const
virtual const WindowFrameView * | GetWindowFrameView () const
virtual | ~BlueSkyChineseTheme ()

Detailed Description

Obsolete theme - replaced by themes in Apoxi/GlobalThemes.

Constructor & Destructor Documentation

BlueSkyChineseTheme::BlueSkyChineseTheme ( )

BlueSkyChineseTheme::~BlueSkyChineseTheme ( ) [virtual]

Member Function Documentation

const CheckBoxListView * BlueSkyChineseTheme::GetCheckBoxListView ( ) const [virtual]

const CheckBoxView * BlueSkyChineseTheme::GetCheckBoxView ( ) const [virtual]

const ControlFrameView * BlueSkyChineseTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const PositionIndicatorView * BlueSkyChineseTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

const ProgressBarView * BlueSkyChineseTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

const PushButtonView * BlueSkyChineseTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const RadioButtonListView * BlueSkyChineseTheme::GetRadioButtonListView ( ) const [virtual]

const RadioButtonView * BlueSkyChineseTheme::GetRadioButtonView ( ) const [virtual]

const SoftkeyBarView * BlueSkyChineseTheme::GetSoftkeyBarView ( ) const [virtual]

const SystemColor BlueSkyChineseTheme::GetSystemColor ( SystemColorId id ) const [virtual]

Returns a color-value of the system-color with the id id specified by the system-color-table. This method must not be overwritten by derived themes, when GetSystemColorTable has been overwritten. To stay backward-compatible with older versions of APOXI, 0 is returned if no system-color-table is provided.

Reimplemented from Theme.

const FontId BlueSkyChineseTheme::GetSystemFontId ( SystemFontId id ) const [virtual]

const TextListView * BlueSkyChineseTheme::GetTextListView ( ) const [virtual]

const WindowFrameView * BlueSkyChineseTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.hpp
  • Compat/GlobalThemes/BlueSkyChineseTheme/BlueSkyChineseTheme.cpp
Generated on Wed Jan 25 00:57:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyControlFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyControlFrameView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp>

Inheritance diagram for BlueSkyControlFrameView:

[legend]
Collaboration diagram for BlueSkyControlFrameView:

[legend]

Public Member Functions

BlueSkyControlFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size)
virtual | ~BlueSkyControlFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

BlueSkyControlFrameView::BlueSkyControlFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size
 | ) |

BlueSkyControlFrameView::~BlueSkyControlFrameView ( ) [virtual]

Member Function Documentation

void BlueSkyControlFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyControlFrameView.cpp
Generated on Wed Jan 25 00:57:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyPositionIndicatorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyPositionIndicatorView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp>

Inheritance diagram for BlueSkyPositionIndicatorView:

[legend]
Collaboration diagram for BlueSkyPositionIndicatorView:

[legend]

Public Member Functions

BlueSkyPositionIndicatorView (XYDIM size)
virtual | ~BlueSkyPositionIndicatorView ()

Protected Member Functions

virtual void | DrawPositionIndicator (const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

BlueSkyPositionIndicatorView::BlueSkyPositionIndicatorView ( XYDIM size )

virtual BlueSkyPositionIndicatorView::~BlueSkyPositionIndicatorView ( ) [inline, virtual]

Member Function Documentation

void BlueSkyPositionIndicatorView::DrawPositionIndicator | ( | const PositionIndicator & | pos_ind,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a position indicator described by the model. Must be implemented in the corresponding theme view.

Parameters:
pos_ind | Position-Indicator which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements PositionIndicatorView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyPositionIndicatorView.cpp
Generated on Wed Jan 25 00:57:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyProgressBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyProgressBarView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp>

Inheritance diagram for BlueSkyProgressBarView:

[legend]
Collaboration diagram for BlueSkyProgressBarView:

[legend]

Public Member Functions

BlueSkyProgressBarView (XYDIM default_height)
virtual | ~BlueSkyProgressBarView ()

Protected Member Functions

virtual void | DrawProgressBar (const ProgressBar &progress_bar, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

BlueSkyProgressBarView::BlueSkyProgressBarView ( XYDIM default_height )

virtual BlueSkyProgressBarView::~BlueSkyProgressBarView ( ) [inline, virtual]

Member Function Documentation

void BlueSkyProgressBarView::DrawProgressBar | ( | const ProgressBar & | progress_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements ProgressBarView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyProgressBarView.cpp
Generated on Wed Jan 25 00:57:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyPushButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyPushButtonView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp>

Inheritance diagram for BlueSkyPushButtonView:

[legend]
Collaboration diagram for BlueSkyPushButtonView:

[legend]

Public Types

typedef PushButtonView | Base

Public Member Functions

BlueSkyPushButtonView (XYDIM default_height)
virtual | ~BlueSkyPushButtonView ()

Protected Member Functions

virtual void | DrawPushButton (const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const

Member Typedef Documentation

typedef PushButtonView BlueSkyPushButtonView::Base

Reimplemented from PushButtonView.

Constructor & Destructor Documentation

BlueSkyPushButtonView::BlueSkyPushButtonView ( XYDIM default_height )

virtual BlueSkyPushButtonView::~BlueSkyPushButtonView ( ) [inline, virtual]

Member Function Documentation

void BlueSkyPushButtonView::DrawPushButton | ( | const PushButton & | push_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PushButtonView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyPushButtonView.cpp
Generated on Wed Jan 25 00:57:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyRadioButtonListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyRadioButtonListView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp>

Inheritance diagram for BlueSkyRadioButtonListView:

[legend]
Collaboration diagram for BlueSkyRadioButtonListView:

[legend]

Public Member Functions

BlueSkyRadioButtonListView (RadioButtonView *rb_view, XYDIM item_height)
virtual | ~BlueSkyRadioButtonListView ()

Protected Member Functions

virtual void | DrawRadioButtonItem (const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const

Constructor & Destructor Documentation

BlueSkyRadioButtonListView::BlueSkyRadioButtonListView | ( | RadioButtonView * | rb_view,
 |  | XYDIM | item_height
 | ) |

virtual BlueSkyRadioButtonListView::~BlueSkyRadioButtonListView ( ) [inline, virtual]

Member Function Documentation

void BlueSkyRadioButtonListView::DrawRadioButtonItem | ( | const RadioButtonItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

Implements RadioButtonListView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonListView.cpp
Generated on Wed Jan 25 00:57:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyRadioButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyRadioButtonView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp>

Inheritance diagram for BlueSkyRadioButtonView:

[legend]
Collaboration diagram for BlueSkyRadioButtonView:

[legend]

Public Types

typedef RadioButtonView | Base

Public Member Functions

BlueSkyRadioButtonView (XYDIM item_height, XYDIM left_gap, XYDIM middle_gap)
virtual | ~BlueSkyRadioButtonView ()

Protected Member Functions

virtual void | DrawRadioButton (const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShiftedRadioButton (const Rect &shift_rect, const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Member Typedef Documentation

typedef RadioButtonView BlueSkyRadioButtonView::Base

Reimplemented from RadioButtonView.

Constructor & Destructor Documentation

BlueSkyRadioButtonView::BlueSkyRadioButtonView | ( | XYDIM | item_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

virtual BlueSkyRadioButtonView::~BlueSkyRadioButtonView ( ) [inline, virtual]

Member Function Documentation

void BlueSkyRadioButtonView::DrawRadioButton | ( | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements RadioButtonView.

void BlueSkyRadioButtonView::DrawShiftedRadioButton | ( | const Rect & | shift_rect,
 |  | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements RadioButtonView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyRadioButtonView.cpp
Generated on Wed Jan 25 00:57:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkySoftkeyBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkySoftkeyBarView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp>

Inheritance diagram for BlueSkySoftkeyBarView:

[legend]
Collaboration diagram for BlueSkySoftkeyBarView:

[legend]

Public Types

typedef SoftkeyBarView | Base

Public Member Functions

virtual | ~BlueSkySoftkeyBarView ()

Protected Member Functions

virtual void | DrawSoftkeyBar (const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const

Member Typedef Documentation

typedef SoftkeyBarView BlueSkySoftkeyBarView::Base

Reimplemented from DrawableObjectView.

Constructor & Destructor Documentation

virtual BlueSkySoftkeyBarView::~BlueSkySoftkeyBarView ( ) [inline, virtual]

Member Function Documentation

void BlueSkySoftkeyBarView::DrawSoftkeyBar | ( | const SoftkeyBar & | softkey_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the Softkey-Bar. Must be implemented in the corresponding theme view.

Parameters:
softkey_bar | Softkey-Bar which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements SoftkeyBarView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkySoftkeyBarView.cpp
Generated on Wed Jan 25 00:57:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyTextListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyTextListView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp>

Inheritance diagram for BlueSkyTextListView:

[legend]
Collaboration diagram for BlueSkyTextListView:

[legend]

Public Member Functions

BlueSkyTextListView (XYDIM item_height)
virtual | ~BlueSkyTextListView ()

Protected Member Functions

virtual void | DrawTextListItem (const TextList &text_list, DeviceContext *dc, INT index, const Rect &item_rect) const

Constructor & Destructor Documentation

BlueSkyTextListView::BlueSkyTextListView ( XYDIM item_height )

virtual BlueSkyTextListView::~BlueSkyTextListView ( ) [inline, virtual]

Member Function Documentation

void BlueSkyTextListView::DrawTextListItem | ( | const TextList & | text_list,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [protected, virtual]

Implements TextListView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyTextListView.cpp
Generated on Wed Jan 25 00:57:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyTheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyTheme Class Reference

Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.hpp>

Inheritance diagram for BlueSkyTheme:

[legend]
Collaboration diagram for BlueSkyTheme:

[legend]

Public Member Functions

BlueSkyTheme ()
virtual const CheckBoxListView * | GetCheckBoxListView () const
virtual const CheckBoxView * | GetCheckBoxView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const RadioButtonListView * | GetRadioButtonListView () const
virtual const RadioButtonView * | GetRadioButtonView () const
virtual const SoftkeyBarView * | GetSoftkeyBarView () const
virtual const SystemColor | GetSystemColor (SystemColorId id) const
virtual const FontId | GetSystemFontId (SystemFontId id) const
virtual const TextListView * | GetTextListView () const
virtual const WindowFrameView * | GetWindowFrameView () const
virtual | ~BlueSkyTheme ()

Detailed Description

Obsolete theme - replaced by themes in Apoxi/GlobalThemes.

Constructor & Destructor Documentation

BlueSkyTheme::BlueSkyTheme ( )

BlueSkyTheme::~BlueSkyTheme ( ) [virtual]

Member Function Documentation

const CheckBoxListView * BlueSkyTheme::GetCheckBoxListView ( ) const [virtual]

const CheckBoxView * BlueSkyTheme::GetCheckBoxView ( ) const [virtual]

const ControlFrameView * BlueSkyTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const PositionIndicatorView * BlueSkyTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

const ProgressBarView * BlueSkyTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

const PushButtonView * BlueSkyTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const RadioButtonListView * BlueSkyTheme::GetRadioButtonListView ( ) const [virtual]

const RadioButtonView * BlueSkyTheme::GetRadioButtonView ( ) const [virtual]

const SoftkeyBarView * BlueSkyTheme::GetSoftkeyBarView ( ) const [virtual]

const SystemColor BlueSkyTheme::GetSystemColor ( SystemColorId id ) const [virtual]

Returns a color-value of the system-color with the id id specified by the system-color-table. This method must not be overwritten by derived themes, when GetSystemColorTable has been overwritten. To stay backward-compatible with older versions of APOXI, 0 is returned if no system-color-table is provided.

Reimplemented from Theme.

const FontId BlueSkyTheme::GetSystemFontId ( SystemFontId id ) const [virtual]

const TextListView * BlueSkyTheme::GetTextListView ( ) const [virtual]

const WindowFrameView * BlueSkyTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyTheme.cpp
Generated on Wed Jan 25 00:57:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BlueSkyWindowFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BlueSkyWindowFrameView Class Reference

#include <Apoxi/Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp>

Inheritance diagram for BlueSkyWindowFrameView:

[legend]
Collaboration diagram for BlueSkyWindowFrameView:

[legend]

Public Member Functions

BlueSkyWindowFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size, XYDIM title_height, XYDIM softkey_bar_height)
virtual | ~BlueSkyWindowFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawWindowExtensions (const Window &window, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

BlueSkyWindowFrameView::BlueSkyWindowFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size,
 |  | XYDIM | title_height,
 |  | XYDIM | softkey_bar_height
 | ) |

BlueSkyWindowFrameView::~BlueSkyWindowFrameView ( ) [virtual]

Member Function Documentation

void BlueSkyWindowFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

void BlueSkyWindowFrameView::DrawWindowExtensions | ( | const Window & | window,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

See also:
ControlFrameView::DrawWindowExenstions

Implements WindowFrameView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.hpp
  • Compat/GlobalThemes/BlueSkyTheme/BlueSkyWindowFrameView.cpp
Generated on Wed Jan 25 00:57:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BmpImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BmpImage Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/BmpImage.hpp>

Inheritance diagram for BmpImage:

[legend]
Collaboration diagram for BmpImage:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

BmpImage (BinData *bin_data, BOOLEAN *success=0)
BmpImage ()
virtual const BinData * | GetBinData () const
Returns the binary data of the image. Per default 0 is returned.
virtual UINT32 | GetFrameDelay (INT frame_idx) const
virtual INT | GetNextFrame (INT frame_idx) const
void | Init (BinData *bin_data, BOOLEAN *success=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual | ~BmpImage ()

Protected Member Functions

virtual void * | BeginScanlineDrawing (INT frame_idx=0) const
virtual void | DrawScanline (void *context, DeviceContext *dc, XYDIM x, XYDIM y, INT scanline_idx, INT old_scanline_idx) const
virtual void | EndScanlineDrawing (void *context) const
virtual XYDIM | GetScanlineDiff (void *context, INT scanline_idx, INT old_scanline_idx) const
virtual ColorValue | GetTransparentColor (void *context) const
virtual BOOLEAN | IsFullTraversingEnabled (void *context) const

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Image.

Constructor & Destructor Documentation

BmpImage::BmpImage ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

BmpImage::BmpImage | ( | BinData * | bin_data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
bin_data | Pointer to a binary data stream which contains the GIF-data. After passing the binary data stream, the stream is obtained by the GIF-image and hence automatically released in the destructor of the GIF-image.
success | Output-parameter, which indicates whether the initialization has been successful.

BmpImage::~BmpImage ( ) [virtual]

Member Function Documentation

void * BmpImage::BeginScanlineDrawing ( INT frame_idx = 0 ) const [protected, virtual]

See also:
Image::BeginScanlineDrawing

Reimplemented from Image.

void BmpImage::DrawScanline | ( | void * | context,
 |  | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

See also:
Image::DrawScanline

Reimplemented from Image.

void BmpImage::EndScanlineDrawing ( void * context ) const [protected, virtual]

See also:
Image::EndScanlineDrawing

Reimplemented from Image.

const BinData * BmpImage::GetBinData ( ) const [virtual]

Returns the binary data of the image. Per default 0 is returned.

Reimplemented from Image.

UINT32 BmpImage::GetFrameDelay ( INT frame_idx ) const [virtual]

See also:
Image::GetFrameDelay

Implements Image.

INT BmpImage::GetNextFrame ( INT frame_idx ) const [virtual]

See also:
Image::GetNextFrame

Implements Image.

XYDIM BmpImage::GetScanlineDiff | ( | void * | context,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

See also:
Image::GetScanlineDiff

Reimplemented from Image.

ColorValue BmpImage::GetTransparentColor ( void * context ) const [protected, virtual]

See also:
Image::GetTransparentColor

Reimplemented from Image.

void BmpImage::Init | ( | BinData * | bin_data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
bin_data | Pointer to a binary data stream which contains the GIF-data. After passing the binary data stream, the stream is obtained by the GIF-image and hence automatically released in the destructor of the GIF-image.
success | Output-parameter, which indicates whether the initialization has been successful.

BOOLEAN BmpImage::IsFullTraversingEnabled ( void * context ) const [protected, virtual]

Returns TRUE, if the GIF is interlaced.

See also:
Image::ForceFullScanlineTraversing

Reimplemented from Image.

BOOLEAN BmpImage::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Image.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/BmpImage.hpp
  • AddOns/MultiMedia/BmpImage.cpp
Generated on Wed Jan 25 00:57:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BooleanCondition Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BooleanCondition Class Reference
[Kernel]

#include <Apoxi/Kernel/Condition.hpp>

Inheritance diagram for BooleanCondition:

[legend]
Collaboration diagram for BooleanCondition:

[legend]

Public Member Functions

BooleanCondition ()
void | Init ()
virtual BOOLEAN | IsTrue () const
void | SetTrue ()
virtual | ~BooleanCondition ()

Detailed Description

Represents a boolean-condition which is assigned to the currently active application when constructing the condition. E. g. AppContainer::Wait() takes usage of such a condition.

Constructor & Destructor Documentation

BooleanCondition::BooleanCondition ( )

Initializes the boolean-condition with FALSE.

BooleanCondition::~BooleanCondition ( ) [virtual]

Member Function Documentation

void BooleanCondition::Init ( )

Initializes the boolean-condition with FALSE.

BOOLEAN BooleanCondition::IsTrue ( ) const [virtual]

Implements Condition.

void BooleanCondition::SetTrue ( )

Set the condition to TRUE and sends the message ApplicationWakeUpMsg

The documentation for this class was generated from the following files:
  • Kernel/Condition.hpp
  • Kernel/Condition.cpp
Generated on Wed Jan 25 00:57:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BootControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BootControl Class Reference
[ADC]

#include <Apoxi/Adc/DataHandler.hpp>

Collaboration diagram for BootControl:

[legend]

Public Types

enum | { NO_PROVIDERS = c_end_provider_range - c_start_provider_range }

Public Member Functions

BootControl ()
void | DisableLoading ()
void | EnableLoading ()
BOOLEAN | IsLoadingAllowed ()
void | OnFinishedSmsLoading ()
void | RequestOnStartup (INT providerid, BootNotification notification)
void | SendDataControlBootProgressMsg (INT providerid, INT progress)
void | StartLoading ()
~BootControl ()

Friends

class | SmsLoadingFinishedCondition

Detailed Description

BootControl controls which data shall be retrieved by ADC in the bootphase.

Member Enumeration Documentation

anonymous enum

Enumerator:
NO_PROVIDERS

Constructor & Destructor Documentation

BootControl::BootControl ( )

BootControl::~BootControl ( )

Member Function Documentation

void BootControl::DisableLoading ( ) [inline]

void BootControl::EnableLoading ( ) [inline]

BOOLEAN BootControl::IsLoadingAllowed ( ) [inline]

void BootControl::OnFinishedSmsLoading ( )

void BootControl::RequestOnStartup | ( | INT | providerid,
 |  | BootNotification | notification
 | ) |

void BootControl::SendDataControlBootProgressMsg | ( | INT | providerid,
 |  | INT | progress
 | ) |

void BootControl::StartLoading ( )

Friends And Related Function Documentation

friend class SmsLoadingFinishedCondition [friend]

The documentation for this class was generated from the following files:
  • Adc/DataHandler.hpp
  • Adc/DataHandler.cpp
Generated on Wed Jan 25 00:57:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BootDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BootDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/BootDispatcher.hpp>

Inheritance diagram for BootDispatcher:

[legend]
Collaboration diagram for BootDispatcher:

[legend]

Public Member Functions

BootDispatcher ()
virtual | ~BootDispatcher ()

Protected Member Functions

BOOLEAN | OnBootDispatching (const StackMsgArgument &arg)

Constructor & Destructor Documentation

BootDispatcher::BootDispatcher ( )

BootDispatcher::~BootDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN BootDispatcher::OnBootDispatching ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/BootDispatcher.hpp
  • Asc/BootDispatcher.cpp
Generated on Wed Jan 25 00:57:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BootDispatchingArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BootDispatchingArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for BootDispatchingArg:

[legend]
Collaboration diagram for BootDispatchingArg:

[legend]

Public Types

enum | { ID = 1381 }

Public Member Functions

BootDispatchingArg ()
INT | GetSequence () const
void | SetSequence (INT sequence)

Static Public Member Functions

static const BootDispatchingArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BootDispatchingArg : reflects no signal

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BootDispatchingArg::BootDispatchingArg ( )

Member Function Documentation

const BootDispatchingArg & BootDispatchingArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT BootDispatchingArg::GetSequence ( ) const [inline]

void BootDispatchingArg::SetSequence ( INT sequence ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 00:57:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BootHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BootHandler Class Reference

#include <Apoxi/Asc/BootHandler.hpp>

Collaboration diagram for BootHandler:

[legend]

Public Types

enum | { ID = BootHandlerId }

Public Member Functions

BootHandler ()
virtual HandlerId | GetHandlerId () const
virtual | ~BootHandler ()

Static Public Member Functions

static void | RequestOnStartup (INT providerid, BootNotification notification)

Detailed Description

The Boot handler BootHandler provides an interface for the application for controlling the boot sequence.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BootHandler::BootHandler ( )

BootHandler::~BootHandler ( ) [virtual]

Member Function Documentation

HandlerId BootHandler::GetHandlerId ( ) const [virtual]

void BootHandler::RequestOnStartup | ( | INT | providerid,
 |  | BootNotification | notification
 | ) | [static]

The documentation for this class was generated from the following files:
  • Asc/BootHandler.hpp
  • Asc/BootHandler.cpp
Generated on Wed Jan 25 00:57:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BootState Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BootState Class Reference
[ADC]

#include <Apoxi/Adc/DataHandler.hpp>

Collaboration diagram for BootState:

[legend]

Public Types

enum | { NO_PROVIDERS = c_end_provider_range - c_start_provider_range, BITS_PER_UINT = sizeof(UINT) * 8, BITFIELDSIZE = (((NO_PROVIDERS*2) + BITS_PER_UINT - 1) / BITS_PER_UINT) * BITS_PER_UINT }

Public Member Functions

BootState ()
BOOLEAN | IsAvailable (INT providerid) const
BOOLEAN | IsUpdated (INT providerid) const
void | SetAvailable (INT providerid)
void | SetUpdated (INT providerid)
~BootState ()

Detailed Description

BootState contains the loading states.

Member Enumeration Documentation

anonymous enum

Enumerator:
NO_PROVIDERS
BITS_PER_UINT
BITFIELDSIZE

Constructor & Destructor Documentation

BootState::BootState ( )

BootState::~BootState ( )

Member Function Documentation

BOOLEAN BootState::IsAvailable ( INT providerid ) const

BOOLEAN BootState::IsUpdated ( INT providerid ) const

void BootState::SetAvailable ( INT providerid )

void BootState::SetUpdated ( INT providerid )

The documentation for this class was generated from the following files:
  • Adc/DataHandler.hpp
  • Adc/DataHandler.cpp
Generated on Wed Jan 25 00:57:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BoundedItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BoundedItem Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/BoundedItem.hpp>

Inheritance diagram for BoundedItem:

[legend]
Collaboration diagram for BoundedItem:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

BoundedItem ()
virtual XYDIM | GetHeight () const =0
virtual INT | GetId () const
virtual XYDIM | GetWidth () const =0
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual | ~BoundedItem ()

Detailed Description

Abstract base class for Atom-Items which know their boundaries and are able to draw themself in their own context.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AtomItem.

Constructor & Destructor Documentation

BoundedItem::BoundedItem ( )

BoundedItem::~BoundedItem ( ) [virtual]

Member Function Documentation

virtual XYDIM BoundedItem::GetHeight ( ) const [pure virtual]

Implemented in AudioItem, ImageItem, VCardItem, and SoundItem.

INT BoundedItem::GetId ( ) const [virtual]

See also:
EditorItem::GetId()

Reimplemented from AtomItem.

Reimplemented in AudioItem, ImageItem, VCardItem, and SoundItem.

virtual XYDIM BoundedItem::GetWidth ( ) const [pure virtual]

Implemented in AudioItem, ImageItem, VCardItem, and SoundItem.

BOOLEAN BoundedItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from AtomItem.

Reimplemented in AudioItem, ImageItem, VCardItem, and SoundItem.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/BoundedItem.hpp
  • AddOns/MultiMedia/BoundedItem.cpp
Generated on Wed Jan 25 00:57:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BrowserRegisterReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BrowserRegisterReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for BrowserRegisterReqArg:

[legend]
Collaboration diagram for BrowserRegisterReqArg:

[legend]

Public Types

enum | { ID = 2323 }

Public Member Functions

BrowserRegisterReqArg ()
BrowserRegisterReqArg (const SiClientFlags &si_client_flags)
const SiClientFlags & | GetSiClientFlags () const
void | SetSiClientFlags (const SiClientFlags &si_client_flags)

Static Public Member Functions

static const BrowserRegisterReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BrowserRegisterReqArg: reflects arguments of signal BRSI_REGISTER_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BrowserRegisterReqArg::BrowserRegisterReqArg ( const SiClientFlags & si_client_flags )

BrowserRegisterReqArg::BrowserRegisterReqArg ( )

Member Function Documentation

const BrowserRegisterReqArg & BrowserRegisterReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SiClientFlags& BrowserRegisterReqArg::GetSiClientFlags ( ) const [inline]

void BrowserRegisterReqArg::SetSiClientFlags ( const SiClientFlags & si_client_flags ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 00:57:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BrowserSaveWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BrowserSaveWin Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/BrowserSaveWin.hpp>

Collaboration diagram for BrowserSaveWin:

[legend]

Public Member Functions

BrowserSaveWin ()
BrowserSaveWin ()
Path | GetNewPath () const
Returns the path that has been entered in the dialog.
Path | GetNewPath () const
Returns the path that has been entered in the dialog.
BOOLEAN | GetSuccess () const
Returns TRUE if confirmed or FALSE if canceled.
BOOLEAN | GetSuccess () const
Returns TRUE if confirmed or FALSE if canceled.
void | Init (BooleanCondition &condition, const MediaRefContainer &media_refs)
void | Init (BooleanCondition &condition, const MediaRefContainer &media_refs)
void | SetTargetPath (const Path &path)
Sets the name that should be shown when opening the dialog.
void | SetTargetPath (const Path &path)
Sets the name that should be shown when opening the dialog.
virtual | ~BrowserSaveWin ()
virtual | ~BrowserSaveWin ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnLayoutClient ()
virtual void | OnOpen ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

BrowserSaveWin::BrowserSaveWin ( )

BrowserSaveWin::~BrowserSaveWin ( ) [virtual]

BrowserSaveWin::BrowserSaveWin ( )

virtual BrowserSaveWin::~BrowserSaveWin ( ) [virtual]

Member Function Documentation

Path BrowserSaveWin::GetNewPath ( ) const

Returns the path that has been entered in the dialog.

Path BrowserSaveWin::GetNewPath ( ) const

Returns the path that has been entered in the dialog.

BOOLEAN BrowserSaveWin::GetSuccess ( ) const [inline]

Returns TRUE if confirmed or FALSE if canceled.

BOOLEAN BrowserSaveWin::GetSuccess ( ) const [inline]

Returns TRUE if confirmed or FALSE if canceled.

void BrowserSaveWin::Init | ( | BooleanCondition & | condition,
 |  | const MediaRefContainer & | media_refs
 | ) |

Initializes the window of the "Save"-dialog.

Parameters:
condition | Condition for the active wait.
media_refs | The associated media reference container.

void BrowserSaveWin::Init | ( | BooleanCondition & | condition,
 |  | const MediaRefContainer & | media_refs
 | ) |

Initializes the window of the "Save"-dialog.

Parameters:
condition | Condition for the active wait.
media_refs | The associated media reference container.

virtual BOOLEAN BrowserSaveWin::OnCancel ( ) [protected, virtual]

See also:
Window::OnCancel

BOOLEAN BrowserSaveWin::OnCancel ( ) [protected, virtual]

See also:
Window::OnCancel

virtual BOOLEAN BrowserSaveWin::OnConfirm ( ) [protected, virtual]

See also:
Window::OnConfirm

BOOLEAN BrowserSaveWin::OnConfirm ( ) [protected, virtual]

See also:
Window::OnConfirm

virtual void BrowserSaveWin::OnLayoutClient ( ) [protected, virtual]

See also:
Window::OnLayoutClient

void BrowserSaveWin::OnLayoutClient ( ) [protected, virtual]

See also:
Window::OnLayoutClient

virtual void BrowserSaveWin::OnOpen ( ) [protected, virtual]

See also:
Window::OnOpen

void BrowserSaveWin::OnOpen ( ) [protected, virtual]

See also:
Window::OnOpen

void BrowserSaveWin::SetTargetPath ( const Path & path )

Sets the name that should be shown when opening the dialog.

void BrowserSaveWin::SetTargetPath ( const Path & path )

Sets the name that should be shown when opening the dialog.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/BrowserSaveWin.hpp
  • Applications/SoundBrowser/Common/BrowserSaveWin.hpp
  • Applications/ImageBrowser/Common/BrowserSaveWin.cpp
  • Applications/SoundBrowser/Common/BrowserSaveWin.cpp
Generated on Wed Jan 25 00:57:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BrowserTermEventArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BrowserTermEventArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for BrowserTermEventArg:

[legend]
Collaboration diagram for BrowserTermEventArg:

[legend]

Public Types

enum | { ID = 2326 }

Public Member Functions

BrowserTermEventArg ()
BrowserTermEventArg (UINT8 term_cause)
UINT8 | GetTermCause () const
void | SetTermCause (UINT8 term_cause)

Static Public Member Functions

static const BrowserTermEventArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BrowserTermEventArg: reflects arguments of signal BRSI_BROWSER_TERM_EVENT

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BrowserTermEventArg::BrowserTermEventArg ( UINT8 term_cause )

BrowserTermEventArg::BrowserTermEventArg ( )

Member Function Documentation

const BrowserTermEventArg & BrowserTermEventArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 BrowserTermEventArg::GetTermCause ( ) const [inline]

void BrowserTermEventArg::SetTermCause ( UINT8 term_cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 00:57:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BrowserView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BrowserView Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/BrowserView.hpp>

Inheritance diagram for BrowserView:

[legend]
Collaboration diagram for BrowserView:

[legend]

Public Member Functions

BrowserView ()
BrowserView ()
const MediaRefPtr & | GetSelectedMediaRef () const
Returns the currently selected constant MediaRef object.
MediaRefPtr & GetSelectedMediaRef ()
Returns the currently selected MediaRef object.
const MediaRefPtr & | GetSelectedMediaRef () const
Returns the currently selected constant MediaRef object.
MediaRefPtr & GetSelectedMediaRef ()
Returns the currently selected MediaRef object.
void | Init (Control *parent, MediaRefContainer &media_refs, DrawableObjectListBoxModel *model)
void | Init (Control *parent, MediaRefContainer &media_refs, DrawableObjectListBoxModel *model)
virtual void | NotifyDelete ()
virtual void | NotifyDelete ()
virtual | ~BrowserView ()
virtual | ~BrowserView ()

Detailed Description

BrowserView has to be used as base class for all views to be used by BrowserViewContainer.

Constructor & Destructor Documentation

BrowserView::BrowserView ( )

BrowserView::~BrowserView ( ) [virtual]

BrowserView::BrowserView ( )

virtual BrowserView::~BrowserView ( ) [virtual]

Member Function Documentation

const MediaRefPtr& BrowserView::GetSelectedMediaRef ( ) const

Returns the currently selected constant MediaRef object.

MediaRefPtr& BrowserView::GetSelectedMediaRef ( )

Returns the currently selected MediaRef object.

const MediaRefPtr & BrowserView::GetSelectedMediaRef ( ) const

Returns the currently selected constant MediaRef object.

MediaRefPtr & BrowserView::GetSelectedMediaRef ( )

Returns the currently selected MediaRef object.

void BrowserView::Init | ( | Control * | parent,
 |  | MediaRefContainer & | media_refs,
 |  | DrawableObjectListBoxModel * | model
 | ) |

Initializes the object.

Parameters:
parent | Parent control where the BrowserView should be shown.
media_refs | Reference to the MediaRefContainer containing the entries of the items to be shown.
model | Model to use for showing the list.

void BrowserView::Init | ( | Control * | parent,
 |  | MediaRefContainer & | media_refs,
 |  | DrawableObjectListBoxModel * | model
 | ) |

Initializes the object.

Parameters:
parent | Parent control where the BrowserView should be shown.
media_refs | Reference to the MediaRefContainer containing the entries of the items to be shown.
model | Model to use for showing the list.

virtual void BrowserView::NotifyDelete ( ) [virtual]

Called when the view has to notified about the deletion of an element

Reimplemented in ImageView.

void BrowserView::NotifyDelete ( ) [virtual]

Called when the view has to notified about the deletion of an element

Reimplemented in ImageView.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/BrowserView.hpp
  • Applications/SoundBrowser/Common/BrowserView.hpp
  • Applications/ImageBrowser/Common/BrowserView.cpp
  • Applications/SoundBrowser/Common/BrowserView.cpp
Generated on Wed Jan 25 00:57:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BrowserViewContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BrowserViewContainer Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/BrowserViewContainer.hpp>

Inheritance diagram for BrowserViewContainer:

[legend]
Collaboration diagram for BrowserViewContainer:

[legend]

Public Member Functions

virtual void | AddView (BrowserView &browser_view)
virtual void | AddView (BrowserView &browser_view)
BrowserViewContainer (Control *parent, BrowserView &browser_view)
BrowserViewContainer ()
BrowserViewContainer (Control *parent, BrowserView &browser_view)
BrowserViewContainer ()
virtual BrowserView * | GetActiveView () const
Returns the currently shown view.
virtual BrowserView * | GetActiveView () const
Returns the currently shown view.
virtual INT | GetViewCount ()
Returns the number of views in the container.
virtual INT | GetViewCount ()
Returns the number of views in the container.
void | Init (Control *parent, BrowserView &browser_view)
void | Init (Control *parent, BrowserView &browser_view)
virtual void | NotifyDelete ()
Notifies all views that an element was deleted.
virtual void | NotifyDelete ()
Notifies all views that an element was deleted.
virtual BOOLEAN | RemoveView (BrowserView &browser_view)
virtual BOOLEAN | RemoveView (BrowserView &browser_view)
virtual void | SetActiveView (INT index)
virtual void | SetActiveView (INT index)
virtual void | ToggleView ()
virtual void | ToggleView ()
virtual void | Update (INT item_count)
virtual void | Update (INT item_count)
virtual | ~BrowserViewContainer ()
virtual | ~BrowserViewContainer ()

Detailed Description

BrowserViewContainer can handle more views of type BrowserView and allows to toggle between the views and apply changes of the model easily to the views.

Constructor & Destructor Documentation

BrowserViewContainer::BrowserViewContainer ( )

BrowserViewContainer::BrowserViewContainer | ( | Control * | parent,
 |  | BrowserView & | browser_view
 | ) |

BrowserViewContainer::~BrowserViewContainer ( ) [virtual]

BrowserViewContainer::BrowserViewContainer ( )

BrowserViewContainer::BrowserViewContainer | ( | Control * | parent,
 |  | BrowserView & | browser_view
 | ) |

virtual BrowserViewContainer::~BrowserViewContainer ( ) [virtual]

Member Function Documentation

virtual void BrowserViewContainer::AddView ( BrowserView & browser_view ) [virtual]

Adds a new view to the BrowserViewContainer.

Parameters:
browser_view View to be added.

void BrowserViewContainer::AddView ( BrowserView & browser_view ) [virtual]

Adds a new view to the BrowserViewContainer.

Parameters:
browser_view View to be added.

virtual BrowserView* BrowserViewContainer::GetActiveView ( ) const [virtual]

Returns the currently shown view.

BrowserView * BrowserViewContainer::GetActiveView ( ) const [virtual]

Returns the currently shown view.

virtual INT BrowserViewContainer::GetViewCount ( ) [virtual]

Returns the number of views in the container.

INT BrowserViewContainer::GetViewCount ( ) [virtual]

Returns the number of views in the container.

void BrowserViewContainer::Init | ( | Control * | parent,
 |  | BrowserView & | browser_view
 | ) |

Initializes the object. At least one view has to be added.

Parameters:
parent | Parent control where the BrowserViewContainer should be shown.
browser_view | The first view to be added to the container.

void BrowserViewContainer::Init | ( | Control * | parent,
 |  | BrowserView & | browser_view
 | ) |

Initializes the object. At least one view has to be added.

Parameters:
parent | Parent control where the BrowserViewContainer should be shown.
browser_view | The first view to be added to the container.

virtual void BrowserViewContainer::NotifyDelete ( ) [virtual]

Notifies all views that an element was deleted.

void BrowserViewContainer::NotifyDelete ( ) [virtual]

Notifies all views that an element was deleted.

virtual BOOLEAN BrowserViewContainer::RemoveView ( BrowserView & browser_view ) [virtual]

Removes an existing view from the BrowserViewContainer.

Parameters:
browser_view View to be removed.

BOOLEAN BrowserViewContainer::RemoveView ( BrowserView & browser_view ) [virtual]

Removes an existing view from the BrowserViewContainer.

Parameters:
browser_view View to be removed.

virtual void BrowserViewContainer::SetActiveView ( INT index ) [virtual]

Sets the index of the view which should be shown in the foreground.

Parameters:
index Index of the view to be shown.

void BrowserViewContainer::SetActiveView ( INT index ) [virtual]

Sets the index of the view which should be shown in the foreground.

Parameters:
index Index of the view to be shown.

virtual void BrowserViewContainer::ToggleView ( ) [virtual]

Removes the active view from the shown control and sets the next view to the foreground.

void BrowserViewContainer::ToggleView ( ) [virtual]

Removes the active view from the shown control and sets the next view to the foreground.

virtual void BrowserViewContainer::Update ( INT item_count ) [virtual]

Applies the update of the model to the views in the BrowserViewContainer.

void BrowserViewContainer::Update ( INT item_count ) [virtual]

Applies the update of the model to the views in the BrowserViewContainer.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/BrowserViewContainer.hpp
  • Applications/SoundBrowser/Common/BrowserViewContainer.hpp
  • Applications/ImageBrowser/Common/BrowserViewContainer.cpp
  • Applications/SoundBrowser/Common/BrowserViewContainer.cpp
Generated on Wed Jan 25 00:57:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Brush Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Brush Class Reference
[GUI]

#include <Apoxi/Gui/Brush.hpp>

Collaboration diagram for Brush:

[legend]

Public Types

enum | BrushStyle { Solid, Checkered }

Public Member Functions

Brush (const Color &color=Color(0), BrushStyle style=Solid)
Constructor for brush.
const Color & | GetColor () const
ColorValue | GetColorValue () const
Returns the color-value of the brush.
BrushStyle | GetStyle () const
Returns the style of the brush.
void | SetColor (const Color &color)
void | SetColorHsv (UINT8 hue, UINT8 saturation, UINT8 value, UINT8 alpha=255)
void | SetColorRgb (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha=255)
void | SetColorValue (ColorValue color_value)
Sets the color of the brush to the value represented by color_value.
void | SetStyle (BrushStyle style)
Sets the style of the brush (not supported yet).

Detailed Description

A brush is used by all graphical methods, which fill an area. A brush has a style (Solid or Checkered) and a color.

Member Enumeration Documentation

enum Brush::BrushStyle

Defines the style of the brush.
Solid - Areas will be filled with the defined color.
Checkered - Areas will be filled with a checkered pattern.

Enumerator:
Solid
Checkered

Constructor & Destructor Documentation

Brush::Brush | ( | const Color & | color = Color(0),
 |  | BrushStyle | style = Solid
 | ) | [inline]

Constructor for brush.

Member Function Documentation

const Color& Brush::GetColor ( ) const [inline]

ColorValue Brush::GetColorValue ( ) const [inline]

Returns the color-value of the brush.

BrushStyle Brush::GetStyle ( ) const [inline]

Returns the style of the brush.

void Brush::SetColor ( const Color & color ) [inline]

void Brush::SetColorHsv | ( | UINT8 | hue,
 |  | UINT8 | saturation,
 |  | UINT8 | value,
 |  | UINT8 | alpha = 255
 | ) | [inline]

Sets the color of the pen to the value represented by hue, saturation and the value. Optionally an alpha-channel can be specified.

void Brush::SetColorRgb | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha = 255
 | ) | [inline]

Sets the color of the pen to the value represented by red-, green- and blue-portions. Optionally an alpha-channel can be specified.

void Brush::SetColorValue ( ColorValue color_value ) [inline]

Sets the color of the brush to the value represented by color_value.

void Brush::SetStyle ( BrushStyle style ) [inline]

Sets the style of the brush (not supported yet).

The documentation for this class was generated from the following file:
  • Gui/Brush.hpp
Generated on Wed Jan 25 00:57:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtActiveDeviceWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtActiveDeviceWindow Class Reference

#include <Applications/BtApp/BtActiveDeviceWindow.hpp>

Collaboration diagram for BtActiveDeviceWindow:

[legend]

Public Member Functions

BtActiveDeviceWindow ()
BtDevice & GetActiveDevice ()
void | Init ()
void | SetActiveDevice (const BtDevice &active_device)
virtual | ~BtActiveDeviceWindow ()

Protected Member Functions

virtual void | OnOpen ()

Detailed Description

BtActiveDeviceWindow used to diaplay current active device. Hs or Dun AppPlugin may set disconnect action to the primary softkey to disconnect the active device.

Constructor & Destructor Documentation

BtActiveDeviceWindow::BtActiveDeviceWindow ( )

BtActiveDeviceWindow::~BtActiveDeviceWindow ( ) [virtual]

Member Function Documentation

BtDevice& BtActiveDeviceWindow::GetActiveDevice ( ) [inline]

void BtActiveDeviceWindow::Init ( )

void BtActiveDeviceWindow::OnOpen ( ) [protected, virtual]

void BtActiveDeviceWindow::SetActiveDevice ( const BtDevice & active_device )

Set the active device

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtActiveDeviceWindow.hpp
  • Applications/BtApp/BtActiveDeviceWindow.cpp
Generated on Wed Jan 25 00:57:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAlertMessageWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAlertMessageWindow Class Reference

#include <Applications/BtApp/BtApplicationWindows.hpp>

Public Types

enum BtAmwType {
BtAmwPair, BtAmwUnpair, BtAmwTrust, BtAmwUntrust,
BtAmwSetName, BtAmwQuerySupportedProfiles, BtAmwDunConnect, BtAmwDunDisconnect,
BtAmwHsConnect, BtAmwHsDisconnect, BtAmwHsCallTransferToPhone, BtAmwHsCallTransferToHeadset,
BtAmwHfConnect, BtAmwHfDisconnect, BtAmwHfAudio2Phone, BtAmwHfAudio2Hf,
BtAmwFaxConnect, BtAmwFaxDisconnect, BtAmwSupportedProfile, BtAmwServiceVerify
}

Public Member Functions

BtAlertMessageWindow ()
void | Display (BtAmwType amw_type, BOOLEAN success)
void | Init ()
virtual | ~BtAlertMessageWindow ()

Detailed Description

BtAlertMessageWindow alert window used to display some alert message to inform user about the status or result of the progress.

Member Enumeration Documentation

enum BtAlertMessageWindow::BtAmwType

Enumerator:
BtAmwPair
BtAmwUnpair
BtAmwTrust
BtAmwUntrust
BtAmwSetName
BtAmwQuerySupportedProfiles
BtAmwDunConnect
BtAmwDunDisconnect
BtAmwHsConnect
BtAmwHsDisconnect
BtAmwHsCallTransferToPhone
BtAmwHsCallTransferToHeadset
BtAmwHfConnect
BtAmwHfDisconnect
BtAmwHfAudio2Phone
BtAmwHfAudio2Hf
BtAmwFaxConnect
BtAmwFaxDisconnect
BtAmwSupportedProfile
BtAmwServiceVerify

Constructor & Destructor Documentation

BtAlertMessageWindow::BtAlertMessageWindow ( )

BtAlertMessageWindow::~BtAlertMessageWindow ( ) [virtual]

Member Function Documentation

void BtAlertMessageWindow::Display | ( | BtAmwType | amw_type,
 |  | BOOLEAN | success
 | ) |

void BtAlertMessageWindow::Init ( )

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationWindows.hpp
  • Applications/BtApp/BtApplicationWindows.cpp
Generated on Wed Jan 25 00:57:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplication Class Reference

#include <Applications/BtApp/BtApplication.hpp>

Collaboration diagram for BtApplication:

[legend]

Public Member Functions

void | BtFeatureSetAvailable (const FeatureID &feature_id, BOOLEAN available)
void | BtRemoteDeviceListOptions ()
BtActiveDeviceWindow * GetActiveDeviceWindow ()
BtDeviceListWindow * GetDeviceListWindow ()
BtLocalSettings * GetLocalSettings ()
virtual void | OnStartup ()
void | SetIndicatorVisible (const String &str, BOOLEAN visible)
virtual | ~BtApplication ()

Static Public Member Functions

static BtApplication * | GetInstance ()

Protected Member Functions

BOOLEAN | OnAuthorizationRequired (const BtAuthorizationRequiredMessage &message)
virtual void | OnBtActivated (BtProfile profile, BOOLEAN connected)
virtual void | OnClose ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &message)
virtual void | OnOpen ()
BOOLEAN | OnPasskeyRequired (const BtPasskeyRequiredMessage &message)
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)

Detailed Description

BtApplication is application of bluetooth. BtApplication is responsible for handle message posted by Apoxi-Bluetooth, construct menu entry, open and close corresponding bluetooth windows.

Constructor & Destructor Documentation

BtApplication::~BtApplication ( ) [virtual]

Member Function Documentation

void BtApplication::BtFeatureSetAvailable | ( | const FeatureID & | feature_id,
 |  | BOOLEAN | available
 | ) |

void BtApplication::BtRemoteDeviceListOptions ( )

BtActiveDeviceWindow* BtApplication::GetActiveDeviceWindow ( ) [inline]

BtDeviceListWindow* BtApplication::GetDeviceListWindow ( ) [inline]

BtApplication * BtApplication::GetInstance ( ) [static]

BtLocalSettings* BtApplication::GetLocalSettings ( ) [inline]

BOOLEAN BtApplication::OnAuthorizationRequired ( const BtAuthorizationRequiredMessage & message ) [protected]

Some Bluetooth Profiles have security settings that require authorization. When reomte device requests to establish a connection, OnAuthorizationRequired will be invoked. Local device has to decide whether to accept the connection or reject it. If the connecting device is trusted the request is answered by the Bluetooth Stack itself. Untrusted devices must answer the request by execuing a BtRespondAuthorizationRequest

void BtApplication::OnBtActivated | ( | BtProfile | profile,
 |  | BOOLEAN | connected
 | ) | [protected, virtual]

void BtApplication::OnClose ( ) [protected, virtual]

See also:
Application::OnClose()

BOOLEAN BtApplication::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN BtApplication::OnMessage ( const Message & message ) [protected, virtual]

See also:
Application::OnMessage()

void BtApplication::OnOpen ( ) [protected, virtual]

See also:
Application::OnPaint()

BOOLEAN BtApplication::OnPasskeyRequired ( const BtPasskeyRequiredMessage & message ) [protected]

During the execution of a pairing request, a request for authentication will be sent to the Local Bluetooth Device. OnPasskeyRequired function will be invoked.To answer the recieved request for authentication the application programmer has to instantiate a BtSendPasskeyReqeust

BOOLEAN BtApplication::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [protected, virtual]

void BtApplication::OnStartup ( ) [virtual]

void BtApplication::SetIndicatorVisible | ( | const String & | str,
 |  | BOOLEAN | visible
 | ) |

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplication.hpp
  • Applications/BtApp/BtApplication.cpp
Generated on Wed Jan 25 00:58:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationDevicePairRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationDevicePairRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationDevicePairRequest:

[legend]
Collaboration diagram for BtApplicationDevicePairRequest:

[legend]

Public Member Functions

BtApplicationDevicePairRequest (BtDeviceListWindow *device_list_window)
Constructor.
virtual | ~BtApplicationDevicePairRequest ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtDevicePairRequest

Constructor & Destructor Documentation

BtApplicationDevicePairRequest::BtApplicationDevicePairRequest ( BtDeviceListWindow * device_list_window )

Constructor.

BtApplicationDevicePairRequest::~BtApplicationDevicePairRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationDevicePairRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationDeviceSearchRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationDeviceSearchRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationDeviceSearchRequest:

[legend]
Collaboration diagram for BtApplicationDeviceSearchRequest:

[legend]

Public Member Functions

BtApplicationDeviceSearchRequest (BtDeviceListWindow *device_list_window)
Constructor.
void | CancelSearchRequest ()
CancelSearchRequest.
virtual | ~BtApplicationDeviceSearchRequest ()
Destructor.

Protected Member Functions

virtual void | OnRemoteDeviceName (const BtDevice &remote_device, const WString &remote_device_name)
Remote device name received message handler member function.
virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtDeviceSearchRequest

Constructor & Destructor Documentation

BtApplicationDeviceSearchRequest::BtApplicationDeviceSearchRequest ( BtDeviceListWindow * device_list_window )

Constructor.

BtApplicationDeviceSearchRequest::~BtApplicationDeviceSearchRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationDeviceSearchRequest::CancelSearchRequest ( )

CancelSearchRequest.

void BtApplicationDeviceSearchRequest::OnRemoteDeviceName | ( | const BtDevice & | remote_device,
 |  | const WString & | remote_device_name
 | ) | [protected, virtual]

Remote device name received message handler member function.

The OnRemoteDeviceName member function will be invoked when a BtRemoteDeviceNameMessage is received by this request. This member function is used to enable some reactions to the receipt of the aforsaid message.
The implmenetation of this member function is a dummy implementation and does nothing. If the application programmer wants to change this behaviour, he has to overload this function in a derived class. He need not to call the inherited base function, because it does nothing.

Parameters:
remote_device | A reference to a BtDevice containing the device for which the name was received.
remote_device_name | A reference to a WString containing the received remote device name.

Reimplemented from BtDeviceSearchRequest.

void BtApplicationDeviceSearchRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationDeviceTrustRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationDeviceTrustRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationDeviceTrustRequest:

[legend]
Collaboration diagram for BtApplicationDeviceTrustRequest:

[legend]

Public Member Functions

BtApplicationDeviceTrustRequest (BtDeviceListWindow *device_list_window)
Constructor.
virtual | ~BtApplicationDeviceTrustRequest ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtDeviceTrustRequest

Constructor & Destructor Documentation

BtApplicationDeviceTrustRequest::BtApplicationDeviceTrustRequest ( BtDeviceListWindow * device_list_window )

Constructor.

BtApplicationDeviceTrustRequest::~BtApplicationDeviceTrustRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationDeviceTrustRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationDeviceUnpairRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationDeviceUnpairRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationDeviceUnpairRequest:

[legend]
Collaboration diagram for BtApplicationDeviceUnpairRequest:

[legend]

Public Member Functions

BtApplicationDeviceUnpairRequest (BtDeviceListWindow *device_list_window)
Constructor.
virtual | ~BtApplicationDeviceUnpairRequest ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtDeviceUnpairRequest

Constructor & Destructor Documentation

BtApplicationDeviceUnpairRequest::BtApplicationDeviceUnpairRequest ( BtDeviceListWindow * device_list_window )

Constructor.

BtApplicationDeviceUnpairRequest::~BtApplicationDeviceUnpairRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationDeviceUnpairRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationDeviceUntrustRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationDeviceUntrustRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationDeviceUntrustRequest:

[legend]
Collaboration diagram for BtApplicationDeviceUntrustRequest:

[legend]

Public Member Functions

BtApplicationDeviceUntrustRequest (BtDeviceListWindow *device_list_window)
Constructor.
virtual | ~BtApplicationDeviceUntrustRequest ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtDeviceUntrustRequest

Constructor & Destructor Documentation

BtApplicationDeviceUntrustRequest::BtApplicationDeviceUntrustRequest ( BtDeviceListWindow * device_list_window )

Constructor.

BtApplicationDeviceUntrustRequest::~BtApplicationDeviceUntrustRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationDeviceUntrustRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationMessage Class Reference

#include <Apoxi/Bluetooth/BtApplicationMessage.hpp>

Inheritance diagram for BtApplicationMessage:

[legend]
Collaboration diagram for BtApplicationMessage:

[legend]

Public Types

enum | { ID = 10000 }

Public Member Functions

BtApplicationMessage (const BtResultCode &result)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const BtResultCode & | GetResult () const
void | SetResult (const BtResultCode &result)
virtual | ~BtApplicationMessage ()

Detailed Description

BtApplicationMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtApplicationMessage::BtApplicationMessage ( const BtResultCode & result )

BtApplicationMessage::~BtApplicationMessage ( ) [virtual]

Member Function Documentation

Message * BtApplicationMessage::Clone ( ) const [virtual]

Implements Message.

Reimplemented in BtGapAndSdapApplicationMessage, BtGapAndSdapRemoteRequestMessage, BtPasskeyRequiredMessage, BtAuthorizationRequiredMessage, BtGapAndSdapNotificationMessage, BtRemoteDevicePairMessage, BtDunApplicationMessage, BtDunConnectMessage, BtDunDisconnectMessage, BtFaxApplicationMessage, BtFaxConnectMessage, and BtFaxDisconnectMessage.

const MsgMetaData & BtApplicationMessage::GetMetaData ( ) const [virtual]

Implements Message.

Reimplemented in BtGapAndSdapApplicationMessage, BtGapAndSdapRemoteRequestMessage, BtPasskeyRequiredMessage, BtAuthorizationRequiredMessage, BtGapAndSdapNotificationMessage, BtRemoteDevicePairMessage, BtDunApplicationMessage, BtDunConnectMessage, BtDunDisconnectMessage, BtFaxApplicationMessage, BtFaxConnectMessage, and BtFaxDisconnectMessage.

const BtResultCode& BtApplicationMessage::GetResult ( ) const [inline]

void BtApplicationMessage::SetResult ( const BtResultCode & result ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtApplicationMessage.hpp
  • Bluetooth/BtApplicationMessage.cpp
Generated on Wed Jan 25 00:58:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationQuerySupportedProfilesRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationQuerySupportedProfilesRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationQuerySupportedProfilesRequest:

[legend]
Collaboration diagram for BtApplicationQuerySupportedProfilesRequest:

[legend]

Public Types

enum | BtQueryRequestSupportWinType { TDeviceDetail, TDeviceList }

Public Member Functions

BtApplicationQuerySupportedProfilesRequest (BtDeviceListWindow *device_list_window)
BtApplicationQuerySupportedProfilesRequest (BtDeviceDetailWindow *device_detail_window)
Constructor.
virtual | ~BtApplicationQuerySupportedProfilesRequest ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtQuerySupportedProfilesRequest

Member Enumeration Documentation

enum BtApplicationQuerySupportedProfilesRequest::BtQueryRequestSupportWinType

Enumerator:
TDeviceDetail
TDeviceList

Constructor & Destructor Documentation

BtApplicationQuerySupportedProfilesRequest::BtApplicationQuerySupportedProfilesRequest ( BtDeviceDetailWindow * device_detail_window )

Constructor.

BtApplicationQuerySupportedProfilesRequest::BtApplicationQuerySupportedProfilesRequest ( BtDeviceListWindow * device_list_window )

BtApplicationQuerySupportedProfilesRequest::~BtApplicationQuerySupportedProfilesRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationQuerySupportedProfilesRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationRespondAuthorizationRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationRespondAuthorizationRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationRespondAuthorizationRequest:

[legend]
Collaboration diagram for BtApplicationRespondAuthorizationRequest:

[legend]

Public Member Functions

BtApplicationRespondAuthorizationRequest ()
Constructor.
virtual | ~BtApplicationRespondAuthorizationRequest ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtRespondAuthorizationRequest

Constructor & Destructor Documentation

BtApplicationRespondAuthorizationRequest::BtApplicationRespondAuthorizationRequest ( )

Constructor.

BtApplicationRespondAuthorizationRequest::~BtApplicationRespondAuthorizationRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationRespondAuthorizationRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationSendPasskeyRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationSendPasskeyRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationSendPasskeyRequest:

[legend]
Collaboration diagram for BtApplicationSendPasskeyRequest:

[legend]

Public Member Functions

BtApplicationSendPasskeyRequest ()
Constructor.
virtual | ~BtApplicationSendPasskeyRequest ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtSendPasskeyReqeust

Constructor & Destructor Documentation

BtApplicationSendPasskeyRequest::BtApplicationSendPasskeyRequest ( )

Constructor.

BtApplicationSendPasskeyRequest::~BtApplicationSendPasskeyRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationSendPasskeyRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationServiceVerifyRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationServiceVerifyRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationServiceVerifyRequest:

[legend]
Collaboration diagram for BtApplicationServiceVerifyRequest:

[legend]

Public Member Functions

BtApplicationServiceVerifyRequest (BtDeviceListWindow *device_list_window)
virtual | ~BtApplicationServiceVerifyRequest ()

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtServiceVerifyRequest

Constructor & Destructor Documentation

BtApplicationServiceVerifyRequest::BtApplicationServiceVerifyRequest ( BtDeviceListWindow * device_list_window )

BtApplicationServiceVerifyRequest::~BtApplicationServiceVerifyRequest ( ) [virtual]

Member Function Documentation

void BtApplicationServiceVerifyRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtApplicationSetRemoteDeviceNameRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtApplicationSetRemoteDeviceNameRequest Class Reference

#include <Applications/BtApp/BtApplicationRequests.hpp>

Inheritance diagram for BtApplicationSetRemoteDeviceNameRequest:

[legend]
Collaboration diagram for BtApplicationSetRemoteDeviceNameRequest:

[legend]

Public Member Functions

BtApplicationSetRemoteDeviceNameRequest (BtDeviceListWindow *device_list_window)
Constructor.
virtual | ~BtApplicationSetRemoteDeviceNameRequest ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)
Request state change handling member function.

Detailed Description

Derived from class BtSetRemoteDeviceNameRequest

Constructor & Destructor Documentation

BtApplicationSetRemoteDeviceNameRequest::BtApplicationSetRemoteDeviceNameRequest ( BtDeviceListWindow * device_list_window )

Constructor.

BtApplicationSetRemoteDeviceNameRequest::~BtApplicationSetRemoteDeviceNameRequest ( ) [virtual]

Destructor.

Member Function Documentation

void BtApplicationSetRemoteDeviceNameRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implements BtLocalRequest.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationRequests.hpp
  • Applications/BtApp/BtApplicationRequests.cpp
Generated on Wed Jan 25 00:58:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAttributeId Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAttributeId Struct Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtTypes.hpp>

Data Fields

union {
UINT16 id
UINT16 range [2]
} attribute
BOOLEAN attribute_range

Field Documentation

union { ... } BtAttributeId::attribute

BOOLEAN BtAttributeId::attribute_range

UINT16 BtAttributeId::id

UINT16 BtAttributeId::range[2]

The documentation for this struct was generated from the following file:
  • Bluetooth/BtTypes.hpp
Generated on Wed Jan 25 00:58:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAudioAccessoryService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAudioAccessoryService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtAudioAccessoryService.hpp>

Inheritance diagram for BtAudioAccessoryService:

[legend]
Collaboration diagram for BtAudioAccessoryService:

[legend]

Public Member Functions

BtAudioAccessoryService (const BtDevice &target_device)
Constructor.
BtAudioAccessoryService ()
Constructor.
virtual BtRequestState | ConnectRequest ()=0
virtual BtRequestState | DisconnectRequest ()=0
BOOLEAN | GetAudioAlwaysOnAccessory () const
virtual UINT8 | GetMicrophoneGain () const =0
virtual UINT8 | GetSpeakerGain () const =0
BOOLEAN | GetUseInbandRinging () const
virtual BOOLEAN | IsConnected () const =0
virtual BOOLEAN | IsInCall () const =0
virtual BOOLEAN | IsRinging () const =0
void | SetAudioAlwaysOnAccessory (BOOLEAN audio_always_on_accessory)
virtual BtRequestState | SetMicrophoneGainRequest (INT8 gain_offset)=0
virtual BtRequestState | SetSpeakerGainRequest (INT8 gain_offset)=0
virtual void | SetUseInbandRinging (BOOLEAN use_inband_ringing)
virtual BtRequestState | TransferAudioToAccessoryRequest ()=0
virtual BtRequestState | TransferAudioToPhoneRequest ()=0
virtual | ~BtAudioAccessoryService ()
Destructor.

Constructor & Destructor Documentation

BtAudioAccessoryService::BtAudioAccessoryService ( )

Constructor.

BtAudioAccessoryService::BtAudioAccessoryService ( const BtDevice & target_device )

Constructor.

BtAudioAccessoryService::~BtAudioAccessoryService ( ) [virtual]

Destructor.

Member Function Documentation

virtual BtRequestState BtAudioAccessoryService::ConnectRequest ( ) [pure virtual]

Implemented in BtHfService, and BtHsService.

virtual BtRequestState BtAudioAccessoryService::DisconnectRequest ( ) [pure virtual]

Implemented in BtHfService, and BtHsService.

BOOLEAN BtAudioAccessoryService::GetAudioAlwaysOnAccessory ( ) const

virtual UINT8 BtAudioAccessoryService::GetMicrophoneGain ( ) const [pure virtual]

Implemented in BtHfService, and BtHsService.

virtual UINT8 BtAudioAccessoryService::GetSpeakerGain ( ) const [pure virtual]

Implemented in BtHfService, and BtHsService.

BOOLEAN BtAudioAccessoryService::GetUseInbandRinging ( ) const

virtual BOOLEAN BtAudioAccessoryService::IsConnected ( ) const [pure virtual]

Implemented in BtHfService, and BtHsService.

virtual BOOLEAN BtAudioAccessoryService::IsInCall ( ) const [pure virtual]

Implemented in BtHfService, and BtHsService.

virtual BOOLEAN BtAudioAccessoryService::IsRinging ( ) const [pure virtual]

Implemented in BtHfService, and BtHsService.

void BtAudioAccessoryService::SetAudioAlwaysOnAccessory ( BOOLEAN audio_always_on_accessory )

virtual BtRequestState BtAudioAccessoryService::SetMicrophoneGainRequest ( INT8 gain_offset ) [pure virtual]

Implemented in BtHfService, and BtHsService.

virtual BtRequestState BtAudioAccessoryService::SetSpeakerGainRequest ( INT8 gain_offset ) [pure virtual]

Implemented in BtHfService, and BtHsService.

void BtAudioAccessoryService::SetUseInbandRinging ( BOOLEAN use_inband_ringing ) [virtual]

Reimplemented in BtHfService.

virtual BtRequestState BtAudioAccessoryService::TransferAudioToAccessoryRequest ( ) [pure virtual]

Implemented in BtHfService, and BtHsService.

virtual BtRequestState BtAudioAccessoryService::TransferAudioToPhoneRequest ( ) [pure virtual]

Implemented in BtHfService, and BtHsService.

The documentation for this class was generated from the following files:
  • Bluetooth/BtAudioAccessoryService.hpp
  • Bluetooth/BtAudioAccessoryService.cpp
Generated on Wed Jan 25 00:58:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAuthorizationRequiredMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAuthorizationRequiredMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapApplicationMessage.hpp>

Inheritance diagram for BtAuthorizationRequiredMessage:

[legend]
Collaboration diagram for BtAuthorizationRequiredMessage:

[legend]

Public Types

enum | { ID = 10013 }

Public Member Functions

BtAuthorizationRequiredMessage (const BtResultCode &result, const BtDeviceAddress &device_address, const WString &device_name, const BtProfile &profile)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const BtProfile & | GetProfile () const
void | SetProfile (const BtProfile &profile)
virtual | ~BtAuthorizationRequiredMessage ()

Detailed Description

BtAuthorizationRequiredMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtAuthorizationRequiredMessage::BtAuthorizationRequiredMessage | ( | const BtResultCode & | result,
 |  | const BtDeviceAddress & | device_address,
 |  | const WString & | device_name,
 |  | const BtProfile & | profile
 | ) |

BtAuthorizationRequiredMessage::~BtAuthorizationRequiredMessage ( ) [virtual]

Member Function Documentation

Message * BtAuthorizationRequiredMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRemoteRequestMessage.

const MsgMetaData & BtAuthorizationRequiredMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRemoteRequestMessage.

const BtProfile& BtAuthorizationRequiredMessage::GetProfile ( ) const [inline]

void BtAuthorizationRequiredMessage::SetProfile ( const BtProfile & profile ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapApplicationMessage.hpp
  • Bluetooth/BtGapAndSdapApplicationMessage.cpp
Generated on Wed Jan 25 00:58:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAuthorizationRequiredWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAuthorizationRequiredWindow Class Reference

#include <Applications/BtApp/BtApplicationWindows.hpp>

Collaboration diagram for BtAuthorizationRequiredWindow:

[legend]

Public Member Functions

BtAuthorizationRequiredWindow ()
void | Init ()
void | SetProfile (BtProfile profile)
void | SetRemoteDeviceAddress (const BtDeviceAddress &remote_device_address)
void | SetRemoteDeviceName (const WString &remote_device_name)
virtual | ~BtAuthorizationRequiredWindow ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual BOOLEAN | OnKeyDown (KeyCode code)
virtual void | OnLayoutClient ()
virtual void | OnOpen ()

Detailed Description

BtAuthorizationRequiredWindow window is used to ask user whether accept connection request from remote device or not

Constructor & Destructor Documentation

BtAuthorizationRequiredWindow::BtAuthorizationRequiredWindow ( )

BtAuthorizationRequiredWindow::~BtAuthorizationRequiredWindow ( ) [virtual]

Member Function Documentation

void BtAuthorizationRequiredWindow::Init ( )

BOOLEAN BtAuthorizationRequiredWindow::OnCancel ( ) [protected, virtual]

BOOLEAN BtAuthorizationRequiredWindow::OnConfirm ( ) [protected, virtual]

BOOLEAN BtAuthorizationRequiredWindow::OnKeyDown ( KeyCode code ) [protected, virtual]

void BtAuthorizationRequiredWindow::OnLayoutClient ( ) [protected, virtual]

void BtAuthorizationRequiredWindow::OnOpen ( ) [protected, virtual]

void BtAuthorizationRequiredWindow::SetProfile ( BtProfile profile )

void BtAuthorizationRequiredWindow::SetRemoteDeviceAddress ( const BtDeviceAddress & remote_device_address )

void BtAuthorizationRequiredWindow::SetRemoteDeviceName ( const WString & remote_device_name )

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationWindows.hpp
  • Applications/BtApp/BtApplicationWindows.cpp
Generated on Wed Jan 25 00:58:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpAlertMessageWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpAlertMessageWindow Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.hpp>

Public Types

enum BtAmwType {
BtAmwAvrcpRegister, BtAmwAvrcpDeRegister, BtAmwAvrcpConnect, BtAmwAvrcpDisconnect,
BtAmwAvrcpPanelPassthrough, BtAmwAvrcpRawFrame, BtAmwAvrcpUnitInfo, BtAmwAvrcpSubunitInfo,
BtAmwNotCongested, BtAmwAvrcpDeviceSelected
}

Public Member Functions

BtAvrcpAlertMessageWindow ()
void | Display (BtAmwType amw_type, BOOLEAN success)
void | Init ()
virtual | ~BtAvrcpAlertMessageWindow ()

Member Enumeration Documentation

enum BtAvrcpAlertMessageWindow::BtAmwType

Enumerator:
BtAmwAvrcpRegister
BtAmwAvrcpDeRegister
BtAmwAvrcpConnect
BtAmwAvrcpDisconnect
BtAmwAvrcpPanelPassthrough
BtAmwAvrcpRawFrame
BtAmwAvrcpUnitInfo
BtAmwAvrcpSubunitInfo
BtAmwNotCongested
BtAmwAvrcpDeviceSelected

Constructor & Destructor Documentation

BtAvrcpAlertMessageWindow::BtAvrcpAlertMessageWindow ( )

Constructor

BtAvrcpAlertMessageWindow::~BtAvrcpAlertMessageWindow ( ) [virtual]

Destructor

Member Function Documentation

void BtAvrcpAlertMessageWindow::Display | ( | BtAmwType | amw_type,
 |  | BOOLEAN | success
 | ) |

Display

void BtAvrcpAlertMessageWindow::Init ( )

Init

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.hpp
  • Applications/BluetoothAvrcp/BtAvrcpAlertMessageWindow.cpp
Generated on Wed Jan 25 00:58:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpCommandInterface Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpCommandInterface Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpCommandInterface.hpp>

Public Member Functions

virtual AvrcpResponse OnAvrcpCommand (AvrcpCommand cmd) const =0

Member Function Documentation

virtual AvrcpResponse BtAvrcpCommandInterface::OnAvrcpCommand ( AvrcpCommand cmd ) const [pure virtual]

Plugin applications which inherit this class should implement this function. This function is invoked by MMI Panel application on receiving BT Apoxi notification. It is assumed that the method would return immediately.

The documentation for this class was generated from the following file:
  • Applications/BluetoothAvrcp/BtAvrcpCommandInterface.hpp
Generated on Wed Jan 25 00:58:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpConnectResponse Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpConnectResponse Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp>

Inheritance diagram for BtAvrcpConnectResponse:

[legend]
Collaboration diagram for BtAvrcpConnectResponse:

[legend]

Public Member Functions

BtAvrcpConnectResponse (BtAvrcpOperationService &avrcp_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetBtapiHandle (btapi_avrcp_handle_t hdl)
virtual | ~BtAvrcpConnectResponse ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.

Friends

class | BtAvrcpOperationController
class | BtAvrcpOperationService

Constructor & Destructor Documentation

BtAvrcpConnectResponse::BtAvrcpConnectResponse ( BtAvrcpOperationService & avrcp_service )

Constructor.

BtAvrcpConnectResponse::~BtAvrcpConnectResponse ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtAvrcpConnectResponse::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtRequestType BtAvrcpConnectResponse::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

void BtAvrcpConnectResponse::SetBtapiHandle ( btapi_avrcp_handle_t hdl ) [inline]

Friends And Related Function Documentation

friend class BtAvrcpOperationController [friend]

Reimplemented from BtAvrcpRequest.

friend class BtAvrcpOperationService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpConnectResponse.hpp
  • Bluetooth/AVRCP/BtAvrcpConnectResponse.cpp
Generated on Wed Jan 25 00:58:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpControllerApplicationWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpControllerApplicationWindow Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp>

Collaboration diagram for BtAvrcpControllerApplicationWindow:

[legend]

Public Types

enum | { AvrcpNotSelected = 0, AvrcpNotConnected, AvrcpConnected, AvrcpConnectedAndActive }

Public Member Functions

BtAvrcpControllerApplicationWindow ()
void | ControllerConnectRequest ()
void | ControllerDisconnectRequest ()
void | ControllerSelectDeviceRequest ()
void | ControllerSetActiveDeviceRequest ()
void | ControllerSetInactiveDeviceRequest ()
void | ControllerSubUnitInfoRequest ()
void | DeleteAllDeviceListItems ()
INT | GetDeviceCount ()
INT | GetPairedDeviceCount ()
INT | GetSelectedDeviceState ()
void | Init (BtAvrcpPanelApplication *avrcp_panel_app)
void | OnConnectRequestFinished (BOOLEAN success)
void | OnDisconnectRequestFinished (BOOLEAN success)
void | OnPanelPassthroughRequestFinished (BOOLEAN success)
void | OnSubUnitInfoRequestFinished (BOOLEAN success)
virtual | ~BtAvrcpControllerApplicationWindow ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnOpen ()

Member Enumeration Documentation

anonymous enum

Enumerator:
AvrcpNotSelected
AvrcpNotConnected
AvrcpConnected
AvrcpConnectedAndActive

Constructor & Destructor Documentation

BtAvrcpControllerApplicationWindow::BtAvrcpControllerApplicationWindow ( )

Constructor

BtAvrcpControllerApplicationWindow::~BtAvrcpControllerApplicationWindow ( ) [virtual]

Destructor

Member Function Documentation

void BtAvrcpControllerApplicationWindow::ControllerConnectRequest ( )

ControllerConnectRequest

void BtAvrcpControllerApplicationWindow::ControllerDisconnectRequest ( )

ControllerDisconnectRequest

void BtAvrcpControllerApplicationWindow::ControllerSelectDeviceRequest ( )

ControllerSelectDeviceRequest

void BtAvrcpControllerApplicationWindow::ControllerSetActiveDeviceRequest ( )

ControllerSetActiveDeviceRequest

void BtAvrcpControllerApplicationWindow::ControllerSetInactiveDeviceRequest ( )

ControllerSetInactiveDeviceRequest

void BtAvrcpControllerApplicationWindow::ControllerSubUnitInfoRequest ( )

ControllerSubUnitInfoRequest

void BtAvrcpControllerApplicationWindow::DeleteAllDeviceListItems ( )

DeleteAllDeviceListItems

INT BtAvrcpControllerApplicationWindow::GetDeviceCount ( )

GetDeviceCount

INT BtAvrcpControllerApplicationWindow::GetPairedDeviceCount ( )

GetPairedDeviceCount

INT BtAvrcpControllerApplicationWindow::GetSelectedDeviceState ( )

GetSelectedDeviceState

void BtAvrcpControllerApplicationWindow::Init ( BtAvrcpPanelApplication * avrcp_panel_app )

Init

BOOLEAN BtAvrcpControllerApplicationWindow::OnConfirm ( ) [protected, virtual]

OnConfirm is the virtual function which will be invoked when user selects LSK

void BtAvrcpControllerApplicationWindow::OnConnectRequestFinished ( BOOLEAN success )

OnConnectRequestFinished

void BtAvrcpControllerApplicationWindow::OnDisconnectRequestFinished ( BOOLEAN success )

OnDisconnectRequestFinished

void BtAvrcpControllerApplicationWindow::OnGetFocus ( ) [protected, virtual]

OnGetFocus is the virtual function which will be invoked when window gets the focus

BOOLEAN BtAvrcpControllerApplicationWindow::OnKeyDown ( KeyCode key_code ) [protected, virtual]

On Key Down

void BtAvrcpControllerApplicationWindow::OnOpen ( ) [protected, virtual]

Invoked on open

void BtAvrcpControllerApplicationWindow::OnPanelPassthroughRequestFinished ( BOOLEAN success )

OnPanelPassthroughRequestFinished

void BtAvrcpControllerApplicationWindow::OnSubUnitInfoRequestFinished ( BOOLEAN success )

OnSubUnitInfoRequestFinished

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp
  • Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.cpp
Generated on Wed Jan 25 00:58:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpControllerDeviceListItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpControllerDeviceListItem Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp>

Inheritance diagram for BtAvrcpControllerDeviceListItem:

[legend]
Collaboration diagram for BtAvrcpControllerDeviceListItem:

[legend]

Public Member Functions

BtAvrcpControllerDeviceListItem (Dispatcher *dispatcher, const WString &device_name, const BtDeviceAddress &device_address)
const BtDeviceAddress & | GetDeviceAddress () const
UINT | GetLastPanelPassThroughRequest ()
BtAvrcpProfileOperationService * GetOperationService ()
BOOLEAN | GetPlayActive ()
const BtDevice & | GetTargetDevice () const
BOOLEAN | IsControllerConnected ()
void | SetLastPanelPassThroughRequest (UINT last_panel_passthrough_request)
void | SetOperationService (BtAvrcpProfileOperationService *avrcp_operation_service)
void | SetPlayActive (BOOLEAN active_flag)
void | SetTargetDevice (const BtDevice &target_device)
virtual | ~BtAvrcpControllerDeviceListItem ()

Constructor & Destructor Documentation

BtAvrcpControllerDeviceListItem::BtAvrcpControllerDeviceListItem | ( | Dispatcher * | dispatcher,
 |  | const WString & | device_name,
 |  | const BtDeviceAddress & | device_address
 | ) |

Constructor

BtAvrcpControllerDeviceListItem::~BtAvrcpControllerDeviceListItem ( ) [virtual]

Destructor

Member Function Documentation

const BtDeviceAddress & BtAvrcpControllerDeviceListItem::GetDeviceAddress ( ) const

Get the device address

UINT BtAvrcpControllerDeviceListItem::GetLastPanelPassThroughRequest ( )

BtAvrcpProfileOperationService * BtAvrcpControllerDeviceListItem::GetOperationService ( )

GetOperationService

BOOLEAN BtAvrcpControllerDeviceListItem::GetPlayActive ( )

const BtDevice & BtAvrcpControllerDeviceListItem::GetTargetDevice ( ) const

GetTargetDevice

BOOLEAN BtAvrcpControllerDeviceListItem::IsControllerConnected ( )

IsControllerConnected

void BtAvrcpControllerDeviceListItem::SetLastPanelPassThroughRequest ( UINT last_panel_passthrough_request )

void BtAvrcpControllerDeviceListItem::SetOperationService ( BtAvrcpProfileOperationService * avrcp_operation_service )

SetOperationService

void BtAvrcpControllerDeviceListItem::SetPlayActive ( BOOLEAN active_flag )

void BtAvrcpControllerDeviceListItem::SetTargetDevice ( const BtDevice & target_device )

SetTargetDevice

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.hpp
  • Applications/BluetoothAvrcp/BtAvrcpControllerApplicationWindows.cpp
Generated on Wed Jan 25 00:58:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpControllerDeviceListWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpControllerDeviceListWindow Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.hpp>

Inheritance diagram for BtAvrcpControllerDeviceListWindow:

[legend]
Collaboration diagram for BtAvrcpControllerDeviceListWindow:

[legend]

Public Member Functions

BtAvrcpControllerDeviceListWindow ()
void | Init (BtAvrcpPanelApplication *avrcp_panel_app, AbstractItemContainer *item_container)
virtual | ~BtAvrcpControllerDeviceListWindow ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnGetFocus ()
virtual void | OnOpen ()
virtual void | OnSelectionChanged ()

Constructor & Destructor Documentation

BtAvrcpControllerDeviceListWindow::BtAvrcpControllerDeviceListWindow ( )

Constructor

BtAvrcpControllerDeviceListWindow::~BtAvrcpControllerDeviceListWindow ( ) [virtual]

Destructor

Member Function Documentation

void BtAvrcpControllerDeviceListWindow::Init | ( | BtAvrcpPanelApplication * | avrcp_panel_app,
 |  | AbstractItemContainer * | item_container
 | ) |

Init

BOOLEAN BtAvrcpControllerDeviceListWindow::OnConfirm ( ) [protected, virtual]

OnGetFocus is the virtual function which will be invoked when user selects RSK for the item selected

Reimplemented from AtlWindow.

void BtAvrcpControllerDeviceListWindow::OnGetFocus ( ) [protected, virtual]

OnGetFocus is the virtual function which will be invoked when window gets the focus

Reimplemented from AtlItemGridWindow.

void BtAvrcpControllerDeviceListWindow::OnOpen ( ) [protected, virtual]

Invoked on open

Reimplemented from AtlItemListWindow.

void BtAvrcpControllerDeviceListWindow::OnSelectionChanged ( ) [protected, virtual]

OnSelectionChanged is the virtual function which will be invoked when user changes the selection

Reimplemented from AtlItemListWindow.

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.hpp
  • Applications/BluetoothAvrcp/BtAvrcpControllerDeviceListWindow.cpp
Generated on Wed Jan 25 00:58:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpDeRegisterRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpDeRegisterRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp>

Inheritance diagram for BtAvrcpDeRegisterRequest:

[legend]
Collaboration diagram for BtAvrcpDeRegisterRequest:

[legend]

Public Member Functions

BtAvrcpDeRegisterRequest (BtAvrcpRegistrationService &avrcp_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtAvrcpRole | GetRole () const
void | SetRole (BtAvrcpRole role)
virtual | ~BtAvrcpDeRegisterRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.

Friends

class | BtAvrcpRegistrationController
class | BtAvrcpRegistrationService

Constructor & Destructor Documentation

BtAvrcpDeRegisterRequest::BtAvrcpDeRegisterRequest ( BtAvrcpRegistrationService & avrcp_service )

Constructor.

BtAvrcpDeRegisterRequest::~BtAvrcpDeRegisterRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtAvrcpDeRegisterRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtRequestType BtAvrcpDeRegisterRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtAvrcpRole BtAvrcpDeRegisterRequest::GetRole ( ) const [inline]

void BtAvrcpDeRegisterRequest::SetRole ( BtAvrcpRole role ) [inline]

Friends And Related Function Documentation

friend class BtAvrcpRegistrationController [friend]

friend class BtAvrcpRegistrationService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.hpp
  • Bluetooth/AVRCP/BtAvrcpDeRegisterRequest.cpp
Generated on Wed Jan 25 00:58:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpDeviceListWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpDeviceListWin Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.hpp>

Inheritance diagram for BtAvrcpDeviceListWin:

[legend]
Collaboration diagram for BtAvrcpDeviceListWin:

[legend]

Public Member Functions

BtAvrcpDeviceListWin ()
void | Init (BtAvrcpPanelApplication *avrcp_panel_app, AbstractItemContainer *item_container)
virtual | ~BtAvrcpDeviceListWin ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnGetFocus ()
virtual void | OnOpen ()
virtual void | OnSelectionChanged ()

Constructor & Destructor Documentation

BtAvrcpDeviceListWin::BtAvrcpDeviceListWin ( )

Constructor

BtAvrcpDeviceListWin::~BtAvrcpDeviceListWin ( ) [virtual]

Destructor

Member Function Documentation

void BtAvrcpDeviceListWin::Init | ( | BtAvrcpPanelApplication * | avrcp_panel_app,
 |  | AbstractItemContainer * | item_container
 | ) |

Init

BOOLEAN BtAvrcpDeviceListWin::OnConfirm ( ) [protected, virtual]

OnGetFocus is the virtual function which will be invoked when user selects RSK for the item selected

Reimplemented from AtlWindow.

void BtAvrcpDeviceListWin::OnGetFocus ( ) [protected, virtual]

OnGetFocus is the virtual function which will be invoked when window gets the focus

Reimplemented from AtlItemGridWindow.

void BtAvrcpDeviceListWin::OnOpen ( ) [protected, virtual]

Invoked on open

Reimplemented from AtlItemListWindow.

void BtAvrcpDeviceListWin::OnSelectionChanged ( ) [protected, virtual]

OnSelectionChanged is the virtual function which will be invoked when user changes the selection

Reimplemented from AtlItemListWindow.

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.hpp
  • Applications/BluetoothAvrcp/BtAvrcpPanelApplicationWindows.cpp
Generated on Wed Jan 25 00:58:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpMessageArgumentsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpMessageArgumentsDestroyTableNode Class Reference

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpMessageArguments.hpp>

Inheritance diagram for BtAvrcpMessageArgumentsDestroyTableNode:

[legend]
Collaboration diagram for BtAvrcpMessageArgumentsDestroyTableNode:

[legend]

Static Public Member Functions

static BtAvrcpMessageArgumentsDestroyTableNode * GetInstance ()

Member Function Documentation

BtAvrcpMessageArgumentsDestroyTableNode * BtAvrcpMessageArgumentsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpMessageArguments.hpp
  • Bluetooth/AVRCP/BtAvrcpMessageArguments.cpp
Generated on Wed Jan 25 00:58:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpNmaConnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpNmaConnect Class Reference

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp>

Inheritance diagram for BtAvrcpNmaConnect:

[legend]
Collaboration diagram for BtAvrcpNmaConnect:

[legend]

Public Types

enum | { ID = 10 }

Public Member Functions

BtAvrcpNmaConnect ()
BtAvrcpNmaConnect (const btapi_avrcp_connect_handle_t &btapi_hdl)
const btapi_avrcp_connect_handle_t & | GetBtapiHdl () const
~BtAvrcpNmaConnect ()

Static Public Member Functions

static const BtAvrcpNmaConnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtAvrcpMessageArgumentsDestroyTableNode

Detailed Description

BtAvrcpNmaCommon

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtAvrcpNmaConnect::BtAvrcpNmaConnect ( const btapi_avrcp_connect_handle_t & btapi_hdl )

BtAvrcpNmaConnect::BtAvrcpNmaConnect ( )

BtAvrcpNmaConnect::~BtAvrcpNmaConnect ( )

Member Function Documentation

const BtAvrcpNmaConnect & BtAvrcpNmaConnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const btapi_avrcp_connect_handle_t& BtAvrcpNmaConnect::GetBtapiHdl ( ) const [inline]

Friends And Related Function Documentation

friend class BtAvrcpMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp
  • Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.cpp
Generated on Wed Jan 25 00:58:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpNmaDisconnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpNmaDisconnect Class Reference

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp>

Inheritance diagram for BtAvrcpNmaDisconnect:

[legend]
Collaboration diagram for BtAvrcpNmaDisconnect:

[legend]

Public Types

enum | { ID = 11 }

Public Member Functions

BtAvrcpNmaDisconnect ()
BtAvrcpNmaDisconnect (void *app_hdl)
void * | GetAppHdl () const
~BtAvrcpNmaDisconnect ()

Static Public Member Functions

static const BtAvrcpNmaDisconnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtAvrcpMessageArgumentsDestroyTableNode

Detailed Description

BtAvrcpNmaCommon

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtAvrcpNmaDisconnect::BtAvrcpNmaDisconnect ( void * app_hdl )

BtAvrcpNmaDisconnect::BtAvrcpNmaDisconnect ( )

BtAvrcpNmaDisconnect::~BtAvrcpNmaDisconnect ( )

Member Function Documentation

const BtAvrcpNmaDisconnect & BtAvrcpNmaDisconnect::Cast ( const StackMsgArgument & arg ) [inline, static]

void* BtAvrcpNmaDisconnect::GetAppHdl ( ) const [inline]

Friends And Related Function Documentation

friend class BtAvrcpMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.hpp
  • Bluetooth/AVRCP/BtAvrcpNotificationMessageArgument.cpp
Generated on Wed Jan 25 00:58:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpNmaPanelPassThrough Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpNmaPanelPassThrough Class Reference

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp>

Inheritance diagram for BtAvrcpNmaPanelPassThrough:

[legend]
Collaboration diagram for BtAvrcpNmaPanelPassThrough:

[legend]

Public Types

enum | { ID = 12 }

Public Member Functions

BtAvrcpNmaPanelPassThrough ()
BtAvrcpNmaPanelPassThrough (const BtAvrcpPanelPassThroughParams &panel_passthrough_params)
const BtAvrcpPanelPassThroughParams & | GetPanelPassthroughParams () const
~BtAvrcpNmaPanelPassThrough ()

Static Public Member Functions

static const BtAvrcpNmaPanelPassThrough & | Cast (const StackMsgArgument &arg)

Friends

class | BtAvrcpMessageArgumentsDestroyTableNode

Detailed Description

BtAvrcpNmaPanelPassThrough

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtAvrcpNmaPanelPassThrough::BtAvrcpNmaPanelPassThrough ( const BtAvrcpPanelPassThroughParams & panel_passthrough_params )

BtAvrcpNmaPanelPassThrough::BtAvrcpNmaPanelPassThrough ( )

BtAvrcpNmaPanelPassThrough::~BtAvrcpNmaPanelPassThrough ( )

Member Function Documentation

const BtAvrcpNmaPanelPassThrough & BtAvrcpNmaPanelPassThrough::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtAvrcpPanelPassThroughParams& BtAvrcpNmaPanelPassThrough::GetPanelPassthroughParams ( ) const [inline]

Friends And Related Function Documentation

friend class BtAvrcpMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp
  • Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.cpp
Generated on Wed Jan 25 00:58:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpNmaRawFrame Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpNmaRawFrame Class Reference

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp>

Inheritance diagram for BtAvrcpNmaRawFrame:

[legend]
Collaboration diagram for BtAvrcpNmaRawFrame:

[legend]

Public Types

enum | { ID = 13 }

Public Member Functions

BtAvrcpNmaRawFrame ()
BtAvrcpNmaRawFrame (const BtAvrcpRawFrameParams &raw_frame_params)
const BtAvrcpRawFrameParams & | GetRawFrameParams () const
~BtAvrcpNmaRawFrame ()

Static Public Member Functions

static const BtAvrcpNmaRawFrame & | Cast (const StackMsgArgument &arg)

Friends

class | BtAvrcpMessageArgumentsDestroyTableNode

Detailed Description

BtAvrcpNmaRawFrame

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtAvrcpNmaRawFrame::BtAvrcpNmaRawFrame ( const BtAvrcpRawFrameParams & raw_frame_params )

BtAvrcpNmaRawFrame::BtAvrcpNmaRawFrame ( )

BtAvrcpNmaRawFrame::~BtAvrcpNmaRawFrame ( )

Member Function Documentation

const BtAvrcpNmaRawFrame & BtAvrcpNmaRawFrame::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtAvrcpRawFrameParams& BtAvrcpNmaRawFrame::GetRawFrameParams ( ) const [inline]

Friends And Related Function Documentation

friend class BtAvrcpMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.hpp
  • Bluetooth/AVRCP/BtAvrcpOperationServiceMessageArgument.cpp
Generated on Wed Jan 25 00:58:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpNotificationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpNotificationMessage Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp>

Inheritance diagram for BtAvrcpNotificationMessage:

[legend]
Collaboration diagram for BtAvrcpNotificationMessage:

[legend]

Public Types

enum | { ID = 10450 }

Public Member Functions

BtAvrcpNotificationMessage (const BtAvrcpNotificationMessage &message)
Constructor.
BtAvrcpNotificationMessage (BtAvrcpOperationService *service, StackMsgArgument *argument=0)
Constructor.
BtAvrcpNotificationMessage (StackMsgArgument *argument=0)
Constructor.
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BtAvrcpOperationService * | GetService () const
virtual BtAvrcpNotificationMessage & | operator= (const BtAvrcpNotificationMessage &message)
virtual FromStackMsg & | operator= (const FromStackMsg &message)
virtual | ~BtAvrcpNotificationMessage ()
Destructor.

Detailed Description

The BtAvrcpNotificationMessage is sent in order to inform the application programmer of an incoming connect or disconnect. The parameters for connect (a so called stack, or btapi handle) is held as a parameter (stack message argument). The btapi handle has to be sent back to the stack, using an implementation of the BtAvrcpOperationService using the method ConnectResponse. In case of an incoming connect the application programmer needs to create a new instance of its BtAvrcpOperationServiceImpl. If this succeeds, one uses the instance to answer the incoming connect. In case of a disconnect notification the respective instance, which is passed in the Disconnect notification, has to be destroyed.

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpNotificationMessage.hpp
  • Bluetooth/AVRCP/BtAvrcpNotificationMessage.cpp
Generated on Wed Jan 25 00:58:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpOperationRequestResponse Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpOperationRequestResponse Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp>

Inheritance diagram for BtAvrcpOperationRequestResponse:

[legend]
Collaboration diagram for BtAvrcpOperationRequestResponse:

[legend]

Public Member Functions

BtAvrcpOperationRequestResponse (BtAvrcpOperationService &avrcp_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtAvrcpResponseType GetResponse ()
void | SetRequestType (BtRequestType request_type)
void | SetResponseType (BtAvrcpResponseType response)
virtual | ~BtAvrcpOperationRequestResponse ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.

Friends

class | BtAvrcpOperationController
class | BtAvrcpOperationService

Constructor & Destructor Documentation

BtAvrcpOperationRequestResponse::BtAvrcpOperationRequestResponse ( BtAvrcpOperationService & avrcp_service )

Constructor.

BtAvrcpOperationRequestResponse::~BtAvrcpOperationRequestResponse ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtAvrcpOperationRequestResponse::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtRequestType BtAvrcpOperationRequestResponse::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtAvrcpResponseType BtAvrcpOperationRequestResponse::GetResponse ( ) [inline]

void BtAvrcpOperationRequestResponse::SetRequestType ( BtRequestType request_type )

void BtAvrcpOperationRequestResponse::SetResponseType ( BtAvrcpResponseType response ) [inline]

Friends And Related Function Documentation

friend class BtAvrcpOperationController [friend]

Reimplemented from BtAvrcpRequest.

friend class BtAvrcpOperationService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.hpp
  • Bluetooth/AVRCP/BtAvrcpOperationRequestResponse.cpp
Generated on Wed Jan 25 00:58:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpOperationService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpOperationService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpOperationService.hpp>

Inheritance diagram for BtAvrcpOperationService:

[legend]
Collaboration diagram for BtAvrcpOperationService:

[legend]

Public Member Functions

BtAvrcpOperationService ()
BtRequestState ConnectRequest ()
BtRequestState | ConnectResponse (btapi_avrcp_handle_t avrcp_handle)
Connect response.
BtRequestState DisconnectRequest ()
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
BOOLEAN | GetSubunitInfo (BtAvrcpSubunitInfoParams &subunit_info)
BOOLEAN | GetUnitInfo (BtAvrcpUnitInfoParams &unit_info)
BOOLEAN | IsConnected () const
BtRequestState | OperationRequestResponse (BtRequestType request_type, BtAvrcpResponseType response)
Response to RawFrameRequest and PanelPassThroughRequest.
BtRequestState | PanelPassthroughRequest (BtAvrcpPanelPassThroughParams ppt_params)
BtRequestState | PanelPassthroughRequest (BtAvrcpOperation operation, BtAvrcpStateFlag state_flag)
BtRequestState | PanelPassthroughRequest (BtAvrcpOperation operation)
BtRequestState | RawFrameRequest (BtAvrcpRawFrameParams raw_frame_params)
BtRequestState | SubunitInfoRequest (UINT8 page)
subunit info request
BtRequestState UnitInfoRequest ()
virtual | ~BtAvrcpOperationService ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &message)
virtual void | OnPanelPassThrough (BtAvrcpPanelPassThroughParams panel_passthrough_params)
called when a Panel Pass Through Indication arrives
virtual void | OnRawFrame (BtAvrcpRawFrameParams raw_frame_params)
virtual void | RegisterMessages () const
virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)
notification mechanism for request state changes
virtual void | UnregisterMessages () const

Friends

class | BtAvrcpOperationController

Detailed Description

BtAvrcpOperationService needs to be instantiated by the MMI. It is the operational class for AVRCP, which enables the MMI programmer to send and receive AVRCP commands over the air. Pre-Condition for sending AVRCP commands is the registration of a controller service record using an implementation of BtAvrcpRegistrationService.

Constructor & Destructor Documentation

BtAvrcpOperationService::BtAvrcpOperationService ( )

Constructor, initializing all instances of requests and responses

BtAvrcpOperationService::~BtAvrcpOperationService ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtAvrcpOperationService::ConnectRequest ( )

ConnectRequest starts the execution of a Connect Request to a device (target or controller) which needs to be set first by using the GAP profile.

BtRequestState BtAvrcpOperationService::ConnectResponse ( btapi_avrcp_handle_t avrcp_handle )

Connect response.

BtRequestState BtAvrcpOperationService::DisconnectRequest ( )

DisconnectRequest starts the execution of a Disconnect Request to the device which is related to the BtAvrcpOperationService instance.

BtRequestState BtAvrcpOperationService::GetRequestState ( BtRequestType request_type ) const [virtual]

GetRequestState returns the current state of each request being executed.

Implements BtService.

BOOLEAN BtAvrcpOperationService::GetSubunitInfo ( BtAvrcpSubunitInfoParams & subunit_info )

GetSubunitInfo returns the subunit information on the remote connected unit of the page which was requested as last. The return value tells the application programmer whether the information is valid or not. Only if the application programmer executed the SubunitInfoRequest before GetSubunitInfo the returned values can be set right.

Parameters:
subunit_info A return parameter of type BtAvrcpSubunitInfoParams.
Returns:
BOOLEAN - indicating whether the delivered information can be valid.

BOOLEAN BtAvrcpOperationService::GetUnitInfo ( BtAvrcpUnitInfoParams & unit_info )

GetUnitInfo returns the information on the remote connected unit. The return value tells the application programmer whether the information is valid or not. Only if the application programmer executed the UnitInfoRequest before GetUnitInfo the returned values can be set right.

Parameters:
unit_info A return parameter of type BtAvrcpUnitInfoParams.
Returns:
BOOLEAN - indicating whether the delivered information can be valid.

BOOLEAN BtAvrcpOperationService::IsConnected ( ) const

IsConnected returns the state of the connection. As each instance of an BtAvrcpOperationService(Impl) represents a connection to a certain device the IsConnected method delivers the state of the certain connection the BtAvrcpOperationService is related to.

BOOLEAN BtAvrcpOperationService::OnMessage ( const Message & message ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Reimplemented from BtAvrcpService.

void BtAvrcpOperationService::OnPanelPassThrough ( BtAvrcpPanelPassThroughParams panel_passthrough_params ) [protected, virtual]

called when a Panel Pass Through Indication arrives

OnPanelPassThrough needs to be overwritten by the application programmer. It is called when a controller connects to APOXI as a target and when a PanelPassThroughInd is received. The method itself shall be called in case a panel passthrough command cannot directly executed. In this case the base class responds with BtArNotImplemented

Reimplemented in BtAvrcpProfileOperationService.

void BtAvrcpOperationService::OnRawFrame ( BtAvrcpRawFrameParams raw_frame_params ) [protected, virtual]

OnRawFrame compare to OnPanelPassThrough

Reimplemented in BtAvrcpProfileOperationService.

BtRequestState BtAvrcpOperationService::OperationRequestResponse | ( | BtRequestType | request_type,
 |  | BtAvrcpResponseType | response
 | ) |

Response to RawFrameRequest and PanelPassThroughRequest.

OperationRequestResponse needs to be called in case of an incoming PanelPassThroughRequest (executed by having the callback method OnPanelPassThrough called) or RawFrameRequest (OnRawFrame) in order to answer whether an operation is implemented or not.

Parameters:
request_type | BtRqtAvrcpPanelPassThroughRsp or BtRqtAvrcpRawFrameRsp
response | BtArNotImplemented, BtArAccepted, BtArRejected, BtArInTransition, BtArImplementedStable, BtArResponseChanged, BtArInterim

BtRequestState BtAvrcpOperationService::PanelPassthroughRequest ( BtAvrcpPanelPassThroughParams ppt_params )

PanelPassthroughRequest executes a full featured PanelPassThroughRequest over the air.

Parameters:
ppt_params An instance of BtAvrcpPanelPassThroughParams. Compare to class documentation.

BtRequestState BtAvrcpOperationService::PanelPassthroughRequest | ( | BtAvrcpOperation | operation,
 |  | BtAvrcpStateFlag | state_flag
 | ) |

PanelPassthroughRequest executes a BtAvrcpOperation over the air. Furthermore the application programmer has the possibility to send a certain key state.

Parameters:
operation | A BtAvrcpOperation
state_flag | Either BtAsfButtonPress or BtAsfButtonRelease

BtRequestState BtAvrcpOperationService::PanelPassthroughRequest ( BtAvrcpOperation operation )

PanelPassThroughRequest executes a BtAvrcpOperation over the air. The key state is key pressed. This is the main operation interface for AVRCP.

Parameters:
operation A BtAvrcpOperation.

BtRequestState BtAvrcpOperationService::RawFrameRequest ( BtAvrcpRawFrameParams raw_frame_params )

RawFrameRequest executes a RawFrame Request.

Parameters:
raw_frame_params An instance of BtAvrcpRawFrameParams. Compare to class documentation

void BtAvrcpOperationService::RegisterMessages ( ) const [protected, virtual]

RegisterMessages registers the BtAvrcpOperationServiceMessage which indicates incoming PanelPassThrough and RawFrame indications

Reimplemented from BtAvrcpService.

void BtAvrcpOperationService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

notification mechanism for request state changes

Implements BtService.

BtRequestState BtAvrcpOperationService::SubunitInfoRequest ( UINT8 page )

subunit info request

SubunitInfoRequest sends a Subunit Info Request over the air. After the SubunitInfoRequest is finished OK, the application programmer can get the subunit information of a remote device by executing the GetSubunitInfo command.

Parameters:
page The page to be read out of the remote device.

BtRequestState BtAvrcpOperationService::UnitInfoRequest ( )

UnitInfoRequest sends a Unit Info Request over the air. After the UnitInfoRequest is finished OK, the application programmer can get the unit information of a remote device by executing the GetUnitInfo command.

void BtAvrcpOperationService::UnregisterMessages ( ) const [protected, virtual]

UnregisterMessages

Reimplemented from BtAvrcpService.

Friends And Related Function Documentation

friend class BtAvrcpOperationController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpOperationService.hpp
  • Bluetooth/AVRCP/BtAvrcpOperationService.cpp
Generated on Wed Jan 25 00:58:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpOperationServiceMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpOperationServiceMessage Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.hpp>

Inheritance diagram for BtAvrcpOperationServiceMessage:

[legend]
Collaboration diagram for BtAvrcpOperationServiceMessage:

[legend]

Public Types

enum | { ID = 10451 }

Public Member Functions

BtAvrcpOperationServiceMessage (const BtAvrcpOperationServiceMessage &message)
Constructor.
BtAvrcpOperationServiceMessage (BtAvrcpOperationService *service, StackMsgArgument *argument=0)
Constructor.
BtAvrcpOperationServiceMessage (StackMsgArgument *argument=0)
Constructor.
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BtAvrcpOperationService * | GetService () const
virtual BtAvrcpOperationServiceMessage & | operator= (const BtAvrcpOperationServiceMessage &message)
virtual FromStackMsg & | operator= (const FromStackMsg &message)
virtual | ~BtAvrcpOperationServiceMessage ()
Destructor.

Detailed Description

Internal message class, used to notify a certain operation service of an incoming PanelPassThroughIndication or RawFrameIndication. If this message is received, dependent on the stack message argument, either OnPanelPassThrough or OnRawFrame in the corresponding BtAvrcpOperationService is called.

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.hpp
  • Bluetooth/AVRCP/BtAvrcpOperationServiceMessage.cpp
Generated on Wed Jan 25 00:58:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpPanelApplication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpPanelApplication Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp>

Collaboration diagram for BtAvrcpPanelApplication:

[legend]

Public Types

enum BtAvrcpPanelAppFeatures {
BtAvrcpPanelSetActiveSubUnit = 0, BtAvrcpOpenControllerWindow, BtAvrcpControllerSelectDeviceRequest, BtAvrcpControllerConnectRequest,
BtAvrcpControllerDisconnectRequest, BtAvrcpControllerSubUnitInfoRequest, BtAvrcpControllerSetActiveDeviceRequest, BtAvrcpControllerSetInactiveDeviceRequest,
BtAvrcpPanelFeatureCount
}
BtAvrcpPanel of Feature indizes. More...

Public Member Functions

BOOLEAN | ChangeActiveDevice (INT idx)
BOOLEAN | DeregisterAvrcpApp (WString &app_name)
BtAvrcpResponseType | OnPanelPassThrough (BtAvrcpPanelPassThroughParams ppt_params)
virtual void | OnStartup ()
BOOLEAN | RegisterAvrcpApp (WString &app_name, BtAvrcpCommandInterface &cmd_handle, MmiSubUnitType sub_unit_info)
void | UpdateContext ()
void | UpdateControllerDeviceListFeaturesAvailable ()
void | UpdateControllerFeaturesAvailable ()
virtual | ~BtAvrcpPanelApplication ()

Static Public Member Functions

static BtAvrcpPanelApplication * | GetInstance ()

Protected Member Functions

AvrcpCommand | ConvertBtApoxiOperationToMmiCommand (BtAvrcpOperation bt_apoxi_operation)
BtAvrcpResponseType | ConvertMmiResponseToApoxiResponse (AvrcpResponse mmi_response)
BtAvrcpSubunitType | GetBtApoxiAvrcpSubunitInfo (MmiSubUnitType sub_unit_info)
BOOLEAN | OnAvrcpNotification (const BtAvrcpNotificationMessage &avrcp_notification_message)
virtual void | OnClose ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &message)
virtual void | OnOpen ()
void | RegisterPanelToApoxiAvrcp ()
virtual void | UnregisterPanelToApoxiAvrcp ()

Detailed Description

BtAvrcpPanelApplication is application of bluetooth avrcp panel. Bt Avrcp Panel Application is the only interface between BT APOXI AVRCP and Audio/Video applications(such as Media player). This application is responsible for registering and unregistering to BT APOXI AVRCP. The operation requests from BT APOXI AVRCP are directed to active a/v plugin and the response is sent back to BT APOXI AVRCP.

Member Enumeration Documentation

enum BtAvrcpPanelApplication::BtAvrcpPanelAppFeatures

BtAvrcpPanel of Feature indizes.

Enumerator:
BtAvrcpPanelSetActiveSubUnit | To display list of subunits in order to set one among them as active.
BtAvrcpOpenControllerWindow | To open controller window.
BtAvrcpControllerSelectDeviceRequest | Select a bluetooth device.
BtAvrcpControllerConnectRequest | Connect request from the controller to a target.
BtAvrcpControllerDisconnectRequest | Disconnect request from the controller to a target.
BtAvrcpControllerSubUnitInfoRequest | Display Controller subunit informaion.
BtAvrcpControllerSetActiveDeviceRequest | Set Active bt device (shown only on AVRCP connected devices).
BtAvrcpControllerSetInactiveDeviceRequest | Set Inactive bt device (shown only on AVRCP connected and active device).
BtAvrcpPanelFeatureCount | Mandatory last entry.

Constructor & Destructor Documentation

BtAvrcpPanelApplication::~BtAvrcpPanelApplication ( ) [virtual]

Destructor

Member Function Documentation

BOOLEAN BtAvrcpPanelApplication::ChangeActiveDevice ( INT idx )

Sets the selected device as active

AvrcpCommand BtAvrcpPanelApplication::ConvertBtApoxiOperationToMmiCommand ( BtAvrcpOperation bt_apoxi_operation ) [protected]

In order to convert BtApoxi Avrcp Operation to Mmi command

BtAvrcpResponseType BtAvrcpPanelApplication::ConvertMmiResponseToApoxiResponse ( AvrcpResponse mmi_response ) [protected]

In order to convert Mmi response to Apoxi response

BOOLEAN BtAvrcpPanelApplication::DeregisterAvrcpApp ( WString & app_name )

Plugin A/V applications invoke DeregisterAvrcpApp to deregister themselves with Panel application

BtAvrcpSubunitType BtAvrcpPanelApplication::GetBtApoxiAvrcpSubunitInfo ( MmiSubUnitType sub_unit_info ) [protected]

In order to map MmiSubUnitType to BtAvrcpSubunitType

BtAvrcpPanelApplication * BtAvrcpPanelApplication::GetInstance ( ) [static]

Returns the instance already created (Singleton)

BOOLEAN BtAvrcpPanelApplication::OnAvrcpNotification ( const BtAvrcpNotificationMessage & avrcp_notification_message ) [protected]

Invoked by APOXI AVRCP when there is notification message

void BtAvrcpPanelApplication::OnClose ( ) [protected, virtual]

See also:
Application::OnClose()

BOOLEAN BtAvrcpPanelApplication::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

See also:
Application::OnFeatureTriggered()

BOOLEAN BtAvrcpPanelApplication::OnMessage ( const Message & message ) [protected, virtual]

See also:
Application::OnMessage()

void BtAvrcpPanelApplication::OnOpen ( ) [protected, virtual]

See also:
Application::OnOpen()

BtAvrcpResponseType BtAvrcpPanelApplication::OnPanelPassThrough ( BtAvrcpPanelPassThroughParams ppt_params )

Invoked when there are Panel pass through requests to be executed

void BtAvrcpPanelApplication::OnStartup ( ) [virtual]

Inherited and overloaded from MmiApplication Invoked on startup

BOOLEAN BtAvrcpPanelApplication::RegisterAvrcpApp | ( | WString & | app_name,
 |  | BtAvrcpCommandInterface & | cmd_handle,
 |  | MmiSubUnitType | sub_unit_info
 | ) |

Plugin A/V applications invoke RegisterAvrcpApp to register themselves to Panel application

void BtAvrcpPanelApplication::RegisterPanelToApoxiAvrcp ( ) [protected]

Registers Panel to APOXI AVRCP Invoked on startup, after the plugin media applications register themselves to Panel.

void BtAvrcpPanelApplication::UnregisterPanelToApoxiAvrcp ( ) [protected, virtual]

Unregisters Panel to APOXI AVRCP Invoked during the destruction of the panel app

void BtAvrcpPanelApplication::UpdateContext ( )

Invoked before displaying the device(sub-unit) list window Also invoked when there is change in selection of items in the list. This is to update the Soft key context.

void BtAvrcpPanelApplication::UpdateControllerDeviceListFeaturesAvailable ( )

Sets the feature availability for the controller device list window menu

void BtAvrcpPanelApplication::UpdateControllerFeaturesAvailable ( )

Sets the feature availability for the controller menu

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp
  • Applications/BluetoothAvrcp/BtAvrcpPanelApplication.cpp
Generated on Wed Jan 25 00:58:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpPanelPassThroughParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpPanelPassThroughParams Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp>

Public Member Functions

BtAvrcpPanelPassThroughParams (BtAvrcpOperation operation, BtAvrcpStateFlag state)
Constructor passing an operational code and a state flag (button press/release).
BtAvrcpPanelPassThroughParams ()
Constructor.
const BtAvrcpOperation | GetOperation () const
const UINT8 * | GetOperationData () const
const UINT8 | GetOperationDataLength () const
const BtAvrcpStateFlag | GetState () const
BOOLEAN | ReleaseOperationData ()
void | SetOperation (BtAvrcpOperation operation)
BOOLEAN | SetOperationData (UINT8 *operation_data)
void | SetOperationDataLength (UINT8 data_length)
void | SetState (BtAvrcpStateFlag state)
virtual | ~BtAvrcpPanelPassThroughParams ()
Destructor.

Detailed Description

Parameters which have to be passed for a panel pass through request. Furthermore this parameter class is used for indicating an incoming panel pass through request when implementing AVRCP target functionality.

Constructor & Destructor Documentation

BtAvrcpPanelPassThroughParams::BtAvrcpPanelPassThroughParams ( )

Constructor.

BtAvrcpPanelPassThroughParams::BtAvrcpPanelPassThroughParams | ( | BtAvrcpOperation | operation,
 |  | BtAvrcpStateFlag | state
 | ) |

Constructor passing an operational code and a state flag (button press/release).

BtAvrcpPanelPassThroughParams::~BtAvrcpPanelPassThroughParams ( ) [virtual]

Destructor.

Member Function Documentation

const BtAvrcpOperation BtAvrcpPanelPassThroughParams::GetOperation ( ) const [inline]

Get operational code

const UINT8* BtAvrcpPanelPassThroughParams::GetOperationData ( ) const [inline]

Get Operation Data (used for vendor unique operation of commands)

const UINT8 BtAvrcpPanelPassThroughParams::GetOperationDataLength ( ) const [inline]

Get Operation Data Length (used for vendor unique extension of commands)

const BtAvrcpStateFlag BtAvrcpPanelPassThroughParams::GetState ( ) const [inline]

Get state (BtAsfButtonPress, BtAsfButtonRelease)

BOOLEAN BtAvrcpPanelPassThroughParams::ReleaseOperationData ( )

free the memory after execution

void BtAvrcpPanelPassThroughParams::SetOperation ( BtAvrcpOperation operation ) [inline]

Set operational code

Parameters:
operational code

BOOLEAN BtAvrcpPanelPassThroughParams::SetOperationData ( UINT8 * operation_data )

Set Operation Data (used for vendor unique commands)

Parameters:
operation data

void BtAvrcpPanelPassThroughParams::SetOperationDataLength ( UINT8 data_length ) [inline]

Set Operation Data Length (used for vendor unique extension of commands)

Parameters:
operation data length

void BtAvrcpPanelPassThroughParams::SetState ( BtAvrcpStateFlag state ) [inline]

Set state flag (BtAsfButtonPress, BtAsfButtonRelease)

Parameters:
state BtAsfButtonRelease or BtAsfButtonPress

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.hpp
  • Bluetooth/AVRCP/BtAvrcpPanelPassThroughParams.cpp
Generated on Wed Jan 25 00:58:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpPanelPassThroughRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpPanelPassThroughRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp>

Inheritance diagram for BtAvrcpPanelPassThroughRequest:

[legend]
Collaboration diagram for BtAvrcpPanelPassThroughRequest:

[legend]

Public Member Functions

BtAvrcpPanelPassThroughRequest (BtAvrcpOperationService &avrcp_service)
Constructor.
BtAvrcpPanelPassThroughParams | GetPanelPassThroughParams () const
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtAvrcpResponseType GetResponse ()
BOOLEAN | ReleaseParams ()
free the memory
void | SetPanelPassThroughParams (BtAvrcpPanelPassThroughParams ppt_params)
void | SetResponse (btapi_avrcp_response_code_t response)
virtual | ~BtAvrcpPanelPassThroughRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.

Friends

class | BtAvrcpOperationController
class | BtAvrcpOperationService

Constructor & Destructor Documentation

BtAvrcpPanelPassThroughRequest::BtAvrcpPanelPassThroughRequest ( BtAvrcpOperationService & avrcp_service )

Constructor.

BtAvrcpPanelPassThroughRequest::~BtAvrcpPanelPassThroughRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtAvrcpPanelPassThroughRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtAvrcpPanelPassThroughParams BtAvrcpPanelPassThroughRequest::GetPanelPassThroughParams ( ) const [inline]

BtRequestType BtAvrcpPanelPassThroughRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtAvrcpResponseType BtAvrcpPanelPassThroughRequest::GetResponse ( ) [inline]

BOOLEAN BtAvrcpPanelPassThroughRequest::ReleaseParams ( )

free the memory

void BtAvrcpPanelPassThroughRequest::SetPanelPassThroughParams ( BtAvrcpPanelPassThroughParams ppt_params ) [inline]

void BtAvrcpPanelPassThroughRequest::SetResponse ( btapi_avrcp_response_code_t response ) [inline]

Friends And Related Function Documentation

friend class BtAvrcpOperationController [friend]

Reimplemented from BtAvrcpRequest.

friend class BtAvrcpOperationService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.hpp
  • Bluetooth/AVRCP/BtAvrcpPanelPassThroughRequest.cpp
Generated on Wed Jan 25 00:58:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpPanelService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpPanelService Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpPanelService.hpp>

Inheritance diagram for BtAvrcpPanelService:

[legend]

Public Member Functions

virtual BOOLEAN | DeregisterAvrcpApp (WString &app_name) const
Plugin applications invoke this to deregister themselves with Panel application.
virtual BOOLEAN | RegisterAvrcpApp (WString &app_name, BtAvrcpCommandInterface &cmd_handle, MmiSubUnitType sub_unit_info) const
Plugin applications invoke this to register themselves to Panel application.

Member Function Documentation

virtual BOOLEAN BtAvrcpPanelService::DeregisterAvrcpApp ( WString & app_name ) const [virtual]

Plugin applications invoke this to deregister themselves with Panel application.

Reimplemented in BtAvrcpPanelServiceImpl.

virtual BOOLEAN BtAvrcpPanelService::RegisterAvrcpApp | ( | WString & | app_name,
 |  | BtAvrcpCommandInterface & | cmd_handle,
 |  | MmiSubUnitType | sub_unit_info
 | ) | const [virtual]

Plugin applications invoke this to register themselves to Panel application.

Reimplemented in BtAvrcpPanelServiceImpl.

The documentation for this class was generated from the following file:
  • Applications/BluetoothAvrcp/BtAvrcpPanelService.hpp
Generated on Wed Jan 25 00:58:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpPanelServiceImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpPanelServiceImpl Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.hpp>

Inheritance diagram for BtAvrcpPanelServiceImpl:

[legend]
Collaboration diagram for BtAvrcpPanelServiceImpl:

[legend]

Public Member Functions

BtAvrcpPanelServiceImpl ()
virtual ServiceResult | DeregisterAvrcpApp (WString &app_name) const
Plugin applications invoke this to deregister themselves with Panel application.
void | Init (Application *app)
virtual ServiceResult | RegisterAvrcpApp (WString &app_name, BtAvrcpCommandInterface &cmd_handle, MmiSubUnitType sub_unit_info) const
Plugin applications invoke this to register themselves to Panel application.
virtual | ~BtAvrcpPanelServiceImpl ()

Constructor & Destructor Documentation

BtAvrcpPanelServiceImpl::BtAvrcpPanelServiceImpl ( )

BtAvrcpPanelServiceImpl::~BtAvrcpPanelServiceImpl ( ) [virtual]

Member Function Documentation

ServiceResult BtAvrcpPanelServiceImpl::DeregisterAvrcpApp ( WString & app_name ) const [virtual]

Plugin applications invoke this to deregister themselves with Panel application.

Reimplemented from BtAvrcpPanelService.

void BtAvrcpPanelServiceImpl::Init ( Application * app )

ServiceResult BtAvrcpPanelServiceImpl::RegisterAvrcpApp | ( | WString & | app_name,
 |  | BtAvrcpCommandInterface & | cmd_handle,
 |  | MmiSubUnitType | sub_unit_info
 | ) | const [virtual]

Plugin applications invoke this to register themselves to Panel application.

Reimplemented from BtAvrcpPanelService.

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.hpp
  • Applications/BluetoothAvrcp/BtAvrcpPanelServiceImpl.cpp
Generated on Wed Jan 25 00:58:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpProfileOperationService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpProfileOperationService Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp>

Inheritance diagram for BtAvrcpProfileOperationService:

[legend]
Collaboration diagram for BtAvrcpProfileOperationService:

[legend]

Public Member Functions

BtAvrcpProfileOperationService (BtAvrcpPanelApplication &panel_app, BtAvrcpAlertMessageWindow &alert_message_window, BtAvrcpControllerApplicationWindow &controller_win)
virtual | ~BtAvrcpProfileOperationService ()

Protected Member Functions

void | OnConnect (BtRequestState old_request_state, BtRequestState new_request_state)
void | OnDisconnect (BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | OnPanelPassThrough (BtAvrcpPanelPassThroughParams ppt_params)
void | OnPanelPassthrough (BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | OnRawFrame (BtAvrcpRawFrameParams raw_frame_paras)
void | OnRawFrame (BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
void | OnSubunitInfo (BtRequestState old_request_state, BtRequestState new_request_state)
void | OnUnitInfo (BtRequestState old_request_state, BtRequestState new_request_state)

Constructor & Destructor Documentation

BtAvrcpProfileOperationService::BtAvrcpProfileOperationService | ( | BtAvrcpPanelApplication & | panel_app,
 |  | BtAvrcpAlertMessageWindow & | alert_message_window,
 |  | BtAvrcpControllerApplicationWindow & | controller_win
 | ) |

Constructor

BtAvrcpProfileOperationService::~BtAvrcpProfileOperationService ( ) [virtual]

Destructor

Member Function Documentation

void BtAvrcpProfileOperationService::OnConnect | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

OnConnect invoked when there is change in state

void BtAvrcpProfileOperationService::OnDisconnect | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

OnDisconnect invoked when there is change in state

void BtAvrcpProfileOperationService::OnPanelPassThrough ( BtAvrcpPanelPassThroughParams ppt_params ) [protected, virtual]

OnPanelPassThrough invoked when there is change in state

Reimplemented from BtAvrcpOperationService.

void BtAvrcpProfileOperationService::OnPanelPassthrough | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

OnPanelPassthrough invoked when there is change in state

void BtAvrcpProfileOperationService::OnRawFrame ( BtAvrcpRawFrameParams raw_frame_paras ) [protected, virtual]

OnRawFrame invoked when there is change in state

Reimplemented from BtAvrcpOperationService.

void BtAvrcpProfileOperationService::OnRawFrame | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

OnRawFrame invoked when there is change in state

void BtAvrcpProfileOperationService::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

OnRequestStateChange invoked when there is change in state of the request type

Implements BtService.

void BtAvrcpProfileOperationService::OnSubunitInfo | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

OnSubunitInfo invoked when there is change in state

void BtAvrcpProfileOperationService::OnUnitInfo | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

OnUnitInfo invoked when there is change in state

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp
  • Applications/BluetoothAvrcp/BtAvrcpProfileService.cpp
Generated on Wed Jan 25 00:58:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpProfileRegistrationService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpProfileRegistrationService Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp>

Inheritance diagram for BtAvrcpProfileRegistrationService:

[legend]
Collaboration diagram for BtAvrcpProfileRegistrationService:

[legend]

Public Member Functions

BtAvrcpProfileRegistrationService (BtAvrcpAlertMessageWindow &alert_message_window)
virtual | ~BtAvrcpProfileRegistrationService ()

Protected Member Functions

void | OnDeRegister (BtRequestState old_request_state, BtRequestState new_request_state)
void | OnRegister (BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)

Constructor & Destructor Documentation

BtAvrcpProfileRegistrationService::BtAvrcpProfileRegistrationService ( BtAvrcpAlertMessageWindow & alert_message_window )

Constructor

BtAvrcpProfileRegistrationService::~BtAvrcpProfileRegistrationService ( ) [virtual]

Destructor

Member Function Documentation

void BtAvrcpProfileRegistrationService::OnDeRegister | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

OnDeRegister invoked when there is change in state

void BtAvrcpProfileRegistrationService::OnRegister | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

OnRegister invoked when there is change in state

void BtAvrcpProfileRegistrationService::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

OnRequestStateChange invoked when there is change in state of the request type

Implements BtService.

The documentation for this class was generated from the following files:
  • Applications/BluetoothAvrcp/BtAvrcpProfileService.hpp
  • Applications/BluetoothAvrcp/BtAvrcpProfileService.cpp
Generated on Wed Jan 25 00:58:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpRawFrameParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpRawFrameParams Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp>

Public Member Functions

BtAvrcpRawFrameParams ()
Constructor.
const BtAvrcpControlType | GetControlType () const
const BtAvrcpOpcode | GetOpCode () const
const UINT8 * | GetOperands () const
const UINT8 | GetOperandsLength () const
const UINT8 | GetSubunitId () const
const BtAvrcpSubunitType | GetSubunitType () const
BOOLEAN | ReleaseOperands ()
void | SetControlType (BtAvrcpControlType ctype)
BOOLEAN | SetOperands (UINT8 *operands)
void | SetOperandsLength (UINT8 operands_length)
void | SetSubunitId (UINT8 subunit_id)
void | SetSubunitType (BtAvrcpSubunitType subunit_type)
virtual | ~BtAvrcpRawFrameParams ()
Destructor.

Detailed Description

Parameters classed used for describing the parameters when sending a vendor unique command over the air. Furthermore this parameter class is used when implementing an AVRCP target to receive vendor unique commands.

Constructor & Destructor Documentation

BtAvrcpRawFrameParams::BtAvrcpRawFrameParams ( )

Constructor.

BtAvrcpRawFrameParams::~BtAvrcpRawFrameParams ( ) [virtual]

Destructor.

Member Function Documentation

const BtAvrcpControlType BtAvrcpRawFrameParams::GetControlType ( ) const [inline]

Get Control Type

Returns:
BtAvrcpControlType BtActControl, BtActStatus, BtActSpecificInquiry, BtActNotify, BtActGeneralInquiry

const BtAvrcpOpcode BtAvrcpRawFrameParams::GetOpCode ( ) const [inline]

Get Opcode - in case of raw frame always vendor dependent!

const UINT8* BtAvrcpRawFrameParams::GetOperands ( ) const [inline]

Get Operands - pointer to the data area

const UINT8 BtAvrcpRawFrameParams::GetOperandsLength ( ) const [inline]

Get Operands Length - the data length of the operation data

const UINT8 BtAvrcpRawFrameParams::GetSubunitId ( ) const [inline]

Get Subunit ID

const BtAvrcpSubunitType BtAvrcpRawFrameParams::GetSubunitType ( ) const [inline]

Get Subunit Type

BOOLEAN BtAvrcpRawFrameParams::ReleaseOperands ( )

ReleaseOperands frees the memory which has been allocated for the SetOperands operation.

void BtAvrcpRawFrameParams::SetControlType ( BtAvrcpControlType ctype ) [inline]

Set Control Type

Parameters:
type A BtAvrcpControlType

BOOLEAN BtAvrcpRawFrameParams::SetOperands ( UINT8 * operands )

Set Operands - the data for the operands is copied to a local structure.

Parameters:
operands

void BtAvrcpRawFrameParams::SetOperandsLength ( UINT8 operands_length ) [inline]

Set Operands Length

Parameters:
operands length

void BtAvrcpRawFrameParams::SetSubunitId ( UINT8 subunit_id ) [inline]

Set Subunit ID

Parameters:
Id

void BtAvrcpRawFrameParams::SetSubunitType ( BtAvrcpSubunitType subunit_type ) [inline]

Set Subunit Type

Parameters:
subunit type

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpRawFrameParams.hpp
  • Bluetooth/AVRCP/BtAvrcpRawFrameParams.cpp
Generated on Wed Jan 25 00:58:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpRawFrameRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpRawFrameRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp>

Inheritance diagram for BtAvrcpRawFrameRequest:

[legend]
Collaboration diagram for BtAvrcpRawFrameRequest:

[legend]

Public Member Functions

BtAvrcpRawFrameRequest (BtAvrcpOperationService &avrcp_service)
Constructor.
BtAvrcpRawFrameParams | GetRawFrameParams () const
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtAvrcpResponseType GetResponse ()
BOOLEAN | ReleaseParams ()
free the memory
void | SetRawFrameParams (BtAvrcpRawFrameParams raw_frame_params)
void | SetResponse (btapi_avrcp_response_code_t response)
virtual | ~BtAvrcpRawFrameRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.

Friends

class | BtAvrcpOperationController
class | BtAvrcpOperationService

Constructor & Destructor Documentation

BtAvrcpRawFrameRequest::BtAvrcpRawFrameRequest ( BtAvrcpOperationService & avrcp_service )

Constructor.

BtAvrcpRawFrameRequest::~BtAvrcpRawFrameRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtAvrcpRawFrameRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtAvrcpRawFrameParams BtAvrcpRawFrameRequest::GetRawFrameParams ( ) const [inline]

BtRequestType BtAvrcpRawFrameRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtAvrcpResponseType BtAvrcpRawFrameRequest::GetResponse ( ) [inline]

BOOLEAN BtAvrcpRawFrameRequest::ReleaseParams ( )

free the memory

void BtAvrcpRawFrameRequest::SetRawFrameParams ( BtAvrcpRawFrameParams raw_frame_params ) [inline]

void BtAvrcpRawFrameRequest::SetResponse ( btapi_avrcp_response_code_t response ) [inline]

Friends And Related Function Documentation

friend class BtAvrcpOperationController [friend]

Reimplemented from BtAvrcpRequest.

friend class BtAvrcpOperationService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpRawFrameRequest.hpp
  • Bluetooth/AVRCP/BtAvrcpRawFrameRequest.cpp
Generated on Wed Jan 25 00:58:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpRegisterParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpRegisterParams Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp>

Collaboration diagram for BtAvrcpRegisterParams:

[legend]

Public Member Functions

BtAvrcpRegisterParams ()
Constructor.
const ULONG | GetCompanyId () const
const UINT8 | GetNoOfSubunits () const
BtAvrcpRole GetRole ()
const BtAvrcpSubunitInfoEntry * | GetSubunitInfos () const
const UINT8 | GetSupportedCategories () const
const UINT8 | GetUnit () const
const BtAvrcpSubunitType | GetUnitType () const
BOOLEAN | ReleaseSubunitInfos ()
void | SetCompanyId (ULONG company_id)
void | SetRole (BtAvrcpRole role)
void | SetSubunitInfos (UINT8 no_of_subunits, BtAvrcpSubunitInfoEntry *subunit_infos)
void | SetSupportedCategories (UINT8 categories)
void | SetUnit (UINT8 unit)
void | SetUnitType (BtAvrcpSubunitType type)
virtual | ~BtAvrcpRegisterParams ()
Destructor.

Detailed Description

Parameter class needed for registering an application to the bluetooth protocol stack. Two different types of roles can be registered - Controller and Target. Before implementing any operations one needs to register at least one of the roles.

Constructor & Destructor Documentation

BtAvrcpRegisterParams::BtAvrcpRegisterParams ( )

Constructor.

BtAvrcpRegisterParams::~BtAvrcpRegisterParams ( ) [virtual]

Destructor.

Member Function Documentation

const ULONG BtAvrcpRegisterParams::GetCompanyId ( ) const [inline]

Get Company ID (Vendor dependent); returns the IEEE number for a company. 0xFFFFFFF for a company, which has no identifier.

const UINT8 BtAvrcpRegisterParams::GetNoOfSubunits ( ) const [inline]

Get the number of attached subunits. Can only be set with SetSubunitInfos, where the number of subunits has to be equal to the subunit info array's entries.

BtAvrcpRole BtAvrcpRegisterParams::GetRole ( ) [inline]

Get Role

Returns:
role either BtAroleController or BtAroleTarget

const BtAvrcpSubunitInfoEntry* BtAvrcpRegisterParams::GetSubunitInfos ( ) const [inline]

Get the Subunit Info Entries for all to the panel connected devices.

const UINT8 BtAvrcpRegisterParams::GetSupportedCategories ( ) const [inline]

Get supported categories.

See also:
SetSupportedCategories for possible values.

const UINT8 BtAvrcpRegisterParams::GetUnit ( ) const [inline]

Get Unit (Vendor dependent)

const BtAvrcpSubunitType BtAvrcpRegisterParams::GetUnitType ( ) const [inline]

Get Subunit Type

See also:
BtTypes.hpp in AVRCP folder for the unit types

BOOLEAN BtAvrcpRegisterParams::ReleaseSubunitInfos ( )

void BtAvrcpRegisterParams::SetCompanyId ( ULONG company_id ) [inline]

Set Company Id (Vendor dependent); Set the IEEE number of a company.

Parameters:
company id

void BtAvrcpRegisterParams::SetRole ( BtAvrcpRole role ) [inline]

Set Role

Parameters:
role either BtAroleController or BtAroleTarget

void BtAvrcpRegisterParams::SetSubunitInfos | ( | UINT8 | no_of_subunits,
 |  | BtAvrcpSubunitInfoEntry * | subunit_infos
 | ) |

Set the Subunit Info Entries for all to the panel connected devices. The number of subunits has to be equal to the number of subunit info entries.

void BtAvrcpRegisterParams::SetSupportedCategories ( UINT8 categories ) [inline]

Set the supported categories. The categories shall be set via an "OR" linking of BtAvrcpCategory parameters. In case a device supports Category 1, 2 and 4 the parameter shall be set as SetSupportedCategories(BtCategory1 | BtCategory2 | BtCategory4); compare to the Bluetooth specification in order to find out which category is to be supported.

Parameters:
supported_categories

void BtAvrcpRegisterParams::SetUnit ( UINT8 unit ) [inline]

Set Unit (Vendor dependent)

Parameters:
unit

void BtAvrcpRegisterParams::SetUnitType ( BtAvrcpSubunitType type ) [inline]

Set Subunit Type

See also:
BtTypes.hpp in AVRCP folder for the unit types
Parameters:
subunit type

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpRegisterParams.hpp
  • Bluetooth/AVRCP/BtAvrcpRegisterParams.cpp
Generated on Wed Jan 25 00:58:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpRegisterRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpRegisterRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp>

Inheritance diagram for BtAvrcpRegisterRequest:

[legend]
Collaboration diagram for BtAvrcpRegisterRequest:

[legend]

Public Member Functions

BtAvrcpRegisterRequest (BtAvrcpRegistrationService &avrcp_service)
Constructor.
BtAvrcpRegisterParams | GetRegisterParams () const
virtual BtRequestType | GetRequestType () const
Get type of this request.
BOOLEAN | ReleaseParams ()
release the memory for subunits
void | SetRegisterParams (BtAvrcpRegisterParams register_params)
virtual | ~BtAvrcpRegisterRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.

Friends

class | BtAvrcpRegistrationController
class | BtAvrcpRegistrationService

Constructor & Destructor Documentation

BtAvrcpRegisterRequest::BtAvrcpRegisterRequest ( BtAvrcpRegistrationService & avrcp_service )

Constructor.

BtAvrcpRegisterRequest::~BtAvrcpRegisterRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtAvrcpRegisterRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtAvrcpRegisterParams BtAvrcpRegisterRequest::GetRegisterParams ( ) const [inline]

BtRequestType BtAvrcpRegisterRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtAvrcpRegisterRequest::ReleaseParams ( )

release the memory for subunits

void BtAvrcpRegisterRequest::SetRegisterParams ( BtAvrcpRegisterParams register_params ) [inline]

Friends And Related Function Documentation

friend class BtAvrcpRegistrationController [friend]

friend class BtAvrcpRegistrationService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpRegisterRequest.hpp
  • Bluetooth/AVRCP/BtAvrcpRegisterRequest.cpp
Generated on Wed Jan 25 00:58:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpRegistrationService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpRegistrationService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp>

Inheritance diagram for BtAvrcpRegistrationService:

[legend]
Collaboration diagram for BtAvrcpRegistrationService:

[legend]

Public Member Functions

BtAvrcpRegistrationService ()
Constructor.
void | DeRegisterRequest (BtAvrcpRole role)
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
void | RegisterRequest (BtAvrcpRegisterParams unit_info)
virtual | ~BtAvrcpRegistrationService ()
Destructor.

Protected Member Functions

virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)
notification mechanism for request state changes

Detailed Description

An instance of this service needs to be implemented to register and de-register controller and target at the bluetooth stack. This is required to start working on an operation service.

Constructor & Destructor Documentation

BtAvrcpRegistrationService::BtAvrcpRegistrationService ( )

Constructor.

BtAvrcpRegistrationService::~BtAvrcpRegistrationService ( ) [virtual]

Destructor.

Member Function Documentation

void BtAvrcpRegistrationService::DeRegisterRequest ( BtAvrcpRole role )

Deregister an Application / Role from Service Discovery Database

Parameters:
role A role represented in AVRCP - BtAroleController or BtAroleTarget

BtRequestState BtAvrcpRegistrationService::GetRequestState ( BtRequestType request_type ) const [virtual]

Returns the current state of the register and the deregister request.

Implements BtService.

void BtAvrcpRegistrationService::RegisterRequest ( BtAvrcpRegisterParams unit_info )

Register an application as avrcp compatible. Parameters to be filled are described within BtAvrcpRegisterParams.

Parameters:
unit_info An instance of BtAvrcpRegisterParams

void BtAvrcpRegistrationService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

notification mechanism for request state changes

Implements BtService.

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpRegistrationService.hpp
  • Bluetooth/AVRCP/BtAvrcpRegistrationService.cpp
Generated on Wed Jan 25 00:58:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpRequest.hpp>

Inheritance diagram for BtAvrcpRequest:

[legend]
Collaboration diagram for BtAvrcpRequest:

[legend]

Public Member Functions

BtAvrcpRequest (BtAvrcpService &avrcp_service)
Constructor.
virtual | ~BtAvrcpRequest ()
Destructor.

Protected Member Functions

virtual BtRequestState | ChangeRequestState (BOOLEAN success)
Sets the new state depending on the success.

Friends

class | BtAvrcpOperationController
class | BtAvrcpService

Constructor & Destructor Documentation

BtAvrcpRequest::BtAvrcpRequest ( BtAvrcpService & avrcp_service )

Constructor.

BtAvrcpRequest::~BtAvrcpRequest ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtAvrcpRequest::ChangeRequestState ( BOOLEAN success ) [protected, virtual]

Sets the new state depending on the success.

ChangeRequestState is a function that is used by the ExecuteRequest and the EvaluateMessageResult functions to do the change of the request state. Depending on the current state and the passed in success, this function sets the right new state. The passed in success parameter can be on the one hand the result of a function call, on the other hand the result parameter of a message sent up to the request by the apropriate controller.

Parameters:
success A BOOLEAN indicating the success of the operation execution stage corresponding to the current state.
Returns:
A BtRequestState containing the new request state after doing the state transition.

Reimplemented from BtRequest.

Friends And Related Function Documentation

friend class BtAvrcpOperationController [friend]

Reimplemented in BtAvrcpConnectResponse, BtAvrcpOperationRequestResponse, BtAvrcpPanelPassThroughRequest, BtAvrcpRawFrameRequest, BtAvrcpSubunitInfoRequest, and BtAvrcpUnitInfoRequest.

friend class BtAvrcpService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpRequest.hpp
  • Bluetooth/AVRCP/BtAvrcpRequest.cpp
Generated on Wed Jan 25 00:58:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpServiceMessage.hpp>

Inheritance diagram for BtAvrcpRequestStateChangedMessage:

[legend]
Collaboration diagram for BtAvrcpRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10455 }

Public Member Functions

BtAvrcpRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtAvrcpRequestStateChangedMessage ()

Detailed Description

BtAvrcpRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtAvrcpRequestStateChangedMessage::BtAvrcpRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtAvrcpRequestStateChangedMessage::~BtAvrcpRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtAvrcpRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtAvrcpRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpServiceMessage.hpp
  • Bluetooth/AVRCP/BtAvrcpServiceMessage.cpp
Generated on Wed Jan 25 00:58:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpService.hpp>

Inheritance diagram for BtAvrcpService:

[legend]
Collaboration diagram for BtAvrcpService:

[legend]

Public Member Functions

BtAvrcpService ()
Constructor.
virtual BtProfile | GetProfile () const
Get the profile this service is associated with.
virtual void | Init ()
virtual | ~BtAvrcpService ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &message)
virtual void | RegisterMessages () const
virtual void | UnregisterMessages () const

Detailed Description

Base class for AVRCP service classes

Constructor & Destructor Documentation

BtAvrcpService::BtAvrcpService ( )

Constructor.

BtAvrcpService::~BtAvrcpService ( ) [virtual]

Destructor.

Member Function Documentation

BtProfile BtAvrcpService::GetProfile ( ) const [virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface, so in the base class, it is a pure virtual function.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implements BtService.

void BtAvrcpService::Init ( ) [virtual]

BOOLEAN BtAvrcpService::OnMessage ( const Message & message ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

Reimplemented in BtAvrcpOperationService.

void BtAvrcpService::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

Reimplemented in BtAvrcpOperationService.

void BtAvrcpService::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

Reimplemented in BtAvrcpOperationService.

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpService.hpp
  • Bluetooth/AVRCP/BtAvrcpService.cpp
Generated on Wed Jan 25 00:58:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpSubunitInfoEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpSubunitInfoEntry Struct Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtTypes.hpp>

Data Fields

UINT8 m_max_subunit_id
BtAvrcpSubunitType m_subunit_type

Detailed Description

Structure needed for subunit information (when implementing and registering more than one application which shall be controlled via AVRCP)

Field Documentation

BtAvrcpSubunitType BtAvrcpSubunitInfoEntry::m_subunit_type

The documentation for this struct was generated from the following file:
  • Bluetooth/AVRCP/BtTypes.hpp
Generated on Wed Jan 25 00:58:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpSubunitInfoParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpSubunitInfoParams Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp>

Collaboration diagram for BtAvrcpSubunitInfoParams:

[legend]

Public Member Functions

BtAvrcpSubunitInfoParams ()
Constructor.
const UINT8 | GetNoOfSubunitInfoEntries () const
Get No of Subunit Entries.
const UINT8 | GetPage () const
Get Page.
const BtAvrcpSubunitInfoEntry * | GetSubunitInfoEntries () const
Get Subunit Info Entries.
void | SetNoOfSubunitInfoEntries (UINT8 no_of_subunit_info_entries)
Set No of Subunit Entries.
void | SetPage (UINT8 page)
Set page.
void | SetSubunitInfoEntries (BtAvrcpSubunitInfoEntry *subunit_info_entries)
Set Subunit Entries.
virtual | ~BtAvrcpSubunitInfoParams ()
Destructor.

Constructor & Destructor Documentation

BtAvrcpSubunitInfoParams::BtAvrcpSubunitInfoParams ( )

Constructor.

BtAvrcpSubunitInfoParams::~BtAvrcpSubunitInfoParams ( ) [virtual]

Destructor.

Member Function Documentation

const UINT8 BtAvrcpSubunitInfoParams::GetNoOfSubunitInfoEntries ( ) const [inline]

Get No of Subunit Entries.

const UINT8 BtAvrcpSubunitInfoParams::GetPage ( ) const [inline]

Get Page.

const BtAvrcpSubunitInfoEntry* BtAvrcpSubunitInfoParams::GetSubunitInfoEntries ( ) const [inline]

Get Subunit Info Entries.

void BtAvrcpSubunitInfoParams::SetNoOfSubunitInfoEntries ( UINT8 no_of_subunit_info_entries ) [inline]

Set No of Subunit Entries.

Parameters:
no_of_subunit_info_entries

void BtAvrcpSubunitInfoParams::SetPage ( UINT8 page ) [inline]

Set page.

Parameters:
page

void BtAvrcpSubunitInfoParams::SetSubunitInfoEntries ( BtAvrcpSubunitInfoEntry * subunit_info_entries )

Set Subunit Entries.

Parameters:
subunit_info_entries

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.hpp
  • Bluetooth/AVRCP/BtAvrcpSubunitInfoParams.cpp
Generated on Wed Jan 25 00:58:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpSubunitInfoRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpSubunitInfoRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp>

Inheritance diagram for BtAvrcpSubunitInfoRequest:

[legend]
Collaboration diagram for BtAvrcpSubunitInfoRequest:

[legend]

Public Member Functions

BtAvrcpSubunitInfoRequest (BtAvrcpOperationService &avrcp_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtAvrcpResponseType GetResponse ()
BtAvrcpSubunitInfoParams GetSubunitInfoParams ()
void | SetResponse (btapi_avrcp_response_code_t response)
void | SetSubunitInfoParams (BtAvrcpSubunitInfoParams subunit_info_params)
virtual | ~BtAvrcpSubunitInfoRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.

Friends

class | BtAvrcpOperationController
class | BtAvrcpOperationService

Constructor & Destructor Documentation

BtAvrcpSubunitInfoRequest::BtAvrcpSubunitInfoRequest ( BtAvrcpOperationService & avrcp_service )

Constructor.

BtAvrcpSubunitInfoRequest::~BtAvrcpSubunitInfoRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtAvrcpSubunitInfoRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtRequestType BtAvrcpSubunitInfoRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtAvrcpResponseType BtAvrcpSubunitInfoRequest::GetResponse ( ) [inline]

BtAvrcpSubunitInfoParams BtAvrcpSubunitInfoRequest::GetSubunitInfoParams ( ) [inline]

void BtAvrcpSubunitInfoRequest::SetResponse ( btapi_avrcp_response_code_t response ) [inline]

void BtAvrcpSubunitInfoRequest::SetSubunitInfoParams ( BtAvrcpSubunitInfoParams subunit_info_params ) [inline]

Friends And Related Function Documentation

friend class BtAvrcpOperationController [friend]

Reimplemented from BtAvrcpRequest.

friend class BtAvrcpOperationService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.hpp
  • Bluetooth/AVRCP/BtAvrcpSubunitInfoRequest.cpp
Generated on Wed Jan 25 00:58:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpUnitInfoParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpUnitInfoParams Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp>

Public Member Functions

BtAvrcpUnitInfoParams ()
Constructor.
const ULONG | GetCompanyId () const
Get Company ID (Vendor dependent).
const UINT8 | GetUnit () const
Get Unit (Vendor dependent).
const BtAvrcpSubunitType | GetUnitType () const
Get Subunit Type.
void | SetCompanyId (ULONG company_id)
Set Company Id (Vendor dependent).
void | SetUnit (UINT8 unit)
Set Unit (Vendor dependent).
void | SetUnitType (BtAvrcpSubunitType type)
Set Subunit Type.
virtual | ~BtAvrcpUnitInfoParams ()
Destructor.

Constructor & Destructor Documentation

BtAvrcpUnitInfoParams::BtAvrcpUnitInfoParams ( )

Constructor.

BtAvrcpUnitInfoParams::~BtAvrcpUnitInfoParams ( ) [virtual]

Destructor.

Member Function Documentation

const ULONG BtAvrcpUnitInfoParams::GetCompanyId ( ) const [inline]

Get Company ID (Vendor dependent).

const UINT8 BtAvrcpUnitInfoParams::GetUnit ( ) const [inline]

Get Unit (Vendor dependent).

const BtAvrcpSubunitType BtAvrcpUnitInfoParams::GetUnitType ( ) const [inline]

Get Subunit Type.

void BtAvrcpUnitInfoParams::SetCompanyId ( ULONG company_id ) [inline]

Set Company Id (Vendor dependent).

Parameters:
company id

void BtAvrcpUnitInfoParams::SetUnit ( UINT8 unit ) [inline]

Set Unit (Vendor dependent).

Parameters:
unit

void BtAvrcpUnitInfoParams::SetUnitType ( BtAvrcpSubunitType type ) [inline]

Set Subunit Type.

Parameters:
subunit type

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpUnitInfoParams.hpp
  • Bluetooth/AVRCP/BtAvrcpUnitInfoParams.cpp
Generated on Wed Jan 25 00:58:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtAvrcpUnitInfoRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtAvrcpUnitInfoRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp>

Inheritance diagram for BtAvrcpUnitInfoRequest:

[legend]
Collaboration diagram for BtAvrcpUnitInfoRequest:

[legend]

Public Member Functions

BtAvrcpUnitInfoRequest (BtAvrcpOperationService &avrcp_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtAvrcpResponseType GetResponse ()
BtAvrcpUnitInfoParams GetUnitInfoParams ()
void | SetResponse (btapi_avrcp_response_code_t response)
void | SetUnitInfoParams (BtAvrcpUnitInfoParams unit_info_params)
virtual | ~BtAvrcpUnitInfoRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.

Friends

class | BtAvrcpOperationController
class | BtAvrcpOperationService

Constructor & Destructor Documentation

BtAvrcpUnitInfoRequest::BtAvrcpUnitInfoRequest ( BtAvrcpOperationService & avrcp_service )

Constructor.

BtAvrcpUnitInfoRequest::~BtAvrcpUnitInfoRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtAvrcpUnitInfoRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtRequestType BtAvrcpUnitInfoRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtAvrcpResponseType BtAvrcpUnitInfoRequest::GetResponse ( ) [inline]

BtAvrcpUnitInfoParams BtAvrcpUnitInfoRequest::GetUnitInfoParams ( )

void BtAvrcpUnitInfoRequest::SetResponse ( btapi_avrcp_response_code_t response ) [inline]

void BtAvrcpUnitInfoRequest::SetUnitInfoParams ( BtAvrcpUnitInfoParams unit_info_params ) [inline]

Friends And Related Function Documentation

friend class BtAvrcpOperationController [friend]

Reimplemented from BtAvrcpRequest.

friend class BtAvrcpOperationService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.hpp
  • Bluetooth/AVRCP/BtAvrcpUnitInfoRequest.cpp
Generated on Wed Jan 25 00:58:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipAbortIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipAbortIndArg Class Reference

Abort Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipAbortIndArg:

[legend]
Collaboration diagram for BtBipAbortIndArg:

[legend]

Public Types

enum | { ID = 7 }

Public Member Functions

BtBipAbortIndArg (const WString &abort_desc)
const WString & | GetAbortDesc () const
virtual | ~BtBipAbortIndArg ()

Static Public Member Functions

static const BtBipAbortIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Abort Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device aborts the current operation.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipAbortIndArg::BtBipAbortIndArg ( const WString & abort_desc )

BtBipAbortIndArg::~BtBipAbortIndArg ( ) [virtual]

Member Function Documentation

const BtBipAbortIndArg & BtBipAbortIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const WString& BtBipAbortIndArg::GetAbortDesc ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipAttachment Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipAttachment Class Reference
[Bluetooth]

An attachment. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipAttachment:

[legend]

Public Member Functions

const String & | GetCharset ()
const DateTime & | GetCreateDate ()
ApoxiMimeTypeId GetMimeType ()
const DateTime & | GetModifyDate ()
const String & | GetName ()
UINT32 | GetSize ()
void | SetAttachmentFormat (const BtBipAttachmentFormat &format)
void | SetCharset (const String &charset)
void | SetCreateDate (const DateTime &date)
void | SetMimeType (ApoxiMimeTypeId mime_type)
void | SetModifyDate (const DateTime &date)
void | SetName (const String &name)
void | SetSize (UINT32 size)

Detailed Description

An attachment.

Member Function Documentation

void BtBipAttachment::SetAttachmentFormat ( const BtBipAttachmentFormat & format ) [inline]

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipTypes.hpp
Generated on Wed Jan 25 00:58:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipAttachmentDesc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipAttachmentDesc Class Reference
[Bluetooth]

Attachment descriptor. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipAttachmentDesc:

[legend]

Public Member Functions

BtBipAttachmentDesc ()
const String & | GetCharset () const
const DateTime & | GetCreated () const
ApoxiMimeTypeId | GetMimeType () const
const String & | GetName () const
UINT32 | GetSize () const
void | SetCharset (const String &charset)
void | SetCreateDate (const DateTime &date)
void | SetMimeType (ApoxiMimeTypeId mime_type)
void | SetName (const String &name)
void | SetSize (UINT32 size)
~BtBipAttachmentDesc ()

Detailed Description

Attachment descriptor.

This class represents an attachment descriptor like defined in BIP Interoperability Specification chapter 4.4.7.3

Constructor & Destructor Documentation

BtBipAttachmentDesc::BtBipAttachmentDesc ( )

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipAttachmentFormat Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipAttachmentFormat Class Reference
[Bluetooth]

Format of an attachment. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipAttachmentFormat:

[legend]

Public Member Functions

BtBipAttachmentFormat ()
const String & | GetCharset () const
ApoxiMimeTypeId | GetMimeType () const
void | SetCharset (const String &charset)
void | SetMimeType (ApoxiMimeTypeId mime_type)
~BtBipAttachmentFormat ()

Detailed Description

Format of an attachment.

Constructor & Destructor Documentation

BtBipAttachmentFormat::BtBipAttachmentFormat ( )

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipClientService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipClientService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BIP/BtBipClientService.hpp>

Public Member Functions

BtRequestState | AbortReq (const WString &reason)
Abort ongoing session.
BtBipClientService ()
Constructor.
BtRequestState | ConnectReq (BtBipSessionId session_id, const BtDevice &device)
Connect to remote BIP device.
BtRequestState | DeleteImageReq (const BtBipImageHdlPtr &img_hdl)
Delete an image on remote device.
BtRequestState DisconnectReq ()
Disconnect remote BIP device.
BtBipResult GetBipResult ()
Get BIP result code of last operation.
BtResultCode | GetImageHdl (BtBipImageHdlPtr &img_hdl)
Get the image handle.
BtResultCode | GetImageProperties (BtBipImagePropertiesPtr &props)
Get the properties of an image.
BtRequestState | GetImagePropertiesReq (const BtBipImageHdlPtr &img_hdl)
Get the properties of an image.
BtRequestState | GetImageReq (const BtBipImageHdlPtr &img_hdl, const BtBipImageDescPtr &img_desc, const DataSinkPtr &image)
Get an image from remote device.
BtResultCode | GetImagesList (BtBipImageListPtr &img_list)
Get the image list.
BtRequestState | GetImagesListReq (UINT16 first_index, UINT16 max_images, BOOLEAN sort_by_latest_first, const BtBipImageHdlDescPtr &filter)
Request a list of images available on remote device.
BtResultCode | GetImagingCapabilites (BtBipImagingCapabilitiesPtr &caps)
Get the imaging capabilities.
BtRequestState GetImagingCapabilitiesReq ()
Get the imaging capabilities of the remote device.
BtRequestState | GetLinkedAttachmentReq (const BtBipImageHdlPtr &img_hdl, const WString &file_name, const DataSinkPtr &attach)
Get an attachment from remote device.
BtRequestState | GetLinkedThumbnailReq (const BtBipImageHdlPtr &img_hdl, const DataSinkPtr &thumb)
Get an image thumbnail from remote device.
BtObexResponseCode GetObexResponseCode ()
Get OBEX response code of last operation.
UINT32 | GetProgressInBytes ()
Get the Bytes already transfered in the current request.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
BtResultCode GetResult ()
Get Bluetooth result code of last operation.
BOOLEAN | IsConnected () const
virtual BOOLEAN | IsServerService () const
BtRequestState | PutImageReq (const WString &name, const ImageObtainer &image)
Send an image to the remote device.
BtRequestState | PutImageReq (const WString &name, BtBipImageDescPtr &img_desc, const ImageObtainer &image)
Send an image to the remote device.
BtRequestState | PutImageReq (const WString &name, const BtBipImageDescPtr &img_desc, const DataSourcePtr &img)
Send an image to the remote device.
BtRequestState | PutLinkedAttachmentReq (const BtBipImageHdlPtr &img_hdl, const BtBipAttachmentDescPtr &attach_desc, const DataSourcePtr &attach)
Send an attachment to the remote device.
BtRequestState | PutLinkedThumbnailReq (const BtBipImageHdlPtr &img_hdl, const DataSourcePtr &thumb)
Send a thumbnail of an image to the remote device.
BtRequestState | PutLinkedThumbnailReq (const BtBipImageHdlPtr &img_hdl, const ImageObtainer &thumb)
Send a thumbnail of an image to the remote device.
virtual | ~BtBipClientService ()
Destructor.

Protected Member Functions

virtual void | RegisterMessages () const
virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | UnregisterMessages () const

Friends

class | BtBipConnectReq

Constructor & Destructor Documentation

BtBipClientService::BtBipClientService ( )

Constructor.

BtBipClientService::~BtBipClientService ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtBipClientService::AbortReq ( const WString & reason )

Abort ongoing session.

The ongoing session is aborted and the user of the remote device is informed.

Parameters:
reason User friendly description why the session was aborted

BtRequestState BtBipClientService::ConnectReq | ( | BtBipSessionId | session_id,
 |  | const BtDevice & | device
 | ) |

Connect to remote BIP device.

To connect to a remote device, first a device search has to be done. The selected device has then to be passed with this method to establish a BIP connection.

Parameters:
session_id | Type of connection to establish, currently only BipImagePush and BipImagePull
device | Device to connect to

BtRequestState BtBipClientService::DeleteImageReq ( const BtBipImageHdlPtr & img_hdl )

Delete an image on remote device.

Parameters:
img_hdl Handle of image that shall be deleted.

BtRequestState BtBipClientService::DisconnectReq ( )

Disconnect remote BIP device.

The connection to the remote device is disconnected.

BtBipResult BtBipClientService::GetBipResult ( )

Get BIP result code of last operation.

BtResultCode BtBipClientService::GetImageHdl ( BtBipImageHdlPtr & img_hdl )

Get the image handle.

An image handle is only available after a successful PutImageRequest.

Parameters:
img_hld A reference to a String.

BtResultCode BtBipClientService::GetImageProperties ( BtBipImagePropertiesPtr & props )

Get the properties of an image.

Image properties are only available after a successful GetImagePropertiesReqeust.

Parameters:
props A reference to BtBipImageProperites that will be filled with the result data.

BtRequestState BtBipClientService::GetImagePropertiesReq ( const BtBipImageHdlPtr & img_hdl )

Get the properties of an image.

The properites of an image contain information about native size, encoding, possible other sizes and attachments of an image.

Parameters:
img_hdl Handle of image to retrieve properties from.

BtRequestState BtBipClientService::GetImageReq | ( | const BtBipImageHdlPtr & | img_hdl,
 |  | const BtBipImageDescPtr & | img_desc,
 |  | const DataSinkPtr & | image
 | ) |

Get an image from remote device.

Parameters:
img_hdl | Handle of image to retrieve.
img_desc | Descriptor of image that specifys the format the image should be retrieved in.
img | Shared pointer to DataSink, where the received image data can be written to.

BtResultCode BtBipClientService::GetImagesList ( BtBipImageListPtr & img_list )

Get the image list.

An image list is only available after a successful GetImageListRequest.

Parameters:
img_list A reference to a BtBipImagesList that will be filled with the result data.

BtRequestState BtBipClientService::GetImagesListReq | ( | UINT16 | first_index,
 |  | UINT16 | max_images,
 |  | BOOLEAN | sort_by_latest_first,
 |  | const BtBipImageHdlDescPtr & | filter
 | ) |

Request a list of images available on remote device.

Parameters:
first_index | Zero based index of image where the list should start.
max_images | Max. number of images in list. Filter to restrict the images returned in list.

BtResultCode BtBipClientService::GetImagingCapabilites ( BtBipImagingCapabilitiesPtr & caps )

Get the imaging capabilities.

The imaging capabilites are only available after a GetImagingCapabilitiesRequest has been processed successfully.

Parameters:
caps A reference to a BtBipImagingCapabilities instance. This instance will be filled with the data

BtRequestState BtBipClientService::GetImagingCapabilitiesReq ( )

Get the imaging capabilities of the remote device.

The imaging capabilities give information about which sort of images the remote device is able to cope with.

BtRequestState BtBipClientService::GetLinkedAttachmentReq | ( | const BtBipImageHdlPtr & | img_hdl,
 |  | const WString & | file_name,
 |  | const DataSinkPtr & | attach
 | ) |

Get an attachment from remote device.

Parameters:
img_hdl | Handle of image of which an attachment is to be retrieved.
file_name | Filename of the attachment that should be retrieved.
attach | Shared pointer to DataSink, where the received attachment can be written to.

BtRequestState BtBipClientService::GetLinkedThumbnailReq | ( | const BtBipImageHdlPtr & | img_hdl,
 |  | const DataSinkPtr & | thumb
 | ) |

Get an image thumbnail from remote device.

Parameters:
img_hdl | Handle of image of which a thumbnail is to be retrieved.
img_desc | Descriptor of image that specifys the format the image should be retrieved in.
thumb | Shared pointer to DataSink, where the received thumbnail can be written to.

BtObexResponseCode BtBipClientService::GetObexResponseCode ( )

Get OBEX response code of last operation.

UINT32 BtBipClientService::GetProgressInBytes ( ) [inline]

Get the Bytes already transfered in the current request.

If no Get or PUT request is running 0 Bytes are returned

BtRequestState BtBipClientService::GetRequestState ( BtRequestType request_type ) const [virtual]

BtResultCode BtBipClientService::GetResult ( )

Get Bluetooth result code of last operation.

BOOLEAN BtBipClientService::IsConnected ( ) const

BOOLEAN BtBipClientService::IsServerService ( ) const [virtual]

BtRequestState BtBipClientService::PutImageReq | ( | const WString & | name,
 |  | const ImageObtainer & | image
 | ) |

Send an image to the remote device.

While sending the data is read from img. After sending finished, the result of the operation has to be checked with GetResult(). If BIP_RESULT_PARTIAL_CONTENT is returned, the thumbnail of the just sent image has to be sent to the remote device. The handle of the sent image can be retrieved with GetImageHandle().

Parameters:
image ImageObtainer of the image.
Returns:

BtRequestState BtBipClientService::PutImageReq | ( | const WString & | name,
 |  | BtBipImageDescPtr & | img_desc,
 |  | const ImageObtainer & | image
 | ) |

Send an image to the remote device.

While sending the data is read from img. After sending finished, the result of the operation has to be checked with GetResult(). If BIP_RESULT_PARTIAL_CONTENT is returned, the thumbnail of the just sent image has to be sent to the remote device. The handle of the sent image can be retrieved with GetImageHandle().

Parameters:
image | ImageObtainer of the image.
img_desc | Shared pointer to BtBipImageDesc that is used for sending the image.
Returns:

BtRequestState BtBipClientService::PutImageReq | ( | const WString & | name,
 |  | const BtBipImageDescPtr & | img_desc,
 |  | const DataSourcePtr & | img
 | ) |

Send an image to the remote device.

While sending the data is read from img. After sending finished, the result of the operation has to be checked with GetResult(). If BIP_RESULT_PARTIAL_CONTENT is returned, the thumbnail of the just sent image has to be sent to the remote device. The handle of the sent image can be retrieved with GetImageHandle().

Parameters:
name | Image name.
img_desc | Image descriptor, that defines the image's properties.
img | Binary image data.
Returns:

BtRequestState BtBipClientService::PutLinkedAttachmentReq | ( | const BtBipImageHdlPtr & | img_hdl,
 |  | const BtBipAttachmentDescPtr & | attach_desc,
 |  | const DataSourcePtr & | attach
 | ) |

Send an attachment to the remote device.

Parameters:
img_hdl | Handle of the image the attachment belongs to.
img_desc | Image descriptor, that defines the image's properties.
attachment | Binay attachment data.

BtRequestState BtBipClientService::PutLinkedThumbnailReq | ( | const BtBipImageHdlPtr & | img_hdl,
 |  | const DataSourcePtr & | thumb
 | ) |

Send a thumbnail of an image to the remote device.

A thumbnail can be sent any time, but it has to be sent after a Put Image request, if the result of the Put Image request is BIP_RESULT_PARTIAL_CONTENT.

Parameters:
img_hdl | Handle of the image the thumbnail belongs to.
thumbnail | Binary thumbnail image data.

BtRequestState BtBipClientService::PutLinkedThumbnailReq | ( | const BtBipImageHdlPtr & | img_hdl,
 |  | const ImageObtainer & | thumb
 | ) |

Send a thumbnail of an image to the remote device.

A thumbnail can be sent any time, but it has to be sent after a Put Image request, if the result of the Put Image request is BIP_RESULT_PARTIAL_CONTENT.

Parameters:
img_hdl | Handle of the image the thumbnail belongs to.
thumbnail | Binary ImageObtainer of image thumbnail.

void BtBipClientService::RegisterMessages ( ) const [protected, virtual]

void BtBipClientService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

void BtBipClientService::UnregisterMessages ( ) const [protected, virtual]

Friends And Related Function Documentation

friend class BtBipConnectReq [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipClientService.hpp
  • Bluetooth/BIP/BtBipClientService.cpp
Generated on Wed Jan 25 00:58:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipConnectIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipConnectIndArg Class Reference

Connect Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipConnectIndArg:

[legend]
Collaboration diagram for BtBipConnectIndArg:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

BtBipConnectIndArg (const BtBipSessionId &session_id, const BtDeviceAddress &device_adr)
const BtDeviceAddress & | GetDeviceAdr () const
BtBipSessionId | GetSessionId () const
virtual | ~BtBipConnectIndArg ()

Static Public Member Functions

static const BtBipConnectIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Connect Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device connects to the local BIP profile.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipConnectIndArg::BtBipConnectIndArg | ( | const BtBipSessionId & | session_id,
 |  | const BtDeviceAddress & | device_adr
 | ) |

BtBipConnectIndArg::~BtBipConnectIndArg ( ) [virtual]

Member Function Documentation

const BtBipConnectIndArg & BtBipConnectIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtDeviceAddress& BtBipConnectIndArg::GetDeviceAdr ( ) const [inline]

BtBipSessionId BtBipConnectIndArg::GetSessionId ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipDeleteImageIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipDeleteImageIndArg Class Reference

Delete Image Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipDeleteImageIndArg:

[legend]
Collaboration diagram for BtBipDeleteImageIndArg:

[legend]

Public Types

enum

Public Member Functions

BtBipDeleteImageIndArg (const BtBipImageHdlPtr &hdl)
const BtBipImageHdlPtr & | GetImageHdl () const
virtual | ~BtBipDeleteImageIndArg ()

Static Public Member Functions

static const BtBipDeleteImageIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Delete Image Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to delete an image on this device.

Member Enumeration Documentation

anonymous enum

Constructor & Destructor Documentation

BtBipDeleteImageIndArg::BtBipDeleteImageIndArg ( const BtBipImageHdlPtr & hdl )

BtBipDeleteImageIndArg::~BtBipDeleteImageIndArg ( ) [virtual]

Member Function Documentation

const BtBipDeleteImageIndArg & BtBipDeleteImageIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageHdlPtr& BtBipDeleteImageIndArg::GetImageHdl ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipDisconnectIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipDisconnectIndArg Class Reference

Disconnect Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipDisconnectIndArg:

[legend]
Collaboration diagram for BtBipDisconnectIndArg:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

BtBipDisconnectIndArg ()
virtual | ~BtBipDisconnectIndArg ()

Static Public Member Functions

static const BtBipDisconnectIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Disconnect Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device connects to the local BIP profile.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipDisconnectIndArg::BtBipDisconnectIndArg ( )

BtBipDisconnectIndArg::~BtBipDisconnectIndArg ( ) [virtual]

Member Function Documentation

const BtBipDisconnectIndArg & BtBipDisconnectIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetImageInd Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetImageInd Class Reference

Get Image Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipGetImageInd:

[legend]
Collaboration diagram for BtBipGetImageInd:

[legend]

Detailed Description

Get Image Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to get an image from this device.

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipMsgArg.hpp
Generated on Wed Jan 25 00:58:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetImageIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetImageIndArg Class Reference

Get Image Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipGetImageIndArg:

[legend]
Collaboration diagram for BtBipGetImageIndArg:

[legend]

Public Types

enum | { ID = 6 }

Public Member Functions

BtBipGetImageIndArg (const BtBipImageHdlPtr &img_hdl, const BtBipImageDescPtr &img_desc)
const BtBipImageDescPtr & | GetImageDesc () const
const BtBipImageHdlPtr & | GetImageHandle () const
~BtBipGetImageIndArg ()

Static Public Member Functions

static const BtBipGetImageIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Get Image Request Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device tries to get an image from this device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipGetImageIndArg::BtBipGetImageIndArg | ( | const BtBipImageHdlPtr & | img_hdl,
 |  | const BtBipImageDescPtr & | img_desc
 | ) |

BtBipGetImageIndArg::~BtBipGetImageIndArg ( )

Member Function Documentation

const BtBipGetImageIndArg & BtBipGetImageIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageDescPtr& BtBipGetImageIndArg::GetImageDesc ( ) const [inline]

const BtBipImageHdlPtr& BtBipGetImageIndArg::GetImageHandle ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetImagePropertiesInd Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetImagePropertiesInd Class Reference

Get Image Properties Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipGetImagePropertiesInd:

[legend]
Collaboration diagram for BtBipGetImagePropertiesInd:

[legend]

Detailed Description

Get Image Properties Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to poll the properties of an image from this device.

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipMsgArg.hpp
Generated on Wed Jan 25 00:58:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetImagePropertiesIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetImagePropertiesIndArg Class Reference

Get Images List Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipGetImagePropertiesIndArg:

[legend]
Collaboration diagram for BtBipGetImagePropertiesIndArg:

[legend]

Public Types

enum | { ID = 14 }

Public Member Functions

BtBipGetImagePropertiesIndArg (const BtBipImageHdlPtr &hdl)
const BtBipImageHdlPtr & | GetImageHdl () const
virtual | ~BtBipGetImagePropertiesIndArg ()

Static Public Member Functions

static const BtBipGetImagePropertiesIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Get Images List Request Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device tries to poll the list of images from this device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipGetImagePropertiesIndArg::BtBipGetImagePropertiesIndArg ( const BtBipImageHdlPtr & hdl )

BtBipGetImagePropertiesIndArg::~BtBipGetImagePropertiesIndArg ( ) [virtual]

Member Function Documentation

const BtBipGetImagePropertiesIndArg & BtBipGetImagePropertiesIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageHdlPtr& BtBipGetImagePropertiesIndArg::GetImageHdl ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetImagesListInd Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetImagesListInd Class Reference

Get Images List Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipGetImagesListInd:

[legend]
Collaboration diagram for BtBipGetImagesListInd:

[legend]

Detailed Description

Get Images List Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to poll the list of images from this device.

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipMsgArg.hpp
Generated on Wed Jan 25 00:58:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetImagesListIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetImagesListIndArg Class Reference

Get Images List Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipGetImagesListIndArg:

[legend]
Collaboration diagram for BtBipGetImagesListIndArg:

[legend]

Public Types

enum | { ID = 5 }

Public Member Functions

BtBipGetImagesListIndArg (UINT16 first_index, UINT16 max_images, BOOLEAN sort_by_latest_first, const BtBipImageHdlDescPtr &filter)
const BtBipImageHdlDescPtr & | GetFilter () const
INT | GetFirstIndex () const
INT | GetMaxImages () const
BOOLEAN | GetSortByLatestFirst () const
virtual | ~BtBipGetImagesListIndArg ()

Static Public Member Functions

static const BtBipGetImagesListIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Get Images List Request Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device tries to poll the list of images from this device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipGetImagesListIndArg::BtBipGetImagesListIndArg | ( | UINT16 | first_index,
 |  | UINT16 | max_images,
 |  | BOOLEAN | sort_by_latest_first,
 |  | const BtBipImageHdlDescPtr & | filter
 | ) |

BtBipGetImagesListIndArg::~BtBipGetImagesListIndArg ( ) [virtual]

Member Function Documentation

const BtBipGetImagesListIndArg & BtBipGetImagesListIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageHdlDescPtr& BtBipGetImagesListIndArg::GetFilter ( ) const [inline]

INT BtBipGetImagesListIndArg::GetFirstIndex ( ) const [inline]

INT BtBipGetImagesListIndArg::GetMaxImages ( ) const [inline]

BOOLEAN BtBipGetImagesListIndArg::GetSortByLatestFirst ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetImagingCapabilitesIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetImagingCapabilitesIndArg Class Reference

Get Imaging Capabilities Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipGetImagingCapabilitesIndArg:

[legend]
Collaboration diagram for BtBipGetImagingCapabilitesIndArg:

[legend]

Detailed Description

Get Imaging Capabilities Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to push a picture to this device.

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipMsgArg.hpp
Generated on Wed Jan 25 00:58:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetImagingCapabilitiesIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetImagingCapabilitiesIndArg Class Reference

Get Imaging Capabilities Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipGetImagingCapabilitiesIndArg:

[legend]
Collaboration diagram for BtBipGetImagingCapabilitiesIndArg:

[legend]

Public Types

enum | { ID = 9 }

Public Member Functions

BtBipGetImagingCapabilitiesIndArg ()
~BtBipGetImagingCapabilitiesIndArg ()

Static Public Member Functions

static const BtBipGetImagingCapabilitiesIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Get Imaging Capabilities Request Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device tries to push a picture to this device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipGetImagingCapabilitiesIndArg::BtBipGetImagingCapabilitiesIndArg ( )

BtBipGetImagingCapabilitiesIndArg::~BtBipGetImagingCapabilitiesIndArg ( )

Member Function Documentation

const BtBipGetImagingCapabilitiesIndArg & BtBipGetImagingCapabilitiesIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetLinkedAttachmentInd Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetLinkedAttachmentInd Class Reference

Get Linked Attachment Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipGetLinkedAttachmentInd:

[legend]
Collaboration diagram for BtBipGetLinkedAttachmentInd:

[legend]

Detailed Description

Get Linked Attachment Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to get an attachment of an image from this device.

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipMsgArg.hpp
Generated on Wed Jan 25 00:58:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetLinkedAttachmentIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetLinkedAttachmentIndArg Class Reference

Get Images List Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipGetLinkedAttachmentIndArg:

[legend]
Collaboration diagram for BtBipGetLinkedAttachmentIndArg:

[legend]

Public Types

enum | { ID = 16 }

Public Member Functions

BtBipGetLinkedAttachmentIndArg (const BtBipImageHdlPtr &hdl, const WString &file_name)
const WString & | GetFileName () const
const BtBipImageHdlPtr & | GetImageHdl () const
virtual | ~BtBipGetLinkedAttachmentIndArg ()

Static Public Member Functions

static const BtBipGetLinkedAttachmentIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Get Images List Request Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device tries to poll the list of images from this device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipGetLinkedAttachmentIndArg::BtBipGetLinkedAttachmentIndArg | ( | const BtBipImageHdlPtr & | hdl,
 |  | const WString & | file_name
 | ) |

BtBipGetLinkedAttachmentIndArg::~BtBipGetLinkedAttachmentIndArg ( ) [virtual]

Member Function Documentation

const BtBipGetLinkedAttachmentIndArg & BtBipGetLinkedAttachmentIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const WString& BtBipGetLinkedAttachmentIndArg::GetFileName ( ) const [inline]

const BtBipImageHdlPtr& BtBipGetLinkedAttachmentIndArg::GetImageHdl ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetLinkedThumbnailInd Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetLinkedThumbnailInd Class Reference

Get Linked Thumbnail Image Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipGetLinkedThumbnailInd:

[legend]
Collaboration diagram for BtBipGetLinkedThumbnailInd:

[legend]

Detailed Description

Get Linked Thumbnail Image Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to push a picture to this device.

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipMsgArg.hpp
Generated on Wed Jan 25 00:58:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipGetLinkedThumbnailIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipGetLinkedThumbnailIndArg Class Reference

Get Images List Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipGetLinkedThumbnailIndArg:

[legend]
Collaboration diagram for BtBipGetLinkedThumbnailIndArg:

[legend]

Public Types

enum | { ID = 15 }

Public Member Functions

BtBipGetLinkedThumbnailIndArg (const BtBipImageHdlPtr &hdl)
const BtBipImageHdlPtr & | GetImageHdl () const
virtual | ~BtBipGetLinkedThumbnailIndArg ()

Static Public Member Functions

static const BtBipGetLinkedThumbnailIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Get Images List Request Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device tries to poll the list of images from this device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipGetLinkedThumbnailIndArg::BtBipGetLinkedThumbnailIndArg ( const BtBipImageHdlPtr & hdl )

BtBipGetLinkedThumbnailIndArg::~BtBipGetLinkedThumbnailIndArg ( ) [virtual]

Member Function Documentation

const BtBipGetLinkedThumbnailIndArg & BtBipGetLinkedThumbnailIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageHdlPtr& BtBipGetLinkedThumbnailIndArg::GetImageHdl ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipImage Class Reference
[Bluetooth]

An image. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipImage:

[legend]

Public Member Functions

BtBipImage (const BtBipImageHdlPtr &hdl, const DateTime &created, const DateTime &modified)
const DateTime & | GetCreated () const
const BtBipImageHdlPtr & | GetImageHdl () const
const DateTime & | GetModified () const
void | SetCreatedDate (const DateTime &created)
void | SetImageHdl (const BtBipImageHdlPtr &hdl)
void | SetModifiedDate (const DateTime &modified)
virtual | ~BtBipImage ()

Detailed Description

An image.

Constructor & Destructor Documentation

BtBipImage::BtBipImage | ( | const BtBipImageHdlPtr & | hdl,
 |  | const DateTime & | created,
 |  | const DateTime & | modified
 | ) |

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImageDesc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipImageDesc Class Reference
[Bluetooth]

Image Desc. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipImageDesc:

[legend]

Public Member Functions

BtBipEncoding | GetEncoding () const
const BtBipImageFormat::ImageDim & | GetImageDim () const
void | GetImageDim (BtBipImageFormat::ImageDim &dim) const
UINT32 | GetImageSize () const
UINT32 | GetMaxImageSize () const
BtBipTransformation | GetTransformation () const
void | SetEncoding (BtBipEncoding encoding)
void | SetImageDim (UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height)
void | SetImageDim (UINT16 min_width, UINT16 max_width, UINT16 max_height)
void | SetImageDim (UINT16 width, UINT16 height)
void | SetImageSize (UINT32 size)
void | SetMaxImageSize (UINT32 max_size)
void | SetTransformation (BtBipTransformation transformation)

Detailed Description

Image Desc.

If used for Image Put, no ranges for size allowed, fixed Dimension has to be used.

Member Function Documentation

void BtBipImageDesc::SetEncoding ( BtBipEncoding encoding ) [inline]

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipTypes.hpp
Generated on Wed Jan 25 00:58:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImageFormat Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipImageFormat Class Reference
[Bluetooth]

Image format. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipImageFormat:

[legend]

Public Member Functions

BtBipEncoding | GetEncoding () const
const ImageDim & | GetImageDim () const
void | GetImageDim (ImageDim &dim) const
Gets a variable dimension with fixed aspect ratio.
UINT32 | GetMaxImageSize () const
Gets maximum image size in bytes.
BtBipTransformation | GetTransformation () const
Get transformation.
void | SetEncoding (BtBipEncoding encoding)
void | SetImageDim (UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height)
Sets fully variable dimension without respect to the aspect ratio.
void | SetImageDim (UINT16 min_width, UINT16 max_width, UINT16 max_height)
Sets a variable dimension with fixed aspect ratio.
void | SetImageDim (UINT16 width, UINT16 height)
Sets a fixed dimension of an image.
void | SetMaxImageSize (UINT32 max_size)
Sets maximum image size in bytes.
void | SetTransformation (BtBipTransformation transformation)

Data Structures

struct | ImageDim

Detailed Description

Image format.

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImageFormat::ImageDim Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtBipImageFormat::ImageDim

BtBipImageFormat::ImageDim Struct Reference

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Data Fields

UINT16 | max_height
UINT16 | max_width
UINT16 | min_height
UINT16 | min_width

Field Documentation

UINT16 BtBipImageFormat::ImageDim::min_width

The documentation for this struct was generated from the following file:
  • Bluetooth/BIP/BtBipTypes.hpp
Generated on Wed Jan 25 00:58:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImageHdl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipImageHdl Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Public Member Functions

String AsString ()
~BtBipImageHdl ()

Static Public Member Functions

static void | CreateImageHdl (UINT32 id, BtBipImageHdlPtr &hdl_ptr)
Create a new image handle, unique between two reboots.

Friends

class | BtBipController
class | BtBipDataConverter
class | BtBipDeleteImageReq
class | BtBipGetImagePropertiesReq
class | BtBipGetImageReq
class | BtBipGetLinkedAttachmentReq
class | BtBipGetLinkedThumbnailReq
class | BtBipMecelXmlConverter
class | BtBipPutAttachReq
class | BtBipPutImageReq
class | BtBipPutThumbReq
class | BtBipServerService

Constructor & Destructor Documentation

BtBipImageHdl::~BtBipImageHdl ( )

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImageHdlDesc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipImageHdlDesc Class Reference
[Bluetooth]

Image Handle Desc. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipImageHdlDesc:

[legend]

Public Member Functions

BtBipImageHdlDesc ()
const DateTime & | GetCreatedFrom () const
const DateTime & | GetCreatedTo () const
BtBipEncoding | GetEncoding () const
const BtBipImageFormat::ImageDim & | GetImageDim () const
void | GetImageDim (BtBipImageFormat::ImageDim &dim) const
const DateTime & | GetModifiedFrom () const
const DateTime & | GetModifiedTo () const
void | SetCreatedFrom (const DateTime &from)
void | SetCreatedFrom (UINT16 year, UINT16 month, UINT16 day, UINT16 hour=0, UINT16 minute=0, UINT16 second=0)
void | SetCreatedTo (const DateTime &to)
void | SetCreatedTo (UINT16 year, UINT16 month, UINT16 day, UINT16 hour=23, UINT16 minut=59, UINT16 second=59)
void | SetEncoding (BtBipEncoding encoding)
void | SetImageDim (UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height)
void | SetImageDim (UINT16 min_width, UINT16 max_width, UINT16 max_height)
void | SetImageDim (UINT16 width, UINT16 height)
void | SetModifiedFrom (const DateTime &from)
void | SetModifiedFrom (UINT16 year, UINT16 month, UINT16 day, UINT16 hour, UINT16 minute, UINT16 second)
void | SetModifiedTo (const DateTime &to)
void | SetModifiedTo (UINT16 year, UINT16 month, UINT16 day, UINT16 hour, UINT16 minute, UINT16 second)
virtual | ~BtBipImageHdlDesc ()

Detailed Description

Image Handle Desc.

Used for filtering images when a image list is retrieved from remote device.

Constructor & Destructor Documentation

BtBipImageHdlDesc::BtBipImageHdlDesc ( )

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImageList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipImageList Class Reference
[Bluetooth]

List of images. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipImageList:

[legend]

Public Types

typedef Vector< BtBipImagePtr > | ImageList

Public Member Functions

void | AddImage (const BtBipImageHdlPtr &handle, const DateTime &created, const DateTime &modified)
void | AddImage (const BtBipImagePtr &image)
BtBipImageList ()
const ImageList & | GetImageList () const
virtual | ~BtBipImageList ()

Detailed Description

List of images.

Member Typedef Documentation

typedef Vector<BtBipImagePtr> BtBipImageList::ImageList

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImageProperties Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipImageProperties Class Reference
[Bluetooth]

Image properties. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipImageProperties:

[legend]

Public Types

typedef Vector< BtBipAttachmentPtr > | BtBipAttachmentList
typedef Vector< BtBipImageFormatPtr > | BtBipVariantList

Public Member Functions

void | AddAttachment (ApoxiMimeTypeId mime_type, const String &charset, const String &name, UINT32 size, const DateTime &created, const DateTime &modified)
void | AddAttachment (const BtBipAttachmentPtr &attach)
void | AddVariant (BtBipEncoding encoding, UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height, UINT32 max_size, BtBipTransformation transformation)
void | AddVariant (BtBipEncoding encoding, UINT16 min_width, UINT16 max_width, UINT16 max_height, UINT32 max_size, BtBipTransformation transformation)
void | AddVariant (BtBipEncoding encoding, UINT16 width, UINT16 height, UINT32 max_size, BtBipTransformation transformation)
void | AddVariant (const BtBipImageFormatPtr &fmt)
const BtBipAttachmentList & | GetAttachmentList () const
const BtBipImageHdlPtr & | GetImageHdl () const
const String & | GetImageName () const
BtBipEncoding | GetNativeEncoding () const
const BtBipImageFormat & | GetNativeFormat () const
UINT16 | GetNativeHeight () const
UINT32 | GetNativeSize () const
UINT16 | GetNativeWidth () const
const BtBipVariantList & | GetVariantList () const
void | SetFriendlyName (const String &name)
void | SetImageHandle (const BtBipImageHdlPtr &hdl)
void | SetNativeDim (UINT16 width, UINT16 height)
void | SetNativeEncoding (BtBipEncoding encoding)
void | SetNativeFormat (const BtBipImageFormat &fmt)
void | SetNativeSize (UINT32 size)

Detailed Description

Image properties.

Member Typedef Documentation

typedef Vector<BtBipImageFormatPtr> BtBipImageProperties::BtBipVariantList

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipImagingCapabilities Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipImagingCapabilities Class Reference
[Bluetooth]

Imaging Capabilities. More...

#include <Apoxi/Bluetooth/BIP/BtBipTypes.hpp>

Collaboration diagram for BtBipImagingCapabilities:

[legend]

Public Types

typedef Vector< BtBipAttachmentFormatPtr > | BtBipAttachmentFormatList
typedef Vector< BtBipImageFormatPtr > | BtBipImageFormatList

Public Member Functions

void | AddAttachmentFormat (ApoxiMimeTypeId mime_type, const String &charset)
void | AddAttachmentFormat (const BtBipAttachmentFormatPtr &format)
void | AddImageFormat (BtBipEncoding, UINT16 res_x, UINT16 res_y, UINT32 max_size)
void | AddImageFormat (const BtBipImageFormatPtr &format)
BtBipImagingCapabilities ()
UINT8 | GetDpofOptions () const
UINT8 | GetFilterParams () const
BtBipEncoding | GetPrefEncoding () const
const BtBipImageFormat & | GetPreferredFormat () const
UINT16 | GetPrefMaxHeight () const
UINT32 | GetPrefMaxSize () const
UINT16 | GetPrefMaxWidth () const
UINT16 | GetPrefMinHeight () const
UINT16 | GetPrefMinWidth () const
UINT16 | GetPrefTransformation () const
const BtBipAttachmentFormatList & | GetSupportedAttachmentFormatList () const
const BtBipImageFormatList & | GetSupportedImageFormatList () const
BOOLEAN | IsDpofOptionSupported (UINT8 dpof_options) const
BOOLEAN | IsFilterSupported (UINT8 filter) const
void | SetDpofOptions (UINT8 dpof_options)
void | SetFilterParamters (UINT8 filter_params)
void | SetPreferredFormat (BtBipEncoding encoding, UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height, BtBipTransformation transformation, UINT32 max_size)
Set a range for the preferred image size with no resize to the aspect ratio.
void | SetPreferredFormat (BtBipEncoding encoding, UINT16 min_width, UINT16 max_width, UINT16 max_height, BtBipTransformation transformation, UINT32 max_size)
Set a range for the preferred image size with fixed aspect ration.
void | SetPreferredFormat (BtBipEncoding encoding, UINT16 width, UINT16 height, BtBipTransformation transformation, UINT32 max_size)
Set a fixed preferred image size.
void | SetPreferredFormat (const BtBipImageFormat &format)
~BtBipImagingCapabilities ()

Detailed Description

Imaging Capabilities.

Member Typedef Documentation

typedef Vector<BtBipImageFormatPtr> BtBipImagingCapabilities::BtBipImageFormatList

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipTypes.hpp
  • Bluetooth/BIP/BtBipTypes.cpp
Generated on Wed Jan 25 00:58:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipMsgArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipMsgArg Class Reference

Base class for all notification arguments of Bt BIP profile. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipMsgArg:

[legend]

Public Member Functions

BtBipMsgArg ()
virtual ~BtBipMsgArg ()

Detailed Description

Base class for all notification arguments of Bt BIP profile.

Constructor & Destructor Documentation

BtBipMsgArg::BtBipMsgArg ( )

virtual BtBipMsgArg::~BtBipMsgArg ( ) [virtual]

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipMsgArg.hpp
Generated on Wed Jan 25 00:58:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipOpFinishedArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipOpFinishedArg Class Reference

Get Images List Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipOpFinishedArg:

[legend]
Collaboration diagram for BtBipOpFinishedArg:

[legend]

Public Types

enum | { ID = 8 }

Public Member Functions

BtBipOpFinishedArg (BtObexResponseCode obex_rsp, BtRequestType request_type)
BtObexResponseCode | GetObexResult () const
BtRequestType | GetRequestType () const
virtual | ~BtBipOpFinishedArg ()

Static Public Member Functions

static const BtBipOpFinishedArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Get Images List Request Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device tries to poll the list of images from this device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipOpFinishedArg::BtBipOpFinishedArg | ( | BtObexResponseCode | obex_rsp,
 |  | BtRequestType | request_type
 | ) |

BtBipOpFinishedArg::~BtBipOpFinishedArg ( ) [virtual]

Member Function Documentation

const BtBipOpFinishedArg & BtBipOpFinishedArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

BtObexResponseCode BtBipOpFinishedArg::GetObexResult ( ) const [inline]

BtRequestType BtBipOpFinishedArg::GetRequestType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipProgressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipProgressMsg Class Reference

#include <Apoxi/Bluetooth/BIP/BtBipServiceMsg.hpp>

Inheritance diagram for BtBipProgressMsg:

[legend]
Collaboration diagram for BtBipProgressMsg:

[legend]

Public Types

enum | { ID = 10506 }

Public Member Functions

BtBipProgressMsg (BtService *service, const BtRequestType &request_type, UINT32 bytes_processed)
virtual Message * | Clone () const
UINT32 | GetBytesProcessed () const
virtual const MsgMetaData & | GetMetaData () const
const BtRequestType & | GetRequestType () const
virtual | ~BtBipProgressMsg ()

Detailed Description

BtBipServerServiceMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtBipProgressMsg::BtBipProgressMsg | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | UINT32 | bytes_processed
 | ) |

BtBipProgressMsg::~BtBipProgressMsg ( ) [virtual]

Member Function Documentation

Message * BtBipProgressMsg::Clone ( ) const [virtual]

Reimplemented from BtServiceMessage.

UINT32 BtBipProgressMsg::GetBytesProcessed ( ) const [inline]

const MsgMetaData & BtBipProgressMsg::GetMetaData ( ) const [virtual]

Reimplemented from BtServiceMessage.

const BtRequestType& BtBipProgressMsg::GetRequestType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipServiceMsg.hpp
  • Bluetooth/BIP/BtBipServiceMsg.cpp
Generated on Wed Jan 25 00:58:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipPutImageCompleteArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipPutImageCompleteArg Class Reference

Put Image Complete. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipPutImageCompleteArg:

[legend]
Collaboration diagram for BtBipPutImageCompleteArg:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

BtBipPutImageCompleteArg (const BtBipImageHdlPtr &img_hdl)
const BtBipImageHdlPtr & | GetImageHdl ()
virtual | ~BtBipPutImageCompleteArg ()

Static Public Member Functions

static const BtBipPutImageCompleteArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Put Image Complete.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, when an incoming put image request is finished.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipPutImageCompleteArg::BtBipPutImageCompleteArg ( const BtBipImageHdlPtr & img_hdl )

BtBipPutImageCompleteArg::~BtBipPutImageCompleteArg ( ) [virtual]

Member Function Documentation

const BtBipPutImageCompleteArg & BtBipPutImageCompleteArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageHdlPtr& BtBipPutImageCompleteArg::GetImageHdl ( ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipPutImageIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipPutImageIndArg Class Reference

Put Image Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipPutImageIndArg:

[legend]
Collaboration diagram for BtBipPutImageIndArg:

[legend]

Public Types

enum

Public Member Functions

BtBipPutImageIndArg (const WString &name, const BtBipImageDescPtr &img_desc)
const BtBipImageDescPtr & | GetImageDesc () const
const WString & | GetImageName () const
virtual | ~BtBipPutImageIndArg ()

Static Public Member Functions

static const BtBipPutImageIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Put Image Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to push a picture to this device.

Member Enumeration Documentation

anonymous enum

Constructor & Destructor Documentation

BtBipPutImageIndArg::BtBipPutImageIndArg | ( | const WString & | name,
 |  | const BtBipImageDescPtr & | img_desc
 | ) |

BtBipPutImageIndArg::~BtBipPutImageIndArg ( ) [virtual]

Member Function Documentation

const BtBipPutImageIndArg & BtBipPutImageIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageDescPtr& BtBipPutImageIndArg::GetImageDesc ( ) const [inline]

const WString& BtBipPutImageIndArg::GetImageName ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipPutLinkedAttachmentCompleteArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipPutLinkedAttachmentCompleteArg Class Reference

Put Image Complete. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipPutLinkedAttachmentCompleteArg:

[legend]
Collaboration diagram for BtBipPutLinkedAttachmentCompleteArg:

[legend]

Public Types

enum | { ID = 13 }

Public Member Functions

BtBipPutLinkedAttachmentCompleteArg (const BtBipImageHdlPtr &img_hdl)
const BtBipImageHdlPtr & | GetImageHdl ()
virtual | ~BtBipPutLinkedAttachmentCompleteArg ()

Static Public Member Functions

static const BtBipPutLinkedAttachmentCompleteArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Put Image Complete.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, when an incoming put image request is finished.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipPutLinkedAttachmentCompleteArg::BtBipPutLinkedAttachmentCompleteArg ( const BtBipImageHdlPtr & img_hdl )

BtBipPutLinkedAttachmentCompleteArg::~BtBipPutLinkedAttachmentCompleteArg ( ) [virtual]

Member Function Documentation

const BtBipPutLinkedAttachmentCompleteArg & BtBipPutLinkedAttachmentCompleteArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageHdlPtr& BtBipPutLinkedAttachmentCompleteArg::GetImageHdl ( ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:58:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipPutLinkedAttachmentInd Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipPutLinkedAttachmentInd Class Reference

Put Linked Attachment Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipPutLinkedAttachmentInd:

[legend]
Collaboration diagram for BtBipPutLinkedAttachmentInd:

[legend]

Detailed Description

Put Linked Attachment Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to push an attachment of an image to this device.

The documentation for this class was generated from the following file:
  • Bluetooth/BIP/BtBipMsgArg.hpp
Generated on Wed Jan 25 00:58:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipPutLinkedAttachmentIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipPutLinkedAttachmentIndArg Class Reference

Put Image Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipPutLinkedAttachmentIndArg:

[legend]
Collaboration diagram for BtBipPutLinkedAttachmentIndArg:

[legend]

Public Types

enum | { ID = 12 }

Public Member Functions

BtBipPutLinkedAttachmentIndArg (const BtBipImageHdlPtr &img_hdl, const BtBipAttachmentDescPtr &attach_desc)
const BtBipAttachmentDescPtr & | GetAttachmentDesc () const
const BtBipImageHdlPtr & | GetImageHdl () const
virtual | ~BtBipPutLinkedAttachmentIndArg ()

Static Public Member Functions

static const BtBipPutLinkedAttachmentIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Put Image Request Indication.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, whenever a remote device tries to push a picture to this device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipPutLinkedAttachmentIndArg::BtBipPutLinkedAttachmentIndArg | ( | const BtBipImageHdlPtr & | img_hdl,
 |  | const BtBipAttachmentDescPtr & | attach_desc
 | ) |

BtBipPutLinkedAttachmentIndArg::~BtBipPutLinkedAttachmentIndArg ( ) [virtual]

Member Function Documentation

const BtBipPutLinkedAttachmentIndArg & BtBipPutLinkedAttachmentIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipAttachmentDescPtr& BtBipPutLinkedAttachmentIndArg::GetAttachmentDesc ( ) const [inline]

const BtBipImageHdlPtr& BtBipPutLinkedAttachmentIndArg::GetImageHdl ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:59:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipPutLinkedThumbnailCompleteArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipPutLinkedThumbnailCompleteArg Class Reference

Put Image Complete. More...

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipPutLinkedThumbnailCompleteArg:

[legend]
Collaboration diagram for BtBipPutLinkedThumbnailCompleteArg:

[legend]

Public Types

enum | { ID = 11 }

Public Member Functions

BtBipPutLinkedThumbnailCompleteArg (const BtBipImageHdlPtr &img_hdl)
const BtBipImageHdlPtr & | GetImageHdl ()
virtual | ~BtBipPutLinkedThumbnailCompleteArg ()

Static Public Member Functions

static const BtBipPutLinkedThumbnailCompleteArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Put Image Complete.

An instance of this class is sent with an BtBipServerNotificationMsg to the application, when an incoming put image request is finished.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtBipPutLinkedThumbnailCompleteArg::BtBipPutLinkedThumbnailCompleteArg ( const BtBipImageHdlPtr & img_hdl )

BtBipPutLinkedThumbnailCompleteArg::~BtBipPutLinkedThumbnailCompleteArg ( ) [virtual]

Member Function Documentation

const BtBipPutLinkedThumbnailCompleteArg & BtBipPutLinkedThumbnailCompleteArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageHdlPtr& BtBipPutLinkedThumbnailCompleteArg::GetImageHdl ( ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:59:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipPutLinkedThumbnailIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipPutLinkedThumbnailIndArg Class Reference

Put Linked Thumbnail Request Indication. More...

#include <Apoxi/Bluetooth/BIP/BtBipMsgArg.hpp>

Inheritance diagram for BtBipPutLinkedThumbnailIndArg:

[legend]
Collaboration diagram for BtBipPutLinkedThumbnailIndArg:

[legend]

Public Types

enum

Public Member Functions

BtBipPutLinkedThumbnailIndArg (const BtBipImageHdlPtr &img_hdl)
const BtBipImageHdlPtr & | GetImageHdl () const
virtual | ~BtBipPutLinkedThumbnailIndArg ()

Static Public Member Functions

static const BtBipPutLinkedThumbnailIndArg & | Cast (const BtBipServerNotificationMsgArg &arg)

Detailed Description

Put Linked Thumbnail Request Indication.

An instance of this class is sent with an BtBipNotificationMsg to the application, whenever a remote device tries to push a thumbnail of an image to this device.

Member Enumeration Documentation

anonymous enum

Constructor & Destructor Documentation

BtBipPutLinkedThumbnailIndArg::BtBipPutLinkedThumbnailIndArg ( const BtBipImageHdlPtr & img_hdl )

BtBipPutLinkedThumbnailIndArg::~BtBipPutLinkedThumbnailIndArg ( ) [virtual]

Member Function Documentation

const BtBipPutLinkedThumbnailIndArg & BtBipPutLinkedThumbnailIndArg::Cast ( const BtBipServerNotificationMsgArg & arg ) [inline, static]

const BtBipImageHdlPtr& BtBipPutLinkedThumbnailIndArg::GetImageHdl ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:59:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipServerNotificationMsgArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipServerNotificationMsgArg Class Reference

#include <Apoxi/Bluetooth/BIP/BtBipNotificationMsgArg.hpp>

Inheritance diagram for BtBipServerNotificationMsgArg:

[legend]

Public Member Functions

BtBipServerNotificationMsgArg (INT id)
INT | Id () const
virtual | ~BtBipServerNotificationMsgArg ()

Constructor & Destructor Documentation

BtBipServerNotificationMsgArg::BtBipServerNotificationMsgArg ( INT id )

BtBipServerNotificationMsgArg::~BtBipServerNotificationMsgArg ( ) [virtual]

Member Function Documentation

INT BtBipServerNotificationMsgArg::Id ( ) const [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipNotificationMsgArg.hpp
  • Bluetooth/BIP/BtBipNotificationMsgArg.cpp
Generated on Wed Jan 25 00:59:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBipServerService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBipServerService Class Reference
[Bluetooth]

BIP Server Service (imaging responder). More...

#include <Apoxi/Bluetooth/BIP/BtBipServerService.hpp>

Public Member Functions

BOOLEAN | AbortRsp (BtObexResponseCode obex_result)
Answer incoming abort request.
BtBipServerService ()
Constructor.
BOOLEAN | Cancel (BtObexResponseCode obex_result)
Cancel ongoing put or get operation.
BOOLEAN | ConnectRsp (BtObexResponseCode obex_result)
Answer incoming connect request.
BOOLEAN | DeleteImageRsp (BtObexResponseCode obex_result)
Send response to incoming delete image request.
BOOLEAN | ErrorRsp (BtRequestState rc)
Send an error response to any incoming request.
BOOLEAN | GetImagePropertiesRsp (BtObexResponseCode obex_result, const BtBipImagePropertiesPtr &img_props)
Send response to incoming get image properties request.
BOOLEAN | GetImageRsp (BtObexResponseCode obex_result, UINT32 file_length, const DataSourcePtr &img)
Send response to incoming get image request.
BOOLEAN | GetImagesListRsp (BtObexResponseCode obex_result, const BtBipImageListPtr &image_list, const BtBipImageHdlDescPtr &applied_filter)
Send response to incoming get images list request.
BOOLEAN | GetImagingCapabilitiesRsp (BtObexResponseCode obex_result, const BtBipImagingCapabilitiesPtr &img_cap)
Send response to incoming get imaging capabilities request.
BOOLEAN | GetLinkedAttachmentRsp (BtObexResponseCode obex_result, const DataSourcePtr &attach)
Send response to incming get linked attachment request.
BOOLEAN | GetLinkedThumbnailRsp (BtObexResponseCode obex_result, const DataSourcePtr &thumb)
Send response to incoming get linked thumbnail request.
UINT32 | GetProgressInBytes ()
Get the Bytes already transfered in the current request.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
Get request state.
UINT8 | GetRfComChannel () const
virtual BOOLEAN | IsServerService () const
BOOLEAN | PutImageRsp (BtObexResponseCode obex_result, const BtBipImageHdlPtr &hdl, const DataSinkPtr &image)
Send response to incoming put image request.
BOOLEAN | PutLinkedAttachmentRsp (BtObexResponseCode obex_result, const DataSinkPtr &attach)
Send response to incoming put attachment request.
BOOLEAN | PutLinkedThumbnailRsp (BtObexResponseCode obex_result, const DataSinkPtr &thumb)
Send response to incoming put thumbnail request.
BOOLEAN | RegisterBipServer ()
virtual | ~BtBipServerService ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | RegisterMessages () const
virtual void | UnregisterMessages () const

Friends

class | BtBipController

Detailed Description

BIP Server Service (imaging responder).

This class provides all functionality to act as an imaging responder for BIP. Currently the scenarios of Image Push and Image Pull are supported. Pls. see also the Bluetooth specification for the Basic Imaging Profile. An application acting as BIP server is informed about incoming events by BtBipServerNotificationMsg. The message contains a BtBipServerNotificationMsgArg that denotes what type of request is made by the remote device. The application then has to send the response using this class.

Constructor & Destructor Documentation

BtBipServerService::BtBipServerService ( )

Constructor.

BtBipServerService::~BtBipServerService ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtBipServerService::AbortRsp ( BtObexResponseCode obex_result )

Answer incoming abort request.

If the remote device wants to abort an operation, a BtBipServerNotificationMsg with a BtBipAbortIndArg is sent to the application. The application has to discard all data, that has been received so far and send an abort response.

BOOLEAN BtBipServerService::Cancel ( BtObexResponseCode obex_result )

Cancel ongoing put or get operation.

With this method the following operations can be canceled:

  • Put Image
  • Put Linked Thumbnail
  • Put Linked Attachment
  • Get Image List
  • Get Image Properties
  • Get Image
  • Get Linked Thumbnail
  • Get Linked Attachment

BOOLEAN BtBipServerService::ConnectRsp ( BtObexResponseCode obex_result )

Answer incoming connect request.

The connection to the remote device is established or a reason, why a connection is currently not possible, can be sent.

BOOLEAN BtBipServerService::DeleteImageRsp ( BtObexResponseCode obex_result )

Send response to incoming delete image request.

This method has to be called by the application as response to a Delete indication to inform the remote device, that the image has been deleted.

BOOLEAN BtBipServerService::ErrorRsp ( BtRequestState rc )

Send an error response to any incoming request.

This method can be called by the application to send an error as response to any incoming request.

Parameters:
rc

BOOLEAN BtBipServerService::GetImagePropertiesRsp | ( | BtObexResponseCode | obex_result,
 |  | const BtBipImagePropertiesPtr & | img_props
 | ) |

Send response to incoming get image properties request.

This method has to be called by the application as response to a Get Image Properties indication to send the properties of the requested image to the remote device.

Parameters:
img_props Properties of image given in the incoming Get Image Properties request

BOOLEAN BtBipServerService::GetImageRsp | ( | BtObexResponseCode | obex_result,
 |  | UINT32 | file_length,
 |  | const DataSourcePtr & | img
 | ) |

Send response to incoming get image request.

This method has to be called by the application as response to a Get Image indication to send the requested image to the remote device.

Parameters:
file_length | Length of image data in bytes.
img | Shared pointer to data source, where the binary image data can be read from.

BOOLEAN BtBipServerService::GetImagesListRsp | ( | BtObexResponseCode | obex_result,
 |  | const BtBipImageListPtr & | image_list,
 |  | const BtBipImageHdlDescPtr & | applied_filter
 | ) |

Send response to incoming get images list request.

This method has to be called by the application as response to a Get Images List indication to send the list of images on the local device to the remote device.

Parameters:
image_list | List of images on the local device, setup according to constraints in the incoming Get Images List request.
applied_filter | Filter, that was applied to build the image list.

BOOLEAN BtBipServerService::GetImagingCapabilitiesRsp | ( | BtObexResponseCode | obex_result,
 |  | const BtBipImagingCapabilitiesPtr & | img_cap
 | ) |

Send response to incoming get imaging capabilities request.

This method has to be called by the application as response to a Get Imaging Capabilities indication to send the capabilities of the local device to the remote device.

Parameters:
obex_result | Obex result of the request (usually Success)
img_cap | Imaging capabilities.

BOOLEAN BtBipServerService::GetLinkedAttachmentRsp | ( | BtObexResponseCode | obex_result,
 |  | const DataSourcePtr & | attach
 | ) |

Send response to incming get linked attachment request.

This method has to be called by the application as response to a Get Linked Thumbnail indication to send the requested attachment to the remote device.

Parameters:
attachment Shared pointer to data source, where the binary attachment data can be read from.

BOOLEAN BtBipServerService::GetLinkedThumbnailRsp | ( | BtObexResponseCode | obex_result,
 |  | const DataSourcePtr & | thumb
 | ) |

Send response to incoming get linked thumbnail request.

This method has to be called by the application as response to a Get Linked Thumbnail indication to send the requested thumbnail to the remote device.

Parameters:
thumb Shared pointer to data source, where the binary thumbnail data can be read from.

UINT32 BtBipServerService::GetProgressInBytes ( )

Get the Bytes already transfered in the current request.

If no Get or PUT request is running 0 Bytes are returned

virtual BtRequestState BtBipServerService::GetRequestState ( BtRequestType request_type ) const [inline, virtual]

Get request state.

This server service doesn't use requests, so the returned state will always be BtRqsUnknown

UINT8 BtBipServerService::GetRfComChannel ( ) const

BOOLEAN BtBipServerService::IsServerService ( ) const [virtual]

virtual void BtBipServerService::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [inline, protected, virtual]

BOOLEAN BtBipServerService::PutImageRsp | ( | BtObexResponseCode | obex_result,
 |  | const BtBipImageHdlPtr & | hdl,
 |  | const DataSinkPtr & | image
 | ) |

Send response to incoming put image request.

This method has to be called by the application as response to an Put Image indication to receive the incoming image.

Parameters:
handle | Handle to image that is created on the local device by the put image request
image | DataSink where image data can be written to.

BOOLEAN BtBipServerService::PutLinkedAttachmentRsp | ( | BtObexResponseCode | obex_result,
 |  | const DataSinkPtr & | attach
 | ) |

Send response to incoming put attachment request.

This method has to be called by the application as response to an Put Linked Attachment indication to receive the incoming attachment.

Parameters:
attach DataSink where attachment data can be written to by APOXI BT BIP

BOOLEAN BtBipServerService::PutLinkedThumbnailRsp | ( | BtObexResponseCode | obex_result,
 |  | const DataSinkPtr & | thumb
 | ) |

Send response to incoming put thumbnail request.

This method has to be called by the application as response to an Put Linked Thumbnail indication to receive the incoming thumbnail.

Parameters:
thumb DataSink where thumbnail data can be written to by APOXI BT BIP

BOOLEAN BtBipServerService::RegisterBipServer ( )

void BtBipServerService::RegisterMessages ( ) const [protected, virtual]

void BtBipServerService::UnregisterMessages ( ) const [protected, virtual]

Friends And Related Function Documentation

friend class BtBipController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BIP/BtBipServerService.hpp
  • Bluetooth/BIP/BtBipServerService.cpp
Generated on Wed Jan 25 00:59:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppClientService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppClientService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BPP/BtBppClientService.hpp>

Inheritance diagram for BtBppClientService:

[legend]
Collaboration diagram for BtBppClientService:

[legend]

Public Member Functions

BtRequestState BppSndAbortReq ()
Abort ongoing print job.
BtRequestState | BppSndFilePush (BppObjectTypeEnum bpp_object_type_enum, const DataSourcePtr &pagetoprint)
Send File to remote BPP device.
BtBppClientService ()
Constructor.
UINT32 | GetProgressInBytes ()
UINT8 | GetProgressInPercent ()
UINT32 | GetProgressTotalBytes ()
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
BtResultCode GetResult ()
Get result code of last operation.
BtBppSndFilePushReqRequest::BppSubstate GetSubState ()
BOOLEAN | IsConnected () const
virtual BOOLEAN | IsServerService () const
virtual | ~BtBppClientService ()
Destructor.

Friends

class | BtBppSndAbortReqRequest
class | BtBppSndFilePushReqRequest

Detailed Description

This is the App interface according to Bluetooth specification for the Basic Printing Profile. Descendants of this class have to override the OnRequestStateChange() method (BtService::OnRequestStateChange()). This method is called, whenever a request changes its state. If the request is finished, the result data can be retrieved using the according getter methods.

Constructor & Destructor Documentation

BtBppClientService::BtBppClientService ( )

Constructor.

BtBppClientService::~BtBppClientService ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtBppClientService::BppSndAbortReq ( )

Abort ongoing print job.

The ongoing print job abortion request is sent to the remote printer.

BtRequestState BtBppClientService::BppSndFilePush | ( | BppObjectTypeEnum | bpp_object_type_enum,
 |  | const DataSourcePtr & | pagetoprint
 | ) |

Send File to remote BPP device.

Send File to remote BPP device, first a device search has to be done. The selected device has then to be passed with this method to establish a BIP connection.

Parameters:
device Device to connect to

UINT32 BtBppClientService::GetProgressInBytes ( ) [inline]

UINT8 BtBppClientService::GetProgressInPercent ( ) [inline]

UINT32 BtBppClientService::GetProgressTotalBytes ( ) [inline]

BtRequestState BtBppClientService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

BtResultCode BtBppClientService::GetResult ( )

Get result code of last operation.

BtBppSndFilePushReqRequest::BppSubstate BtBppClientService::GetSubState ( ) [inline]

BOOLEAN BtBppClientService::IsConnected ( ) const

BOOLEAN BtBppClientService::IsServerService ( ) const [virtual]

Implements BtBppService.

Friends And Related Function Documentation

friend class BtBppSndAbortReqRequest [friend]

friend class BtBppSndFilePushReqRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BPP/BtBppClientService.hpp
  • Bluetooth/BPP/BtBppClientService.cpp
Generated on Wed Jan 25 00:59:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppController Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppController Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BPP/BtBppController.hpp>

Inheritance diagram for BtBppController:

[legend]
Collaboration diagram for BtBppController:

[legend]

Public Member Functions

BtBppController ()
Constructor (default constructor) is private => Singleton.
virtual const WCHAR * | GetName () const
virtual | ~BtBppController ()
Destructor.

Static Public Member Functions

static BtBppController & | GetInstance ()
Get singleton instance.

Protected Member Functions

BOOLEAN | BppSndAbortReq (BtBppSndAbortReqRequest *abortreq)
BOOLEAN | BppSndFilePushReq (BtBppSndFilePushReqRequest *filepushreq)
BOOLEAN | BppSndGetRefObjRsp (BtBppSndGetRefObjRspRequest *getrefobjrsp)

Friends

class | BtBppClientService
class | BtBppServerService
class | BtBppService
class | BtBppSndAbortReqRequest
class | BtBppSndFilePushReqRequest
class | BtBppSndGetRefObjRspRequest

Detailed Description

Bluetooth Bpp profile access class. BtBppController is implemented as Singleton. It provides the interface to the Bluetooth Stack via callbacks.

Constructor & Destructor Documentation

BtBppController::BtBppController ( )

Constructor (default constructor) is private => Singleton.

BtBppController::~BtBppController ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtBppController::BppSndAbortReq ( BtBppSndAbortReqRequest * abortreq ) [protected]

BOOLEAN BtBppController::BppSndFilePushReq ( BtBppSndFilePushReqRequest * filepushreq ) [protected]

BOOLEAN BtBppController::BppSndGetRefObjRsp ( BtBppSndGetRefObjRspRequest * getrefobjrsp ) [protected]

BtBppController & BtBppController::GetInstance ( ) [static]

Get singleton instance.

Returns:
Reference to BtBppController singleton instance.

const WCHAR * BtBppController::GetName ( ) const [virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

Friends And Related Function Documentation

friend class BtBppClientService [friend]

friend class BtBppServerService [friend]

friend class BtBppService [friend]

friend class BtBppSndAbortReqRequest [friend]

friend class BtBppSndFilePushReqRequest [friend]

friend class BtBppSndGetRefObjRspRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BPP/BtBppController.hpp
  • Bluetooth/BPP/BtBppController.cpp
Generated on Wed Jan 25 00:59:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppReq Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppReq Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BPP/BtBppReq.hpp>

Inheritance diagram for BtBppReq:

[legend]
Collaboration diagram for BtBppReq:

[legend]

Public Member Functions

BtBppReq (BtBppService &obex_service)
Constructor.
virtual | ~BtBppReq ()
Destructor.

Protected Member Functions

virtual BtRequestState | ChangeRequestState (BOOLEAN success)
Sets the new state depending on the success.
virtual BOOLEAN | EvaluateExecutionResult (BtResultCode result)
void | SetBppResult (BtBppResult res)
void | SetObexResult (UINT8 res)
virtual void | SetRequestState (BtRequestState request_state)
Set processing state of this request.

Friends

class | BtBppController

Constructor & Destructor Documentation

BtBppReq::BtBppReq ( BtBppService & obex_service )

Constructor.

BtBppReq::~BtBppReq ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtBppReq::ChangeRequestState ( BOOLEAN success ) [protected, virtual]

Sets the new state depending on the success.

ChangeRequestState is a function that is used by the ExecuteRequest and the EvaluateMessageResult functions to do the change of the request state. Depending on the current state and the passed in success, this function sets the right new state. The passed in success parameter can be on the one hand the result of a function call, on the other hand the result parameter of a message sent up to the request by the apropriate controller.

Parameters:
success A BOOLEAN indicating the success of the operation execution stage corresponding to the current state.
Returns:
A BtRequestState containing the new request state after doing the state transition.

Reimplemented from BtRequest.

Reimplemented in BtBppSndAbortReqRequest, and BtBppSndFilePushReqRequest.

BOOLEAN BtBppReq::EvaluateExecutionResult ( BtResultCode result ) [protected, virtual]

Reimplemented from BtRequest.

void BtBppReq::SetBppResult ( BtBppResult res ) [inline, protected]

void BtBppReq::SetObexResult ( UINT8 res ) [inline, protected]

void BtBppReq::SetRequestState ( BtRequestState request_state ) [protected, virtual]

Set processing state of this request.

A request can be seen as it goes through several stages in its execution process. SetRequestState can be used to set the current stage of execution. When the passed in state is other than the current state the OnRequestStateChange callback function will be invoked.

Parameters:
request_state A BtRequestState containing the current stage of exection which has to be set for this request.

Reimplemented from BtServiceRequest.

Reimplemented in BtBppSndAbortReqRequest, and BtBppSndFilePushReqRequest.

Friends And Related Function Documentation

friend class BtBppController [friend]

Reimplemented in BtBppSndAbortReqRequest, BtBppSndFilePushReqRequest, and BtBppSndGetRefObjRspRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/BPP/BtBppReq.hpp
  • Bluetooth/BPP/BtBppReq.cpp
Generated on Wed Jan 25 00:59:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/BPP/BtBppServiceMessage.hpp>

Inheritance diagram for BtBppRequestStateChangedMessage:

[legend]
Collaboration diagram for BtBppRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10316 }

Public Member Functions

BtBppRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtBppRequestStateChangedMessage ()

Detailed Description

BtBppRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtBppRequestStateChangedMessage::BtBppRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtBppRequestStateChangedMessage::~BtBppRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtBppRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtBppRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BPP/BtBppServiceMessage.hpp
  • Bluetooth/BPP/BtBppServiceMessage.cpp
Generated on Wed Jan 25 00:59:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppServerService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppServerService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BPP/BtBppServerService.hpp>

Inheritance diagram for BtBppServerService:

[legend]
Collaboration diagram for BtBppServerService:

[legend]

Public Member Functions

BtRequestState | BppSndGetRefObjRsp (const BtDeviceAddress &device, BppObjectTypeEnum bpp_object_type_enum, const Pathname &pathname)
BtBppServerService ()
Constructor.
BOOLEAN | ConnectResponse ()
Answer incoming connect request.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
UINT8 | GetRfComChannel () const
virtual BOOLEAN | IsServerService () const
virtual BtRequestState | RegisterRequest (UINT8 *header_buffer, UINT16 header_buffer_size, BtSecuritySettings security_settings=BtSesNoSecurity)
virtual BtRequestState | UnregisterRequest ()
virtual | ~BtBppServerService ()
Destructor.

Constructor & Destructor Documentation

BtBppServerService::BtBppServerService ( )

Constructor.

virtual BtBppServerService::~BtBppServerService ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtBppServerService::BppSndGetRefObjRsp | ( | const BtDeviceAddress & | device,
 |  | BppObjectTypeEnum | bpp_object_type_enum,
 |  | const Pathname & | pathname
 | ) |

BOOLEAN BtBppServerService::ConnectResponse ( )

Answer incoming connect request.

The connection to the remote device is established.

virtual BtRequestState BtBppServerService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

UINT8 BtBppServerService::GetRfComChannel ( ) const

virtual BOOLEAN BtBppServerService::IsServerService ( ) const [virtual]

Implements BtBppService.

virtual BtRequestState BtBppServerService::RegisterRequest | ( | UINT8 * | header_buffer,
 |  | UINT16 | header_buffer_size,
 |  | BtSecuritySettings | security_settings = BtSesNoSecurity
 | ) | [virtual]

virtual BtRequestState BtBppServerService::UnregisterRequest ( ) [virtual]

The documentation for this class was generated from the following file:
  • Bluetooth/BPP/BtBppServerService.hpp
Generated on Wed Jan 25 00:59:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppService Class Reference
[Bluetooth]

Base class for BIP service classes. More...

#include <Apoxi/Bluetooth/BPP/BtBppService.hpp>

Inheritance diagram for BtBppService:

[legend]
Collaboration diagram for BtBppService:

[legend]

Public Member Functions

BtBppService ()
Constructor.
virtual BtProfile | GetProfile () const
Get the profile this service is associated with.
virtual BOOLEAN | IsServerService () const =0
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)
virtual | ~BtBppService ()
Destructor.

Protected Member Functions

virtual void | RegisterMessages () const
void | RemoveDispatcher ()
void | SetDispatcher ()
virtual void | UnregisterMessages () const

Detailed Description

Base class for BIP service classes.

Constructor & Destructor Documentation

BtBppService::BtBppService ( )

Constructor.

BtBppService::~BtBppService ( ) [virtual]

Destructor.

Member Function Documentation

BtProfile BtBppService::GetProfile ( ) const [virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface, so in the base class, it is a pure virtual function.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implements BtService.

virtual BOOLEAN BtBppService::IsServerService ( ) const [pure virtual]

Implemented in BtBppClientService, and BtBppServerService.

BOOLEAN BtBppService::OnMessage ( const Message & msg ) [virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void BtBppService::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

void BtBppService::RemoveDispatcher ( ) [protected]

void BtBppService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [virtual]

Implements BtService.

void BtBppService::SetDispatcher ( ) [protected]

void BtBppService::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/BPP/BtBppService.hpp
  • Bluetooth/BPP/BtBppService.cpp
Generated on Wed Jan 25 00:59:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppSndAbortReqRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppSndAbortReqRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BPP/BtBppSndAbortReqRequest.hpp>

Inheritance diagram for BtBppSndAbortReqRequest:

[legend]
Collaboration diagram for BtBppSndAbortReqRequest:

[legend]

Public Member Functions

BtBppSndAbortReqRequest (BtBppClientService &Bpp_client_service)
Constructor.
virtual BtRequestState | ChangeRequestState (BOOLEAN success)
Sets the new state depending on the success.
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtDevice | GetTargetDevice () const
virtual void | SetRequestState (BtRequestState request_state)
Set processing state of this request.
virtual | ~BtBppSndAbortReqRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)

Friends

class | BtBppController

Constructor & Destructor Documentation

BtBppSndAbortReqRequest::BtBppSndAbortReqRequest ( BtBppClientService & Bpp_client_service )

Constructor.

BtBppSndAbortReqRequest::~BtBppSndAbortReqRequest ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtBppSndAbortReqRequest::ChangeRequestState ( BOOLEAN success ) [virtual]

Sets the new state depending on the success.

ChangeRequestState is a function that is used by the ExecuteRequest and the EvaluateMessageResult functions to do the change of the request state. Depending on the current state and the passed in success, this function sets the right new state. The passed in success parameter can be on the one hand the result of a function call, on the other hand the result parameter of a message sent up to the request by the apropriate controller.

Parameters:
success A BOOLEAN indicating the success of the operation execution stage corresponding to the current state.
Returns:
A BtRequestState containing the new request state after doing the state transition.

Reimplemented from BtBppReq.

BOOLEAN BtBppSndAbortReqRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtBppSndAbortReqRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

BtRequestType BtBppSndAbortReqRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtDevice BtBppSndAbortReqRequest::GetTargetDevice ( ) const

void BtBppSndAbortReqRequest::SetRequestState ( BtRequestState request_state ) [virtual]

Set processing state of this request.

A request can be seen as it goes through several stages in its execution process. SetRequestState can be used to set the current stage of execution. When the passed in state is other than the current state the OnRequestStateChange callback function will be invoked.

Parameters:
request_state A BtRequestState containing the current stage of exection which has to be set for this request.

Reimplemented from BtBppReq.

Friends And Related Function Documentation

friend class BtBppController [friend]

Reimplemented from BtBppReq.

The documentation for this class was generated from the following files:
  • Bluetooth/BPP/BtBppSndAbortReqRequest.hpp
  • Bluetooth/BPP/BtBppSndAbortReqRequest.cpp
Generated on Wed Jan 25 00:59:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppSndFilePushReqRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppSndFilePushReqRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp>

Inheritance diagram for BtBppSndFilePushReqRequest:

[legend]
Collaboration diagram for BtBppSndFilePushReqRequest:

[legend]

Public Types

enum BppSubstate {
bpp_state1_initial, bpp_state2_pushsent, bpp_state3_connect_ind_received_ok, bpp_state3_connect_ind_received_failed,
bpp_state4_push_cfm_received_ok_send_more, bpp_state4_push_cfm_received_ok_final, bpp_state4_push_cfm_received_failed, bpp_state5_abort_cfm_received,
bpp_state6_disconnect_ind_received
}

Public Member Functions

BtBppSndFilePushReqRequest (BtBppClientService &Bpp_client_service)
Constructor.
virtual BtRequestState | ChangeRequestState (BOOLEAN success)
Sets the new state depending on the success.
BppSubstate GetBppSubState ()
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtDevice | GetTargetDevice () const
void | SetBppSubState (BppSubstate substate)
void | SetBuffer (UINT8 *buffer, UINT32 buff_used_bytes, UINT32 total_body_length, BOOLEAN is_final_buff)
void | SetObjectDescription (WCHAR *object_description)
void | SetObjectName (WCHAR *object_name)
void | SetObjectType (BppObjectTypeEnum bpp_object_type)
virtual void | SetRequestState (BtRequestState request_state)
Set processing state of this request.
void | SetTargetDevice (const BtDevice &target_device)
virtual | ~BtBppSndFilePushReqRequest ()
Destructor.

Data Fields

UINT8 * | buff
UINT32 | buff_used_bytes

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)
btapi_bpp_snd_file_push_req_t * | GetApiSettings ()

Friends

class | BtBppController

Member Enumeration Documentation

enum BtBppSndFilePushReqRequest::BppSubstate

Enumerator:
bpp_state1_initial
bpp_state2_pushsent
bpp_state3_connect_ind_received_ok
bpp_state3_connect_ind_received_failed
bpp_state4_push_cfm_received_ok_send_more
bpp_state4_push_cfm_received_ok_final
bpp_state4_push_cfm_received_failed
bpp_state5_abort_cfm_received
bpp_state6_disconnect_ind_received

Constructor & Destructor Documentation

BtBppSndFilePushReqRequest::BtBppSndFilePushReqRequest ( BtBppClientService & Bpp_client_service )

Constructor.

BtBppSndFilePushReqRequest::~BtBppSndFilePushReqRequest ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtBppSndFilePushReqRequest::ChangeRequestState ( BOOLEAN success ) [virtual]

Sets the new state depending on the success.

ChangeRequestState is a function that is used by the ExecuteRequest and the EvaluateMessageResult functions to do the change of the request state. Depending on the current state and the passed in success, this function sets the right new state. The passed in success parameter can be on the one hand the result of a function call, on the other hand the result parameter of a message sent up to the request by the apropriate controller.

Parameters:
success A BOOLEAN indicating the success of the operation execution stage corresponding to the current state.
Returns:
A BtRequestState containing the new request state after doing the state transition.

Reimplemented from BtBppReq.

BOOLEAN BtBppSndFilePushReqRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtBppSndFilePushReqRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

btapi_bpp_snd_file_push_req_t * BtBppSndFilePushReqRequest::GetApiSettings ( ) [protected]

BppSubstate BtBppSndFilePushReqRequest::GetBppSubState ( ) [inline]

BtRequestType BtBppSndFilePushReqRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtDevice BtBppSndFilePushReqRequest::GetTargetDevice ( ) const

void BtBppSndFilePushReqRequest::SetBppSubState ( BppSubstate substate ) [inline]

void BtBppSndFilePushReqRequest::SetBuffer | ( | UINT8 * | buffer,
 |  | UINT32 | buff_used_bytes,
 |  | UINT32 | total_body_length,
 |  | BOOLEAN | is_final_buff
 | ) |

void BtBppSndFilePushReqRequest::SetObjectDescription ( WCHAR * object_description )

void BtBppSndFilePushReqRequest::SetObjectName ( WCHAR * object_name )

void BtBppSndFilePushReqRequest::SetObjectType ( BppObjectTypeEnum bpp_object_type )

void BtBppSndFilePushReqRequest::SetRequestState ( BtRequestState request_state ) [virtual]

Set processing state of this request.

A request can be seen as it goes through several stages in its execution process. SetRequestState can be used to set the current stage of execution. When the passed in state is other than the current state the OnRequestStateChange callback function will be invoked.

Parameters:
request_state A BtRequestState containing the current stage of exection which has to be set for this request.

Reimplemented from BtBppReq.

void BtBppSndFilePushReqRequest::SetTargetDevice ( const BtDevice & target_device )

Friends And Related Function Documentation

friend class BtBppController [friend]

Reimplemented from BtBppReq.

Field Documentation

UINT8* BtBppSndFilePushReqRequest::buff

UINT32 BtBppSndFilePushReqRequest::buff_used_bytes

The documentation for this class was generated from the following files:
  • Bluetooth/BPP/BtBppSndFilePushReqRequest.hpp
  • Bluetooth/BPP/BtBppSndFilePushReqRequest.cpp
Generated on Wed Jan 25 00:59:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtBppSndGetRefObjRspRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtBppSndGetRefObjRspRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp>

Inheritance diagram for BtBppSndGetRefObjRspRequest:

[legend]
Collaboration diagram for BtBppSndGetRefObjRspRequest:

[legend]

Public Member Functions

BtBppSndGetRefObjRspRequest (BtBppClientService &Bpp_client_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtDevice | GetTargetDevice () const
void | SetTargetDevice (const BtDevice &target_device)
virtual | ~BtBppSndGetRefObjRspRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)
btapi_bpp_snd_get_ref_obj_ind_t * | GetApiSettings ()

Friends

class | BtBppController

Constructor & Destructor Documentation

BtBppSndGetRefObjRspRequest::BtBppSndGetRefObjRspRequest ( BtBppClientService & Bpp_client_service )

Constructor.

BtBppSndGetRefObjRspRequest::~BtBppSndGetRefObjRspRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtBppSndGetRefObjRspRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

virtual void BtBppSndGetRefObjRspRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

btapi_bpp_snd_get_ref_obj_ind_t * BtBppSndGetRefObjRspRequest::GetApiSettings ( ) [protected]

BtRequestType BtBppSndGetRefObjRspRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtDevice BtBppSndGetRefObjRspRequest::GetTargetDevice ( ) const

void BtBppSndGetRefObjRspRequest::SetTargetDevice ( const BtDevice & target_device )

Friends And Related Function Documentation

friend class BtBppController [friend]

Reimplemented from BtBppReq.

The documentation for this class was generated from the following files:
  • Bluetooth/BPP/BtBppSndGetRefObjRspRequest.hpp
  • Bluetooth/BPP/BtBppSndGetRefObjRspRequest.cpp
Generated on Wed Jan 25 00:59:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtCancelableBroadcastRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtCancelableBroadcastRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtCancelableBroadcastRequest.hpp>

Inheritance diagram for BtCancelableBroadcastRequest:

[legend]
Collaboration diagram for BtCancelableBroadcastRequest:

[legend]

Public Member Functions

BtCancelableBroadcastRequest ()
Constructor.
virtual ~BtCancelableBroadcastRequest ()
Destructor.

Detailed Description

BtCancelableBroadcastRequest is a child class of BtCancelableRequest and implements the common properties for requests that realize a broadcast (all devices in the range) communication and that can be interrupted. Any further concrete requests that address all devices in its range and that can be canceled are not directly derived from BtRequest. Instead of this they should be child classes of BtCancelableBroadcastRequest.
See BtRequest for a complete description of Bluetooth requests.

Constructor & Destructor Documentation

BtCancelableBroadcastRequest::BtCancelableBroadcastRequest ( )

Constructor.

BtCancelableBroadcastRequest::~BtCancelableBroadcastRequest ( ) [virtual]

Destructor.

The documentation for this class was generated from the following files:
  • Bluetooth/BtCancelableBroadcastRequest.hpp
  • Bluetooth/BtCancelableBroadcastRequest.cpp
Generated on Wed Jan 25 00:59:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtCancelableMulticastRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtCancelableMulticastRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtCancelableMulticastRequest.hpp>

Inheritance diagram for BtCancelableMulticastRequest:

[legend]
Collaboration diagram for BtCancelableMulticastRequest:

[legend]

Public Member Functions

BtCancelableMulticastRequest (const BtDeviceList &device_list)
Constructor.
const BtDeviceList & | GetDeviceList () const
Get target of this request.
BtDeviceList & GetDeviceList ()
Get target of this request.
void | SetDeviceList (const BtDeviceList &device_list)
Set target of this request.
virtual | ~BtCancelableMulticastRequest ()
Destructor.

Detailed Description

BtCancelableMulticastRequest is a child class of BtCancelableRequest and implements the common properties for requests that realize multi device communication and that can be interrupted. Any further concrete requests that address more than one and not all devices in its range and that can be canceled are not directly derived from BtRequest. Instead of this they should be child classes of BtCancelableMulticastRequest.
See BtRequest for a complete description of Bluetooth requests.

Constructor & Destructor Documentation

BtCancelableMulticastRequest::BtCancelableMulticastRequest ( const BtDeviceList & device_list )

Constructor.

BtCancelableMulticastRequest::~BtCancelableMulticastRequest ( ) [virtual]

Destructor.

Member Function Documentation

const BtDeviceList & BtCancelableMulticastRequest::GetDeviceList ( ) const

Get target of this request.

GetDevice returns the target this request is associated with.

Returns:
A reference to a BtDevice representing the target of this request.

BtDeviceList & BtCancelableMulticastRequest::GetDeviceList ( )

Get target of this request.

GetDevice returns the target this request is associated with.

Returns:
A reference to a BtDevice representing the target of this request.

void BtCancelableMulticastRequest::SetDeviceList ( const BtDeviceList & device_list )

Set target of this request.

SetDevice sets the target this request should be associated with. This request copies the passed in device to avoid dangling pointers when the request lives and the associated device description is destroyed.

Parameters:
device A reference to a BtDevice that should be the target this request should be associated with.

The documentation for this class was generated from the following files:
  • Bluetooth/BtCancelableMulticastRequest.hpp
  • Bluetooth/BtCancelableMulticastRequest.cpp
Generated on Wed Jan 25 00:59:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtCancelableRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtCancelableRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtCancelableRequest.hpp>

Inheritance diagram for BtCancelableRequest:

[legend]
Collaboration diagram for BtCancelableRequest:

[legend]

Public Member Functions

BtCancelableRequest ()
Constructor.
virtual BOOLEAN | IsCancelable () const
Can execution of this request be stopped.
virtual | ~BtCancelableRequest ()
Destructor.

Detailed Description

BtCancelableRequest is a child class of BtRequest and implements the common properties for request that can be interrupted. Any further concrete requests that can be canceled are not directly derived from BtRequest. Instead of this they should be child classes of BtCancelableRequest.
See BtRequest for a complete description of Bluetooth requests.

Constructor & Destructor Documentation

BtCancelableRequest::BtCancelableRequest ( )

Constructor.

BtCancelableRequest::~BtCancelableRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtCancelableRequest::IsCancelable ( ) const [virtual]

Can execution of this request be stopped.

So kinds of requests have a very long duration. Most of these requests can be interrupted. Other request once submitted can not be stopped. So IsCancelable returns whether a request can be canceled or not. This function is pure virtual in BtRequest because it depends on the kind of request if it is cancelable. BtCancelableRequest is the base class for all requests that can be interrupted. So IsCancelable can be implemented here to return allways TRUE.

Returns:
TRUE: This request can be canceled.

Implements BtRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/BtCancelableRequest.hpp
  • Bluetooth/BtCancelableRequest.cpp
Generated on Wed Jan 25 00:59:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtCancelSearchMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtCancelSearchMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtCancelSearchMessage:

[legend]
Collaboration diagram for BtCancelSearchMessage:

[legend]

Public Types

enum | { ID = 10223 }

Public Member Functions

BtCancelSearchMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtCancelSearchMessage ()

Detailed Description

BtCancelSearchMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtCancelSearchMessage::BtCancelSearchMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtCancelSearchMessage::~BtCancelSearchMessage ( ) [virtual]

Member Function Documentation

Message * BtCancelSearchMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtCancelSearchMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtCancelVerifyMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtCancelVerifyMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtCancelVerifyMessage:

[legend]
Collaboration diagram for BtCancelVerifyMessage:

[legend]

Public Types

enum | { ID = 10235 }

Public Member Functions

BtCancelVerifyMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtCancelVerifyMessage ()

Detailed Description

BtCancelVerifyMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtCancelVerifyMessage::BtCancelVerifyMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtCancelVerifyMessage::~BtCancelVerifyMessage ( ) [virtual]

Member Function Documentation

Message * BtCancelVerifyMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtCancelVerifyMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtChipBmscr Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtChipBmscr Struct Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtTypes.hpp>

Data Fields

BtChipType chip_type
UINT16 | lc_fw_vers
UINT16 | lm_fw_vers

Field Documentation

BtChipType BtChipBmscr::chip_type

UINT16 BtChipBmscr::lc_fw_vers

UINT16 BtChipBmscr::lm_fw_vers

The documentation for this struct was generated from the following file:
  • Bluetooth/BtTypes.hpp
Generated on Wed Jan 25 00:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtChipBmu Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtChipBmu Struct Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtTypes.hpp>

Data Fields

BtChipType chip_type
UINT8 | fw_build [3]
UINT8 | fw_patch
UINT8 | fw_revision
UINT8 | fw_varinat
UINT8 | hw_platform
UINT8 | hw_revision
UINT8 | hw_variant

Field Documentation

BtChipType BtChipBmu::chip_type

UINT8 BtChipBmu::fw_build[3]

UINT8 BtChipBmu::fw_patch

UINT8 BtChipBmu::fw_revision

UINT8 BtChipBmu::fw_varinat

UINT8 BtChipBmu::hw_platform

UINT8 BtChipBmu::hw_revision

UINT8 BtChipBmu::hw_variant

The documentation for this struct was generated from the following file:
  • Bluetooth/BtTypes.hpp
Generated on Wed Jan 25 00:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtChipVersion Union Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtChipVersion Union Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtTypes.hpp>

Collaboration diagram for BtChipVersion:

[legend]

Data Fields

BtChipBmscr bmscr
BtChipBmu bmu
BtChipType chip_type

Detailed Description

BtChipVersion is the structure which contains information about the BT chip.

Field Documentation

BtChipBmscr BtChipVersion::bmscr

BtChipBmu BtChipVersion::bmu

BtChipType BtChipVersion::chip_type

The documentation for this union was generated from the following file:
  • Bluetooth/BtTypes.hpp
Generated on Wed Jan 25 00:59:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtCloseMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtCloseMessage Class Reference

#include <Apoxi/Bluetooth/BtRequestMessage.hpp>

Inheritance diagram for BtCloseMessage:

[legend]
Collaboration diagram for BtCloseMessage:

[legend]

Public Types

enum | { ID = 10202 }

Public Member Functions

BtCloseMessage (const BtResultCode &result, UINT32 request_id, const BtProfile &profile)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const BtProfile & | GetProfile () const
void | SetProfile (const BtProfile &profile)
virtual | ~BtCloseMessage ()

Detailed Description

BtCloseMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtCloseMessage::BtCloseMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const BtProfile & | profile
 | ) |

BtCloseMessage::~BtCloseMessage ( ) [virtual]

Member Function Documentation

Message * BtCloseMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestMessage.

const MsgMetaData & BtCloseMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestMessage.

const BtProfile& BtCloseMessage::GetProfile ( ) const [inline]

void BtCloseMessage::SetProfile ( const BtProfile & profile ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtRequestMessage.hpp
  • Bluetooth/BtRequestMessage.cpp
Generated on Wed Jan 25 00:59:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtConnectabilityMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtConnectabilityMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtConnectabilityMessage:

[legend]
Collaboration diagram for BtConnectabilityMessage:

[legend]

Public Types

enum | { ID = 10216 }

Public Member Functions

BtConnectabilityMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtConnectabilityMessage ()

Detailed Description

BtConnectabilityMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtConnectabilityMessage::BtConnectabilityMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtConnectabilityMessage::~BtConnectabilityMessage ( ) [virtual]

Member Function Documentation

Message * BtConnectabilityMessage::Clone ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

const MsgMetaData & BtConnectabilityMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtConnectionBasedController Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtConnectionBasedController Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtConnectionBasedController.hpp>

Inheritance diagram for BtConnectionBasedController:

[legend]
Collaboration diagram for BtConnectionBasedController:

[legend]

Public Member Functions

BtConnectionBasedController ()
Constructor.
virtual UINT8 | GetPriority () const
Return the startup priority for this controller.
virtual | ~BtConnectionBasedController ()
Destructor.

Protected Member Functions

virtual btapi_cb_funp_t * | GetCallbackFunctionPointers () const
Return a pointer to the structure of function pointers for the callbacks.
virtual btapi_userid_t | GetUserId () const
Return the user id of this contoller assigned to by the Bluetooth stack.
virtual void | Init ()
Controller initalization function.
virtual BOOLEAN | IsDeviceConnected (const BtDevice &device) const =0
Is the passed in device connected to this profile or not?

Friends

class | BtGapAndSdapController

Detailed Description

The most profiles of Bluetooth must be connect respectively disconnected and also support at least a disconnect operation. Controllers that relate to this kind of profiles are directly or indirectly derived from this class.
BtConnectionBasedController implements the connect and disconnect operations and provides an interface to query the connection state of a device to a particular profile.

Constructor & Destructor Documentation

BtConnectionBasedController::BtConnectionBasedController ( )

Constructor.

BtConnectionBasedController::~BtConnectionBasedController ( ) [virtual]

Destructor.

Member Function Documentation

btapi_cb_funp_t * BtConnectionBasedController::GetCallbackFunctionPointers ( ) const [protected, virtual]

Return a pointer to the structure of function pointers for the callbacks.

When the APOXI Bluetooth is registered at the stack an unique user id is generated. This user id identifies the storage of a structure containing all possible callback function addresses. The storage is allocated by the Bluetooth stack and a pointer to this storate is returned at registration. This pointer is stored in the member variable m_callback_functions.
GetCallbackFunctionPointers enables the access to this member variable.

Returns:
A pointer to a btapi_cb_funp_f, which is a structure containing all the function pointers for all callback functions that are needed by the Bluetooth stack.

Implements BtController.

UINT8 BtConnectionBasedController::GetPriority ( ) const [virtual]

Return the startup priority for this controller.

GetPriority is needed to determine the startup sequence of the various constrollers by which the subsystem manager starts them.
The value 0xFF means that it is the most important controller and should be started first. The value 0x00 denotes the least important controller, that will be started at the end of the controller startup sequence.

Returns:
An UINT8 containing the priority of this controller that describes the point of time in the startup sequence, when to start it.

Reimplemented from SubSystem.

btapi_userid_t BtConnectionBasedController::GetUserId ( ) const [protected, virtual]

Return the user id of this contoller assigned to by the Bluetooth stack.

When the APOXI Bluetooth is registered at the Bluetooth stack an unique id is generated and returned by the Bluetooth stack. This id has to be used at each API call to let the Bluetooth stack determine which set of callback function pointers to use for the invocation of a notification callback.
The user id generated by the Bluetooth stack is for internal use only and so the application programme needs no possibility to access this id.

Returns:
A btapi_userid_t containing the user id assigned by the Bluetooth stack.

Implements BtController.

void BtConnectionBasedController::Init ( ) [protected, virtual]

Controller initalization function.

Implements BtController.

virtual BOOLEAN BtConnectionBasedController::IsDeviceConnected ( const BtDevice & device ) const [protected, pure virtual]

Is the passed in device connected to this profile or not?

IsDeviceConnected is used by the BtService class to determine whether it's target is connected to it's profile or not.
IsDeviceConnected is defined as pure virtual because of the child classes of BtConnectionBasedController have two different implementations of the memory, where they store the to them connected devices. Profiles which can only be used exclusively the implemenation of the storage is a member variable. Profiles that allow more than one device being connected at the same time use the BtDeviceList to remember all the devices which are connected to that profile.

Parameters:
device A reference to a BtDevice containing the remoted device that should be tested whether it is connected to this profile or not.
Returns:
TRUE | The passed in device is correct to this profile.
FALSE | The passed in device is not correct to this profile.

Implemented in BtMultiConnectionController, and BtSingleConnectionController.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

Reimplemented from BtController.

The documentation for this class was generated from the following files:
  • Bluetooth/BtConnectionBasedController.hpp
  • Bluetooth/BtConnectionBasedController.cpp
Generated on Wed Jan 25 00:59:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtConnectionlessController Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtConnectionlessController Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtConnectionlessController.hpp>

Inheritance diagram for BtConnectionlessController:

[legend]
Collaboration diagram for BtConnectionlessController:

[legend]

Public Member Functions

BtConnectionlessController ()
Constructor.
virtual UINT8 | GetPriority () const
Return the startup priority for this controller.
virtual | ~BtConnectionlessController ()
Destructor.

Protected Member Functions

BtServiceRequest * | CleanUpRequestExecution (BtResultCode result_code, BtRequestType request_type)
Finalize the execution of an currently executing request.
virtual btapi_cb_funp_t * | GetCallbackFunctionPointers () const
Return a pointer to the structure of function pointers for the callbacks.
BtServiceRequest * | GetExecutingRequest () const
Return currently executing request.
virtual btapi_userid_t | GetUserId () const
Return the user id of this contoller assigned to by the Bluetooth stack.
virtual void | Init ()
Controller initalization function.
BOOLEAN | PrepareRequestExecution (BtServiceRequest *request)
Perpare the execution of a submitted request.

Friends

class | BtGapAndSdapController

Constructor & Destructor Documentation

BtConnectionlessController::BtConnectionlessController ( )

Constructor.

BtConnectionlessController::~BtConnectionlessController ( ) [virtual]

Destructor.

Member Function Documentation

BtServiceRequest * BtConnectionlessController::CleanUpRequestExecution | ( | BtResultCode | result_code,
 |  | BtRequestType | request_type
 | ) | [protected]

Finalize the execution of an currently executing request.

When a request is submitted to the Bluetooth stack for execution, the Bluetooth stack function can return FALSE, if the request is rejected by the Bluetooth stack, or the appropriate callback function is called to report the state of the ongoing request. In all of these cases CleanUpRequestExecution should be called.
CleanUpRequestExecution determines on the passed in parameters whether the member variable m_executing_request should be cleared or not. When CleanUpRequestExecution resets m_executing_request to 0, the id of the cleared request is returned.

Parameters:
result_code | A BtResultCode containing the result of the execution of the currently ongoing request.
request_type | A BtRequestType containing the kind of request for which the result code is passed in.
Returns:
((UINT32)(-1)) | Depending on result_code and request_type the function decided not to resest m_executing_request to 0.
Any other UINT32 | m_executing_request is set to 0 and the id of the finalized request is returned.

btapi_cb_funp_t * BtConnectionlessController::GetCallbackFunctionPointers ( ) const [protected, virtual]

Return a pointer to the structure of function pointers for the callbacks.

When the APOXI Bluetooth is registered at the stack an unique user id is generated. This user id identifies the storage of a structure containing all possible callback function addresses. The storage is allocated by the Bluetooth stack and a pointer to this storate is returned at registration. This pointer is stored in the member variable m_callback_functions.
GetCallbackFunctionPointers enables the access to this member variable.

Returns:
A pointer to a btapi_cb_funp_f, which is a structure containing all the function pointers for all callback functions that are needed by the Bluetooth stack.

Implements BtController.

BtServiceRequest * BtConnectionlessController::GetExecutingRequest ( ) const [protected]

Return currently executing request.

The execution of requests within the controller is limited to one request at a time. A pointer to the currently running request is stored in the member variable m_executing_request. This member variable is used to save informations about the request during its execution in the Bluetooth stack and to enable the assignment between the callback function calls and the request.

Returns:
A pointer to a BtRequest containing the currently running request or 0, if no reqeust is currently running.

UINT8 BtConnectionlessController::GetPriority ( ) const [virtual]

Return the startup priority for this controller.

GetPriority is needed to determine the startup sequence of the various constrollers by which the subsystem manager starts them.
The value 0xFF means that it is the most important controller and should be started first. The value 0x00 denotes the least important controller, that will be started at the end of the controller startup sequence.

Returns:
An UINT8 containing the priority of this controller that describes the point of time in the startup sequence, when to start it.

Reimplemented from SubSystem.

btapi_userid_t BtConnectionlessController::GetUserId ( ) const [protected, virtual]

Return the user id of this contoller assigned to by the Bluetooth stack.

When the APOXI Bluetooth is registered at the Bluetooth stack an unique id is generated and returned by the Bluetooth stack. This id has to be used at each API call to let the Bluetooth stack determine which set of callback function pointers to use for the invocation of a notification callback.
The user id generated by the Bluetooth stack is for internal use only and so the application programme needs no possibility to access this id.

Returns:
A btapi_userid_t containing the user id assigned by the Bluetooth stack.

Implements BtController.

void BtConnectionlessController::Init ( ) [protected, virtual]

Controller initalization function.

Implements BtController.

BOOLEAN BtConnectionlessController::PrepareRequestExecution ( BtServiceRequest * request ) [protected]

Perpare the execution of a submitted request.

When a request is submitted to the controller for execution PrepareRequestExecution checks if an other request is currently running. If so the function returns FALSE, otherwise the member variable m_executing_request is set to point to the passed in request and TRUE is returned.

Parameters:
request A pointer to a BtRequest, that should be exectuted.
Returns:
TRUE | The passed in request can be executed.
FALSE | There is an other request currently running, so the passed in request can not be executed.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

Reimplemented from BtController.

The documentation for this class was generated from the following files:
  • Bluetooth/BtConnectionlessController.hpp
  • Bluetooth/BtConnectionlessController.cpp
Generated on Wed Jan 25 00:59:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtConnectRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtConnectRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtConnectRequest.hpp>

Inheritance diagram for BtConnectRequest:

[legend]
Collaboration diagram for BtConnectRequest:

[legend]

Public Member Functions

BtConnectRequest (BtService &service)
Constructor.
virtual | ~BtConnectRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
const btapi_connect_t * | GetApiSettings () const
Get access to stack parameters.
virtual BOOLEAN | PerformConnectControllerCall ()=0
Perform stack function call for connect.

Friends

class | BtSingleConnectionController

Detailed Description

Some Bluetooth profiles support a connect operation. BtConnectRequest is the base class for these operations. It implements the basic functionality of the connect operations. Profile specific settings and functinalities are capsuled in pure virtual functions and have to be implemented by the concrete connect operations of the various profiles.

Constructor & Destructor Documentation

BtConnectRequest::BtConnectRequest ( BtService & service )

Constructor.

BtConnectRequest::~BtConnectRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtConnectRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate stack parameters. After performing this it calls the PerformConnectControllerCall function, which is responsible for calling the apropriate stack function.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

const btapi_connect_t * BtConnectRequest::GetApiSettings ( ) const [protected]

Get access to stack parameters.

The parameters that were passed to the stack are stored in the member variable m_api_connect. GetApiConnect permitts reading and writing access to this parameter storage for subclasses.

Returns:
A reference to a btapi_connect_t containing the parameters that where passed to the stack, when invoking the stack function.

virtual BOOLEAN BtConnectRequest::PerformConnectControllerCall ( ) [protected, pure virtual]

Perform stack function call for connect.

Because each service interacts with a different controller, the call into this paritcular controller can not be implemented in the base class, so this function is pure virtual und has to be implemented in the concrete connect requests of the various services.

Returns:
TRUE: The Bluetooth stack accepted the connect operation.
FALSE: The Bluetooth stack rejected the connect operation.

Friends And Related Function Documentation

friend class BtSingleConnectionController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtConnectRequest.hpp
  • Bluetooth/BtConnectRequest.cpp
Generated on Wed Jan 25 00:59:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtController Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtController Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtController.hpp>

Inheritance diagram for BtController:

[legend]
Collaboration diagram for BtController:

[legend]

Public Member Functions

BtController ()
Constructor.
virtual BootSequenceState | InvokeAt () const
Return the point of time within the startup sequence, when to start.
virtual void | OnPowerDown ()
Will be called by the subsystem manager to stop the subsystem.
virtual void | OnPowerUp ()
Will be called by the subsystem manager to start the subsystem.
virtual | ~BtController ()
Destructor.

Protected Member Functions

virtual void | CleanUp ()
Controller clean up function.
virtual btapi_cb_funp_t * | GetCallbackFunctionPointers () const =0
Return a pointer to the structure of function pointers for the callbacks.
BOOLEAN | GetIsRegistered () const
Return the registration state of this controller at the Bluetooth stack.
virtual btapi_userid_t | GetUserId () const =0
Return the user id of this contoller assigned to by the Bluetooth stack.
virtual void | Init ()=0
Controller initalization function.
void | PerformExecutionCallback (BtRequest *request, BtResultCode result)
virtual void | Register ()=0
Registers this controller at the Bluetooth stack.
void | SetIsRegistered (BOOLEAN is_registered)
Set the registration state of this contoller at the Bluetooth stack.
virtual void | Unregister ()=0
Sign this controller off the Bluetooth stack.

Friends

class | BtGapAndSdapController

Detailed Description

All communication with the C-API of the Bluetooth stack is routed through so called "Controllers". They support the C-API with all required callback functions and form the call interface to the C functions, that are made available by the C-API to instruct the Bluetooth stack to perform an operation.
The class BtController is the base class for all controller types. It is inherited from the class SubSystem because of the startup sequence of the various controllers.
Controllers are never used by application programmers, so all interfaces are declared as private. To enable classes the access to the interface friend relationships has to be declared for all classes that use a particular controller. Only the interface that is needed by the parent class SubSystem has been made public.

Constructor & Destructor Documentation

BtController::BtController ( )

Constructor.

BtController::~BtController ( ) [virtual]

Destructor.

Member Function Documentation

void BtController::CleanUp ( ) [protected, virtual]

Controller clean up function.

CleanUp is called by the function OnPowerDown and is used to insure a clean shut down of the controller. Normally this function calls Unregister to sign itself off the Bluetooth stack and must not be overwritten by a derived controller except the controller has to do more than only sign off at the Bluetooth stack.

virtual btapi_cb_funp_t* BtController::GetCallbackFunctionPointers ( ) const [protected, pure virtual]

Return a pointer to the structure of function pointers for the callbacks.

When the APOXI Bluetooth is registered at the stack an unique user id is generated. This user id identifies the storage of a structure containing all possible callback function addresses. The storage is allocated by the Bluetooth stack and a pointer to this storate is returned at registration. This pointer is stored in the member variable m_callback_functions.
GetCallbackFunctionPointers enables the access to this member variable.

Returns:
A pointer to a btapi_cb_funp_f, which is a structure containing all the function pointers for all callback functions that are needed by the Bluetooth stack.

Implemented in BtConnectionBasedController, and BtConnectionlessController.

BOOLEAN BtController::GetIsRegistered ( ) const [protected]

Return the registration state of this controller at the Bluetooth stack.

GetIsRegistered returns whether the controller is successfully registered at the Bluetooth stack or not.

Returns:
TRUE | This controller is registered at the Bluetooth stack.
FALSE | This controller is not registered at the Bluetooth stack.

virtual btapi_userid_t BtController::GetUserId ( ) const [protected, pure virtual]

Return the user id of this contoller assigned to by the Bluetooth stack.

When the APOXI Bluetooth is registered at the Bluetooth stack an unique id is generated and returned by the Bluetooth stack. This id has to be used at each API call to let the Bluetooth stack determine which set of callback function pointers to use for the invocation of a notification callback.
The user id generated by the Bluetooth stack is for internal use only and so the application programme needs no possibility to access this id.

Returns:
A btapi_userid_t containing the user id assigned by the Bluetooth stack.

Implemented in BtConnectionBasedController, and BtConnectionlessController.

virtual void BtController::Init ( ) [protected, pure virtual]

Controller initalization function.

Init is called by the function OnPowerUp and is used to initialize the controller. Normally this function calls Register to register itself at the Bluetooth stack and must not be overwritten by a derivedy controller except the controller has to do more than only registering at the Bluetooth stack.

Implemented in BtConnectionBasedController, and BtConnectionlessController.

SubSystem::BootSequenceState BtController::InvokeAt ( ) const [virtual]

Return the point of time within the startup sequence, when to start.

InvokeAt is needed by the subsystem manager to retrieve the point of time within the startup sequence, when to start this subsystem.

Returns:
A BootSequenceState containing the point of time within the startup sequence when to start this subsystem.

Implements SubSystem.

void BtController::OnPowerDown ( ) [virtual]

Will be called by the subsystem manager to stop the subsystem.

When the system shuts down the subsystem manager is responsible for shutting down all subsystems in a particular order. This order is determined by the BootSequenceState on the one side on the priority within the BootSequenceState on the other side. OnPowerDown is called, when the subsystem manager decides to shut down this subsystem.

Reimplemented from SubSystem.

void BtController::OnPowerUp ( ) [virtual]

Will be called by the subsystem manager to start the subsystem.

When the system starts up, the subsystem manager is responsible for starting up all subsystems in a particular order. This order is determined by the BootSequenceState on the one side on the priority within the BootSequenceState on the other side. OnPowerUp is called, when the subsystem manager decides to start up this subsystem.

Reimplemented from SubSystem.

void BtController::PerformExecutionCallback | ( | BtRequest * | request,
 |  | BtResultCode | result
 | ) | [protected]

virtual void BtController::Register ( ) [protected, pure virtual]

Registers this controller at the Bluetooth stack.

Register registers this controller at the Bluetooth stack. This function is a pure virtual function because each controller has to do other things to register itself at the Bluetooth stack. This function must set the member variable m_is_registered depending on the success of registration. Use SetIsRegistered to set the member variable.

void BtController::SetIsRegistered ( BOOLEAN is_registered ) [protected]

Set the registration state of this contoller at the Bluetooth stack.

SetIsRegistered sets whether the controller is successfully registered at the Bluetooth stack or not. Most times this function is used in the implementations of Register and Unregister, to set the appropriate registration state.

Parameters:
is_registered A BOOLEAN containing whether thiscontroller is registered at the Bluetooth stack or not.

virtual void BtController::Unregister ( ) [protected, pure virtual]

Sign this controller off the Bluetooth stack.

Unregister signs this controller off the Bluetooth stack. This functino is a pure virtual function because each controller has to do other things to sign itself off the Bluetooth stack. This function must set the member variable m_is_registered to FALSE. Use SetIsRegistered to set the member variable.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

Reimplemented in BtConnectionBasedController, and BtConnectionlessController.

The documentation for this class was generated from the following files:
  • Bluetooth/BtController.hpp
  • Bluetooth/BtController.cpp
Generated on Wed Jan 25 00:59:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDevice Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDevice.hpp>

Collaboration diagram for BtDevice:

[legend]

Public Member Functions

BtDevice (const BtDevice &device)
Constructor (copy constructor).
BtDevice (const BtDeviceAddress &address=bt_c_empty_device_address)
Constructor (default constructor).
BtResultCode | GetDeviceAddress (BtDeviceAddress &device_addres) const
Query remote device address.
BtResultCode | GetDeviceAndServiceClass (BtDeviceAndServiceClass &device_and_service_class) const
Query the device and service class.
BtResultCode | GetDeviceName (WString &device_name) const
Query remote device name.
BtResultCode | IsConnected (BOOLEAN &is_connected) const
Is this device connected?
BtResultCode | IsKnown (BOOLEAN &is_paired) const
Is this device stored in the known device list?
BtResultCode | IsPaired (BOOLEAN &is_paired) const
Is this device paired?
BtResultCode | IsTrusted (BOOLEAN &is_trusted) const
Is this device trusted?
BOOLEAN | operator!= (const BtDevice &device) const
inequality compare operator
BOOLEAN | operator== (const BtDevice &device) const
equality compare operator
virtual | ~BtDevice ()
Destructor.

Protected Member Functions

BOOLEAN | GetRemoteDeviceInformation (btapi_known_device_t &remote_device_information) const
Query the Bluetooth stack for remote device information.

Friends

class | BtGapAndSdapController

Detailed Description

BtDevice is an interface class to Bluetooth remote devices. It is used to query the properties like address or name of one particular remote Bluetooth device and it also can be used to query some relationship to the the local device like successfull pairing and trusting.
If these properties should be changed the appropriate request, a subclass of BtRequest has to be executed. For further information about execution of remote device requests look BtRequest and subclasses.

Constructor & Destructor Documentation

BtDevice::BtDevice ( const BtDeviceAddress & address = bt_c_empty_device_address )

Constructor (default constructor).

BtDevice::BtDevice ( const BtDevice & device )

Constructor (copy constructor).

BtDevice::~BtDevice ( ) [virtual]

Destructor.

Member Function Documentation

BtResultCode BtDevice::GetDeviceAddress ( BtDeviceAddress & device_addres ) const

Query remote device address.

GetDeviceAddress queries the Bluetooth address of this device.

Parameters:
device_address A reference to a BtDeviceAddress where to store the Bluetooth address.
Returns:
BtOk: The operation was successfully executed and the device_addres is valid.
BtError: The operation failed. Do not use the returned device_addres.

BtResultCode BtDevice::GetDeviceAndServiceClass ( BtDeviceAndServiceClass & device_and_service_class ) const

Query the device and service class.

GetDeviceAndServiceClass queries the device and service class bits, that where retrieved during an inquiry, of this remote device.

Parameters:
device_and_service_class A reference to a BtDeviceAndServiceClass where to store the device and service class of this device.
Returns:
BtOk: The operation was successfully executed and the device_and_service_class is valid.
BtError: The operation failed. Do not use the returned device_and_service_class.

BtResultCode BtDevice::GetDeviceName ( WString & device_name ) const

Query remote device name.

GetLocalName queries the Bluetooth name of this device.

Parameters:
device_name A reference to an WString where to store the Bluetooth name.
Returns:
BtOk: The operation was successfully executed and the device_name is valid.
BtError: The operation failed. Do not use the returned device_name.

BOOLEAN BtDevice::GetRemoteDeviceInformation ( btapi_known_device_t & remote_device_information ) const [protected]

Query the Bluetooth stack for remote device information.

GetRemoteDeviceInformation queries the device information of this device from the stack. This function is used for the implementation of the most above query functions.

Parameters:
remote_device_information A reference to a btapi_known_device_t where to store the retrieved device information.
Returns:
TRUE: The operation was successfully executed and the remote_device_information is valid.
FALSE: The operation failed. Do not use the returned remote_device_information.

BtResultCode BtDevice::IsConnected ( BOOLEAN & is_connected ) const

Is this device connected?

IsConnected queries whether this remote device has an active connection to the local device or not.

Parameters:
is_connected A reference to a BOOLEAN where to store the connected state of this device.
Returns:
BtOk: The operation was successfully executed and the is_connected is valid.
BtError: The operation failed. Do not use the returned is_connected.

BtResultCode BtDevice::IsKnown ( BOOLEAN & is_paired ) const

Is this device stored in the known device list?

IsKnown queries whether this remote device is known by the local device (means: stored in the knwon device list) or not.

Parameters:
is_knwon A reference to a BOOLEAN where to store the known state of this remote device.
Returns:
BtOk: The operation was successfully executed and the is_valid is valid.
BtError: The operation failed. Do not use the returned is_paired.

BtResultCode BtDevice::IsPaired ( BOOLEAN & is_paired ) const

Is this device paired?

IsPaired queries whether this remote device is paired with the local device or not

Parameters:
is_paired A reference to a BOOLEAN where to store the pairing state of this remote device.
Returns:
BtOk: The operation was successfully executed and the is_paired is valid.
BtError: The operation failed. Do not use the returned is_paired.

BtResultCode BtDevice::IsTrusted ( BOOLEAN & is_trusted ) const

Is this device trusted?

IsTrusted queries whether this remote device is trusted by the local device or not.

Parameters:
is_trusted A reference to a BOOLEAN where to store the trust state of this device.
Returns:
BtOk: The operation was successfully executed and the is_trusted is valid.
BtError: The operation failed. Do not use the returned is_trusted.

BOOLEAN BtDevice::operator!= ( const BtDevice & device ) const

inequality compare operator

operator!= is the comparison operator that checks inequality of two BtDevices.

Parameters:
device A reference to a BtDevice that should be compared to this
Returns:
TRUE: The passed in device is not equal to this device.
FASLE: The passed in device is equal to this device.

BOOLEAN BtDevice::operator== ( const BtDevice & device ) const

equality compare operator

operator== is the comparison operator that checks the equality of two BtDevices.

Parameters:
device A reference to a BtDevice that should be compared to this
Returns:
TRUE: The passed in device is equal to this device.
FASLE: The passed in device is not equal to this device.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDevice.hpp
  • Bluetooth/BtDevice.cpp
Generated on Wed Jan 25 00:59:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceAddress Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceAddress Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceAddress.hpp>

Public Member Functions

WString & | AsString (WString &string) const
Convert to a string.
BtDeviceAddress (const char *pc_device_address)
Constructor (address as string of from "XX[:]XX[:]XX[:]XX[:]XX[:]XX".
BtDeviceAddress (const btapi_bdaddr_t &api_device_address)
Constructor (with Bluetooth stack type).
BtDeviceAddress (const BtDeviceAddress &device_address)
Constructor (copy constructor).
BtDeviceAddress ()
Constructor (default constructor).
const btapi_bdaddr_t & | GetApiDeviceAddress () const
Get address as Bluetooth C-API address.
BOOLEAN | operator!= (const BtDeviceAddress &device_address) const
inequality compare operator
BtDeviceAddress & | operator= (const BtDeviceAddress &device_address)
assignment operator
BOOLEAN | operator== (const BtDeviceAddress &device_address) const
equality compare operator
void | SetApiDeviceAddress (const btapi_bdaddr_t &api_devcie_address)
Set the address to the Bluetooth C-API address.
void | SetStringDeviceAddress (const char *pc_device_address)
~BtDeviceAddress ()
Destructor.

Detailed Description

There is only one unique key to distinguish Bluetooth Devices. This key is a 48 bit value and is called a device address. BtDeviceAddress is an object orientated representation of such a 48 bit device address.

Constructor & Destructor Documentation

BtDeviceAddress::BtDeviceAddress ( )

Constructor (default constructor).

BtDeviceAddress::BtDeviceAddress ( const BtDeviceAddress & device_address )

Constructor (copy constructor).

BtDeviceAddress::BtDeviceAddress ( const btapi_bdaddr_t & api_device_address )

Constructor (with Bluetooth stack type).

BtDeviceAddress::BtDeviceAddress ( const char * pc_device_address )

Constructor (address as string of from "XX[:]XX[:]XX[:]XX[:]XX[:]XX".

BtDeviceAddress::~BtDeviceAddress ( )

Destructor.

Member Function Documentation

WString & BtDeviceAddress::AsString ( WString & string ) const

Convert to a string.

AsString converts the binary representation of this address to a human readable form that looks like: "XX:XX:XX:XX:XX:XX" where the "XX"s are a hexadecimal number in the range of 0x00..0xFF.

Parameters:
string A reference to a WString where to store the converted device address.
Returns:
The reference to a WString that was passed in, to enable the usage of AsString in a string concatenation sequence.

const btapi_bdaddr_t & BtDeviceAddress::GetApiDeviceAddress ( ) const

Get address as Bluetooth C-API address.

GetApiDeviceAddress returns this device address as a btapi_bdaddr_t needed by the Bluetooth stack.

Returns:
A reference to a btapi_bdaddr_t containtng this address as needed by the Bluetooth stack.

BOOLEAN BtDeviceAddress::operator!= ( const BtDeviceAddress & device_address ) const

inequality compare operator

operator!= is the comparison operator that checks inequality of two BtDeviceAddresses.

Parameters:
device_address A reference to a BtDeviceAddress that should be compared to this.
Returns:
TRUE: The passed in device address is not equal to this device address.
FASLE: The passed in device address is equal to this device address.

BtDeviceAddress & BtDeviceAddress::operator= ( const BtDeviceAddress & device_address )

assignment operator

operator= assigns the passed in BtDeviceAddress to this device address.

Parameters:
device_address A reference to a BtDeviceAddress that should assigned to this.
Returns:
A reference to a BtDeviceAddress containing this new assigned address.

BOOLEAN BtDeviceAddress::operator== ( const BtDeviceAddress & device_address ) const

equality compare operator

operator== is the comparison operator that checks equality of two BtDeviceAddress es.

Parameters:
device_address A reference to a BtDeviceAddress that should be compared to this.
Returns:
TRUE: The passed in device address is equal to this device address.
FASLE: The passed in device address is not equal to this device address.

void BtDeviceAddress::SetApiDeviceAddress ( const btapi_bdaddr_t & api_devcie_address )

Set the address to the Bluetooth C-API address.

SetApiDeviceAddress assigns the passed in device address that is in the format that the Bluetooth stack returns to this address.

Parameters:
api_devcie_address A reference to a btapi_bdaddr_t containing the device address, which this address should be assigned to.

void BtDeviceAddress::SetStringDeviceAddress ( const char * pc_device_address )

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceAddress.hpp
  • Bluetooth/BtDeviceAddress.cpp
Generated on Wed Jan 25 00:59:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceAddressGenericObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceAddressGenericObject Class Reference

#include <Applications/BtApp/BtDeviceListsWindows.hpp>

Inheritance diagram for BtDeviceAddressGenericObject:

[legend]
Collaboration diagram for BtDeviceAddressGenericObject:

[legend]

Public Member Functions

BtDeviceAddressGenericObject (const BtDeviceAddress &device_address)
BtDeviceAddressGenericObject (const BtDeviceAddressGenericObject &generic_object)
BtDeviceAddressGenericObject ()
Constructor (default).
virtual GenericObject * | Copy () const
Creates a copy of the object itself, must be overwritten in the derived class.
const BtDeviceAddress & | GetDeviceAddress () const
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class, must be overwritten by the derived class.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself, must be overwritten in the derived class.
virtual | ~BtDeviceAddressGenericObject ()

Constructor & Destructor Documentation

BtDeviceAddressGenericObject::BtDeviceAddressGenericObject ( )

Constructor (default).

BtDeviceAddressGenericObject::BtDeviceAddressGenericObject ( const BtDeviceAddressGenericObject & generic_object )

BtDeviceAddressGenericObject::BtDeviceAddressGenericObject ( const BtDeviceAddress & device_address )

BtDeviceAddressGenericObject::~BtDeviceAddressGenericObject ( ) [virtual]

Member Function Documentation

GenericObject * BtDeviceAddressGenericObject::Copy ( ) const [virtual]

Creates a copy of the object itself, must be overwritten in the derived class.

Implements GenericObject.

const BtDeviceAddress & BtDeviceAddressGenericObject::GetDeviceAddress ( ) const

GenericTypeId BtDeviceAddressGenericObject::GetTypeId ( ) [virtual]

Returns the identity of the class, must be overwritten by the derived class.

Implements GenericObject.

BOOLEAN BtDeviceAddressGenericObject::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object instance itself, must be overwritten in the derived class.

Implements GenericObject.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtDeviceListsWindows.hpp
  • Applications/BtApp/BtDeviceListsWindows.cpp
Generated on Wed Jan 25 00:59:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceAndServiceClass Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceAndServiceClass Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceAndServiceClass.hpp>

Public Member Functions

BtDeviceAndServiceClass (ULONG device_and_service_class)
Constructor.
BtDeviceAndServiceClass (const BtDeviceAndServiceClass &device_and_service_class)
Constructor (copy constructor).
BtDeviceAndServiceClass ()
Constructor (default constructor).
UINT8 | GetMajorDeviceClass () const
Get the major device class.
UINT8 | GetMinorDeviceClass () const
Get the minor device class.
UINT16 | GetServiceClass () const
Get the service class.
BOOLEAN | operator!= (const BtDeviceAndServiceClass &device_and_service_class) const
Is a device and service class object not equal to this object?
BtDeviceAndServiceClass & | operator= (const BtDeviceAndServiceClass &device_and_service_class)
Assign a device and service class object to this object.
BOOLEAN | operator== (const BtDeviceAndServiceClass &device_and_service_class) const
Is a device and service class object equal to this object?
void | SetMajorDeviceClass (UINT8 major_device_class)
Set the major device class.
void | SetMinorDeviceClass (UINT8 minor_device_class)
Set the minor device class.
void | SetServiceClass (UINT16 service_class)
Set the service class.
virtual | ~BtDeviceAndServiceClass ()
Destructor.

Detailed Description

BtDeviceAndServiceClass is used to encapsulate the details of the service class, major device class and minor device class bits of a BtDevice. The handling and manipulation of these bits should be made easier by this class.

Constructor & Destructor Documentation

BtDeviceAndServiceClass::BtDeviceAndServiceClass ( )

Constructor (default constructor).

BtDeviceAndServiceClass::BtDeviceAndServiceClass ( const BtDeviceAndServiceClass & device_and_service_class )

Constructor (copy constructor).

BtDeviceAndServiceClass::BtDeviceAndServiceClass ( ULONG device_and_service_class )

Constructor.

BtDeviceAndServiceClass::~BtDeviceAndServiceClass ( ) [virtual]

Destructor.

Member Function Documentation

UINT8 BtDeviceAndServiceClass::GetMajorDeviceClass ( ) const

Get the major device class.

GetMajorDeviceClass returns the major device class. The result of this operation is one of the BT_MDC_xxx constants.

Returns:
UINT8 describing the major device class.

UINT8 BtDeviceAndServiceClass::GetMinorDeviceClass ( ) const

Get the minor device class.

GetMinorDeviceClass returns the minor device class. The result of this operation is one of the BT_SDC_xxx constants. Depending on the major device class the result can be any combination or only one of the constants mentioned above.

Returns:
UINT8 describing the minor device class.

UINT16 BtDeviceAndServiceClass::GetServiceClass ( ) const

Get the service class.

GetServiceClass gets the serivce class. The result of this operation is any combination of the BT_MSC_xxx constants.

Returns:
UINT16 describing the service class.

BOOLEAN BtDeviceAndServiceClass::operator!= ( const BtDeviceAndServiceClass & device_and_service_class ) const

Is a device and service class object not equal to this object?

operator!= is the comparison operator that checks inequality.

Parameters:
device_and_service_class A reference to a BtDeviceAndServiceClass object, which should be compared to this.
Returns:
TRUE: this and service_and_device_class are not equal.
FALSE: this and service_and_device_class are equal.

BtDeviceAndServiceClass & BtDeviceAndServiceClass::operator= ( const BtDeviceAndServiceClass & device_and_service_class )

Assign a device and service class object to this object.

operator= is the assignment operator for BtDeviceAndServiceClass.

Parameters:
device_and_service_class A reference to a BtDeviceAndServiceClass object, which should be assigned to this.
Returns:
A reference to the new assigned this object.

BOOLEAN BtDeviceAndServiceClass::operator== ( const BtDeviceAndServiceClass & device_and_service_class ) const

Is a device and service class object equal to this object?

operator== is the comparison operator that checks equality.

Parameters:
service_and_device_class A reference to a BtDeviceAndServiceClass object, which should be compared to this.
Returns:
TRUE: this and device_and_service_class are equal.
FALSE: this and device_and_service_class are not equal.

void BtDeviceAndServiceClass::SetMajorDeviceClass ( UINT8 major_device_class )

Set the major device class.

SetMajorDeviceClass sets the major device class. The major device class is one of the BT_MDC_xxx constants.

Parameters:
major_device_class The major device class to be set.

void BtDeviceAndServiceClass::SetMinorDeviceClass ( UINT8 minor_device_class )

Set the minor device class.

SetMinorDeviceClass sets the minor device class. The minor device class is one of the BT_SDC_xxx constants. Depending on the major device class the minor device class can be any combination or only one of the constants mentioned above.

Parameters:
minor_device_class The minor device class to be set.

void BtDeviceAndServiceClass::SetServiceClass ( UINT16 service_class )

Set the service class.

SetServiceClass sets the service class. The service class is nay combination of the BT_SDC_xxx constants.

Parameters:
service_class The service class to be set.

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceAndServiceClass.hpp
  • Bluetooth/BtDeviceAndServiceClass.cpp
Generated on Wed Jan 25 00:59:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceDetailWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceDetailWindow Class Reference

#include <Applications/BtApp/BtDeviceDetailWindow.hpp>

Collaboration diagram for BtDeviceDetailWindow:

[legend]

Public Member Functions

BtDeviceDetailWindow ()
const BtDevice & | GetDevice ()
void | Init ()
void | OnSupportedProfileSearch ()
void | SetDevice (const BtDevice &device)
virtual | ~BtDeviceDetailWindow ()

Protected Member Functions

virtual void | OnOpen ()
void | OnRequestFinished (BOOLEAN success)

Friends

class | BtApplicationQuerySupportedProfilesRequest

Detailed Description

BtDeviceDetailWindow window to display the detail information of the request device.

Constructor & Destructor Documentation

BtDeviceDetailWindow::BtDeviceDetailWindow ( )

BtDeviceDetailWindow::~BtDeviceDetailWindow ( ) [virtual]

Member Function Documentation

const BtDevice & BtDeviceDetailWindow::GetDevice ( )

void BtDeviceDetailWindow::Init ( )

void BtDeviceDetailWindow::OnOpen ( ) [protected, virtual]

void BtDeviceDetailWindow::OnRequestFinished ( BOOLEAN success ) [protected]

void BtDeviceDetailWindow::OnSupportedProfileSearch ( )

void BtDeviceDetailWindow::SetDevice ( const BtDevice & device )

Set the device

Friends And Related Function Documentation

friend class BtApplicationQuerySupportedProfilesRequest [friend]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtDeviceDetailWindow.hpp
  • Applications/BtApp/BtDeviceDetailWindow.cpp
Generated on Wed Jan 25 00:59:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceFilter Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceFilter.hpp>

Collaboration diagram for BtDeviceFilter:

[legend]

Public Member Functions

BtDeviceFilter (const BtDeviceAndServiceClass &device_and_service_class, BtDeviceState device_state=BtDsKnown)
Constructor.
BtDeviceFilter (const BtDeviceFilter &device_filter)
Constructor (copy constructor).
BtDeviceFilter ()
Constructor (default constructor).
const BtDeviceAndServiceClass & | GetDeviceAndServiceClass () const
Get the device and service class of this filter.
BtDeviceAndServiceClass & GetDeviceAndServiceClass ()
Get the device and service class of this filter.
BtDeviceState | GetDeviceState () const
Get the device state of this filter.
virtual BOOLEAN | Matches (const BtDevice &device) const
Does a device match this filters condition.
void | SetDeviceAndServiceClass (const BtDeviceAndServiceClass &device_and_service_class)
Set the device and service class for this filter.
void | SetDeviceState (BtDeviceState device_state)
Set the device state for this filter.
virtual | ~BtDeviceFilter ()
Destructor.

Detailed Description

BtDeviceFilter is used to define a condition that can be used to check a BtDevice whether it maches that condition or not. The BtDevice can be checked against the major device class, minor device class, the service class and the device state.

Constructor & Destructor Documentation

BtDeviceFilter::BtDeviceFilter ( )

Constructor (default constructor).

BtDeviceFilter::BtDeviceFilter ( const BtDeviceFilter & device_filter )

Constructor (copy constructor).

BtDeviceFilter::BtDeviceFilter | ( | const BtDeviceAndServiceClass & | device_and_service_class,
 |  | BtDeviceState | device_state = BtDsKnown
 | ) |

Constructor.

BtDeviceFilter::~BtDeviceFilter ( ) [virtual]

Destructor.

Member Function Documentation

const BtDeviceAndServiceClass & BtDeviceFilter::GetDeviceAndServiceClass ( ) const

Get the device and service class of this filter.

GetDeviceAndSericeClass returns the filter condition used by this filter affecting the device and service class.

Returns:
A reference to a BtDeviceAndServiceClass that is used as filter condition of this filter.

BtDeviceAndServiceClass & BtDeviceFilter::GetDeviceAndServiceClass ( )

Get the device and service class of this filter.

GetDeviceAndSericeClass returns the filter condition used by this filter affecting the device and service class.

Returns:
A reference to a BtDeviceAndServiceClass that is used as filter condition of this filter.

BtDeviceState BtDeviceFilter::GetDeviceState ( ) const

Get the device state of this filter.

GetDeviceState returns the filter condition used by this filter.affecting the device state (known, paired, and so on).

Returns:
A BtDeviceState that is used as filter condition for this filter.

BOOLEAN BtDeviceFilter::Matches ( const BtDevice & device ) const [virtual]

Does a device match this filters condition.

Matches tests a BtDevice whether it matches this filter or not. This function is virtual because derived class must extend this function to test against the device state of the BtDevice.

Parameters:
device A reference to a BtDevice that should be tested against the filter condition.
Returns:
TRUE: The passed BtDevice matches the filter condition.
FALSE: The passed BtDevice does not match the filter condition.

void BtDeviceFilter::SetDeviceAndServiceClass ( const BtDeviceAndServiceClass & device_and_service_class )

Set the device and service class for this filter.

SetDeviceAndServiceClass sets the filter condition used by this filter affecting the device and service class.

Returns:
A reference to a BtDeviceAndServiceClass that should be used as filter condition of this filter.

void BtDeviceFilter::SetDeviceState ( BtDeviceState device_state )

Set the device state for this filter.

SetDeviceState sets the filter condition used by this filter.affecting the device state (known paired and so on).

Returns:
A BtDeviceState that should be used as filter condition of this filter.

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceFilter.hpp
  • Bluetooth/BtDeviceFilter.cpp
Generated on Wed Jan 25 00:59:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceList Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceList.hpp>

Collaboration diagram for BtDeviceList:

[legend]

Public Member Functions

const BtDevice & | Back () const
Get the last element of the list.
BtDevice & Back ()
Get the last element of the list.
BtDeviceListConstantIterator | Begin () const
Get an itertator pointing to the first element in the list.
BtDeviceListIterator Begin ()
Get an itertator pointing to the first element in the list.
BtDeviceList (const BtDeviceList &device_list, const BtDeviceFilter &device_filter=BtDeviceFilter())
Constructor (copy constructor).
BtDeviceList (BOOLEAN do_refresh=FALSE, const BtDeviceFilter &device_filter=BtDeviceFilter())
Constructor (default constructor).
void | Clear (void)
Remove all elements from the list.
BtDeviceListConstantIterator | End () const
Get an itertator pointing beyond-the-end of the list.
BtDeviceListIterator End ()
Get an itertator pointing beyond-the-end of the list.
BtDeviceListIterator | Erase (BtDeviceListIterator first, BtDeviceListIterator last)
Erase a specified range of elements from the list.
BtDeviceListIterator | Erase (BtDeviceListIterator iterator)
Erase an element at a specified positin from the list.
void | Filter (const BtDeviceFilter &device_filter)
Clear elements not maching a filter condition.
BtDeviceListConstantIterator | Find (const BtDeviceAddress &device_address) const
Search for a specific address.
BtDeviceListIterator | Find (const BtDeviceAddress &device_address)
Search for a specific address.
BtDeviceListConstantIterator | Find (const BtDevice &device) const
Search for a specific element.
BtDeviceListIterator | Find (const BtDevice &device)
Search for a specific element.
const BtDevice & | Front () const
Get the first element of the list.
BtDevice & Front ()
Get the first element of the list.
UINT | GetSize () const
Get the number of elements stored in the list.
BtDeviceListIterator | Insert (BtDeviceListIterator iterator, const BtDevice &device)
Insert an element at a specified position into the list.
BOOLEAN | IsEmpty () const
Is the list empty?
void | PopBack ()
Remove the element at the end of the list.
void | PopFront ()
Remove the element at the beginning of the list.
void | PushBack (const BtDevice &device)
Append element at the end of the list.
void | PushFront (const BtDevice &device)
Append element at the beginning of the list.
BtDeviceListConstantReverseIterator | RBegin () const
Get an iterator pointing to the first element of the reverted list.
BtDeviceListReverseIterator RBegin ()
Get an iterator pointing to the first element of the reverted list.
void | Refresh (const BtDeviceFilter &device_filter=BtDeviceFilter())
Synchonize list with Bluetooth Stack.
void | Remove (const BtDevice &device)
Remove a specified element from the list.
BtDeviceListConstantReverseIterator | REnd () const
Get an itertator pointing beyond-the-end of the reverted list.
BtDeviceListReverseIterator REnd ()
Get an itertator pointing beyond-the-end of the reverted list.
virtual | ~BtDeviceList ()
Destructor.

Friends

class | BtDeviceListBidirectionalIterator
class | BtDeviceListConstantIterator
class | BtDeviceListConstantReverseIterator
class | BtDeviceListIterator
class | BtDeviceListReverseIterator
class | BtGapAndSdapController

Data Structures

class | BtDeviceListBidirectionalIterator
class | BtDeviceListNode

Detailed Description

BtDeviceList is used to get access to the Bluetooth Devices stored in the Bluetooth Stack. Because the list in the Bluetooth Stack can change over time through finding new devices on the air, changing device properties or deleting devices, the instantiated list is a snapshot of the list stored in the Bluetooth Stack at the point of time, when it was created.
There are two constructors for this class. The first one creates an empty BtDeviceList and, if the paramter do_refresh is set to TRUE, reads all Bluetooth Devices from the Bluetooth Stack, which match the passed BtDeviceFilter and stores them in the newly created list. The second constructor (copy constructor) is used to create a copy of an existing list. The parameter device_filter is used to constrain the number of elements that are copied (e.g.: you can copy out all device that are conneted by passing the apropriate filter).
When the list stored in the Bluetooth Stack changes, there are messages sent to the applications. As a reaction to these messages the function Refresh can be called to synchronize the instance of the BtDeviceList with the list stored in the Bluetooth Stack.
Attention: References to BtDevice-objects within the BtDeviceList can become invalid by the execution of this function, because it is possible that objects stored in the list will be deleted.
Attention: Inserted elements will be copied!

Constructor & Destructor Documentation

BtDeviceList::BtDeviceList | ( | BOOLEAN | do_refresh = FALSE,
 |  | const BtDeviceFilter & | device_filter = BtDeviceFilter()
 | ) | [explicit]

Constructor (default constructor).

BtDeviceList is the default constructor. Depending on the do_refresh parameter an empty list is created or the new list is filled with all Bluetooth Devices stored in the Bluetooth Stack that match the passed BtDeviceFilter.

Parameters:
do_refresh | A BOOLEAN that instructs the constructor either to add BT-Devices stored in the BT-Stack or not.
device_filter | A reference to a BtDeviceFilter that filters the BT-Devices from the BT-Stack when they are added.

BtDeviceList::BtDeviceList | ( | const BtDeviceList & | device_list,
 |  | const BtDeviceFilter & | device_filter = BtDeviceFilter()
 | ) | [explicit]

Constructor (copy constructor).

BtDeviceList is the copy constructor. All BtDevices, that match the device_filter will be copied from the device_list.

Parameters:
device_list | A reference to a BtDeviceList, whose BtDevices should be copied.
device_filter | A reference to a BtDeviceFilter that is used to determine whether a BtDevice should be copied or not.

BtDeviceList::~BtDeviceList ( ) [virtual]

Destructor.

Member Function Documentation

const BtDevice & BtDeviceList::Back ( ) const

Get the last element of the list.

Back returns a reference to the last BtDevice of this BtDeviceList, which must be non-empty

Returns:
A reference to a constant BtDevice that is the last element in the BtDeviceList.

BtDevice & BtDeviceList::Back ( )

Get the last element of the list.

Back returns a reference to the last BtDevice of this BtDeviceList, which must be non-empty

Returns:
A reference to a BtDevice that is the last element in the BtDeviceList.

BtDeviceListConstantIterator BtDeviceList::Begin ( ) const

Get an itertator pointing to the first element in the list.

Begin returns a BtDeviceListConstantIterator that points at the first BtDevice of the BtDeviceList or beyond-the-end of an empty BtDeviceList.

Returns:
BtDeviceListIterator | An iterator pointing to the first element in the list.
End() | The list is empty

BtDeviceListIterator BtDeviceList::Begin ( )

Get an itertator pointing to the first element in the list.

Begin returns a BtDeviceListIterator that points at the first BtDevice of the BtDevcieList or beyond-the-end of an empty BtDeviceList.

Returns:
BtDeviceListIterator | An iterator pointing to the first element in the list.
End() | The list is empty

void BtDeviceList::Clear ( void )

Remove all elements from the list.

Clear removes all BtDevices from the BtDeviceList.

BtDeviceListConstantIterator BtDeviceList::End ( ) const

Get an itertator pointing beyond-the-end of the list.

End returns a BtDeviceListConstantIterator that points just beyond the end of the BtDeviceList.

Returns:
A BtDeviceListConstantIterator that points just beyond-the-end of the BtDeviceList.

BtDeviceListIterator BtDeviceList::End ( )

Get an itertator pointing beyond-the-end of the list.

End returns a BtDeviceListIterator that points just beyond the end of the BtDeviceList.

Returns:
A BtDeviceListIterator that points just beyond-the-end of the BtDeviceList.

BtDeviceListIterator BtDeviceList::Erase | ( | BtDeviceListIterator | first,
 |  | BtDeviceListIterator | last
 | ) |

Erase a specified range of elements from the list.

Erase removes all BtDevices in the range [first,last(. The operation returns a BtDeviceListIterator that points to the first BtDevice beyond the last removedBtDevice or the past-the-end iterator, if the last removed BtDevice was also the last element in the BtDeviceList.

Parameters:
first | A reference to a BtDeviceListIterator that contains the first position of the sequence of BtDevices, which should be deleted.
last | A reference to a BtDeviceListIterator that contains the last position of the sequence of BtDevices, which should be deleted.
Returns:
BtDeviceListIterator | An iterator pointing to the element following the the last element that has been deleted.
End() | The passed in iterator last pointed to the last element in the list.

BtDeviceListIterator BtDeviceList::Erase ( BtDeviceListIterator iterator )

Erase an element at a specified positin from the list.

Erase removes the BtDevice of the the BtDeviceList pointed to by the BtDeviceListIterator. The operation returns a BtDeviceListIterator that points to the first BtDevice beyond the removed BtDevice or the past-the-end iterator, if the BtDeviceListIterator pointing at the BtDevice to delete, represents the last element of the list.

Parameters:
iterator A reference to a BtDeviceListIterator containing the position where to remove the BtDevice.
Returns:
BtDeviceListIterator | An iterator pointing to the element following the the element that has been deleted.
End() | The passed in iterator pointed to the last element in the list.

void BtDeviceList::Filter ( const BtDeviceFilter & device_filter )

Clear elements not maching a filter condition.

Filter deletes all BtDevices from this BtDeviceList that do not match the passed in BtDeviceFilter.
Attention: Iterators and references to BtDevices stored in this BtDeviceList may become invalid.

Parameters:
device_filter A reference to a BtDeviceFilter, which all elements in the resulting BtDeviceList will match.

BtDeviceListConstantIterator BtDeviceList::Find ( const BtDeviceAddress & device_address ) const

Search for a specific address.

Find searches the BtDeviceList for the existance of the passed in BtDeviceAddress and retuns a BtDeviceListIterator that contains the position of the searched BtDevice or the past-the-end iterator, if the BtDeviceList does not contain the searched BtDeviceAddress.

Parameters:
device_address A reference to a BtDeviceAddress that should be found in the BtDeviceList.
Returns:
BtDeviceListIterator | An iterator containing the position of the element within the list.
End() | The element is not contained in the list.

BtDeviceListIterator BtDeviceList::Find ( const BtDeviceAddress & device_address )

Search for a specific address.

Find searches the BtDeviceList for the existance of the passed in BtDeviceAddress and retuns a BtDeviceListIterator that contains the position of the searched BtDevice or the past-the-end iterator, if the BtDeviceList does not contain the searched BtDeviceAddress.

Parameters:
device_address A reference to a BtDeviceAddress that should be found in the BtDeviceList.
Returns:
BtDeviceListIterator | An iterator containing the position of the element within the list.
End() | The element is not contained in the list.

BtDeviceListConstantIterator BtDeviceList::Find ( const BtDevice & device ) const

Search for a specific element.

Find searches the BtDeviceList for the existance of the passed in BtDevice and retuns a BtDeviceListIterator that contains the position of the searched BtDevice or the past-the-end iterator, if the BtDeviceList does not contain the searched BtDevice.

Parameters:
device A Reference to a BtDevice that should be found in the BtDeviceList.
Returns:
BtDeviceListIterator | An iterator containing the position of the element within the list.
End() | The element is not contained in the list.

BtDeviceListIterator BtDeviceList::Find ( const BtDevice & device )

Search for a specific element.

Find searches the BtDeviceList for the existance of the passed in BtDevice and retuns a BtDeviceListIterator that contains the position of the searched BtDevice or the past-the-end iterator, if the BtDeviceList does not contain the searched BtDevice.

Parameters:
device A Reference to a BtDevice that should be found in the BtDeviceList.
Returns:
BtDeviceListIterator | An iterator containing the position of the element within the list.
End() | The element is not contained in the list.

const BtDevice & BtDeviceList::Front ( ) const

Get the first element of the list.

Front returns a reference to the first BtDevice of this BtDeviceList, which must be non-empty.

Returns:
A reference to a constant BtDevice that is the first element in the BtDeviceList.

BtDevice & BtDeviceList::Front ( )

Get the first element of the list.

Front returns a reference to the first BtDevice of this BtDeviceList, which must be non-empty.

Returns:
A reference to a BtDevice that is the first element in the BtDeviceList.

UINT BtDeviceList::GetSize ( ) const

Get the number of elements stored in the list.

GetSize returns the number of BtDevice s stored in the BtDeviceList

Returns:
A UINT8 containing the number of BtDevices.

BtDeviceListIterator BtDeviceList::Insert | ( | BtDeviceListIterator | iterator,
 |  | const BtDevice & | device
 | ) |

Insert an element at a specified position into the list.

Insert inserts the passed BtDevice before the element pointed to by the BtDeviceListIterator and returns a BtDeviceListIterator containing the position of the newly inserted BtDevice.

Parameters:
iterator | A reference to a BtDeviceListIterator containing the position where to insert the new BtDevice.
device | A reference to the BtDevice that should be inserted at the position the BtDeviceListIterator is pointing to.
Returns:
BtDeviceListIterator | An iterator pointing to the position in the list where the new element was inserted
End() | The insert operation failed

BOOLEAN BtDeviceList::IsEmpty ( ) const

Is the list empty?

IsEmpty returns whether there are BtDeviceLists in the BtDeviceList or not.

Returns:
TRUE: The BtDeviceList contains no BtDevices.
FALSE: The BtDeviceList contains BtDevices.

void BtDeviceList::PopBack ( )

Remove the element at the end of the list.

PopBack removes the last element oft the BtDeviceList, which must be non-empty.

void BtDeviceList::PopFront ( )

Remove the element at the beginning of the list.

PopFront removes the first element oft the BtDeviceList, which must be non-empty.

void BtDeviceList::PushBack ( const BtDevice & device )

Append element at the end of the list.

PushBack inserts a BtDevice at the and of the BtDeviceList.

Parameters:
device A reference to a BtDevice that should be inserted at the end of the BtDeviceList.

void BtDeviceList::PushFront ( const BtDevice & device )

Append element at the beginning of the list.

PushFront inserts a BtDevice at the beginning of the BtDeviceList.

Parameters:
device A reference to a BtDevice that should be inserted at the beginning of the BtDeviceList.

BtDeviceListConstantReverseIterator BtDeviceList::RBegin ( ) const

Get an iterator pointing to the first element of the reverted list.

RBegin returns a BtDeviceListConstantReverseIterator that points to the last BtDevice of the BtDeviceList or before-the-beginning of an empty BtDeviceList. Hence, it designates the beginning of the reverse BtDeviceList.

Returns:
BtDeviceListReverseIterator | An iterator pointing to the first element in the reverted list.
End() | The list is empty

BtDeviceListReverseIterator BtDeviceList::RBegin ( )

Get an iterator pointing to the first element of the reverted list.

RBegin returns a BtDeviceListReverseIterator that points to the last BtDevice of the BtDeviceList or before-the-beginning of an empty BtDeviceList. Hence, it designates the beginning of the reverse BtDeviceList.

Returns:
BtDeviceListReverseIterator | An iterator pointing to the first element in the reverted list.
End() | The list is empty

void BtDeviceList::Refresh ( const BtDeviceFilter & device_filter = BtDeviceFilter() )

Synchonize list with Bluetooth Stack.

Refresh synchronizes this BtDeviceList with the list of BT-Devices stored in the BT-Stack. Sychnronize means that the list is not destroyed and built up new. It means that objects are inserted and deleted according to the list stored in the BT-Stack. After the operation only elements matching the passed BtDeviceFilter are in the list.
Attention: Iterators and references to BtDevices stored in this BtDeviceList may become invalid.

Parameters:
device_filter A reference to a BtDeviceFilter, which all elements in the resulting BtDeviceList will match.

void BtDeviceList::Remove ( const BtDevice & device )

Remove a specified element from the list.

Remove searches the BtDeviceList for the occurance of the passed BtDevice and if found, removes it.

Parameters:
device A reference to a BtDevice that shoud be deleted from the BtDeviceList.

BtDeviceListConstantReverseIterator BtDeviceList::REnd ( ) const

Get an itertator pointing beyond-the-end of the reverted list.

REnd returns a BtDeviceListConstantReverseIterator that points before-the-beginning of the BtDeviceList. Hence, it designates the end of the reverse sequence.

Returns:
A BtDeviceListConstantReverseIterator that points just beyond-the-end of the reverse order of the BtDeviceList.

BtDeviceListReverseIterator BtDeviceList::REnd ( )

Get an itertator pointing beyond-the-end of the reverted list.

REnd returns a BtDeviceListReverseIterator that points before-the-beginning of the BtDeviceList. Hence, it designates the end of the reverse sequence.

Returns:
A BtDeviceListReverseIterator that points just beyond-the-end of the reverse order of the BtDeviceList.

Friends And Related Function Documentation

friend class BtDeviceListBidirectionalIterator [friend]

friend class BtDeviceListConstantIterator [friend]

friend class BtDeviceListConstantReverseIterator [friend]

friend class BtDeviceListIterator [friend]

friend class BtDeviceListReverseIterator [friend]

friend class BtGapAndSdapController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceList.hpp
  • Bluetooth/BtDeviceList.cpp
Generated on Wed Jan 25 00:59:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceList::BtDeviceListBidirectionalIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtDeviceList::BtDeviceListBidirectionalIterator

BtDeviceList::BtDeviceListBidirectionalIterator Class Reference

#include <Apoxi/Bluetooth/BtDeviceList.hpp>

Inheritance diagram for BtDeviceList::BtDeviceListBidirectionalIterator:

[legend]
Collaboration diagram for BtDeviceList::BtDeviceListBidirectionalIterator:

[legend]

Public Member Functions

BtDeviceListBidirectionalIterator (const BtDeviceListBidirectionalIterator &bidirectional_iterator)
Constructor (copy constructor).
BtDeviceListBidirectionalIterator ()
Constructor (default constructor).

Protected Member Functions

BtDeviceListBidirectionalIterator (BtDeviceListNode *device_list_node)
Constructor.
const BtDeviceListNode * | GetDeviceListNode () const
Get current node.
BtDeviceListNode * GetDeviceListNode ()
Get current node.
void | SetDeviceListNode (BtDeviceListNode *device_list_node)
Set current node.

Protected Attributes

BtDeviceListNode * m_device_list_node
Current position within the BtDeviceList.

Detailed Description

BtDeviceListBidirectionalIterator is the base class for all BtDeviceListXXXIterators. It encapsules the common properties for all iterators like the actual position for this iterator

Constructor & Destructor Documentation

BtDeviceList::BtDeviceListBidirectionalIterator::BtDeviceListBidirectionalIterator ( )

Constructor (default constructor).

BtDeviceList::BtDeviceListBidirectionalIterator::BtDeviceListBidirectionalIterator ( const BtDeviceListBidirectionalIterator & bidirectional_iterator ) [explicit]

Constructor (copy constructor).

BtDeviceList::BtDeviceListBidirectionalIterator::BtDeviceListBidirectionalIterator ( BtDeviceListNode * device_list_node ) [explicit, protected]

Constructor.

Member Function Documentation

const BtDeviceListNode* BtDeviceList::BtDeviceListBidirectionalIterator::GetDeviceListNode ( ) const [inline, protected]

Get current node.

GetDeviceListNode returns the node within a BtDeviceList representing the current position of this iterator.

Returns:
A pointer to a BtDeviceListNode representing the current position of this iterator.

BtDeviceListNode* BtDeviceList::BtDeviceListBidirectionalIterator::GetDeviceListNode ( ) [inline, protected]

Get current node.

GetDeviceListNode returns the node within a BtDeviceList representing the current position of this iterator.

Returns:
A pointer to a BtDeviceListNode representing the current position of this iterator.

void BtDeviceList::BtDeviceListBidirectionalIterator::SetDeviceListNode ( BtDeviceListNode * device_list_node ) [protected]

Set current node.

SetDeviceListNode sets a node to become the current position within a BtDeviceList repesented by this iterator.

Parameters:
device_list_node A pointer to a BtDeviceListNode that should be the new current positin for this iterator.

Field Documentation

BtDeviceListNode* BtDeviceList::BtDeviceListBidirectionalIterator::m_device_list_node [protected]

Current position within the BtDeviceList.

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceList.hpp
  • Bluetooth/BtDeviceList.cpp
Generated on Wed Jan 25 00:59:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceList::BtDeviceListNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtDeviceList::BtDeviceListNode

BtDeviceList::BtDeviceListNode Class Reference

#include <Apoxi/Bluetooth/BtDeviceList.hpp>

Collaboration diagram for BtDeviceList::BtDeviceListNode:

[legend]

Public Member Functions

BtDeviceListNode ()
Constructor (default constructor).
const BtDevice & | GetDevice () const
Get the device stored in this element.
BtDevice & GetDevice ()
Get the element stored in this node.
const BtDeviceListNode * | GetNext () const
Get successor.
BtDeviceListNode * GetNext ()
Get successor.
const BtDeviceListNode * | GetPrevious () const
Get predecessor.
BtDeviceListNode * GetPrevious ()
Get predecessor.
void | SetDevice (const BtDevice &device)
Store the passed in element in this node.
void | SetNext (BtDeviceListNode *next)
Set successor.
void | SetPrevious (BtDeviceListNode *previous)
Set predecessor.
virtual | ~BtDeviceListNode ()
Destructor.

Friends

class | BtDeviceListBidirectionalIterator

Detailed Description

BtDeviceListNode forms the central class for building up the BtDeviceList. It contains all link variables for a double linked list and memory for holding one BtDevice. It is a private class because it is used by BtDeviceList internally and the application programmer has not to mess around with this class.

Constructor & Destructor Documentation

BtDeviceList::BtDeviceListNode::BtDeviceListNode ( )

Constructor (default constructor).

BtDeviceList::BtDeviceListNode::~BtDeviceListNode ( ) [virtual]

Destructor.

Member Function Documentation

const BtDevice & BtDeviceList::BtDeviceListNode::GetDevice ( ) const

Get the device stored in this element.

GetDevice returns a reference to the element that is managed by this node. It should not be possible to change the contained BtDevice, so a constant reference, is returned by this operation.

Returns:
A reference to a BtDevice containing the element managd by this node.

BtDevice & BtDeviceList::BtDeviceListNode::GetDevice ( )

Get the element stored in this node.

GetDevice returns a reference to the element that is managed by this node. It should be possible to change the contained BtDevice, so a reference, and no constant reference, is returned by this operation.

Returns:
A reference to a BtDevice containing the element managd by this node.

const BtDeviceList::BtDeviceListNode * BtDeviceList::BtDeviceListNode::GetNext ( ) const

Get successor.

GetNext returns the link pointer to the next node representing this nodes successor.

Returns:
BtDeviceListNode | Link to the node that is the successor of this node.
0 | The element is not contained in the list.

BtDeviceList::BtDeviceListNode * BtDeviceList::BtDeviceListNode::GetNext ( )

Get successor.

GetNext returns the link pointer to the next node representing this nodes successor.

Returns:
BtDeviceListNode | Link to the node that is the successor of this node.
0 | The element is not contained in the list.

const BtDeviceList::BtDeviceListNode * BtDeviceList::BtDeviceListNode::GetPrevious ( ) const

Get predecessor.

GetPrevious return the link pointer to the previous node representing thisnodes predecessor.

Returns:
BtDeviceListNode | Link to the node that is the successor of this node.
0 | The element is not contained in the list.

BtDeviceList::BtDeviceListNode * BtDeviceList::BtDeviceListNode::GetPrevious ( )

Get predecessor.

GetPrevious return the link pointer to the previous node representing thisnodes predecessor.

Returns:
BtDeviceListNode | Link to the node that is the successor of this node.
0 | The element is not contained in the list.

void BtDeviceList::BtDeviceListNode::SetDevice ( const BtDevice & device )

Store the passed in element in this node.

SetDevice sets the element that should be managed by this node.

Parameters:
device A reference to a BtDevice representing the element that should be managed by this node.

void BtDeviceList::BtDeviceListNode::SetNext ( BtDeviceListNode * next )

Set successor.

SetNext sets the link pointer to the passed in node that should become the successor of this node.

Parameters:
next A pointer to a BtDeviceListNode that should become this nodes successor.

void BtDeviceList::BtDeviceListNode::SetPrevious ( BtDeviceListNode * previous )

Set predecessor.

SetPrevious sets the link pointer to the passed in node that should become the predecessor of this node.

Parameters:
next A pointer to a BtDeviceListNode that should become this nodes predecessor.

Friends And Related Function Documentation

friend class BtDeviceListBidirectionalIterator [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceList.hpp
  • Bluetooth/BtDeviceList.cpp
Generated on Wed Jan 25 00:59:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceListConstantIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceListConstantIterator Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceListIterator.hpp>

Inheritance diagram for BtDeviceListConstantIterator:

[legend]
Collaboration diagram for BtDeviceListConstantIterator:

[legend]

Public Member Functions

BtDeviceListConstantIterator (const BtDeviceListConstantReverseIterator &device_list_constant_reverse_iterator)
Constructor (copy constructor).
BtDeviceListConstantIterator ()
Constructor (default constructor).
const BtDevice & | operator * () const
iterator dereference operator
BOOLEAN | operator!= (const BtDeviceListConstantReverseIterator &device_list_constant_reverse_iterator) const
iterator inequality compare operator
BOOLEAN | operator!= (const BtDeviceListConstantIterator &device_list_constant_iterator) const
iterator inequality compare operator
BtDeviceListConstantIterator | operator++ (int)
iterator increment operator (postfix)
BtDeviceListConstantIterator & operator++ ()
iterator increment operator (praefix)
BtDeviceListConstantIterator | operator-- (int)
iterator decrement operator (postfix)
BtDeviceListConstantIterator & operator-- ()
iterator decrement operator (praefix)
const BtDevice * | operator-> () const
iterator indirection operator
BOOLEAN | operator== (const BtDeviceListConstantReverseIterator &device_list_constant_reverse_iterator) const
iterator equality compare operator
BOOLEAN | operator== (const BtDeviceListConstantIterator &device_list_constant_iterator) const
iterator equality compare operator

Protected Member Functions

BtDeviceListConstantIterator (BtDeviceList::BtDeviceListNode *device_list_node)
Constructor (private constructor).

Friends

class | BtDeviceList
class | BtDeviceListConstantReverseIterator

Detailed Description

BtDeviceListConstantIterator is used to iterate a BtDeviceList in the normal order. Dereferencing the iterator returns pointers or references to constant objects. So these objects can not be changed through this iterator.

Constructor & Destructor Documentation

BtDeviceListConstantIterator::BtDeviceListConstantIterator ( )

Constructor (default constructor).

BtDeviceListConstantIterator::BtDeviceListConstantIterator ( const BtDeviceListConstantReverseIterator & device_list_constant_reverse_iterator ) [explicit]

Constructor (copy constructor).

BtDeviceListConstantIterator::BtDeviceListConstantIterator ( BtDeviceList::BtDeviceListNode * device_list_node ) [explicit, protected]

Constructor (private constructor).

Member Function Documentation

const BtDevice & BtDeviceListConstantIterator::operator * ( ) const

iterator dereference operator

operator* returns a reference to a BtDevice, which is located at the position the iterator represents. The expression (*i).operation(...) and the expression i->operation(...) behave identically.

Returns:
A reference to a BtDevice at the current location.

BOOLEAN BtDeviceListConstantIterator::operator!= ( const BtDeviceListConstantReverseIterator & device_list_constant_reverse_iterator ) const

iterator inequality compare operator

operator!= is the comparison operator that checks inequality.

Parameters:
device_list_constant_reverse_iterator A reference to a BtDeviceListConstantReverseIterator, which should be compared to this.
Returns:
TRUE: The passed in iterator does not point to the same position as this iterator.
FASLE: The passed in iterator points to the same position as this iterator.

BOOLEAN BtDeviceListConstantIterator::operator!= ( const BtDeviceListConstantIterator & device_list_constant_iterator ) const

iterator inequality compare operator

operator!= is the comparison operator that checks inequality.

Parameters:
device_list_constant_iterator A reference to a BtDeviceListConstantIterator, which should be compared to this.
Returns:
TRUE: The passed in iterator does not point to the same position as this iterator.
FASLE: The passed in iterator points to the same position as this iterator.

BtDeviceListConstantIterator BtDeviceListConstantIterator::operator++ ( int )

iterator increment operator (postfix)

operator++ is the postfix increment operator and is used to move the current position that the iterator is representing in a BtDeviceList forward to the next position in the list.

Returns:
A BtDeviceListConstantIterator that is representing the iterator before advancing. The iterator itself is either the next position in the BtDeviceList or the past-the-end iterator.

Reimplemented in BtDeviceListIterator.

BtDeviceListConstantIterator & BtDeviceListConstantIterator::operator++ ( )

iterator increment operator (praefix)

operator++ is the prefix increment operator and is used to move the current position that the iterator is representing in a BtDeviceList forward to the next position in the list.

Returns:
A reference to a BtDeviceListConstantIterator that is either representing the iterator to the next position in the BtDeviceList or the past-the-end iterator.

Reimplemented in BtDeviceListIterator.

BtDeviceListConstantIterator BtDeviceListConstantIterator::operator-- ( int )

iterator decrement operator (postfix)

operator-- is the postfix decrement operator and is used to move the current position that the iterator is representing in a BtDeviceList backward to the previous position in the list.

Returns:
A BtDeviceListConstantIterator that is representing the iterator before receding. The iterator itself is either the previous position in the BtDeviceList or the past-the-end iterator.

Reimplemented in BtDeviceListIterator.

BtDeviceListConstantIterator & BtDeviceListConstantIterator::operator-- ( )

iterator decrement operator (praefix)

operator-- is the prefix decrement operator and is used to move the current position that the iterator is representing in a BtDeviceList backward to the previous position in the list.

Returns:
A reference to a BtDeviceListConstantIterator that is either representing the iterator to the previous position in the BtDeviceList or the past-the-end iterator.

Reimplemented in BtDeviceListIterator.

const BtDevice * BtDeviceListConstantIterator::operator-> ( ) const

iterator indirection operator

operator-> returns a pointer to a BtDevice, which is located at the position the iterator represents. The expression (*i).operation(...) and the expression i->operation(...) behave identically.

Returns:
A pointer to a BtDevice at the current location.

BOOLEAN BtDeviceListConstantIterator::operator== ( const BtDeviceListConstantReverseIterator & device_list_constant_reverse_iterator ) const

iterator equality compare operator

operator== is the comparison operator that checks equality.

Parameters:
device_list_constant_reverse_iterator A reference to a BtDeviceListConstantReverseIterator, which should be compared to this.
Returns:
TRUE: The passed in iterator points to the same position as this iterator.
FASLE: The passed in iterator does not point to the same position as this iterator.

BOOLEAN BtDeviceListConstantIterator::operator== ( const BtDeviceListConstantIterator & device_list_constant_iterator ) const

iterator equality compare operator

operator== is the comparison operator that checks equality.

Parameters:
device_list_constant_iterator A reference to a BtDeviceListConstantIterator, which should be compared to this.
Returns:
TRUE: The passed in iterator points to the same position as this iterator.
FASLE: The passed in iterator does not point to the same position as this iterator.

Friends And Related Function Documentation

friend class BtDeviceList [friend]

Reimplemented in BtDeviceListIterator.

friend class BtDeviceListConstantReverseIterator [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceListIterator.hpp
  • Bluetooth/BtDeviceListIterator.cpp
Generated on Wed Jan 25 00:59:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceListConstantReverseIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceListConstantReverseIterator Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceListReverseIterator.hpp>

Inheritance diagram for BtDeviceListConstantReverseIterator:

[legend]
Collaboration diagram for BtDeviceListConstantReverseIterator:

[legend]

Public Member Functions

BtDeviceListConstantReverseIterator (const BtDeviceListConstantIterator &device_list_constant_iterator)
Constructor (copy constructor).
BtDeviceListConstantReverseIterator ()
Constructor (default constructor).
const BtDevice & | operator * () const
iterator dereference operator
BOOLEAN | operator!= (const BtDeviceListConstantReverseIterator &device_list_constant_reverse_iterator) const
iterator inequality operator
BtDeviceListConstantReverseIterator | operator++ (int)
iterator increment operator (postfix)
BtDeviceListConstantReverseIterator & operator++ ()
iterator increment operator (praefix)
BtDeviceListConstantReverseIterator | operator-- (int)
iterator decrement operator (postfix)
BtDeviceListConstantReverseIterator & operator-- ()
iterator decrement operato (praefix)
const BtDevice * | operator-> () const
iterator indirection operator
BOOLEAN | operator== (const BtDeviceListConstantReverseIterator &device_list_constant_reverse_iterator) const
iterator equality compare operator

Protected Member Functions

BtDeviceListConstantReverseIterator (BtDeviceList::BtDeviceListNode *device_list_node)
Constructor (private constructor).

Friends

class | BtDeviceListConstantIterator

Detailed Description

BtDeviceListConstantReverseIterator is used to iterate a BtDeviceList in the reverse order. Dereferencing the iterator returns pointers or references to constant objects. So these objects can not be changed through this iterator.

Constructor & Destructor Documentation

BtDeviceListConstantReverseIterator::BtDeviceListConstantReverseIterator ( )

Constructor (default constructor).

BtDeviceListConstantReverseIterator::BtDeviceListConstantReverseIterator ( const BtDeviceListConstantIterator & device_list_constant_iterator ) [explicit]

Constructor (copy constructor).

BtDeviceListConstantReverseIterator::BtDeviceListConstantReverseIterator ( BtDeviceList::BtDeviceListNode * device_list_node ) [explicit, protected]

Constructor (private constructor).

Member Function Documentation

const BtDevice & BtDeviceListConstantReverseIterator::operator * ( ) const

iterator dereference operator

operator* returns a reference to a BtDevice, which is located at the position the iterator represents. The expression (*i).operation(...) and the expression i->operation(...) behave identically.

Returns:
A reference to a BtDevice at the current location.

BOOLEAN BtDeviceListConstantReverseIterator::operator!= ( const BtDeviceListConstantReverseIterator & device_list_constant_reverse_iterator ) const

iterator inequality operator

operator!= is the comparison operator that checks inequality.

Parameters:
device_list_constant_reverse_iterator A reference to a BtDeviceListConstantReverseIterator, which should be compared to this.
Returns:
TRUE: The passed in iterator does not point to the same position as this iterator.
FASLE: The passed in iterator points to the same position as this iterator.

BtDeviceListConstantReverseIterator BtDeviceListConstantReverseIterator::operator++ ( int )

iterator increment operator (postfix)

operator++ is the postfix increment operator and is used to move the current position that the iterator is representing in a BtDeviceList forward to the next position in the list. Incrementing the position of a reverse iterator is the same as decrementing the position in a normal iterator.

Returns:
A BtDeviceListConstantReverseIterator that is representing the iterator before advancing. The iterator itself is either the next position in the BtDeviceList or the past-the-end iterator.

Reimplemented in BtDeviceListReverseIterator.

BtDeviceListConstantReverseIterator & BtDeviceListConstantReverseIterator::operator++ ( )

iterator increment operator (praefix)

operator++ is the prefix increment operator and is used to move the current position that the iterator is representing in a BtDeviceList forward to the next position in the list. Incrementing the position of a reverse iterator is the same as decrementing the position in a normal iterator.

Returns:
A reference to a BtDeviceListConstantReverseIterator that is either representing the iterator to the next position in a BtDeviceList or the past-the-end iterator.

Reimplemented in BtDeviceListReverseIterator.

BtDeviceListConstantReverseIterator BtDeviceListConstantReverseIterator::operator-- ( int )

iterator decrement operator (postfix)

operator-- is the postfix decrement operator and is used to move the current position that the iterator is representing in a BtDeviceList backward to the previous position in the list. Decrementing the position of a reverse iterator is the same as decrementing the position in a normal iterator.

Returns:
A BtDeviceListConstantReverseIterator that is representing the iterator before receding. The iterator itself is either the previous position in the BtDeviceList or the past-the-end iterator.

Reimplemented in BtDeviceListReverseIterator.

BtDeviceListConstantReverseIterator & BtDeviceListConstantReverseIterator::operator-- ( )

iterator decrement operato (praefix)

operator-- is the prefix decrement operator and is used to move the current position that the iterator is representing in a BtDeviceList backward to the previous position in the list. Decrementing the position of a reverse iterator is the same as decrementing the position in a normal iterator.

Returns:
A reference to a BtDeviceListConstantReverseIterator that is either representing the iterator to the previous position in the BtDeviceList or the past-the-end. iterator

Reimplemented in BtDeviceListReverseIterator.

const BtDevice * BtDeviceListConstantReverseIterator::operator-> ( ) const

iterator indirection operator

operator-> returns a pointer to a BtDevice, which is located at the position the iterator represents. The expression (*i).operation(...) and the expression i->operation(...) behave identically.

Returns:
A pointer to a BtDevice at the current location.

BOOLEAN BtDeviceListConstantReverseIterator::operator== ( const BtDeviceListConstantReverseIterator & device_list_constant_reverse_iterator ) const

iterator equality compare operator

operator== is the comparison operator that checks equality.

Parameters:
device_list_constant_reverse_iterator A reference to a BtDeviceListConstantReverseIterator, which should be compared to this.
Returns:
TRUE: The passed in iterator does not point to the same position as this iterator.
FASLE: The passed in iterator points to the same position as this iterator.

Friends And Related Function Documentation

friend class BtDeviceListConstantIterator [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceListReverseIterator.hpp
  • Bluetooth/BtDeviceListReverseIterator.cpp
Generated on Wed Jan 25 00:59:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceListItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceListItem Class Reference

#include <Applications/BtApp/BtDeviceListsWindows.hpp>

Inheritance diagram for BtDeviceListItem:

[legend]
Collaboration diagram for BtDeviceListItem:

[legend]

Public Member Functions

BtDeviceListItem (Dispatcher *dispatcher, const WString &device_name, const BtDeviceAddress &device_address)
Constructor.
const BtDeviceAddress & | GetDeviceAddress () const
virtual | ~BtDeviceListItem ()

Detailed Description

Device items are created dynamically for ItemListWindow

Constructor & Destructor Documentation

BtDeviceListItem::BtDeviceListItem | ( | Dispatcher * | dispatcher,
 |  | const WString & | device_name,
 |  | const BtDeviceAddress & | device_address
 | ) |

Constructor.

BtDeviceListItem::~BtDeviceListItem ( ) [virtual]

Member Function Documentation

const BtDeviceAddress & BtDeviceListItem::GetDeviceAddress ( ) const

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtDeviceListsWindows.hpp
  • Applications/BtApp/BtDeviceListsWindows.cpp
Generated on Wed Jan 25 00:59:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceListIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceListIterator Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceListIterator.hpp>

Inheritance diagram for BtDeviceListIterator:

[legend]
Collaboration diagram for BtDeviceListIterator:

[legend]

Public Member Functions

BtDeviceListIterator (const BtDeviceListReverseIterator &device_list_reverse_iterator)
Constructor (copy constructor).
BtDeviceListIterator ()
Constructor (default constructor).
BtDevice & operator * ()
iterator dereference operator
BtDeviceListIterator | operator++ (int)
iterator increment operator (postfix)
BtDeviceListIterator & operator++ ()
iterator increment opeator (praefix)
BtDeviceListIterator | operator-- (int)
iterator decrement iterator (postfix)
BtDeviceListIterator & operator-- ()
iterator decrement operator (praefix)
BtDevice * operator-> ()
iterator indirections operator

Protected Member Functions

BtDeviceListIterator (BtDeviceList::BtDeviceListNode *device_list_node)
Constructor (private constructor).

Friends

class | BtDeviceList
class | BtDeviceListReverseIteator

Detailed Description

BtDeviceListIterator is used to iterate a BtDeviceList in the normal order. Dereferencing the iterator returns pointers or references to objects. So these objects can be changed through this iterator.

Constructor & Destructor Documentation

BtDeviceListIterator::BtDeviceListIterator ( )

Constructor (default constructor).

BtDeviceListIterator::BtDeviceListIterator ( const BtDeviceListReverseIterator & device_list_reverse_iterator ) [explicit]

Constructor (copy constructor).

BtDeviceListIterator::BtDeviceListIterator ( BtDeviceList::BtDeviceListNode * device_list_node ) [explicit, protected]

Constructor (private constructor).

Member Function Documentation

BtDevice & BtDeviceListIterator::operator * ( )

iterator dereference operator

operator* returns a reference to a BtDevice, which is located at the position the iterator represents. The expression (*i).operation(...) and the expression i->operation(...) behave identically.

Returns:
A reference to a BtDevice at the current location.

BtDeviceListIterator BtDeviceListIterator::operator++ ( int )

iterator increment operator (postfix)

operator++ is the postfix incrment operator and is used to move the current position that the iterator is representing in a BtDeviceList forward to the next position in the list.

Returns:
A BtDeviceListIterator that is representing the iterator before advancing. The iterator itself is either the next position in the BtDeviceList or the past-the-end iterator.

Reimplemented from BtDeviceListConstantIterator.

BtDeviceListIterator & BtDeviceListIterator::operator++ ( )

iterator increment opeator (praefix)

operator++ is the prefix increment operator and is used to move the current position that the iterator is representing in a BtDeviceList forward to the next position in the list.

Returns:
A reference to a BtDeviceListIterator that is either representing the iterator to the next position in the BtDeviceList or the past-the-end iterator.

Reimplemented from BtDeviceListConstantIterator.

BtDeviceListIterator BtDeviceListIterator::operator-- ( int )

iterator decrement iterator (postfix)

operator-- is the postfix decrement operator and is used to move the current position that the iterator is representing in a BtDeviceList backward to the previous position in the list.

Returns:
A BtDeviceListIterator that is representing the iterator before receding. The iterator itself is either the previous position in the BtDeviceList or the past-the-end iterator.

Reimplemented from BtDeviceListConstantIterator.

BtDeviceListIterator & BtDeviceListIterator::operator-- ( )

iterator decrement operator (praefix)

operator-- is the prefix decrement operator and is used to move the current position that the iterator is representing in a BtDeviceList backward to the previous position in the list.

Returns:
A reference to a BtDeviceListIterator that is either representing the iterator to the previous position in the BtDeviceList or the past-the-end iterator.

Reimplemented from BtDeviceListConstantIterator.

BtDevice * BtDeviceListIterator::operator-> ( )

iterator indirections operator

operator-> returns a pointer to a BtDevice, which is located at the position the iterator represents. The expression (*i).operation(...) and the expression i->operation(...) behave identically.

Returns:
A pointer to a BtDevice at the current location.

Friends And Related Function Documentation

friend class BtDeviceList [friend]

Reimplemented from BtDeviceListConstantIterator.

friend class BtDeviceListReverseIteator [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceListIterator.hpp
  • Bluetooth/BtDeviceListIterator.cpp
Generated on Wed Jan 25 00:59:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceListProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceListProvider Class Reference

#include <Applications/BtApp/BtDeviceListsWindows.hpp>

Inheritance diagram for BtDeviceListProvider:

[legend]
Collaboration diagram for BtDeviceListProvider:

[legend]

Public Member Functions

BtDeviceListProvider (const BtDeviceList *device_list)
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &data_item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
virtual Status | GetStatus () const
Returns the status of the provider.
virtual INT | RowCount ()
RowCount returns the number of rows.
void | SetDeviceList (const BtDeviceList *device_list)
virtual | ~BtDeviceListProvider ()
Destructor.

Protected Member Functions

BOOLEAN | GetDeviceAddress (INT index, DataItem &data_item)
BtDeviceListConstantIterator | GetDeviceAtIndex (INT index)
BOOLEAN | GetDeviceMajorClass (INT index, DataItem &data_item)
BOOLEAN | GetDeviceMinorClass (INT index, DataItem &data_item)
BOOLEAN | GetDeviceName (INT index, DataItem &data_item)

Detailed Description

Device list provider to get bluetooth name, address, device class

Constructor & Destructor Documentation

BtDeviceListProvider::BtDeviceListProvider ( const BtDeviceList * device_list )

BtDeviceListProvider::~BtDeviceListProvider ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtDeviceListProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | data_item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

BOOLEAN BtDeviceListProvider::GetDeviceAddress | ( | INT | index,
 |  | DataItem & | data_item
 | ) | [protected]

BtDeviceListConstantIterator BtDeviceListProvider::GetDeviceAtIndex ( INT index ) [protected]

BOOLEAN BtDeviceListProvider::GetDeviceMajorClass | ( | INT | index,
 |  | DataItem & | data_item
 | ) | [protected]

BOOLEAN BtDeviceListProvider::GetDeviceMinorClass | ( | INT | index,
 |  | DataItem & | data_item
 | ) | [protected]

BOOLEAN BtDeviceListProvider::GetDeviceName | ( | INT | index,
 |  | DataItem & | data_item
 | ) | [protected]

INT BtDeviceListProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

Provider::Status BtDeviceListProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

INT BtDeviceListProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

void BtDeviceListProvider::SetDeviceList ( const BtDeviceList * device_list )

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtDeviceListsWindows.hpp
  • Applications/BtApp/BtDeviceListsWindows.cpp
Generated on Wed Jan 25 00:59:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceListReverseIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceListReverseIterator Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceListReverseIterator.hpp>

Inheritance diagram for BtDeviceListReverseIterator:

[legend]
Collaboration diagram for BtDeviceListReverseIterator:

[legend]

Public Member Functions

BtDeviceListReverseIterator (const BtDeviceListIterator &device_list_iterator)
Constructor (copy constructor).
BtDeviceListReverseIterator ()
Constructor (default constructor).
BtDevice & operator * ()
iterator dereference operator
BtDeviceListReverseIterator | operator++ (int)
iterator increment operator (postfix)
BtDeviceListReverseIterator & operator++ ()
iterator increment operator (praefix)
BtDeviceListReverseIterator | operator-- (int)
iterator decrement operator (postfix)
BtDeviceListReverseIterator & operator-- ()
iterator decrement operator (praefix)
BtDevice * operator-> ()
iterator indirection operator

Protected Member Functions

BtDeviceListReverseIterator (BtDeviceList::BtDeviceListNode *device_list_node)
Constructor (private constructor).

Detailed Description

BtDeviceListReverseIterator is used to iterate a BtDeviceList in the reverse order. Dereferencing the iterator returns pointers or references to objects. So these objects can be changed through this iterator.

Constructor & Destructor Documentation

BtDeviceListReverseIterator::BtDeviceListReverseIterator ( )

Constructor (default constructor).

BtDeviceListReverseIterator::BtDeviceListReverseIterator ( const BtDeviceListIterator & device_list_iterator ) [explicit]

Constructor (copy constructor).

BtDeviceListReverseIterator::BtDeviceListReverseIterator ( BtDeviceList::BtDeviceListNode * device_list_node ) [explicit, protected]

Constructor (private constructor).

Member Function Documentation

BtDevice & BtDeviceListReverseIterator::operator * ( )

iterator dereference operator

operator* returns a reference to a BtDevice, which is located at the position the iterator represents. The expression (*i).operation(...)</code) and the expression i->operation(...) behave identically.

Returns:
A reference to a BtDevice at the current location.

BtDeviceListReverseIterator BtDeviceListReverseIterator::operator++ ( int )

iterator increment operator (postfix)

operator++ is the postfix increment operator and is used to move the current position that the iterator is representing in a BtDeviceList forward to the next position in the list. Incrementing the position of a reverse iterator is the same as decrementing the position in a normal iterator.

Returns:
A BtDeviceListReverseIterator that is representing the iterator before advancing. The iterator itself is either the next position in the BtDeviceList or the past-the-end iterator

Reimplemented from BtDeviceListConstantReverseIterator.

BtDeviceListReverseIterator & BtDeviceListReverseIterator::operator++ ( )

iterator increment operator (praefix)

operator++ is the prefix increment operator and is used to move the current position that the iterator is representing in a BtDeviceList forward to the next position in the list. Incrementing the position of a reverse iterator is the same as decrementing the position in a normal iterator.

Returns:
A reference to a BtDeviceListReverseIterator that is either representing the iterator to the next position in the BtDeviceList or the past-the-end iterator.

Reimplemented from BtDeviceListConstantReverseIterator.

BtDeviceListReverseIterator BtDeviceListReverseIterator::operator-- ( int )

iterator decrement operator (postfix)

operator-- is the postfix decrement operator and is used to move the current position that the iterator is representing in a BtDeviceList backward to the previous position in the list. Decrementing the position of a reverse iterator is the same as decrementing the position in a normal iterator.

Returns:
A BtDeviceListReverseIterator that is representing the iterator before receding. The iterator itself is either the previous position in the BtDeviceList or the past-the-end iterator.

Reimplemented from BtDeviceListConstantReverseIterator.

BtDeviceListReverseIterator & BtDeviceListReverseIterator::operator-- ( )

iterator decrement operator (praefix)

operator-- is the prefix decrement operator and is used to move the current position that the iterator is representing in a BtDeviceList backward to the previous position in the list. Decrementing the position of a reverse iterator is the same as decrementing the position in a normal iterator.

Returns:
A reference to a BtDeviceListReverseIterator that is either representing the iterator to the previous position in the BtDeviceList or the past-the-end iterator.

Reimplemented from BtDeviceListConstantReverseIterator.

BtDevice * BtDeviceListReverseIterator::operator-> ( )

iterator indirection operator

operator-> returns a pointer to a BtDevice, which is located at the position the iterator represents. The expression (*i).operation(...) and the expression i->operation(...) behave identically.

Returns:
A pointer to a BtDevice at the current location.

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceListReverseIterator.hpp
  • Bluetooth/BtDeviceListReverseIterator.cpp
Generated on Wed Jan 25 00:59:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceListWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceListWindow Class Reference

#include <Applications/BtApp/BtDeviceListsWindows.hpp>

Inheritance diagram for BtDeviceListWindow:

[legend]
Collaboration diagram for BtDeviceListWindow:

[legend]

Public Types

enum | BtDeviceListWindowType { BtDlwPairedDevices, BtDlwFoundDevices }

Public Member Functions

BtDeviceListWindow ()
void | DeviceSearchCancelRequest ()
BOOLEAN | DoRequestOperation (BtOperationPtr operation)
start SMS00058507
const BtDeviceAddress & | GetDeviceAddress (INT index, Provider *prov)
const BtDeviceAndServiceClass & | GetDeviceClass (INT index, Provider *prov)
const BitmapRes * | GetDeviceIcon (INT index, Provider *prov)
BtDeviceListProvider * GetDeviceListProvider ()
const WString & | GetDeviceName (INT index, Provider *prov)
BOOLEAN | GetImmediateSearch ()
BtDevice GetSelectedDevice ()
BtDeviceListWindowType GetType ()
void | Init ()
void | OnConnectActionExecuted ()
void | OnDeviceNameFound ()
void | OnDeviceSelectActionExecuted ()
BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
void | OnPairDeviceActionExecuted ()
void | OnRemoteDeviceSetNameNotification (BtDevice device, WString device_name)
void | OnRequestFinished (BOOLEAN success)
void | OnSearchAgainActionExecuted ()
void | OnServiceVerifyRequestFinished (BOOLEAN success)
void | OnSetDeviceNameActionExecuted ()
void | OnShowDetailsActionExecuted ()
void | OnSupportedProfileSearch ()
void | OnTrustDeviceActionExecuted ()
void | OnUnpairDeviceActionExecuted ()
void | OnUntrustDeviceActionExecuted ()
void | SetCanSelect (BOOLEAN can_select)
void | SetImmediateSearch (BOOLEAN immediate_search)
void | SetType (BtDeviceListWindowType type)
void | UpdateConnectOptions (BOOLEAN enable)
void | UpdateConnectProfileSelectedWindow (BOOLEAN open)
void | UpdateDeviceList ()
void | UpdateOptionMenu (INT index)
virtual | ~BtDeviceListWindow ()
Destructor.

Protected Member Functions

void | DoOperation (const BtDeviceFilter &device_filter)
virtual void | OnOpen ()
void | OnOperationFinished ()
void | OnPairDeviceActionFinished (BOOLEAN success)
void | OnQuerySupportedProfileFinished (BOOLEAN success)
void | OnSearchAgainActionFinished (BOOLEAN success)
void | OnServiceVerifyRequestExecuted (const BtDevice &device, const BtUUID *services_to_verify, UINT8 number_of_services_to_verify, const BtAttributeId *attributes_requested, UINT8 number_of_attributes_requested)
void | OnTrustDeviceActionFinished (BOOLEAN success)
void | OnUnpairDeviceActionFinished (BOOLEAN success)
void | OnUntrustDeviceActionFinished (BOOLEAN success)
void | UpdateList (void)

Friends

class | BtApplicationDevicePairRequest
class | BtApplicationDeviceSearchRequest
class | BtApplicationDeviceTrustRequest
class | BtApplicationDeviceUnpairRequest
class | BtApplicationDeviceUntrustRequest
class | BtApplicationQuerySupportedProfilesRequest
class | BtApplicationServiceVerifyRequest

Detailed Description

BtDeviceListWindow to display the paired window.

Member Enumeration Documentation

enum BtDeviceListWindow::BtDeviceListWindowType

Enumerator:
BtDlwPairedDevices
BtDlwFoundDevices

Constructor & Destructor Documentation

BtDeviceListWindow::BtDeviceListWindow ( )

BtDeviceListWindow::~BtDeviceListWindow ( ) [virtual]

Destructor.

Member Function Documentation

void BtDeviceListWindow::DeviceSearchCancelRequest ( )

void BtDeviceListWindow::DoOperation ( const BtDeviceFilter & device_filter ) [protected]

BOOLEAN BtDeviceListWindow::DoRequestOperation ( BtOperationPtr operation )

start SMS00058507

const BtDeviceAddress & BtDeviceListWindow::GetDeviceAddress | ( | INT | index,
 |  | Provider * | prov
 | ) |

const BtDeviceAndServiceClass & BtDeviceListWindow::GetDeviceClass | ( | INT | index,
 |  | Provider * | prov
 | ) |

const BitmapRes * BtDeviceListWindow::GetDeviceIcon | ( | INT | index,
 |  | Provider * | prov
 | ) |

BtDeviceListProvider* BtDeviceListWindow::GetDeviceListProvider ( ) [inline]

const WString & BtDeviceListWindow::GetDeviceName | ( | INT | index,
 |  | Provider * | prov
 | ) |

BOOLEAN BtDeviceListWindow::GetImmediateSearch ( )

end SMS00058507

BtDevice BtDeviceListWindow::GetSelectedDevice ( ) [inline]

BtDeviceListWindow::BtDeviceListWindowType BtDeviceListWindow::GetType ( )

void BtDeviceListWindow::Init ( )

void BtDeviceListWindow::OnConnectActionExecuted ( )

void BtDeviceListWindow::OnDeviceNameFound ( )

void BtDeviceListWindow::OnDeviceSelectActionExecuted ( )

BOOLEAN BtDeviceListWindow::OnFeatureTriggered ( const FeatureID & feature_id )

void BtDeviceListWindow::OnOpen ( ) [protected, virtual]

See also:
Control::OnOpen

Reimplemented from AtlItemListWindow.

void BtDeviceListWindow::OnOperationFinished ( ) [protected]

void BtDeviceListWindow::OnPairDeviceActionExecuted ( )

void BtDeviceListWindow::OnPairDeviceActionFinished ( BOOLEAN success ) [protected]

void BtDeviceListWindow::OnQuerySupportedProfileFinished ( BOOLEAN success ) [protected]

void BtDeviceListWindow::OnRemoteDeviceSetNameNotification | ( | BtDevice | device,
 |  | WString | device_name
 | ) |

void BtDeviceListWindow::OnRequestFinished ( BOOLEAN success )

void BtDeviceListWindow::OnSearchAgainActionExecuted ( )

void BtDeviceListWindow::OnSearchAgainActionFinished ( BOOLEAN success ) [protected]

void BtDeviceListWindow::OnServiceVerifyRequestExecuted | ( | const BtDevice & | device,
 |  | const BtUUID * | services_to_verify,
 |  | UINT8 | number_of_services_to_verify,
 |  | const BtAttributeId * | attributes_requested,
 |  | UINT8 | number_of_attributes_requested
 | ) | [protected]

start SMS00058507

void BtDeviceListWindow::OnServiceVerifyRequestFinished ( BOOLEAN success )

void BtDeviceListWindow::OnSetDeviceNameActionExecuted ( )

void BtDeviceListWindow::OnShowDetailsActionExecuted ( )

void BtDeviceListWindow::OnSupportedProfileSearch ( )

void BtDeviceListWindow::OnTrustDeviceActionExecuted ( )

void BtDeviceListWindow::OnTrustDeviceActionFinished ( BOOLEAN success ) [protected]

void BtDeviceListWindow::OnUnpairDeviceActionExecuted ( )

void BtDeviceListWindow::OnUnpairDeviceActionFinished ( BOOLEAN success ) [protected]

void BtDeviceListWindow::OnUntrustDeviceActionExecuted ( )

void BtDeviceListWindow::OnUntrustDeviceActionFinished ( BOOLEAN success ) [protected]

void BtDeviceListWindow::SetCanSelect ( BOOLEAN can_select )

void BtDeviceListWindow::SetImmediateSearch ( BOOLEAN immediate_search )

void BtDeviceListWindow::SetType ( BtDeviceListWindowType type )

void BtDeviceListWindow::UpdateConnectOptions ( BOOLEAN enable )

void BtDeviceListWindow::UpdateConnectProfileSelectedWindow ( BOOLEAN open )

void BtDeviceListWindow::UpdateDeviceList ( )

void BtDeviceListWindow::UpdateList ( void ) [protected]

void BtDeviceListWindow::UpdateOptionMenu ( INT index )

Friends And Related Function Documentation

friend class BtApplicationDevicePairRequest [friend]

friend class BtApplicationDeviceSearchRequest [friend]

friend class BtApplicationDeviceTrustRequest [friend]

friend class BtApplicationDeviceUnpairRequest [friend]

friend class BtApplicationDeviceUntrustRequest [friend]

friend class BtApplicationQuerySupportedProfilesRequest [friend]

friend class BtApplicationServiceVerifyRequest [friend]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtDeviceListsWindows.hpp
  • Applications/BtApp/BtDeviceListsWindows.cpp
Generated on Wed Jan 25 00:59:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDevicePairMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDevicePairMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtDevicePairMessage:

[legend]
Collaboration diagram for BtDevicePairMessage:

[legend]

Public Types

enum | { ID = 10225 }

Public Member Functions

BtDevicePairMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDevicePairMessage ()

Detailed Description

BtDevicePairMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtDevicePairMessage::BtDevicePairMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtDevicePairMessage::~BtDevicePairMessage ( ) [virtual]

Member Function Documentation

Message * BtDevicePairMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtDevicePairMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDevicePairRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDevicePairRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDevicePairRequest.hpp>

Inheritance diagram for BtDevicePairRequest:

[legend]
Collaboration diagram for BtDevicePairRequest:

[legend]

Public Member Functions

BtDevicePairRequest (const BtDevice &device)
Constructor.
BOOLEAN | GetCreateTrust () const
Does this request create a trusted pairing or not?
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetCreateTrust (BOOLEAN create_trust)
Sets whether this request should create a trusted pairing or not.
virtual | ~BtDevicePairRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | RegisterMessages () const
Register the required messages for receipt.
virtual void | UnregisterMessages () const
Unregister the required messages from receipt.

Friends

class | BtGapAndSdapController

Detailed Description

For setting up connections between two Bluetooth Devices link keys are necessary. These link keys are used for authentication and encryption. When a BtDevicePairRequest is executed successfully, these link keys where created and stored for later use when for expample the paired remote device tries to reconnect to the local device.
When no pairing is done, every time a remote device tries to connect to the local device, depending on the security settings of the requested profile, a request for a pin number is executed. This can be suppressed by pairing devices together.
When a untrusted pairing is established and a paired remote device tries to connect to a profile requiring authorization the local device asks its owner for confirmation of the requested connection. So a pairing request has a parameter to the the Bluetooth Stack to create a either a trusted or untrusted pairing.

Constructor & Destructor Documentation

BtDevicePairRequest::BtDevicePairRequest ( const BtDevice & device )

Constructor.

BtDevicePairRequest::~BtDevicePairRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtDevicePairRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

Execute instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. Execute is one of these functions.Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BOOLEAN BtDevicePairRequest::GetCreateTrust ( ) const

Does this request create a trusted pairing or not?

GetCreateTrust returns whether this request creates a trusted or untrusted pairing when it is executed by the Bluetooth Stack.

Returns:
TRUE: The pairing should be created as trusted.
FALSE: The pairing should be created as untrusted.

BtRequestType BtDevicePairRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRequestType returns this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtDevicePairRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtDevicePairRequest::RegisterMessages ( ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtDevicePairRequest the following message is registered: BtDevicePairMessage

Reimplemented from UserDispatcher.

void BtDevicePairRequest::SetCreateTrust ( BOOLEAN create_trust )

Sets whether this request should create a trusted pairing or not.

SetCreateTrust instructs this request depending on the passed in parameterwheter to create a trusted pairing or not, when it is executed.

Parameters:
create_trust A BOOLEAN containing whether this request should create a trusted or untrusted pairing.

void BtDevicePairRequest::UnregisterMessages ( ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtDevicePairRequest the following message is unregistered: BtDevicePairMessage

Reimplemented from UserDispatcher.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDevicePairRequest.hpp
  • Bluetooth/BtDevicePairRequest.cpp
Generated on Wed Jan 25 00:59:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceSearchMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceSearchMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtDeviceSearchMessage:

[legend]
Collaboration diagram for BtDeviceSearchMessage:

[legend]

Public Types

enum | { ID = 10220 }

Public Member Functions

BtDeviceSearchMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDeviceSearchMessage ()

Detailed Description

BtDeviceSearchMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtDeviceSearchMessage::BtDeviceSearchMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtDeviceSearchMessage::~BtDeviceSearchMessage ( ) [virtual]

Member Function Documentation

Message * BtDeviceSearchMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtDeviceSearchMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceSearchModeWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceSearchModeWindow Class Reference

#include <Applications/BtApp/BtLocalSettingsWindows.hpp>

Collaboration diagram for BtDeviceSearchModeWindow:

[legend]

Public Member Functions

BtDeviceSearchModeWindow ()
void | Init (BtDeviceListWindow *device_list_window)
virtual | ~BtDeviceSearchModeWindow ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

BtDeviceSearchModeWindow::BtDeviceSearchModeWindow ( )

BtDeviceSearchModeWindow::~BtDeviceSearchModeWindow ( ) [virtual]

Member Function Documentation

void BtDeviceSearchModeWindow::Init ( BtDeviceListWindow * device_list_window )

BOOLEAN BtDeviceSearchModeWindow::OnConfirm ( ) [protected, virtual]

void BtDeviceSearchModeWindow::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtLocalSettingsWindows.hpp
  • Applications/BtApp/BtLocalSettingsWindows.cpp
Generated on Wed Jan 25 00:59:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceSearchRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceSearchRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceSearchRequest.hpp>

Inheritance diagram for BtDeviceSearchRequest:

[legend]
Collaboration diagram for BtDeviceSearchRequest:

[legend]

Public Member Functions

BtDeviceSearchRequest ()
Constructor.
BtDeviceAndServiceClass | GetDeviceAndServiceClass () const
Which kind of devices should be found?
const BtDeviceList & | GetDeviceList () const
Get the list of found devices.
BOOLEAN | GetImmediatlyRetrieveRemoteDeviceNames () const
BtInquiryAccessCode | GetInquiryAccessCode () const
Which kind of inquiry should be made?
UINT8 | GetInquiryTimeOut () const
How long should the device search last at most?
UINT8 | GetMaximalFoundDevices () const
How many devices should be found at most?
BOOLEAN | GetQueryRemoteDeviceName () const
Should the remote device name be retrieved during the inquiry?
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetDeviceAndServiceClass (BtDeviceAndServiceClass device_and_service_class)
Set kind of devices that should be found.
void | SetImmediatlyRerieveRemoteDeviceNames (BOOLEAN immediatly_rerieve_names)
void | SetInquiryAccessCode (BtInquiryAccessCode inquiry_access_code)
Set the kind of inquiry that should be made.
void | SetInquiryTimeOut (UINT8 inquiry_time_out=0)
Set how long the device search should last at most.
void | SetMaximalFoundDevice (UINT8 maximal_found_devices=0)
Set how many devices should be found at most.
void | SetQueryRemoteDeviceName (BOOLEAN query_remote_device_name)
Set wether the remote device name should be retrieved or not.
virtual | ~BtDeviceSearchRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Cancel ()
Set controller parameters and call stack to cancel operation.
virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | OnRemoteDeviceFound (const BtDevice &remote_device, const BtDeviceAndServiceClass &remote_device_and_service_class, UINT8 signal_strength)
Remote device found message handler member function.
virtual void | OnRemoteDeviceFound (const BtDevice &remote_device, const BtDeviceAndServiceClass &remote_device_and_service_class)
Remote device found message handler member function.
virtual void | OnRemoteDeviceName (const BtDevice &remote_device, const WString &remote_device_name)
Remote device name received message handler member function.
virtual void | RegisterMessages (void) const
Register the required messages for receipt.
virtual void | UnregisterMessages (void) const
Unregister the required messages from receipt.

Friends

class | BtGapAndSdapController

Detailed Description

To communicate with other Bluetooth devices the Bluetooth stack must know that there are other Bluetooth devices ready for communication. To get knowledgs about other devices the Bluetooth stack supports an operation that is called inquiry or device search. This is exactly the operation that BtDeviceSearchRequest initiates on exectution.

Constructor & Destructor Documentation

BtDeviceSearchRequest::BtDeviceSearchRequest ( )

Constructor.

BtDeviceSearchRequest::~BtDeviceSearchRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtDeviceSearchRequest::Cancel ( ) [protected, virtual]

Set controller parameters and call stack to cancel operation.

The Cancel member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that cancels an ongoing operation at the Bluetooth Stack. This function is pure virtual because each request is canceled in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BOOLEAN BtDeviceSearchRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

Execute instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. Execute is one of these functions.Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtDeviceAndServiceClass BtDeviceSearchRequest::GetDeviceAndServiceClass ( ) const

Which kind of devices should be found?

GetDeviceAndServiceClass returns the device and serivce class bits for the remote devices which the request should search on the air.

Returns:
A BtDeviceAndServiceClass object containing the device and service class bits that should be found on the air.

const BtDeviceList & BtDeviceSearchRequest::GetDeviceList ( ) const

Get the list of found devices.

GetDeviceList returns the list of devices found during the execution of this request.

Returns:
A reference to a BtDeviceList containing all devices that where found during the exectution of this request.

BOOLEAN BtDeviceSearchRequest::GetImmediatlyRetrieveRemoteDeviceNames ( ) const

BtInquiryAccessCode BtDeviceSearchRequest::GetInquiryAccessCode ( ) const

Which kind of inquiry should be made?

GetInquiryAccessCode returns the type of inquiry or device search should be done. See the Bluetooth Global Access Profile for further information on Inquiry Access Codes.

Returns:
A BtInquiryAccessCode containig the type of inquiry or device search that should be done.

UINT8 BtDeviceSearchRequest::GetInquiryTimeOut ( ) const

How long should the device search last at most?

GetInquiryTimeOut returns the timeout period after which the request should stop searching. There are two conditions to stop the device search: the numer of devices to find and the time the device search to run. If one condition is satisfied the device search stops.
Unit of timeout: 1 = 1.28s = 2048 baseband slots a 625 ´s

Returns:
An UINT8 containing the time out period after which the request should stop searching.

UINT8 BtDeviceSearchRequest::GetMaximalFoundDevices ( ) const

How many devices should be found at most?

GetMaximalFoundDevices returns the number remote devices after which the request should stop searching. There are two conditions to stop the device search: the numer of devices to find and the time the device search to run. If one condition is satisfied the device search stops.

Returns:
An UINT8 containing the number of remote devices after which the request should stop searching.

BOOLEAN BtDeviceSearchRequest::GetQueryRemoteDeviceName ( ) const

Should the remote device name be retrieved during the inquiry?

GetQueryRemoteDeviceName returns wheter the device name for the remote devices found on the air should be retrieved or not.

Returns:
TRUE: The remote device name should be queried by the Bluetooth stack.
FALSE: The remote device name should not be queried by the Bluetooth stack.

BtRequestType BtDeviceSearchRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtDeviceSearchRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtDeviceSearchRequest::OnRemoteDeviceFound | ( | const BtDevice & | remote_device,
 |  | const BtDeviceAndServiceClass & | remote_device_and_service_class,
 |  | UINT8 | signal_strength
 | ) | [protected, virtual]

Remote device found message handler member function.

The OnRemoteDeviceFound member function will be invoked when a BtRemoteDeviceFoundMessage is received by this request. This member function is used to enable some reactions to the receipt of the aforsaid message.
The implmenetation of this member function is a dummy implementation and does nothing. If the application programmer wants to change this behaviour, he has to overload this function in a derived class. He need not to call the inherited base function, because it does nothing.

Parameters:
remote_device A reference to a BtDevice containing the device that was found on the air and initiated the message.

void BtDeviceSearchRequest::OnRemoteDeviceFound | ( | const BtDevice & | remote_device,
 |  | const BtDeviceAndServiceClass & | remote_device_and_service_class
 | ) | [protected, virtual]

Remote device found message handler member function.

The OnRemoteDeviceFound member function will be invoked when a BtRemoteDeviceFoundMessage is received by this request. This member function is used to enable some reactions to the receipt of the aforsaid message.
The implmenetation of this member function is a dummy implementation and does nothing. If the application programmer wants to change this behaviour, he has to overload this function in a derived class. He need not to call the inherited base function, because it does nothing.

Parameters:
remote_device A reference to a BtDevice containing the device that was found on the air and initiated the message.

void BtDeviceSearchRequest::OnRemoteDeviceName | ( | const BtDevice & | remote_device,
 |  | const WString & | remote_device_name
 | ) | [protected, virtual]

Remote device name received message handler member function.

The OnRemoteDeviceName member function will be invoked when a BtRemoteDeviceNameMessage is received by this request. This member function is used to enable some reactions to the receipt of the aforsaid message.
The implmenetation of this member function is a dummy implementation and does nothing. If the application programmer wants to change this behaviour, he has to overload this function in a derived class. He need not to call the inherited base function, because it does nothing.

Parameters:
remote_device | A reference to a BtDevice containing the device for which the name was received.
remote_device_name | A reference to a WString containing the received remote device name.

Reimplemented in BtApplicationDeviceSearchRequest.

void BtDeviceSearchRequest::RegisterMessages ( void ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtDeviceSearchRequest the following messages are registered: BtDeviceSearchMessage, BtRemoteDeviceMessage, BtRemoteDeviceNameMessage and BtCancelSearchMessage.

Reimplemented from UserDispatcher.

void BtDeviceSearchRequest::SetDeviceAndServiceClass ( BtDeviceAndServiceClass device_and_service_class )

Set kind of devices that should be found.

GetDeviceAndServiceClass sets the device and serivce class bits for the remote devices which the request should search on the air.

Parameters:
device_and_service_class A BtDeviceAndServiceClass containing the device and service class bit that should be found on the air.

void BtDeviceSearchRequest::SetImmediatlyRerieveRemoteDeviceNames ( BOOLEAN immediatly_rerieve_names )

void BtDeviceSearchRequest::SetInquiryAccessCode ( BtInquiryAccessCode inquiry_access_code )

Set the kind of inquiry that should be made.

GetInquiryAccessCode sets the type of inquiry or device search should be done. See the Bluetooth Global Access Profile for further information on Inquiry Access Codes.

Parameters:
inquiry_access_code A BtInquiryAccessCode containig the type of inquiry or device search that should be done.

void BtDeviceSearchRequest::SetInquiryTimeOut ( UINT8 inquiry_time_out = 0 )

Set how long the device search should last at most.

SetInquiryTimeOut sets the timeout period after which the request should stop searching. There are two conditions to stop the device search: the numer of devices to find and the time the device search to run. If one condition is satisfied the device search stops.
Unit of timeout: 1 = 1.28s = 2048 baseband slots a 625 ´s

Parameters:
inquiry_time_out An UINT8 containing the timeout period after which the request should stop searching. Allowed values range from 1 to 48 (1 minute). All other values cause an error.

void BtDeviceSearchRequest::SetMaximalFoundDevice ( UINT8 maximal_found_devices = 0 )

Set how many devices should be found at most.

SetMaximalFoundDevices sets the number remote devices after which the request should stop searching. There are two conditions to stop the device search: the numer of devices to find and the time the device search to run. If one condition is satisfied the device search stops.

Parameters:
maximal_found_devices An UINT8 containing the number of remote devices after which the request should stop searching. Specifying 0 means that the stack should get as much devices as it can store.

void BtDeviceSearchRequest::SetQueryRemoteDeviceName ( BOOLEAN query_remote_device_name )

Set wether the remote device name should be retrieved or not.

GetQueryRemoteDeviceName sets wheter the device name for the remote devices found on the air should be retrieved or not.

Parameters:
query_remote_device_name A BOOLEAN containing whether the names of the remote devices found on the air should be queried or not.

void BtDeviceSearchRequest::UnregisterMessages ( void ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtDeviceSearchRequest the following messages are unregistered: BtDeviceSearchMessage, BtRemoteDeviceMessage, BtRemoteDeviceNameMessage and BtCancelSearchMessage.

Reimplemented from UserDispatcher.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceSearchRequest.hpp
  • Bluetooth/BtDeviceSearchRequest.cpp
Generated on Wed Jan 25 00:59:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceTrustMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceTrustMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtDeviceTrustMessage:

[legend]
Collaboration diagram for BtDeviceTrustMessage:

[legend]

Public Types

enum | { ID = 10227 }

Public Member Functions

BtDeviceTrustMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDeviceTrustMessage ()

Detailed Description

BtDeviceTrustMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtDeviceTrustMessage::BtDeviceTrustMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtDeviceTrustMessage::~BtDeviceTrustMessage ( ) [virtual]

Member Function Documentation

Message * BtDeviceTrustMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtDeviceTrustMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceTrustRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceTrustRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceTrustRequest.hpp>

Inheritance diagram for BtDeviceTrustRequest:

[legend]
Collaboration diagram for BtDeviceTrustRequest:

[legend]

Public Member Functions

BtDeviceTrustRequest (const BtDevice &device)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
virtual | ~BtDeviceTrustRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | RegisterMessages () const
Register the required messages for receipt.
virtual void | UnregisterMessages () const
Unregister the required messages from receipt.

Detailed Description

When two Bluetooth Devices are paired the Bluetooth Stack has created a pair of link keys. These link keys are used for authentication and encryption. When a Remote Bluetooth Device tries to connect to the Local Bluetooth Device and has an valid link key, that means that the link key is stored on both devices, no pin key request is executed.
Each service that can be connected on the Local Bluetooth Device has security settings. When Remote Bluetooth Device tries to connect to a Bluetooth Profile that requires authorizsation an authorizsation request is sent to the Local Bluetooth Device. To suppress this request a Remote Bluetooth Device can be trusted. BtDeviceTrustReauest is the kind of request that creates such a truested relation.
Attention: Only paired devices can be trusted!

Constructor & Destructor Documentation

BtDeviceTrustRequest::BtDeviceTrustRequest ( const BtDevice & device )

Constructor.

BtDeviceTrustRequest::~BtDeviceTrustRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtDeviceTrustRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

ExecuteRequest instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. ExecuteRequest is one of these functions. Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtRequestType BtDeviceTrustRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtDeviceTrustRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtDeviceTrustRequest::RegisterMessages ( ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtDeviceTrustRequest the following message is registered: BtDeviceTrustMessage

Reimplemented from UserDispatcher.

void BtDeviceTrustRequest::UnregisterMessages ( ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtDeviceTrustRequest the following message is unregistered: BtDeviceTrustMessage

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceTrustRequest.hpp
  • Bluetooth/BtDeviceTrustRequest.cpp
Generated on Wed Jan 25 00:59:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceUnpairMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceUnpairMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtDeviceUnpairMessage:

[legend]
Collaboration diagram for BtDeviceUnpairMessage:

[legend]

Public Types

enum | { ID = 10226 }

Public Member Functions

BtDeviceUnpairMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDeviceUnpairMessage ()

Detailed Description

BtDeviceUnpairMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtDeviceUnpairMessage::BtDeviceUnpairMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtDeviceUnpairMessage::~BtDeviceUnpairMessage ( ) [virtual]

Member Function Documentation

Message * BtDeviceUnpairMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtDeviceUnpairMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceUnpairRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceUnpairRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceUnpairRequest.hpp>

Inheritance diagram for BtDeviceUnpairRequest:

[legend]
Collaboration diagram for BtDeviceUnpairRequest:

[legend]

Public Member Functions

BtDeviceUnpairRequest (const BtDevice &device)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
virtual | ~BtDeviceUnpairRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | RegisterMessages () const
Register the required messages for receipt.
virtual void | UnregisterMessages () const
Unregister the required messages from receipt.

Detailed Description

BtDeviceUnpairRequest is used to destroy a former created pairing of two Bluetooth Devices. The result of this request is that the link key that was created by the Bluetooth Stach during the pairing request is destroyed. So when the former paired Bluetooth Device sends an request with the deleted link key this key is not recognized and the procedure of authentication is started.
See BtDevicePairRequest for a complete description of pairing.

Constructor & Destructor Documentation

BtDeviceUnpairRequest::BtDeviceUnpairRequest ( const BtDevice & device )

Constructor.

BtDeviceUnpairRequest::~BtDeviceUnpairRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtDeviceUnpairRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

ExecuteRequest instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. ExecuteRequest is one of these functions. Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtRequestType BtDeviceUnpairRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtDeviceUnpairRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtDeviceUnpairRequest::RegisterMessages ( ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtDeviceUnpairRequest the following message is registered: BtDeviceUnpairMessage

Reimplemented from UserDispatcher.

void BtDeviceUnpairRequest::UnregisterMessages ( ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtDeviceUnpairRequest the following message is unregistered: BtDeviceUnpairMessage

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceUnpairRequest.hpp
  • Bluetooth/BtDeviceUnpairRequest.cpp
Generated on Wed Jan 25 00:59:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceUntrustMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceUntrustMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtDeviceUntrustMessage:

[legend]
Collaboration diagram for BtDeviceUntrustMessage:

[legend]

Public Types

enum | { ID = 10228 }

Public Member Functions

BtDeviceUntrustMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDeviceUntrustMessage ()

Detailed Description

BtDeviceUntrustMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtDeviceUntrustMessage::BtDeviceUntrustMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtDeviceUntrustMessage::~BtDeviceUntrustMessage ( ) [virtual]

Member Function Documentation

Message * BtDeviceUntrustMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtDeviceUntrustMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDeviceUntrustRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDeviceUntrustRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDeviceUntrustRequest.hpp>

Inheritance diagram for BtDeviceUntrustRequest:

[legend]
Collaboration diagram for BtDeviceUntrustRequest:

[legend]

Public Member Functions

BtDeviceUntrustRequest (const BtDevice &device)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
virtual | ~BtDeviceUntrustRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | RegisterMessages () const
Register the required messages for receipt.
virtual void | UnregisterMessages () const
Unregister the required messages from receipt.

Detailed Description

BtDeviceUntrustRequest is used to change the state of a paired Bluetooth Device from trusted to not trusted. The result of this request is that the authorization request is not suppressed when a Remote Bluetooth Device tries to connect to a service that has authorization defined in its security settings.
See BtDeviceTrustRequest for a complete description of trusting.

Constructor & Destructor Documentation

BtDeviceUntrustRequest::BtDeviceUntrustRequest ( const BtDevice & device )

Constructor.

BtDeviceUntrustRequest::~BtDeviceUntrustRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtDeviceUntrustRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

ExecuteRequest instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. ExecuteRequest is one of these functions. Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BtRequestType BtDeviceUntrustRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtDeviceUntrustRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtDeviceUntrustRequest::RegisterMessages ( ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtDeviceUntrustRequest the following message is registered: BtDeviceUntrustMessage

Reimplemented from UserDispatcher.

void BtDeviceUntrustRequest::UnregisterMessages ( ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtDeviceUntrustRequest the following message is unregistered: BtDeviceUntrustMessage

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/BtDeviceUntrustRequest.hpp
  • Bluetooth/BtDeviceUntrustRequest.cpp
Generated on Wed Jan 25 00:59:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDisconnectRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDisconnectRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtDisconnectRequest.hpp>

Inheritance diagram for BtDisconnectRequest:

[legend]
Collaboration diagram for BtDisconnectRequest:

[legend]

Public Member Functions

BtDisconnectRequest (BtService &service)
Constructor.
virtual | ~BtDisconnectRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual BOOLEAN | PerformDisconnectControllerCall ()=0
Perform stack function call for connect.

Friends

class | BtSingleConnectionController

Detailed Description

Some Bluetooth profiles support a disconnect operation. BtDisconnectRequest is the base class for these operations. It implements the basic functionality of the disconnect operations. Profile specific settings and functinalities are capsuled in pure virtual functions and have to be implemented by the concrete disconnect operations of the various profiles.

Constructor & Destructor Documentation

BtDisconnectRequest::BtDisconnectRequest ( BtService & service )

Constructor.

BtDisconnectRequest::~BtDisconnectRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtDisconnectRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate stack parameters. After performing this it calls the PerformDisconnectControllerCall function, which is responsible for calling the apropriate stack function.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

virtual BOOLEAN BtDisconnectRequest::PerformDisconnectControllerCall ( ) [protected, pure virtual]

Perform stack function call for connect.

Because each service interacts with a different controller, the call into this paritcular controller can not be implemented in the base class, so this function is pure virtual und has to be implemented in the concrete disconnect requests of the various services.

Returns:
TRUE: The Bluetooth stack accepted the disconnect operation.
FALSE: The Bluetooth stack rejected the disconnect operation.

Friends And Related Function Documentation

friend class BtSingleConnectionController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtDisconnectRequest.hpp
  • Bluetooth/BtDisconnectRequest.cpp
Generated on Wed Jan 25 00:59:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDiscoverabilityMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDiscoverabilityMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtDiscoverabilityMessage:

[legend]
Collaboration diagram for BtDiscoverabilityMessage:

[legend]

Public Types

enum | { ID = 10214 }

Public Member Functions

BtDiscoverabilityMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDiscoverabilityMessage ()

Detailed Description

BtDiscoverabilityMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtDiscoverabilityMessage::BtDiscoverabilityMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtDiscoverabilityMessage::~BtDiscoverabilityMessage ( ) [virtual]

Member Function Documentation

Message * BtDiscoverabilityMessage::Clone ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

const MsgMetaData & BtDiscoverabilityMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 00:59:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDunApplicationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDunApplicationMessage Class Reference

#include <Apoxi/Bluetooth/DUN/BtDunApplicationMessage.hpp>

Inheritance diagram for BtDunApplicationMessage:

[legend]
Collaboration diagram for BtDunApplicationMessage:

[legend]

Public Types

enum | { ID = 10020 }

Public Member Functions

BtDunApplicationMessage (const BtResultCode &result)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDunApplicationMessage ()

Detailed Description

BtDunApplicationMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtApplicationMessage.

Constructor & Destructor Documentation

BtDunApplicationMessage::BtDunApplicationMessage ( const BtResultCode & result )

BtDunApplicationMessage::~BtDunApplicationMessage ( ) [virtual]

Member Function Documentation

Message * BtDunApplicationMessage::Clone ( ) const [virtual]

Reimplemented from BtApplicationMessage.

Reimplemented in BtDunConnectMessage, and BtDunDisconnectMessage.

const MsgMetaData & BtDunApplicationMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtApplicationMessage.

Reimplemented in BtDunConnectMessage, and BtDunDisconnectMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/DUN/BtDunApplicationMessage.hpp
  • Bluetooth/DUN/BtDunApplicationMessage.cpp
Generated on Wed Jan 25 00:59:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDunAppPlugin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDunAppPlugin Class Reference
[Bluetooth]

#include <Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.hpp>

Collaboration diagram for BtDunAppPlugin:

[legend]

Public Member Functions

void | Init (Application *app)
void | OnDunDisconnectRequestFinished (BOOLEAN success)
response to dun disconnect result
virtual BOOLEAN | OnMessage (const Message &msg)
virtual | ~BtDunAppPlugin ()

Static Public Member Functions

static BtDunAppPlugin * | GetInstance ()

Protected Member Functions

virtual void | OnAppClose ()
virtual void | OnAppOpen ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)

Constructor & Destructor Documentation

BtDunAppPlugin::~BtDunAppPlugin ( ) [virtual]

Member Function Documentation

BtDunAppPlugin * BtDunAppPlugin::GetInstance ( ) [static]

void BtDunAppPlugin::Init ( Application * app )

void BtDunAppPlugin::OnAppClose ( ) [protected, virtual]

See also:
ApplicationPlugin::OnAppClose()

void BtDunAppPlugin::OnAppOpen ( ) [protected, virtual]

See also:
ApplicationPlugin::OnAppOpen()

void BtDunAppPlugin::OnDunDisconnectRequestFinished ( BOOLEAN success )

response to dun disconnect result

BOOLEAN BtDunAppPlugin::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN BtDunAppPlugin::OnMessage ( const Message & msg ) [virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.hpp
  • Applications/BtApp/BtDunAppPlugin/BtDunAppPlugin.cpp
Generated on Wed Jan 25 00:59:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDunConnectMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDunConnectMessage Class Reference

#include <Apoxi/Bluetooth/DUN/BtDunApplicationMessage.hpp>

Inheritance diagram for BtDunConnectMessage:

[legend]
Collaboration diagram for BtDunConnectMessage:

[legend]

Public Types

enum | { ID = 10021 }

Public Member Functions

BtDunConnectMessage (const BtResultCode &result, const BtDevice &device)
virtual Message * | Clone () const
const BtDevice & | GetDevice () const
virtual const MsgMetaData & | GetMetaData () const
void | SetDevice (const BtDevice &device)
virtual | ~BtDunConnectMessage ()

Detailed Description

BtDunConnectMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtDunConnectMessage::BtDunConnectMessage | ( | const BtResultCode & | result,
 |  | const BtDevice & | device
 | ) |

BtDunConnectMessage::~BtDunConnectMessage ( ) [virtual]

Member Function Documentation

Message * BtDunConnectMessage::Clone ( ) const [virtual]

Reimplemented from BtDunApplicationMessage.

const BtDevice& BtDunConnectMessage::GetDevice ( ) const [inline]

const MsgMetaData & BtDunConnectMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtDunApplicationMessage.

void BtDunConnectMessage::SetDevice ( const BtDevice & device ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/DUN/BtDunApplicationMessage.hpp
  • Bluetooth/DUN/BtDunApplicationMessage.cpp
Generated on Wed Jan 25 00:59:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDunDisconnectMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDunDisconnectMessage Class Reference

#include <Apoxi/Bluetooth/DUN/BtDunApplicationMessage.hpp>

Inheritance diagram for BtDunDisconnectMessage:

[legend]
Collaboration diagram for BtDunDisconnectMessage:

[legend]

Public Types

enum | { ID = 10022 }

Public Member Functions

BtDunDisconnectMessage (const BtResultCode &result)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDunDisconnectMessage ()

Detailed Description

BtDunDisconnectMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtDunDisconnectMessage::BtDunDisconnectMessage ( const BtResultCode & result )

BtDunDisconnectMessage::~BtDunDisconnectMessage ( ) [virtual]

Member Function Documentation

Message * BtDunDisconnectMessage::Clone ( ) const [virtual]

Reimplemented from BtDunApplicationMessage.

const MsgMetaData & BtDunDisconnectMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtDunApplicationMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/DUN/BtDunApplicationMessage.hpp
  • Bluetooth/DUN/BtDunApplicationMessage.cpp
Generated on Wed Jan 25 00:59:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDunProfileService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDunProfileService Class Reference

#include <Applications/BtApp/BtDunAppPlugin/BtDunProfileService.hpp>

Inheritance diagram for BtDunProfileService:

[legend]
Collaboration diagram for BtDunProfileService:

[legend]

Public Member Functions

BtDunProfileService ()
Constructor.
virtual | ~BtDunProfileService ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
Response to user initiate dun disconnect request.

Constructor & Destructor Documentation

BtDunProfileService::BtDunProfileService ( )

Constructor.

BtDunProfileService::~BtDunProfileService ( ) [virtual]

Destructor.

Member Function Documentation

void BtDunProfileService::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Response to user initiate dun disconnect request.

OnRequestStateChange will be automatically called if the dun disconnect request state changed.

Parameters:
request_type | A BtRequestType identify the request type.
old_request_state | the old BtRequestState
new_request_state | the BtRequestState after the evoking request operation.

Implements BtService.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtDunAppPlugin/BtDunProfileService.hpp
  • Applications/BtApp/BtDunAppPlugin/BtDunProfileService.cpp
Generated on Wed Jan 25 00:59:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDunRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDunRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/DUN/BtDunServiceMessage.hpp>

Inheritance diagram for BtDunRequestStateChangedMessage:

[legend]
Collaboration diagram for BtDunRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10315 }

Public Member Functions

BtDunRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtDunRequestStateChangedMessage ()

Detailed Description

BtDunRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtDunRequestStateChangedMessage::BtDunRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtDunRequestStateChangedMessage::~BtDunRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtDunRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtDunRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/DUN/BtDunServiceMessage.hpp
  • Bluetooth/DUN/BtDunServiceMessage.cpp
Generated on Wed Jan 25 00:59:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtDunService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtDunService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/DUN/BtDunService.hpp>

Inheritance diagram for BtDunService:

[legend]
Collaboration diagram for BtDunService:

[legend]

Public Member Functions

BtDunService ()
Constructor.
BtRequestState DisconnectRequest ()
Disconnects the DUN-Serivce from the target remote device.
virtual BtProfile | GetProfile () const
Get the profile this service is associated with.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
BOOLEAN | IsConnected () const
virtual | ~BtDunService ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &message)
virtual void | RegisterMessages () const
virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | UnregisterMessages () const

Detailed Description

BtDunService is implemented as a singleton. Offers the functionality for dial up networks and so extends the basic functionality, it depends on BtDunController who forms the low level interface to the Bluetooth Stack.

Constructor & Destructor Documentation

BtDunService::BtDunService ( )

Constructor.

BtDunService::~BtDunService ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtDunService::DisconnectRequest ( )

Disconnects the DUN-Serivce from the target remote device.

BtProfile BtDunService::GetProfile ( ) const [virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implements BtService.

BtRequestState BtDunService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

BOOLEAN BtDunService::IsConnected ( ) const

BOOLEAN BtDunService::OnMessage ( const Message & message ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void BtDunService::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

void BtDunService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Implements BtService.

void BtDunService::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/DUN/BtDunService.hpp
  • Bluetooth/DUN/BtDunService.cpp
Generated on Wed Jan 25 00:59:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtEvent.hpp>

Inheritance diagram for BtEvent:

[legend]

Public Member Functions

BtEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const =0
BtResultCode | GetResult () const
virtual | ~BtEvent ()
Destructor.

Constructor & Destructor Documentation

BtEvent::BtEvent ( BtResultCode result )

Constructor.

BtEvent::~BtEvent ( ) [virtual]

Destructor.

Member Function Documentation

virtual UINT16 BtEvent::GetId ( ) const [pure virtual]

Implemented in BtSddbRegisterServiceEvent, BtSddbUnregisterServiceEvent, BtObexUnregisterEvent, BtObexHeaderIndicationEvent, BtObexHeaderSentEvent, BtObexDataBufferIndicationEvent, BtObexDataIndicationEvent, BtObexTransportDisconnectEvent, BtObexRegisterServerEvent, BtObexServerConnectIndicationEvent, BtObexServerDisconnectIndicationEvent, BtObexServerSetPathIndicationEvent, BtObexServerGetIndicationEvent, BtObexServerPutIndicationEvent, BtObexServerAbortIndicationEvent, BtObexRegisterClientEvent, BtObexClientConnectEvent, BtObexClientDisconnectEvent, BtObexClientSetPathEvent, BtObexClientGetEvent, BtObexClientPutEvent, and BtObexClientAbortEvent.

BtResultCode BtEvent::GetResult ( ) const

The documentation for this class was generated from the following files:
  • Bluetooth/BtEvent.hpp
  • Bluetooth/BtEvent.cpp
Generated on Wed Jan 25 00:59:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtFaxApplicationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtFaxApplicationMessage Class Reference

#include <Apoxi/Bluetooth/FAX/BtFaxApplicationMessage.hpp>

Inheritance diagram for BtFaxApplicationMessage:

[legend]
Collaboration diagram for BtFaxApplicationMessage:

[legend]

Public Types

enum | { ID = 10030 }

Public Member Functions

BtFaxApplicationMessage (const BtResultCode &result)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtFaxApplicationMessage ()

Detailed Description

BtFaxApplicationMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtApplicationMessage.

Constructor & Destructor Documentation

BtFaxApplicationMessage::BtFaxApplicationMessage ( const BtResultCode & result )

BtFaxApplicationMessage::~BtFaxApplicationMessage ( ) [virtual]

Member Function Documentation

Message * BtFaxApplicationMessage::Clone ( ) const [virtual]

Reimplemented from BtApplicationMessage.

Reimplemented in BtFaxConnectMessage, and BtFaxDisconnectMessage.

const MsgMetaData & BtFaxApplicationMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtApplicationMessage.

Reimplemented in BtFaxConnectMessage, and BtFaxDisconnectMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/FAX/BtFaxApplicationMessage.hpp
  • Bluetooth/FAX/BtFaxApplicationMessage.cpp
Generated on Wed Jan 25 00:59:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtFaxAppPlugin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtFaxAppPlugin Class Reference
[Bluetooth]

#include <Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.hpp>

Collaboration diagram for BtFaxAppPlugin:

[legend]

Public Member Functions

void | Init (Application *app)
void | OnFaxDisconnectRequestFinished (BOOLEAN success)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual | ~BtFaxAppPlugin ()

Static Public Member Functions

static BtFaxAppPlugin * | GetInstance ()

Protected Member Functions

virtual void | OnAppClose ()
virtual void | OnAppOpen ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)

Constructor & Destructor Documentation

BtFaxAppPlugin::~BtFaxAppPlugin ( ) [virtual]

Member Function Documentation

BtFaxAppPlugin * BtFaxAppPlugin::GetInstance ( ) [static]

void BtFaxAppPlugin::Init ( Application * app )

void BtFaxAppPlugin::OnAppClose ( ) [protected, virtual]

See also:
ApplicationPlugin::OnAppClose()

void BtFaxAppPlugin::OnAppOpen ( ) [protected, virtual]

See also:
ApplicationPlugin::OnAppOpen()

void BtFaxAppPlugin::OnFaxDisconnectRequestFinished ( BOOLEAN success )

BOOLEAN BtFaxAppPlugin::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN BtFaxAppPlugin::OnMessage ( const Message & msg ) [virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.hpp
  • Applications/BtApp/BtFaxAppPlugin/BtFaxAppPlugin.cpp
Generated on Wed Jan 25 00:59:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtFaxConnectMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtFaxConnectMessage Class Reference

#include <Apoxi/Bluetooth/FAX/BtFaxApplicationMessage.hpp>

Inheritance diagram for BtFaxConnectMessage:

[legend]
Collaboration diagram for BtFaxConnectMessage:

[legend]

Public Types

enum | { ID = 10031 }

Public Member Functions

BtFaxConnectMessage (const BtResultCode &result, const BtDevice &device)
virtual Message * | Clone () const
const BtDevice & | GetDevice () const
virtual const MsgMetaData & | GetMetaData () const
void | SetDevice (const BtDevice &device)
virtual | ~BtFaxConnectMessage ()

Detailed Description

BtFaxConnectMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtFaxConnectMessage::BtFaxConnectMessage | ( | const BtResultCode & | result,
 |  | const BtDevice & | device
 | ) |

BtFaxConnectMessage::~BtFaxConnectMessage ( ) [virtual]

Member Function Documentation

Message * BtFaxConnectMessage::Clone ( ) const [virtual]

Reimplemented from BtFaxApplicationMessage.

const BtDevice& BtFaxConnectMessage::GetDevice ( ) const [inline]

const MsgMetaData & BtFaxConnectMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtFaxApplicationMessage.

void BtFaxConnectMessage::SetDevice ( const BtDevice & device ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/FAX/BtFaxApplicationMessage.hpp
  • Bluetooth/FAX/BtFaxApplicationMessage.cpp
Generated on Wed Jan 25 00:59:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtFaxDisconnectMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtFaxDisconnectMessage Class Reference

#include <Apoxi/Bluetooth/FAX/BtFaxApplicationMessage.hpp>

Inheritance diagram for BtFaxDisconnectMessage:

[legend]
Collaboration diagram for BtFaxDisconnectMessage:

[legend]

Public Types

enum | { ID = 10032 }

Public Member Functions

BtFaxDisconnectMessage (const BtResultCode &result)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtFaxDisconnectMessage ()

Detailed Description

BtFaxDisconnectMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtFaxDisconnectMessage::BtFaxDisconnectMessage ( const BtResultCode & result )

BtFaxDisconnectMessage::~BtFaxDisconnectMessage ( ) [virtual]

Member Function Documentation

Message * BtFaxDisconnectMessage::Clone ( ) const [virtual]

Reimplemented from BtFaxApplicationMessage.

const MsgMetaData & BtFaxDisconnectMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtFaxApplicationMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/FAX/BtFaxApplicationMessage.hpp
  • Bluetooth/FAX/BtFaxApplicationMessage.cpp
Generated on Wed Jan 25 00:59:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtFaxProfileService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtFaxProfileService Class Reference

#include <Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.hpp>

Inheritance diagram for BtFaxProfileService:

[legend]
Collaboration diagram for BtFaxProfileService:

[legend]

Public Member Functions

BtFaxProfileService ()
Constructor.
virtual | ~BtFaxProfileService ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
Response to user initiate Fax disconnect request.

Constructor & Destructor Documentation

BtFaxProfileService::BtFaxProfileService ( )

Constructor.

BtFaxProfileService::~BtFaxProfileService ( ) [virtual]

Destructor.

Member Function Documentation

void BtFaxProfileService::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Response to user initiate Fax disconnect request.

OnRequestStateChange will be automatically called if the Fax disconnect request state changed.

Parameters:
request_type | A BtRequestType identify the request type.
old_request_state | the old BtRequestState
new_request_state | the BtRequestState after the evoking request operation.

Implements BtService.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.hpp
  • Applications/BtApp/BtFaxAppPlugin/BtFaxProfileService.cpp
Generated on Wed Jan 25 00:59:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtFaxRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtFaxRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/FAX/BtFaxServiceMessage.hpp>

Inheritance diagram for BtFaxRequestStateChangedMessage:

[legend]
Collaboration diagram for BtFaxRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10320 }

Public Member Functions

BtFaxRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtFaxRequestStateChangedMessage ()

Detailed Description

BtFaxRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtFaxRequestStateChangedMessage::BtFaxRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtFaxRequestStateChangedMessage::~BtFaxRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtFaxRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtFaxRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/FAX/BtFaxServiceMessage.hpp
  • Bluetooth/FAX/BtFaxServiceMessage.cpp
Generated on Wed Jan 25 00:59:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtFaxService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtFaxService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/FAX/BtFaxService.hpp>

Inheritance diagram for BtFaxService:

[legend]
Collaboration diagram for BtFaxService:

[legend]

Public Member Functions

BtFaxService ()
Constructor.
BtRequestState DisconnectRequest ()
Disconnects the DUN-Serivce from the target remote device.
virtual BtProfile | GetProfile () const
Get the profile this service is associated with.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
BOOLEAN | IsConnected () const
virtual | ~BtFaxService ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &message)
virtual void | RegisterMessages () const
virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | UnregisterMessages () const

Detailed Description

BtFaxService is implemented as a singleton. Offers the functionality for dial up networks and so extends the basic functionality, it depends on BtFaxController who forms the low level interface to the Bluetooth Stack.

Constructor & Destructor Documentation

BtFaxService::BtFaxService ( )

Constructor.

BtFaxService::~BtFaxService ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtFaxService::DisconnectRequest ( )

Disconnects the DUN-Serivce from the target remote device.

BtProfile BtFaxService::GetProfile ( ) const [virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implements BtService.

BtRequestState BtFaxService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

BOOLEAN BtFaxService::IsConnected ( ) const

BOOLEAN BtFaxService::OnMessage ( const Message & message ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void BtFaxService::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

void BtFaxService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Implements BtService.

void BtFaxService::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/FAX/BtFaxService.hpp
  • Bluetooth/FAX/BtFaxService.cpp
Generated on Wed Jan 25 00:59:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtGapAndSdapApplicationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtGapAndSdapApplicationMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapApplicationMessage.hpp>

Inheritance diagram for BtGapAndSdapApplicationMessage:

[legend]
Collaboration diagram for BtGapAndSdapApplicationMessage:

[legend]

Public Types

enum | { ID = 10010 }

Public Member Functions

BtGapAndSdapApplicationMessage (const BtResultCode &result)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtGapAndSdapApplicationMessage ()

Detailed Description

BtGapAndSdapApplicationMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtApplicationMessage.

Constructor & Destructor Documentation

BtGapAndSdapApplicationMessage::BtGapAndSdapApplicationMessage ( const BtResultCode & result )

BtGapAndSdapApplicationMessage::~BtGapAndSdapApplicationMessage ( ) [virtual]

Member Function Documentation

Message * BtGapAndSdapApplicationMessage::Clone ( ) const [virtual]

Reimplemented from BtApplicationMessage.

Reimplemented in BtGapAndSdapRemoteRequestMessage, BtPasskeyRequiredMessage, BtAuthorizationRequiredMessage, BtGapAndSdapNotificationMessage, and BtRemoteDevicePairMessage.

const MsgMetaData & BtGapAndSdapApplicationMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtApplicationMessage.

Reimplemented in BtGapAndSdapRemoteRequestMessage, BtPasskeyRequiredMessage, BtAuthorizationRequiredMessage, BtGapAndSdapNotificationMessage, and BtRemoteDevicePairMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapApplicationMessage.hpp
  • Bluetooth/BtGapAndSdapApplicationMessage.cpp
Generated on Wed Jan 25 01:00:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtGapAndSdapNotificationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtGapAndSdapNotificationMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapApplicationMessage.hpp>

Inheritance diagram for BtGapAndSdapNotificationMessage:

[legend]
Collaboration diagram for BtGapAndSdapNotificationMessage:

[legend]

Public Types

enum | { ID = 10014 }

Public Member Functions

BtGapAndSdapNotificationMessage (const BtResultCode &result)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtGapAndSdapNotificationMessage ()

Detailed Description

BtGapAndSdapNotificationMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtGapAndSdapNotificationMessage::BtGapAndSdapNotificationMessage ( const BtResultCode & result )

BtGapAndSdapNotificationMessage::~BtGapAndSdapNotificationMessage ( ) [virtual]

Member Function Documentation

Message * BtGapAndSdapNotificationMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapApplicationMessage.

Reimplemented in BtRemoteDevicePairMessage.

const MsgMetaData & BtGapAndSdapNotificationMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapApplicationMessage.

Reimplemented in BtRemoteDevicePairMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapApplicationMessage.hpp
  • Bluetooth/BtGapAndSdapApplicationMessage.cpp
Generated on Wed Jan 25 01:00:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtGapAndSdapRemoteRequestMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtGapAndSdapRemoteRequestMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapApplicationMessage.hpp>

Inheritance diagram for BtGapAndSdapRemoteRequestMessage:

[legend]
Collaboration diagram for BtGapAndSdapRemoteRequestMessage:

[legend]

Public Types

enum | { ID = 10011 }

Public Member Functions

BtGapAndSdapRemoteRequestMessage (const BtResultCode &result, const BtDeviceAddress &device_address, const WString &device_name)
virtual Message * | Clone () const
const BtDeviceAddress & | GetDeviceAddress () const
const WString & | GetDeviceName () const
virtual const MsgMetaData & | GetMetaData () const
void | SetDeviceAddress (const BtDeviceAddress &device_address)
void | SetDeviceName (const WString &device_name)
virtual | ~BtGapAndSdapRemoteRequestMessage ()

Detailed Description

BtGapAndSdapRemoteRequestMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtGapAndSdapRemoteRequestMessage::BtGapAndSdapRemoteRequestMessage | ( | const BtResultCode & | result,
 |  | const BtDeviceAddress & | device_address,
 |  | const WString & | device_name
 | ) |

BtGapAndSdapRemoteRequestMessage::~BtGapAndSdapRemoteRequestMessage ( ) [virtual]

Member Function Documentation

Message * BtGapAndSdapRemoteRequestMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapApplicationMessage.

Reimplemented in BtPasskeyRequiredMessage, and BtAuthorizationRequiredMessage.

const BtDeviceAddress& BtGapAndSdapRemoteRequestMessage::GetDeviceAddress ( ) const [inline]

const WString& BtGapAndSdapRemoteRequestMessage::GetDeviceName ( ) const [inline]

const MsgMetaData & BtGapAndSdapRemoteRequestMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapApplicationMessage.

Reimplemented in BtPasskeyRequiredMessage, and BtAuthorizationRequiredMessage.

void BtGapAndSdapRemoteRequestMessage::SetDeviceAddress ( const BtDeviceAddress & device_address ) [inline]

void BtGapAndSdapRemoteRequestMessage::SetDeviceName ( const WString & device_name ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapApplicationMessage.hpp
  • Bluetooth/BtGapAndSdapApplicationMessage.cpp
Generated on Wed Jan 25 01:00:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtGapAndSdapRequestMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtGapAndSdapRequestMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtGapAndSdapRequestMessage:

[legend]
Collaboration diagram for BtGapAndSdapRequestMessage:

[legend]

Public Types

enum | { ID = 10210 }

Public Member Functions

BtGapAndSdapRequestMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtGapAndSdapRequestMessage ()

Detailed Description

BtGapAndSdapRequestMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtRequestMessage.

Constructor & Destructor Documentation

BtGapAndSdapRequestMessage::BtGapAndSdapRequestMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtGapAndSdapRequestMessage::~BtGapAndSdapRequestMessage ( ) [virtual]

Member Function Documentation

Message * BtGapAndSdapRequestMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestMessage.

Reimplemented in BtStateChangedMessage, BtLocalSettingsMessage, BtLocalNameMessage, BtDiscoverabilityMessage, BtPairabilityMessage, BtConnectabilityMessage, BtProfileActivationMessage, BtSendPasskeyMessage, BtRespondAuthorizationMessage, BtDeviceSearchMessage, BtRemoteDeviceMessage, BtRemoteDeviceNameMessage, BtCancelSearchMessage, BtSetRemoteDeviceNameMessage, BtDevicePairMessage, BtDeviceUnpairMessage, BtDeviceTrustMessage, BtDeviceUntrustMessage, BtQuerySupportedProfilesMessage, BtHsSupportedProfileMessage, BtHfSupportedProfileMessage, BtPaSupportedProfileMessage, BtServiceVerifyMessage, BtServiceVerifyResultMessage, and BtCancelVerifyMessage.

const MsgMetaData & BtGapAndSdapRequestMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestMessage.

Reimplemented in BtStateChangedMessage, BtLocalSettingsMessage, BtLocalNameMessage, BtDiscoverabilityMessage, BtPairabilityMessage, BtConnectabilityMessage, BtProfileActivationMessage, BtSendPasskeyMessage, BtRespondAuthorizationMessage, BtDeviceSearchMessage, BtRemoteDeviceMessage, BtRemoteDeviceNameMessage, BtCancelSearchMessage, BtSetRemoteDeviceNameMessage, BtDevicePairMessage, BtDeviceUnpairMessage, BtDeviceTrustMessage, BtDeviceUntrustMessage, BtQuerySupportedProfilesMessage, BtHsSupportedProfileMessage, BtHfSupportedProfileMessage, BtPaSupportedProfileMessage, BtServiceVerifyMessage, BtServiceVerifyResultMessage, and BtCancelVerifyMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:00:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfAppPlugin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfAppPlugin Class Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.hpp>

Collaboration diagram for BtHfAppPlugin:

[legend]

Public Member Functions

void | AddMenuFeature (FeatureID feature, BOOLEAN success)
virtual void | Init (Application *bt_app)
void | RemoveMenuFeature (FeatureID feature, BOOLEAN success)
virtual | ~BtHfAppPlugin ()

Static Public Member Functions

static BtHfAppPlugin * | GetInstance ()

Protected Member Functions

virtual BOOLEAN | BtHfInsertPhoneNr ()
virtual void | OnAppClose ()
virtual void | OnAppOpen ()
void | OnConnectNotification (BtResultCode result, const BtDevice &device)
virtual BOOLEAN | OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &context_item)
void | OnDisconnectNotification (BtResultCode result)
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
BOOLEAN | OnHfNotification (const BtHfNotificationMessage &hf_notification_message)
virtual BOOLEAN | OnMessage (const Message &msg)
void | OnTransferAudioToAccessoryNotification (BtResultCode result)
void | OnTransferAudioToPhoneNotification ()
virtual void | RegisterHfMessages () const
virtual void | UnregisterHfMessages () const

Constructor & Destructor Documentation

BtHfAppPlugin::~BtHfAppPlugin ( ) [virtual]

Member Function Documentation

void BtHfAppPlugin::AddMenuFeature | ( | FeatureID | feature,
 |  | BOOLEAN | success
 | ) |

BOOLEAN BtHfAppPlugin::BtHfInsertPhoneNr ( ) [protected, virtual]

BtHfAppPlugin * BtHfAppPlugin::GetInstance ( ) [static]

void BtHfAppPlugin::Init ( Application * bt_app ) [virtual]

void BtHfAppPlugin::OnAppClose ( ) [protected, virtual]

void BtHfAppPlugin::OnAppOpen ( ) [protected, virtual]

void BtHfAppPlugin::OnConnectNotification | ( | BtResultCode | result,
 |  | const BtDevice & | device
 | ) | [protected]

BOOLEAN BtHfAppPlugin::OnContextFeatureTriggered | ( | const FeatureID & | feature_id,
 |  | const DataItem & | context_item
 | ) | [protected, virtual]

void BtHfAppPlugin::OnDisconnectNotification ( BtResultCode result ) [protected]

BOOLEAN BtHfAppPlugin::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN BtHfAppPlugin::OnHfNotification ( const BtHfNotificationMessage & hf_notification_message ) [protected]

BOOLEAN BtHfAppPlugin::OnMessage ( const Message & msg ) [protected, virtual]

void BtHfAppPlugin::OnTransferAudioToAccessoryNotification ( BtResultCode result ) [protected]

void BtHfAppPlugin::OnTransferAudioToPhoneNotification ( ) [protected]

void BtHfAppPlugin::RegisterHfMessages ( ) const [protected, virtual]

Registers messages

See also:
UserDispatcher::RegisterMessages()

void BtHfAppPlugin::RemoveMenuFeature | ( | FeatureID | feature,
 |  | BOOLEAN | success
 | ) |

void BtHfAppPlugin::UnregisterHfMessages ( ) const [protected, virtual]

Unregisters messages

See also:
UserDispatcher::RegisterMessages()

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfAppPlugin.cpp
Generated on Wed Jan 25 01:00:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfAudioPathWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfAudioPathWindow Class Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.hpp>

Collaboration diagram for BtHfAudioPathWindow:

[legend]

Public Types

enum | BtHfPath { CurrentAudioPath, DefaultAudioPath }

Public Member Functions

BtHfAudioPathWindow (BtHfProfileService &service)
void | Init ()
void | OpenCurrentPathWindow (void)
void | OpenDefaultPathWindow (void)
virtual | ~BtHfAudioPathWindow ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Member Enumeration Documentation

enum BtHfAudioPathWindow::BtHfPath

Enumerator:
CurrentAudioPath
DefaultAudioPath

Constructor & Destructor Documentation

BtHfAudioPathWindow::BtHfAudioPathWindow ( BtHfProfileService & service )

BtHfAudioPathWindow::~BtHfAudioPathWindow ( ) [virtual]

Member Function Documentation

void BtHfAudioPathWindow::Init ( )

BOOLEAN BtHfAudioPathWindow::OnCancel ( ) [protected, virtual]

BOOLEAN BtHfAudioPathWindow::OnConfirm ( ) [protected, virtual]

void BtHfAudioPathWindow::OnOpen ( ) [protected, virtual]

void BtHfAudioPathWindow::OpenCurrentPathWindow ( void )

void BtHfAudioPathWindow::OpenDefaultPathWindow ( void )

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfAudioPathWindow.cpp
Generated on Wed Jan 25 01:00:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfCmaAtChldOneCommandReceived Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfCmaAtChldOneCommandReceived Class Reference

#include <Apoxi/Bluetooth/HF/BtHfControllerMessageArgument.hpp>

Inheritance diagram for BtHfCmaAtChldOneCommandReceived:

[legend]
Collaboration diagram for BtHfCmaAtChldOneCommandReceived:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

BtHfCmaAtChldOneCommandReceived ()
~BtHfCmaAtChldOneCommandReceived ()

Static Public Member Functions

static const BtHfCmaAtChldOneCommandReceived & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfCmaAtChldOneCommandReceived

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfCmaAtChldOneCommandReceived::BtHfCmaAtChldOneCommandReceived ( )

BtHfCmaAtChldOneCommandReceived::~BtHfCmaAtChldOneCommandReceived ( )

Member Function Documentation

const BtHfCmaAtChldOneCommandReceived & BtHfCmaAtChldOneCommandReceived::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfControllerMessageArgument.hpp
  • Bluetooth/HF/BtHfControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfCmaAudioAsynchronous Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfCmaAudioAsynchronous Class Reference

#include <Apoxi/Bluetooth/HF/BtHfControllerMessageArgument.hpp>

Inheritance diagram for BtHfCmaAudioAsynchronous:

[legend]
Collaboration diagram for BtHfCmaAudioAsynchronous:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

BtHfCmaAudioAsynchronous ()
BtHfCmaAudioAsynchronous (BOOLEAN sco_path_status, BOOLEAN audio_connected, BOOLEAN audio_switch_path)
BOOLEAN | IsAudioConnected () const
BOOLEAN | IsAudioSwitchPath () const
BOOLEAN | IsScoPathStatus () const
void | SetAudioConnected (BOOLEAN audio_connected)
void | SetAudioSwitchPath (BOOLEAN audio_switch_path)
void | SetScoPathStatus (BOOLEAN sco_path_status)
~BtHfCmaAudioAsynchronous ()

Static Public Member Functions

static const BtHfCmaAudioAsynchronous & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfCmaMOC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfCmaAudioAsynchronous::BtHfCmaAudioAsynchronous | ( | BOOLEAN | sco_path_status,
 |  | BOOLEAN | audio_connected,
 |  | BOOLEAN | audio_switch_path
 | ) |

BtHfCmaAudioAsynchronous::BtHfCmaAudioAsynchronous ( )

BtHfCmaAudioAsynchronous::~BtHfCmaAudioAsynchronous ( )

Member Function Documentation

const BtHfCmaAudioAsynchronous & BtHfCmaAudioAsynchronous::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN BtHfCmaAudioAsynchronous::IsAudioConnected ( ) const [inline]

BOOLEAN BtHfCmaAudioAsynchronous::IsAudioSwitchPath ( ) const [inline]

BOOLEAN BtHfCmaAudioAsynchronous::IsScoPathStatus ( ) const [inline]

void BtHfCmaAudioAsynchronous::SetAudioConnected ( BOOLEAN audio_connected ) [inline]

void BtHfCmaAudioAsynchronous::SetAudioSwitchPath ( BOOLEAN audio_switch_path ) [inline]

void BtHfCmaAudioAsynchronous::SetScoPathStatus ( BOOLEAN sco_path_status ) [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfControllerMessageArgument.hpp
  • Bluetooth/HF/BtHfControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfCmaCheckPendingAudioCallback Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfCmaCheckPendingAudioCallback Class Reference

#include <Apoxi/Bluetooth/HF/BtHfControllerMessageArgument.hpp>

Inheritance diagram for BtHfCmaCheckPendingAudioCallback:

[legend]
Collaboration diagram for BtHfCmaCheckPendingAudioCallback:

[legend]

Public Types

enum | { ID = 5 }

Public Member Functions

BtHfCmaCheckPendingAudioCallback ()
~BtHfCmaCheckPendingAudioCallback ()

Static Public Member Functions

static const BtHfCmaCheckPendingAudioCallback & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfCmaCheckPendingAudioCallback

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfCmaCheckPendingAudioCallback::BtHfCmaCheckPendingAudioCallback ( )

BtHfCmaCheckPendingAudioCallback::~BtHfCmaCheckPendingAudioCallback ( )

Member Function Documentation

const BtHfCmaCheckPendingAudioCallback & BtHfCmaCheckPendingAudioCallback::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfControllerMessageArgument.hpp
  • Bluetooth/HF/BtHfControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfCmaMOC Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfCmaMOC Class Reference

#include <Apoxi/Bluetooth/HF/BtHfControllerMessageArgument.hpp>

Inheritance diagram for BtHfCmaMOC:

[legend]
Collaboration diagram for BtHfCmaMOC:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

BtHfCmaMOC ()
~BtHfCmaMOC ()

Static Public Member Functions

static const BtHfCmaMOC & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfCmaMOC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfCmaMOC::BtHfCmaMOC ( )

BtHfCmaMOC::~BtHfCmaMOC ( )

Member Function Documentation

const BtHfCmaMOC & BtHfCmaMOC::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfControllerMessageArgument.hpp
  • Bluetooth/HF/BtHfControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfCmaMTC Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfCmaMTC Class Reference

#include <Apoxi/Bluetooth/HF/BtHfControllerMessageArgument.hpp>

Inheritance diagram for BtHfCmaMTC:

[legend]
Collaboration diagram for BtHfCmaMTC:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

BtHfCmaMTC ()
~BtHfCmaMTC ()

Static Public Member Functions

static const BtHfCmaMTC & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfCmaMTC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfCmaMTC::BtHfCmaMTC ( )

BtHfCmaMTC::~BtHfCmaMTC ( )

Member Function Documentation

const BtHfCmaMTC & BtHfCmaMTC::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfControllerMessageArgument.hpp
  • Bluetooth/HF/BtHfControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfCmaPhoneNumberRequired Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfCmaPhoneNumberRequired Class Reference

#include <Apoxi/Bluetooth/HF/BtHfControllerMessageArgument.hpp>

Inheritance diagram for BtHfCmaPhoneNumberRequired:

[legend]
Collaboration diagram for BtHfCmaPhoneNumberRequired:

[legend]

Public Types

enum | { ID = 0 }

Public Member Functions

BtHfCmaPhoneNumberRequired ()
BtHfCmaPhoneNumberRequired (const BtResultCode &result)
const BtResultCode & | GetResult () const
void | SetResult (const BtResultCode &result)
~BtHfCmaPhoneNumberRequired ()

Static Public Member Functions

static const BtHfCmaPhoneNumberRequired & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfCmaPhoneNumberRequired

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfCmaPhoneNumberRequired::BtHfCmaPhoneNumberRequired ( const BtResultCode & result )

BtHfCmaPhoneNumberRequired::BtHfCmaPhoneNumberRequired ( )

BtHfCmaPhoneNumberRequired::~BtHfCmaPhoneNumberRequired ( )

Member Function Documentation

const BtHfCmaPhoneNumberRequired & BtHfCmaPhoneNumberRequired::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHfCmaPhoneNumberRequired::GetResult ( ) const [inline]

void BtHfCmaPhoneNumberRequired::SetResult ( const BtResultCode & result ) [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfControllerMessageArgument.hpp
  • Bluetooth/HF/BtHfControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfFeatureListWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfFeatureListWin Class Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp>

Collaboration diagram for BtHfFeatureListWin:

[legend]

Public Member Functions

BtHfFeatureListWin (BtHfProfileService &service)
void | Init ()
virtual | ~BtHfFeatureListWin ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

BtHfFeatureListWin::BtHfFeatureListWin ( BtHfProfileService & service )

BtHfFeatureListWin::~BtHfFeatureListWin ( ) [virtual]

Member Function Documentation

void BtHfFeatureListWin::Init ( )

BOOLEAN BtHfFeatureListWin::OnCancel ( ) [protected, virtual]

BOOLEAN BtHfFeatureListWin::OnConfirm ( ) [protected, virtual]

void BtHfFeatureListWin::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.cpp
Generated on Wed Jan 25 01:00:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfInbandSettingWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfInbandSettingWin Class Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.hpp>

Collaboration diagram for BtHfInbandSettingWin:

[legend]

Public Member Functions

BtHfInbandSettingWin (BtHfProfileService &service)
void | Init ()
virtual | ~BtHfInbandSettingWin ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

BtHfInbandSettingWin::BtHfInbandSettingWin ( BtHfProfileService & service )

BtHfInbandSettingWin::~BtHfInbandSettingWin ( ) [virtual]

Member Function Documentation

void BtHfInbandSettingWin::Init ( )

BOOLEAN BtHfInbandSettingWin::OnConfirm ( ) [protected, virtual]

void BtHfInbandSettingWin::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfInbandSettingWin.cpp
Generated on Wed Jan 25 01:00:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfMessageArgumentsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfMessageArgumentsDestroyTableNode Class Reference

#include <Apoxi/Bluetooth/HF/BtHfMessageArguments.hpp>

Inheritance diagram for BtHfMessageArgumentsDestroyTableNode:

[legend]
Collaboration diagram for BtHfMessageArgumentsDestroyTableNode:

[legend]

Static Public Member Functions

static BtHfMessageArgumentsDestroyTableNode * GetInstance ()

Member Function Documentation

BtHfMessageArgumentsDestroyTableNode * BtHfMessageArgumentsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfMessageArguments.hpp
  • Bluetooth/HF/BtHfMessageArguments.cpp
Generated on Wed Jan 25 01:00:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaAudioConnectionLost Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaAudioConnectionLost Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaAudioConnectionLost:

[legend]
Collaboration diagram for BtHfNmaAudioConnectionLost:

[legend]

Public Types

enum | { ID = 14 }

Public Member Functions

BtHfNmaAudioConnectionLost ()
BtHfNmaAudioConnectionLost (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHfNmaAudioConnectionLost ()

Static Public Member Functions

static const BtHfNmaAudioConnectionLost & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaAudioConnectionLost

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaAudioConnectionLost::BtHfNmaAudioConnectionLost ( const BtResultCode & result )

BtHfNmaAudioConnectionLost::BtHfNmaAudioConnectionLost ( )

BtHfNmaAudioConnectionLost::~BtHfNmaAudioConnectionLost ( )

Member Function Documentation

const BtHfNmaAudioConnectionLost & BtHfNmaAudioConnectionLost::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHfNmaAudioConnectionLost::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaCallEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaCallEvent Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaCallEvent:

[legend]
Collaboration diagram for BtHfNmaCallEvent:

[legend]

Public Types

enum | { ID = 18 }

Public Member Functions

BtHfNmaCallEvent ()
BtHfNmaCallEvent (const BtHfCallEvent &call_event)
const BtHfCallEvent & | GetCallEvent () const
~BtHfNmaCallEvent ()

Static Public Member Functions

static const BtHfNmaCallEvent & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaCallEvent

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaCallEvent::BtHfNmaCallEvent ( const BtHfCallEvent & call_event )

BtHfNmaCallEvent::BtHfNmaCallEvent ( )

BtHfNmaCallEvent::~BtHfNmaCallEvent ( )

Member Function Documentation

const BtHfNmaCallEvent & BtHfNmaCallEvent::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtHfCallEvent& BtHfNmaCallEvent::GetCallEvent ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaConnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaConnect Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaConnect:

[legend]
Collaboration diagram for BtHfNmaConnect:

[legend]

Public Types

enum | { ID = 10 }

Public Member Functions

BtHfNmaConnect ()
BtHfNmaConnect (const BtResultCode &result, const BtDevice &device)
const BtDevice & | GetDevice () const
const BtResultCode & | GetResult () const
~BtHfNmaConnect ()

Static Public Member Functions

static const BtHfNmaConnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaConnect

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaConnect::BtHfNmaConnect | ( | const BtResultCode & | result,
 |  | const BtDevice & | device
 | ) |

BtHfNmaConnect::BtHfNmaConnect ( )

BtHfNmaConnect::~BtHfNmaConnect ( )

Member Function Documentation

const BtHfNmaConnect & BtHfNmaConnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtDevice& BtHfNmaConnect::GetDevice ( ) const [inline]

const BtResultCode& BtHfNmaConnect::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaDisconnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaDisconnect Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaDisconnect:

[legend]
Collaboration diagram for BtHfNmaDisconnect:

[legend]

Public Types

enum | { ID = 11 }

Public Member Functions

BtHfNmaDisconnect ()
BtHfNmaDisconnect (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHfNmaDisconnect ()

Static Public Member Functions

static const BtHfNmaDisconnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaDisconnect

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaDisconnect::BtHfNmaDisconnect ( const BtResultCode & result )

BtHfNmaDisconnect::BtHfNmaDisconnect ( )

BtHfNmaDisconnect::~BtHfNmaDisconnect ( )

Member Function Documentation

const BtHfNmaDisconnect & BtHfNmaDisconnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHfNmaDisconnect::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaLowPowerModeNotPossible Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaLowPowerModeNotPossible Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaLowPowerModeNotPossible:

[legend]
Collaboration diagram for BtHfNmaLowPowerModeNotPossible:

[legend]

Public Types

enum | { ID = 17 }

Public Member Functions

BtHfNmaLowPowerModeNotPossible ()
BtHfNmaLowPowerModeNotPossible (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHfNmaLowPowerModeNotPossible ()

Static Public Member Functions

static const BtHfNmaLowPowerModeNotPossible & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaLowPowerModeNotPossible

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaLowPowerModeNotPossible::BtHfNmaLowPowerModeNotPossible ( const BtResultCode & result )

BtHfNmaLowPowerModeNotPossible::BtHfNmaLowPowerModeNotPossible ( )

BtHfNmaLowPowerModeNotPossible::~BtHfNmaLowPowerModeNotPossible ( )

Member Function Documentation

const BtHfNmaLowPowerModeNotPossible & BtHfNmaLowPowerModeNotPossible::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHfNmaLowPowerModeNotPossible::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaMicrophoneGain Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaMicrophoneGain Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaMicrophoneGain:

[legend]
Collaboration diagram for BtHfNmaMicrophoneGain:

[legend]

Public Types

enum | { ID = 15 }

Public Member Functions

BtHfNmaMicrophoneGain ()
BtHfNmaMicrophoneGain (const BtResultCode &result, UINT8 gain)
UINT8 | GetGain () const
const BtResultCode & | GetResult () const
~BtHfNmaMicrophoneGain ()

Static Public Member Functions

static const BtHfNmaMicrophoneGain & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaMicrophoneGain

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaMicrophoneGain::BtHfNmaMicrophoneGain | ( | const BtResultCode & | result,
 |  | UINT8 | gain
 | ) |

BtHfNmaMicrophoneGain::BtHfNmaMicrophoneGain ( )

BtHfNmaMicrophoneGain::~BtHfNmaMicrophoneGain ( )

Member Function Documentation

const BtHfNmaMicrophoneGain & BtHfNmaMicrophoneGain::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 BtHfNmaMicrophoneGain::GetGain ( ) const [inline]

const BtResultCode& BtHfNmaMicrophoneGain::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaSpeakerGain Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaSpeakerGain Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaSpeakerGain:

[legend]
Collaboration diagram for BtHfNmaSpeakerGain:

[legend]

Public Types

enum | { ID = 16 }

Public Member Functions

BtHfNmaSpeakerGain ()
BtHfNmaSpeakerGain (const BtResultCode &result, UINT8 gain)
UINT8 | GetGain () const
const BtResultCode & | GetResult () const
~BtHfNmaSpeakerGain ()

Static Public Member Functions

static const BtHfNmaSpeakerGain & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaSpeakerGain

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaSpeakerGain::BtHfNmaSpeakerGain | ( | const BtResultCode & | result,
 |  | UINT8 | gain
 | ) |

BtHfNmaSpeakerGain::BtHfNmaSpeakerGain ( )

BtHfNmaSpeakerGain::~BtHfNmaSpeakerGain ( )

Member Function Documentation

const BtHfNmaSpeakerGain & BtHfNmaSpeakerGain::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 BtHfNmaSpeakerGain::GetGain ( ) const [inline]

const BtResultCode& BtHfNmaSpeakerGain::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaTransferAudioToAccessory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaTransferAudioToAccessory Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaTransferAudioToAccessory:

[legend]
Collaboration diagram for BtHfNmaTransferAudioToAccessory:

[legend]

Public Types

enum | { ID = 12 }

Public Member Functions

BtHfNmaTransferAudioToAccessory ()
BtHfNmaTransferAudioToAccessory (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHfNmaTransferAudioToAccessory ()

Static Public Member Functions

static const BtHfNmaTransferAudioToAccessory & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaTransferAudioToAccessory

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaTransferAudioToAccessory::BtHfNmaTransferAudioToAccessory ( const BtResultCode & result )

BtHfNmaTransferAudioToAccessory::BtHfNmaTransferAudioToAccessory ( )

BtHfNmaTransferAudioToAccessory::~BtHfNmaTransferAudioToAccessory ( )

Member Function Documentation

const BtHfNmaTransferAudioToAccessory & BtHfNmaTransferAudioToAccessory::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHfNmaTransferAudioToAccessory::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNmaTransferAudioToPhone Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNmaTransferAudioToPhone Class Reference

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessageArgument.hpp>

Inheritance diagram for BtHfNmaTransferAudioToPhone:

[legend]
Collaboration diagram for BtHfNmaTransferAudioToPhone:

[legend]

Public Types

enum | { ID = 13 }

Public Member Functions

BtHfNmaTransferAudioToPhone ()
BtHfNmaTransferAudioToPhone (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHfNmaTransferAudioToPhone ()

Static Public Member Functions

static const BtHfNmaTransferAudioToPhone & | Cast (const StackMsgArgument &arg)

Friends

class | BtHfMessageArgumentsDestroyTableNode

Detailed Description

BtHfNmaTransferAudioToPhone

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfNmaTransferAudioToPhone::BtHfNmaTransferAudioToPhone ( const BtResultCode & result )

BtHfNmaTransferAudioToPhone::BtHfNmaTransferAudioToPhone ( )

BtHfNmaTransferAudioToPhone::~BtHfNmaTransferAudioToPhone ( )

Member Function Documentation

const BtHfNmaTransferAudioToPhone & BtHfNmaTransferAudioToPhone::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHfNmaTransferAudioToPhone::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHfMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessageArgument.hpp
  • Bluetooth/HF/BtHfNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfNotificationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfNotificationMessage Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/HF/BtHfNotificationMessage.hpp>

Inheritance diagram for BtHfNotificationMessage:

[legend]
Collaboration diagram for BtHfNotificationMessage:

[legend]

Public Types

enum | { ID = 10105 }

Public Member Functions

BtHfNotificationMessage (const BtHfNotificationMessage &message)
Constructor.
BtHfNotificationMessage (StackMsgArgument *argument=0)
Constructor.
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual BtHfNotificationMessage & | operator= (const BtHfNotificationMessage &message)
virtual FromStackMsg & | operator= (const FromStackMsg &message)
virtual | ~BtHfNotificationMessage ()
Destructor.
The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfNotificationMessage.hpp
  • Bluetooth/HF/BtHfNotificationMessage.cpp
Generated on Wed Jan 25 01:00:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfProfileService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfProfileService Class Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfProfileService.hpp>

Inheritance diagram for BtHfProfileService:

[legend]
Collaboration diagram for BtHfProfileService:

[legend]

Public Member Functions

BtHfProfileService (BtHfProfileWindow &hf_profile_window)
virtual | ~BtHfProfileService ()

Protected Member Functions

virtual void | OnPhoneNumberRequired (BtResultCode result)
virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
Notification function of changes in running requests.

Constructor & Destructor Documentation

BtHfProfileService::BtHfProfileService ( BtHfProfileWindow & hf_profile_window )

BtHfProfileService::~BtHfProfileService ( ) [virtual]

Member Function Documentation

void BtHfProfileService::OnPhoneNumberRequired ( BtResultCode result ) [protected, virtual]

Implements BtHfService.

void BtHfProfileService::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Notification function of changes in running requests.

Whenever the state of a request contained in this service is changed OnRequestStateChange will be called. This function should give the application programmer to do some GUI reaction to the progress or the failure of a partikular request.
This function has to be implemented by the application programmer, so in the base classes this function is pure virtual.

Parameters:
request_type | A BtRequestType enumeration type describing which kind of request has changed its state.
old_request_state | A BtRequestState enumeration type containing the state of the request before the state transition.
new_request_state | A BtRequestState enumeration type containing the state of the request after the state transition.

Implements BtService.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfProfileService.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfProfileService.cpp
Generated on Wed Jan 25 01:00:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfProfileWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfProfileWindow Class Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp>

Collaboration diagram for BtHfProfileWindow:

[legend]

Public Member Functions

BtHfProfileWindow (BtHfProfileService &service)
const BtDevice & | GetTargetDevice () const
void | Init ()
void | OnRemoteConnect (BOOLEAN result)
void | OnRemoteDisconnect (BOOLEAN result)
void | OnTransferCallToHandsfree ()
void | OnTransferCallToPhone ()
void | OnUserConnect ()
void | OnUserDisconnect ()
void | SetTargetDevice (const BtDevice &target_device)
virtual | ~BtHfProfileWindow ()

Protected Member Functions

void | OnDeviceListWindowClose (void)
void | OnHfSettingsWindowClosed (void)
void | OnPhoneNumberRequired (BtResultCode result)
void | OnTransferCallToHandsfreeFinished (BOOLEAN success)
void | OnTransferCallToPhoneFinished (BOOLEAN success)
void | OnUserConnectFinished (BOOLEAN success)
void | OnUserDisconnectFinished (BOOLEAN success)

Friends

class | BtHfProfileService

Constructor & Destructor Documentation

BtHfProfileWindow::BtHfProfileWindow ( BtHfProfileService & service )

BtHfProfileWindow::~BtHfProfileWindow ( ) [virtual]

Member Function Documentation

const BtDevice & BtHfProfileWindow::GetTargetDevice ( ) const

void BtHfProfileWindow::Init ( )

void BtHfProfileWindow::OnDeviceListWindowClose ( void ) [protected]

void BtHfProfileWindow::OnHfSettingsWindowClosed ( void ) [protected]

void BtHfProfileWindow::OnPhoneNumberRequired ( BtResultCode result ) [protected]

void BtHfProfileWindow::OnRemoteConnect ( BOOLEAN result )

void BtHfProfileWindow::OnRemoteDisconnect ( BOOLEAN result )

void BtHfProfileWindow::OnTransferCallToHandsfree ( )

void BtHfProfileWindow::OnTransferCallToHandsfreeFinished ( BOOLEAN success ) [protected]

void BtHfProfileWindow::OnTransferCallToPhone ( )

void BtHfProfileWindow::OnTransferCallToPhoneFinished ( BOOLEAN success ) [protected]

void BtHfProfileWindow::OnUserConnect ( )

void BtHfProfileWindow::OnUserConnectFinished ( BOOLEAN success ) [protected]

void BtHfProfileWindow::OnUserDisconnect ( )

void BtHfProfileWindow::OnUserDisconnectFinished ( BOOLEAN success ) [protected]

void BtHfProfileWindow::SetTargetDevice ( const BtDevice & target_device )

Friends And Related Function Documentation

friend class BtHfProfileService [friend]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfProfileWindows.cpp
Generated on Wed Jan 25 01:00:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfProvider Class Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfProvider.hpp>

Inheritance diagram for BtHfProvider:

[legend]
Collaboration diagram for BtHfProvider:

[legend]

Public Member Functions

BtHfProvider ()
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init ()
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
virtual void | RestoreFactorySettings ()
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT column_id)
virtual | ~BtHfProvider ()

Constructor & Destructor Documentation

BtHfProvider::BtHfProvider ( )

BtHfProvider::~BtHfProvider ( ) [virtual]

Member Function Documentation

BOOLEAN BtHfProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN BtHfProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT BtHfProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void BtHfProvider::Init ( )

INT BtHfProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

void BtHfProvider::RestoreFactorySettings ( ) [virtual]

Implements SettingsProvider.

BOOLEAN BtHfProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN BtHfProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | column_id
 | ) | [virtual]

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfProvider.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfProvider.cpp
Generated on Wed Jan 25 01:00:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfRecord Class Reference
[CallSettings]

#include <Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp>

Inheritance diagram for BtHfRecord:

[legend]
Collaboration diagram for BtHfRecord:

[legend]

Public Member Functions

BtHfRecord (BOOLEAN phone_audio_path=FALSE)
virtual const UINT8 * | GetData ()
virtual INT | GetPersistentSize ()
virtual void | SetData (const UINT8 *data)
~BtHfRecord ()

Data Fields

BtHfRecord::Persist m_data

Data Structures

struct | Persist

Constructor & Destructor Documentation

BtHfRecord::BtHfRecord ( BOOLEAN phone_audio_path = FALSE )

BtHfRecord::~BtHfRecord ( ) [inline]

Member Function Documentation

const UINT8 * BtHfRecord::GetData ( ) [virtual]

Implements Record.

INT BtHfRecord::GetPersistentSize ( ) [virtual]

Implements Record.

void BtHfRecord::SetData ( const UINT8 * data ) [virtual]

Implements Record.

Field Documentation

struct BtHfRecord::Persist BtHfRecord::m_data

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfRecord.cpp
Generated on Wed Jan 25 01:00:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfRecord::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtHfRecord::Persist

BtHfRecord::Persist Struct Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp>

Data Fields

BOOLEAN audio_at_phone

Field Documentation

BOOLEAN BtHfRecord::Persist::audio_at_phone

The documentation for this struct was generated from the following file:
  • Applications/BtApp/BtHfAppPlugin/BtHfRecord.hpp
Generated on Wed Jan 25 01:00:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/HF/BtHfServiceMessage.hpp>

Inheritance diagram for BtHfRequestStateChangedMessage:

[legend]
Collaboration diagram for BtHfRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10330 }

Public Member Functions

BtHfRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtHfRequestStateChangedMessage ()

Detailed Description

BtHfRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtHfRequestStateChangedMessage::BtHfRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtHfRequestStateChangedMessage::~BtHfRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtHfRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtHfRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfServiceMessage.hpp
  • Bluetooth/HF/BtHfServiceMessage.cpp
Generated on Wed Jan 25 01:00:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/HF/BtHfService.hpp>

Inheritance diagram for BtHfService:

[legend]
Collaboration diagram for BtHfService:

[legend]

Public Member Functions

BtHfService ()
Constructor.
virtual BtRequestState | ConnectRequest ()
Establish connection for the device set for this service.
virtual BtRequestState | DisconnectRequest ()
Release connection for the device set for this service.
virtual UINT8 | GetMicrophoneGain () const
virtual BtProfile | GetProfile () const
Get the profile this service is associated with.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
virtual UINT8 | GetSpeakerGain () const
BtHfState | GetState () const
UINT16 | GetSupportedFeatures () const
virtual void | Init ()
Initalize the hands free service.
virtual BOOLEAN | IsConnected () const
Returns the connected state of device set for this service.
virtual BOOLEAN | IsInCall () const
virtual BOOLEAN | IsRinging () const
virtual BtRequestState | SetMicrophoneGainRequest (INT8 gain_offset)
virtual BtRequestState | SetSpeakerGainRequest (INT8 gain_offset)
virtual void | SetTargetDevice (const BtDevice &target_device)
Sets the remote device this service addresses.
virtual void | SetUseInbandRinging (BOOLEAN use_inband_ringing)
virtual BtRequestState | TransferAudioToAccessoryRequest ()
virtual BtRequestState | TransferAudioToPhoneRequest ()
virtual | ~BtHfService ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnCallEventMessage (const CallEventMsg &call_event_message)
BOOLEAN | OnControllerMessage (const BtHfControllerMessage &controller_message)
virtual BOOLEAN | OnMessage (const Message &message)
virtual void | RegisterMessages () const
virtual void | UnregisterMessages () const

Data Structures

class | BtHfAtChldOneCommand

Detailed Description

BtHfService is implemented as a singleton. Offers the functionality for dial up networks and so extends the basic functionality, it depends on BtHfController who forms the low level interface to the Bluetooth Stack.

Constructor & Destructor Documentation

BtHfService::BtHfService ( )

Constructor.

BtHfService::~BtHfService ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtHfService::ConnectRequest ( ) [virtual]

Establish connection for the device set for this service.

ConnectRequest sends a device connect request down to the BtHfController for execution. On successfull execution of this request an ACL connection for the device set for this serivce will be established. The progress of the ongoing request is signalled to the OnRequestStateChange member function.

Returns:
A BtRequestState containing the current state of the requested operation.

Implements BtAudioAccessoryService.

BtRequestState BtHfService::DisconnectRequest ( ) [virtual]

Release connection for the device set for this service.

ConnectRequest sends a device disconnect request down to the BtHfController for execution. On successfull execution of this request the ACL connection for the device set for this serivce will be released. The progress of the ongoing request is signalled to the OnRequestStateChange member function.

Returns:
A BtRequestState containing the current state of the requested operation.

Implements BtAudioAccessoryService.

UINT8 BtHfService::GetMicrophoneGain ( ) const [virtual]

Implements BtAudioAccessoryService.

BtProfile BtHfService::GetProfile ( ) const [virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implements BtService.

BtRequestState BtHfService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

UINT8 BtHfService::GetSpeakerGain ( ) const [virtual]

Implements BtAudioAccessoryService.

BtHfState BtHfService::GetState ( ) const

UINT16 BtHfService::GetSupportedFeatures ( ) const

void BtHfService::Init ( ) [virtual]

Initalize the hands free service.

Init has to be called to make the service running. It adds itself as a dispatcher to the active application and registers the the necessary messages.

BOOLEAN BtHfService::IsConnected ( ) const [virtual]

Returns the connected state of device set for this service.

IsConnected returns whether the device set for this service has an ACL connection established or not.

Returns:
TRUE | ACL connection established.
FALSE | ACL connection not established.

Implements BtAudioAccessoryService.

BOOLEAN BtHfService::IsInCall ( ) const [virtual]

Implements BtAudioAccessoryService.

BOOLEAN BtHfService::IsRinging ( ) const [virtual]

Implements BtAudioAccessoryService.

BOOLEAN BtHfService::OnCallEventMessage ( const CallEventMsg & call_event_message ) [protected, virtual]

BOOLEAN BtHfService::OnControllerMessage ( const BtHfControllerMessage & controller_message ) [protected]

BOOLEAN BtHfService::OnMessage ( const Message & message ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void BtHfService::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

BtRequestState BtHfService::SetMicrophoneGainRequest ( INT8 gain_offset ) [virtual]

Implements BtAudioAccessoryService.

BtRequestState BtHfService::SetSpeakerGainRequest ( INT8 gain_offset ) [virtual]

Implements BtAudioAccessoryService.

void BtHfService::SetTargetDevice ( const BtDevice & target_device ) [virtual]

Sets the remote device this service addresses.

Each BtService class addresses exactly one remote device. For profiles supporting more than one remote device there must be more than one instance of that prarticular service.
SetTargetDevice sets the remote device, that this service addresses.

Parameters:
target_device A reference to a BtDevice containing the remote device this service should address.

Reimplemented from BtService.

void BtHfService::SetUseInbandRinging ( BOOLEAN use_inband_ringing ) [virtual]

Reimplemented from BtAudioAccessoryService.

BtRequestState BtHfService::TransferAudioToAccessoryRequest ( ) [virtual]

Implements BtAudioAccessoryService.

BtRequestState BtHfService::TransferAudioToPhoneRequest ( ) [virtual]

Implements BtAudioAccessoryService.

void BtHfService::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/HF/BtHfService.hpp
  • Bluetooth/HF/BtHfService.cpp
Generated on Wed Jan 25 01:00:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfSupportedProfileMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfSupportedProfileMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtHfSupportedProfileMessage:

[legend]
Collaboration diagram for BtHfSupportedProfileMessage:

[legend]

Public Types

enum | { ID = 10231 }

Public Member Functions

BtHfSupportedProfileMessage (const BtResultCode &result, UINT32 request_id, const WString &hf_profile_name, UINT16 hf_supported_features)
virtual Message * | Clone () const
const WString & | GetHfProfileName () const
UINT16 | GetHfSupportedFeatures () const
virtual const MsgMetaData & | GetMetaData () const
void | SetHfProfileName (const WString &hf_profile_name)
void | SetHfSupportedFeatures (UINT16 hf_supported_features)
virtual | ~BtHfSupportedProfileMessage ()

Detailed Description

BtHfSupportedProfileMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHfSupportedProfileMessage::BtHfSupportedProfileMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const WString & | hf_profile_name,
 |  | UINT16 | hf_supported_features
 | ) |

BtHfSupportedProfileMessage::~BtHfSupportedProfileMessage ( ) [virtual]

Member Function Documentation

Message * BtHfSupportedProfileMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const WString& BtHfSupportedProfileMessage::GetHfProfileName ( ) const [inline]

UINT16 BtHfSupportedProfileMessage::GetHfSupportedFeatures ( ) const [inline]

const MsgMetaData & BtHfSupportedProfileMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

void BtHfSupportedProfileMessage::SetHfProfileName ( const WString & hf_profile_name ) [inline]

void BtHfSupportedProfileMessage::SetHfSupportedFeatures ( UINT16 hf_supported_features ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:00:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfVolumeSettingsWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHfVolumeSettingsWin Class Reference

#include <Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.hpp>

Collaboration diagram for BtHfVolumeSettingsWin:

[legend]

Public Types

enum | AudioGain { MicGain = 0, SpeakerGain }

Public Member Functions

BtHfVolumeSettingsWin (BtHfProfileService &service)
void | Init ()
virtual | ~BtHfVolumeSettingsWin ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()

Member Enumeration Documentation

enum BtHfVolumeSettingsWin::AudioGain

Enumerator:
MicGain
SpeakerGain

Constructor & Destructor Documentation

BtHfVolumeSettingsWin::BtHfVolumeSettingsWin ( BtHfProfileService & service )

BtHfVolumeSettingsWin::~BtHfVolumeSettingsWin ( ) [virtual]

Member Function Documentation

void BtHfVolumeSettingsWin::Init ( )

BOOLEAN BtHfVolumeSettingsWin::OnCancel ( ) [protected, virtual]

BOOLEAN BtHfVolumeSettingsWin::OnConfirm ( ) [protected, virtual]

void BtHfVolumeSettingsWin::OnLayoutClient ( ) [protected, virtual]

BOOLEAN BtHfVolumeSettingsWin::OnMessage ( const Message & msg ) [protected, virtual]

void BtHfVolumeSettingsWin::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.hpp
  • Applications/BtApp/BtHfAppPlugin/BtHfVolumeSettingsWin.cpp
Generated on Wed Jan 25 01:00:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsAppPlugin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsAppPlugin Class Reference
[Bluetooth]

#include <Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.hpp>

Collaboration diagram for BtHsAppPlugin:

[legend]

Public Member Functions

void | Init (Application *app)
void | OnHsCallTransferToHeadsetRequestFinished (BOOLEAN success)
void | OnHsCallTransferToPhoneRequestFinished (BOOLEAN success)
void | OnHsConnectRequestFinished (BOOLEAN success)
void | OnHsDisconnectRequestFinished (BOOLEAN success)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual | ~BtHsAppPlugin ()

Static Public Member Functions

static BtHsAppPlugin * | GetInstance ()

Protected Member Functions

virtual void | OnAppClose ()
virtual void | OnAppOpen ()
virtual BOOLEAN | OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &context_item)
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)

Constructor & Destructor Documentation

BtHsAppPlugin::~BtHsAppPlugin ( ) [virtual]

Member Function Documentation

BtHsAppPlugin * BtHsAppPlugin::GetInstance ( ) [static]

void BtHsAppPlugin::Init ( Application * app )

void BtHsAppPlugin::OnAppClose ( ) [protected, virtual]

See also:
ApplicationPlugin::OnAppClose()

void BtHsAppPlugin::OnAppOpen ( ) [protected, virtual]

See also:
ApplicationPlugin::OnAppOpen()

BOOLEAN BtHsAppPlugin::OnContextFeatureTriggered | ( | const FeatureID & | feature_id,
 |  | const DataItem & | context_item
 | ) | [protected, virtual]

BOOLEAN BtHsAppPlugin::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

void BtHsAppPlugin::OnHsCallTransferToHeadsetRequestFinished ( BOOLEAN success )

void BtHsAppPlugin::OnHsCallTransferToPhoneRequestFinished ( BOOLEAN success )

void BtHsAppPlugin::OnHsConnectRequestFinished ( BOOLEAN success )

void BtHsAppPlugin::OnHsDisconnectRequestFinished ( BOOLEAN success )

These four functions will be called by BtHsProfileService as the mobile initiated requests finished

BOOLEAN BtHsAppPlugin::OnMessage ( const Message & msg ) [virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.hpp
  • Applications/BtApp/BtHsAppPlugin/BtHsAppPlugin.cpp
Generated on Wed Jan 25 01:00:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsCmaAudioAsynchronous Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsCmaAudioAsynchronous Class Reference

#include <Apoxi/Bluetooth/HS/BtHsControllerMessageArgument.hpp>

Inheritance diagram for BtHsCmaAudioAsynchronous:

[legend]
Collaboration diagram for BtHsCmaAudioAsynchronous:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

BtHsCmaAudioAsynchronous ()
BtHsCmaAudioAsynchronous (BOOLEAN sco_path_status, BOOLEAN audio_connected, BOOLEAN audio_switch_path)
BOOLEAN | IsAudioConnected () const
BOOLEAN | IsAudioSwitchPath () const
BOOLEAN | IsScoPathStatus () const
void | SetAudioConnected (BOOLEAN audio_connected)
void | SetAudioSwitchPath (BOOLEAN audio_switch_path)
void | SetScoPathStatus (BOOLEAN sco_path_status)
~BtHsCmaAudioAsynchronous ()

Static Public Member Functions

static const BtHsCmaAudioAsynchronous & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsCmaAudioAsynchronous

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsCmaAudioAsynchronous::BtHsCmaAudioAsynchronous | ( | BOOLEAN | sco_path_status,
 |  | BOOLEAN | audio_connected,
 |  | BOOLEAN | audio_switch_path
 | ) |

BtHsCmaAudioAsynchronous::BtHsCmaAudioAsynchronous ( )

BtHsCmaAudioAsynchronous::~BtHsCmaAudioAsynchronous ( )

Member Function Documentation

const BtHsCmaAudioAsynchronous & BtHsCmaAudioAsynchronous::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN BtHsCmaAudioAsynchronous::IsAudioConnected ( ) const [inline]

BOOLEAN BtHsCmaAudioAsynchronous::IsAudioSwitchPath ( ) const [inline]

BOOLEAN BtHsCmaAudioAsynchronous::IsScoPathStatus ( ) const [inline]

void BtHsCmaAudioAsynchronous::SetAudioConnected ( BOOLEAN audio_connected ) [inline]

void BtHsCmaAudioAsynchronous::SetAudioSwitchPath ( BOOLEAN audio_switch_path ) [inline]

void BtHsCmaAudioAsynchronous::SetScoPathStatus ( BOOLEAN sco_path_status ) [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsControllerMessageArgument.hpp
  • Bluetooth/HS/BtHsControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsCmaAudioTransferOutOfCall Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsCmaAudioTransferOutOfCall Class Reference

#include <Apoxi/Bluetooth/HS/BtHsControllerMessageArgument.hpp>

Inheritance diagram for BtHsCmaAudioTransferOutOfCall:

[legend]
Collaboration diagram for BtHsCmaAudioTransferOutOfCall:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

BtHsCmaAudioTransferOutOfCall ()
~BtHsCmaAudioTransferOutOfCall ()

Static Public Member Functions

static const BtHsCmaAudioTransferOutOfCall & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsCmaAudioTransferOutOfCall

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsCmaAudioTransferOutOfCall::BtHsCmaAudioTransferOutOfCall ( )

BtHsCmaAudioTransferOutOfCall::~BtHsCmaAudioTransferOutOfCall ( )

Member Function Documentation

const BtHsCmaAudioTransferOutOfCall & BtHsCmaAudioTransferOutOfCall::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsControllerMessageArgument.hpp
  • Bluetooth/HS/BtHsControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsCmaCheckPendingAudioCallback Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsCmaCheckPendingAudioCallback Class Reference

#include <Apoxi/Bluetooth/HS/BtHsControllerMessageArgument.hpp>

Inheritance diagram for BtHsCmaCheckPendingAudioCallback:

[legend]
Collaboration diagram for BtHsCmaCheckPendingAudioCallback:

[legend]

Public Types

enum | { ID = 5 }

Public Member Functions

BtHsCmaCheckPendingAudioCallback ()
~BtHsCmaCheckPendingAudioCallback ()

Static Public Member Functions

static const BtHsCmaCheckPendingAudioCallback & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsCmaCheckPendingAudioCallback

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsCmaCheckPendingAudioCallback::BtHsCmaCheckPendingAudioCallback ( )

BtHsCmaCheckPendingAudioCallback::~BtHsCmaCheckPendingAudioCallback ( )

Member Function Documentation

const BtHsCmaCheckPendingAudioCallback & BtHsCmaCheckPendingAudioCallback::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsControllerMessageArgument.hpp
  • Bluetooth/HS/BtHsControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsCmaEnterLowPowerMode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsCmaEnterLowPowerMode Class Reference

#include <Apoxi/Bluetooth/HS/BtHsControllerMessageArgument.hpp>

Inheritance diagram for BtHsCmaEnterLowPowerMode:

[legend]
Collaboration diagram for BtHsCmaEnterLowPowerMode:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

BtHsCmaEnterLowPowerMode ()
~BtHsCmaEnterLowPowerMode ()

Static Public Member Functions

static const BtHsCmaEnterLowPowerMode & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsCmaEnterLowPowerMode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsCmaEnterLowPowerMode::BtHsCmaEnterLowPowerMode ( )

BtHsCmaEnterLowPowerMode::~BtHsCmaEnterLowPowerMode ( )

Member Function Documentation

const BtHsCmaEnterLowPowerMode & BtHsCmaEnterLowPowerMode::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsControllerMessageArgument.hpp
  • Bluetooth/HS/BtHsControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsCmaHangUp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsCmaHangUp Class Reference

#include <Apoxi/Bluetooth/HS/BtHsControllerMessageArgument.hpp>

Inheritance diagram for BtHsCmaHangUp:

[legend]
Collaboration diagram for BtHsCmaHangUp:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

BtHsCmaHangUp ()
~BtHsCmaHangUp ()

Static Public Member Functions

static const BtHsCmaHangUp & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsCmaHangUp

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsCmaHangUp::BtHsCmaHangUp ( )

BtHsCmaHangUp::~BtHsCmaHangUp ( )

Member Function Documentation

const BtHsCmaHangUp & BtHsCmaHangUp::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsControllerMessageArgument.hpp
  • Bluetooth/HS/BtHsControllerMessageArgument.cpp
Generated on Wed Jan 25 01:00:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsConnectionSettingWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsConnectionSettingWin Class Reference

#include <Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.hpp>

Collaboration diagram for BtHsConnectionSettingWin:

[legend]

Public Member Functions

BtHsConnectionSettingWin (BtHsProfileService &service)
void | Init ()
virtual | ~BtHsConnectionSettingWin ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

BtHsConnectionSettingWin::BtHsConnectionSettingWin ( BtHsProfileService & service )

BtHsConnectionSettingWin::~BtHsConnectionSettingWin ( ) [virtual]

Member Function Documentation

void BtHsConnectionSettingWin::Init ( )

BOOLEAN BtHsConnectionSettingWin::OnConfirm ( ) [protected, virtual]

void BtHsConnectionSettingWin::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.hpp
  • Applications/BtApp/BtHsAppPlugin/BtHsConnectionSettingWin.cpp
Generated on Wed Jan 25 01:00:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsInbandSettingWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsInbandSettingWin Class Reference

#include <Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.hpp>

Collaboration diagram for BtHsInbandSettingWin:

[legend]

Public Member Functions

BtHsInbandSettingWin (BtHsProfileService &service)
void | Init ()
virtual | ~BtHsInbandSettingWin ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

BtHsInbandSettingWin::BtHsInbandSettingWin ( BtHsProfileService & service )

BtHsInbandSettingWin::~BtHsInbandSettingWin ( ) [virtual]

Member Function Documentation

void BtHsInbandSettingWin::Init ( )

BOOLEAN BtHsInbandSettingWin::OnConfirm ( ) [protected, virtual]

void BtHsInbandSettingWin::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.hpp
  • Applications/BtApp/BtHsAppPlugin/BtHsInbandSettingWin.cpp
Generated on Wed Jan 25 01:00:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsMessageArgumentsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsMessageArgumentsDestroyTableNode Class Reference

#include <Apoxi/Bluetooth/HS/BtHsMessageArguments.hpp>

Inheritance diagram for BtHsMessageArgumentsDestroyTableNode:

[legend]
Collaboration diagram for BtHsMessageArgumentsDestroyTableNode:

[legend]

Static Public Member Functions

static BtHsMessageArgumentsDestroyTableNode * GetInstance ()

Member Function Documentation

BtHsMessageArgumentsDestroyTableNode * BtHsMessageArgumentsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsMessageArguments.hpp
  • Bluetooth/HS/BtHsMessageArguments.cpp
Generated on Wed Jan 25 01:00:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaAudioConnectionLost Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaAudioConnectionLost Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaAudioConnectionLost:

[legend]
Collaboration diagram for BtHsNmaAudioConnectionLost:

[legend]

Public Types

enum | { ID = 14 }

Public Member Functions

BtHsNmaAudioConnectionLost ()
BtHsNmaAudioConnectionLost (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHsNmaAudioConnectionLost ()

Static Public Member Functions

static const BtHsNmaAudioConnectionLost & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaAudioConnectionLost

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaAudioConnectionLost::BtHsNmaAudioConnectionLost ( const BtResultCode & result )

BtHsNmaAudioConnectionLost::BtHsNmaAudioConnectionLost ( )

BtHsNmaAudioConnectionLost::~BtHsNmaAudioConnectionLost ( )

Member Function Documentation

const BtHsNmaAudioConnectionLost & BtHsNmaAudioConnectionLost::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHsNmaAudioConnectionLost::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaCallEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaCallEvent Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaCallEvent:

[legend]
Collaboration diagram for BtHsNmaCallEvent:

[legend]

Public Types

enum | { ID = 18 }

Public Member Functions

BtHsNmaCallEvent ()
BtHsNmaCallEvent (const BtHsCallEvent &call_event)
const BtHsCallEvent & | GetCallEvent () const
~BtHsNmaCallEvent ()

Static Public Member Functions

static const BtHsNmaCallEvent & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaCallEvent

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaCallEvent::BtHsNmaCallEvent ( const BtHsCallEvent & call_event )

BtHsNmaCallEvent::BtHsNmaCallEvent ( )

BtHsNmaCallEvent::~BtHsNmaCallEvent ( )

Member Function Documentation

const BtHsNmaCallEvent & BtHsNmaCallEvent::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtHsCallEvent& BtHsNmaCallEvent::GetCallEvent ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaConnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaConnect Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaConnect:

[legend]
Collaboration diagram for BtHsNmaConnect:

[legend]

Public Types

enum | { ID = 10 }

Public Member Functions

BtHsNmaConnect ()
BtHsNmaConnect (const BtResultCode &result, const BtDevice &device)
const BtDevice & | GetDevice () const
const BtResultCode & | GetResult () const
~BtHsNmaConnect ()

Static Public Member Functions

static const BtHsNmaConnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaConnect

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaConnect::BtHsNmaConnect | ( | const BtResultCode & | result,
 |  | const BtDevice & | device
 | ) |

BtHsNmaConnect::BtHsNmaConnect ( )

BtHsNmaConnect::~BtHsNmaConnect ( )

Member Function Documentation

const BtHsNmaConnect & BtHsNmaConnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtDevice& BtHsNmaConnect::GetDevice ( ) const [inline]

const BtResultCode& BtHsNmaConnect::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaDisconnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaDisconnect Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaDisconnect:

[legend]
Collaboration diagram for BtHsNmaDisconnect:

[legend]

Public Types

enum | { ID = 11 }

Public Member Functions

BtHsNmaDisconnect ()
BtHsNmaDisconnect (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHsNmaDisconnect ()

Static Public Member Functions

static const BtHsNmaDisconnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaDisconnect

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaDisconnect::BtHsNmaDisconnect ( const BtResultCode & result )

BtHsNmaDisconnect::BtHsNmaDisconnect ( )

BtHsNmaDisconnect::~BtHsNmaDisconnect ( )

Member Function Documentation

const BtHsNmaDisconnect & BtHsNmaDisconnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHsNmaDisconnect::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaLowPowerModeNotPossible Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaLowPowerModeNotPossible Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaLowPowerModeNotPossible:

[legend]
Collaboration diagram for BtHsNmaLowPowerModeNotPossible:

[legend]

Public Types

enum | { ID = 17 }

Public Member Functions

BtHsNmaLowPowerModeNotPossible ()
BtHsNmaLowPowerModeNotPossible (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHsNmaLowPowerModeNotPossible ()

Static Public Member Functions

static const BtHsNmaLowPowerModeNotPossible & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaLowPowerModeNotPossible

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaLowPowerModeNotPossible::BtHsNmaLowPowerModeNotPossible ( const BtResultCode & result )

BtHsNmaLowPowerModeNotPossible::BtHsNmaLowPowerModeNotPossible ( )

BtHsNmaLowPowerModeNotPossible::~BtHsNmaLowPowerModeNotPossible ( )

Member Function Documentation

const BtHsNmaLowPowerModeNotPossible & BtHsNmaLowPowerModeNotPossible::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHsNmaLowPowerModeNotPossible::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaMicrophoneGain Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaMicrophoneGain Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaMicrophoneGain:

[legend]
Collaboration diagram for BtHsNmaMicrophoneGain:

[legend]

Public Types

enum | { ID = 15 }

Public Member Functions

BtHsNmaMicrophoneGain ()
BtHsNmaMicrophoneGain (const BtResultCode &result, UINT8 gain)
UINT8 | GetGain () const
const BtResultCode & | GetResult () const
~BtHsNmaMicrophoneGain ()

Static Public Member Functions

static const BtHsNmaMicrophoneGain & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaMicrophoneGain

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaMicrophoneGain::BtHsNmaMicrophoneGain | ( | const BtResultCode & | result,
 |  | UINT8 | gain
 | ) |

BtHsNmaMicrophoneGain::BtHsNmaMicrophoneGain ( )

BtHsNmaMicrophoneGain::~BtHsNmaMicrophoneGain ( )

Member Function Documentation

const BtHsNmaMicrophoneGain & BtHsNmaMicrophoneGain::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 BtHsNmaMicrophoneGain::GetGain ( ) const [inline]

const BtResultCode& BtHsNmaMicrophoneGain::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaSpeakerGain Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaSpeakerGain Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaSpeakerGain:

[legend]
Collaboration diagram for BtHsNmaSpeakerGain:

[legend]

Public Types

enum | { ID = 16 }

Public Member Functions

BtHsNmaSpeakerGain ()
BtHsNmaSpeakerGain (const BtResultCode &result, UINT8 gain)
UINT8 | GetGain () const
const BtResultCode & | GetResult () const
~BtHsNmaSpeakerGain ()

Static Public Member Functions

static const BtHsNmaSpeakerGain & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaSpeakerGain

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaSpeakerGain::BtHsNmaSpeakerGain | ( | const BtResultCode & | result,
 |  | UINT8 | gain
 | ) |

BtHsNmaSpeakerGain::BtHsNmaSpeakerGain ( )

BtHsNmaSpeakerGain::~BtHsNmaSpeakerGain ( )

Member Function Documentation

const BtHsNmaSpeakerGain & BtHsNmaSpeakerGain::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 BtHsNmaSpeakerGain::GetGain ( ) const [inline]

const BtResultCode& BtHsNmaSpeakerGain::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaTransferAudioToAccessory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaTransferAudioToAccessory Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaTransferAudioToAccessory:

[legend]
Collaboration diagram for BtHsNmaTransferAudioToAccessory:

[legend]

Public Types

enum | { ID = 12 }

Public Member Functions

BtHsNmaTransferAudioToAccessory ()
BtHsNmaTransferAudioToAccessory (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHsNmaTransferAudioToAccessory ()

Static Public Member Functions

static const BtHsNmaTransferAudioToAccessory & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaTransferAudioToAccessory

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaTransferAudioToAccessory::BtHsNmaTransferAudioToAccessory ( const BtResultCode & result )

BtHsNmaTransferAudioToAccessory::BtHsNmaTransferAudioToAccessory ( )

BtHsNmaTransferAudioToAccessory::~BtHsNmaTransferAudioToAccessory ( )

Member Function Documentation

const BtHsNmaTransferAudioToAccessory & BtHsNmaTransferAudioToAccessory::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHsNmaTransferAudioToAccessory::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNmaTransferAudioToPhone Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNmaTransferAudioToPhone Class Reference

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessageArgument.hpp>

Inheritance diagram for BtHsNmaTransferAudioToPhone:

[legend]
Collaboration diagram for BtHsNmaTransferAudioToPhone:

[legend]

Public Types

enum | { ID = 13 }

Public Member Functions

BtHsNmaTransferAudioToPhone ()
BtHsNmaTransferAudioToPhone (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtHsNmaTransferAudioToPhone ()

Static Public Member Functions

static const BtHsNmaTransferAudioToPhone & | Cast (const StackMsgArgument &arg)

Friends

class | BtHsMessageArgumentsDestroyTableNode

Detailed Description

BtHsNmaTransferAudioToPhone

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsNmaTransferAudioToPhone::BtHsNmaTransferAudioToPhone ( const BtResultCode & result )

BtHsNmaTransferAudioToPhone::BtHsNmaTransferAudioToPhone ( )

BtHsNmaTransferAudioToPhone::~BtHsNmaTransferAudioToPhone ( )

Member Function Documentation

const BtHsNmaTransferAudioToPhone & BtHsNmaTransferAudioToPhone::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtHsNmaTransferAudioToPhone::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtHsMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessageArgument.hpp
  • Bluetooth/HS/BtHsNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:00:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsNotificationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsNotificationMessage Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/HS/BtHsNotificationMessage.hpp>

Inheritance diagram for BtHsNotificationMessage:

[legend]
Collaboration diagram for BtHsNotificationMessage:

[legend]

Public Types

enum | { ID = 10104 }

Public Member Functions

BtHsNotificationMessage (const BtHsNotificationMessage &message)
Constructor.
BtHsNotificationMessage (StackMsgArgument *argument=0)
Constructor.
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual BtHsNotificationMessage & | operator= (const BtHsNotificationMessage &message)
virtual FromStackMsg & | operator= (const FromStackMsg &message)
virtual | ~BtHsNotificationMessage ()
Destructor.
The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsNotificationMessage.hpp
  • Bluetooth/HS/BtHsNotificationMessage.cpp
Generated on Wed Jan 25 01:00:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsProfileService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsProfileService Class Reference

#include <Applications/BtApp/BtHsAppPlugin/BtHsProfileService.hpp>

Inheritance diagram for BtHsProfileService:

[legend]
Collaboration diagram for BtHsProfileService:

[legend]

Public Member Functions

BtHsProfileService ()
Constructor.
virtual | ~BtHsProfileService ()
Destructor.

Protected Member Functions

void | OnCallTransferToHeadset (BtRequestState old_request_state, BtRequestState new_request_state)
void | OnCallTransferToPhone (BtRequestState old_request_state, BtRequestState new_request_state)
void | OnConnect (BtRequestState old_request_state, BtRequestState new_request_state)
void | OnDisonnect (BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
Response to user initiate Hs disconnect request.

Constructor & Destructor Documentation

BtHsProfileService::BtHsProfileService ( )

Constructor.

BtHsProfileService::~BtHsProfileService ( ) [virtual]

Destructor.

Member Function Documentation

void BtHsProfileService::OnCallTransferToHeadset | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

void BtHsProfileService::OnCallTransferToPhone | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

void BtHsProfileService::OnConnect | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

void BtHsProfileService::OnDisonnect | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected]

void BtHsProfileService::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Response to user initiate Hs disconnect request.

OnRequestStateChange will be automatically called if the Hs disconnect request state changed.

Parameters:
request_type | A BtRequestType identify the request type.
old_request_state | the old BtRequestState
new_request_state | the BtRequestState after the evoking request operation.

Implements BtService.

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHsAppPlugin/BtHsProfileService.hpp
  • Applications/BtApp/BtHsAppPlugin/BtHsProfileService.cpp
Generated on Wed Jan 25 01:00:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/HS/BtHsServiceMessage.hpp>

Inheritance diagram for BtHsRequestStateChangedMessage:

[legend]
Collaboration diagram for BtHsRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10325 }

Public Member Functions

BtHsRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtHsRequestStateChangedMessage ()

Detailed Description

BtHsRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtHsRequestStateChangedMessage::BtHsRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtHsRequestStateChangedMessage::~BtHsRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtHsRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtHsRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsServiceMessage.hpp
  • Bluetooth/HS/BtHsServiceMessage.cpp
Generated on Wed Jan 25 01:00:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/HS/BtHsService.hpp>

Inheritance diagram for BtHsService:

[legend]
Collaboration diagram for BtHsService:

[legend]

Public Member Functions

BtHsService ()
Constructor.
virtual BtRequestState | ConnectRequest ()
Establish connection for the device set for this service.
virtual BtRequestState | DisconnectRequest ()
Release connection for the device set for this service.
BOOLEAN | GetConnectionOnlyDuringCall () const
Should the connection be kept after call hangup?
virtual UINT8 | GetMicrophoneGain () const
UINT8 | GetNumberOfRingSignals () const
Returns the number of ring signals.
virtual BtProfile | GetProfile () const
Get the profile this service is associated with.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
UINT16 | GetRingInterval () const
Returns the ring interval duration.
virtual UINT8 | GetSpeakerGain () const
BtHsState | GetState () const
Returns the current state of the headset.
virtual void | Init ()
Initalize the head set service.
virtual BOOLEAN | IsConnected () const
Returns the connected state of device set for this service.
virtual BOOLEAN | IsInCall () const
virtual BOOLEAN | IsRinging () const
void | SetConnectionOnlyDuringCall (BOOLEAN connection_only_during_call)
Set whether the device set this service should keep connection after call.
virtual BtRequestState | SetMicrophoneGainRequest (INT8 gain_offset)
Set the gain for the microphone.
void | SetNumberOfRingSignals (UINT8 number_of_ring_signals)
Set the number of ring signals.
void | SetRingInterval (UINT16 ring_interval)
Sets the ring interval duration.
virtual BtRequestState | SetSpeakerGainRequest (INT8 gain_offset)
Set the gain for the speaker.
virtual void | SetTargetDevice (const BtDevice &target_device)
Sets the remote device this service addresses.
virtual BtRequestState | TransferAudioToAccessoryRequest ()
Establish audio connection to the headset.
virtual BtRequestState | TransferAudioToPhoneRequest ()
Release audio connection from the headset.
virtual | ~BtHsService ()
Destructor.

Static Public Member Functions

static const BtDevice & | GetLastConnectedDevice ()
Get the device that was last connected to the BT HS profile.
static void | SetLastConnectedDevice (const BtDevice &last_connected_device)
Set the device that was last connected to the BT HS profile.

Protected Member Functions

void | AcceptCall ()
virtual BOOLEAN | OnCallEventMessage (const CallEventMsg &call_event_message)
virtual BOOLEAN | OnControllerMessage (const BtHsControllerMessage &controller_message)
virtual BOOLEAN | OnMessage (const Message &message)
virtual void | RegisterMessages () const
void | ReleaseCall ()
BtRequestState RingRequest ()
BtRequestState | StopRingRequest (BOOLEAN keep_audio=FALSE)
virtual void | UnregisterMessages () const

Friends

class | BtHsRequest
class | BtHsRingRequest

Detailed Description

The BtHsService class represents the userinterface for the application programmer to the headset profile of the Bluetooth stack.
It is an abstract class, from which the application programmer has to derive his own service class to implement the communication between his bluetooth headset MMI application and the BtHsService. For this purpose he has to implement the OnRequestStateChange member function, that is derived from BtService. This function is allways called when an user initiated request changes his state.
There is a second mechanism to inform the MMI application about events concerning the headset: The application, that wants to be informed when such events occur, has to subscribe the BtHsNotificationMessage. Every time an event that changes the state of the headset occurs, such a message containing a description about the event is posted.

Constructor & Destructor Documentation

BtHsService::BtHsService ( )

Constructor.

BtHsService::~BtHsService ( ) [virtual]

Destructor.

Member Function Documentation

void BtHsService::AcceptCall ( ) [protected]

BtRequestState BtHsService::ConnectRequest ( ) [virtual]

Establish connection for the device set for this service.

ConnectRequest sends a device connect request down to the BtHsController for execution. On successfull execution of this request an ACL connection for the device set for this serivce will be established. The progress of the ongoing request is signalled to the OnRequestStateChange member function.

Returns:
A BtRequestState containing the current state of the requested operation.

Implements BtAudioAccessoryService.

BtRequestState BtHsService::DisconnectRequest ( ) [virtual]

Release connection for the device set for this service.

ConnectRequest sends a device disconnect request down to the BtHsController for execution. On successfull execution of this request the ACL connection for the device set for this serivce will be released. The progress of the ongoing request is signalled to the OnRequestStateChange member function.

Returns:
A BtRequestState containing the current state of the requested operation.

Implements BtAudioAccessoryService.

BOOLEAN BtHsService::GetConnectionOnlyDuringCall ( ) const

Should the connection be kept after call hangup?

GetConnectionOnlyDuringCall returns whether the device set for this service should keep the ACL connection after a call has ended or if it should be released and established again when a new call comes in. The default value for this property is FALSE.

Returns:
TRUE | ACL connection will be released after call and reestablish when a new call comes in.
FALSE | ACL connection is kept after call.

const BtDevice & BtHsService::GetLastConnectedDevice ( ) [static]

Get the device that was last connected to the BT HS profile.

The BtHsController class stores the device address of the last connected device. Because the BtHsController is used as an internal class the BtHsService offers a class method GetLastConnectedDevice to get access to this device.

Returns:
A reference to a BtDevice containing the device that was the last connected headset device.

UINT8 BtHsService::GetMicrophoneGain ( ) const [virtual]

Implements BtAudioAccessoryService.

UINT8 BtHsService::GetNumberOfRingSignals ( ) const

Returns the number of ring signals.

GetNumberOfRingSignals returns the number of ring singals before the headset stops ringing.

Returns:
An UINT8 containing the number of ring signals. Zero depicts infinite number of rings signals.

BtProfile BtHsService::GetProfile ( ) const [virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implements BtService.

BtRequestState BtHsService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

UINT16 BtHsService::GetRingInterval ( ) const

Returns the ring interval duration.

SetRingInterval returns the duration for the ring intervall. The duration is defined as the intervall from the beginning of the ring tone to beginning of the next ring tone.

Returns:
An UINT16 containing the ring interval. The unit for this paramter is milliseconds.

UINT8 BtHsService::GetSpeakerGain ( ) const [virtual]

Implements BtAudioAccessoryService.

BtHsState BtHsService::GetState ( ) const

Returns the current state of the headset.

GetState returns the state of the headset device that is set for this service.

Returns:
BtHssNotConnected | No ACL connection is established for the headset device that is set for this service.
BtHssConnected | An ACL connection is established for the headset device that is set for this service but no activities are going on.
BtHssRinging | An ACL connection is established for the headset device that is set for this service and it is ringing.
BtHssInCall | An ACL connection and an SCO connetion is established for the headset device that is set for this service.

void BtHsService::Init ( ) [virtual]

Initalize the head set service.

Init has to be called to make the service running. It adds itself as a dispatcher to the active application and registers the the necessary messages.

BOOLEAN BtHsService::IsConnected ( ) const [virtual]

Returns the connected state of device set for this service.

IsConnected returns whether the device set for this service has an ACL connection established or not.

Returns:
TRUE | ACL connection established.
FALSE | ACL connection not established.

Implements BtAudioAccessoryService.

BOOLEAN BtHsService::IsInCall ( ) const [virtual]

Implements BtAudioAccessoryService.

BOOLEAN BtHsService::IsRinging ( ) const [virtual]

Implements BtAudioAccessoryService.

BOOLEAN BtHsService::OnCallEventMessage ( const CallEventMsg & call_event_message ) [protected, virtual]

BOOLEAN BtHsService::OnControllerMessage ( const BtHsControllerMessage & controller_message ) [protected, virtual]

BOOLEAN BtHsService::OnMessage ( const Message & message ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void BtHsService::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

void BtHsService::ReleaseCall ( ) [protected]

BtRequestState BtHsService::RingRequest ( ) [protected]

void BtHsService::SetConnectionOnlyDuringCall ( BOOLEAN connection_only_during_call )

Set whether the device set this service should keep connection after call.

SetConnectionOnlyDuringCall sets the behaviour of the device set for this service concerning the ACL connection after a call has ended.

Parameters:
connection_only_during_call<table border=0>

TRUE

Release ACL connection after call.

FALSE

Keep ACL connection after call.

void BtHsService::SetLastConnectedDevice ( const BtDevice & last_connected_device ) [static]

Set the device that was last connected to the BT HS profile.

The last connected device stored in the BtHsController is not stored presistent. So there should be a possibility to set this device at eg the start up phase. The class function SetLastConnectedDevice offers this possbility.

Parameters:
last_connected_device A reference to a BtDevice contraining the device that should be set as the last connected device.

BtRequestState BtHsService::SetMicrophoneGainRequest ( INT8 gain_offset ) [virtual]

Set the gain for the microphone.

CallTransferToPhoneRequest sends a set gain for microphone request down to the BtHsController for execution. On successfull execution the gain of the microphone is adjusted. The progress of the ongoing request is signalled to the OnRequestStateChange member function.
The range of the gain is [0..15].

Parameters:
gain_offset An INT8 containing the offset, which the current offset should be changed. When the resulting gain would exceed the upper or lower bounds for the gain, the upper or lower bound will be set.
Returns:
A BtRequestState containing the current state of the requested operation.

Implements BtAudioAccessoryService.

void BtHsService::SetNumberOfRingSignals ( UINT8 number_of_ring_signals )

Set the number of ring signals.

SetNumberOfRingSignals sets the number of ring singals before the headset stops ringing.

Parameters:
number_of_ring_signals An UINT8 containing the number of ring signals. Zero depicts infinite number of rings signals.

void BtHsService::SetRingInterval ( UINT16 ring_interval )

Sets the ring interval duration.

SetRingInterval sets the duration for the ring intervall. The duration is defined as the intervall from the beginning of the ring tone to beginning of the next ring tone.

Returns:
ring_interval An UINT16 containing the new ring interval. The unit for this paramter is milliseconds.

BtRequestState BtHsService::SetSpeakerGainRequest ( INT8 gain_offset ) [virtual]

Set the gain for the speaker.

CallTransferToPhoneRequest sends a set gain for speaker request down to the BtHsController for execution. On successfull execution the gain of the speaker is adjusted. The progress of the ongoing request is signalled to the OnRequestStateChange member function.
The range of the gain is [0..15].

Parameters:
gain_offset An INT8 containing the offset, which the current offset should be changed. When the resulting gain would exceed the upper or lower bounds for the gain, the upper or lower bound will be set.
Returns:
A BtRequestState containing the current state of the requested operation.

Implements BtAudioAccessoryService.

void BtHsService::SetTargetDevice ( const BtDevice & target_device ) [virtual]

Sets the remote device this service addresses.

Each BtService class addresses exactly one remote device. For profiles supporting more than one remote device there must be more than one instance of that prarticular service.
SetTargetDevice sets the remote device, that this service addresses.

Parameters:
target_device A reference to a BtDevice containing the remote device this service should address.

Reimplemented from BtService.

BtRequestState BtHsService::StopRingRequest ( BOOLEAN keep_audio = FALSE ) [protected]

BtRequestState BtHsService::TransferAudioToAccessoryRequest ( ) [virtual]

Establish audio connection to the headset.

TransferAudioToAccessoryRequest sends a transfer request down to the BtHsController for execution. On successfull execution of this request a SCO connection will be established and the APOXI audio path with be switched to the Bluetooth chip. The progress of the ongoing request is signalled to the OnRequestStateChange member function.

Returns:
A BtRequestState containing the current state of the requested operation.

Implements BtAudioAccessoryService.

BtRequestState BtHsService::TransferAudioToPhoneRequest ( ) [virtual]

Release audio connection from the headset.

TransferAudioToPhoneRequest sends a transfer request down to the BtHsController for execution. On successfull execution of this request the SCO connection will be released and the APOXI audio path with be switched to the internal speaker. The progress of the ongoing request is signalled to the OnRequestStateChange member function.

Returns:
A BtRequestState containing the current state of the requested operation.

Implements BtAudioAccessoryService.

void BtHsService::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

Friends And Related Function Documentation

friend class BtHsRequest [friend]

friend class BtHsRingRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/HS/BtHsService.hpp
  • Bluetooth/HS/BtHsService.cpp
Generated on Wed Jan 25 01:00:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsSupportedProfileMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsSupportedProfileMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtHsSupportedProfileMessage:

[legend]
Collaboration diagram for BtHsSupportedProfileMessage:

[legend]

Public Types

enum | { ID = 10230 }

Public Member Functions

BtHsSupportedProfileMessage (const BtResultCode &result, UINT32 request_id, const WString &hs_profile_name, BOOLEAN hs_has_remote_volume_control)
virtual Message * | Clone () const
const WString & | GetHsProfileName () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsHsHasRemoteVolumeControl () const
void | SetHsHasRemoteVolumeControl (BOOLEAN hs_has_remote_volume_control)
void | SetHsProfileName (const WString &hs_profile_name)
virtual | ~BtHsSupportedProfileMessage ()

Detailed Description

BtHsSupportedProfileMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtHsSupportedProfileMessage::BtHsSupportedProfileMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const WString & | hs_profile_name,
 |  | BOOLEAN | hs_has_remote_volume_control
 | ) |

BtHsSupportedProfileMessage::~BtHsSupportedProfileMessage ( ) [virtual]

Member Function Documentation

Message * BtHsSupportedProfileMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const WString& BtHsSupportedProfileMessage::GetHsProfileName ( ) const [inline]

const MsgMetaData & BtHsSupportedProfileMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

BOOLEAN BtHsSupportedProfileMessage::IsHsHasRemoteVolumeControl ( ) const [inline]

void BtHsSupportedProfileMessage::SetHsHasRemoteVolumeControl ( BOOLEAN hs_has_remote_volume_control ) [inline]

void BtHsSupportedProfileMessage::SetHsProfileName ( const WString & hs_profile_name ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:00:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHsVolumeSettingsWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtHsVolumeSettingsWin Class Reference

#include <Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.hpp>

Collaboration diagram for BtHsVolumeSettingsWin:

[legend]

Public Types

enum | AudioGain { MicGain = 0, SpeakerGain }

Public Member Functions

BtHsVolumeSettingsWin (BtHsProfileService &service)
void | Init ()
virtual | ~BtHsVolumeSettingsWin ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()

Member Enumeration Documentation

enum BtHsVolumeSettingsWin::AudioGain

Enumerator:
MicGain
SpeakerGain

Constructor & Destructor Documentation

BtHsVolumeSettingsWin::BtHsVolumeSettingsWin ( BtHsProfileService & service )

BtHsVolumeSettingsWin::~BtHsVolumeSettingsWin ( ) [virtual]

Member Function Documentation

void BtHsVolumeSettingsWin::Init ( )

BOOLEAN BtHsVolumeSettingsWin::OnCancel ( ) [protected, virtual]

BOOLEAN BtHsVolumeSettingsWin::OnConfirm ( ) [protected, virtual]

void BtHsVolumeSettingsWin::OnLayoutClient ( ) [protected, virtual]

BOOLEAN BtHsVolumeSettingsWin::OnMessage ( const Message & msg ) [protected, virtual]

void BtHsVolumeSettingsWin::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.hpp
  • Applications/BtApp/BtHsAppPlugin/BtHsVolumeSettingsWin.cpp
Generated on Wed Jan 25 01:00:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtIndicatorMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtIndicatorMsg Class Reference

#include <Applications/BtApp/BtMsgTypes.hpp>

Inheritance diagram for BtIndicatorMsg:

[legend]
Collaboration diagram for BtIndicatorMsg:

[legend]

Public Types

enum | { ID = 22500 }

Public Member Functions

BtIndicatorMsg (const BtProfile &profile, BOOLEAN connected)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const BtProfile & | GetProfile () const
BOOLEAN | IsConnected () const
virtual | ~BtIndicatorMsg ()

Detailed Description

BtIndicatorMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtIndicatorMsg::BtIndicatorMsg | ( | const BtProfile & | profile,
 |  | BOOLEAN | connected
 | ) |

BtIndicatorMsg::~BtIndicatorMsg ( ) [virtual]

Member Function Documentation

Message * BtIndicatorMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & BtIndicatorMsg::GetMetaData ( ) const [virtual]

Implements Message.

const BtProfile& BtIndicatorMsg::GetProfile ( ) const [inline]

BOOLEAN BtIndicatorMsg::IsConnected ( ) const [inline]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtMsgTypes.hpp
  • Applications/BtApp/BtMsgTypes.cpp
Generated on Wed Jan 25 01:00:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtJsr82Url Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtJsr82Url Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/JSR82/BtJsr82Url.hpp>

Collaboration diagram for BtJsr82Url:

[legend]

Public Types

enum Parameter {
PAuthenticate, PAuthorize, PEncrypt, PMaster,
PName
}
enum Result {
RParsing, RSuccess, RSyntaxErr, RParameterDuplicatedErr,
RParameterValueRangeErr, RSecuritySettingsErr
}
enum | UrlType { UnknownUrlType, ClientUrlType, ServerUrlType }

Public Member Functions

BtJsr82Url (const String &url_str, UrlType url_type=UnknownUrlType)
Constructor.
BOOLEAN | GetBtAddress (BtDeviceAddress &bt_addr) const
Returns the device address of a client url, if applicable.
UINT8 | GetBtChannel () const
Returns the RFCOMM channel of a client URL, if applicable.
BOOLEAN | GetBtService (BtUUID &uuid) const
Returns the UUID of a server url, if applicable.
BOOLEAN | GetParamValue (Parameter param, String &value) const
BOOLEAN | GetParamValue (Parameter param, BOOLEAN &value) const
Result | GetResult () const
BOOLEAN | GetSecuritySettings (BtSecuritySettings &ses) const
Returns the specified security settings.
UrlType | GetUrlType () const
BOOLEAN | IsUrlValid () const

Friends

class | Scanner
class | Token

Data Structures

class | Scanner
class | StringReader
class | Token

Member Enumeration Documentation

enum BtJsr82Url::Parameter

Enumerator:
PAuthenticate
PAuthorize
PEncrypt
PMaster
PName

enum BtJsr82Url::Result

Enumerator:
RParsing | Parsing ongoing.
RSuccess | Parsing successfully completed.
RSyntaxErr | Error codes starting from here.
RParameterDuplicatedErr | Parameter sepcified more than once.
RParameterValueRangeErr | Parameter value out of range.
RSecuritySettingsErr | Invalid security settings.

enum BtJsr82Url::UrlType

Enumerator:
UnknownUrlType
ClientUrlType
ServerUrlType

Constructor & Destructor Documentation

BtJsr82Url::BtJsr82Url | ( | const String & | url_str,
 |  | UrlType | url_type = UnknownUrlType
 | ) |

Constructor.

Member Function Documentation

BOOLEAN BtJsr82Url::GetBtAddress ( BtDeviceAddress & bt_addr ) const

Returns the device address of a client url, if applicable.

Parameters:
bt_addr Reference to a bluetooth device address where the result should be delivered to.
Returns:
'TRUE' when a valid address was copied to bt_addr, 'FALSE' otherwise.

UINT8 BtJsr82Url::GetBtChannel ( ) const [inline]

Returns the RFCOMM channel of a client URL, if applicable.

Returns:
RFCOMM channel number (1-30) when specified, '0' otherwise.

BOOLEAN BtJsr82Url::GetBtService ( BtUUID & uuid ) const

Returns the UUID of a server url, if applicable.

Parameters:
uuid Reference to a uuid struct where the result should be delivered to.
Returns:
'TRUE' when a valid UUID was copied to uuid, 'FALSE' otherwise.

BOOLEAN BtJsr82Url::GetParamValue | ( | Parameter | param,
 |  | String & | value
 | ) | const

BOOLEAN BtJsr82Url::GetParamValue | ( | Parameter | param,
 |  | BOOLEAN & | value
 | ) | const

Result BtJsr82Url::GetResult ( ) const [inline]

BOOLEAN BtJsr82Url::GetSecuritySettings ( BtSecuritySettings & ses ) const

Returns the specified security settings.

Parameters:
ses Reference to a variable to hold the security settings. When any security settings were specified they are mapped onto the values of the enumeration BtSecuritySettings and 'ses' is overwritten with the resulting value.
Returns:
'TRUE' when security settings were specified in the URL string the URL was constructed from, 'FALSE' otherwise. In the latter case, ses is left unchanged.

UrlType BtJsr82Url::GetUrlType ( ) const [inline]

BOOLEAN BtJsr82Url::IsUrlValid ( ) const [inline]

Friends And Related Function Documentation

friend class Scanner [friend]

friend class Token [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/JSR82/BtJsr82Url.hpp
  • Bluetooth/JSR82/BtJsr82Url.cpp
Generated on Wed Jan 25 01:00:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtJsr82Url::Token Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtJsr82Url::Token

BtJsr82Url::Token Class Reference

#include <Apoxi/Bluetooth/JSR82/BtJsr82Url.hpp>

Collaboration diagram for BtJsr82Url::Token:

[legend]

Public Types

enum TypeId {
TUnknown, TAmbigous, TScheme, TBadInput,
TEndInput, TColon, TEqual, TSemicolon,
TComma, TDot, TAsterix, TSlashes,
TDecNumber, THexNumber, TText, TLocalhost,
TAuthenticate, TAuthorize, TEncrypt, TMaster,
TName, TFalse, TTrue
}

Public Member Functions

TypeId | GetTypeId () const
const String & | GetValue () const
BOOLEAN | IsOfType (TypeId type_id) const
BOOLEAN | MatchesType (TypeId type_id) const

Friends

class | Scanner

Data Structures

struct | Keyword

Member Enumeration Documentation

enum BtJsr82Url::Token::TypeId

Enumerator:
TUnknown
TAmbigous
TScheme
TBadInput
TEndInput
TColon
TEqual
TSemicolon
TComma
TDot
TAsterix
TSlashes
TDecNumber
THexNumber
TText
TLocalhost
TAuthenticate
TAuthorize
TEncrypt
TMaster
TName
TFalse
TTrue

Member Function Documentation

TypeId BtJsr82Url::Token::GetTypeId ( ) const [inline]

const String& BtJsr82Url::Token::GetValue ( ) const [inline]

BOOLEAN BtJsr82Url::Token::IsOfType ( TypeId type_id ) const [inline]

BOOLEAN BtJsr82Url::Token::MatchesType ( TypeId type_id ) const

Friends And Related Function Documentation

friend class Scanner [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/JSR82/BtJsr82Url.hpp
  • Bluetooth/JSR82/BtJsr82Url.cpp
Generated on Wed Jan 25 01:01:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtJsr82Url::Token::Keyword Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtJsr82Url::Token::Keyword

BtJsr82Url::Token::Keyword Struct Reference

#include <Apoxi/Bluetooth/JSR82/BtJsr82Url.hpp>

Data Fields

const CHAR * text_ptr
TypeId type_id

Field Documentation

const CHAR* BtJsr82Url::Token::Keyword::text_ptr

TypeId BtJsr82Url::Token::Keyword::type_id

The documentation for this struct was generated from the following file:
  • Bluetooth/JSR82/BtJsr82Url.hpp
Generated on Wed Jan 25 01:01:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtLocalNameMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtLocalNameMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtLocalNameMessage:

[legend]
Collaboration diagram for BtLocalNameMessage:

[legend]

Public Types

enum | { ID = 10213 }

Public Member Functions

BtLocalNameMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtLocalNameMessage ()

Detailed Description

BtLocalNameMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtLocalNameMessage::BtLocalNameMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtLocalNameMessage::~BtLocalNameMessage ( ) [virtual]

Member Function Documentation

Message * BtLocalNameMessage::Clone ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

const MsgMetaData & BtLocalNameMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:01:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtLocalRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtLocalRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtLocalRequest.hpp>

Inheritance diagram for BtLocalRequest:

[legend]
Collaboration diagram for BtLocalRequest:

[legend]

Public Member Functions

BtLocalRequest ()
Constructor.
virtual BtRequestState | ExecuteRequest ()
Sumbit this request to the Bluetooth Stack.
virtual | ~BtLocalRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | EvaluateMessageResult (const BtRequestMessage &message)
Check the result parameter of the callback functions.
virtual void | ExecutionCallback (BtResultCode result)
virtual BOOLEAN | OnMessage (const Message &messsage)=0
Base message handling member function.
virtual void | OnRequestStateChange (BtRequestState old_request_state, BtRequestState new_request_state)=0
Request state change handling member function.
BOOLEAN | RegisterDispatcher ()
Register this request as message dispatcher.
virtual void | SetRequestState (BtRequestState request_state)
Set processing state of this request.
BOOLEAN | UnregisterDispatcher ()
Unregister this request as message dispatcher.

Detailed Description

When Bluetooth is instructed to do some operation that goes over the air these operations take at least a couple of time. Such operations are called a request for an operation because the function does not execute the operation. Instead of this the function asks the Bluetooth Stack for the exectution of the operation.
To avoid the running application from blocking while it is waiting for the end of the execution of a requested operation, requests where executed in a asynchronous way. When the Bluetooth Stack has finished a requested operation, it calls a callback function associated with the requested operation. Depending on the profile the relevant Bt...Controller implements this callback function. From within these functions messages were sent to the running application to notify it about the progress and success of the requested operation.
BtRequest is the base class for such requests as described above. To enable the reception of messages BtRequest is derived from UserDispatcher. This class is abstract because it primarily defines the interface to all requests. The execution of a certain operation is implemented by the apropriate Bt...Request class. This is done by calling the corresponding function in one Bt...Controller class that instructs the Bluetooth Stack to execute the requested operation.
Some of the operation requested from the Bluetooth Stack can be interrupted. These request are called cancelable. If a request is cancelable the procedure to cancel an initiated request must be implemented too. The last step of implementing a concrete reqeuest is to implement the On... function to dispatch and handle the messages sent to the application by the apropriate Bt...Controller class.

Constructor & Destructor Documentation

BtLocalRequest::BtLocalRequest ( )

Constructor.

BtLocalRequest::~BtLocalRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtLocalRequest::EvaluateMessageResult ( const BtRequestMessage & message ) [protected, virtual]

Check the result parameter of the callback functions.

When a callback function is invoked one parameter is a result code indicatint the state of the ongoing stack operation. Ths result code is interpreted and the if necessary the ChangeRequestState function is called to do the right state change.
This function is a helper function and has to be used be the implementations of a concrete request when it handles the arrived message in the OnMessage function.

Parameters:
message A reference to a BtRequestMessage that references the Bluetooth message received by the OnMessage function.
Returns:
TRUE: The was a state transition.
FALSE: The was no state transition.

Reimplemented in BtRequestRespondRequest.

BtRequestState BtLocalRequest::ExecuteRequest ( ) [virtual]

Sumbit this request to the Bluetooth Stack.

ExecuteRequest instructs this request to sent itself to the Bluetooth stack for execution purposes. This function prepares the submission of the request to the stack. The real exection of the stack call is done by the fuction Execute, which is a pure virtual function, that has to be overwritten by the concrete request, which is a subclass of this class.

Returns:
A BtRequestState containing the current state of exectuion for this request. Most times the returned state indicates whether the Bluetooth Stack has accepted or rejected the request.

Implements BtRequest.

void BtLocalRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Implements BtRequest.

virtual BOOLEAN BtLocalRequest::OnMessage ( const Message & messsage ) [protected, pure virtual]

Base message handling member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements Dispatcher.

Implemented in BtDevicePairRequest, BtDeviceSearchRequest, BtDeviceTrustRequest, BtDeviceUnpairRequest, BtDeviceUntrustRequest, BtQuerySupportedProfilesRequest, BtRespondAuthorizationRequest, BtSendPasskeyRequest, BtServiceVerifyRequest, and BtSetRemoteDeviceNameRequest.

virtual void BtLocalRequest::OnRequestStateChange | ( | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, pure virtual]

Request state change handling member function.

The OnRequestStateChange will allways be invoked when the processing state of this request changes. This function is used to carry out some reactions to the change. It is an pure virtual function and all subsequent (inherited) requests therefore are abstract classes. So the application programmer has to derive the partikular request from the class that fullfills the request and must implement this function. After that the application progammer can use his request to initiate an request at the Bluetooth stack.

Parameters:
old_request_state | A BtRequstState containing the state of the request before the change took place.
new_request_state | A BtRequstState containing the state of the request after the change took place.

Implemented in BtApplicationSendPasskeyRequest, BtApplicationRespondAuthorizationRequest, BtApplicationDevicePairRequest, BtApplicationDeviceUnpairRequest, BtApplicationDeviceTrustRequest, BtApplicationDeviceUntrustRequest, BtApplicationQuerySupportedProfilesRequest, BtApplicationSetRemoteDeviceNameRequest, BtApplicationDeviceSearchRequest, and BtApplicationServiceVerifyRequest.

BOOLEAN BtLocalRequest::RegisterDispatcher ( ) [protected]

Register this request as message dispatcher.

To receive result message the request must register itself at an application to take part at the message routing. The function RegisterDispatcher performs this task. To minimize the number of objects that participate in message routing the request is only registered at an application during its execution process. When it has stopped executing it unregisters itself from the application.

Returns:
TRUE: The request is successfully registered at the application.
FALSE: The registriation of the request at the application failed.

void BtLocalRequest::SetRequestState ( BtRequestState request_state ) [protected, virtual]

Set processing state of this request.

A request can be seen as it goes through several stages in its execution process. SetRequestState can be used to set the current stage of execution. When the passed in state is other than the current state the OnRequestStateChange callback function will be invoked.

Parameters:
request_state A BtRequestState containing the current stage of exection which has to be set for this request.

Implements BtRequest.

BOOLEAN BtLocalRequest::UnregisterDispatcher ( ) [protected]

Unregister this request as message dispatcher.

To receive result messages the request must register itself at an application to take part at message routing. To minimize the number of objects that participate in message routing the request is only registered at an application during its execution process. When it has stopped executing it unregisters itself from the application. This task is done by UnregisterDispatcher.

Returns:
TRUE: The request is successfully unregistered from the application.
FALSE: The unregistriation of the request at the application failed.

The documentation for this class was generated from the following files:
  • Bluetooth/BtLocalRequest.hpp
  • Bluetooth/BtLocalRequest.cpp
Generated on Wed Jan 25 01:01:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtLocalSettings Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtLocalSettings Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtLocalSettings.hpp>

Inheritance diagram for BtLocalSettings:

[legend]
Collaboration diagram for BtLocalSettings:

[legend]

Public Member Functions

BtLocalSettings (Application *application)
Constructor.
BtResultCode | GetChipVersion (BtChipVersion &chip_version) const
Get version of the Bluetooth Hardware.
BtResultCode | GetConnectableMode (BtConnectableMode &connectable_mode) const
Get current connectability mode.
BtResultCode | GetDiscoverableMode (BtDiscoverableMode &discoverable_mode) const
Get current discoverability mode.
BtResultCode | GetIsProfileActive (BtProfile profile, BOOLEAN &active)
BtResultCode | GetLocalAddress (BtDeviceAddress &device_address) const
Get local Bluetooth address.
BtResultCode | GetLocalName (WString &local_name) const
Get local Bluetooth name.
UINT32 | GetLocalSettingsId ()
Get Unique id for this object.
BtStackState | GetLocalState () const
Get the local state.
BtResultCode | GetPairableMode (BtPairableMode &pairable_mode) const
Get current pairability mode.
BtResultCode | SetConnectableMode (BtConnectableMode connectable_mode=BtCmConnectable, BOOLEAN execute_synchron=FALSE)
Set current connectability mode.
BtResultCode | SetDiscoverableMode (BtDiscoverableMode discoverable_mode=BtDmGeneralDiscoverable, BOOLEAN execute_synchron=FALSE)
Set current discoverability mode.
BtResultCode | SetIsProfileActive (BtProfile profile, BOOLEAN active, BOOLEAN execute_synchron=FALSE)
BtResultCode | SetLocalName (const WString &local_name, BOOLEAN execute_synchron=FALSE)
Set local Bluetooth name.
BtResultCode | SetPairableMode (BtPairableMode pairable_mode=BtPmPairable, BOOLEAN execute_synchron=FALSE)
Set current pairability mode.
BtResultCode | TurnOff (BOOLEAN execute_synchron=FALSE)
Turn Bluetooth functionality off.
BtResultCode | TurnOn (BOOLEAN execute_synchron=FALSE)
Turn Bluetooth functionality on.
virtual | ~BtLocalSettings ()
Destructor.

Protected Types

enum BtActiveRequest {
BtArNone = 0, BtArSwitchState = BtStateChangedMessage::ID, BtArLocalName = BtLocalNameMessage::ID, BtArDiscoverability = BtDiscoverabilityMessage::ID,
BtArPairability = BtPairabilityMessage::ID, BtArConnectablity = BtConnectabilityMessage::ID, BtArProfileActivation = BtProfileActivationMessage::ID
}
Asynchronous request type enumeration. More...

Protected Member Functions

virtual void | OnConnectableMode (BtResultCode result)
BtConnectabilityMessage message handler.
virtual void | OnDiscoverableMode (BtResultCode result)
BtDiscoverabilityMessage message handler.
virtual void | OnLocalName (BtResultCode result)
BtLocalNameMessage message handler.
virtual BOOLEAN | OnMessage (const Message &message)
General message handler.
virtual void | OnPairableMode (BtResultCode result)
BtPairabilityMessage message handler.
virtual void | OnProfileActivation (BtResultCode result)
virtual void | OnStateChange (BtStackState stack_state)
BtStateChangeMessage message handler.

Friends

class | BtGapAndSdapController

Detailed Description

BtLocalSettings is an interface class to the local Bluetooth Settings like local device name, visibility, pairability and so on. It implements an interface for querying and setting properties of the Bluetooth Stack.
Although the most BtSet... functions execute asynchronous in the Bluetooth Stack, the time they need to execute is very short. So all BtSet... functions have an additional parameter that controlls the way the function is executed. If the execute_synchron parameter in the BtSet... functions is set to TRUE, the function will block and the result of the operation is given back via the result code of the function. Setting the execute_synchron parameter to FALSE the result code of the function only indicates whether the Bluetooth Stack has accepted the operation or not. The result of the operation is returned through a message sent to this object.
The most times the approach to execute the offered BtSet.. functions synchronous will be better, because, as mentioned above, the operations only take very short time to execute and no progess indication (GUI feedback during the operation) is necessary. Also the implementation of applications that use these functions synchronous is quite easier.
Sometimes an application programmer may decide that he wants to get more control over the operation as the synchronous interface offers. In this case the work he has to do is a little more complex: First he has to derive his own class from BtLocalSettings. The second step is to overwrite the appropriate On... function(s) were he has to implement the reaction on the operation result that is part of the message sent to the owerwritten On... function(s). It is not necessary to call the On... functions of this class because the implementation of the On... functions is only a dummy implementation that does really nothing.
Important: If an operation is executed synchronous, no matter it it is an instance of this class or a class derived from this class, there will be no call to any On... message function (not necessary because the result of the operation matches the result of the called function).

Member Enumeration Documentation

enum BtLocalSettings::BtActiveRequest [protected]

Asynchronous request type enumeration.

BtActiveRequest is used to decide whether a received message was initiated by this object or not.

Enumerator:
BtArNone | No asynchronous request is currently running.
BtArSwitchState | TurnOn or TurnOff is currently running asynchronously.
BtArLocalName | SetLocalName is currently running asynchronously.
BtArDiscoverability | SetDiscoverableMode is currently running asynchronously.
BtArPairability | SetPairableMode is currently running asynchronously.
BtArConnectablity | SetConnectableMode is currently running asynchronously.
BtArProfileActivation

Constructor & Destructor Documentation

BtLocalSettings::BtLocalSettings ( Application * application )

Constructor.

BtLocalSettings::~BtLocalSettings ( ) [virtual]

Destructor.

Member Function Documentation

BtResultCode BtLocalSettings::GetChipVersion ( BtChipVersion & chip_version ) const

Get version of the Bluetooth Hardware.

GetChipVersion queries the version of the Bluetooth Hardware. This operation can not be performed if the Bluetooth functionality is turned off.

Parameters:
chip_version A reference to a BtChipVersion where to store the version of the Bluetooth Hardware returned by the stack.
Returns:
BtOk: The execution of the operation has finished successfully and chip_version is valid.
BtError: The execution of the operation failed: Do not use chip_version and check stack state for further information

BtResultCode BtLocalSettings::GetConnectableMode ( BtConnectableMode & connectable_mode ) const

Get current connectability mode.

GetConnectableMode queries the mode of connectability of the local Bluetooth settings. This operation can be performed although the Bluetooth functionality is turned off.

Parameters:
connectable_mode A reference to a BtConnectableMode enumeration type where to store the mode of connectability.
Returns:
BtOk: The operation was successfully executed and the connectable_mode is valid.
BtError: The operation failed. Do not use the returned connectable_mode.

BtResultCode BtLocalSettings::GetDiscoverableMode ( BtDiscoverableMode & discoverable_mode ) const

Get current discoverability mode.

GetDiscoverableMode queries the mode of discoverability of the local Bluetooth settings. This operation can be perform although the Bluetooth funcionality is turned off.

Parameters:
discoverable_mode A reference to a BtDiscoverableMode enumeration type where to store the mode of discoverability.
Returns:
BtOk: The execution of the operation has finished successfully and discoverable_mode is valid.
BtError: The execution of the operation failed: Do not use discoverable_mode and check stack state for further information.

BtResultCode BtLocalSettings::GetIsProfileActive | ( | BtProfile | profile,
 |  | BOOLEAN & | active
 | ) |

BtResultCode BtLocalSettings::GetLocalAddress ( BtDeviceAddress & device_address ) const

Get local Bluetooth address.

GetLocalAddress queries the local Bluetooth address. This operation can not be performed if the Bluetooth functionality is turned off.

Parameters:
device_address A reference to a BtDeviceAddress where to store the local Bluetooth address.
Returns:
BtOk: The execution of the operation has finished successfully and device_address is valid.
BtError: The execution of the operation failed: Do not use device_address and check stack state for further information.

BtResultCode BtLocalSettings::GetLocalName ( WString & local_name ) const

Get local Bluetooth name.

GetLocalName queries the local Bluetooth name. This operation can be performed although the Bluetooth functionality is turned off.

Parameters:
local_name A reference to a WString where to store the local Bluetooth name.
Returns:
BtOk: The execution of the operation has finished successfully and local_name is valid.
BtError: The execution of the operation failed: Do not use local_name and check stack state for further information.

UINT32 BtLocalSettings::GetLocalSettingsId ( )

Get Unique id for this object.

GetLocalSettingsId return a unique identifier for each instantiated BtLocalSettings object.

Returns:
An UINT32 containing a unique id for this local settings object.

BtStackState BtLocalSettings::GetLocalState ( ) const

Get the local state.

em>GetLocalState queries the state of the Bluetooth Stack. This operation can be performed although the Bluetooth functionality is turned off.

Returns:
A BtStackState containing the current state of the Bluetooth Stack.

BtResultCode BtLocalSettings::GetPairableMode ( BtPairableMode & pairable_mode ) const

Get current pairability mode.

GetPairableMode queries the mode of pairability of the local Bluetooth settings. This operation can be performed although the Bluetooth functionality is turned off.

Parameters:
pairable_mode A reference to a BtPairableMode enumeration type where to store the mode of pairability.
Returns:
BtOk: The operation was successfully executed and the pairable_mode is valid.
BtError: The operation failed. Do not use the returned pairable_mode.

void BtLocalSettings::OnConnectableMode ( BtResultCode result ) [protected, virtual]

BtConnectabilityMessage message handler.

If a SetConnectableMode request is currently running in asynchronous mode or the connectablitiy has changed through an external event,.a message is sent to this function to indicate the progress of the ongoing operation respectively to indicate th chage of the connectablitiy.

Parameters:
result A BtResult indicating the result of the ongoing operation respectvely the change of the connectablitiy.
Returns:
TRUE: The message has been handled and no further handling of this message is necessary.
FALSE: The message has not been handled.

void BtLocalSettings::OnDiscoverableMode ( BtResultCode result ) [protected, virtual]

BtDiscoverabilityMessage message handler.

If a SetDiscoverableMode request is currently running in asynchronous mode or the discoverability has changed through an external event, a message is sent to this function to indicate the progress of the ongoing operation respectively to inidicate the change of the discoverability.

Parameters:
result A BtResult indicating the result of the ongoing operation respectvely the change of the discoverability.
Returns:
TRUE: The message has been handled and no further handling of this message is necessary.
FALSE: The message has not been handled.

void BtLocalSettings::OnLocalName ( BtResultCode result ) [protected, virtual]

BtLocalNameMessage message handler.

If a SetLocalName request is currently running in asynchronous mode or the local name changed through an external evant, a message is sent to this function to indicate the progress of the ongoing operation respectively to indicate the change of the local name.

Parameters:
result A BtResult indicating the result of the ongoing operation respectvely the change of the local name.
Returns:
TRUE: The message has been handled and no further handling of this message is necessary.
FALSE: The message has not been handled.

BOOLEAN BtLocalSettings::OnMessage ( const Message & message ) [protected, virtual]

General message handler.

Every message that is send to a dispatcher, is first sent to the OnMessage callback. This function can either handle the message or route the message forward to another function. This is done in this implementation. If the OnMessage function receives a message it checks if the message is valid for this object, then it routes it to one of the following callback functions. Otherwise the message is ignored and FALSE is returned.

Parameters:
message A reference to a Message or on of its subclasses, representing an event occured in the system.
Returns:
TRUE: The message has been handled and no further handling of this message is necessary.
FALSE: The message has not been handled.

Implements Dispatcher.

void BtLocalSettings::OnPairableMode ( BtResultCode result ) [protected, virtual]

BtPairabilityMessage message handler.

If a SetPairableMode request is currently running in asynchronous mode or the pairability has changed through an external event, a message is sent to this function to indicate the progress of the ongoing operation respectively to indicate the change of the pairability.

Parameters:
result A BtResult indicating the result of the ongoing operation respectvely the change of the pairability.
Returns:
TRUE: The message has been handled and no further handling of this message is necessary.
FALSE: The message has not been handled.

void BtLocalSettings::OnProfileActivation ( BtResultCode result ) [protected, virtual]

void BtLocalSettings::OnStateChange ( BtStackState stack_state ) [protected, virtual]

BtStateChangeMessage message handler.

If a TurnOn or TurnOff request is currently running in asynchronous mode or the state of the stack changed through an external event, a message is sent to this function to indicate a change in the stacks state

Parameters:
stack_state A BtStackState enumeration type containing the state to which the stack switched.
Returns:
TRUE: The message has been handled and no further handling of this message is necessary.
FALSE: The message has not been handled.

BtResultCode BtLocalSettings::SetConnectableMode | ( | BtConnectableMode | connectable_mode = BtCmConnectable,
 |  | BOOLEAN | execute_synchron = FALSE
 | ) |

Set current connectability mode.

SetConnectableMode sets the mode of connectability of the local Bluetooth settings. This operation can be perform although the Bluetooth functionality is turned off. If the parameter execute_synchron is set to FALSE the OnConnectableMode callback function is called to indicate the progress of the operation.

Parameters:
connectable_mode | A BtConnectableMode enumeration type containing the mode of connectability.
execute_synchron | A BOOLEAN indicating wether the operation should be executed synchronous or not.
Returns:
BtAccepted: The stack has accepted the operation and the execution is running (only possible if execute_synchron is FALSE).
BtRejected: The stack has rejected the operation because the parameters are not valid (only possible if execute_synchron is FALSE).
BtIgnored: The operation can not be executed due to another operation currently executed (only possible if execute_synchron is TRUE).
BtOk: The execution of the operation has finished successfully (only possible if execute_synchron is TRUE).
BtError: The execution of the operation failed. (only possible if execute_synchron is TRUE): Check stack state for further information.

BtResultCode BtLocalSettings::SetDiscoverableMode | ( | BtDiscoverableMode | discoverable_mode = BtDmGeneralDiscoverable,
 |  | BOOLEAN | execute_synchron = FALSE
 | ) |

Set current discoverability mode.

SetDiscoverableMode sets the mode of discoverability of the local Bluetooth settings. This operation can be performed although the Bluetooth functionality is turend of. If the parameter execute_synchron is set to FALSE the OnDiscoverableMode callback function is called to indicate the progress of the operation.

Parameters:
discoverable_mode | A BtDiscoverableModeenumeration type containing the mode of discoverability.
execute_synchron | A BOOLEAN indicating wether the operation should be executed synchronous or not.
Returns:
BtAccepted: The stack has accepted the operation and the execution is running (only possible if execute_synchron is FALSE).
BtRejected: The stack has rejected the operation because the parameters are not valid (only possible if execute_synchron is FALSE).
BtIgnored: The operation can not be executed due to another operation currently executed (only possible if execute_synchron is TRUE).
BtOk: The execution of the operation has finished successfully (only possible if execute_synchron is TRUE).
BtError: The execution of the operation failed. (only possible if execute_synchron is TRUE): Check stack state for further information.

BtResultCode BtLocalSettings::SetIsProfileActive | ( | BtProfile | profile,
 |  | BOOLEAN | active,
 |  | BOOLEAN | execute_synchron = FALSE
 | ) |

BtResultCode BtLocalSettings::SetLocalName | ( | const WString & | local_name,
 |  | BOOLEAN | execute_synchron = FALSE
 | ) |

Set local Bluetooth name.

SetLocalName sets the local Bluetooth name. This operation can be performed although the Bluetooth functionality is turned off. If the parameter execute_synchron is set to FALSE the OnLocalName callback function is called to indicate the progress of the operation.

Parameters:
local_name | A reference to aWString containing the new local Bluetooth name.
execute_synchron | A BOOLEAN indicating wether the operation should be executed synchronous or not.
Returns:
BtAccepted: The stack has accepted the operation and the execution is running (only possible if execute_synchron is FALSE).
BtRejected: The stack has rejected the operation because the parameters are not valid (only possible if execute_synchron is FALSE).
BtIgnored: The operation can not be executed due to another operation currently executed (only possible if execute_synchron is TRUE).
BtOk: The execution of the operation has finished successfully (only possible if execute_synchron is TRUE).
BtError: The execution of the operation failed. (only possible if execute_synchron is TRUE): Check stack state for further information.

BtResultCode BtLocalSettings::SetPairableMode | ( | BtPairableMode | pairable_mode = BtPmPairable,
 |  | BOOLEAN | execute_synchron = FALSE
 | ) |

Set current pairability mode.

SetPairableMode sets the mode of pairability of the local Bluetooth settings. This operation can be performed although the Bluetooth functionality is turned off. If the parameter execute_synchron is set to FALSE the OnPairableMode callback function is called to indicate the progress of the operation.

Parameters:
pairable_mode | A BtPairableMode enumeration type containing the mode of pairability.
execute_synchron | A BOOLEAN indicating wether the operation should be executed synchronous or not.
Returns:
BtAccepted: The stack has accepted the operation and the execution is running (only possible if execute_synchron is FALSE).
BtRejected: The stack has rejected the operation because the parameters are not valid (only possible if execute_synchron is FALSE).
BtIgnored: The operation can not be executed due to another operation currently executed (only possible if execute_synchron is TRUE).
BtOk: The execution of the operation has finished successfully (only possible if execute_synchron is TRUE).
BtError: The execution of the operation failed. (only possible if execute_synchron is TRUE): Check stack state for further information.

BtResultCode BtLocalSettings::TurnOff ( BOOLEAN execute_synchron = FALSE )

Turn Bluetooth functionality off.

TurnOff switches Bluetooth functionality off. This operation can be performed although the Bluetooth functionality is turned off. If the parameter execute_synchron is set to FALSE the OnStateChange callback function is called to indicate the progress of the operation.

Parameters:
execute_synchron A BOOLEAN indicating wether the operation should be executed synchronous or not.
Returns:
BtAccepted: The stack has accepted the operation and the execution is running (only possible if execute_synchron is FALSE).
BtRejected: The stack has rejected the operation because the parameters are not valid (only possible if execute_synchron is FALSE).
BtIgnored: The operation can not be executed due to another operation currently executed (only possible if execute_synchron is TRUE).
BtOk: The execution of the operation has finished successfully (only possible if execute_synchron is TRUE).
BtError: The execution of the operation failed. (only possible if execute_synchron is TRUE): Check stack state for further information.

BtResultCode BtLocalSettings::TurnOn ( BOOLEAN execute_synchron = FALSE )

Turn Bluetooth functionality on.

TurnOn switches Bluetooth functionality on.This operation can be performed although the Bluetooth functionality is turned off. If the parameter execute_synchron is set to FALSE the OnStateChange callback function is called to indicate the progress of the operation.

Parameters:
execute_synchron A BOOLEAN indicating wether the operation should be executed synchronous or not.
Returns:
BtAccepted: The stack has accepted the operation and the execution is running (only possible if execute_synchron is FALSE).
BtRejected: The stack has rejected the operation because the parameters are not valid (only possible if execute_synchron is FALSE).
BtIgnored: The operation can not be executed due to another operation currently executed (only possible if execute_synchron is TRUE).
BtOk: The execution of the operation has finished successfully (only possible if execute_synchron is TRUE).
BtError: The execution of the operation failed. (only possible if execute_synchron is TRUE): Check stack state for further information.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtLocalSettings.hpp
  • Bluetooth/BtLocalSettings.cpp
Generated on Wed Jan 25 01:01:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtLocalSettingsMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtLocalSettingsMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtLocalSettingsMessage:

[legend]
Collaboration diagram for BtLocalSettingsMessage:

[legend]

Public Types

enum | { ID = 10212 }

Public Member Functions

BtLocalSettingsMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtLocalSettingsMessage ()

Detailed Description

BtLocalSettingsMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtLocalSettingsMessage::BtLocalSettingsMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtLocalSettingsMessage::~BtLocalSettingsMessage ( ) [virtual]

Member Function Documentation

Message * BtLocalSettingsMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

Reimplemented in BtLocalNameMessage, BtDiscoverabilityMessage, BtPairabilityMessage, BtConnectabilityMessage, and BtProfileActivationMessage.

const MsgMetaData & BtLocalSettingsMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

Reimplemented in BtLocalNameMessage, BtDiscoverabilityMessage, BtPairabilityMessage, BtConnectabilityMessage, and BtProfileActivationMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:01:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtMultiConnectionController Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtMultiConnectionController Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtMultiConnectionController.hpp>

Inheritance diagram for BtMultiConnectionController:

[legend]
Collaboration diagram for BtMultiConnectionController:

[legend]

Public Member Functions

BtMultiConnectionController ()
Constructor.
virtual | ~BtMultiConnectionController ()
Destructor.

Protected Member Functions

BtServiceRequest * | CleanUpRequestExecution (void *apoxi_handle, BtResultCode result_code, BtRequestType request_type)
Finalize the execution of an currently executing request.
BtConnection * | FindConnectionByApoxiHandle (const void *apoxi_handle) const
BtConnection * | FindConnectionByDevice (const BtDevice &device) const
BtConnection * | FindConnectionByRequest (const BtServiceRequest *request) const
BtConnection * | GetFirstConnection () const
BtConnection * | GetNextConnection (const BtConnection *current) const
BOOLEAN | InsertConnection (BtConnection *connection_to_insert, const BtConnection *location=0)
virtual BOOLEAN | IsDeviceConnected (const BtDevice &device) const
BOOLEAN | PrepareRequestExecution (void *apoxi_handle, BtServiceRequest *request)
Perpare the execution of a submitted request.
BtConnection * | RemoveConnection (const BtConnection *connection_to_remove)

Protected Attributes

Mutex m_connection_list_mutex
Mutex to protect the m_connected_devices member variable.

Data Structures

class | BtConnection

Detailed Description

Some Bluetooth Profiles permit more than one remote device connection to itself. BtMultiConnectionController is the controller base class for such kind of profiles.

Constructor & Destructor Documentation

BtMultiConnectionController::BtMultiConnectionController ( )

Constructor.

BtMultiConnectionController::~BtMultiConnectionController ( ) [virtual]

Destructor.

Member Function Documentation

BtServiceRequest * BtMultiConnectionController::CleanUpRequestExecution | ( | void * | apoxi_handle,
 |  | BtResultCode | result_code,
 |  | BtRequestType | request_type
 | ) | [protected]

Finalize the execution of an currently executing request.

When a request is submitted to the Bluetooth stack for execution, the Bluetooth stack function can return FALSE, if the request is rejected by the Bluetooth stack, or the appropriate callback function is called to report the state of the ongoing request. In all of these cases CleanUpRequestExecution should be called.
CleanUpRequestExecution determines on the passed in parameters whether the member variable m_executing_request should be cleared or not. When CleanUpRequestExecution resets m_executing_request to 0, the id of the cleared request is returned.

Parameters:
result_code | A BtResultCode containing the result of the execution of the currently ongoing request.
request_type | A BtRequestType containing the kind of request for which the result code is passed in.
Returns:
((UINT32)(-1)) | Depending on result_code and request_type the function decided not to resest m_executing_request to 0.
Any other UINT32 | m_executing_request is set to 0 and the id of the finalized request is returned.

BtMultiConnectionController::BtConnection * BtMultiConnectionController::FindConnectionByApoxiHandle ( const void * apoxi_handle ) const [protected]

BtMultiConnectionController::BtConnection * BtMultiConnectionController::FindConnectionByDevice ( const BtDevice & device ) const [protected]

BtMultiConnectionController::BtConnection * BtMultiConnectionController::FindConnectionByRequest ( const BtServiceRequest * request ) const [protected]

BtMultiConnectionController::BtConnection * BtMultiConnectionController::GetFirstConnection ( ) const [protected]

BtMultiConnectionController::BtConnection * BtMultiConnectionController::GetNextConnection ( const BtConnection * current ) const [protected]

BOOLEAN BtMultiConnectionController::InsertConnection | ( | BtConnection * | connection_to_insert,
 |  | const BtConnection * | location = 0
 | ) | [protected]

BOOLEAN BtMultiConnectionController::IsDeviceConnected ( const BtDevice & device ) const [protected, virtual]

IsDeviceConnected is used by the BtService class to determine whether it's target is connected to it's profile or not.

Parameters:
device A reference to a BtDevice containing the remoted device that should be tested whether it is connected to this profile or not.
Returns:
TRUE | The passed in device is correct to this profile.
FALSE | The passed in device is not correct to this profile.

Implements BtConnectionBasedController.

BOOLEAN BtMultiConnectionController::PrepareRequestExecution | ( | void * | apoxi_handle,
 |  | BtServiceRequest * | request
 | ) | [protected]

Perpare the execution of a submitted request.

When a request is submitted to the controller for execution PrepareRequestExecution checks if an other request is currently running. If so the function returns FALSE, otherwise the member variable m_executing_request is set to point to the passed in request and TRUE is returned.

Parameters:
request A pointer to a BtRequest, that should be exectuted.
Returns:
TRUE | The passed in request can be executed.
FALSE | There is an other request currently running, so the passed in request can not be executed.

BtMultiConnectionController::BtConnection * BtMultiConnectionController::RemoveConnection ( const BtConnection * connection_to_remove ) [protected]

Field Documentation

Mutex BtMultiConnectionController::m_connection_list_mutex [protected]

Mutex to protect the m_connected_devices member variable.

The documentation for this class was generated from the following files:
  • Bluetooth/BtMultiConnectionController.hpp
  • Bluetooth/BtMultiConnectionController.cpp
Generated on Wed Jan 25 01:01:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtMultiConnectionController::BtConnection Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtMultiConnectionController::BtConnection

BtMultiConnectionController::BtConnection Class Reference

#include <Apoxi/Bluetooth/BtMultiConnectionController.hpp>

Inheritance diagram for BtMultiConnectionController::BtConnection:

[legend]
Collaboration diagram for BtMultiConnectionController::BtConnection:

[legend]

Public Member Functions

BtConnection ()
void * | GetApoxiHandle () const
const BtDevice & | GetDevice () const
BtConnection * | GetNext () const
BtServiceRequest * | GetRunningRequest () const
void | SetApoxiHandle (void *apoxi_handle)
void | SetDevice (const BtDevice &device)
void | SetNext (BtConnection *next)
void | SetRunningRequest (BtServiceRequest *request)
virtual | ~BtConnection ()

Constructor & Destructor Documentation

BtMultiConnectionController::BtConnection::BtConnection ( )

BtMultiConnectionController::BtConnection::~BtConnection ( ) [virtual]

Member Function Documentation

void * BtMultiConnectionController::BtConnection::GetApoxiHandle ( ) const

const BtDevice & BtMultiConnectionController::BtConnection::GetDevice ( ) const

BtMultiConnectionController::BtConnection * BtMultiConnectionController::BtConnection::GetNext ( ) const

BtServiceRequest * BtMultiConnectionController::BtConnection::GetRunningRequest ( ) const

void BtMultiConnectionController::BtConnection::SetApoxiHandle ( void * apoxi_handle )

void BtMultiConnectionController::BtConnection::SetDevice ( const BtDevice & device )

void BtMultiConnectionController::BtConnection::SetNext ( BtConnection * next )

void BtMultiConnectionController::BtConnection::SetRunningRequest ( BtServiceRequest * request )

The documentation for this class was generated from the following files:
  • Bluetooth/BtMultiConnectionController.hpp
  • Bluetooth/BtMultiConnectionController.cpp
Generated on Wed Jan 25 01:01:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexAbortRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexAbortRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexAbortRequest.hpp>

Inheritance diagram for BtObexAbortRequest:

[legend]
Collaboration diagram for BtObexAbortRequest:

[legend]

Public Member Functions

BtObexAbortRequest (BtObexClientService &obex_client_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
virtual | ~BtObexAbortRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexAbortRequest::BtObexAbortRequest ( BtObexClientService & obex_client_service )

Constructor.

BtObexAbortRequest::~BtObexAbortRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexAbortRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexAbortRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

BtRequestType BtObexAbortRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexClientOperationRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexAbortRequest.hpp
  • Bluetooth/OBEX/BtObexAbortRequest.cpp
Generated on Wed Jan 25 01:01:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientAbortEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientAbortEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexClientAbortEvent:

[legend]
Collaboration diagram for BtObexClientAbortEvent:

[legend]

Public Types

enum | { ID = 20 }

Public Member Functions

BtObexClientAbortEvent (BtResultCode resul, UINT8 response_code)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexClientAbortEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientAbortEvent::BtObexClientAbortEvent | ( | BtResultCode | resul,
 |  | UINT8 | response_code
 | ) |

Constructor.

BtObexClientAbortEvent::~BtObexClientAbortEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexClientAbortEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientAddr Class Reference

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp>

Inheritance diagram for BtObexClientAddr:

[legend]
Collaboration diagram for BtObexClientAddr:

[legend]

Public Member Functions

void | BtObexSetClientAddrInfo (const UINT8 *remote_addr, UINT8 remote_channel)
Deprecated !!! Set relevant address info for a Client.
const BtDeviceAddress & | GetDeviceAddress () const
void | GetRemoteAddr (UINT8 *remote_addr)
Deprecated !!!
UINT8 | GetRemoteRfComm ()
Deprecated !!!
UINT8 | GetRfCommChannel () const
BtSecuritySettings | GetSecurity () const
virtual ObexResult | ToString (String &obex_url) const
Converts the ObexAddrInfo into string format.

Static Public Member Functions

static SharedPtr< BtObexClientAddr > | Create (BtSecuritySettings security=BtSesNoSecurity, const BtDeviceAddress &device_addr=bt_c_empty_device_address, UINT8 rfcomm_chan=0)
Instantiate a Client Address by a common static entry point (factory class).

Protected Member Functions

BtObexClientAddr (BtSecuritySettings security, const BtDeviceAddress &device_addr, UINT8 rfcomm_chan)
Constructor. Should be only invoked by Create() method or derived classes.

Friends

class | BtObexTransport

Detailed Description

Class for manipulating a Client Obex Address.

Constructor & Destructor Documentation

BtObexClientAddr::BtObexClientAddr | ( | BtSecuritySettings | security,
 |  | const BtDeviceAddress & | device_addr,
 |  | UINT8 | rfcomm_chan
 | ) | [protected]

Constructor. Should be only invoked by Create() method or derived classes.

Member Function Documentation

void BtObexClientAddr::BtObexSetClientAddrInfo | ( | const UINT8 * | remote_addr,
 |  | UINT8 | remote_channel
 | ) |

Deprecated !!! Set relevant address info for a Client.

Parameters:
remote_addr | the BD_ADDR of the remote device
remote_channel | the remote rfcomm port

SharedPtr< BtObexClientAddr > BtObexClientAddr::Create | ( | BtSecuritySettings | security = BtSesNoSecurity,
 |  | const BtDeviceAddress & | device_addr = bt_c_empty_device_address,
 |  | UINT8 | rfcomm_chan = 0
 | ) | [static]

Instantiate a Client Address by a common static entry point (factory class).

const BtDeviceAddress& BtObexClientAddr::GetDeviceAddress ( ) const [inline]

void BtObexClientAddr::GetRemoteAddr ( UINT8 * remote_addr )

Deprecated !!!

UINT8 BtObexClientAddr::GetRemoteRfComm ( ) [inline]

Deprecated !!!

UINT8 BtObexClientAddr::GetRfCommChannel ( ) const [inline]

BtSecuritySettings BtObexClientAddr::GetSecurity ( ) const [inline]

ObexResult BtObexClientAddr::ToString ( String & obex_url ) const [virtual]

Converts the ObexAddrInfo into string format.

Parameters:
obex_url String to append the result to
Returns:
TRUE if the conversion was successful, FALSE otherwise.

Reimplemented from ObexAddress.

Friends And Related Function Documentation

friend class BtObexTransport [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexImplAddress.cpp
Generated on Wed Jan 25 01:01:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientAddrResultNotifier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientAddrResultNotifier Class Reference

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.hpp>

Inheritance diagram for BtObexClientAddrResultNotifier:

[legend]
Collaboration diagram for BtObexClientAddrResultNotifier:

[legend]

Static Public Member Functions

static SharedPtr< BtObexClientAddrResultNotifier > | Create (const ObexOperationId &job_id, BtSecuritySettings security, const BtDeviceAddress &device_addr, UINT8 rfcomm_chan)

Protected Member Functions

BtObexClientAddrResultNotifier (const ObexOperationId &job_id, BtSecuritySettings security, const BtDeviceAddress &device_addr, UINT8 rfcomm_chan)
virtual void | OnResult (BtResultCode result)

Constructor & Destructor Documentation

BtObexClientAddrResultNotifier::BtObexClientAddrResultNotifier | ( | const ObexOperationId & | job_id,
 |  | BtSecuritySettings | security,
 |  | const BtDeviceAddress & | device_addr,
 |  | UINT8 | rfcomm_chan
 | ) | [protected]

Member Function Documentation

SharedPtr< BtObexClientAddrResultNotifier > BtObexClientAddrResultNotifier::Create | ( | const ObexOperationId & | job_id,
 |  | BtSecuritySettings | security,
 |  | const BtDeviceAddress & | device_addr,
 |  | UINT8 | rfcomm_chan
 | ) | [static]

void BtObexClientAddrResultNotifier::OnResult ( BtResultCode result ) [protected, virtual]

Implements BtOperationBase.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexClientAddrResultNotifier.cpp
Generated on Wed Jan 25 01:01:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientConnectEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientConnectEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexClientConnectEvent:

[legend]
Collaboration diagram for BtObexClientConnectEvent:

[legend]

Public Types

enum | { ID = 15 }

Public Member Functions

BtObexClientConnectEvent (BtResultCode result, UINT8 response_code)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexClientConnectEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientConnectEvent::BtObexClientConnectEvent | ( | BtResultCode | result,
 |  | UINT8 | response_code
 | ) |

Constructor.

BtObexClientConnectEvent::~BtObexClientConnectEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexClientConnectEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientDisconnectEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientDisconnectEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexClientDisconnectEvent:

[legend]
Collaboration diagram for BtObexClientDisconnectEvent:

[legend]

Public Types

enum | { ID = 16 }

Public Member Functions

BtObexClientDisconnectEvent (BtResultCode result, UINT8 response_code)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexClientDisconnectEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientDisconnectEvent::BtObexClientDisconnectEvent | ( | BtResultCode | result,
 |  | UINT8 | response_code
 | ) |

Constructor.

BtObexClientDisconnectEvent::~BtObexClientDisconnectEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexClientDisconnectEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexClientEvent:

[legend]
Collaboration diagram for BtObexClientEvent:

[legend]

Public Member Functions

BtObexClientEvent (BtResultCode result)
Constructor.
virtual ~BtObexClientEvent ()
Destructor.

Constructor & Destructor Documentation

BtObexClientEvent::BtObexClientEvent ( BtResultCode result )

Constructor.

BtObexClientEvent::~BtObexClientEvent ( ) [virtual]

Destructor.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientGetEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientGetEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexClientGetEvent:

[legend]
Collaboration diagram for BtObexClientGetEvent:

[legend]

Public Types

enum | { ID = 18 }

Public Member Functions

BtObexClientGetEvent (BtResultCode result, UINT8 response_code)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexClientGetEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientGetEvent::BtObexClientGetEvent | ( | BtResultCode | result,
 |  | UINT8 | response_code
 | ) |

Constructor.

BtObexClientGetEvent::~BtObexClientGetEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexClientGetEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientNmaDataBufferIndication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientNmaDataBufferIndication Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexClientNmaDataBufferIndication:

[legend]
Collaboration diagram for BtObexClientNmaDataBufferIndication:

[legend]

Public Types

enum | { ID = 42 }

Public Member Functions

BtObexClientNmaDataBufferIndication ()
BtObexClientNmaDataBufferIndication (const BtResultCode &result, UINT16 number_of_bytes, BOOLEAN delete_object, BOOLEAN create_empty)
UINT16 | GetNumberOfBytes () const
const BtResultCode & | GetResult () const
BOOLEAN | IsCreateEmpty () const
BOOLEAN | IsDeleteObject () const
~BtObexClientNmaDataBufferIndication ()

Static Public Member Functions

static const BtObexClientNmaDataBufferIndication & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexClientNmaDataBufferIndication

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientNmaDataBufferIndication::BtObexClientNmaDataBufferIndication | ( | const BtResultCode & | result,
 |  | UINT16 | number_of_bytes,
 |  | BOOLEAN | delete_object,
 |  | BOOLEAN | create_empty
 | ) |

BtObexClientNmaDataBufferIndication::BtObexClientNmaDataBufferIndication ( )

BtObexClientNmaDataBufferIndication::~BtObexClientNmaDataBufferIndication ( )

Member Function Documentation

const BtObexClientNmaDataBufferIndication & BtObexClientNmaDataBufferIndication::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT16 BtObexClientNmaDataBufferIndication::GetNumberOfBytes ( ) const [inline]

const BtResultCode& BtObexClientNmaDataBufferIndication::GetResult ( ) const [inline]

BOOLEAN BtObexClientNmaDataBufferIndication::IsCreateEmpty ( ) const [inline]

BOOLEAN BtObexClientNmaDataBufferIndication::IsDeleteObject ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientNmaDataInidication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientNmaDataInidication Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexClientNmaDataInidication:

[legend]
Collaboration diagram for BtObexClientNmaDataInidication:

[legend]

Public Types

enum | { ID = 43 }

Public Member Functions

BtObexClientNmaDataInidication ()
BtObexClientNmaDataInidication (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexClientNmaDataInidication ()

Static Public Member Functions

static const BtObexClientNmaDataInidication & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexClientNmaDataInidication

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientNmaDataInidication::BtObexClientNmaDataInidication ( const BtResultCode & result )

BtObexClientNmaDataInidication::BtObexClientNmaDataInidication ( )

BtObexClientNmaDataInidication::~BtObexClientNmaDataInidication ( )

Member Function Documentation

const BtObexClientNmaDataInidication & BtObexClientNmaDataInidication::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexClientNmaDataInidication::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientNmaHeaderIndication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientNmaHeaderIndication Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexClientNmaHeaderIndication:

[legend]
Collaboration diagram for BtObexClientNmaHeaderIndication:

[legend]

Public Types

enum | { ID = 41 }

Public Member Functions

BtObexClientNmaHeaderIndication ()
BtObexClientNmaHeaderIndication (const BtResultCode &result, const BtObexHeader &header)
const BtObexHeader & | GetHeader () const
const BtResultCode & | GetResult () const
~BtObexClientNmaHeaderIndication ()

Static Public Member Functions

static const BtObexClientNmaHeaderIndication & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexClientNmaHeaderIndication

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientNmaHeaderIndication::BtObexClientNmaHeaderIndication | ( | const BtResultCode & | result,
 |  | const BtObexHeader & | header
 | ) |

BtObexClientNmaHeaderIndication::BtObexClientNmaHeaderIndication ( )

BtObexClientNmaHeaderIndication::~BtObexClientNmaHeaderIndication ( )

Member Function Documentation

const BtObexClientNmaHeaderIndication & BtObexClientNmaHeaderIndication::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtObexHeader& BtObexClientNmaHeaderIndication::GetHeader ( ) const [inline]

const BtResultCode& BtObexClientNmaHeaderIndication::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientNmaHeaderSent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientNmaHeaderSent Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexClientNmaHeaderSent:

[legend]
Collaboration diagram for BtObexClientNmaHeaderSent:

[legend]

Public Types

enum | { ID = 40 }

Public Member Functions

BtObexClientNmaHeaderSent ()
BtObexClientNmaHeaderSent (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexClientNmaHeaderSent ()

Static Public Member Functions

static const BtObexClientNmaHeaderSent & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexClientNmaHeaderSent

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientNmaHeaderSent::BtObexClientNmaHeaderSent ( const BtResultCode & result )

BtObexClientNmaHeaderSent::BtObexClientNmaHeaderSent ( )

BtObexClientNmaHeaderSent::~BtObexClientNmaHeaderSent ( )

Member Function Documentation

const BtObexClientNmaHeaderSent & BtObexClientNmaHeaderSent::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexClientNmaHeaderSent::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientNmaTransportDisconnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientNmaTransportDisconnect Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexClientNmaTransportDisconnect:

[legend]
Collaboration diagram for BtObexClientNmaTransportDisconnect:

[legend]

Public Types

enum | { ID = 44 }

Public Member Functions

BtObexClientNmaTransportDisconnect ()
BtObexClientNmaTransportDisconnect (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexClientNmaTransportDisconnect ()

Static Public Member Functions

static const BtObexClientNmaTransportDisconnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexClientNmaTransportDisconnect

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientNmaTransportDisconnect::BtObexClientNmaTransportDisconnect ( const BtResultCode & result )

BtObexClientNmaTransportDisconnect::BtObexClientNmaTransportDisconnect ( )

BtObexClientNmaTransportDisconnect::~BtObexClientNmaTransportDisconnect ( )

Member Function Documentation

const BtObexClientNmaTransportDisconnect & BtObexClientNmaTransportDisconnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexClientNmaTransportDisconnect::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientNotificationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientNotificationMessage Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessage.hpp>

Inheritance diagram for BtObexClientNotificationMessage:

[legend]
Collaboration diagram for BtObexClientNotificationMessage:

[legend]

Public Types

enum | { ID = 10107 }

Public Member Functions

BtObexClientNotificationMessage (const BtObexClientNotificationMessage &message)
Constructor.
BtObexClientNotificationMessage (BtObexClientService *service, StackMsgArgument *argument=0)
Constructor.
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BtObexClientService * | GetService () const
virtual BtObexClientNotificationMessage & | operator= (const BtObexClientNotificationMessage &message)
virtual FromStackMsg & | operator= (const FromStackMsg &message)
virtual | ~BtObexClientNotificationMessage ()
Destructor.
The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessage.hpp
  • Bluetooth/OBEX/BtObexNotificationMessage.cpp
Generated on Wed Jan 25 01:01:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientObserverImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientObserverImpl Class Reference

This class contains the implementation of the Client Service Observer, related to the Bt stack/controller callbacks for Obex Client operations (Connect, Put, Get, ...). More...

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp>

Inheritance diagram for BtObexClientObserverImpl:

[legend]
Collaboration diagram for BtObexClientObserverImpl:

[legend]

Public Member Functions

BtObexClientObserverImpl ()
Constructor.
virtual | ~BtObexClientObserverImpl ()
Destructor.

Protected Member Functions

virtual void | OnAbort (BtResultCode code, UINT8 response_code)
virtual void | OnBufferRequested (BtResultCode result, UINT16 last_buffer_filled, BOOLEAN delete_object, BOOLEAN create_empty_object)
virtual void | OnConnect (BtResultCode code, UINT8 response_code)
virtual void | OnDataRequested (BtResultCode result)
virtual void | OnDisconnect (BtResultCode code, UINT8 response_code)
virtual void | OnError (BtObexErrorCode error)
virtual void | OnGet (BtResultCode code, UINT8 response_code)
virtual void | OnHeader (BtResultCode result, const BtObexHeader &header)
virtual void | OnHeaderSent (BtResultCode resul)
virtual void | OnPut (BtResultCode code, UINT8 response_code)
virtual void | OnRegister (BtResultCode code)
virtual void | OnResponse (BtResultCode code, UINT8 response_code)
virtual void | OnSetPath (BtResultCode code, UINT8 response_code)
virtual void | OnTransportDisconnect (BtResultCode result)
virtual void | OnUnregister (BtResultCode result)

Friends

class | BtObexImpl
The BtObexImpl can access BtObexServerObserverImpl.

Detailed Description

This class contains the implementation of the Client Service Observer, related to the Bt stack/controller callbacks for Obex Client operations (Connect, Put, Get, ...).

Constructor & Destructor Documentation

BtObexClientObserverImpl::BtObexClientObserverImpl ( )

Constructor.

BtObexClientObserverImpl::~BtObexClientObserverImpl ( ) [virtual]

Destructor.

Member Function Documentation

void BtObexClientObserverImpl::OnAbort | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, virtual]

Implements BtObexClientServiceObserver.

void BtObexClientObserverImpl::OnBufferRequested | ( | BtResultCode | result,
 |  | UINT16 | last_buffer_filled,
 |  | BOOLEAN | delete_object,
 |  | BOOLEAN | create_empty_object
 | ) | [protected, virtual]

Implements BtObexServiceObserver.

void BtObexClientObserverImpl::OnConnect | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, virtual]

Implements BtObexClientServiceObserver.

void BtObexClientObserverImpl::OnDataRequested ( BtResultCode result ) [protected, virtual]

Implements BtObexServiceObserver.

void BtObexClientObserverImpl::OnDisconnect | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, virtual]

Implements BtObexClientServiceObserver.

virtual void BtObexClientObserverImpl::OnError ( BtObexErrorCode error ) [inline, protected, virtual]

Implements BtObexServiceObserver.

void BtObexClientObserverImpl::OnGet | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, virtual]

Implements BtObexClientServiceObserver.

void BtObexClientObserverImpl::OnHeader | ( | BtResultCode | result,
 |  | const BtObexHeader & | header
 | ) | [protected, virtual]

Implements BtObexServiceObserver.

virtual void BtObexClientObserverImpl::OnHeaderSent ( BtResultCode resul ) [inline, protected, virtual]

Implements BtObexServiceObserver.

void BtObexClientObserverImpl::OnPut | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, virtual]

Implements BtObexClientServiceObserver.

void BtObexClientObserverImpl::OnRegister ( BtResultCode code ) [protected, virtual]

Implements BtObexClientServiceObserver.

void BtObexClientObserverImpl::OnResponse | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, virtual]

void BtObexClientObserverImpl::OnSetPath | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, virtual]

Implements BtObexClientServiceObserver.

void BtObexClientObserverImpl::OnTransportDisconnect ( BtResultCode result ) [protected, virtual]

Implements BtObexServiceObserver.

void BtObexClientObserverImpl::OnUnregister ( BtResultCode result ) [protected, virtual]

Implements BtObexServiceObserver.

Friends And Related Function Documentation

friend class BtObexImpl [friend]

The BtObexImpl can access BtObexServerObserverImpl.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexClientObserverImpl.cpp
Generated on Wed Jan 25 01:01:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientOperationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientOperationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexClientOperationEvent:

[legend]
Collaboration diagram for BtObexClientOperationEvent:

[legend]

Public Member Functions

BtObexClientOperationEvent (BtResultCode result, UINT8 response_code)
Constructor.
UINT8 | GetResponseCode () const
virtual | ~BtObexClientOperationEvent ()
Destructor.

Constructor & Destructor Documentation

BtObexClientOperationEvent::BtObexClientOperationEvent | ( | BtResultCode | result,
 |  | UINT8 | response_code
 | ) |

Constructor.

BtObexClientOperationEvent::~BtObexClientOperationEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT8 BtObexClientOperationEvent::GetResponseCode ( ) const

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientOperationRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientOperationRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexClientOperationRequest.hpp>

Inheritance diagram for BtObexClientOperationRequest:

[legend]
Collaboration diagram for BtObexClientOperationRequest:

[legend]

Public Member Functions

BtObexClientOperationRequest (BtObexService &obex_service)
Constructor.
BOOLEAN | GetAborted () const
UINT8 | GetResponseCode () const
void | SetResponseCode (UINT8 response_code)
virtual | ~BtObexClientOperationRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | GetAcceptAbort () const
void | SetAborted (BOOLEAN aborted)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexClientOperationRequest::BtObexClientOperationRequest ( BtObexService & obex_service )

Constructor.

BtObexClientOperationRequest::~BtObexClientOperationRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexClientOperationRequest::GetAborted ( ) const

BOOLEAN BtObexClientOperationRequest::GetAcceptAbort ( ) const [protected, virtual]

Reimplemented in BtObexGetRequest, and BtObexPutRequest.

UINT8 BtObexClientOperationRequest::GetResponseCode ( ) const

void BtObexClientOperationRequest::SetAborted ( BOOLEAN aborted ) [protected]

void BtObexClientOperationRequest::SetResponseCode ( UINT8 response_code )

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexRequest.

Reimplemented in BtObexAbortRequest, BtObexConnectRequest, BtObexDisconnectRequest, BtObexGetRequest, BtObexPutRequest, and BtObexSetPathRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexClientOperationRequest.hpp
  • Bluetooth/OBEX/BtObexClientOperationRequest.cpp
Generated on Wed Jan 25 01:01:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientPutEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientPutEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexClientPutEvent:

[legend]
Collaboration diagram for BtObexClientPutEvent:

[legend]

Public Types

enum | { ID = 19 }

Public Member Functions

BtObexClientPutEvent (BtResultCode result, UINT8 response_code)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexClientPutEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientPutEvent::BtObexClientPutEvent | ( | BtResultCode | result,
 |  | UINT8 | response_code
 | ) |

Constructor.

BtObexClientPutEvent::~BtObexClientPutEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexClientPutEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexServiceMessage.hpp>

Inheritance diagram for BtObexClientRequestStateChangedMessage:

[legend]
Collaboration diagram for BtObexClientRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10340 }

Public Member Functions

BtObexClientRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtObexClientRequestStateChangedMessage ()

Detailed Description

BtObexClientRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtRequestStateChangedMessage.

Constructor & Destructor Documentation

BtObexClientRequestStateChangedMessage::BtObexClientRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtObexClientRequestStateChangedMessage::~BtObexClientRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtObexClientRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtObexClientRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexServiceMessage.hpp
  • Bluetooth/OBEX/BtObexServiceMessage.cpp
Generated on Wed Jan 25 01:01:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexClientService.hpp>

Inheritance diagram for BtObexClientService:

[legend]
Collaboration diagram for BtObexClientService:

[legend]

Public Member Functions

BtRequestState AbortRequest ()
BOOLEAN | Attach (BtObexClientServiceObserver *service_observer)
BtObexClientService ()
Constructor.
BtRequestState ConnectRequest ()
BOOLEAN | DataBufferIndication (UINT8 *data_buffer, UINT16 data_buffer_size)
BOOLEAN | DataReadyIndication (const UINT8 *data, UINT16 data_size, BOOLEAN more_data_pending=FALSE)
BOOLEAN | Detach (BtObexClientServiceObserver *service_observer)
BtRequestState DisconnectRequest ()
BtRequestState GetRequest ()
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
UINT8 | GetRfComPort () const
BOOLEAN | IsConnected () const
virtual BOOLEAN | IsServerService () const
BtRequestState | PutRequest (BOOLEAN delete_object, BOOLEAN create_empty_object)
virtual BtRequestState | RegisterRequest (UINT8 *header_buffer, UINT16 header_buffer_size, BtSecuritySettings security_settings=BtSesNoSecurity)
BtRequestState | SetPathRequest (BOOLEAN backup, BOOLEAN create)
void | SetRfComPort (UINT8 rf_com_port)
virtual BtRequestState | UnregisterRequest ()
virtual | ~BtObexClientService ()
Destructor.

Friends

class | BtObexAbortRequest
class | BtObexConnectRequest
class | BtObexDisconnectRequest
class | BtObexGetRequest
class | BtObexPutRequest
class | BtObexRegisterClientRequest
class | BtObexSetPathRequest
class | BtObexUnregisterClientRequest

Constructor & Destructor Documentation

BtObexClientService::BtObexClientService ( )

Constructor.

BtObexClientService::~BtObexClientService ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtObexClientService::AbortRequest ( )

BOOLEAN BtObexClientService::Attach ( BtObexClientServiceObserver * service_observer )

BtRequestState BtObexClientService::ConnectRequest ( )

BOOLEAN BtObexClientService::DataBufferIndication | ( | UINT8 * | data_buffer,
 |  | UINT16 | data_buffer_size
 | ) |

BOOLEAN BtObexClientService::DataReadyIndication | ( | const UINT8 * | data,
 |  | UINT16 | data_size,
 |  | BOOLEAN | more_data_pending = FALSE
 | ) |

BOOLEAN BtObexClientService::Detach ( BtObexClientServiceObserver * service_observer )

BtRequestState BtObexClientService::DisconnectRequest ( )

BtRequestState BtObexClientService::GetRequest ( )

BtRequestState BtObexClientService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

UINT8 BtObexClientService::GetRfComPort ( ) const

BOOLEAN BtObexClientService::IsConnected ( ) const

BOOLEAN BtObexClientService::IsServerService ( ) const [virtual]

Implements BtObexService.

BtRequestState BtObexClientService::PutRequest | ( | BOOLEAN | delete_object,
 |  | BOOLEAN | create_empty_object
 | ) |

BtRequestState BtObexClientService::RegisterRequest | ( | UINT8 * | header_buffer,
 |  | UINT16 | header_buffer_size,
 |  | BtSecuritySettings | security_settings = BtSesNoSecurity
 | ) | [virtual]

Implements BtObexService.

BtRequestState BtObexClientService::SetPathRequest | ( | BOOLEAN | backup,
 |  | BOOLEAN | create
 | ) |

void BtObexClientService::SetRfComPort ( UINT8 rf_com_port )

BtRequestState BtObexClientService::UnregisterRequest ( ) [virtual]

Implements BtObexService.

Friends And Related Function Documentation

friend class BtObexAbortRequest [friend]

friend class BtObexConnectRequest [friend]

friend class BtObexDisconnectRequest [friend]

friend class BtObexGetRequest [friend]

friend class BtObexPutRequest [friend]

friend class BtObexRegisterClientRequest [friend]

friend class BtObexSetPathRequest [friend]

friend class BtObexUnregisterClientRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexClientService.hpp
  • Bluetooth/OBEX/BtObexClientService.cpp
Generated on Wed Jan 25 01:01:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientServiceImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientServiceImpl Class Reference

This class contains the extension of the BtObexClientService class. More...

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp>

Inheritance diagram for BtObexClientServiceImpl:

[legend]
Collaboration diagram for BtObexClientServiceImpl:

[legend]

Public Member Functions

BtObexClientServiceImpl ()
virtual | ~BtObexClientServiceImpl ()

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
Notification function of changes in running requests.

Detailed Description

This class contains the extension of the BtObexClientService class.

This is necessary because the mother class contains one pure virtual function (currently unused in the Bt Obex Transport Adapter implementation)

Constructor & Destructor Documentation

BtObexClientServiceImpl::BtObexClientServiceImpl ( )

BtObexClientServiceImpl::~BtObexClientServiceImpl ( ) [virtual]

Member Function Documentation

void BtObexClientServiceImpl::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Notification function of changes in running requests.

Whenever the state of a request contained in this service is changed OnRequestStateChange will be called. This function should give the application programmer to do some GUI reaction to the progress or the failure of a partikular request.
This function has to be implemented by the application programmer, so in the base classes this function is pure virtual.

Parameters:
request_type | A BtRequestType enumeration type describing which kind of request has changed its state.
old_request_state | A BtRequestState enumeration type containing the state of the request before the state transition.
new_request_state | A BtRequestState enumeration type containing the state of the request after the state transition.

Implements BtService.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexClientServiceImpl.cpp
Generated on Wed Jan 25 01:01:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientServiceObserver Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientServiceObserver Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexClientServiceObserver.hpp>

Inheritance diagram for BtObexClientServiceObserver:

[legend]
Collaboration diagram for BtObexClientServiceObserver:

[legend]

Public Member Functions

BtObexClientServiceObserver ()
Constructor.
virtual | ~BtObexClientServiceObserver ()
Destructor.

Protected Member Functions

virtual void | OnAbort (BtResultCode code, UINT8 response_code)=0
virtual void | OnConnect (BtResultCode code, UINT8 response_code)=0
virtual void | OnDisconnect (BtResultCode code, UINT8 response_code)=0
virtual void | OnEvent (const BtEvent &event)
virtual void | OnGet (BtResultCode code, UINT8 response_code)=0
virtual void | OnPut (BtResultCode code, UINT8 response_code)=0
virtual void | OnRegister (BtResultCode code)=0
virtual void | OnSetPath (BtResultCode code, UINT8 response_code)=0

Friends

class | BtObexClientService

Constructor & Destructor Documentation

BtObexClientServiceObserver::BtObexClientServiceObserver ( )

Constructor.

BtObexClientServiceObserver::~BtObexClientServiceObserver ( ) [virtual]

Destructor.

Member Function Documentation

virtual void BtObexClientServiceObserver::OnAbort | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, pure virtual]

Implemented in BtObexClientObserverImpl.

virtual void BtObexClientServiceObserver::OnConnect | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, pure virtual]

Implemented in BtObexClientObserverImpl.

virtual void BtObexClientServiceObserver::OnDisconnect | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, pure virtual]

Implemented in BtObexClientObserverImpl.

void BtObexClientServiceObserver::OnEvent ( const BtEvent & event ) [protected, virtual]

Reimplemented from BtObexServiceObserver.

virtual void BtObexClientServiceObserver::OnGet | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, pure virtual]

Implemented in BtObexClientObserverImpl.

virtual void BtObexClientServiceObserver::OnPut | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, pure virtual]

Implemented in BtObexClientObserverImpl.

virtual void BtObexClientServiceObserver::OnRegister ( BtResultCode code ) [protected, pure virtual]

Implemented in BtObexClientObserverImpl.

virtual void BtObexClientServiceObserver::OnSetPath | ( | BtResultCode | code,
 |  | UINT8 | response_code
 | ) | [protected, pure virtual]

Implemented in BtObexClientObserverImpl.

Friends And Related Function Documentation

friend class BtObexClientService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexClientServiceObserver.hpp
  • Bluetooth/OBEX/BtObexClientServiceObserver.cpp
Generated on Wed Jan 25 01:01:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexClientSetPathEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexClientSetPathEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexClientSetPathEvent:

[legend]
Collaboration diagram for BtObexClientSetPathEvent:

[legend]

Public Types

enum | { ID = 17 }

Public Member Functions

BtObexClientSetPathEvent (BtResultCode result, UINT8 response_code)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexClientSetPathEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexClientSetPathEvent::BtObexClientSetPathEvent | ( | BtResultCode | result,
 |  | UINT8 | response_code
 | ) |

Constructor.

BtObexClientSetPathEvent::~BtObexClientSetPathEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexClientSetPathEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexConnectRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexConnectRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexConnectRequest.hpp>

Inheritance diagram for BtObexConnectRequest:

[legend]
Collaboration diagram for BtObexConnectRequest:

[legend]

Public Member Functions

BtObexConnectRequest (BtObexClientService &obex_client_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
UINT8 | GetRfComPort () const
BtDevice | GetTargetDevice () const
void | SetRfComPort (UINT8 rfcom_port)
void | SetTargetDevice (const BtDevice &target_device)
virtual | ~BtObexConnectRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexConnectRequest::BtObexConnectRequest ( BtObexClientService & obex_client_service )

Constructor.

BtObexConnectRequest::~BtObexConnectRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexConnectRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexConnectRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

BtRequestType BtObexConnectRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

UINT8 BtObexConnectRequest::GetRfComPort ( ) const

BtDevice BtObexConnectRequest::GetTargetDevice ( ) const

void BtObexConnectRequest::SetRfComPort ( UINT8 rfcom_port )

void BtObexConnectRequest::SetTargetDevice ( const BtDevice & target_device )

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexClientOperationRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexConnectRequest.hpp
  • Bluetooth/OBEX/BtObexConnectRequest.cpp
Generated on Wed Jan 25 01:01:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexController Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexController Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexController.hpp>

Inheritance diagram for BtObexController:

[legend]
Collaboration diagram for BtObexController:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual | ~BtObexController ()
Destructor.

Static Public Member Functions

static BtObexController & | GetInstance ()
Get singleton instance.

Protected Member Functions

BOOLEAN | ObexAbortRequest (BtObexAbortRequest *abort_request)
BOOLEAN | ObexAddHeader (const BtObexService *obex_service, UINT8 header_id, WString header_value)
BOOLEAN | ObexAddHeader (const BtObexService *obex_service, UINT8 header_id, UINT8 *header_value, UINT16 header_value_length)
BOOLEAN | ObexAddHeader (const BtObexService *obex_service, UINT8 header_id, UINT32 header_value)
BOOLEAN | ObexAddHeader (const BtObexService *obex_service, UINT8 header_id, UINT8 header_value)
BOOLEAN | ObexConnectRequest (BtObexConnectRequest *connect_request)
BOOLEAN | ObexDataBufferIndication (const BtObexService *obex_service, UINT8 *data_buffer, UINT16 data_buffer_size, UINT8 response_code)
BOOLEAN | ObexDataIndication (const BtObexService *obex_service, const UINT8 *data, UINT16 data_size, BOOLEAN more_data_pending, UINT8 response_code)
BOOLEAN | ObexDiscardHeaders (const BtObexService *obex_service)
BOOLEAN | ObexDisconnectRequest (BtObexDisconnectRequest *disconnect_request)
BOOLEAN | ObexGetFreeSize (const BtObexService *obex_service, UINT16 &bytes_free)
BOOLEAN | ObexGetRequest (BtObexGetRequest *get_request)
BOOLEAN | ObexPutRequest (BtObexPutRequest *put_request)
BOOLEAN | ObexRegisterClientRequest (BtObexRegisterClientRequest *register_request)
BOOLEAN | ObexRegisterServerRequest (BtObexRegisterServerRequest *register_request)
BOOLEAN | ObexSendResponse (const BtObexService *obex_service, UINT8 response_code)
BOOLEAN | ObexSetPathRequest (BtObexSetPathRequest *set_path_request)
BOOLEAN | ObexUnregisterClientRequest (BtObexUnregisterClientRequest *unregister_request)
BOOLEAN | ObexUnregisterServerRequest (BtObexUnregisterServerRequest *unregister_request)

Friends

class | BtObexAbortRequest
class | BtObexClientService
class | BtObexConnectRequest
class | BtObexDisconnectRequest
class | BtObexGetRequest
class | BtObexPutRequest
class | BtObexRegisterClientRequest
class | BtObexRegisterServerRequest
class | BtObexSendResponseRequest
class | BtObexServerService
class | BtObexService
class | BtObexSetPathRequest
class | BtObexUnregisterClientRequest
class | BtObexUnregisterServerRequest

Data Structures

class | BtObexConnection

Detailed Description

Bluetooth Dial Up Network profile access class. BtDunController is implemented as Singleton and forms the interface to the Bluetooth Stack via callbacks.

Constructor & Destructor Documentation

BtObexController::~BtObexController ( ) [virtual]

Destructor.

Member Function Documentation

BtObexController & BtObexController::GetInstance ( ) [static]

Get singleton instance.

BtDunController is implemented as a singleton, so GetInstance() returns a refernce to the singleton object of BtDunController.

Returns:
Reference to a BtDunController containing the singleton instance object.

const WCHAR * BtObexController::GetName ( ) const [virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

BOOLEAN BtObexController::ObexAbortRequest ( BtObexAbortRequest * abort_request ) [protected]

BOOLEAN BtObexController::ObexAddHeader | ( | const BtObexService * | obex_service,
 |  | UINT8 | header_id,
 |  | WString | header_value
 | ) | [protected]

BOOLEAN BtObexController::ObexAddHeader | ( | const BtObexService * | obex_service,
 |  | UINT8 | header_id,
 |  | UINT8 * | header_value,
 |  | UINT16 | header_value_length
 | ) | [protected]

BOOLEAN BtObexController::ObexAddHeader | ( | const BtObexService * | obex_service,
 |  | UINT8 | header_id,
 |  | UINT32 | header_value
 | ) | [protected]

BOOLEAN BtObexController::ObexAddHeader | ( | const BtObexService * | obex_service,
 |  | UINT8 | header_id,
 |  | UINT8 | header_value
 | ) | [protected]

BOOLEAN BtObexController::ObexConnectRequest ( BtObexConnectRequest * connect_request ) [protected]

BOOLEAN BtObexController::ObexDataBufferIndication | ( | const BtObexService * | obex_service,
 |  | UINT8 * | data_buffer,
 |  | UINT16 | data_buffer_size,
 |  | UINT8 | response_code
 | ) | [protected]

BOOLEAN BtObexController::ObexDataIndication | ( | const BtObexService * | obex_service,
 |  | const UINT8 * | data,
 |  | UINT16 | data_size,
 |  | BOOLEAN | more_data_pending,
 |  | UINT8 | response_code
 | ) | [protected]

BOOLEAN BtObexController::ObexDiscardHeaders ( const BtObexService * obex_service ) [protected]

BOOLEAN BtObexController::ObexDisconnectRequest ( BtObexDisconnectRequest * disconnect_request ) [protected]

BOOLEAN BtObexController::ObexGetFreeSize | ( | const BtObexService * | obex_service,
 |  | UINT16 & | bytes_free
 | ) | [protected]

BOOLEAN BtObexController::ObexGetRequest ( BtObexGetRequest * get_request ) [protected]

BOOLEAN BtObexController::ObexPutRequest ( BtObexPutRequest * put_request ) [protected]

BOOLEAN BtObexController::ObexRegisterClientRequest ( BtObexRegisterClientRequest * register_request ) [protected]

BOOLEAN BtObexController::ObexRegisterServerRequest ( BtObexRegisterServerRequest * register_request ) [protected]

BOOLEAN BtObexController::ObexSendResponse | ( | const BtObexService * | obex_service,
 |  | UINT8 | response_code
 | ) | [protected]

BOOLEAN BtObexController::ObexSetPathRequest ( BtObexSetPathRequest * set_path_request ) [protected]

BOOLEAN BtObexController::ObexUnregisterClientRequest ( BtObexUnregisterClientRequest * unregister_request ) [protected]

BOOLEAN BtObexController::ObexUnregisterServerRequest ( BtObexUnregisterServerRequest * unregister_request ) [protected]

Friends And Related Function Documentation

friend class BtObexAbortRequest [friend]

friend class BtObexClientService [friend]

friend class BtObexConnectRequest [friend]

friend class BtObexDisconnectRequest [friend]

friend class BtObexGetRequest [friend]

friend class BtObexPutRequest [friend]

friend class BtObexRegisterClientRequest [friend]

friend class BtObexRegisterServerRequest [friend]

friend class BtObexSendResponseRequest [friend]

friend class BtObexServerService [friend]

friend class BtObexService [friend]

friend class BtObexSetPathRequest [friend]

friend class BtObexUnregisterClientRequest [friend]

friend class BtObexUnregisterServerRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexController.hpp
  • Bluetooth/OBEX/BtObexController.cpp
Generated on Wed Jan 25 01:01:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexController::BtObexConnection Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtObexController::BtObexConnection

BtObexController::BtObexConnection Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexController.hpp>

Inheritance diagram for BtObexController::BtObexConnection:

[legend]
Collaboration diagram for BtObexController::BtObexConnection:

[legend]

Public Member Functions

BtObexConnection ()
BOOLEAN | GetIsServer () const
btapi_goep_handle_t | GetObexHandle () const
BtObexAbortRequest * | GetRunningAbortRequest () const
void | SetIsServer (BOOLEAN is_server)
void | SetObexHandle (btapi_goep_handle_t obex_handle)
void | SetRunningAbortRequest (BtObexAbortRequest *request)
virtual | ~BtObexConnection ()

Constructor & Destructor Documentation

BtObexController::BtObexConnection::BtObexConnection ( )

BtObexController::BtObexConnection::~BtObexConnection ( ) [virtual]

Member Function Documentation

BOOLEAN BtObexController::BtObexConnection::GetIsServer ( ) const

btapi_goep_handle_t BtObexController::BtObexConnection::GetObexHandle ( ) const

BtObexAbortRequest * BtObexController::BtObexConnection::GetRunningAbortRequest ( ) const

void BtObexController::BtObexConnection::SetIsServer ( BOOLEAN is_server )

void BtObexController::BtObexConnection::SetObexHandle ( btapi_goep_handle_t obex_handle )

void BtObexController::BtObexConnection::SetRunningAbortRequest ( BtObexAbortRequest * request )

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexController.hpp
  • Bluetooth/OBEX/BtObexController.cpp
Generated on Wed Jan 25 01:01:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexDataBufferIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexDataBufferIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexDataBufferIndicationEvent:

[legend]
Collaboration diagram for BtObexDataBufferIndicationEvent:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

BtObexDataBufferIndicationEvent (BtResultCode result, UINT16 last_buffer_filled, BOOLEAN delete_object, BOOLEAN create_empty_object)
Constructor.
BOOLEAN | GetCreateEmptyObject () const
BOOLEAN | GetDeleteObect () const
virtual UINT16 | GetId () const
UINT16 | GetLastBufferFilled () const
virtual | ~BtObexDataBufferIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexDataBufferIndicationEvent::BtObexDataBufferIndicationEvent | ( | BtResultCode | result,
 |  | UINT16 | last_buffer_filled,
 |  | BOOLEAN | delete_object,
 |  | BOOLEAN | create_empty_object
 | ) |

Constructor.

BtObexDataBufferIndicationEvent::~BtObexDataBufferIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexDataBufferIndicationEvent::GetCreateEmptyObject ( ) const

BOOLEAN BtObexDataBufferIndicationEvent::GetDeleteObect ( ) const

UINT16 BtObexDataBufferIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

UINT16 BtObexDataBufferIndicationEvent::GetLastBufferFilled ( ) const

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexDataIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexDataIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexDataIndicationEvent:

[legend]
Collaboration diagram for BtObexDataIndicationEvent:

[legend]

Public Types

enum | { ID = 5 }

Public Member Functions

BtObexDataIndicationEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexDataIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexDataIndicationEvent::BtObexDataIndicationEvent ( BtResultCode result )

Constructor.

BtObexDataIndicationEvent::~BtObexDataIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexDataIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexDisconnectRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexDisconnectRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexDisconnectRequest.hpp>

Inheritance diagram for BtObexDisconnectRequest:

[legend]
Collaboration diagram for BtObexDisconnectRequest:

[legend]

Public Member Functions

BtObexDisconnectRequest (BtObexClientService &obex_client_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
virtual | ~BtObexDisconnectRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexDisconnectRequest::BtObexDisconnectRequest ( BtObexClientService & obex_client_service )

Constructor.

BtObexDisconnectRequest::~BtObexDisconnectRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexDisconnectRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexDisconnectRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

BtRequestType BtObexDisconnectRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexClientOperationRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexDisconnectRequest.hpp
  • Bluetooth/OBEX/BtObexDisconnectRequest.cpp
Generated on Wed Jan 25 01:01:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexEvent:

[legend]
Collaboration diagram for BtObexEvent:

[legend]

Public Member Functions

BtObexEvent (BtResultCode result)
Constructor.
virtual ~BtObexEvent ()
Destructor.

Constructor & Destructor Documentation

BtObexEvent::BtObexEvent ( BtResultCode result )

Constructor.

BtObexEvent::~BtObexEvent ( ) [virtual]

Destructor.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexGetRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexGetRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexGetRequest.hpp>

Inheritance diagram for BtObexGetRequest:

[legend]
Collaboration diagram for BtObexGetRequest:

[legend]

Public Member Functions

BtObexGetRequest (BtObexClientService &obex_client_service)
Constructor.
virtual BtRequestType | GetRequestType () const
Get type of this request.
virtual | ~BtObexGetRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)
virtual BOOLEAN | GetAcceptAbort () const

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexGetRequest::BtObexGetRequest ( BtObexClientService & obex_client_service )

Constructor.

BtObexGetRequest::~BtObexGetRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexGetRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexGetRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

BOOLEAN BtObexGetRequest::GetAcceptAbort ( ) const [protected, virtual]

Reimplemented from BtObexClientOperationRequest.

BtRequestType BtObexGetRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexClientOperationRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexGetRequest.hpp
  • Bluetooth/OBEX/BtObexGetRequest.cpp
Generated on Wed Jan 25 01:01:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexHeader Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexHeader Struct Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtTypes.hpp>

Data Fields

UINT8 header_id
BtObexHeaderType header_type
union {
struct {
const UINT8 * buffer
UINT16 size
} byte_sequence
UINT8 byte_value
UINT32 dword_value
struct {
const UINT16 * buffer
UINT16 size
} unicode_string
} value

Field Documentation

const UINT16* BtObexHeader::buffer

const UINT8* BtObexHeader::buffer

struct { ... } BtObexHeader::byte_sequence

UINT8 BtObexHeader::byte_value

UINT32 BtObexHeader::dword_value

UINT8 BtObexHeader::header_id

BtObexHeaderType BtObexHeader::header_type

UINT16 BtObexHeader::size

struct { ... } BtObexHeader::unicode_string

union { ... } BtObexHeader::value

The documentation for this struct was generated from the following file:
  • Bluetooth/OBEX/BtTypes.hpp
Generated on Wed Jan 25 01:01:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexHeaderIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexHeaderIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexHeaderIndicationEvent:

[legend]
Collaboration diagram for BtObexHeaderIndicationEvent:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

BtObexHeaderIndicationEvent (BtResultCode result, const BtObexHeader &header)
Constructor.
const BtObexHeader & | GetHeader () const
virtual UINT16 | GetId () const
virtual | ~BtObexHeaderIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexHeaderIndicationEvent::BtObexHeaderIndicationEvent | ( | BtResultCode | result,
 |  | const BtObexHeader & | header
 | ) |

Constructor.

BtObexHeaderIndicationEvent::~BtObexHeaderIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

const BtObexHeader & BtObexHeaderIndicationEvent::GetHeader ( ) const

UINT16 BtObexHeaderIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexHeaderSentEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexHeaderSentEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexHeaderSentEvent:

[legend]
Collaboration diagram for BtObexHeaderSentEvent:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

BtObexHeaderSentEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexHeaderSentEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexHeaderSentEvent::BtObexHeaderSentEvent ( BtResultCode result )

Constructor.

BtObexHeaderSentEvent::~BtObexHeaderSentEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexHeaderSentEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexImpl Class Reference

This class contains the implementation of Obex related operations (Connect, Put, Get, ...) for both Client and Server connections. More...

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp>

Inheritance diagram for BtObexImpl:

[legend]
Collaboration diagram for BtObexImpl:

[legend]

Public Member Functions

virtual void | Abort (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &abort_req)
Aborts an ongoing OBEX client operation.
virtual ObexResult | AcquireClientChannel (ObexChannel &result, const ObexAddrPtr &addr_ptr, BOOLEAN reserve=FALSE)
Allocates an Obex Channel for the client.
virtual ObexResult | AcquireServerChannel (ObexChannel &result, const ObexAddrPtr &addr_ptr, BOOLEAN reserve=FALSE)
Allocates an Obex Channel for the server, no stack calling.
virtual void | BindServerChannel (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexAddrPtr &addr_ptr)
Registers to the stack like server. Takes a rfcomm port number from the stack, associates it to the Obex Address and Channel, registers the server like service in the SDDB.
BtObexImpl ()
Constructor.
virtual void | CloseChannel (const ObexChannel &channel, ObexOperationId oper_id)
Closes an Obex Channel.
virtual void | Connect (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Starts an Obex connection to the remote server.
virtual void | DataProcessed (const ObexChannel &channel, ObexOperationId oper_id, ObexBuffer &obex_buffer)
Confirm processing of data delivered to an application.
virtual void | Disconnect (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &disc_req)
Starts an Obex DISCONNECT operation.
virtual void | Get (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &get_req)
Starts or continues an Obex GET operation.
Mutex * GetTransportMutex ()
virtual void | OpenClientChannel (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexAddrPtr &addr_ptr)
Associates an Obex Channel to an Obex Address.
virtual void | Put (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &put_req)
Starts or continues an Obex PUT operation.
virtual ObexResult | ReleaseChannel (ObexChannel &channel)
Releases an Obex Channel.
virtual void | ReturnResponse (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &server_resp)
By calling this method the Server (application layer) sends a response to a remote client request.
virtual void | SetPath (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &setp_req)
Starts an Obex SETHPATH operation.
virtual | ~BtObexImpl ()
Destructor.

Friends

class | BtObexClientConnection
class | BtObexClientObserverImpl
The BtObexClientObserverImpl can access BtObexImpl (callback path related).
class | BtObexSddbServiceObserverImpl
class | BtObexServerConnection
class | BtObexServerObserverImpl
The BtObexServerObserverImpl can access BtObexImpl (callback path related).

Data Structures

class | BtObexClientConnection
Information for managing an Obex Client connection (i.e. instance).
class | BtObexServerConnection
Information for managing an Obex Server connection (i.e. instance).
class | ChannelPool
Structure to manage relationships among: channel, address, Client/Server Service instances.

Detailed Description

This class contains the implementation of Obex related operations (Connect, Put, Get, ...) for both Client and Server connections.

The public section implements the interfaces, while the private section implements structures and methods to perform the Obex operations through the Obex Services (see the related document, xxxxxx put reference here ). The Obex Services are a wrapper to the BtObexController which works in conjunction with the Mecel stack).

Constructor & Destructor Documentation

BtObexImpl::BtObexImpl ( )

Constructor.

BtObexImpl::~BtObexImpl ( ) [virtual]

Destructor.

Member Function Documentation

void BtObexImpl::Abort | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | abort_req
 | ) | [virtual]

Aborts an ongoing OBEX client operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier of the operation to be aborted
abort_req | OBEX object which holds the headers to be included in the ABORT request

Implements ObexLayer.

ObexResult BtObexImpl::AcquireClientChannel | ( | ObexChannel & | result,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | BOOLEAN | reserve = FALSE
 | ) | [virtual]

Allocates an Obex Channel for the client.

Parameters:
result | The allocated obex channel reference if no errors occured
addr_ptr | Smartpointer holding a valid transport address, can be ignored for Bt Obex implementation (IrDA related only)
reserve | If set to TRUE, indicates that private transport resources should be reserved for this channel. The Bt Obex implementation ignore this parameter. It is present for interface compatibility only, but is always FALSE.
Returns:
TRUE in case of success, ObexResult indicating an error if the channel pool is full
Note: this function does not call the stack, is a factory function.

Implements ObexProtocol.

ObexResult BtObexImpl::AcquireServerChannel | ( | ObexChannel & | result,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | BOOLEAN | reserve = FALSE
 | ) | [virtual]

Allocates an Obex Channel for the server, no stack calling.

Parameters:
result | The allocated obex channel reference if no errors occured
addr_ptr | Smartpointer holding a valid transport address, can be ignored for Bt Obex implementation (IrDA related only)
reserve | If set to TRUE, indicates that private transport resources should be reserved for this channel. The Bt Obex implementation ignore this parameter. It is present for interface compatibility only, but is always FALSE.
Returns:
TRUE in case of success, ObexResult indicating an error if the channel pool is full
Note: this function does not call the stack, is a factory function.

Implements ObexProtocol.

void BtObexImpl::BindServerChannel | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexAddrPtr & | addr_ptr
 | ) | [virtual]

Registers to the stack like server. Takes a rfcomm port number from the stack, associates it to the Obex Address and Channel, registers the server like service in the SDDB.

Parameters:
server_chan | Server transport channel to open (bind).
oper_id | Operation identifier
addr_ptr | Smartpointer holding the OBEX address of the service to be bounded
Note: this function is the first stack calling while establishing a Server Obex session

Implements ObexProtocol.

void BtObexImpl::CloseChannel | ( | const ObexChannel & | channel,
 |  | ObexOperationId | oper_id
 | ) | [virtual]

Closes an Obex Channel.

Parameters:
channel | Channel to be closed.
oper_id | Operation identifier
The channel must have been previously opened with an OpenClientChannel() (or a BindServerChannel()?)

Implements ObexProtocol.

void BtObexImpl::Connect | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Starts an Obex connection to the remote server.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
conn_req | Obex Object which holds the headers to be included in the CONNECT request and flags according to OBEX Spec. 3.3.1.2, but no data !
Note: in the passed Obex Object there are headers only, no Obex Buffer allocated

Implements ObexLayer.

void BtObexImpl::DataProcessed | ( | const ObexChannel & | channel,
 |  | ObexOperationId | oper_id,
 |  | ObexBuffer & | obex_buffer
 | ) | [virtual]

Confirm processing of data delivered to an application.

Parameters:
channel | Channel associated with the requested operation
oper_id | Operation identifier
obex_buffer | Buffer to be disposed
By calling this method the application layer returns the ownership of a buffer back to the protocol implementation which had produced the buffer and therefore knows how to dispose it.

Implements ObexLayer.

void BtObexImpl::Disconnect | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | disc_req
 | ) | [virtual]

Starts an Obex DISCONNECT operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
disc_req | Obex Object which holds the headers to be included in the DISCONNECT request.
Note: in the passed Obex Objext there are headers only, no Obex Buffer allocated

Implements ObexLayer.

void BtObexImpl::Get | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | get_req
 | ) | [virtual]

Starts or continues an Obex GET operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier.
get_req | Obex Object which holds the headers to be included in the GET request and possibly BODY data within an ObexBuffer.
Note that in rare cases a GET request may contain a BODY header !

Implements ObexLayer.

Mutex* BtObexImpl::GetTransportMutex ( ) [inline]

void BtObexImpl::OpenClientChannel | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexAddrPtr & | addr_ptr
 | ) | [virtual]

Associates an Obex Channel to an Obex Address.

Parameters:
client_chan | Client channel under association.
oper_id | Operation identifier
addr_ptr | Smartpointer holding the Obex Address under association (of the service to connect to)
Note: this function is the first stack calling while establishing a Client Obex session

Implements ObexProtocol.

void BtObexImpl::Put | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | put_req
 | ) | [virtual]

Starts or continues an Obex PUT operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
put_req | Obex Object which holds the headers to be included in the PUT request and BODY data within an ObexBuffer.

Implements ObexLayer.

ObexResult BtObexImpl::ReleaseChannel ( ObexChannel & channel ) [virtual]

Releases an Obex Channel.

Returns:
TRUE in case of success, ObexResult indicating an error otherwise.
The channel must have been previously obtained by calling the AcquireClientChannel() or the AcquireServerChannel()

Implements ObexProtocol.

void BtObexImpl::ReturnResponse | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | server_resp
 | ) | [virtual]

By calling this method the Server (application layer) sends a response to a remote client request.

Parameters:
server_chan | Server channel associated with the response.
oper_id | Operation identifier
server_resp | OBEX object which holds the headers to be included in the response, the response code and possibly BODY data within an ObexBuffer.

Implements ObexLayer.

void BtObexImpl::SetPath | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | setp_req
 | ) | [virtual]

Starts an Obex SETHPATH operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
setp_req | Obex Object which holds the headers to be included in the SETPATH request and flags according to OBEX Spec. 3.3.6.1, but no data !
Note: in the passed Obex Object there are headers only, no Obex Buffer allocated

Implements ObexLayer.

Friends And Related Function Documentation

friend class BtObexClientConnection [friend]

friend class BtObexClientObserverImpl [friend]

The BtObexClientObserverImpl can access BtObexImpl (callback path related).

friend class BtObexSddbServiceObserverImpl [friend]

friend class BtObexServerConnection [friend]

friend class BtObexServerObserverImpl [friend]

The BtObexServerObserverImpl can access BtObexImpl (callback path related).

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexImpl.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexImpl.cpp
Generated on Wed Jan 25 01:01:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexMessageArgumentsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexMessageArgumentsDestroyTableNode Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexMessageArguments.hpp>

Inheritance diagram for BtObexMessageArgumentsDestroyTableNode:

[legend]
Collaboration diagram for BtObexMessageArgumentsDestroyTableNode:

[legend]

Static Public Member Functions

static BtObexMessageArgumentsDestroyTableNode * GetInstance ()

Member Function Documentation

BtObexMessageArgumentsDestroyTableNode * BtObexMessageArgumentsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexMessageArguments.hpp
  • Bluetooth/BIP/BtBipMsgArg.cpp
  • Bluetooth/OBEX/BtObexMessageArguments.cpp
Generated on Wed Jan 25 01:01:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexPutRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexPutRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexPutRequest.hpp>

Inheritance diagram for BtObexPutRequest:

[legend]
Collaboration diagram for BtObexPutRequest:

[legend]

Public Member Functions

BtObexPutRequest (BtObexClientService &obex_client_service)
Constructor.
BOOLEAN | GetCreateEmptyObject () const
BOOLEAN | GetDeleteObject () const
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetCreateEmptyObject (BOOLEAN create_empty=TRUE)
void | SetDeleteObject (BOOLEAN delete_object=TRUE)
virtual | ~BtObexPutRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)
virtual BOOLEAN | GetAcceptAbort () const

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexPutRequest::BtObexPutRequest ( BtObexClientService & obex_client_service )

Constructor.

BtObexPutRequest::~BtObexPutRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexPutRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexPutRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

BOOLEAN BtObexPutRequest::GetAcceptAbort ( ) const [protected, virtual]

Reimplemented from BtObexClientOperationRequest.

BOOLEAN BtObexPutRequest::GetCreateEmptyObject ( ) const

BOOLEAN BtObexPutRequest::GetDeleteObject ( ) const

BtRequestType BtObexPutRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

void BtObexPutRequest::SetCreateEmptyObject ( BOOLEAN create_empty = TRUE )

void BtObexPutRequest::SetDeleteObject ( BOOLEAN delete_object = TRUE )

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexClientOperationRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexPutRequest.hpp
  • Bluetooth/OBEX/BtObexPutRequest.cpp
Generated on Wed Jan 25 01:01:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexRegisterClientEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexRegisterClientEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexRegisterClientEvent:

[legend]
Collaboration diagram for BtObexRegisterClientEvent:

[legend]

Public Types

enum | { ID = 14 }

Public Member Functions

BtObexRegisterClientEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexRegisterClientEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexRegisterClientEvent::BtObexRegisterClientEvent ( BtResultCode result )

Constructor.

BtObexRegisterClientEvent::~BtObexRegisterClientEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexRegisterClientEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexRegisterClientRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexRegisterClientRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexRegisterClientRequest.hpp>

Inheritance diagram for BtObexRegisterClientRequest:

[legend]
Collaboration diagram for BtObexRegisterClientRequest:

[legend]

Public Member Functions

BtObexRegisterClientRequest (BtObexClientService &obex_client_service)
Constructor.
void * | GetApoxiHandle (void)
const void * | GetApoxiHandle (void) const
UINT8 * | GetHeaderBuffer (void)
const UINT8 * | GetHeaderBuffer (void) const
UINT16 | GetHeaderBufferSize (void) const
virtual BtRequestType | GetRequestType () const
Get type of this request.
BtSecuritySettings | GetSecuritySettings () const
void | SetApoxiHandle (void *apoxi_handle)
void | SetHeaderBuffer (UINT8 *header_buffer, UINT16 header_buffer_size)
void | SetSecuritySettings (BtSecuritySettings security_settings)
virtual | ~BtObexRegisterClientRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexRegisterClientRequest::BtObexRegisterClientRequest ( BtObexClientService & obex_client_service )

Constructor.

BtObexRegisterClientRequest::~BtObexRegisterClientRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexRegisterClientRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexRegisterClientRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

void * BtObexRegisterClientRequest::GetApoxiHandle ( void )

const void * BtObexRegisterClientRequest::GetApoxiHandle ( void ) const

UINT8 * BtObexRegisterClientRequest::GetHeaderBuffer ( void )

const UINT8 * BtObexRegisterClientRequest::GetHeaderBuffer ( void ) const

UINT16 BtObexRegisterClientRequest::GetHeaderBufferSize ( void ) const

BtRequestType BtObexRegisterClientRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BtSecuritySettings BtObexRegisterClientRequest::GetSecuritySettings ( ) const

void BtObexRegisterClientRequest::SetApoxiHandle ( void * apoxi_handle )

void BtObexRegisterClientRequest::SetHeaderBuffer | ( | UINT8 * | header_buffer,
 |  | UINT16 | header_buffer_size
 | ) |

void BtObexRegisterClientRequest::SetSecuritySettings ( BtSecuritySettings security_settings )

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexRegisterClientRequest.hpp
  • Bluetooth/OBEX/BtObexRegisterClientRequest.cpp
Generated on Wed Jan 25 01:01:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexRegisterServerEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexRegisterServerEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexRegisterServerEvent:

[legend]
Collaboration diagram for BtObexRegisterServerEvent:

[legend]

Public Types

enum | { ID = 7 }

Public Member Functions

BtObexRegisterServerEvent (BtResultCode result, UINT8 rfcom_channel)
Constructor.
virtual UINT16 | GetId () const
UINT8 | GetRfComChannel () const
virtual | ~BtObexRegisterServerEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexRegisterServerEvent::BtObexRegisterServerEvent | ( | BtResultCode | result,
 |  | UINT8 | rfcom_channel
 | ) |

Constructor.

BtObexRegisterServerEvent::~BtObexRegisterServerEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexRegisterServerEvent::GetId ( ) const [virtual]

Implements BtEvent.

UINT8 BtObexRegisterServerEvent::GetRfComChannel ( ) const

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexRegisterServerRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexRegisterServerRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexRegisterServerRequest.hpp>

Inheritance diagram for BtObexRegisterServerRequest:

[legend]
Collaboration diagram for BtObexRegisterServerRequest:

[legend]

Public Member Functions

BtObexRegisterServerRequest (BtObexServerService &obex_server_service)
Constructor.
void * | GetApoxiHandle (void)
const void * | GetApoxiHandle (void) const
UINT8 * | GetHeaderBuffer (void)
const UINT8 * | GetHeaderBuffer (void) const
UINT16 | GetHeaderBufferSize (void) const
virtual BtRequestType | GetRequestType () const
Get type of this request.
UINT8 | GetRfComChannel () const
BtSecuritySettings | GetSecuritySettings () const
void | SetApoxiHandle (void *apoxi_handle)
void | SetHeaderBuffer (UINT8 *header_buffer, UINT16 header_buffer_size)
void | SetSecuritySettings (BtSecuritySettings security_settings)
virtual | ~BtObexRegisterServerRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)
void | OnRfComChannel (UINT8 rfcom_channel)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexRegisterServerRequest::BtObexRegisterServerRequest ( BtObexServerService & obex_server_service )

Constructor.

BtObexRegisterServerRequest::~BtObexRegisterServerRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexRegisterServerRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexRegisterServerRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

void * BtObexRegisterServerRequest::GetApoxiHandle ( void )

const void * BtObexRegisterServerRequest::GetApoxiHandle ( void ) const

UINT8 * BtObexRegisterServerRequest::GetHeaderBuffer ( void )

const UINT8 * BtObexRegisterServerRequest::GetHeaderBuffer ( void ) const

UINT16 BtObexRegisterServerRequest::GetHeaderBufferSize ( void ) const

BtRequestType BtObexRegisterServerRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

UINT8 BtObexRegisterServerRequest::GetRfComChannel ( ) const

BtSecuritySettings BtObexRegisterServerRequest::GetSecuritySettings ( ) const

void BtObexRegisterServerRequest::OnRfComChannel ( UINT8 rfcom_channel ) [protected]

void BtObexRegisterServerRequest::SetApoxiHandle ( void * apoxi_handle )

void BtObexRegisterServerRequest::SetHeaderBuffer | ( | UINT8 * | header_buffer,
 |  | UINT16 | header_buffer_size
 | ) |

void BtObexRegisterServerRequest::SetSecuritySettings ( BtSecuritySettings security_settings )

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexRegisterServerRequest.hpp
  • Bluetooth/OBEX/BtObexRegisterServerRequest.cpp
Generated on Wed Jan 25 01:01:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexRequest.hpp>

Inheritance diagram for BtObexRequest:

[legend]
Collaboration diagram for BtObexRequest:

[legend]

Public Member Functions

BtObexRequest (BtObexService &obex_service)
Constructor.
virtual | ~BtObexRequest ()
Destructor.

Protected Member Functions

virtual BtRequestState | ChangeRequestState (BOOLEAN success)
Sets the new state depending on the success.
virtual BOOLEAN | EvaluateExecutionResult (BtResultCode result)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexRequest::BtObexRequest ( BtObexService & obex_service )

Constructor.

BtObexRequest::~BtObexRequest ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtObexRequest::ChangeRequestState ( BOOLEAN success ) [protected, virtual]

Sets the new state depending on the success.

ChangeRequestState is a function that is used by the ExecuteRequest and the EvaluateMessageResult functions to do the change of the request state. Depending on the current state and the passed in success, this function sets the right new state. The passed in success parameter can be on the one hand the result of a function call, on the other hand the result parameter of a message sent up to the request by the apropriate controller.

Parameters:
success A BOOLEAN indicating the success of the operation execution stage corresponding to the current state.
Returns:
A BtRequestState containing the new request state after doing the state transition.

Reimplemented from BtRequest.

BOOLEAN BtObexRequest::EvaluateExecutionResult ( BtResultCode result ) [protected, virtual]

Reimplemented from BtRequest.

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented in BtObexAbortRequest, BtObexClientOperationRequest, BtObexConnectRequest, BtObexDisconnectRequest, BtObexGetRequest, BtObexPutRequest, BtObexRegisterClientRequest, BtObexRegisterServerRequest, BtObexSetPathRequest, BtObexUnregisterClientRequest, and BtObexUnregisterServerRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexRequest.hpp
  • Bluetooth/OBEX/BtObexRequest.cpp
Generated on Wed Jan 25 01:01:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexResponseCode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexResponseCode Class Reference

Indicates success or failure of an OBEX operation. More...

#include <Apoxi/Bluetooth/BtObexResponseCode.hpp>

Public Types

enum ResponseCode {
Success = 0x20, Continue = 0x10, PartialContent = 0x26, BadRequest = 0x40,
NotImplemented = 0x51, Forbidden = 0x43, Unauthorised = 0x41, PreconditionFailed = 0x4C,
NotFound = 0x44, NotAcceptable = 0x46, ServiceUnavailable = 0x53, Unspecified = 0x7F
}

Public Member Functions

BtObexResponseCode (const BtObexResponseCode &from)
Copy constructor.
BtObexResponseCode (UINT8 obex_resp_code)
Constructor.
BtObexResponseCode (ResponseCode obex_resp_code=Unspecified, BOOLEAN final_flag=FALSE)
Constructor and default constructor.
ResponseCode | GetObexResponseCode () const
Returns the obex response code code, or in case of no error, Ok.
UINT8 | GetObexResponseCodeByte () const
Returns the byte representation of the obex response code.
BOOLEAN | IsError () const
Tells whether this result indicates an error.
BOOLEAN | IsFinal () const
Tells whether the final bit is set.
BOOLEAN | IsFinished () const
Tells whether the result indicates the end of an obex request.
BOOLEAN | IsOk () const
Tells whether this result indicates success.
operator BOOLEAN () const
Conversion operator to BOOLEAN.
BtObexResponseCode & | operator= (const BtObexResponseCode &from)
Assigmnent operator.

Static Public Member Functions

static BtObexResponseCode | Ok ()
Constructs an BtObexResponseCode object that indicates success, final flag set.

Detailed Description

Indicates success or failure of an OBEX operation.

This class defines an implicit conversion to BOOLEAN where 'TRUE' indicates success whereas 'FALSE' means that an error has occured. The actual obex response code can be obtained by GetObexResponseCode().

Default-constructed instances indicate an 'Unspecified' error. Use the named constructor Ok() to obtain an BtObexResponseCode object that means success.

Note: currently only Obex response codes needed by Basic Imaging are supported.

Member Enumeration Documentation

enum BtObexResponseCode::ResponseCode

Enumerator:
Success
Continue
PartialContent
BadRequest
NotImplemented
Forbidden
Unauthorised
PreconditionFailed
NotFound
NotAcceptable
ServiceUnavailable
Unspecified

Constructor & Destructor Documentation

BtObexResponseCode::BtObexResponseCode | ( | ResponseCode | obex_resp_code = Unspecified,
 |  | BOOLEAN | final_flag = FALSE
 | ) | [inline]

Constructor and default constructor.

Attention: The default-constructed object indicates an error !

BtObexResponseCode::BtObexResponseCode ( UINT8 obex_resp_code ) [inline]

Constructor.

BtObexResponseCode::BtObexResponseCode ( const BtObexResponseCode & from ) [inline]

Copy constructor.

Member Function Documentation

BtObexResponseCode::ResponseCode BtObexResponseCode::GetObexResponseCode ( ) const [inline]

Returns the obex response code code, or in case of no error, Ok.

UINT8 BtObexResponseCode::GetObexResponseCodeByte ( ) const [inline]

Returns the byte representation of the obex response code.

BOOLEAN BtObexResponseCode::IsError ( ) const [inline]

Tells whether this result indicates an error.

BOOLEAN BtObexResponseCode::IsFinal ( ) const [inline]

Tells whether the final bit is set.

BOOLEAN BtObexResponseCode::IsFinished ( ) const [inline]

Tells whether the result indicates the end of an obex request.

BOOLEAN BtObexResponseCode::IsOk ( ) const [inline]

Tells whether this result indicates success.

BtObexResponseCode BtObexResponseCode::Ok ( ) [inline, static]

Constructs an BtObexResponseCode object that indicates success, final flag set.

BtObexResponseCode::operator BOOLEAN ( ) const [inline]

Conversion operator to BOOLEAN.

Returns 'TRUE' if the result indicates success, 'FALSE' if the object represents an error code.

BtObexResponseCode & BtObexResponseCode::operator= ( const BtObexResponseCode & from ) [inline]

Assigmnent operator.

The documentation for this class was generated from the following file:
  • Bluetooth/BtObexResponseCode.hpp
Generated on Wed Jan 25 01:01:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexSddbImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexSddbImpl Class Reference

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp>

Inheritance diagram for BtObexSddbImpl:

[legend]
Collaboration diagram for BtObexSddbImpl:

[legend]

Public Member Functions

BtObexSddbImpl ()
Constructor.
BtRequestState UnregisterServiceRecordRequest ()
virtual | ~BtObexSddbImpl ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
Notification function of changes in running requests.

Constructor & Destructor Documentation

BtObexSddbImpl::BtObexSddbImpl ( )

Constructor.

BtObexSddbImpl::~BtObexSddbImpl ( ) [virtual]

Destructor.

Member Function Documentation

void BtObexSddbImpl::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Notification function of changes in running requests.

Whenever the state of a request contained in this service is changed OnRequestStateChange will be called. This function should give the application programmer to do some GUI reaction to the progress or the failure of a partikular request.
This function has to be implemented by the application programmer, so in the base classes this function is pure virtual.

Parameters:
request_type | A BtRequestType enumeration type describing which kind of request has changed its state.
old_request_state | A BtRequestState enumeration type containing the state of the request before the state transition.
new_request_state | A BtRequestState enumeration type containing the state of the request after the state transition.

Implements BtService.

BtRequestState BtObexSddbImpl::UnregisterServiceRecordRequest ( )

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexSddbImpl.cpp
Generated on Wed Jan 25 01:01:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexSddbServiceObserverImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexSddbServiceObserverImpl Class Reference

This class contains the implementation of the BtSddb Service Observer, related to the Bt stack/controller callbacks for Sddb operations (Register, Reregister, Unregister). More...

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp>

Inheritance diagram for BtObexSddbServiceObserverImpl:

[legend]
Collaboration diagram for BtObexSddbServiceObserverImpl:

[legend]

Public Member Functions

BtObexSddbServiceObserverImpl ()
Constructor.
void | SetIndex (UINT8 id)
virtual | ~BtObexSddbServiceObserverImpl ()
Destructor.

Protected Member Functions

virtual void | OnRegisterService (BtResultCode code)
virtual void | OnUnregisterService (BtResultCode code)

Protected Attributes

UINT8 | m_id

Friends

class | BtSddbService

Detailed Description

This class contains the implementation of the BtSddb Service Observer, related to the Bt stack/controller callbacks for Sddb operations (Register, Reregister, Unregister).

Constructor & Destructor Documentation

BtObexSddbServiceObserverImpl::BtObexSddbServiceObserverImpl ( )

Constructor.

BtObexSddbServiceObserverImpl::~BtObexSddbServiceObserverImpl ( ) [virtual]

Destructor.

Member Function Documentation

void BtObexSddbServiceObserverImpl::OnRegisterService ( BtResultCode code ) [protected, virtual]

Implements BtSddbServiceObserver.

void BtObexSddbServiceObserverImpl::OnUnregisterService ( BtResultCode code ) [protected, virtual]

Implements BtSddbServiceObserver.

void BtObexSddbServiceObserverImpl::SetIndex ( UINT8 id ) [inline]

Friends And Related Function Documentation

friend class BtSddbService [friend]

Reimplemented from BtSddbServiceObserver.

Field Documentation

UINT8 BtObexSddbServiceObserverImpl::m_id [protected]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexSddbServiceObserverImpl.cpp
Generated on Wed Jan 25 01:01:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerAbortIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerAbortIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexServerAbortIndicationEvent:

[legend]
Collaboration diagram for BtObexServerAbortIndicationEvent:

[legend]

Public Types

enum | { ID = 13 }

Public Member Functions

BtObexServerAbortIndicationEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexServerAbortIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerAbortIndicationEvent::BtObexServerAbortIndicationEvent ( BtResultCode result )

Constructor.

BtObexServerAbortIndicationEvent::~BtObexServerAbortIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexServerAbortIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerAddr Class Reference

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp>

Inheritance diagram for BtObexServerAddr:

[legend]
Collaboration diagram for BtObexServerAddr:

[legend]

Public Types

enum | BtObexServerCodes { InvalidRfCommPortNumber = 0xFF }

Public Member Functions

UINT8 | GetRfCommPortNumber ()
UINT16 | GetSddbCase ()
BtSecuritySettings GetSecurity ()
const String & | GetServiceName () const
void | SetRfCommPortNumber (UINT8 rfcomm)
void | SetSddbCase (UINT16 sddb_case)
void | SetSecurity (BtSecuritySettings security)
void | SetServerDefaultParam ()
void | SetServerTargetString (String target)
void | SetServerUuid128 (UINT8 *service_id)
virtual ObexResult | ToString (String &obex_url) const
Converts the ObexAddrInfo into string format.

Static Public Member Functions

static SharedPtr< BtObexServerAddr > | Create ()
Instantiate a Server Address by a common static entry point (factory class).

Protected Member Functions

BtObexServerAddr ()
Calls the constructor of the mother class to set the transport id.

Friends

class | BtObexServerObserverImpl
class | BtObexTransport

Detailed Description

Class for manipulating a Server Obex Address.

Member Enumeration Documentation

enum BtObexServerAddr::BtObexServerCodes

Enumerator:
InvalidRfCommPortNumber

Constructor & Destructor Documentation

BtObexServerAddr::BtObexServerAddr ( ) [protected]

Calls the constructor of the mother class to set the transport id.

Member Function Documentation

SharedPtr< BtObexServerAddr > BtObexServerAddr::Create ( ) [static]

Instantiate a Server Address by a common static entry point (factory class).

UINT8 BtObexServerAddr::GetRfCommPortNumber ( )

UINT16 BtObexServerAddr::GetSddbCase ( )

BtSecuritySettings BtObexServerAddr::GetSecurity ( ) [inline]

const String& BtObexServerAddr::GetServiceName ( ) const [inline]

void BtObexServerAddr::SetRfCommPortNumber ( UINT8 rfcomm )

void BtObexServerAddr::SetSddbCase ( UINT16 sddb_case )

void BtObexServerAddr::SetSecurity ( BtSecuritySettings security ) [inline]

void BtObexServerAddr::SetServerDefaultParam ( )

void BtObexServerAddr::SetServerTargetString ( String target )

void BtObexServerAddr::SetServerUuid128 ( UINT8 * service_id )

ObexResult BtObexServerAddr::ToString ( String & obex_url ) const [virtual]

Converts the ObexAddrInfo into string format.

Parameters:
obex_url String to append the result to
Returns:
TRUE if the conversion was successful, FALSE otherwise.

Reimplemented from ObexAddress.

Friends And Related Function Documentation

friend class BtObexServerObserverImpl [friend]

friend class BtObexTransport [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexImplAddress.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexImplAddress.cpp
Generated on Wed Jan 25 01:01:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerConnectIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerConnectIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexServerConnectIndicationEvent:

[legend]
Collaboration diagram for BtObexServerConnectIndicationEvent:

[legend]

Public Types

enum | { ID = 8 }

Public Member Functions

BtObexServerConnectIndicationEvent (BtResultCode result, const BtDevice &device)
Constructor.
const BtDevice & | GetDevice () const
virtual UINT16 | GetId () const
virtual | ~BtObexServerConnectIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerConnectIndicationEvent::BtObexServerConnectIndicationEvent | ( | BtResultCode | result,
 |  | const BtDevice & | device
 | ) |

Constructor.

BtObexServerConnectIndicationEvent::~BtObexServerConnectIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

const BtDevice & BtObexServerConnectIndicationEvent::GetDevice ( ) const

UINT16 BtObexServerConnectIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerDisconnectIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerDisconnectIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexServerDisconnectIndicationEvent:

[legend]
Collaboration diagram for BtObexServerDisconnectIndicationEvent:

[legend]

Public Types

enum | { ID = 9 }

Public Member Functions

BtObexServerDisconnectIndicationEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexServerDisconnectIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerDisconnectIndicationEvent::BtObexServerDisconnectIndicationEvent ( BtResultCode result )

Constructor.

BtObexServerDisconnectIndicationEvent::~BtObexServerDisconnectIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexServerDisconnectIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexServerEvent:

[legend]
Collaboration diagram for BtObexServerEvent:

[legend]

Public Member Functions

BtObexServerEvent (BtResultCode result)
Constructor.
virtual ~BtObexServerEvent ()
Destructor.

Constructor & Destructor Documentation

BtObexServerEvent::BtObexServerEvent ( BtResultCode result )

Constructor.

BtObexServerEvent::~BtObexServerEvent ( ) [virtual]

Destructor.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerGetIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerGetIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexServerGetIndicationEvent:

[legend]
Collaboration diagram for BtObexServerGetIndicationEvent:

[legend]

Public Types

enum | { ID = 11 }

Public Member Functions

BtObexServerGetIndicationEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexServerGetIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerGetIndicationEvent::BtObexServerGetIndicationEvent ( BtResultCode result )

Constructor.

BtObexServerGetIndicationEvent::~BtObexServerGetIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexServerGetIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaAbort Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaAbort Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaAbort:

[legend]
Collaboration diagram for BtObexServerNmaAbort:

[legend]

Public Types

enum | { ID = 25 }

Public Member Functions

BtObexServerNmaAbort ()
BtObexServerNmaAbort (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexServerNmaAbort ()

Static Public Member Functions

static const BtObexServerNmaAbort & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaAbort

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaAbort::BtObexServerNmaAbort ( const BtResultCode & result )

BtObexServerNmaAbort::BtObexServerNmaAbort ( )

BtObexServerNmaAbort::~BtObexServerNmaAbort ( )

Member Function Documentation

const BtObexServerNmaAbort & BtObexServerNmaAbort::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaAbort::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaConnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaConnect Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaConnect:

[legend]
Collaboration diagram for BtObexServerNmaConnect:

[legend]

Public Types

enum | { ID = 20 }

Public Member Functions

BtObexServerNmaConnect ()
BtObexServerNmaConnect (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexServerNmaConnect ()

Static Public Member Functions

static const BtObexServerNmaConnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaConnect

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaConnect::BtObexServerNmaConnect ( const BtResultCode & result )

BtObexServerNmaConnect::BtObexServerNmaConnect ( )

BtObexServerNmaConnect::~BtObexServerNmaConnect ( )

Member Function Documentation

const BtObexServerNmaConnect & BtObexServerNmaConnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaConnect::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaDataBufferIndication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaDataBufferIndication Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaDataBufferIndication:

[legend]
Collaboration diagram for BtObexServerNmaDataBufferIndication:

[legend]

Public Types

enum | { ID = 28 }

Public Member Functions

BtObexServerNmaDataBufferIndication ()
BtObexServerNmaDataBufferIndication (const BtResultCode &result, UINT16 number_of_bytes, BOOLEAN delete_object, BOOLEAN create_empty)
UINT16 | GetNumberOfBytes () const
const BtResultCode & | GetResult () const
BOOLEAN | IsCreateEmpty () const
BOOLEAN | IsDeleteObject () const
~BtObexServerNmaDataBufferIndication ()

Static Public Member Functions

static const BtObexServerNmaDataBufferIndication & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaDataBufferIndication

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaDataBufferIndication::BtObexServerNmaDataBufferIndication | ( | const BtResultCode & | result,
 |  | UINT16 | number_of_bytes,
 |  | BOOLEAN | delete_object,
 |  | BOOLEAN | create_empty
 | ) |

BtObexServerNmaDataBufferIndication::BtObexServerNmaDataBufferIndication ( )

BtObexServerNmaDataBufferIndication::~BtObexServerNmaDataBufferIndication ( )

Member Function Documentation

const BtObexServerNmaDataBufferIndication & BtObexServerNmaDataBufferIndication::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT16 BtObexServerNmaDataBufferIndication::GetNumberOfBytes ( ) const [inline]

const BtResultCode& BtObexServerNmaDataBufferIndication::GetResult ( ) const [inline]

BOOLEAN BtObexServerNmaDataBufferIndication::IsCreateEmpty ( ) const [inline]

BOOLEAN BtObexServerNmaDataBufferIndication::IsDeleteObject ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaDataInidication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaDataInidication Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaDataInidication:

[legend]
Collaboration diagram for BtObexServerNmaDataInidication:

[legend]

Public Types

enum | { ID = 29 }

Public Member Functions

BtObexServerNmaDataInidication ()
BtObexServerNmaDataInidication (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexServerNmaDataInidication ()

Static Public Member Functions

static const BtObexServerNmaDataInidication & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaDataInidication

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaDataInidication::BtObexServerNmaDataInidication ( const BtResultCode & result )

BtObexServerNmaDataInidication::BtObexServerNmaDataInidication ( )

BtObexServerNmaDataInidication::~BtObexServerNmaDataInidication ( )

Member Function Documentation

const BtObexServerNmaDataInidication & BtObexServerNmaDataInidication::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaDataInidication::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaDisconnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaDisconnect Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaDisconnect:

[legend]
Collaboration diagram for BtObexServerNmaDisconnect:

[legend]

Public Types

enum | { ID = 21 }

Public Member Functions

BtObexServerNmaDisconnect ()
BtObexServerNmaDisconnect (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexServerNmaDisconnect ()

Static Public Member Functions

static const BtObexServerNmaDisconnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaDisconnect

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaDisconnect::BtObexServerNmaDisconnect ( const BtResultCode & result )

BtObexServerNmaDisconnect::BtObexServerNmaDisconnect ( )

BtObexServerNmaDisconnect::~BtObexServerNmaDisconnect ( )

Member Function Documentation

const BtObexServerNmaDisconnect & BtObexServerNmaDisconnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaDisconnect::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaGet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaGet Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaGet:

[legend]
Collaboration diagram for BtObexServerNmaGet:

[legend]

Public Types

enum | { ID = 23 }

Public Member Functions

BtObexServerNmaGet ()
BtObexServerNmaGet (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexServerNmaGet ()

Static Public Member Functions

static const BtObexServerNmaGet & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaGet

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaGet::BtObexServerNmaGet ( const BtResultCode & result )

BtObexServerNmaGet::BtObexServerNmaGet ( )

BtObexServerNmaGet::~BtObexServerNmaGet ( )

Member Function Documentation

const BtObexServerNmaGet & BtObexServerNmaGet::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaGet::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaHeaderIndication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaHeaderIndication Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaHeaderIndication:

[legend]
Collaboration diagram for BtObexServerNmaHeaderIndication:

[legend]

Public Types

enum | { ID = 27 }

Public Member Functions

BtObexServerNmaHeaderIndication ()
BtObexServerNmaHeaderIndication (const BtResultCode &result, const BtObexHeader &header)
const BtObexHeader & | GetHeader () const
const BtResultCode & | GetResult () const
~BtObexServerNmaHeaderIndication ()

Static Public Member Functions

static const BtObexServerNmaHeaderIndication & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaHeaderIndication

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaHeaderIndication::BtObexServerNmaHeaderIndication | ( | const BtResultCode & | result,
 |  | const BtObexHeader & | header
 | ) |

BtObexServerNmaHeaderIndication::BtObexServerNmaHeaderIndication ( )

BtObexServerNmaHeaderIndication::~BtObexServerNmaHeaderIndication ( )

Member Function Documentation

const BtObexServerNmaHeaderIndication & BtObexServerNmaHeaderIndication::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtObexHeader& BtObexServerNmaHeaderIndication::GetHeader ( ) const [inline]

const BtResultCode& BtObexServerNmaHeaderIndication::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaHeaderSent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaHeaderSent Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaHeaderSent:

[legend]
Collaboration diagram for BtObexServerNmaHeaderSent:

[legend]

Public Types

enum | { ID = 26 }

Public Member Functions

BtObexServerNmaHeaderSent ()
BtObexServerNmaHeaderSent (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexServerNmaHeaderSent ()

Static Public Member Functions

static const BtObexServerNmaHeaderSent & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaHeaderSent

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaHeaderSent::BtObexServerNmaHeaderSent ( const BtResultCode & result )

BtObexServerNmaHeaderSent::BtObexServerNmaHeaderSent ( )

BtObexServerNmaHeaderSent::~BtObexServerNmaHeaderSent ( )

Member Function Documentation

const BtObexServerNmaHeaderSent & BtObexServerNmaHeaderSent::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaHeaderSent::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaPut Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaPut Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaPut:

[legend]
Collaboration diagram for BtObexServerNmaPut:

[legend]

Public Types

enum | { ID = 24 }

Public Member Functions

BtObexServerNmaPut ()
BtObexServerNmaPut (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexServerNmaPut ()

Static Public Member Functions

static const BtObexServerNmaPut & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaPut

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaPut::BtObexServerNmaPut ( const BtResultCode & result )

BtObexServerNmaPut::BtObexServerNmaPut ( )

BtObexServerNmaPut::~BtObexServerNmaPut ( )

Member Function Documentation

const BtObexServerNmaPut & BtObexServerNmaPut::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaPut::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaSetPath Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaSetPath Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaSetPath:

[legend]
Collaboration diagram for BtObexServerNmaSetPath:

[legend]

Public Types

enum | { ID = 22 }

Public Member Functions

BtObexServerNmaSetPath ()
BtObexServerNmaSetPath (const BtResultCode &result, BOOLEAN Backup, BOOLEAN Create)
const BtResultCode & | GetResult () const
BOOLEAN | IsBackup () const
BOOLEAN | IsCreate () const
~BtObexServerNmaSetPath ()

Static Public Member Functions

static const BtObexServerNmaSetPath & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaSetPath

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaSetPath::BtObexServerNmaSetPath | ( | const BtResultCode & | result,
 |  | BOOLEAN | Backup,
 |  | BOOLEAN | Create
 | ) |

BtObexServerNmaSetPath::BtObexServerNmaSetPath ( )

BtObexServerNmaSetPath::~BtObexServerNmaSetPath ( )

Member Function Documentation

const BtObexServerNmaSetPath & BtObexServerNmaSetPath::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaSetPath::GetResult ( ) const [inline]

BOOLEAN BtObexServerNmaSetPath::IsBackup ( ) const [inline]

BOOLEAN BtObexServerNmaSetPath::IsCreate ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNmaTransportDisconnect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNmaTransportDisconnect Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp>

Inheritance diagram for BtObexServerNmaTransportDisconnect:

[legend]
Collaboration diagram for BtObexServerNmaTransportDisconnect:

[legend]

Public Types

enum | { ID = 30 }

Public Member Functions

BtObexServerNmaTransportDisconnect ()
BtObexServerNmaTransportDisconnect (const BtResultCode &result)
const BtResultCode & | GetResult () const
~BtObexServerNmaTransportDisconnect ()

Static Public Member Functions

static const BtObexServerNmaTransportDisconnect & | Cast (const StackMsgArgument &arg)

Friends

class | BtObexMessageArgumentsDestroyTableNode

Detailed Description

BtObexServerNmaTransportDisconnect

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerNmaTransportDisconnect::BtObexServerNmaTransportDisconnect ( const BtResultCode & result )

BtObexServerNmaTransportDisconnect::BtObexServerNmaTransportDisconnect ( )

BtObexServerNmaTransportDisconnect::~BtObexServerNmaTransportDisconnect ( )

Member Function Documentation

const BtObexServerNmaTransportDisconnect & BtObexServerNmaTransportDisconnect::Cast ( const StackMsgArgument & arg ) [inline, static]

const BtResultCode& BtObexServerNmaTransportDisconnect::GetResult ( ) const [inline]

Friends And Related Function Documentation

friend class BtObexMessageArgumentsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.hpp
  • Bluetooth/OBEX/BtObexNotificationMessageArgument.cpp
Generated on Wed Jan 25 01:01:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerNotificationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerNotificationMessage Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexNotificationMessage.hpp>

Inheritance diagram for BtObexServerNotificationMessage:

[legend]
Collaboration diagram for BtObexServerNotificationMessage:

[legend]

Public Types

enum | { ID = 10106 }

Public Member Functions

BtObexServerNotificationMessage (const BtObexServerNotificationMessage &message)
Constructor.
BtObexServerNotificationMessage (BtObexServerService *service, StackMsgArgument *argument=0)
Constructor.
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BtObexServerService * | GetService () const
virtual BtObexServerNotificationMessage & | operator= (const BtObexServerNotificationMessage &message)
virtual FromStackMsg & | operator= (const FromStackMsg &message)
virtual | ~BtObexServerNotificationMessage ()
Destructor.
The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexNotificationMessage.hpp
  • Bluetooth/OBEX/BtObexNotificationMessage.cpp
Generated on Wed Jan 25 01:01:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerObserverImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerObserverImpl Class Reference

This class contains the implementation of the Server Service Observer, related to the Bt stack/controller callbacks for Obex Server operations (Put, Get, ...). More...

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp>

Inheritance diagram for BtObexServerObserverImpl:

[legend]
Collaboration diagram for BtObexServerObserverImpl:

[legend]

Public Member Functions

BtObexServerObserverImpl ()
Constructor.
void | SetIndex (UINT8 id)
Store the Server instance number of the BtObexImpl object in the Server Observer instance.
virtual | ~BtObexServerObserverImpl ()
Destructor.

Protected Member Functions

virtual void | OnAbort (BtResultCode code)
virtual void | OnBufferRequested (BtResultCode result, UINT16 last_buffer_filled, BOOLEAN delete_object, BOOLEAN create_empty_object)
virtual void | OnConnect (BtResultCode code, const BtDevice &device)
virtual void | OnDataRequested (BtResultCode result)
virtual void | OnDisconnect (BtResultCode code)
virtual void | OnError (BtObexErrorCode error)
virtual void | OnGet (BtResultCode code)
virtual void | OnHeader (BtResultCode result, const BtObexHeader &header)
virtual void | OnHeaderSent (BtResultCode result)
virtual void | OnPut (BtResultCode code)
virtual void | OnRegister (BtResultCode code, UINT8 rfcom_channel)
virtual void | OnSetPath (BtResultCode code, BOOLEAN backup, BOOLEAN create)
virtual void | OnTransportDisconnect (BtResultCode result)
virtual void | OnUnregister (BtResultCode result)

Friends

class | BtObexImpl
The BtObexImpl can access BtObexServerObserverImpl.

Detailed Description

This class contains the implementation of the Server Service Observer, related to the Bt stack/controller callbacks for Obex Server operations (Put, Get, ...).

Constructor & Destructor Documentation

BtObexServerObserverImpl::BtObexServerObserverImpl ( )

Constructor.

BtObexServerObserverImpl::~BtObexServerObserverImpl ( ) [virtual]

Destructor.

Member Function Documentation

void BtObexServerObserverImpl::OnAbort ( BtResultCode code ) [protected, virtual]

Implements BtObexServerServiceObserver.

void BtObexServerObserverImpl::OnBufferRequested | ( | BtResultCode | result,
 |  | UINT16 | last_buffer_filled,
 |  | BOOLEAN | delete_object,
 |  | BOOLEAN | create_empty_object
 | ) | [protected, virtual]

Implements BtObexServiceObserver.

void BtObexServerObserverImpl::OnConnect | ( | BtResultCode | code,
 |  | const BtDevice & | device
 | ) | [protected, virtual]

Implements BtObexServerServiceObserver.

void BtObexServerObserverImpl::OnDataRequested ( BtResultCode result ) [protected, virtual]

Implements BtObexServiceObserver.

void BtObexServerObserverImpl::OnDisconnect ( BtResultCode code ) [protected, virtual]

Implements BtObexServerServiceObserver.

virtual void BtObexServerObserverImpl::OnError ( BtObexErrorCode error ) [inline, protected, virtual]

Implements BtObexServiceObserver.

void BtObexServerObserverImpl::OnGet ( BtResultCode code ) [protected, virtual]

Implements BtObexServerServiceObserver.

void BtObexServerObserverImpl::OnHeader | ( | BtResultCode | result,
 |  | const BtObexHeader & | header
 | ) | [protected, virtual]

Implements BtObexServiceObserver.

void BtObexServerObserverImpl::OnHeaderSent ( BtResultCode result ) [protected, virtual]

Implements BtObexServiceObserver.

void BtObexServerObserverImpl::OnPut ( BtResultCode code ) [protected, virtual]

Implements BtObexServerServiceObserver.

void BtObexServerObserverImpl::OnRegister | ( | BtResultCode | code,
 |  | UINT8 | rfcom_channel
 | ) | [protected, virtual]

Implements BtObexServerServiceObserver.

void BtObexServerObserverImpl::OnSetPath | ( | BtResultCode | code,
 |  | BOOLEAN | backup,
 |  | BOOLEAN | create
 | ) | [protected, virtual]

Implements BtObexServerServiceObserver.

void BtObexServerObserverImpl::OnTransportDisconnect ( BtResultCode result ) [protected, virtual]

Implements BtObexServiceObserver.

void BtObexServerObserverImpl::OnUnregister ( BtResultCode result ) [protected, virtual]

Implements BtObexServiceObserver.

void BtObexServerObserverImpl::SetIndex ( UINT8 id ) [inline]

Store the Server instance number of the BtObexImpl object in the Server Observer instance.

Parameters:
id instance of the Server connection
This function should be used by the Bt Obex Implementation only

Friends And Related Function Documentation

friend class BtObexImpl [friend]

The BtObexImpl can access BtObexServerObserverImpl.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexServerObserverImpl.cpp
Generated on Wed Jan 25 01:01:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerPutIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerPutIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexServerPutIndicationEvent:

[legend]
Collaboration diagram for BtObexServerPutIndicationEvent:

[legend]

Public Types

enum | { ID = 12 }

Public Member Functions

BtObexServerPutIndicationEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexServerPutIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerPutIndicationEvent::BtObexServerPutIndicationEvent ( BtResultCode result )

Constructor.

BtObexServerPutIndicationEvent::~BtObexServerPutIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexServerPutIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:01:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/OBEX/BtObexServiceMessage.hpp>

Inheritance diagram for BtObexServerRequestStateChangedMessage:

[legend]
Collaboration diagram for BtObexServerRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10335 }

Public Member Functions

BtObexServerRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtObexServerRequestStateChangedMessage ()

Detailed Description

BtObexServerRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtObexServerRequestStateChangedMessage::BtObexServerRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtObexServerRequestStateChangedMessage::~BtObexServerRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtObexServerRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtObexServerRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexServiceMessage.hpp
  • Bluetooth/OBEX/BtObexServiceMessage.cpp
Generated on Wed Jan 25 01:01:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexServerService.hpp>

Inheritance diagram for BtObexServerService:

[legend]
Collaboration diagram for BtObexServerService:

[legend]

Public Member Functions

BOOLEAN | Attach (BtObexServerServiceObserver *service_observer)
BtObexServerService ()
Constructor.
BOOLEAN | DataBufferIndication (UINT8 *data_buffer, UINT16 data_buffer_size, UINT8 response_code=0)
BOOLEAN | DataIndication (const UINT8 *data, UINT16 data_size, BOOLEAN more_data_pending=FALSE, UINT8 response_code=0)
BOOLEAN | Detach (BtObexServerServiceObserver *service_observer)
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
UINT8 | GetRfComChannel () const
virtual BOOLEAN | IsServerService () const
virtual BtRequestState | RegisterRequest (UINT8 *header_buffer, UINT16 header_buffer_size, BtSecuritySettings security_settings=BtSesNoSecurity)
BOOLEAN | SendResponse (UINT8 response_code)
virtual BtRequestState | UnregisterRequest ()
virtual | ~BtObexServerService ()
Destructor.

Friends

class | BtObexController
class | BtObexRegisterServerRequest
class | BtObexUnregisterServerRequest

Constructor & Destructor Documentation

BtObexServerService::BtObexServerService ( )

Constructor.

BtObexServerService::~BtObexServerService ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexServerService::Attach ( BtObexServerServiceObserver * service_observer )

BOOLEAN BtObexServerService::DataBufferIndication | ( | UINT8 * | data_buffer,
 |  | UINT16 | data_buffer_size,
 |  | UINT8 | response_code = 0
 | ) |

BOOLEAN BtObexServerService::DataIndication | ( | const UINT8 * | data,
 |  | UINT16 | data_size,
 |  | BOOLEAN | more_data_pending = FALSE,
 |  | UINT8 | response_code = 0
 | ) |

BOOLEAN BtObexServerService::Detach ( BtObexServerServiceObserver * service_observer )

BtRequestState BtObexServerService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

UINT8 BtObexServerService::GetRfComChannel ( ) const

BOOLEAN BtObexServerService::IsServerService ( ) const [virtual]

Implements BtObexService.

BtRequestState BtObexServerService::RegisterRequest | ( | UINT8 * | header_buffer,
 |  | UINT16 | header_buffer_size,
 |  | BtSecuritySettings | security_settings = BtSesNoSecurity
 | ) | [virtual]

Implements BtObexService.

BOOLEAN BtObexServerService::SendResponse ( UINT8 response_code )

BtRequestState BtObexServerService::UnregisterRequest ( ) [virtual]

Implements BtObexService.

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexService.

friend class BtObexRegisterServerRequest [friend]

friend class BtObexUnregisterServerRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexServerService.hpp
  • Bluetooth/OBEX/BtObexServerService.cpp
Generated on Wed Jan 25 01:01:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerServiceImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerServiceImpl Class Reference

This class contains the extension of the BtObexServerService class. More...

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp>

Inheritance diagram for BtObexServerServiceImpl:

[legend]
Collaboration diagram for BtObexServerServiceImpl:

[legend]

Public Member Functions

BtObexServerServiceImpl ()
virtual | ~BtObexServerServiceImpl ()

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)
Notification function of changes in running requests.

Detailed Description

This class contains the extension of the BtObexServerService class.

This is necessary because one of the ancestor classes contains one pure virtual function (currently unused in the Bt Obex Transport Adapter implementation)

Constructor & Destructor Documentation

BtObexServerServiceImpl::BtObexServerServiceImpl ( )

BtObexServerServiceImpl::~BtObexServerServiceImpl ( ) [virtual]

Member Function Documentation

void BtObexServerServiceImpl::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Notification function of changes in running requests.

Whenever the state of a request contained in this service is changed OnRequestStateChange will be called. This function should give the application programmer to do some GUI reaction to the progress or the failure of a partikular request.
This function has to be implemented by the application programmer, so in the base classes this function is pure virtual.

Parameters:
request_type | A BtRequestType enumeration type describing which kind of request has changed its state.
old_request_state | A BtRequestState enumeration type containing the state of the request before the state transition.
new_request_state | A BtRequestState enumeration type containing the state of the request after the state transition.

Implements BtService.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexServerServiceImpl.cpp
Generated on Wed Jan 25 01:01:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerServiceObserver Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerServiceObserver Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexServerServiceObserver.hpp>

Inheritance diagram for BtObexServerServiceObserver:

[legend]
Collaboration diagram for BtObexServerServiceObserver:

[legend]

Public Member Functions

BtObexServerServiceObserver ()
Constructor.
virtual | ~BtObexServerServiceObserver ()
Destructor.

Protected Member Functions

virtual void | OnAbort (BtResultCode code)=0
virtual void | OnConnect (BtResultCode code, const BtDevice &device)=0
virtual void | OnDisconnect (BtResultCode code)=0
virtual void | OnEvent (const BtEvent &event)
virtual void | OnGet (BtResultCode code)=0
virtual void | OnPut (BtResultCode code)=0
virtual void | OnRegister (BtResultCode code, UINT8 rfcom_channel)=0
virtual void | OnSetPath (BtResultCode code, BOOLEAN backup, BOOLEAN create)=0

Friends

class | BtObexServerService

Constructor & Destructor Documentation

BtObexServerServiceObserver::BtObexServerServiceObserver ( )

Constructor.

BtObexServerServiceObserver::~BtObexServerServiceObserver ( ) [virtual]

Destructor.

Member Function Documentation

virtual void BtObexServerServiceObserver::OnAbort ( BtResultCode code ) [protected, pure virtual]

Implemented in BtObexServerObserverImpl.

virtual void BtObexServerServiceObserver::OnConnect | ( | BtResultCode | code,
 |  | const BtDevice & | device
 | ) | [protected, pure virtual]

Implemented in BtObexServerObserverImpl.

virtual void BtObexServerServiceObserver::OnDisconnect ( BtResultCode code ) [protected, pure virtual]

Implemented in BtObexServerObserverImpl.

void BtObexServerServiceObserver::OnEvent ( const BtEvent & event ) [protected, virtual]

Reimplemented from BtObexServiceObserver.

virtual void BtObexServerServiceObserver::OnGet ( BtResultCode code ) [protected, pure virtual]

Implemented in BtObexServerObserverImpl.

virtual void BtObexServerServiceObserver::OnPut ( BtResultCode code ) [protected, pure virtual]

Implemented in BtObexServerObserverImpl.

virtual void BtObexServerServiceObserver::OnRegister | ( | BtResultCode | code,
 |  | UINT8 | rfcom_channel
 | ) | [protected, pure virtual]

Implemented in BtObexServerObserverImpl.

virtual void BtObexServerServiceObserver::OnSetPath | ( | BtResultCode | code,
 |  | BOOLEAN | backup,
 |  | BOOLEAN | create
 | ) | [protected, pure virtual]

Implemented in BtObexServerObserverImpl.

Friends And Related Function Documentation

friend class BtObexServerService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexServerServiceObserver.hpp
  • Bluetooth/OBEX/BtObexServerServiceObserver.cpp
Generated on Wed Jan 25 01:02:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServerSetPathIndicationEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServerSetPathIndicationEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexServerSetPathIndicationEvent:

[legend]
Collaboration diagram for BtObexServerSetPathIndicationEvent:

[legend]

Public Types

enum | { ID = 10 }

Public Member Functions

BtObexServerSetPathIndicationEvent (BtResultCode result, BOOLEAN backup, BOOLEAN create)
Constructor.
BOOLEAN | GetBackup () const
BOOLEAN | GetCreate () const
virtual UINT16 | GetId () const
virtual | ~BtObexServerSetPathIndicationEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexServerSetPathIndicationEvent::BtObexServerSetPathIndicationEvent | ( | BtResultCode | result,
 |  | BOOLEAN | backup,
 |  | BOOLEAN | create
 | ) |

Constructor.

BtObexServerSetPathIndicationEvent::~BtObexServerSetPathIndicationEvent ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexServerSetPathIndicationEvent::GetBackup ( ) const

BOOLEAN BtObexServerSetPathIndicationEvent::GetCreate ( ) const

UINT16 BtObexServerSetPathIndicationEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:02:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexService.hpp>

Inheritance diagram for BtObexService:

[legend]
Collaboration diagram for BtObexService:

[legend]

Public Member Functions

BOOLEAN | AddHeader (UINT8 header_id, WString header_value)
BOOLEAN | AddHeader (UINT8 header_id, UINT8 *header_value, UINT16 header_value_length)
BOOLEAN | AddHeader (UINT8 header_id, UINT32 header_value)
BOOLEAN | AddHeader (UINT8 header_id, UINT8 header_value)
BtObexService ()
Constructor.
BOOLEAN | DiscardHeaders ()
BOOLEAN | GetFreeSize (UINT16 &bytes_free)
virtual BtProfile | GetProfile () const
Get the profile this service is associated with.
virtual BOOLEAN | IsServerService () const =0
virtual BtRequestState | RegisterRequest (UINT8 *header_buffer, UINT16 header_buffer_size, BtSecuritySettings security_settings=BtSesNoSecurity)=0
virtual BtRequestState | UnregisterRequest ()=0
virtual | ~BtObexService ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &message)
virtual void | RegisterMessages () const
virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)
void | UnregisterCallback (BtResultCode result)
virtual void | UnregisterMessages () const

Friends

class | BtObexController
class | BtObexRequest

Constructor & Destructor Documentation

BtObexService::BtObexService ( )

Constructor.

BtObexService::~BtObexService ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexService::AddHeader | ( | UINT8 | header_id,
 |  | WString | header_value
 | ) |

BOOLEAN BtObexService::AddHeader | ( | UINT8 | header_id,
 |  | UINT8 * | header_value,
 |  | UINT16 | header_value_length
 | ) |

BOOLEAN BtObexService::AddHeader | ( | UINT8 | header_id,
 |  | UINT32 | header_value
 | ) |

BOOLEAN BtObexService::AddHeader | ( | UINT8 | header_id,
 |  | UINT8 | header_value
 | ) |

BOOLEAN BtObexService::DiscardHeaders ( )

BOOLEAN BtObexService::GetFreeSize ( UINT16 & bytes_free )

BtProfile BtObexService::GetProfile ( ) const [virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface, so in the base class, it is a pure virtual function.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implements BtService.

virtual BOOLEAN BtObexService::IsServerService ( ) const [pure virtual]

Implemented in BtObexClientService, and BtObexServerService.

BOOLEAN BtObexService::OnMessage ( const Message & message ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void BtObexService::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

virtual BtRequestState BtObexService::RegisterRequest | ( | UINT8 * | header_buffer,
 |  | UINT16 | header_buffer_size,
 |  | BtSecuritySettings | security_settings = BtSesNoSecurity
 | ) | [pure virtual]

Implemented in BtObexClientService, and BtObexServerService.

void BtObexService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Implements BtService.

void BtObexService::UnregisterCallback ( BtResultCode result ) [protected]

void BtObexService::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

virtual BtRequestState BtObexService::UnregisterRequest ( ) [pure virtual]

Implemented in BtObexClientService, and BtObexServerService.

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented in BtObexServerService.

friend class BtObexRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexService.hpp
  • Bluetooth/OBEX/BtObexService.cpp
Generated on Wed Jan 25 01:02:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServiceObserver Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServiceObserver Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexServiceObserver.hpp>

Inheritance diagram for BtObexServiceObserver:

[legend]
Collaboration diagram for BtObexServiceObserver:

[legend]

Public Member Functions

BtObexServiceObserver ()
Constructor.
virtual | ~BtObexServiceObserver ()
Destructor.

Protected Member Functions

virtual void | OnBufferRequested (BtResultCode result, UINT16 last_buffer_filled, BOOLEAN delete_object, BOOLEAN create_empty_object)=0
virtual void | OnDataRequested (BtResultCode result)=0
virtual void | OnError (BtObexErrorCode error)=0
virtual void | OnEvent (const BtEvent &event)
virtual void | OnHeader (BtResultCode result, const BtObexHeader &header)=0
virtual void | OnHeaderSent (BtResultCode result)=0
virtual void | OnTransportDisconnect (BtResultCode result)=0
virtual void | OnUnregister (BtResultCode result)=0

Friends

class | BtObexService

Constructor & Destructor Documentation

BtObexServiceObserver::BtObexServiceObserver ( )

Constructor.

BtObexServiceObserver::~BtObexServiceObserver ( ) [virtual]

Destructor.

Member Function Documentation

virtual void BtObexServiceObserver::OnBufferRequested | ( | BtResultCode | result,
 |  | UINT16 | last_buffer_filled,
 |  | BOOLEAN | delete_object,
 |  | BOOLEAN | create_empty_object
 | ) | [protected, pure virtual]

Implemented in BtObexClientObserverImpl, and BtObexServerObserverImpl.

virtual void BtObexServiceObserver::OnDataRequested ( BtResultCode result ) [protected, pure virtual]

Implemented in BtObexClientObserverImpl, and BtObexServerObserverImpl.

virtual void BtObexServiceObserver::OnError ( BtObexErrorCode error ) [protected, pure virtual]

Implemented in BtObexClientObserverImpl, and BtObexServerObserverImpl.

void BtObexServiceObserver::OnEvent ( const BtEvent & event ) [protected, virtual]

Implements BtServiceObserver.

Reimplemented in BtObexClientServiceObserver, and BtObexServerServiceObserver.

virtual void BtObexServiceObserver::OnHeader | ( | BtResultCode | result,
 |  | const BtObexHeader & | header
 | ) | [protected, pure virtual]

Implemented in BtObexClientObserverImpl, and BtObexServerObserverImpl.

virtual void BtObexServiceObserver::OnHeaderSent ( BtResultCode result ) [protected, pure virtual]

Implemented in BtObexClientObserverImpl, and BtObexServerObserverImpl.

virtual void BtObexServiceObserver::OnTransportDisconnect ( BtResultCode result ) [protected, pure virtual]

Implemented in BtObexClientObserverImpl, and BtObexServerObserverImpl.

virtual void BtObexServiceObserver::OnUnregister ( BtResultCode result ) [protected, pure virtual]

Implemented in BtObexClientObserverImpl, and BtObexServerObserverImpl.

Friends And Related Function Documentation

friend class BtObexService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexServiceObserver.hpp
  • Bluetooth/OBEX/BtObexServiceObserver.cpp
Generated on Wed Jan 25 01:02:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServiceTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexServiceTable Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp>

Collaboration diagram for BtObexServiceTable:

[legend]

Public Types

enum | { MAX_LEN_TARGET = 24 }
typedef UINT8 | ServiceType

Static Public Member Functions

static void | ExtendToUuid128 (BtUUID &uuid128, const BtUUID &uuid_in)
static ServiceInfo | GetServiceInfoByTarget (const ByteBuffer &target)
static ServiceInfo | GetServiceInfoByType (UINT serv_type)
static ServiceInfo | GetServiceInfoByUuid (const BtUUID &uuid)

Data Structures

struct | Entry
struct | ObexTarget
struct | Security
class | ServiceInfo

Member Typedef Documentation

typedef UINT8 BtObexServiceTable::ServiceType

Member Enumeration Documentation

anonymous enum

Enumerator:
MAX_LEN_TARGET

Member Function Documentation

void BtObexServiceTable::ExtendToUuid128 | ( | BtUUID & | uuid128,
 |  | const BtUUID & | uuid_in
 | ) | [static]

BtObexServiceTable::ServiceInfo BtObexServiceTable::GetServiceInfoByTarget ( const ByteBuffer & target ) [static]

BtObexServiceTable::ServiceInfo BtObexServiceTable::GetServiceInfoByType ( UINT serv_type ) [static]

BtObexServiceTable::ServiceInfo BtObexServiceTable::GetServiceInfoByUuid ( const BtUUID & uuid ) [static]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexServiceTable.cpp
Generated on Wed Jan 25 01:02:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServiceTable::Entry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtObexServiceTable::Entry

BtObexServiceTable::Entry Struct Reference

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp>

Collaboration diagram for BtObexServiceTable::Entry:

[legend]

Data Fields

ObexTarget obex_target
BtUUID service_class
const CHAR * service_name
Security service_ses
ServiceType service_type

Field Documentation

ObexTarget BtObexServiceTable::Entry::obex_target

BtUUID BtObexServiceTable::Entry::service_class

const CHAR* BtObexServiceTable::Entry::service_name

Security BtObexServiceTable::Entry::service_ses

ServiceType BtObexServiceTable::Entry::service_type

The documentation for this struct was generated from the following file:
  • Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp
Generated on Wed Jan 25 01:02:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServiceTable::ObexTarget Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtObexServiceTable::ObexTarget

BtObexServiceTable::ObexTarget Struct Reference

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp>

Data Fields

UINT8 | data [MAX_LEN_TARGET]
UINT8 | length

Field Documentation

UINT8 BtObexServiceTable::ObexTarget::data[MAX_LEN_TARGET]

UINT8 BtObexServiceTable::ObexTarget::length

The documentation for this struct was generated from the following file:
  • Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp
Generated on Wed Jan 25 01:02:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServiceTable::Security Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtObexServiceTable::Security

BtObexServiceTable::Security Struct Reference

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp>

Data Fields

BtSecuritySettings client
BtSecuritySettings server

Field Documentation

BtSecuritySettings BtObexServiceTable::Security::client

BtSecuritySettings BtObexServiceTable::Security::server

The documentation for this struct was generated from the following file:
  • Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp
Generated on Wed Jan 25 01:02:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexServiceTable::ServiceInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
BtObexServiceTable::ServiceInfo

BtObexServiceTable::ServiceInfo Class Reference

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp>

Collaboration diagram for BtObexServiceTable::ServiceInfo:

[legend]

Public Member Functions

BtSecuritySettings | GetClientSecurity () const
Returns the default client security settings for this service.
BOOLEAN | GetObexTarget (ByteBuffer &target) const
Obtains the OBEX TARGET header of the specific service.
BtSecuritySettings | GetServerSecurity () const
Returns the default client security settings for this service.
BOOLEAN | GetServiceClass (BtUUID &uuid) const
Obtains the service class of the specific service.
const CHAR * | GetServiceName () const
Returns the service name.
ServiceType | GetServiceType () const
Returns the service type identifier (unique key).
BOOLEAN | IsEqualTo (const ServiceInfo &rhs) const
BOOLEAN | IsValid () const
Tells whether service-specific information are available or not.
ServiceInfo ()

Friends

class | BtObexServiceTable

Constructor & Destructor Documentation

BtObexServiceTable::ServiceInfo::ServiceInfo ( )

Member Function Documentation

BtSecuritySettings BtObexServiceTable::ServiceInfo::GetClientSecurity ( ) const [inline]

Returns the default client security settings for this service.

BOOLEAN BtObexServiceTable::ServiceInfo::GetObexTarget ( ByteBuffer & target ) const

Obtains the OBEX TARGET header of the specific service.

BtSecuritySettings BtObexServiceTable::ServiceInfo::GetServerSecurity ( ) const [inline]

Returns the default client security settings for this service.

BOOLEAN BtObexServiceTable::ServiceInfo::GetServiceClass ( BtUUID & uuid ) const

Obtains the service class of the specific service.

const CHAR* BtObexServiceTable::ServiceInfo::GetServiceName ( ) const [inline]

Returns the service name.

ServiceType BtObexServiceTable::ServiceInfo::GetServiceType ( ) const [inline]

Returns the service type identifier (unique key).

BOOLEAN BtObexServiceTable::ServiceInfo::IsEqualTo ( const ServiceInfo & rhs ) const [inline]

BOOLEAN BtObexServiceTable::ServiceInfo::IsValid ( ) const [inline]

Tells whether service-specific information are available or not.

Friends And Related Function Documentation

friend class BtObexServiceTable [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexServiceTable.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexServiceTable.cpp
Generated on Wed Jan 25 01:02:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexSetPathRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexSetPathRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexSetPathRequest.hpp>

Inheritance diagram for BtObexSetPathRequest:

[legend]
Collaboration diagram for BtObexSetPathRequest:

[legend]

Public Member Functions

BtObexSetPathRequest (BtObexClientService &obex_client_service)
Constructor.
BOOLEAN | GetBackup () const
BOOLEAN | GetCreateDirectory () const
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetBackup (BOOLEAN backup=TRUE)
void | SetCreateDirectory (BOOLEAN create_directory=TRUE)
virtual | ~BtObexSetPathRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexSetPathRequest::BtObexSetPathRequest ( BtObexClientService & obex_client_service )

Constructor.

BtObexSetPathRequest::~BtObexSetPathRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexSetPathRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexSetPathRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

BOOLEAN BtObexSetPathRequest::GetBackup ( ) const

BOOLEAN BtObexSetPathRequest::GetCreateDirectory ( ) const

BtRequestType BtObexSetPathRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

void BtObexSetPathRequest::SetBackup ( BOOLEAN backup = TRUE )

void BtObexSetPathRequest::SetCreateDirectory ( BOOLEAN create_directory = TRUE )

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexClientOperationRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexSetPathRequest.hpp
  • Bluetooth/OBEX/BtObexSetPathRequest.cpp
Generated on Wed Jan 25 01:02:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexSubSystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexSubSystem Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp>

Inheritance diagram for BtObexSubSystem:

[legend]
Collaboration diagram for BtObexSubSystem:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual BootSequenceState | InvokeAt () const
virtual void | OnPowerUp ()

Member Function Documentation

virtual const WCHAR* BtObexSubSystem::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

virtual BootSequenceState BtObexSubSystem::InvokeAt ( ) const [inline, virtual]

InvokeAt denotes the system boot phase the SubSystem shall be initialized in.

Implements SubSystem.

void BtObexSubSystem::OnPowerUp ( ) [virtual]

This method will be invoked on system power on.

Reimplemented from SubSystem.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexTransport.cpp
Generated on Wed Jan 25 01:02:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexTransport Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp>

Inheritance diagram for BtObexTransport:

[legend]
Collaboration diagram for BtObexTransport:

[legend]

Public Member Functions

virtual ObexProtocol * | GetProtocol (ObexProtocolId level)
Return the proper protocol pointer.
virtual void | ResolveClientAddr (const String &client_url, ObexProtocolId prot_id, ObexOperationId job_id)
Extract infos from the client URL string and associate them to an ObexAddress object just created by this method.
virtual void | ResolveServerAddr (const String &server_url, ObexProtocolId prot_id, BOOLEAN sdb_autocreate, ObexOperationId job_id)
Extract infos from the server URL string and associate them to an ObexAddress object just created by this method.
virtual | ~BtObexTransport ()

Static Public Member Functions

static BtObexTransport * | GetInstance ()
Singleton accessor.
static BtObexImpl & | GetObexInstance ()
Singleton accessor.

Protected Member Functions

BtObexTransport ()
void | Init ()

Friends

class | BtObexClientAddrResultNotifier

Detailed Description

This class contains the implementation of the Obex Abstract Transport operations for the Bluetooth Obex Transport.

Constructor & Destructor Documentation

BtObexTransport::~BtObexTransport ( ) [virtual]

BtObexTransport::BtObexTransport ( ) [protected]

Member Function Documentation

BtObexTransport * BtObexTransport::GetInstance ( ) [static]

Singleton accessor.

BtObexImpl & BtObexTransport::GetObexInstance ( ) [static]

Singleton accessor.

ObexProtocol * BtObexTransport::GetProtocol ( ObexProtocolId level ) [virtual]

Return the proper protocol pointer.

Implements ObexAbstractTransport.

void BtObexTransport::Init ( ) [protected]

void BtObexTransport::ResolveClientAddr | ( | const String & | client_url,
 |  | ObexProtocolId | prot_id,
 |  | ObexOperationId | job_id
 | ) | [virtual]

Extract infos from the client URL string and associate them to an ObexAddress object just created by this method.

Parameters:
client_url | Server Address in URL format
prot_id | Protocol which will be bound to the address
job_id | Reference to associate request and response

Implements ObexAbstractTransport.

void BtObexTransport::ResolveServerAddr | ( | const String & | server_url,
 |  | ObexProtocolId | prot_id,
 |  | BOOLEAN | sdb_autocreate,
 |  | ObexOperationId | job_id
 | ) | [virtual]

Extract infos from the server URL string and associate them to an ObexAddress object just created by this method.

Parameters:
server_url | Server Address in URL format
prot_id | Protocol which will be bound to the address
sdb_autocreate | Check whether address can be autoregistered
job_id | Reference to associate request and response

Implements ObexAbstractTransport.

Friends And Related Function Documentation

friend class BtObexClientAddrResultNotifier [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/ObexTransport/BtObexTransport.hpp
  • Bluetooth/OBEX/ObexTransport/BtObexTransport.cpp
Generated on Wed Jan 25 01:02:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexTransportDisconnectEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexTransportDisconnectEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexTransportDisconnectEvent:

[legend]
Collaboration diagram for BtObexTransportDisconnectEvent:

[legend]

Public Types

enum | { ID = 6 }

Public Member Functions

BtObexTransportDisconnectEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexTransportDisconnectEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexTransportDisconnectEvent::BtObexTransportDisconnectEvent ( BtResultCode result )

Constructor.

BtObexTransportDisconnectEvent::~BtObexTransportDisconnectEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexTransportDisconnectEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:02:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexUnregisterClientRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexUnregisterClientRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp>

Inheritance diagram for BtObexUnregisterClientRequest:

[legend]
Collaboration diagram for BtObexUnregisterClientRequest:

[legend]

Public Member Functions

BtObexUnregisterClientRequest (BtObexClientService &obex_client_service)
Constructor.
btapi_goep_handle_t | GetObexHandle (void) const
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetObexHandle (btapi_goep_handle_t obex_handle)
virtual | ~BtObexUnregisterClientRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexUnregisterClientRequest::BtObexUnregisterClientRequest ( BtObexClientService & obex_client_service )

Constructor.

BtObexUnregisterClientRequest::~BtObexUnregisterClientRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexUnregisterClientRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexUnregisterClientRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

btapi_goep_handle_t BtObexUnregisterClientRequest::GetObexHandle ( void ) const

BtRequestType BtObexUnregisterClientRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

void BtObexUnregisterClientRequest::SetObexHandle ( btapi_goep_handle_t obex_handle )

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexUnregisterClientRequest.hpp
  • Bluetooth/OBEX/BtObexUnregisterClientRequest.cpp
Generated on Wed Jan 25 01:02:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexUnregisterEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexUnregisterEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexEvent.hpp>

Inheritance diagram for BtObexUnregisterEvent:

[legend]
Collaboration diagram for BtObexUnregisterEvent:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

BtObexUnregisterEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtObexUnregisterEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtObexUnregisterEvent::BtObexUnregisterEvent ( BtResultCode result )

Constructor.

BtObexUnregisterEvent::~BtObexUnregisterEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtObexUnregisterEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexEvent.hpp
  • Bluetooth/OBEX/BtObexEvent.cpp
Generated on Wed Jan 25 01:02:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObexUnregisterServerRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObexUnregisterServerRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp>

Inheritance diagram for BtObexUnregisterServerRequest:

[legend]
Collaboration diagram for BtObexUnregisterServerRequest:

[legend]

Public Member Functions

BtObexUnregisterServerRequest (BtObexServerService &obex_server_service)
Constructor.
btapi_goep_handle_t | GetObexHandle (void) const
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetObexHandle (btapi_goep_handle_t obex_handle)
virtual | ~BtObexUnregisterServerRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)

Friends

class | BtObexController

Constructor & Destructor Documentation

BtObexUnregisterServerRequest::BtObexUnregisterServerRequest ( BtObexServerService & obex_server_service )

Constructor.

BtObexUnregisterServerRequest::~BtObexUnregisterServerRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObexUnregisterServerRequest::Execute ( ) [protected, virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

void BtObexUnregisterServerRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Reimplemented from BtServiceRequest.

btapi_goep_handle_t BtObexUnregisterServerRequest::GetObexHandle ( void ) const

BtRequestType BtObexUnregisterServerRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

void BtObexUnregisterServerRequest::SetObexHandle ( btapi_goep_handle_t obex_handle )

Friends And Related Function Documentation

friend class BtObexController [friend]

Reimplemented from BtObexRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/OBEX/BtObexUnregisterServerRequest.hpp
  • Bluetooth/OBEX/BtObexUnregisterServerRequest.cpp
Generated on Wed Jan 25 01:02:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtObservableService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtObservableService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtObservableService.hpp>

Inheritance diagram for BtObservableService:

[legend]
Collaboration diagram for BtObservableService:

[legend]

Public Member Functions

BtObservableService ()
Constructor.
BOOLEAN | GetUseMessageInterface () const
void | SetUseMessageInterface (BOOLEAN use_message_interface)
virtual | ~BtObservableService ()
Destructor.

Protected Member Functions

BOOLEAN | Attach (BtServiceObserver *service_observer)
BOOLEAN | Detach (BtServiceObserver *service_observer)
void | Notify (const BtEvent &event)

Data Structures

class | BtServiceObserverListElement

Constructor & Destructor Documentation

BtObservableService::BtObservableService ( )

Constructor.

BtObservableService::~BtObservableService ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtObservableService::Attach ( BtServiceObserver * service_observer ) [protected]

BOOLEAN BtObservableService::Detach ( BtServiceObserver * service_observer ) [protected]

BOOLEAN BtObservableService::GetUseMessageInterface ( ) const

void BtObservableService::Notify ( const BtEvent & event ) [protected]

void BtObservableService::SetUseMessageInterface ( BOOLEAN use_message_interface )

The documentation for this class was generated from the following files:
  • Bluetooth/BtObservableService.hpp
  • Bluetooth/BtObservableService.cpp
Generated on Wed Jan 25 01:02:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtOpenMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtOpenMessage Class Reference

#include <Apoxi/Bluetooth/BtRequestMessage.hpp>

Inheritance diagram for BtOpenMessage:

[legend]
Collaboration diagram for BtOpenMessage:

[legend]

Public Types

enum | { ID = 10201 }

Public Member Functions

BtOpenMessage (const BtResultCode &result, UINT32 request_id, const BtProfile &profile)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const BtProfile & | GetProfile () const
void | SetProfile (const BtProfile &profile)
virtual | ~BtOpenMessage ()

Detailed Description

BtOpenMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtOpenMessage::BtOpenMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const BtProfile & | profile
 | ) |

BtOpenMessage::~BtOpenMessage ( ) [virtual]

Member Function Documentation

Message * BtOpenMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestMessage.

const MsgMetaData & BtOpenMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestMessage.

const BtProfile& BtOpenMessage::GetProfile ( ) const [inline]

void BtOpenMessage::SetProfile ( const BtProfile & profile ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtRequestMessage.hpp
  • Bluetooth/BtRequestMessage.cpp
Generated on Wed Jan 25 01:02:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtOperationBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtOperationBase Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtOperationBase.hpp>

Inheritance diagram for BtOperationBase:

[legend]
Collaboration diagram for BtOperationBase:

[legend]

Public Types

enum | BtErrorReason { BtErUnknown, BtErUserBreak, BtErOperationResultInvalid, BtErOperationFailure }

Public Member Functions

BtOperationBase ()
Constructor.
BtErrorReason | GetErrorReason () const
virtual BtOperationType | GetOperationType () const =0
BtResultCode | GetResult () const
void | SetErrorReason (BtErrorReason error_reason)
void | SetResult (BtResultCode result, BtErrorReason error_reason=BtErUnknown)
virtual | ~BtOperationBase ()
Destructor.

Protected Member Functions

virtual void | OnResult (BtResultCode result)=0
The documentation for this class was generated from the following files:
  • Bluetooth/BtOperationBase.hpp
  • Bluetooth/BtOperationBase.cpp
Generated on Wed Jan 25 01:02:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtOperationSelectDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtOperationSelectDevice Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtOperationSelectDevice.hpp>

Inheritance diagram for BtOperationSelectDevice:

[legend]
Collaboration diagram for BtOperationSelectDevice:

[legend]

Public Member Functions

BtOperationSelectDevice (const BtDeviceFilter &device_filter=BtDeviceFilter())
Constructor.
const BtDevice & | GetDevice () const
const BtDeviceFilter & | GetDeviceFilter () const
virtual BtOperationType | GetOperationType () const
void | SetDevice (const BtDevice &device)
void | SetDeviceFilter (const BtDeviceFilter &device_filter)
virtual | ~BtOperationSelectDevice ()
Destructor.
The documentation for this class was generated from the following files:
  • Bluetooth/BtOperationSelectDevice.hpp
  • Bluetooth/BtOperationSelectDevice.cpp
Generated on Wed Jan 25 01:02:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtOperationSelectDeviceAndPerformServiceVerify Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtOperationSelectDeviceAndPerformServiceVerify Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp>

Inheritance diagram for BtOperationSelectDeviceAndPerformServiceVerify:

[legend]
Collaboration diagram for BtOperationSelectDeviceAndPerformServiceVerify:

[legend]

Public Member Functions

BtOperationSelectDeviceAndPerformServiceVerify ()
Constructor.
const BtAttributeId * | GetAttributesRequested () const
const BtDevice & | GetDevice () const
const BtDeviceFilter & | GetDeviceFilter () const
BtDeviceRelation | GetDeviceRelation () const
UINT8 | GetNumberOfAttributesRequested () const
UINT8 | GetNumberOfServicesToVerify () const
virtual BtOperationType | GetOperationType () const
const BtUUID * | GetServiceToVerify () const
const BtServiceVerifyResult & | GetServiceVerifyResult () const
BOOLEAN | SetAttributesRequested (const BtAttributeId *attributes_requested, UINT8 number_of_attributes_requested)
void | SetDevice (const BtDevice &device)
void | SetDeviceFilter (const BtDeviceFilter &device_filter)
void | SetDeviceReleation (BtDeviceRelation device_relation)
BOOLEAN | SetServicesToVerify (const BtUUID *services_to_verify, UINT8 number_of_services_to_verify)
BOOLEAN | SetServiceVerifyResult (const BtServiceVerifyResult &service_verify_result)
virtual | ~BtOperationSelectDeviceAndPerformServiceVerify ()
Destructor.
The documentation for this class was generated from the following files:
  • Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.hpp
  • Bluetooth/BtOperationSelectDeviceAndPerformServiceVerify.cpp
Generated on Wed Jan 25 01:02:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtPairabilityMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtPairabilityMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtPairabilityMessage:

[legend]
Collaboration diagram for BtPairabilityMessage:

[legend]

Public Types

enum | { ID = 10215 }

Public Member Functions

BtPairabilityMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtPairabilityMessage ()

Detailed Description

BtPairabilityMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtPairabilityMessage::BtPairabilityMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtPairabilityMessage::~BtPairabilityMessage ( ) [virtual]

Member Function Documentation

Message * BtPairabilityMessage::Clone ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

const MsgMetaData & BtPairabilityMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:02:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtPasskeyRequiredMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtPasskeyRequiredMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapApplicationMessage.hpp>

Inheritance diagram for BtPasskeyRequiredMessage:

[legend]
Collaboration diagram for BtPasskeyRequiredMessage:

[legend]

Public Types

enum | { ID = 10012 }

Public Member Functions

BtPasskeyRequiredMessage (const BtResultCode &result, const BtDeviceAddress &device_address, const WString &device_name)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtPasskeyRequiredMessage ()

Detailed Description

BtPasskeyRequiredMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtPasskeyRequiredMessage::BtPasskeyRequiredMessage | ( | const BtResultCode & | result,
 |  | const BtDeviceAddress & | device_address,
 |  | const WString & | device_name
 | ) |

BtPasskeyRequiredMessage::~BtPasskeyRequiredMessage ( ) [virtual]

Member Function Documentation

Message * BtPasskeyRequiredMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRemoteRequestMessage.

const MsgMetaData & BtPasskeyRequiredMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRemoteRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapApplicationMessage.hpp
  • Bluetooth/BtGapAndSdapApplicationMessage.cpp
Generated on Wed Jan 25 01:02:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtPasskeyRequiredWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtPasskeyRequiredWindow Class Reference

#include <Applications/BtApp/BtApplicationWindows.hpp>

Collaboration diagram for BtPasskeyRequiredWindow:

[legend]

Public Member Functions

BtPasskeyRequiredWindow ()
void | Init ()
void | SetRemoteDeviceAddress (const BtDeviceAddress &remote_device_address)
void | SetRemoteDeviceName (const WString &remote_device_name)
virtual | ~BtPasskeyRequiredWindow ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual BOOLEAN | OnKeyDown (KeyCode code)
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &message)
virtual void | OnOpen ()
virtual BOOLEAN | OnTimeout (const Timer &timer)

Detailed Description

BtPasskeyRequiredWindow window is used to request user to enter passkey

Constructor & Destructor Documentation

BtPasskeyRequiredWindow::BtPasskeyRequiredWindow ( )

BtPasskeyRequiredWindow::~BtPasskeyRequiredWindow ( ) [virtual]

Member Function Documentation

void BtPasskeyRequiredWindow::Init ( )

BOOLEAN BtPasskeyRequiredWindow::OnCancel ( ) [protected, virtual]

BOOLEAN BtPasskeyRequiredWindow::OnConfirm ( ) [protected, virtual]

BOOLEAN BtPasskeyRequiredWindow::OnKeyDown ( KeyCode code ) [protected, virtual]

void BtPasskeyRequiredWindow::OnLayoutClient ( ) [protected, virtual]

BOOLEAN BtPasskeyRequiredWindow::OnMessage ( const Message & message ) [protected, virtual]

void BtPasskeyRequiredWindow::OnOpen ( ) [protected, virtual]

BOOLEAN BtPasskeyRequiredWindow::OnTimeout ( const Timer & timer ) [protected, virtual]

void BtPasskeyRequiredWindow::SetRemoteDeviceAddress ( const BtDeviceAddress & remote_device_address )

void BtPasskeyRequiredWindow::SetRemoteDeviceName ( const WString & remote_device_name )

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationWindows.hpp
  • Applications/BtApp/BtApplicationWindows.cpp
Generated on Wed Jan 25 01:02:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtPaSupportedProfileMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtPaSupportedProfileMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtPaSupportedProfileMessage:

[legend]
Collaboration diagram for BtPaSupportedProfileMessage:

[legend]

Public Types

enum | { ID = 10232 }

Public Member Functions

BtPaSupportedProfileMessage (const BtResultCode &result, UINT32 request_id, const WString &pa_profile_name)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetPaProfileName () const
void | SetPaProfileName (const WString &pa_profile_name)
virtual | ~BtPaSupportedProfileMessage ()

Detailed Description

BtPaSupportedProfileMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtPaSupportedProfileMessage::BtPaSupportedProfileMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const WString & | pa_profile_name
 | ) |

BtPaSupportedProfileMessage::~BtPaSupportedProfileMessage ( ) [virtual]

Member Function Documentation

Message * BtPaSupportedProfileMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtPaSupportedProfileMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const WString& BtPaSupportedProfileMessage::GetPaProfileName ( ) const [inline]

void BtPaSupportedProfileMessage::SetPaProfileName ( const WString & pa_profile_name ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:02:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtProfileActivationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtProfileActivationMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtProfileActivationMessage:

[legend]
Collaboration diagram for BtProfileActivationMessage:

[legend]

Public Types

enum | { ID = 10217 }

Public Member Functions

BtProfileActivationMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtProfileActivationMessage ()

Detailed Description

BtConnectabilityMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtProfileActivationMessage::BtProfileActivationMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtProfileActivationMessage::~BtProfileActivationMessage ( ) [virtual]

Member Function Documentation

Message * BtProfileActivationMessage::Clone ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

const MsgMetaData & BtProfileActivationMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtLocalSettingsMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:02:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtQuerySupportedProfilesMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtQuerySupportedProfilesMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtQuerySupportedProfilesMessage:

[legend]
Collaboration diagram for BtQuerySupportedProfilesMessage:

[legend]

Public Types

enum | { ID = 10229 }

Public Member Functions

BtQuerySupportedProfilesMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtQuerySupportedProfilesMessage ()

Detailed Description

BtQuerySupportedProfilesMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtQuerySupportedProfilesMessage::BtQuerySupportedProfilesMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtQuerySupportedProfilesMessage::~BtQuerySupportedProfilesMessage ( ) [virtual]

Member Function Documentation

Message * BtQuerySupportedProfilesMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtQuerySupportedProfilesMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:02:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtQuerySupportedProfilesRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtQuerySupportedProfilesRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtQuerySupportedProfilesRequest.hpp>

Inheritance diagram for BtQuerySupportedProfilesRequest:

[legend]
Collaboration diagram for BtQuerySupportedProfilesRequest:

[legend]

Public Member Functions

BtQuerySupportedProfilesRequest (const BtDevice &device)
Constructor.
const WString & | GetHfServiceName () const
Get the name of the head set service.
const WString & | GetHsServiceName () const
Get the name of the head set service.
const WString & | GetPaServiceName () const
Get the name of the head set service.
virtual BtRequestType | GetRequestType () const
Get type of this request.
UINT16 | GetSupportedFeatures () const
Get by the hands free service supported features.
BOOLEAN | HasRemoteVolumeControl () const
Has head set service a remote volume control.
BOOLEAN | IsHfServiceSupported () const
Is hands free service supported?
BOOLEAN | IsHsServiceSupported () const
Is head set service supported?
BOOLEAN | IsPaServiceSupported () const
Is phone access service supported?
virtual | ~BtQuerySupportedProfilesRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual void | OnHfProfileSupported (const WString &name, UINT16 supported_features)
Hands free supported message handler member function.
virtual void | OnHfProfileSupported (BtResultCode result, const WString &name, UINT16 supported_features)
virtual void | OnHsProfileSupported (const WString &name, BOOLEAN has_remote_volume_control)
Head set supported message handler member function.
virtual void | OnHsProfileSupported (BtResultCode result, const WString &name, BOOLEAN has_remote_volume_control)
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | OnPaProfileSupported (const WString &name)
Phone access supported message handler member function.
virtual void | OnPaProfileSupported (BtResultCode result, const WString &name)
virtual void | RegisterMessages () const
Register the required messages for receipt.
virtual void | UnregisterMessages () const
Unregister the required messages from receipt.

Detailed Description

Bluetooth has defined some profiles like Head Set or Hands Free that are used to increase the comfort of handling the device. These profiles are called accessory profiles. To make the service search for such profiles easier the Bluetooth Stack has defined an operation that queries exactly this kind of profiles from Remote Bluetooth Devices. BtQuerySupportedProfilesRequest is the implementation of the operation described above.

Constructor & Destructor Documentation

BtQuerySupportedProfilesRequest::BtQuerySupportedProfilesRequest ( const BtDevice & device )

Constructor.

BtQuerySupportedProfilesRequest::~BtQuerySupportedProfilesRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtQuerySupportedProfilesRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

ExecuteRequest instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. ExecuteRequest is one of these functions. Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

const WString & BtQuerySupportedProfilesRequest::GetHfServiceName ( ) const

Get the name of the head set service.

After the execution of this request GetHfServiceName returns name of the, with this request associated remote Bluetooth device, hands free service.

Returns:
A reference to a WString containing the name of the hands free service.

const WString & BtQuerySupportedProfilesRequest::GetHsServiceName ( ) const

Get the name of the head set service.

After the execution of this request GetHsServiceName returns name of the, with this request associated remote Bluetooth device, head set service.

Returns:
A reference to a WString containing the name of the head set service.

const WString & BtQuerySupportedProfilesRequest::GetPaServiceName ( ) const

Get the name of the head set service.

After the execution of this request GetPaServiceName returns name of the, with this request associated remote Bluetooth device, phone access service.

Returns:
A reference to a WString containing the name of the phone access service.

BtRequestType BtQuerySupportedProfilesRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

UINT16 BtQuerySupportedProfilesRequest::GetSupportedFeatures ( ) const

Get by the hands free service supported features.

After the execution of this request GetSupportedFeatures returns the features of the hands free service of the remote Bluetooth device that is associated with this request.

Parameters:
An UINT16 containing the features as an bitfield that the hands free service supports.

BOOLEAN BtQuerySupportedProfilesRequest::HasRemoteVolumeControl ( ) const

Has head set service a remote volume control.

After the execution of this request HasRemoteVolumeControl returns wheter the head set service of the remote Bluetooth device associated with <me>this request has a remote volume control or not.

Returns:
TRUE: The hands free service has a remote volume control.
FALSE: The hands free service has no remote volume control.

BOOLEAN BtQuerySupportedProfilesRequest::IsHfServiceSupported ( ) const

Is hands free service supported?

After the execution of this request IsHfServiceSupported returns wheter the with this request associated remote Bluetooth device supports the hands gree service or not.

Returns:
TRUE: The hands free service is supported.
FALSE: The hands free service is not supported.

BOOLEAN BtQuerySupportedProfilesRequest::IsHsServiceSupported ( ) const

Is head set service supported?

After the execution of this request IsHsServiceSupported returns wheter the with this request associated remote Bluetooth device supports the head set service or not.

Returns:
TRUE: The head set service is supported.
FALSE: The head set service is not supported.

BOOLEAN BtQuerySupportedProfilesRequest::IsPaServiceSupported ( ) const

Is phone access service supported?

After the execution of this request IsPaServiceSupported returns wheter the with this request associated Remote Bluetooth Device supports the Phone Access Profile or not.

Returns:
TRUE: The phone access service is supported.
FALSE: The phone access service is not supported.

void BtQuerySupportedProfilesRequest::OnHfProfileSupported | ( | const WString & | name,
 |  | UINT16 | supported_features
 | ) | [protected, virtual]

Hands free supported message handler member function.

The OnHfProfileSupported member function will be invoked when a BtHfProfileSupportedMessage is received by this request. This member function is used to enable some reaction to the receipt of the aforsaid message.
The implmenetation of this member function is a dummy implementation and does nothing. If the application programmer wants to change this behaviour, he has to overload this function in a derived class. He need not to call the inherited base function, because it does nothing.

Parameters:
name | A reference to a WString containing the name of the hands free service.
supported_features | An UINT16 containing the features as an bitfield that the hands free service supports.

void BtQuerySupportedProfilesRequest::OnHfProfileSupported | ( | BtResultCode | result,
 |  | const WString & | name,
 |  | UINT16 | supported_features
 | ) | [protected, virtual]

void BtQuerySupportedProfilesRequest::OnHsProfileSupported | ( | const WString & | name,
 |  | BOOLEAN | has_remote_volume_control
 | ) | [protected, virtual]

Head set supported message handler member function.

The OnHsProfileSupported member function will be invoked when a BtHsProfileSupportedMessage is received by this request. This member function is used to enable some reaction to the receipt of the aforsaid message.
The implmenetation of this member function is a dummy implementation and does nothing. If the application programmer wants to change this behaviour, he has to overload this function in a derived class. He need not to call the inherited base function, because it does nothing.

Parameters:
name | A reference to a WString containing the name of the head set service.
has_remote_volume_control | A BOOLEAN containing whether the head set has a remote volume control or not

void BtQuerySupportedProfilesRequest::OnHsProfileSupported | ( | BtResultCode | result,
 |  | const WString & | name,
 |  | BOOLEAN | has_remote_volume_control
 | ) | [protected, virtual]

BOOLEAN BtQuerySupportedProfilesRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtQuerySupportedProfilesRequest::OnPaProfileSupported ( const WString & name ) [protected, virtual]

Phone access supported message handler member function.

The OnPaProfileSupported member function will be invoked when a BtHfProfileSupportedMessage is received by this request. This member function is used to enable some reaction to the receipt of the aforsaid message.
The implmenetation of this member function is a dummy implementation and does nothing. If the application programmer wants to change this behaviour, he has to overload this function in a derived class. He need not to call the inherited base function, because it does nothing.

Parameters:
name A reference to a WString containing the name of the phone access service.

void BtQuerySupportedProfilesRequest::OnPaProfileSupported | ( | BtResultCode | result,
 |  | const WString & | name
 | ) | [protected, virtual]

void BtQuerySupportedProfilesRequest::RegisterMessages ( ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtQuerySupportedProfilesRequest the following messages are registered: BtQuerySupportedProfilesMessage, BtHsSupportedProfileMessage, BtHfSupportedProfileMessage and BtPaSupportedProfileMessage.

Reimplemented from UserDispatcher.

void BtQuerySupportedProfilesRequest::UnregisterMessages ( ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtQuerySupportedProfilesRequest the following messages are unregistered: BtQuerySupportedProfilesMessage, BtHsSupportedProfileMessage, BtHfSupportedProfileMessage and BtPaSupportedProfileMessage.

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/BtQuerySupportedProfilesRequest.hpp
  • Bluetooth/BtQuerySupportedProfilesRequest.cpp
Generated on Wed Jan 25 01:02:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRemoteDeviceMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRemoteDeviceMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtRemoteDeviceMessage:

[legend]
Collaboration diagram for BtRemoteDeviceMessage:

[legend]

Public Types

enum | { ID = 10221 }

Public Member Functions

BtRemoteDeviceMessage (const BtResultCode &result, UINT32 request_id, const BtDeviceAddress &device_address, const BtDeviceAndServiceClass &device_and_service_class, UINT8 signal_strength)
virtual Message * | Clone () const
const BtDeviceAddress & | GetDeviceAddress () const
const BtDeviceAndServiceClass & | GetDeviceAndServiceClass () const
virtual const MsgMetaData & | GetMetaData () const
UINT8 | GetSignalStrength () const
void | SetDeviceAddress (const BtDeviceAddress &device_address)
void | SetDeviceAndServiceClass (const BtDeviceAndServiceClass &device_and_service_class)
void | SetSignalStrength (UINT8 signal_strength)
virtual | ~BtRemoteDeviceMessage ()

Detailed Description

BtRemoteDeviceMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtRemoteDeviceMessage::BtRemoteDeviceMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const BtDeviceAddress & | device_address,
 |  | const BtDeviceAndServiceClass & | device_and_service_class,
 |  | UINT8 | signal_strength
 | ) |

BtRemoteDeviceMessage::~BtRemoteDeviceMessage ( ) [virtual]

Member Function Documentation

Message * BtRemoteDeviceMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const BtDeviceAddress& BtRemoteDeviceMessage::GetDeviceAddress ( ) const [inline]

const BtDeviceAndServiceClass& BtRemoteDeviceMessage::GetDeviceAndServiceClass ( ) const [inline]

const MsgMetaData & BtRemoteDeviceMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

UINT8 BtRemoteDeviceMessage::GetSignalStrength ( ) const [inline]

void BtRemoteDeviceMessage::SetDeviceAddress ( const BtDeviceAddress & device_address ) [inline]

void BtRemoteDeviceMessage::SetDeviceAndServiceClass ( const BtDeviceAndServiceClass & device_and_service_class ) [inline]

void BtRemoteDeviceMessage::SetSignalStrength ( UINT8 signal_strength ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:02:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRemoteDeviceNameMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRemoteDeviceNameMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtRemoteDeviceNameMessage:

[legend]
Collaboration diagram for BtRemoteDeviceNameMessage:

[legend]

Public Types

enum | { ID = 10222 }

Public Member Functions

BtRemoteDeviceNameMessage (const BtResultCode &result, UINT32 request_id, const BtDeviceAddress &device_address, const WString &device_name)
virtual Message * | Clone () const
const BtDeviceAddress & | GetDeviceAddress () const
const WString & | GetDeviceName () const
virtual const MsgMetaData & | GetMetaData () const
void | SetDeviceAddress (const BtDeviceAddress &device_address)
void | SetDeviceName (const WString &device_name)
virtual | ~BtRemoteDeviceNameMessage ()

Detailed Description

BtRemoteDeviceNameMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtRemoteDeviceNameMessage::BtRemoteDeviceNameMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const BtDeviceAddress & | device_address,
 |  | const WString & | device_name
 | ) |

BtRemoteDeviceNameMessage::~BtRemoteDeviceNameMessage ( ) [virtual]

Member Function Documentation

Message * BtRemoteDeviceNameMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const BtDeviceAddress& BtRemoteDeviceNameMessage::GetDeviceAddress ( ) const [inline]

const WString& BtRemoteDeviceNameMessage::GetDeviceName ( ) const [inline]

const MsgMetaData & BtRemoteDeviceNameMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

void BtRemoteDeviceNameMessage::SetDeviceAddress ( const BtDeviceAddress & device_address ) [inline]

void BtRemoteDeviceNameMessage::SetDeviceName ( const WString & device_name ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:02:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRemoteDevicePairMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRemoteDevicePairMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapApplicationMessage.hpp>

Inheritance diagram for BtRemoteDevicePairMessage:

[legend]
Collaboration diagram for BtRemoteDevicePairMessage:

[legend]

Public Types

enum | { ID = 10015 }

Public Member Functions

BtRemoteDevicePairMessage (const BtResultCode &result)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtRemoteDevicePairMessage ()

Detailed Description

BtRemoteDevicePairMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtRemoteDevicePairMessage::BtRemoteDevicePairMessage ( const BtResultCode & result )

BtRemoteDevicePairMessage::~BtRemoteDevicePairMessage ( ) [virtual]

Member Function Documentation

Message * BtRemoteDevicePairMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapNotificationMessage.

const MsgMetaData & BtRemoteDevicePairMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapNotificationMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapApplicationMessage.hpp
  • Bluetooth/BtGapAndSdapApplicationMessage.cpp
Generated on Wed Jan 25 01:02:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtRequest.hpp>

Inheritance diagram for BtRequest:

[legend]
Collaboration diagram for BtRequest:

[legend]

Public Member Functions

BtRequest ()
Constructor.
virtual BOOLEAN | CanCancelRequest () const
Can this request be cancelled?
BtRequestState CancelRequest ()
Stop the exection of this request.
virtual BOOLEAN | CanExecuteRequest () const
Can this request be exectued?
virtual BtRequestState | ExecuteRequest ()=0
Sumbit this request to the Bluetooth Stack.
UINT32 | GetRequestId () const
Gets the unique id for this request.
BtRequestState | GetRequestState () const
Get processing state of this request.
virtual BtRequestType | GetRequestType () const =0
Get type of this request.
virtual BOOLEAN | IsCancelable () const =0
Is this kind of request cancelable?
virtual | ~BtRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Cancel ()=0
Set controller parameters and call stack to cancel operation.
virtual BtRequestState | ChangeRequestState (BOOLEAN success)
Sets the new state depending on the success.
virtual BtRequestState | ChangeRequestStateForCancel (BOOLEAN success)
Set the new state for a cancel operation depending on the success.
virtual BOOLEAN | EvaluateExecutionResult (BtResultCode result)
virtual BOOLEAN | Execute ()=0
Set controller parameters and call controller function.
virtual void | ExecutionCallback (BtResultCode result)=0
virtual void | ResetRequestState ()
virtual void | SetRequestState (BtRequestState request_state)=0
Set processing state of this request.

Protected Attributes

Mutex m_is_registered_mutex
Mutex, that protectects the m_is_registered member.
BtRequestState m_state
Processing state of this request.

Friends

class | BtController

Detailed Description

When Bluetooth is instructed to do some operation that goes over the air these operations take at least a couple of time. Such operations are called a request for an operation because the function does not execute the operation. Instead of this the function asks the Bluetooth Stack for the exectution of the operation.
To avoid the running application from blocking while it is waiting for the end of the execution of a requested operation, requests where executed in a asynchronous way. When the Bluetooth Stack has finished a requested operation, it calls a callback function associated with the requested operation. Depending on the profile the relevant Bt...Controller implements this callback function. From within these functions messages were sent to the running application to notify it about the progress and success of the requested operation.
BtRequest is the base class for such requests as described above. To enable the reception of messages BtRequest is derived from UserDispatcher. This class is abstract because it primarily defines the interface to all requests. The execution of a certain operation is implemented by the apropriate Bt...Request class. This is done by calling the corresponding function in one Bt...Controller class that instructs the Bluetooth Stack to execute the requested operation.
Some of the operation requested from the Bluetooth Stack can be interrupted. These request are called cancelable. If a request is cancelable the procedure to cancel an initiated request must be implemented too. The last step of implementing a concrete reqeuest is to implement the On... function to dispatch and handle the messages sent to the application by the apropriate Bt...Controller class.

Constructor & Destructor Documentation

BtRequest::BtRequest ( )

Constructor.

BtRequest::~BtRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtRequest::CanCancelRequest ( ) const [virtual]

Can this request be cancelled?

Checks if the request is ready for being cancelled. This means that this request has to be in certain states.

Returns:
TRUE: This request is ready for being cancelled.
FALSE: This request is not ready for being cancelled.

virtual BOOLEAN BtRequest::Cancel ( ) [protected, pure virtual]

Set controller parameters and call stack to cancel operation.

The Cancel member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that cancels an ongoing operation at the Bluetooth Stack. This function is pure virtual because each request is canceled in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implemented in BtDeviceSearchRequest, BtServiceRequest, BtServiceVerifyRequest, and BtUncancelableRequest.

BtRequestState BtRequest::CancelRequest ( )

Stop the exection of this request.

CancelRequest is used to stop this ongoing request. If this request is cancelable this function must be implemented in the class that realizes this request. If this request is not cancelable this concrete request is derived from BtUncancelableRequest where this function is implemented to return only the current state of execution.

Returns:
A BtRequestState containing the current state of exectuion for this request. If this request is not cancelable the request state will not change and this not changed request state is returned. Otherwise the state will change and this changed state will be returned.

BOOLEAN BtRequest::CanExecuteRequest ( ) const [virtual]

Can this request be exectued?

Checks if the request is ready for being executed. This means that this request has to be in certain states.

Returns:
TRUE: This request is ready for being executed.
FALSE: This request is not ready for being executed.

BtRequestState BtRequest::ChangeRequestState ( BOOLEAN success ) [protected, virtual]

Sets the new state depending on the success.

ChangeRequestState is a function that is used by the ExecuteRequest and the EvaluateMessageResult functions to do the change of the request state. Depending on the current state and the passed in success, this function sets the right new state. The passed in success parameter can be on the one hand the result of a function call, on the other hand the result parameter of a message sent up to the request by the apropriate controller.

Parameters:
success A BOOLEAN indicating the success of the operation execution stage corresponding to the current state.
Returns:
A BtRequestState containing the new request state after doing the state transition.

Reimplemented in BtAvrcpRequest, BtBppReq, BtBppSndAbortReqRequest, BtBppSndFilePushReqRequest, BtRequestRespondRequest, and BtObexRequest.

BtRequestState BtRequest::ChangeRequestStateForCancel ( BOOLEAN success ) [protected, virtual]

Set the new state for a cancel operation depending on the success.

ChangeRequestStateForCancel is a function that is used by the CancelRequest function to do the change of the request state. Depending on the current state and the passed in success, this function sets the right new state. The passed in success parameter is the result of a stack function call.

Parameters:
success A BOOLEAN indicating the success of the operation execution stage corresponding to the current state.
Returns:
A BtRequestState containing the new request state after doing the state transition.

BOOLEAN BtRequest::EvaluateExecutionResult ( BtResultCode result ) [protected, virtual]

Reimplemented in BtBppReq, and BtObexRequest.

virtual BOOLEAN BtRequest::Execute ( ) [protected, pure virtual]

Set controller parameters and call controller function.

The Execute member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that executes the requested operation at the Bluetooth Stack. This function is pure virtual because each request is exectued in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implemented in BtAvrcpConnectResponse, BtAvrcpDeRegisterRequest, BtAvrcpOperationRequestResponse, BtAvrcpPanelPassThroughRequest, BtAvrcpRawFrameRequest, BtAvrcpRegisterRequest, BtAvrcpSubunitInfoRequest, BtAvrcpUnitInfoRequest, BtBppSndAbortReqRequest, BtBppSndFilePushReqRequest, BtBppSndGetRefObjRspRequest, BtConnectRequest, BtDevicePairRequest, BtDeviceSearchRequest, BtDeviceTrustRequest, BtDeviceUnpairRequest, BtDeviceUntrustRequest, BtDisconnectRequest, BtQuerySupportedProfilesRequest, BtRespondAuthorizationRequest, BtSendPasskeyRequest, BtServiceVerifyRequest, BtSetRemoteDeviceNameRequest, BtObexAbortRequest, BtObexConnectRequest, BtObexDisconnectRequest, BtObexGetRequest, BtObexPutRequest, BtObexRegisterClientRequest, BtObexRegisterServerRequest, BtObexSetPathRequest, BtObexUnregisterClientRequest, and BtObexUnregisterServerRequest.

virtual BtRequestState BtRequest::ExecuteRequest ( ) [pure virtual]

Sumbit this request to the Bluetooth Stack.

ExecuteRequest instructs this request to sent itself to the Bluetooth stack for execution purposes. This function prepares the submission of the request to the stack. The real exection of the stack call is done by the fuction Execute, which is a pure virtual function, that has to be overwritten by the concrete request, which is a subclass of this class.

Returns:
A BtRequestState containing the current state of exectuion for this request. Most times the returned state indicates whether the Bluetooth Stack has accepted or rejected the request.

Implemented in BtLocalRequest, and BtServiceRequest.

virtual void BtRequest::ExecutionCallback ( BtResultCode result ) [protected, pure virtual]

Implemented in BtBppSndAbortReqRequest, BtBppSndFilePushReqRequest, BtBppSndGetRefObjRspRequest, BtLocalRequest, BtServiceRequest, BtObexAbortRequest, BtObexConnectRequest, BtObexDisconnectRequest, BtObexGetRequest, BtObexPutRequest, BtObexRegisterClientRequest, BtObexRegisterServerRequest, BtObexSetPathRequest, BtObexUnregisterClientRequest, and BtObexUnregisterServerRequest.

UINT32 BtRequest::GetRequestId ( ) const

Gets the unique id for this request.

GetRequestId returns a unique id for each request instantiated by any application.

Returns:
A UINT32 containing the unique id for this request.

BtRequestState BtRequest::GetRequestState ( ) const

Get processing state of this request.

A request can be seen as it goes through several stages in its execution process. Because all requests execute asynchronously there must be a possibility to query the stage of execution in which the request currently is. GetRequestState is the function that realizes this needs.

Returns:
A BtRequestState containing the current stage of execution of this request.

virtual BtRequestType BtRequest::GetRequestType ( ) const [pure virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implemented in BtAvrcpConnectResponse, BtAvrcpDeRegisterRequest, BtAvrcpOperationRequestResponse, BtAvrcpPanelPassThroughRequest, BtAvrcpRawFrameRequest, BtAvrcpRegisterRequest, BtAvrcpSubunitInfoRequest, BtAvrcpUnitInfoRequest, BtBppSndAbortReqRequest, BtBppSndFilePushReqRequest, BtBppSndGetRefObjRspRequest, BtDevicePairRequest, BtDeviceSearchRequest, BtDeviceTrustRequest, BtDeviceUnpairRequest, BtDeviceUntrustRequest, BtQuerySupportedProfilesRequest, BtRespondAuthorizationRequest, BtSendPasskeyRequest, BtServiceVerifyRequest, BtSetRemoteDeviceNameRequest, BtObexAbortRequest, BtObexConnectRequest, BtObexDisconnectRequest, BtObexGetRequest, BtObexPutRequest, BtObexRegisterClientRequest, BtObexRegisterServerRequest, BtObexSetPathRequest, BtObexUnregisterClientRequest, and BtObexUnregisterServerRequest.

virtual BOOLEAN BtRequest::IsCancelable ( ) const [pure virtual]

Is this kind of request cancelable?

So kinds of requests have a very long duration. Most of these requests can be interrupted. Other request once submitted can not be stopped. So IsCancelable returns whether a request can be canceled or not. This function is pure virtual because it depends on the kind of request if it is cancelable. Further there are two subclasses which implement this function and the concrete request should be derived from one of these classes.

Returns:
TRUE: This request can be canceled.
FALSE: This request can not be canceled.

Implemented in BtCancelableRequest, BtServiceRequest, and BtUncancelableRequest.

void BtRequest::ResetRequestState ( ) [protected, virtual]

virtual void BtRequest::SetRequestState ( BtRequestState request_state ) [protected, pure virtual]

Set processing state of this request.

A request can be seen as it goes through several stages in its execution process. SetRequestState can be used to set the current stage of execution. When the passed in state is other than the current state the OnRequestStateChange callback function will be invoked.

Parameters:
request_state A BtRequestState containing the current stage of exection which has to be set for this request.

Implemented in BtBppReq, BtBppSndAbortReqRequest, BtBppSndFilePushReqRequest, BtLocalRequest, and BtServiceRequest.

Friends And Related Function Documentation

friend class BtController [friend]

Reimplemented in BtServiceRequest.

Field Documentation

Mutex BtRequest::m_is_registered_mutex [protected]

Mutex, that protectects the m_is_registered member.

BtRequestState BtRequest::m_state [protected]

Processing state of this request.

The documentation for this class was generated from the following files:
  • Bluetooth/BtRequest.hpp
  • Bluetooth/BtRequest.cpp
Generated on Wed Jan 25 01:02:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRequestMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRequestMessage Class Reference

#include <Apoxi/Bluetooth/BtRequestMessage.hpp>

Inheritance diagram for BtRequestMessage:

[legend]
Collaboration diagram for BtRequestMessage:

[legend]

Public Types

enum | { ID = 10200 }

Public Member Functions

BtRequestMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetRequestId () const
const BtResultCode & | GetResult () const
void | SetRequestId (UINT32 request_id)
void | SetResult (const BtResultCode &result)
virtual | ~BtRequestMessage ()

Detailed Description

BtRequestMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtRequestMessage::BtRequestMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtRequestMessage::~BtRequestMessage ( ) [virtual]

Member Function Documentation

Message * BtRequestMessage::Clone ( ) const [virtual]

Implements Message.

Reimplemented in BtGapAndSdapRequestMessage, BtStateChangedMessage, BtLocalSettingsMessage, BtLocalNameMessage, BtDiscoverabilityMessage, BtPairabilityMessage, BtConnectabilityMessage, BtProfileActivationMessage, BtSendPasskeyMessage, BtRespondAuthorizationMessage, BtDeviceSearchMessage, BtRemoteDeviceMessage, BtRemoteDeviceNameMessage, BtCancelSearchMessage, BtSetRemoteDeviceNameMessage, BtDevicePairMessage, BtDeviceUnpairMessage, BtDeviceTrustMessage, BtDeviceUntrustMessage, BtQuerySupportedProfilesMessage, BtHsSupportedProfileMessage, BtHfSupportedProfileMessage, BtPaSupportedProfileMessage, BtServiceVerifyMessage, BtServiceVerifyResultMessage, BtCancelVerifyMessage, BtOpenMessage, and BtCloseMessage.

const MsgMetaData & BtRequestMessage::GetMetaData ( ) const [virtual]

Implements Message.

Reimplemented in BtGapAndSdapRequestMessage, BtStateChangedMessage, BtLocalSettingsMessage, BtLocalNameMessage, BtDiscoverabilityMessage, BtPairabilityMessage, BtConnectabilityMessage, BtProfileActivationMessage, BtSendPasskeyMessage, BtRespondAuthorizationMessage, BtDeviceSearchMessage, BtRemoteDeviceMessage, BtRemoteDeviceNameMessage, BtCancelSearchMessage, BtSetRemoteDeviceNameMessage, BtDevicePairMessage, BtDeviceUnpairMessage, BtDeviceTrustMessage, BtDeviceUntrustMessage, BtQuerySupportedProfilesMessage, BtHsSupportedProfileMessage, BtHfSupportedProfileMessage, BtPaSupportedProfileMessage, BtServiceVerifyMessage, BtServiceVerifyResultMessage, BtCancelVerifyMessage, BtOpenMessage, and BtCloseMessage.

UINT32 BtRequestMessage::GetRequestId ( ) const [inline]

const BtResultCode& BtRequestMessage::GetResult ( ) const [inline]

void BtRequestMessage::SetRequestId ( UINT32 request_id ) [inline]

void BtRequestMessage::SetResult ( const BtResultCode & result ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtRequestMessage.hpp
  • Bluetooth/BtRequestMessage.cpp
Generated on Wed Jan 25 01:02:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRequestOperationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRequestOperationMessage Class Reference

#include <Apoxi/Bluetooth/BtRequestOperationMessage.hpp>

Inheritance diagram for BtRequestOperationMessage:

[legend]
Collaboration diagram for BtRequestOperationMessage:

[legend]

Public Types

enum | { ID = 10099 }

Public Member Functions

BtRequestOperationMessage (const BtOperationPtr &operation)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const BtOperationPtr & | GetOperation () const
void | SetOperation (const BtOperationPtr &operation)
virtual | ~BtRequestOperationMessage ()

Detailed Description

BtRequestOperationMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtRequestOperationMessage::BtRequestOperationMessage ( const BtOperationPtr & operation )

BtRequestOperationMessage::~BtRequestOperationMessage ( ) [virtual]

Member Function Documentation

Message * BtRequestOperationMessage::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & BtRequestOperationMessage::GetMetaData ( ) const [virtual]

Implements Message.

const BtOperationPtr& BtRequestOperationMessage::GetOperation ( ) const [inline]

void BtRequestOperationMessage::SetOperation ( const BtOperationPtr & operation ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtRequestOperationMessage.hpp
  • Bluetooth/BtRequestOperationMessage.cpp
Generated on Wed Jan 25 01:02:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRequestRespondRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRequestRespondRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtRequestRespondRequest.hpp>

Inheritance diagram for BtRequestRespondRequest:

[legend]
Collaboration diagram for BtRequestRespondRequest:

[legend]

Public Member Functions

BtRequestRespondRequest (const BtDevice &device)
Constructor.
virtual | ~BtRequestRespondRequest ()
Destructor.

Protected Member Functions

virtual BtRequestState | ChangeRequestState (BOOLEAN success)
Sets the new state depending on the success.
virtual BOOLEAN | EvaluateMessageResult (const BtRequestMessage &message)
Check the result parameter of the callback functions.

Detailed Description

Under certain conditions there could be the situation, that the Bluetooth stack needs some information during the execution of partikular operations. To implement a posibility to send the requested information to the stack the BtRequestRespondRequest is introduced. This is a request that could be executed during another request is running.
In the case of such request, the noification sequence of the Bluetooth stack differs slightly from normal requests. This changes are reflected in a slightly different state machine for these requests. To handle this new state machine the to state changing functions ChangeRequestState and EvaluateMessageResult have to be overwritten.

Constructor & Destructor Documentation

BtRequestRespondRequest::BtRequestRespondRequest ( const BtDevice & device )

Constructor.

BtRequestRespondRequest::~BtRequestRespondRequest ( ) [virtual]

Destructor.

Member Function Documentation

BtRequestState BtRequestRespondRequest::ChangeRequestState ( BOOLEAN success ) [protected, virtual]

Sets the new state depending on the success.

ChangeRequestState is a function that is used by the ExecuteRequest and the EvaluateMessageResult functions to do the change of the request state. Depending on the current state and the passed in success, this function sets the right new state. The passed in success parameter can be on the one hand the result of a function call, on the other hand the result parameter of a message sent up to the request by the apropriate controller.

Parameters:
success A BOOLEAN indicating the success of the operation execution stage corresponding to the current state.
Returns:
A BtRequestState containing the new request state after doing the state transition.

Reimplemented from BtRequest.

BOOLEAN BtRequestRespondRequest::EvaluateMessageResult ( const BtRequestMessage & message ) [protected, virtual]

Check the result parameter of the callback functions.

When a callback function is invoked one parameter is a result code indicatint the state of the ongoing stack operation. Ths result code is interpreted and the if necessary the ChangeRequestState function is called to do the right state change.
This function is a helper function and has to be used be the implementations of a concrete request when it handles the arrived message in the OnMessage function.

Parameters:
message A reference to a BtRequestMessage that references the Bluetooth message received by the OnMessage function.
Returns:
TRUE: The was a state transition.
FALSE: The was no state transition.

Reimplemented from BtLocalRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/BtRequestRespondRequest.hpp
  • Bluetooth/BtRequestRespondRequest.cpp
Generated on Wed Jan 25 01:02:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRequestRunningWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRequestRunningWindow Class Reference

#include <Applications/BtApp/BtApplicationWindows.hpp>

Collaboration diagram for BtRequestRunningWindow:

[legend]

Public Types

enum BtRrwType {
BtRrwUnknown = -1, BtRrwPair, BtRrwUnpair, BtRrwTrust,
BtRrwUntrust, BtRrwSetName, BtRrwQuerySupportedProfiles, BtRrwDeviceSearch,
BtRrwDunDisconnect, BtRrwHsConnect, BtRrwHsDisconnect, BtRrwHsCallTransferToPhone,
BtRrwHsCallTransferToHeadset, BtRrwHfConnect, BtRrwHfDisconnect, BtRrwHfAudio2Hf,
BtRrwHfAudio2Phone, BtRrwFaxDisconnect, BtRrwServiceVerify
}

Public Member Functions

BtRequestRunningWindow ()
const BtCancelableRequest * | GetCancelableRequest () const
BtCancelableRequest * GetCancelableRequest ()
void | Init ()
void | SetCancelableRequest (BtCancelableRequest *cancelable_request)
void | SetType (BtRrwType type)
virtual | ~BtRequestRunningWindow ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual void | OnOpen ()
void | OnRequestCancel ()

Detailed Description

Some request execution may take a lot of time, during these period BtRequestRunningWindow ,which contains a waiting animation, will be displayed.

Member Enumeration Documentation

enum BtRequestRunningWindow::BtRrwType

Enumerator:
BtRrwUnknown
BtRrwPair
BtRrwUnpair
BtRrwTrust
BtRrwUntrust
BtRrwSetName
BtRrwQuerySupportedProfiles
BtRrwDeviceSearch
BtRrwDunDisconnect
BtRrwHsConnect
BtRrwHsDisconnect
BtRrwHsCallTransferToPhone
BtRrwHsCallTransferToHeadset
BtRrwHfConnect
BtRrwHfDisconnect
BtRrwHfAudio2Hf
BtRrwHfAudio2Phone
BtRrwFaxDisconnect
BtRrwServiceVerify

Constructor & Destructor Documentation

BtRequestRunningWindow::BtRequestRunningWindow ( )

BtRequestRunningWindow::~BtRequestRunningWindow ( ) [virtual]

Member Function Documentation

const BtCancelableRequest * BtRequestRunningWindow::GetCancelableRequest ( ) const

BtCancelableRequest * BtRequestRunningWindow::GetCancelableRequest ( )

void BtRequestRunningWindow::Init ( )

BOOLEAN BtRequestRunningWindow::OnCancel ( ) [protected, virtual]

void BtRequestRunningWindow::OnOpen ( ) [protected, virtual]

void BtRequestRunningWindow::OnRequestCancel ( ) [protected]

void BtRequestRunningWindow::SetCancelableRequest ( BtCancelableRequest * cancelable_request )

void BtRequestRunningWindow::SetType ( BtRrwType type )

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtApplicationWindows.hpp
  • Applications/BtApp/BtApplicationWindows.cpp
Generated on Wed Jan 25 01:02:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/BtServiceMessage.hpp>

Inheritance diagram for BtRequestStateChangedMessage:

[legend]
Collaboration diagram for BtRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10305 }

Public Member Functions

BtRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const BtRequestState & | GetNewRequestState () const
const BtRequestState & | GetOldRequestState () const
const BtRequestType & | GetRequestType () const
void | SetNewRequestState (const BtRequestState &new_request_state)
void | SetOldRequestState (const BtRequestState &old_request_state)
void | SetRequestType (const BtRequestType &request_type)
virtual | ~BtRequestStateChangedMessage ()

Detailed Description

BtRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtRequestStateChangedMessage::BtRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtRequestStateChangedMessage::~BtRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtServiceMessage.

Reimplemented in BtAvrcpRequestStateChangedMessage, BtBppRequestStateChangedMessage, BtSddbRequestStateChangedMessage, BtDunRequestStateChangedMessage, BtFaxRequestStateChangedMessage, BtHfRequestStateChangedMessage, BtHsRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, and BtObexClientRequestStateChangedMessage.

const MsgMetaData & BtRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtServiceMessage.

Reimplemented in BtAvrcpRequestStateChangedMessage, BtBppRequestStateChangedMessage, BtSddbRequestStateChangedMessage, BtDunRequestStateChangedMessage, BtFaxRequestStateChangedMessage, BtHfRequestStateChangedMessage, BtHsRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, and BtObexClientRequestStateChangedMessage.

const BtRequestState& BtRequestStateChangedMessage::GetNewRequestState ( ) const [inline]

const BtRequestState& BtRequestStateChangedMessage::GetOldRequestState ( ) const [inline]

const BtRequestType& BtRequestStateChangedMessage::GetRequestType ( ) const [inline]

void BtRequestStateChangedMessage::SetNewRequestState ( const BtRequestState & new_request_state ) [inline]

void BtRequestStateChangedMessage::SetOldRequestState ( const BtRequestState & old_request_state ) [inline]

void BtRequestStateChangedMessage::SetRequestType ( const BtRequestType & request_type ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtServiceMessage.hpp
  • Bluetooth/BtServiceMessage.cpp
Generated on Wed Jan 25 01:02:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRespondAuthorizationMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRespondAuthorizationMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtRespondAuthorizationMessage:

[legend]
Collaboration diagram for BtRespondAuthorizationMessage:

[legend]

Public Types

enum | { ID = 10219 }

Public Member Functions

BtRespondAuthorizationMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtRespondAuthorizationMessage ()

Detailed Description

BtRespondAuthorizationMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtRespondAuthorizationMessage::BtRespondAuthorizationMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtRespondAuthorizationMessage::~BtRespondAuthorizationMessage ( ) [virtual]

Member Function Documentation

Message * BtRespondAuthorizationMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtRespondAuthorizationMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:02:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtRespondAuthorizationRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtRespondAuthorizationRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtRespondAuthorizationRequest.hpp>

Inheritance diagram for BtRespondAuthorizationRequest:

[legend]
Collaboration diagram for BtRespondAuthorizationRequest:

[legend]

Public Member Functions

BtRespondAuthorizationRequest (const BtDevice &device)
Constructor.
BOOLEAN | GetAcceptAuthorization () const
Will the connection be accepted or not?
BOOLEAN | GetCreateTrust () const
Will the remote device be trusted in the fucture or not?
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetAcceptAuthorization (BOOLEAN accept_authorization)
Set whether the connection will be accepted or not.
void | SetCreateTrust (BOOLEAN create_trust)
Set whether the remote device be trusted in the futute or not.
virtual | ~BtRespondAuthorizationRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | RegisterMessages () const
Register the required messages for receipt.
virtual void | UnregisterMessages () const
Unregister the required messages from receipt.

Detailed Description

Some Bluetooth Profiles have security settings that require authorization. That means that a connection that should be established must be accepted or rejected respectively. This is indicated that a request for authorization is sent to the connected Bluetooth Device. This device has now to decide whether to accept the connection or reject it. If the connecting device is trusted the request is answered by the Bluetooth Stack itself. Untrusted devices must answer the request by execuing a BtRespondAuthorizationRequest to enable or disable the requested connection.

Constructor & Destructor Documentation

BtRespondAuthorizationRequest::BtRespondAuthorizationRequest ( const BtDevice & device )

Constructor.

BtRespondAuthorizationRequest::~BtRespondAuthorizationRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtRespondAuthorizationRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

Execute instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. Execute is one of these functions.Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BOOLEAN BtRespondAuthorizationRequest::GetAcceptAuthorization ( ) const

Will the connection be accepted or not?

GetAcceptAuthorization returns whether this request will accept the requested authorization or reject it, when this request is executed.

Returns:
TRUE: The requested authorization will be accepted.
FALSE: The requested authorization will be rejected.

BOOLEAN BtRespondAuthorizationRequest::GetCreateTrust ( ) const

Will the remote device be trusted in the fucture or not?

GetCreateTrust returns whether the connecting Bluetooth Device is trusted or not when this request has been executed.

Returns:
TRUE: The connecting Bluetooth device gets trusted.
FALSE: The connecting Bluetooth device does not get trusted.

BtRequestType BtRespondAuthorizationRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtRespondAuthorizationRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtRespondAuthorizationRequest::RegisterMessages ( ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtRespondAuthorizationRequest the following message is registered: BtRespondAuthorizationMessage

Reimplemented from UserDispatcher.

void BtRespondAuthorizationRequest::SetAcceptAuthorization ( BOOLEAN accept_authorization )

Set whether the connection will be accepted or not.

SetAcceptAuthorization set whether this request will accept the requested authorization or reject it, when this request is executed.

Parameters:
accept_authorization A BOOLEAN containing whether to accept or reject the requested authorization.

void BtRespondAuthorizationRequest::SetCreateTrust ( BOOLEAN create_trust )

Set whether the remote device be trusted in the futute or not.

SetCreateTrust sets whether the connecting Bluetooth Device is trusted or not when this request has been executed.

Parameters:
create_trust A BOOLEAN containing whether to trust the connecting Bluetooth Device on not.

void BtRespondAuthorizationRequest::UnregisterMessages ( ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtRespondAuthorizationRequest the following message is unregistered: BtRespondAuthorizationMessage

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/BtRespondAuthorizationRequest.hpp
  • Bluetooth/BtRespondAuthorizationRequest.cpp
Generated on Wed Jan 25 01:02:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDataElement Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDataElement Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDataElement:

[legend]

Public Member Functions

BtSddbDataElement ()
Constructor.
virtual INT32 | GetSize () const =0
virtual BtDataElementType | GetType () const =0
virtual BOOLEAN | IsValid () const =0
virtual | ~BtSddbDataElement ()
Destructor.

Protected Member Functions

virtual BtSddbDataElement * | Clone () const =0
virtual INT32 | GetMemorySize () const =0
virtual BOOLEAN | ReadFromMemory (const void *&memory, INT32 &memory_size)=0
virtual void * | WriteToMemory (void *memory) const =0

Friends

class | BtSddbDeContainer
class | BtSddbServiceAttribute

Detailed Description

BtDataElement is the base class for all kinds of data elements. A data element is a unit that has a size, a type and a value. The type determines how the value has to be interpreted. Some member functions are implemented as pure virtual functions, so this class is abstract and can never be instantiated. It only forms a basic interface to query some informations that are necessary for type casting.

Constructor & Destructor Documentation

BtSddbDataElement::BtSddbDataElement ( )

Constructor.

BtSddbDataElement::~BtSddbDataElement ( ) [virtual]

Destructor.

Member Function Documentation

virtual BtSddbDataElement* BtSddbDataElement::Clone ( ) const [protected, pure virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implemented in BtSddbDeNil, BtSddbDeUint8, BtSddbDeUint16, BtSddbDeUint32, BtSddbDeSint8, BtSddbDeSint16, BtSddbDeSint32, BtSddbDeUuid16, BtSddbDeUuid32, BtSddbDeBoolean, BtSddbDeUint64, BtSddbDeUint128, BtSddbDeSint64, BtSddbDeSint128, BtSddbDeUuid128, BtSddbDeString, BtSddbDeUrl, BtSddbDeSequence, and BtSddbDeAlternative.

virtual INT32 BtSddbDataElement::GetMemorySize ( ) const [protected, pure virtual]

GetMemorySize is used by BtServiceAttribute in conjunction with the service discovery database and returns the size of this data element, if it would be stored in the format the BT-Stack expects.

Parameters:
A UINT32 containing the size of the data element, if it would be stored in the format the BT-Stack expects.

Implemented in BtSddbDeOneByteDescriptionType, BtSddbDeVariableLengthType, and BtSddbDeContainer.

virtual INT32 BtSddbDataElement::GetSize ( ) const [pure virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implemented in BtSddbDeNil, BtSddbDeUint8, BtSddbDeUint16, BtSddbDeUint32, BtSddbDeSint8, BtSddbDeSint16, BtSddbDeSint32, BtSddbDeUuid16, BtSddbDeUuid32, BtSddbDeBoolean, BtSddbDeUint64, BtSddbDeUint128, BtSddbDeSint64, BtSddbDeSint128, BtSddbDeUuid128, BtSddbDeVariableLengthType, and BtSddbDeContainer.

virtual BtDataElementType BtSddbDataElement::GetType ( ) const [pure virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implemented in BtSddbDeNil, BtSddbDeUintBase, BtSddbDeSintBase, BtSddbDeUuidBase, BtSddbDeBoolean, BtSddbDeBigUintBase, BtSddbDeBigSintBase, BtSddbDeUuid128, BtSddbDeString, BtSddbDeUrl, BtSddbDeSequence, and BtSddbDeAlternative.

virtual BOOLEAN BtSddbDataElement::IsValid ( ) const [pure virtual]

Implemented in BtSddbDeBaseCType, BtSddbDeByteBlockType, BtSddbDeVariableLengthType, and BtSddbDeContainer.

virtual BOOLEAN BtSddbDataElement::ReadFromMemory | ( | const void *& | memory,
 |  | INT32 & | memory_size
 | ) | [protected, pure virtual]

Implemented in BtSddbDeOneByteDescriptionType, BtSddbDeVariableLengthType, and BtSddbDeContainer.

virtual void* BtSddbDataElement::WriteToMemory ( void * memory ) const [protected, pure virtual]

WriteToMemroy is used by BtServiceAttribute in conjunction with the service discovery database and it writes this data element to a memory location in the format the BT-Stack expects.

Parameters:
memory A pointer to void containing the start address of the memory block, where to write this data element to.

Implemented in BtSddbDeOneByteDescriptionType, BtSddbDeVariableLengthType, and BtSddbDeContainer.

Friends And Related Function Documentation

friend class BtSddbDeContainer [friend]

friend class BtSddbServiceAttribute [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDataElementFactory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDataElementFactory Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Collaboration diagram for BtSddbDataElementFactory:

[legend]

Public Member Functions

BtSddbDataElement * | NewDataElement (UINT8 data_element_descriptor)
virtual | ~BtSddbDataElementFactory ()
Destructor.

Static Public Member Functions

static BtSddbDataElementFactory & | GetInstance ()
Get singleton instance.

Protected Member Functions

BtSddbDataElement * | NewSint (UINT8 size_descriptor)
BtSddbDataElement * | NewUint (UINT8 size_descriptor)
BtSddbDataElement * | NewUuid (UINT8 size_descriptor)

Constructor & Destructor Documentation

BtSddbDataElementFactory::~BtSddbDataElementFactory ( ) [virtual]

Destructor.

Member Function Documentation

BtSddbDataElementFactory & BtSddbDataElementFactory::GetInstance ( ) [static]

Get singleton instance.

BtSddbDataElement * BtSddbDataElementFactory::NewDataElement ( UINT8 data_element_descriptor )

BtSddbDataElement * BtSddbDataElementFactory::NewSint ( UINT8 size_descriptor ) [protected]

BtSddbDataElement * BtSddbDataElementFactory::NewUint ( UINT8 size_descriptor ) [protected]

BtSddbDataElement * BtSddbDataElementFactory::NewUuid ( UINT8 size_descriptor ) [protected]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeAlternative Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeAlternative Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeAlternative:

[legend]
Collaboration diagram for BtSddbDeAlternative:

[legend]

Public Member Functions

BtSddbDeAlternative ()
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeAlternative ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementTypeDescriptor () const

Constructor & Destructor Documentation

BtSddbDeAlternative::BtSddbDeAlternative ( )

BtSddbDeAlternative::~BtSddbDeAlternative ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeAlternative::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeAlternative::GetDataElementTypeDescriptor ( ) const [protected, virtual]

Implements BtSddbDeContainer.

BtDataElementType BtSddbDeAlternative::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeBaseCType Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeBaseCType Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeBaseCType:

[legend]
Collaboration diagram for BtSddbDeBaseCType:

[legend]

Public Member Functions

BtSddbDeBaseCType ()
Constructor.
virtual BOOLEAN | IsValid () const
virtual | ~BtSddbDeBaseCType ()
Destructor.

Constructor & Destructor Documentation

BtSddbDeBaseCType::BtSddbDeBaseCType ( )

Constructor.

BtSddbDeBaseCType::~BtSddbDeBaseCType ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtSddbDeBaseCType::IsValid ( ) const [virtual]

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeBigSintBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeBigSintBase Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeBigSintBase:

[legend]
Collaboration diagram for BtSddbDeBigSintBase:

[legend]

Public Member Functions

BtSddbDeBigSintBase ()
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeBigSintBase ()

Constructor & Destructor Documentation

BtSddbDeBigSintBase::BtSddbDeBigSintBase ( )

BtSddbDeBigSintBase::~BtSddbDeBigSintBase ( ) [virtual]

Member Function Documentation

BtDataElementType BtSddbDeBigSintBase::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeBigUintBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeBigUintBase Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeBigUintBase:

[legend]
Collaboration diagram for BtSddbDeBigUintBase:

[legend]

Public Member Functions

BtSddbDeBigUintBase ()
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeBigUintBase ()

Constructor & Destructor Documentation

BtSddbDeBigUintBase::BtSddbDeBigUintBase ( )

BtSddbDeBigUintBase::~BtSddbDeBigUintBase ( ) [virtual]

Member Function Documentation

BtDataElementType BtSddbDeBigUintBase::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeBoolean Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeBoolean Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeBoolean:

[legend]
Collaboration diagram for BtSddbDeBoolean:

[legend]

Public Member Functions

BtSddbDeBoolean (BOOLEAN value=FALSE)
virtual INT32 | GetSize () const
virtual BtDataElementType | GetType () const
BOOLEAN | GetValue () const
void | SetValue (BOOLEAN value)
virtual | ~BtSddbDeBoolean ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeBoolean::BtSddbDeBoolean ( BOOLEAN value = FALSE )

BtSddbDeBoolean::~BtSddbDeBoolean ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeBoolean::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeBoolean::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeBoolean::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

BtDataElementType BtSddbDeBoolean::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

BOOLEAN BtSddbDeBoolean::GetValue ( ) const

void BtSddbDeBoolean::SetValue ( BOOLEAN value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeByteBlockType Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeByteBlockType Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeByteBlockType:

[legend]
Collaboration diagram for BtSddbDeByteBlockType:

[legend]

Public Member Functions

BtSddbDeByteBlockType ()
UINT8 * | GetValue () const
virtual BOOLEAN | IsValid () const
void | SetValue (const UINT8 *value)
virtual | ~BtSddbDeByteBlockType ()

Constructor & Destructor Documentation

BtSddbDeByteBlockType::BtSddbDeByteBlockType ( )

BtSddbDeByteBlockType::~BtSddbDeByteBlockType ( ) [virtual]

Member Function Documentation

UINT8 * BtSddbDeByteBlockType::GetValue ( ) const

BOOLEAN BtSddbDeByteBlockType::IsValid ( ) const [virtual]

Implements BtSddbDataElement.

void BtSddbDeByteBlockType::SetValue ( const UINT8 * value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeContainer Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeContainer:

[legend]
Collaboration diagram for BtSddbDeContainer:

[legend]

Public Member Functions

BtSddbDeContainer ()
void | Clear (void)
BtSddbDataElement * | Delete (const BtSddbDataElement *data_element)
const BtSddbDataElement * | GetFirst () const
BtSddbDataElement * GetFirst ()
const BtSddbDataElement * | GetNext (const BtSddbDataElement *current) const
BtSddbDataElement * | GetNext (const BtSddbDataElement *current)
virtual INT32 | GetSize () const
BOOLEAN | Insert (const BtSddbDataElement &data_element, const BtSddbDataElement *position=0)
virtual BOOLEAN | IsValid () const
virtual | ~BtSddbDeContainer ()

Protected Member Functions

BOOLEAN | Copy (const BtSddbDeContainer *to_copy)
UINT8 | GetDataElementSizeDescriptor () const
virtual UINT8 | GetDataElementTypeDescriptor () const =0
virtual INT32 | GetMemorySize () const
INT32 | GetMemorySizeOfContainedDataElements () const
virtual BOOLEAN | ReadFromMemory (const void *&memory, INT32 &memory_size)
virtual void * | WriteToMemory (void *memory) const

Data Structures

class | BtSddbDeContainerNode

Detailed Description

BtCompoundDataElement represents data elements that consist of other data elements. These data elements can be basic data elements or again compound data elements. There are two kinds of compound data elements: data element sequences and alternate data elements. Data element sequences describe a composition of two or more data elements, an alternate data element describes a selection of two or more data elements. Seclection means that the data element describes two or more posibilities of values a data element can hold. The BtCompoundDataElement is the owner of its sub data elements and maintains the memory for these. This means, that the inserted sub data elements are not copied, only the pointer to the data element is stored in the BtCompoundDataElement. So the memory for the data element has to be allocated by the user, but the destruction of the memory is done by the BtCompoundDataElement.

Constructor & Destructor Documentation

BtSddbDeContainer::BtSddbDeContainer ( )

BtSddbDeContainer::~BtSddbDeContainer ( ) [virtual]

Member Function Documentation

void BtSddbDeContainer::Clear ( void )

BOOLEAN BtSddbDeContainer::Copy ( const BtSddbDeContainer * to_copy ) [protected]

BtSddbDataElement * BtSddbDeContainer::Delete ( const BtSddbDataElement * data_element )

Delete deletes the passed data element from this data element and returns the data element following the deleted one or 0 if the the deleted one was the last. The deleted element is also destroyed, so the passed pointer gets invalid.

Parameters:
date_element A reference to a pointer to a BtDataElement that should be deleted. The pointer is set to 0 if the element is was in this data element and could be deleted.
Returns:
A pointer to a BtDataElement pointing to the sub data element following to one that was deleted.

0 The data element that has to be deleted was the last one or was not contained in this data element. Check data_element to disdinguish these two cases.

UINT8 BtSddbDeContainer::GetDataElementSizeDescriptor ( ) const [protected]

virtual UINT8 BtSddbDeContainer::GetDataElementTypeDescriptor ( ) const [protected, pure virtual]

Implemented in BtSddbDeSequence, and BtSddbDeAlternative.

const BtSddbDataElement * BtSddbDeContainer::GetFirst ( ) const

GetFirst returns the first data element of the chain, building up this data element.

Returns:
A pointner to a BtDataElement containing the address of the first data element of this compound data element.

0 if the data element contains no sub data elements.

BtSddbDataElement * BtSddbDeContainer::GetFirst ( )

GetFirst returns the first data element of the chain, building up the data element.

Returns:
A pointner to a BtDataElement containing the address of the first data element of this compound data element.

0 if the data element contains no sub data elements.

INT32 BtSddbDeContainer::GetMemorySize ( ) const [protected, virtual]

GetMemorySize is used by BtServiceAttribute in conjunction with the service discovery database and returns the size of this data element, if it would be stored in the format the BT-Stack expects.

Parameters:
A UINT32 containing the size of the data element, if it would be stored in the format the BT-Stack expects.

Implements BtSddbDataElement.

INT32 BtSddbDeContainer::GetMemorySizeOfContainedDataElements ( ) const [protected]

const BtSddbDataElement * BtSddbDeContainer::GetNext ( const BtSddbDataElement * current ) const

GetNext returns the data element next to the passed data element in the chain building up this data element.

Parameters:
current A pointer to a BtDataElement containing the address of the data element for which the successor is wanted. current may not be 0.
Returns:
A pointer to a BtDataElement containing the address of the element following the current element.

0 if the current data element was the last in the chain building up this data element.

BtSddbDataElement * BtSddbDeContainer::GetNext ( const BtSddbDataElement * current )

GetNext returns the data element next to the passed data element in the chain building up this data element.

Parameters:
current A pointer to a BtDataElement containing the address of the data element for which the successor is wanted. current may not be 0.
Returns:
A pointer to a BtDataElement containing the address of the element following the current element.

0 if the current data element was the last in the chain building up this data element.

INT32 BtSddbDeContainer::GetSize ( ) const [virtual]

GetSize return the size of the data element. The unit of the returned size is in data elements. This stands for the number who many sub data elements this element contains.

Returns:
A UINT16 containing the number of sub data elements are stored in this data element.

Implements BtSddbDataElement.

BOOLEAN BtSddbDeContainer::Insert | ( | const BtSddbDataElement & | data_element,
 |  | const BtSddbDataElement * | position = 0
 | ) |

Insert inserts a new data element into this data element.

Parameters:
data_element | A refererence to a BtDataElement that depicts the data element that should be inserted into this data element.
position | A pointer to a BtDataElement containing the address of the sub data element of this data element before which the data_element should be inserted. If the position has the value 0 the data_element is appended at the end.
Returns:
TRUE The insert operation was successfull.

FALSE The insert operation failed, The data element was not inserted.

BOOLEAN BtSddbDeContainer::IsValid ( ) const [virtual]

Implements BtSddbDataElement.

BOOLEAN BtSddbDeContainer::ReadFromMemory | ( | const void *& | memory,
 |  | INT32 & | memory_size
 | ) | [protected, virtual]

Implements BtSddbDataElement.

void * BtSddbDeContainer::WriteToMemory ( void * memory ) const [protected, virtual]

WriteToMemroy is used by BtServiceAttribute in conjunction with the service discovery database and it writes this data element to a memory location in the format the BT-Stack expects.

Parameters:
memory A pointer to void containing the start address of the memory block, where to write this data element to.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeNil Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeNil Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeNil:

[legend]
Collaboration diagram for BtSddbDeNil:

[legend]

Public Member Functions

BtSddbDeNil ()
virtual INT32 | GetSize () const
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeNil ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeNil::BtSddbDeNil ( )

BtSddbDeNil::~BtSddbDeNil ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeNil::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeNil::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeNil::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

BtDataElementType BtSddbDeNil::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeOneByteDescriptionType Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeOneByteDescriptionType Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeOneByteDescriptionType:

[legend]
Collaboration diagram for BtSddbDeOneByteDescriptionType:

[legend]

Public Member Functions

BtSddbDeOneByteDescriptionType ()
Constructor.
const void * | GetData () const
void * | GetData ()
virtual | ~BtSddbDeOneByteDescriptionType ()
Destructor.

Protected Member Functions

virtual UINT8 | GetDataElementDescriptor () const =0
virtual INT32 | GetMemorySize () const
virtual BOOLEAN | ReadFromMemory (const void *&memory, INT32 &memory_size)
void | SetData (void *data)
virtual void * | WriteToMemory (void *memory) const

Protected Attributes

void * | m_data

Constructor & Destructor Documentation

BtSddbDeOneByteDescriptionType::BtSddbDeOneByteDescriptionType ( )

Constructor.

BtSddbDeOneByteDescriptionType::~BtSddbDeOneByteDescriptionType ( ) [virtual]

Destructor.

Member Function Documentation

const void * BtSddbDeOneByteDescriptionType::GetData ( ) const

GetData returns a pointer to a memory block where the value data of this data element is stored. How to interpret the content of this memory block depends on the type of the data element.

Returns:
A pointer to void containing the address of a memory block containing the value data for this data element.

void * BtSddbDeOneByteDescriptionType::GetData ( )

GetData returns a pointer to a memory block where the value data of this data element is stored. How to interpret the content of this memory block depends on the type of the data element.

Returns:
A pointer to void containing the address of a memory block containing the value data for this data element.

virtual UINT8 BtSddbDeOneByteDescriptionType::GetDataElementDescriptor ( ) const [protected, pure virtual]

Implemented in BtSddbDeNil, BtSddbDeUint8, BtSddbDeUint16, BtSddbDeUint32, BtSddbDeSint8, BtSddbDeSint16, BtSddbDeSint32, BtSddbDeUuid16, BtSddbDeUuid32, BtSddbDeBoolean, BtSddbDeUint64, BtSddbDeUint128, BtSddbDeSint64, BtSddbDeSint128, and BtSddbDeUuid128.

INT32 BtSddbDeOneByteDescriptionType::GetMemorySize ( ) const [protected, virtual]

GetMemorySize is used by BtServiceAttribute in conjunction with the service discovery database and returns the size of this data element, if it would be stored in the format the BT-Stack expects.

Parameters:
A UINT32 containing the size of the data element, if it would be stored in the format the BT-Stack expects.

Implements BtSddbDataElement.

BOOLEAN BtSddbDeOneByteDescriptionType::ReadFromMemory | ( | const void *& | memory,
 |  | INT32 & | memory_size
 | ) | [protected, virtual]

Implements BtSddbDataElement.

void BtSddbDeOneByteDescriptionType::SetData ( void * data ) [protected]

void * BtSddbDeOneByteDescriptionType::WriteToMemory ( void * memory ) const [protected, virtual]

WriteToMemroy is used by BtServiceAttribute in conjunction with the service discovery database and it writes this data element to a memory location in the format the BT-Stack expects.

Parameters:
memory A pointer to void containing the start address of the memory block, where to write this data element to.

Implements BtSddbDataElement.

Field Documentation

void* BtSddbDeOneByteDescriptionType::m_data [protected]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeSequence Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeSequence Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeSequence:

[legend]
Collaboration diagram for BtSddbDeSequence:

[legend]

Public Member Functions

BtSddbDeSequence ()
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeSequence ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementTypeDescriptor () const

Constructor & Destructor Documentation

BtSddbDeSequence::BtSddbDeSequence ( )

BtSddbDeSequence::~BtSddbDeSequence ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeSequence::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeSequence::GetDataElementTypeDescriptor ( ) const [protected, virtual]

Implements BtSddbDeContainer.

BtDataElementType BtSddbDeSequence::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeSint128 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeSint128 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeSint128:

[legend]
Collaboration diagram for BtSddbDeSint128:

[legend]

Public Member Functions

BtSddbDeSint128 (const UINT8 *value=0)
virtual INT32 | GetSize () const
virtual | ~BtSddbDeSint128 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeSint128::BtSddbDeSint128 ( const UINT8 * value = 0 )

BtSddbDeSint128::~BtSddbDeSint128 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeSint128::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeSint128::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeSint128::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeSint16 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeSint16 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeSint16:

[legend]
Collaboration diagram for BtSddbDeSint16:

[legend]

Public Member Functions

BtSddbDeSint16 (INT16 value=0)
virtual INT32 | GetSize () const
INT16 | GetValue () const
void | SetValue (INT16 value)
virtual | ~BtSddbDeSint16 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeSint16::BtSddbDeSint16 ( INT16 value = 0 )

BtSddbDeSint16::~BtSddbDeSint16 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeSint16::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeSint16::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeSint16::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

INT16 BtSddbDeSint16::GetValue ( ) const

void BtSddbDeSint16::SetValue ( INT16 value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeSint32 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeSint32 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeSint32:

[legend]
Collaboration diagram for BtSddbDeSint32:

[legend]

Public Member Functions

BtSddbDeSint32 (INT32 value=0)
virtual INT32 | GetSize () const
INT32 | GetValue () const
void | SetValue (INT32 value)
virtual | ~BtSddbDeSint32 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeSint32::BtSddbDeSint32 ( INT32 value = 0 )

BtSddbDeSint32::~BtSddbDeSint32 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeSint32::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeSint32::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeSint32::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

INT32 BtSddbDeSint32::GetValue ( ) const

void BtSddbDeSint32::SetValue ( INT32 value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeSint64 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeSint64 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeSint64:

[legend]
Collaboration diagram for BtSddbDeSint64:

[legend]

Public Member Functions

BtSddbDeSint64 (const UINT8 *value=0)
virtual INT32 | GetSize () const
virtual | ~BtSddbDeSint64 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeSint64::BtSddbDeSint64 ( const UINT8 * value = 0 )

BtSddbDeSint64::~BtSddbDeSint64 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeSint64::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeSint64::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeSint64::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeSint8 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeSint8 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeSint8:

[legend]
Collaboration diagram for BtSddbDeSint8:

[legend]

Public Member Functions

BtSddbDeSint8 (INT8 value=0)
virtual INT32 | GetSize () const
INT8 | GetValue () const
void | SetValue (INT8 value)
virtual | ~BtSddbDeSint8 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeSint8::BtSddbDeSint8 ( INT8 value = 0 )

BtSddbDeSint8::~BtSddbDeSint8 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeSint8::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeSint8::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeSint8::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

INT8 BtSddbDeSint8::GetValue ( ) const

void BtSddbDeSint8::SetValue ( INT8 value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeSintBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeSintBase Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeSintBase:

[legend]
Collaboration diagram for BtSddbDeSintBase:

[legend]

Public Member Functions

BtSddbDeSintBase ()
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeSintBase ()

Constructor & Destructor Documentation

BtSddbDeSintBase::BtSddbDeSintBase ( )

BtSddbDeSintBase::~BtSddbDeSintBase ( ) [virtual]

Member Function Documentation

BtDataElementType BtSddbDeSintBase::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeString Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeString Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeString:

[legend]
Collaboration diagram for BtSddbDeString:

[legend]

Public Member Functions

BtSddbDeString (const WString &value)
BtSddbDeString ()
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeString ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementTypeDescriptor () const

Constructor & Destructor Documentation

BtSddbDeString::BtSddbDeString ( )

BtSddbDeString::BtSddbDeString ( const WString & value )

BtSddbDeString::~BtSddbDeString ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeString::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeString::GetDataElementTypeDescriptor ( ) const [protected, virtual]

Implements BtSddbDeVariableLengthType.

BtDataElementType BtSddbDeString::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUint128 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUint128 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUint128:

[legend]
Collaboration diagram for BtSddbDeUint128:

[legend]

Public Member Functions

BtSddbDeUint128 (const UINT8 *value=0)
virtual INT32 | GetSize () const
virtual | ~BtSddbDeUint128 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUint128::BtSddbDeUint128 ( const UINT8 * value = 0 )

BtSddbDeUint128::~BtSddbDeUint128 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUint128::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUint128::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeUint128::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUint16 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUint16 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUint16:

[legend]
Collaboration diagram for BtSddbDeUint16:

[legend]

Public Member Functions

BtSddbDeUint16 (UINT16 value=0)
virtual INT32 | GetSize () const
UINT16 | GetValue () const
void | SetValue (UINT16 value)
virtual | ~BtSddbDeUint16 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUint16::BtSddbDeUint16 ( UINT16 value = 0 )

BtSddbDeUint16::~BtSddbDeUint16 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUint16::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUint16::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeUint16::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

UINT16 BtSddbDeUint16::GetValue ( ) const

void BtSddbDeUint16::SetValue ( UINT16 value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUint32 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUint32 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUint32:

[legend]
Collaboration diagram for BtSddbDeUint32:

[legend]

Public Member Functions

BtSddbDeUint32 (UINT32 value=0)
virtual INT32 | GetSize () const
UINT32 | GetValue () const
void | SetValue (UINT32 value)
virtual | ~BtSddbDeUint32 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUint32::BtSddbDeUint32 ( UINT32 value = 0 )

BtSddbDeUint32::~BtSddbDeUint32 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUint32::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUint32::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeUint32::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

UINT32 BtSddbDeUint32::GetValue ( ) const

void BtSddbDeUint32::SetValue ( UINT32 value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUint64 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUint64 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUint64:

[legend]
Collaboration diagram for BtSddbDeUint64:

[legend]

Public Member Functions

BtSddbDeUint64 (const UINT8 *value=0)
virtual INT32 | GetSize () const
virtual | ~BtSddbDeUint64 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUint64::BtSddbDeUint64 ( const UINT8 * value = 0 )

BtSddbDeUint64::~BtSddbDeUint64 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUint64::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUint64::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeUint64::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUint8 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUint8 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUint8:

[legend]
Collaboration diagram for BtSddbDeUint8:

[legend]

Public Member Functions

BtSddbDeUint8 (UINT8 value=0)
virtual INT32 | GetSize () const
UINT8 | GetValue () const
void | SetValue (UINT8 value)
virtual | ~BtSddbDeUint8 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUint8::BtSddbDeUint8 ( UINT8 value = 0 )

BtSddbDeUint8::~BtSddbDeUint8 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUint8::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUint8::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeUint8::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

UINT8 BtSddbDeUint8::GetValue ( ) const

void BtSddbDeUint8::SetValue ( UINT8 value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUintBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUintBase Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUintBase:

[legend]
Collaboration diagram for BtSddbDeUintBase:

[legend]

Public Member Functions

BtSddbDeUintBase ()
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeUintBase ()

Constructor & Destructor Documentation

BtSddbDeUintBase::BtSddbDeUintBase ( )

BtSddbDeUintBase::~BtSddbDeUintBase ( ) [virtual]

Member Function Documentation

BtDataElementType BtSddbDeUintBase::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUrl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUrl Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUrl:

[legend]
Collaboration diagram for BtSddbDeUrl:

[legend]

Public Member Functions

BtSddbDeUrl ()
BtSddbDeUrl (const WString &value)
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeUrl ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementTypeDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUrl::BtSddbDeUrl ( const WString & value )

BtSddbDeUrl::BtSddbDeUrl ( )

BtSddbDeUrl::~BtSddbDeUrl ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUrl::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUrl::GetDataElementTypeDescriptor ( ) const [protected, virtual]

Implements BtSddbDeVariableLengthType.

BtDataElementType BtSddbDeUrl::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUuid128 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUuid128 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUuid128:

[legend]
Collaboration diagram for BtSddbDeUuid128:

[legend]

Public Member Functions

BtSddbDeUuid128 (const UINT8 *value=0)
virtual INT32 | GetSize () const
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeUuid128 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUuid128::BtSddbDeUuid128 ( const UINT8 * value = 0 )

BtSddbDeUuid128::~BtSddbDeUuid128 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUuid128::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUuid128::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeUuid128::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

BtDataElementType BtSddbDeUuid128::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUuid16 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUuid16 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUuid16:

[legend]
Collaboration diagram for BtSddbDeUuid16:

[legend]

Public Member Functions

BtSddbDeUuid16 (UINT16 value=0)
virtual INT32 | GetSize () const
UINT16 | GetValue () const
void | SetValue (UINT16 value)
virtual | ~BtSddbDeUuid16 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUuid16::BtSddbDeUuid16 ( UINT16 value = 0 )

BtSddbDeUuid16::~BtSddbDeUuid16 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUuid16::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUuid16::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeUuid16::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

UINT16 BtSddbDeUuid16::GetValue ( ) const

void BtSddbDeUuid16::SetValue ( UINT16 value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUuid32 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUuid32 Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUuid32:

[legend]
Collaboration diagram for BtSddbDeUuid32:

[legend]

Public Member Functions

BtSddbDeUuid32 (UINT32 value=0)
virtual INT32 | GetSize () const
UINT32 | GetValue () const
void | SetValue (UINT32 value)
virtual | ~BtSddbDeUuid32 ()

Protected Member Functions

virtual BtSddbDataElement * | Clone () const
virtual UINT8 | GetDataElementDescriptor () const

Constructor & Destructor Documentation

BtSddbDeUuid32::BtSddbDeUuid32 ( UINT32 value = 0 )

BtSddbDeUuid32::~BtSddbDeUuid32 ( ) [virtual]

Member Function Documentation

BtSddbDataElement * BtSddbDeUuid32::Clone ( ) const [protected, virtual]

Clone creates a copy of this data element.

Returns:
A pointer to a BtDataElement containing the address of a data element that is an exact copy of this data element.

0 A copy of this data element could not be created.

Implements BtSddbDataElement.

UINT8 BtSddbDeUuid32::GetDataElementDescriptor ( ) const [protected, virtual]

Implements BtSddbDeOneByteDescriptionType.

INT32 BtSddbDeUuid32::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

UINT32 BtSddbDeUuid32::GetValue ( ) const

void BtSddbDeUuid32::SetValue ( UINT32 value )

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeUuidBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeUuidBase Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeUuidBase:

[legend]
Collaboration diagram for BtSddbDeUuidBase:

[legend]

Public Member Functions

BtSddbDeUuidBase ()
virtual BtDataElementType | GetType () const
virtual | ~BtSddbDeUuidBase ()

Constructor & Destructor Documentation

BtSddbDeUuidBase::BtSddbDeUuidBase ( )

BtSddbDeUuidBase::~BtSddbDeUuidBase ( ) [virtual]

Member Function Documentation

BtDataElementType BtSddbDeUuidBase::GetType ( ) const [virtual]

GetType returns the type of the data element as an enumeration type. This information can be used for type cast.

Returns:
A BtDataElementType that is an enumeration type describing the kind of date element.

Implements BtSddbDataElement.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbDeVariableLengthType Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbDeVariableLengthType Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbDataElements.hpp>

Inheritance diagram for BtSddbDeVariableLengthType:

[legend]
Collaboration diagram for BtSddbDeVariableLengthType:

[legend]

Public Member Functions

BtSddbDeVariableLengthType (const WString &value)
BtSddbDeVariableLengthType ()
virtual INT32 | GetSize () const
WString | GetValue () const
virtual BOOLEAN | IsValid () const
void | SetValue (const WString &value)
virtual | ~BtSddbDeVariableLengthType ()

Protected Member Functions

UINT8 | GetDataElementSizeDescriptor () const
virtual UINT8 | GetDataElementTypeDescriptor () const =0
virtual INT32 | GetMemorySize () const
virtual BOOLEAN | ReadFromMemory (const void *&memory, INT32 &memory_size)
virtual void * | WriteToMemory (void *memory) const

Protected Attributes

String m_value

Constructor & Destructor Documentation

BtSddbDeVariableLengthType::BtSddbDeVariableLengthType ( )

BtSddbDeVariableLengthType::BtSddbDeVariableLengthType ( const WString & value )

BtSddbDeVariableLengthType::~BtSddbDeVariableLengthType ( ) [virtual]

Member Function Documentation

UINT8 BtSddbDeVariableLengthType::GetDataElementSizeDescriptor ( ) const [protected]

virtual UINT8 BtSddbDeVariableLengthType::GetDataElementTypeDescriptor ( ) const [protected, pure virtual]

Implemented in BtSddbDeString, and BtSddbDeUrl.

INT32 BtSddbDeVariableLengthType::GetMemorySize ( ) const [protected, virtual]

GetMemorySize is used by BtServiceAttribute in conjunction with the service discovery database and returns the size of this data element, if it would be stored in the format the BT-Stack expects.

Parameters:
A UINT32 containing the size of the data element, if it would be stored in the format the BT-Stack expects.

Implements BtSddbDataElement.

INT32 BtSddbDeVariableLengthType::GetSize ( ) const [virtual]

GetSize return the size of the data element. How this size has to be interpreted depends on the type of this data element.

Returns:
An INT32 describing the size of the data element.

Implements BtSddbDataElement.

WString BtSddbDeVariableLengthType::GetValue ( ) const

BOOLEAN BtSddbDeVariableLengthType::IsValid ( ) const [virtual]

Implements BtSddbDataElement.

BOOLEAN BtSddbDeVariableLengthType::ReadFromMemory | ( | const void *& | memory,
 |  | INT32 & | memory_size
 | ) | [protected, virtual]

Implements BtSddbDataElement.

void BtSddbDeVariableLengthType::SetValue ( const WString & value )

void * BtSddbDeVariableLengthType::WriteToMemory ( void * memory ) const [protected, virtual]

WriteToMemroy is used by BtServiceAttribute in conjunction with the service discovery database and it writes this data element to a memory location in the format the BT-Stack expects.

Parameters:
memory A pointer to void containing the start address of the memory block, where to write this data element to.

Implements BtSddbDataElement.

Field Documentation

String BtSddbDeVariableLengthType::m_value [protected]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbDataElements.hpp
  • Bluetooth/BtSddbDataElements.cpp
Generated on Wed Jan 25 01:02:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbEvent.hpp>

Inheritance diagram for BtSddbEvent:

[legend]
Collaboration diagram for BtSddbEvent:

[legend]

Public Member Functions

BtSddbEvent (BtResultCode result)
Constructor.
virtual ~BtSddbEvent ()
Destructor.

Constructor & Destructor Documentation

BtSddbEvent::BtSddbEvent ( BtResultCode result )

Constructor.

BtSddbEvent::~BtSddbEvent ( ) [virtual]

Destructor.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbEvent.hpp
  • Bluetooth/BtSddbEvent.cpp
Generated on Wed Jan 25 01:02:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbRegisterServiceEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbRegisterServiceEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbEvent.hpp>

Inheritance diagram for BtSddbRegisterServiceEvent:

[legend]
Collaboration diagram for BtSddbRegisterServiceEvent:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

BtSddbRegisterServiceEvent (BtResultCode result, UINT32 service_record_handle)
Constructor.
virtual UINT16 | GetId () const
UINT32 | GetSerivceRecordHandle () const
virtual | ~BtSddbRegisterServiceEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtSddbRegisterServiceEvent::BtSddbRegisterServiceEvent | ( | BtResultCode | result,
 |  | UINT32 | service_record_handle
 | ) |

Constructor.

BtSddbRegisterServiceEvent::~BtSddbRegisterServiceEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtSddbRegisterServiceEvent::GetId ( ) const [virtual]

Implements BtEvent.

UINT32 BtSddbRegisterServiceEvent::GetSerivceRecordHandle ( ) const

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbEvent.hpp
  • Bluetooth/BtSddbEvent.cpp
Generated on Wed Jan 25 01:02:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbRequestStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbRequestStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/BtSddbServiceMessage.hpp>

Inheritance diagram for BtSddbRequestStateChangedMessage:

[legend]
Collaboration diagram for BtSddbRequestStateChangedMessage:

[legend]

Public Types

enum | { ID = 10310 }

Public Member Functions

BtSddbRequestStateChangedMessage (BtService *service, const BtRequestType &request_type, const BtRequestState &old_request_state, const BtRequestState &new_request_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtSddbRequestStateChangedMessage ()

Detailed Description

BtSddbRequestStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BtServiceMessage.

Constructor & Destructor Documentation

BtSddbRequestStateChangedMessage::BtSddbRequestStateChangedMessage | ( | BtService * | service,
 |  | const BtRequestType & | request_type,
 |  | const BtRequestState & | old_request_state,
 |  | const BtRequestState & | new_request_state
 | ) |

BtSddbRequestStateChangedMessage::~BtSddbRequestStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtSddbRequestStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

const MsgMetaData & BtSddbRequestStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtRequestStateChangedMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbServiceMessage.hpp
  • Bluetooth/BtSddbServiceMessage.cpp
Generated on Wed Jan 25 01:02:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbService.hpp>

Inheritance diagram for BtSddbService:

[legend]
Collaboration diagram for BtSddbService:

[legend]

Public Member Functions

BOOLEAN | Attach (BtSddbServiceObserver *service_observer)
BtSddbService ()
Constructor.
BOOLEAN | Detach (BtSddbServiceObserver *service_observer)
virtual BtProfile | GetProfile () const
Get the profile this service is associated with.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const
UINT32 | GetServiceRecordHandle ()
BtRequestState | RegisterServiceRecordRequest (const BtSddbServiceRecord &service_record, UINT32 service_record_handle=0)
BtRequestState | UnregisterServiceRecordRequest (UINT32 service_record_handle)
virtual | ~BtSddbService ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &message)
virtual void | RegisterMessages () const
void | RegisterServiceCallback (BtResultCode result, UINT32 service_record_handle)
virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)
virtual void | UnregisterMessages () const
void | UnregisterServiceCallback (BtResultCode result)

Friends

class | BtSddbRegisterServiceRecordRequest
class | BtSddbUnregisterServiceRecordRequest

Constructor & Destructor Documentation

BtSddbService::BtSddbService ( )

Constructor.

BtSddbService::~BtSddbService ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtSddbService::Attach ( BtSddbServiceObserver * service_observer )

BOOLEAN BtSddbService::Detach ( BtSddbServiceObserver * service_observer )

BtProfile BtSddbService::GetProfile ( ) const [virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implements BtService.

BtRequestState BtSddbService::GetRequestState ( BtRequestType request_type ) const [virtual]

Implements BtService.

UINT32 BtSddbService::GetServiceRecordHandle ( )

BOOLEAN BtSddbService::OnMessage ( const Message & message ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void BtSddbService::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

void BtSddbService::RegisterServiceCallback | ( | BtResultCode | result,
 |  | UINT32 | service_record_handle
 | ) | [protected]

BtRequestState BtSddbService::RegisterServiceRecordRequest | ( | const BtSddbServiceRecord & | service_record,
 |  | UINT32 | service_record_handle = 0
 | ) |

void BtSddbService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, virtual]

Implements BtService.

void BtSddbService::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

void BtSddbService::UnregisterServiceCallback ( BtResultCode result ) [protected]

BtRequestState BtSddbService::UnregisterServiceRecordRequest ( UINT32 service_record_handle )

Friends And Related Function Documentation

friend class BtSddbRegisterServiceRecordRequest [friend]

friend class BtSddbUnregisterServiceRecordRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbService.hpp
  • Bluetooth/BtSddbService.cpp
Generated on Wed Jan 25 01:02:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbServiceAttribute Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbServiceAttribute Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbServiceAttribute.hpp>

Collaboration diagram for BtSddbServiceAttribute:

[legend]

Public Member Functions

BtSddbServiceAttribute (const BtSddbServiceAttribute &service_attribute)
Constructor.
BtSddbServiceAttribute (UINT16 attribute_id, const BtSddbDataElement &data_delement)
Constructor.
BtSddbServiceAttribute ()
Constructor (default).
UINT16 | GetAttributeId () const
const BtSddbDataElement * | GetAttributeValue () const
BtSddbDataElement * GetAttributeValue ()
BOOLEAN | IsValid () const
void | SetAttributeId (UINT16 attribute_id)
BOOLEAN | SetAttributeValue (const BtSddbDataElement &attribute_value)
virtual | ~BtSddbServiceAttribute ()
Destructor.

Protected Member Functions

UINT32 | GetMemorySize () const
BOOLEAN | ReadFromMemory (const void *&memory, INT32 &memory_size)
void * | WriteToMemory (void *memory) const

Friends

class | BtSddbServiceRecord

Constructor & Destructor Documentation

BtSddbServiceAttribute::BtSddbServiceAttribute ( )

Constructor (default).

BtSddbServiceAttribute::BtSddbServiceAttribute | ( | UINT16 | attribute_id,
 |  | const BtSddbDataElement & | data_delement
 | ) |

Constructor.

BtSddbServiceAttribute::BtSddbServiceAttribute ( const BtSddbServiceAttribute & service_attribute )

Constructor.

BtSddbServiceAttribute::~BtSddbServiceAttribute ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtSddbServiceAttribute::GetAttributeId ( ) const

GetAttributeId returns the unique id identifying this attribute.

Returns:
An UINT16 containing the unique id for this attribute.

const BtSddbDataElement * BtSddbServiceAttribute::GetAttributeValue ( ) const

GetAttributeValue returns the BtDataElement containing the value of this attribute.

Returns:
A pointer to a BtDataElement containing the value of this attribute.

BtSddbDataElement * BtSddbServiceAttribute::GetAttributeValue ( )

GetAttributeValue returns the BtDataElement containing the value of this attribute.

Returns:
A pointer to a BtDataElement containing the value of this attribute.

UINT32 BtSddbServiceAttribute::GetMemorySize ( ) const [protected]

GetMemorySize is used by the service discovery database and returns the size of this attribute, if it would be stored in the format the BT-Stack expects.

Returns:
A UINT32 containing the size of the attribute, if it would be stored in the format the BT-Stack expects.

BOOLEAN BtSddbServiceAttribute::IsValid ( ) const

BOOLEAN BtSddbServiceAttribute::ReadFromMemory | ( | const void *& | memory,
 |  | INT32 & | memory_size
 | ) | [protected]

void BtSddbServiceAttribute::SetAttributeId ( UINT16 attribute_id )

BOOLEAN BtSddbServiceAttribute::SetAttributeValue ( const BtSddbDataElement & attribute_value )

void * BtSddbServiceAttribute::WriteToMemory ( void * memory ) const [protected]

WriteToMemroy is used by the service discovery database and it writes this attribute to a memory location in the format the BT-Stack expects.

Parameters:
memory A pointer to void containing the start address of the memory block, where to write this attribute to.

Friends And Related Function Documentation

friend class BtSddbServiceRecord [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbServiceAttribute.hpp
  • Bluetooth/BtSddbServiceAttribute.cpp
Generated on Wed Jan 25 01:02:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbServiceObserver Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbServiceObserver Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbServiceObserver.hpp>

Inheritance diagram for BtSddbServiceObserver:

[legend]
Collaboration diagram for BtSddbServiceObserver:

[legend]

Public Member Functions

BtSddbServiceObserver ()
Constructor.
virtual | ~BtSddbServiceObserver ()
Destructor.

Protected Member Functions

virtual void | OnEvent (const BtEvent &event)
virtual void | OnRegisterService (BtResultCode code)=0
virtual void | OnUnregisterService (BtResultCode code)=0

Friends

class | BtSddbService

Constructor & Destructor Documentation

BtSddbServiceObserver::BtSddbServiceObserver ( )

Constructor.

BtSddbServiceObserver::~BtSddbServiceObserver ( ) [virtual]

Destructor.

Member Function Documentation

void BtSddbServiceObserver::OnEvent ( const BtEvent & event ) [protected, virtual]

Implements BtServiceObserver.

virtual void BtSddbServiceObserver::OnRegisterService ( BtResultCode code ) [protected, pure virtual]

Implemented in BtObexSddbServiceObserverImpl.

virtual void BtSddbServiceObserver::OnUnregisterService ( BtResultCode code ) [protected, pure virtual]

Implemented in BtObexSddbServiceObserverImpl.

Friends And Related Function Documentation

friend class BtSddbService [friend]

Reimplemented in BtObexSddbServiceObserverImpl.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbServiceObserver.hpp
  • Bluetooth/BtSddbServiceObserver.cpp
Generated on Wed Jan 25 01:02:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbServiceRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbServiceRecord Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbServiceRecord.hpp>

Public Member Functions

BtSddbServiceRecord ()
Constructor (Default).
void | Clear (void)
BtSddbServiceAttribute * | Delete (BtSddbServiceAttribute *service_attribute)
const BtSddbServiceAttribute * | GetAttributeById (UINT16 service_attribute_id) const
BtSddbServiceAttribute * | GetAttributeById (UINT16 service_attribute_id)
const BtSddbServiceAttribute * | GetFirstAttribute () const
BtSddbServiceAttribute * GetFirstAttribute ()
const BtSddbServiceAttribute * | GetNextAttribute (const BtSddbServiceAttribute *current) const
BtSddbServiceAttribute * | GetNextAttribute (const BtSddbServiceAttribute *current)
UINT16 | GetNumberOfAttributes () const
BOOLEAN | Insert (const BtSddbServiceAttribute &service_attribute, const BtSddbServiceAttribute *position=0)
BOOLEAN | IsValid () const
BtSddbServiceRecord & | operator= (const BtSddbServiceRecord &service_record)
virtual | ~BtSddbServiceRecord ()
Destructor.

Protected Member Functions

UINT32 | GetMemorySize () const
BOOLEAN | ReadFromMemory (const void *&memory, INT32 &memory_size)
void * | WriteToMemory (void *memory) const

Friends

class | BtServiceDiscoveryDatabase

Data Structures

class | BtSddbServiceRecordNode

Constructor & Destructor Documentation

BtSddbServiceRecord::BtSddbServiceRecord ( )

Constructor (Default).

BtSddbServiceRecord::~BtSddbServiceRecord ( ) [virtual]

Destructor.

Member Function Documentation

void BtSddbServiceRecord::Clear ( void )

BtSddbServiceAttribute * BtSddbServiceRecord::Delete ( BtSddbServiceAttribute * service_attribute )

Delete deletes the passed service attribute from this service record and returns the service attribute following the deleted one or 0 if the deleted one was the last. The deleted element is also destroyed, so the passed pointer gets invalid.

Parameters:
service_attribute A reference to a pointer to a BtServiceAttribute that should be deleted. The pointer is set to 0 if the attribute was in this service record and could be deleted.
Returns:
A pointer to a BtServiceAttribute pointing to the service attribute following the one that was deleted.

0 The service attribute that has to be deleted was the last one or was not contained in this service record. Check service_attribute to distinguish these two cases.

const BtSddbServiceAttribute * BtSddbServiceRecord::GetAttributeById ( UINT16 service_attribute_id ) const

GetAttributeById searches this service record for the existance of an attribute with the passed id. If so the attribute is returned, otherwise 0 is returned to inidicate that the attribute was not found in this service record.

Parameters:
service_attribute_id An UINT16 containing the unique id of an attribute, that should be retrieved.
Returns:
A pointer to a BtServiceAttribute containing the service attribute with the passed unique id.

0 The service attribute matching the passed unique id can not be found.

BtSddbServiceAttribute * BtSddbServiceRecord::GetAttributeById ( UINT16 service_attribute_id )

GetAttributeById searches this service record for the existance of an attribute with the passed id. If so the attribute is returned, otherwise 0 is returned to inidicate that the attribute was not found in this service record.

Parameters:
service_attribute_id An UINT16 containing the unique id of an attribute, that should be retrieved.
Returns:
A pointer to a BtServiceAttribute containing the service attribute with the passed unique id.

0 The service attribute matching the passed unique id can not be found.

const BtSddbServiceAttribute * BtSddbServiceRecord::GetFirstAttribute ( ) const

GetFirstAttribute returns the first attribute of the chain building up this service record.

Returns:
A pointer to a BtServiceAttribute containing the address of the first service attribute of this service record.

0 if the service record contains no service attributes.

BtSddbServiceAttribute * BtSddbServiceRecord::GetFirstAttribute ( )

GetFirstAttribute returns the first attribute of the chain building up this service record.

Returns:
A pointer to a BtServiceAttribute containing the address of the first service attribute of this service record.

0 if the service record contains no service attributes.

UINT32 BtSddbServiceRecord::GetMemorySize ( ) const [protected]

GetMemorySize is used by the service discovery database and returns the size of this service record, if it would be stored in the format the BT-Stack expects.

Returns:
A UINT32 containing the size of the service record, if it would be stored in the format the BT-Stack expects.

const BtSddbServiceAttribute * BtSddbServiceRecord::GetNextAttribute ( const BtSddbServiceAttribute * current ) const

GetNextAttribute returns the service attribute next to the passed service attribute in the chain building up this service record.

Parameters:
current A pointner to a BtServiceAttribute containing the address of the service attribute for which the successor is wanted. current may not be 0.
Returns:
A pointer to a BtServiceAttribute containting the address of the attribute following the current attribute.

0 if the current service attribute was the last in the chain building up this service record.

BtSddbServiceAttribute * BtSddbServiceRecord::GetNextAttribute ( const BtSddbServiceAttribute * current )

GetNextAttribute returns the service attribute next to the passed service attribute in the chain building up this service record.

Parameters:
current A pointner to a BtServiceAttribute containing the address of the service attribute for which the successor is wanted. current may not be 0.
Returns:
A pointer to a BtServiceAttribute containting the address of the attribute following the current attribute.

0 if the current service attribute was the last in the chain building up this service record.

UINT16 BtSddbServiceRecord::GetNumberOfAttributes ( ) const

GetNumberOfAttributes returns the number of BtServiceAttributes contained in this service record.

Returns:
An UINT16 containing the number of service attributes that are stored in this service record.

BOOLEAN BtSddbServiceRecord::Insert | ( | const BtSddbServiceAttribute & | service_attribute,
 |  | const BtSddbServiceAttribute * | position = 0
 | ) |

Insert inserts a new service attribute into this service record.

Parameters:
service_attribute | A reference to a BtServiceAttribute that depicts the service attribute that should be inserted nto this service record. The service record, that should be inserted is copied.
position | A pointer to a BtServiceAttribute containing the address of the service attribute of this service record before which the service_attribute should be inserted. If the position has the value 0 the service_attribute is appended at the end.
Returns:
TRUE The insert operation was successfull.

FALSE The insert operation failed. The service attribute was not inserted.

BOOLEAN BtSddbServiceRecord::IsValid ( ) const

BtSddbServiceRecord & BtSddbServiceRecord::operator= ( const BtSddbServiceRecord & service_record )

BOOLEAN BtSddbServiceRecord::ReadFromMemory | ( | const void *& | memory,
 |  | INT32 & | memory_size
 | ) | [protected]

ReadFromMemory is used to construct the BtServiceRecord from a memory block containing a service record. The format how this memory block has to be interpreted is defined by the is_service_search_result flag.

Parameters:
memory A pointer to void containing the start address of the memory block, where to read this service record from.
Returns:
A pointer to void containing the address within the passed memory block, where the read ended.

void * BtSddbServiceRecord::WriteToMemory ( void * memory ) const [protected]

WriteToMemroy is used by the service discovery database and it writes this service record to a memory location in the format the BT-Stack expects.

Parameters:
memory A pointer to void containing the start address of the memory block, where to write this service record to.
Returns:
A pointer to void containing the address within the passed memory block, where the write ended.

Friends And Related Function Documentation

friend class BtServiceDiscoveryDatabase [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbServiceRecord.hpp
  • Bluetooth/BtSddbServiceRecord.cpp
Generated on Wed Jan 25 01:02:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSddbUnregisterServiceEvent Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSddbUnregisterServiceEvent Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSddbEvent.hpp>

Inheritance diagram for BtSddbUnregisterServiceEvent:

[legend]
Collaboration diagram for BtSddbUnregisterServiceEvent:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

BtSddbUnregisterServiceEvent (BtResultCode result)
Constructor.
virtual UINT16 | GetId () const
virtual | ~BtSddbUnregisterServiceEvent ()
Destructor.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtSddbUnregisterServiceEvent::BtSddbUnregisterServiceEvent ( BtResultCode result )

Constructor.

BtSddbUnregisterServiceEvent::~BtSddbUnregisterServiceEvent ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtSddbUnregisterServiceEvent::GetId ( ) const [virtual]

Implements BtEvent.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSddbEvent.hpp
  • Bluetooth/BtSddbEvent.cpp
Generated on Wed Jan 25 01:02:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSendPasskeyMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSendPasskeyMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtSendPasskeyMessage:

[legend]
Collaboration diagram for BtSendPasskeyMessage:

[legend]

Public Types

enum | { ID = 10218 }

Public Member Functions

BtSendPasskeyMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtSendPasskeyMessage ()

Detailed Description

BtSendPasskeyMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtSendPasskeyMessage::BtSendPasskeyMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtSendPasskeyMessage::~BtSendPasskeyMessage ( ) [virtual]

Member Function Documentation

Message * BtSendPasskeyMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtSendPasskeyMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:02:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSendPasskeyRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSendPasskeyRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSendPasskeyRequest.hpp>

Inheritance diagram for BtSendPasskeyRequest:

[legend]
Collaboration diagram for BtSendPasskeyRequest:

[legend]

Public Member Functions

BtSendPasskeyRequest (const BtDevice &device)
Constructor.
BOOLEAN | GetAcceptPairing () const
Will the received pairing request be accepted or not.
const WString & | GetPinCode () const
Gets the pin code.
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetAcceptPairing (BOOLEAN accept_pairing)
Sets whether the received pairing request will be accepted or not.
void | SetPinCode (const WString &pin_code)
Sets the pin code.
virtual | ~BtSendPasskeyRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | RegisterMessages () const
Register the required messages for receipt.
virtual void | UnregisterMessages () const
Unregister the required messages from receipt.

Detailed Description

During the execution of a pairing request by the Bluetooth Stack a request for authentication will be sent to the Local Bluetooth Device, no matter wheter the Local or the Remote Bluetooth Device has initiated the pairing request. To answer the recieved request for authentication the application programmer has to instantiate a BtSendPasskeyReqeust, set wheter the pairing is accepted or not. If the pairing is accepted the pin code must be set. After a positive execution of this request the Bluetooth Stack has created the link keys, which will be used for further authentication and encryption.

Constructor & Destructor Documentation

BtSendPasskeyRequest::BtSendPasskeyRequest ( const BtDevice & device )

Constructor.

BtSendPasskeyRequest::~BtSendPasskeyRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtSendPasskeyRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

Execute instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. Execute is one of these functions.Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BOOLEAN BtSendPasskeyRequest::GetAcceptPairing ( ) const

Will the received pairing request be accepted or not.

GetAcceptPairing returns whether this request will accept the requested pairing or reject it, when this request is exectued.

Returns:
TRUE: The requested pairing will be accepted.
FALSE: The requested pairing will be rejected.

const WString & BtSendPasskeyRequest::GetPinCode ( ) const

Gets the pin code.

GetPinCode returns the pin code that will be submitted when this request is executed.

Returns:
A reference to a WString representing the pin code as an unicode string.

BtRequestType BtSendPasskeyRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtSendPasskeyRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtSendPasskeyRequest::RegisterMessages ( ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtSendPasskeyRequest the following message is registered: BtSendPasskeyMessage

Reimplemented from UserDispatcher.

void BtSendPasskeyRequest::SetAcceptPairing ( BOOLEAN accept_pairing )

Sets whether the received pairing request will be accepted or not.

SetAcceptPairing sets wheter this request will accept the requested pairing or reject it, when this request is executed.

Parameters:
accept_pairing A BOOLEAN containing whether to accept or reject the requested pairing.

void BtSendPasskeyRequest::SetPinCode ( const WString & pin_code )

Sets the pin code.

SetPinCode sets the pin code that will be submitted when this request is executed.

Parameters:
pin_code A reference to WString representing the pin code that has to be submitted a an unicode string.

void BtSendPasskeyRequest::UnregisterMessages ( ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtSendPasskeyRequest the following message is unregistered: BtSendPasskeyMessage

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSendPasskeyRequest.hpp
  • Bluetooth/BtSendPasskeyRequest.cpp
Generated on Wed Jan 25 01:02:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtService Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtService.hpp>

Inheritance diagram for BtService:

[legend]
Collaboration diagram for BtService:

[legend]

Public Member Functions

BtService (const BtDevice &target_device)
Constructor.
BtService ()
Constructor.
virtual BtProfile | GetProfile () const =0
Get the profile this service is associated with.
virtual BtRequestState | GetRequestState (BtRequestType request_type) const =0
BtDevice & GetTargetDevice ()
Get the remote device this service addresses.
const BtDevice & | GetTargetDevice () const
Get the remote device this service addresses.
virtual void | SetTargetDevice (const BtDevice &target_device)
Sets the remote device this service addresses.
virtual | ~BtService ()
Destructor.

Protected Member Functions

virtual void | OnRequestStateChange (BtRequestType request_type, BtRequestState old_request_state, BtRequestState new_request_state)=0
Notification function of changes in running requests.
virtual void | RequestStateChangeCallback (BtServiceRequest *request, BtRequestState old_request_state, BtRequestState new_request_state)=0

Friends

class | BtServiceRequest

Detailed Description

The communication between the application and the various kinds of the Bt...Controller classes is done via BtServiceRequests. The class BtService is the base class for all services supported by the Bluetooth Stack. It forms an container for all requests of on particular profile. This class is abstract because it primarily defines the basic functionalities to all services. Each service that is supported by the Bluetooth Stack must implement a Bt...Controller and a Bt...Service class.

Constructor & Destructor Documentation

BtService::BtService ( )

Constructor.

BtService::BtService ( const BtDevice & target_device )

Constructor.

BtService::~BtService ( ) [virtual]

Destructor.

Member Function Documentation

virtual BtProfile BtService::GetProfile ( ) const [pure virtual]

Get the profile this service is associated with.

GetProfile returns the profile for which this service provides the interface, so in the base class, it is a pure virtual function.

Returns:
A BtProfile enumeration type containing the profile this service is associated with.

Implemented in BtAvrcpService, BtBppService, BtSddbService, BtDunService, BtFaxService, BtHfService, BtHsService, and BtObexService.

virtual BtRequestState BtService::GetRequestState ( BtRequestType request_type ) const [pure virtual]

Implemented in BtAvrcpOperationService, BtAvrcpRegistrationService, BtBppClientService, BtBppServerService, BtSddbService, BtDunService, BtFaxService, BtHfService, BtHsService, BtObexClientService, and BtObexServerService.

BtDevice & BtService::GetTargetDevice ( )

Get the remote device this service addresses.

Each BtService class addresses exactly one remote device. For profiles supporting more than one remote device there must be more than one instance of that prarticular servce.
GetTargetDevice returns the remote device, which this service addresses.

Returns:
A reference to a BtDevice containing the target remote device.

const BtDevice & BtService::GetTargetDevice ( ) const

Get the remote device this service addresses.

Each BtService class addresses exactly one remote device. For profiles supporting more than one remote device there must be more than one instance of that prarticular servce.
GetTargetDevice returns the remote device, which this service addresses.

Returns:
A reference to a BtDevice containing the target remote device.

virtual void BtService::OnRequestStateChange | ( | BtRequestType | request_type,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, pure virtual]

Notification function of changes in running requests.

Whenever the state of a request contained in this service is changed OnRequestStateChange will be called. This function should give the application programmer to do some GUI reaction to the progress or the failure of a partikular request.
This function has to be implemented by the application programmer, so in the base classes this function is pure virtual.

Parameters:
request_type | A BtRequestType enumeration type describing which kind of request has changed its state.
old_request_state | A BtRequestState enumeration type containing the state of the request before the state transition.
new_request_state | A BtRequestState enumeration type containing the state of the request after the state transition.

Implemented in BtObexClientServiceImpl, BtObexSddbImpl, BtObexServerServiceImpl, BtAvrcpProfileRegistrationService, BtAvrcpProfileOperationService, BtDunProfileService, BtFaxProfileService, BtHfProfileService, and BtHsProfileService.

virtual void BtService::RequestStateChangeCallback | ( | BtServiceRequest * | request,
 |  | BtRequestState | old_request_state,
 |  | BtRequestState | new_request_state
 | ) | [protected, pure virtual]

Implemented in BtAvrcpOperationService, BtAvrcpRegistrationService, BtBppService, BtSddbService, BtDunService, BtFaxService, and BtObexService.

void BtService::SetTargetDevice ( const BtDevice & target_device ) [virtual]

Sets the remote device this service addresses.

Each BtService class addresses exactly one remote device. For profiles supporting more than one remote device there must be more than one instance of that prarticular servce.
SetTargetDevice sets the remote device, that this service addresses.

Parameters:
target_device A reference to a BtDevice containing the remote device this service should address.

Reimplemented in BtHfService, and BtHsService.

Friends And Related Function Documentation

friend class BtServiceRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtService.hpp
  • Bluetooth/BtService.cpp
Generated on Wed Jan 25 01:02:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtServiceMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtServiceMessage Class Reference

#include <Apoxi/Bluetooth/BtServiceMessage.hpp>

Inheritance diagram for BtServiceMessage:

[legend]
Collaboration diagram for BtServiceMessage:

[legend]

Public Types

enum | { ID = 10300 }

Public Member Functions

BtServiceMessage (BtService *service)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BtService * | GetService () const
void | SetService (BtService *service)
virtual | ~BtServiceMessage ()

Detailed Description

BtApplicationMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtServiceMessage::BtServiceMessage ( BtService * service )

BtServiceMessage::~BtServiceMessage ( ) [virtual]

Member Function Documentation

Message * BtServiceMessage::Clone ( ) const [virtual]

Implements Message.

Reimplemented in BtAvrcpRequestStateChangedMessage, BtBipProgressMsg, BtBppRequestStateChangedMessage, BtSddbRequestStateChangedMessage, BtRequestStateChangedMessage, BtDunRequestStateChangedMessage, BtFaxRequestStateChangedMessage, BtHfRequestStateChangedMessage, BtHsRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, and BtObexClientRequestStateChangedMessage.

const MsgMetaData & BtServiceMessage::GetMetaData ( ) const [virtual]

Implements Message.

Reimplemented in BtAvrcpRequestStateChangedMessage, BtBipProgressMsg, BtBppRequestStateChangedMessage, BtSddbRequestStateChangedMessage, BtRequestStateChangedMessage, BtDunRequestStateChangedMessage, BtFaxRequestStateChangedMessage, BtHfRequestStateChangedMessage, BtHsRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, and BtObexClientRequestStateChangedMessage.

BtService* BtServiceMessage::GetService ( ) const [inline]

void BtServiceMessage::SetService ( BtService * service ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtServiceMessage.hpp
  • Bluetooth/BtServiceMessage.cpp
Generated on Wed Jan 25 01:03:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtServiceObserver Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtServiceObserver Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtServiceObserver.hpp>

Inheritance diagram for BtServiceObserver:

[legend]

Public Member Functions

BtServiceObserver ()
Constructor.
virtual | ~BtServiceObserver ()
Destructor.

Protected Member Functions

virtual void | OnEvent (const BtEvent &event)=0

Friends

class | BtObservableService

Constructor & Destructor Documentation

BtServiceObserver::BtServiceObserver ( )

Constructor.

BtServiceObserver::~BtServiceObserver ( ) [virtual]

Destructor.

Member Function Documentation

virtual void BtServiceObserver::OnEvent ( const BtEvent & event ) [protected, pure virtual]

Implemented in BtSddbServiceObserver, BtObexClientServiceObserver, BtObexServerServiceObserver, and BtObexServiceObserver.

Friends And Related Function Documentation

friend class BtObservableService [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtServiceObserver.hpp
  • Bluetooth/BtServiceObserver.cpp
Generated on Wed Jan 25 01:03:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtServiceRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtServiceRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtServiceRequest.hpp>

Inheritance diagram for BtServiceRequest:

[legend]
Collaboration diagram for BtServiceRequest:

[legend]

Public Member Functions

BtServiceRequest (BtService &service)
Constructor.
virtual BtRequestState | ExecuteRequest ()
Sumbit this request to the Bluetooth Stack.
BtService & GetService ()
Get the associationed servce.
const BtService & | GetService () const
Get the associationed servce.
virtual BOOLEAN | IsCancelable () const
Is this kind of request cancelable?
virtual | ~BtServiceRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Cancel ()
Stop the exection of this request.
virtual void | ExecutionCallback (BtResultCode result)
virtual void | SetRequestState (BtRequestState request_state)
Set processing state of this request.

Friends

class | BtController

Detailed Description

As described at the class BtService the service is a container for all requests that can be fullfilled by one profile. So the requests contained in a service need a connection to their owning service. This propertiy is implemented in BtServiceRequest.
BtServiceRequest is derived from BtUncancelableRequest becuase all pofile requests going over the air can not be cancelled.

Constructor & Destructor Documentation

BtServiceRequest::BtServiceRequest ( BtService & service )

Constructor.

BtServiceRequest::~BtServiceRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtServiceRequest::Cancel ( ) [protected, virtual]

Stop the exection of this request.

CancelRequest is used to stop this ongoing request. Requests derived from BtUncancelableRequest are generally not cancelable, so CancelRequest can be implemented here as a dummy function. This function does not cancel the ongoing request. It only returns FALSE to indicate a failure in the call to cancel an uncancelable operation.

Returns:
A BtRequestState containing the current state of exectuion for this request.

Implements BtRequest.

BtRequestState BtServiceRequest::ExecuteRequest ( ) [virtual]

Sumbit this request to the Bluetooth Stack.

ExecuteRequest instructs this request to sent itself to the Bluetooth stack for execution purposes. This function prepares the submission of the request to the stack. The real exection of the stack call is done by the fuction Execute, which is a pure virtual function, that has to be overwritten by the concrete request, which is a subclass of this class.

Returns:
A BtRequestState containing the current state of exectuion for this request. Most times the returned state indicates whether the Bluetooth Stack has accepted or rejected the request.

Implements BtRequest.

void BtServiceRequest::ExecutionCallback ( BtResultCode result ) [protected, virtual]

Implements BtRequest.

Reimplemented in BtBppSndAbortReqRequest, BtBppSndFilePushReqRequest, BtBppSndGetRefObjRspRequest, BtObexAbortRequest, BtObexConnectRequest, BtObexDisconnectRequest, BtObexGetRequest, BtObexPutRequest, BtObexRegisterClientRequest, BtObexRegisterServerRequest, BtObexSetPathRequest, BtObexUnregisterClientRequest, and BtObexUnregisterServerRequest.

BtService & BtServiceRequest::GetService ( )

Get the associationed servce.

GetService returns the service this request is associated with.

Returns:
A reference to a BtService contaning the service this request is associated with.

const BtService & BtServiceRequest::GetService ( ) const

Get the associationed servce.

GetService returns the service this request is associated with.

Returns:
A reference to a BtService contaning the service this request is associated with.

BOOLEAN BtServiceRequest::IsCancelable ( ) const [virtual]

Is this kind of request cancelable?

So kinds of requests have a very long duration. Most of these requests can be interrupted. Other request once submitted can not be stopped. So IsCancelable returns whether a request can be canceled or not. This function is pure virtual because it depends on the kind of request if it is cancelable. Further there are two subclasses which implement this function and the concrete request should be derived from one of these classes.

Returns:
TRUE: This request can be canceled.
FALSE: This request can not be canceled.

Implements BtRequest.

void BtServiceRequest::SetRequestState ( BtRequestState request_state ) [protected, virtual]

Set processing state of this request.

A request can be seen as it goes through several stages in its execution process. SetRequestState can be used to set the current stage of execution. When the passed in state is other than the current state the OnRequestStateChange callback function will be invoked.

Parameters:
request_state A BtRequestState containing the current stage of exection which has to be set for this request.

Implements BtRequest.

Reimplemented in BtBppReq, BtBppSndAbortReqRequest, and BtBppSndFilePushReqRequest.

Friends And Related Function Documentation

friend class BtController [friend]

Reimplemented from BtRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/BtServiceRequest.hpp
  • Bluetooth/BtServiceRequest.cpp
Generated on Wed Jan 25 01:03:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtServiceVerifyMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtServiceVerifyMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtServiceVerifyMessage:

[legend]
Collaboration diagram for BtServiceVerifyMessage:

[legend]

Public Types

enum | { ID = 10233 }

Public Member Functions

BtServiceVerifyMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtServiceVerifyMessage ()

Detailed Description

BtServiceVerifyMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtServiceVerifyMessage::BtServiceVerifyMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtServiceVerifyMessage::~BtServiceVerifyMessage ( ) [virtual]

Member Function Documentation

Message * BtServiceVerifyMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtServiceVerifyMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:03:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtServiceVerifyRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtServiceVerifyRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtServiceVerifyRequest.hpp>

Inheritance diagram for BtServiceVerifyRequest:

[legend]
Collaboration diagram for BtServiceVerifyRequest:

[legend]

Public Member Functions

BtServiceVerifyRequest (const BtDeviceList &device_list)
Constructor.
const BtAttributeId * | GetAttributesRequested () const
Which attriburtes should be returned.
BtDeviceRelation | GetDeviceRelation () const
Which relation should the verified devices have?
UINT8 | GetNumberOfAttributesRequested () const
How many attributes should be returned.
UINT8 | GetNumberOfServicesToVerify () const
How many service should be verified?
virtual BtRequestType | GetRequestType () const
Get type of this request.
const BtUUID * | GetServicesToVerify () const
Which service should be verified?
const BtServiceVerifyResult * | GetServiceVerifyResult (const BtDeviceAddress &device_address) const
Return the service verify result for a specific device.
BOOLEAN | SetAttributesRequested (const BtAttributeId *attribute_ids, UINT8 number_of_attribute_ids)
Set the attributes that should be returned.
void | SetDeviceRelation (BtDeviceRelation device_relation)
Set the realtion that the verifyed devices must have.
BOOLEAN | SetServicesToVerify (const BtUUID *uuids, UINT8 number_of_uuids)
Set services that should be verified.
virtual | ~BtServiceVerifyRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Cancel ()
Set controller parameters and call stack to cancel operation.
virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | OnServiceVerifyResultReceived (const BtDeviceAddress &device_address, const WString &device_name, const BtServiceVerifyResult *service_verify_result)
Service verify result received message handler member function.
virtual void | RegisterMessages (void) const
Register the required messages for receipt.
virtual void | UnregisterMessages (void) const
Unregister the required messages from receipt.

Friends

class | BtGapAndSdapController

Data Structures

class | BtServiceVerifyResultNode

Detailed Description

During a device discorvery request there were very few informations exchanged between the local device and the found remote devices. To get informations that are more exact the BtServiceVerifyRequest can be used. This kind of request lets the application programmer query one or more devices whether they support one or more particular services. It can also decide that, when a service is supported, certain attributes with their values are queried from this service and returned to the local device.

Constructor & Destructor Documentation

BtServiceVerifyRequest::BtServiceVerifyRequest ( const BtDeviceList & device_list )

Constructor.

BtServiceVerifyRequest::~BtServiceVerifyRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtServiceVerifyRequest::Cancel ( ) [protected, virtual]

Set controller parameters and call stack to cancel operation.

The Cancel member function is responsible for setting the appropriate parameters and perform the call to the controllers function, that cancels an ongoing operation at the Bluetooth Stack. This function is pure virtual because each request is canceled in a different way and this has to be implemented by the concrete Bt...Request class.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

BOOLEAN BtServiceVerifyRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

Execute instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. Execute is one of these functions.Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

const BtAttributeId * BtServiceVerifyRequest::GetAttributesRequested ( ) const

Which attriburtes should be returned.

For every verified service a BtServiceVerifyRequest can query any number up to 255 service attributes and their values. GetAttributesRequested returns these attributes that where queried from every verified serivce.

Returns:
A pointer to an array of BtAttributeId containing the attribute ids of the attributes that should be queried.

BtDeviceRelation BtServiceVerifyRequest::GetDeviceRelation ( ) const

Which relation should the verified devices have?

GetDeviceRelation returns the kind of relation - paired, trusted or connected - the remote devices should have to the local device. All devices in the list of devices to verify that do not match the relation condition where not verfied. A BtDeviceRelation containing the device realtion that the remote devices should have.

UINT8 BtServiceVerifyRequest::GetNumberOfAttributesRequested ( ) const

How many attributes should be returned.

For every verified service a BtServiceVerifyRequest can query any number up to 255 service attributes and their values. GetNumberOfAttributesRequested returns the number of attributes that where queried from every verified serivce.

Returns:
An UINT8 containing the number of service attributes that where queried from every verified service.

UINT8 BtServiceVerifyRequest::GetNumberOfServicesToVerify ( ) const

How many service should be verified?

A BtServiceVerifyRequest can not only verify one single service. It can verify any number of services up to 255. The function GetNumberOfServicesToVerify returns that number of services to verify.

Returns:
An UINT8 containing the number of services that should be verified.

BtRequestType BtServiceVerifyRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

const BtUUID * BtServiceVerifyRequest::GetServicesToVerify ( ) const

Which service should be verified?

A BtServiceVerifyRequest can not only verify one single service. It can verify any number of services up to 255. The function GetServicesToVerify returns these services to verify.

Returns:
A pointer to an array of BtUUID containing the UUIDs of the services that should be verified.

const BtServiceVerifyResult * BtServiceVerifyRequest::GetServiceVerifyResult ( const BtDeviceAddress & device_address ) const

Return the service verify result for a specific device.

A BtServiceVerifyRequest con not only verify one single remote device. It can veriry any number of remote devices. For every remoted device queried there will be one BtServiceVerifyResult. GetServiceVerifyResult returns the service verify result for one partikular remote device identified through the passed in BtDeviceAddress. The returned pointer is valid as long as this request "lives" (exists in memory). param device_address A reference to a BtDeviceAddress containing the address of the remote device for which the servic everify result should be returned.

Returns:
A pointer to a BtServiceVerifyResult containing the service verify result for the passed in device address. If the BtServiceVerifyRequest has no result for the passed in device_address the function will return 0.

BOOLEAN BtServiceVerifyRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtServiceVerifyRequest::OnServiceVerifyResultReceived | ( | const BtDeviceAddress & | device_address,
 |  | const WString & | device_name,
 |  | const BtServiceVerifyResult * | service_verify_result
 | ) | [protected, virtual]

Service verify result received message handler member function.

The OnServiceVerifyResultReceived member function will be invoked when a BtServiceVeriryReceivedMessage is received by this request. This member function is used to enable some reactions to the receipt of the aforsaid message. The implmenetation of this member function is a dummy implementation and does nothing. If the application programmer wants to change this behaviour, he has to overload this function in a derived class. He need not to call the inherited base function, because it does nothing.

Parameters:
device_address | A BtDeviceAddress containing the remote device address for which the service verify result is returned.
service_verify_result | A pointer to a BtServiceVerifyResult containing the result for the device_addressy.

void BtServiceVerifyRequest::RegisterMessages ( void ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtServiceVerifyRequest the following messages are registered: BtServiceVerifyMessage, BtServiceVerifyResultMessage.

Reimplemented from UserDispatcher.

BOOLEAN BtServiceVerifyRequest::SetAttributesRequested | ( | const BtAttributeId * | attribute_ids,
 |  | UINT8 | number_of_attribute_ids
 | ) |

Set the attributes that should be returned.

For every verified service a BtServiceVerifyRequest can query any number up to 255 service attributes and their values. SetAttributesRequested sets these attributes that where queried from every verified serivce.

Parameters:
attribute_ids | A pointer to an array of BtAttributeId containing the attribute ids of the attributes that should be queried.
number_of_attribute_ids | An UINT8 containing the number of service attributes that should be queried from every verified service.
Returns:
TRUE: The attribures to query could be set.
FALSE: The attribures to query could not be set because the memory to copy the attribute ids could not be gained.

void BtServiceVerifyRequest::SetDeviceRelation ( BtDeviceRelation device_relation )

Set the realtion that the verifyed devices must have.

GetDeviceRelation sets the kind of relation - paired, trusted or connected - the remote devices must have to the local device. All devices in the list of devices to verify that do not match the relation condition where not verfied.

Parameters:
device_relation A BtDeviceRelation containing the kind of relation that the remote devices must have.

BOOLEAN BtServiceVerifyRequest::SetServicesToVerify | ( | const BtUUID * | uuids,
 |  | UINT8 | number_of_uuids
 | ) |

Set services that should be verified.

A BtServiceVerifyRequest can not only verify one single service. It can verify any number of services up to 255. The function SetServicesToVerify sets these services to verify.

Parameters:
uuids | A pointer to an array of BtUUID containing the UUIDs of the servies to verify.
number_of_uuids | An UINT8 containing the number of UUIDs stored in the array.
Returns:
TRUE: The services to verify could be set.
FALSE: The services to verify could not be set. Either the number_of_uuids is set to zero or the memory to copy the uuids could not be gained.

void BtServiceVerifyRequest::UnregisterMessages ( void ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtServiceVerifyRequest the following messages are unregistered: BtServiceVerifyMessage, BtServiceVerifyResultMessage.

Reimplemented from UserDispatcher.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtServiceVerifyRequest.hpp
  • Bluetooth/BtServiceVerifyRequest.cpp
Generated on Wed Jan 25 01:03:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtServiceVerifyResult Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtServiceVerifyResult Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtServiceVerifyResult.hpp>

Public Member Functions

UINT16 | GetNumberOfServiceRecords () const
Get number of service records stored in this service verify result.
BOOLEAN | GetServiceRecordAtIndex (UINT16 index, BtSvrServiceRecord &svr_service_record) const
Retrieve a service record from this service verify result.
BOOLEAN | IsValid () const
Get validity of this service verify result.
virtual | ~BtServiceVerifyResult ()
Destructor.

Friends

class | BtOperationSelectDeviceAndPerformServiceVerify
class | BtServiceVerifyRequest

Detailed Description

When the Bluetooth Stack performs a service verify request the result of this request is stored in a memory block. The memory block allocated by the Bluetooth Stack will be copied in the constructor. From this time on it is independent from any other service verify request. So this class stores the size and a pointer to a memory block, for which the class is responsible to free at destruction.
There is no direct access to the memory block and it's size. Instead of this there are functions defined to get access to the single records. These functions do not copy any data. They only store a description of a record in the passed in BtSvrServiceRecord. So the application programmer has to provide the memory for the storage of the description.
The only point of execution, where memory is copied is in the constructor of BtServiceVerifyResult. All other access to the memory stored in BtServiceVerifyResult is done via references (pointers).
This is done so to ease the configuration of the memory pools and to avoid too many constructor calls for values that are not really needed by the application programmer.

Constructor & Destructor Documentation

BtServiceVerifyResult::~BtServiceVerifyResult ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtServiceVerifyResult::GetNumberOfServiceRecords ( ) const

Get number of service records stored in this service verify result.

GetNumberOfServiceRecords returns the number of records contained in this service verify result.

Returns:
An UINT16 containing the number of records that are stored in this service verify result.

BOOLEAN BtServiceVerifyResult::GetServiceRecordAtIndex | ( | UINT16 | index,
 |  | BtSvrServiceRecord & | svr_service_record
 | ) | const

Retrieve a service record from this service verify result.

GetSerivceRecordAtIndex returns the record at the position index of this service verify result. The index is zero based [0 .. numberOfRecords - 1].

Parameters:
index | An UINT16 containing the index of the BtSvrServiceRecord that should be retrieved.
svr_service_record | A reference to a BtSvrServiceRecord where to store the information of the retrieved record.
Returns:
TRUE: The index is valid and a description of the record is stored in svr_service_record.
FALSE: The index is out of bounds. Do not use the content of svr_service_record because it is not valid.

BOOLEAN BtServiceVerifyResult::IsValid ( ) const

Get validity of this service verify result.

IsValid returns the validity state of this service verify result.

Returns:
TRUE: This service verify result is valid. All other member functions return a result that can be used further.
FALSE: This service verify result is invalid. Do not call any further member functions because they allways will return an error.

Friends And Related Function Documentation

friend class BtOperationSelectDeviceAndPerformServiceVerify [friend]

friend class BtServiceVerifyRequest [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtServiceVerifyResult.hpp
  • Bluetooth/BtServiceVerifyResult.cpp
Generated on Wed Jan 25 01:03:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtServiceVerifyResultMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtServiceVerifyResultMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtServiceVerifyResultMessage:

[legend]
Collaboration diagram for BtServiceVerifyResultMessage:

[legend]

Public Types

enum | { ID = 10234 }

Public Member Functions

BtServiceVerifyResultMessage (const BtResultCode &result, UINT32 request_id, const BtDeviceAddress &device_address, const WString &device_name, void *data, UINT16 data_size)
virtual Message * | Clone () const
void * | GetData () const
UINT16 | GetDataSize () const
const BtDeviceAddress & | GetDeviceAddress () const
const WString & | GetDeviceName () const
virtual const MsgMetaData & | GetMetaData () const
void | SetData (void *data)
void | SetDataSize (UINT16 data_size)
void | SetDeviceAddress (const BtDeviceAddress &device_address)
void | SetDeviceName (const WString &device_name)
virtual | ~BtServiceVerifyResultMessage ()

Detailed Description

BtServiceVerifyResultMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtServiceVerifyResultMessage::BtServiceVerifyResultMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const BtDeviceAddress & | device_address,
 |  | const WString & | device_name,
 |  | void * | data,
 |  | UINT16 | data_size
 | ) |

BtServiceVerifyResultMessage::~BtServiceVerifyResultMessage ( ) [virtual]

Member Function Documentation

Message * BtServiceVerifyResultMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

void* BtServiceVerifyResultMessage::GetData ( ) const [inline]

UINT16 BtServiceVerifyResultMessage::GetDataSize ( ) const [inline]

const BtDeviceAddress& BtServiceVerifyResultMessage::GetDeviceAddress ( ) const [inline]

const WString& BtServiceVerifyResultMessage::GetDeviceName ( ) const [inline]

const MsgMetaData & BtServiceVerifyResultMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

void BtServiceVerifyResultMessage::SetData ( void * data ) [inline]

void BtServiceVerifyResultMessage::SetDataSize ( UINT16 data_size ) [inline]

void BtServiceVerifyResultMessage::SetDeviceAddress ( const BtDeviceAddress & device_address ) [inline]

void BtServiceVerifyResultMessage::SetDeviceName ( const WString & device_name ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:03:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSetRemoteDeviceNameMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSetRemoteDeviceNameMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtSetRemoteDeviceNameMessage:

[legend]
Collaboration diagram for BtSetRemoteDeviceNameMessage:

[legend]

Public Types

enum | { ID = 10224 }

Public Member Functions

BtSetRemoteDeviceNameMessage (const BtResultCode &result, UINT32 request_id)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~BtSetRemoteDeviceNameMessage ()

Detailed Description

BtSetRemoteDeviceNameMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtSetRemoteDeviceNameMessage::BtSetRemoteDeviceNameMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id
 | ) |

BtSetRemoteDeviceNameMessage::~BtSetRemoteDeviceNameMessage ( ) [virtual]

Member Function Documentation

Message * BtSetRemoteDeviceNameMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtSetRemoteDeviceNameMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:03:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSetRemoteDeviceNameRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSetRemoteDeviceNameRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSetRemoteDeviceNameRequest.hpp>

Inheritance diagram for BtSetRemoteDeviceNameRequest:

[legend]
Collaboration diagram for BtSetRemoteDeviceNameRequest:

[legend]

Public Member Functions

BtSetRemoteDeviceNameRequest (const BtDevice &device)
Constructor.
const WString & | GetRemoteDeviceName () const
Gets the remote device name that should be set.
virtual BtRequestType | GetRequestType () const
Get type of this request.
void | SetRemoteDeviceName (const WString &remoted_device_name)
Set the name that the remote device should be assigned to.
virtual | ~BtSetRemoteDeviceNameRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Execute ()
Sumbit this request to the Bluetooth Stack.
virtual BOOLEAN | OnMessage (const Message &message)
Message dispatching member function.
virtual void | RegisterMessages () const
Register the required messages for receipt.
virtual void | UnregisterMessages () const
Unregister the required messages from receipt.

Friends

class | BtGapAndSdapController

Detailed Description

When Bluetooth detects some remote devices during an inquiry these found devices where stored in the Bluetooth stack. Additionally to the Bluetooth device address a name is stored. This name is a local name for the remote Bluetooth device. This means that the local device knows the address of the remote device under the name stored in the list. Because Bluetooth remote device names are not recomended unique it is possible to have two remote devices with the same name stored in the Bluetooth stack.
Most times the name of the remote device stored in the Bluetooth stack is used to present it to the use as an human readable represenation of the associated Bluetooth remote device address. So it is not goot to have two equal names in the list. BtSetRemoteDeviceNameRequest implements the possiblity to change the name for the remote device stored in the Bluetooth stack. Attention: This does not change the name of the device address at the remote device. Only the local stored name for the address is changed.

Constructor & Destructor Documentation

BtSetRemoteDeviceNameRequest::BtSetRemoteDeviceNameRequest ( const BtDevice & device )

Constructor.

BtSetRemoteDeviceNameRequest::~BtSetRemoteDeviceNameRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtSetRemoteDeviceNameRequest::Execute ( ) [protected, virtual]

Sumbit this request to the Bluetooth Stack.

ExecuteRequest instructs this request to send itself to the Bluetooth Stack for execution purposes.
In the base class of all Bluetooth Requests - BtRequest - there is an interface defined, that all requests must fullfill respectively implement. Some functions in this interface are declared pure virtual because they can not be implemented in the base classes. ExecuteRequest is one of these functions. Because the execution of various requests differ very strong, the implmentation of this function is done by the various concrete request classes.

Returns:
TRUE: The setup of the stack parameters was successfull and the Bluetooth stack accepted the requested operation.
FALSE: Either the setup of the stack parameters failed or the Bluetooth stack rejected the requested operation.

Implements BtRequest.

const WString & BtSetRemoteDeviceNameRequest::GetRemoteDeviceName ( ) const

Gets the remote device name that should be set.

GetRemoteDeviceName queries the name that should be set for the remote device addresse by this request.

Returns:
A reference to a WString containing the name for the remote device that has to be set on the execution of this request.

BtRequestType BtSetRemoteDeviceNameRequest::GetRequestType ( ) const [virtual]

Get type of this request.

The runtime type information feature is not supported by all compilers which this framework is used with. So a rudimentary type information system is implemnted by this class. Each type of request that has no subtypes (leaf class) must return an unique type identifier. GetRuestType return this type idenifier which is implemented as an enumeration type.

Returns:
A BtRequestType containing the type that describes this request.

Implements BtRequest.

BOOLEAN BtSetRemoteDeviceNameRequest::OnMessage ( const Message & message ) [protected, virtual]

Message dispatching member function.

The OnMessage member function is the first entry point in every dispatcher for the reception of messages. From there on it will be routed to the appropriate On... member function, if it should be handled by this dispatcher or passed back to the superior dispatcher.

Returns:
TRUE: The received message has be handle. No further handling for the message is needed.
FALSE: The received message is not handled by this dispatcher. Route it forward to the next dispatcher.

Implements BtLocalRequest.

void BtSetRemoteDeviceNameRequest::RegisterMessages ( ) const [protected, virtual]

Register the required messages for receipt.

After registering itself at an application, the request has to tell the message dispatching mechanism which messages this request is intersted in. RegisterMessage performs this task. For the BtSetRemoteDeviceNameRequest the following message is registered: BtSetRemoteDeviceNameMessage

Reimplemented from UserDispatcher.

void BtSetRemoteDeviceNameRequest::SetRemoteDeviceName ( const WString & remoted_device_name )

Set the name that the remote device should be assigned to.

SetRemoteDeviceName is used to set the name to which the remote device should be assigned when the request is executed.

Parameters:
remoted_device_name A reference to a WString containing the name, that the remote device should be assigned to.

void BtSetRemoteDeviceNameRequest::UnregisterMessages ( ) const [protected, virtual]

Unregister the required messages from receipt.

Before unregistering itself from the application, the request has to remove the messages, it is interested in form the message dispatching mechanism. UnregisterMessage performs this task. For the BtSetRemoteDeviceNameRequest the following message is unregistered: BtSetRemoteDeviceNameMessage

Reimplemented from UserDispatcher.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSetRemoteDeviceNameRequest.hpp
  • Bluetooth/BtSetRemoteDeviceNameRequest.cpp
Generated on Wed Jan 25 01:03:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSingleConnectionController Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSingleConnectionController Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSingleConnectionController.hpp>

Inheritance diagram for BtSingleConnectionController:

[legend]
Collaboration diagram for BtSingleConnectionController:

[legend]

Public Member Functions

BtSingleConnectionController ()
Constructor.
virtual | ~BtSingleConnectionController ()
Destructor.

Protected Member Functions

BtServiceRequest * | CleanUpRequestExecution (BtResultCode result_code, BtRequestType request_type)
Finalize the execution of an currently executing request.
void | ClearConnectedDevice ()
Clear the connected device.
BOOLEAN | ConnectRequest (BtConnectRequest *connect_request)
Set up a Service between two devices.
BOOLEAN | DisconnectRequest (BtDisconnectRequest *disconnect_request)
Close a Service between two devices.
const BtDevice & | GetConnectedDevice () const
BtServiceRequest * | GetExecutingRequest () const
Return currently executing request.
virtual BOOLEAN | IsDeviceConnected (const BtDevice &device) const
Is the passed in device connected to this profile or not?
BOOLEAN | PrepareRequestExecution (BtServiceRequest *request)
Perpare the execution of a submitted request.
BOOLEAN | SetConnectedDevice (const BtDevice &connected_device)
Set the connected device.

Detailed Description

Some Bluetooth Profiles permit only one remote device connection to itself. BtSingleConnectionController is the controller base class for such kind of profiles. BtSingleConnectionController implements

Constructor & Destructor Documentation

BtSingleConnectionController::BtSingleConnectionController ( )

Constructor.

BtSingleConnectionController::~BtSingleConnectionController ( ) [virtual]

Destructor.

Member Function Documentation

BtServiceRequest * BtSingleConnectionController::CleanUpRequestExecution | ( | BtResultCode | result_code,
 |  | BtRequestType | request_type
 | ) | [protected]

Finalize the execution of an currently executing request.

When a request is submitted to the Bluetooth stack for execution, the Bluetooth stack function can return FALSE, if the request is rejected by the Bluetooth stack, or the appropriate callback function is called to report the state of the ongoing request. In all of these cases CleanUpRequestExecution should be called.
CleanUpRequestExecution determines on the passed in parameters whether the member variable m_executing_request should be cleared or not. When CleanUpRequestExecution resets m_executing_request to 0, the id of the cleared request is returned.

Parameters:
result_code | A BtResultCode containing the result of the execution of the currently ongoing request.
request_type | A BtRequestType containing the kind of request for which the result code is passed in.
Returns:
((UINT32)(-1)) | Depending on result_code and request_type the function decided not to resest m_executing_request to 0.
Any other UINT32 | m_executing_request is set to 0 and the id of the finalized request is returned.

void BtSingleConnectionController::ClearConnectedDevice ( ) [protected]

Clear the connected device.

If a device is connected to the profile this controller is representing, the connected device is stored in the member variable m_connected_device. This function is used to clear to the m_connected_device member variable.

BOOLEAN BtSingleConnectionController::ConnectRequest ( BtConnectRequest * connect_request ) [protected]

Set up a Service between two devices.

OpenServiceRequest instructs the Bluetooth stack to perform a Service set up based on the settings passed in.

Parameters:
connect_settings.A reference to a btapi_connect_t containing the settings for the Service to be set up.
Returns:
TRUE | The passed in paramaters are correct and the request is submitted to the Bluetooth stack.
FALSE | The passed in paramters are incorrect and the request is not submitted to the Bluetooth stack.

BOOLEAN BtSingleConnectionController::DisconnectRequest ( BtDisconnectRequest * disconnect_request ) [protected]

Close a Service between two devices.

CloseServiceRequest instructs the Blluetooth stack to perform a close Service based on the settings passed in.

Parameters:
disconnect_settings.A reference to a btapi_disconnect_t containing the settings for Service to be closed.
Returns:
TRUE | The passed in paramaters are correct and the request is submitted to the Bluetooth stack.
FALSE | The passed in paramters are incorrect and the request is not submitted to the Bluetooth stack.

const BtDevice & BtSingleConnectionController::GetConnectedDevice ( ) const [protected]

BtServiceRequest * BtSingleConnectionController::GetExecutingRequest ( ) const [protected]

Return currently executing request.

The execution of requests within the controller is limited to one request at a time. A pointer to the currently running request is stored in the member variable m_executing_request. This member variable is used to save informations about the request during its execution in the Bluetooth stack and to enable the assignment between the callback function calls and the request.

Returns:
A pointer to a BtRequest containing the currently running request or 0, if no reqeust is currently running.

BOOLEAN BtSingleConnectionController::IsDeviceConnected ( const BtDevice & device ) const [protected, virtual]

Is the passed in device connected to this profile or not?

IsDeviceConnected is used by the BtService class to determine whether it's target is connected to it's profile or not.

Parameters:
device A reference to a BtDevice containing the remoted device that should be tested whether it is connected to this profile or not.
Returns:
TRUE | The passed in device is correct to this profile.
FALSE | The passed in device is not correct to this profile.

Implements BtConnectionBasedController.

BOOLEAN BtSingleConnectionController::PrepareRequestExecution ( BtServiceRequest * request ) [protected]

Perpare the execution of a submitted request.

When a request is submitted to the controller for execution PrepareRequestExecution checks if an other request is currently running. If so the function returns FALSE, otherwise the member variable m_executing_request is set to point to the passed in request and TRUE is returned.

Parameters:
request A pointer to a BtRequest, that should be exectuted.
Returns:
TRUE | The passed in request can be executed.
FALSE | There is an other request currently running, so the passed in request can not be executed.

BOOLEAN BtSingleConnectionController::SetConnectedDevice ( const BtDevice & connected_device ) [protected]

Set the connected device.

If a device is connected to the profile this controller is representing, the connected device is stored in the member variable m_connected_device. This function is used to set to the m_connected_device member variable.

Parameters:
connected_device A reference to a BtDevice containing the device to which the member variable m_connected_device has to be set to,
Returns:
TRUE | The member variable m_connected_devicey is set correctly.
FALSE | There is another device connected to this controller (profile) and must be disconnected prior setting the new connected device.

The documentation for this class was generated from the following files:
  • Bluetooth/BtSingleConnectionController.hpp
  • Bluetooth/BtSingleConnectionController.cpp
Generated on Wed Jan 25 01:03:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtStateChangedMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtStateChangedMessage Class Reference

#include <Apoxi/Bluetooth/BtGapAndSdapRequestMessage.hpp>

Inheritance diagram for BtStateChangedMessage:

[legend]
Collaboration diagram for BtStateChangedMessage:

[legend]

Public Types

enum | { ID = 10211 }

Public Member Functions

BtStateChangedMessage (const BtResultCode &result, UINT32 request_id, const BtStackState &stack_state)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const BtStackState & | GetStackState () const
void | SetStackState (const BtStackState &stack_state)
virtual | ~BtStateChangedMessage ()

Detailed Description

BtStateChangedMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

BtStateChangedMessage::BtStateChangedMessage | ( | const BtResultCode & | result,
 |  | UINT32 | request_id,
 |  | const BtStackState & | stack_state
 | ) |

BtStateChangedMessage::~BtStateChangedMessage ( ) [virtual]

Member Function Documentation

Message * BtStateChangedMessage::Clone ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const MsgMetaData & BtStateChangedMessage::GetMetaData ( ) const [virtual]

Reimplemented from BtGapAndSdapRequestMessage.

const BtStackState& BtStateChangedMessage::GetStackState ( ) const [inline]

void BtStateChangedMessage::SetStackState ( const BtStackState & stack_state ) [inline]

The documentation for this class was generated from the following files:
  • Bluetooth/BtGapAndSdapRequestMessage.hpp
  • Bluetooth/BtGapAndSdapRequestMessage.cpp
Generated on Wed Jan 25 01:03:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSvrDataElement Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSvrDataElement Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSvrDataElement.hpp>

Public Member Functions

BOOLEAN | AsBoolean () const
INT32 | AsSigned () const
String | AsString () const
UINT32 | AsUnsigned () const
BtUUID | AsUuid () const
WString | AsWString () const
BtSvrDataElement ()
Default - Constructor.
BOOLEAN | GetDataElementAtIndex (UINT16 index, BtSvrDataElement &svr_data_element) const
Retrieve a sub data element from this data element.
UINT16 | GetNumberOfDataElements () const
Get number of sub data elements.
BtDataElementType | GetType () const
Get the type of this data element.
const void * | GetValuePointer () const
Get a pointer to the concrete value data.
INT32 | GetValueSize () const
Get the size of the concrete value data.
BOOLEAN | IsValid () const
Get validity of this data element.
virtual | ~BtSvrDataElement ()
Destructor.

Friends

class | BtSvrServiceAttribute
BOOLEAN | operator!= (const BtSvrDataElement &left_value, const BtSvrDataElement &right_value)
BOOLEAN | operator== (const BtSvrDataElement &left_value, const BtSvrDataElement &right_value)

Detailed Description

The result of a service verify request executed by the Bluetooth Stack is an object of the class BtServiceVerifyResult. This class is a collection of zero or more service records. The interface to these service records is built by the class BtSvrServiceRecord.A service record can be seen as a collection of zero or more service attributes. Service attributes are realized in the class BtSvrServiceAttribute. The interface of this class enables the access to the properties of a service attribute like its identifier or its value. The value of such a service attribute is represented by a data element.
A data elements is a description of a concrete value. The type of value a data element contains is descriped by the BtDataElementType that is an enumeration type. As data types in real programming languages data elements can be devided into two kinds of data: atomic and compound data types. Atomic data elements contain one value and the type specifies how to interpret the data pointer.Compound data elements consist themselfs of a sequence of data elements. These data elements can be atomic or compound data elements again. So it is possible to build up recursive structurse of data values.
One particular data element is represented by a BtSvrDataElement object that contains the description of that data element. In this context the expression "description" stands for the size of the data element and a pointer into the memory block of the corresponding BtServieVerifyResult, where this data element starts.
There is no direct access to the memory block and its size. Instead of this there are functions defined to get access to either the data element value and its size (to interpret the returned data pointer correctly) or to the sub data elements of this data element.
The functions for retrieving sub data elements do not copy any data. They only store a description of the sub data element in the passed in BtSvrDataElement. So the application programmer has to provide the memory for the storage of the sub data element.

Constructor & Destructor Documentation

BtSvrDataElement::BtSvrDataElement ( )

Default - Constructor.

BtSvrDataElement::~BtSvrDataElement ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtSvrDataElement::AsBoolean ( ) const

long BtSvrDataElement::AsSigned ( ) const

String BtSvrDataElement::AsString ( ) const

unsigned long BtSvrDataElement::AsUnsigned ( ) const

BtUUID BtSvrDataElement::AsUuid ( ) const

WString BtSvrDataElement::AsWString ( ) const

BOOLEAN BtSvrDataElement::GetDataElementAtIndex | ( | UINT16 | index,
 |  | BtSvrDataElement & | svr_data_element
 | ) | const

Retrieve a sub data element from this data element.

GetDataElementAtIndex returns the sub data element at the position index of this data element. The index is zero based [0..numberOfDataElements - 1].

Parameters:
index | An UINT16 containing the index of the BtSvrDataElement that should be retrieved.
svr_data_element | A reference to a BtSvrDataElement where to store the information of the retrieved data element.
Returns:
TRUE: The index is valid and a description of the data element is stored in svr_data_element.
FALSE: The index is out of bounds. Do not use the content of svr_data_element because it is not valid.

UINT16 BtSvrDataElement::GetNumberOfDataElements ( ) const

Get number of sub data elements.

GetNumberOfDataElements returns the number of sub data elements contained in this data element.

Returns:
An UINT16 containing the number of sub data elements that are stored in this data element.

BtDataElementType BtSvrDataElement::GetType ( ) const

Get the type of this data element.

GetType returns the type of the data element as an enumeration type. In conjunction with the size the C/C++ cast can be determined to interpret the value pointer properly.

Returns:
A BtDataElementType that is an enumeration type describing the type of date element.

const void * BtSvrDataElement::GetValuePointer ( ) const

Get a pointer to the concrete value data.

GetValuePointer returns a pointer to the beginning of a memory block containing the value data for this data element. To get full access to the value the returned pointer must be casted to the apropriate C/C++ type or structure.

Returns:
A pointer to void containing the start address of the concrete value data.

INT32 BtSvrDataElement::GetValueSize ( ) const

Get the size of the concrete value data.

GetValueSize returns the size of the value data stored in this data element. In conjunction with the type the C/C++ cast can be determined to interpret the value pointer properly.

Returns:
An UINT32 describing the size of the data element value of this data element.

BOOLEAN BtSvrDataElement::IsValid ( ) const

Get validity of this data element.

IsValid returns the validity state of this data element.

Returns:
TRUE: This data element is valid. All other member functions return a result that can be used further.
FALSE: This data element is invalid. Do not call any further member functions because they allways will return an error.

Friends And Related Function Documentation

friend class BtSvrServiceAttribute [friend]

BOOLEAN operator!= | ( | const BtSvrDataElement & | left_value,
 |  | const BtSvrDataElement & | right_value
 | ) | [friend]

BOOLEAN operator== | ( | const BtSvrDataElement & | left_value,
 |  | const BtSvrDataElement & | right_value
 | ) | [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSvrDataElement.hpp
  • Bluetooth/BtSvrDataElement.cpp
Generated on Wed Jan 25 01:03:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSvrServiceAttribute Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSvrServiceAttribute Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSvrServiceAttribute.hpp>

Public Member Functions

BtSvrServiceAttribute ()
Default - Constructor.
UINT16 | GetAttributeId () const
Retrieve the identifier of this service attribute.
BOOLEAN | GetAttributeValue (BtSvrDataElement &svr_data_element) const
Retrieve the value of this service attribute.
BOOLEAN | IsValid () const
Get validity of this service attribute.
virtual | ~BtSvrServiceAttribute ()
Destructor.

Friends

class | BtSvrServiceRecord

Detailed Description

The result of a service verify request executed by the Bluetooth Stack is an object of the class BtServiceVerifyResult. This class is a collection of zero or more service records. The interface to these service records is built by the class BtSvrServiceRecord. A service record can be seen as a collection of zero or more service attributes.
One particular service attribute is represented by a BtServiceAttribute object that contains the description of that service attribute. In this context the expression "description" stands for the size of the service attribute and a pointer into the memory block of the corresponding BtServiceVerifyResult, where this serivce attribute starts.
There is no direct access to the memory block and its size. Instead of this there are functions defined to get access to the single properties like the unique identifier of this service attribute or the data element representing the value of this service attribute. These functions do not copy any data. They only store a descirption of the value in the passed in BtSvrDataElement. So the application programmer has to provide the memory for the storage of the data element.

Constructor & Destructor Documentation

BtSvrServiceAttribute::BtSvrServiceAttribute ( )

Default - Constructor.

BtSvrServiceAttribute::~BtSvrServiceAttribute ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtSvrServiceAttribute::GetAttributeId ( ) const

Retrieve the identifier of this service attribute.

GetAttributeId returns the identifier of this service attribute. Each service attribute within a service record has an unique identifier.

Returns:
An UINT16 containing the unique identifier of thisBtSvrServiceAttribute. If this service attribute is not valid the constant UINT_MAX (0xFFFF) is returned

BOOLEAN BtSvrServiceAttribute::GetAttributeValue ( BtSvrDataElement & svr_data_element ) const

Retrieve the value of this service attribute.

GetAttributeValue returns the data element of this service attribute representing its value.

Parameters:
svr_data_element A reference to a BtSvrDataElement where to store the information of the retrieved attribute value.
Returns:
TRUE: The description of the value of this service attribute is stored in svr_data_element.
FALSE: An error occured. Do not use the content of svr_data_element because it is not valid.

BOOLEAN BtSvrServiceAttribute::IsValid ( ) const

Get validity of this service attribute.

IsValid returns the validity state of this service attribute.

Returns:
TRUE: This service attribute is valid. All other member functions return a result that can be used further.
FALSE: This service attribute is invalid. Do not call any further member functions because they allways will return an error.

Friends And Related Function Documentation

friend class BtSvrServiceRecord [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSvrServiceAttribute.hpp
  • Bluetooth/BtSvrServiceAttribute.cpp
Generated on Wed Jan 25 01:03:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtSvrServiceRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtSvrServiceRecord Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtSvrServiceRecord.hpp>

Public Member Functions

BtSvrServiceRecord ()
Default - Constructor.
UINT16 | GetNumberOfServiceAttributes () const
Get number of service attributes stored in this service record.
BOOLEAN | GetServiceAttributeAtIndex (UINT16 index, BtSvrServiceAttribute &svr_service_attribute) const
Retrieve a service attribute from this service record.
BOOLEAN | GetServiceAttributeById (UINT16 id, BtSvrServiceAttribute &svr_service_attribute) const
Retrieve a service attribute from this service record.
BOOLEAN | IsValid () const
Get validity of this service record.
virtual | ~BtSvrServiceRecord ()
Destructor.

Friends

class | BtServiceVerifyResult

Detailed Description

The result of a service verify request executed by the Bluetooth Stack is an object of the class BtServiceVerifyResult. This class is a collection of zero or more service records.
One particular service record is represented by a BtSvrServiceRecord object that contains the description of that service record. In this context the expression "description" stands for the size of the service record and a pointer into the memory block of the corresponding BtServiceVerifyResult, where this service record starts.
There is no direct access to the memory block and it's size. Instead of this there are functions defined to get access to the single attributes like retrieving them via an index or an unique identifier. These functions do not copy any data. They only store a desciption of an attribute in the passed in BtSvrServiceAttribute. So the application programmer has to provide the memory for the storage of the description.

Constructor & Destructor Documentation

BtSvrServiceRecord::BtSvrServiceRecord ( )

Default - Constructor.

BtSvrServiceRecord::~BtSvrServiceRecord ( ) [virtual]

Destructor.

Member Function Documentation

UINT16 BtSvrServiceRecord::GetNumberOfServiceAttributes ( ) const

Get number of service attributes stored in this service record.

GetNumberOfServiceAttributes returns the number of attributes contained in this service record.

Returns:
An UINT16 containing the number of attributes that are stored in this service record.

BOOLEAN BtSvrServiceRecord::GetServiceAttributeAtIndex | ( | UINT16 | index,
 |  | BtSvrServiceAttribute & | svr_service_attribute
 | ) | const

Retrieve a service attribute from this service record.

GetServiceAttributeAtIndex returns the attribute at the position index of this service record. The index is zero based [0 .. numberOfAttributes - 1].

Parameters:
index | An UINT16 containing the index of the BtSvrServicAttribute that should be retrieved.
svr_service_attribute | A reference to a BtSvrServicAttribute where to store the information of the retrieved attribute.
Returns:
TRUE: The index is valid and a description of the attribute is stored in svr_service_attribute.
FALSE: The index is out of bounds. Do not use the content of svr_service_attribute because it is not valid.

BOOLEAN BtSvrServiceRecord::GetServiceAttributeById | ( | UINT16 | id,
 |  | BtSvrServiceAttribute & | svr_service_attribute
 | ) | const

Retrieve a service attribute from this service record.

GetServiceAttributeAtIndex returns the attribute with the identifier id of this service record.

Parameters:
id | An UINT16 containing the identifier of the BtSvrServicAttribute that should be retrieved.
svr_service_attribute | A reference to a BtSvrServicAttribute where to store the information of the retrieved attribute.
Returns:
TRUE: The identifier is valid and a description of the attribute is stored in svr_service_attribute.
FALSE: The identifier can not be found. Do not use the content of svr_service_attribute because it is not valid.

BOOLEAN BtSvrServiceRecord::IsValid ( ) const

Get validity of this service record.

IsValid returns the validity state of this service record.

Returns:
TRUE: This service record is valid. All other member functions return a result that can be used further.
FALSE: This service record is invalid. Do not call any further member functions because they allways will return an error.

Friends And Related Function Documentation

friend class BtServiceVerifyResult [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtSvrServiceRecord.hpp
  • Bluetooth/BtSvrServiceRecord.cpp
Generated on Wed Jan 25 01:03:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtTransport Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtTransport.hpp>

Inheritance diagram for BtTransport:

[legend]
Collaboration diagram for BtTransport:

[legend]

Public Member Functions

virtual void | Enable ()
Request enabling of the transport (asynchronously).
virtual AvState | GetAvState () const
Query remote device name.
virtual | ~BtTransport ()
Destructor.

Static Public Member Functions

static BtTransport & | GetInstance ()
Get singleton instance.

Friends

class | BtGapAndSdapController

Constructor & Destructor Documentation

BtTransport::~BtTransport ( ) [virtual]

Destructor.

Member Function Documentation

void BtTransport::Enable ( ) [virtual]

Request enabling of the transport (asynchronously).

This method attempts to enable the transport, posibly involving conflict management intervention or MMI activity. Therefore, every implementation is expected to deliver the result asynchronously by calling OnAvStateChanged().

Implements AbstractTransport.

AbstractTransport::AvState BtTransport::GetAvState ( ) const [virtual]

Query remote device name.

Implements AbstractTransport.

BtTransport & BtTransport::GetInstance ( ) [static]

Get singleton instance.

BtGapAndSdapController is implemented as a singleton, so GetInstance() returns a refernce to the singleton object of BtGapAndSdapController.

Returns:
Reference to a BtGapAndSdapController containing the singleton instance object.

Friends And Related Function Documentation

friend class BtGapAndSdapController [friend]

The documentation for this class was generated from the following files:
  • Bluetooth/BtTransport.hpp
  • Bluetooth/BtTransport.cpp
Generated on Wed Jan 25 01:03:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtTurnOnOffWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtTurnOnOffWindow Class Reference

#include <Applications/BtApp/BtLocalSettingsWindows.hpp>

Collaboration diagram for BtTurnOnOffWindow:

[legend]

Public Member Functions

BtTurnOnOffWindow ()
void | Init (BtLocalSettings *local_settings)
virtual | ~BtTurnOnOffWindow ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

BtTurnOnOffWindow::BtTurnOnOffWindow ( )

BtTurnOnOffWindow::~BtTurnOnOffWindow ( ) [virtual]

Member Function Documentation

void BtTurnOnOffWindow::Init ( BtLocalSettings * local_settings )

BOOLEAN BtTurnOnOffWindow::OnConfirm ( ) [protected, virtual]

void BtTurnOnOffWindow::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/BtApp/BtLocalSettingsWindows.hpp
  • Applications/BtApp/BtLocalSettingsWindows.cpp
Generated on Wed Jan 25 01:03:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtUncancelablePointToPointRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtUncancelablePointToPointRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtUncancelablePointToPointRequest.hpp>

Inheritance diagram for BtUncancelablePointToPointRequest:

[legend]
Collaboration diagram for BtUncancelablePointToPointRequest:

[legend]

Public Member Functions

BtUncancelablePointToPointRequest (const BtDevice &device)
Constructor.
const BtDevice & | GetDevice () const
Get target of this request.
BtDevice & GetDevice ()
Get target of this request.
void | SetDevice (const BtDevice &device)
Set target of this request.
virtual | ~BtUncancelablePointToPointRequest ()
Destructor.

Detailed Description

BtUncancelablePointToPointRequest is a child class of BtUncancelableRequest and implements the common properties for request that can realize a point to point communication and that can not be canceled. Any further concrete requests that address one single device and that can not be canceled are not directly derived from BtRequest. Instead of this they should be child classes of BtUncancelablePointToPointRequestRequest.
See BtRequest for a complete description of Bluetooth requests.

Constructor & Destructor Documentation

BtUncancelablePointToPointRequest::BtUncancelablePointToPointRequest ( const BtDevice & device )

Constructor.

BtUncancelablePointToPointRequest::~BtUncancelablePointToPointRequest ( ) [virtual]

Destructor.

Member Function Documentation

const BtDevice & BtUncancelablePointToPointRequest::GetDevice ( ) const

Get target of this request.

GetDevice returns the target this request is associated with.

Returns:
A reference to a BtDevice representing the target of this request.

BtDevice & BtUncancelablePointToPointRequest::GetDevice ( )

Get target of this request.

GetDevice returns the target this request is associated with.

Returns:
A reference to a BtDevice representing the target of this request.

void BtUncancelablePointToPointRequest::SetDevice ( const BtDevice & device )

Set target of this request.

SetDevice sets the target this request should be associated with. This request copies the passed in device to avoid dangling pointers when the request lives and the associated device description is destroyed.

Parameters:
device A reference to a BtDevice that should be the target this request should be associated with.

The documentation for this class was generated from the following files:
  • Bluetooth/BtUncancelablePointToPointRequest.hpp
  • Bluetooth/BtUncancelablePointToPointRequest.cpp
Generated on Wed Jan 25 01:03:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtUncancelableRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtUncancelableRequest Class Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtUncancelableRequest.hpp>

Inheritance diagram for BtUncancelableRequest:

[legend]
Collaboration diagram for BtUncancelableRequest:

[legend]

Public Member Functions

BtUncancelableRequest ()
Constructor.
virtual BOOLEAN | IsCancelable () const
Can execution of this request be stopped.
virtual | ~BtUncancelableRequest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | Cancel ()
Stop the exection of this request.

Detailed Description

BtUncancelableRequest is a child class of BtRequest and implements the common properties for request that can not be interrupted. Any further concrete requests that can not be canceled are not directly derived from BtRequest. Instead of this they should be child classes of BtUncancelableRequest.
See BtRequest for a complete description of Bluetooth requests.

Constructor & Destructor Documentation

BtUncancelableRequest::BtUncancelableRequest ( )

Constructor.

BtUncancelableRequest::~BtUncancelableRequest ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN BtUncancelableRequest::Cancel ( ) [protected, virtual]

Stop the exection of this request.

CancelRequest is used to stop this ongoing request. Requests derived from BtUncancelableRequest are generally not cancelable, so CancelRequest can be implemented here as a dummy function. This function does not cancel the ongoing request. It only returns FALSE to indicate a failure in the call to cancel an uncancelable operation.

Returns:
A BtRequestState containing the current state of exectuion for this request.

Implements BtRequest.

BOOLEAN BtUncancelableRequest::IsCancelable ( ) const [virtual]

Can execution of this request be stopped.

So kinds of requests have a very long duration. Most of these requests can be interrupted. Other request once submitted can not be stopped. So IsCancelable returns whether a request can be canceled or not. This function is pure virtual in BtRequest because it depends on the kind of request if it is cancelable. BtUncancelableRequest is the base class for all requests that can not be interrupted. So IsCancelable can be implemented here to return allways FALSE.

Returns:
FALSE: This request can not be canceled.

Implements BtRequest.

The documentation for this class was generated from the following files:
  • Bluetooth/BtUncancelableRequest.hpp
  • Bluetooth/BtUncancelableRequest.cpp
Generated on Wed Jan 25 01:03:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtUUID Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BtUUID Struct Reference
[Bluetooth]

#include <Apoxi/Bluetooth/BtTypes.hpp>

Data Fields

BtUuidType type
Type of UUID.
UINT8 uuid [16]
Value of UUID.

Field Documentation

BtUuidType BtUUID::type

Type of UUID.

UINT8 BtUUID::uuid[16]

Value of UUID.

The documentation for this struct was generated from the following file:
  • Bluetooth/BtTypes.hpp
Generated on Wed Jan 25 01:03:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BubbleSortProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BubbleSortProvider Class Reference

#include <Apoxi/Auxiliary/BubbleSortProvider.hpp>

Inheritance diagram for BubbleSortProvider:

[legend]
Collaboration diagram for BubbleSortProvider:

[legend]

Public Types

typedef SortProvider | Base

Public Member Functions

BubbleSortProvider (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
BubbleSortProvider ()
void | Init (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
The same interface as the constructor.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and executes the sort process.
virtual | ~BubbleSortProvider ()
Destructor.

Detailed Description

A BubbleSortProvider is used to sort rows of a child provider with the bubble sort algorithm.

Member Typedef Documentation

typedef SortProvider BubbleSortProvider::Base

Reimplemented from SortProvider.

Constructor & Destructor Documentation

BubbleSortProvider::BubbleSortProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

BubbleSortProvider::BubbleSortProvider | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be sorted. columnid: Specify which columnid has to be sorted. order: Specify whether ascending (TRUE) or descending (FALSE).

BubbleSortProvider::~BubbleSortProvider ( ) [virtual]

Destructor.

Member Function Documentation

void BubbleSortProvider::Init | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

The same interface as the constructor.

Reimplemented from SortProvider.

BOOLEAN BubbleSortProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and executes the sort process.

Implements SortProvider.

The documentation for this class was generated from the following files:
  • Auxiliary/BubbleSortProvider.hpp
  • Auxiliary/BubbleSortProvider.cpp
Generated on Wed Jan 25 01:03:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BufferedData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BufferedData Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/BufferedData.hpp>

Inheritance diagram for BufferedData:

[legend]
Collaboration diagram for BufferedData:

[legend]

Public Member Functions

virtual BinData * | Clone () const
virtual void | ReleaseInstance ()

Static Public Member Functions

static BufferedData * | CreateInstance (UINT8 HUGE *buffer, UINT32 length, DrmLocalId id=c_drm_invalid_local_id)

Protected Member Functions

BufferedData (void HUGE *buffer, UINT32 length, DrmLocalId id=c_drm_invalid_local_id)
virtual | ~BufferedData ()

Detailed Description

Extends the class RamData to provide an internal copy of the buffer passed by BufferedData::CreateInstance. The internal buffer is allocated in BufferedData::CreateInstance and destroyed in BufferedData::ReleaseInstance. Hence when using the class BufferedData the application-programmer may delete its buffer immediatly after invoking BufferedData::CreateInstance because the buffer is copied to the internal buffer.

Constructor & Destructor Documentation

BufferedData::BufferedData | ( | void HUGE * | buffer,
 |  | UINT32 | length,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) | [protected]

BufferedData::~BufferedData ( ) [protected, virtual]

Destroys the internal buffer for the case, that ReleaseInstance has not been invoked.

Member Function Documentation

BinData * BufferedData::Clone ( ) const [virtual]

See also:
BinData::Clone

Reimplemented from RamData.

BufferedData * BufferedData::CreateInstance | ( | UINT8 HUGE * | buffer,
 |  | UINT32 | length,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) | [static]

Creates and returns an object of this class. The content of buffer is copied to an internal buffer. The internal buffer is destroyed when invoking ReleaseInstance().

void BufferedData::ReleaseInstance ( ) [virtual]

Destroys the internal buffer.

See also:
BinData::ReleaseInstance

Reimplemented from BinData.

The documentation for this class was generated from the following files:
  • Auxiliary/BufferedData.hpp
  • Auxiliary/BufferedData.cpp
Generated on Wed Jan 25 01:03:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BufferedOutputStream Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BufferedOutputStream Class Reference
[Kernel]

#include <Apoxi/Compat/BufferedOutputStream.hpp>

Inheritance diagram for BufferedOutputStream:

[legend]
Collaboration diagram for BufferedOutputStream:

[legend]

Public Member Functions

BufferedOutputStream (OutputStream *stream)
virtual void | Flush ()
virtual INT | Write (const BYTE *data, INT len)
virtual INT | Write (const BYTE data)
virtual | ~BufferedOutputStream ()

Constructor & Destructor Documentation

BufferedOutputStream::BufferedOutputStream ( OutputStream * stream )

BufferedOutputStream::~BufferedOutputStream ( ) [virtual]

Member Function Documentation

void BufferedOutputStream::Flush ( ) [virtual]

Reimplemented from OutputStream.

INT BufferedOutputStream::Write | ( | const BYTE * | data,
 |  | INT | len
 | ) | [virtual]

Reimplemented from OutputStream.

INT BufferedOutputStream::Write ( const BYTE data ) [virtual]

Implements OutputStream.

The documentation for this class was generated from the following files:
  • Compat/BufferedOutputStream.hpp
  • Compat/BufferedOutputStream.cpp
Generated on Wed Jan 25 01:03:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BufferPoolManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

BufferPoolManager Class Reference
[Devices]

#include <Apoxi/Auxiliary/BufferPoolManager.hpp>

Collaboration diagram for BufferPoolManager:

[legend]

Public Types

enum ResultType {
NoError, BufferPoolNotAvailableError, BufferNotExistentError, BufferAdjustedWarning,
NoBufferFreeError, OutOfMemoryError
}

Public Member Functions

BufferPoolManager::ResultType | CreateBufferPool (UINT8 &buff_count, UINT32 buff_len, UINT32 &pool_handle)
BufferPoolManager::ResultType | DeleteBufferPool (UINT32 &pool_handle)
BufferPoolManager::ResultType | GetBuffer (UINT32 pool_handle, UINT8 HUGE *&buff_ptr)
BufferPoolManager::ResultType | GetBufferPoolStatus (UINT32 pool_handle, UINT8 &free_buff_count)
BufferPoolManager::ResultType | ReleaseBuffer (UINT8 HUGE *&buff_ptr)

Static Public Member Functions

static BufferPoolManager * | GetInstance ()

Data Structures

struct | Buffer
struct | Pool

Detailed Description

The BufferManager is a singleton (i.e. a static class) with static methods only. It will created at boot time and will be present until the system will be shutdown.

Member Enumeration Documentation

enum BufferPoolManager::ResultType

Enumerator:
NoError
BufferPoolNotAvailableError
BufferNotExistentError
BufferAdjustedWarning
NoBufferFreeError
OutOfMemoryError

Member Function Documentation

BufferPoolManager::ResultType BufferPoolManager::CreateBufferPool | ( | UINT8 & | buff_count,
 |  | UINT32 | buff_len,
 |  | UINT32 & | pool_handle
 | ) |

Creates a new buffer pool. The application which creates the buffer pool is responsible to delete it later.

Parameters:
buff_count | [IN] Number of requested buffers. [OUT] Number of actually allocated buffers (might be smaller than the requested one).
buff_len | [IN] Length of each buffer in byte.
buff_ptr_array | [OUT] Pointer to buffer array, containing buff_count buffers.
pool_handle | [OUT] Handle to the created buffer pool. It just a magic number to identify the pool
Returns:

BufferPoolManager::ResultType BufferPoolManager::DeleteBufferPool ( UINT32 & pool_handle )

Deletes an existing buffer pool. Typically the application which has created the buffer pool is responsible to delete it also. After deletion of a specific buffer pool no application/device can get any buffer from this pool any longer.

Parameters:
pool_handle [IN] Handle to the buffer pool to be deleted. [OUT] Return value is NULL if pool is successfully deleted. In case of an error the pool_handle will not be modified
Returns:

BufferPoolManager::ResultType BufferPoolManager::GetBuffer | ( | UINT32 | pool_handle,
 |  | UINT8 HUGE *& | buff_ptr
 | ) |

Gets a reference (pointer) to any free buffer. The buffer manager returns a pointer the any free buffer, which is available in the given buffer pool.

Parameters:
pool_handle | [IN] Handle to the buffer pool from which a free buffer shall be obtained.
buff_ptr | [OUT] Pointer to the returned buffer.
Returns:

BufferPoolManager::ResultType BufferPoolManager::GetBufferPoolStatus | ( | UINT32 | pool_handle,
 |  | UINT8 & | free_buff_count
 | ) |

Retrieves the amount of free buffers in the given Buffer pool

Parameters:
pool_handle | [IN] Handle to the buffer pool to be queried
free_buff_count | [OUT] Free buffer count
Returns:

BufferPoolManager * BufferPoolManager::GetInstance ( ) [static]

BufferPoolManager::ResultType BufferPoolManager::ReleaseBuffer ( UINT8 HUGE *& buff_ptr )

Releases one or more buffer(s) (typically of one specific type, i.e. buffers belonging to the same pool). A released buffer can be returned by the BufferManager if someone calls BufferManager::GetBuffer(...)

Parameters:
buff_ptr [IN] Pointer to an buffer which shall be released. The buffer is provided by the caller and passed as reference to the method.

The documentation for this class was generated from the following files:
  • Auxiliary/BufferPoolManager.hpp
  • Auxiliary/BufferPoolManager.cpp
Generated on Wed Jan 25 01:03:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ByteBuffer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ByteBuffer Class Reference

#include <Apoxi/Auxiliary/ByteBuffer.hpp>

Inheritance diagram for ByteBuffer:

[legend]

Public Member Functions

virtual BOOLEAN | Append (UINT8 octet)
Append an octet at the end of the buffer and increments length.
ByteBuffer (const UINT8 *buffer, INT len, INT capacity=0)
Creates a ByteBuffer object by copying a given buffer.
ByteBuffer (const ByteBuffer *bbCopy)
Creates a ByteBuffer object by copying another one.
ByteBuffer (const ByteBuffer &bbCopy)
Creates a ByteBuffer object by copying another one.
ByteBuffer (INT len, INT capacity=0)
Creates a ByteBuffer object (initialized with zeros).
ByteBuffer ()
Creates an empty ByteBuffer object.
INT | GetCapacity () const
Returns the capacity of the internal buffer.
virtual UINT8 * | GetData () const
Returns the pointer to the internal buffer.
virtual INT | GetLength () const
Returns the length of the internal buffer.
virtual BOOLEAN | IsEmpty () const
Checks whether the internal buffer is empty (points to null).
virtual BOOLEAN | IsEqualTo (const ByteBuffer &rhs) const
Tells whether 2 byte buffers have identical content.
ByteBuffer & | operator= (const ByteBuffer &bbCopy)
Assigns a new value to the ByteBuffer object.
UINT8 & | operator[] (INT idx)
Retrieve UINT8 from index idx of the internal buffer.
virtual BOOLEAN | PreAlloc (INT length, INT capacity=0)
Preallocates buffer space.
BOOLEAN | Reserve (INT capacity)
Reserves buffer space maintaining the current length.
virtual BOOLEAN | SetLength (INT length)
virtual void | Swap (ByteBuffer &swap_with)
Swaps content of object with those of 'swap_with'.
virtual | ~ByteBuffer ()
Destroys the ByteBuffer object and frees the memory of the internal buffer.

Protected Member Functions

BOOLEAN | Allocate (INT length, INT capacity=0)
void | Free ()
BOOLEAN | Reallocate (INT length, INT capacity)

Constructor & Destructor Documentation

ByteBuffer::ByteBuffer ( )

Creates an empty ByteBuffer object.

ByteBuffer::ByteBuffer | ( | INT | len,
 |  | INT | capacity = 0
 | ) |

Creates a ByteBuffer object (initialized with zeros).

ByteBuffer::ByteBuffer ( const ByteBuffer & bbCopy )

Creates a ByteBuffer object by copying another one.

ByteBuffer::ByteBuffer ( const ByteBuffer * bbCopy )

Creates a ByteBuffer object by copying another one.

ByteBuffer::ByteBuffer | ( | const UINT8 * | buffer,
 |  | INT | len,
 |  | INT | capacity = 0
 | ) |

Creates a ByteBuffer object by copying a given buffer.

ByteBuffer::~ByteBuffer ( ) [virtual]

Destroys the ByteBuffer object and frees the memory of the internal buffer.

Member Function Documentation

BOOLEAN ByteBuffer::Allocate | ( | INT | length,
 |  | INT | capacity = 0
 | ) | [protected]

BOOLEAN ByteBuffer::Append ( UINT8 octet ) [virtual]

Append an octet at the end of the buffer and increments length.

void ByteBuffer::Free ( ) [protected]

INT ByteBuffer::GetCapacity ( ) const [inline]

Returns the capacity of the internal buffer.

virtual UINT8* ByteBuffer::GetData ( ) const [inline, virtual]

Returns the pointer to the internal buffer.

virtual INT ByteBuffer::GetLength ( ) const [inline, virtual]

Returns the length of the internal buffer.

virtual BOOLEAN ByteBuffer::IsEmpty ( ) const [inline, virtual]

Checks whether the internal buffer is empty (points to null).

BOOLEAN ByteBuffer::IsEqualTo ( const ByteBuffer & rhs ) const [virtual]

Tells whether 2 byte buffers have identical content.

ByteBuffer & ByteBuffer::operator= ( const ByteBuffer & bbCopy )

Assigns a new value to the ByteBuffer object.

UINT8 & ByteBuffer::operator[] ( INT idx )

Retrieve UINT8 from index idx of the internal buffer.

BOOLEAN ByteBuffer::PreAlloc | ( | INT | length,
 |  | INT | capacity = 0
 | ) | [virtual]

Preallocates buffer space.

Allocates at least 'length' bytes. When capacity is greater than 'length', 'capacity' bytes are allocated instead. After a successful call to PreAlloc, GetLength() will return 'length', GetCapacity() will return 'length'. Existing data is preserved.

Returns:
'TRUE' in case of success, 'FALSE' when memory allocation failed - in this case the object is not modified

BOOLEAN ByteBuffer::Reallocate | ( | INT | length,
 |  | INT | capacity
 | ) | [protected]

BOOLEAN ByteBuffer::Reserve ( INT capacity ) [inline]

Reserves buffer space maintaining the current length.

When capacity is greater then GetCapacity() a new buffer of 'capacity' bytes is allocated. The old content and its length are preserved.

Returns:
'TRUE' in case of success, 'FALSE' when memory allocation failed - in this case the object is not modified

BOOLEAN ByteBuffer::SetLength ( INT length ) [virtual]

void ByteBuffer::Swap ( ByteBuffer & swap_with ) [virtual]

Swaps content of object with those of 'swap_with'.

The documentation for this class was generated from the following files:
  • Auxiliary/ByteBuffer.hpp
  • Auxiliary/ByteBuffer.cpp
Generated on Wed Jan 25 01:03:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CachingSortProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CachingSortProvider Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/CachingSortProvider.hpp>

Inheritance diagram for CachingSortProvider:

[legend]
Collaboration diagram for CachingSortProvider:

[legend]

Public Types

typedef QuickSortProvider | Base

Public Member Functions

CachingSortProvider (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
CachingSortProvider ()
void | Init (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
The same interface as the constructor.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use by executing the sort process.
virtual | ~CachingSortProvider ()
Destructor.

Detailed Description

The CachingSortProvider sort rows of its child provider by using a special caching algorithm. First the values to be sorted are read and sorted block wise. Then these blocks are merged together by comparing the smallest value with the smallest value of each block. With this algorithm the data has only to be accessed twice. Hence the CachingSortProvider is meant to sort provider with slow data access (e.g. with data stored in FFS). If the data access is fast or the data is already cached still the QuickSortProvider should be used to assure the best possible performance. If no memory is available to cache the entries the QuickSort algorithm will be used.

Member Typedef Documentation

typedef QuickSortProvider CachingSortProvider::Base

Reimplemented from QuickSortProvider.

Constructor & Destructor Documentation

CachingSortProvider::CachingSortProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

CachingSortProvider::CachingSortProvider | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be sorted. columnid: Specify which columnid has to be sorted. order: Specify whether ascending (TRUE) or descending (FALSE).

CachingSortProvider::~CachingSortProvider ( ) [virtual]

Destructor.

Member Function Documentation

void CachingSortProvider::Init | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

The same interface as the constructor.

Reimplemented from QuickSortProvider.

BOOLEAN CachingSortProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use by executing the sort process.

Reimplemented from QuickSortProvider.

The documentation for this class was generated from the following files:
  • Auxiliary/CachingSortProvider.hpp
  • Auxiliary/CachingSortProvider.cpp
Generated on Wed Jan 25 01:03:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalculatorInputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalculatorInputMapper Class Reference
[Editors]

Manages the input of numbers and a decimal point. More...

#include <Apoxi/Gui/CalculatorInputMapper.hpp>

Inheritance diagram for CalculatorInputMapper:

[legend]
Collaboration diagram for CalculatorInputMapper:

[legend]

Public Member Functions

CalculatorInputMapper ()
virtual Alphabet | GetAlphabet () const
virtual INT | GetId () const
virtual | ~CalculatorInputMapper ()

Protected Member Functions

virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Detailed Description

Manages the input of numbers and a decimal point.

Constructor & Destructor Documentation

CalculatorInputMapper::CalculatorInputMapper ( ) [explicit]

CalculatorInputMapper::~CalculatorInputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet CalculatorInputMapper::GetAlphabet ( ) const [virtual]

Returns SevenBitAlphabet.

See also:
InputMapper::GetAlphabet.

Reimplemented from NumericInputMapper.

INT CalculatorInputMapper::GetId ( ) const [virtual]

See also:
InputMapper::GetId()

Reimplemented from NumericInputMapper.

BOOLEAN CalculatorInputMapper::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
InputMapper::OnKeyDown()

Reimplemented from NumericInputMapper.

The documentation for this class was generated from the following files:
  • Gui/CalculatorInputMapper.hpp
  • Gui/CalculatorInputMapper.cpp
Generated on Wed Jan 25 01:03:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarAddRecordWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarAddRecordWin Class Reference

#include <Applications/Calendar/CalendarAddRecordWin.hpp>

Collaboration diagram for CalendarAddRecordWin:

[legend]

Public Member Functions

CalendarAddRecordWin ()
void | Init ()
void | OnLayoutClient ()
void | SetCategory ()
void | SetData (CalendarRecord rec)
void | SetDate (Date day)
void | SetRecurrence ()
void | StoreAppointment ()
virtual | ~CalendarAddRecordWin ()

Protected Member Functions

virtual void | OnClose ()

Constructor & Destructor Documentation

CalendarAddRecordWin::CalendarAddRecordWin ( )

CalendarAddRecordWin::~CalendarAddRecordWin ( ) [virtual]

Member Function Documentation

void CalendarAddRecordWin::Init ( )

void CalendarAddRecordWin::OnClose ( ) [protected, virtual]

void CalendarAddRecordWin::OnLayoutClient ( )

void CalendarAddRecordWin::SetCategory ( )

void CalendarAddRecordWin::SetData ( CalendarRecord rec )

void CalendarAddRecordWin::SetDate ( Date day )

void CalendarAddRecordWin::SetRecurrence ( )

void CalendarAddRecordWin::StoreAppointment ( )

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarAddRecordWin.hpp
  • Applications/Calendar/CalendarAddRecordWin.cpp
Generated on Wed Jan 25 01:03:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarApp Class Reference

#include <Applications/Calendar/CalendarApp.hpp>

Collaboration diagram for CalendarApp:

[legend]

Public Member Functions

void | AbortCalendarRecordIns ()
CalendarApp ()
CalendarProvider * GetCalendarProvider ()
BOOLEAN | IsAlarmDay (Date date)
BOOLEAN | SaveCalendarRecord (CalendarRecord *record)
void | SetCurrentRecordIdx (INT idx)
void | UpdateAlarmList ()
virtual | ~CalendarApp ()

Static Public Member Functions

static CalendarApp * | GetInstance ()

Protected Member Functions

BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual void | OnOpen ()
virtual void | OnStartup ()

Constructor & Destructor Documentation

CalendarApp::CalendarApp ( )

CalendarApp::~CalendarApp ( ) [virtual]

Member Function Documentation

void CalendarApp::AbortCalendarRecordIns ( )

CalendarProvider* CalendarApp::GetCalendarProvider ( ) [inline]

CalendarApp * CalendarApp::GetInstance ( ) [static]

BOOLEAN CalendarApp::IsAlarmDay ( Date date )

BOOLEAN CalendarApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected]

void CalendarApp::OnOpen ( ) [protected, virtual]

void CalendarApp::OnStartup ( ) [protected, virtual]

BOOLEAN CalendarApp::SaveCalendarRecord ( CalendarRecord * record )

void CalendarApp::SetCurrentRecordIdx ( INT idx ) [inline]

void CalendarApp::UpdateAlarmList ( )

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarApp.hpp
  • Applications/Calendar/CalendarApp.cpp
Generated on Wed Jan 25 01:03:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarDialogWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarDialogWin Class Reference

#include <Applications/Calendar/CalendarDialogWin.hpp>

Collaboration diagram for CalendarDialogWin:

[legend]

Public Member Functions

INT | GetData ()
void | Init ()
BOOLEAN | OnConfirm ()
void | OnOpen ()
void | SetData (INT value)

Member Function Documentation

INT CalendarDialogWin::GetData ( )

void CalendarDialogWin::Init ( )

BOOLEAN CalendarDialogWin::OnConfirm ( )

void CalendarDialogWin::OnOpen ( )

void CalendarDialogWin::SetData ( INT value )

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarDialogWin.hpp
  • Applications/Calendar/CalendarDialogWin.cpp
Generated on Wed Jan 25 01:03:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarGotoDateWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarGotoDateWin Class Reference

#include <Applications/Calendar/CalendarGotoDateWin.hpp>

Collaboration diagram for CalendarGotoDateWin:

[legend]

Public Member Functions

CalendarGotoDateWin ()
void | Init (CalendarMonthWin *parent)
virtual | ~CalendarGotoDateWin ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
void | OnLayoutClient ()

Constructor & Destructor Documentation

CalendarGotoDateWin::CalendarGotoDateWin ( )

CalendarGotoDateWin::~CalendarGotoDateWin ( ) [virtual]

Member Function Documentation

void CalendarGotoDateWin::Init ( CalendarMonthWin * parent )

BOOLEAN CalendarGotoDateWin::OnCancel ( ) [protected, virtual]

BOOLEAN CalendarGotoDateWin::OnConfirm ( ) [protected, virtual]

void CalendarGotoDateWin::OnLayoutClient ( ) [protected]

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarGotoDateWin.hpp
  • Applications/Calendar/CalendarGotoDateWin.cpp
Generated on Wed Jan 25 01:03:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarGrid Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarGrid Class Reference
[Components]

#include <Applications/Calendar/CalendarGrid.hpp>

Inheritance diagram for CalendarGrid:

[legend]
Collaboration diagram for CalendarGrid:

[legend]

Public Member Functions

CalendarGrid ()
virtual INT | GetCellCount () const
virtual XYDIM | GetCellHeight () const
virtual XYDIM | GetCellWidth () const
virtual INT | GetColumnCount () const
Date GetCurrentSelectedDay ()
void | Init (Control *parent)
void | Invalidate (const Rect &rect=Rect(), BOOLEAN erase=TRUE)
BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
void | SetCurrentSelectedDay (Date date)
virtual | ~CalendarGrid ()

Protected Member Functions

void | OnGetFocus ()
BOOLEAN | OnKeyDown (KeyCode key_code)

Detailed Description

Control for managing menu hierarchies. The menu-hierarchy and the look of each menu-item is defined by an instance of the class AbstractMenuAccessor. Comfortable accessors are available in the AddOn GuiMenuAccessors.

Constructor & Destructor Documentation

CalendarGrid::CalendarGrid ( )

CalendarGrid::~CalendarGrid ( ) [virtual]

Member Function Documentation

virtual INT CalendarGrid::GetCellCount ( ) const [inline, virtual]

Returns:
Defines the number of cells for the grid.

Implements AbstractGrid.

XYDIM CalendarGrid::GetCellHeight ( ) const [virtual]

See also:
AbstractGrid::GetCellHeight

Implements AbstractGrid.

XYDIM CalendarGrid::GetCellWidth ( ) const [virtual]

See also:
AbstractGrid::GetCellWidth

Reimplemented from AbstractGrid.

virtual INT CalendarGrid::GetColumnCount ( ) const [inline, virtual]

Returns:
Defines the number of columns for the grid.

Implements AbstractGrid.

Date CalendarGrid::GetCurrentSelectedDay ( ) [inline]

void CalendarGrid::Init ( Control * parent )

Parameters:
parent | Control which embeds the Menu.
menu_accessor | Pointer to the accessor of the main menu.

Reimplemented from AbstractGrid.

void CalendarGrid::Invalidate | ( | const Rect & | rect = Rect(),
 |  | BOOLEAN | erase = TRUE
 | ) |

Invalidates a specified area of the control. This leads to a repaint of this area in the next idle-state of the application.

Parameters:
rect | Specifies the area by a rectangle. The coordinates are relative to the upper left position of the control. If no rectangle is specified, the whole area will be invalidated.
erase | Indicates, whether the control should be erased before Control::OnPaint is called. By default erase is TRUE.

Reimplemented from Control.

void CalendarGrid::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from AbstractGrid.

BOOLEAN CalendarGrid::OnInputMap ( const InputMapItem & input_map_item ) [virtual]

Reimplemented from Control.

BOOLEAN CalendarGrid::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from AbstractGrid.

void CalendarGrid::SetCurrentSelectedDay ( Date date ) [inline]

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarGrid.hpp
  • Applications/Calendar/CalendarGrid.cpp
Generated on Wed Jan 25 01:03:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarGridView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarGridView Class Reference
[Components]

#include <Applications/Calendar/CalendarGrid.hpp>

Inheritance diagram for CalendarGridView:

[legend]
Collaboration diagram for CalendarGridView:

[legend]

Public Member Functions

CalendarGridView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual | ~CalendarGridView ()

Constructor & Destructor Documentation

CalendarGridView::CalendarGridView ( )

CalendarGridView::~CalendarGridView ( ) [virtual]

Member Function Documentation

void CalendarGridView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarGrid.hpp
  • Applications/Calendar/CalendarGrid.cpp
Generated on Wed Jan 25 01:03:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarListWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarListWin Class Reference
[CalendarListWin, CalendarListWin]

This class declares a new kind of window derived from class MmiItemListWindow. More...

#include <Applications/Calendar/CalendarListWin.hpp>

Collaboration diagram for CalendarListWin:

[legend]

Public Member Functions

CalendarListWin ()
BOOLEAN | DeleteAllItems ()
BOOLEAN | DeleteSelectedItem ()
void | Init (Provider *provider)
BOOLEAN | ModifySelectedItem ()
void | SetType (Date date)
void | SetWindow (CalendarAddRecordWin &win)
virtual | ~CalendarListWin ()

Protected Member Functions

virtual void | OnClose ()
virtual void | OnGetFocus ()
virtual void | OnOpen ()

Detailed Description

This class declares a new kind of window derived from class MmiItemListWindow.

Constructor & Destructor Documentation

CalendarListWin::CalendarListWin ( )

CalendarListWin::~CalendarListWin ( ) [virtual]

Member Function Documentation

BOOLEAN CalendarListWin::DeleteAllItems ( )

BOOLEAN CalendarListWin::DeleteSelectedItem ( )

void CalendarListWin::Init ( Provider * provider )

BOOLEAN CalendarListWin::ModifySelectedItem ( )

void CalendarListWin::OnClose ( ) [protected, virtual]

void CalendarListWin::OnGetFocus ( ) [protected, virtual]

void CalendarListWin::OnOpen ( ) [protected, virtual]

void CalendarListWin::SetType ( Date date )

void CalendarListWin::SetWindow ( CalendarAddRecordWin & win )

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarListWin.hpp
  • Applications/Calendar/CalendarListWin.cpp
Generated on Wed Jan 25 01:03:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarMonthSelector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarMonthSelector Class Reference

#include <Applications/Calendar/CalendarMonthSelector.hpp>

Inheritance diagram for CalendarMonthSelector:

[legend]
Collaboration diagram for CalendarMonthSelector:

[legend]

Public Member Functions

CalendarMonthSelector ()
virtual INT | GetCellCount () const
virtual XYDIM | GetCellHeight () const
virtual INT | GetColumnCount () const
void | Init (Control *parent)
BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
virtual | ~CalendarMonthSelector ()

Constructor & Destructor Documentation

CalendarMonthSelector::CalendarMonthSelector ( )

CalendarMonthSelector::~CalendarMonthSelector ( ) [virtual]

Member Function Documentation

virtual INT CalendarMonthSelector::GetCellCount ( ) const [inline, virtual]

Returns:
Defines the number of cells for the grid.

Implements AbstractGrid.

virtual XYDIM CalendarMonthSelector::GetCellHeight ( ) const [inline, virtual]

Returns:
Defines the height of all cells.

Implements AbstractGrid.

virtual INT CalendarMonthSelector::GetColumnCount ( ) const [inline, virtual]

Returns:
Defines the number of columns for the grid.

Implements AbstractGrid.

void CalendarMonthSelector::Init ( Control * parent )

Parameters:
parent Control which embeds the AbstractGrid.

Reimplemented from AbstractGrid.

BOOLEAN CalendarMonthSelector::OnInputMap ( const InputMapItem & input_map_item ) [virtual]

Reimplemented from Control.

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarMonthSelector.hpp
  • Applications/Calendar/CalendarMonthSelector.cpp
Generated on Wed Jan 25 01:03:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarMonthSelectorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarMonthSelectorView Class Reference

Describes the view of a radiobutton-control. More...

#include <Applications/Calendar/CalendarMonthSelector.hpp>

Inheritance diagram for CalendarMonthSelectorView:

[legend]
Collaboration diagram for CalendarMonthSelectorView:

[legend]

Public Member Functions

CalendarMonthSelectorView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual | ~CalendarMonthSelectorView ()

Detailed Description

Describes the view of a radiobutton-control.

Constructor & Destructor Documentation

CalendarMonthSelectorView::CalendarMonthSelectorView ( )

CalendarMonthSelectorView::~CalendarMonthSelectorView ( ) [virtual]

Member Function Documentation

void CalendarMonthSelectorView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarMonthSelector.hpp
  • Applications/Calendar/CalendarMonthSelector.cpp
Generated on Wed Jan 25 01:03:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarMonthWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarMonthWin Class Reference

#include <Applications/Calendar/CalendarMonthWin.hpp>

Collaboration diagram for CalendarMonthWin:

[legend]

Public Member Functions

void | AddRecord ()
CalendarMonthWin ()
CalendarAddRecordWin * GetCalendarAddWin ()
CalendarListWin * GetCalendarListWin ()
Date | GetCurrentDate () const
void | GotoDay ()
void | Init ()
void | OnLayoutClient ()
void | OnOpen ()
void | SetCurrentDate (Date date)
BOOLEAN | Update ()
void | ViewAll ()
void | ViewSelectedDay ()
virtual | ~CalendarMonthWin ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()

Constructor & Destructor Documentation

CalendarMonthWin::CalendarMonthWin ( )

CalendarMonthWin::~CalendarMonthWin ( ) [virtual]

Member Function Documentation

void CalendarMonthWin::AddRecord ( )

CalendarAddRecordWin* CalendarMonthWin::GetCalendarAddWin ( ) [inline]

CalendarListWin* CalendarMonthWin::GetCalendarListWin ( ) [inline]

Date CalendarMonthWin::GetCurrentDate ( ) const [inline]

void CalendarMonthWin::GotoDay ( )

void CalendarMonthWin::Init ( )

BOOLEAN CalendarMonthWin::OnCancel ( ) [protected, virtual]

void CalendarMonthWin::OnLayoutClient ( )

void CalendarMonthWin::OnOpen ( )

void CalendarMonthWin::SetCurrentDate ( Date date )

BOOLEAN CalendarMonthWin::Update ( )

void CalendarMonthWin::ViewAll ( )

void CalendarMonthWin::ViewSelectedDay ( )

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarMonthWin.hpp
  • Applications/Calendar/CalendarMonthWin.cpp
Generated on Wed Jan 25 01:03:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarProvider Class Reference

#include <Applications/Calendar/CalendarProvider.hpp>

Inheritance diagram for CalendarProvider:

[legend]
Collaboration diagram for CalendarProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

BOOLEAN | AppendRow ()
Append a row.
CalendarProvider ()
BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
BOOLEAN | DeleteAllRows ()
BOOLEAN | DeleteRow (INT row)
Delete the specified row.
BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
INT | GetProviderId () const
Returns the provider id.
BOOLEAN | GetRecordData (INT row, CalendarRecord *dst)
void | Init (Protector *protector)
Sets a protector object. The protector object must be in an initialized state.
INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
INT | RowCount ()
RowCount returns the number of rows.
BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
void | SetDateIsValid (BOOLEAN valid)
virtual | ~CalendarProvider ()

Protected Attributes

CalendarRecord m_current_calendar_record
BOOLEAN | m_date_is_valid
CalendarRecord m_delete_record
RecordHandler m_handler
INT | m_row_count

Member Typedef Documentation

typedef ThreadSafeProvider CalendarProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

CalendarProvider::CalendarProvider ( )

CalendarProvider::~CalendarProvider ( ) [virtual]

Member Function Documentation

BOOLEAN CalendarProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

BOOLEAN CalendarProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN CalendarProvider::DeleteAllRows ( )

BOOLEAN CalendarProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN CalendarProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT CalendarProvider::GetProviderId ( ) const [inline, virtual]

Returns the provider id.

Implements Provider.

BOOLEAN CalendarProvider::GetRecordData | ( | INT | row,
 |  | CalendarRecord * | dst
 | ) |

void CalendarProvider::Init ( Protector * protector )

Sets a protector object. The protector object must be in an initialized state.

Reimplemented from ThreadSafeProvider.

INT CalendarProvider::MaxRowCount ( ) [inline, virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT CalendarProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN CalendarProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN CalendarProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

void CalendarProvider::SetDateIsValid ( BOOLEAN valid )

Field Documentation

CalendarRecord CalendarProvider::m_current_calendar_record [protected]

BOOLEAN CalendarProvider::m_date_is_valid [protected]

CalendarRecord CalendarProvider::m_delete_record [protected]

RecordHandler CalendarProvider::m_handler [protected]

INT CalendarProvider::m_row_count [protected]

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarProvider.hpp
  • Applications/Calendar/CalendarProvider.cpp
Generated on Wed Jan 25 01:03:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarRecord Class Reference

#include <Applications/Calendar/CalendarRecord.hpp>

Inheritance diagram for CalendarRecord:

[legend]
Collaboration diagram for CalendarRecord:

[legend]

Public Types

enum CalendarCategory {
Memo, Meeting, Birthday, CallRemind,
Anniversary, Other, CategoryCounts
}
enum CalendarRecurrence {
NoRepeat, Daily, Weekly, Monthly,
Yearly, RecurrenceCounts
}

Public Member Functions

CalendarRecord (Date date, Time time, WString txt, CalendarCategory cat=Memo, CalendarRecurrence recurr=NoRepeat)
CalendarRecord ()
CalendarCategory GetCategory ()
virtual const UINT8 * | GetData ()
Date GetDate ()
const WCHAR * | GetDescription () const
virtual INT | GetPersistentSize ()
CalendarRecurrence GetRecurrence ()
Time GetTime ()
void | Init ()
virtual BOOLEAN | IsRecordDeleted ()
virtual void | MarkDeleted ()
void | SetCategory (CalendarCategory cat)
virtual void | SetData (const UINT8 *data)
void | SetDate (Date date)
void | SetDescription (const WString &txt)
void | SetRecurrence (CalendarRecurrence recurr)
void | SetTime (Time time)
virtual | ~CalendarRecord ()

Protected Attributes

CalendarRecord::Persist m_data

Data Structures

struct | Persist

Member Enumeration Documentation

enum CalendarRecord::CalendarCategory

Enumerator:
Memo
Meeting
Birthday
CallRemind
Anniversary
Other
CategoryCounts

enum CalendarRecord::CalendarRecurrence

Enumerator:
NoRepeat
Daily
Weekly
Monthly
Yearly
RecurrenceCounts

Constructor & Destructor Documentation

CalendarRecord::CalendarRecord ( )

CalendarRecord::CalendarRecord | ( | Date | date,
 |  | Time | time,
 |  | WString | txt,
 |  | CalendarCategory | cat = Memo,
 |  | CalendarRecurrence | recurr = NoRepeat
 | ) |

CalendarRecord::~CalendarRecord ( ) [virtual]

Member Function Documentation

CalendarCategory CalendarRecord::GetCategory ( ) [inline]

const UINT8 * CalendarRecord::GetData ( ) [virtual]

Implements Record.

Date CalendarRecord::GetDate ( ) [inline]

const WCHAR* CalendarRecord::GetDescription ( ) const [inline]

INT CalendarRecord::GetPersistentSize ( ) [virtual]

Implements Record.

CalendarRecurrence CalendarRecord::GetRecurrence ( ) [inline]

Time CalendarRecord::GetTime ( ) [inline]

void CalendarRecord::Init ( )

BOOLEAN CalendarRecord::IsRecordDeleted ( ) [virtual]

Reimplemented from Record.

void CalendarRecord::MarkDeleted ( ) [virtual]

Reimplemented from Record.

void CalendarRecord::SetCategory ( CalendarCategory cat ) [inline]

void CalendarRecord::SetData ( const UINT8 * data ) [virtual]

Implements Record.

void CalendarRecord::SetDate ( Date date ) [inline]

void CalendarRecord::SetDescription ( const WString & txt ) [inline]

void CalendarRecord::SetRecurrence ( CalendarRecurrence recurr ) [inline]

void CalendarRecord::SetTime ( Time time ) [inline]

Field Documentation

struct CalendarRecord::Persist CalendarRecord::m_data [protected]

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarRecord.hpp
  • Applications/Calendar/CalendarRecord.cpp
Generated on Wed Jan 25 01:03:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarRecord::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CalendarRecord::Persist

CalendarRecord::Persist Struct Reference

#include <Applications/Calendar/CalendarRecord.hpp>

Collaboration diagram for CalendarRecord::Persist:

[legend]

Data Fields

CalendarCategory category
Date date
WCHAR description [max_calendar_description_len+1]
CalendarRecurrence recurrence
Time time

Field Documentation

CalendarCategory CalendarRecord::Persist::category

Date CalendarRecord::Persist::date

WCHAR CalendarRecord::Persist::description[max_calendar_description_len+1]

CalendarRecurrence CalendarRecord::Persist::recurrence

Time CalendarRecord::Persist::time

The documentation for this struct was generated from the following file:
  • Applications/Calendar/CalendarRecord.hpp
Generated on Wed Jan 25 01:03:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarRecordsList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarRecordsList Class Reference
[CallRecords]

#include <Applications/Calendar/CalendarRecordsList.hpp>

Collaboration diagram for CalendarRecordsList:

[legend]

Public Member Functions

CalendarRecordsList ()
BOOLEAN | DeleteAllItems ()
BOOLEAN | DeleteSelectedItem ()
INT | GetEntryCount (Date date)
void | Init ()
BOOLEAN | ModifySelectedItem ()
void | SetType (Date date)
void | SetWindow (CalendarAddRecordWin &win)
void | UpdateView ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()

Constructor & Destructor Documentation

CalendarRecordsList::CalendarRecordsList ( )

Member Function Documentation

BOOLEAN CalendarRecordsList::DeleteAllItems ( )

BOOLEAN CalendarRecordsList::DeleteSelectedItem ( )

INT CalendarRecordsList::GetEntryCount ( Date date ) [inline]

void CalendarRecordsList::Init ( )

BOOLEAN CalendarRecordsList::ModifySelectedItem ( )

BOOLEAN CalendarRecordsList::OnMessage ( const Message & msg ) [protected, virtual]

void CalendarRecordsList::OnOpen ( ) [protected, virtual]

void CalendarRecordsList::SetType ( Date date )

void CalendarRecordsList::SetWindow ( CalendarAddRecordWin & win )

void CalendarRecordsList::UpdateView ( )

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarRecordsList.hpp
  • Applications/Calendar/CalendarRecordsList.cpp
Generated on Wed Jan 25 01:03:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarRecordsListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalendarRecordsListBoxModel Class Reference

#include <Applications/Calendar/CalendarRecordsListBox.hpp>

Collaboration diagram for CalendarRecordsListBoxModel:

[legend]

Public Member Functions

CalendarRecordsListBoxModel (DrawableObjectListBox *listbox)
CalendarRecordsListBoxModel ()
void | DeleteAllItems ()
void | DeleteItem (INT index)
BOOLEAN | GetCalendarRecord (INT index, CalendarRecord *rec)
virtual const BitmapRes * | GetCellIcon (INT index, BOOLEAN highlighted)
virtual const WCHAR * | GetCellText (INT index, BOOLEAN highlighted)
INT | GetEntryCount (Date date)
WString GetNote ()
void | Init (DrawableObjectListBox *listbox)
void | SetType (Date date)
void | UpdateRow (INT row)

Constructor & Destructor Documentation

CalendarRecordsListBoxModel::CalendarRecordsListBoxModel ( )

CalendarRecordsListBoxModel::CalendarRecordsListBoxModel ( DrawableObjectListBox * listbox ) [explicit]

Member Function Documentation

void CalendarRecordsListBoxModel::DeleteAllItems ( )

void CalendarRecordsListBoxModel::DeleteItem ( INT index )

BOOLEAN CalendarRecordsListBoxModel::GetCalendarRecord | ( | INT | index,
 |  | CalendarRecord * | rec
 | ) |

const BitmapRes * CalendarRecordsListBoxModel::GetCellIcon | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

const WCHAR * CalendarRecordsListBoxModel::GetCellText | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

INT CalendarRecordsListBoxModel::GetEntryCount ( Date date )

WString CalendarRecordsListBoxModel::GetNote ( )

void CalendarRecordsListBoxModel::Init ( DrawableObjectListBox * listbox )

void CalendarRecordsListBoxModel::SetType ( Date date )

void CalendarRecordsListBoxModel::UpdateRow ( INT row )

The documentation for this class was generated from the following files:
  • Applications/Calendar/CalendarRecordsListBox.hpp
  • Applications/Calendar/CalendarRecordsListBox.cpp
Generated on Wed Jan 25 01:03:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallAcceptMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallAcceptMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallAcceptMsg:

[legend]
Collaboration diagram for CallAcceptMsg:

[legend]

Public Types

enum | { ID = 18712 }

Public Member Functions

CallAcceptMsg (const CallHdl &call_hdl)
virtual Message * | Clone () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~CallAcceptMsg ()

Detailed Description

CallAcceptMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallAcceptMsg::CallAcceptMsg ( const CallHdl & call_hdl )

CallAcceptMsg::~CallAcceptMsg ( ) [virtual]

Member Function Documentation

Message * CallAcceptMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CallAcceptMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & CallAcceptMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarredMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarredMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallBarredMsg:

[legend]
Collaboration diagram for CallBarredMsg:

[legend]

Public Types

enum | { ID = 18560 }

Public Member Functions

CallBarredMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code, const SsStatus &ss_status)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~CallBarredMsg ()

Detailed Description

Sent when a call is barred

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallBarredMsg::CallBarredMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code,
 |  | const SsStatus & | ss_status
 | ) |

CallBarredMsg::~CallBarredMsg ( ) [virtual]

Member Function Documentation

Message * CallBarredMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & CallBarredMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& CallBarredMsg::GetSsCode ( ) const [inline]

const SsStatus& CallBarredMsg::GetSsStatus ( ) const [inline]

const Tipd& CallBarredMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarringActivatedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarringActivatedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallBarringActivatedMsg:

[legend]
Collaboration diagram for CallBarringActivatedMsg:

[legend]

Public Types

enum | { ID = 18542 }

Public Member Functions

CallBarringActivatedMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code, const Vector< CallBarringFeature > &call_barring_features, const SsCode &parameter_ss_code, const ServiceGroup &parameter_basic_service)
virtual Message * | Clone () const
const Vector< CallBarringFeature > & | GetCallBarringFeatures () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParameterBasicService () const
const SsCode & | GetParameterSsCode () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
virtual | ~CallBarringActivatedMsg ()

Detailed Description

CallBarringActivatedMsg: sent when call barring was activated

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallBarringActivatedMsg::CallBarringActivatedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code,
 |  | const Vector< CallBarringFeature > & | call_barring_features,
 |  | const SsCode & | parameter_ss_code,
 |  | const ServiceGroup & | parameter_basic_service
 | ) |

CallBarringActivatedMsg::~CallBarringActivatedMsg ( ) [virtual]

Member Function Documentation

Message * CallBarringActivatedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<CallBarringFeature>& CallBarringActivatedMsg::GetCallBarringFeatures ( ) const [inline]

const MsgMetaData & CallBarringActivatedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallBarringActivatedMsg::GetParameterBasicService ( ) const [inline]

const SsCode& CallBarringActivatedMsg::GetParameterSsCode ( ) const [inline]

const SsCode& CallBarringActivatedMsg::GetSsCode ( ) const [inline]

const Tipd& CallBarringActivatedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarringDeactivatedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarringDeactivatedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallBarringDeactivatedMsg:

[legend]
Collaboration diagram for CallBarringDeactivatedMsg:

[legend]

Public Types

enum | { ID = 18543 }

Public Member Functions

CallBarringDeactivatedMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code, const Vector< CallBarringFeature > &call_barring_features, const SsCode &parameter_ss_code, const ServiceGroup &parameter_basic_service)
virtual Message * | Clone () const
const Vector< CallBarringFeature > & | GetCallBarringFeatures () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParameterBasicService () const
const SsCode & | GetParameterSsCode () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
virtual | ~CallBarringDeactivatedMsg ()

Detailed Description

CallBarringDeactivatedMsg: sent when call barring was deactivated

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallBarringDeactivatedMsg::CallBarringDeactivatedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code,
 |  | const Vector< CallBarringFeature > & | call_barring_features,
 |  | const SsCode & | parameter_ss_code,
 |  | const ServiceGroup & | parameter_basic_service
 | ) |

CallBarringDeactivatedMsg::~CallBarringDeactivatedMsg ( ) [virtual]

Member Function Documentation

Message * CallBarringDeactivatedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<CallBarringFeature>& CallBarringDeactivatedMsg::GetCallBarringFeatures ( ) const [inline]

const MsgMetaData & CallBarringDeactivatedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallBarringDeactivatedMsg::GetParameterBasicService ( ) const [inline]

const SsCode& CallBarringDeactivatedMsg::GetParameterSsCode ( ) const [inline]

const SsCode& CallBarringDeactivatedMsg::GetSsCode ( ) const [inline]

const Tipd& CallBarringDeactivatedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarringFeature Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarringFeature Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CallBarringFeature:

[legend]

Data Fields

SsGroup basic_service
SsStatus ss_status

Field Documentation

SsGroup CallBarringFeature::basic_service

SsStatus CallBarringFeature::ss_status

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:03:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarringFeatureList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarringFeatureList Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CallBarringFeatureList:

[legend]

Data Fields

CallBarringFeature data [c_max_no_basic_service_groups]

Field Documentation

CallBarringFeature CallBarringFeatureList::data[c_max_no_basic_service_groups]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:03:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarringHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarringHandler Class Reference

CallBarringHandler is a Supplementary Service handler responsible for activating, deactivating and interrogating the Call Waiting SS. More...

#include <Apoxi/Asc/CallBarringHandler.hpp>

Collaboration diagram for CallBarringHandler:

[legend]

Public Types

enum | { ID = CallBarringHandlerId }

Public Member Functions

SsApiRc | AbortPasswordRequest (Tipd tipd)
SsApiRc | Activate (SsCode ss_code, const WString &pw, ServiceGroup basic_service=AllServices, const WString &override_ss_sequence=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
CallBarringHandler ()
Constructor.
SsApiRc | ChangePassword (const WString &old_pw, const WString &new_pw, const WString &conf_pw, const WString &override_ss_sequence=L"", BOOLEAN register_only=FALSE, BOOLEAN provide_ss_code=TRUE)
SsApiRc | Deactivate (SsCode ss_code, const WString &pw, ServiceGroup basic_service=AllServices, const WString &override_ss_sequence=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
virtual HandlerId | GetHandlerId () const
SsApiRc | RequestStatus (SsCode ss_code, ServiceGroup basic_service=AllServices, const WString &override_ss_sequence=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
SsApiRc | SendPassword (Tipd tipd, const WString &password)
virtual | ~CallBarringHandler ()
Destructor.

Detailed Description

CallBarringHandler is a Supplementary Service handler responsible for activating, deactivating and interrogating the Call Waiting SS.

The CallBarringHandler is a SS handler responsible for modifying the Call Barring SS. This includes activating and deactivating specific services, setting passwords on those services as well as interrogating their current status. The handler provides various methods with different parameter signatures for these purposes. The call barring supplementary service consists of this set of subservices:

  • all call barrings
  • all outgoing call barrings
  • barring of all outgoing calls
  • barring of all outgoing international calls
  • barring of all outgoing international calls except those directed at the home PLMN country
  • all incoming call barrings
  • barring of all incoming calls
  • barring of all incoming calls when roaming outside the home PLMN
Therefore the desired subservice or subservice group has to specified.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Constructor & Destructor Documentation

CallBarringHandler::CallBarringHandler ( )

Constructor.

CallBarringHandler::~CallBarringHandler ( ) [virtual]

Destructor.

Member Function Documentation

SsApiRc CallBarringHandler::AbortPasswordRequest ( Tipd tipd )

Aborts password request.

Parameters:
tipd Tipd of the request
Returns:
Success

SsApiRc CallBarringHandler::Activate | ( | SsCode | ss_code,
 |  | const WString & | pw,
 |  | ServiceGroup | basic_service = AllServices,
 |  | const WString & | override_ss_sequence = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Activates call barring.
Activates the given call barring kind and optionally for a specific basic service group.
This method triggers sending of *<code dependend on parameter>*<pw>*<mmi_code># to the mobile network.

Parameters:
ss_code | The supplementary service code describing the desired service (all call barrings, barring of all outgoing calls, etc.).
pw | The call barring password.
basic_service | The basic service group the request (all services, all teleservices, etc.), defaults to all services.
override_ss_sequence | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return
or any other value CheckParameterCodes might return.

SsApiRc CallBarringHandler::ChangePassword | ( | const WString & | old_pw,
 |  | const WString & | new_pw,
 |  | const WString & | conf_pw,
 |  | const WString & | override_ss_sequence = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | BOOLEAN | provide_ss_code = TRUE
 | ) |

Changes the call barring password.
Cahnges the password for all call barring services. The call barring password is needed to activate or deactivate the service. This method triggers sending of *03*330*<old_pw>*<new_pw>*<conf_pw># to the mobile network.

Parameters:
old_pw | The old call barring password.
new_pw | The new call barring password.
conf_pw | The confirmation of the new call barring password, this has to match the new_pw string.
override_ss_sequence | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
provide_ss_code | If set to FALSE, *03**.. is sent instead of *03*330*...
Returns:
InvalidServiceCode - if the supplementary service code is not of a call barring kind,
ConfPasswordMismatch - if the new password does not match the confirmation password,
or any other value SsMainHandler::BeginTransaction might return.

SsApiRc CallBarringHandler::Deactivate | ( | SsCode | ss_code,
 |  | const WString & | pw,
 |  | ServiceGroup | basic_service = AllServices,
 |  | const WString & | override_ss_sequence = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Deactivates call barring.
Deactivates the given call barring kind and optionally for a specific basic service group.
This method triggers sending of #<code dependend on parameter>*<pw>*<mmi_code># to the mobile network.

Parameters:
ss_code | The supplementary service code describing the desired service (all call barrings, barring of all outgoing calls, etc.).
pw | The call barring password.
basic_service | The basic service group the request (all services, all teleservices, etc.), defaults to all services.
override_ss_sequence | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return
or any other value CheckParameterCodes might return.

HandlerId CallBarringHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
CallBarringHandlerId

SsApiRc CallBarringHandler::RequestStatus | ( | SsCode | ss_code,
 |  | ServiceGroup | basic_service = AllServices,
 |  | const WString & | override_ss_sequence = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Interrogates the call barring status.
Requests the status of the given call barring kind and optionally for a specific basic service group.
This method triggers sending of *#<code dependend on parameter>*<mmi_code># to the mobile network.

Parameters:
ss_code | The supplementary service code describing the desired service (all call barrings, barring of all outgoing calls, etc.).
basic_service | The basic service group the request (all services, all teleservices, etc.), defaults to all services.
override_ss_sequence | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return
or any other value CheckParameterCodes might return.

SsApiRc CallBarringHandler::SendPassword | ( | Tipd | tipd,
 |  | const WString & | password
 | ) |

Sends a password to the GSM stack upon request.

Parameters:
tipd | Tipd of the request
password | The password sent to the network.
Returns:
Success

The documentation for this class was generated from the following files:
  • Asc/CallBarringHandler.hpp
  • Asc/CallBarringHandler.cpp
Generated on Wed Jan 25 01:03:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarringInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarringInfo Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CallBarringInfo:

[legend]

Data Fields

CallBarringFeatureList feature_list
INT feature_list_size
SsCode sc

Field Documentation

CallBarringFeatureList CallBarringInfo::feature_list

INT CallBarringInfo::feature_list_size

SsCode CallBarringInfo::sc

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:03:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarringPasswordChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarringPasswordChangedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallBarringPasswordChangedMsg:

[legend]
Collaboration diagram for CallBarringPasswordChangedMsg:

[legend]

Public Types

enum | { ID = 18549 }

Public Member Functions

CallBarringPasswordChangedMsg (ExecutionContext *context, const Tipd &tipd, const WString &new_password, const SsCode &param_ss_code, const WString &param_old_password, const WString &param_new_password, const WString &param_conf_password)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetNewPassword () const
const WString & | GetParamConfPassword () const
const WString & | GetParamNewPassword () const
const WString & | GetParamOldPassword () const
const SsCode & | GetParamSsCode () const
const Tipd & | GetTipd () const
virtual | ~CallBarringPasswordChangedMsg ()

Detailed Description

CallBarringPasswordChangedMsg: sent when new CB password was registered

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallBarringPasswordChangedMsg::CallBarringPasswordChangedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const WString & | new_password,
 |  | const SsCode & | param_ss_code,
 |  | const WString & | param_old_password,
 |  | const WString & | param_new_password,
 |  | const WString & | param_conf_password
 | ) |

CallBarringPasswordChangedMsg::~CallBarringPasswordChangedMsg ( ) [virtual]

Member Function Documentation

Message * CallBarringPasswordChangedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & CallBarringPasswordChangedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const WString& CallBarringPasswordChangedMsg::GetNewPassword ( ) const [inline]

const WString& CallBarringPasswordChangedMsg::GetParamConfPassword ( ) const [inline]

const WString& CallBarringPasswordChangedMsg::GetParamNewPassword ( ) const [inline]

const WString& CallBarringPasswordChangedMsg::GetParamOldPassword ( ) const [inline]

const SsCode& CallBarringPasswordChangedMsg::GetParamSsCode ( ) const [inline]

const Tipd& CallBarringPasswordChangedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallBarringStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallBarringStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallBarringStatusMsg:

[legend]
Collaboration diagram for CallBarringStatusMsg:

[legend]

Public Types

enum | { ID = 18544 }

Public Member Functions

CallBarringStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status, const Vector< SsGroup > &basic_service_list, const SsCode &parameter_ss_code, const ServiceGroup &parameter_basic_service)
virtual Message * | Clone () const
const Vector< SsGroup > & | GetBasicServiceList () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParameterBasicService () const
const SsCode & | GetParameterSsCode () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~CallBarringStatusMsg ()

Detailed Description

CallBarringStatusMsg: sent when call barring status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallBarringStatusMsg::CallBarringStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status,
 |  | const Vector< SsGroup > & | basic_service_list,
 |  | const SsCode & | parameter_ss_code,
 |  | const ServiceGroup & | parameter_basic_service
 | ) |

CallBarringStatusMsg::~CallBarringStatusMsg ( ) [virtual]

Member Function Documentation

Message * CallBarringStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<SsGroup>& CallBarringStatusMsg::GetBasicServiceList ( ) const [inline]

const MsgMetaData & CallBarringStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallBarringStatusMsg::GetParameterBasicService ( ) const [inline]

const SsCode& CallBarringStatusMsg::GetParameterSsCode ( ) const [inline]

const SsStatus& CallBarringStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& CallBarringStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallControlIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallControlIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallControlIndMsg:

[legend]
Collaboration diagram for CallControlIndMsg:

[legend]

Public Types

enum | { ID = 18704 }

Public Member Functions

CallControlIndMsg (const CallControlSetupIndArg &arg)
virtual Message * | Clone () const
const CallControlSetupIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallControlSetupIndArg &arg)
virtual | ~CallControlIndMsg ()

Detailed Description

CallControlIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallControlIndMsg::CallControlIndMsg ( const CallControlSetupIndArg & arg )

CallControlIndMsg::~CallControlIndMsg ( ) [virtual]

Member Function Documentation

Message * CallControlIndMsg::Clone ( ) const [virtual]

Implements Message.

const CallControlSetupIndArg& CallControlIndMsg::GetArg ( ) const [inline]

const MsgMetaData & CallControlIndMsg::GetMetaData ( ) const [virtual]

Implements Message.

void CallControlIndMsg::SetArg ( const CallControlSetupIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallControlInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallControlInfoMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallControlInfoMsg:

[legend]
Collaboration diagram for CallControlInfoMsg:

[legend]

Public Types

enum | { ID = 18424 }

Public Member Functions

CallControlInfoMsg (ExecutionContext *context, const CallHdl &call_hdl)
virtual Message * | Clone () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~CallControlInfoMsg ()

Detailed Description

CallControlInfoMsg: sent when MN_CALL_IND_CALL_CONTROL_INFO is received from stack

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallControlInfoMsg::CallControlInfoMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl
 | ) |

CallControlInfoMsg::~CallControlInfoMsg ( ) [virtual]

Member Function Documentation

Message * CallControlInfoMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CallControlInfoMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & CallControlInfoMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallControlSetupIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallControlSetupIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for CallControlSetupIndArg:

[legend]
Collaboration diagram for CallControlSetupIndArg:

[legend]

Public Types

enum | { ID = 5302 }

Public Member Functions

CallControlSetupIndArg ()
const SimCallControlResult & | GetCallControlResult () const
const PhoneNumber & | GetCalledPartyNumber () const
const SimAlphaIdentifier & | GetOrig1TextInfoAlpha () const
const SimAlphaIdentifier & | GetOrig2TextInfoAlpha () const
const SimAlphaIdentifier & | GetTextInfoAlpha () const
BOOLEAN | IsSimtkRelated () const
void | SetCallControlResult (const SimCallControlResult &call_control_result)
void | SetCalledPartyNumber (const PhoneNumber &called_party_number)
void | SetOrig1TextInfoAlpha (const SimAlphaIdentifier &orig_1_text_info_alpha)
void | SetOrig2TextInfoAlpha (const SimAlphaIdentifier &orig_2_text_info_alpha)
void | SetSimtkRelated (BOOLEAN simtk_related)
void | SetTextInfoAlpha (const SimAlphaIdentifier &text_info_alpha)

Static Public Member Functions

static const CallControlSetupIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallControlIndArg: reflects arguments of signal MN_CALL_CONTROL_SETUP_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallControlSetupIndArg::CallControlSetupIndArg ( )

Member Function Documentation

const CallControlSetupIndArg & CallControlSetupIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimCallControlResult& CallControlSetupIndArg::GetCallControlResult ( ) const [inline]

const PhoneNumber& CallControlSetupIndArg::GetCalledPartyNumber ( ) const [inline]

const SimAlphaIdentifier& CallControlSetupIndArg::GetOrig1TextInfoAlpha ( ) const [inline]

const SimAlphaIdentifier& CallControlSetupIndArg::GetOrig2TextInfoAlpha ( ) const [inline]

const SimAlphaIdentifier& CallControlSetupIndArg::GetTextInfoAlpha ( ) const [inline]

BOOLEAN CallControlSetupIndArg::IsSimtkRelated ( ) const [inline]

void CallControlSetupIndArg::SetCallControlResult ( const SimCallControlResult & call_control_result ) [inline]

void CallControlSetupIndArg::SetCalledPartyNumber ( const PhoneNumber & called_party_number ) [inline]

void CallControlSetupIndArg::SetOrig1TextInfoAlpha ( const SimAlphaIdentifier & orig_1_text_info_alpha ) [inline]

void CallControlSetupIndArg::SetOrig2TextInfoAlpha ( const SimAlphaIdentifier & orig_2_text_info_alpha ) [inline]

void CallControlSetupIndArg::SetSimtkRelated ( BOOLEAN simtk_related ) [inline]

void CallControlSetupIndArg::SetTextInfoAlpha ( const SimAlphaIdentifier & text_info_alpha ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:03:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallControlSsIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallControlSsIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for CallControlSsIndArg:

[legend]
Collaboration diagram for CallControlSsIndArg:

[legend]

Public Types

enum | { ID = 5303 }

Public Member Functions

CallControlSsIndArg ()
const SimCallControlResult & | GetCallControlResult () const
const SimAlphaIdentifier & | GetOrig1TextInfoAlpha () const
const SimAlphaIdentifier & | GetTextInfoAlpha () const
const WString & | GetUserInput () const
const DataCodingScheme::Language & | GetUserInputLanguage () const
BOOLEAN | IsSimtkRelated () const
void | SetCallControlResult (const SimCallControlResult &call_control_result)
void | SetOrig1TextInfoAlpha (const SimAlphaIdentifier &orig_1_text_info_alpha)
void | SetSimtkRelated (BOOLEAN simtk_related)
void | SetTextInfoAlpha (const SimAlphaIdentifier &text_info_alpha)
void | SetUserInput (const WString &user_input)
void | SetUserInputLanguage (const DataCodingScheme::Language &user_input_language)

Static Public Member Functions

static const CallControlSsIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallControlIndArg: reflects arguments of signal MN_CALL_CONTROL_SS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallControlSsIndArg::CallControlSsIndArg ( )

Member Function Documentation

const CallControlSsIndArg & CallControlSsIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimCallControlResult& CallControlSsIndArg::GetCallControlResult ( ) const [inline]

const SimAlphaIdentifier& CallControlSsIndArg::GetOrig1TextInfoAlpha ( ) const [inline]

const SimAlphaIdentifier& CallControlSsIndArg::GetTextInfoAlpha ( ) const [inline]

const WString& CallControlSsIndArg::GetUserInput ( ) const [inline]

const DataCodingScheme::Language& CallControlSsIndArg::GetUserInputLanguage ( ) const [inline]

BOOLEAN CallControlSsIndArg::IsSimtkRelated ( ) const [inline]

void CallControlSsIndArg::SetCallControlResult ( const SimCallControlResult & call_control_result ) [inline]

void CallControlSsIndArg::SetOrig1TextInfoAlpha ( const SimAlphaIdentifier & orig_1_text_info_alpha ) [inline]

void CallControlSsIndArg::SetSimtkRelated ( BOOLEAN simtk_related ) [inline]

void CallControlSsIndArg::SetTextInfoAlpha ( const SimAlphaIdentifier & text_info_alpha ) [inline]

void CallControlSsIndArg::SetUserInput ( const WString & user_input ) [inline]

void CallControlSsIndArg::SetUserInputLanguage ( const DataCodingScheme::Language & user_input_language ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:03:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallControlUssdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallControlUssdIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for CallControlUssdIndArg:

[legend]
Collaboration diagram for CallControlUssdIndArg:

[legend]

Public Types

enum | { ID = 5304 }

Public Member Functions

CallControlUssdIndArg ()
const SimCallControlResult & | GetCallControlResult () const
const SimAlphaIdentifier & | GetOrig1TextInfoAlpha () const
const SimAlphaIdentifier & | GetTextInfoAlpha () const
const WString & | GetUserInput () const
const DataCodingScheme::Language & | GetUserInputLanguage () const
BOOLEAN | IsSimtkRelated () const
void | SetCallControlResult (const SimCallControlResult &call_control_result)
void | SetOrig1TextInfoAlpha (const SimAlphaIdentifier &orig_1_text_info_alpha)
void | SetSimtkRelated (BOOLEAN simtk_related)
void | SetTextInfoAlpha (const SimAlphaIdentifier &text_info_alpha)
void | SetUserInput (const WString &user_input)
void | SetUserInputLanguage (const DataCodingScheme::Language &user_input_language)

Static Public Member Functions

static const CallControlUssdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallControlIndArg: reflects arguments of signal MN_CALL_CONTROL_USSD_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallControlUssdIndArg::CallControlUssdIndArg ( )

Member Function Documentation

const CallControlUssdIndArg & CallControlUssdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimCallControlResult& CallControlUssdIndArg::GetCallControlResult ( ) const [inline]

const SimAlphaIdentifier& CallControlUssdIndArg::GetOrig1TextInfoAlpha ( ) const [inline]

const SimAlphaIdentifier& CallControlUssdIndArg::GetTextInfoAlpha ( ) const [inline]

const WString& CallControlUssdIndArg::GetUserInput ( ) const [inline]

const DataCodingScheme::Language& CallControlUssdIndArg::GetUserInputLanguage ( ) const [inline]

BOOLEAN CallControlUssdIndArg::IsSimtkRelated ( ) const [inline]

void CallControlUssdIndArg::SetCallControlResult ( const SimCallControlResult & call_control_result ) [inline]

void CallControlUssdIndArg::SetOrig1TextInfoAlpha ( const SimAlphaIdentifier & orig_1_text_info_alpha ) [inline]

void CallControlUssdIndArg::SetSimtkRelated ( BOOLEAN simtk_related ) [inline]

void CallControlUssdIndArg::SetTextInfoAlpha ( const SimAlphaIdentifier & text_info_alpha ) [inline]

void CallControlUssdIndArg::SetUserInput ( const WString & user_input ) [inline]

void CallControlUssdIndArg::SetUserInputLanguage ( const DataCodingScheme::Language & user_input_language ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:03:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDeflectionErrIndicationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDeflectionErrIndicationMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallDeflectionErrIndicationMsg:

[legend]
Collaboration diagram for CallDeflectionErrIndicationMsg:

[legend]

Public Types

enum | { ID = 18954 }

Public Member Functions

CallDeflectionErrIndicationMsg (ExecutionContext *context, const SsErrIndArg &arg)
virtual Message * | Clone () const
const SsErrIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SsErrIndArg &arg)
virtual | ~CallDeflectionErrIndicationMsg ()

Detailed Description

SsErrIndicationMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDeflectionErrIndicationMsg::CallDeflectionErrIndicationMsg | ( | ExecutionContext * | context,
 |  | const SsErrIndArg & | arg
 | ) |

CallDeflectionErrIndicationMsg::~CallDeflectionErrIndicationMsg ( ) [virtual]

Member Function Documentation

Message * CallDeflectionErrIndicationMsg::Clone ( ) const [virtual]

Implements Message.

const SsErrIndArg& CallDeflectionErrIndicationMsg::GetArg ( ) const [inline]

const MsgMetaData & CallDeflectionErrIndicationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallDeflectionErrIndicationMsg::SetArg ( const SsErrIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDeflectionHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDeflectionHandler Class Reference

#include <Apoxi/Asc/CallDeflectionHandler.hpp>

Public Types

enum | { ID = CallDeflectionHandlerId }

Public Member Functions

CallDeflectionHandler ()
virtual HandlerId | GetHandlerId () const
CallApiRc | ProcessCallDeflectRequest (PhoneNumber deflect_number)
virtual | ~CallDeflectionHandler ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDeflectionHandler::CallDeflectionHandler ( )

CallDeflectionHandler::~CallDeflectionHandler ( ) [virtual]

Member Function Documentation

HandlerId CallDeflectionHandler::GetHandlerId ( ) const [virtual]

CallApiRc CallDeflectionHandler::ProcessCallDeflectRequest ( PhoneNumber deflect_number )

The documentation for this class was generated from the following files:
  • Asc/CallDeflectionHandler.hpp
  • Asc/CallDeflectionHandler.cpp
Generated on Wed Jan 25 01:03:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDeflectionIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDeflectionIndArg Class Reference

#include <Apoxi/Apc/CdStackMsgArgs.hpp>

Inheritance diagram for CallDeflectionIndArg:

[legend]
Collaboration diagram for CallDeflectionIndArg:

[legend]

Public Types

enum | { ID = 1069 }

Public Member Functions

CallDeflectionIndArg ()
const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallDeflectionIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallDeflectionIndArg: reflects arguments of signal MN_CALL_DEFLECTION_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDeflectionIndArg::CallDeflectionIndArg ( )

Member Function Documentation

const CallDeflectionIndArg & CallDeflectionIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& CallDeflectionIndArg::GetTipd ( ) const [inline]

void CallDeflectionIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CdStackMsgArgs.hpp
  • Apc/CdStackMsgArgs.cpp
Generated on Wed Jan 25 01:03:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDeflectionIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDeflectionIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallDeflectionIndMsg:

[legend]
Collaboration diagram for CallDeflectionIndMsg:

[legend]

Public Types

enum | { ID = 18953 }

Public Member Functions

CallDeflectionIndMsg (ExecutionContext *context, const CallDeflectionIndArg &arg)
virtual Message * | Clone () const
const CallDeflectionIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallDeflectionIndArg &arg)
virtual | ~CallDeflectionIndMsg ()

Detailed Description

CallDeflectionIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDeflectionIndMsg::CallDeflectionIndMsg | ( | ExecutionContext * | context,
 |  | const CallDeflectionIndArg & | arg
 | ) |

CallDeflectionIndMsg::~CallDeflectionIndMsg ( ) [virtual]

Member Function Documentation

Message * CallDeflectionIndMsg::Clone ( ) const [virtual]

Implements Message.

const CallDeflectionIndArg& CallDeflectionIndMsg::GetArg ( ) const [inline]

const MsgMetaData & CallDeflectionIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallDeflectionIndMsg::SetArg ( const CallDeflectionIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDeflectionRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDeflectionRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallDeflectionRejectedMsg:

[legend]
Collaboration diagram for CallDeflectionRejectedMsg:

[legend]

Public Types

enum | { ID = 18955 }

Public Member Functions

CallDeflectionRejectedMsg (ExecutionContext *context, const SsRejArg &arg)
virtual Message * | Clone () const
const SsRejArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SsRejArg &arg)
virtual | ~CallDeflectionRejectedMsg ()

Detailed Description

SsRejectedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDeflectionRejectedMsg::CallDeflectionRejectedMsg | ( | ExecutionContext * | context,
 |  | const SsRejArg & | arg
 | ) |

CallDeflectionRejectedMsg::~CallDeflectionRejectedMsg ( ) [virtual]

Member Function Documentation

Message * CallDeflectionRejectedMsg::Clone ( ) const [virtual]

Implements Message.

const SsRejArg& CallDeflectionRejectedMsg::GetArg ( ) const [inline]

const MsgMetaData & CallDeflectionRejectedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallDeflectionRejectedMsg::SetArg ( const SsRejArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDeflectSsReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDeflectSsReqArg Class Reference

#include <Apoxi/Apc/CdStackMsgArgs.hpp>

Inheritance diagram for CallDeflectSsReqArg:

[legend]
Collaboration diagram for CallDeflectSsReqArg:

[legend]

Public Types

enum | { ID = 2065 }

Public Member Functions

CallDeflectSsReqArg ()
CallDeflectSsReqArg (const Tipd &tipd, const CallRelatedSs &call_related_ss, const PhoneNumber &deflect_number)
const CallRelatedSs & | GetCallRelatedSs () const
const PhoneNumber & | GetDeflectNumber () const
const Tipd & | GetTipd () const
void | SetCallRelatedSs (const CallRelatedSs &call_related_ss)
void | SetDeflectNumber (const PhoneNumber &deflect_number)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallDeflectSsReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallDeflectSsReqArg: reflects arguments of signal MN_CRSS_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDeflectSsReqArg::CallDeflectSsReqArg | ( | const Tipd & | tipd,
 |  | const CallRelatedSs & | call_related_ss,
 |  | const PhoneNumber & | deflect_number
 | ) |

CallDeflectSsReqArg::CallDeflectSsReqArg ( )

Member Function Documentation

const CallDeflectSsReqArg & CallDeflectSsReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallRelatedSs& CallDeflectSsReqArg::GetCallRelatedSs ( ) const [inline]

const PhoneNumber& CallDeflectSsReqArg::GetDeflectNumber ( ) const [inline]

const Tipd& CallDeflectSsReqArg::GetTipd ( ) const [inline]

void CallDeflectSsReqArg::SetCallRelatedSs ( const CallRelatedSs & call_related_ss ) [inline]

void CallDeflectSsReqArg::SetDeflectNumber ( const PhoneNumber & deflect_number ) [inline]

void CallDeflectSsReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CdStackMsgArgs.hpp
  • Apc/CdStackMsgArgs.cpp
Generated on Wed Jan 25 01:03:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDiscIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDiscIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CallDiscIndArg:

[legend]
Collaboration diagram for CallDiscIndArg:

[legend]

Public Types

enum | { ID = 1121 }

Public Member Functions

CallDiscIndArg ()
const CallErrorCause & | GetCallDiscCause () const
const Tipd & | GetTipd () const
void | SetCallDiscCause (const CallErrorCause &call_disc_cause)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallDiscIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallDiscIndArg: reflects arguments of signal MN_DISC_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDiscIndArg::CallDiscIndArg ( )

Member Function Documentation

const CallDiscIndArg & CallDiscIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& CallDiscIndArg::GetCallDiscCause ( ) const [inline]

const Tipd& CallDiscIndArg::GetTipd ( ) const [inline]

void CallDiscIndArg::SetCallDiscCause ( const CallErrorCause & call_disc_cause ) [inline]

void CallDiscIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:03:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDisconnectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDisconnectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallDisconnectedMsg:

[legend]
Collaboration diagram for CallDisconnectedMsg:

[legend]

Public Types

enum | { ID = 18406 }

Public Member Functions

CallDisconnectedMsg (ExecutionContext *context, const CallHdl &arg, const DisconnectingMode &disconnecting_mode)
virtual Message * | Clone () const
const CallHdl & | GetArg () const
const DisconnectingMode & | GetDisconnectingMode () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallHdl &arg)
void | SetDisconnectingMode (const DisconnectingMode &disconnecting_mode)
virtual | ~CallDisconnectedMsg ()

Detailed Description

CallDisconnectedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDisconnectedMsg::CallDisconnectedMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | arg,
 |  | const DisconnectingMode & | disconnecting_mode
 | ) |

CallDisconnectedMsg::~CallDisconnectedMsg ( ) [virtual]

Member Function Documentation

Message * CallDisconnectedMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CallDisconnectedMsg::GetArg ( ) const [inline]

const DisconnectingMode& CallDisconnectedMsg::GetDisconnectingMode ( ) const [inline]

const MsgMetaData & CallDisconnectedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallDisconnectedMsg::SetArg ( const CallHdl & arg ) [inline]

void CallDisconnectedMsg::SetDisconnectingMode ( const DisconnectingMode & disconnecting_mode ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDisconnectingArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDisconnectingArg Struct Reference
[APOXI Stack Control]

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for CallDisconnectingArg:

[legend]

Data Fields

CallHdl call
TimeSpan call_duration
CallErrorCause cause
PhoneNumber phone_no

Detailed Description

CallDisconnectedArg contains all the data sent when a call is disconnected by the network.

Field Documentation

CallHdl CallDisconnectingArg::call

TimeSpan CallDisconnectingArg::call_duration

CallErrorCause CallDisconnectingArg::cause

PhoneNumber CallDisconnectingArg::phone_no

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 01:03:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDisconnectingMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDisconnectingMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallDisconnectingMsg:

[legend]
Collaboration diagram for CallDisconnectingMsg:

[legend]

Public Types

enum | { ID = 18405 }

Public Member Functions

CallDisconnectingMsg (ExecutionContext *context, const CallDisconnectingArg &arg, const DisconnectingMode &disconnecting_mode)
virtual Message * | Clone () const
const CallDisconnectingArg & | GetArg () const
const DisconnectingMode & | GetDisconnectingMode () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallDisconnectingArg &arg)
void | SetDisconnectingMode (const DisconnectingMode &disconnecting_mode)
virtual | ~CallDisconnectingMsg ()

Detailed Description

CallDisconnectingMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDisconnectingMsg::CallDisconnectingMsg | ( | ExecutionContext * | context,
 |  | const CallDisconnectingArg & | arg,
 |  | const DisconnectingMode & | disconnecting_mode
 | ) |

CallDisconnectingMsg::~CallDisconnectingMsg ( ) [virtual]

Member Function Documentation

Message * CallDisconnectingMsg::Clone ( ) const [virtual]

Implements Message.

const CallDisconnectingArg& CallDisconnectingMsg::GetArg ( ) const [inline]

const DisconnectingMode& CallDisconnectingMsg::GetDisconnectingMode ( ) const [inline]

const MsgMetaData & CallDisconnectingMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallDisconnectingMsg::SetArg ( const CallDisconnectingArg & arg ) [inline]

void CallDisconnectingMsg::SetDisconnectingMode ( const DisconnectingMode & disconnecting_mode ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallDiscReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallDiscReqArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CallDiscReqArg:

[legend]
Collaboration diagram for CallDiscReqArg:

[legend]

Public Types

enum | { ID = 2120 }

Public Member Functions

CallDiscReqArg ()
CallDiscReqArg (const Tipd &tipd, const CallErrorCause &call_disc_cause)
const CallErrorCause & | GetCallDiscCause () const
const Tipd & | GetTipd () const
void | SetCallDiscCause (const CallErrorCause &call_disc_cause)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallDiscReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallDiscReqArg: reflects arguments of signal MN_DISC_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallDiscReqArg::CallDiscReqArg | ( | const Tipd & | tipd,
 |  | const CallErrorCause & | call_disc_cause
 | ) |

CallDiscReqArg::CallDiscReqArg ( )

Member Function Documentation

const CallDiscReqArg & CallDiscReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& CallDiscReqArg::GetCallDiscCause ( ) const [inline]

const Tipd& CallDiscReqArg::GetTipd ( ) const [inline]

void CallDiscReqArg::SetCallDiscCause ( const CallErrorCause & call_disc_cause ) [inline]

void CallDiscReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:03:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalledPartyAlertingMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CalledPartyAlertingMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CalledPartyAlertingMsg:

[legend]
Collaboration diagram for CalledPartyAlertingMsg:

[legend]

Public Types

enum | { ID = 18401 }

Public Member Functions

CalledPartyAlertingMsg (ExecutionContext *context, const CallHdl &arg)
virtual Message * | Clone () const
const CallHdl & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallHdl &arg)
virtual | ~CalledPartyAlertingMsg ()

Detailed Description

CalledPartyAlertingMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CalledPartyAlertingMsg::CalledPartyAlertingMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | arg
 | ) |

CalledPartyAlertingMsg::~CalledPartyAlertingMsg ( ) [virtual]

Member Function Documentation

Message * CalledPartyAlertingMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CalledPartyAlertingMsg::GetArg ( ) const [inline]

const MsgMetaData & CalledPartyAlertingMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CalledPartyAlertingMsg::SetArg ( const CallHdl & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallEvent Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallEvent Struct Reference
[APOXI Stack Control]

A simple structure providing information on an event happened to a particular call. More...

#include <Apoxi/Asc/Types.hpp>

Collaboration diagram for CallEvent:

[legend]

Public Types

enum Action {
MocInSetup, MocEstablished, MocRejected, MtcIsWaiting,
MtcEstablished, CallReleased, CallDisconnected, CallIsHeld,
CallRetrieved, EctAccomplished, MultipartyJoin, MultiPartyOnHold,
MultiPartyRetrieved, MultiPartyReleased, MultiPartySplitted, MmMocInSetup,
MmMocEstablished, MmMocRejected, MmMtcIsWaiting, MmMtcEstablished,
MmCallReleased, MmCallDisconnected
}

Data Fields

Action action
CallIndex call_index

Detailed Description

A simple structure providing information on an event happened to a particular call.

Member Enumeration Documentation

enum CallEvent::Action

Enumerator:
MocInSetup
MocEstablished
MocRejected
MtcIsWaiting
MtcEstablished
CallReleased
CallDisconnected
CallIsHeld
CallRetrieved
EctAccomplished
MultipartyJoin
MultiPartyOnHold
MultiPartyRetrieved
MultiPartyReleased
MultiPartySplitted
MmMocInSetup
MmMocEstablished
MmMocRejected
MmMtcIsWaiting
MmMtcEstablished
MmCallReleased
MmCallDisconnected

Field Documentation

Action CallEvent::action

CallIndex CallEvent::call_index

The documentation for this struct was generated from the following file:
  • Asc/Types.hpp
Generated on Wed Jan 25 01:03:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallEventMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallEventMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallEventMsg:

[legend]
Collaboration diagram for CallEventMsg:

[legend]

Public Types

enum | { ID = 18703 }

Public Member Functions

CallEventMsg (const CallEvent &event)
virtual Message * | Clone () const
const CallEvent & | GetEvent () const
virtual const MsgMetaData & | GetMetaData () const
void | SetEvent (const CallEvent &event)
virtual | ~CallEventMsg ()

Detailed Description

CallEventMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallEventMsg::CallEventMsg ( const CallEvent & event )

CallEventMsg::~CallEventMsg ( ) [virtual]

Member Function Documentation

Message * CallEventMsg::Clone ( ) const [virtual]

Implements Message.

const CallEvent& CallEventMsg::GetEvent ( ) const [inline]

const MsgMetaData & CallEventMsg::GetMetaData ( ) const [virtual]

Implements Message.

void CallEventMsg::SetEvent ( const CallEvent & event ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:03:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallForwardingActivatedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallForwardingActivatedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallForwardingActivatedMsg:

[legend]
Collaboration diagram for CallForwardingActivatedMsg:

[legend]

Public Types

enum | { ID = 18537 }

Public Member Functions

CallForwardingActivatedMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code, const Vector< ForwardingFeature > &forwarding_features, const SsCode &parameter_ss_code, const ServiceGroup &parameter_basic_service, const PhoneNumber &parameter_phonenumber, UINT parameter_time_out)
virtual Message * | Clone () const
const Vector< ForwardingFeature > & | GetForwardingFeatures () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParameterBasicService () const
const PhoneNumber & | GetParameterPhonenumber () const
const SsCode & | GetParameterSsCode () const
UINT | GetParameterTimeOut () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
virtual | ~CallForwardingActivatedMsg ()

Detailed Description

CallForwardingActivatedMsg: sent when call forwarding was activated

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallForwardingActivatedMsg::CallForwardingActivatedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code,
 |  | const Vector< ForwardingFeature > & | forwarding_features,
 |  | const SsCode & | parameter_ss_code,
 |  | const ServiceGroup & | parameter_basic_service,
 |  | const PhoneNumber & | parameter_phonenumber,
 |  | UINT | parameter_time_out
 | ) |

CallForwardingActivatedMsg::~CallForwardingActivatedMsg ( ) [virtual]

Member Function Documentation

Message * CallForwardingActivatedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<ForwardingFeature>& CallForwardingActivatedMsg::GetForwardingFeatures ( ) const [inline]

const MsgMetaData & CallForwardingActivatedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallForwardingActivatedMsg::GetParameterBasicService ( ) const [inline]

const PhoneNumber& CallForwardingActivatedMsg::GetParameterPhonenumber ( ) const [inline]

const SsCode& CallForwardingActivatedMsg::GetParameterSsCode ( ) const [inline]

UINT CallForwardingActivatedMsg::GetParameterTimeOut ( ) const [inline]

const SsCode& CallForwardingActivatedMsg::GetSsCode ( ) const [inline]

const Tipd& CallForwardingActivatedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallForwardingActiveMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallForwardingActiveMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallForwardingActiveMsg:

[legend]
Collaboration diagram for CallForwardingActiveMsg:

[legend]

Public Types

enum | { ID = 18525 }

Public Member Functions

CallForwardingActiveMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
virtual | ~CallForwardingActiveMsg ()

Detailed Description

CallForwardingActiveMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallForwardingActiveMsg::CallForwardingActiveMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code
 | ) |

CallForwardingActiveMsg::~CallForwardingActiveMsg ( ) [virtual]

Member Function Documentation

Message * CallForwardingActiveMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & CallForwardingActiveMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& CallForwardingActiveMsg::GetSsCode ( ) const [inline]

const Tipd& CallForwardingActiveMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallForwardingDeactivatedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallForwardingDeactivatedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallForwardingDeactivatedMsg:

[legend]
Collaboration diagram for CallForwardingDeactivatedMsg:

[legend]

Public Types

enum | { ID = 18538 }

Public Member Functions

CallForwardingDeactivatedMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code, const Vector< ForwardingFeature > &forwarding_features, const SsCode &parameter_ss_code, const ServiceGroup &parameter_basic_service)
virtual Message * | Clone () const
const Vector< ForwardingFeature > & | GetForwardingFeatures () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParameterBasicService () const
const SsCode & | GetParameterSsCode () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
virtual | ~CallForwardingDeactivatedMsg ()

Detailed Description

CallForwardingDeactivatedMsg: sent when CallForwarding was deactivated

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallForwardingDeactivatedMsg::CallForwardingDeactivatedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code,
 |  | const Vector< ForwardingFeature > & | forwarding_features,
 |  | const SsCode & | parameter_ss_code,
 |  | const ServiceGroup & | parameter_basic_service
 | ) |

CallForwardingDeactivatedMsg::~CallForwardingDeactivatedMsg ( ) [virtual]

Member Function Documentation

Message * CallForwardingDeactivatedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<ForwardingFeature>& CallForwardingDeactivatedMsg::GetForwardingFeatures ( ) const [inline]

const MsgMetaData & CallForwardingDeactivatedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallForwardingDeactivatedMsg::GetParameterBasicService ( ) const [inline]

const SsCode& CallForwardingDeactivatedMsg::GetParameterSsCode ( ) const [inline]

const SsCode& CallForwardingDeactivatedMsg::GetSsCode ( ) const [inline]

const Tipd& CallForwardingDeactivatedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallForwardingErasedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallForwardingErasedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallForwardingErasedMsg:

[legend]
Collaboration diagram for CallForwardingErasedMsg:

[legend]

Public Types

enum | { ID = 18541 }

Public Member Functions

CallForwardingErasedMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code, const Vector< ForwardingFeature > &forwarding_features, const SsCode &parameter_ss_code, const ServiceGroup &parameter_basic_service)
virtual Message * | Clone () const
const Vector< ForwardingFeature > & | GetForwardingFeatures () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParameterBasicService () const
const SsCode & | GetParameterSsCode () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
virtual | ~CallForwardingErasedMsg ()

Detailed Description

CallForwardingErasedMsg: sent when CallForwarding was erased

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallForwardingErasedMsg::CallForwardingErasedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code,
 |  | const Vector< ForwardingFeature > & | forwarding_features,
 |  | const SsCode & | parameter_ss_code,
 |  | const ServiceGroup & | parameter_basic_service
 | ) |

CallForwardingErasedMsg::~CallForwardingErasedMsg ( ) [virtual]

Member Function Documentation

Message * CallForwardingErasedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<ForwardingFeature>& CallForwardingErasedMsg::GetForwardingFeatures ( ) const [inline]

const MsgMetaData & CallForwardingErasedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallForwardingErasedMsg::GetParameterBasicService ( ) const [inline]

const SsCode& CallForwardingErasedMsg::GetParameterSsCode ( ) const [inline]

const SsCode& CallForwardingErasedMsg::GetSsCode ( ) const [inline]

const Tipd& CallForwardingErasedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallForwardingHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallForwardingHandler Class Reference

#include <Apoxi/Asc/CallForwardingHandler.hpp>

Collaboration diagram for CallForwardingHandler:

[legend]

Public Types

enum | { ID = CallForwardingHandlerId }

Public Member Functions

SsApiRc | Activate (SsCode ss_code, ServiceGroup basic_service=AllServices, const WString override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
SsApiRc | Activate (SsCode ss_code, const PhoneNumber &number, UINT time_out=0, const WString override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
SsApiRc | Activate (SsCode ss_code, ServiceGroup basic_service, const PhoneNumber &number, UINT time_out=0, const WString override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
CallForwardingHandler ()
SsApiRc | Deactivate (SsCode ss_code, ServiceGroup basic_service=AllServices, const WString override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
SsApiRc | Erase (SsCode ss_code, ServiceGroup basic_service=AllServices, const WString override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
virtual HandlerId | GetHandlerId () const
SsApiRc | Register (SsCode ss_code, ServiceGroup basic_service, const PhoneNumber &number, UINT time_out=0, const WString override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
SsApiRc | Register (SsCode ss_code, const PhoneNumber &number, UINT time_out=0, const WString override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
SsApiRc | RequestStatus (SsCode ss_code, ServiceGroup basic_service=AllServices, const WString override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)

Protected Member Functions

virtual ReturnCode | ProcessStackMsgArgument (const SsStackMsgArgument &arg)

Detailed Description

The CallForwardingHandler is a SS handler responsible for modifying the Call Forwarding SS. This includes registering and erasing numbers for specific services, activating and deactivating those services as well as interrogating their current status. The handler provides various methods with different parameter signatures for these purposes. The call forwarding supplementary service consists of this set of subservices:
  • all call forwardings
  • unconditionally forward the call
  • all conditional call forwardings
  • forward the call if the subscriber is busy
  • forward the call if the subscriber does not pick up
  • forward the call if the subsicriber is not reachable
Therefore the desired subservice or subservice group has to specified.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Constructor & Destructor Documentation

CallForwardingHandler::CallForwardingHandler ( )

Creates a new handler instance and initialises the attributes.

Member Function Documentation

SsApiRc CallForwardingHandler::Activate | ( | SsCode | ss_code,
 |  | ServiceGroup | basic_service = AllServices,
 |  | const WString | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Activates call forwarding.
Activates the given call forwarding kind and optionally for a specific basic service group.
Only call forwardings which were registered beforehand may be activated this way.
This method triggers sending of *<code dependend on parameter>*<mmi_code># to the mobile network. The actual function is delegated to the ExecuteRequest.

Parameters:
ss_code | The supplementary service code describing the desired service (all call forwardings, conditional call forwardings, etc.).
basic_service | The basic service group of the request (all services, all teleservices, etc.), defaults to all services.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any code ExecuteRequest might return.

SsApiRc CallForwardingHandler::Activate | ( | SsCode | ss_code,
 |  | const PhoneNumber & | number,
 |  | UINT | time_out = 0,
 |  | const WString | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Activates call forwarding.
Activates the given call forwarding kind for all basic service groups.
This call includes the registration with the specified phone number and if applicable time out. This method triggers sending of *<code dependend on parameter>*<number>**<time_out># to the mobile network. The actual function is delegated to the ExecuteRequest.

Parameters:
ss_code | The supplementary service code describing the desired service (all call forwardings, conditional call forwardings, etc.).
number | The phone number to set the call forwarding to.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
time_out | The time out needed for call forwarding on no answer if applicable, defaults to 0.
Returns:
Any code ExecuteRequest might return.

SsApiRc CallForwardingHandler::Activate | ( | SsCode | ss_code,
 |  | ServiceGroup | basic_service,
 |  | const PhoneNumber & | number,
 |  | UINT | time_out = 0,
 |  | const WString | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Activates call forwarding.
Activates the given call forwarding kind for a specific basic service group.
This call includes the registration with the specified phone number and if applicable time out. This method triggers sending of *<code dependend on parameter>*<number>*<mmi_code>*<time_out># to the mobile network. The actual function is delegated to the ExecuteRequest.

Parameters:
ss_code | The supplementary service code describing the desired service (all call forwardings, conditional call forwardings, etc.).
basic_service | The basic service group of the request (all services, all teleservices, etc.), defaults to all services.
number | The phone number to set the call forwarding to.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
time_out | The time out needed for call forwarding on no answer if applicable, defaults to 0.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any code ExecuteRequest might return.

SsApiRc CallForwardingHandler::Deactivate | ( | SsCode | ss_code,
 |  | ServiceGroup | basic_service = AllServices,
 |  | const WString | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Deactivates call forwarding.
Deactivates the given call forwarding kind and optionally for a specific basic service group.
This method triggers sending of #<code dependend on parameter>*<mmi_code># to the mobile network. The actual function is delegated to the ExecuteRequest.

Parameters:
ss_code | The supplementary service code describing the desired service (all call forwardings, conditional call forwardings, etc.).
basic_service | The basic service group of the request (all services, all teleservices, etc.), defaults to all services.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any code ExecuteRequest might return.

SsApiRc CallForwardingHandler::Erase | ( | SsCode | ss_code,
 |  | ServiceGroup | basic_service = AllServices,
 |  | const WString | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Erases a previously set call forwarding.
Erases and deactivates the given call forwarding kind and optionally for a specific basic service group.
This method triggers sending of ##<code dependend on parameter>*<mmi_code># to the mobile network. The actual function is delegated to the ExecuteRequest.

Parameters:
ss_code | The supplementary service code describing the desired service (all call forwardings, conditional call forwardings, etc.).
basic_service | The basic service group of the request (all services, all teleservices, etc.), defaults to all services.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any code ExecuteRequest might return.

HandlerId CallForwardingHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
CallForwardingHandlerId

SsBaseHandler::ReturnCode CallForwardingHandler::ProcessStackMsgArgument ( const SsStackMsgArgument & arg ) [protected, virtual]

This method is called by the SsDispatcher upon receiving a StackMsgArgument. The method checks whether the given argument is processable in any way (contains correct data), creates a new message object using the appropriate Create*Msg methods and stores the message by means of its superclass.

Parameters:
arg The wrapper object which should contain either a SsForwardingIndArg, a SsInterrogateIndArg or a SsRetResIndArg to be processed.
Returns:
OkNoMessage - if a message was created,
TipdMismatch - if the tipd of the argument does not match the tipd of the current transaction,
OperationCodeMismatch - if the argument's operation code does not match the expected operation code associated with the initial request,
UnexpectedSsCode - if the supplementary service code is not of a call forwarding kind,
UnexpectedArgument - if the argument is not either a SsForwardingIndArg, SsInterrogateIndArg or a SsRetResIndArg,
or any other code the Create*Msg methods might return.
See also:
SsBaseHandler

SsDispatcher

SsApiRc CallForwardingHandler::Register | ( | SsCode | ss_code,
 |  | ServiceGroup | basic_service,
 |  | const PhoneNumber & | number,
 |  | UINT | time_out = 0,
 |  | const WString | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Registers call forwarding.
Registers the given call forwarding kind for a specific basic service group with the specified phone number and if applicable time out.
This method triggers sending of **<code dependend on parameter>*<number>*<mmi_code>*<time_out># to the mobile network. The actual function is delegated to the ExecuteRequest.

Parameters:
ss_code | The supplementary service code describing the desired service (all call forwardings, conditional call forwardings, etc.).
basic_service | The basic service group of the request (all services, all teleservices, etc.), defaults to all services.
number | The phone number to set the call forwarding to.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
time_out | The time out needed for call forwarding on no answer if applicable, defaults to 0.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
InvalidPhoneNumber - if the phone number is empty or otherwise illegal,
or any other code ExecuteRequest might return.

SsApiRc CallForwardingHandler::Register | ( | SsCode | ss_code,
 |  | const PhoneNumber & | number,
 |  | UINT | time_out = 0,
 |  | const WString | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Registers call forwarding.
Registers the given call forwarding kind for all basic service groups with the specified phone number and if applicable time out.
This method triggers sending of **<code dependend on parameter>*<number>**<time_out># to the mobile network. The actual function is delegated to the ExecuteRequest.

Parameters:
ss_code | The supplementary service code describing the desired service (all call forwardings, conditional call forwardings, etc.).
number | The phone number to set the call forwarding to.
time_out | The time out needed for call forwarding on no answer if applicable, defaults to 0.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
Returns:
InvalidPhoneNumber - if the phone number is empty or otherwise illegal,
or any other code ExecuteRequest might return.

SsApiRc CallForwardingHandler::RequestStatus | ( | SsCode | ss_code,
 |  | ServiceGroup | basic_service = AllServices,
 |  | const WString | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Interrogates the call forwarding status.
Requests the status of the given call forwarding kind and optionally for a specific basic service group.
This method triggers sending of *#<code dependend on parameter>*<mmi_code># to the mobile network. The actual function is delegated to the ExecuteRequest.

Parameters:
ss_code | The supplementary service code describing the desired service (all call forwardings, conditional call forwardings, etc.).
basic_service | The basic service group of the request (all services, all teleservices, etc.), defaults to all services.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any code ExecuteRequest might return.

The documentation for this class was generated from the following files:
  • Asc/CallForwardingHandler.hpp
  • Asc/CallForwardingHandler.cpp
Generated on Wed Jan 25 01:04:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallForwardingRegisteredMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallForwardingRegisteredMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallForwardingRegisteredMsg:

[legend]
Collaboration diagram for CallForwardingRegisteredMsg:

[legend]

Public Types

enum | { ID = 18540 }

Public Member Functions

CallForwardingRegisteredMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code, const Vector< ForwardingFeature > &forwarding_features, const SsCode &parameter_ss_code, const ServiceGroup &parameter_basic_service, const PhoneNumber &parameter_phonenumber, UINT parameter_time_out)
virtual Message * | Clone () const
const Vector< ForwardingFeature > & | GetForwardingFeatures () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParameterBasicService () const
const PhoneNumber & | GetParameterPhonenumber () const
const SsCode & | GetParameterSsCode () const
UINT | GetParameterTimeOut () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
virtual | ~CallForwardingRegisteredMsg ()

Detailed Description

CallForwardingRegisteredMsg: sent when CallForwarding was registered

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallForwardingRegisteredMsg::CallForwardingRegisteredMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code,
 |  | const Vector< ForwardingFeature > & | forwarding_features,
 |  | const SsCode & | parameter_ss_code,
 |  | const ServiceGroup & | parameter_basic_service,
 |  | const PhoneNumber & | parameter_phonenumber,
 |  | UINT | parameter_time_out
 | ) |

CallForwardingRegisteredMsg::~CallForwardingRegisteredMsg ( ) [virtual]

Member Function Documentation

Message * CallForwardingRegisteredMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<ForwardingFeature>& CallForwardingRegisteredMsg::GetForwardingFeatures ( ) const [inline]

const MsgMetaData & CallForwardingRegisteredMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallForwardingRegisteredMsg::GetParameterBasicService ( ) const [inline]

const PhoneNumber& CallForwardingRegisteredMsg::GetParameterPhonenumber ( ) const [inline]

const SsCode& CallForwardingRegisteredMsg::GetParameterSsCode ( ) const [inline]

UINT CallForwardingRegisteredMsg::GetParameterTimeOut ( ) const [inline]

const SsCode& CallForwardingRegisteredMsg::GetSsCode ( ) const [inline]

const Tipd& CallForwardingRegisteredMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallForwardingStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallForwardingStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallForwardingStatusMsg:

[legend]
Collaboration diagram for CallForwardingStatusMsg:

[legend]

Public Types

enum | { ID = 18539 }

Public Member Functions

CallForwardingStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status, const Vector< ForwardingFeature > &forwarding_features, const SsCode &parameter_ss_code, const ServiceGroup &parameter_basic_service)
virtual Message * | Clone () const
const Vector< ForwardingFeature > & | GetForwardingFeatures () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParameterBasicService () const
const SsCode & | GetParameterSsCode () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~CallForwardingStatusMsg ()

Detailed Description

CallForwardingStatusMsg: sent when CallForwarding status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallForwardingStatusMsg::CallForwardingStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status,
 |  | const Vector< ForwardingFeature > & | forwarding_features,
 |  | const SsCode & | parameter_ss_code,
 |  | const ServiceGroup & | parameter_basic_service
 | ) |

CallForwardingStatusMsg::~CallForwardingStatusMsg ( ) [virtual]

Member Function Documentation

Message * CallForwardingStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<ForwardingFeature>& CallForwardingStatusMsg::GetForwardingFeatures ( ) const [inline]

const MsgMetaData & CallForwardingStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallForwardingStatusMsg::GetParameterBasicService ( ) const [inline]

const SsCode& CallForwardingStatusMsg::GetParameterSsCode ( ) const [inline]

const SsStatus& CallForwardingStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& CallForwardingStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CallHandler.hpp>

Public Types

enum | { ID = CallHandlerId }

Public Member Functions

CallHandler ()
Sets the pointer to the CallDispatcher in the base class.
CallDispatcher * | GetCallDispatcher ()
DtmfDispatcher * | GetDtmfDispatcher ()
virtual HandlerId | GetHandlerId () const
CallApiRc | Release (CallIndex call_index, UINT32 &call_duration, CallErrorCause cause, BOOLEAN wait_condition=FALSE)
CallApiRc | StartDtmfToneGeneration (CallIndex idx, KeyCode key)
CallApiRc | StopDtmfToneGeneration (CallIndex idx)
virtual | ~CallHandler ()

Static Public Member Functions

static void | ClearBlacklist ()
Method for manual clearing of the blacklist. Always successful.
static BOOLEAN | GetDefaultClirMode (ClirMode &clir_mode)
Get default CLIR mode from NVRAM.
static BOOLEAN | GetDefaultCugInfo (CugDescriptor &cug_desc)
Get default CUG info from NVRAM.
static CallApiRc | RejectAllMoc (BOOLEAN activate)
static CallApiRc | RejectAllMtc (BOOLEAN activate)
static void | RequestRedialStatus ()
static BOOLEAN | SetDefaultClirMode (ClirMode clir_mode)
Set default CLIR mode in NVRAM.
static BOOLEAN | SetDefaultCugInfo (const CugDescriptor &cug_desc)
Set default CUG info in NVRAM.
static void | SetMnRediallingEnabled (BOOLEAN action)

Detailed Description

The class CallHandler supports basic call handling functions. This basic functionality comprises features which neither are specific for mobile terminated nor originated calls, e.g., release of calls. Furthermore, there are methods for DMTF tone generation.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallHandler::CallHandler ( )

Sets the pointer to the CallDispatcher in the base class.

CallHandler::~CallHandler ( ) [virtual]

Member Function Documentation

void CallHandler::ClearBlacklist ( ) [static]

Method for manual clearing of the blacklist. Always successful.

CallDispatcher* CallHandler::GetCallDispatcher ( ) [inline]

Returns a pointer to the CallDispatcher object of the CallHandler. Required to have access to several methods of the CallDispatcher.

Returns:
A pointer to an object of class CallDispatcher

BOOLEAN CallHandler::GetDefaultClirMode ( ClirMode & clir_mode ) [static]

Get default CLIR mode from NVRAM.

Read default CLIR mode from NVRAM. The default CLIR mode is used for each call setup, if no dedicated CLIR mode is given at setup.

clir_mode The default CLIR mode

Returns:
TRUE, if reading from NVRAM was successful FALSE, if reading from in NVRAM failed

BOOLEAN CallHandler::GetDefaultCugInfo ( CugDescriptor & cug_desc ) [static]

Get default CUG info from NVRAM.

Read default CUG info from NVRAM. The default CUG info is used for each call setup, if no dedicated CUG info is given at setup.

cug_desc The default CUG info.

Returns:
TRUE, if storing in NVRAM was successful FALSE, if storing in NVRAM failed

DtmfDispatcher* CallHandler::GetDtmfDispatcher ( ) [inline]

Returns a pointer to the DtmfDispatcher object of the CallHandler. Required in order to be able to remove the dispatcher in case of disconnection of the respective call.

Returns:
A pointer to an object of class DtmfDispatcher

HandlerId CallHandler::GetHandlerId ( ) const [virtual]

CallApiRc CallHandler::RejectAllMoc ( BOOLEAN activate ) [static]

Enables/disables blocking of all mobile originated calls. If enabled the MN will reject all mobile terminated call setups with cause 'call rejected'.

Parameters:
activate TRUE activates, FALSE deactivates blocking.
Returns:
See CallHdl::RejectAllMtc(...).

CallApiRc CallHandler::RejectAllMtc ( BOOLEAN activate ) [static]

Enables/disables blocking of all mobile terminated calls. If enabled the MN will reject all mobile terminated call setups with cause 'call rejected'.

Parameters:
activate TRUE activates, FALSE deactivates blocking.
Returns:
See CallHdl::RejectAllMtc(...).

CallApiRc CallHandler::Release | ( | CallIndex | call_index,
 |  | UINT32 & | call_duration,
 |  | CallErrorCause | cause,
 |  | BOOLEAN | wait_condition = FALSE
 | ) |

Sends a release request for the call corresponding to call_index to the protocol stack. The call will be removed from the internal data structure immediately. The disconnect confirmation will be sent by the network or, if a 30sec timer expires, by the stack itself.

Parameters:
call_index | The reference to the call to be released.
call_duration | See CallHdl::Release(...).
Returns:
See CallHdl::Release(...).

void CallHandler::RequestRedialStatus ( ) [static]

Requests the current redial-status, which will be provided by RedialStatusMsg

BOOLEAN CallHandler::SetDefaultClirMode ( ClirMode clir_mode ) [static]

Set default CLIR mode in NVRAM.

Store default CLIR mode to NVRAM. The default CLIR mode is used for each call setup, if no dedicated CLIR mode is given at setup.

clir_mode The default CLIR mode

Returns:
TRUE, if storing in NVRAM was successful FALSE, if storing in NVRAM failed

BOOLEAN CallHandler::SetDefaultCugInfo ( const CugDescriptor & cug_desc ) [static]

Set default CUG info in NVRAM.

Store default CUG info to NVRAM. The default CUG info is used for each call setup, if no dedicated CUG info is given at setup.

cug_desc The default CUG info.

Returns:
TRUE, if storing in NVRAM was successful FALSE, if storing in NVRAM failed

void CallHandler::SetMnRediallingEnabled ( BOOLEAN action ) [static]

Enables the Mobile Network redialling mechanism but does not activated it. By default, the MN-internal redialling mechanism is enabled.

Parameters:
action TRUE sets the mechnalism enabled, FALSE sets the mechanism disabled.

CallApiRc CallHandler::StartDtmfToneGeneration | ( | CallIndex | idx,
 |  | KeyCode | key
 | ) |

Starts the generation of a DTMF tone during an active voice call.

Parameters:
key | A KeyCode 0, 1, ... 9, * or #.
call_index | The reference to the active voice call.
Returns:
See CallHdl::StartDtmfToneGeneration(...).

CallApiRc CallHandler::StopDtmfToneGeneration ( CallIndex idx )

Stops the previosly started generation of a DTMF tone.

Parameters:
call_index The reference to the active voice call.
Returns:
See CallHdl::StartDtmfToneGeneration(...).

The documentation for this class was generated from the following files:
  • Asc/CallHandler.hpp
  • Asc/CallHandler.cpp
Generated on Wed Jan 25 01:04:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallHdl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallHdl Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CallHdl.hpp>

Inheritance diagram for CallHdl:

[legend]
Collaboration diagram for CallHdl:

[legend]

Public Member Functions

CallApiRc Accept ()
CallHdl (CallIndex call_index=c_null_call_index)
CallApiRc ExplicitCallTransfer ()
SimAlphaIdentifier | GetAlphaIdentifier () const
SimCallControlResult | GetCallControlResult () const
virtual TimeSpan | GetCallDuration () const
virtual CallIndex | GetCallIndex () const
Returns the call index of the CallHdl object.
LineSelector | GetCallLine () const
CallType | GetCallType () const
Get the CallType of the call.
ClirMode | GetClirMode () const
Get the ClirMode which has been used for MOC setup.
const PhoneNumber & | GetConnectedToPhoneNumber () const
CallApiRc GetCurrentCallMeter ()
CallApiRc GetCurrentChargeData ()
EccCategory | GetEccCategory () const
CallEstCause | GetEstablishCause () const
GsmSignal | GetGsmSignal () const
const PhoneNumber & | GetPhoneNumber () const
CallRelatedSsCode | GetSsCode () const
virtual DateTime | GetStartTime () const
virtual CallApiRc | Hold ()
virtual void | Invalidate ()
Sets the reference of a CallHdl object to the void reference.
BOOLEAN | IsAcceptPermitted () const
Returns TRUE if the preconditions for accepting an mtc are fulfilled.
virtual BOOLEAN | IsActive () const
BOOLEAN | IsCallControlPerformed () const
BOOLEAN | IsExplicitCallTransferPermitted () const
virtual BOOLEAN | IsHeld () const
virtual BOOLEAN | IsHoldPermitted () const
BOOLEAN | IsInSetup () const
BOOLEAN | IsMobileOriginated () const
BOOLEAN | IsMobileTerminated () const
BOOLEAN | IsMptyMember () const
virtual BOOLEAN | IsRetrievePermitted () const
BOOLEAN | IsSame (const CallHdl &call) const
BOOLEAN | IsSetupPermitted () const
Returns TRUE if the preconditions for a moc (voice) are fulfilled.
BOOLEAN | IsStartDtmfToneGenerationPermitted () const
Returns TRUE if applied to a single call or a multi-party call containing one call.
virtual BOOLEAN | IsValid () const
CallApiRc | Reject (ClearCause cause=SubscriberBusy, BOOLEAN wait_condition=FALSE)
virtual CallApiRc | Release (TimeSpan *calling_time=0, BOOLEAN wait_condition=FALSE)
virtual CallApiRc | Retrieve ()
CallApiRc SendAlertInd ()
CallApiRc | Setup (const PhoneNumber &phone_no, ClirMode clir_mode=DontCare, BOOLEAN redial=FALSE, const CugDescriptor *cug=0, LineSelector call_line=Line1, BOOLEAN ctm=FALSE, CallEstCause est_cause=HalfTchSpeech, const EccCategory *ecc_category=0)
CallApiRc | SetupAndRedial (const PhoneNumber &phone_no, ClirMode clir_mode=DontCare, const CugDescriptor *cug=0, LineSelector call_line=Line1, BOOLEAN ctm=FALSE, CallEstCause est_cause=HalfTchSpeech, const EccCategory *ecc_category=0)
virtual CallApiRc | StartDtmfToneGeneration (KeyCode key)
virtual CallApiRc | StopDtmfToneGeneration ()
virtual | ~CallHdl ()

Static Public Member Functions

static void | CancelRedialling ()
static CallHdl | GetActiveCallHdl ()
static CallHdl | GetHeldCallHdl ()
static CallHdl | GetSetupCallHdl ()

Detailed Description

The class CallHdl is intended to represent a single mobile originated or mobile terminated voice call. Multi-party calls are not represented by this class. The class provides methods for all common opertations on single voice calls, like Setup, Release, Accept, Hold, Retrieve, etc. Furthermore, methods are available to access call-related data, like the corresponding phone number, the type of call, information transferred by the network (e.g. supplementary service code), the time of setup, the state of a call (active, held, setup) etc..
Additional methods which indicate if the corresponding operation is permitted for the respective CallHdl are alse available. The corresponding operations are Setup, Accept, Hold, Retrieve, Explicit Call Transfer, and Start/StopDtmfToneGeneration.
The class keeps a reference to a call (CallIndex). This CallIndex refers to a call which may be active, held or in setup phase. If a CallHdl object does not refer to a call, it keeps a void CallIndex, i.e., the c_null_call_index.

Constructor & Destructor Documentation

CallHdl::CallHdl ( CallIndex call_index = c_null_call_index ) [explicit]

Creates a well-initialized CallHdl object.

Parameters:
call_index A reference to a call. If omitted, which is the standard case, c_null_call_index is used by default.

CallHdl::~CallHdl ( ) [virtual]

Member Function Documentation

CallApiRc CallHdl::Accept ( )

Accepts an incoming (mobile terminated) voice call. Returns NoError if it has been successfully accepted. A CallSetupProgressMsg is sent during execution of Accept(). Refer to the documentation of CallApiRc for a detailed description of the return values.

Returns:
NoError - If executed successfully. In case of error one of the following values will be returned: CallDataLocked, ActiveCallDetected, InvalidCallIndex, VoidCallIndex or CallDisconnected.

void CallHdl::CancelRedialling ( ) [static]

With CancelRedialling the automatic redialling process can be stopped while a redialling timer is active and no call setup attempt is done. If a call setup attemt is ongoing, the redial process can be stopped using the Release method. CancelRedialling is always successful.

CallApiRc CallHdl::ExplicitCallTransfer ( )

The explicit call transfer supplementary service enables the served mobile subscriber to (A) who has two calls (remote parties B and C) to connect the other parties in the two calls and release the served mobile subscriber(A) own connection. Preconditions: If A-B is active A-C has to be in state waiting (C is MTC) and if call A-B is in held state, A-C has to be in state active or waiting. The method has to be applied to one of the respective calls. If the ECT has been successfully executed, the disconnect indications for the both calls will follow up synchronously.

Returns:
NoError - if excecuted successfully, InvalidCallIndex - if the CallHdl is invalid, VoidCallIndex - if no call exists for to the valid CallHdl, MptyCallDetected - if a MPTY call exists, SecondCallMissing - if only one call exists, SupplementaryServiceFailed - if ECT request is denied by the network. In this case the method GetLastErrorCause() of the CrssHandler returns the exact error code.

CallHdl CallHdl::GetActiveCallHdl ( ) [static]

Returns a CallHdl object with the CallIndex of the active call. If the active call is a multi party call, or no active call exists, the CallIndex is c_null_call_index, i.e. the returned CallHdl is invalid.

SimAlphaIdentifier CallHdl::GetAlphaIdentifier ( ) const

SimCallControlResult CallHdl::GetCallControlResult ( ) const

TimeSpan CallHdl::GetCallDuration ( ) const [virtual]

Returns a TimeSpan object for the duration of the call represented by a CallHdl. The method is applicable to CallHdl.

Returns:
A zero value if the CallHdl is not valid. Also zero if a single call has not been successfully established. The time span from the successful establishment of of a single call or multiparty call to the time of execution of this method.

Implements CallHdlBase.

virtual CallIndex CallHdl::GetCallIndex ( ) const [inline, virtual]

Returns the call index of the CallHdl object.

Implements CallHdlBase.

LineSelector CallHdl::GetCallLine ( ) const

CallType CallHdl::GetCallType ( ) const

Get the CallType of the call.

ClirMode CallHdl::GetClirMode ( ) const

Get the ClirMode which has been used for MOC setup.

const PhoneNumber & CallHdl::GetConnectedToPhoneNumber ( ) const

Returns a reference to a PhoneNumber object where a mobile originated call is actually connected to. If the dialled number is equl to the connected to number, the return value is identical to the return of GetPhoneNumber(). If applied to a llHdl which represents an MTC the return value is equal to the return value of GetPhoneNumber(). The CallHdl shall contain a valid CallIndex!!

See also:
GetPhoneNumber().
Returns:
A constant reference to a PhoneNumber.

CallApiRc CallHdl::GetCurrentCallMeter ( )

Initiates the sending of the ASC message CurrentCallMeterMsg for one time, if the respective call exists.

Returns:
VoidCallIndex if the CallHdl is not valid any more, SupplementaryService failed if AoC is not supported for this call, NoError otherwise.

CallApiRc CallHdl::GetCurrentChargeData ( )

Initiates the sending of the ASC message CurrentChargeMsg for one time if the respective call exists.

Returns:
VoidCallIndex if the CallHdl is not valid any more, SupplementaryService failed if AoC is not supported for this call, NoError otherwise.

EccCategory CallHdl::GetEccCategory ( ) const

CallEstCause CallHdl::GetEstablishCause ( ) const

GsmSignal CallHdl::GetGsmSignal ( ) const

Returns the GsmSignal (e.g., call back ring tone, etc.) related to a mobile terminated call which is passed by the network. The CallHdl shall contain a valid CallIndex. See also GetPhoneNumber().

Returns:
IeMissing - if applied to a mobile originated call, or if the call does not exist.
Other values are described in section describing the type GetGsmSignal.

CallHdl CallHdl::GetHeldCallHdl ( ) [static]

Returns a CallHdl object with the CallIndex of the held call. If the held call is a multi party call, or no held call exists, the CallIndex is c_null_call_index, i.e. the returned CallHdl is invalid.

const PhoneNumber & CallHdl::GetPhoneNumber ( ) const

Returns a reference to a PhoneNumber object containing the phone number of a MOC or MTC. If the phone number has not yet been transmitted by network, the returned PhoneNumber is empty (MTC) If invoked during the setup phase of a MOC, the return value is the dialled phone number. The CallHdl shall contain a valid CallIndex, i.e., c_null_call_index < CallIndex < c_max_calls.

Returns:
A constant reference to a PhoneNumber.

CallHdl CallHdl::GetSetupCallHdl ( ) [static]

Returns a CallHdl object with the CallIndex of the call which is currently in setup phase. If no call in setup phase is found, the CallIndex is c_null_call_index.

CallRelatedSsCode CallHdl::GetSsCode ( ) const

Returns the supplementary service code related to a MOC or MTC. The code is transmitted by the network upon setup confirmation of an MOC or MTC. The CallHdl shall contain a valid CallIndex. See also GetPhoneNumber().

Returns:
VoidSsCode - If the CallHdl object refers to a non existing call.
Other values are described in section describing the type CallReleatedSsCode.

DateTime CallHdl::GetStartTime ( ) const [virtual]

Returns the time when the call was established. The CallHdl shall contain a valid CallIndex. See also GetPhoneNumber().

Returns:
A DateTime object containing the time the call was established. Contains 0 if applied to a non existent call.

Implements CallHdlBase.

CallApiRc CallHdl::Hold ( ) [virtual]

Holds an active call and returns NoError if successful. Only one held call is allowed at one time. Refer to the documentation of CallApiRc for a detailed description of the return values.

Returns:
NoError - If executed successfully. In case of any error, one of the following values is returned: CallDataLocked, HeldCallDetected, ActiveCallRequired, InvalidCallIndex, VoidCallIndex, CallDisconnected, SupplementaryServiceFailed, HoldRequestRejected.

virtual void CallHdl::Invalidate ( ) [inline, virtual]

Sets the reference of a CallHdl object to the void reference.

Implements CallHdlBase.

BOOLEAN CallHdl::IsAcceptPermitted ( ) const

Returns TRUE if the preconditions for accepting an mtc are fulfilled.

BOOLEAN CallHdl::IsActive ( ) const [virtual]

Returns TRUE if the given CallHdl refers to the active call, FALSE otherwise (also when containing a void reference).

Implements CallHdlBase.

BOOLEAN CallHdl::IsCallControlPerformed ( ) const

BOOLEAN CallHdl::IsExplicitCallTransferPermitted ( ) const

Returns TRUE if the preconditions for an explicit call transfer are fulfilled. Has to be applied to a CallHdl representing the active or held call!

BOOLEAN CallHdl::IsHeld ( ) const [virtual]

Returns TRUE if the given CallHdl refers to the held call, FALSE otherwise (also when containing a void reference).

Implements CallHdlBase.

BOOLEAN CallHdl::IsHoldPermitted ( ) const [virtual]

See also:
CallHdlBase::IsHoldPermitted.

Implements CallHdlBase.

BOOLEAN CallHdl::IsInSetup ( ) const

Returns TRUE if the given CallHdl refers to the call in setup phase, FALSE otherwise.

BOOLEAN CallHdl::IsMobileOriginated ( ) const

Returns TRUE if the CallHdl refers to a mobile originated call, FALSE otherwise.

BOOLEAN CallHdl::IsMobileTerminated ( ) const

Returns TRUE if the CallHdl refers to a mobile terminated call, FALSE otherwise.

BOOLEAN CallHdl::IsMptyMember ( ) const

Checks if the given CallHdl object is member of a mpty call.

Returns:
True if it is a member, FALSE otherwise.

BOOLEAN CallHdl::IsRetrievePermitted ( ) const [virtual]

See also:
CallHdlBase::IsRetrievePermitted.

Implements CallHdlBase.

BOOLEAN CallHdl::IsSame ( const CallHdl & call ) const

Checks the CallIndices of both CallHdl objects.

Returns:
TRUE - If both objects refer to the same call.
FALSE - If the references are different or both objects keep a void reference.

BOOLEAN CallHdl::IsSetupPermitted ( ) const

Returns TRUE if the preconditions for a moc (voice) are fulfilled.

BOOLEAN CallHdl::IsStartDtmfToneGenerationPermitted ( ) const

Returns TRUE if applied to a single call or a multi-party call containing one call.

virtual BOOLEAN CallHdl::IsValid ( ) const [inline, virtual]

A CallHdl object is valid if it's reference is different to the void reference.

Returns:
FALSE - If the reference is the void reference.
TRUE - Otherwise.

Implements CallHdlBase.

CallApiRc CallHdl::Reject | ( | ClearCause | cause = SubscriberBusy,
 |  | BOOLEAN | wait_condition = FALSE
 | ) |

Releases a mobile terminated call before it is accepted and sends the calling party information about the cause for the release..

Parameters:
cause The default cause SubscriberBusy, is used when the called user has indicated the inability to accept another call.
Returns:
See CallHdl::Release.

CallApiRc CallHdl::Release | ( | TimeSpan * | calling_time = 0,
 |  | BOOLEAN | wait_condition = FALSE
 | ) | [virtual]

Releases a mobile terminated or mobile originated voice call. May be invoked during call setup, call active and call held phase. The internal data will be immediately updated. There is no active wait for the networks release confirmation, since the confirmation will be generated by the protocol stack if the network fails to answer within 30 sec. The CallIndex of the CallHdl is set to c_null_call_index. Refer to the documentation of CallApiRc for a detailed description of the return values.

Parameters:
calling_time | - Is set to the call duration (time span).
wait_condition | TRUE for synchronous waiting of release
Returns:
NoError - If executed successfully. In case of error, one of the following values will be returned: CallDataLocked, InvalidCallIndex, VoidCallIndex.

Implements CallHdlBase.

CallApiRc CallHdl::Retrieve ( ) [virtual]

Retrieves a held call, and returns NoError if successful.Only one active call is allowed at one time. Refer to the documentation of CallApiRc for a detailed description of the return values.

Returns:
NoError - If executed successfully.In case of any error, one of the following values is returned: CallDataLocked, ActiveCallDetected, HeldCallRequired, InvalidCallIndex, VoidCallIndex, CallDisconnected, SupplementaryServiceFailed, RetrieveRequestRejected.

CallApiRc CallHdl::SendAlertInd ( )

Informs the calling party that the mobile station is ringing now. (triggers the protocol stack to signal the information to the calling party). Useful for MTCs only.Refer to the documentation of CallApiRc for a detailed description of the return values.

Returns:
NoError - If executed successfully. In case of error, one of the follwing values will be returned: CallDataLocked, ActiveCallDetected, InvalidCallIndex, VoidCallIndex, CallDisconnected.

CallApiRc CallHdl::Setup | ( | const PhoneNumber & | phone_no,
 |  | ClirMode | clir_mode = DontCare,
 |  | BOOLEAN | redial = FALSE,
 |  | const CugDescriptor * | cug = 0,
 |  | LineSelector | call_line = Line1,
 |  | BOOLEAN | ctm = FALSE,
 |  | CallEstCause | est_cause = HalfTchSpeech,
 |  | const EccCategory * | ecc_category = 0
 | ) |

Establishes a mobile originated voice call. Assigns the CallIndex in the CallHdl as soon it is available by the protocol stack and returns NoError, if the call setup was successful. In case of any error, the CallIndex will be set to c_null_call_index. During the execution of Setup(const PhoneNumber & phone_no), several info-messages are sent (active wait loop). The messages supply information on setup progress and are the following: MocSetupAcceptMsg, ConnectionStatusMsg, and CallSetupProgressMsg. Refer to the documentation of CallApiRc for a detailed description of the return values. The CLIR mode is defaulted to the network settings. The CUG descriptor ist defaulted to the preferred CUG index and outgoing access enabled. Redialling is disabled by default.

Parameters:
phone_no | The phone number of the call to be set up.
clir_mode | SuppressPhoneNumber or DisplayPhoneNumber. By default DontCare will be used.
redial | Enables automatic redialling if TRUE, disables automatic redialling otherwise. By default, the redialling feature is disabled.
cug | A const pointer to the closed user group description. The default CUG information is defined as follows: The selected CUG is the PreferedCug, the CUG index is set to -1, and the outgoing access is not restricted, i.e., it is set to FALSE.
call_line | Line1 or Line2. For using active line service ALS. By default Line1 will be used.
ctm | Activate TTY(teletypewriter) also known as TDD(Telecommunication Device for Deaf).
est_cause | Is HalfTchSpeech normaly. In case of emergency-call this must be set to EmergencyCall
ecc_category | In case of a emergency-call the EccCategory can be set.
Returns:
NoError - If executed successfully. In case of error one of the following values will be returned: CallDataLocked, NoNetwork, ActiveCallDetected, SetupCallDetected, MaxCallCountExceeded, CallDisconnected, CallSetupRejected.

CallApiRc CallHdl::SetupAndRedial | ( | const PhoneNumber & | phone_no,
 |  | ClirMode | clir_mode = DontCare,
 |  | const CugDescriptor * | cug = 0,
 |  | LineSelector | call_line = Line1,
 |  | BOOLEAN | ctm = FALSE,
 |  | CallEstCause | est_cause = HalfTchSpeech,
 |  | const EccCategory * | ecc_category = 0
 | ) |

Same as Setup but after an unsuccessful setup attempt the automatich redialling mechanism of the MN will be started. Still defined for compatibility reasons. Use Setup() with redialling param instead!

Parameters:
phone_no | See Setup.
clir_mode | See Setup.
cug | See Setup.
call_line | See Setup.
ctm | See Setup.
est_cause | See Setup.
ecc_category | See Setup.
Returns:
See Setup.

CallApiRc CallHdl::StartDtmfToneGeneration ( KeyCode key ) [virtual]

Starts the generation of a DTMF tone during an active voice call. Refer to the documentation of CallApiRc for a detailed description of the return values.

Parameters:
key A KeyCode 0, 1, ... 9, * or #.
Returns:
NoError - If successful. In case of an error, one of the following values is returned: CallDataLocked, VoidCallIndex, InvalidCallIndex, ActiveCallRequired, SpeechCallRequired, InvalidMptyMemberCount,

Reimplemented from CallHdlBase.

CallApiRc CallHdl::StopDtmfToneGeneration ( ) [virtual]

Stops the started generation of a DTMF tone.

Returns:
See CallHdl::StartDtmfToneGeneration(...).

Reimplemented from CallHdlBase.

The documentation for this class was generated from the following files:
  • Asc/CallHdl.hpp
  • Asc/CallHdl.cpp
Generated on Wed Jan 25 01:04:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallHdlBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallHdlBase Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CallHdlBase.hpp>

Inheritance diagram for CallHdlBase:

[legend]
Collaboration diagram for CallHdlBase:

[legend]

Public Member Functions

CallHdlBase ()
virtual TimeSpan | GetCallDuration () const =0
virtual CallIndex | GetCallIndex () const =0
virtual DateTime | GetStartTime () const =0
virtual void | Invalidate ()=0
Invalidates a CallHdl or a MptyCallHdl.
virtual BOOLEAN | IsActive () const =0
virtual BOOLEAN | IsHeld () const =0
virtual BOOLEAN | IsHoldPermitted () const =0
Returns TRUE if the preconditions for holding a call are fulfilled.
BOOLEAN | IsJoinPermitted () const
Returns TRUE if the preconditions for a multi-party call are fulfilled.
virtual BOOLEAN | IsRetrievePermitted () const =0
Returns TRUE if the preconditions for retrieving a call are fulfilled.
BOOLEAN | IsSwapPermitted () const
Returns TRUE if the preconditions for swapping calls are fulfilled.
virtual BOOLEAN | IsValid () const =0
virtual CallApiRc | Join ()
virtual CallApiRc | Release (TimeSpan *calling_time=0, BOOLEAN wait_condition=FALSE)=0
virtual CallApiRc | StartDtmfToneGeneration (KeyCode key)
virtual CallApiRc | StopDtmfToneGeneration ()
virtual CallApiRc | Swap ()
virtual | ~CallHdlBase ()

Static Public Member Functions

static void | ClearBlacklist ()
static INT | GetCallCount ()
static WString & | GetStatusString ()
static CallErrorCause | ReadLastMnCause ()
static CallApiRc | RejectAllMoc (BOOLEAN activate)
static CallApiRc | RejectAllMtc (BOOLEAN activate)
static CallApiRc | ReleaseAllActiveCalls ()
static CallApiRc | ReleaseAllHeldCalls ()
static void | ReportCurrentCallMeter (BOOLEAN activate)
static void | ReportCurrentCharge (BOOLEAN activate)
static void | SetRediallingEnable (BOOLEAN action)

Static Public Attributes

static WString | m_status_string

Detailed Description

The class CallHdlBase is the base class for single call objectes ( CallHdl) and multi-party call objects (MptyCallHdl) and comprises besides some virtual methods, methods which are commen to single and multi-party calls.

Constructor & Destructor Documentation

CallHdlBase::CallHdlBase ( )

CallHdlBase::~CallHdlBase ( ) [virtual]

Member Function Documentation

void CallHdlBase::ClearBlacklist ( ) [static]

Initiates the manual clearing of the blacklist, i.e., every called party number is removed from the blacklist and the corresponding timers are reset.

INT CallHdlBase::GetCallCount ( ) [static]

Returns the current number of calls, where a multi-party call is considered as one call. A call in setup phase is also considered as one call. Example: An active multi-party call exists and a mobile terminated call arrives: GetCallCount returns 2.

Returns:
The current number of calls.

virtual TimeSpan CallHdlBase::GetCallDuration ( ) const [pure virtual]

Returns a TimeSpan object for the duration of the call represented by a CallHdl ore MptyCallHdl. The method is applicable to both MptyCallHdl and CallHdl.

Returns:
A zero value if the CallHdl/MptyCallHdl is not valid. Also zero if a single call has not been successfully established. The time span from the successful establishment of of a single call or multiparty call to the time of execution of this method.

Implemented in CallHdl, and MptyCallHdl.

virtual CallIndex CallHdlBase::GetCallIndex ( ) const [pure virtual]

Implemented in CallHdl, and MptyCallHdl.

virtual DateTime CallHdlBase::GetStartTime ( ) const [pure virtual]

Returns a DateTime object representing the time at the point when the call was established. GetStartTime() may be applied to a CallHdl or MptyCallHdl object.

Returns:
The time when the call was established.

Implemented in CallHdl, and MptyCallHdl.

WString & CallHdlBase::GetStatusString ( ) [static]

virtual void CallHdlBase::Invalidate ( ) [pure virtual]

Invalidates a CallHdl or a MptyCallHdl.

Implemented in CallHdl, and MptyCallHdl.

virtual BOOLEAN CallHdlBase::IsActive ( ) const [pure virtual]

Implemented in CallHdl, and MptyCallHdl.

virtual BOOLEAN CallHdlBase::IsHeld ( ) const [pure virtual]

Implemented in CallHdl, and MptyCallHdl.

virtual BOOLEAN CallHdlBase::IsHoldPermitted ( ) const [pure virtual]

Returns TRUE if the preconditions for holding a call are fulfilled.

Implemented in CallHdl, and MptyCallHdl.

BOOLEAN CallHdlBase::IsJoinPermitted ( ) const

Returns TRUE if the preconditions for a multi-party call are fulfilled.

virtual BOOLEAN CallHdlBase::IsRetrievePermitted ( ) const [pure virtual]

Returns TRUE if the preconditions for retrieving a call are fulfilled.

Implemented in CallHdl, and MptyCallHdl.

BOOLEAN CallHdlBase::IsSwapPermitted ( ) const

Returns TRUE if the preconditions for swapping calls are fulfilled.

virtual BOOLEAN CallHdlBase::IsValid ( ) const [pure virtual]

Implemented in CallHdl, and MptyCallHdl.

CallApiRc CallHdlBase::Join ( ) [virtual]

Creates a multi party call from a held and an active call, or adds an active call to an existing multi party call. The method may be applied to the mulity-party or the single call.
Refer to the documentation of CallApiRc for a detailed description of the return values.

Returns:
NoError if Join was successfully executed. In case of an error one of the following values will be returned: CallDataLocked, ActiveCallRequired, HeldCallRequired, MaxMptyMemberCountExceeded, VoidCallIndex, CallDisconnected, SupplementaryServiceFailed.

CallErrorCause CallHdlBase::ReadLastMnCause ( ) [static]

CallApiRc CallHdlBase::RejectAllMoc ( BOOLEAN activate ) [static]

Enables/disables blocking of all mobile originated calls. If enabled the MN will reject all mobile terminated call setups with cause #21 'call rejected'.

Parameters:
activate TRUE activates, FALSE deactivates blocking.
Returns:
NoError - If blocking successfully enabled or disabled. CallDataLocked if another thread currently blocks the internal data structures.

CallApiRc CallHdlBase::RejectAllMtc ( BOOLEAN activate ) [static]

Enables/disables blocking of all mobile terminated calls. If enabled the MN will reject all mobile terminated call setups with cause #21 'call rejected'.

Parameters:
activate TRUE activates, FALSE deactivates blocking.
Returns:
NoError - If blocking successfully enabled or disabled. CallDataLocked if another thread currently blocks the internal data structures.

virtual CallApiRc CallHdlBase::Release | ( | TimeSpan * | calling_time = 0,
 |  | BOOLEAN | wait_condition = FALSE
 | ) | [pure virtual]

Implemented in CallHdl, and MptyCallHdl.

CallApiRc CallHdlBase::ReleaseAllActiveCalls ( ) [static]

Releases all active calls if existent. Used in connection with call related supplementary services.

CallApiRc CallHdlBase::ReleaseAllHeldCalls ( ) [static]

Releases all held calls if existent. Used in connection with call related supplementary services.

void CallHdlBase::ReportCurrentCallMeter ( BOOLEAN activate ) [static]

Starts the automatic reporting of the current call meter (CCM). The ASC message CurrentCallMeterMsg will be sent each time when the CCM is calculated (but not more than once within 2 seconds) until the automatic reporting is stopped by calling this method with parameter activate set to FALSE.

Parameters:
activate Starts reporting of CCM if TRUE, stops reporting if FALSE.

void CallHdlBase::ReportCurrentCharge ( BOOLEAN activate ) [static]

Starts the automatic reporting of the current charge. The ASC message CurrentChargeMsg will be sent each time when the CCM is calculated (but not more than once within 2 seconds) until the automatic reporting is stopped by calling this method with parameter activate set to FALSE.

Parameters:
activate Starts reporting of current charge if TRUE, stops reporting if FALSE.

void CallHdlBase::SetRediallingEnable ( BOOLEAN action ) [static]

This method enables/disables the internal redialling mechanism.

Parameters:
action TRUE enables the internal redialling mechanism, FALSE disables the mechanism.

virtual CallApiRc CallHdlBase::StartDtmfToneGeneration ( KeyCode key ) [inline, virtual]

Starts the generation of a DTMF tone during an active voice call. Refer to the documentation of CallApiRc for a detailed description of the return values.

Parameters:
key A KeyCode 0, 1, ... 9, * or #.
Returns:
NoError - If successful. In case of an error, one of the following values is returned: CallDataLocked, VoidCallIndex, InvalidCallIndex, ActiveCallRequired, SpeechCallRequired, InvalidMptyMemberCount,

Reimplemented in CallHdl, and MptyCallHdl.

virtual CallApiRc CallHdlBase::StopDtmfToneGeneration ( ) [inline, virtual]

Stops the started generation of a DTMF tone.

Returns:
See CallHdl::StartDtmfToneGeneration(...).

Reimplemented in CallHdl, and MptyCallHdl.

CallApiRc CallHdlBase::Swap ( ) [virtual]

SwapCalls() holds the active call, retrieves the held call and returns NoError in case of success. The method may be applied to the active or held call. A held and an active call are required, one of them may be a multy-party call. The method is applicable to both, CallHdl and MptyCallHdl objects. The error indication is analogue to the error indication of Hold and Retrieve since Swap() is the consecutive execution of Hold() and Retrieve().
Refer to the documentation of CallApiRc for a detailed description of the return values.

Returns:
NoError if the operation was successfully excuted. In case of an error one of the following values will be returned: CallDataLocked, ActiveCallRequired, HeldCallRequired, InvalidCallIndex, VoidCallIndex, CallDisconnected, SupplementaryServiceFailed, HoldRequestRejected, RetrieveRequestRejected.

Field Documentation

WString CallHdlBase::m_status_string [static]

The documentation for this class was generated from the following files:
  • Asc/CallHdlBase.hpp
  • Asc/CallHdlBase.cpp
Generated on Wed Jan 25 01:04:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallHeldMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallHeldMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallHeldMsg:

[legend]
Collaboration diagram for CallHeldMsg:

[legend]

Public Types

enum | { ID = 18526 }

Public Member Functions

CallHeldMsg (ExecutionContext *context, const Tipd &tipd)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
virtual | ~CallHeldMsg ()

Detailed Description

CallHeldMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallHeldMsg::CallHeldMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd
 | ) |

CallHeldMsg::~CallHeldMsg ( ) [virtual]

Member Function Documentation

Message * CallHeldMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & CallHeldMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& CallHeldMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallHoldCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallHoldCnfArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for CallHoldCnfArg:

[legend]
Collaboration diagram for CallHoldCnfArg:

[legend]

Public Types

enum | { ID = 1062 }

Public Member Functions

CallHoldCnfArg ()
const CallRelatedSsState & | GetCrssState () const
const Tipd & | GetTipd () const
void | SetCrssState (const CallRelatedSsState &crss_state)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallHoldCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallHoldCnfArg::CallHoldCnfArg ( )

Member Function Documentation

const CallHoldCnfArg & CallHoldCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallRelatedSsState& CallHoldCnfArg::GetCrssState ( ) const [inline]

const Tipd& CallHoldCnfArg::GetTipd ( ) const [inline]

void CallHoldCnfArg::SetCrssState ( const CallRelatedSsState & crss_state ) [inline]

void CallHoldCnfArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallHoldRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallHoldRejArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for CallHoldRejArg:

[legend]
Collaboration diagram for CallHoldRejArg:

[legend]

Public Types

enum | { ID = 1063 }

Public Member Functions

CallHoldRejArg ()
const CallErrorCause & | GetCallDiscCause () const
const CallRelatedSsState & | GetCrssState () const
const Tipd & | GetTipd () const
void | SetCallDiscCause (const CallErrorCause &call_disc_cause)
void | SetCrssState (const CallRelatedSsState &crss_state)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallHoldRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallHoldRejArg: reflects arguments of signal MN_HOLD_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallHoldRejArg::CallHoldRejArg ( )

Member Function Documentation

const CallHoldRejArg & CallHoldRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& CallHoldRejArg::GetCallDiscCause ( ) const [inline]

const CallRelatedSsState& CallHoldRejArg::GetCrssState ( ) const [inline]

const Tipd& CallHoldRejArg::GetTipd ( ) const [inline]

void CallHoldRejArg::SetCallDiscCause ( const CallErrorCause & call_disc_cause ) [inline]

void CallHoldRejArg::SetCrssState ( const CallRelatedSsState & crss_state ) [inline]

void CallHoldRejArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallHoldRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallHoldRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallHoldRejectedMsg:

[legend]
Collaboration diagram for CallHoldRejectedMsg:

[legend]

Public Types

enum | { ID = 18321 }

Public Member Functions

CallHoldRejectedMsg (ExecutionContext *context, const CallHdl &call, const CallErrorCause &cause)
virtual Message * | Clone () const
const CallHdl & | GetCall () const
const CallErrorCause & | GetCause () const
virtual const MsgMetaData & | GetMetaData () const
void | SetCall (const CallHdl &call)
void | SetCause (const CallErrorCause &cause)
virtual | ~CallHoldRejectedMsg ()

Detailed Description

CallHoldRejectedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallHoldRejectedMsg::CallHoldRejectedMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call,
 |  | const CallErrorCause & | cause
 | ) |

CallHoldRejectedMsg::~CallHoldRejectedMsg ( ) [virtual]

Member Function Documentation

Message * CallHoldRejectedMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CallHoldRejectedMsg::GetCall ( ) const [inline]

const CallErrorCause& CallHoldRejectedMsg::GetCause ( ) const [inline]

const MsgMetaData & CallHoldRejectedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallHoldRejectedMsg::SetCall ( const CallHdl & call ) [inline]

void CallHoldRejectedMsg::SetCause ( const CallErrorCause & cause ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CallIndArg:

[legend]
Collaboration diagram for CallIndArg:

[legend]

Public Types

enum | { ID = 1123 }

Public Member Functions

CallIndArg ()
const CallErrorCause & | GetCallErrorCause () const
const LineSelector & | GetCallLine () const
const CallState & | GetCallState () const
const CallType & | GetCallType () const
const DataCallType & | GetDataCallType () const
const EccCategory & | GetEccCategory () const
const CallEstCause & | GetEstablishCause () const
const PhoneNumber & | GetPhoneNumber () const
const Tipd & | GetTipd () const
BOOLEAN | IsCtm () const
void | SetCallErrorCause (const CallErrorCause &call_error_cause)
void | SetCallLine (const LineSelector &call_line)
void | SetCallState (const CallState &call_state)
void | SetCallType (const CallType &call_type)
void | SetCtm (BOOLEAN ctm)
void | SetDataCallType (const DataCallType &data_call_type)
void | SetEccCategory (const EccCategory &ecc_category)
void | SetEstablishCause (const CallEstCause &establish_cause)
void | SetPhoneNumber (const PhoneNumber &phone_number)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallIndArg: reflects arguments of signal MN_CALL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallIndArg::CallIndArg ( )

Member Function Documentation

const CallIndArg & CallIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& CallIndArg::GetCallErrorCause ( ) const [inline]

const LineSelector& CallIndArg::GetCallLine ( ) const [inline]

const CallState& CallIndArg::GetCallState ( ) const [inline]

const CallType& CallIndArg::GetCallType ( ) const [inline]

const DataCallType& CallIndArg::GetDataCallType ( ) const [inline]

const EccCategory& CallIndArg::GetEccCategory ( ) const [inline]

const CallEstCause& CallIndArg::GetEstablishCause ( ) const [inline]

const PhoneNumber& CallIndArg::GetPhoneNumber ( ) const [inline]

const Tipd& CallIndArg::GetTipd ( ) const [inline]

BOOLEAN CallIndArg::IsCtm ( ) const [inline]

void CallIndArg::SetCallErrorCause ( const CallErrorCause & call_error_cause ) [inline]

void CallIndArg::SetCallLine ( const LineSelector & call_line ) [inline]

void CallIndArg::SetCallState ( const CallState & call_state ) [inline]

void CallIndArg::SetCallType ( const CallType & call_type ) [inline]

void CallIndArg::SetCtm ( BOOLEAN ctm ) [inline]

void CallIndArg::SetDataCallType ( const DataCallType & data_call_type ) [inline]

void CallIndArg::SetEccCategory ( const EccCategory & ecc_category ) [inline]

void CallIndArg::SetEstablishCause ( const CallEstCause & establish_cause ) [inline]

void CallIndArg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

void CallIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallIndCallControlInfoArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallIndCallControlInfoArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CallIndCallControlInfoArg:

[legend]
Collaboration diagram for CallIndCallControlInfoArg:

[legend]

Public Types

enum | { ID = 1136 }

Public Member Functions

CallIndCallControlInfoArg ()
const SimAlphaIdentifier & | GetAlphaIdentifier () const
const SimCallControlResult & | GetCallControlResult () const
const Tipd & | GetTipd () const
BOOLEAN | IsCallControlPerformed () const
void | SetAlphaIdentifier (const SimAlphaIdentifier &alpha_identifier)
void | SetCallControlPerformed (BOOLEAN call_control_performed)
void | SetCallControlResult (const SimCallControlResult &call_control_result)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallIndCallControlInfoArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallIndCallControlInfoArg: reflects arguments of signal MN_CALL_IND_CALL_CONTROL_INFO

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallIndCallControlInfoArg::CallIndCallControlInfoArg ( )

Member Function Documentation

const CallIndCallControlInfoArg & CallIndCallControlInfoArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimAlphaIdentifier& CallIndCallControlInfoArg::GetAlphaIdentifier ( ) const [inline]

const SimCallControlResult& CallIndCallControlInfoArg::GetCallControlResult ( ) const [inline]

const Tipd& CallIndCallControlInfoArg::GetTipd ( ) const [inline]

BOOLEAN CallIndCallControlInfoArg::IsCallControlPerformed ( ) const [inline]

void CallIndCallControlInfoArg::SetAlphaIdentifier ( const SimAlphaIdentifier & alpha_identifier ) [inline]

void CallIndCallControlInfoArg::SetCallControlPerformed ( BOOLEAN call_control_performed ) [inline]

void CallIndCallControlInfoArg::SetCallControlResult ( const SimCallControlResult & call_control_result ) [inline]

void CallIndCallControlInfoArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallInfoArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallInfoArg Struct Reference
[APOXI Stack Control]

Structure which will never be sent in this environment!!! More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for CallInfoArg:

[legend]

Data Fields

CallHdl call
A CallHdl object holding the call_index of the respective call.
CallState state
Supplied by MN. Comprises MocSetup, MocStarted, MocActive, MtcConfirmed, etc.
CallType type
Describs the type of call. Supplied by MN.

Detailed Description

Structure which will never be sent in this environment!!!

Field Documentation

CallHdl CallInfoArg::call

A CallHdl object holding the call_index of the respective call.

CallState CallInfoArg::state

Supplied by MN. Comprises MocSetup, MocStarted, MocActive, MtcConfirmed, etc.

CallType CallInfoArg::type

Describs the type of call. Supplied by MN.

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 01:04:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallInfoMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallInfoMsg:

[legend]
Collaboration diagram for CallInfoMsg:

[legend]

Public Types

enum | { ID = 18407 }

Public Member Functions

CallInfoMsg (ExecutionContext *context, const CallInfoArg &arg)
virtual Message * | Clone () const
const CallInfoArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallInfoArg &arg)
virtual | ~CallInfoMsg ()

Detailed Description

CallInfoMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallInfoMsg::CallInfoMsg | ( | ExecutionContext * | context,
 |  | const CallInfoArg & | arg
 | ) |

CallInfoMsg::~CallInfoMsg ( ) [virtual]

Member Function Documentation

Message * CallInfoMsg::Clone ( ) const [virtual]

Implements Message.

const CallInfoArg& CallInfoMsg::GetArg ( ) const [inline]

const MsgMetaData & CallInfoMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallInfoMsg::SetArg ( const CallInfoArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallingName Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallingName Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CallingName:

[legend]

Data Fields

CnameChoice cname_selector
DataCodingScheme data_coding_scheme
WString name_string

Field Documentation

CnameChoice CallingName::cname_selector

DataCodingScheme CallingName::data_coding_scheme

WString CallingName::name_string

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:04:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallIsWaitingMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallIsWaitingMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallIsWaitingMsg:

[legend]
Collaboration diagram for CallIsWaitingMsg:

[legend]

Public Types

enum | { ID = 18528 }

Public Member Functions

CallIsWaitingMsg (ExecutionContext *context, const Tipd &tipd)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
virtual | ~CallIsWaitingMsg ()

Detailed Description

CallIsWaitingMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallIsWaitingMsg::CallIsWaitingMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd
 | ) |

CallIsWaitingMsg::~CallIsWaitingMsg ( ) [virtual]

Member Function Documentation

Message * CallIsWaitingMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & CallIsWaitingMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& CallIsWaitingMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallNotifyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallNotifyMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallNotifyMsg:

[legend]
Collaboration diagram for CallNotifyMsg:

[legend]

Public Types

enum | { ID = 18414 }

Public Member Functions

CallNotifyMsg (ExecutionContext *context, const CallHdl &call_hdl, const NotificationDescription &description)
virtual Message * | Clone () const
const CallHdl & | GetCallHdl () const
const NotificationDescription & | GetDescription () const
virtual const MsgMetaData & | GetMetaData () const
void | SetCallHdl (const CallHdl &call_hdl)
void | SetDescription (const NotificationDescription &description)
virtual | ~CallNotifyMsg ()

Detailed Description

CallNotifyMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallNotifyMsg::CallNotifyMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl,
 |  | const NotificationDescription & | description
 | ) |

CallNotifyMsg::~CallNotifyMsg ( ) [virtual]

Member Function Documentation

Message * CallNotifyMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CallNotifyMsg::GetCallHdl ( ) const [inline]

const NotificationDescription& CallNotifyMsg::GetDescription ( ) const [inline]

const MsgMetaData & CallNotifyMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallNotifyMsg::SetCallHdl ( const CallHdl & call_hdl ) [inline]

void CallNotifyMsg::SetDescription ( const NotificationDescription & description ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallOnHoldMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallOnHoldMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallOnHoldMsg:

[legend]
Collaboration diagram for CallOnHoldMsg:

[legend]

Public Types

enum | { ID = 18320 }

Public Member Functions

CallOnHoldMsg (ExecutionContext *context, const CallHdl &call)
virtual Message * | Clone () const
const CallHdl & | GetCall () const
virtual const MsgMetaData & | GetMetaData () const
void | SetCall (const CallHdl &call)
virtual | ~CallOnHoldMsg ()

Detailed Description

CallOnHoldMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallOnHoldMsg::CallOnHoldMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call
 | ) |

CallOnHoldMsg::~CallOnHoldMsg ( ) [virtual]

Member Function Documentation

Message * CallOnHoldMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CallOnHoldMsg::GetCall ( ) const [inline]

const MsgMetaData & CallOnHoldMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallOnHoldMsg::SetCall ( const CallHdl & call ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallProgressIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallProgressIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CallProgressIndArg:

[legend]
Collaboration diagram for CallProgressIndArg:

[legend]

Public Types

enum | { ID = 1120 }

Public Member Functions

CallProgressIndArg ()
const CallProgressInd & | GetCallProgressInd () const
const Tipd & | GetTipd () const
void | SetCallProgressInd (const CallProgressInd &call_progress_ind)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallProgressIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallProgressIndArg: reflects arguments of signal MNMI_PROGRESS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallProgressIndArg::CallProgressIndArg ( )

Member Function Documentation

const CallProgressIndArg & CallProgressIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallProgressInd& CallProgressIndArg::GetCallProgressInd ( ) const [inline]

const Tipd& CallProgressIndArg::GetTipd ( ) const [inline]

void CallProgressIndArg::SetCallProgressInd ( const CallProgressInd & call_progress_ind ) [inline]

void CallProgressIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallRelatedSsCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallRelatedSsCnfArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for CallRelatedSsCnfArg:

[legend]
Collaboration diagram for CallRelatedSsCnfArg:

[legend]

Public Types

enum | { ID = 1060 }

Public Member Functions

CallRelatedSsCnfArg ()
const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallRelatedSsCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallRelatedSsCnfArg::CallRelatedSsCnfArg ( )

Member Function Documentation

const CallRelatedSsCnfArg & CallRelatedSsCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& CallRelatedSsCnfArg::GetTipd ( ) const [inline]

void CallRelatedSsCnfArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallRelatedSsRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallRelatedSsRejArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for CallRelatedSsRejArg:

[legend]
Collaboration diagram for CallRelatedSsRejArg:

[legend]

Public Types

enum | { ID = 1061 }

Public Member Functions

CallRelatedSsRejArg ()
const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallRelatedSsRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallRelatedSsRejArg::CallRelatedSsRejArg ( )

Member Function Documentation

const CallRelatedSsRejArg & CallRelatedSsRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& CallRelatedSsRejArg::GetTipd ( ) const [inline]

void CallRelatedSsRejArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallRelatedSsReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallRelatedSsReqArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for CallRelatedSsReqArg:

[legend]
Collaboration diagram for CallRelatedSsReqArg:

[legend]

Public Types

enum | { ID = 2060 }

Public Member Functions

CallRelatedSsReqArg ()
CallRelatedSsReqArg (const Tipd &tipd, const CallRelatedSs &call_related_ss)
const CallRelatedSs & | GetCallRelatedSs () const
const Tipd & | GetTipd () const
void | SetCallRelatedSs (const CallRelatedSs &call_related_ss)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallRelatedSsReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallRelatedSsReqArg: reflects arguments of signal MN_CRSS_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallRelatedSsReqArg::CallRelatedSsReqArg | ( | const Tipd & | tipd,
 |  | const CallRelatedSs & | call_related_ss
 | ) |

CallRelatedSsReqArg::CallRelatedSsReqArg ( )

Member Function Documentation

const CallRelatedSsReqArg & CallRelatedSsReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallRelatedSs& CallRelatedSsReqArg::GetCallRelatedSs ( ) const [inline]

const Tipd& CallRelatedSsReqArg::GetTipd ( ) const [inline]

void CallRelatedSsReqArg::SetCallRelatedSs ( const CallRelatedSs & call_related_ss ) [inline]

void CallRelatedSsReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallRelCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallRelCnfArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CallRelCnfArg:

[legend]
Collaboration diagram for CallRelCnfArg:

[legend]

Public Types

enum | { ID = 1129 }

Public Member Functions

CallRelCnfArg ()
const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallRelCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallRelCnfArg: reflects arguments of signal MN_REL_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallRelCnfArg::CallRelCnfArg ( )

Member Function Documentation

const CallRelCnfArg & CallRelCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& CallRelCnfArg::GetTipd ( ) const [inline]

void CallRelCnfArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallReleaseMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallReleaseMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallReleaseMsg:

[legend]
Collaboration diagram for CallReleaseMsg:

[legend]

Public Types

enum | { ID = 18713 }

Public Member Functions

CallReleaseMsg (const CallHdl &call_hdl)
virtual Message * | Clone () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~CallReleaseMsg ()

Detailed Description

CallReleaseMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallReleaseMsg::CallReleaseMsg ( const CallHdl & call_hdl )

CallReleaseMsg::~CallReleaseMsg ( ) [virtual]

Member Function Documentation

Message * CallReleaseMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CallReleaseMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & CallReleaseMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallRelIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallRelIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CallRelIndArg:

[legend]
Collaboration diagram for CallRelIndArg:

[legend]

Public Types

enum | { ID = 1131 }

Public Member Functions

CallRelIndArg ()
const CallErrorCause & | GetCallDiscCause () const
const Tipd & | GetTipd () const
void | SetCallDiscCause (const CallErrorCause &call_disc_cause)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CallRelIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallRelIndArg: reflects arguments of signal MN_REL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallRelIndArg::CallRelIndArg ( )

Member Function Documentation

const CallRelIndArg & CallRelIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& CallRelIndArg::GetCallDiscCause ( ) const [inline]

const Tipd& CallRelIndArg::GetTipd ( ) const [inline]

void CallRelIndArg::SetCallDiscCause ( const CallErrorCause & call_disc_cause ) [inline]

void CallRelIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallRetrievedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallRetrievedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallRetrievedMsg:

[legend]
Collaboration diagram for CallRetrievedMsg:

[legend]

Public Types

enum | { ID = 18527 }

Public Member Functions

CallRetrievedMsg (ExecutionContext *context, const Tipd &tipd)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
virtual | ~CallRetrievedMsg ()

Detailed Description

CallRetrievedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallRetrievedMsg::CallRetrievedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd
 | ) |

CallRetrievedMsg::~CallRetrievedMsg ( ) [virtual]

Member Function Documentation

Message * CallRetrievedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & CallRetrievedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& CallRetrievedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallSetupBySimtTkReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallSetupBySimtTkReqArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CallSetupBySimtTkReqArg:

[legend]
Collaboration diagram for CallSetupBySimtTkReqArg:

[legend]

Public Types

enum | { ID = 1134 }

Public Member Functions

CallSetupBySimtTkReqArg ()
const ProactiveCause & | GetCause () const
UINT8 | GetSimCallSetupOption () const
const PhoneNumber & | GetStkCallSetupNo () const
void | SetCause (const ProactiveCause &cause)
void | SetSimCallSetupOption (UINT8 sim_call_setup_option)
void | SetStkCallSetupNo (const PhoneNumber &stk_call_setup_no)

Static Public Member Functions

static const CallSetupBySimtTkReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallSetupBySimtTkReqArg: necessary for context switch between SimTkApp and CallHandlingApp

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallSetupBySimtTkReqArg::CallSetupBySimtTkReqArg ( )

Member Function Documentation

const CallSetupBySimtTkReqArg & CallSetupBySimtTkReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& CallSetupBySimtTkReqArg::GetCause ( ) const [inline]

UINT8 CallSetupBySimtTkReqArg::GetSimCallSetupOption ( ) const [inline]

const PhoneNumber& CallSetupBySimtTkReqArg::GetStkCallSetupNo ( ) const [inline]

void CallSetupBySimtTkReqArg::SetCause ( const ProactiveCause & cause ) [inline]

void CallSetupBySimtTkReqArg::SetSimCallSetupOption ( UINT8 sim_call_setup_option ) [inline]

void CallSetupBySimtTkReqArg::SetStkCallSetupNo ( const PhoneNumber & stk_call_setup_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:04:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallSetupProgressArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallSetupProgressArg Struct Reference
[APOXI Stack Control]

Structure indicating the progress during setup phase of a call. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for CallSetupProgressArg:

[legend]

Data Fields

CallHdl call
A refernce to the respective call.
CallProgressInd progress_ind

Detailed Description

Structure indicating the progress during setup phase of a call.

Field Documentation

CallHdl CallSetupProgressArg::call

A refernce to the respective call.

CallProgressInd CallSetupProgressArg::progress_ind

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 01:04:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallSetupProgressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallSetupProgressMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallSetupProgressMsg:

[legend]
Collaboration diagram for CallSetupProgressMsg:

[legend]

Public Types

enum | { ID = 18404 }

Public Member Functions

CallSetupProgressMsg (ExecutionContext *context, const CallSetupProgressArg &arg)
virtual Message * | Clone () const
const CallSetupProgressArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallSetupProgressArg &arg)
virtual | ~CallSetupProgressMsg ()

Detailed Description

CallSetupProgressMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallSetupProgressMsg::CallSetupProgressMsg | ( | ExecutionContext * | context,
 |  | const CallSetupProgressArg & | arg
 | ) |

CallSetupProgressMsg::~CallSetupProgressMsg ( ) [virtual]

Member Function Documentation

Message * CallSetupProgressMsg::Clone ( ) const [virtual]

Implements Message.

const CallSetupProgressArg& CallSetupProgressMsg::GetArg ( ) const [inline]

const MsgMetaData & CallSetupProgressMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CallSetupProgressMsg::SetArg ( const CallSetupProgressArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallSsAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallSsAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for CallSsAction:

[legend]
Collaboration diagram for CallSsAction:

[legend]

Public Types

enum CallSsActionId {
ReleaseAllHeldOrSetUdub, ReleaseAllActiveAndAcceptOther, ReleaseSpecificCall, PlaceAllActiveOnHold,
PlaceAllActiveOnHoldExceptSpecificCall, AddHeldCall, ConnectTwoCallsAndDisconnectSubscriber, RedirectCall,
ActivateCompletionOfCalls, Invalid
}
Type of Supplementary Service as defined in 3GPP TS 22.030. More...

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
CallSsAction ()
virtual InputActionType | GetActionType () const
Returns the type of the action.
INT | GetCallIdx () const
Returns the call index for the cases "1X" and "2X".
CallSsActionId | GetCallSsActionId () const
Returns the type of Supplementary Service.
const PhoneNumber & | GetPhoneNumber () const
Returns the phonenumber for the case of "4*phonenumber".
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual | ~CallSsAction ()

Detailed Description

CallSsAction analyzes if the input string has the meaning of handling supplementary services within a call. It will not be checked if calls are active. Execute has to be overwritten to implement the different supplementary services.

Member Enumeration Documentation

enum CallSsAction::CallSsActionId

Type of Supplementary Service as defined in 3GPP TS 22.030.

Enumerator:
ReleaseAllHeldOrSetUdub
ReleaseAllActiveAndAcceptOther
ReleaseSpecificCall
PlaceAllActiveOnHold
PlaceAllActiveOnHoldExceptSpecificCall
AddHeldCall
ConnectTwoCallsAndDisconnectSubscriber
RedirectCall
ActivateCompletionOfCalls
Invalid

Constructor & Destructor Documentation

CallSsAction::CallSsAction ( )

CallSsAction::~CallSsAction ( ) [virtual]

Member Function Documentation

InputAction * CallSsAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType CallSsAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

INT CallSsAction::GetCallIdx ( ) const [inline]

Returns the call index for the cases "1X" and "2X".

CallSsActionId CallSsAction::GetCallSsActionId ( ) const [inline]

Returns the type of Supplementary Service.

const PhoneNumber& CallSsAction::GetPhoneNumber ( ) const [inline]

Returns the phonenumber for the case of "4*phonenumber".

BOOLEAN CallSsAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:04:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallTypeTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallTypeTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for CallTypeTable:

[legend]
Collaboration diagram for CallTypeTable:

[legend]

Static Public Member Functions

static const WCHAR * | GetCallType (CsdDataConnProfile::CallType call_type)
static const UINT | GetSize ()

Member Function Documentation

static const WCHAR* CallTypeTable::GetCallType ( CsdDataConnProfile::CallType call_type ) [inline, static]

static const UINT CallTypeTable::GetSize ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:04:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallWaitingActivatedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallWaitingActivatedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallWaitingActivatedMsg:

[legend]
Collaboration diagram for CallWaitingActivatedMsg:

[legend]

Public Types

enum | { ID = 18519 }

Public Member Functions

CallWaitingActivatedMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status, const Vector< SsGroup > &basic_service_list, const ServiceGroup &param_basic_service)
virtual Message * | Clone () const
const Vector< SsGroup > & | GetBasicServiceList () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParamBasicService () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~CallWaitingActivatedMsg ()

Detailed Description

CallWaitingActivatedMsg: sent when call waiting was activated

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallWaitingActivatedMsg::CallWaitingActivatedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status,
 |  | const Vector< SsGroup > & | basic_service_list,
 |  | const ServiceGroup & | param_basic_service
 | ) |

CallWaitingActivatedMsg::~CallWaitingActivatedMsg ( ) [virtual]

Member Function Documentation

Message * CallWaitingActivatedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<SsGroup>& CallWaitingActivatedMsg::GetBasicServiceList ( ) const [inline]

const MsgMetaData & CallWaitingActivatedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallWaitingActivatedMsg::GetParamBasicService ( ) const [inline]

const SsStatus& CallWaitingActivatedMsg::GetSsStatus ( ) const [inline]

const Tipd& CallWaitingActivatedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallWaitingDeactivatedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallWaitingDeactivatedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallWaitingDeactivatedMsg:

[legend]
Collaboration diagram for CallWaitingDeactivatedMsg:

[legend]

Public Types

enum | { ID = 18520 }

Public Member Functions

CallWaitingDeactivatedMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status, const Vector< SsGroup > &basic_service_list, const ServiceGroup &param_basic_service)
virtual Message * | Clone () const
const Vector< SsGroup > & | GetBasicServiceList () const
virtual const MsgMetaData & | GetMetaData () const
const ServiceGroup & | GetParamBasicService () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~CallWaitingDeactivatedMsg ()

Detailed Description

CallWaitingDeactivatedMsg: sent when CallWaiting was deactivated

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallWaitingDeactivatedMsg::CallWaitingDeactivatedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status,
 |  | const Vector< SsGroup > & | basic_service_list,
 |  | const ServiceGroup & | param_basic_service
 | ) |

CallWaitingDeactivatedMsg::~CallWaitingDeactivatedMsg ( ) [virtual]

Member Function Documentation

Message * CallWaitingDeactivatedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<SsGroup>& CallWaitingDeactivatedMsg::GetBasicServiceList ( ) const [inline]

const MsgMetaData & CallWaitingDeactivatedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& CallWaitingDeactivatedMsg::GetParamBasicService ( ) const [inline]

const SsStatus& CallWaitingDeactivatedMsg::GetSsStatus ( ) const [inline]

const Tipd& CallWaitingDeactivatedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallWaitingHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallWaitingHandler Class Reference

#include <Apoxi/Asc/CallWaitingHandler.hpp>

Public Types

enum | { ID = CallWaitingHandlerId }

Public Member Functions

SsApiRc | Activate (ServiceGroup basic_service=AllServices, const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
CallWaitingHandler ()
SsApiRc | Deactivate (ServiceGroup basic_service=AllServices, const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
virtual HandlerId | GetHandlerId () const
SsApiRc | RequestStatus (ServiceGroup basic_service, const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE)
SsApiRc | RequestStatus (ServiceGroup basic_service, const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
SsApiRc | RequestStatus (const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE, LineSelector line=InvalidLine)
virtual | ~CallWaitingHandler ()

Detailed Description

The CallWaitingHandler is a SS handler responsible for modifying the Call Waiting SS. This includes activating and deactivating the service as well as interrogating the current status. The handler provides various methods for these purposes.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Constructor & Destructor Documentation

CallWaitingHandler::CallWaitingHandler ( )

CallWaitingHandler::~CallWaitingHandler ( ) [virtual]

Member Function Documentation

SsApiRc CallWaitingHandler::Activate | ( | ServiceGroup | basic_service = AllServices,
 |  | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Activates call waiting.
Activates the call waiting service and optionally for a specific basic service group.
This method triggers sending of *43*<basic_service># to the mobile network. The transaction is initiated using the main handler and the resulting tipd is stored along with the parameters.

Parameters:
basic_service | The basic service group of the request (all services, all teleservices, etc.), defaults to all services.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return.
See also:
SsMainHandler

SsApiRc CallWaitingHandler::Deactivate | ( | ServiceGroup | basic_service = AllServices,
 |  | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Deactivates call waiting.
Deactivates the call waiting service and optionally for a specific basic service group.
This method triggers sending of #43*<basic_service># to the mobile network. The transaction is initiated using the main handler and the resulting tipd is stored along with the parameters.

Parameters:
basic_service | The basic service group of the request (all services, all teleservices, etc.), defaults to all services.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return.
See also:
SsMainHandler

HandlerId CallWaitingHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
CallWaitingHandlerId

SsApiRc CallWaitingHandler::RequestStatus | ( | ServiceGroup | basic_service,
 |  | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE
 | ) |

Interrogates the call waiting status.
This method triggers sending of *#43# to the mobile network. The transaction is initiated using the main handler and the resulting tipd is stored.

Parameters:
basic_service | The basic service group of the request (all services, all teleservices, etc.)
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return.
See also:
SsMainHandler

SsApiRc CallWaitingHandler::RequestStatus | ( | ServiceGroup | basic_service,
 |  | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Interrogates the call waiting status.
This method triggers sending of *#43# to the mobile network. The transaction is initiated using the main handler and the resulting tipd is stored.

Parameters:
basic_service | The basic service group of the request (all services, all teleservices, etc.)
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return.
See also:
SsMainHandler

SsApiRc CallWaitingHandler::RequestStatus | ( | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE,
 |  | LineSelector | line = InvalidLine
 | ) |

Interrogates the call waiting status.
This method triggers sending of *#43# to the mobile network. The transaction is initiated using the main handler and the resulting tipd is stored.

THIS METHOD IS DEPRECATED. Use Request Status with basic service instead.

Parameters:
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return.
See also:
SsMainHandler

The documentation for this class was generated from the following files:
  • Asc/CallWaitingHandler.hpp
  • Asc/CallWaitingHandler.cpp
Generated on Wed Jan 25 01:04:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallWaitingStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CallWaitingStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CallWaitingStatusMsg:

[legend]
Collaboration diagram for CallWaitingStatusMsg:

[legend]

Public Types

enum | { ID = 18521 }

Public Member Functions

CallWaitingStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status, const Vector< SsGroup > &basic_service_list)
virtual Message * | Clone () const
const Vector< SsGroup > & | GetBasicServiceList () const
virtual const MsgMetaData & | GetMetaData () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~CallWaitingStatusMsg ()

Detailed Description

CallWaitingStatusMsg: sent when CallWaiting status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CallWaitingStatusMsg::CallWaitingStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status,
 |  | const Vector< SsGroup > & | basic_service_list
 | ) |

CallWaitingStatusMsg::~CallWaitingStatusMsg ( ) [virtual]

Member Function Documentation

Message * CallWaitingStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const Vector<SsGroup>& CallWaitingStatusMsg::GetBasicServiceList ( ) const [inline]

const MsgMetaData & CallWaitingStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsStatus& CallWaitingStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& CallWaitingStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:04:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Camera Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Camera Class Reference
[Devices, Devices, Devices, Devices, Devices, Devices]

#include <Apoxi/Devices/BP30/Camera.hpp>

Inheritance diagram for Camera:

[legend]
Collaboration diagram for Camera:

[legend]

Public Types

enum | ActionType { Decrease, Reset, Increase }
enum | AntiFlickerType { AntiFlickerNotSupported, AntiFlickerDisabled, AntiFlickerHz50, AntiFlickerHz60 }
enum CameraError {
NoError, CameraAlreadyLockedError, CameraNotReadyError, UnsupportedCameraFeature,
CameraNotInitializedError, BufferNotAvailableError, BufferAllocationError, VideoEncoderBufferAllocationError,
ApplicationControlError, UnsupportedFrameRateError, InvalidCameraParameter, InvalidSizeError,
JpegEncodingError, UserAbortedError
}
enum CameraState {
UnitializedState, IdleState, ViewfindingState, ViewfinderHiddenState,
ImageCapturingState, VideoCapturingState, VideoCapturingHiddenState, ViewfinderHoldState,
ViewfinderHoldHiddenState, VideoCapturingPausedState, ErrorState
}
enum FilterType {
NoFilter = 0, SepiaFilter, EmbossFilter, GrayScaleFilter,
NegativeFilter, HorrorFilter = 50, HazeFilter = 51, GlassTileFilter = 52,
PuzzleTileFilter = 53, OilpaintFilter = 54, PictureFrameFilter = 55, FilmFilter = 56,
ConcaveFilter = 57, EndOfFilterType
}
enum FlashType {
FlashNotSupported, FlashDisabled, FlashEnabled, AutomaticFlash,
RedEyeReductionFlash
}
enum ImageSizeType {
QqcifSize, Size96x96, SqcifSize, QqvgaSize,
QcifSize, QsifSize, QvgaSize, CifSize,
VgaSize, SvgaSize, XgaSize, Size1Mp,
Size1_3Mp, SxgaSize, UxgaSize, Size2Mp,
Size3Mp, EndOfImageSizeType
}
enum | MeteringType { FullImageMetering, CenterBasedMetering }
typedef Camera::ParameterLimits | ParameterLimits
enum Result {
ViewfinderStarted, ViewfinderStopped, BrightnessChanged, ContrastChanged,
ExposureChanged, FilterChanged, AntiflickerChanged, TwilightChanged,
WhiteBalanceChanged, FrameRateChanged, VideoCaptureStarted, VideoCaptureStopped,
VideoCapturePaused, VideoCaptureUnPaused
}
enum | ScalingMethodType { NoScaling, LetterboxScaling, BestFitScaling }
enum TransformationType {
NoTransformation, Rotate90, Rotate180, Rotate270,
Mirror, MirrorRotate90, MirrorRotate180, MirrorRotate270
}
enum | TwilightType { TwilightOff, TwilightOn, TwilightAuto }
enum WhiteBalanceType {
AutoBalance, SunlightBalance, CloudyBalance, IncandescentBalance,
FluorescentBalance
}

Public Member Functions

Camera (INT category, INT device_id)
virtual BOOLEAN | Close ()
AntiFlickerType | GetAntiFlickerMode () const
INT | GetBrightness () const
BOOLEAN | GetBrightnessLimits (INT &min_level, INT &max_level, INT &def_level)
TransformationType | GetCaptureTransformation () const
INT | GetContrast () const
BOOLEAN | GetContrastLimits (INT &min_level, INT &max_level, INT &def_level)
INT | GetDisplayIndex () const
BOOLEAN | GetEffectiveViewfinderRect (Rect &effective_rect)
INT | GetExposure () const
BOOLEAN | GetExposureLimits (INT &min_level, INT &max_level, INT &def_level)
FilterType | GetFilter () const
FlashType | GetFlash () const
INT | GetLastError () const
MeteringType | GetMeteringMode () const
ImageSizeType | GetSelectedImageSize () const
CameraState | GetState () const
virtual BOOLEAN | GetSupportedImageSizes (const ImageSizeType *&array, UINT8 &count) const
TwilightType | GetTwilightMode () const
ScalingMethodType | GetViewScalingMethod () const
WhiteBalanceType | GetWhiteBalance () const
virtual INT | GetZoomLevelCount () const
virtual BOOLEAN | HideViewfinder ()
BOOLEAN | IsTwinViewfinderEnabled () const
virtual BOOLEAN | Open ()
virtual BOOLEAN | RestartViewfinder ()
BOOLEAN | SetAntiFlickerMode (AntiFlickerType anti_flicker_mode)
BOOLEAN | SetBrightness (INT brightness)
virtual BOOLEAN | SetCaptureImageSize (ImageSizeType capture_image_size, TransformationType capture_transformation=Camera::NoTransformation)
BOOLEAN | SetContrast (INT level)
BOOLEAN | SetExposure (INT level)
BOOLEAN | SetFilter (FilterType filter)
BOOLEAN | SetFlash (FlashType flash)
BOOLEAN | SetMeteringMode (MeteringType metering_mode)
BOOLEAN | SetTwilightMode (TwilightType twilight)
BOOLEAN | SetTwinViewfinderEnabled (BOOLEAN enabled)
virtual BOOLEAN | SetViewfinderRect (Rect &vf_rect, INT display_idx=0, TransformationType view_transformation=NoTransformation, ScalingMethodType view_scaling_method=NoScaling)
virtual BOOLEAN | SetViewScalingMethod (ScalingMethodType scaling_method)
BOOLEAN | SetWhiteBalance (WhiteBalanceType white_balance_mode)
virtual BOOLEAN | SetZoom (ActionType action, UINT8 step_size=1)
virtual BOOLEAN | ShowViewfinder ()
virtual BOOLEAN | StartViewfinder ()
virtual BOOLEAN | StopViewfinder ()
virtual | ~Camera ()

Static Public Member Functions

static const Size | GetImageSizeDimensions (ImageSizeType size_type)

Protected Member Functions

UINT16 | CalcCameraScalingRate (ImageSizeType imageType, INT device_zoom_level)
UINT16 | CalcCameraScalingRate (ImageSizeType imageType, INT device_zoom_level)
UINT16 | CalcCameraScalingRate (ImageSizeType imageType, INT device_zoom_level)
virtual BOOLEAN & | GetLock ()
virtual BOOLEAN & | GetLock ()
virtual BOOLEAN & | GetLock ()
virtual BOOLEAN & | GetLock ()
virtual BOOLEAN & | GetLock ()
virtual BOOLEAN & | GetLock ()
INT | GetZoom ()
INT | GetZoom ()
INT | GetZoom ()
void | SetState (CameraState state)
void | SetState (CameraState state)
void | SetState (CameraState camera_state)
void | SetState (CameraState camera_state)
void | SetState (CameraState camera_state)
void | SetState (CameraState state)

Protected Attributes

INT | m_brightness_level
CamWin32 * m_cam_win32
ImageSizeType m_capture_image_size
INT | m_contrast_level
INT | m_exposure_level
FlashType m_flash
ImageSizeType m_image_size
INT | m_last_error
MeteringType m_metering_mode
Rect m_rect
TransformationType m_view_image_transformation
WhiteBalanceType m_white_balance
INT | m_zoom_level

Data Structures

struct | ParameterLimits
struct | ParameterStruct
struct | ParameterStruct
struct | ParameterStruct
struct | ViewfinderInfo

Detailed Description

Base implementation accessing hardware cameras

Member Typedef Documentation

typedef struct Camera::ParameterLimits Camera::ParameterLimits

Member Enumeration Documentation

enum Camera::ActionType

defines the action which will be performed for changing the zoom

Enumerator:
Decrease | Decreases zoom level.
Reset | resets zoom level to default
Increase | increases zoom level

enum Camera::AntiFlickerType

Types for AntiFlicker

Enumerator:
AntiFlickerNotSupported | will be used as return value if no anti flicker is supported
AntiFlickerDisabled | Anti flicker reduction is disabled.
AntiFlickerHz50 | Anti flicker is set to compensate 50Hz environment.
AntiFlickerHz60 | Anit flicker is set to compensate 60Hz environment.

enum Camera::CameraError

Error codes in case of FALSE return type in camera methods or in case of CameraErrorMsg

Enumerator:
NoError
CameraAlreadyLockedError | This error occurs, if another application is already using the CameraDevice.
CameraNotReadyError | Reports a driver problem.
UnsupportedCameraFeature | indicates, that the requested feature is not present for the camera
CameraNotInitializedError | Camera has not been initialzed properly.
BufferNotAvailableError | indicates, that one buffer from BufferPoolManager is not available (for MMFr)
BufferAllocationError | indicates, that not enough buffer are available for capturing
VideoEncoderBufferAllocationError | not enough memory for VideoEncoder is available
ApplicationControlError | Application made.
UnsupportedFrameRateError | Framerate is not supported for this Camera.
InvalidCameraParameter | Usually, this indicated, that application tried to set a value, which is out of range.
InvalidSizeError | Image size is not supported or not known.
JpegEncodingError | during JPEG encoding, an error occured
UserAbortedError | user aborted capturing process

enum Camera::CameraState

Enumerator:
UnitializedState
IdleState
ViewfindingState
ViewfinderHiddenState
ImageCapturingState
VideoCapturingState
VideoCapturingHiddenState
ViewfinderHoldState
ViewfinderHoldHiddenState
VideoCapturingPausedState
ErrorState

enum Camera::FilterType

Filters between 50 and 100 are custom ones

Enumerator:
NoFilter
SepiaFilter
EmbossFilter
GrayScaleFilter
NegativeFilter
HorrorFilter
HazeFilter
GlassTileFilter
PuzzleTileFilter
OilpaintFilter
PictureFrameFilter
FilmFilter
ConcaveFilter
EndOfFilterType

enum Camera::FlashType

FlashType has several flash modes

Enumerator:
FlashNotSupported
FlashDisabled | Flash or Flash LED will be set to off.
FlashEnabled | Flash LED will be set to on or in case of a real flash, next snapshot will be with flash.
AutomaticFlash | Camera decides wheter to use flash or not.
RedEyeReductionFlash | Enables red-eye-reduction flash.

enum Camera::ImageSizeType

ImageSize has given list of possible predefined image sizes

Enumerator:
QqcifSize | 88x72
Size96x96 | 96x96
SqcifSize | 128x96
QqvgaSize | 160x120
QcifSize | 176x144
QsifSize | 276x120
QvgaSize | 320x240
CifSize | 352x288 - 0.3 Mp
VgaSize | 640x480
SvgaSize | 800x600
XgaSize | 1024x768
Size1Mp | 1152x864 - 1.0 Mp
Size1_3Mp | 1280x960 - 1.3 Mp
SxgaSize | 1280x1024
UxgaSize | 1600x1200
Size2Mp | 1728x1152
Size3Mp | 2048x1536 - 3.0 Mp
EndOfImageSizeType

enum Camera::MeteringType

Enumerator:
FullImageMetering | average luminance of whole image will be used for metering
CenterBasedMetering | center of image has more priority for metering than other parts

enum Camera::Result

Enumerator:
ViewfinderStarted
ViewfinderStopped
BrightnessChanged
ContrastChanged
ExposureChanged
FilterChanged
AntiflickerChanged
TwilightChanged
WhiteBalanceChanged
FrameRateChanged
VideoCaptureStarted
VideoCaptureStopped
VideoCapturePaused
VideoCaptureUnPaused

enum Camera::ScalingMethodType

Predefined scaling method for viewfinder

Enumerator:
NoScaling | Viewfinder will not be scaled but just cropped to given area.
LetterboxScaling | Viewfinder will be scaled using letterbox to given area.
BestFitScaling | Viewfinder will be scaled to fill out the given area best cropping could be done on top/bottom and left/right side

enum Camera::TransformationType

Transformation for viewfinder and/or captured image, which can be set in Camera::SetViewfinderRect and Camera::SetCaptureTransformation.

Enumerator:
NoTransformation | Default type. No transformation is done.
Rotate90 | Will rotate the image orientation 90 degrees in a clockwise direction.
Rotate180 | Will rotate the image orientation 180 degrees in a clockwise direction.
Rotate270 | Will rotate the image orientation 270 degrees in a clockwise direction.
Mirror | Will mirror the image.
MirrorRotate90 | Will first mirror the image and the rotate the image 90 degrees clockwise.
MirrorRotate180 | Will first mirror the image and the rotate the image 180 degrees clockwise.
MirrorRotate270 | Will first mirror the image and the rotate the image 270 degrees clockwise.

enum Camera::TwilightType

Twilight modes

Enumerator:
TwilightOff | No twilight enhancement.
TwilightOn | Twilight enhancement enabled.
TwilightAuto | Automatic setting for twilight.

enum Camera::WhiteBalanceType

Types for setting WhiteBalance

Enumerator:
AutoBalance | Camera sensor decides best WB.
SunlightBalance | WB for Sunlight surrounding.
CloudyBalance | WB for cloudy surrounding.
IncandescentBalance | WB for indoor surrounding.
FluorescentBalance | WB for fluorescent surrounding.

Constructor & Destructor Documentation

Camera::Camera | ( | INT | category,
 |  | INT | device_id
 | ) |

Parameters:
category | See AbstractDevice::Category
device_id | DeviceId of Camera

Camera::~Camera ( ) [virtual]

Member Function Documentation

UINT16 Camera::CalcCameraScalingRate | ( | ImageSizeType | imageType,
 |  | INT | device_zoom_level
 | ) | [protected]

UINT16 Camera::CalcCameraScalingRate | ( | ImageSizeType | imageType,
 |  | INT | device_zoom_level
 | ) | [protected]

Calculates the camera scaling rate of image size type and device zoom level.

UINT16 Camera::CalcCameraScalingRate | ( | ImageSizeType | imageType,
 |  | INT | device_zoom_level
 | ) | [protected]

Calculates the camera scaling rate of image size type and device zoom level.

BOOLEAN Camera::Close ( ) [virtual]

Close() frees any allocated buffers for capturing and unlocks the camera.

Returns:
returns FALSE if unlocking or buffer deallocation fails.

Reimplemented in StillCamera, StillCamera, VideoCamera, StillCamera, and StillCamera.

Camera::AntiFlickerType Camera::GetAntiFlickerMode ( ) const

Returns:
the current value for anti flicker mode. If anti flicker mode is not supported, NotSupported is returned.

INT Camera::GetBrightness ( ) const

Gets the brightness for the viewfinder

Returns:
the brightness value which is actual used

BOOLEAN Camera::GetBrightnessLimits | ( | INT & | min_level,
 |  | INT & | max_level,
 |  | INT & | def_level
 | ) |

Gets the brightness limits for the viewfinder

Parameters:
min_level | the minimal brightness level
max_level | the maximal brightness level
def_level | the default brightness level
Returns:
returns TRUE if get brightness was successful

Camera::TransformationType Camera::GetCaptureTransformation ( ) const

Returns:
returns the currently set rotation for captured images

INT Camera::GetContrast ( ) const

Gets the contrast for the viewfinder

Returns:
the contrast value which is actual used

BOOLEAN Camera::GetContrastLimits | ( | INT & | min_level,
 |  | INT & | max_level,
 |  | INT & | def_level
 | ) |

Gets the contrast limits for the viewfinder

Parameters:
min_level | the minimal contrast level
max_level | the maximal contrast level
def_level | the default contrast level
Returns:
returns TRUE if get contrast was successful

BOOLEAN Camera::GetEffectiveViewfinderRect ( Rect & effective_rect )

GetEffectiveViewFinderRect() currents the viewfinder rectangle, which may have been adapted by driver after calling StartViewfinder().

Parameters:
effective_rect returns the adapted viewfinder rect.
Returns:
returns TRUE if viewfinder rect has changed.

INT Camera::GetExposure ( ) const

Retrieves currently set exposure level

BOOLEAN Camera::GetExposureLimits | ( | INT & | min_level,
 |  | INT & | max_level,
 |  | INT & | def_level
 | ) |

Retrieves exposure limits of camera.

Parameters:
min_level | the minimal exposure level
max_level | the maximum exposure level
def_level | the default exposure level
Returns:
returns TRUE if retrieved levels are valid.

Camera::FilterType Camera::GetFilter ( ) const

Returns:
returns the currently set filter, which is applied on viewfinder and snapshots.

Camera::FlashType Camera::GetFlash ( ) const

Returns:
selected flash type, if the camera does not have a flash, always returns FlashNotSupported.

const Size Camera::GetImageSizeDimensions ( ImageSizeType size_type ) [static]

returns the with and height in pixel corresponding to the given ImageSizeType enum.

Parameters:
size_type Image size
Returns:
width and height of given size.

virtual BOOLEAN& Camera::GetLock ( ) [inline, protected, virtual]

See also:
AbstractLockableDevice::GetLock

Implements AbstractLockableDevice.

virtual BOOLEAN& Camera::GetLock ( ) [inline, protected, virtual]

See also:
AbstractLockableDevice::GetLock

Implements AbstractLockableDevice.

virtual BOOLEAN& Camera::GetLock ( ) [inline, protected, virtual]

See also:
AbstractLockableDevice::GetLock

Implements AbstractLockableDevice.

virtual BOOLEAN& Camera::GetLock ( ) [inline, protected, virtual]

See also:
AbstractLockableDevice::GetLock

Implements AbstractLockableDevice.

virtual BOOLEAN& Camera::GetLock ( ) [inline, protected, virtual]

See also:
AbstractLockableDevice::GetLock

Implements AbstractLockableDevice.

virtual BOOLEAN& Camera::GetLock ( ) [inline, protected, virtual]

See also:
AbstractLockableDevice::GetLock

Implements AbstractLockableDevice.

Camera::MeteringType Camera::GetMeteringMode ( ) const

Retrieves currently set metering mode for viewfinder and captured images.

Camera::ImageSizeType Camera::GetSelectedImageSize ( ) const

Returns:
the current set image size for snapshots.

BOOLEAN Camera::GetSupportedImageSizes | ( | const ImageSizeType *& | array,
 |  | UINT8 & | count
 | ) | const [virtual]

GetSupportedImageSizes delivers an array of type ImageSizeType with the supported image sizes of the camera.

Parameters:
array | returns an array of possible sizes for images
count | returns the number of supported image sizes
Returns:
returns FALSE if operation was not successful.

Camera::TwilightType Camera::GetTwilightMode ( ) const

Returns:
returns the current set twilight mode.

Camera::ScalingMethodType Camera::GetViewScalingMethod ( ) const

Returns:
the currently set scaling method for the viewfinder.

Camera::WhiteBalanceType Camera::GetWhiteBalance ( ) const

Retrieves currently set white balance for camera

INT Camera::GetZoom ( ) [protected]

INT Camera::GetZoom ( ) [protected]

Get current set zoom level.

INT Camera::GetZoom ( ) [protected]

Get current set zoom level.

INT Camera::GetZoomLevelCount ( ) const [virtual]

Gets the number of zoom levels. The number of zoom levels depends on the choosen capture image size and the choosen capture transformation.

Returns:
returns The number of zoom levels supported by choosen capture image size and capture transformation.

BOOLEAN Camera::HideViewfinder ( ) [virtual]

HideViewfinder() allows an application to draw over the viewfinder. The camera will not refresh the viewfinder but remains active.

Returns:
returns FALSE if an hardware error occurred or this feature is not available.

BOOLEAN Camera::IsTwinViewfinderEnabled ( ) const

returns TRUE if twinviewfinder is currently enabled

BOOLEAN Camera::Open ( ) [virtual]

Open() sets default values for the Camera which are available through a CameraConfig or by driver. Furthermore it tries to Lock the Camera for exclusive usage.

Returns:
returns FALSE, if setting values or locking failed.

Reimplemented in StillCamera, VideoCamera, and StillCamera.

BOOLEAN Camera::RestartViewfinder ( ) [virtual]

BOOLEAN Camera::SetAntiFlickerMode ( AntiFlickerType anti_flicker_mode )

Enables or disables the anti flicker mode. The scanning frequency can be toggled between 50 and 60Hz. If the camera does not support an anti flicker mode, this does not have an effect and FALSE is returned.

Parameters:
anti_flicker_mode the requested anti flicker mode.
Returns:
TRUE if setting the anti flicker mode was successful, FALSE otherwise.

BOOLEAN Camera::SetBrightness ( INT brightness )

Sets the brightness for the viewfinder

Parameters:
brightness define the brightness value to be performed
Returns:
returns FALSE if brightness level was out of range.

BOOLEAN Camera::SetCaptureImageSize | ( | ImageSizeType | capture_image_size,
 |  | TransformationType | capture_transformation = Camera::NoTransformation
 | ) | [virtual]

Sets the capture image size for snapshots and video capturing.

Parameters:
capture_image_size | predefined image size for captured image.
capture_transformation | capture image transformation.
Returns:
returns TRUE if given size is possible

BOOLEAN Camera::SetContrast ( INT level )

Sets the contrast for the viewfinder

Parameters:
level define the contrast value to be performed. Configration of contrast range is done via CameraConfig
Returns:
returns FALSE if contrast level was out of range

BOOLEAN Camera::SetExposure ( INT level )

This function is used to set the exposure value level of the camera sensor Exposure value is the relationship between aperture and shutter time. Changing the exposure value is done by changing the exposure time, as changing the aperture is not possible on mobile cameras. Thus, this controls how much light is allowed to hit the sensor

Parameters:
level level in between range given by GetExposureLimits()
Returns:
returns TRUE if exposure level was set successfully

BOOLEAN Camera::SetFilter ( FilterType filter )

SetFilter() applies an image effect on the viewfinder and on the captured image. This feature is highly hardware dependent and in case of no filter support FALSE is returned.

Parameters:
filter desired filter
Returns:
returns TRUE if applying filter was successful

BOOLEAN Camera::SetFlash ( FlashType flash )

Enables or disables the flash. If the camera does not have a flash, this does not have an effect and FALSE is returned.

Parameters:
flash desired flash type for the next snapshot
Returns:
TRUE if setting the flash was ok, FALSE otherwise.

BOOLEAN Camera::SetMeteringMode ( MeteringType metering_mode )

Changes the metering mode of the camera. Usually, the average luminace will be used in the whole picture will be used for adjusting the exposure time. If there is a bright light source from the side, this can be compensated by giving center luminace a higher value than outer parts of the picture.

Parameters:
metering_mode desired metering for the camera sensor.
Returns:
returns TRUE if desired metering is available.

void Camera::SetState ( CameraState state ) [inline, protected]

void Camera::SetState ( CameraState state ) [inline, protected]

void Camera::SetState ( CameraState camera_state ) [protected]

void Camera::SetState ( CameraState camera_state ) [protected]

void Camera::SetState ( CameraState camera_state ) [protected]

void Camera::SetState ( CameraState state ) [inline, protected]

BOOLEAN Camera::SetTwilightMode ( TwilightType twilight )

Enables or disables the twilight mode or sets it into automatic mode. This increases the sensitivity of the camera's imaging sensor. If the camera does not support a twilight mode, this does not have an effect and FALSE is returned. By default, camera operates in twilight off mode.

Parameters:
twilight sets desired twilight mode.
Returns:
TRUE if setting the twilight mode was successful, FALSE otherwise.

BOOLEAN Camera::SetTwinViewfinderEnabled ( BOOLEAN enabled )

This method enables twin viewfinder support, which means, that the viewfinder will be displayed on BOTH displays at the same time. This feature is ONLY available, if feature define APOXI_CAMERA_TWINVIEWFINDER_SUPPORT is set. The sequence for using twinviewfinder is as follows:

Viewfinder on Main only:

Camera::SetViewfinderRect(main_rect, 0, NoTransformation); // setting up rect for main display Camera::StartViewfinder(); // starts viewfinder on main Camera::StopViewfinder(); // stops viewfinder on main

Viewfinder on sub only:

Camera::SetViewfinderRect(sub_rect, 1, Rotate180); // example for sub display rect, rotated Camera::StartViewfinder(); // starts viewfinder on sub Camera::StopViewfinder(); // stops viewfinder on sub

Viewfinder both in main and sub:

Camera::SetViewfinderRect(main_rect, 0, NoTransformation); // setup viewfinder for main Camera::SetViewfinderRect(sub_rect, 1, Rotate180); // setup viewfinder for sub Camera::SetTwinViewfinderEnabled(TRUE); // sets viewfinder to both main&sub Camera::StartViewfinder(); // starts both main and sub Camera::StopViewfinder(); // stops both main and sub

Parameters:
enabled enables twinviewfinder
Returns:
returns FALSE if twinviewfinder is not supported, or viewfinder configuration is invalid (missing rect for subdisplay)

BOOLEAN Camera::SetViewfinderRect | ( | Rect & | vf_rect,
 |  | INT | display_idx = 0,
 |  | TransformationType | view_transformation = NoTransformation,
 |  | ScalingMethodType | view_scaling_method = NoScaling
 | ) | [virtual]

Sets the rectangle, display, orientation and scaling of the camera viewfinder.

Parameters:
vf_rect | Rectangle which describes the viewfinder (in and out parameter)
display_idx | Index of display where viewfinder should be drawn at, default is main display
view_transformation | Desired orientation of the viewfinder, default is normal orientation.
view_scaling_method | Desirted scaling method, default is no scaling.
Returns:
Returns TRUE if viewfinder size, position and orientation is valid.

BOOLEAN Camera::SetViewScalingMethod ( ScalingMethodType scaling_method ) [virtual]

SetViewScalingMethod() defines, which scaling method should be applied for the viewfinder. This function needs to be set before enabling the viewfinder but is optional.

Parameters:
scaling_method scaling method for viewfinder
Returns:
returns FALSE if desired scaling method is not applicable.

BOOLEAN Camera::SetWhiteBalance ( WhiteBalanceType white_balance_mode )

SetWhiteBalance sets the camera white balance mode.

Parameters:
white_balance_mode desired white balance mode type.
Returns:
returns TRUE when setting of white balance is successful. Otherwise FALSE is returned.

BOOLEAN Camera::SetZoom | ( | ActionType | action,
 |  | UINT8 | step_size = 1
 | ) | [virtual]

Sets the zoom factor for the viewfinder

Parameters:
action | defines which zooming action should be performed. Decrease - decreases zoom level Increase - increases zoom level Reset - resets zoom level to default value
step_size | Step changes the interval on the performed action
Returns:
returns FALSE if zoom is out of range or driver error.

BOOLEAN Camera::ShowViewfinder ( ) [virtual]

ShowViewfinder() again displays the viewfinder on the display. Display content will be overwritten by the camera again.

Returns:
returns FALSE if an hardware error occurred or this feature is not available.

BOOLEAN Camera::StartViewfinder ( ) [virtual]

StartViewfinder() enables the viewfinder on the display and sets the camera into active mode.

Returns:
returns FALSE if viewfinder can not be started due to missing preconditions or a hardware failure.

Reimplemented in VideoCamera.

BOOLEAN Camera::StopViewfinder ( ) [virtual]

StopViewFinder() stops the viewfinder and shuts down the camera.

Returns:
returns FALSE if an hardware error occurred.

Reimplemented in VideoCamera.

Field Documentation

INT Camera::m_brightness_level [protected]

Brightness level.

CamWin32* Camera::m_cam_win32 [protected]

ImageSizeType Camera::m_capture_image_size [protected]

The capture image size.

INT Camera::m_contrast_level [protected]

Contrast level.

INT Camera::m_exposure_level [protected]

Exposure level.

FlashType Camera::m_flash [protected]

Flash

ImageSizeType Camera::m_image_size [protected]

INT Camera::m_last_error [protected]

The last error.

MeteringType Camera::m_metering_mode [protected]

Rect Camera::m_rect [protected]

Current viewfinder rectangle.

TransformationType Camera::m_view_image_transformation [protected]

The viewfinder image transformation.

WhiteBalanceType Camera::m_white_balance [protected]

WhiteBalance

INT Camera::m_zoom_level [protected]

The set zoom level.

The documentation for this class was generated from the following files:
  • Devices/BP30/Camera.hpp
  • Devices/CameraInterface.hpp
  • Devices/MPE/Camera.hpp
  • Devices/MPEU/Camera.hpp
  • Devices/MPEU/Extensions/AtiW2282/Camera.hpp
  • Devices/SGold/Camera.hpp
  • Devices/Win32/Camera.hpp
  • Devices/BP30/Camera.cpp
  • Devices/MPE/Camera.cpp
  • Devices/MPEU/Camera.cpp
  • Devices/MPEU/Extensions/AtiW2282/Camera.cpp
  • Devices/SGold/Camera.cpp
  • Devices/SGold/Companion/Epson716/Camera.cpp
  • Devices/SGold/Companion/Scicos3020/Camera.cpp
  • Devices/Win32/Camera.cpp
Generated on Wed Jan 25 01:04:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Camera::ParameterLimits Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Camera::ParameterLimits

Camera::ParameterLimits Struct Reference

#include <Apoxi/Devices/CameraInterface.hpp>

Data Fields

INT | def
INT | max
INT | min

Field Documentation

INT Camera::ParameterLimits::def

INT Camera::ParameterLimits::max

INT Camera::ParameterLimits::min

The documentation for this struct was generated from the following file:
  • Devices/CameraInterface.hpp
Generated on Wed Jan 25 01:04:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CameraApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CameraApp Class Reference

#include <Applications/Camera/CameraApp.hpp>

Collaboration diagram for CameraApp:

[legend]

Public Member Functions

StillCamera * GetCameraReference ()
void | LoadCameraSettings ()
virtual | ~CameraApp ()
Destructor.

Static Public Member Functions

static void | cb_capture_finished (INT result, void *context, UINT16 frame)
static void | cb_image_captured (INT result, void *context, UINT16 frame)
static void | cb_image_encoded (INT result, void *context, UINT16 frame)
static CameraApp * | GetInstance ()
Get an Instance of the CameraApp.

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
Routed via Base class AtlApplication.
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)
Routed via Base class AtlApplication.
virtual void | OnStartup ()

Constructor & Destructor Documentation

CameraApp::~CameraApp ( ) [virtual]

Destructor.

Member Function Documentation

void CameraApp::cb_capture_finished | ( | INT | result,
 |  | void * | context,
 |  | UINT16 | frame
 | ) | [static]

void CameraApp::cb_image_captured | ( | INT | result,
 |  | void * | context,
 |  | UINT16 | frame
 | ) | [static]

void CameraApp::cb_image_encoded | ( | INT | result,
 |  | void * | context,
 |  | UINT16 | frame
 | ) | [static]

StillCamera * CameraApp::GetCameraReference ( )

CameraApp * CameraApp::GetInstance ( ) [static]

Get an Instance of the CameraApp.

void CameraApp::LoadCameraSettings ( )

void CameraApp::OnClose ( ) [protected, virtual]

See also:
Base::OnClose

BOOLEAN CameraApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

Routed via Base class AtlApplication.

BOOLEAN CameraApp::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Base::OnMessage

void CameraApp::OnOpen ( ) [protected, virtual]

See also:
Base::OnOpen

BOOLEAN CameraApp::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [protected, virtual]

Routed via Base class AtlApplication.

void CameraApp::OnStartup ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/Camera/CameraApp.hpp
  • Applications/Camera/CameraApp.cpp
Generated on Wed Jan 25 01:04:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CameraCaptureWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CameraCaptureWin Class Reference

#include <Applications/Camera/CameraCaptureWin.hpp>

Collaboration diagram for CameraCaptureWin:

[legend]

Public Member Functions

BOOLEAN | CancelCamera (INT status)
virtual void | Init (CameraApp *pcamera_app)

Static Public Member Functions

static void | cb_capture_finished (INT result, void *context, UINT16 frame)
static void | cb_image_captured (INT result, void *context, UINT16 frame)
static void | cb_image_encoded (INT result, void *context, UINT16 frame)

Protected Member Functions

Path | GetNewPath (Pathname &path_name_1, WString &deviceIdStr) const
virtual void | OnClose ()
virtual void | OnGetFocus ()
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnPaint (const Rect &repaint_rect)

Protected Attributes

StillCamera * m_camera
BOOLEAN | m_camera_capture_canceling
UINT | m_current_camera_idx
DataSink * | m_File_Sink_Array [MAX_INDEX_FILE_SINK_ARRAY+1]
JpegImage m_jpeg_image
CameraApp * m_pcamera_app

Member Function Documentation

BOOLEAN CameraCaptureWin::CancelCamera ( INT status )

void CameraCaptureWin::cb_capture_finished | ( | INT | result,
 |  | void * | context,
 |  | UINT16 | frame
 | ) | [static]

void CameraCaptureWin::cb_image_captured | ( | INT | result,
 |  | void * | context,
 |  | UINT16 | frame
 | ) | [static]

void CameraCaptureWin::cb_image_encoded | ( | INT | result,
 |  | void * | context,
 |  | UINT16 | frame
 | ) | [static]

Path CameraCaptureWin::GetNewPath | ( | Pathname & | path_name_1,
 |  | WString & | deviceIdStr
 | ) | const [protected]

void CameraCaptureWin::Init ( CameraApp * pcamera_app ) [virtual]

void CameraCaptureWin::OnClose ( ) [protected, virtual]

void CameraCaptureWin::OnGetFocus ( ) [protected, virtual]

void CameraCaptureWin::OnLoseFocus ( ) [protected, virtual]

BOOLEAN CameraCaptureWin::OnMessage ( const Message & msg ) [protected, virtual]

void CameraCaptureWin::OnOpen ( ) [protected, virtual]

void CameraCaptureWin::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

Field Documentation

StillCamera* CameraCaptureWin::m_camera [protected]

BOOLEAN CameraCaptureWin::m_camera_capture_canceling [protected]

UINT CameraCaptureWin::m_current_camera_idx [protected]

DataSink* CameraCaptureWin::m_File_Sink_Array[MAX_INDEX_FILE_SINK_ARRAY+1] [protected]

JpegImage CameraCaptureWin::m_jpeg_image [protected]

CameraApp* CameraCaptureWin::m_pcamera_app [protected]

The documentation for this class was generated from the following files:
  • Applications/Camera/CameraCaptureWin.hpp
  • Applications/Camera/CameraCaptureWin.cpp
Generated on Wed Jan 25 01:04:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CameraMsgStartViewfinding Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CameraMsgStartViewfinding Class Reference

#include <Applications/Camera/MsgTypes.hpp>

Inheritance diagram for CameraMsgStartViewfinding:

[legend]
Collaboration diagram for CameraMsgStartViewfinding:

[legend]

Public Types

enum | { ID = 22700 }

Public Member Functions

CameraMsgStartViewfinding (ExecutionContext *context)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~CameraMsgStartViewfinding ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CameraMsgStartViewfinding::CameraMsgStartViewfinding ( ExecutionContext * context )

CameraMsgStartViewfinding::~CameraMsgStartViewfinding ( ) [virtual]

Member Function Documentation

Message * CameraMsgStartViewfinding::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & CameraMsgStartViewfinding::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/Camera/MsgTypes.hpp
  • Applications/Camera/MsgTypes.cpp
Generated on Wed Jan 25 01:04:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CameraMsgStopViewfinding Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CameraMsgStopViewfinding Class Reference

#include <Applications/Camera/MsgTypes.hpp>

Inheritance diagram for CameraMsgStopViewfinding:

[legend]
Collaboration diagram for CameraMsgStopViewfinding:

[legend]

Public Types

enum | { ID = 22701 }

Public Member Functions

CameraMsgStopViewfinding (ExecutionContext *context)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~CameraMsgStopViewfinding ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CameraMsgStopViewfinding::CameraMsgStopViewfinding ( ExecutionContext * context )

CameraMsgStopViewfinding::~CameraMsgStopViewfinding ( ) [virtual]

Member Function Documentation

Message * CameraMsgStopViewfinding::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & CameraMsgStopViewfinding::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/Camera/MsgTypes.hpp
  • Applications/Camera/MsgTypes.cpp
Generated on Wed Jan 25 01:04:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CameraOptionSettingsWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CameraOptionSettingsWin Class Reference

#include <Applications/Camera/CameraOptionSettingsWin.hpp>

Collaboration diagram for CameraOptionSettingsWin:

[legend]

Public Types

enum | { MaFlsAuto, MaFlsOff, MaFlsRedEye, MaFlsLast }
enum | { MaFliOff, MaFli50Hz, MaFli60Hz, MaFliLast }
enum | { MaWbAuto, MaWbOutdoor, MaWbIndoor, MaWbLast }
enum | WindowType { FlashType, WhiteBalanceType, AntiFlickerType }

Public Member Functions

CameraOptionSettingsWin ()
void | Init (WindowType type)
virtual | ~CameraOptionSettingsWin ()

Data Fields

enum CameraOptionSettingsWin:: { ... } | FliType
enum CameraOptionSettingsWin:: { ... } | FlsType
enum CameraOptionSettingsWin:: { ... } | WbType

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual void | OnLayoutClient ()
void | OnOpen ()

Member Enumeration Documentation

anonymous enum

Enumerator:
MaFlsAuto
MaFlsOff
MaFlsRedEye
MaFlsLast

anonymous enum

Enumerator:
MaFliOff
MaFli50Hz
MaFli60Hz
MaFliLast

anonymous enum

Enumerator:
MaWbAuto
MaWbOutdoor
MaWbIndoor
MaWbLast

enum CameraOptionSettingsWin::WindowType

Enumerator:
FlashType
WhiteBalanceType
AntiFlickerType

Constructor & Destructor Documentation

CameraOptionSettingsWin::CameraOptionSettingsWin ( )

CameraOptionSettingsWin::~CameraOptionSettingsWin ( ) [virtual]

Member Function Documentation

void CameraOptionSettingsWin::Init ( WindowType type )

void CameraOptionSettingsWin::OnActionExecuted ( Action * action ) [protected, virtual]

void CameraOptionSettingsWin::OnLayoutClient ( ) [protected, virtual]

void CameraOptionSettingsWin::OnOpen ( ) [protected]

Field Documentation

enum { ... } CameraOptionSettingsWin::FliType

enum { ... } CameraOptionSettingsWin::FlsType

enum { ... } CameraOptionSettingsWin::WbType

The documentation for this class was generated from the following files:
  • Applications/Camera/CameraOptionSettingsWin.hpp
  • Applications/Camera/CameraOptionSettingsWin.cpp
Generated on Wed Jan 25 01:04:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CameraSettings Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CameraSettings Class Reference

#include <Applications/Camera/CameraSettings.hpp>

Collaboration diagram for CameraSettings:

[legend]

Public Member Functions

CameraSettings ()
Camera::AntiFlickerType | GetAntiFlicker () const
INT | GetBrightness () const
INT | GetContrast () const
Camera::FilterType | GetFilter () const
StillCamera::FlashType | GetFlash () const
Camera::ImageSizeType | GetImageSize () const
INT | GetJPEGQuality () const
Camera::TransformationType | GetTransformation () const
Camera::TwilightType | GetTwilight () const
INT | GetZoom () const
BOOLEAN | Init (StillCamera *stillcamera_ref, UINT8 display_idx)
BOOLEAN | SetAntiFlicker (Camera::AntiFlickerType antiflicker)
BOOLEAN | SetBrightness (INT brightness)
BOOLEAN | SetContrast (INT contrast)
BOOLEAN | SetFilter (Camera::FilterType filter)
BOOLEAN | SetFlash (StillCamera::FlashType flash)
BOOLEAN | SetImageSize (Camera::ImageSizeType size)
BOOLEAN | SetJPEGQuality (INT quality)
BOOLEAN | SetTransformation (Camera::TransformationType transType)
BOOLEAN | SetTwilight (Camera::TwilightType twilight)
BOOLEAN | SetWhiteBalance (Camera::WhiteBalanceType wb)
BOOLEAN | SetZoom (Camera::ActionType zoom)
~CameraSettings ()

Constructor & Destructor Documentation

CameraSettings::CameraSettings ( )

CameraSettings::~CameraSettings ( )

Member Function Documentation

Camera::AntiFlickerType CameraSettings::GetAntiFlicker ( ) const

INT CameraSettings::GetBrightness ( ) const

INT CameraSettings::GetContrast ( ) const

Camera::FilterType CameraSettings::GetFilter ( ) const

StillCamera::FlashType CameraSettings::GetFlash ( ) const

Camera::ImageSizeType CameraSettings::GetImageSize ( ) const

INT CameraSettings::GetJPEGQuality ( ) const

Camera::TransformationType CameraSettings::GetTransformation ( ) const

Camera::TwilightType CameraSettings::GetTwilight ( ) const

INT CameraSettings::GetZoom ( ) const

BOOLEAN CameraSettings::Init | ( | StillCamera * | stillcamera_ref,
 |  | UINT8 | display_idx
 | ) |

BOOLEAN CameraSettings::SetAntiFlicker ( Camera::AntiFlickerType antiflicker )

BOOLEAN CameraSettings::SetBrightness ( INT brightness )

BOOLEAN CameraSettings::SetContrast ( INT contrast )

BOOLEAN CameraSettings::SetFilter ( Camera::FilterType filter )

BOOLEAN CameraSettings::SetFlash ( StillCamera::FlashType flash )

BOOLEAN CameraSettings::SetImageSize ( Camera::ImageSizeType size )

BOOLEAN CameraSettings::SetJPEGQuality ( INT quality )

BOOLEAN CameraSettings::SetTransformation ( Camera::TransformationType transType )

BOOLEAN CameraSettings::SetTwilight ( Camera::TwilightType twilight )

BOOLEAN CameraSettings::SetWhiteBalance ( Camera::WhiteBalanceType wb )

BOOLEAN CameraSettings::SetZoom ( Camera::ActionType zoom )

The documentation for this class was generated from the following files:
  • Applications/Camera/CameraSettings.hpp
  • Applications/Camera/CameraSettings.cpp
Generated on Wed Jan 25 01:04:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CameraSettingsWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CameraSettingsWin Class Reference

#include <Applications/Camera/CameraSettingsWin.hpp>

Collaboration diagram for CameraSettingsWin:

[legend]

Public Member Functions

CameraSettingsWin ()
void | Init ()
virtual | ~CameraSettingsWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
void | OnClose ()
virtual void | OnLayoutClient ()
void | OnOpen ()

Constructor & Destructor Documentation

CameraSettingsWin::CameraSettingsWin ( )

CameraSettingsWin::~CameraSettingsWin ( ) [virtual]

Member Function Documentation

void CameraSettingsWin::Init ( )

void CameraSettingsWin::OnActionExecuted ( Action * action ) [protected, virtual]

void CameraSettingsWin::OnClose ( ) [protected]

void CameraSettingsWin::OnLayoutClient ( ) [protected, virtual]

void CameraSettingsWin::OnOpen ( ) [protected]

The documentation for this class was generated from the following files:
  • Applications/Camera/CameraSettingsWin.hpp
  • Applications/Camera/CameraSettingsWin.cpp
Generated on Wed Jan 25 01:04:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CameraViewFinderWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CameraViewFinderWin Class Reference

#include <Applications/Camera/CameraViewFinderWin.hpp>

Collaboration diagram for CameraViewFinderWin:

[legend]

Public Member Functions

void | Init (CameraApp *pcamera_app)
void | RefreshViewFinder ()
void | SetSettingModeTextline (const WString &)
void | SetViewFinderRectToNewFormat (Rect &vf_rect, Camera::ImageSizeType size_type)

Protected Member Functions

void | OnClose ()
virtual void | OnGetFocus ()
virtual void | OnLayoutClient ()
virtual void | OnLoseFocus ()
void | OnOpen ()
virtual void | OnPaint (const Rect &repaint_rect)
void | RedrawStatusLine ()

Protected Attributes

ImageBox m_arrow_next
ImageBox m_arrow_prev
TextLine m_textline_settingmode
WString m_wstr_settingmode

Member Function Documentation

void CameraViewFinderWin::Init ( CameraApp * pcamera_app )

void CameraViewFinderWin::OnClose ( ) [protected]

void CameraViewFinderWin::OnGetFocus ( ) [protected, virtual]

void CameraViewFinderWin::OnLayoutClient ( ) [protected, virtual]

void CameraViewFinderWin::OnLoseFocus ( ) [protected, virtual]

void CameraViewFinderWin::OnOpen ( ) [protected]

void CameraViewFinderWin::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

void CameraViewFinderWin::RedrawStatusLine ( ) [protected]

void CameraViewFinderWin::RefreshViewFinder ( )

void CameraViewFinderWin::SetSettingModeTextline ( const WString & )

void CameraViewFinderWin::SetViewFinderRectToNewFormat | ( | Rect & | vf_rect,
 |  | Camera::ImageSizeType | size_type
 | ) |

Field Documentation

ImageBox CameraViewFinderWin::m_arrow_next [protected]

ImageBox CameraViewFinderWin::m_arrow_prev [protected]

TextLine CameraViewFinderWin::m_textline_settingmode [protected]

WString CameraViewFinderWin::m_wstr_settingmode [protected]

The documentation for this class was generated from the following files:
  • Applications/Camera/CameraViewFinderWin.hpp
  • Applications/Camera/CameraViewFinderWin.cpp
Generated on Wed Jan 25 01:04:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CamWin32 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CamWin32 Class Reference

#include <Apoxi/Devices/Win32/CamWin32.hpp>

Collaboration diagram for CamWin32:

[legend]

Public Types

enum ColorFormatType {
DefaultFormat, RawFormat, JpegFormat, PngFormat,
EndOfColorType
}
enum FrameRateType {
Fps5 = 0, Fps7_5, Fps10, Fps12,
Fps15, Fps24, Fps25, Fps30,
EndOfFpsType
}
enum | ImageFormatType { YUV420 }
enum ImageSizeType {
QqcifSize, SqcifSize, QqvgaSize, QcifSize,
QsifSize, QvgaSize, CifSize, VgaSize,
SvgaSize, XgaSize, Size1Mp, Size1_3Mp,
UxgaSize, Size2Mp, Size3Mp, EndOfImageSizeType
}
enum | Property { BrightnessProperty = 0, ContrastProperty, CompressionProperty, EndOfProperty }
enum | PropertyType { DefaultValue, CurrentValue, AutoValue, EndOfPropertyType }
enum TransformationType {
NoTransformation, Rotate90, Rotate180, Rotate270,
Mirror, MirrorRotate90, MirrorRotate180, MirrorRotate270
}

Public Member Functions

void | Disable ()
BOOLEAN | Enable (INT device_idx=0)
BOOLEAN | FreezeViewFinder ()
BOOLEAN | GetCurrentImage (UINT8 HUGE *&buffer, UINT32 &length)
BOOLEAN | GetCurrentImageBufferSize (UINT32 &length)
INT | GetMaxZoomLevel ()
BOOLEAN | GetPropertyRange (INT property, INT &min, INT &max, INT &interval, INT &def, INT &cur)
BOOLEAN | GetSupportedFrameRates (const FrameRateType *&array, UINT8 &count)
BOOLEAN | GetSupportedImageSizes (const ImageSizeType *&array, UINT8 &count)
BOOLEAN | GetSupportedSensorImageSizes (const ImageSizeType *&array, UINT8 &count)
BOOLEAN | Init ()
void | RegisterFrameCapturedCB (void(*CB_FrameCaptured)(INT ret, UINT8 HUGE *buf, UINT32 size, UINT32 stamp))
void | RegisterGetBufferCB (UINT8 HUGE *(*CB_GetBuffer)())
BOOLEAN | SetColorFormat (ColorFormatType color_format)
BOOLEAN | SetColorModeEnabled (BOOLEAN color_mode)
BOOLEAN | SetFrameRate (FrameRateType frame_rate)
BOOLEAN | SetImageSize (ImageSizeType size, UINT8 &max_zoom_level)
BOOLEAN | SetProperty (INT property, INT type, INT value)
BOOLEAN | SetSensorImageSize (ImageSizeType size, UINT8 &max_zoom_level)
BOOLEAN | SetTransformation (TransformationType trans)
BOOLEAN | SetTwilightModeEnabled (BOOLEAN twilight_mode)
void | SetViewFinder (const Rect &vf_rect, UINT8 display_idx)
BOOLEAN | SetZoomLevel (UINT8 zoom)
BOOLEAN | StartVideoCapture (ImageFormatType format_type)
BOOLEAN | StartViewFinder ()
BOOLEAN | StopVideoCapture ()
BOOLEAN | StopViewFinder ()
virtual | ~CamWin32 ()

Static Public Member Functions

static CamWin32 * | GetInstance ()
static void | ViewFinder_CB (double Time, BYTE *pBuffer, long BufferLen)

Member Enumeration Documentation

enum CamWin32::ColorFormatType

Enumerator:
DefaultFormat
RawFormat
JpegFormat
PngFormat
EndOfColorType

enum CamWin32::FrameRateType

Enumerator:
Fps5
Fps7_5
Fps10
Fps12
Fps15
Fps24
Fps25
Fps30
EndOfFpsType

enum CamWin32::ImageFormatType

Enumerator:
YUV420

enum CamWin32::ImageSizeType

ImageSize has given list of possible predefined image sizes

Enumerator:
QqcifSize
SqcifSize
QqvgaSize
QcifSize
QsifSize
QvgaSize
CifSize
VgaSize
SvgaSize
XgaSize
Size1Mp
Size1_3Mp
UxgaSize
Size2Mp
Size3Mp
EndOfImageSizeType

enum CamWin32::Property

Property is an enumeration about settings that uses a value range from 0 to 100, can be also called "percent property"

Enumerator:
BrightnessProperty
ContrastProperty
CompressionProperty
EndOfProperty

enum CamWin32::PropertyType

The PropertyType is a specialization of the the desired setting

Enumerator:
DefaultValue
CurrentValue
AutoValue
EndOfPropertyType

enum CamWin32::TransformationType

Enumerator:
NoTransformation
Rotate90
Rotate180
Rotate270
Mirror
MirrorRotate90
MirrorRotate180
MirrorRotate270

Constructor & Destructor Documentation

CamWin32::~CamWin32 ( ) [virtual]

Member Function Documentation

void CamWin32::Disable ( )

BOOLEAN CamWin32::Enable ( INT device_idx = 0 )

BOOLEAN CamWin32::FreezeViewFinder ( )

Freezes the viewfinder callback loop

Returns:
TRUE if succeeded

BOOLEAN CamWin32::GetCurrentImage | ( | UINT8 HUGE *& | buffer,
 |  | UINT32 & | length
 | ) |

Returns the current picture according to the settings specified.

Parameters:
buf | buffer where image should be stored in
size | size of buffer, returned size is actual image size
Returns:
TRUE if it was successful, FALSE if not.

BOOLEAN CamWin32::GetCurrentImageBufferSize ( UINT32 & length )

After using SetViewFinderState to ViewFinderState::CaptureViewFinder, this Method returns the size of the image which is required for the buffer

CamWin32 * CamWin32::GetInstance ( ) [static]

INT CamWin32::GetMaxZoomLevel ( )

Returns the maximum zoom level

BOOLEAN CamWin32::GetPropertyRange | ( | INT | property,
 |  | INT & | min,
 |  | INT & | max,
 |  | INT & | interval,
 |  | INT & | def,
 |  | INT & | cur
 | ) |

Retrieves the range & values of a given property (see Property enum)

Parameters:
property | property of which range & values should be retrieved
min | minimum value of given property
max | maximum value of given property
interval | interval stepsize of given property
def | default value of given property
cur | current value of given property
Returns:
TRUE if succeeded

BOOLEAN CamWin32::GetSupportedFrameRates | ( | const FrameRateType *& | array,
 |  | UINT8 & | count
 | ) |

Returns an array of available frame rates which are supported by the video camera.

Parameters:
twilight_active | indicates if frame rates are for twilight mode
rate_count | deliveres the number of frame rates
Returns:
array of possible frame rates

BOOLEAN CamWin32::GetSupportedImageSizes | ( | const ImageSizeType *& | array,
 |  | UINT8 & | count
 | ) |

GetSupportedImageSizes delivers an array of type ImageSizeType with the supported image sizes of the camera.

Parameters:
count returns the number of supported image sizes
Returns:
returns an array of possible sizes for images

BOOLEAN CamWin32::GetSupportedSensorImageSizes | ( | const ImageSizeType *& | array,
 |  | UINT8 & | count
 | ) |

GetSupportedSensorImageSizes delivers an array of type ImageSizeType with the supported image sizes of the camera sensor.

Parameters:
count returns the number of supported image sizes
Returns:
returns an array of possible sizes for images

BOOLEAN CamWin32::Init ( )

void CamWin32::RegisterFrameCapturedCB ( void(*)(INT ret, UINT8 HUGE *buf, UINT32 size, UINT32 stamp) CB_FrameCaptured )

Registers the FrameCaptured callback function (for videocapture)

void CamWin32::RegisterGetBufferCB ( UINT8 HUGE *(*)() CB_GetBuffer )

Registers the GetBuffer callback function (for videocapture)

BOOLEAN CamWin32::SetColorFormat ( ColorFormatType color_format )

Sets the ImageFormat which is used to store the taken picture

Parameters:
format Image Format
Returns:
returns TRUE if the Image format is supported by the camera, FALSE if the format is not supported

BOOLEAN CamWin32::SetColorModeEnabled ( BOOLEAN color_mode )

Enables or disables the color mode.

Parameters:
color_mode to enable or disable the color mode.
Returns:
TRUE if setting the color mode was ok, FALSE otherwise.

BOOLEAN CamWin32::SetFrameRate ( FrameRateType frame_rate )

Sets the frame rate for capturing video

Parameters:
frame_rate Frame rate which will be used for capturing

BOOLEAN CamWin32::SetImageSize | ( | ImageSizeType | size,
 |  | UINT8 & | max_zoom_level
 | ) |

Sets the size of the images returned by the camera from a given enum

Parameters:
size | predefined image size
max_zoom_level | returns the maximum possible zoom level with the selected image size
Returns:
returns TRUE if given size was accepted by driver

BOOLEAN CamWin32::SetProperty | ( | INT | property,
 |  | INT | type,
 |  | INT | value
 | ) |

Sets a specific Property from enum Property (e.g. brightness) with a given PropertyType (e.g. Default).

Parameters:
property | user specific property. Ranges from 0..50 are reserved internally
type | type of property. Ranges from 0..50 are reserved internally
value | property value

BOOLEAN CamWin32::SetSensorImageSize | ( | ImageSizeType | size,
 |  | UINT8 & | max_zoom_level
 | ) |

Sets the size of the camera sensor

Parameters:
size | predefined image size
max_zoom_level | returns the maximum possible zoom level with the selected image size
Returns:
returns TRUE if given size was accepted by driver

BOOLEAN CamWin32::SetTransformation ( TransformationType trans )

SetRotation sets rotation of a picture

Parameters:
rot rotation of type TransformationType
Returns:
returns TRUE if rotation was accepted, FALSE otherwise.

BOOLEAN CamWin32::SetTwilightModeEnabled ( BOOLEAN twilight_mode )

Enables or disables the twilight mode. This increases the sensitivity of the camera's imaging sensor. If the camera does not support a twilight mode, this does not have an effect and FALSE is returned.

Parameters:
twilight_mode to enable or disable the twilight mode.
Returns:
TRUE if setting the twilight mode was ok, FALSE otherwise.

void CamWin32::SetViewFinder | ( | const Rect & | vf_rect,
 |  | UINT8 | display_idx
 | ) |

Sets target viewfinder dimensions. Note: use display width/height, not GetClientRect() !

Parameters:
disp_width | target width
disp_height | target height

BOOLEAN CamWin32::SetZoomLevel ( UINT8 zoom )

Sets the zoom level

Parameters:
zoom zoom level
Returns:
returns TRUE if zooming was successful

BOOLEAN CamWin32::StartVideoCapture ( ImageFormatType format_type )

Starts the video capturing after setting Video Properties, Viewfinder rect and ImageFormat

Parameters:
format_type color format type of video stream
Returns:
returns TRUE if capturing started successfully, FALSE if not

BOOLEAN CamWin32::StartViewFinder ( )

Starts viewfinder callback loop Note: you first have to set the viewfinder & register the viewfinder callback

Returns:
TRUE if succeeded

BOOLEAN CamWin32::StopVideoCapture ( )

Stops video capturing.

Returns:
returns TRUE if stopping was successfull, FALSE if not

BOOLEAN CamWin32::StopViewFinder ( )

Stops the viewfinder callback loop

Returns:
true if succeeded

void CamWin32::ViewFinder_CB | ( | double | Time,
 |  | BYTE * | pBuffer,
 |  | long | BufferLen
 | ) | [static]

The documentation for this class was generated from the following files:
  • Devices/Win32/CamWin32.hpp
  • Devices/Win32/CamWin32.cpp
Generated on Wed Jan 25 01:05:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CancelAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CancelAction Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/CancelAction.hpp>

Inheritance diagram for CancelAction:

[legend]
Collaboration diagram for CancelAction:

[legend]

Public Member Functions

CancelAction (Control *control, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
CancelAction ()
virtual BOOLEAN | Execute ()
void | Init (Control *control, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
virtual | ~CancelAction ()

Detailed Description

Obsolete - it is planned to drop the method Control::OnCancel as it can be replaced by simply using an Action and overwriting Control::OnActionExecuted instead.

Invokes Control::OnCancel() of the specified Control. Before the Action can be executed, it must be provided with a pointer to the Control by the constructor or by the method Init.

Constructor & Destructor Documentation

CancelAction::CancelAction ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

CancelAction::CancelAction | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

CancelAction::~CancelAction ( ) [virtual]

Member Function Documentation

BOOLEAN CancelAction::Execute ( ) [virtual]

Invokes Control::OnCancel() of the Control, which was set with the constructor or the method Init.

Reimplemented from Action.

void CancelAction::Init | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

The documentation for this class was generated from the following files:
  • Compat/CancelAction.hpp
  • Compat/CancelAction.cpp
Generated on Wed Jan 25 01:05:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Caret Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Caret Class Reference
[Editors]

#include <Apoxi/Gui/Caret.hpp>

Inheritance diagram for Caret:

[legend]
Collaboration diagram for Caret:

[legend]

Public Types

enum | Mode { Insert, Overwrite }

Public Member Functions

Caret (AbstractEditor *editor, Mode mode=Insert)
Caret ()
virtual void | Draw (DeviceContext *dc, const Rect &bounds, BOOLEAN right_to_left=FALSE) const =0
INT | GetColumn () const
const AbstractEditor * | GetEditor () const
INT | GetIndex () const
virtual XYDIM | GetMinimalWidth () const =0
Returns the minimal width of the cursor in pixels.
Mode | GetMode () const
Returns the mode of the cursor (Insert or Overwrite).
INT | GetRow () const
BOOLEAN | IsVisible () const
Returns whether the caret is visible.
virtual void | SetColumn (INT column)
void | SetMode (Mode mode)
virtual void | SetRow (INT row)
virtual void | SetVisible (BOOLEAN visible)
virtual void | ShowHint () const
virtual | ~Caret ()

Protected Member Functions

AbstractEditor * GetEditor ()

Detailed Description

Every caret is part of an editor and describes the position and the look of the cursor. The position is defined by the row and the column. The caret is allocated and freed by the input mapper; also the input mapper has to provide its caret by the necessary parameters for displaying the right hint (see Caret::ShowHint()) or mode.

Member Enumeration Documentation

enum Caret::Mode

Describes the mode of the cursor.

Enumerator:
Insert | When pressing a key the character will get inserted after the cursor.
Overwrite | When pressing a key the character behind the cursor will be replaced by the new character.

Constructor & Destructor Documentation

Caret::Caret ( )

Caret::Caret | ( | AbstractEditor * | editor,
 |  | Mode | mode = Insert
 | ) | [explicit]

Caret::~Caret ( ) [virtual]

Member Function Documentation

virtual void Caret::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds,
 |  | BOOLEAN | right_to_left = FALSE
 | ) | const [pure virtual]

Draws the cursor.

Parameters:
dc | Device context where the cursor is drawn.
bounds | Bounding rectangle where the cursor is drawn. Usually the bounding rectangle has the size of the glyph below the cursor.
right_to_left | If set to TRUE the cursor is above a right to left character (e. g. an Arabic glyph). This is useful for having a different representation.

Implemented in DefaultCaret, and MultiTapCaret.

INT Caret::GetColumn ( ) const [inline]

Returns the column of the caret. It is assured that the value is >= 0.

AbstractEditor* Caret::GetEditor ( ) [inline, protected]

Returns:
Pointer to the corresponding editor.

const AbstractEditor* Caret::GetEditor ( ) const [inline]

Returns:
Pointer to the corresponding editor.

INT Caret::GetIndex ( ) const

Returns the index of the item where the caret is located. The index is calculated by the given row and column. If -1 is returned, no items are available.

virtual XYDIM Caret::GetMinimalWidth ( ) const [pure virtual]

Returns the minimal width of the cursor in pixels.

Implemented in DefaultCaret, and MultiTapCaret.

Mode Caret::GetMode ( ) const [inline]

Returns the mode of the cursor (Insert or Overwrite).

INT Caret::GetRow ( ) const [inline]

Returns the row of the caret. It is assured that the value is >= 0.

BOOLEAN Caret::IsVisible ( ) const

Returns whether the caret is visible.

void Caret::SetColumn ( INT column ) [virtual]

Sets the column of the caret. A value < 0 will be converted to 0 automatically.

Reimplemented in DefaultCaret.

void Caret::SetMode ( Mode mode ) [inline]

Sets the mode of the cursor (Insert or Overwrite). Usually this also modifies the representation of the cursor.

void Caret::SetRow ( INT row ) [virtual]

Sets the row of the caret. A value < 0 will be converted to 0 automatically.

Reimplemented in DefaultCaret.

void Caret::SetVisible ( BOOLEAN visible ) [virtual]

Allows to make the caret invisible. This is useful for cursor blinking or when the editor is in the read only mode. Per default the caret is visible.

Reimplemented in DefaultCaret.

void Caret::ShowHint ( ) const [virtual]

Is invoked after drawing the content of the editor and enables to display an additional hint like e. g. the state of the input mapper like the tabbing-information for the multi tap input mapper. The caret should be provided with the necessary information by its input mapper.

Reimplemented in MultiTapCaret.

The documentation for this class was generated from the following files:
  • Gui/Caret.hpp
  • Gui/Caret.cpp
Generated on Wed Jan 25 01:05:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CArray< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CArray< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/BinarySearch.hpp>

Inheritance diagram for CArray< T >:

[legend]
Collaboration diagram for CArray< T >:

[legend]

Public Types

typedef T | ElemType

Public Member Functions

CArray (const T *arr, INT size)
const T & | operator[] (INT i) const
INT | Size () const

template<class T>
class CArray< T >

Member Typedef Documentation

template<class T>
typedef T CArray< T >::ElemType

Constructor & Destructor Documentation

template<class T>
CArray< T >::CArray | ( | const T * | arr,
 |  | INT | size
 | ) | [inline]

Member Function Documentation

template<class T>
const T& CArray< T >::operator[] ( INT i ) const [inline]

template<class T>
INT CArray< T >::Size ( ) const [inline]

The documentation for this class was generated from the following file:
  • Auxiliary/BinarySearch.hpp
Generated on Wed Jan 25 01:05:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbmiData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbmiData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [2]

Field Documentation

UINT8 CbmiData::val[2]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:05:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbmiProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbmiProvider Class Reference
[Provider]

#include <Apoxi/Adc/CbmiProvider.hpp>

Inheritance diagram for CbmiProvider:

[legend]
Collaboration diagram for CbmiProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

CbmiProvider ()
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *aux_handler, Protector *protector)
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~CbmiProvider ()

Detailed Description

CbmiProvider is the provider to retrieve and manipulate the Cbmi values of the sim (GSM 11.11 V8.2.0 10.3.13). An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_cbmi_provider_id

Following column ids are defined: c_cbmi_id :NumberType

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider CbmiProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

CbmiProvider::CbmiProvider ( )

CbmiProvider::~CbmiProvider ( ) [virtual]

Member Function Documentation

BOOLEAN CbmiProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN CbmiProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from Provider.

BOOLEAN CbmiProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN CbmiProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT CbmiProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void CbmiProvider::Init | ( | SimAuxHandler * | aux_handler,
 |  | Protector * | protector
 | ) |

INT CbmiProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT CbmiProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN CbmiProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN CbmiProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/CbmiProvider.hpp
  • Adc/CbmiProvider.cpp
Generated on Wed Jan 25 01:05:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbmiRange Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbmiRange Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT16 | high
UINT16 | low

Field Documentation

UINT16 CbmiRange::high

UINT16 CbmiRange::low

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:05:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbmiRangeProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbmiRangeProvider Class Reference
[Provider]

#include <Apoxi/Adc/CbmiRangeProvider.hpp>

Inheritance diagram for CbmiRangeProvider:

[legend]
Collaboration diagram for CbmiRangeProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

CbmiRangeProvider ()
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *aux_handler, Protector *protector)
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~CbmiRangeProvider ()

Detailed Description

CbmiRangeProvider is the provider to retrieve and manipulate the Cbmi values of the sim (GSM 11.11 V8.2.0 10.3.28). An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_cbmi_range_provider_id

Following column ids are defined: c_cbmi_range_low_id :NumberType c_cbmi_range_high_id :NumberType

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider CbmiRangeProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

CbmiRangeProvider::CbmiRangeProvider ( )

CbmiRangeProvider::~CbmiRangeProvider ( ) [virtual]

Member Function Documentation

BOOLEAN CbmiRangeProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN CbmiRangeProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from Provider.

BOOLEAN CbmiRangeProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN CbmiRangeProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT CbmiRangeProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void CbmiRangeProvider::Init | ( | SimAuxHandler * | aux_handler,
 |  | Protector * | protector
 | ) |

INT CbmiRangeProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT CbmiRangeProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN CbmiRangeProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN CbmiRangeProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/CbmiRangeProvider.hpp
  • Adc/CbmiRangeProvider.cpp
Generated on Wed Jan 25 01:05:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Cbs Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Cbs Class Reference

#include <Apoxi/Apc/Cbs.hpp>

Collaboration diagram for Cbs:

[legend]

Public Member Functions

Cbs (const Cbs &cbs)
Cbs (const T_SMS_CB_MESSAGE &sdl_cbs)
Cbs (const SerialNumber &serial_number, const MessageIdentifier &message_identifier=0xffff, const DataCodingScheme &dcs=DataCodingScheme(), INT length=0, const UINT8 *data=0)
Cbs ()
void | Clear ()
resets the whole object.
void | ClearData ()
clears all data allocated.
void | CopyData (const UINT8 *data)
copies the given data into the member m_data (m_length elems are copied).
void | GetBlobObject (BlobObject &object) const
returns the complete data in binary form, the blob object is filled accordingly
UINT8 * | GetData () const
const DataCodingScheme & | GetDataCodingScheme () const
INT | GetLength () const
INT | GetMaxDataSize () const
const MessageIdentifier & | GetMessageIdentifier () const
const SerialNumber & | GetSerialNumber () const
WString | GetText () const
returns the complete data, interpreted (via data coding scheme) as text.
BOOLEAN | IsIndex () const
Cbs & | operator= (const Cbs &cbs)
INT | ReallocateData (INT length)
returns the number of bytes reallocated, already allocated memory is not cleared.
INT | ResizeData (INT length)
returns the number of bytes resized, already allocated memory is cleared.
~Cbs ()

Static Public Member Functions

static INT | GetMaxPages ()

Data Structures

class | Filter
class | SerialNumber
Serial Number - 3GPP TS 23.041 V4.1.0 [9.4.1.2.1]. More...

Detailed Description

3GPP TS 23.041 V4.1.0 [9.4] - This class describes the protocol for the cell broadcast service.

Constructor & Destructor Documentation

Cbs::Cbs ( )

Cbs::Cbs | ( | const SerialNumber & | serial_number,
 |  | const MessageIdentifier & | message_identifier = 0xffff,
 |  | const DataCodingScheme & | dcs = DataCodingScheme(),
 |  | INT | length = 0,
 |  | const UINT8 * | data = 0
 | ) |

Cbs::Cbs ( const T_SMS_CB_MESSAGE & sdl_cbs )

Cbs::~Cbs ( )

Cbs::Cbs ( const Cbs & cbs )

Member Function Documentation

void Cbs::Clear ( )

resets the whole object.

void Cbs::ClearData ( )

clears all data allocated.

void Cbs::CopyData ( const UINT8 * data )

copies the given data into the member m_data (m_length elems are copied).

void Cbs::GetBlobObject ( BlobObject & object ) const

returns the complete data in binary form, the blob object is filled accordingly

UINT8* Cbs::GetData ( ) const [inline]

const DataCodingScheme& Cbs::GetDataCodingScheme ( ) const [inline]

INT Cbs::GetLength ( ) const [inline]

INT Cbs::GetMaxDataSize ( ) const [inline]

static INT Cbs::GetMaxPages ( ) [inline, static]

const MessageIdentifier& Cbs::GetMessageIdentifier ( ) const [inline]

const SerialNumber& Cbs::GetSerialNumber ( ) const [inline]

WString Cbs::GetText ( ) const

returns the complete data, interpreted (via data coding scheme) as text.

BOOLEAN Cbs::IsIndex ( ) const [inline]

Cbs & Cbs::operator= ( const Cbs & cbs )

INT Cbs::ReallocateData ( INT length )

returns the number of bytes reallocated, already allocated memory is not cleared.

INT Cbs::ResizeData ( INT length )

returns the number of bytes resized, already allocated memory is cleared.

The documentation for this class was generated from the following files:
  • Apc/Cbs.hpp
  • Apc/Cbs.cpp
Generated on Wed Jan 25 01:05:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Cbs::Filter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Cbs::Filter

Cbs::Filter Class Reference

#include <Apoxi/Apc/Cbs.hpp>

Collaboration diagram for Cbs::Filter:

[legend]

Public Types

enum | { c_max_stack_no_of_message_identifiers = MN_MAX_CB_MSG_ID_LIST_LENGTH, c_max_stack_no_of_data_coding_schemes = MN_MAX_CB_DCS_LIST_LENGTH, c_max_apoxi_no_of_message_identifiers = MessageIdentifierContainer::c_max_apoxi_no_of_message_identifiers }
enum | Mode { Normal = 0, Inverted = 1 }

Public Member Functions

BOOLEAN | Append (const DataCodingSchemeRange &dcs_range)
BOOLEAN | Append (const DataCodingScheme &dcs)
BOOLEAN | Append (const MessageIdentifierRange &mid_range)
BOOLEAN | Append (const MessageIdentifier &mid)
void | ClearDataCodingSchemeList ()
void | ClearMessageIdentifierList ()
void | Convert2SdlFilter (T_MN_SMS_CB_START_REQ &sdl_filter) const
void | DbgOut () const
void | EnableDcsListFilter (BOOLEAN dcs_list_filter_enabled=TRUE)
activate filter for data coding scheme
void | EnableMidListFilter (BOOLEAN mid_list_filter_enabled=TRUE)
activate filter for message identifier
BOOLEAN | Exists (const MessageIdentifierRange &mid_range) const
BOOLEAN | Exists (const MessageIdentifier &mid) const
BOOLEAN | Exists (const DataCodingSchemeRange &dcs_range) const
BOOLEAN | Exists (const DataCodingScheme &dcs) const
Filter (BOOLEAN ignore_duplicates, INT sleep_duration=c_cbs_default_sleep_timer, UINT8 no_of_pages=MAX_SMS_CB_MAX_NBR_PAGES, BOOLEAN dcs_list_filter_enabled=TRUE, BOOLEAN mid_list_filter_enabled=TRUE, Mode mode=Normal, INT wake_duration=c_cbs_default_active_timer)
Filter (const Filter &filter)
Filter ()
INT | GetActiveDuration () const
Mode | GetMode () const
UINT8 | GetNextHighDcs (UINT8 dcs)
UINT16 | GetNextHighMid (UINT16 mid)
UINT8 | GetNextLowDcs (UINT8 dcs)
UINT16 | GetNextLowMid (UINT16 mid)
INT | GetNoOfDcsRanges () const
INT | GetNoOfMidRanges () const
UINT8 | GetNoOfPages () const
INT | GetSleepDuration () const
void | IgnoreDuplicates (BOOLEAN ignore_duplicates)
BOOLEAN | IgnoreDuplicates () const
BOOLEAN | IsDcsListFilterEnabled () const
BOOLEAN | IsMatching (const DataCodingScheme &dcs, const MessageIdentifier &mid) const
BOOLEAN | IsMidListFilterEnabled () const
BOOLEAN | MakeModeNormal ()
BOOLEAN | MergeDataCodingSchemeRanges (const Filter &filter)
BOOLEAN | MergeMessageIdentifierRanges (const Filter &filter)
Filter & | operator= (const Filter &filter)
BOOLEAN | Optimize ()
void | Remove (const DataCodingSchemeRange &dcs_range)
void | Remove (const DataCodingScheme &dcs)
void | Remove (const MessageIdentifierRange &mid_range)
void | Remove (const MessageIdentifier &mid)
void | SetActiveDuration (INT active_duration)
void | SetMode (Mode mode)
void | SetNoOfPages (UINT8 no_of_pages)
void | SetSleepDuration (INT sleep_duration)
~Filter ()

Static Public Member Functions

static void | DisableGlobalActiveDuration ()
static void | DisableGlobalSleepDuration ()
static void | EnableGlobalActiveDuration (INT duration)
static void | EnableGlobalSleepDuration (INT duration)
static INT | GetMaxNoOfDcsRanges ()
static INT | GetMaxNoOfMidRanges ()

Member Enumeration Documentation

anonymous enum

Enumerator:
c_max_stack_no_of_message_identifiers
c_max_stack_no_of_data_coding_schemes
c_max_apoxi_no_of_message_identifiers

enum Cbs::Filter::Mode

filter mode (Cell Broadcast Message Type Mode - 3GPP TS 27.005 V4.1.0 [3.3.4])

Enumerator:
Normal | declares, that the message type lists (message identifier & data coding scheme) are accepted.
Inverted | declares, that the message type lists (message identifier & data coding scheme) are not accepted

Constructor & Destructor Documentation

Cbs::Filter::Filter ( )

Cbs::Filter::Filter ( const Filter & filter )

Cbs::Filter::Filter | ( | BOOLEAN | ignore_duplicates,
 |  | INT | sleep_duration = c_cbs_default_sleep_timer,
 |  | UINT8 | no_of_pages = MAX_SMS_CB_MAX_NBR_PAGES,
 |  | BOOLEAN | dcs_list_filter_enabled = TRUE,
 |  | BOOLEAN | mid_list_filter_enabled = TRUE,
 |  | Mode | mode = Normal,
 |  | INT | wake_duration = c_cbs_default_active_timer
 | ) |

Cbs::Filter::~Filter ( )

Member Function Documentation

BOOLEAN Cbs::Filter::Append ( const DataCodingSchemeRange & dcs_range )

BOOLEAN Cbs::Filter::Append ( const DataCodingScheme & dcs )

BOOLEAN Cbs::Filter::Append ( const MessageIdentifierRange & mid_range )

BOOLEAN Cbs::Filter::Append ( const MessageIdentifier & mid )

void Cbs::Filter::ClearDataCodingSchemeList ( )

void Cbs::Filter::ClearMessageIdentifierList ( )

void Cbs::Filter::Convert2SdlFilter ( T_MN_SMS_CB_START_REQ & sdl_filter ) const

void Cbs::Filter::DbgOut ( ) const

void Cbs::Filter::DisableGlobalActiveDuration ( ) [static]

void Cbs::Filter::DisableGlobalSleepDuration ( ) [static]

void Cbs::Filter::EnableDcsListFilter ( BOOLEAN dcs_list_filter_enabled = TRUE ) [inline]

activate filter for data coding scheme

void Cbs::Filter::EnableGlobalActiveDuration ( INT duration ) [static]

void Cbs::Filter::EnableGlobalSleepDuration ( INT duration ) [static]

void Cbs::Filter::EnableMidListFilter ( BOOLEAN mid_list_filter_enabled = TRUE ) [inline]

activate filter for message identifier

BOOLEAN Cbs::Filter::Exists ( const MessageIdentifierRange & mid_range ) const

BOOLEAN Cbs::Filter::Exists ( const MessageIdentifier & mid ) const

BOOLEAN Cbs::Filter::Exists ( const DataCodingSchemeRange & dcs_range ) const

BOOLEAN Cbs::Filter::Exists ( const DataCodingScheme & dcs ) const

INT Cbs::Filter::GetActiveDuration ( ) const [inline]

static INT Cbs::Filter::GetMaxNoOfDcsRanges ( ) [inline, static]

static INT Cbs::Filter::GetMaxNoOfMidRanges ( ) [inline, static]

Mode Cbs::Filter::GetMode ( ) const [inline]

UINT8 Cbs::Filter::GetNextHighDcs ( UINT8 dcs )

UINT16 Cbs::Filter::GetNextHighMid ( UINT16 mid )

UINT8 Cbs::Filter::GetNextLowDcs ( UINT8 dcs )

UINT16 Cbs::Filter::GetNextLowMid ( UINT16 mid )

INT Cbs::Filter::GetNoOfDcsRanges ( ) const [inline]

INT Cbs::Filter::GetNoOfMidRanges ( ) const [inline]

UINT8 Cbs::Filter::GetNoOfPages ( ) const [inline]

INT Cbs::Filter::GetSleepDuration ( ) const [inline]

void Cbs::Filter::IgnoreDuplicates ( BOOLEAN ignore_duplicates ) [inline]

BOOLEAN Cbs::Filter::IgnoreDuplicates ( ) const [inline]

BOOLEAN Cbs::Filter::IsDcsListFilterEnabled ( ) const [inline]

BOOLEAN Cbs::Filter::IsMatching | ( | const DataCodingScheme & | dcs,
 |  | const MessageIdentifier & | mid
 | ) | const

BOOLEAN Cbs::Filter::IsMidListFilterEnabled ( ) const [inline]

BOOLEAN Cbs::Filter::MakeModeNormal ( )

BOOLEAN Cbs::Filter::MergeDataCodingSchemeRanges ( const Filter & filter )

BOOLEAN Cbs::Filter::MergeMessageIdentifierRanges ( const Filter & filter )

Cbs::Filter & Cbs::Filter::operator= ( const Filter & filter )

BOOLEAN Cbs::Filter::Optimize ( )

void Cbs::Filter::Remove ( const DataCodingSchemeRange & dcs_range )

void Cbs::Filter::Remove ( const DataCodingScheme & dcs )

void Cbs::Filter::Remove ( const MessageIdentifierRange & mid_range )

void Cbs::Filter::Remove ( const MessageIdentifier & mid )

void Cbs::Filter::SetActiveDuration ( INT active_duration ) [inline]

void Cbs::Filter::SetMode ( Mode mode ) [inline]

void Cbs::Filter::SetNoOfPages ( UINT8 no_of_pages ) [inline]

void Cbs::Filter::SetSleepDuration ( INT sleep_duration ) [inline]

The documentation for this class was generated from the following files:
  • Apc/Cbs.hpp
  • Apc/Cbs.cpp
Generated on Wed Jan 25 01:05:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Cbs::SerialNumber Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Cbs::SerialNumber

Cbs::SerialNumber Class Reference

Serial Number - 3GPP TS 23.041 V4.1.0 [9.4.1.2.1]. More...

#include <Apoxi/Apc/Cbs.hpp>

Collaboration diagram for Cbs::SerialNumber:

[legend]

Public Types

enum GeographicalScope {
CellWideImmediate, PlmnWideNormal, LocationAreaWideNormal, CellWideNormal,
InvalidScope
}

Public Member Functions

void | Clear ()
UINT16 | Get () const
returns the whole two byte serial-number.
GeographicalScope | GetGeographicalScope () const
returns the geographical scope from the serial-number.
UINT16 | GetMessageCode () const
returns the message code from the serial-number.
UINT8 | GetUpdateNumber () const
returns the update number from the serial-number.
BOOLEAN | IsIndex () const
SerialNumber (UINT16 incoming_word)
SerialNumber ()
void | SetGeographicalScope (GeographicalScope geographical_scope)
writes the geographical scope to the serial-number.
void | SetMessageCode (UINT16 serial_number)
writes the message code to the serial-number.
void | SetUpdateNumber (UINT8 update_number)
writes the update number to the serial-number.

Detailed Description

Serial Number - 3GPP TS 23.041 V4.1.0 [9.4.1.2.1].

Member Enumeration Documentation

enum Cbs::SerialNumber::GeographicalScope

Enumerator:
CellWideImmediate | only cell wide by default direkt display (which means that any CBS message if received in the next cell is regarded as "new")
PlmnWideNormal | PLMN wide (which means that the Message Code and/or Update Number must change in the next cell for the CBS message to be "new")
LocationAreaWideNormal | Location area wide (in GSM) by default display under user interaction (which means that a CBS message with the same Message Code and Update Number may or may not be "new" in the next cell according to whether the next cell is in the same Location Area as the current cell) The corresponding scpoe in UMTS is called service area!
CellWideNormal | only cell wide by default display under user interaction (which means that any CBS message if received in the next cell is regarded as "new")
InvalidScope

Constructor & Destructor Documentation

Cbs::SerialNumber::SerialNumber ( )

Cbs::SerialNumber::SerialNumber ( UINT16 incoming_word )

Member Function Documentation

void Cbs::SerialNumber::Clear ( ) [inline]

UINT16 Cbs::SerialNumber::Get ( ) const [inline]

returns the whole two byte serial-number.

Cbs::SerialNumber::GeographicalScope Cbs::SerialNumber::GetGeographicalScope ( ) const

returns the geographical scope from the serial-number.

UINT16 Cbs::SerialNumber::GetMessageCode ( ) const

returns the message code from the serial-number.

UINT8 Cbs::SerialNumber::GetUpdateNumber ( ) const

returns the update number from the serial-number.

BOOLEAN Cbs::SerialNumber::IsIndex ( ) const

void Cbs::SerialNumber::SetGeographicalScope ( GeographicalScope geographical_scope )

writes the geographical scope to the serial-number.

void Cbs::SerialNumber::SetMessageCode ( UINT16 serial_number )

writes the message code to the serial-number.

void Cbs::SerialNumber::SetUpdateNumber ( UINT8 update_number )

writes the update number to the serial-number.

The documentation for this class was generated from the following files:
  • Apc/Cbs.hpp
  • Apc/Cbs.cpp
Generated on Wed Jan 25 01:05:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CbsDispatcher.hpp>

Inheritance diagram for CbsDispatcher:

[legend]
Collaboration diagram for CbsDispatcher:

[legend]

Public Member Functions

CbsDispatcher ()
CbsFilterList & GetCbsFilterList ()
virtual | ~CbsDispatcher ()

Protected Member Functions

BOOLEAN | OnCbsLimitInd (const StackMsgArgument &arg)
BOOLEAN | OnCbsNewDataInd (const StackMsgArgument &arg)

Constructor & Destructor Documentation

CbsDispatcher::CbsDispatcher ( )

CbsDispatcher::~CbsDispatcher ( ) [virtual]

Member Function Documentation

CbsFilterList& CbsDispatcher::GetCbsFilterList ( ) [inline]

BOOLEAN CbsDispatcher::OnCbsLimitInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN CbsDispatcher::OnCbsNewDataInd ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/CbsDispatcher.hpp
  • Asc/CbsDispatcher.cpp
Generated on Wed Jan 25 01:05:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsFilterList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsFilterList Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CbsFilterList.hpp>

Collaboration diagram for CbsFilterList:

[legend]

Public Types

enum | { c_max_cbs_applications = 10 }

Public Member Functions

CbsFilterList ()
const Cbs::Filter * | GetFilter (Application *app) const
const Cbs::Filter & | GetMergedFilter () const
BOOLEAN | IsEmpty () const
BOOLEAN | IsOfInterest (Application *app, const CbsNewDataIndArg &arg) const
BOOLEAN | MergeFilters ()
BOOLEAN | PutFilter (Application *app, const Cbs::Filter &filter)
BOOLEAN | RemoveFilter (Application *app)
virtual | ~CbsFilterList ()

Data Structures

struct | CbsFilterListEntry

Member Enumeration Documentation

anonymous enum

Enumerator:
c_max_cbs_applications

Constructor & Destructor Documentation

CbsFilterList::CbsFilterList ( )

CbsFilterList::~CbsFilterList ( ) [virtual]

Member Function Documentation

const Cbs::Filter * CbsFilterList::GetFilter ( Application * app ) const

const Cbs::Filter& CbsFilterList::GetMergedFilter ( ) const [inline]

BOOLEAN CbsFilterList::IsEmpty ( ) const

BOOLEAN CbsFilterList::IsOfInterest | ( | Application * | app,
 |  | const CbsNewDataIndArg & | arg
 | ) | const

BOOLEAN CbsFilterList::MergeFilters ( )

BOOLEAN CbsFilterList::PutFilter | ( | Application * | app,
 |  | const Cbs::Filter & | filter
 | ) |

BOOLEAN CbsFilterList::RemoveFilter ( Application * app )

The documentation for this class was generated from the following files:
  • Asc/CbsFilterList.hpp
  • Asc/CbsFilterList.cpp
Generated on Wed Jan 25 01:05:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsFilterList::CbsFilterListEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CbsFilterList::CbsFilterListEntry

CbsFilterList::CbsFilterListEntry Struct Reference

#include <Apoxi/Asc/CbsFilterList.hpp>

Collaboration diagram for CbsFilterList::CbsFilterListEntry:

[legend]

Public Member Functions

void | Clear ()
void | Init ()

Data Fields

Application * m_app
Cbs::Filter * m_filter

Member Function Documentation

void CbsFilterList::CbsFilterListEntry::Clear ( ) [inline]

void CbsFilterList::CbsFilterListEntry::Init ( ) [inline]

Field Documentation

Application* CbsFilterList::CbsFilterListEntry::m_app

Cbs::Filter* CbsFilterList::CbsFilterListEntry::m_filter

The documentation for this struct was generated from the following file:
  • Asc/CbsFilterList.hpp
Generated on Wed Jan 25 01:05:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CbsHandler.hpp>

Collaboration diagram for CbsHandler:

[legend]

Public Types

enum | { ID = CbsHandlerId }

Public Member Functions

CbsHandler ()
CbsFilterList & GetCbsFilterList ()
virtual HandlerId | GetHandlerId () const
BOOLEAN | Start (const Cbs::Filter &filter)
BOOLEAN | Stop ()
virtual | ~CbsHandler ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsHandler::CbsHandler ( )

CbsHandler::~CbsHandler ( ) [virtual]

Member Function Documentation

CbsFilterList& CbsHandler::GetCbsFilterList ( ) [inline]

HandlerId CbsHandler::GetHandlerId ( ) const [virtual]

BOOLEAN CbsHandler::Start ( const Cbs::Filter & filter )

BOOLEAN CbsHandler::Stop ( )

The documentation for this class was generated from the following files:
  • Asc/CbsHandler.hpp
  • Asc/CbsHandler.cpp
Generated on Wed Jan 25 01:05:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsLimitIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsLimitIndArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsLimitIndArg:

[legend]
Collaboration diagram for CbsLimitIndArg:

[legend]

Public Types

enum | { ID = 1025 }

Public Member Functions

CbsLimitIndArg ()
UINT16 | GetMaxMessageId () const
void | SetMaxMessageId (UINT16 max_message_id)

Static Public Member Functions

static const CbsLimitIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsLimitIndArg: reflects arguments of signal MN_SMS_CB_MESSAGE_ID_LIMIT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsLimitIndArg::CbsLimitIndArg ( )

Member Function Documentation

const CbsLimitIndArg & CbsLimitIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT16 CbsLimitIndArg::GetMaxMessageId ( ) const [inline]

void CbsLimitIndArg::SetMaxMessageId ( UINT16 max_message_id ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsLimitMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsLimitMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CbsLimitMsg:

[legend]
Collaboration diagram for CbsLimitMsg:

[legend]

Public Types

enum | { ID = 18925 }

Public Member Functions

CbsLimitMsg (ExecutionContext *context, UINT16 max_message_id)
virtual Message * | Clone () const
UINT16 | GetMaxMessageId () const
virtual const MsgMetaData & | GetMetaData () const
void | SetMaxMessageId (UINT16 max_message_id)
virtual | ~CbsLimitMsg ()

Detailed Description

CbsLimitMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsLimitMsg::CbsLimitMsg | ( | ExecutionContext * | context,
 |  | UINT16 | max_message_id
 | ) |

CbsLimitMsg::~CbsLimitMsg ( ) [virtual]

Member Function Documentation

Message * CbsLimitMsg::Clone ( ) const [virtual]

Implements Message.

UINT16 CbsLimitMsg::GetMaxMessageId ( ) const [inline]

const MsgMetaData & CbsLimitMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CbsLimitMsg::SetMaxMessageId ( UINT16 max_message_id ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:05:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsNewDataIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsNewDataIndArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsNewDataIndArg:

[legend]
Collaboration diagram for CbsNewDataIndArg:

[legend]

Public Types

enum | { ID = 1020 }

Public Member Functions

CbsNewDataIndArg ()
const Cbs & | GetCbs () const
void | SetCbs (const Cbs &cbs)

Static Public Member Functions

static const CbsNewDataIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsNewDataIndArg: reflects arguments of signal MN_SMS_CB_DATA_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsNewDataIndArg::CbsNewDataIndArg ( )

Member Function Documentation

const CbsNewDataIndArg & CbsNewDataIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Cbs& CbsNewDataIndArg::GetCbs ( ) const [inline]

void CbsNewDataIndArg::SetCbs ( const Cbs & cbs ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsNewDataMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsNewDataMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CbsNewDataMsg:

[legend]
Collaboration diagram for CbsNewDataMsg:

[legend]

Public Types

enum | { ID = 18922 }

Public Member Functions

CbsNewDataMsg (ExecutionContext *context, const CbsNewDataIndArg &arg)
virtual Message * | Clone () const
const CbsNewDataIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CbsNewDataIndArg &arg)
virtual | ~CbsNewDataMsg ()

Detailed Description

CbsNewDataMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsNewDataMsg::CbsNewDataMsg | ( | ExecutionContext * | context,
 |  | const CbsNewDataIndArg & | arg
 | ) |

CbsNewDataMsg::~CbsNewDataMsg ( ) [virtual]

Member Function Documentation

Message * CbsNewDataMsg::Clone ( ) const [virtual]

Implements Message.

const CbsNewDataIndArg& CbsNewDataMsg::GetArg ( ) const [inline]

const MsgMetaData & CbsNewDataMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CbsNewDataMsg::SetArg ( const CbsNewDataIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:05:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsNewDataRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsNewDataRejArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsNewDataRejArg:

[legend]
Collaboration diagram for CbsNewDataRejArg:

[legend]

Public Types

enum | { ID = 2020 }

Public Member Functions

CbsNewDataRejArg ()
CbsNewDataRejArg (const Cbs::SerialNumber &serial_number, const MessageIdentifier &message_identifier)
const MessageIdentifier & | GetMessageIdentifier () const
const Cbs::SerialNumber & | GetSerialNumber () const
void | SetMessageIdentifier (const MessageIdentifier &message_identifier)
void | SetSerialNumber (const Cbs::SerialNumber &serial_number)
~CbsNewDataRejArg ()

Static Public Member Functions

static const CbsNewDataRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsNewDataRejArg: reflects arguments of signal MN_SMS_CB_DATA_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsNewDataRejArg::CbsNewDataRejArg | ( | const Cbs::SerialNumber & | serial_number,
 |  | const MessageIdentifier & | message_identifier
 | ) |

CbsNewDataRejArg::CbsNewDataRejArg ( )

CbsNewDataRejArg::~CbsNewDataRejArg ( )

Member Function Documentation

const CbsNewDataRejArg & CbsNewDataRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MessageIdentifier& CbsNewDataRejArg::GetMessageIdentifier ( ) const [inline]

const Cbs::SerialNumber& CbsNewDataRejArg::GetSerialNumber ( ) const [inline]

void CbsNewDataRejArg::SetMessageIdentifier ( const MessageIdentifier & message_identifier ) [inline]

void CbsNewDataRejArg::SetSerialNumber ( const Cbs::SerialNumber & serial_number ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsStartCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsStartCnfArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsStartCnfArg:

[legend]
Collaboration diagram for CbsStartCnfArg:

[legend]

Public Types

enum | { ID = 1023 }

Public Member Functions

CbsStartCnfArg ()

Static Public Member Functions

static const CbsStartCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsStartCnfArg: reflects arguments of signal MN_SMS_CB_START_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsStartCnfArg::CbsStartCnfArg ( )

Member Function Documentation

const CbsStartCnfArg & CbsStartCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsStartDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsStartDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CbsStartDispatcher.hpp>

Inheritance diagram for CbsStartDispatcher:

[legend]
Collaboration diagram for CbsStartDispatcher:

[legend]

Public Member Functions

CbsStartDispatcher ()
BOOLEAN | Succeded () const
virtual | ~CbsStartDispatcher ()

Protected Member Functions

BOOLEAN | OnCbsStartCnf (const StackMsgArgument &arg)
BOOLEAN | OnCbsStartRej (const StackMsgArgument &arg)

Constructor & Destructor Documentation

CbsStartDispatcher::CbsStartDispatcher ( )

CbsStartDispatcher::~CbsStartDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN CbsStartDispatcher::OnCbsStartCnf ( const StackMsgArgument & arg ) [protected]

BOOLEAN CbsStartDispatcher::OnCbsStartRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN CbsStartDispatcher::Succeded ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/CbsStartDispatcher.hpp
  • Asc/CbsStartDispatcher.cpp
Generated on Wed Jan 25 01:05:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsStartRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsStartRejArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsStartRejArg:

[legend]
Collaboration diagram for CbsStartRejArg:

[legend]

Public Types

enum | { ID = 1021 }

Public Member Functions

CbsStartRejArg ()

Static Public Member Functions

static const CbsStartRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsStartRejArg: reflects arguments of signal MN_SMS_CB_START_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsStartRejArg::CbsStartRejArg ( )

Member Function Documentation

const CbsStartRejArg & CbsStartRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsStartReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsStartReqArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsStartReqArg:

[legend]
Collaboration diagram for CbsStartReqArg:

[legend]

Public Types

enum | { ID = 2021 }

Public Member Functions

CbsStartReqArg ()
CbsStartReqArg (const Cbs::Filter &filter)
const Cbs::Filter & | GetFilter () const
void | SetFilter (const Cbs::Filter &filter)

Static Public Member Functions

static const CbsStartReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsStartReqArg: reflects arguments of signal MN_SMS_CB_START_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsStartReqArg::CbsStartReqArg ( const Cbs::Filter & filter )

CbsStartReqArg::CbsStartReqArg ( )

Member Function Documentation

const CbsStartReqArg & CbsStartReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Cbs::Filter& CbsStartReqArg::GetFilter ( ) const [inline]

void CbsStartReqArg::SetFilter ( const Cbs::Filter & filter ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsStopCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsStopCnfArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsStopCnfArg:

[legend]
Collaboration diagram for CbsStopCnfArg:

[legend]

Public Types

enum | { ID = 1024 }

Public Member Functions

CbsStopCnfArg ()

Static Public Member Functions

static const CbsStopCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsStopCnfArg: reflects arguments of signal MN_SMS_CB_STOP_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsStopCnfArg::CbsStopCnfArg ( )

Member Function Documentation

const CbsStopCnfArg & CbsStopCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsStopDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsStopDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CbsStopDispatcher.hpp>

Inheritance diagram for CbsStopDispatcher:

[legend]
Collaboration diagram for CbsStopDispatcher:

[legend]

Public Member Functions

CbsStopDispatcher ()
BOOLEAN | Succeded () const
virtual | ~CbsStopDispatcher ()

Protected Member Functions

BOOLEAN | OnCbsStopCnf (const StackMsgArgument &arg)
BOOLEAN | OnCbsStopRej (const StackMsgArgument &arg)

Constructor & Destructor Documentation

CbsStopDispatcher::CbsStopDispatcher ( )

CbsStopDispatcher::~CbsStopDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN CbsStopDispatcher::OnCbsStopCnf ( const StackMsgArgument & arg ) [protected]

BOOLEAN CbsStopDispatcher::OnCbsStopRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN CbsStopDispatcher::Succeded ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/CbsStopDispatcher.hpp
  • Asc/CbsStopDispatcher.cpp
Generated on Wed Jan 25 01:05:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsStopRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsStopRejArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsStopRejArg:

[legend]
Collaboration diagram for CbsStopRejArg:

[legend]

Public Types

enum | { ID = 1022 }

Public Member Functions

CbsStopRejArg ()

Static Public Member Functions

static const CbsStopRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsStopRejArg: reflects arguments of signal MN_SMS_CB_STOP_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsStopRejArg::CbsStopRejArg ( )

Member Function Documentation

const CbsStopRejArg & CbsStopRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CbsStopReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CbsStopReqArg Class Reference

#include <Apoxi/Apc/CbsStackMsgArgs.hpp>

Inheritance diagram for CbsStopReqArg:

[legend]
Collaboration diagram for CbsStopReqArg:

[legend]

Public Types

enum | { ID = 2022 }

Public Member Functions

CbsStopReqArg ()

Static Public Member Functions

static const CbsStopReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CbsStopReqArg: reflects arguments of signal MN_SMS_CB_STOP_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CbsStopReqArg::CbsStopReqArg ( )

Member Function Documentation

const CbsStopReqArg & CbsStopReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CbsStackMsgArgs.hpp
  • Apc/CbsStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CcbsEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CcbsEntry Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CcbsEntry:

[legend]

Data Fields

UINT8 ccbs_idx
PhoneNumber idle_subscriber_no
ServiceGroup serv_group
Subaddress subaddress

Field Documentation

UINT8 CcbsEntry::ccbs_idx

PhoneNumber CcbsEntry::idle_subscriber_no

ServiceGroup CcbsEntry::serv_group

Subaddress CcbsEntry::subaddress

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:05:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CcbsList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CcbsList Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CcbsList:

[legend]

Data Fields

CcbsEntry ccbs_entry [5]

Field Documentation

CcbsEntry CcbsList::ccbs_entry[5]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:05:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CcbsRecallMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CcbsRecallMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CcbsRecallMsg:

[legend]
Collaboration diagram for CcbsRecallMsg:

[legend]

Public Types

enum | { ID = 18570 }

Public Member Functions

CcbsRecallMsg (ExecutionContext *context, const PhoneNumber &phone_number)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetPhoneNumber () const
void | SetPhoneNumber (const PhoneNumber &phone_number)
virtual | ~CcbsRecallMsg ()

Detailed Description

CcbsRecallMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CcbsRecallMsg::CcbsRecallMsg | ( | ExecutionContext * | context,
 |  | const PhoneNumber & | phone_number
 | ) |

CcbsRecallMsg::~CcbsRecallMsg ( ) [virtual]

Member Function Documentation

Message * CcbsRecallMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & CcbsRecallMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& CcbsRecallMsg::GetPhoneNumber ( ) const [inline]

void CcbsRecallMsg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:05:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CcbsResultMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CcbsResultMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CcbsResultMsg:

[legend]
Collaboration diagram for CcbsResultMsg:

[legend]

Public Types

enum | { ID = 18562 }

Public Member Functions

CcbsResultMsg (ExecutionContext *context, const InterrogateCcbsResult &interrogate_ccbs_result)
virtual Message * | Clone () const
const InterrogateCcbsResult & | GetInterrogateCcbsResult () const
virtual const MsgMetaData & | GetMetaData () const
void | SetInterrogateCcbsResult (const InterrogateCcbsResult &interrogate_ccbs_result)
virtual | ~CcbsResultMsg ()

Detailed Description

CcbsResultMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CcbsResultMsg::CcbsResultMsg | ( | ExecutionContext * | context,
 |  | const InterrogateCcbsResult & | interrogate_ccbs_result
 | ) |

CcbsResultMsg::~CcbsResultMsg ( ) [virtual]

Member Function Documentation

Message * CcbsResultMsg::Clone ( ) const [virtual]

Implements Message.

const InterrogateCcbsResult& CcbsResultMsg::GetInterrogateCcbsResult ( ) const [inline]

const MsgMetaData & CcbsResultMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CcbsResultMsg::SetInterrogateCcbsResult ( const InterrogateCcbsResult & interrogate_ccbs_result ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:05:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CcbsStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CcbsStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CcbsStatusMsg:

[legend]
Collaboration diagram for CcbsStatusMsg:

[legend]

Public Types

enum | { ID = 18561 }

Public Member Functions

CcbsStatusMsg (ExecutionContext *context, const CcbsStatus &ccbs_status)
virtual Message * | Clone () const
const CcbsStatus & | GetCcbsStatus () const
virtual const MsgMetaData & | GetMetaData () const
void | SetCcbsStatus (const CcbsStatus &ccbs_status)
virtual | ~CcbsStatusMsg ()

Detailed Description

CcbsStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CcbsStatusMsg::CcbsStatusMsg | ( | ExecutionContext * | context,
 |  | const CcbsStatus & | ccbs_status
 | ) |

CcbsStatusMsg::~CcbsStatusMsg ( ) [virtual]

Member Function Documentation

Message * CcbsStatusMsg::Clone ( ) const [virtual]

Implements Message.

const CcbsStatus& CcbsStatusMsg::GetCcbsStatus ( ) const [inline]

const MsgMetaData & CcbsStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CcbsStatusMsg::SetCcbsStatus ( const CcbsStatus & ccbs_status ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:05:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CcpData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CcpData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [14]

Field Documentation

UINT8 CcpData::val[14]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:05:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Cell Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Cell Class Reference

Combines the row and column of a matrix. More...

#include <Apoxi/Compat/Grid.hpp>

Public Member Functions

Cell (const Cell &row)
Constructor for a cell.
Cell (INT column=0, XYDIM row=0)
Constructor for a cell.
INT | GetColumn () const
Returns the column of the cell.
INT | GetRow () const
Sets the row of the cell.
BOOLEAN | IsEqual (const Cell *cell) const
BOOLEAN | IsGreater (const Cell *cell) const
BOOLEAN | IsLess (const Cell *cell) const
void | SetColumn (INT column)
Sets the column of the cell.
void | SetRow (INT row)
Sets the row of the cell.

Detailed Description

Combines the row and column of a matrix.

Constructor & Destructor Documentation

Cell::Cell | ( | INT | column = 0,
 |  | XYDIM | row = 0
 | ) |

Constructor for a cell.

Cell::Cell ( const Cell & row )

Constructor for a cell.

Member Function Documentation

INT Cell::GetColumn ( ) const [inline]

Returns the column of the cell.

INT Cell::GetRow ( ) const [inline]

Sets the row of the cell.

BOOLEAN Cell::IsEqual ( const Cell * cell ) const

BOOLEAN Cell::IsGreater ( const Cell * cell ) const

BOOLEAN Cell::IsLess ( const Cell * cell ) const

void Cell::SetColumn ( INT column ) [inline]

Sets the column of the cell.

void Cell::SetRow ( INT row ) [inline]

Sets the row of the cell.

The documentation for this class was generated from the following files:
  • Compat/Grid.hpp
  • Compat/Grid.cpp
Generated on Wed Jan 25 01:05:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CellChangeCnts Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CellChangeCnts Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

CellChangeCnts | operator= (T_CELL_CHANGE_CNTS cell_change_cnts)

Data Fields

UINT8 | cr_cnt
UINT8 | cr_cnt_at
UINT8 | ir_cr_cnt_at
UINT8 | ir_cr_cnt_su
UINT8 | ir_hocc_cnt_at
UINT8 | ir_hocc_cnt_su
BOOLEAN | reset_mm_cnt

Member Function Documentation

CellChangeCnts CellChangeCnts::operator= ( T_CELL_CHANGE_CNTS cell_change_cnts )

Field Documentation

UINT8 CellChangeCnts::cr_cnt

UINT8 CellChangeCnts::cr_cnt_at

UINT8 CellChangeCnts::ir_cr_cnt_at

UINT8 CellChangeCnts::ir_cr_cnt_su

UINT8 CellChangeCnts::ir_hocc_cnt_at

UINT8 CellChangeCnts::ir_hocc_cnt_su

BOOLEAN CellChangeCnts::reset_mm_cnt

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:05:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CellInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CellInfoIndArg Class Reference

#include <Apoxi/Apc/NetworkStackMsgArgs.hpp>

Inheritance diagram for CellInfoIndArg:

[legend]
Collaboration diagram for CellInfoIndArg:

[legend]

Public Types

enum | { ID = 2181 }

Public Member Functions

CellInfoIndArg ()
const CellId & | GetCellId () const
const Lai & | GetLai () const
BOOLEAN | IsGprsAvailable () const
void | SetCellId (const CellId &cell_id)
void | SetGprsAvailable (BOOLEAN gprs_available)
void | SetLai (const Lai &lai)

Static Public Member Functions

static const CellInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CellInfoIndArg: reflects arguments of signal MNMI_CELL_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CellInfoIndArg::CellInfoIndArg ( )

Member Function Documentation

const CellInfoIndArg & CellInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CellId& CellInfoIndArg::GetCellId ( ) const [inline]

const Lai& CellInfoIndArg::GetLai ( ) const [inline]

BOOLEAN CellInfoIndArg::IsGprsAvailable ( ) const [inline]

void CellInfoIndArg::SetCellId ( const CellId & cell_id ) [inline]

void CellInfoIndArg::SetGprsAvailable ( BOOLEAN gprs_available ) [inline]

void CellInfoIndArg::SetLai ( const Lai & lai ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/NetworkStackMsgArgs.hpp
  • Apc/NetworkStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CellInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CellInfoMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CellInfoMsg:

[legend]
Collaboration diagram for CellInfoMsg:

[legend]

Public Types

enum | { ID = 18801 }

Public Member Functions

CellInfoMsg (ExecutionContext *context, const CellInfoIndArg &arg)
virtual Message * | Clone () const
const CellInfoIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CellInfoIndArg &arg)
virtual | ~CellInfoMsg ()

Detailed Description

CellInfoMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CellInfoMsg::CellInfoMsg | ( | ExecutionContext * | context,
 |  | const CellInfoIndArg & | arg
 | ) |

CellInfoMsg::~CellInfoMsg ( ) [virtual]

Member Function Documentation

Message * CellInfoMsg::Clone ( ) const [virtual]

Implements Message.

const CellInfoIndArg& CellInfoMsg::GetArg ( ) const [inline]

const MsgMetaData & CellInfoMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void CellInfoMsg::SetArg ( const CellInfoIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:05:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CellParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CellParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for CellParam:

[legend]

Public Member Functions

CellParam ()
BOOLEAN | IsAccessControlClassInvalid ()
BOOLEAN | IsArfcnDedInvalid ()
BOOLEAN | IsArfcnInvalid ()
BOOLEAN | IsBsicBccInvalid ()
BOOLEAN | IsBsicInvalid ()
BOOLEAN | IsBsicNccInvalid ()
BOOLEAN | IsBsPaMfrmsInvalid ()
BOOLEAN | IsC1Invalid ()
BOOLEAN | IsC2Invalid ()
BOOLEAN | IsC2ValidParamsInvalid ()
BOOLEAN | IsCellBarAccessInvalid ()
BOOLEAN | IsCellBarQualifyInvalid ()
BOOLEAN | IsCellChangeCntInvalid ()
BOOLEAN | IsCellIdInvalid ()
BOOLEAN | IsCellReselectOffsetInvalid ()
BOOLEAN | IsChannelModeInvalid ()
BOOLEAN | IsChannelTypeInvalid ()
BOOLEAN | IsDscInvalid ()
BOOLEAN | IsDtxUsedInvalid ()
BOOLEAN | IsLacInvalid ()
BOOLEAN | IsMccInvalid ()
BOOLEAN | IsMncInvalid ()
BOOLEAN | IsMsTxPowerMaxCchInvalid ()
BOOLEAN | IsNoRfChansInvalid ()
BOOLEAN | IsPenaltyTimeInvalid ()
BOOLEAN | IsPlmnInvalid ()
BOOLEAN | IsRllInvalid ()
BOOLEAN | IsRxlevAccessMinInvalid ()
BOOLEAN | IsRxlevFullInvalid ()
BOOLEAN | IsRxlevServInvalid ()
BOOLEAN | IsRxlevSubInvalid ()
BOOLEAN | IsRxqualFullInvalid ()
BOOLEAN | IsRxqualSubInvalid ()
BOOLEAN | IsT3212Invalid ()
BOOLEAN | IsTimingAdvanceInvalid ()
BOOLEAN | IsTmpOffsetInvalid ()
BOOLEAN | IsTxPowerLevelInvalid ()
CellParam | operator= (T_SCELL_PARAM scell_param)

Data Fields

UINT16 | access_control_class
UINT16 | arfcn
UINT16 | arfcn_ded
BYTE | bs_pa_mfrms
BYTE | bsic
BYTE | bsic_bcc
BYTE | bsic_ncc
INT | c1
INT | c2
BYTE | c2_valid_params
BYTE | cell_bar_access
BYTE | cell_bar_qualify
INT | cell_change_cnt
UINT16 | cell_id
BYTE | cell_reselect_offset
BYTE | channel_mode
BYTE | channel_type
BOOLEAN | cipher_on
BYTE | dsc
BYTE | dtx_used
UINT16 | lac
UINT16 | mcc
UINT16 | mnc
BYTE | ms_tx_power_max_cch
INT | no_rf_chans
BYTE | penalty_time
Plmn plmn
BYTE | rll
BYTE | rxlev_access_min
SignalStrengthLevel rxlev_full
SignalStrengthLevel rxlev_serv
SignalStrengthLevel rxlev_sub
SignalQualityLevel rxqual_full
SignalQualityLevel rxqual_sub
UINT16 | t3212
BYTE | timing_advance
BYTE | tmp_offset
BYTE | tx_power_level

Constructor & Destructor Documentation

CellParam::CellParam ( ) [inline]

Member Function Documentation

BOOLEAN CellParam::IsAccessControlClassInvalid ( ) [inline]

BOOLEAN CellParam::IsArfcnDedInvalid ( ) [inline]

BOOLEAN CellParam::IsArfcnInvalid ( ) [inline]

BOOLEAN CellParam::IsBsicBccInvalid ( ) [inline]

BOOLEAN CellParam::IsBsicInvalid ( ) [inline]

BOOLEAN CellParam::IsBsicNccInvalid ( ) [inline]

BOOLEAN CellParam::IsBsPaMfrmsInvalid ( ) [inline]

BOOLEAN CellParam::IsC1Invalid ( ) [inline]

BOOLEAN CellParam::IsC2Invalid ( ) [inline]

BOOLEAN CellParam::IsC2ValidParamsInvalid ( ) [inline]

BOOLEAN CellParam::IsCellBarAccessInvalid ( ) [inline]

BOOLEAN CellParam::IsCellBarQualifyInvalid ( ) [inline]

BOOLEAN CellParam::IsCellChangeCntInvalid ( ) [inline]

BOOLEAN CellParam::IsCellIdInvalid ( ) [inline]

BOOLEAN CellParam::IsCellReselectOffsetInvalid ( ) [inline]

BOOLEAN CellParam::IsChannelModeInvalid ( ) [inline]

BOOLEAN CellParam::IsChannelTypeInvalid ( ) [inline]

BOOLEAN CellParam::IsDscInvalid ( ) [inline]

BOOLEAN CellParam::IsDtxUsedInvalid ( ) [inline]

BOOLEAN CellParam::IsLacInvalid ( ) [inline]

BOOLEAN CellParam::IsMccInvalid ( ) [inline]

BOOLEAN CellParam::IsMncInvalid ( ) [inline]

BOOLEAN CellParam::IsMsTxPowerMaxCchInvalid ( ) [inline]

BOOLEAN CellParam::IsNoRfChansInvalid ( ) [inline]

BOOLEAN CellParam::IsPenaltyTimeInvalid ( ) [inline]

BOOLEAN CellParam::IsPlmnInvalid ( ) [inline]

BOOLEAN CellParam::IsRllInvalid ( ) [inline]

BOOLEAN CellParam::IsRxlevAccessMinInvalid ( ) [inline]

BOOLEAN CellParam::IsRxlevFullInvalid ( ) [inline]

BOOLEAN CellParam::IsRxlevServInvalid ( ) [inline]

BOOLEAN CellParam::IsRxlevSubInvalid ( ) [inline]

BOOLEAN CellParam::IsRxqualFullInvalid ( ) [inline]

BOOLEAN CellParam::IsRxqualSubInvalid ( ) [inline]

BOOLEAN CellParam::IsT3212Invalid ( ) [inline]

BOOLEAN CellParam::IsTimingAdvanceInvalid ( ) [inline]

BOOLEAN CellParam::IsTmpOffsetInvalid ( ) [inline]

BOOLEAN CellParam::IsTxPowerLevelInvalid ( ) [inline]

CellParam CellParam::operator= ( T_SCELL_PARAM scell_param )

Field Documentation

UINT16 CellParam::access_control_class

UINT16 CellParam::arfcn

UINT16 CellParam::arfcn_ded

BYTE CellParam::bs_pa_mfrms

BYTE CellParam::bsic

BYTE CellParam::bsic_bcc

BYTE CellParam::bsic_ncc

INT CellParam::c1

INT CellParam::c2

BYTE CellParam::c2_valid_params

BYTE CellParam::cell_bar_access

BYTE CellParam::cell_bar_qualify

INT CellParam::cell_change_cnt

UINT16 CellParam::cell_id

BYTE CellParam::cell_reselect_offset

BYTE CellParam::channel_mode

BYTE CellParam::channel_type

BOOLEAN CellParam::cipher_on

BYTE CellParam::dsc

BYTE CellParam::dtx_used

UINT16 CellParam::lac

UINT16 CellParam::mcc

UINT16 CellParam::mnc

BYTE CellParam::ms_tx_power_max_cch

INT CellParam::no_rf_chans

BYTE CellParam::penalty_time

Plmn CellParam::plmn

BYTE CellParam::rll

BYTE CellParam::rxlev_access_min

SignalStrengthLevel CellParam::rxlev_full

SignalStrengthLevel CellParam::rxlev_serv

SignalStrengthLevel CellParam::rxlev_sub

SignalQualityLevel CellParam::rxqual_full

SignalQualityLevel CellParam::rxqual_sub

UINT16 CellParam::t3212

BYTE CellParam::timing_advance

BYTE CellParam::tmp_offset

BYTE CellParam::tx_power_level

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:05:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CenteredTextIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CenteredTextIndicator Class Reference
[APOXI Template Layer]

Indicator that displays a text width maximized width. More...

#include <Apoxi/Compat/Indicator.hpp>

Inheritance diagram for CenteredTextIndicator:

[legend]
Collaboration diagram for CenteredTextIndicator:

[legend]

Public Member Functions

CenteredTextIndicator (const WString &text)
CenteredTextIndicator ()
virtual Size | GetSize () const
Returns the size of the indicator.
virtual | ~CenteredTextIndicator ()

Detailed Description

Indicator that displays a text width maximized width.

Constructor & Destructor Documentation

CenteredTextIndicator::CenteredTextIndicator ( ) [inline]

CenteredTextIndicator::CenteredTextIndicator ( const WString & text )

CenteredTextIndicator::~CenteredTextIndicator ( ) [virtual]

Member Function Documentation

Size CenteredTextIndicator::GetSize ( ) const [virtual]

Returns the size of the indicator.

Reimplemented from TextIndicator.

The documentation for this class was generated from the following files:
  • Compat/Indicator.hpp
  • Compat/Indicator.cpp
Generated on Wed Jan 25 01:05:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CfuDataIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CfuDataIndArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for CfuDataIndArg:

[legend]
Collaboration diagram for CfuDataIndArg:

[legend]

Public Types

enum | { ID = 1118 }

Public Member Functions

CfuDataIndArg ()
const CfuServiceArray & | GetCfuServiceArray () const
void | SetCfuServiceArray (const CfuServiceArray &cfu_service_array)

Static Public Member Functions

static const CfuDataIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CfuDataIndArg : reflects arguments of signal MN_CFU_DATA_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CfuDataIndArg::CfuDataIndArg ( )

Member Function Documentation

const CfuDataIndArg & CfuDataIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CfuServiceArray& CfuDataIndArg::GetCfuServiceArray ( ) const [inline]

void CfuDataIndArg::SetCfuServiceArray ( const CfuServiceArray & cfu_service_array ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CfuService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CfuService Class Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CfuService:

[legend]

Public Member Functions

CfuService (const CfuService &service)
CfuService ()
CfuServiceCode | GetCfuServiceCode () const
returns the CfuServiceCode means if the Servive is undefined, activated or deactivated
const PhoneNumber & | GetForwardPhoneNumber () const
returns the call forwarded phonenumber
CfuService & | operator= (const CfuService &service)
void | Set (CfuServiceCode servicecode, const PhoneNumber &phno)

Constructor & Destructor Documentation

CfuService::CfuService ( ) [inline]

CfuService::CfuService ( const CfuService & service ) [inline]

Member Function Documentation

CfuServiceCode CfuService::GetCfuServiceCode ( ) const [inline]

returns the CfuServiceCode means if the Servive is undefined, activated or deactivated

const PhoneNumber& CfuService::GetForwardPhoneNumber ( ) const [inline]

returns the call forwarded phonenumber

CfuService& CfuService::operator= ( const CfuService & service ) [inline]

void CfuService::Set | ( | CfuServiceCode | servicecode,
 |  | const PhoneNumber & | phno
 | ) | [inline]

The documentation for this class was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:05:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CfuServiceArray Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CfuServiceArray Class Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CfuServiceArray:

[legend]

Public Member Functions

CfuServiceArray (const CfuServiceArray &array)
CfuServiceArray ()
void | DbgOut () const
CfuDataSource | GetCfuDataSource () const
returns last CfuDataSource, means if CPHS or NVRAM, or NETWORK etc was used to set the values
const CfuService & | GetCfuService (CfuArrayIndex idx) const
returns a CfuService object based on the CfuArrayIndex, means CfuTelephony, CfuTelephonyLine2
void | Merge (const CfuServiceArray &array)
CfuServiceArray & | operator= (const CfuServiceArray &array)

Data Fields

CfuDataSource m_source
CfuService | m_val [CfuArrayAccessMaxLines]

Constructor & Destructor Documentation

CfuServiceArray::CfuServiceArray ( ) [inline]

CfuServiceArray::CfuServiceArray ( const CfuServiceArray & array ) [inline]

Member Function Documentation

void CfuServiceArray::DbgOut ( ) const [inline]

CfuDataSource CfuServiceArray::GetCfuDataSource ( ) const [inline]

returns last CfuDataSource, means if CPHS or NVRAM, or NETWORK etc was used to set the values

const CfuService& CfuServiceArray::GetCfuService ( CfuArrayIndex idx ) const [inline]

returns a CfuService object based on the CfuArrayIndex, means CfuTelephony, CfuTelephonyLine2

void CfuServiceArray::Merge ( const CfuServiceArray & array ) [inline]

CfuServiceArray& CfuServiceArray::operator= ( const CfuServiceArray & array ) [inline]

Field Documentation

CfuDataSource CfuServiceArray::m_source

CfuService CfuServiceArray::m_val[CfuArrayAccessMaxLines]

The documentation for this class was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:05:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CfuStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CfuStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CfuStatusMsg:

[legend]
Collaboration diagram for CfuStatusMsg:

[legend]

Public Types

enum | { ID = 18715 }

Public Member Functions

CfuStatusMsg (const CfuServiceArray &cfu_service_array)
virtual Message * | Clone () const
const CfuServiceArray & | GetCfuServiceArray () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~CfuStatusMsg ()

Detailed Description

CfuStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CfuStatusMsg::CfuStatusMsg ( const CfuServiceArray & cfu_service_array )

CfuStatusMsg::~CfuStatusMsg ( ) [virtual]

Member Function Documentation

Message * CfuStatusMsg::Clone ( ) const [virtual]

Implements Message.

const CfuServiceArray& CfuStatusMsg::GetCfuServiceArray ( ) const [inline]

const MsgMetaData & CfuStatusMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:05:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChannelData_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChannelData_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for ChannelData_s:

[legend]

Data Fields

ChannelDataArray data
byte length

Field Documentation

ChannelDataArray ChannelData_s::data

byte ChannelData_s::length

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:05:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChannelDataArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChannelDataArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

byte A [244]

Field Documentation

byte ChannelDataArray::A[244]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:05:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChargeIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChargeIndArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for ChargeIndArg:

[legend]
Collaboration diagram for ChargeIndArg:

[legend]

Public Types

enum | { ID = 1067 }

Public Member Functions

ChargeIndArg ()
const AocChargeData & | GetAllCallsCharge () const
const AocChargeData & | GetThisCallCharge () const
const Tipd & | GetTipd () const
void | SetAllCallsCharge (const AocChargeData &all_calls_charge)
void | SetThisCallCharge (const AocChargeData &this_call_charge)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const ChargeIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChargeIndArg: reflects arguments of signal MN_CHARGE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChargeIndArg::ChargeIndArg ( )

Member Function Documentation

const ChargeIndArg & ChargeIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const AocChargeData& ChargeIndArg::GetAllCallsCharge ( ) const [inline]

const AocChargeData& ChargeIndArg::GetThisCallCharge ( ) const [inline]

const Tipd& ChargeIndArg::GetTipd ( ) const [inline]

void ChargeIndArg::SetAllCallsCharge ( const AocChargeData & all_calls_charge ) [inline]

void ChargeIndArg::SetThisCallCharge ( const AocChargeData & this_call_charge ) [inline]

void ChargeIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Charger Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Charger Class Reference
[Devices]

#include <Apoxi/Devices/BP30/Charger.hpp>

Inheritance diagram for Charger:

[legend]
Collaboration diagram for Charger:

[legend]

Public Types

enum ChargerMsgType {
ChargerRemoved, ChargeBattery, ChargingPaused, ChargingResumed,
LowBattery, BatteryIdError, BatteryEmpty, ChargeEndChargerIsDisconnected,
ChargeEndBatteryIsFull
}
enum ChargerStatus {
Disabled, WaitingForConnection, ConnectedAndCharging, ConnectedAndTemperatureProtection,
ConnectedAndBatteryFull, DisconnectedAndBatteryFull, DisconnectedAndBatteryNotFull, ChargerDisabledBatteryIdError,
ChargerDisabledVoltageError
}

Public Member Functions

virtual const WCHAR * | GetName () const
virtual | ~Charger ()

Static Public Member Functions

static void | Charge (BOOLEAN charge)
static ControlArg | Control (INT command, ControlArg arg)
static INT16 | GetBatteryVoltage ()
static UINT8 | GetCapacityStatus ()
static ChargerStatus | GetStatus ()
static BOOLEAN | IsBatteryLow ()
static BOOLEAN | IsChargerInserted ()
static BOOLEAN | IsUsbChargingEnabled ()
static void | SetUsbCharging (BOOLEAN enable)
static void | StartBatteryLoadListening ()
static void | StopBatteryLoadListening ()

Protected Member Functions

virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()

Detailed Description

class Charger Charger is the APOXI device abstraction interface for charger hardware driver.

Member Enumeration Documentation

enum Charger::ChargerMsgType

ChargerMsgType

Enumerator:
ChargerRemoved
ChargeBattery | former BatteryChargerRemovedMsg
ChargingPaused | former BatteryChargingMsg
ChargingResumed | former ChargingPausedMsg
LowBattery | former ChargingResumedMsg
BatteryIdError | former BatteryLowMsg
BatteryEmpty | former BatteryIdErrorMsg
ChargeEndChargerIsDisconnected | former BatteryEmptyMsg
ChargeEndBatteryIsFull | former BatteryStopChargingMsg reason = ChargeEndBatteryFull

enum Charger::ChargerStatus

ChargerStatus

Enumerator:
Disabled
WaitingForConnection | charger has not been initialized
ConnectedAndCharging | the charger is not connected
ConnectedAndTemperatureProtection | the charger is connected and charging is active
ConnectedAndBatteryFull | the charger is connected and charging is inactive due to temperature protection
DisconnectedAndBatteryFull | the charger is connected and charging is inactive due to battery full
DisconnectedAndBatteryNotFull | the battery is full and the charger has recently been removed - waiting to stop
ChargerDisabledBatteryIdError | the battery is not full and the charger has recently been removed - waiting to stop
ChargerDisabledVoltageError | charger driver is disabled due to low voltage

Constructor & Destructor Documentation

Charger::~Charger ( ) [virtual]

Member Function Documentation

void Charger::Charge ( BOOLEAN charge ) [static]

sets charger on or off

static ControlArg Charger::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) | [static]

See also:
AbstractDevice::Control

INT16 Charger::GetBatteryVoltage ( ) [static]

returns mean battery voltage in idle mode

UINT8 Charger::GetCapacityStatus ( ) [static]

returns how much capacity is left - expressed as percentage of full capacity. Value range: [0..100]

const WCHAR * Charger::GetName ( ) const [virtual]

Returns the name of a device. The name must not be unique and should just give a short description of the device.

Implements AbstractDevice.

Charger::ChargerStatus Charger::GetStatus ( ) [static]

BOOLEAN Charger::IsBatteryLow ( ) [static]

returns TRUE in case of phone is in low battery state

BOOLEAN Charger::IsChargerInserted ( ) [static]

returns if charger is inserted or not

BOOLEAN Charger::IsUsbChargingEnabled ( ) [static]

check USB-charging status. TRUE if USB connected and charging enabled, FALSE otherwise

virtual void Charger::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void Charger::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void Charger::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void Charger::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

void Charger::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

void Charger::SetUsbCharging ( BOOLEAN enable ) [static]

enable/disable USB-charging

void Charger::StartBatteryLoadListening ( ) [static]

start receiving battery load level indication

void Charger::StopBatteryLoadListening ( ) [static]

stop receiving battery load level indication

The documentation for this class was generated from the following files:
  • Devices/BP30/Charger.hpp
  • Devices/ChargerInterface.hpp
  • Devices/MPE/Charger.hpp
  • Devices/MPEU/Charger.hpp
  • Devices/SGold/Charger.hpp
  • Devices/Win32/Charger.hpp
  • Devices/BP30/Charger.cpp
  • Devices/MPE/Charger.cpp
  • Devices/MPEU/Charger.cpp
  • Devices/SGold/Charger.cpp
  • Devices/Win32/Charger.cpp
Generated on Wed Jan 25 01:05:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChargeReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChargeReqArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for ChargeReqArg:

[legend]
Collaboration diagram for ChargeReqArg:

[legend]

Public Types

enum | { ID = 2062 }

Public Member Functions

ChargeReqArg ()
ChargeReqArg (const Tipd &tipd)
const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const ChargeReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChargeReqArg: reflects arguments of signal MN_CHARGE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChargeReqArg::ChargeReqArg ( const Tipd & tipd )

ChargeReqArg::ChargeReqArg ( )

Member Function Documentation

const ChargeReqArg & ChargeReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& ChargeReqArg::GetTipd ( ) const [inline]

void ChargeReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChargerInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChargerInfoMsg Class Reference

#include <Apoxi/Devices/ChargerMsgTypes.hpp>

Inheritance diagram for ChargerInfoMsg:

[legend]
Collaboration diagram for ChargerInfoMsg:

[legend]

Public Types

enum | { ID = 9150 }

Public Member Functions

ChargerInfoMsg (const Charger::ChargerMsgType &charger_msg_type)
virtual Message * | Clone () const
const Charger::ChargerMsgType & | GetChargerMsgType () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~ChargerInfoMsg ()

Detailed Description

CHARGER

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChargerInfoMsg::ChargerInfoMsg ( const Charger::ChargerMsgType & charger_msg_type )

ChargerInfoMsg::~ChargerInfoMsg ( ) [virtual]

Member Function Documentation

Message * ChargerInfoMsg::Clone ( ) const [virtual]

Implements Message.

const Charger::ChargerMsgType& ChargerInfoMsg::GetChargerMsgType ( ) const [inline]

const MsgMetaData & ChargerInfoMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Devices/ChargerMsgTypes.hpp
  • Devices/ChargerMsgTypes.cpp
Generated on Wed Jan 25 01:05:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChargerSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChargerSignalMapTableNode Class Reference

#include <Apoxi/Devices/ChargerSignalMapTableNode.hpp>

Inheritance diagram for ChargerSignalMapTableNode:

[legend]
Collaboration diagram for ChargerSignalMapTableNode:

[legend]

Static Public Member Functions

static ChargerSignalMapTableNode * GetInstance ()

Detailed Description

@addtogroup Devices

Member Function Documentation

ChargerSignalMapTableNode * ChargerSignalMapTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Devices/ChargerSignalMapTableNode.hpp
  • Devices/ChargerSignalMapTableNode.cpp
Generated on Wed Jan 25 01:05:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChargerSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChargerSignalProcessor Class Reference

#include <Apoxi/Devices/ChargerSignalProcessor.hpp>

Static Public Member Functions

static void | PostBatteryLoadLevelInd (const ProcessPtr &process_ptr)
static void | PostChargingBatteryInd (const ProcessPtr &process_ptr)
static void | PostChargingPausedInd (const ProcessPtr &process_ptr)
static void | PostChargingResumedInd (const ProcessPtr &process_ptr)
static void | PostEmptyBatteryInd (const ProcessPtr &process_ptr)
static void | PostLowBatteryInd (const ProcessPtr &process_ptr)
static void | PostRemoveChargerInd (const ProcessPtr &process_ptr)
static void | PostStopChargingBatteryInd (const ProcessPtr &process_ptr)

Detailed Description

@addtogroup Devices

Member Function Documentation

void ChargerSignalProcessor::PostBatteryLoadLevelInd ( const ProcessPtr & process_ptr ) [static]

void ChargerSignalProcessor::PostChargingBatteryInd ( const ProcessPtr & process_ptr ) [static]

void ChargerSignalProcessor::PostChargingPausedInd ( const ProcessPtr & process_ptr ) [static]

void ChargerSignalProcessor::PostChargingResumedInd ( const ProcessPtr & process_ptr ) [static]

void ChargerSignalProcessor::PostEmptyBatteryInd ( const ProcessPtr & process_ptr ) [static]

void ChargerSignalProcessor::PostLowBatteryInd ( const ProcessPtr & process_ptr ) [static]

void ChargerSignalProcessor::PostRemoveChargerInd ( const ProcessPtr & process_ptr ) [static]

void ChargerSignalProcessor::PostStopChargingBatteryInd ( const ProcessPtr & process_ptr ) [static]

The documentation for this class was generated from the following files:
  • Devices/ChargerSignalProcessor.hpp
  • Devices/ChargerSignalProcessor.cpp
Generated on Wed Jan 25 01:05:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChargeUnitsIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChargeUnitsIndArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for ChargeUnitsIndArg:

[legend]
Collaboration diagram for ChargeUnitsIndArg:

[legend]

Public Types

enum | { ID = 1068 }

Public Member Functions

ChargeUnitsIndArg ()
ULONG | GetAllCallsCcm () const
ULONG | GetThisCallCcm () const
const Tipd & | GetTipd () const
void | SetAllCallsCcm (ULONG all_calls_ccm)
void | SetThisCallCcm (ULONG this_call_ccm)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const ChargeUnitsIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChargeUnitsIndArg: reflects arguments of signal MN[MI]_CHARGE_UNITS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChargeUnitsIndArg::ChargeUnitsIndArg ( )

Member Function Documentation

const ChargeUnitsIndArg & ChargeUnitsIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

ULONG ChargeUnitsIndArg::GetAllCallsCcm ( ) const [inline]

ULONG ChargeUnitsIndArg::GetThisCallCcm ( ) const [inline]

const Tipd& ChargeUnitsIndArg::GetTipd ( ) const [inline]

void ChargeUnitsIndArg::SetAllCallsCcm ( ULONG all_calls_ccm ) [inline]

void ChargeUnitsIndArg::SetThisCallCcm ( ULONG this_call_ccm ) [inline]

void ChargeUnitsIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChargeUnitsReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChargeUnitsReqArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for ChargeUnitsReqArg:

[legend]
Collaboration diagram for ChargeUnitsReqArg:

[legend]

Public Types

enum | { ID = 2064 }

Public Member Functions

ChargeUnitsReqArg ()
ChargeUnitsReqArg (const Tipd &tipd)
const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const ChargeUnitsReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChargeUnitsReqArg: reflects arguments of signal MN[MI]_CHARGE_UNITS_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChargeUnitsReqArg::ChargeUnitsReqArg ( const Tipd & tipd )

ChargeUnitsReqArg::ChargeUnitsReqArg ( )

Member Function Documentation

const ChargeUnitsReqArg & ChargeUnitsReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& ChargeUnitsReqArg::GetTipd ( ) const [inline]

void ChargeUnitsReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:05:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CharInputMapEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CharInputMapEntry Struct Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Collaboration diagram for CharInputMapEntry:

[legend]

Data Fields

WCHAR m_char
InputMapEntry m_map_entry

Field Documentation

WCHAR CharInputMapEntry::m_char

InputMapEntry CharInputMapEntry::m_map_entry

The documentation for this struct was generated from the following file:
  • Kernel/InputMap.hpp
Generated on Wed Jan 25 01:05:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CharInputMapItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CharInputMapItem Class Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Inheritance diagram for CharInputMapItem:

[legend]
Collaboration diagram for CharInputMapItem:

[legend]

Public Types

typedef InputMapItem | Base

Public Member Functions

CharInputMapItem (MapItemType type, WCHAR chr)
WCHAR | GetChar () const
void | SetChar (WCHAR chr)

Member Typedef Documentation

typedef InputMapItem CharInputMapItem::Base

Constructor & Destructor Documentation

CharInputMapItem::CharInputMapItem | ( | MapItemType | type,
 |  | WCHAR | chr
 | ) | [inline]

Member Function Documentation

WCHAR CharInputMapItem::GetChar ( ) const [inline]

void CharInputMapItem::SetChar ( WCHAR chr ) [inline]

The documentation for this class was generated from the following file:
  • Kernel/InputMap.hpp
Generated on Wed Jan 25 01:05:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CharItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CharItem Class Reference
[Editors]

Editor-Item which contains a wide-character. More...

#include <Apoxi/Gui/CharItem.hpp>

Inheritance diagram for CharItem:

[legend]
Collaboration diagram for CharItem:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

CharItem (WCHAR c)
CharItem ()
virtual AtomItem * | Clone () const
virtual void | Draw (DeviceContext *dc, const Rect &bounds) const
WCHAR | GetChar () const
virtual INT | GetId () const
virtual BOOLEAN | IsInstanceOf (INT id) const
operator WCHAR () const
CharItem & | operator= (WCHAR c)
virtual | ~CharItem ()

Detailed Description

Editor-Item which contains a wide-character.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AtomItem.

Constructor & Destructor Documentation

CharItem::CharItem ( )

CharItem::CharItem ( WCHAR c ) [inline, explicit]

CharItem::~CharItem ( ) [virtual]

Member Function Documentation

AtomItem * CharItem::Clone ( ) const [virtual]

Returns:
A pointer to a deep copy of this object.
See also:
AtomItem::Clone();

Implements AtomItem.

void CharItem::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AtomItem::Draw()

Implements AtomItem.

WCHAR CharItem::GetChar ( ) const [inline]

INT CharItem::GetId ( ) const [virtual]

See also:
AtomItem::GetId()

Reimplemented from AtomItem.

BOOLEAN CharItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from AtomItem.

CharItem::operator WCHAR ( ) const [inline]

CharItem& CharItem::operator= ( WCHAR c ) [inline]

The documentation for this class was generated from the following files:
  • Gui/CharItem.hpp
  • Gui/CharItem.cpp
Generated on Wed Jan 25 01:05:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBox Class Reference

Obsolete - use the class CheckBoxControl from GUI instead. More...

#include <Apoxi/Compat/CheckBox.hpp>

Inheritance diagram for CheckBox:

[legend]
Collaboration diagram for CheckBox:

[legend]

Public Member Functions

CheckBox (Control *parent, const WCHAR *caption=0, BOOLEAN selected=FALSE)
CheckBox ()
void | Init (Control *parent, const WCHAR *caption=0, BOOLEAN selected=FALSE)
BOOLEAN | IsSelected () const
void | SetSelected (BOOLEAN selected)
virtual | ~CheckBox ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual void | OnChangeStatus ()
Is called, if the status of the CheckBox has been changed.
virtual void | OnGetFocus ()
virtual BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
virtual void | OnLanguageChanged ()
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnSoftkeyPressed (INT idx)
virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Detailed Description

Obsolete - use the class CheckBoxControl from GUI instead.

Constructor & Destructor Documentation

CheckBox::CheckBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

CheckBox::CheckBox | ( | Control * | parent,
 |  | const WCHAR * | caption = 0,
 |  | BOOLEAN | selected = FALSE
 | ) |

Parameters:
parent | Pointer to the window, which embedds the CheckBox.
caption | Pointer to the caption.
selected | State of the CheckBox.

CheckBox::~CheckBox ( ) [virtual]

Member Function Documentation

Model * CheckBox::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel()

Reimplemented from Component.

void CheckBox::Init | ( | Control * | parent,
 |  | const WCHAR * | caption = 0,
 |  | BOOLEAN | selected = FALSE
 | ) |

Parameters:
parent | Pointer to the window, which embedds the CheckBox.
caption | Pointer to the caption.
selected | State of the CheckBox.

BOOLEAN CheckBox::IsSelected ( ) const

void CheckBox::OnChangeStatus ( ) [protected, virtual]

Is called, if the status of the CheckBox has been changed.

void CheckBox::OnGetFocus ( ) [protected, virtual]

See also:
Window::OnGetFocus()

Reimplemented from Control.

BOOLEAN CheckBox::OnInputMap ( const InputMapItem & input_map_item ) [protected, virtual]

See also:
Window::OnInputMap

Reimplemented from Control.

void CheckBox::OnLanguageChanged ( ) [protected, virtual]

See also:
Control::OnLanguageChanged

Reimplemented from Control.

void CheckBox::OnLoseFocus ( ) [protected, virtual]

See also:
Window::OnGetFocus()

Reimplemented from Control.

BOOLEAN CheckBox::OnSoftkeyPressed ( INT idx ) [protected, virtual]

See also:
Window::OnSoftkeyPressed()

void CheckBox::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from Control.

void CheckBox::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect &rect)

Reimplemented from Control.

void CheckBox::SetSelected ( BOOLEAN selected )

The documentation for this class was generated from the following files:
  • Compat/CheckBox.hpp
  • Compat/CheckBox.cpp
Generated on Wed Jan 25 01:05:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBoxAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBoxAction Class Reference
[Items]

#include <Apoxi/Gui/CheckBoxAction.hpp>

Inheritance diagram for CheckBoxAction:

[legend]
Collaboration diagram for CheckBoxAction:

[legend]

Public Types

enum | { ID = 5 }

Public Member Functions

CheckBoxAction (const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE)
Obsolete - use the constructor having a dispatcher as input instead.
CheckBoxAction (Dispatcher *dispatcher, const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE)
CheckBoxAction ()
virtual const BitmapRes * | GetDeselectedIcon () const
Obsolete - see AbstractToggleAction::GetDeselectedIcon.
virtual const BitmapRes * | GetSelectedIcon () const
Obsolete - see AbstractToggleAction::GetSelectedIcon.
void | Init (const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE)
Obsolete - use the Init having a dispatcher as input instead.
void | Init (Dispatcher *dispatcher, const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual void | SetSelected (BOOLEAN select)
virtual BOOLEAN | Toggle (BOOLEAN old_state)
virtual | ~CheckBoxAction ()

Detailed Description

A checkbox action describes an action which toggles itself on executing between a selected state and a deselected state.
See also:
CheckBoxControl

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractToggleAction.

Constructor & Destructor Documentation

CheckBoxAction::CheckBoxAction ( )

CheckBoxAction::CheckBoxAction | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.
selected | Specifies whether the toggle action is in the selected or non selected state.

CheckBoxAction::~CheckBoxAction ( ) [virtual]

CheckBoxAction::CheckBoxAction | ( | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE
 | ) |

Obsolete - use the constructor having a dispatcher as input instead.

Member Function Documentation

const BitmapRes * CheckBoxAction::GetDeselectedIcon ( ) const [virtual]

Obsolete - see AbstractToggleAction::GetDeselectedIcon.

Reimplemented from AbstractToggleAction.

const BitmapRes * CheckBoxAction::GetSelectedIcon ( ) const [virtual]

Obsolete - see AbstractToggleAction::GetSelectedIcon.

Reimplemented from AbstractToggleAction.

void CheckBoxAction::Init | ( | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE
 | ) |

Obsolete - use the Init having a dispatcher as input instead.

void CheckBoxAction::Init | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.
selected | Specifies whether the toggle action is in the selected or non selected state.

BOOLEAN CheckBoxAction::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from AbstractToggleAction.

BOOLEAN CheckBoxAction::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from AbstractToggleAction.

void CheckBoxAction::SetSelected ( BOOLEAN select ) [virtual]

See also:
AbstractToggleAction::SetSelected

Reimplemented from AbstractToggleAction.

BOOLEAN CheckBoxAction::Toggle ( BOOLEAN old_state ) [virtual]

See also:
AbstractToggleAction::Toggle

Implements AbstractToggleAction.

The documentation for this class was generated from the following files:
  • Gui/CheckBoxAction.hpp
  • Gui/CheckBoxAction.cpp
Generated on Wed Jan 25 01:05:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBoxControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBoxControl Class Reference
[Components]

#include <Apoxi/Gui/CheckBoxControl.hpp>

Inheritance diagram for CheckBoxControl:

[legend]
Collaboration diagram for CheckBoxControl:

[legend]

Public Types

enum | { ID = 6 }

Public Member Functions

CheckBoxControl (Control *parent, const WCHAR *text, BOOLEAN selected=FALSE)
CheckBoxControl ()
INT | GetValue () const
Returns the value of the checkbox. Per default 0 is returned.
void | Init (Control *parent, const WCHAR *text, BOOLEAN selected=FALSE)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsSelected () const
Returns the selection state of the checkbox.
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetSelected (BOOLEAN selected)
Adjusts the selection state of the checkbox. Per default the selection state is FALSE.
void | SetValue (INT value)
A checkbox may represent a value, which can be specified.
void | Toggle ()
virtual | ~CheckBoxControl ()

Protected Member Functions

virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Detailed Description

A CheckBoxControl represents a checkbox, which may be selected or unselected. In contrast to a radiobutton-control, checkboxes are independant from other checkboxes per definition.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractButton.

Constructor & Destructor Documentation

CheckBoxControl::CheckBoxControl ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

CheckBoxControl::CheckBoxControl | ( | Control * | parent,
 |  | const WCHAR * | text,
 |  | BOOLEAN | selected = FALSE
 | ) |

Parameters:
parent | Pointer to the window, which embeds the checkbox-control.
text | Pointer to the text of the checkbox-control.
selected | Flag, whether the checkbox is selected.

CheckBoxControl::~CheckBoxControl ( ) [virtual]

Member Function Documentation

INT CheckBoxControl::GetValue ( ) const [inline]

Returns the value of the checkbox. Per default 0 is returned.

void CheckBoxControl::Init | ( | Control * | parent,
 |  | const WCHAR * | text,
 |  | BOOLEAN | selected = FALSE
 | ) |

Parameters:
parent | Pointer to the window, which embeds the checkbox-control.
text | Pointer to the text of the checkbox-control.
selected | Flag, whether the checkbox is selected.

BOOLEAN CheckBoxControl::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractButton.

BOOLEAN CheckBoxControl::IsSelected ( ) const [inline]

Returns the selection state of the checkbox.

void CheckBoxControl::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged

Reimplemented from Control.

void CheckBoxControl::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from Control.

BOOLEAN CheckBoxControl::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractButton.

void CheckBoxControl::SetSelected ( BOOLEAN selected ) [inline]

Adjusts the selection state of the checkbox. Per default the selection state is FALSE.

void CheckBoxControl::SetValue ( INT value ) [inline]

A checkbox may represent a value, which can be specified.

void CheckBoxControl::Toggle ( )

Toggles the selected property: if the checkbox is selected it will get unselected, if the selection is unselected it will get selected.

The documentation for this class was generated from the following files:
  • Gui/CheckBoxControl.hpp
  • Gui/CheckBoxControl.cpp
Generated on Wed Jan 25 01:05:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBoxControlView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBoxControlView Class Reference
[Components]

Describes the view of a checkbox-control. More...

#include <Apoxi/Gui/CheckBoxControl.hpp>

Inheritance diagram for CheckBoxControlView:

[legend]
Collaboration diagram for CheckBoxControlView:

[legend]

Public Member Functions

CheckBoxControlView (XYDIM default_height)
CheckBoxControlView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | Update (const Theme &theme)
virtual | ~CheckBoxControlView ()

Detailed Description

Describes the view of a checkbox-control.

Constructor & Destructor Documentation

CheckBoxControlView::CheckBoxControlView ( )

CheckBoxControlView::CheckBoxControlView ( XYDIM default_height )

CheckBoxControlView::~CheckBoxControlView ( ) [virtual]

Member Function Documentation

void CheckBoxControlView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

void CheckBoxControlView::Update ( const Theme & theme ) [virtual]

See also:
View::Update

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Gui/CheckBoxControl.hpp
  • Gui/CheckBoxControl.cpp
Generated on Wed Jan 25 01:05:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBoxItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBoxItem Class Reference

#include <Apoxi/Compat/CheckBoxItem.hpp>

Inheritance diagram for CheckBoxItem:

[legend]
Collaboration diagram for CheckBoxItem:

[legend]

Public Member Functions

CheckBoxItem (const WCHAR *text=0, BOOLEAN selected=FALSE)
const WCHAR * | GetText () const
Returns the text of the item.
BOOLEAN | IsSelected () const
Returns TRUE, if the checkbox is selected.
void | SetSelected (BOOLEAN selected)
Sets the selection of the item.
void | SetText (const WCHAR *text)
Sets the text of the item.

Detailed Description

Defines a menu-item which looks like a checkbox-control. This is mostly for performance-reasons, because using controls as menu-items leads to inefficient scrolling and a huge amount of memory.

Constructor & Destructor Documentation

CheckBoxItem::CheckBoxItem | ( | const WCHAR * | text = 0,
 |  | BOOLEAN | selected = FALSE
 | ) | [inline]

Member Function Documentation

const WCHAR* CheckBoxItem::GetText ( ) const [inline]

Returns the text of the item.

BOOLEAN CheckBoxItem::IsSelected ( ) const [inline]

Returns TRUE, if the checkbox is selected.

void CheckBoxItem::SetSelected ( BOOLEAN selected ) [inline]

Sets the selection of the item.

void CheckBoxItem::SetText ( const WCHAR * text ) [inline]

Sets the text of the item.

The documentation for this class was generated from the following file:
  • Compat/CheckBoxItem.hpp
Generated on Wed Jan 25 01:05:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBoxList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBoxList Class Reference

#include <Apoxi/Compat/CheckBoxList.hpp>

Inheritance diagram for CheckBoxList:

[legend]
Collaboration diagram for CheckBoxList:

[legend]

Public Member Functions

void | AddItem (CheckBoxItem *item, const WCHAR *text, BOOLEAN selected=FALSE) const
void | AddItem (CheckBoxItem *item, CheckBoxItem *after=0)
CheckBoxList (Control *parent)
CheckBoxList ()
CheckBoxItem * | GetFirstItem () const
void | Init (Control *parent)
void | RemoveAllItems () const
void | RemoveItem (CheckBoxItem *item)
virtual | ~CheckBoxList ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual void | OnItemSelected ()
virtual void | OnLanguageChanged ()
virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Detailed Description

Obsolete - use the CheckBoxControl or the CheckBoxAction in combination with a listbox instead.

Constructor & Destructor Documentation

CheckBoxList::CheckBoxList ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

CheckBoxList::CheckBoxList ( Control * parent )

Parameters:
parent Pointer to the window, which embedds the CheckBoxList.

CheckBoxList::~CheckBoxList ( ) [virtual]

Member Function Documentation

void CheckBoxList::AddItem | ( | CheckBoxItem * | item,
 |  | const WCHAR * | text,
 |  | BOOLEAN | selected = FALSE
 | ) | const

void CheckBoxList::AddItem | ( | CheckBoxItem * | item,
 |  | CheckBoxItem * | after = 0
 | ) |

Parameters:
item | CheckBoxItem to be added to the item list.
after | By default (0) the item is appended to the end of the item list. Otherwise it will be inserted after this item.

Model * CheckBoxList::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel()

Reimplemented from Component.

CheckBoxItem * CheckBoxList::GetFirstItem ( ) const

Returns:
First item of the item list.

void CheckBoxList::Init ( Control * parent )

Parameters:
parent Pointer to the window, which embedds the CheckBoxList.

Reimplemented from AbstractListBox.

void CheckBoxList::OnItemSelected ( ) [protected, virtual]

See also:
AbstractMenuList::OnItemSelected

Reimplemented from AbstractMenuList.

void CheckBoxList::OnLanguageChanged ( ) [protected, virtual]

See also:
Control::OnLanguageChanged

Reimplemented from Control.

void CheckBoxList::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from AbstractListBox.

void CheckBoxList::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect &rect)

Reimplemented from AbstractListBox.

void CheckBoxList::RemoveAllItems ( ) const

void CheckBoxList::RemoveItem ( CheckBoxItem * item )

Parameters:
item CheckBoxItem to be removed from the item list.

The documentation for this class was generated from the following files:
  • Compat/CheckBoxList.hpp
  • Compat/CheckBoxList.cpp
Generated on Wed Jan 25 01:05:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBoxListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBoxListView Class Reference

Describes the view of a checkbox-list. More...

#include <Apoxi/Compat/CheckBoxList.hpp>

Inheritance diagram for CheckBoxListView:

[legend]
Collaboration diagram for CheckBoxListView:

[legend]

Public Member Functions

CheckBoxListView (CheckBoxView *view, XYDIM item_height)
CheckBoxListView ()
virtual void | DrawItem (const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const
virtual | ~CheckBoxListView ()

Protected Member Functions

virtual void | DrawCheckBoxItem (const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const =0

Protected Attributes

const CheckBoxView * | m_view

Detailed Description

Describes the view of a checkbox-list.

Constructor & Destructor Documentation

CheckBoxListView::CheckBoxListView ( )

CheckBoxListView::CheckBoxListView | ( | CheckBoxView * | view,
 |  | XYDIM | item_height
 | ) |

CheckBoxListView::~CheckBoxListView ( ) [virtual]

Member Function Documentation

virtual void CheckBoxListView::DrawCheckBoxItem | ( | const CheckBoxItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, pure virtual]

Implemented in BlueSkyCheckBoxListView, DefaultCheckBoxListView, TestCheckBoxListView, and DefaultCheckBoxListView.

void CheckBoxListView::DrawItem | ( | const AbstractListBox & | listbox,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [virtual]

Reimplemented from AbstractListBoxView.

Field Documentation

const CheckBoxView* CheckBoxListView::m_view [protected]

The documentation for this class was generated from the following files:
  • Compat/CheckBoxList.hpp
  • Compat/CheckBoxList.cpp
Generated on Wed Jan 25 01:05:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBoxModel Class Reference

Describes the model of a checkbox. More...

#include <Apoxi/Compat/CheckBox.hpp>

Inheritance diagram for CheckBoxModel:

[legend]
Collaboration diagram for CheckBoxModel:

[legend]

Public Types

typedef Model | Base

Public Member Functions

CheckBoxModel (const WCHAR *caption=0, BOOLEAN selected=FALSE)
const WCHAR * | GetCaption () const
Returns the caption of the checkbox-model.
BOOLEAN | IsSelected () const
Returns the selected of the checkbox-model.
void | SetCaption (const WCHAR *caption)
Sets the caption of the checkbox-model.
void | SetSelected (BOOLEAN selected)
Sets the selected of the checkbox-model.

Detailed Description

Describes the model of a checkbox.

Member Typedef Documentation

typedef Model CheckBoxModel::Base

Constructor & Destructor Documentation

CheckBoxModel::CheckBoxModel | ( | const WCHAR * | caption = 0,
 |  | BOOLEAN | selected = FALSE
 | ) |

Member Function Documentation

const WCHAR* CheckBoxModel::GetCaption ( ) const [inline]

Returns the caption of the checkbox-model.

BOOLEAN CheckBoxModel::IsSelected ( ) const [inline]

Returns the selected of the checkbox-model.

void CheckBoxModel::SetCaption ( const WCHAR * caption ) [inline]

Sets the caption of the checkbox-model.

void CheckBoxModel::SetSelected ( BOOLEAN selected ) [inline]

Sets the selected of the checkbox-model.

The documentation for this class was generated from the following files:
  • Compat/CheckBox.hpp
  • Compat/CheckBox.cpp
Generated on Wed Jan 25 01:05:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CheckBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CheckBoxView Class Reference

Describes the view of a checkbox. More...

#include <Apoxi/Compat/CheckBox.hpp>

Inheritance diagram for CheckBoxView:

[legend]
Collaboration diagram for CheckBoxView:

[legend]

Public Member Functions

CheckBoxView (XYDIM default_height, XYDIM left_gap, XYDIM middle_gap)
CheckBoxView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShifted (const Rect &shift_rect, const Model &abstract_model, DeviceContext *dc, const Rect &repaint_rect) const
XYDIM | GetItemHeight () const
Returns the height of the item.
XYDIM | GetLeftGap () const
XYDIM | GetMiddleGap () const
Returns the gap between the checkbox-button and the caption.
void | SetItemHeight (XYDIM item_height)
Sets the height of the item.
void | SetLeftGap (XYDIM left_gap)
void | SetMiddleGap (XYDIM middle_gap)
Sets the gap between the checkbox-button and the caption.
virtual | ~CheckBoxView ()

Protected Member Functions

virtual void | DrawCheckBox (const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const =0
virtual void | DrawShiftedCheckBox (const Rect &shift_rect, const CheckBoxModel &abstract_model, DeviceContext *dc, const Rect &repaint_rect) const =0

Detailed Description

Describes the view of a checkbox.

Constructor & Destructor Documentation

CheckBoxView::CheckBoxView ( )

CheckBoxView::CheckBoxView | ( | XYDIM | default_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

CheckBoxView::~CheckBoxView ( ) [virtual]

Member Function Documentation

void CheckBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

virtual void CheckBoxView::DrawCheckBox | ( | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Implemented in BlueSkyCheckBoxView, DefaultCheckBoxView, TestCheckBoxView, and DefaultCheckBoxView.

void CheckBoxView::DrawShifted | ( | const Rect & | shift_rect,
 |  | const Model & | abstract_model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

virtual void CheckBoxView::DrawShiftedCheckBox | ( | const Rect & | shift_rect,
 |  | const CheckBoxModel & | abstract_model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Implemented in BlueSkyCheckBoxView, DefaultCheckBoxView, TestCheckBoxView, and DefaultCheckBoxView.

XYDIM CheckBoxView::GetItemHeight ( ) const [inline]

Returns the height of the item.

XYDIM CheckBoxView::GetLeftGap ( ) const [inline]

Returns the gap between the left side of the control-frame and the checkbox-button.

XYDIM CheckBoxView::GetMiddleGap ( ) const [inline]

Returns the gap between the checkbox-button and the caption.

void CheckBoxView::SetItemHeight ( XYDIM item_height ) [inline]

Sets the height of the item.

void CheckBoxView::SetLeftGap ( XYDIM left_gap ) [inline]

Sets the gap between the left side of the control-frame and the checkbox-button.

void CheckBoxView::SetMiddleGap ( XYDIM middle_gap ) [inline]

Sets the gap between the checkbox-button and the caption.

The documentation for this class was generated from the following files:
  • Compat/CheckBox.hpp
  • Compat/CheckBox.cpp
Generated on Wed Jan 25 01:05:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChildBinData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChildBinData Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/ChildBinData.hpp>

Inheritance diagram for ChildBinData:

[legend]
Collaboration diagram for ChildBinData:

[legend]

Public Member Functions

virtual UINT32 | GetLength () const
virtual UINT32 | Read (UINT32 idx, void *val, UINT32 nbytes) const
virtual BOOLEAN | Read (UINT32 idx, UINT8 &val) const

Static Public Member Functions

static ChildBinData * | CreateInstance (const BinData &parent_data, UINT32 start_offset)

Protected Member Functions

ChildBinData (const BinData &parent_data, UINT32 start_offset)
virtual | ~ChildBinData ()

Detailed Description

ChildBinData allows to read data starting from a given offset of an existing BinData object.

Constructor & Destructor Documentation

ChildBinData::ChildBinData | ( | const BinData & | parent_data,
 |  | UINT32 | start_offset
 | ) | [protected]

ChildBinData::~ChildBinData ( ) [protected, virtual]

Member Function Documentation

ChildBinData * ChildBinData::CreateInstance | ( | const BinData & | parent_data,
 |  | UINT32 | start_offset
 | ) | [static]

Creates and returns an object of this class.

Parameters:
parent_data | BinData object containing the data which should be read.
start_offset | Start offset of the data. When invoking ChildBinData::Read the parameter idx will be incremented by the start offset.

UINT32 ChildBinData::GetLength ( ) const [virtual]

See also:
BinData::GetLength

Implements BinData.

UINT32 ChildBinData::Read | ( | UINT32 | idx,
 |  | void * | val,
 |  | UINT32 | nbytes
 | ) | const [virtual]

See also:
BinData::Read

Implements BinData.

BOOLEAN ChildBinData::Read | ( | UINT32 | idx,
 |  | UINT8 & | val
 | ) | const [virtual]

See also:
BinData::Read

Implements BinData.

The documentation for this class was generated from the following files:
  • Auxiliary/ChildBinData.hpp
  • Auxiliary/ChildBinData.cpp
Generated on Wed Jan 25 01:05:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChineseQuickSortProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChineseQuickSortProvider Class Reference

#include <Apoxi/Auxiliary/ChineseQuickSortProvider.hpp>

Inheritance diagram for ChineseQuickSortProvider:

[legend]
Collaboration diagram for ChineseQuickSortProvider:

[legend]

Public Types

typedef QuickSortProvider | Base
enum | SortMode { normal = 0, pinyin, stroke, bopomofo }

Public Member Functions

ChineseQuickSortProvider (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
ChineseQuickSortProvider ()
SortMode GetSortMode ()
void | SetSortMode (SortMode sort_mode)
INT | SortCompare (WString *x1, WString *x2)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and executes the sort process.
virtual | ~ChineseQuickSortProvider ()

Protected Member Functions

virtual void | QuickSort (INT left, INT right, INT &depth)

Detailed Description

A ChineseQuickSortProvider is used to sort rows of a child provider with the quick sort algorithm.

Member Typedef Documentation

typedef QuickSortProvider ChineseQuickSortProvider::Base

Reimplemented from QuickSortProvider.

Member Enumeration Documentation

enum ChineseQuickSortProvider::SortMode

Enumerator:
normal
pinyin
stroke
bopomofo

Constructor & Destructor Documentation

ChineseQuickSortProvider::ChineseQuickSortProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ChineseQuickSortProvider::ChineseQuickSortProvider | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be sorted. columnid: Specify which columnid has to be sorted. order: Specify whether ascending (TRUE) or descending (FALSE).

ChineseQuickSortProvider::~ChineseQuickSortProvider ( ) [virtual]

Member Function Documentation

ChineseQuickSortProvider::SortMode ChineseQuickSortProvider::GetSortMode ( )

void ChineseQuickSortProvider::QuickSort | ( | INT | left,
 |  | INT | right,
 |  | INT & | depth
 | ) | [protected, virtual]

Reimplemented from QuickSortProvider.

void ChineseQuickSortProvider::SetSortMode ( SortMode sort_mode )

INT ChineseQuickSortProvider::SortCompare | ( | WString * | x1,
 |  | WString * | x2
 | ) |

BOOLEAN ChineseQuickSortProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and executes the sort process.

Reimplemented from QuickSortProvider.

The documentation for this class was generated from the following files:
  • Auxiliary/ChineseQuickSortProvider.hpp
  • Auxiliary/ChineseQuickSortProvider.cpp
Generated on Wed Jan 25 01:06:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChineseT9InputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChineseT9InputMapper Class Reference

#include <Apoxi/AddOns/T9/ChineseT9InputMapper.hpp>

Inheritance diagram for ChineseT9InputMapper:

[legend]
Collaboration diagram for ChineseT9InputMapper:

[legend]

Public Member Functions

ChineseT9InputMapper (AbstractEditor *editor=0)
virtual InputMapper::Alphabet | GetAlphabet () const
virtual PredMode | GetMode () const
Discover the current input method.
virtual const WCHAR * | GetPhonetics (INT *selected_index=0) const
virtual INT | GetSelectedIndex () const
virtual const WCHAR * | GetSelection () const
virtual const WCHAR * | GetStatusInfo () const
A human-readable name for the current input method.
virtual const WCHAR * | GetStrokes () const
virtual BOOLEAN | IsModeSupported (PredMode mode)
virtual BOOLEAN | SetMode (PredMode mode)
virtual | ~ChineseT9InputMapper ()

Protected Member Functions

virtual const T9Wrapper * | GetT9Wrapper () const
override
virtual T9Wrapper * | GetT9Wrapper ()
override
virtual BOOLEAN | OnLongKeyPress_T9 (KeyCode apoxi_key_code)
This is an override.
virtual BOOLEAN | OnShortKeyUp_T9 (KeyCode apoxi_key_code)

Detailed Description

This InputMapper supports the following methods:
  • Traditional Chinese Stroke
    • Simplified Chinese Stoke
    • Pinyin (Traditional Chinese Phonetic)
    • Bopofomo (Simplified Chinese Phonetic) (and English from the base class)

Constructor & Destructor Documentation

ChineseT9InputMapper::ChineseT9InputMapper ( AbstractEditor * editor = 0 )

ChineseT9InputMapper::~ChineseT9InputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet ChineseT9InputMapper::GetAlphabet ( ) const [virtual]

See also:
InputMapper::GetAlphabet

Reimplemented from EnglishT9InputMapper.

PredInputMapper::PredMode ChineseT9InputMapper::GetMode ( ) const [virtual]

Discover the current input method.

Reimplemented from EnglishT9InputMapper.

const WCHAR * ChineseT9InputMapper::GetPhonetics ( INT * selected_index = 0 ) const [virtual]

Reimplemented from T9InputMapper.

INT ChineseT9InputMapper::GetSelectedIndex ( ) const [virtual]

Reimplemented from T9InputMapper.

const WCHAR * ChineseT9InputMapper::GetSelection ( ) const [virtual]

Reimplemented from T9InputMapper.

const WCHAR * ChineseT9InputMapper::GetStatusInfo ( ) const [virtual]

A human-readable name for the current input method.

Reimplemented from EnglishT9InputMapper.

const WCHAR * ChineseT9InputMapper::GetStrokes ( ) const [virtual]

Reimplemented from T9InputMapper.

const T9Wrapper * ChineseT9InputMapper::GetT9Wrapper ( ) const [protected, virtual]

override

Reimplemented from EnglishT9InputMapper.

T9Wrapper * ChineseT9InputMapper::GetT9Wrapper ( ) [protected, virtual]

override

Reimplemented from EnglishT9InputMapper.

BOOLEAN ChineseT9InputMapper::IsModeSupported ( PredMode mode ) [virtual]

Reimplemented from EnglishT9InputMapper.

BOOLEAN ChineseT9InputMapper::OnLongKeyPress_T9 ( KeyCode apoxi_key_code ) [protected, virtual]

This is an override.

Reimplemented from EnglishT9InputMapper.

BOOLEAN ChineseT9InputMapper::OnShortKeyUp_T9 ( KeyCode apoxi_key_code ) [protected, virtual]

See also:
InputMapper::OnShortKeyUp_T9(). This is an override.

Reimplemented from EnglishT9InputMapper.

BOOLEAN ChineseT9InputMapper::SetMode ( PredMode mode ) [virtual]

Reimplemented from EnglishT9InputMapper.

The documentation for this class was generated from the following files:
  • AddOns/T9/ChineseT9InputMapper.hpp
  • AddOns/T9/ChineseT9InputMapper.cpp
Generated on Wed Jan 25 01:06:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChineseT9Wrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChineseT9Wrapper Class Reference

#include <Apoxi/AddOns/T9/ChineseT9Wrapper.hpp>

Public Member Functions

BOOLEAN | ChangePhoneticSelection (T9U8 phonetic_index)
change the phonetic group in the pinyin selection list
ChineseT9Wrapper ()
virtual void | DestroyT9 ()
const WCHAR * | GetBopomofoList () const
T9NUM | GetChineseKeyBufLen () const
Get count of how many keys have been pressed to form one phonetic group.
BOOLEAN | GetChineseMode_IsAmbiguousPhonetic () const
BOOLEAN | GetChineseMode_IsAutoSpell () const
BOOLEAN | GetChineseMode_IsComponents () const
BOOLEAN | GetChineseMode_IsCUdbSearchOnly () const
BOOLEAN | GetChineseMode_IsExplicitPhonetic () const
BOOLEAN | GetChineseMode_IsExplicitPhoneticContinualSelection () const
BOOLEAN | GetChineseMode_IsFuzzyPinyin () const
BOOLEAN | GetChineseMode_IsStroke () const
const T9U16 * | GetChineseSelectPage () const
Get the Chinese characters for selecting with the same phonetic pronunciation.
T9NUM | GetChineseSelectPageNum () const
SelectPageNum.
T9U8 | GetPhoneticCount () const
To calculate how many Phonetic Groups with same key sequences.
T9U8 | GetPhoneticIndex () const
get current selected phonetic group index
const T9U8 * | GetPhoneticList () const
Get the Phonetic group content.
const T9U8 * | GetStrokeBuffer () const
Get the Stroke group content.
virtual void | Init ()
BOOLEAN | IsLanguageSupported (t9_language language, T9MINOR mode)
void | RefreshPhoneticList ()
Phonetic list can only be refreshed by sending a request to T9 core.
BOOLEAN | SelectPhoneticChineseWord (UINT index)
Select a word from the Chinese selection list.
BOOLEAN | SelectStrokeChineseWord (UINT index)
BOOLEAN | SetMode_Bopomofo ()
BOOLEAN | SetMode_PinYin ()
BOOLEAN | SetMode_SimplifiedChineseStroke ()
BOOLEAN | SetMode_TraditionalChineseStroke ()
BOOLEAN | ToggleComponentEntryMode ()
Switch between Component/Non-Component mode.
virtual | ~ChineseT9Wrapper ()

Constructor & Destructor Documentation

ChineseT9Wrapper::ChineseT9Wrapper ( )

ChineseT9Wrapper::~ChineseT9Wrapper ( ) [virtual]

Member Function Documentation

BOOLEAN ChineseT9Wrapper::ChangePhoneticSelection ( T9U8 phonetic_index )

change the phonetic group in the pinyin selection list

void ChineseT9Wrapper::DestroyT9 ( ) [virtual]

const WCHAR * ChineseT9Wrapper::GetBopomofoList ( ) const

T9NUM ChineseT9Wrapper::GetChineseKeyBufLen ( ) const

Get count of how many keys have been pressed to form one phonetic group.

BOOLEAN ChineseT9Wrapper::GetChineseMode_IsAmbiguousPhonetic ( ) const

BOOLEAN ChineseT9Wrapper::GetChineseMode_IsAutoSpell ( ) const

BOOLEAN ChineseT9Wrapper::GetChineseMode_IsComponents ( ) const

BOOLEAN ChineseT9Wrapper::GetChineseMode_IsCUdbSearchOnly ( ) const

BOOLEAN ChineseT9Wrapper::GetChineseMode_IsExplicitPhonetic ( ) const

BOOLEAN ChineseT9Wrapper::GetChineseMode_IsExplicitPhoneticContinualSelection ( ) const

BOOLEAN ChineseT9Wrapper::GetChineseMode_IsFuzzyPinyin ( ) const

BOOLEAN ChineseT9Wrapper::GetChineseMode_IsStroke ( ) const

const T9U16 * ChineseT9Wrapper::GetChineseSelectPage ( ) const

Get the Chinese characters for selecting with the same phonetic pronunciation.

T9NUM ChineseT9Wrapper::GetChineseSelectPageNum ( ) const

SelectPageNum.

T9U8 ChineseT9Wrapper::GetPhoneticCount ( ) const

To calculate how many Phonetic Groups with same key sequences.

T9U8 ChineseT9Wrapper::GetPhoneticIndex ( ) const

get current selected phonetic group index

const T9U8 * ChineseT9Wrapper::GetPhoneticList ( ) const

Get the Phonetic group content.

const T9U8 * ChineseT9Wrapper::GetStrokeBuffer ( ) const

Get the Stroke group content.

void ChineseT9Wrapper::Init ( ) [virtual]

BOOLEAN ChineseT9Wrapper::IsLanguageSupported | ( | t9_language | language,
 |  | T9MINOR | mode
 | ) |

Method for testing if a language is supported in one of the current T9 language databases (LDB)

Parameters:
language
Returns:
TRUE if language is supported, FALSE otherwise

void ChineseT9Wrapper::RefreshPhoneticList ( )

Phonetic list can only be refreshed by sending a request to T9 core.

BOOLEAN ChineseT9Wrapper::SelectPhoneticChineseWord ( UINT index )

Select a word from the Chinese selection list.

BOOLEAN ChineseT9Wrapper::SelectStrokeChineseWord ( UINT index )

BOOLEAN ChineseT9Wrapper::SetMode_Bopomofo ( )

BOOLEAN ChineseT9Wrapper::SetMode_PinYin ( )

BOOLEAN ChineseT9Wrapper::SetMode_SimplifiedChineseStroke ( )

BOOLEAN ChineseT9Wrapper::SetMode_TraditionalChineseStroke ( )

BOOLEAN ChineseT9Wrapper::ToggleComponentEntryMode ( )

Switch between Component/Non-Component mode.

The documentation for this class was generated from the following files:
  • AddOns/T9/ChineseT9Wrapper.hpp
  • AddOns/T9/ChineseT9Wrapper.cpp
Generated on Wed Jan 25 01:06:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Chv1DisableIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Chv1DisableIndArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for Chv1DisableIndArg:

[legend]
Collaboration diagram for Chv1DisableIndArg:

[legend]

Public Types

enum | { ID = 1044 }

Public Member Functions

Chv1DisableIndArg ()
const ChvAttemptsStruct & | GetChvAttempts () const
const ChvStatus & | GetStatus () const
void | SetChvAttempts (const ChvAttemptsStruct &chv_attempts)
void | SetStatus (const ChvStatus &status)

Static Public Member Functions

static const Chv1DisableIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

Chv1DisableIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

Chv1DisableIndArg::Chv1DisableIndArg ( )

Member Function Documentation

const Chv1DisableIndArg & Chv1DisableIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvAttemptsStruct& Chv1DisableIndArg::GetChvAttempts ( ) const [inline]

const ChvStatus& Chv1DisableIndArg::GetStatus ( ) const [inline]

void Chv1DisableIndArg::SetChvAttempts ( const ChvAttemptsStruct & chv_attempts ) [inline]

void Chv1DisableIndArg::SetStatus ( const ChvStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Chv1DisableReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Chv1DisableReqArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for Chv1DisableReqArg:

[legend]
Collaboration diagram for Chv1DisableReqArg:

[legend]

Public Types

enum | { ID = 2044 }

Public Member Functions

Chv1DisableReqArg ()
Chv1DisableReqArg (const T_SI_CHV &chv)
Chv1DisableReqArg (const CHAR *pin)
const T_SI_CHV & | GetChv () const
void | SetChv (const T_SI_CHV &chv)

Static Public Member Functions

static const Chv1DisableReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

Chv1DisableReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

Chv1DisableReqArg::Chv1DisableReqArg ( const CHAR * pin )

Chv1DisableReqArg::Chv1DisableReqArg ( const T_SI_CHV & chv )

Chv1DisableReqArg::Chv1DisableReqArg ( )

Member Function Documentation

const Chv1DisableReqArg & Chv1DisableReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_SI_CHV& Chv1DisableReqArg::GetChv ( ) const [inline]

void Chv1DisableReqArg::SetChv ( const T_SI_CHV & chv ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Chv1EnableIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Chv1EnableIndArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for Chv1EnableIndArg:

[legend]
Collaboration diagram for Chv1EnableIndArg:

[legend]

Public Types

enum | { ID = 1043 }

Public Member Functions

Chv1EnableIndArg ()
const ChvAttemptsStruct & | GetChvAttempts () const
const ChvStatus & | GetStatus () const
void | SetChvAttempts (const ChvAttemptsStruct &chv_attempts)
void | SetStatus (const ChvStatus &status)

Static Public Member Functions

static const Chv1EnableIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

Chv1EnableIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

Chv1EnableIndArg::Chv1EnableIndArg ( )

Member Function Documentation

const Chv1EnableIndArg & Chv1EnableIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvAttemptsStruct& Chv1EnableIndArg::GetChvAttempts ( ) const [inline]

const ChvStatus& Chv1EnableIndArg::GetStatus ( ) const [inline]

void Chv1EnableIndArg::SetChvAttempts ( const ChvAttemptsStruct & chv_attempts ) [inline]

void Chv1EnableIndArg::SetStatus ( const ChvStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Chv1EnableReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Chv1EnableReqArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for Chv1EnableReqArg:

[legend]
Collaboration diagram for Chv1EnableReqArg:

[legend]

Public Types

enum | { ID = 2043 }

Public Member Functions

Chv1EnableReqArg ()
Chv1EnableReqArg (const T_SI_CHV &chv)
Chv1EnableReqArg (const CHAR *pin)
const T_SI_CHV & | GetChv () const
void | SetChv (const T_SI_CHV &chv)

Static Public Member Functions

static const Chv1EnableReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

Chv1EnableReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

Chv1EnableReqArg::Chv1EnableReqArg ( const CHAR * pin )

Chv1EnableReqArg::Chv1EnableReqArg ( const T_SI_CHV & chv )

Chv1EnableReqArg::Chv1EnableReqArg ( )

Member Function Documentation

const Chv1EnableReqArg & Chv1EnableReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_SI_CHV& Chv1EnableReqArg::GetChv ( ) const [inline]

void Chv1EnableReqArg::SetChv ( const T_SI_CHV & chv ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvAttemptsStruct Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvAttemptsStruct Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

ChvAttempts chv1AttemptsLeft
ChvAttempts chv1UnblAttemptsLeft
ChvAttempts chv2AttemptsLeft
ChvAttempts chv2UnblAttemptsLeft

Field Documentation

ChvAttempts ChvAttemptsStruct::chv1AttemptsLeft

ChvAttempts ChvAttemptsStruct::chv1UnblAttemptsLeft

ChvAttempts ChvAttemptsStruct::chv2AttemptsLeft

ChvAttempts ChvAttemptsStruct::chv2UnblAttemptsLeft

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:06:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvChangedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ChvChangedMsg:

[legend]
Collaboration diagram for ChvChangedMsg:

[legend]

Public Types

enum | { ID = 18708 }

Public Member Functions

ChvChangedMsg (const ChvAction &chv_action, const ChvNo &chvno, const ChvStatus &status)
virtual Message * | Clone () const
const ChvAction & | GetChvAction () const
const ChvNo & | GetChvno () const
virtual const MsgMetaData & | GetMetaData () const
const ChvStatus & | GetStatus () const
void | SetChvAction (const ChvAction &chv_action)
void | SetChvno (const ChvNo &chvno)
void | SetStatus (const ChvStatus &status)
virtual | ~ChvChangedMsg ()

Detailed Description

ChvChangedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChvChangedMsg::ChvChangedMsg | ( | const ChvAction & | chv_action,
 |  | const ChvNo & | chvno,
 |  | const ChvStatus & | status
 | ) |

ChvChangedMsg::~ChvChangedMsg ( ) [virtual]

Member Function Documentation

Message * ChvChangedMsg::Clone ( ) const [virtual]

Implements Message.

const ChvAction& ChvChangedMsg::GetChvAction ( ) const [inline]

const ChvNo& ChvChangedMsg::GetChvno ( ) const [inline]

const MsgMetaData & ChvChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

const ChvStatus& ChvChangedMsg::GetStatus ( ) const [inline]

void ChvChangedMsg::SetChvAction ( const ChvAction & chv_action ) [inline]

void ChvChangedMsg::SetChvno ( const ChvNo & chvno ) [inline]

void ChvChangedMsg::SetStatus ( const ChvStatus & status ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:06:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvChangeIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvChangeIndArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for ChvChangeIndArg:

[legend]
Collaboration diagram for ChvChangeIndArg:

[legend]

Public Types

enum | { ID = 1041 }

Public Member Functions

ChvChangeIndArg ()
const ChvAttemptsStruct & | GetChvAttempts () const
const ChvNo & | GetChvno () const
const ChvStatus & | GetStatus () const
void | SetChvAttempts (const ChvAttemptsStruct &chv_attempts)
void | SetChvno (const ChvNo &chvno)
void | SetStatus (const ChvStatus &status)

Static Public Member Functions

static const ChvChangeIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChvChangeIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChvChangeIndArg::ChvChangeIndArg ( )

Member Function Documentation

const ChvChangeIndArg & ChvChangeIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvAttemptsStruct& ChvChangeIndArg::GetChvAttempts ( ) const [inline]

const ChvNo& ChvChangeIndArg::GetChvno ( ) const [inline]

const ChvStatus& ChvChangeIndArg::GetStatus ( ) const [inline]

void ChvChangeIndArg::SetChvAttempts ( const ChvAttemptsStruct & chv_attempts ) [inline]

void ChvChangeIndArg::SetChvno ( const ChvNo & chvno ) [inline]

void ChvChangeIndArg::SetStatus ( const ChvStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvChangeReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvChangeReqArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for ChvChangeReqArg:

[legend]
Collaboration diagram for ChvChangeReqArg:

[legend]

Public Types

enum | { ID = 2041 }

Public Member Functions

ChvChangeReqArg ()
ChvChangeReqArg (const ChvNo &chvno, const T_SI_CHV &oldchv, const T_SI_CHV &newchv)
ChvChangeReqArg (const ChvNo &chvno, const CHAR *oldpin, const CHAR *newpin)
const ChvNo & | GetChvno () const
const T_SI_CHV & | GetNewchv () const
const T_SI_CHV & | GetOldchv () const
void | SetChvno (const ChvNo &chvno)
void | SetNewchv (const T_SI_CHV &newchv)
void | SetOldchv (const T_SI_CHV &oldchv)

Static Public Member Functions

static const ChvChangeReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChvChangeReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChvChangeReqArg::ChvChangeReqArg | ( | const ChvNo & | chvno,
 |  | const CHAR * | oldpin,
 |  | const CHAR * | newpin
 | ) |

ChvChangeReqArg::ChvChangeReqArg | ( | const ChvNo & | chvno,
 |  | const T_SI_CHV & | oldchv,
 |  | const T_SI_CHV & | newchv
 | ) |

ChvChangeReqArg::ChvChangeReqArg ( )

Member Function Documentation

const ChvChangeReqArg & ChvChangeReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvNo& ChvChangeReqArg::GetChvno ( ) const [inline]

const T_SI_CHV& ChvChangeReqArg::GetNewchv ( ) const [inline]

const T_SI_CHV& ChvChangeReqArg::GetOldchv ( ) const [inline]

void ChvChangeReqArg::SetChvno ( const ChvNo & chvno ) [inline]

void ChvChangeReqArg::SetNewchv ( const T_SI_CHV & newchv ) [inline]

void ChvChangeReqArg::SetOldchv ( const T_SI_CHV & oldchv ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

ChvAttempts attempts_left
ChvNo no
ChvStatus status
ChvAttempts unblocking_attempts_left

Field Documentation

ChvAttempts ChvData::attempts_left

ChvNo ChvData::no

ChvStatus ChvData::status

ChvAttempts ChvData::unblocking_attempts_left

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:06:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvProvider Class Reference
[Provider]

#include <Apoxi/Adc/ChvProvider.hpp>

Inheritance diagram for ChvProvider:

[legend]
Collaboration diagram for ChvProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

ChvProvider ()
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
virtual Provider::Status | GetStatus () const
Returns the status of the provider.
void | Init (SimChvHandler *chv_handler, Protector *protector)
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~ChvProvider ()

Detailed Description

ChvProvider is the provider to retrieve different states of the different pins of the mobile station. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_chv_provider_id

Following column ids are defined: c_no_id :NumberType: c_state_id :NumberType: c_attempts_left_id :NumberType: c_unblocking_attempts_left_id:NumberType:

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider ChvProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

ChvProvider::ChvProvider ( )

ChvProvider::~ChvProvider ( ) [virtual]

Member Function Documentation

BOOLEAN ChvProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT ChvProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

Provider::Status ChvProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

void ChvProvider::Init | ( | SimChvHandler * | chv_handler,
 |  | Protector * | protector
 | ) |

INT ChvProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN ChvProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/ChvProvider.hpp
  • Adc/ChvProvider.cpp
Generated on Wed Jan 25 01:06:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvRefreshIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvRefreshIndArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for ChvRefreshIndArg:

[legend]
Collaboration diagram for ChvRefreshIndArg:

[legend]

Public Types

enum | { ID = 1045 }

Public Member Functions

ChvRefreshIndArg ()
const ChvAction & | GetChvAction () const
const ChvAttemptsStruct & | GetChvAttempts () const
const ChvNo & | GetChvno () const
const ChvStatus & | GetStatus () const
BOOLEAN | IsResult () const
void | SetChvAction (const ChvAction &chv_action)
void | SetChvAttempts (const ChvAttemptsStruct &chv_attempts)
void | SetChvno (const ChvNo &chvno)
void | SetResult (BOOLEAN result)
void | SetStatus (const ChvStatus &status)

Static Public Member Functions

static const ChvRefreshIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChvRefreshIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChvRefreshIndArg::ChvRefreshIndArg ( )

Member Function Documentation

const ChvRefreshIndArg & ChvRefreshIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvAction& ChvRefreshIndArg::GetChvAction ( ) const [inline]

const ChvAttemptsStruct& ChvRefreshIndArg::GetChvAttempts ( ) const [inline]

const ChvNo& ChvRefreshIndArg::GetChvno ( ) const [inline]

const ChvStatus& ChvRefreshIndArg::GetStatus ( ) const [inline]

BOOLEAN ChvRefreshIndArg::IsResult ( ) const [inline]

void ChvRefreshIndArg::SetChvAction ( const ChvAction & chv_action ) [inline]

void ChvRefreshIndArg::SetChvAttempts ( const ChvAttemptsStruct & chv_attempts ) [inline]

void ChvRefreshIndArg::SetChvno ( const ChvNo & chvno ) [inline]

void ChvRefreshIndArg::SetResult ( BOOLEAN result ) [inline]

void ChvRefreshIndArg::SetStatus ( const ChvStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvUnblockIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvUnblockIndArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for ChvUnblockIndArg:

[legend]
Collaboration diagram for ChvUnblockIndArg:

[legend]

Public Types

enum | { ID = 1042 }

Public Member Functions

ChvUnblockIndArg ()
const ChvAttemptsStruct & | GetChvAttempts () const
const ChvNo & | GetChvno () const
const ChvStatus & | GetStatus () const
void | SetChvAttempts (const ChvAttemptsStruct &chv_attempts)
void | SetChvno (const ChvNo &chvno)
void | SetStatus (const ChvStatus &status)

Static Public Member Functions

static const ChvUnblockIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChvUnblockIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChvUnblockIndArg::ChvUnblockIndArg ( )

Member Function Documentation

const ChvUnblockIndArg & ChvUnblockIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvAttemptsStruct& ChvUnblockIndArg::GetChvAttempts ( ) const [inline]

const ChvNo& ChvUnblockIndArg::GetChvno ( ) const [inline]

const ChvStatus& ChvUnblockIndArg::GetStatus ( ) const [inline]

void ChvUnblockIndArg::SetChvAttempts ( const ChvAttemptsStruct & chv_attempts ) [inline]

void ChvUnblockIndArg::SetChvno ( const ChvNo & chvno ) [inline]

void ChvUnblockIndArg::SetStatus ( const ChvStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvUnblockReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvUnblockReqArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for ChvUnblockReqArg:

[legend]
Collaboration diagram for ChvUnblockReqArg:

[legend]

Public Types

enum | { ID = 2042 }

Public Member Functions

ChvUnblockReqArg ()
ChvUnblockReqArg (const ChvNo &chvno, const T_SI_CHV &unblockchv, const T_SI_CHV &newchv)
ChvUnblockReqArg (const ChvNo &chvno, const CHAR *unblockpin, const CHAR *newpin)
const ChvNo & | GetChvno () const
const T_SI_CHV & | GetNewchv () const
const T_SI_CHV & | GetUnblockchv () const
void | SetChvno (const ChvNo &chvno)
void | SetNewchv (const T_SI_CHV &newchv)
void | SetUnblockchv (const T_SI_CHV &unblockchv)

Static Public Member Functions

static const ChvUnblockReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChvUnblockReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChvUnblockReqArg::ChvUnblockReqArg | ( | const ChvNo & | chvno,
 |  | const CHAR * | unblockpin,
 |  | const CHAR * | newpin
 | ) |

ChvUnblockReqArg::ChvUnblockReqArg | ( | const ChvNo & | chvno,
 |  | const T_SI_CHV & | unblockchv,
 |  | const T_SI_CHV & | newchv
 | ) |

ChvUnblockReqArg::ChvUnblockReqArg ( )

Member Function Documentation

const ChvUnblockReqArg & ChvUnblockReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvNo& ChvUnblockReqArg::GetChvno ( ) const [inline]

const T_SI_CHV& ChvUnblockReqArg::GetNewchv ( ) const [inline]

const T_SI_CHV& ChvUnblockReqArg::GetUnblockchv ( ) const [inline]

void ChvUnblockReqArg::SetChvno ( const ChvNo & chvno ) [inline]

void ChvUnblockReqArg::SetNewchv ( const T_SI_CHV & newchv ) [inline]

void ChvUnblockReqArg::SetUnblockchv ( const T_SI_CHV & unblockchv ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvVerifyIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvVerifyIndArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for ChvVerifyIndArg:

[legend]
Collaboration diagram for ChvVerifyIndArg:

[legend]

Public Types

enum | { ID = 1040 }

Public Member Functions

ChvVerifyIndArg ()
const ChvAttemptsStruct & | GetChvAttempts () const
const ChvNo & | GetChvno () const
const ChvStatus & | GetStatus () const
void | SetChvAttempts (const ChvAttemptsStruct &chv_attempts)
void | SetChvno (const ChvNo &chvno)
void | SetStatus (const ChvStatus &status)

Static Public Member Functions

static const ChvVerifyIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChvVerifyIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChvVerifyIndArg::ChvVerifyIndArg ( )

Member Function Documentation

const ChvVerifyIndArg & ChvVerifyIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvAttemptsStruct& ChvVerifyIndArg::GetChvAttempts ( ) const [inline]

const ChvNo& ChvVerifyIndArg::GetChvno ( ) const [inline]

const ChvStatus& ChvVerifyIndArg::GetStatus ( ) const [inline]

void ChvVerifyIndArg::SetChvAttempts ( const ChvAttemptsStruct & chv_attempts ) [inline]

void ChvVerifyIndArg::SetChvno ( const ChvNo & chvno ) [inline]

void ChvVerifyIndArg::SetStatus ( const ChvStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ChvVerifyReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ChvVerifyReqArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for ChvVerifyReqArg:

[legend]
Collaboration diagram for ChvVerifyReqArg:

[legend]

Public Types

enum | { ID = 2040 }

Public Member Functions

ChvVerifyReqArg ()
ChvVerifyReqArg (const ChvNo &chvno, const T_SI_CHV &chv)
ChvVerifyReqArg (const ChvNo &chvno, const CHAR *pin)
const T_SI_CHV & | GetChv () const
const ChvNo & | GetChvno () const
void | SetChv (const T_SI_CHV &chv)
void | SetChvno (const ChvNo &chvno)

Static Public Member Functions

static const ChvVerifyReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ChvVerifyReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ChvVerifyReqArg::ChvVerifyReqArg | ( | const ChvNo & | chvno,
 |  | const CHAR * | pin
 | ) |

ChvVerifyReqArg::ChvVerifyReqArg | ( | const ChvNo & | chvno,
 |  | const T_SI_CHV & | chv
 | ) |

ChvVerifyReqArg::ChvVerifyReqArg ( )

Member Function Documentation

const ChvVerifyReqArg & ChvVerifyReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_SI_CHV& ChvVerifyReqArg::GetChv ( ) const [inline]

const ChvNo& ChvVerifyReqArg::GetChvno ( ) const [inline]

void ChvVerifyReqArg::SetChv ( const T_SI_CHV & chv ) [inline]

void ChvVerifyReqArg::SetChvno ( const ChvNo & chvno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CiTestParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CiTestParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

CiTestParam ()
BOOLEAN | IsNoBlocksInvalid ()
BOOLEAN | IsSumCOverIInvalid ()
CiTestParam | operator= (T_CI_TESTPARAM ci_testparam)

Data Fields

UINT8 | no_blocks
INT | sum_c_over_i

Constructor & Destructor Documentation

CiTestParam::CiTestParam ( ) [inline]

Member Function Documentation

BOOLEAN CiTestParam::IsNoBlocksInvalid ( ) [inline]

BOOLEAN CiTestParam::IsSumCOverIInvalid ( ) [inline]

CiTestParam CiTestParam::operator= ( T_CI_TESTPARAM ci_testparam )

Field Documentation

UINT8 CiTestParam::no_blocks

INT CiTestParam::sum_c_over_i

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:06:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CiTestParamList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CiTestParamList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for CiTestParamList:

[legend]

Public Types

enum | { LengthOfCiTestparamArray = TESTPARAM_CI_CS_COUNT }

Public Member Functions

BOOLEAN | IsEmpty ()
CiTestParamList | operator= (T_CI_TESTPARAM_LIST ci_testparam_list)
CiTestParam & | operator[] (INT index)

Data Fields

CiTestParam | ci_testparam_array [LengthOfCiTestparamArray]
INT | length

Member Enumeration Documentation

anonymous enum

Enumerator:
LengthOfCiTestparamArray

Member Function Documentation

BOOLEAN CiTestParamList::IsEmpty ( )

CiTestParamList CiTestParamList::operator= ( T_CI_TESTPARAM_LIST ci_testparam_list )

CiTestParam & CiTestParamList::operator[] ( INT index )

Field Documentation

CiTestParam CiTestParamList::ci_testparam_array[LengthOfCiTestparamArray]

INT CiTestParamList::length

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:06:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClearBlackListCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClearBlackListCnfArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for ClearBlackListCnfArg:

[legend]
Collaboration diagram for ClearBlackListCnfArg:

[legend]

Public Types

enum | { ID = 1148 }

Public Member Functions

ClearBlackListCnfArg ()

Static Public Member Functions

static const ClearBlackListCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ClearBlackListCnfArg: reflects the signal MNMI_CLEAR_BLACKLIST_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ClearBlackListCnfArg::ClearBlackListCnfArg ( )

Member Function Documentation

const ClearBlackListCnfArg & ClearBlackListCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClearBlacklistReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClearBlacklistReqArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for ClearBlacklistReqArg:

[legend]
Collaboration diagram for ClearBlacklistReqArg:

[legend]

Public Types

enum | { ID = 2143 }

Public Member Functions

ClearBlacklistReqArg ()

Static Public Member Functions

static const ClearBlacklistReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ClearBlacklistReqArg: reflects arguments of signal MNMI_CLEAR_BLACKLIST_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ClearBlacklistReqArg::ClearBlacklistReqArg ( )

Member Function Documentation

const ClearBlacklistReqArg & ClearBlacklistReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClientDc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClientDc Class Reference
[GUI]

#include <Apoxi/Gui/ClientDc.hpp>

Inheritance diagram for ClientDc:

[legend]
Collaboration diagram for ClientDc:

[legend]

Public Member Functions

virtual void AdjustBoundingRect ()
ClientDc (VirtualDisplay *display)
ClientDc (Control *control)
ClientDc ()

Detailed Description

Device context for the client area of a control. It is recommended that application developers use more comfortable class PaintDc for drawing the client area.

Constructor & Destructor Documentation

ClientDc::ClientDc ( )

ClientDc::ClientDc ( Control * control )

ClientDc::ClientDc ( VirtualDisplay * display )

Member Function Documentation

void ClientDc::AdjustBoundingRect ( ) [virtual]

See also:
DeviceContext::AdjustBoundingRect()

Reimplemented from DeviceContext.

The documentation for this class was generated from the following files:
  • Gui/ClientDc.hpp
  • Gui/ClientDc.cpp
Generated on Wed Jan 25 01:06:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClientDeregistrationArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClientDeregistrationArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for ClientDeregistrationArg:

[legend]
Collaboration diagram for ClientDeregistrationArg:

[legend]

Public Types

enum | { ID = 2243 }

Public Member Functions

ClientDeregistrationArg (const Client &client=MmiClient)
const Client & | GetClient () const
void | SetClient (const Client &client)

Static Public Member Functions

static const ClientDeregistrationArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ClientDeregistrationArg: reflects arguments of signal MN_SENDER_DEREGISTRATION_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ClientDeregistrationArg::ClientDeregistrationArg ( const Client & client = MmiClient )

Member Function Documentation

const ClientDeregistrationArg & ClientDeregistrationArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Client& ClientDeregistrationArg::GetClient ( ) const [inline]

void ClientDeregistrationArg::SetClient ( const Client & client ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClientId Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClientId Struct Reference

Stores the Client Id information. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Public Types

enum | { MAX_SIZE = 23 }
Maximum size of Client-Id in bytes. More...

Public Member Functions

ClientId ()
Constructor.
void | ConvertToStr (String &client_id_str) const
BOOLEAN | IsValid ()

Data Fields

BYTE | m_client_id [MAX_SIZE]
Client-Id coded in BCD format.

Detailed Description

Stores the Client Id information.

Member Enumeration Documentation

anonymous enum

Maximum size of Client-Id in bytes.

Enumerator:
MAX_SIZE

Constructor & Destructor Documentation

ClientId::ClientId ( ) [inline]

Constructor.

Member Function Documentation

void ClientId::ConvertToStr ( String & client_id_str ) const [inline]

This method decodes the Client Id name in BCD format and converts it into string format

BOOLEAN ClientId::IsValid ( ) [inline]

Field Documentation

BYTE ClientId::m_client_id[MAX_SIZE]

Client-Id coded in BCD format.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:06:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClientInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClientInfo Struct Reference

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for ClientInfo:

[legend]

Public Member Functions

ClientInfo (const ClientId &client_id, const ClientName &client_name)
Argument constructor.
ClientInfo ()
Default constructor.

Data Fields

ClientId m_client_id
Client Id of the end-point which requested location.
ClientName m_client_name
Client name of the end-point which requested location.

Detailed Description

Stores the client information i.e. client Id, client-name and DCS (Data Coding Scheme). It is used in case of MT-LR.

Constructor & Destructor Documentation

ClientInfo::ClientInfo ( ) [inline]

Default constructor.

ClientInfo::ClientInfo | ( | const ClientId & | client_id,
 |  | const ClientName & | client_name
 | ) | [inline]

Argument constructor.

Field Documentation

ClientId ClientInfo::m_client_id

Client Id of the end-point which requested location.

ClientName ClientInfo::m_client_name

Client name of the end-point which requested location.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:06:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClientName Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClientName Struct Reference

Stores the client name. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for ClientName:

[legend]

Public Types

enum { MAX_SIZE = 63 }
Obsolete: Maximum size of client name in bytes. More...

Public Member Functions

ClientName (const BYTE *client_name, Dcs dcs)
Argument constructor.
ClientName ()
Constructor.

Data Fields

String m_client_name
Client name in human-readable format.

Detailed Description

Stores the client name.

Member Enumeration Documentation

anonymous enum

Obsolete: Maximum size of client name in bytes.

Enumerator:
MAX_SIZE

Constructor & Destructor Documentation

ClientName::ClientName ( ) [inline]

Constructor.

ClientName::ClientName | ( | const BYTE * | client_name,
 |  | Dcs | dcs
 | ) | [inline]

Argument constructor.

Field Documentation

String ClientName::m_client_name

Client name in human-readable format.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:06:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClientNetAdapter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClientNetAdapter Class Reference

#include <Apoxi/Socket/NetAdapterHandler.hpp>

Inheritance diagram for ClientNetAdapter:

[legend]
Collaboration diagram for ClientNetAdapter:

[legend]

Public Member Functions

ClientNetAdapter (NetAdapterHandler *handler, NetAdapter::Id id, NetAdapter::Type type)
virtual SocketError | GetError () const =0
virtual INT | GetInBufByteCount ()=0
void | HandleOnAsyncEvent (InetSocket::Event event)
virtual INT | Read (void *buf, INT buflen, InetSocketAddr *from=0)=0
virtual BOOLEAN | Send (const UINT8 *data, UINT32 len, InetSocketAddr *to=0)
virtual INT | Write (const void *buf, INT buflen, InetSocketAddr *to=0)=0
virtual | ~ClientNetAdapter ()

Protected Attributes

UINT32 | m_data_sent
UINT8 * | m_recv_buffer
UINT8 * | m_send_buffer
UINT32 | m_send_buffer_offset
UINT32 | m_send_buffer_size
Semaphore m_send_sem

Constructor & Destructor Documentation

ClientNetAdapter::ClientNetAdapter | ( | NetAdapterHandler * | handler,
 |  | NetAdapter::Id | id,
 |  | NetAdapter::Type | type
 | ) |

ClientNetAdapter::~ClientNetAdapter ( ) [virtual]

Member Function Documentation

virtual SocketError ClientNetAdapter::GetError ( ) const [pure virtual]

Implemented in UdpNetAdapter, and TcpNetAdapter.

virtual INT ClientNetAdapter::GetInBufByteCount ( ) [pure virtual]

Implemented in UdpNetAdapter, and TcpNetAdapter.

void ClientNetAdapter::HandleOnAsyncEvent ( InetSocket::Event event )

virtual INT ClientNetAdapter::Read | ( | void * | buf,
 |  | INT | buflen,
 |  | InetSocketAddr * | from = 0
 | ) | [pure virtual]

Implemented in UdpNetAdapter, and TcpNetAdapter.

BOOLEAN ClientNetAdapter::Send | ( | const UINT8 * | data,
 |  | UINT32 | len,
 |  | InetSocketAddr * | to = 0
 | ) | [virtual]

virtual INT ClientNetAdapter::Write | ( | const void * | buf,
 |  | INT | buflen,
 |  | InetSocketAddr * | to = 0
 | ) | [pure virtual]

Implemented in UdpNetAdapter, and TcpNetAdapter.

Field Documentation

UINT32 ClientNetAdapter::m_data_sent [protected]

UINT8* ClientNetAdapter::m_recv_buffer [protected]

Necessary receive buffer members.

UINT8* ClientNetAdapter::m_send_buffer [protected]

Necessary send buffer members.

UINT32 ClientNetAdapter::m_send_buffer_offset [protected]

UINT32 ClientNetAdapter::m_send_buffer_size [protected]

Semaphore ClientNetAdapter::m_send_sem [protected]

Semaphore used for protecting the send buffer.

The documentation for this class was generated from the following files:
  • Socket/NetAdapterHandler.hpp
  • Socket/NetAdapterHandler.cpp
Generated on Wed Jan 25 01:06:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClientRegistrationArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClientRegistrationArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for ClientRegistrationArg:

[legend]
Collaboration diagram for ClientRegistrationArg:

[legend]

Public Types

enum | { ID = 2242 }

Public Member Functions

ClientRegistrationArg (const Client &client=MmiClient)
const Client & | GetClient () const
void | SetClient (const Client &client)

Static Public Member Functions

static const ClientRegistrationArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ClientRegistrationArg: reflects arguments of signal MN_SENDER_REGISTRATION_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ClientRegistrationArg::ClientRegistrationArg ( const Client & client = MmiClient )

Member Function Documentation

const ClientRegistrationArg & ClientRegistrationArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Client& ClientRegistrationArg::GetClient ( ) const [inline]

void ClientRegistrationArg::SetClient ( const Client & client ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 01:06:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClipAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClipAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for ClipAction:

[legend]
Collaboration diagram for ClipAction:

[legend]

Public Member Functions

virtual InputActionType | GetActionType () const
Returns the type of the action.

Protected Member Functions

virtual InputParser::SsCode | GetSsCode () const

Detailed Description

ClipAction analyzes if the input string has the meaning of interrogation of CLIP. Execute has to be overwritten to implement the sending of the SS string.

Member Function Documentation

InputActionType ClipAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

InputParser::SsCode ClipAction::GetSsCode ( ) const [protected, virtual]

Implements NumberIdentificationAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:06:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClipHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClipHandler Class Reference

#include <Apoxi/Asc/ClipHandler.hpp>

Public Types

enum | { ID = ClipHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
SsApiRc | RequestStatus (const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE)

Protected Member Functions

virtual ReturnCode | CreateInterrogateResultMsg (const SsInterrogateIndArg &arg, SsMessage *&msg) const

Detailed Description

The ClipHandler is a SS handler responsible for interrogating the Calling Line Identification Presentation SS. The class provides methods to query to current CLIP status and to convert the stack-message-arguments into Apoxi-messages. It relies heavily on methods provided by its superclass.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Member Function Documentation

SsBaseHandler::ReturnCode ClipHandler::CreateInterrogateResultMsg | ( | const SsInterrogateIndArg & | arg,
 |  | SsMessage *& | msg
 | ) | const [protected, virtual]

Creates a specific Apoxi-message based on the given argument. The message is statically created, cloned and the pointer parameter set to the clone.

Parameters:
arg | The argument which contains the data and needs to be parsed.
msg | A reference to a message-pointer which will be set to the new message.
Returns:
OkNoMessage

HandlerId ClipHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
ClipHandlerId

SsApiRc ClipHandler::RequestStatus | ( | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE
 | ) |

Interrogates the CLIP status. This method triggers sending of *#30# to the mobile network. The actual function is delegated to the Interrogate method of the super class.

Parameters:
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Success - if the mobile network accepted the supplementary service request,
SupplementaryServicePending - if another supplementary service is currently pending,
SupplementaryServiceDenied - if the supplementary service request was rejected by the mobile network,
NormalServiceRequired - if the network service state is invalid.
See also:
SsClHandler

The documentation for this class was generated from the following files:
  • Asc/ClipHandler.hpp
  • Asc/ClipHandler.cpp
Generated on Wed Jan 25 01:06:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClipStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClipStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ClipStatusMsg:

[legend]
Collaboration diagram for ClipStatusMsg:

[legend]

Public Types

enum | { ID = 18545 }

Public Member Functions

ClipStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~ClipStatusMsg ()

Detailed Description

ClipStatusMsg: sent when clip status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ClipStatusMsg::ClipStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status
 | ) |

ClipStatusMsg::~ClipStatusMsg ( ) [virtual]

Member Function Documentation

Message * ClipStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & ClipStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsStatus& ClipStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& ClipStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:06:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClirAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClirAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for ClirAction:

[legend]
Collaboration diagram for ClirAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
ClirAction ()
virtual InputActionType | GetActionType () const
Returns the type of the action.
const PhoneNumber & | GetClirPhoneNumber () const
Returns the phonenumber in the case of activation or decativation.
InputParser::SsProcedure | GetSsProcedure () const
Returns the procedure type.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual | ~ClirAction ()

Detailed Description

ClirAction analyzes if the input string has the meaning of activation, deactivation or interrogation of CLIR. Execute has to be overwritten to implement the sending of the SS string.

Constructor & Destructor Documentation

ClirAction::ClirAction ( )

ClirAction::~ClirAction ( ) [virtual]

Member Function Documentation

InputAction * ClirAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType ClirAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

const PhoneNumber& ClirAction::GetClirPhoneNumber ( ) const [inline]

Returns the phonenumber in the case of activation or decativation.

InputParser::SsProcedure ClirAction::GetSsProcedure ( ) const [inline]

Returns the procedure type.

BOOLEAN ClirAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:06:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CliRestrictionInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CliRestrictionInfo Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for CliRestrictionInfo:

[legend]

Data Fields

EmlppPriority default_priority
EmlppPriority max_entitled_priority
CliRestrictionOption option
SsStatus ss_status

Field Documentation

EmlppPriority CliRestrictionInfo::default_priority

EmlppPriority CliRestrictionInfo::max_entitled_priority

CliRestrictionOption CliRestrictionInfo::option

SsStatus CliRestrictionInfo::ss_status

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:06:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClirHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClirHandler Class Reference

#include <Apoxi/Asc/ClirHandler.hpp>

Public Types

enum | { ID = ClirHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
SsApiRc | RequestStatus (const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE)

Protected Member Functions

virtual BOOLEAN | CheckSelector (const SsInterrogateIndArg &arg) const
virtual ReturnCode | CreateInterrogateResultMsg (const SsInterrogateIndArg &arg, SsMessage *&msg) const

Detailed Description

The ClirHandler is a SS handler responsible for interrogating the Calling Line Identification Restriction SS. The class provides methods to query to current CLIR status and to convert the stack-message-arguments into Apoxi-messages. It relies heavily on methods provided by its superclass.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Member Function Documentation

BOOLEAN ClirHandler::CheckSelector ( const SsInterrogateIndArg & arg ) const [protected, virtual]

Checks the selector of the specified argument.

Returns:
true - if the selector contained in the argument equals SsCliRestrictInfoInterrogate.
Parameters:
arg The argument which selector should be checked.

SsBaseHandler::ReturnCode ClirHandler::CreateInterrogateResultMsg | ( | const SsInterrogateIndArg & | arg,
 |  | SsMessage *& | msg
 | ) | const [protected, virtual]

Creates a specific Apoxi-message based on the given argument. The message is statically created, cloned and the pointer parameter set to the clone.

Parameters:
arg | The argument which contains the data and needs to be parsed.
msg | A reference to a message-pointer which will be set to the new message.
Returns:
OkNoMessage

HandlerId ClirHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
ClirHandlerId

SsApiRc ClirHandler::RequestStatus | ( | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE
 | ) |

Interrogates the CLIR status. This method triggers sending of *#31# to the mobile network. The actual function is delegated to the Interrogate method of the super class.

Parameters:
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Success - if the mobile network accepted the supplementary service request,
SupplementaryServicePending - if another supplementary service is currently pending,
SupplementaryServiceDenied - if the supplementary service request was rejected by the mobile network,
NormalServiceRequired - if the network service state is invalid.
See also:
SsClHandler

The documentation for this class was generated from the following files:
  • Asc/ClirHandler.hpp
  • Asc/ClirHandler.cpp
Generated on Wed Jan 25 01:06:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClirNotSurpressedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClirNotSurpressedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ClirNotSurpressedMsg:

[legend]
Collaboration diagram for ClirNotSurpressedMsg:

[legend]

Public Types

enum | { ID = 18524 }

Public Member Functions

ClirNotSurpressedMsg (ExecutionContext *context, const Tipd &tipd)
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
virtual | ~ClirNotSurpressedMsg ()

Detailed Description

ClirNotSurpressedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ClirNotSurpressedMsg::ClirNotSurpressedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd
 | ) |

ClirNotSurpressedMsg::~ClirNotSurpressedMsg ( ) [virtual]

Member Function Documentation

Message * ClirNotSurpressedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & ClirNotSurpressedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& ClirNotSurpressedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:06:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ClirStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ClirStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ClirStatusMsg:

[legend]
Collaboration diagram for ClirStatusMsg:

[legend]

Public Types

enum | { ID = 18548 }

Public Member Functions

ClirStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status, const CliRestrictionOption &cli_restriction_option)
virtual Message * | Clone () const
const CliRestrictionOption & | GetCliRestrictionOption () const
virtual const MsgMetaData & | GetMetaData () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~ClirStatusMsg ()

Detailed Description

ClirStatusMsg: sent when clir status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ClirStatusMsg::ClirStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status,
 |  | const CliRestrictionOption & | cli_restriction_option
 | ) |

ClirStatusMsg::~ClirStatusMsg ( ) [virtual]

Member Function Documentation

Message * ClirStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const CliRestrictionOption& ClirStatusMsg::GetCliRestrictionOption ( ) const [inline]

const MsgMetaData & ClirStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsStatus& ClirStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& ClirStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:06:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CloseAllMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CloseAllMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for CloseAllMsg:

[legend]
Collaboration diagram for CloseAllMsg:

[legend]

Public Types

enum | { ID = 13001 }

Public Member Functions

virtual Message * | Clone () const
CloseAllMsg (const AtlConfig::BeforeClosingAction &action=AtlConfig::DoNothing)
const AtlConfig::BeforeClosingAction & | GetAction () const
virtual const MsgMetaData & | GetMetaData () const
void | SetAction (const AtlConfig::BeforeClosingAction &action)
virtual | ~CloseAllMsg ()

Detailed Description

CloseAll

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CloseAllMsg::CloseAllMsg ( const AtlConfig::BeforeClosingAction & action = AtlConfig::DoNothing )

CloseAllMsg::~CloseAllMsg ( ) [virtual]

Member Function Documentation

Message * CloseAllMsg::Clone ( ) const [virtual]

Implements Message.

const AtlConfig::BeforeClosingAction& CloseAllMsg::GetAction ( ) const [inline]

const MsgMetaData & CloseAllMsg::GetMetaData ( ) const [virtual]

Implements Message.

void CloseAllMsg::SetAction ( const AtlConfig::BeforeClosingAction & action ) [inline]

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 01:06:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CloseDataConnMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CloseDataConnMsg Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpMsgTypes.hpp>

Inheritance diagram for CloseDataConnMsg:

[legend]
Collaboration diagram for CloseDataConnMsg:

[legend]

Public Types

enum | { ID = 4233 }

Public Member Functions

virtual Message * | Clone () const
CloseDataConnMsg (ExecutionContext *context)
virtual const MsgMetaData & | GetMetaData () const
virtual | ~CloseDataConnMsg ()

Detailed Description

This message sends a request to the GLTP connection application for closing the socket connection

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CloseDataConnMsg::CloseDataConnMsg ( ExecutionContext * context )

CloseDataConnMsg::~CloseDataConnMsg ( ) [virtual]

Member Function Documentation

Message * CloseDataConnMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & CloseDataConnMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpMsgTypes.hpp
  • AddOns/Lcs/GLTP/GltpMsgTypes.cpp
Generated on Wed Jan 25 01:06:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CloseWindowAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CloseWindowAction Class Reference
[Items]

#include <Apoxi/Gui/CloseWindowAction.hpp>

Inheritance diagram for CloseWindowAction:

[legend]
Collaboration diagram for CloseWindowAction:

[legend]

Public Member Functions

CloseWindowAction (Window *win, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
Obsolete - use constructor with a dispatcher as input-parameter instead.
CloseWindowAction (Dispatcher *dispatcher, Window *win, const WString &text, const ImageObtainer &icon=ImageObtainer())
CloseWindowAction ()
virtual BOOLEAN | Execute ()
void | Init (Window *win, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
Obsolete - use a Init with a dispatcher as input-parameter instead.
void | Init (Dispatcher *dispatcher, Window *win, const WString &text, const ImageObtainer &icon=ImageObtainer())
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
void | SetWindow (Window *win)
virtual | ~CloseWindowAction ()

Detailed Description

Closes a window, when the action is executed.

Constructor & Destructor Documentation

CloseWindowAction::CloseWindowAction ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

CloseWindowAction::CloseWindowAction | ( | Dispatcher * | dispatcher,
 |  | Window * | win,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon = ImageObtainer()
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
win | Pointer to the window, which should be closed.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.

CloseWindowAction::~CloseWindowAction ( ) [virtual]

CloseWindowAction::CloseWindowAction | ( | Window * | win,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Obsolete - use constructor with a dispatcher as input-parameter instead.

Member Function Documentation

BOOLEAN CloseWindowAction::Execute ( ) [virtual]

Closes the window, which was set with the constructor or the method Init.

Reimplemented from Action.

void CloseWindowAction::Init | ( | Window * | win,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Obsolete - use a Init with a dispatcher as input-parameter instead.

void CloseWindowAction::Init | ( | Dispatcher * | dispatcher,
 |  | Window * | win,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon = ImageObtainer()
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
win | Pointer to the window, which should be closed.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.

BOOLEAN CloseWindowAction::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Action.

void CloseWindowAction::SetWindow ( Window * win ) [inline]

The documentation for this class was generated from the following files:
  • Gui/CloseWindowAction.hpp
  • Gui/CloseWindowAction.cpp
Generated on Wed Jan 25 01:06:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CloseWindowMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CloseWindowMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for CloseWindowMsg:

[legend]
Collaboration diagram for CloseWindowMsg:

[legend]

Public Types

enum | { ID = 1124 }

Public Member Functions

virtual Message * | Clone () const
CloseWindowMsg (Window *window, INT exit_code=0)
INT | GetExitCode () const
virtual const MsgMetaData & | GetMetaData () const
Window * | GetWindow () const
virtual | ~CloseWindowMsg ()

Detailed Description

This message is sent when a window is closed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CloseWindowMsg::CloseWindowMsg | ( | Window * | window,
 |  | INT | exit_code = 0
 | ) |

CloseWindowMsg::~CloseWindowMsg ( ) [virtual]

Member Function Documentation

Message * CloseWindowMsg::Clone ( ) const [virtual]

Implements Message.

INT CloseWindowMsg::GetExitCode ( ) const [inline]

const MsgMetaData & CloseWindowMsg::GetMetaData ( ) const [virtual]

Implements Message.

Window* CloseWindowMsg::GetWindow ( ) const [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:06:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CmiProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CmiProvider Class Reference
[Provider]

#include <Apoxi/Adc/CmiProvider.hpp>

Inheritance diagram for CmiProvider:

[legend]
Collaboration diagram for CmiProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

CmiProvider ()
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
virtual Provider::Status | GetStatus () const
Returns the status of the provider.
void | Init (SimAuxHandler *chv_handler, Protector *protector)
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~CmiProvider ()

Detailed Description

CmiProvider is the provider to retrieve the CMI parameters set in the EF-CMI file. Please refer to the GSM specification 11.11 chapter 10.5.13 and 10.5.16.

An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_cmi_provider_id

Following column ids are defined: c_cmi_alpha_id :WStringType: Alpha identifier of the CMI record c_cmi_id :NumberType: Comparison Method Identifier -> cast to (UINT8)

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider CmiProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

CmiProvider::CmiProvider ( )

CmiProvider::~CmiProvider ( ) [virtual]

Member Function Documentation

BOOLEAN CmiProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT CmiProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

Provider::Status CmiProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

void CmiProvider::Init | ( | SimAuxHandler * | chv_handler,
 |  | Protector * | protector
 | ) |

INT CmiProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN CmiProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/CmiProvider.hpp
  • Adc/CmiProvider.cpp
Generated on Wed Jan 25 01:06:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CmiRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CmiRecord Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 | alphaid [c_max_cmi_alpha_id_size]
INT | alphaidlength
UINT8 | cmi

Field Documentation

UINT8 CmiRecord::alphaid[c_max_cmi_alpha_id_size]

INT CmiRecord::alphaidlength

UINT8 CmiRecord::cmi

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:06:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CnapAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CnapAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for CnapAction:

[legend]
Collaboration diagram for CnapAction:

[legend]

Public Member Functions

virtual InputActionType | GetActionType () const
Returns the type of the action.

Protected Member Functions

virtual InputParser::SsCode | GetSsCode () const

Detailed Description

CnapAction analyzes if the input string has the meaning of interrogation of CNAP. Execute has to be overwritten to implement the sending of the SS string.

Member Function Documentation

InputActionType CnapAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

InputParser::SsCode CnapAction::GetSsCode ( ) const [protected, virtual]

Implements NumberIdentificationAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:06:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CnapHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CnapHandler Class Reference

#include <Apoxi/Asc/CnapHandler.hpp>

Public Types

enum | { ID = CnapHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
SsApiRc | RequestStatus (const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE)

Protected Member Functions

virtual ReturnCode | CreateInterrogateResultMsg (const SsInterrogateIndArg &arg, SsMessage *&msg) const

Detailed Description

The CnapHandler is a SS handler responsible for interrogating the Calling Line Identification Presentation SS. The class provides amethods to query to current CLIP status and to convert the stack-message-arguments into Apoxi-messages. It relies heavily on methods provided by its superclass.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Member Function Documentation

SsBaseHandler::ReturnCode CnapHandler::CreateInterrogateResultMsg | ( | const SsInterrogateIndArg & | arg,
 |  | SsMessage *& | msg
 | ) | const [protected, virtual]

Creates a specific Apoxi-message based on the given argument. The message is statically created, cloned and the pointer parameter set to the clone.

Parameters:
arg | The argument which contains the data and needs to be parsed.
msg | A reference to a message-pointer which will be set to the new message.
Returns:
OkNoMessage

HandlerId CnapHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
CnapHandlerId

SsApiRc CnapHandler::RequestStatus | ( | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE
 | ) |

Interrogates the CLIP status. This method triggers sending of *#30# to the mobile network. The actual function is delegated to the Interrogate method of the super class.

Parameters:
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Success - if the mobile network accepted the supplementary service request,
SupplementaryServicePending - if another supplementary service is currently pending,
SupplementaryServiceDenied - if the supplementary service request was rejected by the mobile network,
NormalServiceRequired - if the network service state is invalid.
See also:
SsClHandler

The documentation for this class was generated from the following files:
  • Asc/CnapHandler.hpp
  • Asc/CnapHandler.cpp
Generated on Wed Jan 25 01:06:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CnapInfoReceivedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CnapInfoReceivedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CnapInfoReceivedMsg:

[legend]
Collaboration diagram for CnapInfoReceivedMsg:

[legend]

Public Types

enum | { ID = 18564 }

Public Member Functions

virtual Message * | Clone () const
CnapInfoReceivedMsg (ExecutionContext *context, const Tipd &tipd, const WString &cnap_name, const CnameChoice &presentation_indicator, const DataCodingScheme &data_coding_scheme)
const WString & | GetCnapName () const
const DataCodingScheme & | GetDataCodingScheme () const
virtual const MsgMetaData & | GetMetaData () const
const CnameChoice & | GetPresentationIndicator () const
const Tipd & | GetTipd () const
virtual | ~CnapInfoReceivedMsg ()

Detailed Description

CnapInfoReceivedMsg: sent when CNAP information has been received for an incoming call

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CnapInfoReceivedMsg::CnapInfoReceivedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const WString & | cnap_name,
 |  | const CnameChoice & | presentation_indicator,
 |  | const DataCodingScheme & | data_coding_scheme
 | ) |

CnapInfoReceivedMsg::~CnapInfoReceivedMsg ( ) [virtual]

Member Function Documentation

Message * CnapInfoReceivedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const WString& CnapInfoReceivedMsg::GetCnapName ( ) const [inline]

const DataCodingScheme& CnapInfoReceivedMsg::GetDataCodingScheme ( ) const [inline]

const MsgMetaData & CnapInfoReceivedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const CnameChoice& CnapInfoReceivedMsg::GetPresentationIndicator ( ) const [inline]

const Tipd& CnapInfoReceivedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:06:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CnapStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CnapStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CnapStatusMsg:

[legend]
Collaboration diagram for CnapStatusMsg:

[legend]

Public Types

enum | { ID = 18563 }

Public Member Functions

virtual Message * | Clone () const
CnapStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status)
virtual const MsgMetaData & | GetMetaData () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~CnapStatusMsg ()

Detailed Description

CnapStatusMsg: sent when colr status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CnapStatusMsg::CnapStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status
 | ) |

CnapStatusMsg::~CnapStatusMsg ( ) [virtual]

Member Function Documentation

Message * CnapStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & CnapStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsStatus& CnapStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& CnapStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:06:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CodecDevice Class Reference
[CodecManager]

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Inheritance diagram for CodecDevice:

[legend]

Public Types

enum | AacFormat { AacFormatAdts = 0, AacFormatAdif, AacFormatRaw, AacFormatEnd }
enum | AmrDtxConfig { AmrDtxOff = 0, AmrDtxOn, AmrDtxEnd }
enum AmrIfFormat {
AmrFrameFormatUndefined = 0, AmrFrameFormatConformance, AmrFrameFormatIf1, AmrFrameFormatIf2,
AmrFrameFormatMime, AmrFrameFormatEnd
}
enum | ApplicationCategoriesFlagsType { StorageAppCatFlag = 0x1, StreamingAppCatFlag = 0x2, TelephonyAppCatFlag = 0x4, GreatestValueOfApplicationCategoriesFlagsType = TelephonyAppCatFlag }
typedef INT32 | AudioChannelId
typedef void(* | CbResult )(ResultType result, void *context)
typedef void(* | CbResultAndTimeInfo )(ResultType result, void *context, UINT32 time_ms)
enum CodecType {
DefaultCodec = 0, UnknownCodec, Mpeg4Sp, H263Bl,
GsmAmrNb, Mpeg4Aac, Qcelp, Evrc,
Mp3, Mpeg4AacPlusV1, Mpeg4AacPlusV2, H264Bp,
EndOfCodecType
}
enum | DirectionType { UnspecificDirection, DecodingDirection, EncodingDirection, EndOfDirectionType }
enum | EncQualityConfig { EncQualityLow, EncQualityMid, EncQualityHigh }
enum | LocationType { HostLocation, CompanionLocation, EndOfLocationType }
enum | MonoSteroConfig { Mono = 0, Stereo, DualMono, MonoStereoConfigEnd }
enum ResultType {
Success = 0, MediaNotSupported, OutOfMemory, SmallBuffer,
NullParameter, InvalidParameter, InvalidFrameSize, FeatureNotSupported,
GeneralError, MaxNumberOfCodersReached, MaxNumberOfOperationsReached, ArrayTooShort,
InvalidState, EndOfResultType
}
typedef UINT32 | TimestampMSec

Public Member Functions

virtual ResultType | GetProperties (Properties &properties)=0
virtual | ~CodecDevice ()

Protected Member Functions

CodecDevice ()
virtual ResultType | SetCodec (CodecType codec)=0

Friends

class | CodecManager

Data Structures

struct | AudioChannel
struct | AudioCodecCapabilities
struct | AudioDecoderParameters
struct | AudioEncoderParameters
struct | AudioIOBuffer
struct | AudioStreamInfo
struct | Properties
struct | VideoCodecCapabilities
struct | VideoDecoderInfo
struct | VideoDecoderParameters
struct | VideoEncoderInfo
struct | VideoEncoderParameters
struct | VideoStreamInfo

Member Typedef Documentation

typedef INT32 CodecDevice::AudioChannelId

Audio channel ID.

typedef void(* CodecDevice::CbResult)(ResultType result, void *context)

Callback function that is invoked by the CodecDevice when the corresponding asynchronous operation has been finished.

Parameters:
result | A result (error) code: Success if the operation was successful. Otherwise, an appropriate error code.
context | A context (e.g. this pointer) that has been passed to the CodecDevice object when the corresponding function has been invoked.
See also:
CbResultAndTimeInfo

typedef void(* CodecDevice::CbResultAndTimeInfo)(ResultType result, void *context, UINT32 time_ms)

Callback function that is invoked by the CodecDevice when the corresponding asynchronous operation has been finished. In addition, the current clock time is provided (if suppoted).

Parameters:
result | A result (error) code: Success if the operation was successful. Otherwise, an appropriate error code.
context | A context (e.g. this pointer) that has been passed to the CodecDevice object when the corresponding function has been invoked.
time_ms | Current clock time (in milliseconds). If CodecDevice object does not support time, this value has to be ignored.
See also:
CbResult

typedef UINT32 CodecDevice::TimestampMSec

Time in ms.

Member Enumeration Documentation

enum CodecDevice::AacFormat

AAC format configuration. It indicates AAC interface format type.

Enumerator:
AacFormatAdts
AacFormatAdif
AacFormatRaw
AacFormatEnd

enum CodecDevice::AmrDtxConfig

AMR DTX configuration. It enables/disables DTX feature.

Enumerator:
AmrDtxOff
AmrDtxOn
AmrDtxEnd

enum CodecDevice::AmrIfFormat

AMR I/F format. It indicates AMR interface format type.

Enumerator:
AmrFrameFormatUndefined
AmrFrameFormatConformance
AmrFrameFormatIf1
AmrFrameFormatIf2
AmrFrameFormatMime
AmrFrameFormatEnd

enum CodecDevice::ApplicationCategoriesFlagsType

Application categories type. It is used for the video encoder to inform the video encoder about the application type that is using the video encoder functionality.

Enumerator:
StorageAppCatFlag
StreamingAppCatFlag
TelephonyAppCatFlag
GreatestValueOfApplicationCategoriesFlagsType

enum CodecDevice::CodecType

Codec.

Enumerator:
DefaultCodec | CodecManager should select a suitable/default codec. It is used for encoding purposes.
UnknownCodec | Codec is unknown to the encoder/decoder, i.e., the codec is not supported by the encoder/decoder.
Mpeg4Sp | MPEG-4 Simple Profile.
H263Bl | H.263 Baseline.
GsmAmrNb | GSM AMR Narrow Band.
Mpeg4Aac | AAC-LC (or AAC-LTP).
Qcelp | QCELP.
Evrc | EVRC.
Mp3 | MP3.
Mpeg4AacPlusV1 | AAC-Plus V1 (= AAC+ = HE-AAC = AAC-LC + SBR).
Mpeg4AacPlusV2 | AAC-Plus V2 (= AAC++ = Enhanced AAC+ = AAC-LC + SBR + PS).
H264Bp | H.264 Baseline Profile.
EndOfCodecType

enum CodecDevice::DirectionType

Direction type. It indicates if the CodecDevice sub-class is a decoder or an encoder.

Enumerator:
UnspecificDirection
DecodingDirection
EncodingDirection
EndOfDirectionType

enum CodecDevice::EncQualityConfig

Encoder quality configuration. It indicates the recording quality.

Enumerator:
EncQualityLow
EncQualityMid
EncQualityHigh

enum CodecDevice::LocationType

Location type. It is used in order to indicate where the corresponding item (e.g. buffers) is located.

Enumerator:
HostLocation | located on the host chip
CompanionLocation | located on the companion chip
EndOfLocationType

enum CodecDevice::MonoSteroConfig

Mono/Stero configuration. It indicates Mono/Stero configuration for AAC encoding.

Enumerator:
Mono
Stereo
DualMono
MonoStereoConfigEnd

enum CodecDevice::ResultType

Result (error) codes that are usually returned by the functions of the CodecManager, VideoEncoder, VideoDecoder and AudioDecoder.

Enumerator:
Success | Function successfully completed.
MediaNotSupported | MIME type or codec is not supported.
OutOfMemory
SmallBuffer | Buffer length (size) is too short.
NullParameter
InvalidParameter
InvalidFrameSize
FeatureNotSupported | The feature is not supported (e.g. due to HW constraints).
GeneralError | General or unknown error.
MaxNumberOfCodersReached | The maximum number of Encoders/Decoders has been already created.
MaxNumberOfOperationsReached | The maximum number of invocations of this function has been reached, i.e., the queue is full.
ArrayTooShort | Insufficient number of elements in the array.
InvalidState
EndOfResultType

Constructor & Destructor Documentation

virtual CodecDevice::~CodecDevice ( ) [inline, virtual]

Default destructor.

CodecDevice::CodecDevice ( ) [inline, protected]

Default constructor.

Member Function Documentation

virtual ResultType CodecDevice::GetProperties ( Properties & properties ) [pure virtual]

This function retrieves the properties of the codec device. It is used by the CodecManager in order to find out an appriopriate CodecDevice sub-class instance.

Parameters:
properties On return the retrieved properties.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType CodecDevice::SetCodec ( CodecType codec ) [protected, pure virtual]

This function is used to set the codec. This codec shall be used when Open is called next time to the CodecDevice. It is only used by the CodecManager.

Parameters:
codec Codec to be set.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Friends And Related Function Documentation

friend class CodecManager [friend]

Reimplemented in AudioCapturerEncoder, AudioDecoder, AudioDecoderRenderer, AudioEncoder, VideoDecoder, VideoEncoder, and AtiAudioDecoderRenderer.

The documentation for this class was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::AudioChannel Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::AudioChannel

CodecDevice::AudioChannel Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

AudioChannelId m_id

Detailed Description

Audio channel.

Field Documentation

AudioChannelId CodecDevice::AudioChannel::m_id

AudioChannelId

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::AudioCodecCapabilities Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::AudioCodecCapabilities

CodecDevice::AudioCodecCapabilities Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Public Member Functions

AudioCodecCapabilities ()
~AudioCodecCapabilities ()

Data Fields

UINT32 | m_application_categories
CodecType * m_array_of_supported_codecs
UINT16 | m_max_quality_level
UINT16 | m_min_quality_level
UINT8 | m_num_of_supported_codecs

Detailed Description

Capabilites of the audio decoder.

Constructor & Destructor Documentation

CodecDevice::AudioCodecCapabilities::AudioCodecCapabilities ( ) [inline]

Default Constructor.

CodecDevice::AudioCodecCapabilities::~AudioCodecCapabilities ( ) [inline]

Destructor.

Field Documentation

UINT32 CodecDevice::AudioCodecCapabilities::m_application_categories

All the supported application categories flag bits will be set (see CodecDevice::ApplicationCategoriesFlagsType), e.g. if the codec supports both Storage & Streaming then it will be set to "3".

CodecType* CodecDevice::AudioCodecCapabilities::m_array_of_supported_codecs

Array of the supported audio codecs. The number of elements is given by m_num_of_supported_codecs.

UINT16 CodecDevice::AudioCodecCapabilities::m_max_quality_level

Maximum supported quality level.

UINT16 CodecDevice::AudioCodecCapabilities::m_min_quality_level

Minimum supported quality level. 0 corresponds to default settings.

UINT8 CodecDevice::AudioCodecCapabilities::m_num_of_supported_codecs

Number of supported audio codecs. It is also the length (number of elements) of m_array_of_supported_codecs.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::AudioDecoderParameters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::AudioDecoderParameters

CodecDevice::AudioDecoderParameters Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

CodecType m_audio_codec
INT | m_format
UINT16 | m_quality_level

Detailed Description

Audio decoder parameters passed to the decoder.
See also:
AudioDecoder::SetConfig

Field Documentation

CodecType CodecDevice::AudioDecoderParameters::m_audio_codec

Audio codec (if known to the caller) that shall be used for decoding. If the audio codec is not known to the caller, this parameter shall be set to CodecDevice::UnknownCodec or CodecDevice::DefaultCodec and the CodecManager shall find out the codec by querying all registered audio decoders (until the first decoder supporting the stream has been found). The same applies if the passed audio codec is not valid or the codec is not supported: all registered audio decoders shall be queried.

INT CodecDevice::AudioDecoderParameters::m_format

Audio codec format. This parameter is intepreted in different way dependending on the actual audio decoder. It has to be casted to the type specific for a given audio codec:
For AAC it has to be casted to AudioDecoder::AacFormatType enum.

UINT16 CodecDevice::AudioDecoderParameters::m_quality_level

Quality level of the decoder. The greater this value, the better the quality. 0 corresponds to default settings. If the value is greater than the maximum supported quality level (which can be retrieved via CodecManager::GetAudioDecoderCapabilities), the maximum level is set.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::AudioEncoderParameters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::AudioEncoderParameters

CodecDevice::AudioEncoderParameters Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

INT | m_bit_allocation_method
INT16 | m_bit_pool
UINT32 | m_block_len
INT | m_channel_mode
UINT32 | m_input_sampling_frequency
UINT32 | m_num_of_subbands

Detailed Description

Audio encoder parameters passed to the encoder that is opened. Note: some of the parameters are not valid for all audio encoders, thus, they will be ignored by the corresponding encoders.
See also:
AudioDecoder::SetConfig

Field Documentation

INT CodecDevice::AudioEncoderParameters::m_bit_allocation_method

Bit allocation method. It has to be casted to AudioEncoder::BitAllocationMethodType enum.

INT16 CodecDevice::AudioEncoderParameters::m_bit_pool

Value of bitpool for frame (for SBC encoder it can vary between 8 and 255. Bitpool parameter is proportional to the bit-rate of operation.

UINT32 CodecDevice::AudioEncoderParameters::m_block_len

Block length for filter bank.

INT CodecDevice::AudioEncoderParameters::m_channel_mode

Channel mode. It has to be casted to AudioEncoder::ChannelModeType enum.

UINT32 CodecDevice::AudioEncoderParameters::m_input_sampling_frequency

Sampling frequency of the input PCM data in Hertz.

UINT32 CodecDevice::AudioEncoderParameters::m_num_of_subbands

Number of subbands in filter bank.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::AudioIOBuffer Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::AudioIOBuffer

CodecDevice::AudioIOBuffer Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

UINT8 * | m_buffer
UINT32 | m_buffer_len
BOOLEAN | m_last_buffer
TimestampMSec m_time

Detailed Description

A struct containing information about encoded audio data buffer.

Field Documentation

UINT8* CodecDevice::AudioIOBuffer::m_buffer

Poniter to the encoded data buffer.

UINT32 CodecDevice::AudioIOBuffer::m_buffer_len

Encoded buffer length.

BOOLEAN CodecDevice::AudioIOBuffer::m_last_buffer

Indicates last encoded buffer.

TimestampMSec CodecDevice::AudioIOBuffer::m_time

Timestamp of the encoded buffer.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::AudioStreamInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::AudioStreamInfo

CodecDevice::AudioStreamInfo Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

CodecType m_codec_type
UINT32 | m_num_of_channels
UINT32 | m_sampling_frequency

Detailed Description

A struct containing information about encoded audio stream.

Field Documentation

CodecType CodecDevice::AudioStreamInfo::m_codec_type

The encoding type (codec) of the compressed audio stream.

UINT32 CodecDevice::AudioStreamInfo::m_num_of_channels

Number of channnels.

UINT32 CodecDevice::AudioStreamInfo::m_sampling_frequency

Sampling frequency in Hertz.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::Properties Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::Properties

CodecDevice::Properties Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Public Member Functions

Properties ()
~Properties ()

Data Fields

CodecType * m_array_of_supported_codecs
BOOLEAN | m_combined_device
DirectionType m_direction
UINT | m_num_of_supported_codecs

Detailed Description

Properties of the CodecDevice sub-class.
See also:
GetProperties

Constructor & Destructor Documentation

CodecDevice::Properties::Properties ( ) [inline]

Constructor

CodecDevice::Properties::~Properties ( ) [inline]

Destructor

Field Documentation

CodecType* CodecDevice::Properties::m_array_of_supported_codecs

Array of codecs supported by the CodecDevice instance.

BOOLEAN CodecDevice::Properties::m_combined_device

Specifies if the codec device is a combined device (e.g. a decoder/renderer combined device).

DirectionType CodecDevice::Properties::m_direction

Direction (de-/encoding) of the codec device.

UINT CodecDevice::Properties::m_num_of_supported_codecs

Number of supported codecs. It is the number of elements of m_array_of_supported_codecs.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::VideoCodecCapabilities Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::VideoCodecCapabilities

CodecDevice::VideoCodecCapabilities Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Public Member Functions

VideoCodecCapabilities ()
~VideoCodecCapabilities ()

Data Fields

UINT32 | m_application_categories
CodecType * m_array_of_supported_codecs
UINT32 | m_max_bit_rate
UINT16 | m_max_frame_rate_denominator
UINT16 | m_max_frame_rate_numerator
UINT16 | m_max_height
UINT16 | m_max_quality_level
UINT16 | m_max_width
UINT32 | m_min_bit_rate
UINT16 | m_min_frame_rate_denominator
UINT16 | m_min_frame_rate_numerator
UINT16 | m_min_height
UINT16 | m_min_quality_level
UINT16 | m_min_width
UINT8 | m_num_of_supported_codecs

Detailed Description

Capabilites of the video encoder/decoder.

Constructor & Destructor Documentation

CodecDevice::VideoCodecCapabilities::VideoCodecCapabilities ( ) [inline]

Default Constructor.

CodecDevice::VideoCodecCapabilities::~VideoCodecCapabilities ( ) [inline]

Destructor.

Field Documentation

UINT32 CodecDevice::VideoCodecCapabilities::m_application_categories

All the supported application categories flag bits will be set (see CodecDevice::ApplicationCategoriesFlagsType), e.g. if the codec supports both Storage & Streaming then it will be set to "3".

CodecType* CodecDevice::VideoCodecCapabilities::m_array_of_supported_codecs

Array of the supported video codecs. The number of elements is given by m_num_of_supported_codecs.

UINT32 CodecDevice::VideoCodecCapabilities::m_max_bit_rate

Maximum supported bit rate (in bits per second).

UINT16 CodecDevice::VideoCodecCapabilities::m_max_frame_rate_denominator

Denominator of the maximum supported frame rate (in frames per second). The actual maximum frame rate is calculated as m_max_frame_rate_numerator/m_max_frame_rate_denominator.

UINT16 CodecDevice::VideoCodecCapabilities::m_max_frame_rate_numerator

Numerator of the maximum supported frame rate (in frames per second). The actual maximum frame rate is calculated as m_max_frame_rate_numerator/m_max_frame_rate_denominator.

UINT16 CodecDevice::VideoCodecCapabilities::m_max_height

Maximum supported height.

UINT16 CodecDevice::VideoCodecCapabilities::m_max_quality_level

Maximum supported quality level. In case of Video Decoder this will indicate the Deinterlacing, Deringing & Deblocking capabilities

UINT16 CodecDevice::VideoCodecCapabilities::m_max_width

Maximum supported width.

UINT32 CodecDevice::VideoCodecCapabilities::m_min_bit_rate

Minimum supported bit rate (in bits per second).

UINT16 CodecDevice::VideoCodecCapabilities::m_min_frame_rate_denominator

Denominator of the minimum supported frame rate (in frames per second). The actual minimum frame rate is calculated as m_min_frame_rate_numerator/m_min_frame_rate_denominator.

UINT16 CodecDevice::VideoCodecCapabilities::m_min_frame_rate_numerator

Numerator of the minimum supported frame rate (in frames per second). The actual minimum frame rate is calculated as m_min_frame_rate_numerator/m_min_frame_rate_denominator.

UINT16 CodecDevice::VideoCodecCapabilities::m_min_height

Minimum supported height.

UINT16 CodecDevice::VideoCodecCapabilities::m_min_quality_level

Minimum supported quality level. In case of Video Decoder this will indicate the Deinterlacing, Deringing & Deblocking capabilities. 0 corresponds to default settings.

UINT16 CodecDevice::VideoCodecCapabilities::m_min_width

Minimum supported width.

UINT8 CodecDevice::VideoCodecCapabilities::m_num_of_supported_codecs

Number of supported video codecs. It is also the length (number of elements) of m_array_of_supported_codecs.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::VideoDecoderInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::VideoDecoderInfo

CodecDevice::VideoDecoderInfo Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

BOOLEAN m_clock_support
LocationType m_location

Detailed Description

Struct containing informations delivered by the video decoder.

Field Documentation

BOOLEAN CodecDevice::VideoDecoderInfo::m_clock_support

Indicates if the video decoder supports a clock (e.g. an external clock on companion chip).

LocationType CodecDevice::VideoDecoderInfo::m_location

Location of the video decoder.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::VideoDecoderParameters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::VideoDecoderParameters

CodecDevice::VideoDecoderParameters Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

UINT16 | m_actual_height
UINT16 | m_actual_width
UINT32 | m_length_of_header_length_field
UINT32 | m_length_of_length_field
UINT32 | m_max_bit_rate
UINT16 | m_quality_level

Detailed Description

Video decoder parameters passed to the decoder.
See also:
VideoDecoder::SetConfig

Field Documentation

UINT16 CodecDevice::VideoDecoderParameters::m_actual_height

Height of the compressed video frame. This parameter is only used if there is no config stream, i.e. if the config_stream parameter in VideoDecoder::SetConfig is 0. Otherwise this parameter is ignored by the decoder since this information is retrieved by the decoder from the config stream.

UINT16 CodecDevice::VideoDecoderParameters::m_actual_width

Width of the compressed video frame. This parameter is only used if there is no config stream, i.e. if the config_stream parameter in VideoDecoder::SetConfig is 0. Otherwise this parameter is ignored by the decoder since this information is retrieved by the decoder from the config stream.

UINT32 CodecDevice::VideoDecoderParameters::m_length_of_header_length_field

Length (in bytes) required to represent header length. This is useful only if the stream is encoded in 3GPP format. For H.264 decoder only.

UINT32 CodecDevice::VideoDecoderParameters::m_length_of_length_field

Length (in bytes) of NAL length field present in compressed frame data. The compressed video frame contains length of each NAL unit followed by NAL data. This is useful only if the stream is encoded in 3GPP format. For H.264 decoder only.

UINT32 CodecDevice::VideoDecoderParameters::m_max_bit_rate

Maximum bit rate (in bits/sec). If this info is not available this value shall be set to 0.

UINT16 CodecDevice::VideoDecoderParameters::m_quality_level

Quality level of the decoder. The greater this value, the better the quality. In general, in dependency of this value the post-processsing features (Deinterlacing, Deringing & Deblocking) are enabled/disabled. 0 corresponds to default settings. If the value is greater than the maximum supported quality level (which can be retrieved via CodecManager::GetVideoDecoderCapabilities), the maximum level is set.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::VideoEncoderInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::VideoEncoderInfo

CodecDevice::VideoEncoderInfo Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

UINT32 m_in_buf_max_len
LocationType m_location

Detailed Description

Struct containing informations delivered by the video encoder.

Field Documentation

UINT32 CodecDevice::VideoEncoderInfo::m_in_buf_max_len

Maximum length of the input buffer in bytes. This information might be used by the VideoCamera device.

LocationType CodecDevice::VideoEncoderInfo::m_location

Location of the video encoder.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::VideoEncoderParameters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::VideoEncoderParameters

CodecDevice::VideoEncoderParameters Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

UINT16 | m_actual_height
UINT16 | m_actual_width
UINT32 | m_application_category
UINT32 | m_bit_rate
UINT16 | m_frame_rate_denominator
UINT16 | m_frame_rate_numerator
UINT16 | m_quality_level
UINT32 | m_timer_resolution

Detailed Description

Video encoder parameters passed to the video encoder.
See also:
VideoEncoder::SetConfig

Field Documentation

UINT16 CodecDevice::VideoEncoderParameters::m_actual_height

Actual height of the video (in pixels).

UINT16 CodecDevice::VideoEncoderParameters::m_actual_width

Actual width of the video (in pixels).

UINT32 CodecDevice::VideoEncoderParameters::m_application_category

The application category that is making use of the video encoder (see CodecDevice::ApplicationCategoriesFlagsType). In dependency of this parameter (and the m_quality_level parameter) the actual parameters (like SceneCutDetection, Preprocessing level, rate control model) of the video encoder are set.

UINT32 CodecDevice::VideoEncoderParameters::m_bit_rate

Bit rate (in bits/sec).

UINT16 CodecDevice::VideoEncoderParameters::m_frame_rate_denominator

Denominator of the frame rate (in frames per second). The actual frame rate is calculated as m_frame_rate_numerator/m_frame_rate_denominator.

UINT16 CodecDevice::VideoEncoderParameters::m_frame_rate_numerator

Numerator of the frame rate (in frames per second). The actual frame rate is calculated as m_frame_rate_numerator/m_frame_rate_denominator.

UINT16 CodecDevice::VideoEncoderParameters::m_quality_level

Quality level. In dependency of this parameter (and the m_application_category parameter) the actual parameters (like SceneCutDetection, Preprocessing level, rate control model) of the video encoder are set. The higher this value the better the encoding quality. 0 corresponds to default settings. If the value is greater than the maximum supported quality level (which can be retrieved via CodecManager::GetVideoEncoderCapabilities), the maximum level is set.

UINT32 CodecDevice::VideoEncoderParameters::m_timer_resolution

Resolution of the timer being used to calculate the time stamps. This value denotes number of primary time units per one second.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecDevice::VideoStreamInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CodecDevice::VideoStreamInfo

CodecDevice::VideoStreamInfo Struct Reference

#include <Apoxi/AddOns/CodecManager/CodecDevice.hpp>

Data Fields

UINT16 | m_actual_height
UINT16 | m_actual_width
UINT16 | m_ext_height
UINT16 | m_ext_width
UINT16 | m_frame_rate_denominator
UINT16 | m_frame_rate_numerator
INT | m_left_offset
UINT32 | m_max_bit_rate
UINT32 | m_out_frame_length
CodecType m_stream_type
INT | m_top_offset

Detailed Description

A struct containing information about encoded video stream.

Field Documentation

UINT16 CodecDevice::VideoStreamInfo::m_actual_height

Actual height of the compressed video frame.

UINT16 CodecDevice::VideoStreamInfo::m_actual_width

Actual width of the compressed video frame.

UINT16 CodecDevice::VideoStreamInfo::m_ext_height

Extended height of the compressed video frame (a multiple value of the MB height).

UINT16 CodecDevice::VideoStreamInfo::m_ext_width

Extended width of the compressed video frame (a multiple value of the MB width).

UINT16 CodecDevice::VideoStreamInfo::m_frame_rate_denominator

Denominator of the frame rate (in frames per second). The actual frame rate is calculated as m_frame_rate_numerator/m_frame_rate_denominator.

UINT16 CodecDevice::VideoStreamInfo::m_frame_rate_numerator

Numerator of the frame rate (in frames per second). The actual frame rate is calculated as m_frame_rate_numerator/m_frame_rate_denominator.

INT CodecDevice::VideoStreamInfo::m_left_offset

Left offset in the extended image from where the display image has to be obtained. It is only supported by some codecs (H.264). In order to disable cropping, this parameter and m_top_offset shall be set to 0.

UINT32 CodecDevice::VideoStreamInfo::m_max_bit_rate

Maximum bit rate (in bits/sec).If this info is not available this value is equal to 0.

UINT32 CodecDevice::VideoStreamInfo::m_out_frame_length

Video decoder output frame length (in bytes).

CodecType CodecDevice::VideoStreamInfo::m_stream_type

The encoding type (codec) of the compressed video stream.

INT CodecDevice::VideoStreamInfo::m_top_offset

Top offset in the extended image from where the display image has to be obtained. It is only supported by some codecs (H.264). In order to disable cropping, this parameter and m_left_offset shall be set to 0.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/CodecDevice.hpp
Generated on Wed Jan 25 01:06:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CodecManager Class Reference
[CodecManager]

#include <Apoxi/AddOns/CodecManager/CodecManager.hpp>

Collaboration diagram for CodecManager:

[legend]

Public Member Functions

CodecDevice::ResultType | ObtainDecoder (CodecDevice *&codec_device, CodecDevice::CodecType codec_type, BOOLEAN &combined_device)
CodecDevice::ResultType | ObtainEncoder (CodecDevice *&codec_device, CodecDevice::CodecType codec_type, BOOLEAN &combined_device)
CodecDevice::ResultType | RegisterDecoder (CodecDevice *codec_device)
CodecDevice::ResultType | RegisterEncoder (CodecDevice *codec_device)
void | ReleaseDecoder (CodecDevice *codec_device)
void | ReleaseEncoder (CodecDevice *codec_device)
void | UnregisterDecoder (CodecDevice *codec_device)
void | UnregisterEncoder (CodecDevice *codec_device)
virtual | ~CodecManager ()

Friends

class | CodecConfig

Detailed Description

Central instance of the codec device. It allows to access and to make use of the functionality provided by the VideoEncoder, VideoDecoder and AudioDecoder sub-class instances.

Constructor & Destructor Documentation

CodecManager::~CodecManager ( ) [virtual]

Destructor.

Member Function Documentation

CodecDevice::ResultType CodecManager::ObtainDecoder | ( | CodecDevice *& | codec_device,
 |  | CodecDevice::CodecType | codec_type,
 |  | BOOLEAN & | combined_device
 | ) |

Retrieves a pointer to an instance of a decoder (CodecDevice sub-class). This pointer has to be casted to the actual codec device type pointer (e.g. VideoDecoder) in order to use the provided functionality.

Parameters:
codec_device | On return it contains the pointer to a CodecDevice sub-class instance. Via this pointer the decoder functionality can be accessed. In case of failure it contains a null pointer.
codec_type | Required decoder codec to be supported by the returned CodecDevice instance.
enc_info | On return, it specifies if the obtained decoder is a combined device i.e. a decoder/renderer.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an aprropriate error code.
See also:
ReleaseDecoder

CodecDevice::ResultType CodecManager::ObtainEncoder | ( | CodecDevice *& | codec_device,
 |  | CodecDevice::CodecType | codec_type,
 |  | BOOLEAN & | combined_device
 | ) |

Retrieves a pointer to an instance of an encoder (CodecDevice sub-class). This pointer has to be casted to the actual codec device type pointer (e.g. VideoEncoder) in order to use the provided functionality.

Parameters:
codec_device | On return it contains the pointer to a CodecDevice sub-class instance. Via this pointer the encoder functionality can be accessed. In case of failure it contains a null pointer.
codec_type | Required encoder codec to be supported by the returned CodecDevice instance.
enc_info | On return, it specifies if the obtained encoder is a combined device i.e. a capturer/encoder.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an aprropriate error code.
See also:
ReleaseEncoder

CodecDevice::ResultType CodecManager::RegisterDecoder ( CodecDevice * codec_device )

This function is used by a codec library in order to register a new decoder with the CodecManager (Note: one decoder can support more than one codec). This registers an already created instance of the CodecDevice sub-class.

Parameters:
codec_device Pointer to the decoder that shall be registered.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType CodecManager::RegisterEncoder ( CodecDevice * codec_device )

This function is used by a codec library in order to register a new encoder with the CodecManager (Note: one encoder can support more than one codec). This registers an already created instance of the CodecDevice sub-class.

Parameters:
codec_device Pointer to the encoder that shall be registered.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

void CodecManager::ReleaseDecoder ( CodecDevice * codec_device )

Releases a previously obtained encoder (obtained by CodecManager::ObtainDecoder). This method should be invoked as soon as the decoder is not needed anymore to allow other decoders to access the resources.

Parameters:
codec_device Pointer to the CodecDevice (sub-class) instance that shall be released.
See also:
ObtainDecoder

void CodecManager::ReleaseEncoder ( CodecDevice * codec_device )

Releases a previously obtained encoder (obtained by CodecManager::ObtainEncoder. This method should be invoked as soon as the encoder is not needed anymore to allow other encoders to access the resources.

Parameters:
codec_device Pointer to the CodecDevice (sub-class) instance that shall be released.
See also:
ObtainEncoder

void CodecManager::UnregisterDecoder ( CodecDevice * codec_device )

Unregister a decoder sub-class.

Parameters:
codec_device Pointer to the decoder that shall be unregistered.

void CodecManager::UnregisterEncoder ( CodecDevice * codec_device )

Unregister an encoder sub-class.

Parameters:
codec_device Pointer to the encoder that shall be unregistered.

Friends And Related Function Documentation

friend class CodecConfig [friend]

The documentation for this class was generated from the following files:
  • AddOns/CodecManager/CodecManager.hpp
  • AddOns/CodecManager/CodecManager.cpp
Generated on Wed Jan 25 01:06:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodedTimeStamp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CodedTimeStamp Class Reference

(ServiceCentreTimeStamp) 3GPP 23.040 V5.1.0 [9.2.3.11] - More...

#include <Apoxi/Apc/ValidityPeriod.hpp>

Public Member Functions

CodedTimeStamp (const UINT8 *data, BOOLEAN time_only=FALSE)
CodedTimeStamp ()
DateTime | GetAbsoluteDateTime () const
TimeSpan | GetRelativeTime () const
INT | GetTimeZone () const
timezone representation in quarters of an hour +/- to Greenwich Mean Time (GMT)
void | SetAbsoluteDateTime (const DateTime &date_time)
void | SetRelativeTime (const TimeSpan &time_span)
void | SetTimeZone (INT time_zone)
void | UpdateData (UINT8 *data) const

Detailed Description

(ServiceCentreTimeStamp) 3GPP 23.040 V5.1.0 [9.2.3.11] -

Constructor & Destructor Documentation

CodedTimeStamp::CodedTimeStamp ( )

CodedTimeStamp::CodedTimeStamp | ( | const UINT8 * | data,
 |  | BOOLEAN | time_only = FALSE
 | ) |

Member Function Documentation

DateTime CodedTimeStamp::GetAbsoluteDateTime ( ) const

TimeSpan CodedTimeStamp::GetRelativeTime ( ) const

INT CodedTimeStamp::GetTimeZone ( ) const

timezone representation in quarters of an hour +/- to Greenwich Mean Time (GMT)

void CodedTimeStamp::SetAbsoluteDateTime ( const DateTime & date_time )

void CodedTimeStamp::SetRelativeTime ( const TimeSpan & time_span )

void CodedTimeStamp::SetTimeZone ( INT time_zone )

void CodedTimeStamp::UpdateData ( UINT8 * data ) const

The documentation for this class was generated from the following files:
  • Apc/ValidityPeriod.hpp
  • Apc/ValidityPeriod.cpp
Generated on Wed Jan 25 01:06:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Color Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Color Class Reference
[GUI]

#include <Apoxi/Gui/Color.hpp>

Public Types

enum SystemColorId {
ClientBackground = 0, ClientForeground = 1, ActiveFrameBackground = 2, ActiveFrameForeground = 3,
InactiveFrameBackground = 4, InactiveFrameForeground = 5, SelectionBackground = 6, SelectionForeground = 7,
Shaded = 8, ButtonBackground = 9, ButtonForeground = 10, ContextMenuBackground = 11,
ActiveWindowTitle = 12, InactiveWindowTitle = 13, SystemColorIdCount = 14
}

Public Member Functions

ColorValue | Blend (ColorValue background) const
Color | Blend (const Color &background) const
Color (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha=255)
Color (SystemColorId system_color_id)
Color (ColorValue color_value)
Color ()
Initializes the color-object as black color.
UINT8 | GetAlpha () const
UINT8 | GetBlue () const
UINT8 | GetGreen () const
UINT8 | GetRed () const
void | GetRgb (UINT8 &red, UINT8 &green, UINT8 &blue, UINT8 *alpha=0) const
Returns the red-, green- and blue-value and optionally the alpha-value of the color-object.
ColorValue | GetValue () const
Returns the value of the color.
BOOLEAN | operator!= (const Color &color) const
Checks whether the color parameter is not identical to the object.
BOOLEAN | operator== (const Color &color) const
Checks whether the color parameter is not identical to the object.
void | SetAlpha (UINT8 alpha)
Sets the alpha component of the color object The alpha value specifies the opacity of the color, i.e. 0 == transparent, 128 == 50% translucent, 255 == opaque.
void | SetBlue (UINT8 blue)
Sets the blue component of the color object.
void | SetGreen (UINT8 green)
Sets the green component of the color object.
void | SetHsv (UINT16 hue, UINT8 saturation, UINT8 value, UINT8 alpha=255)
void | SetRed (UINT8 red)
Sets the red component of the color object.
void | SetRgb (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha=255)
void | SetValue (ColorValue color_value)
Sets the color to the value represented by color_value.

Static Public Member Functions

static ColorValue | Blend (ColorValue foreground, ColorValue background, UINT8 alpha=255)

Detailed Description

Describes a color used by all graphical operations. A color can be specified by it's value or as RGB or HSV values.

The result of the shown color depends on the available color-depth specified by the display-driver. For low-color displays, which internally use color-tables, a mapping to closest similar color is done. The mapped color is stored as ColorValue. It is recommended to work with the color-object itself instead of the display device dependant ColorValue.

Member Enumeration Documentation

enum Color::SystemColorId

Every theme offers specific color values to a system color ID. By using system color IDs instead of hard coded color values the output of applications automatically respects the look of a theme. E. g. use device_context->SetPenColor(Color::ClientForeground)); instead of a hard coded device_context->SetPenColor(Color(10, 200, 10));. The MMI may use custom color IDs starting with the range 100 (IDs from 0 to 99 are reserved for APOXI).

Enumerator:
ClientBackground | Background color for the client area of a window.
ClientForeground | Foreground color for the client area of a window.
ActiveFrameBackground | Background color for a window-frame when the window has the focus.
ActiveFrameForeground | Foreground color for a window-frame when the window has the focus.
InactiveFrameBackground | Background color for a window-frame when the window has not the focus.
InactiveFrameForeground | Foreground color for a window-frame when the window has not the focus.
SelectionBackground | Background color for selections e. g. used in listboxes.
SelectionForeground | Foreground color for selections e. g. used in listboxes.
Shaded | Color for inactive texts e. g. disabled actions.
ButtonBackground | Background color for any kind of button (e. g. push-button).
ButtonForeground | Foreground color for any kind of button (e. g. push-button).
ContextMenuBackground | Background color for a context menu.
ActiveWindowTitle | Color of the window title when the window has the focus.
InactiveWindowTitle | Color of the window title when the window has not the focus.
SystemColorIdCount

Constructor & Destructor Documentation

Color::Color ( )

Initializes the color-object as black color.

Color::Color ( ColorValue color_value )

Initializes the color-object with the recalculated RGB-values from the color_value.

Color::Color ( SystemColorId system_color_id )

Initializes the color-object with the RGB-values indicated by the system-color system_color_id. The system-colors are defined by an instance of the class Theme.

Color::Color | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha = 255
 | ) |

Member Function Documentation

ColorValue Color::Blend | ( | ColorValue | foreground,
 |  | ColorValue | background,
 |  | UINT8 | alpha = 255
 | ) | [static]

Alpha-blends two colors. If alpha is specified, then the foreground color's alpha value is set to the specified value, otherwise the foreground's alpha value is used (caution: if ColorValue is 16 bit, then alpha will always be 0). If alpha is greater than 255, it will be set to 255.

Returns:
the blended color

ColorValue Color::Blend ( ColorValue background ) const

Alpha-blends two colors. this is used as the foreground color; accordingly, this's alpha value is used.

Returns:
the blended color

Color Color::Blend ( const Color & background ) const

Alpha-blends two colors. this is used as the foreground color; accordingly, this's alpha value is used.

Returns:
the blended color

UINT8 Color::GetAlpha ( ) const [inline]

Returns:
the alpha-value of the color-object. The alpha value specifies the opacity of the color, i.e. 0 == transparent, 128 == 50% translucent, 255 == opaque.

UINT8 Color::GetBlue ( ) const [inline]

Returns:
the blue-value of the color-object.

UINT8 Color::GetGreen ( ) const [inline]

Returns:
the green-value of the color-object.

UINT8 Color::GetRed ( ) const [inline]

Returns:
the red-value of the color-object.

void Color::GetRgb | ( | UINT8 & | red,
 |  | UINT8 & | green,
 |  | UINT8 & | blue,
 |  | UINT8 * | alpha = 0
 | ) | const

Returns the red-, green- and blue-value and optionally the alpha-value of the color-object.

ColorValue Color::GetValue ( ) const

Returns the value of the color.

BOOLEAN Color::operator!= ( const Color & color ) const

Checks whether the color parameter is not identical to the object.

BOOLEAN Color::operator== ( const Color & color ) const

Checks whether the color parameter is not identical to the object.

void Color::SetAlpha ( UINT8 alpha ) [inline]

Sets the alpha component of the color object The alpha value specifies the opacity of the color, i.e. 0 == transparent, 128 == 50% translucent, 255 == opaque.

void Color::SetBlue ( UINT8 blue ) [inline]

Sets the blue component of the color object.

void Color::SetGreen ( UINT8 green ) [inline]

Sets the green component of the color object.

void Color::SetHsv | ( | UINT16 | hue,
 |  | UINT8 | saturation,
 |  | UINT8 | value,
 |  | UINT8 | alpha = 255
 | ) |

void Color::SetRed ( UINT8 red ) [inline]

Sets the red component of the color object.

void Color::SetRgb | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha = 255
 | ) |

Sets the color to the value represented by red-, green- and blue-portions. Optionally an alpha-channel can be specified. Note that in the planes-mode invoking this method needs a lot of runtime, because the closest similar color must be searched from the color-table for each call.

void Color::SetValue ( ColorValue color_value )

Sets the color to the value represented by color_value.

The documentation for this class was generated from the following files:
  • Gui/Color.hpp
  • Gui/Color.cpp
Generated on Wed Jan 25 01:06:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColorSegmentation Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColorSegmentation Struct Reference
[GUI]

#include <Apoxi/Gui/ColorSegmentation.hpp>

Public Member Functions

INT | GetAlphaBitCount () const
INT | GetBlueBitCount () const
INT | GetGreenBitCount () const
INT | GetRedBitCount () const

Data Fields

INT | m_alpha_bit_count
INT | m_blue_bit_count
INT | m_green_bit_count
INT | m_red_bit_count

Detailed Description

Describes how many bits for the color parts Red, Green, Blue and Alpha are used.

Member Function Documentation

INT ColorSegmentation::GetAlphaBitCount ( ) const [inline]

INT ColorSegmentation::GetBlueBitCount ( ) const [inline]

INT ColorSegmentation::GetGreenBitCount ( ) const [inline]

INT ColorSegmentation::GetRedBitCount ( ) const [inline]

Field Documentation

INT ColorSegmentation::m_alpha_bit_count

INT ColorSegmentation::m_blue_bit_count

INT ColorSegmentation::m_green_bit_count

INT ColorSegmentation::m_red_bit_count

The documentation for this struct was generated from the following file:
  • Gui/ColorSegmentation.hpp
Generated on Wed Jan 25 01:06:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColorTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColorTable Struct Reference
[GUI]

#include <Apoxi/Gui/ColorTable.hpp>

Collaboration diagram for ColorTable:

[legend]

Public Member Functions

UINT8 | GetBlue (INT index) const
INT | GetColorCount () const
UINT8 | GetGreen (INT index) const
UINT8 | GetRed (INT index) const
const Palette * | GetRgb (INT index) const

Data Fields

INT | m_color_count
const Palette * | m_palette

Detailed Description

The Color-Table defines the RGB-values for each color used by graphical operations. This is needed for finding the nearest matching color when using RGB-values on displays with less colors.

Member Function Documentation

UINT8 ColorTable::GetBlue ( INT index ) const [inline]

INT ColorTable::GetColorCount ( ) const [inline]

UINT8 ColorTable::GetGreen ( INT index ) const [inline]

UINT8 ColorTable::GetRed ( INT index ) const [inline]

const Palette* ColorTable::GetRgb ( INT index ) const [inline]

Field Documentation

INT ColorTable::m_color_count

const Palette* ColorTable::m_palette

The documentation for this struct was generated from the following file:
  • Gui/ColorTable.hpp
Generated on Wed Jan 25 01:06:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColpAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColpAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for ColpAction:

[legend]
Collaboration diagram for ColpAction:

[legend]

Public Member Functions

virtual InputActionType | GetActionType () const
Returns the type of the action.

Protected Member Functions

virtual InputParser::SsCode | GetSsCode () const

Detailed Description

ColpAction analyzes if the input string has the meaning of interrogation of COLP. Execute has to be overwritten to implement the sending of the SS string.

Member Function Documentation

InputActionType ColpAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

InputParser::SsCode ColpAction::GetSsCode ( ) const [protected, virtual]

Implements NumberIdentificationAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:06:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColpHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColpHandler Class Reference

#include <Apoxi/Asc/ColpHandler.hpp>

Public Types

enum | { ID = ColpHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
SsApiRc | RequestStatus (const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE)

Protected Member Functions

virtual ReturnCode | CreateInterrogateResultMsg (const SsInterrogateIndArg &arg, SsMessage *&msg) const

Detailed Description

The ColpHandler is a SS handler responsible for interrogating the Connected Line Identification Presentation SS. The class provides methods to query to current COLP status and to convert the stack-message-arguments into Apoxi-messages. It relies heavily on methods provided by its superclass.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Member Function Documentation

SsBaseHandler::ReturnCode ColpHandler::CreateInterrogateResultMsg | ( | const SsInterrogateIndArg & | arg,
 |  | SsMessage *& | msg
 | ) | const [protected, virtual]

Creates a specific Apoxi-message based on the given argument. The message is statically created, cloned and the pointer parameter set to the clone.

Parameters:
arg | The argument which contains the data and needs to be parsed.
msg | A reference to a message-pointer which will be set to the new message.
Returns:
OkNoMessage

HandlerId ColpHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
ColpHandlerId

SsApiRc ColpHandler::RequestStatus | ( | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE
 | ) |

Interrogates the COLP status. This method triggers sending of *#76# to the mobile network. The actual function is delegated to the Interrogate method of the super class.

Parameters:
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Success - if the mobile network accepted the supplementary service request,
SupplementaryServicePending - if another supplementary service is currently pending,
SupplementaryServiceDenied - if the supplementary service request was rejected by the mobile network,
NormalServiceRequired - if the network service state is invalid.
See also:
SsClHandler

The documentation for this class was generated from the following files:
  • Asc/ColpHandler.hpp
  • Asc/ColpHandler.cpp
Generated on Wed Jan 25 01:06:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColpStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColpStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ColpStatusMsg:

[legend]
Collaboration diagram for ColpStatusMsg:

[legend]

Public Types

enum | { ID = 18546 }

Public Member Functions

virtual Message * | Clone () const
ColpStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status)
virtual const MsgMetaData & | GetMetaData () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~ColpStatusMsg ()

Detailed Description

ColpStatusMsg: sent when colp status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ColpStatusMsg::ColpStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status
 | ) |

ColpStatusMsg::~ColpStatusMsg ( ) [virtual]

Member Function Documentation

Message * ColpStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & ColpStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsStatus& ColpStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& ColpStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:06:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColrAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColrAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for ColrAction:

[legend]
Collaboration diagram for ColrAction:

[legend]

Public Member Functions

virtual InputActionType | GetActionType () const
Returns the type of the action.

Protected Member Functions

virtual InputParser::SsCode | GetSsCode () const

Detailed Description

ColrAction analyzes if the input string has the meaning of interrogation of COLR. Execute has to be overwritten to implement the sending of the SS string.

Member Function Documentation

InputActionType ColrAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

InputParser::SsCode ColrAction::GetSsCode ( ) const [protected, virtual]

Implements NumberIdentificationAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:06:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColrHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColrHandler Class Reference

#include <Apoxi/Asc/ColrHandler.hpp>

Public Types

enum | { ID = ColrHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
SsApiRc | RequestStatus (const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE)

Protected Member Functions

virtual ReturnCode | CreateInterrogateResultMsg (const SsInterrogateIndArg &arg, SsMessage *&msg) const

Detailed Description

The ColrHandler is a SS handler responsible for interrogating the Connected Line Identification Restriction SS. The class provides methods to query to current COLR status and to convert the stack-message-arguments into Apoxi-messages. It relies heavily on methods provided by its superclass.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Member Function Documentation

SsBaseHandler::ReturnCode ColrHandler::CreateInterrogateResultMsg | ( | const SsInterrogateIndArg & | arg,
 |  | SsMessage *& | msg
 | ) | const [protected, virtual]

Creates a specific Apoxi-message based on the given argument. The message is statically created, cloned and the pointer parameter set to the clone.

Parameters:
arg | The argument which contains the data and needs to be parsed.
msg | A reference to a message-pointer which will be set to the new message.
Returns:
OkNoMessage

HandlerId ColrHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
ColrHandlerId

SsApiRc ColrHandler::RequestStatus | ( | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE
 | ) |

Interrogates the COLR status. This method triggers sending of *#77# to the mobile network. The actual function is delegated to the Interrogate method of the super class.

Parameters:
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Success - if the mobile network accepted the supplementary service request,
SupplementaryServicePending - if another supplementary service is currently pending,
SupplementaryServiceDenied - if the supplementary service request was rejected by the mobile network,
NormalServiceRequired - if the network service state is invalid.
See also:
SsClHandler

The documentation for this class was generated from the following files:
  • Asc/ColrHandler.hpp
  • Asc/ColrHandler.cpp
Generated on Wed Jan 25 01:06:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColrStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColrStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ColrStatusMsg:

[legend]
Collaboration diagram for ColrStatusMsg:

[legend]

Public Types

enum | { ID = 18547 }

Public Member Functions

virtual Message * | Clone () const
ColrStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status)
virtual const MsgMetaData & | GetMetaData () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~ColrStatusMsg ()

Detailed Description

ColrStatusMsg: sent when colr status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ColrStatusMsg::ColrStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status
 | ) |

ColrStatusMsg::~ColrStatusMsg ( ) [virtual]

Member Function Documentation

Message * ColrStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & ColrStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsStatus& ColrStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& ColrStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:06:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ColumnInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ColumnInfo Struct Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Provider.hpp>

Data Fields

INT colid
DataType type

Field Documentation

INT ColumnInfo::colid

DataType ColumnInfo::type

The documentation for this struct was generated from the following file:
  • Auxiliary/Provider.hpp
Generated on Wed Jan 25 01:06:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: comm_root_cert Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

comm_root_cert Struct Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp>

Collaboration diagram for comm_root_cert:

[legend]

Data Fields

comm_root_cert * pNext
INT8 * | psContent
INT8 * | pszContentType
UINT32 | uiLength

Field Documentation

struct comm_root_cert* comm_root_cert::pNext

INT8* comm_root_cert::psContent

INT8* comm_root_cert::pszContentType

UINT32 comm_root_cert::uiLength

The documentation for this struct was generated from the following file:
  • AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp
Generated on Wed Jan 25 01:06:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: comm_user_cert Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

comm_user_cert Struct Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp>

Collaboration diagram for comm_user_cert:

[legend]

Data Fields

comm_user_cert * pNext
INT8 * | psKey
INT8 * | psUserCert
INT8 * | pszContentType
INT8 * | pszPassword
UINT32 | uiCertLen
UINT32 | uiKeyLen

Field Documentation

struct comm_user_cert* comm_user_cert::pNext

INT8* comm_user_cert::psKey

INT8* comm_user_cert::psUserCert

INT8* comm_user_cert::pszContentType

INT8* comm_user_cert::pszPassword

UINT32 comm_user_cert::uiCertLen

UINT32 comm_user_cert::uiKeyLen

The documentation for this struct was generated from the following file:
  • AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp
Generated on Wed Jan 25 01:06:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CommandType Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CommandType Class Reference

3GPP TS 23.040 V5.1.0 [9.2.3.19] More...

#include <Apoxi/Apc/CommandType.hpp>

Collaboration diagram for CommandType:

[legend]

Public Types

enum Type {
Enquiry = 0, CancelStatusReportRequest, Delete, EnableStatusReportRequest,
ReservedType, ServiceCenterSpecificType, InvalidType
}
describes the various command types More...

Public Member Functions

void | Clear ()
CommandType (UINT8 incoming_byte)
CommandType ()
UINT8 | Get () const
Type | GetType () const
void | SetType (Type type)

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.3.19]

Member Enumeration Documentation

enum CommandType::Type

describes the various command types

Enumerator:
Enquiry
CancelStatusReportRequest
Delete
EnableStatusReportRequest
ReservedType
ServiceCenterSpecificType
InvalidType

Constructor & Destructor Documentation

CommandType::CommandType ( )

CommandType::CommandType ( UINT8 incoming_byte )

Member Function Documentation

void CommandType::Clear ( ) [inline]

UINT8 CommandType::Get ( ) const [inline]

CommandType::Type CommandType::GetType ( ) const

void CommandType::SetType ( Type type )

The documentation for this class was generated from the following files:
  • Apc/CommandType.hpp
  • Apc/CommandType.cpp
Generated on Wed Jan 25 01:06:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CommonSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CommonSignalMapTableNode Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/CommonSignalMapTableNode.hpp>

Inheritance diagram for CommonSignalMapTableNode:

[legend]
Collaboration diagram for CommonSignalMapTableNode:

[legend]

Static Public Member Functions

static CommonSignalMapTableNode * GetInstance ()

Member Function Documentation

CommonSignalMapTableNode * CommonSignalMapTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/CommonSignalMapTableNode.hpp
  • Apc/SignalHandler/CommonSignalMapTableNode.cpp
Generated on Wed Jan 25 01:06:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CommonSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CommonSignalProcessor Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/CommonSignalProcessor.hpp>

Collaboration diagram for CommonSignalProcessor:

[legend]

Static Public Member Functions

static void | PostAcmMaxReadInd (const ProcessPtr &process_ptr)
static void | PostAcmMaxUpdInd (const ProcessPtr &process_ptr)
static void | PostAcmReadInd (const ProcessPtr &process_ptr)
static void | PostAcmUpdInd (const ProcessPtr &process_ptr)
static void | PostAocInd (const ProcessPtr &process_ptr)
static void | PostAtAccessoryRegisterReq (const ProcessPtr &process_ptr)
static void | PostAtAlphaTagReq (const ProcessPtr &process_ptr)
static void | PostAtGenericCmdReq (const ProcessPtr &process_ptr)
static void | PostAtKeyReq (const ProcessPtr &process_ptr)
static void | PostAtPbListReq (const ProcessPtr &process_ptr)
static void | PostAtPbSelectReq (const ProcessPtr &process_ptr)
static void | PostAttachAllowedInd (const ProcessPtr &process_ptr)
static void | PostAttachCnf (const ProcessPtr &process_ptr)
static void | PostAttachRej (const ProcessPtr &process_ptr)
static void | PostAudDriverRsp (const ProcessPtr &process_ptr)
static void | PostAutoCallRestrictInd (const ProcessPtr &process_ptr)
static void | PostBandCnf (const ProcessPtr &process_ptr)
static void | PostBandRej (const ProcessPtr &process_ptr)
static void | PostBdnInd (const ProcessPtr &process_ptr)
static void | PostBrowserTermRes (const ProcessPtr &process_ptr)
static void | PostCallControlSetupInd (const ProcessPtr &process_ptr)
static void | PostCallControlSsInd (const ProcessPtr &process_ptr)
static void | PostCallControlUssdInd (const ProcessPtr &process_ptr)
static void | PostCallDeflectionInd (const ProcessPtr &process_ptr)
static void | PostCallDiscInd (const ProcessPtr &process_ptr)
static void | PostCallHoldCnf (const ProcessPtr &process_ptr)
static void | PostCallHoldRej (const ProcessPtr &process_ptr)
static void | PostCallProgressInd (const ProcessPtr &process_ptr)
static void | PostCallRelatedSsCnf (const ProcessPtr &process_ptr)
static void | PostCallRelatedSsRej (const ProcessPtr &process_ptr)
static void | PostCallRelCnf (const ProcessPtr &process_ptr)
static void | PostCallRelInd (const ProcessPtr &process_ptr)
static void | PostCbmiReadInd (const ProcessPtr &process_ptr)
static void | PostCbmirReadInd (const ProcessPtr &process_ptr)
static void | PostCbmirUpdInd (const ProcessPtr &process_ptr)
static void | PostCbmiUpdInd (const ProcessPtr &process_ptr)
static void | PostCbsLimitInd (const ProcessPtr &process_ptr)
static void | PostCbsNewDataInd (const ProcessPtr &process_ptr)
static void | PostCbsStartCnf (const ProcessPtr &process_ptr)
static void | PostCbsStartRej (const ProcessPtr &process_ptr)
static void | PostCbsStopCnf (const ProcessPtr &process_ptr)
static void | PostCbsStopRej (const ProcessPtr &process_ptr)
static void | PostCcpReadInd (const ProcessPtr &process_ptr)
static void | PostCcpUpdInd (const ProcessPtr &process_ptr)
static void | PostCellInfoInd (const ProcessPtr &process_ptr)
static void | PostCfuDataInd (const ProcessPtr &process_ptr)
static void | PostChargeInd (const ProcessPtr &process_ptr)
static void | PostChargeUnitsInd (const ProcessPtr &process_ptr)
static void | PostChv1DisableInd (const ProcessPtr &process_ptr)
static void | PostChv1EnableInd (const ProcessPtr &process_ptr)
static void | PostChvChangeInd (const ProcessPtr &process_ptr)
static void | PostChvRefreshInd (const ProcessPtr &process_ptr)
static void | PostChvUnblockInd (const ProcessPtr &process_ptr)
static void | PostChvVerifyInd (const ProcessPtr &process_ptr)
static void | PostClearBlacklistCnf (const ProcessPtr &process_ptr)
static void | PostCmiReadInd (const ProcessPtr &process_ptr)
static void | PostConnectionInd (const ProcessPtr &process_ptr)
static void | PostCphsCfufReadInd (const ProcessPtr &process_ptr)
static void | PostCphsCfufUpdInd (const ProcessPtr &process_ptr)
static void | PostCphsCspReadInd (const ProcessPtr &process_ptr)
static void | PostCphsCspUpdInd (const ProcessPtr &process_ptr)
static void | PostCphsIstReadInd (const ProcessPtr &process_ptr)
static void | PostCphsOnmReadInd (const ProcessPtr &process_ptr)
static void | PostCphsOnsReadInd (const ProcessPtr &process_ptr)
static void | PostCphsVmwfReadInd (const ProcessPtr &process_ptr)
static void | PostCphsVmwfUpdInd (const ProcessPtr &process_ptr)
static void | PostDetachCnf (const ProcessPtr &process_ptr)
static void | PostDiagnosticInd (const ProcessPtr &process_ptr)
static void | PostDisplayTextReq (const ProcessPtr &process_ptr)
static void | PostDtmfBufferClearedInd (const ProcessPtr &process_ptr)
static void | PostEccListInd (const ProcessPtr &process_ptr)
static void | PostEctCnf (const ProcessPtr &process_ptr)
static void | PostEndSimToolkitInd (const ProcessPtr &process_ptr)
static void | PostEngineeringModeControlResponse (const ProcessPtr &process_ptr)
static void | PostExtProactiveCmdInd (const ProcessPtr &process_ptr)
static void | PostFdnInd (const ProcessPtr &process_ptr)
static void | PostGetInkeyReq (const ProcessPtr &process_ptr)
static void | PostGetInputReq (const ProcessPtr &process_ptr)
static void | PostGetTermProfileCnfInd (const ProcessPtr &process_ptr)
static void | PostGprsClassInd (const ProcessPtr &process_ptr)
static void | PostHomezoneInd (const ProcessPtr &process_ptr)
static void | PostIconDescReadInd (const ProcessPtr &process_ptr)
static void | PostImageReadInd (const ProcessPtr &process_ptr)
static void | PostImeiReadInd (const ProcessPtr &process_ptr)
static void | PostKbdtControl (const ProcessPtr &process_ptr)
static void | PostLanguageNotificationInd (const ProcessPtr &process_ptr)
static void | PostLanguageSettingReq (const ProcessPtr &process_ptr)
static void | PostLaunchBrowserPromptReq (const ProcessPtr &process_ptr)
static void | PostLaunchBrowserReq (const ProcessPtr &process_ptr)
static void | PostMdhDeregistrationCnf (const ProcessPtr &process_ptr)
static void | PostMdhMakeViewCnf (const ProcessPtr &process_ptr)
static void | PostMdhNewMessageInd (const ProcessPtr &process_ptr)
static void | PostMdhNewStatusReportInd (const ProcessPtr &process_ptr)
static void | PostMdhRegistrationCnf (const ProcessPtr &process_ptr)
static void | PostMdhRemoveViewCnf (const ProcessPtr &process_ptr)
static void | PostMdhSetConfigCnf (const ProcessPtr &proess_ptr)
static void | PostMdhSetStorageCnf (const ProcessPtr &process_ptr)
static void | PostMdhSmsConcRefNumInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsDeletionInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsExtendedDataInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsInitFinishedInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsReadInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsRefreshInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsReportReadInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsStatusInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsStorageRefreshInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsTransmitInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsTransmitStartInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsTransmitStopInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsUpdStatusInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsUpdStatusRefreshInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsWaitingInd (const ProcessPtr &process_ptr)
static void | PostMdhSmsWriteCnf (const ProcessPtr &process_ptr)
static void | PostMenuSelectionRej (const ProcessPtr &process_ptr)
static void | PostMnInformationInd (const ProcessPtr &process_ptr)
static void | PostMocAlertInd (const ProcessPtr &process_ptr)
static void | PostMocSetupAcc (const ProcessPtr &process_ptr)
static void | PostMocSetupCnf (const ProcessPtr &process_ptr)
static void | PostMocSetupRej (const ProcessPtr &process_ptr)
static void | PostMptyCnf (const ProcessPtr &process_ptr)
static void | PostMtcAcceptRej (const ProcessPtr &process_ptr)
static void | PostMtcConfInd (const ProcessPtr &process_ptr)
static void | PostMtcSetupCompl (const ProcessPtr &process_ptr)
static void | PostMtcSetupInd (const ProcessPtr &process_ptr)
static void | PostNotifyInd (const ProcessPtr &process_ptr)
static void | PostNRegStateInd (const ProcessPtr &process_ptr)
static void | PostODyn2ReadInd (const ProcessPtr &process_ptr)
static void | PostODyn2UpdInd (const ProcessPtr &process_ptr)
static void | PostODynReadInd (const ProcessPtr &process_ptr)
static void | PostODynUpdInd (const ProcessPtr &process_ptr)
static void | PostOmBandStatusCnf (const ProcessPtr &process_ptr)
static void | PostOmControlInd (const ProcessPtr &process_ptr)
static void | PostOmMultiSlotCnf (const ProcessPtr &process_ptr)
static void | PostOmMultiSlotRej (const ProcessPtr &process_ptr)
static void | PostOmRatChangeCnf (const ProcessPtr &process_ptr)
static void | PostOmRatChangeInd (const ProcessPtr &process_ptr)
static void | PostPbCountInd (const ProcessPtr &process_ptr)
static void | PostPbEntryReadInd (const ProcessPtr &process_ptr)
static void | PostPbEntryUpdInd (const ProcessPtr &process_ptr)
static void | PostPbInfoReadInd (const ProcessPtr &process_ptr)
static void | PostPinDisableInd (const ProcessPtr &process_ptr)
static void | PostPinEnableInd (const ProcessPtr &process_ptr)
static void | PostPlayToneReq (const ProcessPtr &process_ptr)
static void | PostPlmnListCnf (const ProcessPtr &process_ptr)
static void | PostPlmnListRej (const ProcessPtr &process_ptr)
static void | PostPowerDownCnf (const ProcessPtr &process_ptr)
static void | PostPowerDownInd (const ProcessPtr &process_ptr)
static void | PostPrefExtLangReadInd (const ProcessPtr &process_ptr)
static void | PostPrefExtLangUpdInd (const ProcessPtr &process_ptr)
static void | PostPrefLangReadInd (const ProcessPtr &process_ptr)
static void | PostPrefLangUpdInd (const ProcessPtr &process_ptr)
static void | PostPuctReadInd (const ProcessPtr &process_ptr)
static void | PostPuctUpdInd (const ProcessPtr &process_ptr)
static void | PostRedialInd (const ProcessPtr &process_ptr)
static void | PostRedialQueryInd (const ProcessPtr &process_ptr)
static void | PostRedialSetupInd (const ProcessPtr &process_ptr)
static void | PostRedialStatusInd (const ProcessPtr &process_ptr)
static void | PostRedialStopInd (const ProcessPtr &process_ptr)
static void | PostRegStateInd (const ProcessPtr &process_ptr)
static void | PostSelectItemReq (const ProcessPtr &process_ptr)
static void | PostSetTermProfileCnfInd (const ProcessPtr &process_ptr)
static void | PostSetTermProfileRejInd (const ProcessPtr &process_ptr)
static void | PostSetupEventReq (const ProcessPtr &process_ptr)
static void | PostSetupIdleModeTextReq (const ProcessPtr &process_ptr)
static void | PostSetupMenuReq (const ProcessPtr &process_ptr)
static void | PostSignalStrengthLevelInd (const ProcessPtr &process_ptr)
static void | PostSimErrorInd (const ProcessPtr &process_ptr)
static void | PostSimFileInfoInd (const ProcessPtr &process_ptr)
static void | PostSimFullAccessInd (const ProcessPtr &process_ptr)
static void | PostSimGenericInd (const ProcessPtr &process_ptr)
static void | PostSimInfoInd (const ProcessPtr &process_ptr)
static void | PostSimInitInd (const ProcessPtr &process_ptr)
static void | PostSimLockStatusInd (const ProcessPtr &process_ptr)
static void | PostSimMccMncInd (const ProcessPtr &process_ptr)
static void | PostSimModifyLockInd (const ProcessPtr &process_ptr)
static void | PostSimMruPropertyRefreshInd (const ProcessPtr &process_ptr)
static void | PostSimMruPropertyUpdCnf (const ProcessPtr &process_ptr)
static void | PostSimRefreshInd (const ProcessPtr &process_ptr)
static void | PostSimTkCallSetupInd (const ProcessPtr &process_ptr)
static void | PostSimTkInterfaceInd (const ProcessPtr &process_ptr)
static void | PostSimTkRefreshCnfReq (const ProcessPtr &process_ptr)
static void | PostSimTkRefreshNewReq (const ProcessPtr &process_ptr)
static void | PostSimTkRefreshQueryReq (const ProcessPtr &process_ptr)
static void | PostSimTkRefreshReq (const ProcessPtr &process_ptr)
static void | PostSimTkRefreshResetReq (const ProcessPtr &process_ptr)
static void | PostSimTkResetCnf (const ProcessPtr &process_ptr)
static void | PostSimTkResetCnfReq (const ProcessPtr &process_ptr)
static void | PostSimTkRunAtCmdInfoInd (const ProcessPtr &process_ptr)
static void | PostSimTkSendDtmfEndInd (const ProcessPtr &process_ptr)
static void | PostSimTkSendDtmfInd (const ProcessPtr &process_ptr)
static void | PostSimTkSmsPpInd (const ProcessPtr &process_ptr)
static void | PostSimTkSsInd (const ProcessPtr &process_ptr)
static void | PostSmsCapacityAvailable (const ProcessPtr &process_ptr)
static void | PostSmsCapacityExceeded (const ProcessPtr &process_ptr)
static void | PostSmsControlInd (const ProcessPtr &process_ptr)
static void | PostSmsGetMoreMessageStatusInd (const ProcessPtr &process_ptr)
static void | PostSmsrReadInd (const ProcessPtr &process_ptr)
static void | PostSmsrUpdInd (const ProcessPtr &process_ptr)
static void | PostSmsSendCnf (const ProcessPtr &process_ptr)
static void | PostSmsSendRej (const ProcessPtr &process_ptr)
static void | PostSpnReadInd (const ProcessPtr &process_ptr)
static void | PostSsBarringInd (const ProcessPtr &process_ptr)
static void | PostSsBeginAcc (const ProcessPtr &process_ptr)
static void | PostSsCauseInd (const ProcessPtr &process_ptr)
static void | PostSsCcbsReCallInd (const ProcessPtr &process_ptr)
static void | PostSsCcbsResultInd (const ProcessPtr &process_ptr)
static void | PostSsCcbsStatusInd (const ProcessPtr &process_ptr)
static void | PostSsClientRej (const ProcessPtr &process_ptr)
static void | PostSsDataInd (const ProcessPtr &process_ptr)
static void | PostSsEndInd (const ProcessPtr &process_ptr)
static void | PostSsErrInd (const ProcessPtr &process_ptr)
static void | PostSsFacilityRej (const ProcessPtr &process_ptr)
static void | PostSsForwardingInd (const ProcessPtr &process_ptr)
static void | PostSsForwcheckInd (const ProcessPtr &process_ptr)
static void | PostSsGetPasswordInd (const ProcessPtr &process_ptr)
static void | PostSsGetPasswordRej (const ProcessPtr &process_ptr)
static void | PostSsInterrogateInd (const ProcessPtr &process_ptr)
static void | PostSsNotifyInd (const ProcessPtr &process_ptr)
static void | PostSsPasswordInd (const ProcessPtr &process_ptr)
static void | PostSsRej (const ProcessPtr &process_ptr)
static void | PostSsRetResInd (const ProcessPtr &process_ptr)
static void | PostSstReadInd (const ProcessPtr &process_ptr)
static void | PostSsUnstructInd (const ProcessPtr &process_ptr)
static void | PostSsUssdInd (const ProcessPtr &process_ptr)
static void | PostSsUssdResentInd (const ProcessPtr &process_ptr)
static void | PostStartDtmfCnf (const ProcessPtr &process_ptr)
static void | PostStartDtmfRej (const ProcessPtr &process_ptr)
static void | PostStopDtmfCnf (const ProcessPtr &process_ptr)
static void | PostTermRspCnf (const ProcessPtr &process_ptr)
static void | PostTestparamInd (const ProcessPtr &process_ptr)
static void | PostUrrcSignalStrengthLevelInd (const ProcessPtr &process_ptr)

Detailed Description

CommonSignalProcessor is the gsm97/gprs-common translation unit, which generates (and posts) internal APOXI messages out of an incoming SDL signals.

Member Function Documentation

void CommonSignalProcessor::PostAcmMaxReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAcmMaxUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAcmReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAcmUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAocInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAtAccessoryRegisterReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAtAlphaTagReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAtGenericCmdReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAtKeyReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAtPbListReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAtPbSelectReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAttachAllowedInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAttachCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAttachRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAudDriverRsp ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostAutoCallRestrictInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostBandCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostBandRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostBdnInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostBrowserTermRes ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallControlSetupInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallControlSsInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallControlUssdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallDeflectionInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallDiscInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallHoldCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallHoldRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallProgressInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallRelatedSsCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallRelatedSsRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallRelCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCallRelInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbmiReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbmirReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbmirUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbmiUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbsLimitInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbsNewDataInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbsStartCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbsStartRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbsStopCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCbsStopRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCcpReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCcpUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCellInfoInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCfuDataInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostChargeInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostChargeUnitsInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostChv1DisableInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostChv1EnableInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostChvChangeInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostChvRefreshInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostChvUnblockInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostChvVerifyInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostClearBlacklistCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCmiReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostConnectionInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsCfufReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsCfufUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsCspReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsCspUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsIstReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsOnmReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsOnsReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsVmwfReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostCphsVmwfUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostDetachCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostDiagnosticInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostDisplayTextReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostDtmfBufferClearedInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostEccListInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostEctCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostEndSimToolkitInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostEngineeringModeControlResponse ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostExtProactiveCmdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostFdnInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostGetInkeyReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostGetInputReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostGetTermProfileCnfInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostGprsClassInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostHomezoneInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostIconDescReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostImageReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostImeiReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostKbdtControl ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostLanguageNotificationInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostLanguageSettingReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostLaunchBrowserPromptReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostLaunchBrowserReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhDeregistrationCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhMakeViewCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhNewMessageInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhNewStatusReportInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhRegistrationCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhRemoveViewCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSetConfigCnf ( const ProcessPtr & proess_ptr ) [static]

void CommonSignalProcessor::PostMdhSetStorageCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsConcRefNumInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsDeletionInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsExtendedDataInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsInitFinishedInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsRefreshInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsReportReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsStatusInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsStorageRefreshInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsTransmitInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsTransmitStartInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsTransmitStopInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsUpdStatusInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsUpdStatusRefreshInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsWaitingInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMdhSmsWriteCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMenuSelectionRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMnInformationInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMocAlertInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMocSetupAcc ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMocSetupCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMocSetupRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMptyCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMtcAcceptRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMtcConfInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMtcSetupCompl ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostMtcSetupInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostNotifyInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostNRegStateInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostODyn2ReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostODyn2UpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostODynReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostODynUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostOmBandStatusCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostOmControlInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostOmMultiSlotCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostOmMultiSlotRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostOmRatChangeCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostOmRatChangeInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPbCountInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPbEntryReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPbEntryUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPbInfoReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPinDisableInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPinEnableInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPlayToneReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPlmnListCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPlmnListRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPowerDownCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPowerDownInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPrefExtLangReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPrefExtLangUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPrefLangReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPrefLangUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPuctReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostPuctUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostRedialInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostRedialQueryInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostRedialSetupInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostRedialStatusInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostRedialStopInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostRegStateInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSelectItemReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSetTermProfileCnfInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSetTermProfileRejInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSetupEventReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSetupIdleModeTextReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSetupMenuReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSignalStrengthLevelInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimErrorInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimFileInfoInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimFullAccessInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimGenericInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimInfoInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimInitInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimLockStatusInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimMccMncInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimModifyLockInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimMruPropertyRefreshInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimMruPropertyUpdCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimRefreshInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkCallSetupInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkInterfaceInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkRefreshCnfReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkRefreshNewReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkRefreshQueryReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkRefreshReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkRefreshResetReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkResetCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkResetCnfReq ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkRunAtCmdInfoInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkSendDtmfEndInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkSendDtmfInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkSmsPpInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSimTkSsInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSmsCapacityAvailable ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSmsCapacityExceeded ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSmsControlInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSmsGetMoreMessageStatusInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSmsrReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSmsrUpdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSmsSendCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSmsSendRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSpnReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsBarringInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsBeginAcc ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsCauseInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsCcbsReCallInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsCcbsResultInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsCcbsStatusInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsClientRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsDataInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsEndInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsErrInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsFacilityRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsForwardingInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsForwcheckInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsGetPasswordInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsGetPasswordRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsInterrogateInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsNotifyInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsPasswordInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsRetResInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSstReadInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsUnstructInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsUssdInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostSsUssdResentInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostStartDtmfCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostStartDtmfRej ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostStopDtmfCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostTermRspCnf ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostTestparamInd ( const ProcessPtr & process_ptr ) [static]

void CommonSignalProcessor::PostUrrcSignalStrengthLevelInd ( const ProcessPtr & process_ptr ) [static]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/CommonSignalProcessor.hpp
  • Apc/SignalHandler/AtcSignalProcessor.cpp
  • Apc/SignalHandler/AtSignalProcessor.cpp
  • Apc/SignalHandler/AudioSignalProcessor.cpp
  • Apc/SignalHandler/CallMiscSignalProcessor.cpp
  • Apc/SignalHandler/CbsSignalProcessor.cpp
  • Apc/SignalHandler/ChvSignalProcessor.cpp
  • Apc/SignalHandler/CrssSignalProcessor.cpp
  • Apc/SignalHandler/ImageSignalProcessor.cpp
  • Apc/SignalHandler/MdhSignalProcessor.cpp
  • Apc/SignalHandler/MiscSignalProcessor.cpp
  • Apc/SignalHandler/MocSignalProcessor.cpp
  • Apc/SignalHandler/MtcSignalProcessor.cpp
  • Apc/SignalHandler/NetworkSignalProcessor.cpp
  • Apc/SignalHandler/OmSignalProcessor.cpp
  • Apc/SignalHandler/PhoneBookSignalProcessor.cpp
  • Apc/SignalHandler/PlmnSignalProcessor.cpp
  • Apc/SignalHandler/PowerSignalProcessor.cpp
  • Apc/SignalHandler/SimMiscSignalProcessor.cpp
  • Apc/SignalHandler/SimTkSignalProcessor.cpp
  • Apc/SignalHandler/SmsSignalProcessor.cpp
  • Apc/SignalHandler/SsCcbsSignalProcessor.cpp
  • Apc/SignalHandler/SsSignalProcessor.cpp
Generated on Wed Jan 25 01:07:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CommonStackMsgArgsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CommonStackMsgArgsDestroyTableNode Class Reference

#include <Apoxi/Apc/CommonStackMsgArgs.hpp>

Inheritance diagram for CommonStackMsgArgsDestroyTableNode:

[legend]
Collaboration diagram for CommonStackMsgArgsDestroyTableNode:

[legend]

Static Public Member Functions

static CommonStackMsgArgsDestroyTableNode * GetInstance ()

Member Function Documentation

CommonStackMsgArgsDestroyTableNode * CommonStackMsgArgsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Apc/CommonStackMsgArgs.hpp
  • Apc/CommonStackMsgArgs.cpp
Generated on Wed Jan 25 01:07:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CommonStackMsgMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CommonStackMsgMapTableNode Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/CommonStackMsgMapTableNode.hpp>

Inheritance diagram for CommonStackMsgMapTableNode:

[legend]
Collaboration diagram for CommonStackMsgMapTableNode:

[legend]

Static Public Member Functions

static CommonStackMsgMapTableNode * GetInstance ()

Member Function Documentation

CommonStackMsgMapTableNode * CommonStackMsgMapTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/CommonStackMsgMapTableNode.hpp
  • Apc/SignalHandler/CommonStackMsgMapTableNode.cpp
Generated on Wed Jan 25 01:07:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CommonStackMsgProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CommonStackMsgProcessor Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/CommonStackMsgProcessor.hpp>

Inheritance diagram for CommonStackMsgProcessor:

[legend]
Collaboration diagram for CommonStackMsgProcessor:

[legend]

Static Public Member Functions

static void | ProcessAcmMaxReadReq (const StackMsgArgument &arg)
static void | ProcessAcmMaxUpdReq (const StackMsgArgument &arg)
static void | ProcessAcmReadReq (const StackMsgArgument &arg)
static void | ProcessAcmUpdReq (const StackMsgArgument &arg)
static void | ProcessAtAccessoryNotificationInd (const StackMsgArgument &arg)
static void | ProcessAtAccessoryRegisterCnf (const StackMsgArgument &arg)
static void | ProcessAtAlphaTagCnf (const StackMsgArgument &arg)
static void | ProcessAtGenericCmdInd (const StackMsgArgument &arg)
static void | ProcessAtPbInfoInd (const StackMsgArgument &arg)
static void | ProcessAtPbListCnf (const StackMsgArgument &arg)
static void | ProcessAtPbSelectCnf (const StackMsgArgument &arg)
static void | ProcessAttachReq (const StackMsgArgument &arg)
static void | ProcessBandSelectionReq (const StackMsgArgument &arg)
static void | ProcessBdnReq (const StackMsgArgument &arg)
static void | ProcessBrowserRegisterReq (const StackMsgArgument &arg)
static void | ProcessBrowserTermEvent (const StackMsgArgument &arg)
static void | ProcessCallDeflectSsReq (const StackMsgArgument &arg)
static void | ProcessCallDiscReq (const StackMsgArgument &arg)
static void | ProcessCallRelatedSsReq (const StackMsgArgument &arg)
static void | ProcessCbmiReadReq (const StackMsgArgument &arg)
static void | ProcessCbmirReadReq (const StackMsgArgument &arg)
static void | ProcessCbmirUpdReq (const StackMsgArgument &arg)
static void | ProcessCbmiUpdReq (const StackMsgArgument &arg)
static void | ProcessCbsNewDataRej (const StackMsgArgument &arg)
static void | ProcessCbsStartReq (const StackMsgArgument &arg)
static void | ProcessCbsStopReq (const StackMsgArgument &arg)
static void | ProcessCcpReadReq (const StackMsgArgument &arg)
static void | ProcessCcpUpdReq (const StackMsgArgument &arg)
static void | ProcessChargeReq (const StackMsgArgument &arg)
static void | ProcessChargeUnitsReq (const StackMsgArgument &arg)
static void | ProcessChv1DisableReq (const StackMsgArgument &arg)
static void | ProcessChv1EnableReq (const StackMsgArgument &arg)
static void | ProcessChvChangeReq (const StackMsgArgument &arg)
static void | ProcessChvUnblockReq (const StackMsgArgument &arg)
static void | ProcessChvVerifyReq (const StackMsgArgument &arg)
static void | ProcessClearBlacklistReq (const StackMsgArgument &arg)
static void | ProcessClientDeregistration (const StackMsgArgument &arg)
static void | ProcessClientRegistration (const StackMsgArgument &arg)
static void | ProcessCmiReadReq (const StackMsgArgument &arg)
static void | ProcessControlHwDataOnlyReq (const StackMsgArgument &arg)
static void | ProcessCphsCfufReadReq (const StackMsgArgument &arg)
static void | ProcessCphsCfufUpdReq (const StackMsgArgument &arg)
static void | ProcessCphsCspReadReq (const StackMsgArgument &arg)
static void | ProcessCphsCspUpdReq (const StackMsgArgument &arg)
static void | ProcessCphsIstReadReq (const StackMsgArgument &arg)
static void | ProcessCphsOnmReadReq (const StackMsgArgument &arg)
static void | ProcessCphsOnsReadReq (const StackMsgArgument &arg)
static void | ProcessCphsVmwfReadReq (const StackMsgArgument &arg)
static void | ProcessCphsVmwfUpdReq (const StackMsgArgument &arg)
static void | ProcessDetachReq (const StackMsgArgument &arg)
static void | ProcessDhChannelChangeStatusEvent (const StackMsgArgument &arg)
static void | ProcessDhChannelCloseInd (const StackMsgArgument &arg)
static void | ProcessDhChannelDataAvailEvent (const StackMsgArgument &arg)
static void | ProcessDhChannelOpenCnf (const StackMsgArgument &arg)
static void | ProcessDhChannelOpenRej (const StackMsgArgument &arg)
static void | ProcessDhChannelReceiveInd (const StackMsgArgument &arg)
static void | ProcessDhChannelSendInd (const StackMsgArgument &arg)
static void | ProcessDisplayTextRsp (const StackMsgArgument &arg)
static void | ProcessEngineeringModeControlRequest (const StackMsgArgument &arg)
static void | ProcessExtProactiveCmdCnf (const StackMsgArgument &arg)
static void | ProcessExtProactiveCmdReq (const StackMsgArgument &arg)
static void | ProcessFdnReq (const StackMsgArgument &arg)
static void | ProcessGetInkeyRsp (const StackMsgArgument &arg)
static void | ProcessGetInputRsp (const StackMsgArgument &arg)
static void | ProcessGprsClassReq (const StackMsgArgument &arg)
static void | ProcessIconDescReadReq (const StackMsgArgument &arg)
static void | ProcessIdleScreenAvailEvent (const StackMsgArgument &arg)
static void | ProcessImageReadReq (const StackMsgArgument &arg)
static void | ProcessImeiReadReq (const StackMsgArgument &arg)
static void | ProcessLanguageSelectEvent (const StackMsgArgument &arg)
static void | ProcessLanguageSettingInd (const StackMsgArgument &arg)
static void | ProcessLaunchBrowserInd (const StackMsgArgument &arg)
static void | ProcessLaunchBrowserPromptInd (const StackMsgArgument &arg)
static void | ProcessMdhDeregistrationReq (const StackMsgArgument &arg)
static void | ProcessMdhMakeViewReq (const StackMsgArgument &arg)
static void | ProcessMdhRegistrationReq (const StackMsgArgument &arg)
static void | ProcessMdhRemoveViewReq (const StackMsgArgument &arg)
static void | ProcessMdhSetConfigReq (const StackMsgArgument &arg)
static void | ProcessMdhSetStorageReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsConcRefNumReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsDeletionReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsExtendedDataReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsReadReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsReportReadReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsSetWaitingReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsStatusReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsTransmitAck (const StackMsgArgument &arg)
static void | ProcessMdhSmsTransmitStartAck (const StackMsgArgument &arg)
static void | ProcessMdhSmsUpdStatusReq (const StackMsgArgument &arg)
static void | ProcessMdhSmsWriteReq (const StackMsgArgument &arg)
static void | ProcessMenuSelectionReq (const StackMsgArgument &arg)
static void | ProcessMnNetworkSearchModeReq (const StackMsgArgument &arg)
static void | ProcessMnTriggerReq (const StackMsgArgument &arg)
static void | ProcessMocSetupReq (const StackMsgArgument &arg)
static void | ProcessMtcAccept (const StackMsgArgument &arg)
static void | ProcessMtcAlertReq (const StackMsgArgument &arg)
static void | ProcessODyn2ReadReq (const StackMsgArgument &arg)
static void | ProcessODyn2UpdReq (const StackMsgArgument &arg)
static void | ProcessODynReadReq (const StackMsgArgument &arg)
static void | ProcessODynUpdReq (const StackMsgArgument &arg)
static void | ProcessOmBandStatusReq (const StackMsgArgument &arg)
static void | ProcessOmFactoryResetInd (const StackMsgArgument &arg)
static void | ProcessOmGetTermProfileReq (const StackMsgArgument &arg)
static void | ProcessOmMultiSlotReq (const StackMsgArgument &arg)
static void | ProcessOmPowerUp (const StackMsgArgument &arg)
static void | ProcessOmRatChangeReq (const StackMsgArgument &arg)
static void | ProcessOmSetTermProfileReq (const StackMsgArgument &arg)
static void | ProcessPbCountReq (const StackMsgArgument &arg)
static void | ProcessPbEntryReadReq (const StackMsgArgument &arg)
static void | ProcessPbEntryUpdReq (const StackMsgArgument &arg)
static void | ProcessPbInfoReadReq (const StackMsgArgument &arg)
static void | ProcessPinDisableReq (const StackMsgArgument &arg)
static void | ProcessPinEnableReq (const StackMsgArgument &arg)
static void | ProcessPlayToneRsp (const StackMsgArgument &arg)
static void | ProcessPlmnInfoReq (const StackMsgArgument &arg)
static void | ProcessPlmnListAbort (const StackMsgArgument &arg)
static void | ProcessPlmnListReq (const StackMsgArgument &arg)
static void | ProcessPowerDownReq (const StackMsgArgument &arg)
static void | ProcessPrefExtLangReadReq (const StackMsgArgument &arg)
static void | ProcessPrefExtLangUpdReq (const StackMsgArgument &arg)
static void | ProcessPrefLangReadReq (const StackMsgArgument &arg)
static void | ProcessPrefLangUpdReq (const StackMsgArgument &arg)
static void | ProcessPrefPlmnChange (const StackMsgArgument &arg)
static void | ProcessPrefServiceSetReq (const StackMsgArgument &arg)
static void | ProcessPuctReadReq (const StackMsgArgument &arg)
static void | ProcessPuctUpdReq (const StackMsgArgument &arg)
static void | ProcessRedialingQueryReq (const StackMsgArgument &arg)
static void | ProcessRediallingDisabledInd (const StackMsgArgument &arg)
static void | ProcessRedialRej (const StackMsgArgument &arg)
static void | ProcessRejectCallsInd (const StackMsgArgument &arg)
static void | ProcessSelectItemRsp (const StackMsgArgument &arg)
static void | ProcessSetAutoCharge (const StackMsgArgument &arg)
static void | ProcessSetChargeUnits (const StackMsgArgument &arg)
static void | ProcessSetupEventCnf (const StackMsgArgument &arg)
static void | ProcessSetupIdleModeTextRsp (const StackMsgArgument &arg)
static void | ProcessSetupMenuRsp (const StackMsgArgument &arg)
static void | ProcessSiChannelCloseInfoRes (const StackMsgArgument &arg)
static void | ProcessSiChannelCloseReq (const StackMsgArgument &arg)
static void | ProcessSiChannelOpenPromptRes (const StackMsgArgument &arg)
static void | ProcessSiChannelReceiveInfoRes (const StackMsgArgument &arg)
static void | ProcessSiChannelSendInfoRes (const StackMsgArgument &arg)
static void | ProcessSimFileInfoReq (const StackMsgArgument &arg)
static void | ProcessSimGenericReq (const StackMsgArgument &arg)
static void | ProcessSimModifyLockReq (const StackMsgArgument &arg)
static void | ProcessSimMruPropertyUpdReq (const StackMsgArgument &arg)
static void | ProcessSimTkCallSetupAcc (const StackMsgArgument &arg)
static void | ProcessSimTkCallSetupRej (const StackMsgArgument &arg)
static void | ProcessSimTkRefreshCnfInd (const StackMsgArgument &arg)
static void | ProcessSimTkRefreshNewRsp (const StackMsgArgument &arg)
static void | ProcessSimTkRefreshQueryRes (const StackMsgArgument &arg)
static void | ProcessSimTkRefreshResetRsp (const StackMsgArgument &arg)
static void | ProcessSimTkRefreshRsp (const StackMsgArgument &arg)
static void | ProcessSimTkResetCnfInd (const StackMsgArgument &arg)
static void | ProcessSimTkRunAtCmdInfoRes (const StackMsgArgument &arg)
static void | ProcessSimTkSendDtmfCnf (const StackMsgArgument &arg)
static void | ProcessSimTkSmsPpRsp (const StackMsgArgument &arg)
static void | ProcessSimTkSsRsp (const StackMsgArgument &arg)
static void | ProcessSimTkStopSendDtmfReq (const StackMsgArgument &arg)
static void | ProcessSmsConfigIndArg (const StackMsgArgument &arg)
static void | ProcessSmsGetMoreMessageStatusReq (const StackMsgArgument &arg)
static void | ProcessSmsrReadReq (const StackMsgArgument &arg)
static void | ProcessSmsrUpdReq (const StackMsgArgument &arg)
static void | ProcessSmsSendReq (const StackMsgArgument &arg)
static void | ProcessSmsSetMoreMessageReq (const StackMsgArgument &arg)
static void | ProcessSpnReadReq (const StackMsgArgument &arg)
static void | ProcessSsCcbsInvoke (const StackMsgArgument &arg)
static void | ProcessSsCcbsReCallRequest (const StackMsgArgument &arg)
static void | ProcessSsCcbsReject (const StackMsgArgument &arg)
static void | ProcessSsErrReq (const StackMsgArgument &arg)
static void | ProcessSsGetPasswordRsp (const StackMsgArgument &arg)
static void | ProcessSsRejReq (const StackMsgArgument &arg)
static void | ProcessSsSendEndReq (const StackMsgArgument &arg)
static void | ProcessSsSendReq (const StackMsgArgument &arg)
static void | ProcessSstReadReq (const StackMsgArgument &arg)
static void | ProcessSsUssdReq (const StackMsgArgument &arg)
static void | ProcessStartDtmfReq (const StackMsgArgument &arg)
static void | ProcessStartSignalStrengthListening (const StackMsgArgument &arg)
static void | ProcessStopBatteryLoadListening (const StackMsgArgument &arg)
static void | ProcessStopDtmfReq (const StackMsgArgument &arg)
static void | ProcessStopSignalStrengthListening (const StackMsgArgument &arg)
static void | ProcessTestparamReq (const StackMsgArgument &arg)
static void | ProcessUserActivityEvent (const StackMsgArgument &arg)

Detailed Description

CommonStackMsgProcessor is the gsm97/gprs-common translation unit, which generates (and sends) SDL signals into the SDL environment out of an internal APOXI messages.

Member Function Documentation

void CommonStackMsgProcessor::ProcessAcmMaxReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAcmMaxUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAcmReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAcmUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAtAccessoryNotificationInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAtAccessoryRegisterCnf ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAtAlphaTagCnf ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAtGenericCmdInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAtPbInfoInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAtPbListCnf ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAtPbSelectCnf ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessAttachReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessBandSelectionReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessBdnReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessBrowserRegisterReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessBrowserTermEvent ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCallDeflectSsReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCallDiscReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCallRelatedSsReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCbmiReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCbmirReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCbmirUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCbmiUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCbsNewDataRej ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCbsStartReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCbsStopReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCcpReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCcpUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessChargeReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessChargeUnitsReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessChv1DisableReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessChv1EnableReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessChvChangeReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessChvUnblockReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessChvVerifyReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessClearBlacklistReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessClientDeregistration ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessClientRegistration ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCmiReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessControlHwDataOnlyReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsCfufReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsCfufUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsCspReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsCspUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsIstReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsOnmReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsOnsReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsVmwfReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessCphsVmwfUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessDetachReq ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessDhChannelChangeStatusEvent ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessDhChannelCloseInd ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessDhChannelDataAvailEvent ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessDhChannelOpenCnf ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessDhChannelOpenRej ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessDhChannelReceiveInd ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessDhChannelSendInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessDisplayTextRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessEngineeringModeControlRequest ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessExtProactiveCmdCnf ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessExtProactiveCmdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessFdnReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessGetInkeyRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessGetInputRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessGprsClassReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessIconDescReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessIdleScreenAvailEvent ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessImageReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessImeiReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessLanguageSelectEvent ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessLanguageSettingInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessLaunchBrowserInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessLaunchBrowserPromptInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhDeregistrationReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhMakeViewReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhRegistrationReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhRemoveViewReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSetConfigReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSetStorageReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsConcRefNumReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsDeletionReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsExtendedDataReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsReportReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsSetWaitingReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsStatusReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsTransmitAck ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsTransmitStartAck ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsUpdStatusReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMdhSmsWriteReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMenuSelectionReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMnNetworkSearchModeReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMnTriggerReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMocSetupReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMtcAccept ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessMtcAlertReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessODyn2ReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessODyn2UpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessODynReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessODynUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessOmBandStatusReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessOmFactoryResetInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessOmGetTermProfileReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessOmMultiSlotReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessOmPowerUp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessOmRatChangeReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessOmSetTermProfileReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPbCountReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPbEntryReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPbEntryUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPbInfoReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPinDisableReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPinEnableReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPlayToneRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPlmnInfoReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPlmnListAbort ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPlmnListReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPowerDownReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPrefExtLangReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPrefExtLangUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPrefLangReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPrefLangUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPrefPlmnChange ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPrefServiceSetReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPuctReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessPuctUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessRedialingQueryReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessRediallingDisabledInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessRedialRej ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessRejectCallsInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSelectItemRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSetAutoCharge ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSetChargeUnits ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSetupEventCnf ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSetupIdleModeTextRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSetupMenuRsp ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessSiChannelCloseInfoRes ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessSiChannelCloseReq ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessSiChannelOpenPromptRes ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessSiChannelReceiveInfoRes ( const StackMsgArgument & arg ) [static]

static void CommonStackMsgProcessor::ProcessSiChannelSendInfoRes ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimFileInfoReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimGenericReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimModifyLockReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimMruPropertyUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkCallSetupAcc ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkCallSetupRej ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkRefreshCnfInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkRefreshNewRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkRefreshQueryRes ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkRefreshResetRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkRefreshRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkResetCnfInd ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkRunAtCmdInfoRes ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkSendDtmfCnf ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkSmsPpRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkSsRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSimTkStopSendDtmfReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSmsConfigIndArg ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSmsGetMoreMessageStatusReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSmsrReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSmsrUpdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSmsSendReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSmsSetMoreMessageReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSpnReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsCcbsInvoke ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsCcbsReCallRequest ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsCcbsReject ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsErrReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsGetPasswordRsp ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsRejReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsSendEndReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsSendReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSstReadReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessSsUssdReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessStartDtmfReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessStartSignalStrengthListening ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessStopBatteryLoadListening ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessStopDtmfReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessStopSignalStrengthListening ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessTestparamReq ( const StackMsgArgument & arg ) [static]

void CommonStackMsgProcessor::ProcessUserActivityEvent ( const StackMsgArgument & arg ) [static]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/CommonStackMsgProcessor.hpp
  • Apc/SignalHandler/AtcStackMsgProcessor.cpp
  • Apc/SignalHandler/CallMiscStackMsgProcessor.cpp
  • Apc/SignalHandler/CbsStackMsgProcessor.cpp
  • Apc/SignalHandler/ChvStackMsgProcessor.cpp
  • Apc/SignalHandler/CrssStackMsgProcessor.cpp
  • Apc/SignalHandler/ImageStackMsgProcessor.cpp
  • Apc/SignalHandler/MdhStackMsgProcessor.cpp
  • Apc/SignalHandler/MiscStackMsgProcessor.cpp
  • Apc/SignalHandler/MocStackMsgProcessor.cpp
  • Apc/SignalHandler/MtcStackMsgProcessor.cpp
  • Apc/SignalHandler/NetworkStackMsgProcessor.cpp
  • Apc/SignalHandler/OmStackMsgProcessor.cpp
  • Apc/SignalHandler/PhoneBookStackMsgProcessor.cpp
  • Apc/SignalHandler/PlmnStackMsgProcessor.cpp
  • Apc/SignalHandler/PowerStackMsgProcessor.cpp
  • Apc/SignalHandler/SimMiscStackMsgProcessor.cpp
  • Apc/SignalHandler/SimTkStackMsgProcessor.cpp
  • Apc/SignalHandler/SmsStackMsgProcessor.cpp
  • Apc/SignalHandler/SsCcbsStackMsgProcessor.cpp
  • Apc/SignalHandler/SsStackMsgProcessor.cpp
  • Apc/SignalHandler/StatusHandlerProcessor.cpp
  • Apc/SignalHandler/StatusStackMsgProcessor.cpp
Generated on Wed Jan 25 01:07:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Component Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Component Class Reference
[Components]

#include <Apoxi/Gui/Component.hpp>

Inheritance diagram for Component:

[legend]
Collaboration diagram for Component:

[legend]

Public Types

enum | { ID = 7 }

Public Member Functions

void | AdjustParent (Control *parent)
Component (const View *view, Control *parent=0)
Component ()
void | DeleteLater ()
const Rect & | GetBoundingRect () const
virtual XYDIM | GetDefaultHeight () const
virtual XYDIM | GetDefaultWidth () const
XYDIM | GetHeight () const
INT | GetId () const
Model * | GetModel () const
Control * | GetParent () const
Point | GetPos () const
Size | GetSize () const
const View * | GetView () const
XYDIM | GetWidth () const
XYDIM | GetXPos () const
XYDIM | GetYPos () const
void | Init (const View *view, Control *parent=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetBoundingRect (XYDIM left, XYDIM top, XYDIM right, XYDIM bottom)
void | SetBoundingRect (const Rect &bounds)
void | SetHeight (XYDIM height)
void | SetId (INT id)
virtual void | SetParent (Control *parent)=0
void | SetPos (XYDIM x, XYDIM y)
void | SetPos (const Point &pos)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetSize (XYDIM width, XYDIM height)
void | SetSize (const Size &size)
void | SetWidth (XYDIM width)
void | SetXPos (XYDIM x_pos)
void | SetYPos (XYDIM y_pos)
virtual | ~Component ()

Protected Member Functions

virtual void | Cleanup ()
virtual Model * | CreateModel () const
virtual void | OnLanguageChanged ()=0
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnMove (XYDIM dx, XYDIM dy)
Is called, if the Component has been moved.
virtual void | OnResize (XYDIM dx, XYDIM dy)
Is called, if the Component has been resized.
virtual void | OnThemeChanged ()=0
virtual void | Refresh (const Rect &rect)
void | SetModel (Model *model)
void | SetView (const View *view)

Protected Attributes

const View * | m_abstract_view

Detailed Description

A Component is a graphical object restricted by a bounding rectangle, which can be modified in position and size in different manners. Every component a pointer to a view. The view defines the look of the component and changes dynamically, when the theme has been changed. Every component might have a model, which is useful for complex components which share behaviour but need different implementations for getting and setting data.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

Component::Component ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

Component::Component | ( | const View * | view,
 |  | Control * | parent = 0
 | ) |

Parameters:
view | Pointer to the view which is used for drawing the component.
parent | Parent control which embeds the component.

Component::~Component ( ) [virtual]

Member Function Documentation

void Component::AdjustParent ( Control * parent ) [inline]

Sets the parent-property to parent, without detaching the component from the old parent or attaching it to the new parent. It is recommended to use the method Control::SetParent in applications, but for special usecases where e. g. one instance of a component is a child of several parents, this method might be useful.

void Component::Cleanup ( ) [protected, virtual]

Is invoked, when the component gets invisible e. g. when the parent-window which contains the component is closed.

Reimplemented in MultiMediaEditor, SvgPlayer, Menu, AbstractEditor, AbstractItemGrid, AnimatedTextLine, ContextMenu, Control, ImageBox, ItemBox, ItemMenu, and ItemTree.

Model * Component::CreateModel ( ) const [protected, virtual]

Factory method for creating a model. Must be implemented by every class, which needs it's own model. By default a component has no model and 0 is returned. If a model is dynamically created by 'new', it must be deleted in the destructor by e. g. delete GetModel();.

Returns:
Pointer to the model.

Reimplemented in MultiMediaEditor, Animation, CheckBox, CheckBoxList, DateEditBox, EditBox, Grid, MenuList, ProviderListBox, RadioButtonList, TextList, TimeEditBox, DateEditor, IpAddrEditor, LineEditor, MultiLineEditor, PasswordEditor, TimeEditor, and EmsEditor.

void Component::DeleteLater ( )

Performs a deferred deletion of the component. The deletion will be done in the next idle state of the scheduler. Invoking this method is recommended e. g. if a window is created dynamically and should be deleted when closing the window. By overwriting Window::OnClose and invoking DeleteLater this can be done in a safe way (invoking 'delete this' inside Window::OnClose is not allowed!).

const Rect& Component::GetBoundingRect ( ) const [inline]

Returns:
Bounding rectangle.

XYDIM Component::GetDefaultHeight ( ) const [virtual]

Returns:
Default height of the object. If no default height has been specified, -1 is returned. Usually the default height is defined by the view object of the component.

Reimplemented in SvgPlayer, SelectionBox, StrokeBox, T9PinyinBox, Zi8AlphabetBox, Zi8SelectionBox, Zi8StrokeBox, Animation, ImageBox, ItemBox, LineEditor, and Window.

XYDIM Component::GetDefaultWidth ( ) const [virtual]

Returns:
Default width of the object. If no default width has been specified, -1 is returned. Usually the default width is defined by the view object of the component.

Reimplemented in SvgPlayer, Animation, ImageBox, ItemBox, and Window.

XYDIM Component::GetHeight ( ) const [inline]

Returns:
Height of the bounding rectangle.

Reimplemented in SvgPlayer.

INT Component::GetId ( ) const [inline]

Returns the unique ID available for each instance which has been generated by Aragon. Per default -1 is returned, which means that the instance has not been generated by Aragon. Don't mix the the unique ID with the RTTI provided by Component::IsInstanceOf.

Model * Component::GetModel ( ) const

Returns:
Pointer to the corresponding model.

Control* Component::GetParent ( ) const [inline]

Returns:
Pointer to the parent control. If the control is a root-control, 0 is returned. It is assured, that a root-control is an instance of the class Window.

Point Component::GetPos ( ) const [inline]

Returns:
Position of the upper left edge.

Size Component::GetSize ( ) const [inline]

Returns:
Size of the bounding rectangle.

const View* Component::GetView ( ) const [inline]

Returns:
Pointer to the corresponding view.

Reimplemented in AbstractEditBox, DateEditBox, EditBox, IndicatorBar, and TimeEditBox.

XYDIM Component::GetWidth ( ) const [inline]

Returns:
Width of the bounding rectangle.

Reimplemented in SvgPlayer.

XYDIM Component::GetXPos ( ) const [inline]

Returns:
x-position of the upper left edge.

XYDIM Component::GetYPos ( ) const [inline]

Returns:
y-position of the upper left edge.

void Component::Init | ( | const View * | view,
 |  | Control * | parent = 0
 | ) |

Parameters:
view | Pointer to the view which is used for drawing the component.
parent | Parent control which embeds the component.

BOOLEAN Component::IsInstanceOf ( INT id ) const [virtual]

Returns TRUE, if the component is an instance of the component-class with the ID id. Must be implemented by each derived class the following way:

BOOLEAN MyComponent::IsInstanceOf(INT id) const
{
    if (ID != id)
        return Base::IsInstanceOf(id);
    return TRUE;
}

Example: if it should be checked, whether an item is an instance of the class Window the following code might be used:

if (comp->IsInstanceOf(Window::ID)) {
    Window* win = (Window*)win;
    ...
}

The following ID ranges are reserved:

  • 0 to 999: APOXI
  • 1000 to 1999: Reference MMI and Applications
  • 2000 to 49999: Customer Projects
  • 50000 to 65535: 3rd Pary Applications (see GuiIDs.pdf for details)

Reimplemented in MultiMediaEditor, AtlWindow, AtlItemGridWindow, AtlItemListWindow, AtlItemMenuWindow, AbstractButton, AbstractEditor, AbstractGrid, AbstractItemGrid, AbstractLineEditor, AbstractMultiLineEditor, AbstractTextObject, Alert, AnimatedTextLine, CheckBoxControl, ContextMenu, Control, DateEditor, DrawableObject, FlowLayout, GridLayout, ImageBox, IpAddrEditor, ItemBox, ItemGrid, ItemMenu, ItemTree, LineEditor, MessageBox, MultiLineEditor, Panel, PasswordEditor, PositionIndicator, ProgressBar, PushButton, RadioButtonControl, TabButton, TabControl, TextBox, TextLine, TimeEditor, and Window.

virtual void Component::OnLanguageChanged ( ) [protected, pure virtual]

Is called, after the language has been changed. Overwrite this method when the component contains strings which should get retranslated. Don't forget to invoke the base method.

Implemented in AtlWindow, CheckBox, CheckBoxList, Menu, MenuList, RadioButtonList, SoftkeyBar, AbstractButton, AbstractItemGrid, AbstractTextObject, Control, DrawableObject, TabControl, and Window.

BOOLEAN Component::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage()

Implements Dispatcher.

Reimplemented in SvgPlayer, T9PredictiveInputBox, Zi8PredictiveInputBox, AtlWindow, AtlItemBox, AtlItemGridWindow, AtlItemMenuWindow, AtlLabelListWindow, AtlItemGrid, AtlItemMenu, IndicatorBar, Menu, SoftkeyBar, AbstractButton, AbstractEditor, AbstractItemGrid, Alert, ContextMenu, DrawableObject, ImageBox, ItemBox, ItemTree, TabControl, Window, SavingProgressWin, and UibFolderWin.

void Component::OnMove | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

Is called, if the Component has been moved.

Reimplemented in Control, DrawableObject, ImageBox, and Window.

void Component::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

Is called, if the Component has been resized.

Reimplemented in AbstractListBox, AbstractItemGrid, AbstractMultiLineEditor, AnimatedTextLine, Control, DrawableObject, ImageBox, ItemBox, and Window.

virtual void Component::OnThemeChanged ( ) [protected, pure virtual]

Is called, after the theme has been changed. Overwrite this method if the component has a theme dependant view. Don't forget to invoke the base method.

Implemented in AtlWindow, AbstractEditBox, AbstractListBox, Animation, CheckBox, CheckBoxList, Grid, MenuList, RadioButtonList, SoftkeyBar, TextList, AbstractGrid, AbstractItemGrid, AbstractTextObject, CheckBoxControl, Control, DrawableObject, FlowLayout, GridLayout, MultiLineEditor, Panel, PositionIndicator, ProgressBar, PushButton, RadioButtonControl, TabButton, TabControl, and Window.

void Component::Refresh ( const Rect & rect ) [protected, virtual]

Is invoked, before the component gets visible e. g. when the parent-window which contains the component is opened.

Reimplemented in MultiMediaEditor, AtlItemBox, AbstractEditBox, AbstractListBox, CheckBox, CheckBoxList, Grid, Menu, MenuList, RadioButtonList, TextList, AbstractEditor, AbstractGrid, AbstractItemGrid, AbstractMultiLineEditor, AnimatedTextLine, CheckBoxControl, ContextMenu, Control, DateEditor, ImageBox, ItemBox, ItemMenu, ItemTree, PushButton, RadioButtonControl, TabButton, TabControl, and Window.

void Component::SetBoundingRect | ( | XYDIM | left,
 |  | XYDIM | top,
 |  | XYDIM | right,
 |  | XYDIM | bottom
 | ) |

Parameters:
left | Position of the left edge of the bounding rectangle.
top | Position of the top edge of the bounding rectangle.
right | Position of the right edge of the bounding rectangle.
bottom | Position of the bottom edge of the bounding rectangle.

void Component::SetBoundingRect ( const Rect & bounds )

Parameters:
bounds Bounding rectangle.

void Component::SetHeight ( XYDIM height )

Parameters:
height Height of the bounding rectangle.

Reimplemented in SvgPlayer, and Grid.

void Component::SetId ( INT id ) [inline]

Sets the unique ID (used by Aragon).

void Component::SetModel ( Model * model ) [inline, protected]

Changes the model during runtime. If a model has been created dynamically inside Component::CreateModel it must be deleted before invoking Component::SetModel. Generally it is recommended to change the content of the model instead of changing the model itself.

See also:
CreateModel

virtual void Component::SetParent ( Control * parent ) [pure virtual]

Embeds the component as part of the Control parent and removes it from the current parent.

Implemented in Control, and DrawableObject.

void Component::SetPos | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

Parameters:
x | x-position of the upper left edge.
y | y-position of the upper left edge.

void Component::SetPos ( const Point & pos )

Parameters:
pos Position of the upper left edge.

BOOLEAN Component::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented in MultiMediaEditor, AtlWindow, AbstractButton, AbstractEditor, AbstractGrid, AbstractItemGrid, AbstractLineEditor, AbstractMultiLineEditor, AbstractTextObject, Alert, AnimatedTextLine, CheckBoxControl, ContextMenu, Control, DateEditor, DrawableObject, FlowLayout, GridLayout, ImageBox, IpAddrEditor, ItemBox, ItemGrid, ItemMenu, ItemTree, LineEditor, MessageBox, MultiLineEditor, PasswordEditor, PositionIndicator, ProgressBar, PushButton, RadioButtonControl, TabButton, TabControl, TextBox, TextLine, TimeEditor, and Window.

void Component::SetSize | ( | XYDIM | width,
 |  | XYDIM | height
 | ) |

Parameters:
width | Width of the bounding rectangle.
height | Height of the bounding rectangle.

Reimplemented in Grid.

void Component::SetSize ( const Size & size )

Parameters:
Size of the bounding rectangle.

Reimplemented in Grid.

void Component::SetView ( const View * view ) [inline, protected]

Sets the view for the component. Usually this is done once when the component is constructed and each time the theme has been changed (see Component::OnLanguageChanged).

void Component::SetWidth ( XYDIM width )

Parameters:
width Width of the bounding rectangle.

Reimplemented in SvgPlayer, and Grid.

void Component::SetXPos ( XYDIM x_pos )

Parameters:
x x-position of the upper left edge.

void Component::SetYPos ( XYDIM y_pos )

Parameters:
y y-position of the upper left edge.

Field Documentation

const View* Component::m_abstract_view [protected]

m_abstract_view is protected and not private for backward-compatibility with older APOXI-versions. It is strongly recommended to use Component::SetView() and Component::GetView() instead of direct accessing to m_abstract_view.

The documentation for this class was generated from the following files:
  • Gui/Component.hpp
  • Gui/Component.cpp
Generated on Wed Jan 25 01:07:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CompoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CompoundItem Class Reference
[Editors]

#include <Apoxi/Gui/CompoundItem.hpp>

Inheritance diagram for CompoundItem:

[legend]
Collaboration diagram for CompoundItem:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

virtual void | Clear ()
Removes and deletes all continued items and clears the contained data.
virtual CompoundItem * | Clone () const
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const =0
virtual INT | GetId () const
virtual INT | GetItemCount () const =0
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const =0
virtual XYDIM | GetLineWidth (INT index, INT count) const =0
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual BOOLEAN | Merge (const CompoundItem &compound_item)
virtual void | ReleaseInstance ()
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | Split (INT index, CompoundItem **compound_item)
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=EditorDocument::WhitespaceWrap) const =0
virtual | ~CompoundItem ()

Protected Member Functions

CompoundItem ()

Detailed Description

A compound-item may contain one ore more abstract editor-items. The editor-document is responsible for the administration of the compound-items and takes care of merging and deleting inserted and modified compound-items. Therefor the creating of a compound-item may not be done by the constructor, but by CompoundItem::CreateInstance, which is provided by each derived class. Note that the compound-item may store the items in an optimized format (e. g. character-items may be stored as WString-object instead of a vector of character-items), hence methods for getting the content of a compound-item must be defined in the derived classes.
See also:
AtomItem

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CompoundItem::~CompoundItem ( ) [virtual]

CompoundItem::CompoundItem ( ) [protected]

Member Function Documentation

void CompoundItem::Clear ( ) [virtual]

Removes and deletes all continued items and clears the contained data.

Reimplemented in GeneralCompoundItem, ParagraphCompoundItem, and TextCompoundItem.

CompoundItem * CompoundItem::Clone ( ) const [virtual]

Makes a clone of the compound item. As soon as the cloned compound item is inserted into an editor document it is obtained by the editor document and hence may not be modified or accessed outside the scope of the editor document anymore. If the cloned compound item is not inserted to an editor document, it must be deleted manually if not needed anymore.

Returns:
Pointer to the cloned compound item. 0 is returned if the cloning was not successful. Per default 0 is returned; it is recommended that derived classes implement the method Clone, but it is no requirement.

Reimplemented in GeneralCompoundItem, ParagraphCompoundItem, RichTextCompoundItem, and TextCompoundItem.

virtual void CompoundItem::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [pure virtual]

Parameters:
dc | Device-Context for drawing.
x | x-position in pixels.
y | y-position in pixels.
index | Index of item, where the drawing should start.
count | Number of items counted from index which should be drawn.

Implemented in GeneralCompoundItem, ParagraphCompoundItem, ParagraphMarker, RichTextCompoundItem, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

INT CompoundItem::GetId ( ) const [virtual]

Returns:
Unique ID of the item.

Implements AbstractEditorItem.

Reimplemented in GeneralCompoundItem, ParagraphCompoundItem, ParagraphMarker, RichTextCompoundItem, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

virtual INT CompoundItem::GetItemCount ( ) const [pure virtual]

Returns:
The number of Items inside the compound item. The interface for accessing the Items is defined by derived classes.

Implemented in GeneralCompoundItem, ParagraphCompoundItem, ParagraphMarker, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

virtual XYDIM CompoundItem::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [pure virtual]

Parameters:
basiline Output parameter which contains the baseline, if the pointer is not zero.
Returns:
The needed height of a line for count Items starting at the Item with the index index.

Implemented in GeneralCompoundItem, ParagraphCompoundItem, ParagraphMarker, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

virtual XYDIM CompoundItem::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [pure virtual]

Returns:
The needed width of a line for count Items starting at the Item with the index index.

Implemented in GeneralCompoundItem, ParagraphCompoundItem, ParagraphMarker, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

BOOLEAN CompoundItem::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

Inserts the Item item before the item with the index index.

Returns:
TRUE, if inserting is supported and successful. Per default FALSE is returned for the implementation of the class CompoundItem.

Reimplemented in GeneralCompoundItem, ParagraphCompoundItem, and TextCompoundItem.

BOOLEAN CompoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Implements AbstractEditorItem.

Reimplemented in GeneralCompoundItem, ParagraphCompoundItem, ParagraphMarker, RichTextCompoundItem, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

BOOLEAN CompoundItem::Merge ( const CompoundItem & compound_item ) [virtual]

Merges the compound item with another compound item by appending the other compound item to itself.

Parameters:
compound_item compound item, which should be appended at the end of this compound item.
Returns:
TRUE, if the merge has been sucessful. FALSE is returned, when merging generally is not supported or the type of the compound item is not supported for the merge-process. Per default FALSE is returned for the implementation of the class CompoundItem.

Reimplemented in GeneralCompoundItem, RichTextCompoundItem, and TextCompoundItem.

void CompoundItem::ReleaseInstance ( ) [virtual]

Releases any allocated resources from the compound-item and deletes the object.

BOOLEAN CompoundItem::RemoveItem ( INT index = -1 ) [virtual]

Removes the Item with the index index.

Returns:
TRUE, if removing is supported and successful. Per default FALSE is returned for the implementation of the class CompoundItem.

Reimplemented in GeneralCompoundItem, ParagraphCompoundItem, and TextCompoundItem.

BOOLEAN CompoundItem::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

Replaces the Item with the index index by the item item.

Returns:
TRUE, if replacing is supported and successful. Per default FALSE is returned for the implementation of the class CompoundItem.

Reimplemented in GeneralCompoundItem, ParagraphCompoundItem, and TextCompoundItem.

BOOLEAN CompoundItem::Split | ( | INT | index,
 |  | CompoundItem ** | compound_item
 | ) | [virtual]

Splits the compound item in two parts. The second compound item will contain at least one Item, otherwise FALSE is returned.

Parameters:
index | Index of Item, where the split should occur. The Item which matches to the index will be part of the second compound item.
compound_item | Output parameter. Points to the second compound item.
Returns:
TRUE, if splitting is allowed. FALSE is also returned when the index is zero or indicates the last Item of the compound item. Per default FALSE is returned for the implementation of the class CompoundItem.

Reimplemented in GeneralCompoundItem, ParagraphCompoundItem, RichTextCompoundItem, and TextCompoundItem.

virtual INT CompoundItem::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = EditorDocument::WhitespaceWrap
 | ) | const [pure virtual]

Wraps a line of a compound item corresponding to the wrap policy and returns the number of items which may get drawn.

Parameters:
index | Start index of the item, where the wrapping should be started.
width | Available width in pixels, where the items should be wrapped into.
wrap_policy | The wrapping policy describes how the wrapping inside the available width is done (
See also:
EditorDocument::WrapPolicy)

Implemented in GeneralCompoundItem, ParagraphCompoundItem, ParagraphMarker, DateCompoundItem, IpAddrCompoundItem, TextCompoundItem, and TimeCompoundItem.

The documentation for this class was generated from the following files:
  • Gui/CompoundItem.hpp
  • Gui/CompoundItem.cpp
Generated on Wed Jan 25 01:07:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CompoundItemIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CompoundItemIterator Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/MultiMediaEditorDocument.hpp>

Collaboration diagram for CompoundItemIterator:

[legend]

Public Member Functions

BOOLEAN | Begin ()
CompoundItemIterator (const MultiMediaEditorDocument *doc)
const CompoundItem * | Get (INT *start_index=0) const
BOOLEAN | Next ()
virtual | ~CompoundItemIterator ()

Data Structures

struct | Node

Detailed Description

Allows to iterate over all compound items of a multimedia editor document.

Constructor & Destructor Documentation

CompoundItemIterator::CompoundItemIterator ( const MultiMediaEditorDocument * doc )

Provides the iterator with the document and automatically sets the iterator to the begin.

CompoundItemIterator::~CompoundItemIterator ( ) [virtual]

Member Function Documentation

BOOLEAN CompoundItemIterator::Begin ( )

Resets the iterator to the begin of the document. CompoundItem::Get returns the first compound item if CompoundItemIterator::Begin returned TRUE. Use CompoundItemIterator::Next for moving the iterator to the next item.

Returns:
FALSE is returned, if the document contains no compound items.

const CompoundItem * CompoundItemIterator::Get ( INT * start_index = 0 ) const

Returns a pointer to the current compound item. 0 is only returned, if CompoundItemIterator::Begin or CompoundItemIterator::Next returned 0.

Parameters:
start_index Optional output parameter which contains the start item index of the compound item in relation to the document.

BOOLEAN CompoundItemIterator::Next ( )

Sets the iterator to the next compound item of the document. The current compound item can be retrieved by CompoundItemIterator::Get.

Returns:
FALSE is returned, if no next compound item exists.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/MultiMediaEditorDocument.hpp
  • AddOns/MultiMedia/MultiMediaEditorDocument.cpp
Generated on Wed Jan 25 01:07:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CompoundItemReferrer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CompoundItemReferrer Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/CompoundItemReferrer.hpp>

Collaboration diagram for CompoundItemReferrer:

[legend]

Public Member Functions

CompoundItemReferrer (INT start_index=0, CompoundItem *compound_item=0)
CompoundItem * | GetCompoundItem () const
INT | GetCount () const
Wrapper-method for getting the number of items of the compound-item.
INT | GetStartIndex () const
void | SetCompoundItem (CompoundItem *compound_item)
void | SetStartIndex (INT index)

Detailed Description

Stores the start-index of a Compound-Item related to the document and a pointer to the Compound-Item. By having a Compound-Item-Referrer for each Compound-Item a fast access is possible when only an item-index for the document is given and the corresponding Compound-Item must be accessed.

Constructor & Destructor Documentation

CompoundItemReferrer::CompoundItemReferrer | ( | INT | start_index = 0,
 |  | CompoundItem * | compound_item = 0
 | ) | [explicit]

Member Function Documentation

CompoundItem* CompoundItemReferrer::GetCompoundItem ( ) const [inline]

INT CompoundItemReferrer::GetCount ( ) const [inline]

Wrapper-method for getting the number of items of the compound-item.

INT CompoundItemReferrer::GetStartIndex ( ) const [inline]

void CompoundItemReferrer::SetCompoundItem ( CompoundItem * compound_item ) [inline]

void CompoundItemReferrer::SetStartIndex ( INT index ) [inline]

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/CompoundItemReferrer.hpp
  • AddOns/MultiMedia/CompoundItemReferrer.cpp
Generated on Wed Jan 25 01:07:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CompoundSmsItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CompoundSmsItem Class Reference
[Middle Layer]

#include <Apoxi/Adc/CompoundSmsItem.hpp>

Inheritance diagram for CompoundSmsItem:

[legend]
Collaboration diagram for CompoundSmsItem:

[legend]

Public Member Functions

CompoundSmsItem (SimPduHandler *handler, SmsFilterType filter_type, INT recno)
objects are created internally by the SMS providers
virtual GenericObject * | Copy () const
Creates a copy of the object itself, must be overwritten in the derived class.
BOOLEAN | GetBaseInformationElement (BaseInformationElement &ie)
get the next BaseInformationElement defined in APC
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class, must be overwritten by the derived class.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself, must be overwritten in the derived class.
BOOLEAN | StartIteration ()
start iteration
virtual | ~CompoundSmsItem ()

Constructor & Destructor Documentation

CompoundSmsItem::CompoundSmsItem | ( | SimPduHandler * | handler,
 |  | SmsFilterType | filter_type,
 |  | INT | recno
 | ) |

objects are created internally by the SMS providers

CompoundSmsItem::~CompoundSmsItem ( ) [virtual]

Member Function Documentation

GenericObject * CompoundSmsItem::Copy ( ) const [virtual]

Creates a copy of the object itself, must be overwritten in the derived class.

Implements GenericObject.

BOOLEAN CompoundSmsItem::GetBaseInformationElement ( BaseInformationElement & ie )

get the next BaseInformationElement defined in APC

GenericTypeId CompoundSmsItem::GetTypeId ( ) [virtual]

Returns the identity of the class, must be overwritten by the derived class.

Implements GenericObject.

BOOLEAN CompoundSmsItem::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object instance itself, must be overwritten in the derived class.

Implements GenericObject.

BOOLEAN CompoundSmsItem::StartIteration ( )

start iteration

The documentation for this class was generated from the following files:
  • Adc/CompoundSmsItem.hpp
  • Adc/CompoundSmsItem.cpp
Generated on Wed Jan 25 01:07:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CompoundTpduItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CompoundTpduItem Class Reference
[Middle Layer]

#include <Apoxi/Adc/CompoundSmsItem.hpp>

Inheritance diagram for CompoundTpduItem:

[legend]
Collaboration diagram for CompoundTpduItem:

[legend]

Public Member Functions

CompoundTpduItem (SimPduHandler *handler, SmsFilterType filter_type, INT recno)
virtual GenericObject * | Copy () const
Creates a copy of the object itself, must be overwritten in the derived class.
BOOLEAN | GetTpdu (Tpdu &tpdu, INT &tpduno)
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class, must be overwritten by the derived class.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself, must be overwritten in the derived class.
BOOLEAN | LoadFirstTpdu ()
BOOLEAN | LoadNextTpdu ()
BOOLEAN | WriteTpdu (const Tpdu &tpdu, INT tpduno)
virtual | ~CompoundTpduItem ()

Constructor & Destructor Documentation

CompoundTpduItem::CompoundTpduItem | ( | SimPduHandler * | handler,
 |  | SmsFilterType | filter_type,
 |  | INT | recno
 | ) |

CompoundTpduItem::~CompoundTpduItem ( ) [virtual]

Member Function Documentation

GenericObject * CompoundTpduItem::Copy ( ) const [virtual]

Creates a copy of the object itself, must be overwritten in the derived class.

Implements GenericObject.

BOOLEAN CompoundTpduItem::GetTpdu | ( | Tpdu & | tpdu,
 |  | INT & | tpduno
 | ) |

GenericTypeId CompoundTpduItem::GetTypeId ( ) [virtual]

Returns the identity of the class, must be overwritten by the derived class.

Implements GenericObject.

BOOLEAN CompoundTpduItem::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object instance itself, must be overwritten in the derived class.

Implements GenericObject.

BOOLEAN CompoundTpduItem::LoadFirstTpdu ( )

BOOLEAN CompoundTpduItem::LoadNextTpdu ( )

BOOLEAN CompoundTpduItem::WriteTpdu | ( | const Tpdu & | tpdu,
 |  | INT | tpduno
 | ) |

The documentation for this class was generated from the following files:
  • Adc/CompoundSmsItem.hpp
  • Adc/CompoundSmsItem.cpp
Generated on Wed Jan 25 01:07:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Condition Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Condition Class Reference
[Kernel]

#include <Apoxi/Kernel/Condition.hpp>

Inheritance diagram for Condition:

[legend]

Public Member Functions

Condition ()
virtual BOOLEAN | IsTrue () const =0
virtual | ~Condition ()

Detailed Description

Abstract class for an object representing a condition. E. g. AppContainer::Wait() takes usage of such a condition.

Constructor & Destructor Documentation

Condition::Condition ( )

Condition::~Condition ( ) [virtual]

Member Function Documentation

virtual BOOLEAN Condition::IsTrue ( ) const [pure virtual]

Implemented in BooleanCondition.

The documentation for this class was generated from the following files:
  • Kernel/Condition.hpp
  • Kernel/Condition.cpp
Generated on Wed Jan 25 01:07:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ConfirmAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ConfirmAction Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/ConfirmAction.hpp>

Inheritance diagram for ConfirmAction:

[legend]
Collaboration diagram for ConfirmAction:

[legend]

Public Member Functions

ConfirmAction (Control *control, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
ConfirmAction ()
virtual BOOLEAN | Execute ()
void | Init (Control *control, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
virtual | ~ConfirmAction ()

Detailed Description

Obsolete - it is planned to drop the method Control::OnConfirm as it can be replaced by simply using an Action and overwriting Control::OnActionExecuted instead.

Invokes Control::OnConfirm() of the specified Control. Before the Action can be executed, it must be provided with a pointer to the Control by the constructor or by the method Init.

Constructor & Destructor Documentation

ConfirmAction::ConfirmAction ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ConfirmAction::ConfirmAction | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

ConfirmAction::~ConfirmAction ( ) [virtual]

Member Function Documentation

BOOLEAN ConfirmAction::Execute ( ) [virtual]

Invokes Control::OnConfirm() of the Control, which was set with the constructor or the method Init.

Reimplemented from Action.

void ConfirmAction::Init | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

The documentation for this class was generated from the following files:
  • Compat/ConfirmAction.hpp
  • Compat/ConfirmAction.cpp
Generated on Wed Jan 25 01:07:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ConnectionIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ConnectionIndArg Class Reference

#include <Apoxi/Apc/NetworkStackMsgArgs.hpp>

Inheritance diagram for ConnectionIndArg:

[legend]
Collaboration diagram for ConnectionIndArg:

[legend]

Public Types

enum | { ID = 2180 }

Public Member Functions

ConnectionIndArg ()
BOOLEAN | IsConnected () const
BOOLEAN | IsEnciphered () const
void | SetConnected (BOOLEAN connected)
void | SetEnciphered (BOOLEAN enciphered)

Static Public Member Functions

static const ConnectionIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ConnectionIndArg: reflects arguments of signal MNMI_CONNECTION_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ConnectionIndArg::ConnectionIndArg ( )

Member Function Documentation

const ConnectionIndArg & ConnectionIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN ConnectionIndArg::IsConnected ( ) const [inline]

BOOLEAN ConnectionIndArg::IsEnciphered ( ) const [inline]

void ConnectionIndArg::SetConnected ( BOOLEAN connected ) [inline]

void ConnectionIndArg::SetEnciphered ( BOOLEAN enciphered ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/NetworkStackMsgArgs.hpp
  • Apc/NetworkStackMsgArgs.cpp
Generated on Wed Jan 25 01:07:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ConnectionStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ConnectionStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ConnectionStatusMsg:

[legend]
Collaboration diagram for ConnectionStatusMsg:

[legend]

Public Types

enum | { ID = 18413 }

Public Member Functions

virtual Message * | Clone () const
ConnectionStatusMsg (ExecutionContext *context, const ConnectionIndArg &arg)
const ConnectionIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const ConnectionIndArg &arg)
virtual | ~ConnectionStatusMsg ()

Detailed Description

ConnectionStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ConnectionStatusMsg::ConnectionStatusMsg | ( | ExecutionContext * | context,
 |  | const ConnectionIndArg & | arg
 | ) |

ConnectionStatusMsg::~ConnectionStatusMsg ( ) [virtual]

Member Function Documentation

Message * ConnectionStatusMsg::Clone ( ) const [virtual]

Implements Message.

const ConnectionIndArg& ConnectionStatusMsg::GetArg ( ) const [inline]

const MsgMetaData & ConnectionStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void ConnectionStatusMsg::SetArg ( const ConnectionIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:07:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextDescription Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextDescription Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/ContextDescription.hpp>

Collaboration diagram for ContextDescription:

[legend]

Public Member Functions

ContextDescription ()
const ContextID & | GetContextId ()
KeyMapping & GetKeyMap ()
const SoftkeyDesc & | GetSoftkeyDesc (INT sk_index)
const WString & | GetWindowTitle ()
void | Init (const ContextID &context_id, const WString &window_title)
void | Init (const ContextID &context_id)
void | SetSoftkeyDesc (INT sk_index, SoftkeyDesc sk_desc)
void | SetWindowTitle (const WString &title)
~ContextDescription ()

Detailed Description

A context description specifies a set of configurations for following user-experience elements:
  • Window title
  • Key maps
  • Features or context menus for the softkeys
  • Indicator configuration

Constructor & Destructor Documentation

ContextDescription::ContextDescription ( )

ContextDescription::~ContextDescription ( )

Member Function Documentation

const ContextID& ContextDescription::GetContextId ( ) [inline]

Returns:
ContextID for this description

KeyMapping& ContextDescription::GetKeyMap ( ) [inline]

Returns:
Keymap for this description

const SoftkeyDesc& ContextDescription::GetSoftkeyDesc ( INT sk_index ) [inline]

Parameters:
sk_index Index of softkey
Returns:
Softkey description

const WString& ContextDescription::GetWindowTitle ( ) [inline]

Returns:
Text for window title

void ContextDescription::Init | ( | const ContextID & | context_id,
 |  | const WString & | window_title
 | ) | [inline]

void ContextDescription::Init ( const ContextID & context_id ) [inline]

void ContextDescription::SetSoftkeyDesc | ( | INT | sk_index,
 |  | SoftkeyDesc | sk_desc
 | ) | [inline]

Parameters:
sk_index | Index of softkey
sk_desc | Softkey description

void ContextDescription::SetWindowTitle ( const WString & title ) [inline]

Parameters:
title Text for window title

The documentation for this class was generated from the following files:
  • Atl/Context/ContextDescription.hpp
  • Atl/Context/ContextDescription.cpp
Generated on Wed Jan 25 01:07:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextExecuteMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextExecuteMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ContextExecuteMsg:

[legend]
Collaboration diagram for ContextExecuteMsg:

[legend]

Public Types

enum | { ID = 3000 }
typedef void(* | CallbackFn )(void *)

Public Member Functions

virtual Message * | Clone () const
ContextExecuteMsg (ExecutionContext *context, const CallbackFn fn=0, void *arg=0)
virtual void | Execute ()
virtual const MsgMetaData & | GetMetaData () const
virtual | ~ContextExecuteMsg ()

Detailed Description

This message is an abstract message for any message that. should be executed in appliation context. The method should be implemented by the sender.

Member Typedef Documentation

typedef void(* ContextExecuteMsg::CallbackFn)(void *)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ContextExecuteMsg::ContextExecuteMsg | ( | ExecutionContext * | context,
 |  | const CallbackFn | fn = 0,
 |  | void * | arg = 0
 | ) |

ContextExecuteMsg::~ContextExecuteMsg ( ) [virtual]

Member Function Documentation

Message * ContextExecuteMsg::Clone ( ) const [virtual]

Implements Message.

Reimplemented in RegCbNotifyMsg.

void ContextExecuteMsg::Execute ( ) [virtual]

Reimplemented in RegCbNotifyMsg.

const MsgMetaData & ContextExecuteMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:07:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextFeature Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextFeature Class Reference
[APOXI Template Layer]

Special feature, which requires a context item as feature invocation argument. More...

#include <Apoxi/Atl/Features/ContextFeature.hpp>

Inheritance diagram for ContextFeature:

[legend]
Collaboration diagram for ContextFeature:

[legend]

Public Types

enum | { ID = 2 }
enum ContextType {
WStringType, NumberType, ItemTextType, PhoneNumberType,
ItemType, ProviderType, ContainerType, UndefinedType
}

Public Member Functions

ContextFeature (AtlApplication *app, const FeatureID &id)
ContextFeature ()
virtual BOOLEAN | Execute (const DataItem &data_item)
virtual BOOLEAN | Execute ()
ContextType | GetContextType () const
virtual INT | GetID () const
void | Init (AtlApplication *app, const FeatureID &id, ContextType contextType=ItemType)
virtual BOOLEAN | IsEqual (const Feature &feature) const
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetContextType (ContextType type)
virtual | ~ContextFeature ()

Detailed Description

Special feature, which requires a context item as feature invocation argument.

The documentation for this class was generated from the following files:
  • Atl/Features/ContextFeature.hpp
  • Atl/Features/ContextFeature.cpp
Generated on Wed Jan 25 01:07:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextFeatureHandle Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextFeatureHandle Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/ContextFeatureHandle.hpp>

Inheritance diagram for ContextFeatureHandle:

[legend]
Collaboration diagram for ContextFeatureHandle:

[legend]

Public Member Functions

ContextFeatureHandle (const AppFeatureID &id, const DataItem &contextitem, BOOLEAN fixed_context)
virtual void | Execute (AtlApplication *context_app=0) const
virtual | ~ContextFeatureHandle ()

Detailed Description

Context feature handle executes a context feature on behalf of the key manager
See also:
KeyManager

Constructor & Destructor Documentation

ContextFeatureHandle::ContextFeatureHandle | ( | const AppFeatureID & | id,
 |  | const DataItem & | contextitem,
 |  | BOOLEAN | fixed_context
 | ) |

ContextFeatureHandle::~ContextFeatureHandle ( ) [virtual]

Member Function Documentation

void ContextFeatureHandle::Execute ( AtlApplication * context_app = 0 ) const [virtual]

Retrieves the context feature from the feature broker and executes it, after feature-using application or plugin has set the context item, and feature-providing application or plugin has checked the state of the Feature.

Parameters:
context_app feature-providing application or plugin

Reimplemented from FeatureHandle.

The documentation for this class was generated from the following files:
  • Atl/Context/ContextFeatureHandle.hpp
  • Atl/Context/ContextFeatureHandle.cpp
Generated on Wed Jan 25 01:07:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextFeatureItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextFeatureItem Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/ContextFeatureItem.hpp>

Inheritance diagram for ContextFeatureItem:

[legend]
Collaboration diagram for ContextFeatureItem:

[legend]

Public Types

enum | { ID = 101 }
typedef FeatureItem | Base

Public Member Functions

ContextFeatureItem (ContextFeature *feature, const WString &text="", const ImageObtainer &icon=ImageObtainer(), BOOLEAN fixed_context=FALSE)
ContextFeatureItem (ContextFeature *feature, const WString &text="", BOOLEAN fixed_context=FALSE)
ContextFeatureItem ()
virtual BOOLEAN | Execute ()
const DataItem & | GetContextItem () const
ContextFeature::ContextType | GetContextType () const
virtual INT | GetID () const
void | Init (ContextFeature *feature, const WString &text="", const ImageObtainer &icon=ImageObtainer(), BOOLEAN fixed_context=FALSE)
void | Init (ContextFeature *feature, const WString &text="", BOOLEAN fixed_context=FALSE)
virtual BOOLEAN | IsFixedContext ()
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetContextItem (const DataItem &item)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual | ~ContextFeatureItem ()

Detailed Description

Context feature item wraps a context feature, which is a parameterizable piece of functionality provided by an application or plugin. The parameter, which is used when invoking the feature, is called context item. The context feature item specifies text and icon, in case the feature is displayed in a GUI element, as well as a particular context item as feature invocation argument.

Member Typedef Documentation

typedef FeatureItem ContextFeatureItem::Base

Reimplemented from FeatureItem.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from FeatureItem.

Constructor & Destructor Documentation

ContextFeatureItem::ContextFeatureItem ( )

ContextFeatureItem::ContextFeatureItem | ( | ContextFeature * | feature,
 |  | const WString & | text = "",
 |  | BOOLEAN | fixed_context = FALSE
 | ) |

ContextFeatureItem::ContextFeatureItem | ( | ContextFeature * | feature,
 |  | const WString & | text = "",
 |  | const ImageObtainer & | icon = ImageObtainer(),
 |  | BOOLEAN | fixed_context = FALSE
 | ) |

ContextFeatureItem::~ContextFeatureItem ( ) [virtual]

Member Function Documentation

BOOLEAN ContextFeatureItem::Execute ( ) [virtual]

Executes the wrapped context feature and passes the actual context item as parameter.

Returns:
Return value of the executed context feature.
See also:
ContextFeature

Reimplemented from FeatureItem.

const DataItem& ContextFeatureItem::GetContextItem ( ) const [inline]

Returns:
Context item of this context feature item

ContextFeature::ContextType ContextFeatureItem::GetContextType ( ) const

Returns:
Type information, which data type the feature-providing application or plugin expects for the context item

INT ContextFeatureItem::GetID ( ) const [virtual]

Returns:
returns the runtime type id of FeatureItemContainer

Reimplemented from FeatureItem.

void ContextFeatureItem::Init | ( | ContextFeature * | feature,
 |  | const WString & | text = "",
 |  | const ImageObtainer & | icon = ImageObtainer(),
 |  | BOOLEAN | fixed_context = FALSE
 | ) |

void ContextFeatureItem::Init | ( | ContextFeature * | feature,
 |  | const WString & | text = "",
 |  | BOOLEAN | fixed_context = FALSE
 | ) |

virtual BOOLEAN ContextFeatureItem::IsFixedContext ( ) [inline, virtual]

If the context item is fixed, it must not be updated after initialization. If not fixed, the framework will ensure that the feature-using application or plugin always updates the context item before it is actually executed.

BOOLEAN ContextFeatureItem::IsInstanceOf ( INT id ) const [virtual]

See also:
Item

Reimplemented from FeatureItem.

void ContextFeatureItem::SetContextItem ( const DataItem & item ) [inline]

Parameters:
item The context item of type DataItem specifies the feature invocation argument for the feature-providing application or plugin

BOOLEAN ContextFeatureItem::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from FeatureItem.

The documentation for this class was generated from the following files:
  • Atl/Features/ContextFeatureItem.hpp
  • Atl/Features/ContextFeatureItem.cpp
Generated on Wed Jan 25 01:07:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextFeatureTriggerMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextFeatureTriggerMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for ContextFeatureTriggerMsg:

[legend]
Collaboration diagram for ContextFeatureTriggerMsg:

[legend]

Public Types

enum | { ID = 13006 }

Public Member Functions

virtual Message * | Clone () const
ContextFeatureTriggerMsg (ExecutionContext *context, const FeatureID &feature_id, const DataItem &context_item)
const DataItem & | GetContextItem () const
const FeatureID & | GetFeatureId () const
virtual const MsgMetaData & | GetMetaData () const
void | SetContextItem (const DataItem &context_item)
void | SetFeatureId (const FeatureID &feature_id)
virtual | ~ContextFeatureTriggerMsg ()

Detailed Description

ContextFeatureTriggerMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ContextFeatureTriggerMsg::ContextFeatureTriggerMsg | ( | ExecutionContext * | context,
 |  | const FeatureID & | feature_id,
 |  | const DataItem & | context_item
 | ) |

ContextFeatureTriggerMsg::~ContextFeatureTriggerMsg ( ) [virtual]

Member Function Documentation

Message * ContextFeatureTriggerMsg::Clone ( ) const [virtual]

Implements Message.

const DataItem& ContextFeatureTriggerMsg::GetContextItem ( ) const [inline]

const FeatureID& ContextFeatureTriggerMsg::GetFeatureId ( ) const [inline]

const MsgMetaData & ContextFeatureTriggerMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void ContextFeatureTriggerMsg::SetContextItem ( const DataItem & context_item ) [inline]

void ContextFeatureTriggerMsg::SetFeatureId ( const FeatureID & feature_id ) [inline]

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 01:07:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextManager Class Reference
[APOXI Template Layer]

This singleton handles context switches and applies context descriptions to new contexts. More...

#include <Apoxi/Atl/Context/ContextManager.hpp>

Collaboration diagram for ContextManager:

[legend]

Public Member Functions

ContextDescription * | GetContextDesc (const ContextID &context_id)
const ContextID * | GetContextId ()
Dispatcher * | GetDispatcher () const
KeyMapping & GetKeyMap ()
void | NotifyContextItemSwitch ()
void | NotifyContextSwitch (AtlWindow *win, const ContextID &context_id)
virtual | ~ContextManager ()

Static Public Member Functions

static ContextManager & | GetInstance ()

Protected Member Functions

void | UpdateSoftkeys (AtlWindow *win, const ContextID &context_id)

Friends

class | AtlWindow

Detailed Description

This singleton handles context switches and applies context descriptions to new contexts.

Constructor & Destructor Documentation

ContextManager::~ContextManager ( ) [virtual]

Member Function Documentation

ContextDescription * ContextManager::GetContextDesc ( const ContextID & context_id )

Parameters:
ContextId of the requested ContextDescription
Returns:
ContextDescription for the given context_id.

const ContextID * ContextManager::GetContextId ( )

Returns:
Id of active context description

Dispatcher* ContextManager::GetDispatcher ( ) const [inline]

Returns:
The dispatcher of the active window, which is either an application or a plugin

static ContextManager& ContextManager::GetInstance ( ) [inline, static]

KeyMapping & ContextManager::GetKeyMap ( )

Returns:
Either key map for active context, or default key map for default context

void ContextManager::NotifyContextItemSwitch ( )

Notification of the change of the context item in the active context, e.g. because of a changed selection in a list window

void ContextManager::NotifyContextSwitch | ( | AtlWindow * | win,
 |  | const ContextID & | context_id
 | ) |

Applies window specific configurations to the window

Parameters:
win | Window, the context is valid for
context_id | New context for the window

void ContextManager::UpdateSoftkeys | ( | AtlWindow * | win,
 |  | const ContextID & | context_id
 | ) | [protected]

Applies window specific configurations to the window

Parameters:
win | Window, the context is valid for
context_id | New context for the window

Friends And Related Function Documentation

friend class AtlWindow [friend]

The documentation for this class was generated from the following files:
  • Atl/Context/ContextManager.hpp
  • Atl/Context/ContextManager.cpp
Generated on Wed Jan 25 01:07:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextMenu Class Reference
[Components]

#include <Apoxi/Gui/ContextMenu.hpp>

Inheritance diagram for ContextMenu:

[legend]
Collaboration diagram for ContextMenu:

[legend]

Public Types

enum | { ID = 8 }
enum | Corner { TopLeft, TopRight, BottomLeft, BottomRight }

Public Member Functions

BOOLEAN | AddItem (Item *item)
ContextMenu ()
ContextMenu (XYDIM x, XYDIM y, Corner corner=TopLeft, AbstractItemContainer *item_cont=0, ContextMenu *parent_menu=0)
AbstractItemContainer * | GetItemContainer () const
Returns the item container which is shown inside the context menu.
const AbstractItemRenderer * | GetRenderer () const
Returns the renderer which is used for drawing the items.
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetRenderer (const ItemRendererProperties *properties=0)
virtual | ~ContextMenu ()

Protected Member Functions

virtual void | Cleanup ()
virtual void | OnActionExecuted (Action *action)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | Refresh (const Rect &rect)

Detailed Description

Represents a context menu which may contain a variable number of items. As items representing an instance of the class AbstractItemContainer recursively contain other items, a context menu also may contain sub menus. It is possible to use custom item renderer properties for each instance of a context menu.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Window.

enum ContextMenu::Corner

Corner of the context menu, which is the target for the x- and y-position.

Enumerator:
TopLeft | The x- and y-position describes the top left corner of the context menu.
TopRight | The x- and y-position describes the top right corner of the context menu.
BottomLeft | The x- and y-position describes the bottom left corner of the context menu.
BottomRight | The x- and y-position describes the bottom right corner of the context menu.

Constructor & Destructor Documentation

ContextMenu::ContextMenu | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | Corner | corner = TopLeft,
 |  | AbstractItemContainer * | item_cont = 0,
 |  | ContextMenu * | parent_menu = 0
 | ) |

Parameters:
x | x-position of the corner specified by corner.
x | y-position of the corner specified by corner.
corner | Corner of the context menu which is the target for the x- and y-position.
item_cont | Pointer to the item-container, which contains the items of the context menu.
parent_menu | Pointer to the parent context menu, which will be informed by the message ContextMenuClosedMsg if the context menu has been closed.

ContextMenu::ContextMenu ( )

ContextMenu::~ContextMenu ( ) [virtual]

Member Function Documentation

BOOLEAN ContextMenu::AddItem ( Item * item )

Adds the item item after the already added items. For other item-operations use ContextMenu::GetItemContainer and invoke the corresponding methods.

void ContextMenu::Cleanup ( ) [protected, virtual]

See also:
Component::Cleanup

Reimplemented from Control.

AbstractItemContainer * ContextMenu::GetItemContainer ( ) const

Returns the item container which is shown inside the context menu.

const AbstractItemRenderer * ContextMenu::GetRenderer ( ) const

Returns the renderer which is used for drawing the items.

BOOLEAN ContextMenu::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Window.

void ContextMenu::OnActionExecuted ( Action * action ) [protected, virtual]

See also:
Window::OnActionExecuted

Reimplemented from Window.

BOOLEAN ContextMenu::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Window.

void ContextMenu::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from Window.

BOOLEAN ContextMenu::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Window.

void ContextMenu::SetRenderer ( const ItemRendererProperties * properties = 0 )

Sets the renderer used for drawing the items with the specified properties. If this method is not invoked, the default-properties specified by GuiEngineConfig::GetDefaultItemRendererProperties are used.

Parameters:
properties Item-renderer-properties which are used by the renderer.

The documentation for this class was generated from the following files:
  • Gui/ContextMenu.hpp
  • Gui/ContextMenu.cpp
Generated on Wed Jan 25 01:07:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextMenuClosedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextMenuClosedMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for ContextMenuClosedMsg:

[legend]
Collaboration diagram for ContextMenuClosedMsg:

[legend]

Public Types

enum | { ID = 1122 }

Public Member Functions

virtual Message * | Clone () const
ContextMenuClosedMsg (ContextMenu *context_menu)
ContextMenu * | GetContextMenu () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~ContextMenuClosedMsg ()

Detailed Description

This message is sent from an instance of a ContextMenu, after it has been closed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ContextMenuClosedMsg::ContextMenuClosedMsg ( ContextMenu * context_menu )

ContextMenuClosedMsg::~ContextMenuClosedMsg ( ) [virtual]

Member Function Documentation

Message * ContextMenuClosedMsg::Clone ( ) const [virtual]

Implements Message.

ContextMenu* ContextMenuClosedMsg::GetContextMenu ( ) const [inline]

const MsgMetaData & ContextMenuClosedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:07:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextMsg Class Reference
[Kernel]

#include <Apoxi/Kernel/Message.hpp>

Inheritance diagram for ContextMsg:

[legend]
Collaboration diagram for ContextMsg:

[legend]

Public Member Functions

ContextMsg (ExecutionContext *context)
Application * | GetApplication () const
ExecutionContext * | GetContext () const
virtual const MsgMetaData & | GetMetaData () const =0
void | SetApplication (Application *app)
void | SetContext (ExecutionContext *context)
virtual | ~ContextMsg ()

Detailed Description

Extends a message by having access to an context. Every context-message has the category MC_CONTEXT.

Constructor & Destructor Documentation

ContextMsg::ContextMsg ( ExecutionContext * context )

ContextMsg::~ContextMsg ( ) [virtual]

Member Function Documentation

Application * ContextMsg::GetApplication ( ) const

ExecutionContext* ContextMsg::GetContext ( ) const [inline]

virtual const MsgMetaData& ContextMsg::GetMetaData ( ) const [pure virtual]

Implements Message.

Implemented in AppActionExecutedMsg, LocationNotifInvokeMsg, LocationResMsg, LocationErrMsg, AbortResMsg, SetupDataConnMsg, SendRequestMsg, GltpConnStatusMsg, CloseDataConnMsg, EmServThreadMsg, MediaManagerMsg, MCServiceInterfaceMsg, MmCallStatusMsg, MmCallDisconnectingMsg, MmMocSetupAcceptMsg, MmCallSetupProgressMsg, MmCallInfoMsg, MmCallNotifyMsg, MmCurrentChargeDataMsg, MmCurrentCallMeterMsg, MmAocChargingStatusMsg, SvgStatusMsg, SvgHyperlinkSelectMsg, DBItemChangedMsg, VrPromptMsg, VrResultMsg, VrErrorMsg, VrWarningMsg, VrRecognitionAbortedMsg, VrTrainingAbortedMsg, VrRecognitionStoppedMsg, VrTrainingResultMsg, VrPlaybackFinishedMsg, VrTrainingFailedMsg, VrRecognitionFailedMsg, RegNotifyMsg, FileChunkOperationProgressMsg, SsMessage, SignalStrengthLevelMsg, SignalQualityLevelMsg, AccessoryIndMsg, RegistrationSuccessMsg, RegistrationChangeMsg, PlmnScanFinishedMsg, RegistrationAllowedMsg, SimCallSetupMsg, SimSmsSentMsg, SimSsSentMsg, SimRefreshMsg, SimRefreshResetMsg, SimResetConfirmationMsg, SimResetDoneMsg, SimDisplayTextMsg, SimGetInputMsg, SimGetInkeyMsg, SimSelectItemMsg, SimSetupMenuMsg, SimMenuItemSelectionFailedMsg, SimPlayToneMsg, SimSetupIdleModeTextMsg, SimEndTransactionMsg, SimCallSetupRejectedMsg, CallOnHoldMsg, CallHoldRejectedMsg, MptyOnHoldMsg, MptyHoldRejectedMsg, SimTkLanguageNotificationMsg, SimTkSetupEventMsg, TermRspCnfMsg, SimTkRefreshStartMsg, SimTkProfileGetCnfMsg, SimTkProfileSetCnfMsg, SimTkProfileSetRejMsg, SimLaunchBrowserReqMsg, SimLaunchBrowserPromptReqMsg, SimBrowserTermResMsg, OmMultiSlotIndMsg, DhChannelOpenReqMsg, DhChannelCloseReqMsg, DhChannelSendReqMsg, DhChannelDataAvailableResMsg, DhChannelReceiveReqMsg, DhChannelChangeStatusResMsg, SimTkRunAtCmdInfoIndMsg, SimTkSendDtmfIndMsg, SimTkSendDtmfEndIndMsg, PowerModeIndMsg, MocSetupAcceptMsg, CalledPartyAlertingMsg, MtcArrivedMsg, MtcReadyMsg, CallSetupProgressMsg, CallDisconnectingMsg, CallDisconnectedMsg, CallInfoMsg, DtmfStartCnfMsg, DtmfStopCnfMsg, DtmfRejectMsg, DtmfBufferCleanedMsg, RemotePartyActionMsg, ConnectionStatusMsg, CallNotifyMsg, RedialStartedMsg, RedialStoppedMsg, RedialSetupMsg, RedialSuccessMsg, AocChargingStatusMsg, CurrentCallMeterMsg, CurrentChargeDataMsg, DiagnosticIndMsg, RedialStatusMsg, CallControlInfoMsg, MocSetupRejectIndMsg, ForwardingInfoReceivedMsg, BarringInfoReceivedMsg, SsDataReceivedMsg, SsNotificationMsg, InterrogationResultMsg, PasswordReceivedMsg, UssDataReceivedMsg, HlrSsDataCorruptMsg, SsSuccessMsg, SsEndMsg, SsRejectedMsg, SsErrIndicationMsg, PasswordInquiryMsg, PasswordRejectedMsg, UssdIndicationMsg, UssdResentMsg, SsFacilityRejectedMsg, SsInfoMsg, CcbsRecallMsg, CcbsStatusMsg, CcbsResultMsg, UssdAnswerMsg, EngineeringReportMsg, BandSelectionMsg, HomezoneMsg, NwDiscStartIndMsg, RatStateMsg, GsmBandStateMsg, BandStatusMsg, EngineeringModeControlResponseMsg, RatChangeModeChangedMsg, CellInfoMsg, SmsNewMessageMsg, SmsNewStatusReportMsg, SmsNewSocketDataMsg, SmsPortDataRecvMsg, SmsSendConfirmMsg, SmsSendRejectMsg, SmsSpaceExceededMsg, SmsSpaceAvailableMsg, CbsNewDataMsg, SmsPrefStorageMediaChangedMsg, SmsMessageWaitingChangedMsg, CbsLimitMsg, PbSizeRequestMsg, PbEntryRequestMsg, PbAlphaTagRequestMsg, CallDeflectionIndMsg, CallDeflectionErrIndicationMsg, CallDeflectionRejectedMsg, CtmInfoIndMsg, SsRequestSentMsg, SsRequestAcceptedMsg, SsRequestRejectedMsg, CallWaitingActivatedMsg, CallWaitingDeactivatedMsg, CallWaitingStatusMsg, EmlppRegisteredMsg, EmlppStatusMsg, NetworkSsErrorMsg, NetworkSsRejectedMsg, StackSsRejectedMsg, ClirNotSurpressedMsg, CallForwardingActiveMsg, CallHeldMsg, CallRetrievedMsg, CallIsWaitingMsg, CallBarredMsg, ForwardedCallIncomingMsg, HlrDataCorruptedMsg, CugCallMsg, OutgoingCallForwardedMsg, IncomingCallForwardedMsg, MultiPartyCallInvokedMsg, EctActiveMsg, EctAlertingMsg, CnapInfoReceivedMsg, CallForwardingActivatedMsg, CallForwardingDeactivatedMsg, CallForwardingStatusMsg, CallForwardingRegisteredMsg, CallForwardingErasedMsg, CallBarringActivatedMsg, CallBarringDeactivatedMsg, CallBarringStatusMsg, ClipStatusMsg, ColpStatusMsg, ColrStatusMsg, CnapStatusMsg, ClirStatusMsg, CallBarringPasswordChangedMsg, SsErrorMsg, UssdRequestMsg, UssdNotifyMsg, UssdEndMsg, UssdDataMsg, UssdRequestResentMsg, GetPasswordMsg, UusStatusMsg, UusQueryRejectedMsg, UusNotificationMsg, UusRegisteredMsg, UusErasedMsg, PropertyTriggerMsg, FeatureTriggerMsg, ContextFeatureTriggerMsg, UpdateItemMsg, DisabledFeatureTriggeredMsg, TransportNotificationMsg, ImageDrawingInterruptedMsg, DeleteComponentMsg, ServiceThreadTerminateMsg, AppGetFocusMsg, AppLoseFocusMsg, SharedTimerMsg, ThreadletNotificationMsg, ContextWakeupMsg, ShutdownRequestMsg, AlarmNotificationMsg, TimerTimeoutMsg, ContextExecuteMsg, ObexAppMsg, SocketControlMsg, AsyncUnitTestMsg, UtcStatusMessage, OpenPbWinMsg, SaveEntryInPhonebookMsg, SyncProgressMsg, ProviderUpdateMsg, CameraMsgStartViewfinding, CameraMsgStopViewfinding, SmsServiceMsg, SmsServiceDocumentMsg, SendSmsMsg, ImageBrowserServiceMsg, LcsAppTransferLocMsg, LcsAppRegisterForMtlrMsg, LcsAppResWinMsg, OnDataRcvdMsg, StartSocketTestMsg, NextSocketTestMsg, ContinueSocketTestMsg, StopSocketTestMsg, SkipSocketTestMsg, SoundBrowserServiceMsg, UibRegisterMsg, UibNotifyMsg, and UibUpdateMsg.

void ContextMsg::SetApplication ( Application * app )

void ContextMsg::SetContext ( ExecutionContext * context ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/Message.hpp
  • Kernel/Message.cpp
Generated on Wed Jan 25 01:07:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextTable Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/ContextTable.hpp>

Collaboration diagram for ContextTable:

[legend]

Static Public Member Functions

static const ContextTableNode * | GetRoot ()
static INT | GetSize ()

Friends

class | ContextTableNode

Member Function Documentation

static const ContextTableNode* ContextTable::GetRoot ( ) [inline, static]

Returns:
the root of the linked list

INT ContextTable::GetSize ( ) [static]

Returns:
the size of the linked list

Friends And Related Function Documentation

friend class ContextTableNode [friend]

The documentation for this class was generated from the following files:
  • Atl/Context/ContextTable.hpp
  • Atl/Context/ContextTable.cpp
Generated on Wed Jan 25 01:07:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextTableEntry Struct Reference

#include <Apoxi/Atl/Context/ContextDescriptionTypes.hpp>

Collaboration diagram for ContextTableEntry:

[legend]

Data Fields

const CHAR * | context_id
const KeymapTableEntry * | keymap
SoftkeyDescTableEntry | softkey_descriptions [APOXI_MAX_SOFTKEY_COUNT]
const CHAR * | title

Field Documentation

const CHAR* ContextTableEntry::context_id

const KeymapTableEntry* ContextTableEntry::keymap

SoftkeyDescTableEntry ContextTableEntry::softkey_descriptions[APOXI_MAX_SOFTKEY_COUNT]

const CHAR* ContextTableEntry::title

The documentation for this struct was generated from the following file:
  • Atl/Context/ContextDescriptionTypes.hpp
Generated on Wed Jan 25 01:07:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextTableNode Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/ContextTableNode.hpp>

Collaboration diagram for ContextTableNode:

[legend]

Public Member Functions

ContextTableNode (const ContextTableEntry *entry)
const ContextTableEntry * | GetEntry () const
const ContextTableNode * | GetNext () const
virtual | ~ContextTableNode ()
destructor

Friends

class | ContextTable

Constructor & Destructor Documentation

ContextTableNode::ContextTableNode ( const ContextTableEntry * entry )

constructor

Parameters:
ContextTableEntry; all information that is needed to create a ContextDescription.

ContextTableNode::~ContextTableNode ( ) [virtual]

destructor

Member Function Documentation

const ContextTableEntry* ContextTableNode::GetEntry ( ) const [inline]

Returns:
ContextTableEntryentry; all information that is needed to create a ContextDescription.

const ContextTableNode* ContextTableNode::GetNext ( ) const [inline]

Returns:
the next node of this linked list to iterate through this linked list.

Friends And Related Function Documentation

friend class ContextTable [friend]

The documentation for this class was generated from the following files:
  • Atl/Context/ContextTableNode.hpp
  • Atl/Context/ContextTableNode.cpp
Generated on Wed Jan 25 01:07:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContextWakeupMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContextWakeupMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ContextWakeupMsg:

[legend]
Collaboration diagram for ContextWakeupMsg:

[legend]

Public Types

enum | { ID = 110 }

Public Member Functions

virtual Message * | Clone () const
ContextWakeupMsg (ExecutionContext *context)
virtual const MsgMetaData & | GetMetaData () const
virtual | ~ContextWakeupMsg ()

Detailed Description

This message will be sent only to wake up the Context/Thread in which the module is embedded.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ContextWakeupMsg::ContextWakeupMsg ( ExecutionContext * context )

ContextWakeupMsg::~ContextWakeupMsg ( ) [virtual]

Member Function Documentation

Message * ContextWakeupMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ContextWakeupMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:07:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ContinueSocketTestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ContinueSocketTestMsg Class Reference

#include <Applications/SocketTest/SocketTestMsgTypes.hpp>

Inheritance diagram for ContinueSocketTestMsg:

[legend]
Collaboration diagram for ContinueSocketTestMsg:

[legend]

Public Types

enum | { ID = 21902 }

Public Member Functions

virtual Message * | Clone () const
ContinueSocketTestMsg (ExecutionContext *context)
virtual const MsgMetaData & | GetMetaData () const
virtual | ~ContinueSocketTestMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ContinueSocketTestMsg::ContinueSocketTestMsg ( ExecutionContext * context )

ContinueSocketTestMsg::~ContinueSocketTestMsg ( ) [virtual]

Member Function Documentation

Message * ContinueSocketTestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ContinueSocketTestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestMsgTypes.hpp
  • Applications/SocketTest/SocketTestMsgTypes.cpp
Generated on Wed Jan 25 01:07:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Control Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Control Class Reference
[Components]

#include <Apoxi/Gui/Control.hpp>

Inheritance diagram for Control:

[legend]
Collaboration diagram for Control:

[legend]

Public Types

enum | { ID = 9 }
enum | FrameType { NoFrame, DefaultFrame, StaticFrame, DynamicFrame }

Public Member Functions

void | AddControl (Control *control, BOOLEAN at_end=TRUE)
void | AddDrawableObject (DrawableObject *drawable_object, BOOLEAN at_end=TRUE)
BOOLEAN | ContainsControl (const Control *control) const
BOOLEAN | ContainsDrawableObject (const DrawableObject *obj) const
Control (Control *parent=0, const View *view=0)
void | Draw ()
virtual void | DrawLayer ()
Rect | GetAbsClientRect () const
XYDIM | GetAbsClientXPos () const
XYDIM | GetAbsClientYPos () const
Rect | GetAbsRect () const
XYDIM | GetAbsXPos () const
XYDIM | GetAbsYPos () const
Application * | GetApplication () const
XYDIM | GetClientHeight () const
virtual Rect | GetClientRect () const
Size | GetClientSize () const
XYDIM | GetClientWidth () const
XYDIM | GetClientXPos () const
XYDIM | GetClientYPos () const
Component * | GetComponent (INT id) const
const ClientDc * | GetDeviceContext () const
ClientDc * GetDeviceContext ()
INT | GetDisplayIndex () const
Returns the index of the display, where the Window should be drawn.
Control * | GetFirstControl () const
DrawableObject * | GetFirstDrawableObject () const
Control * | GetFocusedControl () const
Control * | GetForegroundControl () const
FrameType | GetFrameType () const
INT | GetLanguageId () const
Control * | GetLastFocusedControl () const
NavigationGuidance | GetNavigationGuidance () const
Control * | GetNext (const Control *control) const
Control * | GetNext () const
Window * | GetParentWindow () const
Control * | GetPrevious (Control *control) const
const Rect & | GetRepaintRect () const
BOOLEAN | GrabFocus ()
BOOLEAN | HasFocus () const
void | Init (Control *parent=0, const View *view=0)
void | Invalidate (const Rect &rect, BOOLEAN erase=TRUE)
void | Invalidate ()
void | InvalidateClient (const Rect &rect, BOOLEAN erase=TRUE)
void | InvalidateClient ()
BOOLEAN | IsAutoClearEnabled () const
BOOLEAN | IsAutoLayoutEnabled () const
BOOLEAN | IsChild () const
BOOLEAN | IsDisabled () const
BOOLEAN | IsInForeground () const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsMaximized () const
BOOLEAN | IsOpen () const
Obsolete - use IsParentWindowOpen() instead.
BOOLEAN | IsParentWindowOpen () const
void | LayoutClient ()
virtual void | Maximize ()
void | PutToForeground ()
void | RemoveControl (Control *control)
void | RemoveDrawableObject (DrawableObject *drawable_object)
void | SetAutoClearEnabled (BOOLEAN enabled)
void | SetAutoLayoutEnabled (BOOLEAN enabled)
void | SetDisabled (BOOLEAN disabled)
BOOLEAN | SetDisplayIndex (INT index)
void | SetFrameType (FrameType frame_type)
void | SetNavigationGuidance (NavigationGuidance navigation_guidance)
void | SetNext (Control *next)
virtual void | SetParent (Control *parent)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~Control ()

Protected Member Functions

virtual void | Cleanup ()
virtual const ControlFrameView * | GetFrameView () const
INT | GetInternalDisplayIndex () const
Obsolete - use Control::GetDisplayIndex() instead.
Control * | GetLastFocusedChild () const
Obsolete - use Control::GetLastFocusedControl() instead.
MsgId | GetTriggeredMessage (InputMapId map_id, const InputMapItem &input_map_item) const
virtual void | OnFocusNextControl ()
virtual void | OnFocusPreviousControl ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
virtual BOOLEAN | OnKeyAutoRepeat (KeyCode key_code)
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual BOOLEAN | OnKeyUp (KeyCode key_code, UINT32 duration)
virtual void | OnLanguageChanged ()
Is called, after the language has been changed.
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnLongKeyPress (KeyCode key_code)
virtual void | OnLoseFocus ()
virtual void | OnMove (XYDIM dx, XYDIM dy)
virtual void | OnPaint (const Rect &repaint_rect)
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | OnThemeChanged ()
Is called, after the theme has been changed.
virtual BOOLEAN | OnTimeout (const Timer &timer)
void | OptimizeAutoClear ()
virtual void | Refresh (const Rect &rect)
virtual BOOLEAN | RouteMessage (const Message &msg)
void | SetInternalDisplayIndex (INT index)
void | SetLastFocusedChild (Control *control)
Obsolete - use Control::SetLastFocusedControl() instead.
void | SetLastFocusedControl (Control *control)

Friends

class | Application
class | Window

Data Structures

class | ComponentIterator
class | NavigationGuidance

Detailed Description

A Control has a frame and a client area, which is the area inside the frame. A control can have one or more sub controls and drawable objects, which are only visible inside the client area of the control. The sub controls themselves can recursively have other sub controls.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Component.

enum Control::FrameType

Every control can have a different frame type. The look of a frame type is implemented in the instance of a ControlFrameView, which can be retrieved from the current set Theme by the factory-method Control::GetFrameView().

Enumerator:
NoFrame | The size of each border is zero, hence the client area of the control is equivalent to the bounding-rectangle of the control.
DefaultFrame | The size of the borders is equivalent to the sizes given by the instance of ControlFrameView. A frame of the type DefaultFrame has a different look when the control has the focus.
StaticFrame | In opposite to DefaultFrame the look of the frame is independent from having the focus. This frame type is useful for e. g. editors or list boxes, where the cursor indicates the focus.
DynamicFrame | Is meant for frames where the control dynamically changes the size of the client area during runtime.

Constructor & Destructor Documentation

Control::Control | ( | Control * | parent = 0,
 |  | const View * | view = 0
 | ) |

Parameters:
parent | Pointer to parent control, which includes the control as child.
view | Pointer to the view of the control.

Control::~Control ( ) [virtual]

Member Function Documentation

void Control::AddControl | ( | Control * | control,
 |  | BOOLEAN | at_end = TRUE
 | ) |

Adds a sub control to the control. This method is automatically invoked when initializing a sub control by it's constructor or Control::Init. All sub controls are automatically drawn.

Parameters:
control | Pointer to the sub control.
at_end | If set to TRUE, the control is appended after all other controls. Otherwise the control is inserted at the begin. The order only matters when having overlapping controls.

void Control::AddDrawableObject | ( | DrawableObject * | drawable_object,
 |  | BOOLEAN | at_end = TRUE
 | ) |

Adds a drawable object to the control. This method is automatically invoked when initializing a drawable object by it's constructor or DrawableObject::Init. All drawable objects are automatically drawn by Control::OnPaint()

Parameters:
component | Pointer to the drawable object.
at_end | If set to TRUE, the drawable object is appended after all other drawable objects. Otherwise the drawable object is inserted at the begin. The order only matters when having overlapping drawable objects.
See also:
Control::OnPaint()

void Control::Cleanup ( ) [protected, virtual]

Is invoked, when the control gets invisible e. g. when the parent-window which contains the control is closed. Invokes Component::Cleanup of all sub-components.

Reimplemented from Component.

Reimplemented in MultiMediaEditor, Menu, AbstractEditor, AbstractItemGrid, ContextMenu, ItemMenu, and ItemTree.

BOOLEAN Control::ContainsControl ( const Control * control ) const

Returns TRUE, if the control control is embedded as sub control.

BOOLEAN Control::ContainsDrawableObject ( const DrawableObject * obj ) const

Returns TRUE, if the drawable object obj is embedded into the control.

void Control::Draw ( )

Draws the control including its sub components. Reimplement the method Control::OnPaint for drawing the client area and reimplement the method ControlFrameView::DrawControlFrame of the corresponding theme for drawing the control frame. It is possible to draw a layer above the whole content by reimplementing Control::DrawLayer.

void Control::DrawLayer ( ) [virtual]

Is invoked by Control::Draw and allows to draw a layer above the already drawn control. For example it would be possible to dimm the whole control by drawing an alpha blended filled rectangle this way:

void MyControl::DrawLayer()
{
    FrameDc dc(this);
    dc.BeginUpdate();
    dc.SetBrushColorRgb(0, 0, 0, 128);
    dc.FillRect(0, 0, GetWidth() - 1, GetHeight() - 1);
    dc.EndUpdate();
}

Rect Control::GetAbsClientRect ( ) const

Returns:
Bounding rectangle of the client area in absolute coordinates.

XYDIM Control::GetAbsClientXPos ( ) const

Returns:
x-position of upper-left corner of the client area in absolute coordinates.

XYDIM Control::GetAbsClientYPos ( ) const

Returns:
y-position of upper-left corner of the client area in absolute coordinates.

Rect Control::GetAbsRect ( ) const

Returns:
Bounding rectangle of the Control in absolute coordinates.

XYDIM Control::GetAbsXPos ( ) const

Returns:
x-position of upper-left corner of the Control in absolute coordinates.

XYDIM Control::GetAbsYPos ( ) const

Returns:
y-position of upper-left corner of the Control in absolute coordinates.

Application * Control::GetApplication ( ) const

Returns:
Returns currently active application.

XYDIM Control::GetClientHeight ( ) const

Returns:
Height of the client area.

Rect Control::GetClientRect ( ) const [virtual]

Returns:
Bounding-rectangle of the client area. Can be overwritten for derived controls, which need a modified client-Area, like e. g. a Window which has a title and a softkey-bar. Note that all non-virtual GetClient-methods use this method to return their corresponding parameters. Hence from an economic point of view it is more efficient to invoke GetClientRect() instead of invoking GetClientXPos(), GetClientYPos(), GetClientWidth() and GetClientHeight() when needing all four parameters.

Reimplemented in GridLayout, and Window.

Size Control::GetClientSize ( ) const

Returns:
Size of the client area.

XYDIM Control::GetClientWidth ( ) const

Returns:
Width of the client area.

XYDIM Control::GetClientXPos ( ) const

Returns:
x-position of client area relative to upper left edge of the control.

XYDIM Control::GetClientYPos ( ) const

Returns:
y-position of client area relative to upper left edge of the control.

Component * Control::GetComponent ( INT id ) const

Returns a pointer to the sub-component with the ID id. Each component generated by Aragon has a unique ID which can be retrieved by Component::GetId. If the component has not been generated by Aragon, -1 is returned as default ID.

Parameters:
id ID of the sub-component which should be returned. If -1 is used, 0 is returned.
Returns:
Pointer to the sub-component with the given ID. 0 is returned if the ID is -1 or no sub-component has an equal ID.

const ClientDc * Control::GetDeviceContext ( ) const

Returns:
Pointer to the device context of the client area.

ClientDc * Control::GetDeviceContext ( )

Returns a pointer to the device context of the client area. Note that this device-context is shared by all controls which are drawn on the same display. Hence it is recommended to use the class PaintDc before modifying the device-context.

INT Control::GetDisplayIndex ( ) const [inline]

Returns the index of the display, where the Window should be drawn.

Control* Control::GetFirstControl ( ) const [inline]

Returns a pointer to the first sub control of the control. The following sub controls are accessable by Control::GetNext().

See also:
ComponentIterator

DrawableObject* Control::GetFirstDrawableObject ( ) const [inline]

Returns a pointer to the first drawable-object of the control. The following drawable objects are accessable by DrawableObject::GetNext().

See also:
ComponentIterator

Control * Control::GetFocusedControl ( ) const

Returns the focused sub control of the control (0, if the control has no sub controls). If the control itself has not the focus, also no sub control can have the focus and 0 is returned.

Control * Control::GetForegroundControl ( ) const

Obsolete - use Control::GetFirstControl instead or Control::GetFocusedControl. GetForegroundControl returns the first control for backward compatibility.

FrameType Control::GetFrameType ( ) const [inline]

Returns:
Type of frame (NoFrame, DefaultFrame or StaticFrame).

const ControlFrameView * Control::GetFrameView ( ) const [protected, virtual]

Factory-method for getting the frame-view of the control. Per default, the ControlFrameView from the current set Theme is used.

Reimplemented in Window.

INT Control::GetInternalDisplayIndex ( ) const [inline, protected]

Obsolete - use Control::GetDisplayIndex() instead.

INT Control::GetLanguageId ( ) const [inline]

Returns the language ID which is used for the control.

Control* Control::GetLastFocusedChild ( ) const [inline, protected]

Obsolete - use Control::GetLastFocusedControl() instead.

Control* Control::GetLastFocusedControl ( ) const [inline]

Returns the sub control which had the focus before the control lost it's focus. As soon as the control will gain the focus, this sub control will get the focus too.

NavigationGuidance Control::GetNavigationGuidance ( ) const [inline]

Returns:
The navigation guidance, which can be used to e. g. display the available navigation keys between the softkeys as indication for the user.

Control * Control::GetNext ( const Control * control ) const

Returns the successor of the sub control control. 0 is returned if no successor is available, which usually means that only one sub control is embedded.

Control* Control::GetNext ( ) const [inline]

Returns the next control of the sub control queue. In combination with Control::GetFirstControl() it is possible to iterate over all sub controls. Note that there also exists the iterator ComponentIterator, which allows to iterate over all sub components.

Window * Control::GetParentWindow ( ) const

Returns:
Pointer to the first parent-control, which is an instance of the class Window. It is assured, that at least the root-control is an instance of the class Window.

Control * Control::GetPrevious ( Control * control ) const

Returns the predecessor of the sub control control. 0 is returned if no predecessor is available, which usually means that only one sub control is embedded.

const Rect& Control::GetRepaintRect ( ) const [inline]

Returns the invalidated rectangle of the control which should get repainted. The rectangle is relative to the upper left corner of the control frame.

MsgId Control::GetTriggeredMessage | ( | InputMapId | map_id,
 |  | const InputMapItem & | input_map_item
 | ) | const [protected]

Obsolete - provided for backward compatibility with older APOXI releases. The method is required for the (obsolete) input map concept (see Control::OnInputMap).

BOOLEAN Control::GrabFocus ( )

Tries to grab the focus for the control.

Returns:
TRUE is returned, if the control will get the focus. Note that the focus will be assigned asynchronously and is not assigned immediately after invoking Control::GrabFocus. See also Control::OnGetFocus for details. FALSE is returned, if either the parent-control does not have the focus or if the control cannot get the focus because a window with a higher focus-priority currently has the focus.

BOOLEAN Control::HasFocus ( ) const [inline]

Returns:
TRUE, if the control has the focus. Having the focus means, that all messages of the type MC_FOCUS are routed to this control only.

void Control::Init | ( | Control * | parent = 0,
 |  | const View * | view = 0
 | ) |

Parameters:
parent | Pointer to parent control, which includes the control as child.
view | Pointer to the view of the control.

void Control::Invalidate | ( | const Rect & | rect,
 |  | BOOLEAN | erase = TRUE
 | ) |

Invalidates a specified area of the control. This leads to a repaint of this area in the next idle-state of the application.

Parameters:
rect | Specifies the area by a rectangle. The coordinates are relative to the upper left position of the control. If no rectangle is specified, the whole area will be invalidated.
erase | Indicates, whether the control should be erased before Control::OnPaint is called. By default erase is TRUE.

Reimplemented in CalendarGrid.

void Control::Invalidate ( )

Wrapper for Control::Invalidate(Rect(), TRUE) (no default parameters are used to reduce the code size).

void Control::InvalidateClient | ( | const Rect & | rect,
 |  | BOOLEAN | erase = TRUE
 | ) |

Invalidates the client area of the control. This leads to a repaint of this area in the next idle-state of the application.

Parameters:
rect | Specifies the area by a rectangle. The coordinates are relative to the client area of the control. If no rectangle is specified, the whole are will be invalidated.
erase | Indicates, whether the control should be erased before Control::OnPaint is called. By default erase is TRUE.

void Control::InvalidateClient ( )

Wrapper for Control::InvalidateClient(Rect(), TRUE) (no default parameters are used to reduce the code size).

BOOLEAN Control::IsAutoClearEnabled ( ) const [inline]

Returns TRUE, if auto-clearing of the client area is enabled.

See also:
SetAutoClearEnabled

BOOLEAN Control::IsAutoLayoutEnabled ( ) const [inline]

Returns TRUE, if auto-layouting of sub-components is enabled. Per default the auto-layouting is enabled.

See also:
SetAutoLayoutEnabled

BOOLEAN Control::IsChild ( ) const [inline]

Returns TRUE, if the control is embedded into a parent control.

BOOLEAN Control::IsDisabled ( ) const [inline]

Returns:
TRUE, if the control is disabled and hence gets no messages from the type MC_FOCUS.
See also:
Control::SetDisabled()

BOOLEAN Control::IsInForeground ( ) const

Returns:
TRUE, if the control is on foreground related to controls being at the same level hierarchy. E. g. a child control may be on foreground related to other child controls inside the parent, but the parent control must not be on foreground. When a Control has the focus, it is always in the foreground.

BOOLEAN Control::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Component.

Reimplemented in MultiMediaEditor, AtlWindow, AtlItemGridWindow, AtlItemListWindow, AtlItemMenuWindow, AbstractButton, AbstractEditor, AbstractGrid, AbstractItemGrid, AbstractLineEditor, AbstractMultiLineEditor, Alert, CheckBoxControl, ContextMenu, DateEditor, FlowLayout, GridLayout, IpAddrEditor, ItemGrid, ItemMenu, ItemTree, LineEditor, MessageBox, MultiLineEditor, Panel, PasswordEditor, PushButton, RadioButtonControl, TabButton, TabControl, TimeEditor, and Window.

BOOLEAN Control::IsMaximized ( ) const [inline]

Returns:
TRUE, if the control is maximized.
See also:
Maximize()

BOOLEAN Control::IsOpen ( ) const

Obsolete - use IsParentWindowOpen() instead.

Reimplemented in Window.

BOOLEAN Control::IsParentWindowOpen ( ) const

Returns:
TRUE, if the first parent-control which is an instance of the class Window is open. Note that it is assured, that at least one parent of a control is an instance of the class Window, which can be opened or closed.

void Control::LayoutClient ( )

Leads to a relayout of the client area by invoking OnLayoutClient. Additionally the drawing-performance is optimized by invoking OptimizeAutoClear.

void Control::Maximize ( ) [virtual]

Maximizes the Control to the size of the display if it has no parent, otherwise it is maximized to the client area of the parent. The frame-border is outside the visible area, title and softkey-bar are fully visible. The control will stay maximized until the position or the size will be changed.

Reimplemented in Window.

void Control::OnFocusNextControl ( ) [protected, virtual]

Is called, if the focus will be switched to the next control inside the control.

Reimplemented in FlowLayout, GridLayout, and TabControl.

void Control::OnFocusPreviousControl ( ) [protected, virtual]

Is called, if the focus will be switched to the previous control inside the control.

Reimplemented in FlowLayout, GridLayout, and TabControl.

void Control::OnGetFocus ( ) [protected, virtual]

Is called, if the control gets the focus. When a Control has the focus, all messages of the type MC_FOCUS are forwarded to this Control.

Reimplemented in AbstractPredictiveInputBox, AtlWindow, AtlItemGridWindow, AbstractEditBox, CheckBox, EditBox, AbstractEditor, AbstractGrid, AbstractItemGrid, AbstractMultiLineEditor, GridLayout, Window, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, CalendarGrid, SmsEditor, SmsViewerWin, and UibFolderWin.

BOOLEAN Control::OnInputMap ( const InputMapItem & input_map_item ) [protected, virtual]

Reimplemented in AbstractEditBox, AbstractListBox, AbstractMenuList, CheckBox, EditBox, Grid, CalendarGrid, and CalendarMonthSelector.

BOOLEAN Control::OnKeyAutoRepeat ( KeyCode key_code ) [protected, virtual]

If one key is pressed permanently this method is called periodically corresponding to the set autorepeat value.

Parameters:
Code of the key.

Reimplemented in AbstractGrid, and GridLayout.

BOOLEAN Control::OnKeyDown ( KeyCode key_code ) [protected, virtual]

Is called, if a key has been pressed and is still holded.

Parameters:
Code of the key.
Returns:
TRUE, if the key-down message has been dispatched and hence should not be routed to other windows anymore.

Reimplemented in MultiMediaEditor, AtlWindow, AtlItemGridWindow, AtlItemMenuWindow, PropertyEditor, DateEditBox, EditBox, TimeEditBox, AbstractEditor, AbstractGrid, AbstractLineEditor, AbstractMultiLineEditor, FlowLayout, GridLayout, TabControl, Window, PbDetailEditBox, PbNameEditBox, CalendarGrid, and ImageBrowserDetailWin.

BOOLEAN Control::OnKeyUp | ( | KeyCode | key_code,
 |  | UINT32 | duration
 | ) | [protected, virtual]

Is called, if a key has been released.

Parameters:
Code of the key.
Returns:
TRUE, if the key-up message has been dispatched and hence should not be routed to other windows anymore.

Reimplemented in AbstractEditor.

void Control::OnLanguageChanged ( ) [protected, virtual]

Is called, after the language has been changed.

Implements Component.

Reimplemented in AtlWindow, CheckBox, CheckBoxList, Menu, MenuList, RadioButtonList, AbstractButton, AbstractItemGrid, TabControl, and Window.

void Control::OnLayoutClient ( ) [protected, virtual]

Is called, if the client area should be layouted (e. g. when the control is initialized or the size of the client area has changed). The use of the class Layouter for layouting the controls is recommended.

See also:
Layouter

Reimplemented in MultiMediaEditor, T9PredictiveInputBox, Zi8PredictiveInputBox, AtlLabelListWindow, AbstractListBox, TextList, AbstractGrid, AbstractMultiLineEditor, FlowLayout, GridLayout, MessageBox, Panel, TabControl, Window, EmsComposeWin, SmsComposeWin, SmsViewerWin, ImageBrowserDetailWin, and SavingProgressWin.

BOOLEAN Control::OnLongKeyPress ( KeyCode key_code ) [protected, virtual]

Is called once before the autorepeat starts, if a key is pressed for a long time.

Parameters:
Code of the key.

Reimplemented in T9PredictiveInputBox, and AbstractEditor.

void Control::OnLoseFocus ( ) [protected, virtual]

Is called, if the control loses the focus.

See also:
Control::OnGetFocus()

Reimplemented in AtlWindow, AtlItemMenuWindow, AbstractEditBox, CheckBox, EditBox, AbstractEditor, AbstractItemGrid, and Window.

void Control::OnMove | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnMove(dx, dy)

Reimplemented from Component.

Reimplemented in Window.

void Control::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

Is called, if the control must be repainted. A repainting is always triggered by a Control::Invalidate. Note that the repainting is not done immediately after a Control::Invalidate, but when entering the next idle-state. Hence if an update of the display is needed before entering the idle-state, <em<Application::UpdateDisplay must be invoked.

Parameters:
@see Control::Invalidate()
See also:
Application::UpdateDisplay()

Reimplemented in MultiMediaEditor, AbstractListBox, AbstractEditor, AbstractGrid, AbstractItemGrid, AbstractMultiLineEditor, and Alert.

void Control::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnResize(dx, dy)

Reimplemented from Component.

Reimplemented in AbstractListBox, AbstractItemGrid, AbstractMultiLineEditor, and Window.

void Control::OnThemeChanged ( ) [protected, virtual]

Is called, after the theme has been changed.

Implements Component.

Reimplemented in AtlWindow, AbstractEditBox, AbstractListBox, CheckBox, CheckBoxList, Grid, MenuList, RadioButtonList, TextList, AbstractGrid, AbstractItemGrid, CheckBoxControl, FlowLayout, GridLayout, MultiLineEditor, Panel, PushButton, RadioButtonControl, TabButton, TabControl, and Window.

BOOLEAN Control::OnTimeout ( const Timer & timer ) [protected, virtual]

Is called, if a timer has been expired.

Parameters:
timer Timer, which expired.

Reimplemented in AbstractListBox, AbstractGrid, AbstractItemGrid, and Alert.

void Control::OptimizeAutoClear ( ) [protected]

Tries to to disable auto-clearing of the client area, when a sub control completely fills the client area.

void Control::PutToForeground ( )

Puts the control to the foreground and assigns the focus.

See also:
IsInForeground()

void Control::Refresh ( const Rect & rect ) [protected, virtual]

Is invoked, before the control gets visible e. g. when the parent-window which contains the control is opened. Invokes Component::Refresh of all sub-components.

Reimplemented from Component.

Reimplemented in MultiMediaEditor, AbstractEditBox, AbstractListBox, CheckBox, CheckBoxList, Grid, Menu, MenuList, RadioButtonList, TextList, AbstractEditor, AbstractGrid, AbstractItemGrid, AbstractMultiLineEditor, CheckBoxControl, ContextMenu, DateEditor, ItemMenu, ItemTree, PushButton, RadioButtonControl, TabButton, TabControl, and Window.

void Control::RemoveControl ( Control * control )

Removes a sub control from the control, hence it is not drawn anymore and cannot get the focus.

void Control::RemoveDrawableObject ( DrawableObject * drawable_object )

Removes a drawable object from the control, hence it is not drawn anymore in Control::OnPaint().

Parameters:
component Pointer to the drawable object.
See also:
Control::OnPaint()

BOOLEAN Control::RouteMessage ( const Message & msg ) [protected, virtual]

Implements the message routing of controls. It is recommended not to change the default message routing and usually it should not be necessary.

See also:
Dispatcher::RouteMessage

Reimplemented from Dispatcher.

Reimplemented in T9PredictiveInputBox, and Zi8PredictiveInputBox.

void Control::SetAutoClearEnabled ( BOOLEAN enabled )

Per default the client area of a control is automatically cleared before invoking OnPaint. This can be turned off be setting enabled to FALSE. This is useful when e. g. the drawing of the client area is done synchronously outside the context of OnPaint.

void Control::SetAutoLayoutEnabled ( BOOLEAN enabled ) [inline]

If enabled is TRUE, the control automatically layouts a sub control inside the client area. This is only done, if exactly one sub control is part of the control. If more than one sub control has been added, the layouting must be done by overwriting the method Control::OnLayoutClient or by using a LayouterControl as wrapper. Per default the automatical layouting of one sub control is enabled.

See also:
Layouter

LayouterControl

void Control::SetDisabled ( BOOLEAN disabled )

Marks the control as disabled, if disabled is TRUE. A control which is disabled does not treat messages of the type MC_FOCUS, even if the Control is focused. Hence all the sub controls do not get this messages too. This is useful when e. g. reading out a large provider in Window::OnOpen() and the interaction with the user should be disabled until the reading of the provider has been finished.

BOOLEAN Control::SetDisplayIndex ( INT index )

Sets the index of the display, where the Control should be drawn. The number of displays can be specified in DisplayConfig::GetDisplayCount().

Returns:
TRUE, if the change of the display-index has been successful. Note that it is not possible to change the display-index of a child-control to an index, which is different to the index of its parent-control.

void Control::SetFrameType ( FrameType frame_type ) [inline]

Parameters:
frame_type Type of frame (NoFrame,DefaultFrame or StaticFrame). The look and size of the frame is defined by the corresponding instance of ControlFrameView of the current Theme.
See also:
Theme::GetControlFrameView()

Theme::GetWindowFrameView()

void Control::SetInternalDisplayIndex ( INT index ) [inline, protected]

Allows derived classed to set the display index property without reattaching the control.

void Control::SetLastFocusedChild ( Control * control ) [inline, protected]

Obsolete - use Control::SetLastFocusedControl() instead.

void Control::SetLastFocusedControl ( Control * control ) [inline, protected]

Allows derived classes to let the control remember the sub control which should get the focus when the control itself will get the focus.

void Control::SetNavigationGuidance ( NavigationGuidance navigation_guidance )

Sets the navigation guidance, which usually will be shown between the softkeys. Note that APOXI updates the navigation guidance for the up- and down-keys automatically when the methods Control::AddControl and Control::RemoveControlare invoked. The policy in this case is that the up- and down-keys get enabled if at least 2 sub controls are part of the control, otherwise they get disabled (the up- and down-keys are the default keys for switching the focus between sub controls). As entry point for initializing the navigation guidance Control::OnGetFocus is recommended. See also Control::GetNavigationGuidance for details.

void Control::SetNext ( Control * next ) [inline]

Sets the next control for the sub control queue. It should not be necessary for an application to use this method directly.

void Control::SetParent ( Control * parent ) [virtual]

See also:
Component::SetParent

Implements Component.

BOOLEAN Control::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Component.

Reimplemented in MultiMediaEditor, AtlWindow, AbstractButton, AbstractEditor, AbstractGrid, AbstractItemGrid, AbstractLineEditor, AbstractMultiLineEditor, Alert, CheckBoxControl, ContextMenu, DateEditor, FlowLayout, GridLayout, IpAddrEditor, ItemGrid, ItemMenu, ItemTree, LineEditor, MessageBox, MultiLineEditor, PasswordEditor, PushButton, RadioButtonControl, TabButton, TabControl, TimeEditor, and Window.

Friends And Related Function Documentation

friend class Application [friend]

friend class Window [friend]

The documentation for this class was generated from the following files:
  • Gui/Control.hpp
  • Gui/Control.cpp
Generated on Wed Jan 25 01:08:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Control::ComponentIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Control::ComponentIterator

Control::ComponentIterator Class Reference

#include <Apoxi/Gui/Control.hpp>

Collaboration diagram for Control::ComponentIterator:

[legend]

Public Types

enum | Type { All, Controls, DrawableObjects }
Specifies the kind of components which should be iterated. More...

Public Member Functions

BOOLEAN | Begin ()
ComponentIterator (const Control &control, Type type=All)
Component * | Get () const
BOOLEAN | Next ()
ComponentIterator | operator++ (INT)
ComponentIterator & operator++ ()
~ComponentIterator ()

Detailed Description

Allows to iterate over all components embedded into a control. Sample code:
for (Control::ComponentIterator it(control); it.Get() != 0; ++it) {
    Component* comp = it.Get();
    // ...
}

Member Enumeration Documentation

enum Control::ComponentIterator::Type

Specifies the kind of components which should be iterated.

Enumerator:
All | All drawable objects and controls are iterated (= default value).
Controls | Only controls are iterated.
DrawableObjects | Only drawable objects are iterated.

Constructor & Destructor Documentation

Control::ComponentIterator::ComponentIterator | ( | const Control & | control,
 |  | Type | type = All
 | ) |

Parameters:
control | Controls whichs components should be iterated.
type | Which type of components should be iterated.

Control::ComponentIterator::~ComponentIterator ( )

Member Function Documentation

BOOLEAN Control::ComponentIterator::Begin ( )

Resets the iterator the the first component. Returns TRUE if the control contains at least one component.

Component* Control::ComponentIterator::Get ( ) const [inline]

Returns the current component of the iterator.

BOOLEAN Control::ComponentIterator::Next ( )

Returns TRUE if the controls has a next component. ComponentIterator::Get returns this component.

Control::ComponentIterator Control::ComponentIterator::operator++ ( INT )

Moves the iterator to the next component.

Control::ComponentIterator & Control::ComponentIterator::operator++ ( )

Moves the iterator to the next component.

The documentation for this class was generated from the following files:
  • Gui/Control.hpp
  • Gui/Control.cpp
Generated on Wed Jan 25 01:08:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Control::NavigationGuidance Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Control::NavigationGuidance

Control::NavigationGuidance Class Reference

#include <Apoxi/Gui/Control.hpp>

Public Types

enum | State { Off = 0, Disabled = 1, Enabled = 2 }
Describes the state of one navigation key. More...
enum Type {
Left = 0, Right = 2, Up = 4, Down = 6,
Center = 8
}
Describes the available keys for navigation. More...

Public Member Functions

State | GetState (Type type) const
Returns the state of the navigation key type.
void | Merge (NavigationGuidance nav_guid)
NavigationGuidance (State left_state, State right_state=Off, State up_state=Off, State down_state=Off, State center_state=Off)
NavigationGuidance ()
BOOLEAN | operator!= (NavigationGuidance nav_guid) const
BOOLEAN | operator== (NavigationGuidance nav_guid) const
void | SetState (Type type, State state)
Sets the state of the navigation key type to state.
~NavigationGuidance ()

Detailed Description

The navigation guidance can be retrieved by the method Control::GetNavigationGuidance and gives the information, which navigation keys will be handled by the control. This navigation guidance can be used to e. g. display the available keys between the softkeys as indication for the user.

Member Enumeration Documentation

enum Control::NavigationGuidance::State

Describes the state of one navigation key.

Enumerator:
Off | The navigation key is not used and invisible.
Disabled | The navigation key is available but disabled, which usually means that it's shown greyed out.
Enabled | The navigation key is available.

enum Control::NavigationGuidance::Type

Describes the available keys for navigation.

Enumerator:
Left | The left arrow key is available for the user.
Right | The right arrow key is available for the user.
Up | The up arrow key is available for the user.
Down | The down arrow key is available for the user.
Center | The center key is available for the user.

Constructor & Destructor Documentation

Control::NavigationGuidance::NavigationGuidance ( )

Control::NavigationGuidance::NavigationGuidance | ( | State | left_state,
 |  | State | right_state = Off,
 |  | State | up_state = Off,
 |  | State | down_state = Off,
 |  | State | center_state = Off
 | ) |

Control::NavigationGuidance::~NavigationGuidance ( )

Member Function Documentation

Control::NavigationGuidance::State Control::NavigationGuidance::GetState ( Type type ) const

Returns the state of the navigation key type.

void Control::NavigationGuidance::Merge ( NavigationGuidance nav_guid )

Merges the navigation guidance with nav_guid, where nav_gui may overwrite the settings of the navigation guidance.

BOOLEAN Control::NavigationGuidance::operator!= ( NavigationGuidance nav_guid ) const [inline]

BOOLEAN Control::NavigationGuidance::operator== ( NavigationGuidance nav_guid ) const [inline]

void Control::NavigationGuidance::SetState | ( | Type | type,
 |  | State | state
 | ) |

Sets the state of the navigation key type to state.

The documentation for this class was generated from the following files:
  • Gui/Control.hpp
  • Gui/Control.cpp
Generated on Wed Jan 25 01:08:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ControlDc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ControlDc Class Reference
[GUI]

#include <Apoxi/Gui/ControlDc.hpp>

Inheritance diagram for ControlDc:

[legend]
Collaboration diagram for ControlDc:

[legend]

Public Member Functions

ControlDc (VirtualDisplay *display)
ControlDc (Control *control)
ControlDc ()
void | Init (VirtualDisplay *display)
void | Init (Control *control)

Protected Member Functions

void | Update (const Rect &abs_rect)

Detailed Description

Device context used for drawing into a control.

Constructor & Destructor Documentation

ControlDc::ControlDc ( )

ControlDc::ControlDc ( Control * control )

ControlDc::ControlDc ( VirtualDisplay * display )

Member Function Documentation

void ControlDc::Init ( VirtualDisplay * display )

void ControlDc::Init ( Control * control )

void ControlDc::Update ( const Rect & abs_rect ) [protected]

See also:
DeviceContext::Update

Reimplemented in FrameDc.

The documentation for this class was generated from the following files:
  • Gui/ControlDc.hpp
  • Gui/ControlDc.cpp
Generated on Wed Jan 25 01:08:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ControlFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ControlFrameView Class Reference
[GUI]

#include <Apoxi/Gui/ControlFrameView.hpp>

Inheritance diagram for ControlFrameView:

[legend]
Collaboration diagram for ControlFrameView:

[legend]

Public Member Functions

ControlFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size)
ControlFrameView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawClientAreaBackground (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
XYDIM | GetBottomSize () const
Returns the size of the bottom border given in pixels.
XYDIM | GetLeftSize () const
Returns the size of the left border given in pixels.
XYDIM | GetRightSize () const
Returns the size of the top border given in pixels.
XYDIM | GetTopSize () const
Returns the size of the top border given in pixels.
virtual | ~ControlFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const =0
void | DrawFrameComponents (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
Draws all components which have been added to the frame.
void | SetBottomSize (XYDIM bottom_size)
void | SetLeftSize (XYDIM left_size)
void | SetRightSize (XYDIM right_size)
void | SetTopSize (XYDIM top_size)

Detailed Description

A control frame view is responsible for drawing the frame of a control including the default background of the client area.

Constructor & Destructor Documentation

ControlFrameView::ControlFrameView ( )

ControlFrameView::ControlFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size
 | ) |

Parameters:
left_size | Size of the left border in pixels.
top_size | Size of the top border in pixels.
right_size | Size of the right border in pixels.
bottom_size | Size of the bottom border in pixels.

ControlFrameView::~ControlFrameView ( ) [virtual]

Member Function Documentation

void ControlFrameView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

Reimplemented in WindowFrameView.

void ControlFrameView::DrawClientAreaBackground | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Draws the default background for the client area of the control frame. Per default the area is filled with the color defined by Color::ClientBackground. Especially for the derived class WindowFrameView it makes sense to implement a custom background.

Reimplemented in DefaultWindowFrameView.

virtual void ControlFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implemented in BlueSkyControlFrameView, BlueSkyWindowFrameView, DefaultControlFrameView, DefaultWindowFrameView, TestControlFrameView, TestWindowFrameView, CTControlFrameView, CTWindowFrameView, DefaultControlFrameView, DefaultWindowFrameView, and FoggyWindowFrameView.

void ControlFrameView::DrawFrameComponents | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected]

Draws all components which have been added to the frame.

XYDIM ControlFrameView::GetBottomSize ( ) const [inline]

Returns the size of the bottom border given in pixels.

XYDIM ControlFrameView::GetLeftSize ( ) const [inline]

Returns the size of the left border given in pixels.

XYDIM ControlFrameView::GetRightSize ( ) const [inline]

Returns the size of the top border given in pixels.

XYDIM ControlFrameView::GetTopSize ( ) const [inline]

Returns the size of the top border given in pixels.

void ControlFrameView::SetBottomSize ( XYDIM bottom_size ) [inline, protected]

void ControlFrameView::SetLeftSize ( XYDIM left_size ) [inline, protected]

void ControlFrameView::SetRightSize ( XYDIM right_size ) [inline, protected]

void ControlFrameView::SetTopSize ( XYDIM top_size ) [inline, protected]

The documentation for this class was generated from the following files:
  • Gui/ControlFrameView.hpp
  • Gui/ControlFrameView.cpp
Generated on Wed Jan 25 01:08:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ControlHwDataOnlyArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ControlHwDataOnlyArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for ControlHwDataOnlyArg:

[legend]
Collaboration diagram for ControlHwDataOnlyArg:

[legend]

Public Types

enum | { ID = 2249 }

Public Member Functions

ControlHwDataOnlyArg ()

Static Public Member Functions

static const ControlHwDataOnlyArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ControlHwDataOnlyArg: reflects arguments of signal MIOM_CTRL_HW_DATA_ONLY

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ControlHwDataOnlyArg::ControlHwDataOnlyArg ( )

Member Function Documentation

const ControlHwDataOnlyArg & ControlHwDataOnlyArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ControlMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ControlMsg Class Reference
[Kernel]

#include <Apoxi/Kernel/Message.hpp>

Inheritance diagram for ControlMsg:

[legend]
Collaboration diagram for ControlMsg:

[legend]

Public Member Functions

ControlMsg (Control *control)
Control * | GetControl () const
virtual const MsgMetaData & | GetMetaData () const =0
void | SetControl (Control *control)
virtual | ~ControlMsg ()

Detailed Description

Extends a message by having access to a control. Every control-message has the category MC_CONTROL.

Constructor & Destructor Documentation

ControlMsg::ControlMsg ( Control * control )

ControlMsg::~ControlMsg ( ) [virtual]

Member Function Documentation

Control* ControlMsg::GetControl ( ) const [inline]

virtual const MsgMetaData& ControlMsg::GetMetaData ( ) const [pure virtual]

Implements Message.

Implemented in FocusNextControlMsg, FocusPreviousControlMsg, SelectionChangedMsg, GetFocusMsg, LoseFocusMsg, and JumpToRowMsg.

void ControlMsg::SetControl ( Control * control ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/Message.hpp
  • Kernel/Message.cpp
Generated on Wed Jan 25 01:08:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Conversion Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Conversion Class Reference

#include <Apoxi/Auxiliary/Conversion.hpp>

Static Public Member Functions

static KeyCode | IA52KeyCode (const UINT8 key)
static UINT8 | KeyCode2IA5 (const KeyCode key)

Member Function Documentation

KeyCode Conversion::IA52KeyCode ( const UINT8 key ) [static]

UINT8 Conversion::KeyCode2IA5 ( const KeyCode key ) [static]

The documentation for this class was generated from the following files:
  • Auxiliary/Conversion.hpp
  • Auxiliary/Conversion.cpp
Generated on Wed Jan 25 01:08:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CopyHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CopyHandler Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/CopyHandler.hpp>

Inheritance diagram for CopyHandler:

[legend]
Collaboration diagram for CopyHandler:

[legend]

Public Member Functions

BOOLEAN | CopyAll (MmiAdvancedProgressBox *listener=0)
CopyHandler (Provider *src_prov, Provider *dst_prov)
CopyHandler ()
BOOLEAN | CopyRow (INT row)
void | Init (Provider *src_prov, Provider *dst_prov)
virtual | ~CopyHandler ()

Constructor & Destructor Documentation

CopyHandler::CopyHandler ( )

CopyHandler::CopyHandler | ( | Provider * | src_prov,
 |  | Provider * | dst_prov
 | ) |

CopyHandler::~CopyHandler ( ) [virtual]

Member Function Documentation

BOOLEAN CopyHandler::CopyAll ( MmiAdvancedProgressBox * listener = 0 )

BOOLEAN CopyHandler::CopyRow ( INT row )

void CopyHandler::Init | ( | Provider * | src_prov,
 |  | Provider * | dst_prov
 | ) |

Reimplemented in PbCopyHandler.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/CopyHandler.hpp
  • Applications/AdvPhonebook/CopyHandler.cpp
Generated on Wed Jan 25 01:08:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CopyToPbAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CopyToPbAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for CopyToPbAction:

[legend]
Collaboration diagram for CopyToPbAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN CopyToPbAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:08:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CountryProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CountryProvider Class Reference
[Provider]

#include <Apoxi/Adc/CountryProvider.hpp>

Inheritance diagram for CountryProvider:

[legend]
Collaboration diagram for CountryProvider:

[legend]

Public Types

typedef Provider | Base

Public Member Functions

CountryProvider ()
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
virtual Provider::Status | GetStatus () const
Returns the status of the provider.
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual | ~CountryProvider ()

Detailed Description

CountryProvider is the provider to retrieve data concerning country codes. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_country_provider_id

Following column ids are defined: c_mcc_id :NumberType returns the mobile country code. c_cc_id :NumberType returns the ITU-T E.164 country code. c_country_shortname_id :WStringType returns the countries short name.

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef Provider CountryProvider::Base

Constructor & Destructor Documentation

CountryProvider::CountryProvider ( )

CountryProvider::~CountryProvider ( ) [virtual]

Member Function Documentation

BOOLEAN CountryProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT CountryProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

Provider::Status CountryProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

INT CountryProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

The documentation for this class was generated from the following files:
  • Adc/CountryProvider.hpp
  • Adc/CountryProvider.cpp
Generated on Wed Jan 25 01:08:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: COverIList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

COverIList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Types

enum | { LengthOfCOverIArray = TESTPARAM_CI_CS_COUNT }

Public Member Functions

BOOLEAN | IsEmpty ()
COverIList | operator= (T_C_OVER_I_LIST c_over_i_list)
SignalStrengthLevel & | operator[] (INT index)

Data Fields

SignalStrengthLevel | c_over_i_array [LengthOfCOverIArray]
INT | length

Member Enumeration Documentation

anonymous enum

Enumerator:
LengthOfCOverIArray

Member Function Documentation

BOOLEAN COverIList::IsEmpty ( )

COverIList COverIList::operator= ( T_C_OVER_I_LIST c_over_i_list )

SignalStrengthLevel & COverIList::operator[] ( INT index )

Field Documentation

SignalStrengthLevel COverIList::c_over_i_array[LengthOfCOverIArray]

INT COverIList::length

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:08:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsAuxProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsAuxProvider Class Reference
[Provider]

#include <Apoxi/Adc/CphsAuxProvider.hpp>

Inheritance diagram for CphsAuxProvider:

[legend]
Collaboration diagram for CphsAuxProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
CphsAuxProvider ()
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimCphsHandler *cphs_handler, Protector *protector)
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~CphsAuxProvider ()

Detailed Description

CphsAuxProvider is the provider to retrieve different kind of data relating to the Cphs extension of the Gsm standard from the mobile station. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_cphs_aux_provider_id

Following column ids are defined: c_cphs_phase_id :NumberType: CPHS Phase as defined in CPHS4_2.WW6 B3.1.1 c_infnrs_activated_id :NumberType: cast to BOOLEAN if service is activated c_infnrs_allocated_id :NumberType: cast to BOOLEAN if service is allocated c_csp_activated_id :NumberType: cast to BOOLEAN if service is activated c_csp_allocated_id :NumberType: cast to BOOLEAN if service is allocated c_sst_activated_id :NumberType: cast to BOOLEAN if service is activated c_sst_allocated_id :NumberType: cast to BOOLEAN if service is allocated c_mboxnrs_activated_id :NumberType: cast to BOOLEAN if service is activated c_mboxnrs_allocated_id :NumberType: cast to BOOLEAN if service is allocated c_opname_activated_id :NumberType: cast to BOOLEAN if service is activated c_opname_allocated_id :NumberType: cast to BOOLEAN if service is allocated c_operator_name_id :WStringType: operator name as defined in CPHS4_2.WW6 B.4.1.2 c_operator_shortname_id :WStringType: operator name with max. 10 Chars as defined in CPHS4_2.WW6 B.4.1.2 c_msg_wait_ind_line1_id :NumberType: cast to BOOLEAN if msg is waiting c_msg_wait_ind_line2_id :NumberType: cast to BOOLEAN if msg is waiting c_msg_wait_ind_fax_id :NumberType: cast to BOOLEAN if msg is waiting c_msg_wait_ind_data_id :NumberType: cast to BOOLEAN if msg is waiting c_call_fwd_line1_id :NumberType: cast to BOOLEAN if call forwarding unconditional is active c_call_fwd_line2_id :NumberType: cast to BOOLEAN if call forwarding unconditional is active c_call_fwd_fax_id :NumberType: cast to BOOLEAN if call forwarding unconditional is active c_call_fwd_data_id :NumberType: cast to BOOLEAN if call forwarding unconditional is active c_line_in_use_id :NumberType: 0 if Line1 is used, 1 if Line2 is used (meaning of byte on SIM is reverse) c_line_is_locked_id :NumberType: cast to BOOLEAN, if TRUE the line is locked c_cphs_is_present_id :NumberType: cast to BOOLEAN, if TRUE CPHS is supported c_orange_welcome_msg_id :WStringType: returns the Orange welcome message

This provider only consists of one fixed row.

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider CphsAuxProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

CphsAuxProvider::CphsAuxProvider ( )

CphsAuxProvider::~CphsAuxProvider ( ) [virtual]

Member Function Documentation

BOOLEAN CphsAuxProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN CphsAuxProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT CphsAuxProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void CphsAuxProvider::Init | ( | SimCphsHandler * | cphs_handler,
 |  | Protector * | protector
 | ) |

INT CphsAuxProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN CphsAuxProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN CphsAuxProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/CphsAuxProvider.hpp
  • Adc/CphsAuxProvider.cpp
Generated on Wed Jan 25 01:08:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCfufArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCfufArray Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [2]

Field Documentation

UINT8 CphsCfufArray::val[2]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:08:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCfufReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCfufReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsCfufReadIndArg:

[legend]
Collaboration diagram for CphsCfufReadIndArg:

[legend]

Public Types

enum | { ID = 1420 }

Public Member Functions

CphsCfufReadIndArg ()
const CphsCfufArray & | GetCphsCfufArray () const
const SimUpdateStatus & | GetStatus () const
void | SetCphsCfufArray (const CphsCfufArray &cphs_cfuf_array)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsCfufReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsVmwfReadIndArg: reflects arguments of signal SI_CPHS_CFUF_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsCfufReadIndArg::CphsCfufReadIndArg ( )

Member Function Documentation

const CphsCfufReadIndArg & CphsCfufReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsCfufArray& CphsCfufReadIndArg::GetCphsCfufArray ( ) const [inline]

const SimUpdateStatus& CphsCfufReadIndArg::GetStatus ( ) const [inline]

void CphsCfufReadIndArg::SetCphsCfufArray ( const CphsCfufArray & cphs_cfuf_array ) [inline]

void CphsCfufReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCfufReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCfufReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsCfufReadReqArg:

[legend]
Collaboration diagram for CphsCfufReadReqArg:

[legend]

Public Types

enum | { ID = 2418 }

Public Member Functions

CphsCfufReadReqArg ()

Static Public Member Functions

static const CphsCfufReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsCfufReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsCfufReadReqArg::CphsCfufReadReqArg ( )

Member Function Documentation

const CphsCfufReadReqArg & CphsCfufReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCfufUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCfufUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsCfufUpdIndArg:

[legend]
Collaboration diagram for CphsCfufUpdIndArg:

[legend]

Public Types

enum | { ID = 1424 }

Public Member Functions

CphsCfufUpdIndArg ()
const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsCfufUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsCfufUpdIndArg: reflects arguments of signal SI_CPHS_CFUF_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsCfufUpdIndArg::CphsCfufUpdIndArg ( )

Member Function Documentation

const CphsCfufUpdIndArg & CphsCfufUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& CphsCfufUpdIndArg::GetStatus ( ) const [inline]

void CphsCfufUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCfufUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCfufUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsCfufUpdReqArg:

[legend]
Collaboration diagram for CphsCfufUpdReqArg:

[legend]

Public Types

enum | { ID = 2422 }

Public Member Functions

CphsCfufUpdReqArg ()
CphsCfufUpdReqArg (const CphsCfufArray &cphs_cfuf_array)
const CphsCfufArray & | GetCphsCfufArray () const
void | SetCphsCfufArray (const CphsCfufArray &cphs_cfuf_array)

Static Public Member Functions

static const CphsCfufUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsCfufUpdReqArg: reflects arguments of signal SI_CPHS_CFUF_UPDATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsCfufUpdReqArg::CphsCfufUpdReqArg ( const CphsCfufArray & cphs_cfuf_array )

CphsCfufUpdReqArg::CphsCfufUpdReqArg ( )

Member Function Documentation

const CphsCfufUpdReqArg & CphsCfufUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsCfufArray& CphsCfufUpdReqArg::GetCphsCfufArray ( ) const [inline]

void CphsCfufUpdReqArg::SetCphsCfufArray ( const CphsCfufArray & cphs_cfuf_array ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCspArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCspArray Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [22]

Field Documentation

UINT8 CphsCspArray::val[22]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:08:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCspReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCspReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsCspReadIndArg:

[legend]
Collaboration diagram for CphsCspReadIndArg:

[legend]

Public Types

enum | { ID = 1425 }

Public Member Functions

CphsCspReadIndArg ()
const CphsCspArray & | GetCphsCspArray () const
const LineSelector & | GetLineSelector () const
INT | GetNoOfGroups () const
const SimUpdateStatus & | GetStatus () const
void | SetCphsCspArray (const CphsCspArray &cphs_csp_array)
void | SetLineSelector (const LineSelector &line_selector)
void | SetNoOfGroups (INT no_of_groups)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsCspReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsCspReadIndArg: reflects arguments of signal SI_CPHS_CSP_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsCspReadIndArg::CphsCspReadIndArg ( )

Member Function Documentation

const CphsCspReadIndArg & CphsCspReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsCspArray& CphsCspReadIndArg::GetCphsCspArray ( ) const [inline]

const LineSelector& CphsCspReadIndArg::GetLineSelector ( ) const [inline]

INT CphsCspReadIndArg::GetNoOfGroups ( ) const [inline]

const SimUpdateStatus& CphsCspReadIndArg::GetStatus ( ) const [inline]

void CphsCspReadIndArg::SetCphsCspArray ( const CphsCspArray & cphs_csp_array ) [inline]

void CphsCspReadIndArg::SetLineSelector ( const LineSelector & line_selector ) [inline]

void CphsCspReadIndArg::SetNoOfGroups ( INT no_of_groups ) [inline]

void CphsCspReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCspReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCspReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsCspReadReqArg:

[legend]
Collaboration diagram for CphsCspReadReqArg:

[legend]

Public Types

enum | { ID = 2423 }

Public Member Functions

CphsCspReadReqArg ()
CphsCspReadReqArg (const LineSelector &line_selector, INT no_of_groups, const CphsCspArray &cphs_csp_array)
const CphsCspArray & | GetCphsCspArray () const
const LineSelector & | GetLineSelector () const
INT | GetNoOfGroups () const
void | SetCphsCspArray (const CphsCspArray &cphs_csp_array)
void | SetLineSelector (const LineSelector &line_selector)
void | SetNoOfGroups (INT no_of_groups)

Static Public Member Functions

static const CphsCspReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsCspReadReqArg: reflects arguments of signal SI_CPHS_CSP_READ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsCspReadReqArg::CphsCspReadReqArg | ( | const LineSelector & | line_selector,
 |  | INT | no_of_groups,
 |  | const CphsCspArray & | cphs_csp_array
 | ) |

CphsCspReadReqArg::CphsCspReadReqArg ( )

Member Function Documentation

const CphsCspReadReqArg & CphsCspReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsCspArray& CphsCspReadReqArg::GetCphsCspArray ( ) const [inline]

const LineSelector& CphsCspReadReqArg::GetLineSelector ( ) const [inline]

INT CphsCspReadReqArg::GetNoOfGroups ( ) const [inline]

void CphsCspReadReqArg::SetCphsCspArray ( const CphsCspArray & cphs_csp_array ) [inline]

void CphsCspReadReqArg::SetLineSelector ( const LineSelector & line_selector ) [inline]

void CphsCspReadReqArg::SetNoOfGroups ( INT no_of_groups ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCspUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCspUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsCspUpdIndArg:

[legend]
Collaboration diagram for CphsCspUpdIndArg:

[legend]

Public Types

enum | { ID = 1426 }

Public Member Functions

CphsCspUpdIndArg ()
const LineSelector & | GetLineSelector () const
const SimUpdateStatus & | GetStatus () const
void | SetLineSelector (const LineSelector &line_selector)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsCspUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsCspReadIndArg: reflects arguments of signal SI_CPHS_CSP_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsCspUpdIndArg::CphsCspUpdIndArg ( )

Member Function Documentation

const CphsCspUpdIndArg & CphsCspUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const LineSelector& CphsCspUpdIndArg::GetLineSelector ( ) const [inline]

const SimUpdateStatus& CphsCspUpdIndArg::GetStatus ( ) const [inline]

void CphsCspUpdIndArg::SetLineSelector ( const LineSelector & line_selector ) [inline]

void CphsCspUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsCspUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsCspUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsCspUpdReqArg:

[legend]
Collaboration diagram for CphsCspUpdReqArg:

[legend]

Public Types

enum | { ID = 2424 }

Public Member Functions

CphsCspUpdReqArg ()
CphsCspUpdReqArg (const LineSelector &line_selector, INT no_of_groups, const CphsCspArray &cphs_csp_array)
const CphsCspArray & | GetCphsCspArray () const
const LineSelector & | GetLineSelector () const
INT | GetNoOfGroups () const
void | SetCphsCspArray (const CphsCspArray &cphs_csp_array)
void | SetLineSelector (const LineSelector &line_selector)
void | SetNoOfGroups (INT no_of_groups)

Static Public Member Functions

static const CphsCspUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsCspUpdReqArg: reflects arguments of signal SI_CPHS_CSP_UPDATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsCspUpdReqArg::CphsCspUpdReqArg | ( | const LineSelector & | line_selector,
 |  | INT | no_of_groups,
 |  | const CphsCspArray & | cphs_csp_array
 | ) |

CphsCspUpdReqArg::CphsCspUpdReqArg ( )

Member Function Documentation

const CphsCspUpdReqArg & CphsCspUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsCspArray& CphsCspUpdReqArg::GetCphsCspArray ( ) const [inline]

const LineSelector& CphsCspUpdReqArg::GetLineSelector ( ) const [inline]

INT CphsCspUpdReqArg::GetNoOfGroups ( ) const [inline]

void CphsCspUpdReqArg::SetCphsCspArray ( const CphsCspArray & cphs_csp_array ) [inline]

void CphsCspUpdReqArg::SetLineSelector ( const LineSelector & line_selector ) [inline]

void CphsCspUpdReqArg::SetNoOfGroups ( INT no_of_groups ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsIstArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsIstArray Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [8]

Field Documentation

UINT8 CphsIstArray::val[8]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:08:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsIstReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsIstReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsIstReadIndArg:

[legend]
Collaboration diagram for CphsIstReadIndArg:

[legend]

Public Types

enum | { ID = 1418 }

Public Member Functions

CphsIstReadIndArg ()
const CphsIstArray & | GetCphsIstArray () const
const SimUpdateStatus & | GetStatus () const
void | SetCphsIstArray (const CphsIstArray &cphs_ist_array)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsIstReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsIstReadIndArg: reflects arguments of signal SI_CPHS_IST_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsIstReadIndArg::CphsIstReadIndArg ( )

Member Function Documentation

const CphsIstReadIndArg & CphsIstReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsIstArray& CphsIstReadIndArg::GetCphsIstArray ( ) const [inline]

const SimUpdateStatus& CphsIstReadIndArg::GetStatus ( ) const [inline]

void CphsIstReadIndArg::SetCphsIstArray ( const CphsIstArray & cphs_ist_array ) [inline]

void CphsIstReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsIstReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsIstReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsIstReadReqArg:

[legend]
Collaboration diagram for CphsIstReadReqArg:

[legend]

Public Types

enum | { ID = 2416 }

Public Member Functions

CphsIstReadReqArg ()

Static Public Member Functions

static const CphsIstReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsIstReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsIstReadReqArg::CphsIstReadReqArg ( )

Member Function Documentation

const CphsIstReadReqArg & CphsIstReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsOnmName Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsOnmName Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [40]

Field Documentation

UINT8 CphsOnmName::val[40]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:08:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsOnmReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsOnmReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsOnmReadIndArg:

[legend]
Collaboration diagram for CphsOnmReadIndArg:

[legend]

Public Types

enum | { ID = 1421 }

Public Member Functions

CphsOnmReadIndArg ()
const CphsOnmName & | GetCphsOnmName () const
const SimUpdateStatus & | GetStatus () const
void | SetCphsOnmName (const CphsOnmName &cphs_onm_name)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsOnmReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsOnmReadIndArg: reflects arguments of signal SI_CPHS_ONM_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsOnmReadIndArg::CphsOnmReadIndArg ( )

Member Function Documentation

const CphsOnmReadIndArg & CphsOnmReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsOnmName& CphsOnmReadIndArg::GetCphsOnmName ( ) const [inline]

const SimUpdateStatus& CphsOnmReadIndArg::GetStatus ( ) const [inline]

void CphsOnmReadIndArg::SetCphsOnmName ( const CphsOnmName & cphs_onm_name ) [inline]

void CphsOnmReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsOnmReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsOnmReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsOnmReadReqArg:

[legend]
Collaboration diagram for CphsOnmReadReqArg:

[legend]

Public Types

enum | { ID = 2419 }

Public Member Functions

CphsOnmReadReqArg ()

Static Public Member Functions

static const CphsOnmReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsOnmReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsOnmReadReqArg::CphsOnmReadReqArg ( )

Member Function Documentation

const CphsOnmReadReqArg & CphsOnmReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsOnsName Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsOnsName Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [10]

Field Documentation

UINT8 CphsOnsName::val[10]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:08:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsOnsReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsOnsReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsOnsReadIndArg:

[legend]
Collaboration diagram for CphsOnsReadIndArg:

[legend]

Public Types

enum | { ID = 1422 }

Public Member Functions

CphsOnsReadIndArg ()
const CphsOnsName & | GetCphsOnsName () const
const SimUpdateStatus & | GetStatus () const
void | SetCphsOnsName (const CphsOnsName &cphs_ons_name)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsOnsReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsOnsReadIndArg: reflects arguments of signal SI_CPHS_ONS_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsOnsReadIndArg::CphsOnsReadIndArg ( )

Member Function Documentation

const CphsOnsReadIndArg & CphsOnsReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsOnsName& CphsOnsReadIndArg::GetCphsOnsName ( ) const [inline]

const SimUpdateStatus& CphsOnsReadIndArg::GetStatus ( ) const [inline]

void CphsOnsReadIndArg::SetCphsOnsName ( const CphsOnsName & cphs_ons_name ) [inline]

void CphsOnsReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsOnsReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsOnsReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsOnsReadReqArg:

[legend]
Collaboration diagram for CphsOnsReadReqArg:

[legend]

Public Types

enum | { ID = 2420 }

Public Member Functions

CphsOnsReadReqArg ()

Static Public Member Functions

static const CphsOnsReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsOnsReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsOnsReadReqArg::CphsOnsReadReqArg ( )

Member Function Documentation

const CphsOnsReadReqArg & CphsOnsReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsServPflProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsServPflProvider Class Reference
[Provider]

#include <Apoxi/Adc/CphsServPflProvider.hpp>

Inheritance diagram for CphsServPflProvider:

[legend]
Collaboration diagram for CphsServPflProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
CphsServPflProvider ()
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimCphsHandler *cphs_handler, Protector *protector)
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~CphsServPflProvider ()

Detailed Description

em>CphsServPflProvider is the provider to retrieve data relating to the Customer service profile from the sim (CPHS4_2.WW6 B4.7). An instance of this class is part of the the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_cphs_costumer_prof_provider_id

Following column ids are defined:

all columns represents a BOOLEAN value and shall be casted to BOOLEAN

c_serv_cfu_id :NumberType: c_serv_cfb_id :NumberType: c_serv_cfnry_id :NumberType: c_serv_cfnrc_id :NumberType: c_serv_ct_id :NumberType:

c_serv_boac_id :NumberType: c_serv_boic_id :NumberType: c_serv_boic_exhc_id :NumberType: c_serv_baic_id :NumberType: c_serv_bic_roam_id :NumberType:

c_serv_mpty_id :NumberType: c_serv_cug_id :NumberType: c_serv_aoc_id :NumberType: c_serv_pref_cug_id :NumberType: c_serv_cug_oa_id :NumberType:

c_serv_hold_id :NumberType: c_serv_cw_id :NumberType: c_serv_ccbs_id :NumberType: c_serv_usr_usr_sig_id :NumberType:

c_serv_sm_mt_id :NumberType: c_serv_sm_mo_id :NumberType: c_serv_sm_cb_id :NumberType: c_serv_repl_path_id :NumberType: c_serv_del_conf_id :NumberType: c_serv_protid_id :NumberType: c_serv_val_per_id :NumberType:

c_serv_als_id :NumberType:

c_serv_clip_id :NumberType: c_serv_co_lr_id :NumberType: c_serv_co_lp_id :NumberType: c_serv_mci_id :NumberType: c_serv_cli_send_id :NumberType: c_serv_cli_block_id :NumberType:

c_serv_gprs_id :NumberType: c_serv_hscsd_id :NumberType: c_serv_vgrp_call_id :NumberType: c_serv_voice_bcst_serv_id :NumberType: c_serv_mtpl_subs_pfl_id :NumberType: c_serv_mtpl_band_id :NumberType:

c_serv_plmn_mode_id :NumberType: c_serv_vps_id :NumberType: c_serv_smmo_paging_id :NumberType: c_serv_smmo_email_id :NumberType: c_serv_fax_id :NumberType: c_serv_data_id :NumberType: c_serv_language_id :NumberType:

This provider only consists of one fixed row.

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider CphsServPflProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

CphsServPflProvider::CphsServPflProvider ( )

CphsServPflProvider::~CphsServPflProvider ( ) [virtual]

Member Function Documentation

BOOLEAN CphsServPflProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN CphsServPflProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT CphsServPflProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void CphsServPflProvider::Init | ( | SimCphsHandler * | cphs_handler,
 |  | Protector * | protector
 | ) |

INT CphsServPflProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN CphsServPflProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN CphsServPflProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/CphsServPflProvider.hpp
  • Adc/CphsServPflProvider.cpp
Generated on Wed Jan 25 01:08:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsVmwfArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsVmwfArray Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [2]

Field Documentation

UINT8 CphsVmwfArray::val[2]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:08:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsVmwfReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsVmwfReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsVmwfReadIndArg:

[legend]
Collaboration diagram for CphsVmwfReadIndArg:

[legend]

Public Types

enum | { ID = 1419 }

Public Member Functions

CphsVmwfReadIndArg ()
const CphsVmwfArray & | GetCphsVmwfArray () const
const SimUpdateStatus & | GetStatus () const
void | SetCphsVmwfArray (const CphsVmwfArray &cphs_vmwf_array)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsVmwfReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsVmwfReadIndArg: reflects arguments of signal SI_CPHS_VMWF_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsVmwfReadIndArg::CphsVmwfReadIndArg ( )

Member Function Documentation

const CphsVmwfReadIndArg & CphsVmwfReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsVmwfArray& CphsVmwfReadIndArg::GetCphsVmwfArray ( ) const [inline]

const SimUpdateStatus& CphsVmwfReadIndArg::GetStatus ( ) const [inline]

void CphsVmwfReadIndArg::SetCphsVmwfArray ( const CphsVmwfArray & cphs_vmwf_array ) [inline]

void CphsVmwfReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsVmwfReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsVmwfReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsVmwfReadReqArg:

[legend]
Collaboration diagram for CphsVmwfReadReqArg:

[legend]

Public Types

enum | { ID = 2417 }

Public Member Functions

CphsVmwfReadReqArg ()

Static Public Member Functions

static const CphsVmwfReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsVmwfReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsVmwfReadReqArg::CphsVmwfReadReqArg ( )

Member Function Documentation

const CphsVmwfReadReqArg & CphsVmwfReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsVmwfUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsVmwfUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsVmwfUpdIndArg:

[legend]
Collaboration diagram for CphsVmwfUpdIndArg:

[legend]

Public Types

enum | { ID = 1423 }

Public Member Functions

CphsVmwfUpdIndArg ()
const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const CphsVmwfUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsVmwfUpdIndArg: reflects arguments of signal SI_CPHS_VMWF_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsVmwfUpdIndArg::CphsVmwfUpdIndArg ( )

Member Function Documentation

const CphsVmwfUpdIndArg & CphsVmwfUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& CphsVmwfUpdIndArg::GetStatus ( ) const [inline]

void CphsVmwfUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CphsVmwfUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CphsVmwfUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for CphsVmwfUpdReqArg:

[legend]
Collaboration diagram for CphsVmwfUpdReqArg:

[legend]

Public Types

enum | { ID = 2421 }

Public Member Functions

CphsVmwfUpdReqArg ()
CphsVmwfUpdReqArg (const CphsVmwfArray &cphs_vmwf_array)
const CphsVmwfArray & | GetCphsVmwfArray () const
void | SetCphsVmwfArray (const CphsVmwfArray &cphs_vmwf_array)

Static Public Member Functions

static const CphsVmwfUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CphsVmwfUpdReqArg: reflects arguments of signal SI_CPHS_VMWF_UPDATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CphsVmwfUpdReqArg::CphsVmwfUpdReqArg ( const CphsVmwfArray & cphs_vmwf_array )

CphsVmwfUpdReqArg::CphsVmwfUpdReqArg ( )

Member Function Documentation

const CphsVmwfUpdReqArg & CphsVmwfUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CphsVmwfArray& CphsVmwfUpdReqArg::GetCphsVmwfArray ( ) const [inline]

void CphsVmwfUpdReqArg::SetCphsVmwfArray ( const CphsVmwfArray & cphs_vmwf_array ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CrssHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CrssHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/CrssHandler.hpp>

Collaboration diagram for CrssHandler:

[legend]

Public Types

enum | { ID = CrssHandlerId }

Public Member Functions

CrssHandler ()
Default constructor. Sets the default pointer in the base class.
CallApiRc | ExplicitCallTransfer (CallIndex call_index)
virtual HandlerId | GetHandlerId () const
SsErrorCode | GetLastErrorCode () const
CallApiRc | Hold (CallIndex idx)
CallApiRc JoinCalls ()
CallApiRc | ReleaseActiveCall () const
CallApiRc | ReleaseAllActiveCalls () const
CallApiRc | ReleaseAllHeldCalls () const
CallApiRc | ReleaseMpty (UINT32 &duration, BOOLEAN wait_condition=FALSE) const
CallApiRc | Retrieve (CallIndex idx)
CallApiRc | SplitMpty (CallIndex call_index)
CallApiRc | SwapCalls () const
virtual | ~CrssHandler ()

Detailed Description

The class CrssHandler supports call related supplementary services like Hold(), Retrieve(), Swap(), etc. Furthermore, there are methods for multi-party call support. The methods are active wait dispatcher based, i.e. the methods return upon completion of the whole opertaion. Explicit call transfer is one exception, the disconnect indications for the both calls will arrive asyncronously after the method returns.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CrssHandler::CrssHandler ( )

Default constructor. Sets the default pointer in the base class.

CrssHandler::~CrssHandler ( ) [virtual]

Member Function Documentation

CallApiRc CrssHandler::ExplicitCallTransfer ( CallIndex call_index )

Sends an explicit call transfer request to the network. The methos returns upon sucessful ECT request (the disconnect indications for the two calls will follow up) or on failure (network denies the ECT request, or the ECT timer expires.

Parameters:
call_index One of the two calls to be transfered.
Returns:
CallApiRc See CallHdl::ExplicitCallTransfer().

HandlerId CrssHandler::GetHandlerId ( ) const [virtual]

SsErrorCode CrssHandler::GetLastErrorCode ( ) const [inline]

Returns the error code occurred the last time while the active wait dispatcher CrssDispatcher was invoked. A return value of SsErrorCode::NoError indicates that no particular error code has been sent from the protocol stack.

CallApiRc CrssHandler::Hold ( CallIndex idx )

Holds an active call and returns NoError if successful. Starts a StackMsgActiveWaitDispatcher, sends the corresponding request to the protocol stack and evaluates the messages of the protocol stack in the methods of CallDispatcher. Refer to the documentation of Hold() in the class CallHdl.

Parameters:
call_index A reference to the call to be held.
Returns:
Refer to Hold() of class CallHdl.

CallApiRc CrssHandler::JoinCalls ( )

Creates a multi party call from a held and an active call, or adds an active call to an existing multi party call. .

Returns:
Refer to JoinCalls() of class CallHdl.

CallApiRc CrssHandler::ReleaseActiveCall ( ) const

Analogue to ReleaseAllActiveCalls() but releases only one specific active call.Further information is also avaible in the documentation of class CallHdl.

Parameters:
call_index Refers to the call to be released.
Returns:
Refer to ReleaseActiveCall() of class CallHdl.

CallApiRc CrssHandler::ReleaseAllActiveCalls ( ) const

Analogue to ReleaseAllHeldCalls() but releases all calls in state active.

Returns:
Refer to ReleaseAllActiveCalls() of class CallHdl.

CallApiRc CrssHandler::ReleaseAllHeldCalls ( ) const

Releases all calls (voice and data) which are in state hold. Sends the corresponding request to the protocol stack. The internal data structure is updated immediately. A the disconnection confirmation will be sent by network or the stack itself (after 30sec). One call index is given to the protocol stack as prepresentant for all held calls.

Returns:
CallDataLocked - Refer to Setup(...).

CallApiRc CrssHandler::ReleaseMpty | ( | UINT32 & | duration,
 |  | BOOLEAN | wait_condition = FALSE
 | ) | const

Releases all members of an active or held multi party call.

Parameters:
duration | Will be set to the call duration value.
wait_condition | TRUE for synchronous waiting of release
Returns:
Refer to Release() of class MptyCallHdl.

CallApiRc CrssHandler::Retrieve ( CallIndex idx )

Retrieves a held call and returns NoError if successful. Starts a StackMsgActiveWaitDispatcher, sends the corresponding request to the protocol stack and evaluates the messages of the protocol stack in the methods of CallDispatcher. Refer to the documentation of Retrieve() in the class CallHdl..

Parameters:
call_index The reference to the call to be retrieved.
Returns:
Refer to Retrieve() of class CallHdl.

CallApiRc CrssHandler::SplitMpty ( CallIndex call_index )

Holds the active multi-party call except of the call call_index which remains active.

Parameters:
call_index The call which has to be splitted from the multi- party call. .
Returns:
Refer to JoinCalls() of class CallHdl.

CallApiRc CrssHandler::SwapCalls ( ) const

The method SwapCalls() holds the active call, retrieves the held call and returns NoError in case of success. SwapCalls() consecutively calls Hold(CallIndex idx) and Retrieve(CallIndex idx). Refer to this methods for more detailed information.

Returns:
Refer to CallHdl::SwapCalls().

The documentation for this class was generated from the following files:
  • Asc/CrssHandler.hpp
  • Asc/CrssHandler.cpp
Generated on Wed Jan 25 01:08:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CsdDataConn Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CsdDataConn Class Reference
[Socket]

#include <Apoxi/Socket/CsdDataConn.hpp>

Inheritance diagram for CsdDataConn:

[legend]
Collaboration diagram for CsdDataConn:

[legend]

Public Member Functions

virtual void | OnReleaseCompleted (DcError error)
virtual void | OnSetupCompleted (DcError error)

Protected Member Functions

virtual void | Cleanup ()
CsdDataConn (const DataConnProfilePtr &profile)
const CsdDataConnProfile & | MyProfile () const
virtual void | OnAfterPppRelease ()
virtual void | OnBeforePppSetup ()
virtual void | PostInfoMsg (MessageType type) const
void | ReleaseDataCall ()
virtual | ~CsdDataConn ()

Protected Attributes

DcError m_dc_err
Error of last data call operation.
CallApiRc m_dch_err
Error of last data call handler operation.

Friends

class | DataConnProfile
class | NiSharedPtr< DataConn >

Constructor & Destructor Documentation

CsdDataConn::CsdDataConn ( const DataConnProfilePtr & profile ) [protected]

Creates a CSD data connection which uses profile on setup. The given profile smart pointer must be valid, otherwise an assertion holds.

CsdDataConn::~CsdDataConn ( ) [protected, virtual]

Member Function Documentation

void CsdDataConn::Cleanup ( ) [protected, virtual]

Cleans up the internals to virginal state.

Reimplemented from PppDataConn.

const CsdDataConnProfile& CsdDataConn::MyProfile ( ) const [inline, protected]

Reimplemented from DataConn.

void CsdDataConn::OnAfterPppRelease ( ) [protected, virtual]

Release the data call.

Reimplemented from PppDataConn.

void CsdDataConn::OnBeforePppSetup ( ) [protected, virtual]

Set up the data call.

Reimplemented from PppDataConn.

void CsdDataConn::OnReleaseCompleted ( DcError error ) [virtual]

DataCall release result callback.

Implements DataCallControl.

void CsdDataConn::OnSetupCompleted ( DcError error ) [virtual]

DataCall setup result callback.

Implements DataCallControl.

void CsdDataConn::PostInfoMsg ( MessageType type ) const [protected, virtual]

void CsdDataConn::ReleaseDataCall ( ) [protected]

Friends And Related Function Documentation

friend class DataConnProfile [friend]

Reimplemented from DataConn.

friend class NiSharedPtr< DataConn > [friend]

Reimplemented from DataConn.

Field Documentation

DcError CsdDataConn::m_dc_err [protected]

Error of last data call operation.

CallApiRc CsdDataConn::m_dch_err [protected]

Error of last data call handler operation.

The documentation for this class was generated from the following files:
  • Socket/CsdDataConn.hpp
  • Socket/CsdDataConn.cpp
Generated on Wed Jan 25 01:08:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CsdDataConnAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CsdDataConnAccessor Class Reference
[DataConn]

#include <Applications/DataConn/DataConnAccessor.hpp>

Inheritance diagram for CsdDataConnAccessor:

[legend]
Collaboration diagram for CsdDataConnAccessor:

[legend]

Public Member Functions

CsdDataConnAccessor (CsdDataConnProfile *profile)
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
void | Init ()
virtual void | Update ()
virtual | ~CsdDataConnAccessor ()

Protected Member Functions

virtual INT | CountSettings () const
virtual void | OnTrigger (INT selected_idx)

Constructor & Destructor Documentation

CsdDataConnAccessor::CsdDataConnAccessor ( CsdDataConnProfile * profile )

CsdDataConnAccessor::~CsdDataConnAccessor ( ) [virtual]

Member Function Documentation

INT CsdDataConnAccessor::CountSettings ( ) const [protected, virtual]

Reimplemented from DataConnAccessor.

const WCHAR * CsdDataConnAccessor::GetItemText ( BOOLEAN highlighted ) [virtual]

Reimplemented from DataConnAccessor.

void CsdDataConnAccessor::Init ( )

Reimplemented from DataConnAccessor.

void CsdDataConnAccessor::OnTrigger ( INT selected_idx ) [protected, virtual]

Reimplemented from DataConnAccessor.

void CsdDataConnAccessor::Update ( ) [virtual]

Reimplemented from DataConnAccessor.

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnAccessor.hpp
  • Applications/DataConn/DataConnAccessor.cpp
Generated on Wed Jan 25 01:08:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CsdDataConnProfile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CsdDataConnProfile Class Reference
[Socket]

#include <Apoxi/Socket/CsdDataConnProfile.hpp>

Inheritance diagram for CsdDataConnProfile:

[legend]
Collaboration diagram for CsdDataConnProfile:

[legend]

Public Types

enum | CallType { c_isdn = 0, c_analog = 1 }
enum DataRate {
c_data_rate_2400 = 1, c_data_rate_4800 = 2, c_data_rate_9600 = 4, c_data_rate_14400 = 6,
c_data_rate_19200 = 8, c_data_rate_28800 = 12
}

Public Member Functions

CsdDataConnProfile ()
CallType | GetCallType () const
UINT32 | GetDataBaudRate () const
const DataCallContext & | GetDataCallContext () const
DataRate | GetDataRate () const
const PhoneNumber & | GetPhoneNumber () const
void | SetCallType (CallType ct)
void | SetDataCallContext (const DataCallContext &context)
void | SetDataRate (DataRate dr)
void | SetPhoneNumber (const PhoneNumber &pn)
virtual | ~CsdDataConnProfile ()

Protected Member Functions

virtual void | Assign (const DataConnProfile &from_dcp)
virtual DataConnProfile * | New () const
virtual void | SaveFrom (const PersistDataConnProfile &bpp)
virtual void | SaveTo (PersistDataConnProfile &bpp) const

Data Structures

struct | Bit
struct | Persist

Detailed Description

Circuit switched bearer profile. Use this profile type to define CSD data connections.

Member Enumeration Documentation

enum CsdDataConnProfile::CallType

Enumerator:
c_isdn
c_analog

enum CsdDataConnProfile::DataRate

Enumerator:
c_data_rate_2400
c_data_rate_4800
c_data_rate_9600
c_data_rate_14400
c_data_rate_19200
c_data_rate_28800

Constructor & Destructor Documentation

CsdDataConnProfile::CsdDataConnProfile ( )

CsdDataConnProfile::~CsdDataConnProfile ( ) [virtual]

Member Function Documentation

void CsdDataConnProfile::Assign ( const DataConnProfile & from_dcp ) [protected, virtual]

Copies and sets all properties of the given data connection profile object, especially used for cloning.

Reimplemented from DataConnProfile.

CallType CsdDataConnProfile::GetCallType ( ) const [inline]

Return data call type of CSD connection (ISDN / Analog).

UINT32 CsdDataConnProfile::GetDataBaudRate ( ) const [inline]

Return baud rate of defined data rate (i.e. 9600 for c_data_rate_9600).

const DataCallContext& CsdDataConnProfile::GetDataCallContext ( ) const [inline]

Return the context (setup parameters) for the data call.

DataRate CsdDataConnProfile::GetDataRate ( ) const [inline]

Return data rate of CSD profile.

const PhoneNumber& CsdDataConnProfile::GetPhoneNumber ( ) const [inline]

Return dial up number of ISP (Internet Service Provider).

DataConnProfile * CsdDataConnProfile::New ( ) const [protected, virtual]

Return a new data connection profile object based on the current dynamic type.

Implements DataConnProfile.

void CsdDataConnProfile::SaveFrom ( const PersistDataConnProfile & bpp ) [protected, virtual]

Reimplemented from DataConnProfile.

void CsdDataConnProfile::SaveTo ( PersistDataConnProfile & bpp ) const [protected, virtual]

Reimplemented from DataConnProfile.

void CsdDataConnProfile::SetCallType ( CallType ct ) [inline]

Set data call type of CSD connection.

void CsdDataConnProfile::SetDataCallContext ( const DataCallContext & context ) [inline]

Set the context (setup parameters) for the data call.

void CsdDataConnProfile::SetDataRate ( DataRate dr ) [inline]

Set data rate of CSD profile. Currently only data rates up to 9600 baud are supported.

void CsdDataConnProfile::SetPhoneNumber ( const PhoneNumber & pn ) [inline]

Set dial up number of ISP.

The documentation for this class was generated from the following files:
  • Socket/CsdDataConnProfile.hpp
  • Socket/CsdDataConnProfile.cpp
Generated on Wed Jan 25 01:08:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CsdDataConnProfile::Bit Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CsdDataConnProfile::Bit

CsdDataConnProfile::Bit Struct Reference

#include <Apoxi/Socket/CsdDataConnProfile.hpp>

Data Fields

UINT | m_call_type: 1
UINT | m_data_rate: 4

Field Documentation

UINT CsdDataConnProfile::Bit::m_call_type

UINT CsdDataConnProfile::Bit::m_data_rate

The documentation for this struct was generated from the following file:
  • Socket/CsdDataConnProfile.hpp
Generated on Wed Jan 25 01:08:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CsdDataConnProfile::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
CsdDataConnProfile::Persist

CsdDataConnProfile::Persist Struct Reference

#include <Apoxi/Socket/CsdDataConnProfile.hpp>

Collaboration diagram for CsdDataConnProfile::Persist:

[legend]

Data Fields

Bit m_bit
UINT8 m_phone_no [c_max_bcd_number_size]

Field Documentation

Bit CsdDataConnProfile::Persist::m_bit

UINT8 CsdDataConnProfile::Persist::m_phone_no[c_max_bcd_number_size]

The documentation for this struct was generated from the following file:
  • Socket/CsdDataConnProfile.hpp
Generated on Wed Jan 25 01:08:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CsdDataConnProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CsdDataConnProvider Class Reference
[Synchronization]

#include <Applications/DataConn/CsdDataConnProvider.hpp>

Inheritance diagram for CsdDataConnProvider:

[legend]
Collaboration diagram for CsdDataConnProvider:

[legend]

Public Types

typedef DataConnProvider | Base

Public Member Functions

CsdDataConnProvider ()
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT column)
SetDataItem sets data items
virtual | ~CsdDataConnProvider ()
Destructor.

Protected Member Functions

virtual void | ClearProfile ()
virtual DataConnProfile * | GetProfileInstance ()

Member Typedef Documentation

typedef DataConnProvider CsdDataConnProvider::Base

Reimplemented from DataConnProvider.

Constructor & Destructor Documentation

CsdDataConnProvider::CsdDataConnProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

CsdDataConnProvider::~CsdDataConnProvider ( ) [virtual]

Destructor.

Member Function Documentation

void CsdDataConnProvider::ClearProfile ( ) [protected, virtual]

Implements DataConnProvider.

BOOLEAN CsdDataConnProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Reimplemented from DataConnProvider.

virtual DataConnProfile* CsdDataConnProvider::GetProfileInstance ( ) [inline, protected, virtual]

Implements DataConnProvider.

virtual INT CsdDataConnProvider::GetProviderId ( ) const [inline, virtual]

Returns the provider id.

Reimplemented from DataConnProvider.

BOOLEAN CsdDataConnProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | column
 | ) | [virtual]

SetDataItem sets data items

Reimplemented from DataConnProvider.

The documentation for this class was generated from the following files:
  • Applications/DataConn/CsdDataConnProvider.hpp
  • Applications/DataConn/CsdDataConnProvider.cpp
Generated on Wed Jan 25 01:08:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CsdSettingsTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CsdSettingsTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for CsdSettingsTable:

[legend]
Collaboration diagram for CsdSettingsTable:

[legend]

Static Public Member Functions

static const WCHAR * GetSetting (DataConnApp::CsdSettingsTypeId setting)

Member Function Documentation

static const WCHAR* CsdSettingsTable::GetSetting ( DataConnApp::CsdSettingsTypeId setting ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:08:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CTControlFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CTControlFrameView Class Reference

#include <Apoxi/GlobalThemes/CustomizableTheme/CTControlFrameView.hpp>

Inheritance diagram for CTControlFrameView:

[legend]
Collaboration diagram for CTControlFrameView:

[legend]

Public Member Functions

CTControlFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size)
CTControlFrameView ()
void | SetDimensions (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size)
virtual | ~CTControlFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

CTControlFrameView::CTControlFrameView ( )

CTControlFrameView::CTControlFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size
 | ) |

CTControlFrameView::~CTControlFrameView ( ) [virtual]

Member Function Documentation

void CTControlFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

void CTControlFrameView::SetDimensions | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size
 | ) |

APOXI-Internal method.

This method sets the dimensions (left, right, top, bottom sizes). It is called by CustomizableTheme from its Update(...) method. It shouldn't be necessary for application programmers to use it.

The documentation for this class was generated from the following files:
  • GlobalThemes/CustomizableTheme/CTControlFrameView.hpp
  • GlobalThemes/CustomizableTheme/CTControlFrameView.cpp
Generated on Wed Jan 25 01:08:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CtmInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CtmInfoIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for CtmInfoIndArg:

[legend]
Collaboration diagram for CtmInfoIndArg:

[legend]

Public Types

enum | { ID = 1133 }

Public Member Functions

CtmInfoIndArg ()
const Tipd & | GetTipd () const
BOOLEAN | IsCtm () const
void | SetCtm (BOOLEAN ctm)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const CtmInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CtmInfoIndArg: reflects the signal MN_CTM_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CtmInfoIndArg::CtmInfoIndArg ( )

Member Function Documentation

const CtmInfoIndArg & CtmInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& CtmInfoIndArg::GetTipd ( ) const [inline]

BOOLEAN CtmInfoIndArg::IsCtm ( ) const [inline]

void CtmInfoIndArg::SetCtm ( BOOLEAN ctm ) [inline]

void CtmInfoIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:08:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CtmInfoIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CtmInfoIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CtmInfoIndMsg:

[legend]
Collaboration diagram for CtmInfoIndMsg:

[legend]

Public Types

enum | { ID = 18956 }

Public Member Functions

virtual Message * | Clone () const
CtmInfoIndMsg (ExecutionContext *context, const CallHdl &call_hdl, BOOLEAN ctm)
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsCtm () const
void | SetCallHdl (const CallHdl &call_hdl)
void | SetCtm (BOOLEAN ctm)
virtual | ~CtmInfoIndMsg ()

Detailed Description

CtmInfoIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CtmInfoIndMsg::CtmInfoIndMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl,
 |  | BOOLEAN | ctm
 | ) |

CtmInfoIndMsg::~CtmInfoIndMsg ( ) [virtual]

Member Function Documentation

Message * CtmInfoIndMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& CtmInfoIndMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & CtmInfoIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BOOLEAN CtmInfoIndMsg::IsCtm ( ) const [inline]

void CtmInfoIndMsg::SetCallHdl ( const CallHdl & call_hdl ) [inline]

void CtmInfoIndMsg::SetCtm ( BOOLEAN ctm ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:08:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CTPanelView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CTPanelView Class Reference

#include <Apoxi/GlobalThemes/CustomizableTheme/CTPanelView.hpp>

Inheritance diagram for CTPanelView:

[legend]
Collaboration diagram for CTPanelView:

[legend]

Public Member Functions

CTPanelView (XYDIM default_height)
CTPanelView ()
virtual void | Update (const Theme &theme)
virtual | ~CTPanelView ()

Protected Member Functions

virtual void | DrawPanel (const Panel &panel, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

CTPanelView::CTPanelView ( )

CTPanelView::CTPanelView ( XYDIM default_height )

CTPanelView::~CTPanelView ( ) [virtual]

Member Function Documentation

void CTPanelView::DrawPanel | ( | const Panel & | panel,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PanelView.

void CTPanelView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • GlobalThemes/CustomizableTheme/CTPanelView.hpp
  • GlobalThemes/CustomizableTheme/CTPanelView.cpp
Generated on Wed Jan 25 01:08:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CTPositionIndicatorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CTPositionIndicatorView Class Reference

#include <Apoxi/GlobalThemes/CustomizableTheme/CTPositionIndicatorView.hpp>

Inheritance diagram for CTPositionIndicatorView:

[legend]
Collaboration diagram for CTPositionIndicatorView:

[legend]

Public Member Functions

CTPositionIndicatorView (XYDIM size)
CTPositionIndicatorView ()
void | SetPosIndSize (XYDIM size)
virtual | ~CTPositionIndicatorView ()

Protected Member Functions

virtual void | DrawPositionIndicator (const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const
TODO: implement horizontal position indicators.

Constructor & Destructor Documentation

CTPositionIndicatorView::CTPositionIndicatorView ( )

CTPositionIndicatorView::CTPositionIndicatorView ( XYDIM size ) [explicit]

virtual CTPositionIndicatorView::~CTPositionIndicatorView ( ) [inline, virtual]

Member Function Documentation

void CTPositionIndicatorView::DrawPositionIndicator | ( | const PositionIndicator & | pos_ind,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

TODO: implement horizontal position indicators.

Implements PositionIndicatorView.

void CTPositionIndicatorView::SetPosIndSize ( XYDIM size )

APOXI-Internal method.

This method sets the PositionIndicator's default size. It is called by CustomizableTheme from its Update(...) method. It shouldn't be necessary for application programmers to use it.

The documentation for this class was generated from the following files:
  • GlobalThemes/CustomizableTheme/CTPositionIndicatorView.hpp
  • GlobalThemes/CustomizableTheme/CTPositionIndicatorView.cpp
Generated on Wed Jan 25 01:08:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CTProgressBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CTProgressBarView Class Reference

#include <Apoxi/GlobalThemes/CustomizableTheme/CTProgressBarView.hpp>

Inheritance diagram for CTProgressBarView:

[legend]
Collaboration diagram for CTProgressBarView:

[legend]

Public Member Functions

CTProgressBarView (XYDIM default_height)
CTProgressBarView ()
void | SetDefaultProgressBarHeight (XYDIM height)
virtual void | Update (const Theme &theme)
virtual | ~CTProgressBarView ()

Protected Member Functions

virtual void | DrawProgressBar (const ProgressBar &progress_bar, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

CTProgressBarView::CTProgressBarView ( )

CTProgressBarView::CTProgressBarView ( XYDIM default_height ) [explicit]

virtual CTProgressBarView::~CTProgressBarView ( ) [inline, virtual]

Member Function Documentation

void CTProgressBarView::DrawProgressBar | ( | const ProgressBar & | progress_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements ProgressBarView.

void CTProgressBarView::SetDefaultProgressBarHeight ( XYDIM height )

APOXI-Internal method.

This method sets the ProgressBar's default height. It is called by CustomizableTheme from its Update(...) method. It shouldn't be necessary for application programmers to use it.

void CTProgressBarView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • GlobalThemes/CustomizableTheme/CTProgressBarView.hpp
  • GlobalThemes/CustomizableTheme/CTProgressBarView.cpp
Generated on Wed Jan 25 01:08:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CTPushButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CTPushButtonView Class Reference

#include <Apoxi/GlobalThemes/CustomizableTheme/CTPushButtonView.hpp>

Inheritance diagram for CTPushButtonView:

[legend]
Collaboration diagram for CTPushButtonView:

[legend]

Public Member Functions

CTPushButtonView (XYDIM default_height)
CTPushButtonView ()
void | SetDefaultPushButtonHeight (XYDIM height)
virtual void | Update (const Theme &theme)
virtual | ~CTPushButtonView ()

Protected Member Functions

virtual void | DrawPushButton (const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

CTPushButtonView::CTPushButtonView ( )

CTPushButtonView::CTPushButtonView ( XYDIM default_height ) [explicit]

virtual CTPushButtonView::~CTPushButtonView ( ) [inline, virtual]

Member Function Documentation

void CTPushButtonView::DrawPushButton | ( | const PushButton & | push_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PushButtonView.

void CTPushButtonView::SetDefaultPushButtonHeight ( XYDIM height )

APOXI-Internal method.

This method sets the PushButton's default height. It is called by CustomizableTheme from its Update(...) method. It shouldn't be necessary for application programmers to use it.

void CTPushButtonView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • GlobalThemes/CustomizableTheme/CTPushButtonView.hpp
  • GlobalThemes/CustomizableTheme/CTPushButtonView.cpp
Generated on Wed Jan 25 01:08:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CTResourcePack Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CTResourcePack Class Reference

#include <Apoxi/GlobalThemes/CustomizableTheme/CTResourcePack.hpp>

Collaboration diagram for CTResourcePack:

[legend]

Public Types

enum BorderModeType {
Flat, Raised, RaisedBorder, Sunken,
SunkenBorder
}
enum | CornerModeType { Angular, Rounded }
enum | LightOriginType { LowerLeft, LowerRight, UpperLeft, UpperRight }
enum ParseType {
UnknownParseType, BooleanParseType, XyDimParseType, IntegerParseType,
UInt8ParseType, UInt16ParseType, WStringParseType, ColorParseType,
LightOriginParseType, CornerModeParseType, BorderModeParseType, ProgressBarDrawModeParseType,
TextAttrParseType, TextAlignParseType, FontAlignParseType
}
enum | ProgressBarDrawModeType { DrawPrimitives, DrawBitmap }
enum PropertyType {
UnknownPropertyType = 255, SubComponentPropertyType, SystemColorTable = 0, ThemeName,
ClientBackgroundColor, ClientForegroundColor, ActiveFrameBackgroundColor, ActiveFrameForegroundColor,
InactiveFrameBackgroundColor, InactiveFrameForegroundColor, SelectionBackgroundColor, SelectionForegroundColor,
ShadedColor, ButtonBackgroundColor, ButtonForegroundColor, ContextMenuBackgroundColor,
LightOrigin, DropShadowWidth, DropShadowDistance, DropShadowColor,
DropShadowMaxAlpha, DropShadowMinAlpha, BackgroundDim, SelectedCheckBoxBitmapUri,
DeselectedCheckBoxBitmapUri, SelectedRadioButtonBitmapUri, DeselectedRadioButtonBitmapUri, SelectedCheckBoxBitmap,
DeselectedCheckBoxBitmap, SelectedRadioButtonBitmap, DeselectedRadioButtonBitmap, BorderMode,
BorderWidth, OuterBorderWidth, BorderCornerMode, RoundedCornerRadius,
DropShadowEnabled, ComponentForegroundColor, ComponentBackgroundColor, OuterBorderColor,
InnerBorderColor, LightColor, DarkerLightColor, LightShadow,
DarkShadow, TitleBarHeight, TitleBarBitmapUri, TitleBarBitmap,
InactiveTitleBarHeight, InactiveTitleBarBitmapUri, InactiveTitleBarBitmap, SoftkeyBarHeight,
SoftkeyBarButtonSpacing, SoftkeyBarBackgroundBitmapUri, SoftkeyBarBackgroundBitmap, SoftkeyBarButton1BitmapUri,
SoftkeyBarButton1Bitmap, SoftkeyBarButton2BitmapUri, SoftkeyBarButton2Bitmap, SoftkeyBarNavGuideEnabled,
SoftkeyBarNavGuideActiveColor, SoftkeyBarNavGuideInactiveColor, ProgressBarDrawingMode, ProgressBarBitmap,
ProgressBarDrawPercentage, ProgressBarHeight, PushButtonHeight, PositionIndicatorWidth,
PositionIndicatorDrawArrows, PositionIndicatorArrowHeight, TextFormatProp, TextAlignProp,
TextAttrProp, FontAlignProp
}
enum ResourceType {
Global = 0, ControlFrameControl, WindowFrameControl, WindowTitleBarControl,
InactiveWindowFrameControl, InactiveWindowTitleBarControl, SoftkeyBarControl, SoftkeyBarButtonsControl,
ProgressBarControl, ProgressBarBarControl, PushButtonControl, PositionIndicatorControl,
PositionIndicatorBarControl, PositionIndicatorArrowBoxControl
}

Public Member Functions

CTResourcePack ()
BOOLEAN | CustomizedDataAvailable ()
WString | GetName () const
convenience method for retrieving the name. Could also use GetProperty (Global, ThemeName).
void * | GetProperty (ResourceType resource, PropertyType property)
WString | GetResourceUri () const
void | InitProperties ()
BOOLEAN | ReadProperties (CTResourceParser &parser)
BOOLEAN | SetProperty (ResourceType resource, PropertyType property, void *data)
void | SetResourceUri (const WString &resource_uri)
~CTResourcePack ()

Friends

class | CTResourceParser

Data Structures

struct | CommonProperties

Member Enumeration Documentation

enum CTResourcePack::BorderModeType

Enumerator:
Flat
Raised
RaisedBorder
Sunken
SunkenBorder

enum CTResourcePack::CornerModeType

Enumerator:
Angular
Rounded

enum CTResourcePack::LightOriginType

Enumerator:
LowerLeft
LowerRight
UpperLeft
UpperRight

enum CTResourcePack::ParseType

Enumerator:
UnknownParseType
BooleanParseType
XyDimParseType
IntegerParseType
UInt8ParseType
UInt16ParseType
WStringParseType
ColorParseType
LightOriginParseType
CornerModeParseType
BorderModeParseType
ProgressBarDrawModeParseType
TextAttrParseType
TextAlignParseType
FontAlignParseType

enum CTResourcePack::ProgressBarDrawModeType

Enumerator:
DrawPrimitives
DrawBitmap

enum CTResourcePack::PropertyType

Enumerator:
UnknownPropertyType
SubComponentPropertyType
SystemColorTable
ThemeName
ClientBackgroundColor
ClientForegroundColor
ActiveFrameBackgroundColor
ActiveFrameForegroundColor
InactiveFrameBackgroundColor
InactiveFrameForegroundColor
SelectionBackgroundColor
SelectionForegroundColor
ShadedColor
ButtonBackgroundColor
ButtonForegroundColor
ContextMenuBackgroundColor
LightOrigin
DropShadowWidth
DropShadowDistance
DropShadowColor
DropShadowMaxAlpha
DropShadowMinAlpha
BackgroundDim
SelectedCheckBoxBitmapUri
DeselectedCheckBoxBitmapUri
SelectedRadioButtonBitmapUri
DeselectedRadioButtonBitmapUri
SelectedCheckBoxBitmap
DeselectedCheckBoxBitmap
SelectedRadioButtonBitmap
DeselectedRadioButtonBitmap
BorderMode
BorderWidth
OuterBorderWidth
BorderCornerMode
RoundedCornerRadius
DropShadowEnabled
ComponentForegroundColor
ComponentBackgroundColor
OuterBorderColor
InnerBorderColor
LightColor
DarkerLightColor
LightShadow
DarkShadow
TitleBarHeight
TitleBarBitmapUri
TitleBarBitmap
InactiveTitleBarHeight
InactiveTitleBarBitmapUri
InactiveTitleBarBitmap
SoftkeyBarHeight
SoftkeyBarButtonSpacing
SoftkeyBarBackgroundBitmapUri
SoftkeyBarBackgroundBitmap
SoftkeyBarButton1BitmapUri
SoftkeyBarButton1Bitmap
SoftkeyBarButton2BitmapUri
SoftkeyBarButton2Bitmap
SoftkeyBarNavGuideEnabled
SoftkeyBarNavGuideActiveColor
SoftkeyBarNavGuideInactiveColor
ProgressBarDrawingMode
ProgressBarBitmap
ProgressBarDrawPercentage
ProgressBarHeight
PushButtonHeight
PositionIndicatorWidth
PositionIndicatorDrawArrows
PositionIndicatorArrowHeight
TextFormatProp
TextAlignProp
TextAttrProp
FontAlignProp

enum CTResourcePack::ResourceType

Enumerator:
Global
ControlFrameControl
WindowFrameControl
WindowTitleBarControl
InactiveWindowFrameControl
InactiveWindowTitleBarControl
SoftkeyBarControl
SoftkeyBarButtonsControl
ProgressBarControl
ProgressBarBarControl
PushButtonControl
PositionIndicatorControl
PositionIndicatorBarControl
PositionIndicatorArrowBoxControl

Constructor & Destructor Documentation

CTResourcePack::CTResourcePack ( )

CTResourcePack::~CTResourcePack ( )

Member Function Documentation

BOOLEAN CTResourcePack::CustomizedDataAvailable ( ) [inline]

Returns:
TRUE if the resource pack has read its properties from a resource file or other data source; FALSE if only the hard-coded default values are available

WString CTResourcePack::GetName ( ) const [inline]

convenience method for retrieving the name. Could also use GetProperty (Global, ThemeName).

void * CTResourcePack::GetProperty | ( | ResourceType | resource,
 |  | PropertyType | property
 | ) |

WString CTResourcePack::GetResourceUri ( ) const [inline]

void CTResourcePack::InitProperties ( )

BOOLEAN CTResourcePack::ReadProperties ( CTResourceParser & parser )

BOOLEAN CTResourcePack::SetProperty | ( | ResourceType | resource,
 |  | PropertyType | property,
 |  | void * | data
 | ) |

Has one side-effect: if (De)SeclectedCheckboxUri or (De)SelectedRadioButtonUri is set, the specified resource is read immediately if possible, and can be retrieved by using GetProperty (De)SelectedCheckBoxBitmap and (De)SelectedRadioButtonBitmap.

void CTResourcePack::SetResourceUri ( const WString & resource_uri ) [inline]

Friends And Related Function Documentation

friend class CTResourceParser [friend]

The documentation for this class was generated from the following files:
  • GlobalThemes/CustomizableTheme/CTResourcePack.hpp
  • GlobalThemes/CustomizableTheme/CTResourcePack.cpp
Generated on Wed Jan 25 01:08:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CTWindowFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CTWindowFrameView Class Reference

#include <Apoxi/GlobalThemes/CustomizableTheme/CTWindowFrameView.hpp>

Inheritance diagram for CTWindowFrameView:

[legend]
Collaboration diagram for CTWindowFrameView:

[legend]

Public Member Functions

CTWindowFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size, XYDIM title_height, XYDIM softkey_bar_height)
CTWindowFrameView ()
void | SetDimensions (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size, XYDIM title_height, XYDIM softkey_bar_height)
virtual | ~CTWindowFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawWindowExtensions (const Window &window, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

CTWindowFrameView::CTWindowFrameView ( )

CTWindowFrameView::CTWindowFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size,
 |  | XYDIM | title_height,
 |  | XYDIM | softkey_bar_height
 | ) |

CTWindowFrameView::~CTWindowFrameView ( ) [virtual]

Member Function Documentation

void CTWindowFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

void CTWindowFrameView::DrawWindowExtensions | ( | const Window & | window,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

See also:
ControlFrameView::DrawWindowExenstions

Implements WindowFrameView.

void CTWindowFrameView::SetDimensions | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size,
 |  | XYDIM | title_height,
 |  | XYDIM | softkey_bar_height
 | ) |

APOXI-Internal method.

This method sets the dimensions (left, right, top, bottom sizes, and titlebar and softkeybar height). It is called by CustomizableTheme from its Update(...) method. It shouldn't be necessary for application programmers to use it.

The documentation for this class was generated from the following files:
  • GlobalThemes/CustomizableTheme/CTWindowFrameView.hpp
  • GlobalThemes/CustomizableTheme/CTWindowFrameView.cpp
Generated on Wed Jan 25 01:08:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CugCallMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CugCallMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CugCallMsg:

[legend]
Collaboration diagram for CugCallMsg:

[legend]

Public Types

enum | { ID = 18531 }

Public Member Functions

virtual Message * | Clone () const
CugCallMsg (ExecutionContext *context, const Tipd &tipd, INT cug_index)
INT | GetCugIndex () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
virtual | ~CugCallMsg ()

Detailed Description

CugCallMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CugCallMsg::CugCallMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | INT | cug_index
 | ) |

CugCallMsg::~CugCallMsg ( ) [virtual]

Member Function Documentation

Message * CugCallMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

INT CugCallMsg::GetCugIndex ( ) const [inline]

const MsgMetaData & CugCallMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& CugCallMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:08:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CugDescriptor Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CugDescriptor Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

INT | index
CugSelector selected_cug
BOOLEAN | suppress_oa

Field Documentation

INT CugDescriptor::index

CugSelector CugDescriptor::selected_cug

BOOLEAN CugDescriptor::suppress_oa

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:08:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CurrencyCode Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CurrencyCode Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [3]

Field Documentation

UINT8 CurrencyCode::val[3]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:08:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CurrentCallMeterMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CurrentCallMeterMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CurrentCallMeterMsg:

[legend]
Collaboration diagram for CurrentCallMeterMsg:

[legend]

Public Types

enum | { ID = 18420 }

Public Member Functions

virtual Message * | Clone () const
CurrentCallMeterMsg (ExecutionContext *context, const CallHdl &call_hdl, ULONG this_call_ccm, ULONG all_calls_ccm)
ULONG | GetAllCallsCcm () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
ULONG | GetThisCallCcm () const
void | SetAllCallsCcm (ULONG all_calls_ccm)
void | SetCallHdl (const CallHdl &call_hdl)
void | SetThisCallCcm (ULONG this_call_ccm)
virtual | ~CurrentCallMeterMsg ()

Detailed Description

CurrentCallMeterMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CurrentCallMeterMsg::CurrentCallMeterMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl,
 |  | ULONG | this_call_ccm,
 |  | ULONG | all_calls_ccm
 | ) |

CurrentCallMeterMsg::~CurrentCallMeterMsg ( ) [virtual]

Member Function Documentation

Message * CurrentCallMeterMsg::Clone ( ) const [virtual]

Implements Message.

ULONG CurrentCallMeterMsg::GetAllCallsCcm ( ) const [inline]

const CallHdl& CurrentCallMeterMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & CurrentCallMeterMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

ULONG CurrentCallMeterMsg::GetThisCallCcm ( ) const [inline]

void CurrentCallMeterMsg::SetAllCallsCcm ( ULONG all_calls_ccm ) [inline]

void CurrentCallMeterMsg::SetCallHdl ( const CallHdl & call_hdl ) [inline]

void CurrentCallMeterMsg::SetThisCallCcm ( ULONG this_call_ccm ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:08:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CurrentChargeDataMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CurrentChargeDataMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for CurrentChargeDataMsg:

[legend]
Collaboration diagram for CurrentChargeDataMsg:

[legend]

Public Types

enum | { ID = 18421 }

Public Member Functions

virtual Message * | Clone () const
CurrentChargeDataMsg (ExecutionContext *context, const CallHdl &call_hdl, const AocChargeData &this_call_charge, const AocChargeData &all_calls_charge)
const AocChargeData & | GetAllCallsCharge () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
const AocChargeData & | GetThisCallCharge () const
void | SetAllCallsCharge (const AocChargeData &all_calls_charge)
void | SetCallHdl (const CallHdl &call_hdl)
void | SetThisCallCharge (const AocChargeData &this_call_charge)
virtual | ~CurrentChargeDataMsg ()

Detailed Description

CurrentChargeDataMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

CurrentChargeDataMsg::CurrentChargeDataMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl,
 |  | const AocChargeData & | this_call_charge,
 |  | const AocChargeData & | all_calls_charge
 | ) |

CurrentChargeDataMsg::~CurrentChargeDataMsg ( ) [virtual]

Member Function Documentation

Message * CurrentChargeDataMsg::Clone ( ) const [virtual]

Implements Message.

const AocChargeData& CurrentChargeDataMsg::GetAllCallsCharge ( ) const [inline]

const CallHdl& CurrentChargeDataMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & CurrentChargeDataMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const AocChargeData& CurrentChargeDataMsg::GetThisCallCharge ( ) const [inline]

void CurrentChargeDataMsg::SetAllCallsCharge ( const AocChargeData & all_calls_charge ) [inline]

void CurrentChargeDataMsg::SetCallHdl ( const CallHdl & call_hdl ) [inline]

void CurrentChargeDataMsg::SetThisCallCharge ( const AocChargeData & this_call_charge ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:08:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CustomizableTheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CustomizableTheme Class Reference

#include <Apoxi/GlobalThemes/CustomizableTheme/CustomizableTheme.hpp>

Inheritance diagram for CustomizableTheme:

[legend]
Collaboration diagram for CustomizableTheme:

[legend]

Public Member Functions

virtual const BitmapRes * | GetBitmap (BitmapResId id) const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const WCHAR * | GetName () const
Returns the name of the theme. Per default 0 is returned.
virtual const PanelView * | GetPanelView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const PushButtonView * | GetPushButtonView () const
CTResourcePack * GetResourcePack ()
virtual const ColorTable * | GetSystemColorTable () const
virtual const WindowFrameView * | GetWindowFrameView () const
void | SetResourcePack (CTResourcePack *resource_pack)
Sets the resource pack.
virtual void | Update ()
virtual | ~CustomizableTheme ()

Static Public Member Functions

static Rect | AdjustBounds (const Rect &bounds, CTResourcePack *pack, CTResourcePack::ResourceType resource)
static void | DrawComponent (PaintDc &pdc, const Rect &bounds, CTResourcePack *pack, CTResourcePack::ResourceType resource)
static const Theme & | GetInstance (CTResourcePack *pack=0)
static CTResourcePack * | GetResourcePackIfActive ()

Static Public Attributes

static WString | c_theme_name = L"Customizable Theme"

Detailed Description

The Customizable Theme allows the user to set many properties for drawing controls.

Constructor & Destructor Documentation

CustomizableTheme::~CustomizableTheme ( ) [virtual]

Member Function Documentation

Rect CustomizableTheme::AdjustBounds | ( | const Rect & | bounds,
 |  | CTResourcePack * | pack,
 |  | CTResourcePack::ResourceType | resource
 | ) | [static]

void CustomizableTheme::DrawComponent | ( | PaintDc & | pdc,
 |  | const Rect & | bounds,
 |  | CTResourcePack * | pack,
 |  | CTResourcePack::ResourceType | resource
 | ) | [static]

const BitmapRes * CustomizableTheme::GetBitmap ( BitmapResId id ) const [virtual]

const ControlFrameView * CustomizableTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const Theme & CustomizableTheme::GetInstance ( CTResourcePack * pack = 0 ) [static]

Returns:
an instance of the CustomizableTheme. Optionally, you can specify a resource pack that is set for the theme. This is just for your convenience, saving one method call. The same result as doing CTResourcePack* pack = (CTResourcePack*)ResourceManager::GetInstance().Construct(uri); CustomizableTheme& theme = (CustomizableTheme&)CustomizableTheme::GetInstance(pack); can be achieved with CTResourcePack* pack = (CTResourcePack*)ResourceManager::GetInstance().Construct(uri); CustomizableTheme& theme = (CustomizableTheme&)CustomizableTheme::GetInstance(); theme.SetResourcePack(pack); As long as the system is not initialized (System::IsInitialized returns false), a resource pack with default values is returned. This prevents errors when the system is starting up, as theme properties are requested even then.

const WCHAR * CustomizableTheme::GetName ( ) const [virtual]

Returns the name of the theme. Per default 0 is returned.

Reimplemented from Theme.

const PanelView * CustomizableTheme::GetPanelView ( ) const [virtual]

Returns a pointer to a panel view, which is used to draw an instance of the class Panel. The panel usually is aligned at the bottom of the desktop and shows the softkeys.

Reimplemented from Theme.

const PositionIndicatorView * CustomizableTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

const ProgressBarView * CustomizableTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

const PushButtonView * CustomizableTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

CTResourcePack* CustomizableTheme::GetResourcePack ( ) [inline]

Returns:
a pointer to the current resource pack

CTResourcePack * CustomizableTheme::GetResourcePackIfActive ( ) [static]

If the currently active theme is a customizable theme, return its resource pack, 0 otherwise

Returns:
the resource pack

const ColorTable * CustomizableTheme::GetSystemColorTable ( ) const [virtual]

Returns a pointer to the color-table of the system-colors. This method should be overwritten by derived themes providing a pointer to a custom color-table. To stay backward-compatible with older versions of APOXI, 0 is returned in the default-implementation.

Reimplemented from Theme.

const WindowFrameView * CustomizableTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

void CustomizableTheme::SetResourcePack ( CTResourcePack * resource_pack ) [inline]

Sets the resource pack.

void CustomizableTheme::Update ( ) [virtual]

Converts all colors given by the system-color-table to system-colors and invokes View::Update(this) for every View which is part of the theme. Also the fonts are updated which may be specified by ThemeConfig::GetFontId().

Reimplemented from Theme.

Field Documentation

WString CustomizableTheme::c_theme_name = L"Customizable Theme" [static]

The documentation for this class was generated from the following files:
  • GlobalThemes/CustomizableTheme/CustomizableTheme.hpp
  • GlobalThemes/CustomizableTheme/CustomizableTheme.cpp
Generated on Wed Jan 25 01:09:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CustomRingerAudioReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CustomRingerAudioReference Class Reference
[Audio]

#include <Apoxi/Audio/CustomRingerAudioReference.hpp>

Inheritance diagram for CustomRingerAudioReference:

[legend]
Collaboration diagram for CustomRingerAudioReference:

[legend]

Public Types

enum Format {
FormatSmaf, FormatMidi, FormatRmd, FormatImelody,
FormatBuzzer, FormatSmafPhrase
}
Sound formats. More...

Public Member Functions

AudioPlayer::ConstBuffer | GetBuffer () const
UINT32 | GetBufferSize () const
virtual enumClassType | GetClassType () const
Format | GetFormat () const
virtual | ~CustomRingerAudioReference ()

Static Public Member Functions

static SharedPtr< CustomRingerAudioReference > | Create (AudioPlayer::Buffer buffer, UINT32 buffer_size, Format format, BOOLEAN take_ownership)
static SharedPtr< CustomRingerAudioReference > | Create (AudioPlayer::ConstBuffer buffer, UINT32 buffer_size, Format format)

Protected Member Functions

CustomRingerAudioReference (AudioPlayer::Buffer buffer, UINT32 buffer_size, Format format, BOOLEAN take_ownership)
CustomRingerAudioReference (AudioPlayer::ConstBuffer buffer, UINT32 buffer_size, Format format)

Protected Attributes

AudioPlayer::ConstBuffer | m_buffer
UINT32 | m_buffer_size
BOOLEAN | m_data_owned
Format m_format

Detailed Description

Ringer sounds are higher quality sounds made by the polyphonic chip (For instance, Yamaha MA3) or a traditional ringer. These are non-preset sounds. For instance, they could be stored in flash memory.

Member Enumeration Documentation

enum CustomRingerAudioReference::Format

Sound formats.

Enumerator:
FormatSmaf | SMAF (supported only if MAx YAMAHA chip is present).
FormatMidi | MIDI.
FormatRmd | RMD (not supported).
FormatImelody | Imelody (supported only if internal polyringer available).
FormatBuzzer | Buzzer (Obsolete, should not be used anymore).
FormatSmafPhrase | SMAF/Phrase-L1 (supported only if MAx YAMAHA chip is present).

Constructor & Destructor Documentation

CustomRingerAudioReference::~CustomRingerAudioReference ( ) [virtual]

CustomRingerAudioReference::CustomRingerAudioReference | ( | AudioPlayer::ConstBuffer | buffer,
 |  | UINT32 | buffer_size,
 |  | Format | format
 | ) | [protected]

CustomRingerAudioReference::CustomRingerAudioReference | ( | AudioPlayer::Buffer | buffer,
 |  | UINT32 | buffer_size,
 |  | Format | format,
 |  | BOOLEAN | take_ownership
 | ) | [protected]

Member Function Documentation

SharedPtr< CustomRingerAudioReference > CustomRingerAudioReference::Create | ( | AudioPlayer::Buffer | buffer,
 |  | UINT32 | buffer_size,
 |  | Format | format,
 |  | BOOLEAN | take_ownership
 | ) | [static]

Create a new instance.

Parameters:
buffer | The sound data. This must be a pointer to a linear address space, so it can not, for instance, be in the FFS. The format supported depends highly on which ringer device (MA2, MA3 or internal polyringer) is available on the target hardware. Refer to the official specification for the details of the sound data's required format. For instance, see the SMAF specification.
buffer_size,: The number of bytes of data pointed to by buffer.
format | Sound format of the buffer data.
take_ownership,: This should always be true. It exists only to differentiate this overload from the other create() overload.
Returns:
A new instance.

SharedPtr< CustomRingerAudioReference > CustomRingerAudioReference::Create | ( | AudioPlayer::ConstBuffer | buffer,
 |  | UINT32 | buffer_size,
 |  | Format | format
 | ) | [static]

Create a new instance.

Parameters:
buffer | The sound data. This must be a pointer to a linear address space, so it can not, for instance, be in the FFS. The format supported depends highly on which ringer device (MA2, MA3 or internal polyringer) is available on the target hardware. Refer to the official specification for the details of the sound data's required format. For instance, see the SMAF specification.
buffer_size,: The number of bytes of data pointed to by buffer.
format | Sound format of the buffer data.
Returns:
A new instance.

AudioPlayer::ConstBuffer CustomRingerAudioReference::GetBuffer ( ) const

UINT32 CustomRingerAudioReference::GetBufferSize ( ) const

AudioReference::enumClassType CustomRingerAudioReference::GetClassType ( ) const [virtual]

Implements AudioReference.

Reimplemented in CustomSmafPhraseAudioReference.

CustomRingerAudioReference::Format CustomRingerAudioReference::GetFormat ( ) const

Field Documentation

AudioPlayer::ConstBuffer CustomRingerAudioReference::m_buffer [protected]

UINT32 CustomRingerAudioReference::m_buffer_size [protected]

BOOLEAN CustomRingerAudioReference::m_data_owned [protected]

Format CustomRingerAudioReference::m_format [protected]

The documentation for this class was generated from the following files:
  • Audio/CustomRingerAudioReference.hpp
  • Audio/CustomRingerAudioReference.cpp
Generated on Wed Jan 25 01:09:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CustomSmafPhraseAudioReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CustomSmafPhraseAudioReference Class Reference
[Audio]

#include <Apoxi/Audio/CustomSmafPhraseAudioReference.hpp>

Inheritance diagram for CustomSmafPhraseAudioReference:

[legend]
Collaboration diagram for CustomSmafPhraseAudioReference:

[legend]

Public Member Functions

virtual BOOLEAN | CanPlayTogetherWith (const AudioReference &audio_ref) const
virtual VolumeLevel | GetChannelVolume () const
If the sound to be played has only one channel then this is the same as calling GetVolume().
virtual enumClassType | GetClassType () const
virtual ChannelNumber | GetNumberOfChannels () const
virtual void | SetChannelVolume (VolumeLevel val)
virtual | ~CustomSmafPhraseAudioReference ()

Static Public Member Functions

static SharedPtr< CustomSmafPhraseAudioReference > | Create (AudioPlayer::Buffer buffer, UINT32 buffer_size, BOOLEAN take_ownership)
static SharedPtr< CustomSmafPhraseAudioReference > | Create (AudioPlayer::ConstBuffer buffer, UINT32 buffer_size)

Protected Member Functions

CustomSmafPhraseAudioReference (AudioPlayer::Buffer buffer, UINT32 buffer_size, BOOLEAN take_ownership)
CustomSmafPhraseAudioReference (AudioPlayer::ConstBuffer buffer, UINT32 buffer_size)

Protected Attributes

VolumeLevel m_channelVolume

Detailed Description

Ringer sounds are higher quality sounds made by the polyphonic chip (For instance, Yamaha MA3) or a traditional ringer. These are non-preset sounds. For instance, they could be stored in flash memory.

Constructor & Destructor Documentation

CustomSmafPhraseAudioReference::~CustomSmafPhraseAudioReference ( ) [virtual]

CustomSmafPhraseAudioReference::CustomSmafPhraseAudioReference | ( | AudioPlayer::ConstBuffer | buffer,
 |  | UINT32 | buffer_size
 | ) | [protected]

CustomSmafPhraseAudioReference::CustomSmafPhraseAudioReference | ( | AudioPlayer::Buffer | buffer,
 |  | UINT32 | buffer_size,
 |  | BOOLEAN | take_ownership
 | ) | [protected]

Member Function Documentation

BOOLEAN CustomSmafPhraseAudioReference::CanPlayTogetherWith ( const AudioReference & audio_ref ) const [virtual]

Reimplemented from AudioReference.

static SharedPtr<CustomSmafPhraseAudioReference> CustomSmafPhraseAudioReference::Create | ( | AudioPlayer::Buffer | buffer,
 |  | UINT32 | buffer_size,
 |  | BOOLEAN | take_ownership
 | ) | [static]

Parameters:
buffer The data. The data will be deallocated automatically in the destructor.
buffer_size,: The number of bytes of data pointed to by buffer.
take_ownership,: This should always be true. It exists only to differentiate this overload from the other create() overload.

SharedPtr< CustomSmafPhraseAudioReference > CustomSmafPhraseAudioReference::Create | ( | AudioPlayer::ConstBuffer | buffer,
 |  | UINT32 | buffer_size
 | ) | [static]

Parameters:
buffer The data. This should live as long as the AudioReference. The data will not be copied.
buffer_size,: The number of bytes of data pointed to by buffer.

AudioReference::VolumeLevel CustomSmafPhraseAudioReference::GetChannelVolume ( ) const [virtual]

If the sound to be played has only one channel then this is the same as calling GetVolume().

Reimplemented from AudioReference.

AudioReference::enumClassType CustomSmafPhraseAudioReference::GetClassType ( ) const [virtual]

Reimplemented from CustomRingerAudioReference.

AudioReference::ChannelNumber CustomSmafPhraseAudioReference::GetNumberOfChannels ( ) const [virtual]

This will be different on each system, depending on the hardware. For instance, Yamaha's MA3 can play 40 channels, but the MA2 can only play 16.

Reimplemented from AudioReference.

void CustomSmafPhraseAudioReference::SetChannelVolume ( VolumeLevel val ) [virtual]

Field Documentation

VolumeLevel CustomSmafPhraseAudioReference::m_channelVolume [protected]

The documentation for this class was generated from the following files:
  • Audio/CustomSmafPhraseAudioReference.hpp
  • Audio/CustomSmafPhraseAudioReference.cpp
Generated on Wed Jan 25 01:09:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CustomToneAudioReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

CustomToneAudioReference Class Reference
[Audio]

#include <Apoxi/Audio/CustomToneAudioReference.hpp>

Inheritance diagram for CustomToneAudioReference:

[legend]
Collaboration diagram for CustomToneAudioReference:

[legend]

Public Types

typedef INT16 | DefaultAmplitude
enum | ToneType { NormalTone, DualTone, TripleTone }
Available tone types. More...

Public Member Functions

const void * | GetBuffer () const
See Create() for a description of the format.
virtual enumClassType | GetClassType () const
UINT32 | GetNumberOfTones () const
ToneType | GetToneType () const
void | SetNumberOfTones (UINT32 no_of_tones)
void | SetToneType (CustomToneAudioReference::ToneType type)
virtual | ~CustomToneAudioReference ()

Static Public Member Functions

static SharedPtr< CustomToneAudioReference > | Create (const void *tone_data, ToneType tone_type, UINT32 no_of_tones)
static CustomToneAudioReference::DefaultAmplitude | GetDefaultAmplitude ()
Get the default amplitude that can be used when a custom tone is created. It will have the same level as speech.

Protected Member Functions

CustomToneAudioReference (const void *tone_data, ToneType tone_type, UINT32 no_of_tones)

Protected Attributes

UINT32 | m_no_of_tones
const void * | m_tone_data
ToneType m_tone_type

Detailed Description

A reference to a tone that should be based on custom data, such as data in the Flash File System. Tones are simple sounds made by the DSP chip

Member Typedef Documentation

typedef INT16 CustomToneAudioReference::DefaultAmplitude

Member Enumeration Documentation

enum CustomToneAudioReference::ToneType

Available tone types.

Enumerator:
NormalTone | Normal tone.
DualTone | Dual tone.
TripleTone | Triple tone.

Constructor & Destructor Documentation

CustomToneAudioReference::~CustomToneAudioReference ( ) [virtual]

CustomToneAudioReference::CustomToneAudioReference | ( | const void * | tone_data,
 |  | ToneType | tone_type,
 |  | UINT32 | no_of_tones
 | ) | [protected]

Member Function Documentation

SharedPtr< CustomToneAudioReference > CustomToneAudioReference::Create | ( | const void * | tone_data,
 |  | ToneType | tone_type,
 |  | UINT32 | no_of_tones
 | ) | [static]

Create an instance.

Parameters:
tone_data | A buffer of tone data. The size of this buffer is determined by the tone_type and no_of_tones parameter.
tone_type | The Type of tone. Different tone types require different tone_data formats. Here are the formats for the tone_data buffer:
  • NormalTone: Sequential blocks of data, of this format: UINT16 frequency1; INT16 amplitude1; UINT16 duration;

  • DualTone: Sequential blocks of data, of this format: UINT16 frequency1; INT16 amplitude1; UINT16 frequency2; INT16 amplitude2; UINT16 duration;

  • TripleTone: Sequential blocks of data, of this format: UINT16 frequency1; INT16 amplitude1; UINT16 frequency2; INT16 amplitude2; UINT16 frequency3; INT16 amplitude3; UINT16 duration;

For instance, a NormalTone tone_data buffer might be defined like this:

 struct NormalToneBlock
 {
   UINT16 frequency1;
   INT16 amplitude1;
   UINT16 duration;
 };

 NormalToneBlock custom_tone_normal[] = {
 // Frequency, amplitude , duration (ms)
    { 350   , 0x2000    , 1000},
    { 550   , 0x2000    , 500},
    { 750   , 0x2000    , 500},
    { 950   , 0x4000    , 500},
    {1150   , 0x4000    , 500},
    {1350   , 0x4000    , 500},
    {1550   , 0x4000    , 500},
    {1750   , 0x4000    , 500},
 };

Parameters:
no_of_tones How many blocks of tone data are in the tone_data buffer.
Returns:
A new instance.

const void * CustomToneAudioReference::GetBuffer ( ) const

See Create() for a description of the format.

AudioReference::enumClassType CustomToneAudioReference::GetClassType ( ) const [virtual]

Implements AudioReference.

CustomToneAudioReference::DefaultAmplitude CustomToneAudioReference::GetDefaultAmplitude ( ) [static]

Get the default amplitude that can be used when a custom tone is created. It will have the same level as speech.

UINT32 CustomToneAudioReference::GetNumberOfTones ( ) const

CustomToneAudioReference::ToneType CustomToneAudioReference::GetToneType ( ) const

void CustomToneAudioReference::SetNumberOfTones ( UINT32 no_of_tones )

void CustomToneAudioReference::SetToneType ( CustomToneAudioReference::ToneType type )

Field Documentation

UINT32 CustomToneAudioReference::m_no_of_tones [protected]

const void* CustomToneAudioReference::m_tone_data [protected]

ToneType CustomToneAudioReference::m_tone_type [protected]

The documentation for this class was generated from the following files:
  • Audio/CustomToneAudioReference.hpp
  • Audio/CustomToneAudioReference.cpp
Generated on Wed Jan 25 01:09:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataCallContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataCallContext Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/DataCallContext.hpp>

Public Types

enum ConnectionElement {
Transparent = TRANSPARENT, NonTransparent = NON_TRANSPARENT, TransparentPreferred = TRANSPARENT_PREF, NonTransparentPreferred = NON_TRANSPARENT_PREF,
ElementUndefined = CONN_ELEMENT_UNDEFINED, InvalidConnectionElement
}

Public Member Functions

DataCallContext ()
ConnectionElement | GetConnectionElement () const
void | Reset ()
resets the all parameters
void | SetConnectionElement (ConnectionElement connection_element)
~DataCallContext ()

Detailed Description

The class DataCallContext is used to initialize a DataCallHdl. It holds all the configurable parameter, which can be set for a DataCall.

Member Enumeration Documentation

enum DataCallContext::ConnectionElement

Enumerator:
Transparent
NonTransparent
TransparentPreferred
NonTransparentPreferred
ElementUndefined
InvalidConnectionElement invokes default setting

Constructor & Destructor Documentation

DataCallContext::DataCallContext ( )

DataCallContext::~DataCallContext ( )

Member Function Documentation

ConnectionElement DataCallContext::GetConnectionElement ( ) const [inline]

void DataCallContext::Reset ( )

resets the all parameters

void DataCallContext::SetConnectionElement ( ConnectionElement connection_element ) [inline]

The documentation for this class was generated from the following files:
  • Asc/DataCallContext.hpp
  • Asc/DataCallContext.cpp
Generated on Wed Jan 25 01:09:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataCallControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataCallControl Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/DataCallControl.hpp>

Inheritance diagram for DataCallControl:

[legend]

Public Member Functions

DataCallControl ()
virtual void | OnReleaseCompleted (DcError error)=0
virtual void | OnSetupCompleted (DcError error)=0
~DataCallControl ()

Detailed Description

This class contains the callback routines called upon arrival of IPDS_SETUP_CNF, IPDS_SETUP_REJ, IPDS_RELEASE_CNF and IPDS_RELEASE_IND. Inherit from this class and overwrite the virtual methods.

Constructor & Destructor Documentation

DataCallControl::DataCallControl ( ) [inline]

DataCallControl::~DataCallControl ( ) [inline]

Member Function Documentation

virtual void DataCallControl::OnReleaseCompleted ( DcError error ) [pure virtual]

Invoked upon receipt of the data call release confirmation, or invoked upon receipt of a data call disconnect indication.

Parameters:
error The cause for the disconnection of the data call (if disconnected by network or user remote), NoCallError if invoked due to a preceeding data call release request.

Implemented in CsdDataConn.

virtual void DataCallControl::OnSetupCompleted ( DcError error ) [pure virtual]

Invoked upon receipt of confirmation or of a data call setup or upon receipt of a rejection of a data call setup attempt.

Parameters:
error The cause for the rejection of the data call setup attempt, NoCallError if the setup was successful.

Implemented in CsdDataConn.

The documentation for this class was generated from the following file:
  • Asc/DataCallControl.hpp
Generated on Wed Jan 25 01:09:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataCallHdl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataCallHdl Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/DataCallHdl.hpp>

Collaboration diagram for DataCallHdl:

[legend]

Static Public Member Functions

static void | Init (const DataCallContext &context)
Initializes the DataCallHdl with a defined context (containing variable data call parameter).
static CallApiRc | Release ()
static CallApiRc | Setup (const PhoneNumber &phone_no, BOOLEAN isdn, UINT data_rate, DataCallControl *dcc_p)

Friends

class | DataCallSignalProcessor

Detailed Description

The class DataCallHdl supplies an interface to setup circuit switched data calls.

Member Function Documentation

void DataCallHdl::Init ( const DataCallContext & context ) [static]

Initializes the DataCallHdl with a defined context (containing variable data call parameter).

CallApiRc DataCallHdl::Release ( ) [static]

Sends a data call release request signal to the protocol stack. The release cause will be defaulted internally. The release is always successful, except if no data call exists.

Returns:
NoError if release request was successfully sent.

DataCallRequired if no data call currently exists.

CallApiRc DataCallHdl::Setup | ( | const PhoneNumber & | phone_no,
 |  | BOOLEAN | isdn,
 |  | UINT | data_rate,
 |  | DataCallControl * | dcc_p
 | ) | [static]

Sets up a circuit switched data call.

Parameters:
phone_no | The destination phone number.
isdn | Defines if the data call type is analog (FALSE) or digital (TRUE).
data_rate | The value defines the data rate. E.g. a value of 14400 defines the respective data rate.
Returns:
DataCallDetected if an active call data alreay exists, SetupCallDetected if a voice call n setup phase exists, ActiveCallDetected if an active voice call exists, HeldCallDetected if a held voice call exists. NoError if signal successfully sent.

Friends And Related Function Documentation

friend class DataCallSignalProcessor [friend]

The documentation for this class was generated from the following files:
  • Asc/DataCallHdl.hpp
  • Asc/Host/DataCallHdl.cpp
  • Asc/Target/DataCallHdl.cpp
Generated on Wed Jan 25 01:09:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataCallSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataCallSignalMapTableNode Class Reference

#include <Apoxi/Asc/Target/DataCallSignalMapTableNode.hpp>

Inheritance diagram for DataCallSignalMapTableNode:

[legend]
Collaboration diagram for DataCallSignalMapTableNode:

[legend]

Static Public Member Functions

static DataCallSignalMapTableNode * GetInstance ()

Member Function Documentation

DataCallSignalMapTableNode * DataCallSignalMapTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Asc/Target/DataCallSignalMapTableNode.hpp
  • Asc/Target/DataCallSignalMapTableNode.cpp
Generated on Wed Jan 25 01:09:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataCallSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataCallSignalProcessor Class Reference

#include <Apoxi/Asc/Host/DataCallSignalProcessor.hpp>

Static Public Member Functions

static void | PostIpdsReleaseCnf (const ProcessPtr &process_ptr)
static void | PostIpdsReleaseCnf ()
static void | PostIpdsReleaseInd (const ProcessPtr &process_ptr)
static void | PostIpdsReleaseInd ()
static void | PostIpdsSetupCnf (const ProcessPtr &process_ptr)
static void | PostIpdsSetupCnf ()
static void | PostIpdsSetupRej (const ProcessPtr &process_ptr)
static void | PostIpdsSetupRej ()

Detailed Description

DataCallSignalProcessor

Member Function Documentation

void DataCallSignalProcessor::PostIpdsReleaseCnf ( const ProcessPtr & process_ptr ) [static]

void DataCallSignalProcessor::PostIpdsReleaseCnf ( ) [static]

void DataCallSignalProcessor::PostIpdsReleaseInd ( const ProcessPtr & process_ptr ) [static]

void DataCallSignalProcessor::PostIpdsReleaseInd ( ) [static]

void DataCallSignalProcessor::PostIpdsSetupCnf ( const ProcessPtr & process_ptr ) [static]

void DataCallSignalProcessor::PostIpdsSetupCnf ( ) [static]

void DataCallSignalProcessor::PostIpdsSetupRej ( const ProcessPtr & process_ptr ) [static]

void DataCallSignalProcessor::PostIpdsSetupRej ( ) [static]

The documentation for this class was generated from the following files:
  • Asc/Host/DataCallSignalProcessor.hpp
  • Asc/Target/DataCallSignalProcessor.hpp
  • Asc/Host/DataCallSignalProcessor.cpp
  • Asc/Target/DataCallSignalProcessor.cpp
Generated on Wed Jan 25 01:09:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataCoding Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataCoding Class Reference

#include <Apoxi/Auxiliary/DataCoding.hpp>

Public Member Functions

DataCoding ()
~DataCoding ()

Static Public Member Functions

static INT | CopyCbsUnicodeBufferAndAdjustBytes (const UINT8 *src, UINT8 *dest, INT bufferlen, BOOLEAN haslengthbyte=FALSE)
static BOOLEAN | ForceWcharsTo7bitWchars (const WCHAR *source, WCHAR *dest, INT len)
transforms a WCHAR string to 7 bit transformable WCHAR string.
static INT | GetBufferLength (INT nofwcharchrs, const WCHAR *string)
Determines the necessary size for the compressed buffer.
static INT | GetCbsWchars (INT nofbytes, const UINT8 *buffer, BOOLEAN haslengthbyte=FALSE)
Determines how many WCHARs are contained in the cbs buffer, dependend of the size of buffer.
static INT | GetEffectiveWchars (INT nofseptets, const UINT8 *buffer, UINT8 step=0)
Determines how many WCHARs are contained in the buffer, dependend of the number of septets.
static INT | GetSeptets (INT nofwcharchrs, const WCHAR *string)
Determines the number of septets.
static INT | GetUnicodeStringToGsm7DefaultStringLength (const WCHAR *src, INT len)
detects the length of possible 7-bit string with escaped symbols
static INT | GetWchars (INT nofbytes, const UINT8 *buffer, BOOLEAN checkeos=FALSE)
Determines how many WCHARs are contained in the buffer, dependend of the size of buffer.
static void | Gsm7DefaultStringToUnicodeString (const CHAR *src, WCHAR *dest, INT len)
encodes a 7-bit uncompressed string directly in a unicode string
static BOOLEAN | HasOnly7bitChars (const WCHAR *string)
checks if a WCHAR string only contains transformable 7 bit characters.
static BOOLEAN | IsWCharToGsm7Possible (WCHAR src)
checks if WCHAR could be possibly transformed to a 7 bit character.
static INT | MoveUnicodeBufferAndAdjustBytes (const UINT8 *src, UINT8 *dest, INT bufferlen)
static INT | PackWcharsToSeptets (const WCHAR *inbuffer, INT nofwcharchrs, UINT8 *outbuffer, INT size_of_outbuffer, UINT8 step)
static INT | PackWcharsToSeptets (const WCHAR *inbuffer, INT nofwcharchrs, UINT8 *outbuffer, UINT8 step=0)
static void | UnicodeStringToGsm7DefaultString (const WCHAR *src, CHAR *dest, INT len)
encodes a unicode string directly in a 7-bit uncompressed string
static BOOLEAN | UnpackCbsSeptetsToWchars (const UINT8 *in7bitbuffer, INT nofbytes, WCHAR *outbuffer, BOOLEAN haslengthbyte=FALSE)
Unpacks an array of octets containing packed 7-bit GSM default alphabet text as defined in GSM 03.38, 6.1.2.
static BOOLEAN | UnpackSeptetsToWchars (const UINT8 *in7bitbuffer, INT nofwcharchrs, WCHAR *outbuffer, UINT8 step=0)
Unpacks an array of octets containing packed 7-bit GSM default alphabet text as defined in GSM 03.38, 6.1.2.

Constructor & Destructor Documentation

DataCoding::DataCoding ( )

DataCoding::~DataCoding ( )

Member Function Documentation

INT DataCoding::CopyCbsUnicodeBufferAndAdjustBytes | ( | const UINT8 * | src,
 |  | UINT8 * | dest,
 |  | INT | bufferlen,
 |  | BOOLEAN | haslengthbyte = FALSE
 | ) | [static]

copies the bytes inside the unicode characters and copy it into dest, dependend of the endian format. Also the length byte contained in the CBS data buffer unicode buffer is taken into account. Returns the number of converted characters.

BOOLEAN DataCoding::ForceWcharsTo7bitWchars | ( | const WCHAR * | source,
 |  | WCHAR * | dest,
 |  | INT | len
 | ) | [static]

transforms a WCHAR string to 7 bit transformable WCHAR string.

INT DataCoding::GetBufferLength | ( | INT | nofwcharchrs,
 |  | const WCHAR * | string
 | ) | [static]

Determines the necessary size for the compressed buffer.

INT DataCoding::GetCbsWchars | ( | INT | nofbytes,
 |  | const UINT8 * | buffer,
 |  | BOOLEAN | haslengthbyte = FALSE
 | ) | [static]

Determines how many WCHARs are contained in the cbs buffer, dependend of the size of buffer.

INT DataCoding::GetEffectiveWchars | ( | INT | nofseptets,
 |  | const UINT8 * | buffer,
 |  | UINT8 | step = 0
 | ) | [static]

Determines how many WCHARs are contained in the buffer, dependend of the number of septets.

INT DataCoding::GetSeptets | ( | INT | nofwcharchrs,
 |  | const WCHAR * | string
 | ) | [static]

Determines the number of septets.

INT DataCoding::GetUnicodeStringToGsm7DefaultStringLength | ( | const WCHAR * | src,
 |  | INT | len
 | ) | [static]

detects the length of possible 7-bit string with escaped symbols

INT DataCoding::GetWchars | ( | INT | nofbytes,
 |  | const UINT8 * | buffer,
 |  | BOOLEAN | checkeos = FALSE
 | ) | [static]

Determines how many WCHARs are contained in the buffer, dependend of the size of buffer.

void DataCoding::Gsm7DefaultStringToUnicodeString | ( | const CHAR * | src,
 |  | WCHAR * | dest,
 |  | INT | len
 | ) | [static]

encodes a 7-bit uncompressed string directly in a unicode string

BOOLEAN DataCoding::HasOnly7bitChars ( const WCHAR * string ) [static]

checks if a WCHAR string only contains transformable 7 bit characters.

BOOLEAN DataCoding::IsWCharToGsm7Possible ( WCHAR src ) [static]

checks if WCHAR could be possibly transformed to a 7 bit character.

INT DataCoding::MoveUnicodeBufferAndAdjustBytes | ( | const UINT8 * | src,
 |  | UINT8 * | dest,
 |  | INT | bufferlen
 | ) | [static]

copies the bytes inside the unicode characters and copy it into dest, dependend of the endian format. Returns the number of converted characters.

INT DataCoding::PackWcharsToSeptets | ( | const WCHAR * | inbuffer,
 |  | INT | nofwcharchrs,
 |  | UINT8 * | outbuffer,
 |  | INT | size_of_outbuffer,
 |  | UINT8 | step
 | ) | [static]

Packs 7-Bit chars into an array of octets as defined in GSM 03.38, 6.1.2. Returns the number of converted characters.

INT DataCoding::PackWcharsToSeptets | ( | const WCHAR * | inbuffer,
 |  | INT | nofwcharchrs,
 |  | UINT8 * | outbuffer,
 |  | UINT8 | step = 0
 | ) | [static]

Packs 7-Bit chars into an array of octets as defined in GSM 03.38, 6.1.2. Returns the size of packed buffer (in bytes).

void DataCoding::UnicodeStringToGsm7DefaultString | ( | const WCHAR * | src,
 |  | CHAR * | dest,
 |  | INT | len
 | ) | [static]

encodes a unicode string directly in a 7-bit uncompressed string

BOOLEAN DataCoding::UnpackCbsSeptetsToWchars | ( | const UINT8 * | in7bitbuffer,
 |  | INT | nofbytes,
 |  | WCHAR * | outbuffer,
 |  | BOOLEAN | haslengthbyte = FALSE
 | ) | [static]

Unpacks an array of octets containing packed 7-bit GSM default alphabet text as defined in GSM 03.38, 6.1.2.

BOOLEAN DataCoding::UnpackSeptetsToWchars | ( | const UINT8 * | in7bitbuffer,
 |  | INT | nofwcharchrs,
 |  | WCHAR * | outbuffer,
 |  | UINT8 | step = 0
 | ) | [static]

Unpacks an array of octets containing packed 7-bit GSM default alphabet text as defined in GSM 03.38, 6.1.2.

The documentation for this class was generated from the following files:
  • Auxiliary/DataCoding.hpp
  • Auxiliary/DataCoding.cpp
Generated on Wed Jan 25 01:09:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataCodingScheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataCodingScheme Class Reference

3GPP TS 23.038 V4.3.0 (2001-09) More...

#include <Apoxi/Apc/DataCodingScheme.hpp>

Collaboration diagram for DataCodingScheme:

[legend]

Public Types

enum Alphabet {
DefaultAlphabet = 0, EightBitAlphabet, Ucs2Alphabet, ReservedAlphabet,
InvalidAlphabet
}
alphabet for the corresponding text More...
enum GroupId {
GeneralDataCodingGroup, AutomaticDeletionGroup, ReservedCodingGroup, MsgWaitingIndDiscardGroup,
MsgWaitingIndStoreDefaultGroup, MsgWaitingIndStoreUcs2Group, DataCodingMsgHandlingGroup, LanguageSelectionGroup,
LanguageSelectionWithinMessageGroup, WapGroup, InvalidGroup
}
describes the various kinds of groups More...
enum Language {
German = 0, English, Italian, French,
Spanish, Dutch, Swedish, Danish,
Portuguese, Finnish, Norwegian, Greek,
Turkish, Hungarian, Polish, UnspecifiedLanguage,
Czech, Hebrew, Arabic, Russian,
Icelandic, ReservedLanguage, InvalidLanguage
}
langauge for cell broadcast data coding scheme (using the default alphabet) More...
enum LanguageGroupId {
LanguageGroup00 = 0, LanguageGroup01, LanguageGroup10, LanguageGroup11,
InvalidLanguageGroup
}
defines the various kinds of subgroups for the languages More...
enum MessageClass {
Class0 = 0, Class1, Class2, Class3,
NoClass, InvalidClass
}
enum | TextCompression { TextUncompressed, TextCompressed, InvalidTextCompression }
enum | Type { Sms, Cbs, InvalidType }
defines the different kinds of data coding scheme More...
enum WaitingMessage {
VoiceMessage = 0, FaxMessage, EmailMessage, OtherMessage,
InvalidMessage
}
enum | WaitingMessageIndication { MessageWaitingActive, MessageWaitingInactive, MessageWaitingInvalid }
waiting indication activation signature More...

Public Member Functions

void | Clear ()
DataCodingScheme (Type type, UINT8 incoming_byte=0)
DataCodingScheme ()
UINT8 | Get () const
Alphabet | GetAlphabet () const
GroupId | GetGroupId () const
Language | GetLanguage () const
MessageClass | GetMessageClass () const
TextCompression | GetTextCompression () const
Type | GetType () const
WaitingMessage | GetWaitingMessage () const
WaitingMessageIndication | GetWaitingMessageIndication () const
BOOLEAN | IsInvalid () const
BOOLEAN | operator== (const DataCodingScheme &dcs) const
void | SetAlphabet (Alphabet alphabet)
void | SetGroupId (GroupId group_id)
void | SetLanguage (Language language)
void | SetMessageClass (MessageClass msg_class)
void | SetTextCompression (TextCompression msg_class)
void | SetType (Type type)
void | SetWaitingMessage (WaitingMessage waiting_message)
void | SetWaitingMessageIndication (WaitingMessageIndication waiting_message_indication)

Detailed Description

3GPP TS 23.038 V4.3.0 (2001-09)

Member Enumeration Documentation

enum DataCodingScheme::Alphabet

alphabet for the corresponding text

Enumerator:
DefaultAlphabet
EightBitAlphabet
Ucs2Alphabet
ReservedAlphabet
InvalidAlphabet

enum DataCodingScheme::GroupId

describes the various kinds of groups

Enumerator:
GeneralDataCodingGroup
AutomaticDeletionGroup
ReservedCodingGroup
MsgWaitingIndDiscardGroup
MsgWaitingIndStoreDefaultGroup
MsgWaitingIndStoreUcs2Group
DataCodingMsgHandlingGroup
LanguageSelectionGroup
LanguageSelectionWithinMessageGroup
WapGroup
InvalidGroup

enum DataCodingScheme::Language

langauge for cell broadcast data coding scheme (using the default alphabet)

Enumerator:
German
English
Italian
French
Spanish
Dutch
Swedish
Danish
Portuguese
Finnish
Norwegian
Greek
Turkish
Hungarian
Polish
UnspecifiedLanguage
Czech
Hebrew
Arabic
Russian
Icelandic
ReservedLanguage
InvalidLanguage

enum DataCodingScheme::LanguageGroupId

defines the various kinds of subgroups for the languages

Enumerator:
LanguageGroup00 index describes the bits 5..4 (eg. 00 for LangaugeGroup00)
LanguageGroup01
LanguageGroup10
LanguageGroup11
InvalidLanguageGroup

enum DataCodingScheme::MessageClass

Enumerator:
Class0
Class1
Class2
Class3
NoClass
InvalidClass

enum DataCodingScheme::TextCompression

Enumerator:
TextUncompressed
TextCompressed
InvalidTextCompression

enum DataCodingScheme::Type

defines the different kinds of data coding scheme

Enumerator:
Sms | Short message service.
Cbs | Cell broadcast service.
InvalidType

enum DataCodingScheme::WaitingMessage

Enumerator:
VoiceMessage | Voice mail indication.
FaxMessage | Fax mail indication.
EmailMessage | E-mail indication.
OtherMessage | Network depended.
InvalidMessage

enum DataCodingScheme::WaitingMessageIndication

waiting indication activation signature

Enumerator:
MessageWaitingActive
MessageWaitingInactive
MessageWaitingInvalid

Constructor & Destructor Documentation

DataCodingScheme::DataCodingScheme ( )

DataCodingScheme::DataCodingScheme | ( | Type | type,
 |  | UINT8 | incoming_byte = 0
 | ) |

Member Function Documentation

void DataCodingScheme::Clear ( )

UINT8 DataCodingScheme::Get ( ) const [inline]

DataCodingScheme::Alphabet DataCodingScheme::GetAlphabet ( ) const

DataCodingScheme::GroupId DataCodingScheme::GetGroupId ( ) const

DataCodingScheme::Language DataCodingScheme::GetLanguage ( ) const

DataCodingScheme::MessageClass DataCodingScheme::GetMessageClass ( ) const

DataCodingScheme::TextCompression DataCodingScheme::GetTextCompression ( ) const

Type DataCodingScheme::GetType ( ) const [inline]

DataCodingScheme::WaitingMessage DataCodingScheme::GetWaitingMessage ( ) const

DataCodingScheme::WaitingMessageIndication DataCodingScheme::GetWaitingMessageIndication ( ) const

BOOLEAN DataCodingScheme::IsInvalid ( ) const [inline]

BOOLEAN DataCodingScheme::operator== ( const DataCodingScheme & dcs ) const

void DataCodingScheme::SetAlphabet ( Alphabet alphabet )

void DataCodingScheme::SetGroupId ( GroupId group_id )

void DataCodingScheme::SetLanguage ( Language language )

void DataCodingScheme::SetMessageClass ( MessageClass msg_class )

void DataCodingScheme::SetTextCompression ( TextCompression msg_class )

void DataCodingScheme::SetType ( Type type ) [inline]

void DataCodingScheme::SetWaitingMessage ( WaitingMessage waiting_message )

void DataCodingScheme::SetWaitingMessageIndication ( WaitingMessageIndication waiting_message_indication )

The documentation for this class was generated from the following files:
  • Apc/DataCodingScheme.hpp
  • Apc/DataCodingScheme.cpp
Generated on Wed Jan 25 01:09:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataCodingSchemeRange Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataCodingSchemeRange Class Reference

used for cell broadcast filter More...

#include <Apoxi/Apc/DataCodingScheme.hpp>

Inheritance diagram for DataCodingSchemeRange:

[legend]
Collaboration diagram for DataCodingSchemeRange:

[legend]

Public Member Functions

void | Begin (const DataCodingScheme &begin)
const DataCodingScheme & | Begin () const
DataCodingSchemeRange (const DataCodingScheme &begin, const DataCodingScheme &end=DataCodingScheme())
DataCodingSchemeRange ()
void | End (const DataCodingScheme &end)
const DataCodingScheme & | End () const
BOOLEAN | IsValid ()
BOOLEAN | operator== (const DataCodingSchemeRange &dcs_range) const

Detailed Description

used for cell broadcast filter

Constructor & Destructor Documentation

DataCodingSchemeRange::DataCodingSchemeRange ( )

DataCodingSchemeRange::DataCodingSchemeRange | ( | const DataCodingScheme & | begin,
 |  | const DataCodingScheme & | end = DataCodingScheme()
 | ) |

Member Function Documentation

void DataCodingSchemeRange::Begin ( const DataCodingScheme & begin ) [inline]

const DataCodingScheme& DataCodingSchemeRange::Begin ( ) const [inline]

void DataCodingSchemeRange::End ( const DataCodingScheme & end ) [inline]

const DataCodingScheme& DataCodingSchemeRange::End ( ) const [inline]

BOOLEAN DataCodingSchemeRange::IsValid ( ) [inline]

BOOLEAN DataCodingSchemeRange::operator== ( const DataCodingSchemeRange & dcs_range ) const

The documentation for this class was generated from the following files:
  • Apc/DataCodingScheme.hpp
  • Apc/DataCodingScheme.cpp
Generated on Wed Jan 25 01:09:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConn Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConn Class Reference
[Socket]

#include <Apoxi/Socket/DataConn.hpp>

Inheritance diagram for DataConn:

[legend]
Collaboration diagram for DataConn:

[legend]

Public Member Functions

virtual BOOLEAN | GetIpAddress (IpAddr &addr) const =0
virtual UINT8 | GetNsapi () const
const IpAddr & | GetPrimaryDnsServerAddress () const
DataConnProfilePtr | GetProfile () const
DataConnProfile::ProfileType | GetProfileType () const
const IpAddr & | GetSecondaryDnsServerAddress () const
BOOLEAN | IsActive () const
BOOLEAN | IsCancelled () const
BOOLEAN | IsConnected () const
BOOLEAN | IsDisconnected () const
BOOLEAN | IsInactive () const
BOOLEAN | IsInHold () const
BOOLEAN | IsInRelease () const
BOOLEAN | IsInSetup () const
BOOLEAN | Release (BOOLEAN block=FALSE)
BOOLEAN | Release (SocketData &sd)
void | ResetIdleTimer ()
BOOLEAN | Setup ()
BOOLEAN | Setup (SocketData &sd)

Protected Types

typedef ContextExecuteMsg::CallbackFn | DataConnCtrlCb
enum DataConnState {
st_inactive = 0, st_start_setup, st_in_setup, st_set_on_wait_for_setup,
st_check_cancel, st_set_on_cancel, st_setup_success, st_setup_failure,
st_active, st_idle_timeout, st_in_hold, st_reactivate,
st_deactivate, st_in_trigger_release, st_start_release, st_in_release,
st_ignore_setup_req, st_released, st_max_states
}
enum MessageType {
mt_data_conn_init = 0, mt_data_conn_established, mt_data_conn_setup_failed, mt_data_conn_init_release,
mt_data_conn_released, mt_data_conn_setup_blocked
}

Protected Member Functions

void | BearerDisconnectedEvent (SocketControlMsgType error_msg)
virtual BOOLEAN | CancelSetup ()
BOOLEAN | CheckCancelRequest (BOOLEAN internal=FALSE)
void | CheckTimers ()
virtual void | Cleanup ()
DataConn (const DataConnProfilePtr &profile)
virtual BOOLEAN | DataConnIsBlocked () const
virtual void | DoRelease ()=0
virtual void | DoSetup ()=0
SocketData & | GetSocketData () const
DataConnState | GetState () const
void | Init ()
void | InvalidateSockets () const
const DataConnProfile & | MyProfile () const
void | PostDataConnControlMsg (const DataConnCtrlCb cb)
virtual void | PostInfoMsg (MessageType type) const =0
void | PostSocketControlMsg (SocketControlMsgType control_type)
void | ReleasedEvent ()
void | SetPrimaryDnsServerAddress (const IpAddr &primary_dns_addr)
void | SetSecondaryDnsServerAddress (const IpAddr &secondary_dns_addr)
virtual BOOLEAN | SetupContext ()
void | SetupFailedEvent (SocketControlMsgType error_msg)
void | SetupSucceededEvent ()
virtual BOOLEAN | TeardownContext ()
BOOLEAN | WaitForSetup (SocketData &sd)
virtual | ~DataConn ()

Static Protected Member Functions

static void | PostSocketControlMsg (SocketData &sd, SocketControlMsgType control_type)

Friends

class | DataConnCtrlCbs
class | DataConnManager
class | DataConnProfile
class | NiSharedPtr< DataConn >

Data Structures

struct | ReleaseEventData
struct | SocketEventData

Detailed Description

Abstract class DataConn is the base class of data connections. It is implemented as a well-defined state machine and thereby defines the states a data connection can be in.

Member Typedef Documentation

typedef ContextExecuteMsg::CallbackFn DataConn::DataConnCtrlCb [protected]

Member Enumeration Documentation

enum DataConn::DataConnState [protected]

Enumeration of states of a data connection. State enumeration order must match the order of state method entries in the state map.

Enumerator:
st_inactive
st_start_setup
st_in_setup
st_set_on_wait_for_setup
st_check_cancel
st_set_on_cancel
st_setup_success
st_setup_failure
st_active
st_idle_timeout
st_in_hold
st_reactivate
st_deactivate
st_in_trigger_release
st_start_release
st_in_release
st_ignore_setup_req
st_released
st_max_states

enum DataConn::MessageType [protected]

Enumerator:
mt_data_conn_init | Message to send when data connection setup starts.
mt_data_conn_established | Message to send when data connection is established.
mt_data_conn_setup_failed | Message to send when data connection setup failed.
mt_data_conn_init_release | Message to send when data connection release starts.
mt_data_conn_released | Message to send when data connection is released.
mt_data_conn_setup_blocked | Message to send when data connection setup is blocked.

Constructor & Destructor Documentation

DataConn::DataConn ( const DataConnProfilePtr & profile ) [protected]

Creates a data connection which uses profile on setup. The given profile smart pointer must be valid, otherwise an assertion holds.

DataConn::~DataConn ( ) [protected, virtual]

Member Function Documentation

void DataConn::BearerDisconnectedEvent ( SocketControlMsgType error_msg ) [protected]

To be called when the data connection bearer is asynchronously disconnected.

virtual BOOLEAN DataConn::CancelSetup ( ) [inline, protected, virtual]

This method is called when a data connection shall be canceled during the setup phase. Derived classes can override this method to immediately stop the setup process. This is especially needed if the setup process might take a long time. If this method is not overridden then the data connection continues the setup process completely but then immediately shuts it down again since a cancel request was issued during the setup process.

Returns:
Tells if the cancellation was done.

Reimplemented in PppDataConn.

BOOLEAN DataConn::CheckCancelRequest ( BOOLEAN internal = FALSE ) [protected]

Checks if the user canceled the data connection and triggers a release in case. Argument internal tells if the method is called from an internal state.

Returns:
Tells if cancel was requested.

void DataConn::CheckTimers ( ) [protected]

Checks if any timer flags have been set. In case a flag has been set the respective callback is called.

void DataConn::Cleanup ( ) [protected, virtual]

Cleans up the internals to virginal state.

Reimplemented in CsdDataConn, PppDataConn, and PsdDataConn.

virtual BOOLEAN DataConn::DataConnIsBlocked ( ) const [inline, protected, virtual]

If there are some special conditions which block the data connection from being setup, override this method and return TRUE in case. You also have to post a DataConnInfoMsg indicating the reason for blocking in order to inform the context for it can react accordingly.

Reimplemented in PsdDataConn.

virtual void DataConn::DoRelease ( ) [protected, pure virtual]

Asynchronous data connection release request.

Implemented in PppDataConn, and PsdDataConn.

virtual void DataConn::DoSetup ( ) [protected, pure virtual]

Asynchronous data connection setup request.

Implemented in PppDataConn, and PsdDataConn.

virtual BOOLEAN DataConn::GetIpAddress ( IpAddr & addr ) const [pure virtual]

Retrieves the IP address that is currently assigned to this data connection. If the connection is not setup and running and hence no address can be retrieved then FALSE will be returned.

Implemented in PppDataConn, and PsdDataConn.

UINT8 DataConn::GetNsapi ( ) const [virtual]

Returns the network service access point identifier (NSAPI). If the data connection doesn't supply one, an invalid NSAPI value is returned.

Reimplemented in PsdDataConn.

const IpAddr& DataConn::GetPrimaryDnsServerAddress ( ) const [inline]

Returns the IP address of the used primary DNS server. This is either the one defined in the profile or if it was 0.0.0.0 before, then it's the automatically assigned one.

DataConnProfilePtr DataConn::GetProfile ( ) const [inline]

Returns the profile of the data connection.

DataConnProfile::ProfileType DataConn::GetProfileType ( ) const [inline]

Returns the profile type of the data connection.

const IpAddr& DataConn::GetSecondaryDnsServerAddress ( ) const [inline]

Returns the IP address of the used secondary DNS server. This is either the one defined in the profile or if it was 0.0.0.0 before, then it's the automatically assigned one.

SocketData& DataConn::GetSocketData ( ) const [inline, protected]

Returns the socket data that triggered the data connection setup.

DataConn::DataConnState DataConn::GetState ( ) const [protected]

Returns the current state of the data connection.

void DataConn::Init ( ) [inline, protected]

This method initializes the freshly constructed data connection by executing CleanUp(). This method has to be called after the object has been constructed.

void DataConn::InvalidateSockets ( ) const [protected]

Invalidates all attached socket datas. For each socket data

  • the error code m_socket_err is set and
  • the socket control error message m_ctrl_err_msg is sent to its owning context.

BOOLEAN DataConn::IsActive ( ) const [inline]

Tells if the data connection is active, i.e. the connection is established and it is used by at least one attached socket.

BOOLEAN DataConn::IsCancelled ( ) const

Tells if the data connection was canceled, i.e. if the client called Release() during data connection setup.

BOOLEAN DataConn::IsConnected ( ) const [inline]

Tells if the data connection is connected, i.e. the connection is established and can be used for communication.

BOOLEAN DataConn::IsDisconnected ( ) const [inline]

Tells if the data connection is disconnected, i.e. the connection is closed and cannot be used for communication.

BOOLEAN DataConn::IsInactive ( ) const [inline]

Tells if the data connection is inactive, i.e. the data connection is idle and disconnected.

BOOLEAN DataConn::IsInHold ( ) const [inline]

Tells if the data connection is in hold, i.e. the connection is established, however, currently no socket is attached to it.

BOOLEAN DataConn::IsInRelease ( ) const [inline]

Tells if the data connection is currently being released, i.e. the data connection link is getting closed.

BOOLEAN DataConn::IsInSetup ( ) const [inline]

Tells if the data connection is currently being set up, i.e. the data connection link is getting established.

const DataConnProfile& DataConn::MyProfile ( ) const [inline, protected]

Reimplemented in CsdDataConn, and PsdDataConn.

void DataConn::PostDataConnControlMsg ( const DataConnCtrlCb cb ) [protected]

virtual void DataConn::PostInfoMsg ( MessageType type ) const [protected, pure virtual]

void DataConn::PostSocketControlMsg ( SocketControlMsgType control_type ) [protected]

Posts the socket control message control_type to the socket data that triggered the currently running setup or release process if a valid context is connected to it. If the current action was not triggered by a socket data but for example by a timeout, then nothing is sent.

void DataConn::PostSocketControlMsg | ( | SocketData & | sd,
 |  | SocketControlMsgType | control_type
 | ) | [static, protected]

Posts the socket control message control_type to socket data sd if a valid context is connected to it.

BOOLEAN DataConn::Release ( BOOLEAN block = FALSE )

Trigger the release of the data connection independent of any socket data. The release of the data connection can run in blocking or non-blocking mode, parameter block specifies the desired execution mode. The return value states if the release has really been started. The release can't be started either on an out of memory condition or if the data connection is not active or currently gets released already.

Returns:
Tells if the data connection release could be started.

BOOLEAN DataConn::Release ( SocketData & sd )

Socket data sd requests to release the data connection. This method does not block, it triggers the release and returns immediately. The data connection release can't be started only on an out of memory condition.

Parameters:
sd Socket data which triggers the release request.
Returns:
Tells if the data connection release could be started.

void DataConn::ReleasedEvent ( ) [protected]

To be called when the data connection is released, either successfully or not.

void DataConn::ResetIdleTimer ( )

Resets the idle timer. If there is activity on an associated socket then the idle timer of the data connection shall be reset.

void DataConn::SetPrimaryDnsServerAddress ( const IpAddr & primary_dns_addr ) [inline, protected]

Sets the IP address of the primary DNS server to be used.

void DataConn::SetSecondaryDnsServerAddress ( const IpAddr & secondary_dns_addr ) [inline, protected]

Sets the IP address of the secondary DNS server to be used.

BOOLEAN DataConn::Setup ( )

Trigger the setup of the data connection independent of any socket data. This method blocks till the setup has either succeeded or failed.

Returns:
Success of data connection setup.

BOOLEAN DataConn::Setup ( SocketData & sd )

Socket data sd requests to setup the data connection. If the data connection can't be setup, the reason for the problem is provided as error code in sd. This method blocks till the setup has either succeeded or failed.

Parameters:
sd Socket data which triggers the setup request.
Returns:
Success of data connection setup.

BOOLEAN DataConn::SetupContext ( ) [protected, virtual]

This method is called immediately before DoSetup() is called in order to prepare the environment for the asynchronous setup request.

Returns:
Success of setting up the environment.

void DataConn::SetupFailedEvent ( SocketControlMsgType error_msg ) [protected]

To be called when the data connection setup process failed.

void DataConn::SetupSucceededEvent ( ) [protected]

To be called when the data connection setup process succeeds.

BOOLEAN DataConn::TeardownContext ( ) [protected, virtual]

This method is called immediately after DoRelease() or after a SetupFailedEvent() has been called due to a failed setup request in order to cleanup the environment.

Returns:
Success of tearing down the environment.

BOOLEAN DataConn::WaitForSetup ( SocketData & sd ) [protected]

Waits for the setup process to be completed and returns its success. If setup was not successful then the according error code is set to sd.

Returns:
Success of data connection setup.

Friends And Related Function Documentation

friend class DataConnCtrlCbs [friend]

friend class DataConnManager [friend]

friend class DataConnProfile [friend]

Reimplemented in CsdDataConn, and PsdDataConn.

friend class NiSharedPtr< DataConn > [friend]

Reimplemented in CsdDataConn, and PsdDataConn.

The documentation for this class was generated from the following files:
  • Socket/DataConn.hpp
  • Socket/DataConn.cpp
Generated on Wed Jan 25 01:09:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnAccessor Class Reference
[DataConn]

#include <Applications/DataConn/DataConnAccessor.hpp>

Inheritance diagram for DataConnAccessor:

[legend]
Collaboration diagram for DataConnAccessor:

[legend]

Public Member Functions

virtual INT | CountSettings () const
DataConnAccessor (DataConnProfile *profile)
virtual BOOLEAN | First ()
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
void | Init ()
virtual BOOLEAN | IsEnabled ()
virtual BOOLEAN | Next ()
virtual void | Update ()
virtual | ~DataConnAccessor ()

Protected Member Functions

virtual INT | GetIndex ()
DataConnProfileId GetProfileId ()
virtual void | OnTrigger (INT selected_idx)

Constructor & Destructor Documentation

DataConnAccessor::DataConnAccessor ( DataConnProfile * profile )

DataConnAccessor::~DataConnAccessor ( ) [virtual]

Member Function Documentation

INT DataConnAccessor::CountSettings ( ) const [virtual]

Reimplemented in CsdDataConnAccessor, PsdDataConnAccessor, and SerDataConnAccessor.

BOOLEAN DataConnAccessor::First ( ) [virtual]

virtual INT DataConnAccessor::GetIndex ( ) [inline, protected, virtual]

const WCHAR * DataConnAccessor::GetItemText ( BOOLEAN highlighted ) [virtual]

Reimplemented in CsdDataConnAccessor, PsdDataConnAccessor, and SerDataConnAccessor.

DataConnProfileId DataConnAccessor::GetProfileId ( ) [inline, protected]

void DataConnAccessor::Init ( )

Reimplemented in CsdDataConnAccessor, PsdDataConnAccessor, and SerDataConnAccessor.

BOOLEAN DataConnAccessor::IsEnabled ( ) [virtual]

BOOLEAN DataConnAccessor::Next ( ) [virtual]

void DataConnAccessor::OnTrigger ( INT selected_idx ) [protected, virtual]

Reimplemented in CsdDataConnAccessor, PsdDataConnAccessor, and SerDataConnAccessor.

void DataConnAccessor::Update ( ) [virtual]

Reimplemented in CsdDataConnAccessor, PsdDataConnAccessor, and SerDataConnAccessor.

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnAccessor.hpp
  • Applications/DataConn/DataConnAccessor.cpp
Generated on Wed Jan 25 01:09:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnApp Class Reference
[DataConn]

#include <Applications/DataConn/DataConnApp.hpp>

Collaboration diagram for DataConnApp:

[legend]

Public Types

enum | { PropInvalidId = -1 }
enum CommonPropertyId {
PropName, PropAccount, PropPasswd, PropQueryPasswd,
PropPrimaryDnsServerAddress, PropSecondaryDnsServerAddress, CommonPropCount
}
enum CsdPropertyId {
PropCallType, PropPhoneNo, PropDataRate, PropIdleTimer,
PropLingerTimer, CsdPropCount
}
enum FeatureId {
FeatViewDataConnList, FeatEditProfile, FeatDeleteProfile, FeatSaveProfile,
FeatSetDefaultProfile, FeatureCnt
}
enum PsdPropertyId {
PropApnName, PropLocalAddr, PropAuthType, PropDataCompr,
PropQosPrecedence, PropQosDelay, PropQosReliability, PropQosPeakRate,
PropQosMeanRate, PsdPropCount
}
enum | SerPropertyId { PropSerIdleTimer, PropSerLingerTimer, SerPropCount }

Public Member Functions

void | AddDataConnDescription (DataConnDescription *dataconn_desc)
virtual void | OnStartup ()
virtual BOOLEAN | UpdateItem (Item *item)
virtual | ~DataConnApp ()

Static Public Member Functions

static DataConnApp * | GetInstance ()

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &context_item)
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual void | OnOpen ()

Data Structures

class | DataConnDescription
struct | EditableSettingTable

Member Enumeration Documentation

anonymous enum

Enumerator:
PropInvalidId

enum DataConnApp::CommonPropertyId

Enumerator:
PropName
PropAccount
PropPasswd
PropQueryPasswd
PropPrimaryDnsServerAddress
PropSecondaryDnsServerAddress
CommonPropCount

enum DataConnApp::CsdPropertyId

Enumerator:
PropCallType
PropPhoneNo
PropDataRate
PropIdleTimer
PropLingerTimer
CsdPropCount

enum DataConnApp::FeatureId

Enumerator:
FeatViewDataConnList
FeatEditProfile
FeatDeleteProfile
FeatSaveProfile
FeatSetDefaultProfile
FeatureCnt

enum DataConnApp::PsdPropertyId

Enumerator:
PropApnName
PropLocalAddr
PropAuthType
PropDataCompr
PropQosPrecedence
PropQosDelay
PropQosReliability
PropQosPeakRate
PropQosMeanRate
PsdPropCount

enum DataConnApp::SerPropertyId

Enumerator:
PropSerIdleTimer
PropSerLingerTimer
SerPropCount

Constructor & Destructor Documentation

DataConnApp::~DataConnApp ( ) [virtual]

Member Function Documentation

void DataConnApp::AddDataConnDescription ( DataConnDescription * dataconn_desc )

DataConnApp * DataConnApp::GetInstance ( ) [static]

void DataConnApp::OnClose ( ) [protected, virtual]

BOOLEAN DataConnApp::OnContextFeatureTriggered | ( | const FeatureID & | feature_id,
 |  | const DataItem & | context_item
 | ) | [protected, virtual]

BOOLEAN DataConnApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

void DataConnApp::OnOpen ( ) [protected, virtual]

void DataConnApp::OnStartup ( ) [virtual]

BOOLEAN DataConnApp::UpdateItem ( Item * item ) [virtual]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnApp.hpp
  • Applications/DataConn/DataConnApp.cpp
Generated on Wed Jan 25 01:09:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnApp::DataConnDescription Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DataConnApp::DataConnDescription

DataConnApp::DataConnDescription Class Reference

#include <Applications/DataConn/DataConnApp.hpp>

Collaboration diagram for DataConnApp::DataConnDescription:

[legend]

Public Member Functions

DataConnDescription (Property *property, INT prop_cnt, DataConnProfileType profile_type, DataConnProvider *provider, EditableSettingTable *editable_table=0, BOOLEAN allocated_dynamically=TRUE)
DataConnProfileType | GetDataConnProfileType () const
EditableSettingTable * | GetEditableTable () const
Property * | GetFirstProperty () const
INT | GetPropCnt () const
DataConnProvider * | GetProvider () const
BOOLEAN | IsAllocatedDynamically () const

Constructor & Destructor Documentation

DataConnApp::DataConnDescription::DataConnDescription | ( | Property * | property,
 |  | INT | prop_cnt,
 |  | DataConnProfileType | profile_type,
 |  | DataConnProvider * | provider,
 |  | EditableSettingTable * | editable_table = 0,
 |  | BOOLEAN | allocated_dynamically = TRUE
 | ) |

Member Function Documentation

DataConnProfileType DataConnApp::DataConnDescription::GetDataConnProfileType ( ) const [inline]

EditableSettingTable* DataConnApp::DataConnDescription::GetEditableTable ( ) const [inline]

Property* DataConnApp::DataConnDescription::GetFirstProperty ( ) const [inline]

INT DataConnApp::DataConnDescription::GetPropCnt ( ) const [inline]

DataConnProvider* DataConnApp::DataConnDescription::GetProvider ( ) const [inline]

BOOLEAN DataConnApp::DataConnDescription::IsAllocatedDynamically ( ) const [inline]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnApp.hpp
  • Applications/DataConn/DataConnApp.cpp
Generated on Wed Jan 25 01:09:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnApp::EditableSettingTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DataConnApp::EditableSettingTable

DataConnApp::EditableSettingTable Struct Reference

#include <Applications/DataConn/DataConnApp.hpp>

Data Fields

BOOLEAN | always_editable
INT | type

Field Documentation

BOOLEAN DataConnApp::EditableSettingTable::always_editable

INT DataConnApp::EditableSettingTable::type

The documentation for this struct was generated from the following file:
  • Applications/DataConn/DataConnApp.hpp
Generated on Wed Jan 25 01:09:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnCommonSettingsTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnCommonSettingsTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for DataConnCommonSettingsTable:

[legend]
Collaboration diagram for DataConnCommonSettingsTable:

[legend]

Static Public Member Functions

static const WCHAR * GetSetting (DataConnApp::BasicSettingsTypeId setting)

Member Function Documentation

static const WCHAR* DataConnCommonSettingsTable::GetSetting ( DataConnApp::BasicSettingsTypeId setting ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:09:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnInfoMsg Class Reference

#include <Apoxi/Socket/SocketMsg.hpp>

Inheritance diagram for DataConnInfoMsg:

[legend]
Collaboration diagram for DataConnInfoMsg:

[legend]

Public Types

enum | { ID = 19102 }

Public Member Functions

virtual Message * | Clone () const
DataConnInfoMsg (const DataConnInfoMsgType &type, const DataConnProfileId &profile, DcError csd_err=NoCallError, CallApiRc csd_dial_err=NoError, PdpContext::ErrorCause psd_err=PdpContext::NoError)
CallApiRc GetCsdDialError ()
DcError GetCsdError ()
virtual const MsgMetaData & | GetMetaData () const
const DataConnProfileId & | GetProfile () const
PdpContext::ErrorCause GetPsdError ()
const DataConnInfoMsgType & | GetType () const
void | SetProfile (const DataConnProfileId &profile)
void | SetType (const DataConnInfoMsgType &type)
virtual | ~DataConnInfoMsg ()

Detailed Description

Message indicating setup / release of CSD or PSD data connections.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DataConnInfoMsg::DataConnInfoMsg | ( | const DataConnInfoMsgType & | type,
 |  | const DataConnProfileId & | profile,
 |  | DcError | csd_err = NoCallError,
 |  | CallApiRc | csd_dial_err = NoError,
 |  | PdpContext::ErrorCause | psd_err = PdpContext::NoError
 | ) |

DataConnInfoMsg::~DataConnInfoMsg ( ) [virtual]

Member Function Documentation

Message * DataConnInfoMsg::Clone ( ) const [virtual]

Implements Message.

CallApiRc DataConnInfoMsg::GetCsdDialError ( ) [inline]

Returns error code that was indicated during dial up for CSD data connection. On success 'NoError' is returned. See Asc/Types.hpp

DcError DataConnInfoMsg::GetCsdError ( ) [inline]

Returns error code that was indicated for CSD data connection. On success 'NoCallError' is returned. See Apc/SignalTypes.hpp

const MsgMetaData & DataConnInfoMsg::GetMetaData ( ) const [virtual]

Implements Message.

const DataConnProfileId& DataConnInfoMsg::GetProfile ( ) const [inline]

PdpContext::ErrorCause DataConnInfoMsg::GetPsdError ( ) [inline]

Returns error code that was indicated during PSD data connection setup. On success 'PdpContextNoError' is returned. See Asc/PdpContext.hpp

const DataConnInfoMsgType& DataConnInfoMsg::GetType ( ) const [inline]

void DataConnInfoMsg::SetProfile ( const DataConnProfileId & profile ) [inline]

void DataConnInfoMsg::SetType ( const DataConnInfoMsgType & type ) [inline]

The documentation for this class was generated from the following files:
  • Socket/SocketMsg.hpp
  • Socket/SocketMsg.cpp
Generated on Wed Jan 25 01:09:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnLbModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnLbModel Class Reference
[DataConn]

#include <Applications/DataConn/DataConnWin.hpp>

Collaboration diagram for DataConnLbModel:

[legend]

Public Member Functions

DataConnLbModel (DrawableObjectListBox *parent)
DataConnLbModel ()
virtual const BitmapRes * | GetCellIcon (INT index, BOOLEAN highlighted)
virtual const WCHAR * | GetCellText (INT index, BOOLEAN highlighted)
INT | GetProfileCount ()
DataConnProfileId GetSelectedProfileId ()
DataConnProfileManager::ProfileInfo GetSelectedProfileInfo ()
void | Init (DataConnWin *win, DrawableObjectListBox *parent)
void | Update ()
virtual | ~DataConnLbModel ()

Protected Member Functions

virtual void | OnSelectionChanged (INT selected_index)

Constructor & Destructor Documentation

DataConnLbModel::DataConnLbModel ( )

DataConnLbModel::DataConnLbModel ( DrawableObjectListBox * parent ) [explicit]

DataConnLbModel::~DataConnLbModel ( ) [virtual]

Member Function Documentation

const BitmapRes * DataConnLbModel::GetCellIcon | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

const WCHAR * DataConnLbModel::GetCellText | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

INT DataConnLbModel::GetProfileCount ( ) [inline]

DataConnProfileId DataConnLbModel::GetSelectedProfileId ( ) [inline]

DataConnProfileManager::ProfileInfo DataConnLbModel::GetSelectedProfileInfo ( ) [inline]

void DataConnLbModel::Init | ( | DataConnWin * | win,
 |  | DrawableObjectListBox * | parent
 | ) |

void DataConnLbModel::OnSelectionChanged ( INT selected_index ) [protected, virtual]

void DataConnLbModel::Update ( )

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnWin.hpp
  • Applications/DataConn/DataConnWin.cpp
Generated on Wed Jan 25 01:09:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnManager Class Reference
[Socket]

#include <Apoxi/Socket/DataConnManager.hpp>

Collaboration diagram for DataConnManager:

[legend]

Public Member Functions

DataConn & | GetDataConn (DataConnProfileId id)
const DataConn & | GetDataConn (DataConnProfileId id) const
DataConnPtr | GetDataConnByIdx (UINT idx) const
DataConnPtr | GetDataConnByIdxAndType (UINT idx, DataConnProfile::ProfileType type) const
UINT | GetDataConnCount (DataConnProfile::ProfileType type) const
UINT | GetDataConnCount () const
BOOLEAN | IsDataConnRegistered (DataConnProfileId id) const
BOOLEAN | RegisterDataConn (DataConnProfileId id)
BOOLEAN | UnregisterDataConn (DataConnProfileId id)

Static Public Member Functions

static DataConnManager & | Get ()

Friends

class | SocketRxThread

Detailed Description

Class DataConnManager implements a singleton that manages data connections of any type (e.g. circuit switched, packet switched, or serial).

Member Function Documentation

DataConnManager & DataConnManager::Get ( ) [static]

Returns the reference to the data connection manager singleton.

DataConn & DataConnManager::GetDataConn ( DataConnProfileId id )

Returns a reference to the data connection with the specified data connection profile id. This method must only be called for data connections that are currently registered, otherwise an assertion holds.

Returns:
Reference to the specified data connection.
See also:
RegisterDataConn

const DataConn & DataConnManager::GetDataConn ( DataConnProfileId id ) const

Returns a constant reference to the data connection with the specified data connection profile id. This method must only be called for data connections that are currently registered, otherwise an assertion holds.

Returns:
Constant reference to the specified data connection.
See also:
RegisterDataConn

DataConnPtr DataConnManager::GetDataConnByIdx ( UINT idx ) const

This method is used to enumerate the currently registered data connections. E.g., if there are n data connections active, then the index may range from 0 to n - 1. If idx is too high, the empty smart pointer is returned.

DataConnPtr DataConnManager::GetDataConnByIdxAndType | ( | UINT | idx,
 |  | DataConnProfile::ProfileType | type
 | ) | const

This method is used to enumerate the currently registered data connections of type. E.g., if there are n data connections of some type active, then the index may range from 0 to n - 1. If idx is too high, the empty smart pointer is returned.

UINT DataConnManager::GetDataConnCount ( DataConnProfile::ProfileType type ) const

Returns the number of existing data connections of the specified type.

UINT DataConnManager::GetDataConnCount ( ) const

Returns the number of existing data connections.

BOOLEAN DataConnManager::IsDataConnRegistered ( DataConnProfileId id ) const

Tells if the data connection with id is already registered to the data connection manager.

BOOLEAN DataConnManager::RegisterDataConn ( DataConnProfileId id )

Registers the data connection specified by profile id to the data connection manager. The method returns TRUE if the data connection was registered successfully. Registering fails if the data connection is already registered, or if the ID of the given profile doesn't exist or cannot be retrieved, or if an out of memory condition occurs.

Returns:
Success of operation.

BOOLEAN DataConnManager::UnregisterDataConn ( DataConnProfileId id )

Unregisters the data connection specified by profile id from the data connection manager. The method returns TRUE if the data connection was unregistered successfully. If the data connection is currently active, then the data connection gets released first. The method blocks until unregistering is finished. Unregistering fails if no data connection with profile id is currently registered.

Returns:
Success of operation.

Friends And Related Function Documentation

friend class SocketRxThread [friend]

The documentation for this class was generated from the following files:
  • Socket/DataConnManager.hpp
  • Socket/DataConnManager.cpp
Generated on Wed Jan 25 01:09:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnOptionWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnOptionWin Class Reference
[DataConn]

#include <Applications/DataConn/DataConnOptionWin.hpp>

Public Types

typedef MmiDialog | Base

Public Member Functions

void | AddAction (RadioButtonAction *action)
DataConnOptionWin ()
INT | GetSelectedValue ()
void | Init ()
void | SetSelectedRadioButton (INT value)
virtual | ~DataConnOptionWin ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()

Member Typedef Documentation

typedef MmiDialog DataConnOptionWin::Base

Constructor & Destructor Documentation

DataConnOptionWin::DataConnOptionWin ( )

DataConnOptionWin::~DataConnOptionWin ( ) [virtual]

Member Function Documentation

void DataConnOptionWin::AddAction ( RadioButtonAction * action ) [inline]

INT DataConnOptionWin::GetSelectedValue ( )

void DataConnOptionWin::Init ( )

BOOLEAN DataConnOptionWin::OnConfirm ( ) [protected, virtual]

void DataConnOptionWin::SetSelectedRadioButton ( INT value )

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnOptionWin.hpp
  • Applications/DataConn/DataConnOptionWin.cpp
Generated on Wed Jan 25 01:09:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProfile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnProfile Class Reference
[Socket]

#include <Apoxi/Socket/DataConnProfile.hpp>

Inheritance diagram for DataConnProfile:

[legend]
Collaboration diagram for DataConnProfile:

[legend]

Public Types

enum | { c_account_len_max = APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX, c_passwd_len_max = APOXI_BEARER_PROFILE_PASSWD_LEN_MAX }
enum | ProfileType { c_profile_type_psd = 0, c_profile_type_csd = 1 }
enum | TimeoutValue { c_default_idle_timeout = 120, c_default_linger_timeout = 30, c_infinite_timeout = 1023, c_no_timeout = 0 }

Public Member Functions

DataConnProfilePtr | Clone () const
void | EnablePasswdQuery (BOOLEAN enable=TRUE)
const String & | GetAccount () const
DataConnProfileId | GetId () const
UINT16 | GetIdleTimeout () const
UINT16 | GetLingerTimeout () const
const WString & | GetName () const
const String & | GetPasswd () const
const IpAddr & | GetPrimaryDnsServerAddress () const
const IpAddr & | GetSecondaryDnsServerAddress () const
ProfileType | GetType () const
BOOLEAN | IsReadOnly () const
BOOLEAN | QueryForPasswd () const
virtual void | SaveFrom (const PersistDataConnProfile &bpp)
virtual void | SaveTo (PersistDataConnProfile &bpp) const
void | SetAccount (const String &account)
void | SetIdleTimeout (UINT16 timeout)
void | SetLingerTimeout (UINT16 timeout)
void | SetName (const WString &name)
void | SetPasswd (const String &passwd)
void | SetPrimaryDnsServerAddress (const IpAddr &primary_dns)
void | SetReadOnly ()
void | SetSecondaryDnsServerAddress (const IpAddr &secondary_dns)
virtual | ~DataConnProfile ()

Protected Member Functions

virtual void | Assign (const DataConnProfile &from_dcp)
DataConnProfile (ProfileType type)
virtual DataConnProfile * | New () const =0

Static Protected Member Functions

static DataConnPtr | CreateDataConn (const DataConnProfilePtr &profile)

Friends

class | DataConnManager
class | DataConnProfileManager
class | PersistDataConnProfile

Data Structures

struct | Bit
struct | Persist

Detailed Description

Class DataConnProfile is the base class of data bearer settings.

Member Enumeration Documentation

anonymous enum

Enumerator:
c_account_len_max
c_passwd_len_max

enum DataConnProfile::ProfileType

Enumerator:
c_profile_type_psd
c_profile_type_csd

enum DataConnProfile::TimeoutValue

Enumerator:
c_default_idle_timeout | 2 minutes.
c_default_linger_timeout | 30 seconds.
c_infinite_timeout | Infinite timeout.
c_no_timeout | No timeout.

Constructor & Destructor Documentation

DataConnProfile::DataConnProfile ( ProfileType type ) [protected]

DataConnProfile::~DataConnProfile ( ) [virtual]

Member Function Documentation

void DataConnProfile::Assign ( const DataConnProfile & from_dcp ) [protected, virtual]

Copies and sets all properties of the given data connection profile object, especially used for cloning.

Reimplemented in CsdDataConnProfile, and PsdDataConnProfile.

DataConnProfilePtr DataConnProfile::Clone ( ) const

Returns a clone of the current data connection profile.

DataConnPtr DataConnProfile::CreateDataConn ( const DataConnProfilePtr & profile ) [static, protected]

Returns a new data connection according to the given data connection profile. The data connection returned is wrapped into a smart pointer. The profile must be valid, otherwise an assertion holds.

Returns:
A DataConnPtr wrapping either a new data connection or 0 if there is not enough memory left.

void DataConnProfile::EnablePasswdQuery ( BOOLEAN enable = TRUE ) [inline]

Enable/disable mandatory password query.

const String& DataConnProfile::GetAccount ( ) const [inline]

Return login name of data account.

DataConnProfileId DataConnProfile::GetId ( ) const [inline]

Returns unique id for profile (can be used to reference profile).

UINT16 DataConnProfile::GetIdleTimeout ( ) const [inline]

Get idle timeout value in seconds (max. 1024). After defined number of seconds without inbound or outbound data transfer, the connection will be automatically shut down.

UINT16 DataConnProfile::GetLingerTimeout ( ) const [inline]

Get linger timeout value in seconds (max. 1024). When the last socket referring to a data connection releases the data connection then the data connection is not released immediately but stays alive for the specified amount of seconds. During this time a setup request for the same data connection is very fast. If no setup request takes place, then after the linger timeout the data connection is shut down physically.

const WString& DataConnProfile::GetName ( ) const [inline]

Returns the user defined name of the bearer profile.

const String& DataConnProfile::GetPasswd ( ) const [inline]

Return login password of data account.

const IpAddr& DataConnProfile::GetPrimaryDnsServerAddress ( ) const [inline]

Returns the IP address of the primary DNS server.

const IpAddr& DataConnProfile::GetSecondaryDnsServerAddress ( ) const [inline]

Returns the IP address of the secondary DNS server.

ProfileType DataConnProfile::GetType ( ) const [inline]

Return type of profile.

BOOLEAN DataConnProfile::IsReadOnly ( ) const [inline]

TRUE if profile is predefined and can't be modified.

virtual DataConnProfile* DataConnProfile::New ( ) const [protected, pure virtual]

Return a new data connection profile object based on the current dynamic type.

Implemented in CsdDataConnProfile, and PsdDataConnProfile.

BOOLEAN DataConnProfile::QueryForPasswd ( ) const [inline]

Mandatory password query enabled/disabled.

void DataConnProfile::SaveFrom ( const PersistDataConnProfile & bpp ) [virtual]

Reimplemented in CsdDataConnProfile, and PsdDataConnProfile.

void DataConnProfile::SaveTo ( PersistDataConnProfile & bpp ) const [virtual]

Reimplemented in CsdDataConnProfile, and PsdDataConnProfile.

void DataConnProfile::SetAccount ( const String & account ) [inline]

Set login name of data account. Length restrictions apply according to c_account_len_max.

void DataConnProfile::SetIdleTimeout ( UINT16 timeout ) [inline]

Set idle timeout value of data connection. Set to c_no_timeout to deactivate the timer.

void DataConnProfile::SetLingerTimeout ( UINT16 timeout ) [inline]

Set linger timeout value of data connection. Set to c_no_timeout to deactivate the timer.

void DataConnProfile::SetName ( const WString & name ) [inline]

Set the user defined name of the bearer profile. Length restrictions apply according to c_host_name_len_max.

void DataConnProfile::SetPasswd ( const String & passwd ) [inline]

Set password of data account. Length restrictions apply according to c_passwd_len_max. Note that APOXI socket system will not perform password queries on its own.

void DataConnProfile::SetPrimaryDnsServerAddress ( const IpAddr & primary_dns ) [inline]

Sets the IP address of the primary DNS server. Note that DNS might not be supported in all configurations.

void DataConnProfile::SetReadOnly ( ) [inline]

Define profile as read only.

void DataConnProfile::SetSecondaryDnsServerAddress ( const IpAddr & secondary_dns ) [inline]

Sets the IP address of the secondary DNS server. Note that DNS might not be supported in all configurations.

Friends And Related Function Documentation

friend class DataConnManager [friend]

friend class DataConnProfileManager [friend]

friend class PersistDataConnProfile [friend]

The documentation for this class was generated from the following files:
  • Socket/DataConnProfile.hpp
  • Socket/DataConnProfile.cpp
Generated on Wed Jan 25 01:09:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProfile::Bit Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DataConnProfile::Bit

DataConnProfile::Bit Struct Reference

#include <Apoxi/Socket/DataConnProfile.hpp>

Data Fields

UINT | m_id: (sizeof(DataConnProfileId) * 8U)
UINT | m_idle_timeout: 10
UINT | m_linger_timeout: 10
UINT | m_passwd_query: 1
UINT | m_readonly: 1
UINT | m_type: 2

Field Documentation

UINT DataConnProfile::Bit::m_id

UINT DataConnProfile::Bit::m_idle_timeout

UINT DataConnProfile::Bit::m_linger_timeout

UINT DataConnProfile::Bit::m_passwd_query

UINT DataConnProfile::Bit::m_readonly

UINT DataConnProfile::Bit::m_type

The documentation for this struct was generated from the following file:
  • Socket/DataConnProfile.hpp
Generated on Wed Jan 25 01:09:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProfile::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DataConnProfile::Persist

DataConnProfile::Persist Struct Reference

#include <Apoxi/Socket/DataConnProfile.hpp>

Collaboration diagram for DataConnProfile::Persist:

[legend]

Data Fields

CHAR | m_account [c_account_len_max+1]
Bit m_bit
WCHAR | m_name [c_host_name_len_max+1]
CHAR | m_passwd [c_passwd_len_max+1]
IpAddr::Persist m_primary_dns
IpAddr::Persist m_secondary_dns

Field Documentation

CHAR DataConnProfile::Persist::m_account[c_account_len_max+1]

Bit DataConnProfile::Persist::m_bit

WCHAR DataConnProfile::Persist::m_name[c_host_name_len_max+1]

CHAR DataConnProfile::Persist::m_passwd[c_passwd_len_max+1]

IpAddr::Persist DataConnProfile::Persist::m_primary_dns

IpAddr::Persist DataConnProfile::Persist::m_secondary_dns

The documentation for this struct was generated from the following file:
  • Socket/DataConnProfile.hpp
Generated on Wed Jan 25 01:09:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProfileInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnProfileInfoMsg Class Reference

#include <Apoxi/Socket/SocketMsg.hpp>

Inheritance diagram for DataConnProfileInfoMsg:

[legend]
Collaboration diagram for DataConnProfileInfoMsg:

[legend]

Public Types

enum | { ID = 19103 }

Public Member Functions

virtual Message * | Clone () const
DataConnProfileInfoMsg (const DataConnProfileInfoMsgType &type, const DataConnProfileId &profileId, const WString &profileName, BOOLEAN temporaryProfile)
virtual const MsgMetaData & | GetMetaData () const
const DataConnProfileId & | GetProfileId () const
const WString & | GetProfileName () const
const DataConnProfileInfoMsgType & | GetType () const
BOOLEAN | IsTemporaryProfile () const
void | SetProfileId (const DataConnProfileId &profileId)
void | SetProfileName (const WString &profileName)
void | SetTemporaryProfile (BOOLEAN temporaryProfile)
void | SetType (const DataConnProfileInfoMsgType &type)
virtual | ~DataConnProfileInfoMsg ()

Detailed Description

Message indicating creation/change/deletion of a temporary/persistent data connection profile.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DataConnProfileInfoMsg::DataConnProfileInfoMsg | ( | const DataConnProfileInfoMsgType & | type,
 |  | const DataConnProfileId & | profileId,
 |  | const WString & | profileName,
 |  | BOOLEAN | temporaryProfile
 | ) |

DataConnProfileInfoMsg::~DataConnProfileInfoMsg ( ) [virtual]

Member Function Documentation

Message * DataConnProfileInfoMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & DataConnProfileInfoMsg::GetMetaData ( ) const [virtual]

Implements Message.

const DataConnProfileId& DataConnProfileInfoMsg::GetProfileId ( ) const [inline]

const WString& DataConnProfileInfoMsg::GetProfileName ( ) const [inline]

const DataConnProfileInfoMsgType& DataConnProfileInfoMsg::GetType ( ) const [inline]

BOOLEAN DataConnProfileInfoMsg::IsTemporaryProfile ( ) const [inline]

void DataConnProfileInfoMsg::SetProfileId ( const DataConnProfileId & profileId ) [inline]

void DataConnProfileInfoMsg::SetProfileName ( const WString & profileName ) [inline]

void DataConnProfileInfoMsg::SetTemporaryProfile ( BOOLEAN temporaryProfile ) [inline]

void DataConnProfileInfoMsg::SetType ( const DataConnProfileInfoMsgType & type ) [inline]

The documentation for this class was generated from the following files:
  • Socket/SocketMsg.hpp
  • Socket/SocketMsg.cpp
Generated on Wed Jan 25 01:09:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProfileManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnProfileManager Class Reference
[Socket]

#include <Apoxi/Socket/DataConnProfileManager.hpp>

Collaboration diagram for DataConnProfileManager:

[legend]

Public Member Functions

BOOLEAN | AddProfile (DataConnProfile &dcp)
BOOLEAN | AddTemporaryProfile (DataConnProfile &dcp)
BOOLEAN | AttachStorage (DataConnProfileStorage *storage)
BOOLEAN | DeleteProfile (DataConnProfileId id)
DataConnProfileId | GetDefProfileId () const
DataConnProfilePtr | GetProfile (DataConnProfileId &id)
BOOLEAN | GetProfileIdSet (DataConnProfileIdSet &pis) const
BOOLEAN | GetProfileInfo (DataConnProfileId id, ProfileInfo &pi)
BOOLEAN | GetTemporaryProfileIdSet (DataConnTempProfileIdSet &pis) const
BOOLEAN | IsTemporaryProfileId (DataConnProfileId id) const
BOOLEAN | ResetToFactoryDefaults ()
BOOLEAN | SaveProfile (const DataConnProfile &dcp)
BOOLEAN | SetDefProfileId (DataConnProfileId id)
BOOLEAN | StorageIsAttached () const
BOOLEAN | UpdateProfile (DataConnProfile &dcp)

Static Public Member Functions

static DataConnProfileManager & | Get ()
static DataConnProfileId | GetCanonicalProfileId (DataConnProfileId id)

Data Structures

class | ProfileInfo

Detailed Description

Class DataConnProfileManager manages and persists DataConnProfile objects.

Member Function Documentation

BOOLEAN DataConnProfileManager::AddProfile ( DataConnProfile & dcp )

Adds a new data connection profile. Adding a new data connection profile will assign a new ID to it and save it.

BOOLEAN DataConnProfileManager::AddTemporaryProfile ( DataConnProfile & dcp )

Adds a new, temporary data connection profile. Adding a new data connection profile will assign a new ID to it.

BOOLEAN DataConnProfileManager::AttachStorage ( DataConnProfileStorage * storage )

Attaches a data connection profile storage. This has to be done before persistent data connection profiles can be used. The data connection profile storage is responsible for storing data connection profiles, e.g. to the flash file system or to NVRAM. If you pass 0 then the currently attached storage, if any, gets closed and detached and TRUE is returned. If a valid storage is passed then the currently attached storage, if any, gets closed and the new one is opened and attached and the success of attaching is returned.

BOOLEAN DataConnProfileManager::DeleteProfile ( DataConnProfileId id )

Deletes a data connection profile.

DataConnProfileManager & DataConnProfileManager::Get ( ) [static]

Returns the reference to the data connection profile manager singleton.

DataConnProfileId DataConnProfileManager::GetCanonicalProfileId ( DataConnProfileId id ) [static]

Returns the canonical profile ID for the given profile id. This means, that for the invalid profile id the default profile ID is returned, otherwise the id itself is returned. Note, that if id is the invalid profile ID and no profiles are defined then the invalid profile ID is returned.

DataConnProfileId DataConnProfileManager::GetDefProfileId ( ) const

Returns the ID of the default data connection profile.

DataConnProfilePtr DataConnProfileManager::GetProfile ( DataConnProfileId & id )

Retrieves the data connection profile for the specified profile id. If the specified data connection profile id is the invalid one, then the default data connection profile is retrieved instead and argument id is set to its ID. The success of retrieving a data connection profile is returned.

Parameters:
id Profile ID of the data connection whose profile is to be retrieved. On success, id is set to the ID of the actually retrieved profile.
Returns:
A DataConnProfilePtr wrapping either a data connection profile or 0 on failure.

BOOLEAN DataConnProfileManager::GetProfileIdSet ( DataConnProfileIdSet & pis ) const

Retrieves the set of existing, non-temporary data connection profile IDs.

BOOLEAN DataConnProfileManager::GetProfileInfo | ( | DataConnProfileId | id,
 |  | ProfileInfo & | pi
 | ) |

Retrieves information of a data connection profile.

BOOLEAN DataConnProfileManager::GetTemporaryProfileIdSet ( DataConnTempProfileIdSet & pis ) const

Retrieves the set of existing, temporary data connection profile IDs.

BOOLEAN DataConnProfileManager::IsTemporaryProfileId ( DataConnProfileId id ) const

Checks whether the given data connection profile id belongs to a valid temporary data connection profile or not.

BOOLEAN DataConnProfileManager::ResetToFactoryDefaults ( )

Restores persistent data connection profile settings to defined factory defaults. This method does not affect any currently existing temporary data connection profiles.

BOOLEAN DataConnProfileManager::SaveProfile ( const DataConnProfile & dcp )

Saves an existing connection profile.

BOOLEAN DataConnProfileManager::SetDefProfileId ( DataConnProfileId id )

Defines the default, non-temporary data connection profile ID.

BOOLEAN DataConnProfileManager::StorageIsAttached ( ) const [inline]

Tells if a data connection profile storage is attached.

BOOLEAN DataConnProfileManager::UpdateProfile ( DataConnProfile & dcp )

Updates the given data connection profile instance with the latest settings out of the profile storage.

Returns:
Tells if the given profile instance could be updated or not.

The documentation for this class was generated from the following files:
  • Socket/DataConnProfileManager.hpp
  • Socket/DataConnProfileManager.cpp
Generated on Wed Jan 25 01:09:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProfileManager::ProfileInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DataConnProfileManager::ProfileInfo

DataConnProfileManager::ProfileInfo Class Reference

#include <Apoxi/Socket/DataConnProfileManager.hpp>

Collaboration diagram for DataConnProfileManager::ProfileInfo:

[legend]

Public Member Functions

const WString & | GetName () const
DataConnProfile::ProfileType | GetType () const
BOOLEAN | IsReadOnly () const
BOOLEAN | IsTemporary () const

Friends

class | DataConnProfileManager

Data Structures

struct | Bit

Detailed Description

Subset of data connection profile data that can be used to list and display data connection profiles.

Member Function Documentation

const WString& DataConnProfileManager::ProfileInfo::GetName ( ) const [inline]

Returns the profile name.

DataConnProfile::ProfileType DataConnProfileManager::ProfileInfo::GetType ( ) const [inline]

Determines the type of profile, i.e. packet switched, circuit switched, or serial.

BOOLEAN DataConnProfileManager::ProfileInfo::IsReadOnly ( ) const [inline]

Defines if the profile can be deleted or modified. Preset profiles are read only.

BOOLEAN DataConnProfileManager::ProfileInfo::IsTemporary ( ) const [inline]

Defines if the profile is a temporary one. Temporary profiles can't be stored persistent.

Friends And Related Function Documentation

friend class DataConnProfileManager [friend]

The documentation for this class was generated from the following file:
  • Socket/DataConnProfileManager.hpp
Generated on Wed Jan 25 01:09:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProfileStorage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnProfileStorage Class Reference
[Socket]

#include <Apoxi/Socket/DataConnProfileStorage.hpp>

Inheritance diagram for DataConnProfileStorage:

[legend]

Public Member Functions

virtual void | Close ()
virtual BOOLEAN | Open ()
virtual BOOLEAN | Read (INT recno, PersistDataConnProfile &pdcp)
virtual BOOLEAN | Read (Header &header)
virtual BOOLEAN | ResetToFactoryDefaults ()
virtual BOOLEAN | Write (INT recno, const PersistDataConnProfile &pdcp)
virtual BOOLEAN | Write (const Header &header)

Data Structures

class | Header

Detailed Description

DataConnProfileStorage defines an interface to a storage for DataConnProfile objects. It is used by DataConnProfileManager to store and retrieve DataConnProfile settings. DataConnProfileStorage functionality will be used exclusively by DataConnProfileManager. DataConnProfileManager will also control access to DataConnProfileStorage - only one context will access DataConnProfileStorage functionality at a time. In order to avoid dependencies on specifics of storing the profiles, APOXI does not provide an implementation of profile storage. Prototypic implementation can be obtained from COMNEON.

Member Function Documentation

virtual void DataConnProfileStorage::Close ( ) [inline, virtual]

Close is called to shut down the profile storage. No read or write operations will be done after closing the storage device.

Reimplemented in FfsDataConnProfileStorage.

virtual BOOLEAN DataConnProfileStorage::Open ( void ) [inline, virtual]

Open is called to initialize the profile storage. After successful open operation, data can be read from and written to the profile storage.

Reimplemented in FfsDataConnProfileStorage.

virtual BOOLEAN DataConnProfileStorage::Read | ( | INT | recno,
 |  | PersistDataConnProfile & | pdcp
 | ) | [inline, virtual]

Read receives the profile with record number recno from the profile storage. Record numbers range from 0 to DataConnManager::c_data_conn_profile_count - 1.

Reimplemented in FfsDataConnProfileStorage.

virtual BOOLEAN DataConnProfileStorage::Read ( Header & header ) [inline, virtual]

Read reads the header from the profile storage. If data has been read successfully TRUE is returned. If data is read for the first time, then the header must be initialized according to the default constructor of class Header.

BOOLEAN DataConnProfileStorage::ResetToFactoryDefaults ( ) [virtual]

ResetToFactoryDefaults clears the profile storage and resets its values to factory defaults. Operation can only be applied if the profile storage is in open state. The default implementation clears the header to default values (i.e. deletes all DataConnProfiles).

virtual BOOLEAN DataConnProfileStorage::Write | ( | INT | recno,
 |  | const PersistDataConnProfile & | pdcp
 | ) | [inline, virtual]

Write saves profile data to record number recno. Record numbers range from 0 to DataConnManager::c_data_conn_profile_count - 1.

Reimplemented in FfsDataConnProfileStorage.

virtual BOOLEAN DataConnProfileStorage::Write ( const Header & header ) [inline, virtual]

Write writes header information to the profile storage. It is assumed that the write operation is synchronous.

The documentation for this class was generated from the following files:
  • Socket/DataConnProfileStorage.hpp
  • Socket/DataConnProfileStorage.cpp
Generated on Wed Jan 25 01:09:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProfileStorage::Header Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DataConnProfileStorage::Header

DataConnProfileStorage::Header Class Reference

#include <Apoxi/Socket/DataConnProfileStorage.hpp>

Public Types

enum | { c_file_version = 1 }

Public Member Functions

Header ()

Data Fields

DataConnProfileId m_def_profile
UINT8 | m_free [10]
DataConnProfileId m_last_id
DataConnProfileIdSet m_profile_id
UINT16 | m_profile_rec_size
UINT8 | m_rec_max_count
UINT8 | m_version

Detailed Description

Header stores profile storage meta data like default DataConnProfile ID and record allocation table. Also included is data for conformance and plausibility checks.

Member Enumeration Documentation

anonymous enum

Enumerator:
c_file_version

Constructor & Destructor Documentation

DataConnProfileStorage::Header::Header ( )

Field Documentation

DataConnProfileId DataConnProfileStorage::Header::m_def_profile

UINT8 DataConnProfileStorage::Header::m_free[10]

DataConnProfileId DataConnProfileStorage::Header::m_last_id

DataConnProfileIdSet DataConnProfileStorage::Header::m_profile_id

UINT16 DataConnProfileStorage::Header::m_profile_rec_size

UINT8 DataConnProfileStorage::Header::m_rec_max_count

UINT8 DataConnProfileStorage::Header::m_version

The documentation for this class was generated from the following files:
  • Socket/DataConnProfileStorage.hpp
  • Socket/DataConnProfileStorage.cpp
Generated on Wed Jan 25 01:09:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnProvider Class Reference
[DataConn]

#include <Applications/DataConn/DataConnProvider.hpp>

Inheritance diagram for DataConnProvider:

[legend]
Collaboration diagram for DataConnProvider:

[legend]

Public Types

typedef Provider | Base

Public Member Functions

virtual BOOLEAN | AppendRow ()
Append a row.
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
DataConnProvider ()
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT column)
SetDataItem sets data items
virtual | ~DataConnProvider ()
Destructor.

Protected Member Functions

virtual void | ClearProfile ()=0
DataConnProfile * | GetProfile (DataConnProfileId profile_id)
DataConnProfile * GetProfile ()
DataConnProfileId | GetProfileId (INT row) const
virtual DataConnProfile * | GetProfileInstance ()=0
DataConnProfileManager * GetProfileManager ()
DataConnProfile::ProfileType | GetProfileType (INT row) const

Member Typedef Documentation

typedef Provider DataConnProvider::Base

Reimplemented in CsdDataConnProvider, PsdDataConnProvider, and SerDataConnProvider.

Constructor & Destructor Documentation

DataConnProvider::DataConnProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

DataConnProvider::~DataConnProvider ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN DataConnProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

virtual void DataConnProvider::ClearProfile ( ) [protected, pure virtual]

Implemented in CsdDataConnProvider, PsdDataConnProvider, and SerDataConnProvider.

BOOLEAN DataConnProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN DataConnProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN DataConnProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

Reimplemented in CsdDataConnProvider, PsdDataConnProvider, and SerDataConnProvider.

DataConnProfile * DataConnProvider::GetProfile ( DataConnProfileId profile_id ) [protected]

DataConnProfile* DataConnProvider::GetProfile ( ) [inline, protected]

DataConnProfileId DataConnProvider::GetProfileId ( INT row ) const [protected]

virtual DataConnProfile* DataConnProvider::GetProfileInstance ( ) [protected, pure virtual]

Implemented in CsdDataConnProvider, PsdDataConnProvider, and SerDataConnProvider.

DataConnProfileManager* DataConnProvider::GetProfileManager ( ) [inline, protected]

DataConnProfile::ProfileType DataConnProvider::GetProfileType ( INT row ) const [protected]

INT DataConnProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

Reimplemented in CsdDataConnProvider, PsdDataConnProvider, and SerDataConnProvider.

INT DataConnProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN DataConnProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN DataConnProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | column
 | ) | [virtual]

SetDataItem sets data items

Reimplemented from Provider.

Reimplemented in CsdDataConnProvider, PsdDataConnProvider, and SerDataConnProvider.

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnProvider.hpp
  • Applications/DataConn/DataConnProvider.cpp
Generated on Wed Jan 25 01:09:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnTypeWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnTypeWin Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTypeWin.hpp>

Collaboration diagram for DataConnTypeWin:

[legend]

Public Types

typedef MmiDialog | Base

Public Member Functions

DataConnTypeWin ()
DataConnProfile::ProfileType GetProfileType ()
void | Init ()
virtual | ~DataConnTypeWin ()

Member Typedef Documentation

typedef MmiDialog DataConnTypeWin::Base

Constructor & Destructor Documentation

DataConnTypeWin::DataConnTypeWin ( )

DataConnTypeWin::~DataConnTypeWin ( ) [virtual]

Member Function Documentation

DataConnProfile::ProfileType DataConnTypeWin::GetProfileType ( ) [inline]

void DataConnTypeWin::Init ( )

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTypeWin.hpp
  • Applications/DataConn/DataConnTypeWin.cpp
Generated on Wed Jan 25 01:09:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataConnWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataConnWin Class Reference
[DataConn]

#include <Applications/DataConn/DataConnWin.hpp>

Collaboration diagram for DataConnWin:

[legend]

Public Types

typedef MmiWindow | Base

Public Member Functions

DataConnWin ()
DataConnApp * GetConnApplication ()
DataConnProfileId GetSelectedProfileId ()
void | Init (DataConnApp *app)
void | Update ()
void | UpdateEnabledActions ()
virtual | ~DataConnWin ()

Protected Member Functions

virtual void | OnOpen ()

Member Typedef Documentation

typedef MmiWindow DataConnWin::Base

Constructor & Destructor Documentation

DataConnWin::DataConnWin ( )

DataConnWin::~DataConnWin ( ) [virtual]

Member Function Documentation

DataConnApp* DataConnWin::GetConnApplication ( ) [inline]

DataConnProfileId DataConnWin::GetSelectedProfileId ( ) [inline]

void DataConnWin::Init ( DataConnApp * app )

void DataConnWin::OnOpen ( ) [protected, virtual]

void DataConnWin::Update ( )

void DataConnWin::UpdateEnabledActions ( )

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnWin.hpp
  • Applications/DataConn/DataConnWin.cpp
Generated on Wed Jan 25 01:09:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataControl Class Reference
[ADC]

#include <Apoxi/Adc/DataHandler.hpp>

Inheritance diagram for DataControl:

[legend]
Collaboration diagram for DataControl:

[legend]

Public Types

typedef SubSystem | Base

Public Member Functions

DataControl ()
virtual const WCHAR * | GetName () const
virtual UINT8 | GetPriority () const
virtual SubSystemManager::BootSequenceState | InvokeAt () const
virtual void | OnPowerDown ()
virtual void | OnPowerUp ()
virtual | ~DataControl ()

Static Public Member Functions

static BootControl * | GetBootControl ()
static DataHandler * | GetDataHandler ()
returns the DataHandler which can be used for further operations
static MainProvider * | GetMainProvider ()
returns the MainProvider to retrieve the ADC providers
static SimAccessor * | GetSimAccessor ()
static void | PostNotification (DataControlType type)

Detailed Description

DataControl is the singelton which represents the ADC.

Member Typedef Documentation

typedef SubSystem DataControl::Base

Constructor & Destructor Documentation

DataControl::DataControl ( )

DataControl::~DataControl ( ) [virtual]

Member Function Documentation

static BootControl* DataControl::GetBootControl ( ) [inline, static]

DataHandler * DataControl::GetDataHandler ( ) [static]

returns the DataHandler which can be used for further operations

MainProvider * DataControl::GetMainProvider ( ) [static]

returns the MainProvider to retrieve the ADC providers

const WCHAR * DataControl::GetName ( ) const [virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

UINT8 DataControl::GetPriority ( ) const [virtual]

Priority controls the init sequence of SubSystems.

Reimplemented from SubSystem.

static SimAccessor* DataControl::GetSimAccessor ( ) [inline, static]

SubSystemManager::BootSequenceState DataControl::InvokeAt ( ) const [virtual]

InvokeAt denotes the system boot phase the SubSystem shall be initialized in.

Implements SubSystem.

void DataControl::OnPowerDown ( ) [virtual]

This method will be invoked on system power down.

Reimplemented from SubSystem.

void DataControl::OnPowerUp ( ) [virtual]

This method will be invoked on system power on.

Reimplemented from SubSystem.

void DataControl::PostNotification ( DataControlType type ) [static]

The documentation for this class was generated from the following files:
  • Adc/DataHandler.hpp
  • Adc/DataHandler.cpp
Generated on Wed Jan 25 01:09:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataControlBootMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataControlBootMsg Class Reference

#include <Apoxi/Adc/MsgTypes.hpp>

Inheritance diagram for DataControlBootMsg:

[legend]
Collaboration diagram for DataControlBootMsg:

[legend]

Public Types

enum | { ID = 19003 }

Public Member Functions

virtual Message * | Clone () const
DataControlBootMsg (const BootState &boot_state)
const BootState & | GetBootState () const
virtual const MsgMetaData & | GetMetaData () const
void | SetBootState (const BootState &boot_state)
virtual | ~DataControlBootMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DataControlBootMsg::DataControlBootMsg ( const BootState & boot_state )

DataControlBootMsg::~DataControlBootMsg ( ) [virtual]

Member Function Documentation

Message * DataControlBootMsg::Clone ( ) const [virtual]

Implements Message.

const BootState& DataControlBootMsg::GetBootState ( ) const [inline]

const MsgMetaData & DataControlBootMsg::GetMetaData ( ) const [virtual]

Implements Message.

void DataControlBootMsg::SetBootState ( const BootState & boot_state ) [inline]

The documentation for this class was generated from the following files:
  • Adc/MsgTypes.hpp
  • Adc/MsgTypes.cpp
Generated on Wed Jan 25 01:09:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataControlBootProgressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataControlBootProgressMsg Class Reference

#include <Apoxi/Adc/MsgTypes.hpp>

Inheritance diagram for DataControlBootProgressMsg:

[legend]
Collaboration diagram for DataControlBootProgressMsg:

[legend]

Public Types

enum | { ID = 19002 }

Public Member Functions

virtual Message * | Clone () const
DataControlBootProgressMsg (INT provider_id, INT progress)
virtual const MsgMetaData & | GetMetaData () const
INT | GetProgress () const
INT | GetProviderId () const
void | SetProgress (INT progress)
void | SetProviderId (INT provider_id)
virtual | ~DataControlBootProgressMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DataControlBootProgressMsg::DataControlBootProgressMsg | ( | INT | provider_id,
 |  | INT | progress
 | ) |

DataControlBootProgressMsg::~DataControlBootProgressMsg ( ) [virtual]

Member Function Documentation

Message * DataControlBootProgressMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & DataControlBootProgressMsg::GetMetaData ( ) const [virtual]

Implements Message.

INT DataControlBootProgressMsg::GetProgress ( ) const [inline]

INT DataControlBootProgressMsg::GetProviderId ( ) const [inline]

void DataControlBootProgressMsg::SetProgress ( INT progress ) [inline]

void DataControlBootProgressMsg::SetProviderId ( INT provider_id ) [inline]

The documentation for this class was generated from the following files:
  • Adc/MsgTypes.hpp
  • Adc/MsgTypes.cpp
Generated on Wed Jan 25 01:09:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataControlEndBootMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataControlEndBootMsg Class Reference

#include <Apoxi/Adc/MsgTypes.hpp>

Inheritance diagram for DataControlEndBootMsg:

[legend]
Collaboration diagram for DataControlEndBootMsg:

[legend]

Public Types

enum | { ID = 19004 }

Public Member Functions

virtual Message * | Clone () const
DataControlEndBootMsg (const BootState &boot_state)
const BootState & | GetBootState () const
virtual const MsgMetaData & | GetMetaData () const
void | SetBootState (const BootState &boot_state)
virtual | ~DataControlEndBootMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DataControlEndBootMsg::DataControlEndBootMsg ( const BootState & boot_state )

DataControlEndBootMsg::~DataControlEndBootMsg ( ) [virtual]

Member Function Documentation

Message * DataControlEndBootMsg::Clone ( ) const [virtual]

Implements Message.

const BootState& DataControlEndBootMsg::GetBootState ( ) const [inline]

const MsgMetaData & DataControlEndBootMsg::GetMetaData ( ) const [virtual]

Implements Message.

void DataControlEndBootMsg::SetBootState ( const BootState & boot_state ) [inline]

The documentation for this class was generated from the following files:
  • Adc/MsgTypes.hpp
  • Adc/MsgTypes.cpp
Generated on Wed Jan 25 01:09:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataControlModificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataControlModificationMsg Class Reference

#include <Apoxi/Adc/MsgTypes.hpp>

Inheritance diagram for DataControlModificationMsg:

[legend]
Collaboration diagram for DataControlModificationMsg:

[legend]

Public Types

enum | { ID = 19000 }

Public Member Functions

virtual Message * | Clone () const
DataControlModificationMsg (const DataControlType &dataControlType, Application *application)
Application * | GetApplication () const
const DataControlType & | GetDataControlType () const
virtual const MsgMetaData & | GetMetaData () const
void | SetApplication (Application *application)
void | SetDataControlType (const DataControlType &dataControlType)
virtual | ~DataControlModificationMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DataControlModificationMsg::DataControlModificationMsg | ( | const DataControlType & | dataControlType,
 |  | Application * | application
 | ) |

DataControlModificationMsg::~DataControlModificationMsg ( ) [virtual]

Member Function Documentation

Message * DataControlModificationMsg::Clone ( ) const [virtual]

Implements Message.

Application* DataControlModificationMsg::GetApplication ( ) const [inline]

const DataControlType& DataControlModificationMsg::GetDataControlType ( ) const [inline]

const MsgMetaData & DataControlModificationMsg::GetMetaData ( ) const [virtual]

Implements Message.

void DataControlModificationMsg::SetApplication ( Application * application ) [inline]

void DataControlModificationMsg::SetDataControlType ( const DataControlType & dataControlType ) [inline]

The documentation for this class was generated from the following files:
  • Adc/MsgTypes.hpp
  • Adc/MsgTypes.cpp
Generated on Wed Jan 25 01:09:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataControlPhonebookStateMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataControlPhonebookStateMsg Class Reference

#include <Apoxi/Adc/MsgTypes.hpp>

Inheritance diagram for DataControlPhonebookStateMsg:

[legend]
Collaboration diagram for DataControlPhonebookStateMsg:

[legend]

Public Types

enum | { ID = 19005 }

Public Member Functions

virtual Message * | Clone () const
DataControlPhonebookStateMsg (BOOLEAN fdn_enabled, BOOLEAN bdn_enabled)
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsBdnEnabled () const
BOOLEAN | IsFdnEnabled () const
void | SetBdnEnabled (BOOLEAN bdn_enabled)
void | SetFdnEnabled (BOOLEAN fdn_enabled)
virtual | ~DataControlPhonebookStateMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DataControlPhonebookStateMsg::DataControlPhonebookStateMsg | ( | BOOLEAN | fdn_enabled,
 |  | BOOLEAN | bdn_enabled
 | ) |

DataControlPhonebookStateMsg::~DataControlPhonebookStateMsg ( ) [virtual]

Member Function Documentation

Message * DataControlPhonebookStateMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & DataControlPhonebookStateMsg::GetMetaData ( ) const [virtual]

Implements Message.

BOOLEAN DataControlPhonebookStateMsg::IsBdnEnabled ( ) const [inline]

BOOLEAN DataControlPhonebookStateMsg::IsFdnEnabled ( ) const [inline]

void DataControlPhonebookStateMsg::SetBdnEnabled ( BOOLEAN bdn_enabled ) [inline]

void DataControlPhonebookStateMsg::SetFdnEnabled ( BOOLEAN fdn_enabled ) [inline]

The documentation for this class was generated from the following files:
  • Adc/MsgTypes.hpp
  • Adc/MsgTypes.cpp
Generated on Wed Jan 25 01:09:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataControlStartBootMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataControlStartBootMsg Class Reference

#include <Apoxi/Adc/MsgTypes.hpp>

Inheritance diagram for DataControlStartBootMsg:

[legend]
Collaboration diagram for DataControlStartBootMsg:

[legend]

Public Types

enum | { ID = 19001 }

Public Member Functions

virtual Message * | Clone () const
DataControlStartBootMsg ()
virtual const MsgMetaData & | GetMetaData () const
virtual | ~DataControlStartBootMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DataControlStartBootMsg::DataControlStartBootMsg ( )

DataControlStartBootMsg::~DataControlStartBootMsg ( ) [virtual]

Member Function Documentation

Message * DataControlStartBootMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & DataControlStartBootMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Adc/MsgTypes.hpp
  • Adc/MsgTypes.cpp
Generated on Wed Jan 25 01:09:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataHandler Class Reference
[ADC]

#include <Apoxi/Adc/DataHandler.hpp>

Inheritance diagram for DataHandler:

[legend]
Collaboration diagram for DataHandler:

[legend]

Public Types

typedef MainProvider | Base

Public Member Functions

BOOLEAN | ActivateBdn ()
activates BDN mode, returns FALSE if not successfull
BOOLEAN | ActivateFdn ()
activates the FDN mode, returns FALSE if not successfull
BOOLEAN | ActivateSmsUsage ()
void | CancelAllSimRequests ()
BOOLEAN | ChangePreferredStorageMedia (Sms::StorageType storagetype)
changes the preferred storage media of smses during runtime
BOOLEAN | CheckSpnData (const Plmn &regplmn, BOOLEAN &showregplmn, BOOLEAN &showspnname, WString &spnname, BOOLEAN use_spn_display_condition=FALSE)
BOOLEAN | CheckSpnData (const BcdPlmn &regplmn, BOOLEAN &showregplmn, BOOLEAN &showspnname, WString &spnname, BOOLEAN use_spn_display_condition=FALSE)
DataHandler ()
BOOLEAN | DeactivateBdn ()
decativates BDN mode, returns FALSE if not successfull
BOOLEAN | DeactivateFdn ()
deactivates the FDN mode, returns FALSE if not successfull
BOOLEAN | DeselectUsimPb ()
void | EnableBuiltinEccCodes (BOOLEAN enable=TRUE)
OBSOLETE: enable the builtin ecc codes additionally to the ecc codes on sim.
void | EnablePidCheckForConcSms (BOOLEAN pidcheck=TRUE)
control the concatenation of csms: allow tpdus with different PIDs or not, APOXI default = NO checking
WString | GetActiveExtLanguage () const
BatteryLoadLevel GetBatteryLoadLevel ()
const CfuServiceArray & | GetCfuServiceArray () const
UINT8 | GetConcSmsPduMaxNo ()
returns the maximum number of supported pdus per concateneted SMS
DataAvailability | GetDataAvailability (INT columnid)
returns the DataAvailability of a certain ADC provider
EccCategory | GetEccCategory (const WString &checkstr)
EccCustomization * GetEccCustomization ()
Returns the pointer to the ecc customization object.
BOOLEAN | GetEmlppSetupCallCondition (EmlppPriorityLevel idx, BOOLEAN &condition)
BOOLEAN | GetEmlppSubscription (EmlppPriorityLevel idx, BOOLEAN &subscribed)
BOOLEAN | GetEonsPlmnName (const Plmn &checkplmn, UINT16 lac, WString &longname, WString &shortname)
BOOLEAN | GetEonsPlmnName (const BcdPlmn &checkplmn, UINT16 lac, WString &longname, WString &shortname)
GsmBand GetGsmBand ()
BcdPlmn | GetHomeBcdPlmn () const
Plmn | GetHomePlmn () const
void | GetIsLsaIdentifierPresent (BOOLEAN islsaidentifierpresent)
SimUpdateStatus GetLastSimUpdateStatus ()
returns the status value of the last change/delete/write access to the sim
void | GetLsaIdentifier (LsaIdentifier &lsaidentifier)
MainProvider * GetMainProvider ()
void | GetNetworkNameLong (WString &network_name_long)
void | GetNetworkNameShort (WString &network_name_short)
PowerMode GetPowerMode ()
Sms::StorageType | GetPreferredStorageMedia () const
virtual Provider * | GetProvider (INT columnid)
returns the pointer to the ADC provider defined by the provider id
RadioAccessTechnology GetRadioAccessTechnology ()
BcdPlmn | GetRegisteredBcdPlmn () const
UINT16 | GetRegisteredLac () const
Plmn | GetRegisteredPlmn () const
BOOLEAN | GetScanStatus ()
UsimPbLocation | GetSelectedUsimPb () const
SignalQualityLevel GetSignalQualityLevel ()
SignalStrengthLevel GetSignalStrengthLevel ()
SimAccessor * GetSimAccessor ()
SimChvHandler * GetSimChvHandler ()
allows accessing the SimChvhandler
SimCphsHandler * GetSimCphsHandler ()
BOOLEAN | GetSimIconDescription (INT recno, SimIconDescription &data)
returns an Simtoolkit SimIconDescription object defined by the ID.
BOOLEAN | GetSimImage (const SimImageDescriptor &imgdesc, SimImage &data)
returns an SimImage object defined by the SimImageDescriptor.
SimMexeCertificate * | GetSimMexeCertificate (UINT idx)
UINT | GetSimMexeCertificateCount () const
returns the number of loadable certificates
SimPduHandler * GetSimPduHandler ()
void | GetTimeZone (TimeZone &timezone)
BOOLEAN | GetUsimPbLocReport (UsimPbLocReport &report)
BOOLEAN | InitMexe ()
Initializes the Mexe subsystem: loads the descriptor files of the DF-Mexe subdirectory.
BOOLEAN | IsAdnReadWritableIfFdnActive () const
returns if ADN is accessible when FDN is activated
BOOLEAN | IsBdnActivated () const
returns if BDN mode is activated
BOOLEAN | IsBdnReadWritableIfBdnNotActive () const
returns if BDN is accessible when BDN is not activated
BOOLEAN | IsCingularNetworkSelectionMenuControlSupportEnabled (BOOLEAN &enabled)
BOOLEAN | IsCingularSimInserted ()
BOOLEAN | IsCspPlmnModeBitSet (BOOLEAN &isset)
BOOLEAN | IsEccCode (const WString &checkstr)
Checks if a certain String is contained in the EccProvider.
BOOLEAN | IsFdnActivated () const
returns if FDN mode is activated
BOOLEAN | IsGprsFdnActivationCodePresent ()
returns if the activation code is present in the FDN-phonebook
BOOLEAN | IsPartlyConcSmsStateChangeable ()
returns if partly concatented sms can be changed in their state
BOOLEAN | IsSimAccessAllowed ()
checks if Sim access is allowed, that means if CHV1 is verified or not needed
BOOLEAN | IsSimPresent ()
checks if Sim is present
BOOLEAN | IsSimRefreshPossible () const
BOOLEAN | IsSimResetPossible () const
BOOLEAN | IsSimServiceEnabled (SimServiceId id, BOOLEAN &enabled)
BOOLEAN | IsUsimInserted ()
checks if an Usim is inserted
BOOLEAN | LookupAlphaId (const PhoneNumber &phno, WString &alphaid, BOOLEAN uselookupalphaext=TRUE)
BOOLEAN | LookupPlmnName (const Plmn &plmn, WString &longname, WString &shortname, NetType &nettype, WString &countryname)
BOOLEAN | LookupPlmnName (const BcdPlmn &plmn, WString &longname, WString &shortname, NetType &nettype, WString &countryname)
BOOLEAN | MdhRequestCsmsRefNo (UINT16 &ref_no)
BOOLEAN | ModifyLock (const SecLockAction lockaction, const SecLockType locktype, const WString &oldpwd, const WString &newpwd)
executes an unlocking action
BOOLEAN | RefreshData (const SimRefreshIndArg &arg)
BOOLEAN | RefreshDataSimTk (const SimEfRefresh &refreshstruct)
BOOLEAN | RefreshSimMruProperty (const SimMruPropertyRefreshIndArg &arg)
void | ReloadNewMsgTpdu (Tpdu &tpdu, INT tpduno)
void | ReloadTpdu (INT recno)
void | Reset ()
BOOLEAN | SelectUsimPb (UsimPbLocation location)
void | SetActiveExtLanguage (const WString &language)
sets the currently used language to inform the Simtoolkit
void | SetBatteryLoadLevel (const BatteryLoadLevel level)
void | SetCellId (const CellId &cellid)
void | SetCfuServiceArray (const CfuServiceArray &servicearray)
void | SetConcSmsPduMaxNo (UINT8 no)
set the maximum number of supported pdus per concateneted SMS, customer specific
void | SetEccNetworkArray (const EccNetworkArray &eccarray)
void | SetGprsAttached (BOOLEAN gprs_attached)
void | SetGprsClass (const GprsClass gprs_class)
void | SetGprsClassChangeOrigin (const ProcessSource gprs_class_change_origin)
void | SetGsmBand (const GsmBand &band)
void | SetInitialPrefferedStorageMedia (Sms::StorageType storagetype)
sets the initial storage media of smses on startup
void | SetIsLsaIdentifierPresent (const BOOLEAN islsaidentifierpresent)
void | SetLai (const Lai &lai)
void | SetLastCcm (UINT32 last_ccm)
void | SetLastCcm2 (UINT32 last_ccm)
void | SetLsaIdentifier (const LsaIdentifier &lsaidentifier)
void | SetMaxConcRefNo (UINT16 refno)
void | SetMaxNoOfPduCache (UINT16 pdu_no_cache)
set the no of pdu which shall be cached internally in RAM, is not the no which can be processed
void | SetMdhWaitingIndicatorArray (const MdhWaitIndicatorArray &wia)
void | SetNetworkNameLong (const WString &network_name_long)
void | SetNetworkNameShort (const WString &network_name_short)
void | SetPartlyConcSmsStateChangeable (BOOLEAN changeable)
set if partly concateneted sms shall be changed in the their state
void | SetPowerMode (PowerMode power_mode)
void | SetRadioAccessTechnology (const RadioAccessTechnology &rat)
void | SetRatChangeMode (const RatChangeMode &rat_change_mode)
void | SetRegisteredPlmn (const Plmn &plmn)
void | SetRegisterMode (const RegisterMode mode)
void | SetRegisterRejectCause (const RegisterRejectCause rejectcause)
void | SetRegisterStatus (const RegisterStatus status)
void | SetScanStatus (BOOLEAN scan_status)
void | SetSecLockStates (const SecLockStates &lockstates)
void | SetSignalQualityLevel (const SignalQualityLevel signalquality)
void | SetSignalQualityMax (const SignalQualityMax signalquality)
void | SetSignalStrengthLevel (const SignalStrengthLevel signalstrength)
void | SetSignalStrengthMax (const SignalStrengthMax signalstrength)
void | SetSimAccess (const SimIndicator indicator)
void | SetSimErrorCode (const SimErrorCode errorcode)
void | SetSimInfo (const SimInfo &info)
void | SetSimInitInfo (const SimInitResult &info, const Imsi &imsi, UINT8 adnbyte, UINT8 bdnbyte)
void | SetSimLockStates (const SimLockStates &lockstates)
void | SetSimRefreshPossible (BOOLEAN refreshable)
sets the flag if the Simtoolkit is allowed to reset the Sim
void | SetSimResetPossible (BOOLEAN resetable)
sets the flag if the Simtoolkit is allowed to reset the Sim
void | SetSimTkMainMenu (const SetupMenuReqArg &arg)
void | SetSmsHeaderCacheParams (INT noofentries=30, INT noofchars=20)
set the no of header strings and there maximum size which shall be cached internally
void | SetTimeZone (const TimeZone &timezone)
BOOLEAN | Shutdown ()
BOOLEAN | Startup ()
BOOLEAN | StoreTpdu (const Tpdu &tpdu, const Sms::StorageType storage_type)
BOOLEAN | StoreTpdu (const Tpdu &tpdu)
BOOLEAN | UpdateLockInformation ()
BOOLEAN | WasSimChanged ()
checks if an new SIM was inserted after rebooting, only valid if a SIM is present
virtual | ~DataHandler ()

Friends

class | SimAccessor
class | SimPduHandler

Detailed Description

DataHandler is the class which represents the functionality of ADC.

Member Typedef Documentation

typedef MainProvider DataHandler::Base

Constructor & Destructor Documentation

DataHandler::DataHandler ( )

DataHandler::~DataHandler ( ) [virtual]

Member Function Documentation

BOOLEAN DataHandler::ActivateBdn ( )

activates BDN mode, returns FALSE if not successfull

BOOLEAN DataHandler::ActivateFdn ( )

activates the FDN mode, returns FALSE if not successfull

BOOLEAN DataHandler::ActivateSmsUsage ( )

void DataHandler::CancelAllSimRequests ( ) [inline]

BOOLEAN DataHandler::ChangePreferredStorageMedia ( Sms::StorageType storagetype )

changes the preferred storage media of smses during runtime

BOOLEAN DataHandler::CheckSpnData | ( | const Plmn & | regplmn,
 |  | BOOLEAN & | showregplmn,
 |  | BOOLEAN & | showspnname,
 |  | WString & | spnname,
 |  | BOOLEAN | use_spn_display_condition = FALSE
 | ) |

BOOLEAN DataHandler::CheckSpnData | ( | const BcdPlmn & | regplmn,
 |  | BOOLEAN & | showregplmn,
 |  | BOOLEAN & | showspnname,
 |  | WString & | spnname,
 |  | BOOLEAN | use_spn_display_condition = FALSE
 | ) |

Retrieves the service provider name and the display conditions dependend of the conditions set in the EF-SPN and EF_SPDI files. If EF_SPN file is not present a FALSE will be returned. The flag use_spn_display_condition controls the behaviour of the display condition byte of the SPN file in case of the SPDI file is present. If this parameter is set to TRUE the return values of showregplmn and showspnname are set like defined in 3GPP TS 51.011. If the parameter is set to FALSE (default) the showregplmn and showspnname are set like defined in 3GPP TS 21.101.

BOOLEAN DataHandler::DeactivateBdn ( )

decativates BDN mode, returns FALSE if not successfull

BOOLEAN DataHandler::DeactivateFdn ( )

deactivates the FDN mode, returns FALSE if not successfull

BOOLEAN DataHandler::DeselectUsimPb ( )

Deselects a certain phonebook which was been choosen by the MMI. The internal cache will be cleared and access to the phonebooks is prohibited.

void DataHandler::EnableBuiltinEccCodes ( BOOLEAN enable = TRUE ) [inline]

OBSOLETE: enable the builtin ecc codes additionally to the ecc codes on sim.

void DataHandler::EnablePidCheckForConcSms ( BOOLEAN pidcheck = TRUE ) [inline]

control the concatenation of csms: allow tpdus with different PIDs or not, APOXI default = NO checking

WString DataHandler::GetActiveExtLanguage ( ) const

BatteryLoadLevel DataHandler::GetBatteryLoadLevel ( ) [inline]

const CfuServiceArray & DataHandler::GetCfuServiceArray ( ) const

Returns the CFU array which is asynchrous set by the MN process on startup and when changing the call forwarding flags.

UINT8 DataHandler::GetConcSmsPduMaxNo ( ) [inline]

returns the maximum number of supported pdus per concateneted SMS

DataAvailability DataHandler::GetDataAvailability ( INT columnid )

returns the DataAvailability of a certain ADC provider

EccCategory DataHandler::GetEccCategory ( const WString & checkstr )

Returns the EccCategory for a certain ECC code. If there is no category available for the ECC or the checkstr is not a valid ECC an EccCategory object with value 0 will be returned.

EccCustomization * DataHandler::GetEccCustomization ( )

Returns the pointer to the ecc customization object.

BOOLEAN DataHandler::GetEmlppSetupCallCondition | ( | EmlppPriorityLevel | idx,
 |  | BOOLEAN & | condition
 | ) |

returns the fast setup call condition for a certain priority level. Return value: returns TRUE if the Emlpp file can be accessed

BOOLEAN DataHandler::GetEmlppSubscription | ( | EmlppPriorityLevel | idx,
 |  | BOOLEAN & | subscribed
 | ) |

checks if a certain priority level is subscribed, result is contained in 'subscribed' . Return value: returns TRUE if the Emlpp file can be accessed

BOOLEAN DataHandler::GetEonsPlmnName | ( | const Plmn & | checkplmn,
 |  | UINT16 | lac,
 |  | WString & | longname,
 |  | WString & | shortname
 | ) |

BOOLEAN DataHandler::GetEonsPlmnName | ( | const BcdPlmn & | checkplmn,
 |  | UINT16 | lac,
 |  | WString & | longname,
 |  | WString & | shortname
 | ) |

Retrieves the longname and/or shortname of a certain plmn / lac combination and make a lookup in the files EF-PNN and EF-OPL. If the plmn/lac does not fullfill the matching condition, or if the files are not present on SIM/USIM a FALSE will be returned.

GsmBand DataHandler::GetGsmBand ( ) [inline]

BcdPlmn DataHandler::GetHomeBcdPlmn ( ) const

Retrieves the Home Plmn which resides in the Imsi file. If the Imsi is not valid a InvalidPlmn/InvalidBcdPlmn will be returned.

Plmn DataHandler::GetHomePlmn ( ) const

void DataHandler::GetIsLsaIdentifierPresent ( BOOLEAN islsaidentifierpresent )

SimUpdateStatus DataHandler::GetLastSimUpdateStatus ( ) [inline]

returns the status value of the last change/delete/write access to the sim

void DataHandler::GetLsaIdentifier ( LsaIdentifier & lsaidentifier )

MainProvider* DataHandler::GetMainProvider ( ) [inline]

void DataHandler::GetNetworkNameLong ( WString & network_name_long )

void DataHandler::GetNetworkNameShort ( WString & network_name_short )

PowerMode DataHandler::GetPowerMode ( )

returns the current PowerMode

Sms::StorageType DataHandler::GetPreferredStorageMedia ( ) const

Provider * DataHandler::GetProvider ( INT columnid ) [virtual]

returns the pointer to the ADC provider defined by the provider id

Reimplemented from MainProvider.

RadioAccessTechnology DataHandler::GetRadioAccessTechnology ( ) [inline]

BcdPlmn DataHandler::GetRegisteredBcdPlmn ( ) const

UINT16 DataHandler::GetRegisteredLac ( ) const

Retrieves the LAC value which is temporaly stored in the StatusProvider.

Plmn DataHandler::GetRegisteredPlmn ( ) const

Retrieves the Registered Plmn which is temporaly stored in the StatusProvider.

BOOLEAN DataHandler::GetScanStatus ( )

UsimPbLocation DataHandler::GetSelectedUsimPb ( ) const

Returns the selected phonebook which is currently cached by APOXI

SignalQualityLevel DataHandler::GetSignalQualityLevel ( ) [inline]

SignalStrengthLevel DataHandler::GetSignalStrengthLevel ( ) [inline]

SimAccessor* DataHandler::GetSimAccessor ( ) [inline]

SimChvHandler* DataHandler::GetSimChvHandler ( ) [inline]

allows accessing the SimChvhandler

SimCphsHandler* DataHandler::GetSimCphsHandler ( ) [inline]

BOOLEAN DataHandler::GetSimIconDescription | ( | INT | recno,
 |  | SimIconDescription & | data
 | ) |

returns an Simtoolkit SimIconDescription object defined by the ID.

BOOLEAN DataHandler::GetSimImage | ( | const SimImageDescriptor & | imgdesc,
 |  | SimImage & | data
 | ) |

returns an SimImage object defined by the SimImageDescriptor.

SimMexeCertificate * DataHandler::GetSimMexeCertificate ( UINT idx )

returns a SimMexeCertificate object which contains the certificate payload. This call causes a request to the SIM/USIM, in case the certificate is not accessible a zero pointer will be returned

UINT DataHandler::GetSimMexeCertificateCount ( ) const

returns the number of loadable certificates

SimPduHandler* DataHandler::GetSimPduHandler ( ) [inline]

void DataHandler::GetTimeZone ( TimeZone & timezone )

BOOLEAN DataHandler::GetUsimPbLocReport ( UsimPbLocReport & report )

Returns a report object which contains information about which USIM phonebooks are present and can be selected, and the current selected USIM phonebook if there is one.

BOOLEAN DataHandler::InitMexe ( )

Initializes the Mexe subsystem: loads the descriptor files of the DF-Mexe subdirectory.

BOOLEAN DataHandler::IsAdnReadWritableIfFdnActive ( ) const [inline]

returns if ADN is accessible when FDN is activated

BOOLEAN DataHandler::IsBdnActivated ( ) const [inline]

returns if BDN mode is activated

BOOLEAN DataHandler::IsBdnReadWritableIfBdnNotActive ( ) const [inline]

returns if BDN is accessible when BDN is not activated

BOOLEAN DataHandler::IsCingularNetworkSelectionMenuControlSupportEnabled ( BOOLEAN & enabled )

Returns via enabled parameter if the Cingular Network Selection Menu Control Support flag set on the SIM. The return value itself indicates if the file is present or not

BOOLEAN DataHandler::IsCingularSimInserted ( )

Returns if a Cingular SIM is inserted, this is done by checking if the EF-TST file is present

BOOLEAN DataHandler::IsCspPlmnModeBitSet ( BOOLEAN & isset )

Returns via isset parameter if the Plmn mode bit is set inside the CPHS CSP file. The return value itself indicates if the file is present or not.

BOOLEAN DataHandler::IsEccCode ( const WString & checkstr )

Checks if a certain String is contained in the EccProvider.

BOOLEAN DataHandler::IsFdnActivated ( ) const [inline]

returns if FDN mode is activated

BOOLEAN DataHandler::IsGprsFdnActivationCodePresent ( )

returns if the activation code is present in the FDN-phonebook

BOOLEAN DataHandler::IsPartlyConcSmsStateChangeable ( ) [inline]

returns if partly concatented sms can be changed in their state

BOOLEAN DataHandler::IsSimAccessAllowed ( )

checks if Sim access is allowed, that means if CHV1 is verified or not needed

BOOLEAN DataHandler::IsSimPresent ( )

checks if Sim is present

BOOLEAN DataHandler::IsSimRefreshPossible ( ) const

BOOLEAN DataHandler::IsSimResetPossible ( ) const

BOOLEAN DataHandler::IsSimServiceEnabled | ( | SimServiceId | id,
 |  | BOOLEAN & | enabled
 | ) |

Returns via enabled parameter if a certain service inside SIM or USIM is enabled. In case a SIM is inserted the file EF-SST will be used, in case a USIM is inserted the EF-UST file will be used. The return value itself indicates if access to the files is possible. The enumeration type SimServiceId is defined in the SstProvider.hpp file.

BOOLEAN DataHandler::IsUsimInserted ( )

checks if an Usim is inserted

BOOLEAN DataHandler::LookupAlphaId | ( | const PhoneNumber & | phno,
 |  | WString & | alphaid,
 |  | BOOLEAN | uselookupalphaext = TRUE
 | ) |

returns the alphaid related to a given phonenumber if the phonebooks are already loaded. uselookupalphaext parameter, tells if a possible existing LookupAlphaIdExtension shall be used or not. Return value: returns TRUE if a valid alphaid was found

BOOLEAN DataHandler::LookupPlmnName | ( | const Plmn & | plmn,
 |  | WString & | longname,
 |  | WString & | shortname,
 |  | NetType & | nettype,
 |  | WString & | countryname
 | ) |

BOOLEAN DataHandler::LookupPlmnName | ( | const BcdPlmn & | plmn,
 |  | WString & | longname,
 |  | WString & | shortname,
 |  | NetType & | nettype,
 |  | WString & | countryname
 | ) |

Retrieves the short-, longname, network type and countryname of a certain plmn of the internal plmn-table inside stack. If the plmn cannot be found a FALSE will be returned.

BOOLEAN DataHandler::MdhRequestCsmsRefNo ( UINT16 & ref_no )

requests the reference number for concatenated sms; return TRUE on success

BOOLEAN DataHandler::ModifyLock | ( | const SecLockAction | lockaction,
 |  | const SecLockType | locktype,
 |  | const WString & | oldpwd,
 |  | const WString & | newpwd
 | ) |

executes an unlocking action

BOOLEAN DataHandler::RefreshData ( const SimRefreshIndArg & arg )

BOOLEAN DataHandler::RefreshDataSimTk ( const SimEfRefresh & refreshstruct )

BOOLEAN DataHandler::RefreshSimMruProperty ( const SimMruPropertyRefreshIndArg & arg )

void DataHandler::ReloadNewMsgTpdu | ( | Tpdu & | tpdu,
 |  | INT | tpduno
 | ) |

void DataHandler::ReloadTpdu ( INT recno )

void DataHandler::Reset ( )

BOOLEAN DataHandler::SelectUsimPb ( UsimPbLocation location )

Selects a certain phonebook which have been choosen by the MMI. Which phonebooks are available can be detected by GetUsimPbLocReport.

void DataHandler::SetActiveExtLanguage ( const WString & language )

sets the currently used language to inform the Simtoolkit

void DataHandler::SetBatteryLoadLevel ( const BatteryLoadLevel level )

void DataHandler::SetCellId ( const CellId & cellid )

void DataHandler::SetCfuServiceArray ( const CfuServiceArray & servicearray )

void DataHandler::SetConcSmsPduMaxNo ( UINT8 no ) [inline]

set the maximum number of supported pdus per concateneted SMS, customer specific

void DataHandler::SetEccNetworkArray ( const EccNetworkArray & eccarray )

void DataHandler::SetGprsAttached ( BOOLEAN gprs_attached )

void DataHandler::SetGprsClass ( const GprsClass gprs_class ) [inline]

void DataHandler::SetGprsClassChangeOrigin ( const ProcessSource gprs_class_change_origin ) [inline]

void DataHandler::SetGsmBand ( const GsmBand & band ) [inline]

void DataHandler::SetInitialPrefferedStorageMedia ( Sms::StorageType storagetype )

sets the initial storage media of smses on startup

void DataHandler::SetIsLsaIdentifierPresent ( const BOOLEAN islsaidentifierpresent )

void DataHandler::SetLai ( const Lai & lai )

void DataHandler::SetLastCcm ( UINT32 last_ccm )

void DataHandler::SetLastCcm2 ( UINT32 last_ccm )

void DataHandler::SetLsaIdentifier ( const LsaIdentifier & lsaidentifier )

void DataHandler::SetMaxConcRefNo ( UINT16 refno )

void DataHandler::SetMaxNoOfPduCache ( UINT16 pdu_no_cache ) [inline]

set the no of pdu which shall be cached internally in RAM, is not the no which can be processed

void DataHandler::SetMdhWaitingIndicatorArray ( const MdhWaitIndicatorArray & wia )

void DataHandler::SetNetworkNameLong ( const WString & network_name_long )

void DataHandler::SetNetworkNameShort ( const WString & network_name_short )

void DataHandler::SetPartlyConcSmsStateChangeable ( BOOLEAN changeable ) [inline]

set if partly concateneted sms shall be changed in the their state

void DataHandler::SetPowerMode ( PowerMode power_mode ) [inline]

void DataHandler::SetRadioAccessTechnology ( const RadioAccessTechnology & rat ) [inline]

void DataHandler::SetRatChangeMode ( const RatChangeMode & rat_change_mode ) [inline]

void DataHandler::SetRegisteredPlmn ( const Plmn & plmn )

void DataHandler::SetRegisterMode ( const RegisterMode mode )

void DataHandler::SetRegisterRejectCause ( const RegisterRejectCause rejectcause )

void DataHandler::SetRegisterStatus ( const RegisterStatus status )

void DataHandler::SetScanStatus ( BOOLEAN scan_status )

void DataHandler::SetSecLockStates ( const SecLockStates & lockstates )

void DataHandler::SetSignalQualityLevel ( const SignalQualityLevel signalquality )

void DataHandler::SetSignalQualityMax ( const SignalQualityMax signalquality )

void DataHandler::SetSignalStrengthLevel ( const SignalStrengthLevel signalstrength )

void DataHandler::SetSignalStrengthMax ( const SignalStrengthMax signalstrength )

void DataHandler::SetSimAccess ( const SimIndicator indicator )

void DataHandler::SetSimErrorCode ( const SimErrorCode errorcode )

void DataHandler::SetSimInfo ( const SimInfo & info )

void DataHandler::SetSimInitInfo | ( | const SimInitResult & | info,
 |  | const Imsi & | imsi,
 |  | UINT8 | adnbyte,
 |  | UINT8 | bdnbyte
 | ) |

void DataHandler::SetSimLockStates ( const SimLockStates & lockstates )

void DataHandler::SetSimRefreshPossible ( BOOLEAN refreshable )

sets the flag if the Simtoolkit is allowed to reset the Sim

void DataHandler::SetSimResetPossible ( BOOLEAN resetable )

sets the flag if the Simtoolkit is allowed to reset the Sim

void DataHandler::SetSimTkMainMenu ( const SetupMenuReqArg & arg )

void DataHandler::SetSmsHeaderCacheParams | ( | INT | noofentries = 30,
 |  | INT | noofchars = 20
 | ) | [inline]

set the no of header strings and there maximum size which shall be cached internally

void DataHandler::SetTimeZone ( const TimeZone & timezone )

BOOLEAN DataHandler::Shutdown ( )

BOOLEAN DataHandler::Startup ( )

BOOLEAN DataHandler::StoreTpdu | ( | const Tpdu & | tpdu,
 |  | const Sms::StorageType | storage_type
 | ) |

BOOLEAN DataHandler::StoreTpdu ( const Tpdu & tpdu )

BOOLEAN DataHandler::UpdateLockInformation ( )

BOOLEAN DataHandler::WasSimChanged ( )

checks if an new SIM was inserted after rebooting, only valid if a SIM is present

Friends And Related Function Documentation

friend class SimAccessor [friend]

friend class SimPduHandler [friend]

The documentation for this class was generated from the following files:
  • Adc/DataHandler.hpp
  • Adc/DataHandler.cpp
Generated on Wed Jan 25 01:10:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataItem Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/DataItem.hpp>

Collaboration diagram for DataItem:

[legend]

Public Member Functions

DataItem (const DataItem &data_item)
copy constructor of the DataItem class.
DataItem (const GenericObject *const object)
generates a DataItem of type GenericObject.
DataItem (const DateTime::Persist &datetime)
generates a DataItem of type DateTime.
DataItem (const DateTime &datetime)
generates a DataItem of type DateTime.
DataItem (const Time &time)
generates a DataItem of type Time.
DataItem (const Date &date)
generates a DataItem of type Date.
DataItem (const PhoneNumber &PhoneNumber)
generates a DataItem of type PhoneNumber.
DataItem (const WString &wstringdata)
generates a DataItem of type WString.
DataItem (const String &stringdata)
generates a DataItem of type String.
DataItem (Number val)
generates a DataItem of type Number.
DataItem (DataType type)
generates a DataItem of type type.
DataItem ()
generates an undefined DataItem.
BOOLEAN | GetBoolean () const
returns the a boolean value of the DataItem object.
DataType | GetDataType () const
determines the type of the DataItem object.
BOOLEAN | GetDate (Date &date) const
returns the date of the DataItem object.
Date | GetDate () const
returns the date of the DataItem object.
BOOLEAN | GetDateTime (DateTime &date) const
returns the date and time of the DataItem object.
DateTime | GetDateTime () const
returns the date and time of the DataItem object.
GenericObject * | GetGenericObject () const
returns a copy of the generic object inside the DataItem.
const GenericObject * | GetGenericObjectPtr () const
returns the pointer of the generic object inside the DataItem.
Number | GetNumber () const
returns the a numeric value of the DataItem object.
BOOLEAN | GetPhoneNumber (PhoneNumber &bcdnr) const
returns the phonenumber of the DataItem object.
PhoneNumber | GetPhoneNumber () const
returns the phonenumber of the DataItem object.
Provider * | GetProvider () const
returns the pointer to a provider of the DataItem object.
BOOLEAN | GetString (String &strdata) const
returns the string of the DataItem object.
String | GetString () const
returns the string of the DataItem object.
BOOLEAN | GetTime (Time &time) const
returns the time of the DataItem object.
Time | GetTime () const
returns the time of the DataItem object.
BOOLEAN | GetWString (WString &strdata) const
returns the unicode string of the DataItem object.
WString | GetWString () const
returns the unicode string of the DataItem object.
BOOLEAN | IsEqual (const DataItem &item) const
Checks whether the object and the item object are identical.
BOOLEAN | IsGreater (const DataItem &item) const
Checks whether the object is larger than the item object.
BOOLEAN | IsGreaterEqual (const DataItem &item) const
Checks whether the object is larger or equal than the item object.
BOOLEAN | IsInRange (const DataItem &item1, const DataItem &item2) const
Checks whether the object is in the range between item1 and item2.
BOOLEAN | IsLess (const DataItem &item) const
Checks whether the object is smaller than the item object.
BOOLEAN | IsLessEqual (const DataItem &item) const
Checks whether the object is smaller or equal than the item object.
BOOLEAN | IsNotEqual (const DataItem &item) const
Checks whether the object and the item object are not identical.
BOOLEAN | operator!= (DataItem &item) const
Checks whether the object and the item object are not identical.
BOOLEAN | operator< (DataItem &item) const
Checks whether the object is smaller than the item object.
BOOLEAN | operator<= (DataItem &item) const
Checks whether the object is smaller or equal than the item object.
DataItem & | operator= (const DataItem &item)
Assigns the item object to the object.
BOOLEAN | operator== (DataItem &item) const
Checks whether the object and the item object are identical.
BOOLEAN | operator> (DataItem &item) const
Checks whether the object is larger than the item object.
BOOLEAN | operator>= (DataItem &item) const
Checks whether the object is in the range between item1 and item2.
void | SetBoolean (const BOOLEAN data)
set the object with a Boolean value
void | SetDataType (DataType type)
sets the type of the DataItem object.
void | SetDate (const Date &date)
fills the object with a date object
void | SetDateTime (const DateTime::Persist &date)
fills the object with a datetime object
void | SetDateTime (const DateTime &date)
fills the object with a datetime object
void | SetGenericObject (const GenericObject *const genobject)
fills the object with a generic object
void | SetNumber (const Number data)
set the object with a numeric value
void | SetPhoneNumber (const PhoneNumber &bcdnr)
fills the object with a phonenumber object
void | SetProvider (Provider *provider)
set the object with a pointer to a provider
void | SetString (const CHAR *strdata)
fills the object with a string
void | SetString (const String &strdata)
fills the object with a string
void | SetTime (const Time &time)
fills the object with a time object
void | SetWString (const WCHAR *strdata)
fills the object with a unicode string
void | SetWString (const WString &strdata)
fills the object with a unicode string
~DataItem ()
destroys the object and also the containing object.

Protected Attributes

DataType m_type

Detailed Description

DataItem is used to represent data of a provider. Provider, Number, String, WString, PhoneNumber, Date, Time, DateTime and GenericObject classes are supported. DataItem always contains an object of one of these types but can be reused when storing new data inside the object. NOTE: Do not subclass.

Constructor & Destructor Documentation

DataItem::DataItem ( )

generates an undefined DataItem.

DataItem::DataItem ( DataType type )

generates a DataItem of type type.

DataItem::DataItem ( Number val )

generates a DataItem of type Number.

DataItem::DataItem ( const String & stringdata )

generates a DataItem of type String.

DataItem::DataItem ( const WString & wstringdata )

generates a DataItem of type WString.

DataItem::DataItem ( const PhoneNumber & PhoneNumber )

generates a DataItem of type PhoneNumber.

DataItem::DataItem ( const Date & date )

generates a DataItem of type Date.

DataItem::DataItem ( const Time & time )

generates a DataItem of type Time.

DataItem::DataItem ( const DateTime & datetime )

generates a DataItem of type DateTime.

DataItem::DataItem ( const DateTime::Persist & datetime )

generates a DataItem of type DateTime.

DataItem::DataItem ( const GenericObject *const object )

generates a DataItem of type GenericObject.

DataItem::DataItem ( const DataItem & data_item )

copy constructor of the DataItem class.

DataItem::~DataItem ( )

destroys the object and also the containing object.

Member Function Documentation

BOOLEAN DataItem::GetBoolean ( ) const

returns the a boolean value of the DataItem object.

DataType DataItem::GetDataType ( ) const [inline]

determines the type of the DataItem object.

BOOLEAN DataItem::GetDate ( Date & date ) const

returns the date of the DataItem object.

Date DataItem::GetDate ( ) const

returns the date of the DataItem object.

BOOLEAN DataItem::GetDateTime ( DateTime & date ) const

returns the date and time of the DataItem object.

DateTime DataItem::GetDateTime ( ) const

returns the date and time of the DataItem object.

GenericObject * DataItem::GetGenericObject ( ) const

returns a copy of the generic object inside the DataItem.

const GenericObject * DataItem::GetGenericObjectPtr ( ) const

returns the pointer of the generic object inside the DataItem.

Number DataItem::GetNumber ( ) const

returns the a numeric value of the DataItem object.

BOOLEAN DataItem::GetPhoneNumber ( PhoneNumber & bcdnr ) const

returns the phonenumber of the DataItem object.

PhoneNumber DataItem::GetPhoneNumber ( ) const

returns the phonenumber of the DataItem object.

Provider * DataItem::GetProvider ( ) const

returns the pointer to a provider of the DataItem object.

BOOLEAN DataItem::GetString ( String & strdata ) const

returns the string of the DataItem object.

String DataItem::GetString ( ) const

returns the string of the DataItem object.

BOOLEAN DataItem::GetTime ( Time & time ) const

returns the time of the DataItem object.

Time DataItem::GetTime ( ) const

returns the time of the DataItem object.

BOOLEAN DataItem::GetWString ( WString & strdata ) const

returns the unicode string of the DataItem object.

WString DataItem::GetWString ( ) const

returns the unicode string of the DataItem object.

BOOLEAN DataItem::IsEqual ( const DataItem & item ) const

Checks whether the object and the item object are identical.

BOOLEAN DataItem::IsGreater ( const DataItem & item ) const

Checks whether the object is larger than the item object.

BOOLEAN DataItem::IsGreaterEqual ( const DataItem & item ) const [inline]

Checks whether the object is larger or equal than the item object.

BOOLEAN DataItem::IsInRange | ( | const DataItem & | item1,
 |  | const DataItem & | item2
 | ) | const

Checks whether the object is in the range between item1 and item2.

BOOLEAN DataItem::IsLess ( const DataItem & item ) const

Checks whether the object is smaller than the item object.

BOOLEAN DataItem::IsLessEqual ( const DataItem & item ) const [inline]

Checks whether the object is smaller or equal than the item object.

BOOLEAN DataItem::IsNotEqual ( const DataItem & item ) const [inline]

Checks whether the object and the item object are not identical.

BOOLEAN DataItem::operator!= ( DataItem & item ) const [inline]

Checks whether the object and the item object are not identical.

BOOLEAN DataItem::operator< ( DataItem & item ) const [inline]

Checks whether the object is smaller than the item object.

BOOLEAN DataItem::operator<= ( DataItem & item ) const [inline]

Checks whether the object is smaller or equal than the item object.

DataItem & DataItem::operator= ( const DataItem & item )

Assigns the item object to the object.

BOOLEAN DataItem::operator== ( DataItem & item ) const [inline]

Checks whether the object and the item object are identical.

BOOLEAN DataItem::operator> ( DataItem & item ) const [inline]

Checks whether the object is larger than the item object.

BOOLEAN DataItem::operator>= ( DataItem & item ) const [inline]

Checks whether the object is in the range between item1 and item2.

void DataItem::SetBoolean ( const BOOLEAN data )

set the object with a Boolean value

void DataItem::SetDataType ( DataType type )

sets the type of the DataItem object.

void DataItem::SetDate ( const Date & date )

fills the object with a date object

void DataItem::SetDateTime ( const DateTime::Persist & date )

fills the object with a datetime object

void DataItem::SetDateTime ( const DateTime & date )

fills the object with a datetime object

void DataItem::SetGenericObject ( const GenericObject *const genobject )

fills the object with a generic object

void DataItem::SetNumber ( const Number data )

set the object with a numeric value

void DataItem::SetPhoneNumber ( const PhoneNumber & bcdnr )

fills the object with a phonenumber object

void DataItem::SetProvider ( Provider * provider )

set the object with a pointer to a provider

void DataItem::SetString ( const CHAR * strdata )

fills the object with a string

void DataItem::SetString ( const String & strdata )

fills the object with a string

void DataItem::SetTime ( const Time & time )

fills the object with a time object

void DataItem::SetWString ( const WCHAR * strdata )

fills the object with a unicode string

void DataItem::SetWString ( const WString & strdata )

fills the object with a unicode string

Field Documentation

DataType DataItem::m_type [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/DataItem.hpp
  • Auxiliary/DataItem.cpp
Generated on Wed Jan 25 01:10:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataPack Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataPack Class Reference

#include <Apoxi/Gui/DataPack.hpp>

Inheritance diagram for DataPack:

[legend]
Collaboration diagram for DataPack:

[legend]

Public Member Functions

DataPack (const UINT8 *data)
DataPackId | GetId () const
UINT16 | GetNumberOfEntries () const
UINT32 | GetSize () const
virtual | ~DataPack ()

Protected Attributes

const DataPackHeaderData * | m_data
Pointer that holds meta data for the data pack like id, size or number of entries.

Friends

class | BasicPackConnector

Detailed Description

An object of DataPack encapsulates the common data of each DataPack. This data contains the size, an id and the number of entries a data pack has.

Constructor & Destructor Documentation

DataPack::DataPack ( const UINT8 * data )

Constructs a DataPack and initializes the data member of the data pack with the parameter data.

Parameters:
data Pointer to the data for the data pack in the customization pack.

DataPack::~DataPack ( ) [virtual]

Destructor for DataPack.

Member Function Documentation

DataPackId DataPack::GetId ( ) const

Returns the id of the data pack.

Returns:
Id of the data pack.

UINT16 DataPack::GetNumberOfEntries ( ) const

Returns the number of entries a data pack contains.

Returns:
Number of entries, a data pack contains.

UINT32 DataPack::GetSize ( ) const

Returns the size of the data pack.

Returns:
Size of the data pack in UINT8s.

Friends And Related Function Documentation

friend class BasicPackConnector [friend]

Reimplemented in FontPack, and TextPack.

Field Documentation

const DataPackHeaderData* DataPack::m_data [protected]

Pointer that holds meta data for the data pack like id, size or number of entries.

The documentation for this class was generated from the following files:
  • Gui/DataPack.hpp
  • Gui/DataPack.cpp
Generated on Wed Jan 25 01:10:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataRateTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataRateTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for DataRateTable:

[legend]
Collaboration diagram for DataRateTable:

[legend]

Static Public Member Functions

static const WCHAR * | GetDataRate (CsdDataConnProfile::DataRate data_rate)
static CsdDataConnProfile::DataRate | GetDataRateType (INT idx)
static const UINT | GetSize ()

Member Function Documentation

static const WCHAR* DataRateTable::GetDataRate ( CsdDataConnProfile::DataRate data_rate ) [inline, static]

static CsdDataConnProfile::DataRate DataRateTable::GetDataRateType ( INT idx ) [inline, static]

static const UINT DataRateTable::GetSize ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:10:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataRecord Class Reference

#include <Apoxi/AddOns/AdcExtensions/DataRecord.hpp>

Public Member Functions

DataRecord (DataRecordId id, BOOLEAN deleted=FALSE)
DataRecordId | GetId () const

Friends

class | DataRecordHandler

Constructor & Destructor Documentation

DataRecord::DataRecord | ( | DataRecordId | id,
 |  | BOOLEAN | deleted = FALSE
 | ) |

Member Function Documentation

DataRecordId DataRecord::GetId ( ) const [inline]

Friends And Related Function Documentation

friend class DataRecordHandler [friend]

The documentation for this class was generated from the following files:
  • AddOns/AdcExtensions/DataRecord.hpp
  • AddOns/AdcExtensions/DataRecord.cpp
Generated on Wed Jan 25 01:10:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataRecordHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataRecordHandler Class Reference

#include <Apoxi/AddOns/AdcExtensions/DataRecordHandler.hpp>

Inheritance diagram for DataRecordHandler:

[legend]

Public Member Functions

virtual BOOLEAN | AddRecord (const DataRecord *rec)=0
DataRecordHandler (INT record_length)
Constructor.
virtual BOOLEAN | DeleteRecord (INT row)=0
virtual BOOLEAN | LoadRecord (INT row, DataRecord *rec)=0
virtual BOOLEAN | StoreRecord (INT row, const DataRecord *rec)=0

Protected Member Functions

BOOLEAN | IsRecordDeleted (const DataRecord &rec) const
void | MarkRecordDeleted (DataRecord &rec)

Protected Attributes

INT | m_record_length

Detailed Description

A DataRecordHandler can be used to load and store record based data onto a non volatile medium. Storage is organized by rows.
See also:
DataRecord

Constructor & Destructor Documentation

DataRecordHandler::DataRecordHandler ( INT record_length )

Constructor.

Parameters:
record_length,: size of record to be stored.

Member Function Documentation

virtual BOOLEAN DataRecordHandler::AddRecord ( const DataRecord * rec ) [pure virtual]

AddRecord is used to add a DataRecord.

Parameters:
*rec,: pointer to the DataRecord to be added.
Returns:
TRUE if record is successfully added, FALSE otherwise.

Implemented in NvRamDataRecordHandler.

virtual BOOLEAN DataRecordHandler::DeleteRecord ( INT row ) [pure virtual]

DeleteRecord is used to delete a DataRecord on a specific row.

Parameters:
row,: row which to be deleted.
Returns:
TRUE if record is successfully deleted, FALSE otherwise.

Implemented in NvRamDataRecordHandler.

BOOLEAN DataRecordHandler::IsRecordDeleted ( const DataRecord & rec ) const [protected]

virtual BOOLEAN DataRecordHandler::LoadRecord | ( | INT | row,
 |  | DataRecord * | rec
 | ) | [pure virtual]

LoadRecord is used to load a DataRecord from a specific row.

Parameters:
row,: row from which to load.
*rec,: pointer to the DataRecord (buffer) where the loaded record is stored.
Returns:
TRUE if record is successfully loaded, FALSE otherwise.

Implemented in NvRamDataRecordHandler.

void DataRecordHandler::MarkRecordDeleted ( DataRecord & rec ) [protected]

virtual BOOLEAN DataRecordHandler::StoreRecord | ( | INT | row,
 |  | const DataRecord * | rec
 | ) | [pure virtual]

StoreRecord is used to store a DataRecord into a specific row. The row has to be already filled with a record. Use AddRecord if this is not the case.

Parameters:
row,: row in which to store
*rec,: pointer to the DataRecord to be stored.
Returns:
TRUE if record is successfully stored, FALSE otherwise.

Implemented in NvRamDataRecordHandler.

Field Documentation

INT DataRecordHandler::m_record_length [protected]

The documentation for this class was generated from the following files:
  • AddOns/AdcExtensions/DataRecordHandler.hpp
  • AddOns/AdcExtensions/DataRecordHandler.cpp
Generated on Wed Jan 25 01:10:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataSink Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataSink Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/DataSink.hpp>

Inheritance diagram for DataSink:

[legend]
Collaboration diagram for DataSink:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()=0
const DrmAsset & | GetDrmAsset () const
virtual BOOLEAN | GetSize (UINT32 &size) const =0
virtual BOOLEAN | IsOpen () const =0
virtual BOOLEAN | Open ()=0
virtual UINT32 | Write (UINT32 offset, const void HUGE *buf, UINT32 nbytes)=0
virtual UINT32 | Write (const void HUGE *buf, UINT32 nbytes)=0
virtual | ~DataSink ()

Protected Member Functions

DataSink (DrmLocalId id)

Protected Attributes

const DrmAsset | m_drm_asset

Detailed Description

Class DataSink is the abstraction of any kind of data sink where you can write to.

Constructor & Destructor Documentation

DataSink::~DataSink ( ) [virtual]

Destructs this instance.

DataSink::DataSink ( DrmLocalId id ) [protected]

Member Function Documentation

virtual BOOLEAN DataSink::Close ( ) [pure virtual]

Closes the data sink. After closing the data sink it can not be written any more.

Returns:
Success of operation.

Implemented in FileDataSink, HeapDataSink, and StringDataSink.

const DrmAsset& DataSink::GetDrmAsset ( ) const [inline]

Returns the DRM asset to process and validate DRM constraints and permissions.

Returns:
A reference to the DRM asset of this data sink.

virtual BOOLEAN DataSink::GetSize ( UINT32 & size ) const [pure virtual]

Returns the size of the data sink in terms of bytes. The size of the data sink is actually defined by the amount of data written at the end of the data sink.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implemented in FileDataSink, HeapDataSink, and StringDataSink.

virtual BOOLEAN DataSink::IsOpen ( ) const [pure virtual]

Returns whether the data sink is currently open or closed.

Returns:
Whether the data sink is open or not.

Implemented in FileDataSink, HeapDataSink, and StringDataSink.

virtual BOOLEAN DataSink::Open ( ) [pure virtual]

Opens the data sink for writing. The size of a freshly opened data sink is 0. A data sink can only be written if it has been opened before.

Returns:
Success of operation.

Implemented in FileDataSink, HeapDataSink, and StringDataSink.

virtual UINT32 DataSink::Write | ( | UINT32 | offset,
 |  | const void HUGE * | buf,
 |  | UINT32 | nbytes
 | ) | [pure virtual]

Writes nbytes bytes of buffer buf to the data sink at the given offset. Note, that this method is only allowed to be used to overwrite existing data. Hence, if the given offset plus the number of bytes to write nbytes is larger than the current size of the data sink then an assertion fails. Overriding methods must implement this assertion. Since this method only overrides existing data it does not affect the size of the data sink.

Parameters:
offset | The offset where to start writing.
buf | The buffer to be written.
nbytes | The number of bytes to be written.
Returns:
Number of bytes actually written.

Implemented in FileDataSink, HeapDataSink, and StringDataSink.

virtual UINT32 DataSink::Write | ( | const void HUGE * | buf,
 |  | UINT32 | nbytes
 | ) | [pure virtual]

Writes nbytes bytes of buffer buf to the data sink. The data is written at the end of the data sink and hence increases the size of the data sink by the amount of bytes written.

Parameters:
buf | The buffer to be written.
nbytes | The number of bytes to be written.
Returns:
Number of bytes actually written.

Implemented in FileDataSink, HeapDataSink, and StringDataSink.

Field Documentation

const DrmAsset DataSink::m_drm_asset [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/DataSink.hpp
  • Auxiliary/DataSink.cpp
Generated on Wed Jan 25 01:10:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataSource Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataSource Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/DataSource.hpp>

Inheritance diagram for DataSource:

[legend]
Collaboration diagram for DataSource:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()=0
const DrmAsset & | GetDrmAsset () const
virtual BOOLEAN | GetSize (UINT32 &size) const =0
virtual BOOLEAN | IsOpen () const =0
virtual BOOLEAN | Open ()=0
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)=0
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 count)=0
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)=0
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 count)=0
virtual | ~DataSource ()

Protected Member Functions

DataSource (DrmLocalId id)

Protected Attributes

const DrmAsset | m_drm_asset

Detailed Description

Class DataSource is the abstraction of any kind of data source where you can read from.

Constructor & Destructor Documentation

DataSource::~DataSource ( ) [virtual]

Destructs this instance.

DataSource::DataSource ( DrmLocalId id ) [protected]

Member Function Documentation

virtual BOOLEAN DataSource::Close ( ) [pure virtual]

Closes the data source. After closing the data source it can not be read any more.

Returns:
Success of operation.

Implemented in FileDataSource, BinDataDataSource, HeapDataSource, and NonsharedBinDataDataSource.

const DrmAsset& DataSource::GetDrmAsset ( ) const [inline]

Returns the DRM asset to process and validate DRM constraints and permissions.

Returns:
A reference to the DRM asset of this data source.

virtual BOOLEAN DataSource::GetSize ( UINT32 & size ) const [pure virtual]

Returns the size of the data source in terms of bytes.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implemented in FileDataSource, BinDataDataSource, HeapDataSource, and NonsharedBinDataDataSource.

virtual BOOLEAN DataSource::IsOpen ( ) const [pure virtual]

Returns whether the data source is currently open or closed.

Returns:
Whether the data source is open or not.

Implemented in FileDataSource, BinDataDataSource, HeapDataSource, and NonsharedBinDataDataSource.

virtual BOOLEAN DataSource::Open ( ) [pure virtual]

Opens the data source for reading. Opening sets the current read position to the beginning of the data source. The read methods that do not use an offset argument always start to read at the current read position. A data source can only be read if it has been opened before.

Returns:
Success of operation.

Implemented in FileDataSource, BinDataDataSource, HeapDataSource, and NonsharedBinDataDataSource.

virtual BOOLEAN DataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [pure virtual]

Reads up to max_count bytes from this data source starting at offset and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. parameter offset is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! Note that this method does not affect the current read position. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadRandomDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 offset = 0;
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(offset, buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...

                    // Increase offset where to read next.
                    offset += bytes_read;
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implemented in FileDataSource, BinDataDataSource, HeapDataSource, and NonsharedBinDataDataSource.

virtual BOOLEAN DataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [pure virtual]

Reads exactly count bytes from this data source starting at offset and copies them to the provided buffer. Note that this method does not affect the current read position.

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implemented in FileDataSource, BinDataDataSource, HeapDataSource, and NonsharedBinDataDataSource.

virtual BOOLEAN DataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [pure virtual]

Reads up to max_count bytes from this data source starting at the current read position and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. the current read position is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! The current read position is updated. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadSequentialDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implemented in FileDataSource, BinDataDataSource, HeapDataSource, and NonsharedBinDataDataSource.

virtual BOOLEAN DataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [pure virtual]

Reads exactly count bytes from this data source starting at the current read position and copies them to the provided buffer. The current read position is updated.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implemented in FileDataSource, BinDataDataSource, HeapDataSource, and NonsharedBinDataDataSource.

Field Documentation

const DrmAsset DataSource::m_drm_asset [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/DataSource.hpp
  • Auxiliary/DataSource.cpp
Generated on Wed Jan 25 01:10:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataSourceBinData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataSourceBinData Class Reference

#include <Apoxi/Auxiliary/DataSourceBinData.hpp>

Inheritance diagram for DataSourceBinData:

[legend]
Collaboration diagram for DataSourceBinData:

[legend]

Public Member Functions

virtual UINT32 | GetLength () const
Returns the number of bytes which are hold by this object.
virtual MemMap * | ObtainMemMap (UINT32 idx, UINT32 size) const
virtual UINT32 | Read (UINT32 idx, void *buf, UINT32 nbytes) const
virtual BOOLEAN | Read (UINT32 idx, UINT8 &val) const
virtual void | ReleaseMemMap (MemMap **h_map) const

Static Public Member Functions

static DataSourceBinData * | CreateInstance (const DataSourcePtr &data_source)

Protected Member Functions

DataSourceBinData (const DataSourcePtr &data_source)
virtual | ~DataSourceBinData ()

Protected Attributes

DataSourcePtr m_data_source

Detailed Description

Class DataSourceBinData wraps a data source into the BinData interface. The DataSource-derived instance is given to and controlled by this class via a smart-pointer to ease the ownership problem of the provided data source.

Constructor & Destructor Documentation

DataSourceBinData::DataSourceBinData ( const DataSourcePtr & data_source ) [protected]

DataSourceBinData::~DataSourceBinData ( ) [protected, virtual]

Member Function Documentation

DataSourceBinData * DataSourceBinData::CreateInstance ( const DataSourcePtr & data_source ) [static]

Creates and returns a ready to use object of this class. The binary data is read from the specified data_source. If the data source is closed and can not be opened 0 is returned. Note, that the data source is not closed on destruction of this instance.

Parameters:
data_source The data source to read from.
Returns:
A ready to use object or 0 on failure.

UINT32 DataSourceBinData::GetLength ( ) const [virtual]

Returns the number of bytes which are hold by this object.

Implements BinData.

MemMap * DataSourceBinData::ObtainMemMap | ( | UINT32 | idx,
 |  | UINT32 | size
 | ) | const [virtual]

Obtains a memory map from the given index idx with the specified size size. A size of -1 returns a MemMap to the end of data. 0 is returned if obtaining a memory map is not supported on the bin data object.

Reimplemented from BinData.

UINT32 DataSourceBinData::Read | ( | UINT32 | idx,
 |  | void * | buf,
 |  | UINT32 | nbytes
 | ) | const [virtual]

Reads byte_count bytes starting from the offset idx into buffer buf. Returns the number of read bytes.

Implements BinData.

BOOLEAN DataSourceBinData::Read | ( | UINT32 | idx,
 |  | UINT8 & | val
 | ) | const [virtual]

Returns a single byte in val at the given index idx. val is not changed if idx does not exist.

Returns:
TRUE if a value at the index exists, FALSE otherwise.

Implements BinData.

void DataSourceBinData::ReleaseMemMap ( MemMap ** h_map ) const [virtual]

Releases a MemMap which has been obtained by BinData::ObtainMemMap.

Reimplemented from BinData.

Field Documentation

DataSourcePtr DataSourceBinData::m_data_source [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/DataSourceBinData.hpp
  • Auxiliary/DataSourceBinData.cpp
Generated on Wed Jan 25 01:10:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DataSourceRtStreamingSource Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DataSourceRtStreamingSource Class Reference

#include <Apoxi/Audio/RtStreaming/DataSourceRtStreamingSource.hpp>

Inheritance diagram for DataSourceRtStreamingSource:

[legend]
Collaboration diagram for DataSourceRtStreamingSource:

[legend]

Public Member Functions

DataSourceRtStreamingSource (DataSourcePtr ds)

Protected Member Functions

virtual BOOLEAN | CloseAction ()
Implements the concrete Close() behaviour.
virtual void | OnBufferSwitch (RtStreamingBuffer &buffer)
Indicates buffer switch.
virtual BOOLEAN | OpenAction ()
Implements the concrete Open() behaviour.
virtual BOOLEAN | StartAction (const BufferInfo &buf_info)
Implements the concrete Start() behaviour.
virtual BOOLEAN | StopAction ()
Implements the concrete Stop() behaviour.

Protected Attributes

RtStreamingBuffer * buffers
UINT32 | m_buf_size
INT8 | m_cur_buffer_returned
UINT32 | m_cur_file_offset
DataSourcePtr m_cur_src
Semaphore m_fill_semaphore
UINT8 | m_no_of_buffers
BOOLEAN | m_stop_requested_by_conn

Constructor & Destructor Documentation

DataSourceRtStreamingSource::DataSourceRtStreamingSource ( DataSourcePtr ds )

Member Function Documentation

BOOLEAN DataSourceRtStreamingSource::CloseAction ( ) [protected, virtual]

Implements the concrete Close() behaviour.

Implements RtStreamingEndPoint.

void DataSourceRtStreamingSource::OnBufferSwitch ( RtStreamingBuffer & buffer ) [protected, virtual]

Indicates buffer switch.

Should be implemented as following:
Gain ownership of 'buffer' and refill it or queue it for asynchronous refilling in background. The assign a buffer containing data to 'buffer', giving ownership to the corresponding RtStreamingSink instance. The last buffer of the stream should have the IsEndOfData() flag set.

Implements RtStreamingSource.

BOOLEAN DataSourceRtStreamingSource::OpenAction ( ) [protected, virtual]

Implements the concrete Open() behaviour.

Implements RtStreamingEndPoint.

BOOLEAN DataSourceRtStreamingSource::StartAction ( const BufferInfo & buf_info ) [protected, virtual]

Implements the concrete Start() behaviour.

Implements RtStreamingSource.

BOOLEAN DataSourceRtStreamingSource::StopAction ( ) [protected, virtual]

Implements the concrete Stop() behaviour.

When this method is invoked the implementation should stop producing data and set the end-of-data flag for the next buffer delivered within the call to OnBufferSwitch().

Implements RtStreamingSource.

Field Documentation

RtStreamingBuffer* DataSourceRtStreamingSource::buffers [protected]

UINT32 DataSourceRtStreamingSource::m_buf_size [protected]

INT8 DataSourceRtStreamingSource::m_cur_buffer_returned [protected]

UINT32 DataSourceRtStreamingSource::m_cur_file_offset [protected]

DataSourcePtr DataSourceRtStreamingSource::m_cur_src [protected]

Semaphore DataSourceRtStreamingSource::m_fill_semaphore [protected]

UINT8 DataSourceRtStreamingSource::m_no_of_buffers [protected]

BOOLEAN DataSourceRtStreamingSource::m_stop_requested_by_conn [protected]

The documentation for this class was generated from the following files:
  • Audio/RtStreaming/DataSourceRtStreamingSource.hpp
  • Audio/RtStreaming/DataSourceRtStreamingSource.cpp
Generated on Wed Jan 25 01:10:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Date Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Date Class Reference
[Auxiliary]

Date is used to represent a single date. More...

#include <Apoxi/Auxiliary/Date.hpp>

Inheritance diagram for Date:

[legend]

Public Types

enum Day {
Monday = 0, Tuesday = 1, Wednesday = 2, Thursday = 3,
Friday = 4, Saturday = 5, Sunday = 6
}
Allowed enumerations for the Day type. More...
enum Format {
ShortDateDM, ShortDateWDM, ShortDateDMY, ShortDateWDMY,
LongDateDM, LongDateWDM, LongDateDMY, LongDateWDMY
}
Allowed formats for string representation of a Date. More...
enum Month {
January = 1, February = 2, March = 3, April = 4,
May = 5, June = 6, July = 7, August = 8,
September = 9, October = 10, November = 11, December = 12
}
Allowed enumerations for the Month type. More...
enum PresetDate {
Today, Tomorrow, TheDayAfterTomorrow, Yesterday,
TheDayBeforeYesterday
}
Allowed enumeration values for initializing the Date object. More...

Public Member Functions

void | AddDays (INT ndays)
Add days to the date object, result will be a new date.
Date (const Persist &dstruct)
Creates a date object of persistent struct.
Date (INT day, INT month, INT year)
Constructor which creates a Date object with a day, a month and a year value.
Date (PresetDate pd)
Constructor which creates a Date object with a preset date type.
Date ()
Constructor which creates a Date object of Today.
const WCHAR * | DayName () const
Returns the weekdays name of the date object.
Day | DayOfWeek () const
Returns the day enumeration type of the date object.
INT | DayOfYear () const
Returns the day of the year value of the date object.
INT | DaysInMonth () const
Returns the number of days the month has (defined by the date).
INT | DaysInYear () const
Returns the number of days the year (defined by the date).
INT | GetDay () const
Returns the day value of the date.
INT | GetMonth () const
Returns the month value of the date.
WString | GetWString (const WCHAR *format) const
Returns the string representation defined in the WCHAR format string parameter.
WString | GetWString (Format date_format) const
Returns the string representation of the date object defined in the Format enumeration.
INT | GetYear () const
Returns the year value of the date including the century.
INT | GetYearYY () const
Returns the year value of the date excluding the century.
INT | GetYearYYYY () const
Returns the year value of the date including the century.
BOOLEAN | IsLeapYear () const
Checks if the date objects year is a leap year.
BOOLEAN | IsValid (const BOOLEAN accept_zeroed_date=TRUE) const
Checks if the Date object is representing a valid date.
BOOLEAN | IsZero () const
Checks if the Date object is empty.
const WCHAR * | MonthName () const
Returns the months name of the date object.
BOOLEAN | operator!= (const Date &date) const
Checks whether the date parameter is not identical to the object.
BOOLEAN | operator< (const Date &date) const
Checks whether the object is smaller than the date parameter object.
void | operator<< (const Date::Persist &date)
BOOLEAN | operator<= (const Date &date) const
Checks whether the object is smaller or equal than the date parameter object.
BOOLEAN | operator== (const Date &date) const
Checks whether the date parameter is identical to the object.
BOOLEAN | operator> (const Date &date) const
Checks whether the object is larger than the date parameter object.
BOOLEAN | operator>= (const Date &date) const
Checks whether the object is larger or equal than the date parameter object.
void | operator>> (Date::Persist &date) const
void | SetDay (INT day)
Sets the value of the day inside the date object.
void | SetMonth (INT month)
Sets the value of the month inside the date object.
void | SetYear (INT year)
Sets the value of the year inside the date object.
const WCHAR * | ShortDayName () const
Returns the weekdays shortname of the date object.
const WCHAR * | ShortMonthName () const
Returns the months shortname of the date object.
INT | WeekOfYear () const
Returns the week of the year value of the date object.

Static Public Member Functions

static INT | Compare (const Date &d1, const Date &d2)
static INT | Compare (const Date::Persist &t1, const Date::Persist &t2)
static const WCHAR * | DayName (Day day)
static UINT16 | DaysInYear (UINT16 year)
static BOOLEAN | IsLeapYear (UINT16 year)
static const WCHAR * | MonthName (INT month)
static const WCHAR * | ShortDayName (Day day)
static const WCHAR * | ShortMonthName (INT month)

Protected Attributes

UINT8 | m_day
UINT8 | m_month
UINT16 | m_year

Static Protected Attributes

static const WCHAR * | day_name [7]
static const UINT8 | days_in_month [12] = { 31,0,31,30,31,30,31,31,30,31,30,31 }
static const WCHAR * | month_name [13]
static const WCHAR * | short_day_name [7]
static const WCHAR * | short_month_name [13]

Data Structures

struct | Persist

Detailed Description

Date is used to represent a single date.

Member Enumeration Documentation

enum Date::Day

Allowed enumerations for the Day type.

Enumerator:
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday
Sunday

enum Date::Format

Allowed formats for string representation of a Date.

Enumerator:
ShortDateDM | day of month, month
ShortDateWDM | abbreviated weekday name, day of month, month
ShortDateDMY | day of month, month, year
ShortDateWDMY | abbreviated weekday name, day of month, abbreviated month name, year
LongDateDM | day of month, full month name
LongDateWDM | full weekday name, day of month, full month name
LongDateDMY | day of month, full month name, year
LongDateWDMY | full weekday name, day of month, full month name, year

enum Date::Month

Allowed enumerations for the Month type.

Enumerator:
January
February
March
April
May
June
July
August
September
October
November
December

enum Date::PresetDate

Allowed enumeration values for initializing the Date object.

Enumerator:
Today
Tomorrow
TheDayAfterTomorrow
Yesterday
TheDayBeforeYesterday

Constructor & Destructor Documentation

Date::Date ( )

Constructor which creates a Date object of Today.

Date::Date ( PresetDate pd )

Constructor which creates a Date object with a preset date type.

Date::Date | ( | INT | day,
 |  | INT | month,
 |  | INT | year
 | ) |

Constructor which creates a Date object with a day, a month and a year value.

Date::Date ( const Persist & dstruct )

Creates a date object of persistent struct.

Member Function Documentation

void Date::AddDays ( INT ndays )

Add days to the date object, result will be a new date.

INT Date::Compare | ( | const Date & | d1,
 |  | const Date & | d2
 | ) | [static]

INT Date::Compare | ( | const Date::Persist & | t1,
 |  | const Date::Persist & | t2
 | ) | [static]

const WCHAR * Date::DayName ( Day day ) [static]

const WCHAR* Date::DayName ( ) const [inline]

Returns the weekdays name of the date object.

Date::Day Date::DayOfWeek ( ) const

Returns the day enumeration type of the date object.

INT Date::DayOfYear ( ) const

Returns the day of the year value of the date object.

INT Date::DaysInMonth ( ) const

Returns the number of days the month has (defined by the date).

UINT16 Date::DaysInYear ( UINT16 year ) [static]

INT Date::DaysInYear ( ) const [inline]

Returns the number of days the year (defined by the date).

INT Date::GetDay ( ) const [inline]

Returns the day value of the date.

INT Date::GetMonth ( ) const [inline]

Returns the month value of the date.

WString Date::GetWString ( const WCHAR * format ) const

Returns the string representation defined in the WCHAR format string parameter.

WString Date::GetWString ( Format date_format ) const

Returns the string representation of the date object defined in the Format enumeration.

INT Date::GetYear ( ) const [inline]

Returns the year value of the date including the century.

INT Date::GetYearYY ( ) const

Returns the year value of the date excluding the century.

INT Date::GetYearYYYY ( ) const [inline]

Returns the year value of the date including the century.

BOOLEAN Date::IsLeapYear ( UINT16 year ) [static]

BOOLEAN Date::IsLeapYear ( ) const [inline]

Checks if the date objects year is a leap year.

BOOLEAN Date::IsValid ( const BOOLEAN accept_zeroed_date = TRUE ) const

Checks if the Date object is representing a valid date.

BOOLEAN Date::IsZero ( ) const

Checks if the Date object is empty.

const WCHAR * Date::MonthName ( INT month ) [static]

const WCHAR* Date::MonthName ( ) const [inline]

Returns the months name of the date object.

BOOLEAN Date::operator!= ( const Date & date ) const

Checks whether the date parameter is not identical to the object.

BOOLEAN Date::operator< ( const Date & date ) const

Checks whether the object is smaller than the date parameter object.

void Date::operator<< ( const Date::Persist & date )

BOOLEAN Date::operator<= ( const Date & date ) const

Checks whether the object is smaller or equal than the date parameter object.

BOOLEAN Date::operator== ( const Date & date ) const

Checks whether the date parameter is identical to the object.

BOOLEAN Date::operator> ( const Date & date ) const

Checks whether the object is larger than the date parameter object.

BOOLEAN Date::operator>= ( const Date & date ) const

Checks whether the object is larger or equal than the date parameter object.

void Date::operator>> ( Date::Persist & date ) const

void Date::SetDay ( INT day ) [inline]

Sets the value of the day inside the date object.

void Date::SetMonth ( INT month ) [inline]

Sets the value of the month inside the date object.

void Date::SetYear ( INT year ) [inline]

Sets the value of the year inside the date object.

const WCHAR * Date::ShortDayName ( Day day ) [static]

const WCHAR* Date::ShortDayName ( ) const [inline]

Returns the weekdays shortname of the date object.

const WCHAR * Date::ShortMonthName ( INT month ) [static]

const WCHAR* Date::ShortMonthName ( ) const [inline]

Returns the months shortname of the date object.

INT Date::WeekOfYear ( ) const

Returns the week of the year value of the date object.

Field Documentation

const WCHAR * Date::day_name [static, protected]

Initial value:

 {
    L"Monday",
    L"Tuesday",
    L"Wednesday",
    L"Thursday",
    L"Friday",
    L"Saturday",
    L"Sunday"
}

const UINT8 Date::days_in_month = { 31,0,31,30,31,30,31,31,30,31,30,31 } [static, protected]

UINT8 Date::m_day [protected]

UINT8 Date::m_month [protected]

UINT16 Date::m_year [protected]

const WCHAR * Date::month_name [static, protected]

Initial value:

 {
    L"",
    L"January",
    L"February",
    L"March",
    L"April",
    L"May",
    L"June",
    L"July",
    L"August",
    L"September",
    L"October",
    L"November",
    L"December"
}

const WCHAR * Date::short_day_name [static, protected]

Initial value:

 {
    L"Mon",
    L"Tue",
    L"Wed",
    L"Thu",
    L"Fri",
    L"Sat",
    L"Sun"
}

const WCHAR * Date::short_month_name [static, protected]

Initial value:

 {
    L"",
    L"Jan",
    L"Feb",
    L"Mar",
    L"Apr",
    L"May",
    L"Jun",
    L"Jul",
    L"Aug",
    L"Sep",
    L"Oct",
    L"Nov",
    L"Dec"
}

The documentation for this class was generated from the following files:
  • Auxiliary/Date.hpp
  • Auxiliary/Date.cpp
Generated on Wed Jan 25 01:10:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Date::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Date::Persist

Date::Persist Struct Reference

#include <Apoxi/Auxiliary/Date.hpp>

Data Fields

UINT8 | m_day
UINT8 | m_month
UINT16 | m_year

Field Documentation

UINT8 Date::Persist::m_day

UINT8 Date::Persist::m_month

UINT16 Date::Persist::m_year

The documentation for this struct was generated from the following file:
  • Auxiliary/Date.hpp
Generated on Wed Jan 25 01:10:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateCompoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateCompoundItem Class Reference
[Editors]

Contains a date. More...

#include <Apoxi/Gui/DateCompoundItem.hpp>

Inheritance diagram for DateCompoundItem:

[legend]
Collaboration diagram for DateCompoundItem:

[legend]

Public Types

enum | { ID = 8 }

Public Member Functions

virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
const Date & | GetDate () const
DateFormat | GetDateFormat () const
virtual INT | GetId () const
virtual INT | GetItemCount () const
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT index, INT count) const
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetDate (const Date &date)
void | SetDateFormat (DateFormat date_format)
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=EditorDocument::WhitespaceWrap) const
virtual | ~DateCompoundItem ()

Static Public Member Functions

static DateCompoundItem * | CreateInstance (const Date &date=Date())
Creates and returns an object of this class.

Protected Member Functions

DateCompoundItem (const Date &date=Date())

Detailed Description

Contains a date.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from CompoundItem.

Constructor & Destructor Documentation

DateCompoundItem::~DateCompoundItem ( ) [virtual]

DateCompoundItem::DateCompoundItem ( const Date & date = Date() ) [protected]

Member Function Documentation

DateCompoundItem * DateCompoundItem::CreateInstance ( const Date & date = Date() ) [static]

Creates and returns an object of this class.

void DateCompoundItem::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::Draw

Implements CompoundItem.

const Date& DateCompoundItem::GetDate ( ) const [inline]

DateFormat DateCompoundItem::GetDateFormat ( ) const [inline]

INT DateCompoundItem::GetId ( ) const [virtual]

See also:
CompoundItem::GetId()

Reimplemented from CompoundItem.

INT DateCompoundItem::GetItemCount ( ) const [virtual]

See also:
CompoundItem::GetItemCount

Implements CompoundItem.

XYDIM DateCompoundItem::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
CompoundItem::GetLineHeight

Implements CompoundItem.

XYDIM DateCompoundItem::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::GetLineWidth

Implements CompoundItem.

BOOLEAN DateCompoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from CompoundItem.

void DateCompoundItem::SetDate ( const Date & date ) [inline]

void DateCompoundItem::SetDateFormat ( DateFormat date_format ) [inline]

INT DateCompoundItem::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = EditorDocument::WhitespaceWrap
 | ) | const [virtual]

See also:
CompoundItem::WrapLine

Implements CompoundItem.

The documentation for this class was generated from the following files:
  • Gui/DateCompoundItem.hpp
  • Gui/DateCompoundItem.cpp
Generated on Wed Jan 25 01:10:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateEditBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateEditBox Class Reference

Obsolete - use DateEditor from Gui instead. More...

#include <Apoxi/Compat/DateEditBox.hpp>

Inheritance diagram for DateEditBox:

[legend]
Collaboration diagram for DateEditBox:

[legend]

Public Member Functions

DateEditBox (Control *parent, Date::Format format=Date::ShortDateDMY, const WCHAR *caption=0, CaptionPos caption_pos=CaptionOnTop)
DateEditBox ()
Date | GetDate () const
const WCHAR * | GetFormat () const
void | Init (Control *parent, Date::Format format=Date::ShortDateDMY, const WCHAR *caption=0, CaptionPos caption_pos=CaptionOnTop)
virtual BOOLEAN | IsInputValid () const
void | SetDate (const Date &date) const
void | SetFormat (const WCHAR *format)
void | SetFormat (Date::Format format)
virtual | ~DateEditBox ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual const AbstractEditBoxView * | GetView () const
virtual void | MoveCursor (INT inc)
virtual void | OnDeleteChar ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Detailed Description

Obsolete - use DateEditor from Gui instead.

Constructor & Destructor Documentation

DateEditBox::DateEditBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

DateEditBox::DateEditBox | ( | Control * | parent,
 |  | Date::Format | format = Date::ShortDateDMY,
 |  | const WCHAR * | caption = 0,
 |  | CaptionPos | caption_pos = CaptionOnTop
 | ) |

Parameters:
parent | Pointer to the window, which embedds the DateEditBox.
format | See Date::Format.
caption | Pointer to the caption.
caption_pos | See CaptionPosType.

DateEditBox::~DateEditBox ( ) [virtual]

Member Function Documentation

Model * DateEditBox::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

Date DateEditBox::GetDate ( ) const

const WCHAR* DateEditBox::GetFormat ( ) const [inline]

const AbstractEditBoxView * DateEditBox::GetView ( ) const [protected, virtual]

See also:
AbstractEditBox::GetView

Implements AbstractEditBox.

void DateEditBox::Init | ( | Control * | parent,
 |  | Date::Format | format = Date::ShortDateDMY,
 |  | const WCHAR * | caption = 0,
 |  | CaptionPos | caption_pos = CaptionOnTop
 | ) |

Parameters:
parent | Pointer to the window, which embedds the DateEditBox.
format | See Date::Format.
caption | Pointer to the caption.
caption_pos | See CaptionPosType.

BOOLEAN DateEditBox::IsInputValid ( ) const [virtual]

See also:
AbstractEditBox::IsInputValid

Reimplemented from AbstractEditBox.

void DateEditBox::MoveCursor ( INT inc ) [protected, virtual]

See also:
AbstractEditBox::MoveCursor

Reimplemented from AbstractEditBox.

void DateEditBox::OnDeleteChar ( ) [protected, virtual]

See also:
AbstractEditBox::OnDeleteChar

Reimplemented from AbstractEditBox.

BOOLEAN DateEditBox::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from Control.

void DateEditBox::SetDate ( const Date & date ) const

void DateEditBox::SetFormat ( const WCHAR * format )

void DateEditBox::SetFormat ( Date::Format format )

The documentation for this class was generated from the following files:
  • Compat/DateEditBox.hpp
  • Compat/DateEditBox.cpp
Generated on Wed Jan 25 01:10:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateEditBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateEditBoxModel Class Reference

Describes the model of a date editbox. More...

#include <Apoxi/Compat/DateEditBox.hpp>

Inheritance diagram for DateEditBoxModel:

[legend]
Collaboration diagram for DateEditBoxModel:

[legend]

Detailed Description

Describes the model of a date editbox.

The documentation for this class was generated from the following file:
  • Compat/DateEditBox.hpp
Generated on Wed Jan 25 01:10:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateEditBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateEditBoxView Class Reference

Describes the view of a date editbox. More...

#include <Apoxi/Compat/DateEditBox.hpp>

Inheritance diagram for DateEditBoxView:

[legend]
Collaboration diagram for DateEditBoxView:

[legend]

Public Member Functions

DateEditBoxView (XYDIM line_height, XYDIM caption_gap, XYDIM caption_width, XYDIM caption_height, XYDIM frame_size, XYDIM default_width=-1, XYDIM default_height=-1)
DateEditBoxView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual | ~DateEditBoxView ()

Protected Member Functions

virtual void | DrawDateEditBox (const DateEditBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Detailed Description

Describes the view of a date editbox.

Constructor & Destructor Documentation

DateEditBoxView::DateEditBoxView ( )

DateEditBoxView::DateEditBoxView | ( | XYDIM | line_height,
 |  | XYDIM | caption_gap,
 |  | XYDIM | caption_width,
 |  | XYDIM | caption_height,
 |  | XYDIM | frame_size,
 |  | XYDIM | default_width = -1,
 |  | XYDIM | default_height = -1
 | ) |

DateEditBoxView::~DateEditBoxView ( ) [virtual]

Member Function Documentation

void DateEditBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void DateEditBoxView::DrawDateEditBox | ( | const DateEditBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a dateeditbox described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a dateeditbox.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

The documentation for this class was generated from the following files:
  • Compat/DateEditBox.hpp
  • Compat/DateEditBox.cpp
Generated on Wed Jan 25 01:10:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateEditor Class Reference
[Editors]

#include <Apoxi/Gui/DateEditor.hpp>

Inheritance diagram for DateEditor:

[legend]
Collaboration diagram for DateEditor:

[legend]

Public Types

enum | { ID = 30 }

Public Member Functions

DateEditor (Control *parent, const Date &date=Date())
DateEditor ()
Date | GetDate () const
DateFormat | GetDateFormat () const
void | Init (Control *parent, const Date &date=Date())
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual void | MoveCaret (INT steps)
void | SetDate (const Date &date)
void | SetDateFormat (DateFormat date_format)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~DateEditor ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual void | Refresh (const Rect &rect)

Detailed Description

Editor for editing a date in a variable format.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractLineEditor.

Constructor & Destructor Documentation

DateEditor::DateEditor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

DateEditor::DateEditor | ( | Control * | parent,
 |  | const Date & | date = Date()
 | ) | [explicit]

Parameters:
parent | Pointer to the Control, which embedds the DateEditor.
date | Value for Date which should be edited.

DateEditor::~DateEditor ( ) [virtual]

Member Function Documentation

Model * DateEditor::CreateModel ( ) const [protected, virtual]

Factory method for creating a model. Must be implemented by every class, which needs it's own model. By default a component has no model and 0 is returned. If a model is dynamically created by 'new', it must be deleted in the destructor by e. g. delete GetModel();.

Returns:
Pointer to the model.

Reimplemented from Component.

Date DateEditor::GetDate ( ) const

DateFormat DateEditor::GetDateFormat ( ) const

void DateEditor::Init | ( | Control * | parent,
 |  | const Date & | date = Date()
 | ) |

Parameters:
parent | Pointer to the Control, which embedds the DateEditor.
date | Value for Date which should be edited.

BOOLEAN DateEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractLineEditor.

void DateEditor::MoveCaret ( INT steps ) [virtual]

See also:
AbstractEditor::MoveCaret()

Reimplemented from AbstractLineEditor.

void DateEditor::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from AbstractEditor.

void DateEditor::SetDate ( const Date & date )

void DateEditor::SetDateFormat ( DateFormat date_format )

BOOLEAN DateEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractLineEditor.

The documentation for this class was generated from the following files:
  • Gui/DateEditor.hpp
  • Gui/DateEditor.cpp
Generated on Wed Jan 25 01:10:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateEditorDocument Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateEditorDocument Class Reference
[Editors]

A Date-Editor-Document contains a Date-Compound-Item. More...

#include <Apoxi/Gui/DateEditorDocument.hpp>

Inheritance diagram for DateEditorDocument:

[legend]
Collaboration diagram for DateEditorDocument:

[legend]

Public Member Functions

DateEditorDocument (const Date &date=Date())
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
virtual const CompoundItem & | GetCompoundItem (INT index, INT *start_item_index=0) const
const Date & | GetDate () const
DateFormat | GetDateFormat () const
virtual INT | GetItemCount () const
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT index, INT count) const
virtual INT | GetMaxItemCount () const
void | Init (const Date &date)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index)
BOOLEAN | IsSeparator (INT index) const
virtual BOOLEAN | RemoveItem (INT index)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index)
void | SetDate (const Date &date)
void | SetDateFormat (DateFormat date_format)
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=WhitespaceWrap) const
virtual | ~DateEditorDocument ()

Protected Member Functions

BOOLEAN | Reinterpret (INT index)

Detailed Description

A Date-Editor-Document contains a Date-Compound-Item.

Constructor & Destructor Documentation

DateEditorDocument::DateEditorDocument ( const Date & date = Date() )

DateEditorDocument::~DateEditorDocument ( ) [virtual]

Member Function Documentation

void DateEditorDocument::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
EditorDocument::Draw()

Implements EditorDocument.

const CompoundItem & DateEditorDocument::GetCompoundItem | ( | INT | index,
 |  | INT * | start_item_index = 0
 | ) | const [virtual]

See also:
EditorDocument::GetCompoundItem()

Implements EditorDocument.

const Date & DateEditorDocument::GetDate ( ) const

DateFormat DateEditorDocument::GetDateFormat ( ) const

INT DateEditorDocument::GetItemCount ( ) const [virtual]

See also:
EditorDocument::GetItemCount()

Implements EditorDocument.

XYDIM DateEditorDocument::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
EditorDocument::GetLineHeight()

Implements EditorDocument.

XYDIM DateEditorDocument::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
EditorDocument::GetLineWidth()

Implements EditorDocument.

INT DateEditorDocument::GetMaxItemCount ( ) const [virtual]

See also:
EditorDocument::GetMaxItemCount()

Implements EditorDocument.

void DateEditorDocument::Init ( const Date & date )

BOOLEAN DateEditorDocument::InsertItem | ( | const AtomItem & | item,
 |  | INT | index
 | ) | [virtual]

See also:
EditorDocument::InsertItem()

Implements EditorDocument.

BOOLEAN DateEditorDocument::IsSeparator ( INT index ) const

BOOLEAN DateEditorDocument::Reinterpret ( INT index ) [protected]

Reinterprets a date given as string to the class Date.

Parameters:
index Index of the character, where the change has occured.
Returns:
em>TRUE, if the operation was successful.

BOOLEAN DateEditorDocument::RemoveItem ( INT index ) [virtual]

See also:
EditorDocument::RemoveItem()

Implements EditorDocument.

BOOLEAN DateEditorDocument::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index
 | ) | [virtual]

See also:
EditorDocument::ReplaceItem()

Implements EditorDocument.

void DateEditorDocument::SetDate ( const Date & date )

void DateEditorDocument::SetDateFormat ( DateFormat date_format )

INT DateEditorDocument::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = WhitespaceWrap
 | ) | const [virtual]

See also:
EditorDocument::WrapLine()

Implements EditorDocument.

The documentation for this class was generated from the following files:
  • Gui/DateEditorDocument.hpp
  • Gui/DateEditorDocument.cpp
Generated on Wed Jan 25 01:10:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateEditorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateEditorView Class Reference
[Editors]

#include <Apoxi/Gui/DateEditor.hpp>

Inheritance diagram for DateEditorView:

[legend]
Collaboration diagram for DateEditorView:

[legend]

Public Member Functions

DateEditorView ()
virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual | ~DateEditorView ()

Constructor & Destructor Documentation

DateEditorView::DateEditorView ( ) [explicit]

DateEditorView::~DateEditorView ( ) [virtual]

Member Function Documentation

void DateEditorView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Reimplemented from AbstractLineEditorView.

The documentation for this class was generated from the following files:
  • Gui/DateEditor.hpp
  • Gui/DateEditor.cpp
Generated on Wed Jan 25 01:10:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: datestr Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

datestr Struct Reference

#include <Apoxi/AddOns/AfsFat/FatSim.hpp>

Data Fields

ushort date
ushort time

Field Documentation

ushort datestr::date

ushort datestr::time

The documentation for this struct was generated from the following file:
  • AddOns/AfsFat/FatSim.hpp
Generated on Wed Jan 25 01:10:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateTime Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateTime Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/DateTime.hpp>

Inheritance diagram for DateTime:

[legend]
Collaboration diagram for DateTime:

[legend]

Public Types

enum | { RelativeBaseYear = 1970 }
enum | Alignment { Zero, UniversalTime, LocalTime }
typedef Date | Base

Public Member Functions

void | AddTimeSpan (const TimeSpan &timespan)
Adds a several time span to the object.
DateTime (UINT32 absoluteseconds, Alignment alignment=Zero)
DateTime (INT day, INT month, INT year, const Time &timeval, Alignment alignment=Zero)
DateTime (const Persist &dstruct)
Constructor for persist struct.
DateTime (INT day, INT month, INT year, INT hour, INT minute, INT second=0, INT millisecond=0, Alignment alignment=Zero)
DateTime (INT day, INT month, INT year)
Constructor for initialized the DateTime object, Time and Alignment are Zero.
DateTime (const DateTime &date_time)
Copyconstructor.
DateTime (PresetDate pd=Today)
Constructor for a preinitialized DateTime object releated to LocalTime.
DateTime (Alignment alignment)
Constructor for preinitialized DateTime objects related to desired time zone.
WString | Format (const WCHAR *format) const
UINT32 | GetAbsoluteDay () const
Returns the absolute days since the base year.
UINT64 | GetAbsoluteMilliseconds () const
Returns the absolute milliseconds since the base year.
UINT32 | GetAbsoluteSeconds () const
Returns the absolute seconds since the base year.
Alignment | GetAlignment () const
Current Alignment where Date and Time are related to.
Date | GetDate () const
INT | GetHour () const
TimeSpan | GetInterval (const DateTime &datetime)
Computes the absolute difference between two points of time observing their timezone.
INT | GetMillisecond () const
INT | GetMinute () const
INT | GetSecond () const
Time GetTime ()
const Time & | GetTime () const
BOOLEAN | operator!= (const DateTime &datetime) const
DateTime | operator+ (const TimeSpan &timespan) const
DateTime & | operator+= (const TimeSpan &timespan)
DateTime | operator- (const TimeSpan &timespan) const
DateTime & | operator-= (const TimeSpan &timespan)
BOOLEAN | operator< (const DateTime &datetime) const
void | operator<< (const DateTime::Persist &time)
BOOLEAN | operator<= (const DateTime &datetime) const
BOOLEAN | operator== (const DateTime &datetime) const
BOOLEAN | operator> (const DateTime &datetime) const
BOOLEAN | operator>= (const DateTime &datetime) const
void | operator>> (DateTime::Persist &time) const
void | SetDate (const Date &dateval)
void | SetDateTime (const Date &dateval, const Time &timeval)
void | SetHour (INT hour)
void | SetMillisecond (INT millisecond)
void | SetMinute (INT minute)
void | SetSecond (INT second)
void | SetTime (const Time &timeval)
void | SubTimeSpan (const TimeSpan &timespan)
Subtracts a several time span to the object.

Static Public Member Functions

static INT | Compare (const DateTime::Persist &d1, const DateTime::Persist &d2)
static INT | Compare (const DateTime &d1, const DateTime &d2)
static const TimeZone & | GetCurrentLocalTimeZone ()
static const TimeZone & | GetLocalTimeZone ()
Returns local timezone.
static const TimeZone & | GetTemporaryLocalTimeZone ()
static void | SetLocalTimeZone (const TimeZone &tz)
static void | SetTemporaryLocalTimeZone (const TimeZone &tz)

Data Structures

struct | Persist
struct | tm

Detailed Description

DateTime is used to represent a point of time, consisting of date and time values related to a specific TimeZone.

Member Typedef Documentation

typedef Date DateTime::Base

Member Enumeration Documentation

anonymous enum

Enumerator:
RelativeBaseYear Time base for computing the relative time values in seconds 1.1.1970, 00:00:00.

enum DateTime::Alignment

Enumerator:
Zero
UniversalTime
LocalTime

Constructor & Destructor Documentation

DateTime::DateTime ( Alignment alignment )

Constructor for preinitialized DateTime objects related to desired time zone.

DateTime::DateTime ( PresetDate pd = Today )

Constructor for a preinitialized DateTime object releated to LocalTime.

DateTime::DateTime ( const DateTime & date_time )

Copyconstructor.

DateTime::DateTime | ( | INT | day,
 |  | INT | month,
 |  | INT | year
 | ) |

Constructor for initialized the DateTime object, Time and Alignment are Zero.

DateTime::DateTime | ( | INT | day,
 |  | INT | month,
 |  | INT | year,
 |  | INT | hour,
 |  | INT | minute,
 |  | INT | second = 0,
 |  | INT | millisecond = 0,
 |  | Alignment | alignment = Zero
 | ) |

Constructor for initialized the DateTime object, Alignment defines to which timezone the datetime object is related to.

DateTime::DateTime ( const Persist & dstruct )

Constructor for persist struct.

DateTime::DateTime | ( | INT | day,
 |  | INT | month,
 |  | INT | year,
 |  | const Time & | timeval,
 |  | Alignment | alignment = Zero
 | ) |

Constructor for initialized the DateTime object, Alignment defines to which timezone the datetime object is related to.

DateTime::DateTime | ( | UINT32 | absoluteseconds,
 |  | Alignment | alignment = Zero
 | ) |

Constructor which converts the absolut second value to internal representation Alignment defines to which timezone the datetime object is related to.

Member Function Documentation

void DateTime::AddTimeSpan ( const TimeSpan & timespan )

Adds a several time span to the object.

INT DateTime::Compare | ( | const DateTime::Persist & | d1,
 |  | const DateTime::Persist & | d2
 | ) | [static]

INT DateTime::Compare | ( | const DateTime & | d1,
 |  | const DateTime & | d2
 | ) | [static]

WString DateTime::Format ( const WCHAR * format ) const

Formats the datetime value to the string (excluding TimeZoneInformation) Output limited to 32 characters right now

UINT32 DateTime::GetAbsoluteDay ( ) const

Returns the absolute days since the base year.

UINT64 DateTime::GetAbsoluteMilliseconds ( ) const

Returns the absolute milliseconds since the base year.

UINT32 DateTime::GetAbsoluteSeconds ( ) const

Returns the absolute seconds since the base year.

Alignment DateTime::GetAlignment ( ) const [inline]

Current Alignment where Date and Time are related to.

static const TimeZone& DateTime::GetCurrentLocalTimeZone ( ) [inline, static]

Returns currently local timezone, where date and time are related to: Normaly LocalTime Zone, except temporary Local TimeZone is set valid

Date DateTime::GetDate ( ) const

INT DateTime::GetHour ( ) const [inline]

TimeSpan DateTime::GetInterval ( const DateTime & datetime )

Computes the absolute difference between two points of time observing their timezone.

static const TimeZone& DateTime::GetLocalTimeZone ( ) [inline, static]

Returns local timezone.

INT DateTime::GetMillisecond ( ) const [inline]

INT DateTime::GetMinute ( ) const [inline]

INT DateTime::GetSecond ( ) const [inline]

static const TimeZone& DateTime::GetTemporaryLocalTimeZone ( ) [inline, static]

Returns temporary timezone where every created DateTime object with Alignment LocalTime is shifted to, when this timezone is valid. This timezone is transient.

Time DateTime::GetTime ( ) [inline]

const Time& DateTime::GetTime ( ) const [inline]

BOOLEAN DateTime::operator!= ( const DateTime & datetime ) const

DateTime DateTime::operator+ ( const TimeSpan & timespan ) const

DateTime & DateTime::operator+= ( const TimeSpan & timespan )

DateTime DateTime::operator- ( const TimeSpan & timespan ) const

DateTime & DateTime::operator-= ( const TimeSpan & timespan )

BOOLEAN DateTime::operator< ( const DateTime & datetime ) const

void DateTime::operator<< ( const DateTime::Persist & time )

BOOLEAN DateTime::operator<= ( const DateTime & datetime ) const

BOOLEAN DateTime::operator== ( const DateTime & datetime ) const

BOOLEAN DateTime::operator> ( const DateTime & datetime ) const

BOOLEAN DateTime::operator>= ( const DateTime & datetime ) const

void DateTime::operator>> ( DateTime::Persist & time ) const

void DateTime::SetDate ( const Date & dateval )

void DateTime::SetDateTime | ( | const Date & | dateval,
 |  | const Time & | timeval
 | ) |

void DateTime::SetHour ( INT hour ) [inline]

static void DateTime::SetLocalTimeZone ( const TimeZone & tz ) [inline, static]

Sets LocalTimeZone. This timezone is persistent. Invoking this method does not affect date and time of further created DateTime objects with Alignment LocalTime

void DateTime::SetMillisecond ( INT millisecond ) [inline]

void DateTime::SetMinute ( INT minute ) [inline]

void DateTime::SetSecond ( INT second ) [inline]

static void DateTime::SetTemporaryLocalTimeZone ( const TimeZone & tz ) [inline, static]

Sets temporary timezone. When this timezone is set, every created DateTime object with Alignment LocalTime will be shifted to this timezone. This timezone is transient.

void DateTime::SetTime ( const Time & timeval ) [inline]

void DateTime::SubTimeSpan ( const TimeSpan & timespan )

Subtracts a several time span to the object.

The documentation for this class was generated from the following files:
  • Auxiliary/DateTime.hpp
  • Auxiliary/DateTime.cpp
Generated on Wed Jan 25 01:10:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateTime::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DateTime::Persist

DateTime::Persist Struct Reference

#include <Apoxi/Auxiliary/DateTime.hpp>

Public Member Functions

BOOLEAN | IsLater (const Persist &datetime) const
BOOLEAN | IsZero () const
void | Reset ()

Data Fields

struct {
UINT16 m_minute: 6
UINT16 m_month: 4
UINT16 m_second: 6
} m_data1
struct {
UINT16 m_day: 5
UINT16 m_hour: 5
} m_data2
struct {
UINT16 m_year
} m_data3

Member Function Documentation

BOOLEAN DateTime::Persist::IsLater ( const Persist & datetime ) const [inline]

BOOLEAN DateTime::Persist::IsZero ( ) const [inline]

void DateTime::Persist::Reset ( ) [inline]

Field Documentation

struct { ... } DateTime::Persist::m_data1

struct { ... } DateTime::Persist::m_data2

struct { ... } DateTime::Persist::m_data3

UINT16 DateTime::Persist::m_day

UINT16 DateTime::Persist::m_hour

UINT16 DateTime::Persist::m_minute

UINT16 DateTime::Persist::m_month

UINT16 DateTime::Persist::m_second

UINT16 DateTime::Persist::m_year

The documentation for this struct was generated from the following file:
  • Auxiliary/DateTime.hpp
Generated on Wed Jan 25 01:10:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DateTimeInputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DateTimeInputMapper Class Reference
[Editors]

#include <Apoxi/Gui/DateTimeInputMapper.hpp>

Inheritance diagram for DateTimeInputMapper:

[legend]
Collaboration diagram for DateTimeInputMapper:

[legend]

Public Member Functions

DateTimeInputMapper (BOOLEAN date_mode=TRUE, BOOLEAN highlight_field=FALSE)
virtual Alphabet | GetAlphabet () const
virtual INT | GetId () const
virtual void | SetEditor (AbstractEditor *editor)
virtual | ~DateTimeInputMapper ()

Protected Member Functions

virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLoseFocus ()

Detailed Description

Manages the input of a date or time object and is usually used by the classes DateEditor and TimeEditor.

Constructor & Destructor Documentation

DateTimeInputMapper::DateTimeInputMapper | ( | BOOLEAN | date_mode = TRUE,
 |  | BOOLEAN | highlight_field = FALSE
 | ) | [explicit]

Parameters:
date_mode | If set to TRUE, the input mapper allows editing a date object, otherwise a time object can be edited.
higlight_field | If set to TRUE, the currently edited field is highlighted as input indication.

DateTimeInputMapper::~DateTimeInputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet DateTimeInputMapper::GetAlphabet ( ) const [virtual]

Returns SevenBitAlphabet.

See also:
InputMapper::GetAlphabet.

Reimplemented from NumericInputMapper.

INT DateTimeInputMapper::GetId ( ) const [virtual]

See also:
InputMapper::GetId()

Reimplemented from NumericInputMapper.

void DateTimeInputMapper::OnGetFocus ( ) [protected, virtual]

See also:
InputMapper::OnGetFocus

Reimplemented from InputMapper.

BOOLEAN DateTimeInputMapper::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
InputMapper::OnKeyDown()

Reimplemented from NumericInputMapper.

void DateTimeInputMapper::OnLoseFocus ( ) [protected, virtual]

See also:
InputMapper::OnLoseFocus

Reimplemented from InputMapper.

void DateTimeInputMapper::SetEditor ( AbstractEditor * editor ) [virtual]

See also:
InputMapper::SetEditor()

Reimplemented from InputMapper.

The documentation for this class was generated from the following files:
  • Gui/DateTimeInputMapper.hpp
  • Gui/DateTimeInputMapper.cpp
Generated on Wed Jan 25 01:10:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DbgDump Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DbgDump Class Reference

#include <Apoxi/Auxiliary/DbgDump.hpp>

Static Public Member Functions

static WString CreateHexCodes (const UINT8 *buffer, INT len)

Member Function Documentation

WString DbgDump::CreateHexCodes | ( | const UINT8 * | buffer,
 |  | INT | len
 | ) | [static]

The documentation for this class was generated from the following files:
  • Auxiliary/DbgDump.hpp
  • Auxiliary/DbgDump.cpp
Generated on Wed Jan 25 01:10:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DbgTimingMeasurement Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DbgTimingMeasurement Class Reference

#include <Apoxi/Kernel/DbgTimingMeasurement.hpp>

Public Member Functions

DbgTimingMeasurement (const CHAR *)
void Stop ()

Constructor & Destructor Documentation

DbgTimingMeasurement::DbgTimingMeasurement ( const CHAR * ) [inline]

Member Function Documentation

void DbgTimingMeasurement::Stop ( void ) [inline]

The documentation for this class was generated from the following file:
  • Kernel/DbgTimingMeasurement.hpp
Generated on Wed Jan 25 01:10:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DBItemChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DBItemChangedMsg Class Reference

#include <Apoxi/AddOns/SyncML/MsgTypes.hpp>

Inheritance diagram for DBItemChangedMsg:

[legend]
Collaboration diagram for DBItemChangedMsg:

[legend]

Public Types

enum | { ID = 4100 }

Public Member Functions

virtual Message * | Clone () const
DBItemChangedMsg (ExecutionContext *context, UINT16 db_uri, UINT32 item_uri, const DateTime &time_stamp, const SyncMLChangeType &opcode)
UINT16 | GetDbUri () const
UINT32 | GetItemUri () const
virtual const MsgMetaData & | GetMetaData () const
const SyncMLChangeType & | GetOpcode () const
const DateTime & | GetTimeStamp () const
virtual | ~DBItemChangedMsg ()

Detailed Description

Apoxi SyncML part application specified message, which will be sent to only one application

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DBItemChangedMsg::DBItemChangedMsg | ( | ExecutionContext * | context,
 |  | UINT16 | db_uri,
 |  | UINT32 | item_uri,
 |  | const DateTime & | time_stamp,
 |  | const SyncMLChangeType & | opcode
 | ) |

DBItemChangedMsg::~DBItemChangedMsg ( ) [virtual]

Member Function Documentation

Message * DBItemChangedMsg::Clone ( ) const [virtual]

Implements Message.

UINT16 DBItemChangedMsg::GetDbUri ( ) const [inline]

UINT32 DBItemChangedMsg::GetItemUri ( ) const [inline]

const MsgMetaData & DBItemChangedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const SyncMLChangeType& DBItemChangedMsg::GetOpcode ( ) const [inline]

const DateTime& DBItemChangedMsg::GetTimeStamp ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/SyncML/MsgTypes.hpp
  • AddOns/SyncML/MsgTypes.cpp
Generated on Wed Jan 25 01:10:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DBService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DBService Class Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Inheritance diagram for DBService:

[legend]
Collaboration diagram for DBService:

[legend]

Public Member Functions

virtual UINT16 | AddItem (UINT32 &item_id, const void *item_data, UINT32 item_data_length, const SyncMLItemMetaInfo &item_meta_info)=0
virtual BOOLEAN | ClearDatabase ()=0
virtual BOOLEAN | CloseDatabase ()=0
virtual BOOLEAN | CommitTransaction ()=0
virtual UINT16 | CopyItem (const UINT32 item_id, const UINT16 target_location, UINT32 &copy_item_id)=0
virtual UINT16 | DeleteItem (const UINT32 item_id)=0
virtual DBItemIterator * | GetAllItems ()=0
virtual BOOLEAN | GetDynamicProperties (SyncMLDynamicProps &dynamic_props)=0
virtual BOOLEAN | GetItemData (const UINT32 item_id, void *item_data, UINT32 &item_data_length, SyncMLItemMetaInfo *item_meta_info=0)=0
virtual BOOLEAN | GetItemMetaInfo (const UINT32 item_id, SyncMLItemMetaInfo &item_meta_info)=0
virtual const SyncMLDataStoreProps * | GetStaticProperties ()=0
virtual BOOLEAN | LockDataStore ()=0
virtual BOOLEAN | OpenDatabase ()=0
virtual BOOLEAN | Rollback ()=0
virtual DBItemIterator * | SearchDataItems (const String &search_grammar, const String &search_query)=0
virtual BOOLEAN | StartTransaction ()=0
virtual BOOLEAN | UnlockDataStore ()=0
virtual UINT16 | UpdateItem (const UINT32 item_id, const void *item_data, UINT32 item_data_length, const SyncMLItemMetaInfo &item_meta_info)=0

Protected Member Functions

DBService (const Guid &guid)

Data Structures

class | DBItemIterator

Detailed Description

The DBService class is a base class for service interfaces for data base applications. It is derived from Apoxi class Service. It is intended to be used by SyncML applications as the interface to a data store and therefore has to be implemented by data base applications which want to synchronize their data with other device.

Constructor & Destructor Documentation

DBService::DBService ( const Guid & guid ) [inline, protected]

Member Function Documentation

virtual UINT16 DBService::AddItem | ( | UINT32 & | item_id,
 |  | const void * | item_data,
 |  | UINT32 | item_data_length,
 |  | const SyncMLItemMetaInfo & | item_meta_info
 | ) | [pure virtual]

Adds an item to the database. New item id for the item is returned in output parameter item_id.

Parameters:
item_id[out] | : The item id for the newly added item.
item_data[in] | : Data for the item.
item_data_length[in] | : Length of the data for the item.
item_meta_info[in] | : Meta information about the data for the item.
Returns:
Returns the response status code of the operation (see Response Status Codes in the SyncML Representation Protocol).

virtual BOOLEAN DBService::ClearDatabase ( ) [pure virtual]

Deletes all items from the database.

Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::CloseDatabase ( ) [pure virtual]

Closes the database. Is called by SyncML application after reading and writing the data.

Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::CommitTransaction ( ) [pure virtual]

Commits the transactions and makes all the changes since StartTransaction was called.

Returns:
TRUE if successful, FALSE otherwise.

virtual UINT16 DBService::CopyItem | ( | const UINT32 | item_id,
 |  | const UINT16 | target_location,
 |  | UINT32 & | copy_item_id
 | ) | [pure virtual]

Makes a copy of the item with id item_id and stores it in the database. Gives back the id of the item copy in copy_item_id.

Parameters:
item_id[in] | : The item id for the newly added item.
target_location[in] | : The location where the copy should be added.
copy_item_id[out] | : The id of the new copy of the item.
Returns:
Returns the response status code of the operation, (see Response Status Codes in the SyncML Representation Protocol).

virtual UINT16 DBService::DeleteItem ( const UINT32 item_id ) [pure virtual]

Deletes the item with item id from the database.

Parameters:
item_id[in] : Item id which is to be deleted.
Returns:
Returns the response status code of the operation (see Response Status Codes in the SyncML Representation Protocol).

virtual DBItemIterator* DBService::GetAllItems ( ) [pure virtual]

Gets the iterator for all the item ids in data store.

Returns:
pointer to a DBItemIterator iterator for all items in the data store. If the iterator isn't used any more, it has to be released using Release.

virtual BOOLEAN DBService::GetDynamicProperties ( SyncMLDynamicProps & dynamic_props ) [pure virtual]

Gets the dynamic properties for this data store.

Parameters:
dynamic_props[out] : the dynamic properties for this data store.
Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::GetItemData | ( | const UINT32 | item_id,
 |  | void * | item_data,
 |  | UINT32 & | item_data_length,
 |  | SyncMLItemMetaInfo * | item_meta_info = 0
 | ) | [pure virtual]

Gets the data of the item with id item_id. Gives back the data in parameter item_data and meta data in parameter item_meta_info.

Parameters:
item_id[in] | : The item id for the item.
item_data[out] | : Pointer to the buffer for the item data.
item_data_length[in/out],: Input should be size of buffer, output the actual length of item data.
item_meta_info[out] | : Pointer to the meta information of the item. Maybe 0.
Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::GetItemMetaInfo | ( | const UINT32 | item_id,
 |  | SyncMLItemMetaInfo & | item_meta_info
 | ) | [pure virtual]

Gets the meta info of the item with id item_id. Gives back the meta data in parameter item_meta_info.

Parameters:
item_id[in] | : The item id for the item.
item_meta_info[out] | : Meta information about the data of the item.
Returns:
TRUE if successful, FALSE otherwise.

virtual const SyncMLDataStoreProps* DBService::GetStaticProperties ( ) [pure virtual]

Gets the static properties for this data store.

Returns:
data_store_props : properties of this data store.

virtual BOOLEAN DBService::LockDataStore ( ) [pure virtual]

Locks the data store to prohibit any data changes by others than the SyncML application.

Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::OpenDatabase ( ) [pure virtual]

Opens the database. Has to be called by the SyncML application before data is read or written.

Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::Rollback ( ) [pure virtual]

Rollbacks the transaction and undos all the changes since StartTransaction was called.

Returns:
TRUE if successful, FALSE otherwise.

virtual DBItemIterator* DBService::SearchDataItems | ( | const String & | search_grammar,
 |  | const String & | search_query
 | ) | [pure virtual]

Get the iterator to the item ids based on search_grammer and search_query.

Parameters:
search_grammar[in] | : the search grammar the query is specified in (e.g. "sql").
search_query[in] | : the search query as a string.
Returns:
pointer to a DBItemIterator iterator for the items selected by the query. If the iterator isn't used any more, it has to be released using Release.

virtual BOOLEAN DBService::StartTransaction ( ) [pure virtual]

Starts a transaction.

Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::UnlockDataStore ( ) [pure virtual]

Unlocks the data store and allows changes by others than the SyncML application.

Returns:
TRUE if successful, FALSE otherwise.

virtual UINT16 DBService::UpdateItem | ( | const UINT32 | item_id,
 |  | const void * | item_data,
 |  | UINT32 | item_data_length,
 |  | const SyncMLItemMetaInfo & | item_meta_info
 | ) | [pure virtual]

Updates an item in the database with new data.

Parameters:
item_id[in] | : The item id for the item.
item_data[in] | : Data for the item.
item_data_length[in] | : Length of the data for the item.
item_meta_info[in] | : Meta information about the data for the item.
Returns:
Returns the response status code of the operation (see Response Status Codes in the SyncML Representation Protocol).

The documentation for this class was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 01:10:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DBService::DBItemIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DBService::DBItemIterator

DBService::DBItemIterator Class Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Public Member Functions

virtual BOOLEAN | GetNextItem (UINT32 &item_id, void *item_data, UINT32 &item_data_length, SyncMLItemMetaInfo *item_meta_info=0)=0
virtual BOOLEAN | GetNextItemMetaInfo (UINT32 &item_id, SyncMLItemMetaInfo &item_meta_info)=0
virtual BOOLEAN | HasNext ()=0
virtual BOOLEAN | Release ()=0

Detailed Description

Iterator for iterating over the items in a datastore.

Member Function Documentation

virtual BOOLEAN DBService::DBItemIterator::GetNextItem | ( | UINT32 & | item_id,
 |  | void * | item_data,
 |  | UINT32 & | item_data_length,
 |  | SyncMLItemMetaInfo * | item_meta_info = 0
 | ) | [pure virtual]

Gets the item id, data, and meta information of the next item. Gives back the id of the next item in parameter item_id and the data in parameter item_data and meta data in parameter item_meta_info.

Parameters:
item_id[out] | : The item id for the item.
item_data[out] | : Pointer to the buffer for the item data.
item_data_length[in/out],: Input should be size of data buffer, output the actual length of item data.
item_meta_info[out] | : Pointer to the meta information of the item. Maybe 0.
Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::DBItemIterator::GetNextItemMetaInfo | ( | UINT32 & | item_id,
 |  | SyncMLItemMetaInfo & | item_meta_info
 | ) | [pure virtual]

Gets the item id and meta information of the next item. Gives back the id of the next item in parameter item_id and meta data in parameter item_meta_info.

Parameters:
item_id[out] | : The item id for the item.
item_meta_info[out] | : Meta information about the data of the item.
Returns:
TRUE if successful, FALSE otherwise.

virtual BOOLEAN DBService::DBItemIterator::HasNext ( ) [pure virtual]

Tests if there is a next item.

Returns:
TRUE if there is a next item, FALSE otherwise.

virtual BOOLEAN DBService::DBItemIterator::Release ( ) [pure virtual]

Releases the iterator and free any memory used.

Returns:
TRUE if successful, FALSE otherwise.

The documentation for this class was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 01:10:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DchReport Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DchReport Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

DchReport | operator= (T_EM_DCH_REPORT t_dch_report)

Data Fields

UINT32 | meas_bler
INT16 | meas_sir
INT16 | target_sir

Member Function Documentation

DchReport DchReport::operator= ( T_EM_DCH_REPORT t_dch_report )

Field Documentation

UINT32 DchReport::meas_bler

INT16 DchReport::meas_sir

INT16 DchReport::target_sir

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:10:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DcsLanguageFilterRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DcsLanguageFilterRule Class Reference

#include <Apoxi/AddOns/AdcExtensions/DcsLanguageFilterRule.hpp>

Inheritance diagram for DcsLanguageFilterRule:

[legend]
Collaboration diagram for DcsLanguageFilterRule:

[legend]

Public Member Functions

DcsLanguageFilterRule ()
virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)
virtual | ~DcsLanguageFilterRule ()

Constructor & Destructor Documentation

DcsLanguageFilterRule::DcsLanguageFilterRule ( )

DcsLanguageFilterRule::~DcsLanguageFilterRule ( ) [virtual]

Member Function Documentation

BOOLEAN DcsLanguageFilterRule::ExecuteRule ( const DataItem & dataitem ) [virtual]

ExecuteRule does the actual comparision between the data item given in the argument and the value stored when the filter rule is constructed.

Implements FilterRule.

The documentation for this class was generated from the following files:
  • AddOns/AdcExtensions/DcsLanguageFilterRule.hpp
  • AddOns/AdcExtensions/DcsLanguageFilterRule.cpp
Generated on Wed Jan 25 01:10:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DebugOutputStream Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DebugOutputStream Class Reference
[Kernel]

#include <Apoxi/Compat/DebugOutputStream.hpp>

Inheritance diagram for DebugOutputStream:

[legend]
Collaboration diagram for DebugOutputStream:

[legend]

Public Member Functions

DebugOutputStream ()
virtual void | Flush ()
virtual OutputStream & | operator<< (const unsigned long n)
virtual OutputStream & | operator<< (const long n)
virtual OutputStream & | operator<< (const unsigned int n)
virtual OutputStream & | operator<< (const int n)
virtual OutputStream & | operator<< (const unsigned short n)
virtual OutputStream & | operator<< (const short n)
virtual OutputStream & | operator<< (const wchar_t *w)
virtual OutputStream & | operator<< (const char *s)
virtual OutputStream & | operator<< (const signed char c)
virtual OutputStream & | operator<< (const unsigned char c)
virtual OutputStream & | operator<< (const char c)
virtual INT | Write (const BYTE *data, INT len)
virtual INT | Write (const BYTE data)
virtual | ~DebugOutputStream ()

Constructor & Destructor Documentation

DebugOutputStream::DebugOutputStream ( )

DebugOutputStream::~DebugOutputStream ( ) [virtual]

Member Function Documentation

void DebugOutputStream::Flush ( ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const unsigned long n ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const long n ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const unsigned int n ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const int n ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const unsigned short n ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const short n ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const wchar_t * w ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const char * s ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const signed char c ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const unsigned char c ) [virtual]

Reimplemented from OutputStream.

OutputStream & DebugOutputStream::operator<< ( const char c ) [virtual]

Reimplemented from OutputStream.

INT DebugOutputStream::Write | ( | const BYTE * | data,
 |  | INT | len
 | ) | [virtual]

Reimplemented from OutputStream.

INT DebugOutputStream::Write ( const BYTE data ) [virtual]

Implements OutputStream.

The documentation for this class was generated from the following files:
  • Compat/DebugOutputStream.hpp
  • Compat/DebugOutputStream.cpp
Generated on Wed Jan 25 01:10:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DecodingThreadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DecodingThreadlet Class Reference
[GUI]

#include <Apoxi/Gui/DecodingThreadlet.hpp>

Inheritance diagram for DecodingThreadlet:

[legend]
Collaboration diagram for DecodingThreadlet:

[legend]

Public Member Functions

virtual INT | Fn ()
virtual void | ReleaseInstance ()
virtual | ~DecodingThreadlet ()

Static Public Member Functions

static DecodingThreadlet * | CreateInstance (Image *image, Bitmap *bitmap, INT frame_idx)

Detailed Description

DecodingThreadlet uses an own thread for converting an image to a bitmap. Decompression, decoding and converting does not affect the system.

Constructor & Destructor Documentation

DecodingThreadlet::~DecodingThreadlet ( ) [virtual]

Member Function Documentation

DecodingThreadlet * DecodingThreadlet::CreateInstance | ( | Image * | image,
 |  | Bitmap * | bitmap,
 |  | INT | frame_idx
 | ) | [static]

Creates a decoding-threadlet and releases itself automatically after the threadlet has been executed.

INT DecodingThreadlet::Fn ( ) [virtual]

See also:
Thread::Fn

Implements Threadlet.

void DecodingThreadlet::ReleaseInstance ( ) [virtual]

See also:
Threadlet::ReleaseInstance

Reimplemented from Threadlet.

The documentation for this class was generated from the following files:
  • Gui/DecodingThreadlet.hpp
  • Gui/DecodingThreadlet.cpp
Generated on Wed Jan 25 01:10:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultCaret Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultCaret Class Reference
[Editors]

#include <Apoxi/Gui/DefaultCaret.hpp>

Inheritance diagram for DefaultCaret:

[legend]
Collaboration diagram for DefaultCaret:

[legend]

Public Member Functions

DefaultCaret (AbstractEditor *editor, UINT32 blink_rate, Caret::Mode mode=Insert)
DefaultCaret ()
virtual void | Draw (DeviceContext *dc, const Rect &bounds, BOOLEAN right_to_left=FALSE) const
virtual XYDIM | GetMinimalWidth () const
BOOLEAN | IsBlinking () const
virtual void | SetColumn (INT column)
virtual void | SetRow (INT row)
virtual void | SetVisible (BOOLEAN visible)
virtual | ~DefaultCaret ()

Friends

class | TriggerTimer< DefaultCaret >

Detailed Description

Simple caret, which marks the whole Item in overwrite mode and displays a small line on the left side of an item in insert mode.

Constructor & Destructor Documentation

DefaultCaret::DefaultCaret ( )

DefaultCaret::DefaultCaret | ( | AbstractEditor * | editor,
 |  | UINT32 | blink_rate,
 |  | Caret::Mode | mode = Insert
 | ) |

Parameters:
editor | Pointer to the corresponding editor.
blink_rate | Blink speed of the caret.
mode | See Caret::Mode.

DefaultCaret::~DefaultCaret ( ) [virtual]

Member Function Documentation

void DefaultCaret::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds,
 |  | BOOLEAN | right_to_left = FALSE
 | ) | const [virtual]

See also:
Caret::Draw

Implements Caret.

Reimplemented in MultiTapCaret.

XYDIM DefaultCaret::GetMinimalWidth ( ) const [virtual]

See also:
Caret::GetMinimalWidth()

Implements Caret.

Reimplemented in MultiTapCaret.

BOOLEAN DefaultCaret::IsBlinking ( ) const [inline]

Returns TRUE, if the caret is currently blinking and hence visible.

void DefaultCaret::SetColumn ( INT column ) [virtual]

See also:
Caret::SetColumn()

Reimplemented from Caret.

void DefaultCaret::SetRow ( INT row ) [virtual]

See also:
Caret::SetRow()

Reimplemented from Caret.

void DefaultCaret::SetVisible ( BOOLEAN visible ) [virtual]

See also:
Caret::SetVisible()

Reimplemented from Caret.

Friends And Related Function Documentation

friend class TriggerTimer< DefaultCaret > [friend]

The documentation for this class was generated from the following files:
  • Gui/DefaultCaret.hpp
  • Gui/DefaultCaret.cpp
Generated on Wed Jan 25 01:10:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultCheckBoxListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultCheckBoxListView Class Reference

Obsolete since APOXI-1.6.2. More...

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp>

Inheritance diagram for DefaultCheckBoxListView:

[legend]
Collaboration diagram for DefaultCheckBoxListView:

[legend]

Public Member Functions

DefaultCheckBoxListView (CheckBoxView *cb_view, XYDIM item_height)
DefaultCheckBoxListView ()
DefaultCheckBoxListView (CheckBoxView *cb_view, XYDIM item_height)
DefaultCheckBoxListView ()
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultCheckBoxListView ()
virtual | ~DefaultCheckBoxListView ()

Protected Member Functions

virtual void | DrawCheckBoxItem (const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const
virtual void | DrawCheckBoxItem (const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const

Detailed Description

Obsolete since APOXI-1.6.2.

Constructor & Destructor Documentation

DefaultCheckBoxListView::DefaultCheckBoxListView ( )

DefaultCheckBoxListView::DefaultCheckBoxListView | ( | CheckBoxView * | cb_view,
 |  | XYDIM | item_height
 | ) |

virtual DefaultCheckBoxListView::~DefaultCheckBoxListView ( ) [inline, virtual]

DefaultCheckBoxListView::DefaultCheckBoxListView ( )

DefaultCheckBoxListView::DefaultCheckBoxListView | ( | CheckBoxView * | cb_view,
 |  | XYDIM | item_height
 | ) |

virtual DefaultCheckBoxListView::~DefaultCheckBoxListView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultCheckBoxListView::DrawCheckBoxItem | ( | const CheckBoxItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

Implements CheckBoxListView.

void DefaultCheckBoxListView::DrawCheckBoxItem | ( | const CheckBoxItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

Implements CheckBoxListView.

virtual void DefaultCheckBoxListView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

void DefaultCheckBoxListView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp
  • GlobalThemes/DefaultTheme/DefaultCheckBoxListView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxListView.cpp
  • GlobalThemes/DefaultTheme/DefaultCheckBoxListView.cpp
Generated on Wed Jan 25 01:10:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultCheckBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultCheckBoxView Class Reference

Obsolete since APOXI-1.6.2. More...

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp>

Inheritance diagram for DefaultCheckBoxView:

[legend]
Collaboration diagram for DefaultCheckBoxView:

[legend]

Public Member Functions

DefaultCheckBoxView (XYDIM default_height, XYDIM left_gap, XYDIM middle_gap)
DefaultCheckBoxView ()
DefaultCheckBoxView (XYDIM default_height, XYDIM left_gap, XYDIM middle_gap)
DefaultCheckBoxView ()
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultCheckBoxView ()
virtual | ~DefaultCheckBoxView ()

Protected Member Functions

virtual void | DrawCheckBox (const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawCheckBox (const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShiftedCheckBox (const Rect &shift_rect, const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShiftedCheckBox (const Rect &shift_rect, const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Detailed Description

Obsolete since APOXI-1.6.2.

Constructor & Destructor Documentation

DefaultCheckBoxView::DefaultCheckBoxView ( )

DefaultCheckBoxView::DefaultCheckBoxView | ( | XYDIM | default_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

virtual DefaultCheckBoxView::~DefaultCheckBoxView ( ) [inline, virtual]

DefaultCheckBoxView::DefaultCheckBoxView ( )

DefaultCheckBoxView::DefaultCheckBoxView | ( | XYDIM | default_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

virtual DefaultCheckBoxView::~DefaultCheckBoxView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultCheckBoxView::DrawCheckBox | ( | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements CheckBoxView.

void DefaultCheckBoxView::DrawCheckBox | ( | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements CheckBoxView.

virtual void DefaultCheckBoxView::DrawShiftedCheckBox | ( | const Rect & | shift_rect,
 |  | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements CheckBoxView.

void DefaultCheckBoxView::DrawShiftedCheckBox | ( | const Rect & | shift_rect,
 |  | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements CheckBoxView.

virtual void DefaultCheckBoxView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

void DefaultCheckBoxView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp
  • GlobalThemes/DefaultTheme/DefaultCheckBoxView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultCheckBoxView.cpp
  • GlobalThemes/DefaultTheme/DefaultCheckBoxView.cpp
Generated on Wed Jan 25 01:10:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultChineseTheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultChineseTheme Class Reference

Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

#include <Apoxi/Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.hpp>

Inheritance diagram for DefaultChineseTheme:

[legend]
Collaboration diagram for DefaultChineseTheme:

[legend]

Public Member Functions

DefaultChineseTheme ()
virtual const CheckBoxListView * | GetCheckBoxListView () const
virtual const CheckBoxView * | GetCheckBoxView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const RadioButtonListView * | GetRadioButtonListView () const
virtual const RadioButtonView * | GetRadioButtonView () const
virtual const SoftkeyBarView * | GetSoftkeyBarView () const
virtual const SystemColor | GetSystemColor (SystemColorId id) const
virtual const FontId | GetSystemFontId (SystemFontId id) const
virtual const TextListView * | GetTextListView () const
virtual const WindowFrameView * | GetWindowFrameView () const
void | Update ()
virtual | ~DefaultChineseTheme ()

Detailed Description

Obsolete theme - replaced by themes in Apoxi/GlobalThemes.

Constructor & Destructor Documentation

DefaultChineseTheme::DefaultChineseTheme ( )

DefaultChineseTheme::~DefaultChineseTheme ( ) [virtual]

Member Function Documentation

const CheckBoxListView * DefaultChineseTheme::GetCheckBoxListView ( ) const [virtual]

const CheckBoxView * DefaultChineseTheme::GetCheckBoxView ( ) const [virtual]

const ControlFrameView * DefaultChineseTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const PositionIndicatorView * DefaultChineseTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

const ProgressBarView * DefaultChineseTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

const PushButtonView * DefaultChineseTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const RadioButtonListView * DefaultChineseTheme::GetRadioButtonListView ( ) const [virtual]

const RadioButtonView * DefaultChineseTheme::GetRadioButtonView ( ) const [virtual]

const SoftkeyBarView * DefaultChineseTheme::GetSoftkeyBarView ( ) const [virtual]

const SystemColor DefaultChineseTheme::GetSystemColor ( SystemColorId id ) const [virtual]

Returns a color-value of the system-color with the id id specified by the system-color-table. This method must not be overwritten by derived themes, when GetSystemColorTable has been overwritten. To stay backward-compatible with older versions of APOXI, 0 is returned if no system-color-table is provided.

Reimplemented from Theme.

const FontId DefaultChineseTheme::GetSystemFontId ( SystemFontId id ) const [virtual]

const TextListView * DefaultChineseTheme::GetTextListView ( ) const [virtual]

const WindowFrameView * DefaultChineseTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

void DefaultChineseTheme::Update ( ) [virtual]

Converts all colors given by the system-color-table to system-colors and invokes View::Update(this) for every View which is part of the theme. Also the fonts are updated which may be specified by ThemeConfig::GetFontId().

Reimplemented from Theme.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.hpp
  • Compat/GlobalThemes/DefaultChineseTheme/DefaultChineseTheme.cpp
Generated on Wed Jan 25 01:10:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultControlFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultControlFrameView Class Reference

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp>

Inheritance diagram for DefaultControlFrameView:

[legend]
Collaboration diagram for DefaultControlFrameView:

[legend]

Public Member Functions

DefaultControlFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size)
DefaultControlFrameView ()
DefaultControlFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size)
DefaultControlFrameView ()
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultControlFrameView ()
virtual | ~DefaultControlFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

DefaultControlFrameView::DefaultControlFrameView ( )

DefaultControlFrameView::DefaultControlFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size
 | ) |

DefaultControlFrameView::~DefaultControlFrameView ( ) [virtual]

DefaultControlFrameView::DefaultControlFrameView ( )

DefaultControlFrameView::DefaultControlFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size
 | ) |

virtual DefaultControlFrameView::~DefaultControlFrameView ( ) [virtual]

Member Function Documentation

virtual void DefaultControlFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

void DefaultControlFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

virtual void DefaultControlFrameView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

void DefaultControlFrameView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp
  • GlobalThemes/DefaultTheme/DefaultControlFrameView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultControlFrameView.cpp
  • GlobalThemes/DefaultTheme/DefaultControlFrameView.cpp
Generated on Wed Jan 25 01:10:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultDisplay Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultDisplay Class Reference
[Devices, Devices, Devices, Devices, Devices, Devices]

#include <Apoxi/Devices/BP30/DefaultDisplay.hpp>

Inheritance diagram for DefaultDisplay:

[legend]
Collaboration diagram for DefaultDisplay:

[legend]

Public Member Functions

DefaultDisplay (INT index)
DefaultDisplay (INT index)
DefaultDisplay (INT index)
DefaultDisplay (INT index)
DefaultDisplay (INT index)
DefaultDisplay (INT index)
virtual BacklightMode | GetBacklightMode () const
virtual BacklightMode | GetBacklightMode () const
virtual BacklightMode | GetBacklightMode () const
virtual BacklightMode | GetBacklightMode () const
virtual BacklightMode | GetBacklightMode () const
virtual BacklightMode | GetBacklightMode () const
virtual INT | GetBrightness () const
virtual INT | GetBrightness () const
virtual INT | GetBrightness () const
virtual INT | GetBrightness () const
virtual INT | GetBrightness () const
virtual INT | GetBrightness () const
virtual INT | GetContrast () const
virtual INT | GetContrast () const
virtual INT | GetContrast () const
virtual INT | GetContrast () const
virtual INT | GetContrast () const
virtual INT | GetContrast () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual PowerMode | GetPowerMode () const
virtual PowerMode | GetPowerMode () const
virtual PowerMode | GetPowerMode () const
virtual PowerMode | GetPowerMode () const
virtual PowerMode | GetPowerMode () const
virtual PowerMode | GetPowerMode () const
virtual VideoChannel * | GetVideoChannel ()
virtual VideoChannel * | GetVideoChannel ()
virtual VideoChannel * | GetVideoChannel ()
virtual VideoChannel * | GetVideoChannel ()
virtual VideoChannel * | GetVideoChannel ()
virtual VideoChannel * | GetVideoChannel ()
virtual BOOLEAN | IsBacklightOn () const
virtual BOOLEAN | IsBacklightOn () const
virtual BOOLEAN | IsBacklightOn () const
virtual BOOLEAN | IsBacklightOn () const
virtual BOOLEAN | IsBacklightOn () const
virtual BOOLEAN | IsBacklightOn () const
virtual BOOLEAN | IsCallbackActive () const
virtual BOOLEAN | IsCallbackActive () const
virtual BOOLEAN | IsCallbackActive () const
virtual BOOLEAN | IsCallbackActive () const
virtual BOOLEAN | IsCallbackActive () const
virtual BOOLEAN | IsPowerOn () const
virtual BOOLEAN | IsPowerOn () const
virtual BOOLEAN | IsPowerOn () const
virtual BOOLEAN | IsPowerOn () const
virtual BOOLEAN | IsPowerOn () const
virtual BOOLEAN | IsPowerOn () const
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStop ()
virtual void | OnStop ()
virtual void | OnStop ()
virtual void | OnStop ()
virtual void | OnStop ()
virtual void | OnStop ()
void | OnTimer ()
void | OnTimer ()
void | OnTimer ()
void | OnTimer ()
void | OnTimer ()
void | OnTimer ()
virtual void | ReactivateBacklight ()
virtual void | ReactivateBacklight ()
virtual void | ReactivateBacklight ()
virtual void | ReactivateBacklight ()
virtual void | ReactivateBacklight ()
virtual void | ReactivateBacklight ()
virtual void | ReactivatePower ()
virtual void | ReactivatePower ()
virtual void | ReactivatePower ()
virtual void | ReactivatePower ()
virtual void | ReactivatePower ()
virtual void | ReactivatePower ()
virtual void | Refresh (const CustomFrameBuffer *custom_frame_buf)
virtual void | Refresh ()
virtual void | Refresh (const CustomFrameBuffer *custom_frame_buf)
virtual void | Refresh ()
virtual void | Refresh (const CustomFrameBuffer *custom_frame_buf)
virtual void | Refresh ()
virtual void | Refresh (const CustomFrameBuffer *custom_frame_buf)
virtual void | Refresh ()
virtual void | Refresh (const CustomFrameBuffer *custom_frame_buf)
virtual void | Refresh ()
virtual void | Refresh (const CustomFrameBuffer *custom_frame_buf)
virtual void | Refresh ()
virtual void | SetBacklightMode (BacklightMode mode)
virtual void | SetBacklightMode (BacklightMode mode)
virtual void | SetBacklightMode (BacklightMode mode)
virtual void | SetBacklightMode (BacklightMode mode)
virtual void | SetBacklightMode (BacklightMode mode)
virtual void | SetBacklightMode (BacklightMode mode)
virtual void | SetBacklightTimeout (UINT32 timeout)
virtual void | SetBacklightTimeout (UINT32 timeout)
virtual void | SetBacklightTimeout (UINT32 timeout)
virtual void | SetBacklightTimeout (UINT32 timeout)
virtual void | SetBacklightTimeout (UINT32 timeout)
virtual void | SetBacklightTimeout (UINT32 timeout)
virtual void | SetBrightness (INT brightness)
virtual void | SetBrightness (INT brightness)
virtual void | SetBrightness (INT brightness)
virtual void | SetBrightness (INT brightness)
virtual void | SetBrightness (INT brightness)
virtual void | SetBrightness (INT brightness)
virtual void | SetCallbackActive (BOOLEAN state)
virtual void | SetCallbackActive (BOOLEAN state)
virtual void | SetCallbackActive (BOOLEAN state)
virtual void | SetCallbackActive (BOOLEAN state)
virtual void | SetCallbackActive (BOOLEAN state)
virtual void | SetContrast (INT contrast)
virtual void | SetContrast (INT contrast)
virtual void | SetContrast (INT contrast)
virtual void | SetContrast (INT contrast)
virtual void | SetContrast (INT contrast)
virtual void | SetContrast (INT contrast)
virtual void | SetCustomFrameBufferRect (const Rect &rect)
virtual void | SetCustomFrameBufferRect (const Rect &rect)
virtual void | SetCustomFrameBufferRect (const Rect &rect)
virtual void | SetPowerMode (PowerMode mode)
virtual void | SetPowerMode (PowerMode mode)
virtual void | SetPowerMode (PowerMode mode)
virtual void | SetPowerMode (PowerMode mode)
virtual void | SetPowerMode (PowerMode mode)
virtual void | SetPowerMode (PowerMode mode)
virtual void | SetPowerTimeout (UINT32 timeout)
virtual void | SetPowerTimeout (UINT32 timeout)
virtual void | SetPowerTimeout (UINT32 timeout)
virtual void | SetPowerTimeout (UINT32 timeout)
virtual void | SetPowerTimeout (UINT32 timeout)
virtual void | SetPowerTimeout (UINT32 timeout)
virtual | ~DefaultDisplay ()
virtual | ~DefaultDisplay ()
virtual | ~DefaultDisplay ()
virtual | ~DefaultDisplay ()
virtual | ~DefaultDisplay ()
virtual | ~DefaultDisplay ()

Static Public Member Functions

static void | SynchronizeBuffers ()
static void | SynchronizeBuffers ()
static void | SynchronizeBuffers ()
static void | SynchronizeBuffers ()
static void | SynchronizeBuffers ()

Friends

class | VideoChannel

Detailed Description

Provides methods for accessing the display in a generic way. For the application developer it is recommended to use the class DeviceContext for drawing operations. Using the display device directly is possible but it is important to know, that this approach bypasses the APOXI window system.

Constructor & Destructor Documentation

DefaultDisplay::DefaultDisplay ( INT index )

Parameters:
index Index of the display. Usually the main display has the index 0 and the sub display index 1.

DefaultDisplay::~DefaultDisplay ( ) [virtual]

DefaultDisplay::DefaultDisplay ( INT index )

Parameters:
index Index of the display. Usually the main display has the index 0 and the sub display index 1.

virtual DefaultDisplay::~DefaultDisplay ( ) [virtual]

DefaultDisplay::DefaultDisplay ( INT index )

Parameters:
index Index of the display. Usually the main display has the index 0 and the sub display index 1.

virtual DefaultDisplay::~DefaultDisplay ( ) [virtual]

DefaultDisplay::DefaultDisplay ( INT index )

Parameters:
index Index of the display. Usually the main display has the index 0 and the sub display index 1.

virtual DefaultDisplay::~DefaultDisplay ( ) [virtual]

DefaultDisplay::DefaultDisplay ( INT index )

Parameters:
index Index of the display. Usually the main display has the index 0 and the sub display index 1.

virtual DefaultDisplay::~DefaultDisplay ( ) [virtual]

DefaultDisplay::DefaultDisplay ( INT index )

Parameters:
index Index of the display. Usually the main display has the index 0 and the sub display index 1.

virtual DefaultDisplay::~DefaultDisplay ( ) [virtual]

Member Function Documentation

virtual BacklightMode DefaultDisplay::GetBacklightMode ( ) const [virtual]

See also:
Display::GetBacklightMode

Reimplemented from Display.

virtual BacklightMode DefaultDisplay::GetBacklightMode ( ) const [virtual]

See also:
Display::GetBacklightMode

Reimplemented from Display.

virtual BacklightMode DefaultDisplay::GetBacklightMode ( ) const [virtual]

See also:
Display::GetBacklightMode

Reimplemented from Display.

virtual BacklightMode DefaultDisplay::GetBacklightMode ( ) const [virtual]

See also:
Display::GetBacklightMode

Reimplemented from Display.

virtual BacklightMode DefaultDisplay::GetBacklightMode ( ) const [virtual]

See also:
Display::GetBacklightMode

Reimplemented from Display.

Display::BacklightMode DefaultDisplay::GetBacklightMode ( ) const [virtual]

See also:
Display::GetBacklightMode

Reimplemented from Display.

virtual INT DefaultDisplay::GetBrightness ( ) const [virtual]

See also:
Display::GetBrightness

Reimplemented from Display.

virtual INT DefaultDisplay::GetBrightness ( ) const [virtual]

See also:
Display::GetBrightness

Reimplemented from Display.

virtual INT DefaultDisplay::GetBrightness ( ) const [virtual]

See also:
Display::GetBrightness

Reimplemented from Display.

virtual INT DefaultDisplay::GetBrightness ( ) const [virtual]

See also:
Display::GetBrightness

Reimplemented from Display.

virtual INT DefaultDisplay::GetBrightness ( ) const [virtual]

See also:
Display::GetBrightness

Reimplemented from Display.

INT DefaultDisplay::GetBrightness ( ) const [virtual]

See also:
Display::GetBrightness

Reimplemented from Display.

virtual INT DefaultDisplay::GetContrast ( ) const [virtual]

See also:
Display::GetContrast

Reimplemented from Display.

virtual INT DefaultDisplay::GetContrast ( ) const [virtual]

See also:
Display::GetContrast

Reimplemented from Display.

virtual INT DefaultDisplay::GetContrast ( ) const [virtual]

See also:
Display::GetContrast

Reimplemented from Display.

virtual INT DefaultDisplay::GetContrast ( ) const [virtual]

See also:
Display::GetContrast

Reimplemented from Display.

virtual INT DefaultDisplay::GetContrast ( ) const [virtual]

See also:
Display::GetContrast

Reimplemented from Display.

INT DefaultDisplay::GetContrast ( ) const [virtual]

See also:
Display::GetContrast

Reimplemented from Display.

virtual const WCHAR* DefaultDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from VirtualDisplay.

virtual const WCHAR* DefaultDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from VirtualDisplay.

virtual const WCHAR* DefaultDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from VirtualDisplay.

virtual const WCHAR* DefaultDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from VirtualDisplay.

virtual const WCHAR* DefaultDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from VirtualDisplay.

const WCHAR * DefaultDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from VirtualDisplay.

virtual PowerMode DefaultDisplay::GetPowerMode ( ) const [virtual]

See also:
Displa::SetPowerMode

Reimplemented from Display.

virtual PowerMode DefaultDisplay::GetPowerMode ( ) const [virtual]

See also:
Displa::SetPowerMode

Reimplemented from Display.

virtual PowerMode DefaultDisplay::GetPowerMode ( ) const [virtual]

See also:
Displa::SetPowerMode

Reimplemented from Display.

virtual PowerMode DefaultDisplay::GetPowerMode ( ) const [virtual]

See also:
Displa::SetPowerMode

Reimplemented from Display.

virtual PowerMode DefaultDisplay::GetPowerMode ( ) const [virtual]

See also:
Displa::SetPowerMode

Reimplemented from Display.

Display::PowerMode DefaultDisplay::GetPowerMode ( ) const [virtual]

See also:
Displa::SetPowerMode

Reimplemented from Display.

virtual VideoChannel* DefaultDisplay::GetVideoChannel ( ) [virtual]

Returns a pointer to the video channel. It depends on the implementation of the device, whether a video channel is supported.

See also:
VideoChannel

Reimplemented from Display.

virtual VideoChannel* DefaultDisplay::GetVideoChannel ( ) [virtual]

Returns a pointer to the video channel. It depends on the implementation of the device, whether a video channel is supported.

See also:
VideoChannel

Reimplemented from Display.

virtual VideoChannel* DefaultDisplay::GetVideoChannel ( ) [virtual]

Returns a pointer to the video channel. It depends on the implementation of the device, whether a video channel is supported.

See also:
VideoChannel

Reimplemented from Display.

virtual VideoChannel* DefaultDisplay::GetVideoChannel ( ) [virtual]

Returns a pointer to the video channel. It depends on the implementation of the device, whether a video channel is supported.

See also:
VideoChannel

Reimplemented from Display.

virtual VideoChannel* DefaultDisplay::GetVideoChannel ( ) [virtual]

Returns a pointer to the video channel. It depends on the implementation of the device, whether a video channel is supported.

See also:
VideoChannel

Reimplemented from Display.

VideoChannel * DefaultDisplay::GetVideoChannel ( ) [virtual]

Returns a pointer to the video channel. It depends on the implementation of the device, whether a video channel is supported.

See also:
VideoChannel

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsBacklightOn ( ) const [virtual]

See also:
Display::IsBacklightOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsBacklightOn ( ) const [virtual]

See also:
Display::IsBacklightOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsBacklightOn ( ) const [virtual]

See also:
Display::IsBacklightOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsBacklightOn ( ) const [virtual]

See also:
Display::IsBacklightOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsBacklightOn ( ) const [virtual]

See also:
Display::IsBacklightOn

Reimplemented from Display.

BOOLEAN DefaultDisplay::IsBacklightOn ( ) const [virtual]

See also:
Display::IsBacklightOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsCallbackActive ( ) const [virtual]

See also:
Display::IsCallbackActive

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsCallbackActive ( ) const [virtual]

See also:
Display::IsCallbackActive

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsCallbackActive ( ) const [virtual]

See also:
Display::IsCallbackActive

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsCallbackActive ( ) const [virtual]

See also:
Display::IsCallbackActive

Reimplemented from Display.

BOOLEAN DefaultDisplay::IsCallbackActive ( ) const [virtual]

See also:
Display::IsCallbackActive

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsPowerOn ( ) const [virtual]

See also:
Display::IsPowerOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsPowerOn ( ) const [virtual]

See also:
Display::IsPowerOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsPowerOn ( ) const [virtual]

See also:
Display::IsPowerOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsPowerOn ( ) const [virtual]

See also:
Display::IsPowerOn

Reimplemented from Display.

virtual BOOLEAN DefaultDisplay::IsPowerOn ( ) const [virtual]

See also:
Display::IsPowerOn

Reimplemented from Display.

BOOLEAN DefaultDisplay::IsPowerOn ( ) const [virtual]

See also:
Display::IsPowerOn

Reimplemented from Display.

virtual void DefaultDisplay::OnStart ( ) [virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStart ( ) [virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStart ( ) [virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStart ( ) [virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStart ( ) [virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

void DefaultDisplay::OnStart ( ) [virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStop ( ) [virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStop ( ) [virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStop ( ) [virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStop ( ) [virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

virtual void DefaultDisplay::OnStop ( ) [virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

void DefaultDisplay::OnStop ( ) [virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

void DefaultDisplay::OnTimer ( )

Is invoked if the backlight or power has been timed out (see Display::SetBacklightTimeout and Display::SetPowerTimeout). The method should not invoked directly by the MMI and is public only to keep backward compatibility with older APOXI versions.

void DefaultDisplay::OnTimer ( )

Obsolete - is provided for backward compatibility with earlier APOXI releases. The display device does not do any timer handling, this should be done by the MMI.

void DefaultDisplay::OnTimer ( )

Obsolete - is provided for backward compatibility with earlier APOXI releases. The display device does not do any timer handling, this should be done by the MMI.

void DefaultDisplay::OnTimer ( )

Is invoked if the backlight or power has been timed out (see Display::SetBacklightTimeout and Display::SetPowerTimeout). The method should not invoked directly by the MMI and is public only to keep backward compatibility with older APOXI versions.

void DefaultDisplay::OnTimer ( )

Is invoked if the backlight or power has been timed out (see Display::SetBacklightTimeout and Display::SetPowerTimeout). The method should not invoked directly by the MMI and is public only to keep backward compatibility with older APOXI versions.

void DefaultDisplay::OnTimer ( )

Obsolete - is provided for backward compatibility with earlier APOXI releases. The display device does not do any timer handling, this should be done by the MMI.

virtual void DefaultDisplay::ReactivateBacklight ( ) [virtual]

See also:
Display::ReactivateBacklight

Reimplemented from Display.

virtual void DefaultDisplay::ReactivateBacklight ( ) [virtual]

See also:
Display::ReactivateBacklight

Reimplemented from Display.

virtual void DefaultDisplay::ReactivateBacklight ( ) [virtual]

See also:
Display::ReactivateBacklight

Reimplemented from Display.

virtual void DefaultDisplay::ReactivateBacklight ( ) [virtual]

See also:
Display::ReactivateBacklight

Reimplemented from Display.

virtual void DefaultDisplay::ReactivateBacklight ( ) [virtual]

See also:
Display::ReactivateBacklight

Reimplemented from Display.

void DefaultDisplay::ReactivateBacklight ( ) [virtual]

See also:
Display::ReactivateBacklight

Reimplemented from Display.

virtual void DefaultDisplay::ReactivatePower ( ) [virtual]

See also:
Display::ReactivatePower

Reimplemented from Display.

virtual void DefaultDisplay::ReactivatePower ( ) [virtual]

See also:
Display::ReactivatePower

Reimplemented from Display.

virtual void DefaultDisplay::ReactivatePower ( ) [virtual]

See also:
Display::ReactivatePower

Reimplemented from Display.

virtual void DefaultDisplay::ReactivatePower ( ) [virtual]

See also:
Display::ReactivatePower

Reimplemented from Display.

virtual void DefaultDisplay::ReactivatePower ( ) [virtual]

See also:
Display::ReactivatePower

Reimplemented from Display.

void DefaultDisplay::ReactivatePower ( ) [virtual]

See also:
Display::ReactivatePower

Reimplemented from Display.

virtual void DefaultDisplay::Refresh ( const CustomFrameBuffer * custom_frame_buf ) [virtual]

Refreshs the display area specified by the blitting-rectangle (see Display::SetBlitRect and Display::GetBlitRect). Whether the refreshing is done synchronous or asynchronous, depends on the capabilities of the low-level display device. Per default APOXI does not block when refreshing the display, hence block is set to FALSE. If the update should be done synchronous, set block to TRUE and APOXI will wait until the low-level display device has finished the refreshing.

Parameters:
custom_frame_buf Optional parameter which allows to pass a custom frame buffer for refreshing instead of using the internal frame buffer.

virtual void DefaultDisplay::Refresh ( ) [virtual]

See also:
VirtualDisplay::Refresh

Reimplemented from Display.

virtual void DefaultDisplay::Refresh ( const CustomFrameBuffer * custom_frame_buf ) [virtual]

Refreshs the display area specified by the blitting-rectangle (see Display::SetBlitRect and Display::GetBlitRect). Whether the refreshing is done synchronous or asynchronous, depends on the capabilities of the low-level display device. Per default APOXI does not block when refreshing the display, hence block is set to FALSE. If the update should be done synchronous, set block to TRUE and APOXI will wait until the low-level display device has finished the refreshing.

Parameters:
custom_frame_buf Optional parameter which allows to pass a custom frame buffer for refreshing instead of using the internal frame buffer.

virtual void DefaultDisplay::Refresh ( ) [virtual]

See also:
VirtualDisplay::Refresh

Reimplemented from Display.

virtual void DefaultDisplay::Refresh ( const CustomFrameBuffer * custom_frame_buf ) [virtual]

Refreshs the display area specified by the blitting-rectangle (see Display::SetBlitRect and Display::GetBlitRect). Whether the refreshing is done synchronous or asynchronous, depends on the capabilities of the low-level display device. Per default APOXI does not block when refreshing the display, hence block is set to FALSE. If the update should be done synchronous, set block to TRUE and APOXI will wait until the low-level display device has finished the refreshing.

Parameters:
custom_frame_buf Optional parameter which allows to pass a custom frame buffer for refreshing instead of using the internal frame buffer.

virtual void DefaultDisplay::Refresh ( ) [virtual]

See also:
VirtualDisplay::Refresh

Reimplemented from Display.

virtual void DefaultDisplay::Refresh ( const CustomFrameBuffer * custom_frame_buf ) [virtual]

Refreshs the display area specified by the blitting-rectangle (see Display::SetBlitRect and Display::GetBlitRect). Whether the refreshing is done synchronous or asynchronous, depends on the capabilities of the low-level display device. Per default APOXI does not block when refreshing the display, hence block is set to FALSE. If the update should be done synchronous, set block to TRUE and APOXI will wait until the low-level display device has finished the refreshing.

Parameters:
custom_frame_buf Optional parameter which allows to pass a custom frame buffer for refreshing instead of using the internal frame buffer.

virtual void DefaultDisplay::Refresh ( ) [virtual]

See also:
VirtualDisplay::Refresh

Reimplemented from Display.

virtual void DefaultDisplay::Refresh ( const CustomFrameBuffer * custom_frame_buf ) [virtual]

Refreshs the display area specified by the blitting-rectangle (see Display::SetBlitRect and Display::GetBlitRect). Whether the refreshing is done synchronous or asynchronous, depends on the capabilities of the low-level display device. Per default APOXI does not block when refreshing the display, hence block is set to FALSE. If the update should be done synchronous, set block to TRUE and APOXI will wait until the low-level display device has finished the refreshing.

Parameters:
custom_frame_buf Optional parameter which allows to pass a custom frame buffer for refreshing instead of using the internal frame buffer.

virtual void DefaultDisplay::Refresh ( ) [virtual]

See also:
VirtualDisplay::Refresh

Reimplemented from Display.

void DefaultDisplay::Refresh ( const CustomFrameBuffer * custom_frame_buf ) [virtual]

Refreshs the display area specified by the blitting-rectangle (see Display::SetBlitRect and Display::GetBlitRect). Whether the refreshing is done synchronous or asynchronous, depends on the capabilities of the low-level display device. Per default APOXI does not block when refreshing the display, hence block is set to FALSE. If the update should be done synchronous, set block to TRUE and APOXI will wait until the low-level display device has finished the refreshing.

Parameters:
custom_frame_buf Optional parameter which allows to pass a custom frame buffer for refreshing instead of using the internal frame buffer.

void DefaultDisplay::Refresh ( ) [virtual]

See also:
VirtualDisplay::Refresh

Reimplemented from Display.

virtual void DefaultDisplay::SetBacklightMode ( BacklightMode mode ) [virtual]

See also:
Display::SetBacklightMode.

virtual void DefaultDisplay::SetBacklightMode ( BacklightMode mode ) [virtual]

See also:
Display::SetBacklightMode.

virtual void DefaultDisplay::SetBacklightMode ( BacklightMode mode ) [virtual]

See also:
Display::SetBacklightMode.

virtual void DefaultDisplay::SetBacklightMode ( BacklightMode mode ) [virtual]

See also:
Display::SetBacklightMode.

virtual void DefaultDisplay::SetBacklightMode ( BacklightMode mode ) [virtual]

See also:
Display::SetBacklightMode.

void DefaultDisplay::SetBacklightMode ( BacklightMode mode ) [virtual]

See also:
Display::SetBacklightMode.

virtual void DefaultDisplay::SetBacklightTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetBacklightTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetBacklightTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetBacklightTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetBacklightTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetBacklightTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetBacklightTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetBacklightTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetBacklightTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetBacklightTimeout

Reimplemented from Display.

void DefaultDisplay::SetBacklightTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetBacklightTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetBrightness ( INT brightness ) [virtual]

See also:
Display::SetBrightness

Reimplemented from Display.

virtual void DefaultDisplay::SetBrightness ( INT brightness ) [virtual]

See also:
Display::SetBrightness

Reimplemented from Display.

virtual void DefaultDisplay::SetBrightness ( INT brightness ) [virtual]

See also:
Display::SetBrightness

Reimplemented from Display.

virtual void DefaultDisplay::SetBrightness ( INT brightness ) [virtual]

See also:
Display::SetBrightness

Reimplemented from Display.

virtual void DefaultDisplay::SetBrightness ( INT brightness ) [virtual]

See also:
Display::SetBrightness

Reimplemented from Display.

void DefaultDisplay::SetBrightness ( INT brightness ) [virtual]

See also:
Display::SetBrightness

Reimplemented from Display.

virtual void DefaultDisplay::SetCallbackActive ( BOOLEAN state ) [virtual]

See also:
Display::SetCallbackActive

Reimplemented from Display.

virtual void DefaultDisplay::SetCallbackActive ( BOOLEAN state ) [virtual]

See also:
Display::SetCallbackActive

Reimplemented from Display.

virtual void DefaultDisplay::SetCallbackActive ( BOOLEAN state ) [virtual]

See also:
Display::SetCallbackActive

Reimplemented from Display.

virtual void DefaultDisplay::SetCallbackActive ( BOOLEAN state ) [virtual]

See also:
Display::SetCallbackActive

Reimplemented from Display.

void DefaultDisplay::SetCallbackActive ( BOOLEAN state ) [virtual]

See also:
Display::SetCallbackActive

Reimplemented from Display.

virtual void DefaultDisplay::SetContrast ( INT contrast ) [virtual]

See also:
Display::SetContrast

Reimplemented from Display.

virtual void DefaultDisplay::SetContrast ( INT contrast ) [virtual]

See also:
Display::SetContrast

Reimplemented from Display.

virtual void DefaultDisplay::SetContrast ( INT contrast ) [virtual]

See also:
Display::SetContrast

Reimplemented from Display.

virtual void DefaultDisplay::SetContrast ( INT contrast ) [virtual]

See also:
Display::SetContrast

Reimplemented from Display.

virtual void DefaultDisplay::SetContrast ( INT contrast ) [virtual]

See also:
Display::SetContrast

Reimplemented from Display.

void DefaultDisplay::SetContrast ( INT contrast ) [virtual]

See also:
Display::SetContrast

Reimplemented from Display.

virtual void DefaultDisplay::SetCustomFrameBufferRect ( const Rect & rect ) [virtual]

See also:
Display::SetCustomFrameBufferRect

Reimplemented from Display.

virtual void DefaultDisplay::SetCustomFrameBufferRect ( const Rect & rect ) [virtual]

See also:
Display::SetCustomFrameBufferRect

Reimplemented from Display.

void DefaultDisplay::SetCustomFrameBufferRect ( const Rect & rect ) [virtual]

See also:
Display::SetCustomFrameBufferRect

Reimplemented from Display.

virtual void DefaultDisplay::SetPowerMode ( PowerMode mode ) [virtual]

See also:
Display::SetPowerMode

virtual void DefaultDisplay::SetPowerMode ( PowerMode mode ) [virtual]

See also:
Display::SetPowerMode

virtual void DefaultDisplay::SetPowerMode ( PowerMode mode ) [virtual]

See also:
Display::SetPowerMode

virtual void DefaultDisplay::SetPowerMode ( PowerMode mode ) [virtual]

See also:
Display::SetPowerMode

virtual void DefaultDisplay::SetPowerMode ( PowerMode mode ) [virtual]

See also:
Display::SetPowerMode

void DefaultDisplay::SetPowerMode ( PowerMode mode ) [virtual]

See also:
Display::SetPowerMode

virtual void DefaultDisplay::SetPowerTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetPowerTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetPowerTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetPowerTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetPowerTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetPowerTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetPowerTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetPowerTimeout

Reimplemented from Display.

virtual void DefaultDisplay::SetPowerTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetPowerTimeout

Reimplemented from Display.

void DefaultDisplay::SetPowerTimeout ( UINT32 timeout ) [virtual]

See also:
Display::SetPowerTimeout

Reimplemented from Display.

static void DefaultDisplay::SynchronizeBuffers ( ) [static]

static void DefaultDisplay::SynchronizeBuffers ( ) [static]

static void DefaultDisplay::SynchronizeBuffers ( ) [static]

static void DefaultDisplay::SynchronizeBuffers ( ) [static]

void DefaultDisplay::SynchronizeBuffers ( ) [static]

Friends And Related Function Documentation

VideoChannel [friend]

The documentation for this class was generated from the following files:
  • Devices/BP30/DefaultDisplay.hpp
  • Devices/MPE/DefaultDisplay.hpp
  • Devices/MPEU/DefaultDisplay.hpp
  • Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.hpp
  • Devices/SGold/DefaultDisplay.hpp
  • Devices/Win32/DefaultDisplay.hpp
  • Devices/BP30/DefaultDisplay.cpp
  • Devices/MPE/DefaultDisplay.cpp
  • Devices/MPEU/DefaultDisplay.cpp
  • Devices/MPEU/Extensions/AtiW2282/DefaultDisplay.cpp
  • Devices/SGold/DefaultDisplay.cpp
  • Devices/Win32/DefaultDisplay.cpp
Generated on Wed Jan 25 01:10:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultItemRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultItemRenderer Class Reference
[GUI]

#include <Apoxi/Gui/DefaultItemRenderer.hpp>

Inheritance diagram for DefaultItemRenderer:

[legend]
Collaboration diagram for DefaultItemRenderer:

[legend]

Public Member Functions

DefaultItemRenderer (const ItemRendererProperties *properties=0)
virtual void | DrawBackground (DeviceContext *dc, const Item &item, const Rect &bounds, INT item_style) const
virtual void | DrawItem (DeviceContext *dc, const Item &item, const Rect &bounds, INT item_style) const
virtual Rect | GetIconRect (const Item &item, const Rect &bounds) const
virtual IconState::Size | GetIconSizeState (INT item_style=DefaultStyle) const
virtual XYDIM | GetItemHeight (INT item_style=DefaultStyle) const
virtual BOOLEAN | ScrollText () const
virtual BOOLEAN | StartTextScrolling (const Item &item, const Rect &bounds) const
virtual void | StopTextScrolling (const Item &item) const
virtual | ~DefaultItemRenderer ()

Protected Member Functions

virtual void | DrawText (DeviceContext *dc, const Item &item, const Rect &text_rect, INT item_style) const

Detailed Description

The default item renderer respects all item renderer properties (see class ItemRendererProperties) and automatically scrolls the text of the selected item, if it does not fit into the boundaries.

Constructor & Destructor Documentation

DefaultItemRenderer::DefaultItemRenderer ( const ItemRendererProperties * properties = 0 )

Parameters:
properties Pointer to the item renderer properties, which define the look of the items.

DefaultItemRenderer::~DefaultItemRenderer ( ) [virtual]

Member Function Documentation

void DefaultItemRenderer::DrawBackground | ( | DeviceContext * | dc,
 |  | const Item & | item,
 |  | const Rect & | bounds,
 |  | INT | item_style
 | ) | const [virtual]

See also:
AbstractItemRenderer::DrawBackground

Implements AbstractItemRenderer.

Reimplemented in AtlItemRenderer.

void DefaultItemRenderer::DrawItem | ( | DeviceContext * | dc,
 |  | const Item & | item,
 |  | const Rect & | bounds,
 |  | INT | item_style
 | ) | const [virtual]

See also:
AbstractItemRenderer::DrawItem

Implements AbstractItemRenderer.

Reimplemented in AtlItemRenderer.

void DefaultItemRenderer::DrawText | ( | DeviceContext * | dc,
 |  | const Item & | item,
 |  | const Rect & | text_rect,
 |  | INT | item_style
 | ) | const [protected, virtual]

Draws the text of the item inside the given text rectangle. This method is invoked by DefaultItemRenderer::DrawItem and may be overwritten if the rendering of the text should be adjusted to custom requirements.

Parameters:
dc | Device context where the drawing is done.
item | Item which should be drawn.
text_rect | Bounding rectangle of the text. The rectangle is already adjusted to respect the icon, the border gap and an optional indicator.
item_style | Style of the item (see AbstractItemRenderer::ItemStyle).

Rect DefaultItemRenderer::GetIconRect | ( | const Item & | item,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AbstractItemRenderer::GetIconRect

Implements AbstractItemRenderer.

Reimplemented in AtlItemRenderer.

IconState::Size DefaultItemRenderer::GetIconSizeState ( INT item_style = DefaultStyle ) const [virtual]

See also:
AbstractItemRenderer::GetIconSizeState

Reimplemented from AbstractItemRenderer.

XYDIM DefaultItemRenderer::GetItemHeight ( INT item_style = DefaultStyle ) const [virtual]

See also:
AbstractItemRenderer::GetItemHeight

Implements AbstractItemRenderer.

BOOLEAN DefaultItemRenderer::ScrollText ( ) const [virtual]

See also:
AbstractItemRenderer::ScrollText

Reimplemented from AbstractItemRenderer.

BOOLEAN DefaultItemRenderer::StartTextScrolling | ( | const Item & | item,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AbstractItemRenderer::StartTextScrolling

Reimplemented from AbstractItemRenderer.

Reimplemented in AtlItemRenderer.

void DefaultItemRenderer::StopTextScrolling ( const Item & item ) const [virtual]

See also:
AbstractItemRenderer::StopTextScrolling

Reimplemented from AbstractItemRenderer.

Reimplemented in AtlItemRenderer.

The documentation for this class was generated from the following files:
  • Gui/DefaultItemRenderer.hpp
  • Gui/DefaultItemRenderer.cpp
Generated on Wed Jan 25 01:10:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultPanelView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultPanelView Class Reference

#include <Apoxi/GlobalThemes/DefaultTheme/DefaultPanelView.hpp>

Inheritance diagram for DefaultPanelView:

[legend]
Collaboration diagram for DefaultPanelView:

[legend]

Public Member Functions

virtual void | Update (const Theme &theme)
virtual | ~DefaultPanelView ()

Protected Member Functions

virtual void | DrawPanel (const Panel &panel, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

DefaultPanelView::~DefaultPanelView ( ) [virtual]

Member Function Documentation

void DefaultPanelView::DrawPanel | ( | const Panel & | panel,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PanelView.

void DefaultPanelView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • GlobalThemes/DefaultTheme/DefaultPanelView.hpp
  • GlobalThemes/DefaultTheme/DefaultPanelView.cpp
Generated on Wed Jan 25 01:10:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultPositionIndicatorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultPositionIndicatorView Class Reference

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp>

Inheritance diagram for DefaultPositionIndicatorView:

[legend]
Collaboration diagram for DefaultPositionIndicatorView:

[legend]

Public Member Functions

DefaultPositionIndicatorView (XYDIM size)
DefaultPositionIndicatorView ()
DefaultPositionIndicatorView (XYDIM size)
DefaultPositionIndicatorView ()
virtual | ~DefaultPositionIndicatorView ()
virtual | ~DefaultPositionIndicatorView ()

Protected Member Functions

virtual void | DrawPositionIndicator (const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawPositionIndicator (const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

DefaultPositionIndicatorView::DefaultPositionIndicatorView ( )

DefaultPositionIndicatorView::DefaultPositionIndicatorView ( XYDIM size ) [explicit]

virtual DefaultPositionIndicatorView::~DefaultPositionIndicatorView ( ) [inline, virtual]

DefaultPositionIndicatorView::DefaultPositionIndicatorView ( )

DefaultPositionIndicatorView::DefaultPositionIndicatorView ( XYDIM size ) [explicit]

virtual DefaultPositionIndicatorView::~DefaultPositionIndicatorView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultPositionIndicatorView::DrawPositionIndicator | ( | const PositionIndicator & | pos_ind,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a position indicator described by the model. Must be implemented in the corresponding theme view.

Parameters:
pos_ind | Position-Indicator which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements PositionIndicatorView.

void DefaultPositionIndicatorView::DrawPositionIndicator | ( | const PositionIndicator & | pos_ind,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a position indicator described by the model. Must be implemented in the corresponding theme view.

Parameters:
pos_ind | Position-Indicator which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements PositionIndicatorView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp
  • GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.cpp
  • GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.cpp
Generated on Wed Jan 25 01:10:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultProgressBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultProgressBarView Class Reference

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp>

Inheritance diagram for DefaultProgressBarView:

[legend]
Collaboration diagram for DefaultProgressBarView:

[legend]

Public Member Functions

DefaultProgressBarView (XYDIM default_height)
DefaultProgressBarView ()
DefaultProgressBarView (XYDIM default_height)
DefaultProgressBarView ()
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultProgressBarView ()
virtual | ~DefaultProgressBarView ()

Protected Member Functions

virtual void | DrawProgressBar (const ProgressBar &progress_bar, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawProgressBar (const ProgressBar &progress_bar, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

DefaultProgressBarView::DefaultProgressBarView ( )

DefaultProgressBarView::DefaultProgressBarView ( XYDIM default_height ) [explicit]

virtual DefaultProgressBarView::~DefaultProgressBarView ( ) [inline, virtual]

DefaultProgressBarView::DefaultProgressBarView ( )

DefaultProgressBarView::DefaultProgressBarView ( XYDIM default_height ) [explicit]

virtual DefaultProgressBarView::~DefaultProgressBarView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultProgressBarView::DrawProgressBar | ( | const ProgressBar & | progress_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements ProgressBarView.

void DefaultProgressBarView::DrawProgressBar | ( | const ProgressBar & | progress_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements ProgressBarView.

virtual void DefaultProgressBarView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

void DefaultProgressBarView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp
  • GlobalThemes/DefaultTheme/DefaultProgressBarView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultProgressBarView.cpp
  • GlobalThemes/DefaultTheme/DefaultProgressBarView.cpp
Generated on Wed Jan 25 01:10:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultPushButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultPushButtonView Class Reference

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp>

Inheritance diagram for DefaultPushButtonView:

[legend]
Collaboration diagram for DefaultPushButtonView:

[legend]

Public Member Functions

DefaultPushButtonView (XYDIM default_height)
DefaultPushButtonView ()
DefaultPushButtonView (XYDIM default_height)
DefaultPushButtonView ()
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultPushButtonView ()
virtual | ~DefaultPushButtonView ()

Protected Member Functions

virtual void | DrawPushButton (const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawPushButton (const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

DefaultPushButtonView::DefaultPushButtonView ( )

DefaultPushButtonView::DefaultPushButtonView ( XYDIM default_height ) [explicit]

virtual DefaultPushButtonView::~DefaultPushButtonView ( ) [inline, virtual]

DefaultPushButtonView::DefaultPushButtonView ( )

DefaultPushButtonView::DefaultPushButtonView ( XYDIM default_height ) [explicit]

virtual DefaultPushButtonView::~DefaultPushButtonView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultPushButtonView::DrawPushButton | ( | const PushButton & | push_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PushButtonView.

void DefaultPushButtonView::DrawPushButton | ( | const PushButton & | push_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PushButtonView.

virtual void DefaultPushButtonView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

void DefaultPushButtonView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp
  • GlobalThemes/DefaultTheme/DefaultPushButtonView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultPushButtonView.cpp
  • GlobalThemes/DefaultTheme/DefaultPushButtonView.cpp
Generated on Wed Jan 25 01:10:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultRadioButtonListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultRadioButtonListView Class Reference

Obsolete since APOXI-1.6.2. More...

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp>

Inheritance diagram for DefaultRadioButtonListView:

[legend]
Collaboration diagram for DefaultRadioButtonListView:

[legend]

Public Member Functions

DefaultRadioButtonListView (const RadioButtonView *rb_view, XYDIM item_height)
DefaultRadioButtonListView ()
DefaultRadioButtonListView (const RadioButtonView *rb_view, XYDIM item_height)
DefaultRadioButtonListView ()
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultRadioButtonListView ()
virtual | ~DefaultRadioButtonListView ()

Protected Member Functions

virtual void | DrawRadioButtonItem (const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const
virtual void | DrawRadioButtonItem (const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const

Detailed Description

Obsolete since APOXI-1.6.2.

Constructor & Destructor Documentation

DefaultRadioButtonListView::DefaultRadioButtonListView ( )

DefaultRadioButtonListView::DefaultRadioButtonListView | ( | const RadioButtonView * | rb_view,
 |  | XYDIM | item_height
 | ) |

virtual DefaultRadioButtonListView::~DefaultRadioButtonListView ( ) [inline, virtual]

DefaultRadioButtonListView::DefaultRadioButtonListView ( )

DefaultRadioButtonListView::DefaultRadioButtonListView | ( | const RadioButtonView * | rb_view,
 |  | XYDIM | item_height
 | ) |

virtual DefaultRadioButtonListView::~DefaultRadioButtonListView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultRadioButtonListView::DrawRadioButtonItem | ( | const RadioButtonItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

Implements RadioButtonListView.

void DefaultRadioButtonListView::DrawRadioButtonItem | ( | const RadioButtonItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

Implements RadioButtonListView.

virtual void DefaultRadioButtonListView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

void DefaultRadioButtonListView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp
  • GlobalThemes/DefaultTheme/DefaultRadioButtonListView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonListView.cpp
  • GlobalThemes/DefaultTheme/DefaultRadioButtonListView.cpp
Generated on Wed Jan 25 01:10:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultRadioButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultRadioButtonView Class Reference

Obsolete since APOXI-1.6.2. More...

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp>

Inheritance diagram for DefaultRadioButtonView:

[legend]
Collaboration diagram for DefaultRadioButtonView:

[legend]

Public Member Functions

DefaultRadioButtonView (XYDIM item_height, XYDIM left_gap, XYDIM middle_gap)
DefaultRadioButtonView ()
DefaultRadioButtonView (XYDIM item_height, XYDIM left_gap, XYDIM middle_gap)
DefaultRadioButtonView ()
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultRadioButtonView ()
virtual | ~DefaultRadioButtonView ()

Protected Member Functions

virtual void | DrawRadioButton (const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawRadioButton (const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShiftedRadioButton (const Rect &shift_rect, const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShiftedRadioButton (const Rect &shift_rect, const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Detailed Description

Obsolete since APOXI-1.6.2.

Constructor & Destructor Documentation

DefaultRadioButtonView::DefaultRadioButtonView ( )

DefaultRadioButtonView::DefaultRadioButtonView | ( | XYDIM | item_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

virtual DefaultRadioButtonView::~DefaultRadioButtonView ( ) [inline, virtual]

DefaultRadioButtonView::DefaultRadioButtonView ( )

DefaultRadioButtonView::DefaultRadioButtonView | ( | XYDIM | item_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

virtual DefaultRadioButtonView::~DefaultRadioButtonView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultRadioButtonView::DrawRadioButton | ( | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements RadioButtonView.

void DefaultRadioButtonView::DrawRadioButton | ( | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements RadioButtonView.

virtual void DefaultRadioButtonView::DrawShiftedRadioButton | ( | const Rect & | shift_rect,
 |  | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements RadioButtonView.

void DefaultRadioButtonView::DrawShiftedRadioButton | ( | const Rect & | shift_rect,
 |  | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements RadioButtonView.

virtual void DefaultRadioButtonView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

void DefaultRadioButtonView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp
  • GlobalThemes/DefaultTheme/DefaultRadioButtonView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultRadioButtonView.cpp
  • GlobalThemes/DefaultTheme/DefaultRadioButtonView.cpp
Generated on Wed Jan 25 01:10:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultSoftkeyBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultSoftkeyBarView Class Reference

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp>

Inheritance diagram for DefaultSoftkeyBarView:

[legend]
Collaboration diagram for DefaultSoftkeyBarView:

[legend]

Public Member Functions

virtual | ~DefaultSoftkeyBarView ()
virtual | ~DefaultSoftkeyBarView ()

Protected Member Functions

virtual void | DrawSoftkeyBar (const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawSoftkeyBar (const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

virtual DefaultSoftkeyBarView::~DefaultSoftkeyBarView ( ) [inline, virtual]

virtual DefaultSoftkeyBarView::~DefaultSoftkeyBarView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultSoftkeyBarView::DrawSoftkeyBar | ( | const SoftkeyBar & | softkey_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the Softkey-Bar. Must be implemented in the corresponding theme view.

Parameters:
softkey_bar | Softkey-Bar which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements SoftkeyBarView.

void DefaultSoftkeyBarView::DrawSoftkeyBar | ( | const SoftkeyBar & | softkey_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the Softkey-Bar. Must be implemented in the corresponding theme view.

Parameters:
softkey_bar | Softkey-Bar which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements SoftkeyBarView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp
  • GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.cpp
  • GlobalThemes/DefaultTheme/DefaultSoftkeyBarView.cpp
Generated on Wed Jan 25 01:10:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultTabButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultTabButtonView Class Reference

Implements the drawing of the TabButton. More...

#include <Apoxi/GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp>

Inheritance diagram for DefaultTabButtonView:

[legend]
Collaboration diagram for DefaultTabButtonView:

[legend]

Public Member Functions

DefaultTabButtonView (XYDIM default_height, XYDIM default_width=-1, XYDIM min_width=-1, XYDIM max_width=-1, XYDIM clipped_width=20)
virtual | ~DefaultTabButtonView ()

Protected Member Functions

virtual void | DrawTabButton (const TabButton &tab_button, DeviceContext *dc, const Rect &repaint_rect) const

Detailed Description

Implements the drawing of the TabButton.

Constructor & Destructor Documentation

DefaultTabButtonView::DefaultTabButtonView | ( | XYDIM | default_height,
 |  | XYDIM | default_width = -1,
 |  | XYDIM | min_width = -1,
 |  | XYDIM | max_width = -1,
 |  | XYDIM | clipped_width = 20
 | ) |

See also:
TabButtonView::TabButtonView

DefaultTabButtonView::~DefaultTabButtonView ( ) [virtual]

Member Function Documentation

void DefaultTabButtonView::DrawTabButton | ( | const TabButton & | tab_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

See also:
TabButtonView::DrawTabButton

Implements TabButtonView.

The documentation for this class was generated from the following files:
  • GlobalThemes/DefaultTheme/DefaultTabButtonView.hpp
  • GlobalThemes/DefaultTheme/DefaultTabButtonView.cpp
Generated on Wed Jan 25 01:10:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultTabControlView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultTabControlView Class Reference

Implements the drawing of the TabControl. More...

#include <Apoxi/GlobalThemes/DefaultTheme/DefaultTabControlView.hpp>

Inheritance diagram for DefaultTabControlView:

[legend]
Collaboration diagram for DefaultTabControlView:

[legend]

Public Member Functions

DefaultTabControlView (XYDIM border_size, XYDIM header_height=-1)
virtual | ~DefaultTabControlView ()

Protected Member Functions

virtual void | DrawTabControl (const TabControl &tab_control, DeviceContext *dc, const Rect &repaint_rect) const

Detailed Description

Implements the drawing of the TabControl.

Constructor & Destructor Documentation

DefaultTabControlView::DefaultTabControlView | ( | XYDIM | border_size,
 |  | XYDIM | header_height = -1
 | ) |

See also:
TabControlView::TabControlView

DefaultTabControlView::~DefaultTabControlView ( ) [virtual]

Member Function Documentation

void DefaultTabControlView::DrawTabControl | ( | const TabControl & | tab_control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

See also:
TabControlView::DrawTabControl

Implements TabControlView.

The documentation for this class was generated from the following files:
  • GlobalThemes/DefaultTheme/DefaultTabControlView.hpp
  • GlobalThemes/DefaultTheme/DefaultTabControlView.cpp
Generated on Wed Jan 25 01:10:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultTextListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultTextListView Class Reference

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultTextListView.hpp>

Inheritance diagram for DefaultTextListView:

[legend]
Collaboration diagram for DefaultTextListView:

[legend]

Public Member Functions

DefaultTextListView (XYDIM item_height)
DefaultTextListView ()
DefaultTextListView (XYDIM item_height)
DefaultTextListView ()
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultTextListView ()
virtual | ~DefaultTextListView ()

Protected Member Functions

virtual void | DrawTextListItem (const TextList &text_list, DeviceContext *dc, INT index, const Rect &item_rect) const
virtual void | DrawTextListItem (const TextList &text_list, DeviceContext *dc, INT index, const Rect &item_rect) const

Constructor & Destructor Documentation

DefaultTextListView::DefaultTextListView ( )

DefaultTextListView::DefaultTextListView ( XYDIM item_height ) [explicit]

virtual DefaultTextListView::~DefaultTextListView ( ) [inline, virtual]

DefaultTextListView::DefaultTextListView ( )

DefaultTextListView::DefaultTextListView ( XYDIM item_height ) [explicit]

virtual DefaultTextListView::~DefaultTextListView ( ) [inline, virtual]

Member Function Documentation

virtual void DefaultTextListView::DrawTextListItem | ( | const TextList & | text_list,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [protected, virtual]

Implements TextListView.

void DefaultTextListView::DrawTextListItem | ( | const TextList & | text_list,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [protected, virtual]

Implements TextListView.

virtual void DefaultTextListView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

void DefaultTextListView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultTextListView.hpp
  • GlobalThemes/DefaultTheme/DefaultTextListView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultTextListView.cpp
  • GlobalThemes/DefaultTheme/DefaultTextListView.cpp
Generated on Wed Jan 25 01:10:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultTheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultTheme Class Reference

Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultTheme.hpp>

Inheritance diagram for DefaultTheme:

[legend]
Collaboration diagram for DefaultTheme:

[legend]

Public Member Functions

DefaultTheme ()
virtual const BitmapRes * | GetBitmap (BitmapResId id) const
virtual const CheckBoxListView * | GetCheckBoxListView () const
virtual const CheckBoxView * | GetCheckBoxView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const WCHAR * | GetName () const
Returns the name of the theme. Per default 0 is returned.
virtual const PanelView * | GetPanelView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const RadioButtonListView * | GetRadioButtonListView () const
virtual const RadioButtonView * | GetRadioButtonView () const
virtual const SoftkeyBarView * | GetSoftkeyBarView () const
virtual const ColorTable * | GetSystemColorTable () const
virtual const ColorTable * | GetSystemColorTable () const
virtual const TabButtonView * | GetTabButtonView () const
virtual const TabControlView * | GetTabControlView () const
virtual const TextListView * | GetTextListView () const
virtual const WindowFrameView * | GetWindowFrameView () const
virtual const WindowFrameView * | GetWindowFrameView () const
virtual void | Update ()
void | Update ()
virtual | ~DefaultTheme ()
virtual | ~DefaultTheme ()

Static Public Member Functions

static const Theme & | GetInstance ()

Detailed Description

Obsolete theme - replaced by themes in Apoxi/GlobalThemes.

Constructor & Destructor Documentation

DefaultTheme::DefaultTheme ( )

DefaultTheme::~DefaultTheme ( ) [virtual]

virtual DefaultTheme::~DefaultTheme ( ) [virtual]

Member Function Documentation

const BitmapRes * DefaultTheme::GetBitmap ( BitmapResId id ) const [virtual]

const CheckBoxListView * DefaultTheme::GetCheckBoxListView ( ) const [virtual]

const CheckBoxView * DefaultTheme::GetCheckBoxView ( ) const [virtual]

virtual const ControlFrameView* DefaultTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const ControlFrameView * DefaultTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const Theme & DefaultTheme::GetInstance ( ) [static]

const WCHAR * DefaultTheme::GetName ( ) const [virtual]

Returns the name of the theme. Per default 0 is returned.

Reimplemented from Theme.

const PanelView * DefaultTheme::GetPanelView ( ) const [virtual]

Returns a pointer to a panel view, which is used to draw an instance of the class Panel. The panel usually is aligned at the bottom of the desktop and shows the softkeys.

Reimplemented from Theme.

virtual const PositionIndicatorView* DefaultTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

const PositionIndicatorView * DefaultTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

virtual const ProgressBarView* DefaultTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

const ProgressBarView * DefaultTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

virtual const PushButtonView* DefaultTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const PushButtonView * DefaultTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const RadioButtonListView * DefaultTheme::GetRadioButtonListView ( ) const [virtual]

const RadioButtonView * DefaultTheme::GetRadioButtonView ( ) const [virtual]

const SoftkeyBarView * DefaultTheme::GetSoftkeyBarView ( ) const [virtual]

virtual const ColorTable* DefaultTheme::GetSystemColorTable ( ) const [virtual]

Returns a pointer to the color-table of the system-colors. This method should be overwritten by derived themes providing a pointer to a custom color-table. To stay backward-compatible with older versions of APOXI, 0 is returned in the default-implementation.

Reimplemented from Theme.

const ColorTable * DefaultTheme::GetSystemColorTable ( ) const [virtual]

Returns a pointer to the color-table of the system-colors. This method should be overwritten by derived themes providing a pointer to a custom color-table. To stay backward-compatible with older versions of APOXI, 0 is returned in the default-implementation.

Reimplemented from Theme.

const TabButtonView * DefaultTheme::GetTabButtonView ( ) const [virtual]

Returns a pointer to a tab button view, which is used to draw an instance of the class TabButton. A tab button is embedded inside a tab control.

Reimplemented from Theme.

const TabControlView * DefaultTheme::GetTabControlView ( ) const [virtual]

Returns a pointer to a tab control view, which is used to draw an instance of the class TabControl.

Reimplemented from Theme.

const TextListView * DefaultTheme::GetTextListView ( ) const [virtual]

virtual const WindowFrameView* DefaultTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

const WindowFrameView * DefaultTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

virtual void DefaultTheme::Update ( ) [virtual]

Converts all colors given by the system-color-table to system-colors and invokes View::Update(this) for every View which is part of the theme. Also the fonts are updated which may be specified by ThemeConfig::GetFontId().

Reimplemented from Theme.

void DefaultTheme::Update ( ) [virtual]

Converts all colors given by the system-color-table to system-colors and invokes View::Update(this) for every View which is part of the theme. Also the fonts are updated which may be specified by ThemeConfig::GetFontId().

Reimplemented from Theme.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultTheme.hpp
  • GlobalThemes/DefaultTheme/DefaultTheme.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultTheme.cpp
  • GlobalThemes/DefaultTheme/DefaultTheme.cpp
Generated on Wed Jan 25 01:10:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DefaultWindowFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DefaultWindowFrameView Class Reference

#include <Apoxi/Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp>

Inheritance diagram for DefaultWindowFrameView:

[legend]
Collaboration diagram for DefaultWindowFrameView:

[legend]

Public Member Functions

DefaultWindowFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size, XYDIM title_height, XYDIM softkey_bar_height)
DefaultWindowFrameView ()
DefaultWindowFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size, XYDIM title_height, XYDIM softkey_bar_height)
DefaultWindowFrameView ()
virtual void | DrawClientAreaBackground (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | Update (const Theme &theme)
virtual void | Update (const Theme &theme)
virtual | ~DefaultWindowFrameView ()
virtual | ~DefaultWindowFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawWindowExtensions (const Window &window, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawWindowExtensions (const Window &window, DeviceContext *dc, const Rect &repaint_rect) const

Detailed Description

Implements the window frame view for the default APOXI theme.

Constructor & Destructor Documentation

DefaultWindowFrameView::DefaultWindowFrameView ( )

DefaultWindowFrameView::DefaultWindowFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size,
 |  | XYDIM | title_height,
 |  | XYDIM | softkey_bar_height
 | ) |

DefaultWindowFrameView::~DefaultWindowFrameView ( ) [virtual]

DefaultWindowFrameView::DefaultWindowFrameView ( )

DefaultWindowFrameView::DefaultWindowFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size,
 |  | XYDIM | title_height,
 |  | XYDIM | softkey_bar_height
 | ) |

virtual DefaultWindowFrameView::~DefaultWindowFrameView ( ) [virtual]

Member Function Documentation

void DefaultWindowFrameView::DrawClientAreaBackground | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
ControlFrameView::DrawClientAreaBackground

Reimplemented from ControlFrameView.

virtual void DefaultWindowFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

void DefaultWindowFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

virtual void DefaultWindowFrameView::DrawWindowExtensions | ( | const Window & | window,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

See also:
ControlFrameView::DrawWindowExenstions

Implements WindowFrameView.

void DefaultWindowFrameView::DrawWindowExtensions | ( | const Window & | window,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

See also:
ControlFrameView::DrawWindowExenstions

Implements WindowFrameView.

virtual void DefaultWindowFrameView::Update ( const Theme & theme ) [virtual]

See also:
View::Update

Reimplemented from View.

void DefaultWindowFrameView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp
  • GlobalThemes/DefaultTheme/DefaultWindowFrameView.hpp
  • Compat/GlobalThemes/DefaultTheme/DefaultWindowFrameView.cpp
  • GlobalThemes/DefaultTheme/DefaultWindowFrameView.cpp
Generated on Wed Jan 25 01:11:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DelegationProviderListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DelegationProviderListener Class Reference

#include <Apoxi/Auxiliary/AbstractDelegationProvider.hpp>

Inheritance diagram for DelegationProviderListener:

[legend]
Collaboration diagram for DelegationProviderListener:

[legend]

Public Member Functions

DelegationProviderListener (AbstractDelegationProvider *provider, ProviderListener *child_listener)
virtual void | OnExecuting ()
virtual | ~DelegationProviderListener ()

Detailed Description

For internal use in derived classes of DelegationProvider to handle a accurate progress indication. Delegates only OnExecuting to the child-listener. OnStarted and OnFinished on the child-listener should be invoked directly by the DelegationProvider.

Constructor & Destructor Documentation

DelegationProviderListener::DelegationProviderListener | ( | AbstractDelegationProvider * | provider,
 |  | ProviderListener * | child_listener
 | ) |

DelegationProviderListener::~DelegationProviderListener ( ) [virtual]

Member Function Documentation

void DelegationProviderListener::OnExecuting ( ) [virtual]

Will be called during execution. Calls OnExecutingListener to modify the progress value before the OnExecuting method of the child-listener is invoked.

Reimplemented from ProviderListener.

The documentation for this class was generated from the following files:
  • Auxiliary/AbstractDelegationProvider.hpp
  • Auxiliary/AbstractDelegationProvider.cpp
Generated on Wed Jan 25 01:11:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DeleteComponentMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DeleteComponentMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for DeleteComponentMsg:

[legend]
Collaboration diagram for DeleteComponentMsg:

[legend]

Public Types

enum | { ID = 1127 }

Public Member Functions

virtual Message * | Clone () const
DeleteComponentMsg (ExecutionContext *context, Component *component)
Component * | GetComponent () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~DeleteComponentMsg ()

Detailed Description

This message is send asynchronously by Component::DeleteLater to allow deleting of a component inside e. g. Window::OnClose. The deleting itself is done by the application.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DeleteComponentMsg::DeleteComponentMsg | ( | ExecutionContext * | context,
 |  | Component * | component
 | ) |

DeleteComponentMsg::~DeleteComponentMsg ( ) [virtual]

Member Function Documentation

Message * DeleteComponentMsg::Clone ( ) const [virtual]

Implements Message.

Component* DeleteComponentMsg::GetComponent ( ) const [inline]

const MsgMetaData & DeleteComponentMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:11:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DeletedNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DeletedNode Class Reference
[Afs]

#include <Apoxi/Afs/DeletedNode.hpp>

Collaboration diagram for DeletedNode:

[legend]

Public Member Functions

DeletedNode (INT file_id)
DeletedNode ()
INT | GetFileId ()
DeletedNode * GetNext ()
DeletedNode * GetPrevious ()
void | SetFileId (INT file_id)
void | SetNext (DeletedNode *next)
void | SetPrevious (DeletedNode *prev)
~DeletedNode ()

Detailed Description

structure for deleting node

Constructor & Destructor Documentation

DeletedNode::DeletedNode ( ) [inline]

DeletedNode::DeletedNode ( INT file_id ) [inline]

DeletedNode::~DeletedNode ( ) [inline]

Member Function Documentation

INT DeletedNode::GetFileId ( ) [inline]

DeletedNode* DeletedNode::GetNext ( ) [inline]

DeletedNode* DeletedNode::GetPrevious ( ) [inline]

void DeletedNode::SetFileId ( INT file_id ) [inline]

void DeletedNode::SetNext ( DeletedNode * next ) [inline]

void DeletedNode::SetPrevious ( DeletedNode * prev ) [inline]

The documentation for this class was generated from the following file:
  • Afs/DeletedNode.hpp
Generated on Wed Jan 25 01:11:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DeletedNodeList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DeletedNodeList Class Reference
[Afs]

#include <Apoxi/Afs/DeletedNode.hpp>

Collaboration diagram for DeletedNodeList:

[legend]

Public Member Functions

DeletedNodeList ()
DeletedNode * GetFirst ()
DeletedNode * PopBack ()
void PushBack (DeletedNode *node)
~DeletedNodeList ()

Detailed Description

structure of deleted node list

Constructor & Destructor Documentation

DeletedNodeList::DeletedNodeList ( ) [inline]

DeletedNodeList::~DeletedNodeList ( ) [inline]

Member Function Documentation

DeletedNode* DeletedNodeList::GetFirst ( ) [inline]

DeletedNode* DeletedNodeList::PopBack ( ) [inline]

void DeletedNodeList::PushBack ( DeletedNode * node ) [inline]

The documentation for this class was generated from the following file:
  • Afs/DeletedNode.hpp
Generated on Wed Jan 25 01:11:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Desktop Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Desktop Class Reference
[GUI]

#include <Apoxi/Gui/Desktop.hpp>

Inheritance diagram for Desktop:

[legend]
Collaboration diagram for Desktop:

[legend]

Public Types

enum | PanelAlignment { PanelOnLeft, PanelOnRight, PanelOnTop, PanelOnBottom }
enum | SectionAlignment { HorizBorderAlign, VertBorderAlign }
enum SectionType {
LeftSection = 0, TopSection = 1, RightSection = 2, BottomSection = 3,
LastSectionEntry = 4
}

Public Member Functions

Rect | GetCenterBounds () const
GlassPane * GetGlassPane ()
PanelAlignment | GetPanelAlignment () const
Rect | GetPanelBounds () const
Component * | GetSection (SectionType section_type)
Rect | GetSectionContainerBounds () const
BOOLEAN | IsPanelEnabled () const
void | Release ()
void | SetCenter (Window *win, XYDIM left_gap=0, XYDIM top_gap=0, XYDIM right_gap=0, XYDIM bottom_gap=0)
void | SetPanelAlignment (PanelAlignment alignment)
Sets the panel alignment and the panel properties corresponding to the alignment.
void | SetPanelEnabled (BOOLEAN enable)
Sets whether the panel is enabled or not.
virtual | ~Desktop ()

Static Public Member Functions

static Desktop * | CreateInstance (PanelAlignment panel_align=PanelOnBottom, SectionAlignment section_align=HorizBorderAlign)
static Desktop * | GetInstance ()

Protected Member Functions

virtual GlassPane * | CreateGlassPane ()
virtual Component * | CreateSection (SectionType section_type)
Desktop (PanelAlignment panel_align, SectionAlignment section_align)
virtual BOOLEAN | OnMessage (const Message &msg)

Data Structures

class | SectionWindow

Detailed Description

Implements a singleton of a Desktop. The Desktop administrates a panel which can be used as a softkey bar or whatever. Panels are members of Application. A desktop may also have:
  • a glasspane, which may contain graphical objects staying above all windows (e. g. a battery-indicator or a mouse-pointer).
  • sections, which are aligned at the four borders of the desktop. Those sections may show e. g. some indicators.

Member Enumeration Documentation

enum Desktop::PanelAlignment

Enumerator:
PanelOnLeft
PanelOnRight
PanelOnTop
PanelOnBottom

enum Desktop::SectionAlignment

The section alignment describes how the sections on the borders are aligned.

Enumerator:
HorizBorderAlign | The top- and bottom-section use the whole width of the desktop. The left- and right-section use the remaining height.
VertBorderAlign | The left- and right-section use the whole height of the desktop. The top- and bottom-section use the remaining width.

enum Desktop::SectionType

The section type describes on which border of the desktop the section should be aligned.

Enumerator:
LeftSection
TopSection
RightSection
BottomSection
LastSectionEntry Mandatory last entry.

Constructor & Destructor Documentation

Desktop::~Desktop ( ) [virtual]

Desktop::Desktop | ( | PanelAlignment | panel_align,
 |  | SectionAlignment | section_align
 | ) | [protected]

Member Function Documentation

GlassPane * Desktop::CreateGlassPane ( ) [protected, virtual]

Factory method for creating a glasspane. Overwrite this method to instantiate an own glasspane. Per default an instance of the class GlassPane is created.

Desktop * Desktop::CreateInstance | ( | PanelAlignment | panel_align = PanelOnBottom,
 |  | SectionAlignment | section_align = HorizBorderAlign
 | ) | [static]

Creates an instance of the Desktop. Alignment of the panel, which is per default on the bottom. Alignment of the sections on the desktop-border.

Returns:
a pointer to the instance

Component * Desktop::CreateSection ( SectionType section_type ) [protected, virtual]

Factory method for creating a section. Overwrite this method to instantiate a section dependant from the section type. The desktop automatically will set the parent of the created section. Per default 0 is returned.

Rect Desktop::GetCenterBounds ( ) const

Returns:
The boundaries of the center of the desktop. If a center has been defined by Desktop::SetCenter, the boundaries of the section minus the gap for the borders is returned. Otherwise the section boundaries are returned (see Desktop::GetSectionContainerBounds).

GlassPane * Desktop::GetGlassPane ( )

Returns:
Pointer to the glasspane. Invokes the factory method Desktop::CreateGlassPane when GetGlassPane is invoked the first time.

static Desktop* Desktop::GetInstance ( ) [inline, static]

Get an instance of the Desktop.

Returns:
a pointer to the instance, or null if no such instance exists

PanelAlignment Desktop::GetPanelAlignment ( ) const [inline]

Returns:
the current panel alignment

Rect Desktop::GetPanelBounds ( ) const

Returns:
The boundaries of the panel. An empty rectangle is returned, if the panel is disabled.

Component * Desktop::GetSection ( SectionType section_type )

Returns:
Pointer to the section defined by the section type. Invokes the factory method Desktop::CreateSection when GetSection is invoked the first time.

Rect Desktop::GetSectionContainerBounds ( ) const

Returns:
The boundaries of the section container, which are different from the the boundaries of the display, as they exclude the panel (the panel is not part of the section container).

BOOLEAN Desktop::IsPanelEnabled ( ) const [inline]

Returns:
TRUE if the panel is enabled, FALSE otherwise

BOOLEAN Desktop::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Implements Dispatcher.

void Desktop::Release ( )

Must be invoked by the application which created the Desktop by Desktop::CreateInstance.

void Desktop::SetCenter | ( | Window * | win,
 |  | XYDIM | left_gap = 0,
 |  | XYDIM | top_gap = 0,
 |  | XYDIM | right_gap = 0,
 |  | XYDIM | bottom_gap = 0
 | ) |

Sets the window win as center of the desktop and opens it automatically. Usually win represents the idlescreen of an MMI. The gaps define the space in pixels for the sections on the borders of the desktop. The sections are created by the factory method Desktop::CreateSection.

void Desktop::SetPanelAlignment ( PanelAlignment alignment )

Sets the panel alignment and the panel properties corresponding to the alignment.

void Desktop::SetPanelEnabled ( BOOLEAN enable )

Sets whether the panel is enabled or not.

The documentation for this class was generated from the following files:
  • Gui/Desktop.hpp
  • Gui/Desktop.cpp
Generated on Wed Jan 25 01:11:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DetachCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DetachCnfArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for DetachCnfArg:

[legend]
Collaboration diagram for DetachCnfArg:

[legend]

Public Types

enum | { ID = 5364 }

Public Member Functions

DetachCnfArg ()
const UserCause & | GetCause () const
const RegisterStatus & | GetStatus () const
void | SetCause (const UserCause &cause)
void | SetStatus (const RegisterStatus &status)

Static Public Member Functions

static const DetachCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DetachCnfArg: reflects arguments of signal MN_DETACH_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DetachCnfArg::DetachCnfArg ( )

Member Function Documentation

const DetachCnfArg & DetachCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UserCause& DetachCnfArg::GetCause ( ) const [inline]

const RegisterStatus& DetachCnfArg::GetStatus ( ) const [inline]

void DetachCnfArg::SetCause ( const UserCause & cause ) [inline]

void DetachCnfArg::SetStatus ( const RegisterStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DetachReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DetachReqArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for DetachReqArg:

[legend]
Collaboration diagram for DetachReqArg:

[legend]

Public Types

enum | { ID = 6361 }

Public Member Functions

DetachReqArg ()

Static Public Member Functions

static const DetachReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DetachReqArg: reflects arguments of signal MN_DETACH_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DetachReqArg::DetachReqArg ( )

Member Function Documentation

const DetachReqArg & DetachReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DeviceContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DeviceContext Class Reference
[GUI]

#include <Apoxi/Gui/DeviceContext.hpp>

Inheritance diagram for DeviceContext:

[legend]
Collaboration diagram for DeviceContext:

[legend]

Public Types

enum | AlphaBlendingMode { MaskAlphaBlending, ImmediateAlphaBlending }
enum RasterOp {
OverpaintRop, AndRop, OrRop, XorRop,
NXorRop, InvertRop
}
enum TransformationMode {
NoTransformation, MirrorRot180, Mirror, Rot180,
MirrorRot270, Rot90, Rot270, MirrorRot90
}

Public Member Functions

void | BeginUpdate ()
void | ClearRect (XYDIM left, XYDIM top, XYDIM right, XYDIM bottom)
Wrapper-method for ClearRect(const Rect& rect).
void | ClearRect (const Rect &rect)
Clears a rectangle given by rect using the system color CLIENT_BACKGROUND.
DeviceContext (VirtualDisplay *display, Control *control=0)
DeviceContext (const DeviceContext *dc)
DeviceContext ()
void | DrawArc (XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, INT start_angle, INT arc_angle)
void | DrawBitmap (XYDIM x, XYDIM y, const BitmapRes &bmp, TransformationMode trans_mode=NoTransformation)
void | DrawCircle (XYDIM x, XYDIM y, XYDIM radius, BOOLEAN fill=FALSE)
void | DrawGsmBitmap (XYDIM x, XYDIM y, const UINT8 *src)
Draws a bitmap which is stored in GSM format.
void | DrawLine (XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, INT thickness)
Draws a line with the pen-color from x1/y2 to x2/y2 with the given thickness.
void | DrawLine (XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2)
Draws a line with the pen-color from x1/y1 to x2/y2.
void | DrawPixel (XYDIM x, XYDIM y)
Draws a single pixel with the pen-color to the position x/y .
void | DrawPolygon (const XYDIM x[], const XYDIM y[], INT edges_count, BOOLEAN fill=FALSE)
void | DrawRect (XYDIM left, XYDIM top, XYDIM right, XYDIM bottom, BOOLEAN fill=FALSE)
Wrapper-method for DrawRect((const Rect& rect, BOOLEAN fill = FALSE).
void | DrawRect (const Rect &rect, BOOLEAN fill=FALSE)
void | DrawRoundRect (XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, XYDIM arc_width, XYDIM arc_height)
void | DrawText (XYDIM x, XYDIM y, const WCHAR *text, INT from=0, INT char_count=-1, BidiManager::ParagraphContext *context=0)
void | DrawTextBox (const Rect &box_rect, const WCHAR *text, INT from=0, INT char_count=-1, BOOLEAN center_vertical=FALSE, XYDIM line_gap=0)
void | DrawTextInvert (XYDIM x, XYDIM y, const WCHAR *text, INT from=0, INT char_count=-1)
void | EndUpdate ()
void | FillArc (XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, INT start_angle, INT arc_angle)
void | FillCircle (XYDIM x, XYDIM y, XYDIM radius)
void | FillPolygon (const XYDIM x[], const XYDIM y[], INT edges_count, const BitmapRes *texture=0)
void | FillRect (XYDIM left, XYDIM top, XYDIM right, XYDIM bottom)
Wrapper-method for FillRect(const Rect& rect).
void | FillRect (const Rect &rect)
Fills a rectangle with the brush-color.
void | FillRoundRect (XYDIM x1, XYDIM y1, XYDIM x2, XYDIM y2, XYDIM arc_width, XYDIM arc_height)
XYDIM | GetAbsX () const
Returns the absolute x coordinate of the upper left edge of the device context.
XYDIM | GetAbsY () const
Returns the absolute < coordinate of the upper left edge of the device context.
AlphaBlendingMode | GetAlphaBlendingMode () const
const Brush & | GetBrush () const
const Color & | GetBrushColor () const
ColorValue | GetBrushColorValue () const
BrushStyle | GetBrushStyle () const
Rect | GetClipRect () const
VirtualDisplay * | GetDisplay () const
const Font & | GetFont () const
FontAlign | GetFontAlign () const
XYDIM | GetHeight () const
const Pen & | GetPen () const
const Color & | GetPenColor () const
ColorValue | GetPenColorValue () const
PenStyle | GetPenStyle () const
Color | GetPixelColor (XYDIM x, XYDIM y) const
RasterOp | GetRasterOp () const
TextAlign | GetTextAlign () const
TextAttr | GetTextAttr () const
const TextFormat & | GetTextFormat () const
Size | GetTextSize (const WCHAR *text, INT from=0, INT char_count=-1) const
Returns the text size in pixels for the text with the current set textformat.
XYDIM | GetWidth () const
void | Init (const DeviceContext *dc)
void | Init (VirtualDisplay *display, Control *control=0)
void | InvertRect (XYDIM left, XYDIM top, XYDIM right, XYDIM bottom)
Wrapper-method for InvertRect(const Rect& rect).
void | InvertRect (const Rect &rect)
Inverts a rectangle given by rect.
BOOLEAN | IsInForeground ()
void | Scroll (const Rect &rect, XYDIM dx, XYDIM dy)
void | SetAlphaBlendingMode (AlphaBlendingMode mode)
void | SetBrush (const Brush &brush)
void | SetBrushColor (SystemColorId system_color_id)
void | SetBrushColor (const Color &color)
void | SetBrushColorHsv (UINT8 hue, UINT8 saturation, UINT8 value, UINT8 alpha=255)
void | SetBrushColorRgb (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha=255)
void | SetBrushColorValue (ColorValue color_value)
void | SetBrushStyle (BrushStyle brush_style)
void | SetClipRect (const Rect &clip_rect)
void | SetControl (Control *control)
void | SetFont (const Font &font)
void | SetFontAlign (FontAlign font_align)
void | SetPen (const Pen &pen)
void | SetPenColor (SystemColorId system_color_id)
void | SetPenColor (const Color &color)
void | SetPenColorHsv (UINT8 hue, UINT8 saturation, UINT8 value, UINT8 alpha=255)
void | SetPenColorRgb (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha=255)
void | SetPenColorValue (ColorValue color_value)
void | SetPenStyle (PenStyle pen_style)
void | SetRasterOp (RasterOp raster_op)
void | SetTextAlign (TextAlign text_align)
void | SetTextAttr (TextAttr text_attr)
void | SetTextFormat (const TextFormat &text_format)
void | UpdateDisplay () const
virtual | ~DeviceContext ()

Static Public Member Functions

static BOOLEAN | Obtain (const Ticks &timeout)
static void | Release ()

Protected Member Functions

virtual void | AdjustBoundingRect ()
Control * GetControl ()
virtual void | SetAbsX (XYDIM abs_x)
virtual void | SetAbsY (XYDIM abs_y)
void | SetDisplay (VirtualDisplay *display)
virtual void | SetHeight (XYDIM height)
virtual void | SetWidth (XYDIM width)
void | UpdateAbsPos (XYDIM dx, XYDIM dy)

Data Structures

struct | ClipStack
class | StylePainter
struct | TextLine

Detailed Description

Defines the context which will be used by any graphical operation.

Member Enumeration Documentation

enum DeviceContext::AlphaBlendingMode

Defines the kind of alpha blending which can be set by DeviceContext::SetAlphaBlendingMode.

Enumerator:
MaskAlphaBlending | The alpha mask is stored separatly. This mode is useful when drawing on a bitmap by a BitmapDc, which will be drawn on the display afterwards.
ImmediateAlphaBlending | The drawing operations are immediatly blended to the background.

enum DeviceContext::RasterOp

Enumerator:
OverpaintRop
AndRop
OrRop
XorRop
NXorRop
InvertRop

enum DeviceContext::TransformationMode

Bitmaps may be rotated and/or mirrored on the fly. The transformation-mode describes the kind of transformation. See DeviceContext::DrawBitmap for additional information.

Enumerator:
NoTransformation | Draws with no transformation.
MirrorRot180 | Draws the bitmap horizontally mirrored and rotated by 180 degrees.
Mirror | Draws the bitmap horizontally mirrored.
Rot180 | Draws the bitmap rotated by 180 degrees.
MirrorRot270 | Draws the bitmap horizontally mirrored and rotated by 270 degrees to the left.
Rot90 | Draws the bitmap rotated by 90 degrees to the left.
Rot270 | Draws the bitmap rotated by 270 degrees to the left.
MirrorRot90 | Draws the bitmap horizontally mirrored and rotated by 90 degrees to the left.

Constructor & Destructor Documentation

DeviceContext::DeviceContext ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

DeviceContext::DeviceContext ( const DeviceContext * dc )

DeviceContext::DeviceContext | ( | VirtualDisplay * | display,
 |  | Control * | control = 0
 | ) |

Parameters:
display | Destination display.
control | Control which uses the device-context. If no control is provided, the device-context does not respect the clipping of overlapping windows and controls.

DeviceContext::~DeviceContext ( ) [virtual]

Member Function Documentation

void DeviceContext::AdjustBoundingRect ( ) [protected, virtual]

Reimplemented in BitmapDc, ClientDc, DisplayDc, and FrameDc.

void DeviceContext::BeginUpdate ( )

Use BeginUpdate on the beginning of a group of graphical operations. Every group of graphical operations has to be encapsulated between BeginUpdate and EndUpdate. Nesting of BeginUpdate/EndUpdate is allowed.

void DeviceContext::ClearRect | ( | XYDIM | left,
 |  | XYDIM | top,
 |  | XYDIM | right,
 |  | XYDIM | bottom
 | ) | [inline]

Wrapper-method for ClearRect(const Rect& rect).

void DeviceContext::ClearRect ( const Rect & rect )

Clears a rectangle given by rect using the system color CLIENT_BACKGROUND.

void DeviceContext::DrawArc | ( | XYDIM | x1,
 |  | XYDIM | y1,
 |  | XYDIM | x2,
 |  | XYDIM | y2,
 |  | INT | start_angle,
 |  | INT | arc_angle
 | ) |

Draws an arc with the pen-color. Please note that drawing an arc is a quite expensive operation; it is recommended not to use it inside an APOXI-theme for drawing e. g. round corners of a window. Use a bitmap instead or do the drawing with DrawLine.

Parameters:
x1 | X-position of the upper-left corner of the arc to be drawn.
y1 | Y-position of the upper-left corner of the arc to be drawn.
x2 | X-position of the lower-right corner of the rectangle of the arc.
y2 | Y-position of the lower-right corner of the rectangle of the arc.
start_angle | The start angle of the arc.
arc_angle | The angular extent of the arc, relative to the start.

void DeviceContext::DrawBitmap | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const BitmapRes & | bmp,
 |  | TransformationMode | trans_mode = NoTransformation
 | ) |

Parameters:
x | Horizontal position of the bitmaps upper left corner.
y | Vertical position of the bitmaps upper left corner.
bmp | Bitmap which should be drawn.
trans_mode | Transformation-mode, which should be applied. Is currently not implemented and will be available in APOXI-1.10.0.

void DeviceContext::DrawCircle | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | radius,
 |  | BOOLEAN | fill = FALSE
 | ) |

Draws a circle with the pen-color.

Parameters:
x | X-position of the middle of the circle.
y | Y-position of the middle of the circle.
radius | Radius of the circle.
fill | If TRUE, the circle will be filled with the brush-color.

void DeviceContext::DrawGsmBitmap | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const UINT8 * | src
 | ) |

Draws a bitmap which is stored in GSM format.

void DeviceContext::DrawLine | ( | XYDIM | x1,
 |  | XYDIM | y1,
 |  | XYDIM | x2,
 |  | XYDIM | y2,
 |  | INT | thickness
 | ) |

Draws a line with the pen-color from x1/y2 to x2/y2 with the given thickness.

void DeviceContext::DrawLine | ( | XYDIM | x1,
 |  | XYDIM | y1,
 |  | XYDIM | x2,
 |  | XYDIM | y2
 | ) |

Draws a line with the pen-color from x1/y1 to x2/y2.

void DeviceContext::DrawPixel | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

Draws a single pixel with the pen-color to the position x/y .

void DeviceContext::DrawPolygon | ( | const XYDIM | x[],
 |  | const XYDIM | y[],
 |  | INT | edges_count,
 |  | BOOLEAN | fill = FALSE
 | ) |

Draws a polygon with the pen-color.

Parameters:
x | Pointer to an array of x-coordinates.
y | Pointer to an array of y-coordinates.
edges_count | Number of edges, which are described by the x- and y-arrays. edges_count must be >= 3.
fill | If TRUE, the polygon will be filled with the brush-color.

void DeviceContext::DrawRect | ( | XYDIM | left,
 |  | XYDIM | top,
 |  | XYDIM | right,
 |  | XYDIM | bottom,
 |  | BOOLEAN | fill = FALSE
 | ) | [inline]

Wrapper-method for DrawRect((const Rect& rect, BOOLEAN fill = FALSE).

void DeviceContext::DrawRect | ( | const Rect & | rect,
 |  | BOOLEAN | fill = FALSE
 | ) |

Draws a rectangle with the pen-color.

Parameters:
rect | Rectangle to be drawn.
fill | If TRUE, the rectangle will be filled with the brush-color.

void DeviceContext::DrawRoundRect | ( | XYDIM | x1,
 |  | XYDIM | y1,
 |  | XYDIM | x2,
 |  | XYDIM | y2,
 |  | XYDIM | arc_width,
 |  | XYDIM | arc_height
 | ) |

Draws the outline of a rounded corner rectangle (also circle or ellipse) with pen color. Please note that drawing a rounded rectangle is a quite expensive operation; it is recommended not to use it inside an APOXI-theme for drawing e. g. round corners of a window. Use a bitmap instead or do the drawing with DrawLine.

Parameters:
x1 | X-position of the upper-left corner.
y1 | Y-position of the upper-left corner.
x2 | X-position of the lower-right corner of the rectangle.
y2 | Y-position of the lower-right corner of the rectangle.
arc_width | The horizontal diameter of the arc at the corners.
arc_height | The vertical diameter of the arc at the corners.

void DeviceContext::DrawText | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const WCHAR * | text,
 |  | INT | from = 0,
 |  | INT | char_count = -1,
 |  | BidiManager::ParagraphContext * | context = 0
 | ) |

Draws a single line of text.

Parameters:
x | Horizontal starting point of the text.
y | Vertical starting point of the text.
text | Text to be drawn.
from | Index of the character where the drawing starts.
char_count | Number of characters to be drawn (-1 means until ).
context | Pointer to the paragraph-context provided by the bidi-manager, which might be needed for the output of bidirectional text. If no context is given, the current text is taken as paragraph-context.
See also:
BidiManager

void DeviceContext::DrawTextBox | ( | const Rect & | box_rect,
 |  | const WCHAR * | text,
 |  | INT | from = 0,
 |  | INT | char_count = -1,
 |  | BOOLEAN | center_vertical = FALSE,
 |  | XYDIM | line_gap = 0
 | ) |

Draws text into a rectangular area with automatically word wrapping.

Parameters:
box_rect | Rectangle, which defines the boundaries of the text.
text | Pointer to the text, which should be drawn.
from | Start index of first character which should be drawn.
char_count | Number of characters which should be drawn. -1 stands for all characters.
center_vertical | If set to TRUE, the text will be centered vertically inside the bounding-rectangle. If set to FALSE, the text will be aligned on the top.
line_gap | Specifies the vertical gap between two lines.
See also:
DrawText

void DeviceContext::DrawTextInvert | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const WCHAR * | text,
 |  | INT | from = 0,
 |  | INT | char_count = -1
 | ) |

Calls DrawText and afterwards InvertRect with the width and height of the text.

See also:
DrawText

void DeviceContext::EndUpdate ( )

Use EndUpdate at the end of a group of graphical operations.

See also:
BeginUpdate

void DeviceContext::FillArc | ( | XYDIM | x1,
 |  | XYDIM | y1,
 |  | XYDIM | x2,
 |  | XYDIM | y2,
 |  | INT | start_angle,
 |  | INT | arc_angle
 | ) |

Fills an arc with the brush color. Please note that drawing an arc is a quite expensive operation; it is recommended not to use it inside an APOXI-theme for drawing e. g. round corners of a window. Use a bitmap instead or do the drawing with DrawLine.

Parameters:
x1 | X-position of the upper-left corner of the arc to be drawn.
y1 | Y-position of the upper-left corner of the arc to be drawn.
x2 | X-position of the lower-right corner of the rectangle of the arc.
y2 | Y-position of the lower-right corner of the rectangle of the arc.
start_angle | The start angle of the arc.
arc_angle | The angular extent of the arc, relative to the start.

void DeviceContext::FillCircle | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | radius
 | ) | [inline]

Draws a filled circle with the brush-color.

Parameters:
x | X-position of the middle of the circle.
y | Y-position of the middle of the circle.
radius | Radius of the circle.

void DeviceContext::FillPolygon | ( | const XYDIM | x[],
 |  | const XYDIM | y[],
 |  | INT | edges_count,
 |  | const BitmapRes * | texture = 0
 | ) |

Draws a filled polygon with the brush-color. Current restriction: filling only works on convex polygons.

Parameters:
x | Pointer to an array of x-coordinates.
y | Pointer to an array of y-coordinates.
edges_count | Number of edges, which are described by the x- and y-arrays. edges_count must be >= 3.
texture | Optional parameter which specifies the texture the polygon should be filled with. If a texture is specified, the brush-color is ignored.

void DeviceContext::FillRect | ( | XYDIM | left,
 |  | XYDIM | top,
 |  | XYDIM | right,
 |  | XYDIM | bottom
 | ) | [inline]

Wrapper-method for FillRect(const Rect& rect).

void DeviceContext::FillRect ( const Rect & rect )

Fills a rectangle with the brush-color.

void DeviceContext::FillRoundRect | ( | XYDIM | x1,
 |  | XYDIM | y1,
 |  | XYDIM | x2,
 |  | XYDIM | y2,
 |  | XYDIM | arc_width,
 |  | XYDIM | arc_height
 | ) |

Fills in a rounded corner rectangle (also circle or ellipse) with brush color. Please note that drawing a rounded rectangle is a quite expensive operation; it is recommended not to use it inside an APOXI-theme for drawing e. g. round corners of a window. Use a bitmap instead or do the drawing with DrawLine.

Parameters:
x1 | X-position of the upper-left corner.
y1 | Y-position of the upper-left corner.
x2 | X-position of the lower-right corner of the rectangle.
y2 | Y-position of the lower-right corner of the rectangle.
arc_width | The horizontal diameter of the arc at the corners.
arc_height | The vertical diameter of the arc at the corners.

XYDIM DeviceContext::GetAbsX ( ) const [inline]

Returns the absolute x coordinate of the upper left edge of the device context.

XYDIM DeviceContext::GetAbsY ( ) const [inline]

Returns the absolute < coordinate of the upper left edge of the device context.

DeviceContext::AlphaBlendingMode DeviceContext::GetAlphaBlendingMode ( ) const

Returns:
the current alpha blending mode.

const Brush& DeviceContext::GetBrush ( ) const [inline]

Returns the brush style which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

const Color& DeviceContext::GetBrushColor ( ) const [inline]

Returns the brush color which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

ColorValue DeviceContext::GetBrushColorValue ( ) const [inline]

Sets the brush color value which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

BrushStyle DeviceContext::GetBrushStyle ( ) const [inline]

Returns the brush style which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

Rect DeviceContext::GetClipRect ( ) const

Returns the clipping rectange where each graphical operation gets clipped. It is assured that the clipping rectangle is inside the boundaries of the device context.

Control* DeviceContext::GetControl ( ) [inline, protected]

VirtualDisplay* DeviceContext::GetDisplay ( ) const [inline]

Returns a pointer to the virtual display of the device context. Note that using the virtual display directly should not be necessary inside the MMI and used with care.

const Font & DeviceContext::GetFont ( ) const

Returns the font which is used for text drawing methods like DeviceContext::DrawText and DeviceContext::DrawTextBox.

FontAlign DeviceContext::GetFontAlign ( ) const [inline]

Returns the font alignment which is used for text drawing methods like DeviceContext::DrawText and DeviceContext::DrawTextBox.

XYDIM DeviceContext::GetHeight ( ) const [inline]

Returns:
Height of the Device-Context in pixels.

const Pen& DeviceContext::GetPen ( ) const [inline]

Returns the pen which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

const Color& DeviceContext::GetPenColor ( ) const [inline]

Returns the pen color which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

ColorValue DeviceContext::GetPenColorValue ( ) const [inline]

Returns the pen color value which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

PenStyle DeviceContext::GetPenStyle ( ) const [inline]

Returns the pen style which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

Color DeviceContext::GetPixelColor | ( | XYDIM | x,
 |  | XYDIM | y
 | ) | const

Returns:
Color of the pixel on position x, y.

RasterOp DeviceContext::GetRasterOp ( ) const [inline]

Obsolete - raster operations are note supported anymore due to having an alpha channel.

TextAlign DeviceContext::GetTextAlign ( ) const [inline]

Returns the text alignment which is used for the text drawing method DeviceContext::DrawTextBox. Note that the text alignment is ignored by the method DeviceContext::DrawText, as a rectangular area is required for the alignment.

TextAttr DeviceContext::GetTextAttr ( ) const [inline]

Returns the attributes of the text (Normal, Underlined, Italic, Bold, Strikethrough), which is used for the text drawing methods DeviceContext::DrawText and DeviceContext::DrawTextBox.

const TextFormat& DeviceContext::GetTextFormat ( ) const [inline]

Returns the textformat which is used for text drawing methods like DeviceContext::DrawText and DeviceContext::DrawTextBox.

Size DeviceContext::GetTextSize | ( | const WCHAR * | text,
 |  | INT | from = 0,
 |  | INT | char_count = -1
 | ) | const

Returns the text size in pixels for the text with the current set textformat.

XYDIM DeviceContext::GetWidth ( ) const [inline]

Returns:
Width of the Device-Context in pixels.

void DeviceContext::Init ( const DeviceContext * dc )

void DeviceContext::Init | ( | VirtualDisplay * | display,
 |  | Control * | control = 0
 | ) |

Parameters:
display | Destination display.
control | Control which uses the device-context. If no control is provided, the device-context does not respect the clipping of overlapping windows and controls.

void DeviceContext::InvertRect | ( | XYDIM | left,
 |  | XYDIM | top,
 |  | XYDIM | right,
 |  | XYDIM | bottom
 | ) | [inline]

Wrapper-method for InvertRect(const Rect& rect).

void DeviceContext::InvertRect ( const Rect & rect )

Inverts a rectangle given by rect.

BOOLEAN DeviceContext::IsInForeground ( ) [inline]

Returns:
TRUE, if the drawing of the device context will be done in the foreground, so that no window overlaps the drawing area of the device context. This allows to add speed improvements for certain situations by using the display device in a direct manner. Note that using the display device directly should not be necessary for application developers for default use cases.

BOOLEAN DeviceContext::Obtain ( const Ticks & timeout ) [static]

This method is invoked by the window-system to assure, that a device-context may only be obtained by one thread. It should not be necessary for the application programmer to use this method.

static void DeviceContext::Release ( ) [inline, static]

Release the device-context for other threads. See DeviceContext::Obtain for details.

void DeviceContext::Scroll | ( | const Rect & | rect,
 |  | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

Scrolls a rectangular area.

Parameters:
rect | Area to be scrolled.
dx | Number of pixels to be scrolled horizontally.
dy | Number of pixels to be scrolled vertically.

void DeviceContext::SetAbsX ( XYDIM abs_x ) [protected, virtual]

void DeviceContext::SetAbsY ( XYDIM abs_y ) [protected, virtual]

void DeviceContext::SetAlphaBlendingMode ( AlphaBlendingMode mode )

Sets the alpha blending mode

void DeviceContext::SetBrush ( const Brush & brush ) [inline]

Sets the brush style which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

void DeviceContext::SetBrushColor ( SystemColorId system_color_id )

Sets the brush color which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

void DeviceContext::SetBrushColor ( const Color & color ) [inline]

Sets the brush color which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

void DeviceContext::SetBrushColorHsv | ( | UINT8 | hue,
 |  | UINT8 | saturation,
 |  | UINT8 | value,
 |  | UINT8 | alpha = 255
 | ) | [inline]

Sets the color of the brush to the value represented by hue, saturation and the value. Optionally an alpha-channel can be specified.

void DeviceContext::SetBrushColorRgb | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha = 255
 | ) | [inline]

Sets the color of the brush to the value represented by red-, green- and blue-portions. Optionally an alpha-channel can be specified.

void DeviceContext::SetBrushColorValue ( ColorValue color_value ) [inline]

Sets the brush color which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

void DeviceContext::SetBrushStyle ( BrushStyle brush_style ) [inline]

Sets the brush style which is used for drawing methods like DeviceContext::FillRect or DeviceContext::FillCircle.

void DeviceContext::SetClipRect ( const Rect & clip_rect )

After calling this method every graphical operation will be clipped to this rectangle. It is recommended before setting the clipping rectangle to intersect the wished rectangle with the existing clipping rectangle to assure an optimized clipping and prevent overdrawing other components:
PaintDc pdc(GetDeviceContext());
Rect my_clip_rect(0, 0, 100, 50);
my_clip_rect.Intersect(pdc.GetClipRect());
pdc.SetClipRect(my_clip_rect);

Parameters:
clip_rect New clipping rectangle.

void DeviceContext::SetControl ( Control * control )

Sets the control where the device context is embedded into. It should not be necessary for the application programmer to use this method.

void DeviceContext::SetDisplay ( VirtualDisplay * display ) [inline, protected]

void DeviceContext::SetFont ( const Font & font )

Sets the font which is used for text drawing methods like DeviceContext::DrawText and DeviceContext::DrawTextBox.

void DeviceContext::SetFontAlign ( FontAlign font_align ) [inline]

Sets the font alignment which is used for text drawing methods like DeviceContext::DrawText and DeviceContext::DrawTextBox.

void DeviceContext::SetHeight ( XYDIM height ) [protected, virtual]

void DeviceContext::SetPen ( const Pen & pen ) [inline]

Sets the pen which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

void DeviceContext::SetPenColor ( SystemColorId system_color_id )

Sets the pen color which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

void DeviceContext::SetPenColor ( const Color & color ) [inline]

Sets the pen color which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

void DeviceContext::SetPenColorHsv | ( | UINT8 | hue,
 |  | UINT8 | saturation,
 |  | UINT8 | value,
 |  | UINT8 | alpha = 255
 | ) | [inline]

Sets the color of the pen to the value represented by hue, saturation and the value. Optionally an alpha-channel can be specified.

void DeviceContext::SetPenColorRgb | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha = 255
 | ) | [inline]

Sets the color of the pen to the value represented by red-, green- and blue-portions. Optionally an alpha-channel can be specified.

void DeviceContext::SetPenColorValue ( ColorValue color_value ) [inline]

Sets the pen color value which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

void DeviceContext::SetPenStyle ( PenStyle pen_style ) [inline]

Sets the pen style which is used for drawing methods like DeviceContext::DrawLine or DeviceContext::DrawRect.

void DeviceContext::SetRasterOp ( RasterOp raster_op ) [inline]

Obsolete - raster operations are note supported anymore due to supporting an alpha channel.

void DeviceContext::SetTextAlign ( TextAlign text_align ) [inline]

Sets the text alignment which is used for the text drawing method DeviceContext::DrawTextBox. Note that the text alignment is ignored by the method DeviceContext::DrawText, as a rectangular area is required for the alignment.

void DeviceContext::SetTextAttr ( TextAttr text_attr ) [inline]

Sets the attributes of the text (Normal, Underlined, Italic, Bold, Strikethrough), which is used for the text drawing methods DeviceContext::DrawText and DeviceContext::DrawTextBox. Setting two attributes at the same time can be done the following way: dc.SetTextAttr(TextFormat::Italic | TextFormat::Bold);

void DeviceContext::SetTextFormat ( const TextFormat & text_format ) [inline]

Sets the textformat which is used for text drawing methods like DeviceContext::DrawText and DeviceContext::DrawTextBox.

void DeviceContext::SetWidth ( XYDIM width ) [protected, virtual]

void DeviceContext::UpdateAbsPos | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected]

void DeviceContext::UpdateDisplay ( ) const

Only use UpdateDisplay() if an immediately display update is necessary. Under normal circumstances the display will be updated during the next idle state of the application.

The documentation for this class was generated from the following files:
  • Gui/DeviceContext.hpp
  • Gui/DeviceContext.cpp
Generated on Wed Jan 25 01:11:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DeviceManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DeviceManager Class Reference
[Devices]

#include <Apoxi/Devices/DeviceManager.hpp>

Collaboration diagram for DeviceManager:

[legend]

Public Member Functions

void | AddDevice (AbstractDevice &device)
AbstractDevice * | GetDevice (AbstractDevice::Category category, INT index=0) const
void | RemoveDevice (AbstractDevice &device)

Static Public Member Functions

static Display * | GetDisplay (INT display_idx=0)
static DeviceManager & | GetInstance ()
static ClientDc * | GetSharedDc (INT display_idx=0)

Friends

class | Iterator
class | ShutDown
class | StartUp

Data Structures

class | Iterator

Detailed Description

Central instance which allows accessing all APOXI devices. The device manager assures a proper initialization of all devices during the startup- and shutdown process. Additionally it is possible during runtime to check the available devices.
See also:
AbstractDevice

Member Function Documentation

void DeviceManager::AddDevice ( AbstractDevice & device )

Adds the device to the device manager. It is recommended that the devices invoke DeviceManager::GetInstance().AddDevice(*this) in their constructor. This allows a static allocation of a device instance. For each added device the method AbstractDevice::OnStart() is invoked when starting up APOXI. This allows the device to initialize itself by having full access to APOXI.

AbstractDevice * DeviceManager::GetDevice | ( | AbstractDevice::Category | category,
 |  | INT | index = 0
 | ) | const

Returns a pointer to a device dependent from the category and the index.

Parameters:
category | Category of the device (e. g. KeyboardCategory or DisplayCategory).
index | Index of the device related to the category. Per default only one device instance of a category is available. But for example the category DisplayCategory might have two instances of a device, where one instance has the index 0 (= main display) and the other instance the index 1 (= sub display).

static Display* DeviceManager::GetDisplay ( INT display_idx = 0 ) [inline, static]

Returns a pointer to the display device. The display device is accessed especially for time critical tasks and hence this wrapper method is offered for a fast access. It's also possible to access the display device in a generic way by DeviceManager::GetInstance().GetDevice(AbstractDevice::DisplayCategory), but DeviceManager::GetDisplay() is faster.

Parameters:
display_idx Index of the display which should be returned. Usually 0 is the main display and 1 the sub display.

DeviceManager & DeviceManager::GetInstance ( ) [static]

Returns the DeviceManager instance.

static ClientDc* DeviceManager::GetSharedDc ( INT display_idx = 0 ) [inline, static]

Returns the shared device context for the display with the index display_idx. It should not be necessary for an application to access a shared device context in a direct manner.

void DeviceManager::RemoveDevice ( AbstractDevice & device )

Removes the device from the device manager. It is recommended that the device invokes DeviceManager::GetInstance().RemoveDevice(*this) in their destructor.

Friends And Related Function Documentation

friend class Iterator [friend]

friend class ShutDown [friend]

friend class StartUp [friend]

The documentation for this class was generated from the following files:
  • Devices/DeviceManager.hpp
  • Devices/DeviceManager.cpp
Generated on Wed Jan 25 01:11:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DeviceManager::Iterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
DeviceManager::Iterator

DeviceManager::Iterator Class Reference

#include <Apoxi/Devices/DeviceManager.hpp>

Collaboration diagram for DeviceManager::Iterator:

[legend]

Public Member Functions

BOOLEAN | Begin ()
AbstractDevice * | Get () const
Iterator ()
Iterator | operator++ (INT)
Iterator & operator++ ()
~Iterator ()

Detailed Description

Allows to iterate over all devices which have been added to the device manager. Sample code:
        for (DeviceManager::Iterator it; it.Get() != 0; ++it) {
            AbstractDevice* device = it.Get();
            ...
        }

Note that the device manager will be locked until the destructor of the iterator will be invoked.

Constructor & Destructor Documentation

DeviceManager::Iterator::Iterator ( )

DeviceManager::Iterator::~Iterator ( )

Member Function Documentation

BOOLEAN DeviceManager::Iterator::Begin ( )

Resets the iterator to the begin. FALSE is returned if no device has been added to the device manager.

AbstractDevice* DeviceManager::Iterator::Get ( ) const [inline]

Returns the current device. 0 is returned if no device has been added to the device manager or the iterator has exceeded the end.

DeviceManager::Iterator DeviceManager::Iterator::operator++ ( INT )

Moves the iterator to the next device.

DeviceManager::Iterator & DeviceManager::Iterator::operator++ ( )

Moves the iterator to the next device.

The documentation for this class was generated from the following files:
  • Devices/DeviceManager.hpp
  • Devices/DeviceManager.cpp
Generated on Wed Jan 25 01:11:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelChangeStatusEventArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelChangeStatusEventArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelChangeStatusEventArg:

[legend]
Collaboration diagram for DhChannelChangeStatusEventArg:

[legend]

Public Types

enum | { ID = 2368 }

Public Member Functions

DhChannelChangeStatusEventArg ()
DhChannelChangeStatusEventArg (const SimTkTransactionId &tid, UINT8 cidx, const SiChannelChangedState &changed_state)
const SiChannelChangedState & | GetChangedState () const
UINT8 | GetCidx () const
const SimTkTransactionId & | GetTid () const
void | SetChangedState (const SiChannelChangedState &changed_state)
void | SetCidx (UINT8 cidx)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelChangeStatusEventArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelChangeStatusEventArg: reflects arguments of signal DH_CHANNEL_CHANGE_STATUS_EVENT

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelChangeStatusEventArg::DhChannelChangeStatusEventArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | const SiChannelChangedState & | changed_state
 | ) |

DhChannelChangeStatusEventArg::DhChannelChangeStatusEventArg ( )

Member Function Documentation

const DhChannelChangeStatusEventArg & DhChannelChangeStatusEventArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SiChannelChangedState& DhChannelChangeStatusEventArg::GetChangedState ( ) const [inline]

UINT8 DhChannelChangeStatusEventArg::GetCidx ( ) const [inline]

const SimTkTransactionId& DhChannelChangeStatusEventArg::GetTid ( ) const [inline]

void DhChannelChangeStatusEventArg::SetChangedState ( const SiChannelChangedState & changed_state ) [inline]

void DhChannelChangeStatusEventArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelChangeStatusEventArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelChangeStatusResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelChangeStatusResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelChangeStatusResArg:

[legend]
Collaboration diagram for DhChannelChangeStatusResArg:

[legend]

Public Types

enum | { ID = 1336 }

Public Member Functions

DhChannelChangeStatusResArg ()
UINT8 | GetCidx () const
UINT8 | GetSimResult () const
const SimTkTransactionId & | GetTid () const
void | SetCidx (UINT8 cidx)
void | SetSimResult (UINT8 sim_result)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelChangeStatusResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelChangeStatusResArg: reflects arguments of signal DH_ CHANNEL_CHANGE_STATUS_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelChangeStatusResArg::DhChannelChangeStatusResArg ( )

Member Function Documentation

const DhChannelChangeStatusResArg & DhChannelChangeStatusResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelChangeStatusResArg::GetCidx ( ) const [inline]

UINT8 DhChannelChangeStatusResArg::GetSimResult ( ) const [inline]

const SimTkTransactionId& DhChannelChangeStatusResArg::GetTid ( ) const [inline]

void DhChannelChangeStatusResArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelChangeStatusResArg::SetSimResult ( UINT8 sim_result ) [inline]

void DhChannelChangeStatusResArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelChangeStatusResMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelChangeStatusResMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DhChannelChangeStatusResMsg:

[legend]
Collaboration diagram for DhChannelChangeStatusResMsg:

[legend]

Public Types

enum | { ID = 18344 }

Public Member Functions

virtual Message * | Clone () const
DhChannelChangeStatusResMsg (ExecutionContext *context, const DhChannelChangeStatusResArg &arg)
const DhChannelChangeStatusResArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DhChannelChangeStatusResArg &arg)
virtual | ~DhChannelChangeStatusResMsg ()

Detailed Description

DhChannelChangeStatusResMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelChangeStatusResMsg::DhChannelChangeStatusResMsg | ( | ExecutionContext * | context,
 |  | const DhChannelChangeStatusResArg & | arg
 | ) |

DhChannelChangeStatusResMsg::~DhChannelChangeStatusResMsg ( ) [virtual]

Member Function Documentation

Message * DhChannelChangeStatusResMsg::Clone ( ) const [virtual]

Implements Message.

const DhChannelChangeStatusResArg& DhChannelChangeStatusResMsg::GetArg ( ) const [inline]

const MsgMetaData & DhChannelChangeStatusResMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DhChannelChangeStatusResMsg::SetArg ( const DhChannelChangeStatusResArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:11:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelCloseIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelCloseIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelCloseIndArg:

[legend]
Collaboration diagram for DhChannelCloseIndArg:

[legend]

Public Types

enum | { ID = 2334 }

Public Member Functions

DhChannelCloseIndArg ()
DhChannelCloseIndArg (const SimTkTransactionId &tid, UINT8 cidx, UINT8 gen_result, UINT8 adn_result)
UINT8 | GetAdnResult () const
UINT8 | GetCidx () const
UINT8 | GetGenResult () const
const SimTkTransactionId & | GetTid () const
void | SetAdnResult (UINT8 adn_result)
void | SetCidx (UINT8 cidx)
void | SetGenResult (UINT8 gen_result)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelCloseIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelCloseIndArg: reflects arguments of signal DH_CHANNEL_CLOSE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelCloseIndArg::DhChannelCloseIndArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | UINT8 | gen_result,
 |  | UINT8 | adn_result
 | ) |

DhChannelCloseIndArg::DhChannelCloseIndArg ( )

Member Function Documentation

const DhChannelCloseIndArg & DhChannelCloseIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelCloseIndArg::GetAdnResult ( ) const [inline]

UINT8 DhChannelCloseIndArg::GetCidx ( ) const [inline]

UINT8 DhChannelCloseIndArg::GetGenResult ( ) const [inline]

const SimTkTransactionId& DhChannelCloseIndArg::GetTid ( ) const [inline]

void DhChannelCloseIndArg::SetAdnResult ( UINT8 adn_result ) [inline]

void DhChannelCloseIndArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelCloseIndArg::SetGenResult ( UINT8 gen_result ) [inline]

void DhChannelCloseIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelCloseReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelCloseReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelCloseReqArg:

[legend]
Collaboration diagram for DhChannelCloseReqArg:

[legend]

Public Types

enum | { ID = 1332 }

Public Member Functions

DhChannelCloseReqArg ()
UINT8 | GetCidx () const
const SimTkTransactionId & | GetTid () const
void | SetCidx (UINT8 cidx)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelCloseReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelCloseReqArg: reflects arguments of signal DH_CHANNEL_CLOSE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelCloseReqArg::DhChannelCloseReqArg ( )

Member Function Documentation

const DhChannelCloseReqArg & DhChannelCloseReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelCloseReqArg::GetCidx ( ) const [inline]

const SimTkTransactionId& DhChannelCloseReqArg::GetTid ( ) const [inline]

void DhChannelCloseReqArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelCloseReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelCloseReqMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelCloseReqMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DhChannelCloseReqMsg:

[legend]
Collaboration diagram for DhChannelCloseReqMsg:

[legend]

Public Types

enum | { ID = 18340 }

Public Member Functions

virtual Message * | Clone () const
DhChannelCloseReqMsg (ExecutionContext *context, const DhChannelCloseReqArg &arg)
const DhChannelCloseReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DhChannelCloseReqArg &arg)
virtual | ~DhChannelCloseReqMsg ()

Detailed Description

DhChannelCloseReqMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelCloseReqMsg::DhChannelCloseReqMsg | ( | ExecutionContext * | context,
 |  | const DhChannelCloseReqArg & | arg
 | ) |

DhChannelCloseReqMsg::~DhChannelCloseReqMsg ( ) [virtual]

Member Function Documentation

Message * DhChannelCloseReqMsg::Clone ( ) const [virtual]

Implements Message.

const DhChannelCloseReqArg& DhChannelCloseReqMsg::GetArg ( ) const [inline]

const MsgMetaData & DhChannelCloseReqMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DhChannelCloseReqMsg::SetArg ( const DhChannelCloseReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:11:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelDataAvailableResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelDataAvailableResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelDataAvailableResArg:

[legend]
Collaboration diagram for DhChannelDataAvailableResArg:

[legend]

Public Types

enum | { ID = 1334 }

Public Member Functions

DhChannelDataAvailableResArg ()
UINT8 | GetCidx () const
UINT8 | GetSimResult () const
const SimTkTransactionId & | GetTid () const
void | SetCidx (UINT8 cidx)
void | SetSimResult (UINT8 sim_result)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelDataAvailableResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelDataAvailableResArg: reflects arguments of signal DH_CHANNEL_DATA_AVAILABLE_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelDataAvailableResArg::DhChannelDataAvailableResArg ( )

Member Function Documentation

const DhChannelDataAvailableResArg & DhChannelDataAvailableResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelDataAvailableResArg::GetCidx ( ) const [inline]

UINT8 DhChannelDataAvailableResArg::GetSimResult ( ) const [inline]

const SimTkTransactionId& DhChannelDataAvailableResArg::GetTid ( ) const [inline]

void DhChannelDataAvailableResArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelDataAvailableResArg::SetSimResult ( UINT8 sim_result ) [inline]

void DhChannelDataAvailableResArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelDataAvailableResMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelDataAvailableResMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DhChannelDataAvailableResMsg:

[legend]
Collaboration diagram for DhChannelDataAvailableResMsg:

[legend]

Public Types

enum | { ID = 18342 }

Public Member Functions

virtual Message * | Clone () const
DhChannelDataAvailableResMsg (ExecutionContext *context, const DhChannelDataAvailableResArg &arg)
const DhChannelDataAvailableResArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DhChannelDataAvailableResArg &arg)
virtual | ~DhChannelDataAvailableResMsg ()

Detailed Description

DhChannelDataAvailableResMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelDataAvailableResMsg::DhChannelDataAvailableResMsg | ( | ExecutionContext * | context,
 |  | const DhChannelDataAvailableResArg & | arg
 | ) |

DhChannelDataAvailableResMsg::~DhChannelDataAvailableResMsg ( ) [virtual]

Member Function Documentation

Message * DhChannelDataAvailableResMsg::Clone ( ) const [virtual]

Implements Message.

const DhChannelDataAvailableResArg& DhChannelDataAvailableResMsg::GetArg ( ) const [inline]

const MsgMetaData & DhChannelDataAvailableResMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DhChannelDataAvailableResMsg::SetArg ( const DhChannelDataAvailableResArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:11:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelDataAvailEventArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelDataAvailEventArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelDataAvailEventArg:

[legend]
Collaboration diagram for DhChannelDataAvailEventArg:

[legend]

Public Types

enum | { ID = 2369 }

Public Member Functions

DhChannelDataAvailEventArg ()
DhChannelDataAvailEventArg (const SimTkTransactionId &tid, UINT8 cidx, UINT16 channel_data_length, const SiChannelChangedState &changed_state)
const SiChannelChangedState & | GetChangedState () const
UINT16 | GetChannelDataLength () const
UINT8 | GetCidx () const
const SimTkTransactionId & | GetTid () const
void | SetChangedState (const SiChannelChangedState &changed_state)
void | SetChannelDataLength (UINT16 channel_data_length)
void | SetCidx (UINT8 cidx)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelDataAvailEventArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelDataAvailEventArg: reflects arguments of signal DH_CHANNEL_DATA_AVAILABLE_EVENT

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelDataAvailEventArg::DhChannelDataAvailEventArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | UINT16 | channel_data_length,
 |  | const SiChannelChangedState & | changed_state
 | ) |

DhChannelDataAvailEventArg::DhChannelDataAvailEventArg ( )

Member Function Documentation

const DhChannelDataAvailEventArg & DhChannelDataAvailEventArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SiChannelChangedState& DhChannelDataAvailEventArg::GetChangedState ( ) const [inline]

UINT16 DhChannelDataAvailEventArg::GetChannelDataLength ( ) const [inline]

UINT8 DhChannelDataAvailEventArg::GetCidx ( ) const [inline]

const SimTkTransactionId& DhChannelDataAvailEventArg::GetTid ( ) const [inline]

void DhChannelDataAvailEventArg::SetChangedState ( const SiChannelChangedState & changed_state ) [inline]

void DhChannelDataAvailEventArg::SetChannelDataLength ( UINT16 channel_data_length ) [inline]

void DhChannelDataAvailEventArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelDataAvailEventArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelOpenCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelOpenCnfArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelOpenCnfArg:

[legend]
Collaboration diagram for DhChannelOpenCnfArg:

[legend]

Public Types

enum | { ID = 2332 }

Public Member Functions

DhChannelOpenCnfArg ()
DhChannelOpenCnfArg (const SimTkTransactionId &tid, UINT8 cidx, UINT16 buffer_size, const SiBearerDesc &bearer_desc, UINT8 gen_result, UINT8 adn_result)
UINT8 | GetAdnResult () const
const SiBearerDesc & | GetBearerDesc () const
UINT16 | GetBufferSize () const
UINT8 | GetCidx () const
UINT8 | GetGenResult () const
const SimTkTransactionId & | GetTid () const
void | SetAdnResult (UINT8 adn_result)
void | SetBearerDesc (const SiBearerDesc &bearer_desc)
void | SetBufferSize (UINT16 buffer_size)
void | SetCidx (UINT8 cidx)
void | SetGenResult (UINT8 gen_result)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelOpenCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelOpenCnfArg: reflects arguments of signal DH_CHANNEL_OPEN_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelOpenCnfArg::DhChannelOpenCnfArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | UINT16 | buffer_size,
 |  | const SiBearerDesc & | bearer_desc,
 |  | UINT8 | gen_result,
 |  | UINT8 | adn_result
 | ) |

DhChannelOpenCnfArg::DhChannelOpenCnfArg ( )

Member Function Documentation

const DhChannelOpenCnfArg & DhChannelOpenCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelOpenCnfArg::GetAdnResult ( ) const [inline]

const SiBearerDesc& DhChannelOpenCnfArg::GetBearerDesc ( ) const [inline]

UINT16 DhChannelOpenCnfArg::GetBufferSize ( ) const [inline]

UINT8 DhChannelOpenCnfArg::GetCidx ( ) const [inline]

UINT8 DhChannelOpenCnfArg::GetGenResult ( ) const [inline]

const SimTkTransactionId& DhChannelOpenCnfArg::GetTid ( ) const [inline]

void DhChannelOpenCnfArg::SetAdnResult ( UINT8 adn_result ) [inline]

void DhChannelOpenCnfArg::SetBearerDesc ( const SiBearerDesc & bearer_desc ) [inline]

void DhChannelOpenCnfArg::SetBufferSize ( UINT16 buffer_size ) [inline]

void DhChannelOpenCnfArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelOpenCnfArg::SetGenResult ( UINT8 gen_result ) [inline]

void DhChannelOpenCnfArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelOpenRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelOpenRejArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelOpenRejArg:

[legend]
Collaboration diagram for DhChannelOpenRejArg:

[legend]

Public Types

enum | { ID = 2333 }

Public Member Functions

DhChannelOpenRejArg ()
DhChannelOpenRejArg (const SimTkTransactionId &tid, UINT8 cidx, UINT8 gen_result, UINT8 adn_result)
UINT8 | GetAdnResult () const
UINT8 | GetCidx () const
UINT8 | GetGenResult () const
const SimTkTransactionId & | GetTid () const
void | SetAdnResult (UINT8 adn_result)
void | SetCidx (UINT8 cidx)
void | SetGenResult (UINT8 gen_result)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelOpenRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelOpenRejArg: reflects arguments of signal DH_CHANNEL_OPEN_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelOpenRejArg::DhChannelOpenRejArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | UINT8 | gen_result,
 |  | UINT8 | adn_result
 | ) |

DhChannelOpenRejArg::DhChannelOpenRejArg ( )

Member Function Documentation

const DhChannelOpenRejArg & DhChannelOpenRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelOpenRejArg::GetAdnResult ( ) const [inline]

UINT8 DhChannelOpenRejArg::GetCidx ( ) const [inline]

UINT8 DhChannelOpenRejArg::GetGenResult ( ) const [inline]

const SimTkTransactionId& DhChannelOpenRejArg::GetTid ( ) const [inline]

void DhChannelOpenRejArg::SetAdnResult ( UINT8 adn_result ) [inline]

void DhChannelOpenRejArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelOpenRejArg::SetGenResult ( UINT8 gen_result ) [inline]

void DhChannelOpenRejArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelOpenReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelOpenReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelOpenReqArg:

[legend]
Collaboration diagram for DhChannelOpenReqArg:

[legend]

Public Types

enum | { ID = 1331 }

Public Member Functions

DhChannelOpenReqArg ()
const String & | GetApn () const
const SiBearerDesc & | GetBearerDesc () const
UINT16 | GetBufferSize () const
UINT8 | GetCidx () const
UINT8 | GetCmdQualifier () const
const SiIpAddress & | GetDestIpAddr () const
const SiDuration & | GetDuration1 () const
const SiDuration & | GetDuration2 () const
const SiIpAddress & | GetLocalIpAddr () const
const PhoneNumber & | GetPhoneNumber () const
UINT16 | GetPort () const
const SimSubAddress & | GetSubAddr () const
const SimTkTransactionId & | GetTid () const
const SiTransportLayer & | GetTranspLayer () const
const SimTextString & | GetUserLogin () const
const SimTextString & | GetUserPassword () const
BOOLEAN | IsEnablePassword () const
void | SetApn (const String &apn)
void | SetBearerDesc (const SiBearerDesc &bearer_desc)
void | SetBufferSize (UINT16 buffer_size)
void | SetCidx (UINT8 cidx)
void | SetCmdQualifier (UINT8 cmd_qualifier)
void | SetDestIpAddr (const SiIpAddress &dest_ip_addr)
void | SetDuration1 (const SiDuration &duration1)
void | SetDuration2 (const SiDuration &duration2)
void | SetEnablePassword (BOOLEAN enable_password)
void | SetLocalIpAddr (const SiIpAddress &local_ip_addr)
void | SetPhoneNumber (const PhoneNumber &phone_number)
void | SetPort (UINT16 port)
void | SetSubAddr (const SimSubAddress &sub_addr)
void | SetTid (const SimTkTransactionId &tid)
void | SetTranspLayer (const SiTransportLayer &transp_layer)
void | SetUserLogin (const SimTextString &user_login)
void | SetUserPassword (const SimTextString &user_password)

Static Public Member Functions

static const DhChannelOpenReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelOpenReqArg: reflects arguments of signal DH_CHANNEL_OPEN_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelOpenReqArg::DhChannelOpenReqArg ( )

Member Function Documentation

const DhChannelOpenReqArg & DhChannelOpenReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const String& DhChannelOpenReqArg::GetApn ( ) const [inline]

const SiBearerDesc& DhChannelOpenReqArg::GetBearerDesc ( ) const [inline]

UINT16 DhChannelOpenReqArg::GetBufferSize ( ) const [inline]

UINT8 DhChannelOpenReqArg::GetCidx ( ) const [inline]

UINT8 DhChannelOpenReqArg::GetCmdQualifier ( ) const [inline]

const SiIpAddress& DhChannelOpenReqArg::GetDestIpAddr ( ) const [inline]

const SiDuration& DhChannelOpenReqArg::GetDuration1 ( ) const [inline]

const SiDuration& DhChannelOpenReqArg::GetDuration2 ( ) const [inline]

const SiIpAddress& DhChannelOpenReqArg::GetLocalIpAddr ( ) const [inline]

const PhoneNumber& DhChannelOpenReqArg::GetPhoneNumber ( ) const [inline]

UINT16 DhChannelOpenReqArg::GetPort ( ) const [inline]

const SimSubAddress& DhChannelOpenReqArg::GetSubAddr ( ) const [inline]

const SimTkTransactionId& DhChannelOpenReqArg::GetTid ( ) const [inline]

const SiTransportLayer& DhChannelOpenReqArg::GetTranspLayer ( ) const [inline]

const SimTextString& DhChannelOpenReqArg::GetUserLogin ( ) const [inline]

const SimTextString& DhChannelOpenReqArg::GetUserPassword ( ) const [inline]

BOOLEAN DhChannelOpenReqArg::IsEnablePassword ( ) const [inline]

void DhChannelOpenReqArg::SetApn ( const String & apn ) [inline]

void DhChannelOpenReqArg::SetBearerDesc ( const SiBearerDesc & bearer_desc ) [inline]

void DhChannelOpenReqArg::SetBufferSize ( UINT16 buffer_size ) [inline]

void DhChannelOpenReqArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelOpenReqArg::SetCmdQualifier ( UINT8 cmd_qualifier ) [inline]

void DhChannelOpenReqArg::SetDestIpAddr ( const SiIpAddress & dest_ip_addr ) [inline]

void DhChannelOpenReqArg::SetDuration1 ( const SiDuration & duration1 ) [inline]

void DhChannelOpenReqArg::SetDuration2 ( const SiDuration & duration2 ) [inline]

void DhChannelOpenReqArg::SetEnablePassword ( BOOLEAN enable_password ) [inline]

void DhChannelOpenReqArg::SetLocalIpAddr ( const SiIpAddress & local_ip_addr ) [inline]

void DhChannelOpenReqArg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

void DhChannelOpenReqArg::SetPort ( UINT16 port ) [inline]

void DhChannelOpenReqArg::SetSubAddr ( const SimSubAddress & sub_addr ) [inline]

void DhChannelOpenReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

void DhChannelOpenReqArg::SetTranspLayer ( const SiTransportLayer & transp_layer ) [inline]

void DhChannelOpenReqArg::SetUserLogin ( const SimTextString & user_login ) [inline]

void DhChannelOpenReqArg::SetUserPassword ( const SimTextString & user_password ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelOpenReqMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelOpenReqMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DhChannelOpenReqMsg:

[legend]
Collaboration diagram for DhChannelOpenReqMsg:

[legend]

Public Types

enum | { ID = 18339 }

Public Member Functions

virtual Message * | Clone () const
DhChannelOpenReqMsg (ExecutionContext *context, const DhChannelOpenReqArg &arg)
const DhChannelOpenReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DhChannelOpenReqArg &arg)
virtual | ~DhChannelOpenReqMsg ()

Detailed Description

DhChannelOpenReqMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelOpenReqMsg::DhChannelOpenReqMsg | ( | ExecutionContext * | context,
 |  | const DhChannelOpenReqArg & | arg
 | ) |

DhChannelOpenReqMsg::~DhChannelOpenReqMsg ( ) [virtual]

Member Function Documentation

Message * DhChannelOpenReqMsg::Clone ( ) const [virtual]

Implements Message.

const DhChannelOpenReqArg& DhChannelOpenReqMsg::GetArg ( ) const [inline]

const MsgMetaData & DhChannelOpenReqMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DhChannelOpenReqMsg::SetArg ( const DhChannelOpenReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:11:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelReceiveIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelReceiveIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelReceiveIndArg:

[legend]
Collaboration diagram for DhChannelReceiveIndArg:

[legend]

Public Types

enum | { ID = 2367 }

Public Member Functions

DhChannelReceiveIndArg ()
DhChannelReceiveIndArg (const SimTkTransactionId &tid, UINT8 cidx, UINT16 remaining_data_length, UINT8 gen_result, UINT8 adn_result, const ChannelData &channel_data)
UINT8 | GetAdnResult () const
const ChannelData & | GetChannelData () const
UINT8 | GetCidx () const
UINT8 | GetGenResult () const
UINT16 | GetRemainingDataLength () const
const SimTkTransactionId & | GetTid () const
void | SetAdnResult (UINT8 adn_result)
void | SetChannelData (const ChannelData &channel_data)
void | SetCidx (UINT8 cidx)
void | SetGenResult (UINT8 gen_result)
void | SetRemainingDataLength (UINT16 remaining_data_length)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelReceiveIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelReceiveIndArg: reflects arguments of signal DH_CHANNEL_RECEIVE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelReceiveIndArg::DhChannelReceiveIndArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | UINT16 | remaining_data_length,
 |  | UINT8 | gen_result,
 |  | UINT8 | adn_result,
 |  | const ChannelData & | channel_data
 | ) |

DhChannelReceiveIndArg::DhChannelReceiveIndArg ( )

Member Function Documentation

const DhChannelReceiveIndArg & DhChannelReceiveIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelReceiveIndArg::GetAdnResult ( ) const [inline]

const ChannelData& DhChannelReceiveIndArg::GetChannelData ( ) const [inline]

UINT8 DhChannelReceiveIndArg::GetCidx ( ) const [inline]

UINT8 DhChannelReceiveIndArg::GetGenResult ( ) const [inline]

UINT16 DhChannelReceiveIndArg::GetRemainingDataLength ( ) const [inline]

const SimTkTransactionId& DhChannelReceiveIndArg::GetTid ( ) const [inline]

void DhChannelReceiveIndArg::SetAdnResult ( UINT8 adn_result ) [inline]

void DhChannelReceiveIndArg::SetChannelData ( const ChannelData & channel_data ) [inline]

void DhChannelReceiveIndArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelReceiveIndArg::SetGenResult ( UINT8 gen_result ) [inline]

void DhChannelReceiveIndArg::SetRemainingDataLength ( UINT16 remaining_data_length ) [inline]

void DhChannelReceiveIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelReceiveReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelReceiveReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelReceiveReqArg:

[legend]
Collaboration diagram for DhChannelReceiveReqArg:

[legend]

Public Types

enum | { ID = 1335 }

Public Member Functions

DhChannelReceiveReqArg ()
UINT8 | GetChannelDataLength () const
UINT8 | GetCidx () const
const SimTkTransactionId & | GetTid () const
void | SetChannelDataLength (UINT8 channel_data_length)
void | SetCidx (UINT8 cidx)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelReceiveReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelReceiveReqArg: reflects arguments of signal DH_CHANNEL_RECEIVE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelReceiveReqArg::DhChannelReceiveReqArg ( )

Member Function Documentation

const DhChannelReceiveReqArg & DhChannelReceiveReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelReceiveReqArg::GetChannelDataLength ( ) const [inline]

UINT8 DhChannelReceiveReqArg::GetCidx ( ) const [inline]

const SimTkTransactionId& DhChannelReceiveReqArg::GetTid ( ) const [inline]

void DhChannelReceiveReqArg::SetChannelDataLength ( UINT8 channel_data_length ) [inline]

void DhChannelReceiveReqArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelReceiveReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelReceiveReqMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelReceiveReqMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DhChannelReceiveReqMsg:

[legend]
Collaboration diagram for DhChannelReceiveReqMsg:

[legend]

Public Types

enum | { ID = 18343 }

Public Member Functions

virtual Message * | Clone () const
DhChannelReceiveReqMsg (ExecutionContext *context, const DhChannelReceiveReqArg &arg)
const DhChannelReceiveReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DhChannelReceiveReqArg &arg)
virtual | ~DhChannelReceiveReqMsg ()

Detailed Description

DhChannelReceiveReqMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelReceiveReqMsg::DhChannelReceiveReqMsg | ( | ExecutionContext * | context,
 |  | const DhChannelReceiveReqArg & | arg
 | ) |

DhChannelReceiveReqMsg::~DhChannelReceiveReqMsg ( ) [virtual]

Member Function Documentation

Message * DhChannelReceiveReqMsg::Clone ( ) const [virtual]

Implements Message.

const DhChannelReceiveReqArg& DhChannelReceiveReqMsg::GetArg ( ) const [inline]

const MsgMetaData & DhChannelReceiveReqMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DhChannelReceiveReqMsg::SetArg ( const DhChannelReceiveReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:11:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelSendIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelSendIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelSendIndArg:

[legend]
Collaboration diagram for DhChannelSendIndArg:

[legend]

Public Types

enum | { ID = 2335 }

Public Member Functions

DhChannelSendIndArg ()
DhChannelSendIndArg (const SimTkTransactionId &tid, UINT8 cidx, UINT16 empty_bytes_in_tx, UINT8 gen_result, UINT8 adn_result)
UINT8 | GetAdnResult () const
UINT8 | GetCidx () const
UINT16 | GetEmptyBytesInTx () const
UINT8 | GetGenResult () const
const SimTkTransactionId & | GetTid () const
void | SetAdnResult (UINT8 adn_result)
void | SetCidx (UINT8 cidx)
void | SetEmptyBytesInTx (UINT16 empty_bytes_in_tx)
void | SetGenResult (UINT8 gen_result)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelSendIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelSendIndArg: reflects arguments of signal DH_CHANNEL_SEND_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelSendIndArg::DhChannelSendIndArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | UINT16 | empty_bytes_in_tx,
 |  | UINT8 | gen_result,
 |  | UINT8 | adn_result
 | ) |

DhChannelSendIndArg::DhChannelSendIndArg ( )

Member Function Documentation

const DhChannelSendIndArg & DhChannelSendIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 DhChannelSendIndArg::GetAdnResult ( ) const [inline]

UINT8 DhChannelSendIndArg::GetCidx ( ) const [inline]

UINT16 DhChannelSendIndArg::GetEmptyBytesInTx ( ) const [inline]

UINT8 DhChannelSendIndArg::GetGenResult ( ) const [inline]

const SimTkTransactionId& DhChannelSendIndArg::GetTid ( ) const [inline]

void DhChannelSendIndArg::SetAdnResult ( UINT8 adn_result ) [inline]

void DhChannelSendIndArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelSendIndArg::SetEmptyBytesInTx ( UINT16 empty_bytes_in_tx ) [inline]

void DhChannelSendIndArg::SetGenResult ( UINT8 gen_result ) [inline]

void DhChannelSendIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelSendReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelSendReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DhChannelSendReqArg:

[legend]
Collaboration diagram for DhChannelSendReqArg:

[legend]

Public Types

enum | { ID = 1333 }

Public Member Functions

DhChannelSendReqArg ()
const ChannelData & | GetChannelData () const
UINT8 | GetCidx () const
const SiSendDataType & | GetSendDataType () const
const SimTkTransactionId & | GetTid () const
void | SetChannelData (const ChannelData &channel_data)
void | SetCidx (UINT8 cidx)
void | SetSendDataType (const SiSendDataType &send_data_type)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DhChannelSendReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DhChannelSendReqArg: reflects arguments of signal DH_CHANNEL_SEND_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelSendReqArg::DhChannelSendReqArg ( )

Member Function Documentation

const DhChannelSendReqArg & DhChannelSendReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChannelData& DhChannelSendReqArg::GetChannelData ( ) const [inline]

UINT8 DhChannelSendReqArg::GetCidx ( ) const [inline]

const SiSendDataType& DhChannelSendReqArg::GetSendDataType ( ) const [inline]

const SimTkTransactionId& DhChannelSendReqArg::GetTid ( ) const [inline]

void DhChannelSendReqArg::SetChannelData ( const ChannelData & channel_data ) [inline]

void DhChannelSendReqArg::SetCidx ( UINT8 cidx ) [inline]

void DhChannelSendReqArg::SetSendDataType ( const SiSendDataType & send_data_type ) [inline]

void DhChannelSendReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DhChannelSendReqMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DhChannelSendReqMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DhChannelSendReqMsg:

[legend]
Collaboration diagram for DhChannelSendReqMsg:

[legend]

Public Types

enum | { ID = 18341 }

Public Member Functions

virtual Message * | Clone () const
DhChannelSendReqMsg (ExecutionContext *context, const DhChannelSendReqArg &arg)
const DhChannelSendReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DhChannelSendReqArg &arg)
virtual | ~DhChannelSendReqMsg ()

Detailed Description

DhChannelSendReqMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DhChannelSendReqMsg::DhChannelSendReqMsg | ( | ExecutionContext * | context,
 |  | const DhChannelSendReqArg & | arg
 | ) |

DhChannelSendReqMsg::~DhChannelSendReqMsg ( ) [virtual]

Member Function Documentation

Message * DhChannelSendReqMsg::Clone ( ) const [virtual]

Implements Message.

const DhChannelSendReqArg& DhChannelSendReqMsg::GetArg ( ) const [inline]

const MsgMetaData & DhChannelSendReqMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DhChannelSendReqMsg::SetArg ( const DhChannelSendReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:11:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DiagnosticIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DiagnosticIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for DiagnosticIndArg:

[legend]
Collaboration diagram for DiagnosticIndArg:

[legend]

Public Types

enum | { ID = 1132 }

Public Member Functions

DiagnosticIndArg ()
const DiagnosticCause & | GetDiagnosticCause () const
const Tipd & | GetTipd () const
void | SetDiagnosticCause (const DiagnosticCause &diagnostic_cause)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const DiagnosticIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DiagnosticIndArg: reflects arguments of signal MN_DIAGNOSTIC_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DiagnosticIndArg::DiagnosticIndArg ( )

Member Function Documentation

const DiagnosticIndArg & DiagnosticIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const DiagnosticCause& DiagnosticIndArg::GetDiagnosticCause ( ) const [inline]

const Tipd& DiagnosticIndArg::GetTipd ( ) const [inline]

void DiagnosticIndArg::SetDiagnosticCause ( const DiagnosticCause & diagnostic_cause ) [inline]

void DiagnosticIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:11:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DiagnosticIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DiagnosticIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DiagnosticIndMsg:

[legend]
Collaboration diagram for DiagnosticIndMsg:

[legend]

Public Types

enum | { ID = 18422 }

Public Member Functions

virtual Message * | Clone () const
DiagnosticIndMsg (ExecutionContext *context, const Tipd &tipd, const DiagnosticCause &diagnostic_cause)
const DiagnosticCause & | GetDiagnosticCause () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
virtual | ~DiagnosticIndMsg ()

Detailed Description

DiagnosticIndMsg: sent when Diagnostic Information is sent from stack

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DiagnosticIndMsg::DiagnosticIndMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const DiagnosticCause & | diagnostic_cause
 | ) |

DiagnosticIndMsg::~DiagnosticIndMsg ( ) [virtual]

Member Function Documentation

Message * DiagnosticIndMsg::Clone ( ) const [virtual]

Implements Message.

const DiagnosticCause& DiagnosticIndMsg::GetDiagnosticCause ( ) const [inline]

const MsgMetaData & DiagnosticIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const Tipd& DiagnosticIndMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:11:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DialogWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DialogWindow Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/DialogWindow.hpp>

Inheritance diagram for DialogWindow:

[legend]
Collaboration diagram for DialogWindow:

[legend]

Public Types

enum | ReturnId { ConfirmId, CancelId }
Specifies the selection of the user. More...

Public Member Functions

virtual | ~DialogWindow ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()

Detailed Description

Obsolete, as it offers no benefit to the base-class Window.

Member Enumeration Documentation

enum DialogWindow::ReturnId

Specifies the selection of the user.

Enumerator:
ConfirmId | User confirmed the DialogWindow.
CancelId | User canceled the DialogWindow.

Constructor & Destructor Documentation

DialogWindow::~DialogWindow ( ) [virtual]

Member Function Documentation

BOOLEAN DialogWindow::OnCancel ( ) [protected, virtual]

Closes the window, if it gets the message Message::WinCancelMsg.

See also:
Window::OnCancel

BOOLEAN DialogWindow::OnConfirm ( ) [protected, virtual]

Closes the window, if it gets the message Message::WinConfirmMsg.

See also:
Window::OnConfirm

The documentation for this class was generated from the following files:
  • Compat/DialogWindow.hpp
  • Compat/DialogWindow.cpp
Generated on Wed Jan 25 01:11:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DirectoryIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DirectoryIterator Class Reference
[Root File System]

Client interface and base class for directory iterators. More...

#include <Apoxi/Afs/Rfs/DirectoryIterator.hpp>

Inheritance diagram for DirectoryIterator:

[legend]
Collaboration diagram for DirectoryIterator:

[legend]

Public Member Functions

virtual File::Error | GetLastError () const
virtual const Path & | GetPath () const
virtual const Pathname & | GetPathname () const
virtual void | Increment ()
BOOLEAN | IsValid () const
virtual | ~DirectoryIterator ()
Destroys the directory iterator.

Protected Member Functions

void | ApplyInitialFilter ()
virtual DirectoryIterator & | AtomicIncrement ()=0
DirectoryIterator (const Pathname &dir_pathname, const FileFilterPtr &filter, const WString &device_Id)

Protected Attributes

Path m_cur_path
const Pathname | m_dir_pathname
The directory pathname this iterator was opened for.
FileFilterPtr m_filter
The filter functor to apply.
File::Error m_last_error

Detailed Description

Client interface and base class for directory iterators.

Abstract class DirectoryIterator defines the interface for directory iterators. A directory iterator is initialized with a directory pathname and iterates over files and directories in this directory. The files to be iterated can be filtered. Subdirectories are not recursively iterated, this has to be programmed by the client explicitly.

Since a virtual root storage device which unifies all storage devices that are actually registered to the root file system is available (device Id rfs), it is rather easy to write code for iterating any directory on any storage device. A function which takes the path of a directory to be iterated and a string to write the contents of this directory to could actually look like this:

    static BOOLEAN IterateDirectory(Pathname dir_pathname, WString &dir_content)
    {
        // Get the directory iterator from the root file system.
        DirectoryIteratorPtr itor = RootFileSystem::GetDirectoryIterator(
            dir_pathname,       // The directory to iterate.
            FileFilterPtr(0),   // Empty filter, we get all files.
            L"rfs");            // Storage device Id of the virtual root device.

        if (!itor.IsValid()) {
            DBG_OUT((0, L"A directory iterator could not be created.\n"));
            return FALSE;
        }

        // Iterate all entries in the directory and write the pathnames of the
        // entries to string dir_content.
        for ( ; itor->IsValid(); itor->Increment()) {
            const Pathname &actual_pathname = itor->GetPathname();
            dir_content << actual_pathname.ToWString() << L"\n";
        }

        return TRUE;
    }

If you pass for example path /ffs as parameter dir_pathname to the function above then the contents of the flash file system gets written to dir_content since the virtual root storage device holds all the storage devices currently registered to the system as entries of its first-level directory. Hence, to get a list of all the registered storage devices you can pass the root directory / to the function.

Nevertheless you might prefer to work with a dedicated storage device directly. One reason for this might be the fact that it is slightly faster because of implementation issues. Of course this is also possible. E.g., for iterating all files stored on the flash file system, see the following sample function:

    static BOOLEAN IterateFlashStorageDevice()
    {
        // Get the directory iterator from the root file system.
        DirectoryIteratorPtr itor = RootFileSystem::GetDirectoryIterator(
            Pathname(),         // Constructs the root pathname "/".
            FileFilterPtr(0),   // Empty filter, we get all files.
            L"ffs");            // Storage device Id string of the flash device.

        if (!itor.IsValid()) {
            DBG_OUT((0, L"A directory iterator could not be created.\n"));
            return FALSE;
        }

        for ( ; itor->IsValid(); itor->Increment()) {
            const Pathname &actual_pathname = itor->GetPathname();

            // Work with the pathname...
        }

        return TRUE;
    }

Caveat: if the file that a valid iterator points to is deleted then the iterator gets invalid! Using it further on results in undefined behavior and is not allowed. This has to be assured by the client logic.

Constructor & Destructor Documentation

DirectoryIterator::~DirectoryIterator ( ) [virtual]

Destroys the directory iterator.

DirectoryIterator::DirectoryIterator | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter,
 |  | const WString & | device_Id
 | ) | [explicit, protected]

Constructs a directory iterator for directory dir_pathname on storage device with storage device Id device_Id. The iterator retrieves files and directories whose names comply with filter. This is the only constructor since a non-initialized directory iterator is not allowed. Subclasses have to provide a constructor with the same formal arguments and must initialize m_cur_path to either

  • the pathname of the first file or directory in directory dir_pathname or to
  • the root pathname signaling the end iterator.

Parameters:
dir_pathname | The pathname of the directory whose files and subdirectories are to be iterated.
filter | A file filter functor.
device_Id | The Id of the storage device.

Member Function Documentation

void DirectoryIterator::ApplyInitialFilter ( ) [protected]

This method has to be called at the end of the constructor of any derived class. Precondition is that m_cur_path is either the

  • pathname of the first file or directory in directory dir_pathname or
  • the root pathname signaling the end iterator. It checks if m_cur_path complies to the given filter criterion and if not, iterates to the first file or directory complying to it.

virtual DirectoryIterator& DirectoryIterator::AtomicIncrement ( ) [protected, pure virtual]

Increments the iterator to point to the next pathname in the directory and returns a reference to itself. This increment operation does not consider the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

Returns:
Reference to itself incremented to point to the next pathname or to the root pathname signaling the end iterator.

Implemented in FatDirectoryIteratorImp, FlashDirectoryIteratorImp, RamDirectoryIteratorImp, and RootDirectoryIteratorImp.

File::Error DirectoryIterator::GetLastError ( ) const [virtual]

Returns the error occurred by the last operation.

Reimplemented in RootDirectoryIteratorImp.

const Path & DirectoryIterator::GetPath ( ) const [virtual]

Returns the path of the file or directory the iterator currently points to. Only valid iterators are allowed to be accessed. If the iterator is the end iterator, i.e. the current pathname is the root pathname, then an assertion holds.

const Pathname & DirectoryIterator::GetPathname ( ) const [virtual]

Returns the pathname of the file or directory the iterator currently points to. Only valid iterators are allowed to be accessed. If the iterator is the end iterator, i.e. the current pathname is the root pathname, then an assertion holds.

void DirectoryIterator::Increment ( ) [virtual]

Increments the iterator to refer to the next pathname or to the root pathname if the iterator gets invalid. This increment operation considers the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

Reimplemented in RootDirectoryIteratorImp.

BOOLEAN DirectoryIterator::IsValid ( ) const

Tells if the iterator points to some file or directory. This is determined by simply checking the current pathname. If the current pathname is the root pathname it is not valid, otherwise it is valid. Note that if the file that the iterator points to is deleted the iterator gets invalid and must not be used anymore. This has to be assured by the client logic, otherwise undefined behavior is the consequence.

Returns:
Returns if the iterator is valid.

Field Documentation

Path DirectoryIterator::m_cur_path [protected]

The pathname the iterator currently points to. The root pathname signals the end iterator.

const Pathname DirectoryIterator::m_dir_pathname [protected]

The directory pathname this iterator was opened for.

FileFilterPtr DirectoryIterator::m_filter [protected]

The filter functor to apply.

File::Error DirectoryIterator::m_last_error [mutable, protected]

The documentation for this class was generated from the following files:
  • Afs/Rfs/DirectoryIterator.hpp
  • Afs/Rfs/DirectoryIterator.cpp
Generated on Wed Jan 25 01:11:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DirtyFileHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DirtyFileHandler Class Reference
[Afs]

#include <Apoxi/Afs/DirtyFileHandler.hpp>

Collaboration diagram for DirtyFileHandler:

[legend]

Public Member Functions

~DirtyFileHandler ()
default destructor

Static Public Member Functions

static BOOLEAN | FlushDirtyFile ()
flush the dirtybuffer to dirtyfile
static BOOLEAN | GetDirtyFlag ()
returns dirtyflag
static INT16 | GetLastTransaction ()
returns last transactionid
static BOOLEAN | Init ()
creates dirtyfile and updates dirty buffer
static void | SetDirtyFlag (BOOLEAN flag)
sets dirtyflag
static void | SetLastTransaction (INT16 last_commited_transaction)
sets lasttransactionid

Detailed Description

structure dirty file handler

Constructor & Destructor Documentation

DirtyFileHandler::~DirtyFileHandler ( ) [inline]

default destructor

Member Function Documentation

BOOLEAN DirtyFileHandler::FlushDirtyFile ( ) [static]

flush the dirtybuffer to dirtyfile

------------------------------------------------------------------------ FlushDirtyFile ------------------------------------------------------------------------

BOOLEAN DirtyFileHandler::GetDirtyFlag ( ) [static]

returns dirtyflag

------------------------------------------------------------------------ GetDirtyFlag ------------------------------------------------------------------------

INT16 DirtyFileHandler::GetLastTransaction ( ) [static]

returns last transactionid

------------------------------------------------------------------------ GetLastTransaction ------------------------------------------------------------------------

BOOLEAN DirtyFileHandler::Init ( ) [static]

creates dirtyfile and updates dirty buffer

------------------------------------------------------------------------ Init ------------------------------------------------------------------------

void DirtyFileHandler::SetDirtyFlag ( BOOLEAN flag ) [static]

sets dirtyflag

------------------------------------------------------------------------ SetDirtyFlag ------------------------------------------------------------------------

void DirtyFileHandler::SetLastTransaction ( INT16 last_commited_transaction ) [static]

sets lasttransactionid

------------------------------------------------------------------------ SetLastTransaction ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/DirtyFileHandler.hpp
  • Afs/DirtyFileHandler.cpp
Generated on Wed Jan 25 01:11:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisabledFeatureTriggeredMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DisabledFeatureTriggeredMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for DisabledFeatureTriggeredMsg:

[legend]
Collaboration diagram for DisabledFeatureTriggeredMsg:

[legend]

Public Types

enum | { ID = 13008 }

Public Member Functions

virtual Message * | Clone () const
DisabledFeatureTriggeredMsg (ExecutionContext *context, const FeatureID &feature_id)
const FeatureID & | GetFeatureId () const
virtual const MsgMetaData & | GetMetaData () const
void | SetFeatureId (const FeatureID &feature_id)
virtual | ~DisabledFeatureTriggeredMsg ()

Detailed Description

UpdateItemMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DisabledFeatureTriggeredMsg::DisabledFeatureTriggeredMsg | ( | ExecutionContext * | context,
 |  | const FeatureID & | feature_id
 | ) |

DisabledFeatureTriggeredMsg::~DisabledFeatureTriggeredMsg ( ) [virtual]

Member Function Documentation

Message * DisabledFeatureTriggeredMsg::Clone ( ) const [virtual]

Implements Message.

const FeatureID& DisabledFeatureTriggeredMsg::GetFeatureId ( ) const [inline]

const MsgMetaData & DisabledFeatureTriggeredMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DisabledFeatureTriggeredMsg::SetFeatureId ( const FeatureID & feature_id ) [inline]

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 01:11:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Dispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Dispatcher Class Reference
[Kernel]

#include <Apoxi/Kernel/Dispatcher.hpp>

Inheritance diagram for Dispatcher:

[legend]

Public Member Functions

Dispatcher ()
void | SendSelf (const Message &msg)
virtual | ~Dispatcher ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)=0
virtual BOOLEAN | RouteMessage (const Message &msg)

Detailed Description

A dispatcher is capable of routing and retrieving messages and represents one of the most important base classes of APOXI (e. g. the classes Application and Window are derived from Dispatcher). The whole communication between applications and inside applications is done by messages. A message send to a dispatcher can be treated in OnMessage.

Constructor & Destructor Documentation

Dispatcher::Dispatcher ( )

Dispatcher::~Dispatcher ( ) [virtual]

Member Function Documentation

virtual BOOLEAN Dispatcher::OnMessage ( const Message & msg ) [protected, pure virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implemented in SimUserDispatcher, HttpHandler, WapHandler, LcsProviderImpl, GltpProviderImpl, SaProviderImpl, SvgPlayer, T9PredictiveInputBox, UsbTransport, Zi8PredictiveInputBox, StackMsgDispatcher, AtlApplication, AtlApplicationPlugin, AtlWindow, AtlItemBox, AtlItemGridWindow, AtlItemMenuWindow, AtlLabelListWindow, BtAvrcpOperationService, BtAvrcpService, BtBppService, BtDevicePairRequest, BtDeviceSearchRequest, BtDeviceTrustRequest, BtDeviceUnpairRequest, BtDeviceUntrustRequest, BtLocalRequest, BtLocalSettings, BtQuerySupportedProfilesRequest, BtRespondAuthorizationRequest, BtSddbService, BtSendPasskeyRequest, BtServiceVerifyRequest, BtSetRemoteDeviceNameRequest, BtDunService, BtFaxService, BtHfService, BtHsService, BtObexService, AbstractMenuAccessor, AtlItemGrid, AtlItemMenu, IndicatorBar, Menu, MenuAccessor, SharedTimer, SoftkeyBar, GenericAudioDevice, AbstractButton, AbstractEditor, AbstractItemGrid, Alert, Component, ContextMenu, Desktop, DrawableObject, ImageBox, ItemBox, ItemTree, Model, TabControl, Window, Application, MessageMapDispatcher, SavingProgressWin, GltpConnApp, and UibFolderWin.

BOOLEAN Dispatcher::RouteMessage ( const Message & msg ) [protected, virtual]

This method implements the routing logic for all messages. The default implementation is only calling OnMessage. The routing sequence for Application::RouteMessage and Control::RouteMessage is much more complex. When routing messages through several dispatchers, a message which has already been dispatched by a dispatcher won't be routed anymore to other dispatchers.

Reimplemented in T9PredictiveInputBox, Zi8PredictiveInputBox, AtlApplication, Control, and Application.

void Dispatcher::SendSelf ( const Message & msg ) [inline]

Sends the message msg synchronous to the dispatcher and invokes RouteMessage, which routes the message. For sending a message asynchronous use Message::Post(), which will broadcast the message to all applications, which have subscribed for this message.

The documentation for this class was generated from the following files:
  • Kernel/Dispatcher.hpp
  • Kernel/Dispatcher.cpp
Generated on Wed Jan 25 01:11:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DispatcherAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DispatcherAction Class Reference
[Kernel]

#include <Apoxi/Kernel/DispatcherAction.hpp>

Inheritance diagram for DispatcherAction:

[legend]
Collaboration diagram for DispatcherAction:

[legend]

Public Member Functions

DispatcherAction (const Dispatcher &dispatcher, Action *action)
Action * | GetAction () const
const Dispatcher & | GetDispatcher () const

Constructor & Destructor Documentation

DispatcherAction::DispatcherAction | ( | const Dispatcher & | dispatcher,
 |  | Action * | action
 | ) | [inline]

Member Function Documentation

Action* DispatcherAction::GetAction ( ) const [inline]

const Dispatcher& DispatcherAction::GetDispatcher ( ) const [inline]

The documentation for this class was generated from the following file:
  • Kernel/DispatcherAction.hpp
Generated on Wed Jan 25 01:11:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Display Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Display Class Reference
[Devices]

#include <Apoxi/Devices/Display.hpp>

Inheritance diagram for Display:

[legend]
Collaboration diagram for Display:

[legend]

Public Types

enum | BacklightMode { BacklightModeOff, BacklightModeAuto, BacklightModeOn }
enum Info {
PowerTurnedOn, PowerTurnedOff, BacklightTurnedOn, BacklightTurnedOff,
DisplayTimeout
}
enum | PowerMode { PowerModeOff, PowerModeAuto, PowerModeOn }

Public Member Functions

Display (INT index)
virtual BacklightMode | GetBacklightMode () const
virtual INT | GetBrightness () const
virtual INT | GetContrast () const
virtual PowerMode | GetPowerMode () const
virtual VideoChannel * | GetVideoChannel ()
virtual void | IndicateAlphaMaskUpdate ()
virtual BOOLEAN | IsBacklightOn () const
virtual BOOLEAN | IsCallbackActive () const
BOOLEAN | IsLocked () const
virtual BOOLEAN | IsPowerOn () const
virtual void | ReactivateBacklight ()
virtual void | ReactivatePower ()
void | Refresh (BOOLEAN block, const CustomFrameBuffer *custom_frame_buf=0)
virtual void | Refresh (const CustomFrameBuffer *custom_frame_buf)
virtual void | Refresh ()
virtual void | SetBacklightMode (BacklightMode mode)
virtual void | SetBacklightTimeout (UINT32 timeout)
virtual void | SetBrightness (INT brightness)
Sets the display brightness specified in percentage (0 - 100).
virtual void | SetCallbackActive (BOOLEAN state)
virtual void | SetContrast (INT contrast)
Sets display contrast specified in percentage (0 - 100).
virtual void | SetCustomFrameBufferRect (const Rect &rect)
void | SetLocked (BOOLEAN locked)
virtual void | SetPowerMode (PowerMode mode)
virtual void | SetPowerTimeout (UINT32 timeout)
virtual | ~Display ()

Data Structures

class | CustomFrameBuffer

Detailed Description

Provides methods for accessing the display in a generic way. For the application developer it is recommended to use the class DeviceContext for drawing operations. Using the display device directly is possible but it is important to know, that this approach bypasses the APOXI window system.

Member Enumeration Documentation

enum Display::BacklightMode

Defines the mode for the backlight, which can be set by Display::SetBacklightMode.

Enumerator:
BacklightModeOff | Backlight is continuously off.
BacklightModeAuto | Backlight is on as long ReactivateBacklight is called and turns off automatically after the adjusted timeout given by SetBacklightTimeout.
BacklightModeOn | Backlight is continuously on.

enum Display::Info

The message DisplayInfoMsg will be posted to the system with one of the following parameters as soon as the backlight or the power state changes:

Enumerator:
PowerTurnedOn
PowerTurnedOff
BacklightTurnedOn
BacklightTurnedOff
DisplayTimeout

enum Display::PowerMode

Defines the mode for the power handling, which can be set by Display::SetPowerMode.

Enumerator:
PowerModeOff | Power is continuously off.
PowerModeAuto | Power is on as long ReactivatePower is called and turns off automatically after the adjusted timeout given by SetPowerTimeout. Note that the Power is on as long the backlight is on.
PowerModeOn | Power is continuously on.

Constructor & Destructor Documentation

Display::Display ( INT index )

Parameters:
index Index of the display. Usually the main display has the index 0 and the sub display index 1.

Display::~Display ( ) [virtual]

Member Function Documentation

Display::BacklightMode Display::GetBacklightMode ( ) const [virtual]

Returns:
Mode of the backlight

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

INT Display::GetBrightness ( ) const [virtual]

Returns:
Display brightness specified in percentage (0 - 100).

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

INT Display::GetContrast ( ) const [virtual]

Returns:
Display contrast specified in percentage (0 - 100)

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

Display::PowerMode Display::GetPowerMode ( ) const [virtual]

Returns:
Mode of the power

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

VideoChannel * Display::GetVideoChannel ( ) [virtual]

Returns a pointer to the video channel. It depends on the implementation of the device, whether a video channel is supported.

See also:
VideoChannel

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::IndicateAlphaMaskUpdate ( ) [virtual]

Indicates that the alpha mask which is used for blending the video channel with the display content (see Display::Refresh) might have changed. Per default this method is invoked by APOXI whenever a window is opened, closed, resized or moved. This method is useful for companion chips which do the alpha-blending itself: the updated alpha-mask should be transferred to the companion chip within this method. If no companion chip is used the implementation of this method can be empty, as the blending of the alpha-mask with the video-channel is done in each Display::Refresh.

BOOLEAN Display::IsBacklightOn ( ) const [virtual]

Returns:
Status of backlight (on or off)

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

BOOLEAN Display::IsCallbackActive ( ) const [virtual]

Interface for retrieving information on Callback state

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

BOOLEAN Display::IsLocked ( ) const [inline]

Returns TRUE, if the refreshing of the display will be locked.

See also:
Display::SetLocked

Display::Refresh

BOOLEAN Display::IsPowerOn ( ) const [virtual]

Returns:
Status of power (on or off)

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::ReactivateBacklight ( ) [virtual]

Call this method for example on each key press to turn on the backlight. Then it automatically turns off the display backlight after the adjusted timeout.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::ReactivatePower ( ) [virtual]

Call this method as long as you want to keep the display powered on. When you stop calling that method the power turns off automatically after the adjusted timeout. Note that ReactivatPower will be called internally as long as the backlight is on.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::Refresh | ( | BOOLEAN | block,
 |  | const CustomFrameBuffer * | custom_frame_buf = 0
 | ) |

Obsolete - provided for backward compatibility (The parameter block will be ignored). Use Display::Refresh(const CustomFrameBuffer* custom_frame_buf) instead.

void Display::Refresh ( const CustomFrameBuffer * custom_frame_buf ) [virtual]

Refreshes the display area specified by the blitting-rectangle (see Display::SetBlitRect and Display::GetBlitRect). Whether the refreshing is done synchronous or asynchronous, depends on the capabilities of the low-level display device. Per default APOXI does not block when refreshing the display, hence block is set to FALSE. If the update should be done synchronous, set block to TRUE and APOXI will wait until the low-level display device has finished the refreshing.

Parameters:
custom_frame_buf Optional parameter which allows to pass a custom frame buffer for refreshing instead of using the internal frame buffer.

void Display::Refresh ( ) [virtual]

See also:
VirtualDisplay::Refresh

Reimplemented from VirtualDisplay.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::SetBacklightMode ( BacklightMode mode ) [virtual]

Parameters:
mode See Display::BacklightMode.

void Display::SetBacklightTimeout ( UINT32 timeout ) [virtual]

Parameters:
timeout Timeout value in milliseconds. After this time without calling ReactivateBacklight the backlight turns off.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::SetBrightness ( INT brightness ) [virtual]

Sets the display brightness specified in percentage (0 - 100).

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::SetCallbackActive ( BOOLEAN state ) [virtual]

Interface for disabling the callback function for display refresh.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::SetContrast ( INT contrast ) [virtual]

Sets display contrast specified in percentage (0 - 100).

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::SetCustomFrameBufferRect ( const Rect & rect ) [virtual]

Sets the boundaries of the custom frame buffer. A custom frame buffer can be passed with the method Display::Refresh. The boundaries must be consistent with the passed frame buffer. If no custom frame buffer will be used anymore, Display::SetCustomFrameBufferRect(Rect()) must be invoked.

Reimplemented in DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void Display::SetLocked ( BOOLEAN locked ) [inline]

If locked is TRUE, the refreshing of the display will be locked until Display::SetLocked(FALSE) is invoked. Nothing is blocked, just the refreshing will be skipped.

See also:
Display::Refresh

void Display::SetPowerMode ( PowerMode mode ) [virtual]

Parameters:
mode See Display::PowerMode.

void Display::SetPowerTimeout ( UINT32 timeout ) [virtual]

Parameters:
timeout Timeout value in milliseconds. After this time without calling ReactivatePower the power turns off.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

The documentation for this class was generated from the following files:
  • Devices/Display.hpp
  • Devices/Display.cpp
Generated on Wed Jan 25 01:11:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Display::CustomFrameBuffer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Display::CustomFrameBuffer

Display::CustomFrameBuffer Class Reference

#include <Apoxi/Devices/Display.hpp>

Collaboration diagram for Display::CustomFrameBuffer:

[legend]

Public Member Functions

CustomFrameBuffer (const Bitmap &bmp, const Rect &blit_rect)
const Bitmap & | GetBitmap () const
const Rect & | GetBlitRect () const

Detailed Description

Describes a custom frame buffer which can be passed to Display::Refresh to bypass the internal frame buffer. Using this feature is only recommended when the full control of the display is guaranteed.

Constructor & Destructor Documentation

Display::CustomFrameBuffer::CustomFrameBuffer | ( | const Bitmap & | bmp,
 |  | const Rect & | blit_rect
 | ) | [inline]

Parameters:
bmp | Bitmap which represents the custom frame buffer. It is recommended that the width of the custom frame buffer is equal to the width of the display, as this usually allows to implement a faster transfer.
blit_rect | The blitting rectangle describes the area of the bitmap which should be copied to the display.

Member Function Documentation

const Bitmap& Display::CustomFrameBuffer::GetBitmap ( ) const [inline]

const Rect& Display::CustomFrameBuffer::GetBlitRect ( ) const [inline]

The documentation for this class was generated from the following file:
  • Devices/Display.hpp
Generated on Wed Jan 25 01:11:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplayConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DisplayConfig Class Reference
[Config]

#include <DisplayConfig.hpp>

Static Public Member Functions

static INT | GetBitsPerPixel (INT display_idx)
static const ColorSegmentation & | GetColorSegmentation (INT display_idx)
Returns the color segmentation of the display with the index display_idx.
static const ColorTable & | GetColorTable (INT display_idx)
static INT | GetDisplayCount ()
static UINT8 GDI_HUGE * | GetFrameBuffer (INT display_idx)
static XYDIM | GetHeight (INT display_idx)
Returns the height of display with the index display_idx.
static UINT8 GDI_HUGE * | GetMaskBuffer (INT display_idx)
static UINT8 GDI_HUGE * | GetTransferBuffer (INT display_idx)
static XYDIM | GetWidth (INT display_idx)
Returns the width of display with the index display_idx.
static BOOLEAN | PlanesMode (INT display_idx)

Detailed Description

Allows accessing the display configuration. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static INT DisplayConfig::GetBitsPerPixel ( INT display_idx ) [static]

Returns the number of bits per pixel that are used for the color information.

static const ColorSegmentation& DisplayConfig::GetColorSegmentation ( INT display_idx ) [static]

Returns the color segmentation of the display with the index display_idx.

static const ColorTable& DisplayConfig::GetColorTable ( INT display_idx ) [static]

Returns the ColorTable of display with the index display_idx. If Display::PlanesMode returns FALSE an empty color table may returned as the colors are part of the pixel itself.

static INT DisplayConfig::GetDisplayCount ( ) [static]

Returns the number of displays. If two displays are used then 0 usually represents the main display and 1 the sub display.

static UINT8 GDI_HUGE* DisplayConfig::GetFrameBuffer ( INT display_idx ) [static]

Returns a pointer to the frame buffer. The frame buffer is used by APOXI for doing the drawing operations.

Parameters:
display_idx Index of the display. Usually 0 represents the main display and 1 the sub display.

static XYDIM DisplayConfig::GetHeight ( INT display_idx ) [static]

Returns the height of display with the index display_idx.

static UINT8 GDI_HUGE* DisplayConfig::GetMaskBuffer ( INT display_idx ) [static]

Returns a pointer to the mask buffer which is used to mix the video layer with the frame buffer of the display device. Return 0, is no mixing is required.

Parameters:
display_idx Index of the display. Usually 0 represents the main display and 1 the sub display.

static UINT8 GDI_HUGE* DisplayConfig::GetTransferBuffer ( INT display_idx ) [static]

Returns a pointer to the transfer buffer which contains a copy of the frame buffer to allow an asynchronous DMA by a low level display driver. 0 may be returned if no transfer buffer should be used, but this may slow down the drawing process. The transfer buffer must have the same size as the frame buffer.

Parameters:
display_idx Index of the display. Usually 0 represents the main display and 1 the sub display.

static XYDIM DisplayConfig::GetWidth ( INT display_idx ) [static]

Returns the width of display with the index display_idx.

static BOOLEAN DisplayConfig::PlanesMode ( INT display_idx ) [static]

Returns TRUE, if display with the index display_idx is organized in the plane format. FALSE is returned, if the display is organized in bits-per-pixel format.

The documentation for this class was generated from the following file:
  • DisplayConfig.hpp
Generated on Wed Jan 25 01:11:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplayDc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DisplayDc Class Reference
[GUI]

DeviceContext that encompasses the complete display. More...

#include <Apoxi/Gui/DisplayDc.hpp>

Inheritance diagram for DisplayDc:

[legend]
Collaboration diagram for DisplayDc:

[legend]

Public Member Functions

virtual void | AdjustBoundingRect ()
DisplayDc (Display *display)
DisplayDc ()
void | Init (Display *display)
virtual | ~DisplayDc ()

Detailed Description

DeviceContext that encompasses the complete display.

Constructor & Destructor Documentation

DisplayDc::DisplayDc ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

DisplayDc::DisplayDc ( Display * display )

DisplayDc::~DisplayDc ( ) [virtual]

Member Function Documentation

void DisplayDc::AdjustBoundingRect ( ) [virtual]

See also:
DeviceContext::AdjustBoundingRect()

Reimplemented from DeviceContext.

void DisplayDc::Init ( Display * display )

The documentation for this class was generated from the following files:
  • Gui/DisplayDc.hpp
  • Gui/DisplayDc.cpp
Generated on Wed Jan 25 01:11:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplayInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DisplayInfoMsg Class Reference

#include <Apoxi/Devices/DisplayMsgTypes.hpp>

Inheritance diagram for DisplayInfoMsg:

[legend]
Collaboration diagram for DisplayInfoMsg:

[legend]

Public Types

enum | { ID = 9060 }

Public Member Functions

virtual Message * | Clone () const
DisplayInfoMsg (const Display::Info &info, INT index=0)
INT | GetIndex () const
const Display::Info & | GetInfo () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~DisplayInfoMsg ()

Detailed Description

DisplayInfoMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DisplayInfoMsg::DisplayInfoMsg | ( | const Display::Info & | info,
 |  | INT | index = 0
 | ) |

DisplayInfoMsg::~DisplayInfoMsg ( ) [virtual]

Member Function Documentation

Message * DisplayInfoMsg::Clone ( ) const [virtual]

Implements Message.

INT DisplayInfoMsg::GetIndex ( ) const [inline]

const Display::Info& DisplayInfoMsg::GetInfo ( ) const [inline]

const MsgMetaData & DisplayInfoMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Devices/DisplayMsgTypes.hpp
  • Devices/DisplayMsgTypes.cpp
Generated on Wed Jan 25 01:11:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplayMemoryAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DisplayMemoryAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for DisplayMemoryAction:

[legend]
Collaboration diagram for DisplayMemoryAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN DisplayMemoryAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:11:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplaySettings Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DisplaySettings Class Reference
[MediaFramework]

#include <Apoxi/AddOns/MediaFramework/DisplaySettings.hpp>

Collaboration diagram for DisplaySettings:

[legend]

Public Types

enum | ScaleType { DownscaleToBounds, ScaleToBounds }
enum | VideoQuality { LowQuality, MediumQuality, HighQuality }

Public Member Functions

DisplaySettings (const Rect &bounds, ScaleType scale_type, UINT8 display_index=0, BOOLEAN keep_aspect_ratio=TRUE, BOOLEAN is_first_frame_rendered=FALSE)
DisplaySettings ()
const Rect & | GetBounds () const
ScaleType | GetScaleType () const
BOOLEAN | KeepAspectRatio () const

Detailed Description

Display settings for rendering the media-data in the media player and media recorder.
See also:
MediaPlayer

MediaRecorder

Member Enumeration Documentation

enum DisplaySettings::ScaleType

This enum is used in order to determine how the actual image/video is scaled and placed within the video output window (see the parameters in the constructor).

Enumerator:
DownscaleToBounds | If the captured/playing video size is smaller than the bounds (video output window), the video is not scaled at all and is displayed centered within the bounds. If the video is larger than the bounds, the video is downscaled until the whole video content is visible within the bounds.
ScaleToBounds | If the video size is smaller than the bounds, the image is upscaled until the maximum size has been reached at which the whole video content is visible within the bounds. If upscaling is not supported, than the video shall be displayed centered in the original size. If the video is larger than the bounds, the video is downscaled until the whole image is visible within the bounds.

enum DisplaySettings::VideoQuality

Enumerator:
LowQuality
MediumQuality
HighQuality

Constructor & Destructor Documentation

DisplaySettings::DisplaySettings ( )

DefaultConstructor

DisplaySettings::DisplaySettings | ( | const Rect & | bounds,
 |  | ScaleType | scale_type,
 |  | UINT8 | display_index = 0,
 |  | BOOLEAN | keep_aspect_ratio = TRUE,
 |  | BOOLEAN | is_first_frame_rendered = FALSE
 | ) |

Constructor.

Parameters:
bounds | The absolute position and dimensions (in pixels) of the region (window) on the display that is used for video output (playback/viewfinder). It is relative to the upper left hand corner of the (physical) display.
scale_type | Scale type determines how the image content fits into the bounds (video output region).
display_idx | Display index of the display used for video output (playback/viewfinder). The default value corresponds to the main display.
keep_aspect_ratio | it determines if the aspect ratio (between x and y coordinates) shall be kept
is_first_frame_rendered

Member Function Documentation

const Rect& DisplaySettings::GetBounds ( ) const [inline]

GetBounds

ScaleType DisplaySettings::GetScaleType ( ) const [inline]

GetScaleType

BOOLEAN DisplaySettings::KeepAspectRatio ( ) const [inline]

KeepAspectRatio

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/DisplaySettings.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/DisplaySettings.cpp
Generated on Wed Jan 25 01:12:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplayTextReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DisplayTextReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DisplayTextReqArg:

[legend]
Collaboration diagram for DisplayTextReqArg:

[legend]

Public Types

enum | { ID = 1307 }

Public Member Functions

DisplayTextReqArg ()
const SimIconIdentifier & | GetIcon () const
const SimDisplayTextOptions & | GetOptions () const
const SimTextString & | GetTextString () const
const SimTkTransactionId & | GetTid () const
BOOLEAN | IsImmediateResponse () const
void | SetIcon (const SimIconIdentifier &icon)
void | SetImmediateResponse (BOOLEAN immediate_response)
void | SetOptions (const SimDisplayTextOptions &options)
void | SetTextString (const SimTextString &text_string)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DisplayTextReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DisplayTextReqArg: reflects arguments of signal SI_DISPLAY_TEXT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DisplayTextReqArg::DisplayTextReqArg ( )

Member Function Documentation

const DisplayTextReqArg & DisplayTextReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconIdentifier& DisplayTextReqArg::GetIcon ( ) const [inline]

const SimDisplayTextOptions& DisplayTextReqArg::GetOptions ( ) const [inline]

const SimTextString& DisplayTextReqArg::GetTextString ( ) const [inline]

const SimTkTransactionId& DisplayTextReqArg::GetTid ( ) const [inline]

BOOLEAN DisplayTextReqArg::IsImmediateResponse ( ) const [inline]

void DisplayTextReqArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void DisplayTextReqArg::SetImmediateResponse ( BOOLEAN immediate_response ) [inline]

void DisplayTextReqArg::SetOptions ( const SimDisplayTextOptions & options ) [inline]

void DisplayTextReqArg::SetTextString ( const SimTextString & text_string ) [inline]

void DisplayTextReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:12:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DisplayTextRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DisplayTextRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for DisplayTextRspArg:

[legend]
Collaboration diagram for DisplayTextRspArg:

[legend]

Public Types

enum | { ID = 2307 }

Public Member Functions

DisplayTextRspArg ()
DisplayTextRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)
const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const DisplayTextRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DisplayTextRspArg: reflects arguments of signal SI_DISPLAY_TEXT_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DisplayTextRspArg::DisplayTextRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

DisplayTextRspArg::DisplayTextRspArg ( )

Member Function Documentation

const DisplayTextRspArg & DisplayTextRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& DisplayTextRspArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& DisplayTextRspArg::GetTid ( ) const [inline]

void DisplayTextRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void DisplayTextRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:12:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DistinctProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DistinctProvider Class Reference

#include <Apoxi/Auxiliary/DistinctProvider.hpp>

Inheritance diagram for DistinctProvider:

[legend]
Collaboration diagram for DistinctProvider:

[legend]

Public Types

typedef FilterProvider | Base

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row and all undistinct rows.
DistinctProvider (Provider *provider, INT columnid=0)
DistinctProvider ()
virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
GetChildRow gives the mapping of row to the row in the child provider
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
em>SetDataItem writes data items to an internal buffer.
void | Init (Provider *provider, INT columnid=0)
The same interface as the constructor.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual void | SetFilterColumn (INT filtercolumn)
Specify on which column rule has to be applied.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and starts the filter process.
virtual | ~DistinctProvider ()

Protected Member Functions

virtual BOOLEAN | GetMappedRow (INT &mapped_row, INT row)

Detailed Description

A DistinctProvider is a filter provider and is used to access only distinct rows of a specified columnid of a child provider. See also: Provider, FilterProvider, DataItem, FilterRule.

Member Typedef Documentation

typedef FilterProvider DistinctProvider::Base

Reimplemented from FilterProvider.

Constructor & Destructor Documentation

DistinctProvider::DistinctProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

DistinctProvider::DistinctProvider | ( | Provider * | provider,
 |  | INT | columnid = 0
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be filtered. columnid: Specify which columnid should be distinct.

DistinctProvider::~DistinctProvider ( ) [virtual]

Member Function Documentation

BOOLEAN DistinctProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row. If an update is done for the distinct columnid the update is commited to all undistinct rows.

Reimplemented from AbstractDelegationProvider.

BOOLEAN DistinctProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row and all undistinct rows.

Reimplemented from AbstractDelegationProvider.

BOOLEAN DistinctProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

GetChildRow gives the mapping of row to the row in the child provider

Reimplemented from FilterProvider.

BOOLEAN DistinctProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

em>SetDataItem writes data items to an internal buffer.

Reimplemented from FilterProvider.

BOOLEAN DistinctProvider::GetMappedRow | ( | INT & | mapped_row,
 |  | INT | row
 | ) | [protected, virtual]

Reflects by default GetChildRow. If a derived provider class implements a multistage manipulation on the child-provider, the child row of the very first stage must be returned.

Reimplemented from AbstractDelegationProvider.

void DistinctProvider::Init | ( | Provider * | provider,
 |  | INT | columnid = 0
 | ) |

The same interface as the constructor.

BOOLEAN DistinctProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

SetDataItem reflects SetDataItem of the child-provider. according to GetMappedRow. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

void DistinctProvider::SetFilterColumn ( INT filtercolumn ) [virtual]

Specify on which column rule has to be applied.

Reimplemented from FilterProvider.

BOOLEAN DistinctProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and starts the filter process.

Reimplemented from FilterProvider.

The documentation for this class was generated from the following files:
  • Auxiliary/DistinctProvider.hpp
  • Auxiliary/DistinctProvider.cpp
Generated on Wed Jan 25 01:12:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DistinctRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DistinctRule Class Reference

#include <Apoxi/Auxiliary/DistinctProvider.hpp>

Inheritance diagram for DistinctRule:

[legend]
Collaboration diagram for DistinctRule:

[legend]

Public Types

typedef NotEqualsRule | Base

Public Member Functions

DistinctRule (const DataItem &ruleitem)
DistinctRule ()
virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)
virtual | ~DistinctRule ()

Member Typedef Documentation

typedef NotEqualsRule DistinctRule::Base

Reimplemented from NotEqualsRule.

Constructor & Destructor Documentation

DistinctRule::DistinctRule ( )

DistinctRule::DistinctRule ( const DataItem & ruleitem )

DistinctRule::~DistinctRule ( ) [virtual]

Member Function Documentation

BOOLEAN DistinctRule::ExecuteRule ( const DataItem & dataitem ) [virtual]

ExecuteRule does the actual comparision between the data item given in the argument and the value stored when the filter rule is constructed.

Reimplemented from NotEqualsRule.

The documentation for this class was generated from the following files:
  • Auxiliary/DistinctProvider.hpp
  • Auxiliary/DistinctProvider.cpp
Generated on Wed Jan 25 01:12:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DnsClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DnsClient Class Reference
[Socket]

#include <Apoxi/Socket/DnsClient.hpp>

Inheritance diagram for DnsClient:

[legend]
Collaboration diagram for DnsClient:

[legend]

Public Member Functions

DnsClient (const DataConnProfilePtr &dc_prof=DataConnProfilePtr())
BOOLEAN | GetHostByAddrAsync (const IpAddr &ip_addr)
BOOLEAN | GetHostByNameAsync (const String &name)
virtual | ~DnsClient ()

Static Public Member Functions

static UINT16 | GetHostByAddr (const IpAddr &ip_addr, String &name, const DataConnProfile *dc_prof=0)
static UINT16 | GetHostByName (const String &name, IpAddr &ip_addr, const DataConnProfile *dc_prof=0)
static void | Init ()
static void | Shutdown ()

Protected Member Functions

virtual void | OnAddrResponse (const IpAddr &ip_addr, UINT16 error_no)
virtual void | OnNameResponse (const String &name, UINT16 error_no)

Friends

class | SysDnsClient

Detailed Description

DnsClient provides functions to retrieve DNS information synchronously and asynchronously.

Constructor & Destructor Documentation

DnsClient::DnsClient ( const DataConnProfilePtr & dc_prof = DataConnProfilePtr() )

Creates an instance of DnsClient that can be used for asynchronous requests.

DnsClient::~DnsClient ( ) [virtual]

Destroys this object and the referred SysDnsClient object.

Member Function Documentation

UINT16 DnsClient::GetHostByAddr | ( | const IpAddr & | ip_addr,
 |  | String & | name,
 |  | const DataConnProfile * | dc_prof = 0
 | ) | [static]

Resolves the host address synchronously, i.e. this method is blocking. It returns EDNSC_OK on success or an error code.

BOOLEAN DnsClient::GetHostByAddrAsync ( const IpAddr & ip_addr )

Resolves the host address asynchronously. Derive method OnNameResponse() to react to the asynchronous response.

See also:
OnNameResponse()

UINT16 DnsClient::GetHostByName | ( | const String & | name,
 |  | IpAddr & | ip_addr,
 |  | const DataConnProfile * | dc_prof = 0
 | ) | [static]

Resolves the host name synchronously, i.e. this method is blocking. It returns EDNSC_OK on success or an error code.

BOOLEAN DnsClient::GetHostByNameAsync ( const String & name )

Resolves the host name asynchronously. Derive method OnAddrResponse() to react to the asynchronous response.

See also:
OnAddrResponse()

static void DnsClient::Init ( ) [inline, static]

Initializes the DNS client. Has to be invoked when data connection profile settings are changed.

virtual void DnsClient::OnAddrResponse | ( | const IpAddr & | ip_addr,
 |  | UINT16 | error_no
 | ) | [inline, protected, virtual]

Implement this method to handle the response of an asynchronous name resolution (address request).

See also:
GetHostByNameAsync()

Reimplemented in DnsClientTest.

virtual void DnsClient::OnNameResponse | ( | const String & | name,
 |  | UINT16 | error_no
 | ) | [inline, protected, virtual]

Implement this method to handle the response of an asynchronous address resolution (name request).

See also:
GetHostByAddrAsync

Reimplemented in DnsClientTest.

static void DnsClient::Shutdown ( ) [inline, static]

Releases the held default data connection if it was needed for DNS requests.

Friends And Related Function Documentation

friend class SysDnsClient [friend]

The documentation for this class was generated from the following files:
  • Socket/DnsClient.hpp
  • Socket/DnsClient.cpp
Generated on Wed Jan 25 01:12:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DnsClientTest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DnsClientTest Class Reference
[Socket]

#include <Apoxi/Socket/DnsClientTest.hpp>

Inheritance diagram for DnsClientTest:

[legend]
Collaboration diagram for DnsClientTest:

[legend]

Public Member Functions

DnsClientTest ()
virtual | ~DnsClientTest ()
Destroys object.

Protected Member Functions

virtual void | OnAddrResponse (const IpAddr &ip_addr, UINT16 error_no)
Implement this to handle the response of address requests.
virtual void | OnNameResponse (const String &name, UINT16 error_no)
Implement this to handle the response of name requests.

Detailed Description

DnsClientTest provides sample functions to collect Async response from DNS.

Constructor & Destructor Documentation

DnsClientTest::DnsClientTest ( )

Creates an instance of DnsClientTest that can be used for asynchronous requests.

DnsClientTest::~DnsClientTest ( ) [virtual]

Destroys object.

Member Function Documentation

void DnsClientTest::OnAddrResponse | ( | const IpAddr & | ip_addr,
 |  | UINT16 | error_no
 | ) | [protected, virtual]

Implement this to handle the response of address requests.

Reimplemented from DnsClient.

void DnsClientTest::OnNameResponse | ( | const String & | name,
 |  | UINT16 | error_no
 | ) | [protected, virtual]

Implement this to handle the response of name requests.

Reimplemented from DnsClient.

The documentation for this class was generated from the following files:
  • Socket/DnsClientTest.hpp
  • Socket/DnsClientTest.cpp
Generated on Wed Jan 25 01:12:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DownloadSettings Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DownloadSettings Struct Reference

#include <Applications/SocketTest/SocketTestT.hpp>

Data Fields

UINT32 | m_nDataSize
UINT32 | m_nDownloadTime
UINT32 | m_nPacketSize
UINT32 | m_nServerDelay

Field Documentation

UINT32 DownloadSettings::m_nDataSize

UINT32 DownloadSettings::m_nDownloadTime

UINT32 DownloadSettings::m_nPacketSize

UINT32 DownloadSettings::m_nServerDelay

The documentation for this struct was generated from the following file:
  • Applications/SocketTest/SocketTestT.hpp
Generated on Wed Jan 25 01:12:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrawableObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrawableObject Class Reference
[Components]

#include <Apoxi/Gui/DrawableObject.hpp>

Inheritance diagram for DrawableObject:

[legend]
Collaboration diagram for DrawableObject:

[legend]

Public Types

enum | { ID = 10 }
enum | ParentArea { ClientArea, FrameArea }

Public Member Functions

virtual void | AdjustStrings ()
Obsolete - use OnLanguageChanged instead.
virtual void | AdjustThemeDependencies ()
Obsolete - use OnThemeChanged instead.
void | Draw (DeviceContext *dc, const Rect &repaint_rect) const
DrawableObject (Control *parent, BOOLEAN add_to_parent=TRUE, const View *view=0)
DrawableObject ()
DrawableObject * | GetNext () const
ParentArea | GetParentArea () const
void | Init (Control *parent, BOOLEAN add_to_parent=TRUE, const View *view=0)
void | Invalidate (BOOLEAN erase=TRUE)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsVisible () const
Obsolete - see SetVisible() for further details.
void | SetNext (DrawableObject *next)
virtual void | SetParent (Control *parent)
void | SetParentArea (ParentArea parent_area)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetVisible (BOOLEAN visible)
virtual | ~DrawableObject ()

Protected Member Functions

virtual void | OnLanguageChanged ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnMove (XYDIM dx, XYDIM dy)
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | OnThemeChanged ()

Friends

class | Control

Detailed Description

A Drawable Object is the base for all objects, which have the ability to be drawn inside a rectangulary area of a device-context. Drawable objects are slicker than controls and cannot have a focus and hence no interaction. After initializing a drawable object it is drawn automatically by APOXI to the given bounding-rectangle. It is recommended to adjust the position and size of the drawable object dynamically in the method OnLayoutClient of the parent control.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Component.

enum DrawableObject::ParentArea

Every drawable-object may added as part of the client area or the frame area of the parent control. Per default a drawable-object is added as part of the client area.

See also:
SetParentArea

GetParentArea

Enumerator:
ClientArea
FrameArea

Constructor & Destructor Documentation

DrawableObject::DrawableObject ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

DrawableObject::DrawableObject | ( | Control * | parent,
 |  | BOOLEAN | add_to_parent = TRUE,
 |  | const View * | view = 0
 | ) |

Parameters:
parent | Pointer to the control, where the drawable object should be drawn.
add_to_parent | Indicates, whether the drawable object should be added to the parent control. When the drawable object is added to the parent control, the drawable object is drawn automatically in the client area of the parent control. Pointer to the view, which is responsible to draw the drawable object.

DrawableObject::~DrawableObject ( ) [virtual]

Member Function Documentation

void DrawableObject::AdjustStrings ( ) [virtual]

Obsolete - use OnLanguageChanged instead.

void DrawableObject::AdjustThemeDependencies ( ) [virtual]

Obsolete - use OnThemeChanged instead.

void DrawableObject::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const

Parameters:
dc | Device context, where the object should be drawn.
repaint_rect | Area, which must be repainted.

DrawableObject* DrawableObject::GetNext ( ) const [inline]

Returns the next drawable object for the concatenated list. It is recommended to use the ComponentIterator on MMI level.

ParentArea DrawableObject::GetParentArea ( ) const [inline]

Returns, whether the drawable-object is drawn as part of the client area or the frame area.

void DrawableObject::Init | ( | Control * | parent,
 |  | BOOLEAN | add_to_parent = TRUE,
 |  | const View * | view = 0
 | ) |

Parameters:
parent | Pointer to the control, where the drawable object should be drawn.
add_to_parent | Indicates, whether the drawable object should be added to the parent control. When the drawable object is added to the parent control, the drawable object is drawn automatically in the client area of the parent control. Pointer to the view, which is responsible to draw the drawable object.

void DrawableObject::Invalidate ( BOOLEAN erase = TRUE )

Invalidates the area described by the bounding rectangle of the drawable object. This leads to a repaint of the drawable object in the next idle-state of the application.

Parameters:
erase Incicates, whether the area should be erased before Window::OnPaint is called. By default erase is TRUE.

BOOLEAN DrawableObject::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Component.

Reimplemented in AbstractTextObject, AnimatedTextLine, ImageBox, ItemBox, PositionIndicator, ProgressBar, TextBox, and TextLine.

BOOLEAN DrawableObject::IsVisible ( ) const

Obsolete - see SetVisible() for further details.

void DrawableObject::OnLanguageChanged ( ) [protected, virtual]

See also:
Component::OnLanguageChanged()

Implements Component.

Reimplemented in SoftkeyBar, and AbstractTextObject.

BOOLEAN DrawableObject::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage()

Reimplemented from Component.

Reimplemented in SvgPlayer, AtlItemBox, SoftkeyBar, ImageBox, and ItemBox.

void DrawableObject::OnMove | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnMove

Reimplemented from Component.

Reimplemented in ImageBox.

void DrawableObject::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnResize

Reimplemented from Component.

Reimplemented in AnimatedTextLine, ImageBox, and ItemBox.

void DrawableObject::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged()

Implements Component.

Reimplemented in Animation, SoftkeyBar, AbstractTextObject, PositionIndicator, and ProgressBar.

void DrawableObject::SetNext ( DrawableObject * next ) [inline]

Sets the next drawable object for the concatenated list. Usually it is never necessary to invoke this method by the MMI.

void DrawableObject::SetParent ( Control * parent ) [virtual]

See also:
Component::SetParent

Implements Component.

void DrawableObject::SetParentArea ( ParentArea parent_area ) [inline]

Sets the parent-area of the drawable-object, where the drawing is done. Every drawable-object may added as part of the client area or the frame area of the parent control. Per default a drawable-object is added as part of the client area.

BOOLEAN DrawableObject::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Component.

Reimplemented in AbstractTextObject, AnimatedTextLine, ImageBox, ItemBox, PositionIndicator, ProgressBar, TextBox, and TextLine.

void DrawableObject::SetVisible ( BOOLEAN visible )

Obsolete - use Control::AddDrawableObject(), Control::RemoveDrawableObject to dynamically add/remove a Drawable Object to the Control.

Friends And Related Function Documentation

friend class Control [friend]

The documentation for this class was generated from the following files:
  • Gui/DrawableObject.hpp
  • Gui/DrawableObject.cpp
Generated on Wed Jan 25 01:12:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrawableObjectView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrawableObjectView Class Reference
[Components]

#include <Apoxi/Gui/DrawableObject.hpp>

Inheritance diagram for DrawableObjectView:

[legend]
Collaboration diagram for DrawableObjectView:

[legend]

Public Member Functions

DrawableObjectView (XYDIM default_width=-1, XYDIM default_height=-1)
virtual ~DrawableObjectView ()

Constructor & Destructor Documentation

DrawableObjectView::DrawableObjectView | ( | XYDIM | default_width = -1,
 |  | XYDIM | default_height = -1
 | ) |

DrawableObjectView::~DrawableObjectView ( ) [virtual]

The documentation for this class was generated from the following files:
  • Gui/DrawableObject.hpp
  • Gui/DrawableObject.cpp
Generated on Wed Jan 25 01:12:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmAsset Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmAsset Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/DrmAsset.hpp>

Public Member Functions

DrmStatus | DeleteDrmRights () const
DrmAsset (DrmLocalId id=c_drm_invalid_local_id)
DrmStatus | GetCount (DrmOperation op, INT32 &cnt) const
DrmLocalId | GetDrmLocalId () const
DrmStatus | GetEndDate (DrmOperation op, Date &end_date) const
DrmStatus | GetStartDate (DrmOperation op, Date &start_date) const
DrmUid | GetUid (DrmStatus &status) const
DrmStatus | GetValidityPeriod (DrmOperation op, TimeSpan &validity_period) const
DrmStatus IncrementRefCount ()
BOOLEAN | OnContentConsumedEnd (DrmOperation op) const
BOOLEAN | OnContentConsumedStart (DrmOperation op) const
BOOLEAN | OnRollback (DrmOperation op) const
void | SetLocalDrmId (DrmLocalId id)
DrmStatus | ValidateAsset (DrmOperation op) const

Protected Member Functions

DrmStatus | CreateContainer (DrmOperation op, DrmRightsObjectContainer &ro_holder) const

Detailed Description

DRM enabled applications can invoke the member functions on DRM enabled assets to process and validate DRM constraints and permissions.

Constructor & Destructor Documentation

DrmAsset::DrmAsset ( DrmLocalId id = c_drm_invalid_local_id )

Parameters:
id Local ID of the object.

Member Function Documentation

DrmStatus DrmAsset::CreateContainer | ( | DrmOperation | op,
 |  | DrmRightsObjectContainer & | ro_holder
 | ) | const [protected]

Creates a container for the Rights Objects of the asset.

Parameters:
op | Operation for which the Rights objects are necessary
ro_holder | Container for the Rights Objects

DrmStatus DrmAsset::DeleteDrmRights ( ) const

Deletes the Drm Rights information from the rights store

Returns:
INT error code

DrmStatus DrmAsset::GetCount | ( | DrmOperation | op,
 |  | INT32 & | cnt
 | ) | const

GetCount

Parameters:
op | Operation which consumes content
cnt | Output parameter, which contains the count if the operation has been successful.
Returns:
DrmStatus to indicate error type or success. Returns DrmSuccess to indicate success in getting count value. Returns DrmDefaultConstraints to indicate count constraint is holding maximum possible value. Returns DrmUnknown or other to indicate count constraint not being present in rights XML.

DrmLocalId DrmAsset::GetDrmLocalId ( ) const

Returns the device local id of the asset.

Returns:
c_drm_invalid_local_id if no DRM rights object is existent.

DrmStatus DrmAsset::GetEndDate | ( | DrmOperation | op,
 |  | Date & | end_date
 | ) | const

Parameters:
op | Operation which consumes content
end_date | Output parameter, which contains the end-date if the operation has been successful.
Returns:
DrmStatus to indicate error type or success. Returns DrmSuccess to indicate success in getting end date value. Returns DrmDefaultConstraints to indicate end date is holding maximum possible date. Returns DrmUnknown to indicate datetime constraint not being present in rights XML.

DrmStatus DrmAsset::GetStartDate | ( | DrmOperation | op,
 |  | Date & | start_date
 | ) | const

Parameters:
op | Operation which consumes content
start_date | Output parameter, which contains the start-date if the operation has been successful.
Returns:
DrmStatus to indicate error type or success. Returns DrmSuccess to indicate success in getting start date value. Returns DrmDefaultConstraints to indicate start date is holding minimum possible date. Returns DrmUnknown or other to indicate datetime constraint not being present in rights XML.

DrmUid DrmAsset::GetUid ( DrmStatus & status ) const

Get the Content URI (Uses the DcfParser)

Returns:
DrmUid string

DrmStatus DrmAsset::GetValidityPeriod | ( | DrmOperation | op,
 |  | TimeSpan & | validity_period
 | ) | const

Parameters:
op | Operation which consumes content
validity_period | Output parameter, which contains the validity-period if the operation has been successful.
Returns:
DrmStatus to indicate error type or success. Returns DrmSuccess to indicate success in getting validity period value. Returns DrmDefaultConstraints to indicate interval constraint is holding maximum possible value. Returns DrmUnknown or other to indicate interval constraint not being present in rights XML.

DrmStatus DrmAsset::IncrementRefCount ( )

IncrementRefCount - Increments the reference count for the asset It indicates the existence of an asset and the number of times the asset is copied. Each time a DRM Asset is copied the reference count must be increased by the copying application. A reference count greater than 0 indicates a copy of the asset has been made. All rights associated with the Asset can be deleted when reference count is 0 (only one copy of an asset is existing in the system)

Returns:
DrmStatus - Status of the operation - DrmSuccess on proper increment

BOOLEAN DrmAsset::OnContentConsumedEnd ( DrmOperation op ) const

If content has been consumed, OnContentConsumedEnd will update constraint internal state.

Note : Content will be considered consumed either when the application calls OnContentConsumedStart or OnContentConsumedEnd, which depends on DRM configuration information (operator specific)

Parameters:
op Operation which consumes content
Returns:
TRUE on updation of internal constraint state

BOOLEAN DrmAsset::OnContentConsumedStart ( DrmOperation op ) const

If content has been consumed, OnContentConsumedStart will update constraint internal state to indicate start of content consumption.

Note : Content will be considered consumed either when the application calls OnContentConsumedStart or OnContentConsumedEnd, which depends on DRM configuration information (operator specific)

Parameters:
op Operation which consumes content
Returns:
TRUE on updation of internal constraint state to indicate start of consumption

BOOLEAN DrmAsset::OnRollback ( DrmOperation op ) const

If content has been consumed, OnRollback will revert constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on updation(reverting) of internal constraint state

void DrmAsset::SetLocalDrmId ( DrmLocalId id )

Intializes the local ID of the asset.

Parameters:
id local ID of the object

DrmStatus DrmAsset::ValidateAsset ( DrmOperation op ) const

Validates the permissions of the DrmAsset based on the local ID To be called before rendering / consuming content

Returns:
status of validation or error code

The documentation for this class was generated from the following files:
  • Auxiliary/DrmAsset.hpp
  • Auxiliary/DrmAsset.cpp
Generated on Wed Jan 25 01:12:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmConstraint Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmConstraint Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRights.hpp>

Inheritance diagram for DrmConstraint:

[legend]
Collaboration diagram for DrmConstraint:

[legend]

Public Types

enum | Type { None, TypeCount, TypeDateTime, TypeInterval }
Type of constraint. More...

Public Member Functions

BOOLEAN | DoesApply () const
DrmConstraint (Type type, UINT32 sec_interval)
Period constraint.
DrmConstraint (Type type, UINT32 sec_start, UINT32 sec_end)
Date constraint.
DrmConstraint (Type type, INT32 max_count)
Count constraint.
DrmConstraint ()
Simple constructor.
void | GetCount (INT32 *consume_count, INT32 *max_count, INT32 *prev_count) const
Gives Count constraint to user.
void | GetCount (INT32 *consume_count, INT32 *max_count) const
Gives Count constraint to user.
void | GetDateTime (UINT32 *sec_start, UINT32 *sec_end) const
Gives DateTime constraint to user.
void | GetIntervall (UINT32 *sec_interval, UINT32 *first_consume, UINT32 *prev_consume) const
Gives Intervall constraint to user.
void | GetIntervall (UINT32 *sec_interval, UINT32 *first_consume) const
Gives interval constraint to user.
Type | GetType () const
INT | OnContentConsumedEnd ()
INT | OnContentConsumedStart ()
INT | OnRollback ()
void | SetConsumedCount (INT32 consume_count)
void | SetCount (INT32 max_count)
void | SetEndDate (UINT32 sec_end)
void | SetFirstConsumedInterval (UINT32 first_consume_interval)
void | SetInterval (UINT32 sec_interval)
void | SetPrevConsumedCount (INT32 prev_consume_count)
void | SetPrevFirstConsumedInterval (UINT32 prev_consume_interval)
void | SetStartDate (UINT32 sec_start)
void | SetType (Type type)
virtual | ~DrmConstraint ()
Cleanup and destroy.

Data Structures

union | Data
Union to store constraint data and current state.

Detailed Description

DrmConstraint defines a Count, DateTime, or Interval constraint according to OMA DRM.

Member Enumeration Documentation

enum DrmConstraint::Type

Type of constraint.

Enumerator:
None | No constraint defined.
TypeCount | Count constraint.
TypeDateTime | Date and time limit.
TypeInterval | Interval limited.

Constructor & Destructor Documentation

DrmConstraint::DrmConstraint ( )

Simple constructor.

DrmConstraint::DrmConstraint | ( | Type | type,
 |  | INT32 | max_count
 | ) |

Count constraint.

DrmConstraint::DrmConstraint | ( | Type | type,
 |  | UINT32 | sec_start,
 |  | UINT32 | sec_end
 | ) |

Date constraint.

DrmConstraint::DrmConstraint | ( | Type | type,
 |  | UINT32 | sec_interval
 | ) |

Period constraint.

DrmConstraint::~DrmConstraint ( ) [virtual]

Cleanup and destroy.

Member Function Documentation

BOOLEAN DrmConstraint::DoesApply ( ) const

DoesApply returns TRUE if the constraint applies. In that case content presentation must be prohibited.

void DrmConstraint::GetCount | ( | INT32 * | consume_count,
 |  | INT32 * | max_count,
 |  | INT32 * | prev_count
 | ) | const

Gives Count constraint to user.

void DrmConstraint::GetCount | ( | INT32 * | consume_count,
 |  | INT32 * | max_count
 | ) | const

Gives Count constraint to user.

void DrmConstraint::GetDateTime | ( | UINT32 * | sec_start,
 |  | UINT32 * | sec_end
 | ) | const

Gives DateTime constraint to user.

void DrmConstraint::GetIntervall | ( | UINT32 * | sec_interval,
 |  | UINT32 * | first_consume,
 |  | UINT32 * | prev_consume
 | ) | const

Gives Intervall constraint to user.

void DrmConstraint::GetIntervall | ( | UINT32 * | sec_interval,
 |  | UINT32 * | first_consume
 | ) | const

Gives interval constraint to user.

DrmConstraint::Type DrmConstraint::GetType ( ) const

Returns:
type of constraint

INT DrmConstraint::OnContentConsumedEnd ( )

If content has been consumed, OnContentConsumedEnd will update constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on update of internal constraint state

INT DrmConstraint::OnContentConsumedStart ( )

If content has been consumed, OnContentConsumedStart will update constraint internal state to indicate start of content consumption.

Parameters:
op Operation which consumes content
Returns:
TRUE on update of internal constraint state to indicate start of consumption

INT DrmConstraint::OnRollback ( )

If content has been consumed, OnRollback will update constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on updation of internal constraint state

void DrmConstraint::SetConsumedCount ( INT32 consume_count )

Update the rights object with new count

Parameters:
consume_count Number of times the media object can be used

void DrmConstraint::SetCount ( INT32 max_count )

Initialize for Count constraint

Parameters:
max_count Maximum number of allowed invocations

void DrmConstraint::SetEndDate ( UINT32 sec_end )

void DrmConstraint::SetFirstConsumedInterval ( UINT32 first_consume_interval )

void DrmConstraint::SetInterval ( UINT32 sec_interval )

Initialize for Interval constraint

Parameters:
sec_interval Number of seconds for interval

void DrmConstraint::SetPrevConsumedCount ( INT32 prev_consume_count )

void DrmConstraint::SetPrevFirstConsumedInterval ( UINT32 prev_consume_interval )

void DrmConstraint::SetStartDate ( UINT32 sec_start )

Initialize for DateTime constraint

Parameters:
sec_start Start time and date in seconds (
See also:
DateTime). If no start time specified, set to 0 (zero)
Parameters:
sec_end End time and date in seconds (
See also:
DateTime). If no end time specified, set to 0xffffffff

void DrmConstraint::SetType ( Type type )

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRights.hpp
  • AddOns/Drm/DrmConstraint.cpp
Generated on Wed Jan 25 01:12:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmDcfHeader Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmDcfHeader Struct Reference

#include <Apoxi/AddOns/Drm/DrmDcfParser.hpp>

Collaboration diagram for DrmDcfHeader:

[legend]

Data Fields

Vector< DrmDcfHeaderData > m_header

Detailed Description

To hold all the Dcf headers in name, value format

Field Documentation

Vector<DrmDcfHeaderData> DrmDcfHeader::m_header

The documentation for this struct was generated from the following file:
  • AddOns/Drm/DrmDcfParser.hpp
Generated on Wed Jan 25 01:12:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmDcfHeaderData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmDcfHeaderData Struct Reference

#include <Apoxi/AddOns/Drm/DrmDcfParser.hpp>

Collaboration diagram for DrmDcfHeaderData:

[legend]

Data Fields

String m_name
String m_value

Detailed Description

Dcf header is stored as name, value pair

Field Documentation

String DrmDcfHeaderData::m_name

String DrmDcfHeaderData::m_value

The documentation for this struct was generated from the following file:
  • AddOns/Drm/DrmDcfParser.hpp
Generated on Wed Jan 25 01:12:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmDcfParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmDcfParser Class Reference

#include <Apoxi/AddOns/Drm/DrmDcfParser.hpp>

Collaboration diagram for DrmDcfParser:

[legend]

Public Types

enum DrmDcfHeaderType {
DrmDcfEncryptionMethod = 0, DrmDcfPaddingScheme, DrmDcfRightsIssuer, DrmDcfContentName,
DrmDcfContentDescription, DrmDcfContentVendor, DrmDcfIconUriHeader, DrmDcfUnSupported
}

Public Member Functions

DrmDcfParser ()
DrmDcfParser (const BinData *bd)
INT | GetBlockDataOffSet (INT block_num, INT block_sz, INT &new_block_sz)
BOOLEAN | GetContentId (String &content_id)
BOOLEAN | GetContentType (String &content_type)
BOOLEAN | GetDcfHeader (DrmDcfHeader &header)
BOOLEAN | GetDcfHeader (const CHAR *header_name, String &header_value)
BOOLEAN | GetDcfHeader (enum DrmDcfHeaderType header_type, String &data)
INT | GetMediaObjectLen ()
INT | GetMediaObjectOffSet ()
BOOLEAN | GetVersion (UINT8 &version) const
void | SetDrmDcfMessage (const BinData *bd)
~DrmDcfParser ()

Detailed Description

DrmDcfParser - Class to parse and fetch decrypted media content from the DCF file. Also has helpers to get DCF header information

Member Enumeration Documentation

enum DrmDcfParser::DrmDcfHeaderType

DRMCF header types

Enumerator:
DrmDcfEncryptionMethod
DrmDcfPaddingScheme
DrmDcfRightsIssuer
DrmDcfContentName
DrmDcfContentDescription
DrmDcfContentVendor
DrmDcfIconUriHeader
DrmDcfUnSupported

Constructor & Destructor Documentation

DrmDcfParser::DrmDcfParser ( const BinData * bd )

Constructor

Parameters:
const BinData Takes the Dcf data buffer as input

DrmDcfParser::DrmDcfParser ( )

DrmDcfParser::~DrmDcfParser ( )

Member Function Documentation

INT DrmDcfParser::GetBlockDataOffSet | ( | INT | block_num,
 |  | INT | block_sz,
 |  | INT & | new_block_sz
 | ) |

Get the offset inthe dcf message for the given block

Parameters:
block_num | should be greater than 1.
block_sz | standard block size
new_block_sz | This will be updated by this function. The value will remain same as block_sz execpt for the last block.
Returns:
Offset in DCF message or error code OR reached end error OR message parse error

BOOLEAN DrmDcfParser::GetContentId ( String & content_id )

Get the unique id of the DRM protected content

Returns:
content URI/Id

BOOLEAN DrmDcfParser::GetContentType ( String & content_type )

Get the MIME media type of the protected DRM content

Returns:
String

BOOLEAN DrmDcfParser::GetDcfHeader ( DrmDcfHeader & header )

Get the all available DCF headers from the message and store in a vector, in name, value pair format.

Returns:
TRUE on successfull parsing

BOOLEAN DrmDcfParser::GetDcfHeader | ( | const CHAR * | header_name,
 |  | String & | header_value
 | ) |

Get the standard/user defined DCF header value based on the header name

Returns:
TRUE on successfull parsing

BOOLEAN DrmDcfParser::GetDcfHeader | ( | enum DrmDcfHeaderType | header_type,
 |  | String & | data
 | ) |

Get the standard DCF header value based on the header type as defined in OMA DRMCF specification

Returns:
TRUE on successfull parsing

INT DrmDcfParser::GetMediaObjectLen ( )

Get the encrypted data length from DCF message

Returns:
length of data or error code DRM_DCF_ERROR

INT DrmDcfParser::GetMediaObjectOffSet ( )

Get the encrypted content offset from the DCF message

Returns:
Offset in DCF message or error code DRM_DCF_ERROR

BOOLEAN DrmDcfParser::GetVersion ( UINT8 & version ) const

Get the Version number of OMA DRMCF specification

Returns:
Version number

void DrmDcfParser::SetDrmDcfMessage ( const BinData * bd )

Set the DRM message

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmDcfParser.hpp
  • AddOns/Drm/DrmDcfParser.cpp
Generated on Wed Jan 25 01:12:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmInfo Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/DrmInfo.hpp>

Inheritance diagram for DrmInfo:

[legend]
Collaboration diagram for DrmInfo:

[legend]

Public Types

enum Operation {
c_none = 0, c_play = 1, c_display = 2, c_execute = 4,
c_print = 8, c_forward = 16, c_no_lock = 32, c_forward_lock = 64,
c_combined_delivery = 128, c_separate_delivery = 256
}

Public Member Functions

DrmInfo ()
void | Init (UINT16 drm_method)
BOOLEAN | IsCombinedDelivered ()
BOOLEAN | IsDisplayable ()
BOOLEAN | IsExecutable ()
BOOLEAN | IsForwardable ()
BOOLEAN | IsForwardLocked ()
BOOLEAN | IsPlayable ()
BOOLEAN | IsPrintable ()
BOOLEAN | IsSeparateDelivered ()
void | ReadFrom (const DrmInfoPersistStructure &persist_structure)
void | WriteTo (DrmInfoPersistStructure *persist_structure) const
virtual | ~DrmInfo ()

Member Enumeration Documentation

enum DrmInfo::Operation

Operation is an enumeration representing all possible rights of an object protected by DRM. We internally store this information in x^2 steps of integer values to keep the storage most simple (we only need one integer). Access to this information is provided by methods ranging from "IsPlayable()" to "IsForwardable()".

Enumerator:
c_none
c_play
c_display
c_execute
c_print
c_forward
c_no_lock
c_forward_lock
c_combined_delivery
c_separate_delivery

Constructor & Destructor Documentation

DrmInfo::DrmInfo ( )

DrmInfo::~DrmInfo ( ) [virtual]

Member Function Documentation

void DrmInfo::Init ( UINT16 drm_method )

Init

Parameters:
drm_method | defines the method type of the delivered object. if the method is forward lock (c_forward_lock) we do not check the parameter operations. is shall be 0
operations | defines the operations which are allowed for this object a combination can be achieved by adding up right, e.g. (c_display + c_print)

BOOLEAN DrmInfo::IsCombinedDelivered ( )

IsCombinedDelivered

Returns:
if object is combined delivered

BOOLEAN DrmInfo::IsDisplayable ( )

IsDisplayable returns, if the object is allowed to be displayed. The right to be displayed it one of the basic rights of DRM.

Returns:
if object is allowed to be displayed

BOOLEAN DrmInfo::IsExecutable ( )

IsExecutable returns, if the object is allowed to be executed. The right to be executed it one of the basic rights of DRM.

Returns:
if object is allowed to be executed

BOOLEAN DrmInfo::IsForwardable ( )

IsForwardable returns, if the object is allowed to be forwarded to other devices. The right to be printed it one of the basic rights of DRM.

Returns:
if object is allowed to be printed

BOOLEAN DrmInfo::IsForwardLocked ( )

IsForwardLocked

Returns:
if object is forward locked

BOOLEAN DrmInfo::IsPlayable ( )

IsPlayable returns, if the object is allowed to be played. The right to be played it one of the basic rights of DRM.

Returns:
if object is allowed to be played

BOOLEAN DrmInfo::IsPrintable ( )

IsPrintable returns, if the object is allowed to be printed. The right to be printed it one of the basic rights of DRM.

Returns:
if object is allowed to be printed

BOOLEAN DrmInfo::IsSeparateDelivered ( )

IsSeparateDelivered

Returns:
if object is separately locked

void DrmInfo::ReadFrom ( const DrmInfoPersistStructure & persist_structure )

ReadFrom initializes a DrmInfo object with the values stored in a DrmInfo::Persist structure.

Parameters:
profile A reference to a Persist structure containing drm-information

void DrmInfo::WriteTo ( DrmInfoPersistStructure * persist_structure ) const

WriteTo returns a persist structure with a fixed size, which can be easily persisted in memory or a file system.

Parameters:
profile A pointer to a Persist structure

The documentation for this class was generated from the following files:
  • Auxiliary/DrmInfo.hpp
  • Auxiliary/DrmInfo.cpp
Generated on Wed Jan 25 01:12:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmInfoPersistStructure Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmInfoPersistStructure Struct Reference
[Auxiliary]

#include <Apoxi/Auxiliary/DrmInfo.hpp>

Data Fields

UINT16 m_permissions

Detailed Description

DrmInfo is a class to store and manage objects protected by Digital Rights Management. For more information about DRM by OMA (Open Mobile Alliance) please refer to the OMA Digital Rights Management version 1.0 on http://www.openmobilealliance.org/documents.asp

At the moment of this implementation the documents are released in version 1.0

DRM Message Media Types: application/vnd.oma.drm.message = ForwardLock

Overview about the different DrmMethods is provided by Nokia http://www.forum.nokia.com/html_reader/main/1,32611,2563,00.html?page_nbr=2

"The OMA DRM Version 1.0 standard will govern the use of mobile-centric content types, whether they are received by WAP download or Multimedia Message Service (MMS). This will be the world's first mobile DRM standard. The standard provides three DRM methods: forward-lock, combined delivery and separate delivery.

->Forward-lock is intended for the delivery of news, sports, information, and images that should not be forwarded to others. It will be applied most often in subscription-based services. A mobile device is allowed to play, display, or execute, but it cannot forward the media object. The content itself is hidden inside the DRM message that is delivered to the terminal. A DRM message contains a media object and an optional rights object. In the forward-lock method, the DRM message contains only the media object.

->Combined delivery enables usage rules to be set for the media object. This method extends forward-lock by adding a rights object to the DRM Message. Rights define how the device is allowed to render the content. Rights can be limited using both time and count constraints. This method also enables a preview feature. For instance, the rights object for a ring tone distributed inside a DRM Message could specify that the ring tone could be played only twice or only for two weeks.

->Separate delivery protects higher-value media and enables super distribution, which allows the device to forward the media but not the rights. This is achieved by delivering the content and rights via separate channels, which is more secure than a combined delivery method. The content is encrypted into DRM Content Format (DCF) using symmetric encryption, while the rights specify a Content Encryption Key (CEK), which is used by the DRM User Agent in the device for decryption." [(c) by Nokia (http://www.forum.nokia.com/html_reader/main/1,32611,2563,00.html?page_nbr=2)]

This version of the DrmInfo Class implements the ForwardLock only!

Field Documentation

UINT16 DrmInfoPersistStructure::m_permissions

The documentation for this struct was generated from the following file:
  • Auxiliary/DrmInfo.hpp
Generated on Wed Jan 25 01:12:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmMediaObject Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmMediaObject Struct Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/Drm.hpp>

Collaboration diagram for DrmMediaObject:

[legend]

Data Fields

UINT8 * | m_content
INT | m_content_len
String m_content_type

Detailed Description

Decrypted Media Object, returned by the DRM API

Field Documentation

UINT8* DrmMediaObject::m_content

Pointer to decrypted media object buffer

INT DrmMediaObject::m_content_len

Content Length of the media object buffer

String DrmMediaObject::m_content_type

Mime Type of media object

The documentation for this struct was generated from the following file:
  • AddOns/Drm/Drm.hpp
Generated on Wed Jan 25 01:12:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmMessage Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmMessage.hpp>

Collaboration diagram for DrmMessage:

[legend]

Public Member Functions

DrmMessage (const BinData *drm_message, const CHAR *headers)
DrmMessage (const BinData *drm_message, DrmMimeType drm_mime_type)
BinData * | GetMediaObject (DrmOperation op, BlockData *block_data, DrmStatus &status)
DrmStatus | GetMediaObject (DrmOperation op, DrmMediaObject *media_object, BlockData *block_data)
BinData * | GetMediaObject (DrmOperation op, DrmStatus &status)
DrmStatus | GetMediaObject (DrmOperation op, DrmMediaObject *media_object)
BinData * | GetRawMediaObject (BOOLEAN decrypt, BlockData *block_data, DrmStatus &status)
BinData * | GetRawMediaObject (BOOLEAN decrypt, DrmStatus &status)
DrmStatus | GetRawMediaObject (BOOLEAN decrypt, DrmMediaObject *media_object, BlockData *block_data)
DrmStatus | GetRawMediaObject (BOOLEAN decrypt, DrmMediaObject *media_object)
String | GetRightsIssuer () const
DrmUid | GetUid (DrmStatus &status) const
DrmLocalId ProcessDrmMessage ()
void | SetDrmLocalId (const DrmLocalId local_id)
DrmStatus | StripRelXml (UINT8 **buf)
~DrmMessage ()
Destructor.

Static Public Member Functions

static DrmMimeType | GetDrmMimeType (const BinData *drm_message, const CHAR *base_mime_type)
static String | GetMediaMimeType (const BinData *drm_message, DrmMimeType drm_mime_type)
static String | GetRawMediaMimeType (const BinData *drm_message, DrmMimeType drm_mime_type, BOOLEAN &more)
static DrmLocalId | ProcessRightsMessage (const BinData *drm_rights_msg)

Detailed Description

DrmMessage parses the class based on the mime type of the data and extracts rights objects for persistence.
  • creates a local id for the content
  • exposes API to fetch the content buffer

Constructor & Destructor Documentation

DrmMessage::DrmMessage | ( | const BinData * | drm_message,
 |  | DrmMimeType | drm_mime_type
 | ) |

Constructor

Parameters:
drm_message | pointer to the received DRM Message buffer
drm_mime_type | Mime type of DRM Message (FL, CD , DCF , Rights Object in XML/WBXML)

DrmMessage::DrmMessage | ( | const BinData * | drm_message,
 |  | const CHAR * | headers
 | ) |

Constructor

Parameters:
const | BinData & pointer to the received DRM Message buffer
headers | Http headers if any - Content Type header of the DRM message

DrmMessage::~DrmMessage ( )

Destructor.

Member Function Documentation

DrmMimeType DrmMessage::GetDrmMimeType | ( | const BinData * | drm_message,
 |  | const CHAR * | base_mime_type
 | ) | [static]

Returns the Drm Mime type associated with asset

Parameters:
drm_message | - buffer with multipart drm message
base_mime_type | - Base Mime Type received through http_response or from storage
Returns:
Drm Mime type

String DrmMessage::GetMediaMimeType | ( | const BinData * | drm_message,
 |  | DrmMimeType | drm_mime_type
 | ) | [static]

Get the mime type(excluding the parameters)of media object containted in DRM message

Parameters:
drm_message - buffer with multipart drm message

BinData * DrmMessage::GetMediaObject | ( | DrmOperation | op,
 |  | BlockData * | block_data,
 |  | DrmStatus & | status
 | ) |

Get the decrypted media object from the Drm Message buffer as a BinData object This internally validates the operation. The BinData instance must be released after use of this object. The media type of the buffer can be obtained using the method DrmMessage::GetMediaMimeType()

Parameters:
op | - DRM operation to check permissions
block_data - pointer to structure containing block numbers to parsed and size of each parsed block
  • allocated by user - both start and end block data is returned
status | - status of the operation
Returns:
BinData containing decrypted media object If the returned pointer is NULL - check for error code in status

DrmStatus DrmMessage::GetMediaObject | ( | DrmOperation | op,
 |  | DrmMediaObject * | media_object,
 |  | BlockData * | block_data
 | ) |

Get the decrypted media object from the Drm Message buffer This internally validates the operation.

Parameters:
DrmOperation | DRM operation to check permissions
DrmMediaObject* | pointer to media object allocated by APOXI DRM
BlockData* pointer to structure containing block numbers to parsed and size of each parsed block
  • allocated by user - both start and end block data is returned
Returns:
Status - If the returned pointer is NULL for DrmMediaObject - check for error code in status

BinData * DrmMessage::GetMediaObject | ( | DrmOperation | op,
 |  | DrmStatus & | status
 | ) |

Get the decrypted media object from the Drm Message buffer as a BinData object This internally validates the operation. The BinData instance must be released after use of this object. The media type of the buffer can be obtained using the method DrmMessage::GetMediaMimeType()

Parameters:
op | - DRM operation to check permissions
status | - status of the operation
Returns:
BinData containing decrypted media object If the returned pointer is NULL - check for error code in status

DrmStatus DrmMessage::GetMediaObject | ( | DrmOperation | op,
 |  | DrmMediaObject * | media_object
 | ) |

Get the decrypted media object from the Drm Message buffer This internally validates the operation.

Parameters:
DrmOperation | DRM operation to check permissions
DrmMediaObject* | pointer to media object allocated by APOXI DRM
Returns:
Status - If the returned pointer is NULL for DrmMediaObject - check for error code in status

static String DrmMessage::GetRawMediaMimeType | ( | const BinData * | drm_message,
 |  | DrmMimeType | drm_mime_type,
 |  | BOOLEAN & | more
 | ) | [static]

Get the mime type of media object containted in DRM message

Parameters:
more | - indicate if there is more than just content Mime type,user should parse the return value to get the values for content media mime type and other information like 'charset'
drm_message | - buffer with multipart drm message

BinData* DrmMessage::GetRawMediaObject | ( | BOOLEAN | decrypt,
 |  | BlockData * | block_data,
 |  | DrmStatus & | status
 | ) |

Get the unvalidated media object from the Drm Message buffer as a BinData object The BinData instance must be released after use of this object. The media type of the buffer can be obtained using the method DrmMessage::GetMediaMimeType()

Parameters:
decrypt | used to decide whether to decrypt the media object or not
block_data - pointer to structure containing block numbers to parsed and size of each parsed block
  • allocated by user - both start and end block data is returned
status | - status of the operation
Returns:
BinData containing decrypted media object If the returned pointer is NULL - check for error code in status Note: This interface is only provided to give access to media object for expired DRM objects. Ideally GetMediaObject is supposed to be used for accessing the media object.

BinData* DrmMessage::GetRawMediaObject | ( | BOOLEAN | decrypt,
 |  | DrmStatus & | status
 | ) |

Get the unvalidated media object from the Drm Message buffer as a BinData object The BinData instance must be released after use of this object. The media type of the buffer can be obtained using the method DrmMessage::GetMediaMimeType()

Parameters:
decrypt | used to decide whether to decrypt the media object or not
status | - status of the operation
Returns:
BinData containing decrypted media object If the returned pointer is NULL - check for error code in status Note: This interface is only provided to give access to media object for expired DRM objects. Ideally GetMediaObject is supposed to be used for accessing the media object.

DrmStatus DrmMessage::GetRawMediaObject | ( | BOOLEAN | decrypt,
 |  | DrmMediaObject * | media_object,
 |  | BlockData * | block_data
 | ) |

Get the unvalidated media object from the Drm Message buffer

Parameters:
decrypt | used to decide whether to decrypt the media object or not
DrmMediaObject* | pointer to media object allocated by APOXI DRM
BlockData* pointer to structure containing block numbers to parsed and size of each parsed block
  • allocated by user - both start and end block data is returned
Returns:
Status - If the returned pointer is NULL for DrmMediaObject - check for error code in status Note: This interface is only provided to give access to media object for expired DRM objects. Ideally GetMediaObject is supposed to be used for accessing the media object.

DrmStatus DrmMessage::GetRawMediaObject | ( | BOOLEAN | decrypt,
 |  | DrmMediaObject * | media_object
 | ) |

Get the unvalidated media object from the Drm Message buffer

Parameters:
decrypt | used to decide whether to decrypt the media object or not
DrmMediaObject* | pointer to media object allocated by APOXI DRM
Returns:
Status - If the returned pointer is NULL for DrmMediaObject - check for error code in status
Note: This interface is only provided to give access to media object for expired DRM objects. Ideally GetMediaObject is supposed to be used for accessing the media object.

String DrmMessage::GetRightsIssuer ( ) const

Get the URL of the rights issuer (Uses the DcfParser)

Returns:
String url string

DrmUid DrmMessage::GetUid ( DrmStatus & status ) const

Get the Content URI (Uses the DcfParser)

Returns:
DrmUid string

DrmLocalId DrmMessage::ProcessDrmMessage ( )

Processes the incoming DRM message and persists the rights information and returns a local ID, which maps to the UID of the asset. Application can persist this local ID for future reference to the asset and rights.

Returns:
DrmLocalID Integer local ID of the DRM Object

DrmLocalId DrmMessage::ProcessRightsMessage ( const BinData * drm_rights_msg ) [static]

Processes the incoming rights message (e.g separate delivery) and persists the rights information into the rights object store.

Parameters:
const BinData& DRM Rights Message
Returns:
DrmLocalID Integer local ID of the DRM object

void DrmMessage::SetDrmLocalId ( const DrmLocalId local_id )

Set the Local ID into the object

Parameters:
const DrmLocalID local id of the asset

DrmStatus DrmMessage::StripRelXml ( UINT8 ** buf )

Removes the XML part from the REL - Must be called after Process Drm Message for CD messages

Parameters:
UINT8* buf - Contains the new buffer to be written to FFS. It is an in-out parameter. It must be deleted by the user as it is allocated inside the function.
Returns:
DrmStatus - Success on stripping XML from REL

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmMessage.hpp
  • AddOns/Drm/DrmMessage.cpp
Generated on Wed Jan 25 01:12:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmPermission Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmPermission Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRights.hpp>

Inheritance diagram for DrmPermission:

[legend]
Collaboration diagram for DrmPermission:

[legend]

Public Member Functions

BOOLEAN | AddConstraint (const DrmConstraint &constraint)
DrmPermission ()
const DrmConstraint & | GetConstraint (INT index) const
Returns a constraint for the given vector index.
DrmConstraintDefValues | GetConstraintDefaultValue () const
INT | GetConstraintsCount () const
Returns number of constraints available for this permission.
BOOLEAN | GetCountConstraint (INT32 &consume_count, INT32 &max_count)
BOOLEAN | GetDateConstraint (UINT32 &start_date, UINT32 &end_date)
BOOLEAN | GetIntervalConstraint (UINT32 &start_consume, UINT32 &max_consume)
DrmOperation | GetOpType () const
Returns DrmOperation according to OMA DRM.
BOOLEAN | IsAllowed () const
IsAllowed will return TRUE if no constraints apply to operation.
INT | OnContentConsumedEnd ()
INT | OnContentConsumedStart ()
INT | OnRollback ()
void | SetConstraintDefaultValue (DrmConstraintDefValues def_constraints)
BOOLEAN | SetOpType (DrmOperation op)
virtual | ~DrmPermission ()

Detailed Description

DrmPermission specifies a DRM operation and constraints on that operation according to OMA DRM.

Constructor & Destructor Documentation

DrmPermission::DrmPermission ( )

DrmPermission::~DrmPermission ( ) [virtual]

Member Function Documentation

BOOLEAN DrmPermission::AddConstraint ( const DrmConstraint & constraint )

AddConstraint adds a constraint to the permission object. Note that OMA DRM currently defines 3 types of constraint. Therefore not more than 3 constraints of each constraint type can be added.

Returns:
TRUE on success, FALSE on error

const DrmConstraint & DrmPermission::GetConstraint ( INT index ) const

Returns a constraint for the given vector index.

DrmConstraintDefValues DrmPermission::GetConstraintDefaultValue ( ) const [inline]

GetConstraintDefaultValue returns TRUE if the constraint has default value. In that case content can be presented irrespective of the value.

INT DrmPermission::GetConstraintsCount ( ) const

Returns number of constraints available for this permission.

BOOLEAN DrmPermission::GetCountConstraint | ( | INT32 & | consume_count,
 |  | INT32 & | max_count
 | ) |

BOOLEAN DrmPermission::GetDateConstraint | ( | UINT32 & | start_date,
 |  | UINT32 & | end_date
 | ) |

BOOLEAN DrmPermission::GetIntervalConstraint | ( | UINT32 & | start_consume,
 |  | UINT32 & | max_consume
 | ) |

DrmOperation DrmPermission::GetOpType ( ) const

Returns DrmOperation according to OMA DRM.

BOOLEAN DrmPermission::IsAllowed ( ) const

IsAllowed will return TRUE if no constraints apply to operation.

INT DrmPermission::OnContentConsumedEnd ( )

If content has been consumed, OnContentConsumedEnd will update constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on update of internal constraint state

INT DrmPermission::OnContentConsumedStart ( )

If content has been consumed, OnContentConsumedStart will update constraint internal state to indicate start of content consumption.

Parameters:
op Operation which consumes content
Returns:
TRUE on update of internal constraint state to indicate start of consumption

INT DrmPermission::OnRollback ( )

If content has been consumed, OnRollback will update constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on updation of internal constraint state

void DrmPermission::SetConstraintDefaultValue ( DrmConstraintDefValues def_constraints ) [inline]

Set m_def_constraints.

BOOLEAN DrmPermission::SetOpType ( DrmOperation op )

SetOpType initializes the operation type of the permission object

Returns:
TRUE on success, FALSE on error

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRights.hpp
  • AddOns/Drm/DrmPermission.cpp
Generated on Wed Jan 25 01:12:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmRelParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmRelParser Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRelparser.hpp>

Collaboration diagram for DrmRelParser:

[legend]

Public Types

enum | DrmVersion { Drm_v_1_0, Drm_v_None }

Public Member Functions

DrmRelParser (DrmRightsObject &ro, const BinData *wbxml_data, DrmXmlFormat wbxml_format)
DrmRelParser (DrmRightsObject &ro, const UINT8 *rights_xml_buffer, DrmXmlFormat xml_format)
DrmVersion GetDrmVersion ()
INT32 | Parse ()
void | SetDrmVersion (String &version)

Protected Member Functions

DrmRightsObject & GetRightsObject ()
DrmStatus ParseWbxmlRel ()
INT32 | ParseXmlRel ()

Friends

class | WbxmlParserRel
class | XmlParserRel

Member Enumeration Documentation

enum DrmRelParser::DrmVersion

Enumerator:
Drm_v_1_0
Drm_v_None

Constructor & Destructor Documentation

DrmRelParser::DrmRelParser | ( | DrmRightsObject & | ro,
 |  | const UINT8 * | rights_xml_buffer,
 |  | DrmXmlFormat | xml_format
 | ) | [inline]

DrmRelParser::DrmRelParser | ( | DrmRightsObject & | ro,
 |  | const BinData * | wbxml_data,
 |  | DrmXmlFormat | wbxml_format
 | ) | [inline]

Member Function Documentation

DrmVersion DrmRelParser::GetDrmVersion ( )

Returns the version data of the REL data

Returns:
DrmVersion 1-v1.0, 2-v2.0 ...

DrmRightsObject& DrmRelParser::GetRightsObject ( ) [inline, protected]

INT32 DrmRelParser::Parse ( )

Parses the REL data based on the type of encoding ie XML/WBXML. Stores the parsed data in compressed form in the APOXI DRM engine.

Returns:
status - TRUE on success, parsing status on error eg DrmCorruptMessage etc...

DrmStatus DrmRelParser::ParseWbxmlRel ( ) [protected]

INT32 DrmRelParser::ParseXmlRel ( ) [protected]

Parses the REL XML data Non validating parser with well-formedness checking

void DrmRelParser::SetDrmVersion ( String & version ) [inline]

Sets the version

Friends And Related Function Documentation

friend class WbxmlParserRel [friend]

friend class XmlParserRel [friend]

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRelparser.hpp
  • AddOns/Drm/DrmRelparser.cpp
Generated on Wed Jan 25 01:12:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmRightsMapTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmRightsMapTableEntry Struct Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRightsStore.hpp>

Collaboration diagram for DrmRightsMapTableEntry:

[legend]

Data Fields

BOOLEAN m_is_valid
DrmLocalId m_local_id
Vector< String > m_ro_file_paths
String m_uid

Detailed Description

DrmRightsMapTableEntry is an element in the rights map table, that serves as a map to reach the correct rights object file in FFS. In addition to that, it helps the rights object store to effectively map local IDs to Content IDs.

Field Documentation

BOOLEAN DrmRightsMapTableEntry::m_is_valid

DrmLocalId DrmRightsMapTableEntry::m_local_id

Vector<String> DrmRightsMapTableEntry::m_ro_file_paths

String DrmRightsMapTableEntry::m_uid

The documentation for this struct was generated from the following file:
  • AddOns/Drm/DrmRightsStore.hpp
Generated on Wed Jan 25 01:12:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmRightsObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmRightsObject Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRights.hpp>

Collaboration diagram for DrmRightsObject:

[legend]

Public Member Functions

BOOLEAN | AddPermission (const DrmPermission &perm)
DrmRightsObject ()
BOOLEAN | GetCountConstraint (DrmOperation op, INT32 &consume_count, INT32 &max_count)
BOOLEAN | GetDateConstraint (DrmOperation op, UINT32 &start_date, UINT32 &endDate)
DrmMimeType | GetDrmMimeType () const
Returns DRM MIME type.
BOOLEAN | GetIntervalConstraint (DrmOperation op, UINT32 &start_consume, UINT32 &max_consume)
BOOLEAN | GetKey (UINT8 *key) const
Returns DRM AES key, this is available only for separate delivery.
DrmLocalId | GetLocalId () const
Returns local id.
MimeType | GetMoMimeType () const
DrmPermission * | GetPermission (DrmOperation op)
Returns permission object for the given operation.
DrmPermission & | GetPermission (INT index)
Returns permission object for the given vector index.
INT | GetPermissionsCount () const
Returns the number of permissions available for this rights object.
UINT8 | GetRefCount ()
const DrmUid & | GetUid () const
Returns UID, this is not available for forward lock.
BOOLEAN | IsAllowed (DrmOperation op) const
IsAllowed returns TRUE if specified operation is allowed on asset.
INT | IsConstraintAvailable (DrmOperation op)
INT | OnContentConsumedEnd (DrmOperation op)
INT | OnContentConsumedStart (DrmOperation op)
INT | OnRollback (DrmOperation op)
void | SetKey (const DrmKey &key)
void | SetLocalId (DrmLocalId local_id)
Initializes unique local id of a rights object.
void | SetMimeType (DrmMimeType mime_type)
Initialize the DRM MIME type.
void | SetMoMimeType (MimeType mime_type)
Initialize the media object MIME type.
void | SetRefCount (UINT8 count)
void | SetUid (const DrmUid &uid)
~DrmRightsObject ()

Detailed Description

DrmRightsObject is a binary representation of DRMREL specified OMA DRM Rights Object. Each DrmRightsObject can has a UID and a set of DrmPermissions according to OMA DRM. Beside UID each DrmRightsObject also has a device local unique ID. This ID can be used to easily access and reference the rights objects. Rights object with same UID will also have same local ID.

Constructor & Destructor Documentation

DrmRightsObject::DrmRightsObject ( )

DrmRightsObject::~DrmRightsObject ( )

Member Function Documentation

BOOLEAN DrmRightsObject::AddPermission ( const DrmPermission & perm )

Adds a permission object to the rights object. Currently OMA DRM defines 4 different types of operations (play, display, execute, and print. Therefore not more than 4 permissions can be added to a rights object. Permission must not be of the same type as already existing permission objects.

Returns:
TRUE on success, FALSE on error

BOOLEAN DrmRightsObject::GetCountConstraint | ( | DrmOperation | op,
 |  | INT32 & | consume_count,
 |  | INT32 & | max_count
 | ) |

BOOLEAN DrmRightsObject::GetDateConstraint | ( | DrmOperation | op,
 |  | UINT32 & | start_date,
 |  | UINT32 & | endDate
 | ) |

DrmMimeType DrmRightsObject::GetDrmMimeType ( ) const

Returns DRM MIME type.

BOOLEAN DrmRightsObject::GetIntervalConstraint | ( | DrmOperation | op,
 |  | UINT32 & | start_consume,
 |  | UINT32 & | max_consume
 | ) |

BOOLEAN DrmRightsObject::GetKey ( UINT8 * key ) const

Returns DRM AES key, this is available only for separate delivery.

DrmLocalId DrmRightsObject::GetLocalId ( ) const

Returns local id.

MimeType DrmRightsObject::GetMoMimeType ( ) const

DrmPermission * DrmRightsObject::GetPermission ( DrmOperation op )

Returns permission object for the given operation.

DrmPermission & DrmRightsObject::GetPermission ( INT index )

Returns permission object for the given vector index.

INT DrmRightsObject::GetPermissionsCount ( ) const

Returns the number of permissions available for this rights object.

UINT8 DrmRightsObject::GetRefCount ( ) [inline]

Gets the reference count of the rights object.

const DrmUid & DrmRightsObject::GetUid ( ) const

Returns UID, this is not available for forward lock.

BOOLEAN DrmRightsObject::IsAllowed ( DrmOperation op ) const

IsAllowed returns TRUE if specified operation is allowed on asset.

INT DrmRightsObject::IsConstraintAvailable ( DrmOperation op )

INT DrmRightsObject::OnContentConsumedEnd ( DrmOperation op )

If content has been consumed, OnContentConsumedEnd will update constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on update of internal constraint state

INT DrmRightsObject::OnContentConsumedStart ( DrmOperation op )

If content has been consumed, OnContentConsumedStart will update constraint internal state to indicate start of content consumption.

Parameters:
op Operation which consumes content
Returns:
TRUE on update of internal constraint state to indicate start of consumption

INT DrmRightsObject::OnRollback ( DrmOperation op )

If content has been consumed, OnRollback will update constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on updation of internal constraint state

void DrmRightsObject::SetKey ( const DrmKey & key )

Initializes the optional decryption key for encrypted content in separate delivery.

void DrmRightsObject::SetLocalId ( DrmLocalId local_id )

Initializes unique local id of a rights object.

void DrmRightsObject::SetMimeType ( DrmMimeType mime_type )

Initialize the DRM MIME type.

void DrmRightsObject::SetMoMimeType ( MimeType mime_type )

Initialize the media object MIME type.

void DrmRightsObject::SetRefCount ( UINT8 count ) [inline]

Sets the reference count of the rights object.

void DrmRightsObject::SetUid ( const DrmUid & uid )

Initializes UID of a rights object. The UID defines the associated asset.

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRights.hpp
  • AddOns/Drm/DrmRightsObject.cpp
Generated on Wed Jan 25 01:12:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmRightsObjectContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmRightsObjectContainer Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRightsStore.hpp>

Collaboration diagram for DrmRightsObjectContainer:

[legend]

Public Member Functions

void | AddRightsObject (const DrmRightsObject &rights_obj)
INT | GetCount () const
Returns the number of rights objects available for the asset.
DrmRightsObject & | GetRightsObject (INT i)
BOOLEAN | IsAllowed (DrmOperation op)
BOOLEAN | IsDrmOpValid (DrmOperation op, MimeType mo_type) const
BOOLEAN | OnContentConsumedEnd (DrmOperation op)
BOOLEAN | OnContentConsumedStart (DrmOperation op)
BOOLEAN | OnRollback (DrmOperation op)

Detailed Description

Multiple rights object can reference the same asset. Therefore DrmRightsObjectContainer is exposing the same interface than DrmRightsObject, but will ensure that all rights object will be consulted / updated accordingly.

Member Function Documentation

void DrmRightsObjectContainer::AddRightsObject ( const DrmRightsObject & rights_obj )

AddRightsObject - Adds a rights object to the container

Parameters:
rights_obj DrmRightsObject
Returns:
void

INT DrmRightsObjectContainer::GetCount ( ) const

Returns the number of rights objects available for the asset.

Multiple rights object can reference the same asset. Therefore DrmRightsObjectContainer is exposing the same interface than DrmRightsObject, but will ensure that all rights object will be consulted / updated accordingly.

DrmRightsObject & DrmRightsObjectContainer::GetRightsObject ( INT i )

Returns a right object

Parameters:
i index of rights object to retrieve
Returns:
reference to rights object

BOOLEAN DrmRightsObjectContainer::IsAllowed ( DrmOperation op )

IsAllowed returns TRUE if specified operation is allowed on asset. All rights object in the container will be consulted.

BOOLEAN DrmRightsObjectContainer::IsDrmOpValid | ( | DrmOperation | op,
 |  | MimeType | mo_type
 | ) | const

The function checks whether the given permissions can be allowed on the media object based on its MIME type.

Parameters:
op | Operation which consumes content
mo_type | Media object MIME type
Returns:
TRUE if permission can be allowed on the media object

BOOLEAN DrmRightsObjectContainer::OnContentConsumedEnd ( DrmOperation op )

If content has been consumed, OnContentConsumedEnd will update constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on update of internal constraint state

BOOLEAN DrmRightsObjectContainer::OnContentConsumedStart ( DrmOperation op )

If content has been consumed, OnContentConsumedStart will update constraint internal state to indicate start of content consumption.

Parameters:
op Operation which consumes content
Returns:
TRUE on update of internal constraint state to indicate start of consumption

BOOLEAN DrmRightsObjectContainer::OnRollback ( DrmOperation op )

If content has been consumed, OnRollback will update constraint internal state.

Parameters:
op Operation which consumes content
Returns:
TRUE on updation of internal constraint state

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRightsStore.hpp
  • AddOns/Drm/DrmRightsContainer.cpp
  • AddOns/Drm/DrmRightsStore.cpp
Generated on Wed Jan 25 01:12:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmRightsObjectFile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmRightsObjectFile Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRightsStore.hpp>

Static Public Member Functions

static BOOLEAN | Create (const CHAR *ro_file_path, DrmRightsObject &rights_obj)
static BOOLEAN | Delete (const CHAR *ro_file_path)
static BOOLEAN | GetRightsObject (const CHAR *ro_file_path, DrmRightsObject &rights_obj)
static BOOLEAN | ReadRightsObject (FlsFile &fp, DrmRightsObject &rights_obj)
static UINT32 | ReadROHeaderInfo (FlsFile &ro_file, DrmLocalId &id, DrmUid &uid)
static BOOLEAN | Update (const CHAR *ro_file_path, DrmRightsObject &rights_obj)
static BOOLEAN | WriteRightsObject (FlsFile &fp, DrmRightsObject &rights_obj)

Detailed Description

DrmRightsObjectFile - Abstracts a Rights Object in the FFS. It serializes and de-serializes the DrmRightsObject to and from the FFS. This will be used by the DrmRightsStore.

Member Function Documentation

BOOLEAN DrmRightsObjectFile::Create | ( | const CHAR * | ro_file_path,
 |  | DrmRightsObject & | rights_obj
 | ) | [static]

Create - Creates the rights object file. This is used to create the ro file for the first time.

Parameters:
const DrmRightsObject& Rights Object reference
Returns:
BOOLEAN success/failure of the write operation

BOOLEAN DrmRightsObjectFile::Delete ( const CHAR * ro_file_path ) [static]

Delete - Delete the file from FFS

BOOLEAN DrmRightsObjectFile::GetRightsObject | ( | const CHAR * | ro_file_path,
 |  | DrmRightsObject & | rights_obj
 | ) | [static]

GetRightsObject - Returns the rights information from the rights object file as DrmRightsObject.

Parameters:
DrmRightsObject reference

BOOLEAN DrmRightsObjectFile::ReadRightsObject | ( | FlsFile & | fp,
 |  | DrmRightsObject & | rights_obj
 | ) | [static]

ReadRightsObject - Used by GetRightsObject. Has the logic that loads the rights object from the FFS.

UINT32 DrmRightsObjectFile::ReadROHeaderInfo | ( | FlsFile & | ro_file,
 |  | DrmLocalId & | id,
 |  | DrmUid & | uid
 | ) | [static]

BOOLEAN DrmRightsObjectFile::Update | ( | const CHAR * | ro_file_path,
 |  | DrmRightsObject & | rights_obj
 | ) | [static]

Update - Updates the rights object file. This is used to update the file after the constraints are modified by OnContentConsumed

Parameters:
const DrmRightsObject Rights Object reference
Returns:
BOOLEAN success/failure of the write operation

BOOLEAN DrmRightsObjectFile::WriteRightsObject | ( | FlsFile & | fp,
 |  | DrmRightsObject & | rights_obj
 | ) | [static]

WriteRightsObject - Used by create and update. Has the logic that persists the rights object in FFS as a binary file.

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRightsStore.hpp
  • AddOns/Drm/DrmRightsStore.cpp
Generated on Wed Jan 25 01:12:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmRightsObjectStore Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmRightsObjectStore Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRightsStore.hpp>

Collaboration diagram for DrmRightsObjectStore:

[legend]

Public Member Functions

DrmLocalId | AddRightsObject (DrmRightsObject &ro)
BOOLEAN | DeleteRightsObject (DrmLocalId id)
DrmRightsObjectStore ()
BOOLEAN | GetDrmRights (const DrmLocalId &id, DrmRightsObjectContainer &ro_container)
DrmLocalId | GetNextLocalId (void)
void | InitRightsObjectMapTable (void)
BOOLEAN | IsLocalIdValid (DrmLocalId local_id)
DrmUid | MapLocalIdToUid (DrmLocalId id)
DrmLocalId | MapUidToLocalId (const DrmUid &uid)
BOOLEAN | UpdateRightsObject (DrmRightsObject &ro, INT r_index)

Detailed Description

DrmRightsObjectStore is the persistent storage area for DrmRightsObjects. Applications can retrieve DrmRightsObjectContainer objects to query constraints on assets. DrmRightsObjectStore is a singleton that will read rights objects at power on to memory and updates FFS database accordingly whenever a rights object status has been changed.

Constructor & Destructor Documentation

DrmRightsObjectStore::DrmRightsObjectStore ( )

Member Function Documentation

DrmLocalId DrmRightsObjectStore::AddRightsObject ( DrmRightsObject & ro )

AddRightsObject adds a new rights object to the store.

Returns:
local ID of the new rights object or c_drm_invalid_local_id on error.

BOOLEAN DrmRightsObjectStore::DeleteRightsObject ( DrmLocalId id )

AddRightsObject deletes all rights objects with the given id from the store.

Returns:
TRUE if operation succeeded, FALSE otherwise.

BOOLEAN DrmRightsObjectStore::GetDrmRights | ( | const DrmLocalId & | id,
 |  | DrmRightsObjectContainer & | ro_container
 | ) |

GetDrmRights retrieves all rights object available for a given local ID of an asset

Returns:
a DrmRightsObjectContainer that holds all available rights objects for the asset.

DrmLocalId DrmRightsObjectStore::GetNextLocalId ( void )

GetNextlocalId - Get the next available local ID. This function refers the map to allocate the next available local ID.

Returns:
DrmLcoalId Local ID

void DrmRightsObjectStore::InitRightsObjectMapTable ( void )

Init function to initialize the map. Called only once when the Store is created

BOOLEAN DrmRightsObjectStore::IsLocalIdValid ( DrmLocalId local_id )

Validates the local ID against the map.

Returns:
TRUE if operation succeeded, FALSE otherwise.

DrmUid DrmRightsObjectStore::MapLocalIdToUid ( DrmLocalId id )

Maps a device local ID of an asset to OMA DRM UID

Returns:
UID of local ID or Null string if no such local ID exists in the system.

DrmLocalId DrmRightsObjectStore::MapUidToLocalId ( const DrmUid & uid )

Maps a OMA DRM UID of an asset to device local unique ID

Returns:
local ID of UID or c_drm_invalid_local_id if no such UID is stored in the device.

BOOLEAN DrmRightsObjectStore::UpdateRightsObject | ( | DrmRightsObject & | ro,
 |  | INT | r_index
 | ) |

UpdateRightsObject - Updates the existing rights object

Returns:
success/failure

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRightsStore.hpp
  • AddOns/Drm/DrmRightsStore.cpp
Generated on Wed Jan 25 01:12:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmROStoreSingleton Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmROStoreSingleton Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRightsStore.hpp>

Collaboration diagram for DrmROStoreSingleton:

[legend]

Static Public Member Functions

static void | DestroyInstance ()
static DrmRightsObjectStore * | Instance ()

Protected Member Functions

DrmROStoreSingleton ()
virtual | ~DrmROStoreSingleton ()

Detailed Description

When the static Instance() method is called for the first time, the singleton object is created. Every sequential call returns a reference to this instance. The class instance can be destroyed by calling the DestroyInstance() method.

Constructor & Destructor Documentation

DrmROStoreSingleton::DrmROStoreSingleton ( ) [inline, protected]

Shield the constructor(s) and destructor

virtual DrmROStoreSingleton::~DrmROStoreSingleton ( ) [inline, protected, virtual]

Member Function Documentation

static void DrmROStoreSingleton::DestroyInstance ( ) [inline, static]

DestroyInstance -- Destroys the only instance. IMPORTANT : Call it as a last step and avoid dangling references

static DrmRightsObjectStore* DrmROStoreSingleton::Instance ( ) [inline, static]

Instance - Returns a reference to the instance, if not there creates it.

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRightsStore.hpp
  • AddOns/Drm/DrmRightsStore.cpp
Generated on Wed Jan 25 01:12:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmSecurity Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmSecurity Class Reference

#include <Apoxi/AddOns/Drm/DrmSecurity.hpp>

Public Member Functions

DrmSecurity ()
~DrmSecurity ()

Static Public Member Functions

static BOOLEAN | DrmCrypt (UINT8 *in_buf, INT buf_len)
static void | InitializeKey ()

Detailed Description

Provide lite weight encryption/decryption interface

Constructor & Destructor Documentation

DrmSecurity::DrmSecurity ( ) [inline]

DrmSecurity::~DrmSecurity ( ) [inline]

Member Function Documentation

BOOLEAN DrmSecurity::DrmCrypt | ( | UINT8 * | in_buf,
 |  | INT | buf_len
 | ) | [static]

Encrypts/Decrypts the the given buffer. The result is stored back in the given buffer itself. The key for encryption/decryption is known to only DRM security module.

Returns:
TRUE on success

void DrmSecurity::InitializeKey ( ) [static]

Initialize the encryption key. This function should be called once during DRM initialization.

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmSecurity.hpp
  • AddOns/Drm/DrmSecurity.cpp
Generated on Wed Jan 25 01:12:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmSubsystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmSubsystem Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmSubsystem.hpp>

Inheritance diagram for DrmSubsystem:

[legend]
Collaboration diagram for DrmSubsystem:

[legend]

Public Member Functions

DrmSubsystem ()
virtual const WCHAR * | GetName () const
virtual UINT8 | GetPriority () const
priority controls the init sequence of SubSystems
virtual BootSequenceState | InvokeAt () const
define the point of time when the DrmSubsystem should be invoked
virtual void | OnPowerDown ()
shuts down the DrmSubsystem sub-system
virtual void | OnPowerUp ()
starts up the DrmSubsystem sub-system

Static Public Member Functions

static DrmSubsystem * | GetInstance ()

Constructor & Destructor Documentation

DrmSubsystem::DrmSubsystem ( )

Member Function Documentation

static DrmSubsystem* DrmSubsystem::GetInstance ( ) [inline, static]

virtual const WCHAR* DrmSubsystem::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

virtual UINT8 DrmSubsystem::GetPriority ( ) const [inline, virtual]

priority controls the init sequence of SubSystems

Reimplemented from SubSystem.

virtual BootSequenceState DrmSubsystem::InvokeAt ( ) const [inline, virtual]

define the point of time when the DrmSubsystem should be invoked

Implements SubSystem.

void DrmSubsystem::OnPowerDown ( ) [virtual]

shuts down the DrmSubsystem sub-system

Reimplemented from SubSystem.

void DrmSubsystem::OnPowerUp ( ) [virtual]

starts up the DrmSubsystem sub-system

Reimplemented from SubSystem.

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmSubsystem.hpp
  • AddOns/Drm/DrmSubsystem.cpp
Generated on Wed Jan 25 01:12:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmUtils Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmUtils Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmUtils.hpp>

Static Public Member Functions

static BOOLEAN DecodeBase64Data (UINT8 *base64data, INT base64len, UINT8 **decoded_buf, INT *buflen)

Detailed Description

DrmUtils - Utility functions for the DRM engine All utility functions used by the DRM module to be placed here.

Member Function Documentation

BOOLEAN DrmUtils::DecodeBase64Data | ( | UINT8 * | base64data,
 |  | INT | base64len,
 |  | UINT8 ** | decoded_buf,
 |  | INT * | buflen
 | ) | [static]

Decodes the Base64Data

Parameters:
UINT8* | - base64 encoded data - allocated and filled by user
INT | - length of the base64 encoded data
UINT8* | - decoded data - allocated and filled by method
INT | - length of the decoded data

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmUtils.hpp
  • AddOns/Drm/DrmUtils.cpp
Generated on Wed Jan 25 01:12:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DrmWapPushMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DrmWapPushMsg Class Reference

#include <Apoxi/AddOns/Drm/DrmWapPushMsg.hpp>

Inheritance diagram for DrmWapPushMsg:

[legend]
Collaboration diagram for DrmWapPushMsg:

[legend]

Public Types

enum | { ID = 4350 }

Public Member Functions

virtual Message * | Clone () const
DrmWapPushMsg (const DrmLocalId &local_id=c_drm_invalid_local_id)
const DrmLocalId & | GetLocalId () const
virtual const MsgMetaData & | GetMetaData () const
void | SetLocalId (const DrmLocalId &local_id)
virtual | ~DrmWapPushMsg ()

Detailed Description

Message indicating successful reception of valid DRM rights object.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DrmWapPushMsg::DrmWapPushMsg ( const DrmLocalId & local_id = c_drm_invalid_local_id )

DrmWapPushMsg::~DrmWapPushMsg ( ) [virtual]

Member Function Documentation

Message * DrmWapPushMsg::Clone ( ) const [virtual]

Implements Message.

const DrmLocalId& DrmWapPushMsg::GetLocalId ( ) const [inline]

const MsgMetaData & DrmWapPushMsg::GetMetaData ( ) const [virtual]

Implements Message.

void DrmWapPushMsg::SetLocalId ( const DrmLocalId & local_id ) [inline]

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmWapPushMsg.hpp
  • AddOns/Drm/DrmWapPushMsg.cpp
Generated on Wed Jan 25 01:12:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: dstat Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

dstat Struct Reference

#include <Apoxi/AddOns/AfsFat/FatSim.hpp>

Data Fields

sshort driveno
ushort fattribute
ushort fdate
char | fext [4]
char | fname [10]
ulong fsize
ushort ftime
char | longFileName [FS_MAXPATH]
char | path [FS_MAXPATH]
char | pext [4]
char | plongFileName [FS_MAXPATH]
void * | pmom
char | pname [10]
void * | pobj

Field Documentation

sshort dstat::driveno

ushort dstat::fattribute

ushort dstat::fdate

char dstat::fext[4]

char dstat::fname[10]

ulong dstat::fsize

ushort dstat::ftime

char dstat::longFileName[FS_MAXPATH]

char dstat::path[FS_MAXPATH]

char dstat::pext[4]

char dstat::plongFileName[FS_MAXPATH]

void* dstat::pmom

char dstat::pname[10]

void* dstat::pobj

The documentation for this struct was generated from the following file:
  • AddOns/AfsFat/FatSim.hpp
Generated on Wed Jan 25 01:12:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DtmfBufferCleanedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DtmfBufferCleanedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DtmfBufferCleanedMsg:

[legend]
Collaboration diagram for DtmfBufferCleanedMsg:

[legend]

Public Types

enum | { ID = 18411 }

Public Member Functions

virtual Message * | Clone () const
DtmfBufferCleanedMsg (ExecutionContext *context)
virtual const MsgMetaData & | GetMetaData () const
virtual | ~DtmfBufferCleanedMsg ()

Detailed Description

DtmfBufferCleanedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DtmfBufferCleanedMsg::DtmfBufferCleanedMsg ( ExecutionContext * context )

DtmfBufferCleanedMsg::~DtmfBufferCleanedMsg ( ) [virtual]

Member Function Documentation

Message * DtmfBufferCleanedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & DtmfBufferCleanedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:12:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DtmfBufferClearedIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DtmfBufferClearedIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for DtmfBufferClearedIndArg:

[legend]
Collaboration diagram for DtmfBufferClearedIndArg:

[legend]

Public Types

enum | { ID = 1127 }

Public Member Functions

DtmfBufferClearedIndArg ()

Static Public Member Functions

static const DtmfBufferClearedIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

DtmfBufferClearedIndArg reflects arguments of signal MN_DTMF_BUFFER_CLEARED_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DtmfBufferClearedIndArg::DtmfBufferClearedIndArg ( )

Member Function Documentation

const DtmfBufferClearedIndArg & DtmfBufferClearedIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:12:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DtmfRejectArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DtmfRejectArg Struct Reference
[APOXI Stack Control]

Structure keeping DTMF rejection cause and respective call index of the call. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for DtmfRejectArg:

[legend]

Data Fields

CallHdl call
A refernce to the respective call.
CallErrorCause cause
Cause for DTMF generation reject.

Detailed Description

Structure keeping DTMF rejection cause and respective call index of the call.

Field Documentation

CallHdl DtmfRejectArg::call

A refernce to the respective call.

CallErrorCause DtmfRejectArg::cause

Cause for DTMF generation reject.

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 01:12:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DtmfRejectMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DtmfRejectMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DtmfRejectMsg:

[legend]
Collaboration diagram for DtmfRejectMsg:

[legend]

Public Types

enum | { ID = 18410 }

Public Member Functions

virtual Message * | Clone () const
DtmfRejectMsg (ExecutionContext *context, const DtmfRejectArg &arg)
const DtmfRejectArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DtmfRejectArg &arg)
virtual | ~DtmfRejectMsg ()

Detailed Description

DtmfRejectMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DtmfRejectMsg::DtmfRejectMsg | ( | ExecutionContext * | context,
 |  | const DtmfRejectArg & | arg
 | ) |

DtmfRejectMsg::~DtmfRejectMsg ( ) [virtual]

Member Function Documentation

Message * DtmfRejectMsg::Clone ( ) const [virtual]

Implements Message.

const DtmfRejectArg& DtmfRejectMsg::GetArg ( ) const [inline]

const MsgMetaData & DtmfRejectMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DtmfRejectMsg::SetArg ( const DtmfRejectArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:12:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DtmfStartCnfArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DtmfStartCnfArg Struct Reference
[APOXI Stack Control]

Structure keeping information for DTMF tone generation. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for DtmfStartCnfArg:

[legend]

Data Fields

CallHdl call
A CallHdl object holding the call_index of the active call.
KeyCode key
Respective key code of the pressed key.

Detailed Description

Structure keeping information for DTMF tone generation.

Field Documentation

CallHdl DtmfStartCnfArg::call

A CallHdl object holding the call_index of the active call.

KeyCode DtmfStartCnfArg::key

Respective key code of the pressed key.

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 01:12:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DtmfStartCnfMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DtmfStartCnfMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DtmfStartCnfMsg:

[legend]
Collaboration diagram for DtmfStartCnfMsg:

[legend]

Public Types

enum | { ID = 18408 }

Public Member Functions

virtual Message * | Clone () const
DtmfStartCnfMsg (ExecutionContext *context, const DtmfStartCnfArg &arg)
const DtmfStartCnfArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DtmfStartCnfArg &arg)
virtual | ~DtmfStartCnfMsg ()

Detailed Description

DtmfStartCnfMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DtmfStartCnfMsg::DtmfStartCnfMsg | ( | ExecutionContext * | context,
 |  | const DtmfStartCnfArg & | arg
 | ) |

DtmfStartCnfMsg::~DtmfStartCnfMsg ( ) [virtual]

Member Function Documentation

Message * DtmfStartCnfMsg::Clone ( ) const [virtual]

Implements Message.

const DtmfStartCnfArg& DtmfStartCnfMsg::GetArg ( ) const [inline]

const MsgMetaData & DtmfStartCnfMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DtmfStartCnfMsg::SetArg ( const DtmfStartCnfArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:12:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DtmfStopCnfMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DtmfStopCnfMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for DtmfStopCnfMsg:

[legend]
Collaboration diagram for DtmfStopCnfMsg:

[legend]

Public Types

enum | { ID = 18409 }

Public Member Functions

virtual Message * | Clone () const
DtmfStopCnfMsg (ExecutionContext *context, const CallHdl &arg)
const CallHdl & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallHdl &arg)
virtual | ~DtmfStopCnfMsg ()

Detailed Description

DtmfStopCnfMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

DtmfStopCnfMsg::DtmfStopCnfMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | arg
 | ) |

DtmfStopCnfMsg::~DtmfStopCnfMsg ( ) [virtual]

Member Function Documentation

Message * DtmfStopCnfMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& DtmfStopCnfMsg::GetArg ( ) const [inline]

const MsgMetaData & DtmfStopCnfMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void DtmfStopCnfMsg::SetArg ( const CallHdl & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:12:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DualFilterProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DualFilterProvider Class Reference
[AuxExtensions]

#include <Apoxi/AddOns/AuxExtensions/DualFilterProvider.hpp>

Inheritance diagram for DualFilterProvider:

[legend]
Collaboration diagram for DualFilterProvider:

[legend]

Public Types

enum FilterOperator {
AndFilterOp, OrFilterOp, XorFilterOp, FirstAndNotSecondFilterOp,
NotFirstAndSecondFilterOp, FirstOrNotSecondFilterOp, NotFirstOrSecondFilterOp
}

Public Member Functions

DualFilterProvider (Provider *provider, FilterRule *fst_rule, FilterRule *snd_rule, INT fst_columnid=0, INT snd_columnid=0, FilterOperator op=AndFilterOp, BOOLEAN negation=FALSE)
DualFilterProvider ()
void | Init (Provider *provider, FilterRule *fst_rule, FilterRule *snd_rule, INT fst_columnid=0, INT snd_columnid=0, FilterOperator op=AndFilterOp, BOOLEAN negation=FALSE)
The same interface as the constructor.
virtual BOOLEAN | SetParameter (const DataItem &item)
Set the FilterOperator.
void | SetSecondFilterColumn (INT filtercolumn)
Specify on which column rule has to be applied.
void | SetSecondFilterRule (FilterRule *rule)
Specify how the rows are filtered.
virtual | ~DualFilterProvider ()

Protected Member Functions

virtual BOOLEAN | IsRowFiltered (Provider *base_provider, INT row, BOOLEAN negate)

Detailed Description

A DualFilterProvider is used to access rows of a child provider which match a criterion specified in a filter rule.

Member Enumeration Documentation

enum DualFilterProvider::FilterOperator

Enumerator:
AndFilterOp
OrFilterOp
XorFilterOp
FirstAndNotSecondFilterOp
NotFirstAndSecondFilterOp
FirstOrNotSecondFilterOp
NotFirstOrSecondFilterOp

Constructor & Destructor Documentation

DualFilterProvider::DualFilterProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

DualFilterProvider::DualFilterProvider | ( | Provider * | provider,
 |  | FilterRule * | fst_rule,
 |  | FilterRule * | snd_rule,
 |  | INT | fst_columnid = 0,
 |  | INT | snd_columnid = 0,
 |  | FilterOperator | op = AndFilterOp,
 |  | BOOLEAN | negation = FALSE
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be filtered. rule: Specify how the rows are filtered. columnid: Specify on which columnid rule has to be applied. negation: Specify whether rule must be negated.

DualFilterProvider::~DualFilterProvider ( ) [virtual]

Member Function Documentation

void DualFilterProvider::Init | ( | Provider * | provider,
 |  | FilterRule * | fst_rule,
 |  | FilterRule * | snd_rule,
 |  | INT | fst_columnid = 0,
 |  | INT | snd_columnid = 0,
 |  | FilterOperator | op = AndFilterOp,
 |  | BOOLEAN | negation = FALSE
 | ) |

The same interface as the constructor.

BOOLEAN DualFilterProvider::IsRowFiltered | ( | Provider * | base_provider,
 |  | INT | row,
 |  | BOOLEAN | negate
 | ) | [protected, virtual]

Determines whether or not the specified row should be included.

Parameters:
base_provider | Child provider.
row | Index of row to test.
negate | TRUE to negate the result, FALSE otherwise.
Returns:
TRUE to include row row, FALSE otherwise.

Reimplemented from FilterProvider.

BOOLEAN DualFilterProvider::SetParameter ( const DataItem & item ) [virtual]

Set the FilterOperator.

Reimplemented from FilterProvider.

void DualFilterProvider::SetSecondFilterColumn ( INT filtercolumn ) [inline]

Specify on which column rule has to be applied.

void DualFilterProvider::SetSecondFilterRule ( FilterRule * rule ) [inline]

Specify how the rows are filtered.

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/DualFilterProvider.hpp
  • AddOns/AuxExtensions/DualFilterProvider.cpp
Generated on Wed Jan 25 01:12:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DummyVrEngineParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DummyVrEngineParams Class Reference

#include <Apoxi/AddOns/VoiceRecognition/DummyVrEngineParams.hpp>

Inheritance diagram for DummyVrEngineParams:

[legend]
Collaboration diagram for DummyVrEngineParams:

[legend]

Public Member Functions

DummyVrEngineParams ()
construct
virtual void * | GetNativeParams ()
virtual BOOLEAN | SetMaxRecognitionTime (UINT16 time)
Set the maximum duration for recognition (in ms).
virtual BOOLEAN | SetMaxSilenceTime (UINT16 time)
Set max. time of silence after which recognition is ends (in ms).
virtual BOOLEAN | SetRecognitionMode (VrHandler::VrRecognitionMode mode)
Set Recognition mode.

Constructor & Destructor Documentation

DummyVrEngineParams::DummyVrEngineParams ( )

construct

Member Function Documentation

virtual void* DummyVrEngineParams::GetNativeParams ( ) [inline, virtual]

Implements VrEngineParams.

BOOLEAN DummyVrEngineParams::SetMaxRecognitionTime ( UINT16 time ) [virtual]

Set the maximum duration for recognition (in ms).

Implements VrEngineParams.

BOOLEAN DummyVrEngineParams::SetMaxSilenceTime ( UINT16 time ) [virtual]

Set max. time of silence after which recognition is ends (in ms).

Implements VrEngineParams.

BOOLEAN DummyVrEngineParams::SetRecognitionMode ( VrHandler::VrRecognitionMode mode ) [virtual]

Set Recognition mode.

Implements VrEngineParams.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/DummyVrEngineParams.hpp
  • AddOns/VoiceRecognition/DummyVrEngineParams.cpp
Generated on Wed Jan 25 01:12:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DwdDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DwdDevice Class Reference
[Audio]

#include <Apoxi/Audio/DwdDevice.hpp>

Inheritance diagram for DwdDevice:

[legend]
Collaboration diagram for DwdDevice:

[legend]

Public Member Functions

DwdDevice ()
virtual | ~DwdDevice ()

Protected Types

typedef INT | AudResource
typedef UINT8 | DwdHandleType
typedef UINT16 | DwdIDType

Protected Member Functions

void | DeAllocateDwd (AudioActiveReference &audio_ref)
void | DeAllocateDwdID (AudioActiveReference &audio_ref)
void | GenerateHandleId (AudioActiveReference &active_reference)
BOOLEAN | HandleAudReturnCode (const AudioReference &audio_reference, const AudioError::AudReturnCode return_code)
virtual BOOLEAN | Play_Allocate (AudioActiveReference &audio_ref)=0
BOOLEAN | Play_Allocate_DWD (AudioActiveReference &active_reference, AudResource aud_resource)

Static Protected Member Functions

static void | AddReferenceMapping (AudioActiveReference &active_reference, INT32 handle_id)
static SharedPtr< AudioActiveReference > | FindReference (INT32 handle_id)
static void | RemoveReferenceMapping (UINT32 handle_id)

Protected Attributes

DwdHandleType m_dwd_handle

Detailed Description

This is the base class for all audio devices which make use of the audio drivers from DWD.

Member Typedef Documentation

typedef INT DwdDevice::AudResource [protected]

typedef UINT8 DwdDevice::DwdHandleType [protected]

typedef UINT16 DwdDevice::DwdIDType [protected]

Constructor & Destructor Documentation

DwdDevice::DwdDevice ( )

DwdDevice::~DwdDevice ( ) [virtual]

Member Function Documentation

void DwdDevice::AddReferenceMapping | ( | AudioActiveReference & | active_reference,
 |  | INT32 | handle_id
 | ) | [static, protected]

void DwdDevice::DeAllocateDwd ( AudioActiveReference & audio_ref ) [protected]

void DwdDevice::DeAllocateDwdID ( AudioActiveReference & audio_ref ) [protected]

SharedPtr< AudioActiveReference > DwdDevice::FindReference ( INT32 handle_id ) [static, protected]

void DwdDevice::GenerateHandleId ( AudioActiveReference & active_reference ) [protected]

BOOLEAN DwdDevice::HandleAudReturnCode | ( | const AudioReference & | audio_reference,
 |  | const AudioError::AudReturnCode | return_code
 | ) | [protected]

virtual BOOLEAN DwdDevice::Play_Allocate ( AudioActiveReference & audio_ref ) [protected, pure virtual]

Implemented in MapiAudioPlayer, and AudioVibratorDevice.

BOOLEAN DwdDevice::Play_Allocate_DWD | ( | AudioActiveReference & | active_reference,
 |  | AudResource | aud_resource
 | ) | [protected]

void DwdDevice::RemoveReferenceMapping ( UINT32 handle_id ) [static, protected]

Field Documentation

DwdHandleType DwdDevice::m_dwd_handle [protected]

The documentation for this class was generated from the following files:
  • Audio/DwdDevice.hpp
  • Audio/DwdDevice.cpp
Generated on Wed Jan 25 01:12:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DwdPlayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DwdPlayer Class Reference
[Audio]

#include <Apoxi/Audio/DwdPlayer.hpp>

Inheritance diagram for DwdPlayer:

[legend]
Collaboration diagram for DwdPlayer:

[legend]

Public Member Functions

virtual BOOLEAN | CanPlay (const AudioActiveReference &active_reference) const
virtual BOOLEAN | CanResume (const AudioActiveReference &active_reference) const
virtual BOOLEAN | CanSuspend (const AudioActiveReference &active_reference) const
DwdPlayer ()
virtual | ~DwdPlayer ()

Protected Types

typedef UINT8 | SuspendSlotType

Protected Member Functions

void | AllocateSuspendSlot (SuspendSlotType suspend_slot)
void | AllocateSuspendSlot (SuspendSlotType suspendSlot, AudioActiveReference *ref_ptr)
Reserve the suspend slot.
BOOLEAN | GetAllocatedSuspendSlot (AudioActiveReference *ref_ptr, SuspendSlotType &suspend_slot)
BOOLEAN | GetAvailableSuspendSlot (SuspendSlotType &suspend_slot)
virtual BOOLEAN | OnSdlSignal (UINT16 func_id, UINT8 handle, UINT16 drv_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4)
void | ReleaseSuspendSlot (DwdPlayer::SuspendSlotType suspend_slot)
void | ReleaseSuspendSlot (AudioActiveReference *ref_ptr)
Release the suspend slot.
virtual BOOLEAN | SetVolume_Implementation (VolumeLevel volume)

Detailed Description

This is the base class for all audio players which make use of the audio drivers from DWD.

Member Typedef Documentation

typedef UINT8 DwdPlayer::SuspendSlotType [protected]

Constructor & Destructor Documentation

DwdPlayer::DwdPlayer ( )

DwdPlayer::~DwdPlayer ( ) [virtual]

Member Function Documentation

void DwdPlayer::AllocateSuspendSlot ( SuspendSlotType suspend_slot ) [protected]

void DwdPlayer::AllocateSuspendSlot | ( | SuspendSlotType | suspendSlot,
 |  | AudioActiveReference * | ref_ptr
 | ) | [protected]

Reserve the suspend slot.

BOOLEAN DwdPlayer::CanPlay ( const AudioActiveReference & active_reference ) const [virtual]

Reimplemented in StreamAudioPlayer.

BOOLEAN DwdPlayer::CanResume ( const AudioActiveReference & active_reference ) const [virtual]

Reimplemented in MapiAudioPlayer, and StreamAudioPlayer.

BOOLEAN DwdPlayer::CanSuspend ( const AudioActiveReference & active_reference ) const [virtual]

Reimplemented in MapiAudioPlayer, and StreamAudioPlayer.

BOOLEAN DwdPlayer::GetAllocatedSuspendSlot | ( | AudioActiveReference * | ref_ptr,
 |  | SuspendSlotType & | suspend_slot
 | ) | [protected]

BOOLEAN DwdPlayer::GetAvailableSuspendSlot ( SuspendSlotType & suspend_slot ) [protected]

Get the available suspend slot

Parameters:
suspend_slot The available slot
Returns:
FALSE if there are no slots available that means all are already reserved for suspension

BOOLEAN DwdPlayer::OnSdlSignal | ( | UINT16 | func_id,
 |  | UINT8 | handle,
 |  | UINT16 | drv_id,
 |  | INT8 | return_code,
 |  | UINT32 | param1,
 |  | UINT32 | param2,
 |  | UINT32 | param3,
 |  | UINT32 | param4
 | ) | [protected, virtual]

Reimplemented in MapiAudioPlayer.

void DwdPlayer::ReleaseSuspendSlot ( DwdPlayer::SuspendSlotType suspend_slot ) [protected]

void DwdPlayer::ReleaseSuspendSlot ( AudioActiveReference * ref_ptr ) [protected]

Release the suspend slot.

BOOLEAN DwdPlayer::SetVolume_Implementation ( VolumeLevel volume ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Audio/DwdPlayer.hpp
  • Audio/DwdPlayer.cpp
Generated on Wed Jan 25 01:12:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DynamicBitVector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DynamicBitVector Class Reference

#include <Apoxi/Auxiliary/DynamicBitVector.hpp>

Public Member Functions

DynamicBitVector (const DynamicBitVector &from)
Constructs a bit vector by duplication of an existing one.
DynamicBitVector (INT nrofbits)
Constructs a bit vector with nrofbits bits.
DynamicBitVector ()
Constructs an empty bit vector.
BOOLEAN | GetBit (INT idx) const
Retrieves bit value at index idx.
UINT | GetLength () const
Returns the length of the vector in bits.
BOOLEAN | Intersects (const DynamicBitVector &rhs) const
Returns TRUE when the set intersection is non-empty.
DynamicBitVector & | operator= (const DynamicBitVector &from)
Assigns a bit vector to another one.
void | SetBit (INT idx, BOOLEAN set=TRUE)
Assigns parameter set to bit value at index idx.
~DynamicBitVector ()
Destructs a bit vector.

Detailed Description

DynamicBitVector is used to allocate a dynamic bit vector with an arbitrary number of bits.

Constructor & Destructor Documentation

DynamicBitVector::DynamicBitVector ( ) [inline]

Constructs an empty bit vector.

DynamicBitVector::DynamicBitVector ( INT nrofbits ) [inline]

Constructs a bit vector with nrofbits bits.

DynamicBitVector::DynamicBitVector ( const DynamicBitVector & from ) [inline]

Constructs a bit vector by duplication of an existing one.

DynamicBitVector::~DynamicBitVector ( ) [inline]

Destructs a bit vector.

Member Function Documentation

BOOLEAN DynamicBitVector::GetBit ( INT idx ) const [inline]

Retrieves bit value at index idx.

UINT DynamicBitVector::GetLength ( ) const [inline]

Returns the length of the vector in bits.

BOOLEAN DynamicBitVector::Intersects ( const DynamicBitVector & rhs ) const [inline]

Returns TRUE when the set intersection is non-empty.

DynamicBitVector& DynamicBitVector::operator= ( const DynamicBitVector & from ) [inline]

Assigns a bit vector to another one.

void DynamicBitVector::SetBit | ( | INT | idx,
 |  | BOOLEAN | set = TRUE
 | ) | [inline]

Assigns parameter set to bit value at index idx.

The documentation for this class was generated from the following file:
  • Auxiliary/DynamicBitVector.hpp
Generated on Wed Jan 25 01:12:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: DynamicMenuPool Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DynamicMenuPool Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Config/DynamicMenuPool.hpp>

Inheritance diagram for DynamicMenuPool:

[legend]
Collaboration diagram for DynamicMenuPool:

[legend]

Public Member Functions

DynamicMenuPool ()
virtual ~DynamicMenuPool ()

Constructor & Destructor Documentation

DynamicMenuPool::DynamicMenuPool ( )

DynamicMenuPool::~DynamicMenuPool ( ) [virtual]

The documentation for this class was generated from the following files:
  • Atl/Config/DynamicMenuPool.hpp
  • Atl/Config/DynamicMenuPool.cpp
Generated on Wed Jan 25 01:12:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EccArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EccArray Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 | length
UINT8 | val [15]

Field Documentation

UINT8 EccArray::length

UINT8 EccArray::val[15]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:12:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EccCategory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EccCategory Class Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for EccCategory:

[legend]

Public Member Functions

EccCategory (const EccCategory &cat)
EccCategory (UINT8 value)
EccCategory ()
UINT8 | GetValue () const
BOOLEAN | IsAmbulance () const
BOOLEAN | IsFireBrigade () const
BOOLEAN | IsMarineGuard () const
BOOLEAN | IsMountainRescue () const
BOOLEAN | IsPolice () const
EccCategory & | operator= (const EccCategory &cat)
void | SetValue (UINT8 value)

Constructor & Destructor Documentation

EccCategory::EccCategory ( ) [inline]

EccCategory::EccCategory ( UINT8 value ) [inline]

EccCategory::EccCategory ( const EccCategory & cat ) [inline]

Member Function Documentation

UINT8 EccCategory::GetValue ( ) const [inline]

BOOLEAN EccCategory::IsAmbulance ( ) const [inline]

BOOLEAN EccCategory::IsFireBrigade ( ) const [inline]

BOOLEAN EccCategory::IsMarineGuard ( ) const [inline]

BOOLEAN EccCategory::IsMountainRescue ( ) const [inline]

BOOLEAN EccCategory::IsPolice ( ) const [inline]

EccCategory& EccCategory::operator= ( const EccCategory & cat ) [inline]

void EccCategory::SetValue ( UINT8 value ) [inline]

The documentation for this class was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:12:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EccCustomization Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EccCustomization Class Reference
[Provider]

#include <Apoxi/Adc/EccProvider.hpp>

The documentation for this class was generated from the following file:
  • Adc/EccProvider.hpp
Generated on Wed Jan 25 01:12:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EccListIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EccListIndArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for EccListIndArg:

[legend]
Collaboration diagram for EccListIndArg:

[legend]

Public Types

enum | { ID = 1380 }

Public Member Functions

EccListIndArg ()
EccListIndArg (const EccNetworkArray &ecc_network_array)
const EccNetworkArray & | GetEccNetworkArray () const
void | SetEccNetworkArray (const EccNetworkArray &ecc_network_array)

Static Public Member Functions

static const EccListIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

EccListIndArg : reflects arguments of signal MN_ECC_LIST_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EccListIndArg::EccListIndArg ( const EccNetworkArray & ecc_network_array )

EccListIndArg::EccListIndArg ( )

Member Function Documentation

const EccListIndArg & EccListIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const EccNetworkArray& EccListIndArg::GetEccNetworkArray ( ) const [inline]

void EccListIndArg::SetEccNetworkArray ( const EccNetworkArray & ecc_network_array ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:12:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EccNetworkArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EccNetworkArray Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for EccNetworkArray:

[legend]

Data Fields

EccNetworkElement m_elements [c_max_ecc_network_elements]
INT m_number

Field Documentation

EccNetworkElement EccNetworkArray::m_elements[c_max_ecc_network_elements]

INT EccNetworkArray::m_number

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:12:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EccNetworkElement Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EccNetworkElement Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for EccNetworkElement:

[legend]

Data Fields

UINT8 m_category
EccNetworkNumber m_number

Field Documentation

UINT8 EccNetworkElement::m_category

EccNetworkNumber EccNetworkElement::m_number

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:12:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EccNetworkNumber Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EccNetworkNumber Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [c_max_ecc_network_number_length]

Field Documentation

UINT8 EccNetworkNumber::val[c_max_ecc_network_number_length]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:12:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EccProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EccProvider Class Reference
[Provider]

#include <Apoxi/Adc/EccProvider.hpp>

Inheritance diagram for EccProvider:

[legend]
Collaboration diagram for EccProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

EccProvider ()
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
EccCategory | GetEccCategory (const WString &checkstr)
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *aux_handler, Protector *protector)
BOOLEAN | IsEccCode (const WString &checkstr)
virtual INT | RowCount ()
RowCount returns the number of rows.
void | SetEccNetworkArray (const EccNetworkArray &eccarray)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~EccProvider ()

Member Typedef Documentation

typedef ThreadSafeProvider EccProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

EccProvider::EccProvider ( )

EccProvider::~EccProvider ( ) [virtual]

Member Function Documentation

BOOLEAN EccProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

EccCategory EccProvider::GetEccCategory ( const WString & checkstr )

INT EccProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void EccProvider::Init | ( | SimAuxHandler * | aux_handler,
 |  | Protector * | protector
 | ) |

BOOLEAN EccProvider::IsEccCode ( const WString & checkstr )

INT EccProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

void EccProvider::SetEccNetworkArray ( const EccNetworkArray & eccarray )

BOOLEAN EccProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/EccProvider.hpp
  • Adc/EccProvider.cpp
Generated on Wed Jan 25 01:12:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EctActiveMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EctActiveMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for EctActiveMsg:

[legend]
Collaboration diagram for EctActiveMsg:

[legend]

Public Types

enum | { ID = 18535 }

Public Member Functions

virtual Message * | Clone () const
EctActiveMsg (ExecutionContext *context, const Tipd &tipd, const RdnChoice &rdn_selector, const PhoneNumber &address, const PhoneNumber &sub_address)
const PhoneNumber & | GetAddress () const
virtual const MsgMetaData & | GetMetaData () const
const RdnChoice & | GetRdnSelector () const
const PhoneNumber & | GetSubAddress () const
const Tipd & | GetTipd () const
virtual | ~EctActiveMsg ()

Detailed Description

EctActiveMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EctActiveMsg::EctActiveMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const RdnChoice & | rdn_selector,
 |  | const PhoneNumber & | address,
 |  | const PhoneNumber & | sub_address
 | ) |

EctActiveMsg::~EctActiveMsg ( ) [virtual]

Member Function Documentation

Message * EctActiveMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const PhoneNumber& EctActiveMsg::GetAddress ( ) const [inline]

const MsgMetaData & EctActiveMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const RdnChoice& EctActiveMsg::GetRdnSelector ( ) const [inline]

const PhoneNumber& EctActiveMsg::GetSubAddress ( ) const [inline]

const Tipd& EctActiveMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:12:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EctAlertingMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EctAlertingMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for EctAlertingMsg:

[legend]
Collaboration diagram for EctAlertingMsg:

[legend]

Public Types

enum | { ID = 18536 }

Public Member Functions

virtual Message * | Clone () const
EctAlertingMsg (ExecutionContext *context, const Tipd &tipd)
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
virtual | ~EctAlertingMsg ()

Detailed Description

EctAlertingMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EctAlertingMsg::EctAlertingMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd
 | ) |

EctAlertingMsg::~EctAlertingMsg ( ) [virtual]

Member Function Documentation

Message * EctAlertingMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & EctAlertingMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& EctAlertingMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:12:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EctCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EctCnfArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for EctCnfArg:

[legend]
Collaboration diagram for EctCnfArg:

[legend]

Public Types

enum | { ID = 1065 }

Public Member Functions

EctCnfArg ()
const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const EctCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

EctCnfArg: reflects arguments of signal MN_ECT_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EctCnfArg::EctCnfArg ( )

Member Function Documentation

const EctCnfArg & EctCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& EctCnfArg::GetTipd ( ) const [inline]

void EctCnfArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:12:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EctIndicator Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EctIndicator Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for EctIndicator:

[legend]

Data Fields

EctCallState ect_callstate
Rdn rdn

Field Documentation

EctCallState EctIndicator::ect_callstate

Rdn EctIndicator::rdn

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:12:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditBox Class Reference

Obsolete - use MultiLineEditor or LineEditor from Gui instead. More...

#include <Apoxi/Compat/EditBox.hpp>

Inheritance diagram for EditBox:

[legend]
Collaboration diagram for EditBox:

[legend]

Public Types

typedef AbstractEditBox | Base
enum | DeleteMode { DelLeftCharMode, DelCurrCharMode }
enum EditMode {
AlphanumMode, AlphanumNameMode, NumericMode, PhoneNumberMode,
PredInputMode
}
enum | ShiftState { OffShiftstate, OnShiftstate, LockedShiftstate }

Public Member Functions

EditBox (Control *parent, WCHAR *text=0, INT max_text_len=0, EditMode edit_mode=AlphanumMode, const WCHAR *caption=0, CaptionPos caption_pos=CaptionOnTop)
EditBox ()
DeleteMode | GetDeleteMode () const
EditMode | GetEditMode () const
void | Init (Control *parent, WCHAR *text=0, INT max_text_len=0, EditMode edit_mode=AlphanumMode, const WCHAR *caption=0, CaptionPos caption_pos=CaptionOnTop)
void | SetDeleteMode (DeleteMode delete_mode)
void | SetEditMode (EditMode edit_mode)
virtual | ~EditBox ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual const AbstractEditBoxView * | GetView () const
virtual void | MoveCursor (INT inc)
virtual void | OnDeleteChar ()
virtual void | OnDtmfSeparator ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLoseFocus ()
virtual void | OnPagingTimer ()
Is called, if the timer for paging expired.
virtual void | OnPlus ()
Is called, if the key for the plus character has been pressed for a long time.
virtual void | OnShiftKey ()
Is called, if the shift key is pressed.
virtual void | OnWildcard ()

Friends

class | EditBoxPagingTimer

Detailed Description

Obsolete - use MultiLineEditor or LineEditor from Gui instead.

Member Typedef Documentation

typedef AbstractEditBox EditBox::Base

Reimplemented from AbstractEditBox.

Member Enumeration Documentation

enum EditBox::DeleteMode

Enumerator:
DelLeftCharMode | Pressing on the delete-key results in a deleting the character left from the cursor and moving the cursor left one character.
DelCurrCharMode | Pressing on the delete-key results in deleting the character below the cursor.

enum EditBox::EditMode

Enumerator:
AlphanumMode | All characters are possible for input.
AlphanumNameMode | AlphanumMode with automatic upper-case letters after a space character.
NumericMode | Characters from 0 to 9 allowed.
PhoneNumberMode | Characters from 0 to 9, #, + and ? allowed.
PredInputMode

enum EditBox::ShiftState

Enumerator:
OffShiftstate
OnShiftstate
LockedShiftstate

Constructor & Destructor Documentation

EditBox::EditBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

EditBox::EditBox | ( | Control * | parent,
 |  | WCHAR * | text = 0,
 |  | INT | max_text_len = 0,
 |  | EditMode | edit_mode = AlphanumMode,
 |  | const WCHAR * | caption = 0,
 |  | CaptionPos | caption_pos = CaptionOnTop
 | ) |

Parameters:
parent | Pointer the window, which embedds the editor.
text | Pointer to the text to edit.
max_text_len | Maximal length of the text to edit (Attention: include the terminal zero).
edit_mode | See EditMode.
caption | Pointer to the caption.
caption_pos | See CaptionPosType.

EditBox::~EditBox ( ) [virtual]

Member Function Documentation

Model * EditBox::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

DeleteMode EditBox::GetDeleteMode ( ) const [inline]

EditMode EditBox::GetEditMode ( ) const [inline]

const AbstractEditBoxView * EditBox::GetView ( ) const [protected, virtual]

See also:
AbstractEditBox::GetView

Implements AbstractEditBox.

void EditBox::Init | ( | Control * | parent,
 |  | WCHAR * | text = 0,
 |  | INT | max_text_len = 0,
 |  | EditMode | edit_mode = AlphanumMode,
 |  | const WCHAR * | caption = 0,
 |  | CaptionPos | caption_pos = CaptionOnTop
 | ) |

Parameters:
parent | Pointer the window, which embedds the editor.
text | Pointer to the text to edit.
max_text_len | Maximal length of the text to edit (Attention: include the terminal zero).
edit_mode | See EditMode.
caption | Pointer to the caption.
caption_pos | See CaptionPosType.

void EditBox::MoveCursor ( INT inc ) [protected, virtual]

See also:
AbstractEditBox::MoveCursor

Reimplemented from AbstractEditBox.

void EditBox::OnDeleteChar ( ) [protected, virtual]

See also:
AbstractEditBox::OnDeleteChar

Reimplemented from AbstractEditBox.

void EditBox::OnDtmfSeparator ( ) [protected, virtual]

Is called, if the key for the DTMF separator has been pressed for a long time. The character can be defined in EditConfig.

void EditBox::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from AbstractEditBox.

BOOLEAN EditBox::OnInputMap ( const InputMapItem & input_map_item ) [protected, virtual]

See also:
Control::OnInputMap

Reimplemented from AbstractEditBox.

BOOLEAN EditBox::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from Control.

void EditBox::OnLoseFocus ( ) [protected, virtual]

See also:
Control::OnLoseFocus

Reimplemented from AbstractEditBox.

void EditBox::OnPagingTimer ( ) [protected, virtual]

Is called, if the timer for paging expired.

void EditBox::OnPlus ( ) [protected, virtual]

Is called, if the key for the plus character has been pressed for a long time.

void EditBox::OnShiftKey ( ) [protected, virtual]

Is called, if the shift key is pressed.

void EditBox::OnWildcard ( ) [protected, virtual]

Is called, if the key for the wildcard character has been pressed for a long time. The character can be defined in EditConfig.

void EditBox::SetDeleteMode ( DeleteMode delete_mode ) [inline]

void EditBox::SetEditMode ( EditMode edit_mode )

Friends And Related Function Documentation

friend class EditBoxPagingTimer [friend]

The documentation for this class was generated from the following files:
  • Compat/EditBox.hpp
  • Compat/EditBox.cpp
Generated on Wed Jan 25 01:12:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditBoxBlinkTimer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditBoxBlinkTimer Class Reference

#include <Apoxi/Compat/AbstractEditBox.hpp>

Inheritance diagram for EditBoxBlinkTimer:

[legend]
Collaboration diagram for EditBoxBlinkTimer:

[legend]

Public Types

typedef Timer | Base

Public Member Functions

EditBoxBlinkTimer ()
void | SetEditBox (AbstractEditBox *edit_box)

Protected Member Functions

virtual void | OnTimer ()

Member Typedef Documentation

typedef Timer EditBoxBlinkTimer::Base

Reimplemented from Linkable< Timer >.

Constructor & Destructor Documentation

EditBoxBlinkTimer::EditBoxBlinkTimer ( )

Member Function Documentation

void EditBoxBlinkTimer::OnTimer ( ) [protected, virtual]

Is called, if the timout-value of the timer expired. In the default implementation of this method the message TimerTimeoutMsg is sent.

Reimplemented from Timer.

void EditBoxBlinkTimer::SetEditBox ( AbstractEditBox * edit_box ) [inline]

The documentation for this class was generated from the following files:
  • Compat/AbstractEditBox.hpp
  • Compat/AbstractEditBox.cpp
Generated on Wed Jan 25 01:12:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditBoxModel Class Reference

Describes the model of a date editbox. More...

#include <Apoxi/Compat/EditBox.hpp>

Inheritance diagram for EditBoxModel:

[legend]
Collaboration diagram for EditBoxModel:

[legend]

Detailed Description

Describes the model of a date editbox.

The documentation for this class was generated from the following file:
  • Compat/EditBox.hpp
Generated on Wed Jan 25 01:12:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditBoxPagingTimer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditBoxPagingTimer Class Reference

#include <Apoxi/Compat/EditBox.hpp>

Inheritance diagram for EditBoxPagingTimer:

[legend]
Collaboration diagram for EditBoxPagingTimer:

[legend]

Public Types

typedef Timer | Base

Public Member Functions

EditBoxPagingTimer ()
void | SetEditBox (EditBox *edit_box)

Protected Member Functions

virtual void | OnTimer ()

Member Typedef Documentation

typedef Timer EditBoxPagingTimer::Base

Reimplemented from Linkable< Timer >.

Constructor & Destructor Documentation

EditBoxPagingTimer::EditBoxPagingTimer ( )

Member Function Documentation

void EditBoxPagingTimer::OnTimer ( ) [protected, virtual]

Is called, if the timout-value of the timer expired. In the default implementation of this method the message TimerTimeoutMsg is sent.

Reimplemented from Timer.

void EditBoxPagingTimer::SetEditBox ( EditBox * edit_box ) [inline]

The documentation for this class was generated from the following files:
  • Compat/EditBox.hpp
  • Compat/EditBox.cpp
Generated on Wed Jan 25 01:12:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditBoxView Class Reference

Describes the view of a date editbox. More...

#include <Apoxi/Compat/EditBox.hpp>

Inheritance diagram for EditBoxView:

[legend]
Collaboration diagram for EditBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
EditBoxView (XYDIM line_height, XYDIM caption_gap, XYDIM caption_width, XYDIM caption_height, XYDIM frame_size, XYDIM default_width=-1, XYDIM default_height=-1)
EditBoxView ()
virtual | ~EditBoxView ()

Protected Member Functions

virtual void | DrawEditBox (const EditBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Detailed Description

Describes the view of a date editbox.

Constructor & Destructor Documentation

EditBoxView::EditBoxView ( )

EditBoxView::EditBoxView | ( | XYDIM | line_height,
 |  | XYDIM | caption_gap,
 |  | XYDIM | caption_width,
 |  | XYDIM | caption_height,
 |  | XYDIM | frame_size,
 |  | XYDIM | default_width = -1,
 |  | XYDIM | default_height = -1
 | ) |

EditBoxView::~EditBoxView ( ) [virtual]

Member Function Documentation

void EditBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void EditBoxView::DrawEditBox | ( | const EditBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a editbox described by the model.

Parameters:
model | Model describing the data of a editbox.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

The documentation for this class was generated from the following files:
  • Compat/EditBox.hpp
  • Compat/EditBox.cpp
Generated on Wed Jan 25 01:12:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditConfig Class Reference
[Config]

#include <EditConfig.hpp>

Collaboration diagram for EditConfig:

[legend]

Static Public Member Functions

static InputMapper * | AllocInputMapper (INT input_mapper_id)
static UINT32 | GetBlinkRate ()
Defines the blinking rate of the cursor in milliseconds.
static WCHAR | GetDtmfSeparator ()
Returns character which should be used as DTMF seperator.
static UINT32 | GetPagingTimeout ()
Defines the preferred paging timeout for multitap input mappers.
static WCHAR | GetWildcard ()
Returns the character which should be used as wildcard.

Detailed Description

Allows accessing the editor configuration. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static InputMapper* EditConfig::AllocInputMapper ( INT input_mapper_id ) [static]

Allocates a new instance of an InputMapper with the id input_mapper_id. If the input_mapper_id is not supported or the allocation has failed, 0 is returned.

static UINT32 EditConfig::GetBlinkRate ( ) [static]

Defines the blinking rate of the cursor in milliseconds.

static WCHAR EditConfig::GetDtmfSeparator ( ) [static]

Returns character which should be used as DTMF seperator.

static UINT32 EditConfig::GetPagingTimeout ( ) [static]

Defines the preferred paging timeout for multitap input mappers.

static WCHAR EditConfig::GetWildcard ( ) [static]

Returns the character which should be used as wildcard.

The documentation for this class was generated from the following file:
  • EditConfig.hpp
Generated on Wed Jan 25 01:12:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditLine Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditLine Class Reference

#include <Apoxi/Compat/AbstractEditBox.hpp>

Public Member Functions

EditLine ()
INT | GetIndex () const
INT | GetLength () const
void | SetIndex (INT index)
void | SetLength (INT length)

Constructor & Destructor Documentation

EditLine::EditLine ( )

Member Function Documentation

INT EditLine::GetIndex ( ) const [inline]

INT EditLine::GetLength ( ) const [inline]

void EditLine::SetIndex ( INT index ) [inline]

void EditLine::SetLength ( INT length ) [inline]

The documentation for this class was generated from the following files:
  • Compat/AbstractEditBox.hpp
  • Compat/AbstractEditBox.cpp
Generated on Wed Jan 25 01:12:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditorDocument Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditorDocument Class Reference
[Editors]

#include <Apoxi/Gui/EditorDocument.hpp>

Inheritance diagram for EditorDocument:

[legend]
Collaboration diagram for EditorDocument:

[legend]

Public Types

enum | LineAlignment { DefaultAlign, LeftAlign, CenteredAlign, RightAlign }
enum WrapPolicy {
WhitespaceWrap = 0, StrictWhitespaceWrap = 1, LeftJustifiedWrap = 2, CutWrap = 3,
CompactWrap = 4
}

Public Member Functions

virtual void | Clear ()
Clears the whole content of the document.
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT item_index, INT count) const =0
EditorDocument ()
InputMapper::Alphabet | GetAlphabet () const
virtual const CompoundItem & | GetCompoundItem (INT ci_index, INT *start_item_index=0) const =0
virtual INT | GetCompoundItemCount () const
virtual INT | GetItemCount () const =0
Returns the number of Items of the document.
virtual void | GetItemScope (INT item_index, INT count, INT sub_index, XYDIM *x, XYDIM *width) const
virtual LineAlignment | GetLineAlignment (INT item_index, INT count) const
virtual XYDIM | GetLineHeight (INT item_index, INT count, XYDIM *baseline=0) const =0
virtual XYDIM | GetLineWidth (INT item_index, INT count) const =0
virtual INT | GetMaxItemCount () const =0
const CompoundItem & | GetParentCompoundItem (INT item_index, INT *start_item_index=0) const
virtual BOOLEAN | InsertCompoundItem (CompoundItem *compound_item, INT ci_index=-1)
virtual BOOLEAN | InsertCompoundItemBeforeItem (CompoundItem *compound_item, INT item_index=-1)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT item_index=-1)=0
virtual BOOLEAN | IsEditableAfterLastItem () const
virtual BOOLEAN | IsRightToLeftItem (INT item_index) const
virtual void | OnChangedLayout (const Vector< EditorLine > &line, INT from=-1, INT count=0)
virtual BOOLEAN | RemoveCompoundItem (INT ci_index=-1)
virtual BOOLEAN | RemoveItem (INT item_index=-1)=0
Removes the Item with the index item_index.
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT item_index=-1)=0
void | SetAlphabet (InputMapper::Alphabet alphabet)
Sets the alphabet corresponding to 3GPP TS 23038 V430 (2001-09).
virtual INT | WrapLine (INT item_index, XYDIM width, WrapPolicy wrap_policy=WhitespaceWrap) const =0
virtual | ~EditorDocument ()

Detailed Description

Every editor has an Editor-Document, which contains one or more compound items. Every compound item may contain a variable number of Items (an Item is an instance of the class AtomItem), like e. g. characters or bitmaps). An Editor-Document has the property to be obtainable when beeing shared between several objects.
See also:
CompoundItem

AtomItem

Member Enumeration Documentation

enum EditorDocument::LineAlignment

Enumerator:
DefaultAlign | compound items are aligned corresponding to the used language (usually this means left-aligned).
LeftAlign | compound items are aligned left.
CenteredAlign | compound items are horizontally centered.
RightAlign | compound items are aligned right.

enum EditorDocument::WrapPolicy

Enumerator:
WhitespaceWrap | Wrapping is done on white-spaces. If there is no whitespace before the wrapping edge, the word might get splitted. The wrapping is done in a way, that every character is fully visible at the end of a line. WhitespaceWrap is the default wrapping method when editing texts.
StrictWhitespaceWrap | Behaves the same as WhitespaceWrap, but the wrapping is done strictly on whitespaces and hence no word is splitted.
LeftJustifiedWrap | Wrapping is done on white-spaces. In opposite to WhitespaceWrap white spaces at the end of a line may be clipped. Hence no line starts with a white-space and leads to a left-justified layout. LeftJustifiedWrap is recommended for read-only documents. When using LeftJustifiedWrap for editing a text, than the situation is possible that the caret disappears out of the visible area when adding a lot of whitespaces.
CutWrap | Wrapping is done after the first partly visible character at the end of a line.
CompactWrap | The wrapping is done in a way that no character will get clipped at the end of a line. No differentiation is done between whitespaces and other characters. This leads to a very compact layout for e. g. small areas, but usually leads to cutted words.

Constructor & Destructor Documentation

EditorDocument::EditorDocument ( )

EditorDocument::~EditorDocument ( ) [virtual]

Member Function Documentation

void EditorDocument::Clear ( ) [virtual]

Clears the whole content of the document.

Reimplemented in MultiMediaEditorDocument, and TextEditorDocument.

virtual void EditorDocument::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | item_index,
 |  | INT | count
 | ) | const [pure virtual]

Parameters:
dc | Device-Context for drawing.
x | x-position in pixels.
y | y-position in pixels.
item_index | Index of item, where the drawing should start.
count | Number of items counted from index which should be drawn.

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

InputMapper::Alphabet EditorDocument::GetAlphabet ( ) const [inline]

Returns:
Used alphabet corresponding to 3GPP TS 23038 V430 (2001-09).

virtual const CompoundItem& EditorDocument::GetCompoundItem | ( | INT | ci_index,
 |  | INT * | start_item_index = 0
 | ) | const [pure virtual]

Returns the compound item with the index ci_index.

Parameters:
ci_index | Index of the compound item (the number of available compound items can be retrieved by GetCompoundItemCount()).
start_item_index | Output parameter, which contains the index of the first Item of the compound item compared to all items of the document.
Returns:
compound item with the given index.

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

INT EditorDocument::GetCompoundItemCount ( ) const [virtual]

Returns the number of compound items of the document. Every document contains at least one compound item (= 1 is the default return-value).

Reimplemented in MultiMediaEditorDocument.

virtual INT EditorDocument::GetItemCount ( ) const [pure virtual]

Returns the number of Items of the document.

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

void EditorDocument::GetItemScope | ( | INT | item_index,
 |  | INT | count,
 |  | INT | sub_index,
 |  | XYDIM * | x,
 |  | XYDIM * | width
 | ) | const [virtual]

Returns the x-position and width of an item, which is part of the line specified by item_index and count. The default-implementation is suitable for documents, which don't contain a bidi-text inside the line.

Parameters:
item_index | Index of the item, where the line starts.
count | Number of items in the line.
sub_index | Index relative to item_index, which indicates the item.
x | Output parameter which contains the x-position of the item.
width | Output parameter which contains the width of the item.

Reimplemented in MultiMediaEditorDocument, and TextEditorDocument.

LineAlignment EditorDocument::GetLineAlignment | ( | INT | item_index,
 |  | INT | count
 | ) | const [virtual]

Parameters:
item_index | Index of the item, where the line starts.
count | Number of items in the line.
Returns:
Alignment of the line for count items starting at the item with the index item_index. Per default the value EditorDocument::DefaultAlign is returned.

Reimplemented in MultiMediaEditorDocument.

virtual XYDIM EditorDocument::GetLineHeight | ( | INT | item_index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [pure virtual]

Parameters:
item_index | Index of the item, where the line starts.
count | Number of items in the line.
baseline | Output parameter which contains the baseline, if the pointer is not zero.
Returns:
The needed height of a line for count items starting at the item with the index item_index.

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

virtual XYDIM EditorDocument::GetLineWidth | ( | INT | item_index,
 |  | INT | count
 | ) | const [pure virtual]

Parameters:
item_index | Index of the item, where the line starts.
count | Number of items in the line.
Returns:
The needed width of a line for count items starting at the item with the index item_index.

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

virtual INT EditorDocument::GetMaxItemCount ( ) const [pure virtual]

Returns the maximum number of Items which can be inserted into the document. -1 is returned, if there is no limit.

Implemented in MultiMediaEditorDocument, DateEditorDocument, IpAddrEditorDocument, TextEditorDocument, and TimeEditorDocument.

const CompoundItem & EditorDocument::GetParentCompoundItem | ( | INT | item_index,
 |  | INT * | start_item_index = 0
 | ) | const

Returns the parent compound item of the item with the index item_index.

Parameters:
item_index | Index of the item, which is part of the parent compound item.
start_item_index | Output parameter, which contains the index of the first item of the compound item compared to all items of the document.

BOOLEAN EditorDocument::InsertCompoundItem | ( | CompoundItem * | compound_item,
 |  | INT | ci_index = -1
 | ) | [virtual]

Inserts a compound item, which has to be created by CompoundItem::CreateInstance(), into the document. The document takes care about splitting, merging and deleting compound items by CompoundItem::ReleaseInstance(), hence the pointer to every passed compound item might be invalid after invoking InsertCompoundItem (e. g. when inserting the content of the compound item might be merged to the previous compound item and the inserted compound item will be deleted immediatly). Note that the default-implementation of the class EditorDocument does not allow to insert any kind of compound item. In this case FALSE is returned (= default return-value) and the compound item is deleted immediatly.

Parameters:
compound_item | Compound-item, which should be inserted.
ci_index | Index of the compound item, which will be the successor of the compound item compound_item. If the index is smaller than 0, the compound item will be appended at the end of the document.
Returns:
TRUE, if the insert-process has been successful.

Reimplemented in MultiMediaEditorDocument.

BOOLEAN EditorDocument::InsertCompoundItemBeforeItem | ( | CompoundItem * | compound_item,
 |  | INT | item_index = -1
 | ) | [virtual]

Inserts a compound item into the document. In opposite to InsertCompoundItem the compound item can be inserted before a variable item, not only before a compound item. The document takes care about splitting, merging and deleting compound items by CompoundItem::ReleaseInstance(), hence the pointer to every passed compound item might be invalid after invoking InsertCompoundItemBeforeItem (e. g. when inserting the content of the compound item might be merged to the previous compound item and the inserted compound item will be deleted immediatly). Note that the default-implementation of the class EditorDocument does not allow to insert any kind of compound item. In this case FALSE is returned (= default return-value) and the compound item is deleted immediatly.

Parameters:
compound_item | Compound item, which should be inserted.
item_index | Index of the item, which will be the successor of the compound item comp_item. If the index is smaller than 0, the compound item will be appended at the end of the compound item.
Returns:
TRUE, if the insert-process has been successful.

Reimplemented in MultiMediaEditorDocument.

virtual BOOLEAN EditorDocument::InsertItem | ( | const AtomItem & | item,
 |  | INT | item_index = -1
 | ) | [pure virtual]

Inserts the item item before the item with the index item_index. The document takes care to copy the item by either cloning it or copying its content into the corresponding compound item. Hence the Item may be allocated on the stack (e. g. EditorDocument::InsertItem(CharItem(L'A'), 5); is allowed).

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

BOOLEAN EditorDocument::IsEditableAfterLastItem ( ) const [virtual]

Returns:
TRUE, if editing after the last item of the document is allowed. Per default TRUE is returned.

Reimplemented in MultiMediaEditorDocument.

BOOLEAN EditorDocument::IsRightToLeftItem ( INT item_index ) const [virtual]

Returns TRUE, if the item with the index item_index should be treated as right-to-left-item (e. g. an arabic letter). The information might be useful for displaying the caret. Per default FALSE is returned.

Reimplemented in MultiMediaEditorDocument, and TextEditorDocument.

void EditorDocument::OnChangedLayout | ( | const Vector< EditorLine > & | line,
 |  | INT | from = -1,
 |  | INT | count = 0
 | ) | [virtual]

Reimplemented in MultiMediaEditorDocument.

BOOLEAN EditorDocument::RemoveCompoundItem ( INT ci_index = -1 ) [virtual]

Removes the compound item with the given index. Note that not all implementations of the class EditorDocument allow a variable number of compound items. Per default, FALSE is returned.

Parameters:
ci_index Index of the compound item, which should be removed. If the index is smaller than 0, the last compound item will be deleted.

Reimplemented in MultiMediaEditorDocument.

virtual BOOLEAN EditorDocument::RemoveItem ( INT item_index = -1 ) [pure virtual]

Removes the Item with the index item_index.

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

virtual BOOLEAN EditorDocument::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | item_index = -1
 | ) | [pure virtual]

Replaces the Item with the index item_index by the item item. The document takes care to copy the item by either cloning it or copying it's content into the corresponding compound item. Hence the Item may be allocated on the stack (e. g. EditorDocument::ReplaceItem(CharItem(L'A'), 5); is allowed).

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

void EditorDocument::SetAlphabet ( InputMapper::Alphabet alphabet ) [inline]

Sets the alphabet corresponding to 3GPP TS 23038 V430 (2001-09).

virtual INT EditorDocument::WrapLine | ( | INT | item_index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = WhitespaceWrap
 | ) | const [pure virtual]

Wraps the line starting from the index item_index into the available width width with the wrap policy wrap_policy and returns the number of items which fit into the available width.

Implemented in MultiMediaEditorDocument, DateEditorDocument, TextEditorDocument, and TimeEditorDocument.

The documentation for this class was generated from the following files:
  • Gui/EditorDocument.hpp
  • Gui/EditorDocument.cpp
Generated on Wed Jan 25 01:13:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditorDocumentObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditorDocumentObtainer Class Reference
[Editors]

#include <Apoxi/Gui/EditorDocument.hpp>

Inheritance diagram for EditorDocumentObtainer:

[legend]
Collaboration diagram for EditorDocumentObtainer:

[legend]

Public Member Functions

EditorDocumentObtainer (EditorDocument *doc, BOOLEAN disposeable)
EditorDocumentObtainer ()
const EditorDocument * | GetEditorDocument () const
EditorDocument * GetEditorDocument ()
virtual | ~EditorDocumentObtainer ()

Detailed Description

Obtains an instance of the class EditorDocument and destructs it when necessary. An editor document obtainer does a reference counting, hence when all editor document obtainers are destructed and the editor document obtainer has been initialized to obtain a disposable editor document, the editor document itself will get deleted too. If objects share one instance of the class EditorDocument, it is strongly recommended to use an editor document obtainer instead of a pointer to the editor document itself.

Constructor & Destructor Documentation

EditorDocumentObtainer::EditorDocumentObtainer ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

EditorDocumentObtainer::EditorDocumentObtainer | ( | EditorDocument * | doc,
 |  | BOOLEAN | disposeable
 | ) |

Parameters:
doc | Pointer to the editor document, which may be shared.
disposable | If set to TRUE, the editor document doc will get deleted automatically, when no editor document obtainer references this editor document anymore.

EditorDocumentObtainer::~EditorDocumentObtainer ( ) [virtual]

Member Function Documentation

const EditorDocument* EditorDocumentObtainer::GetEditorDocument ( ) const [inline]

EditorDocument* EditorDocumentObtainer::GetEditorDocument ( ) [inline]

The documentation for this class was generated from the following files:
  • Gui/EditorDocument.hpp
  • Gui/EditorDocument.cpp
Generated on Wed Jan 25 01:13:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditorItemNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditorItemNode Class Reference
[EMS]

#include <Applications/Ems/EmsIeParser.hpp>

Collaboration diagram for EditorItemNode:

[legend]

Public Types

enum ItemType {
DefaultTextFormattingIe, ParagraphItem, TextItem, AtomicItem,
InvalidItem
}

Public Member Functions

EditorItemNode ()
CompoundItem * GetCompoundItem ()
AtomItem * GetEditorItem ()
ItemType | GetItemType () const
INT | GetLength () const
INT | GetPosition () const
InformationElement GetTextFormattingElement ()
void | SetCompoundItem (CompoundItem *item)
void | SetEditorItem (AtomItem *item)
void | SetItemType (ItemType type)
void | SetLength (INT length)
void | SetPosition (INT pos)
void | SetTextFormatting (UINT8 mode, UINT8 colour)
~EditorItemNode ()

Member Enumeration Documentation

enum EditorItemNode::ItemType

Enumerator:
DefaultTextFormattingIe
ParagraphItem
TextItem
AtomicItem
InvalidItem

Constructor & Destructor Documentation

EditorItemNode::EditorItemNode ( )

EditorItemNode::~EditorItemNode ( )

Member Function Documentation

CompoundItem * EditorItemNode::GetCompoundItem ( )

AtomItem * EditorItemNode::GetEditorItem ( )

ItemType EditorItemNode::GetItemType ( ) const [inline]

INT EditorItemNode::GetLength ( ) const [inline]

INT EditorItemNode::GetPosition ( ) const [inline]

InformationElement EditorItemNode::GetTextFormattingElement ( )

void EditorItemNode::SetCompoundItem ( CompoundItem * item )

void EditorItemNode::SetEditorItem ( AtomItem * item )

void EditorItemNode::SetItemType ( ItemType type ) [inline]

void EditorItemNode::SetLength ( INT length ) [inline]

void EditorItemNode::SetPosition ( INT pos ) [inline]

void EditorItemNode::SetTextFormatting | ( | UINT8 | mode,
 |  | UINT8 | colour
 | ) |

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsIeParser.hpp
  • Applications/Ems/EmsIeParser.cpp
Generated on Wed Jan 25 01:13:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EditorLine Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EditorLine Class Reference
[Editors]

#include <Apoxi/Gui/EditorLine.hpp>

Public Member Functions

EditorLine (INT start_idx=0, INT length=0, XYDIM height=0)
XYDIM | GetHeight () const
INT | GetLength () const
INT | GetStartIndex () const
void | SetHeight (INT height)
void | SetLength (INT length)
void | SetStartIndex (INT start_idx)

Detailed Description

Internal class used by the editors for representing a line of an editor. The interface of this class might change in future APOXI releases and may not be used by the MMI in a direct manner.

Constructor & Destructor Documentation

EditorLine::EditorLine | ( | INT | start_idx = 0,
 |  | INT | length = 0,
 |  | XYDIM | height = 0
 | ) | [explicit]

Member Function Documentation

XYDIM EditorLine::GetHeight ( ) const [inline]

INT EditorLine::GetLength ( ) const [inline]

INT EditorLine::GetStartIndex ( ) const [inline]

void EditorLine::SetHeight ( INT height ) [inline]

void EditorLine::SetLength ( INT length ) [inline]

void EditorLine::SetStartIndex ( INT start_idx ) [inline]

The documentation for this class was generated from the following files:
  • Gui/EditorLine.hpp
  • Gui/EditorLine.cpp
Generated on Wed Jan 25 01:13:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ElementList< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ElementList< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/ElementList.hpp>

Inheritance diagram for ElementList< T >:

[legend]
Collaboration diagram for ElementList< T >:

[legend]

Public Member Functions

void | Append (const T &entry)
void | Append (T *entry)
Appends a copy of entry to the linked list.
BOOLEAN | AppendDistinct (const T &entry)
BOOLEAN | AppendDistinct (T *entry)
void | Clear ()
Clears the whole list and frees the memory of its elements.
ElementList (const ElementList< T > &list)
ElementList ()
BOOLEAN | Exists (const T &entry) const
BOOLEAN | Exists (T *entry) const
T * | GetAt (INT idx) const
Returns the pointer of the element of position idx in the list.
T * | GetFront () const
ElementList & | operator= (const ElementList< T > &list)
T & | operator[] (INT i)
const T & | operator[] (INT i) const
INT | Remove (const T &entry)
Returns the number of removed (matching) entries.
INT | Remove (T *entry)
Returns the number of removed (matching) entries.
virtual | ~ElementList ()

Detailed Description

template<class T>
class ElementList< T >

The ElementList is a linked list template, which manages the memory of its elements.

Member Function Documentation

template<class T>
void ElementList< T >::Append ( const T & entry ) [inline]

template<class T>
BOOLEAN ElementList< T >::AppendDistinct ( const T & entry ) [inline]

template<class T>
BOOLEAN ElementList< T >::Exists ( const T & entry ) const [inline]

template<class T>
T* ElementList< T >::GetAt ( INT idx ) const [inline]

Returns the pointer of the element of position idx in the list.

Reimplemented from ElementListBase.

Reimplemented in SortedElementList< T >, and SortedElementList< InputActionPtr >.

template<class T>
T* ElementList< T >::GetFront ( ) const [inline]

Returns a pointer to the first element of the linked list. The elements will not be removed from the list.

Reimplemented from LinkedListBase.

Reimplemented in SortedElementList< T >, and SortedElementList< InputActionPtr >.

template<class T>
T& ElementList< T >::operator[] ( INT i ) [inline]

Subscription operator returns the reference to the object on position i.

Reimplemented from ElementListBase.

template<class T>
const T& ElementList< T >::operator[] ( INT i ) const [inline]

Subscription operator returns the reference to the constant object on position i.

Reimplemented from ElementListBase.

template<class T>
INT ElementList< T >::Remove ( const T & entry ) [inline]

Returns the number of removed (matching) entries.

The documentation for this class was generated from the following file:
  • Auxiliary/ElementList.hpp
Generated on Wed Jan 25 01:13:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ElementListBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ElementListBase Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/ElementList.hpp>

Inheritance diagram for ElementListBase:

[legend]
Collaboration diagram for ElementListBase:

[legend]

Public Member Functions

ElementListBase ()
LinkableBase * | GetAt (INT idx) const
Returns the pointer of the element of position idx in the list.
LinkableBase & | operator[] (INT i)
const LinkableBase & | operator[] (INT i) const
virtual | ~ElementListBase ()

Constructor & Destructor Documentation

ElementListBase::ElementListBase ( )

ElementListBase::~ElementListBase ( ) [virtual]

Member Function Documentation

LinkableBase * ElementListBase::GetAt ( INT idx ) const

Returns the pointer of the element of position idx in the list.

Reimplemented in ElementList< T >, SortedElementList< T >, ElementList< MediaRefLinkable >, ElementList< InputActionPtr >, ElementList< Tpdu >, ElementList< DataCodingSchemeRange >, and SortedElementList< InputActionPtr >.

LinkableBase & ElementListBase::operator[] ( INT i )

Subscription operator returns the reference to the object on position i.

Reimplemented in ElementList< T >, ElementList< MediaRefLinkable >, ElementList< InputActionPtr >, ElementList< Tpdu >, and ElementList< DataCodingSchemeRange >.

const LinkableBase & ElementListBase::operator[] ( INT i ) const

Subscription operator returns the reference to the constant object on position i.

Reimplemented in ElementList< T >, ElementList< MediaRefLinkable >, ElementList< InputActionPtr >, ElementList< Tpdu >, and ElementList< DataCodingSchemeRange >.

The documentation for this class was generated from the following files:
  • Auxiliary/ElementList.hpp
  • Auxiliary/ElementList.cpp
Generated on Wed Jan 25 01:13:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: emcpp_apoxi_OBEXAdapter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

emcpp_apoxi_OBEXAdapter Class Reference

#include <Apoxi/AddOns/StreamObex/emcpp_apoxi_OBEXAdapter.hpp>

Collaboration diagram for emcpp_apoxi_OBEXAdapter:

[legend]

Public Member Functions

emcpp_apoxi_OBEXAdapter (StreamObexImpl &obex_implementation, const ObexChannel &obex_channel)
const ObexChannel & | obex_channel () const
StreamObexImpl & obex_implementation ()
const Private & | private_implementation () const
Private & | private_implementation ()
~emcpp_apoxi_OBEXAdapter ()

Constructor & Destructor Documentation

emcpp_apoxi_OBEXAdapter::emcpp_apoxi_OBEXAdapter | ( | StreamObexImpl & | obex_implementation,
 |  | const ObexChannel & | obex_channel
 | ) |

emcpp_apoxi_OBEXAdapter::~emcpp_apoxi_OBEXAdapter ( )

Member Function Documentation

const ObexChannel& emcpp_apoxi_OBEXAdapter::obex_channel ( ) const [inline]

StreamObexImpl& emcpp_apoxi_OBEXAdapter::obex_implementation ( ) [inline]

const Private& emcpp_apoxi_OBEXAdapter::private_implementation ( ) const [inline]

Private& emcpp_apoxi_OBEXAdapter::private_implementation ( ) [inline]

The documentation for this class was generated from the following file:
  • AddOns/StreamObex/emcpp_apoxi_OBEXAdapter.hpp
Generated on Wed Jan 25 01:13:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmlppAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmlppAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for EmlppAction:

[legend]
Collaboration diagram for EmlppAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
EmlppAction ()
virtual InputActionType | GetActionType () const
Returns the type of the action.
INT | GetPriority () const
Returns the priority code.
InputParser::SsCode | GetSsCode () const
Returns the ss code.
InputParser::SsProcedure | GetSsProcedure () const
Returns the procedure type.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual | ~EmlppAction ()

Detailed Description

EmlppAction analyzes if the input string has the meaning of interrogation or registration. Execute has to be overwritten to implement the sending of the SS string.

Constructor & Destructor Documentation

EmlppAction::EmlppAction ( )

EmlppAction::~EmlppAction ( ) [virtual]

Member Function Documentation

InputAction * EmlppAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType EmlppAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

INT EmlppAction::GetPriority ( ) const [inline]

Returns the priority code.

InputParser::SsCode EmlppAction::GetSsCode ( ) const [inline]

Returns the ss code.

InputParser::SsProcedure EmlppAction::GetSsProcedure ( ) const [inline]

Returns the procedure type.

BOOLEAN EmlppAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:13:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmlppHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmlppHandler Class Reference

#include <Apoxi/Asc/EmlppHandler.hpp>

Public Types

enum | { ID = EmlppHandlerId }

Public Member Functions

EmlppHandler ()
virtual HandlerId | GetHandlerId () const
SsApiRc | Register (EmlppPriorityLevel priority, const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE)
SsApiRc | RequestStatus (const WString &override_ss_seq=L"", BOOLEAN register_only=FALSE)
virtual | ~EmlppHandler ()

Detailed Description

The EmlppHandler is a SS handler responsible for modifying the eMlpp SS. This includes registering and interrogating the current status. The handler provides various methods for these purposes.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Constructor & Destructor Documentation

EmlppHandler::EmlppHandler ( )

EmlppHandler::~EmlppHandler ( ) [virtual]

Member Function Documentation

HandlerId EmlppHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
EmlppHandlerId

SsApiRc EmlppHandler::Register | ( | EmlppPriorityLevel | priority,
 |  | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE
 | ) |

Register priority for eMLPP.
Registers the default priority for mobile origintate calls. This method triggers sending of **75n# to the mobile network. The transaction is initiated using the main handler and the resulting tipd is stored along with the parameters.

Parameters:
priority | Priority to register at network for outgoing calls, only EmlppPriorityLevel0 to EmlppPriorityLevel4 may be used.
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return.
See also:
SsMainHandler

SsApiRc EmlppHandler::RequestStatus | ( | const WString & | override_ss_seq = L"",
 |  | BOOLEAN | register_only = FALSE
 | ) |

Interrogates the status of eMlpp.
This method triggers sending of *#75# to the mobile network. The transaction is initiated using the main handler and the resulting tipd is stored.

Parameters:
override_ss_seq | Supplementary Service request string to be sent to net, overrides handler generated request string.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::BeginTransaction might return.
See also:
SsMainHandler

The documentation for this class was generated from the following files:
  • Asc/EmlppHandler.hpp
  • Asc/EmlppHandler.cpp
Generated on Wed Jan 25 01:13:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmlppPriority Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmlppPriority Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

BOOLEAN in_use
EmlppPriorityLevel value

Field Documentation

BOOLEAN EmlppPriority::in_use

EmlppPriorityLevel EmlppPriority::value

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:13:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmlppRegisteredMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmlppRegisteredMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for EmlppRegisteredMsg:

[legend]
Collaboration diagram for EmlppRegisteredMsg:

[legend]

Public Types

enum | { ID = 18565 }

Public Member Functions

virtual Message * | Clone () const
EmlppRegisteredMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status, const EmlppPriorityLevel &default_priority)
const EmlppPriorityLevel & | GetDefaultPriority () const
virtual const MsgMetaData & | GetMetaData () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~EmlppRegisteredMsg ()

Detailed Description

EmlppRegisteredMsg: sent when new default priority was registered at network

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EmlppRegisteredMsg::EmlppRegisteredMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status,
 |  | const EmlppPriorityLevel & | default_priority
 | ) |

EmlppRegisteredMsg::~EmlppRegisteredMsg ( ) [virtual]

Member Function Documentation

Message * EmlppRegisteredMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const EmlppPriorityLevel& EmlppRegisteredMsg::GetDefaultPriority ( ) const [inline]

const MsgMetaData & EmlppRegisteredMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsStatus& EmlppRegisteredMsg::GetSsStatus ( ) const [inline]

const Tipd& EmlppRegisteredMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:13:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmlppStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmlppStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for EmlppStatusMsg:

[legend]
Collaboration diagram for EmlppStatusMsg:

[legend]

Public Types

enum | { ID = 18566 }

Public Member Functions

virtual Message * | Clone () const
EmlppStatusMsg (ExecutionContext *context, const Tipd &tipd, const SsStatus &ss_status, const EmlppPriorityLevel &default_priority, const EmlppPriorityLevel &max_entitled_priority)
const EmlppPriorityLevel & | GetDefaultPriority () const
const EmlppPriorityLevel & | GetMaxEntitledPriority () const
virtual const MsgMetaData & | GetMetaData () const
const SsStatus & | GetSsStatus () const
const Tipd & | GetTipd () const
virtual | ~EmlppStatusMsg ()

Detailed Description

EmlppStatusMsg: sent when Emlpp status was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EmlppStatusMsg::EmlppStatusMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsStatus & | ss_status,
 |  | const EmlppPriorityLevel & | default_priority,
 |  | const EmlppPriorityLevel & | max_entitled_priority
 | ) |

EmlppStatusMsg::~EmlppStatusMsg ( ) [virtual]

Member Function Documentation

Message * EmlppStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const EmlppPriorityLevel& EmlppStatusMsg::GetDefaultPriority ( ) const [inline]

const EmlppPriorityLevel& EmlppStatusMsg::GetMaxEntitledPriority ( ) const [inline]

const MsgMetaData & EmlppStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsStatus& EmlppStatusMsg::GetSsStatus ( ) const [inline]

const Tipd& EmlppStatusMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:13:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsApp Class Reference

#include <Applications/Ems/EmsApp.hpp>

Inheritance diagram for EmsApp:

[legend]
Collaboration diagram for EmsApp:

[legend]

Public Member Functions

virtual void | ForwardSms (Provider *provider, INT act_row)
virtual AbstractSmsComposeWin * | GetSmsComposer ()
virtual void | ReplySms (Provider *provider, INT act_row)
virtual | ~EmsApp ()

Static Public Member Functions

static EmsCreator * | GetEmsCreator ()
static EmsApp * | GetInstance ()

Protected Member Functions

virtual SmsFactory * | GetSmsFactory ()
virtual AbstractSmsViewerWin * | GetSmsViewer ()
virtual void | OnExportConfirmation (SmsExportType export_type, Sms::Result result_code, const SmsContext &profile, INT pending_segement_count=0)
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
Routed via Base class MmiApplication.
virtual void | OnOpen ()
virtual void | OnStartup ()
virtual void | SendImpl (const SmsContext &profile, const EditorDocumentObtainer &obtainer)
virtual void | SendToManyRecipient (SmsContext *profile, INT nCnt, const EditorDocumentObtainer &obtainer)
virtual void | StoreImpl (const SmsContext &profile, const EditorDocumentObtainer &obtainer)

Constructor & Destructor Documentation

EmsApp::~EmsApp ( ) [virtual]

Member Function Documentation

void EmsApp::ForwardSms | ( | Provider * | provider,
 |  | INT | act_row
 | ) | [virtual]

forward specified SMS

Parameters:
provider.
act_row,: row, in which the SMS located.

Reimplemented from AbstractSmsApp.

static EmsCreator* EmsApp::GetEmsCreator ( ) [inline, static]

EmsApp * EmsApp::GetInstance ( ) [static]

AbstractSmsComposeWin * EmsApp::GetSmsComposer ( ) [virtual]

virtual SmsFactory* EmsApp::GetSmsFactory ( ) [inline, protected, virtual]

AbstractSmsViewerWin * EmsApp::GetSmsViewer ( ) [protected, virtual]

void EmsApp::OnExportConfirmation | ( | SmsExportType | export_type,
 |  | Sms::Result | result_code,
 |  | const SmsContext & | profile,
 |  | INT | pending_segement_count = 0
 | ) | [protected, virtual]

BOOLEAN EmsApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

Routed via Base class MmiApplication.

Reimplemented from AbstractSmsApp.

void EmsApp::OnOpen ( ) [protected, virtual]

Reimplemented from AbstractSmsApp.

void EmsApp::OnStartup ( ) [protected, virtual]

Reimplemented from AbstractSmsApp.

void EmsApp::ReplySms | ( | Provider * | provider,
 |  | INT | act_row
 | ) | [virtual]

replies Sms

Parameters:
provider.
act_row,: row, in which the SMS located.

Reimplemented from AbstractSmsApp.

void EmsApp::SendImpl | ( | const SmsContext & | profile,
 |  | const EditorDocumentObtainer & | obtainer
 | ) | [protected, virtual]

Implements sending of an SMS. If a parameter is set to 0, the previously specified value should be used.

void EmsApp::SendToManyRecipient | ( | SmsContext * | profile,
 |  | INT | nCnt,
 |  | const EditorDocumentObtainer & | obtainer
 | ) | [protected, virtual]

void EmsApp::StoreImpl | ( | const SmsContext & | profile,
 |  | const EditorDocumentObtainer & | obtainer
 | ) | [protected, virtual]

Implements storing of an SMS. If a parameter is set to 0, the previously specified value should be used.

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsApp.hpp
  • Applications/Ems/EmsApp.cpp
Generated on Wed Jan 25 01:13:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsComposeWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsComposeWin Class Reference
[EMS]

#include <Applications/Ems/EmsComposeWin.hpp>

Inheritance diagram for EmsComposeWin:

[legend]
Collaboration diagram for EmsComposeWin:

[legend]

Public Member Functions

EmsComposeWin ()
virtual EditorDocumentObtainer | GetDocumentObtainer () const
EmsEditor * GetEditor ()
virtual AbstractPredictiveInputBox * | GetPredInputBox ()
virtual void | Init (EmsApp *ems_app)
void | InsertImage ()
void | InsertSound ()
virtual void | OnInputModeChanged (PredInputMapper::PredMode mode)
virtual void | RelaySms (Provider *provider, INT row, BOOLEAN reply=FALSE)
RelaySms is used to reply or forward the SMS.
virtual void | SetDocumentObtainer (const EditorDocumentObtainer &obtainer)
virtual | ~EmsComposeWin ()

Protected Member Functions

virtual void | OnDocumentChanged (const EditorDocument *doc)
virtual void | OnLayoutClient ()
virtual void | OpenModeless (const Rect &rect=Rect())

Constructor & Destructor Documentation

EmsComposeWin::EmsComposeWin ( )

EmsComposeWin::~EmsComposeWin ( ) [virtual]

Member Function Documentation

EditorDocumentObtainer EmsComposeWin::GetDocumentObtainer ( ) const [virtual]

Implements AbstractSmsComposeWin.

EmsEditor* EmsComposeWin::GetEditor ( ) [inline]

AbstractPredictiveInputBox * EmsComposeWin::GetPredInputBox ( ) [virtual]

Implements AbstractSmsComposeWin.

void EmsComposeWin::Init ( EmsApp * ems_app ) [virtual]

void EmsComposeWin::InsertImage ( )

void EmsComposeWin::InsertSound ( )

void EmsComposeWin::OnDocumentChanged ( const EditorDocument * doc ) [protected, virtual]

Implements EmsEditorListener.

void EmsComposeWin::OnInputModeChanged ( PredInputMapper::PredMode mode ) [virtual]

Is invoked, when the mode of the predictive input has been changed. This allows e. g. setting the corresponding font for Chinese input if needed.

Reimplemented from AbstractSmsComposeWin.

void EmsComposeWin::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Window.

void EmsComposeWin::OpenModeless ( const Rect & rect = Rect() ) [protected, virtual]

Opens the window modeless. This means that immediatly after the window has been opened the caller of this method may continue and the closing of the window is done in an asynchronous manner.

Parameters:
rect Specifies the size of the window (by default the window will be opened fullsized).

Reimplemented from Window.

void EmsComposeWin::RelaySms | ( | Provider * | provider,
 |  | INT | row,
 |  | BOOLEAN | reply = FALSE
 | ) | [virtual]

RelaySms is used to reply or forward the SMS.

Reimplemented from AbstractSmsComposeWin.

void EmsComposeWin::SetDocumentObtainer ( const EditorDocumentObtainer & obtainer ) [virtual]

Implements AbstractSmsComposeWin.

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsComposeWin.hpp
  • Applications/Ems/EmsComposeWin.cpp
Generated on Wed Jan 25 01:13:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsCreator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsCreator Class Reference
[EMS]

#include <Applications/Ems/EmsCreator.hpp>

Collaboration diagram for EmsCreator:

[legend]

Public Member Functions

BOOLEAN | CreateMessages (const EditorDocument &document, const SmsContext *context, SmsFactory *factory)
EmsCreator ()
SpaceInfo | GetSpaceInfo (const EditorDocument &document, const SmsContext *context)
~EmsCreator ()

Data Structures

struct | SpaceInfo

Constructor & Destructor Documentation

EmsCreator::EmsCreator ( )

EmsCreator::~EmsCreator ( )

Member Function Documentation

BOOLEAN EmsCreator::CreateMessages | ( | const EditorDocument & | document,
 |  | const SmsContext * | context,
 |  | SmsFactory * | factory
 | ) |

EmsCreator::SpaceInfo EmsCreator::GetSpaceInfo | ( | const EditorDocument & | document,
 |  | const SmsContext * | context
 | ) |

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsCreator.hpp
  • Applications/Ems/EmsCreator.cpp
Generated on Wed Jan 25 01:13:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsCreator::SpaceInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
EmsCreator::SpaceInfo

EmsCreator::SpaceInfo Struct Reference

#include <Applications/Ems/EmsCreator.hpp>

Data Fields

UINT8 | m_free_chars
Number of characters left in last segment.
UINT8 | m_pdu_count
Numbers of segments for one sms.

Field Documentation

UINT8 EmsCreator::SpaceInfo::m_free_chars

Number of characters left in last segment.

UINT8 EmsCreator::SpaceInfo::m_pdu_count

Numbers of segments for one sms.

The documentation for this struct was generated from the following file:
  • Applications/Ems/EmsCreator.hpp
Generated on Wed Jan 25 01:13:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsEditor Class Reference
[EMS]

#include <Applications/Ems/EmsEditor.hpp>

Inheritance diagram for EmsEditor:

[legend]
Collaboration diagram for EmsEditor:

[legend]

Public Member Functions

virtual BOOLEAN | Backspace ()
EmsEditor ()
EditorDocumentObtainer | GetObtainedDocument () const
void | Init (Control *parent, InputMapper::Id input_mapper_id)
virtual BOOLEAN | InsertCompoundItem (CompoundItem *compound_item, INT index=-1)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual void | OnItemMarked (const AbstractEditorItem *item)
virtual BOOLEAN | RemoveCompoundItem (INT index=-1)
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
void | SetEditorListener (EmsEditorListener *lstn)
void | SetObtainedDocument (EditorDocumentObtainer obtainer)
virtual void | StartTextFormatting (const TextFormat &format, const Color &text_color, const Color &bg_color)
virtual | ~EmsEditor ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual BOOLEAN | DestroyModel (Model *model)

Constructor & Destructor Documentation

EmsEditor::EmsEditor ( )

EmsEditor::~EmsEditor ( ) [virtual]

Member Function Documentation

BOOLEAN EmsEditor::Backspace ( ) [virtual]

See also:
AbstractEditor::Backspace()

Reimplemented from MultiMediaEditor.

Model * EmsEditor::CreateModel ( ) const [protected, virtual]

Factory method for creating a model. Must be implemented by every class, which needs it's own model. By default a component has no model and 0 is returned. If a model is dynamically created by 'new', it must be deleted in the destructor by e. g. delete GetModel();.

Returns:
Pointer to the model.

Reimplemented from MultiMediaEditor.

BOOLEAN EmsEditor::DestroyModel ( Model * model ) [protected, virtual]

Reimplemented from MultiMediaEditor.

EditorDocumentObtainer EmsEditor::GetObtainedDocument ( ) const

void EmsEditor::Init | ( | Control * | parent,
 |  | InputMapper::Id | input_mapper_id
 | ) |

BOOLEAN EmsEditor::InsertCompoundItem | ( | CompoundItem * | compound_item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::InsertCompoundItem()

Reimplemented from AbstractEditor.

BOOLEAN EmsEditor::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::InsertItem()

Reimplemented from MultiMediaEditor.

void EmsEditor::OnItemMarked ( const AbstractEditorItem * item ) [virtual]

Is invoked, in the read-only-mode, when an Abstract-Editor-Item is marked.

Parameters:
item Marked item (0, if no item is marked).

Reimplemented from MultiMediaEditor.

BOOLEAN EmsEditor::RemoveCompoundItem ( INT index = -1 ) [virtual]

See also:
AbstractEditor::RemoveCompoundItem

Reimplemented from AbstractEditor.

BOOLEAN EmsEditor::RemoveItem ( INT index = -1 ) [virtual]

See also:
AbstractEditor::RemoveItem()

Reimplemented from MultiMediaEditor.

BOOLEAN EmsEditor::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::ReplaceItem()

Reimplemented from MultiMediaEditor.

void EmsEditor::SetEditorListener ( EmsEditorListener * lstn ) [inline]

void EmsEditor::SetObtainedDocument ( EditorDocumentObtainer obtainer )

void EmsEditor::StartTextFormatting | ( | const TextFormat & | format,
 |  | const Color & | text_color,
 |  | const Color & | bg_color
 | ) | [virtual]

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsEditor.hpp
  • Applications/Ems/EmsEditor.cpp
Generated on Wed Jan 25 01:13:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsEditorListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsEditorListener Class Reference
[EMS]

#include <Applications/Ems/EmsEditorListener.hpp>

Inheritance diagram for EmsEditorListener:

[legend]

Public Member Functions

EmsEditorListener ()
virtual | ~EmsEditorListener ()

Protected Member Functions

virtual void | OnDocumentChanged (const EditorDocument *document)=0

Friends

class | EmsEditor

Constructor & Destructor Documentation

EmsEditorListener::EmsEditorListener ( )

EmsEditorListener::~EmsEditorListener ( ) [virtual]

Member Function Documentation

virtual void EmsEditorListener::OnDocumentChanged ( const EditorDocument * document ) [protected, pure virtual]

Implemented in EmsComposeWin.

Friends And Related Function Documentation

friend class EmsEditor [friend]

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsEditorListener.hpp
  • Applications/Ems/EmsEditorListener.cpp
Generated on Wed Jan 25 01:13:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmServThreadMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmServThreadMsg Class Reference

#include <Apoxi/AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.hpp>

Inheritance diagram for EmServThreadMsg:

[legend]
Collaboration diagram for EmServThreadMsg:

[legend]

Public Types

enum | { ID = 54002 }

Public Member Functions

virtual Message * | Clone () const
EmServThreadMsg (ExecutionContext *application, const tEmApxAudDeviceHdl &m_h_aud_device, const tCallbackFnPtr &m_cb_fn_ptr, void *m_cb_data, const EmApoxiBOOLEAN &m_is_audio_muted, const EmApoxiBOOLEAN &m_start_stop_audio)
void * | GetMCbData () const
const tCallbackFnPtr & | GetMCbFnPtr () const
virtual const MsgMetaData & | GetMetaData () const
const tEmApxAudDeviceHdl & | GetMHAudDevice () const
const EmApoxiBOOLEAN & | GetMIsAudioMuted () const
const EmApoxiBOOLEAN & | GetMStartStopAudio () const
void | SetMCbData (void *m_cb_data)
void | SetMCbFnPtr (const tCallbackFnPtr &m_cb_fn_ptr)
void | SetMHAudDevice (const tEmApxAudDeviceHdl &m_h_aud_device)
void | SetMIsAudioMuted (const EmApoxiBOOLEAN &m_is_audio_muted)
void | SetMStartStopAudio (const EmApoxiBOOLEAN &m_start_stop_audio)
virtual | ~EmServThreadMsg ()

Protected Member Functions

virtual void | Dump (OutputStream &ostr) const

Friends

OutputStream & | operator<< (OutputStream &ostr, const EmServThreadMsg &cls)
InputStream & | operator>> (InputStream &istr, EmServThreadMsg &cls)

Detailed Description

EmServThreadMsg MediaFramework Service Thread Message.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EmServThreadMsg::EmServThreadMsg | ( | ExecutionContext * | application,
 |  | const tEmApxAudDeviceHdl & | m_h_aud_device,
 |  | const tCallbackFnPtr & | m_cb_fn_ptr,
 |  | void * | m_cb_data,
 |  | const EmApoxiBOOLEAN & | m_is_audio_muted,
 |  | const EmApoxiBOOLEAN & | m_start_stop_audio
 | ) |

EmServThreadMsg::~EmServThreadMsg ( ) [virtual]

Member Function Documentation

Message * EmServThreadMsg::Clone ( ) const [virtual]

Implements Message.

void EmServThreadMsg::Dump ( OutputStream & ostr ) const [protected, virtual]

void* EmServThreadMsg::GetMCbData ( ) const [inline]

const tCallbackFnPtr& EmServThreadMsg::GetMCbFnPtr ( ) const [inline]

const MsgMetaData & EmServThreadMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const tEmApxAudDeviceHdl& EmServThreadMsg::GetMHAudDevice ( ) const [inline]

const EmApoxiBOOLEAN& EmServThreadMsg::GetMIsAudioMuted ( ) const [inline]

const EmApoxiBOOLEAN& EmServThreadMsg::GetMStartStopAudio ( ) const [inline]

void EmServThreadMsg::SetMCbData ( void * m_cb_data ) [inline]

void EmServThreadMsg::SetMCbFnPtr ( const tCallbackFnPtr & m_cb_fn_ptr ) [inline]

void EmServThreadMsg::SetMHAudDevice ( const tEmApxAudDeviceHdl & m_h_aud_device ) [inline]

void EmServThreadMsg::SetMIsAudioMuted ( const EmApoxiBOOLEAN & m_is_audio_muted ) [inline]

void EmServThreadMsg::SetMStartStopAudio ( const EmApoxiBOOLEAN & m_start_stop_audio ) [inline]

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const EmServThreadMsg & | cls
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | EmServThreadMsg & | cls
 | ) | [friend]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.hpp
  • AddOns/MediaFramework/ApoxiExtensions/EmServThreadMsg.cpp
Generated on Wed Jan 25 01:13:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsIeParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsIeParser Class Reference
[EMS]

#include <Applications/Ems/EmsIeParser.hpp>

Collaboration diagram for EmsIeParser:

[legend]

Public Member Functions

EmsIeParser ()
void | Parse (CompoundSmsItem *sms_item, EditorDocument &document, BOOLEAN append=FALSE, BOOLEAN mark_missing=TRUE)
virtual | ~EmsIeParser ()

Constructor & Destructor Documentation

EmsIeParser::EmsIeParser ( )

EmsIeParser::~EmsIeParser ( ) [virtual]

Member Function Documentation

void EmsIeParser::Parse | ( | CompoundSmsItem * | sms_item,
 |  | EditorDocument & | document,
 |  | BOOLEAN | append = FALSE,
 |  | BOOLEAN | mark_missing = TRUE
 | ) |

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsIeParser.hpp
  • Applications/Ems/EmsIeParser.cpp
Generated on Wed Jan 25 01:13:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsImage Class Reference
[EMS]

#include <Applications/Ems/EmsImage.hpp>

Inheritance diagram for EmsImage:

[legend]
Collaboration diagram for EmsImage:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT frame_idx, const Rect &clip_rect) const
EmsImage (XYDIM width, XYDIM height, UINT8 frames, BinData *data, UINT8 anim_control=0)
virtual const BinData * | GetBinData () const
Returns the image data in the ems specific format.
virtual UINT32 | GetFrameDelay (INT frame_idx) const
virtual INT | GetId () const
virtual INT | GetNextFrame (INT frame_idx) const
Returns the index of the frame wich follows the specified frame in frame_idx.
BinData * GetPlainData ()
Returns the image data in the ems specific format.
virtual | ~EmsImage ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Image.

Constructor & Destructor Documentation

EmsImage::EmsImage | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | UINT8 | frames,
 |  | BinData * | data,
 |  | UINT8 | anim_control = 0
 | ) |

EmsImage::~EmsImage ( ) [virtual]

Member Function Documentation

void EmsImage::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | frame_idx,
 |  | const Rect & | clip_rect
 | ) | const [virtual]

const BinData * EmsImage::GetBinData ( ) const [virtual]

Returns the image data in the ems specific format.

Reimplemented from Image.

UINT32 EmsImage::GetFrameDelay ( INT frame_idx ) const [virtual]

Returns the time in milliseconds the specified frame should be displayed. The value Image::c_unlimited means that it should be displayed _forever_.

Implements Image.

INT EmsImage::GetId ( ) const [virtual]

INT EmsImage::GetNextFrame ( INT frame_idx ) const [virtual]

Returns the index of the frame wich follows the specified frame in frame_idx.

Implements Image.

BinData* EmsImage::GetPlainData ( ) [inline]

Returns the image data in the ems specific format.

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsImage.hpp
  • Applications/Ems/EmsImage.cpp
Generated on Wed Jan 25 01:13:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsInsertPrompt Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsInsertPrompt Class Reference
[EMS]

#include <Applications/Ems/EmsInsertPrompt.hpp>

Collaboration diagram for EmsInsertPrompt:

[legend]

Public Types

enum | EmsInsertType { InsertImageType = 0, InsertSoundType = 1 }

Public Member Functions

EmsInsertPrompt ()
EmsInsertPrompt::EmsInsertType | GetSelectedType () const
void | Init ()
virtual | ~EmsInsertPrompt ()

Member Enumeration Documentation

enum EmsInsertPrompt::EmsInsertType

Enumerator:
InsertImageType
InsertSoundType

Constructor & Destructor Documentation

EmsInsertPrompt::EmsInsertPrompt ( )

EmsInsertPrompt::~EmsInsertPrompt ( ) [virtual]

Member Function Documentation

EmsInsertPrompt::EmsInsertType EmsInsertPrompt::GetSelectedType ( ) const

void EmsInsertPrompt::Init ( )

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsInsertPrompt.hpp
  • Applications/Ems/EmsInsertPrompt.cpp
Generated on Wed Jan 25 01:13:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsInsertPromptListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsInsertPromptListBoxModel Class Reference
[EMS]

#include <Applications/Ems/EmsInsertPrompt.hpp>

Public Member Functions

EmsInsertPromptListBoxModel ()
virtual const WCHAR * | GetCellText (INT index, BOOLEAN highlighted)
void | Init (DrawableObjectListBox *parent)
virtual | ~EmsInsertPromptListBoxModel ()

Constructor & Destructor Documentation

EmsInsertPromptListBoxModel::EmsInsertPromptListBoxModel ( )

EmsInsertPromptListBoxModel::~EmsInsertPromptListBoxModel ( ) [virtual]

Member Function Documentation

const WCHAR * EmsInsertPromptListBoxModel::GetCellText | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

void EmsInsertPromptListBoxModel::Init ( DrawableObjectListBox * parent )

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsInsertPrompt.hpp
  • Applications/Ems/EmsInsertPrompt.cpp
Generated on Wed Jan 25 01:13:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsResourceMaps Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsResourceMaps Class Reference
[EMS]

#include <Applications/Ems/EmsResourceMaps.hpp>

Collaboration diagram for EmsResourceMaps:

[legend]

Static Public Member Functions

static UINT8 | GetEmsColorCount ()
Returns the number of colors returned in GetEmsColors.
static const WCHAR ** | GetEmsColorNames ()
static const Color * | GetEmsColors ()
Returns an array containing all colors for ems.
static void | InitEmsColors ()
static AnimNode | MapAnimation (InformationElement::PredefinedAnimationType type)
Returns the animation for the value defined in 3GPP TS 23.040 V4.4.0 [9.2.3.24.10.3.3].
static const Font & | MapFont (InformationElement::FontSize size)
Returns the font for the given size.
static InformationElement::FontSize | MapFont (const Font &font)
Returns the font size of the given font.
static TextFormat::TextAlign | MapLineAlignment (EditorDocument::LineAlignment val)
static EditorDocument::LineAlignment | MapLineAlignment (TextFormat::TextAlign val)
static Audio::AudioToneId | MapSound (InformationElement::PredefinedSoundType type)
Returns the tone id of the audio device for the value defined in 3GPP TS 23.040 V4.4.0 [9.2.3.24.10.3.1].
static InformationElement::TextAlignment | MapTextAlignment (EditorDocument::LineAlignment val)
static EditorDocument::LineAlignment | MapTextAlignment (InformationElement::TextAlignment val)
static InformationElement::TextColour | MapTextColor (const Color &val)
Returns the defined value in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1] of the given color.
static const Color & | MapTextColor (InformationElement::TextColour val)
Returns the color of the defined value in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1].

Data Structures

struct | AnimNode

Member Function Documentation

UINT8 EmsResourceMaps::GetEmsColorCount ( ) [static]

Returns the number of colors returned in GetEmsColors.

const WCHAR ** EmsResourceMaps::GetEmsColorNames ( ) [static]

Returns an array of names of the ems colors. Names corresponds by the index to the colors. If names are not supported, 0 must be returned, otherwise an array of length GetEmsColorCount.

const Color * EmsResourceMaps::GetEmsColors ( ) [static]

Returns an array containing all colors for ems.

void EmsResourceMaps::InitEmsColors ( ) [static]

EmsResourceMaps::AnimNode EmsResourceMaps::MapAnimation ( InformationElement::PredefinedAnimationType type ) [static]

Returns the animation for the value defined in 3GPP TS 23.040 V4.4.0 [9.2.3.24.10.3.3].

const Font & EmsResourceMaps::MapFont ( InformationElement::FontSize size ) [static]

Returns the font for the given size.

InformationElement::FontSize EmsResourceMaps::MapFont ( const Font & font ) [static]

Returns the font size of the given font.

TextFormat::TextAlign EmsResourceMaps::MapLineAlignment ( EditorDocument::LineAlignment val ) [static]

EditorDocument::LineAlignment EmsResourceMaps::MapLineAlignment ( TextFormat::TextAlign val ) [static]

Audio::AudioToneId EmsResourceMaps::MapSound ( InformationElement::PredefinedSoundType type ) [static]

Returns the tone id of the audio device for the value defined in 3GPP TS 23.040 V4.4.0 [9.2.3.24.10.3.1].

InformationElement::TextAlignment EmsResourceMaps::MapTextAlignment ( EditorDocument::LineAlignment val ) [static]

EditorDocument::LineAlignment EmsResourceMaps::MapTextAlignment ( InformationElement::TextAlignment val ) [static]

InformationElement::TextColour EmsResourceMaps::MapTextColor ( const Color & val ) [static]

Returns the defined value in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1] of the given color.

const Color & EmsResourceMaps::MapTextColor ( InformationElement::TextColour val ) [static]

Returns the color of the defined value in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1].

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsResourceMaps.hpp
  • Applications/Ems/EmsResourceMaps.cpp
Generated on Wed Jan 25 01:13:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsResourceMaps::AnimNode Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
EmsResourceMaps::AnimNode

EmsResourceMaps::AnimNode Struct Reference

#include <Applications/Ems/EmsResourceMaps.hpp>

Collaboration diagram for EmsResourceMaps::AnimNode:

[legend]

Data Fields

const BitmapRes *const * | m_anim
UINT8 | m_frame_count

Field Documentation

const BitmapRes* const* EmsResourceMaps::AnimNode::m_anim

UINT8 EmsResourceMaps::AnimNode::m_frame_count

The documentation for this struct was generated from the following file:
  • Applications/Ems/EmsResourceMaps.hpp
Generated on Wed Jan 25 01:13:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmsViewerWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmsViewerWin Class Reference
[EMS]

#include <Applications/Ems/EmsViewerWin.hpp>

Inheritance diagram for EmsViewerWin:

[legend]
Collaboration diagram for EmsViewerWin:

[legend]

Public Member Functions

EmsViewerWin ()
virtual const EditorDocument * | GetDocument () const
void | Init (EmsApp *sms_app)
virtual void | SetDocument (const EditorDocument *doc)
virtual | ~EmsViewerWin ()

Protected Member Functions

virtual void | OnDisplaySms (Provider *provider, INT row)

Constructor & Destructor Documentation

EmsViewerWin::EmsViewerWin ( )

EmsViewerWin::~EmsViewerWin ( ) [virtual]

Member Function Documentation

const EditorDocument * EmsViewerWin::GetDocument ( ) const [virtual]

Implements AbstractSmsViewerWin.

void EmsViewerWin::Init ( EmsApp * sms_app )

void EmsViewerWin::OnDisplaySms | ( | Provider * | provider,
 |  | INT | row
 | ) | [protected, virtual]

void EmsViewerWin::SetDocument ( const EditorDocument * doc ) [virtual]

Implements AbstractSmsViewerWin.

The documentation for this class was generated from the following files:
  • Applications/Ems/EmsViewerWin.hpp
  • Applications/Ems/EmsViewerWin.cpp
Generated on Wed Jan 25 01:13:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzAacDecoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzAacDecoder Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.hpp>

Inheritance diagram for EmzAacDecoder:

[legend]
Collaboration diagram for EmzAacDecoder:

[legend]

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len, DecodingFunctionType &dec_fct)
virtual CodecManager::ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len, DecodingFunctionType &dec_fct)
virtual void | Close ()
virtual ResultType | DecodeBuffer (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual CodecManager::ResultType | DecodeBuffer (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual CodecManager::ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual CodecManager::ResultType | Flush ()
virtual CodecManager::ResultType | GetAudioStreamInfo (const UINT8 *config_stream, UINT32 &config_len, const CodecManager::AudioDecoderParameters &params, CodecManager::AudioStreamInfo &stream_info)
virtual ResultType | GetCapabilities (AudioCodecCapabilities &caps)
virtual CodecManager::ResultType | GetCapabilities (CodecManager::AudioCodecCapabilities &caps)
virtual ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual ResultType | GetProperties (Properties &properties)
virtual ResultType | Open ()
virtual ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded)
virtual CodecManager::ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded)
virtual CodecManager::ResultType | Reset ()
virtual ResultType | SetConfig (const UINT8 *config_stream, UINT32 &config_len, const AudioDecoderParameters &params, AudioStreamInfo &stream_info)
virtual ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual | ~EmzAacDecoder ()
virtual | ~EmzAacDecoder ()

Protected Member Functions

virtual ResultType | SetCodec (CodecType codec)

Friends

class | EmzAacDecoderThread
class | EmzCodecsLib

Data Structures

class | OperationInfo
class | OperationInfo
struct | StateFlags
struct | StateFlags

Detailed Description

Emuzed SW AAC audio decoder interface class

Constructor & Destructor Documentation

EmzAacDecoder::~EmzAacDecoder ( ) [virtual]

Destructor.

virtual EmzAacDecoder::~EmzAacDecoder ( ) [virtual]

Destructor.

Member Function Documentation

virtual ResultType EmzAacDecoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len,
 |  | DecodingFunctionType & | dec_fct
 | ) | [virtual]

Allocates a number of output buffers that are used to store the decoded frames. The array will be freed (deallocated) when using StopAudioDecoder.

Parameters:
out_buf_array | On return, a pointer to the output buffer array (the elements of the array are pointers to the actual buffers).
out_buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e. the AudioDecoder adapt the number passed in by the caller if necessary.
out_buf_len | On return, the actual buffer length, i.e. the AudioDecoder.
dec_fct | The caller informs the audio decoder about the function that it wants to be used for decoding (since the output buffers length and number depends on the decoding funtion). On return, contains the actually used value (e.g. if the desired decoding function is not supported).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
StopAudioDecoder

CodecDevice::ResultType EmzAacDecoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len,
 |  | DecodingFunctionType & | dec_fct
 | ) | [virtual]

See also:
AudioDecoder::AllocateOutputBuffers

void EmzAacDecoder::Close ( ) [virtual]

Closes and releases the audio decoder. This method should be invoked as soon as the audio decoder is not needed anymore to allow other audio decoders to access the resources.

See also:
Open

Implements AudioDecoder.

virtual ResultType EmzAacDecoder::DecodeBuffer | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

Decodes an audio buffer. The input buffer shall contain at least one complete frame. This function continues decoding until there is no complete frame in the input buffer or not enough space in the output buffer. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbFrameDecoded will be invoked. Note: In the callback function the number of consumed bytes (of the input buffer) will be returned.

Parameters:
in_buf | Pointer to the audio input buffer (containing the encoded frames).
in_buf_len | Length of the audio input buffer (in bytes).
out_buf | Pointer to the audio output buffer (containing the decoded frames).
out_buf_len | Length of the audio output buffer (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

Implements AudioDecoder.

CodecDevice::ResultType EmzAacDecoder::DecodeBuffer | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

See also:
AudioDecoder::DecodeBuffer

Implements AudioDecoder.

virtual ResultType EmzAacDecoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

Decodes an audio frame. The input buffer contains always one complete frame. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbFrameDecoded will be invoked. Note: In the callback function the number of consumed bytes (of the input buffer) will be returned.
DecodeBuffer shall be preferred to this function.

Parameters:
in_buf | Pointer to the audio input buffer (containing the encoded frame).
in_buf_len | Length of the audio input buffer (in bytes).
out_buf | Pointer to the audio output buffer (containing the decoded frame).
out_buf_len | Length of the audio output buffer (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

DecodeBuffer

Implements AudioDecoder.

CodecDevice::ResultType EmzAacDecoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

See also:
AudioDecoder::DecodeFrame

Implements AudioDecoder.

CodecManager::ResultType EmzAacDecoder::Flush ( ) [virtual]

See also:
AudioDecoder::Flush

CodecManager::ResultType EmzAacDecoder::GetAudioStreamInfo | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const CodecManager::AudioDecoderParameters & | params,
 |  | CodecManager::AudioStreamInfo & | stream_info
 | ) | [virtual]

See also:
AudioDecoder::GetAudioStreamInfo(

CodecDevice::ResultType EmzAacDecoder::GetCapabilities ( AudioCodecCapabilities & caps ) [virtual]

This function is used to retrieve the capabilities of the audio decoder (AudioDecoder sub-class).

Parameters:
caps On return, it contains the capabilities.
Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the AudioDecoder sub-class.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implements AudioDecoder.

CodecManager::ResultType EmzAacDecoder::GetCapabilities ( CodecManager::AudioCodecCapabilities & caps ) [virtual]

See also:
AudioDecoder::GetCapabilities

virtual ResultType EmzAacDecoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

This function retrieves the values of specified parameters in the audio decoder.

Parameters:
types_array | Array of the parameter types that specify the parameters to be retrieved.
values_array | On return, array of the retrieved parameter values. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type. The caller has to allocate memory for this array before invoking of this function. The existing elements of the array are then filled with the corresponding parameter values by the audio decoder.
array_count | Length (number of elements) of the types_array and types_array i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzAacDecoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
AudioDecoder::GetParameters

CodecDevice::ResultType EmzAacDecoder::GetProperties ( Properties & properties ) [virtual]

see CodecDevice::GetProperties

CodecDevice::ResultType EmzAacDecoder::Open ( ) [virtual]

Opens the audio decoder. In general, when a decoder is opened, it is reserved for the caller and cannot be used by another caller. Thus, as soon as the audio decoder is not needed anymore, it shall be released by using Close.

Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Close

Implements AudioDecoder.

virtual ResultType EmzAacDecoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded
 | ) | [virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the AudioDecoder. This context is then passed as an argument of all callback functions invoked by the AudioDecoder.
cb_frame_decoded | A pointer to a callback function that is invoked by the AudioDecoder when a frame has been decoded (and post-processed) and is ready for rendering.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzAacDecoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded
 | ) | [virtual]

See also:
AudioDecoder::RegisterCallbackFunctions

CodecManager::ResultType EmzAacDecoder::Reset ( ) [virtual]

See also:
AudioDecoder::Reset

CodecDevice::ResultType EmzAacDecoder::SetCodec ( CodecType codec ) [protected, virtual]

See also:
CodecDevice::SetCodec

CodecDevice::ResultType EmzAacDecoder::SetConfig | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const AudioDecoderParameters & | params,
 |  | AudioStreamInfo & | stream_info
 | ) | [virtual]

Configures the audio decoder.

Parameters:
config_stream | Pointer to the configuration stream for audio decoder.
config_len | Length of the configuration stream config_stream in number of bytes. On return it contains the number of bytes consumed.
params | Audio decoder parameters. The parameter audio_codec indicates the audio codec (if known to the caller) that shall be used for decoding. If the audio codec is not known to the caller, this parameter shall be set to UnknownCodec or DefaultCodec and the AudioDecoder sub-class shall find out the appropriate codec (if supported). The same applies if the passed audio codec is not valid.
stream_info | On return, it contains the encoded stream info.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implements AudioDecoder.

virtual ResultType EmzAacDecoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

Sets dynamically one or more decoder parameters.

Parameters:
types_array | Array of the parameter types that specify the parameters to be changed. The corresponding values to be set are delivered in values_array.
values_array | Array of the values to which the corresponding parameters have to be set. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type.
array_count | Length (number of elements) of the types_array and values_array, i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzAacDecoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
AudioDecoder::SetParameters

Friends And Related Function Documentation

EmzAacDecoderThread [friend]

EmzCodecsLib [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzAacDecoder.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoder.cpp
Generated on Wed Jan 25 01:13:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzAacDecoderThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzAacDecoderThread Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.hpp>

Inheritance diagram for EmzAacDecoderThread:

[legend]
Collaboration diagram for EmzAacDecoderThread:

[legend]

Public Member Functions

virtual INT | ThreadFn ()
virtual INT | ThreadFn ()

Friends

class | EmzAacDecoder

Detailed Description

AAC audio decoder interface (thread).

Member Function Documentation

virtual INT EmzAacDecoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

INT EmzAacDecoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

Friends And Related Function Documentation

EmzAacDecoder [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzAacDecoderThread.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzAacDecoderThread.cpp
Generated on Wed Jan 25 01:13:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzCodecsLib Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzCodecsLib Class Reference
[Config, Config]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.hpp>

Friends

class CodecConfig

Detailed Description

Emuzed Video Decoder & Encoder Interface Library class.

Friends And Related Function Documentation

CodecConfig [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzCodecsLib.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzCodecsLib.cpp
Generated on Wed Jan 25 01:13:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzH264Decoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzH264Decoder Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.hpp>

Inheritance diagram for EmzH264Decoder:

[legend]
Collaboration diagram for EmzH264Decoder:

[legend]

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual CodecManager::ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual ResultType | Close ()
virtual ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags, UINT32 time_stamp)
virtual CodecManager::ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual ResultType | DecodePacket (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual CodecManager::ResultType | DecodePacket (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual CodecManager::ResultType | Flush ()
virtual ResultType | FlushBuffers (CbResult cb_video_decoder_flushed, void *context)
virtual ResultType | GetCapabilities (VideoCodecCapabilities &caps)
virtual CodecManager::ResultType | GetCapabilities (CodecManager::VideoCodecCapabilities &caps)
virtual ResultType | GetCurrentVideoClockTime (UINT32 &time_ms)
virtual ResultType | GetNumberOfInitialDecodeOperations (UINT8 &operations)
virtual CodecManager::ResultType | GetNumberOfInitialDecodeOperations (UINT8 &operations)
virtual ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual ResultType | GetProperties (Properties &properties)
virtual ResultType | NotifyOutputBufferReleased (const UINT8 HUGE *out_buf)
virtual CodecManager::ResultType | NotifyOutputBufferReleased (const UINT8 HUGE *out_buf)
virtual ResultType | Open (VideoDecoderInfo &dec_info)
virtual ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded, CbInBufferFree cb_in_buf_free)
virtual CodecManager::ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded, CbInBufferFree cb_in_buf_free)
virtual ResultType | ReleaseOutputBuffer (const UINT8 HUGE *out_buf)
virtual CodecManager::ResultType | ReleaseOutputBuffer (const UINT8 HUGE *out_buf)
virtual ResultType | Reset ()
virtual CodecManager::ResultType | Reset ()
virtual ResultType | SetAssociatedAudioCh (UINT32 audio_channel)
virtual ResultType | SetConfig (const UINT8 *config_stream, UINT32 &config_len, const VideoDecoderParameters &params, VideoStreamInfo &stream_info)
virtual ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual ResultType | SetVideoClockTime (UINT32 time_ms)
virtual ResultType | Start (CbResultAndTimeInfo cb_video_decoder_started, void *context)
virtual ResultType | Stop (CbResult cb_video_decoder_stopped, void *context)
virtual | ~EmzH264Decoder ()
virtual | ~EmzH264Decoder ()

Protected Member Functions

virtual ResultType | SetCodec (CodecType codec)

Friends

class | EmzCodecsLib
class | EmzH264DecoderThread

Data Structures

class | OperationInfo
class | OperationInfo
struct | StateFlags
struct | StateFlags

Detailed Description

H.264 video decoder device (interface).

Constructor & Destructor Documentation

EmzH264Decoder::~EmzH264Decoder ( ) [virtual]

Destructor.

virtual EmzH264Decoder::~EmzH264Decoder ( ) [virtual]

Destructor.

Member Function Documentation

virtual ResultType EmzH264Decoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

Allocates a number of output buffers that are used to store the decoded (and post-processed) frames.

Parameters:
out_buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e. the EmzH264Decoder can adapt the number passed in by the caller if necessary.
out_buf_len | Desired length (in bytes) of one output buffer (all buffers have the same length). If set to 0, the default length will be used. On return, the actual buffer length, i.e. the EmzH264Decoder can adapt the length passed in by the caller if necessary.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoDecoder::AllocateOutputBuffers

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::Close ( ) [virtual]

See also:
VideoDecoder::Close

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags,
 |  | UINT32 | time_stamp
 | ) | [virtual]

Decodes a video frame. The input buffer contains always one complete frame. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbVideoFrameDecoded will be invoked.

Parameters:
in_buf | Pointer to the video input buffer (containing the encoded frame).
in_buf_len | Length of the video input buffer (in bytes).
flags | Bit flags as defined by the FlagsType enum indicating if it is the last frame in the stream/file.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

Implements VideoDecoder.

CodecManager::ResultType EmzH264Decoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

See also:
VideoDecoder::DecodeFrame

virtual ResultType EmzH264Decoder::DecodePacket | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

Decodes a video packet. Contains one or more packet but the packets are always complete. The actual decoding is done asynchronously, i.e., when a complete frame has been decoded, the callback function CbVideoFrameDecoded will be invoked.

Parameters:
in_buf | Pointer to the video input buffer (containing the encoded packets)
in_buf_len | Length of the video input buffer (in bytes).
flags | Bit flags as defined by the FlagsType enum. It indicates if it is the last packet in the frame and if it is the last frame.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::DecodePacket | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

See also:
VideoDecoder::DecodePacket

Implements VideoDecoder.

CodecManager::ResultType EmzH264Decoder::Flush ( ) [virtual]

See also:
VideoDecoder::Flush

CodecDevice::ResultType EmzH264Decoder::FlushBuffers | ( | CbResult | cb_video_decoder_flushed,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::FlushBuffers

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::GetCapabilities ( VideoCodecCapabilities & caps ) [virtual]

This function is used to retrieve the capabilities of the video decoder (VideoDecoder sub-class).

Parameters:
caps On return, it contains the capabilities. Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the VideoDecoder sub-class.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implements VideoDecoder.

CodecManager::ResultType EmzH264Decoder::GetCapabilities ( CodecManager::VideoCodecCapabilities & caps ) [virtual]

See also:
VideoDecoder::GetCapabilities

CodecDevice::ResultType EmzH264Decoder::GetCurrentVideoClockTime ( UINT32 & time_ms ) [virtual]

See also:
VideoDecoder::GetCurrentVideoClockTime

Implements VideoDecoder.

virtual ResultType EmzH264Decoder::GetNumberOfInitialDecodeOperations ( UINT8 & operations ) [virtual]

Gets the number of recommended (preferred) initial DecodeFrame calls for stuffing the decoder.

Parameters:
operations On return, the recommended number.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzH264Decoder::GetNumberOfInitialDecodeOperations ( UINT8 & operations ) [virtual]

See also:
VideoDecoder::GetNumberOfInitialDecodeOperations

virtual ResultType EmzH264Decoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

This function retrieves the values of specified parameters in the video decoder.

Parameters:
types_array | Array of the parameter types that specify the parameters to be retrieved.
values_array | On return, array of the retrieved parameter values. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type. The caller has to allocate memory for this array before invoking of this function. The existing elements of the array are then filled with the corresponding parameter values by the video decoder.
array_count | Length (number of elements) of the types_array and types_array i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzH264Decoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
VideoDecoder::GetParameters

CodecDevice::ResultType EmzH264Decoder::GetProperties ( Properties & properties ) [virtual]

see CodecDevice::GetProperties

virtual ResultType EmzH264Decoder::NotifyOutputBufferReleased ( const UINT8 HUGE * out_buf ) [virtual]

This function is used to notify the decoder that the specified decoder output buffer has been released (by some other entity) and can be re-used by the decoder. In general, this function is called by the client application when the buffer has been rendered and automatically released by the renderer (VideoChannel device).

Parameters:
out_buf Pointer to the video output buffer that has been released.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
ReleaseOutputBuffer

CodecDevice::ResultType EmzH264Decoder::NotifyOutputBufferReleased ( const UINT8 HUGE * out_buf ) [virtual]

See also:
VideoDecoder::NotifyOutputBufferReleased

CodecDevice::ResultType EmzH264Decoder::Open ( VideoDecoderInfo & dec_info ) [virtual]

See also:
VideoDecoder::Open

Implements VideoDecoder.

virtual ResultType EmzH264Decoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded,
 |  | CbInBufferFree | cb_in_buf_free
 | ) | [virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the EmzH264Decoder. This context is then passed as an argument of all callback functions invoked by the EmzH264Decoder.
cb_frame_decoded | A pointer to a callback function that is invoked by the EmzH264Decoder when a frame has been decoded (and post-processed) and is ready for rendering.
cb_in_buf_free | A pointer to a callback function that is called by the EmzH264Decoder when a video input buffer is not used anymore by the decoder (as the data has been already decoded) and can be re-used.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzH264Decoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded,
 |  | CbInBufferFree | cb_in_buf_free
 | ) | [virtual]

See also:
VideoDecoder::RegisterCallbackFunctions

virtual ResultType EmzH264Decoder::ReleaseOutputBuffer ( const UINT8 HUGE * out_buf ) [virtual]

Releases the specified output buffer of the decoder and, thus, allows the decoder to fill it with new decoded (and post-processed) frames if available. In general, this function is called when the frame stored in the buffer shall not been rendered at all or it has been rendered but the buffer has not been released automatically.

Parameters:
out_buf Pointer to the video decoder output buffer that shall be released.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
NotifyOutputBufferReleased

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::ReleaseOutputBuffer ( const UINT8 HUGE * out_buf ) [virtual]

See also:
VideoDecoder::ReleaseOutputBuffer

Implements VideoDecoder.

virtual ResultType EmzH264Decoder::Reset ( ) [virtual]

See also:
VideoDecoder::Reset

CodecDevice::ResultType EmzH264Decoder::Reset ( ) [virtual]

See also:
VideoDecoder::Reset

CodecDevice::ResultType EmzH264Decoder::SetAssociatedAudioCh ( UINT32 audio_channel ) [virtual]

See also:
VideoDecoder::SetAssociatedAudioCh

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::SetCodec ( CodecType codec ) [protected, virtual]

See also:
CodecDevice::SetCodec

CodecDevice::ResultType EmzH264Decoder::SetConfig | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const VideoDecoderParameters & | params,
 |  | VideoStreamInfo & | stream_info
 | ) | [virtual]

See also:
VideoDecoder::SetConfig

Implements VideoDecoder.

virtual ResultType EmzH264Decoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

Sets dynamically one or more decoder parameters.

Parameters:
types_array | Array of the parameter types that specify the parameters to be changed. The corresponding values to be set are delivered in values_array.
values_array | Array of the values to which the corresponding parameters have to be set. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type.
array_count | Length (number of elements) of the types_array and values_array, i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzH264Decoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
VideoDecoder::SetParameters

CodecDevice::ResultType EmzH264Decoder::SetVideoClockTime ( UINT32 time_ms ) [virtual]

See also:
VideoDecoder::SetVideoClockTime

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::Start | ( | CbResultAndTimeInfo | cb_video_decoder_started,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::Start

Implements VideoDecoder.

CodecDevice::ResultType EmzH264Decoder::Stop | ( | CbResult | cb_video_decoder_stopped,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::Stop

Implements VideoDecoder.

Friends And Related Function Documentation

EmzCodecsLib [friend]

EmzH264DecoderThread [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzH264Decoder.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzH264Decoder.cpp
Generated on Wed Jan 25 01:13:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzH264DecoderThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzH264DecoderThread Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.hpp>

Inheritance diagram for EmzH264DecoderThread:

[legend]
Collaboration diagram for EmzH264DecoderThread:

[legend]

Public Member Functions

virtual INT | ThreadFn ()
virtual INT | ThreadFn ()

Friends

class | EmzH264Decoder

Detailed Description

H.264 video decoder device (interface) - thread class. In this thread the actual decoding is run.

Member Function Documentation

virtual INT EmzH264DecoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

INT EmzH264DecoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

Friends And Related Function Documentation

EmzH264Decoder [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzH264DecoderThread.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzH264DecoderThread.cpp
Generated on Wed Jan 25 01:13:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzMp3Decoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzMp3Decoder Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.hpp>

Inheritance diagram for EmzMp3Decoder:

[legend]
Collaboration diagram for EmzMp3Decoder:

[legend]

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len, DecodingFunctionType &dec_fct)
virtual CodecManager::ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len, DecodingFunctionType &dec_fct)
virtual void | Close ()
virtual ResultType | DecodeBuffer (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual CodecManager::ResultType | DecodeBuffer (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual CodecManager::ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual CodecManager::ResultType | Flush ()
virtual CodecManager::ResultType | GetAudioStreamInfo (const UINT8 *config_stream, UINT32 &config_len, const CodecManager::AudioDecoderParameters &params, CodecManager::AudioStreamInfo &stream_info)
virtual ResultType | GetCapabilities (AudioCodecCapabilities &caps)
virtual CodecManager::ResultType | GetCapabilities (CodecManager::AudioCodecCapabilities &caps)
virtual ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual ResultType | GetProperties (Properties &properties)
virtual ResultType | Open ()
virtual ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded)
virtual CodecManager::ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded)
virtual CodecManager::ResultType | Reset ()
virtual ResultType | SetConfig (const UINT8 *config_stream, UINT32 &config_len, const AudioDecoderParameters &params, AudioStreamInfo &stream_info)
virtual ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual | ~EmzMp3Decoder ()
virtual | ~EmzMp3Decoder ()

Protected Member Functions

virtual ResultType | SetCodec (CodecType codec)

Friends

class | EmzCodecsLib
class | EmzMp3DecoderThread

Data Structures

class | OperationInfo
class | OperationInfo
struct | StateFlags
struct | StateFlags

Detailed Description

Emuzed SW MP3 audio decoder interface class

Constructor & Destructor Documentation

EmzMp3Decoder::~EmzMp3Decoder ( ) [virtual]

Destructor.

virtual EmzMp3Decoder::~EmzMp3Decoder ( ) [virtual]

Destructor.

Member Function Documentation

virtual ResultType EmzMp3Decoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len,
 |  | DecodingFunctionType & | dec_fct
 | ) | [virtual]

Allocates a number of output buffers that are used to store the decoded frames. The array will be freed (deallocated) when using StopAudioDecoder.

Parameters:
out_buf_array | On return, a pointer to the output buffer array (the elements of the array are pointers to the actual buffers).
out_buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e. the AudioDecoder adapt the number passed in by the caller if necessary.
out_buf_len | On return, the actual buffer length, i.e. the AudioDecoder.
dec_fct | The caller informs the audio decoder about the function that it wants to be used for decoding (since the output buffers length and number depends on the decoding funtion). On return, contains the actually used value (e.g. if the desired decoding function is not supported).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
StopAudioDecoder

CodecDevice::ResultType EmzMp3Decoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len,
 |  | DecodingFunctionType & | dec_fct
 | ) | [virtual]

See also:
AudioDecoder::AllocateOutputBuffers

void EmzMp3Decoder::Close ( ) [virtual]

Closes and releases the audio decoder. This method should be invoked as soon as the audio decoder is not needed anymore to allow other audio decoders to access the resources.

See also:
Open

Implements AudioDecoder.

virtual ResultType EmzMp3Decoder::DecodeBuffer | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

Decodes an audio buffer. The input buffer shall contain at least one complete frame. This function continues decoding until there is no complete frame in the input buffer or not enough space in the output buffer. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbFrameDecoded will be invoked. Note: In the callback function the number of consumed bytes (of the input buffer) will be returned.

Parameters:
in_buf | Pointer to the audio input buffer (containing the encoded frames).
in_buf_len | Length of the audio input buffer (in bytes).
out_buf | Pointer to the audio output buffer (containing the decoded frames).
out_buf_len | Length of the audio output buffer (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

Implements AudioDecoder.

CodecDevice::ResultType EmzMp3Decoder::DecodeBuffer | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

See also:
AudioDecoder::DecodeBuffer

Implements AudioDecoder.

virtual ResultType EmzMp3Decoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

Decodes an audio frame. The input buffer contains always one complete frame. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbFrameDecoded will be invoked. Note: In the callback function the number of consumed bytes (of the input buffer) will be returned.
DecodeBuffer shall be preferred to this function.

Parameters:
in_buf | Pointer to the audio input buffer (containing the encoded frame).
in_buf_len | Length of the audio input buffer (in bytes).
out_buf | Pointer to the audio output buffer (containing the decoded frame).
out_buf_len | Length of the audio output buffer (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

DecodeBuffer

Implements AudioDecoder.

CodecDevice::ResultType EmzMp3Decoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

See also:
AudioDecoder::DecodeFrame

Implements AudioDecoder.

CodecManager::ResultType EmzMp3Decoder::Flush ( ) [virtual]

See also:
AudioDecoder::Flush

CodecManager::ResultType EmzMp3Decoder::GetAudioStreamInfo | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const CodecManager::AudioDecoderParameters & | params,
 |  | CodecManager::AudioStreamInfo & | stream_info
 | ) | [virtual]

See also:
AudioDecoder::GetAudioStreamInfo(

CodecDevice::ResultType EmzMp3Decoder::GetCapabilities ( AudioCodecCapabilities & caps ) [virtual]

This function is used to retrieve the capabilities of the audio decoder (AudioDecoder sub-class).

Parameters:
caps On return, it contains the capabilities.
Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the AudioDecoder sub-class.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implements AudioDecoder.

CodecManager::ResultType EmzMp3Decoder::GetCapabilities ( CodecManager::AudioCodecCapabilities & caps ) [virtual]

See also:
AudioDecoder::GetCapabilities

virtual ResultType EmzMp3Decoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

This function retrieves the values of specified parameters in the audio decoder.

Parameters:
types_array | Array of the parameter types that specify the parameters to be retrieved.
values_array | On return, array of the retrieved parameter values. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type. The caller has to allocate memory for this array before invoking of this function. The existing elements of the array are then filled with the corresponding parameter values by the audio decoder.
array_count | Length (number of elements) of the types_array and types_array i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzMp3Decoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
AudioDecoder::GetParameters

CodecDevice::ResultType EmzMp3Decoder::GetProperties ( Properties & properties ) [virtual]

see CodecDevice::GetProperties

CodecDevice::ResultType EmzMp3Decoder::Open ( ) [virtual]

Opens the audio decoder. In general, when a decoder is opened, it is reserved for the caller and cannot be used by another caller. Thus, as soon as the audio decoder is not needed anymore, it shall be released by using Close.

Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Close

Implements AudioDecoder.

virtual ResultType EmzMp3Decoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded
 | ) | [virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the AudioDecoder. This context is then passed as an argument of all callback functions invoked by the AudioDecoder.
cb_frame_decoded | A pointer to a callback function that is invoked by the AudioDecoder when a frame has been decoded (and post-processed) and is ready for rendering.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzMp3Decoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded
 | ) | [virtual]

See also:
AudioDecoder::RegisterCallbackFunctions

CodecManager::ResultType EmzMp3Decoder::Reset ( ) [virtual]

See also:
AudioDecoder::Reset

CodecDevice::ResultType EmzMp3Decoder::SetCodec ( CodecType codec ) [protected, virtual]

See also:
CodecDevice::SetCodec

CodecDevice::ResultType EmzMp3Decoder::SetConfig | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const AudioDecoderParameters & | params,
 |  | AudioStreamInfo & | stream_info
 | ) | [virtual]

Configures the audio decoder.

Parameters:
config_stream | Pointer to the configuration stream for audio decoder.
config_len | Length of the configuration stream config_stream in number of bytes. On return it contains the number of bytes consumed.
params | Audio decoder parameters. The parameter audio_codec indicates the audio codec (if known to the caller) that shall be used for decoding. If the audio codec is not known to the caller, this parameter shall be set to CodecManager::UnknownCodec or CodecManager::DefaultCodec and the AudioDecoder sub-class shall find out the appropriate codec (if supported). The same applies if the passed audio codec is not valid.
stream_info | On return, it contains the encoded stream info.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implements AudioDecoder.

virtual ResultType EmzMp3Decoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

Sets dynamically one or more decoder parameters.

Parameters:
types_array | Array of the parameter types that specify the parameters to be changed. The corresponding values to be set are delivered in values_array.
values_array | Array of the values to which the corresponding parameters have to be set. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type.
array_count | Length (number of elements) of the types_array and values_array, i.e., both arrays have always the same length.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

CodecDevice::ResultType EmzMp3Decoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
AudioDecoder::SetParameters

Friends And Related Function Documentation

EmzCodecsLib [friend]

EmzMp3DecoderThread [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzMp3Decoder.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMp3Decoder.cpp
Generated on Wed Jan 25 01:13:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzMp3DecoderThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzMp3DecoderThread Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp>

Inheritance diagram for EmzMp3DecoderThread:

[legend]
Collaboration diagram for EmzMp3DecoderThread:

[legend]

Public Member Functions

virtual INT | ThreadFn ()
virtual INT | ThreadFn ()

Friends

class | EmzMp3Decoder

Detailed Description

MP3 audio decoder interface (thread).

Member Function Documentation

virtual INT EmzMp3DecoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

INT EmzMp3DecoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

Friends And Related Function Documentation

EmzMp3Decoder [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzMp3DecoderThread.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMp3DecoderThread.cpp
Generated on Wed Jan 25 01:13:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzMpeg4Decoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzMpeg4Decoder Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp>

Inheritance diagram for EmzMpeg4Decoder:

[legend]
Collaboration diagram for EmzMpeg4Decoder:

[legend]

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual CodecManager::ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual ResultType | Close ()
virtual ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags, UINT32 time_stamp)
virtual CodecManager::ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual ResultType | DecodePacket (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual CodecManager::ResultType | DecodePacket (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual CodecManager::ResultType | Flush ()
virtual ResultType | FlushBuffers (CbResult cb_video_decoder_flushed, void *context)
virtual ResultType | GetCapabilities (VideoCodecCapabilities &caps)
virtual CodecManager::ResultType | GetCapabilities (CodecManager::VideoCodecCapabilities &caps)
virtual ResultType | GetCurrentVideoClockTime (UINT32 &time_ms)
virtual CodecManager::ResultType | GetNumberOfInitialDecodeOperations (UINT8 &operations)
virtual CodecManager::ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual ResultType | GetProperties (Properties &properties)
virtual CodecManager::ResultType | NotifyOutputBufferReleased (const UINT8 HUGE *out_buf)
virtual ResultType | Open (VideoDecoderInfo &dec_info)
virtual ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded, CbInBufferFree cb_in_buf_free)
virtual CodecManager::ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded, CbInBufferFree cb_in_buf_free)
virtual ResultType | ReleaseOutputBuffer (const UINT8 HUGE *out_buf)
virtual CodecManager::ResultType | ReleaseOutputBuffer (const UINT8 HUGE *out_buf)
virtual CodecManager::ResultType | Reset ()
virtual ResultType | SetAssociatedAudioCh (UINT32 audio_channel)
virtual ResultType | SetConfig (const UINT8 *config_stream, UINT32 &config_len, const VideoDecoderParameters &params, VideoStreamInfo &stream_info)
virtual CodecManager::ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual ResultType | SetVideoClockTime (UINT32 time_ms)
virtual ResultType | Start (CbResultAndTimeInfo cb_video_decoder_started, void *context)
virtual ResultType | Stop (CbResult cb_video_decoder_stopped, void *context)
virtual | ~EmzMpeg4Decoder ()
virtual | ~EmzMpeg4Decoder ()

Protected Member Functions

virtual ResultType | SetCodec (CodecType codec)

Friends

class | EmzCodecsLib
class | EmzMpeg4DecoderThread

Data Structures

class | OperationInfo
class | OperationInfo
struct | StateFlags
struct | StateFlags

Detailed Description

MPEG-4 Simple Profile and H.263 Baseline video decoder interface.

Constructor & Destructor Documentation

EmzMpeg4Decoder::~EmzMpeg4Decoder ( ) [virtual]

Destructor.

virtual EmzMpeg4Decoder::~EmzMpeg4Decoder ( ) [virtual]

Destructor.

Member Function Documentation

virtual ResultType EmzMpeg4Decoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoDecoder::AllocateOutputBuffers

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoDecoder::AllocateOutputBuffers

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::Close ( ) [virtual]

See also:
VideoDecoder::Close

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags,
 |  | UINT32 | time_stamp
 | ) | [virtual]

See also:
VideoDecoder::DecodeFrame

Implements VideoDecoder.

CodecManager::ResultType EmzMpeg4Decoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

See also:
VideoDecoder::DecodeFrame

virtual ResultType EmzMpeg4Decoder::DecodePacket | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

See also:
VideoDecoder::DecodePacket

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::DecodePacket | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

See also:
VideoDecoder::DecodePacket

Implements VideoDecoder.

CodecManager::ResultType EmzMpeg4Decoder::Flush ( ) [virtual]

See also:
VideoDecoder::Flush

CodecDevice::ResultType EmzMpeg4Decoder::FlushBuffers | ( | CbResult | cb_video_decoder_flushed,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::FlushBuffers

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::GetCapabilities ( VideoCodecCapabilities & caps ) [virtual]

See also:
VideoDecoder::GetCapabilities

Implements VideoDecoder.

CodecManager::ResultType EmzMpeg4Decoder::GetCapabilities ( CodecManager::VideoCodecCapabilities & caps ) [virtual]

See also:
VideoDecoder::GetCapabilities

CodecDevice::ResultType EmzMpeg4Decoder::GetCurrentVideoClockTime ( UINT32 & time_ms ) [virtual]

See also:
VideoDecoder::GetCurrentVideoClockTime

Implements VideoDecoder.

CodecManager::ResultType EmzMpeg4Decoder::GetNumberOfInitialDecodeOperations ( UINT8 & operations ) [virtual]

See also:
VideoDecoder::GetNumberOfInitialDecodeOperations

CodecManager::ResultType EmzMpeg4Decoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
VideoDecoder::GetParameters

CodecDevice::ResultType EmzMpeg4Decoder::GetProperties ( Properties & properties ) [virtual]

see CodecDevice::GetProperties

CodecManager::ResultType EmzMpeg4Decoder::NotifyOutputBufferReleased ( const UINT8 HUGE * out_buf ) [virtual]

See also:
VideoDecoder::NotifyOutputBufferReleased

CodecDevice::ResultType EmzMpeg4Decoder::Open ( VideoDecoderInfo & dec_info ) [virtual]

See also:
VideoDecoder::Open

Implements VideoDecoder.

virtual ResultType EmzMpeg4Decoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded,
 |  | CbInBufferFree | cb_in_buf_free
 | ) | [virtual]

See also:
VideoDecoder::RegisterCallbackFunctions

CodecDevice::ResultType EmzMpeg4Decoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded,
 |  | CbInBufferFree | cb_in_buf_free
 | ) | [virtual]

See also:
VideoDecoder::RegisterCallbackFunctions

virtual ResultType EmzMpeg4Decoder::ReleaseOutputBuffer ( const UINT8 HUGE * out_buf ) [virtual]

See also:
VideoDecoder::ReleaseOutputBuffer

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::ReleaseOutputBuffer ( const UINT8 HUGE * out_buf ) [virtual]

See also:
VideoDecoder::ReleaseOutputBuffer

Implements VideoDecoder.

CodecManager::ResultType EmzMpeg4Decoder::Reset ( ) [virtual]

See also:
VideoDecoder::Reset

CodecDevice::ResultType EmzMpeg4Decoder::SetAssociatedAudioCh ( UINT32 audio_channel ) [virtual]

See also:
VideoDecoder::SetAssociatedAudioCh

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::SetCodec ( CodecType codec ) [protected, virtual]

See also:
CodecDevice::SetCodec

CodecDevice::ResultType EmzMpeg4Decoder::SetConfig | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const VideoDecoderParameters & | params,
 |  | VideoStreamInfo & | stream_info
 | ) | [virtual]

See also:
VideoDecoder::SetConfig

Implements VideoDecoder.

CodecManager::ResultType EmzMpeg4Decoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
VideoDecoder::SetParameters

CodecDevice::ResultType EmzMpeg4Decoder::SetVideoClockTime ( UINT32 time_ms ) [virtual]

See also:
VideoDecoder::SetVideoClockTime

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::Start | ( | CbResultAndTimeInfo | cb_video_decoder_started,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::Start

Implements VideoDecoder.

CodecDevice::ResultType EmzMpeg4Decoder::Stop | ( | CbResult | cb_video_decoder_stopped,
 |  | void * | context
 | ) | [virtual]

See also:
VideoDecoder::Stop

Implements VideoDecoder.

Friends And Related Function Documentation

EmzCodecsLib [friend]

EmzMpeg4DecoderThread [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Decoder.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Decoder.cpp
Generated on Wed Jan 25 01:13:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzMpeg4DecoderThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzMpeg4DecoderThread Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp>

Inheritance diagram for EmzMpeg4DecoderThread:

[legend]
Collaboration diagram for EmzMpeg4DecoderThread:

[legend]

Public Member Functions

virtual INT | ThreadFn ()
virtual INT | ThreadFn ()

Friends

class | EmzMpeg4Decoder

Detailed Description

MPEG-4 Simple Profile and H.263 Baseline video decoder interface.

Member Function Documentation

virtual INT EmzMpeg4DecoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

INT EmzMpeg4DecoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

Friends And Related Function Documentation

EmzMpeg4Decoder [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzMpeg4DecoderThread.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4DecoderThread.cpp
Generated on Wed Jan 25 01:13:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzMpeg4Encoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzMpeg4Encoder Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp>

Inheritance diagram for EmzMpeg4Encoder:

[legend]
Collaboration diagram for EmzMpeg4Encoder:

[legend]

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual CodecManager::ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual CodecManager::ResultType | AssignCaptureBufferPool (UINT32 buf_pool_handle)
virtual ResultType | Close ()
virtual ResultType | EncodeFrame (UINT8 HUGE *in_buf, UINT32 time_stamp, UINT32 key_frame_ind)
virtual CodecManager::ResultType | EncodeFrame (UINT8 HUGE *in_buf, UINT32 time_stamp, UINT32 key_frame_ind, UINT8 HUGE *out_buf)
virtual CodecManager::ResultType | Flush ()
virtual ResultType | FlushBuffers (CbResult cb_video_encoder_flushed, void *context)
virtual ResultType | GetCapabilities (VideoCodecCapabilities &caps)
virtual CodecManager::ResultType | GetCapabilities (CodecManager::VideoCodecCapabilities &caps)
virtual ResultType | GetConfigStream (UINT8 HUGE *&out_buf, UINT32 &out_buf_len)
virtual CodecManager::ResultType | GetConfigStream (UINT8 HUGE *out_buf, UINT32 &out_buf_len)
virtual CodecManager::ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual ResultType | GetProperties (Properties &properties)
virtual ResultType | InsertKeyFrame ()
virtual ResultType | Open ()
virtual ResultType | RegisterCallbackFunctions (void *context, CbVideoFrameEncoded cb_frame_encoded)
virtual CodecManager::ResultType | RegisterCallbackFunctions (void *context, CbFrameEncoded cb_frame_encoded)
virtual ResultType | ReleaseConfigStreamBuffer (UINT8 HUGE *buf)
virtual ResultType | ReleaseOutputBuffer (UINT8 HUGE *out_buf)
virtual CodecManager::ResultType | Reset ()
virtual ResultType | SetCodec (CodecType codec)
virtual ResultType | SetConfig (const VideoEncoderParameters &params, UINT32 &out_buf_max_len)
virtual ResultType | SetDynamicConfig (VideoEncoderDynParameters &params)
virtual CodecManager::ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual ResultType | Start ()
virtual ResultType | Stop (CbResult cb_video_decoder_stopped, void *context)
virtual | ~EmzMpeg4Encoder ()
virtual | ~EmzMpeg4Encoder ()

Friends

class | EmzCodecsLib
class | EmzMpeg4EncoderThread

Data Structures

class | OperationInfo
class | OperationInfo
struct | StateFlags
struct | StateFlags

Detailed Description

MPEG-4 Simple Profile and H.263 Baseline video encoder interface for the Emuzed SW encoder lib.

Constructor & Destructor Documentation

EmzMpeg4Encoder::~EmzMpeg4Encoder ( ) [virtual]

Destructor

virtual EmzMpeg4Encoder::~EmzMpeg4Encoder ( ) [virtual]

Destructor

Member Function Documentation

CodecDevice::ResultType EmzMpeg4Encoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoEncoder::AllocateOutputBuffers

Implements VideoEncoder.

CodecManager::ResultType EmzMpeg4Encoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoEncoder::AllocateOutputBuffers

CodecManager::ResultType EmzMpeg4Encoder::AssignCaptureBufferPool ( UINT32 buf_pool_handle ) [virtual]

See also:
VideoEncoder::AssignCaptureBufferPool

CodecDevice::ResultType EmzMpeg4Encoder::Close ( ) [virtual]

See also:
VideoEncoder::Close

Implements VideoEncoder.

CodecDevice::ResultType EmzMpeg4Encoder::EncodeFrame | ( | UINT8 HUGE * | in_buf,
 |  | UINT32 | time_stamp,
 |  | UINT32 | key_frame_ind
 | ) | [virtual]

See also:
VideoEncoder::EncodeFrame

Implements VideoEncoder.

CodecManager::ResultType EmzMpeg4Encoder::EncodeFrame | ( | UINT8 HUGE * | in_buf,
 |  | UINT32 | time_stamp,
 |  | UINT32 | key_frame_ind,
 |  | UINT8 HUGE * | out_buf
 | ) | [virtual]

See also:
VideoEncoder::EncodeFrame

CodecManager::ResultType EmzMpeg4Encoder::Flush ( ) [virtual]

See also:
VideoEncoder::Flush

CodecDevice::ResultType EmzMpeg4Encoder::FlushBuffers | ( | CbResult | cb_video_encoder_flushed,
 |  | void * | context
 | ) | [virtual]

See also:
VideoEncoder::FlushBuffers

Implements VideoEncoder.

CodecDevice::ResultType EmzMpeg4Encoder::GetCapabilities ( VideoCodecCapabilities & caps ) [virtual]

See also:
VideoEncoder::GetCapabilities

Implements VideoEncoder.

CodecManager::ResultType EmzMpeg4Encoder::GetCapabilities ( CodecManager::VideoCodecCapabilities & caps ) [virtual]

See also:
VideoEncoder::GetCapabilities

CodecDevice::ResultType EmzMpeg4Encoder::GetConfigStream | ( | UINT8 HUGE *& | out_buf,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoEncoder::GetConfigStream

Implements VideoEncoder.

CodecManager::ResultType EmzMpeg4Encoder::GetConfigStream | ( | UINT8 HUGE * | out_buf,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

See also:
VideoEncoder::GetConfigStream

CodecManager::ResultType EmzMpeg4Encoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
VideoEncoder::GetParameters

CodecDevice::ResultType EmzMpeg4Encoder::GetProperties ( Properties & properties ) [virtual]

see CodecDevice::GetProperties

CodecDevice::ResultType EmzMpeg4Encoder::InsertKeyFrame ( ) [virtual]

See also:
VideoEncoder::InsertKeyFrame

Implements VideoEncoder.

CodecDevice::ResultType EmzMpeg4Encoder::Open ( ) [virtual]

See also:
VideoEncoder::Open

Implements VideoEncoder.

CodecDevice::ResultType EmzMpeg4Encoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbVideoFrameEncoded | cb_frame_encoded
 | ) | [virtual]

See also:
VideoEncoder::RegisterCallbackFunctions

CodecManager::ResultType EmzMpeg4Encoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameEncoded | cb_frame_encoded
 | ) | [virtual]

See also:
VideoEncoder::RegisterCallbackFunctions

CodecDevice::ResultType EmzMpeg4Encoder::ReleaseConfigStreamBuffer ( UINT8 HUGE * buf ) [virtual]

See also:
VideoEncoder::ReleaseConfigStreamBuffer

Implements VideoEncoder.

CodecDevice::ResultType EmzMpeg4Encoder::ReleaseOutputBuffer ( UINT8 HUGE * out_buf ) [virtual]

See also:
VideoEncoder::ReleaseOutputBuffer

Implements VideoEncoder.

CodecManager::ResultType EmzMpeg4Encoder::Reset ( ) [virtual]

See also:
VideoEncoder::Reset

CodecDevice::ResultType EmzMpeg4Encoder::SetCodec ( CodecType codec ) [virtual]

See also:
VideoEncoder::SetCodec

CodecDevice::ResultType EmzMpeg4Encoder::SetConfig | ( | const VideoEncoderParameters & | params,
 |  | UINT32 & | out_buf_max_len
 | ) | [virtual]

See also:
VideoEncoder::SetConfig

Implements VideoEncoder.

CodecDevice::ResultType EmzMpeg4Encoder::SetDynamicConfig ( VideoEncoderDynParameters & params ) [virtual]

See also:
VideoEncoder::SetDynamicConfig

CodecManager::ResultType EmzMpeg4Encoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
VideoEncoder::SetParameters

CodecDevice::ResultType EmzMpeg4Encoder::Start ( ) [virtual]

See also:
VideoEncoder::Start

Implements VideoEncoder.

CodecDevice::ResultType EmzMpeg4Encoder::Stop | ( | CbResult | cb_video_decoder_stopped,
 |  | void * | context
 | ) | [virtual]

See also:
VideoEncoder::Stop

Implements VideoEncoder.

Friends And Related Function Documentation

EmzCodecsLib [friend]

EmzMpeg4EncoderThread [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzMpeg4Encoder.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4Encoder.cpp
Generated on Wed Jan 25 01:13:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzMpeg4EncoderThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzMpeg4EncoderThread Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp>

Inheritance diagram for EmzMpeg4EncoderThread:

[legend]
Collaboration diagram for EmzMpeg4EncoderThread:

[legend]

Public Member Functions

virtual INT | ThreadFn ()
virtual INT | ThreadFn ()

Friends

class | EmzMpeg4Encoder

Detailed Description

MPEG-4 Simple Profile and H.263 Baseline video encoder interface.

Member Function Documentation

virtual INT EmzMpeg4EncoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

INT EmzMpeg4EncoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

Friends And Related Function Documentation

EmzMpeg4Encoder [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzMpeg4EncoderThread.cpp
  • Devices/MPEU/Extensions/EmzCodecs/EmzMpeg4EncoderThread.cpp
Generated on Wed Jan 25 01:13:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzSbcEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzSbcEncoder Class Reference
[Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.hpp>

Inheritance diagram for EmzSbcEncoder:

[legend]
Collaboration diagram for EmzSbcEncoder:

[legend]

Public Member Functions

virtual CodecManager::ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len, EncodingFunctionType &dec_fct)
virtual CodecManager::ResultType | EncodeBuffer (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual CodecManager::ResultType | EncodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, const UINT8 HUGE *out_buf, UINT32 out_buf_len)
virtual CodecManager::ResultType | Flush ()
virtual CodecManager::ResultType | GetCapabilities (CodecManager::AudioCodecCapabilities &caps)
virtual CodecManager::ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | RegisterCallbackFunctions (void *context, CbFrameEncoded cb_frame_encoded)
virtual CodecManager::ResultType | Reset ()
virtual CodecManager::ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual | ~EmzSbcEncoder ()

Friends

class | EmzCodecsLib
class | EmzSbcEncoderThread

Data Structures

class | OperationInfo
struct | StateFlags

Detailed Description

Emuzed Bluetooth SBC audio encoder interface class

Constructor & Destructor Documentation

EmzSbcEncoder::~EmzSbcEncoder ( ) [virtual]

Destructor.

Member Function Documentation

CodecManager::ResultType EmzSbcEncoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len,
 |  | EncodingFunctionType & | dec_fct
 | ) | [virtual]

See also:
AudioEncoder::AllocateOutputBuffers

CodecManager::ResultType EmzSbcEncoder::EncodeBuffer | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

See also:
AudioEncoder::EncodeBuffer

Implements AudioEncoder.

CodecManager::ResultType EmzSbcEncoder::EncodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | const UINT8 HUGE * | out_buf,
 |  | UINT32 | out_buf_len
 | ) | [virtual]

See also:
AudioEncoder::EncodeFrame

Implements AudioEncoder.

CodecManager::ResultType EmzSbcEncoder::Flush ( ) [virtual]

See also:
AudioEncoder::Flush

CodecManager::ResultType EmzSbcEncoder::GetCapabilities ( CodecManager::AudioCodecCapabilities & caps ) [virtual]

See also:
AudioEncoder::GetCapabilities

CodecManager::ResultType EmzSbcEncoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
AudioEncoder::GetParameters

CodecManager::ResultType EmzSbcEncoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameEncoded | cb_frame_encoded
 | ) | [virtual]

See also:
AudioEncoder::RegisterCallbackFunctions

CodecManager::ResultType EmzSbcEncoder::Reset ( ) [virtual]

See also:
AudioEncoder::Reset

CodecManager::ResultType EmzSbcEncoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

See also:
AudioEncoder::SetParameters

Friends And Related Function Documentation

friend class EmzCodecsLib [friend]

friend class EmzSbcEncoderThread [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoder.cpp
Generated on Wed Jan 25 01:13:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzSbcEncoderThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzSbcEncoderThread Class Reference
[Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.hpp>

Inheritance diagram for EmzSbcEncoderThread:

[legend]
Collaboration diagram for EmzSbcEncoderThread:

[legend]

Public Member Functions

virtual INT | ThreadFn ()

Friends

class | EmzSbcEncoder

Detailed Description

SBC audio encoder interface (thread).

Member Function Documentation

INT EmzSbcEncoderThread::ThreadFn ( ) [virtual]

Thread Function.

Implements Thread.

Friends And Related Function Documentation

friend class EmzSbcEncoder [friend]

The documentation for this class was generated from the following files:
  • Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.hpp
  • Devices/MPE/Extensions/EmzCodecs/EmzSbcEncoderThread.cpp
Generated on Wed Jan 25 01:13:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzUtils Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EmzUtils Class Reference
[Devices, Devices]

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp>

Data Structures

class | Queue
class | Queue

Detailed Description

Utilities class for the codec device

The documentation for this class was generated from the following file:
  • Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp
Generated on Wed Jan 25 01:13:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EmzUtils::Queue< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
EmzUtils::Queue

EmzUtils::Queue< T > Class Template Reference

#include <Apoxi/Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp>

Inheritance diagram for EmzUtils::Queue< T >:

[legend]

Detailed Description

template<class T>
class EmzUtils::Queue< T >

Queue class used in the codec device.

The documentation for this class was generated from the following file:
  • Devices/MPE/Extensions/EmzCodecs/EmzUtils.hpp
Generated on Wed Jan 25 01:13:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EncodingThreadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EncodingThreadlet Class Reference
[GUI]

#include <Apoxi/Gui/EncodingThreadlet.hpp>

Inheritance diagram for EncodingThreadlet:

[legend]
Collaboration diagram for EncodingThreadlet:

[legend]

Public Member Functions

virtual INT | Fn ()
virtual void | ReleaseInstance ()
virtual | ~EncodingThreadlet ()

Protected Member Functions

EncodingThreadlet (ImageEncoder &encoder, BinData &source, const Image::MetaData &src_params, DataSink &dest)
EncodingThreadlet (ImageEncoder &encoder, const Image &source, DataSink &dest)
BinData * | GetBinData () const
Returns the source data. 0 is returned if a image as source is used.
DataSink & GetDataSink ()
Returns the data sink where the encoded image is written into.
ImageEncoder & GetEncoder ()
Returns the owner of the encoding threadlet.
const Image * | GetImage () const
const Image::MetaData * | GetMetaData () const
Returns the meta information of the source data. 0 is returned if an image as source is used.

Detailed Description

EncodingThreadlet is the abstract base class for threadlets which want to encode an image inside a separate thread to avoid a blocked system. The constructor is protected and it is recommended to provide a static factory method in the derived class to create an instance. The methods Threadlet::Fn must be implemented by the derived class.

Constructor & Destructor Documentation

EncodingThreadlet::~EncodingThreadlet ( ) [virtual]

EncodingThreadlet::EncodingThreadlet | ( | ImageEncoder & | encoder,
 |  | const Image & | source,
 |  | DataSink & | dest
 | ) | [protected]

Parameters:
encoder | Owner of the encoding threadlet.
source | Source image which should get encoded.
dest | Destination data sink where the source image is encoded into.

EncodingThreadlet::EncodingThreadlet | ( | ImageEncoder & | encoder,
 |  | BinData & | source,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest
 | ) | [protected]

Parameters:
encode | Owner of the encoding threadlet.
source | Source data which should get encoded.
src_params | Encoding parameters for the source data.
dest | Destination data sink where the source data is encoded into.

Member Function Documentation

INT EncodingThreadlet::Fn ( ) [virtual]

Passes the given image to the encoder.

Implements Threadlet.

BinData* EncodingThreadlet::GetBinData ( ) const [inline, protected]

Returns the source data. 0 is returned if a image as source is used.

DataSink& EncodingThreadlet::GetDataSink ( ) [inline, protected]

Returns the data sink where the encoded image is written into.

ImageEncoder& EncodingThreadlet::GetEncoder ( ) [inline, protected]

Returns the owner of the encoding threadlet.

const Image* EncodingThreadlet::GetImage ( ) const [inline, protected]

const Image::MetaData* EncodingThreadlet::GetMetaData ( ) const [inline, protected]

Returns the meta information of the source data. 0 is returned if an image as source is used.

void EncodingThreadlet::ReleaseInstance ( ) [virtual]

Deletes the instance (it's assumed that the threadlet is allocated on the heap). If the threadlet is not allocated on the heap, this method must be reimplemented by the derived class in a proper manner.

See also:
Threadlet::ReleaseInstance

Reimplemented from Threadlet.

The documentation for this class was generated from the following files:
  • Gui/EncodingThreadlet.hpp
  • Gui/EncodingThreadlet.cpp
Generated on Wed Jan 25 01:13:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EndSimToolkitIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EndSimToolkitIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for EndSimToolkitIndArg:

[legend]
Collaboration diagram for EndSimToolkitIndArg:

[legend]

Public Types

enum | { ID = 1315 }

Public Member Functions

EndSimToolkitIndArg ()

Static Public Member Functions

static const EndSimToolkitIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

EndSimToolkitIndArg: reflects arguments of signal SI_END_TK_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EndSimToolkitIndArg::EndSimToolkitIndArg ( )

Member Function Documentation

const EndSimToolkitIndArg & EndSimToolkitIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:13:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EngineeringModeControlRequestArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EngineeringModeControlRequestArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for EngineeringModeControlRequestArg:

[legend]
Collaboration diagram for EngineeringModeControlRequestArg:

[legend]

Public Types

enum | { ID = 2109 }

Public Member Functions

EngineeringModeControlRequestArg ()
EngineeringModeControlRequestArg (const EngineeringModeControl &function, ULONG param=0)
const EngineeringModeControl & | GetFunction () const
ULONG | GetParam () const
void | SetFunction (const EngineeringModeControl &function)
void | SetParam (ULONG param)

Static Public Member Functions

static const EngineeringModeControlRequestArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

EngineeringModeControlRequestArg : reflects arguments of signal URRC_EM_CTRL_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EngineeringModeControlRequestArg::EngineeringModeControlRequestArg | ( | const EngineeringModeControl & | function,
 |  | ULONG | param = 0
 | ) |

EngineeringModeControlRequestArg::EngineeringModeControlRequestArg ( )

Member Function Documentation

const EngineeringModeControlRequestArg & EngineeringModeControlRequestArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const EngineeringModeControl& EngineeringModeControlRequestArg::GetFunction ( ) const [inline]

ULONG EngineeringModeControlRequestArg::GetParam ( ) const [inline]

void EngineeringModeControlRequestArg::SetFunction ( const EngineeringModeControl & function ) [inline]

void EngineeringModeControlRequestArg::SetParam ( ULONG param ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:13:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EngineeringModeControlResponseArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EngineeringModeControlResponseArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for EngineeringModeControlResponseArg:

[legend]
Collaboration diagram for EngineeringModeControlResponseArg:

[legend]

Public Types

enum | { ID = 1117 }

Public Member Functions

EngineeringModeControlResponseArg ()
INT | GetFunction () const
INT | GetResult () const
void | SetFunction (INT function)
void | SetResult (INT result)

Static Public Member Functions

static const EngineeringModeControlResponseArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

EngineeringModeControlResponseArg : reflects arguments of signal URRC_EM_CTRL_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EngineeringModeControlResponseArg::EngineeringModeControlResponseArg ( )

Member Function Documentation

const EngineeringModeControlResponseArg & EngineeringModeControlResponseArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT EngineeringModeControlResponseArg::GetFunction ( ) const [inline]

INT EngineeringModeControlResponseArg::GetResult ( ) const [inline]

void EngineeringModeControlResponseArg::SetFunction ( INT function ) [inline]

void EngineeringModeControlResponseArg::SetResult ( INT result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:13:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EngineeringModeControlResponseMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EngineeringModeControlResponseMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for EngineeringModeControlResponseMsg:

[legend]
Collaboration diagram for EngineeringModeControlResponseMsg:

[legend]

Public Types

enum | { ID = 18611 }

Public Member Functions

virtual Message * | Clone () const
EngineeringModeControlResponseMsg (ExecutionContext *context, const EngineeringModeControlResponseArg &cnf_arg)
const EngineeringModeControlResponseArg & | GetCnfArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetCnfArg (const EngineeringModeControlResponseArg &cnf_arg)
virtual | ~EngineeringModeControlResponseMsg ()

Detailed Description

EngineeringModeControlResponseMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EngineeringModeControlResponseMsg::EngineeringModeControlResponseMsg | ( | ExecutionContext * | context,
 |  | const EngineeringModeControlResponseArg & | cnf_arg
 | ) |

EngineeringModeControlResponseMsg::~EngineeringModeControlResponseMsg ( ) [virtual]

Member Function Documentation

Message * EngineeringModeControlResponseMsg::Clone ( ) const [virtual]

Implements Message.

const EngineeringModeControlResponseArg& EngineeringModeControlResponseMsg::GetCnfArg ( ) const [inline]

const MsgMetaData & EngineeringModeControlResponseMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void EngineeringModeControlResponseMsg::SetCnfArg ( const EngineeringModeControlResponseArg & cnf_arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:13:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EngineeringReportMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EngineeringReportMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for EngineeringReportMsg:

[legend]
Collaboration diagram for EngineeringReportMsg:

[legend]

Public Types

enum | { ID = 18603 }

Public Member Functions

virtual Message * | Clone () const
EngineeringReportMsg (ExecutionContext *context, const TestparamReportArg &report_arg)
virtual const MsgMetaData & | GetMetaData () const
const TestparamReportArg & | GetReportArg () const
void | SetReportArg (const TestparamReportArg &report_arg)
virtual | ~EngineeringReportMsg ()

Detailed Description

EngineeringReportMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

EngineeringReportMsg::EngineeringReportMsg | ( | ExecutionContext * | context,
 |  | const TestparamReportArg & | report_arg
 | ) |

EngineeringReportMsg::~EngineeringReportMsg ( ) [virtual]

Member Function Documentation

Message * EngineeringReportMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & EngineeringReportMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const TestparamReportArg& EngineeringReportMsg::GetReportArg ( ) const [inline]

void EngineeringReportMsg::SetReportArg ( const TestparamReportArg & report_arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:13:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EnglishT9InputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EnglishT9InputMapper Class Reference

#include <Apoxi/AddOns/T9/EnglishT9InputMapper.hpp>

Inheritance diagram for EnglishT9InputMapper:

[legend]
Collaboration diagram for EnglishT9InputMapper:

[legend]

Public Member Functions

EnglishT9InputMapper (AbstractEditor *editor=0)
virtual InputMapper::Alphabet | GetAlphabet () const
virtual PredMode | GetMode () const
Discover the current input method.
virtual const WCHAR * | GetStatusInfo () const
A human-readable name for the current input method.
virtual BOOLEAN | IsModeSupported (PredMode mode)
virtual BOOLEAN | SetMode (PredMode mode)
virtual | ~EnglishT9InputMapper ()

Protected Member Functions

T9NUM | GetLdbNumForMode (PredMode mode) const
virtual const T9Wrapper * | GetT9Wrapper () const
Overridden.
virtual T9Wrapper * | GetT9Wrapper ()
Overridden.
T9Wrapper::t9_symbol | MapKey_English (KeyCode apoxi_key_code)
T9Wrapper::t9_symbol | MapKey_English_Alphabetic (KeyCode apoxi_key_code)
This method is separate from the whole MapKey_English(), to allow reuse for PinYin.
WCHAR | MapKeyToCharacter_Numbers (KeyCode apoxi_key_code)
virtual BOOLEAN | OnLongKeyPress_T9 (KeyCode apoxi_key_code)
virtual BOOLEAN | OnShortKeyUp_T9 (KeyCode key_code)
This is an override.

Detailed Description

This should probably be called LatinT9InputMapper, because it can be used for other Latin languages.

Constructor & Destructor Documentation

EnglishT9InputMapper::EnglishT9InputMapper ( AbstractEditor * editor = 0 )

EnglishT9InputMapper::~EnglishT9InputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet EnglishT9InputMapper::GetAlphabet ( ) const [virtual]

See also:
InputMapper::GetAlphabet

Reimplemented from InputMapper.

Reimplemented in ChineseT9InputMapper.

T9NUM EnglishT9InputMapper::GetLdbNumForMode ( PredMode mode ) const [protected]

PredInputMapper::PredMode EnglishT9InputMapper::GetMode ( ) const [virtual]

Discover the current input method.

Reimplemented from T9InputMapper.

Reimplemented in ChineseT9InputMapper.

const WCHAR * EnglishT9InputMapper::GetStatusInfo ( ) const [virtual]

A human-readable name for the current input method.

Reimplemented from T9InputMapper.

Reimplemented in ChineseT9InputMapper.

const T9Wrapper * EnglishT9InputMapper::GetT9Wrapper ( ) const [protected, virtual]

Overridden.

Implements T9InputMapper.

Reimplemented in ChineseT9InputMapper.

T9Wrapper * EnglishT9InputMapper::GetT9Wrapper ( ) [protected, virtual]

Overridden.

Implements T9InputMapper.

Reimplemented in ChineseT9InputMapper.

BOOLEAN EnglishT9InputMapper::IsModeSupported ( PredMode mode ) [virtual]

Reimplemented in ChineseT9InputMapper.

T9Wrapper::t9_symbol EnglishT9InputMapper::MapKey_English ( KeyCode apoxi_key_code ) [protected]

T9Wrapper::t9_symbol EnglishT9InputMapper::MapKey_English_Alphabetic ( KeyCode apoxi_key_code ) [protected]

This method is separate from the whole MapKey_English(), to allow reuse for PinYin.

WCHAR EnglishT9InputMapper::MapKeyToCharacter_Numbers ( KeyCode apoxi_key_code ) [protected]

BOOLEAN EnglishT9InputMapper::OnLongKeyPress_T9 ( KeyCode apoxi_key_code ) [protected, virtual]

See also:
InputMapper::OnLongKeyPress(). This is an override.

Reimplemented from T9InputMapper.

Reimplemented in ChineseT9InputMapper.

BOOLEAN EnglishT9InputMapper::OnShortKeyUp_T9 ( KeyCode key_code ) [protected, virtual]

This is an override.

Reimplemented from T9InputMapper.

Reimplemented in ChineseT9InputMapper.

BOOLEAN EnglishT9InputMapper::SetMode ( PredMode mode ) [virtual]

Reimplemented in ChineseT9InputMapper.

The documentation for this class was generated from the following files:
  • AddOns/T9/EnglishT9InputMapper.hpp
  • AddOns/T9/EnglishT9InputMapper.cpp
Generated on Wed Jan 25 01:13:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EngModeAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EngModeAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for EngModeAction:

[legend]
Collaboration diagram for EngModeAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
EngModeAction ()
virtual InputActionType | GetActionType () const
Returns the type of the action.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual BOOLEAN | ShallExecuteImmediatly ()
Returns if Execute can be called immediatly without confirmation with an additional key (e.g SEND).
virtual | ~EngModeAction ()

Detailed Description

EngModeAction analyzes if the input string has the meaning of starting the engineering mode. Execute has to be overwritten to implement the showing of the engineering data.

Constructor & Destructor Documentation

EngModeAction::EngModeAction ( )

EngModeAction::~EngModeAction ( ) [virtual]

Member Function Documentation

InputAction * EngModeAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType EngModeAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

BOOLEAN EngModeAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

BOOLEAN EngModeAction::ShallExecuteImmediatly ( ) [virtual]

Returns if Execute can be called immediatly without confirmation with an additional key (e.g SEND).

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:13:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EnumTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EnumTextMap Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/EnumTextMap.hpp>

Inheritance diagram for EnumTextMap:

[legend]

Static Public Member Functions

static const WCHAR * GetText (const EnumTextTable table, const UINT size, const INT value)

Member Function Documentation

static const WCHAR* EnumTextMap::GetText | ( | const EnumTextTable | table,
 |  | const UINT | size,
 |  | const INT | value
 | ) | [static]

The documentation for this class was generated from the following file:
  • Atl/EnumTextMap.hpp
Generated on Wed Jan 25 01:13:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EnumTextTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EnumTextTableEntry Struct Reference
[APOXI Template Layer]

#include <Apoxi/Atl/EnumTextMap.hpp>

Data Fields

INT | code
const WCHAR * | text

Field Documentation

INT EnumTextTableEntry::code

const WCHAR* EnumTextTableEntry::text

The documentation for this struct was generated from the following file:
  • Atl/EnumTextMap.hpp
Generated on Wed Jan 25 01:13:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EnumTranslationTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EnumTranslationTable Class Reference
[Translation]

#include <Apoxi/AddOns/Translation/EnumTranslationTable.hpp>

Collaboration diagram for EnumTranslationTable:

[legend]

Static Public Member Functions

static const ValueTextMap::Table * | Alphabet ()
translation table for enum DataCodingScheme::Alphabet
static const ValueTextMap::Table * | AocChargingStatus ()
translation table for enum AocChargingStatus
static const ValueTextMap::Table * | AudioToneToneType ()
translation table for enum AudioTone::ToneType
static const ValueTextMap::Table * | CallApiRc ()
translation table for enum CallApiRc
static const ValueTextMap::Table * | CallErrorCause ()
translation table for enum CallErrorCause
static const ValueTextMap::Table * | CallRelatedSsCode ()
translation table for enum CallRelatedSsCode
static const ValueTextMap::Table * | ChvNo ()
translation table for enum ChvNo
static const ValueTextMap::Table * | ChvStatus ()
translation table for enum ChvStatus
static const ValueTextMap::Table * | Compression ()
translation table for enum DataCodingScheme::Compression
static const ValueTextMap::Table * | DcsGroupId ()
translation table for enum DataCodingScheme::GroupId
static const ValueTextMap::Table * | HandlerId ()
translation table for enum HandlerId
static const ValueTextMap::Table * | MessageClass ()
translation table for enum DataCodingScheme::MessageClass
static const ValueTextMap::Table * | MessageResultReason ()
translation table for enum ShortMessageStatus::Reason
static const ValueTextMap::Table * | MessageStatus ()
translation table for enum ShortMessageStatus::Status
static const ValueTextMap::Table * | MessageType ()
translation table for enum ProtocolIdentifier::MessageType
static const ValueTextMap::Table * | MessageTypeIndicator ()
translation table for enum MessageTypeIndicator::Type
static const ValueTextMap::Table * | PdpContextErrorCause ()
translation table for enum PdpContext::ErrorCause
static const ValueTextMap::Table * | PdpContextManagerState ()
translation table for enum PdpContextManager::State
static const ValueTextMap::Table * | PdpContextOrigin ()
translation table for enum PdpContext::Origin
static const ValueTextMap::Table * | PdpContextState ()
translation table for enum PdpContext::State
static const ValueTextMap::Table * | PidInterworking ()
translation table for enum ProtocolIdentifier::Interworking
static const ValueTextMap::Table * | ProblemCode ()
translation table for enum TaggedProblemCode::ProblemCode
static const ValueTextMap::Table * | ProblemTag ()
translation table for enum TaggedProblemCode::ProblemTag
static const ValueTextMap::Table * | RegisterRejectCause ()
translation table for enum RegisterRejectCause
static const ValueTextMap::Table * | RegisterStatus ()
translation table for enum RegisterStatus
static const ValueTextMap::Table * | SecLockResult ()
translation table for enum SecLockResult
static const ValueTextMap::Table * | ServiceGroup ()
translation table for enum ServiceGroup
static const ValueTextMap::Table * | SimIndicator ()
translation table for enum SimIndicator
static const ValueTextMap::Table * | SmsResult ()
translation table for enum Sms::Result
static const ValueTextMap::Table * | SmsStorageType ()
translation table for enum Sms::StorageType
static const ValueTextMap::Table * | SmsWarningLevel ()
translation table for enum Sms::WarningLevel
static const ValueTextMap::Table * | SsBaseHandlerReturnCode ()
translation table for enum SsBaseHandler::ReturnCode
static const ValueTextMap::Table * | SsErrorCode ()
translation table for enum SsErrorCode::Code
static const ValueTextMap::Table * | SsOperationCode ()
translation table for enum SsOperationCode
static const ValueTextMap::Table * | TelematicDevice ()
translation table for enum ProtocolIdentifier::TelematicDevice
static const ValueTextMap::Table * | TpduStatus ()
translation table for enum Tpdu::Status
static const ValueTextMap::Table * | ValidityPeriodFormat ()
translation table for enum ValidityPeriodFormat::Format
static const ValueTextMap::Table * | WaitingMessage ()
translation table for enum DataCodingScheme::WaitingMessage
static const ValueTextMap::Table * | WaitingMessageIndication ()
translation table for enum DataCodingScheme::WaitingMessageIndication

Member Function Documentation

static const ValueTextMap::Table* EnumTranslationTable::Alphabet ( ) [inline, static]

translation table for enum DataCodingScheme::Alphabet

static const ValueTextMap::Table* EnumTranslationTable::AocChargingStatus ( ) [inline, static]

translation table for enum AocChargingStatus

static const ValueTextMap::Table* EnumTranslationTable::AudioToneToneType ( ) [inline, static]

translation table for enum AudioTone::ToneType

static const ValueTextMap::Table* EnumTranslationTable::CallApiRc ( ) [inline, static]

translation table for enum CallApiRc

static const ValueTextMap::Table* EnumTranslationTable::CallErrorCause ( ) [inline, static]

translation table for enum CallErrorCause

static const ValueTextMap::Table* EnumTranslationTable::CallRelatedSsCode ( ) [inline, static]

translation table for enum CallRelatedSsCode

static const ValueTextMap::Table* EnumTranslationTable::ChvNo ( ) [inline, static]

translation table for enum ChvNo

static const ValueTextMap::Table* EnumTranslationTable::ChvStatus ( ) [inline, static]

translation table for enum ChvStatus

static const ValueTextMap::Table* EnumTranslationTable::Compression ( ) [inline, static]

translation table for enum DataCodingScheme::Compression

static const ValueTextMap::Table* EnumTranslationTable::DcsGroupId ( ) [inline, static]

translation table for enum DataCodingScheme::GroupId

static const ValueTextMap::Table* EnumTranslationTable::HandlerId ( ) [inline, static]

translation table for enum HandlerId

static const ValueTextMap::Table* EnumTranslationTable::MessageClass ( ) [inline, static]

translation table for enum DataCodingScheme::MessageClass

static const ValueTextMap::Table* EnumTranslationTable::MessageResultReason ( ) [inline, static]

translation table for enum ShortMessageStatus::Reason

static const ValueTextMap::Table* EnumTranslationTable::MessageStatus ( ) [inline, static]

translation table for enum ShortMessageStatus::Status

static const ValueTextMap::Table* EnumTranslationTable::MessageType ( ) [inline, static]

translation table for enum ProtocolIdentifier::MessageType

static const ValueTextMap::Table* EnumTranslationTable::MessageTypeIndicator ( ) [inline, static]

translation table for enum MessageTypeIndicator::Type

static const ValueTextMap::Table* EnumTranslationTable::PdpContextErrorCause ( ) [inline, static]

translation table for enum PdpContext::ErrorCause

static const ValueTextMap::Table* EnumTranslationTable::PdpContextManagerState ( ) [inline, static]

translation table for enum PdpContextManager::State

static const ValueTextMap::Table* EnumTranslationTable::PdpContextOrigin ( ) [inline, static]

translation table for enum PdpContext::Origin

static const ValueTextMap::Table* EnumTranslationTable::PdpContextState ( ) [inline, static]

translation table for enum PdpContext::State

static const ValueTextMap::Table* EnumTranslationTable::PidInterworking ( ) [inline, static]

translation table for enum ProtocolIdentifier::Interworking

static const ValueTextMap::Table* EnumTranslationTable::ProblemCode ( ) [inline, static]

translation table for enum TaggedProblemCode::ProblemCode

static const ValueTextMap::Table* EnumTranslationTable::ProblemTag ( ) [inline, static]

translation table for enum TaggedProblemCode::ProblemTag

static const ValueTextMap::Table* EnumTranslationTable::RegisterRejectCause ( ) [inline, static]

translation table for enum RegisterRejectCause

static const ValueTextMap::Table* EnumTranslationTable::RegisterStatus ( ) [inline, static]

translation table for enum RegisterStatus

static const ValueTextMap::Table* EnumTranslationTable::SecLockResult ( ) [inline, static]

translation table for enum SecLockResult

static const ValueTextMap::Table* EnumTranslationTable::ServiceGroup ( ) [inline, static]

translation table for enum ServiceGroup

static const ValueTextMap::Table* EnumTranslationTable::SimIndicator ( ) [inline, static]

translation table for enum SimIndicator

static const ValueTextMap::Table* EnumTranslationTable::SmsResult ( ) [inline, static]

translation table for enum Sms::Result

static const ValueTextMap::Table* EnumTranslationTable::SmsStorageType ( ) [inline, static]

translation table for enum Sms::StorageType

static const ValueTextMap::Table* EnumTranslationTable::SmsWarningLevel ( ) [inline, static]

translation table for enum Sms::WarningLevel

static const ValueTextMap::Table* EnumTranslationTable::SsBaseHandlerReturnCode ( ) [inline, static]

translation table for enum SsBaseHandler::ReturnCode

static const ValueTextMap::Table* EnumTranslationTable::SsErrorCode ( ) [inline, static]

translation table for enum SsErrorCode::Code

static const ValueTextMap::Table* EnumTranslationTable::SsOperationCode ( ) [inline, static]

translation table for enum SsOperationCode

static const ValueTextMap::Table* EnumTranslationTable::TelematicDevice ( ) [inline, static]

translation table for enum ProtocolIdentifier::TelematicDevice

static const ValueTextMap::Table* EnumTranslationTable::TpduStatus ( ) [inline, static]

translation table for enum Tpdu::Status

static const ValueTextMap::Table* EnumTranslationTable::ValidityPeriodFormat ( ) [inline, static]

translation table for enum ValidityPeriodFormat::Format

static const ValueTextMap::Table* EnumTranslationTable::WaitingMessage ( ) [inline, static]

translation table for enum DataCodingScheme::WaitingMessage

static const ValueTextMap::Table* EnumTranslationTable::WaitingMessageIndication ( ) [inline, static]

translation table for enum DataCodingScheme::WaitingMessageIndication

The documentation for this class was generated from the following files:
  • AddOns/Translation/EnumTranslationTable.hpp
  • AddOns/Translation/EnumTranslationTable.cpp
Generated on Wed Jan 25 01:13:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EqualsRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EqualsRule Class Reference
[Auxiliary]

EqualsRule checks whether data item equal to rule item More...

#include <Apoxi/Auxiliary/FilterRule.hpp>

Inheritance diagram for EqualsRule:

[legend]
Collaboration diagram for EqualsRule:

[legend]

Public Types

typedef FilterRule | Base

Public Member Functions

EqualsRule (const DataItem &ruleitem)
EqualsRule ()
virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)
virtual | ~EqualsRule ()

Detailed Description

EqualsRule checks whether data item equal to rule item

Member Typedef Documentation

typedef FilterRule EqualsRule::Base

Constructor & Destructor Documentation

EqualsRule::EqualsRule ( )

EqualsRule::EqualsRule ( const DataItem & ruleitem )

EqualsRule::~EqualsRule ( ) [virtual]

Member Function Documentation

BOOLEAN EqualsRule::ExecuteRule ( const DataItem & dataitem ) [virtual]

ExecuteRule does the actual comparision between the data item given in the argument and the value stored when the filter rule is constructed.

Implements FilterRule.

The documentation for this class was generated from the following files:
  • Auxiliary/FilterRule.hpp
  • Auxiliary/FilterRule.cpp
Generated on Wed Jan 25 01:13:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EquivPlmnLists Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EquivPlmnLists Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for EquivPlmnLists:

[legend]

Public Types

enum | { LengthOfPlmnArray = LENGTH_OF_PLMN_ARRAY }

Public Member Functions

BOOLEAN | IsEmpty ()
EquivPlmnLists | operator= (T_EQUIV_PLMN_LIST equiv_plmn_list)
Plmn & | operator[] (INT index)

Data Fields

INT | length
Plmn | plmn_array [LengthOfPlmnArray]

Member Enumeration Documentation

anonymous enum

Enumerator:
LengthOfPlmnArray

Member Function Documentation

BOOLEAN EquivPlmnLists::IsEmpty ( )

EquivPlmnLists EquivPlmnLists::operator= ( T_EQUIV_PLMN_LIST equiv_plmn_list )

Plmn & EquivPlmnLists::operator[] ( INT index )

Field Documentation

INT EquivPlmnLists::length

Plmn EquivPlmnLists::plmn_array[LengthOfPlmnArray]

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:13:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EventData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

EventData Class Reference

#include <Apoxi/Auxiliary/EventData.hpp>

Inheritance diagram for EventData:

[legend]

Public Member Functions

virtual ~EventData ()

Detailed Description

Base class for data passed to state machine events. Event data always has to be allocated dynamically since it is passed by pointer to the state machine and after having processed it the state machine will free the data.

See also:
StateMachine

Constructor & Destructor Documentation

virtual EventData::~EventData ( ) [inline, virtual]

The documentation for this class was generated from the following file:
  • Auxiliary/EventData.hpp
Generated on Wed Jan 25 01:13:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExecutionContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExecutionContext Class Reference

#include <Apoxi/Kernel/ExecutionContext.hpp>

Inheritance diagram for ExecutionContext:

[legend]
Collaboration diagram for ExecutionContext:

[legend]

Public Types

enum | Type { APPLICATION, SERVICE_THREAD }

Public Member Functions

void | AddDispatcher (UserDispatcher *disp)
BOOLEAN | ContainsDispatcher (const UserDispatcher *disp) const
ExecutionContext ()
virtual const Guid & | GetGuid () const
virtual Type | GetType () const =0
virtual void | RegisterMessage (MsgId msg_id)=0
void | RemoveDispatcher (UserDispatcher *disp)
virtual void | UnregisterMessage (MsgId msg_id)=0
virtual | ~ExecutionContext ()

Static Public Member Functions

static ExecutionContext & | GetCurrentContext ()
static BOOLEAN | IsInContext (const ExecutionContext *context=0)
static void | Wait (const Condition &cond)

Protected Member Functions

virtual BOOLEAN | AcceptMsg (const Message &msg)=0
virtual void | AddTimer (Timer &timer)=0
BOOLEAN | HandleDispatcherList (const Message &msg)
virtual BOOLEAN | HandleMsg (const MessageReferrer &msg_ref)=0
virtual void | RemoveTimer (Timer &timer)=0

Friends

class | MessageRouter
class | Timer

Detailed Description

Class ExecutionContext provides the basic infrastructure for applications and service threads:
  • It holds a list of additional user defined dispatchers.
  • It handles messages, which are registered for this execution context.
  • It processes active waits using conditions. These functionalities establish the basic means of implementing applications and service threads in APOXI.

Member Enumeration Documentation

enum ExecutionContext::Type

Currently there are two types of ApoxiThreads which have an ExecutionContext.

Enumerator:
APPLICATION
SERVICE_THREAD

Constructor & Destructor Documentation

ExecutionContext::ExecutionContext ( )

ExecutionContext::~ExecutionContext ( ) [virtual]

Member Function Documentation

virtual BOOLEAN ExecutionContext::AcceptMsg ( const Message & msg ) [protected, pure virtual]

Tells if msg is accepted.

Implemented in Application, and ServiceThread.

void ExecutionContext::AddDispatcher ( UserDispatcher * disp )

Adds a UserDispatcher to the application and invokes UserDispatcher::RegisterMessages.

virtual void ExecutionContext::AddTimer ( Timer & timer ) [protected, pure virtual]

Adds the timer to the context.

Implemented in Application, and ServiceThread.

BOOLEAN ExecutionContext::ContainsDispatcher ( const UserDispatcher * disp ) const

return Tells if the context contains disp.

ExecutionContext & ExecutionContext::GetCurrentContext ( ) [static]

Returns the ExecutionContext of the currently running ApoxiThread. Critical code which might run in non-ApoxiThread context must call ExecutionContext::IsContextAvailable() before to check if an ExecutionContext is available. Calling this method in any non-ApoxiThread context ends in an assertion.

const Guid & ExecutionContext::GetGuid ( ) const [virtual]

Returns:
GUID to identify the execution context. This is needed for example in AlarmManager to persist the application and re-identify it after re-boot.

virtual Type ExecutionContext::GetType ( ) const [pure virtual]

Returns:
Type of ExectionContext.

Implemented in Application, and ServiceThread.

BOOLEAN ExecutionContext::HandleDispatcherList ( const Message & msg ) [protected]

virtual BOOLEAN ExecutionContext::HandleMsg ( const MessageReferrer & msg_ref ) [protected, pure virtual]

Handles the message which the message referrer msg_ref points to.

Implemented in Application, and ServiceThread.

BOOLEAN ExecutionContext::IsInContext ( const ExecutionContext * context = 0 ) [static]

Checks if the currently active context is equal to context. If context is 0 then it checks if the system is currently in any APOXI context.

virtual void ExecutionContext::RegisterMessage ( MsgId msg_id ) [pure virtual]

Registers a message to the ExecutionContext. Only registered messages are accepted and handled.

Implemented in Application, and ServiceThread.

void ExecutionContext::RemoveDispatcher ( UserDispatcher * disp )

Removes the dispatcher from the application and invokes UserDispatcher::UnregisterMessages

virtual void ExecutionContext::RemoveTimer ( Timer & timer ) [protected, pure virtual]

Removes the timer from the context.

Implemented in Application, and ServiceThread.

virtual void ExecutionContext::UnregisterMessage ( MsgId msg_id ) [pure virtual]

Unregisters a message from the ExecutionContext. Messages with ID msg_id are no more accepted.

Implemented in Application, and ServiceThread.

static void ExecutionContext::Wait ( const Condition & cond ) [inline, static]

Blocking function call until the condition is fulfilled. While waiting, the context is still able to handle messages in parallel.

Parameters:
cond Condition to wait for.

Friends And Related Function Documentation

friend class MessageRouter [friend]

friend class Timer [friend]

The documentation for this class was generated from the following files:
  • Kernel/ExecutionContext.hpp
  • Kernel/ExecutionContext.cpp
Generated on Wed Jan 25 01:14:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExternalCommunicationHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExternalCommunicationHandler Class Reference

#include <Apoxi/Kernel/ExternalCommunicationHandler.hpp>

Inheritance diagram for ExternalCommunicationHandler:

[legend]
Collaboration diagram for ExternalCommunicationHandler:

[legend]

Public Types

enum | HandlerType { SignalHandlerType, AtHandlerType, InvalidHandlerType }

Public Member Functions

ExternalCommunicationHandler ()
virtual HandlerType | GetHandlerType () const =0
virtual void | Init (const AbstractExternalData *external_data=0)
virtual void | PostMessage (const MessageReferrer &msg_ref)
virtual void | RouteData (const AbstractExternalData &external_data)
virtual | ~ExternalCommunicationHandler ()

Member Enumeration Documentation

enum ExternalCommunicationHandler::HandlerType

Enumerator:
SignalHandlerType
AtHandlerType
InvalidHandlerType

Constructor & Destructor Documentation

ExternalCommunicationHandler::ExternalCommunicationHandler ( )

ExternalCommunicationHandler::~ExternalCommunicationHandler ( ) [virtual]

Member Function Documentation

virtual HandlerType ExternalCommunicationHandler::GetHandlerType ( ) const [pure virtual]

Implemented in SignalHandler.

void ExternalCommunicationHandler::Init ( const AbstractExternalData * external_data = 0 ) [virtual]

Reimplemented in SignalHandler.

void ExternalCommunicationHandler::PostMessage ( const MessageReferrer & msg_ref ) [virtual]

PostMessage converts the APOXI-message which is wrapped by MessageReferrer into specific data format of handler and sends this to the stack.

Reimplemented in SignalHandler.

void ExternalCommunicationHandler::RouteData ( const AbstractExternalData & external_data ) [virtual]

RouteData converts incoming data into APOXI-messages and routes them to the APOXI-applications.

Reimplemented in SignalHandler.

The documentation for this class was generated from the following files:
  • Kernel/ExternalCommunicationHandler.hpp
  • Kernel/ExternalCommunicationHandler.cpp
Generated on Wed Jan 25 01:14:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExternalPdpContextInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExternalPdpContextInfoMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ExternalPdpContextInfoMsg:

[legend]
Collaboration diagram for ExternalPdpContextInfoMsg:

[legend]

Public Types

enum | { ID = 18711 }

Public Member Functions

virtual Message * | Clone () const
ExternalPdpContextInfoMsg (const PdpContext::Id &contextId, const PdpContextManager::ExternalContextState &contextState)
const PdpContext::Id & | GetContextId () const
const PdpContextManager::ExternalContextState & | GetContextState () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~ExternalPdpContextInfoMsg ()

Detailed Description

ExternalPdpContextInfoMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ExternalPdpContextInfoMsg::ExternalPdpContextInfoMsg | ( | const PdpContext::Id & | contextId,
 |  | const PdpContextManager::ExternalContextState & | contextState
 | ) |

ExternalPdpContextInfoMsg::~ExternalPdpContextInfoMsg ( ) [virtual]

Member Function Documentation

Message * ExternalPdpContextInfoMsg::Clone ( ) const [virtual]

Implements Message.

const PdpContext::Id& ExternalPdpContextInfoMsg::GetContextId ( ) const [inline]

const PdpContextManager::ExternalContextState& ExternalPdpContextInfoMsg::GetContextState ( ) const [inline]

const MsgMetaData & ExternalPdpContextInfoMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:14:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExternalTimeoutMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExternalTimeoutMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ExternalTimeoutMsg:

[legend]
Collaboration diagram for ExternalTimeoutMsg:

[legend]

Public Types

enum | { ID = 301 }

Public Member Functions

virtual Message * | Clone () const
ExternalTimeoutMsg (Timer *timer)
virtual const MsgMetaData & | GetMetaData () const
Timer * | GetTimer () const
void | SetTimer (Timer *timer)
virtual | ~ExternalTimeoutMsg ()

Detailed Description

This message is sent originally when a AxeTimer times out. Arguments: args[0].t_void ... pointer to the timed out AxeTimer

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ExternalTimeoutMsg::ExternalTimeoutMsg ( Timer * timer )

ExternalTimeoutMsg::~ExternalTimeoutMsg ( ) [virtual]

Member Function Documentation

Message * ExternalTimeoutMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ExternalTimeoutMsg::GetMetaData ( ) const [virtual]

Implements Message.

Timer* ExternalTimeoutMsg::GetTimer ( ) const [inline]

void ExternalTimeoutMsg::SetTimer ( Timer * timer ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:14:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtLanguage Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtLanguage Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Public Member Functions

WString | GetWString () const
void | Set (const WString &str)

Data Fields

UINT8 | val [2]

Member Function Documentation

WString ExtLanguage::GetWString ( ) const [inline]

void ExtLanguage::Set ( const WString & str ) [inline]

Field Documentation

UINT8 ExtLanguage::val[2]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:14:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtLanguageArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtLanguageArray Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [c_sizeof_extlanguagearray]

Field Documentation

UINT8 ExtLanguageArray::val[c_sizeof_extlanguagearray]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:14:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtProactiveCmdCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtProactiveCmdCnfArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for ExtProactiveCmdCnfArg:

[legend]
Collaboration diagram for ExtProactiveCmdCnfArg:

[legend]

Public Types

enum | { ID = 1320 }

Public Member Functions

ExtProactiveCmdCnfArg ()

Static Public Member Functions

static const ExtProactiveCmdCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ExtProactiveCmdCnfArg: reflects arguments of signal SI_EXT_PROACTIVE_CMD_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ExtProactiveCmdCnfArg::ExtProactiveCmdCnfArg ( )

Member Function Documentation

const ExtProactiveCmdCnfArg & ExtProactiveCmdCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:14:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtProactiveCmdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtProactiveCmdIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for ExtProactiveCmdIndArg:

[legend]
Collaboration diagram for ExtProactiveCmdIndArg:

[legend]

Public Types

enum | { ID = 2320 }

Public Member Functions

ExtProactiveCmdIndArg ()
ExtProactiveCmdIndArg (UINT8 result, SimApduData *apdu_data_ptr)
SimApduData * | GetApduDataPtr () const
UINT8 | GetResult () const
void | SetApduDataPtr (SimApduData *apdu_data_ptr)
void | SetResult (UINT8 result)

Static Public Member Functions

static const ExtProactiveCmdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ExtProactiveCmdIndArg: reflects arguments of signal SI_EXT_PROACTIVE_CMD_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ExtProactiveCmdIndArg::ExtProactiveCmdIndArg | ( | UINT8 | result,
 |  | SimApduData * | apdu_data_ptr
 | ) |

ExtProactiveCmdIndArg::ExtProactiveCmdIndArg ( )

Member Function Documentation

const ExtProactiveCmdIndArg & ExtProactiveCmdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

SimApduData* ExtProactiveCmdIndArg::GetApduDataPtr ( ) const [inline]

UINT8 ExtProactiveCmdIndArg::GetResult ( ) const [inline]

void ExtProactiveCmdIndArg::SetApduDataPtr ( SimApduData * apdu_data_ptr ) [inline]

void ExtProactiveCmdIndArg::SetResult ( UINT8 result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:14:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtProactiveCmdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtProactiveCmdReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for ExtProactiveCmdReqArg:

[legend]
Collaboration diagram for ExtProactiveCmdReqArg:

[legend]

Public Types

enum | { ID = 1319 }

Public Member Functions

ExtProactiveCmdReqArg ()
ExtProactiveCmdReqArg (SimApduData *apdu_data_ptr)
SimApduData * | GetApduDataPtr () const
void | SetApduDataPtr (SimApduData *apdu_data_ptr)

Static Public Member Functions

static const ExtProactiveCmdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ExtProactiveCmdReqArg: reflects arguments of signal SI_EXT_PROACTIVE_CMD_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ExtProactiveCmdReqArg::ExtProactiveCmdReqArg ( SimApduData * apdu_data_ptr )

ExtProactiveCmdReqArg::ExtProactiveCmdReqArg ( )

Member Function Documentation

const ExtProactiveCmdReqArg & ExtProactiveCmdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

SimApduData* ExtProactiveCmdReqArg::GetApduDataPtr ( ) const [inline]

void ExtProactiveCmdReqArg::SetApduDataPtr ( SimApduData * apdu_data_ptr ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:14:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtPsdContextListener_SerialTerminal Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtPsdContextListener_SerialTerminal Class Reference

#include <Apoxi/Asc/ExternalPsdContextListener.hpp>

Collaboration diagram for ExtPsdContextListener_SerialTerminal:

[legend]

Public Types

enum | Event { DataAvailable, DataSent }
enum Parity {
ParityNone = ExtPsdContextListener_SioGlueWrapper::ParityNone, ParityOdd = ExtPsdContextListener_SioGlueWrapper::ParityOdd, ParityEven = ExtPsdContextListener_SioGlueWrapper::ParityEvent, ParityMark = ExtPsdContextListener_SioGlueWrapper::ParityMark,
ParitySpace = ExtPsdContextListener_SioGlueWrapper::ParitySpace
}
enum | Result { Ok, Error, NotConnected }

Public Member Functions

Result | Connect (const String &connect_string, UINT32 speed, UINT8 stop_bits, UINT8 data_bits, Parity parity)
Result Disconnect ()
Result | GetConnectionParameters (UINT32 *speed, UINT8 *stop_bits, UINT8 *data_bits, Parity *parity) const
BOOLEAN | IsConnected () const
Result | Read (void *buffer, UINT16 buffer_size, UINT16 &bytes_read)
Result | SetAtMode (BOOLEAN enable)
void | SetListener (ExtPsdContextListener_SerialTerminalListener *listener)
Result | Write (const void *buffer, UINT16 buffer_size, UINT16 &bytes_written)
virtual | ~ExtPsdContextListener_SerialTerminal ()
Destructor.

Static Public Member Functions

static ExtPsdContextListener_SerialTerminal * | GetFreeSerialTerminal ()
static void | ReleaseSerialTerminal (ExtPsdContextListener_SerialTerminal *terminal)

Protected Member Functions

void | OnSignalChange (ExtPsdContextListener_SioGlueWrapper::SignalType type, void *signal_parameter, void *user_parameter)

Protected Attributes

BOOLEAN | m_is_in_use
Defines if a terminal is currently in use or not.

Friends

class | ExtPsdContextListener_SioGlueSignalListener

Detailed Description

ExtPsdContextListener_SerialTerminal is a terminal to the Sio. It can connect and disconnect to the serial IO, and read and write data from and to it.

Member Enumeration Documentation

enum ExtPsdContextListener_SerialTerminal::Event

Enumerator:
DataAvailable
DataSent

enum ExtPsdContextListener_SerialTerminal::Parity

Enumerator:
ParityNone
ParityOdd
ParityEven
ParityMark
ParitySpace

enum ExtPsdContextListener_SerialTerminal::Result

Enumerator:
Ok
Error
NotConnected TBD: check possbile states of terminals!

Constructor & Destructor Documentation

ExtPsdContextListener_SerialTerminal::~ExtPsdContextListener_SerialTerminal ( ) [virtual]

Destructor.

Member Function Documentation

ExtPsdContextListener_SerialTerminal::Result ExtPsdContextListener_SerialTerminal::Connect | ( | const String & | connect_string,
 |  | UINT32 | speed,
 |  | UINT8 | stop_bits,
 |  | UINT8 | data_bits,
 |  | Parity | parity
 | ) |

Opens a connection to the SIO.

Parameters:
connect_string | string to identify b-party, e.g. phone number
speed | connection speed
stop_bits | nr of stop bits
data_bits | nr. of data bits
parity | parity, e.g. no parity

ExtPsdContextListener_SerialTerminal::Result ExtPsdContextListener_SerialTerminal::Disconnect ( )

Closes the connection to the SIO

Returns:
Terminal::Result::c_ok on success

ExtPsdContextListener_SerialTerminal::Result ExtPsdContextListener_SerialTerminal::GetConnectionParameters | ( | UINT32 * | speed,
 |  | UINT8 * | stop_bits,
 |  | UINT8 * | data_bits,
 |  | Parity * | parity
 | ) | const

Reads connection parameters from the SIO

Parameters:
speed | connection speed
stop_bits | nr of stop bits
data_bits | nr. of data bits
parity | parity, e.g. no parity
Returns:
Terminal::Result::c_ok on success

ExtPsdContextListener_SerialTerminal * ExtPsdContextListener_SerialTerminal::GetFreeSerialTerminal ( ) [static]

Returns:
0 if no free ExtPsdContextListener_SerialTerminal can be retrieved.

BOOLEAN ExtPsdContextListener_SerialTerminal::IsConnected ( ) const [inline]

Returns whether the terminal is connected to the SIO or not.

void ExtPsdContextListener_SerialTerminal::OnSignalChange | ( | ExtPsdContextListener_SioGlueWrapper::SignalType | type,
 |  | void * | signal_parameter,
 |  | void * | user_parameter
 | ) | [protected]

Handler for SIO Signals

Parameters:
type | type of SIO signal
signal_parameter | signal specific parameter
user_param | user specific paramerter

ExtPsdContextListener_SerialTerminal::Result ExtPsdContextListener_SerialTerminal::Read | ( | void * | buffer,
 |  | UINT16 | buffer_size,
 |  | UINT16 & | bytes_read
 | ) |

Reads the data available from SIO and writes it into the buffer. if bytes_read is equal to buffer_size, more data may be available. if bytes_read is 0, then no more data is available at the moment, the client will be informed, when data is available by sending a message.

Parameters:
buffer | pointer to the read buffer
buffer_size | size of the read buffer
bytes_read | specifies size of data actually read from the SIO.
Returns:
Terminal::Result::c_ok on success

static void ExtPsdContextListener_SerialTerminal::ReleaseSerialTerminal ( ExtPsdContextListener_SerialTerminal * terminal ) [inline, static]

Release a Terminal, if it is not in use anymore. Be aware, that any use will raise an assertion afterwards. Do not delete the object, but release any reference to it.

Result ExtPsdContextListener_SerialTerminal::SetAtMode ( BOOLEAN enable )

Enable AT Mode

Parameters:
enable desired state of AT mode
Returns:
Terminal::Result::c_ok on success

void ExtPsdContextListener_SerialTerminal::SetListener ( ExtPsdContextListener_SerialTerminalListener * listener ) [inline]

Set listener wich is called on terminal events

ExtPsdContextListener_SerialTerminal::Result ExtPsdContextListener_SerialTerminal::Write | ( | const void * | buffer,
 |  | UINT16 | buffer_size,
 |  | UINT16 & | bytes_written
 | ) |

Writes buffer_size bytes from the buffer to the SIO.

Parameters:
buffer | the buffer to write to the SIO.
buffer_size | size of the buffer handed over
bytes_written | specifies the size of the data written to the SIO.
Returns:
Terminal::Result::c_ok on success

Friends And Related Function Documentation

friend class ExtPsdContextListener_SioGlueSignalListener [friend]

Field Documentation

BOOLEAN ExtPsdContextListener_SerialTerminal::m_is_in_use [protected]

Defines if a terminal is currently in use or not.

The documentation for this class was generated from the following files:
  • Asc/ExternalPsdContextListener.hpp
  • Asc/ExternalPsdContextListener.cpp
Generated on Wed Jan 25 01:14:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtPsdContextListener_SerialTerminalListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtPsdContextListener_SerialTerminalListener Class Reference

#include <Apoxi/Asc/ExternalPsdContextListener.hpp>

Inheritance diagram for ExtPsdContextListener_SerialTerminalListener:

[legend]

Public Member Functions

ExtPsdContextListener_SerialTerminalListener ()
Constructor.
virtual void | OnTerminalEvent (ExtPsdContextListener_SerialTerminal &terminal, ExtPsdContextListener_SerialTerminal::Event event)=0
virtual | ~ExtPsdContextListener_SerialTerminalListener ()
Destructor.

Detailed Description

The abstract class ExtPsdContextListener_SerialTerminalListener is the base for terminal listeners. It defines a call-back interface which is used by the terminal to notify the listener about terminal events.

Constructor & Destructor Documentation

ExtPsdContextListener_SerialTerminalListener::ExtPsdContextListener_SerialTerminalListener ( )

Constructor.

ExtPsdContextListener_SerialTerminalListener::~ExtPsdContextListener_SerialTerminalListener ( ) [virtual]

Destructor.

Member Function Documentation

virtual void ExtPsdContextListener_SerialTerminalListener::OnTerminalEvent | ( | ExtPsdContextListener_SerialTerminal & | terminal,
 |  | ExtPsdContextListener_SerialTerminal::Event | event
 | ) | [pure virtual]

Call-back method for terminal events

Parameters:
terminal | Terminal which caused event
event | Occured event

Implemented in ExtPsdContextListenerImpl_SerialTerminalListener.

The documentation for this class was generated from the following files:
  • Asc/ExternalPsdContextListener.hpp
  • Asc/ExternalPsdContextListener.cpp
Generated on Wed Jan 25 01:14:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtPsdContextListener_SioGlueSignalListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtPsdContextListener_SioGlueSignalListener Class Reference

#include <Apoxi/Asc/ExternalPsdContextListener.hpp>

Collaboration diagram for ExtPsdContextListener_SioGlueSignalListener:

[legend]

Public Member Functions

ExtPsdContextListener_SioGlueSignalListener ()
Constructor.
void | Init (ExtPsdContextListener_SerialTerminal *terminal)
Initialize the class by setting the terminal.
void | OnSignalChange (ExtPsdContextListener_SioGlueWrapper::SignalType type, void *signal_parameter, void *user_parameter)
virtual | ~ExtPsdContextListener_SioGlueSignalListener ()
Destructor.

Static Public Member Functions

static void | sio_glue_handler (glue_sig_t sig_code, void *sig_param, void *user_param)

Detailed Description

ExtPsdContextListener_SioGlueSignalListener fowards SIO callbacks to a listening ExtPsdContextListener_SerialTerminal

Constructor & Destructor Documentation

ExtPsdContextListener_SioGlueSignalListener::ExtPsdContextListener_SioGlueSignalListener ( )

Constructor.

ExtPsdContextListener_SioGlueSignalListener::~ExtPsdContextListener_SioGlueSignalListener ( ) [virtual]

Destructor.

Member Function Documentation

void ExtPsdContextListener_SioGlueSignalListener::Init ( ExtPsdContextListener_SerialTerminal * terminal ) [inline]

Initialize the class by setting the terminal.

void ExtPsdContextListener_SioGlueSignalListener::OnSignalChange | ( | ExtPsdContextListener_SioGlueWrapper::SignalType | type,
 |  | void * | signal_parameter,
 |  | void * | user_parameter
 | ) |

wrapper for callbacks of Sio glue layer; original interface: static void sio_glue_handler (glue_sig_t sig_code, void *sig_param, void *user_param)

Parameters:
type | type of SIO signal, e.g. changed terminal lines
signal_parameter | signal specific parameter e.g. state of terminal lines, see ExtPsdContextListener_SioGlueWrapper::TermIos
user_parameter | user specific parameter, e.g. a pointer to a signal handler class

void ExtPsdContextListener_SioGlueSignalListener::sio_glue_handler | ( | glue_sig_t | sig_code,
 |  | void * | sig_param,
 |  | void * | user_param
 | ) | [static]

Define the function pointer for the callback from the Sio Glue Layer

Parameters:
sig_code | specifies type of SIO signal, e.g. changed terminal lines
signal_param | signal specific parameter e.g. state of terminal lines, see ExtPsdContextListener_SioGlueWrapper::TermIos
user_param | user specific parameter, e.g. pointer to a signal handler class

The documentation for this class was generated from the following files:
  • Asc/ExternalPsdContextListener.hpp
  • Asc/ExternalPsdContextListener.cpp
Generated on Wed Jan 25 01:14:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtPsdContextListener_SioGlueWrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtPsdContextListener_SioGlueWrapper Class Reference

#include <Apoxi/Asc/ExternalPsdContextListener.hpp>

Public Types

enum | LineState { SioLineOff = SIO_LINE_OFF, SioLineOn = SIO_LINE_ON, SioLineDontCare = SIO_LINE_ON+1 }
enum Parity {
ParityNone = SIO_PARITY_NONE, ParityOdd = SIO_PARITY_ODD, ParityEvent = SIO_PARITY_EVEN, ParityMark = SIO_PARITY_MARK,
ParitySpace = SIO_PARITY_SPACE
}
enum Result {
SioOk = SIO_STAT_OK, SioError = SIO_STAT_ERROR, SioEnoughBuffer = SIO_STAT_WATER_HIGH, SioBufferLow = SIO_STAT_WATER_LOW,
SioAtBusy = SIO_STAT_AT_BUSY, SioAtComplete = SIO_STAT_AT_COMPL
}
enum | SignalStartStop { SioExecModeStart = GLUE_EXECMODE_START, SioExecModeKill = GLUE_EXECMODE_KILL, SioSigvalLast = GLUE_SIGVAL_LAST }
enum SignalType {
SioDataReq = GLUE_SIG_DATAREQ, SioTermIos = GLUE_SIG_TERMIOS, SioExecMode = GLUE_SIG_EXECMODE, SioClose = GLUE_SIG_CLOSE,
SioOpen = GLUE_SIG_OPEN, SioLast = GLUE_SIG_LAST
}

Static Public Member Functions

static Result | Close (const SioCommId &comm_id)
static Result | GetAtMode (const SioCommId &comm_id, BOOLEAN &at_mode)
static Result | GetBufferSizes (const SioCommId &comm_id, UINT16 &free, UINT16 &size)
static Result | GetStatus (const SioCommId &comm_id, TermIos &state)
static Result | Open (const String &device_name, SioCommId &comm_id)
static Result | ReadData (const SioCommId &comm_id, void *buffer, UINT16 size, UINT16 &read)
static Result | RegisterSignalListener (const SioCommId &comm_id, ExtPsdContextListener_SioGlueSignalListener &listener)
static Result | SetAtMode (const SioCommId &comm_id, BOOLEAN at_mode)
static Result | SetStatus (const SioCommId &comm_id, const TermIos &state)
static Result | UnRegisterSignalListener (const SioCommId &comm_id, const ExtPsdContextListener_SioGlueSignalListener &listener)
static Result | WriteData (const SioCommId &comm_id, const void *buffer, UINT16 size, UINT16 &written)

Data Structures

struct | SioCommId
struct | TermIos

Detailed Description

Wraps the c-coded serial input output layer of the mobile phone stack.

Member Enumeration Documentation

enum ExtPsdContextListener_SioGlueWrapper::LineState

Status of the V.24 lines.

Enumerator:
SioLineOff | Line is off.
SioLineOn | Line is on.
SioLineDontCare | Don't care/don'set line state.

enum ExtPsdContextListener_SioGlueWrapper::Parity

Parity values.

Enumerator:
ParityNone
ParityOdd
ParityEvent
ParityMark
ParitySpace

enum ExtPsdContextListener_SioGlueWrapper::Result

Return values of the GlueWrapper.

Enumerator:
SioOk | Success.
SioError | An error occurred.
SioEnoughBuffer | Sufficient buffer space is available.
SioBufferLow | The buffer space is in critical state.
SioAtBusy | AT response is incomplete.
SioAtComplete | Complete AT response.

enum ExtPsdContextListener_SioGlueWrapper::SignalStartStop

List of the signal values from the glue layer to the glue client.

Enumerator:
SioExecModeStart | Activate the client.
SioExecModeKill | Terminate the client.
SioSigvalLast

enum ExtPsdContextListener_SioGlueWrapper::SignalType

Signal type of Sio, which is forwarded to the the Listeners

Enumerator:
SioDataReq | Data from the modem are available.
SioTermIos | Changes of the port settings.
SioExecMode | Tell the glue client the expected execution mode.
SioClose | Switch off the hardware device.
SioOpen | Switch on the hardware device.
SioLast

Member Function Documentation

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::Close ( const SioCommId & comm_id ) [static]

Close will deallocate the sio clue descriptor. To deallocate means to make the descriptor available for return by subsequent calls to Open().

Parameters:
comm_id the handle of the sio client that shall be closed.
Returns:
returns c_sio_ok on success, or c_sio_error if an error occurred like invalid descriptor.

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::GetAtMode | ( | const SioCommId & | comm_id,
 |  | BOOLEAN & | at_mode
 | ) | [static]

Determines if the connection defined by the comm_id parameter is either in online (data is transfered) or offline (at commmands are being transfered) mode.

Parameters:
comm_id | the handle of the sio client.
at_mode | defines if at mode is on or off.

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::GetBufferSizes | ( | const SioCommId & | comm_id,
 |  | UINT16 & | free,
 |  | UINT16 & | size
 | ) | [static]

Get information about the size and fress space of the internal buffer of the sio.

Parameters:
comm_id | the handle of the sio client.
free | specifies the number of free bytes of the internal buffer of the sio.
size | specifies the overall size of the internal buffer of the sio.

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::GetStatus | ( | const SioCommId & | comm_id,
 |  | TermIos & | state
 | ) | [static]

Returns the current status of the connection (e.g. parity, data_bits, stop_bit, ...) of the sio client and allows to get the states of the v24 serial lines.

Parameters:
comm_id | the handle of the sio client
state | the current state of the connection of the sio client.

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::Open | ( | const String & | device_name,
 |  | SioCommId & | comm_id
 | ) | [static]

Open will open the GlueWrapper and connect to Sio.

Parameters:
comm_id | the handle of the sio client that shall be opened.
device_name | the name of the terminal by which the client is identified.
Returns:
returns c_sio_ok on success, or c_sio_error if an error occurred like unknown device name or multiple registration

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::ReadData | ( | const SioCommId & | comm_id,
 |  | void * | buffer,
 |  | UINT16 | size,
 |  | UINT16 & | read
 | ) | [static]

ReadData() attempts to read up to size bytes into the buffer starting at buffer the beginning of buffer.

Parameters:
comm_id | the handle of the sio client.
buffer | [OUT] Pointer to buffer
size | [IN] size of buffer
read | [OUT] the number of bytes read from Sio and written into buffer
Returns:
returns c_sio_ok on success, or c_sio_error if an error occured like GlueWrapper is closed

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::RegisterSignalListener | ( | const SioCommId & | comm_id,
 |  | ExtPsdContextListener_SioGlueSignalListener & | listener
 | ) | [static]

Registers the callback method of the ExtPsdContextListener_SioGlueSignalListener at the sio glue layer.

Parameters:
comm_id | the handle of the sio client for which a callback is registered.
listener | the listener to listen on callbacks of the sio.

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::SetAtMode | ( | const SioCommId & | comm_id,
 |  | BOOLEAN | at_mode
 | ) | [static]

Sets the terminal connection either into online (data is transfered) or offline (at commmands are being transfered) mode.

Parameters:
comm_id | the handle of the sio client.
at_mode | defines if at mode shall be switched on or off.

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::SetStatus | ( | const SioCommId & | comm_id,
 |  | const TermIos & | state
 | ) | [static]

Sets the options for the connection (e.g. parity, data_bits, stop_bit, ...) and allows to switch lines on and off.

Parameters:
comm_id | the handle of the sio client
state | the state that shall be set for the connection of the sio client.

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::UnRegisterSignalListener | ( | const SioCommId & | comm_id,
 |  | const ExtPsdContextListener_SioGlueSignalListener & | listener
 | ) | [static]

Unregisters the callback method of the ExtPsdContextListener_SioGlueSignalListener from the sio glue layer.

Parameters:
comm_id | the handle of the sio client for which the callback method is unregistered.
listener | the listener to stop listening on callbacks of the sio.

ExtPsdContextListener_SioGlueWrapper::Result ExtPsdContextListener_SioGlueWrapper::WriteData | ( | const SioCommId & | comm_id,
 |  | const void * | buffer,
 |  | UINT16 | size,
 |  | UINT16 & | written
 | ) | [static]

WriteData() writes up to size bytes to the glue layer starting at buffer the beginning of buffer.

Parameters:
comm_id | the handle of the sio client.
buffer | [OUT] Pointer to buffer
size | [IN] size of buffer
written | [OUT] the number of bytes written to Sio
Returns:
returns c_sio_enough_buffer, c_sio_buffer_low on success, or c_sio_error if an error occured like GlueWrapper is closed

The documentation for this class was generated from the following files:
  • Asc/ExternalPsdContextListener.hpp
  • Asc/ExternalPsdContextListener.cpp
Generated on Wed Jan 25 01:14:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtPsdContextListener_SioGlueWrapper::SioCommId Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ExtPsdContextListener_SioGlueWrapper::SioCommId

ExtPsdContextListener_SioGlueWrapper::SioCommId Struct Reference

#include <Apoxi/Asc/ExternalPsdContextListener.hpp>

Friends

class ExtPsdContextListener_SioGlueWrapper

Friends And Related Function Documentation

friend class ExtPsdContextListener_SioGlueWrapper [friend]

The documentation for this struct was generated from the following file:
  • Asc/ExternalPsdContextListener.hpp
Generated on Wed Jan 25 01:14:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtPsdContextListener_SioGlueWrapper::TermIos Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ExtPsdContextListener_SioGlueWrapper::TermIos

ExtPsdContextListener_SioGlueWrapper::TermIos Struct Reference

#include <Apoxi/Asc/ExternalPsdContextListener.hpp>

Public Member Functions

LineState | GetCts () const
Get modem flow control status.
UINT8 | GetDataBits () const
Get data bits.
LineState | GetDcd () const
Get carrier status.
LineState | GetDsr () const
Get modem connection staus.
LineState | GetDtr () const
Get terminal connection status. (read only).
Parity | GetParity () const
Get parity.
LineState | GetRi () const
Get ring indicator.
LineState | GetRts () const
Get flow control status. (read only).
UINT32 | GetSpeed () const
Get connection speed.
UINT8 | GetStopBits () const
Get stop bits.
void | SetCts (LineState state)
Set modem flow control status.
void | SetDataBits (UINT8 data_bits)
Set data bits.
void | SetDcd (LineState state)
Set carrier status.
void | SetDsr (LineState state)
Get modem connection staus.
void | SetParity (Parity parity)
Set parity.
void | SetRi (LineState state)
Set ring indicator.
void | SetSpeed (UINT32 speed)
Set connection speed.
void | SetStopBits (UINT8 stop_bits)
Set stop bits.
TermIos (sio_termios_t *sio_termios)
TermIos ()
Constructor.
~TermIos ()
Destructor.

Data Fields

friend | ExtPsdContextListener_SioGlueWrapper

Detailed Description

V.24 signal lines, see glue_termios_t;

Constructor & Destructor Documentation

ExtPsdContextListener_SioGlueWrapper::TermIos::TermIos ( )

Constructor.

ExtPsdContextListener_SioGlueWrapper::TermIos::TermIos ( sio_termios_t * sio_termios )

Constructor

Parameters:
sio_termios Structure containing the termios signals

ExtPsdContextListener_SioGlueWrapper::TermIos::~TermIos ( )

Destructor.

Member Function Documentation

LineState ExtPsdContextListener_SioGlueWrapper::TermIos::GetCts ( ) const [inline]

Get modem flow control status.

UINT8 ExtPsdContextListener_SioGlueWrapper::TermIos::GetDataBits ( ) const [inline]

Get data bits.

LineState ExtPsdContextListener_SioGlueWrapper::TermIos::GetDcd ( ) const [inline]

Get carrier status.

LineState ExtPsdContextListener_SioGlueWrapper::TermIos::GetDsr ( ) const [inline]

Get modem connection staus.

LineState ExtPsdContextListener_SioGlueWrapper::TermIos::GetDtr ( ) const [inline]

Get terminal connection status. (read only).

Parity ExtPsdContextListener_SioGlueWrapper::TermIos::GetParity ( ) const [inline]

Get parity.

LineState ExtPsdContextListener_SioGlueWrapper::TermIos::GetRi ( ) const [inline]

Get ring indicator.

LineState ExtPsdContextListener_SioGlueWrapper::TermIos::GetRts ( ) const [inline]

Get flow control status. (read only).

UINT32 ExtPsdContextListener_SioGlueWrapper::TermIos::GetSpeed ( ) const [inline]

Get connection speed.

UINT8 ExtPsdContextListener_SioGlueWrapper::TermIos::GetStopBits ( ) const [inline]

Get stop bits.

void ExtPsdContextListener_SioGlueWrapper::TermIos::SetCts ( LineState state ) [inline]

Set modem flow control status.

void ExtPsdContextListener_SioGlueWrapper::TermIos::SetDataBits ( UINT8 data_bits ) [inline]

Set data bits.

void ExtPsdContextListener_SioGlueWrapper::TermIos::SetDcd ( LineState state ) [inline]

Set carrier status.

void ExtPsdContextListener_SioGlueWrapper::TermIos::SetDsr ( LineState state ) [inline]

Get modem connection staus.

void ExtPsdContextListener_SioGlueWrapper::TermIos::SetParity ( Parity parity ) [inline]

Set parity.

void ExtPsdContextListener_SioGlueWrapper::TermIos::SetRi ( LineState state ) [inline]

Set ring indicator.

void ExtPsdContextListener_SioGlueWrapper::TermIos::SetSpeed ( UINT32 speed ) [inline]

Set connection speed.

void ExtPsdContextListener_SioGlueWrapper::TermIos::SetStopBits ( UINT8 stop_bits ) [inline]

Set stop bits.

Field Documentation

friend ExtPsdContextListener_SioGlueWrapper::TermIos::ExtPsdContextListener_SioGlueWrapper

The documentation for this struct was generated from the following files:
  • Asc/ExternalPsdContextListener.hpp
  • Asc/ExternalPsdContextListener.cpp
Generated on Wed Jan 25 01:14:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtPsdContextListenerImpl_SerialTerminalListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ExtPsdContextListenerImpl_SerialTerminalListener Class Reference

#include <Apoxi/Asc/ExternalPsdContextListener.hpp>

Inheritance diagram for ExtPsdContextListenerImpl_SerialTerminalListener:

[legend]
Collaboration diagram for ExtPsdContextListenerImpl_SerialTerminalListener:

[legend]

Public Types

typedef ExtPsdContextListener_SerialTerminalListener | Base

Public Member Functions

ExtPsdContextListenerImpl_SerialTerminalListener ()
Constructor.
virtual void | OnTerminalEvent (ExtPsdContextListener_SerialTerminal &terminal, ExtPsdContextListener_SerialTerminal::Event event)
void | TerminateExtPsdContext ()
virtual | ~ExtPsdContextListenerImpl_SerialTerminalListener ()
Destructor.

Detailed Description

Implements the interface ExtPsdContextListener_SerialTerminalListener. ExtPsdContextListenerImpl_SerialTerminalListener maps terminal events to FromStack messages with appropriate arguments.

Member Typedef Documentation

typedef ExtPsdContextListener_SerialTerminalListener ExtPsdContextListenerImpl_SerialTerminalListener::Base

Constructor & Destructor Documentation

ExtPsdContextListenerImpl_SerialTerminalListener::ExtPsdContextListenerImpl_SerialTerminalListener ( )

Constructor.

ExtPsdContextListenerImpl_SerialTerminalListener::~ExtPsdContextListenerImpl_SerialTerminalListener ( ) [virtual]

Destructor.

Member Function Documentation

void ExtPsdContextListenerImpl_SerialTerminalListener::OnTerminalEvent | ( | ExtPsdContextListener_SerialTerminal & | terminal,
 |  | ExtPsdContextListener_SerialTerminal::Event | event
 | ) | [virtual]

See also:
SerialTerminlListener::OnTerminalEvent

Implements ExtPsdContextListener_SerialTerminalListener.

void ExtPsdContextListenerImpl_SerialTerminalListener::TerminateExtPsdContext ( )

The documentation for this class was generated from the following files:
  • Asc/ExternalPsdContextListener.hpp
  • Asc/ExternalPsdContextListener.cpp
Generated on Wed Jan 25 01:14:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatDirectoryIteratorImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatDirectoryIteratorImp Class Reference
[FAT filesystem support]

Directory iterator implementation for FAT storage device. More...

#include <Apoxi/AddOns/AfsFat/FatDirectoryIteratorImp.hpp>

Inheritance diagram for FatDirectoryIteratorImp:

[legend]
Collaboration diagram for FatDirectoryIteratorImp:

[legend]

Protected Member Functions

virtual DirectoryIterator & | AtomicIncrement ()
FatDirectoryIteratorImp (const Pathname &dir_pathname, const WString &device_id, const FileFilterPtr &filter)
virtual | ~FatDirectoryIteratorImp ()
Destroys the FAT directory iterator.

Friends

class | FatStorageDeviceImp

Detailed Description

Directory iterator implementation for FAT storage device.

Class FatDirectoryIteratorImp implements the directory iterator for the FAT storage devices.

Constructor & Destructor Documentation

FatDirectoryIteratorImp::FatDirectoryIteratorImp | ( | const Pathname & | dir_pathname,
 |  | const WString & | device_id,
 |  | const FileFilterPtr & | filter
 | ) | [explicit, protected]

FatDirectoryIteratorImp::~FatDirectoryIteratorImp ( ) [protected, virtual]

Destroys the FAT directory iterator.

Member Function Documentation

DirectoryIterator & FatDirectoryIteratorImp::AtomicIncrement ( ) [protected, virtual]

Increments the iterator to point to the next pathname in the directory and returns a reference to itself. This increment operation does not consider the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

Returns:
Reference to itself incremented to point to the next pathname or to the root pathname signaling the end iterator.

Implements DirectoryIterator.

Friends And Related Function Documentation

friend class FatStorageDeviceImp [friend]

The documentation for this class was generated from the following files:
  • AddOns/AfsFat/FatDirectoryIteratorImp.hpp
  • AddOns/AfsFat/FatDirectoryIteratorImp.cpp
Generated on Wed Jan 25 01:14:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatFile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatFile Class Reference
[FAT filesystem support]

#include <Apoxi/AddOns/AfsFat/FatFile.hpp>

Collaboration diagram for FatFile:

[legend]

Public Member Functions

BOOLEAN | AssureInitialized (const CHAR *filename) const
BOOLEAN | Close ()
BOOLEAN | Create (const CHAR *filename, UINT32 size)
BOOLEAN | CreateStreaming (const CHAR *filename)
BOOLEAN | Delete ()
FatFile ()
BOOLEAN | GetCreationTimestamp (FatTimeRecord &time_stamp) const
BOOLEAN | GetFileSize (UINT32 &file_size) const
BOOLEAN | GetHandle (FatHandle &file_handle) const
BOOLEAN | GetLastAccessTimestamp (FatTimeRecord &time_stamp) const
FatError | GetLastError () const
BOOLEAN | GetLastUpdateTimestamp (FatTimeRecord &time_stamp) const
BOOLEAN | IsArchive () const
BOOLEAN | IsHidden () const
BOOLEAN | IsInitialized () const
BOOLEAN | IsOpen () const
BOOLEAN | IsReadOnly () const
BOOLEAN | Open (const CHAR *filename, FatOpenMode mode)
BOOLEAN | OpenStreaming (const CHAR *filename, FatOpenMode mode)
BOOLEAN | Read (void HUGE *buffer, UINT32 offset, UINT32 max_no_bytes, UINT32 &bytes_read)
BOOLEAN | Read (void HUGE *buffer, UINT32 offset, UINT32 bytes)
BOOLEAN | ReadStreaming (void HUGE *buffer, UINT32 count, UINT32 bytes_read)
BOOLEAN | ReadStreamingAsync (void HUGE *buffer, UINT32 count, void(callback_func)(File::Error result, UINT32 bytes_operated))
BOOLEAN | Rename (const CHAR *new_filename)
BOOLEAN | Resize (UINT32 new_size)
BOOLEAN | SetArchive (BOOLEAN archive)
BOOLEAN | SetHidden (BOOLEAN hidden)
BOOLEAN | SetReadOnly (BOOLEAN read_only)
BOOLEAN | Write (const void HUGE *buffer, UINT32 offset, UINT32 no_bytes)
BOOLEAN | WriteStreaming (const void HUGE *buffer, UINT32 count)
BOOLEAN | WriteStreamingAsync (const void HUGE *buffer, UINT32 count, void(callback_func)(File::Error result, UINT32 bytes_operated))
~FatFile ()

Static Public Member Functions

static void | StreamingDriverReadCallback (INT16 result, void *client_arg)
static void | StreamingDriverWriteCallback (INT16 result, void *client_arg)

Constructor & Destructor Documentation

FatFile::FatFile ( )

FatFile::~FatFile ( )

Member Function Documentation

BOOLEAN FatFile::AssureInitialized ( const CHAR * filename ) const

Assures that after the method call the file is initialized.

BOOLEAN FatFile::Close ( )

BOOLEAN FatFile::Create | ( | const CHAR * | filename,
 |  | UINT32 | size
 | ) |

BOOLEAN FatFile::CreateStreaming ( const CHAR * filename )

BOOLEAN FatFile::Delete ( )

BOOLEAN FatFile::GetCreationTimestamp ( FatTimeRecord & time_stamp ) const

BOOLEAN FatFile::GetFileSize ( UINT32 & file_size ) const

BOOLEAN FatFile::GetHandle ( FatHandle & file_handle ) const

Retrieves the file handle. The file handle can only be retrieved if the file is open.

BOOLEAN FatFile::GetLastAccessTimestamp ( FatTimeRecord & time_stamp ) const

FatError FatFile::GetLastError ( ) const

BOOLEAN FatFile::GetLastUpdateTimestamp ( FatTimeRecord & time_stamp ) const

BOOLEAN FatFile::IsArchive ( ) const

BOOLEAN FatFile::IsHidden ( ) const

BOOLEAN FatFile::IsInitialized ( ) const [inline]

Tells if the file is initialized, i.e. if it has a valid file handle associated. A valid file handle is assigned when the file is successfully opened or created.

BOOLEAN FatFile::IsOpen ( ) const

BOOLEAN FatFile::IsReadOnly ( ) const

BOOLEAN FatFile::Open | ( | const CHAR * | filename,
 |  | FatOpenMode | mode
 | ) |

BOOLEAN FatFile::OpenStreaming | ( | const CHAR * | filename,
 |  | FatOpenMode | mode
 | ) |

BOOLEAN FatFile::Read | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_no_bytes,
 |  | UINT32 & | bytes_read
 | ) |

BOOLEAN FatFile::Read | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | bytes
 | ) |

BOOLEAN FatFile::ReadStreaming | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 | bytes_read
 | ) |

BOOLEAN FatFile::ReadStreamingAsync | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | void(callback_func)(File::Error result, UINT32 bytes_operated) |
 | ) |

BOOLEAN FatFile::Rename ( const CHAR * new_filename )

BOOLEAN FatFile::Resize ( UINT32 new_size )

BOOLEAN FatFile::SetArchive ( BOOLEAN archive )

BOOLEAN FatFile::SetHidden ( BOOLEAN hidden )

BOOLEAN FatFile::SetReadOnly ( BOOLEAN read_only )

void FatFile::StreamingDriverReadCallback | ( | INT16 | result,
 |  | void * | client_arg
 | ) | [static]

void FatFile::StreamingDriverWriteCallback | ( | INT16 | result,
 |  | void * | client_arg
 | ) | [static]

BOOLEAN FatFile::Write | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | no_bytes
 | ) |

BOOLEAN FatFile::WriteStreaming | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

BOOLEAN FatFile::WriteStreamingAsync | ( | const void HUGE * | buffer,
 |  | UINT32 | count,
 |  | void(callback_func)(File::Error result, UINT32 bytes_operated) |
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/AfsFat/FatFile.hpp
  • AddOns/AfsFat/FatFile.cpp
Generated on Wed Jan 25 01:14:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatFileImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatFileImp Class Reference
[FAT filesystem support]

File implementation for FAT filesystem (FAT) storage devices More...

#include <Apoxi/AddOns/AfsFat/FatFileImp.hpp>

Inheritance diagram for FatFileImp:

[legend]
Collaboration diagram for FatFileImp:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | Create (UINT32 size)
virtual BOOLEAN | CreateDir ()
virtual BOOLEAN | CreateStreaming ()
virtual BOOLEAN | Delete ()
virtual BOOLEAN | GetAccessDate (Date &date) const
virtual BOOLEAN | GetAttributes (Attributes &attributes) const
virtual BOOLEAN | GetCreationDate (Date &date) const
virtual BOOLEAN | GetModificationDate (Date &date) const
virtual BOOLEAN | GetNativeProperty (UINT prop_Id, void *val) const
virtual BOOLEAN | GetSize (UINT32 &size) const
virtual const WString & | GetStorageDeviceId () const
virtual BOOLEAN | IsArchive () const
virtual BOOLEAN | IsHidden () const
virtual BOOLEAN | IsOpen () const
Tells if the file is open.
virtual BOOLEAN | IsReadOnly () const
virtual BOOLEAN | Open (OpenMode open_mode)
virtual BOOLEAN | OpenStreaming (OpenMode open_mode)
virtual BOOLEAN | Rename (const WString &new_name)
virtual BOOLEAN | Resize (UINT32 new_size, UINT32 copy_buf_size)
virtual BOOLEAN | SetArchive (BOOLEAN archive)
virtual BOOLEAN | SetHidden (BOOLEAN hidden)
virtual BOOLEAN | SetReadOnly (BOOLEAN read_only)

Static Public Attributes

static const UINT | PROP_NATIVEHANDLE = 0

Protected Member Functions

virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 count)
virtual BOOLEAN | DoReadStreaming (void HUGE *buffer, UINT32 count, UINT32 &bytes_read)
virtual BOOLEAN | DoReadStreamingAsync (void HUGE *buffer, UINT32 count, StreamingCallback)
virtual BOOLEAN | DoWrite (const void HUGE *buffer, UINT32 offset, UINT32 count)
virtual BOOLEAN | DoWriteStreaming (const void HUGE *buffer, UINT32 count)
virtual BOOLEAN | DoWriteStreamingAsync (const void HUGE *buffer, UINT32 count, StreamingCallback)
FatFileImp (const Pathname &pathname, const WString &device_id)
virtual const FileState & | MyState () const
Returns the constant state of the constant file.
virtual FileState & | MyState ()
Returns the state of the file.
virtual | ~FatFileImp ()

Static Protected Member Functions

static Date | DateFromDriverDate (UINT16 date)
static FatOpenMode | TranslateOpenMode (OpenMode open_mode)

Friends

class | FatStorageDeviceImp

Detailed Description

File implementation for FAT filesystem (FAT) storage devices

Class FatFileImp represents a file stored on a FAT storage device supporting the root file system interface.

See also:
File

Constructor & Destructor Documentation

FatFileImp::FatFileImp | ( | const Pathname & | pathname,
 |  | const WString & | device_id
 | ) | [protected]

FatFileImp::~FatFileImp ( ) [protected, virtual]

Member Function Documentation

BOOLEAN FatFileImp::Close ( ) [virtual]

Closes a previously opened file. An overriding method must call this base implementation at the end of its implementation if the file could be closed successfully to assure that the counter of open files gets set properly.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FatFileImp::Create ( UINT32 size ) [virtual]

Creates a physical file with path m_path and initial size specified in bytes. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents operations in mode ReadAndWriteMode and its internal file position is set to 0, independent of the size argument. The file grows itself if it is written beyond its actual size. Creating an empty file with size 0 is allowed. For shrinking or growing the file use method Resize(). An overriding method must call this base implementation at the end of its implementation if the file could be created successfully to assure that the counter of open files gets set properly. This is a file operation and of course the file must not be open on call.

Parameters:
size The initial size of the new file.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FatFileImp::CreateDir ( ) [virtual]

Creates a physical directory with path m_path. The last segment of m_path is taken as name of the new directory to create. The directory can only be created if all the directories specified in m_path already exist and the new directory doesn't exist yet. This is a file operation and of course the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FatFileImp::CreateStreaming ( ) [virtual]

Creates a physical file with path m_path. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents in streaming mode.

This means that only the methods:

  • WriteStreaming
  • WriteStreamingAsync
  • ReadStreaming
  • ReadStreamingAsync and not the methods Read() or Write() can be used with this file.

Implements File.

Date FatFileImp::DateFromDriverDate ( UINT16 date ) [inline, static, protected]

BOOLEAN FatFileImp::Delete ( ) [virtual]

Deletes the file or directory. If the file is actually a directory, then it must be empty in order to be deleted. If the file or directory does not exist the method fails. The method succeeds if and only if the file or directory could successfully be deleted. This is a file operation, the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FatFileImp::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [protected, virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)

Implements File.

BOOLEAN FatFileImp::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 count)

Implements File.

BOOLEAN FatFileImp::DoReadStreaming | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 & | bytes_read
 | ) | [protected, virtual]

See also:
ReadStreaming(void HUGE *buffer, UINT32 count, UINT32 &bytes_read);

Implements File.

virtual BOOLEAN FatFileImp::DoReadStreamingAsync | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [protected, virtual]

See also:
ReadStreamingAsync(void HUGE *buffer, UINT32 count, StreamingCallback);

Implements File.

BOOLEAN FatFileImp::DoWrite | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
Write(const void HUGE *buffer, UINT32 offset, UINT32 count)

Implements File.

BOOLEAN FatFileImp::DoWriteStreaming | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
WriteStreaming(const void HUGE *buffer, UINT32 count);

Implements File.

virtual BOOLEAN FatFileImp::DoWriteStreamingAsync | ( | const void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [protected, virtual]

See also:
WriteStreamingAsync(const void HUGE *buffer, UINT32 count, StreamingCallback);

Implements File.

BOOLEAN FatFileImp::GetAccessDate ( Date & date ) const [virtual]

If the access date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open. Please override this method for storage devices which support retrieving the date of the last file access.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

BOOLEAN FatFileImp::GetAttributes ( Attributes & attributes ) const [virtual]

BOOLEAN FatFileImp::GetCreationDate ( Date & date ) const [virtual]

If the creation date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FatFileImp::GetModificationDate ( Date & date ) const [virtual]

If the modification date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FatFileImp::GetNativeProperty | ( | UINT | prop_Id,
 |  | void * | val
 | ) | const [virtual]

Retrieves the native property identified by prop_Id via argument val. If the property is not supported by the native file (and therefore can't be retrieved) the method fails. The properties that the native file supports are defined by the derived class that implements the native file support. E.g., for knowing which properties a flash file supports look at the documentation of class FlashFileImp, there the respective property IDs are defined. It is crucial that the given property ID prop_Id and the receiving value val really match!

Parameters:
prop_Id | ID of the native file property to retrieve, defined in the derived class that implements the native file support.
val | Valid pointer to the value object that shall be set to the current value of the file property with id prop_Id.
Returns:
Tells if the file property could be retrieved.

Reimplemented from File.

BOOLEAN FatFileImp::GetSize ( UINT32 & size ) const [virtual]

If the file size can be retrieved then size is set to the actual file size in bytes and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

const WString & FatFileImp::GetStorageDeviceId ( ) const [virtual]

Returns the storage device ID of the device associated to this file class.

Implements File.

BOOLEAN FatFileImp::IsArchive ( ) const [virtual]

Tells if the file is archive. This is a file operation, the file must not be open on call.

Implements File.

BOOLEAN FatFileImp::IsHidden ( ) const [virtual]

Tells if the file is hidden. This is a file operation, the file must not be open on call.

Implements File.

BOOLEAN FatFileImp::IsOpen ( ) const [virtual]

Tells if the file is open.

Implements File.

BOOLEAN FatFileImp::IsReadOnly ( ) const [virtual]

Tells if the file is read only. This is a file operation, the file must not be open on call.

Implements File.

const File::FileState & FatFileImp::MyState ( ) const [protected, virtual]

Returns the constant state of the constant file.

Implements File.

File::FileState & FatFileImp::MyState ( ) [protected, virtual]

Returns the state of the file.

Implements File.

BOOLEAN FatFileImp::Open ( OpenMode open_mode ) [virtual]

BOOLEAN FatFileImp::OpenStreaming ( OpenMode open_mode ) [virtual]

BOOLEAN FatFileImp::Rename ( const WString & new_name ) [virtual]

Renames the file or directory to new_name. If the file or directory does not exist the method fails. Argument new_name is the file name including the file extension (if any) but without any leading directories. The MIME type of the renamed file is defined by the extension of the new name, if none exists it has general type. If the new name is equal to the old name the method fails. The method succeeds if and only if the file or directory really was renamed. Subclasses have to first check if the new file name is different to the actual one, then physically rename the file, and finally call this base method for changing the name which is controlled within this base class. This base method never fails. For a sample implementation see FlashFileImp::Rename(). This is a file operation, the file must not be open on call.

Parameters:
new_name New name of the file including the file extension (if any). No directory segments are allowed.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FatFileImp::Resize | ( | UINT32 | new_size,
 |  | UINT32 | copy_buf_size
 | ) | [virtual]

Resizes the file to contain new_size bytes. If the new size is less than the original size then the file is truncated. If the new size is bigger than the original size then the newly created part of the file is not initialized and has to be written to be in defined state. Emptying a file by resizing it to size 0 is allowed. This default implementation uses a temporary file for resizing. Override this method if resizing is explicitly supported by the derived file class. This is a file operation, the file must not be open on call.

Parameters:
new_size | The new size of the file.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

BOOLEAN FatFileImp::SetArchive ( BOOLEAN archive ) [virtual]

Sets the archive flag.

Parameters:
archive If TRUE then the file is an archive.

Implements File.

BOOLEAN FatFileImp::SetHidden ( BOOLEAN hidden ) [virtual]

Sets the hidden flag.

Parameters:
hidden If TRUE then the file is hidden.

Implements File.

BOOLEAN FatFileImp::SetReadOnly ( BOOLEAN read_only ) [virtual]

Sets the read only flag.

Parameters:
read_only If TRUE then the file is set to read only mode.

Implements File.

FatOpenMode FatFileImp::TranslateOpenMode ( OpenMode open_mode ) [static, protected]

Friends And Related Function Documentation

friend class FatStorageDeviceImp [friend]

Field Documentation

const UINT FatFileImp::PROP_NATIVEHANDLE = 0 [static]

Property ID for the internal FAT handle of type fs_fd_type. Getting this property is only possible if the file is open. Setting this property is not possible.

The documentation for this class was generated from the following files:
  • AddOns/AfsFat/FatFileImp.hpp
  • AddOns/AfsFat/FatFileImp.cpp
Generated on Wed Jan 25 01:14:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatFileInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatFileInfo Struct Reference
[FAT filesystem support]

#include <Apoxi/AddOns/AfsFat/FatTypes.hpp>

Collaboration diagram for FatFileInfo:

[legend]

Data Fields

UINT16 | fattribute
UINT16 | padding
FatTimeRecord st_atime
INT32 | st_blksize
INT32 | st_blocks
FatTimeRecord st_ctime
INT16 | st_dev
INT16 | st_ino
UINT32 | st_mode
FatTimeRecord st_mtime
INT16 | st_nlink
INT16 | st_rdev
UINT32 | st_size

Field Documentation

UINT16 FatFileInfo::fattribute

UINT16 FatFileInfo::padding

FatTimeRecord FatFileInfo::st_atime

INT32 FatFileInfo::st_blksize

INT32 FatFileInfo::st_blocks

FatTimeRecord FatFileInfo::st_ctime

INT16 FatFileInfo::st_dev

INT16 FatFileInfo::st_ino

UINT32 FatFileInfo::st_mode

FatTimeRecord FatFileInfo::st_mtime

INT16 FatFileInfo::st_nlink

INT16 FatFileInfo::st_rdev

UINT32 FatFileInfo::st_size

The documentation for this struct was generated from the following file:
  • AddOns/AfsFat/FatTypes.hpp
Generated on Wed Jan 25 01:14:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatFindData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatFindData Struct Reference
[FAT filesystem support]

#include <Apoxi/AddOns/AfsFat/FatTypes.hpp>

Data Fields

INT16 | driveno
UINT16 | fattribute
UINT16 | fdate
CHAR | fext [4]
CHAR | fname [10]
UINT32 | fsize
UINT16 | ftime
CHAR | longFileName [FS_MAXPATH]
CHAR | path [FS_MAXPATH]
CHAR | pext [4]
CHAR | plongFileName [FS_MAXPATH]
void * | pmom
CHAR | pname [10]
void * | pobj

Field Documentation

INT16 FatFindData::driveno

UINT16 FatFindData::fattribute

UINT16 FatFindData::fdate

CHAR FatFindData::fext[4]

CHAR FatFindData::fname[10]

UINT32 FatFindData::fsize

UINT16 FatFindData::ftime

CHAR FatFindData::longFileName[FS_MAXPATH]

CHAR FatFindData::path[FS_MAXPATH]

CHAR FatFindData::pext[4]

CHAR FatFindData::plongFileName[FS_MAXPATH]

void* FatFindData::pmom

CHAR FatFindData::pname[10]

void* FatFindData::pobj

The documentation for this struct was generated from the following file:
  • AddOns/AfsFat/FatTypes.hpp
Generated on Wed Jan 25 01:14:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatFsUsbMassStorageReleaseMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatFsUsbMassStorageReleaseMsg Class Reference

#include <Apoxi/AddOns/AfsFat/FatFsMsgTypes.hpp>

Inheritance diagram for FatFsUsbMassStorageReleaseMsg:

[legend]
Collaboration diagram for FatFsUsbMassStorageReleaseMsg:

[legend]

Public Types

enum | { ID = 16061 }

Public Member Functions

virtual Message * | Clone () const
FatFsUsbMassStorageReleaseMsg (const WString &storage_device_id)
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetStorageDeviceId () const
virtual | ~FatFsUsbMassStorageReleaseMsg ()

Detailed Description

This message is posted by the FAT-FS RFS addon when the USB mass storage device releases exclusive access of a FAT-FS storage device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FatFsUsbMassStorageReleaseMsg::FatFsUsbMassStorageReleaseMsg ( const WString & storage_device_id )

FatFsUsbMassStorageReleaseMsg::~FatFsUsbMassStorageReleaseMsg ( ) [virtual]

Member Function Documentation

Message * FatFsUsbMassStorageReleaseMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & FatFsUsbMassStorageReleaseMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& FatFsUsbMassStorageReleaseMsg::GetStorageDeviceId ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/AfsFat/FatFsMsgTypes.hpp
  • AddOns/AfsFat/FatFsMsgTypes.cpp
Generated on Wed Jan 25 01:14:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatFsUsbMassStorageRequestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatFsUsbMassStorageRequestMsg Class Reference

#include <Apoxi/AddOns/AfsFat/FatFsMsgTypes.hpp>

Inheritance diagram for FatFsUsbMassStorageRequestMsg:

[legend]
Collaboration diagram for FatFsUsbMassStorageRequestMsg:

[legend]

Public Types

enum | { ID = 16060 }

Public Member Functions

virtual Message * | Clone () const
FatFsUsbMassStorageRequestMsg (const WString &storage_device_id, BOOLEAN request_granted)
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetStorageDeviceId () const
BOOLEAN | IsRequestGranted () const
virtual | ~FatFsUsbMassStorageRequestMsg ()

Detailed Description

This message is posted by the FAT-FS RFS addon when the USB mass storage device requests exclusive access of a FAT-FS storage device.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FatFsUsbMassStorageRequestMsg::FatFsUsbMassStorageRequestMsg | ( | const WString & | storage_device_id,
 |  | BOOLEAN | request_granted
 | ) |

FatFsUsbMassStorageRequestMsg::~FatFsUsbMassStorageRequestMsg ( ) [virtual]

Member Function Documentation

Message * FatFsUsbMassStorageRequestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & FatFsUsbMassStorageRequestMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& FatFsUsbMassStorageRequestMsg::GetStorageDeviceId ( ) const [inline]

BOOLEAN FatFsUsbMassStorageRequestMsg::IsRequestGranted ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/AfsFat/FatFsMsgTypes.hpp
  • AddOns/AfsFat/FatFsMsgTypes.cpp
Generated on Wed Jan 25 01:14:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatHandler Class Reference
[FAT filesystem support]

#include <Apoxi/AddOns/AfsFat/FatHandler.hpp>

Static Public Member Functions

static BOOLEAN | Append (FatHandle hp, const UINT8 HUGE *buffer, UINT32 count)
static BOOLEAN | ChangeDir (const CHAR *dir_name)
static BOOLEAN | Close (FatHandle hp)
static FatHandle | Create (const CHAR *file_name, UINT32 size)
static BOOLEAN | Delete (const CHAR *file_name)
static BOOLEAN | FileExists (const CHAR *file_name)
static void | FindDone (FatFindData &find_data)
static BOOLEAN | FindFirst (FatFindData &find_data, const CHAR *filespec)
static BOOLEAN | FindNext (FatFindData &find_data)
static BOOLEAN | Flush (FatHandle hp)
static BOOLEAN | GetAttributes (const CHAR *filename, UINT16 &attr)
static BOOLEAN | GetCurrentDir (const CHAR *drive_letter, CHAR *current_dir)
static BOOLEAN | GetFileInfo (const CHAR *file_name, FatFileInfo &info)
static UINT32 | GetFreeSpaceSize ()
static FatError | GetLastError ()
static BOOLEAN | IsDirectory (const CHAR *pathname)
static BOOLEAN | MakeDir (const CHAR *dir_name)
static FatHandle | Open (const CHAR *file_name, FatOpenMode mode)
static BOOLEAN | Read (FatHandle hp, UINT8 HUGE *buffer, UINT32 count)
static BOOLEAN | ReadStreaming (FatHandle hp, UINT8 HUGE *buffer, UINT32 count, UINT32 bytes_read, void *client_arg)
static BOOLEAN | ReadStreamingAsync (FatHandle hp, UINT8 HUGE *buffer, UINT32 count, void(callback_func)(INT16 result, void *client_arg), void *client_arg)
static BOOLEAN | RemoveDir (const CHAR *dir_name)
static BOOLEAN | Rename (const CHAR *current_file_name, const CHAR *new_file_name)
static UINT32 | Seek (FatHandle hp, INT32 offset, INT16 origin, INT16 &err_flag)
static BOOLEAN | SetAttributes (const CHAR *filename, UINT16 attr)
static BOOLEAN | Truncate (FatHandle hp, UINT32 new_size)
static BOOLEAN | Write (FatHandle hp, const UINT8 HUGE *buffer, UINT32 count)
static BOOLEAN | WriteStreaming (FatHandle hp, const UINT8 HUGE *buffer, UINT32 count, void *client_arg)
static BOOLEAN | WriteStreamingAsync (FatHandle hp, const UINT8 HUGE *buffer, UINT32 count, void(callback_func)(INT16 result, void *client_arg), void *client_arg)
Disk-Device-Services
static void | DiskAbort (FsDeviceType device)
static BOOLEAN | DiskAssignDriveLetter (FsDeviceType device, CHAR drive_letter)
static BOOLEAN | DiskClose (FsDeviceType device)
static BOOLEAN | DiskFlush (FsDeviceType device)
static BOOLEAN | DiskFormat (FsDeviceType device, BOOLEAN quick)
static UINT16 | DiskGetLastDeviceError (FsDeviceType device)
static BOOLEAN | DiskInfo (FsDeviceType device, BOOLEAN &mounted, UINT8 &nof_partitions)
static BOOLEAN | DiskOpen (FsDeviceType device)
static BOOLEAN | DiskSetDefaultDevice (FsDeviceType device)

Member Function Documentation

BOOLEAN FatHandler::Append | ( | FatHandle | hp,
 |  | const UINT8 HUGE * | buffer,
 |  | UINT32 | count
 | ) | [static]

Adds the specified data to the end of the existing file.

Parameters:
hp | File handle.
buffer | Pointer to the buffer where to copy data from.
count | Number of bytes to copy.
Returns:
Success of operation.

BOOLEAN FatHandler::ChangeDir ( const CHAR * dir_name ) [static]

Changes the current working directory.

Parameters:
dir_name The name of the directory to be changed to.
Returns:
Success of operation.

BOOLEAN FatHandler::Close ( FatHandle hp ) [static]

Closes the file with the specified handle. Only possible if the file exists and is in open state. Saves buffered data if the file was opened for write/append operations.

Parameters:
hp File handle.
Returns:
Success of operation.

FatHandle FatHandler::Create | ( | const CHAR * | file_name,
 |  | UINT32 | size
 | ) | [static]

Creates a new empty file with file_name of the specified initial size. The file is opened for write and read operations.

Parameters:
file_name | The name of the file to create.
size | The initial size of the file to create.
Returns:
Valid handle of the new file on success or the invalid handle (-1) on failure.

BOOLEAN FatHandler::Delete ( const CHAR * file_name ) [static]

Deletes the file with file_name. The file should not be open when the delete operation is requested.

Parameters:
file_name The name of the file to be deleted.
Returns:
Success of operation.

void FatHandler::DiskAbort ( FsDeviceType device ) [static]

BOOLEAN FatHandler::DiskAssignDriveLetter | ( | FsDeviceType | device,
 |  | CHAR | drive_letter
 | ) | [static]

BOOLEAN FatHandler::DiskClose ( FsDeviceType device ) [static]

BOOLEAN FatHandler::DiskFlush ( FsDeviceType device ) [static]

BOOLEAN FatHandler::DiskFormat | ( | FsDeviceType | device,
 |  | BOOLEAN | quick
 | ) | [static]

UINT16 FatHandler::DiskGetLastDeviceError ( FsDeviceType device ) [static]

BOOLEAN FatHandler::DiskInfo | ( | FsDeviceType | device,
 |  | BOOLEAN & | mounted,
 |  | UINT8 & | nof_partitions
 | ) | [static]

BOOLEAN FatHandler::DiskOpen ( FsDeviceType device ) [static]

BOOLEAN FatHandler::DiskSetDefaultDevice ( FsDeviceType device ) [static]

BOOLEAN FatHandler::FileExists ( const CHAR * file_name ) [static]

Checks for the presence of the file with the specified file_name.

Parameters:
file_name The name of the file.
Returns:
TRUE if the file exists, FALSE otherwise.

void FatHandler::FindDone ( FatFindData & find_data ) [static]

Must be called to finish the current file find process.

Parameters:
find_data Find info record where to store data.

BOOLEAN FatHandler::FindFirst | ( | FatFindData & | find_data,
 |  | const CHAR * | filespec
 | ) | [static]

Retrieves info on the first stored file that matches the filespec via find_data.

Parameters:
filespec | Target file specification (may include the wildcards '?*').
find_data | Find info record where to store data.
Returns:
TRUE if file is found, FALSE otherwise.

BOOLEAN FatHandler::FindNext ( FatFindData & find_data ) [static]

Retrieves info on the next stored file that matches the filespec from the preceding FindFirst() via find_data.

Parameters:
find_data Find info record where to store data.
Returns:
TRUE if file is found, FALSE otherwise.

BOOLEAN FatHandler::Flush ( FatHandle hp ) [static]

Flushes the file with handle hp. After this call completes, the on-disk view of the file is consistent with the in-memory view.

Returns:
Success of operation.

BOOLEAN FatHandler::GetAttributes | ( | const CHAR * | filename,
 |  | UINT16 & | attr
 | ) | [static]

Retrieves the attribute of the file with filename.

Parameters:
filename | The file name.
attr | The value where to store the attribute.
Returns:
Success of operation.

BOOLEAN FatHandler::GetCurrentDir | ( | const CHAR * | drive_letter,
 |  | CHAR * | current_dir
 | ) | [static]

Retrieves the current working directory of drive with drive letter drive_letter.

Parameters:
drive_letter | Specifies the drive letter of the drive for which to retrieve the current working directory.
current_dir | Buffer where to store the name of the current working directory. The size of the buffer must be at least 256 bytes.
Returns:
Success of operation.

BOOLEAN FatHandler::GetFileInfo | ( | const CHAR * | file_name,
 |  | FatFileInfo & | info
 | ) | [static]

Retrieves the file info record (name, size, timestamp, ...) of the file with file_name via info.

Parameters:
file_name | The name of the file.
info | File info record where to store data.
Returns:
Success of operation.

UINT32 FatHandler::GetFreeSpaceSize ( ) [static]

Returns the number of available bytes free on the specified FAT device.

Returns:
The number of free bytes.

FatError FatHandler::GetLastError ( ) [static]

Gets the error code during last file operation.

Returns:
The error code met last time.

BOOLEAN FatHandler::IsDirectory ( const CHAR * pathname ) [static]

Tells if pathname specifies a directory.

Parameters:
pathname The pathname.
Returns:
Tells if pathname is a directory.

BOOLEAN FatHandler::MakeDir ( const CHAR * dir_name ) [static]

Creates a new directory.

Parameters:
dir_name The name of the directory to be created.
Returns:
Success of operation.

FatHandle FatHandler::Open | ( | const CHAR * | file_name,
 |  | FatOpenMode | mode
 | ) | [static]

Opens a file with the specified file_name for operations specified by mode. Only possible if the file exists and is not already open.

Parameters:
file_name | The name of the file to open.
mode | Specifies in which mode to open the file.
Returns:
Valid handle of the open file on success or the invalid handle (-1) on failure.

BOOLEAN FatHandler::Read | ( | FatHandle | hp,
 |  | UINT8 HUGE * | buffer,
 |  | UINT32 | count
 | ) | [static]

Copies count bytes of data from the file with the specified handle hp to the buffer. Only possible if the file exists and is opened for read operations.

Parameters:
hp | File handle.
buffer | Pointer to the buffer where to copy data to.
count | Number of bytes to copy.
Returns:
Success of operation.

BOOLEAN FatHandler::ReadStreaming | ( | FatHandle | hp,
 |  | UINT8 HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 | bytes_read,
 |  | void * | client_arg
 | ) | [static]

Copies count bytes of data from the file with the specified handle hp to the buffer. Only possible if the file exists and is opened for read operations. The synchronous operation takes place with the priority of the streaming mode, which is higher than the priority of the normal synchronous FAT operations.

Parameters:
hp | File handle.
buffer | Pointer to the buffer where to copy data to.
count | Number of bytes to copy.
Returns:
Success of operation.

BOOLEAN FatHandler::ReadStreamingAsync | ( | FatHandle | hp,
 |  | UINT8 HUGE * | buffer,
 |  | UINT32 | count,
 |  | void(callback_func)(INT16 result, void *client_arg) | ,
 |  | void * | client_arg
 | ) | [static]

Copies count bytes of data from the file with the specified handle hp to the buffer. Only possible if the file exists and is opened for read operations. The asynchronous operation takes place with the priority of the streaming mode, which is higher than the priority of the normal FAT operations. The method returns immediately and the driver signalises by calling the callback_func that the asynchronous operation ended. Wheter the buffer could be filled successfully or not can be found out by the parameters of the callback_func.

Parameters:
hp | File handle.
buffer | Pointer to the buffer where to copy data to.
count | Number of bytes to copy.
callback_func | Function, which is called by the driver, when the asynchronous operation is finished.
client_arg | client arguments, which are returned in the callback function.
Returns:
Success of operation.

BOOLEAN FatHandler::RemoveDir ( const CHAR * dir_name ) [static]

Deletes the directory including all the files in it.

Parameters:
dir_name The name of the directory to be deleted.
Returns:
Success of operation.

BOOLEAN FatHandler::Rename | ( | const CHAR * | current_file_name,
 |  | const CHAR * | new_file_name
 | ) | [static]

Renames an existing file with current_file_name to new_file_name. Not possible if the file is in the open state.

Parameters:
current_file_name | Specifies the current name of the file.
new_file_name | Specifies the new name of the file.
Returns:
Success of operation.

UINT32 FatHandler::Seek | ( | FatHandle | hp,
 |  | INT32 | offset,
 |  | INT16 | origin,
 |  | INT16 & | err_flag
 | ) | [static]

Moves the current file position.

Parameters:
hp | File handle.
offset | Offset specifying the amount of bytes and the direction (positive is forward, negative is backward) where to move the current file position to.
origin | Position where to apply the offset to.
err_flag | Receives the error code.
Returns:
The file position after the move.

BOOLEAN FatHandler::SetAttributes | ( | const CHAR * | filename,
 |  | UINT16 | attr
 | ) | [static]

Sets the attributes of the file with filename.

Parameters:
filename | The file name.
attr | The attribute to set to the file.
Returns:
Success of operation.

BOOLEAN FatHandler::Truncate | ( | FatHandle | hp,
 |  | UINT32 | new_size
 | ) | [static]

Truncates the open file with handle hp to new_size. Any file blocks beyond new_size are freed and the file size is adjusted. The current file position is left at the new end of the file.

Returns:
Success of operation.

BOOLEAN FatHandler::Write | ( | FatHandle | hp,
 |  | const UINT8 HUGE * | buffer,
 |  | UINT32 | count
 | ) | [static]

Copies count bytes of data from buffer to the file with the specified handle hp. Only possible if the file exists and is opened for write operations.

Parameters:
hp | File handle.
buffer | Pointer to the buffer where to copy data from.
count | Number of bytes to copy.
Returns:
Success of operation.

BOOLEAN FatHandler::WriteStreaming | ( | FatHandle | hp,
 |  | const UINT8 HUGE * | buffer,
 |  | UINT32 | count,
 |  | void * | client_arg
 | ) | [static]

Copies count bytes of data from buffer to the file with the specified handle hp. Only possible if the file exists and is opened for write operations. The synchronous operation takes place with the priority of the streaming mode, which is higher than the priority of the normal FAT operations.

Parameters:
hp | File handle.
buffer | Pointer to the buffer where to copy data from.
count | Number of bytes to copy.
Returns:
Success of operation.

BOOLEAN FatHandler::WriteStreamingAsync | ( | FatHandle | hp,
 |  | const UINT8 HUGE * | buffer,
 |  | UINT32 | count,
 |  | void(callback_func)(INT16 result, void *client_arg) | ,
 |  | void * | client_arg
 | ) | [static]

Copies count bytes of data from buffer to the file with the specified handle hp. Only possible if the file exists and is opened for write operations. The asynchronous operation takes place with the priority of the streaming mode, which is higher than the priority of the normal FAT operations. The method returns immediately and the driver signalises by calling the callback that the asynchronous operation ended. Wheter the buffer could be filled successfully or not can be found out by the parameters of the callback_func.

Parameters:
hp | File handle.
buffer | Pointer to the buffer where to copy data from.
count | Number of bytes to copy.
callback_func | Function, which is called by the driver, when the asynchronous operation is finished.
client_arg | client arguments, which are returned in the callback function.
Returns:
Success of operation.

The documentation for this class was generated from the following files:
  • AddOns/AfsFat/FatHandler.hpp
  • AddOns/AfsFat/FatHandler.cpp
Generated on Wed Jan 25 01:14:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FatStorageDeviceImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FatStorageDeviceImp Class Reference
[FAT filesystem support]

Storage device implementation for FAT storage devices. More...

#include <Apoxi/AddOns/AfsFat/FatStorageDeviceImp.hpp>

Inheritance diagram for FatStorageDeviceImp:

[legend]
Collaboration diagram for FatStorageDeviceImp:

[legend]

Public Member Functions

virtual BOOLEAN | Exists (const Pathname &pathname) const
virtual BOOLEAN | Flush ()
virtual BOOLEAN | Format (BOOLEAN quick=FALSE)
virtual UINT8 | GetDefaultChunkSize () const
virtual UINT32 | GetFreeVolumeSize () const
virtual BOOLEAN | GetMediaAvailableStatus (BOOLEAN &media_present) const
virtual WString | GetNativeDirectoryPathname (const Pathname &pathname) const
virtual WString | GetNativeFilePathname (const Pathname &pathname) const
virtual UINT32 | GetTotalVolumeSize () const
virtual UINT32 | GetUsedVolumeSize () const
virtual BOOLEAN | IsDirectory (const Pathname &pathname) const
virtual BOOLEAN | IsReady () const

Friends

class | FatDirectoryIteratorImp
class | FatFile
class | FatFileImp
class | FatStorageDeviceImpInternals
class | RootFileSystem

Data Structures

struct | FatFsDeviceDescriptor

Detailed Description

Storage device implementation for FAT storage devices.

Class FatStorageDeviceImp implements the storage device interface for using FAT file systems within the root file system.

Member Function Documentation

BOOLEAN FatStorageDeviceImp::Exists ( const Pathname & pathname ) const [virtual]

Tells if pathname exists. If it exists it may either be a file or a directory.

Implements StorageDevice.

BOOLEAN FatStorageDeviceImp::Flush ( ) [virtual]

This method is to be overridden by devices which have to empty buffers when they are shutdown. It might be especially useful for plug and play devices. This base class implementation does nothing.

Returns:
The success of the operation.

Reimplemented from StorageDevice.

BOOLEAN FatStorageDeviceImp::Format ( BOOLEAN quick = FALSE ) [virtual]

This method formats the actual storage device. It is only possible to format real devices. The root storage device cannot be formatted.

Returns:
The success of the operation.

Implements StorageDevice.

UINT8 FatStorageDeviceImp::GetDefaultChunkSize ( ) const [virtual]

Returns the default chunk size for operating in chunk mode on files stored on this storage device.

See also:
File::GetChunkSize()

File::SetChunkSize()

Implements StorageDevice.

UINT32 FatStorageDeviceImp::GetFreeVolumeSize ( ) const [virtual]

Returns the free volume size of the device in bytes.

Returns:
The free volume size of the device in bytes.

Implements StorageDevice.

BOOLEAN FatStorageDeviceImp::GetMediaAvailableStatus ( BOOLEAN & media_present ) const [virtual]

Gets the storage media insertion status. This base implementation simply returns FALSE. This method has to be overridden by devices which support exchangeable medias. If the method succeeds then parameter media_present tells whether a storage media is inserted.

Returns:
Tells if the storage media insertion status could be retrieved.

Reimplemented from StorageDevice.

WString FatStorageDeviceImp::GetNativeDirectoryPathname ( const Pathname & pathname ) const [virtual]

Returns pathname in native directory name format. The native directory name format may differ from storage device to storage device.

Implements StorageDevice.

WString FatStorageDeviceImp::GetNativeFilePathname ( const Pathname & pathname ) const [virtual]

Returns pathname in native file name format. The native file name format may differ from storage device to storage device.

Implements StorageDevice.

UINT32 FatStorageDeviceImp::GetTotalVolumeSize ( ) const [virtual]

Returns the total volume size of the device in bytes.

Returns:
The total volume size of the device in bytes.

Implements StorageDevice.

UINT32 FatStorageDeviceImp::GetUsedVolumeSize ( ) const [virtual]

Returns the used volume size of the device in bytes. Note that this size is usually larger than the sum of the sizes of all stored files, since meta information to control the directory structure is stored on the device, too.

Returns:
The used volume size of the device in bytes.

Implements StorageDevice.

BOOLEAN FatStorageDeviceImp::IsDirectory ( const Pathname & pathname ) const [virtual]

Tells if pathname is a directory. This base implementation returns TRUE only for the root pathname, since every storage device is at least organized in a flat manner which we interpret as having a single root directory. The method is declared as abstract for when implementing a new storage device you can't forget to deal with this issue. If the derived storage device is organized in a flat manner, then the override of this abstract method might be a simple call to this base class implementation. If a derived class supports directories then implement this method accordingly.

Implements StorageDevice.

BOOLEAN FatStorageDeviceImp::IsReady ( ) const [virtual]

Tells if the device is ready for being accessed.

Implements StorageDevice.

Friends And Related Function Documentation

friend class FatDirectoryIteratorImp [friend]

friend class FatFile [friend]

friend class FatFileImp [friend]

friend class FatStorageDeviceImpInternals [friend]

friend class RootFileSystem [friend]

Reimplemented from StorageDevice.

The documentation for this class was generated from the following files:
  • AddOns/AfsFat/FatStorageDeviceImp.hpp
  • AddOns/AfsFat/FatStorageDeviceImp.cpp
Generated on Wed Jan 25 01:14:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FdnIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FdnIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for FdnIndArg:

[legend]
Collaboration diagram for FdnIndArg:

[legend]

Public Types

enum | { ID = 1484 }

Public Member Functions

FdnIndArg ()
const FdnState & | GetFdnState () const
UINT8 | GetFileStatus () const
const SimUpdateStatus & | GetSimUpdateStatus () const
void | SetFdnState (const FdnState &fdn_state)
void | SetFileStatus (UINT8 file_status)
void | SetSimUpdateStatus (const SimUpdateStatus &sim_update_status)

Static Public Member Functions

static const FdnIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

FdnIndArg: reflects arguments of signal MN_FDN_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FdnIndArg::FdnIndArg ( )

Member Function Documentation

const FdnIndArg & FdnIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const FdnState& FdnIndArg::GetFdnState ( ) const [inline]

UINT8 FdnIndArg::GetFileStatus ( ) const [inline]

const SimUpdateStatus& FdnIndArg::GetSimUpdateStatus ( ) const [inline]

void FdnIndArg::SetFdnState ( const FdnState & fdn_state ) [inline]

void FdnIndArg::SetFileStatus ( UINT8 file_status ) [inline]

void FdnIndArg::SetSimUpdateStatus ( const SimUpdateStatus & sim_update_status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:14:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FdnReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FdnReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for FdnReqArg:

[legend]
Collaboration diagram for FdnReqArg:

[legend]

Public Types

enum | { ID = 2470 }

Public Member Functions

FdnReqArg ()
FdnReqArg (const FdnState &fdn_state)
const FdnState & | GetFdnState () const
void | SetFdnState (const FdnState &fdn_state)

Static Public Member Functions

static const FdnReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

FdnReqArg: reflects arguments of signal MN_FDN_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FdnReqArg::FdnReqArg ( const FdnState & fdn_state )

FdnReqArg::FdnReqArg ( )

Member Function Documentation

const FdnReqArg & FdnReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const FdnState& FdnReqArg::GetFdnState ( ) const [inline]

void FdnReqArg::SetFdnState ( const FdnState & fdn_state ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:14:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Feature Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Feature Class Reference
[APOXI Template Layer]

Represents pure functionality, will be wrapped by a feature item. More...

#include <Apoxi/Atl/Features/Feature.hpp>

Inheritance diagram for Feature:

[legend]
Collaboration diagram for Feature:

[legend]

Public Types

enum | { ID = 3 }
enum | FeatureAttributeId { UnspecifiedAttributeId = -1, AvailableAttributeId = 0, EnabledAttributeId = 1, CustomAttributeId = 99 }

Public Member Functions

void | BlockNotification (BOOLEAN block)
virtual BOOLEAN | Execute ()
Feature (AtlApplication *app, const FeatureID &id)
Feature ()
AtlApplication * | GetApplication () const
const FeatureID & | GetFeatureId () const
virtual INT | GetID () const
void | Init (AtlApplication *app, const FeatureID &id, BOOLEAN available, BOOLEAN enabled)
void | Init (AtlApplication *app, const FeatureID &id)
BOOLEAN | IsAvailable () const
BOOLEAN | IsEnabled () const
virtual BOOLEAN | IsEqual (const Feature &feature) const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsNotificationBlocked () const
void | SetApplication (AtlApplication *app)
void | SetAvailable (BOOLEAN available)
Notifies both FeatureBroker and the focused control about this state change.
void | SetEnabled (BOOLEAN enabled)
Notifies both FeatureBroker and the focused control about this state change.
virtual | ~Feature ()

Protected Member Functions

void | NotifyFeatureChange (INT property_id=UnspecifiedAttributeId)

Protected Attributes

AtlApplication * m_app
FeatureID m_feature_id

Detailed Description

Represents pure functionality, will be wrapped by a feature item.

See also:
FeatureItem

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

The documentation for this class was generated from the following files:
  • Atl/Features/Feature.hpp
  • Atl/Features/Feature.cpp
Generated on Wed Jan 25 01:14:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FeatureBroker Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FeatureBroker Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/FeatureBroker.hpp>

Collaboration diagram for FeatureBroker:

[legend]

Public Member Functions

Feature * | GetFeature (const AppFeatureID &id) const
Feature * | GetFeature (const ApplicationID &appID, const FeatureID &feature) const
virtual MenuDesc * | GetMenu (const MenuID &id)
BOOLEAN | OnFeatureAdded (Feature *feature)
Notifies the menu pool on adding of new features.
void | OnFeatureStatusChanged (Feature *feature)
Notifies the menu pool on state changes of features.
BOOLEAN | RegisterApplication (AtlApplication *app)
virtual | ~FeatureBroker ()

Static Public Member Functions

static FeatureBroker * | GetInstance ()

Protected Member Functions

BOOLEAN | IsMenuInitialized ()

Friends

class | Feature
class | Property

Detailed Description

Singleton feature broker knows all feature-providing applications and distributes their features. Further, it maintains all menu descriptions for context menus.

Constructor & Destructor Documentation

FeatureBroker::~FeatureBroker ( ) [virtual]

Member Function Documentation

Feature* FeatureBroker::GetFeature ( const AppFeatureID & id ) const [inline]

Feature * FeatureBroker::GetFeature | ( | const ApplicationID & | appID,
 |  | const FeatureID & | feature
 | ) | const

static FeatureBroker* FeatureBroker::GetInstance ( ) [inline, static]

MenuDesc * FeatureBroker::GetMenu ( const MenuID & id ) [virtual]

BOOLEAN FeatureBroker::IsMenuInitialized ( ) [protected]

BOOLEAN FeatureBroker::OnFeatureAdded ( Feature * feature )

Notifies the menu pool on adding of new features.

See also:
MenuPool

void FeatureBroker::OnFeatureStatusChanged ( Feature * feature )

Notifies the menu pool on state changes of features.

BOOLEAN FeatureBroker::RegisterApplication ( AtlApplication * app )

Parameters:
app Application to register with FeatureBroker
Returns:
TRUE, if application has not been registered, before.

Friends And Related Function Documentation

friend class Feature [friend]

friend class Property [friend]

The documentation for this class was generated from the following files:
  • Atl/Features/FeatureBroker.hpp
  • Atl/Features/FeatureBroker.cpp
Generated on Wed Jan 25 01:14:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FeatureChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FeatureChangedMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for FeatureChangedMsg:

[legend]
Collaboration diagram for FeatureChangedMsg:

[legend]

Public Types

enum | { ID = 13003 }

Public Member Functions

virtual Message * | Clone () const
FeatureChangedMsg (Feature *feature, INT property_id=Feature::UnspecifiedAttributeId)
Feature * | GetFeature () const
virtual const MsgMetaData & | GetMetaData () const
INT | GetPropertyId () const
virtual | ~FeatureChangedMsg ()

Detailed Description

FeatureChanged

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FeatureChangedMsg::FeatureChangedMsg | ( | Feature * | feature,
 |  | INT | property_id = Feature::UnspecifiedAttributeId
 | ) |

FeatureChangedMsg::~FeatureChangedMsg ( ) [virtual]

Member Function Documentation

Message * FeatureChangedMsg::Clone ( ) const [virtual]

Implements Message.

Feature* FeatureChangedMsg::GetFeature ( ) const [inline]

const MsgMetaData & FeatureChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

INT FeatureChangedMsg::GetPropertyId ( ) const [inline]

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 01:14:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FeatureHandle Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FeatureHandle Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/FeatureHandle.hpp>

Inheritance diagram for FeatureHandle:

[legend]
Collaboration diagram for FeatureHandle:

[legend]

Public Member Functions

virtual void | Execute (AtlApplication *context_app=0) const
FeatureHandle (const AppFeatureID &id)
const AppFeatureID & | GetAppFeatureID () const
~FeatureHandle ()

Protected Attributes

AppFeatureID m_featureID

Detailed Description

Feature handle executes a feature on behalf of the key manager
See also:
KeyManager

Constructor & Destructor Documentation

FeatureHandle::FeatureHandle ( const AppFeatureID & id )

FeatureHandle::~FeatureHandle ( )

Member Function Documentation

void FeatureHandle::Execute ( AtlApplication * context_app = 0 ) const [virtual]

Retrieves the feature from the FeatureBroker and executes it.

Parameters:
context_app feature-providing application or plugin

Reimplemented in ContextFeatureHandle.

const AppFeatureID& FeatureHandle::GetAppFeatureID ( ) const [inline]

Field Documentation

AppFeatureID FeatureHandle::m_featureID [protected]

The documentation for this class was generated from the following files:
  • Atl/Features/FeatureHandle.hpp
  • Atl/Features/FeatureHandle.cpp
Generated on Wed Jan 25 01:14:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FeatureItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FeatureItem Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/FeatureItem.hpp>

Inheritance diagram for FeatureItem:

[legend]
Collaboration diagram for FeatureItem:

[legend]

Public Types

enum | { ID = 100 }
enum | FeatureItemPropertyId { FeaturePropertyId = 5, ContextPropertyId = 6 }

Public Member Functions

virtual BOOLEAN | Execute ()
FeatureItem (Feature *feature, const WString &text, const ImageObtainer &icon)
FeatureItem (Feature *feature, const WString &text)
FeatureItem (Feature *feature)
FeatureItem ()
const ContextID & | GetContextId () const
const Feature * | GetFeature () const
Feature * GetFeature ()
FeatureID | GetFeatureId () const
virtual INT | GetID () const
virtual const WString & | GetText () const
void | Init (Feature *feature, const WString &text, const ImageObtainer &icon)
void | Init (Feature *feature, const WString &text)
void | Init (Feature *feature=0)
BOOLEAN | IsAttachedToProperty (Property *property) const
virtual BOOLEAN | IsEnabled () const
virtual BOOLEAN | IsEqual (const Item &item) const
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual void | OnLanguageChanged ()
void | SetContextId (const CHAR *id)
void | SetContextId (const ContextID &id)
virtual void | SetEnabled (BOOLEAN enabled)
void | SetFeature (Feature *feature)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual void | SetText (const WString &text)
virtual void | Update ()
Updates the text of the FeatureItem.
virtual | ~FeatureItem ()

Protected Attributes

Feature * m_feature
SubstitutedText m_substituted_text

Detailed Description

FeatureItem wraps a feature, which is a piece of functionality provided by an application or plugin. FeatureItems are used to display and execute features in menus and list windows. The feature item specifies text and icon, in case the feature is displayed in a GUI element. Feature items can have a context id, which is used, when selecting the feature item in a menu. If no context id is set, the context id of the featureitemcontainer is used. If this also has no context id, the context of the window is used.

The documentation for this class was generated from the following files:
  • Atl/Features/FeatureItem.hpp
  • Atl/Features/FeatureItem.cpp
Generated on Wed Jan 25 01:14:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FeatureItemContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FeatureItemContainer Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/FeatureItemContainer.hpp>

Inheritance diagram for FeatureItemContainer:

[legend]
Collaboration diagram for FeatureItemContainer:

[legend]

Public Types

typedef ItemContainer | Base
enum | FeatureItemContainerPropertyId { ContextPropertyId = 5 }
enum | Identifier { ID = 106 }

Public Member Functions

virtual BOOLEAN | AddItem (Item *item)
BOOLEAN | ContainsFeature (Feature *feature)
FeatureItemContainer (FeatureItemContainerID container_id, BOOLEAN ignore_unavailable_features=TRUE)
FeatureItemContainer (BOOLEAN ignore_unavailable_features=TRUE)
FeatureItemContainerID | GetContainerId () const
const ContextID & | GetContextId () const
virtual INT | GetID () const
virtual Item * | GetItem (INT index) const
virtual INT | GetItemCount () const
Returns the number of items of the item-grid.
virtual INT | GetItemIndex (const Item &item) const
void | IgnoreUnavailableFeatures (BOOLEAN flag)
void | Init (FeatureItemContainerID container_id, const WString &text, BOOLEAN ignore_unavailable_features=TRUE)
void | Init (FeatureItemContainerID container_id, BOOLEAN ignore_unavailable_features=TRUE)
virtual BOOLEAN | InsertItem (INT index, Item *item)
void | Invalidate ()
BOOLEAN | IsAvailable () const
virtual BOOLEAN | IsEqual (const Item &item) const
The item is identical to this feature item container, it if has the same type and the same container_id.
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual BOOLEAN | RemoveAllItems ()
virtual BOOLEAN | RemoveItem (INT index)
void | SetContainerId (FeatureItemContainerID container_id)
void | SetContextId (const CHAR *id)
void | SetContextId (const ContextID &id)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
BOOLEAN | UnavailableFeaturesIgnored () const
Returns TRUE if unavailable features are ignored, FALSE otherwise.
virtual | ~FeatureItemContainer ()

Detailed Description

The FeatureItemContainer contains Items like the ItemContainer but it has an additional handling for FeatureItems. FeatureItemContainers are used for full sized menus and popup menus. Each FeatureItemContainer can be identified by an id. FeatureItemContainers can have a context id, which is used, when selecting the feature item in a menu. If no context id is set, the context of the AtlWindow is used.

Member Typedef Documentation

typedef ItemContainer FeatureItemContainer::Base

Reimplemented from ItemContainer.

The documentation for this class was generated from the following files:
  • Atl/Features/FeatureItemContainer.hpp
  • Atl/Features/FeatureItemContainer.cpp
Generated on Wed Jan 25 01:14:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FeaturePool Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FeaturePool Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/FeaturePool.hpp>

Collaboration diagram for FeaturePool:

[legend]

Public Member Functions

virtual BOOLEAN | AddFeature (Feature *feature)
virtual BOOLEAN | AddFeatures (Feature features[], INT size)
virtual Feature * | GetFeature (const FeatureID &id) const

Protected Types

typedef SimpleMap< FeatureID,
Feature * > 		FeaturePoolF

Member Typedef Documentation

typedef SimpleMap<FeatureID,Feature*> FeaturePool::FeaturePoolF [protected]

Member Function Documentation

BOOLEAN FeaturePool::AddFeature ( Feature * feature ) [virtual]

BOOLEAN FeaturePool::AddFeatures | ( | Feature | features[],
 |  | INT | size
 | ) | [virtual]

Feature * FeaturePool::GetFeature ( const FeatureID & id ) const [virtual]

The documentation for this class was generated from the following files:
  • Atl/Features/FeaturePool.hpp
  • Atl/Features/FeaturePool.cpp
Generated on Wed Jan 25 01:14:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FeatureTriggerMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FeatureTriggerMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for FeatureTriggerMsg:

[legend]
Collaboration diagram for FeatureTriggerMsg:

[legend]

Public Types

enum | { ID = 13005 }

Public Member Functions

virtual Message * | Clone () const
FeatureTriggerMsg (ExecutionContext *context, const FeatureID &feature_id)
const FeatureID & | GetFeatureId () const
virtual const MsgMetaData & | GetMetaData () const
void | SetFeatureId (const FeatureID &feature_id)
virtual | ~FeatureTriggerMsg ()

Detailed Description

FeatureTriggerMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FeatureTriggerMsg::FeatureTriggerMsg | ( | ExecutionContext * | context,
 |  | const FeatureID & | feature_id
 | ) |

FeatureTriggerMsg::~FeatureTriggerMsg ( ) [virtual]

Member Function Documentation

Message * FeatureTriggerMsg::Clone ( ) const [virtual]

Implements Message.

const FeatureID& FeatureTriggerMsg::GetFeatureId ( ) const [inline]

const MsgMetaData & FeatureTriggerMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void FeatureTriggerMsg::SetFeatureId ( const FeatureID & feature_id ) [inline]

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 01:14:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ffs_drm_attrib_type Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ffs_drm_attrib_type Struct Reference

#include <Apoxi/Afs/Ffs/FfsSim.hpp>

Data Fields

word local_id
word mime_type

Field Documentation

word ffs_drm_attrib_type::local_id

word ffs_drm_attrib_type::mime_type

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsSim.hpp
Generated on Wed Jan 25 01:14:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ffs_file_info_type Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ffs_file_info_type Struct Reference

#include <Apoxi/Afs/Ffs/FfsSim.hpp>

Collaboration diagram for ffs_file_info_type:

[legend]

Data Fields

ffs_drm_attrib_type drm_attrib
byte dynamic
byte reserved
ulong size
ffs_time_record_type timestamp
ffs_filetype_type type

Field Documentation

ffs_drm_attrib_type ffs_file_info_type::drm_attrib

byte ffs_file_info_type::dynamic

byte ffs_file_info_type::reserved

ulong ffs_file_info_type::size

ffs_time_record_type ffs_file_info_type::timestamp

ffs_filetype_type ffs_file_info_type::type

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsSim.hpp
Generated on Wed Jan 25 01:14:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ffs_ref_type Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ffs_ref_type Struct Reference

#include <Apoxi/Afs/Ffs/FfsSim.hpp>

Data Fields

dir_id_type dir_id
word file_id
word finding_dirs

Field Documentation

dir_id_type ffs_ref_type::dir_id

word ffs_ref_type::file_id

word ffs_ref_type::finding_dirs

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsSim.hpp
Generated on Wed Jan 25 01:14:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ffs_time_record_type Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ffs_time_record_type Struct Reference

#include <Apoxi/Afs/Ffs/FfsSim.hpp>

Data Fields

byte date
byte hour
byte min
byte month
word year

Field Documentation

byte ffs_time_record_type::date

byte ffs_time_record_type::hour

byte ffs_time_record_type::min

byte ffs_time_record_type::month

word ffs_time_record_type::year

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsSim.hpp
Generated on Wed Jan 25 01:14:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsDataConnProfileStorage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsDataConnProfileStorage Class Reference
[DataConn]

#include <Applications/DataConn/MyDataConnProfileStorage.hpp>

Inheritance diagram for FfsDataConnProfileStorage:

[legend]
Collaboration diagram for FfsDataConnProfileStorage:

[legend]

Public Member Functions

virtual void | Close ()
FfsDataConnProfileStorage ()
UINT32 | GetProfileOffset (INT recno) const
virtual BOOLEAN | Open ()
BOOLEAN | OpenFfsFile ()
virtual BOOLEAN | Read (INT recno, PersistDataConnProfile &pdcp)
virtual BOOLEAN | Read (Header &header)
virtual BOOLEAN | Write (INT recno, const PersistDataConnProfile &pdcp)
virtual BOOLEAN | Write (const Header &header)

Data Fields

FlsFile m_file

Constructor & Destructor Documentation

FfsDataConnProfileStorage::FfsDataConnProfileStorage ( )

Member Function Documentation

void FfsDataConnProfileStorage::Close ( ) [virtual]

Close is called to shut down the profile storage. No read or write operations will be done after closing the storage device.

Reimplemented from DataConnProfileStorage.

UINT32 FfsDataConnProfileStorage::GetProfileOffset ( INT recno ) const [inline]

virtual BOOLEAN FfsDataConnProfileStorage::Open ( void ) [inline, virtual]

Open is called to initialize the profile storage. After successful open operation, data can be read from and written to the profile storage.

Reimplemented from DataConnProfileStorage.

BOOLEAN FfsDataConnProfileStorage::OpenFfsFile ( )

BOOLEAN FfsDataConnProfileStorage::Read | ( | INT | recno,
 |  | PersistDataConnProfile & | pdcp
 | ) | [virtual]

Read receives the profile with record number recno from the profile storage. Record numbers range from 0 to DataConnManager::c_data_conn_profile_count - 1.

Reimplemented from DataConnProfileStorage.

BOOLEAN FfsDataConnProfileStorage::Read ( Header & header ) [virtual]

BOOLEAN FfsDataConnProfileStorage::Write | ( | INT | recno,
 |  | const PersistDataConnProfile & | pdcp
 | ) | [virtual]

Write saves profile data to record number recno. Record numbers range from 0 to DataConnManager::c_data_conn_profile_count - 1.

Reimplemented from DataConnProfileStorage.

BOOLEAN FfsDataConnProfileStorage::Write ( const Header & header ) [virtual]

Field Documentation

FlsFile FfsDataConnProfileStorage::m_file

The documentation for this class was generated from the following files:
  • Applications/DataConn/MyDataConnProfileStorage.hpp
  • Applications/DataConn/MyDataConnProfileStorage.cpp
Generated on Wed Jan 25 01:14:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsDrmAttrib Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsDrmAttrib Struct Reference
[Flash File System support]

FfsDrmAttrib contains the digital rights management attribute. More...

#include <Apoxi/Afs/Ffs/FfsTypes.hpp>

Data Fields

UINT16 | local_id
UINT16 | mime_type

Detailed Description

FfsDrmAttrib contains the digital rights management attribute.

Field Documentation

UINT16 FfsDrmAttrib::local_id

UINT16 FfsDrmAttrib::mime_type

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsTypes.hpp
Generated on Wed Jan 25 01:14:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsFile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsFile Class Reference

#include <Apoxi/Compat/FfsFile.hpp>

Collaboration diagram for FfsFile:

[legend]

Public Member Functions

BOOLEAN | Append (const void FFS_HUGE *src, UINT16 nof)
BOOLEAN | Close ()
BOOLEAN | Create (const CHAR *filename, MimeType mime_type, UINT32 size)
BOOLEAN | Create (const CHAR *filename, FfsFileType file_type, UINT32 size)
BOOLEAN | Create (const CHAR *filename, UINT32 size)
BOOLEAN | Create (FfsFileId id, MimeType mime_type, UINT32 size)
Please refer to MimeTypeTable for possible MimeTypes.
BOOLEAN | Create (FfsFileId id, FfsFileType file_type, UINT32 size)
BOOLEAN | Delete ()
FfsFile ()
UINT32 | GetFileSize ()
FfsFileType GetFileType ()
FfsError | GetLastError () const
FfsTimeRecord GetTimestamp ()
BOOLEAN | Modify (const void FFS_HUGE *src, UINT32 offset, UINT16 nof)
BOOLEAN | Open (const CHAR *filename, MimeType mime_type, FfsOpenMode mode)
BOOLEAN | Open (const CHAR *filename, FfsFileType file_type, FfsOpenMode mode)
BOOLEAN | Open (const CHAR *filename, FfsOpenMode mode)
BOOLEAN | Open (FfsFileId id, MimeType mime_type, FfsOpenMode mode)
Please refer to MimeTypeTable for possible MimeTypes.
BOOLEAN | Open (FfsFileId id, FfsFileType file_type, FfsOpenMode mode)
Please refer to FFSTypes for possible FfsOpenModes.
BOOLEAN | Read (UINT32 offset, void FFS_HUGE *dst, UINT16 nof)
BOOLEAN | Rename (const CHAR *new_filename)
BOOLEAN | Rename (FfsFileId new_id)
BOOLEAN | Write (const void FFS_HUGE *src, UINT32 offset, UINT16 nof)
~FfsFile ()

Detailed Description

FfsFile is the class which enables the user to store data (e.g. SMS, Phonebook,...) in a non-volatile memory.

Constructor & Destructor Documentation

FfsFile::FfsFile ( )

FfsFile::~FfsFile ( )

Member Function Documentation

BOOLEAN FfsFile::Append | ( | const void FFS_HUGE * | src,
 |  | UINT16 | nof
 | ) |

BOOLEAN FfsFile::Close ( )

BOOLEAN FfsFile::Create | ( | const CHAR * | filename,
 |  | MimeType | mime_type,
 |  | UINT32 | size
 | ) |

BOOLEAN FfsFile::Create | ( | const CHAR * | filename,
 |  | FfsFileType | file_type,
 |  | UINT32 | size
 | ) |

BOOLEAN FfsFile::Create | ( | const CHAR * | filename,
 |  | UINT32 | size
 | ) |

be aware to give the full filename including the extension, otherwise the operation will fail.

BOOLEAN FfsFile::Create | ( | FfsFileId | id,
 |  | MimeType | mime_type,
 |  | UINT32 | size
 | ) |

Please refer to MimeTypeTable for possible MimeTypes.

BOOLEAN FfsFile::Create | ( | FfsFileId | id,
 |  | FfsFileType | file_type,
 |  | UINT32 | size
 | ) |

Creates the file. After creation the FfsOpenMode is set to c_write_mode.

BOOLEAN FfsFile::Delete ( )

UINT32 FfsFile::GetFileSize ( )

FfsFileType FfsFile::GetFileType ( )

FfsError FfsFile::GetLastError ( ) const [inline]

FfsTimeRecord FfsFile::GetTimestamp ( )

BOOLEAN FfsFile::Modify | ( | const void FFS_HUGE * | src,
 |  | UINT32 | offset,
 |  | UINT16 | nof
 | ) |

BOOLEAN FfsFile::Open | ( | const CHAR * | filename,
 |  | MimeType | mime_type,
 |  | FfsOpenMode | mode
 | ) |

BOOLEAN FfsFile::Open | ( | const CHAR * | filename,
 |  | FfsFileType | file_type,
 |  | FfsOpenMode | mode
 | ) |

BOOLEAN FfsFile::Open | ( | const CHAR * | filename,
 |  | FfsOpenMode | mode
 | ) |

be aware to give the full filename including the extension, otherwise the operation will fail.

BOOLEAN FfsFile::Open | ( | FfsFileId | id,
 |  | MimeType | mime_type,
 |  | FfsOpenMode | mode
 | ) |

Please refer to MimeTypeTable for possible MimeTypes.

BOOLEAN FfsFile::Open | ( | FfsFileId | id,
 |  | FfsFileType | file_type,
 |  | FfsOpenMode | mode
 | ) |

Please refer to FFSTypes for possible FfsOpenModes.

BOOLEAN FfsFile::Read | ( | UINT32 | offset,
 |  | void FFS_HUGE * | dst,
 |  | UINT16 | nof
 | ) |

BOOLEAN FfsFile::Rename ( const CHAR * new_filename )

BOOLEAN FfsFile::Rename ( FfsFileId new_id )

BOOLEAN FfsFile::Write | ( | const void FFS_HUGE * | src,
 |  | UINT32 | offset,
 |  | UINT16 | nof
 | ) |

The documentation for this class was generated from the following files:
  • Compat/FfsFile.hpp
  • Compat/FfsFile.cpp
Generated on Wed Jan 25 01:14:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsFileInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsFileInfo Struct Reference
[Flash File System support]

#include <Apoxi/Afs/Ffs/FfsTypes.hpp>

Collaboration diagram for FfsFileInfo:

[legend]

Data Fields

FfsDrmAttrib drm_attrib
UINT8 | dynamic
UINT8 | reserved
UINT32 | size
FfsTimeRecord timestamp
FfsFileType type

Detailed Description

FfsFileInfo contains information regarding the type, size and last modification.

Field Documentation

FfsDrmAttrib FfsFileInfo::drm_attrib

UINT8 FfsFileInfo::dynamic

UINT8 FfsFileInfo::reserved

UINT32 FfsFileInfo::size

FfsTimeRecord FfsFileInfo::timestamp

FfsFileType FfsFileInfo::type

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsTypes.hpp
Generated on Wed Jan 25 01:14:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsHandler Class Reference
[Flash File System support]

#include <Apoxi/Afs/Ffs/FfsHandler.hpp>

Static Public Member Functions

static FfsError | Append (const CHAR *filename, FfsHandle h, const void FFS_HUGE *src, UINT32 no_bytes, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Append (FfsFileId id, FfsHandle h, const void FFS_HUGE *src, UINT32 no_bytes, FfsUserType user_id=FfsUserTypeMmi)
static UINT32 | CalcFileMemOvrhd (UINT32 size, BOOLEAN use_name)
Calculates the memory overhead of a file.
static FfsError | ChangeDir (const CHAR *dir_name, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Close (const CHAR *filename, FfsHandle h, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Close (FfsFileId id, FfsHandle h, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Copy (const CHAR *filename, const CHAR *dst_filename, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Copy (FfsFileId id, FfsFileId dst_id, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Create (const CHAR *filename, FfsHandle *hp, FfsFileType type, UINT32 size, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Create (FfsFileId id, FfsHandle *hp, FfsFileType type, UINT32 size, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Delete (const CHAR *filename, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Delete (FfsFileId id, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | DeleteDir (const CHAR *dir_name, FfsUserType user_id=FfsUserTypeMmi)
static BOOLEAN | FFindFirst (CHAR *filename, const CHAR *name_spec, FfsFileType type, FfsRefType *ref_type, FfsUserType user_id=FfsUserTypeMmi)
static BOOLEAN | FFindNext (CHAR *filename, const CHAR *name_spec, FfsFileType type, FfsRefType *ref_type, FfsUserType user_id=FfsUserTypeMmi)
static BOOLEAN | FileExist (const CHAR *filename, FfsUserType user_id=FfsUserTypeMmi)
static BOOLEAN | FileExist (FfsFileId id, FfsUserType user_id=FfsUserTypeMmi)
static BOOLEAN | FindFirst (CHAR *filename, const CHAR *name_spec, FfsFileType type, FfsUserType user_id=FfsUserTypeMmi)
static BOOLEAN | FindFirst (FfsFileId *id, FfsFileType type)
static BOOLEAN | FindNext (CHAR *filename, const CHAR *name_spec, FfsFileType type, FfsUserType user_id=FfsUserTypeMmi)
static BOOLEAN | FindNext (FfsFileId last_id, FfsFileId *id, FfsFileType type)
static FfsError | GetCurrentDir (CHAR *current_dir, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | GetDrmAttrib (const CHAR *filename, FfsDrmAttrib &attrib, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | GetDrmAttrib (FfsFileId id, FfsDrmAttrib &attrib, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | GetFileId (FfsFileId *id, const CHAR *filename, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | GetFileInfo (const CHAR *filename, FfsFileInfo *info, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | GetFileInfo (FfsFileId id, FfsFileInfo *info, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | GetFileName (CHAR *filename, FfsFileId id, FfsUserType user_id=FfsUserTypeMmi)
static UINT32 | GetFreeFfsSpace ()
static UINT32 | GetFreeSpaceByType (FfsFileType type)
static UINT32 | GetFreeSpaceInGlobalPool ()
static FfsFileId | GetNextFreeId ()
static UINT16 | GetNofFiles ()
static UINT16 | GetNofFilesByType (FfsFileType type)
static UINT32 | GetReservedSpace ()
Returns the reserved space of the global memory pool.
static UINT32 | GetReservedSpace (FfsFileType type)
static UINT32 | GetTotalSpace ()
static UINT32 | GetUsedSpace ()
static UINT32 | GetUsedSpaceByType (FfsFileType type)
static UINT32 | GetUsedSpaceInGlobalPool ()
Returns the used space in the global pool.
static BOOLEAN | IsDirectory (const CHAR *pathname, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | MakeDir (const CHAR *dir_name, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Modify (const CHAR *filename, FfsHandle h, const void FFS_HUGE *src, UINT32 offset, UINT32 no_bytes, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Modify (FfsFileId id, FfsHandle h, const void FFS_HUGE *src, UINT32 offset, UINT32 no_bytes, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Open (const CHAR *filename, FfsHandle *hp, FfsOpenMode mode, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Open (FfsFileId id, FfsHandle *hp, FfsOpenMode mode, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Read (const CHAR *filename, FfsHandle h, UINT32 offset, void FFS_HUGE *dst, UINT32 no_bytes, FfsUserType user_id=FfsUserTypeMmi, void(callback_func)(FfsError result)=NULL)
static FfsError | Read (FfsFileId id, FfsHandle h, UINT32 offset, void FFS_HUGE *dst, UINT32 no_bytes, FfsUserType user_id=FfsUserTypeMmi, void(callback_func)(FfsError result)=NULL)
static FfsError | Rename (const CHAR *filename, const CHAR *new_filename, FfsFileType new_type, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Rename (FfsFileId id, FfsFileId new_id, FfsFileType new_type, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | SetDrmAttrib (const CHAR *filename, const FfsDrmAttrib &attrib, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | SetDrmAttrib (FfsFileId id, const FfsDrmAttrib &attrib, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Truncate (const CHAR *filename, UINT32 new_size, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Truncate (FfsFileId id, UINT32 new_size, FfsUserType user_id=FfsUserTypeMmi)
static FfsError | Write (const CHAR *filename, FfsHandle h, const void FFS_HUGE *src, UINT32 offset, UINT32 no_bytes, FfsUserType user_id=FfsUserTypeMmi, void(callback_func)(FfsError result)=NULL)
static FfsError | Write (FfsFileId id, FfsHandle h, const void FFS_HUGE *src, UINT32 offset, UINT32 no_bytes, FfsUserType user_id=FfsUserTypeMmi, void(callback_func)(FfsError result)=NULL)

Detailed Description

FfsHandler provides an object-oriented interface to the FFS. Please also refer to the class FlsFile, which provides an easy-to-use interface for using the FFS.

The following code fragment shows some examples of the FfsHandler interface. If working on host, you can easily observe the content of the file with a simple text-editor.

    FfsHandle fhandle;
    const CHAR *fname = "A";
    const INT fsize = 128;
    const INT offset = 0;
    const CHAR src[] = "This text is written into the file.";
    const CHAR mod_src[] = "This text overwrites some data in the file.";

    // Check if the file already exists.
    if (!FfsHandler::FileExist(fname)) {
        // Create the file if not already created.
        if (FfsHandler::Create(fname, &fhandle, FfsFileTypeTxt, fsize) == FfsErrorSuccess) {
            // Write something into the file starting at offset.
            if (FfsHandler::Write(fname, fhandle, src, offset, sizeof(src)) == FfsErrorSuccess) {
                // Close the file again.
                FfsHandler::Close(fname, fhandle);
            } else {
                // Deal with the error.
                return FALSE;
            }
        } else {
            // Deal with the error.
            return FALSE;
        }
    } else {
        // Open the file in modify mode if it already exists.
        if (FfsHandler::Open(fname, &fhandle, FfsOpenModeModify) == FfsErrorSuccess) {
            // Modify a part of the file.
            if (FfsHandler::Modify(fname, fhandle, mod_src, offset, sizeof(mod_src)) == FfsErrorSuccess) {
                // Close the file again.
                FfsHandler::Close(fname, fhandle);
            } else {
                // Deal with the error.
                return FALSE;
            }
        } else {
            // Deal with the error.
            return FALSE;
        }
    }
    return TRUE;

NOTE: Please do not instantiate this class.

Member Function Documentation

FfsError FfsHandler::Append | ( | const CHAR * | filename,
 |  | FfsHandle | h,
 |  | const void FFS_HUGE * | src,
 |  | UINT32 | no_bytes,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Adds the data from the specified src at the end of the file with the specified filename. Only possible if the file exists and is open in FfsOpenModeAppend.

FfsError FfsHandler::Append | ( | FfsFileId | id,
 |  | FfsHandle | h,
 |  | const void FFS_HUGE * | src,
 |  | UINT32 | no_bytes,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Adds the data from the specified src at the end of the file with the specified id. Only possible if the file exists and is open in FfsOpenModeAppend.

UINT32 FfsHandler::CalcFileMemOvrhd | ( | UINT32 | size,
 |  | BOOLEAN | use_name
 | ) | [static]

Calculates the memory overhead of a file.

FfsError FfsHandler::ChangeDir | ( | const CHAR * | dir_name,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Changes the current working directory.

Parameters:
dir_name The name of the directory to be changed to.
Returns:
If the operation is successful.

FfsError FfsHandler::Close | ( | const CHAR * | filename,
 |  | FfsHandle | h,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Closes a file with the specified filename. Only possible if the file exists and is not already open.

FfsError FfsHandler::Close | ( | FfsFileId | id,
 |  | FfsHandle | h,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Closes a file with the specified id. Only possible if the file exists and is not already open.

FfsError FfsHandler::Copy | ( | const CHAR * | filename,
 |  | const CHAR * | dst_filename,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies an existing file with the specified filename to new file with dst_filename. Only possible if the source file exists and is closed. The destination file will be created automatically, afterwards the content of the source file will be written in the destination file.

FfsError FfsHandler::Copy | ( | FfsFileId | id,
 |  | FfsFileId | dst_id,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies an existing file with the specified id to a new file with dst_id. Only possible if the source file exists and is closed. The destination file will be created automatically, afterwards the content of the source file will be written in the destination file.

FfsError FfsHandler::Create | ( | const CHAR * | filename,
 |  | FfsHandle * | hp,
 |  | FfsFileType | type,
 |  | UINT32 | size,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Creates a new file with the specified filename and size. The file is opened in write-mode afterwards. Stores the file handle at the location specified by hp.

FfsError FfsHandler::Create | ( | FfsFileId | id,
 |  | FfsHandle * | hp,
 |  | FfsFileType | type,
 |  | UINT32 | size,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Creates a new file with the specified id and size. The file is opened in write-mode afterwards. Stores the file handle at the location specified by hp.

FfsError FfsHandler::Delete | ( | const CHAR * | filename,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Deletes the file with the specified filename and any further operations will be rejected. The file should not be open when this operation is requested.

FfsError FfsHandler::Delete | ( | FfsFileId | id,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Deletes the file with the specified id and any further operations will be rejected. The file should not be open when this operation is requested.

FfsError FfsHandler::DeleteDir | ( | const CHAR * | dir_name,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Deletes the directory with the specified name.

Parameters:
dir_name The name of the directory, which should be deleted.
Returns:
An error code, which gives information about the success.

BOOLEAN FfsHandler::FFindFirst | ( | CHAR * | filename,
 |  | const CHAR * | name_spec,
 |  | FfsFileType | type,
 |  | FfsRefType * | ref_type,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Works like FindFirst, but also supports directories.

Parameters:
filename | The pathname of the first found file.
name_spec | A pattern for matching files, e.g. *.

BOOLEAN FfsHandler::FFindNext | ( | CHAR * | filename,
 |  | const CHAR * | name_spec,
 |  | FfsFileType | type,
 |  | FfsRefType * | ref_type,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Works like FindNext, but also supports directories.

Parameters:
filename | The pathname of the first found file.
name_spec | A pattern for matching files, e.g. *.

BOOLEAN FfsHandler::FileExist | ( | const CHAR * | filename,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Checks the presence of the file in the FFS with the specified filename

BOOLEAN FfsHandler::FileExist | ( | FfsFileId | id,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Checks the presence of the file in the FFS with the specified id

BOOLEAN FfsHandler::FindFirst | ( | CHAR * | filename,
 |  | const CHAR * | name_spec,
 |  | FfsFileType | type,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies the name of the first found file with the specified type and complying to the pattern name_spec into filename. Use FfsFileTypeAll to find files of all types.

BOOLEAN FfsHandler::FindFirst | ( | FfsFileId * | id,
 |  | FfsFileType | type
 | ) | [static]

Copies the file ID of the first file with the specified type into id. Use FfsFileTypeAll to find files of all types.

BOOLEAN FfsHandler::FindNext | ( | CHAR * | filename,
 |  | const CHAR * | name_spec,
 |  | FfsFileType | type,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies the first stored file-id of the specified type into filename. Use FfsFileTypeAll to find files of all types.

BOOLEAN FfsHandler::FindNext | ( | FfsFileId | last_id,
 |  | FfsFileId * | id,
 |  | FfsFileType | type
 | ) | [static]

Copies the file ID of the next found file with the specified type after the file with ID last_id into id. Use FfsFileTypeAll to find files of all types.

FfsError FfsHandler::GetCurrentDir | ( | CHAR * | current_dir,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Changes the current working directory.

Parameters:
current_dir Buffer where to store the name of the current directory.
Returns:
If the operation is successful.

FfsError FfsHandler::GetDrmAttrib | ( | const CHAR * | filename,
 |  | FfsDrmAttrib & | attrib,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Gets the digital rights management attribute of file with name filename via attrib.

FfsError FfsHandler::GetDrmAttrib | ( | FfsFileId | id,
 |  | FfsDrmAttrib & | attrib,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Gets the digital rights management attribute of file with ID id via attrib.

FfsError FfsHandler::GetFileId | ( | FfsFileId * | id,
 |  | const CHAR * | filename,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies the regarding ID of the file with the specified filename into id

FfsError FfsHandler::GetFileInfo | ( | const CHAR * | filename,
 |  | FfsFileInfo * | info,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies information data of the file with the specified filename into info containing: FfsFileType, size, timestamp.

FfsError FfsHandler::GetFileInfo | ( | FfsFileId | id,
 |  | FfsFileInfo * | info,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies information data of the file with the specified id into info containing: FfsFileType, size, timestamp.

FfsError FfsHandler::GetFileName | ( | CHAR * | filename,
 |  | FfsFileId | id,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies the regarding filename of the file with the specified id into filename

UINT32 FfsHandler::GetFreeFfsSpace ( ) [static]

Returns the number of available bytes free in the FFS.

UINT32 FfsHandler::GetFreeSpaceByType ( FfsFileType type ) [static]

Returns the number of available bytes free in the regarding memory pool of the specified type.

UINT32 FfsHandler::GetFreeSpaceInGlobalPool ( ) [static]

Returns the number of available bytes free in the global memory pool.

FfsFileId FfsHandler::GetNextFreeId ( ) [static]

Returns the next available FfsFileId or 0xFFFF if no id is available.

UINT16 FfsHandler::GetNofFiles ( ) [static]

Returns the number of the stored files in the FFS.

UINT16 FfsHandler::GetNofFilesByType ( FfsFileType type ) [static]

Returns the number of the stored files in the FFS with the specified type.

UINT32 FfsHandler::GetReservedSpace ( ) [static]

Returns the reserved space of the global memory pool.

UINT32 FfsHandler::GetReservedSpace ( FfsFileType type ) [static]

Returns the reserved space of the regarding memory pool. This method should be called to determine if the usage of GetUsedSpaceByType() is possible. These values are defined at compile-time, in the ffs_memory_pool_reservations-table, which is located in the file ffs_def.h, and therefore never change.

UINT32 FfsHandler::GetTotalSpace ( ) [static]

Returns the maximum available bytes in the FFS, i.e.: The amount of free bytes in an empty FFS. This value is defined at compile-time, and therefore never changes.

UINT32 FfsHandler::GetUsedSpace ( ) [static]

Returns the total number of bytes used in the FFS. Please be aware, that the amount is always larger than the sum of all filesizes, since there is some overhead included due to the nature of the FFS.

UINT32 FfsHandler::GetUsedSpaceByType ( FfsFileType type ) [static]

Returns the total number of bytes used in the regarding memory pool. If no reservation (i.e.: 0 bytes) is defined in the ffs_memory_pool_reservations-table, which is located in the file ffs_def.h, the return value is also 0. Therefore, it is necessary to check the reserved space for the memory pool via the GetReservedSpace() method to make sure the usage of this method makes sense. Please be aware, that the amount is always larger than the sum of all filesizes in the regarding memory pool, since there is some overhead included due to the nature of the FFS.

UINT32 FfsHandler::GetUsedSpaceInGlobalPool ( ) [static]

Returns the used space in the global pool.

BOOLEAN FfsHandler::IsDirectory | ( | const CHAR * | pathname,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Judge if a path name is a directory.

Parameters:
pathname The directory name to be judged.
Returns:
TRUE if the pathname is a directory. FALSE if the pathname is not a directory.

FfsError FfsHandler::MakeDir | ( | const CHAR * | dir_name,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Creates a new directory.

Parameters:
dir_name The name of the directory to be created.
Returns:
If the operation is successful.

FfsError FfsHandler::Modify | ( | const CHAR * | filename,
 |  | FfsHandle | h,
 |  | const void FFS_HUGE * | src,
 |  | UINT32 | offset,
 |  | UINT32 | no_bytes,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies the data from the specified src into the file with the specified filename. Only possible if the file exists and is open in FfsOpenModeModify.

FfsError FfsHandler::Modify | ( | FfsFileId | id,
 |  | FfsHandle | h,
 |  | const void FFS_HUGE * | src,
 |  | UINT32 | offset,
 |  | UINT32 | no_bytes,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Copies the data from the specified src into the file with the specified id. Only possible if the file exists and is open in FfsOpenModeModify.

FfsError FfsHandler::Open | ( | const CHAR * | filename,
 |  | FfsHandle * | hp,
 |  | FfsOpenMode | mode,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Opens a file with the specified filename in the specified mode. Only possible if the file exists and is not already open. Stores the file handle at the location specified by hp.

FfsError FfsHandler::Open | ( | FfsFileId | id,
 |  | FfsHandle * | hp,
 |  | FfsOpenMode | mode,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Opens a file with the specified id in the specified mode. Only possible if the file exists and is not already open. Stores the file handle at the location specified by hp.

FfsError FfsHandler::Read | ( | const CHAR * | filename,
 |  | FfsHandle | h,
 |  | UINT32 | offset,
 |  | void FFS_HUGE * | dst,
 |  | UINT32 | no_bytes,
 |  | FfsUserType | user_id = FfsUserTypeMmi,
 |  | void(callback_func)(FfsError result) | = NULL
 | ) | [static]

Copies the data from the specified filename into the specified dst. Only possible if the file exists and is open in FfsOpenModeRead.

FfsError FfsHandler::Read | ( | FfsFileId | id,
 |  | FfsHandle | h,
 |  | UINT32 | offset,
 |  | void FFS_HUGE * | dst,
 |  | UINT32 | no_bytes,
 |  | FfsUserType | user_id = FfsUserTypeMmi,
 |  | void(callback_func)(FfsError result) | = NULL
 | ) | [static]

Copies the data from the specified id into the specified dst. Only possible if the file exists and is open in FfsOpenModeRead.

FfsError FfsHandler::Rename | ( | const CHAR * | filename,
 |  | const CHAR * | new_filename,
 |  | FfsFileType | new_type,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Renames an existing file with the specified filename to new_filename and converts the file to the specified new_type. The file should not be open when this operation is requested.

FfsError FfsHandler::Rename | ( | FfsFileId | id,
 |  | FfsFileId | new_id,
 |  | FfsFileType | new_type,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Renames an existing file with the specified id to new_id and converts the file to the specified new_type. The file should not be open when this operation is requested.

FfsError FfsHandler::SetDrmAttrib | ( | const CHAR * | filename,
 |  | const FfsDrmAttrib & | attrib,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Sets the digital rights management attribute of file with name filename to attrib.

FfsError FfsHandler::SetDrmAttrib | ( | FfsFileId | id,
 |  | const FfsDrmAttrib & | attrib,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

Sets the digital rights management attribute of file with ID id to attrib.

FfsError FfsHandler::Truncate | ( | const CHAR * | filename,
 |  | UINT32 | new_size,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

FfsError FfsHandler::Truncate | ( | FfsFileId | id,
 |  | UINT32 | new_size,
 |  | FfsUserType | user_id = FfsUserTypeMmi
 | ) | [static]

FfsError FfsHandler::Write | ( | const CHAR * | filename,
 |  | FfsHandle | h,
 |  | const void FFS_HUGE * | src,
 |  | UINT32 | offset,
 |  | UINT32 | no_bytes,
 |  | FfsUserType | user_id = FfsUserTypeMmi,
 |  | void(callback_func)(FfsError result) | = NULL
 | ) | [static]

Copies the data from the specified src into the file with the specified filename.Only possible if the file exists and is open in write-mode.

FfsError FfsHandler::Write | ( | FfsFileId | id,
 |  | FfsHandle | h,
 |  | const void FFS_HUGE * | src,
 |  | UINT32 | offset,
 |  | UINT32 | no_bytes,
 |  | FfsUserType | user_id = FfsUserTypeMmi,
 |  | void(callback_func)(FfsError result) | = NULL
 | ) | [static]

Copies the data from the specified src into the file with the specified id. Only possible if the file exists and is open in write-mode.

The documentation for this class was generated from the following files:
  • Afs/Ffs/FfsHandler.hpp
  • Afs/Ffs/FfsHandler.cpp
Generated on Wed Jan 25 01:14:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsMenu Class Reference

#include <Applications/SocketTest/FfsMenu.hpp>

Collaboration diagram for FfsMenu:

[legend]

Public Member Functions

FfsMenu ()
constructor
BOOLEAN | First ()
go to first item
virtual const BitmapRes * | GetItemIcon (BOOLEAN highlighted)
returns item icon
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
returns item text
void | Init ()
object initialization
BOOLEAN | Next ()
go to next item
virtual | ~FfsMenu ()
destructor

Protected Member Functions

INT | GetIndex () const
returns current item index
virtual void | OnTrigger (INT selected_idx)
called when item selected

Detailed Description

FfsMenu class

Constructor & Destructor Documentation

FfsMenu::FfsMenu ( )

constructor

Constructor for FfsMenu

FfsMenu::~FfsMenu ( ) [virtual]

destructor

Destructor for FfsMenu

Member Function Documentation

BOOLEAN FfsMenu::First ( )

go to first item

Goes to the first item in menu.

Return values:
always returns TRUE

INT FfsMenu::GetIndex ( ) const [inline, protected]

returns current item index

const BitmapRes * FfsMenu::GetItemIcon ( BOOLEAN highlighted ) [virtual]

returns item icon

Returns the current item icon.

Return values:
pointer to item icon

const WCHAR * FfsMenu::GetItemText ( BOOLEAN highlighted ) [virtual]

returns item text

Returns the current item text.

Return values:
pointer to item text

void FfsMenu::Init ( )

object initialization

Initializes FfsMenu.

BOOLEAN FfsMenu::Next ( )

go to next item

Goes to the next item in menu.

Return values:
TRUE if successful, FALSE if there are no more items

void FfsMenu::OnTrigger ( INT selected_idx ) [protected, virtual]

called when item selected

Called when some item is choosed in menu.

Parameters:
selected_idx - index of selected item

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsMenu.hpp
  • Applications/SocketTest/FfsMenu.cpp
Generated on Wed Jan 25 01:14:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsMimeTypeMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsMimeTypeMap Class Reference
[Flash File System support]

#include <Apoxi/Afs/Ffs/FfsMimeTypeMap.hpp>

Collaboration diagram for FfsMimeTypeMap:

[legend]

Static Public Member Functions

static const CHAR * | GetExtByFileType (FfsFileType file_type)
static FfsFileType | GetFileTypeByExt (const CHAR *extension)
static FfsFileType | GetFileTypeByMimeStr (const CHAR *mime_str)
static FfsFileType | GetFileTypeByMimeType (MimeType mime_type, UINT8 offset=0)
static const CHAR * | GetMimeStrByFileType (FfsFileType file_type)
static MimeType | GetMimeTypeByFileType (FfsFileType file_type)
static INT | IsBinaryByFileType (FfsFileType file_type)
static INT | IsTextByFileType (FfsFileType file_type)

Detailed Description

Class FfsMimeTypeMap provides static methods for getting MIME type table information based on the type of a flash file and vice versa.

See also:
MimeTypeTable

Member Function Documentation

const CHAR * FfsMimeTypeMap::GetExtByFileType ( FfsFileType file_type ) [static]

FfsFileType FfsMimeTypeMap::GetFileTypeByExt ( const CHAR * extension ) [static]

FfsFileType FfsMimeTypeMap::GetFileTypeByMimeStr ( const CHAR * mime_str ) [static]

FfsFileType FfsMimeTypeMap::GetFileTypeByMimeType | ( | MimeType | mime_type,
 |  | UINT8 | offset = 0
 | ) | [static]

More than one filetype can be registered for a particular MIME type. E.g. c_mime_audio_mpeg FfsFileTypeMp3 c_mime_audio_mpeg FfsFileTypeMpga If the order of the filetypes is known, the offset can be used to choose a particular filetype. In the example above GetFileTypeByMimeType(c_mime_audio_mpeg, 1) would return FfsFileTypeMpga.

const CHAR * FfsMimeTypeMap::GetMimeStrByFileType ( FfsFileType file_type ) [static]

static MimeType FfsMimeTypeMap::GetMimeTypeByFileType ( FfsFileType file_type ) [inline, static]

INT FfsMimeTypeMap::IsBinaryByFileType ( FfsFileType file_type ) [static]

INT FfsMimeTypeMap::IsTextByFileType ( FfsFileType file_type ) [static]

The documentation for this class was generated from the following files:
  • Afs/Ffs/FfsMimeTypeMap.hpp
  • Afs/Ffs/FfsMimeTypeMap.cpp
Generated on Wed Jan 25 01:14:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsMimeTypeMapEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsMimeTypeMapEntry Struct Reference
[Flash File System support]

#include <Apoxi/Afs/Ffs/FfsMimeTypeMap.hpp>

Data Fields

FfsFileType ffs_type
MimeType mime_type

Field Documentation

FfsFileType FfsMimeTypeMapEntry::ffs_type

MimeType FfsMimeTypeMapEntry::mime_type

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsMimeTypeMap.hpp
Generated on Wed Jan 25 01:14:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsRefType Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsRefType Struct Reference
[Flash File System support]

#include <Apoxi/Afs/Ffs/FfsTypes.hpp>

Data Fields

UINT16 | dir_id
UINT16 | file_id
UINT16 | finding_dirs

Detailed Description

FfsRefType contains references to a file and to the corresponding parent directory.

Field Documentation

UINT16 FfsRefType::dir_id

UINT16 FfsRefType::file_id

UINT16 FfsRefType::finding_dirs

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsTypes.hpp
Generated on Wed Jan 25 01:14:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTestBase::FfsTestInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
FfsTestBase::FfsTestInfo

FfsTestBase::FfsTestInfo Struct Reference

#include <Applications/SocketTest/FfsTestBase.hpp>

Data Fields

BOOLEAN | m_bTestEnabled
Indication if test is enabled.
UINT32 | m_nErrorCode
Error code of test.
UINT32 | m_nIterationsDone
Finished number of iterations of test.
UINT32 | m_nIterationsSuccessfull
Number of successfully finished iterations of test.
UINT32 | m_nIterationsTotal
Total number of iterations of test.
Status | m_nStatus
Status of test.
WCHAR | m_wsName [20]
Test name.

Detailed Description

Structure holding the test group settings.

Field Documentation

BOOLEAN FfsTestBase::FfsTestInfo::m_bTestEnabled

Indication if test is enabled.

UINT32 FfsTestBase::FfsTestInfo::m_nErrorCode

Error code of test.

UINT32 FfsTestBase::FfsTestInfo::m_nIterationsDone

Finished number of iterations of test.

UINT32 FfsTestBase::FfsTestInfo::m_nIterationsSuccessfull

Number of successfully finished iterations of test.

UINT32 FfsTestBase::FfsTestInfo::m_nIterationsTotal

Total number of iterations of test.

Status FfsTestBase::FfsTestInfo::m_nStatus

Status of test.

WCHAR FfsTestBase::FfsTestInfo::m_wsName[20]

Test name.

The documentation for this struct was generated from the following file:
  • Applications/SocketTest/FfsTestBase.hpp
Generated on Wed Jan 25 01:14:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTestDispWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTestDispWin Class Reference

#include <Applications/SocketTest/FfsTestDispWin.hpp>

Collaboration diagram for FfsTestDispWin:

[legend]

Public Member Functions

FfsTestDispWin ()
constructor
FfsTestBase * | GetFfsTestBase ()
Mutex & GetMutex ()
void | Init ()
initialization
void | OnTimer ()
void | RefreshScreen ()
refreshes the screen
virtual | ~FfsTestDispWin ()
destructor

Static Public Member Functions

static void | ClearThreadlet ()
static FfsTestThreadlet * | GetThreadlet ()

Protected Member Functions

virtual void | OnClose ()
calles when closing window
virtual void | OnOpen ()
called when opening window
virtual void | OnPaint (const Rect &repaint_rect)
called when window needs repainting
virtual BOOLEAN | OnSoftkeyPressed (INT idx)
called when softkey is pressed

Friends

class | TriggerTimer< FfsTestDispWin >

Detailed Description

Window that opens when testing is in progress. It displays informations of finished tests and current progress.

Constructor & Destructor Documentation

FfsTestDispWin::FfsTestDispWin ( )

constructor

Constructor for progress window.

FfsTestDispWin::~FfsTestDispWin ( ) [virtual]

destructor

Destructor for progress window .

Member Function Documentation

static void FfsTestDispWin::ClearThreadlet ( ) [inline, static]

FfsTestBase* FfsTestDispWin::GetFfsTestBase ( ) [inline]

Mutex& FfsTestDispWin::GetMutex ( ) [inline]

static FfsTestThreadlet* FfsTestDispWin::GetThreadlet ( ) [inline, static]

void FfsTestDispWin::Init ( )

initialization

Initializes progress window.

void FfsTestDispWin::OnClose ( ) [protected, virtual]

calles when closing window

Called on closing the progress window.

void FfsTestDispWin::OnOpen ( ) [protected, virtual]

called when opening window

Called on opening the progress window.

void FfsTestDispWin::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

called when window needs repainting

Called when screen must be repainted.

Parameters:
repaint_rect - rectangle to be repainted

BOOLEAN FfsTestDispWin::OnSoftkeyPressed ( INT idx ) [protected, virtual]

called when softkey is pressed

Called when softkey of progress window is pressed.

Parameters:
idx - index of pressed softkey
Return values:
TRUE if action is handled

void FfsTestDispWin::OnTimer ( )

Called regularly on timer.

void FfsTestDispWin::RefreshScreen ( )

refreshes the screen

Refreshes the screen with test informations.

Friends And Related Function Documentation

friend class TriggerTimer< FfsTestDispWin > [friend]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsTestDispWin.hpp
  • Applications/SocketTest/FfsTestDispWin.cpp
Generated on Wed Jan 25 01:14:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTestMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTestMenu Class Reference

#include <Applications/SocketTest/FfsTestMenu.hpp>

Collaboration diagram for FfsTestMenu:

[legend]

Public Member Functions

FfsTestMenu ()
constructor
BOOLEAN | First ()
goes to first item
virtual const BitmapRes * | GetItemIcon (BOOLEAN highlighted)
gets current item icon
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
gets current item text
void | Init ()
initializes object
BOOLEAN | Next ()
goes to next item
virtual | ~FfsTestMenu ()
destructor

Protected Member Functions

INT | GetIndex () const
returns current item index
virtual void | OnTrigger (INT selected_idx)
called when item selected

Detailed Description

FfsTestMenu class is menu with listed all test . When one test group is selected from menu, FfsTestSubMenu menu is opened.

Constructor & Destructor Documentation

FfsTestMenu::FfsTestMenu ( )

constructor

Constructor for FfsTestMenu

FfsTestMenu::~FfsTestMenu ( ) [virtual]

destructor

Destructor for FfsTestMenu

Member Function Documentation

BOOLEAN FfsTestMenu::First ( )

goes to first item

Goes to first menu item.

Return values:
always returns TRUE

INT FfsTestMenu::GetIndex ( ) const [inline, protected]

returns current item index

const BitmapRes * FfsTestMenu::GetItemIcon ( BOOLEAN highlighted ) [virtual]

gets current item icon

Returns the current item icon.

Return values:
pointer to item icon

const WCHAR * FfsTestMenu::GetItemText ( BOOLEAN highlighted ) [virtual]

gets current item text

Returns the current item text.

Return values:
pointer to item text

void FfsTestMenu::Init ( )

initializes object

This method is used to initialize FfsTestMenu object. It must be called before any other call to this object.

BOOLEAN FfsTestMenu::Next ( )

goes to next item

Goes to the next item in menu.

Return values:
TRUE if successful, FALSE if there are no more items

void FfsTestMenu::OnTrigger ( INT selected_idx ) [protected, virtual]

called when item selected

Called when some item is choosed in menu.

Parameters:
selected_idx - index of selected item

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsTestMenu.hpp
  • Applications/SocketTest/FfsTestMenu.cpp
Generated on Wed Jan 25 01:14:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTestResultsMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTestResultsMenu Class Reference

#include <Applications/SocketTest/FfsTestResultsMenu.hpp>

Collaboration diagram for FfsTestResultsMenu:

[legend]

Public Member Functions

FfsTestResultsMenu ()
constructor
BOOLEAN | First ()
goes to first item
virtual const BitmapRes * | GetItemIcon (BOOLEAN highlighted)
gets current item icon
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
gets current item text
void | Init ()
initializes object
BOOLEAN | Next ()
goes to next item
virtual | ~FfsTestResultsMenu ()
destructor

Protected Member Functions

INT | GetIndex () const
returns current item index
virtual void | OnTrigger (INT selected_idx)
called when item selected

Detailed Description

SocketTestResultsMenu class is menu with listed results of performed tests.

Constructor & Destructor Documentation

FfsTestResultsMenu::FfsTestResultsMenu ( )

constructor

Constructor for SocketTestResultsMenu

FfsTestResultsMenu::~FfsTestResultsMenu ( ) [virtual]

destructor

Destructor for SocketTestResultsMenu

Member Function Documentation

BOOLEAN FfsTestResultsMenu::First ( )

goes to first item

Goes to first menu item.

Return values:
always returns TRUE

INT FfsTestResultsMenu::GetIndex ( ) const [inline, protected]

returns current item index

const BitmapRes * FfsTestResultsMenu::GetItemIcon ( BOOLEAN highlighted ) [virtual]

gets current item icon

Returns the current item icon.

Return values:
pointer to item icon

const WCHAR * FfsTestResultsMenu::GetItemText ( BOOLEAN highlighted ) [virtual]

gets current item text

Returns the current item text.

Return values:
pointer to item text

void FfsTestResultsMenu::Init ( )

initializes object

This method is used to initialize SocketTestResultsMenu object. It must be called before any other call to this object.

BOOLEAN FfsTestResultsMenu::Next ( )

goes to next item

Goes to the next item in menu.

Return values:
TRUE if successful, FALSE if there are no more items

void FfsTestResultsMenu::OnTrigger ( INT selected_idx ) [protected, virtual]

called when item selected

Called when some item is choosed in menu.

Parameters:
selected_idx - index of selected item

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsTestResultsMenu.hpp
  • Applications/SocketTest/FfsTestResultsMenu.cpp
Generated on Wed Jan 25 01:14:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTestResultsSubMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTestResultsSubMenu Class Reference

#include <Applications/SocketTest/FfsTestResultsMenu.hpp>

Public Member Functions

FfsTestResultsSubMenu ()
constructor
BOOLEAN | First ()
goes to first item
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
gets current item text
void | Init (INT test=-1)
initializes object
BOOLEAN | Next ()
goes to next item
virtual | ~FfsTestResultsSubMenu ()
destructor

Protected Member Functions

INT | GetIndex () const
returns current item index
virtual void | OnTrigger (INT selected_idx)
called when item selected

Detailed Description

SocketTestResultsTestSubMenu class is menu used for displaying the test results of each test.

Constructor & Destructor Documentation

FfsTestResultsSubMenu::FfsTestResultsSubMenu ( )

constructor

Constructor for SocketTestResultsSubMenu

FfsTestResultsSubMenu::~FfsTestResultsSubMenu ( ) [virtual]

destructor

Destructor for SocketTestResultsTestSubMenu

Member Function Documentation

BOOLEAN FfsTestResultsSubMenu::First ( )

goes to first item

Goes to the first item in menu.

Return values:
always returns TRUE

INT FfsTestResultsSubMenu::GetIndex ( ) const [inline, protected]

returns current item index

const WCHAR * FfsTestResultsSubMenu::GetItemText ( BOOLEAN highlighted ) [virtual]

gets current item text

Returns the current item text.

Return values:
pointer to item text

void FfsTestResultsSubMenu::Init ( INT test = -1 )

initializes object

Initializes SocketTestResultsTestSubMenu object.

Parameters:
test - number of test group to be initialized, if -1 than just initializes base class

BOOLEAN FfsTestResultsSubMenu::Next ( )

goes to next item

Goes to the next item in menu.

Return values:
TRUE if successful, FALSE if there are no more items

void FfsTestResultsSubMenu::OnTrigger ( INT selected_idx ) [protected, virtual]

called when item selected

Called when some item is choosed in menu.

Parameters:
selected_idx - index of selected item

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsTestResultsMenu.hpp
  • Applications/SocketTest/FfsTestResultsMenu.cpp
Generated on Wed Jan 25 01:14:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTests Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTests Class Reference

#include <Applications/SocketTest/FfsTests.hpp>

Collaboration diagram for FfsTests:

[legend]

Public Member Functions

UINT32 | FfsTest_T1 ()
FfsTest_T1.
UINT32 | FfsTest_T2 ()
FfsTest_T2.
UINT32 | FfsTest_T3 ()
FfsTest_T3.
UINT32 | FfsTest_T4 ()
FfsTest_T4.
UINT32 | FfsTest_T5 ()
FfsTest_T5.
UINT32 | FfsTest_T6 ()
FfsTest_T5.
FfsTests ()
virtual | ~FfsTests ()

Constructor & Destructor Documentation

FfsTests::FfsTests ( )

FfsTests::~FfsTests ( ) [virtual]

Member Function Documentation

UINT32 FfsTests::FfsTest_T1 ( )

FfsTest_T1.

Open file if exist, otherwise create a new one and then close that file

Return values:
error code

UINT32 FfsTests::FfsTest_T2 ( )

FfsTest_T2.

Open file if exist, otherwise create a new one and then writes some text into the file. In the same time check if the file size gets increased automatically. After writing file is not closed.

Return values:
error code

UINT32 FfsTests::FfsTest_T3 ( )

FfsTest_T3.

Open file if exist, otherwise create a new one and then overwrites some data in the file.

Return values:
error code

UINT32 FfsTests::FfsTest_T4 ( )

FfsTest_T4.

Open file if exist, otherwise create a new one and then appends some data into the file.

Return values:
error code

UINT32 FfsTests::FfsTest_T5 ( )

FfsTest_T5.

Open file if exist, otherwise create a new one and then appends some data into the file.

Return values:
error code

UINT32 FfsTests::FfsTest_T6 ( )

FfsTest_T5.

Open file if exist, otherwise create a new one and then appends some data into the file.

Return values:
error code

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsTests.hpp
  • Applications/SocketTest/FfsTests.cpp
Generated on Wed Jan 25 01:14:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTestSubMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTestSubMenu Class Reference

#include <Applications/SocketTest/FfsTestMenu.hpp>

Public Member Functions

FfsTestSubMenu ()
constructor
BOOLEAN | First ()
goes to first item
virtual const BitmapRes * | GetItemIcon (BOOLEAN highlighted)
gets current item icon
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
gets current item text
void | Init (INT test=-1)
initializes object
BOOLEAN | Next ()
goes to next item
virtual | ~FfsTestSubMenu ()
destructor

Protected Member Functions

INT | GetIndex () const
returns current item index
virtual void | OnTrigger (INT selected_idx)
called when item selected

Detailed Description

FfsTestSubMenu class is menu used for setting the data in each test group. Every test group consists of several tests and for each test it's possible to change number of iterations.

Constructor & Destructor Documentation

FfsTestSubMenu::FfsTestSubMenu ( )

constructor

Constructor for FfsTestSubMenu

FfsTestSubMenu::~FfsTestSubMenu ( ) [virtual]

destructor

Destructor for FfsTestSubMenu

Member Function Documentation

BOOLEAN FfsTestSubMenu::First ( )

goes to first item

Goes to the first item in menu.

Return values:
always returns TRUE

INT FfsTestSubMenu::GetIndex ( ) const [inline, protected]

returns current item index

const BitmapRes * FfsTestSubMenu::GetItemIcon ( BOOLEAN highlighted ) [virtual]

gets current item icon

Returns the current item icon.

Return values:
pointer to item icon

const WCHAR * FfsTestSubMenu::GetItemText ( BOOLEAN highlighted ) [virtual]

gets current item text

Returns the current item text.

Return values:
pointer to item text

void FfsTestSubMenu::Init ( INT test = -1 )

initializes object

Initializes FfsTestSubMenu object.

Parameters:
test - number of test group to be initialized, if -1 than just initializes base class

BOOLEAN FfsTestSubMenu::Next ( )

goes to next item

Goes to the next item in menu.

Return values:
TRUE if successful, FALSE if there are no more items

void FfsTestSubMenu::OnTrigger ( INT selected_idx ) [protected, virtual]

called when item selected

Called when some item is choosed in menu.

Parameters:
selected_idx - index of selected item

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsTestMenu.hpp
  • Applications/SocketTest/FfsTestMenu.cpp
Generated on Wed Jan 25 01:14:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTestThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTestThread Class Reference

#include <Applications/SocketTest/FfsTestThread.hpp>

Inheritance diagram for FfsTestThread:

[legend]
Collaboration diagram for FfsTestThread:

[legend]

Public Member Functions

FfsTestThread ()
void | SetMutex (Mutex *aMutex)
virtual INT | ThreadFn ()
void | UpdateTestInfo (UINT32 aError)
virtual | ~FfsTestThread ()

Static Public Member Functions

static UINT32 | GetCurrentTest ()
static BOOLEAN | GetRunning ()
static void | SetRunning (BOOLEAN bRunning)

Constructor & Destructor Documentation

FfsTestThread::FfsTestThread ( )

FfsTestThread::~FfsTestThread ( ) [virtual]

Member Function Documentation

static UINT32 FfsTestThread::GetCurrentTest ( ) [inline, static]

static BOOLEAN FfsTestThread::GetRunning ( ) [inline, static]

void FfsTestThread::SetMutex ( Mutex * aMutex ) [inline]

static void FfsTestThread::SetRunning ( BOOLEAN bRunning ) [inline, static]

INT FfsTestThread::ThreadFn ( ) [virtual]

Implements Thread.

void FfsTestThread::UpdateTestInfo ( UINT32 aError )

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsTestThread.hpp
  • Applications/SocketTest/FfsTestThread.cpp
Generated on Wed Jan 25 01:15:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTestThreadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTestThreadlet Class Reference

#include <Applications/SocketTest/FfsTestThreadlet.hpp>

Inheritance diagram for FfsTestThreadlet:

[legend]
Collaboration diagram for FfsTestThreadlet:

[legend]

Public Member Functions

virtual INT | Fn ()
virtual void | ReleaseInstance ()

Static Public Member Functions

static FfsTestThreadlet * | CreateInstance (FfsTestDispWin *dispWin)
static UINT32 | GetCurrentTest ()
static BOOLEAN | GetRunning ()
static void | SetRunning (BOOLEAN bRunning)

Member Function Documentation

FfsTestThreadlet * FfsTestThreadlet::CreateInstance ( FfsTestDispWin * dispWin ) [static]

Creates an FFS threadlet and releases itself automatically after the threadlet has been executed.

INT FfsTestThreadlet::Fn ( ) [virtual]

Fn is the function that will be executed in thread context. Be aware of restrictions to operations that can be performed in thread context.

Implements Threadlet.

static UINT32 FfsTestThreadlet::GetCurrentTest ( ) [inline, static]

static BOOLEAN FfsTestThreadlet::GetRunning ( ) [inline, static]

void FfsTestThreadlet::ReleaseInstance ( ) [virtual]

Is invoked, when the threadlet has the permission to destroy itself. Per default nothing is done. Overwriting this method is useful, if a derived class offers a static method CreateInstance, which internally allocates an instance on the heap, so that in ReleaseInstance this instance might be deleted. This releases the application, which created a worker-thread, to taking care about releasing the threadlet by listening to the message ThreadletNotificationMsg.

Reimplemented from Threadlet.

static void FfsTestThreadlet::SetRunning ( BOOLEAN bRunning ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/FfsTestThreadlet.hpp
  • Applications/SocketTest/FfsTestThreadlet.cpp
Generated on Wed Jan 25 01:15:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FfsTimeRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FfsTimeRecord Struct Reference
[Flash File System support]

FfsTimeRecord is updated after every modification of a file. More...

#include <Apoxi/Afs/Ffs/FfsTypes.hpp>

Data Fields

UINT8 | date
UINT8 | hour
UINT8 | min
UINT8 | month
UINT16 | year

Detailed Description

FfsTimeRecord is updated after every modification of a file.

Field Documentation

UINT8 FfsTimeRecord::date

UINT8 FfsTimeRecord::hour

UINT8 FfsTimeRecord::min

UINT8 FfsTimeRecord::month

UINT16 FfsTimeRecord::year

The documentation for this struct was generated from the following file:
  • Afs/Ffs/FfsTypes.hpp
Generated on Wed Jan 25 01:15:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FifoLinkedList< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FifoLinkedList< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/FifoLinkedList.hpp>

Inheritance diagram for FifoLinkedList< T >:

[legend]
Collaboration diagram for FifoLinkedList< T >:

[legend]

Public Member Functions

FifoLinkedList ()
void | Pop ()
void | Push (T *elem)
void | Remove (T *elem)

Detailed Description

template<class T>
class FifoLinkedList< T >

FifoLinkedList is a linked list with First In First Out behaviour.

Constructor & Destructor Documentation

template<class T>
FifoLinkedList< T >::FifoLinkedList ( ) [inline]

Member Function Documentation

template<class T>
void FifoLinkedList< T >::Pop ( ) [inline]

template<class T>
void FifoLinkedList< T >::Push ( T * elem ) [inline]

template<class T>
void FifoLinkedList< T >::Remove ( T * elem ) [inline]

The documentation for this class was generated from the following file:
  • Auxiliary/FifoLinkedList.hpp
Generated on Wed Jan 25 01:15:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: File Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

File Class Reference
[Root File System]

Client interface and base class for files. More...

#include <Apoxi/Afs/Rfs/File.hpp>

Inheritance diagram for File:

[legend]
Collaboration diagram for File:

[legend]

Public Types

enum | { c_copy_buf_size = 10 * 1024 }
enum Error {
NoError, OperationFailedError, AccessDeniedError, AlreadyOpenError,
OpeningError, OperationNotAllowedError, OperationCancelledError, NotOpenError,
NotFoundError, AlreadyExistsError, InitializingError, IllegalModeError,
RangeError, WriteError, BadFileError, SharingError,
DeviceError, FatalError, MemoryError, TooManyFilesError,
OutOfMemoryError, InvalidFileNameError, InternalError, TempFileCreationError,
IllegalIdError, IllegalTypeError, IllegalUserIdError, StreamingError,
StaticFileError, InconsistentMemTablesError, NoFactoryDefaultFileError, MemNotAvailableError,
BadFormatError, IOError, UnknownError, IllegalDirOperationError,
DirSpaceNotAvailableError, EndOfDirectoryError, NoMediaError, BadMediaError,
ChangedMediaError, MediaFailureError, EccError
}
Enumeration of error codes for working with files. More...
enum | OpenMode { ReadOnlyMode, ReadAndWriteMode }
Enumeration of open modes for opening files. More...
enum | SeekOrigin { SeekSet, SeekCur, SeekEnd }
typedef void(* | StreamingCallback )(File::Error result, UINT32 bytes_operated)

Public Member Functions

BOOLEAN | Accept (FileVisitor &visitor)
BOOLEAN | CancelOperation ()
virtual BOOLEAN | Close ()=0
virtual BOOLEAN | Copy (const Pathname &dest_pathname, const WString &dest_device_Id=L"rfs", UINT32 copy_buf_size=c_copy_buf_size)
BOOLEAN | Copy (const Path &dest_path, UINT32 copy_buf_size=c_copy_buf_size)
virtual BOOLEAN | Create (UINT32 size)=0
virtual BOOLEAN | CreateDir ()=0
virtual BOOLEAN | CreateStreaming ()=0
virtual BOOLEAN | Delete ()=0
BOOLEAN | Exists () const
virtual BOOLEAN | GetAccessDate (Date &date) const
virtual BOOLEAN | GetAttributes (Attributes &attributes) const
UINT8 | GetChunkSize () const
virtual BOOLEAN | GetCreationDate (Date &date) const =0
Error | GetLastError () const
Returns the error occurred by the last operation.
virtual BOOLEAN | GetModificationDate (Date &date) const =0
WString | GetName () const
WString | GetNativeDirectoryPathname () const
WString | GetNativeFilePathname () const
virtual BOOLEAN | GetNativeProperty (UINT prop_Id, void *val) const
const Path & | GetPath () const
Returns the path of the file.
const Pathname & | GetPathname () const
Returns the pathname of the file.
virtual BOOLEAN | GetSize (UINT32 &size) const =0
const StorageDevicePtr | GetStorageDevice () const
Returns the storage device associated to this file class.
virtual const WString & | GetStorageDeviceId () const =0
virtual BOOLEAN | IsArchive () const =0
BOOLEAN | IsDirectory () const
virtual BOOLEAN | IsHidden () const =0
virtual BOOLEAN | IsOpen () const =0
Tells if the file is open.
BOOLEAN | IsOpenInMode (OpenMode open_mode) const
Tells if the file is open in the specified open_mode.
virtual BOOLEAN | IsReadOnly () const =0
BOOLEAN | IsTemporary () const
Tells if this file is a temporary file.
void | MakePermanent ()
virtual BOOLEAN | Move (const Pathname &dest_pathname)
virtual BOOLEAN | Open (OpenMode open_mode)=0
virtual BOOLEAN | OpenStreaming (OpenMode open_mode)=0
virtual BOOLEAN | Rename (const WString &new_name)=0
virtual BOOLEAN | Resize (UINT32 new_size, UINT32 copy_buf_size=c_copy_buf_size)
virtual BOOLEAN | SetArchive (BOOLEAN archive)=0
void | SetChunkSize (UINT8 size, BOOLEAN send_progress_messages=FALSE)
virtual BOOLEAN | SetHidden (BOOLEAN hidden)=0
virtual BOOLEAN | SetNativeProperty (UINT prop_Id, const void *val)
virtual BOOLEAN | SetReadOnly (BOOLEAN read_only)=0
virtual BOOLEAN | Split (UINT32 offset, const Pathname &new_file, UINT32 copy_buf_size=c_copy_buf_size)
virtual | ~File ()
Random-File-Access
In contrast to the C-style file access methods which always take place at the internally controlled current file position, these methods take an additional offset parameter, which directly specifies the file position where the next Read() or Write() operation shall take place.

BOOLEAN | Read (void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)
BOOLEAN | Read (void HUGE *buffer, UINT32 offset, UINT32 count)
BOOLEAN | ReadStreaming (void HUGE *buffer, UINT32 count, UINT32 &bytes_read)
BOOLEAN | ReadStreamingAsync (void HUGE *buffer, UINT32 count, StreamingCallback)
BOOLEAN | Write (const void HUGE *buffer, UINT32 offset, UINT32 count)
BOOLEAN | WriteStreaming (const void HUGE *buffer, UINT32 count)
BOOLEAN | WriteStreamingAsync (const void HUGE *buffer, UINT32 count, StreamingCallback callback_func)
C-Style-File-Access
An APOXI file can be operated similar to how it is done in the C standard library (please refer to the C standard library functions fseek(), ftell(), fread(), and fwrite()). The methods in this group internally control the current file position, which specifies where in the file the next operation takes place. The current file position can be changed with method Seek() and retrieved with method Tell(). The methods to read and write at the current file position are named ReadCur() and WriteCur(). APOXI also supports random access file operations. The two different approaches of accessing a file are totally independent of each other, i.e. the random access methods do not affect the current file position at all.

BOOLEAN | ReadCur (void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
BOOLEAN | ReadCur (void HUGE *buffer, UINT32 count)
BOOLEAN | Seek (INT32 offset, SeekOrigin origin)
UINT32 | Tell ()
BOOLEAN | WriteCur (const void HUGE *buffer, UINT32 count)

Protected Member Functions

BOOLEAN | CopyContentsTo (const FilePtr &dest_file, UINT32 copy_buf_size)
virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)=0
virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 count)=0
virtual BOOLEAN | DoReadStreaming (void HUGE *buffer, UINT32 count, UINT32 &bytes_read)=0
virtual BOOLEAN | DoReadStreamingAsync (void HUGE *buffer, UINT32 count, StreamingCallback)=0
virtual BOOLEAN | DoWrite (const void HUGE *buffer, UINT32 offset, UINT32 count)=0
virtual BOOLEAN | DoWriteStreaming (const void HUGE *buffer, UINT32 count)=0
virtual BOOLEAN | DoWriteStreamingAsync (const void HUGE *buffer, UINT32 count, StreamingCallback)=0
File (const Pathname &pathname, const WString &device_Id)
virtual const FileState & | MyState () const =0
Returns the constant state of the constant file.
virtual FileState & | MyState ()=0
Returns the state of the file.
BOOLEAN | PrepareRename (const WString &new_name, String &new_native_name) const
void | SetTemporary ()
Sets the file to be deleted on destruction.

Friends

class | FileChunkOperator
class | RootFileImp
class | RootFileSystem

Data Structures

class | Attributes
struct | FileState
Structure holding the state of the file. More...

Detailed Description

Client interface and base class for files.

The abstract class File specifies the interface for files stored on a storage device and identified by a path. A File object is to be interpreted as a file handle.

Getting a file

Objects of class File cannot be created by operator new. In order to get a File object, method RootFileSystem::GetFile() has to be called. This method returns a smart-pointer of type FilePtr wrapping a newly created File object. The smart-pointer wrapper takes care for proper destruction of the file object.

Operations

This class defines many methods, we classify some of them into these two categories:

  • Contents operations like reading and writing. Prior to performing contents operations the respective file must be opened. After having finished contents operations the file should be closed. If the file is not explicitly closed, this is done in the destructor.
  • File operations like creating, deleting, renaming, and copying. To perform file operations the file must not be open. This is checked using assertions.

All contents and file operations return a BOOLEAN value:

  • TRUE indicates that the operation was performed successfully and
  • FALSE indicates that an error occurred during execution of the operation.

In case of failure of contents or file operations a call to method GetLastError() returns the error code. In case of success this error code is undefined and therefore GetLastError() should not be called.

Other methods allow for getting and/or setting properties (e.g. filename, pathname, path, modification date, creation date, directory flag) or state information (hidden flag, read-only flag, existence) of the file. These methods also return a BOOLEAN value indicating if the asked information could be retrieved. If it could not be retrieved it means that this kind of information is not supported on the file.

Important notes on writing a file

Improve write performance via initial size

A file always has an actual size. When creating a file with Create() you have to specify the initial size. By specifying a realistic value of how big the file will finally be you push performance of write operations a lot. This is because the file does not have to be enlarged when doing a write beyond the actual file size. Please note that if you do a write beyond the actual size then the file gets automatically resized. Of course the actual size then changes accordingly.

Undefined data in files

It is completely within the responsibility of the programmer to care for all the bytes in the file are written to meaningful values. This has to be done with the Write() method. If the programmer fails in writing all positions in the file, then the positions not written contain undefined data!

MIME type of a file

The MIME type of a file is defined by the extension of its pathname.

Sample on how to create a file

See the following sample function of how a file is usually created:

    static BOOLEAN CreateAudioMpegFile(UINT32 size)
    {
        Pathname pathname("/my_sound_file");

        // Add the file extension for the desired MIME type.
        pathname.AddFileExtension(c_mime_audio_mpeg);

        // Get the "file handle".
        FilePtr file = RootFileSystem::GetFile(pathname, L"ffs");
        if (!file.IsValid()) {
            // Handle out of memory error.
            return FALSE;
        }

        if (file->Exists()) {
            // We can't create an already existing file.
            return FALSE;
        }

        if (!file->Create(size)) {
            // Handle file create error.
            return FALSE;
        }

        // Write to the file...

        if (!file->Close()) {
            // Handle file close error.
            return FALSE;
        }

        return TRUE;
    }

Implementing a derived File class for a new storage device

For implementing a concrete file for a distinct storage device, abstract class File has to be subclassed. By design, a storage device is implemented as a subclass of class StorageDevice and requires its associated file class to be implemented as a subclass of class File. For example, in order to integrate the flash file system into the root file system, class FlashStorageDeviceImp is implemented as subclass of class StorageDevice and the associated files stored on the flash storage device are instances of class FlashFileImp, which is implemented as a subclass of class File.

See also:
RootFileSystem

StorageDevice

FlashStorageDeviceImp

FlashFileImp

Member Typedef Documentation

typedef void(* File::StreamingCallback)(File::Error result, UINT32 bytes_operated)

Callback method for streaming operations

Member Enumeration Documentation

anonymous enum

Enumerator:
c_copy_buf_size Default size of copy buffer to use for default implementations of Copy() and Resize().

enum File::Error

Enumeration of error codes for working with files.

Enumerator:
NoError
OperationFailedError
AccessDeniedError
AlreadyOpenError
OpeningError
OperationNotAllowedError
OperationCancelledError
NotOpenError
NotFoundError
AlreadyExistsError
InitializingError
IllegalModeError
RangeError
WriteError
BadFileError
SharingError
DeviceError
FatalError
MemoryError
TooManyFilesError
OutOfMemoryError
InvalidFileNameError
InternalError
TempFileCreationError
IllegalIdError
IllegalTypeError
IllegalUserIdError
StreamingError
StaticFileError
InconsistentMemTablesError
NoFactoryDefaultFileError
MemNotAvailableError
BadFormatError
IOError
UnknownError
IllegalDirOperationError
DirSpaceNotAvailableError
EndOfDirectoryError
NoMediaError
BadMediaError
ChangedMediaError
MediaFailureError
EccError

enum File::OpenMode

Enumeration of open modes for opening files.

Enumerator:
ReadOnlyMode
ReadAndWriteMode

enum File::SeekOrigin

Enumeration to specify the origin from where method Seek() should reposition the current file position.

Enumerator:
SeekSet | Beginning of file.
SeekCur | Current file position.
SeekEnd | End of file.

Constructor & Destructor Documentation

File::File | ( | const Pathname & | pathname,
 |  | const WString & | device_Id
 | ) | [protected]

Creates a file object for pathname located on storage device with storage device ID device_Id.

Parameters:
pathname | The pathname of the file.
device_Id | The storage device ID of the file.

File::~File ( ) [virtual]

The subclass has to close the file if it is still open and free any resources. If the file is a temporary file then this file has been created as a temporary file using RootFileSystem::CreateTempFile() and the associated physical file has to be deleted, too. See FlashFileImp::~FlashFileImp() for a sample implementation.

Member Function Documentation

BOOLEAN File::Accept ( FileVisitor & visitor )

If this file is a valid directory then the file visitor is accepted and TRUE is returned. Accepting the file visitor means that for each file in this directory method Visit() of visitor is called. The file visitor defines the filter for the directory iterator to use and tells if directories themselves should also be visited. If this file is not a valid directory then the visitor can't be accepted and FALSE is returned.

Parameters:
visitor The file visitor which operates on the files iterated over.
See also:
FileVisitor

BOOLEAN File::CancelOperation ( )

This method allows to cancel an operation which is currently running in chunk mode. It is only possible to cancel operations that run in chunk mode, operations not running in chunk mode block and hence can't be interrupted. If cancellation could be performed, then TRUE is returned. If no chunk mode operation is currently running, or the operation running is blocking, cancellation can not be performed and FALSE is returned. If cancellation succeeds, the operation running returns with FALSE and the error code OperationCancelled is set. Note that in case of a canceled write operation, the contents of the file operated on is then in an undefined state.

BOOLEAN File::Close ( ) [pure virtual]

Closes a previously opened file. An overriding method must call this base implementation at the end of its implementation if the file could be closed successfully to assure that the counter of open files gets set properly.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::Copy | ( | const Pathname & | dest_pathname,
 |  | const WString & | dest_device_Id = L"rfs",
 |  | UINT32 | copy_buf_size = c_copy_buf_size
 | ) | [virtual]

Copies the contents of this file to a file at pathname dest_pathname on the device specified by dest_device_Id. Pathname dest_pathname specifies an existing directory either with or without a filename. If a filename is not specified then the name of this source file is used as destination filename. If the destination file already exists the method fails. If dest_pathname specifies this file nothing is done and TRUE is returned. This file must exist, must not be a directory and must not be open, otherwise an assertion holds.

Parameters:
dest_pathname | The pathname where to copy this file to.
dest_device_Id | Specifies the storage device where to copy to default initialized to the root storage device.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented in RootFileImp.

BOOLEAN File::Copy | ( | const Path & | dest_path,
 |  | UINT32 | copy_buf_size = c_copy_buf_size
 | ) |

Copies the contents of this file to a file at path dest_path. Path dest_path specifies an existing directory either with or without a filename. If a filename is not specified then the name of this source file is used as destination filename. If the destination file already exists the method fails. If dest_path specifies this file nothing is done and TRUE is returned. This file must exist, must not be a directory and must not be open, otherwise an assertion holds.

Parameters:
dest_path | The path where to copy this file to.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::CopyContentsTo | ( | const FilePtr & | dest_file,
 |  | UINT32 | copy_buf_size
 | ) | [protected]

Copies the contents of this file to the destination file dest_file. The destination file must exist and if it is not open yet then it will be opened. As many bytes are copied as fit into the destination file. On success the files are closed explicitly.

Parameters:
dest_file | The destination file.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::Create ( UINT32 size ) [pure virtual]

Creates a physical file with path m_path and initial size specified in bytes. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents operations in mode ReadAndWriteMode and its internal file position is set to 0, independent of the size argument. The file grows itself if it is written beyond its actual size. Creating an empty file with size 0 is allowed. For shrinking or growing the file use method Resize(). An overriding method must call this base implementation at the end of its implementation if the file could be created successfully to assure that the counter of open files gets set properly. This is a file operation and of course the file must not be open on call.

Parameters:
size The initial size of the new file.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::CreateDir ( ) [pure virtual]

Creates a physical directory with path m_path. The last segment of m_path is taken as name of the new directory to create. The directory can only be created if all the directories specified in m_path already exist and the new directory doesn't exist yet. This is a file operation and of course the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::CreateStreaming ( ) [pure virtual]

Creates a physical file with path m_path. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents in streaming mode.

This means that only the methods:

  • WriteStreaming
  • WriteStreamingAsync
  • ReadStreaming
  • ReadStreamingAsync and not the methods Read() or Write() can be used with this file.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::Delete ( ) [pure virtual]

Deletes the file or directory. If the file is actually a directory, then it must be empty in order to be deleted. If the file or directory does not exist the method fails. The method succeeds if and only if the file or directory could successfully be deleted. This is a file operation, the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [protected, pure virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, pure virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 count)

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::DoReadStreaming | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 & | bytes_read
 | ) | [protected, pure virtual]

See also:
ReadStreaming(void HUGE *buffer, UINT32 count, UINT32 &bytes_read);

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::DoReadStreamingAsync | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [protected, pure virtual]

See also:
ReadStreamingAsync(void HUGE *buffer, UINT32 count, StreamingCallback);

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::DoWrite | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, pure virtual]

See also:
Write(const void HUGE *buffer, UINT32 offset, UINT32 count)

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::DoWriteStreaming | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [protected, pure virtual]

See also:
WriteStreaming(const void HUGE *buffer, UINT32 count);

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::DoWriteStreamingAsync | ( | const void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [protected, pure virtual]

See also:
WriteStreamingAsync(const void HUGE *buffer, UINT32 count, StreamingCallback);

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::Exists ( ) const

Tells if the file exists, i.e. it is checked whether a file with the pathname of this object exists. The root directory always exists. For other pathnames the associated storage device is asked whether a file with the pathname of this object exists.

virtual BOOLEAN File::GetAccessDate ( Date & date ) const [inline, virtual]

If the access date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open. Please override this method for storage devices which support retrieving the date of the last file access.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented in FatFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::GetAttributes ( Attributes & attributes ) const [inline, virtual]

Gets all the attributes of this file at once. If no attribute could be retrieved FALSE is returned. If at least one attribute could be retrieved TRUE is returned and argument attributes specifies for each attribute whether it could be retrieved or not. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

UINT8 File::GetChunkSize ( ) const [inline]

Returns the chunk size to use for file operations. Some storage device drivers are implemented in a way that they block other tasks. To avoid this, a file operation can be split into smaller chunks and operates on these sequentially. Each operation on a small chunk still blocks, however, between operating the chunks, other tasks are given the opportunity to handle their messages, thereby avoiding unwanted blocking of other tasks and improving user experience. The chunk size is specified in terms of 4 KB blocks (i.e. 4096 bytes). Hence, to get the effective chunk size used in KB, multiply the returned value with 4.

Returns:
Chunk size in terms of 4 KB blocks (i.e. 4096 bytes).

virtual BOOLEAN File::GetCreationDate ( Date & date ) const [pure virtual]

If the creation date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

File::Error File::GetLastError ( ) const

Returns the error occurred by the last operation.

virtual BOOLEAN File::GetModificationDate ( Date & date ) const [pure virtual]

If the modification date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

WString File::GetName ( ) const

Returns the name of the file without directory information.

WString File::GetNativeDirectoryPathname ( ) const

Returns the pathname in native directory name format. The native directory name format may differ from storage device to storage device.

WString File::GetNativeFilePathname ( ) const

Returns the pathname in native file name format. The native file name format may differ from storage device to storage device.

virtual BOOLEAN File::GetNativeProperty | ( | UINT | prop_Id,
 |  | void * | val
 | ) | const [inline, virtual]

Retrieves the native property identified by prop_Id via argument val. If the property is not supported by the native file (and therefore can't be retrieved) the method fails. The properties that the native file supports are defined by the derived class that implements the native file support. E.g., for knowing which properties a flash file supports look at the documentation of class FlashFileImp, there the respective property IDs are defined. It is crucial that the given property ID prop_Id and the receiving value val really match!

Parameters:
prop_Id | ID of the native file property to retrieve, defined in the derived class that implements the native file support.
val | Valid pointer to the value object that shall be set to the current value of the file property with id prop_Id.
Returns:
Tells if the file property could be retrieved.

Reimplemented in FatFileImp, FlashFileImp, and RootFileImp.

const Path & File::GetPath ( ) const

Returns the path of the file.

const Pathname & File::GetPathname ( ) const

Returns the pathname of the file.

virtual BOOLEAN File::GetSize ( UINT32 & size ) const [pure virtual]

If the file size can be retrieved then size is set to the actual file size in bytes and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

const StorageDevicePtr File::GetStorageDevice ( ) const

Returns the storage device associated to this file class.

virtual const WString& File::GetStorageDeviceId ( ) const [pure virtual]

Returns the storage device ID of the device associated to this file class.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::IsArchive ( ) const [pure virtual]

Tells if the file is archive. This is a file operation, the file must not be open on call.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::IsDirectory ( ) const

Tells if the file is a directory, i.e. it is checked whether the file with the pathname of this object is a directory. The root pathname is a directory. For other pathnames the associated storage device is asked whether the file with the pathname of this object is a directory.

virtual BOOLEAN File::IsHidden ( ) const [pure virtual]

Tells if the file is hidden. This is a file operation, the file must not be open on call.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::IsOpen ( ) const [pure virtual]

Tells if the file is open.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::IsOpenInMode ( OpenMode open_mode ) const

Tells if the file is open in the specified open_mode.

virtual BOOLEAN File::IsReadOnly ( ) const [pure virtual]

Tells if the file is read only. This is a file operation, the file must not be open on call.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::IsTemporary ( ) const [inline]

Tells if this file is a temporary file.

void File::MakePermanent ( )

If this file has been created as a temporary file the file is turned into a permanent one, otherwise nothing is done.

BOOLEAN File::Move ( const Pathname & dest_pathname ) [virtual]

Moves the file to pathname dest_pathname on the current storage device. The dest_pathname has to contain the target filename. Only specifying a directory where the file should be moved to is not allowed.

Parameters:
dest_path The path where to move this file to.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

virtual const FileState& File::MyState ( ) const [protected, pure virtual]

Returns the constant state of the constant file.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual FileState& File::MyState ( ) [protected, pure virtual]

Returns the state of the file.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::Open ( OpenMode open_mode ) [pure virtual]

Opens the file for reading and/or writing depending on open_mode. There are two open modes:

  • ReadOnlyMode and
  • ReadAndWriteMode.

Opening a file is only possible if the file exists and is currently closed, otherwise opening fails. If opened in ReadOnlyMode only reading the file is allowed, writing the file causes an assertion to fail. If opened in ReadAndWriteMode both reading and writing the file are allowed. Please close the file after contents operations by calling Close(). However, if the file is not closed explicitly then it will be closed automatically on destruction. Opening a directory is not allowed and will result in an assertion. An overriding method must call this base implementation at the end of its implementation if the file could be opened successfully to assure that the open mode, the internal file position, and the counter of open files get set properly.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::OpenStreaming ( OpenMode open_mode ) [pure virtual]

In difference to Open(), the file is opened in streaming mode. This means that only the methods:

  • WriteStreaming
  • WriteStreamingAsync
  • ReadStreaming
  • ReadStreamingAsync and not the methods Read() or Write() can be used.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::PrepareRename | ( | const WString & | new_name,
 |  | String & | new_native_name
 | ) | const [protected]

Checks if new_name is a filename without any folders specified and if new_name is different from the current name. If so, TRUE is returned and new_native_name is set to the new pathname in native format, else FALSE is returned and the appropriate error code is set.

BOOLEAN File::Read | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) |

Reads up to max_count bytes from this file starting at offset and copies them to the provided buffer. This is a contents operation. The file must be opened before. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of file while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the file, i.e. parameter offset is greater than or equal to the size of the file, this method sets bytes_read to 0 and returns TRUE, signaling end of file! Please see the following sample function for completely reading a file:

            static BOOLEAN ReadFile(const FilePtr &open_file)
            {
                ASSERT_DEBUG(open_file->IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 offset = 0;
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole file in a loop.
                while ((ok = open_file->Read(buf, offset, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...

                    // Increase offset where to read next.
                    offset += bytes_read;
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

If the read operation fails, use GetLastError() to investigate the error.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
offset | The zero-based position where to start reading the file.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::Read | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) |

Reads exactly count bytes from this file starting at offset and copies them to the provided buffer. This is a contents operation. The file must be opened before. If the method could not succeed use method GetLastError() to investigate the problem.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
offset | The zero-based position where to start reading the file.
count | The number of bytes to read.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::ReadCur | ( | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) |

Reads up to max_count bytes from this file starting at the current file position and copies them to the provided buffer. This is a contents operation. The file must be opened before. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of file while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the file, i.e. the current file position is greater than or equal to the size of the file, this method sets bytes_read to 0 and returns TRUE, signaling end of file! Please see the following sample function for completely reading a file:

            static BOOLEAN ReadCurFile(const FilePtr &open_file)
            {
                ASSERT_DEBUG(open_file->IsOpen() && open_file->Tell() == 0);

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole file in a loop.
                while ((ok = open_file->ReadCur(buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

If the read operation fails, use GetLastError() to investigate the error.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::ReadCur | ( | void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

Reads exactly count bytes from this file starting at the current file position and copies them to the provided buffer. This is a contents operation. The file must be opened before. If the method could not succeed use method GetLastError() to investigate the problem.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::ReadStreaming | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 & | bytes_read
 | ) |

Behaves exactly as the method Read() with the same parameter list. The differences to the Read method are:

  • this method only works on files, which are opened in streaming mode.
  • the read operation is fulfilled with an higher priority and therefore may return faster.

BOOLEAN File::ReadStreamingAsync | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) |

ReadStreamingAsync is the asynchronous pendant of ReadStreaming() The method returns immediately after his call and signalises later by calling the callback function /a StreamingCallback, that the read operation ended. An possible error code and the number of bytes read are returned as parameters of the callback function /a StreamingCallback.

BOOLEAN File::Rename ( const WString & new_name ) [pure virtual]

Renames the file or directory to new_name. If the file or directory does not exist the method fails. Argument new_name is the file name including the file extension (if any) but without any leading directories. The MIME type of the renamed file is defined by the extension of the new name, if none exists it has general type. If the new name is equal to the old name the method fails. The method succeeds if and only if the file or directory really was renamed. Subclasses have to first check if the new file name is different to the actual one, then physically rename the file, and finally call this base method for changing the name which is controlled within this base class. This base method never fails. For a sample implementation see FlashFileImp::Rename(). This is a file operation, the file must not be open on call.

Parameters:
new_name New name of the file including the file extension (if any). No directory segments are allowed.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::Resize | ( | UINT32 | new_size,
 |  | UINT32 | copy_buf_size = c_copy_buf_size
 | ) | [virtual]

Resizes the file to contain new_size bytes. If the new size is less than the original size then the file is truncated. If the new size is bigger than the original size then the newly created part of the file is not initialized and has to be written to be in defined state. Emptying a file by resizing it to size 0 is allowed. This default implementation uses a temporary file for resizing. Override this method if resizing is explicitly supported by the derived file class. This is a file operation, the file must not be open on call.

Parameters:
new_size | The new size of the file.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

BOOLEAN File::Seek | ( | INT32 | offset,
 |  | SeekOrigin | origin
 | ) |

Repositions the current file position to the position that is offset bytes from origin. The next ReadCur() or WriteCur() operation takes place at the new position.

Parameters:
offset | Number of bytes from origin.
origin | Initial position.

virtual BOOLEAN File::SetArchive ( BOOLEAN archive ) [pure virtual]

Sets the archive flag.

Parameters:
archive If TRUE then the file is an archive.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

void File::SetChunkSize | ( | UINT8 | size,
 |  | BOOLEAN | send_progress_messages = FALSE
 | ) |

Sets chunk size to use for operation in chunk mode. This value is specified in terms of 4 KB blocks (i.e. 4096 bytes). Hence, to get the effective chunk size used in KB, multiply value size with 4. To disable chunk mode operation, provide 0 as chunk size. To use the recommended chunk size, specify the value which is defined as the default chunk size by the associated storage device. Argument send_progress_messages defines whether progress messages shall be sent or not. Progress messages can be used to implement a progress bar indicating the progress of the chunk mode operation.

See also:
StorageDevice::GetDefaultChunkSize()

virtual BOOLEAN File::SetHidden ( BOOLEAN hidden ) [pure virtual]

Sets the hidden flag.

Parameters:
hidden If TRUE then the file is hidden.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

virtual BOOLEAN File::SetNativeProperty | ( | UINT | prop_Id,
 |  | const void * | val
 | ) | [inline, virtual]

Sets the native property identified by prop_Id to value val. If the property is not supported by the native file (and therefore can't be set) the method fails. The properties that the native file supports are defined by the derived class that implements the native file support. E.g., for knowing which properties a flash file supports look at the documentation of class FlashFileImp, there the respective property IDs are defined. It is crucial that the given property ID prop_Id and the passed value val really match!

Parameters:
prop_Id | ID of the native file property to set, defined in the derived class that implements the native file support.
val | Valid pointer to the value that shall be set for file property with id prop_Id.
Returns:
Tells if the file property could be set.

Reimplemented in FlashFileImp, and RootFileImp.

virtual BOOLEAN File::SetReadOnly ( BOOLEAN read_only ) [pure virtual]

Sets the read only flag.

Parameters:
read_only If TRUE then the file is set to read only mode.

Implemented in FatFileImp, FlashFileImp, RamFileImp, and RootFileImp.

void File::SetTemporary ( ) [protected]

Sets the file to be deleted on destruction.

BOOLEAN File::Split | ( | UINT32 | offset,
 |  | const Pathname & | new_file,
 |  | UINT32 | copy_buf_size = c_copy_buf_size
 | ) | [virtual]

Splits the contents of this file at offset. The first half of the file remains in this file, the second half of the file will be stored in new_file. Pathname new_file specifies an existing directory with a new filename, i.e. the directory must exist but the file must not exist, otherwise the method fails. If new_file specifies this file nothing is done and FALSE is returned. The specified offset must be greater than 0 and lower than the current size of the file minus 1, otherwise an assertion holds. This file must exist, must not be a directory and must not be open, otherwise an assertion holds.

Parameters:
offset | Number of bytes from origin where to split the file.
new_file | The pathname of the file which will store the second half of the file.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented in RootFileImp.

UINT32 File::Tell ( )

Returns the current file position where the next ReadCur() or WriteCur() operation takes place.

BOOLEAN File::Write | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) |

Writes the specified count bytes to the file starting at position offset. The bytes are read from buffer. The filesize is increased if required. This is a contents operation. The file must be opened before. On error please call GetLastError() to get an error code.

Parameters:
buffer | The pointer to the buffer containing the bytes to write to the file. It must be a valid pointer and the buffer must be at least count bytes in size.
offset | Defines the position within the file where to start writing the specified bytes.
count | The number of bytes that should be written from the buffer to the file.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::WriteCur | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

Writes the specified count bytes to the file starting at the current file position. The bytes are read from buffer. The filesize is increased if required. This is a contents operation. The file must be opened before. On error please call GetLastError() to get an error code.

Parameters:
buffer | The pointer to the buffer containing the bytes to write to the file. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes that should be written from the buffer to the file.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN File::WriteStreaming | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

Behaves exactly as the method Write() with the same parameter list. The differences to the Write method are:

  • this method only works on files, which are opened in streaming mode.
  • the write operation is fulfilled with an higher priority and therefore may return faster.

BOOLEAN File::WriteStreamingAsync | ( | const void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback | callback_func
 | ) |

WriteStreamingAsync is the asynchronous pendant of WriteStreaming() The method returns immediately after his call and signalises later by calling the callback function /a StreamingCallback, that the write operation ended. An possible error code is returned as parameter of the callback function /a StreamingCallback.

Friends And Related Function Documentation

friend class FileChunkOperator [friend]

friend class RootFileImp [friend]

friend class RootFileSystem [friend]

The documentation for this class was generated from the following files:
  • Afs/Rfs/File.hpp
  • Afs/Rfs/File.cpp
Generated on Wed Jan 25 01:15:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: File::Attributes Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
File::Attributes

File::Attributes Class Reference

#include <Apoxi/Afs/Rfs/File.hpp>

Collaboration diagram for File::Attributes:

[legend]

Public Types

enum Type {
Directory = 0, ReadOnly, Hidden, Size,
CreationDate, CreationTime, ModificationDate, ModificationTime,
AccessDate, AccessTime, Archive
}

Public Member Functions

Date | GetAccessDate () const
Time | GetAccessTime () const
Date | GetCreationDate () const
Time | GetCreationTime () const
Date | GetModificationDate () const
Time | GetModificationTime () const
UINT32 | GetSize () const
BOOLEAN | IsArchive () const
BOOLEAN | IsDefined (Type attribute) const
BOOLEAN | IsDirectory () const
BOOLEAN | IsHidden () const
BOOLEAN | IsReadOnly () const
void | SetAccessDate (const Date &date)
void | SetAccessTime (const Time &time)
void | SetArchive (BOOLEAN status=TRUE)
void | SetCreationDate (const Date &date)
void | SetCreationTime (const Time &time)
void | SetDirectory (BOOLEAN status=TRUE)
void | SetHidden (BOOLEAN status=TRUE)
void | SetModificationDate (const Date &date)
void | SetModificationTime (const Time &time)
void | SetReadOnly (BOOLEAN status=TRUE)
void | SetSize (UINT32 size)

Detailed Description

Class Attributes is a container to convey the attributes of a file. Files of different storage devices support different attributes. Hence, this class provides method IsDefined() to check whether a distinct attribute is defined. If so, the attribute can be retrieved using the respective getter or interrogation method.

Member Enumeration Documentation

enum File::Attributes::Type

This enumeration defines the attributes that a file might support.

Enumerator:
Directory
ReadOnly
Hidden
Size
CreationDate
CreationTime
ModificationDate
ModificationTime
AccessDate
AccessTime
Archive

Member Function Documentation

Date File::Attributes::GetAccessDate ( ) const [inline]

Returns the value of the AccessDate attribute. The attribute must be defined, otherwise an assertion holds.

Time File::Attributes::GetAccessTime ( ) const [inline]

Returns the value of the AccessTime attribute. The attribute must be defined, otherwise an assertion holds.

Date File::Attributes::GetCreationDate ( ) const [inline]

Returns the value of the CreationDate attribute. The attribute must be defined, otherwise an assertion holds.

Time File::Attributes::GetCreationTime ( ) const [inline]

Returns the value of the CreationTime attribute. The attribute must be defined, otherwise an assertion holds.

Date File::Attributes::GetModificationDate ( ) const [inline]

Returns the value of the ModificationDate attribute. The attribute must be defined, otherwise an assertion holds.

Time File::Attributes::GetModificationTime ( ) const [inline]

Returns the value of the ModificationTime attribute. The attribute must be defined, otherwise an assertion holds.

UINT32 File::Attributes::GetSize ( ) const [inline]

Returns the value of the Size attribute. The attribute must be defined, otherwise an assertion holds.

BOOLEAN File::Attributes::IsArchive ( ) const [inline]

Returns the value of the Archive attribute. The attribute must be defined, otherwise an assertion holds.

BOOLEAN File::Attributes::IsDefined ( Type attribute ) const [inline]

Tells whether attribute is defined. The attribute is defined when its value has been set using the respective setter method. If the attribute is defined, its value can be retrieved using the respective getter or interrogation method.

BOOLEAN File::Attributes::IsDirectory ( ) const [inline]

Returns the value of the Directory attribute. The attribute must be defined, otherwise an assertion holds.

BOOLEAN File::Attributes::IsHidden ( ) const [inline]

Returns the value of the Hidden attribute. The attribute must be defined, otherwise an assertion holds.

BOOLEAN File::Attributes::IsReadOnly ( ) const [inline]

Returns the value of the ReadOnly attribute. The attribute must be defined, otherwise an assertion holds.

void File::Attributes::SetAccessDate ( const Date & date ) [inline]

Sets the value of the AccessDate attribute.

void File::Attributes::SetAccessTime ( const Time & time ) [inline]

Sets the value of the AccessTime attribute.

void File::Attributes::SetArchive ( BOOLEAN status = TRUE ) [inline]

Sets the value of the Archive attribute.

void File::Attributes::SetCreationDate ( const Date & date ) [inline]

Sets the value of the CreationDate attribute.

void File::Attributes::SetCreationTime ( const Time & time ) [inline]

Sets the value of the CreationTime attribute.

void File::Attributes::SetDirectory ( BOOLEAN status = TRUE ) [inline]

Sets the value of the Directory attribute.

void File::Attributes::SetHidden ( BOOLEAN status = TRUE ) [inline]

Sets the value of the Hidden attribute.

void File::Attributes::SetModificationDate ( const Date & date ) [inline]

Sets the value of the ModificationDate attribute.

void File::Attributes::SetModificationTime ( const Time & time ) [inline]

Sets the value of the ModificationTime attribute.

void File::Attributes::SetReadOnly ( BOOLEAN status = TRUE ) [inline]

Sets the value of the ReadOnly attribute.

void File::Attributes::SetSize ( UINT32 size ) [inline]

Sets the value of the Size attribute.

The documentation for this class was generated from the following file:
  • Afs/Rfs/File.hpp
Generated on Wed Jan 25 01:15:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: File::FileState Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
File::FileState

File::FileState Struct Reference

Structure holding the state of the file. More...

#include <Apoxi/Afs/Rfs/File.hpp>

Collaboration diagram for File::FileState:

[legend]

Public Member Functions

FileState ()

Data Fields

FileChunkOperator * m_chunk_operator
UINT8 | m_chunk_size
UINT32 | m_cur_file_pos
Error m_last_error
Error code of last operation.
OpenMode m_open_mode
The mode the file is opened with.
BOOLEAN | m_send_progress_messages
BOOLEAN | m_temporary
The temporary flag.

Detailed Description

Structure holding the state of the file.

Constructor & Destructor Documentation

File::FileState::FileState ( ) [inline]

Field Documentation

FileChunkOperator* File::FileState::m_chunk_operator

The chunk operator currently used. If no chunk operation is in progress currently then this pointer is 0.

UINT8 File::FileState::m_chunk_size

The chunk size to use for operation in chunk mode. This value is specified in terms of 4 KB blocks (i.e. 4096 bytes). Hence, to get the effective chunk size in KB, multiply this value with 4.

UINT32 File::FileState::m_cur_file_pos

The current file position at which the next ReadCur() or WriteCur() operation takes place.

Error File::FileState::m_last_error [mutable]

Error code of last operation.

OpenMode File::FileState::m_open_mode

The mode the file is opened with.

BOOLEAN File::FileState::m_send_progress_messages

This flag indicates whether chunk mode operations shall send progress messages.

BOOLEAN File::FileState::m_temporary

The temporary flag.

The documentation for this struct was generated from the following file:
  • Afs/Rfs/File.hpp
Generated on Wed Jan 25 01:15:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileBinData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileBinData Class Reference
[Root File System]

#include <Apoxi/Afs/Rfs/FileBinData.hpp>

Inheritance diagram for FileBinData:

[legend]
Collaboration diagram for FileBinData:

[legend]

Public Member Functions

virtual BinData * | Clone () const
virtual UINT32 | GetLength () const
Returns the number of bytes which are hold by this object.
virtual MemMap * | ObtainMemMap (UINT32 idx, UINT32 size) const
virtual UINT32 | Read (UINT32 idx, void *buf, UINT32 nbytes) const
virtual BOOLEAN | Read (UINT32 idx, UINT8 &val) const
virtual void | ReleaseMemMap (MemMap **h_map) const

Static Public Member Functions

static FileBinData * | CreateInstance (const FilePtr &file)
static FileBinData * | CreateInstance (const Path &file_path)

Protected Member Functions

FileBinData ()
virtual | ~FileBinData ()

Protected Attributes

FilePtr m_file
The file that is read.

Detailed Description

Class FileBinData implements the BinData interface for files of the APOXI Root File System (RFS).

Constructor & Destructor Documentation

FileBinData::FileBinData ( ) [protected]

FileBinData::~FileBinData ( ) [protected, virtual]

Member Function Documentation

BinData * FileBinData::Clone ( ) const [virtual]

Clones the BinData object. Cloning is useful if a BinData object is already obtained by one object, but another object wants to access the same data too. The cloned BinData object must be released by BinData::ReleaseInstance if it is not needed anymore. 0 is returned if the cloning has failed.

Reimplemented from BinData.

FileBinData * FileBinData::CreateInstance ( const FilePtr & file ) [static]

Creates and returns a ready to use object of this class. The binary data is read from file. If file is not yet open it will be opened in read only mode. On destruction of the object the file will be closed. If file does not exist or specifies a directory 0 is returned. Another reason for failure and returning 0 is an out of memory condition.

Parameters:
file The source file.
Returns:
A ready to use object or 0 on failure.

FileBinData * FileBinData::CreateInstance ( const Path & file_path ) [static]

Creates and returns a ready to use object of this class. The binary data is read from file at file_path. If the file is not yet open it will be opened in read only mode. On destruction of the object the file will be closed. If the file does not exist or specifies a directory 0 is returned. Another reason for failure and returning 0 is an out of memory condition.

Parameters:
file_path The path of the source file.
Returns:
A ready to use object or 0 on failure.

UINT32 FileBinData::GetLength ( ) const [virtual]

Returns the number of bytes which are hold by this object.

Implements BinData.

MemMap * FileBinData::ObtainMemMap | ( | UINT32 | idx,
 |  | UINT32 | size
 | ) | const [virtual]

Obtains a memory map from the given index idx with the specified size size. A size of -1 returns a MemMap to the end of data. 0 is returned if obtaining a memory map is not supported on the bin data object.

Reimplemented from BinData.

UINT32 FileBinData::Read | ( | UINT32 | idx,
 |  | void * | buf,
 |  | UINT32 | nbytes
 | ) | const [virtual]

Reads byte_count bytes starting from the offset idx into buffer buf. Returns the number of read bytes.

Implements BinData.

BOOLEAN FileBinData::Read | ( | UINT32 | idx,
 |  | UINT8 & | val
 | ) | const [virtual]

Returns a single byte in val at the given index idx. val is not changed if idx does not exist.

Returns:
TRUE if a value at the index exists, FALSE otherwise.

Implements BinData.

void FileBinData::ReleaseMemMap ( MemMap ** h_map ) const [virtual]

Releases a MemMap which has been obtained by BinData::ObtainMemMap.

Reimplemented from BinData.

Field Documentation

FilePtr FileBinData::m_file [protected]

The file that is read.

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileBinData.hpp
  • Afs/Rfs/FileBinData.cpp
Generated on Wed Jan 25 01:15:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileChunkOperationProgressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileChunkOperationProgressMsg Class Reference

#include <Apoxi/Afs/Rfs/RfsMsgTypes.hpp>

Inheritance diagram for FileChunkOperationProgressMsg:

[legend]
Collaboration diagram for FileChunkOperationProgressMsg:

[legend]

Public Types

enum | { ID = 16050 }

Public Member Functions

virtual Message * | Clone () const
FileChunkOperationProgressMsg (ExecutionContext *context, const File &file, UINT progress)
const File & | GetFile () const
virtual const MsgMetaData & | GetMetaData () const
UINT | GetProgress () const
virtual | ~FileChunkOperationProgressMsg ()

Detailed Description

On demand this message is periodically posted while a file chunk mode operation is executed in order to report its progress in percent.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FileChunkOperationProgressMsg::FileChunkOperationProgressMsg | ( | ExecutionContext * | context,
 |  | const File & | file,
 |  | UINT | progress
 | ) |

FileChunkOperationProgressMsg::~FileChunkOperationProgressMsg ( ) [virtual]

Member Function Documentation

Message * FileChunkOperationProgressMsg::Clone ( ) const [virtual]

Implements Message.

const File& FileChunkOperationProgressMsg::GetFile ( ) const [inline]

const MsgMetaData & FileChunkOperationProgressMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

UINT FileChunkOperationProgressMsg::GetProgress ( ) const [inline]

The documentation for this class was generated from the following files:
  • Afs/Rfs/RfsMsgTypes.hpp
  • Afs/Rfs/RfsMsgTypes.cpp
Generated on Wed Jan 25 01:15:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileChunkOperator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileChunkOperator Class Reference
[Root File System]

#include <Apoxi/Afs/Rfs/FileChunkOperator.hpp>

Collaboration diagram for FileChunkOperator:

[legend]

Public Types

enum | Operation { ReadOffsetExact, ReadOffsetMax, WriteOffsetExact }

Public Member Functions

BOOLEAN | Cancel ()
FileChunkOperator (File &file, UINT32 chunk_size, BOOLEAN send_progress_messages)
BOOLEAN | Read (void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)
BOOLEAN | Read (void HUGE *buffer, UINT32 offset, UINT32 count)
BOOLEAN | Write (const void HUGE *buffer, UINT32 offset, UINT32 count)

Member Enumeration Documentation

enum FileChunkOperator::Operation

Enumerator:
ReadOffsetExact
ReadOffsetMax
WriteOffsetExact

Constructor & Destructor Documentation

FileChunkOperator::FileChunkOperator | ( | File & | file,
 |  | UINT32 | chunk_size,
 |  | BOOLEAN | send_progress_messages
 | ) |

Member Function Documentation

BOOLEAN FileChunkOperator::Cancel ( )

BOOLEAN FileChunkOperator::Read | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) |

BOOLEAN FileChunkOperator::Read | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) |

BOOLEAN FileChunkOperator::Write | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) |

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileChunkOperator.hpp
  • Afs/Rfs/FileChunkOperator.cpp
Generated on Wed Jan 25 01:15:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileDataSink Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileDataSink Class Reference
[Root File System]

#include <Apoxi/Afs/Rfs/FileDataSink.hpp>

Inheritance diagram for FileDataSink:

[legend]
Collaboration diagram for FileDataSink:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
FileDataSink (const FilePtr &file, UINT32 initial_size=0, BOOLEAN overwrite_existing_file=FALSE, DrmLocalId id=c_drm_invalid_local_id)
FileDataSink (const Path &file_path, UINT32 initial_size=0, BOOLEAN overwrite_existing_file=FALSE, DrmLocalId id=c_drm_invalid_local_id)
virtual BOOLEAN | GetSize (UINT32 &size) const
virtual BOOLEAN | IsOpen () const
virtual BOOLEAN | Open ()
virtual UINT32 | Write (UINT32 offset, const void HUGE *buf, UINT32 nbytes)
virtual UINT32 | Write (const void HUGE *buf, UINT32 nbytes)
virtual | ~FileDataSink ()

Protected Attributes

FilePtr m_file
const UINT32 | m_initial_size
const BOOLEAN | m_overwrite_existing_file

Detailed Description

Class FileDataSink implements a data sink which writes to a file of the APOXI Root File System (RFS).

Constructor & Destructor Documentation

FileDataSink::FileDataSink | ( | const Path & | file_path,
 |  | UINT32 | initial_size = 0,
 |  | BOOLEAN | overwrite_existing_file = FALSE,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) |

Creates a file data sink instance. This data sink writes to the file at file_path. The file data sink has to be opened using method Open() before writing to it. On destruction, the file data sink will be closed if not explicitly done before.

Parameters:
file_path | The path of the file to write to.
initial_size | Defines the initial size of the file data sink.
overwrite_existing_file | Tells if an already existing file at file_path may be overwritten when opening the file data sink.
id | The DRM local ID.

FileDataSink::FileDataSink | ( | const FilePtr & | file,
 |  | UINT32 | initial_size = 0,
 |  | BOOLEAN | overwrite_existing_file = FALSE,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) |

Creates a file data sink instance. This data sink writes to the specified file. The file data sink has to be opened using method Open() before writing to it. On destruction, the file data sink will be closed if not explicitly done before.

Parameters:
file | The file to write to.
initial_size | Defines the initial size of the file data sink.
overwrite_existing_file | Tells if an already existing file may be overwritten when opening the file data sink.
id | The DRM local ID.

FileDataSink::~FileDataSink ( ) [virtual]

Destroys the file data sink. The associated file is also closed if not done yet.

Member Function Documentation

BOOLEAN FileDataSink::Close ( ) [virtual]

Closes the data sink. After closing the data sink it can not be written any more.

Returns:
Success of operation.

Implements DataSink.

BOOLEAN FileDataSink::GetSize ( UINT32 & size ) const [virtual]

Returns the size of the data sink in terms of bytes. The size of the data sink is actually defined by the amount of data written at the end of the data sink.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implements DataSink.

BOOLEAN FileDataSink::IsOpen ( ) const [virtual]

Returns whether the data sink is currently open or closed.

Returns:
Whether the data sink is open or not.

Implements DataSink.

BOOLEAN FileDataSink::Open ( ) [virtual]

Opens the file data sink. Opening succeeds if either the associated file does not exist yet and can be newly created, or if it exists and it is allowed to overwrite it. The constructor is provided with argument overwrite_existing_file which specifies whether an existing file may be overwritten or not when opening the file data sink. Note that if the associated file already exists it has to be in closed state, otherwise this method asserts.

Implements DataSink.

UINT32 FileDataSink::Write | ( | UINT32 | offset,
 |  | const void HUGE * | buf,
 |  | UINT32 | nbytes
 | ) | [virtual]

Writes nbytes bytes of buffer buf to the data sink at the given offset. Note, that this method is only allowed to be used to overwrite existing data. Hence, if the given offset plus the number of bytes to write nbytes is larger than the current size of the data sink then an assertion fails. Overriding methods must implement this assertion. Since this method only overrides existing data it does not affect the size of the data sink.

Parameters:
offset | The offset where to start writing.
buf | The buffer to be written.
nbytes | The number of bytes to be written.
Returns:
Number of bytes actually written.

Implements DataSink.

UINT32 FileDataSink::Write | ( | const void HUGE * | buf,
 |  | UINT32 | nbytes
 | ) | [virtual]

Writes nbytes bytes of buffer buf to the data sink. The data is written at the end of the data sink and hence increases the size of the data sink by the amount of bytes written.

Parameters:
buf | The buffer to be written.
nbytes | The number of bytes to be written.
Returns:
Number of bytes actually written.

Implements DataSink.

Field Documentation

FilePtr FileDataSink::m_file [protected]

const UINT32 FileDataSink::m_initial_size [protected]

const BOOLEAN FileDataSink::m_overwrite_existing_file [protected]

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileDataSink.hpp
  • Afs/Rfs/FileDataSink.cpp
Generated on Wed Jan 25 01:15:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileDataSource Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileDataSource Class Reference
[Root File System]

#include <Apoxi/Afs/Rfs/FileDataSource.hpp>

Inheritance diagram for FileDataSource:

[legend]
Collaboration diagram for FileDataSource:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
FileDataSource (const FilePtr &file, DrmLocalId id=c_drm_invalid_local_id)
FileDataSource (const Path &file_path, DrmLocalId id=c_drm_invalid_local_id)
virtual BOOLEAN | GetSize (UINT32 &size) const
virtual BOOLEAN | IsOpen () const
virtual BOOLEAN | Open ()
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 count)
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 count)
virtual | ~FileDataSource ()

Protected Attributes

FilePtr m_file

Detailed Description

Class FileDataSource implements a data source which reads from an associated File instance.

Constructor & Destructor Documentation

FileDataSource::FileDataSource | ( | const Path & | file_path,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) |

Creates a file data source instance. This data source reads from the file at file_path. The file data source has to be opened using method Open() before reading from it. On destruction, the file data source will be closed if not explicitly done before. Note that the file which shall be read from must be in closed state if it exists, otherwise an assertion holds.

Parameters:
file_path | The path of the file to read from.
id | The DRM local ID.

FileDataSource::FileDataSource | ( | const FilePtr & | file,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) |

Creates a file data source instance. This data source reads from the specified file. The file data source has to be opened using method Open() before reading from it. On destruction, the file data source will be closed if not explicitly done before. Note that the file which shall be read from must be in closed state if it exists, otherwise an assertion holds.

Parameters:
file | The file to read from.
id | The DRM local ID.

FileDataSource::~FileDataSource ( ) [virtual]

Destroys the file data source. The associated file is also closed if not done yet.

Member Function Documentation

BOOLEAN FileDataSource::Close ( ) [virtual]

Closes the data source. After closing the data source it can not be read any more.

Returns:
Success of operation.

Implements DataSource.

BOOLEAN FileDataSource::GetSize ( UINT32 & size ) const [virtual]

Returns the size of the data source in terms of bytes.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN FileDataSource::IsOpen ( ) const [virtual]

Returns whether the data source is currently open or closed.

Returns:
Whether the data source is open or not.

Implements DataSource.

BOOLEAN FileDataSource::Open ( ) [virtual]

Opens the file data source. Opening succeeds if the associated file exists, is currently closed, and can be opened in read only mode.

Implements DataSource.

BOOLEAN FileDataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [virtual]

Reads up to max_count bytes from this data source starting at offset and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. parameter offset is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! Note that this method does not affect the current read position. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadRandomDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 offset = 0;
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(offset, buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...

                    // Increase offset where to read next.
                    offset += bytes_read;
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN FileDataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [virtual]

Reads exactly count bytes from this data source starting at offset and copies them to the provided buffer. Note that this method does not affect the current read position.

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN FileDataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [virtual]

Reads up to max_count bytes from this data source starting at the current read position and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. the current read position is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! The current read position is updated. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadSequentialDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN FileDataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [virtual]

Reads exactly count bytes from this data source starting at the current read position and copies them to the provided buffer. The current read position is updated.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implements DataSource.

Field Documentation

FilePtr FileDataSource::m_file [protected]

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileDataSource.hpp
  • Afs/Rfs/FileDataSource.cpp
Generated on Wed Jan 25 01:15:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileFilter Class Reference
[Root File System]

Base class for file filters. More...

#include <Apoxi/Afs/Rfs/FileFilter.hpp>

Inheritance diagram for FileFilter:

[legend]

Public Member Functions

virtual BOOLEAN | Complies (const Path &path)=0
virtual | ~FileFilter ()
Destroys a file filter.

Protected Member Functions

FileFilter ()
Constructs a file filter.

Detailed Description

Base class for file filters.

Abstract class FileFilter is the base class for file filter functors. Concrete filters have to override method Complies(). If a function or method requires a file filter to be passed as argument but you are interested in all files then just pass the temporary object of an empty smart-pointer, i.e. FileFilterPtr(0).

Constructor & Destructor Documentation

FileFilter::~FileFilter ( ) [virtual]

Destroys a file filter.

FileFilter::FileFilter ( ) [protected]

Constructs a file filter.

Member Function Documentation

virtual BOOLEAN FileFilter::Complies ( const Path & path ) [pure virtual]

Tells if the file with path complies with the filter criteria.

Parameters:
path The path of the file to filter.
Returns:
Tells if the file with path complies with the filter.

Implemented in NamePatternFileFilter, ImageFileFilter, and SoundFileFilter.

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileFilter.hpp
  • Afs/Rfs/FileFilter.cpp
Generated on Wed Jan 25 01:15:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileInfo_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileInfo_s Struct Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/Unzip.hpp>

Data Fields

UINT16 | compressed_size
UINT16 | compression_method
UINT32 | crc
UINT16 | disk_num_start
UINT32 | dosDate
UINT32 | external_fa
UINT16 | flag
UINT16 | internal_fa
UINT16 | size_file_comment
UINT16 | size_file_extra
UINT16 | size_filename
UINT16 | uncompressed_size
UINT16 | version
UINT16 | version_needed

Field Documentation

UINT16 FileInfo_s::compressed_size

UINT16 FileInfo_s::compression_method

UINT32 FileInfo_s::crc

UINT16 FileInfo_s::disk_num_start

UINT32 FileInfo_s::dosDate

UINT32 FileInfo_s::external_fa

UINT16 FileInfo_s::flag

UINT16 FileInfo_s::internal_fa

UINT16 FileInfo_s::size_file_comment

UINT16 FileInfo_s::size_file_extra

UINT16 FileInfo_s::size_filename

UINT16 FileInfo_s::uncompressed_size

UINT16 FileInfo_s::version

UINT16 FileInfo_s::version_needed

The documentation for this struct was generated from the following file:
  • AddOns/MultiMedia/Unzip.hpp
Generated on Wed Jan 25 01:15:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileInfoInternal_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileInfoInternal_s Struct Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/Unzip.hpp>

Data Fields

UINT32 offset_curfile

Field Documentation

UINT32 FileInfoInternal_s::offset_curfile

The documentation for this struct was generated from the following file:
  • AddOns/MultiMedia/Unzip.hpp
Generated on Wed Jan 25 01:15:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileInputStream Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileInputStream Class Reference
[Kernel]

#include <Apoxi/Compat/FileInputStream.hpp>

Inheritance diagram for FileInputStream:

[legend]
Collaboration diagram for FileInputStream:

[legend]

Public Member Functions

virtual UINT32 | Available ()
void | Close ()
int | Eof ()
FileInputStream ()
int | IsOpen () const
void | Open (const char *name, int flags)
int | Peek ()
virtual INT | Read (BYTE *data, INT len)
virtual INT | Read (BYTE &data)
virtual | ~FileInputStream ()

Constructor & Destructor Documentation

FileInputStream::FileInputStream ( )

FileInputStream::~FileInputStream ( ) [virtual]

Member Function Documentation

UINT32 FileInputStream::Available ( ) [virtual]

Implements InputStream.

void FileInputStream::Close ( ) [inline]

int FileInputStream::Eof ( ) [inline]

int FileInputStream::IsOpen ( void ) const [inline]

void FileInputStream::Open | ( | const char * | name,
 |  | int | flags
 | ) | [inline]

int FileInputStream::Peek ( ) [inline]

INT FileInputStream::Read | ( | BYTE * | data,
 |  | INT | len
 | ) | [virtual]

Reimplemented from InputStream.

INT FileInputStream::Read ( BYTE & data ) [virtual]

Implements InputStream.

The documentation for this class was generated from the following files:
  • Compat/FileInputStream.hpp
  • Compat/FileInputStream.cpp
Generated on Wed Jan 25 01:15:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileInReadStatusInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileInReadStatusInfo Struct Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/UnzipFfs.hpp>

Data Fields

UINT32 | byte_before_the_zipfile
UINT32 | compression_method
UINT32 | crc32
UINT32 | crc32_wait
FfsHandle jar_file_handle
const CHAR * | jar_file_name
UINT32 | offset_local_extrafield
UINT32 | pos_in_zipfile
UINT32 | pos_local_extrafield
CHAR * | read_buffer
UINT32 | rest_read_compressed
UINT32 | rest_read_uncompressed
UINT | size_local_extrafield
z_stream | stream
UINT32 | stream_initialised

Field Documentation

UINT32 FileInReadStatusInfo::byte_before_the_zipfile

UINT32 FileInReadStatusInfo::compression_method

UINT32 FileInReadStatusInfo::crc32

UINT32 FileInReadStatusInfo::crc32_wait

FfsHandle FileInReadStatusInfo::jar_file_handle

const CHAR* FileInReadStatusInfo::jar_file_name

UINT32 FileInReadStatusInfo::offset_local_extrafield

UINT32 FileInReadStatusInfo::pos_in_zipfile

UINT32 FileInReadStatusInfo::pos_local_extrafield

CHAR* FileInReadStatusInfo::read_buffer

UINT32 FileInReadStatusInfo::rest_read_compressed

UINT32 FileInReadStatusInfo::rest_read_uncompressed

UINT FileInReadStatusInfo::size_local_extrafield

z_stream FileInReadStatusInfo::stream

UINT32 FileInReadStatusInfo::stream_initialised

The documentation for this struct was generated from the following file:
  • AddOns/MultiMedia/UnzipFfs.hpp
Generated on Wed Jan 25 01:15:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileNameListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileNameListBoxModel Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

Model for showing filenames stored in a MediaRefContainer. More...

#include <Applications/ImageBrowser/Common/FileNameListBoxModel.hpp>

Collaboration diagram for FileNameListBoxModel:

[legend]

Public Member Functions

FileNameListBoxModel (DrawableObjectListBox *control, const MediaRefContainer &media_refs)
FileNameListBoxModel ()
FileNameListBoxModel (DrawableObjectListBox *control, const MediaRefContainer &media_refs)
FileNameListBoxModel ()
virtual const WCHAR * | GetCellText (INT index, BOOLEAN highlighted)
virtual const WCHAR * | GetCellText (INT index, BOOLEAN highlighted)
void | Init (DrawableObjectListBox *control, const MediaRefContainer &media_refs)
void | Init (DrawableObjectListBox *control, const MediaRefContainer &media_refs)
virtual | ~FileNameListBoxModel ()
virtual | ~FileNameListBoxModel ()

Detailed Description

Model for showing filenames stored in a MediaRefContainer.

Constructor & Destructor Documentation

FileNameListBoxModel::FileNameListBoxModel ( )

FileNameListBoxModel::FileNameListBoxModel | ( | DrawableObjectListBox * | control,
 |  | const MediaRefContainer & | media_refs
 | ) |

FileNameListBoxModel::~FileNameListBoxModel ( ) [virtual]

FileNameListBoxModel::FileNameListBoxModel ( )

FileNameListBoxModel::FileNameListBoxModel | ( | DrawableObjectListBox * | control,
 |  | const MediaRefContainer & | media_refs
 | ) |

virtual FileNameListBoxModel::~FileNameListBoxModel ( ) [virtual]

Member Function Documentation

virtual const WCHAR* FileNameListBoxModel::GetCellText | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

Returns the text representing the item.

Parameters:
index | Index of the item.
highlighted | Defines if the selected item is highlighted (ignored).

const WCHAR * FileNameListBoxModel::GetCellText | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

Returns the text representing the item.

Parameters:
index | Index of the item.
highlighted | Defines if the selected item is highlighted (ignored).

void FileNameListBoxModel::Init | ( | DrawableObjectListBox * | control,
 |  | const MediaRefContainer & | media_refs
 | ) |

void FileNameListBoxModel::Init | ( | DrawableObjectListBox * | control,
 |  | const MediaRefContainer & | media_refs
 | ) |

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/FileNameListBoxModel.hpp
  • Applications/SoundBrowser/Common/FileNameListBoxModel.hpp
  • Applications/ImageBrowser/Common/FileNameListBoxModel.cpp
  • Applications/SoundBrowser/Common/FileNameListBoxModel.cpp
Generated on Wed Jan 25 01:15:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileNameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileNameView Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

View for showing filenames by the use of a FileNameListBoxModel. More...

#include <Applications/ImageBrowser/Common/FileNameView.hpp>

Inheritance diagram for FileNameView:

[legend]
Collaboration diagram for FileNameView:

[legend]

Public Member Functions

FileNameView ()
FileNameView ()
void | Init (Control *parent, MediaRefContainer &media_refs)
void | Init (Control *parent, MediaRefContainer &media_refs)
virtual | ~FileNameView ()
virtual | ~FileNameView ()

Protected Member Functions

virtual void | OnGetFocus ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual BOOLEAN | OnMessage (const Message &msg)

Detailed Description

View for showing filenames by the use of a FileNameListBoxModel.

Constructor & Destructor Documentation

FileNameView::FileNameView ( )

FileNameView::~FileNameView ( ) [virtual]

FileNameView::FileNameView ( )

virtual FileNameView::~FileNameView ( ) [virtual]

Member Function Documentation

void FileNameView::Init | ( | Control * | parent,
 |  | MediaRefContainer & | media_refs
 | ) |

Initializes the object.

Parameters:
parent | Parent control where the BrowserView should be shown.
media_refs | Reference to the MediaRefContainer containing the entries of the items to be shown.

void FileNameView::Init | ( | Control * | parent,
 |  | MediaRefContainer & | media_refs
 | ) |

Initializes the object.

Parameters:
parent | Parent control where the BrowserView should be shown.
media_refs | Reference to the MediaRefContainer containing the entries of the items to be shown.

virtual void FileNameView::OnGetFocus ( ) [protected, virtual]

void FileNameView::OnGetFocus ( ) [protected, virtual]

virtual BOOLEAN FileNameView::OnMessage ( const Message & msg ) [protected, virtual]

BOOLEAN FileNameView::OnMessage ( const Message & msg ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/FileNameView.hpp
  • Applications/SoundBrowser/Common/FileNameView.hpp
  • Applications/ImageBrowser/Common/FileNameView.cpp
  • Applications/SoundBrowser/Common/FileNameView.cpp
Generated on Wed Jan 25 01:15:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileOutputStream Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileOutputStream Class Reference
[Kernel]

#include <Apoxi/Compat/FileOutputStream.hpp>

Inheritance diagram for FileOutputStream:

[legend]
Collaboration diagram for FileOutputStream:

[legend]

Public Member Functions

void | Close ()
INT | Eof ()
FileOutputStream ()
virtual void | Flush ()
INT | IsOpen () const
void | Open (const char *name, int flags)
virtual INT | Write (const BYTE *data, INT len)
virtual INT | Write (const BYTE data)
virtual | ~FileOutputStream ()

Constructor & Destructor Documentation

FileOutputStream::FileOutputStream ( )

FileOutputStream::~FileOutputStream ( ) [virtual]

Member Function Documentation

void FileOutputStream::Close ( ) [inline]

INT FileOutputStream::Eof ( ) [inline]

void FileOutputStream::Flush ( ) [virtual]

Reimplemented from OutputStream.

INT FileOutputStream::IsOpen ( void ) const [inline]

void FileOutputStream::Open | ( | const char * | name,
 |  | int | flags
 | ) | [inline]

INT FileOutputStream::Write | ( | const BYTE * | data,
 |  | INT | len
 | ) | [virtual]

Reimplemented from OutputStream.

INT FileOutputStream::Write ( const BYTE data ) [virtual]

Implements OutputStream.

The documentation for this class was generated from the following files:
  • Compat/FileOutputStream.hpp
  • Compat/FileOutputStream.cpp
Generated on Wed Jan 25 01:15:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FilePack Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FilePack Class Reference

#include <Apoxi/Gui/FilePack.hpp>

Inheritance diagram for FilePack:

[legend]
Collaboration diagram for FilePack:

[legend]

Public Member Functions

FilePack (const UINT8 *data)
const CustFileData * | GetFile (UINT16 index)
virtual | ~FilePack ()

Constructor & Destructor Documentation

FilePack::FilePack ( const UINT8 * data )

FilePack::~FilePack ( ) [virtual]

Member Function Documentation

const CustFileData * FilePack::GetFile ( UINT16 index )

The documentation for this class was generated from the following files:
  • Gui/FilePack.hpp
  • Gui/FilePack.cpp
Generated on Wed Jan 25 01:15:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FilePackConnector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FilePackConnector Class Reference

#include <Apoxi/Gui/FilePackConnector.hpp>

Collaboration diagram for FilePackConnector:

[legend]

Static Public Member Functions

static void | CopyData (UINT16 file_index, UINT8 *buffer, UINT32 offset, UINT32 length)
static const UINT8 * | GetData (UINT16 index)
static const WCHAR * | GetFileName (UINT16 index)
static void | GetFileNames (const WCHAR **file_names, INT size)
static UINT32 | GetFileSize (UINT16 index)
static INT32 | GetIndexOfFile (const WCHAR *file_name)
static MimeType | GetMimeType (UINT16 file_index)
static INT | GetNumberOfFiles ()
static void | Init ()
static BOOLEAN | IsFilePackAvailable ()

Member Function Documentation

void FilePackConnector::CopyData | ( | UINT16 | file_index,
 |  | UINT8 * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | length
 | ) | [static]

const UINT8 * FilePackConnector::GetData ( UINT16 index ) [static]

const WCHAR * FilePackConnector::GetFileName ( UINT16 index ) [static]

void FilePackConnector::GetFileNames | ( | const WCHAR ** | file_names,
 |  | INT | size
 | ) | [static]

UINT32 FilePackConnector::GetFileSize ( UINT16 index ) [static]

INT32 FilePackConnector::GetIndexOfFile ( const WCHAR * file_name ) [static]

MimeType FilePackConnector::GetMimeType ( UINT16 file_index ) [static]

INT FilePackConnector::GetNumberOfFiles ( ) [static]

void FilePackConnector::Init ( ) [static]

BOOLEAN FilePackConnector::IsFilePackAvailable ( ) [static]

The documentation for this class was generated from the following files:
  • Gui/FilePackConnector.hpp
  • Gui/FilePackConnector.cpp
Generated on Wed Jan 25 01:15:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FileVisitor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FileVisitor Class Reference
[Root File System]

Base class for file visitors. More...

#include <Apoxi/Afs/Rfs/FileVisitor.hpp>

Collaboration diagram for FileVisitor:

[legend]

Public Member Functions

FileFilterPtr | GetIteratorFilter () const
virtual BOOLEAN | Visit (const Path &file)=0
BOOLEAN | VisitDirectories () const
virtual | ~FileVisitor ()
Destroys the file visitor.

Protected Member Functions

FileVisitor (const FileFilterPtr &filter, BOOLEAN visit_directories=FALSE)

Protected Attributes

FileFilterPtr m_filter
The client provided filter for selecting the files to iterate on.

Detailed Description

Base class for file visitors.

Class FileVisitor implements an operation which shall be executed for all or certain filtered files in a directory. An instance of class File can accept a file visitor and in case the file is a directory it accepts the visitor and calls its method Visit() on every file gathered using a directory iterator initialized with the filter defined in the file visitor. This implements the visitor pattern.

Constructor & Destructor Documentation

FileVisitor::~FileVisitor ( ) [virtual]

Destroys the file visitor.

FileVisitor::FileVisitor | ( | const FileFilterPtr & | filter,
 |  | BOOLEAN | visit_directories = FALSE
 | ) | [protected]

Constructs a file visitor. The filter is used to initialize the directory iterator which shall be used and the last argument defines if subdirectories themselves are visited, too.

Parameters:
filter | The filter functor used to initialize the directory iterator.
visit_directories | Tells if subdirectories themselves are visited.

Member Function Documentation

FileFilterPtr FileVisitor::GetIteratorFilter ( ) const [inline]

Returns the filter functor for intializing the iterator to be used.

virtual BOOLEAN FileVisitor::Visit ( const Path & file ) [pure virtual]

Visits file and performs its operation on it. The return value indicates if the visiting shall continue or shall be aborted.

BOOLEAN FileVisitor::VisitDirectories ( ) const [inline]

Tells if directories themselves shall be visited, i.e. if method Visit() shall be called also on directories or only on files.

Field Documentation

FileFilterPtr FileVisitor::m_filter [protected]

The client provided filter for selecting the files to iterate on.

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileVisitor.hpp
  • Afs/Rfs/FileVisitor.cpp
Generated on Wed Jan 25 01:15:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FilterProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FilterProvider Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/FilterProvider.hpp>

Inheritance diagram for FilterProvider:

[legend]
Collaboration diagram for FilterProvider:

[legend]

Public Types

typedef AbstractDelegationProvider | Base

Public Member Functions

virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
FilterProvider (Provider *provider, FilterRule *rule, INT columnid=0, BOOLEAN negation=FALSE)
FilterProvider ()
virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
GetChildRow gives the mapping of row to the row in the child provider
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
void | Init (Provider *provider, FilterRule *rule, INT columnid=0, BOOLEAN negation=FALSE)
The same interface as the constructor.
virtual BOOLEAN | InsertRow (INT row)
InsertRow adds a row in front of the row specified.
virtual void | OnExecutingListener (Provider *provider=0)
virtual INT | RowCount ()
RowCount returns the number of filtered rows.
void | SetFilterColumn (INT filtercolumn)
Specify on which column rule has to be applied.
void | SetFilterRule (FilterRule *rule)
Specify how the rows are filtered.
void | SetNegation (BOOLEAN negation)
negate the given filter rule (TRUE) or not (FALSE)
virtual BOOLEAN | SetParameter (const DataItem &item)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and starts the filter process.
virtual | ~FilterProvider ()
Destructor.

Protected Member Functions

virtual BOOLEAN | IsRowFiltered (Provider *base_provider, INT row, BOOLEAN negate)
virtual void | OnChildProviderModification (Provider *provider, const Provider::Modification &modification)

Detailed Description

A FilterProvider is used to access rows of a child provider which match a criterion specified in a filter rule.

Member Typedef Documentation

typedef AbstractDelegationProvider FilterProvider::Base

Reimplemented from AbstractDelegationProvider.

Reimplemented in DistinctProvider, and PbNameFilterProvider.

Constructor & Destructor Documentation

FilterProvider::FilterProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

FilterProvider::FilterProvider | ( | Provider * | provider,
 |  | FilterRule * | rule,
 |  | INT | columnid = 0,
 |  | BOOLEAN | negation = FALSE
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be filtered. rule: Specify how the rows are filtered. columnid: Specify on which columnid rule has to be applied. negation: Specify whether rule must be negated.

FilterProvider::~FilterProvider ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN FilterProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

DeleteAllRows deletes all filtered rows of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

BOOLEAN FilterProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

GetChildRow gives the mapping of row to the row in the child provider

Implements AbstractDelegationProvider.

Reimplemented in DistinctProvider.

BOOLEAN FilterProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements AbstractDelegationProvider.

Reimplemented in DistinctProvider, and PbNameFilterProvider.

void FilterProvider::Init | ( | Provider * | provider,
 |  | FilterRule * | rule,
 |  | INT | columnid = 0,
 |  | BOOLEAN | negation = FALSE
 | ) |

The same interface as the constructor.

BOOLEAN FilterProvider::InsertRow ( INT row ) [virtual]

InsertRow adds a row in front of the row specified.

Reimplemented from AbstractDelegationProvider.

BOOLEAN FilterProvider::IsRowFiltered | ( | Provider * | base_provider,
 |  | INT | row,
 |  | BOOLEAN | negate
 | ) | [protected, virtual]

Determines whether or not the specified row should be included.

Parameters:
base_provider | Child provider.
row | Index of row to test.
negate | TRUE to negate the result, FALSE otherwise.
Returns:
TRUE to include row row, FALSE otherwise.

Reimplemented in DualFilterProvider.

void FilterProvider::OnChildProviderModification | ( | Provider * | provider,
 |  | const Provider::Modification & | modification
 | ) | [protected, virtual]

Reimplemented from AbstractDelegationProvider.

void FilterProvider::OnExecutingListener ( Provider * provider = 0 ) [virtual]

Called by DelegationProviderListener to modify the progress value. The current version reflects the progress value of the child-provider until 99 percent.

Reimplemented from AbstractDelegationProvider.

INT FilterProvider::RowCount ( ) [virtual]

RowCount returns the number of filtered rows.

Reimplemented from AbstractDelegationProvider.

void FilterProvider::SetFilterColumn ( INT filtercolumn ) [inline]

Specify on which column rule has to be applied.

Reimplemented in DistinctProvider.

void FilterProvider::SetFilterRule ( FilterRule * rule ) [inline]

Specify how the rows are filtered.

void FilterProvider::SetNegation ( BOOLEAN negation ) [inline]

negate the given filter rule (TRUE) or not (FALSE)

BOOLEAN FilterProvider::SetParameter ( const DataItem & item ) [virtual]

GetColumnInfoPerId reflects GetColumnInfoPerId of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

Reimplemented in DualFilterProvider, and PbNameFilterProvider.

BOOLEAN FilterProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and starts the filter process.

Reimplemented from AbstractDelegationProvider.

Reimplemented in DistinctProvider, and PbNameFilterProvider.

The documentation for this class was generated from the following files:
  • Auxiliary/FilterProvider.hpp
  • Auxiliary/FilterProvider.cpp
Generated on Wed Jan 25 01:15:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FilterRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FilterRule Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/FilterRule.hpp>

Inheritance diagram for FilterRule:

[legend]
Collaboration diagram for FilterRule:

[legend]

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)=0
FilterRule (const DataItem &ruleitem, const DataItem &rule2item)
FilterRule (const DataItem &ruleitem)
FilterRule ()
void | Init (const DataItem &ruleitem, const DataItem &rule2item)
void | Init (const DataItem &ruleitem)
virtual | ~FilterRule ()

Protected Attributes

DataItem m_rule2item
DataItem m_ruleitem

Detailed Description

A FilterRule is used to specify a criterion on a data item. See also: ContainsRule, EqualsRule, RangeRule.

Constructor & Destructor Documentation

FilterRule::FilterRule ( )

On construction a data item (the rule item) has to be given to specify the value which has to be tested.

FilterRule::FilterRule ( const DataItem & ruleitem )

FilterRule::FilterRule | ( | const DataItem & | ruleitem,
 |  | const DataItem & | rule2item
 | ) |

FilterRule::~FilterRule ( ) [virtual]

Member Function Documentation

virtual BOOLEAN FilterRule::ExecuteRule ( const DataItem & dataitem ) [pure virtual]

ExecuteRule does the actual comparision between the data item given in the argument and the value stored when the filter rule is constructed.

Implemented in DcsLanguageFilterRule, PhoneNumberMatchRule, DistinctRule, EqualsRule, NotEqualsRule, RangeRule, LessRule, and GreaterRule.

void FilterRule::Init | ( | const DataItem & | ruleitem,
 |  | const DataItem & | rule2item
 | ) |

void FilterRule::Init ( const DataItem & ruleitem ) [inline]

Reimplemented in PhoneNumberMatchRule.

Field Documentation

DataItem FilterRule::m_rule2item [protected]

DataItem FilterRule::m_ruleitem [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/FilterRule.hpp
  • Auxiliary/FilterRule.cpp
Generated on Wed Jan 25 01:15:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Find2Provider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Find2Provider Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Find2Provider.hpp>

Inheritance diagram for Find2Provider:

[legend]
Collaboration diagram for Find2Provider:

[legend]

Public Types

typedef FindProvider | Base

Public Member Functions

Find2Provider (Provider *provider, FilterRule *rule, INT column, FilterRule *rule2, INT column2)
Find2Provider ()
void | Init (Provider *provider, FilterRule *rule, INT column, FilterRule *rule2, INT column2)
The same interface as the constructor.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and starts the find process.
virtual | ~Find2Provider ()

Detailed Description

A Find2Provider is a find provider, which takes a second column and filter rule. The conditions are connected using a logical AND. NOTE: No writing is possible on a FindProvider. Use GetChildRow to get the row of the child provider and update the child provider directly. See also: Provider, FilterProvider, DataItem, FilterRule, FindProvider.

Member Typedef Documentation

typedef FindProvider Find2Provider::Base

Reimplemented from FindProvider.

Constructor & Destructor Documentation

Find2Provider::Find2Provider ( )

Find2Provider::Find2Provider | ( | Provider * | provider,
 |  | FilterRule * | rule,
 |  | INT | column,
 |  | FilterRule * | rule2,
 |  | INT | column2
 | ) |

Find2Provider::~Find2Provider ( ) [virtual]

Member Function Documentation

void Find2Provider::Init | ( | Provider * | provider,
 |  | FilterRule * | rule,
 |  | INT | column,
 |  | FilterRule * | rule2,
 |  | INT | column2
 | ) |

The same interface as the constructor.

BOOLEAN Find2Provider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and starts the find process.

Reimplemented from FindProvider.

The documentation for this class was generated from the following files:
  • Auxiliary/Find2Provider.hpp
  • Auxiliary/Find2Provider.cpp
Generated on Wed Jan 25 01:15:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FindProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FindProvider Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/FindProvider.hpp>

Inheritance diagram for FindProvider:

[legend]
Collaboration diagram for FindProvider:

[legend]

Public Types

typedef AbstractDelegationProvider | Base

Public Member Functions

virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
FindProvider (Provider *provider, FilterRule *rule, INT columnid=0)
FindProvider ()
virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
GetChildRow gives the mapping of row to the row in the child provider
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
void | Init (Provider *provider, FilterRule *rule, INT columnid=0)
The same interface as the constructor.
virtual void | OnExecutingListener (Provider *provider=0)
virtual INT | RowCount ()
RowCount returns the number of found rows, normally always 1 or 0.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and starts the find process.
virtual | ~FindProvider ()

Protected Member Functions

virtual void | OnChildProviderModification (Provider *provider, const Provider::Modification &modification)

Protected Attributes

INT | m_column
INT | m_FindRow
FilterRule * m_rule

Detailed Description

A FindProvider is used to access the first row of a child provider which match a criterion specified in a filter rule.

Member Typedef Documentation

typedef AbstractDelegationProvider FindProvider::Base

Reimplemented from AbstractDelegationProvider.

Reimplemented in Find2Provider.

Constructor & Destructor Documentation

FindProvider::FindProvider ( )

FindProvider::FindProvider | ( | Provider * | provider,
 |  | FilterRule * | rule,
 |  | INT | columnid = 0
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be filtered. rule: Specify how the rows are filtered. columnid: Specify on which columnid rule has to be applied.

FindProvider::~FindProvider ( ) [virtual]

Member Function Documentation

BOOLEAN FindProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

DeleteAllRows deletes the found row of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

BOOLEAN FindProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

GetChildRow gives the mapping of row to the row in the child provider

Implements AbstractDelegationProvider.

BOOLEAN FindProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements AbstractDelegationProvider.

void FindProvider::Init | ( | Provider * | provider,
 |  | FilterRule * | rule,
 |  | INT | columnid = 0
 | ) |

The same interface as the constructor.

void FindProvider::OnChildProviderModification | ( | Provider * | provider,
 |  | const Provider::Modification & | modification
 | ) | [protected, virtual]

Reimplemented from AbstractDelegationProvider.

void FindProvider::OnExecutingListener ( Provider * provider = 0 ) [virtual]

Called by DelegationProviderListener to modify the progress value. The current version reflects the progress value of the child-provider until 99 percent.

Reimplemented from AbstractDelegationProvider.

INT FindProvider::RowCount ( ) [virtual]

RowCount returns the number of found rows, normally always 1 or 0.

Reimplemented from AbstractDelegationProvider.

BOOLEAN FindProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and starts the find process.

Reimplemented from AbstractDelegationProvider.

Reimplemented in Find2Provider.

Field Documentation

INT FindProvider::m_column [protected]

INT FindProvider::m_FindRow [protected]

FilterRule* FindProvider::m_rule [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/FindProvider.hpp
  • Auxiliary/FindProvider.cpp
Generated on Wed Jan 25 01:15:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FixedPtrArray< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FixedPtrArray< T > Class Template Reference

#include <Apoxi/Auxiliary/FixedPtrArray.hpp>

Inheritance diagram for FixedPtrArray< T >:

[legend]

Public Types

typedef T * | PtrT

Public Member Functions

void | DeletePtrObj (INT idx) const
FixedPtrArray (INT count)
Creates a pointer array of length count.
FixedPtrArray ()
Creates a pointer array of length zero.
INT | GetCount () const
PtrT | GetPtr (INT idx) const
PtrT | operator[] (INT idx)
PtrT | operator[] (INT idx) const
BOOLEAN | Resize (INT count)
BOOLEAN | Resize (INT count, T *pattern)
void | SetPtr (INT idx, PtrT ptr)
~FixedPtrArray ()
Deletes the pointer array but not the corresponding objects.

Detailed Description

template<class T>
class FixedPtrArray< T >

FixedPtrArray is used to represent an array of pointers to classes.

Member Typedef Documentation

template<class T>
typedef T* FixedPtrArray< T >::PtrT

Constructor & Destructor Documentation

template<class T>
FixedPtrArray< T >::FixedPtrArray ( ) [inline]

Creates a pointer array of length zero.

template<class T>
FixedPtrArray< T >::FixedPtrArray ( INT count ) [inline]

Creates a pointer array of length count.

template<class T>
FixedPtrArray< T >::~FixedPtrArray ( ) [inline]

Deletes the pointer array but not the corresponding objects.

Member Function Documentation

template<class T>
void FixedPtrArray< T >::DeletePtrObj ( INT idx ) const [inline]

template<class T>
INT FixedPtrArray< T >::GetCount ( ) const [inline]

template<class T>
PtrT FixedPtrArray< T >::GetPtr ( INT idx ) const [inline]

template<class T>
PtrT FixedPtrArray< T >::operator[] ( INT idx ) [inline]

template<class T>
PtrT FixedPtrArray< T >::operator[] ( INT idx ) const [inline]

template<class T>
BOOLEAN FixedPtrArray< T >::Resize ( INT count ) [inline]

template<class T>
BOOLEAN FixedPtrArray< T >::Resize | ( | INT | count,
 |  | T * | pattern
 | ) | [inline]

Resizes the array and fills the pointer array with a pattern, if the array grows the old data pointer array is deleted.

template<class T>
void FixedPtrArray< T >::SetPtr | ( | INT | idx,
 |  | PtrT | ptr
 | ) | [inline]

The documentation for this class was generated from the following file:
  • Auxiliary/FixedPtrArray.hpp
Generated on Wed Jan 25 01:15:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FlagCaretaker Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FlagCaretaker Class Reference

#include <Apoxi/Audio/FlagCaretaker.hpp>

Public Member Functions

FlagCaretaker (BOOLEAN &flag, BOOLEAN value_to_set)
~FlagCaretaker ()

Constructor & Destructor Documentation

FlagCaretaker::FlagCaretaker | ( | BOOLEAN & | flag,
 |  | BOOLEAN | value_to_set
 | ) |

FlagCaretaker::~FlagCaretaker ( )

The documentation for this class was generated from the following files:
  • Audio/FlagCaretaker.hpp
  • Audio/FlagCaretaker.cpp
Generated on Wed Jan 25 01:15:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FlashDirectoryIteratorImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FlashDirectoryIteratorImp Class Reference
[Flash File System support]

Directory iterator implementation for flash storage device. More...

#include <Apoxi/AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp>

Inheritance diagram for FlashDirectoryIteratorImp:

[legend]
Collaboration diagram for FlashDirectoryIteratorImp:

[legend]

Protected Member Functions

virtual DirectoryIterator & | AtomicIncrement ()
FlashDirectoryIteratorImp (const Pathname &dir_pathname, const FileFilterPtr &filter, BOOLEAN find_dirs)
virtual | ~FlashDirectoryIteratorImp ()
Destroys the flash directory iterator.

Friends

class | FlashStorageDeviceImp

Detailed Description

Directory iterator implementation for flash storage device.

Class FlashDirectoryIteratorImp implements the directory iterator for the flash storage device.

Constructor & Destructor Documentation

FlashDirectoryIteratorImp::FlashDirectoryIteratorImp | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter,
 |  | BOOLEAN | find_dirs
 | ) | [explicit, protected]

See also:
DirectoryIterator::DirectoryIterator(const Pathname &, const FileFilterPtr &, const WString &)

virtual FlashDirectoryIteratorImp::~FlashDirectoryIteratorImp ( ) [protected, virtual]

Destroys the flash directory iterator.

Member Function Documentation

virtual DirectoryIterator& FlashDirectoryIteratorImp::AtomicIncrement ( ) [protected, virtual]

Increments the iterator to point to the next pathname in the directory and returns a reference to itself. This increment operation does not consider the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

Returns:
Reference to itself incremented to point to the next pathname or to the root pathname signaling the end iterator.

Implements DirectoryIterator.

Friends And Related Function Documentation

friend class FlashStorageDeviceImp [friend]

The documentation for this class was generated from the following files:
  • AddOns/AfsFfs/FlashDirectoryIteratorImp.hpp
  • AddOns/AfsFfs/FlashDirectoryIteratorImp.cpp
Generated on Wed Jan 25 01:15:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FlashFileImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FlashFileImp Class Reference
[Flash File System support]

File implementation for flash file system (FFS) storage device More...

#include <Apoxi/AddOns/AfsFfs/FlashFileImp.hpp>

Inheritance diagram for FlashFileImp:

[legend]
Collaboration diagram for FlashFileImp:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | Create (UINT32 size)
virtual BOOLEAN | CreateDir ()
virtual BOOLEAN | CreateStreaming ()
virtual BOOLEAN | Delete ()
virtual BOOLEAN | GetAttributes (Attributes &attributes) const
virtual BOOLEAN | GetCreationDate (Date &date) const
virtual BOOLEAN | GetModificationDate (Date &date) const
virtual BOOLEAN | GetNativeProperty (UINT prop_Id, void *val) const
virtual BOOLEAN | GetSize (UINT32 &size) const
virtual const WString & | GetStorageDeviceId () const
virtual BOOLEAN | IsArchive () const
virtual BOOLEAN | IsHidden () const
virtual BOOLEAN | IsOpen () const
Tells if the file is open.
virtual BOOLEAN | IsReadOnly () const
virtual BOOLEAN | Open (OpenMode open_mode)
virtual BOOLEAN | OpenStreaming (OpenMode open_mode)
virtual BOOLEAN | Rename (const WString &new_name)
virtual BOOLEAN | Resize (UINT32 new_size, UINT32 copy_buf_size)
virtual BOOLEAN | SetArchive (BOOLEAN archive)
virtual BOOLEAN | SetHidden (BOOLEAN hidden)
virtual BOOLEAN | SetNativeProperty (UINT prop_Id, const void *val)
virtual BOOLEAN | SetReadOnly (BOOLEAN read_only)

Static Public Attributes

static const UINT | PROP_DRM_ATTRIB = 2
static const UINT | PROP_NATIVEHANDLE = 0
static const UINT | PROP_USERID = 1

Protected Member Functions

virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 count)
virtual BOOLEAN | DoReadStreaming (void HUGE *buffer, UINT32 count, UINT32 &bytes_read)
virtual BOOLEAN | DoReadStreamingAsync (void HUGE *buffer, UINT32 count, StreamingCallback)
virtual BOOLEAN | DoWrite (const void HUGE *buffer, UINT32 offset, UINT32 count)
virtual BOOLEAN | DoWriteStreaming (const void HUGE *buffer, UINT32 count)
virtual BOOLEAN | DoWriteStreamingAsync (const void HUGE *buffer, UINT32 count, StreamingCallback)
FlashFileImp (const Pathname &pathname)
virtual const FileState & | MyState () const
Returns the constant state of the constant file.
virtual FileState & | MyState ()
Returns the state of the file.
virtual | ~FlashFileImp ()

Friends

class | FlashStorageDeviceImp

Detailed Description

File implementation for flash file system (FFS) storage device

Class FlashFileImp represents a file stored on the FFS storage device supporting the root file system interface.

FlashFileImp supports native stream reading and native stream writing. Please see the following code samples:

See also:
File

Constructor & Destructor Documentation

FlashFileImp::FlashFileImp ( const Pathname & pathname ) [protected]

FlashFileImp::~FlashFileImp ( ) [protected, virtual]

Member Function Documentation

BOOLEAN FlashFileImp::Close ( ) [virtual]

Closes a previously opened file. An overriding method must call this base implementation at the end of its implementation if the file could be closed successfully to assure that the counter of open files gets set properly.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FlashFileImp::Create ( UINT32 size ) [virtual]

Creates a physical file with path m_path and initial size specified in bytes. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents operations in mode ReadAndWriteMode and its internal file position is set to 0, independent of the size argument. The file grows itself if it is written beyond its actual size. Creating an empty file with size 0 is allowed. For shrinking or growing the file use method Resize(). An overriding method must call this base implementation at the end of its implementation if the file could be created successfully to assure that the counter of open files gets set properly. This is a file operation and of course the file must not be open on call.

Parameters:
size The initial size of the new file.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FlashFileImp::CreateDir ( ) [virtual]

Creates a physical directory with path m_path. The last segment of m_path is taken as name of the new directory to create. The directory can only be created if all the directories specified in m_path already exist and the new directory doesn't exist yet. This is a file operation and of course the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FlashFileImp::CreateStreaming ( ) [virtual]

Creates a physical file with path m_path. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents in streaming mode.

This means that only the methods:

  • WriteStreaming
  • WriteStreamingAsync
  • ReadStreaming
  • ReadStreamingAsync and not the methods Read() or Write() can be used with this file.

Implements File.

BOOLEAN FlashFileImp::Delete ( ) [virtual]

Deletes the file or directory. If the file is actually a directory, then it must be empty in order to be deleted. If the file or directory does not exist the method fails. The method succeeds if and only if the file or directory could successfully be deleted. This is a file operation, the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FlashFileImp::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [protected, virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)

Implements File.

BOOLEAN FlashFileImp::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 count)

Implements File.

BOOLEAN FlashFileImp::DoReadStreaming | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 & | bytes_read
 | ) | [protected, virtual]

See also:
ReadStreaming(void HUGE *buffer, UINT32 count, UINT32 &bytes_read);

Implements File.

virtual BOOLEAN FlashFileImp::DoReadStreamingAsync | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [protected, virtual]

See also:
ReadStreamingAsync(void HUGE *buffer, UINT32 count, StreamingCallback);

Implements File.

BOOLEAN FlashFileImp::DoWrite | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
Write(const void HUGE *buffer, UINT32 offset, UINT32 count)

Implements File.

BOOLEAN FlashFileImp::DoWriteStreaming | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
WriteStreaming(const void HUGE *buffer, UINT32 count);

Implements File.

virtual BOOLEAN FlashFileImp::DoWriteStreamingAsync | ( | const void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [protected, virtual]

See also:
WriteStreamingAsync(const void HUGE *buffer, UINT32 count, StreamingCallback);

Implements File.

BOOLEAN FlashFileImp::GetAttributes ( Attributes & attributes ) const [virtual]

BOOLEAN FlashFileImp::GetCreationDate ( Date & date ) const [virtual]

If the creation date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FlashFileImp::GetModificationDate ( Date & date ) const [virtual]

If the modification date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FlashFileImp::GetNativeProperty | ( | UINT | prop_Id,
 |  | void * | val
 | ) | const [virtual]

Retrieves the native property identified by prop_Id via argument val. If the property is not supported by the native file (and therefore can't be retrieved) the method fails. The properties that the native file supports are defined by the derived class that implements the native file support. E.g., for knowing which properties a flash file supports look at the documentation of class FlashFileImp, there the respective property IDs are defined. It is crucial that the given property ID prop_Id and the receiving value val really match!

Parameters:
prop_Id | ID of the native file property to retrieve, defined in the derived class that implements the native file support.
val | Valid pointer to the value object that shall be set to the current value of the file property with id prop_Id.
Returns:
Tells if the file property could be retrieved.

Reimplemented from File.

BOOLEAN FlashFileImp::GetSize ( UINT32 & size ) const [virtual]

If the file size can be retrieved then size is set to the actual file size in bytes and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

const WString & FlashFileImp::GetStorageDeviceId ( ) const [virtual]

Returns the storage device ID of the device associated to this file class.

Implements File.

BOOLEAN FlashFileImp::IsArchive ( ) const [virtual]

Tells if the file is archive. This is a file operation, the file must not be open on call.

Implements File.

BOOLEAN FlashFileImp::IsHidden ( ) const [virtual]

Tells if the file is hidden. This is a file operation, the file must not be open on call.

Implements File.

virtual BOOLEAN FlashFileImp::IsOpen ( ) const [inline, virtual]

Tells if the file is open.

Implements File.

BOOLEAN FlashFileImp::IsReadOnly ( ) const [virtual]

Tells if the file is read only. This is a file operation, the file must not be open on call.

Implements File.

const File::FileState & FlashFileImp::MyState ( ) const [protected, virtual]

Returns the constant state of the constant file.

Implements File.

File::FileState & FlashFileImp::MyState ( ) [protected, virtual]

Returns the state of the file.

Implements File.

BOOLEAN FlashFileImp::Open ( OpenMode open_mode ) [virtual]

BOOLEAN FlashFileImp::OpenStreaming ( OpenMode open_mode ) [virtual]

BOOLEAN FlashFileImp::Rename ( const WString & new_name ) [virtual]

Renames the file or directory to new_name. If the file or directory does not exist the method fails. Argument new_name is the file name including the file extension (if any) but without any leading directories. The MIME type of the renamed file is defined by the extension of the new name, if none exists it has general type. If the new name is equal to the old name the method fails. The method succeeds if and only if the file or directory really was renamed. Subclasses have to first check if the new file name is different to the actual one, then physically rename the file, and finally call this base method for changing the name which is controlled within this base class. This base method never fails. For a sample implementation see FlashFileImp::Rename(). This is a file operation, the file must not be open on call.

Parameters:
new_name New name of the file including the file extension (if any). No directory segments are allowed.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN FlashFileImp::Resize | ( | UINT32 | new_size,
 |  | UINT32 | copy_buf_size
 | ) | [virtual]

Resizes the file to contain new_size bytes. If the new size is less than the original size then the file is truncated. If the new size is bigger than the original size then the newly created part of the file is not initialized and has to be written to be in defined state. Emptying a file by resizing it to size 0 is allowed. This default implementation uses a temporary file for resizing. Override this method if resizing is explicitly supported by the derived file class. This is a file operation, the file must not be open on call.

Parameters:
new_size | The new size of the file.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

BOOLEAN FlashFileImp::SetArchive ( BOOLEAN archive ) [virtual]

Sets the archive flag.

Parameters:
archive If TRUE then the file is an archive.

Implements File.

BOOLEAN FlashFileImp::SetHidden ( BOOLEAN hidden ) [virtual]

Sets the hidden flag.

Parameters:
hidden If TRUE then the file is hidden.

Implements File.

BOOLEAN FlashFileImp::SetNativeProperty | ( | UINT | prop_Id,
 |  | const void * | val
 | ) | [virtual]

Sets the native property identified by prop_Id to value val. If the property is not supported by the native file (and therefore can't be set) the method fails. The properties that the native file supports are defined by the derived class that implements the native file support. E.g., for knowing which properties a flash file supports look at the documentation of class FlashFileImp, there the respective property IDs are defined. It is crucial that the given property ID prop_Id and the passed value val really match!

Parameters:
prop_Id | ID of the native file property to set, defined in the derived class that implements the native file support.
val | Valid pointer to the value that shall be set for file property with id prop_Id.
Returns:
Tells if the file property could be set.

Reimplemented from File.

BOOLEAN FlashFileImp::SetReadOnly ( BOOLEAN read_only ) [virtual]

Sets the read only flag.

Parameters:
read_only If TRUE then the file is set to read only mode.

Implements File.

Friends And Related Function Documentation

friend class FlashStorageDeviceImp [friend]

Field Documentation

const UINT FlashFileImp::PROP_DRM_ATTRIB = 2 [static]

Property ID for the digital rights management (DRM) attribute of the internal flash file. This property is of type FfsDrmAttrib. Setting and getting this property is always possible.

const UINT FlashFileImp::PROP_NATIVEHANDLE = 0 [static]

Property ID for the internal flash file handle of type FfsHandle. Getting this property is only possible if the file is open. Setting this property is not possible.

const UINT FlashFileImp::PROP_USERID = 1 [static]

Property ID for the internal flash file user ID of type FfsUserType. Setting this property is only possible if the file is closed. Getting this property is always possible.

The documentation for this class was generated from the following files:
  • AddOns/AfsFfs/FlashFileImp.hpp
  • AddOns/AfsFfs/FlashFileImp.cpp
Generated on Wed Jan 25 01:15:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FlashStorageDeviceImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FlashStorageDeviceImp Class Reference
[Flash File System support]

Storage device implementation for flash storage device. More...

#include <Apoxi/AddOns/AfsFfs/FlashStorageDeviceImp.hpp>

Inheritance diagram for FlashStorageDeviceImp:

[legend]
Collaboration diagram for FlashStorageDeviceImp:

[legend]

Public Member Functions

virtual BOOLEAN | Exists (const Pathname &pathname) const
virtual BOOLEAN | Format (BOOLEAN quick=FALSE)
virtual UINT8 | GetDefaultChunkSize () const
virtual UINT32 | GetFreeVolumeSize () const
virtual WString | GetNativeDirectoryPathname (const Pathname &pathname) const
virtual WString | GetNativeFilePathname (const Pathname &pathname) const
virtual UINT32 | GetTotalVolumeSize () const
virtual UINT32 | GetUsedVolumeSize () const
virtual BOOLEAN | IsDirectory (const Pathname &pathname) const
virtual BOOLEAN | IsReady () const

Static Public Member Functions

static const WString & | GetId ()
Returns the storage device ID string.

Protected Member Functions

virtual DirectoryIteratorPtr | CreateDirectoryIterator (const Pathname &dir_pathname, const FileFilterPtr &filter) const
virtual FilePtr | CreateFileObject (const Pathname &pathname) const
FlashStorageDeviceImp ()
Creates a new flash storage device object.
virtual | ~FlashStorageDeviceImp ()

Static Protected Member Functions

static File::Error | ConvertFfsErrorToFileError (FfsError ffs_error)
Converts the errors delivered by the driver to Apoxi Filesystem errors.
static BOOLEAN | Setup ()

Friends

class | FlashDirectoryIteratorImp
class | FlashFileImp
class | FlsFile
class | RootFileSystem

Detailed Description

Storage device implementation for flash storage device.

Class FlashStorageDeviceImp implements the storage device interface for using the flash file system within the root file system.

Constructor & Destructor Documentation

FlashStorageDeviceImp::FlashStorageDeviceImp ( ) [protected]

Creates a new flash storage device object.

FlashStorageDeviceImp::~FlashStorageDeviceImp ( ) [protected, virtual]

Destroys this flash storage device and unregisters it from the root file system.

Member Function Documentation

File::Error FlashStorageDeviceImp::ConvertFfsErrorToFileError ( FfsError ffs_error ) [static, protected]

Converts the errors delivered by the driver to Apoxi Filesystem errors.

DirectoryIteratorPtr FlashStorageDeviceImp::CreateDirectoryIterator | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter
 | ) | const [protected, virtual]

Creates a new directory iterator object for the specified pathname.

Parameters:
dir_pathname | The pathname of the directory.
filter | The filter which selects the files the iterator shall return.
Returns:
A DirectoryIteratorPtr wrapping either a new directory iterator object or 0 if there is not enough memory left.

Implements StorageDevice.

FilePtr FlashStorageDeviceImp::CreateFileObject ( const Pathname & pathname ) const [protected, virtual]

Creates a new file object for the specified pathname.

Parameters:
pathname The pathname.
Returns:
A FilePtr wrapping either a new file object or 0 if there is not enough memory left.

Implements StorageDevice.

BOOLEAN FlashStorageDeviceImp::Exists ( const Pathname & pathname ) const [virtual]

Tells if pathname exists. If it exists it may either be a file or a directory.

Implements StorageDevice.

BOOLEAN FlashStorageDeviceImp::Format ( BOOLEAN quick = FALSE ) [virtual]

This method formats the actual storage device. It is only possible to format real devices. The root storage device cannot be formatted.

Returns:
The success of the operation.

Implements StorageDevice.

UINT8 FlashStorageDeviceImp::GetDefaultChunkSize ( ) const [virtual]

Returns the default chunk size for operating in chunk mode on files stored on this storage device.

See also:
File::GetChunkSize()

File::SetChunkSize()

Implements StorageDevice.

UINT32 FlashStorageDeviceImp::GetFreeVolumeSize ( ) const [virtual]

Returns the free volume size of the device in bytes.

Returns:
The free volume size of the device in bytes.

Implements StorageDevice.

const WString & FlashStorageDeviceImp::GetId ( ) [static]

Returns the storage device ID string.

WString FlashStorageDeviceImp::GetNativeDirectoryPathname ( const Pathname & pathname ) const [virtual]

Returns pathname in native directory name format. The native directory name format may differ from storage device to storage device.

Implements StorageDevice.

WString FlashStorageDeviceImp::GetNativeFilePathname ( const Pathname & pathname ) const [virtual]

Returns pathname in native file name format. The native file name format may differ from storage device to storage device.

Implements StorageDevice.

UINT32 FlashStorageDeviceImp::GetTotalVolumeSize ( ) const [virtual]

Returns the total volume size of the device in bytes.

Returns:
The total volume size of the device in bytes.

Implements StorageDevice.

UINT32 FlashStorageDeviceImp::GetUsedVolumeSize ( ) const [virtual]

Returns the used volume size of the device in bytes. Note that this size is usually larger than the sum of the sizes of all stored files, since meta information to control the directory structure is stored on the device, too.

Returns:
The used volume size of the device in bytes.

Implements StorageDevice.

BOOLEAN FlashStorageDeviceImp::IsDirectory ( const Pathname & pathname ) const [virtual]

Tells if pathname is a directory. This base implementation returns TRUE only for the root pathname, since every storage device is at least organized in a flat manner which we interpret as having a single root directory. The method is declared as abstract for when implementing a new storage device you can't forget to deal with this issue. If the derived storage device is organized in a flat manner, then the override of this abstract method might be a simple call to this base class implementation. If a derived class supports directories then implement this method accordingly.

Implements StorageDevice.

BOOLEAN FlashStorageDeviceImp::IsReady ( ) const [virtual]

Tells if the device is ready for being accessed.

Implements StorageDevice.

BOOLEAN FlashStorageDeviceImp::Setup ( ) [static, protected]

Sets up the storage device for usage. The method must be called before using the flash storage device. It can be called as many times as convenient, however, only the first call does the work. If there is a setup problem FALSE is returned.

Friends And Related Function Documentation

friend class FlashDirectoryIteratorImp [friend]

friend class FlashFileImp [friend]

friend class FlsFile [friend]

friend class RootFileSystem [friend]

Reimplemented from StorageDevice.

The documentation for this class was generated from the following files:
  • AddOns/AfsFfs/FlashStorageDeviceImp.hpp
  • AddOns/AfsFfs/FlashStorageDeviceImp.cpp
Generated on Wed Jan 25 01:15:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FlipMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FlipMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for FlipMsg:

[legend]
Collaboration diagram for FlipMsg:

[legend]

Public Types

enum | { ID = 205 }

Public Member Functions

virtual Message * | Clone () const
FlipMsg (BOOLEAN flip_open)
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsFlipOpen () const
virtual | ~FlipMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FlipMsg::FlipMsg ( BOOLEAN flip_open )

FlipMsg::~FlipMsg ( ) [virtual]

Member Function Documentation

Message * FlipMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & FlipMsg::GetMetaData ( ) const [virtual]

Implements Message.

BOOLEAN FlipMsg::IsFlipOpen ( ) const [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:15:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FlowLayout Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FlowLayout Class Reference
[GUI]

#include <Apoxi/Gui/FlowLayout.hpp>

Inheritance diagram for FlowLayout:

[legend]
Collaboration diagram for FlowLayout:

[legend]

Public Types

enum | { ID = 38 }
enum | Alignment { Start = 0, Middle = 1, End = 2 }

Public Member Functions

void | AddAlignInfo (Component &comp, Alignment align)
FlowLayout (Control *parent, BOOLEAN horizontal=TRUE)
FlowLayout ()
BOOLEAN | GetAlignInfo (const Component &comp, Alignment &align) const
void | Init (Control *parent, BOOLEAN horizontal=TRUE)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | RemoveAlignInfo (const Component &comp)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~FlowLayout ()

Protected Member Functions

virtual void | OnFocusNextControl ()
virtual void | OnFocusPreviousControl ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
virtual void | OnThemeChanged ()

Data Structures

struct | AlignInfo

Detailed Description

Allows to layout components in a horizontal or vertical flow. For each embedded component a layout information can be added. The layout information specifies whether the component should be aligned at the start, middle or end of the available area.

If the flow layout uses a horizontal flow, 'Start' is interpreted as 'Left' and 'End' means 'Right'. If the flow layout uses a vertical flow, 'Start' is interpreted as 'Top' and 'End' means 'Bottom'.

The documentation for this class was generated from the following files:
  • Gui/FlowLayout.hpp
  • Gui/FlowLayout.cpp
Generated on Wed Jan 25 01:15:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FlsFile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FlsFile Class Reference
[Flash File System support]

#include <Apoxi/Afs/Ffs/FlsFile.hpp>

Collaboration diagram for FlsFile:

[legend]

Public Member Functions

BOOLEAN | AssureInitialized (const CHAR *filename)
BOOLEAN | Close ()
BOOLEAN | Copy (const CHAR *dest_filename)
BOOLEAN | Create (const CHAR *filename, FfsFileType file_type, UINT32 size)
BOOLEAN | Create (const CHAR *filename, UINT32 size)
BOOLEAN | Create (FfsFileId id, FfsFileType file_type, UINT32 size)
BOOLEAN | CreateStreaming (const CHAR *filename)
BOOLEAN | Delete ()
FlsFile (FfsUserType user_id)
FlsFile ()
BOOLEAN | GetDrmAttrib (FfsDrmAttrib &attrib) const
BOOLEAN | GetFileSize (UINT32 &file_size) const
BOOLEAN | GetFileType (FfsFileType &file_type) const
BOOLEAN | GetHandle (FfsHandle &file_handle) const
FfsError | GetLastError () const
BOOLEAN | GetTimestamp (FfsTimeRecord &time_stamp) const
FfsUserType | GetUserId () const
To determine the user id.
BOOLEAN | IsInitialized () const
BOOLEAN | IsOpen () const
Tells if the file is open.
BOOLEAN | Open (const CHAR *filename, FfsFileType file_type)
BOOLEAN | Open (const CHAR *filename)
BOOLEAN | Open (FfsFileId id, FfsFileType file_type)
BOOLEAN | OpenStreaming (const CHAR *filename)
BOOLEAN | Read (void FFS_HUGE *dst, UINT32 offset, UINT32 max_no_bytes, UINT32 &bytes_read) const
BOOLEAN | Read (void FFS_HUGE *dst, UINT32 offset, UINT32 no_bytes) const
BOOLEAN | ReadStreaming (void HUGE *buffer, UINT32 count, UINT32 bytes_read)
BOOLEAN | ReadStreamingAsync (void HUGE *buffer, UINT32 count, void(callback_func)(File::Error result, UINT32 bytes_operated))
BOOLEAN | Rename (const CHAR *new_filename)
BOOLEAN | Rename (FfsFileId new_id)
BOOLEAN | Resize (UINT32 new_size)
BOOLEAN | SetDrmAttrib (const FfsDrmAttrib &attrib)
BOOLEAN | SetUserId (FfsUserType user_id)
BOOLEAN | Write (const void FFS_HUGE *src, UINT32 offset, UINT32 no_bytes)
BOOLEAN | WriteStreaming (const void HUGE *buffer, UINT32 count)
BOOLEAN | WriteStreamingAsync (const void HUGE *buffer, UINT32 count, void(callback_func)(File::Error result, UINT32 bytes_operated))
~FlsFile ()

Static Public Member Functions

static void | StreamingDriverReadCallback (FfsError result, void *client_arg)
static void | StreamingDriverWriteCallback (FfsError result, void *client_arg)

Detailed Description

FlsFile provides an easy to use interface for using the FFS. Please also refer to the class FfsHandler, which provides an object-oriented interface for achieving information-related data from the FFS. FlsFile itself is also built upon the interface of FfsHandler.

After creation the file doesn't need to be opened explicitly, and the FlsFile::Write() method can be called right afterwards, even several times consecutively. After data is written once, it is also possible to call the FlsFile::Read() method without closing and reopening the file, since the necessary open-modes are managed internally. However, the call of FlsFile::Close() has to be done after all operations are finished, so other processes can gain access to this file, too.

Since only the FlsFile::Open() and FlsFile::Create() methods take either an id or a filename as parameter, either of these methods has to be called before other methods can be called.

If, for instance, the deletion of a file which has neither been opened nor created is necessary, please use the class FfsHandler and the regarding methods.

The methods which extract the file type from the filename use the methods of class MimeTypeTable.

The following code fragments show some examples of the FlsFile interface. If working on host, you can easily observe the content of the file with a simple text editor.

This piece of code creates a file and writes something into it:

    FlsFile file;
    const CHAR *fname = "A";
    UINT32 filesize = 0;
    const CHAR src[] = "This text is written into the file.";

    // Create a text file, 10 bytes large.
    if (file.Create(fname, FfsFileTypeTxt, 10)) {
        // Check the filesize, must be 10.
        file.GetFileSize(filesize);

        // Write some text into the file. Notice that the filesize gets increased automatically.
        file.Write(src, 0, sizeof(src));

        // Check the filesize, must be sizeof(src).
        file.GetFileSize(filesize);

        // Close the file again for other processes can gain access.
        file.Close();
    } else {
        // Something went wrong, check what.
        FfsError result = file.GetLastError();
        // Deal with the error.
        // ...
    }

This piece of code opens a file and modifies some data:

    FlsFile file;
    const CHAR *fname = "A";
    INT offset = 0;
    const CHAR mod_src[] = "This text overwrites some data in the file.";

    // Open the file with the given filename.
    if (file.Open(fname)) {
        // Modify some part of the file.
        file.Write(mod_src, offset, sizeof(mod_src));

        // Close the file again for other processes can gain access.
        file.Close();
    } else {
        // Something went wrong, check what.
        FfsError result = file.GetLastError();
        // Deal with the error.
        // ...
    }

This piece of code appends some data to the file:

    FlsFile file;
    const CHAR *fname = "A";
    UINT32 filesize = 0;
    const CHAR app_src[] = "This text is appended to the file.";

    // Open the file with the given filename.
    if (file.Open(fname)) {
        // Append some data to the file using its filesize as offset.
        file.GetFileSize(filesize);
        file.Write(app_src, filesize, sizeof(app_src));

        // Close the file again for other processes can gain access.
        file.Close();
    } else {
        // Something went wrong, check what.
        FfsError result = file.GetLastError();
        // Deal with the error.
        // ...
    }

This piece of code opens a file and reads data from it:

    CHAR *dst = 0;
    FlsFile file;
    const CHAR *fname = "A";
    UINT32 filesize = 0;
    INT offset = 0;

    // Open the file with the given filename.
    if (file.Open(fname)) {
        file.GetFileSize(filesize);

        // Allocate memory to copy the file content into.
        dst = new CHAR[filesize];

        // Copy the whole data from the file into the buffer.
        file.Read(dst, offset, filesize);

        // Close the file again for other processes can gain access.
        file.Close();
    } else {
        // Something went wrong, check what.
        FfsError result = file.GetLastError();
        // Deal with the error.
        // ...
    }

Constructor & Destructor Documentation

FlsFile::FlsFile ( )

Default constructor. The user ID is set to FfsUserTypeMmi.

FlsFile::FlsFile ( FfsUserType user_id )

FlsFile::~FlsFile ( )

Member Function Documentation

BOOLEAN FlsFile::AssureInitialized ( const CHAR * filename )

Assures that after the method call the file will be initialized

BOOLEAN FlsFile::Close ( )

Closes the file and makes it available for other processes. Only possible if the file exists and was opened or created before.

BOOLEAN FlsFile::Copy ( const CHAR * dest_filename )

Copies the source file to the specified dest_filename. If the dest_filename is in a directory, then this directory must already exist.

BOOLEAN FlsFile::Create | ( | const CHAR * | filename,
 |  | FfsFileType | file_type,
 |  | UINT32 | size
 | ) |

Creates a file with the specified filename, file_type, and size. This method is supposed to be used if you want to store a file of a known file_type, but without the respective extension.

BOOLEAN FlsFile::Create | ( | const CHAR * | filename,
 |  | UINT32 | size
 | ) |

Creates a file with the specified filename and size. Only possible if the file does not yet exist and the filename contains the extension, since the file type is gathered by parsing the extension of the filename.

BOOLEAN FlsFile::Create | ( | FfsFileId | id,
 |  | FfsFileType | file_type,
 |  | UINT32 | size
 | ) |

Creates a file with the specified id, file_type, and size. Only possible if the file does not yet exist.

BOOLEAN FlsFile::CreateStreaming ( const CHAR * filename )

Creates a file with the specified filename, file_type, and size. This method is supposed to be used if you want to store a file of a known file_type, but without the respective extension. The file is opened for streaming automatically.

BOOLEAN FlsFile::Delete ( )

Deletes the file. Only possible if the file exists and is not open anymore.

BOOLEAN FlsFile::GetDrmAttrib ( FfsDrmAttrib & attrib ) const

Gets the digital rights management attribute via attrib. This method only succeeds if the file handle is initialized.

See also:
IsInitialized()

BOOLEAN FlsFile::GetFileSize ( UINT32 & file_size ) const

Copies the actual size into file_size. Only possible if the file exists and was opened before.

BOOLEAN FlsFile::GetFileType ( FfsFileType & file_type ) const

Copies the actual type into file_type. Only possible if the file exists and was opened before.

BOOLEAN FlsFile::GetHandle ( FfsHandle & file_handle ) const

Retrieves the file handle. The file handle can only be retrieved if the file is open.

FfsError FlsFile::GetLastError ( ) const [inline]

Returns the last occurred error. This method should be called after any method called before didn't return TRUE to determine the reason.

BOOLEAN FlsFile::GetTimestamp ( FfsTimeRecord & time_stamp ) const

Copies the actual timestamp into time_stamp. The timestamp contains the year, month, date, hour, and minute of either the creation or the last modification. Only possible if the file exists and was opened before.

FfsUserType FlsFile::GetUserId ( ) const [inline]

To determine the user id.

BOOLEAN FlsFile::IsInitialized ( ) const [inline]

Tells if the file has a name or an ID. The file gets assigned a name or an ID when it is opened or created.

BOOLEAN FlsFile::IsOpen ( void ) const [inline]

Tells if the file is open.

BOOLEAN FlsFile::Open | ( | const CHAR * | filename,
 |  | FfsFileType | file_type
 | ) |

Opens a file with the specified filename and file_type. Opening is only possible if the file exists.

BOOLEAN FlsFile::Open ( const CHAR * filename )

Opens a file with the specified filename. Opening is only possible if the file exists and the filename contains the extension, since the file type is gathered by parsing the extension of the filename.

BOOLEAN FlsFile::Open | ( | FfsFileId | id,
 |  | FfsFileType | file_type
 | ) |

Opens a file with the specified id and file_type. Opening is only possible if the file exists.

BOOLEAN FlsFile::OpenStreaming ( const CHAR * filename )

Opens a file with the specified filename and file_type for streaming. Opening is only possible if the file exists.

BOOLEAN FlsFile::Read | ( | void FFS_HUGE * | dst,
 |  | UINT32 | offset,
 |  | UINT32 | max_no_bytes,
 |  | UINT32 & | bytes_read
 | ) | const

Reads up to max_no_bytes bytes from this file starting at offset and copies them to the provided buffer dst. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_no_bytes due to reaching the end of file while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the file, i.e. parameter offset is greater than or equal to the size of the file, this method sets bytes_read to 0 and returns TRUE, signaling end of file!

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN FlsFile::Read | ( | void FFS_HUGE * | dst,
 |  | UINT32 | offset,
 |  | UINT32 | no_bytes
 | ) | const

Copies the data from the file into the specified dst. Only possible if the file exists and was opened before.

BOOLEAN FlsFile::ReadStreaming | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 | bytes_read
 | ) |

Reads up to count bytes from this file starting at the current offset and copies them to the provided buffer buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from count due to reaching the end of file while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the file, i.e. parameter offset is greater than or equal to the size of the file, this method sets bytes_read to 0 and returns TRUE, signaling end of file! The difference of the "Read" and the synchronous "ReadStreaming" is, that "ReadStreaming" runs with an higher priority and therefore may work faster.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN FlsFile::ReadStreamingAsync | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | void(callback_func)(File::Error result, UINT32 bytes_operated) |
 | ) |

Reads up to count bytes from this file starting at the current offset and copies them to the provided buffer buffer. This function returns immediately after his call and signalises by calling the callback_func, when the asynchronous operation is finished. The result of the operation can be retrieved by the parameters of the callback_func

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

BOOLEAN FlsFile::Rename ( const CHAR * new_filename )

Renames the file into new_filename. Only possible if the file exists and is not open anymore.

BOOLEAN FlsFile::Rename ( FfsFileId new_id )

Renames the file into new_id. Only possible if the file exists and is not open anymore.

BOOLEAN FlsFile::Resize ( UINT32 new_size )

Resizes the file to the specified new_size. Data beyond the new_size will be deleted. Since the filesize is increased automatically from the Write() methods, this method should only be called if the file should getting smaller. Only possible if the file exists and was opened before.

BOOLEAN FlsFile::SetDrmAttrib ( const FfsDrmAttrib & attrib )

Sets the digital rights management attribute to attrib. This method only succeeds if the file handle is initialized.

See also:
IsInitialized()

BOOLEAN FlsFile::SetUserId ( FfsUserType user_id )

To set/change the user id. Only possible if the file is closed. Be aware: The last error is not updated, in case of failing, just FALSE is returned!

void FlsFile::StreamingDriverReadCallback | ( | FfsError | result,
 |  | void * | client_arg
 | ) | [static]

void FlsFile::StreamingDriverWriteCallback | ( | FfsError | result,
 |  | void * | client_arg
 | ) | [static]

BOOLEAN FlsFile::Write | ( | const void FFS_HUGE * | src,
 |  | UINT32 | offset,
 |  | UINT32 | no_bytes
 | ) |

Copies the data from the specified src into the file. Only possible if the file exists and was opened before. If offset and no_bytes exceeds the actual filesize, the filesize will automatically increased.

BOOLEAN FlsFile::WriteStreaming | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

Copies the data from the specified src into the file. Only possible if the file exists and was opened before. If offset and no_bytes exceeds the actual filesize, the filesize will automatically increased. The difference of the "Write" and the synchronous "WriteStreaming" is, that "WriteStreaming" runs with an higher priority and therefore may work faster.

BOOLEAN FlsFile::WriteStreamingAsync | ( | const void HUGE * | buffer,
 |  | UINT32 | count,
 |  | void(callback_func)(File::Error result, UINT32 bytes_operated) |
 | ) |

Copies the data from the specified src into the file. Only possible if the file exists and was opened before. If offset and no_bytes exceeds the actual filesize, the filesize will automatically increased. This asynchronous method returns immediately after his call and signalises the end of the write operation by calling the callback_func.

The documentation for this class was generated from the following files:
  • Afs/Ffs/FlsFile.hpp
  • Afs/Ffs/FlsFile.cpp
Generated on Wed Jan 25 01:15:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioApplication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FmRadioApplication Class Reference

#include <Applications/FmRadio/FmRadioApplication.hpp>

Collaboration diagram for FmRadioApplication:

[legend]

Public Types

enum | RadioFmState { RadioFmOff, RadioFmOn, RadioFmOnMinimized, RadioFmToRestart }

Public Member Functions

void | CloseMinimizedRadio (void)
FmRadioSettingsProvider * | GetFmRadioSettingsProv (void)
FmRadioStationsProvider * | GetFmRadioStationsProv (void)
FmRadioWindow * | GetFmRadioWin (void)
RadioFmState | GetRadioOn (void)
void | SetRadioOn (RadioFmState State)
virtual | ~FmRadioApplication ()

Static Public Member Functions

static FmRadioApplication * | GetInstance ()

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)
virtual void | OnStartup ()

Member Enumeration Documentation

enum FmRadioApplication::RadioFmState

Enumerator:
RadioFmOff
RadioFmOn
RadioFmOnMinimized
RadioFmToRestart

Constructor & Destructor Documentation

FmRadioApplication::~FmRadioApplication ( ) [virtual]

Member Function Documentation

void FmRadioApplication::CloseMinimizedRadio ( void ) [inline]

FmRadioSettingsProvider* FmRadioApplication::GetFmRadioSettingsProv ( void ) [inline]

FmRadioStationsProvider* FmRadioApplication::GetFmRadioStationsProv ( void ) [inline]

FmRadioWindow* FmRadioApplication::GetFmRadioWin ( void ) [inline]

FmRadioApplication * FmRadioApplication::GetInstance ( ) [static]

RadioFmState FmRadioApplication::GetRadioOn ( void ) [inline]

void FmRadioApplication::OnClose ( ) [protected, virtual]

BOOLEAN FmRadioApplication::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN FmRadioApplication::OnMessage ( const Message & msg ) [protected, virtual]

void FmRadioApplication::OnOpen ( ) [protected, virtual]

BOOLEAN FmRadioApplication::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [protected, virtual]

void FmRadioApplication::OnStartup ( ) [protected, virtual]

void FmRadioApplication::SetRadioOn ( RadioFmState State ) [inline]

The documentation for this class was generated from the following files:
  • Applications/FmRadio/FmRadioApplication.hpp
  • Applications/FmRadio/FmRadioApplication.cpp
Generated on Wed Jan 25 01:15:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioEditWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FmRadioEditWin Class Reference

#include <Applications/FmRadio/FmRadioEditWin.hpp>

Collaboration diagram for FmRadioEditWin:

[legend]

Public Member Functions

FmRadioEditWin ()
void | Init (INT BandLim)
~FmRadioEditWin ()

Protected Member Functions

BOOLEAN | OnCancel ()
BOOLEAN | OnConfirm ()
void | OnLayoutClient ()

Constructor & Destructor Documentation

FmRadioEditWin::FmRadioEditWin ( )

FmRadioEditWin::~FmRadioEditWin ( )

Member Function Documentation

void FmRadioEditWin::Init ( INT BandLim )

BOOLEAN FmRadioEditWin::OnCancel ( ) [protected]

BOOLEAN FmRadioEditWin::OnConfirm ( ) [protected]

void FmRadioEditWin::OnLayoutClient ( ) [protected]

The documentation for this class was generated from the following files:
  • Applications/FmRadio/FmRadioEditWin.hpp
  • Applications/FmRadio/FmRadioEditWin.cpp
Generated on Wed Jan 25 01:15:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioSelectStrongerFreq Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FmRadioSelectStrongerFreq Class Reference

#include <Applications/FmRadio/FmRadioSelectStrongerFreq.hpp>

Inheritance diagram for FmRadioSelectStrongerFreq:

[legend]
Collaboration diagram for FmRadioSelectStrongerFreq:

[legend]

Public Member Functions

FmRadioSelectStrongerFreq ()
void | Init (Provider *fmradio_stat_prov)
~FmRadioSelectStrongerFreq ()

Protected Member Functions

BOOLEAN | OnCancel ()
BOOLEAN | OnConfirm ()
void | OnOpen ()

Constructor & Destructor Documentation

FmRadioSelectStrongerFreq::FmRadioSelectStrongerFreq ( )

FmRadioSelectStrongerFreq::~FmRadioSelectStrongerFreq ( )

Member Function Documentation

void FmRadioSelectStrongerFreq::Init ( Provider * fmradio_stat_prov )

BOOLEAN FmRadioSelectStrongerFreq::OnCancel ( ) [protected, virtual]

Reimplemented from AtlWindow.

BOOLEAN FmRadioSelectStrongerFreq::OnConfirm ( ) [protected, virtual]

Reimplemented from AtlWindow.

void FmRadioSelectStrongerFreq::OnOpen ( ) [protected, virtual]

See also:
Control::OnOpen

Reimplemented from AtlItemListWindow.

The documentation for this class was generated from the following files:
  • Applications/FmRadio/FmRadioSelectStrongerFreq.hpp
  • Applications/FmRadio/FmRadioSelectStrongerFreq.cpp
Generated on Wed Jan 25 01:15:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioSettingsProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FmRadioSettingsProvider Class Reference

#include <Applications/FmRadio/FmRadioSettingsProvider.hpp>

Inheritance diagram for FmRadioSettingsProvider:

[legend]
Collaboration diagram for FmRadioSettingsProvider:

[legend]

Public Member Functions

virtual BOOLEAN | CommitRow (INT row=0)
Commit updates done in a row.
FmRadioSettingsProvider ()
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items em>SetDataItem writes data items to an internal buffer.
virtual INT | GetProviderId () const
Returns the provider id.
void | Init ()
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
virtual void | RestoreFactorySettings ()
virtual BOOLEAN | SelectRow (INT row=0)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual | ~FmRadioSettingsProvider ()

Constructor & Destructor Documentation

FmRadioSettingsProvider::FmRadioSettingsProvider ( )

FmRadioSettingsProvider::~FmRadioSettingsProvider ( ) [virtual]

Member Function Documentation

BOOLEAN FmRadioSettingsProvider::CommitRow ( INT row = 0 ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN FmRadioSettingsProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items em>SetDataItem writes data items to an internal buffer.

Implements Provider.

INT FmRadioSettingsProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void FmRadioSettingsProvider::Init ( )

INT FmRadioSettingsProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

void FmRadioSettingsProvider::RestoreFactorySettings ( ) [virtual]

Implements SettingsProvider.

BOOLEAN FmRadioSettingsProvider::SelectRow ( INT row = 0 ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN FmRadioSettingsProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Applications/FmRadio/FmRadioSettingsProvider.hpp
  • Applications/FmRadio/FmRadioSettingsProvider.cpp
Generated on Wed Jan 25 01:15:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioSettingsRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FmRadioSettingsRecord Class Reference

#include <Applications/FmRadio/FmRadioSettingsRecord.hpp>

Inheritance diagram for FmRadioSettingsRecord:

[legend]
Collaboration diagram for FmRadioSettingsRecord:

[legend]

Public Member Functions

FmRadioSettingsRecord (UINT8 radio_last_volume, UINT32 radio_last_freq)
FmRatioSettingsRecord ()
virtual const UINT8 * | GetData ()
virtual INT | GetPersistentSize ()
UINT32 | GetRadioLastFreq ()
UINT8 | GetRadioLastVolume ()
virtual void | SetData (const UINT8 *data)
void | SetDefault ()
void | SetRadioLastFreq (UINT32 radio_last_freq)
void | SetRadioLastVolume (UINT8 radio_last_volume)

Data Fields

FmRadioSettingsRecord::Persist m_data

Data Structures

struct | Persist

Constructor & Destructor Documentation

FmRadioSettingsRecord::FmRadioSettingsRecord | ( | UINT8 | radio_last_volume,
 |  | UINT32 | radio_last_freq
 | ) |

Member Function Documentation

FmRadioSettingsRecord::FmRatioSettingsRecord ( )

const UINT8 * FmRadioSettingsRecord::GetData ( ) [virtual]

Implements Record.

INT FmRadioSettingsRecord::GetPersistentSize ( ) [virtual]

Implements Record.

UINT32 FmRadioSettingsRecord::GetRadioLastFreq ( ) [inline]

UINT8 FmRadioSettingsRecord::GetRadioLastVolume ( ) [inline]

void FmRadioSettingsRecord::SetData ( const UINT8 * data ) [virtual]

Implements Record.

void FmRadioSettingsRecord::SetDefault ( )

void FmRadioSettingsRecord::SetRadioLastFreq ( UINT32 radio_last_freq ) [inline]

void FmRadioSettingsRecord::SetRadioLastVolume ( UINT8 radio_last_volume ) [inline]

Field Documentation

struct FmRadioSettingsRecord::Persist FmRadioSettingsRecord::m_data

The documentation for this class was generated from the following files:
  • Applications/FmRadio/FmRadioSettingsRecord.hpp
  • Applications/FmRadio/FmRadioSettingsRecord.cpp
Generated on Wed Jan 25 01:15:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioSettingsRecord::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
FmRadioSettingsRecord::Persist

FmRadioSettingsRecord::Persist Struct Reference

#include <Applications/FmRadio/FmRadioSettingsRecord.hpp>

Data Fields

UINT32 | radio_last_freq
UINT8 | radio_last_volume

Field Documentation

UINT32 FmRadioSettingsRecord::Persist::radio_last_freq

UINT8 FmRadioSettingsRecord::Persist::radio_last_volume

The documentation for this struct was generated from the following file:
  • Applications/FmRadio/FmRadioSettingsRecord.hpp
Generated on Wed Jan 25 01:15:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioStationsProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FmRadioStationsProvider Class Reference

#include <Applications/FmRadio/FmRadioStationsProvider.hpp>

Inheritance diagram for FmRadioStationsProvider:

[legend]
Collaboration diagram for FmRadioStationsProvider:

[legend]

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
FmRadioStationsProvider ()
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items em>SetDataItem writes data items to an internal buffer.
virtual INT | GetProviderId () const
Returns the provider id.
void | Init ()
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
virtual void | RestoreFactorySettings ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~FmRadioStationsProvider ()

Constructor & Destructor Documentation

FmRadioStationsProvider::FmRadioStationsProvider ( )

FmRadioStationsProvider::~FmRadioStationsProvider ( ) [virtual]

Member Function Documentation

BOOLEAN FmRadioStationsProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN FmRadioStationsProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items em>SetDataItem writes data items to an internal buffer.

Implements Provider.

INT FmRadioStationsProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void FmRadioStationsProvider::Init ( )

INT FmRadioStationsProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

void FmRadioStationsProvider::RestoreFactorySettings ( ) [virtual]

Implements SettingsProvider.

INT FmRadioStationsProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Reimplemented from SettingsProvider.

BOOLEAN FmRadioStationsProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN FmRadioStationsProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN FmRadioStationsProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from SettingsProvider.

The documentation for this class was generated from the following files:
  • Applications/FmRadio/FmRadioStationsProvider.hpp
  • Applications/FmRadio/FmRadioStationsProvider.cpp
Generated on Wed Jan 25 01:15:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioStationsRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FmRadioStationsRecord Class Reference

#include <Applications/FmRadio/FmRadioStationsRecord.hpp>

Inheritance diagram for FmRadioStationsRecord:

[legend]
Collaboration diagram for FmRadioStationsRecord:

[legend]

Public Member Functions

FmRadioStationsRecord (UINT32 radio_freq=0L)
virtual const UINT8 * | GetData ()
virtual INT | GetPersistentSize ()
UINT32 | GetRadioFreq ()
virtual void | SetData (const UINT8 *data)
void | SetRadioFreq (UINT32 radio_freq)

Data Fields

FmRadioStationsRecord::Persist m_data

Data Structures

struct | Persist

Constructor & Destructor Documentation

FmRadioStationsRecord::FmRadioStationsRecord ( UINT32 radio_freq = 0L )

Member Function Documentation

const UINT8 * FmRadioStationsRecord::GetData ( ) [virtual]

Implements Record.

INT FmRadioStationsRecord::GetPersistentSize ( ) [virtual]

Implements Record.

UINT32 FmRadioStationsRecord::GetRadioFreq ( ) [inline]

void FmRadioStationsRecord::SetData ( const UINT8 * data ) [virtual]

Implements Record.

void FmRadioStationsRecord::SetRadioFreq ( UINT32 radio_freq ) [inline]

Field Documentation

struct FmRadioStationsRecord::Persist FmRadioStationsRecord::m_data

The documentation for this class was generated from the following files:
  • Applications/FmRadio/FmRadioStationsRecord.hpp
  • Applications/FmRadio/FmRadioStationsRecord.cpp
Generated on Wed Jan 25 01:16:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioStationsRecord::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
FmRadioStationsRecord::Persist

FmRadioStationsRecord::Persist Struct Reference

#include <Applications/FmRadio/FmRadioStationsRecord.hpp>

Data Fields

UINT32 radio_freq

Field Documentation

UINT32 FmRadioStationsRecord::Persist::radio_freq

The documentation for this struct was generated from the following file:
  • Applications/FmRadio/FmRadioStationsRecord.hpp
Generated on Wed Jan 25 01:16:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FmRadioWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FmRadioWindow Class Reference

#include <Applications/FmRadio/FmRadioWindow.hpp>

Collaboration diagram for FmRadioWindow:

[legend]

Public Member Functions

void | CloseMinimized (void)
FmRadioWindow ()
void | HandleRadioAudioNotification (void)
void | Init ()
void | SetFrequency (UINT32 edited_freq)
void | UpdateRadioDisplay (void)
~FmRadioWindow ()

Protected Member Functions

void | OnClose ()
void | OnLayoutClient ()
BOOLEAN | OnMessage (const Message &msg)
void | OnOpen ()
BOOLEAN | SaveFrequency (KeyCode key_code)
void | SetFrequency (KeyCode key_code)
void | SwitchOff ()

Constructor & Destructor Documentation

FmRadioWindow::FmRadioWindow ( )

FmRadioWindow::~FmRadioWindow ( )

Member Function Documentation

void FmRadioWindow::CloseMinimized ( void )

void FmRadioWindow::HandleRadioAudioNotification ( void )

void FmRadioWindow::Init ( )

void FmRadioWindow::OnClose ( ) [protected]

void FmRadioWindow::OnLayoutClient ( ) [protected]

BOOLEAN FmRadioWindow::OnMessage ( const Message & msg ) [protected]

void FmRadioWindow::OnOpen ( ) [protected]

BOOLEAN FmRadioWindow::SaveFrequency ( KeyCode key_code ) [protected]

void FmRadioWindow::SetFrequency ( KeyCode key_code ) [protected]

void FmRadioWindow::SetFrequency ( UINT32 edited_freq )

void FmRadioWindow::SwitchOff ( ) [protected]

void FmRadioWindow::UpdateRadioDisplay ( void )

The documentation for this class was generated from the following files:
  • Applications/FmRadio/FmRadioWindow.hpp
  • Applications/FmRadio/FmRadioWindow.cpp
Generated on Wed Jan 25 01:16:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FocusNextControlMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FocusNextControlMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for FocusNextControlMsg:

[legend]
Collaboration diagram for FocusNextControlMsg:

[legend]

Public Types

enum | { ID = 1100 }

Public Member Functions

virtual Message * | Clone () const
FocusNextControlMsg (Control *control)
virtual const MsgMetaData & | GetMetaData () const
virtual | ~FocusNextControlMsg ()

Detailed Description

This message is sent from a control when the focus should change to the next control.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FocusNextControlMsg::FocusNextControlMsg ( Control * control )

FocusNextControlMsg::~FocusNextControlMsg ( ) [virtual]

Member Function Documentation

Message * FocusNextControlMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & FocusNextControlMsg::GetMetaData ( ) const [virtual]

Implements ControlMsg.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:16:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FocusObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FocusObtainer Class Reference
[Kernel]

#include <Apoxi/Kernel/System.hpp>

Inheritance diagram for FocusObtainer:

[legend]
Collaboration diagram for FocusObtainer:

[legend]

Public Member Functions

FocusObtainer ()

Friends

class System

Constructor & Destructor Documentation

FocusObtainer::FocusObtainer ( )

Friends And Related Function Documentation

friend class System [friend]

The documentation for this class was generated from the following files:
  • Kernel/System.hpp
  • Kernel/System.cpp
Generated on Wed Jan 25 01:16:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FocusPreviousControlMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FocusPreviousControlMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for FocusPreviousControlMsg:

[legend]
Collaboration diagram for FocusPreviousControlMsg:

[legend]

Public Types

enum | { ID = 1101 }

Public Member Functions

virtual Message * | Clone () const
FocusPreviousControlMsg (Control *control)
virtual const MsgMetaData & | GetMetaData () const
virtual | ~FocusPreviousControlMsg ()

Detailed Description

This message is sent from a control when the focus should change to the previous control.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FocusPreviousControlMsg::FocusPreviousControlMsg ( Control * control )

FocusPreviousControlMsg::~FocusPreviousControlMsg ( ) [virtual]

Member Function Documentation

Message * FocusPreviousControlMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & FocusPreviousControlMsg::GetMetaData ( ) const [virtual]

Implements ControlMsg.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:16:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FoggyPanelView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FoggyPanelView Class Reference

#include <Apoxi/GlobalThemes/FoggyTheme/FoggyPanelView.hpp>

Inheritance diagram for FoggyPanelView:

[legend]
Collaboration diagram for FoggyPanelView:

[legend]

Public Member Functions

virtual void | Update (const Theme &theme)
virtual | ~FoggyPanelView ()

Protected Member Functions

virtual void | DrawPanel (const Panel &panel, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

FoggyPanelView::~FoggyPanelView ( ) [virtual]

Member Function Documentation

void FoggyPanelView::DrawPanel | ( | const Panel & | panel,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PanelView.

void FoggyPanelView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • GlobalThemes/FoggyTheme/FoggyPanelView.hpp
  • GlobalThemes/FoggyTheme/FoggyPanelView.cpp
Generated on Wed Jan 25 01:16:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FoggyPositionIndicatorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FoggyPositionIndicatorView Class Reference

#include <Apoxi/GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp>

Inheritance diagram for FoggyPositionIndicatorView:

[legend]
Collaboration diagram for FoggyPositionIndicatorView:

[legend]

Public Member Functions

FoggyPositionIndicatorView (XYDIM size)
FoggyPositionIndicatorView ()
virtual | ~FoggyPositionIndicatorView ()

Protected Member Functions

virtual void | DrawPositionIndicator (const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

FoggyPositionIndicatorView::FoggyPositionIndicatorView ( )

FoggyPositionIndicatorView::FoggyPositionIndicatorView ( XYDIM size ) [explicit]

virtual FoggyPositionIndicatorView::~FoggyPositionIndicatorView ( ) [inline, virtual]

Member Function Documentation

void FoggyPositionIndicatorView::DrawPositionIndicator | ( | const PositionIndicator & | pos_ind,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a position indicator described by the model. Must be implemented in the corresponding theme view.

Parameters:
pos_ind | Position-Indicator which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements PositionIndicatorView.

The documentation for this class was generated from the following files:
  • GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.hpp
  • GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.cpp
Generated on Wed Jan 25 01:16:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FoggyPushButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FoggyPushButtonView Class Reference

#include <Apoxi/GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp>

Inheritance diagram for FoggyPushButtonView:

[legend]
Collaboration diagram for FoggyPushButtonView:

[legend]

Public Member Functions

FoggyPushButtonView (XYDIM Foggy_height)
FoggyPushButtonView ()
virtual void | Update (const Theme &theme)
virtual | ~FoggyPushButtonView ()

Protected Member Functions

virtual void | DrawPushButton (const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

FoggyPushButtonView::FoggyPushButtonView ( )

FoggyPushButtonView::FoggyPushButtonView ( XYDIM Foggy_height ) [explicit]

virtual FoggyPushButtonView::~FoggyPushButtonView ( ) [inline, virtual]

Member Function Documentation

void FoggyPushButtonView::DrawPushButton | ( | const PushButton & | push_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PushButtonView.

void FoggyPushButtonView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • GlobalThemes/FoggyTheme/FoggyPushButtonView.hpp
  • GlobalThemes/FoggyTheme/FoggyPushButtonView.cpp
Generated on Wed Jan 25 01:16:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FoggySoftkeyBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FoggySoftkeyBarView Class Reference

#include <Apoxi/Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp>

Inheritance diagram for FoggySoftkeyBarView:

[legend]
Collaboration diagram for FoggySoftkeyBarView:

[legend]

Public Member Functions

virtual | ~FoggySoftkeyBarView ()
virtual | ~FoggySoftkeyBarView ()

Protected Member Functions

virtual void | DrawSoftkeyBar (const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawSoftkeyBar (const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

virtual FoggySoftkeyBarView::~FoggySoftkeyBarView ( ) [inline, virtual]

virtual FoggySoftkeyBarView::~FoggySoftkeyBarView ( ) [inline, virtual]

Member Function Documentation

virtual void FoggySoftkeyBarView::DrawSoftkeyBar | ( | const SoftkeyBar & | softkey_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the Softkey-Bar. Must be implemented in the corresponding theme view.

Parameters:
softkey_bar | Softkey-Bar which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements SoftkeyBarView.

void FoggySoftkeyBarView::DrawSoftkeyBar | ( | const SoftkeyBar & | softkey_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the Softkey-Bar. Must be implemented in the corresponding theme view.

Parameters:
softkey_bar | Softkey-Bar which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements SoftkeyBarView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp
  • GlobalThemes/FoggyTheme/FoggySoftkeyBarView.hpp
  • Compat/GlobalThemes/FoggyTheme/FoggySoftkeyBarView.cpp
  • GlobalThemes/FoggyTheme/FoggySoftkeyBarView.cpp
Generated on Wed Jan 25 01:16:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FoggyTheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FoggyTheme Class Reference

Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

#include <Apoxi/Compat/GlobalThemes/FoggyTheme/FoggyTheme.hpp>

Inheritance diagram for FoggyTheme:

[legend]
Collaboration diagram for FoggyTheme:

[legend]

Public Member Functions

FoggyTheme ()
virtual const BitmapRes * | GetBitmap (BitmapResId id) const
virtual const CheckBoxListView * | GetCheckBoxListView () const
virtual const CheckBoxView * | GetCheckBoxView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const WCHAR * | GetName () const
Returns the name of the theme. Per default 0 is returned.
virtual const PanelView * | GetPanelView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const RadioButtonListView * | GetRadioButtonListView () const
virtual const RadioButtonView * | GetRadioButtonView () const
virtual const SoftkeyBarView * | GetSoftkeyBarView () const
virtual const SystemColor | GetSystemColor (SystemColorId id) const
virtual const ColorTable * | GetSystemColorTable () const
virtual const TabButtonView * | GetTabButtonView () const
virtual const TabControlView * | GetTabControlView () const
virtual const TextListView * | GetTextListView () const
virtual const WindowFrameView * | GetWindowFrameView () const
virtual const WindowFrameView * | GetWindowFrameView () const
virtual void | Update ()
virtual void | Update ()
virtual | ~FoggyTheme ()
virtual | ~FoggyTheme ()

Static Public Member Functions

static const Theme & | GetInstance ()

Detailed Description

Obsolete theme - replaced by themes in Apoxi/GlobalThemes.

Constructor & Destructor Documentation

FoggyTheme::FoggyTheme ( )

FoggyTheme::~FoggyTheme ( ) [virtual]

virtual FoggyTheme::~FoggyTheme ( ) [virtual]

Member Function Documentation

const BitmapRes * FoggyTheme::GetBitmap ( BitmapResId id ) const [virtual]

const CheckBoxListView * FoggyTheme::GetCheckBoxListView ( ) const [virtual]

const CheckBoxView * FoggyTheme::GetCheckBoxView ( ) const [virtual]

virtual const ControlFrameView* FoggyTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const ControlFrameView * FoggyTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const Theme & FoggyTheme::GetInstance ( ) [static]

const WCHAR * FoggyTheme::GetName ( ) const [virtual]

Returns the name of the theme. Per default 0 is returned.

Reimplemented from Theme.

const PanelView * FoggyTheme::GetPanelView ( ) const [virtual]

Returns a pointer to a panel view, which is used to draw an instance of the class Panel. The panel usually is aligned at the bottom of the desktop and shows the softkeys.

Reimplemented from Theme.

virtual const PositionIndicatorView* FoggyTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

const PositionIndicatorView * FoggyTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

virtual const ProgressBarView* FoggyTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

const ProgressBarView * FoggyTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

virtual const PushButtonView* FoggyTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const PushButtonView * FoggyTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const RadioButtonListView * FoggyTheme::GetRadioButtonListView ( ) const [virtual]

const RadioButtonView * FoggyTheme::GetRadioButtonView ( ) const [virtual]

const SoftkeyBarView * FoggyTheme::GetSoftkeyBarView ( ) const [virtual]

const SystemColor FoggyTheme::GetSystemColor ( SystemColorId id ) const [virtual]

Returns a color-value of the system-color with the id id specified by the system-color-table. This method must not be overwritten by derived themes, when GetSystemColorTable has been overwritten. To stay backward-compatible with older versions of APOXI, 0 is returned if no system-color-table is provided.

Reimplemented from Theme.

const ColorTable * FoggyTheme::GetSystemColorTable ( ) const [virtual]

Returns a pointer to the color-table of the system-colors. This method should be overwritten by derived themes providing a pointer to a custom color-table. To stay backward-compatible with older versions of APOXI, 0 is returned in the default-implementation.

Reimplemented from Theme.

const TabButtonView * FoggyTheme::GetTabButtonView ( ) const [virtual]

Returns a pointer to a tab button view, which is used to draw an instance of the class TabButton. A tab button is embedded inside a tab control.

Reimplemented from Theme.

const TabControlView * FoggyTheme::GetTabControlView ( ) const [virtual]

Returns a pointer to a tab control view, which is used to draw an instance of the class TabControl.

Reimplemented from Theme.

const TextListView * FoggyTheme::GetTextListView ( ) const [virtual]

virtual const WindowFrameView* FoggyTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

const WindowFrameView * FoggyTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

virtual void FoggyTheme::Update ( ) [virtual]

Converts all colors given by the system-color-table to system-colors and invokes View::Update(this) for every View which is part of the theme. Also the fonts are updated which may be specified by ThemeConfig::GetFontId().

Reimplemented from Theme.

void FoggyTheme::Update ( ) [virtual]

Converts all colors given by the system-color-table to system-colors and invokes View::Update(this) for every View which is part of the theme. Also the fonts are updated which may be specified by ThemeConfig::GetFontId().

Reimplemented from Theme.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/FoggyTheme/FoggyTheme.hpp
  • GlobalThemes/FoggyTheme/FoggyTheme.hpp
  • Compat/GlobalThemes/FoggyTheme/FoggyTheme.cpp
  • GlobalThemes/FoggyTheme/FoggyTheme.cpp
Generated on Wed Jan 25 01:16:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FoggyWindowFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FoggyWindowFrameView Class Reference

#include <Apoxi/GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp>

Inheritance diagram for FoggyWindowFrameView:

[legend]
Collaboration diagram for FoggyWindowFrameView:

[legend]

Public Member Functions

FoggyWindowFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size, XYDIM title_height, XYDIM softkey_bar_height)
FoggyWindowFrameView ()
virtual void | Update (const Theme &theme)
virtual | ~FoggyWindowFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawWindowExtensions (const Window &window, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

FoggyWindowFrameView::FoggyWindowFrameView ( )

FoggyWindowFrameView::FoggyWindowFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size,
 |  | XYDIM | title_height,
 |  | XYDIM | softkey_bar_height
 | ) |

FoggyWindowFrameView::~FoggyWindowFrameView ( ) [virtual]

Member Function Documentation

void FoggyWindowFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

void FoggyWindowFrameView::DrawWindowExtensions | ( | const Window & | window,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

See also:
ControlFrameView::DrawWindowExenstions

Implements WindowFrameView.

void FoggyWindowFrameView::Update ( const Theme & theme ) [virtual]

Reimplemented from View.

The documentation for this class was generated from the following files:
  • GlobalThemes/FoggyTheme/FoggyWindowFrameView.hpp
  • GlobalThemes/FoggyTheme/FoggyWindowFrameView.cpp
Generated on Wed Jan 25 01:16:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Font Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Font Class Reference
[GUI]

#include <Apoxi/Gui/Font.hpp>

Inheritance diagram for Font:

[legend]

Public Types

enum SystemFontId {
Client = 0, ActiveTitle, InactiveTitle, Softkeys,
Menu, TextEditor, SystemFontIdCount
}

Public Member Functions

Font ()
virtual INT | GetBaseline () const =0
Returns the baseline of a font beginning from the top.
virtual INT | GetGapToNextChar (WCHAR character=0) const =0
Returns the gap to the character after character.
virtual void | GetGlyph (WCHAR chr, TextAttr text_attr, GlyphPtr glyph) const =0
virtual INT | GetHeight () const =0
Returns the height of a font.
virtual const WCHAR * | GetName () const =0
INT | GetTextWidth (const WCHAR *text, TextAttr text_attr, INT from=0, INT n_chars=-1, BOOLEAN include_gap=FALSE) const
BOOLEAN | operator!= (const Font &font) const
BOOLEAN | operator== (const Font &font) const
virtual BOOLEAN | SupportsTextAttr (TextAttr text_attr) const =0
virtual | ~Font ()

Detailed Description

Describes all necessary data for a font, like the name, height, baseline, gap between characters, look of the characters etc.

Member Enumeration Documentation

enum Font::SystemFontId

Every theme offers fonts for components and parts of components. These fonts can easily accessed by the system-font-id: const Font& font = System::GetFont(Font::Client)

Enumerator:
Client | Font for the client-area of a control.
ActiveTitle | Font for the window-title, when the window has the focus.
InactiveTitle | Font for the window-title, when the window has not the focus.
Softkeys | Font used by the softkeys of a window.
Menu | Font used for menus.
TextEditor | Font used by editors using the text-editor-document.
SystemFontIdCount

Constructor & Destructor Documentation

Font::Font ( )

Font::~Font ( ) [virtual]

Member Function Documentation

virtual INT Font::GetBaseline ( ) const [pure virtual]

Returns the baseline of a font beginning from the top.

Implemented in FontEntry, and RomFont.

virtual INT Font::GetGapToNextChar ( WCHAR character = 0 ) const [pure virtual]

Returns the gap to the character after character.

Implemented in FontEntry, and RomFont.

virtual void Font::GetGlyph | ( | WCHAR | chr,
 |  | TextAttr | text_attr,
 |  | GlyphPtr | glyph
 | ) | const [pure virtual]

Returns the glyph of the character chr into the output-parameter glyph.

Implemented in FontEntry, and RomFont.

virtual INT Font::GetHeight ( ) const [pure virtual]

Returns the height of a font.

Implemented in FontEntry, and RomFont.

virtual const WCHAR* Font::GetName ( ) const [pure virtual]

Returns:
Name of the font.

Implemented in FontEntry, and RomFont.

INT Font::GetTextWidth | ( | const WCHAR * | text,
 |  | TextAttr | text_attr,
 |  | INT | from = 0,
 |  | INT | n_chars = -1,
 |  | BOOLEAN | include_gap = FALSE
 | ) | const

Parameters:
text | Pointer to the text.
from | Start-index for counting (index starts at 0).
n_chars | Number of characters to count. 0 means counting all characters.
include_gap | If set to TRUE, the gap of the last character will be added.
Returns:
Width of the text in pixels.

BOOLEAN Font::operator!= ( const Font & font ) const [inline]

BOOLEAN Font::operator== ( const Font & font ) const

virtual BOOLEAN Font::SupportsTextAttr ( TextAttr text_attr ) const [pure virtual]

Returns TRUE, if the font supports the text-attribute text_attr.

See also:
TextFormat

Implemented in FontEntry, and RomFont.

The documentation for this class was generated from the following files:
  • Gui/Font.hpp
  • Gui/Font.cpp
Generated on Wed Jan 25 01:16:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FontConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FontConfig Class Reference
[Config]

#include <FontConfig.hpp>

Static Public Member Functions

static const Font & | GetFont (INT idx)
static INT | GetFontCount ()
static ThaiTextRenderer::ThaiFontHint * | GetThaiFontHints (const Font &font)

Detailed Description

Allows accessing the configuration for fonts. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static const Font& FontConfig::GetFont ( INT idx ) [static]

Returns:
Reference to the font idx.

static INT FontConfig::GetFontCount ( ) [static]

Returns:
Number of available fonts.

static ThaiTextRenderer::ThaiFontHint* FontConfig::GetThaiFontHints ( const Font & font ) [static]

Returns the hinting table for bitmap fonts when rendering Thai glyphs. 0 is returned if Thai is not supported.

The documentation for this class was generated from the following file:
  • FontConfig.hpp
Generated on Wed Jan 25 01:16:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FontEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FontEntry Class Reference

#include <Apoxi/Gui/FontEntry.hpp>

Inheritance diagram for FontEntry:

[legend]
Collaboration diagram for FontEntry:

[legend]

Public Member Functions

FontEntry (const FontData *data, const GlyphData *glyphs)
virtual INT | GetBaseline () const
const WCHAR * | GetFontFamilyName () const
virtual INT | GetGapToNextChar (WCHAR character=0) const
virtual void | GetGlyph (WCHAR chr, TextAttr text_attr, GlyphPtr glyph) const
virtual INT | GetHeight () const
EntryId | GetId () const
virtual const WCHAR * | GetName () const
UINT16 | GetNumGlyphs () const
BOOLEAN | SupportsStyle (WCHAR chr, TextAttr text_attr) const
virtual BOOLEAN | SupportsTextAttr (TextAttr text_attr) const
BOOLEAN | SupportsUnicodeRange (WCHAR from, WCHAR to) const
virtual | ~FontEntry ()

Protected Member Functions

UINT8 * | GetGlyphStartPos (WCHAR chr) const

Detailed Description

A FontEntry encapsulates the data of one font. This data consists of the metadata for the font and the glyphdata.

Constructor & Destructor Documentation

FontEntry::FontEntry | ( | const FontData * | data,
 |  | const GlyphData * | glyphs
 | ) |

Constructor for FontEntry. Initializes the FontEntry object with the data given in parameter FontData and GlyphData.

Parameters:
data | Pointer to the common data of the font like height, name,...
glyphs | Pointer to the glyph table of the font.

FontEntry::~FontEntry ( ) [virtual]

Desturctor for FontEntry.

Member Function Documentation

INT FontEntry::GetBaseline ( ) const [virtual]

Returns the baseline of the font.

Returns:
Baseline of the font.

Implements Font.

const WCHAR * FontEntry::GetFontFamilyName ( ) const

Returns the family name of the font.

Returns:
Font family the font belongs to.

INT FontEntry::GetGapToNextChar ( WCHAR character = 0 ) const [virtual]

Returns the gap to next character.

Parameters:
character character for which the gap shall be returned. Gap is the same for each character (not yet implemented).
Returns:
returns the gap to the next character

Implements Font.

void FontEntry::GetGlyph | ( | WCHAR | chr,
 |  | TextAttr | text_attr,
 |  | GlyphPtr | glyph
 | ) | const [virtual]

Fills the parameter glyph with the data of the glyph contained in the font entry.

Parameters:
chr | Character to search for.
text_attr@see | TextFormat::TextAttr
glyph | Glyph pointer where the data is written to.
Returns:
Result of the GetGlyph method. TODO: Kommentar

Implements Font.

UINT8 * FontEntry::GetGlyphStartPos ( WCHAR chr ) const [protected]

INT FontEntry::GetHeight ( ) const [virtual]

Returns the height of the glyphs of the font.

Returns:
Height of the font.

Implements Font.

EntryId FontEntry::GetId ( ) const [inline]

Returns the id of the font.

Returns:
Id of the font.

const WCHAR * FontEntry::GetName ( ) const [virtual]

Returns the name of the font.

Returns:
Name of the font like Arial, Times New Roman,...

Implements Font.

UINT16 FontEntry::GetNumGlyphs ( ) const

Returns the number of glyphs the font object contains.

Returns:
Number of glyphs contained in the glyph table of the font.

BOOLEAN FontEntry::SupportsStyle | ( | WCHAR | chr,
 |  | TextAttr | text_attr
 | ) | const

Returns TRUE if the character given in parameter chr supports the style given in parameter text_attr.

Parameters:
chr | Charakter that should be displayable in the given style
text_attr | Style the charakter should be displayable with.
Returns:
TRUE if the character supports the style.

BOOLEAN FontEntry::SupportsTextAttr ( TextAttr text_attr ) const [virtual]

See also:
Font::SupportsTextAttr

Implements Font.

BOOLEAN FontEntry::SupportsUnicodeRange | ( | WCHAR | from,
 |  | WCHAR | to
 | ) | const

Returns true if the font object contains EACH character within the range given by the parameters from and to.

Parameters:
from | Character to start reading from.
to | Character where to stop reading.
Returns:
TRUE if each of the characters within the given range is contained in the string table, otherwise FALSE.

The documentation for this class was generated from the following files:
  • Gui/FontEntry.hpp
  • Gui/FontEntry.cpp
Generated on Wed Jan 25 01:16:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FontManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FontManager Class Reference

#include <Apoxi/Gui/FontManager.hpp>

Static Public Member Functions

static BOOLEAN | CanDisplay (WCHAR chr, INT index=m_active_font_index)
static INT | GetActiveFontIndex ()
static UINT8 | GetBaseline (INT index=m_active_font_index)
static const FontEntry * | GetFont (const WCHAR *name, UINT8 height)
static const FontEntry * | GetFont (INT index)
static const WCHAR * | GetFontFamilyName (INT index=m_active_font_index)
static const WCHAR * | GetFontName (INT index=m_active_font_index)
static UINT8 | GetGapToNextChar (WCHAR chr=0, INT index=m_active_font_index)
static BOOLEAN | GetGlyph (WCHAR chr, Glyph &glyph, TextAttr text_attr=TextFormat::Normal, INT font_index=m_active_font_index)
static BOOLEAN | GetGlyphs (const WCHAR *chr, Glyph *glyphs, INT count, TextAttr text_attr=TextFormat::Normal, INT font_index=m_active_font_index)
static UINT8 | GetHeight (INT index=m_active_font_index)
static EntryId | GetIdOfFont (const WCHAR *name, UINT8 height)
static INT | GetIndexOfFont (const WCHAR *name, UINT8 height)
static UINT16 | GetNumberOfFonts ()
static INT | GetNumGlyphs (INT index=m_active_font_index)
static BOOLEAN | SetActiveFont (INT index)
static void | SetUseStaticFonts (BOOLEAN value)
static BOOLEAN | SupportsStyle (WCHAR chr, TextAttr text_attr, INT index=m_active_font_index)
static BOOLEAN | SupportsUnicodeRange (WCHAR from, WCHAR to, INT index=m_active_font_index)
static BOOLEAN | UseStaticFonts ()

Detailed Description

The FontManager is able to switch the fonts displayed on the screen and return glyphs of these fonts. Furthermore it provides functionality for retrieving information about the different fonts of a font pack.

Member Function Documentation

BOOLEAN FontManager::CanDisplay | ( | WCHAR | chr,
 |  | INT | index = m_active_font_index
 | ) | [static]

Returns TRUE if the character of parameter chr is available in the font identified by the parameter index.

Parameters:
chr | Character of that shall be displayed.
index | Index of the font of which the character shall be displayed. Default index is the index of the active font.
Returns:
TRUE if the character with of the given font (index) can be displayed otherwise FALSE.

INT FontManager::GetActiveFontIndex ( ) [static]

Returns the index of the active font.

Returns:
Index of the active font.

UINT8 FontManager::GetBaseline ( INT index = m_active_font_index ) [static]

Returns the baseline of the font at positon index.

Parameters:
index Index of the font. Default value is the index of the active font.
Returns:
Baseline of the font.

const FontEntry * FontManager::GetFont | ( | const WCHAR * | name,
 |  | UINT8 | height
 | ) | [static]

Returns the FontEntry object identified by the parameter name.

Parameters:
name | Name of the font that shall be returned.
height | Height of the font that shall be returned.
Returns:
Constant FontEntry object identified by the name and the height.

const FontEntry * FontManager::GetFont ( INT index ) [static]

Returns the FontEntry object at position index.

Parameters:
index Index of the font that shall be returned.
Returns:
Constant FontEntry object identified by the index. If specified object is not found, 0 is returned.

const WCHAR * FontManager::GetFontFamilyName ( INT index = m_active_font_index ) [static]

Returns the name of the font family of the font at position index.

Parameters:
index Index of the font. Default value is the index of the active font.
Returns:
Name of the font family of the font at position index.

const WCHAR * FontManager::GetFontName ( INT index = m_active_font_index ) [static]

Returns the name of the font at position index.

Parameters:
index Index of the font. Default value is the index of the active font.
Returns:
Name of the font at position index.

UINT8 FontManager::GetGapToNextChar | ( | WCHAR | chr = 0,
 |  | INT | index = m_active_font_index
 | ) | [static]

Returns the gap to the next character.

BOOLEAN FontManager::GetGlyph | ( | WCHAR | chr,
 |  | Glyph & | glyph,
 |  | TextAttr | text_attr = TextFormat::Normal,
 |  | INT | font_index = m_active_font_index
 | ) | [static]

Returns a pointer to a glyph structure for the character chr. The style of the glyph can be identified by the parameter text_attr.

Parameters:
chr | Character value of which the glyph data shall be returned.
glyph | Glyph instance to fill with data.
text_attr | Style the character should be of. Default value is TextFormat::Normal.
font_index | Index of the font the character shall be read from. Default value is the index of the active font.
Returns:
TRUE if the glyph contains the data of the character handed over in parameter chr.

BOOLEAN FontManager::GetGlyphs | ( | const WCHAR * | chr,
 |  | Glyph * | glyphs,
 |  | INT | count,
 |  | TextAttr | text_attr = TextFormat::Normal,
 |  | INT | font_index = m_active_font_index
 | ) | [static]

Writes the glyphs for a given string (chr) into the array provided by the caller.

Parameters:
chr | Character array containing the values the given glyphs array shall contain.
glyphs | Glyph array containing glyph objects to be filled with data.
count | Number of glyphs.
text_attr | Style the character should be of. Default value is TextFormat::Normal.
font_index | Index of the font from which the glyphs shall be read.
Returns:
TRUE if the glyph array contains the data of the characters handed over in parameter chr.

UINT8 FontManager::GetHeight ( INT index = m_active_font_index ) [static]

Returns the height of the font identified by the parameter index.

Parameters:
index Index of the font of which the height shall be returned. Default index is the index of the active font.
Returns:
Height of the font identified by font index in the parameter.

EntryId FontManager::GetIdOfFont | ( | const WCHAR * | name,
 |  | UINT8 | height
 | ) | [static]

Returns the font id of the font with the name handed over as parameter.

Parameters:
name | Name of the font of which the id shall be retrieved.
height | Height of the font.
Returns:
Id of the font identified by the name.

INT FontManager::GetIndexOfFont | ( | const WCHAR * | name,
 |  | UINT8 | height
 | ) | [static]

Returns the index of the font with the name given as parameter.

Parameters:
name | Name of the font of which the index shall be retrieved.
height | Height of the font that shall be returned.
Returns:
Index of the font identified by the name.

UINT16 FontManager::GetNumberOfFonts ( ) [static]

Returns the number of fonts that are available in the FontPack.

INT FontManager::GetNumGlyphs ( INT index = m_active_font_index ) [static]

Returns the number of glyphs that are available in the font at position index.

Parameters:
index Index of the font. Default value is the index of the active font.
Returns:
Number of glyphs available in the active font.

BOOLEAN FontManager::SetActiveFont ( INT index ) [static]

Sets the font at position index as active font. Getting information about the font by calling the getter methods of the FontManager uses this font if no parameter for the font index is provided.

Parameters:
index Index of the font that shall be set as active font.
Returns:
TRUE if the font identified by the parameter index is set as active font, otherwise FALSE.

void FontManager::SetUseStaticFonts ( BOOLEAN value ) [static]

BOOLEAN FontManager::SupportsStyle | ( | WCHAR | chr,
 |  | TextAttr | text_attr,
 |  | INT | index = m_active_font_index
 | ) | [static]

Validates if the font at position index supports the given style.

Parameters:
chr | Character that shall support the style.
text_attr | Style the character should be of. Default value is TextFormat::Normal.
Returns:
TRUE if the character chr of the active font supports the TextAttribute text_attr, FALSE otherwise.

BOOLEAN FontManager::SupportsUnicodeRange | ( | WCHAR | from,
 |  | WCHAR | to,
 |  | INT | index = m_active_font_index
 | ) | [static]

Returns TRUE if the font specified by parameter index provides the characters within the range specified by the parameters from and to.

Parameters:
from | Character to start reading from.
to | Character where to stop reading.
index | Index of the font.
Returns:
TRUE if every character within the given range is available, FALSE otherwise.

BOOLEAN FontManager::UseStaticFonts ( ) [static]

The documentation for this class was generated from the following files:
  • Gui/FontManager.hpp
  • Gui/FontManager.cpp
Generated on Wed Jan 25 01:16:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FontPack Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FontPack Class Reference

#include <Apoxi/Gui/FontPack.hpp>

Inheritance diagram for FontPack:

[legend]
Collaboration diagram for FontPack:

[legend]

Public Types

typedef DataPack | Base

Public Member Functions

FontPack (UINT8 *data)
const FontEntry * | GetFont (INT index) const
const FontEntry ** | GetFonts () const
virtual | ~FontPack ()

Friends

class | BasicPackConnector

Detailed Description

An object of FontPack encapsulates the data of the font pack that is available in the customization pack and provides functionality for the FontPackConnector to access this data.

Member Typedef Documentation

typedef DataPack FontPack::Base

Constructor & Destructor Documentation

FontPack::FontPack ( UINT8 * data )

Constructor for FontPack. Initializes the FontPack with the data handed over as parameter.

Parameters:
data Pointer to the starting address of the data of the FontPack in the customization pack.

FontPack::~FontPack ( ) [virtual]

Destructor for FontPack.

Member Function Documentation

const FontEntry * FontPack::GetFont ( INT index ) const

Returns the FontEntry of the FontPack at position index.

Parameters:
index | Index of the font.
size | Size of the font.
Returns:
FontEntry object identified by the parameters index and size.

const FontEntry ** FontPack::GetFonts ( ) const

Returns an array of all FontEntries in the customization pack.

Returns:
Array containing all FontEntries available in the FontPack.

Friends And Related Function Documentation

friend class BasicPackConnector [friend]

Reimplemented from DataPack.

The documentation for this class was generated from the following files:
  • Gui/FontPack.hpp
  • Gui/FontPack.cpp
Generated on Wed Jan 25 01:16:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FontPackConnector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FontPackConnector Class Reference

#include <Apoxi/Gui/FontPackConnector.hpp>

Collaboration diagram for FontPackConnector:

[legend]

Static Public Member Functions

static BOOLEAN | ContainsFont (FontId id)
static INT | GetActiveFontIndex ()
static const FontEntry * | GetFont (INT index)
static BOOLEAN | GetFontNames (const WCHAR **font_names, INT size)
static INT | GetNumberOfFonts ()
static void | Init ()
static BOOLEAN | IsFontPackAvailable ()
static BOOLEAN | SetActiveFont (const INT index)

Detailed Description

The FontPackConnector provides functionality for accessing the data of a font pack.

Member Function Documentation

static BOOLEAN FontPackConnector::ContainsFont ( FontId id ) [static]

Returns true if the font pack contains a font with the id provided in parameter id.

Returns:
TRUE if font with the given id is available.

INT FontPackConnector::GetActiveFontIndex ( ) [static]

Returns the index of the active font.

const FontEntry * FontPackConnector::GetFont ( INT index ) [static]

Returns the font at position index.

Parameters:
index | Index of the font.
size | Size of the font.
Returns:
Constant FontEntry object identified by index and size.

BOOLEAN FontPackConnector::GetFontNames | ( | const WCHAR ** | font_names,
 |  | INT | size
 | ) | [static]

Writes the names of the fonts that are available in the font pack into the array provided by the caller.

Parameters:
font_names Array to which the names of the fonts are written.

INT FontPackConnector::GetNumberOfFonts ( ) [static]

Returns the number of fonts that are available in the font pack.

Returns:
Number of fonts available in the FontPack.

void FontPackConnector::Init ( ) [static]

Initilizes the FontPackConnector with the font pack available in the customization pack.

BOOLEAN FontPackConnector::IsFontPackAvailable ( ) [static]

Returns true if a font pack is available in the customization pack.

Returns:
TRUE if a FontPack is available.

BOOLEAN FontPackConnector::SetActiveFont ( const INT index ) [static]

Sets the font at position idx as active font.

Parameters:
idx | Index of the font.
size | Size of the font.
Returns:
TRUE if the active font has been successfully set.

The documentation for this class was generated from the following files:
  • Gui/FontPackConnector.hpp
  • Gui/FontPackConnector.cpp
Generated on Wed Jan 25 01:16:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FontRes Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FontRes Struct Reference
[GUI]

#include <Apoxi/Gui/Font.hpp>

Collaboration diagram for FontRes:

[legend]

Data Fields

XYDIM | baseline
const GlyphIndexTabPtr | bold_glyph_index_tab
XYDIM | gap_to_next_char
XYDIM | height
Glyph invalid_glyph
const GlyphIndexTabPtr | italic_bold_glyph_index_tab
const GlyphIndexTabPtr | italic_glyph_index_tab
const WCHAR * | name
const GlyphIndexTabPtr | normal_glyph_index_tab

Field Documentation

XYDIM FontRes::baseline

const GlyphIndexTabPtr FontRes::bold_glyph_index_tab

XYDIM FontRes::gap_to_next_char

XYDIM FontRes::height

Glyph FontRes::invalid_glyph

const GlyphIndexTabPtr FontRes::italic_bold_glyph_index_tab

const GlyphIndexTabPtr FontRes::italic_glyph_index_tab

const WCHAR* FontRes::name

const GlyphIndexTabPtr FontRes::normal_glyph_index_tab

The documentation for this struct was generated from the following file:
  • Gui/Font.hpp
Generated on Wed Jan 25 01:16:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ForwardedCallIncomingMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ForwardedCallIncomingMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ForwardedCallIncomingMsg:

[legend]
Collaboration diagram for ForwardedCallIncomingMsg:

[legend]

Public Types

enum | { ID = 18529 }

Public Member Functions

virtual Message * | Clone () const
ForwardedCallIncomingMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code)
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
virtual | ~ForwardedCallIncomingMsg ()

Detailed Description

ForwardedCallIncomingMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ForwardedCallIncomingMsg::ForwardedCallIncomingMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code
 | ) |

ForwardedCallIncomingMsg::~ForwardedCallIncomingMsg ( ) [virtual]

Member Function Documentation

Message * ForwardedCallIncomingMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & ForwardedCallIncomingMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& ForwardedCallIncomingMsg::GetSsCode ( ) const [inline]

const Tipd& ForwardedCallIncomingMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:16:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ForwardingFeature Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ForwardingFeature Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for ForwardingFeature:

[legend]

Data Fields

SsGroup basic_service
PhoneNumber forward_to_number
INT | noreply_timer
UINT8 | options
SsStatus ss_status

Field Documentation

SsGroup ForwardingFeature::basic_service

PhoneNumber ForwardingFeature::forward_to_number

INT ForwardingFeature::noreply_timer

UINT8 ForwardingFeature::options

SsStatus ForwardingFeature::ss_status

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:16:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ForwardingFeatureList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ForwardingFeatureList Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for ForwardingFeatureList:

[legend]

Data Fields

ForwardingFeature data [c_max_no_basic_service_groups]

Field Documentation

ForwardingFeature ForwardingFeatureList::data[c_max_no_basic_service_groups]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:16:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ForwardingInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ForwardingInfo Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for ForwardingInfo:

[legend]

Data Fields

ForwardingFeatureList feature_list
INT feature_list_size
SsCode sc

Field Documentation

ForwardingFeatureList ForwardingInfo::feature_list

INT ForwardingInfo::feature_list_size

SsCode ForwardingInfo::sc

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:16:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ForwardingInfoReceivedArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ForwardingInfoReceivedArg Struct Reference
[APOXI Stack Control]

Contains the data related ForwardingInfoReceivedMsg. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for ForwardingInfoReceivedArg:

[legend]

Data Fields

ForwardingInfo forwarding_info
This type passes information, received in a ForwardingInfo type.
SsOperationCode operation_code
The respective call independent supplementary operation code.

Detailed Description

Contains the data related ForwardingInfoReceivedMsg.

Field Documentation

ForwardingInfo ForwardingInfoReceivedArg::forwarding_info

This type passes information, received in a ForwardingInfo type.

SsOperationCode ForwardingInfoReceivedArg::operation_code

The respective call independent supplementary operation code.

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 01:16:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ForwardingInfoReceivedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ForwardingInfoReceivedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for ForwardingInfoReceivedMsg:

[legend]
Collaboration diagram for ForwardingInfoReceivedMsg:

[legend]

Public Types

enum | { ID = 18500 }

Public Member Functions

virtual Message * | Clone () const
ForwardingInfoReceivedMsg (ExecutionContext *context, const ForwardingInfoReceivedArg &arg)
const ForwardingInfoReceivedArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const ForwardingInfoReceivedArg &arg)
virtual | ~ForwardingInfoReceivedMsg ()

Detailed Description

ForwardingInfoReceivedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ForwardingInfoReceivedMsg::ForwardingInfoReceivedMsg | ( | ExecutionContext * | context,
 |  | const ForwardingInfoReceivedArg & | arg
 | ) |

ForwardingInfoReceivedMsg::~ForwardingInfoReceivedMsg ( ) [virtual]

Member Function Documentation

Message * ForwardingInfoReceivedMsg::Clone ( ) const [virtual]

Implements Message.

const ForwardingInfoReceivedArg& ForwardingInfoReceivedMsg::GetArg ( ) const [inline]

const MsgMetaData & ForwardingInfoReceivedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void ForwardingInfoReceivedMsg::SetArg ( const ForwardingInfoReceivedArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:16:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ForwardingSsAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ForwardingSsAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for ForwardingSsAction:

[legend]
Collaboration diagram for ForwardingSsAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
ForwardingSsAction ()
virtual InputActionType | GetActionType () const
Returns the type of the action.
InputParser::BasicServiceMmiCode | GetBasicServiceMmiCode () const
Returns the basic service group.
const WString & | GetConditionTimer () const
Returns the no reply condition timer.
const WString & | GetPhoneNumber () const
Returns the directory number.
InputParser::SsCode | GetSsCode () const
Returns the ss code.
InputParser::SsProcedure | GetSsProcedure () const
Returns the procedure type.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual | ~ForwardingSsAction ()

Detailed Description

ForwardingSsAction analyzes if the input string has the meaning of activation, deactivation or interrogation of Call Offering Services as defined in 3GPP TS 22.082. Execute has to be overwritten to implement the sending of the SS string.

Constructor & Destructor Documentation

ForwardingSsAction::ForwardingSsAction ( )

ForwardingSsAction::~ForwardingSsAction ( ) [virtual]

Member Function Documentation

InputAction * ForwardingSsAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType ForwardingSsAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

InputParser::BasicServiceMmiCode ForwardingSsAction::GetBasicServiceMmiCode ( ) const [inline]

Returns the basic service group.

const WString& ForwardingSsAction::GetConditionTimer ( ) const [inline]

Returns the no reply condition timer.

const WString& ForwardingSsAction::GetPhoneNumber ( ) const [inline]

Returns the directory number.

InputParser::SsCode ForwardingSsAction::GetSsCode ( ) const [inline]

Returns the ss code.

InputParser::SsProcedure ForwardingSsAction::GetSsProcedure ( ) const [inline]

Returns the procedure type.

BOOLEAN ForwardingSsAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:16:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Fota Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Fota Class Reference
[Devices]

#include <Apoxi/Devices/BP30/Fota.hpp>

Inheritance diagram for Fota:

[legend]
Collaboration diagram for Fota:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual | ~Fota ()

Static Public Member Functions

static ControlArg | Control (INT command, ControlArg arg)
static UINT32 | GetMetaDataCapacity ()
static INT | InitiateFirmwareUpdate (BOOLEAN force=TRUE)
static INT | ReadMetaData (UINT32 offset, void *buffer, UINT32 size)
static INT | WriteMetaData (UINT32 offset, const void *buffer, UINT32 size)

Friends

class | ShutDown

Detailed Description

Fota is the APOXI device abstraction interface for Firmware-update-Over-The-Air functionality. When Sibley flash is used, the data written must be aligned with the region size. Some regions can be used for control data (flags etc.) while other regions for data objects (e.g. bitmaps) which cannot be rewritten before a block-erase has been performed. The function GetMetaDataCapacity can be used to retrieve the region size.

Constructor & Destructor Documentation

Fota::~Fota ( ) [virtual]

Member Function Documentation

static ControlArg Fota::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) | [static]

See also:
AbstractDevice::Control

UINT32 Fota::GetMetaDataCapacity ( ) [static]

Get the FLASH region size. This function is only available in Normal Mode.

Returns:
The region size in bytes. If the flash doesn't have regions, 0 will be returned.

const WCHAR * Fota::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

INT Fota::InitiateFirmwareUpdate ( BOOLEAN force = TRUE ) [static]

This method has to be called to reboot system from normal mode and initiate firmware update in the software update mode. The system is rebooted without clearing the RAM content.

Parameters:
force The parameter forces the system to reboot (normally applications can prevent the system from rebooting - e.g. when a download is active).
Returns:
Returns 0 if success, error values TBD.

INT Fota::ReadMetaData | ( | UINT32 | offset,
 |  | void * | buffer,
 |  | UINT32 | size
 | ) | [static]

Read data from reserved FOTA Meta Data area. This function is only available in Normal Mode.

Parameters:
offset | Address offset in the FOTA MetaData area where to start reading.
buffer | Pointer to location where to copy the data to.
size | The number of bytes to read.
Returns:
Returns 0 if success, error values TBD.

INT Fota::WriteMetaData | ( | UINT32 | offset,
 |  | const void * | buffer,
 |  | UINT32 | size
 | ) | [static]

Write data to reserved FOTA Meta Data area. This function is only available in Normal Mode.

Parameters:
offset | Address offset in the FOTA MetaData area where to start writing.
buffer | Pointer to the RAM location where to copy the data from.
size | The number of bytes to write.
Returns:
Returns 0 if success, error values TBD.

Friends And Related Function Documentation

friend class ShutDown [friend]

The documentation for this class was generated from the following files:
  • Devices/BP30/Fota.hpp
  • Devices/FotaInterface.hpp
  • Devices/MPE/Fota.hpp
  • Devices/MPEU/Fota.hpp
  • Devices/SGold/Fota.hpp
  • Devices/Win32/Fota.hpp
  • Devices/BP30/Fota.cpp
  • Devices/MPE/Fota.cpp
  • Devices/MPEU/Fota.cpp
  • Devices/SGold/Fota.cpp
  • Devices/Win32/Fota.cpp
Generated on Wed Jan 25 01:16:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Fraction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Fraction Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Fraction.hpp>

Public Member Functions

Fraction (INT32 num, INT32 denom=1)
Constructor.
Fraction (const Fraction &frac)
Constructor.
Fraction ()
Constructor.
WString | GetDecimalString (INT digits=0) const
GetDecimalString.
INT32 | GetDenominator () const
GetDenominator.
WString | GetFractionString () const
GetFractionString.
INT32 | GetNumerator () const
GetNumerator.
BOOLEAN | IsValid () const
IsValid.
Fraction | operator * (const Fraction &fraction) const
operator *
Fraction & | operator *= (const Fraction &frac)
operator *=
Fraction | operator+ (const Fraction &fraction) const
operator +
Fraction & | operator+= (const Fraction &frac)
operator +=
Fraction | operator- (const Fraction &fraction) const
operator -
Fraction & | operator-= (const Fraction &frac)
operator -=
Fraction | operator/ (const Fraction &fraction) const
operator /
Fraction & | operator/= (const Fraction &frac)
operator /=
Fraction Reciprocal ()
returns Reciprocal value
void | Set (INT32 num, INT32 denom=1)
Set.
BOOLEAN | SetDecimalString (const WCHAR *str)
SetDecimalString.
void | SetDenominator (INT32 denom)
SetDenominator.
BOOLEAN | SetFractionString (const WCHAR *str)
SetFractionString.
void | SetNumerator (INT32 num)
SetNumerator.
void | Simplify ()
Simplify simplifies the Fraction.
virtual | ~Fraction ()

Constructor & Destructor Documentation

Fraction::Fraction ( )

Constructor.

Fraction::Fraction ( const Fraction & frac )

Constructor.

Parameters:
Fraction to initialize

Fraction::Fraction | ( | INT32 | num,
 |  | INT32 | denom = 1
 | ) |

Constructor.

Parameters:
num,: numerator and
denom,: denominator to initialize

Fraction::~Fraction ( ) [virtual]

Member Function Documentation

WString Fraction::GetDecimalString ( INT digits = 0 ) const

GetDecimalString.

Returns:
Fraction as a decimal number in a string

INT32 Fraction::GetDenominator ( ) const [inline]

GetDenominator.

Returns:
denominator

WString Fraction::GetFractionString ( ) const

GetFractionString.

Returns:
Fraction as fraction number in a string

INT32 Fraction::GetNumerator ( ) const [inline]

GetNumerator.

Returns:
numerator

BOOLEAN Fraction::IsValid ( ) const

IsValid.

Returns:
TRUE if Fraction is valid, otherwise FALSE

Fraction Fraction::operator * ( const Fraction & fraction ) const

operator *

Fraction & Fraction::operator *= ( const Fraction & frac )

operator *=

Fraction Fraction::operator+ ( const Fraction & fraction ) const

operator +

Fraction & Fraction::operator+= ( const Fraction & frac )

operator +=

Fraction Fraction::operator- ( const Fraction & fraction ) const

operator -

Fraction & Fraction::operator-= ( const Fraction & frac )

operator -=

Fraction Fraction::operator/ ( const Fraction & fraction ) const

operator /

Fraction & Fraction::operator/= ( const Fraction & frac )

operator /=

Fraction Fraction::Reciprocal ( )

returns Reciprocal value

void Fraction::Set | ( | INT32 | num,
 |  | INT32 | denom = 1
 | ) |

Set.

Parameters:
numerator | and
denominator | to initialize

BOOLEAN Fraction::SetDecimalString ( const WCHAR * str )

SetDecimalString.

Parameters:
decimal number in a string, e.g. "12,345" to set Fraction

void Fraction::SetDenominator ( INT32 denom ) [inline]

SetDenominator.

Parameters:
denom,: set as denomiator

BOOLEAN Fraction::SetFractionString ( const WCHAR * str )

SetFractionString.

Parameters:
fraction number in a string, e.g. "9/10" to set Fraction

void Fraction::SetNumerator ( INT32 num ) [inline]

SetNumerator.

Parameters:
num,: set as numerator

void Fraction::Simplify ( )

Simplify simplifies the Fraction.

The documentation for this class was generated from the following files:
  • Atl/Fraction.hpp
  • Atl/Fraction.cpp
Generated on Wed Jan 25 01:16:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FrameDc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FrameDc Class Reference
[GUI]

Device context used for drawing the frame of a control. More...

#include <Apoxi/Gui/FrameDc.hpp>

Inheritance diagram for FrameDc:

[legend]
Collaboration diagram for FrameDc:

[legend]

Public Member Functions

virtual void | AdjustBoundingRect ()
FrameDc (Control *control)
FrameDc ()

Protected Member Functions

void | Update (const Rect &abs_rect)

Detailed Description

Device context used for drawing the frame of a control.

Constructor & Destructor Documentation

FrameDc::FrameDc ( )

FrameDc::FrameDc ( Control * control )

Member Function Documentation

void FrameDc::AdjustBoundingRect ( ) [virtual]

See also:
DeviceContext::AdjustBoundingRect()

Reimplemented from DeviceContext.

void FrameDc::Update ( const Rect & abs_rect ) [protected]

See also:
DeviceContext::Update

Reimplemented from ControlDc.

The documentation for this class was generated from the following files:
  • Gui/FrameDc.hpp
  • Gui/FrameDc.cpp
Generated on Wed Jan 25 01:16:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FromStackMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FromStackMsg Class Reference

#include <Apoxi/Apc/Message.hpp>

Inheritance diagram for FromStackMsg:

[legend]
Collaboration diagram for FromStackMsg:

[legend]

Public Types

enum | { ID = 15000 }

Public Member Functions

virtual Message * | Clone () const
FromStackMsg (const FromStackMsg &msg)
FromStackMsg (StackMsgArgument *arg=0)
StackMsgArgument * | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
virtual FromStackMsg & | operator= (const FromStackMsg &msg)
virtual | ~FromStackMsg ()

Detailed Description

FromStackMsg is a specialiced message which is meant to carry information FROM the protocol stack to APOXI.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FromStackMsg::FromStackMsg ( StackMsgArgument * arg = 0 )

FromStackMsg::FromStackMsg ( const FromStackMsg & msg )

FromStackMsg::~FromStackMsg ( ) [virtual]

Member Function Documentation

Message * FromStackMsg::Clone ( ) const [virtual]

Implements Message.

Reimplemented in BtAvrcpNotificationMessage, BtAvrcpOperationServiceMessage, BtHfNotificationMessage, BtHsNotificationMessage, BtObexServerNotificationMessage, and BtObexClientNotificationMessage.

StackMsgArgument* FromStackMsg::GetArg ( ) const [inline]

const MsgMetaData & FromStackMsg::GetMetaData ( ) const [virtual]

Implements Message.

Reimplemented in BtAvrcpNotificationMessage, BtAvrcpOperationServiceMessage, BtHfNotificationMessage, BtHsNotificationMessage, BtObexServerNotificationMessage, and BtObexClientNotificationMessage.

FromStackMsg & FromStackMsg::operator= ( const FromStackMsg & msg ) [virtual]

Reimplemented in BtAvrcpNotificationMessage, BtAvrcpOperationServiceMessage, BtHfNotificationMessage, BtHsNotificationMessage, BtObexServerNotificationMessage, and BtObexClientNotificationMessage.

The documentation for this class was generated from the following files:
  • Apc/Message.hpp
  • Apc/MessageImpl.cpp
Generated on Wed Jan 25 01:16:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: fs_registered_info_type Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

fs_registered_info_type Struct Reference

#include <Apoxi/AddOns/AfsFat/FatSim.hpp>

Data Fields

void * | client_arg
fs_device_type device
char | drive_letter
BOOL indication
BOOL media_present
void(* | notification_func )(fs_device_type device, BOOL media_present, void *client_arg)
BOOL removable

Field Documentation

void* fs_registered_info_type::client_arg

fs_device_type fs_registered_info_type::device

char fs_registered_info_type::drive_letter

BOOL fs_registered_info_type::indication

BOOL fs_registered_info_type::media_present

void(* fs_registered_info_type::notification_func)(fs_device_type device, BOOL media_present, void *client_arg)

BOOL fs_registered_info_type::removable

The documentation for this struct was generated from the following file:
  • AddOns/AfsFat/FatSim.hpp
Generated on Wed Jan 25 01:16:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: fs_stat Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

fs_stat Struct Reference

#include <Apoxi/AddOns/AfsFat/FatSim.hpp>

Collaboration diagram for fs_stat:

[legend]

Data Fields

ushort fattribute
ushort padding
DATESTR st_atime
slong st_blksize
slong st_blocks
DATESTR st_ctime
sshort st_dev
sshort st_ino
ulong st_mode
DATESTR st_mtime
sshort st_nlink
sshort st_rdev
ulong st_size

Field Documentation

ushort fs_stat::fattribute

ushort fs_stat::padding

DATESTR fs_stat::st_atime

slong fs_stat::st_blksize

slong fs_stat::st_blocks

DATESTR fs_stat::st_ctime

sshort fs_stat::st_dev

sshort fs_stat::st_ino

ulong fs_stat::st_mode

DATESTR fs_stat::st_mtime

sshort fs_stat::st_nlink

sshort fs_stat::st_rdev

ulong fs_stat::st_size

The documentation for this struct was generated from the following file:
  • AddOns/AfsFat/FatSim.hpp
Generated on Wed Jan 25 01:16:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FsRegistrationInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FsRegistrationInfo Struct Reference
[FAT filesystem support]

#include <Apoxi/AddOns/AfsFat/FatTypes.hpp>

Data Fields

void * | client_arg
FsDeviceType device
CHAR | drive_letter
BOOLEAN | indication
BOOLEAN | media_present
void(* | notification_func )(FsDeviceType device, BOOLEAN media_present, void *client_arg)
BOOLEAN | removable

Detailed Description

Contains all available attributes of a registered device

Field Documentation

void* FsRegistrationInfo::client_arg

FsDeviceType FsRegistrationInfo::device

CHAR FsRegistrationInfo::drive_letter

BOOLEAN FsRegistrationInfo::indication

BOOLEAN FsRegistrationInfo::media_present

void(* FsRegistrationInfo::notification_func)(FsDeviceType device, BOOLEAN media_present, void *client_arg)

BOOLEAN FsRegistrationInfo::removable

The documentation for this struct was generated from the following file:
  • AddOns/AfsFat/FatTypes.hpp
Generated on Wed Jan 25 01:16:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpAuthProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpAuthProvider Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpAuthProvider.hpp>

Inheritance diagram for FtpAuthProvider:

[legend]
Collaboration diagram for FtpAuthProvider:

[legend]

Public Member Functions

virtual BOOLEAN | AuthorizeUser (const String &username)
virtual BOOLEAN | AuthorizeUserPassword (const String &username, const String &password)
FtpAuthProvider ()
virtual Pathname | GetUserHome (const String &username)=0
virtual BOOLEAN | IsAccessGranted (const String &username, const Path &path)
virtual | ~FtpAuthProvider ()

Constructor & Destructor Documentation

FtpAuthProvider::FtpAuthProvider ( )

Constructor. Initializes all member variables with the default values.

FtpAuthProvider::~FtpAuthProvider ( ) [virtual]

Destructor. Deallocates used resources.

Member Function Documentation

BOOLEAN FtpAuthProvider::AuthorizeUser ( const String & username ) [virtual]

Method for authorizing a certain user. Must be implemented in derived classes.

Parameters:
username Name of a certain user to authorize.

Implements AuthProvider.

BOOLEAN FtpAuthProvider::AuthorizeUserPassword | ( | const String & | username,
 |  | const String & | password
 | ) | [virtual]

Method for authorizing a certain user with a certain password. Must be implemented in derived classes.

Parameters:
username | Name of a certain user to authorize.
password | Password for a certain user account.

Implements AuthProvider.

virtual Pathname FtpAuthProvider::GetUserHome ( const String & username ) [pure virtual]

Returns the relative home directory of a user.

Parameters:
username Name of a certain user to authorize.
Returns:
Home directory of the user, relative to server home.

BOOLEAN FtpAuthProvider::IsAccessGranted | ( | const String & | username,
 |  | const Path & | path
 | ) | [virtual]

Returns whether a certain user is allowed to access the specified path.

Parameters:
username | Name of a certain user to authorize.
pathname | Path name to check.

Implements AuthProvider.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpAuthProvider.hpp
  • AddOns/Server/FtpServer/FtpAuthProvider.cpp
Generated on Wed Jan 25 01:16:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpClient Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpClient.hpp>

Inheritance diagram for FtpClient:

[legend]
Collaboration diagram for FtpClient:

[legend]

Public Types

enum | State { c_state_not_logged_in, c_state_terminated, c_state_login_process, c_state_logged_in }

Public Member Functions

FtpClient (Server *server, Pathname homeDir, Pathname currentDir=Pathname(L"/"))
virtual FtpDataConnectionType | GetDataConnectionType ()
virtual FtpDataSocketPtr | GetFtpDataSocket ()
virtual FtpSocketPtr | GetFtpSocket ()
virtual UINT | GetId ()
virtual InetSocketAddr | GetLocalDataSocketAddr ()
virtual InetSocketAddr | GetPeerDataSocketAddr ()
virtual const String & | GetUser ()
virtual | ~FtpClient ()

Protected Member Functions

BOOLEAN | CloseDataConnection ()
virtual BOOLEAN | DoListCmd (const FtpRequest &request)
virtual BOOLEAN | DoRetrCmd (const FtpRequest &request)
virtual BOOLEAN | DoStorCmd (const FtpRequest &request)
BOOLEAN | EstablishDataConnection ()
virtual BOOLEAN | ExecCdupCmd (const FtpRequest &request)
virtual BOOLEAN | ExecCmd (const FtpRequest &request)
virtual BOOLEAN | ExecCwdCmd (const FtpRequest &request)
virtual BOOLEAN | ExecDeleCmd (const FtpRequest &request)
virtual BOOLEAN | ExecListCmd (const FtpRequest &request)
virtual BOOLEAN | ExecMkdCmd (const FtpRequest &request)
virtual BOOLEAN | ExecModeCmd (const FtpRequest &request)
virtual BOOLEAN | ExecNoopCmd (const FtpRequest &request)
virtual BOOLEAN | ExecPassCmd (const FtpRequest &request, AuthProvider *ftpAuthProvider)
virtual BOOLEAN | ExecPasvCmd (const FtpRequest &request)
virtual BOOLEAN | ExecPortCmd (const FtpRequest &request)
virtual BOOLEAN | ExecPwdCmd (const FtpRequest &request)
virtual BOOLEAN | ExecQuitCmd (const FtpRequest &request)
virtual BOOLEAN | ExecRetrCmd (const FtpRequest &request)
virtual BOOLEAN | ExecRmdCmd (const FtpRequest &request)
virtual BOOLEAN | ExecStorCmd (const FtpRequest &request)
virtual BOOLEAN | ExecStruCmd (const FtpRequest &request)
virtual BOOLEAN | ExecTypeCmd (const FtpRequest &request)
virtual BOOLEAN | ExecUserCmd (const FtpRequest &request, AuthProvider *ftpAuthProvider)
Pathname | GetAbsolutePathname (const Pathname &pathname)
String | GetDirItemInformation (Pathname pathname)
State GetState ()
BOOLEAN | ReplyMessage (const String &replyCode, const String &text)
virtual void | SetDataConnectionType (FtpDataConnectionType dataConnType)
virtual void | SetFtpDataSocket (FtpDataSocketPtr ftpDataSocket)
virtual void | SetFtpSocket (FtpSocketPtr ftpSocket)
virtual void | SetLocalDataSocketAddr (const InetSocketAddr &localDataSocketAddr)
virtual void | SetPeerDataSocketAddr (const InetSocketAddr &peerDataSocketAddr)
void | SetState (State state)

Friends

class | FtpDataServerSocket
class | FtpServer

Member Enumeration Documentation

enum FtpClient::State

Enumerator:
c_state_not_logged_in
c_state_terminated
c_state_login_process
c_state_logged_in

Constructor & Destructor Documentation

FtpClient::FtpClient | ( | Server * | server,
 |  | Pathname | homeDir,
 |  | Pathname | currentDir = Pathname(L"/")
 | ) |

FtpClient::~FtpClient ( ) [virtual]

Member Function Documentation

BOOLEAN FtpClient::CloseDataConnection ( ) [protected]

Closes the data connection to the peer data socket.

Returns:
Whether the connection could be closed or not.

BOOLEAN FtpClient::DoListCmd ( const FtpRequest & request ) [protected, virtual]

Finally commits thte actions of the LIST command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::DoRetrCmd ( const FtpRequest & request ) [protected, virtual]

Finally commits thte actions of the RETR command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::DoStorCmd ( const FtpRequest & request ) [protected, virtual]

Finally commits thte actions of the STOR command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::EstablishDataConnection ( ) [protected]

Establishes a data connection to the peer data socket. NOTE: The method replies to the peer control socket if the connection could be established, was previously given or if it could not be created.

Returns:
Whether the connection could be established or not.

BOOLEAN FtpClient::ExecCdupCmd ( const FtpRequest & request ) [protected, virtual]

Executes CDUP command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecCmd ( const FtpRequest & request ) [protected, virtual]

Executes an FTP command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecCwdCmd ( const FtpRequest & request ) [protected, virtual]

Executes CWD command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecDeleCmd ( const FtpRequest & request ) [protected, virtual]

Executes DELE command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecListCmd ( const FtpRequest & request ) [protected, virtual]

Executes LIST command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecMkdCmd ( const FtpRequest & request ) [protected, virtual]

Executes MKD command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecModeCmd ( const FtpRequest & request ) [protected, virtual]

Executes MODE command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecNoopCmd ( const FtpRequest & request ) [protected, virtual]

Executes NOOP command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecPassCmd | ( | const FtpRequest & | request,
 |  | AuthProvider * | ftpAuthProvider
 | ) | [protected, virtual]

Executes PASS command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message. The object which determines whether a user is permitted to log in or not.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecPasvCmd ( const FtpRequest & request ) [protected, virtual]

Executes PASV command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecPortCmd ( const FtpRequest & request ) [protected, virtual]

Executes PORT command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecPwdCmd ( const FtpRequest & request ) [protected, virtual]

Executes PWD command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecQuitCmd ( const FtpRequest & request ) [protected, virtual]

Executes QUIT command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecRetrCmd ( const FtpRequest & request ) [protected, virtual]

Executes RETR command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecRmdCmd ( const FtpRequest & request ) [protected, virtual]

Executes RMD command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecStorCmd ( const FtpRequest & request ) [protected, virtual]

Executes STOR command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecStruCmd ( const FtpRequest & request ) [protected, virtual]

Executes STRU command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecTypeCmd ( const FtpRequest & request ) [protected, virtual]

Executes TYPE command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message.
Returns:
Whether the command could be processed or not.

BOOLEAN FtpClient::ExecUserCmd | ( | const FtpRequest & | request,
 |  | AuthProvider * | ftpAuthProvider
 | ) | [protected, virtual]

Executes USER command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
request The FTP request message. The object which determines whether a user is permitted to log in or not.
Returns:
Whether the command could be processed or not.

Pathname FtpClient::GetAbsolutePathname ( const Pathname & pathname ) [protected]

Converts the given user home absolute path name to an absolute path name in the RFS. The result depends on the specified user home directory.

Parameters:
pathname path name absolute to user home
Returns:
path name absolute to RFS root

FtpDataConnectionType FtpClient::GetDataConnectionType ( ) [virtual]

String FtpClient::GetDirItemInformation ( Pathname pathname ) [protected]

Returns information about a directory entry as it will be used for listing directory contents.

Parameters:
pathname The path name of the file or directory.
Returns:
The information about the file.

FtpDataSocketPtr FtpClient::GetFtpDataSocket ( ) [virtual]

FtpSocketPtr FtpClient::GetFtpSocket ( ) [virtual]

UINT FtpClient::GetId ( ) [virtual]

Reimplemented from ServerClient.

InetSocketAddr FtpClient::GetLocalDataSocketAddr ( ) [virtual]

InetSocketAddr FtpClient::GetPeerDataSocketAddr ( ) [virtual]

FtpClient::State FtpClient::GetState ( ) [protected]

const String & FtpClient::GetUser ( ) [virtual]

BOOLEAN FtpClient::ReplyMessage | ( | const String & | replyCode,
 |  | const String & | text
 | ) | [protected]

Replies a code and text message to the client's control socket.

Parameters:
replyCode | The number of the reply code (1xx, 2xx, 3xx, 4xx, 5xx).
text | The (optional) text describing the cause or additional information about the replay code.
Returns:
Reply sent correctly.

void FtpClient::SetDataConnectionType ( FtpDataConnectionType dataConnType ) [protected, virtual]

void FtpClient::SetFtpDataSocket ( FtpDataSocketPtr ftpDataSocket ) [protected, virtual]

Sets an other FTP data socket.

void FtpClient::SetFtpSocket ( FtpSocketPtr ftpSocket ) [protected, virtual]

Sets an other FTP socket.

void FtpClient::SetLocalDataSocketAddr ( const InetSocketAddr & localDataSocketAddr ) [protected, virtual]

Sets the local data socket address.

void FtpClient::SetPeerDataSocketAddr ( const InetSocketAddr & peerDataSocketAddr ) [protected, virtual]

Sets the peer data socket address.

void FtpClient::SetState ( State state ) [protected]

Friends And Related Function Documentation

friend class FtpDataServerSocket [friend]

friend class FtpServer [friend]

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpClient.hpp
  • AddOns/Server/FtpServer/FtpClient.cpp
Generated on Wed Jan 25 01:16:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpConnectMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpConnectMessage Class Reference

#include <Apoxi/AddOns/Server/FtpServer/MsgTypes.hpp>

Inheritance diagram for FtpConnectMessage:

[legend]
Collaboration diagram for FtpConnectMessage:

[legend]

Public Types

enum | { ID = 4504 }

Public Member Functions

virtual Message * | Clone () const
FtpConnectMessage (const InetSocketAddr &peerAddr, const FtpSocketPtr &peerSocket)
virtual const MsgMetaData & | GetMetaData () const
const InetSocketAddr & | GetPeerAddr () const
const FtpSocketPtr & | GetPeerSocket () const
virtual | ~FtpConnectMessage ()

Detailed Description

This message is sent when a client connects to the ftp server.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FtpConnectMessage::FtpConnectMessage | ( | const InetSocketAddr & | peerAddr,
 |  | const FtpSocketPtr & | peerSocket
 | ) |

FtpConnectMessage::~FtpConnectMessage ( ) [virtual]

Member Function Documentation

Message * FtpConnectMessage::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & FtpConnectMessage::GetMetaData ( ) const [virtual]

Implements Message.

const InetSocketAddr& FtpConnectMessage::GetPeerAddr ( ) const [inline]

const FtpSocketPtr& FtpConnectMessage::GetPeerSocket ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/MsgTypes.hpp
  • AddOns/Server/FtpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:16:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpDataServerSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpDataServerSocket Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpDataServerSocket.hpp>

Inheritance diagram for FtpDataServerSocket:

[legend]
Collaboration diagram for FtpDataServerSocket:

[legend]

Public Member Functions

FtpDataServerSocket (Server *server, UINT clientId=0)
virtual | ~FtpDataServerSocket ()

Protected Member Functions

virtual void | OnAsyncEvent (Event event)

Friends

class | FtpClient
class | TcpServerSocket

Constructor & Destructor Documentation

FtpDataServerSocket::FtpDataServerSocket | ( | Server * | server,
 |  | UINT | clientId = 0
 | ) |

FtpDataServerSocket::~FtpDataServerSocket ( ) [virtual]

Member Function Documentation

void FtpDataServerSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Receives the notification of an asynchronous event. The event types are dependent on the socket type, some events are only sent for connection oriented sockets or for server sockets (please see the enumeration Event). A client who uses sockets has to derive an own socket class and implement this method in order to listen to the events that occur on the socket and to react on it according to its communication policy.

Reimplemented from InetSocket.

Friends And Related Function Documentation

friend class FtpClient [friend]

friend class TcpServerSocket [friend]

Reimplemented from InetSocket.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpDataServerSocket.hpp
  • AddOns/Server/FtpServer/FtpDataServerSocket.cpp
Generated on Wed Jan 25 01:16:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpDataSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpDataSocket Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpDataSocket.hpp>

Inheritance diagram for FtpDataSocket:

[legend]
Collaboration diagram for FtpDataSocket:

[legend]

Public Member Functions

FtpDataSocket (FtpSocketPtr ftpSocket, UINT clientId=0, FtpTransferMode mode=c_ftp_transfer_mode_block, FtpTransferType type=c_ftp_transfer_type_ascii, FtpTransferStructure structure=c_ftp_transfer_structure_file)
virtual | ~FtpDataSocket ()

Protected Member Functions

virtual FtpInTransferPtr | GetFtpInTransfer ()
virtual FtpOutTransferPtr | GetFtpOutTransfer ()
virtual FtpSocketPtr | GetFtpSocket ()
virtual void | OnAsyncEvent (Event event)
virtual FtpTransferError | ProgressFtpInTransfer (UINT32 bytes)
virtual FtpTransferError | ProgressFtpOutTransfer ()
virtual void | SetClientId (UINT clientId)
virtual void | SetFtpInTransfer (FtpInTransferPtr ftpInTransfer)
virtual void | SetFtpOutTransfer (FtpOutTransferPtr ftpOutTransfer)
virtual void | SetFtpSocket (FtpSocketPtr ftpSocket)
virtual void | SetMode (FtpTransferMode mode)
virtual void | SetStructure (FtpTransferStructure structure)
virtual void | SetType (FtpTransferType type)

Protected Attributes

UINT | m_clientId
UINT8 * | m_data_in_buffer
UINT8 * | m_data_out_buffer
FtpInTransferPtr m_ftpInTransfer
FtpOutTransferPtr m_ftpOutTransfer
FtpSocketPtr m_ftpSocket
FtpTransferMode m_mode
Server * m_server
FtpTransferStructure m_structure
FtpTransferType m_type

Friends

class | FtpClient
class | FtpInTransfer
class | FtpOutTransfer
class | FtpServer

Constructor & Destructor Documentation

FtpDataSocket::FtpDataSocket | ( | FtpSocketPtr | ftpSocket,
 |  | UINT | clientId = 0,
 |  | FtpTransferMode | mode = c_ftp_transfer_mode_block,
 |  | FtpTransferType | type = c_ftp_transfer_type_ascii,
 |  | FtpTransferStructure | structure = c_ftp_transfer_structure_file
 | ) |

FtpDataSocket::~FtpDataSocket ( ) [virtual]

Member Function Documentation

FtpInTransferPtr FtpDataSocket::GetFtpInTransfer ( ) [protected, virtual]

FtpOutTransferPtr FtpDataSocket::GetFtpOutTransfer ( ) [protected, virtual]

FtpSocketPtr FtpDataSocket::GetFtpSocket ( ) [protected, virtual]

void FtpDataSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Receives the notification of an asynchronous event. The event types are dependent on the socket type, some events are only sent for connection oriented sockets or for server sockets (please see the enumeration Event). A client who uses sockets has to derive an own socket class and implement this method in order to listen to the events that occur on the socket and to react on it according to its communication policy.

Reimplemented from InetSocket.

FtpTransferError FtpDataSocket::ProgressFtpInTransfer ( UINT32 bytes ) [protected, virtual]

FtpTransferError FtpDataSocket::ProgressFtpOutTransfer ( ) [protected, virtual]

void FtpDataSocket::SetClientId ( UINT clientId ) [protected, virtual]

void FtpDataSocket::SetFtpInTransfer ( FtpInTransferPtr ftpInTransfer ) [protected, virtual]

void FtpDataSocket::SetFtpOutTransfer ( FtpOutTransferPtr ftpOutTransfer ) [protected, virtual]

void FtpDataSocket::SetFtpSocket ( FtpSocketPtr ftpSocket ) [protected, virtual]

void FtpDataSocket::SetMode ( FtpTransferMode mode ) [protected, virtual]

void FtpDataSocket::SetStructure ( FtpTransferStructure structure ) [protected, virtual]

void FtpDataSocket::SetType ( FtpTransferType type ) [protected, virtual]

Friends And Related Function Documentation

friend class FtpClient [friend]

friend class FtpInTransfer [friend]

friend class FtpOutTransfer [friend]

friend class FtpServer [friend]

Field Documentation

UINT FtpDataSocket::m_clientId [protected]

UINT8* FtpDataSocket::m_data_in_buffer [protected]

UINT8* FtpDataSocket::m_data_out_buffer [protected]

FtpInTransferPtr FtpDataSocket::m_ftpInTransfer [protected]

FtpOutTransferPtr FtpDataSocket::m_ftpOutTransfer [protected]

FtpSocketPtr FtpDataSocket::m_ftpSocket [protected]

FtpTransferMode FtpDataSocket::m_mode [protected]

Server* FtpDataSocket::m_server [protected]

FtpTransferStructure FtpDataSocket::m_structure [protected]

FtpTransferType FtpDataSocket::m_type [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpDataSocket.hpp
  • AddOns/Server/FtpServer/FtpDataSocket.cpp
Generated on Wed Jan 25 01:16:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpDisconnectMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpDisconnectMessage Class Reference

#include <Apoxi/AddOns/Server/FtpServer/MsgTypes.hpp>

Inheritance diagram for FtpDisconnectMessage:

[legend]
Collaboration diagram for FtpDisconnectMessage:

[legend]

Public Types

enum | { ID = 4505 }

Public Member Functions

virtual Message * | Clone () const
FtpDisconnectMessage (UINT clientId, const FtpConnectionType &connType=c_ftp_conn_type_control)
UINT | GetClientId () const
const FtpConnectionType & | GetConnType () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~FtpDisconnectMessage ()

Detailed Description

This message is sent when a client has disconnected.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FtpDisconnectMessage::FtpDisconnectMessage | ( | UINT | clientId,
 |  | const FtpConnectionType & | connType = c_ftp_conn_type_control
 | ) |

FtpDisconnectMessage::~FtpDisconnectMessage ( ) [virtual]

Member Function Documentation

Message * FtpDisconnectMessage::Clone ( ) const [virtual]

Implements Message.

UINT FtpDisconnectMessage::GetClientId ( ) const [inline]

const FtpConnectionType& FtpDisconnectMessage::GetConnType ( ) const [inline]

const MsgMetaData & FtpDisconnectMessage::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/MsgTypes.hpp
  • AddOns/Server/FtpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:16:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpErrorMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpErrorMessage Class Reference

#include <Apoxi/AddOns/Server/FtpServer/MsgTypes.hpp>

Inheritance diagram for FtpErrorMessage:

[legend]
Collaboration diagram for FtpErrorMessage:

[legend]

Public Types

enum | { ID = 4501 }

Public Member Functions

virtual Message * | Clone () const
FtpErrorMessage (const FtpServiceCommand &cmd, const FtpServiceCommandError &code)
const FtpServiceCommand & | GetCmd () const
const FtpServiceCommandError & | GetCode () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~FtpErrorMessage ()

Detailed Description

This message is sent when an error occurs performing a service command (or even on success).

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FtpErrorMessage::FtpErrorMessage | ( | const FtpServiceCommand & | cmd,
 |  | const FtpServiceCommandError & | code
 | ) |

FtpErrorMessage::~FtpErrorMessage ( ) [virtual]

Member Function Documentation

Message * FtpErrorMessage::Clone ( ) const [virtual]

Implements Message.

const FtpServiceCommand& FtpErrorMessage::GetCmd ( ) const [inline]

const FtpServiceCommandError& FtpErrorMessage::GetCode ( ) const [inline]

const MsgMetaData & FtpErrorMessage::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/MsgTypes.hpp
  • AddOns/Server/FtpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:16:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpInTransfer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpInTransfer Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpInTransfer.hpp>

Inheritance diagram for FtpInTransfer:

[legend]
Collaboration diagram for FtpInTransfer:

[legend]

Public Member Functions

FtpInTransfer (FtpSocketPtr ftpSocket, FilePtr file, UINT32 offset=0, BOOLEAN running=TRUE)
virtual | ~FtpInTransfer ()

Protected Member Functions

virtual FtpTransferError | Start ()

Friends

class | FtpDataSocket
class | FtpServer

Constructor & Destructor Documentation

FtpInTransfer::FtpInTransfer | ( | FtpSocketPtr | ftpSocket,
 |  | FilePtr | file,
 |  | UINT32 | offset = 0,
 |  | BOOLEAN | running = TRUE
 | ) |

FtpInTransfer::~FtpInTransfer ( ) [virtual]

Member Function Documentation

FtpTransferError FtpInTransfer::Start ( ) [protected, virtual]

Starts the transfer.

Returns:
Result of starting the transfer.

Implements FtpTransfer.

Friends And Related Function Documentation

friend class FtpDataSocket [friend]

Reimplemented from FtpTransfer.

friend class FtpServer [friend]

Reimplemented from FtpTransfer.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpInTransfer.hpp
  • AddOns/Server/FtpServer/FtpInTransfer.cpp
Generated on Wed Jan 25 01:16:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpOutTransfer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpOutTransfer Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpOutTransfer.hpp>

Inheritance diagram for FtpOutTransfer:

[legend]
Collaboration diagram for FtpOutTransfer:

[legend]

Public Member Functions

FtpOutTransfer (FtpSocketPtr ftpSocket, FilePtr file, UINT32 offset=0, BOOLEAN running=TRUE)
virtual | ~FtpOutTransfer ()

Protected Member Functions

virtual FtpTransferError | Start ()

Friends

class | FtpDataSocket
class | FtpServer

Constructor & Destructor Documentation

FtpOutTransfer::FtpOutTransfer | ( | FtpSocketPtr | ftpSocket,
 |  | FilePtr | file,
 |  | UINT32 | offset = 0,
 |  | BOOLEAN | running = TRUE
 | ) |

FtpOutTransfer::~FtpOutTransfer ( ) [virtual]

Member Function Documentation

FtpTransferError FtpOutTransfer::Start ( ) [protected, virtual]

Starts the transfer.

Returns:
Result of starting the transfer.

Implements FtpTransfer.

Friends And Related Function Documentation

friend class FtpDataSocket [friend]

Reimplemented from FtpTransfer.

friend class FtpServer [friend]

Reimplemented from FtpTransfer.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpOutTransfer.hpp
  • AddOns/Server/FtpServer/FtpOutTransfer.cpp
Generated on Wed Jan 25 01:16:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpRequest Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpRequest.hpp>

Collaboration diagram for FtpRequest:

[legend]

Public Member Functions

FtpRequest (const InetSocketAddr &peerAddr, UINT clientId, const String &cmd, const String &params)
UINT | GetClientId () const
const String & | GetCmd () const
const String & | GetParams () const
const InetSocketAddr & | GetPeerAddr () const
virtual | ~FtpRequest ()

Constructor & Destructor Documentation

FtpRequest::FtpRequest | ( | const InetSocketAddr & | peerAddr,
 |  | UINT | clientId,
 |  | const String & | cmd,
 |  | const String & | params
 | ) |

FtpRequest::~FtpRequest ( ) [virtual]

Member Function Documentation

UINT FtpRequest::GetClientId ( ) const [inline]

const String& FtpRequest::GetCmd ( ) const [inline]

const String& FtpRequest::GetParams ( ) const [inline]

const InetSocketAddr& FtpRequest::GetPeerAddr ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpRequest.hpp
  • AddOns/Server/FtpServer/FtpRequest.cpp
Generated on Wed Jan 25 01:16:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpRequestMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpRequestMessage Class Reference

#include <Apoxi/AddOns/Server/FtpServer/MsgTypes.hpp>

Inheritance diagram for FtpRequestMessage:

[legend]
Collaboration diagram for FtpRequestMessage:

[legend]

Public Types

enum | { ID = 4503 }

Public Member Functions

virtual Message * | Clone () const
FtpRequestMessage (const FtpRequest &ftpRequest)
const FtpRequest & | GetFtpRequest () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~FtpRequestMessage ()

Detailed Description

This message is sent when a client poses a request.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FtpRequestMessage::FtpRequestMessage ( const FtpRequest & ftpRequest )

FtpRequestMessage::~FtpRequestMessage ( ) [virtual]

Member Function Documentation

Message * FtpRequestMessage::Clone ( ) const [virtual]

Implements Message.

const FtpRequest& FtpRequestMessage::GetFtpRequest ( ) const [inline]

const MsgMetaData & FtpRequestMessage::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/MsgTypes.hpp
  • AddOns/Server/FtpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:16:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpServer Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpServer.hpp>

Inheritance diagram for FtpServer:

[legend]
Collaboration diagram for FtpServer:

[legend]

Public Member Functions

FtpServer (FtpServerConfig *serverConfig, FtpAuthProvider *authProvider)
virtual FtpClient * | GetClient (UINT clientId)
virtual IpAddr | GetHostIp ()
virtual IpPortNo | GetPort ()
virtual void | Start (const InetSocketAddr &localAddr, DataConnProfileId dataConnProfileId=c_invalid_data_conn_profile_id)
virtual void | Stop ()
virtual | ~FtpServer ()

Protected Member Functions

virtual BOOLEAN | ConnectClient (const InetSocketAddr &peerAddr, const FtpSocketPtr &peerSocket)
virtual BOOLEAN | DisconnectClient (UINT clientId)
virtual BOOLEAN | ExecCmd (const FtpRequest &request)
virtual BOOLEAN | HandleRequest (const FtpRequest &request)
virtual void | Init ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | Terminate ()

Friends

class | FtpClient
class | FtpSocket

Constructor & Destructor Documentation

FtpServer::FtpServer | ( | FtpServerConfig * | serverConfig,
 |  | FtpAuthProvider * | authProvider
 | ) |

FtpServer::~FtpServer ( ) [virtual]

Member Function Documentation

BOOLEAN FtpServer::ConnectClient | ( | const InetSocketAddr & | peerAddr,
 |  | const FtpSocketPtr & | peerSocket
 | ) | [protected, virtual]

Connects a client to the server.

Parameters:
peerAddr | Address of the peer socket.
peerSocket | Socket object for sending/receiving data.
Returns:
Whether the operation was successful or not.

BOOLEAN FtpServer::DisconnectClient ( UINT clientId ) [protected, virtual]

Disconnects a client.

Parameters:
clientId ID of the client.
Returns:
Whether the operation was successful or not.

BOOLEAN FtpServer::ExecCmd ( const FtpRequest & request ) [protected, virtual]

Executes a command. It returns whether the given FTP command could be processed or not. The return value does not express the result of the operation. This is done by the FTP reply code.

Parameters:
msg The FTP request message.
Returns:
Whether the command could be processed or not.

FtpClient * FtpServer::GetClient ( UINT clientId ) [virtual]

Returns the pointer to the according FtpClient object.

Parameters:
clientId ID of the client.
Returns:
Pointer to the FtpClient object.

Reimplemented from Server.

IpAddr FtpServer::GetHostIp ( ) [virtual]

Returns the IP address of the host.

Returns:
The IP address of the host.

Implements Server.

IpPortNo FtpServer::GetPort ( ) [virtual]

Gets the port number of the control connection.

Returns:
Port number of the control connection.

Implements Server.

BOOLEAN FtpServer::HandleRequest ( const FtpRequest & request ) [protected, virtual]

Handles an FTP request.

Parameters:
fr An FTP request object.
Returns:
Whether the request could be handled or not.

void FtpServer::Init ( ) [protected, virtual]

Protected service interface (called by the constructor). The implementation sends messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Implements Server.

BOOLEAN FtpServer::OnMessage ( const Message & msg ) [protected, virtual]

Handles a system message.

Parameters:
msg A system message object.
Returns:
Whether the message was handled or not.

Reimplemented from ServiceThread.

void FtpServer::Start | ( | const InetSocketAddr & | localAddr,
 |  | DataConnProfileId | dataConnProfileId = c_invalid_data_conn_profile_id
 | ) | [virtual]

Public service interface. The implementation sends messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Parameters:
localAddr | Socket address to bind to.
dataConnProfileId | ID of the DataConn to use for opening sockets.

Implements Server.

void FtpServer::Stop ( ) [virtual]

Public service interface. The implementation sends messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Implements Server.

void FtpServer::Terminate ( ) [protected, virtual]

Protected service interface (called by the destructor). The implementation sends messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Implements Server.

Friends And Related Function Documentation

friend class FtpClient [friend]

friend class FtpSocket [friend]

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpServer.hpp
  • AddOns/Server/FtpServer/FtpServer.cpp
Generated on Wed Jan 25 01:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpServerConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpServerConfig Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpServerConfig.hpp>

Inheritance diagram for FtpServerConfig:

[legend]
Collaboration diagram for FtpServerConfig:

[legend]

Public Member Functions

FtpServerConfig ()
virtual ~FtpServerConfig ()

Constructor & Destructor Documentation

FtpServerConfig::FtpServerConfig ( )

Constructor. Initializes all member variables with the default values.

FtpServerConfig::~FtpServerConfig ( ) [virtual]

Destructor. Deallocates used resources.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpServerConfig.hpp
  • AddOns/Server/FtpServer/FtpServerConfig.cpp
Generated on Wed Jan 25 01:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpServerSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpServerSocket Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpServerSocket.hpp>

Inheritance diagram for FtpServerSocket:

[legend]
Collaboration diagram for FtpServerSocket:

[legend]

Public Member Functions

FtpServerSocket (Server *server)
virtual | ~FtpServerSocket ()

Protected Member Functions

virtual void | OnAsyncEvent (Event event)

Constructor & Destructor Documentation

FtpServerSocket::FtpServerSocket ( Server * server )

FtpServerSocket::~FtpServerSocket ( ) [virtual]

Member Function Documentation

void FtpServerSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Receives the notification of an asynchronous event. The event types are dependent on the socket type, some events are only sent for connection oriented sockets or for server sockets (please see the enumeration Event). A client who uses sockets has to derive an own socket class and implement this method in order to listen to the events that occur on the socket and to react on it according to its communication policy.

Reimplemented from InetSocket.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpServerSocket.hpp
  • AddOns/Server/FtpServer/FtpServerSocket.cpp
Generated on Wed Jan 25 01:16:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpServiceMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpServiceMessage Class Reference

#include <Apoxi/AddOns/Server/FtpServer/MsgTypes.hpp>

Inheritance diagram for FtpServiceMessage:

[legend]
Collaboration diagram for FtpServiceMessage:

[legend]

Public Types

enum | { ID = 4500 }

Public Member Functions

virtual Message * | Clone () const
FtpServiceMessage (const FtpServiceCommand &cmd, const InetSocketAddr &socketAddr=InetSocketAddr(), const DataConnProfileId &dataConnProfileId=c_invalid_data_conn_profile_id)
const FtpServiceCommand & | GetCmd () const
const DataConnProfileId & | GetDataConnProfileId () const
virtual const MsgMetaData & | GetMetaData () const
const InetSocketAddr & | GetSocketAddr () const
virtual | ~FtpServiceMessage ()

Detailed Description

This message is sent when an other application (preferably FtpServerApp) uses the public FtpServer interface.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FtpServiceMessage::FtpServiceMessage | ( | const FtpServiceCommand & | cmd,
 |  | const InetSocketAddr & | socketAddr = InetSocketAddr(),
 |  | const DataConnProfileId & | dataConnProfileId = c_invalid_data_conn_profile_id
 | ) |

FtpServiceMessage::~FtpServiceMessage ( ) [virtual]

Member Function Documentation

Message * FtpServiceMessage::Clone ( ) const [virtual]

Implements Message.

const FtpServiceCommand& FtpServiceMessage::GetCmd ( ) const [inline]

const DataConnProfileId& FtpServiceMessage::GetDataConnProfileId ( ) const [inline]

const MsgMetaData & FtpServiceMessage::GetMetaData ( ) const [virtual]

Implements Message.

const InetSocketAddr& FtpServiceMessage::GetSocketAddr ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/MsgTypes.hpp
  • AddOns/Server/FtpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:16:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpSocket Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpSocket.hpp>

Inheritance diagram for FtpSocket:

[legend]
Collaboration diagram for FtpSocket:

[legend]

Public Member Functions

FtpSocket (Server *server, UINT clientId=0)
virtual | ~FtpSocket ()

Protected Member Functions

virtual void | OnAsyncEvent (Event event)
virtual BOOLEAN | ReplyMessage (const String &code, const String &text)
virtual void | SetClientId (UINT clientId)

Protected Attributes

Server * m_server

Friends

class | FtpClient
class | FtpDataSocket
class | FtpInTransfer
class | FtpOutTransfer
class | FtpServer
class | FtpServerSocket

Constructor & Destructor Documentation

FtpSocket::FtpSocket | ( | Server * | server,
 |  | UINT | clientId = 0
 | ) |

FtpSocket::~FtpSocket ( ) [virtual]

Member Function Documentation

void FtpSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Receives the notification of an asynchronous event. The event types are dependent on the socket type, some events are only sent for connection oriented sockets or for server sockets (please see the enumeration Event). A client who uses sockets has to derive an own socket class and implement this method in order to listen to the events that occur on the socket and to react on it according to its communication policy.

Reimplemented from InetSocket.

BOOLEAN FtpSocket::ReplyMessage | ( | const String & | code,
 |  | const String & | text
 | ) | [protected, virtual]

Replies a code and text message to the client's control socket.

Parameters:
code | The reply code to return (1xx, 2xx, 3xx, 4xx, 5xx).
text | An optional text field describing the reply or giving additional information.
Returns:
Whether the reply could be sent or not.

void FtpSocket::SetClientId ( UINT clientId ) [protected, virtual]

Friends And Related Function Documentation

friend class FtpClient [friend]

friend class FtpDataSocket [friend]

friend class FtpInTransfer [friend]

friend class FtpOutTransfer [friend]

friend class FtpServer [friend]

friend class FtpServerSocket [friend]

Field Documentation

Server* FtpSocket::m_server [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpSocket.hpp
  • AddOns/Server/FtpServer/FtpSocket.cpp
Generated on Wed Jan 25 01:16:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpTransfer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpTransfer Class Reference
[FTPSERVER]

#include <Apoxi/AddOns/Server/FtpServer/FtpTransfer.hpp>

Inheritance diagram for FtpTransfer:

[legend]
Collaboration diagram for FtpTransfer:

[legend]

Public Member Functions

virtual BOOLEAN | IsRunning ()
virtual | ~FtpTransfer ()

Protected Member Functions

FtpTransfer (UINT clientId, FtpSocketPtr ftpSocket, FilePtr file, UINT32 offset=0, BOOLEAN running=TRUE)
virtual void | SetRunning (BOOLEAN running)
virtual FtpTransferError | Start ()=0

Protected Attributes

UINT | m_clientId
BOOLEAN | m_disconnect_on_complete
FilePtr m_file
UINT32 | m_filesize
FtpSocketPtr m_ftpSocket
UINT32 | m_offset
BOOLEAN | m_running

Friends

class | FtpClient
class | FtpDataSocket
class | FtpServer

Constructor & Destructor Documentation

FtpTransfer::~FtpTransfer ( ) [virtual]

FtpTransfer::FtpTransfer | ( | UINT | clientId,
 |  | FtpSocketPtr | ftpSocket,
 |  | FilePtr | file,
 |  | UINT32 | offset = 0,
 |  | BOOLEAN | running = TRUE
 | ) | [protected]

Constructor.

Parameters:
server | Pointer to a server object.
clientId | ID of the corresponding client.
ftpSocket | Smart pointer to the socket used by that client.
offset | Offset where the transfer should start from.
running | Whether the transfer should start immediately or not.
blockLength | The size of one transfer block in bytes which shall be used for transferring large files.

Member Function Documentation

BOOLEAN FtpTransfer::IsRunning ( ) [virtual]

Returns whether the transfer is currently running or not.

Returns:
Whether the transfer is running or not.

void FtpTransfer::SetRunning ( BOOLEAN running ) [protected, virtual]

Sets the transfer to running or stopped.

Parameters:
running Whether the transfer should be running or not.

virtual FtpTransferError FtpTransfer::Start ( ) [protected, pure virtual]

Starts the transfer.

Returns:
The result of the method.

Implemented in FtpInTransfer, and FtpOutTransfer.

Friends And Related Function Documentation

friend class FtpClient [friend]

friend class FtpDataSocket [friend]

Reimplemented in FtpInTransfer, and FtpOutTransfer.

friend class FtpServer [friend]

Reimplemented in FtpInTransfer, and FtpOutTransfer.

Field Documentation

UINT FtpTransfer::m_clientId [protected]

BOOLEAN FtpTransfer::m_disconnect_on_complete [protected]

FilePtr FtpTransfer::m_file [protected]

UINT32 FtpTransfer::m_filesize [protected]

FtpSocketPtr FtpTransfer::m_ftpSocket [protected]

UINT32 FtpTransfer::m_offset [protected]

BOOLEAN FtpTransfer::m_running [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/FtpTransfer.hpp
  • AddOns/Server/FtpServer/FtpTransfer.cpp
Generated on Wed Jan 25 01:16:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FtpTransferMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FtpTransferMessage Class Reference

#include <Apoxi/AddOns/Server/FtpServer/MsgTypes.hpp>

Inheritance diagram for FtpTransferMessage:

[legend]
Collaboration diagram for FtpTransferMessage:

[legend]

Public Types

enum | { ID = 4502 }

Public Member Functions

virtual Message * | Clone () const
FtpTransferMessage (UINT clientId, const FtpTransferDirection &direction, const FtpTransferError &error)
UINT | GetClientId () const
const FtpTransferDirection & | GetDirection () const
const FtpTransferError & | GetError () const
virtual const MsgMetaData & | GetMetaData () const
virtual | ~FtpTransferMessage ()

Detailed Description

This message is sent when an event occurs concerning an FTP transfer.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

FtpTransferMessage::FtpTransferMessage | ( | UINT | clientId,
 |  | const FtpTransferDirection & | direction,
 |  | const FtpTransferError & | error
 | ) |

FtpTransferMessage::~FtpTransferMessage ( ) [virtual]

Member Function Documentation

Message * FtpTransferMessage::Clone ( ) const [virtual]

Implements Message.

UINT FtpTransferMessage::GetClientId ( ) const [inline]

const FtpTransferDirection& FtpTransferMessage::GetDirection ( ) const [inline]

const FtpTransferError& FtpTransferMessage::GetError ( ) const [inline]

const MsgMetaData & FtpTransferMessage::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/Server/FtpServer/MsgTypes.hpp
  • AddOns/Server/FtpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:16:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FunctionalityIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FunctionalityIndicator Class Reference

3GPP 23.040 V5.1.0 [9.2.3.12.3] More...

#include <Apoxi/Apc/ValidityPeriod.hpp>

Collaboration diagram for FunctionalityIndicator:

[legend]

Public Types

enum TimeFormat {
Unspecified = 0, Packed, Seconds, Relative,
ReservedTimeFormat
}

Public Member Functions

void | Clear ()
BOOLEAN | ExtensionExists () const
FunctionalityIndicator (UINT8 incoming_byte)
FunctionalityIndicator ()
UINT8 | Get () const
TimeFormat | GetTimeFormat () const
BOOLEAN | IsSingleShot () const
void | SetExtensionExists (BOOLEAN flag)
void | SetSingleShot (BOOLEAN flag)
void | SetTimeFormat (TimeFormat time_format)

Detailed Description

3GPP 23.040 V5.1.0 [9.2.3.12.3]

Member Enumeration Documentation

enum FunctionalityIndicator::TimeFormat

Enumerator:
Unspecified
Packed
Seconds
Relative
ReservedTimeFormat

Constructor & Destructor Documentation

FunctionalityIndicator::FunctionalityIndicator ( )

FunctionalityIndicator::FunctionalityIndicator ( UINT8 incoming_byte )

Member Function Documentation

void FunctionalityIndicator::Clear ( ) [inline]

BOOLEAN FunctionalityIndicator::ExtensionExists ( ) const [inline]

UINT8 FunctionalityIndicator::Get ( ) const [inline]

FunctionalityIndicator::TimeFormat FunctionalityIndicator::GetTimeFormat ( ) const

BOOLEAN FunctionalityIndicator::IsSingleShot ( ) const [inline]

void FunctionalityIndicator::SetExtensionExists ( BOOLEAN flag ) [inline]

void FunctionalityIndicator::SetSingleShot ( BOOLEAN flag ) [inline]

void FunctionalityIndicator::SetTimeFormat ( TimeFormat time_format )

The documentation for this class was generated from the following files:
  • Apc/ValidityPeriod.hpp
  • Apc/ValidityPeriod.cpp
Generated on Wed Jan 25 01:16:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GatiManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GatiManager Class Reference

#include <Apoxi/Devices/Win32/GatiManager.hpp>

Inheritance diagram for GatiManager:

[legend]
Collaboration diagram for GatiManager:

[legend]

Public Member Functions

BOOLEAN | Broadcast (const INT id, const UINT32 cmd, const UINT32 length, const void *data)
BOOLEAN | Deregister (const UINT32 id)
virtual const WCHAR * | GetName () const
virtual BootSequenceState | InvokeAt () const
virtual void | OnPowerDown ()
virtual void | OnPowerUp ()
BOOLEAN | Register (GatiServer *(*createInstanceFunc)(), const UINT32 id)
BOOLEAN | SendData (const GatiServer *server, const UINT32 cmd, const UINT32 length, const void *data)
BOOLEAN | ShutDown ()
BOOLEAN | StartUp ()
virtual | ~GatiManager ()

Static Public Member Functions

static GatiManager & | GetInstance ()

Friends

class | GatiManagerInternals

Data Structures

struct | DataGramHeader
struct | GatiConnectionEntry
struct | GatiServerEntry

Detailed Description

The GatiManager class is a singleton for managing GATI Servers within the host simulation.

It fulfills several tasks: (1) It allows to register and deregister GatiServer classes and keeps an internal list of all registered classes. (2) It listens to a predefined port for incoming requests from GatiClients and handles the connection request in order to establish a connection between a GatiServer and a GatiClient. (3) It fires events like OnConnect(), OnDisconnect(), ... to inform the GatiServers. (4) It handles the data connections and forwards received data to the desired recipient.

Constructor & Destructor Documentation

GatiManager::~GatiManager ( ) [virtual]

Destructor

Member Function Documentation

BOOLEAN GatiManager::Broadcast | ( | const INT | id,
 |  | const UINT32 | cmd,
 |  | const UINT32 | length,
 |  | const void * | data
 | ) |

Broadcasts data to all GatiClient which are connected to a GatiServer with the given ID.

Parameters:
id[in] : the ID of the GatiServer
cmd[in],: the command identifying the data.
length[in],: data length in number of bytes
data[in],: pointer to the first byte of the data which has to be sent
Returns:
TRUE if successful, FALSE otherwise

BOOLEAN GatiManager::Deregister ( const UINT32 id )

Deregisters a GatiServer at the GatiManager and closes the remote connection to the GatiClient if there is one. If the deregistration was successful, the event OnDeregistration() will be fired.

Parameters:
server[in] : the reference to a GatiServer instance
Returns:
TRUE if successful, FALSE otherwise

GatiManager & GatiManager::GetInstance ( ) [static]

Returns the singleton instance of the class GatiManager.

Returns:
the pointer to singleton GatiManager instance.

virtual const WCHAR* GatiManager::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

virtual BootSequenceState GatiManager::InvokeAt ( ) const [inline, virtual]

InvokeAt denotes the system boot phase the SubSystem shall be initialized in.

Implements SubSystem.

virtual void GatiManager::OnPowerDown ( ) [inline, virtual]

This method will be invoked on system power down.

Reimplemented from SubSystem.

virtual void GatiManager::OnPowerUp ( ) [inline, virtual]

This method will be invoked on system power on.

Reimplemented from SubSystem.

BOOLEAN GatiManager::Register | ( | GatiServer *(*)() | createInstanceFunc,
 |  | const UINT32 | id
 | ) |

Registers a GatiServer at the GatiManager. If the registration was successful, the event OnRegistration() will be fired.

Parameters:
server[in] : the reference to a GatiServer instance
Returns:
TRUE if successful, FALSE otherwise

BOOLEAN GatiManager::SendData | ( | const GatiServer * | server,
 |  | const UINT32 | cmd,
 |  | const UINT32 | length,
 |  | const void * | data
 | ) |

Sends data from the GatiServer to the associated GatiClient.

Parameters:
server[in] : the reference to the sending GatiServer instance
cmd[in],: the command identifying the data.
length[in],: data length in number of bytes
data[in],: pointer to the first byte of the data which has to be sent
Returns:
TRUE if successful, FALSE otherwise

BOOLEAN GatiManager::ShutDown ( )

Shuts down the listening socket and terminates the main thread loop. If successful the event OnShutDown() will be fired.

Returns:
TRUE if successful, FALSE otherwise

BOOLEAN GatiManager::StartUp ( )

Sets up a listening socket and activates the main thread loop. If successful the event OnStartup() will be fired.

Returns:
TRUE if successful, FALSE otherwise

Friends And Related Function Documentation

friend class GatiManagerInternals [friend]

The documentation for this class was generated from the following files:
  • Devices/Win32/GatiManager.hpp
  • Devices/Win32/GatiManager.cpp
Generated on Wed Jan 25 01:16:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GatiServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GatiServer Class Reference

#include <Apoxi/Devices/Win32/GatiServer.hpp>

Inheritance diagram for GatiServer:

[legend]

Public Member Functions

virtual void | Destroy ()=0
virtual INT | GetId () const =0
virtual void | OnConnect ()=0
virtual void | OnDataReceived (UINT32 cmd, UINT32 length, void *data)=0
virtual void | OnDisconnect ()=0

Detailed Description

Abstract base class for GATI servers.

Member Function Documentation

virtual void GatiServer::Destroy ( ) [pure virtual]

Method will be called if the GatiSever has to be destroyed.

Implemented in AudioGatiServer.

virtual INT GatiServer::GetId ( ) const [pure virtual]

Returns a unique ID for the server-type. The IDs 0 to 99 are reserved for APOXI GATI servers:

  • 0 ... MMI Simulator server
  • 1 ... Aragon server

Implemented in AudioGatiServer.

virtual void GatiServer::OnConnect ( ) [pure virtual]

Method will be called if a connection to a GatiClient has been etablished successfully.

Implemented in AudioGatiServer.

virtual void GatiServer::OnDataReceived | ( | UINT32 | cmd,
 |  | UINT32 | length,
 |  | void * | data
 | ) | [pure virtual]

Method to react on incoming data (from the GatiClient to GatiServer).

Parameters:
cmd[in],: the command identifying the data.
length[in],: data length in number of bytes
data[in],: pointer to the buffer containing the received data

Implemented in AudioGatiServer.

virtual void GatiServer::OnDisconnect ( ) [pure virtual]

Method will be called if the connection to the GatiClient has been shut down or the connection was lost.

Implemented in AudioGatiServer.

The documentation for this class was generated from the following file:
  • Devices/Win32/GatiServer.hpp
Generated on Wed Jan 25 01:16:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GeneralCompoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GeneralCompoundItem Class Reference
[MultiMedia]

Represents a simple container for Bounded-Editor-Items. More...

#include <Apoxi/AddOns/MultiMedia/GeneralCompoundItem.hpp>

Inheritance diagram for GeneralCompoundItem:

[legend]
Collaboration diagram for GeneralCompoundItem:

[legend]

Public Types

enum | { ID = 12 }

Public Member Functions

virtual void | Clear ()
virtual CompoundItem * | Clone () const
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
virtual INT | GetId () const
virtual const AtomItem * | GetItem (INT index) const
virtual INT | GetItemCount () const
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT index, INT count) const
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual BOOLEAN | Merge (const CompoundItem &compound_item)
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | Split (INT index, CompoundItem **compound_item)
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=EditorDocument::WhitespaceWrap) const
virtual | ~GeneralCompoundItem ()

Static Public Member Functions

static GeneralCompoundItem * | CreateInstance ()
Creates and returns an object of this class.

Protected Member Functions

GeneralCompoundItem ()

Detailed Description

Represents a simple container for Bounded-Editor-Items.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from CompoundItem.

Constructor & Destructor Documentation

GeneralCompoundItem::~GeneralCompoundItem ( ) [virtual]

GeneralCompoundItem::GeneralCompoundItem ( ) [protected]

Member Function Documentation

void GeneralCompoundItem::Clear ( ) [virtual]

See also:
CompoundItem::Clear

Reimplemented from CompoundItem.

CompoundItem * GeneralCompoundItem::Clone ( ) const [virtual]

See also:
CompoundItem::Clone

Reimplemented from CompoundItem.

GeneralCompoundItem * GeneralCompoundItem::CreateInstance ( ) [static]

Creates and returns an object of this class.

void GeneralCompoundItem::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::Draw

Implements CompoundItem.

INT GeneralCompoundItem::GetId ( ) const [virtual]

See also:
CompoundItem::GetId()

Reimplemented from CompoundItem.

const AtomItem * GeneralCompoundItem::GetItem ( INT index ) const [virtual]

Returns the AtomItem at the given index or 0 if the index is not valid.

INT GeneralCompoundItem::GetItemCount ( ) const [virtual]

See also:
CompoundItem::GetItemCount

Implements CompoundItem.

XYDIM GeneralCompoundItem::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
CompoundItem::GetLineHeight

Implements CompoundItem.

XYDIM GeneralCompoundItem::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::GetLineWidth

Implements CompoundItem.

BOOLEAN GeneralCompoundItem::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
CompoundItem::InsertItem

Reimplemented from CompoundItem.

BOOLEAN GeneralCompoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from CompoundItem.

BOOLEAN GeneralCompoundItem::Merge ( const CompoundItem & compound_item ) [virtual]

See also:
CompoundItem::Merge

Reimplemented from CompoundItem.

BOOLEAN GeneralCompoundItem::RemoveItem ( INT index = -1 ) [virtual]

See also:
CompoundItem::RemoveItem

Reimplemented from CompoundItem.

BOOLEAN GeneralCompoundItem::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
CompoundItem::ReplaceItem

Reimplemented from CompoundItem.

BOOLEAN GeneralCompoundItem::Split | ( | INT | index,
 |  | CompoundItem ** | compound_item
 | ) | [virtual]

See also:
CompoundItem::Split

Reimplemented from CompoundItem.

INT GeneralCompoundItem::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = EditorDocument::WhitespaceWrap
 | ) | const [virtual]

See also:
CompoundItem::WrapLine

Implements CompoundItem.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/GeneralCompoundItem.hpp
  • AddOns/MultiMedia/GeneralCompoundItem.cpp
Generated on Wed Jan 25 01:16:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GenericAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GenericAudioDevice Class Reference

#include <Apoxi/Devices/Win32/GenericAudioDevice.hpp>

Inheritance diagram for GenericAudioDevice:

[legend]
Collaboration diagram for GenericAudioDevice:

[legend]

Public Types

enum AudioReturnCode {
AudioRcOk, AudioRcfunctionalityNotAvailable, AudioRcResourceInUse, AudioRcResourceConflict,
AudioRcHandleNotUsed, AudioRcNoHwSupport, AudioRcSharingViolation, AudioRcParameterOutOfRange,
AudioRcFormatNotSupported, AudioRcAudioDriverDisabled, AudioRcRingerToneError, AudioRcMp3Info,
AudioRcRadioInfo, AudioRcRingerToneFinish, AudioRcToneFinish, AudioRcDeviceNotInitialized,
AudioRcMimeTypeNotSupported, AudioRcDeviceAlreadyInitialized, AudioRcErrorAllocateHW, AudioRcFileNotFound,
AudioRcFileCloseError, AudioRcStartParamNotSet, AudioRcError
}
Return codes. More...
enum | Priority { PrioNormal, PrioHigh }
This structure defines the priorities. More...

Public Member Functions

GenericAudioDevice ()
UINT | GetId ()
virtual const WCHAR * | GetName () const
virtual AudioReturnCode | Init (Priority prio=PrioNormal)
BOOLEAN | IsInitialized ()
virtual AudioReturnCode | Release ()
Releases HW.
virtual AudioReturnCode | Start (BOOLEAN auto_release=TRUE)
virtual AudioReturnCode | Stop (UINT8 channel=0)
virtual | ~GenericAudioDevice ()

Protected Member Functions

AudioReturnCode | Convert2AudioReturnCode (INT error)
Map aud_drv return codes to AudioDevice::AudioReturnCode.
INT | ConvertPriority2INT (Priority prio)
Map Priority to INT for aud_priority_enum-cast.
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnToneStopped (AudioReturnCode return_code, INT nParams, UINT32 param_array[])

Protected Attributes

BOOLEAN | m_auto_release
TRUE HW is to be released as soon as the APOXI message AudioMsg::ID is received.
UINT8 | m_hw_handle
HW handle.

Detailed Description

The class GenericAudioDevice is the base class for audio device classes and describes the general interface.

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Member Enumeration Documentation

enum GenericAudioDevice::AudioReturnCode

Return codes.

Enumerator:
AudioRcOk | Success.
AudioRcfunctionalityNotAvailable | Functionality is not available.
AudioRcResourceInUse | Ressource is in use.
AudioRcResourceConflict | Ressource conflict.
AudioRcHandleNotUsed | Handle not used.
AudioRcNoHwSupport | No hardware support.
AudioRcSharingViolation | Sharing violaton.
AudioRcParameterOutOfRange | Paramter out of range.
AudioRcFormatNotSupported | Audioformat not supported.
AudioRcAudioDriverDisabled | Audiodriver is disabled.
AudioRcRingerToneError | Ringer tone error.
AudioRcMp3Info | MP3 info.
AudioRcRadioInfo | Radio info.
AudioRcRingerToneFinish | Ringer tone finished.
AudioRcToneFinish | Tone finished.
AudioRcDeviceNotInitialized | Device is not initialized.
AudioRcMimeTypeNotSupported | Mimi type not supported.
AudioRcDeviceAlreadyInitialized | Device is already initialized.
AudioRcErrorAllocateHW | Error allocate hardware.
AudioRcFileNotFound | File not found.
AudioRcFileCloseError | File close error.
AudioRcStartParamNotSet | Parameter not set.
AudioRcError | Common error.

enum GenericAudioDevice::Priority

This structure defines the priorities.

Enumerator:
PrioNormal
PrioHigh High priority.

Constructor & Destructor Documentation

GenericAudioDevice::GenericAudioDevice ( )

GenericAudioDevice::~GenericAudioDevice ( ) [virtual]

Member Function Documentation

GenericAudioDevice::AudioReturnCode GenericAudioDevice::Convert2AudioReturnCode ( INT error ) [protected]

Map aud_drv return codes to AudioDevice::AudioReturnCode.

INT GenericAudioDevice::ConvertPriority2INT ( Priority prio ) [protected]

Map Priority to INT for aud_priority_enum-cast.

UINT GenericAudioDevice::GetId ( )

Returns the Object Id.

Returns:
Object Id. Object Id used when asynchronous messages are received.
Use GetId to verify if an incoming message is related to the object instance.

const WCHAR * GenericAudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

Reimplemented in AmplifierAudioDevice, KeyToneAudioDevice, Mp3AudioDevice, RingerAudioDevice, SpeechAudioDevice, ToneAudioDevice, and VoiceMemoAudioDevice.

GenericAudioDevice::AudioReturnCode GenericAudioDevice::Init ( Priority prio = PrioNormal ) [virtual]

Allocates HW

Parameters:
prio Priority for HW allocation. Note: As the HW is limited only leave AudioDevice instance idealized state when used when audio is going to be used. Otherwise the AudioDevice instance may block other instances from accessing the audio HW.

BOOLEAN GenericAudioDevice::IsInitialized ( )

Returns if the AudioDevice is initialized.

Returns:
TRUE audio object is initialized

BOOLEAN GenericAudioDevice::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Implements Dispatcher.

void GenericAudioDevice::OnToneStopped | ( | AudioReturnCode | return_code,
 |  | INT | nParams,
 |  | UINT32 | param_array[]
 | ) | [protected, virtual]

Called when a tone stopped playing.

Parameters:
return_code | Async return code of operation.
nParams | number of elements in param_array.
param_array | array holding the parameters passed from SDL

GenericAudioDevice::AudioReturnCode GenericAudioDevice::Release ( ) [virtual]

Releases HW.

GenericAudioDevice::AudioReturnCode GenericAudioDevice::Start ( BOOLEAN auto_release = TRUE ) [virtual]

Plays the requested tone.
A message is send when the tone stops playing. The volume level will be last one selected AudioSetVolume method. If a tone is started before the present one is finished, the present tone will be disabled and the new tone is started, i.e. no suspend/resume functionality.
Note: Release the HW by using Release() to enable other instances of to access the HW.

Parameters:
auto_release,: If TRUE Release is called after the tone stops playing.
Returns:
Result of operation.

Reimplemented in AmplifierAudioDevice, KeyToneAudioDevice, Mp3AudioDevice, RingerAudioDevice, SpeechAudioDevice, ToneAudioDevice, and VoiceMemoAudioDevice.

GenericAudioDevice::AudioReturnCode GenericAudioDevice::Stop ( UINT8 channel = 0 ) [virtual]

Stops the audio device.

Parameters:
channel Channel to stop. Channel applies only if to SMAF-phrase format tones are played (audio device ringer).

Reimplemented in AmplifierAudioDevice, KeyToneAudioDevice, Mp3AudioDevice, RingerAudioDevice, SpeechAudioDevice, ToneAudioDevice, and VoiceMemoAudioDevice.

Field Documentation

BOOLEAN GenericAudioDevice::m_auto_release [protected]

TRUE HW is to be released as soon as the APOXI message AudioMsg::ID is received.

UINT8 GenericAudioDevice::m_hw_handle [protected]

HW handle.

The documentation for this class was generated from the following files:
  • Devices/Win32/GenericAudioDevice.hpp
  • Devices/Win32/GenericAudioDevice.cpp
Generated on Wed Jan 25 01:17:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GenericFeatureData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GenericFeatureData Class Reference
[Audio]

#include <Apoxi/Audio/GenericFeatureData.hpp>

Inheritance diagram for GenericFeatureData:

[legend]
Collaboration diagram for GenericFeatureData:

[legend]

Public Member Functions

virtual GenericObject * | Copy () const
Creates a copy of the object itself.
GenericFeatureData (const GenericFeatureData &)
GenericFeatureData ()
Constructor of the abstract class GenericObject.
const AudioActiveReference * | GetActiveReference () const
Should be used by audio devices to identify the sound the feature has to be executed for.
void * | GetDataPtr () const
Should be used to retrieve any kind of data.
const GenericFeatureData::GenericTrackInfo * | GetGenericTrackInfo () const
Should be used be the caller of the feature to get the track information.
UINT32 | GetNumber () const
Should be used to retrieve numbers.
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself.
void | SetActiveReference (const AudioActiveReference *active_ref)
Should be used by the caller to identify the sound the feature has to be executed for.
void | SetDataPtr (void *data)
Should be used to pass any kind of data.
void | SetGenericTrackInfo (const GenericFeatureData::GenericTrackInfo &track_info)
Should be used by audio devices which provide track information of sounds.
void | SetNumber (UINT32 data)
Should be used to pass numbers.
virtual | ~GenericFeatureData ()
Destructor of the abstract class GenericObject.

Data Structures

struct | GenericTrackInfo
This structure is used for setting/getting the track information of a sound. More...

Detailed Description

This class is used to pass and get back data when executing features.

Constructor & Destructor Documentation

GenericFeatureData::GenericFeatureData ( )

Constructor of the abstract class GenericObject.

The documentation for this class was generated from the following files:
  • Audio/GenericFeatureData.hpp
  • Audio/GenericFeatureData.cpp
Generated on Wed Jan 25 01:17:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GenericFeatureData::GenericTrackInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
GenericFeatureData::GenericTrackInfo

GenericFeatureData::GenericTrackInfo Struct Reference
[Audio]

This structure is used for setting/getting the track information of a sound. More...

#include <Apoxi/Audio/GenericFeatureData.hpp>

Collaboration diagram for GenericFeatureData::GenericTrackInfo:

[legend]

Data Fields

WString m_album
WString m_artist
WString m_author
WString m_comment
WString m_composer
WString m_copyright
WString m_description
WString m_duration
WString m_genre
WString m_original_artist
WString m_rating
WString m_song_name
WString m_title
WString m_track
WString m_url
WString m_year

Detailed Description

This structure is used for setting/getting the track information of a sound.

Field Documentation

WString GenericFeatureData::GenericTrackInfo::m_title

The documentation for this struct was generated from the following file:
  • Audio/GenericFeatureData.hpp
Generated on Wed Jan 25 01:17:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GenericObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GenericObject Class Reference

#include <Apoxi/Auxiliary/GenericObject.hpp>

Inheritance diagram for GenericObject:

[legend]

Public Member Functions

virtual GenericObject * | Copy () const =0
Creates a copy of the object itself, must be overwritten in the derived class.
GenericObject (const GenericObject &)
GenericObject ()
Constructor of the abstract class GenericObject.
virtual GenericTypeId | GetTypeId ()=0
Returns the identity of the class, must be overwritten by the derived class.
virtual BOOLEAN | IsEqual (GenericObject *object)=0
Compares the object parameter with the object instance itself, must be overwritten in the derived class.
BOOLEAN | IsSameType (GenericObject *object)
Compares the types of the object parameter and the object itself.
virtual | ~GenericObject ()
Destructor of the abstract class GenericObject.

Detailed Description

GenericObject is an abstract base class, which can be used inside DataItems. Therefore derived classes can be used to transport data into and out of providers.

Constructor & Destructor Documentation

GenericObject::GenericObject ( )

Constructor of the abstract class GenericObject.

GenericObject::GenericObject ( const GenericObject & )

GenericObject::~GenericObject ( ) [virtual]

Destructor of the abstract class GenericObject.

Member Function Documentation

virtual GenericObject* GenericObject::Copy ( ) const [pure virtual]

Creates a copy of the object itself, must be overwritten in the derived class.

Implemented in CompoundSmsItem, CompoundTpduItem, MenuDescObj, ItemObj, MenuIdObj, ImgObtObj, GenericFeatureData, BlobObject, BlobPtr, RegBlobObject, BtDeviceAddressGenericObject, and ImageRefGenContainer.

virtual GenericTypeId GenericObject::GetTypeId ( ) [pure virtual]

Returns the identity of the class, must be overwritten by the derived class.

Implemented in CompoundSmsItem, CompoundTpduItem, MenuDescObj, ItemObj, MenuIdObj, ImgObtObj, GenericFeatureData, BlobObject, BlobPtr, RegBlobObject, BtDeviceAddressGenericObject, and ImageRefGenContainer.

virtual BOOLEAN GenericObject::IsEqual ( GenericObject * object ) [pure virtual]

Compares the object parameter with the object instance itself, must be overwritten in the derived class.

Implemented in CompoundSmsItem, CompoundTpduItem, MenuDescObj, ItemObj, MenuIdObj, ImgObtObj, GenericFeatureData, BlobObject, BlobPtr, RegBlobObject, BtDeviceAddressGenericObject, and ImageRefGenContainer.

BOOLEAN GenericObject::IsSameType ( GenericObject * object )

Compares the types of the object parameter and the object itself.

The documentation for this class was generated from the following files:
  • Auxiliary/GenericObject.hpp
  • Auxiliary/GenericObject.cpp
Generated on Wed Jan 25 01:17:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GenericWorkerTask Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GenericWorkerTask Class Reference
[Kernel]

#include <Apoxi/Kernel/GenericWorkerTask.hpp>

Inheritance diagram for GenericWorkerTask:

[legend]
Collaboration diagram for GenericWorkerTask:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual BootSequenceState | InvokeAt () const
BOOLEAN | IsBusy () const
virtual void | OnPowerDown ()
virtual void | OnPowerUp ()
virtual INT | ThreadFn ()
virtual | ~GenericWorkerTask ()

Static Public Member Functions

static GenericWorkerTask & | GetInstance ()

Friends

class | Os
class | Threadlet
class | WorkerTaskObtainer

Data Structures

class | WorkerTaskObtainer

Detailed Description

The generic worker tasks runs on a lower priority than the rest of the system and applications can submit work packages (= threadlets) to the input queue of this task. The queue will be treated as FIFO queue. While the threadlet is executed, the application can decide to wait synchronously by the active wait mechanism (see AppContainer::Wait()) or just start the threadlet asynchronously.
See also:
Threadlet

Constructor & Destructor Documentation

GenericWorkerTask::~GenericWorkerTask ( ) [virtual]

Member Function Documentation

static GenericWorkerTask& GenericWorkerTask::GetInstance ( ) [inline, static]

const WCHAR * GenericWorkerTask::GetName ( ) const [virtual]

See also:
SubSystem::GetName

Reimplemented from Thread.

SubSystemManager::BootSequenceState GenericWorkerTask::InvokeAt ( ) const [virtual]

See also:
SubSystem::InvokeAt

Implements SubSystem.

BOOLEAN GenericWorkerTask::IsBusy ( ) const

Returns:
TRUE, if the GenericWorkerTask is busy at the moment. Busy means, that the list of Threadlets is not empty.

void GenericWorkerTask::OnPowerDown ( ) [virtual]

See also:
SubSystem::OnPowerDown

Reimplemented from SubSystem.

void GenericWorkerTask::OnPowerUp ( ) [virtual]

See also:
SubSystem::OnPowerUp

Reimplemented from SubSystem.

INT GenericWorkerTask::ThreadFn ( ) [virtual]

See also:
Thread::ThreadFn

Implements Thread.

Friends And Related Function Documentation

friend class Os [friend]

Reimplemented from Thread.

friend class Threadlet [friend]

friend class WorkerTaskObtainer [friend]

The documentation for this class was generated from the following files:
  • Kernel/GenericWorkerTask.hpp
  • Kernel/GenericWorkerTask.cpp
Generated on Wed Jan 25 01:17:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GetFocusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GetFocusMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for GetFocusMsg:

[legend]
Collaboration diagram for GetFocusMsg:

[legend]

Public Types

enum | { ID = 1000 }

Public Member Functions

virtual Message * | Clone () const
GetFocusMsg (Control *control)
virtual const MsgMetaData & | GetMetaData () const
virtual | ~GetFocusMsg ()

Detailed Description

This message is sent before an inactive control gets focused.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GetFocusMsg::GetFocusMsg ( Control * control )

GetFocusMsg::~GetFocusMsg ( ) [virtual]

Member Function Documentation

Message * GetFocusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & GetFocusMsg::GetMetaData ( ) const [virtual]

Implements ControlMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:17:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GetInkeyReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GetInkeyReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for GetInkeyReqArg:

[legend]
Collaboration diagram for GetInkeyReqArg:

[legend]

Public Types

enum | { ID = 1309 }

Public Member Functions

const SimIconIdentifier & | GetIcon () const
GetInkeyReqArg ()
const SimGetInkeyOptions & | GetOptions () const
const SimTextString & | GetTextString () const
const SimTkTransactionId & | GetTid () const
void | SetIcon (const SimIconIdentifier &icon)
void | SetOptions (const SimGetInkeyOptions &options)
void | SetTextString (const SimTextString &text_string)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const GetInkeyReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

GetInkeyReqArg: reflects arguments of signal SI_GET_INKEY_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GetInkeyReqArg::GetInkeyReqArg ( )

Member Function Documentation

const GetInkeyReqArg & GetInkeyReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconIdentifier& GetInkeyReqArg::GetIcon ( ) const [inline]

const SimGetInkeyOptions& GetInkeyReqArg::GetOptions ( ) const [inline]

const SimTextString& GetInkeyReqArg::GetTextString ( ) const [inline]

const SimTkTransactionId& GetInkeyReqArg::GetTid ( ) const [inline]

void GetInkeyReqArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void GetInkeyReqArg::SetOptions ( const SimGetInkeyOptions & options ) [inline]

void GetInkeyReqArg::SetTextString ( const SimTextString & text_string ) [inline]

void GetInkeyReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:17:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GetInkeyRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GetInkeyRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for GetInkeyRspArg:

[legend]
Collaboration diagram for GetInkeyRspArg:

[legend]

Public Types

enum | { ID = 2309 }

Public Member Functions

const DataCodingScheme & | GetDcs () const
GetInkeyRspArg ()
GetInkeyRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause, const WString &text, const DataCodingScheme &dcs, const SimKey &key=SimKeyInvalid)
const SimKey & | GetKey () const
const ProactiveCause & | GetProactiveCause () const
const WString & | GetText () const
const SimTkTransactionId & | GetTid () const
void | SetDcs (const DataCodingScheme &dcs)
void | SetKey (const SimKey &key)
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetText (const WString &text)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const GetInkeyRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

GetInkeyRspArg: reflects arguments of signal SI_GET_INKEY_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GetInkeyRspArg::GetInkeyRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause,
 |  | const WString & | text,
 |  | const DataCodingScheme & | dcs,
 |  | const SimKey & | key = SimKeyInvalid
 | ) |

GetInkeyRspArg::GetInkeyRspArg ( )

Member Function Documentation

const GetInkeyRspArg & GetInkeyRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const DataCodingScheme& GetInkeyRspArg::GetDcs ( ) const [inline]

const SimKey& GetInkeyRspArg::GetKey ( ) const [inline]

const ProactiveCause& GetInkeyRspArg::GetProactiveCause ( ) const [inline]

const WString& GetInkeyRspArg::GetText ( ) const [inline]

const SimTkTransactionId& GetInkeyRspArg::GetTid ( ) const [inline]

void GetInkeyRspArg::SetDcs ( const DataCodingScheme & dcs ) [inline]

void GetInkeyRspArg::SetKey ( const SimKey & key ) [inline]

void GetInkeyRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void GetInkeyRspArg::SetText ( const WString & text ) [inline]

void GetInkeyRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:17:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GetInputReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GetInputReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for GetInputReqArg:

[legend]
Collaboration diagram for GetInputReqArg:

[legend]

Public Types

enum | { ID = 1308 }

Public Member Functions

const SimTextString & | GetDefaultTextString () const
const SimIconIdentifier & | GetIcon () const
GetInputReqArg ()
INT | GetMaxInputLen () const
INT | GetMinInputLen () const
const SimGetInputOptions & | GetOptions () const
const SimTextString & | GetTextString () const
const SimTkTransactionId & | GetTid () const
void | SetDefaultTextString (const SimTextString &default_text_string)
void | SetIcon (const SimIconIdentifier &icon)
void | SetMaxInputLen (INT max_input_len)
void | SetMinInputLen (INT min_input_len)
void | SetOptions (const SimGetInputOptions &options)
void | SetTextString (const SimTextString &text_string)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const GetInputReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

GetInputReqArg: reflects arguments of signal SI_GET_INPUT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GetInputReqArg::GetInputReqArg ( )

Member Function Documentation

const GetInputReqArg & GetInputReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTextString& GetInputReqArg::GetDefaultTextString ( ) const [inline]

const SimIconIdentifier& GetInputReqArg::GetIcon ( ) const [inline]

INT GetInputReqArg::GetMaxInputLen ( ) const [inline]

INT GetInputReqArg::GetMinInputLen ( ) const [inline]

const SimGetInputOptions& GetInputReqArg::GetOptions ( ) const [inline]

const SimTextString& GetInputReqArg::GetTextString ( ) const [inline]

const SimTkTransactionId& GetInputReqArg::GetTid ( ) const [inline]

void GetInputReqArg::SetDefaultTextString ( const SimTextString & default_text_string ) [inline]

void GetInputReqArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void GetInputReqArg::SetMaxInputLen ( INT max_input_len ) [inline]

void GetInputReqArg::SetMinInputLen ( INT min_input_len ) [inline]

void GetInputReqArg::SetOptions ( const SimGetInputOptions & options ) [inline]

void GetInputReqArg::SetTextString ( const SimTextString & text_string ) [inline]

void GetInputReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:17:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GetInputRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GetInputRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for GetInputRspArg:

[legend]
Collaboration diagram for GetInputRspArg:

[legend]

Public Types

enum | { ID = 2308 }

Public Member Functions

const DataCodingScheme & | GetDcs () const
GetInputRspArg ()
GetInputRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause, const WString &text, const DataCodingScheme &dcs, BOOLEAN packed)
const ProactiveCause & | GetProactiveCause () const
const WString & | GetText () const
const SimTkTransactionId & | GetTid () const
BOOLEAN | IsPacked () const
void | SetDcs (const DataCodingScheme &dcs)
void | SetPacked (BOOLEAN packed)
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetText (const WString &text)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const GetInputRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

GetInputRspArg: reflects arguments of signal SI_GET_INPUT_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GetInputRspArg::GetInputRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause,
 |  | const WString & | text,
 |  | const DataCodingScheme & | dcs,
 |  | BOOLEAN | packed
 | ) |

GetInputRspArg::GetInputRspArg ( )

Member Function Documentation

const GetInputRspArg & GetInputRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const DataCodingScheme& GetInputRspArg::GetDcs ( ) const [inline]

const ProactiveCause& GetInputRspArg::GetProactiveCause ( ) const [inline]

const WString& GetInputRspArg::GetText ( ) const [inline]

const SimTkTransactionId& GetInputRspArg::GetTid ( ) const [inline]

BOOLEAN GetInputRspArg::IsPacked ( ) const [inline]

void GetInputRspArg::SetDcs ( const DataCodingScheme & dcs ) [inline]

void GetInputRspArg::SetPacked ( BOOLEAN packed ) [inline]

void GetInputRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void GetInputRspArg::SetText ( const WString & text ) [inline]

void GetInputRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:17:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GetPasswordMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GetPasswordMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for GetPasswordMsg:

[legend]
Collaboration diagram for GetPasswordMsg:

[legend]

Public Types

enum | { ID = 18559 }

Public Member Functions

void | Abort ()
virtual Message * | Clone () const
CallBarringHandler * | GetHandler () const
virtual const MsgMetaData & | GetMetaData () const
GetPasswordMsg (ExecutionContext *context, const Tipd &tipd, CallBarringHandler *handler)
const Tipd & | GetTipd () const
void | SendPassword (const WString &password)
virtual | ~GetPasswordMsg ()

Detailed Description

Sent when the network requests a password

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GetPasswordMsg::GetPasswordMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | CallBarringHandler * | handler
 | ) |

GetPasswordMsg::~GetPasswordMsg ( ) [virtual]

Member Function Documentation

void GetPasswordMsg::Abort ( ) [inline]

Message * GetPasswordMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

CallBarringHandler* GetPasswordMsg::GetHandler ( ) const [inline]

const MsgMetaData & GetPasswordMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& GetPasswordMsg::GetTipd ( ) const [inline]

void GetPasswordMsg::SendPassword ( const WString & password ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:17:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GifImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GifImage Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/GifImage.hpp>

Inheritance diagram for GifImage:

[legend]
Collaboration diagram for GifImage:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

virtual const BinData * | GetBinData () const
Returns the bin data object, which contains the GIF data.
virtual UINT32 | GetFrameDelay (INT frame_idx) const
virtual INT | GetNextFrame (INT frame_idx) const
GifImage (BinData *bin_data, BOOLEAN *success=0)
GifImage ()
void | Init (BinData *bin_data, BOOLEAN *success=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual | ~GifImage ()

Protected Member Functions

virtual void * | BeginScanlineDrawing (INT frame_idx=0) const
virtual void | DrawScanline (void *context, DeviceContext *dc, XYDIM x, XYDIM y, INT scanline_idx, INT old_scanline_idx) const
virtual void | EndScanlineDrawing (void *context) const
virtual XYDIM | GetFrameHeight (void *context) const
virtual XYDIM | GetFrameWidth (void *context) const
virtual XYDIM | GetFrameXPos (void *context) const
virtual XYDIM | GetScanlineDiff (void *context, INT scanline_idx, INT old_scanline_idx) const
virtual ColorValue | GetTransparentColor (void *context) const
virtual BOOLEAN | IsFullTraversingEnabled (void *context) const
virtual BOOLEAN | IsTransparent (void *context) const

Friends

class | GifDecoder

Detailed Description

Represents a GIF87a or GIF89a image.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Image.

Constructor & Destructor Documentation

GifImage::GifImage ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

GifImage::GifImage | ( | BinData * | bin_data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
bin_data | Pointer to a binary data stream which contains the GIF-data. After passing the binary data stream, the stream is obtained by the GIF-image and hence automatically released in the destructor of the GIF-image.
success | Output-parameter, which indicates whether the initialization has been successful.

GifImage::~GifImage ( ) [virtual]

Member Function Documentation

void * GifImage::BeginScanlineDrawing ( INT frame_idx = 0 ) const [protected, virtual]

See also:
Image::BeginScanlineDrawing

Reimplemented from Image.

void GifImage::DrawScanline | ( | void * | context,
 |  | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

See also:
Image::DrawScanline

Reimplemented from Image.

void GifImage::EndScanlineDrawing ( void * context ) const [protected, virtual]

See also:
Image::EndScanlineDrawing

Reimplemented from Image.

const BinData * GifImage::GetBinData ( ) const [virtual]

Returns the bin data object, which contains the GIF data.

Reimplemented from Image.

UINT32 GifImage::GetFrameDelay ( INT frame_idx ) const [virtual]

See also:
Image::GetFrameDelay

Implements Image.

XYDIM GifImage::GetFrameHeight ( void * context ) const [protected, virtual]

See also:
Image::GetFrameHeight

Reimplemented from Image.

XYDIM GifImage::GetFrameWidth ( void * context ) const [protected, virtual]

See also:
Image::GetFrameWidth

Reimplemented from Image.

XYDIM GifImage::GetFrameXPos ( void * context ) const [protected, virtual]

See also:
Image::GetFrameXPos

Reimplemented from Image.

INT GifImage::GetNextFrame ( INT frame_idx ) const [virtual]

See also:
Image::GetNextFrame

Implements Image.

XYDIM GifImage::GetScanlineDiff | ( | void * | context,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

See also:
Image::GetScanlineDiff

Reimplemented from Image.

ColorValue GifImage::GetTransparentColor ( void * context ) const [protected, virtual]

See also:
Image::GetTransparentColor

Reimplemented from Image.

void GifImage::Init | ( | BinData * | bin_data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
bin_data | Pointer to a binary data stream which contains the GIF-data. After passing the binary data stream, the stream is obtained by the GIF-image and hence automatically released in the destructor of the GIF-image.
success | Output-parameter, which indicates whether the initialization has been successful.

BOOLEAN GifImage::IsFullTraversingEnabled ( void * context ) const [protected, virtual]

Returns TRUE, if the GIF is interlaced.

See also:
Image::ForceFullScanlineTraversing

Reimplemented from Image.

BOOLEAN GifImage::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Image.

BOOLEAN GifImage::IsTransparent ( void * context ) const [protected, virtual]

See also:
Image::IsTransparent

Reimplemented from Image.

Friends And Related Function Documentation

friend class GifDecoder [friend]

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/GifImage.hpp
  • AddOns/MultiMedia/GifImage.cpp
Generated on Wed Jan 25 01:17:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlassPane Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GlassPane Class Reference
[GUI]

#include <Apoxi/Gui/GlassPane.hpp>

Collaboration diagram for GlassPane:

[legend]

Public Member Functions

void | Add (PaneObject *pane_object)
BOOLEAN | Contains (const PaneObject *pane_object) const
virtual void | Draw (DeviceContext *dc) const
GlassPane ()
BOOLEAN | IsEnabled () const
void | Remove (PaneObject *pane_object)
void | RemoveAllPaneObjects ()
void | SetEnabled (BOOLEAN enabled)
virtual | ~GlassPane ()

Detailed Description

A glasspane collects graphical objects which stay above all windows (e. g. a battery-indicator or a mouse-pointer). A graphical object is described by a pane-object.
See also:
PaneObject

Constructor & Destructor Documentation

GlassPane::GlassPane ( )

GlassPane::~GlassPane ( ) [virtual]

Member Function Documentation

void GlassPane::Add ( PaneObject * pane_object )

BOOLEAN GlassPane::Contains ( const PaneObject * pane_object ) const

void GlassPane::Draw ( DeviceContext * dc ) const [virtual]

Draws all pane-object which have been added to the glass-pane. The drawing is not done if GlassPane::IsEnabled returns FALSE.

BOOLEAN GlassPane::IsEnabled ( ) const [inline]

void GlassPane::Remove ( PaneObject * pane_object )

void GlassPane::RemoveAllPaneObjects ( )

void GlassPane::SetEnabled ( BOOLEAN enabled ) [inline]

The documentation for this class was generated from the following files:
  • Gui/GlassPane.hpp
  • Gui/GlassPane.cpp
Generated on Wed Jan 25 01:17:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpAidDataRequests Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpAidDataRequests Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/AidDataRequests.hpp>

Collaboration diagram for GltpAidDataRequests:

[legend]

Public Member Functions

void | FormAidingRequest (INT32 init_lat, INT32 init_long, BOOLEAN ms_mode)
void | FormMsmtRequest (const MeasurementData &msr_data)
void | FormPosnRequest (BYTE *posn_data)
const GltpAidingRequest & | GetAidingRequest () const
const GltpHelloRequest & | GetHelloRequest () const
const GltpMsmtRequest & | GetMsmtRequest () const
const GltpPositionRequest & | GetPosnRequest () const
GltpAidDataRequests ()
Constructor.
void | SetUnitId (UINT16 unit_id)
Since a new unit-id is being set, this method reconstructs the.
~GltpAidDataRequests ()
Destructor.

Constructor & Destructor Documentation

GltpAidDataRequests::GltpAidDataRequests ( )

Constructor.

GltpAidDataRequests::~GltpAidDataRequests ( )

Destructor.

Member Function Documentation

void GltpAidDataRequests::FormAidingRequest | ( | INT32 | init_lat,
 |  | INT32 | init_long,
 |  | BOOLEAN | ms_mode
 | ) |

This method constructs the 'Aiding' request to be sent to the GL server

void GltpAidDataRequests::FormMsmtRequest ( const MeasurementData & msr_data )

This method constructs the 'Measurement' request to be sent to the GL server

void GltpAidDataRequests::FormPosnRequest ( BYTE * posn_data )

This method constructs the 'Position' request to be sent to the GL server

const GltpAidingRequest& GltpAidDataRequests::GetAidingRequest ( ) const [inline]

const GltpHelloRequest& GltpAidDataRequests::GetHelloRequest ( ) const [inline]

const GltpMsmtRequest& GltpAidDataRequests::GetMsmtRequest ( ) const [inline]

const GltpPositionRequest& GltpAidDataRequests::GetPosnRequest ( ) const [inline]

void GltpAidDataRequests::SetUnitId ( UINT16 unit_id )

Since a new unit-id is being set, this method reconstructs the.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/AidDataRequests.hpp
  • AddOns/Lcs/GLTP/AidDataRequests.cpp
Generated on Wed Jan 25 01:17:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpAidingDataWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpAidingDataWin Class Reference

#include <Applications/LcsTransports/Settings/AidingDataWin.hpp>

Collaboration diagram for GltpAidingDataWin:

[legend]

Public Member Functions

GltpAidingDataWin ()
Contructor.
void | Init ()
virtual | ~GltpAidingDataWin ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnOpen ()

Detailed Description

This window takes the following inputs from the user: 1. Initial latitude 2. Initial longitude 3. Unit-Id 4. Mode(MS-based or Assisted) 5. Repeat interval for GLTP requests

Constructor & Destructor Documentation

GltpAidingDataWin::GltpAidingDataWin ( )

Contructor.

GltpAidingDataWin::~GltpAidingDataWin ( ) [virtual]

Destructor.

Member Function Documentation

void GltpAidingDataWin::Init ( )

BOOLEAN GltpAidingDataWin::OnCancel ( ) [protected, virtual]

BOOLEAN GltpAidingDataWin::OnConfirm ( ) [protected, virtual]

void GltpAidingDataWin::OnLayoutClient ( ) [protected, virtual]

void GltpAidingDataWin::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/LcsTransports/Settings/AidingDataWin.hpp
  • Applications/LcsTransports/Settings/AidingDataWin.cpp
Generated on Wed Jan 25 01:17:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpAidingRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpAidingRequest Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/AidDataRequests.hpp>

Inheritance diagram for GltpAidingRequest:

[legend]
Collaboration diagram for GltpAidingRequest:

[legend]

Public Member Functions

void | FormRequest (INT32 init_lat, INT32 init_long, BOOLEAN ms_mode)
virtual const BYTE * | GetRequest () const
Returns a pointer to the request.
virtual INT | GetSize () const
Returns the request size in bytes.
GltpAidingRequest ()
Constructor.
virtual | ~GltpAidingRequest ()
Destructor.

Constructor & Destructor Documentation

GltpAidingRequest::GltpAidingRequest ( )

Constructor.

GltpAidingRequest::~GltpAidingRequest ( ) [virtual]

Destructor.

Member Function Documentation

void GltpAidingRequest::FormRequest | ( | INT32 | init_lat,
 |  | INT32 | init_long,
 |  | BOOLEAN | ms_mode
 | ) |

virtual const BYTE* GltpAidingRequest::GetRequest ( ) const [inline, virtual]

Returns a pointer to the request.

Implements GltpRequest.

virtual INT GltpAidingRequest::GetSize ( ) const [inline, virtual]

Returns the request size in bytes.

Implements GltpRequest.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/AidDataRequests.hpp
  • AddOns/Lcs/GLTP/AidDataRequests.cpp
Generated on Wed Jan 25 01:17:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpAssistanceData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpAssistanceData Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/AssistanceData.hpp>

Collaboration diagram for GltpAssistanceData:

[legend]

Public Member Functions

BOOLEAN | Append (const BYTE *ad_buf, INT size)
const BYTE * | GetBuffer () const
const ReferenceLocation & | GetReferenceLocation () const
This method returns the reference location.
const ReferenceTime & | GetReferenceTime () const
This method returns the reference time.
INT | GetSize () const
This method returns the size of the assistance data.
GltpAssistanceData ()
Constructor.
BOOLEAN | IsAidingStale () const
void | SetAidingStale (BOOLEAN stale)
void | SetReferenceLocation (const ReferenceLocation &ref_loc)
This method sets the reference location.
void | SetReferenceTime (const ReferenceTime &ref_time)
This method sets the reference time.
~GltpAssistanceData ()
Destructor.

Constructor & Destructor Documentation

GltpAssistanceData::GltpAssistanceData ( )

Constructor.

GltpAssistanceData::~GltpAssistanceData ( )

Destructor.

Member Function Documentation

BOOLEAN GltpAssistanceData::Append | ( | const BYTE * | ad_buf,
 |  | INT | size
 | ) |

This method appends the contents of the new assistance data packet to the buffer

const BYTE* GltpAssistanceData::GetBuffer ( ) const [inline]

This method returns the pointer to the buffer that contains the assistance data

const ReferenceLocation& GltpAssistanceData::GetReferenceLocation ( ) const [inline]

This method returns the reference location.

const ReferenceTime& GltpAssistanceData::GetReferenceTime ( ) const [inline]

This method returns the reference time.

INT GltpAssistanceData::GetSize ( ) const [inline]

This method returns the size of the assistance data.

BOOLEAN GltpAssistanceData::IsAidingStale ( ) const [inline]

void GltpAssistanceData::SetAidingStale ( BOOLEAN stale ) [inline]

This marks the aiding as stale whenever the AGPS stack indicates so in the 'status' field of measurement data

void GltpAssistanceData::SetReferenceLocation ( const ReferenceLocation & ref_loc ) [inline]

This method sets the reference location.

void GltpAssistanceData::SetReferenceTime ( const ReferenceTime & ref_time ) [inline]

This method sets the reference time.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/AssistanceData.hpp
  • AddOns/Lcs/GLTP/AssistanceData.cpp
Generated on Wed Jan 25 01:17:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpConnApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpConnApp Class Reference

This class handles the socket based communication for Gltp protocol. More...

#include <Applications/LcsTransports/GLTP/GltpConnApp.hpp>

Inheritance diagram for GltpConnApp:

[legend]
Collaboration diagram for GltpConnApp:

[legend]

Public Member Functions

~GltpConnApp ()
Destructor.

Static Public Member Functions

static GltpConnApp * | GetInstance ()
The only method to get an instance of this class.

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnStartup ()

Detailed Description

This class handles the socket based communication for Gltp protocol.

Constructor & Destructor Documentation

GltpConnApp::~GltpConnApp ( )

Destructor.

Member Function Documentation

GltpConnApp * GltpConnApp::GetInstance ( ) [static]

The only method to get an instance of this class.

void GltpConnApp::OnClose ( ) [protected, virtual]

Is called, if the application is closed.

Reimplemented from Application.

BOOLEAN GltpConnApp::OnMessage ( const Message & msg ) [protected, virtual]

Every message send to an application may be dispatched in OnMessage.

See also:
Dispatcher::OnMessage

Reimplemented from Application.

void GltpConnApp::OnOpen ( ) [protected, virtual]

Is called after the default initialization process.

Reimplemented from Application.

void GltpConnApp::OnStartup ( ) [protected, virtual]

Is called after attaching the application to an AppContainer for pre-start initialization.

Reimplemented from Application.

The documentation for this class was generated from the following files:
  • Applications/LcsTransports/GLTP/GltpConnApp.hpp
  • Applications/LcsTransports/GLTP/GltpConnApp.cpp
Generated on Wed Jan 25 01:17:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpConnStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpConnStatusMsg Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpMsgTypes.hpp>

Inheritance diagram for GltpConnStatusMsg:

[legend]
Collaboration diagram for GltpConnStatusMsg:

[legend]

Public Types

enum | { ID = 4232 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const GltpConnStatus & | GetStatus () const
GltpConnStatusMsg (ExecutionContext *context, const GltpConnStatus &status)
virtual | ~GltpConnStatusMsg ()

Detailed Description

This message sends the connection status information to the GLTP connection application

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GltpConnStatusMsg::GltpConnStatusMsg | ( | ExecutionContext * | context,
 |  | const GltpConnStatus & | status
 | ) |

GltpConnStatusMsg::~GltpConnStatusMsg ( ) [virtual]

Member Function Documentation

Message * GltpConnStatusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & GltpConnStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const GltpConnStatus& GltpConnStatusMsg::GetStatus ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpMsgTypes.hpp
  • AddOns/Lcs/GLTP/GltpMsgTypes.cpp
Generated on Wed Jan 25 01:17:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpHelloRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpHelloRequest Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/AidDataRequests.hpp>

Inheritance diagram for GltpHelloRequest:

[legend]
Collaboration diagram for GltpHelloRequest:

[legend]

Public Member Functions

void | FormRequest (UINT16 unit_id)
virtual const BYTE * | GetRequest () const
Returns a pointer to the request.
virtual INT | GetSize () const
Returns the request size in bytes.
GltpHelloRequest ()
Constructor.
virtual | ~GltpHelloRequest ()
Destructor.

Constructor & Destructor Documentation

GltpHelloRequest::GltpHelloRequest ( )

Constructor.

GltpHelloRequest::~GltpHelloRequest ( ) [virtual]

Destructor.

Member Function Documentation

void GltpHelloRequest::FormRequest ( UINT16 unit_id )

virtual const BYTE* GltpHelloRequest::GetRequest ( ) const [inline, virtual]

Returns a pointer to the request.

Implements GltpRequest.

virtual INT GltpHelloRequest::GetSize ( ) const [inline, virtual]

Returns the request size in bytes.

Implements GltpRequest.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/AidDataRequests.hpp
  • AddOns/Lcs/GLTP/AidDataRequests.cpp
Generated on Wed Jan 25 01:17:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpMsgProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpMsgProcessor Class Reference

This class sends the Gltp requests to the Lcs Stack. More...

#include <Apoxi/AddOns/Lcs/GLTP/GltpMsgProcessor.hpp>

Inheritance diagram for GltpMsgProcessor:

[legend]
Collaboration diagram for GltpMsgProcessor:

[legend]

Static Public Member Functions

static void | ProcessMeasurementDataReq (const BYTE *ad_buf, INT size, BOOLEAN forced_fix=FALSE)
Operations.
static void | ProcessReferenceTimeReq (const ReferenceTime &ref_time)
static void | ProcessRefLocReq (const ReferenceLocation &ref_loc)

Detailed Description

This class sends the Gltp requests to the Lcs Stack.

Member Function Documentation

void GltpMsgProcessor::ProcessMeasurementDataReq | ( | const BYTE * | ad_buf,
 |  | INT | size,
 |  | BOOLEAN | forced_fix = FALSE
 | ) | [static]

Operations.

This method forms a MNMI_LCS_GLTP_MSR_REQ SDL signal from the parameters given and sends it to the Lcs Stack

void GltpMsgProcessor::ProcessReferenceTimeReq ( const ReferenceTime & ref_time ) [static]

Sends the MNMI_LCS_GLTP_TIME SDL signal containing the reference time to Lcs Stack for setting the RTC to GPS time

void GltpMsgProcessor::ProcessRefLocReq ( const ReferenceLocation & ref_loc ) [static]

Sends the MNMI_GLTP_REF_LOC SDL signal to Lcs Stack for setting the reference location in the GL library

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpMsgProcessor.hpp
  • AddOns/Lcs/GLTP/GltpMsgProcessor.cpp
Generated on Wed Jan 25 01:17:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpMsmtRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpMsmtRequest Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/AidDataRequests.hpp>

Inheritance diagram for GltpMsmtRequest:

[legend]
Collaboration diagram for GltpMsmtRequest:

[legend]

Public Member Functions

void | FormRequest (const MeasurementData &msr_data)
virtual const BYTE * | GetRequest () const
Returns a pointer to the request.
virtual INT | GetSize () const
Returns the request size in bytes.
GltpMsmtRequest ()
Constructor.
virtual | ~GltpMsmtRequest ()
Destructor.

Constructor & Destructor Documentation

GltpMsmtRequest::GltpMsmtRequest ( )

Constructor.

GltpMsmtRequest::~GltpMsmtRequest ( ) [virtual]

Destructor.

Member Function Documentation

void GltpMsmtRequest::FormRequest ( const MeasurementData & msr_data )

virtual const BYTE* GltpMsmtRequest::GetRequest ( ) const [inline, virtual]

Returns a pointer to the request.

Implements GltpRequest.

virtual INT GltpMsmtRequest::GetSize ( ) const [inline, virtual]

Returns the request size in bytes.

Implements GltpRequest.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/AidDataRequests.hpp
  • AddOns/Lcs/GLTP/AidDataRequests.cpp
Generated on Wed Jan 25 01:17:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpPositionRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpPositionRequest Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/AidDataRequests.hpp>

Inheritance diagram for GltpPositionRequest:

[legend]
Collaboration diagram for GltpPositionRequest:

[legend]

Public Member Functions

void | FormRequest (BYTE *posn_data)
virtual const BYTE * | GetRequest () const
Returns a pointer to the request.
virtual INT | GetSize () const
Returns the request size in bytes.
GltpPositionRequest ()
Constructor.
virtual | ~GltpPositionRequest ()
Destructor.

Constructor & Destructor Documentation

GltpPositionRequest::GltpPositionRequest ( )

Constructor.

GltpPositionRequest::~GltpPositionRequest ( ) [virtual]

Destructor.

Member Function Documentation

void GltpPositionRequest::FormRequest ( BYTE * posn_data )

virtual const BYTE* GltpPositionRequest::GetRequest ( ) const [inline, virtual]

Returns a pointer to the request.

Implements GltpRequest.

virtual INT GltpPositionRequest::GetSize ( ) const [inline, virtual]

Returns the request size in bytes.

Implements GltpRequest.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/AidDataRequests.hpp
  • AddOns/Lcs/GLTP/AidDataRequests.cpp
Generated on Wed Jan 25 01:17:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpProviderImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpProviderImpl Class Reference

The implementation of the GLTP protocol provider. More...

#include <Apoxi/AddOns/Lcs/GLTP/GltpProviderImpl.hpp>

Inheritance diagram for GltpProviderImpl:

[legend]
Collaboration diagram for GltpProviderImpl:

[legend]

Public Member Functions

void | GetConfigValues (INT32 &latitude, INT32 &longitude, UINT32 &unit_id) const
virtual void | Init ()
This method performs the necessary initialization.
virtual void | OnTimeOut (LcsTimerType timer_type)
This method is invoked whenever the MO-LR timer expires.
void | RegisterConnApp (Application *conn_app)
void | SetDataConnResult (LcsErrorCode result, BYTE *ack_buff=NULL, INT size=0)
void | StoreConfigValues (INT32 latitude, INT32 longitude, UINT32 unit_id)
virtual LcsErrorCode | TransferLocationReq (MolrType molr_type, LocationMethod location_method, const LcsMmiQos &lcs_mmi_qos, const ClientId &client_id, const MlcNumber &mlc_number, INT32 repeat_interval)
virtual | ~GltpProviderImpl ()
Destructor.

Static Public Member Functions

static GltpProviderImpl * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()
The only method to release the instance of this class.

Protected Member Functions

virtual BOOLEAN | OnAbortResponse (const StackMsgArgument &arg)
Receives the abort response message.
BOOLEAN | OnMeasurementResp (const StackMsgArgument &arg)
virtual BOOLEAN | OnMessage (const Message &msg)
This method implements the message handler.

Detailed Description

The implementation of the GLTP protocol provider.

Constructor & Destructor Documentation

GltpProviderImpl::~GltpProviderImpl ( ) [virtual]

Destructor.

Member Function Documentation

void GltpProviderImpl::GetConfigValues | ( | INT32 & | latitude,
 |  | INT32 & | longitude,
 |  | UINT32 & | unit_id
 | ) | const

This method is invoked by the settings application to get the configuration values stored in the flash file

GltpProviderImpl * GltpProviderImpl::GetInstance ( ) [static]

The only method to get the instance of this class.

void GltpProviderImpl::Init ( ) [virtual]

This method performs the necessary initialization.

Reimplemented from LcsProviderImplBase.

BOOLEAN GltpProviderImpl::OnAbortResponse ( const StackMsgArgument & arg ) [protected, virtual]

Receives the abort response message.

Reimplemented from LcsProviderImplBase.

BOOLEAN GltpProviderImpl::OnMeasurementResp ( const StackMsgArgument & arg ) [protected]

This method receives and processes the position/measurement data sent by the Lcs stack

BOOLEAN GltpProviderImpl::OnMessage ( const Message & msg ) [protected, virtual]

This method implements the message handler.

Reimplemented from StackMsgDispatcher.

void GltpProviderImpl::OnTimeOut ( LcsTimerType timer_type ) [virtual]

This method is invoked whenever the MO-LR timer expires.

Implements LcsProviderImplBase.

void GltpProviderImpl::RegisterConnApp ( Application * conn_app ) [inline]

This method stores the pointer to the GLTP connection application for sending messages later on

void GltpProviderImpl::ReleaseInstance ( ) [static]

The only method to release the instance of this class.

void GltpProviderImpl::SetDataConnResult | ( | LcsErrorCode | result,
 |  | BYTE * | ack_buff = NULL,
 |  | INT | size = 0
 | ) |

This method is invoked by the GLTP connection application to indicate the result of the operation done on the data connection

void GltpProviderImpl::StoreConfigValues | ( | INT32 | latitude,
 |  | INT32 | longitude,
 |  | UINT32 | unit_id
 | ) |

This method is invoked by the settings application to store in a flash file the configuration values entered by the user

LcsErrorCode GltpProviderImpl::TransferLocationReq | ( | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsMmiQos & | lcs_mmi_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number,
 |  | INT32 | repeat_interval
 | ) | [virtual]

This method sends a request to the network to transfer the user's location to an external LCS client. GLTP doesn't support this functionality.

Implements LcsProviderImplBase.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpProviderImpl.hpp
  • AddOns/Lcs/GLTP/GltpProviderImpl.cpp
Generated on Wed Jan 25 01:17:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpRequest Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/AidDataRequests.hpp>

Inheritance diagram for GltpRequest:

[legend]

Public Types

enum | { HEADER_SIZE = 14 }

Public Member Functions

virtual const BYTE * | GetRequest () const =0
Returns a pointer to the request.
virtual INT | GetSize () const =0
Returns the request size in bytes.
virtual | ~GltpRequest ()
Destructor.

Static Public Member Functions

static UINT16 | GetUnitId ()
Returns the unit-id of the MS.

Protected Member Functions

BYTE * | FillHeader (BYTE *buffer, UINT32 tag, UINT16 data_length)
Fills the header part of the GLTP request.
GltpRequest ()
Constructor.

Static Protected Attributes

static UINT16 | m_unit_id = 0
Contains the unit-id of the MS.

Member Enumeration Documentation

anonymous enum

Enumerator:
HEADER_SIZE

Constructor & Destructor Documentation

GltpRequest::~GltpRequest ( ) [virtual]

Destructor.

GltpRequest::GltpRequest ( ) [protected]

Constructor.

Member Function Documentation

BYTE * GltpRequest::FillHeader | ( | BYTE * | buffer,
 |  | UINT32 | tag,
 |  | UINT16 | data_length
 | ) | [protected]

Fills the header part of the GLTP request.

virtual const BYTE* GltpRequest::GetRequest ( ) const [pure virtual]

Returns a pointer to the request.

Implemented in GltpHelloRequest, GltpAidingRequest, GltpMsmtRequest, and GltpPositionRequest.

virtual INT GltpRequest::GetSize ( ) const [pure virtual]

Returns the request size in bytes.

Implemented in GltpHelloRequest, GltpAidingRequest, GltpMsmtRequest, and GltpPositionRequest.

static UINT16 GltpRequest::GetUnitId ( ) [inline, static]

Returns the unit-id of the MS.

Field Documentation

UINT16 GltpRequest::m_unit_id = 0 [static, protected]

Contains the unit-id of the MS.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/AidDataRequests.hpp
  • AddOns/Lcs/GLTP/AidDataRequests.cpp
Generated on Wed Jan 25 01:17:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpSignalMapTableNode Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpSignalMapTableNode.hpp>

Inheritance diagram for GltpSignalMapTableNode:

[legend]
Collaboration diagram for GltpSignalMapTableNode:

[legend]

Public Member Functions

~GltpSignalMapTableNode ()
Destructor.

Static Public Member Functions

static GltpSignalMapTableNode * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()
The only method to get the instance of this class.

Detailed Description

Keeps the mapping of SDL signal to the corresponding processing methos in GltpSignalProcessor.

Constructor & Destructor Documentation

GltpSignalMapTableNode::~GltpSignalMapTableNode ( )

Destructor.

Member Function Documentation

GltpSignalMapTableNode * GltpSignalMapTableNode::GetInstance ( ) [static]

The only method to get the instance of this class.

void GltpSignalMapTableNode::ReleaseInstance ( ) [static]

The only method to get the instance of this class.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpSignalMapTableNode.hpp
  • AddOns/Lcs/GLTP/GltpSignalMapTableNode.cpp
Generated on Wed Jan 25 01:17:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpSignalProcessor Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpSignalProcessor.hpp>

Static Public Member Functions

static void PostMeasurementData (const ProcessPtr &process_ptr)
Operations.

Detailed Description

This class generates (and posts) APOXI messages corresponding to the incoming LCS-related SDL signals

Member Function Documentation

void GltpSignalProcessor::PostMeasurementData ( const ProcessPtr & process_ptr ) [static]

Operations.

Receives SDL MNMI_LCS_GLTP_MSR_CNF signal from Lcs Stack,forms an argument message and posts it to application

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpSignalProcessor.hpp
  • AddOns/Lcs/GLTP/GltpSignalProcessor.cpp
Generated on Wed Jan 25 01:17:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GltpStackMsgArgsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GltpStackMsgArgsDestroyTableNode Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpStackMsgArgs.hpp>

Inheritance diagram for GltpStackMsgArgsDestroyTableNode:

[legend]
Collaboration diagram for GltpStackMsgArgsDestroyTableNode:

[legend]

Static Public Member Functions

static GltpStackMsgArgsDestroyTableNode * GetInstance ()

Member Function Documentation

GltpStackMsgArgsDestroyTableNode * GltpStackMsgArgsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpStackMsgArgs.hpp
  • AddOns/Lcs/GLTP/GltpStackMsgArgs.cpp
Generated on Wed Jan 25 01:17:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Glyph Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Glyph Struct Reference
[GUI]

#include <Apoxi/Gui/Font.hpp>

Public Member Functions

const UINT8 FONT_HUGE * | GetData () const
INT | GetWidth () const

Data Fields

const UINT8 FONT_HUGE * | m_data
INT | m_width

Member Function Documentation

const UINT8 FONT_HUGE* Glyph::GetData ( ) const [inline]

INT Glyph::GetWidth ( ) const [inline]

Field Documentation

const UINT8 FONT_HUGE* Glyph::m_data

INT Glyph::m_width

The documentation for this struct was generated from the following file:
  • Gui/Font.hpp
Generated on Wed Jan 25 01:17:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlyphHeader Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GlyphHeader Struct Reference
[GUI]

#include <Apoxi/Gui/Font.hpp>

Data Fields

UINT8 | m_low_byte
UINT16 | m_offset
UINT8 | m_width

Field Documentation

UINT8 GlyphHeader::m_low_byte

UINT16 GlyphHeader::m_offset

UINT8 GlyphHeader::m_width

The documentation for this struct was generated from the following file:
  • Gui/Font.hpp
Generated on Wed Jan 25 01:17:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GlyphIndexTab Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GlyphIndexTab Struct Reference
[GUI]

#include <Apoxi/Gui/Font.hpp>

Data Fields

UINT8 | m_glyph_count [256]
const GlyphHeaderPtr | m_glyph_tab [256]

Field Documentation

UINT8 GlyphIndexTab::m_glyph_count[256]

const GlyphHeaderPtr GlyphIndexTab::m_glyph_tab[256]

The documentation for this struct was generated from the following file:
  • Gui/Font.hpp
Generated on Wed Jan 25 01:17:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GmmParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GmmParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

GmmParam ()
BOOLEAN | IsServiceStateInvalid ()
BOOLEAN | IsStateInvalid ()
BOOLEAN | IsTimerInvalid ()
BOOLEAN | IsUpdateStatusInvalid ()
GmmParam | operator= (T_GMM_TESTPARAM gmm_testparam)

Data Fields

BOOLEAN | ready_connected
INT | service_state
INT | state
INT | timer
INT | update_status

Constructor & Destructor Documentation

GmmParam::GmmParam ( ) [inline]

Member Function Documentation

BOOLEAN GmmParam::IsServiceStateInvalid ( ) [inline]

BOOLEAN GmmParam::IsStateInvalid ( ) [inline]

BOOLEAN GmmParam::IsTimerInvalid ( ) [inline]

BOOLEAN GmmParam::IsUpdateStatusInvalid ( ) [inline]

GmmParam GmmParam::operator= ( T_GMM_TESTPARAM gmm_testparam )

Field Documentation

BOOLEAN GmmParam::ready_connected

INT GmmParam::service_state

INT GmmParam::state

INT GmmParam::timer

INT GmmParam::update_status

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:17:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GprsAttachStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GprsAttachStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for GprsAttachStatusMsg:

[legend]
Collaboration diagram for GprsAttachStatusMsg:

[legend]

Public Types

enum | { ID = 18710 }

Public Member Functions

virtual Message * | Clone () const
const PdpContextManager::AttachStatus & | GetAttachStatus () const
virtual const MsgMetaData & | GetMetaData () const
GprsAttachStatusMsg (const PdpContextManager::AttachStatus &attachStatus)
void | SetAttachStatus (const PdpContextManager::AttachStatus &attachStatus)
virtual | ~GprsAttachStatusMsg ()

Detailed Description

GprsAttachStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GprsAttachStatusMsg::GprsAttachStatusMsg ( const PdpContextManager::AttachStatus & attachStatus )

GprsAttachStatusMsg::~GprsAttachStatusMsg ( ) [virtual]

Member Function Documentation

Message * GprsAttachStatusMsg::Clone ( ) const [virtual]

Implements Message.

const PdpContextManager::AttachStatus& GprsAttachStatusMsg::GetAttachStatus ( ) const [inline]

const MsgMetaData & GprsAttachStatusMsg::GetMetaData ( ) const [virtual]

Implements Message.

void GprsAttachStatusMsg::SetAttachStatus ( const PdpContextManager::AttachStatus & attachStatus ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:17:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GprsClassIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GprsClassIndArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for GprsClassIndArg:

[legend]
Collaboration diagram for GprsClassIndArg:

[legend]

Public Types

enum | { ID = 5366 }

Public Member Functions

const GprsClass & | GetGprsClass () const
const ProcessSource & | GetProcessSource () const
GprsClassIndArg ()
void | SetGprsClass (const GprsClass &gprs_class)
void | SetProcessSource (const ProcessSource &process_source)

Static Public Member Functions

static const GprsClassIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

GprsClassIndArg: reflects arguments of signal MN_GCLASS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GprsClassIndArg::GprsClassIndArg ( )

Member Function Documentation

const GprsClassIndArg & GprsClassIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GprsClass& GprsClassIndArg::GetGprsClass ( ) const [inline]

const ProcessSource& GprsClassIndArg::GetProcessSource ( ) const [inline]

void GprsClassIndArg::SetGprsClass ( const GprsClass & gprs_class ) [inline]

void GprsClassIndArg::SetProcessSource ( const ProcessSource & process_source ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:17:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GprsClassReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GprsClassReqArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for GprsClassReqArg:

[legend]
Collaboration diagram for GprsClassReqArg:

[legend]

Public Types

enum | { ID = 6363 }

Public Member Functions

const GprsClass & | GetGprsClass () const
GprsClassReqArg ()
GprsClassReqArg (const GprsClass &gprs_class)
void | SetGprsClass (const GprsClass &gprs_class)

Static Public Member Functions

static const GprsClassReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

GprsClassReqArg: reflects arguments of signal MNMI_GCLASS_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GprsClassReqArg::GprsClassReqArg ( const GprsClass & gprs_class )

GprsClassReqArg::GprsClassReqArg ( )

Member Function Documentation

const GprsClassReqArg & GprsClassReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GprsClass& GprsClassReqArg::GetGprsClass ( ) const [inline]

void GprsClassReqArg::SetGprsClass ( const GprsClass & gprs_class ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:17:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GprsParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GprsParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for GprsParam:

[legend]

Public Member Functions

GprsParam ()
BOOLEAN | IsAccessBurstTypeInvalid ()
BOOLEAN | IsAccThrInvalid ()
BOOLEAN | IsC31Invalid ()
BOOLEAN | IsC32Invalid ()
BOOLEAN | IsCellReselectHystInvalid ()
BOOLEAN | IsDrxMaxInvalid ()
BOOLEAN | IsEmoInvalid ()
BOOLEAN | IsGprsSupported ()
BOOLEAN | IsNcoInvalid ()
BOOLEAN | IsNetworkOpModeInvalid ()
BOOLEAN | IsPbcchPresent ()
BOOLEAN | IsPsi1RepeatPeriodInvalid ()
BOOLEAN | IsPsiCountHrInvalid ()
BOOLEAN | IsPsiCountLrInvalid ()
BOOLEAN | IsRacInvalid ()
BOOLEAN | IsSi13Present ()
BOOLEAN | IsSplitPgCycle ()
BOOLEAN | IsT3192Invalid ()
GprsParam | operator= (T_GPRS_PARAM gprs_param)

Data Fields

INT | acc_burst_type
BYTE | acc_thr
INT | c31
INT | c32
COverIList c_over_i
BYTE | cr_hyst
BYTE | drx_max
INT | emo
BOOLEAN | gprs_sup
INT | nco
NetworkOpMode net_op_mode
AckNackParamList no_ack_nack_blocks
BOOLEAN | pbcch_present
BYTE | psi1_repeat
BYTE | psi_count_hr
BYTE | psi_count_lr
BYTE | rac
BOOLEAN | si13_present
BOOLEAN | split_pg_cycle
UINT16 | t3192

Constructor & Destructor Documentation

GprsParam::GprsParam ( ) [inline]

Member Function Documentation

BOOLEAN GprsParam::IsAccessBurstTypeInvalid ( ) [inline]

BOOLEAN GprsParam::IsAccThrInvalid ( ) [inline]

BOOLEAN GprsParam::IsC31Invalid ( ) [inline]

BOOLEAN GprsParam::IsC32Invalid ( ) [inline]

BOOLEAN GprsParam::IsCellReselectHystInvalid ( ) [inline]

BOOLEAN GprsParam::IsDrxMaxInvalid ( ) [inline]

BOOLEAN GprsParam::IsEmoInvalid ( ) [inline]

BOOLEAN GprsParam::IsGprsSupported ( ) [inline]

BOOLEAN GprsParam::IsNcoInvalid ( ) [inline]

BOOLEAN GprsParam::IsNetworkOpModeInvalid ( ) [inline]

BOOLEAN GprsParam::IsPbcchPresent ( ) [inline]

BOOLEAN GprsParam::IsPsi1RepeatPeriodInvalid ( ) [inline]

BOOLEAN GprsParam::IsPsiCountHrInvalid ( ) [inline]

BOOLEAN GprsParam::IsPsiCountLrInvalid ( ) [inline]

BOOLEAN GprsParam::IsRacInvalid ( ) [inline]

BOOLEAN GprsParam::IsSi13Present ( ) [inline]

BOOLEAN GprsParam::IsSplitPgCycle ( ) [inline]

BOOLEAN GprsParam::IsT3192Invalid ( ) [inline]

GprsParam GprsParam::operator= ( T_GPRS_PARAM gprs_param )

Field Documentation

INT GprsParam::acc_burst_type

BYTE GprsParam::acc_thr

INT GprsParam::c31

INT GprsParam::c32

COverIList GprsParam::c_over_i

BYTE GprsParam::cr_hyst

BYTE GprsParam::drx_max

INT GprsParam::emo

BOOLEAN GprsParam::gprs_sup

INT GprsParam::nco

NetworkOpMode GprsParam::net_op_mode

AckNackParamList GprsParam::no_ack_nack_blocks

BOOLEAN GprsParam::pbcch_present

BYTE GprsParam::psi1_repeat

BYTE GprsParam::psi_count_hr

BYTE GprsParam::psi_count_lr

BYTE GprsParam::rac

BOOLEAN GprsParam::si13_present

BOOLEAN GprsParam::split_pg_cycle

UINT16 GprsParam::t3192

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:17:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GprsStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GprsStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for GprsStatusMsg:

[legend]
Collaboration diagram for GprsStatusMsg:

[legend]

Public Types

enum | { ID = 18702 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
GprsStatusMsg (BOOLEAN attached)
BOOLEAN | IsAttached () const
void | SetAttached (BOOLEAN attached)
virtual | ~GprsStatusMsg ()

Detailed Description

GprsStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GprsStatusMsg::GprsStatusMsg ( BOOLEAN attached )

GprsStatusMsg::~GprsStatusMsg ( ) [virtual]

Member Function Documentation

Message * GprsStatusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & GprsStatusMsg::GetMetaData ( ) const [virtual]

Implements Message.

BOOLEAN GprsStatusMsg::IsAttached ( ) const [inline]

void GprsStatusMsg::SetAttached ( BOOLEAN attached ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:17:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GpsFixData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GpsFixData Struct Reference

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for GpsFixData:

[legend]

Data Fields

UINT32 | m_gps_tow
UINT16 | m_gps_week
UnsignedValue m_hdop
Horizontal Dilution of Precision.
UnsignedValue m_loc_error
Estimated location error in metres.
UINT16 | m_microsec
UINT8 | m_num_sats
SatelliteInfo m_sat_info [MAX_SATS]
UnsignedValue m_speed
Speed of the MS in m/sec.
UINT8 | m_speed_valid
UINT32 | m_time_tag_delta
Estimated time tag error in msec.

Field Documentation

UINT32 GpsFixData::m_gps_tow

UINT16 GpsFixData::m_gps_week

UnsignedValue GpsFixData::m_hdop

Horizontal Dilution of Precision.

UnsignedValue GpsFixData::m_loc_error

Estimated location error in metres.

UINT16 GpsFixData::m_microsec

UINT8 GpsFixData::m_num_sats

SatelliteInfo GpsFixData::m_sat_info[MAX_SATS]

UnsignedValue GpsFixData::m_speed

Speed of the MS in m/sec.

UINT8 GpsFixData::m_speed_valid

UINT32 GpsFixData::m_time_tag_delta

Estimated time tag error in msec.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:17:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GpsFixDataInt Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GpsFixDataInt Struct Reference

This structure stores the GPS fix data for internal conversion later. More...

#include <Apoxi/AddOns/Lcs/GLTP/GltpTypes.hpp>

Collaboration diagram for GpsFixDataInt:

[legend]

Public Member Functions

void | Convert (GpsFixData &fix_data) const

Data Fields

UINT32 | m_gps_tow
UINT16 | m_gps_week
UINT32 | m_hdop
Horizontal Dilution of Precision.
UINT32 | m_loc_error
Estimated location error in metres.
UINT16 | m_microsec
UINT8 | m_num_sats
SatelliteInfo m_sat_info [MAX_SATS]
UINT32 | m_speed
Speed of the MS in m/sec.
UINT8 | m_speed_valid
UINT32 | m_time_tag_delta
Estimated time tag error in msec.

Detailed Description

This structure stores the GPS fix data for internal conversion later.

Member Function Documentation

void GpsFixDataInt::Convert ( GpsFixData & fix_data ) const [inline]

Field Documentation

UINT32 GpsFixDataInt::m_gps_tow

UINT16 GpsFixDataInt::m_gps_week

UINT32 GpsFixDataInt::m_hdop

Horizontal Dilution of Precision.

UINT32 GpsFixDataInt::m_loc_error

Estimated location error in metres.

UINT16 GpsFixDataInt::m_microsec

UINT8 GpsFixDataInt::m_num_sats

SatelliteInfo GpsFixDataInt::m_sat_info[MAX_SATS]

UINT32 GpsFixDataInt::m_speed

Speed of the MS in m/sec.

UINT8 GpsFixDataInt::m_speed_valid

UINT32 GpsFixDataInt::m_time_tag_delta

Estimated time tag error in msec.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/GLTP/GltpTypes.hpp
Generated on Wed Jan 25 01:17:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GreaterRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GreaterRule Class Reference
[Auxiliary]

IsGreaterRule checks whether data item is larger than the rule item More...

#include <Apoxi/Auxiliary/FilterRule.hpp>

Inheritance diagram for GreaterRule:

[legend]
Collaboration diagram for GreaterRule:

[legend]

Public Types

typedef FilterRule | Base

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)
GreaterRule (const DataItem &ruleitem)
GreaterRule ()
virtual | ~GreaterRule ()

Detailed Description

IsGreaterRule checks whether data item is larger than the rule item

Member Typedef Documentation

typedef FilterRule GreaterRule::Base

Constructor & Destructor Documentation

GreaterRule::GreaterRule ( )

GreaterRule::GreaterRule ( const DataItem & ruleitem )

GreaterRule::~GreaterRule ( ) [virtual]

Member Function Documentation

BOOLEAN GreaterRule::ExecuteRule ( const DataItem & dataitem ) [virtual]

ExecuteRule does the actual comparision between the data item given in the argument and the value stored when the filter rule is constructed.

Implements FilterRule.

The documentation for this class was generated from the following files:
  • Auxiliary/FilterRule.hpp
  • Auxiliary/FilterRule.cpp
Generated on Wed Jan 25 01:17:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Grid Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Grid Class Reference

Obsolete - use AbstractGrid or Menu from GUI instead. More...

#include <Apoxi/Compat/Grid.hpp>

Inheritance diagram for Grid:

[legend]
Collaboration diagram for Grid:

[legend]

Public Types

typedef Control | Base

Public Member Functions

Cell | GetFirstCell () const
Returns the first selectable cell.
Cell | GetLastCell () const
Returns the last selectable cell.
INT | GetNoOfCells () const
Returns the number of grid cells.
INT | GetNoOfColumns () const
Returns the number of grid columns.
INT | GetNoOfRows () const
Returns the number of grid rows.
Cell | GetSelectedCell () const
Returns the selected cell of the grid.
SelectionMode | GetSelectionMode () const
Returns the order for cell selection.
Grid (Control *parent, INT columns, INT rows, Behaviour behaviour=DefaultBehaviour, const Cell &selected_cell=Cell())
Constructor of the grid.
Grid ()
void | Init (Control *parent, INT columns, INT rows, Behaviour behaviour=DefaultBehaviour, const Cell &selected_cell=Cell())
BOOLEAN | IsColumnTitled () const
Returns TRUE if the first row is set as column names.
BOOLEAN | IsRowTitled () const
Returns TRUE if the first column is set as row names.
void | SetColumnTitled (BOOLEAN column_titled)
Sets the first row as column names. So they are not selectable.
void | SetFirstCell (const Cell &cell)
Sets the first selectable cell.
virtual void | SetHeight (XYDIM height)
Sets the height of the window.
void | SetLastCell (const Cell &cell)
Sets the last selectable cell.
void | SetNoOfColumns (INT n_columns)
Sets the number of grid columns.
void | SetNoOfRows (INT n_rows)
Sets the number of grid rows.
void | SetRowTitled (BOOLEAN row_titled)
Sets the first column as row names. So they are not selectable.
void | SetSelectedCell (const Cell &cell)
Sets the selected cell of the grid.
void | SetSelectionMode (SelectionMode mode)
Sets the order for cell selection.
void | SetSize (XYDIM width, XYDIM height)
Sets the size of the window.
virtual void | SetSize (const Size &size)
Sets the size of the window.
virtual void | SetWidth (XYDIM width)
Sets the width of the window.
virtual | ~Grid ()

Protected Member Functions

void | AdjustThemeDependencies ()
virtual Model * | CreateModel () const
virtual BOOLEAN | OnInputMap (const InputMapItem &input_map_item)
virtual void | OnMoveDown ()
Is called, if the cursor has been moved to the lower cell.
virtual void | OnMoveLeft ()
Is called, if the cursor has been moved to the left cell.
virtual void | OnMoveRight ()
Is called, if the cursor has been moved to the right cell.
virtual void | OnMoveUp ()
Is called, if the cursor has been moved to the upper cell.
virtual void | OnSelectionChanged ()
Is called, if another cell will be selected.
virtual void | OnThemeChanged ()
Is called, if the theme has been changed.
virtual void | Refresh (const Rect &rect)

Detailed Description

Obsolete - use AbstractGrid or Menu from GUI instead.

Member Typedef Documentation

typedef Control Grid::Base

Reimplemented from Control.

Constructor & Destructor Documentation

Grid::Grid ( )

Grid::Grid | ( | Control * | parent,
 |  | INT | columns,
 |  | INT | rows,
 |  | Behaviour | behaviour = DefaultBehaviour,
 |  | const Cell & | selected_cell = Cell()
 | ) |

Constructor of the grid.

Grid::~Grid ( ) [virtual]

Member Function Documentation

void Grid::AdjustThemeDependencies ( ) [protected]

Model * Grid::CreateModel ( ) const [protected, virtual]

See also:
Component::Refresh

Reimplemented from Component.

Cell Grid::GetFirstCell ( ) const

Returns the first selectable cell.

Cell Grid::GetLastCell ( ) const

Returns the last selectable cell.

INT Grid::GetNoOfCells ( ) const

Returns the number of grid cells.

INT Grid::GetNoOfColumns ( ) const

Returns the number of grid columns.

INT Grid::GetNoOfRows ( ) const

Returns the number of grid rows.

Cell Grid::GetSelectedCell ( ) const

Returns the selected cell of the grid.

SelectionMode Grid::GetSelectionMode ( ) const

Returns the order for cell selection.

void Grid::Init | ( | Control * | parent,
 |  | INT | columns,
 |  | INT | rows,
 |  | Behaviour | behaviour = DefaultBehaviour,
 |  | const Cell & | selected_cell = Cell()
 | ) |

BOOLEAN Grid::IsColumnTitled ( ) const

Returns TRUE if the first row is set as column names.

BOOLEAN Grid::IsRowTitled ( ) const

Returns TRUE if the first column is set as row names.

BOOLEAN Grid::OnInputMap ( const InputMapItem & input_map_item ) [protected, virtual]

Reimplemented from Control.

void Grid::OnMoveDown ( ) [protected, virtual]

Is called, if the cursor has been moved to the lower cell.

void Grid::OnMoveLeft ( ) [protected, virtual]

Is called, if the cursor has been moved to the left cell.

void Grid::OnMoveRight ( ) [protected, virtual]

Is called, if the cursor has been moved to the right cell.

void Grid::OnMoveUp ( ) [protected, virtual]

Is called, if the cursor has been moved to the upper cell.

virtual void Grid::OnSelectionChanged ( ) [inline, protected, virtual]

Is called, if another cell will be selected.

void Grid::OnThemeChanged ( ) [protected, virtual]

Is called, if the theme has been changed.

Reimplemented from Control.

void Grid::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect &rect)

Reimplemented from Control.

void Grid::SetColumnTitled ( BOOLEAN column_titled )

Sets the first row as column names. So they are not selectable.

void Grid::SetFirstCell ( const Cell & cell )

Sets the first selectable cell.

void Grid::SetHeight ( XYDIM height ) [virtual]

Sets the height of the window.

Reimplemented from Component.

void Grid::SetLastCell ( const Cell & cell )

Sets the last selectable cell.

void Grid::SetNoOfColumns ( INT n_columns )

Sets the number of grid columns.

void Grid::SetNoOfRows ( INT n_rows )

Sets the number of grid rows.

void Grid::SetRowTitled ( BOOLEAN row_titled )

Sets the first column as row names. So they are not selectable.

void Grid::SetSelectedCell ( const Cell & cell )

Sets the selected cell of the grid.

void Grid::SetSelectionMode ( SelectionMode mode )

Sets the order for cell selection.

void Grid::SetSize | ( | XYDIM | width,
 |  | XYDIM | height
 | ) | [inline]

Sets the size of the window.

Reimplemented from Component.

void Grid::SetSize ( const Size & size ) [virtual]

Sets the size of the window.

Reimplemented from Component.

void Grid::SetWidth ( XYDIM width ) [virtual]

Sets the width of the window.

Reimplemented from Component.

The documentation for this class was generated from the following files:
  • Compat/Grid.hpp
  • Compat/Grid.cpp
Generated on Wed Jan 25 01:17:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GridLayout Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GridLayout Class Reference
[Components]

#include <Apoxi/Gui/GridLayout.hpp>

Inheritance diagram for GridLayout:

[legend]
Collaboration diagram for GridLayout:

[legend]

Public Types

enum | { ID = 15 }
enum | StretchUnit { Default, Percent, Pixel }
enum | XAlign { XDefault, Left, Center, Right }
Specifies the x-alignment of a component inside a cell. More...
enum | YAlign { YDefault, Top, Middle, Bottom }
Specifies the y-alignment of a component inside a cell. More...

Public Member Functions

Size | GetCellSize (INT row, INT column) const
virtual Rect | GetClientRect () const
INT | GetColumnCount () const
INT | GetRowCount () const
GridLayout (Control *parent, INT row_count, INT col_count=1, Size min_size=Size(-1,-1))
GridLayout ()
void | Init (Control *parent, INT row_count, INT col_count=1, Size min_size=Size(-1,-1))
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetCellProperties (INT row, INT col, Component *component, XAlign x_align=XDefault, YAlign y_align=YDefault)
void | SetColumnProperty (INT col, StretchUnit stretch_unit, INT value=0)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetRowProperty (INT row, StretchUnit stretch_unit, INT value=0)
virtual | ~GridLayout ()

Protected Member Functions

virtual void | OnFocusNextControl ()
virtual void | OnFocusPreviousControl ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyAutoRepeat (KeyCode key_code)
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
virtual void | OnThemeChanged ()

Data Structures

struct | Cell
struct | LayouterProperties

Detailed Description

Control for layouting components inside a grid. A grid with a variable number of rows and columns can be specified, where each component is assigned to one cell of the grid. For each cell layouting properties can be specified. It is also possible to specify a minimum size. If this size is not available, the grid layout control automatically adds a horizontal and/or vertical position indicator, so that the content can be scrolled.

The documentation for this class was generated from the following files:
  • Gui/GridLayout.hpp
  • Gui/GridLayout.cpp
Generated on Wed Jan 25 01:17:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GridModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GridModel Class Reference

A matixbox-model describes the data of the widget grid. More...

#include <Apoxi/Compat/Grid.hpp>

Inheritance diagram for GridModel:

[legend]
Collaboration diagram for GridModel:

[legend]

Public Member Functions

BOOLEAN | DecrementCell (Cell *cell, BOOLEAN select) const
Behaviour | GetBehaviour () const
Cell | GetFirstCell () const
Returns the first selectable cell.
INT | GetFirstVisibleRow () const
Cell | GetLastCell () const
Returns the last selectable cell.
INT | GetMaxVisibleRows () const
INT | GetNoOfCells () const
Returns the number of grid cells.
INT | GetNoOfColumns () const
Returns the number of grid rows.
INT | GetNoOfRows () const
Returns the number of grid rows.
PositionIndicator * GetPositionIndicator ()
INT | GetRepaintHint () const
Cell | GetSelectedCell () const
Returns the selected index of the grid.
SelectionMode | GetSelectionMode () const
Returns the order for cell selection.
GridModel (INT n_columns, INT n_rows, Behaviour behaviour=DefaultBehaviour, const Cell &selected_cell=Cell())
Constructor of the grid-model.
GridModel ()
BOOLEAN | IncrementCell (Cell *cell, BOOLEAN select) const
void | Init (INT n_columns, INT n_rows, Behaviour behaviour=DefaultBehaviour, const Cell &selected_cell=Cell())
BOOLEAN | IsColumnTitled () const
Returns TRUE if the first row is set as column names.
BOOLEAN | IsFirstCell (const Cell *cell) const
BOOLEAN | IsIndicatorFullsized () const
BOOLEAN | IsLastCell (const Cell *cell) const
BOOLEAN | IsRowTitled () const
Returns TRUE if the first column is set as row names.
BOOLEAN | IsSelectableCell (const Cell *cell) const
void | SetBehaviour (Behaviour behaviour)
void | SetColumnTitled (BOOLEAN column_titled)
Sets the first row as column names. So they are not selectable.
void | SetFirstCell (const Cell &cell)
Sets the first selectable cell.
void | SetFirstVisibleRow (INT row)
void | SetLastCell (const Cell &cell)
Sets the last selectable cell.
void | SetMaxVisibleRows (INT max_visible_rows)
void | SetNoOfColumns (INT n_columns)
Sets the number of grid rows.
void | SetNoOfRows (INT n_rows)
Sets the number of grid rows.
void | SetRepaintHint (RepaintHint hint)
void | SetRowTitled (BOOLEAN row_titled)
Sets the first column as row names. So they are not selectable.
void | SetSelectedCell (const Cell &cell)
Sets the selected index of the grid.
void | SetSelectionMode (SelectionMode mode)
Sets the order for cell selection.
virtual | ~GridModel ()

Detailed Description

A matixbox-model describes the data of the widget grid.

Constructor & Destructor Documentation

GridModel::GridModel ( )

GridModel::GridModel | ( | INT | n_columns,
 |  | INT | n_rows,
 |  | Behaviour | behaviour = DefaultBehaviour,
 |  | const Cell & | selected_cell = Cell()
 | ) |

Constructor of the grid-model.

virtual GridModel::~GridModel ( ) [inline, virtual]

Member Function Documentation

BOOLEAN GridModel::DecrementCell | ( | Cell * | cell,
 |  | BOOLEAN | select
 | ) | const

Behaviour GridModel::GetBehaviour ( ) const [inline]

Cell GridModel::GetFirstCell ( ) const [inline]

Returns the first selectable cell.

INT GridModel::GetFirstVisibleRow ( ) const [inline]

Cell GridModel::GetLastCell ( ) const [inline]

Returns the last selectable cell.

INT GridModel::GetMaxVisibleRows ( ) const [inline]

INT GridModel::GetNoOfCells ( ) const [inline]

Returns the number of grid cells.

INT GridModel::GetNoOfColumns ( ) const [inline]

Returns the number of grid rows.

INT GridModel::GetNoOfRows ( ) const [inline]

Returns the number of grid rows.

PositionIndicator* GridModel::GetPositionIndicator ( ) [inline]

INT GridModel::GetRepaintHint ( ) const [inline]

Cell GridModel::GetSelectedCell ( ) const [inline]

Returns the selected index of the grid.

SelectionMode GridModel::GetSelectionMode ( ) const [inline]

Returns the order for cell selection.

BOOLEAN GridModel::IncrementCell | ( | Cell * | cell,
 |  | BOOLEAN | select
 | ) | const

void GridModel::Init | ( | INT | n_columns,
 |  | INT | n_rows,
 |  | Behaviour | behaviour = DefaultBehaviour,
 |  | const Cell & | selected_cell = Cell()
 | ) |

BOOLEAN GridModel::IsColumnTitled ( ) const [inline]

Returns TRUE if the first row is set as column names.

BOOLEAN GridModel::IsFirstCell ( const Cell * cell ) const

BOOLEAN GridModel::IsIndicatorFullsized ( ) const [inline]

BOOLEAN GridModel::IsLastCell ( const Cell * cell ) const

BOOLEAN GridModel::IsRowTitled ( ) const [inline]

Returns TRUE if the first column is set as row names.

BOOLEAN GridModel::IsSelectableCell ( const Cell * cell ) const

void GridModel::SetBehaviour ( Behaviour behaviour ) [inline]

void GridModel::SetColumnTitled ( BOOLEAN column_titled )

Sets the first row as column names. So they are not selectable.

void GridModel::SetFirstCell ( const Cell & cell )

Sets the first selectable cell.

void GridModel::SetFirstVisibleRow ( INT row )

void GridModel::SetLastCell ( const Cell & cell )

Sets the last selectable cell.

void GridModel::SetMaxVisibleRows ( INT max_visible_rows )

void GridModel::SetNoOfColumns ( INT n_columns )

Sets the number of grid rows.

void GridModel::SetNoOfRows ( INT n_rows )

Sets the number of grid rows.

void GridModel::SetRepaintHint ( RepaintHint hint ) [inline]

void GridModel::SetRowTitled ( BOOLEAN row_titled )

Sets the first column as row names. So they are not selectable.

void GridModel::SetSelectedCell ( const Cell & cell )

Sets the selected index of the grid.

void GridModel::SetSelectionMode ( SelectionMode mode ) [inline]

Sets the order for cell selection.

The documentation for this class was generated from the following files:
  • Compat/Grid.hpp
  • Compat/Grid.cpp
Generated on Wed Jan 25 01:17:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GridView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GridView Class Reference

#include <Apoxi/Compat/Grid.hpp>

Inheritance diagram for GridView:

[legend]
Collaboration diagram for GridView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
Draws the grid.
virtual void | DrawCell (const GridModel &model, DeviceContext *dc, const Cell &cell, BOOLEAN highlighted=FALSE) const
virtual void | DrawCellPostHighlighted (const GridModel &model, DeviceContext *dc, const Cell &cell) const
Is called, after the highlighted cell with the position cell is drawn.
virtual void | DrawCellPreHighlighted (const GridModel &model, DeviceContext *dc, const Cell &cell) const
Is called, before the highlighted cell with the position cell is drawn.
XYDIM | GetCellHeight () const
Returns the cell-height of the grid.
Rect | GetCellRect (const GridModel &model, const DeviceContext &dc, const Cell &cell) const
Returns the used rectangulary area of the row with the cell cell.
XYDIM | GetCellWidth () const
Returns the cell-width of the grid.
XYDIM | GetCellXPos (const GridModel &model, const DeviceContext &dc, const Cell &cell) const
Returns the x-position of the item with the cell cell.
XYDIM | GetCellYPos (const GridModel &model, const DeviceContext &dc, const Cell &cell) const
Returns the y-position of the item with the cell cell.
XYDIM | GetColTitleHeight () const
Returns the height of the column title.
INT | GetLastCompletelyVisibleRow (const GridModel &model, const DeviceContext &dc) const
Returns the last completely visible row of the grid.
INT | GetLastVisibleRow (const GridModel &model, const DeviceContext &dc) const
Returns the last (partly) visible row of the grid.
XYDIM | GetPosIndicatorWidth () const
Returns the width of the position indicator.
XYDIM | GetRowTitleWidth () const
Returns the width of the row title.
GridView (XYDIM cell_width, XYDIM cell_height, XYDIM pos_indicator_width)
GridView ()
void | SetCellHeight (XYDIM cell_height)
Sets the cell-height of the grid.
void | SetCellWidth (XYDIM cell_width)
Sets the cell-width of the grid.
void | SetColTitleHeight (XYDIM height)
Sets the height of the column title.
void | SetPosIndicatorWidth (XYDIM pos_indicator_width)
Sets the width of the position indicator.
void | SetRowTitleWidth (XYDIM width)
Sets the width of the row title.
virtual | ~GridView ()

Detailed Description

A grid-view describes the view of the widget grid.

Constructor & Destructor Documentation

GridView::GridView ( )

GridView::GridView | ( | XYDIM | cell_width,
 |  | XYDIM | cell_height,
 |  | XYDIM | pos_indicator_width
 | ) |

GridView::~GridView ( ) [virtual]

Member Function Documentation

void GridView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Draws the grid.

Implements View.

void GridView::DrawCell | ( | const GridModel & | model,
 |  | DeviceContext * | dc,
 |  | const Cell & | cell,
 |  | BOOLEAN | highlighted = FALSE
 | ) | const [virtual]

Draws the cell with the position cell of the grid. By default the parameter highlighted has no results to the look of the cell, but it can be used by derived views for specialised drawing.

void GridView::DrawCellPostHighlighted | ( | const GridModel & | model,
 |  | DeviceContext * | dc,
 |  | const Cell & | cell
 | ) | const [virtual]

Is called, after the highlighted cell with the position cell is drawn.

void GridView::DrawCellPreHighlighted | ( | const GridModel & | model,
 |  | DeviceContext * | dc,
 |  | const Cell & | cell
 | ) | const [virtual]

Is called, before the highlighted cell with the position cell is drawn.

XYDIM GridView::GetCellHeight ( ) const [inline]

Returns the cell-height of the grid.

Rect GridView::GetCellRect | ( | const GridModel & | model,
 |  | const DeviceContext & | dc,
 |  | const Cell & | cell
 | ) | const

Returns the used rectangulary area of the row with the cell cell.

XYDIM GridView::GetCellWidth ( ) const [inline]

Returns the cell-width of the grid.

XYDIM GridView::GetCellXPos | ( | const GridModel & | model,
 |  | const DeviceContext & | dc,
 |  | const Cell & | cell
 | ) | const

Returns the x-position of the item with the cell cell.

XYDIM GridView::GetCellYPos | ( | const GridModel & | model,
 |  | const DeviceContext & | dc,
 |  | const Cell & | cell
 | ) | const

Returns the y-position of the item with the cell cell.

XYDIM GridView::GetColTitleHeight ( ) const [inline]

Returns the height of the column title.

INT GridView::GetLastCompletelyVisibleRow | ( | const GridModel & | model,
 |  | const DeviceContext & | dc
 | ) | const

Returns the last completely visible row of the grid.

INT GridView::GetLastVisibleRow | ( | const GridModel & | model,
 |  | const DeviceContext & | dc
 | ) | const

Returns the last (partly) visible row of the grid.

XYDIM GridView::GetPosIndicatorWidth ( ) const [inline]

Returns the width of the position indicator.

XYDIM GridView::GetRowTitleWidth ( ) const [inline]

Returns the width of the row title.

void GridView::SetCellHeight ( XYDIM cell_height ) [inline]

Sets the cell-height of the grid.

void GridView::SetCellWidth ( XYDIM cell_width ) [inline]

Sets the cell-width of the grid.

void GridView::SetColTitleHeight ( XYDIM height ) [inline]

Sets the height of the column title.

void GridView::SetPosIndicatorWidth ( XYDIM pos_indicator_width ) [inline]

Sets the width of the position indicator.

void GridView::SetRowTitleWidth ( XYDIM width ) [inline]

Sets the width of the row title.

The documentation for this class was generated from the following files:
  • Compat/Grid.hpp
  • Compat/Grid.cpp
Generated on Wed Jan 25 01:17:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GroupProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GroupProvider Class Reference
[AdvPhonebook]

#include <Applications/AdvPhonebook/GroupProvider.hpp>

Inheritance diagram for GroupProvider:

[legend]
Collaboration diagram for GroupProvider:

[legend]

Public Types

typedef Provider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (IN INT columnid, IN INT row, OUT DataItem &item)
virtual INT | GetProviderId () const
Returns the provider id.
GroupProvider ()
void | Init ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual | ~GroupProvider ()

Data Structures

struct | GroupRec

Member Typedef Documentation

typedef Provider GroupProvider::Base

Constructor & Destructor Documentation

GroupProvider::GroupProvider ( )

GroupProvider::~GroupProvider ( ) [virtual]

Member Function Documentation

virtual BOOLEAN GroupProvider::GetDataItem | ( | IN INT | columnid,
 |  | IN INT | row,
 |  | OUT DataItem & | item
 | ) | [virtual]

INT GroupProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void GroupProvider::Init ( )

INT GroupProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/GroupProvider.hpp
  • Applications/AdvPhonebook/GroupProvider.cpp
Generated on Wed Jan 25 01:17:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GroupProvider::GroupRec Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
GroupProvider::GroupRec

GroupProvider::GroupRec Struct Reference

#include <Applications/AdvPhonebook/GroupProvider.hpp>

Collaboration diagram for GroupProvider::GroupRec:

[legend]

Data Fields

INT id
WString name

Field Documentation

INT GroupProvider::GroupRec::id

WString GroupProvider::GroupRec::name

The documentation for this struct was generated from the following file:
  • Applications/AdvPhonebook/GroupProvider.hpp
Generated on Wed Jan 25 01:17:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GsmBandList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GsmBandList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Types

enum | { MaxGsmBands = BAND_LIST_LENGTH }

Public Member Functions

GsmBandList | operator= (T_BAND_LIST gsm_band_list)
GsmBand & | operator[] (INT index)

Data Fields

GsmBand | gsm_bands [MaxGsmBands]

Member Enumeration Documentation

anonymous enum

Enumerator:
MaxGsmBands

Member Function Documentation

GsmBandList GsmBandList::operator= ( T_BAND_LIST gsm_band_list )

GsmBand& GsmBandList::operator[] ( INT index ) [inline]

Field Documentation

GsmBand GsmBandList::gsm_bands[MaxGsmBands]

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:17:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GsmBandStateMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GsmBandStateMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for GsmBandStateMsg:

[legend]
Collaboration diagram for GsmBandStateMsg:

[legend]

Public Types

enum | { ID = 18608 }

Public Member Functions

virtual Message * | Clone () const
const GsmBand & | GetGsmBand () const
virtual const MsgMetaData & | GetMetaData () const
GsmBandStateMsg (ExecutionContext *context, const GsmBand &gsm_band)
void | SetGsmBand (const GsmBand &gsm_band)
virtual | ~GsmBandStateMsg ()

Detailed Description

GsmBandStateMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

GsmBandStateMsg::GsmBandStateMsg | ( | ExecutionContext * | context,
 |  | const GsmBand & | gsm_band
 | ) |

GsmBandStateMsg::~GsmBandStateMsg ( ) [virtual]

Member Function Documentation

Message * GsmBandStateMsg::Clone ( ) const [virtual]

Implements Message.

const GsmBand& GsmBandStateMsg::GetGsmBand ( ) const [inline]

const MsgMetaData & GsmBandStateMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void GsmBandStateMsg::SetGsmBand ( const GsmBand & gsm_band ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:17:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Guid Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Guid Class Reference
[Services]

#include <Apoxi/AddOns/Services/Service.hpp>

Public Member Functions

BOOLEAN | operator!= (const Guid &guid) const
BOOLEAN | operator== (const Guid &guid) const

Data Fields

UINT32 | data1
UINT16 | data2
UINT16 | data3
UINT8 | data4 [8]

Member Function Documentation

BOOLEAN Guid::operator!= ( const Guid & guid ) const [inline]

BOOLEAN Guid::operator== ( const Guid & guid ) const [inline]

Field Documentation

UINT32 Guid::data1

UINT16 Guid::data2

UINT16 Guid::data3

UINT8 Guid::data4[8]

The documentation for this class was generated from the following file:
  • AddOns/Services/Service.hpp
Generated on Wed Jan 25 01:18:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuidServiceTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GuidServiceTable Class Reference
[Afs]

#include <Apoxi/Afs/GuidServiceTable.hpp>

Collaboration diagram for GuidServiceTable:

[legend]

Public Types

enum | { c_asot_max = APOXI_REG_MAX_ASOT }
maximum no of external trees More...

Static Public Member Functions

static ObjectTreeService * | GetObjectTreeforURI (const Uri &reg_uri)
returns the service ptr of external tree
static BOOLEAN | SetObjectTreeURI (const Uri &reg_uri, const Guid &guid)
stores the service ptr of external tree

Detailed Description

this table holds all the applications ASOT root and the corresponding service pointer

Member Enumeration Documentation

anonymous enum

maximum no of external trees

Enumerator:
c_asot_max

Member Function Documentation

ObjectTreeService * GuidServiceTable::GetObjectTreeforURI ( const Uri & passed_uri ) [static]

returns the service ptr of external tree

------------------------------------------------------------------------ GetObjectTreeforURI ------------------------------------------------------------------------

BOOLEAN GuidServiceTable::SetObjectTreeURI | ( | const Uri & | passed_uri,
 |  | const Guid & | passed_guid
 | ) | [static]

stores the service ptr of external tree

------------------------------------------------------------------------ SetObjectTreeURI ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/GuidServiceTable.hpp
  • Afs/GuidServiceTable.cpp
Generated on Wed Jan 25 01:18:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuidUriTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GuidUriTable Struct Reference
[Afs]

#include <Apoxi/Afs/GuidServiceTable.hpp>

Collaboration diagram for GuidUriTable:

[legend]

Data Fields

Uri rooturi
ObjectTreeService * serviceptr

Detailed Description

Stores the service pointers for the external object trees

Field Documentation

Uri GuidUriTable::rooturi

ObjectTreeService* GuidUriTable::serviceptr

The documentation for this struct was generated from the following file:
  • Afs/GuidServiceTable.hpp
Generated on Wed Jan 25 01:18:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiEngineConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GuiEngineConfig Class Reference
[Config]

#include <GuiEngineConfig.hpp>

Static Public Member Functions

static const ItemRendererProperties * | GetDefaultItemRendererProperties ()
static const ColorValue * | GetIconColorTable ()
static Size | GetIconSize (IconState::Size size)
static UINT32 | GetImageBufferMax ()
static ScrollBehavior | GetScrollBehavior ()
static UINT32 | GetSharedImageBufferMax ()
static AbstractTextRenderer & | GetTextRenderer (LanguageManager::LanguageType language_id)
static AbstractItemRenderer * | ObtainItemRenderer (const ItemRendererProperties *properties=0)
static void | ReleaseItemRenderer (AbstractItemRenderer *renderer)

Detailed Description

Allows accessing the GUI engine configuration. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static const ItemRendererProperties* GuiEngineConfig::GetDefaultItemRendererProperties ( ) [static]

Returns an instance of the item-renderer-properties which is used if no item-renderer-properties are specified for the item-renderer.

static const ColorValue* GuiEngineConfig::GetIconColorTable ( ) [static]

Returns a pointer to a color table for icons. Such a color table is required for native images using the indexed format. It's in the hand of the project configuration to decide how many colors are used for the icons, but the maximum is to return a pointer to 256 color values.

static Size GuiEngineConfig::GetIconSize ( IconState::Size size ) [static]

Returns the size corresponding the size defined by the icon-state.

static UINT32 GuiEngineConfig::GetImageBufferMax ( ) [static]

Returns the maximum available buffer for one decoded image. If 0 is returned, the maximum is only restricted by the available shared image-buffer (see GuiEngineConfig::GetSharedImageBufferMax). It might be useful to specify a image buffer maximum, if e. g. only a lot of small images should be buffered instead of one or two large images.

static ScrollBehavior GuiEngineConfig::GetScrollBehavior ( ) [static]

Defines the scroll behavior of all controls, where a selection can be made out of a number of items. Possible values are DefaultBehavior, BlockScrollBehavior and RotateBehavior.

static UINT32 GuiEngineConfig::GetSharedImageBufferMax ( ) [static]

Returns the maximum available buffer for all decoded images in bytes. If 0 is returned, no buffering is done. APOXI tries to buffer each decoded image to increase the drawing speed.

static AbstractTextRenderer& GuiEngineConfig::GetTextRenderer ( LanguageManager::LanguageType language_id ) [static]

Returns a text renderer applicable to the specified language, or a SimpleTextRenderer if the language does not support or need a text renderer

static AbstractItemRenderer* GuiEngineConfig::ObtainItemRenderer ( const ItemRendererProperties * properties = 0 ) [static]

Obtains an instance of the class AbstractItemRenderer which uses the properties as for the rendering of the items.

static void GuiEngineConfig::ReleaseItemRenderer ( AbstractItemRenderer * renderer ) [static]

Releases the previously obtained instance of the renderer.

The documentation for this class was generated from the following file:
  • GuiEngineConfig.hpp
Generated on Wed Jan 25 01:18:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiObjectFactory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

GuiObjectFactory Class Reference
[Config]

#include <GuiObjectFactory.hpp>

Public Types

enum ClassType {
UnknownClassType = 255, ObjectReference = 0, AlertClassType = 1, AnimatedTextLineClassType = 2,
CheckBoxControlClassType = 3, ContextMenuClassType = 4, DateEditorClassType = 5, ImageBoxClassType = 6,
IpAddrEditorClassType = 7, ItemGridClassType = 8, ItemMenuClassType = 9, ItemTreeClassType = 10,
LayouterControlClassType = 11, LineEditorClassType = 12, MessageBoxClassType = 13, MultiLineEditorClassType = 14,
MultiMediaEditorClassType = 15, PasswordEditorClassType = 16, ProgressBarClassType = 17, PushButtonClassType = 18,
RadioButtonControlClassType = 19, RadioButtonGroupClassType = 20, TextLineClassType = 21, TimeEditorClassType = 22,
WindowClassType = 23, ItemMenuWindowClassType = 24, AtlWindowClassType = 25, AbstractEditorClassType = 26,
AbstractGridClassType = 27, AbstractItemContainerClassType = 28, AbstractItemGridClassType = 29, AbstractLineEditorClassType = 30,
AbstractMultiLineEditorClassType = 31, AbstractPredictiveInputBoxClassType = 32, AbstractTextObjectClassType = 33, ActionClassType = 34,
ComponentClassType = 35, ControlClassType = 36, DispatcherClassType = 37, DrawableObjectClassType = 38,
ImageObtainerClassType = 39, ItemClassType = 40, ItemContainerClassType = 41, ItemRendererPropertiesClassType = 42,
PositionIndicatorClassType = 43, TextFormatClassType = 44, MenuDescClassType = 45, MenuPropertiesClassType = 46,
FeatureItemContainerClassType = 47, MenuMapClassType = 48, PropertyContainerClassType = 49, FeatureItemClassType = 50,
TextBoxClassType = 51, CloseWindowActionClassType = 52, OpenWindowActionClassType = 53, RadioButtonActionClassType = 54,
ContextFeatureItemClassType = 55, MenuResourceTableType = 56, CtResourcePackClassType = 57, PropertyItemClassType = 58,
ItemBoxClassType = 59, IndicatorItemClassType = 60, PropertyDescriptorClassType = 61, AtlItemBoxClassType = 62,
ValueMappingPropertyDescriptorClassType = 63, MappingPolicyClassType = 64, RangeMappingPolicyClassType = 65, ProgressPropertyDescriptorClassType = 66,
PasswordPropertyDescriptorClassType = 67
}
enum ParseType {
UnknownType, BooleanType, XyDimType, IntegerType,
UInt8Type, UInt16Type, WStringType, StringType,
ColorType, RectType, IpAddrType, DateType,
TimeType, SizeType, PositionType, FrameType,
ParentAreaType, CornerType, TextAttrType, TextAlignType,
FontAlignType, AnimatedTextLineAnimType, MessageBoxType, InputMapperIdType,
PredInputMapperPredModeType, ItemRendererPropertiesType, ItemRendererPropertiesDisplayType, ItemRendererPropertiesAnimType,
PositionIndicatorOrientationType, MenuType, FontSystemFontIdType, CellPropsType,
RowColumnPropType, FeatureKeyType, TextIconPairType, AlignInfoPropsType
}
enum PropertyId {
UnknownProp = 255, DelayProp = 0, TextProp = 1, TextFormatProp = 2,
TextLineAnimTypeProp = 3, StartDelayProp = 4, AnimSpeedProp = 5, StepProp = 6,
BoundsProp = 7, SelectedProp = 8, XProp = 9, YProp = 10,
CornerProp = 11, ItemContProp = 12, DateProp = 13, ObtainerProp = 14,
AutostartProp = 15, BufferingProp = 16, IpAddrProp = 17, ColumnCountProp = 18,
AdjustWinTitleProp = 19, RowCountProp = 20, ColCountProp = 21, MinSizeProp = 22,
CellsProp = 23, RowPropertiesProp = 24, ColumnPropertiesProp = 25, MaxTextLengthProp = 26,
FontProp = 27, TypeProp = 28, TitleProp = 29, MessageProp = 30,
ReadOnlyProp = 31, LineHeightProp = 32, TextAttrProp = 33, ForegroundcolorProp = 34,
BackgroundcolorProp = 35, TopLineGapProp = 36, BottomLineGapProp = 37, ProgressProp = 38,
RadioButtonGroupProp = 39, VerticalCenteredProp = 40, TimeProp = 41, FocusPriorityProp = 42,
SkActionsProp = 43, LeftSoftkeyProp = 44, RightSoftkeyProp = 45, MenuIdProp = 46,
ActionProp = 47, InputMapperIdProp = 48, ItemProp = 49, RendererPropertiesProp = 50,
PositionIndicatorEnabledProp = 51, MEditorProp = 52, ModeProp = 53, ColorProp = 54,
FrameTypeProp = 55, AutoClearEnabledProp = 56, MaximizedProp = 57, EnabledProp = 58,
DisabledProp = 59, DisplayIdxProp = 60, ComponentsProp = 61, AutoLayoutProp = 62,
ImageUriProp = 63, IconProp = 64, SyncModeEnabledProp = 65, ItemRendererDisplayTypeProp = 66,
ItemRendererAnimTypeProp = 67, ScrollDelayProp = 68, ScrollGapProp = 69, FullScreenPerItemProp = 70,
TransparentProp = 71, MultiLineProp = 72, CenteredVerticalProp = 73, IndicateItemContProp = 74,
BackgrColorProp = 75, HeightProp = 76, GapProp = 77, OrientationProp = 78,
MinValueProp = 79, MaxValueProp = 80, VisibleValuesCountProp = 81, ValueProp = 82,
TextAlignProp = 83, FontAlignProp = 84, FeatureItemContainerProp = 85, MenuPropertiesProp = 86,
MenuTypeProp = 87, FeatureItemContainerIdProp = 88, ItemsProp = 89, MenuPositionProp = 90,
ActualViewProp = 91, EndUserDefineableViewsProp = 92, IsEndUserDefineableProp = 93, DefaultViewProp = 94,
MenuMapMenuIdsProp = 95, MenuMapMenuDescProp = 96, PropertyListProp = 97, AppIdProp = 98,
FeatureIdProp = 99, StartAnimationProp = 100, WindowProp = 101, ModalProp = 102,
DispatcherProp = 103, PosProp = 104, ItemRendererProp = 105, ContextItemProp = 106,
CloseAfterTriggerProp = 107, MenuResourceTableEntryProp = 108, LargeIconProp = 109, MenuResourceTableSizeProp = 110,
MenuResourceTableEntryResourceIdProp = 111, MenuResourceTableEntryMenuIdProp = 112, IsSeparatorProp = 113, PropertyItemEditorProp = 114,
PropertyItemTypeProp = 115, FeatureKeyProp = 116, PropertyDescriptorProp = 117, LabelProp = 118,
TextIconPairCountProp = 119, TextIconPairProp = 120, MappingPolicyProp = 121, RangeCountProp = 122,
IconValueMapProp = 123, BackgroundImageProp = 124, FrameLayoutHintProp = 125, ParentAreaProp = 126,
HorizontalProp = 127, AlignInfoProps = 128, PropCount = 129
}

Static Public Member Functions

static void * | Create (ResourceParser &parser, const GuiObjectDescr &descr)
static CTResourcePack * | CreateCtResourcePack (CTResourceParser &parser, UINT16 id)
static BOOLEAN | Destroy (void *instance, GuiObjectFactory::ClassType class_type, BOOLEAN force)
static BOOLEAN | Finalize (void *src_gui_obj, GuiObjectFactory::ClassType src_class_type, void *target_gui_obj, GuiObjectFactory::PropertyId prop_id)
static BOOLEAN | GetPropertyValue (ResourceParser &parser, GuiObjectFactory::ParseType parse_type, void *value)
static BOOLEAN | IsComponent (ClassType class_type)
static GuiObjectFactory::ClassType | MapBinaryIdToClassType (UINT8 class_id)
static GuiObjectFactory::PropertyId | MapBinaryIdToPropertyId (UINT8 prop_id)
static GuiObjectFactory::ParseType | MapPropertyIdToParseType (const GuiObjectFactory::PropertyId property_id)

Detailed Description

Provides the connection between the generated sources from the ARAGON tool and APOXI. Custom components which should be editable by the ARAGON tool must be added here.

Member Enumeration Documentation

enum GuiObjectFactory::ClassType

For each component a ClassType must be available. This allows a dynamic creation of an instance out of a resource file. The IDs 0 - 999 are reserved for APOXI, the IDs 1000 - 1999 for the Reference MMI. IDs starting with 2000 are available for custom components.

The preferred way of implementing custom class types: 1) define APOXI_ARAGON_CUSTOM_CLASSTYPES_START 1000 2) in MapBinaryIdToClassType, make a second array with your new class types, analogous to class_type_array, e.g. custom_class_type_array also make an analogous variable to nr_class_types, e.g. nr_custom_class_types 3) change the if statement in MapBinaryIdToClassType as follows: if ((class_id >= APOXI_ARAGON_CUSTOM_CLASSTYPES_START) && (class_id - APOXI_ARAGON_CUSTOM_CLASSTYPES_START < nr_custom_class_types)) return custom_class_type_array[class_id - APOXI_ARAGON_CUSTOM_CLASSTYPES_START]; else if (class_id < nr_class_types) return class_type_array[class_id]; else else GuiObjectFactory::UnknownClassType;

This can be done analogously for PropertyTypes.

Enumerator:
UnknownClassType
ObjectReference
AlertClassType
AnimatedTextLineClassType
CheckBoxControlClassType
ContextMenuClassType
DateEditorClassType
ImageBoxClassType
IpAddrEditorClassType
ItemGridClassType
ItemMenuClassType
ItemTreeClassType
LayouterControlClassType
LineEditorClassType
MessageBoxClassType
MultiLineEditorClassType
MultiMediaEditorClassType
PasswordEditorClassType
ProgressBarClassType
PushButtonClassType
RadioButtonControlClassType
RadioButtonGroupClassType
TextLineClassType
TimeEditorClassType
WindowClassType
ItemMenuWindowClassType
AtlWindowClassType
AbstractEditorClassType
AbstractGridClassType
AbstractItemContainerClassType
AbstractItemGridClassType
AbstractLineEditorClassType
AbstractMultiLineEditorClassType
AbstractPredictiveInputBoxClassType
AbstractTextObjectClassType
ActionClassType
ComponentClassType
ControlClassType
DispatcherClassType
DrawableObjectClassType
ImageObtainerClassType
ItemClassType
ItemContainerClassType
ItemRendererPropertiesClassType
PositionIndicatorClassType
TextFormatClassType
MenuDescClassType
MenuPropertiesClassType
FeatureItemContainerClassType
MenuMapClassType
PropertyContainerClassType
FeatureItemClassType
TextBoxClassType
CloseWindowActionClassType
OpenWindowActionClassType
RadioButtonActionClassType
ContextFeatureItemClassType
MenuResourceTableType
CtResourcePackClassType
PropertyItemClassType
ItemBoxClassType
IndicatorItemClassType
PropertyDescriptorClassType
AtlItemBoxClassType
ValueMappingPropertyDescriptorClassType
MappingPolicyClassType
RangeMappingPolicyClassType
ProgressPropertyDescriptorClassType
PasswordPropertyDescriptorClassType

enum GuiObjectFactory::ParseType

Types for parsing a resource file. It is not required to extend the parsing types because of a custom component.

Enumerator:
UnknownType
BooleanType
XyDimType
IntegerType
UInt8Type
UInt16Type
WStringType
StringType
ColorType
RectType
IpAddrType
DateType
TimeType
SizeType
PositionType
FrameType
ParentAreaType
CornerType
TextAttrType
TextAlignType
FontAlignType
AnimatedTextLineAnimType
MessageBoxType
InputMapperIdType
PredInputMapperPredModeType
ItemRendererPropertiesType
ItemRendererPropertiesDisplayType
ItemRendererPropertiesAnimType
PositionIndicatorOrientationType
MenuType
FontSystemFontIdType
CellPropsType
RowColumnPropType
FeatureKeyType
TextIconPairType
AlignInfoPropsType

enum GuiObjectFactory::PropertyId

Describes the properties of a component. The IDs 0 - 999 are reserved for APOXI, the IDs 1000 - 1999 for the Reference MMI. IDs starting with 2000 are available for custom components.

Enumerator:
UnknownProp
DelayProp
TextProp
TextFormatProp
TextLineAnimTypeProp
StartDelayProp
AnimSpeedProp
StepProp
BoundsProp
SelectedProp
XProp
YProp
CornerProp
ItemContProp
DateProp
ObtainerProp
AutostartProp
BufferingProp
IpAddrProp
ColumnCountProp
AdjustWinTitleProp
RowCountProp
ColCountProp
MinSizeProp
CellsProp
RowPropertiesProp
ColumnPropertiesProp
MaxTextLengthProp
FontProp
TypeProp
TitleProp
MessageProp
ReadOnlyProp
LineHeightProp
TextAttrProp
ForegroundcolorProp
BackgroundcolorProp
TopLineGapProp
BottomLineGapProp
ProgressProp
RadioButtonGroupProp
VerticalCenteredProp
TimeProp
FocusPriorityProp
SkActionsProp
LeftSoftkeyProp
RightSoftkeyProp
MenuIdProp
ActionProp
InputMapperIdProp
ItemProp
RendererPropertiesProp
PositionIndicatorEnabledProp
MEditorProp
ModeProp
ColorProp
FrameTypeProp
AutoClearEnabledProp
MaximizedProp
EnabledProp
DisabledProp
DisplayIdxProp
ComponentsProp
AutoLayoutProp
ImageUriProp
IconProp
SyncModeEnabledProp
ItemRendererDisplayTypeProp
ItemRendererAnimTypeProp
ScrollDelayProp
ScrollGapProp
FullScreenPerItemProp
TransparentProp
MultiLineProp
CenteredVerticalProp
IndicateItemContProp
BackgrColorProp
HeightProp
GapProp
OrientationProp
MinValueProp
MaxValueProp
VisibleValuesCountProp
ValueProp
TextAlignProp
FontAlignProp
FeatureItemContainerProp
MenuPropertiesProp
MenuTypeProp
FeatureItemContainerIdProp
ItemsProp
MenuPositionProp
ActualViewProp
EndUserDefineableViewsProp
IsEndUserDefineableProp
DefaultViewProp
MenuMapMenuIdsProp
MenuMapMenuDescProp
PropertyListProp
AppIdProp
FeatureIdProp
StartAnimationProp
WindowProp
ModalProp
DispatcherProp
PosProp
ItemRendererProp
ContextItemProp
CloseAfterTriggerProp
MenuResourceTableEntryProp
LargeIconProp
MenuResourceTableSizeProp
MenuResourceTableEntryResourceIdProp
MenuResourceTableEntryMenuIdProp
IsSeparatorProp
PropertyItemEditorProp
PropertyItemTypeProp
FeatureKeyProp
PropertyDescriptorProp
LabelProp
TextIconPairCountProp
TextIconPairProp
MappingPolicyProp
RangeCountProp
IconValueMapProp
BackgroundImageProp
FrameLayoutHintProp
ParentAreaProp
HorizontalProp
AlignInfoProps
PropCount

Member Function Documentation

static void* GuiObjectFactory::Create | ( | ResourceParser & | parser,
 |  | const GuiObjectDescr & | descr
 | ) | [static]

Creates a new instance of the specified object and adds it to the resource manager's list of created objects.

Parameters:
parser | the parser instance used to parse the resource file. The parser must already be at the correct position within the file (i.e. it must have parsed the information of the object (id, class type)) to parse the object's properties.
descr | the object's description.
See also:
GuiObjectDescr
Returns:
a pointer to the newly created object, or 0 if the object could not be created properly.

static CTResourcePack* GuiObjectFactory::CreateCtResourcePack | ( | CTResourceParser & | parser,
 |  | UINT16 | id
 | ) | [static]

Creates a new instance of a resource pack for the CustomizableTheme and adds it to the resource manager's list of created objects.

Parameters:
parser | the parser
id | the resource pack's id
Returns:
a pointer to the resource pack. If the resource pack could not be parsed, it will contain only the default values.

static BOOLEAN GuiObjectFactory::Destroy | ( | void * | instance,
 |  | GuiObjectFactory::ClassType | class_type,
 |  | BOOLEAN | force
 | ) | [static]

Deletes the specified object from memory. This method is called by the ResourceManager. Deleting objects is accomplished on two runs, where on the first run force is FALSE, while on the second run it is TRUE. The reason for this is that some objects may need to have their parent deleted before it can be deleted itself, e.g. an

See also:
Item can only be deleted after its parent container has been deleted.
Parameters:
instance | a pointer to the object's instance
class_type | the object's type
force | if TRUE, delete the object. This may be ignored by the implementation for specific objects.
Returns:
TRUE if deletion was okay, FALSE otherwise.

static BOOLEAN GuiObjectFactory::Finalize | ( | void * | src_gui_obj,
 |  | GuiObjectFactory::ClassType | src_class_type,
 |  | void * | target_gui_obj,
 |  | GuiObjectFactory::PropertyId | prop_id
 | ) | [static]

Called by the ResourceManager after parsing a GUI layout if some components in it have not been initialized completely. This may happen if e.g. a CloseWindowAction class references a window that has not yet been parsed at the time of its creation, i.e. the window is specified later in the resource file. The ResourceManager recognizes this, and attempts to link all uninitialized objects after the complete file has been parsed. To this effect it will call this method, which implements the code to do so.

Parameters:
src_gui_obj | a pointer to the yet incompletely initialised object
src_class_type | the yet incompletely initialised object's class type
target_gui_obj | a pointer to the referenced object
prop_id | the property that needs to be set to complete src_gui_obj's intialization
Returns:
TRUE if everything went ok, FALSE otherwise.

static BOOLEAN GuiObjectFactory::GetPropertyValue | ( | ResourceParser & | parser,
 |  | GuiObjectFactory::ParseType | parse_type,
 |  | void * | value
 | ) | [static]

This is the fallback method called by ResourceParser::GetPropertyValue if it does not know how to parse parse_type. Implement its parsing here. This can be used to implement parsing of special data types (basic data types can be parsed by the resource parser). Thus new data types can be parsed without the need to extend the resource parser.

Parameters:
parser | a reference to the parser
parse_type | the parse type of the property to be parsed
value | a void pointer to the data that was read.
Returns:
TRUE if parsing went ok, FALSE otherwise.

static BOOLEAN GuiObjectFactory::IsComponent ( ClassType class_type ) [static]

This method is used to check if class_type specifies a

See also:
Component.
Returns:
TRUE if the class type describes objects that are in some way derived from the Component class.

static GuiObjectFactory::ClassType GuiObjectFactory::MapBinaryIdToClassType ( UINT8 class_id ) [static]

Maps the class id read from the resource file to the enum ClassType.

Parameters:
class_id the class ID read from the resource file.
Returns:
the corresponding ClassType, or UnknownClassType if class_id is unknown.

static GuiObjectFactory::PropertyId GuiObjectFactory::MapBinaryIdToPropertyId ( UINT8 prop_id ) [static]

Maps the property id read from the resource file to the enum PropertyId.

Parameters:
prop_id the property ID read from the resource file.
Returns:
the corresponding PropertyId, or UnknownProp if prop_id is unknown.

static GuiObjectFactory::ParseType GuiObjectFactory::MapPropertyIdToParseType ( const GuiObjectFactory::PropertyId property_id ) [static]

Maps a property id to the ParseType. The ParseType specifies how to parse the property's value from the resource file; e.g. a "text" property (e.g. "window title") will probably return "WStringType". This tells the parser how to interpret the next bytes in the file.

Parameters:
property_id the id of the property we want to parse.
Returns:
the corresponding ParseType, or UnknownType if property_id is unknown.

The documentation for this class was generated from the following file:
  • GuiObjectFactory.hpp
Generated on Wed Jan 25 01:18:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HandlerData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HandlerData Struct Reference
[APOXI Stack Control]

#include <Apoxi/Asc/HandlerData.hpp>

Collaboration diagram for HandlerData:

[legend]

Public Member Functions

HandlerId | Id () const
BOOLEAN | IsExclusive () const
BOOLEAN | IsLocked () const
BOOLEAN | Lock (MainHandler *main_handler)
BOOLEAN | Unlock (MainHandler *main_handler)

Data Fields

BaseHandler *(* | CreateHandler )()
HandlerId m_id
BOOLEAN | m_is_exclusive
MainHandler * m_locked_by

Member Function Documentation

HandlerId HandlerData::Id ( ) const [inline]

BOOLEAN HandlerData::IsExclusive ( ) const [inline]

BOOLEAN HandlerData::IsLocked ( ) const

BOOLEAN HandlerData::Lock ( MainHandler * main_handler )

BOOLEAN HandlerData::Unlock ( MainHandler * main_handler )

Field Documentation

BaseHandler*(* HandlerData::CreateHandler)()

HandlerId HandlerData::m_id

BOOLEAN HandlerData::m_is_exclusive

MainHandler* HandlerData::m_locked_by

The documentation for this struct was generated from the following files:
  • Asc/HandlerData.hpp
  • Asc/HandlerData.cpp
Generated on Wed Jan 25 01:18:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HandlerFactory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HandlerFactory Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/HandlerFactory.hpp>

Static Public Member Functions

static BaseHandler * | CreateAccHandler ()
static BaseHandler * | CreateAocHandler ()
static BaseHandler * | CreateAtcHandler ()
static BaseHandler * | CreateBootHandler ()
static BaseHandler * | CreateCallBarringHandler ()
static BaseHandler * | CreateCallControlHandler ()
static BaseHandler * | CreateCallDeflectionHandler ()
static BaseHandler * | CreateCallForwardingHandler ()
static BaseHandler * | CreateCallHandler ()
static BaseHandler * | CreateCallWaitingHandler ()
static BaseHandler * | CreateCbsHandler ()
static BaseHandler * | CreateClipHandler ()
static BaseHandler * | CreateClirHandler ()
static BaseHandler * | CreateCnapHandler ()
static BaseHandler * | CreateColpHandler ()
static BaseHandler * | CreateColrHandler ()
static BaseHandler * | CreateCrssHandler ()
static BaseHandler * | CreateEmlppHandler ()
static BaseHandler * | CreateMocVoiceHandler ()
static BaseHandler * | CreateMoUssdHandler ()
static BaseHandler * | CreateMtcVoiceHandler ()
static BaseHandler * | CreateMultiSlotHandler ()
static BaseHandler * | CreateNetworkHandler ()
static BaseHandler * | CreatePlmnHandler ()
static BaseHandler * | CreatePowerHandler ()
static BaseHandler * | CreateSigHandler ()
static BaseHandler * | CreateSimHandler ()
static BaseHandler * | CreateSimTkHandler ()
static BaseHandler * | CreateSmsHandler ()
static BaseHandler * | CreateSsCcbsHandler ()
static BaseHandler * | CreateSsMainHandler ()
Supplementary services (call independent).
static BaseHandler * | CreateUssdHandler ()

Member Function Documentation

static BaseHandler* HandlerFactory::CreateAccHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateAocHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateAtcHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateBootHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCallBarringHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCallControlHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCallDeflectionHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCallForwardingHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCallHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCallWaitingHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCbsHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateClipHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateClirHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCnapHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateColpHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateColrHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateCrssHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateEmlppHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateMocVoiceHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateMoUssdHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateMtcVoiceHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateMultiSlotHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateNetworkHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreatePlmnHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreatePowerHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateSigHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateSimHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateSimTkHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateSmsHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateSsCcbsHandler ( ) [inline, static]

static BaseHandler* HandlerFactory::CreateSsMainHandler ( ) [inline, static]

Supplementary services (call independent).

static BaseHandler* HandlerFactory::CreateUssdHandler ( ) [inline, static]

The documentation for this class was generated from the following file:
  • Asc/HandlerFactory.hpp
Generated on Wed Jan 25 01:18:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HandlerListEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HandlerListEntry Struct Reference
[APOXI Stack Control]

#include <Apoxi/Asc/HandlerList.hpp>

Inheritance diagram for HandlerListEntry:

[legend]
Collaboration diagram for HandlerListEntry:

[legend]

Public Member Functions

BOOLEAN | Cleanup (MainHandler *main_handler, BOOLEAN force=FALSE)
BaseHandler * | GetHandler () const
HandlerListEntry (HandlerId m_id)
HandlerId | Id () const
BOOLEAN | Init (MainHandler *main_handler)
virtual | ~HandlerListEntry ()

Friends

class | MainHandler

Constructor & Destructor Documentation

HandlerListEntry::HandlerListEntry ( HandlerId m_id )

HandlerListEntry::~HandlerListEntry ( ) [virtual]

Member Function Documentation

BOOLEAN HandlerListEntry::Cleanup | ( | MainHandler * | main_handler,
 |  | BOOLEAN | force = FALSE
 | ) |

BaseHandler* HandlerListEntry::GetHandler ( ) const [inline]

HandlerId HandlerListEntry::Id ( ) const [inline]

BOOLEAN HandlerListEntry::Init ( MainHandler * main_handler )

Friends And Related Function Documentation

friend class MainHandler [friend]

The documentation for this struct was generated from the following files:
  • Asc/HandlerList.hpp
  • Asc/HandlerList.cpp
Generated on Wed Jan 25 01:18:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Hashable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Hashable Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/HashTable.hpp>

Inheritance diagram for Hashable:

[legend]
Collaboration diagram for Hashable:

[legend]

Public Member Functions

virtual HashKey GetKey () const
Hashable (HashKey key=0)

Detailed Description

Every object of a class derived from Hashable is able to be embedded into a HashTable and provides automatically a method for getting a key element.

Constructor & Destructor Documentation

Hashable::Hashable ( HashKey key = 0 ) [inline]

Member Function Documentation

virtual HashKey Hashable::GetKey ( ) const [inline, virtual]

The documentation for this class was generated from the following file:
  • Auxiliary/HashTable.hpp
Generated on Wed Jan 25 01:18:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HashTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HashTable Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/HashTable.hpp>

Collaboration diagram for HashTable:

[legend]

Public Member Functions

virtual BOOLEAN | AddElem (Hashable *elem)
virtual Hashable * | GetElem (HashKey key) const
virtual INT | GetSize () const
HashTable (UINT16 init_size)
virtual void | RemoveElem (HashKey key)
virtual | ~HashTable ()

Protected Member Functions

virtual HashKey | Hash (HashKey key) const

Detailed Description

A HashTable is a container taking objects of type Hashable. It provides a pretty fast access to the stored objects.

Constructor & Destructor Documentation

HashTable::HashTable ( UINT16 init_size )

virtual HashTable::~HashTable ( ) [inline, virtual]

Member Function Documentation

BOOLEAN HashTable::AddElem ( Hashable * elem ) [virtual]

Hashable * HashTable::GetElem ( HashKey key ) const [virtual]

virtual INT HashTable::GetSize ( ) const [inline, virtual]

HashKey HashTable::Hash ( HashKey key ) const [protected, virtual]

void HashTable::RemoveElem ( HashKey key ) [virtual]

The documentation for this class was generated from the following files:
  • Auxiliary/HashTable.hpp
  • Auxiliary/HashTable.cpp
Generated on Wed Jan 25 01:18:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeaderData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HeaderData Struct Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/MultipartParser.hpp>

Collaboration diagram for HeaderData:

[legend]

Data Fields

String m_name
Header name like Content-Type, Content-ID etc.
String m_value
Header value like text/plain, image/jpeg etc.

Detailed Description

HeaderData is a used to store the parsed header information in header name and value pair

Field Documentation

String HeaderData::m_name

Header name like Content-Type, Content-ID etc.

String HeaderData::m_value

Header value like text/plain, image/jpeg etc.

The documentation for this struct was generated from the following file:
  • AddOns/Drm/MultipartParser.hpp
Generated on Wed Jan 25 01:18:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeadSet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HeadSet Class Reference

#include <Apoxi/Apc/Accessory.hpp>

Collaboration diagram for HeadSet:

[legend]

Public Member Functions

HeadSet (Accessory *accessory)
BOOLEAN | IsAttached () const
BOOLEAN | IsMono () const
void | SetAttached (BOOLEAN attached)

Constructor & Destructor Documentation

HeadSet::HeadSet ( Accessory * accessory ) [inline]

Member Function Documentation

BOOLEAN HeadSet::IsAttached ( ) const [inline]

BOOLEAN HeadSet::IsMono ( ) const [inline]

void HeadSet::SetAttached ( BOOLEAN attached ) [inline]

The documentation for this class was generated from the following file:
  • Apc/Accessory.hpp
Generated on Wed Jan 25 01:18:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapArrayObject< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HeapArrayObject< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/HeapObject.hpp>

Collaboration diagram for HeapArrayObject< T >:

[legend]

Public Member Functions

void | Attach (T *data)
HeapArrayObject ()
HeapArrayObject (T *data)
T * | operator() () const
~HeapArrayObject ()

template<class T>
class HeapArrayObject< T >

Constructor & Destructor Documentation

template<class T>
HeapArrayObject< T >::HeapArrayObject ( T * data ) [inline]

template<class T>
HeapArrayObject< T >::HeapArrayObject ( ) [inline]

template<class T>
HeapArrayObject< T >::~HeapArrayObject ( ) [inline]

Member Function Documentation

template<class T>
void HeapArrayObject< T >::Attach ( T * data ) [inline]

template<class T>
T* HeapArrayObject< T >::operator() ( ) const [inline]

The documentation for this class was generated from the following file:
  • Auxiliary/HeapObject.hpp
Generated on Wed Jan 25 01:18:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapDataSink Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HeapDataSink Class Reference

#include <Apoxi/Auxiliary/HeapDataSink.hpp>

Inheritance diagram for HeapDataSink:

[legend]
Collaboration diagram for HeapDataSink:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | GetSize (UINT32 &size) const
HeapDataSink (UINT32 block_size, DrmLocalId id=c_drm_invalid_local_id)
virtual BOOLEAN | IsOpen () const
virtual BOOLEAN | Open ()
virtual UINT32 | Write (UINT32 offset, const void HUGE *buf, UINT32 nbytes)
virtual UINT32 | Write (const void HUGE *buf, UINT32 nbytes)
virtual | ~HeapDataSink ()

Friends

class | HeapDataSource

Detailed Description

Class HeapDataSink implements a data sink which writes to the heap memory.

Constructor & Destructor Documentation

HeapDataSink::HeapDataSink | ( | UINT32 | block_size,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) |

Creates a heap data sink instance. This data sink writes the given data to the heap memory. The heap data sink has to be opened using method Open() before writing to it. On destruction, the heap data sink will be closed automatically if not explicitly done before.

Parameters:
block_size | Defines the size of the heap memory blocks the data sink allocates.
id | The DRM local ID.

HeapDataSink::~HeapDataSink ( ) [virtual]

Destroys the heap data sink and releases all memory occupied.

Member Function Documentation

BOOLEAN HeapDataSink::Close ( ) [virtual]

Closes the heap data sink. After closing the data sink it cannot be opened again and data written any more.

Returns:
Success of operation.

Implements DataSink.

BOOLEAN HeapDataSink::GetSize ( UINT32 & size ) const [virtual]

Returns the size of the data sink in terms of bytes. The size of the data sink is actually defined by the amount of data written at the end of the data sink.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implements DataSink.

BOOLEAN HeapDataSink::IsOpen ( ) const [virtual]

Returns whether the heap data sink is currently open or closed.

Returns:
Whether the heap data sink is open or not.

Implements DataSink.

BOOLEAN HeapDataSink::Open ( ) [virtual]

Opens the heap data sink for writing. The size of a freshly opened heap data sink is 0. A heap data sink can only be written if it has been opened before.

Returns:
Success of operation.

Implements DataSink.

UINT32 HeapDataSink::Write | ( | UINT32 | offset,
 |  | const void HUGE * | buf,
 |  | UINT32 | nbytes
 | ) | [virtual]

Writes nbytes bytes of buffer buf to the data sink at the given offset. Note, that this method is only allowed to be used to overwrite existing data. Hence, if the given offset plus the number of bytes to write nbytes is larger than the current size of the data sink then an assertion fails. Overriding methods must implement this assertion. Since this method only overrides existing data it does not affect the size of the data sink.

Parameters:
offset | The offset where to start writing.
buf | The buffer to be written.
nbytes | The number of bytes to be written.
Returns:
Number of bytes actually written.

Implements DataSink.

UINT32 HeapDataSink::Write | ( | const void HUGE * | buf,
 |  | UINT32 | nbytes
 | ) | [virtual]

Writes nbytes bytes of buffer buf to the data sink. The data is written at the end of the data sink and hence increases the size of the data sink by the amount of bytes written.

Parameters:
buf | The buffer to be written.
nbytes | The number of bytes to be written.
Returns:
Number of bytes actually written.

Implements DataSink.

Friends And Related Function Documentation

friend class HeapDataSource [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/HeapDataSink.hpp
  • Auxiliary/HeapDataSink.cpp
Generated on Wed Jan 25 01:18:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapDataSource Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HeapDataSource Class Reference

#include <Apoxi/Auxiliary/HeapDataSource.hpp>

Inheritance diagram for HeapDataSource:

[legend]
Collaboration diagram for HeapDataSource:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | GetSize (UINT32 &size) const
HeapDataSource (const HeapDataSinkPtr &sink)
virtual BOOLEAN | IsOpen () const
virtual BOOLEAN | Open ()
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 count)
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 count)
virtual | ~HeapDataSource ()

Detailed Description

Class HeapDataSource implements a data source which reads from an associated HeapDataSink instance.

Constructor & Destructor Documentation

HeapDataSource::HeapDataSource ( const HeapDataSinkPtr & sink )

Creates a heap data source instance. This data source reads from a heap data sink which internally controls heap memory blocks. The heap data source has to be opened using method Open() before reading from it. On destruction, the heap data source will be closed if not explicitly done before.

Parameters:
sink The heap data sink to read from.

HeapDataSource::~HeapDataSource ( ) [virtual]

Destroys the heap data source.

Member Function Documentation

BOOLEAN HeapDataSource::Close ( ) [virtual]

Closes the data source. After closing the data source it can not be read any more.

Returns:
Success of operation.

Implements DataSource.

BOOLEAN HeapDataSource::GetSize ( UINT32 & size ) const [virtual]

Returns the size of the data source in terms of bytes.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN HeapDataSource::IsOpen ( ) const [virtual]

Returns whether the data source is currently open or closed.

Returns:
Whether the data source is open or not.

Implements DataSource.

BOOLEAN HeapDataSource::Open ( ) [virtual]

Opens the data source for reading. Opening sets the current read position to the beginning of the data source. The read methods that do not use an offset argument always start to read at the current read position. A data source can only be read if it has been opened before.

Returns:
Success of operation.

Implements DataSource.

BOOLEAN HeapDataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [virtual]

Reads up to max_count bytes from this data source starting at offset and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. parameter offset is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! Note that this method does not affect the current read position. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadRandomDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 offset = 0;
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(offset, buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...

                    // Increase offset where to read next.
                    offset += bytes_read;
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN HeapDataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [virtual]

Reads exactly count bytes from this data source starting at offset and copies them to the provided buffer. Note that this method does not affect the current read position.

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN HeapDataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [virtual]

Reads up to max_count bytes from this data source starting at the current read position and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. the current read position is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! The current read position is updated. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadSequentialDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN HeapDataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [virtual]

Reads exactly count bytes from this data source starting at the current read position and copies them to the provided buffer. The current read position is updated.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implements DataSource.

The documentation for this class was generated from the following files:
  • Auxiliary/HeapDataSource.hpp
  • Auxiliary/HeapDataSource.cpp
Generated on Wed Jan 25 01:18:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HeapManager Class Reference
[Kernel]

#include <Apoxi/Kernel/HeapManager.hpp>

Collaboration diagram for HeapManager:

[legend]

Public Member Functions

HeapManager ()

Static Public Member Functions

static void * | Allocate (size_t nrofbytes, UINT heapid=0)
static void | DbgOut ()
static void | DbgOutContextUsage ()
static BOOLEAN | DumpMemoryConsumptionSnapshot ()
static BOOLEAN | DumpMemoryContextSnapshot ()
static BOOLEAN | EnablePeakMemoryContextOutput (BOOLEAN enable=TRUE)
static void | Free (void *address, UINT virtid=~0)
static BOOLEAN | GenerateMemoryConfig (UINT32 safetypercent=50)
static HeapVector::Page * | GetFirstPageEntry ()
static HeapVector::Page * | GetNextPageEntry ()
static BOOLEAN | GetOverallMemUsage (UINT32 &totalram, UINT32 &currentram, UINT32 &peakram)
static void HUGE * | HugeAllocate (UINT32 nrofbytes, UINT heapid=0)
static void | HugeFree (void HUGE *address, UINT virtid=~0)
static void HUGE * | HugeReAllocate (void HUGE *oldaddress, UINT32 newsize, BOOLEAN shallcopy)
static void | Initialize ()
static BOOLEAN | IsValidAddress (void *address)
static BOOLEAN | IsValidHugeAddress (void HUGE *address)
static void | OverallOverwriteCheck ()
static void * | ReAllocate (void *oldaddress, size_t newsize, BOOLEAN shallcopy)

Friends

class | HeapVector

Detailed Description

MemoryConfiguration

please refer to the APOXI MemoryManagement document for configuration.

DEFINES

APOXI_HEAP_MEM_POOL_TRACE: enables collecting information of memory pages and allow tracing out a visual view of all memory pages on the trace interface.

APOXI_HEAP_MEM_ALLOC_TRACE: enables trace output of each allocate and free call, shall be used only under Win32 because very much trace output is done.

APOXI_HEAP_MEM_CONTEXT_TRACE: enables collecting information of allocation per application/thread and allow tracing out a memory consumption per application and also per page/application related information. if this define is set also APOXI_HEAP_MEM_POOL_TRACE will be set automatically because also this information will be needed.

APOXI_HEAP_MEM_ACCESS_CHECK: enables checking wrong frees (double called) and memory overwrites. This define is set automatically under Win32.

APOXI_HEAP_MEM_DETECT_CONFIG: enables counting of memory usage and detecting of a memory configuration. This define is set automatically under Win32.

APOXI_HEAP_LENGTH_VECTOR (shall not be set manually): adds a length vector per page which contains the real length of the object which is allocated, this is necessary for overwrite checks and additional statistics. Take into account that additional memory is used to held length information.

APOXI_HEAP_CONTEXT_USAGE (shall not be set manually): adds a context vector per page which contains a context id of the object which is allocated, this is necessary for identification to which context an object belongs. Take into account that additional memory is used to held this context information.

APOXI_HEAP_NAME_USAGE (shall not be set manually): adds a character array per page which will be used for certain debug outputs. Take into account that additional memory is used to held this context information.

APOXI_HEAP_STATS_USAGE (shall not be set manually): adds a statistics structure per page which will be used for certain debug outputs. Take into account that additional memory is used to held this context information.

Constructor & Destructor Documentation

HeapManager::HeapManager ( )

Member Function Documentation

void * HeapManager::Allocate | ( | size_t | nrofbytes,
 |  | UINT | heapid = 0
 | ) | [static]

void HeapManager::DbgOut ( ) [static]

void HeapManager::DbgOutContextUsage ( ) [static]

BOOLEAN HeapManager::DumpMemoryConsumptionSnapshot ( ) [static]

BOOLEAN HeapManager::DumpMemoryContextSnapshot ( ) [static]

BOOLEAN HeapManager::EnablePeakMemoryContextOutput ( BOOLEAN enable = TRUE ) [static]

void HeapManager::Free | ( | void * | address,
 |  | UINT | virtid = ~0
 | ) | [static]

BOOLEAN HeapManager::GenerateMemoryConfig ( UINT32 safetypercent = 50 ) [static]

HeapVector::Page * HeapManager::GetFirstPageEntry ( ) [static]

HeapVector::Page * HeapManager::GetNextPageEntry ( ) [static]

BOOLEAN HeapManager::GetOverallMemUsage | ( | UINT32 & | totalram,
 |  | UINT32 & | currentram,
 |  | UINT32 & | peakram
 | ) | [static]

void HUGE * HeapManager::HugeAllocate | ( | UINT32 | nrofbytes,
 |  | UINT | heapid = 0
 | ) | [static]

void HeapManager::HugeFree | ( | void HUGE * | address,
 |  | UINT | virtid = ~0
 | ) | [static]

void HUGE * HeapManager::HugeReAllocate | ( | void HUGE * | oldaddress,
 |  | UINT32 | newsize,
 |  | BOOLEAN | shallcopy
 | ) | [static]

void HeapManager::Initialize ( ) [static]

BOOLEAN HeapManager::IsValidAddress ( void * address ) [static]

BOOLEAN HeapManager::IsValidHugeAddress ( void HUGE * address ) [static]

void HeapManager::OverallOverwriteCheck ( ) [static]

void * HeapManager::ReAllocate | ( | void * | oldaddress,
 |  | size_t | newsize,
 |  | BOOLEAN | shallcopy
 | ) | [static]

Friends And Related Function Documentation

friend class HeapVector [friend]

The documentation for this class was generated from the following files:
  • Kernel/HeapManager.hpp
  • Kernel/HeapManager.cpp
Generated on Wed Jan 25 01:18:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapObject< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HeapObject< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/HeapObject.hpp>

Inheritance diagram for HeapObject< T >:

[legend]
Collaboration diagram for HeapObject< T >:

[legend]

Public Member Functions

void | Attach (T *data)
HeapObject ()
HeapObject (T *data)
T * | operator() () const
virtual | ~HeapObject ()

template<class T>
class HeapObject< T >

Constructor & Destructor Documentation

template<class T>
HeapObject< T >::HeapObject ( T * data ) [inline]

template<class T>
HeapObject< T >::HeapObject ( ) [inline]

template<class T>
virtual HeapObject< T >::~HeapObject ( ) [inline, virtual]

Member Function Documentation

template<class T>
void HeapObject< T >::Attach ( T * data ) [inline]

template<class T>
T* HeapObject< T >::operator() ( ) const [inline]

The documentation for this class was generated from the following file:
  • Auxiliary/HeapObject.hpp
Generated on Wed Jan 25 01:18:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapVector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HeapVector Class Reference
[Kernel]

#include <Apoxi/Kernel/HeapVector.hpp>

Public Types

enum | { BITS_PER_UINT = sizeof(UINT) * 8 }
typedef void *(* | AllocateFunction )(Page *page, size_t nrofbytes)
typedef UINT8 | ContextId
typedef void(* | DbgOutContextFunction )(Page *page)
typedef void(* | DbgOutFunction )(Page *page)
typedef void(* | FreeFunction )(Page *page, const void *address)
typedef Stats *(* | GetStatsFunction )(Page *page)
typedef void(* | InitializeFunction )(Page *page)
typedef BOOLEAN(* | IsFreePageFunction )(Page *page)
typedef void(* | OverwriteCheckFunction )(Page *page)
typedef void *(* | ReAllocateFunction )(Page *page, UINT heapid, void *oldaddress, size_t newsize, BOOLEAN shallcopy)
typedef INT32(* | SizeFunction )(Page *page, const void *address)

Data Structures

struct | BlockPage
struct | FctTable
struct | HeapTableEntry
struct | Page
struct | Stats
struct | VarPage

Member Typedef Documentation

typedef void*(* HeapVector::AllocateFunction)(Page *page, size_t nrofbytes)

typedef UINT8 HeapVector::ContextId

typedef void(* HeapVector::DbgOutContextFunction)(Page *page)

typedef void(* HeapVector::DbgOutFunction)(Page *page)

typedef void(* HeapVector::FreeFunction)(Page *page, const void *address)

typedef Stats*(* HeapVector::GetStatsFunction)(Page *page)

typedef void(* HeapVector::InitializeFunction)(Page *page)

typedef BOOLEAN(* HeapVector::IsFreePageFunction)(Page *page)

typedef void(* HeapVector::OverwriteCheckFunction)(Page *page)

typedef void*(* HeapVector::ReAllocateFunction)(Page *page, UINT heapid, void *oldaddress, size_t newsize, BOOLEAN shallcopy)

typedef INT32(* HeapVector::SizeFunction)(Page *page, const void *address)

Member Enumeration Documentation

anonymous enum

Enumerator:
BITS_PER_UINT

The documentation for this class was generated from the following file:
  • Kernel/HeapVector.hpp
Generated on Wed Jan 25 01:18:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapVector::BlockPage Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
HeapVector::BlockPage

HeapVector::BlockPage Struct Reference

#include <Apoxi/Kernel/HeapVector.hpp>

Static Public Member Functions

static void * | Allocate (Page *page, size_t nrofbytes)
static void | DbgOut (Page *page)
static void | DbgOutContext (Page *page)
static void | Free (Page *page, const void *address)
static Stats * | GetStats (Page *page)
static void | Initialize (Page *page)
static BOOLEAN | IsFreePage (Page *page)
static void | OverwriteCheck (Page *page)
static void * | ReAllocate (Page *page, UINT heapid, void *oldaddress, size_t newsize, BOOLEAN shallcopy)
static INT32 | Size (Page *page, const void *address)

Data Fields

UINT * | m_bits
UINT | m_blockcounter
BOOLEAN | m_free
UINT8 * | m_memory
UINT16 * | m_sizevector

Member Function Documentation

void * HeapVector::BlockPage::Allocate | ( | Page * | page,
 |  | size_t | nrofbytes
 | ) | [static]

void HeapVector::BlockPage::DbgOut ( Page * page ) [static]

void HeapVector::BlockPage::DbgOutContext ( Page * page ) [static]

void HeapVector::BlockPage::Free | ( | Page * | page,
 |  | const void * | address
 | ) | [static]

HeapVector::Stats * HeapVector::BlockPage::GetStats ( Page * page ) [static]

void HeapVector::BlockPage::Initialize ( Page * page ) [static]

BOOLEAN HeapVector::BlockPage::IsFreePage ( Page * page ) [static]

void HeapVector::BlockPage::OverwriteCheck ( Page * page ) [static]

void * HeapVector::BlockPage::ReAllocate | ( | Page * | page,
 |  | UINT | heapid,
 |  | void * | oldaddress,
 |  | size_t | newsize,
 |  | BOOLEAN | shallcopy
 | ) | [static]

INT32 HeapVector::BlockPage::Size | ( | Page * | page,
 |  | const void * | address
 | ) | [static]

Field Documentation

UINT* HeapVector::BlockPage::m_bits

UINT HeapVector::BlockPage::m_blockcounter

BOOLEAN HeapVector::BlockPage::m_free

UINT8* HeapVector::BlockPage::m_memory

UINT16* HeapVector::BlockPage::m_sizevector

The documentation for this struct was generated from the following files:
  • Kernel/HeapVector.hpp
  • Kernel/HeapVector.cpp
Generated on Wed Jan 25 01:18:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapVector::FctTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
HeapVector::FctTable

HeapVector::FctTable Struct Reference

#include <Apoxi/Kernel/HeapVector.hpp>

Data Fields

AllocateFunction m_alloc_fct
DbgOutFunction m_dbgout_context_fct
DbgOutFunction m_dbgout_fct
FreeFunction m_free_fct
GetStatsFunction m_getstats_fct
InitializeFunction m_init_fct
IsFreePageFunction m_isfree_fct
OverwriteCheckFunction m_overwritecheck_fct
ReAllocateFunction m_realloc_fct
SizeFunction m_size_fct

Field Documentation

AllocateFunction HeapVector::FctTable::m_alloc_fct

DbgOutFunction HeapVector::FctTable::m_dbgout_context_fct

DbgOutFunction HeapVector::FctTable::m_dbgout_fct

FreeFunction HeapVector::FctTable::m_free_fct

GetStatsFunction HeapVector::FctTable::m_getstats_fct

InitializeFunction HeapVector::FctTable::m_init_fct

IsFreePageFunction HeapVector::FctTable::m_isfree_fct

OverwriteCheckFunction HeapVector::FctTable::m_overwritecheck_fct

ReAllocateFunction HeapVector::FctTable::m_realloc_fct

SizeFunction HeapVector::FctTable::m_size_fct

The documentation for this struct was generated from the following file:
  • Kernel/HeapVector.hpp
Generated on Wed Jan 25 01:18:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapVector::HeapTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
HeapVector::HeapTableEntry

HeapVector::HeapTableEntry Struct Reference

#include <Apoxi/Kernel/HeapVector.hpp>

Collaboration diagram for HeapVector::HeapTableEntry:

[legend]

Data Fields

INT32 | m_current_virtual_size
UINT | m_heap_id
UINT32 | m_max_virtual_size
const CHAR * | m_name
Page ** m_startpage
UINT | m_virtual_heap_id

Field Documentation

INT32 HeapVector::HeapTableEntry::m_current_virtual_size

UINT HeapVector::HeapTableEntry::m_heap_id

UINT32 HeapVector::HeapTableEntry::m_max_virtual_size

const CHAR* HeapVector::HeapTableEntry::m_name

Page** HeapVector::HeapTableEntry::m_startpage

UINT HeapVector::HeapTableEntry::m_virtual_heap_id

The documentation for this struct was generated from the following file:
  • Kernel/HeapVector.hpp
Generated on Wed Jan 25 01:18:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapVector::Page Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
HeapVector::Page

HeapVector::Page Struct Reference

#include <Apoxi/Kernel/HeapVector.hpp>

Collaboration diagram for HeapVector::Page:

[legend]

Data Fields

UINT8 * | m_base
UINT | m_blocksize
UINT8 * | m_end
const FctTable * | m_fct_table
UINT32 | m_high
BOOLEAN | m_ishuge
UINT16 | m_low
UINT | m_N
Page * m_page

Field Documentation

UINT8* HeapVector::Page::m_base

UINT HeapVector::Page::m_blocksize

UINT8* HeapVector::Page::m_end

const FctTable* HeapVector::Page::m_fct_table

UINT32 HeapVector::Page::m_high

BOOLEAN HeapVector::Page::m_ishuge

UINT16 HeapVector::Page::m_low

UINT HeapVector::Page::m_N

Page* HeapVector::Page::m_page

The documentation for this struct was generated from the following file:
  • Kernel/HeapVector.hpp
Generated on Wed Jan 25 01:18:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapVector::Stats Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
HeapVector::Stats

HeapVector::Stats Struct Reference

#include <Apoxi/Kernel/HeapVector.hpp>

Data Fields

UINT32 | m_allocations
UINT16 | m_current
UINT32 | m_frees
UINT32 | m_overflows
UINT | m_overhead
UINT16 | m_peak

Field Documentation

UINT32 HeapVector::Stats::m_allocations

UINT16 HeapVector::Stats::m_current

UINT32 HeapVector::Stats::m_frees

UINT32 HeapVector::Stats::m_overflows

UINT HeapVector::Stats::m_overhead

UINT16 HeapVector::Stats::m_peak

The documentation for this struct was generated from the following file:
  • Kernel/HeapVector.hpp
Generated on Wed Jan 25 01:18:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HeapVector::VarPage Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
HeapVector::VarPage

HeapVector::VarPage Struct Reference

#include <Apoxi/Kernel/HeapVector.hpp>

Static Public Member Functions

static void * | Allocate (Page *page, size_t nrofbytes)
static void | DbgOut (Page *page)
static void | DbgOutContext (Page *page)
static void | Free (Page *page, const void *address)
static UINT16 | GetBlockNo (Page *vpage, UINT32 nrofbytes, UINT cnt=0)
static Stats * | GetStats (Page *page)
static void HUGE * | HugeAllocate (Page *page, UINT32 nrofbytes)
static void | HugeFree (Page *page, const void HUGE *address)
static void HUGE * | HugeReAllocate (Page *page, UINT heapid, void HUGE *oldaddress, UINT32 newsize, BOOLEAN shallcopy)
static void | Initialize (Page *page)
static BOOLEAN | IsFreePage (Page *page)
static void | OverwriteCheck (Page *page)
static void * | ReAllocate (Page *page, UINT heapid, void *oldaddress, size_t newsize, BOOLEAN shallcopy)
static INT32 | Size (Page *page, const void *address)
static void | SubFree (Page *page, UINT32 address, UINT blockno)

Data Fields

UINT8 HUGE * | m_base_huge
UINT8 HUGE * | m_end_huge
BOOLEAN | m_free
UINT16 * | m_length
UINT8 * | m_memory
UINT | m_shiftval
UINT32 * | m_sizevector

Member Function Documentation

void * HeapVector::VarPage::Allocate | ( | Page * | page,
 |  | size_t | nrofbytes
 | ) | [static]

void HeapVector::VarPage::DbgOut ( Page * page ) [static]

void HeapVector::VarPage::DbgOutContext ( Page * page ) [static]

void HeapVector::VarPage::Free | ( | Page * | page,
 |  | const void * | address
 | ) | [static]

UINT16 HeapVector::VarPage::GetBlockNo | ( | Page * | vpage,
 |  | UINT32 | nrofbytes,
 |  | UINT | cnt = 0
 | ) | [static]

HeapVector::Stats * HeapVector::VarPage::GetStats ( Page * page ) [static]

void HUGE * HeapVector::VarPage::HugeAllocate | ( | Page * | page,
 |  | UINT32 | nrofbytes
 | ) | [static]

void HeapVector::VarPage::HugeFree | ( | Page * | page,
 |  | const void HUGE * | address
 | ) | [static]

void HUGE * HeapVector::VarPage::HugeReAllocate | ( | Page * | page,
 |  | UINT | heapid,
 |  | void HUGE * | oldaddress,
 |  | UINT32 | newsize,
 |  | BOOLEAN | shallcopy
 | ) | [static]

void HeapVector::VarPage::Initialize ( Page * page ) [static]

BOOLEAN HeapVector::VarPage::IsFreePage ( Page * page ) [static]

void HeapVector::VarPage::OverwriteCheck ( Page * page ) [static]

void * HeapVector::VarPage::ReAllocate | ( | Page * | page,
 |  | UINT | heapid,
 |  | void * | oldaddress,
 |  | size_t | newsize,
 |  | BOOLEAN | shallcopy
 | ) | [static]

INT32 HeapVector::VarPage::Size | ( | Page * | page,
 |  | const void * | address
 | ) | [static]

void HeapVector::VarPage::SubFree | ( | Page * | page,
 |  | UINT32 | address,
 |  | UINT | blockno
 | ) | [static]

Field Documentation

UINT8 HUGE* HeapVector::VarPage::m_base_huge

UINT8 HUGE* HeapVector::VarPage::m_end_huge

BOOLEAN HeapVector::VarPage::m_free

UINT16* HeapVector::VarPage::m_length

UINT8* HeapVector::VarPage::m_memory

UINT HeapVector::VarPage::m_shiftval

UINT32* HeapVector::VarPage::m_sizevector

The documentation for this struct was generated from the following files:
  • Kernel/HeapVector.hpp
  • Kernel/HeapVector.cpp
Generated on Wed Jan 25 01:18:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HindiTextRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HindiTextRenderer Class Reference
[GUI]

#include <Apoxi/Gui/HindiTextRenderer.hpp>

Inheritance diagram for HindiTextRenderer:

[legend]
Collaboration diagram for HindiTextRenderer:

[legend]

Public Member Functions

virtual | ~HindiTextRenderer ()

Static Public Member Functions

static HindiTextRenderer & | GetInstance ()

Protected Member Functions

virtual Size | GetGlyph (const WCHAR *cur_text_pos, const WCHAR *substitution_char, INT n_chars, GlyphPtr glyph, INT &parsed_glyphs, BOOLEAN &is_diacritic)
HindiTextRenderer ()

Detailed Description

TODO: implement Hindi text rendering. This renderer currently only renders simple languages.

Constructor & Destructor Documentation

HindiTextRenderer::~HindiTextRenderer ( ) [virtual]

HindiTextRenderer::HindiTextRenderer ( ) [protected]

Member Function Documentation

Size HindiTextRenderer::GetGlyph | ( | const WCHAR * | cur_text_pos,
 |  | const WCHAR * | substitution_char,
 |  | INT | n_chars,
 |  | GlyphPtr | glyph,
 |  | INT & | parsed_glyphs,
 |  | BOOLEAN & | is_diacritic
 | ) | [protected, virtual]

Get the correct glyph for a character. This may depend on its position within in the text, the characters preceding and/or following it. This method, in essence, implements the brunt work for correctly rendering text.

Parameters:
cur_text_pos | Pointer to the current character position within the text.
substitution_char | Pointer to a character that should be used instead of the character at cur_text_pos. If it is 0, then the character pointed to by cur_text_pos is used.
char_count | Number of remaining characters.
glyph | A GlyphPointer where the glyph data is stored (output parameter).
parsed_glyph | Stores the number of parsed glyphs (output parameter). This is used by DrawText to determine if characters can be skipped, e.g. if an 'a' is followed by an '`', and the implementing renderer unifies the character to 'ß', then parsed_glyphs is 2. The DrawText algorithm will then not attempt to get a glyph for the '`' character, but skip it and continue with the one following it.
is_diacritic | After calling the method, is_diacritic will reflect whether the character for the glyph is a diacritic or not. This must be respected by callers insofar as diacritics are drawn in the previous character's cell and thus those characters' width must not be considered when drawing text or calculating the text width.
Returns:
The x/y offset for the current glyph. This is used to change the position of the drawn glyph. Thus, using the example above, if the 'a' and '`' are not unified as one character, then the 'a' can be drawn on its own, and the '`' is drawn on its own at a position above the 'a', where the position is specified by the returned Size value. Usually, however, it is (0,0).

Implements AbstractTextRenderer.

static HindiTextRenderer& HindiTextRenderer::GetInstance ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Gui/HindiTextRenderer.hpp
  • Gui/HindiTextRenderer.cpp
Generated on Wed Jan 25 01:18:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HlrDataCorruptedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HlrDataCorruptedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for HlrDataCorruptedMsg:

[legend]
Collaboration diagram for HlrDataCorruptedMsg:

[legend]

Public Types

enum | { ID = 18530 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
HlrDataCorruptedMsg (ExecutionContext *context, const Tipd &tipd)
virtual | ~HlrDataCorruptedMsg ()

Detailed Description

HlrDataCorruptedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HlrDataCorruptedMsg::HlrDataCorruptedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd
 | ) |

HlrDataCorruptedMsg::~HlrDataCorruptedMsg ( ) [virtual]

Member Function Documentation

Message * HlrDataCorruptedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & HlrDataCorruptedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& HlrDataCorruptedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:18:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HlrSsDataCorruptMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HlrSsDataCorruptMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for HlrSsDataCorruptMsg:

[legend]
Collaboration diagram for HlrSsDataCorruptMsg:

[legend]

Public Types

enum | { ID = 18507 }

Public Member Functions

virtual Message * | Clone () const
const SsOperationCode & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
HlrSsDataCorruptMsg (ExecutionContext *context, const SsOperationCode &arg)
void | SetArg (const SsOperationCode &arg)
virtual | ~HlrSsDataCorruptMsg ()

Detailed Description

HlrSsDataCorruptMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HlrSsDataCorruptMsg::HlrSsDataCorruptMsg | ( | ExecutionContext * | context,
 |  | const SsOperationCode & | arg
 | ) |

HlrSsDataCorruptMsg::~HlrSsDataCorruptMsg ( ) [virtual]

Member Function Documentation

Message * HlrSsDataCorruptMsg::Clone ( ) const [virtual]

Implements Message.

const SsOperationCode& HlrSsDataCorruptMsg::GetArg ( ) const [inline]

const MsgMetaData & HlrSsDataCorruptMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void HlrSsDataCorruptMsg::SetArg ( const SsOperationCode & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:18:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HomezoneIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HomezoneIndArg Class Reference

#include <Apoxi/Apc/NetworkStackMsgArgs.hpp>

Inheritance diagram for HomezoneIndArg:

[legend]
Collaboration diagram for HomezoneIndArg:

[legend]

Public Types

enum | { ID = 2185 }

Public Member Functions

const HomezoneIndicator & | GetIndicator () const
const LineSelector & | GetLineSelector () const
const HomezoneText & | GetText () const
HomezoneIndArg ()
void | SetIndicator (const HomezoneIndicator &indicator)
void | SetLineSelector (const LineSelector &line_selector)
void | SetText (const HomezoneText &text)

Static Public Member Functions

static const HomezoneIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

HomezoneIndArg: reflects arguments of signal MNMI_ZONAL_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HomezoneIndArg::HomezoneIndArg ( )

Member Function Documentation

const HomezoneIndArg & HomezoneIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const HomezoneIndicator& HomezoneIndArg::GetIndicator ( ) const [inline]

const LineSelector& HomezoneIndArg::GetLineSelector ( ) const [inline]

const HomezoneText& HomezoneIndArg::GetText ( ) const [inline]

void HomezoneIndArg::SetIndicator ( const HomezoneIndicator & indicator ) [inline]

void HomezoneIndArg::SetLineSelector ( const LineSelector & line_selector ) [inline]

void HomezoneIndArg::SetText ( const HomezoneText & text ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/NetworkStackMsgArgs.hpp
  • Apc/NetworkStackMsgArgs.cpp
Generated on Wed Jan 25 01:18:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HomezoneMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HomezoneMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for HomezoneMsg:

[legend]
Collaboration diagram for HomezoneMsg:

[legend]

Public Types

enum | { ID = 18605 }

Public Member Functions

virtual Message * | Clone () const
const HomezoneIndicator & | GetIndicator () const
const LineSelector & | GetLineSelector () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetText () const
HomezoneMsg (ExecutionContext *context, const LineSelector &line_selector, const HomezoneIndicator &indicator, const WString &text)
void | SetIndicator (const HomezoneIndicator &indicator)
void | SetLineSelector (const LineSelector &line_selector)
void | SetText (const WString &text)
virtual | ~HomezoneMsg ()

Detailed Description

HomezoneMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HomezoneMsg::HomezoneMsg | ( | ExecutionContext * | context,
 |  | const LineSelector & | line_selector,
 |  | const HomezoneIndicator & | indicator,
 |  | const WString & | text
 | ) |

HomezoneMsg::~HomezoneMsg ( ) [virtual]

Member Function Documentation

Message * HomezoneMsg::Clone ( ) const [virtual]

Implements Message.

const HomezoneIndicator& HomezoneMsg::GetIndicator ( ) const [inline]

const LineSelector& HomezoneMsg::GetLineSelector ( ) const [inline]

const MsgMetaData & HomezoneMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const WString& HomezoneMsg::GetText ( ) const [inline]

void HomezoneMsg::SetIndicator ( const HomezoneIndicator & indicator ) [inline]

void HomezoneMsg::SetLineSelector ( const LineSelector & line_selector ) [inline]

void HomezoneMsg::SetText ( const WString & text ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:18:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HomezoneText Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HomezoneText Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Data Fields

UINT8 | label [15]
UINT8 | length

Field Documentation

UINT8 HomezoneText::label[15]

UINT8 HomezoneText::length

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 01:18:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HostDebugTimeStamp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HostDebugTimeStamp Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/HostDebugTimeStamp.hpp>

Public Member Functions

String GetTimeStamp ()
HostDebugTimeStamp ()
~HostDebugTimeStamp ()

Detailed Description

HostDebugTimeStamp class for Host Build, to display

Constructor & Destructor Documentation

HostDebugTimeStamp::HostDebugTimeStamp ( )

Use HostDebugTimeStamp() to find out current system time.

HostDebugTimeStamp::~HostDebugTimeStamp ( )

Member Function Documentation

String HostDebugTimeStamp::GetTimeStamp ( )

Use GetTimeStamp to read current system time Returns: time as String

The documentation for this class was generated from the following files:
  • Auxiliary/HostDebugTimeStamp.hpp
  • Auxiliary/HostDebugTimeStamp.cpp
Generated on Wed Jan 25 01:18:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HostFatFsDeviceDescriptor Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HostFatFsDeviceDescriptor Struct Reference

#include <Apoxi/AddOns/AfsFat/FatSim.hpp>

Collaboration diagram for HostFatFsDeviceDescriptor:

[legend]

Public Member Functions

HostFatFsDeviceDescriptor (const String &m_device_id, fs_device_type m_device)
HostFatFsDeviceDescriptor ()

Data Fields

fs_device_type m_device
String m_device_id

Constructor & Destructor Documentation

HostFatFsDeviceDescriptor::HostFatFsDeviceDescriptor ( ) [inline]

HostFatFsDeviceDescriptor::HostFatFsDeviceDescriptor | ( | const String & | m_device_id,
 |  | fs_device_type | m_device
 | ) | [inline]

Field Documentation

fs_device_type HostFatFsDeviceDescriptor::m_device

String HostFatFsDeviceDescriptor::m_device_id

The documentation for this struct was generated from the following file:
  • AddOns/AfsFat/FatSim.hpp
Generated on Wed Jan 25 01:18:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HostFileStatType Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HostFileStatType Struct Reference

#include <Apoxi/Afs/HostFsSim/HostCoreFsSim.hpp>

Collaboration diagram for HostFileStatType:

[legend]

Data Fields

UINT16 | fattribute
DateStr st_accesstime
DateStr st_creationtime
INT16 | st_deviceId
INT16 | st_inode
UINT32 | st_mode
DateStr st_modificationtime
INT16 | st_nlink
INT16 | st_rdev
UINT32 | st_size

Field Documentation

UINT16 HostFileStatType::fattribute

DateStr HostFileStatType::st_accesstime

DateStr HostFileStatType::st_creationtime

INT16 HostFileStatType::st_deviceId

INT16 HostFileStatType::st_inode

UINT32 HostFileStatType::st_mode

DateStr HostFileStatType::st_modificationtime

INT16 HostFileStatType::st_nlink

INT16 HostFileStatType::st_rdev

UINT32 HostFileStatType::st_size

The documentation for this struct was generated from the following file:
  • Afs/HostFsSim/HostCoreFsSim.hpp
Generated on Wed Jan 25 01:18:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HostIniFile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HostIniFile Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/HostIniFile.hpp>

Collaboration diagram for HostIniFile:

[legend]

Public Member Functions

HostIniFile (String inifilename, BOOLEAN on_desktop=FALSE)
BOOLEAN | ReadBool (CHAR *section, CHAR *keyname)
INT | ReadInteger (CHAR *section, CHAR *keyname)
BOOLEAN | ReadString (CHAR *section, CHAR *keyname, CHAR *keyvalueMax80)
BOOLEAN | WriteBool (CHAR *section, CHAR *keyname, BOOLEAN keyvalue)
BOOLEAN | WriteInteger (CHAR *section, CHAR *keyname, INT keyvalue)
BOOLEAN | WriteString (CHAR *section, CHAR *keyname, CHAR *keyvalueMax80)
~HostIniFile ()

Detailed Description

HostIniFile class for Host Build configuration storage and reading from ini-File

usage: HostIniFile inifile = HostIniFile("apoxi.ini"); // the inifile goes to <drive>:<Documents and Settings><user name><Application Data> the_port = inifile.ReadInteger("IrDA-Settings", "COM-Port"); String a_string = "1000...2500\0"; inifile.WriteString("Debug-Settings", "DbgOutRange", a_string.GetCString());

Constructor & Destructor Documentation

HostIniFile::HostIniFile | ( | String | inifilename,
 |  | BOOLEAN | on_desktop = FALSE
 | ) |

Use HostIniFile() to create an ini-File or read from the IniFile

Parameters:
inifilename | name of ini-File, if no full qualified path is specified, the file is placed into "Application Data" directory (<drive>:<Documents and Settings><user name><Application Data>)
If | for easier editing the Desktop location is desired, set on_desktop to TRUE, default is FALSE

HostIniFile::~HostIniFile ( )

Member Function Documentation

BOOLEAN HostIniFile::ReadBool | ( | CHAR * | section,
 |  | CHAR * | keyname
 | ) |

Use ReadBool to read from the IniFile

Parameters:
section | in inifile, looks in inifile like [section]
keyname | in inifile, looks in inifile like keyname=
Returns:
the value read from the IniFile

INT HostIniFile::ReadInteger | ( | CHAR * | section,
 |  | CHAR * | keyname
 | ) |

Use ReadInteger to read from the IniFile

Parameters:
section | in inifile, looks in inifile like [section]
keyname | in inifile, looks in inifile like keyname=
Returns:
the value read from the IniFile

BOOLEAN HostIniFile::ReadString | ( | CHAR * | section,
 |  | CHAR * | keyname,
 |  | CHAR * | keyvalueMax80
 | ) |

Use ReadString to read from the IniFile

Parameters:
section | in inifile, looks in inifile like [section]
keyname | in inifile, looks in inifile like keyname=
keyvalueMax80 | Value of Key (max 80 char) in inifile, looks in inifile like keyname=keyvalueMax80
Returns:
FALSE (currently fixed value)

BOOLEAN HostIniFile::WriteBool | ( | CHAR * | section,
 |  | CHAR * | keyname,
 |  | BOOLEAN | keyvalue
 | ) |

Use WriteBool to write to the IniFile

Parameters:
section | in inifile, looks in inifile like [section]
keyname | in inifile, looks in inifile like keyname=
keyvalue | Value of Key in inifile, looks in inifile like keyname=keyvalue
Returns:
FALSE (currently fixed value)

BOOLEAN HostIniFile::WriteInteger | ( | CHAR * | section,
 |  | CHAR * | keyname,
 |  | INT | keyvalue
 | ) |

Use WriteInteger to write to the IniFile

Parameters:
section | in inifile, looks in inifile like [section]
keyname | in inifile, looks in inifile like keyname=
keyvalue | Value of Key in inifile, looks in inifile like keyname=keyvalue
Returns:
FALSE (currently fixed value)

BOOLEAN HostIniFile::WriteString | ( | CHAR * | section,
 |  | CHAR * | keyname,
 |  | CHAR * | keyvalueMax80
 | ) |

Use WriteString to write to the IniFile

Parameters:
section | in inifile, looks in inifile like [section]
keyname | in inifile, looks in inifile like keyname=
keyvalueMax80 | Value of Key (max 80 char) in inifile, looks in inifile like keyname=keyvalueMax80
Returns:
FALSE (currently fixed value)

The documentation for this class was generated from the following files:
  • Auxiliary/HostIniFile.hpp
  • Auxiliary/HostIniFile.cpp
Generated on Wed Jan 25 01:18:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HostIterStatType Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HostIterStatType Struct Reference

#include <Apoxi/Afs/HostFsSim/HostCoreFsSim.hpp>

Data Fields

CHAR | device_id [3]
UINT16 | fattribute
UINT16 | fdate
CHAR | fext [4]
INT32 | filehandle
CHAR | fname [10]
UINT32 | fsize
UINT16 | ftime
CHAR | longFileName [MAX_PATH]
CHAR | path [MAX_PATH]
CHAR | patternName [MAX_PATH]

Field Documentation

CHAR HostIterStatType::device_id[3]

UINT16 HostIterStatType::fattribute

UINT16 HostIterStatType::fdate

CHAR HostIterStatType::fext[4]

INT32 HostIterStatType::filehandle

CHAR HostIterStatType::fname[10]

UINT32 HostIterStatType::fsize

UINT16 HostIterStatType::ftime

CHAR HostIterStatType::longFileName[MAX_PATH]

CHAR HostIterStatType::path[MAX_PATH]

CHAR HostIterStatType::patternName[MAX_PATH]

The documentation for this struct was generated from the following file:
  • Afs/HostFsSim/HostCoreFsSim.hpp
Generated on Wed Jan 25 01:18:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpApplication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpApplication Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpApplication.hpp>

Collaboration diagram for HttpApplication:

[legend]

Public Member Functions

virtual String | GetDescription ()
virtual String | GetId ()
virtual String | GetName ()
virtual HttpResponseCode | OnHttpRequest (HttpRequest &request, HttpResponse &response)=0
virtual void | ReleaseInstance ()
virtual | ~HttpApplication ()

Static Public Member Functions

static HttpApplication * | GetInstance ()

Protected Member Functions

HttpApplication (String appId, String appName, String appDescription)
virtual void | Init ()
virtual void | Terminate ()

Protected Attributes

String m_appDescription
String m_appId
String m_appName

Static Protected Attributes

static HttpApplication * | s_instance

Friends

class | HttpClient
class | HttpServer

Detailed Description

Abstract class of an HTTP web application designed as singleton pattern.

Constructor & Destructor Documentation

HttpApplication::~HttpApplication ( ) [virtual]

HttpApplication::HttpApplication | ( | String | appId,
 |  | String | appName,
 |  | String | appDescription
 | ) | [protected]

Protected constructor due to singleton pattern.

Member Function Documentation

String HttpApplication::GetDescription ( ) [virtual]

Returns the description of the application.

String HttpApplication::GetId ( ) [virtual]

Returns the ID of the application.

static HttpApplication* HttpApplication::GetInstance ( ) [static]

Returns the (only) instance of the class.

String HttpApplication::GetName ( ) [virtual]

Returns the name of the application.

void HttpApplication::Init ( ) [protected, virtual]

Initialize internally used resources (optional). This method is called by the constructor.

virtual HttpResponseCode HttpApplication::OnHttpRequest | ( | HttpRequest & | request,
 |  | HttpResponse & | response
 | ) | [pure virtual]

Executes the necessary operations of this HTTP application.

void HttpApplication::ReleaseInstance ( ) [virtual]

Deletes the (only) instance of the class.

void HttpApplication::Terminate ( ) [protected, virtual]

Remove or free internally used resources (optional). This method is called by the destructor.

Friends And Related Function Documentation

friend class HttpClient [friend]

friend class HttpServer [friend]

Field Documentation

String HttpApplication::m_appDescription [protected]

String HttpApplication::m_appId [protected]

String HttpApplication::m_appName [protected]

HttpApplication * HttpApplication::s_instance [static, protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpApplication.hpp
  • AddOns/Server/HttpServer/HttpApplication.cpp
Generated on Wed Jan 25 01:19:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpApplicationSupplier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpApplicationSupplier Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpApplicationSupplier.hpp>

Collaboration diagram for HttpApplicationSupplier:

[legend]

Public Member Functions

virtual void | DeregisterApplication (String appId)
virtual HttpApplication * | GetApplication (String appId)
virtual UINT | GetApplicationCount ()
virtual BOOLEAN | RegisterApplication (HttpApplication *httpApplication)
virtual void | ReleaseInstance ()
virtual | ~HttpApplicationSupplier ()

Static Public Member Functions

static HttpApplicationSupplier * | GetInstance ()

Protected Attributes

SimpleMap< String, HttpApplication * > m_appList

Friends

class | HttpClient
class | HttpServer

Detailed Description

Class administrating all HTTP web applications designed as singleton pattern.

Constructor & Destructor Documentation

HttpApplicationSupplier::~HttpApplicationSupplier ( ) [virtual]

Member Function Documentation

void HttpApplicationSupplier::DeregisterApplication ( String appId ) [virtual]

Deregisters an HTTP application in this supplier.

HttpApplication * HttpApplicationSupplier::GetApplication ( String appId ) [virtual]

Returns the appropriate HTTP application.

UINT HttpApplicationSupplier::GetApplicationCount ( ) [virtual]

Returns the number of registered HTTP applications.

HttpApplicationSupplier * HttpApplicationSupplier::GetInstance ( ) [static]

Returns the (only) instance of the class.

BOOLEAN HttpApplicationSupplier::RegisterApplication ( HttpApplication * httpApplication ) [virtual]

Registers an HTTP application in this supplier.

void HttpApplicationSupplier::ReleaseInstance ( ) [virtual]

Deletes the (only) instance of the class.

Friends And Related Function Documentation

friend class HttpClient [friend]

friend class HttpServer [friend]

Field Documentation

SimpleMap<String, HttpApplication*> HttpApplicationSupplier::m_appList [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpApplicationSupplier.hpp
  • AddOns/Server/HttpServer/HttpApplicationSupplier.cpp
Generated on Wed Jan 25 01:19:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpAuthProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpAuthProvider Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpAuthProvider.hpp>

Inheritance diagram for HttpAuthProvider:

[legend]
Collaboration diagram for HttpAuthProvider:

[legend]

Public Member Functions

virtual BOOLEAN | AuthorizeUser (const String &username)
virtual BOOLEAN | AuthorizeUserPassword (const String &username, const String &password)
HttpAuthProvider ()
virtual BOOLEAN | IsAccessGranted (const String &username, const Path &path)
virtual | ~HttpAuthProvider ()

Constructor & Destructor Documentation

HttpAuthProvider::HttpAuthProvider ( )

Constructor. Initializes all member variables with the default values.

HttpAuthProvider::~HttpAuthProvider ( ) [virtual]

Destructor. Deallocates used resources.

Member Function Documentation

BOOLEAN HttpAuthProvider::AuthorizeUser ( const String & username ) [virtual]

Method for authorizing a certain user. Must be implemented in derived classes. Default implementation returns FALSE.

Parameters:
username Name of a certain user to authorize.
Returns:
Whether the user s authorized or not.

Implements AuthProvider.

BOOLEAN HttpAuthProvider::AuthorizeUserPassword | ( | const String & | username,
 |  | const String & | password
 | ) | [virtual]

Method for authorizing a certain user with a certain password. Must be implemented in derived classes. Default implementation returns FALSE.

Parameters:
username | Name of a certain user to authorize.
password | Password for a certain user account.
Returns:
Whether the user s authorized or not.

Implements AuthProvider.

BOOLEAN HttpAuthProvider::IsAccessGranted | ( | const String & | username,
 |  | const Path & | path
 | ) | [virtual]

Returns whether a certain user is allowed to access the specified path. Default implementation returns TRUE.

Parameters:
username | Name of a certain user to authorize.
pathname | Path name to check.
Returns:
Whether the user is granted access to the given path or not.

Implements AuthProvider.

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpAuthProvider.hpp
  • AddOns/Server/HttpServer/HttpAuthProvider.cpp
Generated on Wed Jan 25 01:19:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpClient Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpClient.hpp>

Inheritance diagram for HttpClient:

[legend]
Collaboration diagram for HttpClient:

[legend]

Public Member Functions

virtual HttpSocketPtr | GetHttpSocket ()
virtual UINT | GetId ()
HttpClient (Server *server)
virtual HttpResponseCode | OnFileRequest (const Pathname &pathname, HttpResponse &httpResponse)
virtual BOOLEAN | OnHttpGetRequest (HttpRequest &httpRequest)
virtual BOOLEAN | OnHttpPostRequest (HttpRequest &httpRequest)
virtual BOOLEAN | OnHttpRequest (HttpRequest &httpRequest)
virtual | ~HttpClient ()

Protected Member Functions

Pathname | GetAbsolutePathname (const Pathname &pathname)
HttpResponseCode | GetErrorPage (HttpResponse &httpResponse, HttpResponseCode errorCode, WString errorDescription=L"")
HttpResponseCode | GetFavicon (HttpResponse &httpResponse)
HttpResponseCode | GetIndexPage (const HttpRequest &httpRequest, HttpResponse &httpResponse)
HttpResponseCode | GetStyleSheet (HttpResponse &httpResponse)
virtual void | SetHttpSocket (HttpSocketPtr httpSocket)

Friends

class | HttpServer

Constructor & Destructor Documentation

HttpClient::HttpClient ( Server * server )

Constructor.

Parameters:
server Pointer to the corresponding server object.

HttpClient::~HttpClient ( ) [virtual]

Member Function Documentation

Pathname HttpClient::GetAbsolutePathname ( const Pathname & pathname ) [protected]

Converts the given user home absolute path name to an absolute path name in the RFS. The result depends on the specified user home directory.

Parameters:
pathname Path name absolute to user home
Returns:
Path name absolute to RFS root

HttpResponseCode HttpClient::GetErrorPage | ( | HttpResponse & | httpResponse,
 |  | HttpResponseCode | errorCode,
 |  | WString | errorDescription = L""
 | ) | [protected]

Writes an error page of the HTTP server into the HttpResponse object with the given parameters.

Parameters:
httpResponse | The HttpResponse that will be sent back to the client.
errorCode | The HTTP error code (4xx).
errorDescription | The description of the error (e.g. "File not found.").
Returns:
The appropriate HttpResponseCode of the action taken.

HttpResponseCode HttpClient::GetFavicon ( HttpResponse & httpResponse ) [protected]

Writes the favorite icon file named "favicon.ico" of the HTTP server root directory into the HttpResponse object, if the file exists. Otherwise the method generates the default file content for the favorite icon.

Parameters:
httpResponse The HttpResponse that will be sent back to the client.
Returns:
The appropriate HttpResponseCode of the action taken.

HttpSocketPtr HttpClient::GetHttpSocket ( ) [virtual]

Returns a smart pointer to the communication socket.

Returns:
Smart pointer to the communication socket.

UINT HttpClient::GetId ( ) [virtual]

Returns the ID of the client.

Returns:
ID of the client.

Reimplemented from ServerClient.

HttpResponseCode HttpClient::GetIndexPage | ( | const HttpRequest & | httpRequest,
 |  | HttpResponse & | httpResponse
 | ) | [protected]

Writes the index page file named "index.html" of the HTTP server root directory into the HttpResponse object, if the file exists. Otherwise the method generates dynamic output listing all registered web applications.

Parameters:
httpRequest | The HttpRequest that was sent by the client.
httpResponse | The HttpResponse that will be sent back to the client.
Returns:
The appropriate HttpResponseCode of the action taken.

HttpResponseCode HttpClient::GetStyleSheet ( HttpResponse & httpResponse ) [protected]

Writes the style sheet file named "stylesheet.css" of the HTTP server root directory into the HttpResponse object, if the file exists. Otherwise the method generates the default file content for the style sheet.

Parameters:
httpResponse The HttpResponse that will be sent back to the client.
Returns:
The appropriate HttpResponseCode of the action taken.

HttpResponseCode HttpClient::OnFileRequest | ( | const Pathname & | pathname,
 |  | HttpResponse & | httpResponse
 | ) | [virtual]

Handles a file request and adds the content for the appropriate response in the given object.

Parameters:
pathname | The pathname of the requested file.
httpResponse | The HttpResponse object which will be used for adding header fields and file data.
Returns:
The appropriate HttpResponseCode of the action taken.

BOOLEAN HttpClient::OnHttpGetRequest ( HttpRequest & httpRequest ) [virtual]

Handles an HTTP request which uses the command GET and returns the response to the client.

Parameters:
httpRequest An HTTP request. (Attention: this object MUST include c_http_request_method_get as request method!)
Returns:
Whether the operation was successful or not.

BOOLEAN HttpClient::OnHttpPostRequest ( HttpRequest & httpRequest ) [virtual]

Handles an HTTP request which uses the command POST and returns the response to the client.

Parameters:
httpRequest An HTTP request. (Attention: this object MUST include c_http_request_method_post as request method!)
Returns:
Whether the operation was successful or not.

BOOLEAN HttpClient::OnHttpRequest ( HttpRequest & httpRequest ) [virtual]

Handles an HTTP request and returns the response to the client via the socket.

Parameters:
httpRequest An HTTP request.
Returns:
Whether the operation was successful or not.

void HttpClient::SetHttpSocket ( HttpSocketPtr httpSocket ) [protected, virtual]

Sets an other HTTP socket.

Parameters:
httpSocket Smart pointer to an other HTTP socket.

Friends And Related Function Documentation

friend class HttpServer [friend]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpClient.hpp
  • AddOns/Server/HttpServer/HttpClient.cpp
Generated on Wed Jan 25 01:19:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpConnectMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpConnectMessage Class Reference

#include <Apoxi/AddOns/Server/HttpServer/MsgTypes.hpp>

Inheritance diagram for HttpConnectMessage:

[legend]
Collaboration diagram for HttpConnectMessage:

[legend]

Public Types

enum | { ID = 4513 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const InetSocketAddr & | GetPeerAddr () const
const HttpSocketPtr & | GetPeerSocket () const
HttpConnectMessage (const InetSocketAddr &peerAddr, const HttpSocketPtr &peerSocket)
virtual | ~HttpConnectMessage ()

Detailed Description

This message is sent when a client connects to the HTTP server.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HttpConnectMessage::HttpConnectMessage | ( | const InetSocketAddr & | peerAddr,
 |  | const HttpSocketPtr & | peerSocket
 | ) |

HttpConnectMessage::~HttpConnectMessage ( ) [virtual]

Member Function Documentation

Message * HttpConnectMessage::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & HttpConnectMessage::GetMetaData ( ) const [virtual]

Implements Message.

const InetSocketAddr& HttpConnectMessage::GetPeerAddr ( ) const [inline]

const HttpSocketPtr& HttpConnectMessage::GetPeerSocket ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/MsgTypes.hpp
  • AddOns/Server/HttpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:19:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpDisconnectMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpDisconnectMessage Class Reference

#include <Apoxi/AddOns/Server/HttpServer/MsgTypes.hpp>

Inheritance diagram for HttpDisconnectMessage:

[legend]
Collaboration diagram for HttpDisconnectMessage:

[legend]

Public Types

enum | { ID = 4514 }

Public Member Functions

virtual Message * | Clone () const
UINT | GetClientId () const
virtual const MsgMetaData & | GetMetaData () const
HttpDisconnectMessage (UINT clientId)
virtual | ~HttpDisconnectMessage ()

Detailed Description

This message is sent when a client has disconnected.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HttpDisconnectMessage::HttpDisconnectMessage ( UINT clientId )

HttpDisconnectMessage::~HttpDisconnectMessage ( ) [virtual]

Member Function Documentation

Message * HttpDisconnectMessage::Clone ( ) const [virtual]

Implements Message.

UINT HttpDisconnectMessage::GetClientId ( ) const [inline]

const MsgMetaData & HttpDisconnectMessage::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/MsgTypes.hpp
  • AddOns/Server/HttpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:19:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpErrorMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpErrorMessage Class Reference

#include <Apoxi/AddOns/Server/HttpServer/MsgTypes.hpp>

Inheritance diagram for HttpErrorMessage:

[legend]
Collaboration diagram for HttpErrorMessage:

[legend]

Public Types

enum | { ID = 4511 }

Public Member Functions

virtual Message * | Clone () const
const HttpServiceCommand & | GetCmd () const
const HttpServiceCommandError & | GetCode () const
virtual const MsgMetaData & | GetMetaData () const
HttpErrorMessage (const HttpServiceCommand &cmd, const HttpServiceCommandError &code)
virtual | ~HttpErrorMessage ()

Detailed Description

This message is sent when an error occurs performing a service command (or even on success).

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HttpErrorMessage::HttpErrorMessage | ( | const HttpServiceCommand & | cmd,
 |  | const HttpServiceCommandError & | code
 | ) |

HttpErrorMessage::~HttpErrorMessage ( ) [virtual]

Member Function Documentation

Message * HttpErrorMessage::Clone ( ) const [virtual]

Implements Message.

const HttpServiceCommand& HttpErrorMessage::GetCmd ( ) const [inline]

const HttpServiceCommandError& HttpErrorMessage::GetCode ( ) const [inline]

const MsgMetaData & HttpErrorMessage::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/MsgTypes.hpp
  • AddOns/Server/HttpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:19:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpHandler Class Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/HttpWap/HttpHandler.hpp>

Inheritance diagram for HttpHandler:

[legend]
Collaboration diagram for HttpHandler:

[legend]

Public Types

enum | HttpConnStatus { HttpConnError, HttpConnClosed, HttpConnOpen, HttpConnSuspended }

Public Member Functions

virtual BOOLEAN | AddRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)
virtual BOOLEAN | AddUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)
virtual BOOLEAN | CancelHttp (INT requ_id)
virtual BOOLEAN | ClearRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)
virtual BOOLEAN | ClearUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)
virtual BOOLEAN | CloseHttp ()
virtual BOOLEAN | GetCipherSuiteName (INT conn_id, const UINT8 **pCipherSuiteName)
virtual INT | GetConnIdHttp ()
virtual HttpConnStatus | GetConnStatusHttp ()
HttpHandler ()
virtual BOOLEAN | OpenHttp (INT id)
virtual BOOLEAN | ReadRootCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen)
virtual BOOLEAN | ReadUserCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen, UINT8 **certKey, UINT32 *certKeyLen)
virtual BOOLEAN | RequestGetHttp (INT &requ_id, const CHAR *URL, const CHAR *header)
virtual BOOLEAN | RequestHeadHttp (INT &requ_id, const CHAR *URL, const CHAR *header)
virtual BOOLEAN | RequestPostDataHttp (INT &request_id, BinData *body, INT more)
virtual BOOLEAN | RequestPostHttp (INT &requ_id, const CHAR *URL, const CHAR *header, BinData *body, INT more)
virtual BOOLEAN | ResumeHttp ()
virtual BOOLEAN | SuspendHttp ()
virtual | ~HttpHandler ()

Protected Member Functions

virtual BOOLEAN | DecodeMessage (const Message &msg, INT &conn_id, INT &requ_id, INT &status, WString &header, BinData **body, INT &more, INT &length, WString &url)
virtual BOOLEAN | OnMessage (const Message &msg)=0
virtual BOOLEAN | OnResponse (const Message &msg)=0

Detailed Description

This interface defines the functionality of an HTTP handler:
  • opening an HTTP connection,
  • initiating HTTP GET, HEAD and POST requests,
  • closing an HTTP connection,
  • handle HTTP responses coming back in the form of APOXI messages or function calls. Since the function calls lead to asynchronous calls on communication stacks, the return values of the functions indicate the success of the functions and generally not the success of the events in the communication stack or beyond.

Member Enumeration Documentation

enum HttpHandler::HttpConnStatus

Enumerator:
HttpConnError
HttpConnClosed
HttpConnOpen
HttpConnSuspended

Constructor & Destructor Documentation

HttpHandler::HttpHandler ( )

HttpHandler::~HttpHandler ( ) [virtual]

Member Function Documentation

BOOLEAN HttpHandler::AddRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [virtual]

Certificate Management - Used to Add a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

BOOLEAN HttpHandler::AddUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [virtual]

Certificate Management - Used to Add a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

BOOLEAN HttpHandler::CancelHttp ( INT requ_id ) [virtual]

Used by the application to cancel an outstanding request.

There must be an outstanding request in order for this function to Succeed.

Parameters:
requ_id Id of request to cancel.
Returns:
Success of method.

BOOLEAN HttpHandler::ClearRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [virtual]

Certificate Management - Used to Delete a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

BOOLEAN HttpHandler::ClearUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [virtual]

Certificate Management - Used to Delete a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

BOOLEAN HttpHandler::CloseHttp ( ) [virtual]

Used by the application to close the HTTP connection.

HTTP connection must be open in order for this function to succeed. Function will cancel all outstanding requests.

Returns:
Success of method.

BOOLEAN HttpHandler::DecodeMessage | ( | const Message & | msg,
 |  | INT & | conn_id,
 |  | INT & | requ_id,
 |  | INT & | status,
 |  | WString & | header,
 |  | BinData ** | body,
 |  | INT & | more,
 |  | INT & | length,
 |  | WString & | url
 | ) | [protected, virtual]

This Method is called by the Application each time it gets a message in the form of msg class. This method decodes the message and fills the appropriate fields

Parameters:
msg | The message handed in
conn_id | Connection id this will be filled by Plugin class
requ_id | request id this will be filled by Plugin class
status | status to be filled by the Plugin class
header | header to be filled by the Plugin class by NULL or with value depending upono the Messages Type
body | body this will be filled by Plugin class
more | indicates if more data is following this packet or not
length | length of he data recived filling depends upon the message type
url | to be filled in by the Plugin calls depending upon the message type
Returns:
Sucess of the method

BOOLEAN HttpHandler::GetCipherSuiteName | ( | INT | conn_id,
 |  | const UINT8 ** | pCipherSuiteName
 | ) | [virtual]

INT HttpHandler::GetConnIdHttp ( ) [virtual]

Used to get the connection id

Returns:
connection id

HttpHandler::HttpConnStatus HttpHandler::GetConnStatusHttp ( ) [virtual]

Used to get the status

Returns:
status of the connection

virtual BOOLEAN HttpHandler::OnMessage ( const Message & msg ) [protected, pure virtual]

This function MUST be implemented by the Application to get the Response messages from the Stack

Parameters:
msg The message handed in.
Returns:
Success of method.

Implements Dispatcher.

virtual BOOLEAN HttpHandler::OnResponse ( const Message & msg ) [protected, pure virtual]

Used to hand in the content of an HTTP response message. this function should be implemented by the Application

Parameters:
msg The message handed in.
Returns:
Success of method.

BOOLEAN HttpHandler::OpenHttp ( INT id ) [virtual]

Used to open the HTTP connection.

Parameters:
id Id of WapProfile to be used. (WapProfile determines if connection is secure/non-secure and connection-oriented/ connectionless)
Returns:
Success of method.

BOOLEAN HttpHandler::ReadRootCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen
 | ) | [virtual]

Certificate Management - Used to Read a Root Certificate

Parameters:
UINT8** | Certificate data
UINT32* | Certificate length
Returns:
success

BOOLEAN HttpHandler::ReadUserCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen,
 |  | UINT8 ** | certKey,
 |  | UINT32 * | certKeyLen
 | ) | [virtual]

Certificate Management - Used to Read a User Certificate

Parameters:
UINT8** | Certificate Data
UINT32* | Certificate length
UINT8** | Certificate key information
UINT32* | Certificate key length
Returns:
success

BOOLEAN HttpHandler::RequestGetHttp | ( | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header
 | ) | [virtual]

Used by the application to initiate an HTTP GET request.

httpOpen must have been called first.

Parameters:
requ_id | Identifier of the HTTP request.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
Returns:
Success of method.

BOOLEAN HttpHandler::RequestHeadHttp | ( | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header
 | ) | [virtual]

Used by the application to initiate an HTTP HEAD request.

httpOpen must have been called first.

Parameters:
requ_id | Identifier of the HTTP request.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
Returns:
Success of method.

BOOLEAN HttpHandler::RequestPostDataHttp | ( | INT & | request_id,
 |  | BinData * | body,
 |  | INT | more
 | ) | [virtual]

Used by application to supply more body data for an HTTP POST request.

httpRequestPost must have been called first.

Parameters:
request_id | Identifier of the HTTP request.
body | Container with any type of data to be sent in an HTTP POST request.
more | Application can set more to 1 if it wants to supply more body content using the HttpRequestData method. Request will be sent only as soon as entire body is complete (indicated by more being 0).
Returns:
Success of method.

BOOLEAN HttpHandler::RequestPostHttp | ( | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header,
 |  | BinData * | body,
 |  | INT | more
 | ) | [virtual]

Used by the application to initiate an HTTP POST request.

httpOpen must have been called first.

Parameters:
requ_id | Identifier of the HTTP request.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
body | Container with any type of data to be sent in an HTTP POST request.
more | Application can set more to 1 if it wants to supply more body content using the httpRequestPost Data method. Request will be sent only as soon as entire body is complete (indicated by more being 0).
Returns:
Success of method.

BOOLEAN HttpHandler::ResumeHttp ( ) [virtual]

Used by the application to resume the HTTP connection.

HTTP connection must be open in order for this function to succeed. Functionality is implementation specific.

Returns:
Success of method.

BOOLEAN HttpHandler::SuspendHttp ( ) [virtual]

Used by the application to suspend the HTTP connection.

HTTP connection must be open in order for this function to succeed. Functionality is implementation specific.

Returns:
Success of method.

The documentation for this class was generated from the following files:
  • AddOns/HttpWapInterface/HttpWap/HttpHandler.hpp
  • AddOns/HttpWapInterface/HttpWap/HttpHandler.cpp
Generated on Wed Jan 25 01:19:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpRequest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpRequest Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpRequest.hpp>

Collaboration diagram for HttpRequest:

[legend]

Public Types

enum | HttpRequestMethodType { c_http_request_method_get, c_http_request_method_post }
typedef Vector< ParamPair > | ParamPairList

Public Member Functions

RamDataSinkPtr GetBody ()
HttpRequestHeaders GetHeaders ()
String GetHttpVersion ()
HttpRequestMethodType GetRequestMethodType ()
ParamPairList GetRequestParams ()
String GetRequestTarget ()
HttpRequest (HttpRequestMethodType type=c_http_request_method_get)
virtual | ~HttpRequest ()

Protected Member Functions

void | SetBody (RamDataSinkPtr newBody)

Protected Attributes

RamDataSinkPtr m_body
HttpRequestHeaders m_headers
String m_httpVersion
HttpRequestMethodType m_requestMethod
Vector< ParamPair > m_requestParams
String m_requestTarget

Friends

class | HttpServer
class | HttpSocket

Data Structures

struct | ParamPair

Detailed Description

Class that contains all relevant data of an HTTP request as defined in RFC 2616.

Member Typedef Documentation

typedef Vector<ParamPair> HttpRequest::ParamPairList

Member Enumeration Documentation

enum HttpRequest::HttpRequestMethodType

Enumerator:
c_http_request_method_get
c_http_request_method_post

Constructor & Destructor Documentation

HttpRequest::HttpRequest ( HttpRequestMethodType type = c_http_request_method_get )

Constructor.

Parameters:
type The type of the request method (default is c_http_request_method_get).

HttpRequest::~HttpRequest ( ) [virtual]

Destructor.

Member Function Documentation

RamDataSinkPtr HttpRequest::GetBody ( )

Returns the body of the request.

Returns:
The body of the request.

HttpRequestHeaders HttpRequest::GetHeaders ( )

Returns the headers of the HTTP request.

Returns:
A list of HTTP headers.

String HttpRequest::GetHttpVersion ( )

Returns the HTTP version.

Returns:
The HTTP version.

HttpRequest::HttpRequestMethodType HttpRequest::GetRequestMethodType ( )

Returns the type of the request method.

Returns:
The type of the request method.

HttpRequest::ParamPairList HttpRequest::GetRequestParams ( )

Returns a list of all parameters given in this request.

Returns:
A list of all given parameters.

String HttpRequest::GetRequestTarget ( )

Returns the target of the request.

Returns:
The target of the request. May be the path to a file or a web application.

void HttpRequest::SetBody ( RamDataSinkPtr newBody ) [protected]

Sets the body of the request.

Parameters:
newBody New body to set.

Friends And Related Function Documentation

friend class HttpServer [friend]

friend class HttpSocket [friend]

Field Documentation

RamDataSinkPtr HttpRequest::m_body [protected]

HttpRequestHeaders HttpRequest::m_headers [protected]

String HttpRequest::m_httpVersion [protected]

HttpRequestMethodType HttpRequest::m_requestMethod [protected]

Vector<ParamPair> HttpRequest::m_requestParams [protected]

String HttpRequest::m_requestTarget [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpRequest.hpp
  • AddOns/Server/HttpServer/HttpRequest.cpp
Generated on Wed Jan 25 01:19:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpRequest::ParamPair Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
HttpRequest::ParamPair

HttpRequest::ParamPair Struct Reference

#include <Apoxi/AddOns/Server/HttpServer/HttpRequest.hpp>

Collaboration diagram for HttpRequest::ParamPair:

[legend]

Data Fields

String name
String value

Field Documentation

String HttpRequest::ParamPair::name

String HttpRequest::ParamPair::value

The documentation for this struct was generated from the following file:
  • AddOns/Server/HttpServer/HttpRequest.hpp
Generated on Wed Jan 25 01:19:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpRequestMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpRequestMessage Class Reference

#include <Apoxi/AddOns/Server/HttpServer/MsgTypes.hpp>

Inheritance diagram for HttpRequestMessage:

[legend]
Collaboration diagram for HttpRequestMessage:

[legend]

Public Types

enum | { ID = 4512 }

Public Member Functions

virtual Message * | Clone () const
UINT | GetClientId () const
const HttpRequest & | GetHttpRequest () const
virtual const MsgMetaData & | GetMetaData () const
HttpRequestMessage (UINT clientId, const HttpRequest &httpRequest)
virtual | ~HttpRequestMessage ()

Detailed Description

This message is sent when a client poses a request.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HttpRequestMessage::HttpRequestMessage | ( | UINT | clientId,
 |  | const HttpRequest & | httpRequest
 | ) |

HttpRequestMessage::~HttpRequestMessage ( ) [virtual]

Member Function Documentation

Message * HttpRequestMessage::Clone ( ) const [virtual]

Implements Message.

UINT HttpRequestMessage::GetClientId ( ) const [inline]

const HttpRequest& HttpRequestMessage::GetHttpRequest ( ) const [inline]

const MsgMetaData & HttpRequestMessage::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/MsgTypes.hpp
  • AddOns/Server/HttpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:19:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpResponse Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpResponse Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpResponse.hpp>

Collaboration diagram for HttpResponse:

[legend]

Public Member Functions

BOOLEAN | Append (String textStr)
BOOLEAN | Append (HUGE void *data, UINT length)
BOOLEAN | AppendHeader (String headerStr)
RamDataSinkPtr GetBody ()
FilePtr GetFile ()
HttpResponseHeaders GetHeaders ()
String GetStatusLine ()
HttpResponse ()
void | SetFile (FilePtr file)
void | SetStatusLine (String line)
virtual | ~HttpResponse ()

Protected Attributes

RamDataSinkPtr m_body
FilePtr m_file
HttpResponseHeaders m_headers
String m_statusLine

Detailed Description

Class that contains all relevant data of an HTTP response as defined in RFC 2616.

Constructor & Destructor Documentation

HttpResponse::HttpResponse ( )

HttpResponse::~HttpResponse ( ) [virtual]

Member Function Documentation

BOOLEAN HttpResponse::Append ( String textStr )

BOOLEAN HttpResponse::Append | ( | HUGE void * | data,
 |  | UINT | length
 | ) |

BOOLEAN HttpResponse::AppendHeader ( String headerStr )

RamDataSinkPtr HttpResponse::GetBody ( )

FilePtr HttpResponse::GetFile ( )

HttpResponseHeaders HttpResponse::GetHeaders ( )

String HttpResponse::GetStatusLine ( )

void HttpResponse::SetFile ( FilePtr file )

void HttpResponse::SetStatusLine ( String line )

Field Documentation

RamDataSinkPtr HttpResponse::m_body [protected]

FilePtr HttpResponse::m_file [protected]

HttpResponseHeaders HttpResponse::m_headers [protected]

String HttpResponse::m_statusLine [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpResponse.hpp
  • AddOns/Server/HttpServer/HttpResponse.cpp
Generated on Wed Jan 25 01:19:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpServer Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpServer.hpp>

Inheritance diagram for HttpServer:

[legend]
Collaboration diagram for HttpServer:

[legend]

Public Member Functions

virtual IpAddr | GetHostIp ()
virtual IpPortNo | GetPort ()
HttpServer (HttpServerConfig *serverConfig, HttpAuthProvider *authProvider=0)
virtual void | Start (const InetSocketAddr &localAddr, DataConnProfileId dataConnProfileId=c_invalid_data_conn_profile_id)
virtual void | Stop ()
virtual | ~HttpServer ()

Protected Member Functions

virtual BOOLEAN | ConnectClient (const InetSocketAddr &peerAddr, const HttpSocketPtr &peerSocket)
virtual BOOLEAN | DisconnectClient (UINT clientId)
virtual HttpApplication * | GetApplication (String appId)
virtual HttpClient * | GetClient (UINT clientId)
virtual Pathname | GetWwwDir ()
virtual BOOLEAN | HandleRequest (UINT clientId, const HttpRequest &hr)
virtual void | Init ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | Terminate ()

Friends

class | HttpClient
class | HttpServerSocket
class | HttpSocket

Constructor & Destructor Documentation

HttpServer::HttpServer | ( | HttpServerConfig * | serverConfig,
 |  | HttpAuthProvider * | authProvider = 0
 | ) |

Constructor.

Parameters:
authProvider Pointer to a HttpAuthProvider object.

HttpServer::~HttpServer ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN HttpServer::ConnectClient | ( | const InetSocketAddr & | peerAddr,
 |  | const HttpSocketPtr & | peerSocket
 | ) | [protected, virtual]

Connects a client to the server.

Parameters:
peerAddr | Address of the peer socket.
peerSocket | Socket object for sending/receiving data.
Returns:
Whether the operation was successful or not.

BOOLEAN HttpServer::DisconnectClient ( UINT clientId ) [protected, virtual]

Disconnects a client.

Parameters:
clientId ID of the client.
Returns:
Whether the operation was successful or not.

HttpApplication * HttpServer::GetApplication ( String appId ) [protected, virtual]

Returns an application from application supplier.

Parameters:
appId The ID of an application.
Returns:
Pointer to an HttpApplication. Returns 0 if application does not exist or is not registered at the HttpApplicationSupplier.

HttpClient * HttpServer::GetClient ( UINT clientId ) [protected, virtual]

Returns the pointer to a client object with the corresponding ID.

Parameters:
clientId ID of the client.
Returns:
Pointer to a HttpClient object.

Reimplemented from Server.

IpAddr HttpServer::GetHostIp ( ) [virtual]

Returns the IP address of the server.

Returns:
IP address of the server.

Implements Server.

IpPortNo HttpServer::GetPort ( ) [virtual]

Returns the port number where the server is listening.

Returns:
Port number where the server is listening.

Implements Server.

Pathname HttpServer::GetWwwDir ( ) [protected, virtual]

Returns the www directory of the server.

Returns:
The www directory of the server.

BOOLEAN HttpServer::HandleRequest | ( | UINT | clientId,
 |  | const HttpRequest & | hr
 | ) | [protected, virtual]

Handles an HTTP request.

Parameters:
clientId | ID of the client which receives the request.
hr | HttpRequest object containing information and data of a request.
Returns:
Whther the operation was successful or not.

void HttpServer::Init ( ) [protected, virtual]

Protected service interface (called by the constructor). The implementation sends messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Implements Server.

BOOLEAN HttpServer::OnMessage ( const Message & msg ) [protected, virtual]

Handles a system message. Overwritten method of class ServiceThread.

Parameters:
msg A system message.
Returns:
Whether the message was handled or not.

Reimplemented from ServiceThread.

void HttpServer::Start | ( | const InetSocketAddr & | localAddr,
 |  | DataConnProfileId | dataConnProfileId = c_invalid_data_conn_profile_id
 | ) | [virtual]

Public service interface. The implementation sends messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Parameters:
localAddr | The local socket address to bind the server to.
dataConnProfileId | ID of the DataConn to use for opening sockets.

Implements Server.

void HttpServer::Stop ( ) [virtual]

Public service interface. The implementation sends messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Implements Server.

void HttpServer::Terminate ( ) [protected, virtual]

Protected service interface (called by the destructor). The implementation sends messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Implements Server.

Friends And Related Function Documentation

friend class HttpClient [friend]

friend class HttpServerSocket [friend]

friend class HttpSocket [friend]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpServer.hpp
  • AddOns/Server/HttpServer/HttpServer.cpp
Generated on Wed Jan 25 01:19:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpServerConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpServerConfig Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpServerConfig.hpp>

Inheritance diagram for HttpServerConfig:

[legend]
Collaboration diagram for HttpServerConfig:

[legend]

Public Member Functions

virtual const Pathname & | GetWwwDir ()
HttpServerConfig ()
virtual void | SetWwwDir (Pathname wwwDir)
virtual | ~HttpServerConfig ()

Protected Attributes

Pathname m_wwwDir

Constructor & Destructor Documentation

HttpServerConfig::HttpServerConfig ( )

Constructor. Initializes all member variables with the default values.

HttpServerConfig::~HttpServerConfig ( ) [virtual]

Destructor. Deallocates used resources.

Member Function Documentation

const Pathname & HttpServerConfig::GetWwwDir ( ) [virtual]

Returns the www directory of the server containing all externally accessible files.

Returns:
Public www directory of the server.

void HttpServerConfig::SetWwwDir ( Pathname wwwDir ) [virtual]

Sets the www directory of the server containing all externally accessible files.

Parameters:
wwwDir New www directory to set.

Field Documentation

Pathname HttpServerConfig::m_wwwDir [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpServerConfig.hpp
  • AddOns/Server/HttpServer/HttpServerConfig.cpp
Generated on Wed Jan 25 01:19:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpServerSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpServerSocket Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpServerSocket.hpp>

Inheritance diagram for HttpServerSocket:

[legend]
Collaboration diagram for HttpServerSocket:

[legend]

Public Member Functions

HttpServerSocket (Server *server)
virtual | ~HttpServerSocket ()

Protected Member Functions

virtual void | OnAsyncEvent (Event event)

Constructor & Destructor Documentation

HttpServerSocket::HttpServerSocket ( Server * server )

HttpServerSocket::~HttpServerSocket ( ) [virtual]

Member Function Documentation

void HttpServerSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Receives the notification of an asynchronous event. The event types are dependent on the socket type, some events are only sent for connection oriented sockets or for server sockets (please see the enumeration Event). A client who uses sockets has to derive an own socket class and implement this method in order to listen to the events that occur on the socket and to react on it according to its communication policy.

Reimplemented from InetSocket.

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpServerSocket.hpp
  • AddOns/Server/HttpServer/HttpServerSocket.cpp
Generated on Wed Jan 25 01:19:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpServiceMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpServiceMessage Class Reference

#include <Apoxi/AddOns/Server/HttpServer/MsgTypes.hpp>

Inheritance diagram for HttpServiceMessage:

[legend]
Collaboration diagram for HttpServiceMessage:

[legend]

Public Types

enum | { ID = 4510 }

Public Member Functions

virtual Message * | Clone () const
const HttpServiceCommand & | GetCmd () const
const DataConnProfileId & | GetDataConnProfileId () const
virtual const MsgMetaData & | GetMetaData () const
const InetSocketAddr & | GetSocketAddr () const
HttpServiceMessage (const HttpServiceCommand &cmd, const InetSocketAddr &socketAddr=InetSocketAddr(), const DataConnProfileId &dataConnProfileId=c_invalid_data_conn_profile_id)
virtual | ~HttpServiceMessage ()

Detailed Description

This message is sent when an other application (preferably HttpServerApp) uses the public HttpServer interface.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

HttpServiceMessage::HttpServiceMessage | ( | const HttpServiceCommand & | cmd,
 |  | const InetSocketAddr & | socketAddr = InetSocketAddr(),
 |  | const DataConnProfileId & | dataConnProfileId = c_invalid_data_conn_profile_id
 | ) |

HttpServiceMessage::~HttpServiceMessage ( ) [virtual]

Member Function Documentation

Message * HttpServiceMessage::Clone ( ) const [virtual]

Implements Message.

const HttpServiceCommand& HttpServiceMessage::GetCmd ( ) const [inline]

const DataConnProfileId& HttpServiceMessage::GetDataConnProfileId ( ) const [inline]

const MsgMetaData & HttpServiceMessage::GetMetaData ( ) const [virtual]

Implements Message.

const InetSocketAddr& HttpServiceMessage::GetSocketAddr ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/MsgTypes.hpp
  • AddOns/Server/HttpServer/MsgTypes.cpp
Generated on Wed Jan 25 01:19:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpSocket Class Reference
[HTTPSERVER]

#include <Apoxi/AddOns/Server/HttpServer/HttpSocket.hpp>

Inheritance diagram for HttpSocket:

[legend]
Collaboration diagram for HttpSocket:

[legend]

Public Member Functions

HttpSocket (Server *server, UINT clientId=0)
virtual | ~HttpSocket ()

Protected Member Functions

virtual String | ConvertFromHtml (const String &str)
virtual INT8 | HexCharToUInt8 (CHAR ch)
virtual void | OnAsyncEvent (Event event)
virtual BOOLEAN | SendResponse (HttpResponse &httpResponse)
virtual void | SetClientId (UINT clientId)

Protected Attributes

BooleanCondition m_connected
Server * m_server

Friends

class | HttpClient
class | HttpServer

Constructor & Destructor Documentation

HttpSocket::HttpSocket | ( | Server * | server,
 |  | UINT | clientId = 0
 | ) |

Constructor.

Parameters:
server | The corresponding HTTP server.
clientId | ID of the corresponding client.

HttpSocket::~HttpSocket ( ) [virtual]

Destructor.

Member Function Documentation

String HttpSocket::ConvertFromHtml ( const String & str ) [protected, virtual]

Converts an URL string to a 'normal' string. E.g. 'Hello20user!' will be converted to 'Hello user!'.

Parameters:
str An URL type string.
Returns:
A 'normal' string.

INT8 HttpSocket::HexCharToUInt8 ( CHAR ch ) [protected, virtual]

Converts a hex character to its numerical representation, e.g. 'A' will return 10.

Parameters:
ch A hex character.
Returns:
Numeric representation of the hex character.

void HttpSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Handles an asynchronous event. Overwritten method of class TcpSocket.

Parameters:
event An asynchronous event.

Reimplemented from InetSocket.

BOOLEAN HttpSocket::SendResponse ( HttpResponse & httpResponse ) [protected, virtual]

Sends the content of an HttpResponse object to the client. (Internally enqueues the response to eventually previously occured responses and sends the responses one after the other.)

Parameters:
httpResponse The object with the data to send.

void HttpSocket::SetClientId ( UINT clientId ) [protected, virtual]

Sets the client ID of the socket.

Parameters:
cliendId ID of the corresponding client.

Friends And Related Function Documentation

friend class HttpClient [friend]

friend class HttpServer [friend]

Field Documentation

BooleanCondition HttpSocket::m_connected [protected]

Server* HttpSocket::m_server [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/HttpServer/HttpSocket.hpp
  • AddOns/Server/HttpServer/HttpSocket.cpp
Generated on Wed Jan 25 01:19:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpWapMgr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpWapMgr Class Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/HttpWap/HttpWapMgr.hpp>

Collaboration diagram for HttpWapMgr:

[legend]

Public Member Functions

virtual | ~HttpWapMgr ()

Static Public Member Functions

static HttpWapMgr * | GetInstance ()

Protected Member Functions

virtual BOOLEAN | AddRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)
virtual BOOLEAN | AddUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)
virtual BOOLEAN | CancelHttp (INT conn_id, INT requ_id)
virtual BOOLEAN | ClearRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)
virtual BOOLEAN | ClearUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)
virtual BOOLEAN | CloseHttp (INT conn_id)
virtual BOOLEAN | DecodeMessage (const Message &msg, INT &conn_id, INT &requ_id, INT &status, WString &header, BinData **body, INT &more, INT &length, WString &url)
virtual BOOLEAN | GetCipherSuiteName (INT conn_id, const UINT8 **pCipherSuiteName)
virtual INT | GetConnStatusHttp ()
BOOLEAN | GetFreeConnId (INT &conn_id)
virtual BOOLEAN | GetSessionStatusWap (INT conn_id)
virtual BOOLEAN | OpenHttp (INT &conn_id, INT pr_id)
virtual BOOLEAN | ReadRootCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen)
virtual BOOLEAN | ReadUserCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen, UINT8 **certKey, UINT32 *certKeyLen)
virtual BOOLEAN | RegisterWap (INT &conn_id, INT pr_id, WString &mime, INT app_id=0)
void | ReleaseConnId (INT &conn_id)
virtual BOOLEAN | RequestGetHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header)
virtual BOOLEAN | RequestHeadHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header)
virtual BOOLEAN | RequestPostDataHttp (INT conn_id, INT requ_id, BinData *body, INT more)
virtual BOOLEAN | RequestPostHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header, BinData *body, INT more)
virtual BOOLEAN | ResumeHttp (INT conn_id)
virtual BOOLEAN | ResumeWap (INT conn_id)
virtual BOOLEAN | SuspendHttp (INT conn_id)
virtual BOOLEAN | SuspendWap (INT conn_id)
virtual BOOLEAN | UnregisterWap (INT &conn_id, const INT &pr_id)

Protected Attributes

INT | m_conn_id_free_Slot [APOXI_MAX_CONN_LIMIT]
HttpWapMgrPlugin * m_http_plugin

Friends

class | HttpHandler
class | WapHandler

Constructor & Destructor Documentation

HttpWapMgr::~HttpWapMgr ( ) [virtual]

Member Function Documentation

BOOLEAN HttpWapMgr::AddRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [protected, virtual]

Certificate Management - Used to Add a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

BOOLEAN HttpWapMgr::AddUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [protected, virtual]

Certificate Management - Used to Add a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

BOOLEAN HttpWapMgr::CancelHttp | ( | INT | conn_id,
 |  | INT | requ_id
 | ) | [protected, virtual]

Used by the application to cancel an outstanding request.

There must be an outstanding request in order for this function to succeed.

Parameters:
conn_id | Identifier of the HTTP connection, conn_id was returned by httpOpen method.
requ_id | Request id to cancel.
Returns:
Success of method.

BOOLEAN HttpWapMgr::ClearRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [protected, virtual]

Certificate Management - Used to Delete a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

BOOLEAN HttpWapMgr::ClearUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [protected, virtual]

Certificate Management - Used to Delete a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

BOOLEAN HttpWapMgr::CloseHttp ( INT conn_id ) [protected, virtual]

Used by the application to close an HTTP connection.

HTTP connection must be open in order for this function to succeed. Function will cancel all outstanding requests.

Parameters:
conn_id Identifier of the HTTP connection, conn_id was returned by httpOpen method.
Returns:
Success of method.

BOOLEAN HttpWapMgr::DecodeMessage | ( | const Message & | msg,
 |  | INT & | conn_id,
 |  | INT & | requ_id,
 |  | INT & | status,
 |  | WString & | header,
 |  | BinData ** | body,
 |  | INT & | more,
 |  | INT & | length,
 |  | WString & | url
 | ) | [protected, virtual]

This Method is called by the Application each time it gets a message in the form of msg class. This method decodes the message and fills the appropriate fields

Parameters:
msg | The message handed in
conn_id | Connection id this will be filled by Plugin class
requ_id | request id this will be filled by Plugin class
status | status to be filled by the Plugin class
header | header to be filled by the Plugin class by NULL or with value depending upono the Messages Type
body | body this will be filled by Plugin class
more | indicates if more data is following this packet or not
length | length of he data recived filling depends upon the message type
url | to be filled in by the Plugin calls depending upon the message type
Returns:
Sucess of the method

BOOLEAN HttpWapMgr::GetCipherSuiteName | ( | INT | conn_id,
 |  | const UINT8 ** | pCipherSuiteName
 | ) | [protected, virtual]

INT HttpWapMgr::GetConnStatusHttp ( ) [protected, virtual]

Used to query the status of the HTTP connection.

Returns:
The HTTP connection status.

BOOLEAN HttpWapMgr::GetFreeConnId ( INT & conn_id ) [protected]

This function allocates the free connection id

Parameters:
conn_id varialble is filled with valid connection id
Returns:
Sucess of the method

HttpWapMgr * HttpWapMgr::GetInstance ( ) [static]

This function returns the object of the class HttpWapMgr

Parameters:
return instance of the class HttpWapMgr

BOOLEAN HttpWapMgr::GetSessionStatusWap ( INT conn_id ) [protected, virtual]

Used to query the status of the session.

Parameters:
conn_id Identifier of the WAP connection, conn_id was returned by wapRegister method.
Returns:
The WAP session status.

BOOLEAN HttpWapMgr::OpenHttp | ( | INT & | conn_id,
 |  | INT | pr_id
 | ) | [protected, virtual]

Used by application to open the HTTP connection.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls. Value is > 0.
pr_id | Id of WapProfile to be used. (WapProfile determines if connection is secure/non-secure and connection-oriented/ connectionless)
Returns:
Success of method.

BOOLEAN HttpWapMgr::ReadRootCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen
 | ) | [protected, virtual]

Certificate Management - Used to Read a Root Certificate

Parameters:
UINT8** | Certificate data
UINT32* | Certificate length
Returns:
success

BOOLEAN HttpWapMgr::ReadUserCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen,
 |  | UINT8 ** | certKey,
 |  | UINT32 * | certKeyLen
 | ) | [protected, virtual]

Certificate Management - Used to Read a User Certificate

Parameters:
UINT8** | Certificate Data
UINT32* | Certificate length
UINT8** | Certificate key information
UINT32* | Certificate key length
Returns:
success

BOOLEAN HttpWapMgr::RegisterWap | ( | INT & | conn_id,
 |  | INT | pr_id,
 |  | WString & | mime,
 |  | INT | app_id = 0
 | ) | [protected, virtual]

Used to register for WAP push messages.

Function may be called again after a call to wapUnregister.

Parameters:
conn_id | Identifier of the WAP connection. Will be issued and allows a WapHandler to identify itself in function calls. Value is > 0.
pr_id | Id of WapProfile to be used (WapProfile determines if connection is secure/non-secure and connection-oriented/ connectionless).
mime | MIME type supported by registering application.
app_id | Application id according to Open Mobile Naming Authority (OMNA), defaults to 0.
Returns:
Success of method.

void HttpWapMgr::ReleaseConnId ( INT & conn_id ) [protected]

This function releases the connection id

Parameters:
conn_id connection id to be released

BOOLEAN HttpWapMgr::RequestGetHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header
 | ) | [protected, virtual]

Used by the application to initiate an HTTP GET request.

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection, conn_id was returned by httpOpen method.
requ_id | Identifies this request, will be returned by HttpWapMgr.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
Returns:
Success of method.

BOOLEAN HttpWapMgr::RequestHeadHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header
 | ) | [protected, virtual]

Used by the application to initiate an HTTP HEAD request.

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection, conn_id was returned by httpOpen method.
requ_id | Identifies this request, will be returned by HttpWapMgr.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
Returns:
Success of method.

BOOLEAN HttpWapMgr::RequestPostDataHttp | ( | INT | conn_id,
 |  | INT | requ_id,
 |  | BinData * | body,
 |  | INT | more
 | ) | [protected, virtual]

Used by application to supply more body data for an HTTP POST request.

httpRequestPost must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection, conn_id was returned by httpOpen method.
requ_id | Identifies this request, was returned from any httpRequest method.
body | Container with any type of data to be sent in an HTTP POST requests.
more | Application can set more to 1 if it wants to supply more body content using the HttpRequestData method. Request will be sent only as soon as entire body is complete (indicated by more being 0).
Returns:
Success of method.

BOOLEAN HttpWapMgr::RequestPostHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header,
 |  | BinData * | body,
 |  | INT | more
 | ) | [protected, virtual]

Used by the application to initiate an HTTP POST request

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection, conn_id was returned by httpOpen method.
requ_id | Identifies this request, will be returned by HttpWapMgr.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
body | Container with any type of data to be sent in an HTTP POST request.
more | Application can set more to 1 if it wants to supply more body content using the httpRequestData method. Request will be sent only as soon as entire body is complete (indicated by more being 0).
Returns:
Success of method.

BOOLEAN HttpWapMgr::ResumeHttp ( INT conn_id ) [protected, virtual]

Used by the application to tell the stack to resume sending messages.

This function enables flow control between the WAP stack and the application (not between HTTP client and HTTP server). The behaviour of the WAP stack depends e.g. on timeouts etc. and is implementation specific.

Parameters:
conn_id Identifier of the HTTP connection, conn_id was returned by httpOpen method.
Returns:
Success of method.

BOOLEAN HttpWapMgr::ResumeWap ( INT conn_id ) [protected, virtual]

Used by the application to resume the WAP connection.

Returns:
Success of method.

BOOLEAN HttpWapMgr::SuspendHttp ( INT conn_id ) [protected, virtual]

Used by the application to tell the stack to stop sending messages.

This function enables flow control between the WAP stack and the application (not between HTTP client and HTTP server). The behaviour of the WAP stack depends e.g. on timeouts etc. and is implementation specific.

Parameters:
conn_id Identifier of the HTTP connection, conn_id was returned by httpOpen method.
Returns:
Success of method.

BOOLEAN HttpWapMgr::SuspendWap ( INT conn_id ) [protected, virtual]

Used to suspend the WAP connection.

Parameters:
conn_id Identifier of the WAP connection, conn_id was returned by wapRegister method.
Returns:
Success of method.

BOOLEAN HttpWapMgr::UnregisterWap | ( | INT & | conn_id,
 |  | const INT & | pr_id
 | ) | [protected, virtual]

Used by the application to unregister for WAP push messages.

WAP connection must be open in order for this function to succeed. wapRegister must have been called before. Function will cancel all outstanding requests.

Parameters:
conn_id Identifier of the WAP connection, conn_id was returned by wapRegister method.
Returns:
Success of method.

Friends And Related Function Documentation

friend class HttpHandler [friend]

All methods of HttpHandler have access to all methods of HttpWapMgr

friend class WapHandler [friend]

Field Documentation

INT HttpWapMgr::m_conn_id_free_Slot[APOXI_MAX_CONN_LIMIT] [protected]

HttpWapMgrPlugin* HttpWapMgr::m_http_plugin [protected]

The documentation for this class was generated from the following files:
  • AddOns/HttpWapInterface/HttpWap/HttpWapMgr.hpp
  • AddOns/HttpWapInterface/HttpWap/HttpWapMgr.cpp
Generated on Wed Jan 25 01:19:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpWapMgrBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpWapMgrBase Class Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp>

Inheritance diagram for HttpWapMgrBase:

[legend]

Public Member Functions

virtual BOOLEAN | AddRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)=0
virtual BOOLEAN | AddUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)=0
virtual BOOLEAN | CancelHttp (INT conn_id, INT requ_id)=0
virtual BOOLEAN | ClearRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)=0
virtual BOOLEAN | ClearUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)=0
virtual BOOLEAN | CloseHttp (INT conn_id)=0
virtual BOOLEAN | DecodeMessage (const Message &msg, INT &conn_id, INT &requ_id, INT &status, WString &header, BinData **body, INT &more, INT &length, WString &url)=0
virtual BOOLEAN | GetCipherSuiteName (INT conn_id, const UINT8 **pCipherSuiteName)=0
virtual BOOLEAN | GetSessionStatusWap ()=0
HttpWapMgrBase ()
virtual BOOLEAN | IsMessageForMe ()=0
virtual BOOLEAN | OpenHttp (INT &conn_id, INT pr_id)=0
virtual BOOLEAN | ReadRootCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen)=0
virtual BOOLEAN | ReadUserCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen, UINT8 **certKey, UINT32 *certKeyLen)=0
virtual BOOLEAN | RegisterWap (const INT &conn_id, INT pr_id, WString &mime, INT app_id)=0
virtual BOOLEAN | RequestGetHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header)=0
virtual BOOLEAN | RequestHeadHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header)=0
virtual BOOLEAN | RequestPostDataHttp (INT conn_id, INT &requ_id, BinData *body, INT more)=0
virtual BOOLEAN | RequestPostHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header, BinData *body, INT more)=0
virtual BOOLEAN | ResumeHttp (INT conn_id)=0
virtual BOOLEAN | ResumeWap (INT conn_id)=0
virtual BOOLEAN | SuspendHttp (INT conn_id)=0
virtual BOOLEAN | SuspendWap (INT conn_id)=0
virtual BOOLEAN | UnregisterWap (const INT &conn_id)=0
virtual | ~HttpWapMgrBase ()

Constructor & Destructor Documentation

HttpWapMgrBase::HttpWapMgrBase ( ) [inline]

virtual HttpWapMgrBase::~HttpWapMgrBase ( ) [inline, virtual]

Member Function Documentation

virtual BOOLEAN HttpWapMgrBase::AddRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [pure virtual]

Certificate Management - Used to Add a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::AddUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [pure virtual]

Certificate Management - Used to Add a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::CancelHttp | ( | INT | conn_id,
 |  | INT | requ_id
 | ) | [pure virtual]

Used by the application to cancel an outstanding request.

There must be an outstanding request in order for this function to Succeed.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
requ_id | Id of request to cancel.
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::ClearRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [pure virtual]

Certificate Management - Used to Delete a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::ClearUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [pure virtual]

Certificate Management - Used to Delete a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::CloseHttp ( INT conn_id ) [pure virtual]

Used by the application to close the HTTP connection.

HTTP connection must be open in order for this function to succeed. Function will cancel all outstanding requests.

Parameters:
conn_id Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::DecodeMessage | ( | const Message & | msg,
 |  | INT & | conn_id,
 |  | INT & | requ_id,
 |  | INT & | status,
 |  | WString & | header,
 |  | BinData ** | body,
 |  | INT & | more,
 |  | INT & | length,
 |  | WString & | url
 | ) | [pure virtual]

This Method is called by the Application each time it gets a message in the form of msg class. This method decodes the message and fills the appropriate fields

Parameters:
msg | The message handed in
conn_id | Connection id this will be filled by Plugin class
requ_id | request id this will be filled by Plugin class
status | status to be filled by the Plugin class
header | header to be filled by the Plugin class by NULL or with value depending upono the Messages Type
body | body this will be filled by Plugin class
more | indicates if more data is following this packet or not
length | length of he data recived filling depends upon the message type
url | to be filled in by the Plugin calls depending upon the message type
Returns:
Sucess of the method

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::GetCipherSuiteName | ( | INT | conn_id,
 |  | const UINT8 ** | pCipherSuiteName
 | ) | [pure virtual]

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::GetSessionStatusWap ( ) [pure virtual]

Used to query the status of the session.

Parameters:
conn_id Identifier of the WAP connection, conn_id was returned by wapRegister method.
Returns:
The WAP session status.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::IsMessageForMe ( ) [pure virtual]

Used to validate if the message is fo the application or not

Parameters:
return message is for the Application or not

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::OpenHttp | ( | INT & | conn_id,
 |  | INT | pr_id
 | ) | [pure virtual]

Used by application to open the HTTP connection.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls. Value is > 0.
pr_id | Id of WapProfile to be used. (WapProfile determines if connection is secure/non-secure and connection-oriented/ connectionless)
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::ReadRootCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen
 | ) | [pure virtual]

Certificate Management - Used to Read a Root Certificate

Parameters:
UINT8** | Certificate data
UINT32* | Certificate length
Returns:
success

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::ReadUserCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen,
 |  | UINT8 ** | certKey,
 |  | UINT32 * | certKeyLen
 | ) | [pure virtual]

Certificate Management - Used to Read a User Certificate

Parameters:
UINT8** | Certificate Data
UINT32* | Certificate length
UINT8** | Certificate key information
UINT32* | Certificate key length
Returns:
success

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::RegisterWap | ( | const INT & | conn_id,
 |  | INT | pr_id,
 |  | WString & | mime,
 |  | INT | app_id
 | ) | [pure virtual]

Used to register for WAP push messages.

Function may be called again after a call to wapUnregister.

Parameters:
conn_id | Identifier of the WAP connection. Will be issued and allows a WapHandler to identify itself in function calls. Value is > 0.
pr_id | Id of WapProfile to be used (WapProfile determines if connection is secure/non-secure and connection-oriented/ connectionless).
mime | MIME type supported by registering application.
app_id | Application id according to Open Mobile Naming Authority (OMNA), defaults to 0.
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::RequestGetHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header
 | ) | [pure virtual]

Used by the application to initiate an HTTP GET request.

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
requ_id | Identifier of the HTTP request. Will be returned by HttpHandler.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::RequestHeadHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header
 | ) | [pure virtual]

Used by the application to initiate an HTTP HEAD request.

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
requ_id | Identifier of the HTTP request. Will be returned by HttpHandler.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::RequestPostDataHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | BinData * | body,
 |  | INT | more
 | ) | [pure virtual]

Used by application to supply more body data for an HTTP POST request.

httpRequestPost must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
body | Container with any type of data to be sent in an HTTP POST request.
more | Application can set more to 1 if it wants to supply more body content using the HttpRequestData method. Request will be sent only as soon as entire body is complete (indicated by more being 0).
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::RequestPostHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header,
 |  | BinData * | body,
 |  | INT | more
 | ) | [pure virtual]

Used by the application to initiate an HTTP POST request.

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
requ_id | Identifier of the HTTP request. Will be returned by HttpHandler.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
body | Container with any type of data to be sent in an HTTP POST request.
more | Application can set more to 1 if it wants to supply more body content using the httpRequestPost Data method. Request will be sent only as soon as entire body is complete (indicated by more being 0).
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::ResumeHttp ( INT conn_id ) [pure virtual]

Used by the application to resume the HTTP connection.

HTTP connection must be open in order for this function to succeed. Functionality is implementation specific.

Parameters:
conn_id Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::ResumeWap ( INT conn_id ) [pure virtual]

Used by the application to resume the WAP connection.

Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::SuspendHttp ( INT conn_id ) [pure virtual]

Used by the application to suspend the HTTP connection.

HTTP connection must be open in order for this function to succeed. Functionality is implementation specific.

Parameters:
conn_id Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::SuspendWap ( INT conn_id ) [pure virtual]

Used by the application to suspend the WAP connection on the WSP level.

Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

virtual BOOLEAN HttpWapMgrBase::UnregisterWap ( const INT & conn_id ) [pure virtual]

Used by the application to unregister for WAP push messages.

WAP connection must be open in order for this function to succeed. wapRegister must have been called before. Function will cancel all outstanding requests.

Parameters:
conn_id Identifier of the WAP connection, conn_id was returned by wapRegister method.
Returns:
Success of method.

Implemented in HttpWapMgrPlugin.

The documentation for this class was generated from the following file:
  • AddOns/HttpWapInterface/HttpWap/HttpWapMgrBase.hpp
Generated on Wed Jan 25 01:19:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HttpWapMgrPlugin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

HttpWapMgrPlugin Class Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp>

Inheritance diagram for HttpWapMgrPlugin:

[legend]
Collaboration diagram for HttpWapMgrPlugin:

[legend]

Public Member Functions

virtual | ~HttpWapMgrPlugin ()

Static Public Member Functions

static HttpWapMgrPlugin * | GetInstance ()

Protected Member Functions

virtual BOOLEAN | AddRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)
virtual BOOLEAN | AddUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)
virtual BOOLEAN | CancelHttp (INT conn_id, INT requ_id)
virtual BOOLEAN | ClearRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)
virtual BOOLEAN | ClearUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)
virtual BOOLEAN | CloseHttp (INT conn_id)
virtual BOOLEAN | DecodeMessage (const Message &msg, INT &conn_id, INT &requ_id, INT &status, WString &header, BinData **body, INT &more, INT &length, WString &url)
virtual BOOLEAN | GetCipherSuiteName (INT conn_id, const UINT8 **pCipherSuiteName)
BOOLEAN | GetFreeRequestId (INT &request_id)
virtual BOOLEAN | GetSessionStatusWap ()
virtual BOOLEAN | IsMessageForMe ()
virtual BOOLEAN | OpenHttp (INT &conn_id, INT pr_id)
virtual BOOLEAN | ReadRootCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen)
virtual BOOLEAN | ReadUserCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen, UINT8 **certKey, UINT32 *certKeyLen)
virtual BOOLEAN | RegisterWap (const INT &conn_id, INT pr_id, WString &mime, INT app_id)
void | ReleaseRequestId (INT &request_id)
virtual BOOLEAN | RequestGetHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header)
virtual BOOLEAN | RequestHeadHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header)
virtual BOOLEAN | RequestPostDataHttp (INT conn_id, INT &requ_id, BinData *body, INT more)
virtual BOOLEAN | RequestPostHttp (INT conn_id, INT &requ_id, const CHAR *URL, const CHAR *header, BinData *body, INT more)
virtual BOOLEAN | ResumeHttp (INT conn_id)
virtual BOOLEAN | ResumeWap (INT conn_id)
virtual BOOLEAN | SuspendHttp (INT conn_id)
virtual BOOLEAN | SuspendWap (INT conn_id)
virtual BOOLEAN | UnregisterWap (const INT &conn_id)

Protected Attributes

INT | m_request_id_free_Slot [MAXREQUESTLIMIT]

Static Protected Attributes

static HttpWapMgrPlugin | m_http_wap_plugin

Friends

class | HttpWapMgr

Constructor & Destructor Documentation

HttpWapMgrPlugin::~HttpWapMgrPlugin ( ) [virtual]

Member Function Documentation

BOOLEAN HttpWapMgrPlugin::AddRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [protected, virtual]

Certificate Management - Used to Add a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::AddUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [protected, virtual]

Certificate Management - Used to Add a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::CancelHttp | ( | INT | conn_id,
 |  | INT | requ_id
 | ) | [protected, virtual]

Used by the application to cancel an outstanding request.

There must be an outstanding request in order for this function to Succeed.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
requ_id | Id of request to cancel.
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::ClearRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [protected, virtual]

Certificate Management - Used to Delete a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::ClearUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [protected, virtual]

Certificate Management - Used to Delete a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::CloseHttp ( INT conn_id ) [protected, virtual]

Used by the application to close the HTTP connection.

HTTP connection must be open in order for this function to succeed. Function will cancel all outstanding requests.

Parameters:
conn_id Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::DecodeMessage | ( | const Message & | msg,
 |  | INT & | conn_id,
 |  | INT & | requ_id,
 |  | INT & | status,
 |  | WString & | header,
 |  | BinData ** | body,
 |  | INT & | more,
 |  | INT & | length,
 |  | WString & | url
 | ) | [protected, virtual]

This Method is called by the Application each time it gets a message in the form of msg class. This method decodes the message and fills the appropriate fields

Parameters:
msg | The message handed in
conn_id | Connection id this will be filled by Plugin class
requ_id | request id this will be filled by Plugin class
status | status to be filled by the Plugin class
header | header to be filled by the Plugin class by NULL or with value depending upono the Messages Type
body | body this will be filled by Plugin class
more | indicates if more data is following this packet or not
length | length of he data recived filling depends upon the message type
url | to be filled in by the Plugin calls depending upon the message type
Returns:
Sucess of the method

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::GetCipherSuiteName | ( | INT | conn_id,
 |  | const UINT8 ** | pCipherSuiteName
 | ) | [protected, virtual]

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::GetFreeRequestId ( INT & request_id ) [protected]

Used to allocate free request id from the list

Parameters:
request_id Gets the free request id from the list
Returns:
Sucess of the method

HttpWapMgrPlugin * HttpWapMgrPlugin::GetInstance ( ) [static]

This function returns the object of the class HttpWapMgrPlugin

Parameters:
return instance of the class HttpWapMgrPlugin

BOOLEAN HttpWapMgrPlugin::GetSessionStatusWap ( ) [protected, virtual]

Used to query the status of the session.

Parameters:
conn_id Identifier of the WAP connection, conn_id was returned by wapRegister method.
Returns:
The WAP session status.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::IsMessageForMe ( ) [protected, virtual]

Used to validate if the message is fo the application or not

Parameters:
return message is for the Application or not

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::OpenHttp | ( | INT & | conn_id,
 |  | INT | pr_id
 | ) | [protected, virtual]

Used by application to open the HTTP connection.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls. Value is > 0.
pr_id | Id of WapProfile to be used. (WapProfile determines if connection is secure/non-secure and connection-oriented/ connectionless)
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::ReadRootCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen
 | ) | [protected, virtual]

Certificate Management - Used to Read a Root Certificate

Parameters:
UINT8** | Certificate data
UINT32* | Certificate length
Returns:
success

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::ReadUserCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen,
 |  | UINT8 ** | certKey,
 |  | UINT32 * | certKeyLen
 | ) | [protected, virtual]

Certificate Management - Used to Read a User Certificate

Parameters:
UINT8** | Certificate Data
UINT32* | Certificate length
UINT8** | Certificate key information
UINT32* | Certificate key length
Returns:
success

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::RegisterWap | ( | const INT & | conn_id,
 |  | INT | pr_id,
 |  | WString & | mime,
 |  | INT | app_id
 | ) | [protected, virtual]

Used to register for WAP push messages.

Function may be called again after a call to wapUnregister.

Parameters:
conn_id | Identifier of the WAP connection. Will be issued and allows a WapHandler to identify itself in function calls. Value is > 0.
pr_id | Id of WapProfile to be used (WapProfile determines if connection is secure/non-secure and connection-oriented/ connectionless).
mime | MIME type supported by registering application.
app_id | Application id according to Open Mobile Naming Authority (OMNA), defaults to 0.
Returns:
Success of method.

Implements HttpWapMgrBase.

void HttpWapMgrPlugin::ReleaseRequestId ( INT & request_id ) [protected]

Used to free the request id to the list

Parameters:
request_id free's request id to the list

BOOLEAN HttpWapMgrPlugin::RequestGetHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header
 | ) | [protected, virtual]

Used by the application to initiate an HTTP GET request.

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
requ_id | Identifier of the HTTP request. Will be returned by HttpHandler.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::RequestHeadHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header
 | ) | [protected, virtual]

Used by the application to initiate an HTTP HEAD request.

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
requ_id | Identifier of the HTTP request. Will be returned by HttpHandler.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::RequestPostDataHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | BinData * | body,
 |  | INT | more
 | ) | [protected, virtual]

Used by application to supply more body data for an HTTP POST request.

httpRequestPost must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
body | Container with any type of data to be sent in an HTTP POST request.
more | Application can set more to 1 if it wants to supply more body content using the HttpRequestData method. Request will be sent only as soon as entire body is complete (indicated by more being 0).
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::RequestPostHttp | ( | INT | conn_id,
 |  | INT & | requ_id,
 |  | const CHAR * | URL,
 |  | const CHAR * | header,
 |  | BinData * | body,
 |  | INT | more
 | ) | [protected, virtual]

Used by the application to initiate an HTTP POST request.

httpOpen must have been called first.

Parameters:
conn_id | Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
requ_id | Identifier of the HTTP request. Will be returned by HttpHandler.
URL | The requested URL (e.g. "172.36.25.3").
header | Application may supply header values to be used in the request.
body | Container with any type of data to be sent in an HTTP POST request.
more | Application can set more to 1 if it wants to supply more body content using the httpRequestPost Data method. Request will be sent only as soon as entire body is complete (indicated by more being 0).
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::ResumeHttp ( INT conn_id ) [protected, virtual]

Used by the application to resume the HTTP connection.

HTTP connection must be open in order for this function to succeed. Functionality is implementation specific.

Parameters:
conn_id Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::ResumeWap ( INT conn_id ) [protected, virtual]

Used by the application to resume the WAP connection.

Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::SuspendHttp ( INT conn_id ) [protected, virtual]

Used by the application to suspend the HTTP connection.

HTTP connection must be open in order for this function to succeed. Functionality is implementation specific.

Parameters:
conn_id Identifier of the HTTP connection. Will be issued by HttpWapMgr and allows an HttpHandler to identify itself in function calls.
Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::SuspendWap ( INT conn_id ) [protected, virtual]

Used by the application to suspend the WAP connection on the WSP level.

Returns:
Success of method.

Implements HttpWapMgrBase.

BOOLEAN HttpWapMgrPlugin::UnregisterWap ( const INT & conn_id ) [protected, virtual]

Used by the application to unregister for WAP push messages.

WAP connection must be open in order for this function to succeed. wapRegister must have been called before. Function will cancel all outstanding requests.

Parameters:
conn_id Identifier of the WAP connection, conn_id was returned by wapRegister method.
Returns:
Success of method.

Implements HttpWapMgrBase.

Friends And Related Function Documentation

friend class HttpWapMgr [friend]

Field Documentation

HttpWapMgrPlugin HttpWapMgrPlugin::m_http_wap_plugin [static, protected]

INT HttpWapMgrPlugin::m_request_id_free_Slot[MAXREQUESTLIMIT] [protected]

The documentation for this class was generated from the following files:
  • AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.hpp
  • AddOns/HttpWapInterface/HttpWapPlugin/HttpWapMgrPlugin.cpp
Generated on Wed Jan 25 01:19:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Iana Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Iana Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Iana.hpp>

Public Types

enum PortNumber {
c_ftp_data_tcp = (INT) 20, c_ftp_data_udp = (INT) 20, c_ftp_tcp = (INT) 21, c_ftp_udp = (INT) 21,
c_ssh_tcp = (INT) 22, c_ssh_udp = (INT) 22, c_telnet_tcp = (INT) 23, c_telnet_udp = (INT) 23,
c_smtp_tcp = (INT) 25, c_smtp_udp = (INT) 25, c_name_tcp = (INT) 42, c_name_udp = (INT) 42,
c_nameserver_tcp = (INT) 42, c_nameserver_udp = (INT) 42, c_tftp_tcp = (INT) 69, c_tftp_udp = (INT) 69,
c_http_tcp = (INT) 80, c_http_udp = (INT) 80, c_www_tcp = (INT) 80, c_www_udp = (INT) 80,
c_www_http_tcp = (INT) 80, c_www_http_udp = (INT) 80, c_pop3_tcp = (INT) 110, c_pop3_udp = (INT) 110,
c_auth_tcp = (INT) 113, c_auth_udp = (INT) 113, c_nntp_tcp = (INT) 119, c_nntp_udp = (INT) 119,
c_imap_tcp = (INT) 143, c_imap_udp = (INT) 143, c_irc_tcp = (INT) 194, c_irc_udp = (INT) 194,
c_imap3_tcp = (INT) 220, c_imap3_udp = (INT) 220, c_set_tcp = (INT) 257, c_set_udp = (INT) 257,
c_ldap_tcp = (INT) 389, c_ldap_udp = (INT) 389, c_https_tcp = (INT) 443, c_https_udp = (INT) 443,
c_conference_tcp = (INT) 531, c_conference_udp = (INT) 531, c_netnews_tcp = (INT) 532, c_netnews_udp = (INT) 532,
c_ftps_data_tcp = (INT) 989, c_ftps_data_udp = (INT) 989, c_ftps_tcp = (INT) 990, c_ftps_udp = (INT) 990,
c_telnets_tcp = (INT) 992, c_telnets_udp = (INT) 992, c_imaps_tcp = (INT) 993, c_imaps_udp = (INT) 993,
c_ircs_tcp = (INT) 994, c_ircs_udp = (INT) 994, c_pop3s_tcp = (INT) 995, c_pop3s_udp = (INT) 995,
c_wap_push_tcp = (INT) 2948, c_wap_push_udp = (INT) 2948, c_wap_pushsecure_tcp = (INT) 2949, c_wap_pushsecure_udp = (INT) 2949,
c_wimd_tcp = (INT) 2980, c_wimd_udp = (INT) 2980, c_wap_push_http_tcp = (INT) 4035, c_wap_push_http_udp = (INT) 4035,
c_wap_push_https_tcp = (INT) 4036, c_wap_push_https_udp = (INT) 4036, c_wap_wsp_tcp = (INT) 9200, c_wap_wsp_udp = (INT) 9200,
c_wap_wsp_wtp_tcp = (INT) 9201, c_wap_wsp_wtp_udp = (INT) 9201, c_wap_wsp_s_tcp = (INT) 9202, c_wap_wsp_s_udp = (INT) 9202,
c_wap_wsp_wtp_s_tcp = (INT) 9203, c_wap_wsp_wtp_s_udp = (INT) 9203, c_wap_vcard_tcp = (INT) 9204, c_wap_vcard_udp = (INT) 9204,
c_wap_vcal_tcp = (INT) 9205, c_wap_vcal_udp = (INT) 9205, c_wap_vcard_s_tcp = (INT) 9206, c_wap_vcard_s_udp = (INT) 9206,
c_wap_vcal_s_tcp = (INT) 9207, c_wap_vcal_s_udp = (INT) 9207, c_iana_private_ports_begin = (INT) 49152, c_iana_private_ports_end = (INT) 65535,
c_invalid_port_no = (INT) 0
}

Detailed Description

class Iana defines standard port numbers as defined from IANA. Note as port numbers range from 0 to 65535, enum values bigger then 32768 will be negative on 16 bit machines. Care must be taken when range checks are done with enumeration values.

Member Enumeration Documentation

enum Iana::PortNumber

Enumerator:
c_ftp_data_tcp
c_ftp_data_udp
c_ftp_tcp
c_ftp_udp
c_ssh_tcp
c_ssh_udp
c_telnet_tcp
c_telnet_udp
c_smtp_tcp
c_smtp_udp
c_name_tcp
c_name_udp
c_nameserver_tcp
c_nameserver_udp
c_tftp_tcp
c_tftp_udp
c_http_tcp
c_http_udp
c_www_tcp
c_www_udp
c_www_http_tcp
c_www_http_udp
c_pop3_tcp
c_pop3_udp
c_auth_tcp
c_auth_udp
c_nntp_tcp
c_nntp_udp
c_imap_tcp
c_imap_udp
c_irc_tcp
c_irc_udp
c_imap3_tcp
c_imap3_udp
c_set_tcp
c_set_udp
c_ldap_tcp
c_ldap_udp
c_https_tcp
c_https_udp
c_conference_tcp
c_conference_udp
c_netnews_tcp
c_netnews_udp
c_ftps_data_tcp
c_ftps_data_udp
c_ftps_tcp
c_ftps_udp
c_telnets_tcp
c_telnets_udp
c_imaps_tcp
c_imaps_udp
c_ircs_tcp
c_ircs_udp
c_pop3s_tcp
c_pop3s_udp
c_wap_push_tcp
c_wap_push_udp
c_wap_pushsecure_tcp
c_wap_pushsecure_udp
c_wimd_tcp
c_wimd_udp
c_wap_push_http_tcp
c_wap_push_http_udp
c_wap_push_https_tcp
c_wap_push_https_udp
c_wap_wsp_tcp
c_wap_wsp_udp
c_wap_wsp_wtp_tcp
c_wap_wsp_wtp_udp
c_wap_wsp_s_tcp
c_wap_wsp_s_udp
c_wap_wsp_wtp_s_tcp
c_wap_wsp_wtp_s_udp
c_wap_vcard_tcp
c_wap_vcard_udp
c_wap_vcal_tcp
c_wap_vcal_udp
c_wap_vcard_s_tcp
c_wap_vcard_s_udp
c_wap_vcal_s_tcp
c_wap_vcal_s_udp
c_iana_private_ports_begin
c_iana_private_ports_end
c_invalid_port_no

The documentation for this class was generated from the following file:
  • Auxiliary/Iana.hpp
Generated on Wed Jan 25 01:19:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IccId Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IccId Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [10]

Field Documentation

UINT8 IccId::val[10]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:19:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IconDescReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IconDescReadIndArg Class Reference

#include <Apoxi/Apc/ImageStackMsgArgs.hpp>

Inheritance diagram for IconDescReadIndArg:

[legend]
Collaboration diagram for IconDescReadIndArg:

[legend]

Public Types

enum | { ID = 1081 }

Public Member Functions

const SimIconDescription & | GetIcondesc () const
IconDescReadIndArg ()
void | SetIcondesc (const SimIconDescription &icondesc)

Static Public Member Functions

static const IconDescReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

IconDescReadIndArg: reflects arguments of signal SI_ICON_DESCRIPTOR_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

IconDescReadIndArg::IconDescReadIndArg ( )

Member Function Documentation

const IconDescReadIndArg & IconDescReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconDescription& IconDescReadIndArg::GetIcondesc ( ) const [inline]

void IconDescReadIndArg::SetIcondesc ( const SimIconDescription & icondesc ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ImageStackMsgArgs.hpp
  • Apc/ImageStackMsgArgs.cpp
Generated on Wed Jan 25 01:19:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IconDescReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IconDescReadReqArg Class Reference

#include <Apoxi/Apc/ImageStackMsgArgs.hpp>

Inheritance diagram for IconDescReadReqArg:

[legend]
Collaboration diagram for IconDescReadReqArg:

[legend]

Public Types

enum | { ID = 2081 }

Public Member Functions

INT | GetRecno () const
IconDescReadReqArg (INT recno=0)
void | SetRecno (INT recno)

Static Public Member Functions

static const IconDescReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

IconDescReadReqArg: reflects arguments of signal SI_ICON_DESCRIPTOR_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

IconDescReadReqArg::IconDescReadReqArg ( INT recno = 0 )

Member Function Documentation

const IconDescReadReqArg & IconDescReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT IconDescReadReqArg::GetRecno ( ) const [inline]

void IconDescReadReqArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ImageStackMsgArgs.hpp
  • Apc/ImageStackMsgArgs.cpp
Generated on Wed Jan 25 01:19:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IconIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IconIndicator Class Reference
[APOXI Template Layer]

Indicator that displays an icon. More...

#include <Apoxi/Compat/Indicator.hpp>

Inheritance diagram for IconIndicator:

[legend]
Collaboration diagram for IconIndicator:

[legend]

Public Member Functions

virtual void | Draw (DeviceContext *dc, Point pos, Rect draw_rect)
Draws the indicator on the given screen position.
const BitmapRes * | GetIcon () const
Returns the assigned icon.
virtual Size | GetSize () const
Returns the size of the indicator.
IconIndicator (const BitmapRes *icon=0, IndicatorPosition pos=0, IndicatorAlignment align=Center)
OBSOLETE SINCE 1.21.
void | SetIcon (const BitmapRes *icon)
virtual | ~IconIndicator ()

Detailed Description

Indicator that displays an icon.

Constructor & Destructor Documentation

IconIndicator::IconIndicator | ( | const BitmapRes * | icon = 0,
 |  | IndicatorPosition | pos = 0,
 |  | IndicatorAlignment | align = Center
 | ) |

OBSOLETE SINCE 1.21.

IconIndicator::~IconIndicator ( ) [virtual]

Constructs an IconIndicator object with the given icon, position, and alignment. If no icon is set, the indicator will be invisible.

Member Function Documentation

void IconIndicator::Draw | ( | DeviceContext * | dc,
 |  | Point | pos,
 |  | Rect | draw_rect
 | ) | [virtual]

Draws the indicator on the given screen position.

Implements Indicator.

const BitmapRes* IconIndicator::GetIcon ( ) const [inline]

Returns the assigned icon.

Size IconIndicator::GetSize ( ) const [virtual]

Returns the size of the indicator.

Implements Indicator.

void IconIndicator::SetIcon ( const BitmapRes * icon ) [inline]

Sets the icon for this indicator. If the icon is set to 0, the Indicator will be invisible.

The documentation for this class was generated from the following files:
  • Compat/Indicator.hpp
  • Compat/Indicator.cpp
Generated on Wed Jan 25 01:19:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IconSet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IconSet Class Reference
[GUI]

#include <Apoxi/Gui/IconSet.hpp>

Collaboration diagram for IconSet:

[legend]

Public Member Functions

BOOLEAN | AddIcon (const IconState &state, const ImageObtainer &icon)
const ImageObtainer & | GetDefaultIcon () const
const ImageObtainer & | GetIcon (INT index) const
const ImageObtainer & | GetIcon (const IconState &state) const
INT | GetIconCount () const
IconSet (const ImageObtainer &default_icon)
IconSet ()
IconSet & | operator= (const IconSet &icon_set)
void | RemoveAllIcons ()
void | SetDefaultIcon (const ImageObtainer &icon)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
~IconSet ()

Data Structures

struct | IconElem

Detailed Description

An icon set specifies a variable number of icons, which are related to a specific icon state (e. g. disabled or active). Each icon set has at least a default icon, which represents the icon state with the size IconState::DefaultSize and the mode IconState::NormalMode.

It is strongly recommend not to use images for the icon set which require an expensive decoding like PNG, JPEG, GIF or WBMP. The reason is that each time the state of an icon changes the image must be decoded, which might decrease the performance and leads to a weak GUI responsiveness. It is recommended to use icons which are instances of the classes Bitmap, NativeImage or any other kind of image where Image::DecodeSynchronously() returns TRUE.

Constructor & Destructor Documentation

IconSet::IconSet ( )

Default constructor, which initializes the icon set with an emtpy image obtainer as default icon.

IconSet::IconSet ( const ImageObtainer & default_icon )

Parameters:
default_icon Icon for the icon state with the size IconState::DefaultSize and the mode IconState::NormalMode.

IconSet::~IconSet ( )

Member Function Documentation

BOOLEAN IconSet::AddIcon | ( | const IconState & | state,
 |  | const ImageObtainer & | icon
 | ) |

Adds the icon icon for the state defined by state. TRUE is returned, if the icon could be added successfully. If FALSE is returned, either an icon has already been added for the state or not enough memory has been available.

const ImageObtainer& IconSet::GetDefaultIcon ( ) const [inline]

Returns the default icon, which will be used for the icon state with the size IconState::DefaultSize and the mode IconState::NormalMode.

const ImageObtainer & IconSet::GetIcon ( INT index ) const

Returns the icon for the given index. The maximum index can be retrieved by IconSet::GetIconCount.

const ImageObtainer & IconSet::GetIcon ( const IconState & state ) const

Returns the icon for the state state.

INT IconSet::GetIconCount ( ) const

Returns the number of icons including the default icon.

IconSet & IconSet::operator= ( const IconSet & icon_set )

void IconSet::RemoveAllIcons ( )

Removes all icons including the default icon.

void IconSet::SetDefaultIcon ( const ImageObtainer & icon ) [inline]

Sets the default icon, which will be used for the icon state with the size IconState::DefaultSize and the mode IconState::NormalMode.

BOOLEAN IconSet::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Parses the uri for name/value pairs and sets the icons accordingly. The URI format for IconSet property for resource URIs is <uri>!<default icon="" id>="">{;<size>,<mode>=<icon id>="">} e.g. ffs:/test.rc!45;0,0=1111;1,0=2111;2,0=3111;0,1=4111;0,2=5111;1,1=6111;1,2=7111;2,1=8111;2,2=9111

for file URIs file:/<path to="" default="" icon>="">{;<size>,<mode>=<path to="" icon>="">} e.g. file:/c:/1.gif;0,0=c:/2.gif;0,1=c:/3.gif

Size codes: 0 = Small, 1 = Default, 2 = Large Mode codes: 0 = Normal, 1 = Active, 2 = Disabled

Returns:
TRUE if setting icons had no errors, FALSE otherwise.

The documentation for this class was generated from the following files:
  • Gui/IconSet.hpp
  • Gui/IconSet.cpp
Generated on Wed Jan 25 01:19:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IconState Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IconState Class Reference
[GUI]

#include <Apoxi/Gui/IconState.hpp>

Public Types

enum | Mode { NormalMode = 8, DisabledMode = 16, ActiveMode = 32 }
enum | Size { DefaultSize = 1, SmallSize = 2, LargeSize = 4 }

Public Member Functions

Mode | GetMode () const
Size | GetSize () const
IconState (Size size=DefaultSize, Mode mode=NormalMode)
BOOLEAN | operator!= (const IconState &state) const
BOOLEAN | operator== (const IconState &state) const
void | SetMode (Mode mode)
void | SetSize (Size size)

Detailed Description

An icon state defines the size and the mode of an icon. If an icon is defined by an icon set, the unique icon ID of the icon set together with the icon state is used to get the icon itself by invoking the the customizable methods GuiEngineConfig::GetImageIcon and GuiEngineConfig::GetBitmapIcon.
See also:
IconSet

Member Enumeration Documentation

enum IconState::Mode

Enumerator:
NormalMode
DisabledMode
ActiveMode

enum IconState::Size

Enumerator:
DefaultSize
SmallSize
LargeSize

Constructor & Destructor Documentation

IconState::IconState | ( | Size | size = DefaultSize,
 |  | Mode | mode = NormalMode
 | ) |

Parameters:
size | Size of the icon (DefaultSize, SmallSize or LargeSize).
mode | Mode of the icon (NormalMode, DisabledMode, ActiveMode).

Member Function Documentation

IconState::Mode IconState::GetMode ( ) const

IconState::Size IconState::GetSize ( ) const

BOOLEAN IconState::operator!= ( const IconState & state ) const [inline]

BOOLEAN IconState::operator== ( const IconState & state ) const [inline]

void IconState::SetMode ( Mode mode )

void IconState::SetSize ( Size size )

The documentation for this class was generated from the following files:
  • Gui/IconState.hpp
  • Gui/IconState.cpp
Generated on Wed Jan 25 01:19:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IconTextIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IconTextIndicator Class Reference
[APOXI Template Layer]

Indicator that displays an icon and text. More...

#include <Apoxi/Compat/Indicator.hpp>

Inheritance diagram for IconTextIndicator:

[legend]
Collaboration diagram for IconTextIndicator:

[legend]

Public Member Functions

virtual void | Draw (DeviceContext *dc, Point pos, Rect draw_rect)
Draws the indicator on the given screen position.
const BitmapRes * | GetIcon () const
Returns the assigned icon.
virtual Size | GetSize () const
Returns the size of the indicator.
const WString & | GetText () const
Returns the assigned text.
IconTextIndicator (const WString &text, const BitmapRes *icon=0)
IconTextIndicator ()
void | SetIcon (const BitmapRes *icon)
void | SetText (const WString &text)
virtual | ~IconTextIndicator ()

Detailed Description

Indicator that displays an icon and text.

Constructor & Destructor Documentation

IconTextIndicator::IconTextIndicator ( ) [inline]

Constructs an IconIndicator object with the given icon, position, and alignment. If no icon is set, the indicator will be invisible.

IconTextIndicator::IconTextIndicator | ( | const WString & | text,
 |  | const BitmapRes * | icon = 0
 | ) |

IconTextIndicator::~IconTextIndicator ( ) [virtual]

Member Function Documentation

void IconTextIndicator::Draw | ( | DeviceContext * | dc,
 |  | Point | pos,
 |  | Rect | draw_rect
 | ) | [virtual]

Draws the indicator on the given screen position.

Implements Indicator.

const BitmapRes* IconTextIndicator::GetIcon ( ) const [inline]

Returns the assigned icon.

Size IconTextIndicator::GetSize ( ) const [virtual]

Returns the size of the indicator.

Implements Indicator.

const WString& IconTextIndicator::GetText ( ) const [inline]

Returns the assigned text.

void IconTextIndicator::SetIcon ( const BitmapRes * icon ) [inline]

Sets the icon for this indicator. If the icon is set to 0, the Indicator will be invisible.

void IconTextIndicator::SetText ( const WString & text ) [inline]

Sets the text for this indicator. If the text is set to 0, the Indicator will be invisible.

The documentation for this class was generated from the following files:
  • Compat/Indicator.hpp
  • Compat/Indicator.cpp
Generated on Wed Jan 25 01:19:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IconValueIndicator Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IconValueIndicator Struct Reference
[APOXI Template Layer]

Indicator that displays icon assigned for iterator values. More...

#include <Apoxi/Compat/Indicator.hpp>

Inheritance diagram for IconValueIndicator:

[legend]
Collaboration diagram for IconValueIndicator:

[legend]

Public Types

typedef ValueIndicator | Base
typedef const BitmapRes * | BitmapResArray

Public Member Functions

virtual void | Draw (DeviceContext *dc, Point pos, Rect draw_rect)
Draws the indicator on the given screen position.
virtual const BitmapRes * | GetIcon () const
Returns the icon for the asigned value.
virtual Size | GetSize () const
Retruns the size of the indicator.
virtual INT | GetStep () const
IconValueIndicator (const BitmapResArray *icons=0, UINT8 icon_count=0, IndicatorPosition pos=0, IndicatorAlignment align=Left)
OBSOLETE SINCE 1.21.
void | SetIcons (const BitmapResArray *icons, UINT8 icon_count)
virtual | ~IconValueIndicator ()

Detailed Description

Indicator that displays icon assigned for iterator values.

Member Typedef Documentation

typedef ValueIndicator IconValueIndicator::Base

Reimplemented from ValueIndicator.

typedef const BitmapRes* IconValueIndicator::BitmapResArray

Constructor & Destructor Documentation

IconValueIndicator::IconValueIndicator | ( | const BitmapResArray * | icons = 0,
 |  | UINT8 | icon_count = 0,
 |  | IndicatorPosition | pos = 0,
 |  | IndicatorAlignment | align = Left
 | ) |

OBSOLETE SINCE 1.21.

IconValueIndicator::~IconValueIndicator ( ) [virtual]

Member Function Documentation

void IconValueIndicator::Draw | ( | DeviceContext * | dc,
 |  | Point | pos,
 |  | Rect | draw_rect
 | ) | [virtual]

Draws the indicator on the given screen position.

Implements Indicator.

const BitmapRes * IconValueIndicator::GetIcon ( ) const [virtual]

Returns the icon for the asigned value.

Size IconValueIndicator::GetSize ( ) const [virtual]

Retruns the size of the indicator.

Implements Indicator.

INT IconValueIndicator::GetStep ( ) const [virtual]

See also:
ValueIndicator::GetStep

Reimplemented from ValueIndicator.

void IconValueIndicator::SetIcons | ( | const BitmapResArray * | icons,
 |  | UINT8 | icon_count
 | ) |

Sets the icons for this indicator. The icons are used for equal intervals in the range of the indicator. The first icon is used for the lowest, the last icon (icon_count -1) is used for the highest value.

The documentation for this struct was generated from the following files:
  • Compat/Indicator.hpp
  • Compat/Indicator.cpp
Generated on Wed Jan 25 01:19:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IdentifierHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IdentifierHandler Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/IdentifierHandler.hpp>

Static Public Member Functions

static Feature * | GetFeature (const WString &identifier)
static WString | GetIdentifier (Feature *feature)
static Property * | GetProperty (const WString &identifier)

Detailed Description

This class handles identfier strings, which reference either a property or a feature. Notation:
  • prop://<ApplicationID>/<FeatureID>
feat://<ApplicationID>/<FeatureID>

Member Function Documentation

Feature * IdentifierHandler::GetFeature ( const WString & identifier ) [static]

Parameters:
identifier Identifier string. Example: "feat://Sms/NewSms"
Returns:
feature Feature object, if FeatureBroker provides it

WString IdentifierHandler::GetIdentifier ( Feature * feature ) [static]

Parameters:
feature Example: Feature "NewSms" of application "Sms"
Returns:
Identifier string referencing the feature. Example: "feat://Sms/NewSms"

Property * IdentifierHandler::GetProperty ( const WString & identifier ) [static]

Parameters:
identifier Identifier string. Example: "prop://Sms/SmsArrived"
Returns:
feature Property object, if FeatureBroker provides it

The documentation for this class was generated from the following files:
  • Atl/IdentifierHandler.hpp
  • Atl/IdentifierHandler.cpp
Generated on Wed Jan 25 01:19:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IdleScreenAvailEventArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IdleScreenAvailEventArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for IdleScreenAvailEventArg:

[legend]
Collaboration diagram for IdleScreenAvailEventArg:

[legend]

Public Types

enum | { ID = 2317 }

Public Member Functions

IdleScreenAvailEventArg ()

Static Public Member Functions

static const IdleScreenAvailEventArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

IdleScreenAvailEventArg: reflects arguments of signal SI_IDLE_SCREEN_AVAIL_EVENT

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

IdleScreenAvailEventArg::IdleScreenAvailEventArg ( )

Member Function Documentation

const IdleScreenAvailEventArg & IdleScreenAvailEventArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:19:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Image Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Image Class Reference
[GUI]

#include <Apoxi/Gui/Image.hpp>

Inheritance diagram for Image:

[legend]
Collaboration diagram for Image:

[legend]

Public Types

enum | { ID = 43 }
typedef Bitmap * | BitmapPtr
enum ErrorCode {
NoError = 0, UnspecifiedError = 1, InvalidSizeError = 2, InitializationError = 3,
ScanlineBufferError = 4, MissingDataError = 5, IsCurrentlyDecodedError = 6, CouldNotAllocateThreadletError = 7,
ThreadletStoppedError = 8, OutOfMemoryError = 9, DecodingInterruptedError = 10
}
enum | ValidationResult { Valid, Invalid, InProgress }
Is returned by the method Image::Validate. More...

Public Member Functions

BOOLEAN | ConvertToBitmap (Bitmap *bitmap, INT frame_idx=0, BOOLEAN block=TRUE)
virtual BOOLEAN | DecodeSynchronously () const
void | Draw (DeviceContext *dc, XYDIM x, XYDIM y) const
Draws the image at position x, y using the given device-context.
virtual BOOLEAN | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT frame_idx, XYDIM scaled_width=-1, XYDIM scaled_height=-1, const Rect &clip_rect=Rect()) const
virtual void | DrawCorruptImageSign (DeviceContext *dc, XYDIM x, XYDIM y, XYDIM scaled_width, XYDIM scaled_height) const
virtual const BinData * | GetBinData () const
Returns the binary data of the image. Per default 0 is returned.
INT8 | GetBitsPerPixel () const
UINT8 | GetErrorCode () const
INT | GetFrameCount () const
virtual UINT32 | GetFrameDelay (INT frame_idx) const =0
XYDIM | GetHeight () const
Returns the number of pixels in vertical dimension.
Bitmap * | GetImageBuffer (INT frame_idx) const
const MetaData & | GetMetaData () const
virtual INT | GetNextFrame (INT frame_idx) const =0
Returns the index of the frame wich follows the specified frame in frame_idx.
INT | GetRepeatCount () const
XYDIM | GetScaledHeight (XYDIM scaled_width) const
XYDIM | GetScaledWidth (XYDIM scaled_height) const
XYDIM | GetWidth () const
Returns the number of pixel in horizontal dimension.
Image ()
virtual BOOLEAN | IsBufferingAllowed () const
virtual BOOLEAN | IsCopyrighted () const
BOOLEAN | IsCurrentlyDecoded () const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsProgressMsgEnabled () const
void | ObtainBackgroundImages ()
void | SetBackgroundImage (Bitmap *background, INT frame_idx=0)
void | SetErrorCode (UINT8 error_code) const
void | SetProgressMsgEnabled (BOOLEAN progress)
void | StopDecoding () const
ValidationResult | Validate (INT frame_idx=0, BOOLEAN block=TRUE)
void | WaitUntilDecodingIsFinished () const
virtual | ~Image ()

Static Public Attributes

static const UINT32 | c_unlimited = 0xFFFFFFFF

Protected Member Functions

void | AdjustSize (XYDIM &width, XYDIM &height) const
virtual void * | BeginScanlineDrawing (INT frame_idx=0) const
BOOLEAN | CheckForInterrupt () const
virtual void | DrawScanline (void *context, DeviceContext *dc, XYDIM x, XYDIM y, INT scanline_idx, INT old_scanline_idx) const
virtual void | EndScanlineDrawing (void *context) const
virtual XYDIM | GetFrameHeight (void *context) const
virtual XYDIM | GetFrameWidth (void *context) const
virtual XYDIM | GetFrameXPos (void *context) const
virtual XYDIM | GetScanlineDiff (void *context, INT scanline_idx, INT old_scanline_idx) const
virtual ColorValue | GetTransparentColor (void *context) const
virtual BOOLEAN | HasAlphaChannel (void *context) const
virtual BOOLEAN | IsFullTraversingEnabled (void *context) const
BOOLEAN | IsPreviousFrameBuffering () const
virtual BOOLEAN | IsTransparent (void *context) const
void | SetBitsPerPixel (INT8 bpp)
Wrapper method for setting the bits per pixel of the image meta data.
void | SetFrameCount (INT frame_count)
Wrapper method for setting the frame count of the image meta data.
void | SetHeight (XYDIM height)
Wrapper method for setting the height of the image meta data.
void | SetMetaData (XYDIM width, XYDIM heigth, INT8 bpp, INT frame_count, INT repeat_count)
void | SetMetaData (const MetaData &meta_data)
void | SetPreviousFrameBuffering (BOOLEAN previous) const
void | SetRepeatCount (INT repeat_count)
Wrapper method for setting the repeat count of the image meta data.
void | SetWidth (XYDIM width)
Wrapper method for setting the width of the image meta data.

Friends

class | CleanupDrawingObtainer

Data Structures

class | CleanupDrawingObtainer
class | MetaData

Detailed Description

Abstract base class for images like GIF, JPEG, PNG etc. The default implementation of Image::Draw allows horizontal and vertical scaling of an image; the derived classes just need to implement the methods BeginScanlineDrawing, DrawScanline and EndScanlineDrawing for this.

Dependant from the size and format of the image, the drawing of the image might take several seconds. To avoid blocking a user-input like a key-press, a maximum decoder delay can be specified in OptionalConfig::GetSetting (see setting MaxDecoderDelay for details). If this delay is set to e. g. 500 milliseconds then APOXI checks each 500 milliseconds if there is a user-input in the message-queue. Hence if the drawing of a large image takes e. g. 10 seconds, this check is done 20 times during the period of the 10 seconds. If there is a user-input the drawing will be cancelled and the message ImageDrawingInterruptedMsg will be posted. If there is no user-input during a check, just the display is updated to give the user a visual response about the drawing-progress of the image.

APOXI automatically tries to buffer each decoded or scaled image to increase the drawing-performance. The available image-buffer-maximum for all decoded images can be specified by GuiEngineConfig::GetSharedImageBufferMax. Additionally a maximum may be defined for one image by GuiEngineConfig::GetImageBufferMax.

As not all compilers support RTTI but this is useful for images, they provide a RTTI-support by the method Image::IsInstanceOf. This makes it necessary that each image-class gets a unique ID. The IDs from 0 to 999 are reserved for APOXI:

ID: Class

  • 0: Image
  • 1: BmpImage
  • 2: GifImage
  • 3: JpegImage
  • 4: PngImage
  • 5: WbmpImage
  • 6: NativeImage

See also:
ImageDrawingInterruptedMsg

OptionalConfig

GuiEngineConfig

Member Typedef Documentation

typedef Bitmap* Image::BitmapPtr

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

enum Image::ErrorCode

The current state of the error-code of an image can be retrieved by invoking the method GetErrorCode, which returns an INT-value as error-information. This INT-value is mapped to error-codes represented as enums in the corresponding image-classes. The value-range is divided into the following sections:

  • 0 to 20: common error-codes
  • 21 to 40: JPEG
  • 41 to 60: PNG
  • 61 to 80: GIF
  • 81 to 100: WBMP
  • 101 to 120: Native image
  • 121 to 255: error-codes for custom image classes
Enumerator:
NoError | no error has occured (should be the normal case)
UnspecifiedError | an unspecified error has occured, no specific information is available
InvalidSizeError | the image has an invalid size (e. g. the width is zero)
InitializationError | an error occured during the initialization of the drawing
ScanlineBufferError | no scanline-buffer could be obtained, which is needed for scaling
MissingDataError | the image-object does not contain any data
IsCurrentlyDecodedError | when using ConvertToBitmap the image is already decoded by a threadlet
CouldNotAllocateThreadletError | the threadlet needed for decoding in ConvertToBitmap could not be allocated
ThreadletStoppedError | a threadlets has been stopped so no drawing is performed
OutOfMemoryError | memory for the decoder could not be allocated
DecodingInterruptedError | the decoding has been interrupted by invoking Image::StopDecoding

enum Image::ValidationResult

Is returned by the method Image::Validate.

Enumerator:
Valid | The image is valid and Image::GetErrorCode will return ErrorCode::NoError.
Invalid | The image is invalid. The reason of the error can be retrieved by invoking Image::GetErrorCode.
InProgress | The validation is still ongoing. In this case the application must listen to the message ImageDecodingProgressMsg to check when the validation has been finished.

Constructor & Destructor Documentation

Image::Image ( )

Image::~Image ( ) [virtual]

Member Function Documentation

void Image::AdjustSize | ( | XYDIM & | width,
 |  | XYDIM & | height
 | ) | const [protected]

Adjusts the size of the image to the given width and height.

Parameters:
width | I/O parameter, which gets the wished width as input and contains the available width.
width | I/O parameter, which gets the wished height as input and contains the available height.

void * Image::BeginScanlineDrawing ( INT frame_idx = 0 ) const [protected, virtual]

If an image is drawn scanline by scanline, this method is invoked before drawing the first scanline. Usually this is the place where the image-decoder should be initialized (see class ImageDecoder for details) and returned as context-object. If no image-decoder is required, it is recommended to return the pointer to the instance of the image-class itself.

Parameters:
frame_idx Index of the frame, which should be drawn.
Returns:
A pointer to a context-object, which is passed as parameter when invoking DrawScanline and EndScanlineDrawing. Returning 0 means that there has been an an error and hence DrawScanline and EndScanlineDrawing may not invoked afterwards.
See also:
EndScanlineDrawing

DrawScanline

Reimplemented in BmpImage, GifImage, JpegImage, WbmpImage, and NativeImage.

BOOLEAN Image::CheckForInterrupt ( ) const [protected]

Returns TRUE, if the decoding has been interrupted by a user-interaction. This method should be used in combination with a CleanupDrawingObtainer.

BOOLEAN Image::ConvertToBitmap | ( | Bitmap * | bitmap,
 |  | INT | frame_idx = 0,
 |  | BOOLEAN | block = TRUE
 | ) |

Converts the image to a bitmap. This allows very fast drawing operations, but may result in a higher memory demand, because usually most images are compressed.

Parameters:
bitmap | Pointer to the bitmap, which should contain the converted image. The image is automatically scaled to the size of the bitmap.
frame_idx | Index of the frame, which should be converted to a bitmap.
block | If set to TRUE the converting is done synchronously, which means that the thread is blocked until the converting has been finished. This is only recommended for small images. When set to FALSE, the converting is done by the worker-thread and the message ImageDecodingProgressMsg including the progress-value is posted frequently, until the converting has been finished.
Returns:
TRUE if the converting has been successful.
See also:
Bitmap

BOOLEAN Image::DecodeSynchronously ( ) const [virtual]

Indicates, whether an Image should be decoded synchronously or asynchronously and being buffered by default. The default setting is TRUE.

Returns:
Returns TRUE if image should be decoded synchronously

Reimplemented in SvgImage, and NativeImage.

void Image::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y
 | ) | const

Draws the image at position x, y using the given device-context.

BOOLEAN Image::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | frame_idx,
 |  | XYDIM | scaled_width = -1,
 |  | XYDIM | scaled_height = -1,
 |  | const Rect & | clip_rect = Rect()
 | ) | const [virtual]

Draws the frame_idxth frame of the Image at position x, y using the given device context.

Parameters:
dc | Device context to draw the image.
x | X-position of the image origin.
y | Y-position of the image origin.
frame_idx | Number of image frame which should be painted.
scaled_width | Scaled width of the image. If -1 is used, the original width is taken.
scaled_height | Scaled height of the image. If -1 is used, the original height is taken.
clip_rect | Specifies the area inside the image which must be painted.
Returns:
TRUE, if the drawing has been successful. If FALSE is returned, the corresponding error can be retrieved by invoking the method GetErrorCode.

Reimplemented in PngImage, SvgImage, and NativeImage.

void Image::DrawCorruptImageSign | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | scaled_width,
 |  | XYDIM | scaled_height
 | ) | const [virtual]

Is invoked by the decoder, if the decoding has been failed and allows to draw an image sign for corrupt images (e. g. a red cross). Per default nothing is drawn.

void Image::DrawScanline | ( | void * | context,
 |  | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

Draws the specified scanline. Must be implemented for scaling.

Parameters:
context | Pointer to the context-object, which can be retrieved in BeginScanlineDrawing.
x | X-position of the image origin.
y | Y-position of the image origin.
scanline_idx | Number of the scanline index that should be drawn. It is assured, that the scanline_idx is always >= the old_scanline_idx. When the image is not scaled, the scanline_idx is always old_scanline_idx + 1, but it is important to recognize also the cases where the scanline_idx is equal to the old_scanline_idx (this happens when the height of an image is increased) or the scanline_idx is greater then the old_scanline_idx + 1 (this happens when the height of the image is decreased). If the decoder requires that the scanline_idx is always increased by one, the method Image::IsFullTraversingEnabled must be overwritten to return TRUE.
old_scanline_idx | Number of last drawn scanline index.

Reimplemented in BmpImage, GifImage, JpegImage, WbmpImage, and NativeImage.

void Image::EndScanlineDrawing ( void * context ) const [protected, virtual]

If an image is drawn scanline by scanline, this method is invoked after drawing the last scanline. Usually the image-decoder should be freed at this place (see class ImageDecoder for details).

Parameters:
context Pointer to the context-object, which can be retrieved in BeginScanlineDrawing
See also:
BeginScanlineDrawing

DrawScanline

Reimplemented in BmpImage, GifImage, JpegImage, WbmpImage, and NativeImage.

const BinData * Image::GetBinData ( ) const [virtual]

Returns the binary data of the image. Per default 0 is returned.

Reimplemented in BmpImage, GifImage, JpegImage, PngImage, WbmpImage, SvgImage, NativeImage, and EmsImage.

INT8 Image::GetBitsPerPixel ( ) const [inline]

Returns the number of bits for one pixel. If the image represents a grayscale format, the value is less than 0. F.i: A bpp value of 6 means a color image which uses 6 bits to code one pixel, a value of -6 means a grayscale image with 64 grayscales. Monchrom images have a bpp value of 1.

UINT8 Image::GetErrorCode ( void ) const [inline]

Returns an error-code of the image-object. The error-code might be checked, whenever the methods Draw or ConvertToBitmap return FALSE, which indicates that an error has occured during the initialization, the decoding or drawing of the image. For each image-class the error-code is mapped to an enum including the description of the error. Example: if (image.GetErrorCode() == Image::InvalidSizeError) { ... }

INT Image::GetFrameCount ( ) const [inline]

Gives the number of (virtual) frames in the image. If the image is not animated, GetFrameCount returns 1.

virtual UINT32 Image::GetFrameDelay ( INT frame_idx ) const [pure virtual]

Returns the time in milliseconds the specified frame should be displayed. The value Image::c_unlimited means that it should be displayed _forever_.

Implemented in BmpImage, GifImage, JpegImage, PngImage, WbmpImage, SvgImage, NativeImage, and EmsImage.

XYDIM Image::GetFrameHeight ( void * context ) const [protected, virtual]

Delivers the frame height, which can be to the main frame height

Parameters:
context Pointer to the context-object, which can be retrieved within Image::BeginScanlineDrawing.

Reimplemented in GifImage.

XYDIM Image::GetFrameWidth ( void * context ) const [protected, virtual]

Delivers the frame width, which can be to the main frame width

Parameters:
context Pointer to the context-object, which can be retrieved within Image::BeginScanlineDrawing.

Reimplemented in GifImage.

XYDIM Image::GetFrameXPos ( void * context ) const [protected, virtual]

Delivers the frame position, relative to the top left position of the main frame

Parameters:
context Pointer to the context-object, which can be retrieved within Image::BeginScanlineDrawing.

Reimplemented in GifImage.

XYDIM Image::GetHeight ( ) const [inline]

Returns the number of pixels in vertical dimension.

Bitmap * Image::GetImageBuffer ( INT frame_idx ) const

Returns the buffer for the frame with index frame_idx. Per default the buffer is filled by the decoding threadlet asynchronously.

const MetaData& Image::GetMetaData ( ) const [inline]

Returns the meta-data of the image.

See also:
MetaData

virtual INT Image::GetNextFrame ( INT frame_idx ) const [pure virtual]

Returns the index of the frame wich follows the specified frame in frame_idx.

Implemented in BmpImage, GifImage, JpegImage, PngImage, WbmpImage, SvgImage, NativeImage, and EmsImage.

INT Image::GetRepeatCount ( ) const [inline]

Returns the number of repetations of an animation.

Returns:
Value greater that 0: Number of repeations, 0 for unlimited repetations, a value less than 0 if this Image is not animated.

XYDIM Image::GetScaledHeight ( XYDIM scaled_width ) const

Returns the scaled height corresponding to to the scaled width scaled_width keeping the same ratio.

XYDIM Image::GetScaledWidth ( XYDIM scaled_height ) const

Returns the scaled width corresponding to to the scaled height scaled_height keeping the same ratio.

XYDIM Image::GetScanlineDiff | ( | void * | context,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

Returns the difference of the real y-position of the scanline in relation to the scanline-index. Per default 0 is returned, which means that e. g. the y-position of the scanline with the index 5 is also 5. If e. g. -2 is return for the scanline with the index 5, the real y-position would be 3. Returning a different value then 0 makes only sense for interlaced images.

Parameters:
context | Pointer to the context-object, which can be retrieved in BeginScanlineDrawing.
scanline_idx | Number of scanline index that should be drawn.
old_scanline_idx | Number of last drawn scanline index.

Reimplemented in BmpImage, and GifImage.

ColorValue Image::GetTransparentColor ( void * context ) const [protected, virtual]

Returns the color-value of the transparent color. The value is only valid, if IsTransparent is TRUE. Per default 0 is returned.

Parameters:
context Pointer to the context-object, which can be retrieved within Image::BeginScanlineDrawing.

Reimplemented in BmpImage, GifImage, PngImage, WbmpImage, SvgImage, and NativeImage.

XYDIM Image::GetWidth ( ) const [inline]

Returns the number of pixel in horizontal dimension.

BOOLEAN Image::HasAlphaChannel ( void * context ) const [protected, virtual]

Returns TRUE, if the image supports alpha blending. Per default, FALSE is returned.

Parameters:
context Pointer to the context-object, which can be retrieved within Image::BeginScanlineDrawing.

Reimplemented in PngImage, and SvgImage.

BOOLEAN Image::IsBufferingAllowed ( ) const [virtual]

Returns TRUE, if the image may get buffered. Per default TRUE is returned. Usually it should be possible to buffer any kind of image, but there might be use cases like for SVG images where a buffering should be avoided.

Reimplemented in SvgImage.

BOOLEAN Image::IsCopyrighted ( ) const [virtual]

Returns TRUE if the image is copyrighted, FALSEotherwise. Per default FALSE is returned.

Reimplemented in NativeImage.

BOOLEAN Image::IsCurrentlyDecoded ( ) const [inline]

Returns TRUE, if the image is currently decoded and hence the decoding is not finished yet. This information is useful to find out, whether the decoding has been finished, if ConvertToBitmap has been invoked.

BOOLEAN Image::IsFullTraversingEnabled ( void * context ) const [protected, virtual]

Per default FALSE is returned, which means that when drawing the scanlines of the image, not all of them must be traversed. This increases the performance when scaling an image, where the scaled height is smaller then the image-height. But especially for interlaced images or images with complex decoders it makes sense to force the traversing of all scanlines, as it allows a more efficient implementation of the decoder.

Parameters:
context Pointer to the context-object, which can be retrieved within Image::BeginScanlineDrawing

Reimplemented in BmpImage, and GifImage.

BOOLEAN Image::IsInstanceOf ( INT id ) const [virtual]

Returns TRUE, if the image is an instance of the image-class with the ID id. Must be implemented by each derived class the following way:

BOOLEAN MyImage::IsInstanceOf(INT id) const
{
    if (ID != id)
        return Base::IsInstanceOf(id);
    return TRUE;
}

Example: if it should be checked, whether an item is an instance of the class JpegImage the following code might be used:

if (img->IsInstanceOf(JpegImage::ID)) {
    JpegImage* jpeg_img = (JpegImage*)img;
    ...
}

The IDs from 0 to 99 are reserved for APOXI.

Reimplemented in BmpImage, GifImage, JpegImage, PngImage, WbmpImage, SvgImage, and NativeImage.

BOOLEAN Image::IsPreviousFrameBuffering ( ) const [inline, protected]

Returns TRUE if the buffer from the previous frame should be used for drawing the current frame

BOOLEAN Image::IsProgressMsgEnabled ( ) const [inline]

Check, if sending progress messages is enabled or disabled.

BOOLEAN Image::IsTransparent ( void * context ) const [protected, virtual]

Returns TRUE, if the image has transparent pixels. Having transparent pixels may slow down the displaying-process of an image. Per default FALSE is returned.

Parameters:
context Pointer to the context-object, which can be retrieved in BeginScanlineDrawing.

Reimplemented in GifImage, PngImage, WbmpImage, SvgImage, and NativeImage.

void Image::ObtainBackgroundImages ( ) [inline]

Per default background images which are passed to the image by Image::SetBackgroundImage are not owned by the image and hence may not get deleted before the image gets deleted. If the caller allocated the background images and does not delete the image object itself, he can forward the ownership to the image object by invoking Image::ObtainBackgroundImages. This means that when the image is deleted all background images will get deleted too.

void Image::SetBackgroundImage | ( | Bitmap * | background,
 |  | INT | frame_idx = 0
 | ) |

Sets the background image that is needed for animation buffering when having transparent images. The background image is not owned by the image object per default, hence it may not be deleted before the image object is deleted. The ownership can be passed to the image by invoking Image::ObtainBackgroundImages.

See also:
Image::ObtainBackgroundImages

void Image::SetBitsPerPixel ( INT8 bpp ) [inline, protected]

Wrapper method for setting the bits per pixel of the image meta data.

void Image::SetErrorCode ( UINT8 error_code ) const

Sets the state of the error-code of an image. This state should be set, whenever an error occurs when initializing, decoding or drawing an image. If the error code is not Image::ErrorCode::NoError then additionally an ImageDecodingProgressMsg is broadcasted with the value -1 as progress information. This indicates that that the dispatcher which listens to this message should check the error code of the image.

void Image::SetFrameCount ( INT frame_count ) [protected]

Wrapper method for setting the frame count of the image meta data.

void Image::SetHeight ( XYDIM height ) [inline, protected]

Wrapper method for setting the height of the image meta data.

void Image::SetMetaData | ( | XYDIM | width,
 |  | XYDIM | heigth,
 |  | INT8 | bpp,
 |  | INT | frame_count,
 |  | INT | repeat_count
 | ) | [protected]

Sets the basic meta data for the image.

void Image::SetMetaData ( const MetaData & meta_data ) [protected]

Sets the meta data for the image, which describes basic data like width and height.

void Image::SetPreviousFrameBuffering ( BOOLEAN previous ) const [inline, protected]

Sets the drawing mode of current image. If set to TRUE then the previous frame should be used as basis for drawing the current frame. Currently only used within GIF images when the frame is a diff to the previous frame. Normally set to TRUE

void Image::SetProgressMsgEnabled ( BOOLEAN progress ) [inline]

Allows to disable sending progress messages.

void Image::SetRepeatCount ( INT repeat_count ) [inline, protected]

Wrapper method for setting the repeat count of the image meta data.

void Image::SetWidth ( XYDIM width ) [inline, protected]

Wrapper method for setting the width of the image meta data.

void Image::StopDecoding ( ) const

Stops the decoding of an image.

See also:
IsCurrentlyDecoded

Image::ValidationResult Image::Validate | ( | INT | frame_idx = 0,
 |  | BOOLEAN | block = TRUE
 | ) |

Checks whether the the image data is valid. Note that this is a very expensive operation as the whole image data must be decoded.

Parameters:
frame_idx | Index of the frame, which should be validated.
block | If set to TRUE the decoding is done synchronously and hence the calling application is blocked until the decoding has been finished. This is only acceptable for small images. When checking the validity of large images block should be set to FALSE. In this case the decoding is done in a separate thread and the message ImageDecodingProgressMsg is send periodically. This message can be treated by the application to show e. g. a progress bar during decoding (sample code is available in the GUI Tutorial).
Returns:
In the blocking mode either Valid is returned or Invalid. If Invalid is returned the reason of the error can be checked by invoking Image::GetErrorCode. In the non blocking mode InProgress is returned. In this case the application must listen to the message ImageDecodingProgressMsg to check when the validation has been finished. The error code must be checked when the ImageDecodingProgressMsg returns -1 as progress.

void Image::WaitUntilDecodingIsFinished ( ) const [inline]

Obsolete - does the same as Image::StopDecoding. Waiting until the decoding is finished would mean blocking a high priority thread until the low priority thread finished, which is conceptionally flawed.

Friends And Related Function Documentation

friend class CleanupDrawingObtainer [friend]

Field Documentation

const UINT32 Image::c_unlimited = 0xFFFFFFFF [static]

The documentation for this class was generated from the following files:
  • Gui/Image.hpp
  • Gui/Image.cpp
Generated on Wed Jan 25 01:19:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Image::CleanupDrawingObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Image::CleanupDrawingObtainer

Image::CleanupDrawingObtainer Class Reference

#include <Apoxi/Gui/Image.hpp>

Collaboration diagram for Image::CleanupDrawingObtainer:

[legend]

Public Member Functions

BOOLEAN CheckForInterrupt () const
Returns TRUE, if the decoding has been interrupted by a user-interaction.
CleanupDrawingObtainer (const Image &image)
~CleanupDrawingObtainer ()

Detailed Description

Allocated on a stack in the method Draw the CleanupDrawingObtainer assures a consistent state of the image-properties when interrupting the drawing-process by a return-statement.

Constructor & Destructor Documentation

Image::CleanupDrawingObtainer::CleanupDrawingObtainer ( const Image & image )

Image::CleanupDrawingObtainer::~CleanupDrawingObtainer ( )

Member Function Documentation

BOOLEAN Image::CleanupDrawingObtainer::CheckForInterrupt ( ) const

Returns TRUE, if the decoding has been interrupted by a user-interaction.

The documentation for this class was generated from the following files:
  • Gui/Image.hpp
  • Gui/Image.cpp
Generated on Wed Jan 25 01:19:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Image::MetaData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Image::MetaData

Image::MetaData Class Reference

#include <Apoxi/Gui/Image.hpp>

Public Types

enum ColorSpace {
Rgb565ColorSpace, Rgb888ColorSpace, Rgba8888ColorSpace, Yuv420ColorSpace,
Yuv422ColorSpace
}

Public Member Functions

INT8 | GetBitsPerPixel () const
ColorSpace | GetColorSpace () const
INT | GetFrameCount () const
XYDIM | GetHeight () const
INT | GetRepeatCount () const
XYDIM | GetWidth () const
MetaData ()
void | SetBitsPerPixel (INT8 bpp)
void | SetColorSpace (ColorSpace color_space)
void | SetFrameCount (INT frame_count)
void | SetHeight (XYDIM height)
void | SetRepeatCount (INT repeat_count)
void | SetWidth (XYDIM width)
~MetaData ()

Detailed Description

Represents the meta data of an image, which contains basic informations like the width and height of an image.

Member Enumeration Documentation

enum Image::MetaData::ColorSpace

Describes the internally used color space from the image. When drawing the image the used color space will automatically get converted to the color space used by the display.

Enumerator:
Rgb565ColorSpace | 5 bits are used for the red value, 6 bits for the green value and 5 for the blue value.
Rgb888ColorSpace | 8 bits are used for the red, green and blue value.
Rgba8888ColorSpace | 8 bits are used for the red, green, blue and alpha value.
Yuv420ColorSpace
Yuv422ColorSpace

Constructor & Destructor Documentation

Image::MetaData::MetaData ( )

Image::MetaData::~MetaData ( )

Member Function Documentation

INT8 Image::MetaData::GetBitsPerPixel ( ) const [inline]

ColorSpace Image::MetaData::GetColorSpace ( ) const [inline]

INT Image::MetaData::GetFrameCount ( ) const [inline]

XYDIM Image::MetaData::GetHeight ( ) const [inline]

INT Image::MetaData::GetRepeatCount ( ) const [inline]

XYDIM Image::MetaData::GetWidth ( ) const [inline]

void Image::MetaData::SetBitsPerPixel ( INT8 bpp ) [inline]

void Image::MetaData::SetColorSpace ( ColorSpace color_space ) [inline]

void Image::MetaData::SetFrameCount ( INT frame_count ) [inline]

void Image::MetaData::SetHeight ( XYDIM height ) [inline]

void Image::MetaData::SetRepeatCount ( INT repeat_count ) [inline]

void Image::MetaData::SetWidth ( XYDIM width ) [inline]

The documentation for this class was generated from the following files:
  • Gui/Image.hpp
  • Gui/Image.cpp
Generated on Wed Jan 25 01:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBox Class Reference
[Components]

#include <Apoxi/Gui/ImageBox.hpp>

Inheritance diagram for ImageBox:

[legend]
Collaboration diagram for ImageBox:

[legend]

Public Types

enum | { ID = 11 }
typedef Bitmap * | BitmapPtr

Public Member Functions

const BitmapRes * | GetBitmap () const
Deprecated - replaced by ImageBox::GetImageObtainer.
virtual XYDIM | GetDefaultHeight () const
virtual XYDIM | GetDefaultWidth () const
INT | GetFrame () const
Bitmap * | GetImageBuffer (INT frame_idx) const
const ImageObtainer & | GetImageObtainer () const
ImageObtainer & GetImageObtainer ()
DeviceContext::TransformationMode | GetTransformation () const
ImageBox (Control *control, const ImageObtainer &obtainer, XYDIM width=-1, XYDIM height=-1, BOOLEAN autostart=TRUE, BOOLEAN buffering=TRUE, BOOLEAN cleanup_buffer=FALSE)
ImageBox (Control *control, const BitmapRes *bitmap=0)
ImageBox ()
void | Init (Control *control, const ImageObtainer &obtainer, XYDIM width=-1, XYDIM height=-1, BOOLEAN autostart=TRUE, BOOLEAN buffering=TRUE, BOOLEAN cleanup_buffer=FALSE)
void | Init (Control *control, const BitmapRes *bitmap=0, XYDIM width=-1, XYDIM height=-1)
BOOLEAN | IsBufferingEnabled () const
BOOLEAN | IsDecoding () const
BOOLEAN | IsDecodingFinished () const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsPlayOnceEnabled () const
BOOLEAN | IsPreviewShown () const
void | Restart ()
void | SetBitmap (const BitmapRes *bitmap, XYDIM width=-1, XYDIM height=-1)
void | SetBufferingEnabled (BOOLEAN buffering)
void | SetImageObtainer (const ImageObtainer &obtainer, XYDIM width=-1, XYDIM height=-1, BOOLEAN buffering=TRUE)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
BOOLEAN | SetTransformation (DeviceContext::TransformationMode transformation)
void | Start (BOOLEAN play_only_once=FALSE)
void | Stop ()
virtual | ~ImageBox ()

Static Public Member Functions

static BOOLEAN | IsBufferAvailable (XYDIM scaled_width, XYDIM scaled_height, INT frame_count)

Protected Member Functions

virtual void | Cleanup ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnMove (XYDIM dx, XYDIM dy)
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | Refresh (const Rect &rect)

Friends

class | ImageBoxView
class | TriggerTimer< ImageBox >

Detailed Description

Is able to draw any kind of image inside the given boundaries of the drawable object. Per default the image box tries to buffer the image and does the decoding in a separate thread, so that the GUI is never blocked even when decoding large images.

Member Typedef Documentation

typedef Bitmap* ImageBox::BitmapPtr

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

ImageBox::ImageBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ImageBox::ImageBox | ( | Control * | control,
 |  | const BitmapRes * | bitmap = 0
 | ) |

Parameters:
control | Parent control where the ImageBox is embedded.
bitmap | Bitmap which should be drawn. Usually the drawing of a bitmap is faster then drawing an image which might require a complex decoding.

ImageBox::ImageBox | ( | Control * | control,
 |  | const ImageObtainer & | obtainer,
 |  | XYDIM | width = -1,
 |  | XYDIM | height = -1,
 |  | BOOLEAN | autostart = TRUE,
 |  | BOOLEAN | buffering = TRUE,
 |  | BOOLEAN | cleanup_buffer = FALSE
 | ) |

Parameters:
control | Parent control where the ImageBox is embedded.
obtainer | Image obtainer which contains the image. The obtainer will be released in the destructor of the image box. Note that each image box requires to have a custom image object. This means that one image object may not be shared by several image boxes, otherwise the decoding might fail. If the application does not know whether the image is already obtained by another image box, it is recommended to create a custom image object by using BinData::Clone and pass this clone to the ImageFactory for creating a new image instance.
width | User specific width. If -1 is used, the width of the image is used.
height | User specific width. If -1 is used, the width of the image is used.
autostart | If set to FALSE, animations (e. g. a GIF-animation) won't start automatically. In this case ImageBox::Start has to be invoked per hand.
buffering | If set to TRUE (= default value) the image will be decoded once into a buffer, so that it can be drawn in a fast way. The decoding is done in a separate thread, so that the GUI won't be blocked. If set to FALSE, no buffering will be done and the image is decoded on every redraw in the context of the application. This reduces the memory demand but might block the GUI and is a lot slower as when using the buffer. A note to animations having a lot of frames (e. g. a GIF-animation): if the buffering is turned on, APOXI tries to buffer all frames. If this is not possible, at least 2 frame buffers are required to display the animation in a correct manner. If only 2 buffer are available, the current frame has to be decoded each time before drawing, hence the drawing might be slower but it still will be correct. If there is not enough memory for at least 2 buffers and the buffering is turned on, no image will be displayed. Note that turning off the buffering for GIF-images results in drawing only the current frame, which might lead to wrong results when having GIF-animations with transparent colors.
cleanup_buffer | If set to TRUE, the buffer will be freed automatically as soon as the image box boundaries are outside the client area of it's parent control. This parameter is only respected if buffering has been set to TRUE.

ImageBox::~ImageBox ( ) [virtual]

Member Function Documentation

void ImageBox::Cleanup ( ) [protected, virtual]

See also:
Component::Cleanup

Reimplemented from Component.

const BitmapRes* ImageBox::GetBitmap ( ) const [inline]

Deprecated - replaced by ImageBox::GetImageObtainer.

XYDIM ImageBox::GetDefaultHeight ( ) const [virtual]

See also:
AbstractDrawableObject::GetDefaultHeight

Reimplemented from Component.

XYDIM ImageBox::GetDefaultWidth ( ) const [virtual]

See also:
AbstractDrawableObject::GetDefaultWidth

Reimplemented from Component.

INT ImageBox::GetFrame ( ) const [inline]

Returns:
returns the actual displayed frame number.

Bitmap * ImageBox::GetImageBuffer ( INT frame_idx ) const

Allows to get the buffered frame of an image. This might be only useful when the image buffering has been turned on. 0 is returned, if no buffer is available.

Parameters:
frame_idx Index of the desired frame.
Returns:
Buffered Bitmap.

const ImageObtainer& ImageBox::GetImageObtainer ( ) const [inline]

Returns:
Returns the ImageObtainer containing an Image.

ImageObtainer& ImageBox::GetImageObtainer ( ) [inline]

Returns:
Returns the ImageObtainer containing the image.

DeviceContext::TransformationMode ImageBox::GetTransformation ( ) const [inline]

Returns the used transformation mode. See ImageBox::SetTransformation for details.

void ImageBox::Init | ( | Control * | control,
 |  | const ImageObtainer & | obtainer,
 |  | XYDIM | width = -1,
 |  | XYDIM | height = -1,
 |  | BOOLEAN | autostart = TRUE,
 |  | BOOLEAN | buffering = TRUE,
 |  | BOOLEAN | cleanup_buffer = FALSE
 | ) |

Parameters:
control | Parent control where the ImageBox is embedded.
obtainer | Image obtainer which contains the image. The obtainer will be released in the destructor of the image box. Note that each image box requires to have a custom image object. This means that one image object may not be shared by several image boxes, otherwise the decoding might fail. If the application does not know whether the image is already obtained by another image box, it is recommended to create a custom image object by using BinData::Clone and pass this clone to the ImageFactory for creating a new image instance.
width | User specific width. If -1 is used, the width of the image is used.
height | User specific width. If -1 is used, the width of the image is used.
autostart | If set to FALSE, animations (e. g. a GIF-animation) won't start automatically. In this case ImageBox::Start has to be invoked per hand.
buffering | If set to TRUE (= default value) the image will be decoded once into a buffer, so that it can be drawn in a fast way. The decoding is done in a separate thread, so that the GUI won't be blocked. If set to FALSE, no buffering will be done and the image is decoded on every redraw in the context of the application. This reduces the memory demand but might block the GUI and is a lot slower as when using the buffer. A note to animations having a lot of frames (e. g. a GIF-animation): if the buffering is turned on, APOXI tries to buffer all frames. If this is not possible, at least 2 frame buffers are required to display the animation in a correct manner. If only 2 buffer are available, the current frame has to be decoded each time before drawing, hence the drawing might be slower but it still will be correct. If there is not enough memory for at least 2 buffers and the buffering is turned on, no image will be displayed. Note that turning off the buffering for GIF-images results in drawing only the current frame, which might lead to wrong results when having GIF-animations with transparent colors.
cleanup_buffer | If set to TRUE, the buffer will be freed automatically as soon as the image box boundaries are outside the client area of it's parent control. This parameter is only respected if buffering has been set to TRUE.

void ImageBox::Init | ( | Control * | control,
 |  | const BitmapRes * | bitmap = 0,
 |  | XYDIM | width = -1,
 |  | XYDIM | height = -1
 | ) |

Parameters:
control | Parent control where the ImageBox is embedded.
bitmap | Bitmap which should be drawn. Usually the drawing of a bitmap is faster then drawing an image which might require a complex decoding.
width | User specific width. If -1 is used, the width of the image is used.
height | User specific width. If -1 is used, the width of the image is used.

BOOLEAN ImageBox::IsBufferAvailable | ( | XYDIM | scaled_width,
 |  | XYDIM | scaled_height,
 |  | INT | frame_count
 | ) | [static]

Allows to check, if ImageBox is able to buffer a certain Image. Width, height and frame count will be used to determine, if enough memory is available

Parameters:
scaled_width | Desired width of image
scaled_height | Desired height of image
frame_count | Number of frames
Returns:
returns TRUE, if the ImageBox can buffer the desired Image. FALSE if not enough memory is available. In this case, another ImageBox has to release it's buffers to free memory.

BOOLEAN ImageBox::IsBufferingEnabled ( ) const [inline]

Returns TRUE, if the image buffering is enabled. Note that this does not mean, that the current image could be buffered. See ImageBox::GetImageBuffer for details.

BOOLEAN ImageBox::IsDecoding ( ) const [inline]

Returns TRUE, if the image is currently decoded. Usually it is not needed to care about this information. If providing a progress information, the window containing the image box can listen to the message ImageDecodingProgressMsg.

BOOLEAN ImageBox::IsDecodingFinished ( ) const [inline]

Returns TRUE, if the decoding of the image has been finished. Usually it is not needed to care about this information. If providing a progress information, the window containing the image box can listen to the message ImageDecodingProgressMsg.

BOOLEAN ImageBox::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from DrawableObject.

BOOLEAN ImageBox::IsPlayOnceEnabled ( ) const [inline]

Returns TRUE, if an image containing more than one frame should be played only once. Per default FALSE is returned which means that a cyclic animation is done when having images with more than one frame.

See also:
ImageBox::Start

BOOLEAN ImageBox::IsPreviewShown ( ) const [inline]

Returns TRUE, if the preview of the image during decoding is shown. Per default TRUE is returned. When the progress of decoding is 0, FALSE is returned as a preview of an empty image only results in unnecessary flickering.

BOOLEAN ImageBox::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Component::OnMessage

Reimplemented from DrawableObject.

void ImageBox::OnMove | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnMove

Reimplemented from DrawableObject.

void ImageBox::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnResize

Reimplemented from DrawableObject.

void ImageBox::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from Component.

void ImageBox::Restart ( )

Restarts an animation starting with the first frame.

void ImageBox::SetBitmap | ( | const BitmapRes * | bitmap,
 |  | XYDIM | width = -1,
 |  | XYDIM | height = -1
 | ) |

After initializing an ImageBox, the bitmap can be exchanged with SetBitmap. On redraw the new given bitmap will be drawn. If no width or height is given, the Bitmap size will be used.

Parameters:
bitmap | Bitmap which should be drawn.
width | User specific width. If -1 is used, the width of the image is used.
height | User specific width. If -1 is used, the width of the image is used.

void ImageBox::SetBufferingEnabled ( BOOLEAN buffering ) [inline]

Enables the image buffering for the next decoding process.

void ImageBox::SetImageObtainer | ( | const ImageObtainer & | obtainer,
 |  | XYDIM | width = -1,
 |  | XYDIM | height = -1,
 |  | BOOLEAN | buffering = TRUE
 | ) |

After initializing an ImageBox, the image obtainer containing an image can be exchanged.

Parameters:
obtainer | Image obtainer which contains the image. The obtainer will be released in the destructor of the image box. Note that each image box requires to have a custom image object. This means that one image object may not be shared by several image boxes, otherwise the decoding might fail. If the application does not know whether the image is already obtained by another image box, it is recommended to create a custom image object by using BinData::Clone and pass this clone to the ImageFactory for creating a new image instance.
width | User specific width. If -1 is used, the width of the image is used.
height | User specific width. If -1 is used, the width of the image is used.
buffering | If set to TRUE (= default value) the image will be decoded once into a buffer, so that it can be drawn in a fast way. The decoding is done in a separate thread, so that the GUI won't be blocked. If set to FALSE, no buffering will be done and the image is decoded on every redraw in the context of the application. This reduces the memory demand but might block the GUI and is a lot slower as when using the buffer. A note to animations having a lot of frames (e. g. a GIF-animation): if the buffering is turned on, APOXI tries to buffer all frames. If this is not possible, at least 2 frame buffers are required to display the animation in a correct manner. If only 2 buffer are available, the current frame has to be decoded each time before drawing, hence the drawing might be slower but it still will be correct. If there is not enough memory for at least 2 buffers and the buffering is turned on, no image will be displayed. Note that turning off the buffering for GIF-images results in drawing only the current frame, which might lead to wrong results when having GIF-animations with transparent colors.

BOOLEAN ImageBox::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from DrawableObject.

BOOLEAN ImageBox::SetTransformation ( DeviceContext::TransformationMode transformation )

Applies a given transformation on the image. This will only work if buffering is enabled.

Parameters:
transformation Desired transformation, see DeviceContext::TransformationMode for details.
Returns:
FALSE if transformation is not applicable due to missing image buffers.

void ImageBox::Start ( BOOLEAN play_only_once = FALSE )

Starts playback of an animation. If image contains only one frame nothing is done.

Parameters:
play_only_once If set to TRUE the animation will be played only once independant from the repeat count given by the image itself (this might be useful if a GIF animation should be played only once although the repeat count from the image is bigger). If set to FALSE the repeat count from the image is respected.

void ImageBox::Stop ( )

Stops an animation and resets the actual frame to the first frame.

Friends And Related Function Documentation

friend class ImageBoxView [friend]

friend class TriggerTimer< ImageBox > [friend]

The documentation for this class was generated from the following files:
  • Gui/ImageBox.hpp
  • Gui/ImageBox.cpp
Generated on Wed Jan 25 01:20:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBoxView Class Reference
[Components]

#include <Apoxi/Gui/ImageBox.hpp>

Inheritance diagram for ImageBoxView:

[legend]
Collaboration diagram for ImageBoxView:

[legend]

Public Member Functions

virtual ~ImageBoxView ()

Constructor & Destructor Documentation

ImageBoxView::~ImageBoxView ( ) [virtual]

The documentation for this class was generated from the following files:
  • Gui/ImageBox.hpp
  • Gui/ImageBox.cpp
Generated on Wed Jan 25 01:20:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowserApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBrowserApp Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageBrowserApp.hpp>

Collaboration diagram for ImageBrowserApp:

[legend]

Public Member Functions

ServiceResult | GetResourceNames (Vector< Path > &paths, const ImageFilter &image_filter=ImageFilter())
virtual void | OnStartup ()
ServiceResult | SaveImage (const Image *image, const Path &path)
ServiceResult | SaveImage (const BinData *raw_data, const Path &path, DrmMimeType drm_mime_type, MimeType mime_type)
ServiceResult | SelectImage (MediaRefPtr &img_ref, const ImageFilter &img_filter=ImageFilter())
virtual | ~ImageBrowserApp ()
Destructor.

Static Public Member Functions

static ImageBrowserApp * | GetInstance ()

Data Fields

BOOLEAN | m_mirrored
BOOLEAN | m_reversed

Protected Member Functions

virtual DataItem | GetContextDataItem (ContextFeature *feature)
void | OnClose ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
BOOLEAN | OnMessage (const Message &msg)
void | OnOpen ()

Detailed Description

Class ImageBrowserApp implements an image browser.

Constructor & Destructor Documentation

ImageBrowserApp::~ImageBrowserApp ( ) [virtual]

Destructor.

Member Function Documentation

DataItem ImageBrowserApp::GetContextDataItem ( ContextFeature * feature ) [protected, virtual]

static ImageBrowserApp* ImageBrowserApp::GetInstance ( ) [inline, static]

ServiceResult ImageBrowserApp::GetResourceNames | ( | Vector< Path > & | paths,
 |  | const ImageFilter & | image_filter = ImageFilter()
 | ) |

GetResourceNames returns a list of paths for all available images according to the given image filter in img_filter argument. If img_filter argument is a null object, the path of all images should be returned.

Parameters:
paths | The list of paths is returned in paths argument.
img_filter. | The filter that should be applied for the search. If img_filter argument is a null object, the amount of all images should be returned.

void ImageBrowserApp::OnClose ( ) [protected]

BOOLEAN ImageBrowserApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN ImageBrowserApp::OnMessage ( const Message & msg ) [protected]

void ImageBrowserApp::OnOpen ( ) [protected]

void ImageBrowserApp::OnStartup ( ) [virtual]

ServiceResult ImageBrowserApp::SaveImage | ( | const Image * | image,
 |  | const Path & | path
 | ) |

ONLY for EMS images SaveImage stores the image given in image argument at the location given in path argument.

Parameters:
image | Image that should be stored. If image argument is a null object, the invocation should be ignored, but ServResSuccess should be returned. The image stored via this method is not DRM protected.
path | Path for storing location of the image. Modification of the storage location should only be possible, if the path argument is a null object.

ServiceResult ImageBrowserApp::SaveImage | ( | const BinData * | raw_data,
 |  | const Path & | path,
 |  | DrmMimeType | drm_mime_type,
 |  | MimeType | mime_type
 | ) |

SaveImage stores the image given in image argument at the location given in path argument.

Parameters:
image | Image that should be stored. If image argument is a null object, the invocation should be ignored, but ServResSuccess should be returned.
path | Path for storing location of the image. Modification of the storage location should only be possible, if the path argument is a null object. If raw_data is 0, the file given by Path would be saved into ImageBrowser
drm_mime_type | Mime type for Digital Rights Management (DRM) information object for the given image. If DRM Mime type is set to DrmNone, the image is not DRM protected.
mime_type | The Mime type of the image. if the mime type is unknown or invalid, mime type will be map by the extension from the path

ServiceResult ImageBrowserApp::SelectImage | ( | MediaRefPtr & | img_ref,
 |  | const ImageFilter & | img_filter = ImageFilter()
 | ) |

SelectImage presents a list of available images filtered using img_filter argument. If no image is available, an empty list should be presented. If img_filter argument is a null object, the list of images should not be filtered.

Parameters:
img_ref If an image has been selected and the selection has been confirmed, the image is returned in img_ref argument, otherwise img_ref argument is a null object. This Service method is not re-entrant.

Field Documentation

BOOLEAN ImageBrowserApp::m_mirrored

BOOLEAN ImageBrowserApp::m_reversed

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageBrowserApp.hpp
  • Applications/ImageBrowser/ImageBrowserApp.cpp
Generated on Wed Jan 25 01:20:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowserDeleteImageMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBrowserDeleteImageMsg Class Reference

#include <Applications/ImageBrowser/ImageBrowserMsgTypes.hpp>

Inheritance diagram for ImageBrowserDeleteImageMsg:

[legend]
Collaboration diagram for ImageBrowserDeleteImageMsg:

[legend]

Public Types

enum | { ID = 21352 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
ImageBrowserDeleteImageMsg ()
virtual | ~ImageBrowserDeleteImageMsg ()

Detailed Description

Message indicating image deleted from imagebrowser.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImageBrowserDeleteImageMsg::ImageBrowserDeleteImageMsg ( )

ImageBrowserDeleteImageMsg::~ImageBrowserDeleteImageMsg ( ) [virtual]

Member Function Documentation

Message * ImageBrowserDeleteImageMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ImageBrowserDeleteImageMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageBrowserMsgTypes.hpp
  • Applications/ImageBrowser/ImageBrowserMsgTypes.cpp
Generated on Wed Jan 25 01:20:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowserDetailWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBrowserDetailWin Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageBrowserDetailWin.hpp>

Inheritance diagram for ImageBrowserDetailWin:

[legend]
Collaboration diagram for ImageBrowserDetailWin:

[legend]

Public Member Functions

ImageBrowserDetailWin ()
void | Init (Image *image)
BOOLEAN | SetTransformation (DeviceContext::TransformationMode transformation)
void | StartStop (BOOLEAN start)
virtual | ~ImageBrowserDetailWin ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual void | OnClose ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
virtual void | OnOpen ()
void | RepositionImage ()

Detailed Description

Window for displaying in full size the image selected in the ImageBrowser Application.

Constructor & Destructor Documentation

ImageBrowserDetailWin::ImageBrowserDetailWin ( )

ImageBrowserDetailWin::~ImageBrowserDetailWin ( ) [virtual]

Member Function Documentation

void ImageBrowserDetailWin::Init ( Image * image )

Initializes the window with the pointer of the image to display created by the ImageBrowserApp

BOOLEAN ImageBrowserDetailWin::OnCancel ( ) [protected, virtual]

See also:
Window::OnCancel

Reimplemented from AtlWindow.

void ImageBrowserDetailWin::OnClose ( ) [protected, virtual]

See also:
Window::OnClose

Reimplemented from Window.

BOOLEAN ImageBrowserDetailWin::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Window::OnKeyDown

Reimplemented from AtlWindow.

void ImageBrowserDetailWin::OnLayoutClient ( ) [protected, virtual]

See also:
Window::OnLayoutClient

Reimplemented from Window.

void ImageBrowserDetailWin::OnOpen ( ) [protected, virtual]

See also:
Window::OnOpen

Reimplemented from AtlWindow.

void ImageBrowserDetailWin::RepositionImage ( ) [protected]

Initializes the window with the pointer of the image to display created by the ImageBrowserApp

BOOLEAN ImageBrowserDetailWin::SetTransformation ( DeviceContext::TransformationMode transformation )

For Mirror and Reverse of an image or animation.

void ImageBrowserDetailWin::StartStop ( BOOLEAN start )

Starts and stops the animation.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageBrowserDetailWin.hpp
  • Applications/ImageBrowser/ImageBrowserDetailWin.cpp
Generated on Wed Jan 25 01:20:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowserRenameImageMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBrowserRenameImageMsg Class Reference

#include <Applications/ImageBrowser/ImageBrowserMsgTypes.hpp>

Inheritance diagram for ImageBrowserRenameImageMsg:

[legend]
Collaboration diagram for ImageBrowserRenameImageMsg:

[legend]

Public Types

enum | { ID = 21353 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetNewName () const
ImageBrowserRenameImageMsg (const WString &new_name)
virtual | ~ImageBrowserRenameImageMsg ()

Detailed Description

Message indicating image is renamed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImageBrowserRenameImageMsg::ImageBrowserRenameImageMsg ( const WString & new_name )

ImageBrowserRenameImageMsg::~ImageBrowserRenameImageMsg ( ) [virtual]

Member Function Documentation

Message * ImageBrowserRenameImageMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ImageBrowserRenameImageMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& ImageBrowserRenameImageMsg::GetNewName ( ) const [inline]

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageBrowserMsgTypes.hpp
  • Applications/ImageBrowser/ImageBrowserMsgTypes.cpp
Generated on Wed Jan 25 01:20:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowserServiceMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBrowserServiceMsg Class Reference

#include <Applications/ImageBrowser/ImageBrowserMsgTypes.hpp>

Inheritance diagram for ImageBrowserServiceMsg:

[legend]
Collaboration diagram for ImageBrowserServiceMsg:

[legend]

Public Types

enum | { ID = 21354 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
ImageBrowserServiceMsg (ExecutionContext *context)
virtual | ~ImageBrowserServiceMsg ()

Detailed Description

ImageBrowserServiceMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImageBrowserServiceMsg::ImageBrowserServiceMsg ( ExecutionContext * context )

ImageBrowserServiceMsg::~ImageBrowserServiceMsg ( ) [virtual]

Member Function Documentation

Message * ImageBrowserServiceMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ImageBrowserServiceMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageBrowserMsgTypes.hpp
  • Applications/ImageBrowser/ImageBrowserMsgTypes.cpp
Generated on Wed Jan 25 01:20:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowserTestWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBrowserTestWin Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageBrowserTestWin.hpp>

Collaboration diagram for ImageBrowserTestWin:

[legend]

Public Member Functions

ImageBrowserTestWin ()
void | Init ()
virtual | ~ImageBrowserTestWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual BOOLEAN | OnCancel ()
virtual void | OnLayoutClient ()

Constructor & Destructor Documentation

ImageBrowserTestWin::ImageBrowserTestWin ( )

ImageBrowserTestWin::~ImageBrowserTestWin ( ) [virtual]

Member Function Documentation

void ImageBrowserTestWin::Init ( )

void ImageBrowserTestWin::OnActionExecuted ( Action * action ) [protected, virtual]

BOOLEAN ImageBrowserTestWin::OnCancel ( ) [protected, virtual]

void ImageBrowserTestWin::OnLayoutClient ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageBrowserTestWin.hpp
  • Applications/ImageBrowser/ImageBrowserTestWin.cpp
Generated on Wed Jan 25 01:20:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowserWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageBrowserWin Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageBrowserWin.hpp>

Collaboration diagram for ImageBrowserWin:

[legend]

Public Member Functions

MediaRefPtr & GetSelectedImageRef ()
BOOLEAN | GetSuccess () const
ImageBrowserWin ()
void | Init (BooleanCondition &condition, ImageRefContainer &img_refs)
BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
BOOLEAN | SetImageFilter (const ImageFilter &img_filter, BOOLEAN show_select_button)
virtual | ~ImageBrowserWin ()

Protected Member Functions

BOOLEAN | OnCancel ()
void | OnClose ()
BOOLEAN | OnConfirm ()
BOOLEAN | OnKeyDown (KeyCode key_code)
void | OnLayoutClient ()
void | OnOpen ()

Detailed Description

Main window for the image browser application. It provides a menu for calling different operations on the images stored like renaming, deleting, or loading.

Constructor & Destructor Documentation

ImageBrowserWin::ImageBrowserWin ( )

ImageBrowserWin::~ImageBrowserWin ( ) [virtual]

Member Function Documentation

MediaRefPtr & ImageBrowserWin::GetSelectedImageRef ( )

Returns the ImageRef object that has been selected by the ImageBrowser.

BOOLEAN ImageBrowserWin::GetSuccess ( ) const

Returns if the selection was successful and confirmed or if cancel has been pressed.

void ImageBrowserWin::Init | ( | BooleanCondition & | condition,
 |  | ImageRefContainer & | img_refs
 | ) |

Initializes the window with a condition and an ImageRefContainer which has to be created by the ImageBrowserApp.

BOOLEAN ImageBrowserWin::OnCancel ( ) [protected]

void ImageBrowserWin::OnClose ( ) [protected]

BOOLEAN ImageBrowserWin::OnConfirm ( ) [protected]

BOOLEAN ImageBrowserWin::OnFeatureTriggered ( const FeatureID & feature_id )

BOOLEAN ImageBrowserWin::OnKeyDown ( KeyCode key_code ) [protected]

void ImageBrowserWin::OnLayoutClient ( ) [protected]

void ImageBrowserWin::OnOpen ( ) [protected]

BOOLEAN ImageBrowserWin::SetImageFilter | ( | const ImageFilter & | img_filter,
 |  | BOOLEAN | show_select_button
 | ) |

Sets the ImageFilter and reloads the entries of the ImageRefContainer by applying the image filter to every image.

Parameters:
img_filter | ImageFilter to apply.
show_select_button | Defines if the select_button should be shown after the image_filter has been applied to the entries.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageBrowserWin.hpp
  • Applications/ImageBrowser/ImageBrowserWin.cpp
Generated on Wed Jan 25 01:20:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageDecoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageDecoder Class Reference
[GUI]

#include <Apoxi/Gui/ImageDecoder.hpp>

Collaboration diagram for ImageDecoder:

[legend]

Public Member Functions

virtual BOOLEAN | BeginDecoding (const Image &image, INT frame_idx=0)
virtual void | EndDecoding (const Image &image, INT frame_idx=0)
virtual BOOLEAN | GetMetaData (Image &image, Image::MetaData *meta_data)=0
ImageDecoder (BOOLEAN shared=TRUE, const Ticks &timeout=Ticks(200))
virtual | ~ImageDecoder ()

Detailed Description

Base class for image decoders, which are usually implemented as singleton. When starting the decoding, the data is protected by a semaphore automatically.

Constructor & Destructor Documentation

ImageDecoder::ImageDecoder | ( | BOOLEAN | shared = TRUE,
 |  | const Ticks & | timeout = Ticks(200)
 | ) |

Parameters:
shared | If set to TRUE, the decoder is shared by several instances of an image. In this case ImageDecoder::BeginDecoding obtains the decoder with the given timeout. If set to FALSE each instance of an image owns an own instance of an image decoder and hence no obtaining is required.
timeout | Timeout in milliseconds when trying to obtain the image decoder. The parameter is only respected if shared is set to TRUE. Note that when using Ticks::Infinite() the decoder should assure a very small decoding time.

ImageDecoder::~ImageDecoder ( ) [virtual]

Member Function Documentation

BOOLEAN ImageDecoder::BeginDecoding | ( | const Image & | image,
 |  | INT | frame_idx = 0
 | ) | [virtual]

Usually this method is invoked inside Image::BeginScanlineDrawing and indicates, that the decoding process will be started. Hence all initializations for the decoder should be implemented by overwriting this method. If the image decoder is shared, the base implementation obtains a semaphore with the given timeout to have unique access to the data of the class. TRUE is returned, if the obtaining has been successful. Have a look at the constructor how to initialize the shared- and timeout-property.

void ImageDecoder::EndDecoding | ( | const Image & | image,
 |  | INT | frame_idx = 0
 | ) | [virtual]

Usually this method is invoked inside Image::EndScanlineDrawing and indicates, that the decoding-process is finished. Hence freeing all needed resources for the decoder should be implemented by overwriting this method. The base-implementation releases the semaphore which has been obtained by invoking BeginDecoding.

virtual BOOLEAN ImageDecoder::GetMetaData | ( | Image & | image,
 |  | Image::MetaData * | meta_data
 | ) | [pure virtual]

Returns the meta-data of an image into the output-parameter meta_data. Some image-decoders might require to start the decoding to get the image data. In this case don't forget to invoke the methods ImageDecoder::BeginDecoding and ImageDecoder::EndDecoding.

The documentation for this class was generated from the following files:
  • Gui/ImageDecoder.hpp
  • Gui/ImageDecoder.cpp
Generated on Wed Jan 25 01:20:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageDecodingProgressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageDecodingProgressMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for ImageDecodingProgressMsg:

[legend]
Collaboration diagram for ImageDecodingProgressMsg:

[legend]

Public Types

enum | { ID = 1120 }

Public Member Functions

virtual Message * | Clone () const
const Image * | GetImage () const
virtual const MsgMetaData & | GetMetaData () const
INT | GetProgress () const
ImageDecodingProgressMsg (const Image *image, INT progress)
virtual | ~ImageDecodingProgressMsg ()

Detailed Description

This message is broadcasted, if an image is decoded by invoking Image::ConvertToBitmap to indicate the current progress. The decoding is finished, if the progress reached the value 100.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImageDecodingProgressMsg::ImageDecodingProgressMsg | ( | const Image * | image,
 |  | INT | progress
 | ) |

ImageDecodingProgressMsg::~ImageDecodingProgressMsg ( ) [virtual]

Member Function Documentation

Message * ImageDecodingProgressMsg::Clone ( ) const [virtual]

Implements Message.

const Image* ImageDecodingProgressMsg::GetImage ( ) const [inline]

const MsgMetaData & ImageDecodingProgressMsg::GetMetaData ( ) const [virtual]

Implements Message.

INT ImageDecodingProgressMsg::GetProgress ( ) const [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:20:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageDrawingInterruptedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageDrawingInterruptedMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for ImageDrawingInterruptedMsg:

[legend]
Collaboration diagram for ImageDrawingInterruptedMsg:

[legend]

Public Types

enum | { ID = 1126 }

Public Member Functions

virtual Message * | Clone () const
Image * | GetImage () const
virtual const MsgMetaData & | GetMetaData () const
ImageDrawingInterruptedMsg (ExecutionContext *context, Image *image)
virtual | ~ImageDrawingInterruptedMsg ()

Detailed Description

This message is send, when a user-input like a key-press has been done during the decoding of a large image. See description of the class Image for further details.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImageDrawingInterruptedMsg::ImageDrawingInterruptedMsg | ( | ExecutionContext * | context,
 |  | Image * | image
 | ) |

ImageDrawingInterruptedMsg::~ImageDrawingInterruptedMsg ( ) [virtual]

Member Function Documentation

Message * ImageDrawingInterruptedMsg::Clone ( ) const [virtual]

Implements Message.

Image* ImageDrawingInterruptedMsg::GetImage ( ) const [inline]

const MsgMetaData & ImageDrawingInterruptedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:20:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageEncoder Class Reference
[GUI]

#include <Apoxi/Gui/ImageEncoder.hpp>

Inheritance diagram for ImageEncoder:

[legend]
Collaboration diagram for ImageEncoder:

[legend]

Public Types

typedef void(* | Cb_ImageEncoded )(INT result, void *context, DataSink &dest)
enum Error {
NoError, EncoderInitError, FormatNotSupportedError, OutOfMemoryError,
EncodingError, DataSinkClosedError, CouldNotAllocateThreadletError
}

Public Member Functions

virtual BOOLEAN | Encode (const Image &src, DataSink &dest, BOOLEAN block=TRUE)=0
virtual BOOLEAN | Encode (BinData &src, const Image::MetaData &src_params, DataSink &dest, BOOLEAN block=TRUE, void *context=0, Cb_ImageEncoded callback=0)=0
const EncodingParameters * | GetEncodingParams () const
Error | GetLastError () const
ImageEncoder ()
BOOLEAN | IsEncoding () const
void | StopEncoding (BOOLEAN block=TRUE)
virtual | ~ImageEncoder ()

Protected Member Functions

virtual BOOLEAN | BeginEncoding (DataSink &dest)
virtual BOOLEAN | EncodeSynchronously (const Image &img, DataSink &dest)
virtual BOOLEAN | EncodeSynchronously (BinData &src, const Image::MetaData &src_params, DataSink &dest)
virtual BOOLEAN | EndEncoding (DataSink &dest)
BOOLEAN | ExecuteThreadlet (Threadlet *threadlet, BOOLEAN block)
BOOLEAN | IsStopEncodingRequested () const
void | SetEncodingParams (const EncodingParameters *params)
void | SetLastError (Error error)

Friends

class | EncodingThreadlet

Data Structures

class | EncodingParameters

Detailed Description

Base class for image-encoders, which are implemented as singleton. When starting the encoding, the data is protected by a semaphore automatically.

Member Typedef Documentation

typedef void(* ImageEncoder::Cb_ImageEncoded)(INT result, void *context, DataSink &dest)

Member Enumeration Documentation

enum ImageEncoder::Error

Error code which can be retrieved by invoking ImageEncoder::GetLastError.

Enumerator:
NoError | No error has occured.
EncoderInitError | An error has occured during the initialization of the encoder.
FormatNotSupportedError | The format of the source data is not supported.
OutOfMemoryError | Not enough memory is available for doing the encoding.
EncodingError | An error occured during encoding the image.
DataSinkClosedError | The data sink, where the image should be encoded into, has been closed from outside, so that no encoding is possible anymore.
CouldNotAllocateThreadletError | The threadlet could not be allocated, which is required to encode the image asynchronously.

Constructor & Destructor Documentation

ImageEncoder::ImageEncoder ( )

ImageEncoder::~ImageEncoder ( ) [virtual]

Member Function Documentation

BOOLEAN ImageEncoder::BeginEncoding ( DataSink & dest ) [protected, virtual]

BeginEncoding has to be called when starting the encoding. Locks the encoder for exclusive usage.

Reimplemented in JpegEncoder, and PngEncoder.

virtual BOOLEAN ImageEncoder::Encode | ( | const Image & | src,
 |  | DataSink & | dest,
 |  | BOOLEAN | block = TRUE
 | ) | [pure virtual]

Encodes an given image to the specified destination. The image size will be scaled to the size of the encoding parameters. It is recommended that the implementation creates it's decoding threadlet and invokes the protected method ImageEncoder::ExecuteThreadlet.

Parameters:
src | Source image which should be converted.
dest | Destination of the encoded image. The data sink must be already open, otherwise the method Encode will return FALSE. The closing of the data sink must be done manually by the the instance which opened the data sink first.
block | If set to TRUE the encoding is done synchronously, which means that the thread is blocked until the converting has been finished. This is only recommended for encoding small images. When set to FALSE, the converting is done by the worker-thread and the message ImageEncodingProgressMsg including the progress-value is posted frequently, until the converting has been finished. Note that the passed image and the data sink may not be deleted during the asynchronous encoding.
Returns:
Returns TRUE, if the encoding was successfully.

Implemented in JpegEncoder, and PngEncoder.

virtual BOOLEAN ImageEncoder::Encode | ( | BinData & | src,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest,
 |  | BOOLEAN | block = TRUE,
 |  | void * | context = 0,
 |  | Cb_ImageEncoded | callback = 0
 | ) | [pure virtual]

Encodes image data from the given source with the given encoding parameters to the destination represented by a data sink. The size given in src_params will be used for encoding and the size given by the encoding parameters will be ignored. It is recommended that the implementation creates it's decoding threadlet and invokes the protected method ImageEncoder::ExecuteThreadlet.

Parameters:
src | Source of the image data. Note that the BinData object is obtained now by the encoder and hence automatically released when the decoding has been finished. After passing the BinData object to the encoder it is not allowed to invoke the method BinData::ReleaseInstance.
src_params | Parameters which describes the source image data.
dest | Destination of the encoded image. The data sink must be already open, otherwise the method Encode will return FALSE. The closing of the data sink must be done manually by the the instance which opened the data sink first.
block | If set to TRUE the encoding is done synchronously, which means that the thread is blocked until the converting has been finished. This is only recommended for encoding small images. When set to FALSE, the converting is done by the worker-thread and the message ImageEncodingProgressMsg including the progress-value is posted frequently, until the converting has been finished. Note that the passed bin data object, the meta data and the data sink may not be deleted during the asynchronous encoding.
context | Pointer to any data which the application may pass through the callback. In most cases this is the callers application "this" pointer.
callback | Application's callback, which is called when image has been encoded. Parameter block must be set to FALSE in order to use the callback! Callback will be sent even if image encoding was cancelled or broken.
Returns:
Returns TRUE, if the encoding was successfully.

BOOLEAN ImageEncoder::EncodeSynchronously | ( | const Image & | img,
 |  | DataSink & | dest
 | ) | [protected, virtual]

Encodes an given image to the specified destination. The default implementation returns FALSE and should be reimplemented by derived image encoders. The image size will be scaled to the size of the encoding parameters. This method is used by the default implementation of EncodingThreadlet to encode the image synchronously in the context of the threadlet.

Parameters:
dest | Destination of the encoded image. The data sink must be already open, otherwise the method Encode will return FALSE. The closing of the data sink must be done manually by the the instance which opened the data sink first.
block | If set to TRUE the encoding is done synchronously, which means that the thread is blocked until the converting has been finished. This is only recommended for encoding small images. When set to FALSE, the converting is done by the worker-thread and the message ImageEncodingProgressMsg including the progress-value is posted frequently, until the converting has been finished. Note that the passed image and the data sink may not be deleted during the asynchronous encoding.
Returns:
Returns TRUE, if the encoding was successfully.

Reimplemented in JpegEncoder, and PngEncoder.

BOOLEAN ImageEncoder::EncodeSynchronously | ( | BinData & | src,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest
 | ) | [protected, virtual]

Encodes image data from the given source with the given encoding parameters to the destination represented by a data sink. The default implementation returns FALSE and should be reimplemented by derived image encoders. The size given in src_params will be used for encoding and the size given by the encoding parameters will be ignored. This method is used by the default implementation of EncodingThreadlet to encode the image synchronously in the context of the threadlet.

Parameters:
src | Source of the image data. Note that the BinData object is obtained now by the encoder and hence automatically released when the decoding has been finished. After passing the BinData object to the encoder it is not allowed to invoke the method BinData::ReleaseInstance.
src_params | Parameters which describes the source image data.
dest | Destination of the encoded image. The data sink must be already open, otherwise the method Encode will return FALSE. The closing of the data sink must be done manually by the the instance which opened the data sink first.
Returns:
Returns TRUE, if the encoding was successfully.

Reimplemented in JpegEncoder, and PngEncoder.

BOOLEAN ImageEncoder::EndEncoding ( DataSink & dest ) [protected, virtual]

EndEncoding has to be called when finished encoding and unlocks the encoder.

Reimplemented in JpegEncoder, and PngEncoder.

BOOLEAN ImageEncoder::ExecuteThreadlet | ( | Threadlet * | threadlet,
 |  | BOOLEAN | block
 | ) | [protected]

Executes the given threadlet threadlet in the corresponding blocking mode. It is recommended that the implementations of the method ImageEncoder::Encode create an instance of a threadlet and invoke this method for execution. If threadlet is 0 a corresponding error code is set automatically, which can be retrieved by ImageEncoder::GetLastError.

const EncodingParameters* ImageEncoder::GetEncodingParams ( ) const [inline]

GetEncodingParams returns the used encoding parameters. Has to be casted to the used specific decoder, e.g. JpegEncoder: (JpegEncoder::EncodingParameters*)enc->GetEncodingParams();

Returns:
returns the given EncodingParameters, and can be changed

Error ImageEncoder::GetLastError ( ) const [inline]

Retrieves the last error

BOOLEAN ImageEncoder::IsEncoding ( ) const [inline]

Returns TRUE, if the image is encoded currently. Invoking this method is only useful, if an asynchronous encoding is done.

BOOLEAN ImageEncoder::IsStopEncodingRequested ( ) const [inline, protected]

Returns TRUE, if the encoding should be stopped. Requesting this information is only necessary when derived classes implement asynchronous encoding by threadlets.

See also:
ImageEncoder::MarkEncodingFinished

void ImageEncoder::SetEncodingParams ( const EncodingParameters * params ) [inline, protected]

Sets the encoding parameters for encoding.

void ImageEncoder::SetLastError ( Error error ) [inline, protected]

Sets the error code which can be retrieved by ImageEncoder::GetLastError from outside.

void ImageEncoder::StopEncoding ( BOOLEAN block = TRUE )

Stops the encoding. Invoking this method is only useful, if an asynchronous encoding is done.

Parameters:
block = TRUE

Friends And Related Function Documentation

friend class EncodingThreadlet [friend]

The documentation for this class was generated from the following files:
  • Gui/ImageEncoder.hpp
  • Gui/ImageEncoder.cpp
Generated on Wed Jan 25 01:20:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageEncoder::EncodingParameters Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ImageEncoder::EncodingParameters

ImageEncoder::EncodingParameters Class Reference

#include <Apoxi/Gui/ImageEncoder.hpp>

Inheritance diagram for ImageEncoder::EncodingParameters:

[legend]

Public Member Functions

EncodingParameters (XYDIM width, XYDIM height)
XYDIM | GetHeight () const
XYDIM | GetWidth () const
void | SetHeight (XYDIM height)
void | SetWidth (XYDIM width)

Detailed Description

Describes the encoding parameters for the size. Usually derived image encoders extend the encoding parameters to their needs.

Constructor & Destructor Documentation

ImageEncoder::EncodingParameters::EncodingParameters | ( | XYDIM | width,
 |  | XYDIM | height
 | ) | [inline]

Reimplemented in PngEncoder::EncodingParameters.

Member Function Documentation

XYDIM ImageEncoder::EncodingParameters::GetHeight ( ) const [inline]

XYDIM ImageEncoder::EncodingParameters::GetWidth ( ) const [inline]

void ImageEncoder::EncodingParameters::SetHeight ( XYDIM height ) [inline]

void ImageEncoder::EncodingParameters::SetWidth ( XYDIM width ) [inline]

The documentation for this class was generated from the following file:
  • Gui/ImageEncoder.hpp
Generated on Wed Jan 25 01:20:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageEncodingProgressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageEncodingProgressMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for ImageEncodingProgressMsg:

[legend]
Collaboration diagram for ImageEncodingProgressMsg:

[legend]

Public Types

enum | { ID = 1128 }

Public Member Functions

virtual Message * | Clone () const
const ImageEncoder & | GetEncoder () const
virtual const MsgMetaData & | GetMetaData () const
INT | GetProgress () const
ImageEncodingProgressMsg (const ImageEncoder &encoder, INT progress)
virtual | ~ImageEncodingProgressMsg ()

Detailed Description

This message is broadcasted, if an image is encoded asynchronously by ImageEncoder::Decode.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImageEncodingProgressMsg::ImageEncodingProgressMsg | ( | const ImageEncoder & | encoder,
 |  | INT | progress
 | ) |

ImageEncodingProgressMsg::~ImageEncodingProgressMsg ( ) [virtual]

Member Function Documentation

Message * ImageEncodingProgressMsg::Clone ( ) const [virtual]

Implements Message.

const ImageEncoder& ImageEncodingProgressMsg::GetEncoder ( ) const [inline]

const MsgMetaData & ImageEncodingProgressMsg::GetMetaData ( ) const [virtual]

Implements Message.

INT ImageEncodingProgressMsg::GetProgress ( ) const [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:20:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageFactory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageFactory Class Reference
[GUI]

#include <Apoxi/AddOns/MultiMedia/ImageFactory.hpp>

Static Public Member Functions

static Image * | CreateImage (BinData *data, BOOLEAN *success=0)
static void | DestroyImage (Image *image)
static INT | GetImageId (const BinData &data)

Detailed Description

ImageFactory deleviers an image object or an image ID from a given binary data stream.

Member Function Documentation

Image * ImageFactory::CreateImage | ( | BinData * | data,
 |  | BOOLEAN * | success = 0
 | ) | [static]

Creates the correct image object from a given binary data stream. The image object will obtain the bin data object and release when deleting the image object.

Parameters:
data | Binary data stream which contains the image data.
success | Optional output parameter, which is TRUE if the image object is valid

void ImageFactory::DestroyImage ( Image * image ) [static]

Deprecated - the method ImageFactory::CreateImage always uses 'new' for creating an instance, hence the instance can be deleted by invoking 'delete'. It is recommended to use an ImageObtainer as encapsulation for an image, as the image-obtainer automatically takes care about deleting the image if no applications refer to the image anymore.

INT ImageFactory::GetImageId ( const BinData & data ) [static]

Returns the image ID of the binary data stream. The bin data object is not obtained by the image factory and hence not released. It just acts as input parameter.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/ImageFactory.hpp
  • AddOns/MultiMedia/ImageFactory.cpp
Generated on Wed Jan 25 01:20:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageFileFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageFileFilter Class Reference
[Root File System]

File filter filtering image files More...

#include <Apoxi/Afs/Rfs/FileFilter.hpp>

Inheritance diagram for ImageFileFilter:

[legend]
Collaboration diagram for ImageFileFilter:

[legend]

Public Member Functions

virtual BOOLEAN | Complies (const Path &path)
ImageFileFilter (BOOLEAN filter_dirs=FALSE)

Protected Member Functions

virtual | ~ImageFileFilter ()
Destroys an image file filter.

Protected Attributes

BOOLEAN | m_filter_dirs
Tells if directories shall be filtered.

Detailed Description

File filter filtering image files

Class ImageFileFilter is a predefined file filter functor which filters image files. These are actually jpeg, gif, png, tiff, wbmp, bmp, ems, svg, and svgz files. Optionally directories get filtered, too.

Constructor & Destructor Documentation

ImageFileFilter::ImageFileFilter ( BOOLEAN filter_dirs = FALSE )

Constructs an image file filter. If filter_dirs is TRUE then all directories get filtered, too.

Parameters:
filter_dirs Tells if directories shall be filtered.

ImageFileFilter::~ImageFileFilter ( ) [protected, virtual]

Destroys an image file filter.

Member Function Documentation

BOOLEAN ImageFileFilter::Complies ( const Path & path ) [virtual]

Tells if the file with path is an image file of type jpeg, gif, png, tiff, wbmp, bmp, ems, svg, or svgz or is a directory in case it shall filter directories, too.

Implements FileFilter.

Field Documentation

BOOLEAN ImageFileFilter::m_filter_dirs [protected]

Tells if directories shall be filtered.

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileFilter.hpp
  • Afs/Rfs/FileFilter.cpp
Generated on Wed Jan 25 01:20:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageFilter Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

Base class for filters concerning image references. More...

#include <Applications/ImageBrowser/Common/MediaFilter.hpp>

Inheritance diagram for ImageFilter:

[legend]
Collaboration diagram for ImageFilter:

[legend]

Public Member Functions

ImageFilter ()
ImageFilter ()
virtual BOOLEAN | IsAllowed (const MediaRef &media_ref) const
virtual BOOLEAN | IsAllowed (const MediaRef &media_ref) const
virtual | ~ImageFilter ()
virtual | ~ImageFilter ()

Detailed Description

Base class for filters concerning image references.

Constructor & Destructor Documentation

ImageFilter::ImageFilter ( )

ImageFilter::~ImageFilter ( ) [virtual]

ImageFilter::ImageFilter ( )

virtual ImageFilter::~ImageFilter ( ) [virtual]

Member Function Documentation

virtual BOOLEAN ImageFilter::IsAllowed ( const MediaRef & media_ref ) const [virtual]

See also:
MediaFilter::IsAllowed()

Reimplemented from MediaFilter.

BOOLEAN ImageFilter::IsAllowed ( const MediaRef & media_ref ) const [virtual]

See also:
MediaFilter::IsAllowed()

Reimplemented from MediaFilter.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaFilter.hpp
  • Applications/SoundBrowser/Common/MediaFilter.hpp
  • Applications/ImageBrowser/Common/MediaFilter.cpp
  • Applications/SoundBrowser/Common/MediaFilter.cpp
Generated on Wed Jan 25 01:20:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageIncrementalPdcUpdater Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageIncrementalPdcUpdater Class Reference
[GUI]

#include <Apoxi/Gui/Image.hpp>

Inheritance diagram for ImageIncrementalPdcUpdater:

[legend]
Collaboration diagram for ImageIncrementalPdcUpdater:

[legend]

Public Member Functions

ImageIncrementalPdcUpdater (const void *client, PaintDc &pdc, INT max_delay=500)
virtual void | SendInterruptedMsg () const
virtual void | SendProgressMsg (INT total_steps, INT completed_steps) const
virtual | ~ImageIncrementalPdcUpdater ()

Detailed Description

Incremental device context updater used by class Image.

Constructor & Destructor Documentation

ImageIncrementalPdcUpdater::ImageIncrementalPdcUpdater | ( | const void * | client,
 |  | PaintDc & | pdc,
 |  | INT | max_delay = 500
 | ) |

If OptionalConfig defines MaxDecoderDelay then this will be used instead of max_delay as maximal delay between two updates.

See also:
IncrementalPdcUpdater::IncrementalPdcUpdater

ImageIncrementalPdcUpdater::~ImageIncrementalPdcUpdater ( ) [virtual]

Member Function Documentation

void ImageIncrementalPdcUpdater::SendInterruptedMsg ( ) const [virtual]

See also:
IncrementalPdcUpdater::SendInterruptedMsg

Implements IncrementalPdcUpdater.

void ImageIncrementalPdcUpdater::SendProgressMsg | ( | INT | total_steps,
 |  | INT | completed_steps
 | ) | const [virtual]

See also:
IncrementalPdcUpdater::SendProgressMsg

Implements IncrementalPdcUpdater.

The documentation for this class was generated from the following files:
  • Gui/Image.hpp
  • Gui/Image.cpp
Generated on Wed Jan 25 01:20:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageItem Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/ImageItem.hpp>

Inheritance diagram for ImageItem:

[legend]
Collaboration diagram for ImageItem:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

virtual AtomItem * | Clone () const
virtual void | Draw (DeviceContext *dc, const Rect &bounds) const
virtual XYDIM | GetHeight () const
virtual INT | GetId () const
const Image * | GetImage () const
Wrapper method for ImageItem::GetImageObtainer().GetImage().
const ImageObtainer & | GetImageObtainer () const
Returns the embedded image obtainer.
virtual XYDIM | GetWidth () const
ImageItem (const ImageObtainer &obtainer)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual | ~ImageItem ()

Detailed Description

Represents a bounded item which can get an image as input. When adding the ImageItem to the editor document, a clone of the ImageItem will be made so that the original ImageItem can be deleted at any time.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BoundedItem.

Constructor & Destructor Documentation

ImageItem::ImageItem ( const ImageObtainer & obtainer ) [explicit]

Parameters:
obtainer Image obtainer which contains the image. A copy of the obtainer is kept inside the ImageItem, which means that the passed obtainer can be deleted at any time.

ImageItem::~ImageItem ( ) [virtual]

Member Function Documentation

AtomItem * ImageItem::Clone ( ) const [virtual]

Returns a pointer to a flat copy of this object, hence the cloned object and the original object are pointing to the same image.

See also:
AtomItem::Clone();

Implements AtomItem.

void ImageItem::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AtomItem::Draw

Implements AtomItem.

XYDIM ImageItem::GetHeight ( ) const [virtual]

See also:
BoundedItem::GetHeight

Implements BoundedItem.

INT ImageItem::GetId ( ) const [virtual]

See also:
AtomItem::GetId()

Reimplemented from BoundedItem.

const Image* ImageItem::GetImage ( ) const [inline]

Wrapper method for ImageItem::GetImageObtainer().GetImage().

const ImageObtainer& ImageItem::GetImageObtainer ( ) const [inline]

Returns the embedded image obtainer.

XYDIM ImageItem::GetWidth ( ) const [virtual]

See also:
BoundedItem::GetWidth

Implements BoundedItem.

BOOLEAN ImageItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from BoundedItem.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/ImageItem.hpp
  • AddOns/MultiMedia/ImageItem.cpp
Generated on Wed Jan 25 01:20:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageListBoxModel Class Reference
[ImageBrowser]

Base class of a model for showing images. More...

#include <Applications/ImageBrowser/ImageListBoxModel.hpp>

Inheritance diagram for ImageListBoxModel:

[legend]
Collaboration diagram for ImageListBoxModel:

[legend]

Public Member Functions

virtual void | AdjustThemeDependencies ()
virtual DrawableObject * | GetItem (INT index, BOOLEAN highlighted)
virtual DrawableObjectView * | GetRenderingView (INT index, BOOLEAN highlighted)
ImageListBoxModel (DrawableObjectListBox *control)
ImageListBoxModel ()
void | Init (DrawableObjectListBox *control)
virtual void | NotifyDelete ()
This method is called when a delete operation occures.
void | SetImageChanged (BOOLEAN changed=TRUE)
Sets the image changed flag.
virtual void | Update (INT item_count=-1)
virtual | ~ImageListBoxModel ()

Protected Member Functions

virtual ImageObtainer | GetSelectedImage (INT index)=0
virtual void | OnSelectionChanged (INT selected_index)
This method is called when the selection in the listbox changes.

Detailed Description

Base class of a model for showing images.

Constructor & Destructor Documentation

ImageListBoxModel::ImageListBoxModel ( )

ImageListBoxModel::ImageListBoxModel ( DrawableObjectListBox * control )

ImageListBoxModel::~ImageListBoxModel ( ) [virtual]

Member Function Documentation

void ImageListBoxModel::AdjustThemeDependencies ( ) [virtual]

See also:
DrawableObjectListBoxModel

DrawableObject * ImageListBoxModel::GetItem | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

Returns a pointer to the DrawableObject at pos index

Parameters:
index | Position of the item.
highlighted | Defines if the selected item is highlighted (ignored).

Reimplemented in ImageViewListBoxModel.

DrawableObjectView * ImageListBoxModel::GetRenderingView | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

Returns the view of the item that should be displayed.

Parameters:
index | Position of the item.
highlighted | Defines if the selected item is highlighted (ignored).

virtual ImageObtainer ImageListBoxModel::GetSelectedImage ( INT index ) [protected, pure virtual]

Returns a pointer to the image at position index.

Parameters:
index Position of the image to return.

Implemented in ImageViewListBoxModel.

void ImageListBoxModel::Init ( DrawableObjectListBox * control )

Initializes the ImageListBoxModel

Parameters:
control DrawableObjectListBox for which the model is constructed.

void ImageListBoxModel::NotifyDelete ( ) [virtual]

This method is called when a delete operation occures.

Reimplemented in ImageViewListBoxModel.

void ImageListBoxModel::OnSelectionChanged ( INT selected_index ) [protected, virtual]

This method is called when the selection in the listbox changes.

Reimplemented in ImageViewListBoxModel.

void ImageListBoxModel::SetImageChanged ( BOOLEAN changed = TRUE )

Sets the image changed flag.

void ImageListBoxModel::Update ( INT item_count = -1 ) [virtual]

See also:
DrawableObjectListBoxModel::Update()

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageListBoxModel.hpp
  • Applications/ImageBrowser/ImageListBoxModel.cpp
Generated on Wed Jan 25 01:20:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageListBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageListBoxView Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageView.hpp>

Inheritance diagram for ImageListBoxView:

[legend]
Collaboration diagram for ImageListBoxView:

[legend]

Public Member Functions

void | DrawItem (const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const
Draws an item on the image list box.
ImageListBoxView (XYDIM item_height)
ImageListBoxView ()
void | Init (XYDIM item_height)

Detailed Description

ImageListBoxView represents the view for drawing images in a ListBox.

Constructor & Destructor Documentation

ImageListBoxView::ImageListBoxView ( )

ImageListBoxView::ImageListBoxView ( XYDIM item_height )

Member Function Documentation

void ImageListBoxView::DrawItem | ( | const AbstractListBox & | listbox,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [virtual]

Draws an item on the image list box.

Reimplemented from AbstractListBoxView.

void ImageListBoxView::Init ( XYDIM item_height )

Initializes the view with a given height for the items.

Parameters:
item_height Height of the items to display.

Reimplemented from AbstractListBoxView.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageView.hpp
  • Applications/ImageBrowser/ImageView.cpp
Generated on Wed Jan 25 01:20:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageMetaData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageMetaData Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageMetaData.hpp>

Inheritance diagram for ImageMetaData:

[legend]
Collaboration diagram for ImageMetaData:

[legend]

Public Member Functions

UINT8 | GetFrame () const
Returns the number of frames the image consists of.
UINT16 | GetHeight () const
Returns the height of the image.
virtual WString | GetInfoText () const
Returns metadata information in form of a pretty formatted string.
virtual const MetaDataRecord & | GetMetaDataRecord () const
Returns the constant metadata record.
virtual MetaDataRecord & | GetMetaDataRecord ()
Returns the metadata record.
UINT16 | GetWidth () const
Gets the widht of the image.
ImageMetaData (const Path &path, UINT32 size=0, XYDIM width=0, XYDIM height=0, INT frame=0)
ImageMetaData ()
void | Init (const Path &path, UINT32 size=0, XYDIM width=0, XYDIM height=0, INT frame=0)
void | SetFrame (UINT8 frame)
Sets the number of frames the image consists of.
void | SetHeight (UINT16 height)
Sets the height of the image.
void | SetWidth (UINT16 width)
Sets the width of the image.
virtual | ~ImageMetaData ()

Detailed Description

Stores metadata of the images in an ImageMetaDataRecord and provides setter and getter methods for the properties.

Constructor & Destructor Documentation

ImageMetaData::ImageMetaData ( )

ImageMetaData::ImageMetaData | ( | const Path & | path,
 |  | UINT32 | size = 0,
 |  | XYDIM | width = 0,
 |  | XYDIM | height = 0,
 |  | INT | frame = 0
 | ) |

ImageMetaData::~ImageMetaData ( ) [virtual]

Member Function Documentation

UINT8 ImageMetaData::GetFrame ( ) const

Returns the number of frames the image consists of.

UINT16 ImageMetaData::GetHeight ( ) const

Returns the height of the image.

WString ImageMetaData::GetInfoText ( ) const [virtual]

Returns metadata information in form of a pretty formatted string.

Reimplemented from MetaData.

const MetaDataRecord & ImageMetaData::GetMetaDataRecord ( ) const [virtual]

Returns the constant metadata record.

Implements MetaData.

MetaDataRecord & ImageMetaData::GetMetaDataRecord ( ) [virtual]

Returns the metadata record.

Implements MetaData.

UINT16 ImageMetaData::GetWidth ( ) const

Gets the widht of the image.

void ImageMetaData::Init | ( | const Path & | path,
 |  | UINT32 | size = 0,
 |  | XYDIM | width = 0,
 |  | XYDIM | height = 0,
 |  | INT | frame = 0
 | ) |

void ImageMetaData::SetFrame ( UINT8 frame )

Sets the number of frames the image consists of.

void ImageMetaData::SetHeight ( UINT16 height )

Sets the height of the image.

void ImageMetaData::SetWidth ( UINT16 width )

Sets the width of the image.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageMetaData.hpp
  • Applications/ImageBrowser/ImageMetaData.cpp
Generated on Wed Jan 25 01:20:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageMetaDataRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageMetaDataRecord Struct Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageMetaData.hpp>

Inheritance diagram for ImageMetaDataRecord:

[legend]
Collaboration diagram for ImageMetaDataRecord:

[legend]

Public Member Functions

ImageMetaDataRecord (UINT16 width=0, UINT16 height=0, INT frame=0)
virtual | ~ImageMetaDataRecord ()

Data Fields

UINT8 | m_frame
UINT16 | m_height
UINT16 | m_width

Constructor & Destructor Documentation

ImageMetaDataRecord::ImageMetaDataRecord | ( | UINT16 | width = 0,
 |  | UINT16 | height = 0,
 |  | INT | frame = 0
 | ) |

ImageMetaDataRecord::~ImageMetaDataRecord ( ) [virtual]

Field Documentation

UINT8 ImageMetaDataRecord::m_frame

UINT16 ImageMetaDataRecord::m_height

UINT16 ImageMetaDataRecord::m_width

The documentation for this struct was generated from the following files:
  • Applications/ImageBrowser/ImageMetaData.hpp
  • Applications/ImageBrowser/ImageMetaData.cpp
Generated on Wed Jan 25 01:20:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageObtainer Class Reference
[GUI]

#include <Apoxi/Gui/ImageObtainer.hpp>

Inheritance diagram for ImageObtainer:

[legend]
Collaboration diagram for ImageObtainer:

[legend]

Public Member Functions

const BitmapRes * | GetBitmap () const
XYDIM | GetHeight () const
const Image * | GetImage () const
Returns a pointer to the image which is obtained.
Image * GetImage ()
Returns a pointer to the image which is obtained.
XYDIM | GetWidth () const
ImageObtainer (const ImageObtainer &img_obt)
ImageObtainer (const Bitmap &bitmap)
ImageObtainer (const BitmapRes &bitmap)
ImageObtainer (Image *image, BOOLEAN disposeable=FALSE)
ImageObtainer ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~ImageObtainer ()

Detailed Description

Obtains an instance of the class Image and destructs it when necessary. An image obtainer does a reference-counting, hence when all image obtainers are destructed and the image obtainer has been initialized to obtain a disposable image, the image itself will get deleted too. If objects share one instance of the class image, it is strongly recommended to use an image obtainer instead of a pointer to the image itself.

Example 1: usage of the image obtainer with a static image. The image-box contains an image obtainer, which is destructed in the destructor of the image-box. In this case native_img won't destructed, because the parameter disposable of the image obtainer-constructor has been set to FALSE (= default).

static JpegImage jpeg_img(...);
ImageBox image_box(this, ImageObtainer(&jpeg_img));
...

Example 2: usage of the image obtainer with a dynamically allocated image. The image-box contains an image obtainer, which is destructed in the destructor of the image-box. In this case the native_img will be destructed too, because the parameter disposable of the image obtainer-constructor has been set to TRUE.

JpegImage* jpeg_img = new JpegImage(...);
if (jpeg_img != 0) {
    ImageBox image_box(this, ImageObtainer(jpeg_img, TRUE));
    ...
}

Constructor & Destructor Documentation

ImageObtainer::ImageObtainer ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ImageObtainer::ImageObtainer | ( | Image * | image,
 |  | BOOLEAN | disposeable = FALSE
 | ) |

Parameters:
image | Pointer to the image, which may be shared.
disposable | If set to TRUE, the image image will get deleted automatically, when no image obtainer references this image anymore.

ImageObtainer::ImageObtainer ( const BitmapRes & bitmap )

param bitmap Reference to the bitmap resource which may be shared. Note that the bitmap resource will never get deleted as it is no obtainable object. Assigning a bitmap resource directly to an image obtainer has the benefit that it prevents the overhead to create an instance of the class NativeImage which wraps a bitmap resource into an image-class. As a bitmap resource is always located in the ROM and is no instance of the class Image, the method ImageObtainer::GetBitmap must be used for getting a pointer to the bitmap resource.

ImageObtainer::ImageObtainer ( const Bitmap & bitmap )

param bitmap Reference to the bitmap which may be shared. Note that the bitmap will never get deleted as it is no obtainable object. Assigning a bitmap directly to an image obtainer has the benefit that it prevents the overhead to create an instance of the class NativeImage which wraps a bitmap resource into an image-class. The the method ImageObtainer::GetBitmap must be used for getting a pointer to the bitmap resource.

ImageObtainer::ImageObtainer ( const ImageObtainer & img_obt )

ImageObtainer::~ImageObtainer ( ) [virtual]

Member Function Documentation

const BitmapRes * ImageObtainer::GetBitmap ( ) const

Returns a pointer to the bitmap resource which might be obtained. Note that an image obtainer usually obtains an instance of the class Image and ImageObtainer::GetBitmap() will return 0 in this case. See also the description of ImageObtainer::ImageObtainer(const BitmapRes& bitmap) for details.

XYDIM ImageObtainer::GetHeight ( ) const

Returns:
Height of the image/bitmap. In opposite to GetImage()->GetHeight() an obtained bitmap is respected too (see ImageObtainer::GetBitmap). 0 is returned, if not image/bitmap is obtained.

const Image * ImageObtainer::GetImage ( ) const

Returns a pointer to the image which is obtained.

Image * ImageObtainer::GetImage ( )

Returns a pointer to the image which is obtained.

XYDIM ImageObtainer::GetWidth ( ) const

Returns:
Width of the image/bitmap. In opposite to GetImage()->GetWidth() an obtained bitmap is respected too (see ImageObtainer::GetBitmap). 0 is returned, if no image/bitmap is obtained.

BOOLEAN ImageObtainer::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

The documentation for this class was generated from the following files:
  • Gui/ImageObtainer.hpp
  • Gui/ImageObtainer.cpp
Generated on Wed Jan 25 01:20:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageReadIndArg Class Reference

#include <Apoxi/Apc/ImageStackMsgArgs.hpp>

Inheritance diagram for ImageReadIndArg:

[legend]
Collaboration diagram for ImageReadIndArg:

[legend]

Public Types

enum | { ID = 1080 }

Public Member Functions

const SimImage & | GetImage () const
ImageReadIndArg ()
void | SetImage (const SimImage &image)

Static Public Member Functions

static const ImageReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ImageReadIndArg: reflects arguments of signal SI_IMAGE_DATA_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImageReadIndArg::ImageReadIndArg ( )

Member Function Documentation

const ImageReadIndArg & ImageReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimImage& ImageReadIndArg::GetImage ( ) const [inline]

void ImageReadIndArg::SetImage ( const SimImage & image ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ImageStackMsgArgs.hpp
  • Apc/ImageStackMsgArgs.cpp
Generated on Wed Jan 25 01:20:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageReadReqArg Class Reference

#include <Apoxi/Apc/ImageStackMsgArgs.hpp>

Inheritance diagram for ImageReadReqArg:

[legend]
Collaboration diagram for ImageReadReqArg:

[legend]

Public Types

enum | { ID = 2080 }

Public Member Functions

const SimImageDescriptor & | GetImgdescriptor () const
const SimImageRequestType & | GetImgRequestType () const
ImageReadReqArg ()
ImageReadReqArg (const SimImageRequestType &img_request_type, const SimImageDescriptor &imgdescriptor)
void | SetImgdescriptor (const SimImageDescriptor &imgdescriptor)
void | SetImgRequestType (const SimImageRequestType &img_request_type)

Static Public Member Functions

static const ImageReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ImageReadReqArg: reflects arguments of signal SI_IMAGE_DATA_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImageReadReqArg::ImageReadReqArg | ( | const SimImageRequestType & | img_request_type,
 |  | const SimImageDescriptor & | imgdescriptor
 | ) |

ImageReadReqArg::ImageReadReqArg ( )

Member Function Documentation

const ImageReadReqArg & ImageReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimImageDescriptor& ImageReadReqArg::GetImgdescriptor ( ) const [inline]

const SimImageRequestType& ImageReadReqArg::GetImgRequestType ( ) const [inline]

void ImageReadReqArg::SetImgdescriptor ( const SimImageDescriptor & imgdescriptor ) [inline]

void ImageReadReqArg::SetImgRequestType ( const SimImageRequestType & img_request_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ImageStackMsgArgs.hpp
  • Apc/ImageStackMsgArgs.cpp
Generated on Wed Jan 25 01:20:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageRef Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageRef Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageRef.hpp>

Inheritance diagram for ImageRef:

[legend]
Collaboration diagram for ImageRef:

[legend]

Public Member Functions

Image * | CreateImageObject (const BinData *bd, BOOLEAN buffer_to_ram=TRUE)
Image * | CreateImageObject (BinData *bd, BOOLEAN buffer_to_ram=TRUE)
Image * | GetImage (BOOLEAN buffer_to_ram=TRUE)
const ImageObtainer | GetImageObtainer ()
virtual const MetaData & | GetMetaData () const
virtual MetaData & | GetMetaData ()
ImageRef ()
Need to delete after the test.
BOOLEAN | IsImageInitialized () const
Returns if the image is already initilized or not.
void | ReleaseImage ()
Releases the image stored in the member variable m_image.
void | ReleaseThumbnail ()
Releases the thumbnail and its allocated memory.
void | SetImage (Image *image)
Sets the image.
virtual void | SetMetaData (const MetaData &meta_data)
virtual | ~ImageRef ()

Detailed Description

ImageRef is used to encapsulate functionality for handing over information about an image or for loading an image from the filesystem.
See also:
MediaRef

Constructor & Destructor Documentation

ImageRef::ImageRef ( )

Need to delete after the test.

ImageRef::~ImageRef ( ) [virtual]

Member Function Documentation

Image * ImageRef::CreateImageObject | ( | const BinData * | bd,
 |  | BOOLEAN | buffer_to_ram = TRUE
 | ) |

Image * ImageRef::CreateImageObject | ( | BinData * | bd,
 |  | BOOLEAN | buffer_to_ram = TRUE
 | ) |

Image * ImageRef::GetImage ( BOOLEAN buffer_to_ram = TRUE )

If the member containing the image is already initialized it returns the pointer to this image, otherwise it loads the image from its associated file by use of a FileBinData object.

const ImageObtainer ImageRef::GetImageObtainer ( )

const MetaData & ImageRef::GetMetaData ( ) const [virtual]

See also:
MediaRef::GetMetaData

Implements MediaRef.

MetaData & ImageRef::GetMetaData ( ) [virtual]

See also:
MediaRef::GetMetaData

Implements MediaRef.

BOOLEAN ImageRef::IsImageInitialized ( ) const

Returns if the image is already initilized or not.

void ImageRef::ReleaseImage ( )

Releases the image stored in the member variable m_image.

void ImageRef::ReleaseThumbnail ( )

Releases the thumbnail and its allocated memory.

void ImageRef::SetImage ( Image * image )

Sets the image.

void ImageRef::SetMetaData ( const MetaData & meta_data ) [virtual]

See also:
MediaRef::SetMetaData

Implements MediaRef.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageRef.hpp
  • Applications/ImageBrowser/ImageRef.cpp
Generated on Wed Jan 25 01:20:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageRefContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageRefContainer Class Reference

#include <Applications/ImageBrowser/ImageRefContainer.hpp>

Inheritance diagram for ImageRefContainer:

[legend]
Collaboration diagram for ImageRefContainer:

[legend]

Public Member Functions

virtual BOOLEAN | Add (MediaRefPtr &media_ref, BOOLEAN free=TRUE)
virtual BOOLEAN | Delete (MediaRefPtr &media_ref, BOOLEAN delete_file=FALSE)
virtual UINT32 | GetSizeOfRecord () const
ImageRefContainer (const Path &database_path)
ImageRefContainer ()
virtual BOOLEAN | Rename (MediaRefPtr &media_ref, const WString &new_name)
virtual | ~ImageRefContainer ()

Protected Member Functions

virtual MediaRefPtr | CreateMediaRef () const
virtual FileFilterPtr | GetMediaFileFilter () const
virtual BOOLEAN | SetupMediaObject (MediaRefPtr &media_ref)

Detailed Description

Class ImageRefContainer implements a media container for images only.

Constructor & Destructor Documentation

ImageRefContainer::ImageRefContainer ( )

ImageRefContainer::ImageRefContainer ( const Path & database_path )

ImageRefContainer::~ImageRefContainer ( ) [virtual]

Member Function Documentation

BOOLEAN ImageRefContainer::Add | ( | MediaRefPtr & | media_ref,
 |  | BOOLEAN | free = TRUE
 | ) | [virtual]

Adds the image of the media reference and a thumbnail of it if the image size is larger than the defined size for thumbnails.

See also:
MediaRefContainer::Add()

MediaRefPtr ImageRefContainer::CreateMediaRef ( ) const [protected, virtual]

See also:
MediaRefContainer::CreateMediaRef()

Implements MediaRefContainer.

BOOLEAN ImageRefContainer::Delete | ( | MediaRefPtr & | media_ref,
 |  | BOOLEAN | delete_file = FALSE
 | ) | [virtual]

If a thumbnail was created for the image the thumbnail's file is deleted regardless of parameter delete_file.

See also:
MediaRefContainer::Delete()

Reimplemented from MediaRefContainer.

FileFilterPtr ImageRefContainer::GetMediaFileFilter ( ) const [protected, virtual]

See also:
MediaRefContainer::GetMediaFileFilter()

Implements MediaRefContainer.

UINT32 ImageRefContainer::GetSizeOfRecord ( ) const [virtual]

See also:
MediaRefContainer::GetSizeOfRecord()

Implements MediaRefContainer.

BOOLEAN ImageRefContainer::Rename | ( | MediaRefPtr & | media_ref,
 |  | const WString & | new_name
 | ) | [virtual]

If a thumbnail was created for the image the thumbnail's file is renamed, too.

See also:
MediaRefContainer::Rename()

Reimplemented from MediaRefContainer.

BOOLEAN ImageRefContainer::SetupMediaObject ( MediaRefPtr & media_ref ) [protected, virtual]

See also:
MediaRefContainer::SetupMediaObject()

Implements MediaRefContainer.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageRefContainer.hpp
  • Applications/ImageBrowser/ImageRefContainer.cpp
Generated on Wed Jan 25 01:20:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageRefGenContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageRefGenContainer Class Reference

#include <Applications/ImageBrowser/ImageRefGenContainer.hpp>

Inheritance diagram for ImageRefGenContainer:

[legend]
Collaboration diagram for ImageRefGenContainer:

[legend]

Public Member Functions

virtual GenericObject * | Copy () const
Creates a copy of the object itself, must be overwritten in the derived class.
ImageRef & GetImageRefObj ()
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class, must be overwritten by the derived class.
ImageRefGenContainer (const ImageRef &img_obt)
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself, must be overwritten in the derived class.
void | SetImageRefObj (const ImageRef &gen_obt)
virtual | ~ImageRefGenContainer ()

Constructor & Destructor Documentation

virtual ImageRefGenContainer::~ImageRefGenContainer ( ) [inline, virtual]

ImageRefGenContainer::ImageRefGenContainer ( const ImageRef & img_obt ) [inline]

Member Function Documentation

GenericObject * ImageRefGenContainer::Copy ( ) const [virtual]

Creates a copy of the object itself, must be overwritten in the derived class.

Implements GenericObject.

ImageRef & ImageRefGenContainer::GetImageRefObj ( )

GenericTypeId ImageRefGenContainer::GetTypeId ( ) [virtual]

Returns the identity of the class, must be overwritten by the derived class.

Implements GenericObject.

BOOLEAN ImageRefGenContainer::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object instance itself, must be overwritten in the derived class.

Implements GenericObject.

void ImageRefGenContainer::SetImageRefObj ( const ImageRef & gen_obt )

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageRefGenContainer.hpp
  • Applications/ImageBrowser/ImageRefGenContainer.cpp
Generated on Wed Jan 25 01:20:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageView Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/ImageView.hpp>

Inheritance diagram for ImageView:

[legend]
Collaboration diagram for ImageView:

[legend]

Public Member Functions

ImageViewListBoxModel * GetModel ()
ImageView ()
void | Init (Control *control, MediaRefContainer &media_refs)
virtual void | NotifyDelete ()
virtual | ~ImageView ()

Protected Member Functions

virtual void | OnGetFocus ()
This method is called when the control gets the focus.
virtual BOOLEAN | OnMessage (const Message &msg)
This method is called when a new message arrives.

Detailed Description

ImageView is a control that allows the user to scroll through images which are stored in a media reference container.

Constructor & Destructor Documentation

ImageView::ImageView ( )

ImageView::~ImageView ( ) [virtual]

Member Function Documentation

ImageViewListBoxModel* ImageView::GetModel ( ) [inline]

void ImageView::Init | ( | Control * | control,
 |  | MediaRefContainer & | media_refs
 | ) |

Initializes the view with the control and a MediaRefContainer

Parameters:
control | Parent of the image view.
media_refs | Media reference container holding the items to be displayed in the view.

void ImageView::NotifyDelete ( ) [virtual]

Called when the view has to notified about the deletion of an element

Reimplemented from BrowserView.

void ImageView::OnGetFocus ( ) [protected, virtual]

This method is called when the control gets the focus.

BOOLEAN ImageView::OnMessage ( const Message & msg ) [protected, virtual]

This method is called when a new message arrives.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageView.hpp
  • Applications/ImageBrowser/ImageView.cpp
Generated on Wed Jan 25 01:20:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageViewListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImageViewListBoxModel Class Reference
[ImageBrowser]

Class to serve as a model for the ImageView. More...

#include <Applications/ImageBrowser/ImageViewListBoxModel.hpp>

Inheritance diagram for ImageViewListBoxModel:

[legend]
Collaboration diagram for ImageViewListBoxModel:

[legend]

Public Member Functions

virtual const WString | GetCellText (INT index, BOOLEAN highlighted)
virtual DrawableObject * | GetItem (INT index, BOOLEAN highlighted)
const WString | GetResolution (INT index, BOOLEAN highlighted)
ImageViewListBoxModel (DrawableObjectListBox *control, const MediaRefContainer &media_refs)
ImageViewListBoxModel ()
void | Init (DrawableObjectListBox *control, const MediaRefContainer &media_refs)
virtual void | NotifyDelete ()
This method is called when a delete operation occures.
virtual | ~ImageViewListBoxModel ()

Protected Member Functions

virtual ImageObtainer | GetSelectedImage (INT index)
virtual void | OnSelectionChanged (INT selected_index)
This method is called when the selection in the listbox changes.

Detailed Description

Class to serve as a model for the ImageView.

Constructor & Destructor Documentation

ImageViewListBoxModel::ImageViewListBoxModel ( )

ImageViewListBoxModel::ImageViewListBoxModel | ( | DrawableObjectListBox * | control,
 |  | const MediaRefContainer & | media_refs
 | ) |

ImageViewListBoxModel::~ImageViewListBoxModel ( ) [virtual]

Member Function Documentation

const WString ImageViewListBoxModel::GetCellText | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

DrawableObject * ImageViewListBoxModel::GetItem | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

Returns a pointer to the DrawableObject at pos index.

Parameters:
index | Position of the item.
highlighted | Defines if the selected item is highlighted (ignored).

Reimplemented from ImageListBoxModel.

const WString ImageViewListBoxModel::GetResolution | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) |

ImageObtainer ImageViewListBoxModel::GetSelectedImage ( INT index ) [protected, virtual]

Returns a pointer to the image at position index.

Parameters:
index Position of the image to return.

Implements ImageListBoxModel.

void ImageViewListBoxModel::Init | ( | DrawableObjectListBox * | control,
 |  | const MediaRefContainer & | media_refs
 | ) |

Initializes the ImageViewListBoxModel.

Parameters:
control | DrawableObjectListBox for which the model is constructed.
media_refs | MediaRefContainer containing references to the images which should be displayed.

void ImageViewListBoxModel::NotifyDelete ( ) [virtual]

This method is called when a delete operation occures.

Reimplemented from ImageListBoxModel.

void ImageViewListBoxModel::OnSelectionChanged ( INT selected_index ) [protected, virtual]

This method is called when the selection in the listbox changes.

Reimplemented from ImageListBoxModel.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/ImageViewListBoxModel.hpp
  • Applications/ImageBrowser/ImageViewListBoxModel.cpp
Generated on Wed Jan 25 01:20:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Imei Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Imei Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [10]

Field Documentation

UINT8 Imei::val[10]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:20:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImeiReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImeiReadIndArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for ImeiReadIndArg:

[legend]
Collaboration diagram for ImeiReadIndArg:

[legend]

Public Types

enum | { ID = 1110 }

Public Member Functions

const Imei & | GetImei1 () const
const Imei & | GetImei2 () const
const SimUpdateStatus & | GetStatus () const
ImeiReadIndArg ()
void | SetImei1 (const Imei &imei1)
void | SetImei2 (const Imei &imei2)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const ImeiReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ImeiReadIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImeiReadIndArg::ImeiReadIndArg ( )

Member Function Documentation

const ImeiReadIndArg & ImeiReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Imei& ImeiReadIndArg::GetImei1 ( ) const [inline]

const Imei& ImeiReadIndArg::GetImei2 ( ) const [inline]

const SimUpdateStatus& ImeiReadIndArg::GetStatus ( ) const [inline]

void ImeiReadIndArg::SetImei1 ( const Imei & imei1 ) [inline]

void ImeiReadIndArg::SetImei2 ( const Imei & imei2 ) [inline]

void ImeiReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:20:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImeiReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImeiReadReqArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for ImeiReadReqArg:

[legend]
Collaboration diagram for ImeiReadReqArg:

[legend]

Public Types

enum | { ID = 2103 }

Public Member Functions

ImeiReadReqArg ()

Static Public Member Functions

static const ImeiReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

ImeiReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ImeiReadReqArg::ImeiReadReqArg ( )

Member Function Documentation

const ImeiReadReqArg & ImeiReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:20:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImeiShowAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImeiShowAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for ImeiShowAction:

[legend]
Collaboration diagram for ImeiShowAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
ImeiShowAction ()
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual BOOLEAN | ShallExecuteImmediatly ()
Returns if Execute can be called immediatly without confirmation with an additional key (e.g SEND).
virtual | ~ImeiShowAction ()

Detailed Description

ImeiShowAction analyzes if the input string has the meaning of showing the IMEI. Execute has to be overwritten to implement the showing of the IMEI.

Constructor & Destructor Documentation

ImeiShowAction::ImeiShowAction ( )

ImeiShowAction::~ImeiShowAction ( ) [virtual]

Member Function Documentation

InputAction * ImeiShowAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType ImeiShowAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

BOOLEAN ImeiShowAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

BOOLEAN ImeiShowAction::ShallExecuteImmediatly ( ) [virtual]

Returns if Execute can be called immediatly without confirmation with an additional key (e.g SEND).

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:20:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IMelody Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IMelody Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/IMelody.hpp>

Inheritance diagram for IMelody:

[legend]
Collaboration diagram for IMelody:

[legend]

Public Types

enum | { ID = 0 }

Public Member Functions

virtual const BinData * | GetBinData () const
Returns the i-melody data in the ems specific format.
virtual INT | GetId () const
BinData * GetPlainData ()
virtual Audio::ToneData * | GetToneData ()
IMelody (BinData *bin_data, BOOLEAN copyrighted=FALSE)
IMelody ()
void | Init (BinData *bin_data, BOOLEAN copyrighted=FALSE)
virtual | ~IMelody ()

Static Public Member Functions

static void | RegisterParser (AbstractIMelodyParser *parser)
Registers a parser to decode an i-melody.

Detailed Description

Obsolete - all sound classes from AddOns/MultiMedia have been replaced by a new audio concept. Use the AudioDeviceManager instead for playing sounds.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

IMelody::IMelody ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

IMelody::IMelody | ( | BinData * | bin_data,
 |  | BOOLEAN | copyrighted = FALSE
 | ) | [explicit]

Initializes an i-melody-object with the given bin_data.

Parameters:
bin_data | Pointer to a binary data stream which contains the i-melody data. After passing the binary data stream, the stream is obtained by the i-melody-object and hence automatically released in the destructor of the i-melody-object.
copyrighted | Indicates, whether the melody is copyrighted.

IMelody::~IMelody ( ) [virtual]

Member Function Documentation

const BinData * IMelody::GetBinData ( ) const [virtual]

Returns the i-melody data in the ems specific format.

Reimplemented from Sound.

INT IMelody::GetId ( ) const [virtual]

See also:
Sound::GetId

Implements Sound.

BinData* IMelody::GetPlainData ( ) [inline]

Obsolete (provided for backward-compatibility with APOXI-1.6.3) - use GetBinData instead. It is strongly recommend not to change the content of bin-data, because the i-melody-object is owner of the bin-data by definition (see APOXI_GUI_Tutorial for further details).

Audio::ToneData * IMelody::GetToneData ( ) [virtual]

See also:
Melody::GetToneData.

Reimplemented from Melody.

void IMelody::Init | ( | BinData * | bin_data,
 |  | BOOLEAN | copyrighted = FALSE
 | ) |

Initializes an i-melody-object with the given bin_data.

Parameters:
bin_data | Pointer to a binary data stream which contains the i-melody data. After passing the binary data stream, the stream is obtained by the i-melody-object and hence automatically released in the destructor of the i-melody-object.
copyrighted | Indicates, whether the melody is copyrighted.

void IMelody::RegisterParser ( AbstractIMelodyParser * parser ) [static]

Registers a parser to decode an i-melody.

The documentation for this class was generated from the following files:
  • Compat/IMelody.hpp
  • Compat/IMelody.cpp
Generated on Wed Jan 25 01:20:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IMelodyData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IMelodyData Struct Reference
[Obsolete GUI classes]

Holds parsed IMelody data. More...

#include <Apoxi/Compat/IMelody.hpp>

Collaboration diagram for IMelodyData:

[legend]

Data Fields

WString m_composer
Composer as defined in IMelody spec.
WString m_format
Format as defined in IMelody spec.
WString m_name
Name as defined in IMelody spec.
struct {
UINT16 beat: 10
Beat (10 bits) as defined in IMelody spec.
UINT8 style: 2
Style (2 bits) as defined in IMelody spec.
UINT8 volume: 4
Volume (4 bits) as defined in IMelody spec.
} m_properties
Several values as defined in IMelody spec.
Audio::ToneData m_tone_data
Native audio data.
WString m_version
Version as defined in IMelody spec.

Detailed Description

Holds parsed IMelody data.

Field Documentation

UINT16 IMelodyData::beat

Beat (10 bits) as defined in IMelody spec.

WString IMelodyData::m_composer

Composer as defined in IMelody spec.

WString IMelodyData::m_format

Format as defined in IMelody spec.

WString IMelodyData::m_name

Name as defined in IMelody spec.

struct { ... } IMelodyData::m_properties

Several values as defined in IMelody spec.

Audio::ToneData IMelodyData::m_tone_data

Native audio data.

WString IMelodyData::m_version

Version as defined in IMelody spec.

UINT8 IMelodyData::style

Style (2 bits) as defined in IMelody spec.

UINT8 IMelodyData::volume

Volume (4 bits) as defined in IMelody spec.

The documentation for this struct was generated from the following file:
  • Compat/IMelody.hpp
Generated on Wed Jan 25 01:20:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImgObtObj Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ImgObtObj Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Gui/ImgObtObj.hpp>

Inheritance diagram for ImgObtObj:

[legend]
Collaboration diagram for ImgObtObj:

[legend]

Public Types

typedef GenericObject | Base

Public Member Functions

virtual GenericObject * | Copy () const
Creates a copy of the object itself.
const ImageObtainer & | GetImgObt () const
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class.
ImgObtObj (const ImageObtainer &img_obt)
Constructor of the class BitmapRes.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object.
void | SetImgObt (const ImageObtainer &img_obt)
virtual | ~ImgObtObj ()

Member Typedef Documentation

typedef GenericObject ImgObtObj::Base

Constructor & Destructor Documentation

ImgObtObj::ImgObtObj ( const ImageObtainer & img_obt )

Constructor of the class BitmapRes.

ImgObtObj::~ImgObtObj ( ) [virtual]

Member Function Documentation

GenericObject * ImgObtObj::Copy ( ) const [virtual]

Creates a copy of the object itself.

Implements GenericObject.

const ImageObtainer& ImgObtObj::GetImgObt ( ) const [inline]

GenericTypeId ImgObtObj::GetTypeId ( ) [virtual]

Returns the identity of the class.

Implements GenericObject.

BOOLEAN ImgObtObj::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object.

Implements GenericObject.

void ImgObtObj::SetImgObt ( const ImageObtainer & img_obt ) [inline]

The documentation for this class was generated from the following files:
  • Atl/Gui/ImgObtObj.hpp
  • Atl/Gui/ImgObtObj.cpp
Generated on Wed Jan 25 01:20:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Imsi Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Imsi Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [9]

Field Documentation

UINT8 Imsi::val[9]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:20:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IncomingCallForwardedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IncomingCallForwardedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for IncomingCallForwardedMsg:

[legend]
Collaboration diagram for IncomingCallForwardedMsg:

[legend]

Public Types

enum | { ID = 18533 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
IncomingCallForwardedMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code)
virtual | ~IncomingCallForwardedMsg ()

Detailed Description

IncomingCallForwardedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

IncomingCallForwardedMsg::IncomingCallForwardedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code
 | ) |

IncomingCallForwardedMsg::~IncomingCallForwardedMsg ( ) [virtual]

Member Function Documentation

Message * IncomingCallForwardedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & IncomingCallForwardedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& IncomingCallForwardedMsg::GetSsCode ( ) const [inline]

const Tipd& IncomingCallForwardedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:20:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IncrementalPdcUpdater Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IncrementalPdcUpdater Class Reference
[GUI]

#include <Apoxi/Gui/Image.hpp>

Inheritance diagram for IncrementalPdcUpdater:

[legend]
Collaboration diagram for IncrementalPdcUpdater:

[legend]

Public Member Functions

void | Finish () const
IncrementalPdcUpdater (const void *client, PaintDc &pdc, INT max_delay=500)
void | Init ()
BOOLEAN | TimeExpired () const
BOOLEAN | Update (INT total_steps, INT completed_steps)
BOOLEAN | UpdatesMainDisplay () const
virtual | ~IncrementalPdcUpdater ()

Protected Member Functions

virtual void | SendInterruptedMsg () const =0
virtual void | SendProgressMsg (INT total_steps, INT completed_steps) const =0

Static Protected Member Functions

static INT | CalcProgress (INT total_steps, INT completed_steps)

Protected Attributes

const void * | m_client
INT | m_max_delay

Detailed Description

The incremental paint device context updater supports periodically updating a paint device context if the drawing process itself is a rather long task and therefore progress feedback should be given to the user. If the paint device context is the main display, this gets updated immediately. If the incremental updater works on a paint device context different from the main display then no visual feedback can be given directly. Therefore, in any case, messages are automatically sent indicating the progress or interruption of the drawing task. Anybody who is interested can listen and accordingly react to these messages, e.g. a progress bar can (additionally) visually indicate the progress of the drawing task.

Constructor & Destructor Documentation

IncrementalPdcUpdater::IncrementalPdcUpdater | ( | const void * | client,
 |  | PaintDc & | pdc,
 |  | INT | max_delay = 500
 | ) |

Creates and connects the updater to the given client and paint device context pdc. The desired maximal delay between two device context updates defaults to 500 but may be specified differently by optional parameter max_delay.

IncrementalPdcUpdater::~IncrementalPdcUpdater ( ) [virtual]

The destructor of a derived class has to call Finish().

See also:
Finish()

Member Function Documentation

INT IncrementalPdcUpdater::CalcProgress | ( | INT | total_steps,
 |  | INT | completed_steps
 | ) | [static, protected]

Calculates the progress in percentage (1 to 100) from the given total_steps and completed_steps.

Parameters:
total_steps | Number of steps to be done to completely process some task.
completed_steps | Number of steps already processed.

void IncrementalPdcUpdater::Finish ( ) const

Finishes partial device context updates done by the incremental update handling mechanism. This method has to be called at the end of the incremental update handling mechanism. Any call to Init() has to be properly ended with a call to this method Finish(). If this is not done by the client then the destructor of the derived class has to take care of calling it. For this purpose the derived destructor has to call Finish(). If the updater is connected to the main display this is updated directly. In any case a progress message inidicating completion of updating (i.e. progress equals to 100) is sent.

See also:
Init

~IncrementalPdcUpdater

void IncrementalPdcUpdater::Init ( )

Initializes the incremental update handling mechanism. A timer which is later used by method TimeExpired() is started. In addition a progress message inidicating start of updating (i.e. progress equals to 0) is sent.

See also:
TimeExpired

virtual void IncrementalPdcUpdater::SendInterruptedMsg ( ) const [protected, pure virtual]

Abstract method called to send an interrupted message. Any subclass has to implement it. The message sent might take into account the client m_client.

Implemented in ImageIncrementalPdcUpdater.

virtual void IncrementalPdcUpdater::SendProgressMsg | ( | INT | total_steps,
 |  | INT | completed_steps
 | ) | const [protected, pure virtual]

Abstract method called to send a progress message. Any subclass has to implement it. The message sent might take into account the client m_client.

Implemented in ImageIncrementalPdcUpdater.

BOOLEAN IncrementalPdcUpdater::TimeExpired ( ) const

Tells whether the time span for handling an incremental update has expired. If so, the client may prepare for an update and then process it by calling Update(). Method Init() has to be called before applying this method.

See also:
Init

Update

BOOLEAN IncrementalPdcUpdater::Update | ( | INT | total_steps,
 |  | INT | completed_steps
 | ) |

Handles the update request. In case we are painting to the main display this gets updated directly. In any case a progress message taking into account the progress information given via parameters total_steps and completed_steps is sent. In case of drawing to the main display it is also checked if the user asked for stopping the task by pressing any key. In this case an interruption message is sent and FALSE is returned. The caller should react to it accordingly, e.g. freeing ressources and stopping the drawing process. E.g. a progress bar can react to the interruption message accordingly.

Parameters:
total_steps | Number of steps to be done to completely process some task.
completed_steps | Number of steps already processed.

BOOLEAN IncrementalPdcUpdater::UpdatesMainDisplay ( ) const

Tells if the updater updates the main display.

Field Documentation

const void* IncrementalPdcUpdater::m_client [protected]

INT IncrementalPdcUpdater::m_max_delay [protected]

The documentation for this class was generated from the following files:
  • Gui/Image.hpp
  • Gui/Image.cpp
Generated on Wed Jan 25 01:20:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndexTable< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndexTable< T > Class Template Reference

#include <Apoxi/Auxiliary/IndexTable.hpp>

Inheritance diagram for IndexTable< T >:

[legend]
Collaboration diagram for IndexTable< T >:

[legend]

Public Member Functions

void | FillIndexValues ()
Initializes the index table with position values.
void | FillZeroes ()
Fills the index table with zeros.
INT | GetCount () const
Returns the number of indices held by the index table.
INT | GetSize () const
Returns the number of allocated indices held by the index table.
T | GetValue (INT idx) const
Returns an index value.
IndexTable (const IndexTable< T > &indextable)
IndexTable (INT count)
Creates an index table of length count.
IndexTable ()
Creates an empty index table.
void | MoveValue (INT row1, INT row2)
Moves an entry from row1 to row2.
IndexTable< T > & | operator= (const IndexTable< T > &indextable)
T | operator[] (INT idx)
const T | operator[] (INT idx) const
BOOLEAN | Resize (INT count)
Resizes the index table and deletes the old one if it grows.
void | SetValue (INT idx, T value)
Sets an index value.
void | SwapValues (INT row1, INT row2)
Swaps index values of two positions.
~IndexTable ()
Destroys the index table.

Detailed Description

template<class T>
class IndexTable< T >

IndexTable is used to allocate a dynamic indextable of type T.

Constructor & Destructor Documentation

template<class T>
IndexTable< T >::IndexTable ( ) [inline]

Creates an empty index table.

template<class T>
IndexTable< T >::IndexTable ( INT count ) [inline]

Creates an index table of length count.

template<class T>
IndexTable< T >::IndexTable ( const IndexTable< T > & indextable ) [inline]

template<class T>
IndexTable< T >::~IndexTable ( ) [inline]

Destroys the index table.

Member Function Documentation

template<class T>
void IndexTable< T >::FillIndexValues ( ) [inline]

Initializes the index table with position values.

template<class T>
void IndexTable< T >::FillZeroes ( ) [inline]

Fills the index table with zeros.

template<class T>
INT IndexTable< T >::GetCount ( ) const [inline]

Returns the number of indices held by the index table.

template<class T>
INT IndexTable< T >::GetSize ( ) const [inline]

Returns the number of allocated indices held by the index table.

template<class T>
T IndexTable< T >::GetValue ( INT idx ) const [inline]

Returns an index value.

template<class T>
void IndexTable< T >::MoveValue | ( | INT | row1,
 |  | INT | row2
 | ) | [inline]

Moves an entry from row1 to row2.

template<class T>
IndexTable<T>& IndexTable< T >::operator= ( const IndexTable< T > & indextable ) [inline]

template<class T>
T IndexTable< T >::operator[] ( INT idx ) [inline]

template<class T>
const T IndexTable< T >::operator[] ( INT idx ) const [inline]

template<class T>
BOOLEAN IndexTable< T >::Resize ( INT count ) [inline]

Resizes the index table and deletes the old one if it grows.

template<class T>
void IndexTable< T >::SetValue | ( | INT | idx,
 |  | T | value
 | ) | [inline]

Sets an index value.

template<class T>
void IndexTable< T >::SwapValues | ( | INT | row1,
 |  | INT | row2
 | ) | [inline]

Swaps index values of two positions.

The documentation for this class was generated from the following file:
  • Auxiliary/IndexTable.hpp
Generated on Wed Jan 25 01:20:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Indicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Indicator Class Reference
[APOXI Template Layer]

Base class of indicators to be used in IndicatorBars. More...

#include <Apoxi/Compat/Indicator.hpp>

Inheritance diagram for Indicator:

[legend]
Collaboration diagram for Indicator:

[legend]

Public Types

enum | IndicatorAlignment { Left = 0, Center = 1, Right = 2 }
Alignment point of the indicator. OBSOLETE SINCE 1.21. More...
typedef INT | IndicatorPosition
OBSOLETE SINCE 1.21.

Public Member Functions

virtual void | Draw (DeviceContext *dc, Point pos, Rect draw_rect)=0
Draws the indicator on the given screen position.
IndicatorAlignment | GetAlignment () const
OBSOLETE SINCE 1.21.
const IndicatorID & | GetId () const
Returns indicator Id.
const IndicatorDescription * | GetIndicatorDescription () const
IndicatorPosition | GetPosition () const
OBSOLETE SINCE 1.21.
virtual Size | GetSize () const =0
Returns the size of the indicator.
Indicator ()
Constructs an Indicator object with the given position and alignment.
Indicator (IndicatorPosition pos, IndicatorAlignment align)
OBSOLETE SINCE 1.21.
void | Init (const IndicatorID &indicatorId, const IndicatorDescription *desc=0)
virtual BOOLEAN | IsVisible () const
Determines whether or not this indicator should be displayed.
void | SetAlignment (IndicatorAlignment align)
OBSOLETE SINCE 1.21.
void | SetIndicatorDescription (const IndicatorDescription *desc)
void | SetPosition (IndicatorPosition pos)
OBSOLETE SINCE 1.21.
void | SetVisible (BOOLEAN flag)
Sets the indicator visible or invisible.
virtual | ~Indicator ()

Detailed Description

Base class of indicators to be used in IndicatorBars.

Member Typedef Documentation

typedef INT Indicator::IndicatorPosition

OBSOLETE SINCE 1.21.

Member Enumeration Documentation

enum Indicator::IndicatorAlignment

Alignment point of the indicator. OBSOLETE SINCE 1.21.

Enumerator:
Left
Center
Right

Constructor & Destructor Documentation

Indicator::Indicator | ( | IndicatorPosition | pos,
 |  | IndicatorAlignment | align
 | ) |

OBSOLETE SINCE 1.21.

Indicator::Indicator ( )

Constructs an Indicator object with the given position and alignment.

Indicator::~Indicator ( ) [virtual]

Member Function Documentation

virtual void Indicator::Draw | ( | DeviceContext * | dc,
 |  | Point | pos,
 |  | Rect | draw_rect
 | ) | [pure virtual]

Draws the indicator on the given screen position.

Implemented in IconIndicator, TextIndicator, IconTextIndicator, and IconValueIndicator.

IndicatorAlignment Indicator::GetAlignment ( ) const [inline]

OBSOLETE SINCE 1.21.

const IndicatorID& Indicator::GetId ( ) const [inline]

Returns indicator Id.

const IndicatorDescription* Indicator::GetIndicatorDescription ( ) const [inline]

IndicatorPosition Indicator::GetPosition ( ) const [inline]

OBSOLETE SINCE 1.21.

virtual Size Indicator::GetSize ( ) const [pure virtual]

Returns the size of the indicator.

Implemented in IconIndicator, TextIndicator, CenteredTextIndicator, IconTextIndicator, and IconValueIndicator.

void Indicator::Init | ( | const IndicatorID & | indicatorId,
 |  | const IndicatorDescription * | desc = 0
 | ) |

virtual BOOLEAN Indicator::IsVisible ( ) const [inline, virtual]

Determines whether or not this indicator should be displayed.

void Indicator::SetAlignment ( IndicatorAlignment align )

OBSOLETE SINCE 1.21.

void Indicator::SetIndicatorDescription ( const IndicatorDescription * desc )

void Indicator::SetPosition ( IndicatorPosition pos )

OBSOLETE SINCE 1.21.

void Indicator::SetVisible ( BOOLEAN flag )

Sets the indicator visible or invisible.

The documentation for this class was generated from the following files:
  • Compat/Indicator.hpp
  • Compat/Indicator.cpp
Generated on Wed Jan 25 01:20:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndicatorBar Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndicatorBar Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/IndicatorBar.hpp>

Inheritance diagram for IndicatorBar:

[legend]
Collaboration diagram for IndicatorBar:

[legend]

Public Member Functions

void | AddIndicator (Indicator *indicator)
Adds an Indicator to this IndicatorBar.
const IndicatorBarID & | GetId ()
Returns indicator bar Id.
XYDIM | GetIndicatorbarExpansion ()
Get the expansion of this IndicatorBar.
IndicatorBarView::IndicatorBarOrientation GetOrientation ()
Returns the indicatorbar's orientation.
Desktop::SectionType | GetSection () const
Returns section type.
virtual DrawableObjectView * | GetView () const
Returns the view for this IndicatorBar.
IndicatorBar ()
void | Init (const IndicatorBarID &id, Control *control, Desktop::SectionType section, BOOLEAN auto_draw=TRUE)
BOOLEAN | IsEmpty () const
Returns true, if no indicator contained.
void | RemoveAllIndicators ()
Removes all Indicators from this IndicatorBar.
void | RemoveIndicator (Indicator *indicator)
Removes an Indicator from this IndicatorBar.
void | SetIndicatorbarExpansion (XYDIM indicatorbar_expansion)
Set the expansion of this IndicatorBar.
virtual | ~IndicatorBar ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnUpdate (ObservableObject *obs_obj)

Friends

class | IndicatorBarView

Detailed Description

An IndicatorBar is a DrawableObject to display indicators. The indicator bar positions and draws attached Indicators.

Constructor & Destructor Documentation

IndicatorBar::IndicatorBar ( )

IndicatorBar::~IndicatorBar ( ) [virtual]

Member Function Documentation

void IndicatorBar::AddIndicator ( Indicator * indicator )

Adds an Indicator to this IndicatorBar.

const IndicatorBarID& IndicatorBar::GetId ( ) [inline]

Returns indicator bar Id.

XYDIM IndicatorBar::GetIndicatorbarExpansion ( )

Get the expansion of this IndicatorBar.

IndicatorBarView::IndicatorBarOrientation IndicatorBar::GetOrientation ( )

Returns the indicatorbar's orientation.

Desktop::SectionType IndicatorBar::GetSection ( ) const [inline]

Returns section type.

DrawableObjectView * IndicatorBar::GetView ( ) const [virtual]

Returns the view for this IndicatorBar.

Reimplemented from Component.

void IndicatorBar::Init | ( | const IndicatorBarID & | id,
 |  | Control * | control,
 |  | Desktop::SectionType | section,
 |  | BOOLEAN | auto_draw = TRUE
 | ) |

BOOLEAN IndicatorBar::IsEmpty ( ) const [inline]

Returns true, if no indicator contained.

BOOLEAN IndicatorBar::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage()

Reimplemented from Component.

void IndicatorBar::OnUpdate ( ObservableObject * obs_obj ) [protected, virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from Observer.

void IndicatorBar::RemoveAllIndicators ( )

Removes all Indicators from this IndicatorBar.

void IndicatorBar::RemoveIndicator ( Indicator * indicator )

Removes an Indicator from this IndicatorBar.

void IndicatorBar::SetIndicatorbarExpansion ( XYDIM indicatorbar_expansion )

Set the expansion of this IndicatorBar.

Friends And Related Function Documentation

friend class IndicatorBarView [friend]

The documentation for this class was generated from the following files:
  • Compat/IndicatorBar.hpp
  • Compat/IndicatorBar.cpp
Generated on Wed Jan 25 01:20:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndicatorBarPaneObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndicatorBarPaneObject Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/IndicatorPaneObject.hpp>

Inheritance diagram for IndicatorBarPaneObject:

[legend]
Collaboration diagram for IndicatorBarPaneObject:

[legend]

Public Member Functions

virtual void | Draw (DeviceContext *dc)
Draws the indicatorBar on the given screen position.
IndicatorBarPaneObject ()
Constructs an IndicatorBar object with a given position and alignment.
void | Init (IndicatorBar *indicator_bar, const Rect &bounding_rect=Rect())
virtual | ~IndicatorBarPaneObject ()

Constructor & Destructor Documentation

IndicatorBarPaneObject::IndicatorBarPaneObject ( )

Constructs an IndicatorBar object with a given position and alignment.

IndicatorBarPaneObject::~IndicatorBarPaneObject ( ) [virtual]

Member Function Documentation

void IndicatorBarPaneObject::Draw ( DeviceContext * dc ) [virtual]

Draws the indicatorBar on the given screen position.

Reimplemented from PaneObject.

void IndicatorBarPaneObject::Init | ( | IndicatorBar * | indicator_bar,
 |  | const Rect & | bounding_rect = Rect()
 | ) |

The documentation for this class was generated from the following files:
  • Compat/IndicatorPaneObject.hpp
  • Compat/IndicatorPaneObject.cpp
Generated on Wed Jan 25 01:20:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndicatorBarUpdateMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndicatorBarUpdateMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for IndicatorBarUpdateMsg:

[legend]
Collaboration diagram for IndicatorBarUpdateMsg:

[legend]

Public Types

enum | { ID = 13000 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
IndicatorBarUpdateMsg ()
virtual | ~IndicatorBarUpdateMsg ()

Detailed Description

This message is sent from OnUpdate() of Class IndicatorBar to MmiWindow whenever indicator Bar is updated, which also means a indicator has been updated in the IndicatorBar.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

IndicatorBarUpdateMsg::IndicatorBarUpdateMsg ( )

IndicatorBarUpdateMsg::~IndicatorBarUpdateMsg ( ) [virtual]

Member Function Documentation

Message * IndicatorBarUpdateMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & IndicatorBarUpdateMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 01:20:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndicatorBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndicatorBarView Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/IndicatorBar.hpp>

Inheritance diagram for IndicatorBarView:

[legend]
Collaboration diagram for IndicatorBarView:

[legend]

Public Types

enum | IndicatorBarOrientation { horizontal = 0, vertical = 1 }

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
IndicatorBarView ()
virtual | ~IndicatorBarView ()

Member Enumeration Documentation

enum IndicatorBarView::IndicatorBarOrientation

Enumerator:
horizontal
vertical

Constructor & Destructor Documentation

IndicatorBarView::IndicatorBarView ( )

IndicatorBarView::~IndicatorBarView ( ) [virtual]

Member Function Documentation

void IndicatorBarView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

The documentation for this class was generated from the following files:
  • Compat/IndicatorBar.hpp
  • Compat/IndicatorBar.cpp
Generated on Wed Jan 25 01:20:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndicatorDescription Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndicatorDescription Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/IndicatorDescription.hpp>

Collaboration diagram for IndicatorDescription:

[legend]

Public Member Functions

const IndicatorID & | GetIndicatorId () const
Returns the indicator id.
const IndicatorLocation & | GetIndicatorLocation () const
Returns the position relative to the alignment of the indicator.
IndicatorDescription (const IndicatorID &id, const IndicatorLocation &pos)
IndicatorDescription ()
void | Init (const IndicatorID &id, const IndicatorLocation &pos)
void | SetIndicatorId (const IndicatorID &id)
Set the indicator id.
void | SetIndicatorLocation (const IndicatorLocation &pos)
Sets the indicator position.
~IndicatorDescription ()

Constructor & Destructor Documentation

IndicatorDescription::IndicatorDescription ( )

IndicatorDescription::IndicatorDescription | ( | const IndicatorID & | id,
 |  | const IndicatorLocation & | pos
 | ) |

IndicatorDescription::~IndicatorDescription ( )

Member Function Documentation

const IndicatorID& IndicatorDescription::GetIndicatorId ( ) const [inline]

Returns the indicator id.

const IndicatorLocation& IndicatorDescription::GetIndicatorLocation ( ) const [inline]

Returns the position relative to the alignment of the indicator.

void IndicatorDescription::Init | ( | const IndicatorID & | id,
 |  | const IndicatorLocation & | pos
 | ) |

void IndicatorDescription::SetIndicatorId ( const IndicatorID & id ) [inline]

Set the indicator id.

void IndicatorDescription::SetIndicatorLocation ( const IndicatorLocation & pos ) [inline]

Sets the indicator position.

The documentation for this class was generated from the following files:
  • Compat/IndicatorDescription.hpp
  • Compat/IndicatorDescription.cpp
Generated on Wed Jan 25 01:21:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndicatorItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndicatorItem Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/IndicatorItem.hpp>

Inheritance diagram for IndicatorItem:

[legend]
Collaboration diagram for IndicatorItem:

[legend]

Public Types

enum | { ID = 102 }

Public Member Functions

virtual BOOLEAN | Execute ()
const PropertyDescriptor * | GetDescriptor () const
IndicatorItem (Property *property, const WString &text, const ImageObtainer &icon)
IndicatorItem (Property *property, PropertyDescriptor *descriptor)
IndicatorItem (Property *property)
IndicatorItem ()
void | Init (Property *property, const WString &text="", const ImageObtainer &icon=ImageObtainer())
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetDescriptor (PropertyDescriptor *descriptor)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual void | Update ()
Sets text and icon of the vaue item according to the specified property descriptor.
virtual | ~IndicatorItem ()

Detailed Description

Like its base class feature item, a value item encapsulates a feature. However, value items are restricted to hold features of type Property, because the property represents the actual value of a value item. Further, a PropertyDescriptor can be specified for a value item, in order to specify the representation of the properties value.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from FeatureItem.

Constructor & Destructor Documentation

IndicatorItem::IndicatorItem ( )

IndicatorItem::IndicatorItem ( Property * property )

IndicatorItem::IndicatorItem | ( | Property * | property,
 |  | PropertyDescriptor * | descriptor
 | ) |

IndicatorItem::IndicatorItem | ( | Property * | property,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon
 | ) |

IndicatorItem::~IndicatorItem ( ) [virtual]

Member Function Documentation

BOOLEAN IndicatorItem::Execute ( ) [virtual]

Simple value items can not be triggered. Thus, this method returns TRUE.

Reimplemented from FeatureItem.

const PropertyDescriptor * IndicatorItem::GetDescriptor ( ) const

Returns:
Property descriptor of this item

void IndicatorItem::Init | ( | Property * | property,
 |  | const WString & | text = "",
 |  | const ImageObtainer & | icon = ImageObtainer()
 | ) |

BOOLEAN IndicatorItem::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from FeatureItem.

void IndicatorItem::SetDescriptor ( PropertyDescriptor * descriptor )

Parameters:
descriptor For changing the property descriptor of this item

BOOLEAN IndicatorItem::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from FeatureItem.

void IndicatorItem::Update ( ) [virtual]

Sets text and icon of the vaue item according to the specified property descriptor.

Reimplemented from FeatureItem.

The documentation for this class was generated from the following files:
  • Atl/Features/IndicatorItem.hpp
  • Atl/Features/IndicatorItem.cpp
Generated on Wed Jan 25 01:21:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndicatorLocation Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndicatorLocation Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/IndicatorDescription.hpp>

Collaboration diagram for IndicatorLocation:

[legend]

Public Types

enum | Alignment { Start = 0, Middle = 1, End = 2 }
Alignment point of the indicator. More...

Public Member Functions

BOOLEAN | DisplayOnGlassPane () const
Return true, if the indicator has to be shown on the glass pane.
Alignment | GetAlignment () const
Returns the alignment of the indicator on the indicator bar.
const Point & | GetGlassPanePosition () const
Returns the position of the indicator on the glass pane.
const IndicatorBarID & | GetIndicatorBarId () const
Returns the indicator bar where to draw the indicator.
INT | GetIndicatorBarPosition () const
Returns the position relative to the alignment of the indicator on the indicator bar.
IndicatorLocation (const Point &glass_pane_pos)
IndicatorLocation (const IndicatorBarID &barId, Alignment align, INT pos)
IndicatorLocation ()
void | SetAlignment (Alignment align)
Sets the alignment of the indicator on the indicator bar.
void | SetGlassPanePosition (const Point &pos)
Sets the indicator position on the glass pane.
void | SetIndicatorBarId (const IndicatorBarID &barId)
Set the indicator bar where to draw the indicator.
void | SetIndicatorBarPosition (INT pos)
Sets the indicator position on the indicator bar.
~IndicatorLocation ()

Detailed Description

The position of the indicator depends on the alignment. Smaller positions are more left than higher positions. Position 0 indicates the point of the alignment, i.e. an indicator aligned to Center with position 0 will stay in the absolute center of the indicator bar. Therefor positions less than 0 should be used for indicators left to the alignment point, positions larger than 0 should be used for indicator placement right to the alignment point. This involves, that in dicators aligned to Right should be positioned with numbers less than 0 or 0 where position 0 is the most right position.

Member Enumeration Documentation

enum IndicatorLocation::Alignment

Alignment point of the indicator.

Enumerator:
Start
Middle
End

Constructor & Destructor Documentation

IndicatorLocation::IndicatorLocation ( )

IndicatorLocation::IndicatorLocation | ( | const IndicatorBarID & | barId,
 |  | Alignment | align,
 |  | INT | pos
 | ) |

IndicatorLocation::IndicatorLocation ( const Point & glass_pane_pos )

IndicatorLocation::~IndicatorLocation ( )

Member Function Documentation

BOOLEAN IndicatorLocation::DisplayOnGlassPane ( ) const [inline]

Return true, if the indicator has to be shown on the glass pane.

Alignment IndicatorLocation::GetAlignment ( ) const [inline]

Returns the alignment of the indicator on the indicator bar.

const Point& IndicatorLocation::GetGlassPanePosition ( ) const [inline]

Returns the position of the indicator on the glass pane.

const IndicatorBarID& IndicatorLocation::GetIndicatorBarId ( ) const [inline]

Returns the indicator bar where to draw the indicator.

INT IndicatorLocation::GetIndicatorBarPosition ( ) const [inline]

Returns the position relative to the alignment of the indicator on the indicator bar.

void IndicatorLocation::SetAlignment ( Alignment align ) [inline]

Sets the alignment of the indicator on the indicator bar.

void IndicatorLocation::SetGlassPanePosition ( const Point & pos ) [inline]

Sets the indicator position on the glass pane.

void IndicatorLocation::SetIndicatorBarId ( const IndicatorBarID & barId ) [inline]

Set the indicator bar where to draw the indicator.

void IndicatorLocation::SetIndicatorBarPosition ( INT pos ) [inline]

Sets the indicator position on the indicator bar.

The documentation for this class was generated from the following files:
  • Compat/IndicatorDescription.hpp
  • Compat/IndicatorDescription.cpp
Generated on Wed Jan 25 01:21:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IndicatorPaneObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IndicatorPaneObject Class Reference
[APOXI Template Layer]

#include <Apoxi/Compat/IndicatorPaneObject.hpp>

Inheritance diagram for IndicatorPaneObject:

[legend]
Collaboration diagram for IndicatorPaneObject:

[legend]

Public Member Functions

virtual void | Draw (DeviceContext *dc)
Draws the indicator on the given screen position.
IndicatorPaneObject ()
Constructs an Indicator object with the given position and alignment.
void | Init (Indicator *indicator, const Rect &bounding_rect=Rect())
virtual void | OnUpdate (ObservableObject *obs_obj)
virtual | ~IndicatorPaneObject ()

Constructor & Destructor Documentation

IndicatorPaneObject::IndicatorPaneObject ( )

Constructs an Indicator object with the given position and alignment.

IndicatorPaneObject::~IndicatorPaneObject ( ) [virtual]

Member Function Documentation

void IndicatorPaneObject::Draw ( DeviceContext * dc ) [virtual]

Draws the indicator on the given screen position.

Reimplemented from PaneObject.

void IndicatorPaneObject::Init | ( | Indicator * | indicator,
 |  | const Rect & | bounding_rect = Rect()
 | ) |

void IndicatorPaneObject::OnUpdate ( ObservableObject * obs_obj ) [virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from Observer.

The documentation for this class was generated from the following files:
  • Compat/IndicatorPaneObject.hpp
  • Compat/IndicatorPaneObject.cpp
Generated on Wed Jan 25 01:21:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InetSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InetSocket Class Reference
[Socket]

#include <Apoxi/Socket/InetSocket.hpp>

Inheritance diagram for InetSocket:

[legend]
Collaboration diagram for InetSocket:

[legend]

Public Types

enum | ShutdownMode { c_shutdown_stop_rx = SysSocket::c_shutdown_stop_rx, c_shutdown_stop_tx = SysSocket::c_shutdown_stop_tx, c_shutdown_stop_rx_tx = SysSocket::c_shutdown_stop_rx_tx }
enum | Type { c_type_dgram = SysSocket::c_type_dgram, c_type_stream = SysSocket::c_type_stream, c_type_raw = SysSocket::c_type_raw, c_type_default = c_type_dgram }

Public Member Functions

BOOLEAN | Bind (const InetSocketAddr &addr)
virtual BOOLEAN | Close ()
DataConnProfileId | GetDataConnProfileId () const
SocketError | GetError () const
INT | GetInBufByteCount ()
BOOLEAN | GetLocal (InetSocketAddr &addr)
ExecutionContext * | GetOwnerContext () const
BOOLEAN | GetPeer (InetSocketAddr &addr)
BOOLEAN | GetSoBroadcastOption (BOOLEAN &broadcast)
BOOLEAN | GetSoDebugOption (BOOLEAN &dbg)
BOOLEAN | GetSoDontRouteOption (BOOLEAN &dont_route)
BOOLEAN | GetSoKeepAliveOption (BOOLEAN &keep_alive)
BOOLEAN | GetSoLingerOption (SysSocket::LingerSetting &linger_setting)
BOOLEAN | GetSoRcvBufOption (INT &bufsize)
BOOLEAN | GetSoReuseAddrOption (BOOLEAN &reuse)
BOOLEAN | GetSoSndBufOption (INT &bufsize)
BOOLEAN | GetSoTypeOption (Type &type)
virtual BOOLEAN | IsBlocking () const
BOOLEAN | IsDataConnEstablished () const
virtual BOOLEAN | IsOpen () const
virtual BOOLEAN | SetBlocking (BOOLEAN block=FALSE)
BOOLEAN | SetDataConnProfileId (DataConnProfileId id) const
void | SetReadEventNotification (BOOLEAN enable)
BOOLEAN | SetSoBroadcastOption (BOOLEAN broadcast)
BOOLEAN | SetSoDebugOption (BOOLEAN dbg)
BOOLEAN | SetSoDontRouteOption (BOOLEAN dont_route)
BOOLEAN | SetSoKeepAliveOption (BOOLEAN keep_alive)
BOOLEAN | SetSoLingerOption (const SysSocket::LingerSetting &linger_setting)
BOOLEAN | SetSoRcvBufOption (INT bufsize)
BOOLEAN | SetSoReuseAddrOption (BOOLEAN reuse)
BOOLEAN | SetSoSndBufOption (INT bufsize)
BOOLEAN | Shutdown (ShutdownMode how)
virtual | ~InetSocket ()

Protected Types

typedef SysSocket::OptionType | OptionType

Protected Member Functions

void | Attach (SocketData *sd)
void | Detach ()
BOOLEAN | EnsureContext ()
BOOLEAN | GetBoolOption (OptionType type, BOOLEAN &val)
SocketData * | GetSd () const
BOOLEAN | HandOver (InetSocket &to_socket)
InetSocket ()
virtual void | OnAsyncEvent (Event event)
virtual void | OnControlMsg (const SocketControlMsg &msg)=0
BOOLEAN | Open (Type type, const InetSocketAddr *local_addr, BOOLEAN may_reuse_addr)
virtual INT | Read (void *buf, INT buflen)
INT | Read (void *buf, INT buflen, InetSocketAddr *from)
void | ResetDataConnIdleTimer () const
BOOLEAN | SetBoolOption (OptionType type, BOOLEAN val)
BOOLEAN | SetError (SocketError err)
BOOLEAN | SetError (BOOLEAN ok)
BOOLEAN | SetupDataConn ()
BOOLEAN | WaitForDataRecv ()
BOOLEAN | WaitForDataSent ()
virtual INT | Write (const void *buf, INT buflen)
INT | Write (const void *buf, INT buflen, const InetSocketAddr *to)

Protected Attributes

BOOLEAN | m_read_event_notification
SocketData * m_sd

Friends

class | SocketHandler
class | TcpServerSocket

Detailed Description

InetSocket is the abstract base class of specific socket implementations. APOXI sockets are based on a BSD socket interface and extend it with functionality like asynchronous event notifications.

Member Typedef Documentation

typedef SysSocket::OptionType InetSocket::OptionType [protected]

Member Enumeration Documentation

enum InetSocket::ShutdownMode

ShutdownMode specifies how a socket should be shut down.

See also:
Shutdown().
Enumerator:
c_shutdown_stop_rx | Shutdown receiving.
c_shutdown_stop_tx | Shutdown transmitting.
c_shutdown_stop_rx_tx | Shutdown receiving and transmitting.

enum InetSocket::Type

Type specifies the socket type requested.

See also:
GetSoTypeOption()
Enumerator:
c_type_dgram | UDP socket.
c_type_stream | TCP socket.
c_type_raw | RAW socket.
c_type_default | The default socket type is UDP.

Constructor & Destructor Documentation

InetSocket::~InetSocket ( ) [virtual]

InetSocket::InetSocket ( ) [protected]

Member Function Documentation

void InetSocket::Attach ( SocketData * sd ) [protected]

BOOLEAN InetSocket::Bind ( const InetSocketAddr & addr )

Binds the socket to the specified local address.

BOOLEAN InetSocket::Close ( ) [virtual]

Closes the socket.

Implements Socket.

void InetSocket::Detach ( ) [protected]

BOOLEAN InetSocket::EnsureContext ( ) [protected]

BOOLEAN InetSocket::GetBoolOption | ( | OptionType | type,
 |  | BOOLEAN & | val
 | ) | [protected]

DataConnProfileId InetSocket::GetDataConnProfileId ( ) const

Returns the ID of the data connection (profile) that the socket will use for transferring data.

SocketError InetSocket::GetError ( ) const [inline]

If a socket operation failed GetError() returns the cause for the error. The error code is not reset by calling GetError(). As error causes differ between different system socket implementations, a common subset of error codes has been chosen. If c_socket_unknown_error is returned then a system specific error code occurred.

Reimplemented in UdpNetAdapter, and TcpNetAdapter.

INT InetSocket::GetInBufByteCount ( )

Returns the number of bytes that can be read from the socket.

Returns:
Number of bytes that can be read or -1 on failure.

Reimplemented in UdpNetAdapter, and TcpNetAdapter.

BOOLEAN InetSocket::GetLocal ( InetSocketAddr & addr )

Gets the local address explicitly defined by SysSocket::Bind() or implicitly defined by other socket functions like SysSocket::Connect(), SysSocket::Send(), SysSocket::SendTo(), etc.

ExecutionContext * InetSocket::GetOwnerContext ( ) const

Returns the execution context which owns the socket.

BOOLEAN InetSocket::GetPeer ( InetSocketAddr & addr )

Gets the address of the peer.

SocketData* InetSocket::GetSd ( ) const [inline, protected]

BOOLEAN InetSocket::GetSoBroadcastOption ( BOOLEAN & broadcast ) [inline]

Retrieves the socket broadcast option. This option allows the transmission of broadcast messages on the socket.

BOOLEAN InetSocket::GetSoDebugOption ( BOOLEAN & dbg ) [inline]

Retrieves the socket debug option.

BOOLEAN InetSocket::GetSoDontRouteOption ( BOOLEAN & dont_route ) [inline]

Retrieves the socket routing option

BOOLEAN InetSocket::GetSoKeepAliveOption ( BOOLEAN & keep_alive ) [inline]

Retrieves the socket keep alive option.

BOOLEAN InetSocket::GetSoLingerOption ( SysSocket::LingerSetting & linger_setting ) [inline]

Retrieves the socket linger option.

BOOLEAN InetSocket::GetSoRcvBufOption ( INT & bufsize ) [inline]

Retrieves the socket receive buffer option. This option specifies the buffer size of receive/read operations.

BOOLEAN InetSocket::GetSoReuseAddrOption ( BOOLEAN & reuse ) [inline]

Retrieves the socket reuse address option. This option allows the local address to be bound by multiple sockets.

BOOLEAN InetSocket::GetSoSndBufOption ( INT & bufsize ) [inline]

Retrieves the socket send buffer option. This option specifies the buffer size of send/write operations.

BOOLEAN InetSocket::GetSoTypeOption ( Type & type )

Retrieves the socket type option.

BOOLEAN InetSocket::HandOver ( InetSocket & to_socket ) [protected]

Hands over itself to to_socket. This socket is then reverted to closed state and hence does not operate any more. Instead, to_socket continues operation. This method should only be used to hand over a socket between execution contexts if needed. Note that if you hand over a socket from one execution context to another, also the execution context to which to_socket belongs must have initialized a socket handler. For the hand over to succeed this socket must be in open state and to_socket must be in closed state. If the hand over can not be performed FALSE is returned.

See also:
ExecutionContext

SocketHandler

Returns:
Success of hand over.

BOOLEAN InetSocket::IsBlocking ( ) const [virtual]

Tells if the socket is in blocking mode.

Implements Socket.

BOOLEAN InetSocket::IsDataConnEstablished ( ) const [inline]

Tells if the data connection has been established according to the data connection profile settings. The data connection does not refer to the connected state of the socket but to if the bearer (data call, GPRS attach, Bluetooth link, etc.) for the data transfer has been setup correctly.

virtual BOOLEAN InetSocket::IsOpen ( void ) const [inline, virtual]

Checks if the socket is open.

Implements Socket.

virtual void InetSocket::OnAsyncEvent ( Event event ) [inline, protected, virtual]

Receives the notification of an asynchronous event. The event types are dependent on the socket type, some events are only sent for connection oriented sockets or for server sockets (please see the enumeration Event). A client who uses sockets has to derive an own socket class and implement this method in order to listen to the events that occur on the socket and to react on it according to its communication policy.

Reimplemented in FtpDataServerSocket, FtpDataSocket, FtpServerSocket, FtpSocket, HttpServerSocket, HttpSocket, LcsSocket, RegTcpSocket, TcpServerTestSocket, TcpTestSocket, and UdpTestSocket.

virtual void InetSocket::OnControlMsg ( const SocketControlMsg & msg ) [protected, pure virtual]

Translates the socket control message msg into a socket event and routes it accordingly. If a listener is set, its OnSocketEvent method is called. Otherwise the messages are discarded.

Reimplemented from Socket.

Implemented in TcpServerSocket, TcpSocket, and UdpSocket.

BOOLEAN InetSocket::Open | ( | Type | type,
 |  | const InetSocketAddr * | local_addr,
 |  | BOOLEAN | may_reuse_addr
 | ) | [protected]

Opens the socket. No operations on a socket are allowed unless it has been opened before. After closing the socket, the socket must be opened again to use it again.

virtual INT InetSocket::Read | ( | void * | buf,
 |  | INT | buflen
 | ) | [inline, protected, virtual]

Reads data from the socket.

Parameters:
buf | Pointer to read buffer.
buflen | Length of read buffer.
Returns:
Number of bytes written or -1 on failure.

Implements Socket.

Reimplemented in TcpSocket.

INT InetSocket::Read | ( | void * | buf,
 |  | INT | buflen,
 |  | InetSocketAddr * | from
 | ) | [protected]

Reads data from the socket. For connectionless sockets (UDP) the from parameter may be specified for retrieving the source address. For connection-oriented sockets (TCP) parameter from has to be 0.

Returns:
Number of bytes read or -1 on failure.

Reimplemented in UdpNetAdapter, TcpNetAdapter, and UdpSocket.

void InetSocket::ResetDataConnIdleTimer ( ) const [protected]

Resets the idle timer of the associated data connection. If there is activity on this socket then the idle timer of the data connection must be reset.

BOOLEAN InetSocket::SetBlocking ( BOOLEAN block = FALSE ) [virtual]

Enables/disables blocking mode on sockets. Changing blocking mode with pending Read() or Write() requests may produce unpredictable results. Using APOXI sockets in blocking mode is depreciated, APOXI sockets default to non-blocking mode. Socket events are sent to the socket independent of the blocking mode.

Implements Socket.

BOOLEAN InetSocket::SetBoolOption | ( | OptionType | type,
 |  | BOOLEAN | val
 | ) | [protected]

BOOLEAN InetSocket::SetDataConnProfileId ( DataConnProfileId id ) const

Sets the ID of the data connection (profile) that the socket will use for transferring data. Changing the data connection (profile) ID on an active (i.e. connected) socket may cause unpredictable results.

BOOLEAN InetSocket::SetError ( SocketError err ) [inline, protected]

BOOLEAN InetSocket::SetError ( BOOLEAN ok ) [inline, protected]

void InetSocket::SetReadEventNotification ( BOOLEAN enable )

Enables or disables the read notification mechanism (enabled per default). If enabled socket activity on the read-FD_SET is notified by OnAsyncEvent() to the user. Based on the socket type the event can be incoming data, close of connection, etc.. If disabled, no asynchronous event based on the read-FD_SET will be fired at all.

Please note: If the sockets are used in the recommended way, there is no need to use this method.

BOOLEAN InetSocket::SetSoBroadcastOption ( BOOLEAN broadcast ) [inline]

Sets the socket broadcast option. This option allows the transmission of broadcast messages on the socket.

BOOLEAN InetSocket::SetSoDebugOption ( BOOLEAN dbg ) [inline]

Sets the socket debug option.

BOOLEAN InetSocket::SetSoDontRouteOption ( BOOLEAN dont_route ) [inline]

Sets the socket routing option.

BOOLEAN InetSocket::SetSoKeepAliveOption ( BOOLEAN keep_alive ) [inline]

Sets socket keep alive option.

BOOLEAN InetSocket::SetSoLingerOption ( const SysSocket::LingerSetting & linger_setting ) [inline]

Sets socket linger option.

BOOLEAN InetSocket::SetSoRcvBufOption ( INT bufsize ) [inline]

Sets the socket receive buffer option. This option specifies the buffer size of receive/read operations.

BOOLEAN InetSocket::SetSoReuseAddrOption ( BOOLEAN reuse ) [inline]

Sets the socket reuse address option. This option allows the local address to be bound by multiple sockets.

BOOLEAN InetSocket::SetSoSndBufOption ( INT bufsize ) [inline]

Sets the socket send buffer option. This option specifies the buffer size of send/write operations.

BOOLEAN InetSocket::SetupDataConn ( ) [protected]

BOOLEAN InetSocket::Shutdown ( ShutdownMode how )

Shuts down the socket.

BOOLEAN InetSocket::WaitForDataRecv ( ) [inline, protected]

BOOLEAN InetSocket::WaitForDataSent ( ) [inline, protected]

virtual INT InetSocket::Write | ( | const void * | buf,
 |  | INT | buflen
 | ) | [inline, protected, virtual]

Writes data to the socket.

Parameters:
buf | Pointer to write buffer.
buflen | Length of write buffer.
Returns:
Number of bytes written or -1 on failure.

Implements Socket.

Reimplemented in TcpSocket, and LcsSocket.

INT InetSocket::Write | ( | const void * | buf,
 |  | INT | buflen,
 |  | const InetSocketAddr * | to
 | ) | [protected]

Writes data to the socket. For connectionless sockets (UDP) the to parameter may specify a destination address. If it is not specified, then the data is sent to the sockets default destination address previously established. For connection-oriented sockets (TCP) parameter to has to be 0.

Returns:
Number of bytes written or -1 on failure.

Reimplemented in UdpSocket.

Friends And Related Function Documentation

friend class SocketHandler [friend]

Reimplemented from Socket.

friend class TcpServerSocket [friend]

Reimplemented in FtpDataServerSocket.

Field Documentation

BOOLEAN InetSocket::m_read_event_notification [protected]

SocketData* InetSocket::m_sd [protected]

The documentation for this class was generated from the following files:
  • Socket/InetSocket.hpp
  • Socket/InetSocket.cpp
Generated on Wed Jan 25 01:21:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InetSocketAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InetSocketAddr Class Reference
[Socket]

#include <Apoxi/Socket/InetSocketAddr.hpp>

Collaboration diagram for InetSocketAddr:

[legend]

Public Member Functions

IpAddr | GetIpAddr () const
IpPortNo | GetPortNo () const
InetSocketAddr (const IpAddr &ip=IpAddr(), const IpPortNo &port=IpPortNo())
void | SetIpAddr (const IpAddr &ip)
void | SetPortNo (const IpPortNo &port)
String | Verbose () const

Constructor & Destructor Documentation

InetSocketAddr::InetSocketAddr | ( | const IpAddr & | ip = IpAddr(),
 |  | const IpPortNo & | port = IpPortNo()
 | ) |

Member Function Documentation

IpAddr InetSocketAddr::GetIpAddr ( ) const [inline]

IpPortNo InetSocketAddr::GetPortNo ( ) const [inline]

void InetSocketAddr::SetIpAddr ( const IpAddr & ip ) [inline]

void InetSocketAddr::SetPortNo ( const IpPortNo & port ) [inline]

String InetSocketAddr::Verbose ( ) const

The documentation for this class was generated from the following files:
  • Socket/InetSocketAddr.hpp
  • Socket/InetSocketAddr.cpp
Generated on Wed Jan 25 01:21:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InfoDialog Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InfoDialog Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

Dialog showing some information only. More...

#include <Applications/ImageBrowser/Common/InfoDialog.hpp>

Collaboration diagram for InfoDialog:

[legend]

Public Member Functions

InfoDialog ()
InfoDialog ()
void | Init ()
void | Init ()
void | SetText (const WString &text)
Sets the text in the text box.
void | SetText (const WString &text)
Sets the text in the text box.
virtual | ~InfoDialog ()
virtual | ~InfoDialog ()

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnLayoutClient ()

Detailed Description

Dialog showing some information only.

Constructor & Destructor Documentation

InfoDialog::InfoDialog ( )

InfoDialog::~InfoDialog ( ) [virtual]

InfoDialog::InfoDialog ( )

virtual InfoDialog::~InfoDialog ( ) [virtual]

Member Function Documentation

void InfoDialog::Init ( )

void InfoDialog::Init ( )

virtual BOOLEAN InfoDialog::OnConfirm ( ) [protected, virtual]

See also:
Window::OnConfirm

BOOLEAN InfoDialog::OnConfirm ( ) [protected, virtual]

See also:
Window::OnConfirm

virtual void InfoDialog::OnLayoutClient ( ) [protected, virtual]

See also:
Window::OnLayoutClient

void InfoDialog::OnLayoutClient ( ) [protected, virtual]

See also:
Window::OnLayoutClient

void InfoDialog::SetText ( const WString & text )

Sets the text in the text box.

void InfoDialog::SetText ( const WString & text )

Sets the text in the text box.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/InfoDialog.hpp
  • Applications/SoundBrowser/Common/InfoDialog.hpp
  • Applications/ImageBrowser/Common/InfoDialog.cpp
  • Applications/SoundBrowser/Common/InfoDialog.cpp
Generated on Wed Jan 25 01:21:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InformationElement Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InformationElement Class Reference

#include <Apoxi/Apc/InformationElement.hpp>

Public Types

enum ExtendedObjectType {
EOPredefinedSound = 0x00, EOiMelody = 0x01, EOBWBitmap = 0x02, EOTwoBitGrayScale = 0x03,
EOSixBitGrayScale = 0x04, EOPredefinedAnimation = 0x05, EOBWBitmapAnimation = 0x06, EOTwoBitGrayScaleAnimation = 0x07,
EOSixBitGrayScaleAnimation = 0x08, EOvCard = 0x09, EOvCalendar = 0x0A, EOStdWVGObject = 0x0B,
EOPolyphonicMelody = 0x0C, EODataFormatDeliveryRequest = 0xFF
}
Defined Extended Object types in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.13]. More...
enum | FontSize { Default = 0, Large = 1, Small = 2, Reserved = 3 }
Defined font sizes in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1]. More...
enum Identifier {
ConcatenatedSm8Bit = 0x00, SpecialSms = 0x01, ValueNotUsed = 0x03, AddressingScheme8Bit = 0x04,
AddressingScheme16Bit = 0x05, SmscControl = 0x06, UdhSourceIndicator = 0x07, ConcatenatedSm16Bit = 0x08,
WirelessControlMessageProtocol = 0x09, TextFormatting = 0x0a, PredefinedSound = 0x0b, UserDefinedSound = 0x0c,
PredefinedAnimation = 0x0d, LargeAnimation = 0x0e, SmallAnimation = 0x0f, LargePicture = 0x10,
SmallPicture = 0x11, VariablePicture = 0x12, UserPromptIndicator = 0x13, ExtendedObject = 0x14,
ReusedExtendedObject = 0x15, CompressionControl = 0x16, ObjectDistributionIndicator = 0x17, Rfc822EmailHeader = 0x20,
HyperlinkFormatElement = 0x21, ReservedIdentifier, InvalidIdentifier, ContinuedExtendedObject = (ExtendedObject | 0x80)
}
enum | MessageType { VoiceMessage = 0, FaxMessage = 1, ElectronicMail = 2, OtherMessage = 3 }
Message Types defined in 3GPP TS 23.040 V5.1.0 [9.2.3.24.2]. More...
enum PredefinedAnimationType {
IAmIronic = 0, IAmGlad = 1, IAmSceptic = 2, IAmSad = 3,
Wow = 4, IAmCrying = 5, IAmWinking = 6, IAmLaughing = 7,
IAmIndifferent = 8, Kissing = 9, IAmConfused = 10, TongueHangingOut = 11,
IAmAngry = 12, WearingGlasses = 13, Devil = 14
}
Predefined Animations defined in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.3.3]. More...
enum PredefinedSoundType {
ChimesHigh = 0, ChimesLow = 1, Ding = 2, TaDa = 3,
Notify = 4, Drum = 5, Claps = 6, FanFar = 7,
ChordHigh = 8, ChordLow = 9
}
Predefined Sounds defined in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.3.1]. More...
enum | TextAlignment { Left = 0, Center = 1, Right = 2, LanguageDependend = 3 }
Defined text alignment in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1]. More...
enum TextColour {
Black = 0, DarkGrey = 1, DarkRed = 2, DarkYellow = 3,
DarkGreen = 4, DarkCyan = 5, DarkBlue = 6, DarkMagenta = 7,
Grey = 8, White = 9, BrightRed = 10, BrightYellow = 11,
BrightGreen = 12, BrightCyan = 13, BrightBlue = 14, BrightMagenta = 15
}
Defined font sizes in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1]. More...

Public Member Functions

void | CopyTo (UINT8 *destination) const
SmsPortNo | GetAddressingScheme16BitDestinationPort () const
SmsPortNo | GetAddressingScheme16BitOriginatorPort () const
SmsPortNo | GetAddressingScheme8BitDestinationPort () const
SmsPortNo | GetAddressingScheme8BitOriginatorPort () const
UINT8 | GetConcatenatedSm16BitMaximumNumber () const
UINT16 | GetConcatenatedSm16BitReferenceNumber () const
UINT8 | GetConcatenatedSm16BitSequenceNumber () const
UINT8 | GetConcatenatedSm8BitMaximumNumber () const
UINT8 | GetConcatenatedSm8BitReferenceNumber () const
UINT8 | GetConcatenatedSm8BitSequenceNumber () const
UINT8 * | GetData (INT idx) const
UINT8 * | GetData () const
UINT8 * | GetExtendedObjectBuffer () const
BOOLEAN | GetExtendedObjectControlDataMayBeForw () const
BOOLEAN | GetExtendedObjectControlDataUserPrompt () const
UINT16 | GetExtendedObjectLength () const
UINT16 | GetExtendedObjectPosition () const
UINT8 | GetExtendedObjectReferenceNumber () const
InformationElement::ExtendedObjectType | GetExtendedObjectType () const
UINT16 | GetHyperlinkFormatElementAbsolutStartPosition () const
HyperlinkFormatElement.
UINT8 | GetHyperlinkFormatElementTitelLength () const
UINT8 | GetHyperlinkFormatElementUrlLength () const
Identifier | GetIdentifier () const
UINT8 * | GetLargeAnimationBuffer () const
UINT8 | GetLargeAnimationLength () const
UINT8 | GetLargeAnimationStartPosition () const
UINT8 * | GetLargePictureBuffer () const
UINT8 | GetLargePictureLength () const
UINT8 | GetLargePictureStartPosition () const
UINT8 | GetLength () const
UINT8 | GetPredefinedAnimationStartPosition () const
PredefinedAnimationType | GetPredefinedAnimationType () const
UINT8 | GetPredefinedSoundStartPosition () const
PredefinedSoundType | GetPredefinedSoundType () const
UINT16 | GetReusedExtendedObjectPosition () const
UINT8 | GetReusedExtendedObjectReferenceNumber () const
UINT8 | GetRfc822EmailHeaderLength () const
Rfc822EmailHeader.
UINT8 * | GetSmallAnimationBuffer () const
UINT8 | GetSmallAnimationLength () const
UINT8 | GetSmallAnimationStartPosition () const
UINT8 * | GetSmallPictureBuffer () const
UINT8 | GetSmallPictureLength () const
UINT8 | GetSmallPictureStartPosition () const
UINT8 | GetSpecialSmsMessageCount () const
UINT8 | GetSpecialSmsMessageIndicationType () const
SpecialSms.
MessageType | GetSpecialSmsMessageType () const
TextColour | GetTextFormattingBackgroundColour () const
UINT8 | GetTextFormattingColour () const
FontSize | GetTextFormattingFontSize () const
TextColour | GetTextFormattingForegroundColour () const
UINT8 | GetTextFormattingLength () const
UINT8 | GetTextFormattingMode () const
UINT8 | GetTextFormattingStartPosition () const
TextAlignment | GetTextFormattingTextAlignment () const
UINT8 * | GetUserDefinedSoundBuffer () const
UINT8 | GetUserDefinedSoundLength () const
UINT8 | GetUserDefinedSoundStartPosition () const
UINT8 | GetUserPromptIndicatorNumberCorrespondingObjects () const
UserPromptIndicator.
UINT8 * | GetVariablePictureBuffer () const
UINT8 | GetVariablePictureHorizontalDimension () const
UINT8 | GetVariablePictureLength () const
UINT8 | GetVariablePictureStartPosition () const
UINT8 | GetVariablePictureVerticalDimension () const
UINT8 * | GetWirelessControlMessageProtocolBuffer () const
WirelessControlMessageProtocol.
UINT8 | GetWirelessControlMessageProtocolLength () const
InformationElement (UINT8 *anchor)
InformationElement ()
BOOLEAN | IsBold () const
BOOLEAN | IsItalic () const
BOOLEAN | IsStrikethrough () const
BOOLEAN | IsUnderlined () const
BOOLEAN | IsValid () const
InformationElement & | operator= (const InformationElement &ie)
BOOLEAN | PutAddressingScheme16Bit (SmsPortNo destport, SmsPortNo orgport)
AddressingScheme16Bit.
BOOLEAN | PutAddressingScheme8Bit (SmsPortNo destport, SmsPortNo orgport)
AddressingScheme8Bit.
BOOLEAN | PutConcatenatedSm16Bit (UINT16 refno, UINT8 maxno, UINT8 seqno)
ConcatenatedSm16Bit methods.
BOOLEAN | PutConcatenatedSm8Bit (UINT8 refno, UINT8 maxno, UINT8 seqno)
ConcatenatedSm8Bit methods.
BOOLEAN | PutContinuedExtendedObject (UINT8 length, const UINT8 *extended_object_buffer)
BOOLEAN | PutEmsRelativeStartPosition (UINT8 startpos)
Common Ems.
BOOLEAN | PutExtendedObject (UINT16 startpos, UINT8 ref_no, BOOLEAN may_be_forw, BOOLEAN handled_as_user_prompt, InformationElement::ExtendedObjectType type, UINT8 length, UINT16 complete_length, const UINT8 *extended_object_buffer)
ExtendedObject.
BOOLEAN | PutLargeAnimation (UINT8 startpos, const UINT8 *animation)
LargeAnimation.
BOOLEAN | PutLargePicture (UINT8 startpos, const UINT8 *picture)
LargePicture.
BOOLEAN | PutPredefinedAnimation (UINT8 startpos, PredefinedAnimationType animation)
PredefinedAnimation.
BOOLEAN | PutPredefinedSound (UINT8 startpos, PredefinedSoundType sound)
PredefinedSound.
BOOLEAN | PutReusedExtendedObject (UINT16 startpos, UINT8 ref_no)
ReusedExtendedObject.
BOOLEAN | PutSmallAnimation (UINT8 startpos, const UINT8 *animation)
SmallAnimation.
BOOLEAN | PutSmallPicture (UINT8 startpos, const UINT8 *picture)
SmallPicture.
BOOLEAN | PutTextFormatting (UINT8 startpos, UINT8 length, InformationElement::TextAlignment alignment, InformationElement::FontSize fontsize, BOOLEAN bold, BOOLEAN italic, BOOLEAN underlined, BOOLEAN strikethrough, InformationElement::TextColour foreground, InformationElement::TextColour background)
BOOLEAN | PutTextFormatting (UINT8 startpos, UINT8 length, UINT8 mode, UINT8 colour)
TextFormatting.
BOOLEAN | PutUserDefinedSound (UINT8 startpos, UINT8 length, const UINT8 *sound)
UserDefinedSound.
BOOLEAN | PutVariablePicture (UINT8 startpos, UINT8 horiz, UINT8 vert, UINT8 length, const UINT8 *picture)
VariablePicture.
BOOLEAN | SetConcatenatedSmMaximumNumber (UINT8 maxno)
BOOLEAN | SetConcatenatedSmReferenceNumber (UINT16 refno)
generel methods for concatenation IE
BOOLEAN | SetConcatenatedSmSequenceNumber (UINT8 seqno)
BOOLEAN | SetIdentifier (Identifier id)
Sets the identifier id but no data (length = 0).
BOOLEAN | ShallStoreMessage () const
~InformationElement ()

Static Public Member Functions

static UINT16 | GetSize (Identifier id, UINT16 additional=0)

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.3.24.1 - 9.2.3.24.12]

Member Enumeration Documentation

enum InformationElement::ExtendedObjectType

Defined Extended Object types in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.13].

Enumerator:
EOPredefinedSound
EOiMelody
EOBWBitmap
EOTwoBitGrayScale
EOSixBitGrayScale
EOPredefinedAnimation
EOBWBitmapAnimation
EOTwoBitGrayScaleAnimation
EOSixBitGrayScaleAnimation
EOvCard
EOvCalendar
EOStdWVGObject
EOPolyphonicMelody
EODataFormatDeliveryRequest ...

enum InformationElement::FontSize

Defined font sizes in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1].

Enumerator:
Default
Large
Small
Reserved

enum InformationElement::Identifier

Enumerator:
ConcatenatedSm8Bit | Concatenated short message, 8-bit reference number.
SpecialSms | Special SMS message indication.
ValueNotUsed | Value not used to avoid misinterpretion as <LF> character.
AddressingScheme8Bit | Application port addessing scheme, 8-bit address.
AddressingScheme16Bit | Application port addessing scheme, 16-bit address.
SmscControl | SMSC (Sms Centre) Control Parameters.
UdhSourceIndicator | UDH source indicator.
ConcatenatedSm16Bit | Concatenated short message, 16-bit reference number.
WirelessControlMessageProtocol | Wireless control message protocol.
TextFormatting | Text formatting.
PredefinedSound | Predefined sound.
UserDefinedSound | User defined sound (iMelody max. 128 bytes).
PredefinedAnimation | Predifined animation.
LargeAnimation | Large animation (16 * 16 times 4 = 32 * 4 = 128 bytes).
SmallAnimation | Small animation (8 * 8 times 4 = 8 * 4 = 32 bytes).
LargePicture | Large picture (32 * 32 = 128 bytes).
SmallPicture | Small picture (16 * 16 = 32 bytes).
VariablePicture | Variable picture.
UserPromptIndicator | User prompt indicator.
ExtendedObject | Extended object.
ReusedExtendedObject | Reused extended object.
CompressionControl | Compression control.
ObjectDistributionIndicator | Object distribution indicator.
Rfc822EmailHeader | RFC 822 e-mail header.
HyperlinkFormatElement | Hyperlink format element.
ReservedIdentifier | Reserved.
InvalidIdentifier | Invalid.
ContinuedExtendedObject

enum InformationElement::MessageType

Message Types defined in 3GPP TS 23.040 V5.1.0 [9.2.3.24.2].

Enumerator:
VoiceMessage
FaxMessage
ElectronicMail
OtherMessage

enum InformationElement::PredefinedAnimationType

Predefined Animations defined in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.3.3].

Enumerator:
IAmIronic
IAmGlad
IAmSceptic
IAmSad
Wow
IAmCrying
IAmWinking
IAmLaughing
IAmIndifferent
Kissing
IAmConfused
TongueHangingOut
IAmAngry
WearingGlasses
Devil

enum InformationElement::PredefinedSoundType

Predefined Sounds defined in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.3.1].

Enumerator:
ChimesHigh
ChimesLow
Ding
TaDa
Notify
Drum
Claps
FanFar
ChordHigh
ChordLow

enum InformationElement::TextAlignment

Defined text alignment in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1].

Enumerator:
Left
Center
Right
LanguageDependend

enum InformationElement::TextColour

Defined font sizes in 3GPP TS 23.040 V5.1.0 [9.2.3.24.10.1.1].

Enumerator:
Black
DarkGrey
DarkRed
DarkYellow
DarkGreen
DarkCyan
DarkBlue
DarkMagenta
Grey
White
BrightRed
BrightYellow
BrightGreen
BrightCyan
BrightBlue
BrightMagenta

Constructor & Destructor Documentation

InformationElement::InformationElement ( )

InformationElement::InformationElement ( UINT8 * anchor )

InformationElement::~InformationElement ( )

Member Function Documentation

void InformationElement::CopyTo ( UINT8 * destination ) const

SmsPortNo InformationElement::GetAddressingScheme16BitDestinationPort ( ) const

SmsPortNo InformationElement::GetAddressingScheme16BitOriginatorPort ( ) const

SmsPortNo InformationElement::GetAddressingScheme8BitDestinationPort ( ) const

SmsPortNo InformationElement::GetAddressingScheme8BitOriginatorPort ( ) const

UINT8 InformationElement::GetConcatenatedSm16BitMaximumNumber ( ) const

UINT16 InformationElement::GetConcatenatedSm16BitReferenceNumber ( ) const

UINT8 InformationElement::GetConcatenatedSm16BitSequenceNumber ( ) const

UINT8 InformationElement::GetConcatenatedSm8BitMaximumNumber ( ) const

UINT8 InformationElement::GetConcatenatedSm8BitReferenceNumber ( ) const

UINT8 InformationElement::GetConcatenatedSm8BitSequenceNumber ( ) const

UINT8 * InformationElement::GetData ( INT idx ) const

UINT8 * InformationElement::GetData ( ) const

UINT8 * InformationElement::GetExtendedObjectBuffer ( ) const

BOOLEAN InformationElement::GetExtendedObjectControlDataMayBeForw ( ) const

BOOLEAN InformationElement::GetExtendedObjectControlDataUserPrompt ( ) const

UINT16 InformationElement::GetExtendedObjectLength ( ) const

UINT16 InformationElement::GetExtendedObjectPosition ( ) const

UINT8 InformationElement::GetExtendedObjectReferenceNumber ( ) const

InformationElement::ExtendedObjectType InformationElement::GetExtendedObjectType ( ) const

UINT16 InformationElement::GetHyperlinkFormatElementAbsolutStartPosition ( ) const

HyperlinkFormatElement.

UINT8 InformationElement::GetHyperlinkFormatElementTitelLength ( ) const

UINT8 InformationElement::GetHyperlinkFormatElementUrlLength ( ) const

InformationElement::Identifier InformationElement::GetIdentifier ( ) const

UINT8 * InformationElement::GetLargeAnimationBuffer ( ) const

UINT8 InformationElement::GetLargeAnimationLength ( ) const

UINT8 InformationElement::GetLargeAnimationStartPosition ( ) const

UINT8 * InformationElement::GetLargePictureBuffer ( ) const

UINT8 InformationElement::GetLargePictureLength ( ) const

UINT8 InformationElement::GetLargePictureStartPosition ( ) const

UINT8 InformationElement::GetLength ( ) const

UINT8 InformationElement::GetPredefinedAnimationStartPosition ( ) const

InformationElement::PredefinedAnimationType InformationElement::GetPredefinedAnimationType ( ) const

UINT8 InformationElement::GetPredefinedSoundStartPosition ( ) const

InformationElement::PredefinedSoundType InformationElement::GetPredefinedSoundType ( ) const

UINT16 InformationElement::GetReusedExtendedObjectPosition ( ) const

UINT8 InformationElement::GetReusedExtendedObjectReferenceNumber ( ) const

UINT8 InformationElement::GetRfc822EmailHeaderLength ( ) const

Rfc822EmailHeader.

UINT16 InformationElement::GetSize | ( | Identifier | id,
 |  | UINT16 | additional = 0
 | ) | [static]

UINT8 * InformationElement::GetSmallAnimationBuffer ( ) const

UINT8 InformationElement::GetSmallAnimationLength ( ) const

UINT8 InformationElement::GetSmallAnimationStartPosition ( ) const

UINT8 * InformationElement::GetSmallPictureBuffer ( ) const

UINT8 InformationElement::GetSmallPictureLength ( ) const

UINT8 InformationElement::GetSmallPictureStartPosition ( ) const

UINT8 InformationElement::GetSpecialSmsMessageCount ( ) const

UINT8 InformationElement::GetSpecialSmsMessageIndicationType ( ) const

SpecialSms.

InformationElement::MessageType InformationElement::GetSpecialSmsMessageType ( ) const

InformationElement::TextColour InformationElement::GetTextFormattingBackgroundColour ( ) const

UINT8 InformationElement::GetTextFormattingColour ( ) const

InformationElement::FontSize InformationElement::GetTextFormattingFontSize ( ) const

InformationElement::TextColour InformationElement::GetTextFormattingForegroundColour ( ) const

UINT8 InformationElement::GetTextFormattingLength ( ) const

UINT8 InformationElement::GetTextFormattingMode ( ) const

UINT8 InformationElement::GetTextFormattingStartPosition ( ) const

InformationElement::TextAlignment InformationElement::GetTextFormattingTextAlignment ( ) const

UINT8 * InformationElement::GetUserDefinedSoundBuffer ( ) const

UINT8 InformationElement::GetUserDefinedSoundLength ( ) const

UINT8 InformationElement::GetUserDefinedSoundStartPosition ( ) const

UINT8 InformationElement::GetUserPromptIndicatorNumberCorrespondingObjects ( ) const

UserPromptIndicator.

UINT8 * InformationElement::GetVariablePictureBuffer ( ) const

UINT8 InformationElement::GetVariablePictureHorizontalDimension ( ) const

UINT8 InformationElement::GetVariablePictureLength ( ) const

UINT8 InformationElement::GetVariablePictureStartPosition ( ) const

UINT8 InformationElement::GetVariablePictureVerticalDimension ( ) const

UINT8 * InformationElement::GetWirelessControlMessageProtocolBuffer ( ) const

WirelessControlMessageProtocol.

UINT8 InformationElement::GetWirelessControlMessageProtocolLength ( ) const

BOOLEAN InformationElement::IsBold ( ) const

BOOLEAN InformationElement::IsItalic ( ) const

BOOLEAN InformationElement::IsStrikethrough ( ) const

BOOLEAN InformationElement::IsUnderlined ( ) const

BOOLEAN InformationElement::IsValid ( ) const

InformationElement & InformationElement::operator= ( const InformationElement & ie )

BOOLEAN InformationElement::PutAddressingScheme16Bit | ( | SmsPortNo | destport,
 |  | SmsPortNo | orgport
 | ) |

AddressingScheme16Bit.

BOOLEAN InformationElement::PutAddressingScheme8Bit | ( | SmsPortNo | destport,
 |  | SmsPortNo | orgport
 | ) |

AddressingScheme8Bit.

BOOLEAN InformationElement::PutConcatenatedSm16Bit | ( | UINT16 | refno,
 |  | UINT8 | maxno,
 |  | UINT8 | seqno
 | ) |

ConcatenatedSm16Bit methods.

BOOLEAN InformationElement::PutConcatenatedSm8Bit | ( | UINT8 | refno,
 |  | UINT8 | maxno,
 |  | UINT8 | seqno
 | ) |

ConcatenatedSm8Bit methods.

BOOLEAN InformationElement::PutContinuedExtendedObject | ( | UINT8 | length,
 |  | const UINT8 * | extended_object_buffer
 | ) |

BOOLEAN InformationElement::PutEmsRelativeStartPosition ( UINT8 startpos )

Common Ems.

BOOLEAN InformationElement::PutExtendedObject | ( | UINT16 | startpos,
 |  | UINT8 | ref_no,
 |  | BOOLEAN | may_be_forw,
 |  | BOOLEAN | handled_as_user_prompt,
 |  | InformationElement::ExtendedObjectType | type,
 |  | UINT8 | length,
 |  | UINT16 | complete_length,
 |  | const UINT8 * | extended_object_buffer
 | ) |

ExtendedObject.

BOOLEAN InformationElement::PutLargeAnimation | ( | UINT8 | startpos,
 |  | const UINT8 * | animation
 | ) |

LargeAnimation.

BOOLEAN InformationElement::PutLargePicture | ( | UINT8 | startpos,
 |  | const UINT8 * | picture
 | ) |

LargePicture.

BOOLEAN InformationElement::PutPredefinedAnimation | ( | UINT8 | startpos,
 |  | PredefinedAnimationType | animation
 | ) |

PredefinedAnimation.

BOOLEAN InformationElement::PutPredefinedSound | ( | UINT8 | startpos,
 |  | PredefinedSoundType | sound
 | ) |

PredefinedSound.

BOOLEAN InformationElement::PutReusedExtendedObject | ( | UINT16 | startpos,
 |  | UINT8 | ref_no
 | ) |

ReusedExtendedObject.

BOOLEAN InformationElement::PutSmallAnimation | ( | UINT8 | startpos,
 |  | const UINT8 * | animation
 | ) |

SmallAnimation.

BOOLEAN InformationElement::PutSmallPicture | ( | UINT8 | startpos,
 |  | const UINT8 * | picture
 | ) |

SmallPicture.

BOOLEAN InformationElement::PutTextFormatting | ( | UINT8 | startpos,
 |  | UINT8 | length,
 |  | InformationElement::TextAlignment | alignment,
 |  | InformationElement::FontSize | fontsize,
 |  | BOOLEAN | bold,
 |  | BOOLEAN | italic,
 |  | BOOLEAN | underlined,
 |  | BOOLEAN | strikethrough,
 |  | InformationElement::TextColour | foreground,
 |  | InformationElement::TextColour | background
 | ) |

BOOLEAN InformationElement::PutTextFormatting | ( | UINT8 | startpos,
 |  | UINT8 | length,
 |  | UINT8 | mode,
 |  | UINT8 | colour
 | ) |

TextFormatting.

BOOLEAN InformationElement::PutUserDefinedSound | ( | UINT8 | startpos,
 |  | UINT8 | length,
 |  | const UINT8 * | sound
 | ) |

UserDefinedSound.

BOOLEAN InformationElement::PutVariablePicture | ( | UINT8 | startpos,
 |  | UINT8 | horiz,
 |  | UINT8 | vert,
 |  | UINT8 | length,
 |  | const UINT8 * | picture
 | ) |

VariablePicture.

BOOLEAN InformationElement::SetConcatenatedSmMaximumNumber ( UINT8 maxno )

BOOLEAN InformationElement::SetConcatenatedSmReferenceNumber ( UINT16 refno )

generel methods for concatenation IE

BOOLEAN InformationElement::SetConcatenatedSmSequenceNumber ( UINT8 seqno )

BOOLEAN InformationElement::SetIdentifier ( Identifier id )

Sets the identifier id but no data (length = 0).

BOOLEAN InformationElement::ShallStoreMessage ( ) const

The documentation for this class was generated from the following files:
  • Apc/InformationElement.hpp
  • Apc/InformationElement.cpp
Generated on Wed Jan 25 01:21:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for InputAction:

[legend]
Collaboration diagram for InputAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &, const InputContext *)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
virtual InputActionType | GetActionType () const
Returns the type of the action.
INT | GetParsePriority () const
const WString & | GetSourceString () const
Returns the complete source string if analyzing was successfull.
virtual BOOLEAN | HasWrongSyntax ()
Returns if Action is syntactical correct, especially n be called, that means if the input string is analyzed correctly.
InputAction ()
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
virtual BOOLEAN | ShallExecuteImmediatly ()
Returns if Execute can be called immediatly without confirmation with an additional key (e.g SEND).
virtual | ~InputAction ()

Protected Member Functions

void | Clear ()

Static Protected Member Functions

static INT | ParseNumber (const WCHAR *str, INT maxdigits=255)

Protected Attributes

WString m_sourcestring
BOOLEAN | m_syntaxerror

Detailed Description

em>InputAction is the base class for all input action classes. This garantuees an extendable system for analyzing inputstrings especially for the idle screen.

Constructor & Destructor Documentation

InputAction::InputAction ( )

InputAction::~InputAction ( ) [virtual]

Member Function Documentation

InputAction * InputAction::Analyze | ( | const WString & | ,
 |  | const InputContext * |
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented in PbEntryShowAction, UnlockAction, MoCallAction, ImeiShowAction, EngModeAction, CallSsAction, PinAction, ClirAction, NumberIdentificationAction, BarringSsAction, EmlppAction, PasswordChangeSsAction, ForwardingSsAction, WaitSsAction, UndefinedSsAction, UssdAction, ApoxiCommandAction, and LanguageResetAction.

void InputAction::Clear ( ) [inline, protected]

BOOLEAN InputAction::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented in UnlockAction, SsPasswordChangeActionImpl, SsCallBarringActionImpl, SsCallForwardingActionImpl, SsCallWaitingActionImpl, SsClirActionImpl, SsClipActionImpl, SsColrActionImpl, SsColpActionImpl, SsCnapActionImpl, SsUssdActionImpl, and SsEmlppActionImpl.

InputActionType InputAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented in PbEntryShowAction, UnlockAction, MoCallAction, ImeiShowAction, EngModeAction, CallSsAction, PinAction, ClirAction, ClipAction, CnapAction, ColpAction, ColrAction, BarringSsAction, EmlppAction, PasswordChangeSsAction, ForwardingSsAction, WaitSsAction, UndefinedSsAction, UssdAction, ApoxiCommandAction, and LanguageResetAction.

INT InputAction::GetParsePriority ( ) const [inline]

const WString& InputAction::GetSourceString ( ) const [inline]

Returns the complete source string if analyzing was successfull.

BOOLEAN InputAction::HasWrongSyntax ( ) [virtual]

Returns if Action is syntactical correct, especially n be called, that means if the input string is analyzed correctly.

BOOLEAN InputAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented in PbEntryShowAction, UnlockAction, MoCallAction, ImeiShowAction, EngModeAction, CallSsAction, PinAction, ClirAction, NumberIdentificationAction, BarringSsAction, EmlppAction, PasswordChangeSsAction, ForwardingSsAction, WaitSsAction, UndefinedSsAction, UssdAction, ApoxiCommandAction, and LanguageResetAction.

INT InputAction::ParseNumber | ( | const WCHAR * | str,
 |  | INT | maxdigits = 255
 | ) | [static, protected]

BOOLEAN InputAction::ShallExecuteImmediatly ( ) [virtual]

Returns if Execute can be called immediatly without confirmation with an additional key (e.g SEND).

Reimplemented in PbEntryShowAction, ImeiShowAction, EngModeAction, PinAction, and LanguageResetAction.

Field Documentation

WString InputAction::m_sourcestring [protected]

BOOLEAN InputAction::m_syntaxerror [protected]

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:21:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputActionList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputActionList Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAnalyzer.hpp>

Inheritance diagram for InputActionList:

[legend]
Collaboration diagram for InputActionList:

[legend]

Public Member Functions

InputActionList ()
void RegisterInputAction (InputAction *action)
Allows registration of an InputAction object to the list.

Detailed Description

InputActionList is a container class which contains a list of pointers to InputActions. InputActions are registered via RegisterInputAction to the list. Several instances of InputActionList can exist. The InputActions themselves must be instanced seperately and can be registered to more then one InputActionList.

Constructor & Destructor Documentation

InputActionList::InputActionList ( ) [inline]

Member Function Documentation

void InputActionList::RegisterInputAction ( InputAction * action )

Allows registration of an InputAction object to the list.

The documentation for this class was generated from the following files:
  • Asc/InputAnalyzer.hpp
  • Asc/InputAnalyzer.cpp
Generated on Wed Jan 25 01:21:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputActionPtr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputActionPtr Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAnalyzer.hpp>

Inheritance diagram for InputActionPtr:

[legend]
Collaboration diagram for InputActionPtr:

[legend]

Public Member Functions

InputAction * GetInputAction ()
InputActionPtr (InputAction *action)
InputActionPtr ()
BOOLEAN | operator< (const InputActionPtr &ptr) const
BOOLEAN | operator== (const InputActionPtr &ptr) const

Constructor & Destructor Documentation

InputActionPtr::InputActionPtr ( ) [inline]

InputActionPtr::InputActionPtr ( InputAction * action ) [inline, explicit]

Member Function Documentation

InputAction* InputActionPtr::GetInputAction ( ) [inline]

BOOLEAN InputActionPtr::operator< ( const InputActionPtr & ptr ) const [inline]

BOOLEAN InputActionPtr::operator== ( const InputActionPtr & ptr ) const [inline]

The documentation for this class was generated from the following file:
  • Asc/InputAnalyzer.hpp
Generated on Wed Jan 25 01:21:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputAnalyzer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputAnalyzer Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAnalyzer.hpp>

Collaboration diagram for InputAnalyzer:

[legend]

Public Member Functions

InputAction * | GetFirstInputAction (const WString &actionstring, const InputContext *context=0)
Finds the first InputAction that matches actionstring or returns zero if non matches.
void | Init (const InputActionList *actionlist)
InputAnalyzer (const InputActionList *actionlist)
Constructor must be initialized with an InputActionList.
InputAnalyzer ()
~InputAnalyzer ()

Static Public Member Functions

static BOOLEAN | IsStorableMocPhoneNumber (const PhoneNumber &phno)

Detailed Description

InputAnalyzer uses exactly one InputActionList for iterating over all possible actionobjects. Start of the iteration is done with GetFirstInputAction. GetNextInputAction will deliver the next possible action object(s) that matches the actionstring. If one of the both returns zero the lookup procedure is finished.

Constructor & Destructor Documentation

InputAnalyzer::InputAnalyzer ( ) [inline]

InputAnalyzer::InputAnalyzer ( const InputActionList * actionlist ) [explicit]

Constructor must be initialized with an InputActionList.

InputAnalyzer::~InputAnalyzer ( )

Member Function Documentation

InputAction * InputAnalyzer::GetFirstInputAction | ( | const WString & | actionstring,
 |  | const InputContext * | context = 0
 | ) |

Finds the first InputAction that matches actionstring or returns zero if non matches.

void InputAnalyzer::Init ( const InputActionList * actionlist )

BOOLEAN InputAnalyzer::IsStorableMocPhoneNumber ( const PhoneNumber & phno ) [static]

The documentation for this class was generated from the following files:
  • Asc/InputAnalyzer.hpp
  • Asc/InputAnalyzer.cpp
Generated on Wed Jan 25 01:21:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputCharMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputCharMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for InputCharMsg:

[legend]
Collaboration diagram for InputCharMsg:

[legend]

Public Types

enum | { ID = 220 }

Public Member Functions

virtual Message * | Clone () const
WCHAR | GetCharacter () const
virtual const MsgMetaData & | GetMetaData () const
InputCharMsg (WCHAR character)
void | SetCharacter (WCHAR character)
virtual | ~InputCharMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

InputCharMsg::InputCharMsg ( WCHAR character )

InputCharMsg::~InputCharMsg ( ) [virtual]

Member Function Documentation

Message * InputCharMsg::Clone ( ) const [virtual]

Implements Message.

WCHAR InputCharMsg::GetCharacter ( ) const [inline]

const MsgMetaData & InputCharMsg::GetMetaData ( ) const [virtual]

Implements Message.

void InputCharMsg::SetCharacter ( WCHAR character ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:21:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputContext Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAnalyzer.hpp>

Public Member Functions

BOOLEAN | ActiveCallExists () const
BOOLEAN | CallInSetupExists () const
BOOLEAN | HeldCallExists () const
InputContext (Application *application, BOOLEAN msp, BOOLEAN ace, BOOLEAN hce, BOOLEAN cse=FALSE)
InputContext (Application *application)
InputContext ()
BOOLEAN | IsCingularActive () const
BOOLEAN | IsMocSetupPermitted () const
void | SetCingularActive (BOOLEAN active=TRUE)
BOOLEAN | Update ()
Updates the current state inside the input context object.
~InputContext ()

Detailed Description

InputContext describes the states which might be necessary for analyzing the input string, for example the call state.

Constructor & Destructor Documentation

InputContext::InputContext ( )

InputContext::InputContext ( Application * application ) [explicit]

InputContext::InputContext | ( | Application * | application,
 |  | BOOLEAN | msp,
 |  | BOOLEAN | ace,
 |  | BOOLEAN | hce,
 |  | BOOLEAN | cse = FALSE
 | ) |

InputContext::~InputContext ( )

Member Function Documentation

BOOLEAN InputContext::ActiveCallExists ( ) const [inline]

BOOLEAN InputContext::CallInSetupExists ( ) const [inline]

BOOLEAN InputContext::HeldCallExists ( ) const [inline]

BOOLEAN InputContext::IsCingularActive ( ) const [inline]

BOOLEAN InputContext::IsMocSetupPermitted ( ) const [inline]

void InputContext::SetCingularActive ( BOOLEAN active = TRUE ) [inline]

BOOLEAN InputContext::Update ( )

Updates the current state inside the input context object.

The documentation for this class was generated from the following files:
  • Asc/InputAnalyzer.hpp
  • Asc/InputAnalyzer.cpp
Generated on Wed Jan 25 01:21:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputMap Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputMap Struct Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Collaboration diagram for InputMap:

[legend]

Public Member Functions

InputMapId | GetTriggeredMessage (InputMapControlId map_id, const InputMapItem &item) const

Data Fields

InputMapEntry * m_map_entry
INT | m_size

Member Function Documentation

InputMapId InputMap::GetTriggeredMessage | ( | InputMapControlId | map_id,
 |  | const InputMapItem & | item
 | ) | const

Field Documentation

InputMapEntry* InputMap::m_map_entry

INT InputMap::m_size

The documentation for this struct was generated from the following files:
  • Kernel/InputMap.hpp
  • Kernel/InputMap.cpp
Generated on Wed Jan 25 01:21:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputMapEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputMapEntry Struct Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Data Fields

InputMapControlId | m_input_map_control_id
InputMapId | m_input_map_id

Field Documentation

InputMapControlId InputMapEntry::m_input_map_control_id

InputMapId InputMapEntry::m_input_map_id

The documentation for this struct was generated from the following file:
  • Kernel/InputMap.hpp
Generated on Wed Jan 25 01:21:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputMapItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputMapItem Class Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Inheritance diagram for InputMapItem:

[legend]

Public Types

enum MapItemType {
KeyDownType, KeyAutoRepeatType, KeyUpType, LongKeyPressType,
InputCharType
}

Public Member Functions

InputMapItem (MapItemType type)
MapItemType Type () const

Member Enumeration Documentation

enum InputMapItem::MapItemType

Defines the Type of the InputMapItem. TYPE_KEY_DOWN - for any KeyDown event
TYPE_KEY_UP - for any KeyUp event
TYPE_KEY_AUTO_REPEAT - for auto-repeated key events (uses the KeyDownInputMap) TYPE_LONG_KEY_PRESS - for any LongKeyPress event (uses the KeyDownInputMap)

Enumerator:
KeyDownType
KeyAutoRepeatType
KeyUpType
LongKeyPressType
InputCharType

Constructor & Destructor Documentation

InputMapItem::InputMapItem ( MapItemType type ) [inline]

Member Function Documentation

MapItemType InputMapItem::Type ( ) const [inline]

The documentation for this class was generated from the following file:
  • Kernel/InputMap.hpp
Generated on Wed Jan 25 01:21:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputMapper Class Reference
[Editors]

#include <Apoxi/Gui/InputMapper.hpp>

Inheritance diagram for InputMapper:

[legend]
Collaboration diagram for InputMapper:

[legend]

Public Types

enum | Alphabet { UndefinedAlphabet = 0, SevenBitAlphabet = 1, EightBitAlphabet = 2, Ucs2Alphabet = 3 }
enum Id {
Numeric = 0, MultiTap = 1, MultiTab = MultiTap, PhoneNumber = 2,
Predictive = 3, Date = 4, Time = 5, Calculator = 6,
IpAddress = 7, Zi8 = 8, Url = 9, EMailAddress = 10,
T9 = 11, Name = 12, Custom = 99
}
enum | NotificationType { InsertedItem = 0, UpdatedContent = 1, SetText = 1 }

Public Member Functions

virtual Alphabet | GetAlphabet () const
virtual Caret * | GetCaret ()
virtual INT | GetId () const =0
InputMapper (AbstractEditor *editor=0)
virtual BOOLEAN | IsContentValid () const
virtual BOOLEAN | Notify (NotificationType type, INT index=0, const AtomItem *item=0)
virtual void | SetEditor (AbstractEditor *editor)
virtual | ~InputMapper ()

Protected Member Functions

const AbstractEditor * | GetEditor () const
Returns the editor the input mapper belongs too.
AbstractEditor * GetEditor ()
Returns the editor the input mapper belongs too.
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual BOOLEAN | OnKeyUp (KeyCode key_code, UINT32 duration)
virtual BOOLEAN | OnLongKeyPress (KeyCode key_code)
virtual void | OnLoseFocus ()

Protected Attributes

Caret * m_caret

Friends

class | AbstractEditor
class | AbstractMultiLineEditor

Detailed Description

The editors use the input mapper for interpreting pressed keys to modify the content of the document. E. g. when pressing the key 2 a numeric input mapper inserts the number 2 into the document. The input mapper also takes care to navigate the caret of the editor.

Every input mapper has a unique ID which represents one of the following input mapper-classification: Numeric, MultiTap, PhoneNumber, Predictive, Date, Time, Calculator and Custom. The IDs 0 to 99 are reserved for APOXI, the IDs from 100 to 999 are reserved for ATL and third party applications. IDs starting from 1000 are open for customer projects.

The editors only deal with the ID of an input mapper. Which instance is returned for which ID is specified in the factory method EditConfig::AllocInputMapper, which may be customized for projects. This approach allows the implementation of custom input mappers without the need to modify the applications.

Member Enumeration Documentation

enum InputMapper::Alphabet

Alphabet corresponding to 3GPP TS 23038 V430 (2001-09). Every input mapper may support one kind of alphabet (see GetAlphabet).

Enumerator:
UndefinedAlphabet
SevenBitAlphabet
EightBitAlphabet
Ucs2Alphabet

enum InputMapper::Id

The IDs 0 to 99 are reserved for APOXI, the IDs from 100 to 999 are reserved for IDEA and third party applications. IDs starting from 1000 are open for customer projects.

Enumerator:
Numeric | Allows to input numeric numbers from 0 to 9.
MultiTap | Allows to input characters by the multi tap input method. The multi tap table can be configured depending from the locale settings inside the class LocaleConfig.
MultiTab | Deprecated - use MultiTap instead (it was a spelling mistake).
PhoneNumber | Allows to input a phone number including the numbers 0 to 9 and the characters + and #.
Predictive | Predictive input (e. g. T9 or Zi8). It depends on EditConfig::AllocInputMapper which instance of an input mapper is returned. Using 'Predictive' instead of 'T9' or 'Zi8' is useful when the application should not rely on a specific input method.
Date | Allows to input a date. The date format can be specified depending from the locale settings inside the class LocaleConfig. This input mapper ID is used per default for the editor DateEditor.
Time | Allows to input a time. The date format can be specified depending from the locale settings inside the class LocaleConfig. This input mapper ID is used per default for the editor TimeEditor.
Calculator | Allows to input characters useful for a calculator (0 - 9, +, -, /, *).
IpAddress | Allows to input an IP address. This input mapper ID is used per default for the editor IpAddressEditor.
Zi8 | Uses the predictive input eZi text.
Url | Allows to enter an URL. APOXI does not offer a default implementation for this input mapper ID.
EMailAddress | Allows to enter an e-mail address. APOXI does not offer a default implementation for this input mapper ID.
T9 | Uses the predictive input method T9.
Name | Allows to enter a name.
Custom | Defined for custom input mappers. Note that the IDs 100 to 999 are reserved for ATL and third party applications.

enum InputMapper::NotificationType

Enumerator:
InsertedItem
UpdatedContent
SetText Obsolete - use UpdatedContent instead.

Constructor & Destructor Documentation

InputMapper::InputMapper ( AbstractEditor * editor = 0 ) [explicit]

Parameters:
editor Pointer to the editor the input mapper belongs too.

InputMapper::~InputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet InputMapper::GetAlphabet ( ) const [virtual]

Returns:
Used alphabet corresponding to 3GPP TS 23038 V430 (2001-09). Per default UndefinedAlphabet is returned.

Reimplemented in ChineseT9InputMapper, EnglishT9InputMapper, CalculatorInputMapper, DateTimeInputMapper, IpAddrInputMapper, MultiTapInputMapper, NumericInputMapper, and PhoneNumberInputMapper.

Caret * InputMapper::GetCaret ( ) [virtual]

Factory method for creating the Caret. Use following implementation when using an own Caret:
if (m_caret == 0)
m_caret = new XxxCaret(GetEditor());
return m_caret
.

Reimplemented in MultiTapInputMapper.

const AbstractEditor* InputMapper::GetEditor ( ) const [inline, protected]

Returns the editor the input mapper belongs too.

AbstractEditor* InputMapper::GetEditor ( ) [inline, protected]

Returns the editor the input mapper belongs too.

virtual INT InputMapper::GetId ( ) const [pure virtual]

Returns the unique input mapper ID. See also InputMapper::Id.

Implemented in T9InputMapper, Zi8InputMapper, CalculatorInputMapper, DateTimeInputMapper, IpAddrInputMapper, MultiTapInputMapper, NumericInputMapper, and PhoneNumberInputMapper.

BOOLEAN InputMapper::IsContentValid ( ) const [virtual]

Checks, whether the content of the editor is valid corresponding to the rules defined by the input mapper. Per default TRUE is returned. An invalid content can be made by e. g. directly inserting items into the editor-document.

BOOLEAN InputMapper::Notify | ( | NotificationType | type,
 |  | INT | index = 0,
 |  | const AtomItem * | item = 0
 | ) | [virtual]

Is invoked by the editor, if an item has been inserted or the content of the editor has been changed. Overwriting this method allows the input mapper to synchronize its buffer with the editor-content.

Reimplemented in T9InputMapper, and Zi8InputMapper.

void InputMapper::OnGetFocus ( ) [protected, virtual]

Is invoked by the editor if it has got the focus. This allows the input mapper to customize the look or to reset some properties.

Reimplemented in DateTimeInputMapper, and IpAddrInputMapper.

BOOLEAN InputMapper::OnKeyDown ( KeyCode key_code ) [protected, virtual]

Is invoked by the editor when a key has been pressed.

Reimplemented in CalculatorInputMapper, DateTimeInputMapper, IpAddrInputMapper, MultiTapInputMapper, NumericInputMapper, PhoneNumberInputMapper, and PredInputMapper.

BOOLEAN InputMapper::OnKeyUp | ( | KeyCode | key_code,
 |  | UINT32 | duration
 | ) | [protected, virtual]

Is invoked by the editor when a key has been released.

Reimplemented in T9InputMapper, and Zi8InputMapper.

BOOLEAN InputMapper::OnLongKeyPress ( KeyCode key_code ) [protected, virtual]

Is invoked by the editor when a key has been a long time. It is assured that InputMapper::OnKeyDown with the matching key code is invoked before.

Reimplemented in T9InputMapper, Zi8InputMapper, and PhoneNumberInputMapper.

void InputMapper::OnLoseFocus ( ) [protected, virtual]

Is invoked by the editor if it has lost the focus. This allows the input mapper to customize the look or to reset some properties.

Reimplemented in DateTimeInputMapper, and IpAddrInputMapper.

void InputMapper::SetEditor ( AbstractEditor * editor ) [virtual]

Parameters:
editor Pointer to the editor the input mapper should belong too. */

Reimplemented in T9InputMapper, Zi8InputMapper, DateTimeInputMapper, IpAddrInputMapper, and MultiTapInputMapper.

Friends And Related Function Documentation

friend class AbstractEditor [friend]

friend class AbstractMultiLineEditor [friend]

Field Documentation

Caret* InputMapper::m_caret [protected]

The documentation for this class was generated from the following files:
  • Gui/InputMapper.hpp
  • Gui/InputMapper.cpp
Generated on Wed Jan 25 01:21:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputMapperFactory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputMapperFactory Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/InputMapperFactory.hpp>

Public Member Functions

virtual InputMapper * | CreateInstance ()=0
virtual INT | GetId () const =0
virtual void | Init ()=0
InputMapperFactory ()
virtual | ~InputMapperFactory ()

Constructor & Destructor Documentation

InputMapperFactory::InputMapperFactory ( )

The documentation for this class was generated from the following files:
  • Atl/InputMapperFactory.hpp
  • Atl/InputMapperFactory.cpp
Generated on Wed Jan 25 01:21:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputParser Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputParser.hpp>

Collaboration diagram for InputParser:

[legend]

Public Types

enum BasicServiceMmiCode {
AllServices, AllTeleServices, Telephony, AllDataServices,
FacsimileServices, ShortMessageServices, AllTeleServicesExceptSMS, VoiceGroupCallService,
VoiceBroadcastService, AllBearerServices, AllAsyncServices, AllSyncServices,
AllDataCircuitSync, AllDataCircuitAsync, AuxiliarySpeech, AllGPRSBearerServices,
InvalidServiceGroup
}
Basic Service Groups. More...
enum SsCode {
CLIP, CLIR, COLP, COLR,
CFU, CFBusy, CFNoReply, CFNotReachable,
AllCF, AllConditionalCF, BAOC, BAOIC,
BAOICexchome, BAIC, BAICroaming, AllBarrServices,
OutgBarrServices, IncBarrServices, ChangePin, ChangePin2,
UnblockPin, UnblockPin2, Wait, UUSService1,
UUSService2, UUSService3, AllUUSServices, ECT,
CCBS, FM, CNAP, MSP,
MC, RegisterNewPassword, EMLPP, CD,
AllSsServices, InvalidSsCode
}
Supplementary Service Code as defined 3GPP TS 22.030. More...
enum SsProcedure {
Activation, Deactivation, Registration, Erasure,
Interrogation, InvalidProcedure
}
Procedure as defined in 3GPP TS 22.030. More...

Public Member Functions

LexToken | GetNextToken (WString &parsedstring)
void | GetRest (WString &parsedstring)
SsCode | GetSsCode (const WString &ssstring, INT &additionaldigit)
SsCode | GetSsCode (INT &additionaldigit)
SsProcedure GetSsProcedure ()
InputParser (const WString &ssstring)
InputParser ()
~InputParser ()

Static Public Member Functions

static InputParser::BasicServiceMmiCode | GetBasicServiceMmiCode (const WString &bsgstring)
static const WCHAR * | GetBasicServiceMmiCodeString (InputParser::BasicServiceMmiCode code)
static const WCHAR * | GetSSCodeString (SsCode code)
static const WCHAR * | GetSSProcedureString (SsProcedure procedure)

Detailed Description

InputParser is responsible for parsing several parts of the input string.

Member Enumeration Documentation

enum InputParser::BasicServiceMmiCode

Basic Service Groups.

Enumerator:
AllServices
AllTeleServices
Telephony
AllDataServices
FacsimileServices
ShortMessageServices
AllTeleServicesExceptSMS
VoiceGroupCallService
VoiceBroadcastService
AllBearerServices
AllAsyncServices
AllSyncServices
AllDataCircuitSync
AllDataCircuitAsync
AuxiliarySpeech
AllGPRSBearerServices
InvalidServiceGroup

enum InputParser::SsCode

Supplementary Service Code as defined 3GPP TS 22.030.

Enumerator:
CLIP
CLIR
COLP
COLR
CFU
CFBusy
CFNoReply
CFNotReachable
AllCF
AllConditionalCF
BAOC
BAOIC
BAOICexchome
BAIC
BAICroaming
AllBarrServices
OutgBarrServices
IncBarrServices
ChangePin
ChangePin2
UnblockPin
UnblockPin2
Wait
UUSService1
UUSService2
UUSService3
AllUUSServices
ECT
CCBS
FM
CNAP
MSP
MC
RegisterNewPassword
EMLPP
CD
AllSsServices
InvalidSsCode

enum InputParser::SsProcedure

Procedure as defined in 3GPP TS 22.030.

Enumerator:
Activation | Activation "*".
Deactivation | Deactivation "#".
Registration | Registration "**".
Erasure | Erasure "##".
Interrogation | Interrogation "*#".
InvalidProcedure

Constructor & Destructor Documentation

InputParser::InputParser ( ) [inline]

InputParser::InputParser ( const WString & ssstring ) [explicit]

InputParser::~InputParser ( )

Member Function Documentation

InputParser::BasicServiceMmiCode InputParser::GetBasicServiceMmiCode ( const WString & bsgstring ) [static]

const WCHAR * InputParser::GetBasicServiceMmiCodeString ( InputParser::BasicServiceMmiCode code ) [static]

LexToken InputParser::GetNextToken ( WString & parsedstring ) [inline]

void InputParser::GetRest ( WString & parsedstring ) [inline]

InputParser::SsCode InputParser::GetSsCode | ( | const WString & | ssstring,
 |  | INT & | additionaldigit
 | ) |

InputParser::SsCode InputParser::GetSsCode ( INT & additionaldigit )

const WCHAR * InputParser::GetSSCodeString ( SsCode code ) [static]

InputParser::SsProcedure InputParser::GetSsProcedure ( )

const WCHAR * InputParser::GetSSProcedureString ( SsProcedure procedure ) [static]

The documentation for this class was generated from the following files:
  • Asc/InputParser.hpp
  • Asc/InputParser.cpp
Generated on Wed Jan 25 01:21:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InputStream Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InputStream Class Reference
[Kernel]

#include <Apoxi/Compat/InputStream.hpp>

Inheritance diagram for InputStream:

[legend]

Public Member Functions

virtual UINT32 | Available ()=0
InputStream ()
virtual InputStream & | operator>> (unsigned long &n)
virtual InputStream & | operator>> (long &n)
virtual InputStream & | operator>> (unsigned int &n)
virtual InputStream & | operator>> (int &n)
virtual InputStream & | operator>> (unsigned short &n)
virtual InputStream & | operator>> (short &n)
virtual InputStream & | operator>> (const wchar_t *w)
virtual InputStream & | operator>> (signed char *s)
virtual InputStream & | operator>> (unsigned char *s)
virtual InputStream & | operator>> (char *s)
virtual InputStream & | operator>> (signed char &c)
virtual InputStream & | operator>> (unsigned char &c)
virtual InputStream & | operator>> (char &c)
virtual INT | Read (BYTE *data, INT offset, INT len)
virtual INT | Read (BYTE *data, INT len)
virtual INT | Read (BYTE &data)=0
virtual | ~InputStream ()

Constructor & Destructor Documentation

InputStream::InputStream ( )

InputStream::~InputStream ( ) [virtual]

Member Function Documentation

virtual UINT32 InputStream::Available ( ) [pure virtual]

Implemented in FileInputStream.

InputStream & InputStream::operator>> ( unsigned long & n ) [virtual]

InputStream & InputStream::operator>> ( long & n ) [virtual]

InputStream & InputStream::operator>> ( unsigned int & n ) [virtual]

InputStream & InputStream::operator>> ( int & n ) [virtual]

InputStream & InputStream::operator>> ( unsigned short & n ) [virtual]

InputStream & InputStream::operator>> ( short & n ) [virtual]

InputStream & InputStream::operator>> ( const wchar_t * w ) [virtual]

InputStream & InputStream::operator>> ( signed char * s ) [virtual]

InputStream & InputStream::operator>> ( unsigned char * s ) [virtual]

InputStream & InputStream::operator>> ( char * s ) [virtual]

InputStream & InputStream::operator>> ( signed char & c ) [virtual]

InputStream & InputStream::operator>> ( unsigned char & c ) [virtual]

InputStream & InputStream::operator>> ( char & c ) [virtual]

INT InputStream::Read | ( | BYTE * | data,
 |  | INT | offset,
 |  | INT | len
 | ) | [virtual]

INT InputStream::Read | ( | BYTE * | data,
 |  | INT | len
 | ) | [virtual]

Reimplemented in FileInputStream.

virtual INT InputStream::Read ( BYTE & data ) [pure virtual]

Implemented in FileInputStream.

The documentation for this class was generated from the following files:
  • Compat/InputStream.hpp
  • Compat/InputStream.cpp
Generated on Wed Jan 25 01:21:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InteriorNodeRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InteriorNodeRecord Struct Reference
[Afs]

InteriorNodeRecord. More...

#include <Apoxi/Afs/UriMappingTable.hpp>

Data Fields

INT16 | m_backup_file_id
INT16 | m_file_id
CHAR | m_flag
CHAR | m_node_name [c_reg_node_name_size_max]
INT16 | m_parent_file_id
INT16 | m_transaction_id
CHAR | m_tree_level

Detailed Description

InteriorNodeRecord.

Field Documentation

INT16 InteriorNodeRecord::m_backup_file_id

INT16 InteriorNodeRecord::m_file_id

CHAR InteriorNodeRecord::m_flag

CHAR InteriorNodeRecord::m_node_name[c_reg_node_name_size_max]

INT16 InteriorNodeRecord::m_parent_file_id

INT16 InteriorNodeRecord::m_transaction_id

CHAR InteriorNodeRecord::m_tree_level

The documentation for this struct was generated from the following file:
  • Afs/UriMappingTable.hpp
Generated on Wed Jan 25 01:21:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InternalTracer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InternalTracer Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/InternalTracer.hpp>

Public Types

enum | { APP_NAME_LENGTH = 20, STACK_TRACE_DEPTH = 10, MAX_DATA_LENGTH = 400 }
enum TraceId {
Unknown = 0x0000, UChar = 0x0003, ULong = 0x0007, String = 0x000e,
Int = 0x0010, UInt = 0x0012, Char = 0x0013, Long = 0x0014,
Short = 0x0015, UShort = 0x0016, WString = 0x001E, TestState = 0x00E0,
New = 0x00F0, Delete = 0x00F1, AppBegin = 0x00F2, AppEnd = 0x00F3,
ObjectCreate = 0x00F4, ObjectDestroy = 0x00F5, DataTrace = 0x00F6, Misc = 0x00F7,
Message = 0x00F8, Version = 0x00F9, Warning = 0x00FA, FunctionBegin = 0x00FB,
CheckPoint = 0x00FC, FuncStackTrace = 0x00FD, FunctionEnd = 0x00FE, Error = 0x00FF
}
enum TraceMask {
Always = 0x0000, Adc = 0x0001, Apc = 0x0002, Asc = 0x0004,
Aux = 0x0008, Gui = 0x0010, Kernel = 0x0020, Socket = 0x0040,
Mmi = 0x0080, App1 = 0x0100, App2 = 0x0200, App3 = 0x0400,
App4 = 0x0800, Mem = 0x1000, Func = 0x2000, Obj = 0x4000,
Data = -32768, DefaultMask = 0xFFF | Func | Obj | Data
}

Static Public Member Functions

static TraceMask | GetGlobalTraceMask ()
static void | Init ()
static void | SetGlobalTraceMask (TraceMask mask)
static void | TraceAppAttach (const void *linkreg, const void *app, const void *container, const WCHAR *appName, UINT8 newAppId)
static void | TraceAppDetach (const void *linkreg, const void *app, UINT8 newAppId)
static void | TraceBuffer (const void *linkreg, UINT16 id, const void *str, UINT16 size)
static void | TraceData (TraceMask mask, const void *linkreg, TraceId id, const void *data, UINT16 len)
static void | TraceData (TraceMask mask, const void *linkreg, const void *data, UINT16 len)
static void | TraceDelete (const void *linkreg, const void *ptr)
static void | TraceFuncBegin (TraceMask mask, const void *linkreg, const void *this_ptr)
static void | TraceFuncCheckPoint (TraceMask mask, const void *linkreg)
static void | TraceFuncEnd (TraceMask mask, const void *linkreg)
static void | TraceFuncStackTrace (TraceMask mask, const void *linkreg)
static void | TraceMessage (const void *linkreg, UINT16 id, const void *ptr, UINT16 size)
static void | TraceMiscData (TraceMask mask, const void *linkreg, const void *data, UINT16 len)
static void | TraceNew (const void *linkreg, const void *ptr, UINT16 size)
static void | TraceObj (const void *linkreg, TraceId id, const void *ptr)
static void | TraceTestState (const void *linkreg, UINT16 testID, const void *str, UINT16 len)

Protected Member Functions

InternalTracer ()

Static Protected Member Functions

static const void * | CallStackAdr (INT16 level)
static unsigned char | NestedLevel ()

Static Protected Attributes

static TraceMask | g_globalMask = InternalTracer::DefaultMask

Data Structures

struct | AttachData
struct | DataTraceHeader
struct | DelData
struct | DetachData
struct | NewData
struct | TestStateData
struct | TraceHeader
struct | TraceMessageData
struct | TsStruct
this struct just prevents ms compiler to rearange TraceHeader-struct More...

Member Enumeration Documentation

anonymous enum

Enumerator:
APP_NAME_LENGTH
STACK_TRACE_DEPTH
MAX_DATA_LENGTH

enum InternalTracer::TraceId

Enumerator:
Unknown
UChar
ULong
String
Int
UInt
Char
Long
Short
UShort
WString
TestState
New
Delete
AppBegin
AppEnd
ObjectCreate
ObjectDestroy
DataTrace
Misc
Message
Version
Warning
FunctionBegin
CheckPoint
FuncStackTrace
FunctionEnd
Error

enum InternalTracer::TraceMask

Enumerator:
Always
Adc
Apc
Asc
Aux
Gui
Kernel
Socket
Mmi
App1
App2
App3
App4
Mem
Func
Obj
Data
DefaultMask

Constructor & Destructor Documentation

InternalTracer::InternalTracer ( ) [inline, protected]

Member Function Documentation

const void * InternalTracer::CallStackAdr ( INT16 level ) [static, protected]

static TraceMask InternalTracer::GetGlobalTraceMask ( ) [inline, static]

void InternalTracer::Init ( ) [static]

UINT8 InternalTracer::NestedLevel ( ) [static, protected]

static void InternalTracer::SetGlobalTraceMask ( TraceMask mask ) [inline, static]

void InternalTracer::TraceAppAttach | ( | const void * | linkreg,
 |  | const void * | app,
 |  | const void * | container,
 |  | const WCHAR * | appName,
 |  | UINT8 | newAppId
 | ) | [static]

void InternalTracer::TraceAppDetach | ( | const void * | linkreg,
 |  | const void * | app,
 |  | UINT8 | newAppId
 | ) | [static]

void InternalTracer::TraceBuffer | ( | const void * | linkreg,
 |  | UINT16 | id,
 |  | const void * | str,
 |  | UINT16 | size
 | ) | [static]

void InternalTracer::TraceData | ( | TraceMask | mask,
 |  | const void * | linkreg,
 |  | TraceId | id,
 |  | const void * | data,
 |  | UINT16 | len
 | ) | [static]

void InternalTracer::TraceData | ( | TraceMask | mask,
 |  | const void * | linkreg,
 |  | const void * | data,
 |  | UINT16 | len
 | ) | [static]

void InternalTracer::TraceDelete | ( | const void * | linkreg,
 |  | const void * | ptr
 | ) | [static]

void InternalTracer::TraceFuncBegin | ( | TraceMask | mask,
 |  | const void * | linkreg,
 |  | const void * | this_ptr
 | ) | [static]

void InternalTracer::TraceFuncCheckPoint | ( | TraceMask | mask,
 |  | const void * | linkreg
 | ) | [static]

void InternalTracer::TraceFuncEnd | ( | TraceMask | mask,
 |  | const void * | linkreg
 | ) | [static]

void InternalTracer::TraceFuncStackTrace | ( | TraceMask | mask,
 |  | const void * | linkreg
 | ) | [static]

void InternalTracer::TraceMessage | ( | const void * | linkreg,
 |  | UINT16 | id,
 |  | const void * | ptr,
 |  | UINT16 | size
 | ) | [static]

void InternalTracer::TraceMiscData | ( | TraceMask | mask,
 |  | const void * | linkreg,
 |  | const void * | data,
 |  | UINT16 | len
 | ) | [static]

void InternalTracer::TraceNew | ( | const void * | linkreg,
 |  | const void * | ptr,
 |  | UINT16 | size
 | ) | [static]

void InternalTracer::TraceObj | ( | const void * | linkreg,
 |  | TraceId | id,
 |  | const void * | ptr
 | ) | [static]

void InternalTracer::TraceTestState | ( | const void * | linkreg,
 |  | UINT16 | testID,
 |  | const void * | str,
 |  | UINT16 | len
 | ) | [static]

Field Documentation

InternalTracer::TraceMask InternalTracer::g_globalMask = InternalTracer::DefaultMask [static, protected]

The documentation for this class was generated from the following files:
  • Kernel/Os/InternalTracer.hpp
  • Kernel/Os/Nuc32/InternalTracer.cpp
  • Kernel/Os/Win32/InternalTracer.cpp
Generated on Wed Jan 25 01:22:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InternalTracer::TraceHeader Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
InternalTracer::TraceHeader

InternalTracer::TraceHeader Struct Reference

#include <Apoxi/Kernel/Os/InternalTracer.hpp>

Collaboration diagram for InternalTracer::TraceHeader:

[legend]

Data Fields

UINT8 | appId
const void * | codeAdr
UINT16 | id
UINT8 | nestedLevel
TsStruct ts

Field Documentation

UINT8 InternalTracer::TraceHeader::appId

const void* InternalTracer::TraceHeader::codeAdr

UINT16 InternalTracer::TraceHeader::id

UINT8 InternalTracer::TraceHeader::nestedLevel

TsStruct InternalTracer::TraceHeader::ts

The documentation for this struct was generated from the following file:
  • Kernel/Os/InternalTracer.hpp
Generated on Wed Jan 25 01:22:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InternalTracer::TsStruct Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
InternalTracer::TsStruct

InternalTracer::TsStruct Struct Reference

this struct just prevents ms compiler to rearange TraceHeader-struct More...

#include <Apoxi/Kernel/Os/InternalTracer.hpp>

Data Fields

UINT32 ts

Detailed Description

this struct just prevents ms compiler to rearange TraceHeader-struct

Field Documentation

UINT32 InternalTracer::TsStruct::ts

The documentation for this struct was generated from the following file:
  • Kernel/Os/InternalTracer.hpp
Generated on Wed Jan 25 01:22:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InterrogateCcbsResult Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InterrogateCcbsResult Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for InterrogateCcbsResult:

[legend]

Data Fields

CcbsList ccbs_list
INT | ccbs_que_length
UINT8 | ss_status

Field Documentation

CcbsList InterrogateCcbsResult::ccbs_list

INT InterrogateCcbsResult::ccbs_que_length

UINT8 InterrogateCcbsResult::ss_status

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:22:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InterrogateSsResult Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InterrogateSsResult Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for InterrogateSsResult:

[legend]

Data Fields

SsGroup basic_serv_group_list [c_max_no_basic_service_groups]
INT | basic_serv_group_list_size
CliRestrictionInfo cli_restriction_info
ForwardingFeature forward_feature_list [c_max_no_basic_service_groups]
INT | forward_feature_list_size
PhoneNumber forward_to_number
InterrogateSsChoice selector
SsStatus ss_status

Field Documentation

SsGroup InterrogateSsResult::basic_serv_group_list[c_max_no_basic_service_groups]

INT InterrogateSsResult::basic_serv_group_list_size

CliRestrictionInfo InterrogateSsResult::cli_restriction_info

ForwardingFeature InterrogateSsResult::forward_feature_list[c_max_no_basic_service_groups]

INT InterrogateSsResult::forward_feature_list_size

PhoneNumber InterrogateSsResult::forward_to_number

InterrogateSsChoice InterrogateSsResult::selector

SsStatus InterrogateSsResult::ss_status

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:22:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InterrogationResultArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InterrogationResultArg Struct Reference
[APOXI Stack Control]

Contains the interrogation result, containing supplementary service status. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for InterrogationResultArg:

[legend]

Data Fields

SsOperationCode operation_code
The respective call independent supplementary operation code.
InterrogateSsResult result
This type corresponds to the ASN.1 choice type Interrrogate_SS_Result in [GSM 04.80, 4.4.2].

Detailed Description

Contains the interrogation result, containing supplementary service status.

Field Documentation

SsOperationCode InterrogationResultArg::operation_code

The respective call independent supplementary operation code.

InterrogateSsResult InterrogationResultArg::result

This type corresponds to the ASN.1 choice type Interrrogate_SS_Result in [GSM 04.80, 4.4.2].

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 01:22:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InterrogationResultMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InterrogationResultMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for InterrogationResultMsg:

[legend]
Collaboration diagram for InterrogationResultMsg:

[legend]

Public Types

enum | { ID = 18504 }

Public Member Functions

virtual Message * | Clone () const
const InterrogationResultArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
InterrogationResultMsg (ExecutionContext *context, const InterrogationResultArg &arg)
void | SetArg (const InterrogationResultArg &arg)
virtual | ~InterrogationResultMsg ()

Detailed Description

InterrogationResultMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

InterrogationResultMsg::InterrogationResultMsg | ( | ExecutionContext * | context,
 |  | const InterrogationResultArg & | arg
 | ) |

InterrogationResultMsg::~InterrogationResultMsg ( ) [virtual]

Member Function Documentation

Message * InterrogationResultMsg::Clone ( ) const [virtual]

Implements Message.

const InterrogationResultArg& InterrogationResultMsg::GetArg ( ) const [inline]

const MsgMetaData & InterrogationResultMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void InterrogationResultMsg::SetArg ( const InterrogationResultArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:22:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InvalidateMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InvalidateMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for InvalidateMsg:

[legend]
Collaboration diagram for InvalidateMsg:

[legend]

Public Types

enum | { ID = 1118 }

Public Member Functions

virtual Message * | Clone () const
Component * | GetComponent () const
Dispatcher * | GetDispatcher () const
virtual const MsgMetaData & | GetMetaData () const
const Rect & | GetRect () const
InvalidateMsg (Component *component, Dispatcher *dispatcher, const Rect &rect)
virtual | ~InvalidateMsg ()

Detailed Description

Post this message, if a component should be invalidated outside the thread-context of the control.
Parameters:
component | Component which should get invalidated.
dispather | Specifies the dispatcher which posted the message (e. g. the application). The parameter is not required by APOXI itself but might be interesting for customized needs.
rect | Invalidation rectangle relative to the upper left of the component.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

InvalidateMsg::InvalidateMsg | ( | Component * | component,
 |  | Dispatcher * | dispatcher,
 |  | const Rect & | rect
 | ) |

InvalidateMsg::~InvalidateMsg ( ) [virtual]

Member Function Documentation

Message * InvalidateMsg::Clone ( ) const [virtual]

Implements Message.

Component* InvalidateMsg::GetComponent ( ) const [inline]

Dispatcher* InvalidateMsg::GetDispatcher ( ) const [inline]

const MsgMetaData & InvalidateMsg::GetMetaData ( ) const [virtual]

Implements Message.

const Rect& InvalidateMsg::GetRect ( ) const [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:22:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: InvokeId Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

InvokeId Class Reference

This class generates a new invoke id whenever it's instantiated. More...

#include <Apoxi/AddOns/Lcs/Common/LcsDecls.hpp>

Public Member Functions

UINT16 GetInvokeId () const
Returns the new invoke id.
InvokeId ()
Constructor.

Detailed Description

This class generates a new invoke id whenever it's instantiated.

Constructor & Destructor Documentation

InvokeId::InvokeId ( ) [inline]

Constructor.

Member Function Documentation

UINT16 InvokeId::GetInvokeId ( ) const [inline]

Returns the new invoke id.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsDecls.hpp
  • AddOns/Lcs/Common/LcsReqProcessor.cpp
Generated on Wed Jan 25 01:22:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IpAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IpAddr Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/IpAddr.hpp>

Collaboration diagram for IpAddr:

[legend]

Public Types

typedef UINT32 | Persist
enum | PredefIpAddr { c_ipaddr_loopback, c_ipaddr_any, c_ipaddr_broadcast }

Public Member Functions

UINT32 | GetAddr () const
UINT8 | GetAPart () const
Get A part of IP address A.B.C.D.
UINT8 | GetBPart () const
Get B part of IP address A.B.C.D.
UINT8 | GetCPart () const
Get C part of IP address A.B.C.D.
UINT8 | GetDPart () const
Get D part of IP address A.B.C.D.
UINT32 | GetNativeAddr () const
BOOLEAN | InitFrom (const WCHAR *str, INT len=-1)
BOOLEAN | InitFrom (const CHAR *str, INT len=-1)
IpAddr (const WCHAR *str, INT len=-1)
IpAddr (PredefIpAddr pre)
IpAddr (const CHAR *str, INT len=-1)
IpAddr (UINT8 a, UINT8 b, UINT8 c, UINT8 d)
IpAddr (UINT32 addr=0, BOOLEAN convert_from_native=FALSE)
void | operator<< (const Persist &p)
void | operator>> (Persist &p) const
void | SetAddr (UINT32 addr, BOOLEAN convert_from_native=FALSE)
void | SetAPart (UINT8 a)
Set A part of IP address A.B.C.D.
void | SetBPart (UINT8 b)
Set B part of IP address A.B.C.D.
void | SetCPart (UINT8 c)
Set C part of IP address A.B.C.D.
void | SetDPart (UINT8 d)
Set D part of IP address A.B.C.D.
String | Verbose () const

Detailed Description

IpAddr specifies a IPV4 IP address. IP address must be passed in big endian format to socket functions. IpAddr will care for that conversion.

Member Typedef Documentation

typedef UINT32 IpAddr::Persist

Member Enumeration Documentation

enum IpAddr::PredefIpAddr

PredefIpAddr specifies well defined IPV4 addresses.
c_ipaddr_loopback 127.0.0.1
c_ipaddr_any 0.0.0.0
c_ipaddr_broadcast 255.255.255.255

Enumerator:
c_ipaddr_loopback
c_ipaddr_any
c_ipaddr_broadcast

Constructor & Destructor Documentation

IpAddr::IpAddr | ( | UINT32 | addr = 0,
 |  | BOOLEAN | convert_from_native = FALSE
 | ) |

Use this ctor to construct an IP address from UINT32 type. If the given address is in big endian format pass FALSE to parameter two. Otherwise specify TRUE for triggering the conversion from native byte ordering to big endian (null operation if target is big endian).

IpAddr::IpAddr | ( | UINT8 | a,
 |  | UINT8 | b,
 |  | UINT8 | c,
 |  | UINT8 | d
 | ) |

Use this ctor to construct an IP address from the given atomic parts of an IP address.

IpAddr::IpAddr | ( | const CHAR * | str,
 |  | INT | len = -1
 | ) |

Use this ctor to construct an IP address a character string.

Parameters:
character | string in form of a.b.c.d.
len | specifies the length of given string. If len < 0 a null terminated string is expected.

IpAddr::IpAddr ( PredefIpAddr pre )

Use this ctor to construct a standard IP address

IpAddr::IpAddr | ( | const WCHAR * | str,
 |  | INT | len = -1
 | ) |

Use this ctor to construct an IP address a wide character string.

Parameters:
character | string in form of a.b.c.d.
len | specifies the length of given string. If len < 0 a null terminated string is expected.

Member Function Documentation

UINT32 IpAddr::GetAddr ( ) const [inline]

Returns IP address in big endian 32 bit format

UINT8 IpAddr::GetAPart ( ) const [inline]

Get A part of IP address A.B.C.D.

UINT8 IpAddr::GetBPart ( ) const [inline]

Get B part of IP address A.B.C.D.

UINT8 IpAddr::GetCPart ( ) const [inline]

Get C part of IP address A.B.C.D.

UINT8 IpAddr::GetDPart ( ) const [inline]

Get D part of IP address A.B.C.D.

UINT32 IpAddr::GetNativeAddr ( ) const [inline]

Returns IP address in native 32 bit number format.

BOOLEAN IpAddr::InitFrom | ( | const WCHAR * | str,
 |  | INT | len = -1
 | ) |

Use InitFrom to initialize IP address from a wide character string. String format must not divert from a.b.c.d form. Returns FALSE malformed string is specified.

Parameters:
character | string in form of a.b.c.d.
len | specifies the length of given string. If len < 0 a null terminated string is expected.

BOOLEAN IpAddr::InitFrom | ( | const CHAR * | str,
 |  | INT | len = -1
 | ) |

Use InitFrom to initialize IP address from a single byte character string. String format must not divert from a.b.c.d form. Returns FALSE malformed string is specified.

Parameters:
character | string in form of a.b.c.d.
len | specifies the length of given string. If len < 0 a null terminated string is expected.

void IpAddr::operator<< ( const Persist & p ) [inline]

Use this operator to persist IP address

void IpAddr::operator>> ( Persist & p ) const [inline]

Use this operator to persist IP address

void IpAddr::SetAddr | ( | UINT32 | addr,
 |  | BOOLEAN | convert_from_native = FALSE
 | ) |

Set IP address. Parameter two specifies if the given address is in big endian format. If not, SetAddr will convert the given parameter from native to big endian byte ordering

void IpAddr::SetAPart ( UINT8 a ) [inline]

Set A part of IP address A.B.C.D.

void IpAddr::SetBPart ( UINT8 b ) [inline]

Set B part of IP address A.B.C.D.

void IpAddr::SetCPart ( UINT8 c ) [inline]

Set C part of IP address A.B.C.D.

void IpAddr::SetDPart ( UINT8 d ) [inline]

Set D part of IP address A.B.C.D.

String IpAddr::Verbose ( ) const

Get current IP address as string in A.B.C.D format

The documentation for this class was generated from the following files:
  • Auxiliary/IpAddr.hpp
  • Auxiliary/IpAddr.cpp
Generated on Wed Jan 25 01:22:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IpAddrCompoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IpAddrCompoundItem Class Reference
[Editors]

Contains a date. More...

#include <Apoxi/Gui/IpAddrCompoundItem.hpp>

Inheritance diagram for IpAddrCompoundItem:

[legend]
Collaboration diagram for IpAddrCompoundItem:

[legend]

Public Types

enum | { ID = 9 }

Public Member Functions

virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
virtual INT | GetId () const
const IpAddr & | GetIpAddr () const
virtual INT | GetItemCount () const
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT index, INT count) const
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetIpAddr (const IpAddr &ip_addr)
void | SetIpAddr (UINT32 ip_addr)
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=EditorDocument::WhitespaceWrap) const
virtual | ~IpAddrCompoundItem ()

Static Public Member Functions

static IpAddrCompoundItem * | CreateInstance (const IpAddr &ip_addr=IpAddr())
Creates and returns an object of this class.

Protected Member Functions

IpAddrCompoundItem (const IpAddr &ip_addr=IpAddr())

Detailed Description

Contains a date.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from CompoundItem.

Constructor & Destructor Documentation

IpAddrCompoundItem::~IpAddrCompoundItem ( ) [virtual]

IpAddrCompoundItem::IpAddrCompoundItem ( const IpAddr & ip_addr = IpAddr() ) [protected]

Member Function Documentation

IpAddrCompoundItem * IpAddrCompoundItem::CreateInstance ( const IpAddr & ip_addr = IpAddr() ) [static]

Creates and returns an object of this class.

void IpAddrCompoundItem::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::Draw

Implements CompoundItem.

INT IpAddrCompoundItem::GetId ( ) const [virtual]

See also:
CompoundItem::GetId()

Reimplemented from CompoundItem.

const IpAddr& IpAddrCompoundItem::GetIpAddr ( ) const [inline]

INT IpAddrCompoundItem::GetItemCount ( ) const [virtual]

See also:
CompoundItem::GetItemCount

Implements CompoundItem.

XYDIM IpAddrCompoundItem::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
CompoundItem::GetLineHeight

Implements CompoundItem.

XYDIM IpAddrCompoundItem::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::GetLineWidth

Implements CompoundItem.

BOOLEAN IpAddrCompoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from CompoundItem.

void IpAddrCompoundItem::SetIpAddr ( const IpAddr & ip_addr ) [inline]

void IpAddrCompoundItem::SetIpAddr ( UINT32 ip_addr ) [inline]

INT IpAddrCompoundItem::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = EditorDocument::WhitespaceWrap
 | ) | const [virtual]

See also:
CompoundItem::WrapLine

Implements CompoundItem.

The documentation for this class was generated from the following files:
  • Gui/IpAddrCompoundItem.hpp
  • Gui/IpAddrCompoundItem.cpp
Generated on Wed Jan 25 01:22:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IpAddrEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IpAddrEditor Class Reference
[Editors]

#include <Apoxi/Gui/IpAddrEditor.hpp>

Inheritance diagram for IpAddrEditor:

[legend]
Collaboration diagram for IpAddrEditor:

[legend]

Public Types

enum | { ID = 31 }

Public Member Functions

IpAddr | GetIpAddr () const
Returns the current IP address.
void | Init (Control *parent, const IpAddr &ip_addr=IpAddr())
IpAddrEditor (Control *parent, const IpAddr &ip_addr=IpAddr())
IpAddrEditor ()
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetIpAddr (const IpAddr &ip_addr)
Sets the IP address to ip_addr.
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~IpAddrEditor ()

Protected Member Functions

virtual Model * | CreateModel () const

Detailed Description

Editor for editing an IP address.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractLineEditor.

Constructor & Destructor Documentation

IpAddrEditor::IpAddrEditor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

IpAddrEditor::IpAddrEditor | ( | Control * | parent,
 |  | const IpAddr & | ip_addr = IpAddr()
 | ) | [explicit]

Parameters:
parent | Pointer to the Control, which embeds the IpAddrEditor.
ip_addr | Value for IpAddr which should be edited.

IpAddrEditor::~IpAddrEditor ( ) [virtual]

Member Function Documentation

Model * IpAddrEditor::CreateModel ( ) const [protected, virtual]

Factory method for creating a model. Must be implemented by every class, which needs it's own model. By default a component has no model and 0 is returned. If a model is dynamically created by 'new', it must be deleted in the destructor by e. g. delete GetModel();.

Returns:
Pointer to the model.

Reimplemented from Component.

IpAddr IpAddrEditor::GetIpAddr ( ) const

Returns the current IP address.

void IpAddrEditor::Init | ( | Control * | parent,
 |  | const IpAddr & | ip_addr = IpAddr()
 | ) |

Parameters:
parent | Pointer to the Control, which embeds the IpAddrEditor.
ip_addr | Value for IpAddr which should be edited.

BOOLEAN IpAddrEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractLineEditor.

void IpAddrEditor::SetIpAddr ( const IpAddr & ip_addr )

Sets the IP address to ip_addr.

BOOLEAN IpAddrEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractLineEditor.

The documentation for this class was generated from the following files:
  • Gui/IpAddrEditor.hpp
  • Gui/IpAddrEditor.cpp
Generated on Wed Jan 25 01:22:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IpAddrEditorDocument Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IpAddrEditorDocument Class Reference
[Editors]

A IpAddr-Editor-Document contains a IpAddr-Compound-Item. More...

#include <Apoxi/Gui/IpAddrEditorDocument.hpp>

Inheritance diagram for IpAddrEditorDocument:

[legend]
Collaboration diagram for IpAddrEditorDocument:

[legend]

Public Member Functions

IpAddr | GetIpAddr () const
virtual INT | GetMaxItemCount () const
void | Init (const IpAddr &ip_addr)
IpAddrEditorDocument (const IpAddr &ip_addr)
IpAddrEditorDocument ()
BOOLEAN | IsInvalid (INT index) const
BOOLEAN | IsSeparator (INT index) const
void | SetIpAddr (const IpAddr &ip_addr)
virtual | ~IpAddrEditorDocument ()

Detailed Description

A IpAddr-Editor-Document contains a IpAddr-Compound-Item.

Constructor & Destructor Documentation

IpAddrEditorDocument::IpAddrEditorDocument ( )

IpAddrEditorDocument::IpAddrEditorDocument ( const IpAddr & ip_addr ) [explicit]

IpAddrEditorDocument::~IpAddrEditorDocument ( ) [virtual]

Member Function Documentation

IpAddr IpAddrEditorDocument::GetIpAddr ( ) const

INT IpAddrEditorDocument::GetMaxItemCount ( ) const [virtual]

See also:
EditorDocument::GetMaxItemCount()

Reimplemented from TextEditorDocument.

void IpAddrEditorDocument::Init ( const IpAddr & ip_addr )

BOOLEAN IpAddrEditorDocument::IsInvalid ( INT index ) const

BOOLEAN IpAddrEditorDocument::IsSeparator ( INT index ) const

void IpAddrEditorDocument::SetIpAddr ( const IpAddr & ip_addr )

The documentation for this class was generated from the following files:
  • Gui/IpAddrEditorDocument.hpp
  • Gui/IpAddrEditorDocument.cpp
Generated on Wed Jan 25 01:22:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IpAddrInputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IpAddrInputMapper Class Reference
[Editors]

Manages the input of a ip adress. More...

#include <Apoxi/Gui/IpAddrInputMapper.hpp>

Inheritance diagram for IpAddrInputMapper:

[legend]
Collaboration diagram for IpAddrInputMapper:

[legend]

Public Member Functions

virtual Alphabet | GetAlphabet () const
virtual INT | GetId () const
IpAddrInputMapper (BOOLEAN highlight_field=FALSE)
virtual void | SetEditor (AbstractEditor *editor)
virtual | ~IpAddrInputMapper ()

Protected Member Functions

virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLoseFocus ()

Detailed Description

Manages the input of a ip adress.

Constructor & Destructor Documentation

IpAddrInputMapper::IpAddrInputMapper ( BOOLEAN highlight_field = FALSE ) [explicit]

Parameters:
higlight_field If set to TRUE, the currently edited field is highlighted as input indication.

IpAddrInputMapper::~IpAddrInputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet IpAddrInputMapper::GetAlphabet ( ) const [virtual]

Returns SevenBitAlphabet.

See also:
InputMapper::GetAlphabet.

Reimplemented from NumericInputMapper.

INT IpAddrInputMapper::GetId ( ) const [virtual]

See also:
InputMapper::GetId()

Reimplemented from NumericInputMapper.

void IpAddrInputMapper::OnGetFocus ( ) [protected, virtual]

See also:
InputMapper::OnGetFocus

Reimplemented from InputMapper.

BOOLEAN IpAddrInputMapper::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
InputMapper::OnKeyDown()

Reimplemented from NumericInputMapper.

void IpAddrInputMapper::OnLoseFocus ( ) [protected, virtual]

See also:
InputMapper::OnLoseFocus

Reimplemented from InputMapper.

void IpAddrInputMapper::SetEditor ( AbstractEditor * editor ) [virtual]

See also:
InputMapper::SetEditor()

Reimplemented from InputMapper.

The documentation for this class was generated from the following files:
  • Gui/IpAddrInputMapper.hpp
  • Gui/IpAddrInputMapper.cpp
Generated on Wed Jan 25 01:22:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IpAddrPrompt Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IpAddrPrompt Class Reference
[DataConn, DataConn]

#include <Applications/DataConn/IpAddrPrompt.hpp>

Collaboration diagram for IpAddrPrompt:

[legend]

Public Types

typedef AbstractMmiPrompt | Base
typedef AbstractMmiPrompt | Base

Public Member Functions

IpAddr GetIpAddr ()
IpAddr GetIpAddr ()
void | Init (const WCHAR *title=0)
void | Init (const WCHAR *title=0)
IpAddrPrompt ()
IpAddrPrompt ()
void | SetIpAddr (const IpAddr &ip_addr)
void | SetIpAddr (const IpAddr &ip_addr)
virtual | ~IpAddrPrompt ()
virtual | ~IpAddrPrompt ()

Protected Member Functions

virtual AbstractEditor * | GetEditor ()
virtual AbstractEditor * | GetEditor ()

Member Typedef Documentation

typedef AbstractMmiPrompt IpAddrPrompt::Base

typedef AbstractMmiPrompt IpAddrPrompt::Base

Constructor & Destructor Documentation

IpAddrPrompt::IpAddrPrompt ( )

IpAddrPrompt::~IpAddrPrompt ( ) [virtual]

IpAddrPrompt::IpAddrPrompt ( )

virtual IpAddrPrompt::~IpAddrPrompt ( ) [virtual]

Member Function Documentation

virtual AbstractEditor* IpAddrPrompt::GetEditor ( ) [inline, protected, virtual]

virtual AbstractEditor* IpAddrPrompt::GetEditor ( ) [inline, protected, virtual]

IpAddr IpAddrPrompt::GetIpAddr ( ) [inline]

IpAddr IpAddrPrompt::GetIpAddr ( ) [inline]

void IpAddrPrompt::Init ( const WCHAR * title = 0 )

void IpAddrPrompt::Init ( const WCHAR * title = 0 )

void IpAddrPrompt::SetIpAddr ( const IpAddr & ip_addr ) [inline]

void IpAddrPrompt::SetIpAddr ( const IpAddr & ip_addr ) [inline]

The documentation for this class was generated from the following files:
  • Applications/DataConn/IpAddrPrompt.hpp
  • Applications/SocketTest/IpAddrPrompt.hpp
  • Applications/DataConn/IpAddrPrompt.cpp
  • Applications/SocketTest/IpAddrPrompt.cpp
Generated on Wed Jan 25 01:22:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IpPortNo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IpPortNo Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/IpPortNo.hpp>

Collaboration diagram for IpPortNo:

[legend]

Public Member Functions

UINT16 | GetNativePortNumber () const
UINT16 | GetPortNumber () const
IpPortNo (Iana::PortNumber n)
IpPortNo (UINT16 port=0, BOOLEAN convert_from_native=FALSE)

Detailed Description

IpPortNo defines a port address of a socket. Port addresses can be specified from 0 to 65535 (please refer to according RFCs for port numbering schemes and reserved numbers. Please note that socket functions mostly require parameters in big endian format. IpPortNo takes care for you to convert the address correctly.

Constructor & Destructor Documentation

IpPortNo::IpPortNo | ( | UINT16 | port = 0,
 |  | BOOLEAN | convert_from_native = FALSE
 | ) |

This ctor constructs from a given port number an IpPortNo object.

Parameters:
port | port number
covert_from_native | true if parameter port is not in big endian format.

IpPortNo::IpPortNo ( Iana::PortNumber n )

This ctor constructs from predefined IANA port number an IpPortNo object.

Member Function Documentation

UINT16 IpPortNo::GetNativePortNumber ( ) const [inline]

GetNativePortNumber returns port number in processor dependent byte order. Use this method if you have to print port number on display etc.

UINT16 IpPortNo::GetPortNumber ( ) const [inline]

GetPort returns port number in big endian format.

The documentation for this class was generated from the following files:
  • Auxiliary/IpPortNo.hpp
  • Auxiliary/IpPortNo.cpp
Generated on Wed Jan 25 01:22:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrConnection Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrConnection Class Reference

#include <Apoxi/Irda/Obex/IrdaObexTransport.hpp>

Collaboration diagram for IrConnection:

[legend]

Data Fields

BOOLEAN ir_bind_was_succesful
ObexOperationId m_job_id_client

Field Documentation

BOOLEAN IrConnection::ir_bind_was_succesful

ObexOperationId IrConnection::m_job_id_client

The documentation for this class was generated from the following file:
  • Irda/Obex/IrdaObexTransport.hpp
Generated on Wed Jan 25 01:22:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrdaApp Class Reference
[IrdaApp]

#include <Applications/IrdaApp/IrdaApp.hpp>

Collaboration diagram for IrdaApp:

[legend]

Public Member Functions

virtual | ~IrdaApp ()
Destructor.

Static Public Member Functions

static IrdaApp * | GetInstance ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)

Constructor & Destructor Documentation

IrdaApp::~IrdaApp ( ) [virtual]

Destructor.

Member Function Documentation

static IrdaApp* IrdaApp::GetInstance ( ) [inline, static]

BOOLEAN IrdaApp::OnMessage ( const Message & msg ) [protected, virtual]

void IrdaApp::OnOpen ( ) [protected, virtual]

BOOLEAN IrdaApp::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/IrdaApp/IrdaApp.hpp
  • Applications/IrdaApp/IrdaApp.cpp
Generated on Wed Jan 25 01:22:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaObexClientAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrdaObexClientAddr Class Reference

#include <Apoxi/Irda/Obex/IrdaObexAddr.hpp>

Inheritance diagram for IrdaObexClientAddr:

[legend]
Collaboration diagram for IrdaObexClientAddr:

[legend]

Public Types

typedef ObexClientAddr | Base

Public Member Functions

IrDeviceAddr | GetRemoteAddr ()
IrdaObexClientAddr (ObexTransportId transport_id, IrDeviceAddr remote_addr)
virtual ObexResult | ToString (String &obex_url) const
Converts the ObexAddrInfo into string format.

Member Typedef Documentation

typedef ObexClientAddr IrdaObexClientAddr::Base

Reimplemented from ObexClientAddr.

Constructor & Destructor Documentation

IrdaObexClientAddr::IrdaObexClientAddr | ( | ObexTransportId | transport_id,
 |  | IrDeviceAddr | remote_addr
 | ) |

Member Function Documentation

IrDeviceAddr IrdaObexClientAddr::GetRemoteAddr ( ) [inline]

ObexResult IrdaObexClientAddr::ToString ( String & obex_url ) const [virtual]

Converts the ObexAddrInfo into string format.

Parameters:
obex_url String to append the result to
Returns:
TRUE if the conversion was successful, FALSE otherwise.

Reimplemented from ObexAddress.

The documentation for this class was generated from the following files:
  • Irda/Obex/IrdaObexAddr.hpp
  • Irda/Obex/IrdaObexAddr.cpp
Generated on Wed Jan 25 01:22:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaObexImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrdaObexImpl Class Reference

#include <Apoxi/Irda/Obex/IrdaObexImpl.hpp>

Inheritance diagram for IrdaObexImpl:

[legend]
Collaboration diagram for IrdaObexImpl:

[legend]

Public Member Functions

virtual void | Abort (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &abort_req)
Aborts an ongoing OBEX client operation.
virtual ObexResult | AcquireClientChannel (ObexChannel &result, const ObexAddrPtr &addr_ptr, BOOLEAN reserve)
Abstract factory method for client transport channels.
virtual ObexResult | AcquireServerChannel (ObexChannel &result, const ObexAddrPtr &addr_ptr, BOOLEAN reserve)
Abstract factory method for server transport channels.
virtual void | BindServerChannel (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexAddrPtr &addr_ptr)
Binds a server transport channel to an OBEX address.
virtual void | CloseChannel (const ObexChannel &server_chan, ObexOperationId oper_id)
Closes a transport channel.
virtual void | Connect (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Starts an OBEX CONNECT operation.
virtual void | DataProcessed (const ObexChannel &channel, ObexOperationId oper_id, ObexBuffer &obex_buffer)
Confirm processing of data delivered to an application.
virtual void | Disconnect (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &disc_req)
Starts an OBEX DISCONNECT operation.
virtual void | Get (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &get_req)
Starts or continues an OBEX GET operation.
IrdaObexImpl ()
virtual void | OpenClientChannel (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexAddrPtr &addr_ptr)
Opens an OBEX client transport channel.
virtual void | Put (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &put_req)
Starts or continues an OBEX PUT operation.
virtual ObexResult | ReleaseChannel (ObexChannel &channel)
Releases an ObexChannel.
virtual void | ReturnResponse (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &server_resp)
Sends a response to a client request.
virtual void | SetPath (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &setp_req)
Starts an OBEX SETPATH operation.

Friends

class | ClientAppContext
class | ServerAppContext

Data Structures

class | ClientAppContext
class | ServerAppContext

Constructor & Destructor Documentation

IrdaObexImpl::IrdaObexImpl ( )

Member Function Documentation

void IrdaObexImpl::Abort | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | abort_req
 | ) | [virtual]

Aborts an ongoing OBEX client operation.

Only a currently pending PUT or GET operation can be aborted, and only clients may issue ABORT requests.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier of the operation to be aborted
abort_req | OBEX object which holds the headers to be included in the ABORT request.

Implements ObexLayer.

ObexResult IrdaObexImpl::AcquireClientChannel | ( | ObexChannel & | result,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | BOOLEAN | reserve
 | ) | [virtual]

Abstract factory method for client transport channels.

Must be implemented to return a client channel object for the specified protocol. The Channel object must be unique among all channels of the same transport and protocol. However, the under- lying transport service may be shared with other channels.

Parameters:
result | Reference to a channel object to hold the result. It will be overwritten in case of success.
reserve | If set to TRUE, indicates that private transport resources should be reserved for this channel. However, an implementation may choose to silently ignore this hint.
Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise (possibly lack of resources).

Implements ObexProtocol.

ObexResult IrdaObexImpl::AcquireServerChannel | ( | ObexChannel & | result,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | BOOLEAN | reserve
 | ) | [virtual]

Abstract factory method for server transport channels.

Must be implemented to return a server channel object for the specified protocol. The Channel object must be unique among all channels of the same transport and protocol. However, the under- lying transport service may be shared with other channels.

Parameters:
result | Reference to a channel object to hold the result. It will be overwritten in case of success.
reserve | If set to TRUE, indicates that private transport resources should be reserved for this channel. However, an implementation may choose to silently ignore this hint.
Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise (possibly lack of resources).

Implements ObexProtocol.

void IrdaObexImpl::BindServerChannel | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexAddrPtr & | addr_ptr
 | ) | [virtual]

Binds a server transport channel to an OBEX address.

The channel must have been previously obtained by calling AcquireServerChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
server_chan | Server transport channel to open.
oper_id | Operation identifier
addr_ptr | Smartpointer holding the OBEX address of the service to connect to

Implements ObexProtocol.

void IrdaObexImpl::CloseChannel | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id
 | ) | [virtual]

Closes a transport channel.

The channel must have been previously obtained by calling AcquireServerChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
channel | Transport channel to close.
oper_id | Operation identifier

Implements ObexProtocol.

void IrdaObexImpl::Connect | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Starts an OBEX CONNECT operation.

The channel must be a valid client channel in state 'OPEN'.

See also:
OpenClientChannel(). The result is delivered asynchronously by means of a call to OnResponse().

OnResponse()

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
conn_req | OBEX object which holds the headers to be included in the CONNECT request and flags according to OBEX Spec. 3.3.1.2, but no data !

Implements ObexLayer.

void IrdaObexImpl::DataProcessed | ( | const ObexChannel & | channel,
 |  | ObexOperationId | oper_id,
 |  | ObexBuffer & | obex_buffer
 | ) | [virtual]

Confirm processing of data delivered to an application.

By calling this method the application layer returns the ownership of a buffer back to the protocol implementation which had produced the buffer and therefore knows how to dispose it.

Implements ObexLayer.

void IrdaObexImpl::Disconnect | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | disc_req
 | ) | [virtual]

Starts an OBEX DISCONNECT operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
disc_req | OBEX object which holds the headers to be included in the DISCONNECT request.

Implements ObexLayer.

void IrdaObexImpl::Get | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | get_req
 | ) | [virtual]

Starts or continues an OBEX GET operation.

Note that in rare cases a GET request may contain a BODY header !

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier.
get_req | OBEX object which holds the headers to be included in the GET request and possibly BODY data within an ObexBuffer.

Implements ObexLayer.

void IrdaObexImpl::OpenClientChannel | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexAddrPtr & | addr_ptr
 | ) | [virtual]

Opens an OBEX client transport channel.

The channel must have been previously obtained by calling AcquireClientChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
obex_chan | Channel to open
oper_id | Operation identifier
addr_ptr | Smartpointer holding the OBEX address of the service to connect to

Implements ObexProtocol.

void IrdaObexImpl::Put | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | put_req
 | ) | [virtual]

Starts or continues an OBEX PUT operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
put_req | OBEX object which holds the headers to be included in the PUT request and possibly BODY data within an ObexBuffer.

Implements ObexLayer.

ObexResult IrdaObexImpl::ReleaseChannel ( ObexChannel & channel ) [virtual]

Releases an ObexChannel.

Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise.

Implements ObexProtocol.

void IrdaObexImpl::ReturnResponse | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | server_resp
 | ) | [virtual]

Sends a response to a client request.

Parameters:
server_chan | Server channel associated with the response.
oper_id | Operation identifier of the request to respond to (it was passed along with the request).
server_resp | OBEX object which holds the headers to be included in the response, the response code and possibly BODY data within an ObexBuffer.

Implements ObexLayer.

void IrdaObexImpl::SetPath | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | setp_req
 | ) | [virtual]

Starts an OBEX SETPATH operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
setp_req | OBEX object which holds the headers to be included in the SETPATH request and flags according to OBEX Spec. 3.3.6.1, but no data !

Implements ObexLayer.

Friends And Related Function Documentation

friend class ClientAppContext [friend]

friend class ServerAppContext [friend]

The documentation for this class was generated from the following files:
  • Irda/Obex/IrdaObexImpl.hpp
  • Irda/Obex/IrdaObexImpl.cpp
Generated on Wed Jan 25 01:22:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaObexServerAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrdaObexServerAddr Class Reference

#include <Apoxi/Irda/Obex/IrdaObexAddr.hpp>

Inheritance diagram for IrdaObexServerAddr:

[legend]
Collaboration diagram for IrdaObexServerAddr:

[legend]

Public Types

typedef ObexServerAddr | Base

Public Member Functions

IrDeviceAddr | GetRemoteAddr ()
IrdaObexServerAddr (ObexTransportId transport_id, IrDeviceAddr remote_addr)
virtual ObexResult | ToString (String &obex_url) const
Converts the ObexAddrInfo into string format.

Member Typedef Documentation

typedef ObexServerAddr IrdaObexServerAddr::Base

Reimplemented from ObexServerAddr.

Constructor & Destructor Documentation

IrdaObexServerAddr::IrdaObexServerAddr | ( | ObexTransportId | transport_id,
 |  | IrDeviceAddr | remote_addr
 | ) |

Member Function Documentation

IrDeviceAddr IrdaObexServerAddr::GetRemoteAddr ( ) [inline]

ObexResult IrdaObexServerAddr::ToString ( String & obex_url ) const [virtual]

Converts the ObexAddrInfo into string format.

Parameters:
obex_url String to append the result to
Returns:
TRUE if the conversion was successful, FALSE otherwise.

Reimplemented from ObexAddress.

The documentation for this class was generated from the following files:
  • Irda/Obex/IrdaObexAddr.hpp
  • Irda/Obex/IrdaObexAddr.cpp
Generated on Wed Jan 25 01:22:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaObexSubSystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrdaObexSubSystem Class Reference

#include <Apoxi/Irda/Obex/IrdaObexTransport.hpp>

Inheritance diagram for IrdaObexSubSystem:

[legend]
Collaboration diagram for IrdaObexSubSystem:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual BootSequenceState | InvokeAt () const
virtual void | OnPowerUp ()

Member Function Documentation

virtual const WCHAR* IrdaObexSubSystem::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

virtual BootSequenceState IrdaObexSubSystem::InvokeAt ( ) const [inline, virtual]

InvokeAt denotes the system boot phase the SubSystem shall be initialized in.

Implements SubSystem.

void IrdaObexSubSystem::OnPowerUp ( ) [virtual]

This method will be invoked on system power on.

Reimplemented from SubSystem.

The documentation for this class was generated from the following files:
  • Irda/Obex/IrdaObexTransport.hpp
  • Irda/Obex/IrdaObexTransport.cpp
Generated on Wed Jan 25 01:22:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaObexTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrdaObexTransport Class Reference

#include <Apoxi/Irda/Obex/IrdaObexTransport.hpp>

Inheritance diagram for IrdaObexTransport:

[legend]
Collaboration diagram for IrdaObexTransport:

[legend]

Public Types

typedef ObexAbstractTransport | Base

Public Member Functions

virtual void | AbortResolveClientAddr (const ObexOperationId &job_id)
Aborts a running client address resolution procedure.
virtual ObexProtocol * | GetProtocol (ObexProtocolId level)
Provides access to the protocol layer object of the specified level.
IrdaObexTransport ()
virtual void | ResolveClientAddr (const String &client_url, ObexProtocolId prot_id, ObexOperationId job_id)
Resolves an OBEX client address URL.
virtual void | ResolveServerAddr (const String &server_url, ObexProtocolId prot_id, BOOLEAN sdb_autocreate, ObexOperationId job_id)
Resolves an OBEX server address URL.
void | UnbindStack (void *arg)
virtual | ~IrdaObexTransport ()

Static Public Member Functions

static void | ClientCallBack (IrConnect *con, IrCallBackParms *parms)
static IrdaObexTransport & | GetInstance ()
Singleton accessor.
static void | ServerCallBack (IrConnect *con, IrCallBackParms *parms)

Data Fields

IrConnection | irconnections [C_IR_CONNECTIONS_MAX_NUM]

Static Public Attributes

static BOOLEAN | ir_discoverreq_in_progress = FALSE
static UINT16 | m_client_discovery_poll_repeat_counter = 0
static SystemTimer | m_clienttimer

Member Typedef Documentation

typedef ObexAbstractTransport IrdaObexTransport::Base

Constructor & Destructor Documentation

IrdaObexTransport::IrdaObexTransport ( )

IrdaObexTransport::~IrdaObexTransport ( ) [virtual]

Member Function Documentation

void IrdaObexTransport::AbortResolveClientAddr ( const ObexOperationId & job_id ) [virtual]

Aborts a running client address resolution procedure.

Parameters:
job_id Operation Id of the procedure to be aborted.

Reimplemented from ObexAbstractTransport.

void IrdaObexTransport::ClientCallBack | ( | IrConnect * | con,
 |  | IrCallBackParms * | parms
 | ) | [static]

IrdaObexTransport & IrdaObexTransport::GetInstance ( ) [static]

Singleton accessor.

ObexProtocol * IrdaObexTransport::GetProtocol ( ObexProtocolId level ) [virtual]

Provides access to the protocol layer object of the specified level.

Parameters:
level Protocol level / layer
Returns:
Pointer to object or '0' if protocol is unsupported.
Note: All transports must support at least ObexProtocol::ObexLevel !

Implements ObexAbstractTransport.

void IrdaObexTransport::ResolveClientAddr | ( | const String & | client_url,
 |  | ObexProtocolId | prot_id,
 |  | ObexOperationId | job_id
 | ) | [virtual]

Resolves an OBEX client address URL.

This is a factory method which evaluates the URL given in string format and creates an address information object which may contain specific information for the transport. This is accomplished by deriving a subclass from ObexClientAddr and creating an address information object from this class. Then a smartpointer of type ObexAddrPtr to this object and the job_id which was supplied with the URL must be returned by calling ReturnObexAddress().

Parameters:
client_url | Client address in URL format
prot_id | Protocol which will be bound to the address
job_id | Reference to associate request and response

Implements ObexAbstractTransport.

void IrdaObexTransport::ResolveServerAddr | ( | const String & | server_url,
 |  | ObexProtocolId | prot_id,
 |  | BOOLEAN | sdb_autocreate,
 |  | ObexOperationId | job_id
 | ) | [virtual]

Resolves an OBEX server address URL.

This is a factory method which evaluates the URL given in string format and creates an address information object which may contain specific information for the transport. This is accomplished by deriving a subclass from ObexServerAddr and creating an address information object from this class. Then a smartpointer of type ObexAddrPtr to this object and the job_id which was supplied with the URL must be returned by calling ReturnObexAddress().

Parameters:
server_url | Server address in URL format
prot_id | Protocol which will be bound to the address
sdb_autocreate | Check whether address can be autoregistered
job_id | Reference to associate request and response

Implements ObexAbstractTransport.

void IrdaObexTransport::ServerCallBack | ( | IrConnect * | con,
 |  | IrCallBackParms * | parms
 | ) | [static]

void IrdaObexTransport::UnbindStack ( void * arg )

Field Documentation

BOOLEAN IrdaObexTransport::ir_discoverreq_in_progress = FALSE [static]

IrConnection IrdaObexTransport::irconnections[C_IR_CONNECTIONS_MAX_NUM]

UINT16 IrdaObexTransport::m_client_discovery_poll_repeat_counter = 0 [static]

SystemTimer IrdaObexTransport::m_clienttimer [static]

The documentation for this class was generated from the following files:
  • Irda/Obex/IrdaObexTransport.hpp
  • Irda/Obex/IrdaObexTransport.cpp
Generated on Wed Jan 25 01:22:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrdaTransport Class Reference

#include <Apoxi/Irda/IrdaTransport.hpp>

Inheritance diagram for IrdaTransport:

[legend]
Collaboration diagram for IrdaTransport:

[legend]

Public Types

typedef AbstractTransport | Base
enum | ConnType { IrLap, IrLmp, IrComm, IrObex }
enum | IrdaSwitchOffTimeout { default_irda_switch_off_timeout = 600000 }
enum TransportDisableReason {
TransportDisableReasonNotApplicable, TransportDisableReasonIdleTimeout, TransportDisableReasonStackError, TransportDisableReasonAppRequest,
TransportDisableReasonUnknown
}
enum TransportDisableReason to provide info about reason, why transport was disabled More...

Public Member Functions

void | ClearHintBits (UINT byte_offset, UINT8 bit_mask) const
clear IrDA hint bits
void | Disable ()
Request disabling of the transport (asynchronously).
virtual void | Enable ()
Request enabling of the transport (asynchronously).
virtual AvState | GetAvState () const
Returns the availability state of the transport.
BOOLEAN | GetConnState (ConnType type) const
Returns the connection state as specified by type.
BOOLEAN | GetIsWin98Mode () const
TransportDisableReason | GetTransportDisableReason () const
Returns the reason why the transport was disabled.
IrdaTransport ()
Constructor.
void | OnAvStateChanged ()
Indicates change in the availability state of the transport.
void | SetHintBits (UINT byte_offset, UINT8 bit_mask) const
set IrDA hint bits
void | SetIrdaHwTimeout (UINT32 irda_hw_timeout)
set IrDA Hardware Timeout
void | SetIsWin98Mode (BOOLEAN is_win98_mode)
void | SetNickname (UINT8 char_set, const CHAR *nickname) const
set IrDA nickname
~IrdaTransport ()
Destructor. Destroys an IrdaTransport object. Hardware is diabled.

Static Public Member Functions

static IrdaTransport & | GetInstance ()
Singleton accessor.

Member Typedef Documentation

typedef AbstractTransport IrdaTransport::Base

Reimplemented from AbstractTransport.

Member Enumeration Documentation

enum IrdaTransport::ConnType

Enumerator:
IrLap
IrLmp
IrComm
IrObex

enum IrdaTransport::IrdaSwitchOffTimeout

Enumerator:
default_irda_switch_off_timeout

enum IrdaTransport::TransportDisableReason

enum TransportDisableReason to provide info about reason, why transport was disabled

Enumerator:
TransportDisableReasonNotApplicable
TransportDisableReasonIdleTimeout
TransportDisableReasonStackError
TransportDisableReasonAppRequest
TransportDisableReasonUnknown

Constructor & Destructor Documentation

IrdaTransport::IrdaTransport ( )

Constructor.

IrdaTransport::~IrdaTransport ( )

Destructor. Destroys an IrdaTransport object. Hardware is diabled.

Member Function Documentation

void IrdaTransport::ClearHintBits | ( | UINT | byte_offset,
 |  | UINT8 | bit_mask
 | ) | const

clear IrDA hint bits

Parameters:
byte_offset | Offset of hint byte to modify.
bit_mask | Mask of hint bits to clear.

void IrdaTransport::Disable ( )

Request disabling of the transport (asynchronously).

This method attempts to disable the transport. The result is delivered asynchronously by calling OnAvStateChanged().

void IrdaTransport::Enable ( ) [virtual]

Request enabling of the transport (asynchronously).

This method attempts to enable the transport, possibly involving conflict management intervention or MMI activity. Therefore, every implementation is expected to deliver the result asynchronously by calling OnAvStateChanged().

Implements AbstractTransport.

IrdaTransport::AvState IrdaTransport::GetAvState ( ) const [virtual]

Returns the availability state of the transport.

Since state handling can be different for each implementation, this is an abstract method. However, any internal state must be representable by the type AvState

See also:
AvState.

Implements AbstractTransport.

BOOLEAN IrdaTransport::GetConnState ( ConnType type ) const

Returns the connection state as specified by type.

In case of IrLap returns FALSE if there no connection, any other value indicates an active connection For IrLmp, IrComm and IrObex the TRUE is return if at least one connection of the specified type is open.

static IrdaTransport& IrdaTransport::GetInstance ( ) [inline, static]

Singleton accessor.

BOOLEAN IrdaTransport::GetIsWin98Mode ( ) const [inline]

IrdaTransport::TransportDisableReason IrdaTransport::GetTransportDisableReason ( ) const

Returns the reason why the transport was disabled.

void IrdaTransport::OnAvStateChanged ( )

Indicates change in the availability state of the transport.

This method must be called by every implementation whenever the availability of the transport is changed. This will generate a TransportNotificationMsg which tells subscribers about the state change.

Reimplemented from AbstractTransport.

void IrdaTransport::SetHintBits | ( | UINT | byte_offset,
 |  | UINT8 | bit_mask
 | ) | const

set IrDA hint bits

Parameters:
byte_offset | Offset of hint byte to modify.
bit_mask | Mask of hint bits to set.

void IrdaTransport::SetIrdaHwTimeout ( UINT32 irda_hw_timeout )

set IrDA Hardware Timeout

Parameters:
irda_hw_timeout time out in milliseconds.
Use this method to set the IrDA hardware time out to save battery power during idle time. The time out specifies the amount of milliseconds the IrDA hardware remains active after last activity on the interface. The default value is set to 600000 ms = 10 minutes, if Application does not call this function to set a different value. Set to 0 to disable the timer, IrDA hardware will not be switched off in idle state.

void IrdaTransport::SetIsWin98Mode ( BOOLEAN is_win98_mode ) [inline]

void IrdaTransport::SetNickname | ( | UINT8 | char_set,
 |  | const CHAR * | nickname
 | ) | const

set IrDA nickname

Parameters:
char_set | Character set of nickname.
nickname | New nickname (convention: "manufacturor model", e.g. Comneon SuperPhone)
Use this method to set the IrDA nickname as specified in Infrared Data Association Link Management Protocol Version 1.1 chapter 3.4.1.2. Whenever possible use APOXI_IRDA_CHAR_SET_CODE_ASCII as char_set. Note that the actual nickname will be truncated to 20 bytes when 2 hint bits are used.

The documentation for this class was generated from the following files:
  • Irda/IrdaTransport.hpp
  • Irda/IrdaTransport.cpp
Generated on Wed Jan 25 01:22:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrdaWin Class Reference
[IrdaApp]

#include <Applications/IrdaApp/IrdaWin.hpp>

Collaboration diagram for IrdaWin:

[legend]

Public Member Functions

void | Init ()
IrdaWin ()
void | ToggleSelection ()
~IrdaWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual void | OnClose ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

IrdaWin::IrdaWin ( )

IrdaWin::~IrdaWin ( )

Member Function Documentation

void IrdaWin::Init ( )

void IrdaWin::OnActionExecuted ( Action * action ) [protected, virtual]

Display Busy cursor

void IrdaWin::OnClose ( ) [protected, virtual]

void IrdaWin::OnOpen ( ) [protected, virtual]

void IrdaWin::ToggleSelection ( )

The documentation for this class was generated from the following files:
  • Applications/IrdaApp/IrdaWin.hpp
  • Applications/IrdaApp/IrdaWin.cpp
Generated on Wed Jan 25 01:22:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrSocketAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IrSocketAddr Class Reference

#include <Apoxi/AddOns/SioSocketAdapter/IrSocketAddr.hpp>

Inheritance diagram for IrSocketAddr:

[legend]
Collaboration diagram for IrSocketAddr:

[legend]

Public Member Functions

void * | GetSockAddr ()
INT32 | GetSockAddrSize ()
IrSocketAddr (BOOLEAN is_server)
virtual | ~IrSocketAddr ()

Constructor & Destructor Documentation

IrSocketAddr::IrSocketAddr ( BOOLEAN is_server )

Default constructor.

IrSocketAddr::~IrSocketAddr ( ) [virtual]

Destructor.

Member Function Documentation

void * IrSocketAddr::GetSockAddr ( ) [virtual]

This is used only for internal purposes.

Implements SocketAddr.

INT32 IrSocketAddr::GetSockAddrSize ( ) [virtual]

This is used only for internal purposes.

Implements SocketAddr.

The documentation for this class was generated from the following files:
  • AddOns/SioSocketAdapter/IrSocketAddr.hpp
  • AddOns/SioSocketAdapter/IrSocketAddr.cpp
Generated on Wed Jan 25 01:22:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IsrDataContainer< Data, c_queue_size > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IsrDataContainer< Data, c_queue_size > Class Template Reference

#include <Apoxi/Kernel/Os/IsrDataContainer.hpp>

Public Member Functions

IsrDataContainer ()
BOOLEAN | IsrPushData (const Data &data)
BOOLEAN | ThrPopData (Data &data)

Data Structures

struct | QueueEntry

template<class Data, INT c_queue_size = 5>
class IsrDataContainer< Data, c_queue_size >

Constructor & Destructor Documentation

template<class Data, INT c_queue_size>
IsrDataContainer< Data, c_queue_size >::IsrDataContainer ( )

Member Function Documentation

template<class Data, INT c_queue_size>
BOOLEAN IsrDataContainer< Data, c_queue_size >::IsrPushData ( const Data & data )

template<class Data, INT c_queue_size>
BOOLEAN IsrDataContainer< Data, c_queue_size >::ThrPopData ( Data & data )

The documentation for this class was generated from the following file:
  • Kernel/Os/IsrDataContainer.hpp
Generated on Wed Jan 25 01:22:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IsrDataManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IsrDataManager Class Reference

#include <Apoxi/Kernel/Os/IsrDataManager.hpp>

Collaboration diagram for IsrDataManager:

[legend]

Static Public Member Functions

static BOOLEAN | HasPendingData ()
static BOOLEAN | Init ()
static void | ProcessIsrData ()
static void | SetPendingDataFlag (BOOLEAN set=TRUE)

Friends

class | IsrDataMarshaller

Member Function Documentation

static BOOLEAN IsrDataManager::HasPendingData ( ) [inline, static]

BOOLEAN IsrDataManager::Init ( ) [static]

void IsrDataManager::ProcessIsrData ( ) [static]

static void IsrDataManager::SetPendingDataFlag ( BOOLEAN set = TRUE ) [inline, static]

Friends And Related Function Documentation

friend class IsrDataMarshaller [friend]

The documentation for this class was generated from the following files:
  • Kernel/Os/IsrDataManager.hpp
  • Kernel/Os/IsrDataManager.cpp
Generated on Wed Jan 25 01:22:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IsrDataMarshaller Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

IsrDataMarshaller Class Reference

#include <Apoxi/Kernel/Os/IsrDataMarshaller.hpp>

Collaboration diagram for IsrDataMarshaller:

[legend]

Public Member Functions

IsrDataMarshaller ()
virtual void | Marshall ()=0
virtual | ~IsrDataMarshaller ()

Friends

class | IsrDataManager

Constructor & Destructor Documentation

IsrDataMarshaller::IsrDataMarshaller ( )

IsrDataMarshaller::~IsrDataMarshaller ( ) [virtual]

Member Function Documentation

virtual void IsrDataMarshaller::Marshall ( ) [pure virtual]

Friends And Related Function Documentation

friend class IsrDataManager [friend]

The documentation for this class was generated from the following files:
  • Kernel/Os/IsrDataMarshaller.hpp
  • Kernel/Os/IsrDataMarshaller.cpp
Generated on Wed Jan 25 01:22:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Item Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Item Class Reference
[Items]

#include <Apoxi/Gui/Item.hpp>

Inheritance diagram for Item:

[legend]
Collaboration diagram for Item:

[legend]

Public Types

enum | { ID = 0 }
enum ItemPropertyId {
UnspecifiedPropertyId = -1, TextPropertyId = 0, IconPropertyId = 1, EnabledPropertyId = 2,
SeparatorPropertyId = 3, ValuePropertyId = 4, MarkedPropertyId = 5, CustomPropertyId = 999
}

Public Member Functions

void | BlockNotification (BOOLEAN block)
Dispatcher * | GetDispatcher () const
virtual const ImageObtainer & | GetIcon (const IconState &icon_state) const
const ImageObtainer & | GetIcon () const
INT | GetLanguageId () const
virtual const WString & | GetText () const
Returns the text of the item. See Item::SetText for details.
BOOLEAN | HasIcon () const
void | Init (Dispatcher *dispatcher, const WString &text, const IconSet &icon_set, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WString &text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
virtual BOOLEAN | IsEnabled () const
virtual BOOLEAN | IsEqual (const Item &item) const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsMarked () const
BOOLEAN | IsNotificationBlocked () const
BOOLEAN | IsRetranslateEnabled () const
BOOLEAN | IsSeparator () const
BOOLEAN | IsSyncModeEnabled () const
Item (Dispatcher *dispatcher, const WString &text, const IconSet &icon_set, BOOLEAN enabled=TRUE)
Item (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE)
Item (Dispatcher *dispatcher, const WString &text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
Item (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
Item ()
virtual void | OnLanguageChanged ()
virtual void | SetDispatcher (Dispatcher *dispatcher)
virtual void | SetEnabled (BOOLEAN enabled)
void | SetIcon (const IconSet &icon_set)
void | SetIcon (const BitmapRes *icon)
Wrapper-method for Item::SetIcon(ImageObtainer(icon)).
virtual void | SetIcon (const ImageObtainer &icon)
void | SetMarked (BOOLEAN marked)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
void | SetRetranslateEnabled (BOOLEAN enabled)
void | SetSeparator (BOOLEAN is_separator)
void | SetSyncModeEnabled (BOOLEAN enabled)
void | SetText (const WCHAR *text)
Wrapper-method for Item::SetText(WString(text));.
virtual void | SetText (const WString &text)
BOOLEAN | UsesIconSet (BOOLEAN *contains_only_bmps=0) const
virtual | ~Item ()

Protected Member Functions

void | NotifyPropertyChange (INT property_id=UnspecifiedPropertyId)
void | SetEnabledProperty (BOOLEAN enabled) const
void | SetIconProperty (const ImageObtainer &icon) const
void | SetLanguageId (INT lang_id)
void | SetTextProperty (const WString &text) const

Detailed Description

An item is at least represented by a text and/or an icon and informs a dispatcher (e. g. a GUI-component) about changes of the item-properties. The representation of the text and the icon is not part of the item itself; usually items are embedded inside a GUI-component which does the drawing of the item in the desired look.

As not all compilers support RTTI but this is very useful especially for items, they provide a RTTI-support by the method Item::IsInstanceOf. This makes it necessary that each item-class gets a unique ID. The IDs from 0 to 999 are reserved for APOXI:

ID: Class

  • 0: Item
  • 1: Action
  • 2: AbstractItemContainer
  • 3: ItemContainer
  • 4: AbstractToggleAction
  • 5: CheckBoxAction
  • 6: RadioButtonAction

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

enum Item::ItemPropertyId

When a property of an item has been changed, the message ItemPropertiesChanged will be send to the dispatcher, which is assigned to the item. The message contains a property-index, which indicates the changed property or property-group. The property-indices 0 to 999 are reserved for APOXI. Additional defined ids:

  • 5: FeatureItem::FeaturePropertyId
Enumerator:
UnspecifiedPropertyId | Not every property must have its own id. In this case UnspecifiedPropertyId may be used.
TextPropertyId | Indicates that the 'text' property has been changed (see Item::SetText).
IconPropertyId | Indicates that the 'icon' property has been changed (see Item::SetIcon).
EnabledPropertyId | Indicates that the 'enabled' property has been changed (see Item::SetEnabled).
SeparatorPropertyId | Indicates that the 'separator' property has been changed (see Item::SetSeparator).
ValuePropertyId | Indicates that the 'value' property has been changed.
MarkedPropertyId | Indicates that the 'marked' property has been changed (see Item::SetMarked).
CustomPropertyId | Indicates that a custom property has been changed.

Reimplemented in AbstractItemContainer.

Constructor & Destructor Documentation

Item::Item ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

Item::Item | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Item::Item | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Item::Item | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Item::Item | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const IconSet & | icon_set,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon_set | Icon set of the item. Specifying an icon set instead of a bitmap or an image allows having a different icon dependant from the given icon-state in Item::GetIcon. The corresponding icon will be retrieved by invoking the customizable methods GuiEngineConfig::GetImageIcon and GuiEngineConfig::GetBitmapIcon.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Item::~Item ( ) [virtual]

Member Function Documentation

void Item::BlockNotification ( BOOLEAN block ) [inline]

If block is TRUE, the notification to the dispatcher regarding changed properties will be blocked. This might be useful when changing the properties of a large number of items in a loop and the notification is done by the application afterwards anyway. Per default the notification is not blocked.

Dispatcher* Item::GetDispatcher ( ) const [inline]

Returns the dispatcher, which will be informed about property-changes and when executing an item.

const ImageObtainer & Item::GetIcon ( const IconState & icon_state ) const [virtual]

Returns the icon for the icon state specified by icon_state. The corresponding icon will be retrieved by invoking the customizable methods GuiEngineConfig::GetImageIcon and GuiEngineConfig::GetBitmapIcon.

Reimplemented in ProviderProxyItem.

const ImageObtainer & Item::GetIcon ( ) const

Returns the icon for the default icon state. Wrapper-method for Item::GetIcon(IconState(IconState::DefaultSize, IconState::NormalMode)).

INT Item::GetLanguageId ( ) const [inline]

Returns the language ID which is used for the text property.

const WString & Item::GetText ( ) const [virtual]

Returns the text of the item. See Item::SetText for details.

Reimplemented in FeatureItem, and ProviderProxyItem.

BOOLEAN Item::HasIcon ( ) const

Returns TRUE, if the item has at least one icon. The item allows to have up to 9 items dependant from the icon state. See also Item::GetIcon for details.

void Item::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const IconSet & | icon_set,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon_set | Icon set of the item. Specifying an icon set instead of a bitmap or an image allows having a different icon dependant from the given icon-state in Item::GetIcon. The corresponding icon will be retrieved by invoking the customizable methods GuiEngineConfig::GetImageIcon and GuiEngineConfig::GetBitmapIcon.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented in AbstractItemContainer, Action, and ItemContainer.

void Item::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented in AbstractItemContainer, Action, and ItemContainer.

void Item::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented in AbstractItemContainer, Action, and ItemContainer.

void Item::Init | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented in SubMenuAction, AbstractItemContainer, Action, and ItemContainer.

BOOLEAN Item::IsEnabled ( ) const [virtual]

Returns TRUE, if the item is enabled. See Item::IsEnabled for details.

Reimplemented in FeatureItem, and ItemContainer.

BOOLEAN Item::IsEqual ( const Item & item ) const [virtual]

Returns TRUE, if the content of the item is the same as the content of the item item. The default implementation returns TRUE, if the properties text, icon and enabled are identical.

Reimplemented in FeatureItem, FeatureItemContainer, ProviderProxyItem, and AbstractToggleAction.

BOOLEAN Item::IsInstanceOf ( INT id ) const [virtual]

Returns TRUE, if the item is an instance of the item-class with the ID id. Must be implemented by each derived class the following way:

BOOLEAN MyItem::IsInstanceOf(INT id) const
{
    if (ID != id)
        return Base::IsInstanceOf(id);
    return TRUE;
}

Example: if it should be checked, whether an item is an instance of the class Action the following code might be used:

if (item->IsInstanceOf(Action::ID)) {
    Action* action = (Action*)item;
    ...
}

The IDs from 0 to 999 are reserved for APOXI.

Reimplemented in ContextFeatureItem, FeatureItem, FeatureItemContainer, IndicatorItem, ProviderProxyContainer, ProviderProxyItem, PropertyItem, AbstractItemContainer, AbstractToggleAction, Action, CheckBoxAction, ItemContainer, and RadioButtonAction.

BOOLEAN Item::IsMarked ( ) const [inline]

Returns TRUE, if the items has been marked. See Item::SetMarked for details.

BOOLEAN Item::IsNotificationBlocked ( ) const [inline]

Returns TRUE, if the notification to the dispatcher regarding changed properties will be blocked. Per default FALSE is returned.

BOOLEAN Item::IsRetranslateEnabled ( ) const [inline]

Returns TRUE, if the text property will be translated if the language has been changed. Per default TRUE is returned.

BOOLEAN Item::IsSeparator ( ) const [inline]

Returns TRUE, if the item represents a separator. See Item::SetSeparator for details.

BOOLEAN Item::IsSyncModeEnabled ( ) const [inline]

Returns TRUE, if the synchronous mode is enabled. See Item::SetSyncModeEnabled for more details. Per default TRUE is returned.

void Item::NotifyPropertyChange ( INT property_id = UnspecifiedPropertyId ) [protected]

Sends the message ItemPropertiesChangedMsg to the to the dispatcher provided by the constructor or Init. No message is send, if the the item is blocked or the dispatcher has not been set. When adding properties to a derived class, this method should be invoked in the Set-method of the property, if the value is different from the current set value.

void Item::OnLanguageChanged ( ) [virtual]

Is usually invoked by the control where the item has been attached and retranslates the text property of the item.

Reimplemented in FeatureItem.

virtual void Item::SetDispatcher ( Dispatcher * dispatcher ) [inline, virtual]

Sets the dispatcher, which will be informed about property-changes and when executing an item. Usually it should not be necessary to change the dispatcher during runtime.

void Item::SetEnabled ( BOOLEAN enabled ) [virtual]

Sets the item enabled (enabled is TRUE) or disabled (enabled is FALSE) and sends the message ItemPropertiesChangedMsg with the property-id EnabledPropertyId to the dispatcher assigned to the item.

Reimplemented in FeatureItem.

void Item::SetEnabledProperty ( BOOLEAN enabled ) const [inline, protected]

Allows to modify the enabled-property for derived classes without triggering a notification to the dispatcher. This might be useful when overwriting the method Item::IsEnabled to assure a consistent state between the internal property and the returned value. Note that invoking this method means a "lazy" updating of the enabled-property and should be used with care, as the dispatcher is not informed about the change. In general it is strongly recommended to use the method Item::SetEnabled for updating the enabled-property.

void Item::SetIcon ( const IconSet & icon_set )

Sets the icon represented as IconSet and sends the message ItemPropertiesChangedMsg with the property-id IconPropertyId to the dispatcher assigned to the item.

void Item::SetIcon ( const BitmapRes * icon )

Wrapper-method for Item::SetIcon(ImageObtainer(icon)).

void Item::SetIcon ( const ImageObtainer & icon ) [virtual]

Sets the icon and sends the message ItemPropertiesChangedMsg with the property-id IconPropertyId to the dispatcher assigned to the item.

void Item::SetIconProperty ( const ImageObtainer & icon ) const [protected]

Allows to modify the icon-property for derived classes without triggering a notification to the dispatcher. This might be useful when overwriting the method Item::GetIcon to assure a consistent state between the internal property and the returned value. Note that invoking this method means a "lazy" updating of the icon-property and should be used with care, as the dispatcher is not informed about the change. In general it is strongly recommended to use the method Item::SetIcon for updating the icon-property.

void Item::SetLanguageId ( INT lang_id ) [inline, protected]

Sets the language ID for the text property. The item remembers the currently used language ID, so that a retranslation in Item::OnLanguageChanged is only done when necessary. For derived classes which have overwritten the method Item::OnLanguageChanged it might be required to set the language ID if Item::OnLanguageChanged is not invoked.

void Item::SetMarked ( BOOLEAN marked )

If marked is TRUE, the item will be considered as marked. The representation depends on the component where the item is added to (usually marked items are inverted). The message ItemPropertiesChangedMsg with the property-ID MarkedPropertyId is send to the dispatcher assigned to the item.

BOOLEAN Item::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented in ContextFeatureItem, FeatureItem, FeatureItemContainer, IndicatorItem, PropertyItem, AbstractItemContainer, AbstractToggleAction, Action, CheckBoxAction, CloseWindowAction, ItemContainer, OpenContextMenuAction, OpenWindowAction, and RadioButtonAction.

void Item::SetRetranslateEnabled ( BOOLEAN enabled ) [inline]

Activates the retranslating of the text property if enabled is TRUE. Per default the retranslating is enabled: each time the language has been changed during runtime, the text of the item automatically will be retranslated. If this is not wanted (e. g. when showing items representing a dictionary), the retranslating can be disabled by this method.

void Item::SetSeparator ( BOOLEAN is_separator )

If is_separator is TRUE, the item will be considered as separator. The representation depends on the component where the item is added to (usually separator items are represented by a horizontal line). The message ItemPropertiesChangesMsg with the property-ID SeparatorPropertyId is send to the dispatcher assigned to the item.

void Item::SetSyncModeEnabled ( BOOLEAN enabled ) [inline]

Activates the synchronous mode, if enabled is TRUE. Per default the synchronous mode is enabled: Each time the property of an item is changed, the dispatcher assigned to the item is informed synchronously by the message ItemPropertyChangedMsg. If the synchronous mode is disabled by invoking Item::SetSyncModeEnabled(FALSE), the ItemPropertyChangedMsg is broadcasted to the system so that a variable number of dispatchers may react asynchronously on the message. Note that in this case the applications have to register for the ItemPropertiesChangedMsg by invoking Application::RegisterMessage(ItemPropertiesChangedMsg::ID).

void Item::SetText ( const WCHAR * text )

Wrapper-method for Item::SetText(WString(text));.

void Item::SetText ( const WString & text ) [virtual]

Sets the text and sends the message ItemPropertiesChangedMsg with the property-id TextPropertyId to the dispatcher assigned to the item.

Reimplemented in FeatureItem.

void Item::SetTextProperty ( const WString & text ) const [inline, protected]

Allows to modify the text-property for derived classes without triggering a notification to the dispatcher. This might be useful when overwriting the method Item::GetText to assure a consistent state between the internal property and the returned value. Note that invoking this method means a "lazy" updating of the text-property and should be used with care, as the dispatcher is not informed about the change. In general it is strongly recommended to use the method Item::SetText for updating the text-property.

BOOLEAN Item::UsesIconSet ( BOOLEAN * contains_only_bmps = 0 ) const

Returns TRUE, if the icon of the item is represented by an IconSet (this means that the item count is greater than 1).

Parameters:
contains_only_bmps Optional output parameter which is TRUE, if the icon set only contains bitmaps. This parameter is useful when a decision must be done whether an ImageBox should be used or a direct drawing of a bitmap may be done.

The documentation for this class was generated from the following files:
  • Gui/Item.hpp
  • Gui/Item.cpp
Generated on Wed Jan 25 01:22:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemBox Class Reference
[Components]

#include <Apoxi/Gui/ItemBox.hpp>

Inheritance diagram for ItemBox:

[legend]
Collaboration diagram for ItemBox:

[legend]

Public Types

enum | { ID = 37 }

Public Member Functions

virtual XYDIM | GetDefaultHeight () const
virtual XYDIM | GetDefaultWidth () const
Item * | GetItem () const
const AbstractItemRenderer * | GetRenderer () const
void | Init (Control *control, Item *item)
virtual BOOLEAN | IsInstanceOf (INT id) const
ItemBox (Control *control, Item *item)
ItemBox ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetRenderer (const ItemRendererProperties *properties=0)
virtual | ~ItemBox ()

Protected Member Functions

virtual void | Cleanup ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | Refresh (const Rect &rect)

Friends

class | TriggerTimer< ItemBox >

Detailed Description

Represents a drawable object which displays any kind of item. It's possible to specify an item renderer to customize the look.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

ItemBox::ItemBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ItemBox::ItemBox | ( | Control * | control,
 |  | Item * | item
 | ) |

Parameters:
control | Parent control where the item box is embedded. Usually the parent control is an instance of the class Window.
item | Item which should be displayed. Changing the properties of this item automatically leads to a redrawing of the item box. If no dispatcher has been set for the item, the item box will be set as dispatcher automatically.

ItemBox::~ItemBox ( ) [virtual]

Member Function Documentation

void ItemBox::Cleanup ( ) [protected, virtual]

See also:
Component::Cleanup

Reimplemented from Component.

XYDIM ItemBox::GetDefaultHeight ( ) const [virtual]

See also:
Component::GetDefaultHeight

Reimplemented from Component.

XYDIM ItemBox::GetDefaultWidth ( ) const [virtual]

See also:
Component::GetDefaultWidth

Reimplemented from Component.

Item* ItemBox::GetItem ( ) const [inline]

Returns a pointer to the item which is embedded by the image box. Setting a property of the item automatically leads to redrawing of the item box.

const AbstractItemRenderer* ItemBox::GetRenderer ( ) const [inline]

Returns the renderer which is used for drawing the item. Per default 0 is returned, which means that the the icon or the text of the item is drawn centered inside the bounding rectangle of the item box.

void ItemBox::Init | ( | Control * | control,
 |  | Item * | item
 | ) |

Parameters:
control | Parent control where the item box is embedded. Usually the parent control is an instance of the class Window.
item | Item which should be displayed. Changing the properties of this item automatically leads to a redrawing of the item box.

Reimplemented in AtlItemBox.

BOOLEAN ItemBox::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from DrawableObject.

BOOLEAN ItemBox::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from DrawableObject.

Reimplemented in AtlItemBox.

void ItemBox::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnResize()

Reimplemented from DrawableObject.

void ItemBox::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from Component.

Reimplemented in AtlItemBox.

BOOLEAN ItemBox::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by ARAGON to set the properties of the item box out of a resource file. It should not be necessary for the application developer to invoke this method in a direct manner.

Reimplemented from DrawableObject.

void ItemBox::SetRenderer ( const ItemRendererProperties * properties = 0 )

Sets the renderer which is used for drawing the item. To keep the resource demand low per default no renderer is set. In this case the icon or the text of the item is drawn centered inside the bounding rectangle of the item box. The item renderer is specified by the renderer properties and can be configured inside the method GuiEngineConfig::ObtainItemRenderer.

Parameters:
properties Item-renderer-properties which are used by the renderer. If 0 is passed, no renderer will be instantiated. To use the default item renderer use GuiEngineConfig::GetDefaultItemRendererProperties() as parameter.
See also:
GuiEngineConfig::ObtainItemRenderer

Friends And Related Function Documentation

friend class TriggerTimer< ItemBox > [friend]

The documentation for this class was generated from the following files:
  • Gui/ItemBox.hpp
  • Gui/ItemBox.cpp
Generated on Wed Jan 25 01:22:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemBoxView Class Reference
[Components]

#include <Apoxi/Gui/ItemBox.hpp>

Inheritance diagram for ItemBoxView:

[legend]
Collaboration diagram for ItemBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
ItemBoxView ()
virtual | ~ItemBoxView ()

Detailed Description

Displays the item of an item box.

Constructor & Destructor Documentation

ItemBoxView::ItemBoxView ( )

ItemBoxView::~ItemBoxView ( ) [virtual]

Member Function Documentation

void ItemBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

The documentation for this class was generated from the following files:
  • Gui/ItemBox.hpp
  • Gui/ItemBox.cpp
Generated on Wed Jan 25 01:22:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemContainer Class Reference
[Items]

#include <Apoxi/Gui/ItemContainer.hpp>

Inheritance diagram for ItemContainer:

[legend]
Collaboration diagram for ItemContainer:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

virtual BOOLEAN | AddItem (Item *item)
virtual Item * | GetItem (INT index) const
virtual INT | GetItemCount () const
virtual INT | GetItemIndex (const Item &item) const
virtual AbstractItemContainer * | GetParentContainer ()
virtual const ItemRendererProperties * | GetRendererProperties () const
void | Init (Dispatcher *dispatcher, const WString &text, const IconSet &icon_set, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WString &text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
virtual BOOLEAN | InsertItem (INT index, Item *item)
virtual BOOLEAN | IsEnabled () const
virtual BOOLEAN | IsInstanceOf (INT id) const
ItemContainer (Dispatcher *dispatcher, const WString &text, const IconSet &icon_set, BOOLEAN enabled=TRUE)
ItemContainer (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE)
ItemContainer (Dispatcher *dispatcher, const WString &text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
ItemContainer (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *icon=0, BOOLEAN enabled=TRUE)
ItemContainer ()
virtual BOOLEAN | RemoveAllItems ()
virtual BOOLEAN | RemoveItem (INT index)
virtual BOOLEAN | SetParentContainer (AbstractItemContainer *container)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual BOOLEAN | SetRendererProperties (const ItemRendererProperties *properties)
virtual | ~ItemContainer ()

Detailed Description

Default implementation for the class AbstractItemContainer, which stores the items inside a vector.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractItemContainer.

Constructor & Destructor Documentation

ItemContainer::ItemContainer ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ItemContainer::ItemContainer | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

ItemContainer::ItemContainer | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

ItemContainer::ItemContainer | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

ItemContainer::ItemContainer | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const IconSet & | icon_set,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon_set | Icon set of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

ItemContainer::~ItemContainer ( ) [virtual]

Member Function Documentation

BOOLEAN ItemContainer::AddItem ( Item * item ) [virtual]

See also:
AbstractItemContainer::AddItem

Implements AbstractItemContainer.

Reimplemented in FeatureItemContainer, and ProviderProxyContainer.

Item * ItemContainer::GetItem ( INT index ) const [virtual]

See also:
AbstractItemContainer::GetItem

Implements AbstractItemContainer.

Reimplemented in FeatureItemContainer.

INT ItemContainer::GetItemCount ( ) const [virtual]

See also:
AbstractItemContainer::GetItemCount

Implements AbstractItemContainer.

Reimplemented in FeatureItemContainer.

INT ItemContainer::GetItemIndex ( const Item & item ) const [virtual]

See also:
AbstractItemContainer::GetItemIndex

Implements AbstractItemContainer.

Reimplemented in FeatureItemContainer.

AbstractItemContainer * ItemContainer::GetParentContainer ( ) [virtual]

See also:
AbstractItemContainer::GetParentContainer

Implements AbstractItemContainer.

Reimplemented in ProviderProxyContainer.

const ItemRendererProperties * ItemContainer::GetRendererProperties ( ) const [virtual]

See also:
AbstractItemContainer::GetRendererProperties

Reimplemented from AbstractItemContainer.

void ItemContainer::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const IconSet & | icon_set,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon_set | Icon set of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented from AbstractItemContainer.

void ItemContainer::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented from AbstractItemContainer.

void ItemContainer::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented from AbstractItemContainer.

void ItemContainer::Init | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | icon = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which is informed about property changes of the item container. Usually the control which embeds the item container (e. g. ItemMenu, ItemTree or ItemGrid) is the dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.

Reimplemented from AbstractItemContainer.

BOOLEAN ItemContainer::InsertItem | ( | INT | index,
 |  | Item * | item
 | ) | [virtual]

See also:
AbstractItemContainer::InsertItem

Implements AbstractItemContainer.

Reimplemented in FeatureItemContainer, and ProviderProxyContainer.

BOOLEAN ItemContainer::IsEnabled ( ) const [virtual]

See also:
Item::IsEnabled

Reimplemented from Item.

BOOLEAN ItemContainer::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from AbstractItemContainer.

Reimplemented in FeatureItemContainer, and ProviderProxyContainer.

BOOLEAN ItemContainer::RemoveAllItems ( ) [virtual]

Removes all items from the item container. Note that if the items have been allocated dynamically, the creator of the items is also responsible for deleting the items. For deleting dynamically allocated items the following code should used:

ItemContainer* item_cont = ...;
INT count = item_cont->GetItemCount();
for (INT i = 0; i < count; i++) {
    Item* item = item_cont->GetItem(0);
    item_cont->RemoveItem(0);
    delete item;
}
For items which are not created dynamically it is safe just to invoke ItemContainer::RemoveAllItems.

See also:
AbstractItemContainer::RemoveAllItems

Implements AbstractItemContainer.

Reimplemented in FeatureItemContainer, and ProviderProxyContainer.

BOOLEAN ItemContainer::RemoveItem ( INT index ) [virtual]

Removes the item from the item container. Note that if the item has been allocated dynamically, the creator of the item is also responsible for deleting the item. For deleting dynamically allocated items the following code can be used:

Item* item = item_cont->GetItem(index);
item_cont->RemoveItem(index);
delete item;
See also:
AbstractItemContainer::RemoveItem

Implements AbstractItemContainer.

Reimplemented in FeatureItemContainer, and ProviderProxyContainer.

BOOLEAN ItemContainer::SetParentContainer ( AbstractItemContainer * container ) [virtual]

See also:
AbstractItemContainer::SetParentContainer

Implements AbstractItemContainer.

Reimplemented in ProviderProxyContainer.

BOOLEAN ItemContainer::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractItemContainer.

Reimplemented in FeatureItemContainer.

BOOLEAN ItemContainer::SetRendererProperties ( const ItemRendererProperties * properties ) [virtual]

See also:
AbstractItemContainer::SetRendererProperties

Reimplemented from AbstractItemContainer.

The documentation for this class was generated from the following files:
  • Gui/ItemContainer.hpp
  • Gui/ItemContainer.cpp
Generated on Wed Jan 25 01:22:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemGrid Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemGrid Class Reference
[Components]

#include <Apoxi/Gui/ItemGrid.hpp>

Inheritance diagram for ItemGrid:

[legend]
Collaboration diagram for ItemGrid:

[legend]

Public Types

enum | { ID = 12 }

Public Member Functions

virtual INT | GetColumnCount () const
void | Init (Control *parent, AbstractItemContainer *item_cont=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
ItemGrid (Control *parent, AbstractItemContainer *item_cont=0)
ItemGrid ()
void | SetColumnCount (INT count)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~ItemGrid ()

Detailed Description

An item-grid may contain a variable number of items, which are displayed inside a vertically scrollable grid. The number of columns may be adjusted dynamically. If the item-grid only has one column, it behaves like a listbox.

The rendering of the items is defined by an instance of the class AbstractItemRenderer, which may be changed by AbstractItemGrid::SetRenderer.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractItemGrid.

Constructor & Destructor Documentation

ItemGrid::ItemGrid ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ItemGrid::ItemGrid | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0
 | ) |

Parameters:
parent | Parent control where the item grid is embedded.
item_cont | Item container, which specifies the items which should be part of the item grid. If no item container is specified, an item container is allocated automatically internally.

ItemGrid::~ItemGrid ( ) [virtual]

Member Function Documentation

INT ItemGrid::GetColumnCount ( ) const [virtual]

See also:
AbstractGrid::GetColumnCount

Implements AbstractGrid.

void ItemGrid::Init | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0
 | ) |

Parameters:
parent | Parent control where the item grid is embedded.
item_cont | Item container, which specifies the items which should be part of the item grid. If no item container is specified, an item container is allocated automatically internally.

Reimplemented from AbstractItemGrid.

Reimplemented in AtlItemGrid.

BOOLEAN ItemGrid::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractItemGrid.

Reimplemented in ItemMenu.

void ItemGrid::SetColumnCount ( INT count )

Sets the number of columns to count. Per default the column count is set to -1, which results in using the number of columns defined by the item renderer properties. The item renderer properties have a default column count of 1, which means that the item grid looks like a listbox.

BOOLEAN ItemGrid::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractItemGrid.

Reimplemented in ItemMenu.

The documentation for this class was generated from the following files:
  • Gui/ItemGrid.hpp
  • Gui/ItemGrid.cpp
Generated on Wed Jan 25 01:22:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemLabel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemLabel Class Reference
[APOXI Template Layer]

DrawableObject, which shows text. More...

#include <Apoxi/Atl/Gui/ItemLabel.hpp>

Inheritance diagram for ItemLabel:

[legend]
Collaboration diagram for ItemLabel:

[legend]

Public Member Functions

const Item & | GetItem () const
AbstractItemRenderer * | GetRenderer () const
void | Init (Control *control, const Item &item, BOOLEAN auto_draw=TRUE)
void | Init (Control *control)
ItemLabel (Control *control, const Item &item, BOOLEAN auto_draw=TRUE)
ItemLabel ()
void | SetItem (const Item &item)
void | SetRenderer (const ItemRendererProperties *properties=0)
virtual | ~ItemLabel ()

Detailed Description

DrawableObject, which shows text.

The ItemLabel is obsolete with APOXI 2.9.0 Please use the ItemBox provided by APOXI/GUI instead This class will not be maintained and is not configurable with the APOXI GUI Editor

Constructor & Destructor Documentation

ItemLabel::ItemLabel ( )

ItemLabel::ItemLabel | ( | Control * | control,
 |  | const Item & | item,
 |  | BOOLEAN | auto_draw = TRUE
 | ) |

ItemLabel::~ItemLabel ( ) [virtual]

Member Function Documentation

const Item& ItemLabel::GetItem ( ) const [inline]

AbstractItemRenderer* ItemLabel::GetRenderer ( ) const [inline]

void ItemLabel::Init | ( | Control * | control,
 |  | const Item & | item,
 |  | BOOLEAN | auto_draw = TRUE
 | ) |

void ItemLabel::Init ( Control * control )

void ItemLabel::SetItem ( const Item & item ) [inline]

void ItemLabel::SetRenderer ( const ItemRendererProperties * properties = 0 )

The documentation for this class was generated from the following files:
  • Atl/Gui/ItemLabel.hpp
  • Atl/Gui/ItemLabel.cpp
Generated on Wed Jan 25 01:22:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemLabelView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemLabelView Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Gui/ItemLabel.hpp>

Inheritance diagram for ItemLabelView:

[legend]
Collaboration diagram for ItemLabelView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
ItemLabelView ()
virtual | ~ItemLabelView ()

Constructor & Destructor Documentation

ItemLabelView::ItemLabelView ( )

ItemLabelView::~ItemLabelView ( ) [virtual]

Member Function Documentation

void ItemLabelView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

The documentation for this class was generated from the following files:
  • Atl/Gui/ItemLabel.hpp
  • Atl/Gui/ItemLabel.cpp
Generated on Wed Jan 25 01:22:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemMenu Class Reference
[Components]

#include <Apoxi/Gui/ItemMenu.hpp>

Inheritance diagram for ItemMenu:

[legend]
Collaboration diagram for ItemMenu:

[legend]

Public Types

enum | { ID = 13 }

Public Member Functions

BOOLEAN | AdjustWindowTitle () const
virtual BOOLEAN | Back ()
INT | GetLevel () const
Returns the current shown menu-level. 0 indicates the root-menu.
const LevelInfo * | GetLevelInfo (INT level)
void | Init (Control *parent, AbstractItemContainer *item_cont=0, BOOLEAN adjust_win_title=FALSE)
virtual BOOLEAN | IsInstanceOf (INT id) const
ItemMenu (Control *parent, AbstractItemContainer *item_cont=0, BOOLEAN adjust_win_title=FALSE)
ItemMenu ()
void | SetAdjustWindowTitle (BOOLEAN flag)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual BOOLEAN | Trigger (INT index=-1)
virtual | ~ItemMenu ()

Protected Member Functions

virtual void | Cleanup ()
virtual void | OnLevelChange (INT old_level, INT new_level)
virtual void | OnSelectionChanged ()
virtual void | Refresh (const Rect &rect)

Data Structures

class | LevelInfo

Detailed Description

Extends the item-grid to allow traversing a hierarchical menu. A menu is defined by an instance of the class ItemContainer, which may contain a variable number of items. As an ItemContainer is also an instance of the class Item, it is possible to recursively embedd item-containers inside other item-containers, which leads to a hierarchical item-tree.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from ItemGrid.

Constructor & Destructor Documentation

ItemMenu::ItemMenu ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ItemMenu::ItemMenu | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0,
 |  | BOOLEAN | adjust_win_title = FALSE
 | ) |

Parameters:
parent | Parent-control, where the ItemMenu is attached.
item_cont | Item-container, which specifies the items which should be part of the AbstractItemGrid.
adjust_win_title | If set to TRUE, the title of the window where the item-menu is embedded will be adjusted automatically to the text of the currently shown item-container.

ItemMenu::~ItemMenu ( ) [virtual]

Member Function Documentation

BOOLEAN ItemMenu::AdjustWindowTitle ( ) const [inline]

Returns TRUE, if the title of the window where the item-menu is embedded will be adjusted automatically to the text of the currently shown item-container.

BOOLEAN ItemMenu::Back ( ) [virtual]

This method must be invoked to go back the menu-hierarchy. The method ItemMenu::GetLevel can be invoked to determine the current menu-level.

void ItemMenu::Cleanup ( ) [protected, virtual]

See also:
Component::Cleanup

Reimplemented from AbstractItemGrid.

INT ItemMenu::GetLevel ( ) const [inline]

Returns the current shown menu-level. 0 indicates the root-menu.

const ItemMenu::LevelInfo * ItemMenu::GetLevelInfo ( INT level )

Returns the level information for the level with the index level. Note that only a level information is provided for levels which are smaller than the current level. This is because all the information for the currently shown level is already provided by the methods from AbstractItemMenu. The current level can be retrieved by invoking ItemMenu::GetLevel.

void ItemMenu::Init | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0,
 |  | BOOLEAN | adjust_win_title = FALSE
 | ) |

Parameters:
parent | Parent-control, where the ItemMenu is attached.
item_cont | Item-container, which specifies the items which should be part of the AbstractItemGrid.
adjust_win_title | If set to TRUE, the title of the window where the item-menu is embedded will be adjusted automatically to the text of the currently shown item-container.

BOOLEAN ItemMenu::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from ItemGrid.

void ItemMenu::OnLevelChange | ( | INT | old_level,
 |  | INT | new_level
 | ) | [protected, virtual]

Is invoked, before the level of a menu will bee changed by the methods ItemMenu::Trigger or ItemMenu::Back. The method is also invoked when the window containing the item-menu is opened. By overwriting this method e. g. the number of columns of the menu can be changed dynamically dependant from the level.

Parameters:
old_level
new_level

void ItemMenu::OnSelectionChanged ( ) [protected, virtual]

See also:
AbstractGrid::OnSelectionChanged

Reimplemented from AbstractItemGrid.

void ItemMenu::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from AbstractItemGrid.

void ItemMenu::SetAdjustWindowTitle ( BOOLEAN flag ) [inline]

If flag is TRUE, the title of the window where the item-menu is embedded will be adjusted automatically to the text of the currently shown item-container.

BOOLEAN ItemMenu::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from ItemGrid.

BOOLEAN ItemMenu::Trigger ( INT index = -1 ) [virtual]

This method must be invoked to trigger an item (e. g. ItemMenu::Trigger may get invoked by pressing a softkey). Per default the selected item is triggered. If the item is an instance of the class Action, the action will be executed. If the item is an instance of the class AbstractItemContainer, the item-menu will replace the current content by the content of the item-container - this just means showing the content of the sub-menu.

Parameters:
index Index of the item which should get triggered. If the index is < 0, the selected item is triggered.

The documentation for this class was generated from the following files:
  • Gui/ItemMenu.hpp
  • Gui/ItemMenu.cpp
Generated on Wed Jan 25 01:22:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemMenu::LevelInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ItemMenu::LevelInfo

ItemMenu::LevelInfo Class Reference

#include <Apoxi/Gui/ItemMenu.hpp>

Collaboration diagram for ItemMenu::LevelInfo:

[legend]

Public Member Functions

INT | GetFirstVisibleColumn () const
INT | GetFirstVisibleIndex () const
AbstractItemContainer * | GetItemContainer () const
INT | GetSelectedIndex () const
LevelInfo (const ItemMenu &menu)
LevelInfo ()

Detailed Description

Provides information for each menu level and can be retrieved by invoking ItemMenu::GetLevelInfo(INT level).

Constructor & Destructor Documentation

ItemMenu::LevelInfo::LevelInfo ( ) [inline]

ItemMenu::LevelInfo::LevelInfo ( const ItemMenu & menu )

Member Function Documentation

INT ItemMenu::LevelInfo::GetFirstVisibleColumn ( ) const [inline]

INT ItemMenu::LevelInfo::GetFirstVisibleIndex ( ) const [inline]

AbstractItemContainer* ItemMenu::LevelInfo::GetItemContainer ( ) const [inline]

INT ItemMenu::LevelInfo::GetSelectedIndex ( ) const [inline]

The documentation for this class was generated from the following files:
  • Gui/ItemMenu.hpp
  • Gui/ItemMenu.cpp
Generated on Wed Jan 25 01:22:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemObj Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemObj Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/ItemObj.hpp>

Inheritance diagram for ItemObj:

[legend]
Collaboration diagram for ItemObj:

[legend]

Public Member Functions

virtual GenericObject * | Copy () const
Creates a copy of the object itself.
Item * | GetItem () const
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class.
virtual BOOLEAN | IsEqual (GenericObject *object)
ItemObj (Item *item)
void | SetItem (Item *item)
virtual | ~ItemObj ()

Constructor & Destructor Documentation

ItemObj::ItemObj ( Item * item )

ItemObj::~ItemObj ( ) [virtual]

Member Function Documentation

GenericObject * ItemObj::Copy ( ) const [virtual]

Creates a copy of the object itself.

Implements GenericObject.

Item* ItemObj::GetItem ( ) const [inline]

GenericTypeId ItemObj::GetTypeId ( ) [virtual]

Returns the identity of the class.

Implements GenericObject.

BOOLEAN ItemObj::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object instance itself

Implements GenericObject.

void ItemObj::SetItem ( Item * item )

The documentation for this class was generated from the following files:
  • Atl/Features/ItemObj.hpp
  • Atl/Features/ItemObj.cpp
Generated on Wed Jan 25 01:22:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemPropertiesChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemPropertiesChangedMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ItemPropertiesChangedMsg:

[legend]
Collaboration diagram for ItemPropertiesChangedMsg:

[legend]

Public Types

enum | { ID = 302 }

Public Member Functions

virtual Message * | Clone () const
Action * | GetAction () const
Obsolete - provided for backward compatibility.
Item * | GetItem () const
virtual const MsgMetaData & | GetMetaData () const
INT | GetPropertyId () const
ItemPropertiesChangedMsg (Item *item, INT property_id)
virtual | ~ItemPropertiesChangedMsg ()

Detailed Description

This message is sent from an Item, if one of its properties has changed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ItemPropertiesChangedMsg::ItemPropertiesChangedMsg | ( | Item * | item,
 |  | INT | property_id
 | ) |

ItemPropertiesChangedMsg::~ItemPropertiesChangedMsg ( ) [virtual]

Member Function Documentation

Message * ItemPropertiesChangedMsg::Clone ( ) const [virtual]

Implements Message.

Action * ItemPropertiesChangedMsg::GetAction ( ) const

Obsolete - provided for backward compatibility.

Item* ItemPropertiesChangedMsg::GetItem ( ) const [inline]

const MsgMetaData & ItemPropertiesChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

INT ItemPropertiesChangedMsg::GetPropertyId ( ) const [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:22:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemRendererProperties Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemRendererProperties Class Reference
[GUI]

#include <Apoxi/Gui/ItemRendererProperties.hpp>

Collaboration diagram for ItemRendererProperties:

[legend]

Public Types

enum | { ID = 0 }
enum AnimType {
NoAnimation = 0, CycleAnimation = 1, BounceAnimation = 2, BlinkingAnimation = 3,
IconAnimation = 4, OnlyOnceAnimation = 5, CustomAnimation = 99, CycleVerticalAnimation = 1,
CycleHorizontalAnimation = 1, HardVerticalAnimation = 1, HardHorizontalAnimation = 1, SoftVerticalAnimation = 1,
SoftHorizontalAnimation = 1
}
enum DisplayType {
TextAndIconDisplayType = 0, TextDisplayType = 1, IconDisplayType = 2, TextAboveIconDisplayType = 3,
TextBelowIconDisplayType = 4, TextOverlapsIconDisplayType = 5, CustomDisplayType = 99
}

Public Member Functions

BOOLEAN | FullScreenPerItem () const
INT | GetAnimType () const
const Color & | GetBackgroundColor () const
const ImageObtainer & | GetBackgroundImage () const
Returns the background image of the item.
INT | GetColumnCount () const
INT | GetDisplayType () const
XYDIM | GetGap () const
Returns the gap between the icon, text and border of the item.
XYDIM | GetHeight () const
INT | GetRendererHint () const
UINT16 | GetScrollDelay () const
Returns the scroll delay in milliseconds.
XYDIM | GetScrollGap () const
Returns the scroll gap in pixels.
XYDIM | GetSelectionHeight () const
UINT16 | GetStartDelay () const
const Color & | GetTextColor () const
const TextFormat & | GetTextFormat () const
BOOLEAN | IndicateItemContainer () const
Returns TRUE, if an item container will be indicated by a small arrow.
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsMultiLine () const
BOOLEAN | IsTransparent () const
Returns TRUE, if no background for the item will be drawn.
BOOLEAN | IsVerticalCentered () const
Returns TRUE, if the text should be centered vertically inside the available height.
ItemRendererProperties (INT display_type, INT anim_type, UINT16 scroll_delay, XYDIM scroll_gap, const TextFormat &text_format, BOOLEAN full_screen_per_item=FALSE, BOOLEAN transparent=FALSE, BOOLEAN multi_line=FALSE, BOOLEAN centered_vertical=TRUE, BOOLEAN indicate_item_cont=FALSE, const Color &backgr_color=Color(Color::ClientBackground), XYDIM height=-1, XYDIM gap=2, INT column_count=1, XYDIM selection_height=-1, UINT16 start_delay=0, const ImageObtainer &backgr_image=ImageObtainer(), const Color *text_color=0, INT renderer_hint=0)
ItemRendererProperties ()
void | SetAnimType (INT anim_type)
void | SetBackgroundColor (const Color &backgr_color)
void | SetBackgroundImage (const ImageObtainer &backgr_image)
void | SetColumnCount (INT column_count)
void | SetDisplayType (INT display_type)
void | SetFullScreenPerItem (BOOLEAN full_screen_per_item)
void | SetGap (XYDIM gap)
Sets the gap between the icon, text and border of the item.
void | SetHeight (XYDIM height)
void | SetIndicateItemContainer (BOOLEAN flag)
If set to TRUE, an item container will be indicated by a small arrow.
void | SetMultiLine (BOOLEAN multi_line)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetRendererHint (INT renderer_hint)
void | SetScrollDelay (UINT16 scroll_delay)
void | SetScrollGap (XYDIM scroll_gap)
void | SetSelectionHeight (XYDIM selection_height)
void | SetStartDelay (UINT16 start_delay)
void | SetTextColor (const Color *text_color)
void | SetTextFormat (const TextFormat &text_format)
void | SetTransparent (BOOLEAN transparent)
If set to TRUE, no background for the item will be drawn.
void | SetVerticalCentered (BOOLEAN vertical_centered)
If set to TRUE, the text should be centered vertically inside the available height.
virtual | ~ItemRendererProperties ()

Detailed Description

One instance of the item-renderer properties may be assigned to a variable number of item renderers. The item-renderer properties defines how the item-renderer should render and animate its items. Usually GUI-components which use a renderer also offer methods for setting the item-properties (e. g. see AbstractItemGrid::SetRenderer).

As not all compilers support RTTI but this is very useful for item-renderer properties, they provide a RTTI-support by the method ItemRendererProperties::IsInstanceOf. This makes it necessary that each item-renderer properties class gets a unique ID. The IDs from 0 to 99 are reserved for APOXI.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

enum ItemRendererProperties::AnimType

Specifies the animation-type of the animation-properties. The IDs from 0 to 99 are reserved for APOXI.

See also:
AbstractItemRenderer::AnimProperties
Enumerator:
NoAnimation | The text will be clipped if it does not fit into the available area.
CycleAnimation | The text will be scrolled to one direction. Shortly before disappearing, the text scrolls in again from the opposite side.
BounceAnimation | The text will be scrolled to one direction. Shortly before disappearing, the scroll-direction switches and the text scrolls back to the original position.
BlinkingAnimation | The text blinks periodically. This type is not implemented yet in the DefaultItemRenderer.
IconAnimation | The icon will be animated in a custom manner. This type is not implemented yet in the DefaultItemRenderer. Note that if the icon itself is an image with more than one frame, an animation will be done anyway also with other animation types.
OnlyOnceAnimation | The text will be scrolled to one direction. In opposite to CycleAnimation the text will be scrolled only once.
CustomAnimation | Values above 99 may be used for custom animation types.
CycleVerticalAnimation
CycleHorizontalAnimation
HardVerticalAnimation
HardHorizontalAnimation
SoftVerticalAnimation
SoftHorizontalAnimation

enum ItemRendererProperties::DisplayType

Specifies categories for rendering the properties of an item. The IDs from 0 to 99 are reserved for APOXI.

Enumerator:
TextAndIconDisplayType | The text is aligned right beside the icon for languages written from left to right. For languages like Arabic the text is aligned left beside the icon.
TextDisplayType | The text is aligned above the icon.
IconDisplayType | Only the icon is displayed, the text will be ignored.
TextAboveIconDisplayType | The text is aligned above the icon.
TextBelowIconDisplayType | The text is aligned below the icon.
TextOverlapsIconDisplayType | The icon uses the whole area of the item and the text overlaps the icon.
CustomDisplayType | Values above 99 may be used for custom display types.

Constructor & Destructor Documentation

ItemRendererProperties::ItemRendererProperties ( )

ItemRendererProperties::ItemRendererProperties | ( | INT | display_type,
 |  | INT | anim_type,
 |  | UINT16 | scroll_delay,
 |  | XYDIM | scroll_gap,
 |  | const TextFormat & | text_format,
 |  | BOOLEAN | full_screen_per_item = FALSE,
 |  | BOOLEAN | transparent = FALSE,
 |  | BOOLEAN | multi_line = FALSE,
 |  | BOOLEAN | centered_vertical = TRUE,
 |  | BOOLEAN | indicate_item_cont = FALSE,
 |  | const Color & | backgr_color = Color(Color::ClientBackground),
 |  | XYDIM | height = -1,
 |  | XYDIM | gap = 2,
 |  | INT | column_count = 1,
 |  | XYDIM | selection_height = -1,
 |  | UINT16 | start_delay = 0,
 |  | const ImageObtainer & | backgr_image = ImageObtainer(),
 |  | const Color * | text_color = 0,
 |  | INT | renderer_hint = 0
 | ) |

Parameters:
display_type | Specifies the combination of the text and icon (see enum DisplayType).
anim_type | Kind of animation for the text (see enum AnimType).
scroll_delay | Delay in milliseconds until the next scroll step is done.
scroll_gap | Gap in pixel for the textscrolling.
text_format | Textformat of the text.
full_screen_per_item | If set to TRUE, the item boundaries will be stretched to maximal possible size.
transparent | If set to TRUE, no background for the item should be drawn per default.
multi_line | If set to TRUE, the text is wrapped horizontally and displayed in several lines.
centered_vertical | If set to TRUE, the text will be vertically centered. The horizontal text alignment can be defined by setting the text format (see ItemRendererProperties::SetTextFormat).
indicate_item_cont | If set to TRUE, an item-container is indicated by an arrow on the right side.
backgr_color | Specifies the background-color of the item. Is only used, if transparent is FALSE.
height | Height of the item in pixels. If -1 is used, it is in the hand of the control which uses an item renderer to specify the height. Usually -1 means that the height of the font is chosen.
gap | Gap in pixels for the item-border.
column_count | Preferred number of columns, if several items are rendered inside a control. If a control may only contain one item, this parameter is ignored.
selection_height | Height of the selected item in pixels.
start_delay | Delay in milliseconds until the scrolling of the text is started.
backgr_image | Background image for the item. Note that the transparent property must be set to TRUE to have a visible background image.
text_color | Color of the item text. If text_color is 0, the color Color::ClientForeground defined by the theme is used. The passed color object is copied internally and hence can be deleted after invoking the method.
renderer_hint | Sets the hint for the renderer, which can be used in GuiEngineConfig::ObtainItemRenderer to specify which kind of custom renderer should be created. A value of 0 means that the DefaultItemRenderer should be used. The definition of the meaning for values greater than 0 are customer specific.

ItemRendererProperties::~ItemRendererProperties ( ) [virtual]

Member Function Documentation

BOOLEAN ItemRendererProperties::FullScreenPerItem ( ) const [inline]

Returns TRUE; if the height of the item should be maximized to fill the whole screen. In this case the property height (see ItemRendererProperties::GetHeight and ItemRendererProperties::SetHeight) will be ignored.

INT ItemRendererProperties::GetAnimType ( ) const [inline]

See also:
ItemRenderer::AnimType

const Color& ItemRendererProperties::GetBackgroundColor ( ) const [inline]

Returns the background color of the item. The background color will be ignored if the transparent property (see ItemRendererProperties::SetTransparent and ItemRendererProperties::IsTransparent) is set.

const ImageObtainer& ItemRendererProperties::GetBackgroundImage ( ) const [inline]

Returns the background image of the item.

INT ItemRendererProperties::GetColumnCount ( ) const [inline]

Returns the preferred number of columns, if several items are rendered inside a control. If a control may only contain one item, this parameter is ignored.

INT ItemRendererProperties::GetDisplayType ( ) const [inline]

See also:
ItemRenderer::DisplayType

XYDIM ItemRendererProperties::GetGap ( ) const [inline]

Returns the gap between the icon, text and border of the item.

XYDIM ItemRendererProperties::GetHeight ( ) const [inline]

Returns the preferred height of the item. If -1 is used, it is in the hand of the control which uses an item renderer to specify the height. Usually -1 means that the height of the font is chosen.

INT ItemRendererProperties::GetRendererHint ( ) const [inline]

Returns the renderer hint. Per default 0 is returned which means that the DefaultItemRenderer should be used. See ItemRendererProperties::SetRendererHint for more details.

UINT16 ItemRendererProperties::GetScrollDelay ( ) const [inline]

Returns the scroll delay in milliseconds.

XYDIM ItemRendererProperties::GetScrollGap ( ) const [inline]

Returns the scroll gap in pixels.

XYDIM ItemRendererProperties::GetSelectionHeight ( ) const [inline]

Returns the preferred height of an item in the selected state. If -1 is used, the default height (see ItemRendererProperties::GetHeight) is chosen.

UINT16 ItemRendererProperties::GetStartDelay ( ) const [inline]

Returns the delay in milliseconds until the scrolling of the text is started. Per default 0 is returned.

const Color & ItemRendererProperties::GetTextColor ( ) const

Returns the color of the item text. Per default the color of Client::Foreground is used.

const TextFormat& ItemRendererProperties::GetTextFormat ( ) const [inline]

Returns the textformat of the text. see ItemRendererProperties::SetTextFormat for more details.

BOOLEAN ItemRendererProperties::IndicateItemContainer ( ) const [inline]

Returns TRUE, if an item container will be indicated by a small arrow.

BOOLEAN ItemRendererProperties::IsInstanceOf ( INT id ) const [virtual]

Returns TRUE, if the item is an instance of the item-class with the ID id. Must be implemented by each derived class the following way:

BOOLEAN MyItemRendererProperties::IsInstanceOf(INT id) const
{
    BOOLEAN is_instance = (ID == id);
    if (!is_instance)
        is_instance = Base::IsInstanceOf(id);
    return is_instance;
}

Example: if it should be checked, whether an item is an instance of the class Action the following code might be used:

if (properties->IsInstanceOf(MyItemRendererProperties::ID)) {
    MyItemRendererProperties* properties = (MyItemRendererProperties*)properties;
    ...
}

BOOLEAN ItemRendererProperties::IsMultiLine ( ) const [inline]

Returns TRUE, if the text of the item will be wrapped into several lines to fit into the available width.

BOOLEAN ItemRendererProperties::IsTransparent ( ) const [inline]

Returns TRUE, if no background for the item will be drawn.

BOOLEAN ItemRendererProperties::IsVerticalCentered ( ) const [inline]

Returns TRUE, if the text should be centered vertically inside the available height.

void ItemRendererProperties::SetAnimType ( INT anim_type ) [inline]

See also:
ItemRenderer::AnimType

void ItemRendererProperties::SetBackgroundColor ( const Color & backgr_color )

Sets the background color of the item. The background color will be ignored if the transparent property (see ItemRendererProperties::SetTransparent and ItemRendererProperties::IsTransparent) is set.

void ItemRendererProperties::SetBackgroundImage ( const ImageObtainer & backgr_image ) [inline]

Sets the background image for the item. Note that the transparent property must be set to TRUE to have a visible background image.

void ItemRendererProperties::SetColumnCount ( INT column_count ) [inline]

Sets the preferred number of columns, if several items are rendered inside a control. If a control may only contain one item, this parameter is ignored.

void ItemRendererProperties::SetDisplayType ( INT display_type ) [inline]

See also:
ItemRenderer::DisplayType

void ItemRendererProperties::SetFullScreenPerItem ( BOOLEAN full_screen_per_item ) [inline]

If set to TRUE, the height of the item should be maximized to fill the whole screen. In this case the property height (see ItemRendererProperties::GetHeight and ItemRendererProperties::SetHeight) will be ignored.

void ItemRendererProperties::SetGap ( XYDIM gap ) [inline]

Sets the gap between the icon, text and border of the item.

void ItemRendererProperties::SetHeight ( XYDIM height ) [inline]

Sets the preferred height of the item. If -1 is used, it is in the hand of the control which uses an item renderer to specify the height. Usually -1 means that the height of the font is chosen.

void ItemRendererProperties::SetIndicateItemContainer ( BOOLEAN flag ) [inline]

If set to TRUE, an item container will be indicated by a small arrow.

void ItemRendererProperties::SetMultiLine ( BOOLEAN multi_line ) [inline]

If set to TRUE, the text of the item will be wrapped into several lines to fit into the available width.

BOOLEAN ItemRendererProperties::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

void ItemRendererProperties::SetRendererHint ( INT renderer_hint ) [inline]

Sets the hint for the renderer, which can be used in GuiEngineConfig::ObtainItemRenderer to specify which kind of custom renderer should be created. A value of 0 means that the DefaultItemRenderer should be used. The definition of the meaning for values greater than 0 are customer specific.

void ItemRendererProperties::SetScrollDelay ( UINT16 scroll_delay )

Sets the delay for scrolling in milliseconds. A scroll delays below 50 milliseconds will be converted to 50 milliseconds.

void ItemRendererProperties::SetScrollGap ( XYDIM scroll_gap )

Sets the scroll gap in pixels. A scroll gap < 1 will be converted to 1.

void ItemRendererProperties::SetSelectionHeight ( XYDIM selection_height ) [inline]

Sets the preferred height of an item in the selected state. If -1 is used, the default height (see ItemRendererProperties::GetHeight) is chosen.

void ItemRendererProperties::SetStartDelay ( UINT16 start_delay ) [inline]

Sets the delay in milliseconds until the scrolling of the text is started. 0 is the default value.

void ItemRendererProperties::SetTextColor ( const Color * text_color )

Sets the color of the item text. If text_color is 0, the color Color::ClientForeground defined by the theme is used. The passed color object is copied internally and hence can be deleted after invoking the method.

void ItemRendererProperties::SetTextFormat ( const TextFormat & text_format ) [inline]

Sets the textformat for the text. Note that if the display type is set to 'IconDisplayType' no text will be shown at all.

void ItemRendererProperties::SetTransparent ( BOOLEAN transparent ) [inline]

If set to TRUE, no background for the item will be drawn.

void ItemRendererProperties::SetVerticalCentered ( BOOLEAN vertical_centered ) [inline]

If set to TRUE, the text should be centered vertically inside the available height.

The documentation for this class was generated from the following files:
  • Gui/ItemRendererProperties.hpp
  • Gui/ItemRendererProperties.cpp
Generated on Wed Jan 25 01:23:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemRendererPropertiesChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemRendererPropertiesChangedMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for ItemRendererPropertiesChangedMsg:

[legend]
Collaboration diagram for ItemRendererPropertiesChangedMsg:

[legend]

Public Types

enum | { ID = 1129 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
ItemRendererPropertiesChangedMsg ()
virtual | ~ItemRendererPropertiesChangedMsg ()

Detailed Description

This message is sent when globally shared item renderer properties have been changed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ItemRendererPropertiesChangedMsg::ItemRendererPropertiesChangedMsg ( )

ItemRendererPropertiesChangedMsg::~ItemRendererPropertiesChangedMsg ( ) [virtual]

Member Function Documentation

Message * ItemRendererPropertiesChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ItemRendererPropertiesChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:23:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ItemTree Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ItemTree Class Reference
[Components]

#include <Apoxi/Gui/ItemTree.hpp>

Inheritance diagram for ItemTree:

[legend]
Collaboration diagram for ItemTree:

[legend]

Public Types

enum | { ID = 14 }

Public Member Functions

virtual INT | GetColumnCount () const
virtual AbstractItemContainer * | GetItemContainer () const
void | Init (Control *parent, AbstractItemContainer *item_cont=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
ItemTree (Control *parent, AbstractItemContainer *item_cont=0)
ItemTree ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual BOOLEAN | Trigger (INT index=-1)
virtual | ~ItemTree ()

Protected Member Functions

virtual void | Cleanup ()
virtual void | DrawItemBorder (DeviceContext *dc, const Rect &cell_rect, const Rect &item_rect, INT item_index) const
virtual Rect | GetItemRect (INT item_index) const
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | Refresh (const Rect &rect)

Detailed Description

Extends the abstract item-grid to allow traversing a hierarchical menu shown as a tree-view. A menu is defined by an instance of the class ItemContainer, which may contain a variable number of items. As an ItemContainer is also an instance of the class Item, it is possible to recursively embedd item-containers inside other item-containers, which leads to a hierarchical item-tree.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractItemGrid.

Constructor & Destructor Documentation

ItemTree::ItemTree ( )

ItemTree::ItemTree | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0
 | ) |

Parameters:
parent | Parent-control, where the ItemTree is attached.
item_cont | Item-container, which specifies the items which should be part of the AbstractItemGrid.

ItemTree::~ItemTree ( ) [virtual]

Member Function Documentation

void ItemTree::Cleanup ( ) [protected, virtual]

See also:
Component::Cleanup

Reimplemented from AbstractItemGrid.

void ItemTree::DrawItemBorder | ( | DeviceContext * | dc,
 |  | const Rect & | cell_rect,
 |  | const Rect & | item_rect,
 |  | INT | item_index
 | ) | const [protected, virtual]

See also:
AbstractItemGrid::DrawItemBorder

Reimplemented from AbstractItemGrid.

INT ItemTree::GetColumnCount ( ) const [virtual]

See also:
AbstractGrid::GetColumnCount

Implements AbstractGrid.

AbstractItemContainer * ItemTree::GetItemContainer ( ) const [virtual]

See also:
AbstractItemGrid::GetItemContainer

Reimplemented from AbstractItemGrid.

Rect ItemTree::GetItemRect ( INT item_index ) const [protected, virtual]

See also:
AbstractItemGrid::GetItemRect

Reimplemented from AbstractItemGrid.

void ItemTree::Init | ( | Control * | parent,
 |  | AbstractItemContainer * | item_cont = 0
 | ) |

Parameters:
parent | Parent-control, where the ItemTree is attached.
item_cont | Item-container, which specifies the items which should be part of the AbstractItemGrid.

Reimplemented from AbstractItemGrid.

BOOLEAN ItemTree::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractItemGrid.

BOOLEAN ItemTree::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from AbstractItemGrid.

void ItemTree::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from AbstractItemGrid.

BOOLEAN ItemTree::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractItemGrid.

BOOLEAN ItemTree::Trigger ( INT index = -1 ) [virtual]

This method must be invoked to trigger an item (e. g. ItemMenu::Trigger may get invoked by pressing a softkey). Per default the selected item is triggered. If the item is an instance of the class Action, the action will be executed. If the item is an instance of the class AbstractItemContainer, the item-menu will be opened as sub-tree (or closed if it was openend before).

Parameters:
index Index of the item which should get triggered. If the index is < 0, the selected item is triggered.

The documentation for this class was generated from the following files:
  • Gui/ItemTree.hpp
  • Gui/ItemTree.cpp
Generated on Wed Jan 25 01:23:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JapaneseTextRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JapaneseTextRenderer Class Reference
[GUI]

#include <Apoxi/Gui/JapaneseTextRenderer.hpp>

Inheritance diagram for JapaneseTextRenderer:

[legend]
Collaboration diagram for JapaneseTextRenderer:

[legend]

Public Member Functions

virtual INT | WrapLine (const WCHAR *text, const Font &font, TextAttr text_attr, INT char_count, XYDIM max_width=-1, WrapPolicy policy=(WrapPolicy) 0, BOOLEAN include_gap_at_end=FALSE, Size *total_size=0, INT *ws_at_eol_count=0, XYDIM *ws_at_eol_width=0, INT *last_completely_fitting_word_length=0)
virtual | ~JapaneseTextRenderer ()

Static Public Member Functions

static JapaneseTextRenderer & | GetInstance ()

Protected Member Functions

virtual Size | GetGlyph (const WCHAR *cur_text_pos, const WCHAR *substitution_char, INT n_chars, GlyphPtr glyph, INT &parsed_glyphs, BOOLEAN &is_diacritic)

Detailed Description

Renderer for Japanese text. Currently only implements special wrapping (no punctuation marks at beginning of line).

Constructor & Destructor Documentation

JapaneseTextRenderer::~JapaneseTextRenderer ( ) [virtual]

Member Function Documentation

Size JapaneseTextRenderer::GetGlyph | ( | const WCHAR * | cur_text_pos,
 |  | const WCHAR * | substitution_char,
 |  | INT | n_chars,
 |  | GlyphPtr | glyph,
 |  | INT & | parsed_glyphs,
 |  | BOOLEAN & | is_diacritic
 | ) | [protected, virtual]

See also:
AbstractTextRenderer::GetGlyph

Implements AbstractTextRenderer.

JapaneseTextRenderer & JapaneseTextRenderer::GetInstance ( ) [static]

INT JapaneseTextRenderer::WrapLine | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | char_count,
 |  | XYDIM | max_width = -1,
 |  | WrapPolicy | policy = (WrapPolicy) 0,
 |  | BOOLEAN | include_gap_at_end = FALSE,
 |  | Size * | total_size = 0,
 |  | INT * | ws_at_eol_count = 0,
 |  | XYDIM * | ws_at_eol_width = 0,
 |  | INT * | last_completely_fitting_word_length = 0
 | ) | [virtual]

See also:
AbstractTextRenderer::WrapLine

Reimplemented from AbstractTextRenderer.

The documentation for this class was generated from the following files:
  • Gui/JapaneseTextRenderer.hpp
  • Gui/JapaneseTextRenderer.cpp
Generated on Wed Jan 25 01:23:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JapaneseTranscoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JapaneseTranscoder Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/JapaneseTranscoder.hpp>

Public Types

enum EncodingType {
Auto = 0, Sjis = 1, Jis = 2, Euc = 3,
Ucs2 = 4
}

Public Member Functions

Vector< UINT8 > | Convert (const UINT8 *text, INT text_len, EncodingType to_encoding, BOOLEAN *success=0, EncodingType from_encoding=Auto) const
EncodingType | DetectEncoding (const UINT8 *text, INT text_len) const
~JapaneseTranscoder ()

Static Public Member Functions

static const JapaneseTranscoder & | GetInstance ()

Detailed Description

The Japanese transcoder converts text stored in UCS-2, JIS, S-JIS and EUC to and from each of the formats. It also features autodetection of the type of encoding used within a text.

NOTICE: Some code is taken from the book CJKV Information Processing by Ken Lunde (O'Reilly, October 2002. ISBN 1-56592-224-7), and its accompanying web- and ftp sites. Specifically, code from the book is used in the following methods: Autodetection of encoding type S-JIS to JIS conversion JIS to S-JIS conversion (Please do not remove this notice, as it is required for using code from the book).

Member Enumeration Documentation

enum JapaneseTranscoder::EncodingType

Enumerator:
Auto
Sjis
Jis
Euc
Ucs2

Constructor & Destructor Documentation

JapaneseTranscoder::~JapaneseTranscoder ( )

Member Function Documentation

Vector< UINT8 > JapaneseTranscoder::Convert | ( | const UINT8 * | text,
 |  | INT | text_len,
 |  | EncodingType | to_encoding,
 |  | BOOLEAN * | success = 0,
 |  | EncodingType | from_encoding = Auto
 | ) | const

Converts a text from one encoding to another. All text encodings enumerated in EncodingType can be converted to one another.

Parameters:
text | the original text
text_len | the length of the original text
to_encoding | target encoding
success | optional output parameter is TRUE if converting was successful
from_encoding | specifies the encoding of the original text. Per default this is set to Auto, which causes the method to auto-detect the encoding type
Returns:
a Vector of UINT8 containing the converted text. A Vector was chosen for the return data because it offers a buffer of variable length which does not change the byte order on LE/BE architectures. Variable length is needed because one can never tell how long a converted text is going to be, which would be necessary for e.g. a byte buffer of UINT8 data. WStrings change order of bytes on reading the data (WCHAR is changed according to LE/BE architecture).

JapaneseTranscoder::EncodingType JapaneseTranscoder::DetectEncoding | ( | const UINT8 * | text,
 |  | INT | text_len
 | ) | const

Detect the encoding type of a text

Parameters:
text | the text
text_len | the length of the text
Returns:
the detected EncodingType

const JapaneseTranscoder & JapaneseTranscoder::GetInstance ( ) [static]

Returns an instance of the Japanese encoder.

The documentation for this class was generated from the following files:
  • Auxiliary/JapaneseTranscoder.hpp
  • Auxiliary/JapaneseTranscoder.cpp
Generated on Wed Jan 25 01:23:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JarBinDataStatusInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JarBinDataStatusInfo Struct Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/UnzipBinData.hpp>

Collaboration diagram for JarBinDataStatusInfo:

[legend]

Data Fields

UINT32 | byte_before_the_zipfile
UINT32 | central_pos
FileInfo cur_file_info
FileInfoInternal cur_file_info_internal
UINT32 | current_file_ok
JarFileGlobalInfo gi
BinData * jar_bin_data
UINT32 | num_file
UINT32 | offset_central_dir
BinDataInReadStatusInfo * pfile_in_zip_read
UINT32 | pos_in_central_dir
UINT32 | size_central_dir

Field Documentation

UINT32 JarBinDataStatusInfo::byte_before_the_zipfile

UINT32 JarBinDataStatusInfo::central_pos

FileInfo JarBinDataStatusInfo::cur_file_info

FileInfoInternal JarBinDataStatusInfo::cur_file_info_internal

UINT32 JarBinDataStatusInfo::current_file_ok

JarFileGlobalInfo JarBinDataStatusInfo::gi

BinData* JarBinDataStatusInfo::jar_bin_data

UINT32 JarBinDataStatusInfo::num_file

UINT32 JarBinDataStatusInfo::offset_central_dir

BinDataInReadStatusInfo* JarBinDataStatusInfo::pfile_in_zip_read

UINT32 JarBinDataStatusInfo::pos_in_central_dir

UINT32 JarBinDataStatusInfo::size_central_dir

The documentation for this struct was generated from the following file:
  • AddOns/MultiMedia/UnzipBinData.hpp
Generated on Wed Jan 25 01:23:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JarFileGlobalInfo_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JarFileGlobalInfo_s Struct Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/Unzip.hpp>

Data Fields

UINT16 | number_entry
UINT16 | size_comment

Field Documentation

UINT16 JarFileGlobalInfo_s::number_entry

UINT16 JarFileGlobalInfo_s::size_comment

The documentation for this struct was generated from the following file:
  • AddOns/MultiMedia/Unzip.hpp
Generated on Wed Jan 25 01:23:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JarFileStatusInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JarFileStatusInfo Struct Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/UnzipFfs.hpp>

Collaboration diagram for JarFileStatusInfo:

[legend]

Data Fields

UINT32 | byte_before_the_zipfile
UINT32 | central_pos
FileInfo cur_file_info
FileInfoInternal cur_file_info_internal
UINT32 | current_file_ok
JarFileGlobalInfo gi
FfsHandle jar_file_handle
UINT16 | jar_file_id
CHAR * | jar_file_name
UINT32 | num_file
UINT32 | offset_central_dir
FileInReadStatusInfo * pfile_in_zip_read
UINT32 | pos_in_central_dir
UINT32 | size_central_dir

Field Documentation

UINT32 JarFileStatusInfo::byte_before_the_zipfile

UINT32 JarFileStatusInfo::central_pos

FileInfo JarFileStatusInfo::cur_file_info

FileInfoInternal JarFileStatusInfo::cur_file_info_internal

UINT32 JarFileStatusInfo::current_file_ok

JarFileGlobalInfo JarFileStatusInfo::gi

FfsHandle JarFileStatusInfo::jar_file_handle

UINT16 JarFileStatusInfo::jar_file_id

CHAR* JarFileStatusInfo::jar_file_name

UINT32 JarFileStatusInfo::num_file

UINT32 JarFileStatusInfo::offset_central_dir

FileInReadStatusInfo* JarFileStatusInfo::pfile_in_zip_read

UINT32 JarFileStatusInfo::pos_in_central_dir

UINT32 JarFileStatusInfo::size_central_dir

The documentation for this struct was generated from the following file:
  • AddOns/MultiMedia/UnzipFfs.hpp
Generated on Wed Jan 25 01:23:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JmpBuf Union Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JmpBuf Union Reference
[Operating System]

#include <Apoxi/Kernel/Os/Nuc32/Scheduler.hpp>

Collaboration diagram for JmpBuf:

[legend]

Data Fields

_JUMP_BUFFER jb
jmp_buf jb_std

Field Documentation

_JUMP_BUFFER JmpBuf::jb

jmp_buf JmpBuf::jb_std

The documentation for this union was generated from the following files:
  • Kernel/Os/Nuc32/Scheduler.hpp
  • Kernel/Os/Win32/Scheduler.hpp
Generated on Wed Jan 25 01:23:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JoinProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JoinProvider Class Reference
[AuxExtensions]

#include <Apoxi/AddOns/AuxExtensions/JoinProvider.hpp>

Inheritance diagram for JoinProvider:

[legend]
Collaboration diagram for JoinProvider:

[legend]

Public Types

enum | AffectedProvider { Both, FirstOnly, SecondOnly, None }
Which provider should be affected by modifing operations. More...

Public Member Functions

virtual BOOLEAN | AppendRow ()
virtual INT | ColumnCount () const
virtual BOOLEAN | CommitRow (INT row)
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
virtual BOOLEAN | DeleteRow (INT row)
virtual const ColumnInfo * | GetColumnInfo (INT column)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
INT | GetFirstKeyColumnId () const
GetFirstKeyColumn returns the id of the key column of the first child-provider.
Provider * GetFirstProvider ()
GetFirstProvider returns the first underlaying child-provider.
JoinRule * GetJoinRule ()
GetJoinRule returns the current rule for merging.
virtual INT | GetProgress ()
virtual INT | GetProviderId () const
GetProviderId() reflects the provider Id of the child-provider.
INT | GetSecondKeyColumnId () const
GetSecondKeyColumn returns the id of the key column of the second child-provider.
Provider * GetSecondProvider ()
GetSecondProvider returns the second underlaying child-provider.
void | Init (INT provider_id, Provider *first_provider, Provider *second_provider, INT first_key_colid, INT second_key_colid, JoinRule *join_rule)
The same interface as the constructor.
virtual BOOLEAN | InsertRow (INT row)
JoinProvider (INT provider_id, Provider *first_provider, Provider *second_provider, INT first_key_colid, INT second_key_colid, JoinRule *join_rule)
JoinProvider ()
virtual BOOLEAN | Lock ()
Lock locks both child providers.
virtual INT | MaxRowCount ()
virtual void | OnExecutingListener (Provider *child_provider)
Called by JoinProviderListener to modify the progress value.
virtual INT | RowCount ()
RowCount returns the number of joined rows.
virtual BOOLEAN | SelectRow (INT row)
virtual BOOLEAN | SetDataItem (const DataItem &item, INT column)
virtual BOOLEAN | SetParameter (const DataItem &item)
virtual BOOLEAN | ToggleRow (INT row)
virtual BOOLEAN | Unlock ()
Unlock unlocks both child providers.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update updates both child-providers and forces a new join [O(m*n)].
virtual | ~JoinProvider ()

Protected Member Functions

virtual void | SetProgress (INT progress)
Sets the current progress.

Detailed Description

A JoinProvider joins two providers by the specified column id for the specified filter rule. All matching rows will be joined, what means, that at maximum a join will result in m*n rows, where m is the row count of the first, n the row count of the second provider.
All column ids of both providers will be reflected, plus the following column ids:
c_key_column_id | NumberType | The joined key row. Must be used for append and insert.
c_first_provider_row_id | NumberType | The child row of the first provider.
c_second_provider_row_id | NumberType | The child row of the second provider.
c_first_provider_id | ProviderType | The first child provider (may be 0).
c_second_provider_id | ProviderType | The second child provider (may be 0).

Member Enumeration Documentation

enum JoinProvider::AffectedProvider

Which provider should be affected by modifing operations.

Enumerator:
Both | both providers, this is default
FirstOnly | only the first
SecondOnly | only the second
None | Read only.

Constructor & Destructor Documentation

JoinProvider::JoinProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

JoinProvider::JoinProvider | ( | INT | provider_id,
 |  | Provider * | first_provider,
 |  | Provider * | second_provider,
 |  | INT | first_key_colid,
 |  | INT | second_key_colid,
 |  | JoinRule * | join_rule
 | ) |

On construction the following parameters have to be specified:

  • provider_id: The provider id for this JoinProvider.
  • first_provider: The first child provider which should be joined.
  • second_provider: The second child provider which should be joined.
  • first_join_colid: The column id of the first child provider which should be used as join key.
  • second_join_colid: The column id of the second child provider which should be used as join key.
  • join_rule: Rule to determine a single join.

JoinProvider::~JoinProvider ( ) [virtual]

Member Function Documentation

BOOLEAN JoinProvider::AppendRow ( ) [virtual]

Appends a row. Note: A value for c_key_row must be set before appending a row.

Reimplemented from Provider.

INT JoinProvider::ColumnCount ( ) const [virtual]

See also:
Provider::ColumnCount()

Reimplemented from Provider.

BOOLEAN JoinProvider::CommitRow ( INT row ) [virtual]

Commits only the rows of the affected providers.

See also:
SetParameter

Provider::Commit

Reimplemented from Provider.

BOOLEAN JoinProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of the affected providers.

See also:
SetParameter

Provider::DeleteAllRows

Reimplemented from Provider.

BOOLEAN JoinProvider::DeleteRow ( INT row ) [virtual]

Deletes only the rows of the affected providers.

See also:
SetParameter

Provider::DeleteRow

Reimplemented from Provider.

const ColumnInfo * JoinProvider::GetColumnInfo ( INT column ) [virtual]

See also:
Provider::GetColumnInfo()

Reimplemented from Provider.

BOOLEAN JoinProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
Provider::GetDataItem

Implements Provider.

INT JoinProvider::GetFirstKeyColumnId ( ) const [inline]

GetFirstKeyColumn returns the id of the key column of the first child-provider.

Provider* JoinProvider::GetFirstProvider ( ) [inline]

GetFirstProvider returns the first underlaying child-provider.

JoinRule* JoinProvider::GetJoinRule ( ) [inline]

GetJoinRule returns the current rule for merging.

INT JoinProvider::GetProgress ( ) [virtual]

See also:
Provider::GetProgress

Reimplemented from Provider.

INT JoinProvider::GetProviderId ( ) const [virtual]

GetProviderId() reflects the provider Id of the child-provider.

Implements Provider.

INT JoinProvider::GetSecondKeyColumnId ( ) const [inline]

GetSecondKeyColumn returns the id of the key column of the second child-provider.

Provider* JoinProvider::GetSecondProvider ( ) [inline]

GetSecondProvider returns the second underlaying child-provider.

void JoinProvider::Init | ( | INT | provider_id,
 |  | Provider * | first_provider,
 |  | Provider * | second_provider,
 |  | INT | first_key_colid,
 |  | INT | second_key_colid,
 |  | JoinRule * | join_rule
 | ) |

The same interface as the constructor.

BOOLEAN JoinProvider::InsertRow ( INT row ) [virtual]

Inserts a row in front of the row specified. Note: A value for c_key_row must be set before appending a row.

Reimplemented from Provider.

BOOLEAN JoinProvider::Lock ( ) [virtual]

Lock locks both child providers.

Reimplemented from Provider.

INT JoinProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns m*n rows, where m is the row count of the first, n the row count of the second provider.

Reimplemented from Provider.

void JoinProvider::OnExecutingListener ( Provider * child_provider ) [virtual]

Called by JoinProviderListener to modify the progress value.

INT JoinProvider::RowCount ( ) [virtual]

RowCount returns the number of joined rows.

Implements Provider.

BOOLEAN JoinProvider::SelectRow ( INT row ) [virtual]

Selects only the rows of the affected providers.

See also:
SetParameter

Provider::SelectRow

Reimplemented from Provider.

BOOLEAN JoinProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | column
 | ) | [virtual]

See also:
Provider::SetDataItem

Reimplemented from Provider.

BOOLEAN JoinProvider::SetParameter ( const DataItem & item ) [virtual]

Set the affected providers for all modifing operations using AffectedProvider enum as number type in item.

Reimplemented from Provider.

void JoinProvider::SetProgress ( INT progress ) [protected, virtual]

Sets the current progress.

BOOLEAN JoinProvider::ToggleRow ( INT row ) [virtual]

Toggles only the rows of the affected providers.

See also:
SetParameter

Provider::ToggleRow

Reimplemented from Provider.

BOOLEAN JoinProvider::Unlock ( ) [virtual]

Unlock unlocks both child providers.

Reimplemented from Provider.

BOOLEAN JoinProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update updates both child-providers and forces a new join [O(m*n)].

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/JoinProvider.hpp
  • AddOns/AuxExtensions/JoinProvider.cpp
Generated on Wed Jan 25 01:23:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JoinProviderListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JoinProviderListener Class Reference
[AuxExtensions]

#include <Apoxi/AddOns/AuxExtensions/JoinProvider.hpp>

Inheritance diagram for JoinProviderListener:

[legend]
Collaboration diagram for JoinProviderListener:

[legend]

Public Member Functions

JoinProviderListener (JoinProvider *provider, Provider *child_provider, ProviderListener *child_listener)
virtual void | OnExecuting ()
void | SetChildProvider (Provider *child_provider)
virtual | ~JoinProviderListener ()

Constructor & Destructor Documentation

JoinProviderListener::JoinProviderListener | ( | JoinProvider * | provider,
 |  | Provider * | child_provider,
 |  | ProviderListener * | child_listener
 | ) |

JoinProviderListener::~JoinProviderListener ( ) [virtual]

Member Function Documentation

void JoinProviderListener::OnExecuting ( ) [virtual]

Will be called during execution. Calls OnExecutingListener to modify the progress value before the OnExecuting method of the child-listener is invoked.

Reimplemented from ProviderListener.

void JoinProviderListener::SetChildProvider ( Provider * child_provider ) [inline]

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/JoinProvider.hpp
  • AddOns/AuxExtensions/JoinProvider.cpp
Generated on Wed Jan 25 01:23:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JoinRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JoinRule Class Reference
[AuxExtensions]

#include <Apoxi/AddOns/AuxExtensions/JoinRule.hpp>

Inheritance diagram for JoinRule:

[legend]

Public Types

enum | RelationType { Injective, Surjective, Bijective, Cartesian }

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &fst_item, const DataItem &snd_item)=0
virtual JoinRule::RelationType | GetType ()=0
Returns the type of the relation.
JoinRule ()
virtual | ~JoinRule ()

Detailed Description

A JoinRule is used to specify a criterion on how to join data items. See also: StandardJoinRule.

Member Enumeration Documentation

enum JoinRule::RelationType

The RelationType determines the maximal number of joins from the frst_item to the snd_item parameter in ExecuteRule.

Enumerator:
Injective | Each fst_item has at maximum one join to the snd_items.
Surjective | Each snd_item has at maximum one join to the fst_items.
Bijective | Each fst_item has at maximum one join to a snd_items and vice versa.
Cartesian | Each fst_item can have a join to each of the snd_items.

Constructor & Destructor Documentation

JoinRule::JoinRule ( )

JoinRule::~JoinRule ( ) [virtual]

Member Function Documentation

virtual BOOLEAN JoinRule::ExecuteRule | ( | const DataItem & | fst_item,
 |  | const DataItem & | snd_item
 | ) | [pure virtual]

ExecuteRule does the actual comparision between the data items given in the arguments.

Implemented in StandardJoinRule, and PhoneNumberJoinRule.

virtual JoinRule::RelationType JoinRule::GetType ( ) [pure virtual]

Returns the type of the relation.

Implemented in StandardJoinRule, and PhoneNumberJoinRule.

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/JoinRule.hpp
  • AddOns/AuxExtensions/JoinRule.cpp
Generated on Wed Jan 25 01:23:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JpegEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JpegEncoder Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/JpegEncoder.hpp>

Inheritance diagram for JpegEncoder:

[legend]
Collaboration diagram for JpegEncoder:

[legend]

Public Member Functions

virtual BOOLEAN | Encode (const Image &img, DataSink &dest, BOOLEAN block=TRUE)
virtual BOOLEAN | Encode (BinData &src, const Image::MetaData &src_params, DataSink &dest, BOOLEAN block=TRUE, void *context=0, Cb_ImageEncoded=0)
JpegEncoder (const EncodingParameters &param)
virtual | ~JpegEncoder ()

Protected Member Functions

virtual BOOLEAN | BeginEncoding (DataSink &dest)
virtual BOOLEAN | EncodeSynchronously (const Image &img, DataSink &dest)
virtual BOOLEAN | EncodeSynchronously (BinData &src, const Image::MetaData &src_params, DataSink &dest)
virtual BOOLEAN | EndEncoding (DataSink &dest)

Data Structures

struct | DataDestinationMgr
Expanded data source object reading a BinData object.
class | EncodingParameters
struct | ErrorMgr

Detailed Description

Allows to encode JPEG images from various source formats like RGB and YUV. It's possible to specify the destination resolution and quality level.

Constructor & Destructor Documentation

JpegEncoder::JpegEncoder ( const EncodingParameters & param )

Initializes the JpegEncoder with the JPEG encoding parameters.

JpegEncoder::~JpegEncoder ( ) [virtual]

Destructor, frees all required memory which were needed for encoding

Member Function Documentation

BOOLEAN JpegEncoder::BeginEncoding ( DataSink & dest ) [protected, virtual]

See also:
ImageEncoder::BeginEncoding

Reimplemented from ImageEncoder.

BOOLEAN JpegEncoder::Encode | ( | const Image & | img,
 |  | DataSink & | dest,
 |  | BOOLEAN | block = TRUE
 | ) | [virtual]

See also:
ImageEncoder::Encode

Implements ImageEncoder.

BOOLEAN JpegEncoder::Encode | ( | BinData & | src,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest,
 |  | BOOLEAN | block = TRUE,
 |  | void * | context = 0,
 |  | Cb_ImageEncoded | = 0
 | ) | [virtual]

See also:
ImageEncoder::Encode

BOOLEAN JpegEncoder::EncodeSynchronously | ( | const Image & | img,
 |  | DataSink & | dest
 | ) | [protected, virtual]

See also:
ImageEncoder::EncodeSynchronously

Reimplemented from ImageEncoder.

BOOLEAN JpegEncoder::EncodeSynchronously | ( | BinData & | src,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest
 | ) | [protected, virtual]

See also:
ImageEncoder::EncodeSynchronously

Reimplemented from ImageEncoder.

BOOLEAN JpegEncoder::EndEncoding ( DataSink & dest ) [protected, virtual]

See also:
ImageEncoder::EndDecoding

Reimplemented from ImageEncoder.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/JpegEncoder.hpp
  • AddOns/MultiMedia/JpegEncoder.cpp
Generated on Wed Jan 25 01:23:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JpegEncoder::EncodingParameters Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
JpegEncoder::EncodingParameters

JpegEncoder::EncodingParameters Class Reference

#include <Apoxi/AddOns/MultiMedia/JpegEncoder.hpp>

Inheritance diagram for JpegEncoder::EncodingParameters:

[legend]
Collaboration diagram for JpegEncoder::EncodingParameters:

[legend]

Public Types

enum | EncodingFormat { Yuv420, Yuv422 }

Public Member Functions

EncodingParameters (XYDIM width, XYDIM height, INT quality_level, EncodingFormat encoding_format=Yuv422)
EncodingFormat | GetEncodingFormat () const
INT | GetQualityLevel () const
void | SetEncodingFormat (EncodingFormat format)
void | SetQualityLevel (INT level)

Detailed Description

Describes the encoding parameters like color format, size and quality level.

Member Enumeration Documentation

enum JpegEncoder::EncodingParameters::EncodingFormat

Encoding format of the JPEG image. The encoding format can be changed by JpegEncoder::SetEncodingFormat. Per default Yuv422 is used.

Enumerator:
Yuv420
Yuv422

Constructor & Destructor Documentation

JpegEncoder::EncodingParameters::EncodingParameters | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | quality_level,
 |  | EncodingFormat | encoding_format = Yuv422
 | ) | [inline]

Parameters:
width | Output width (is ignored in case of calling Encode with Bindata)
height | Output height (is ignored in case of calling Encode with BinData)
quality_level | JPEG quality level. 100 means best quality but low compression, 0 means lowest quality but high compression.

Member Function Documentation

EncodingFormat JpegEncoder::EncodingParameters::GetEncodingFormat ( ) const [inline]

Returns the used encoding format.

INT JpegEncoder::EncodingParameters::GetQualityLevel ( ) const [inline]

Retrieves the quality level which has been set for JPEG encoding. 100 means best quality but low compression, 0 means lowest quality but high compression.

void JpegEncoder::EncodingParameters::SetEncodingFormat ( EncodingFormat format ) [inline]

Sets the used encoding format, which has impacts on the quality and size of the JPEG image.

void JpegEncoder::EncodingParameters::SetQualityLevel ( INT level ) [inline]

Sets the quality level for JPEG encoding. 100 means best quality but low compression, 0 means lowest quality but high compression.

The documentation for this class was generated from the following file:
  • AddOns/MultiMedia/JpegEncoder.hpp
Generated on Wed Jan 25 01:23:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JpegEncodingThreadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JpegEncodingThreadlet Class Reference
[GUI]

#include <Apoxi/AddOns/MultiMedia/JpegEncodingThreadlet.hpp>

Inheritance diagram for JpegEncodingThreadlet:

[legend]
Collaboration diagram for JpegEncodingThreadlet:

[legend]

Public Member Functions

virtual | ~JpegEncodingThreadlet ()

Static Public Member Functions

static JpegEncodingThreadlet * | CreateInstance (JpegEncoder &encoder, BinData &source, const Image::MetaData &src_params, DataSink &dest)
static JpegEncodingThreadlet * | CreateInstance (JpegEncoder &encoder, const Image &source, DataSink &dest)

Protected Member Functions

JpegEncodingThreadlet (JpegEncoder &encoder, BinData &source, const Image::MetaData &src_params, DataSink &dest)
JpegEncodingThreadlet (JpegEncoder &encoder, const Image &source, DataSink &dest)

Detailed Description

JpegEncodingThreadlet uses an own thread for encoding a JPEG image.

Constructor & Destructor Documentation

JpegEncodingThreadlet::~JpegEncodingThreadlet ( ) [virtual]

JpegEncodingThreadlet::JpegEncodingThreadlet | ( | JpegEncoder & | encoder,
 |  | const Image & | source,
 |  | DataSink & | dest
 | ) | [protected]

JpegEncodingThreadlet::JpegEncodingThreadlet | ( | JpegEncoder & | encoder,
 |  | BinData & | source,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest
 | ) | [protected]

Member Function Documentation

JpegEncodingThreadlet * JpegEncodingThreadlet::CreateInstance | ( | JpegEncoder & | encoder,
 |  | BinData & | source,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest
 | ) | [static]

Creates an encoding-threadlet and releases itself automatically after the threadlet has been executed.

JpegEncodingThreadlet * JpegEncodingThreadlet::CreateInstance | ( | JpegEncoder & | encoder,
 |  | const Image & | source,
 |  | DataSink & | dest
 | ) | [static]

Creates an encoding-threadlet and releases itself automatically after the threadlet has been executed.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/JpegEncodingThreadlet.hpp
  • AddOns/MultiMedia/JpegEncodingThreadlet.cpp
Generated on Wed Jan 25 01:23:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JpegImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JpegImage Class Reference
[MultiMedia]

Class to contain, decompress and draw a JPEG compatible image. More...

#include <Apoxi/AddOns/MultiMedia/JpegImage.hpp>

Inheritance diagram for JpegImage:

[legend]
Collaboration diagram for JpegImage:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

virtual const BinData * | GetBinData () const
virtual UINT32 | GetFrameDelay (INT frame_idx) const
virtual INT | GetNextFrame (INT frame_idx) const
void | Init (BinData *jpeg_data, BOOLEAN *success=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
JpegImage (BinData *data, BOOLEAN *success=0)
JpegImage ()
virtual | ~JpegImage ()

Protected Member Functions

virtual void * | BeginScanlineDrawing (INT frame_idx=0) const
virtual void | DrawScanline (void *context, DeviceContext *dc, XYDIM x, XYDIM y, INT scanline_idx, INT old_scanline_idx) const
virtual void | EndScanlineDrawing (void *context) const
void | FreeImage ()
Frees the obtained image.

Protected Attributes

BinData * m_data

Detailed Description

Class to contain, decompress and draw a JPEG compatible image.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Image.

Constructor & Destructor Documentation

JpegImage::JpegImage ( )

If the default constructor is used, the parameters have to be provided by using method Init.

JpegImage::JpegImage | ( | BinData * | data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
data | Pointer to a binary data stream which contains the JPEG data. After passing the binary data stream, the stream is obtained by the JPEG image and hence automatically released in the destructor of the JPEG image.
success | Output-parameter, which indicates whether the initialization has been successful.

JpegImage::~JpegImage ( ) [virtual]

Releases the binary data stream m_data if it is still obtained and destructs the object.

Member Function Documentation

void * JpegImage::BeginScanlineDrawing ( INT frame_idx = 0 ) const [protected, virtual]

See also:
Image::BeginScanlineDrawing

Reimplemented from Image.

void JpegImage::DrawScanline | ( | void * | context,
 |  | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

See also:
Image::DrawScanline

Reimplemented from Image.

void JpegImage::EndScanlineDrawing ( void * context ) const [protected, virtual]

See also:
Image::EndScanlineDrawing

Reimplemented from Image.

void JpegImage::FreeImage ( ) [protected]

Frees the obtained image.

const BinData * JpegImage::GetBinData ( ) const [virtual]

See also:
Image::GetBinData

Reimplemented from Image.

UINT32 JpegImage::GetFrameDelay ( INT frame_idx ) const [virtual]

See also:
Image::GetFrameDelay

Implements Image.

INT JpegImage::GetNextFrame ( INT frame_idx ) const [virtual]

See also:
Image::GetNextFrame

Implements Image.

void JpegImage::Init | ( | BinData * | jpeg_data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
jpeg_data | Pointer to a binary data stream which contains the JPEG-data. After passing the binary data stream, the stream is obtained by the JPEG-image and hence automatically released in the destructor of the JPEG-image.
success | Output-parameter, which indicates whether the initialization has been successful.

BOOLEAN JpegImage::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Image.

Field Documentation

BinData* JpegImage::m_data [protected]

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/JpegImage.hpp
  • AddOns/MultiMedia/JpegImage.cpp
Generated on Wed Jan 25 01:23:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: JumpToRowMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

JumpToRowMsg Class Reference

#include <Applications/AdvPhonebook/AdvPbMsgTypes.hpp>

Inheritance diagram for JumpToRowMsg:

[legend]
Collaboration diagram for JumpToRowMsg:

[legend]

Public Types

enum | { ID = 30003 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
JumpToRowMsg (Control *control)
virtual | ~JumpToRowMsg ()

Detailed Description

Phonebook

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

JumpToRowMsg::JumpToRowMsg ( Control * control )

JumpToRowMsg::~JumpToRowMsg ( ) [virtual]

Member Function Documentation

Message * JumpToRowMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & JumpToRowMsg::GetMetaData ( ) const [virtual]

Implements ControlMsg.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbMsgTypes.hpp
  • Applications/AdvPhonebook/AdvPbMsgTypes.cpp
Generated on Wed Jan 25 01:23:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyAutoRepeatMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyAutoRepeatMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for KeyAutoRepeatMsg:

[legend]
Collaboration diagram for KeyAutoRepeatMsg:

[legend]

Public Types

enum | { ID = 204 }

Public Member Functions

virtual Message * | Clone () const
const KeyCode & | GetKeyCode () const
virtual const MsgMetaData & | GetMetaData () const
KeyAutoRepeatMsg (const KeyCode &key_code)
void | SetKeyCode (const KeyCode &key_code)
virtual | ~KeyAutoRepeatMsg ()

Detailed Description

This message is sent when a key is pressed longer than AXE_KEY_AUTOREPEAT_DELAY [ms] an will be repeated al AXE_KEY_AUTOREPEAT_INTERVAL [ms] args[0].t_byte[0] ... contains the key code of the key

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

KeyAutoRepeatMsg::KeyAutoRepeatMsg ( const KeyCode & key_code )

KeyAutoRepeatMsg::~KeyAutoRepeatMsg ( ) [virtual]

Member Function Documentation

Message * KeyAutoRepeatMsg::Clone ( ) const [virtual]

Implements Message.

const KeyCode& KeyAutoRepeatMsg::GetKeyCode ( ) const [inline]

const MsgMetaData & KeyAutoRepeatMsg::GetMetaData ( ) const [virtual]

Implements Message.

void KeyAutoRepeatMsg::SetKeyCode ( const KeyCode & key_code ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:23:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Keyboard Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Keyboard Class Reference
[Devices]

Keyboard. More...

#include <Apoxi/Devices/BP30/Keyboard.hpp>

Inheritance diagram for Keyboard:

[legend]
Collaboration diagram for Keyboard:

[legend]

Public Types

enum Flag {
KeyDown, KeyUp, LongKeyPress, VeryLongKeyPress,
KeyAutoRepeat, InputChar
}
enum | IlluminationMode { IlluminationModeOff, IlluminationModeAuto, IlluminationModeOn }

Public Member Functions

virtual const WCHAR * | GetName () const
virtual | ~Keyboard ()

Static Public Member Functions

static void | ConfirmKeyInput ()
static ControlArg | Control (INT command, ControlArg arg)
static IlluminationMode | GetIlluminationMode ()
static BOOLEAN | GetKeyState (KeyCode keycode)
static BOOLEAN | IsIlluminationOn ()
static BOOLEAN | IsLocked ()
static BOOLEAN | IsMultiKeyMode ()
static void | PostKeyMsg (KeyCode key_code, Flag key_flag, UINT32 duration=0)
static void | ReactivateIllumination ()
static void | SetIlluminationMode (IlluminationMode mode)
static void | SetIlluminationTimeout (UINT32 timeout)
static void | SetLocked (BOOLEAN locked)
static void | SetMultiKeyMode (BOOLEAN enable)

Protected Member Functions

virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()

Data Structures

struct | BitStruct
struct | BitStruct
struct | BitStruct
struct | BitStruct
struct | BitStruct

Detailed Description

Keyboard.

Keyboard is the APOXI device abstraction interface for keyboard hardware driver.

Member Enumeration Documentation

enum Keyboard::Flag

Enumerator:
KeyDown
KeyUp
LongKeyPress
VeryLongKeyPress
KeyAutoRepeat
InputChar

enum Keyboard::IlluminationMode

Enumerator:
IlluminationModeOff
IlluminationModeAuto Illumination is continuously off.
IlluminationModeOn Illumination is continuously on.

Illumination is on as long ReactivateIllumination is called and turns off automatically after the adjusted timeout given by SetIlluminationTimeout.

Constructor & Destructor Documentation

Keyboard::~Keyboard ( ) [virtual]

Member Function Documentation

void Keyboard::ConfirmKeyInput ( ) [static]

static ControlArg Keyboard::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) | [static]

See also:
AbstractDevice::Control

BOOLEAN Keyboard::GetKeyState ( KeyCode keycode ) [static]

Returns:
boolean value if keycode is currently pressed or not

const WCHAR * Keyboard::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

virtual void Keyboard::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

virtual void Keyboard::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

virtual void Keyboard::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

void Keyboard::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

void Keyboard::PostKeyMsg | ( | KeyCode | key_code,
 |  | Flag | key_flag,
 |  | UINT32 | duration = 0
 | ) | [static]

void Keyboard::ReactivateIllumination ( ) [static]

Call this method for example on each key press to turn on the keyboard illumination. Then it automatically turns off the keyboard illumination after the adjusted timeout.

void Keyboard::SetIlluminationMode ( IlluminationMode mode ) [static]

Parameters:
mode See Keyboard::IlluminationMode.

void Keyboard::SetLocked ( BOOLEAN locked ) [static]

The documentation for this class was generated from the following files:
  • Devices/BP30/Keyboard.hpp
  • Devices/KeyboardInterface.hpp
  • Devices/MPE/Keyboard.hpp
  • Devices/MPEU/Keyboard.hpp
  • Devices/SGold/Keyboard.hpp
  • Devices/Win32/Keyboard.hpp
  • Devices/BP30/Keyboard.cpp
  • Devices/MPE/Keyboard.cpp
  • Devices/MPEU/Keyboard.cpp
  • Devices/SGold/Keyboard.cpp
  • Devices/SharedMethods/KeyboardTimer.cpp
  • Devices/Win32/Keyboard.cpp
Generated on Wed Jan 25 01:23:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyboardConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyboardConfig Class Reference
[Config]

#include <KeyboardConfig.hpp>

Static Public Member Functions

static KeyCode | GetArrowDown ()
static KeyCode | GetArrowLeft ()
static KeyCode | GetArrowRight ()
static KeyCode | GetArrowUp ()
static INT | GetAutorepeatDelay ()
static INT | GetAutorepeatInterval ()
static KeyCode | GetBackKey ()
static KeyCode | GetCancelKey ()
static KeyCode | GetClearAllKey ()
static KeyCode | GetCloseKey ()
static KeyCode | GetConfirmKey ()
static KeyCode | GetCustomKey (WCHAR custom_key)
static KeyCode | GetDeleteKey ()
static KeyCode | GetGreenKey ()
static KeyCode | GetHeadsetKey ()
static const InputMap & | GetInputMap (INT index)
static KeyCode | GetInputTogglingKey ()
static INT | GetLongKeyDelay ()
static KeyCode | GetNumber (UINT8 number)
static KeyCode | GetOptionKey ()
static KeyCode | GetRedKey ()
static KeyCode | GetSelectKey ()
static KeyCode | GetSoftkey (INT index)
static INT | GetSoftkeyCount ()
static INT | GetVeryLongKeyDelay ()

Detailed Description

Allows accessing the keyboard configuration. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static KeyCode KeyboardConfig::GetArrowDown ( ) [static]

Returns:
KeyCode of arrow-down key.

static KeyCode KeyboardConfig::GetArrowLeft ( ) [static]

Returns:
KeyCode of arrow-left key.

static KeyCode KeyboardConfig::GetArrowRight ( ) [static]

Returns:
KeyCode of arrow-right key.

static KeyCode KeyboardConfig::GetArrowUp ( ) [static]

Returns:
KeyCode of arrow-up key.

static INT KeyboardConfig::GetAutorepeatDelay ( ) [static]

Returns:
Delay for autorepeat.

static INT KeyboardConfig::GetAutorepeatInterval ( ) [static]

Returns:
Delay for interval between autorepeat.

static KeyCode KeyboardConfig::GetBackKey ( ) [static]

Returns:
KeyCode of the back-key

static KeyCode KeyboardConfig::GetCancelKey ( ) [static]

Returns:
KeyCode of the close-key

static KeyCode KeyboardConfig::GetClearAllKey ( ) [static]

Returns:
KeyCode of the clear all-key

static KeyCode KeyboardConfig::GetCloseKey ( ) [static]

Returns:
KeyCode of the close-key

static KeyCode KeyboardConfig::GetConfirmKey ( ) [static]

Returns:
KeyCode of the confirm key

static KeyCode KeyboardConfig::GetCustomKey ( WCHAR custom_key ) [static]

Parameters:
custom_key Unicode of the custom key representing a character.
Returns:
Keycode of the given custom key.

static KeyCode KeyboardConfig::GetDeleteKey ( ) [static]

Returns:
KeyCode of the delete-key.

static KeyCode KeyboardConfig::GetGreenKey ( ) [static]

Returns:
KeyCode of the green-key.

static KeyCode KeyboardConfig::GetHeadsetKey ( ) [static]

Returns:
KeyCode of the Headsetkey.

static const InputMap& KeyboardConfig::GetInputMap ( INT index ) [static]

Returns:
Reference to InputMap.

static KeyCode KeyboardConfig::GetInputTogglingKey ( ) [static]

Returns:
KeyCode of the toggling key

static INT KeyboardConfig::GetLongKeyDelay ( ) [static]

Returns:
Delay until the LongKeyPress-Message will be sent.

static KeyCode KeyboardConfig::GetNumber ( UINT8 number ) [static]

Returns:
KeyCode of numeric key with the number number (0 - 9).

static KeyCode KeyboardConfig::GetOptionKey ( ) [static]

Returns:
KeyCode of the option-key.

static KeyCode KeyboardConfig::GetRedKey ( ) [static]

Returns:
KeyCode of the red-key.

static KeyCode KeyboardConfig::GetSelectKey ( ) [static]

Returns:
KeyCode of the select-key

static KeyCode KeyboardConfig::GetSoftkey ( INT index ) [static]

Returns:
KeyCode of softkey with the index index.

static INT KeyboardConfig::GetSoftkeyCount ( ) [static]

Returns:
Number of softkeys.

static INT KeyboardConfig::GetVeryLongKeyDelay ( ) [static]

Returns:
Delay until the VeryLongKeyPress-Message will be sent.

The documentation for this class was generated from the following file:
  • KeyboardConfig.hpp
Generated on Wed Jan 25 01:23:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyDownInputMapEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyDownInputMapEntry Struct Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Collaboration diagram for KeyDownInputMapEntry:

[legend]

Data Fields

KeyCode m_key_code
InputMapEntry m_map_entry

Field Documentation

KeyCode KeyDownInputMapEntry::m_key_code

InputMapEntry KeyDownInputMapEntry::m_map_entry

The documentation for this struct was generated from the following file:
  • Kernel/InputMap.hpp
Generated on Wed Jan 25 01:23:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyDownInputMapItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyDownInputMapItem Class Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Inheritance diagram for KeyDownInputMapItem:

[legend]
Collaboration diagram for KeyDownInputMapItem:

[legend]

Public Types

typedef InputMapItem | Base

Public Member Functions

KeyCode | GetKeyCode () const
KeyDownInputMapItem (MapItemType type, KeyCode key_code)
void | SetKeyCode (KeyCode key_code)

Member Typedef Documentation

typedef InputMapItem KeyDownInputMapItem::Base

Constructor & Destructor Documentation

KeyDownInputMapItem::KeyDownInputMapItem | ( | MapItemType | type,
 |  | KeyCode | key_code
 | ) | [inline]

Member Function Documentation

KeyCode KeyDownInputMapItem::GetKeyCode ( ) const [inline]

void KeyDownInputMapItem::SetKeyCode ( KeyCode key_code ) [inline]

The documentation for this class was generated from the following file:
  • Kernel/InputMap.hpp
Generated on Wed Jan 25 01:23:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyDownMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyDownMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for KeyDownMsg:

[legend]
Collaboration diagram for KeyDownMsg:

[legend]

Public Types

enum | { ID = 200 }

Public Member Functions

virtual Message * | Clone () const
const KeyCode & | GetKeyCode () const
virtual const MsgMetaData & | GetMetaData () const
KeyDownMsg (const KeyCode &key_code)
void | SetKeyCode (const KeyCode &key_code)
virtual | ~KeyDownMsg ()

Detailed Description

This message is sent to the active application whenever a user presses a key. Arguments: args[0].t_byte[0] ... contains the key code of the key pressed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

KeyDownMsg::KeyDownMsg ( const KeyCode & key_code )

KeyDownMsg::~KeyDownMsg ( ) [virtual]

Member Function Documentation

Message * KeyDownMsg::Clone ( ) const [virtual]

Implements Message.

const KeyCode& KeyDownMsg::GetKeyCode ( ) const [inline]

const MsgMetaData & KeyDownMsg::GetMetaData ( ) const [virtual]

Implements Message.

void KeyDownMsg::SetKeyCode ( const KeyCode & key_code ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:23:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyManager Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/KeyManager.hpp>

Collaboration diagram for KeyManager:

[legend]

Public Member Functions

BOOLEAN | HandleMessage (const Message &msg, AtlApplication *parent)
~KeyManager ()

Static Public Member Functions

static KeyManager & | GetInstance ()
static void | SwallowKey (KeyCode key_code)

Detailed Description

KeyManager exclusively receives all messages in an application and applies potential key mappings to key down messages according to the active context description.

Constructor & Destructor Documentation

KeyManager::~KeyManager ( )

Member Function Documentation

static KeyManager& KeyManager::GetInstance ( ) [inline, static]

BOOLEAN KeyManager::HandleMessage | ( | const Message & | msg,
 |  | AtlApplication * | parent
 | ) |

Is invoked in AtlApplication::RoutMessage. It checks whether the key-message has a defined keymapping in the current context. If the key has a defined keymapping a new key message is sent otherwise the "old" keymessage is routed via RouteMessage()

Parameters:
msg | Message to be checked, if key mappings must be applied
parent | Parent application of the message, which may be needed for updating context items, if a key mapping contains context features
See also:
KeyMapping

static void KeyManager::SwallowKey ( KeyCode key_code ) [inline, static]

Emulated keys must not be propagated to user activity listeners and must not play key tones eg. key press is mapped to a TriggerKeyFeature, emulated key messages should not play key tone.

The documentation for this class was generated from the following files:
  • Atl/Context/KeyManager.hpp
  • Atl/Context/KeyManager.cpp
Generated on Wed Jan 25 01:23:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyMapping Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyMapping Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/KeyMapping.hpp>

Collaboration diagram for KeyMapping:

[legend]

Public Member Functions

void | AddKeySequenceFeature (KeySequence *sequence, const FeatureHandle *feature_handle)
void | AddVKey (KeyCode hw_key, KeyCode v_key)
void | AddVKeyFeature (KeyCode key, const FeatureHandle *feature_handle)
void | AddVKeyLongFeature (KeyCode key, const FeatureHandle *feature_handle)
void | AddVKeyVeryLongFeature (KeyCode key, const FeatureHandle *feature_handle)
const FeatureHandle * | GetFeature (KeyCode key) const
const FeatureHandle * | GetLongFeature (KeyCode key) const
const FeatureHandle * | GetSequenceFeature (KeyCode key, BOOLEAN &consume_last_key)
const FeatureHandle * | GetVeryLongFeature (KeyCode key) const
KeyCode | GetVKey (KeyCode hw_key) const
KeyMapping ()
~KeyMapping ()

Static Protected Member Functions

static void | UpdateExpireTime ()

Friends

class | KeyManager

Detailed Description

Following KeyMappings are possible:
  • hardware key down to virtual key
  • key down to feature
  • long key down to feature
  • very long key down to feature
  • sequence of hardware key down to feature
See also:
KeyManager

Constructor & Destructor Documentation

KeyMapping::KeyMapping ( )

KeyMapping::~KeyMapping ( )

Member Function Documentation

void KeyMapping::AddKeySequenceFeature | ( | KeySequence * | sequence,
 |  | const FeatureHandle * | feature_handle
 | ) |

Define a mapping of KeySequence to FeatureHandle. The KeySequence is defined by sequence of hardware keys.

Parameters:
sequence | Hardware key down sequence
feature_handle | Mapped feature or context feature

void KeyMapping::AddVKey | ( | KeyCode | hw_key,
 |  | KeyCode | v_key
 | ) |

Define a mapping of given hardware key to virtual key

Parameters:
hwKey | Hardware key down
vKey | Mapped virtual key down

void KeyMapping::AddVKeyFeature | ( | KeyCode | key,
 |  | const FeatureHandle * | feature_handle
 | ) |

Define a mapping of a KeyCode to FeatureHandle, the given key code can be a virtual or hardware key.

Parameters:
vKey | key down
feature_handle | Mapped feature or context feature

void KeyMapping::AddVKeyLongFeature | ( | KeyCode | key,
 |  | const FeatureHandle * | feature_handle
 | ) |

Define a mapping of long key down to FeatureHandle

Parameters:
hwKey | long key down
feature_handle | Mapped feature or context feature

void KeyMapping::AddVKeyVeryLongFeature | ( | KeyCode | key,
 |  | const FeatureHandle * | feature_handle
 | ) |

Defines a mapping of very long key down to FeatureHandle.

Parameters:
hwKey | Hardware very long key down
feature_handle | Mapped feature or context feature

const FeatureHandle * KeyMapping::GetFeature ( KeyCode key ) const

Returns a FeatureHandle to the given Key If no FeatureHandle is mapped to the given KeyCode 0 is returned.

const FeatureHandle * KeyMapping::GetLongFeature ( KeyCode key ) const

Returns a FeatureHandle to the given KeyCode. If a Feature is mapped to the given KeyCode it may only be executed if LongKeyPressMsg arrives. If no FeatureHandle is mapped to the given KeyCode 0 is returned

const FeatureHandle * KeyMapping::GetSequenceFeature | ( | KeyCode | key,
 |  | BOOLEAN & | consume_last_key
 | ) |

Returns the FeatureHande if a KeySequence is finished with the given KeyCode. A FeatureHandle is only returned if the given KeyCode completes a defined KeySequence otherwise 0 is returned.

Parameters:
consume_last_key TRUE means that the last pressed key of the KeySequence should not be routed. AtlApplication::RouteMessage returns TRUE FALSE means that the last pressed key of the KeySequence should be handled and executed as a usual KeyPress.

const FeatureHandle * KeyMapping::GetVeryLongFeature ( KeyCode key ) const

Returns a FeatureHandle to the given KeyCode. If a Feature is mapped to the given KeyCode it may only be executed if VeryLongKeyPressMsg arrives. If no FeatureHandle is mapped to the given KeyCode 0 is returned.

KeyCode KeyMapping::GetVKey ( KeyCode hw_key ) const

Return the KeyCode of the mapped virtual key If no virtual key is mapped to the given hardware key 0 is returned.

void KeyMapping::UpdateExpireTime ( ) [static, protected]

Notify the keymappings that the time of Sequences has expired. Do this only on every KeyDown Message.

Friends And Related Function Documentation

friend class KeyManager [friend]

The documentation for this class was generated from the following files:
  • Atl/Context/KeyMapping.hpp
  • Atl/Context/KeyMapping.cpp
Generated on Wed Jan 25 01:23:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeymapTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeymapTableEntry Struct Reference

#include <Apoxi/Atl/Context/ContextDescriptionTypes.hpp>

Collaboration diagram for KeymapTableEntry:

[legend]

Data Fields

const FeatureHandle * | feature_handle
KeyCode | key_code
UINT8 | keymap_type
KeyCode | to_key_code

Field Documentation

const FeatureHandle* KeymapTableEntry::feature_handle

KeyCode KeymapTableEntry::key_code

UINT8 KeymapTableEntry::keymap_type

KeyCode KeymapTableEntry::to_key_code

The documentation for this struct was generated from the following file:
  • Atl/Context/ContextDescriptionTypes.hpp
Generated on Wed Jan 25 01:23:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyMsgGenerator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyMsgGenerator Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/KeyMsgGenerator.hpp>

Inheritance diagram for KeyMsgGenerator:

[legend]
Collaboration diagram for KeyMsgGenerator:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual UINT8 | GetPriority () const
priority controls the init sequence of SubSystems
virtual BootSequenceState | InvokeAt () const
define the point of time when the StackControl should be invoked
KeyMsgGenerator ()
virtual void | OnPowerDown ()
shuts down the KeyMsgGenerator sub-system
virtual void | OnPowerUp ()
starts up the KeyMsgGenerator sub-system

Static Public Member Functions

static BOOLEAN | Enqueue (const Key &key)
enqueues a new key into the internal key-queue
static KeyMsgGenerator * | GetInstance ()

Data Structures

class | Key
one key-object which is extracted by the AtKeyParser and used as input for the KeyMsgGenerator More...

Detailed Description

The KeyMsgGenerator is a Subsystem, which processes incoming key-data from ATC by using the AT-command at+ckpd. The ATC string is parsed by the AtKeyParser and translated into APOXI key messages. This SubSystem must be actived, for example when automatic testing should be applied.

Constructor & Destructor Documentation

KeyMsgGenerator::KeyMsgGenerator ( )

Member Function Documentation

BOOLEAN KeyMsgGenerator::Enqueue ( const Key & key ) [static]

enqueues a new key into the internal key-queue

static KeyMsgGenerator* KeyMsgGenerator::GetInstance ( ) [inline, static]

virtual const WCHAR* KeyMsgGenerator::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

virtual UINT8 KeyMsgGenerator::GetPriority ( ) const [inline, virtual]

priority controls the init sequence of SubSystems

Reimplemented from SubSystem.

virtual BootSequenceState KeyMsgGenerator::InvokeAt ( ) const [inline, virtual]

define the point of time when the StackControl should be invoked

Implements SubSystem.

void KeyMsgGenerator::OnPowerDown ( ) [virtual]

shuts down the KeyMsgGenerator sub-system

Reimplemented from SubSystem.

void KeyMsgGenerator::OnPowerUp ( ) [virtual]

starts up the KeyMsgGenerator sub-system

Reimplemented from SubSystem.

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/KeyMsgGenerator.hpp
  • Apc/SignalHandler/KeyMsgGenerator.cpp
Generated on Wed Jan 25 01:23:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyMsgGenerator::Key Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
KeyMsgGenerator::Key

KeyMsgGenerator::Key Class Reference

one key-object which is extracted by the AtKeyParser and used as input for the KeyMsgGenerator More...

#include <Apoxi/Apc/SignalHandler/KeyMsgGenerator.hpp>

Inheritance diagram for KeyMsgGenerator::Key:

[legend]
Collaboration diagram for KeyMsgGenerator::Key:

[legend]

Public Types

enum | State { Invalid, Set, InProcess }

Public Member Functions

UINT32 | GetDuration () const
KeyCode | GetKeyCode () const
UINT32 | GetPause () const
Key (UINT32 pause)
Key (KeyCode key_code, UINT32 duration)
Key ()

Friends

class | KeyMsgGenerator

Detailed Description

one key-object which is extracted by the AtKeyParser and used as input for the KeyMsgGenerator

Member Enumeration Documentation

enum KeyMsgGenerator::Key::State

Enumerator:
Invalid
Set
InProcess

Constructor & Destructor Documentation

KeyMsgGenerator::Key::Key ( ) [inline]

KeyMsgGenerator::Key::Key | ( | KeyCode | key_code,
 |  | UINT32 | duration
 | ) | [inline]

KeyMsgGenerator::Key::Key ( UINT32 pause ) [inline]

Member Function Documentation

UINT32 KeyMsgGenerator::Key::GetDuration ( ) const [inline]

KeyCode KeyMsgGenerator::Key::GetKeyCode ( ) const [inline]

UINT32 KeyMsgGenerator::Key::GetPause ( ) const [inline]

Friends And Related Function Documentation

friend class KeyMsgGenerator [friend]

The documentation for this class was generated from the following file:
  • Apc/SignalHandler/KeyMsgGenerator.hpp
Generated on Wed Jan 25 01:23:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeySequence Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeySequence Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/KeySequence.hpp>

Public Member Functions

BOOLEAN | GetConsumeLastKey () const
INT | GetLength () const
BOOLEAN | HasKeyAtPos (const KeyCode &key_code, INT pos) const
KeySequence (const KeyCode *keys, INT length, BOOLEAN consume_last_key)
~KeySequence ()

Protected Member Functions

BOOLEAN | IsStartOfSequence (const KeyCode &key) const

Friends

class | KeyMapping
class | KeySequenceCandidate

Detailed Description

Key sequence class

Friends And Related Function Documentation

friend class KeySequenceCandidate [friend]

The documentation for this class was generated from the following files:
  • Atl/Context/KeySequence.hpp
  • Atl/Context/KeySequence.cpp
Generated on Wed Jan 25 01:23:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeySequenceCandidate Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeySequenceCandidate Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/KeySequence.hpp>

Collaboration diagram for KeySequenceCandidate:

[legend]

Public Member Functions

BOOLEAN | GetConsumeLastKey () const
BOOLEAN | IsFinished () const
BOOLEAN | IsValidSequence (const KeyCode &key)
KeySequenceCandidate (const KeySequenceCandidate &candidate)
KeySequenceCandidate (const KeySequence *sequence)

Constructor & Destructor Documentation

KeySequenceCandidate::KeySequenceCandidate ( const KeySequence * sequence )

The documentation for this class was generated from the following files:
  • Atl/Context/KeySequence.hpp
  • Atl/Context/KeySequence.cpp
Generated on Wed Jan 25 01:23:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyToneAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyToneAudioDevice Class Reference

#include <Apoxi/Devices/Win32/KeyToneAudioDevice.hpp>

Inheritance diagram for KeyToneAudioDevice:

[legend]
Collaboration diagram for KeyToneAudioDevice:

[legend]

Public Types

enum KeyTone {
KeyTone1, KeyTone2, KeyTone3, KeyTone4,
KeyTone5
}
Key tone. More...

Public Member Functions

virtual const WCHAR * | GetName () const
virtual AudioReturnCode | Init (Priority prio)
KeyToneAudioDevice ()
void | SetStartParam (const StartParam *p_start_param)
virtual AudioReturnCode | Start (BOOLEAN auto_release=TRUE)
virtual AudioReturnCode | Stop (UINT8 channel=0)
virtual | ~KeyToneAudioDevice ()

Protected Member Functions

INT | ConvertKeyTone2INT (KeyTone key_tone)

Data Structures

struct | StartParam
Start parameter. More...

Detailed Description

Class KeyToneAudioDevice
Class to play a key tone.
Note: Key tones can always be played.

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Member Enumeration Documentation

enum KeyToneAudioDevice::KeyTone

Key tone.

Enumerator:
KeyTone1 | KeyTone1.
KeyTone2 | KeyTone2.
KeyTone3 | KeyTone3.
KeyTone4 | KeyTone4.
KeyTone5 | KeyTone5.

Constructor & Destructor Documentation

KeyToneAudioDevice::KeyToneAudioDevice ( )

KeyToneAudioDevice::~KeyToneAudioDevice ( ) [virtual]

Member Function Documentation

INT KeyToneAudioDevice::ConvertKeyTone2INT ( KeyTone key_tone ) [protected]

Map Tone to INT for aud_tone_id_enum-cast.

Parameters:
key_tone,: Key tone id to map.

const WCHAR * KeyToneAudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from GenericAudioDevice.

KeyToneAudioDevice::AudioReturnCode KeyToneAudioDevice::Init ( Priority prio ) [virtual]

See also:
AudioDevice::Init

void KeyToneAudioDevice::SetStartParam ( const StartParam * p_start_param )

Set start parameter.

Parameters:
p_start_param,: Pointer to start parameter structure.

KeyToneAudioDevice::AudioReturnCode KeyToneAudioDevice::Start ( BOOLEAN auto_release = TRUE ) [virtual]

Plays the requested key tone using the DSP tone generator.
Key tones have the highest priority and will be played instantly.
If DSP is occupied with an other tone, the tone will be paused and resumed for the key tone.

See also:
GenericAudioDevice::Start

Reimplemented from GenericAudioDevice.

KeyToneAudioDevice::AudioReturnCode KeyToneAudioDevice::Stop ( UINT8 channel = 0 ) [virtual]

Returns AudioRcfunctionalityNotAvailable

See also:
GenericAudioDevice::Stop

Reimplemented from GenericAudioDevice.

The documentation for this class was generated from the following files:
  • Devices/Win32/KeyToneAudioDevice.hpp
  • Devices/Win32/KeyToneAudioDevice.cpp
Generated on Wed Jan 25 01:23:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyToneAudioDevice::StartParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
KeyToneAudioDevice::StartParam

KeyToneAudioDevice::StartParam Struct Reference

Start parameter. More...

#include <Apoxi/Devices/Win32/KeyToneAudioDevice.hpp>

Public Member Functions

StartParam ()
constructor

Data Fields

KeyTone key_tone
Keytone to be played.
UINT16 mix_factor

Detailed Description

Start parameter.

Constructor & Destructor Documentation

KeyToneAudioDevice::StartParam::StartParam ( ) [inline]

constructor

Field Documentation

KeyTone KeyToneAudioDevice::StartParam::key_tone

Keytone to be played.

UINT16 KeyToneAudioDevice::StartParam::mix_factor

Kind of volume with range 0-0x7FFF.
0 - no sound, 0x7FFF is max.
0x4000 will result in a volume level equal to speech.

The documentation for this struct was generated from the following file:
  • Devices/Win32/KeyToneAudioDevice.hpp
Generated on Wed Jan 25 01:23:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyUpInputMapEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyUpInputMapEntry Struct Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Collaboration diagram for KeyUpInputMapEntry:

[legend]

Data Fields

UINT32 | m_duration
KeyCode | m_key_code
InputMapEntry m_map_entry

Field Documentation

UINT32 KeyUpInputMapEntry::m_duration

KeyCode KeyUpInputMapEntry::m_key_code

InputMapEntry KeyUpInputMapEntry::m_map_entry

The documentation for this struct was generated from the following file:
  • Kernel/InputMap.hpp
Generated on Wed Jan 25 01:23:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyUpInputMapItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyUpInputMapItem Class Reference
[Kernel]

#include <Apoxi/Kernel/InputMap.hpp>

Inheritance diagram for KeyUpInputMapItem:

[legend]
Collaboration diagram for KeyUpInputMapItem:

[legend]

Public Types

typedef InputMapItem | Base

Public Member Functions

UINT32 | GetDuration () const
KeyCode | GetKeyCode () const
KeyUpInputMapItem (MapItemType type, KeyCode key_code, UINT32 duration)
void | SetDuration (UINT32 duration)
void | SetKeyCode (KeyCode key_code)

Member Typedef Documentation

typedef InputMapItem KeyUpInputMapItem::Base

Constructor & Destructor Documentation

KeyUpInputMapItem::KeyUpInputMapItem | ( | MapItemType | type,
 |  | KeyCode | key_code,
 |  | UINT32 | duration
 | ) | [inline]

Member Function Documentation

UINT32 KeyUpInputMapItem::GetDuration ( ) const [inline]

KeyCode KeyUpInputMapItem::GetKeyCode ( ) const [inline]

void KeyUpInputMapItem::SetDuration ( UINT32 duration ) [inline]

void KeyUpInputMapItem::SetKeyCode ( KeyCode key_code ) [inline]

The documentation for this class was generated from the following file:
  • Kernel/InputMap.hpp
Generated on Wed Jan 25 01:23:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: KeyUpMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

KeyUpMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for KeyUpMsg:

[legend]
Collaboration diagram for KeyUpMsg:

[legend]

Public Types

enum | { ID = 201 }

Public Member Functions

virtual Message * | Clone () const
UINT32 | GetDuration () const
const KeyCode & | GetKeyCode () const
virtual const MsgMetaData & | GetMetaData () const
KeyUpMsg (const KeyCode &key_code=0, UINT32 duration=0)
void | SetDuration (UINT32 duration)
void | SetKeyCode (const KeyCode &key_code)
virtual | ~KeyUpMsg ()

Detailed Description

This message is sent to the active application whenever a user releases a key. m_key_code: contains the key code of the key released m_duration: contains the duration of the key press. Duration is measured by AXE_TICKS_PER_SECOND AXE_LONG_KEY_PRESS_DURATION and AXE_VERY_LONG_KEY_PRESS_DURATION define the time span of a long key or very long key press in AXE_TICKS_PER_SECOND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

KeyUpMsg::KeyUpMsg | ( | const KeyCode & | key_code = 0,
 |  | UINT32 | duration = 0
 | ) |

KeyUpMsg::~KeyUpMsg ( ) [virtual]

Member Function Documentation

Message * KeyUpMsg::Clone ( ) const [virtual]

Implements Message.

UINT32 KeyUpMsg::GetDuration ( ) const [inline]

const KeyCode& KeyUpMsg::GetKeyCode ( ) const [inline]

const MsgMetaData & KeyUpMsg::GetMetaData ( ) const [virtual]

Implements Message.

void KeyUpMsg::SetDuration ( UINT32 duration ) [inline]

void KeyUpMsg::SetKeyCode ( const KeyCode & key_code ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:23:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: L1Param Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

L1Param Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for L1Param:

[legend]

Public Member Functions

BOOLEAN | IsDscPchInvalid ()
BOOLEAN | IsDscPpchInvalid ()
BOOLEAN | IsRllInvalid ()
BOOLEAN | IsRxqualInvalid ()
BOOLEAN | IsTimingAdvanceInvalid ()
BOOLEAN | IsTxPowerLevelInvalid ()
L1Param ()
L1Param | operator= (T_L1_TESTPARAM_s l1_testparams)

Data Fields

CiTestParamList ci_param
BYTE | dsc_pch
UINT16 | dsc_ppch
BYTE | rll
BYTE | rxqual
BYTE | timing_advance
BYTE | tx_power_level

Constructor & Destructor Documentation

L1Param::L1Param ( ) [inline]

Member Function Documentation

BOOLEAN L1Param::IsDscPchInvalid ( ) [inline]

BOOLEAN L1Param::IsDscPpchInvalid ( ) [inline]

BOOLEAN L1Param::IsRllInvalid ( ) [inline]

BOOLEAN L1Param::IsRxqualInvalid ( ) [inline]

BOOLEAN L1Param::IsTimingAdvanceInvalid ( ) [inline]

BOOLEAN L1Param::IsTxPowerLevelInvalid ( ) [inline]

L1Param L1Param::operator= ( T_L1_TESTPARAM_s l1_testparams )

Field Documentation

CiTestParamList L1Param::ci_param

BYTE L1Param::dsc_pch

UINT16 L1Param::dsc_ppch

BYTE L1Param::rll

BYTE L1Param::rxqual

BYTE L1Param::timing_advance

BYTE L1Param::tx_power_level

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:23:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: L2CapSocketAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

L2CapSocketAddr Class Reference

#include <Apoxi/AddOns/BtSocket/BtSocketAddr.hpp>

Inheritance diagram for L2CapSocketAddr:

[legend]
Collaboration diagram for L2CapSocketAddr:

[legend]

Public Member Functions

void | GetDeviceAddress (BtDeviceAddress &btDevAddr)
unsigned short | GetPsm ()
void * | GetSockAddr ()
INT32 | GetSockAddrSize ()
L2CapSocketAddr (BtDeviceAddress &addr, UINT16 muxchan)
L2CapSocketAddr ()
~L2CapSocketAddr ()

Constructor & Destructor Documentation

L2CapSocketAddr::L2CapSocketAddr ( )

L2CapSocketAddr::L2CapSocketAddr | ( | BtDeviceAddress & | addr,
 |  | UINT16 | muxchan
 | ) |

Constructor.

Parameters:
addr | address reference.
muxchan | Mux channel.

L2CapSocketAddr::~L2CapSocketAddr ( )

Destructor.

Member Function Documentation

void L2CapSocketAddr::GetDeviceAddress ( BtDeviceAddress & btDevAddr )

Retrieves the device address.

Parameters:
btDevAddr Retrieves the device address in this object

unsigned short L2CapSocketAddr::GetPsm ( )

Retrieves the server channale.

void * L2CapSocketAddr::GetSockAddr ( ) [virtual]

This is used only for internal purposes.

Implements SocketAddr.

INT32 L2CapSocketAddr::GetSockAddrSize ( ) [virtual]

This is used only for internal purposes.

Implements SocketAddr.

The documentation for this class was generated from the following files:
  • AddOns/BtSocket/BtSocketAddr.hpp
  • AddOns/BtSocket/BtSocketAddr.cpp
Generated on Wed Jan 25 01:23:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Lai Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Lai Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for Lai:

[legend]

Data Fields

Lac lac
Plmn plmn

Field Documentation

Lac Lai::lac

Plmn Lai::plmn

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 01:23:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageArray Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [c_sizeof_languagearray]

Field Documentation

UINT8 LanguageArray::val[c_sizeof_languagearray]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:23:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageChangedMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for LanguageChangedMsg:

[legend]
Collaboration diagram for LanguageChangedMsg:

[legend]

Public Types

enum | { ID = 121 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
LanguageChangedMsg ()
virtual | ~LanguageChangedMsg ()

Detailed Description

This message is sent when the active language was changed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LanguageChangedMsg::LanguageChangedMsg ( )

LanguageChangedMsg::~LanguageChangedMsg ( ) [virtual]

Member Function Documentation

Message * LanguageChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & LanguageChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:23:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageCodeTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageCodeTableEntry Struct Reference

#include <Apoxi/AddOns/AdcExtensions/LanguageCodeRes.hpp>

Data Fields

DataCodingScheme::Language dcs_lang_code
UINT8 | gsm_lang_code
const WCHAR * | iso_2ltr_code
const WCHAR * | iso_3ltr_code
const WCHAR * | lang_name

Field Documentation

DataCodingScheme::Language LanguageCodeTableEntry::dcs_lang_code

UINT8 LanguageCodeTableEntry::gsm_lang_code

const WCHAR* LanguageCodeTableEntry::iso_2ltr_code

const WCHAR* LanguageCodeTableEntry::iso_3ltr_code

const WCHAR* LanguageCodeTableEntry::lang_name

The documentation for this struct was generated from the following file:
  • AddOns/AdcExtensions/LanguageCodeRes.hpp
Generated on Wed Jan 25 01:23:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageManager Class Reference
[GUI]

#include <Apoxi/Gui/LanguageManager.hpp>

Public Types

enum LanguageType {
English, German, Chinese, Arabic,
Thai, Hebrew, Vietnamese, Japanese,
Hindi, Italian, French, Greek,
Afrikaans, Albanian, Armenian, Basque,
Breton, Catalan, Corsican, Croatian,
Czech, Danish, Dutch, Esperanto,
Estonian, Finnish, Hungarian, Icelandic,
Indonesian, Irish, Latin, Latvian,
Lithuanian, Macedonian, Malay, Maltese,
Norwegian, Polish, Portuguese, Romanian,
Serbian, Slovak, Slovenian, Spanish,
Swahili, Swedish, Turkish, Xhosa,
Zulu, Bulgarian, Byelorussian, Russian,
SerboCroatian, Ukrainian
}

Static Public Member Functions

static INT | GetActiveLanguage ()
static LanguageType | GetActiveLanguageType ()
static const WCHAR * | GetString (INT index)
Obsolete - Returns the string with the index index of the current set language table.
static BOOLEAN | HasActiveLanguageChanged ()
static INT | MapIso639 (const WCHAR *code)
static const WCHAR * | ReTranslate (const WCHAR *text)
static void | SetActiveLanguage (INT lang_id)
static void | SetActiveLanguageType (LanguageType lang_type)
static const WCHAR * | Translate (const WCHAR *text, INT ambiguous_hint=-1)

Detailed Description

Allows to set and get the active language for the system. The language manager also assures a proper translation of strings.

Member Enumeration Documentation

enum LanguageManager::LanguageType

Enumerator:
English
German
Chinese
Arabic
Thai
Hebrew
Vietnamese
Japanese
Hindi
Italian
French
Greek
Afrikaans
Albanian
Armenian
Basque
Breton
Catalan
Corsican
Croatian
Czech
Danish
Dutch
Esperanto
Estonian
Finnish
Hungarian
Icelandic
Indonesian
Irish
Latin
Latvian
Lithuanian
Macedonian
Malay
Maltese
Norwegian
Polish
Portuguese
Romanian
Serbian
Slovak
Slovenian
Spanish
Swahili
Swedish
Turkish
Xhosa
Zulu
Bulgarian
Byelorussian
Russian
SerboCroatian
Ukrainian

Member Function Documentation

static INT LanguageManager::GetActiveLanguage ( ) [inline, static]

Returns the ID of the current set language. It is recommended that the applications work with the LanguageManager::LanguageType instead of language IDs (see LanguageManager::SetActiveLanguageType() and LanguageManager::GetActiveLanguageType()).

LanguageManager::LanguageType LanguageManager::GetActiveLanguageType ( ) [static]

Returns the language type of the current set language. Note that LocaleConfig::GetLanguageType() must be customized, which maps the language IDs to the language type (the class LocaleConfig is in the Config directory of the project).

const WCHAR * LanguageManager::GetString ( INT index ) [static]

Obsolete - Returns the string with the index index of the current set language table.

static BOOLEAN LanguageManager::HasActiveLanguageChanged ( ) [inline, static]

Returns TRUE, if the active language has been changed after the booting process. If FALSE is returned some internal optimizations are possible, as retranslating strings is a quite expensive operation.

INT LanguageManager::MapIso639 ( const WCHAR * code ) [static]

Maps the language code defined in ISO-639 to the internal language ID. If no language ID is available for the given code, -1 is returned.

const WCHAR * LanguageManager::ReTranslate ( const WCHAR * text ) [static]

Retranslates the translated text text to the text dependand on the current set language. If text is not part of the language-table or no language table is provided, text itself is returned.

Parameters:
text Pointer to the already translated text.
Returns:
Pointer to the retranslated text.

void LanguageManager::SetActiveLanguage ( INT lang_id ) [static]

Sets the language to lang_id. The maximum numbers of available languages are defined by LocaleConfig::GetLanguageCount (the class LocaleConfig is in the Config directory of the project). All windows get the message LanguageChangedMsg, which can be treated with the method Component::OnLanguageChanged(). Additionally an update to all themes is done, because a theme may change it's font dynamically by the method ThemeConfig::GetFontId().

It is recommended that the applications work with the LanguageManager::LanguageType instead of language IDs (see LanguageManager::SetActiveLanguageType() and LanguageManager::GetActiveLanguageType()).

void LanguageManager::SetActiveLanguageType ( LanguageType lang_type ) [static]

Sets the language to lang_type. All windows get the message LanguageChangedMsg, which can be treated with the method Component::OnLanguageChanged(). Additionally an update to all themes is done, because a theme may change it's font dynamically by the method ThemeConfig::GetFontId().

Note that LocaleConfig::GetLanguageType() must be customized, which maps the language IDs to the language type (the class LocaleConfig is in the Config directory of the project).

const WCHAR * LanguageManager::Translate | ( | const WCHAR * | text,
 |  | INT | ambiguous_hint = -1
 | ) | [static]

Translates the non-translated text text and returns the corresponding text dependend on the current set language. If no language table is provided, text itself is returned.

Parameters:
text | Pointer to the text which should be translated.
ambiguous_hint | It is possible that one text may have different translations in different contexts. ambiguous_hint indicates the index of the context starting with zero. The default value is -1, which means that there is a 1 to 1 relation between the text and it's translations.
Returns:
Pointer to translated text.

The documentation for this class was generated from the following files:
  • Gui/LanguageManager.hpp
  • Gui/LanguageManager.cpp
Generated on Wed Jan 25 01:23:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageProvider Class Reference

#include <Apoxi/AddOns/AdcExtensions/LanguageProvider.hpp>

Inheritance diagram for LanguageProvider:

[legend]
Collaboration diagram for LanguageProvider:

[legend]

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
virtual INT | GetProviderId () const
LanguageProvider ()
virtual INT | RowCount ()
virtual | ~LanguageProvider ()

Detailed Description

LanguageProvider is a read-only provider to retrieve several languages which are defined in ISO 639-1 (2 letter language codes). This provider has the id c_language_provider_id. LanguageProvider offers the following columns:
c_dcs_language_code_id | NumberType | The language-code as specified in Apc/DataCodingSchemeLanguage.
c_language_name_id | WStringType | The key for the language name for translation via Tr().
c_2_letter_iso639_code_id | WStringType | Two letter language code according to ISO 639-1.
c_3_letter_iso639_code_id | WStringType | Three letter language code according to ISO 639-2.

Constructor & Destructor Documentation

LanguageProvider::LanguageProvider ( )

LanguageProvider::~LanguageProvider ( ) [virtual]

Member Function Documentation

BOOLEAN LanguageProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
Provider::GetDataItem

Implements Provider.

INT LanguageProvider::GetProviderId ( ) const [virtual]

See also:
Provider::GetProviderId

Implements Provider.

INT LanguageProvider::RowCount ( ) [virtual]

See also:
Provider::RowCount

Implements Provider.

The documentation for this class was generated from the following files:
  • AddOns/AdcExtensions/LanguageProvider.hpp
  • AddOns/AdcExtensions/LanguageProvider.cpp
Generated on Wed Jan 25 01:24:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageResetAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageResetAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for LanguageResetAction:

[legend]
Collaboration diagram for LanguageResetAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
INT | GetLanguageCode () const
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
LanguageResetAction ()
virtual BOOLEAN | ShallExecuteImmediatly ()
Will always deliver TRUE because input of terminating # shall start execution immediatly.
virtual | ~LanguageResetAction ()

Detailed Description

LanguageResetAction analyzes if the input string has the meaning of an Orange language reset string, that means if it fullfills the following syntax: *#000n#, where n is an integer in the range from 0 to 2, current valid strings are *#0000# - English, *#0001# - German, *#0002# - French.

Constructor & Destructor Documentation

LanguageResetAction::LanguageResetAction ( )

LanguageResetAction::~LanguageResetAction ( ) [virtual]

Member Function Documentation

InputAction * LanguageResetAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType LanguageResetAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

INT LanguageResetAction::GetLanguageCode ( ) const [inline]

BOOLEAN LanguageResetAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

BOOLEAN LanguageResetAction::ShallExecuteImmediatly ( ) [virtual]

Will always deliver TRUE because input of terminating # shall start execution immediatly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:24:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageSelectEventArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageSelectEventArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for LanguageSelectEventArg:

[legend]
Collaboration diagram for LanguageSelectEventArg:

[legend]

Public Types

enum | { ID = 2318 }

Public Member Functions

const ExtLanguage & | GetExtLanguage () const
LanguageSelectEventArg ()
LanguageSelectEventArg (const ExtLanguage &ext_language)
void | SetExtLanguage (const ExtLanguage &ext_language)

Static Public Member Functions

static const LanguageSelectEventArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

LanguageSelectEventArg: reflects arguments of signal SI_LANG_SELECT_EVENT

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LanguageSelectEventArg::LanguageSelectEventArg ( const ExtLanguage & ext_language )

LanguageSelectEventArg::LanguageSelectEventArg ( )

Member Function Documentation

const LanguageSelectEventArg & LanguageSelectEventArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ExtLanguage& LanguageSelectEventArg::GetExtLanguage ( ) const [inline]

void LanguageSelectEventArg::SetExtLanguage ( const ExtLanguage & ext_language ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:24:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageSettingIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageSettingIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for LanguageSettingIndArg:

[legend]
Collaboration diagram for LanguageSettingIndArg:

[legend]

Public Types

enum | { ID = 2319 }

Public Member Functions

const ExtLanguage & | GetExtLanguage () const
LanguageSettingIndArg ()
LanguageSettingIndArg (const ExtLanguage &ext_language)
void | SetExtLanguage (const ExtLanguage &ext_language)

Static Public Member Functions

static const LanguageSettingIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

LanguageIndArg: reflects arguments of signal SI_LANGUAGE_SETTING_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LanguageSettingIndArg::LanguageSettingIndArg ( const ExtLanguage & ext_language )

LanguageSettingIndArg::LanguageSettingIndArg ( )

Member Function Documentation

const LanguageSettingIndArg & LanguageSettingIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ExtLanguage& LanguageSettingIndArg::GetExtLanguage ( ) const [inline]

void LanguageSettingIndArg::SetExtLanguage ( const ExtLanguage & ext_language ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:24:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LanguageSettingReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LanguageSettingReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for LanguageSettingReqArg:

[legend]
Collaboration diagram for LanguageSettingReqArg:

[legend]

Public Types

enum | { ID = 1318 }

Public Member Functions

const SimTkTransactionId & | GetTid () const
LanguageSettingReqArg ()
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const LanguageSettingReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

LanguageSettingReqArg: reflects arguments of signal SI_LANGUAGE_SETTING_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LanguageSettingReqArg::LanguageSettingReqArg ( )

Member Function Documentation

const LanguageSettingReqArg & LanguageSettingReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkTransactionId& LanguageSettingReqArg::GetTid ( ) const [inline]

void LanguageSettingReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:24:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LastLocationEstimate Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LastLocationEstimate Class Reference

Stores the last known location estimate along with the timestamp. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Inheritance diagram for LastLocationEstimate:

[legend]
Collaboration diagram for LastLocationEstimate:

[legend]

Public Member Functions

void operator= (const LocationEstimate &loc_est)
Assignment operator.

Data Fields

DateTime m_time_stamp
Time-stamp of the location estimate.

Detailed Description

Stores the last known location estimate along with the timestamp.

Member Function Documentation

void LastLocationEstimate::operator= ( const LocationEstimate & loc_est ) [inline]

Assignment operator.

Field Documentation

DateTime LastLocationEstimate::m_time_stamp

Time-stamp of the location estimate.

The documentation for this class was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:24:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LaunchBrowserIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LaunchBrowserIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for LaunchBrowserIndArg:

[legend]
Collaboration diagram for LaunchBrowserIndArg:

[legend]

Public Types

enum | { ID = 2325 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
LaunchBrowserIndArg ()
LaunchBrowserIndArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const LaunchBrowserIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

LaunchBrowserIndArg: reflects arguments of signal SIBR_LAUNCH_BROWSER_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LaunchBrowserIndArg::LaunchBrowserIndArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

LaunchBrowserIndArg::LaunchBrowserIndArg ( )

Member Function Documentation

const LaunchBrowserIndArg & LaunchBrowserIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& LaunchBrowserIndArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& LaunchBrowserIndArg::GetTid ( ) const [inline]

void LaunchBrowserIndArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void LaunchBrowserIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:24:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LaunchBrowserPromptIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LaunchBrowserPromptIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for LaunchBrowserPromptIndArg:

[legend]
Collaboration diagram for LaunchBrowserPromptIndArg:

[legend]

Public Types

enum | { ID = 2324 }

Public Member Functions

UINT8 | GetGeneralResult () const
const SimTkTransactionId & | GetTid () const
LaunchBrowserPromptIndArg ()
LaunchBrowserPromptIndArg (const SimTkTransactionId &tid, UINT8 general_result)
void | SetGeneralResult (UINT8 general_result)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const LaunchBrowserPromptIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

LaunchBrowserPromptIndArg: reflects arguments of signal SI_LAUNCH_BROWSER_PROMPT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LaunchBrowserPromptIndArg::LaunchBrowserPromptIndArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | general_result
 | ) |

LaunchBrowserPromptIndArg::LaunchBrowserPromptIndArg ( )

Member Function Documentation

const LaunchBrowserPromptIndArg & LaunchBrowserPromptIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 LaunchBrowserPromptIndArg::GetGeneralResult ( ) const [inline]

const SimTkTransactionId& LaunchBrowserPromptIndArg::GetTid ( ) const [inline]

void LaunchBrowserPromptIndArg::SetGeneralResult ( UINT8 general_result ) [inline]

void LaunchBrowserPromptIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:24:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Layouter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Layouter Class Reference
[GUI]

#include <Apoxi/Gui/Layouter.hpp>

Public Types

enum | StretchUnit { Percent, Pixel }
Specifies, whether the stretching-parameters should be interpreted in percent or as pixels. More...
enum | XAlign { XDefault, Left, Center, Right }
Specifies the x-alignment of an element (= Component or another Layouter). More...
enum | YAlign { YDefault, Top, Middle, Bottom }
Specifies the y-alignment of an element (= Component or another Layouter). More...

Public Member Functions

void | Arrange (INT x_idx, INT y_idx, Layouter *layouter)
void | Arrange (INT x_idx, INT y_idx, Component *content, XAlign x_align=XDefault, YAlign y_align=YDefault)
Size | GetCellSize (INT row, INT column) const
Layouter (INT x_cells, INT y_cells, const Rect &bounding_rect, XAlign x_align=XDefault, YAlign y_align=YDefault)
Layouter (INT x_cells, INT y_cells, const Control *control, XAlign x_align=XDefault, YAlign y_align=YDefault)
Layouter (INT x_cells, INT y_cells, DeviceContext *dc=0, XAlign x_align=XDefault, YAlign y_align=YDefault)
Obsolete - use Layouter::Layouter(..., Control* control, ...) instead.
void | StretchXGrid (const WCHAR *stretch_descr, StretchUnit unit=Percent)
void | StretchYGrid (const WCHAR *stretch_descr, StretchUnit unit=Percent)

Detailed Description

The class Layouter is capable of layouting components and recursively other layouters inside a grid. The number of horizontal and vertical cells inside the grid can be specified in the constructor of Layouter. A componenent or another layouter can be arranged inside a cell.

Example: Two checkboxes and one editor are aligned vertically in a window. When the size of the window changes, the size of the controls is adjusted by the layouter. In the method Init of the window the three controls are initialized.

void MyWin::Init()
{
    Window::Init();
    m_checkbox_1.Init(this, Tr(L"CheckBox 1"), FALSE);
    m_checkbox_2.Init(this, Tr(L"CheckBox 2"), FALSE);
    m_editor.Init(this, InputMapper::Predictive, L"Test");
}

Variant 1: Each control gets 33 % of the window-height.

void MyWin::OnLayoutClient()
{
    Window::OnLayoutClient();
    Layouter layouter(1, 3, this);
    layouter.Arrange(0, 0, &m_checkbox_1);
    layouter.Arrange(0, 1, &m_checkbox_2);
    layouter.Arrange(0, 2, &m_editor);
}

Variant 2: Each checkbox gets 25 % and the editor 50 % of the window-height.

void MyWin::OnLayoutClient()
{
    Window::OnLayoutClient();
    Layouter layouter(1, 3, this);
    layouter.StretchYGrid(L"25,25,50", Layouter::Percent);
    layouter.Arrange(0, 0, &m_checkbox_1);
    layouter.Arrange(0, 1, &m_checkbox_2);
    layouter.Arrange(0, 2, &m_editor);
}

Variant 3: The checkboxes have a fixed size of 20 pixels and the editor gets the remaining size of the window.

void MyWin::OnLayoutClient()
{
    Window::OnLayoutClient();
    Layouter layouter(1, 3, this);
    layouter.StretchYGrid(L"20,20,--", Layouter::Pixel);
    layouter.Arrange(0, 0, &m_checkbox_1);
    layouter.Arrange(0, 1, &m_checkbox_2);
    layouter.Arrange(0, 2, &m_editor);
}

Member Enumeration Documentation

enum Layouter::StretchUnit

Specifies, whether the stretching-parameters should be interpreted in percent or as pixels.

Enumerator:
Percent | Percent.
Pixel | Pixel.

enum Layouter::XAlign

Specifies the x-alignment of an element (= Component or another Layouter).

Enumerator:
XDefault | Use default-alignment (= Center).
Left | Align on the left side of the cell.
Center | Align centered inside the cell.
Right | Align on the right side of the cell.

enum Layouter::YAlign

Specifies the y-alignment of an element (= Component or another Layouter).

Enumerator:
YDefault | Use default-alignment (= Middle).
Top | Align on the top of the cell.
Middle | Align in the middle of the cell.
Bottom | Align on the bottom of the cell.

Constructor & Destructor Documentation

Layouter::Layouter | ( | INT | x_cells,
 |  | INT | y_cells,
 |  | DeviceContext * | dc = 0,
 |  | XAlign | x_align = XDefault,
 |  | YAlign | y_align = YDefault
 | ) |

Obsolete - use Layouter::Layouter(..., Control* control, ...) instead.

Layouter::Layouter | ( | INT | x_cells,
 |  | INT | y_cells,
 |  | const Control * | control,
 |  | XAlign | x_align = XDefault,
 |  | YAlign | y_align = YDefault
 | ) |

Parameters:
x_cells | Number of cells in horizontal direction.
y_cells | Number of cells in vertical direction.
control | Specifies the Control which specifies the available horizontal and vertical space for the cells by its client area.
x_align | Horizontal alignment of an element inside a cell.
y_align | Vertical alignment of an element inside a cell.

Layouter::Layouter | ( | INT | x_cells,
 |  | INT | y_cells,
 |  | const Rect & | bounding_rect,
 |  | XAlign | x_align = XDefault,
 |  | YAlign | y_align = YDefault
 | ) |

Parameters:
x_cells | Number of cells in horizontal direction.
y_cells | Number of cells in vertical direction.
bounding_rect | Specifies the the position and available size for the cells.
x_align | Horizontal alignment of an element inside a cell.
y_align | Vertical alignment of an element inside a cell.

Member Function Documentation

void Layouter::Arrange | ( | INT | x_idx,
 |  | INT | y_idx,
 |  | Layouter * | layouter
 | ) |

Arranges another layouter inside the cell indicated by the horizontal index x_idx and the vertical index y_idx.

Parameters:
x_idx | Horizontal index of the cell, which should hold the Component (index starts at 0).
y_idx | Vertical index of the cell, which should hold the Component (index starts at 0).
layouter | Pointer to the layouter, which should be embedded.

void Layouter::Arrange | ( | INT | x_idx,
 |  | INT | y_idx,
 |  | Component * | content,
 |  | XAlign | x_align = XDefault,
 |  | YAlign | y_align = YDefault
 | ) |

Arranges a Comonent inside the cell indicated by the horizontal index x_idx and the vertical index y_idx. By default the alignment given by the constructor will be used for all cells. To overwrite them for the cell, use x_align and y_align.

Parameters:
x_idx | Horizontal index of the cell, which should hold the abstract drawable object (index starts at 0).
y_idx | Vertical index of the cell, which should hold the Component (index starts at 0).
content | Pointer to the Component, which should be embedded.
x_align | Horizontal alignment of the Component (default: X_DEFAULT).
y_align | Vertical alignment of the Component (default: Y_DEFAULT).

Size Layouter::GetCellSize | ( | INT | row,
 |  | INT | column
 | ) | const

Returns:
the width and height of the cell at position x/y

void Layouter::StretchXGrid | ( | const WCHAR * | stretch_descr,
 |  | StretchUnit | unit = Percent
 | ) |

By default each cell has the same width. This can be changed by specifying the string stretch_descr. Note: this method must be invoked before arranging the cells.

Parameters:
stretch_descr If the unit is Percent, it describes the percentual ratio of each cell. E. g. given are 3 x 3 cells. L"25,25,50" means the cells on the left need 25 % of the available width, the cells in the middle need 25 % and the cells on the right need 50 %.
If the unit is Pixel, it describes the width of each cell in pixels. The special string '--' can be used to stretch one cell to the remaining space. Note that only one cell may contain a '--'!
Parameters:
unit Describes, whether the stretch descriptor should be interpreted as percentual values or as pixel values.

void Layouter::StretchYGrid | ( | const WCHAR * | stretch_descr,
 |  | StretchUnit | unit = Percent
 | ) |

By default each cell has the same height. This can be changed by specifying the string stretch_descr. Note: this method must be invoked before arranging the cells.

Parameters:
stretch_descr If the unit is Percent, it describes the percentual ratio of each cell. E. g. given are 3 x 3 cells. L"25,25,50" means the cells on the top need 25 % of the available width, the cells in the middle need 25 % and the cells on the bottom need 50 %.
If the unit is Pixel, it describes the height of each cell in pixels. The special string '--' can be used to stretch one cell to the remaining space. Note that only one cell may contain a '--'!
Parameters:
unit Describes, whether the stretch descriptor should be interpreted as percentual values or as pixel values.

The documentation for this class was generated from the following files:
  • Gui/Layouter.hpp
  • Gui/Layouter.cpp
Generated on Wed Jan 25 01:24:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsAppRegisterForMtlrMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsAppRegisterForMtlrMsg Class Reference

#include <Applications/Lcs/LcsAppMsgTypes.hpp>

Inheritance diagram for LcsAppRegisterForMtlrMsg:

[legend]
Collaboration diagram for LcsAppRegisterForMtlrMsg:

[legend]

Public Types

enum | { ID = 22236 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
LcsAppRegisterForMtlrMsg (Application *application)
virtual | ~LcsAppRegisterForMtlrMsg ()

Detailed Description

This message indicates that the application should register for MT-LR

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LcsAppRegisterForMtlrMsg::LcsAppRegisterForMtlrMsg ( Application * application )

LcsAppRegisterForMtlrMsg::~LcsAppRegisterForMtlrMsg ( ) [virtual]

Member Function Documentation

Message * LcsAppRegisterForMtlrMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & LcsAppRegisterForMtlrMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsAppMsgTypes.hpp
  • Applications/Lcs/LcsAppMsgTypes.cpp
Generated on Wed Jan 25 01:24:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsAppResWinMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsAppResWinMsg Class Reference

#include <Applications/Lcs/LcsAppMsgTypes.hpp>

Inheritance diagram for LcsAppResWinMsg:

[legend]
Collaboration diagram for LcsAppResWinMsg:

[legend]

Public Types

enum | { ID = 22237 }

Public Member Functions

virtual Message * | Clone () const
const ResultWinBase::ResWinAction & | GetEventCode () const
virtual const MsgMetaData & | GetMetaData () const
LcsAppResWinMsg (Application *application, const ResultWinBase::ResWinAction &event_code)
virtual | ~LcsAppResWinMsg ()

Detailed Description

This message indicates the next data to be displayed as location result

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LcsAppResWinMsg::LcsAppResWinMsg | ( | Application * | application,
 |  | const ResultWinBase::ResWinAction & | event_code
 | ) |

LcsAppResWinMsg::~LcsAppResWinMsg ( ) [virtual]

Member Function Documentation

Message * LcsAppResWinMsg::Clone ( ) const [virtual]

Implements Message.

const ResultWinBase::ResWinAction& LcsAppResWinMsg::GetEventCode ( ) const [inline]

const MsgMetaData & LcsAppResWinMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsAppMsgTypes.hpp
  • Applications/Lcs/LcsAppMsgTypes.cpp
Generated on Wed Jan 25 01:24:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsAppTransferLocMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsAppTransferLocMsg Class Reference

#include <Applications/Lcs/LcsAppMsgTypes.hpp>

Inheritance diagram for LcsAppTransferLocMsg:

[legend]
Collaboration diagram for LcsAppTransferLocMsg:

[legend]

Public Types

enum | { ID = 22232 }

Public Member Functions

virtual Message * | Clone () const
const ClientId & | GetClientId () const
virtual const MsgMetaData & | GetMetaData () const
const MlcNumber & | GetMlcNumber () const
LcsAppTransferLocMsg (Application *application, const ClientId &client_id, const MlcNumber &mlc_number)
virtual | ~LcsAppTransferLocMsg ()

Detailed Description

This message indicates that a transfer-location request should be sent

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LcsAppTransferLocMsg::LcsAppTransferLocMsg | ( | Application * | application,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number
 | ) |

LcsAppTransferLocMsg::~LcsAppTransferLocMsg ( ) [virtual]

Member Function Documentation

Message * LcsAppTransferLocMsg::Clone ( ) const [virtual]

Implements Message.

const ClientId& LcsAppTransferLocMsg::GetClientId ( ) const [inline]

const MsgMetaData & LcsAppTransferLocMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const MlcNumber& LcsAppTransferLocMsg::GetMlcNumber ( ) const [inline]

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsAppMsgTypes.hpp
  • Applications/Lcs/LcsAppMsgTypes.cpp
Generated on Wed Jan 25 01:24:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsAppUtils Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsAppUtils Class Reference

#include <Applications/Lcs/LcsAppUtils.hpp>

Collaboration diagram for LcsAppUtils:

[legend]

Public Member Functions

void | DisplayMsg (const WCHAR *err_str) const
void | DisplayMsg () const
BOOLEAN | FormQos (LcsMmiQos &lcs_mmi_qos)
BOOLEAN | GetData (const CHAR *data_type, INT32 &data)
This method gets tha data from registry and returns in integer format.
BOOLEAN | GetData (const CHAR *data_type, WString &data)
This method gets tha data from registry and returns in string format.
BOOLEAN | IsReqSent ()
void | ProcessDispMapDecision (BOOLEAN feature_wai)
void | ProcessLocationError (LcsErrorCode err_code)
void | ProcessSelfLocation ()
void | ProcessTransferLocation (const ClientId &client_id, const MlcNumber &mlc_number)
void | SendAbortReq () const
void | SetReqSent (BOOLEAN flag)
BOOLEAN | StoreData (const CHAR *data_type, const WString &data) const
This method takes the data in string format and stores it in registry.
~LcsAppUtils ()
Destructor.

Static Public Member Functions

static LcsAppUtils * | GetInstance ()
static void | ReleaseInstance ()

Detailed Description

This class implements functionalities which are common across all features/applications

Constructor & Destructor Documentation

LcsAppUtils::~LcsAppUtils ( )

Destructor.

Member Function Documentation

void LcsAppUtils::DisplayMsg ( const WCHAR * err_str ) const

void LcsAppUtils::DisplayMsg ( ) const

BOOLEAN LcsAppUtils::FormQos ( LcsMmiQos & lcs_mmi_qos )

BOOLEAN LcsAppUtils::GetData | ( | const CHAR * | data_type,
 |  | INT32 & | data
 | ) |

This method gets tha data from registry and returns in integer format.

BOOLEAN LcsAppUtils::GetData | ( | const CHAR * | data_type,
 |  | WString & | data
 | ) |

This method gets tha data from registry and returns in string format.

LcsAppUtils * LcsAppUtils::GetInstance ( ) [static]

BOOLEAN LcsAppUtils::IsReqSent ( ) [inline]

void LcsAppUtils::ProcessDispMapDecision ( BOOLEAN feature_wai )

void LcsAppUtils::ProcessLocationError ( LcsErrorCode err_code )

void LcsAppUtils::ProcessSelfLocation ( )

void LcsAppUtils::ProcessTransferLocation | ( | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number
 | ) |

void LcsAppUtils::ReleaseInstance ( ) [static]

void LcsAppUtils::SendAbortReq ( ) const

void LcsAppUtils::SetReqSent ( BOOLEAN flag ) [inline]

BOOLEAN LcsAppUtils::StoreData | ( | const CHAR * | data_type,
 |  | const WString & | data
 | ) | const

This method takes the data in string format and stores it in registry.

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsAppUtils.hpp
  • Applications/Lcs/LcsAppUtils.cpp
Generated on Wed Jan 25 01:24:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsArc Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsArc Struct Reference

Stores location estimate in 'point' format with uncertainty of type 'arc'. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for LcsArc:

[legend]

Data Fields

UINT16 | m_confidence
UINT16 | m_included_angle
UINT32 | m_inner_radius
UINT16 | m_offset_angle
LcsPoint m_point
UnsignedValue m_uncert_radius

Detailed Description

Stores location estimate in 'point' format with uncertainty of type 'arc'.

Field Documentation

UINT16 LcsArc::m_confidence

UINT16 LcsArc::m_included_angle

UINT32 LcsArc::m_inner_radius

UINT16 LcsArc::m_offset_angle

LcsPoint LcsArc::m_point

UnsignedValue LcsArc::m_uncert_radius

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:24:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsCommonMsgProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsCommonMsgProcessor Class Reference

This class sends the abortion request to Lcs stack. More...

#include <Apoxi/AddOns/Lcs/Common/LcsCommonMsgProcessor.hpp>

Inheritance diagram for LcsCommonMsgProcessor:

[legend]
Collaboration diagram for LcsCommonMsgProcessor:

[legend]

Static Public Member Functions

static void ProcessAbortReq ()
Forms a MN_LCS_ABORT_REQ SDL signal and sends to Lcs Stack.

Detailed Description

This class sends the abortion request to Lcs stack.

Member Function Documentation

void LcsCommonMsgProcessor::ProcessAbortReq ( ) [static]

Forms a MN_LCS_ABORT_REQ SDL signal and sends to Lcs Stack.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonMsgProcessor.hpp
  • AddOns/Lcs/Common/LcsCommonMsgProcessor.cpp
Generated on Wed Jan 25 01:24:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsCommonSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsCommonSignalMapTableNode Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonSignalMapTableNode.hpp>

Inheritance diagram for LcsCommonSignalMapTableNode:

[legend]
Collaboration diagram for LcsCommonSignalMapTableNode:

[legend]

Public Member Functions

~LcsCommonSignalMapTableNode ()
Destructor.

Static Public Member Functions

static LcsCommonSignalMapTableNode * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()

Detailed Description

This class Keeps the mapping table of abort SDL signal to the processing method

Constructor & Destructor Documentation

LcsCommonSignalMapTableNode::~LcsCommonSignalMapTableNode ( )

Destructor.

Member Function Documentation

LcsCommonSignalMapTableNode * LcsCommonSignalMapTableNode::GetInstance ( ) [static]

The only method to get the instance of this class.

void LcsCommonSignalMapTableNode::ReleaseInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonSignalMapTableNode.hpp
  • AddOns/Lcs/Common/LcsCommonSignalMapTableNode.cpp
Generated on Wed Jan 25 01:24:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsCommonSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsCommonSignalProcessor Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonSignalProcessor.hpp>

Static Public Member Functions

static void PostAbortResponse (const ProcessPtr &process_ptr)
Processes MN_ LCS_ABORT_RSP SDL signal.

Detailed Description

This class generates (and posts) APOXI messages corresponding to the incoming LCS-abort SDL signal

Member Function Documentation

void LcsCommonSignalProcessor::PostAbortResponse ( const ProcessPtr & process_ptr ) [static]

Processes MN_ LCS_ABORT_RSP SDL signal.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonSignalProcessor.hpp
  • AddOns/Lcs/Common/LcsCommonSignalProcessor.cpp
Generated on Wed Jan 25 01:24:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsCommonStackMsgArgsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsCommonStackMsgArgsDestroyTableNode Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonStackMsgArgs.hpp>

Inheritance diagram for LcsCommonStackMsgArgsDestroyTableNode:

[legend]
Collaboration diagram for LcsCommonStackMsgArgsDestroyTableNode:

[legend]

Static Public Member Functions

static LcsCommonStackMsgArgsDestroyTableNode * GetInstance ()

Member Function Documentation

LcsCommonStackMsgArgsDestroyTableNode * LcsCommonStackMsgArgsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonStackMsgArgs.hpp
  • AddOns/Lcs/Common/LcsCommonStackMsgArgs.cpp
Generated on Wed Jan 25 01:24:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsMainApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsMainApp Class Reference

#include <Applications/Lcs/LcsMainApp.hpp>

Collaboration diagram for LcsMainApp:

[legend]

Public Member Functions

virtual | ~LcsMainApp ()
Destructor.

Static Public Member Functions

static LcsMainApp * | GetInstance ()
The only method to get the instance of this class.

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &context_item)
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnStartup ()
virtual BOOLEAN | OnTimeout (const Timer &timer)

Detailed Description

Main application class for Lcs application. This class is responsible for invoking all the main windows for loction notification & verification and location result. It registers for all the messages sent to the MMI app by Location Service Application. Depending on the type of message received, it opens a specific window.

Constructor & Destructor Documentation

LcsMainApp::~LcsMainApp ( ) [virtual]

Destructor.

Member Function Documentation

LcsMainApp * LcsMainApp::GetInstance ( ) [static]

The only method to get the instance of this class.

void LcsMainApp::OnClose ( ) [protected, virtual]

BOOLEAN LcsMainApp::OnContextFeatureTriggered | ( | const FeatureID & | feature_id,
 |  | const DataItem & | context_item
 | ) | [protected, virtual]

BOOLEAN LcsMainApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN LcsMainApp::OnMessage ( const Message & msg ) [protected, virtual]

void LcsMainApp::OnOpen ( ) [protected, virtual]

void LcsMainApp::OnStartup ( ) [protected, virtual]

BOOLEAN LcsMainApp::OnTimeout ( const Timer & timer ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsMainApp.hpp
  • Applications/Lcs/LcsMainApp.cpp
Generated on Wed Jan 25 01:24:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsMainMenuWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsMainMenuWin Class Reference

#include <Applications/Lcs/LcsMainMenuWin.hpp>

Collaboration diagram for LcsMainMenuWin:

[legend]

Public Member Functions

void | Init ()
LcsMainMenuWin ()
Constructor.
void | SetStatus (INT status)
void | SetTime (WString time_str)
virtual | ~LcsMainMenuWin ()
Destructor.

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual void | OnGetFocus ()
virtual void | OnOpen ()

Detailed Description

Class for Lcs main menu. This window displays the following options: 1. GPS Receiver 2. Where Am I 3. Friend Finder On selecting one of the options, the corresponding functionality is invoked

Constructor & Destructor Documentation

LcsMainMenuWin::LcsMainMenuWin ( )

Constructor.

LcsMainMenuWin::~LcsMainMenuWin ( ) [virtual]

Destructor.

Member Function Documentation

void LcsMainMenuWin::Init ( )

void LcsMainMenuWin::OnActionExecuted ( Action * action ) [protected, virtual]

void LcsMainMenuWin::OnGetFocus ( ) [protected, virtual]

void LcsMainMenuWin::OnOpen ( ) [protected, virtual]

void LcsMainMenuWin::SetStatus ( INT status )

void LcsMainMenuWin::SetTime ( WString time_str )

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsMainMenuWin.hpp
  • Applications/Lcs/LcsMainMenuWin.cpp
Generated on Wed Jan 25 01:24:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsMmiQos Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsMmiQos Struct Reference

The Qos structure to be filled by user inputs. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for LcsMmiQos:

[legend]

Public Member Functions

LcsMmiQos ()
Constructor.

Data Fields

UnsignedValue m_horiz_accuracy
Stores the horizontal accuracy : mantissa = value in cm, exponent = 2.
RespTimeCategory m_rsp_time_cat
Stores response time category i.e. low-delay or delay-tolerant.
UnsignedValue m_vert_accuracy
Stores the vertical accuracy : mantissa = value in cm, exponent = 2.

Detailed Description

The Qos structure to be filled by user inputs.

Constructor & Destructor Documentation

LcsMmiQos::LcsMmiQos ( ) [inline]

Constructor.

Field Documentation

UnsignedValue LcsMmiQos::m_horiz_accuracy

Stores the horizontal accuracy : mantissa = value in cm, exponent = 2.

RespTimeCategory LcsMmiQos::m_rsp_time_cat

Stores response time category i.e. low-delay or delay-tolerant.

UnsignedValue LcsMmiQos::m_vert_accuracy

Stores the vertical accuracy : mantissa = value in cm, exponent = 2.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:24:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsMolrResultArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsMolrResultArg Class Reference

#include <Apoxi/AddOns/Lcs/3GPP/LcsArgs.hpp>

Inheritance diagram for LcsMolrResultArg:

[legend]
Collaboration diagram for LcsMolrResultArg:

[legend]

Public Types

enum | { ID = 4216 }

Public Member Functions

const LocationEstimate & | GetLocationEstimate () const
BYTE | GetTiPd () const
LcsMolrResultArg ()
LcsMolrResultArg (BYTE ti_pd, const LocationEstimate &location_estimate)
~LcsMolrResultArg ()

Static Public Member Functions

static const LcsMolrResultArg & | Cast (const StackMsgArgument &arg)

Friends

class | LcsStackMsgArgsDestroyTableNode

Detailed Description

This argument is sent to the MMI application to deliver a MO-LR result

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LcsMolrResultArg::LcsMolrResultArg | ( | BYTE | ti_pd,
 |  | const LocationEstimate & | location_estimate
 | ) |

LcsMolrResultArg::LcsMolrResultArg ( )

LcsMolrResultArg::~LcsMolrResultArg ( )

Member Function Documentation

const LcsMolrResultArg & LcsMolrResultArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const LocationEstimate& LcsMolrResultArg::GetLocationEstimate ( ) const [inline]

BYTE LcsMolrResultArg::GetTiPd ( ) const [inline]

Friends And Related Function Documentation

friend class LcsStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/3GPP/LcsArgs.hpp
  • AddOns/Lcs/3GPP/LcsArgs.cpp
Generated on Wed Jan 25 01:24:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsMsgProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsMsgProcessor Class Reference

Forms SDL signal from the parameters sent and sends it to MN. More...

#include <Apoxi/AddOns/Lcs/3GPP/LcsMsgProcessor.hpp>

Inheritance diagram for LcsMsgProcessor:

[legend]
Collaboration diagram for LcsMsgProcessor:

[legend]

Static Public Member Functions

static void | ProcessMolrReq (TI_PD ti_pd, MolrType molr_type, LocationMethod location_method, const LcsQos &lcs_qos, const ClientId &client_id, const MlcNumber &mlc_number)
Forms and sends MN_SS_LCS_MOLR_REQ SDL signal to Lcs stack.
static void | ProcessVerifResp (TI_PD ti_pd, VerificationResponse verif_resp)
Forms and sends MN_SS_LCS_MTLR_REQ SDL signal to Lcs stack.

Detailed Description

Forms SDL signal from the parameters sent and sends it to MN.

Member Function Documentation

void LcsMsgProcessor::ProcessMolrReq | ( | TI_PD | ti_pd,
 |  | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsQos & | lcs_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number
 | ) | [static]

Forms and sends MN_SS_LCS_MOLR_REQ SDL signal to Lcs stack.

void LcsMsgProcessor::ProcessVerifResp | ( | TI_PD | ti_pd,
 |  | VerificationResponse | verif_resp
 | ) | [static]

Forms and sends MN_SS_LCS_MTLR_REQ SDL signal to Lcs stack.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/3GPP/LcsMsgProcessor.hpp
  • AddOns/Lcs/3GPP/LcsMsgProcessor.cpp
Generated on Wed Jan 25 01:24:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsOptionsMenuWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsOptionsMenuWin Class Reference

#include <Applications/Lcs/LcsOptionsMenuWin.hpp>

Collaboration diagram for LcsOptionsMenuWin:

[legend]

Public Member Functions

void | Init ()
LcsOptionsMenuWin ()
Constructor.
void | SetStatus (INT status)
void | SetTime (WString time_str)
virtual | ~LcsOptionsMenuWin ()
Destructor.

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual void | OnOpen ()

Detailed Description

Class for Lcs Options. This window displays the following options: 1. Self Location 2. Transfer Location On selecting one of the options, the corresponding functionality is invoked

Constructor & Destructor Documentation

LcsOptionsMenuWin::LcsOptionsMenuWin ( )

Constructor.

LcsOptionsMenuWin::~LcsOptionsMenuWin ( ) [virtual]

Destructor.

Member Function Documentation

void LcsOptionsMenuWin::Init ( )

void LcsOptionsMenuWin::OnActionExecuted ( Action * action ) [protected, virtual]

void LcsOptionsMenuWin::OnOpen ( ) [protected, virtual]

void LcsOptionsMenuWin::SetStatus ( INT status )

void LcsOptionsMenuWin::SetTime ( WString time_str )

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsOptionsMenuWin.hpp
  • Applications/Lcs/LcsOptionsMenuWin.cpp
Generated on Wed Jan 25 01:24:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsPoint Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsPoint Struct Reference

Stores location estimate in 'point' format. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for LcsPoint:

[legend]

Data Fields

SignedValue m_latitude
Latitude in degrees.
SignedValue m_longitude
Longitude in degrees.

Detailed Description

Stores location estimate in 'point' format.

Field Documentation

SignedValue LcsPoint::m_latitude

Latitude in degrees.

SignedValue LcsPoint::m_longitude

Longitude in degrees.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:24:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsPointAltitudeUncertEllipsoid Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsPointAltitudeUncertEllipsoid Struct Reference

Stores location estimate in 'point' format with uncertainty of type 'ellpsoid'. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for LcsPointAltitudeUncertEllipsoid:

[legend]

Data Fields

SignedValue m_altitude
UINT16 | m_confidence
UINT16 | m_orientation_angle
LcsPoint m_point
UnsignedValue m_semi_major_axis
UnsignedValue m_semi_minor_axis
UnsignedValue m_uncert_altitude

Detailed Description

Stores location estimate in 'point' format with uncertainty of type 'ellpsoid'.

Field Documentation

SignedValue LcsPointAltitudeUncertEllipsoid::m_altitude

UINT16 LcsPointAltitudeUncertEllipsoid::m_confidence

UINT16 LcsPointAltitudeUncertEllipsoid::m_orientation_angle

LcsPoint LcsPointAltitudeUncertEllipsoid::m_point

UnsignedValue LcsPointAltitudeUncertEllipsoid::m_semi_major_axis

UnsignedValue LcsPointAltitudeUncertEllipsoid::m_semi_minor_axis

UnsignedValue LcsPointAltitudeUncertEllipsoid::m_uncert_altitude

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:24:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsPointUncertCircle Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsPointUncertCircle Struct Reference

Stores location estimate in 'point' format with uncertainty of type 'circle'. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for LcsPointUncertCircle:

[legend]

Data Fields

LcsPoint m_point
UnsignedValue m_uncert_radius
Uncertainty radius : mantissa = value in cm, exponent = 2.

Detailed Description

Stores location estimate in 'point' format with uncertainty of type 'circle'.

Field Documentation

LcsPoint LcsPointUncertCircle::m_point

UnsignedValue LcsPointUncertCircle::m_uncert_radius

Uncertainty radius : mantissa = value in cm, exponent = 2.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:24:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsPointUncertEllipse Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsPointUncertEllipse Struct Reference

Stores location estimate in 'point' format with uncertainty of type 'ellipse'. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Collaboration diagram for LcsPointUncertEllipse:

[legend]

Data Fields

UINT16 | m_confidence
UINT16 | m_orientation_angle
LcsPoint m_point
UnsignedValue m_semi_major_axis
UnsignedValue m_semi_minor_axis

Detailed Description

Stores location estimate in 'point' format with uncertainty of type 'ellipse'.

Field Documentation

UINT16 LcsPointUncertEllipse::m_confidence

UINT16 LcsPointUncertEllipse::m_orientation_angle

LcsPoint LcsPointUncertEllipse::m_point

UnsignedValue LcsPointUncertEllipse::m_semi_major_axis

UnsignedValue LcsPointUncertEllipse::m_semi_minor_axis

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:24:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsProvider Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsProvider.hpp>

Collaboration diagram for LcsProvider:

[legend]

Public Member Functions

LcsErrorCode AbortSelfLocReq ()
This method aborts the ongoing self-location request.
LastLocationEstimate | GetLastKnownLocation () const
LcsErrorCode | RegisterForMtlr (const Application *app)
LcsErrorCode | SelfLocationReq (LcsCost lcs_cost=Low, const LcsMmiQos &lcs_mmi_qos=LcsMmiQos(), INT32 repeat_interval=-1)
LcsErrorCode | SendVerificationResult (UINT16 invoke_id, BOOLEAN user_response)
This method sends the user's verification response to the network.
BOOLEAN | SetNmeaUartSettings (BOOLEAN nmea_switch, const NmeaUartSettings &nmea_uart_settings)
BOOLEAN | SetProtocol (LcsTransportType new_protocol)
LcsErrorCode | TransferLocationReq (const LcsMmiQos &lcs_mmi_qos, const ClientId &client_id, const MlcNumber &mlc_number, INT32 repeat_interval=-1)
~LcsProvider ()
Destructor.

Static Public Member Functions

static LcsProvider * | GetInstance ()
The only method to get the instance of this class.

Detailed Description

This is the interface class to all the Lcs Applications. It forwards the invokation to the appropriate provider implementation

Constructor & Destructor Documentation

LcsProvider::~LcsProvider ( )

Destructor.

Member Function Documentation

LcsErrorCode LcsProvider::AbortSelfLocReq ( )

This method aborts the ongoing self-location request.

LcsProvider * LcsProvider::GetInstance ( ) [static]

The only method to get the instance of this class.

LastLocationEstimate LcsProvider::GetLastKnownLocation ( ) const

This method returns the location information obtained from the last self-location request.

LcsErrorCode LcsProvider::RegisterForMtlr ( const Application * app )

This method registers the only application that should receive MT-LR notifications & send response to MT-LR verification

LcsErrorCode LcsProvider::SelfLocationReq | ( | LcsCost | lcs_cost = Low,
 |  | const LcsMmiQos & | lcs_mmi_qos = LcsMmiQos(),
 |  | INT32 | repeat_interval = -1
 | ) |

This method performs a self-location request based on the cost criteria. Repetition is possible by specifying a non-negative repeat interval.

LcsErrorCode LcsProvider::SendVerificationResult | ( | UINT16 | invoke_id,
 |  | BOOLEAN | user_response
 | ) |

This method sends the user's verification response to the network.

BOOLEAN LcsProvider::SetNmeaUartSettings | ( | BOOLEAN | nmea_switch,
 |  | const NmeaUartSettings & | nmea_uart_settings
 | ) |

This method is used to indicate whether NMEA output to the serial interface should be switched on/off. In the ON case, the new UART settings to be used can also be set.

BOOLEAN LcsProvider::SetProtocol ( LcsTransportType new_protocol )

This method is invoked when another protocol is set active via the Lcs settings menu. This method should be invoked only by the Lcs settings application.

LcsErrorCode LcsProvider::TransferLocationReq | ( | const LcsMmiQos & | lcs_mmi_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number,
 |  | INT32 | repeat_interval = -1
 | ) |

This method transfers the location information of the MS to an external LCS client via a particular GMLC, if possible.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsProvider.hpp
  • AddOns/Lcs/Common/LcsProvider.cpp
Generated on Wed Jan 25 01:24:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsProviderImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsProviderImpl Class Reference

This class implements the 3GPP protocol specific methods. More...

#include <Apoxi/AddOns/Lcs/3GPP/LcsProviderImpl.hpp>

Inheritance diagram for LcsProviderImpl:

[legend]
Collaboration diagram for LcsProviderImpl:

[legend]

Public Member Functions

virtual void | Init ()
This method performs necessary initialization.
virtual void | OnTimeOut (LcsTimerType timer_type)
Invoked whenever the MT-LR or MO-LR timer expires.
void | SendEndReq ()
This method sends an End request to Lcs stack to end the transaction.
virtual LcsErrorCode | SendVerificationResult (UINT16 invoke_id, BOOLEAN user_response)
This method sends the user's verification response to the network.
virtual LcsErrorCode | TransferLocationReq (MolrType molr_type, LocationMethod location_method, const LcsMmiQos &lcs_mmi_qos, const ClientId &client_id, const MlcNumber &mlc_number, INT32 repeat_interval)
virtual | ~LcsProviderImpl ()
Destructor.

Static Public Member Functions

static LcsProviderImpl * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()
The only method to release the instance of this class.

Protected Member Functions

virtual BOOLEAN | OnAbortResponse (const StackMsgArgument &arg)
Receives the abort response message.
BOOLEAN | OnLocationNotifInvoke (const StackMsgArgument &arg)
Receives the MT-LR notification.
BOOLEAN | OnLocationResponse (const StackMsgArgument &arg)
Receives the MO-LR location result.
virtual BOOLEAN | OnMessage (const Message &msg)
BOOLEAN | OnSsError (const StackMsgArgument &arg)
Receives the error message.

Detailed Description

This class implements the 3GPP protocol specific methods.

Constructor & Destructor Documentation

LcsProviderImpl::~LcsProviderImpl ( ) [virtual]

Destructor.

Member Function Documentation

LcsProviderImpl * LcsProviderImpl::GetInstance ( ) [static]

The only method to get the instance of this class.

void LcsProviderImpl::Init ( ) [virtual]

This method performs necessary initialization.

Reimplemented from LcsProviderImplBase.

BOOLEAN LcsProviderImpl::OnAbortResponse ( const StackMsgArgument & arg ) [protected, virtual]

Receives the abort response message.

Reimplemented from LcsProviderImplBase.

BOOLEAN LcsProviderImpl::OnLocationNotifInvoke ( const StackMsgArgument & arg ) [protected]

Receives the MT-LR notification.

BOOLEAN LcsProviderImpl::OnLocationResponse ( const StackMsgArgument & arg ) [protected]

Receives the MO-LR location result.

BOOLEAN LcsProviderImpl::OnMessage ( const Message & msg ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Reimplemented from StackMsgDispatcher.

BOOLEAN LcsProviderImpl::OnSsError ( const StackMsgArgument & arg ) [protected]

Receives the error message.

void LcsProviderImpl::OnTimeOut ( LcsTimerType timer_type ) [virtual]

Invoked whenever the MT-LR or MO-LR timer expires.

Implements LcsProviderImplBase.

void LcsProviderImpl::ReleaseInstance ( ) [static]

The only method to release the instance of this class.

void LcsProviderImpl::SendEndReq ( )

This method sends an End request to Lcs stack to end the transaction.

LcsErrorCode LcsProviderImpl::SendVerificationResult | ( | UINT16 | invoke_id,
 |  | BOOLEAN | user_response
 | ) | [virtual]

This method sends the user's verification response to the network.

Reimplemented from LcsProviderImplBase.

LcsErrorCode LcsProviderImpl::TransferLocationReq | ( | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsMmiQos & | lcs_mmi_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number,
 |  | INT32 | repeat_interval
 | ) | [virtual]

This method sends a request to the network to transfer the user's location to another LCS client

Implements LcsProviderImplBase.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/3GPP/LcsProviderImpl.hpp
  • AddOns/Lcs/3GPP/LcsProviderImpl.cpp
Generated on Wed Jan 25 01:24:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsProviderImplBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsProviderImplBase Class Reference

The abstract base class of all the provider implementations. More...

#include <Apoxi/AddOns/Lcs/Common/LcsProviderImplBase.hpp>

Inheritance diagram for LcsProviderImplBase:

[legend]
Collaboration diagram for LcsProviderImplBase:

[legend]

Public Member Functions

LcsTransportType | GetProtocol () const
Returns the transport protocol supported by the provider implementation.
virtual void | Init ()
Initializes the concrete provider implementation.
LcsProviderImplBase (LcsTransportType protocol)
Argument Constructor.
virtual void | OnTimeOut (LcsTimerType timer_type)=0
Invoked whenever a MT-LR or MO-LR timer expires.
LcsErrorCode | SelfLocationReq (MolrType molr_type, LocationMethod location_method, const LcsMmiQos &lcs_mmi_qos, INT32 repeat_interval)
virtual LcsErrorCode | SendVerificationResult (UINT16 invoke_id, BOOLEAN user_response)
This method sends the user's verification response to the network.
BOOLEAN | SetNmeaUartSettings (BOOLEAN nmea_switch, const NmeaUartSettings &nmea_uart_settings)
Sets the UART settings in the SIO layer for NMEA data transfer.
virtual LcsErrorCode | TransferLocationReq (MolrType molr_type, LocationMethod location_method, const LcsMmiQos &lcs_mmi_qos, const ClientId &client_id, const MlcNumber &mlc_number, INT32 repeat_interval)=0
This method sends a transfer-location request to the network.
virtual | ~LcsProviderImplBase ()
Destructor.

Static Public Member Functions

static LcsErrorCode | AbortSelfLocReq ()
static LastLocationEstimate | GetLastKnownLocation ()
This method returns the result (location estimate) of the most recent MO-LR.
static LcsErrorCode | RegisterForMtlr (const Application *app)

Protected Member Functions

virtual BOOLEAN | OnAbortResponse (const StackMsgArgument &arg)
Receives the abort response message.
void | SendNmeaData ()
Forms & sends NMEA sentences to the serial interface.

Protected Attributes

LcsTimer m_molr_timer
Timer for the ongoing MO-LR.

Static Protected Attributes

static LastLocationEstimate | m_last_loc_est
The most recent location estimate.
static Application * | m_mtlr_app = NULL
The application that has registered for MT-LR notifications.

Detailed Description

The abstract base class of all the provider implementations.

Constructor & Destructor Documentation

LcsProviderImplBase::LcsProviderImplBase ( LcsTransportType protocol ) [explicit]

Argument Constructor.

LcsProviderImplBase::~LcsProviderImplBase ( ) [virtual]

Destructor.

Member Function Documentation

LcsErrorCode LcsProviderImplBase::AbortSelfLocReq ( ) [static]

This method sends aborts a self-location request as follows: 1. A pending self-location request is simply removed 2. An ongoing self-location request operating in MS-based mode is aborted by sending an abort request to the Lcs stack

static LastLocationEstimate LcsProviderImplBase::GetLastKnownLocation ( ) [inline, static]

This method returns the result (location estimate) of the most recent MO-LR.

LcsTransportType LcsProviderImplBase::GetProtocol ( ) const [inline]

Returns the transport protocol supported by the provider implementation.

void LcsProviderImplBase::Init ( ) [virtual]

Initializes the concrete provider implementation.

Reimplemented in LcsProviderImpl, GltpProviderImpl, and SaProviderImpl.

BOOLEAN LcsProviderImplBase::OnAbortResponse ( const StackMsgArgument & arg ) [protected, virtual]

Receives the abort response message.

Reimplemented in LcsProviderImpl, GltpProviderImpl, and SaProviderImpl.

virtual void LcsProviderImplBase::OnTimeOut ( LcsTimerType timer_type ) [pure virtual]

Invoked whenever a MT-LR or MO-LR timer expires.

Implemented in LcsProviderImpl, GltpProviderImpl, and SaProviderImpl.

LcsErrorCode LcsProviderImplBase::RegisterForMtlr ( const Application * app ) [static]

This methos is invoked when an application wants to register for receiving MTLR notifications

LcsErrorCode LcsProviderImplBase::SelfLocationReq | ( | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsMmiQos & | lcs_mmi_qos,
 |  | INT32 | repeat_interval
 | ) |

This method forms a self-location request to be processed by the request processor

void LcsProviderImplBase::SendNmeaData ( ) [protected]

Forms & sends NMEA sentences to the serial interface.

LcsErrorCode LcsProviderImplBase::SendVerificationResult | ( | UINT16 | invoke_id,
 |  | BOOLEAN | user_response
 | ) | [virtual]

This method sends the user's verification response to the network.

Reimplemented in LcsProviderImpl.

BOOLEAN LcsProviderImplBase::SetNmeaUartSettings | ( | BOOLEAN | nmea_switch,
 |  | const NmeaUartSettings & | nmea_uart_settings
 | ) |

Sets the UART settings in the SIO layer for NMEA data transfer.

virtual LcsErrorCode LcsProviderImplBase::TransferLocationReq | ( | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsMmiQos & | lcs_mmi_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number,
 |  | INT32 | repeat_interval
 | ) | [pure virtual]

This method sends a transfer-location request to the network.

Implemented in LcsProviderImpl, GltpProviderImpl, and SaProviderImpl.

Field Documentation

LastLocationEstimate LcsProviderImplBase::m_last_loc_est [static, protected]

The most recent location estimate.

LcsTimer LcsProviderImplBase::m_molr_timer [protected]

Timer for the ongoing MO-LR.

Application * LcsProviderImplBase::m_mtlr_app = NULL [static, protected]

The application that has registered for MT-LR notifications.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsProviderImplBase.hpp
  • AddOns/Lcs/Common/LcsProviderImplBase.cpp
Generated on Wed Jan 25 01:24:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsQos Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsQos Struct Reference

Structure containing the Qos in the format required to fill in the SDL signal. More...

#include <Apoxi/AddOns/Lcs/Common/LcsDecls.hpp>

Data Fields

BYTE | m_horiz_accuracy
Stores the horizontal accuracy k-value.
RespTimeCategory m_rsp_time_cat
Stores response time category i.e., low-delay or delay-tolerant.
BYTE | m_vert_accuracy
Stores the vertical accuracy k-value.

Detailed Description

Structure containing the Qos in the format required to fill in the SDL signal.

Field Documentation

BYTE LcsQos::m_horiz_accuracy

Stores the horizontal accuracy k-value.

RespTimeCategory LcsQos::m_rsp_time_cat

Stores response time category i.e., low-delay or delay-tolerant.

BYTE LcsQos::m_vert_accuracy

Stores the vertical accuracy k-value.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsDecls.hpp
Generated on Wed Jan 25 01:24:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsRepeatTimer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsRepeatTimer Class Reference

Timer used for repeated self location requests. More...

#include <Apoxi/AddOns/Lcs/Common/LcsRepeatTimer.hpp>

Inheritance diagram for LcsRepeatTimer:

[legend]
Collaboration diagram for LcsRepeatTimer:

[legend]

Public Member Functions

void | Init (UINT16 invoke_id, UINT32 timeout, BOOLEAN autotimer=FALSE)
LcsRepeatTimer ()
Constructor.
void | Start ()
virtual | ~LcsRepeatTimer ()
Destructor.

Protected Member Functions

virtual void | OnTimer ()
Invoked when timer times out.

Detailed Description

Timer used for repeated self location requests.

Constructor & Destructor Documentation

LcsRepeatTimer::LcsRepeatTimer ( )

Constructor.

LcsRepeatTimer::~LcsRepeatTimer ( ) [virtual]

Destructor.

Member Function Documentation

void LcsRepeatTimer::Init | ( | UINT16 | invoke_id,
 |  | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

void LcsRepeatTimer::OnTimer ( ) [protected, virtual]

Invoked when timer times out.

Reimplemented from Timer.

void LcsRepeatTimer::Start ( )

Starts the timer.

Reimplemented from Timer.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsRepeatTimer.hpp
  • AddOns/Lcs/Common/LcsRepeatTimer.cpp
Generated on Wed Jan 25 01:24:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsReqProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsReqProcessor Class Reference

The centralized storage for MO-LR and MT-LR requests from all providers. More...

#include <Apoxi/AddOns/Lcs/Common/LcsReqProcessor.hpp>

Collaboration diagram for LcsReqProcessor:

[legend]

Public Member Functions

MolrInfo * | GetMolr () const
This method returns the 1st MO-LR in the store.
MolrStatus | GetMolrStatus (Application *app)
MtlrInfo * GetMtlr ()
This method removes & returns the foremost MT-LR.
void | MolrProcessed (BOOLEAN remove_molr=FALSE)
void | OnRepMolrTimeOut (UINT16 invoke_id)
This method is invoked whenever the timer of a repeated MO-LR expires.
void | RemoveMolr (Application *app)
This method removes the corresponding MO-LR from the store.
BOOLEAN | RequestExists (const LcsProviderImplBase *prov_impl) const
This method checks whether any MO-LR or MT-LR exists for this provider.
MtlrInfo * | RetrieveMtlr (UINT16 invoke_id)
This method removes & returns the MT-LR corresponding to this invoke id.
void | StoreMolr (MolrInfo *molr_info)
This method stores the MO-LR so that it can be processed later.
void | StoreMtlr (const MtlrInfo *mtlr_info)
This method stores the MT-LR so that it can be processed later.
~LcsReqProcessor ()
Destructor.

Static Public Member Functions

static LcsReqProcessor * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()
The only method to release the instance of this class.

Detailed Description

The centralized storage for MO-LR and MT-LR requests from all providers.

Constructor & Destructor Documentation

LcsReqProcessor::~LcsReqProcessor ( )

Destructor.

Member Function Documentation

LcsReqProcessor * LcsReqProcessor::GetInstance ( ) [static]

The only method to get the instance of this class.

MolrInfo * LcsReqProcessor::GetMolr ( ) const

This method returns the 1st MO-LR in the store.

MolrStatus LcsReqProcessor::GetMolrStatus ( Application * app )

This method returns the status of the self-location request issued by this application

MtlrInfo * LcsReqProcessor::GetMtlr ( )

This method removes & returns the foremost MT-LR.

void LcsReqProcessor::MolrProcessed ( BOOLEAN remove_molr = FALSE )

This method is invoked by the provider implementations to indicate the completion of the current MO-LR. If the 'remove_molr' flag is set to TRUE, then the MO-LR is removed from the store.

void LcsReqProcessor::OnRepMolrTimeOut ( UINT16 invoke_id )

This method is invoked whenever the timer of a repeated MO-LR expires.

void LcsReqProcessor::ReleaseInstance ( ) [static]

The only method to release the instance of this class.

void LcsReqProcessor::RemoveMolr ( Application * app )

This method removes the corresponding MO-LR from the store.

BOOLEAN LcsReqProcessor::RequestExists ( const LcsProviderImplBase * prov_impl ) const

This method checks whether any MO-LR or MT-LR exists for this provider.

MtlrInfo * LcsReqProcessor::RetrieveMtlr ( UINT16 invoke_id )

This method removes & returns the MT-LR corresponding to this invoke id.

void LcsReqProcessor::StoreMolr ( MolrInfo * molr_info )

This method stores the MO-LR so that it can be processed later.

void LcsReqProcessor::StoreMtlr ( const MtlrInfo * mtlr_info )

This method stores the MT-LR so that it can be processed later.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsReqProcessor.hpp
  • AddOns/Lcs/Common/LcsReqProcessor.cpp
Generated on Wed Jan 25 01:24:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsSettingsApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsSettingsApp Class Reference

#include <Applications/LcsTransports/Settings/LcsSettingsApp.hpp>

Collaboration diagram for LcsSettingsApp:

[legend]

Public Member Functions

virtual | ~LcsSettingsApp ()
Destructor.

Static Public Member Functions

static LcsSettingsApp * | GetInstance ()
The only method to get the instance of this class.

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)
virtual void | OnStartup ()

Constructor & Destructor Documentation

LcsSettingsApp::~LcsSettingsApp ( ) [virtual]

Destructor.

Member Function Documentation

LcsSettingsApp * LcsSettingsApp::GetInstance ( ) [static]

The only method to get the instance of this class.

void LcsSettingsApp::OnClose ( ) [protected, virtual]

BOOLEAN LcsSettingsApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN LcsSettingsApp::OnMessage ( const Message & msg ) [protected, virtual]

void LcsSettingsApp::OnOpen ( ) [protected, virtual]

BOOLEAN LcsSettingsApp::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [protected, virtual]

void LcsSettingsApp::OnStartup ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/LcsTransports/Settings/LcsSettingsApp.hpp
  • Applications/LcsTransports/Settings/LcsSettingsApp.cpp
Generated on Wed Jan 25 01:24:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsSettingsUtils Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsSettingsUtils Class Reference

#include <Applications/LcsTransports/Settings/LcsSettingsUtils.hpp>

Collaboration diagram for LcsSettingsUtils:

[legend]

Public Member Functions

void | DisplayMsg (const WCHAR *str=NULL)
BOOLEAN | GetData (const CHAR *data_type, INT32 &data)
This method gets tha data from registry and returns in integer format.
BOOLEAN | GetData (const CHAR *data_type, WString &data)
This method gets tha data from registry and returns in string format.
BOOLEAN | StoreData (const CHAR *data_type, INT32 data) const
This method takes the data in integer format and stores it in registry.
BOOLEAN | StoreData (const CHAR *data_type, const WString &data) const
This method takes the data in string format and stores it in registry.
~LcsSettingsUtils ()
Destructor.

Static Public Member Functions

static LcsSettingsUtils * | GetInstance ()
static void | ReleaseInstance ()

Detailed Description

This class implements functionalities which are common to lcs settings application

Constructor & Destructor Documentation

LcsSettingsUtils::~LcsSettingsUtils ( )

Destructor.

Member Function Documentation

void LcsSettingsUtils::DisplayMsg ( const WCHAR * str = NULL )

BOOLEAN LcsSettingsUtils::GetData | ( | const CHAR * | data_type,
 |  | INT32 & | data
 | ) |

This method gets tha data from registry and returns in integer format.

BOOLEAN LcsSettingsUtils::GetData | ( | const CHAR * | data_type,
 |  | WString & | data
 | ) |

This method gets tha data from registry and returns in string format.

LcsSettingsUtils * LcsSettingsUtils::GetInstance ( ) [static]

void LcsSettingsUtils::ReleaseInstance ( ) [static]

BOOLEAN LcsSettingsUtils::StoreData | ( | const CHAR * | data_type,
 |  | INT32 | data
 | ) | const

This method takes the data in integer format and stores it in registry.

BOOLEAN LcsSettingsUtils::StoreData | ( | const CHAR * | data_type,
 |  | const WString & | data
 | ) | const

This method takes the data in string format and stores it in registry.

The documentation for this class was generated from the following files:
  • Applications/LcsTransports/Settings/LcsSettingsUtils.hpp
  • Applications/LcsTransports/Settings/LcsSettingsUtils.cpp
Generated on Wed Jan 25 01:24:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsSignalMapTableNode Class Reference

#include <Apoxi/AddOns/Lcs/3GPP/LcsSignalMapTableNode.hpp>

Inheritance diagram for LcsSignalMapTableNode:

[legend]
Collaboration diagram for LcsSignalMapTableNode:

[legend]

Public Member Functions

~LcsSignalMapTableNode ()
Destructor.

Static Public Member Functions

static LcsSignalMapTableNode * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()

Detailed Description

Receives the LCS-related SDL signals and invokes the corresponding callback The base class's constructor registers itself with the SignalMapTable. This code is based on similar classes, such as CommonSignalMapTableNode and GprsSignalMapTableNode.

Constructor & Destructor Documentation

LcsSignalMapTableNode::~LcsSignalMapTableNode ( )

Destructor.

Member Function Documentation

LcsSignalMapTableNode * LcsSignalMapTableNode::GetInstance ( ) [static]

The only method to get the instance of this class.

void LcsSignalMapTableNode::ReleaseInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/3GPP/LcsSignalMapTableNode.hpp
  • AddOns/Lcs/3GPP/LcsSignalMapTableNode.cpp
Generated on Wed Jan 25 01:24:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsSignalProcessor Class Reference

#include <Apoxi/AddOns/Lcs/3GPP/LcsSignalProcessor.hpp>

Static Public Member Functions

static void | PostMolrResult (const ProcessPtr &process_ptr)
static void | PostMtlrIndReceived (const ProcessPtr &process_ptr)

Detailed Description

This class generates (and posts) APOXI messages corresponding to the incoming LCS-related SDL signals

Member Function Documentation

void LcsSignalProcessor::PostMolrResult ( const ProcessPtr & process_ptr ) [static]

processes MN_SS_LCS_MOLR_IND SDL signal, forms and posts LcsMolrResultArg message to the application

void LcsSignalProcessor::PostMtlrIndReceived ( const ProcessPtr & process_ptr ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/3GPP/LcsSignalProcessor.hpp
  • AddOns/Lcs/3GPP/LcsSignalProcessor.cpp
Generated on Wed Jan 25 01:24:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsSocket Class Reference

#include <Applications/LcsTransports/GLTP/LcsSocket.hpp>

Inheritance diagram for LcsSocket:

[legend]
Collaboration diagram for LcsSocket:

[legend]

Public Member Functions

BOOLEAN | Init (DataConnProfileId prof_id)
LcsSocket ()
Constructor.
INT | Write (const void *buf, INT buflen)
~LcsSocket ()
Destructor.

Protected Member Functions

virtual void | OnAsyncEvent (Event event)
Overridden virtual methods.

Constructor & Destructor Documentation

LcsSocket::LcsSocket ( )

Constructor.

LcsSocket::~LcsSocket ( )

Destructor.

Member Function Documentation

BOOLEAN LcsSocket::Init ( DataConnProfileId prof_id )

void LcsSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Overridden virtual methods.

This method is invoked when some data is received in the socket & is available for reading

Reimplemented from InetSocket.

INT LcsSocket::Write | ( | const void * | buf,
 |  | INT | buflen
 | ) | [virtual]

Writes data to the socket.

Parameters:
buf | Pointer to write buffer.
buflen | Length of write buffer.
Returns:
Number of bytes written or -1 on failure.

Reimplemented from InetSocket.

The documentation for this class was generated from the following files:
  • Applications/LcsTransports/GLTP/LcsSocket.hpp
  • Applications/LcsTransports/GLTP/LcsSocket.cpp
Generated on Wed Jan 25 01:24:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsStackMsgArgsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsStackMsgArgsDestroyTableNode Class Reference

#include <Apoxi/AddOns/Lcs/3GPP/LcsStackMsgArgs.hpp>

Inheritance diagram for LcsStackMsgArgsDestroyTableNode:

[legend]
Collaboration diagram for LcsStackMsgArgsDestroyTableNode:

[legend]

Static Public Member Functions

static LcsStackMsgArgsDestroyTableNode * GetInstance ()

Member Function Documentation

LcsStackMsgArgsDestroyTableNode * LcsStackMsgArgsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/3GPP/LcsStackMsgArgs.hpp
  • AddOns/Lcs/3GPP/LcsStackMsgArgs.cpp
Generated on Wed Jan 25 01:24:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsTimer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsTimer Class Reference

Timer class for MO-LR and MT-LR request timeouts. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTimer.hpp>

Inheritance diagram for LcsTimer:

[legend]
Collaboration diagram for LcsTimer:

[legend]

Public Member Functions

void | Init (LcsTimerType timer_type, UINT32 timeout, const LcsProviderImplBase *provider, BOOLEAN autotimer=FALSE)
LcsTimer ()
Constructor.
void | Start ()
virtual | ~LcsTimer ()
Destructor.

Protected Member Functions

virtual void | OnTimer ()

Detailed Description

Timer class for MO-LR and MT-LR request timeouts.

Constructor & Destructor Documentation

LcsTimer::LcsTimer ( )

Constructor.

LcsTimer::~LcsTimer ( ) [virtual]

Destructor.

Member Function Documentation

void LcsTimer::Init | ( | LcsTimerType | timer_type,
 |  | UINT32 | timeout,
 |  | const LcsProviderImplBase * | provider,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

void LcsTimer::OnTimer ( ) [protected, virtual]

Is called, if the timout-value of the timer expired. In the default implementation of this method the message TimerTimeoutMsg is sent.

Reimplemented from Timer.

void LcsTimer::Start ( )

Starts the timer.

Reimplemented from Timer.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsTimer.hpp
  • AddOns/Lcs/Common/LcsTimer.cpp
Generated on Wed Jan 25 01:24:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsUtils Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsUtils Class Reference

This is a utility Class,used by all providers for miscellaneous operations. More...

#include <Apoxi/AddOns/Lcs/Common/LcsUtils.hpp>

Collaboration diagram for LcsUtils:

[legend]

Public Member Functions

void | DecodeAltitude (SignedValue &actual_altitude) const
UINT16 | DecodeAngle (UINT8 angle) const
Formula: 2N <= angle value < 2(N + 1) ==> angle value = (2N + 2(N + 1)) / 2.
UINT32 | DecodeInnerRadius (UINT16 inner_radius) const
Formula: 5N <= r < 5(N + 1).
void | DecodeLatitude (UINT32 coded_latitude, SignedValue &actual_latitude) const
void | DecodeLocEstimate (LocationEstimate &loc_estimate) const
void | DecodeLongitude (UINT32 coded_longitude, SignedValue &actual_longitude) const
void | DecodeUncertAltitude (UINT8 k_value, UnsignedValue &uncert_altitude) const
UnsignedValue | DecodeUncertRadius (UINT8 k_value) const
UINT8 | EncodeUncertRadius (const UnsignedValue &uncert_radius) const
void | FormQos (const LcsMmiQos &lcs_mmi_qos, LcsQos &lcs_qos) const
void | GpsToUtcTime (UINT16 gps_week, UINT32 gps_tow, UtcTime &utc_time)
Constructs time in UTC format from the given GPS time (GPS-Week + GPS-ToW).
INT32 | Power (INT16 number, UINT8 exponent)
~LcsUtils ()
Destructor.

Static Public Member Functions

static LcsUtils * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()

Detailed Description

This is a utility Class,used by all providers for miscellaneous operations.

Constructor & Destructor Documentation

LcsUtils::~LcsUtils ( )

Destructor.

Member Function Documentation

void LcsUtils::DecodeAltitude ( SignedValue & actual_altitude ) const

UINT16 LcsUtils::DecodeAngle ( UINT8 angle ) const [inline]

Formula: 2N <= angle value < 2(N + 1) ==> angle value = (2N + 2(N + 1)) / 2.

UINT32 LcsUtils::DecodeInnerRadius ( UINT16 inner_radius ) const [inline]

Formula: 5N <= r < 5(N + 1).

void LcsUtils::DecodeLatitude | ( | UINT32 | coded_latitude,
 |  | SignedValue & | actual_latitude
 | ) | const

void LcsUtils::DecodeLocEstimate ( LocationEstimate & loc_estimate ) const

void LcsUtils::DecodeLongitude | ( | UINT32 | coded_longitude,
 |  | SignedValue & | actual_longitude
 | ) | const

void LcsUtils::DecodeUncertAltitude | ( | UINT8 | k_value,
 |  | UnsignedValue & | uncert_altitude
 | ) | const

UnsignedValue LcsUtils::DecodeUncertRadius ( UINT8 k_value ) const [inline]

UINT8 LcsUtils::EncodeUncertRadius ( const UnsignedValue & uncert_radius ) const

void LcsUtils::FormQos | ( | const LcsMmiQos & | lcs_mmi_qos,
 |  | LcsQos & | lcs_qos
 | ) | const

LcsUtils * LcsUtils::GetInstance ( ) [static]

The only method to get the instance of this class.

void LcsUtils::GpsToUtcTime | ( | UINT16 | gps_week,
 |  | UINT32 | gps_tow,
 |  | UtcTime & | utc_time
 | ) |

Constructs time in UTC format from the given GPS time (GPS-Week + GPS-ToW).

INT32 LcsUtils::Power | ( | INT16 | number,
 |  | UINT8 | exponent
 | ) |

Computes the formula: number ^ exponent i.e., Raises the number to the power of the exponent Values of number & exponent should be such that the power doesn't exceed the range of an INT32, a 32-bit integer

void LcsUtils::ReleaseInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsUtils.hpp
  • AddOns/Lcs/Common/LcsUtils.cpp
Generated on Wed Jan 25 01:24:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsWapIntf Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsWapIntf Class Reference

#include <Applications/Lcs/LcsWapIntf.hpp>

Collaboration diagram for LcsWapIntf:

[legend]

Public Member Functions

BOOLEAN | DisplayMap (BOOLEAN feature_wai)
BOOLEAN | IsBrowserOpen ()
BOOLEAN | IsDispMapAllowed ()
void | SetBrowserOpen (BOOLEAN is_open)
void | SetDispMapAllowed (BOOLEAN is_disp_allowed)
~LcsWapIntf ()
Destructor.

Static Public Member Functions

static LcsWapIntf * | GetInstance ()
static void | ReleaseInstance ()

Detailed Description

This class is the interface to the WAP application.All Lcs Applications should use this interface

Constructor & Destructor Documentation

LcsWapIntf::~LcsWapIntf ( )

Destructor.

Member Function Documentation

BOOLEAN LcsWapIntf::DisplayMap ( BOOLEAN feature_wai )

LcsWapIntf * LcsWapIntf::GetInstance ( ) [static]

BOOLEAN LcsWapIntf::IsBrowserOpen ( ) [inline]

BOOLEAN LcsWapIntf::IsDispMapAllowed ( ) [inline]

void LcsWapIntf::ReleaseInstance ( ) [static]

void LcsWapIntf::SetBrowserOpen ( BOOLEAN is_open ) [inline]

void LcsWapIntf::SetDispMapAllowed ( BOOLEAN is_disp_allowed ) [inline]

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsWapIntf.hpp
  • Applications/Lcs/LcsWapIntf.cpp
Generated on Wed Jan 25 01:24:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LcsWString Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LcsWString Class Reference

#include <Applications/Lcs/LcsWString.hpp>

Inheritance diagram for LcsWString:

[legend]
Collaboration diagram for LcsWString:

[legend]

Public Member Functions

void | ConvertToBcd (BYTE *type, INT size)
LcsWString (const WString &rhs)
Copy Constructor.
LcsWString ()
Constructor.
operator INT32 () const
operator UINT32 () const
LcsWString & | operator<< (const ClientName &client_name)
LcsWString & | operator<< (const ClientId &client_id)
LcsWString & | operator<< (UINT16 invoke_id)
LcsWString & | operator<< (const CHAR *rhs)
Concatenates zero terminated CHAR right to the object. Repetitive use is possible (a << b << c).
LcsWString & | operator= (const WString &rhs)
Assigns a new value to the wstring object.
~LcsWString ()
Destructor.

Constructor & Destructor Documentation

LcsWString::LcsWString ( )

Constructor.

LcsWString::LcsWString ( const WString & rhs )

Copy Constructor.

LcsWString::~LcsWString ( )

Destructor.

Member Function Documentation

void LcsWString::ConvertToBcd | ( | BYTE * | type,
 |  | INT | size
 | ) |

LcsWString::operator INT32 ( ) const

LcsWString::operator UINT32 ( ) const

LcsWString & LcsWString::operator<< ( const ClientName & client_name )

LcsWString & LcsWString::operator<< ( const ClientId & client_id )

LcsWString & LcsWString::operator<< ( UINT16 invoke_id )

LcsWString & LcsWString::operator<< ( const CHAR * rhs )

Concatenates zero terminated CHAR right to the object. Repetitive use is possible (a << b << c).

Reimplemented from WString.

LcsWString & LcsWString::operator= ( const WString & rhs )

Assigns a new value to the wstring object.

Reimplemented from WString.

The documentation for this class was generated from the following files:
  • Applications/Lcs/LcsWString.hpp
  • Applications/Lcs/LcsWString.cpp
Generated on Wed Jan 25 01:24:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Led Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Led Class Reference
[Devices]

Back light device. More...

#include <Apoxi/Devices/BP30/Led.hpp>

Inheritance diagram for Led:

[legend]
Collaboration diagram for Led:

[legend]

Public Types

enum | Notification { StreamFinished, StreamStopped, StreamError }
enum | Peripheral { Keyboard = 0x01, Display = 0x02, InService = 0x04, All = (Keyboard | Display | InService) }

Public Member Functions

virtual const WCHAR * | GetName () const
virtual | ~Led ()

Static Public Member Functions

static BOOLEAN | ChangeColor (Peripheral peripheral, Color color)
static BOOLEAN | ColorStream (Peripheral peripheral, const Stream *stream, INT sequence_id=0)
static BOOLEAN | MusicMode (Peripheral peripheral, BOOLEAN on)
static BOOLEAN | Off (Peripheral peripheral, UINT32 fading_time)
static BOOLEAN | On (Peripheral peripheral, Frame frame)
static void | Reset ()

Protected Member Functions

virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()

Data Structures

struct | Color
struct | Frame
struct | Stream
struct | StreamField

Detailed Description

Back light device.

Led is the APOXI device abstraction interface for LED hardware driver.

Member Enumeration Documentation

enum Led::Notification

This information is part of LedNotificationMsg.

Enumerator:
StreamFinished
StreamStopped | LED streaming has finished.
StreamError | An error occurred while streaming.

enum Led::Peripheral

Defines all available LED's in a bit field.

Enumerator:
Keyboard
Display
InService
All

Constructor & Destructor Documentation

Led::~Led ( ) [virtual]

Member Function Documentation

BOOLEAN Led::ChangeColor | ( | Peripheral | peripheral,
 |  | Color | color
 | ) | [static]

Is used to change the color immediately for all LED's defined by parameter peripheral.

BOOLEAN Led::ColorStream | ( | Peripheral | peripheral,
 |  | const Stream * | stream,
 |  | INT | sequence_id = 0
 | ) | [static]

Starts a color stream with specific timing parameters for each color. See Led::Stream.

Parameters:
sequence_id Is passed via LedNotificationMsg.

const WCHAR * Led::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

BOOLEAN Led::MusicMode | ( | Peripheral | peripheral,
 |  | BOOLEAN | on
 | ) | [static]

Starts or stops the music mode for the LED.

BOOLEAN Led::Off | ( | Peripheral | peripheral,
 |  | UINT32 | fading_time
 | ) | [static]

Turns off all LED's defined by parameter peripheral.

BOOLEAN Led::On | ( | Peripheral | peripheral,
 |  | Frame | frame
 | ) | [static]

Turns on all LED's defined by parameter peripheral using the Frame sequence.

virtual void Led::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

virtual void Led::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

virtual void Led::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

virtual void Led::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

void Led::OnStart ( ) [protected, virtual]

Is invoked by the DeviceManager when the system is started. The device must attach itself to the DeviceManager by invoking DeviceManager::AddDevice(*this) in its constructor.

Reimplemented from AbstractDevice.

void Led::Reset ( ) [static]

Turns off all LED's immediately.

The documentation for this class was generated from the following files:
  • Devices/BP30/Led.hpp
  • Devices/LedInterface.hpp
  • Devices/MPE/Led.hpp
  • Devices/MPEU/Led.hpp
  • Devices/SGold/Led.hpp
  • Devices/Win32/Led.hpp
  • Devices/BP30/Led.cpp
  • Devices/MPE/Led.cpp
  • Devices/MPEU/Led.cpp
  • Devices/SGold/Led.cpp
  • Devices/Win32/Led.cpp
Generated on Wed Jan 25 01:24:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Led::Color Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Led::Color

Led::Color Struct Reference

#include <Apoxi/Devices/LedInterface.hpp>

Data Fields

UINT8 | blue
UINT8 | green
UINT8 | red

Field Documentation

UINT8 Led::Color::blue

value for color green 0..255

UINT8 Led::Color::green

value for color red 0..255

UINT8 Led::Color::red

The documentation for this struct was generated from the following file:
  • Devices/LedInterface.hpp
Generated on Wed Jan 25 01:24:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Led::Frame Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Led::Frame

Led::Frame Struct Reference

#include <Apoxi/Devices/LedInterface.hpp>

Collaboration diagram for Led::Frame:

[legend]

Data Fields

Color color
UINT16 | iterations
UINT32 | on_time
UINT32 | total_time

Detailed Description

Struct Frame defines a frame for method Led::On().

Field Documentation

Color Led::Frame::color

UINT16 Led::Frame::iterations

frame duration, total_time - on_time = pause

UINT32 Led::Frame::on_time

UINT32 Led::Frame::total_time

in milliseconds

The documentation for this struct was generated from the following file:
  • Devices/LedInterface.hpp
Generated on Wed Jan 25 01:24:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Led::Stream Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Led::Stream

Led::Stream Struct Reference

#include <Apoxi/Devices/LedInterface.hpp>

Collaboration diagram for Led::Stream:

[legend]

Data Fields

UINT16 | iterations
UINT8 | length
const StreamField * | stream_field

Detailed Description

Struct Stream defines the whole color stream.

Field Documentation

UINT16 Led::Stream::iterations

length of the entire StreamField array (max.10)

UINT8 Led::Stream::length

pointer to the StreamField array

const StreamField* Led::Stream::stream_field

The documentation for this struct was generated from the following file:
  • Devices/LedInterface.hpp
Generated on Wed Jan 25 01:24:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Led::StreamField Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Led::StreamField

Led::StreamField Struct Reference

#include <Apoxi/Devices/LedInterface.hpp>

Collaboration diagram for Led::StreamField:

[legend]

Data Fields

Color fading_color
Frame frame

Detailed Description

Struct StreamField holds the Frame data and the fading color for the frame.

Field Documentation

Color Led::StreamField::fading_color

Frame Led::StreamField::frame

The documentation for this struct was generated from the following file:
  • Devices/LedInterface.hpp
Generated on Wed Jan 25 01:24:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LedNotificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LedNotificationMsg Class Reference

#include <Apoxi/Devices/LedMsgTypes.hpp>

Inheritance diagram for LedNotificationMsg:

[legend]
Collaboration diagram for LedNotificationMsg:

[legend]

Public Types

enum | { ID = 9070 }

Public Member Functions

virtual Message * | Clone () const
INT | GetLedId () const
virtual const MsgMetaData & | GetMetaData () const
const Led::Notification & | GetNotification () const
INT | GetSequenceId () const
LedNotificationMsg (INT led_id, INT sequence_id, const Led::Notification &notification)
virtual | ~LedNotificationMsg ()

Detailed Description

LedNotificationMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LedNotificationMsg::LedNotificationMsg | ( | INT | led_id,
 |  | INT | sequence_id,
 |  | const Led::Notification & | notification
 | ) |

LedNotificationMsg::~LedNotificationMsg ( ) [virtual]

Member Function Documentation

Message * LedNotificationMsg::Clone ( ) const [virtual]

Implements Message.

INT LedNotificationMsg::GetLedId ( ) const [inline]

const MsgMetaData & LedNotificationMsg::GetMetaData ( ) const [virtual]

Implements Message.

const Led::Notification& LedNotificationMsg::GetNotification ( ) const [inline]

INT LedNotificationMsg::GetSequenceId ( ) const [inline]

The documentation for this class was generated from the following files:
  • Devices/LedMsgTypes.hpp
  • Devices/LedMsgTypes.cpp
Generated on Wed Jan 25 01:24:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LedSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LedSignalMapTableNode Class Reference

#include <Apoxi/Devices/LedSignalMapTableNode.hpp>

Inheritance diagram for LedSignalMapTableNode:

[legend]
Collaboration diagram for LedSignalMapTableNode:

[legend]

Static Public Member Functions

static LedSignalMapTableNode * GetInstance ()

Detailed Description

@addtogroup Devices

Member Function Documentation

LedSignalMapTableNode * LedSignalMapTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Devices/LedSignalMapTableNode.hpp
  • Devices/LedSignalMapTableNode.cpp
Generated on Wed Jan 25 01:24:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LedSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LedSignalProcessor Class Reference

#include <Apoxi/Devices/LedSignalProcessor.hpp>

Static Public Member Functions

static void PostLedStreamStatus (const ProcessPtr &process_ptr)

Detailed Description

@addtogroup Devices

Member Function Documentation

void LedSignalProcessor::PostLedStreamStatus ( const ProcessPtr & process_ptr ) [static]

The documentation for this class was generated from the following files:
  • Devices/LedSignalProcessor.hpp
  • Devices/LedSignalProcessor.cpp
Generated on Wed Jan 25 01:24:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LessRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LessRule Class Reference
[Auxiliary]

RangeRule checks whether data item is less than the rule item More...

#include <Apoxi/Auxiliary/FilterRule.hpp>

Inheritance diagram for LessRule:

[legend]
Collaboration diagram for LessRule:

[legend]

Public Types

typedef FilterRule | Base

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)
LessRule (const DataItem &ruleitem)
LessRule ()
virtual | ~LessRule ()

Detailed Description

RangeRule checks whether data item is less than the rule item

Member Typedef Documentation

typedef FilterRule LessRule::Base

Constructor & Destructor Documentation

LessRule::LessRule ( )

LessRule::LessRule ( const DataItem & ruleitem )

LessRule::~LessRule ( ) [virtual]

Member Function Documentation

BOOLEAN LessRule::ExecuteRule ( const DataItem & dataitem ) [virtual]

ExecuteRule does the actual comparision between the data item given in the argument and the value stored when the filter rule is constructed.

Implements FilterRule.

The documentation for this class was generated from the following files:
  • Auxiliary/FilterRule.hpp
  • Auxiliary/FilterRule.cpp
Generated on Wed Jan 25 01:24:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LexAnalyzer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LexAnalyzer Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputParser.hpp>

Collaboration diagram for LexAnalyzer:

[legend]

Public Member Functions

LexToken | GetFirstLexToken (WString &retparam)
LexToken | GetNextLexToken (WString &retparam)
void | GetRest (WString &rest)
void | JumpBack ()
LexAnalyzer (const WString &ssstring)
LexAnalyzer ()
~LexAnalyzer ()

Constructor & Destructor Documentation

LexAnalyzer::LexAnalyzer ( ) [inline]

LexAnalyzer::LexAnalyzer ( const WString & ssstring ) [explicit]

LexAnalyzer::~LexAnalyzer ( )

Member Function Documentation

LexToken LexAnalyzer::GetFirstLexToken ( WString & retparam )

LexToken LexAnalyzer::GetNextLexToken ( WString & retparam )

void LexAnalyzer::GetRest ( WString & rest )

void LexAnalyzer::JumpBack ( )

The documentation for this class was generated from the following files:
  • Asc/InputParser.hpp
  • Asc/InputParser.cpp
Generated on Wed Jan 25 01:24:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LineEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LineEditor Class Reference
[Editors]

#include <Apoxi/Gui/LineEditor.hpp>

Inheritance diagram for LineEditor:

[legend]
Collaboration diagram for LineEditor:

[legend]

Public Types

enum | { ID = 32 }

Public Member Functions

const Font & | GetFont () const
INT | GetMaxTextLength () const
const WString & | GetText () const
void | Init (Control *parent, INT input_mapper_id, const WCHAR *text=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
LineEditor (Control *parent, INT input_mapper_id, const WCHAR *text=0)
LineEditor ()
void | SetFont (const Font &font)
void | SetMaxTextLength (INT max_tex_len)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetText (const WCHAR *text)
virtual | ~LineEditor ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual XYDIM | GetDefaultHeight () const

Detailed Description

Editor for editing a text inside a horizontal scrollable line.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractLineEditor.

Constructor & Destructor Documentation

LineEditor::LineEditor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

LineEditor::LineEditor | ( | Control * | parent,
 |  | INT | input_mapper_id,
 |  | const WCHAR * | text = 0
 | ) |

Parameters:
parent | Parent control which embeds the component.
input_mapper_id | ID of the input mapper. See InputMapper::Id for details. The corresponding instance of the input mapper can be defined in EditConfig::CreateInputMapper().
text | Pointer to text, which will be copied to the internal buffer.

LineEditor::~LineEditor ( ) [virtual]

Member Function Documentation

Model * LineEditor::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

XYDIM LineEditor::GetDefaultHeight ( ) const [protected, virtual]

See also:
Component::GetDefaultHeight

Reimplemented from Component.

const Font & LineEditor::GetFont ( ) const

Returns the font of the text-editor document.

See also:
TextEditorDocument::SetFont

TextEditorDocument::GetFont

INT LineEditor::GetMaxTextLength ( ) const

Returns the maximum length of the text. -1 is returned if no maximum is given.

const WString & LineEditor::GetText ( ) const

Returns:
Reference to a WString, which represents the text of the internal buffer.

void LineEditor::Init | ( | Control * | parent,
 |  | INT | input_mapper_id,
 |  | const WCHAR * | text = 0
 | ) |

Parameters:
parent | Parent control which embeds the component.
input_mapper_id | ID of the input mapper. See InputMapper::Id for details. The corresponding instance of the input mapper can be defined in EditConfig::CreateInputMapper().
text | Pointer to text, which will be copied to the internal buffer.

BOOLEAN LineEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractLineEditor.

void LineEditor::SetFont ( const Font & font )

Sets the font of the text-editor document.

See also:
TextEditorDocument::SetFont

TextEditorDocument::GetFont

void LineEditor::SetMaxTextLength ( INT max_tex_len )

Defines the maximum length of the text. Use -1 if no maximum should be defined.

BOOLEAN LineEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractLineEditor.

void LineEditor::SetText ( const WCHAR * text )

Parameters:
text Pointer to text, which will be copied to the internal buffer.

The documentation for this class was generated from the following files:
  • Gui/LineEditor.hpp
  • Gui/LineEditor.cpp
Generated on Wed Jan 25 01:24:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Linkable< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Linkable< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Linkable.hpp>

Inheritance diagram for Linkable< T >:

[legend]
Collaboration diagram for Linkable< T >:

[legend]

Public Member Functions

T * GetNext () const
Returns a pointer to the next element of the linked list.

template<class T>
class Linkable< T >

Member Function Documentation

template<class T>
T* Linkable< T >::GetNext ( ) const [inline]

Returns a pointer to the next element of the linked list.

Reimplemented from LinkableBase.

The documentation for this class was generated from the following file:
  • Auxiliary/Linkable.hpp
Generated on Wed Jan 25 01:24:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LinkableBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LinkableBase Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Linkable.hpp>

Inheritance diagram for LinkableBase:

[legend]
Collaboration diagram for LinkableBase:

[legend]

Public Member Functions

LinkableBase * | GetNext () const
Returns a pointer to the next element of the linked list.
LinkableBase (LinkableBase *next=0)
Constructs a linkable object.
void | SetNext (LinkableBase *next)
Sets the pointer to the next element of the linked list.
virtual | ~LinkableBase ()
Destructs a linkable object.

Detailed Description

Every instance of a class derived from LinkableBase is embeddable into a linked list and provides methods for setting and getting the next element.

Constructor & Destructor Documentation

LinkableBase::LinkableBase ( LinkableBase * next = 0 )

Constructs a linkable object.

LinkableBase::~LinkableBase ( ) [virtual]

Destructs a linkable object.

Member Function Documentation

LinkableBase* LinkableBase::GetNext ( ) const [inline]

Returns a pointer to the next element of the linked list.

Reimplemented in Linkable< T >, Linkable< SharedPtr< AudioActiveReference > >, Linkable< DrmConstraint >, Linkable< Timer >, Linkable< ProviderPtr >, Linkable< MediaRefLinkable >, Linkable< PortTpdu >, Linkable< PxPhysicalCharacs >, Linkable< MtlrInfo >, Linkable< ObexHeader >, Linkable< ApoxiThread >, Linkable< SharedPtr< AudioReference > >, Linkable< AbstractAppContext >, Linkable< PxPortCharacs >, Linkable< CheckBoxItem >, Linkable< SmsSocket >, Linkable< AudioPreset >, Linkable< SharedPtr< T_obj > >, Linkable< Key >, Linkable< Hashable >, Linkable< ApplicationListEntry >, Linkable< AudioCallback >, Linkable< AudioPath >, Linkable< AudioAccessoryDetails >, Linkable< InputActionPtr >, Linkable< PlmnListEntry >, Linkable< Application >, Linkable< class MemPoolEntry >, Linkable< PortHeaderInformation >, Linkable< DispatcherAction >, Linkable< AppRoutingTableEntry >, Linkable< QueueEntry >, Linkable< ObexServerInfo >, Linkable< SimpleMapElem< TKey, TValue > >, Linkable< MainHandler >, Linkable< Tpdu >, Linkable< WapProfileInfo >, Linkable< PdpContext >, Linkable< Service >, Linkable< DrmPermission >, Linkable< RadioButtonItem >, Linkable< HandlerListEntry >, Linkable< CondListEntry >, Linkable< MessageIdentifierRange >, Linkable< PxAuthInfoCharacs >, Linkable< Threadlet >, Linkable< MenuItem >, Linkable< DataCodingSchemeRange >, Linkable< SettingsProvider >, Linkable< SharedPtr< StreamAudioReference > >, Linkable< NotificationArray >, Linkable< SimItemIdentifier >, and Linkable< MolrInfo >.

void LinkableBase::SetNext ( LinkableBase * next ) [inline]

Sets the pointer to the next element of the linked list.

The documentation for this class was generated from the following files:
  • Auxiliary/Linkable.hpp
  • Auxiliary/LinkedList.cpp
Generated on Wed Jan 25 01:25:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LinkedList< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LinkedList< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/LinkedList.hpp>

Inheritance diagram for LinkedList< T >:

[legend]
Collaboration diagram for LinkedList< T >:

[legend]

Public Member Functions

T * GetFront () const
Returns a pointer to the first element of the linked list.
LinkedList ()
LinkedList (T *elem)

Detailed Description

template<class T>
class LinkedList< T >

A LinkedList, is a linked list of pointers. Do not add the same object(-pointer) again, because this leeds to problems in linking.

Constructor & Destructor Documentation

template<class T>
LinkedList< T >::LinkedList ( T * elem ) [inline]

template<class T>
LinkedList< T >::LinkedList ( ) [inline]

Member Function Documentation

template<class T>
T* LinkedList< T >::GetFront ( ) const [inline]

Returns a pointer to the first element of the linked list.

Reimplemented from LinkedListBase.

The documentation for this class was generated from the following file:
  • Auxiliary/LinkedList.hpp
Generated on Wed Jan 25 01:25:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LinkedListBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LinkedListBase Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/LinkedList.hpp>

Inheritance diagram for LinkedListBase:

[legend]
Collaboration diagram for LinkedListBase:

[legend]

Public Member Functions

BOOLEAN | Contains (LinkableBase *elem) const
LinkableBase * | GetBack () const
LinkableBase * | GetFront () const
Returns a pointer to the first element of the linked list.
INT | GetSize () const
Returns the number of elements of the linked list.
void | Insert (LinkableBase *elem, LinkableBase *after=0)
BOOLEAN | IsEmpty () const
Returns TRUE, if the linked list is empty.
LinkedListBase (LinkableBase *elem=0)
Constructor for the linked list.
void | PopBack ()
Pops the last element from the linked list.
void | PopFront ()
Pops the first element from the linked list.
void | PushBack (LinkableBase *elem)
void | PushFront (LinkableBase *elem)
Pushs the element elem to the front of the linked list.
void | Remove (LinkableBase *elem)
Removes the element elem from the linked list.

Protected Attributes

LinkableBase * m_anchor

Detailed Description

A linked list chains a variable number of objects, which provide the two methods Type* GetNext() and SetNext(Type *next).

Constructor & Destructor Documentation

LinkedListBase::LinkedListBase ( LinkableBase * elem = 0 )

Constructor for the linked list.

Member Function Documentation

BOOLEAN LinkedListBase::Contains ( LinkableBase * elem ) const

Returns:
TRUE, if elem is in list.

LinkableBase * LinkedListBase::GetBack ( ) const

Returns a pointer to the last element of the linked list. Please note that GetBack has to iterate all elements of the linked list and thus will show bad performance in long lists.

LinkableBase* LinkedListBase::GetFront ( ) const [inline]

Returns a pointer to the first element of the linked list.

Reimplemented in ElementList< T >, SortedElementList< T >, LinkedList< T >, SortedLinkedList< T >, ElementList< MediaRefLinkable >, ElementList< InputActionPtr >, ElementList< Tpdu >, ElementList< DataCodingSchemeRange >, SortedElementList< InputActionPtr >, LinkedList< Item >, LinkedList< DrmConstraint >, LinkedList< MolrRepeatInfo >, LinkedList< PxPhysicalCharacs >, LinkedList< PortTpdu >, LinkedList< ApoxiThread >, LinkedList< MtlrInfo >, LinkedList< ObexHeader >, LinkedList< PxPortCharacs >, LinkedList< AbstractAppContext >, LinkedList< SmsSocket >, LinkedList< Key >, LinkedList< ApplicationListEntry >, LinkedList< Hashable >, LinkedList< Application >, LinkedList< QueueEntry >, LinkedList< WapProfileInfo >, LinkedList< DrmPermission >, LinkedList< CondListEntry >, LinkedList< Threadlet >, LinkedList< PxAuthInfoCharacs >, LinkedList< MolrInfo >, and LinkedList< NotificationArray >.

INT LinkedListBase::GetSize ( ) const

Returns the number of elements of the linked list.

void LinkedListBase::Insert | ( | LinkableBase * | elem,
 |  | LinkableBase * | after = 0
 | ) |

Inserts the element elem into the linked list. By default it's appended at front of the linked list. Specify the element after to insert the element element after the element after.

BOOLEAN LinkedListBase::IsEmpty ( ) const [inline]

Returns TRUE, if the linked list is empty.

void LinkedListBase::PopBack ( )

Pops the last element from the linked list.

void LinkedListBase::PopFront ( )

Pops the first element from the linked list.

void LinkedListBase::PushBack ( LinkableBase * elem )

Pushs the element elem to the back of the linked list. Please note that PushBack has to iterate all elements of the linked list and thus will show bad performance in long lists.

void LinkedListBase::PushFront ( LinkableBase * elem )

Pushs the element elem to the front of the linked list.

void LinkedListBase::Remove ( LinkableBase * elem )

Removes the element elem from the linked list.

Field Documentation

LinkableBase* LinkedListBase::m_anchor [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/LinkedList.hpp
  • Auxiliary/LinkedList.cpp
Generated on Wed Jan 25 01:25:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ListPropertyDescriptor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ListPropertyDescriptor Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Properties/ListPropertyDescriptor.hpp>

Inheritance diagram for ListPropertyDescriptor:

[legend]
Collaboration diagram for ListPropertyDescriptor:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

virtual ImageObtainer | GetIcon (INT index) const =0
virtual INT | GetItemCount () const
virtual WString | GetText (INT index) const =0
virtual DataItem | GetValue (INT index) const
virtual BOOLEAN | IsInstanceOf (const INT id) const
ListPropertyDescriptor ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
Sets its properties defined by the APOXI GUI Editor.
virtual | ~ListPropertyDescriptor ()
Destructor.

Detailed Description

Abstract class for property descriptors that describe the presentation (text and icon) for values of properties, which can adopt one value out of a list of defined values.

This class is intended to be the base class for a variety of descriptors that retrieve the list of presentations for the different property values from various sources: directly from the descriptor, from some configuration file, through some Aragon configuration, from some provider etc.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from PropertyDescriptor.

Constructor & Destructor Documentation

ListPropertyDescriptor::ListPropertyDescriptor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ListPropertyDescriptor::~ListPropertyDescriptor ( ) [virtual]

Destructor.

Member Function Documentation

virtual ImageObtainer ListPropertyDescriptor::GetIcon ( INT index ) const [pure virtual]

Returns the n-th icon for the representation of a property's value

Parameters:
index the index of the list entry

Implemented in ValueMappingPropertyDescriptor< T_Container >.

INT ListPropertyDescriptor::GetItemCount ( ) const [virtual]

Returns the number of defined values in the list of values, which the property might adopt.

Returns:
the number of defined values in the list

Reimplemented in ValueMappingPropertyDescriptor< T_Container >.

virtual WString ListPropertyDescriptor::GetText ( INT index ) const [pure virtual]

Returns the n-th text for the representation of a property's value.

Parameters:
index the index of the list entry

Implemented in ValueMappingPropertyDescriptor< T_Container >.

DataItem ListPropertyDescriptor::GetValue ( INT index ) const [virtual]

Retrieves the value for a given index.

Parameters:
index the matching value to the given index should be retrieved
Returns:
a Property's value matching the given index

Reimplemented in ValueMappingPropertyDescriptor< T_Container >.

BOOLEAN ListPropertyDescriptor::IsInstanceOf ( const INT id ) const [virtual]

Returns TRUE, if the PropertyDescriptor is an instance of the ListPropertyDescriptor-class with the ID id.

Reimplemented from PropertyDescriptor.

Reimplemented in ValueMappingPropertyDescriptor< T_Container >.

BOOLEAN ListPropertyDescriptor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Sets its properties defined by the APOXI GUI Editor.

Reimplemented from PropertyDescriptor.

Reimplemented in ValueMappingPropertyDescriptor< T_Container >.

The documentation for this class was generated from the following files:
  • Atl/Properties/ListPropertyDescriptor.hpp
  • Atl/Properties/ListPropertyDescriptor.cpp
Generated on Wed Jan 25 01:25:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LittleEndian16Bit Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LittleEndian16Bit Class Reference

Represents a 16 bit integer in little endian format. More...

#include <Apoxi/Kernel/MachType.hpp>

Inheritance diagram for LittleEndian16Bit:

[legend]

Public Member Functions

LittleEndian16Bit (const BigEndian16Bit &v)
LittleEndian16Bit (UINT16 v=0)
LittleEndian16Bit & operator= (const BigEndian16Bit &v)

Data Fields

union {
UINT16 m_uint16
struct {
UINT8 m_a
UINT8 m_b
} m_uint8
UINT8 m_uint8_ar [2]
} m_val

Detailed Description

Represents a 16 bit integer in little endian format.

Constructor & Destructor Documentation

LittleEndian16Bit::LittleEndian16Bit ( UINT16 v = 0 ) [inline]

Constructs a LittleEndian16Bit object from an unsigned 16 bit integer value in little endian format.

Parameters:
v 16 bit value in little endian format

LittleEndian16Bit::LittleEndian16Bit ( const BigEndian16Bit & v ) [inline]

Constructs a LittleEndian16Bit object from an unsigned 16 bit integer value in big endian format.

Parameters:
v 16 bit value in big endian format

Member Function Documentation

LittleEndian16Bit & LittleEndian16Bit::operator= ( const BigEndian16Bit & v ) [inline]

Assigns an unsigned an unsigned 16 bit integer value in big endian format.

Parameters:
v 16 bit value in big endian format

Reimplemented in Native16Bit.

Field Documentation

UINT8 LittleEndian16Bit::m_a

UINT8 LittleEndian16Bit::m_b

UINT16 LittleEndian16Bit::m_uint16

struct { ... } LittleEndian16Bit::m_uint8

UINT8 LittleEndian16Bit::m_uint8_ar[2]

union { ... } LittleEndian16Bit::m_val

Data union member which defines several access methods to the little endian number Byte member access (m_a, m_b) gives access to byte components in ascending order (i.e. LittleEndian16Bit(Native16Bit(0xaabb)) will result in m_a = 0xaa, m_b = 0xbb)

The documentation for this class was generated from the following file:
  • Kernel/MachType.hpp
Generated on Wed Jan 25 01:25:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LittleEndian32Bit Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LittleEndian32Bit Class Reference

Represents a 32 bit integer in big endian format. More...

#include <Apoxi/Kernel/MachType.hpp>

Inheritance diagram for LittleEndian32Bit:

[legend]

Public Member Functions

LittleEndian32Bit (const BigEndian32Bit &v)
LittleEndian32Bit (UINT32 v=0)
LittleEndian32Bit & operator= (const BigEndian32Bit &v)

Data Fields

union {
struct {
UINT16 m_a
UINT16 m_b
} m_uint16
UINT16 m_uint16_ar [2]
UINT32 m_uint32
struct {
UINT8 m_a
UINT8 m_b
UINT8 m_c
UINT8 m_d
} m_uint8
UINT8 m_uint8_ar [4]
} m_val

Detailed Description

Represents a 32 bit integer in big endian format.

Constructor & Destructor Documentation

LittleEndian32Bit::LittleEndian32Bit ( UINT32 v = 0 ) [inline]

Constructs a LittleEndian32Bit object from an unsigned 32 bit integer value in little endian format.

Parameters:
v 32 bit value in little endian format

LittleEndian32Bit::LittleEndian32Bit ( const BigEndian32Bit & v ) [inline]

Constructs a LittleEndian32Bit object from an unsigned 32 bit integer value in big endian format.

Parameters:
v 32 bit value in big endian format

Member Function Documentation

LittleEndian32Bit & LittleEndian32Bit::operator= ( const BigEndian32Bit & v ) [inline]

Assigns an unsigned an unsigned 32 bit integer value in big endian format.

Parameters:
v 32 bit value in big endian format

Reimplemented in Native32Bit.

Field Documentation

UINT16 LittleEndian32Bit::m_a

UINT8 LittleEndian32Bit::m_a

UINT16 LittleEndian32Bit::m_b

UINT8 LittleEndian32Bit::m_b

UINT8 LittleEndian32Bit::m_c

UINT8 LittleEndian32Bit::m_d

struct { ... } LittleEndian32Bit::m_uint16

UINT16 LittleEndian32Bit::m_uint16_ar[2]

UINT32 LittleEndian32Bit::m_uint32

struct { ... } LittleEndian32Bit::m_uint8

UINT8 LittleEndian32Bit::m_uint8_ar[4]

union { ... } LittleEndian32Bit::m_val

Data union member which defines several access methods to the little endian number Byte member access (m_a, m_b, m_c, m_d) gives access to byte components in ascending order (i.e. LittleEndian32Bit(Native32Bit(0xaabbccdd)) will result in m_a = 0xaa, m_b = 0xbb, m_c = 0xcc, m_d = 0xdd)

The documentation for this class was generated from the following file:
  • Kernel/MachType.hpp
Generated on Wed Jan 25 01:25:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocalDataStore Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocalDataStore Class Reference
[Afs]

#include <Apoxi/Afs/LocalDataStore.hpp>

Static Public Member Functions

static RegResult | AddInteriorNode (const Uri &parent_uri, const Uri &node_uri, INT16 transac_id)
adds interiornode
static RegResult | AddLeafNode (const Uri &parent_uri, const String &node_name, const DataItem &dataitem, INT16 transac_id)
adds a leafnode
static RegResult | Delete (const Uri &uri, INT16 transac_id)
deletes either leaf or interior node
static RegResult | Get (const Uri &uri, DataItem &dataitem, INT16 transac_id)
retrieves the leafnode
static void | RegCommitTransaction (INT16 transaction_id)
static RegResult | Replace (const Uri &uri, const DataItem &dataitem, INT16 transac_id)
replaces the leafnode
static RegResult | Set (const Uri &parent_uri, const String &node_name, const DataItem &dataitem, INT16 transac_id)

Detailed Description

structure of local data store

Member Function Documentation

RegResult LocalDataStore::AddInteriorNode | ( | const Uri & | parent_uri,
 |  | const Uri & | passed_uri,
 |  | INT16 | transac_id
 | ) | [static]

adds interiornode

------------------------------------------------------------------------ AddInteriorNode ------------------------------------------------------------------------

RegResult LocalDataStore::AddLeafNode | ( | const Uri & | parent_uri,
 |  | const String & | node_name,
 |  | const DataItem & | dataitem,
 |  | INT16 | transac_id
 | ) | [static]

adds a leafnode

------------------------------------------------------------------------ AddLeafNode ------------------------------------------------------------------------

RegResult LocalDataStore::Delete | ( | const Uri & | passed_uri,
 |  | INT16 | transac_id
 | ) | [static]

deletes either leaf or interior node

------------------------------------------------------------------------ Delete ------------------------------------------------------------------------

RegResult LocalDataStore::Get | ( | const Uri & | passed_uri,
 |  | DataItem & | dataitem,
 |  | INT16 | transac_id
 | ) | [static]

retrieves the leafnode

------------------------------------------------------------------------ Get - Always gets a leaf ------------------------------------------------------------------------

void LocalDataStore::RegCommitTransaction ( INT16 transaction_id ) [static]

------------------------------------------------------------------------ RegCommitTransaction ------------------------------------------------------------------------

RegResult LocalDataStore::Replace | ( | const Uri & | passed_uri,
 |  | const DataItem & | dataitem,
 |  | INT16 | transac_id
 | ) | [static]

replaces the leafnode

------------------------------------------------------------------------ Replace -only for leafnodes ------------------------------------------------------------------------

RegResult LocalDataStore::Set | ( | const Uri & | parent_uri,
 |  | const String & | node_name,
 |  | const DataItem & | dataitem,
 |  | INT16 | transac_id
 | ) | [static]

------------------------------------------------------------------------ Set ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/LocalDataStore.hpp
  • Afs/LocalDataStore.cpp
Generated on Wed Jan 25 01:25:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Locale Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Locale Class Reference
[GUI]

#include <Apoxi/Gui/Locale.hpp>

Collaboration diagram for Locale:

[legend]

Public Types

enum | TextAlignment { LeftToRight, RightToLeft }

Static Public Member Functions

static const WCHAR * | GetCurrencySymbol ()
static const WCHAR * | GetDateFormat (DateFormat date_format)
static WCHAR | GetDecimalSeparator ()
static INT | GetLanguage ()
static TextAlignment | GetTextAlignment ()
static WCHAR | GetThousandSeparator ()
static const WCHAR * | GetTimeFormat (TimeFormat time_format)
static void | Set (const LocaleData &locale_data)
static void | SetCurrencySymbol (const WCHAR *symbol)
static void | SetDateFormat (DateFormat date_format, const WCHAR *date_str)
static void | SetDecimalSeparator (WCHAR separator)
static void | SetLanguage (INT lang_id)
static void | SetTextAlignment (TextAlignment text_align)
static void | SetThousandSeparator (WCHAR separator)
static void | SetTimeFormat (TimeFormat time_format, const WCHAR *time_str)

Data Structures

struct | LocaleData

Member Enumeration Documentation

enum Locale::TextAlignment

Enumerator:
LeftToRight
RightToLeft

Member Function Documentation

static const WCHAR* Locale::GetCurrencySymbol ( ) [inline, static]

static const WCHAR* Locale::GetDateFormat ( DateFormat date_format ) [inline, static]

static WCHAR Locale::GetDecimalSeparator ( ) [inline, static]

static INT Locale::GetLanguage ( ) [inline, static]

static TextAlignment Locale::GetTextAlignment ( ) [inline, static]

static WCHAR Locale::GetThousandSeparator ( ) [inline, static]

static const WCHAR* Locale::GetTimeFormat ( TimeFormat time_format ) [inline, static]

void Locale::Set ( const LocaleData & locale_data ) [static]

Sets the locale-data with locale_data. Usually the locale-data can be retrieved by invoking LocaleConfig::GetSetting(id), where id specifies the index of the possible range of locale-datas, which may be retrieved by LocaleConfig::GetSettingsCount().

static void Locale::SetCurrencySymbol ( const WCHAR * symbol ) [inline, static]

static void Locale::SetDateFormat | ( | DateFormat | date_format,
 |  | const WCHAR * | date_str
 | ) | [inline, static]

static void Locale::SetDecimalSeparator ( WCHAR separator ) [inline, static]

static void Locale::SetLanguage ( INT lang_id ) [inline, static]

static void Locale::SetTextAlignment ( TextAlignment text_align ) [inline, static]

static void Locale::SetThousandSeparator ( WCHAR separator ) [inline, static]

static void Locale::SetTimeFormat | ( | TimeFormat | time_format,
 |  | const WCHAR * | time_str
 | ) | [inline, static]

The documentation for this class was generated from the following files:
  • Gui/Locale.hpp
  • Gui/Locale.cpp
Generated on Wed Jan 25 01:25:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Locale::LocaleData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Locale::LocaleData

Locale::LocaleData Struct Reference

#include <Apoxi/Gui/Locale.hpp>

Data Fields

const WCHAR * | currency_symbol
const WCHAR ** | dates
WCHAR | decimal_separator
INT | lang_id
TextAlignment text_align
WCHAR | thousand_separator
const WCHAR ** | times

Field Documentation

const WCHAR* Locale::LocaleData::currency_symbol

const WCHAR** Locale::LocaleData::dates

WCHAR Locale::LocaleData::decimal_separator

INT Locale::LocaleData::lang_id

TextAlignment Locale::LocaleData::text_align

WCHAR Locale::LocaleData::thousand_separator

const WCHAR** Locale::LocaleData::times

The documentation for this struct was generated from the following file:
  • Gui/Locale.hpp
Generated on Wed Jan 25 01:25:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocaleConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocaleConfig Class Reference
[Config]

#include <LocaleConfig.hpp>

Static Public Member Functions

static INT | GetLanguageCount ()
static INT | GetLanguageId (const WCHAR *iso2_code)
static LanguageManager::LanguageType | GetLanguageType (INT lang_id)
static const PagingMap & | GetPagingMap (INT idx)
static const Locale::LocaleData & | GetSetting (INT idx)
static INT | GetSettingsCount ()
static INT | GetStringCount ()
static const WCHAR *const * | GetTranslationTable ()

Detailed Description

Allows accessing the configuration for locale settings. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static INT LocaleConfig::GetLanguageCount ( ) [static]

Returns:
Number of available languages.

static INT LocaleConfig::GetLanguageId ( const WCHAR * iso2_code ) [static]

Returns:
APOXI system languages identifier. It is recommended that the applications work with the LanguageManager::LanguageType instead of language IDs (see LocaleConfig::GetLanguageType(), LanguageManager::SetActiveLanguageType() and LanguageManager::GetActiveLanguageType()).

static LanguageManager::LanguageType LocaleConfig::GetLanguageType ( INT lang_id ) [static]

Returns the language type corresponding to the language ID lang_id. It is recommended that the applications work with the LanguageManager::LanguageType instead of language IDs (see LanguageManager::SetActiveLanguageType() and LanguageManager::GetActiveLanguageType()) and this method provides the mapping from the IDs to the language type.

static const PagingMap& LocaleConfig::GetPagingMap ( INT idx ) [static]

Returns:
Paging map of language with the index idx.

static const Locale::LocaleData& LocaleConfig::GetSetting ( INT idx ) [static]

Returns:
Locale setting for the index idx. Use Locale::Set(LocaleConfig::GetSetting(idx)); for assigning the setting to the system.

static INT LocaleConfig::GetSettingsCount ( ) [static]

Returns:
Number of predefined locale settings.

static INT LocaleConfig::GetStringCount ( ) [static]

Returns:
Number of translateable strings given by the translation table.

static const WCHAR* const* LocaleConfig::GetTranslationTable ( ) [static]

Returns:
Translation table.

The documentation for this class was generated from the following file:
  • LocaleConfig.hpp
Generated on Wed Jan 25 01:25:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocationErrMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocationErrMsg Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>

Inheritance diagram for LocationErrMsg:

[legend]
Collaboration diagram for LocationErrMsg:

[legend]

Public Types

enum | { ID = 4207 }

Public Member Functions

virtual Message * | Clone () const
const LcsErrorCode & | GetErrCode () const
virtual const MsgMetaData & | GetMetaData () const
LocationErrMsg (ExecutionContext *context, const LcsErrorCode &err_code)
virtual | ~LocationErrMsg ()

Detailed Description

This message is sent to the MMI application in case of an error in MO-LR

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LocationErrMsg::LocationErrMsg | ( | ExecutionContext * | context,
 |  | const LcsErrorCode & | err_code
 | ) |

LocationErrMsg::~LocationErrMsg ( ) [virtual]

Member Function Documentation

Message * LocationErrMsg::Clone ( ) const [virtual]

Implements Message.

const LcsErrorCode& LocationErrMsg::GetErrCode ( ) const [inline]

const MsgMetaData & LocationErrMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonMsgTypes.hpp
  • AddOns/Lcs/Common/LcsCommonMsgTypes.cpp
Generated on Wed Jan 25 01:25:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocationEstimate Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocationEstimate Struct Reference

Contains the decoded location estimate. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Inheritance diagram for LocationEstimate:

[legend]
Collaboration diagram for LocationEstimate:

[legend]

Public Member Functions

LocationEstimate ()
Constructor.

Data Fields

GpsFixData m_fix_data
LcsShapeType m_lst
Attributes.
LcsPoint m_point
LcsPointAltitudeUncertEllipsoid m_pt_alt_ellipsoid
LcsArc m_pt_arc
LcsPointUncertCircle m_pt_uncert_circle
LcsPointUncertEllipse m_pt_uncert_ellipse

Detailed Description

Contains the decoded location estimate.

Constructor & Destructor Documentation

LocationEstimate::LocationEstimate ( ) [inline]

Constructor.

Field Documentation

GpsFixData LocationEstimate::m_fix_data

LcsShapeType LocationEstimate::m_lst

Attributes.

LcsPoint LocationEstimate::m_point

LcsPointAltitudeUncertEllipsoid LocationEstimate::m_pt_alt_ellipsoid

LcsArc LocationEstimate::m_pt_arc

LcsPointUncertCircle LocationEstimate::m_pt_uncert_circle

LcsPointUncertEllipse LocationEstimate::m_pt_uncert_ellipse

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:25:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocationNotifInvokeArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocationNotifInvokeArg Class Reference

#include <Apoxi/AddOns/Lcs/3GPP/LcsArgs.hpp>

Inheritance diagram for LocationNotifInvokeArg:

[legend]
Collaboration diagram for LocationNotifInvokeArg:

[legend]

Public Types

enum | { ID = 4215 }

Public Member Functions

const ClientInfo & | GetClientInfo () const
const LocationType & | GetLocationType () const
const LcsNotificationType & | GetNotifType () const
const TI_PD & | GetTiPd () const
LocationNotifInvokeArg ()
LocationNotifInvokeArg (const TI_PD &ti_pd, const LcsNotificationType &notif_type, const LocationType &location_type, const ClientInfo &client_info)
~LocationNotifInvokeArg ()

Static Public Member Functions

static const LocationNotifInvokeArg & | Cast (const StackMsgArgument &arg)

Friends

class | LcsStackMsgArgsDestroyTableNode

Detailed Description

This argument is sent to Lcs dispatcher to indicate MT-LR notification

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LocationNotifInvokeArg::LocationNotifInvokeArg | ( | const TI_PD & | ti_pd,
 |  | const LcsNotificationType & | notif_type,
 |  | const LocationType & | location_type,
 |  | const ClientInfo & | client_info
 | ) |

LocationNotifInvokeArg::LocationNotifInvokeArg ( )

LocationNotifInvokeArg::~LocationNotifInvokeArg ( )

Member Function Documentation

const LocationNotifInvokeArg & LocationNotifInvokeArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ClientInfo& LocationNotifInvokeArg::GetClientInfo ( ) const [inline]

const LocationType& LocationNotifInvokeArg::GetLocationType ( ) const [inline]

const LcsNotificationType& LocationNotifInvokeArg::GetNotifType ( ) const [inline]

const TI_PD& LocationNotifInvokeArg::GetTiPd ( ) const [inline]

Friends And Related Function Documentation

friend class LcsStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/3GPP/LcsArgs.hpp
  • AddOns/Lcs/3GPP/LcsArgs.cpp
Generated on Wed Jan 25 01:25:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocationNotifInvokeMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocationNotifInvokeMsg Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>

Inheritance diagram for LocationNotifInvokeMsg:

[legend]
Collaboration diagram for LocationNotifInvokeMsg:

[legend]

Public Types

enum | { ID = 4205 }

Public Member Functions

virtual Message * | Clone () const
const ClientInfo & | GetClientInfo () const
UINT16 | GetInvokeId () const
const LocationType & | GetLocationType () const
virtual const MsgMetaData & | GetMetaData () const
const LcsNotificationType & | GetNotifType () const
LocationNotifInvokeMsg (ExecutionContext *context, UINT16 invoke_id, const LcsNotificationType &notif_type, const LocationType &location_type, const ClientInfo &client_info)
virtual | ~LocationNotifInvokeMsg ()

Detailed Description

This message is sent to the MMI application to indicate a MT-LR notification

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LocationNotifInvokeMsg::LocationNotifInvokeMsg | ( | ExecutionContext * | context,
 |  | UINT16 | invoke_id,
 |  | const LcsNotificationType & | notif_type,
 |  | const LocationType & | location_type,
 |  | const ClientInfo & | client_info
 | ) |

LocationNotifInvokeMsg::~LocationNotifInvokeMsg ( ) [virtual]

Member Function Documentation

Message * LocationNotifInvokeMsg::Clone ( ) const [virtual]

Implements Message.

const ClientInfo& LocationNotifInvokeMsg::GetClientInfo ( ) const [inline]

UINT16 LocationNotifInvokeMsg::GetInvokeId ( ) const [inline]

const LocationType& LocationNotifInvokeMsg::GetLocationType ( ) const [inline]

const MsgMetaData & LocationNotifInvokeMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const LcsNotificationType& LocationNotifInvokeMsg::GetNotifType ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonMsgTypes.hpp
  • AddOns/Lcs/Common/LcsCommonMsgTypes.cpp
Generated on Wed Jan 25 01:25:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocationResMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocationResMsg Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>

Inheritance diagram for LocationResMsg:

[legend]
Collaboration diagram for LocationResMsg:

[legend]

Public Types

enum | { ID = 4206 }

Public Member Functions

virtual Message * | Clone () const
const LocationEstimate & | GetLocationEstimate () const
virtual const MsgMetaData & | GetMetaData () const
LocationResMsg (ExecutionContext *context, const LocationEstimate &location_estimate)
virtual | ~LocationResMsg ()

Detailed Description

This message is sent to the MMI application to deliver a MO-LR result

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LocationResMsg::LocationResMsg | ( | ExecutionContext * | context,
 |  | const LocationEstimate & | location_estimate
 | ) |

LocationResMsg::~LocationResMsg ( ) [virtual]

Member Function Documentation

Message * LocationResMsg::Clone ( ) const [virtual]

Implements Message.

const LocationEstimate& LocationResMsg::GetLocationEstimate ( ) const [inline]

const MsgMetaData & LocationResMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonMsgTypes.hpp
  • AddOns/Lcs/Common/LcsCommonMsgTypes.cpp
Generated on Wed Jan 25 01:25:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocationResultWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocationResultWin Class Reference

This window displays the position fix data. More...

#include <Applications/Lcs/LocationResultWin.hpp>

Inheritance diagram for LocationResultWin:

[legend]
Collaboration diagram for LocationResultWin:

[legend]

Public Member Functions

const WString & | GetTitleText () const
void | Init ()
LocationResultWin ()
Constructor.
void | SetGpsFixData (const GpsFixData &gps_fix_data, BOOLEAN first_half)
void | SetLocationEstimate (const LocationEstimate &loc_estimate, BOOLEAN first_half)
virtual | ~LocationResultWin ()
Destructor.

Protected Member Functions

virtual void | OnLayoutClient ()

Detailed Description

This window displays the position fix data.

Constructor & Destructor Documentation

LocationResultWin::LocationResultWin ( )

Constructor.

LocationResultWin::~LocationResultWin ( ) [virtual]

Destructor.

Member Function Documentation

const WString& LocationResultWin::GetTitleText ( ) const [inline]

void LocationResultWin::Init ( )

Reimplemented from ResultWinBase.

void LocationResultWin::OnLayoutClient ( ) [protected, virtual]

void LocationResultWin::SetGpsFixData | ( | const GpsFixData & | gps_fix_data,
 |  | BOOLEAN | first_half
 | ) |

void LocationResultWin::SetLocationEstimate | ( | const LocationEstimate & | loc_estimate,
 |  | BOOLEAN | first_half
 | ) |

The documentation for this class was generated from the following files:
  • Applications/Lcs/LocationResultWin.hpp
  • Applications/Lcs/LocationResultWin.cpp
Generated on Wed Jan 25 01:25:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocationVerifWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocationVerifWin Class Reference

#include <Applications/Lcs/LocationVerifWin.hpp>

Collaboration diagram for LocationVerifWin:

[legend]

Public Member Functions

void | Init ()
LocationVerifWin ()
Constructor.
void | SetData (INT invoke_id, const WString &text)
void | SetTime (WString time_str)
virtual | ~LocationVerifWin ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Detailed Description

This window class displays the verification request & gets the user's response

Constructor & Destructor Documentation

LocationVerifWin::LocationVerifWin ( )

Constructor.

LocationVerifWin::~LocationVerifWin ( ) [virtual]

Destructor.

Member Function Documentation

void LocationVerifWin::Init ( )

BOOLEAN LocationVerifWin::OnCancel ( ) [protected, virtual]

BOOLEAN LocationVerifWin::OnConfirm ( ) [protected, virtual]

void LocationVerifWin::OnOpen ( ) [protected, virtual]

void LocationVerifWin::SetData | ( | INT | invoke_id,
 |  | const WString & | text
 | ) | [inline]

void LocationVerifWin::SetTime ( WString time_str )

The documentation for this class was generated from the following files:
  • Applications/Lcs/LocationVerifWin.hpp
  • Applications/Lcs/LocationVerifWin.cpp
Generated on Wed Jan 25 01:25:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LociData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LociData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [11]

Field Documentation

UINT8 LociData::val[11]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:25:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LockedKeyDownMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LockedKeyDownMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for LockedKeyDownMsg:

[legend]
Collaboration diagram for LockedKeyDownMsg:

[legend]

Public Types

enum | { ID = 210 }

Public Member Functions

virtual Message * | Clone () const
const KeyCode & | GetKeyCode () const
virtual const MsgMetaData & | GetMetaData () const
LockedKeyDownMsg (const KeyCode &key_code)
void | SetKeyCode (const KeyCode &key_code)
virtual | ~LockedKeyDownMsg ()

Detailed Description

This message is sent to the system whenever a user presses a key while keyboard is locked. Arguments: key_code ... contains the key code of the key pressed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LockedKeyDownMsg::LockedKeyDownMsg ( const KeyCode & key_code )

LockedKeyDownMsg::~LockedKeyDownMsg ( ) [virtual]

Member Function Documentation

Message * LockedKeyDownMsg::Clone ( ) const [virtual]

Implements Message.

const KeyCode& LockedKeyDownMsg::GetKeyCode ( ) const [inline]

const MsgMetaData & LockedKeyDownMsg::GetMetaData ( ) const [virtual]

Implements Message.

void LockedKeyDownMsg::SetKeyCode ( const KeyCode & key_code ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:25:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LockedKeyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LockedKeyMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for LockedKeyMsg:

[legend]
Collaboration diagram for LockedKeyMsg:

[legend]

Public Types

enum | { ID = 211 }

Public Member Functions

virtual Message * | Clone () const
const Keyboard::Flag & | GetFlag () const
const KeyCode & | GetKeyCode () const
virtual const MsgMetaData & | GetMetaData () const
LockedKeyMsg (const Keyboard::Flag &flag, const KeyCode &key_code)
virtual | ~LockedKeyMsg ()

Detailed Description

This message is sent to the system whenever a user presses a key while keyboard is locked. Arguments: key_code ... contains the key code of the key pressed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LockedKeyMsg::LockedKeyMsg | ( | const Keyboard::Flag & | flag,
 |  | const KeyCode & | key_code
 | ) |

LockedKeyMsg::~LockedKeyMsg ( ) [virtual]

Member Function Documentation

Message * LockedKeyMsg::Clone ( ) const [virtual]

Implements Message.

const Keyboard::Flag& LockedKeyMsg::GetFlag ( ) const [inline]

const KeyCode& LockedKeyMsg::GetKeyCode ( ) const [inline]

const MsgMetaData & LockedKeyMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:25:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LockProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LockProvider Class Reference
[Provider]

#include <Apoxi/Adc/LockProvider.hpp>

Inheritance diagram for LockProvider:

[legend]
Collaboration diagram for LockProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimChvHandler *chv_handler, Protector *protector)
LockProvider ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual | ~LockProvider ()

Detailed Description

LockProvider represents the five lock states. A pointer to this provider can be retrieved from the main provider via the id:

c_lock_provider_id

Following column ids are defined: c_mcc_id :NumberType: c_mnc_id :NumberType: c_unlock_startup :NumberType: cast to BOOLEAN c_unlock_menubased :NumberType: cast to BOOLEAN c_unlock_keybased :NumberType: cast to BOOLEAN c_no_locks_id :NumberType: c_no_files :NumberType: c_cause_id :NumberType: cast to SecLockCause c_result_id :NumberType: cast to SecLockResult c_lock_type_id :NumberType: cast to SecLockType c_lock_status_id :NumberType: cast to SecLockStatus c_lock_result_id :NumberType: cast to SecLockResult c_lock_dcp_sup_id :NumberType: c_lock_retrial_method_id:NumberType: c_lock_retrial_count_id :NumberType: c_lock_time_id :NumberType: c_lock_order_id :NumberType:

This provider only consists of one fixed row.

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider LockProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

LockProvider::LockProvider ( )

LockProvider::~LockProvider ( ) [virtual]

Member Function Documentation

BOOLEAN LockProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT LockProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void LockProvider::Init | ( | SimChvHandler * | chv_handler,
 |  | Protector * | protector
 | ) |

INT LockProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

The documentation for this class was generated from the following files:
  • Adc/LockProvider.hpp
  • Adc/LockProvider.cpp
Generated on Wed Jan 25 01:25:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LockTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LockTable Class Reference
[Afs]

#include <Apoxi/Afs/LockTable.hpp>

Collaboration diagram for LockTable:

[legend]

Public Types

enum | { c_max_uris_per_table = APOXI_REG_MAX_URIS_IN_TABLE, c_table_full = -1 }
maximum no of uris supported per table More...

Public Member Functions

INT16 | AddUri (const Uri &lock_uri, Application *lock_owner, BOOLEAN transac_flag)
adds a uri to be locked in the table
INT16 | GetLockTableId ()
returns the lock table id
LockTable * GetNextLockTable ()
returns the next lock table
Application * | GetUri (INT16 lockid, Uri &locked_uri, BOOLEAN &transac_flag)
returns locked uri for the given lockid in the table
RegResult | HasAnyChildLocked (const Uri &uri_to_search)
checks whether any child locked including the uri to search called only for lock
RegResult | IsDeletePossible (const Uri &uri_to_search)
checks whether any child locked, called only for delete
LockTable (INT16 locktableid)
void | RemoveUri (INT16 lockid)
removes the locked uri in the table
Application * | SearchUri (const Uri &uri_to_search, INT16 &lock_index, BOOLEAN &transac_flag)
searches a uri to find if it is locked in the table and also returns the lock index
void | SetLockTableId (INT16 id)
sets the lock table id - presently not used as it is done by ctor
void | SetNextLockTable (LockTable *lck_tbl)
sets the next lock table
~LockTable ()

Detailed Description

structure of lock table

Member Enumeration Documentation

anonymous enum

maximum no of uris supported per table

Enumerator:
c_max_uris_per_table
c_table_full

Constructor & Destructor Documentation

LockTable::LockTable ( INT16 locktableid )

------------------------------------------------------------------------ Ctor ------------------------------------------------------------------------

LockTable::~LockTable ( )

------------------------------------------------------------------------ Dtor ------------------------------------------------------------------------

Member Function Documentation

INT16 LockTable::AddUri | ( | const Uri & | lock_uri,
 |  | Application * | lock_owner,
 |  | BOOLEAN | transac_flag
 | ) |

adds a uri to be locked in the table

------------------------------------------------------------------------ AddUri ------------------------------------------------------------------------

INT16 LockTable::GetLockTableId ( ) [inline]

returns the lock table id

LockTable* LockTable::GetNextLockTable ( ) [inline]

returns the next lock table

Application * LockTable::GetUri | ( | INT16 | index,
 |  | Uri & | locked_uri,
 |  | BOOLEAN & | transac_flag
 | ) |

returns locked uri for the given lockid in the table

------------------------------------------------------------------------ GetUri ------------------------------------------------------------------------

RegResult LockTable::HasAnyChildLocked ( const Uri & uri_to_search )

checks whether any child locked including the uri to search called only for lock

------------------------------------------------------------------------ HasAnyChildLocked - only called for Lock ------------------------------------------------------------------------

RegResult LockTable::IsDeletePossible ( const Uri & uri_to_search )

checks whether any child locked, called only for delete

------------------------------------------------------------------------ IsDeletePossible - only called for delete ------------------------------------------------------------------------

void LockTable::RemoveUri ( INT16 index )

removes the locked uri in the table

------------------------------------------------------------------------ RemoveUri ------------------------------------------------------------------------

Application * LockTable::SearchUri | ( | const Uri & | uri_to_search,
 |  | INT16 & | lock_index,
 |  | BOOLEAN & | transac_flag
 | ) |

searches a uri to find if it is locked in the table and also returns the lock index

------------------------------------------------------------------------ SearchUri ------------------------------------------------------------------------

void LockTable::SetLockTableId ( INT16 id ) [inline]

sets the lock table id - presently not used as it is done by ctor

void LockTable::SetNextLockTable ( LockTable * lck_tbl ) [inline]

sets the next lock table

The documentation for this class was generated from the following files:
  • Afs/LockTable.hpp
  • Afs/LockTable.cpp
Generated on Wed Jan 25 01:25:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LockTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LockTableEntry Struct Reference
[Afs]

structure to store uri and application pointer that locked the uri More...

#include <Apoxi/Afs/LockTable.hpp>

Collaboration diagram for LockTableEntry:

[legend]

Data Fields

Application * lock_owner_id
Uri locked_object_uri
BOOLEAN transac_flag

Detailed Description

structure to store uri and application pointer that locked the uri

structure of locked table entry

Field Documentation

Application* LockTableEntry::lock_owner_id

Uri LockTableEntry::locked_object_uri

BOOLEAN LockTableEntry::transac_flag

The documentation for this struct was generated from the following file:
  • Afs/LockTable.hpp
Generated on Wed Jan 25 01:25:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LockTableList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LockTableList Class Reference
[Afs]

#include <Apoxi/Afs/LockTableList.hpp>

Collaboration diagram for LockTableList:

[legend]

Public Member Functions

INT16 | AddLockUriInTable (const Uri &uri_string, Application *lock_owner, BOOLEAN transac_flag)
add a uri in the table with its lock owner (app)
Application * | FindUriFromTables (INT16 lockid, Uri &uri, BOOLEAN &transac_flag)
returns the locked uri for the lockid
Application * | FindUriFromTables (const Uri &given_uri, INT16 &lockid, BOOLEAN &transac_flag)
find if a uri is locked
RegResult | HasAnyChildLocked (const Uri &given_uri)
checks whether any child locked including the node called only for lock
RegResult | IsDeletePossible (const Uri &given_uri)
checks whether any child locked, called only for delete
void | RemoveLockUriInTable (INT16 lockid)
removed the uri
~LockTableList ()

Static Public Member Functions

static LockTableList * | GetLockTableList ()
Returns the locktablelist object pointer.

Protected Member Functions

BOOLEAN | CreateLockTable ()
creates a lock table
void | DeleteLockTable (INT16 locktableid)
deletes a locktable with the id
LockTable * | GetLockTable (INT16 locktableid)
returns a lock table with the id

Detailed Description

structure for list of locked table entries

Constructor & Destructor Documentation

LockTableList::~LockTableList ( )

------------------------------------------------------------------------ Dtor

THE TABLES ARE ALWAYS DESTROYED FROM LAST. TABLES ONCE CREATED REMAIN IN MEMORY AND NOT DELETED EXPLICITLY. ONLY DELETED THROUGH THIS DTOR ------------------------------------------------------------------------

Member Function Documentation

INT16 LockTableList::AddLockUriInTable | ( | const Uri & | uri_string,
 |  | Application * | lock_owner,
 |  | BOOLEAN | transac_flag
 | ) |

add a uri in the table with its lock owner (app)

------------------------------------------------------------------------ AddLockUriInTable ------------------------------------------------------------------------

BOOLEAN LockTableList::CreateLockTable ( ) [protected]

creates a lock table

------------------------------------------------------------------------ CreateLockTable ------------------------------------------------------------------------

void LockTableList::DeleteLockTable ( INT16 locktableid ) [protected]

deletes a locktable with the id

Application * LockTableList::FindUriFromTables | ( | INT16 | lockid,
 |  | Uri & | locked_uri,
 |  | BOOLEAN & | transac_flag
 | ) |

returns the locked uri for the lockid

------------------------------------------------------------------------ FindUriFromTables Overloaded ------------------------------------------------------------------------

Application * LockTableList::FindUriFromTables | ( | const Uri & | given_uri,
 |  | INT16 & | lockid,
 |  | BOOLEAN & | transac_flag
 | ) |

find if a uri is locked

------------------------------------------------------------------------ FindUriFromTables ------------------------------------------------------------------------

LockTable * LockTableList::GetLockTable ( INT16 locktableid ) [protected]

returns a lock table with the id

------------------------------------------------------------------------ GetLockTable ------------------------------------------------------------------------

LockTableList * LockTableList::GetLockTableList ( ) [static]

Returns the locktablelist object pointer.

------------------------------------------------------------------------ GetLockTableList ------------------------------------------------------------------------

RegResult LockTableList::HasAnyChildLocked ( const Uri & given_uri )

checks whether any child locked including the node called only for lock

------------------------------------------------------------------------ HasAnyChildLocked including the node for lock ------------------------------------------------------------------------

RegResult LockTableList::IsDeletePossible ( const Uri & given_uri )

checks whether any child locked, called only for delete

------------------------------------------------------------------------ IsDeletePossible called only or delete ------------------------------------------------------------------------

void LockTableList::RemoveLockUriInTable ( INT16 lockid )

removed the uri

------------------------------------------------------------------------ RemoveLockUriInTable ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/LockTableList.hpp
  • Afs/LockTableList.cpp
Generated on Wed Jan 25 01:25:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LocResController Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LocResController Class Reference

Class for controling position fix data display. More...

#include <Applications/Lcs/LocResController.hpp>

Collaboration diagram for LocResController:

[legend]

Public Member Functions

void | HandleWinEvent (ResultWinBase::ResWinAction event_code)
void | Init ()
void | Open (const LocationEstimate &loc_estimate)
void | SetStatus (INT32 conn_status)
Updates the title with the new connection status code.
void | UpdateTitle ()
Updates the title with the current system time.
virtual | ~LocResController ()
Destructor.

Static Public Member Functions

static LocResController * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()

Detailed Description

Class for controling position fix data display.

Constructor & Destructor Documentation

LocResController::~LocResController ( ) [virtual]

Destructor.

Member Function Documentation

LocResController * LocResController::GetInstance ( ) [static]

The only method to get the instance of this class.

void LocResController::HandleWinEvent ( ResultWinBase::ResWinAction event_code )

void LocResController::Init ( )

void LocResController::Open ( const LocationEstimate & loc_estimate )

void LocResController::ReleaseInstance ( ) [static]

void LocResController::SetStatus ( INT32 conn_status )

Updates the title with the new connection status code.

void LocResController::UpdateTitle ( )

Updates the title with the current system time.

The documentation for this class was generated from the following files:
  • Applications/Lcs/LocResController.hpp
  • Applications/Lcs/LocResController.cpp
Generated on Wed Jan 25 01:25:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LongKeyPressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LongKeyPressMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for LongKeyPressMsg:

[legend]
Collaboration diagram for LongKeyPressMsg:

[legend]

Public Types

enum | { ID = 202 }

Public Member Functions

virtual Message * | Clone () const
const KeyCode & | GetKeyCode () const
virtual const MsgMetaData & | GetMetaData () const
LongKeyPressMsg (const KeyCode &key_code)
void | SetKeyCode (const KeyCode &key_code)
virtual | ~LongKeyPressMsg ()

Detailed Description

This message is sent when for a long key press event args[0].t_byte[0] ... contains the key code of the key

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LongKeyPressMsg::LongKeyPressMsg ( const KeyCode & key_code )

LongKeyPressMsg::~LongKeyPressMsg ( ) [virtual]

Member Function Documentation

Message * LongKeyPressMsg::Clone ( ) const [virtual]

Implements Message.

const KeyCode& LongKeyPressMsg::GetKeyCode ( ) const [inline]

const MsgMetaData & LongKeyPressMsg::GetMetaData ( ) const [virtual]

Implements Message.

void LongKeyPressMsg::SetKeyCode ( const KeyCode & key_code ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:25:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LookupAlphaIdExtension Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LookupAlphaIdExtension Class Reference
[ADC]

#include <Apoxi/Adc/DataHandler.hpp>

Collaboration diagram for LookupAlphaIdExtension:

[legend]

Public Member Functions

virtual BOOLEAN | LookupAlphaId (const PhoneNumber &phno, WString &alphaid)
virtual method which shall implement the lookup algorithm
LookupAlphaIdExtension ()
virtual | ~LookupAlphaIdExtension ()

Static Public Member Functions

static LookupAlphaIdExtension * | GetInstance ()
static BOOLEAN | IsRegistered ()
return if a derived LookupAlphaIdExtension object is registered
static void | Register (LookupAlphaIdExtension *alpha)
Register a new derived LookupAlphaIdExtension object, only one can be registered.
static void | Unregister ()
Unregister a derived LookupAlphaIdExtension object, and use the default instance again.

Detailed Description

LookupAlphaIdExtension provides an extension mechanism which allows registering an object derived from LookupAlphaIdExtension. This derived class then shall overwrite the LookupAlphaId method and implement a lookup algorithm which returns a certain alpha identifier for a phonenumber. This will then be used by the method DataHandler::LookupAlphaId method. Internally APOXI uses this method to resolve for example SMS phonenumbers.

Constructor & Destructor Documentation

LookupAlphaIdExtension::LookupAlphaIdExtension ( )

LookupAlphaIdExtension::~LookupAlphaIdExtension ( ) [virtual]

Member Function Documentation

LookupAlphaIdExtension * LookupAlphaIdExtension::GetInstance ( ) [static]

grab an instance of the class, either the default instance which will return FALSE when LookupAlphaId is used

BOOLEAN LookupAlphaIdExtension::IsRegistered ( ) [static]

return if a derived LookupAlphaIdExtension object is registered

BOOLEAN LookupAlphaIdExtension::LookupAlphaId | ( | const PhoneNumber & | phno,
 |  | WString & | alphaid
 | ) | [virtual]

virtual method which shall implement the lookup algorithm

void LookupAlphaIdExtension::Register ( LookupAlphaIdExtension * alpha ) [static]

Register a new derived LookupAlphaIdExtension object, only one can be registered.

void LookupAlphaIdExtension::Unregister ( ) [static]

Unregister a derived LookupAlphaIdExtension object, and use the default instance again.

The documentation for this class was generated from the following files:
  • Adc/DataHandler.hpp
  • Adc/DataHandler.cpp
Generated on Wed Jan 25 01:25:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LoseFocusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LoseFocusMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for LoseFocusMsg:

[legend]
Collaboration diagram for LoseFocusMsg:

[legend]

Public Types

enum | { ID = 1001 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
LoseFocusMsg (Control *control)
virtual | ~LoseFocusMsg ()

Detailed Description

This message is sent before the focused control gets deactivated.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LoseFocusMsg::LoseFocusMsg ( Control * control )

LoseFocusMsg::~LoseFocusMsg ( ) [virtual]

Member Function Documentation

Message * LoseFocusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & LoseFocusMsg::GetMetaData ( ) const [virtual]

Implements ControlMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:25:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LsaIdentifier Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LsaIdentifier Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for LsaIdentifier:

[legend]

Data Fields

SDL_Integer length
LsaIdentifierArray lsa_id

Field Documentation

SDL_Integer LsaIdentifier::length

LsaIdentifierArray LsaIdentifier::lsa_id

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 01:25:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LsaIdentifierArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LsaIdentifierArray Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Data Fields

byte A [SDL_INTEGER_LIT(2)+1]

Field Documentation

byte LsaIdentifierArray::A[SDL_INTEGER_LIT(2)+1]

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 01:25:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: LsaIdentityMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

LsaIdentityMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for LsaIdentityMsg:

[legend]
Collaboration diagram for LsaIdentityMsg:

[legend]

Public Types

enum | { ID = 18609 }

Public Member Functions

virtual Message * | Clone () const
const LsaIdentifier & | GetLsaIdentifier () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsLsaIdentifierPresent () const
LsaIdentityMsg (BOOLEAN lsa_identifier_present, const LsaIdentifier &lsa_identifier)
void | SetLsaIdentifier (const LsaIdentifier &lsa_identifier)
void | SetLsaIdentifierPresent (BOOLEAN lsa_identifier_present)
virtual | ~LsaIdentityMsg ()

Detailed Description

LsaIdentityMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

LsaIdentityMsg::LsaIdentityMsg | ( | BOOLEAN | lsa_identifier_present,
 |  | const LsaIdentifier & | lsa_identifier
 | ) |

LsaIdentityMsg::~LsaIdentityMsg ( ) [virtual]

Member Function Documentation

Message * LsaIdentityMsg::Clone ( ) const [virtual]

Implements Message.

const LsaIdentifier& LsaIdentityMsg::GetLsaIdentifier ( ) const [inline]

const MsgMetaData & LsaIdentityMsg::GetMetaData ( ) const [virtual]

Implements Message.

BOOLEAN LsaIdentityMsg::IsLsaIdentifierPresent ( ) const [inline]

void LsaIdentityMsg::SetLsaIdentifier ( const LsaIdentifier & lsa_identifier ) [inline]

void LsaIdentityMsg::SetLsaIdentifierPresent ( BOOLEAN lsa_identifier_present ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:25:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MainDesktop Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MainDesktop Class Reference
[APOXI Template Layer]

Default desktop which displays indicators inside the desktop sections. More...

#include <Apoxi/Atl/Gui/MainDesktop.hpp>

Inheritance diagram for MainDesktop:

[legend]
Collaboration diagram for MainDesktop:

[legend]

Static Public Member Functions

static Desktop * | CreateInstance (PanelAlignment panel_align=PanelOnBottom, SectionAlignment section_align=HorizBorderAlign)

Protected Member Functions

virtual Component * | CreateSection (SectionType section_type)
MainDesktop (PanelAlignment panel_align, SectionAlignment section_align)

Detailed Description

Default desktop which displays indicators inside the desktop sections.

Constructor & Destructor Documentation

MainDesktop::MainDesktop | ( | PanelAlignment | panel_align,
 |  | SectionAlignment | section_align
 | ) | [protected]

Member Function Documentation

Desktop * MainDesktop::CreateInstance | ( | PanelAlignment | panel_align = PanelOnBottom,
 |  | SectionAlignment | section_align = HorizBorderAlign
 | ) | [static]

Component * MainDesktop::CreateSection ( SectionType section_type ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Atl/Gui/MainDesktop.hpp
  • Atl/Gui/MainDesktop.cpp
Generated on Wed Jan 25 01:25:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MainHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MainHandler Class Reference
[APOXI Stack Control]

The main handler is the entry point to the ASC library. More...

#include <Apoxi/Asc/MainHandler.hpp>

Inheritance diagram for MainHandler:

[legend]
Collaboration diagram for MainHandler:

[legend]

Public Member Functions

BOOLEAN | Cleanup ()
ExecutionContext * | GetExecutionContext () const
gives access to the linked application.
BaseHandler * | GetHandler (HandlerId id) const
returns the handler of the given handler id.
BOOLEAN | Init (ExecutionContext *context)
is used to initialize the ASC main handler.
BOOLEAN | IsMounted (HandlerId id) const
returns, if a handler is mounted by this mainhandler
MainHandler ()
Constructor.
BOOLEAN | Mount (HandlerId id)
is used to mount the given handler id.
BOOLEAN | Unmount (HandlerId id)
unmounts the given handler id.
virtual | ~MainHandler ()
Destructor.

Static Public Member Functions

static Mutex * | GetCallDataMutex ()
returns a pointer to the mutex element protecting the internal data
static CallHandlingData * | GetCallHandlingData ()
returns a pointer to the internal call handling data
static void | PostMsg (const Message &msg)
static void | PostToStackMsg (StackMsgArgument *arg)
static BOOLEAN | Startup ()

Data Structures

struct | HandlerDependency

Detailed Description

The main handler is the entry point to the ASC library.

Constructor & Destructor Documentation

MainHandler::MainHandler ( )

Constructor.

MainHandler::~MainHandler ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN MainHandler::Cleanup ( )

cleans up the whole ASC library inclusive unmounting handlers, unregistering messages and removing linked dispatchers.

static Mutex* MainHandler::GetCallDataMutex ( ) [inline, static]

returns a pointer to the mutex element protecting the internal data

static CallHandlingData* MainHandler::GetCallHandlingData ( ) [inline, static]

returns a pointer to the internal call handling data

ExecutionContext * MainHandler::GetExecutionContext ( ) const

gives access to the linked application.

BaseHandler * MainHandler::GetHandler ( HandlerId id ) const

returns the handler of the given handler id.

BOOLEAN MainHandler::Init ( ExecutionContext * context )

is used to initialize the ASC main handler.

BOOLEAN MainHandler::IsMounted ( HandlerId id ) const

returns, if a handler is mounted by this mainhandler

BOOLEAN MainHandler::Mount ( HandlerId id )

is used to mount the given handler id.

void MainHandler::PostMsg ( const Message & msg ) [static]

void MainHandler::PostToStackMsg ( StackMsgArgument * arg ) [static]

BOOLEAN MainHandler::Startup ( ) [static]

BOOLEAN MainHandler::Unmount ( HandlerId id )

unmounts the given handler id.

The documentation for this class was generated from the following files:
  • Asc/MainHandler.hpp
  • Asc/MainHandler.cpp
Generated on Wed Jan 25 01:25:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MainHandlerAccess Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MainHandlerAccess Class Reference

#include <Apoxi/Asc/MainHandlerAccess.hpp>

Collaboration diagram for MainHandlerAccess:

[legend]

Public Member Functions

Application * GetApplication ()
gives access to the linked application.
MainHandler * GetMainHandler () const
returns the entry point to the ASC library.
MainHandlerAccess (MainHandler *main_handler=0)
The constructor is initialized with the corresponding ASC main handler.
~MainHandlerAccess ()

Detailed Description

can be used as base class, which gives access to the ASC main handler and the ADC library.

Constructor & Destructor Documentation

MainHandlerAccess::MainHandlerAccess ( MainHandler * main_handler = 0 )

The constructor is initialized with the corresponding ASC main handler.

MainHandlerAccess::~MainHandlerAccess ( )

Member Function Documentation

Application * MainHandlerAccess::GetApplication ( )

gives access to the linked application.

MainHandler* MainHandlerAccess::GetMainHandler ( ) const [inline]

returns the entry point to the ASC library.

The documentation for this class was generated from the following files:
  • Asc/MainHandlerAccess.hpp
  • Asc/MainHandlerAccess.cpp
Generated on Wed Jan 25 01:25:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MainProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MainProvider Class Reference

#include <Apoxi/Auxiliary/MainProvider.hpp>

Inheritance diagram for MainProvider:

[legend]
Collaboration diagram for MainProvider:

[legend]

Public Member Functions

virtual Provider * | GetProvider (INT providerid)
Returns the pointer to a provider matching with the provider id.
BOOLEAN | HasProvider (INT providerid)
Checks if a provider with a certain id is available in the system.
void | Init ()
Initializes the main provider, has to be called before the first usage.
MainProvider ()
virtual | ~MainProvider ()

Static Public Member Functions

static BOOLEAN | AcquireGlobalProvider (INT providerid)
static BOOLEAN | RegisterGlobalProvider (Provider *provider)
Registers a provider with a certain id.
static BOOLEAN | ReleaseGlobalProvider (INT providerid)
Releases a global provider, so that it might be unregistered.
static BOOLEAN | UnregisterGlobalProvider (Provider *provider)
Unregisters a certain provider.

Static Protected Member Functions

static Provider * | GetGlobalProvider (INT columnid)

Detailed Description

MainProvider provides an application with all providers registered in the system. These registered providers can be shared between all applications.

Constructor & Destructor Documentation

MainProvider::MainProvider ( )

MainProvider::~MainProvider ( ) [virtual]

Member Function Documentation

BOOLEAN MainProvider::AcquireGlobalProvider ( INT providerid ) [static]

Register access to the global provider list before using a certain provider. Therefore a certain application can not remove it from the list

Provider * MainProvider::GetGlobalProvider ( INT columnid ) [static, protected]

Provider * MainProvider::GetProvider ( INT providerid ) [virtual]

Returns the pointer to a provider matching with the provider id.

Reimplemented in DataHandler.

BOOLEAN MainProvider::HasProvider ( INT providerid ) [inline]

Checks if a provider with a certain id is available in the system.

void MainProvider::Init ( )

Initializes the main provider, has to be called before the first usage.

BOOLEAN MainProvider::RegisterGlobalProvider ( Provider * provider ) [static]

Registers a provider with a certain id.

BOOLEAN MainProvider::ReleaseGlobalProvider ( INT providerid ) [static]

Releases a global provider, so that it might be unregistered.

BOOLEAN MainProvider::UnregisterGlobalProvider ( Provider * provider ) [static]

Unregisters a certain provider.

The documentation for this class was generated from the following files:
  • Auxiliary/MainProvider.hpp
  • Auxiliary/MainProvider.cpp
Generated on Wed Jan 25 01:25:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MapiAudioPlayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MapiAudioPlayer Class Reference
[Audio]

#include <Apoxi/AddOns/YamahaMapi/MapiAudioPlayer.hpp>

Inheritance diagram for MapiAudioPlayer:

[legend]
Collaboration diagram for MapiAudioPlayer:

[legend]

Public Member Functions

virtual BOOLEAN | CanResume (const AudioActiveReference &active_reference) const
virtual BOOLEAN | CanSuspend (const AudioActiveReference &active_reference) const
virtual SharedPtr< AudioReference > | CreateAudioReferenceFromExtensionSoundDataSource (MimeType mime_type, AudioReference::SoundDataSource sound_data_source)
virtual UINT16 | GetDeviceID () const
Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).
virtual Vector< MimeTypeSupportInfo > | GetMimeTypeSupportInfo () const
virtual AudioPlayer::AudioSourceType | GetSource () const
virtual void | Play (AudioActiveReference &active_reference)
void | SetStopCallback (BOOLEAN(*cb_stop)(const AudioActiveReference &active_ref))
virtual void | Stop (AudioActiveReference &active_reference)

Static Public Member Functions

static MapiAudioPlayer * | GetInstance ()

Protected Member Functions

virtual AudioMapiManager::RequestOutcomeType | ForwardCommandToDriver (AudioMapiManager::MapiCommandType &command)
virtual BOOLEAN | OnSdlSignal (UINT16 func_id, UINT8 handle, UINT16 drv_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4)
virtual BOOLEAN | Play_Allocate (AudioActiveReference &playing_ref)
BOOLEAN | StopCallbackHaveBeenSet () const

Static Protected Member Functions

static void | SetCommandExecutedCondition (UINT32 parm1, UINT32 parm2)

Protected Attributes

BOOLEAN(* | m_cb_stop )(const AudioActiveReference &active_ref)

Friends

class | AudioMapiManager

Friends And Related Function Documentation

friend class AudioMapiManager [friend]

The documentation for this class was generated from the following files:
  • AddOns/YamahaMapi/MapiAudioPlayer.hpp
  • AddOns/YamahaMapi/MapiAudioPlayer.cpp
Generated on Wed Jan 25 01:25:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MapiAudioReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MapiAudioReference Class Reference

#include <Apoxi/AddOns/YamahaMapi/MapiAudioReference.hpp>

Inheritance diagram for MapiAudioReference:

[legend]
Collaboration diagram for MapiAudioReference:

[legend]

Public Member Functions

virtual enumClassType | GetClassType () const
virtual | ~MapiAudioReference ()

Static Public Member Functions

static SharedPtr< MapiAudioReference > | Create ()

Protected Member Functions

MapiAudioReference ()

Friends

class | MapiAudioPlayer

Constructor & Destructor Documentation

MapiAudioReference::~MapiAudioReference ( ) [virtual]

MapiAudioReference::MapiAudioReference ( ) [protected]

Member Function Documentation

SharedPtr< MapiAudioReference > MapiAudioReference::Create ( ) [static]

AudioReference::enumClassType MapiAudioReference::GetClassType ( ) const [virtual]

Implements AudioReference.

Friends And Related Function Documentation

friend class MapiAudioPlayer [friend]

The documentation for this class was generated from the following files:
  • AddOns/YamahaMapi/MapiAudioReference.hpp
  • AddOns/YamahaMapi/MapiAudioReference.cpp
Generated on Wed Jan 25 01:25:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MappingPolicy Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MappingPolicy Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Properties/MappingPolicy.hpp>

Inheritance diagram for MappingPolicy:

[legend]

Public Member Functions

virtual INT | GetIndex (const DataItem &value) const
virtual DataItem | GetValue (INT index) const
MappingPolicy ()
default constructor
BOOLEAN | SetProperty (ResourceParser &parser, GuiObjectFactory::PropertyId property_id, INT object_id)
virtual | ~MappingPolicy ()
destructor

Detailed Description

MappingPolicy for mapping the value of a property to an index of a TextIcon[].

Constructor & Destructor Documentation

MappingPolicy::MappingPolicy ( )

default constructor

MappingPolicy::~MappingPolicy ( ) [virtual]

destructor

Member Function Documentation

INT MappingPolicy::GetIndex ( const DataItem & value ) const [virtual]

Parameters:
value DataItem describing a Property's value
Returns:
Index of the ValueMappingPropertyDescriptor's TextIconPair matching a Property's value.

Reimplemented in RangeMappingPolicy.

virtual DataItem MappingPolicy::GetValue ( INT index ) const [inline, virtual]

Parameters:
index INT index
Returns:
A Property's value matching the given index in the ValueMappingPropertyDescriptor's TextIconPair.

Reimplemented in RangeMappingPolicy.

BOOLEAN MappingPolicy::SetProperty | ( | ResourceParser & | parser,
 |  | GuiObjectFactory::PropertyId | property_id,
 |  | INT | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented in RangeMappingPolicy.

The documentation for this class was generated from the following files:
  • Atl/Properties/MappingPolicy.hpp
  • Atl/Properties/MappingPolicy.cpp
Generated on Wed Jan 25 01:25:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MbiProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MbiProvider Class Reference
[Provider]

#include <Apoxi/Adc/MbiProvider.hpp>

Inheritance diagram for MbiProvider:

[legend]
Collaboration diagram for MbiProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *handler, Protector *protector)
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
MbiProvider ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~MbiProvider ()

Detailed Description

MbiProvider is the provider to retrieve the MBI record identifier as defined in 3GPP TS 51.011 V4.13.0 and 3GPP TS 31.102 V6.8.0. The record identifier which is returned can be directly be used as the index into the c_mbdn_provider_id phonebook to retrieve its phonenumber and alphaidentifier. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_mbi_provider_id

Following column ids are defined: c_mdni_voicemail_id :NumberType: c_mdni_fax_id :NumberType: c_mdni_electronic_mail_id :NumberType: c_mdni_other_id :NumberType: c_mdni_videomail_id :NumberType:

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider MbiProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

MbiProvider::MbiProvider ( )

MbiProvider::~MbiProvider ( ) [virtual]

Member Function Documentation

BOOLEAN MbiProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN MbiProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT MbiProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void MbiProvider::Init | ( | SimAuxHandler * | handler,
 |  | Protector * | protector
 | ) |

INT MbiProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT MbiProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN MbiProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN MbiProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN MbiProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/MbiProvider.hpp
  • Adc/MbiProvider.cpp
Generated on Wed Jan 25 01:25:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MCServiceInterfaceMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MCServiceInterfaceMsg Class Reference

#include <Apoxi/AddOns/MediaFramework/MsgTypes.hpp>

Inheritance diagram for MCServiceInterfaceMsg:

[legend]
Collaboration diagram for MCServiceInterfaceMsg:

[legend]

Public Types

enum | { ID = 54001 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetPathname () const
INT32 | GetType () const
MCServiceInterfaceMsg (Application *application, INT32 type, const WString &pathname)
void | SetPathname (const WString &pathname)
void | SetType (INT32 type)
virtual | ~MCServiceInterfaceMsg ()

Protected Member Functions

virtual void | Dump (OutputStream &ostr) const

Friends

OutputStream & | operator<< (OutputStream &ostr, const MCServiceInterfaceMsg &cls)
InputStream & | operator>> (InputStream &istr, MCServiceInterfaceMsg &cls)

Detailed Description

MCServiceInterfaceMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MCServiceInterfaceMsg::MCServiceInterfaceMsg | ( | Application * | application,
 |  | INT32 | type,
 |  | const WString & | pathname
 | ) |

MCServiceInterfaceMsg::~MCServiceInterfaceMsg ( ) [virtual]

Member Function Documentation

Message * MCServiceInterfaceMsg::Clone ( ) const [virtual]

Implements Message.

void MCServiceInterfaceMsg::Dump ( OutputStream & ostr ) const [protected, virtual]

const MsgMetaData & MCServiceInterfaceMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const WString& MCServiceInterfaceMsg::GetPathname ( ) const [inline]

INT32 MCServiceInterfaceMsg::GetType ( ) const [inline]

void MCServiceInterfaceMsg::SetPathname ( const WString & pathname ) [inline]

void MCServiceInterfaceMsg::SetType ( INT32 type ) [inline]

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const MCServiceInterfaceMsg & | cls
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | MCServiceInterfaceMsg & | cls
 | ) | [friend]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MsgTypes.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MsgTypes.cpp
Generated on Wed Jan 25 01:25:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhDeletionCmd Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhDeletionCmd Class Reference

MdhDeletionCmd (ms.h: T_DR_DEL_CMD_FLAGS). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Collaboration diagram for MdhDeletionCmd:

[legend]

Public Member Functions

UINT8 | Get () const
void | SetRead (BOOLEAN value=TRUE)
void | SetSent (BOOLEAN value=TRUE)
void | SetSmsr (BOOLEAN value=TRUE)
void | SetUnknown (BOOLEAN value=TRUE)
void | SetUnread (BOOLEAN value=TRUE)
void | SetUnsent (BOOLEAN value=TRUE)

Data Fields

BitField8 val

Detailed Description

MdhDeletionCmd (ms.h: T_DR_DEL_CMD_FLAGS).

Member Function Documentation

UINT8 MdhDeletionCmd::Get ( ) const [inline]

void MdhDeletionCmd::SetRead ( BOOLEAN value = TRUE ) [inline]

void MdhDeletionCmd::SetSent ( BOOLEAN value = TRUE ) [inline]

void MdhDeletionCmd::SetSmsr ( BOOLEAN value = TRUE ) [inline]

void MdhDeletionCmd::SetUnknown ( BOOLEAN value = TRUE ) [inline]

void MdhDeletionCmd::SetUnread ( BOOLEAN value = TRUE ) [inline]

void MdhDeletionCmd::SetUnsent ( BOOLEAN value = TRUE ) [inline]

Field Documentation

BitField8 MdhDeletionCmd::val

The documentation for this class was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:25:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhDeregistrationCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhDeregistrationCnfArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhDeregistrationCnfArg:

[legend]
Collaboration diagram for MdhDeregistrationCnfArg:

[legend]

Public Types

enum | { ID = 5439 }

Public Member Functions

const MdhResult & | GetResult () const
MdhDeregistrationCnfArg ()
void | SetResult (const MdhResult &result)

Static Public Member Functions

static const MdhDeregistrationCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhDeregistrationCnfArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhDeregistrationCnfArg::MdhDeregistrationCnfArg ( )

Member Function Documentation

const MdhDeregistrationCnfArg & MdhDeregistrationCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhResult& MdhDeregistrationCnfArg::GetResult ( ) const [inline]

void MdhDeregistrationCnfArg::SetResult ( const MdhResult & result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:25:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhDeregistrationReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhDeregistrationReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhDeregistrationReqArg:

[legend]
Collaboration diagram for MdhDeregistrationReqArg:

[legend]

Public Types

enum | { ID = 6438 }

Public Member Functions

MdhDeregistrationReqArg ()

Static Public Member Functions

static const MdhDeregistrationReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhDeregistrationReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhDeregistrationReqArg::MdhDeregistrationReqArg ( )

Member Function Documentation

const MdhDeregistrationReqArg & MdhDeregistrationReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:25:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhExtendedData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhExtendedData Class Reference

#include <Apoxi/Apc/MdhTypes.hpp>

Public Member Functions

UINT32 | GetExtData () const
MdhExtendedData ()
MdhExtendedData & | operator= (const MdhExtendedData &ext_data)
void | SetExtData (UINT32 ext_data)

Data Fields

UINT8 | val [c_mdh_max_ext_data]

Constructor & Destructor Documentation

MdhExtendedData::MdhExtendedData ( ) [inline]

Member Function Documentation

UINT32 MdhExtendedData::GetExtData ( ) const [inline]

MdhExtendedData& MdhExtendedData::operator= ( const MdhExtendedData & ext_data ) [inline]

void MdhExtendedData::SetExtData ( UINT32 ext_data ) [inline]

Field Documentation

UINT8 MdhExtendedData::val[c_mdh_max_ext_data]

The documentation for this class was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:25:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhGors Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhGors Class Reference

MdhGors (ms.h: T_DATA Group Operation Result Set, internal use). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Public Member Functions

void | Fill (const UINT8 *buffer, INT bufferlen)
BOOLEAN | IsEmpty () const
BOOLEAN | IsPduDeleted (INT tpdupos) const
MdhGors (const MdhGors &gors)
MdhGors ()
MdhGors & | operator= (const MdhGors &gors)
~MdhGors ()

Detailed Description

MdhGors (ms.h: T_DATA Group Operation Result Set, internal use).

Constructor & Destructor Documentation

MdhGors::MdhGors ( ) [inline]

MdhGors::MdhGors ( const MdhGors & gors ) [inline]

MdhGors::~MdhGors ( ) [inline]

Member Function Documentation

void MdhGors::Fill | ( | const UINT8 * | buffer,
 |  | INT | bufferlen
 | ) | [inline]

BOOLEAN MdhGors::IsEmpty ( ) const [inline]

BOOLEAN MdhGors::IsPduDeleted ( INT tpdupos ) const [inline]

MdhGors& MdhGors::operator= ( const MdhGors & gors ) [inline]

The documentation for this class was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:25:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhMakeViewCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhMakeViewCnfArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhMakeViewCnfArg:

[legend]
Collaboration diagram for MdhMakeViewCnfArg:

[legend]

Public Types

enum | { ID = 5458 }

Public Member Functions

const MdhResult & | GetResult () const
const MdhViewHdl & | GetViewHdl () const
MdhMakeViewCnfArg ()
void | SetResult (const MdhResult &result)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhMakeViewCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhMakeViewCnfArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhMakeViewCnfArg::MdhMakeViewCnfArg ( )

Member Function Documentation

const MdhMakeViewCnfArg & MdhMakeViewCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhResult& MdhMakeViewCnfArg::GetResult ( ) const [inline]

const MdhViewHdl& MdhMakeViewCnfArg::GetViewHdl ( ) const [inline]

void MdhMakeViewCnfArg::SetResult ( const MdhResult & result ) [inline]

void MdhMakeViewCnfArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:25:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhMakeViewReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhMakeViewReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhMakeViewReqArg:

[legend]
Collaboration diagram for MdhMakeViewReqArg:

[legend]

Public Types

enum | { ID = 6457 }

Public Member Functions

MdhMakeViewReqArg ()

Static Public Member Functions

static const MdhMakeViewReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhMakeViewReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhMakeViewReqArg::MdhMakeViewReqArg ( )

Member Function Documentation

const MdhMakeViewReqArg & MdhMakeViewReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:25:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhNewStatusReportIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhNewStatusReportIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhNewStatusReportIndArg:

[legend]
Collaboration diagram for MdhNewStatusReportIndArg:

[legend]

Public Types

enum | { ID = 5463 }

Public Member Functions

INT | GetLink () const
const MdhSmsrLocation & | GetSmsrLocation () const
INT | GetSrPos () const
UINT8 | GetSrStatus () const
const Tpdu & | GetTpdu () const
MdhNewStatusReportIndArg ()
void | SetLink (INT link)
void | SetSmsrLocation (const MdhSmsrLocation &smsr_location)
void | SetSrPos (INT sr_pos)
void | SetSrStatus (UINT8 sr_status)
void | SetTpdu (const Tpdu &tpdu)

Static Public Member Functions

static const MdhNewStatusReportIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhNewStatusReportIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhNewStatusReportIndArg::MdhNewStatusReportIndArg ( )

Member Function Documentation

const MdhNewStatusReportIndArg & MdhNewStatusReportIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT MdhNewStatusReportIndArg::GetLink ( ) const [inline]

const MdhSmsrLocation& MdhNewStatusReportIndArg::GetSmsrLocation ( ) const [inline]

INT MdhNewStatusReportIndArg::GetSrPos ( ) const [inline]

UINT8 MdhNewStatusReportIndArg::GetSrStatus ( ) const [inline]

const Tpdu& MdhNewStatusReportIndArg::GetTpdu ( ) const [inline]

void MdhNewStatusReportIndArg::SetLink ( INT link ) [inline]

void MdhNewStatusReportIndArg::SetSmsrLocation ( const MdhSmsrLocation & smsr_location ) [inline]

void MdhNewStatusReportIndArg::SetSrPos ( INT sr_pos ) [inline]

void MdhNewStatusReportIndArg::SetSrStatus ( UINT8 sr_status ) [inline]

void MdhNewStatusReportIndArg::SetTpdu ( const Tpdu & tpdu ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:25:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhRegistrationCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhRegistrationCnfArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhRegistrationCnfArg:

[legend]
Collaboration diagram for MdhRegistrationCnfArg:

[legend]

Public Types

enum | { ID = 5441 }

Public Member Functions

const MdhResult & | GetResult () const
const MdhViewHdl & | GetViewHdl () const
MdhRegistrationCnfArg ()
void | SetResult (const MdhResult &result)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhRegistrationCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhRegistrationCnfArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhRegistrationCnfArg::MdhRegistrationCnfArg ( )

Member Function Documentation

const MdhRegistrationCnfArg & MdhRegistrationCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhResult& MdhRegistrationCnfArg::GetResult ( ) const [inline]

const MdhViewHdl& MdhRegistrationCnfArg::GetViewHdl ( ) const [inline]

void MdhRegistrationCnfArg::SetResult ( const MdhResult & result ) [inline]

void MdhRegistrationCnfArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:25:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhRegistrationReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhRegistrationReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhRegistrationReqArg:

[legend]
Collaboration diagram for MdhRegistrationReqArg:

[legend]

Public Types

enum | { ID = 6440 }

Public Member Functions

MdhRegistrationReqArg ()

Static Public Member Functions

static const MdhRegistrationReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhRegistrationReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhRegistrationReqArg::MdhRegistrationReqArg ( )

Member Function Documentation

const MdhRegistrationReqArg & MdhRegistrationReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:25:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhRemoveViewCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhRemoveViewCnfArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhRemoveViewCnfArg:

[legend]
Collaboration diagram for MdhRemoveViewCnfArg:

[legend]

Public Types

enum | { ID = 5460 }

Public Member Functions

const MdhResult & | GetResult () const
const MdhViewHdl & | GetViewHdl () const
MdhRemoveViewCnfArg ()
void | SetResult (const MdhResult &result)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhRemoveViewCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhRemoveViewCnfArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhRemoveViewCnfArg::MdhRemoveViewCnfArg ( )

Member Function Documentation

const MdhRemoveViewCnfArg & MdhRemoveViewCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhResult& MdhRemoveViewCnfArg::GetResult ( ) const [inline]

const MdhViewHdl& MdhRemoveViewCnfArg::GetViewHdl ( ) const [inline]

void MdhRemoveViewCnfArg::SetResult ( const MdhResult & result ) [inline]

void MdhRemoveViewCnfArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:25:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhRemoveViewReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhRemoveViewReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhRemoveViewReqArg:

[legend]
Collaboration diagram for MdhRemoveViewReqArg:

[legend]

Public Types

enum | { ID = 6459 }

Public Member Functions

const MdhViewHdl & | GetViewHdl () const
MdhRemoveViewReqArg ()
MdhRemoveViewReqArg (const MdhViewHdl &view_hdl)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhRemoveViewReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhRemoveViewReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhRemoveViewReqArg::MdhRemoveViewReqArg ( const MdhViewHdl & view_hdl )

MdhRemoveViewReqArg::MdhRemoveViewReqArg ( )

Member Function Documentation

const MdhRemoveViewReqArg & MdhRemoveViewReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhViewHdl& MdhRemoveViewReqArg::GetViewHdl ( ) const [inline]

void MdhRemoveViewReqArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhResult Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhResult Struct Reference

MdhResult (ms.h: T_DR_RESULT). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Data Fields

MdhCause cause
MdhStatus status

Detailed Description

MdhResult (ms.h: T_DR_RESULT).

Field Documentation

MdhCause MdhResult::cause

MdhStatus MdhResult::status

The documentation for this struct was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:26:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSetConfigCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSetConfigCnfArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSetConfigCnfArg:

[legend]
Collaboration diagram for MdhSetConfigCnfArg:

[legend]

Public Types

enum | { ID = 5456 }

Public Member Functions

const MdhResult & | GetResult () const
const MdhViewHdl & | GetViewHdl () const
MdhSetConfigCnfArg ()
void | SetResult (const MdhResult &result)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhSetConfigCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSetConfigCnfArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSetConfigCnfArg::MdhSetConfigCnfArg ( )

Member Function Documentation

const MdhSetConfigCnfArg & MdhSetConfigCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhResult& MdhSetConfigCnfArg::GetResult ( ) const [inline]

const MdhViewHdl& MdhSetConfigCnfArg::GetViewHdl ( ) const [inline]

void MdhSetConfigCnfArg::SetResult ( const MdhResult & result ) [inline]

void MdhSetConfigCnfArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSetConfigReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSetConfigReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSetConfigReqArg:

[legend]
Collaboration diagram for MdhSetConfigReqArg:

[legend]

Public Types

enum | { ID = 6455 }

Public Member Functions

const MdhViewConfig & | GetViewConfig () const
const MdhViewHdl & | GetViewHdl () const
MdhSetConfigReqArg ()
MdhSetConfigReqArg (const MdhViewHdl &view_hdl, const MdhViewConfig &view_config)
void | SetViewConfig (const MdhViewConfig &view_config)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhSetConfigReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSetConfigReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSetConfigReqArg::MdhSetConfigReqArg | ( | const MdhViewHdl & | view_hdl,
 |  | const MdhViewConfig & | view_config
 | ) |

MdhSetConfigReqArg::MdhSetConfigReqArg ( )

Member Function Documentation

const MdhSetConfigReqArg & MdhSetConfigReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhViewConfig& MdhSetConfigReqArg::GetViewConfig ( ) const [inline]

const MdhViewHdl& MdhSetConfigReqArg::GetViewHdl ( ) const [inline]

void MdhSetConfigReqArg::SetViewConfig ( const MdhViewConfig & view_config ) [inline]

void MdhSetConfigReqArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSetStorageCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSetStorageCnfArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSetStorageCnfArg:

[legend]
Collaboration diagram for MdhSetStorageCnfArg:

[legend]

Public Types

enum | { ID = 5448 }

Public Member Functions

const MdhResult & | GetResult () const
MdhSetStorageCnfArg ()
void | SetResult (const MdhResult &result)

Static Public Member Functions

static const MdhSetStorageCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSetStorageCnfArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSetStorageCnfArg::MdhSetStorageCnfArg ( )

Member Function Documentation

const MdhSetStorageCnfArg & MdhSetStorageCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhResult& MdhSetStorageCnfArg::GetResult ( ) const [inline]

void MdhSetStorageCnfArg::SetResult ( const MdhResult & result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSetStorageReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSetStorageReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSetStorageReqArg:

[legend]
Collaboration diagram for MdhSetStorageReqArg:

[legend]

Public Types

enum | { ID = 6447 }

Public Member Functions

const MdhWorkMedia & | GetStorMedia () const
MdhSetStorageReqArg ()
MdhSetStorageReqArg (const MdhWorkMedia &stor_media)
void | SetStorMedia (const MdhWorkMedia &stor_media)

Static Public Member Functions

static const MdhSetStorageReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSetStorageReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSetStorageReqArg::MdhSetStorageReqArg ( const MdhWorkMedia & stor_media )

MdhSetStorageReqArg::MdhSetStorageReqArg ( )

Member Function Documentation

const MdhSetStorageReqArg & MdhSetStorageReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhWorkMedia& MdhSetStorageReqArg::GetStorMedia ( ) const [inline]

void MdhSetStorageReqArg::SetStorMedia ( const MdhWorkMedia & stor_media ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSetWaitIndicator Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSetWaitIndicator Struct Reference

MdhSetWaitIndicator (ms.h: T_DR_SET_WAIT_IND_RQ). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Data Fields

UINT8 | count
BOOLEAN | update

Detailed Description

MdhSetWaitIndicator (ms.h: T_DR_SET_WAIT_IND_RQ).

Field Documentation

UINT8 MdhSetWaitIndicator::count

BOOLEAN MdhSetWaitIndicator::update

The documentation for this struct was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:26:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSetWaitIndicatorArray Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSetWaitIndicatorArray Class Reference

MdhSetWaitIndicatorArray (ms.h: T_DR_SET_WAIT_IND_REQ). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Collaboration diagram for MdhSetWaitIndicatorArray:

[legend]

Public Member Functions

MdhSetWaitIndicatorArray ()
void | SetIndicator (MdhWaitType type, BOOLEAN update, UINT8 count=0)

Data Fields

MdhSetWaitIndicator | val [MdhNofMdhWaitTypes]

Detailed Description

MdhSetWaitIndicatorArray (ms.h: T_DR_SET_WAIT_IND_REQ).

Constructor & Destructor Documentation

MdhSetWaitIndicatorArray::MdhSetWaitIndicatorArray ( ) [inline]

Member Function Documentation

void MdhSetWaitIndicatorArray::SetIndicator | ( | MdhWaitType | type,
 |  | BOOLEAN | update,
 |  | UINT8 | count = 0
 | ) | [inline]

Field Documentation

MdhSetWaitIndicator MdhSetWaitIndicatorArray::val[MdhNofMdhWaitTypes]

The documentation for this class was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:26:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsConcRefNumIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsConcRefNumIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsConcRefNumIndArg:

[legend]
Collaboration diagram for MdhSmsConcRefNumIndArg:

[legend]

Public Types

enum | { ID = 5474 }

Public Member Functions

UINT16 | GetRefNo () const
MdhSmsConcRefNumIndArg ()
void | SetRefNo (UINT16 ref_no)

Static Public Member Functions

static const MdhSmsConcRefNumIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsConcRefNumIndArg: reflects arguments of signal DR_SM_CCT_REF_NUMBER_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsConcRefNumIndArg::MdhSmsConcRefNumIndArg ( )

Member Function Documentation

const MdhSmsConcRefNumIndArg & MdhSmsConcRefNumIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT16 MdhSmsConcRefNumIndArg::GetRefNo ( ) const [inline]

void MdhSmsConcRefNumIndArg::SetRefNo ( UINT16 ref_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsConcRefNumReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsConcRefNumReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsConcRefNumReqArg:

[legend]
Collaboration diagram for MdhSmsConcRefNumReqArg:

[legend]

Public Types

enum | { ID = 6466 }

Public Member Functions

MdhSmsConcRefNumReqArg ()

Static Public Member Functions

static const MdhSmsConcRefNumReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsConcRefNumReqArg: reflects arguments of signal DR_SM_CCT_REF_NUMBER_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsConcRefNumReqArg::MdhSmsConcRefNumReqArg ( )

Member Function Documentation

const MdhSmsConcRefNumReqArg & MdhSmsConcRefNumReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsDeletionIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsDeletionIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsDeletionIndArg:

[legend]
Collaboration diagram for MdhSmsDeletionIndArg:

[legend]

Public Types

enum | { ID = 5475 }

Public Member Functions

const MdhDeletionCmd & | GetDeletionCmd () const
const MdhGors & | GetGors () const
INT | GetPosition () const
const MdhResult & | GetResult () const
UINT8 | GetView () const
MdhSmsDeletionIndArg ()
void | SetDeletionCmd (const MdhDeletionCmd &deletion_cmd)
void | SetGors (const MdhGors &gors)
void | SetPosition (INT position)
void | SetResult (const MdhResult &result)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsDeletionIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsDeletionIndArg: reflects arguments of signal DR_SM_GENERIC_DEL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsDeletionIndArg::MdhSmsDeletionIndArg ( )

Member Function Documentation

const MdhSmsDeletionIndArg & MdhSmsDeletionIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhDeletionCmd& MdhSmsDeletionIndArg::GetDeletionCmd ( ) const [inline]

const MdhGors& MdhSmsDeletionIndArg::GetGors ( ) const [inline]

INT MdhSmsDeletionIndArg::GetPosition ( ) const [inline]

const MdhResult& MdhSmsDeletionIndArg::GetResult ( ) const [inline]

UINT8 MdhSmsDeletionIndArg::GetView ( ) const [inline]

void MdhSmsDeletionIndArg::SetDeletionCmd ( const MdhDeletionCmd & deletion_cmd ) [inline]

void MdhSmsDeletionIndArg::SetGors ( const MdhGors & gors ) [inline]

void MdhSmsDeletionIndArg::SetPosition ( INT position ) [inline]

void MdhSmsDeletionIndArg::SetResult ( const MdhResult & result ) [inline]

void MdhSmsDeletionIndArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsDeletionReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsDeletionReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsDeletionReqArg:

[legend]
Collaboration diagram for MdhSmsDeletionReqArg:

[legend]

Public Types

enum | { ID = 6467 }

Public Member Functions

const MdhDeletionCmd & | GetDeletionCmd () const
INT | GetPosition () const
UINT8 | GetView () const
MdhSmsDeletionReqArg ()
MdhSmsDeletionReqArg (UINT8 view, const MdhDeletionCmd &deletion_cmd, INT position)
void | SetDeletionCmd (const MdhDeletionCmd &deletion_cmd)
void | SetPosition (INT position)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsDeletionReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsDeletionReqArg: reflects arguments of signal DR_SM_GENERIC_DEL_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsDeletionReqArg::MdhSmsDeletionReqArg | ( | UINT8 | view,
 |  | const MdhDeletionCmd & | deletion_cmd,
 |  | INT | position
 | ) |

MdhSmsDeletionReqArg::MdhSmsDeletionReqArg ( )

Member Function Documentation

const MdhSmsDeletionReqArg & MdhSmsDeletionReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhDeletionCmd& MdhSmsDeletionReqArg::GetDeletionCmd ( ) const [inline]

INT MdhSmsDeletionReqArg::GetPosition ( ) const [inline]

UINT8 MdhSmsDeletionReqArg::GetView ( ) const [inline]

void MdhSmsDeletionReqArg::SetDeletionCmd ( const MdhDeletionCmd & deletion_cmd ) [inline]

void MdhSmsDeletionReqArg::SetPosition ( INT position ) [inline]

void MdhSmsDeletionReqArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsExtendedDataIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsExtendedDataIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsExtendedDataIndArg:

[legend]
Collaboration diagram for MdhSmsExtendedDataIndArg:

[legend]

Public Types

enum | { ID = 5476 }

Public Member Functions

INT | GetPosition () const
const MdhResult & | GetResult () const
UINT8 | GetView () const
MdhSmsExtendedDataIndArg ()
void | SetPosition (INT position)
void | SetResult (const MdhResult &result)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsExtendedDataIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsExtendedDataIndArg: reflects arguments of signal DR_SM_SET_PROPERTY_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsExtendedDataIndArg::MdhSmsExtendedDataIndArg ( )

Member Function Documentation

const MdhSmsExtendedDataIndArg & MdhSmsExtendedDataIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT MdhSmsExtendedDataIndArg::GetPosition ( ) const [inline]

const MdhResult& MdhSmsExtendedDataIndArg::GetResult ( ) const [inline]

UINT8 MdhSmsExtendedDataIndArg::GetView ( ) const [inline]

void MdhSmsExtendedDataIndArg::SetPosition ( INT position ) [inline]

void MdhSmsExtendedDataIndArg::SetResult ( const MdhResult & result ) [inline]

void MdhSmsExtendedDataIndArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsExtendedDataReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsExtendedDataReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsExtendedDataReqArg:

[legend]
Collaboration diagram for MdhSmsExtendedDataReqArg:

[legend]

Public Types

enum | { ID = 6468 }

Public Member Functions

const MdhExtendedData & | GetExtendedData () const
INT | GetPosition () const
UINT8 | GetView () const
MdhSmsExtendedDataReqArg ()
MdhSmsExtendedDataReqArg (UINT8 view, INT position, const MdhExtendedData &extended_data)
void | SetExtendedData (const MdhExtendedData &extended_data)
void | SetPosition (INT position)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsExtendedDataReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsExtendedDataReqArg: reflects arguments of signal DR_SM_SET_PROPERTY_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsExtendedDataReqArg::MdhSmsExtendedDataReqArg | ( | UINT8 | view,
 |  | INT | position,
 |  | const MdhExtendedData & | extended_data
 | ) |

MdhSmsExtendedDataReqArg::MdhSmsExtendedDataReqArg ( )

Member Function Documentation

const MdhSmsExtendedDataReqArg & MdhSmsExtendedDataReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhExtendedData& MdhSmsExtendedDataReqArg::GetExtendedData ( ) const [inline]

INT MdhSmsExtendedDataReqArg::GetPosition ( ) const [inline]

UINT8 MdhSmsExtendedDataReqArg::GetView ( ) const [inline]

void MdhSmsExtendedDataReqArg::SetExtendedData ( const MdhExtendedData & extended_data ) [inline]

void MdhSmsExtendedDataReqArg::SetPosition ( INT position ) [inline]

void MdhSmsExtendedDataReqArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsInitFinishedIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsInitFinishedIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsInitFinishedIndArg:

[legend]
Collaboration diagram for MdhSmsInitFinishedIndArg:

[legend]

Public Types

enum | { ID = 5468 }

Public Member Functions

const MdhWaitIndicatorArray & | GetWaitIndicatorArray () const
BOOLEAN | IsUpdated () const
MdhSmsInitFinishedIndArg ()
void | SetUpdated (BOOLEAN updated)
void | SetWaitIndicatorArray (const MdhWaitIndicatorArray &wait_indicator_array)

Static Public Member Functions

static const MdhSmsInitFinishedIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsInitFinishedIndArg: reflects arguments of signal DR_SM_INIT_FINISHED_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsInitFinishedIndArg::MdhSmsInitFinishedIndArg ( )

Member Function Documentation

const MdhSmsInitFinishedIndArg & MdhSmsInitFinishedIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhWaitIndicatorArray& MdhSmsInitFinishedIndArg::GetWaitIndicatorArray ( ) const [inline]

BOOLEAN MdhSmsInitFinishedIndArg::IsUpdated ( ) const [inline]

void MdhSmsInitFinishedIndArg::SetUpdated ( BOOLEAN updated ) [inline]

void MdhSmsInitFinishedIndArg::SetWaitIndicatorArray ( const MdhWaitIndicatorArray & wait_indicator_array ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsNewMessageIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsNewMessageIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsNewMessageIndArg:

[legend]
Collaboration diagram for MdhSmsNewMessageIndArg:

[legend]

Public Types

enum | { ID = 5467 }

Public Member Functions

const DataCodingScheme & | GetDataCodingScheme () const
const ProtocolIdentifier & | GetProtocolIdentifier () const
INT | GetStoragePosition () const
const Sms::StorageType & | GetStorageType () const
const Tpdu & | GetTpdu () const
const MdhWaitIndicatorArray & | GetWaitIndicatorArray () const
BOOLEAN | IsUpdated () const
MdhSmsNewMessageIndArg ()
void | SetDataCodingScheme (const DataCodingScheme &data_coding_scheme)
void | SetProtocolIdentifier (const ProtocolIdentifier &protocol_identifier)
void | SetStoragePosition (INT storage_position)
void | SetStorageType (const Sms::StorageType &storage_type)
void | SetTpdu (const Tpdu &tpdu)
void | SetUpdated (BOOLEAN updated)
void | SetWaitIndicatorArray (const MdhWaitIndicatorArray &wait_indicator_array)

Static Public Member Functions

static const MdhSmsNewMessageIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsNewMessageIndArg: reflects arguments of signal DR_SM_NEW_MSG_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsNewMessageIndArg::MdhSmsNewMessageIndArg ( )

Member Function Documentation

const MdhSmsNewMessageIndArg & MdhSmsNewMessageIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const DataCodingScheme& MdhSmsNewMessageIndArg::GetDataCodingScheme ( ) const [inline]

const ProtocolIdentifier& MdhSmsNewMessageIndArg::GetProtocolIdentifier ( ) const [inline]

INT MdhSmsNewMessageIndArg::GetStoragePosition ( ) const [inline]

const Sms::StorageType& MdhSmsNewMessageIndArg::GetStorageType ( ) const [inline]

const Tpdu& MdhSmsNewMessageIndArg::GetTpdu ( ) const [inline]

const MdhWaitIndicatorArray& MdhSmsNewMessageIndArg::GetWaitIndicatorArray ( ) const [inline]

BOOLEAN MdhSmsNewMessageIndArg::IsUpdated ( ) const [inline]

void MdhSmsNewMessageIndArg::SetDataCodingScheme ( const DataCodingScheme & data_coding_scheme ) [inline]

void MdhSmsNewMessageIndArg::SetProtocolIdentifier ( const ProtocolIdentifier & protocol_identifier ) [inline]

void MdhSmsNewMessageIndArg::SetStoragePosition ( INT storage_position ) [inline]

void MdhSmsNewMessageIndArg::SetStorageType ( const Sms::StorageType & storage_type ) [inline]

void MdhSmsNewMessageIndArg::SetTpdu ( const Tpdu & tpdu ) [inline]

void MdhSmsNewMessageIndArg::SetUpdated ( BOOLEAN updated ) [inline]

void MdhSmsNewMessageIndArg::SetWaitIndicatorArray ( const MdhWaitIndicatorArray & wait_indicator_array ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsReadIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsReadIndArg:

[legend]
Collaboration diagram for MdhSmsReadIndArg:

[legend]

Public Types

enum | { ID = 5450 }

Public Member Functions

const MdhExtendedData & | GetExtendedData () const
const MdhResult & | GetResult () const
INT | GetSmsId () const
const MdhTimeStamp & | GetTimeStamp () const
const TpduConc & | GetTpduConc () const
const MdhViewHdl & | GetViewHdl () const
MdhSmsReadIndArg ()
void | SetExtendedData (const MdhExtendedData &extended_data)
void | SetResult (const MdhResult &result)
void | SetSmsId (INT sms_id)
void | SetTimeStamp (const MdhTimeStamp &time_stamp)
void | SetTpduConc (const TpduConc &tpdu_conc)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhSmsReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsReadIndArg: reflects arguments of signal DR_SM_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsReadIndArg::MdhSmsReadIndArg ( )

Member Function Documentation

const MdhSmsReadIndArg & MdhSmsReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhExtendedData& MdhSmsReadIndArg::GetExtendedData ( ) const [inline]

const MdhResult& MdhSmsReadIndArg::GetResult ( ) const [inline]

INT MdhSmsReadIndArg::GetSmsId ( ) const [inline]

const MdhTimeStamp& MdhSmsReadIndArg::GetTimeStamp ( ) const [inline]

const TpduConc& MdhSmsReadIndArg::GetTpduConc ( ) const [inline]

const MdhViewHdl& MdhSmsReadIndArg::GetViewHdl ( ) const [inline]

void MdhSmsReadIndArg::SetExtendedData ( const MdhExtendedData & extended_data ) [inline]

void MdhSmsReadIndArg::SetResult ( const MdhResult & result ) [inline]

void MdhSmsReadIndArg::SetSmsId ( INT sms_id ) [inline]

void MdhSmsReadIndArg::SetTimeStamp ( const MdhTimeStamp & time_stamp ) [inline]

void MdhSmsReadIndArg::SetTpduConc ( const TpduConc & tpdu_conc ) [inline]

void MdhSmsReadIndArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsReadReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsReadReqArg:

[legend]
Collaboration diagram for MdhSmsReadReqArg:

[legend]

Public Types

enum | { ID = 6449 }

Public Member Functions

INT | GetSmsId () const
const MdhViewHdl & | GetViewHdl () const
MdhSmsReadReqArg ()
MdhSmsReadReqArg (const MdhViewHdl &view_hdl, INT sms_id=0)
void | SetSmsId (INT sms_id)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhSmsReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsReadReqArg::MdhSmsReadReqArg | ( | const MdhViewHdl & | view_hdl,
 |  | INT | sms_id = 0
 | ) |

MdhSmsReadReqArg::MdhSmsReadReqArg ( )

Member Function Documentation

const MdhSmsReadReqArg & MdhSmsReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT MdhSmsReadReqArg::GetSmsId ( ) const [inline]

const MdhViewHdl& MdhSmsReadReqArg::GetViewHdl ( ) const [inline]

void MdhSmsReadReqArg::SetSmsId ( INT sms_id ) [inline]

void MdhSmsReadReqArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsRefreshIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsRefreshIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsRefreshIndArg:

[legend]
Collaboration diagram for MdhSmsRefreshIndArg:

[legend]

Public Types

enum | { ID = 5464 }

Public Member Functions

UINT8 | GetStatus () const
INT | GetStoragePosition () const
const MdhTimeStamp & | GetTimeStamp () const
MdhSmsRefreshIndArg ()
void | SetStatus (UINT8 status)
void | SetStoragePosition (INT storage_position)
void | SetTimeStamp (const MdhTimeStamp &time_stamp)

Static Public Member Functions

static const MdhSmsRefreshIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsRefreshIndArg: reflects arguments of signal DR_SM_REFRESH_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsRefreshIndArg::MdhSmsRefreshIndArg ( )

Member Function Documentation

const MdhSmsRefreshIndArg & MdhSmsRefreshIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 MdhSmsRefreshIndArg::GetStatus ( ) const [inline]

INT MdhSmsRefreshIndArg::GetStoragePosition ( ) const [inline]

const MdhTimeStamp& MdhSmsRefreshIndArg::GetTimeStamp ( ) const [inline]

void MdhSmsRefreshIndArg::SetStatus ( UINT8 status ) [inline]

void MdhSmsRefreshIndArg::SetStoragePosition ( INT storage_position ) [inline]

void MdhSmsRefreshIndArg::SetTimeStamp ( const MdhTimeStamp & time_stamp ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsReportReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsReportReadIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsReportReadIndArg:

[legend]
Collaboration diagram for MdhSmsReportReadIndArg:

[legend]

Public Types

enum | { ID = 5473 }

Public Member Functions

INT | GetLinkRecNo () const
const MdhSmsrLocation & | GetLocation () const
INT | GetRecNo () const
const MdhResult & | GetResult () const
const SmsrData & | GetSmsrData () const
UINT8 | GetView () const
MdhSmsReportReadIndArg ()
void | SetLinkRecNo (INT link_rec_no)
void | SetLocation (const MdhSmsrLocation &location)
void | SetRecNo (INT rec_no)
void | SetResult (const MdhResult &result)
void | SetSmsrData (const SmsrData &smsr_data)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsReportReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsReportReadIndArg: reflects arguments of signal DR_SMSR_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsReportReadIndArg::MdhSmsReportReadIndArg ( )

Member Function Documentation

const MdhSmsReportReadIndArg & MdhSmsReportReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT MdhSmsReportReadIndArg::GetLinkRecNo ( ) const [inline]

const MdhSmsrLocation& MdhSmsReportReadIndArg::GetLocation ( ) const [inline]

INT MdhSmsReportReadIndArg::GetRecNo ( ) const [inline]

const MdhResult& MdhSmsReportReadIndArg::GetResult ( ) const [inline]

const SmsrData& MdhSmsReportReadIndArg::GetSmsrData ( ) const [inline]

UINT8 MdhSmsReportReadIndArg::GetView ( ) const [inline]

void MdhSmsReportReadIndArg::SetLinkRecNo ( INT link_rec_no ) [inline]

void MdhSmsReportReadIndArg::SetLocation ( const MdhSmsrLocation & location ) [inline]

void MdhSmsReportReadIndArg::SetRecNo ( INT rec_no ) [inline]

void MdhSmsReportReadIndArg::SetResult ( const MdhResult & result ) [inline]

void MdhSmsReportReadIndArg::SetSmsrData ( const SmsrData & smsr_data ) [inline]

void MdhSmsReportReadIndArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsReportReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsReportReadReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsReportReadReqArg:

[legend]
Collaboration diagram for MdhSmsReportReadReqArg:

[legend]

Public Types

enum | { ID = 6465 }

Public Member Functions

INT | GetPosition () const
UINT8 | GetView () const
MdhSmsReportReadReqArg ()
MdhSmsReportReadReqArg (UINT8 view, INT position)
void | SetPosition (INT position)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsReportReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsReportReadReqArg: reflects arguments of signal DR_SMSR_READ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsReportReadReqArg::MdhSmsReportReadReqArg | ( | UINT8 | view,
 |  | INT | position
 | ) |

MdhSmsReportReadReqArg::MdhSmsReportReadReqArg ( )

Member Function Documentation

const MdhSmsReportReadReqArg & MdhSmsReportReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT MdhSmsReportReadReqArg::GetPosition ( ) const [inline]

UINT8 MdhSmsReportReadReqArg::GetView ( ) const [inline]

void MdhSmsReportReadReqArg::SetPosition ( INT position ) [inline]

void MdhSmsReportReadReqArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsSetWaitingReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsSetWaitingReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsSetWaitingReqArg:

[legend]
Collaboration diagram for MdhSmsSetWaitingReqArg:

[legend]

Public Types

enum | { ID = 6462 }

Public Member Functions

const MdhSetWaitIndicatorArray & | GetSetWaitIndicatorArray () const
MdhSmsSetWaitingReqArg ()
MdhSmsSetWaitingReqArg (const MdhSetWaitIndicatorArray &set_wait_indicator_array)
void | SetSetWaitIndicatorArray (const MdhSetWaitIndicatorArray &set_wait_indicator_array)

Static Public Member Functions

static const MdhSmsSetWaitingReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsSetWaitingReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsSetWaitingReqArg::MdhSmsSetWaitingReqArg ( const MdhSetWaitIndicatorArray & set_wait_indicator_array )

MdhSmsSetWaitingReqArg::MdhSmsSetWaitingReqArg ( )

Member Function Documentation

const MdhSmsSetWaitingReqArg & MdhSmsSetWaitingReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhSetWaitIndicatorArray& MdhSmsSetWaitingReqArg::GetSetWaitIndicatorArray ( ) const [inline]

void MdhSmsSetWaitingReqArg::SetSetWaitIndicatorArray ( const MdhSetWaitIndicatorArray & set_wait_indicator_array ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsStatusIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsStatusIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsStatusIndArg:

[legend]
Collaboration diagram for MdhSmsStatusIndArg:

[legend]

Public Types

enum | { ID = 5444 }

Public Member Functions

UINT8 | GetLastUsed () const
UINT8 | GetNotification () const
const MdhResult & | GetResult () const
MdhSmsStatusIndArg ()
void | SetLastUsed (UINT8 last_used)
void | SetNotification (UINT8 notification)
void | SetResult (const MdhResult &result)

Static Public Member Functions

static const MdhSmsStatusIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsStatusIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsStatusIndArg::MdhSmsStatusIndArg ( )

Member Function Documentation

const MdhSmsStatusIndArg & MdhSmsStatusIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 MdhSmsStatusIndArg::GetLastUsed ( ) const [inline]

UINT8 MdhSmsStatusIndArg::GetNotification ( ) const [inline]

const MdhResult& MdhSmsStatusIndArg::GetResult ( ) const [inline]

void MdhSmsStatusIndArg::SetLastUsed ( UINT8 last_used ) [inline]

void MdhSmsStatusIndArg::SetNotification ( UINT8 notification ) [inline]

void MdhSmsStatusIndArg::SetResult ( const MdhResult & result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsStatusReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsStatusReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsStatusReqArg:

[legend]
Collaboration diagram for MdhSmsStatusReqArg:

[legend]

Public Types

enum | { ID = 6443 }

Public Member Functions

MdhSmsStatusReqArg ()

Static Public Member Functions

static const MdhSmsStatusReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsStatusReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsStatusReqArg::MdhSmsStatusReqArg ( )

Member Function Documentation

const MdhSmsStatusReqArg & MdhSmsStatusReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsStorageRefreshIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsStorageRefreshIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsStorageRefreshIndArg:

[legend]
Collaboration diagram for MdhSmsStorageRefreshIndArg:

[legend]

Public Types

enum | { ID = 5465 }

Public Member Functions

const MdhWorkMedia & | GetWorkMedia () const
MdhSmsStorageRefreshIndArg ()
void | SetWorkMedia (const MdhWorkMedia &work_media)

Static Public Member Functions

static const MdhSmsStorageRefreshIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsStorageRefreshIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsStorageRefreshIndArg::MdhSmsStorageRefreshIndArg ( )

Member Function Documentation

const MdhSmsStorageRefreshIndArg & MdhSmsStorageRefreshIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhWorkMedia& MdhSmsStorageRefreshIndArg::GetWorkMedia ( ) const [inline]

void MdhSmsStorageRefreshIndArg::SetWorkMedia ( const MdhWorkMedia & work_media ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsTransmitAckArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsTransmitAckArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsTransmitAckArg:

[legend]
Collaboration diagram for MdhSmsTransmitAckArg:

[legend]

Public Types

enum | { ID = 6464 }

Public Member Functions

INT | GetPosition () const
UINT8 | GetView () const
BOOLEAN | IsShallTransmit () const
MdhSmsTransmitAckArg ()
MdhSmsTransmitAckArg (UINT8 view, INT position, BOOLEAN shall_transmit)
void | SetPosition (INT position)
void | SetShallTransmit (BOOLEAN shall_transmit)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsTransmitAckArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsTransmitAckArg: reflects arguments of signal DR_SM_TRANSMIT_ACK

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsTransmitAckArg::MdhSmsTransmitAckArg | ( | UINT8 | view,
 |  | INT | position,
 |  | BOOLEAN | shall_transmit
 | ) |

MdhSmsTransmitAckArg::MdhSmsTransmitAckArg ( )

Member Function Documentation

const MdhSmsTransmitAckArg & MdhSmsTransmitAckArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT MdhSmsTransmitAckArg::GetPosition ( ) const [inline]

UINT8 MdhSmsTransmitAckArg::GetView ( ) const [inline]

BOOLEAN MdhSmsTransmitAckArg::IsShallTransmit ( ) const [inline]

void MdhSmsTransmitAckArg::SetPosition ( INT position ) [inline]

void MdhSmsTransmitAckArg::SetShallTransmit ( BOOLEAN shall_transmit ) [inline]

void MdhSmsTransmitAckArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsTransmitIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsTransmitIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsTransmitIndArg:

[legend]
Collaboration diagram for MdhSmsTransmitIndArg:

[legend]

Public Types

enum | { ID = 5471 }

Public Member Functions

const MdhExtendedData & | GetExtendedData () const
INT | GetPosition () const
const MdhTimeStamp & | GetTimeStamp () const
const Tpdu & | GetTpdu () const
UINT8 | GetView () const
const MdhWorkMedia & | GetWorkMedia () const
MdhSmsTransmitIndArg ()
void | SetExtendedData (const MdhExtendedData &extended_data)
void | SetPosition (INT position)
void | SetTimeStamp (const MdhTimeStamp &time_stamp)
void | SetTpdu (const Tpdu &tpdu)
void | SetView (UINT8 view)
void | SetWorkMedia (const MdhWorkMedia &work_media)

Static Public Member Functions

static const MdhSmsTransmitIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsTransmitIndArg: reflects arguments of signal DR_SM_TRANSMIT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsTransmitIndArg::MdhSmsTransmitIndArg ( )

Member Function Documentation

const MdhSmsTransmitIndArg & MdhSmsTransmitIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhExtendedData& MdhSmsTransmitIndArg::GetExtendedData ( ) const [inline]

INT MdhSmsTransmitIndArg::GetPosition ( ) const [inline]

const MdhTimeStamp& MdhSmsTransmitIndArg::GetTimeStamp ( ) const [inline]

const Tpdu& MdhSmsTransmitIndArg::GetTpdu ( ) const [inline]

UINT8 MdhSmsTransmitIndArg::GetView ( ) const [inline]

const MdhWorkMedia& MdhSmsTransmitIndArg::GetWorkMedia ( ) const [inline]

void MdhSmsTransmitIndArg::SetExtendedData ( const MdhExtendedData & extended_data ) [inline]

void MdhSmsTransmitIndArg::SetPosition ( INT position ) [inline]

void MdhSmsTransmitIndArg::SetTimeStamp ( const MdhTimeStamp & time_stamp ) [inline]

void MdhSmsTransmitIndArg::SetTpdu ( const Tpdu & tpdu ) [inline]

void MdhSmsTransmitIndArg::SetView ( UINT8 view ) [inline]

void MdhSmsTransmitIndArg::SetWorkMedia ( const MdhWorkMedia & work_media ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsTransmitStartAckArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsTransmitStartAckArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsTransmitStartAckArg:

[legend]
Collaboration diagram for MdhSmsTransmitStartAckArg:

[legend]

Public Types

enum | { ID = 6463 }

Public Member Functions

UINT8 | GetView () const
BOOLEAN | IsShallTransmit () const
MdhSmsTransmitStartAckArg ()
MdhSmsTransmitStartAckArg (UINT8 view, BOOLEAN shall_transmit)
void | SetShallTransmit (BOOLEAN shall_transmit)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsTransmitStartAckArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsTransmitStartAckArg: reflects arguments of signal DR_SM_TRANSMIT_START_ACK

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsTransmitStartAckArg::MdhSmsTransmitStartAckArg | ( | UINT8 | view,
 |  | BOOLEAN | shall_transmit
 | ) |

MdhSmsTransmitStartAckArg::MdhSmsTransmitStartAckArg ( )

Member Function Documentation

const MdhSmsTransmitStartAckArg & MdhSmsTransmitStartAckArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 MdhSmsTransmitStartAckArg::GetView ( ) const [inline]

BOOLEAN MdhSmsTransmitStartAckArg::IsShallTransmit ( ) const [inline]

void MdhSmsTransmitStartAckArg::SetShallTransmit ( BOOLEAN shall_transmit ) [inline]

void MdhSmsTransmitStartAckArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsTransmitStartIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsTransmitStartIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsTransmitStartIndArg:

[legend]
Collaboration diagram for MdhSmsTransmitStartIndArg:

[legend]

Public Types

enum | { ID = 5470 }

Public Member Functions

INT | GetNoNvramSms () const
INT | GetNoSimSms () const
const MdhTransmitCause & | GetTransmitCause () const
UINT8 | GetView () const
MdhSmsTransmitStartIndArg ()
void | SetNoNvramSms (INT no_nvram_sms)
void | SetNoSimSms (INT no_sim_sms)
void | SetTransmitCause (const MdhTransmitCause &transmit_cause)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsTransmitStartIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsTransmitStartIndArg: reflects arguments of signal DR_SM_TRANSMIT_START_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsTransmitStartIndArg::MdhSmsTransmitStartIndArg ( )

Member Function Documentation

const MdhSmsTransmitStartIndArg & MdhSmsTransmitStartIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT MdhSmsTransmitStartIndArg::GetNoNvramSms ( ) const [inline]

INT MdhSmsTransmitStartIndArg::GetNoSimSms ( ) const [inline]

const MdhTransmitCause& MdhSmsTransmitStartIndArg::GetTransmitCause ( ) const [inline]

UINT8 MdhSmsTransmitStartIndArg::GetView ( ) const [inline]

void MdhSmsTransmitStartIndArg::SetNoNvramSms ( INT no_nvram_sms ) [inline]

void MdhSmsTransmitStartIndArg::SetNoSimSms ( INT no_sim_sms ) [inline]

void MdhSmsTransmitStartIndArg::SetTransmitCause ( const MdhTransmitCause & transmit_cause ) [inline]

void MdhSmsTransmitStartIndArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsTransmitStopIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsTransmitStopIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsTransmitStopIndArg:

[legend]
Collaboration diagram for MdhSmsTransmitStopIndArg:

[legend]

Public Types

enum | { ID = 5472 }

Public Member Functions

const MdhResult & | GetResult () const
UINT8 | GetView () const
MdhSmsTransmitStopIndArg ()
void | SetResult (const MdhResult &result)
void | SetView (UINT8 view)

Static Public Member Functions

static const MdhSmsTransmitStopIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsTransmitStopIndArg: reflects arguments of signal DR_SM_TRANSMIT_STOP_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsTransmitStopIndArg::MdhSmsTransmitStopIndArg ( )

Member Function Documentation

const MdhSmsTransmitStopIndArg & MdhSmsTransmitStopIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhResult& MdhSmsTransmitStopIndArg::GetResult ( ) const [inline]

UINT8 MdhSmsTransmitStopIndArg::GetView ( ) const [inline]

void MdhSmsTransmitStopIndArg::SetResult ( const MdhResult & result ) [inline]

void MdhSmsTransmitStopIndArg::SetView ( UINT8 view ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsUpdStatusIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsUpdStatusIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsUpdStatusIndArg:

[legend]
Collaboration diagram for MdhSmsUpdStatusIndArg:

[legend]

Public Types

enum | { ID = 5446 }

Public Member Functions

INT | GetRecno () const
const MdhResult & | GetResult () const
const MdhViewHdl & | GetViewHdl () const
MdhSmsUpdStatusIndArg ()
void | SetRecno (INT recno)
void | SetResult (const MdhResult &result)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhSmsUpdStatusIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsUpdStatusIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsUpdStatusIndArg::MdhSmsUpdStatusIndArg ( )

Member Function Documentation

const MdhSmsUpdStatusIndArg & MdhSmsUpdStatusIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT MdhSmsUpdStatusIndArg::GetRecno ( ) const [inline]

const MdhResult& MdhSmsUpdStatusIndArg::GetResult ( ) const [inline]

const MdhViewHdl& MdhSmsUpdStatusIndArg::GetViewHdl ( ) const [inline]

void MdhSmsUpdStatusIndArg::SetRecno ( INT recno ) [inline]

void MdhSmsUpdStatusIndArg::SetResult ( const MdhResult & result ) [inline]

void MdhSmsUpdStatusIndArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsUpdStatusRefreshIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsUpdStatusRefreshIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsUpdStatusRefreshIndArg:

[legend]
Collaboration diagram for MdhSmsUpdStatusRefreshIndArg:

[legend]

Public Types

enum | { ID = 5466 }

Public Member Functions

UINT8 | GetStatus () const
INT | GetStoragePosition () const
MdhSmsUpdStatusRefreshIndArg ()
void | SetStatus (UINT8 status)
void | SetStoragePosition (INT storage_position)

Static Public Member Functions

static const MdhSmsUpdStatusRefreshIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsUpdStatusRefreshIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsUpdStatusRefreshIndArg::MdhSmsUpdStatusRefreshIndArg ( )

Member Function Documentation

const MdhSmsUpdStatusRefreshIndArg & MdhSmsUpdStatusRefreshIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 MdhSmsUpdStatusRefreshIndArg::GetStatus ( ) const [inline]

INT MdhSmsUpdStatusRefreshIndArg::GetStoragePosition ( ) const [inline]

void MdhSmsUpdStatusRefreshIndArg::SetStatus ( UINT8 status ) [inline]

void MdhSmsUpdStatusRefreshIndArg::SetStoragePosition ( INT storage_position ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsUpdStatusReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsUpdStatusReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsUpdStatusReqArg:

[legend]
Collaboration diagram for MdhSmsUpdStatusReqArg:

[legend]

Public Types

enum | { ID = 6445 }

Public Member Functions

UINT8 | GetComplete () const
UINT8 | GetRecstatus () const
INT | GetSmsId () const
const MdhViewHdl & | GetViewHdl () const
MdhSmsUpdStatusReqArg ()
MdhSmsUpdStatusReqArg (const MdhViewHdl &view_hdl, INT sms_id, UINT8 recstatus, UINT8 complete)
void | SetComplete (UINT8 complete)
void | SetRecstatus (UINT8 recstatus)
void | SetSmsId (INT sms_id)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhSmsUpdStatusReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsUpdStatusReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsUpdStatusReqArg::MdhSmsUpdStatusReqArg | ( | const MdhViewHdl & | view_hdl,
 |  | INT | sms_id,
 |  | UINT8 | recstatus,
 |  | UINT8 | complete
 | ) |

MdhSmsUpdStatusReqArg::MdhSmsUpdStatusReqArg ( )

Member Function Documentation

const MdhSmsUpdStatusReqArg & MdhSmsUpdStatusReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 MdhSmsUpdStatusReqArg::GetComplete ( ) const [inline]

UINT8 MdhSmsUpdStatusReqArg::GetRecstatus ( ) const [inline]

INT MdhSmsUpdStatusReqArg::GetSmsId ( ) const [inline]

const MdhViewHdl& MdhSmsUpdStatusReqArg::GetViewHdl ( ) const [inline]

void MdhSmsUpdStatusReqArg::SetComplete ( UINT8 complete ) [inline]

void MdhSmsUpdStatusReqArg::SetRecstatus ( UINT8 recstatus ) [inline]

void MdhSmsUpdStatusReqArg::SetSmsId ( INT sms_id ) [inline]

void MdhSmsUpdStatusReqArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsWaitingIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsWaitingIndArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsWaitingIndArg:

[legend]
Collaboration diagram for MdhSmsWaitingIndArg:

[legend]

Public Types

enum | { ID = 5469 }

Public Member Functions

const MdhWaitIndicatorArray & | GetWaitIndicatorArray () const
BOOLEAN | IsUpdated () const
MdhSmsWaitingIndArg ()
void | SetUpdated (BOOLEAN updated)
void | SetWaitIndicatorArray (const MdhWaitIndicatorArray &wait_indicator_array)

Static Public Member Functions

static const MdhSmsWaitingIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsWaitingIndArg: reflects arguments of signal DR_SM_WAIT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsWaitingIndArg::MdhSmsWaitingIndArg ( )

Member Function Documentation

const MdhSmsWaitingIndArg & MdhSmsWaitingIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MdhWaitIndicatorArray& MdhSmsWaitingIndArg::GetWaitIndicatorArray ( ) const [inline]

BOOLEAN MdhSmsWaitingIndArg::IsUpdated ( ) const [inline]

void MdhSmsWaitingIndArg::SetUpdated ( BOOLEAN updated ) [inline]

void MdhSmsWaitingIndArg::SetWaitIndicatorArray ( const MdhWaitIndicatorArray & wait_indicator_array ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsWriteCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsWriteCnfArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsWriteCnfArg:

[legend]
Collaboration diagram for MdhSmsWriteCnfArg:

[legend]

Public Types

enum | { ID = 5452 }

Public Member Functions

UINT8 | GetNoOfSaved () const
const MdhResult & | GetResult () const
INT | GetSmsId () const
const MdhTimeStamp & | GetTimeStamp () const
const MdhViewHdl & | GetViewHdl () const
MdhSmsWriteCnfArg ()
void | SetNoOfSaved (UINT8 no_of_saved)
void | SetResult (const MdhResult &result)
void | SetSmsId (INT sms_id)
void | SetTimeStamp (const MdhTimeStamp &time_stamp)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhSmsWriteCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsWriteCnfArg: reflects arguments of signal DR_SM_WRITE_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsWriteCnfArg::MdhSmsWriteCnfArg ( )

Member Function Documentation

const MdhSmsWriteCnfArg & MdhSmsWriteCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 MdhSmsWriteCnfArg::GetNoOfSaved ( ) const [inline]

const MdhResult& MdhSmsWriteCnfArg::GetResult ( ) const [inline]

INT MdhSmsWriteCnfArg::GetSmsId ( ) const [inline]

const MdhTimeStamp& MdhSmsWriteCnfArg::GetTimeStamp ( ) const [inline]

const MdhViewHdl& MdhSmsWriteCnfArg::GetViewHdl ( ) const [inline]

void MdhSmsWriteCnfArg::SetNoOfSaved ( UINT8 no_of_saved ) [inline]

void MdhSmsWriteCnfArg::SetResult ( const MdhResult & result ) [inline]

void MdhSmsWriteCnfArg::SetSmsId ( INT sms_id ) [inline]

void MdhSmsWriteCnfArg::SetTimeStamp ( const MdhTimeStamp & time_stamp ) [inline]

void MdhSmsWriteCnfArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhSmsWriteReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhSmsWriteReqArg Class Reference

#include <Apoxi/Apc/MdhSmsStackMsgArgs.hpp>

Inheritance diagram for MdhSmsWriteReqArg:

[legend]
Collaboration diagram for MdhSmsWriteReqArg:

[legend]

Public Types

enum | { ID = 6451 }

Public Member Functions

const TpduNode & | GetPduNode () const
INT | GetSmsId () const
const MdhViewHdl & | GetViewHdl () const
MdhSmsWriteReqArg ()
MdhSmsWriteReqArg (const MdhViewHdl &view_hdl, INT sms_id, const TpduNode &pdu_node)
void | SetPduNode (const TpduNode &pdu_node)
void | SetSmsId (INT sms_id)
void | SetViewHdl (const MdhViewHdl &view_hdl)

Static Public Member Functions

static const MdhSmsWriteReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MdhSmsWriteReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MdhSmsWriteReqArg::MdhSmsWriteReqArg | ( | const MdhViewHdl & | view_hdl,
 |  | INT | sms_id,
 |  | const TpduNode & | pdu_node
 | ) |

MdhSmsWriteReqArg::MdhSmsWriteReqArg ( )

Member Function Documentation

const MdhSmsWriteReqArg & MdhSmsWriteReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const TpduNode& MdhSmsWriteReqArg::GetPduNode ( ) const [inline]

INT MdhSmsWriteReqArg::GetSmsId ( ) const [inline]

const MdhViewHdl& MdhSmsWriteReqArg::GetViewHdl ( ) const [inline]

void MdhSmsWriteReqArg::SetPduNode ( const TpduNode & pdu_node ) [inline]

void MdhSmsWriteReqArg::SetSmsId ( INT sms_id ) [inline]

void MdhSmsWriteReqArg::SetViewHdl ( const MdhViewHdl & view_hdl ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MdhSmsStackMsgArgs.hpp
  • Apc/MdhSmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:26:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhViewConfig Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhViewConfig Struct Reference

MdhViewConfig (ms.h: T_DR_SM_VIEW_CONFIG). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Data Fields

MdhFilter filter
MdhSorting sort
MdhWorkMedia storage

Detailed Description

MdhViewConfig (ms.h: T_DR_SM_VIEW_CONFIG).

Field Documentation

MdhFilter MdhViewConfig::filter

MdhSorting MdhViewConfig::sort

MdhWorkMedia MdhViewConfig::storage

The documentation for this struct was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:26:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhWaitIndicator Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhWaitIndicator Struct Reference

MdhWaitIndicator (ms.h: T_DR_WAIT_INDICATOR). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Data Fields

UINT8 | count
MdhWaitIndicatorLevel level
INT | pos
MdhWaitIndicatorSetting setting
MdhWaitIndicatorSmsType smstype
BOOLEAN | update

Detailed Description

MdhWaitIndicator (ms.h: T_DR_WAIT_INDICATOR).

Field Documentation

UINT8 MdhWaitIndicator::count

MdhWaitIndicatorLevel MdhWaitIndicator::level

INT MdhWaitIndicator::pos

MdhWaitIndicatorSetting MdhWaitIndicator::setting

MdhWaitIndicatorSmsType MdhWaitIndicator::smstype

BOOLEAN MdhWaitIndicator::update

The documentation for this struct was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:26:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MdhWaitIndicatorArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MdhWaitIndicatorArray Struct Reference

MdhWaitIndicator (ms.h: T_DR_WAIT_INDICATOR_ARR). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Collaboration diagram for MdhWaitIndicatorArray:

[legend]

Data Fields

MdhWaitIndicator val [MdhNofMdhWaitTypes]

Detailed Description

MdhWaitIndicator (ms.h: T_DR_WAIT_INDICATOR_ARR).

Field Documentation

MdhWaitIndicator MdhWaitIndicatorArray::val[MdhNofMdhWaitTypes]

The documentation for this struct was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 01:26:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MeasurementData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MeasurementData Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpTypes.hpp>

Collaboration diagram for MeasurementData:

[legend]

Public Member Functions

const GpsFixData & | GetGpsFixData () const
INT | GetLength () const
BYTE * | GetMsrData () const
UINT32 | GetStatus () const
MeasurementData (const MeasurementData &rhs)
Copy constructor.
MeasurementData (UINT8 status, INT size, const BYTE *buffer, const GpsFixDataInt &fix_data_int)
Argument constructor.
MeasurementData ()
Default constructor.
~MeasurementData ()
Destructor.

Constructor & Destructor Documentation

MeasurementData::MeasurementData ( ) [inline]

Default constructor.

MeasurementData::MeasurementData | ( | UINT8 | status,
 |  | INT | size,
 |  | const BYTE * | buffer,
 |  | const GpsFixDataInt & | fix_data_int
 | ) | [inline]

Argument constructor.

MeasurementData::MeasurementData ( const MeasurementData & rhs ) [inline]

Copy constructor.

MeasurementData::~MeasurementData ( ) [inline]

Destructor.

Member Function Documentation

const GpsFixData& MeasurementData::GetGpsFixData ( ) const [inline]

INT MeasurementData::GetLength ( ) const [inline]

BYTE* MeasurementData::GetMsrData ( ) const [inline]

UINT32 MeasurementData::GetStatus ( ) const [inline]

The documentation for this class was generated from the following file:
  • AddOns/Lcs/GLTP/GltpTypes.hpp
Generated on Wed Jan 25 01:26:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MeasurementDataArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MeasurementDataArg Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpArgs.hpp>

Inheritance diagram for MeasurementDataArg:

[legend]
Collaboration diagram for MeasurementDataArg:

[legend]

Public Types

enum | { ID = 4225 }

Public Member Functions

const MeasurementData & | GetMsrData () const
MeasurementDataArg ()
MeasurementDataArg (const MeasurementData &msr_data)
~MeasurementDataArg ()

Static Public Member Functions

static const MeasurementDataArg & | Cast (const StackMsgArgument &arg)

Friends

class | GltpStackMsgArgsDestroyTableNode

Detailed Description

This argument is sent to GltpProviderImpl to deliver the GPS mesurements

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MeasurementDataArg::MeasurementDataArg ( const MeasurementData & msr_data )

MeasurementDataArg::MeasurementDataArg ( )

MeasurementDataArg::~MeasurementDataArg ( )

Member Function Documentation

const MeasurementDataArg & MeasurementDataArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MeasurementData& MeasurementDataArg::GetMsrData ( ) const [inline]

Friends And Related Function Documentation

friend class GltpStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpArgs.hpp
  • AddOns/Lcs/GLTP/GltpArgs.cpp
Generated on Wed Jan 25 01:26:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Media Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Media Class Reference

#include <Apoxi/AddOns/MediaFramework/Media.hpp>

Inheritance diagram for Media:

[legend]
Collaboration diagram for Media:

[legend]

Public Member Functions

virtual BinData * | GetBinData ()
virtual UINT32 | GetDuration ()
virtual void | GetFrameRate (UINT16 &frame_rate_numerator, UINT16 &frame_rate_denominator)
virtual MimeType | GetMimeType ()
virtual Size | GetResolution ()
Media (BinData *bin_data, Parameters &params)
Media (BinData *bin_data, MimeType mime_type)
virtual | ~Media ()

Friends

class | MediaObtainer

Data Structures

struct | Parameters

Constructor & Destructor Documentation

Media::Media | ( | BinData * | bin_data,
 |  | MimeType | mime_type
 | ) |

Media::Media | ( | BinData * | bin_data,
 |  | Parameters & | params
 | ) |

virtual Media::~Media ( ) [inline, virtual]

Member Function Documentation

BinData * Media::GetBinData ( ) [virtual]

UINT32 Media::GetDuration ( ) [virtual]

void Media::GetFrameRate | ( | UINT16 & | frame_rate_numerator,
 |  | UINT16 & | frame_rate_denominator
 | ) | [virtual]

Returns the frame rate. Actual frame rate (in frames/sec) is calculated as frame_rate_numerator/frame_rate_denominator.

Parameters:
frame_rate_numerator | On return it contains the frame rate numerator.
frame_rate_denominator | On return it contains the frame rate denominator.

MimeType Media::GetMimeType ( ) [virtual]

Size Media::GetResolution ( ) [virtual]

Friends And Related Function Documentation

friend class MediaObtainer [friend]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/Media.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/Media.cpp
Generated on Wed Jan 25 01:26:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Media::Parameters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Media::Parameters

Media::Parameters Struct Reference

#include <Apoxi/AddOns/MediaFramework/Media.hpp>

Collaboration diagram for Media::Parameters:

[legend]

Data Fields

UINT32 | duration
UINT16 | frame_rate_denominator
UINT16 | frame_rate_numerator
MimeType mime_type
Size resolution

Field Documentation

UINT32 Media::Parameters::duration

UINT16 Media::Parameters::frame_rate_denominator

Frame rate denominator. Actual frame rate (in frames/sec) is calculated as m_frame_rate_numerator/m_frame_rate_denominator.

UINT16 Media::Parameters::frame_rate_numerator

Frame rate numerator. Actual frame rate (in frames/sec) is calculated as m_frame_rate_numerator/m_frame_rate_denominator.

MimeType Media::Parameters::mime_type

Size Media::Parameters::resolution

The documentation for this struct was generated from the following file:
  • AddOns/MediaFramework/Media.hpp
Generated on Wed Jan 25 01:26:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaBox Class Reference

#include <Apoxi/AddOns/MediaFramework/MediaBox.hpp>

Inheritance diagram for MediaBox:

[legend]
Collaboration diagram for MediaBox:

[legend]

Public Member Functions

MediaPlayer * | CreatePlayerInstance (char *media_source, MediaInfo &media_info, MimeType &media_mime_type, void *mesg_dispatcher, MediaManager::MmfResult &mmf_result)
MediaPlayer * | CreatePlayerInstance (BinData *media_source, MediaInfo &media_info, MimeType &media_mime_type, void *mesg_dispatcher, MediaManager::MmfResult &mmf_result)
void | DestroyPlayerInstance (MediaPlayer *media_player)
MediaPlayer * GetPlayerInstance ()
virtual void | Init (Control *parent)
MediaBox ()
virtual | ~MediaBox ()

Constructor & Destructor Documentation

MediaBox::MediaBox ( )

MediaBox::~MediaBox ( ) [virtual]

Member Function Documentation

MediaPlayer * MediaBox::CreatePlayerInstance | ( | char * | media_source,
 |  | MediaInfo & | media_info,
 |  | MimeType & | media_mime_type,
 |  | void * | mesg_dispatcher,
 |  | MediaManager::MmfResult & | mmf_result
 | ) |

MediaPlayer * MediaBox::CreatePlayerInstance | ( | BinData * | media_source,
 |  | MediaInfo & | media_info,
 |  | MimeType & | media_mime_type,
 |  | void * | mesg_dispatcher,
 |  | MediaManager::MmfResult & | mmf_result
 | ) |

void MediaBox::DestroyPlayerInstance ( MediaPlayer * media_player )

MediaPlayer * MediaBox::GetPlayerInstance ( )

void MediaBox::Init ( Control * parent ) [virtual]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaBox.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaBox.cpp
Generated on Wed Jan 25 01:27:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaBoxView Class Reference

#include <Apoxi/AddOns/MediaFramework/MediaBox.hpp>

Inheritance diagram for MediaBoxView:

[legend]
Collaboration diagram for MediaBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
MediaBoxView ()
virtual | ~MediaBoxView ()

Constructor & Destructor Documentation

MediaBoxView::MediaBoxView ( )

MediaBoxView::~MediaBoxView ( ) [virtual]

Member Function Documentation

void MediaBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaBox.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaBox.cpp
Generated on Wed Jan 25 01:27:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaBrowserUtils Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaBrowserUtils Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

Utility class for SB and IB. More...

#include <Applications/ImageBrowser/Common/MediaBrowserUtils.hpp>

Collaboration diagram for MediaBrowserUtils:

[legend]

Public Member Functions

MmiDialog::ReturnId | DisplayDlg (const WString &msg, MmiInfoBox::MmiInfoBoxType type=MmiInfoBox::Error) const
MmiDialog::ReturnId | DisplayDlg (const WString &msg, MmiInfoBox::MmiInfoBoxType type=MmiInfoBox::Error) const
BOOLEAN | ValidateFileName (const WString &name)
Validates a Path for invalid characters.
BOOLEAN | ValidateFileName (const WString &name)
Validates a Path for invalid characters.
~MediaBrowserUtils ()
Destructor.
~MediaBrowserUtils ()
Destructor.

Static Public Member Functions

static MediaBrowserUtils * | GetInstance ()
static MediaBrowserUtils * | GetInstance ()

Detailed Description

Utility class for SB and IB.

Constructor & Destructor Documentation

MediaBrowserUtils::~MediaBrowserUtils ( )

Destructor.

MediaBrowserUtils::~MediaBrowserUtils ( )

Destructor.

Member Function Documentation

MmiDialog::ReturnId MediaBrowserUtils::DisplayDlg | ( | const WString & | msg,
 |  | MmiInfoBox::MmiInfoBoxType | type = MmiInfoBox::Error
 | ) | const

MmiDialog::ReturnId MediaBrowserUtils::DisplayDlg | ( | const WString & | msg,
 |  | MmiInfoBox::MmiInfoBoxType | type = MmiInfoBox::Error
 | ) | const

static MediaBrowserUtils* MediaBrowserUtils::GetInstance ( ) [static]

MediaBrowserUtils * MediaBrowserUtils::GetInstance ( ) [static]

BOOLEAN MediaBrowserUtils::ValidateFileName ( const WString & name )

Validates a Path for invalid characters.

BOOLEAN MediaBrowserUtils::ValidateFileName ( const WString & name )

Validates a Path for invalid characters.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaBrowserUtils.hpp
  • Applications/SoundBrowser/Common/MediaBrowserUtils.hpp
  • Applications/ImageBrowser/Common/MediaBrowserUtils.cpp
  • Applications/SoundBrowser/Common/MediaBrowserUtils.cpp
Generated on Wed Jan 25 01:27:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaFilter Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

Base class for filter that can be used by the image or sound browser. More...

#include <Applications/ImageBrowser/Common/MediaFilter.hpp>

Inheritance diagram for MediaFilter:

[legend]

Public Member Functions

virtual BOOLEAN | IsAllowed (const MediaRef &media_ref) const
Returns if media_ref is allowed to be shown.
virtual BOOLEAN | IsAllowed (const MediaRef &media_ref) const
Returns if media_ref is allowed to be shown.
MediaFilter ()
MediaFilter ()
virtual | ~MediaFilter ()
virtual | ~MediaFilter ()

Detailed Description

Base class for filter that can be used by the image or sound browser.

Constructor & Destructor Documentation

MediaFilter::MediaFilter ( )

MediaFilter::~MediaFilter ( ) [virtual]

MediaFilter::MediaFilter ( )

virtual MediaFilter::~MediaFilter ( ) [virtual]

Member Function Documentation

virtual BOOLEAN MediaFilter::IsAllowed ( const MediaRef & media_ref ) const [virtual]

Returns if media_ref is allowed to be shown.

Reimplemented in ImageFilter, SoundFilter, MimeTypeFilter, ImageFilter, SoundFilter, and MimeTypeFilter.

BOOLEAN MediaFilter::IsAllowed ( const MediaRef & media_ref ) const [virtual]

Returns if media_ref is allowed to be shown.

Reimplemented in ImageFilter, SoundFilter, MimeTypeFilter, ImageFilter, SoundFilter, and MimeTypeFilter.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaFilter.hpp
  • Applications/SoundBrowser/Common/MediaFilter.hpp
  • Applications/ImageBrowser/Common/MediaFilter.cpp
  • Applications/SoundBrowser/Common/MediaFilter.cpp
Generated on Wed Jan 25 01:27:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaFrameworkCaps Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaFrameworkCaps Class Reference
[MediaFramework]

#include <Apoxi/AddOns/MediaFramework/MediaFrameworkCaps.hpp>

Public Member Functions

const MediaFrameworkCaps * | GetCapabilities () const
MediaInfo::MediaCodec | GetDecoderCodec (INT index) const
MediaInfo::MediaCodec | GetEncoderCodec (INT index) const
INT | GetSupportedDecoderCodecsCount () const
INT | GetSupportedEncoderCodecsCount () const
BOOLEAN | IsDecoderCodecSupported (MediaInfo::MediaCodec codec) const
BOOLEAN | IsEncoderCodecSupported (MediaInfo::MediaCodec codec) const
MediaFrameworkCaps ()

Detailed Description

MediaFramework Capabilities

Constructor & Destructor Documentation

MediaFrameworkCaps::MediaFrameworkCaps ( )

Default constructor

Member Function Documentation

const MediaFrameworkCaps* MediaFrameworkCaps::GetCapabilities ( ) const

Returns the MediaFramework capablities.

Returns:
A pointer to a class containing the framework capabilities; In case of failure a NULL pointer.

MediaInfo::MediaCodec MediaFrameworkCaps::GetDecoderCodec ( INT index ) const

This method returns the codec (for decoding) corresponding to the index.

Parameters:
index The index of the info object. Valid values are between 0 and GetSupportedMediaDecCodecsCount()-1.
Returns:
The MediaInfo::MediaCodec; In case the index parameter is not valid MediaInfo::UnknownCodec shall be returned.

MediaInfo::MediaCodec MediaFrameworkCaps::GetEncoderCodec ( INT index ) const

This method returns the codec (for encoding) corresponding to the index.

Parameters:
index The index of the info object. Valid values are between 0 and GetSupportedMediaEncCodecsCount()-1.
Returns:
The MediaInfo::MediaCodec; In case the index parameter is not valid MediaInfo::UnknownCodec shall be returned.

INT MediaFrameworkCaps::GetSupportedDecoderCodecsCount ( ) const

This method returns the total number of supported audio/video codecs (for decoding).

Returns:
The number of supported codecs.

INT MediaFrameworkCaps::GetSupportedEncoderCodecsCount ( ) const

This method returns the total number of supported audio/video codecs for encoding.

Returns:
The number of supported codecs.

BOOLEAN MediaFrameworkCaps::IsDecoderCodecSupported ( MediaInfo::MediaCodec codec ) const

This method provides an information if a specific audio/video codec (for decoding) is supported by the framework.

Parameters:
codec The framework will verify if the codec passed by this parameter is supported by it.
Returns:
TRUE if the codec is supported by the framework; FALSE otherwise

BOOLEAN MediaFrameworkCaps::IsEncoderCodecSupported ( MediaInfo::MediaCodec codec ) const

This method provides an information if a specific audio/video codec (for encoding) is supported by the framework.

Parameters:
codec The framework will verify if the codec passed by this parameter is supported by it.
Returns:
TRUE if the codec is supported by the framework; FALSE otherwise

The documentation for this class was generated from the following file:
  • AddOns/MediaFramework/MediaFrameworkCaps.hpp
Generated on Wed Jan 25 01:27:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaInfo Class Reference
[MediaFramework]

#include <Apoxi/AddOns/MediaFramework/MediaInfo.hpp>

Collaboration diagram for MediaInfo:

[legend]

Public Types

enum MediaCodec {
DefaultCodec, UnknownCodec, Mpeg4Sp, H263Bl,
GsmAmrNb, Mpeg4Aac, Qcelp, Evrc,
Mp3, Mpeg4AacPlusV1, Mpeg4AacPlusV2, H264Bp,
EndOfCodecType
}

Public Member Functions

BOOLEAN | AddAudioInfo (const AudioTrackInfo &info)
BOOLEAN | AddVideoInfo (const VideoTrackInfo &info)
const AudioTrackInfo * | GetAudioInfo (INT index) const
INT | GetAudioInfoCount () const
const ClipInfo & | GetClipInfo () const
const VideoTrackInfo * | GetVideoInfo (INT index) const
INT | GetVideoInfoCount () const
MediaInfo ()
BOOLEAN | ReInit ()
BOOLEAN | SetClipInfo (ClipInfo &clip_info)
BOOLEAN | SetClipInfo (UINT8 *title, UINT8 *author, UINT8 *copyright, UINT8 *rating, UINT8 *description)
~MediaInfo ()

Friends

class | EmApoxiMediaInfo

Data Structures

class | AudioTrackInfo
class | ClipInfo
class | MediaTrackInfo
class | VideoTrackInfo

Member Enumeration Documentation

enum MediaInfo::MediaCodec

Media (audio/video) codec

Enumerator:
DefaultCodec | Media Framework should select a suitable/default codec. It is used for recording purposes.
UnknownCodec | Codec is unknown to the MMF.
Mpeg4Sp | MPEG-4SP.
H263Bl | H.263 Baseline.
GsmAmrNb | GSM AMR-NB.
Mpeg4Aac | AAC.
Qcelp | QCELP.
Evrc | EVRC.
Mp3 | MP3.
Mpeg4AacPlusV1 | AAC-Plus V1 (= AAC+ = HE-AAC = AAC-LC + SBR).
Mpeg4AacPlusV2 | AAC-Plus V2 (= AAC++ = Enhanced AAC+ = AAC-LC + SBR + PS).
H264Bp | H.264 Baseline Profile.
EndOfCodecType

Constructor & Destructor Documentation

MediaInfo::MediaInfo ( )

DefaultConstructor

MediaInfo::~MediaInfo ( )

Member Function Documentation

BOOLEAN MediaInfo::AddAudioInfo ( const AudioTrackInfo & info )

Appends an AudioTrackInfo object to the audio info list. This class takes ownership of the passed info object, i.e. this class is responsible for destroying of this object. It must not be destroyed by the application using this method.

Parameters:
info Track info object that has to be appended.
Returns:
TRUE if the object could be appended successfully, FALSE otherwise

BOOLEAN MediaInfo::AddVideoInfo ( const VideoTrackInfo & info )

Appends a VideoTrackInfo object to the video info list. This class takes ownership of the passed info object, i.e. this class is responsible for destroying of this object. It must not be destroyed by the application using this method.

Parameters:
info Track info object that has to be appended.
Returns:
TRUE if the object could be appended successfully, FALSE otherwise.

const MediaInfo::AudioTrackInfo * MediaInfo::GetAudioInfo ( INT index ) const

Gets the pointer to the AudioTrackInfo object specified by index.

Parameters:
index The index of the info object. Valid values are between 0 and GetAudioInfoCount()-1.
Returns:
The pointer to the object. 0, if the index value is invalid, i.e., is beyond the boundaries of the audio info list, or the list is empty.

INT MediaInfo::GetAudioInfoCount ( ) const [inline]

Gets the number of AudioTrackInfo objects in the audio info list.

Returns:
The number of audio tracks.

const ClipInfo& MediaInfo::GetClipInfo ( ) const [inline]

Gets the pointer to ClipInfo object

Returns:
The pointer to the clip info object.

const MediaInfo::VideoTrackInfo * MediaInfo::GetVideoInfo ( INT index ) const

Gets the pointer to the VideoTrackInfo object specified by index.

Parameters:
index The index of the info object. Valid values are between 0 and GetVideoInfoCount()-1.
Returns:
The pointer to the object. 0, if the index value is invalid, i.e., is beyond the boundaries of the video info list, or the list is empty.

INT MediaInfo::GetVideoInfoCount ( ) const [inline]

Gets the number of VideoTrackInfo objects in the audio info list.

Returns:
The number of video tracks.

BOOLEAN MediaInfo::ReInit ( )

BOOLEAN MediaInfo::SetClipInfo ( ClipInfo & clip_info )

Sets the Clip Information for the file(Valid in case of a Mp3/3gpp file)

Returns:
TRUE if the ClipInformation could be set successfully else FALSE.

BOOLEAN MediaInfo::SetClipInfo | ( | UINT8 * | title,
 |  | UINT8 * | author,
 |  | UINT8 * | copyright,
 |  | UINT8 * | rating,
 |  | UINT8 * | description
 | ) |

Sets the Clip Information for the file(Valid in case of only a 3gpp file)

Returns:
TRUE if the ClipInformation could be set successfully else FALSE.

Friends And Related Function Documentation

friend class EmApoxiMediaInfo [friend]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaInfo.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaInfo.cpp
Generated on Wed Jan 25 01:27:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaInfo::AudioTrackInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MediaInfo::AudioTrackInfo

MediaInfo::AudioTrackInfo Class Reference

#include <Apoxi/AddOns/MediaFramework/MediaInfo.hpp>

Inheritance diagram for MediaInfo::AudioTrackInfo:

[legend]
Collaboration diagram for MediaInfo::AudioTrackInfo:

[legend]

Public Member Functions

AudioTrackInfo (MediaCodec codec_type, UINT32 duration, UINT32 track_id, UINT16 sample_freq, UINT16 channel_cnt, UINT32 bitrate=0)
AudioTrackInfo ()
UINT16 | GetNumberOfChannels () const
UINT16 | GetSampleFreq () const

Detailed Description

Audio track information class

Constructor & Destructor Documentation

MediaInfo::AudioTrackInfo::AudioTrackInfo ( )

default constructor

MediaInfo::AudioTrackInfo::AudioTrackInfo | ( | MediaCodec | codec_type,
 |  | UINT32 | duration,
 |  | UINT32 | track_id,
 |  | UINT16 | sample_freq,
 |  | UINT16 | channel_cnt,
 |  | UINT32 | bitrate = 0
 | ) |

Constructor.

Parameters:
codec_type | Media codec type.
duration | Duration of the stream (in milliseconds)
track_id | Stream ID as in the media source
sample_freq | Sampling frequency (in Hz)
channel_cnt | Number of channels

Member Function Documentation

UINT16 MediaInfo::AudioTrackInfo::GetNumberOfChannels ( ) const [inline]

Gets the number of channels

UINT16 MediaInfo::AudioTrackInfo::GetSampleFreq ( ) const [inline]

Gets the sample frequency (in Hz)

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaInfo.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaInfo.cpp
Generated on Wed Jan 25 01:27:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaInfo::ClipInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MediaInfo::ClipInfo

MediaInfo::ClipInfo Class Reference

#include <Apoxi/AddOns/MediaFramework/MediaInfo.hpp>

Public Member Functions

void | DeInit ()
void | Init ()

Data Fields

UINT16 * | m_p_album
UINT16 * | m_p_artist
UINT8 * | m_p_author
UINT16 * | m_p_comment
UINT16 * | m_p_composer
UINT8 * | m_p_copyright
UINT8 * | m_p_description
UINT16 * | m_p_duration
UINT16 * | m_p_genre
UINT16 * | m_p_original_artist
UINT8 * | m_p_rating
UINT16 * | m_p_song_name
UINT8 * | m_p_title
UINT16 * | m_p_track
UINT16 * | m_p_url
UINT16 * | m_p_year

Member Function Documentation

void MediaInfo::ClipInfo::DeInit ( )

void MediaInfo::ClipInfo::Init ( )

Field Documentation

UINT16* MediaInfo::ClipInfo::m_p_album

UINT16* MediaInfo::ClipInfo::m_p_artist

UINT8* MediaInfo::ClipInfo::m_p_author

UINT16* MediaInfo::ClipInfo::m_p_comment

UINT16* MediaInfo::ClipInfo::m_p_composer

UINT8* MediaInfo::ClipInfo::m_p_copyright

UINT8* MediaInfo::ClipInfo::m_p_description

UINT16* MediaInfo::ClipInfo::m_p_duration

UINT16* MediaInfo::ClipInfo::m_p_genre

UINT16* MediaInfo::ClipInfo::m_p_original_artist

UINT8* MediaInfo::ClipInfo::m_p_rating

UINT16* MediaInfo::ClipInfo::m_p_song_name

UINT8* MediaInfo::ClipInfo::m_p_title

UINT16* MediaInfo::ClipInfo::m_p_track

UINT16* MediaInfo::ClipInfo::m_p_url

UINT16* MediaInfo::ClipInfo::m_p_year

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaInfo.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaInfo.cpp
Generated on Wed Jan 25 01:27:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaInfo::MediaTrackInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MediaInfo::MediaTrackInfo

MediaInfo::MediaTrackInfo Class Reference

#include <Apoxi/AddOns/MediaFramework/MediaInfo.hpp>

Inheritance diagram for MediaInfo::MediaTrackInfo:

[legend]

Public Member Functions

UINT32 | GetBitrate () const
UINT32 | GetDuration () const
MediaCodec | GetMediaCodec () const
UINT32 | GetTrackId () const
MediaTrackInfo (MediaCodec codec_type, UINT32 duration, UINT32 track_id, UINT32 bitrate=0)
MediaTrackInfo ()

Protected Attributes

UINT32 | m_bitrate
Bit rate of the media.
MediaCodec m_codec_type
Media codec type.
UINT32 | m_duration
Duration of the stream (in msecs).
UINT32 | m_track_id
Stream ID as in the Media File.

Detailed Description

Media track information class. Base class for AudioTrackInfo and VideoTrackInfo

Constructor & Destructor Documentation

MediaInfo::MediaTrackInfo::MediaTrackInfo ( )

default constructor

MediaInfo::MediaTrackInfo::MediaTrackInfo | ( | MediaCodec | codec_type,
 |  | UINT32 | duration,
 |  | UINT32 | track_id,
 |  | UINT32 | bitrate = 0
 | ) |

Constructor.

Parameters:
codec_type | Media codec type.
duration | Duration of the stream (in milliseconds)
track_id | Stream ID as in the media source

Member Function Documentation

UINT32 MediaInfo::MediaTrackInfo::GetBitrate ( ) const [inline]

Gets the bitrate

UINT32 MediaInfo::MediaTrackInfo::GetDuration ( ) const [inline]

Gets the duration of the track (in milliseconds)

MediaCodec MediaInfo::MediaTrackInfo::GetMediaCodec ( ) const [inline]

Gets media codec.

UINT32 MediaInfo::MediaTrackInfo::GetTrackId ( ) const [inline]

Gets the track ID

Field Documentation

UINT32 MediaInfo::MediaTrackInfo::m_bitrate [protected]

Bit rate of the media.

MediaCodec MediaInfo::MediaTrackInfo::m_codec_type [protected]

Media codec type.

UINT32 MediaInfo::MediaTrackInfo::m_duration [protected]

Duration of the stream (in msecs).

UINT32 MediaInfo::MediaTrackInfo::m_track_id [protected]

Stream ID as in the Media File.

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaInfo.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaInfo.cpp
Generated on Wed Jan 25 01:27:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaInfo::VideoTrackInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MediaInfo::VideoTrackInfo

MediaInfo::VideoTrackInfo Class Reference

#include <Apoxi/AddOns/MediaFramework/MediaInfo.hpp>

Inheritance diagram for MediaInfo::VideoTrackInfo:

[legend]
Collaboration diagram for MediaInfo::VideoTrackInfo:

[legend]

Public Member Functions

XYDIM | GetHeight () const
XYDIM | GetWidth () const
VideoTrackInfo (MediaCodec codec_type, UINT32 duration, UINT32 track_id, XYDIM m_width, XYDIM m_height, UINT32 bitrate=0)
VideoTrackInfo ()

Detailed Description

Video track information class

Constructor & Destructor Documentation

MediaInfo::VideoTrackInfo::VideoTrackInfo ( )

default constructor

MediaInfo::VideoTrackInfo::VideoTrackInfo | ( | MediaCodec | codec_type,
 |  | UINT32 | duration,
 |  | UINT32 | track_id,
 |  | XYDIM | m_width,
 |  | XYDIM | m_height,
 |  | UINT32 | bitrate = 0
 | ) |

Constructor

Parameters:
codec_type | Media codec type.
duration | Duration of the stream (in milliseconds)
track_id | Stream ID as in the media source
m_width | Frame width (in pixels)
m_height | Frame height (in pixels)

Member Function Documentation

XYDIM MediaInfo::VideoTrackInfo::GetHeight ( ) const [inline]

Gets the frame height (in pixels).

XYDIM MediaInfo::VideoTrackInfo::GetWidth ( ) const [inline]

Gets the frame width (in pixels).

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaInfo.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaInfo.cpp
Generated on Wed Jan 25 01:27:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaManager Class Reference
[MediaFramework]

#include <Apoxi/AddOns/MediaFramework/MediaManager.hpp>

Collaboration diagram for MediaManager:

[legend]

Public Types

enum MmfMsgType {
PauseApiCompletionMsg, PlayApiCompletionMsg, RecordApiCompletionMsg, RewindApiCompletionMsg,
FastForwardApiCompletionMsg, StopApiCompletionMsg, InitCompletionMsg, UninitCompletionMsg,
EofReachedMsg, CriticalErrorMsg, NetworkMsgRtcpByeReceived, MediaTypeNotSupportedMsg,
SamplingFrequencyNotSupportedMsg, NetworkErrConnErr, NetworkErrConnLostErr, NetworkErrUnknown,
NetworkErrConnectFailed, NetworkErrBandWidthTooHigh, NetworkErrUrlNotFound, NetworkErrUrlNotStreamable,
NetworkErrSdpParseError, NetworkErrSdpFileOpenError, NetworkErrHTTPError, NetworkErrRtpDataError,
NetworkErrUnknownServError, NetworkErrCriticalError, BufferingStart, BufferingComplete,
MediaInfoObtainedMsg, UnknownErrorMsg
}
enum MmfResult {
Success = 0, MediaTypeDifferent, MediaNotSupported, OutOfMemory,
SmallBuffer, NullParameter, InvalidParameter, InvalidState,
FeatureNotSupported, InvalidAudioTrack, InvalidVideoTrack, FileNotFound,
EmptyFile, Invalid3gppFile, Incomplete3gppFile, OpenFileFailure,
InvalidMp3File, CorruptMp3File, VidResNotSupported, AudSamplFreqNotSupported,
FpsNotSupported, GeneralError
}

Public Member Functions

MediaPlayer * | CreateMediaPlayer (const char *media_source, MediaInfo &media_info, MimeType &media_mime_type, void *mesg_dispatcher, MmfResult &result)
MediaPlayer * | CreateMediaPlayer (const BinData *media_source, MediaInfo &media_info, MimeType &media_mime_type, void *mesg_dispatcher, MmfResult &result)
MediaRecorder * | CreateMediaRecorder (void *mesg_dispatcher, MmfResult &mmf_result)
void | DestroyMediaPlayer (MediaPlayer *media_player)
void | DestroyMediaRecorder (MediaRecorder *media_recorder)
const MediaFrameworkCaps * | GetCapabilities () const

Static Public Member Functions

static MediaManager & | GetInstance ()

Detailed Description

Central instance of the media framework. Allows to create and destroy media players and recorders which are used by the applications.
See also:
MediaController

Member Enumeration Documentation

enum MediaManager::MmfMsgType

Enumerator:
PauseApiCompletionMsg | Message that communicates the completion of Pause API to the app
PlayApiCompletionMsg | Message that communicates the completion of Play API to the app
RecordApiCompletionMsg | Message that communicates the completion of Record API to the app
RewindApiCompletionMsg | Message that communicates the completion of Rewind API to the app
FastForwardApiCompletionMsg | Message that communicates the completion of Rewind API to the app
StopApiCompletionMsg | Message that communicates the completion of Stop API to the app
InitCompletionMsg | Message that communicates the completion of Init to the app
UninitCompletionMsg | Message that communicates the completion of Deinit to the app
EofReachedMsg | Message that communicates the end of file to the app
CriticalErrorMsg | Message that communicates the critical to the app
NetworkMsgRtcpByeReceived | Message that communicates the reception of RTCP bye
MediaTypeNotSupportedMsg | Message that communicates the unsupportes media type
SamplingFrequencyNotSupportedMsg | Message that communicates the error unsupported frequency
NetworkErrConnErr | Message that communicates some network connection problem to the app
NetworkErrConnLostErr | Message that communicates some network connection lost to the app
NetworkErrUnknown | Message that communicates unknown network error to the app
NetworkErrConnectFailed | Message that communicates the connection attempt failure to the app
NetworkErrBandWidthTooHigh | Message that communicates that the media is of unsupported bandwidth
NetworkErrUrlNotFound | Message that communicates URL not found error to the app
NetworkErrUrlNotStreamable | Message that communicates that the url doesn't have hint tracks
NetworkErrSdpParseError | Message that communicates that SDP parsing failed
NetworkErrSdpFileOpenError | Message that communicates that SDP file opening failed
NetworkErrHTTPError | Message that communicates that HTTP error occurred
NetworkErrRtpDataError | Message that communicates that RTP data error occurred while streaming
NetworkErrUnknownServError | Message that communicates uncommon server errors to the app
NetworkErrCriticalError | Message that communicates critical network error to the app
BufferingStart | Message that communicates the start of buffering stage
BufferingComplete | Message that communicates the end of buffering stage
MediaInfoObtainedMsg | Message that communicates the completion of GetMedioInfo API
UnknownErrorMsg | Message that communicates any unknown error

enum MediaManager::MmfResult

Error-codes which can be retrieved by the output parameter error_code of the method MediaManager::CreateMediaPlayer and MediaManager::CreateMediaRecorder. It is also used as a parameter by the error message sent by the MediaFramework

Enumerator:
Success | function successfully completed
MediaTypeDifferent | MIME type passed to the MMF is different from the actual file MIME type (but supported by MMF)
MediaNotSupported | MIME type not supported by MMF.
OutOfMemory | Memory allocation failure.
SmallBuffer | The buffer passed by the application is insufficient for MMFr - Not Implemented.
NullParameter | The parameter passed To MMFr is NULL.
InvalidParameter | The parameter passed is invalid.
InvalidState | The MMF is not in a state to process a request -- Not Implemented.
FeatureNotSupported | The feature is not supported by MMF (e.g. due to HW constraints).
InvalidAudioTrack | The 3gpp file has an invalid audio track.
InvalidVideoTrack | The 3gpp file has an invalid video track.
FileNotFound | The file doesn't exist.
EmptyFile | The 3gpp file doesn't have any audio/video tracks.
Invalid3gppFile | The 3gpp file doesn't have any movie meta data.
Incomplete3gppFile | Not Implemented.
OpenFileFailure | The opening of the file failed for some reason.(e.g. fopen returned error).
InvalidMp3File | There is no sync frame in the Mp3 file.
CorruptMp3File | The Mp3 frame found is not valid.
VidResNotSupported | This video resolution is not supported.
AudSamplFreqNotSupported | This audio sampling frequency is not supported.
FpsNotSupported
GeneralError | general or unknown error

Member Function Documentation

MediaPlayer* MediaManager::CreateMediaPlayer | ( | const char * | media_source,
 |  | MediaInfo & | media_info,
 |  | MimeType & | media_mime_type,
 |  | void * | mesg_dispatcher,
 |  | MmfResult & | result
 | ) |

Returns a media player.

Parameters:
media_source | [IN] Pointer to the media source filename.
media_info | [OUT] Pointer to the result structure which contains information about all the media tracks in the source. The source may have zero or more video tracks and zero or more audio tracks.
mime_type | [IN/OUT] MIME type of the source. If the MIME type passed to the function is invalid, the Framework shall change this argument value to the actual MIME type.
result | If video file open is successful, MmfMediaTypeDifferent if the passed MIME type is not valid (but the opening is successful), MmfMediaNotSupported if the MIME type is not supported by the MMF, otherwise MmfGeneralError.
Returns:
Pointer to the media player. 0 is returned, if no media player could be created. If the media player is not needed anymore, it must be destroyed by invoking MediaManager::DestroyMediaPlayer.

MediaPlayer* MediaManager::CreateMediaPlayer | ( | const BinData * | media_source,
 |  | MediaInfo & | media_info,
 |  | MimeType & | media_mime_type,
 |  | void * | mesg_dispatcher,
 |  | MmfResult & | result
 | ) |

Returns a media context for the media data which should be rendered.

Parameters:
media_source | [IN] Reference to the media source.
media_info | [OUT] Pointer to the result structure which contains information about all the media tracks in the source. The source may have zero or more video tracks and zero or more audio tracks.
mime_type | [IN/OUT] MIME type of the source. If the MIME type passed to the function is invalid, the Framework shall change this argument value to the actual MIME type.
result | If video file open is successful, MmfMediaTypeDifferent if the passed MIME type is not valid (but the opening is successful), MmfMediaNotSupported if the MIME type is not supported by the MMF, otherwise MmfGeneralError.
Returns:
Pointer to the media player. 0 is returned, if no media player could be created. If the media player is not needed anymore, it must be destroyed by invoking MediaManager::DestroyMediaPlayer.

MediaRecorder* MediaManager::CreateMediaRecorder | ( | void * | mesg_dispatcher,
 |  | MmfResult & | mmf_result
 | ) |

Returns a media recorder.

Parameters:
result Output parameter which contains the error code if the creating of the media context has been failed.
Returns:
Pointer to the media recorder. 0 is returned, if no media recorder could be created. If the media recorder is not needed anymore, it must be destroyed by invoking MediaManager::DestroyMediaRecorder.

void MediaManager::DestroyMediaPlayer ( MediaPlayer * media_player )

Destroys the media player created by MediaManager::CreateMediaPlayer. This method should be invoked as soon as the media player is not needed anymore to allow other media players to access the media resources.

void MediaManager::DestroyMediaRecorder ( MediaRecorder * media_recorder )

Destroys the media controller created by MediaManager::CreateMediaRecorder. This method should be invoked as soon as the media recorder is not needed anymore to allow other media recorders to access the media resources.

const MediaFrameworkCaps* MediaManager::GetCapabilities ( ) const

Returns the MediaFramework capablities.

Returns:
A pointer to a class containing the framework capabilities; In case of failure a NULL pointer.

MediaManager & MediaManager::GetInstance ( ) [static]

Returns a static instance of the MediaManager.

Returns:
Reference to the media manager.

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaManager.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaManager.cpp
Generated on Wed Jan 25 01:27:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaManagerMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaManagerMsg Class Reference

#include <Apoxi/AddOns/MediaFramework/MsgTypes.hpp>

Inheritance diagram for MediaManagerMsg:

[legend]
Collaboration diagram for MediaManagerMsg:

[legend]

Public Types

enum | { ID = 54000 }

Public Member Functions

virtual Message * | Clone () const
void * | GetInstanceptr ()
virtual const MsgMetaData & | GetMetaData () const
const MediaManager::MmfResult & | GetMmfresult () const
const MediaManager::MmfMsgType & | GetType () const
MediaManagerMsg (ExecutionContext *application, const MediaManager::MmfMsgType &type, const MediaManager::MmfResult &mmfresult, void *instanceptr=0)
void | SetInstanceptr (void *instanceptr)
void | SetMmfresult (const MediaManager::MmfResult &mmfresult)
void | SetType (const MediaManager::MmfMsgType &type)
virtual | ~MediaManagerMsg ()

Protected Member Functions

virtual void | Dump (OutputStream &ostr) const

Friends

OutputStream & | operator<< (OutputStream &ostr, const MediaManagerMsg &cls)
InputStream & | operator>> (InputStream &istr, MediaManagerMsg &cls)

Detailed Description

MediaManagerMsg MediaFramework Message.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MediaManagerMsg::MediaManagerMsg | ( | ExecutionContext * | application,
 |  | const MediaManager::MmfMsgType & | type,
 |  | const MediaManager::MmfResult & | mmfresult,
 |  | void * | instanceptr = 0
 | ) |

MediaManagerMsg::~MediaManagerMsg ( ) [virtual]

Member Function Documentation

Message * MediaManagerMsg::Clone ( ) const [virtual]

Implements Message.

void MediaManagerMsg::Dump ( OutputStream & ostr ) const [protected, virtual]

void* MediaManagerMsg::GetInstanceptr ( ) [inline]

const MsgMetaData & MediaManagerMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const MediaManager::MmfResult& MediaManagerMsg::GetMmfresult ( ) const [inline]

const MediaManager::MmfMsgType& MediaManagerMsg::GetType ( ) const [inline]

void MediaManagerMsg::SetInstanceptr ( void * instanceptr ) [inline]

void MediaManagerMsg::SetMmfresult ( const MediaManager::MmfResult & mmfresult ) [inline]

void MediaManagerMsg::SetType ( const MediaManager::MmfMsgType & type ) [inline]

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const MediaManagerMsg & | cls
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | MediaManagerMsg & | cls
 | ) | [friend]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MsgTypes.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MsgTypes.cpp
Generated on Wed Jan 25 01:27:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaObtainer Class Reference

#include <Apoxi/AddOns/MediaFramework/MediaObtainer.hpp>

Inheritance diagram for MediaObtainer:

[legend]
Collaboration diagram for MediaObtainer:

[legend]

Public Member Functions

virtual Media * | GetMedia () const
MediaObtainer (Media *media)
virtual | ~MediaObtainer ()

Constructor & Destructor Documentation

MediaObtainer::MediaObtainer ( Media * media )

MediaObtainer::~MediaObtainer ( ) [virtual]

Member Function Documentation

Media * MediaObtainer::GetMedia ( ) const [virtual]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaObtainer.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaObtainer.cpp
Generated on Wed Jan 25 01:27:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaPathnameVisitor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaPathnameVisitor Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/MediaVisitor.hpp>

Inheritance diagram for MediaPathnameVisitor:

[legend]
Collaboration diagram for MediaPathnameVisitor:

[legend]

Public Member Functions

void | GetPaths (Vector< Path > &paths)
void | GetPaths (Vector< Path > &paths)
MediaPathnameVisitor ()
MediaPathnameVisitor ()
void | Visit (const MediaRef &media_ref)
void | Visit (const MediaRef &media_ref)
virtual | ~MediaPathnameVisitor ()
virtual | ~MediaPathnameVisitor ()

Constructor & Destructor Documentation

MediaPathnameVisitor::MediaPathnameVisitor ( )

MediaPathnameVisitor::~MediaPathnameVisitor ( ) [virtual]

MediaPathnameVisitor::MediaPathnameVisitor ( )

virtual MediaPathnameVisitor::~MediaPathnameVisitor ( ) [virtual]

Member Function Documentation

void MediaPathnameVisitor::GetPaths ( Vector< Path > & paths )

void MediaPathnameVisitor::GetPaths ( Vector< Path > & paths )

void MediaPathnameVisitor::Visit ( const MediaRef & media_ref ) [virtual]

Implements MediaVisitor.

void MediaPathnameVisitor::Visit ( const MediaRef & media_ref ) [virtual]

Implements MediaVisitor.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaVisitor.hpp
  • Applications/SoundBrowser/Common/MediaVisitor.hpp
  • Applications/ImageBrowser/Common/MediaVisitor.cpp
  • Applications/SoundBrowser/Common/MediaVisitor.cpp
Generated on Wed Jan 25 01:27:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaPlayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaPlayer Class Reference
[MediaFramework]

#include <Apoxi/AddOns/MediaFramework/MediaPlayer.hpp>

Public Types

enum State {
UnInitializedState, InsideDefaultSelectMedia, InitializedState, PlayingState,
PausedState, RewindingState, FastForwardingState, AwaitingPlayRespState,
AwaitingRewindRespState, AwaitingFastForwardRespState, AwaitingPauseRespState, AwaitingStopRespState,
AwaitingInitResp, EofProcessing, BufferingCompleteState, BufferingStartState,
ErrorProcessing, ErrorState, DestroyedState, ReadyState,
EofReceivedState
}
enum | TrackSelection { AudioAndVideo, AudioOnly, VideoOnly }

Public Member Functions

virtual MediaManager::MmfResult | FastForward (INT rate)
virtual AudioReference * | GetAudioReference (void) const
virtual BOOLEAN | GetContinue () const
virtual MediaManager::MmfResult | GetFirstVideoFrame (UINT8 *buffer, UINT32 &buffer_length)
virtual MediaManager::MmfResult | GetPosition (UINT32 &position) const
virtual UINT32 | GetPriority () const
virtual UINT16 | GetRepeatCount () const
virtual MediaManager::MmfResult | GetState (MediaPlayer::State &state) const
virtual MediaManager::MmfResult | Pause ()
virtual MediaManager::MmfResult | Play ()
virtual MediaManager::MmfResult | Rewind (INT rate)
virtual MediaManager::MmfResult | SelectMediaTracks (TrackSelection track_selection, UINT audio_track_id, UINT video_track_id)
virtual MediaManager::MmfResult | SetBalanceLevel (UINT level)
virtual MediaManager::MmfResult | SetBassLevel (UINT level)
virtual MediaManager::MmfResult | SetContinue (BOOLEAN continue_flag=FALSE)
virtual MediaManager::MmfResult | SetDisplayLocation (INT x, INT y)
virtual MediaManager::MmfResult | SetDisplaySettings (const DisplaySettings &display_settings)
virtual MediaManager::MmfResult | SetPlaybackContrast (UINT level)
virtual MediaManager::MmfResult | SetPlaybackVideoQuality (DisplaySettings::VideoQuality video_quality)
virtual MediaManager::MmfResult | SetPosition (INT32 position)
virtual MediaManager::MmfResult | SetPriority (UINT32 priority=0)
virtual MediaManager::MmfResult | SetRepeatCount (UINT16 repeat_count=1)
virtual MediaManager::MmfResult | SetTrebleLevel (UINT level)
virtual MediaManager::MmfResult | SetVolumeLevel (UINT volume_level)
virtual MediaManager::MmfResult | Stop ()
virtual MediaManager::MmfResult | Unzoom ()
virtual MediaManager::MmfResult | Zoom (BOOLEAN zoom_up)
virtual | ~MediaPlayer ()

Friends

class | MediaManager

Detailed Description

Media player. Initialization of the resources is done in the constructor. Releasing of the resources is done in the destructor. In general, the methods of this class will return MediaManager::FeatureNotSupported if the corresponding feature is not supported, e.g. due to hardware constraints.

Member Enumeration Documentation

enum MediaPlayer::State

Enumerator:
UnInitializedState
InsideDefaultSelectMedia
InitializedState
PlayingState
PausedState
RewindingState
FastForwardingState
AwaitingPlayRespState
AwaitingRewindRespState
AwaitingFastForwardRespState
AwaitingPauseRespState
AwaitingStopRespState
AwaitingInitResp
EofProcessing
BufferingCompleteState
BufferingStartState
ErrorProcessing
ErrorState
DestroyedState
ReadyState
EofReceivedState

enum MediaPlayer::TrackSelection

Enumerator:
AudioAndVideo
AudioOnly
VideoOnly

Constructor & Destructor Documentation

MediaPlayer::~MediaPlayer ( ) [virtual]

Member Function Documentation

MediaManager::MmfResult MediaPlayer::FastForward ( INT rate ) [virtual]

This method fast-forwards the playback at the given rate. The audio output shall be muted during this period. When the fast forward ends, the application gets a notification (APOXI message).

Parameters:
rate [IN] The rate at which the fast-forward play should be played. It accepts values from 1 to 10. The default rate will be set to 5.
Returns:
MediaManager::Success if media player successfully starts the fast-forward play mode of the media file, otherwise MediaManager::GeneralError

AudioReference * MediaPlayer::GetAudioReference ( void ) const [virtual]

This method gets the audio reference of the audio system

Returns:
the audio reference of the audio system or NULL if there are any errors

BOOLEAN MediaPlayer::GetContinue ( ) const [virtual]

This method gets the continue flag of the apoxi audio system

Returns:
the continue flag of the apoxi audio system

MediaManager::MmfResult MediaPlayer::GetFirstVideoFrame | ( | UINT8 * | buffer,
 |  | UINT32 & | buffer_length
 | ) | [virtual]

MediaManager::MmfResult MediaPlayer::GetPosition ( UINT32 & position ) const [virtual]

This method gets the current position (time) of the currently playing media file (in milliseconds).

Parameters:
position [OUT] Reference to a variable that will contain play position (in milliseconds)
Returns:
MediaManager::Success if media player successfully gets the play position of the currently opened video file, otherwise MediaManager::GeneralError.

UINT32 MediaPlayer::GetPriority ( ) const [virtual]

This method gets the priority of the apoxi audio system

Returns:
the priority of the apoxi audio system

UINT16 MediaPlayer::GetRepeatCount ( ) const [virtual]

This method gets the repeat count

Returns:
the repeat count of the apoxi audio system

MediaManager::MmfResult MediaPlayer::GetState ( MediaPlayer::State & state ) const [virtual]

This method gets the media player state.

Parameters:
state [OUT]Reference to a variable that will contain current player state.
Returns:
MediaManager::Success if media player successfully gets the player state, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaPlayer::Pause ( ) [virtual]

This method pauses the playback of the currently playing video file.

Returns:
MediaManager::Success if media player successfully pauses the playback of the file, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaPlayer::Play ( ) [virtual]

This method starts the playback of the currently opened media file at the current position (time), i.e. after invoking of pause API it resumes the playback at the position at which the playback has been paused. This API returns after the state becomes playing (in other words, the return is not after the completion of media playback). When the media playback completes, the application gets a notification (APOXI message).

Returns:
MediaManager::Success if media player successfully starts playing the file, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaPlayer::Rewind ( INT rate ) [virtual]

This method rewinds the playback at the given rewind rate. The audio output shall be muted during this period. When the rewind ends, the application gets a notification (APOXI message).

Parameters:
rate [IN] The rate at which the rewind play should be played. It accepts values from 1 to 10. Default rewind rate will be set to 5.
Returns:
MediaManager::Success if media player successfully starts the rewind play mode of the media file, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaPlayer::SelectMediaTracks | ( | TrackSelection | track_selection,
 |  | UINT | audio_track_id,
 |  | UINT | video_track_id
 | ) | [virtual]

This method opens the media tracks selected and adds the media framework components required for playing these tracks. Usually, this method is invoked before the playback will be started. If it is not invoked before the playback, then the first track in the media source is selected.

Parameters:
track_selection | [IN] Selected tracks. (Audio only, Video only, or both).
audio_track_id | [IN] Audio track Id as present in the media source.
video_track_id | [IN] Video track Id as present in the media source.
Returns:
MediaManager::Success if media tracks open is successful, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaPlayer::SetBalanceLevel ( UINT level ) [virtual]

This method sets the speaker balance to the desired level.

Parameters:
level [IN] The desired balance level of the speaker.
Returns:
MediaManager::Success if media player successfully sets the speaker balance to desired level, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetBassLevel ( UINT level ) [virtual]

This method sets the speaker bass to the desired level.

Parameters:
level [IN] The desired bass level of the speaker.
Returns:
MediaManager::Success if media player successfully sets the speaker bass to desired level, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetContinue ( BOOLEAN continue_flag = FALSE ) [virtual]

This method passes the continue flag down to apoxi audio

Parameters:
continue_flag [IN] The desired continue flag
Returns:
MediaManager::Success if media player successfully sets the continue flag otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetDisplayLocation | ( | INT | x,
 |  | INT | y
 | ) | [virtual]

This method sets the location of the video with respect to the canvas (video output window) where the video is displayed. The location is specified in pixel values relative to the upper left hand corner of the GUI object. By default, video appears at location (0,0). The location can be given in negative values or can be greater than the actual size of the canvas. When that happens, the video should be clipped to the boundaries of the canvas.

Parameters:
x | [IN] The x coordinate (in pixels) of the video location.
y | [IN] The y coordinate (in pixels) of the video location.
Returns:
MediaManager::Success if media player successfully sets the location, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetDisplaySettings ( const DisplaySettings & display_settings ) [virtual]

This method configures the video output device. This method has to be invoked before the video playback can be started. In case that only audio tracks have to be played, this method is not mandatory before the beginning of the playback.

Parameters:
display_settings,: [IN] Display settings.
Returns:
MediaManager::Success if media player successfully configures the video output window, otherwise GeneralError

MediaManager::MmfResult MediaPlayer::SetPlaybackContrast ( UINT level ) [virtual]

This method sets the Playback contrast to the desired level.

Parameters:
level [IN] The desired contrast of the LCD.
Returns:
MediaManager::Success if media player successfully sets the LCD contrast to desired level, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetPlaybackVideoQuality ( DisplaySettings::VideoQuality video_quality ) [virtual]

This method sets the Playback video quality to the desired level.

Parameters:
video_quality [IN] The desired playback video quality.
Returns:
MediaManager::Success if media player successfully sets the LCD contrast to desired level, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetPosition ( INT32 position ) [virtual]

This method sets the position (time) of the currently playing media file to the positon specified by position (in milliseconds). It will not result into the playback of the media from the new position. So Play API needs to be called for starting the playback from this new position. Setting the position to values before the beginning of the track will effectively set the position to the beginning. Setting the position to beyond the length of the media will set the position to the end of media.

Parameters:
position [IN] The position to be set (in milliseconds)
Returns:
MediaManager::Success if media player successfully sets the play position of the currently opened video file, MediaManager::InvalidState: Indicates that the player is in invalid state (file not opened/tracks not selected), so cannot seek; otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetPriority ( UINT32 priority = 0 ) [virtual]

This method sets the apoxi audio to the requested priority

Parameters:
continue_flag [IN] The desired priority
Returns:
MediaManager::Success if media player successfully sets the priority otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetRepeatCount ( UINT16 repeat_count = 1 ) [virtual]

This method sets the Repeat Count and passes it down to apoxi audio

Parameters:
repeat_count [IN] The desired repeat count.
Returns:
MediaManager::Success if media player successfully sets the repeat count otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetTrebleLevel ( UINT level ) [virtual]

This method sets the speaker treble to the desired level.

Parameters:
level [IN] The desired treble level of the speaker.
Returns:
MediaManager::Success if media player successfully sets the speaker treble to desired level, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::SetVolumeLevel ( UINT volume_level ) [virtual]

This method sets the speaker volume to the desired level.

Parameters:
volume_level [IN] The desired volume level of the speaker ( 0 to 0xffff);
Returns:
MediaManager::Success if media player successfully sets the speaker volume to desired level, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::Stop ( ) [virtual]

This method stops the playback, resets the play position (time) to 0 and shows the first frame of the video file.

Returns:
MediaManager::Success if media player successfully stops the playback of the media file, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaPlayer::Unzoom ( ) [virtual]

This method nullify the zoom changes caused by the Zoom method, i.e. it actually resets the zoom factor to 1. It shall be ignored if there is only audio or the video has not been zoomed. Note: Zoom factor 1 means that the whole video content is visible on the video out window (i.e. no clipping) but it does not mean that the video has to be in the same size (resolution) as in the media source, e.g. if the original video size is 352-by-288 pixels but the video out window size (see DisplaySettings) is 176-by-144 pixels, then the video is usually automatically downscaled to this size (if supported) and a zoom factor 1 would correspond to a 'real' downscaling factor 1/2.

Returns:
MediaManager::Success if media player successfully sets the zoom factor to 1, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaPlayer::Zoom ( BOOLEAN zoom_up ) [virtual]

This method changes the zoom level of the video. If the maximum upscaling factor has been reached and this method is called with zoom_up=TRUE, it shall be ignored. If the maximum downscaling factor has been reached and this method is called with zoom_up=FALSE, it shall be ignored. In case there is only audio, this method shall be ignored as well.

Parameters:
zoom_up [IN] If TRUE then the video shall be upscaled (to the next available level). If FALSE then the video shall be downscaled.
Returns:
MediaManager::Success if media player successfully sets the zoom level, otherwise MediaManager::GeneralError.

Friends And Related Function Documentation

friend class MediaManager [friend]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaPlayer.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaPlayer.cpp
Generated on Wed Jan 25 01:27:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaRecorder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaRecorder Class Reference
[MediaFramework]

#include <Apoxi/AddOns/MediaFramework/MediaRecorder.hpp>

Public Types

enum MediaRecorderState {
UnInitializedState, InitalizedState, PreviewState, AwaitingRecordRespState,
RecordingState, AwaitingPauseRespState, PausedState, AwaitingStopRespState,
AwaitingInitResp, EofProcessing, ErrorProcessing, ErrorState,
DestroyedState
}

Public Member Functions

virtual MediaManager::MmfResult | GetPosition (UINT32 &position) const
virtual UINT32 | GetPriority () const
virtual MediaManager::MmfResult | GetState (MediaRecorderState &state) const
virtual MediaManager::MmfResult | PauseRecord ()
virtual MediaManager::MmfResult | ResumeRecord ()
virtual MediaManager::MmfResult | SetCameraMirroring (BOOLEAN mirroring_on)
virtual MediaManager::MmfResult | SetCameraNightMode (BOOLEAN night_mode_on)
virtual MediaManager::MmfResult | SetDisplayAndRecordSettings (const DisplaySettings &display_settings, const RecordSettings &record_settings)
virtual MediaManager::MmfResult | SetDisplaySettings (const DisplaySettings &display_settings)
virtual MediaManager::MmfResult | SetMute (BOOLEAN mute_on)
virtual MediaManager::MmfResult | SetPriority (UINT32 priority=0)
virtual MediaManager::MmfResult | SetRecordSettings (const RecordSettings &record_settings)
virtual MediaManager::MmfResult | StartPreview ()
virtual MediaManager::MmfResult | StartRecord ()
virtual MediaManager::MmfResult | StopPreview ()
virtual MediaManager::MmfResult | StopRecord ()
virtual MediaManager::MmfResult | Unzoom ()
virtual MediaManager::MmfResult | Zoom (BOOLEAN zoom_up)
~MediaRecorder ()

Friends

class | MediaManager

Detailed Description

Media Recorder. Initialization of the resources is done in the constructor. Releasing of the resources is done in the destructor. In general, the methods of this class will return MediaManager::FeatureNotSupported if the corresponding feature is not supported, e.g. due to hardware constraints.

Member Enumeration Documentation

enum MediaRecorder::MediaRecorderState

Enumerator:
UnInitializedState
InitalizedState
PreviewState
AwaitingRecordRespState
RecordingState
AwaitingPauseRespState
PausedState
AwaitingStopRespState
AwaitingInitResp
EofProcessing
ErrorProcessing
ErrorState
DestroyedState

Constructor & Destructor Documentation

MediaRecorder::~MediaRecorder ( )

Member Function Documentation

MediaManager::MmfResult MediaRecorder::GetPosition ( UINT32 & position ) const [virtual]

This method gets the current video recording position (in milliseconds).

Parameters:
position [OUT]Reference to a variable that will contain current record position .
Returns:
MediaManager::Success if Media recorder successfully gets the current record position, otherwise MediaManager::GeneralError

UINT32 MediaRecorder::GetPriority ( ) const [virtual]

This method gets the priority of the apoxi audio system

Returns:
the priority of the apoxi audio system

MediaManager::MmfResult MediaRecorder::GetState ( MediaRecorderState & state ) const [virtual]

This method gets the Media recorder state.

Parameters:
state [OUT]Reference to a variable that will contain current recorder state.
Returns:
MediaManager::Success if Media recorder successfully gets the recorder state, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::PauseRecord ( ) [virtual]

This method pauses the video recording

Returns:
MediaManager::Success if Media recorder successfully pauses recording, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::ResumeRecord ( ) [virtual]

This method resumes the video recording

Returns:
MediaManager::Success if Media recorder successfully resumes recording, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::SetCameraMirroring ( BOOLEAN mirroring_on ) [virtual]

This method activates/deactivates the camera mirroring.

Parameters:
mirroring_on [IN] If TRUE, the camera mirroring is activated, if FALSE, it is deactivated.
Returns:
MediaManager::Success if Media recorder successfully toggles the camera mirroring, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaRecorder::SetCameraNightMode ( BOOLEAN night_mode_on ) [virtual]

This method activates/deactivates the camera night mode.

Parameters:
night_mode_on [IN] If TRUE, the camera night mode is activated, if FALSE, it is deactivated.
Returns:
MediaManager::Success if Media recorder successfully toggles the camera mode, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaRecorder::SetDisplayAndRecordSettings | ( | const DisplaySettings & | display_settings,
 |  | const RecordSettings & | record_settings
 | ) | [virtual]

This method configures the video output device and sets the video recording settings.

Parameters:
display_settings | [IN] Display settings.
record_settings | Video recording parameters to be set.
Returns:
MediaManager::Success if Media recorder successfully sets the recording parameters, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::SetDisplaySettings ( const DisplaySettings & display_settings ) [virtual]

This method configures the video output device. This is the preview screen in the case of recorder.

Parameters:
display_settings [IN] Display settings.
Returns:
MediaManager::Success if media player successfully configures the video output window, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::SetMute ( BOOLEAN mute_on ) [virtual]

This method Mutes/Unmutes the audio. If the mute_on is true, then the audio rendering is paused. If the mute_on is false, then the audio rendering is resumed.

Parameters:
mute_on [IN] Mute Flag. If mute_on is true, mute is turned on. If mute_on is false, mute is turned off.
Returns:
MediaManager::Success if video recorder successfully mutes/unmutes the audio, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaRecorder::SetPriority ( UINT32 priority = 0 ) [virtual]

This method sets the apoxi audio to the requested priority

Parameters:
continue_flag [IN] The desired priority
Returns:
MediaManager::Success if media player successfully sets the Priority otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaRecorder::SetRecordSettings ( const RecordSettings & record_settings ) [virtual]

This method sets the video recording settings. If the settings do not fit the display settings (e.g. due to hardware constraints), the API would return an error.

Parameters:
record_settings Video recording parameters to be set.
Returns:
MediaManager::Success if Media recorder successfully sets the recording parameters, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::StartPreview ( ) [virtual]

This method starts the camera view finding. Before the preview can be started the display parameters have to be set.

Returns:
MediaManager::Success if Media recorder successfully starts camera view finding, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::StartRecord ( ) [virtual]

This method starts the video recording. Before video recording can be started, the display and recording parameters have to be set.

Returns:
MediaManager::Success if Media recorder successfully starts recording, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::StopPreview ( ) [virtual]

This method stops the camera preview.

Returns:
MediaManager::Success if Media recorder successfully stops camera preview, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::StopRecord ( ) [virtual]

This method Stops the video recording and saves the recorded content in the file.

Returns:
MediaManager::Success if Media recorder successfully stops recording, otherwise MediaManager::GeneralError

MediaManager::MmfResult MediaRecorder::Unzoom ( ) [virtual]

This method nullify the zoom changes caused by the Zoom method, i.e. it actually resets the zoom factor to 1. It shall be ignored if there is only audio or the video has not been zoomed. Note: Zoom factor 1 means that the whole content captured at the camera is visible on the video out window and is stored in the media sink (i.e. clipping/cropping should be avoided) but it does not mean that the video has to be in the same size (resolution) as on the camera, e.g. if the original camera capture size is 640-by-480 pixels but the video out window size and the recorded file resolutions (see DisplaySettings/RecordSettings) are 176-by-144 pixels, then the video is usually automatically downscaled to this size (if supported) and a zoom factor 1 would correspond to a 'real' downscaling factor 1/3.636 (If fractional scaling is not supported, then clipping/cropping as well as downscaling shall be applied).

Returns:
MediaManager::Success if media player successfully sets the zoom factor to 1, otherwise MediaManager::GeneralError.

MediaManager::MmfResult MediaRecorder::Zoom ( BOOLEAN zoom_up ) [virtual]

This method changes the zoom level of the video. It applies for the preview (video out window) as well as for the media sink, i.e. in general, on the video out window the same content shall be visible as that stored in the media sink. If the maximum upscaling factor has been reached and this method is called with zoom_up=TRUE, it shall be ignored. If the maximum downscaling factor has been reached and this method is called with zoom_up=FALSE, it shall be ignored. In case there is only audio, this method shall be ignored as well.

Parameters:
zoom_up [IN] If TRUE then the video shall be upscaled (to the next available level). If FALSE then the video shall be downscaled.
Returns:
MediaManager::Success if media player successfully sets the zoom level, otherwise MediaManager::GeneralError.

Friends And Related Function Documentation

friend class MediaManager [friend]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/MediaRecorder.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/MediaRecorder.cpp
Generated on Wed Jan 25 01:27:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaRef Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaRef Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/MediaRef.hpp>

Inheritance diagram for MediaRef:

[legend]
Collaboration diagram for MediaRef:

[legend]

Public Member Functions

virtual const MetaData & | GetMetaData () const =0
Returns the constant metadata.
virtual MetaData & | GetMetaData ()=0
Returns the metadata.
virtual const MetaData & | GetMetaData () const =0
Returns the constant metadata.
virtual MetaData & | GetMetaData ()=0
Returns the metadata.
BOOLEAN | IsDrmMedia ()
BOOLEAN | IsDrmMedia (FfsDrmAttrib &attrib)
BOOLEAN | IsDrmMedia ()
BOOLEAN | IsDrmMedia (FfsDrmAttrib &attrib)
BOOLEAN | operator== (const MediaRef &media_ref) const
Checks for equality based solely on the path information.
BOOLEAN | operator== (const MediaRef &media_ref) const
Checks for equality based solely on the path information.
BOOLEAN | SendAsMms (const AtomItem *item)
BOOLEAN | SendAsMms (const AtomItem *item)
virtual void | SetMetaData (const MetaData &meta_data)=0
Sets the metadata.
virtual void | SetMetaData (const MetaData &meta_data)=0
Sets the metadata.
virtual | ~MediaRef ()
virtual | ~MediaRef ()

Protected Member Functions

MediaRef ()
MediaRef ()

Detailed Description

Abstract base class for media references like image or sound references. This class defines the interface for setting and getting the metadata for the content.

Constructor & Destructor Documentation

MediaRef::MediaRef ( ) [protected]

MediaRef::~MediaRef ( ) [virtual]

MediaRef::MediaRef ( ) [protected]

virtual MediaRef::~MediaRef ( ) [virtual]

Member Function Documentation

virtual const MetaData& MediaRef::GetMetaData ( ) const [pure virtual]

Returns the constant metadata.

Implemented in ImageRef, and SoundRef.

virtual MetaData& MediaRef::GetMetaData ( ) [pure virtual]

Returns the metadata.

Implemented in ImageRef, and SoundRef.

virtual const MetaData& MediaRef::GetMetaData ( ) const [pure virtual]

Returns the constant metadata.

Implemented in ImageRef, and SoundRef.

virtual MetaData& MediaRef::GetMetaData ( ) [pure virtual]

Returns the metadata.

Implemented in ImageRef, and SoundRef.

BOOLEAN MediaRef::IsDrmMedia ( )

BOOLEAN MediaRef::IsDrmMedia ( FfsDrmAttrib & attrib )

BOOLEAN MediaRef::IsDrmMedia ( )

BOOLEAN MediaRef::IsDrmMedia ( FfsDrmAttrib & attrib )

BOOLEAN MediaRef::operator== ( const MediaRef & media_ref ) const

Checks for equality based solely on the path information.

BOOLEAN MediaRef::operator== ( const MediaRef & media_ref ) const

Checks for equality based solely on the path information.

BOOLEAN MediaRef::SendAsMms ( const AtomItem * item )

Sends the MediaRef as MMS @ param Document to be attched to MMS. Destination number will be selected by the user

BOOLEAN MediaRef::SendAsMms ( const AtomItem * item )

Sends the MediaRef as MMS @ param Document to be attched to MMS. Destination number will be selected by the user

virtual void MediaRef::SetMetaData ( const MetaData & meta_data ) [pure virtual]

Sets the metadata.

Implemented in ImageRef, and SoundRef.

virtual void MediaRef::SetMetaData ( const MetaData & meta_data ) [pure virtual]

Sets the metadata.

Implemented in ImageRef, and SoundRef.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaRef.hpp
  • Applications/SoundBrowser/Common/MediaRef.hpp
  • Applications/ImageBrowser/Common/MediaRef.cpp
  • Applications/SoundBrowser/Common/MediaRef.cpp
Generated on Wed Jan 25 01:27:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaRefContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaRefContainer Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/MediaRefContainer.hpp>

Inheritance diagram for MediaRefContainer:

[legend]
Collaboration diagram for MediaRefContainer:

[legend]

Public Member Functions

virtual BOOLEAN | Add (MediaRefPtr &media_ref)
virtual BOOLEAN | Add (MediaRefPtr &media_ref)
BOOLEAN | ApplyFilter (const MediaFilter &media_filter)
BOOLEAN | ApplyFilter (const MediaFilter &media_filter)
void | ApplyVisitorFilter (MediaVisitor *media_visitor, const MediaFilter &media_filter)
void | ApplyVisitorFilter (MediaVisitor *media_visitor, const MediaFilter &media_filter)
void | Clear ()
Deletes all elements from the container.
void | Clear ()
Deletes all elements from the container.
virtual BOOLEAN | Delete (MediaRefPtr &media_ref, BOOLEAN delete_file=FALSE)
virtual BOOLEAN | Delete (MediaRefPtr &media_ref, BOOLEAN delete_file=FALSE)
BOOLEAN | DeleteAt (INT index, BOOLEAN delete_file=FALSE)
BOOLEAN | DeleteAt (INT index, BOOLEAN delete_file=FALSE)
const MediaRefPtr & | GetElementAt (INT index) const
MediaRefPtr & | GetElementAt (INT index)
const MediaRefPtr & | GetElementAt (INT index) const
MediaRefPtr & | GetElementAt (INT index)
INT | GetIndex (const MediaRefPtr &media_ref) const
INT | GetIndex (const MediaRefPtr &media_ref) const
INT | GetSize () const
Returns the actual number of media references.
INT | GetSize () const
Returns the actual number of media references.
virtual UINT32 | GetSizeOfRecord () const =0
virtual UINT32 | GetSizeOfRecord () const =0
void | Init (const Path &database_path)
void | Init (const Path &database_path)
BOOLEAN | MediaRefExists (const Path &path) const
BOOLEAN | MediaRefExists (const Path &path) const
void | Refresh (MediaFilter *filter=0)
void | Refresh (MediaFilter *filter=0)
virtual BOOLEAN | Rename (MediaRefPtr &media_ref, const WString &new_name)
virtual BOOLEAN | Rename (MediaRefPtr &media_ref, const WString &new_name)
void | SearchForFiles (MediaFilter *app_filter=0, const WString &storage_device_Id=L"ffs")
void | SearchForFiles (MediaFilter *app_filter=0, const WString &storage_device_Id=L"ffs")
void | SetDbPath (const Path &path)
void | SetDbPath (const Path &path)
virtual | ~MediaRefContainer ()
Saves the media reference container and destructs it.
virtual | ~MediaRefContainer ()
Saves the media reference container and destructs it.

Static Public Member Functions

static BOOLEAN | SaveMedia (MediaRefPtr &media_ref, const UINT8 HUGE *content, UINT32 length)
static BOOLEAN | SaveMedia (MediaRefPtr &media_ref, const UINT8 HUGE *content, UINT32 length)

Protected Member Functions

virtual MediaRefPtr | CreateMediaRef () const =0
virtual MediaRefPtr | CreateMediaRef () const =0
virtual FileFilterPtr | GetMediaFileFilter () const =0
Returns the media file filter for the media objects of interest.
virtual FileFilterPtr | GetMediaFileFilter () const =0
Returns the media file filter for the media objects of interest.
virtual BOOLEAN | IsInDatabase (const Path &path) const
Tells if file path is already in the metadata database.
virtual BOOLEAN | IsInDatabase (const Path &path) const
Tells if file path is already in the metadata database.
MediaRefContainer (const Path &path)
MediaRefContainer ()
MediaRefContainer (const Path &path)
MediaRefContainer ()
virtual BOOLEAN | SetupMediaObject (MediaRefPtr &media_ref)=0
virtual BOOLEAN | SetupMediaObject (MediaRefPtr &media_ref)=0

Protected Attributes

Path m_path
The path of the metadata database.

Friends

class | ImageBrowserApp
class | SoundBrowserApp

Detailed Description

Class MediaRefContainer controls the media references in the metadata database. The class provides methods for reading from and writing to the database. It allows the user to add new media references to and delete existing media references from the database. A media reference container is initialized with the path of its associated metadata database. If the metadata database already exists, it is read out and the media reference container is initialized accordingly. If the metadata database does not exist yet, a new metadata database is created when the container is to be saved.

Constructor & Destructor Documentation

MediaRefContainer::MediaRefContainer ( ) [protected]

MediaRefContainer::MediaRefContainer ( const Path & path ) [protected]

MediaRefContainer::~MediaRefContainer ( ) [virtual]

Saves the media reference container and destructs it.

MediaRefContainer::MediaRefContainer ( ) [protected]

MediaRefContainer::MediaRefContainer ( const Path & path ) [protected]

virtual MediaRefContainer::~MediaRefContainer ( ) [virtual]

Saves the media reference container and destructs it.

Member Function Documentation

virtual BOOLEAN MediaRefContainer::Add ( MediaRefPtr & media_ref ) [virtual]

Adds the media reference media_ref to the metadata database. This method has to be called by overriding methods.

Parameters:
media_ref Media reference to add to the metadata database.

Reimplemented in SoundRefContainer.

BOOLEAN MediaRefContainer::Add ( MediaRefPtr & media_ref ) [virtual]

Adds the media reference media_ref to the metadata database. This method has to be called by overriding methods.

Parameters:
media_ref Media reference to add to the metadata database.

Reimplemented in SoundRefContainer.

BOOLEAN MediaRefContainer::ApplyFilter ( const MediaFilter & media_filter )

Filters the current media references for the specified filter criterion. Media references which don't match are deleted from the metadata database.

Parameters:
media_filter The filter to apply on the media references.

BOOLEAN MediaRefContainer::ApplyFilter ( const MediaFilter & media_filter )

Filters the current media references for the specified filter criterion. Media references which don't match are deleted from the metadata database.

Parameters:
media_filter The filter to apply on the media references.

void MediaRefContainer::ApplyVisitorFilter | ( | MediaVisitor * | media_visitor,
 |  | const MediaFilter & | media_filter
 | ) |

Filters the current media references for the specified filter criterion. Media references are passed to the visitor

Parameters:
media_visitor | The visitor to visit the elements
media_filter | The filter to apply on the media references.

void MediaRefContainer::ApplyVisitorFilter | ( | MediaVisitor * | media_visitor,
 |  | const MediaFilter & | media_filter
 | ) |

Filters the current media references for the specified filter criterion. Media references are passed to the visitor

Parameters:
media_visitor | The visitor to visit the elements
media_filter | The filter to apply on the media references.

void MediaRefContainer::Clear ( )

Deletes all elements from the container.

void MediaRefContainer::Clear ( )

Deletes all elements from the container.

virtual MediaRefPtr MediaRefContainer::CreateMediaRef ( ) const [protected, pure virtual]

Implemented in ImageRefContainer, and SoundRefContainer.

virtual MediaRefPtr MediaRefContainer::CreateMediaRef ( ) const [protected, pure virtual]

Implemented in ImageRefContainer, and SoundRefContainer.

virtual BOOLEAN MediaRefContainer::Delete | ( | MediaRefPtr & | media_ref,
 |  | BOOLEAN | delete_file = FALSE
 | ) | [virtual]

Deletes the specified media reference media_ref from the metadata database. If delete_file is TRUE the resource file is deleted, too. This method has to be called by overriding methods.

Parameters:
media_ref | Media reference to delete.
delete_file | Tells if the resource file shall be deleted, too.

Reimplemented in ImageRefContainer.

BOOLEAN MediaRefContainer::Delete | ( | MediaRefPtr & | media_ref,
 |  | BOOLEAN | delete_file = FALSE
 | ) | [virtual]

Deletes the specified media reference media_ref from the metadata database. If delete_file is TRUE the resource file is deleted, too. This method has to be called by overriding methods.

Parameters:
media_ref | Media reference to delete.
delete_file | Tells if the resource file shall be deleted, too.

Reimplemented in ImageRefContainer.

BOOLEAN MediaRefContainer::DeleteAt | ( | INT | index,
 |  | BOOLEAN | delete_file = FALSE
 | ) |

Deletes the media reference at index from the metadata database.

Parameters:
index | Index of media reference to delete.
delete_file | Tells if the resource file shall be deleted, too.
See also:
Delete()

BOOLEAN MediaRefContainer::DeleteAt | ( | INT | index,
 |  | BOOLEAN | delete_file = FALSE
 | ) |

Deletes the media reference at index from the metadata database.

Parameters:
index | Index of media reference to delete.
delete_file | Tells if the resource file shall be deleted, too.
See also:
Delete()

const MediaRefPtr& MediaRefContainer::GetElementAt ( INT index ) const

Returns the constant element at index.

Parameters:
index Indicates which element should be returned.

MediaRefPtr& MediaRefContainer::GetElementAt ( INT index )

Returns the element at index.

Parameters:
index Indicates which element should be returned.

const MediaRefPtr & MediaRefContainer::GetElementAt ( INT index ) const

Returns the constant element at index.

Parameters:
index Indicates which element should be returned.

MediaRefPtr & MediaRefContainer::GetElementAt ( INT index )

Returns the element at index.

Parameters:
index Indicates which element should be returned.

INT MediaRefContainer::GetIndex ( const MediaRefPtr & media_ref ) const

Returns the index for a given media reference.

Parameters:
media_ref Media reference to search for.

INT MediaRefContainer::GetIndex ( const MediaRefPtr & media_ref ) const

Returns the index for a given media reference.

Parameters:
media_ref Media reference to search for.

virtual FileFilterPtr MediaRefContainer::GetMediaFileFilter ( ) const [protected, pure virtual]

Returns the media file filter for the media objects of interest.

Implemented in ImageRefContainer, and SoundRefContainer.

virtual FileFilterPtr MediaRefContainer::GetMediaFileFilter ( ) const [protected, pure virtual]

Returns the media file filter for the media objects of interest.

Implemented in ImageRefContainer, and SoundRefContainer.

INT MediaRefContainer::GetSize ( ) const [inline]

Returns the actual number of media references.

INT MediaRefContainer::GetSize ( ) const [inline]

Returns the actual number of media references.

virtual UINT32 MediaRefContainer::GetSizeOfRecord ( ) const [pure virtual]

Returns the size in bytes of one media reference record of the derived class. The size of the media reference records for different media references may differ.

Implemented in ImageRefContainer, and SoundRefContainer.

virtual UINT32 MediaRefContainer::GetSizeOfRecord ( ) const [pure virtual]

Returns the size in bytes of one media reference record of the derived class. The size of the media reference records for different media references may differ.

Implemented in ImageRefContainer, and SoundRefContainer.

void MediaRefContainer::Init ( const Path & database_path )

Initializes the container with the contents of the metadata database at database_path.

Parameters:
database_path Path of the metadata database.

void MediaRefContainer::Init ( const Path & database_path )

Initializes the container with the contents of the metadata database at database_path.

Parameters:
database_path Path of the metadata database.

virtual BOOLEAN MediaRefContainer::IsInDatabase ( const Path & path ) const [protected, virtual]

Tells if file path is already in the metadata database.

BOOLEAN MediaRefContainer::IsInDatabase ( const Path & path ) const [protected, virtual]

Tells if file path is already in the metadata database.

BOOLEAN MediaRefContainer::MediaRefExists ( const Path & path ) const

Returns if a media reference to a media resource with path already exists in the metadata database.

Parameters:
path Resource path which should be checked.

BOOLEAN MediaRefContainer::MediaRefExists ( const Path & path ) const

Returns if a media reference to a media resource with path already exists in the metadata database.

Parameters:
path Resource path which should be checked.

void MediaRefContainer::Refresh ( MediaFilter * filter = 0 )

Removes all entries from the database and reloads them from the repository

void MediaRefContainer::Refresh ( MediaFilter * filter = 0 )

Removes all entries from the database and reloads them from the repository

virtual BOOLEAN MediaRefContainer::Rename | ( | MediaRefPtr & | media_ref,
 |  | const WString & | new_name
 | ) | [virtual]

Renames the resource file of the specified media reference to the name new_name.

Parameters:
media_ref | Media reference whose resource file to rename.
new_name | New name of the media reference's resource file.

Reimplemented in ImageRefContainer.

BOOLEAN MediaRefContainer::Rename | ( | MediaRefPtr & | media_ref,
 |  | const WString & | new_name
 | ) | [virtual]

Renames the resource file of the specified media reference to the name new_name.

Parameters:
media_ref | Media reference whose resource file to rename.
new_name | New name of the media reference's resource file.

Reimplemented in ImageRefContainer.

static BOOLEAN MediaRefContainer::SaveMedia | ( | MediaRefPtr & | media_ref,
 |  | const UINT8 HUGE * | content,
 |  | UINT32 | length
 | ) | [static]

Writes the binary content of the media reference media_ref . This method is used for saving the files.

Parameters:
media_ref | Media reference for which to store the content.
content | Content to be stored.
length | Length of the content to be stored.

BOOLEAN MediaRefContainer::SaveMedia | ( | MediaRefPtr & | media_ref,
 |  | const UINT8 HUGE * | content,
 |  | UINT32 | length
 | ) | [static]

Writes the binary content of the media reference media_ref . This method is used for saving the files.

Parameters:
media_ref | Media reference for which to store the content.
content | Content to be stored.
length | Length of the content to be stored.

void MediaRefContainer::SearchForFiles | ( | MediaFilter * | app_filter = 0,
 |  | const WString & | storage_device_Id = L"ffs"
 | ) |

Searches the storage device with device Id string storage_device_Id for files complying to the filter which method GetMediaFileFilter returns and adds those files to the database.

void MediaRefContainer::SearchForFiles | ( | MediaFilter * | app_filter = 0,
 |  | const WString & | storage_device_Id = L"ffs"
 | ) |

Searches the storage device with device Id string storage_device_Id for files complying to the filter which method GetMediaFileFilter returns and adds those files to the database.

void MediaRefContainer::SetDbPath ( const Path & path ) [inline]

Set the path of the database file

void MediaRefContainer::SetDbPath ( const Path & path ) [inline]

Set the path of the database file

virtual BOOLEAN MediaRefContainer::SetupMediaObject ( MediaRefPtr & media_ref ) [protected, pure virtual]

Sets up the media object described in metadata and returns if it was successful.

Implemented in ImageRefContainer, and SoundRefContainer.

virtual BOOLEAN MediaRefContainer::SetupMediaObject ( MediaRefPtr & media_ref ) [protected, pure virtual]

Sets up the media object described in metadata and returns if it was successful.

Implemented in ImageRefContainer, and SoundRefContainer.

Friends And Related Function Documentation

ImageBrowserApp [friend]

SoundBrowserApp [friend]

Field Documentation

Path MediaRefContainer::m_path [protected]

The path of the metadata database.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaRefContainer.hpp
  • Applications/SoundBrowser/Common/MediaRefContainer.hpp
  • Applications/ImageBrowser/Common/MediaRefContainer.cpp
  • Applications/SoundBrowser/Common/MediaRefContainer.cpp
Generated on Wed Jan 25 01:27:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaRefLinkable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaRefLinkable Struct Reference
[ImageBrowserCommon, ImageBrowserCommon]

The Linkable wrapping a MediaRef smart pointer. More...

#include <Applications/ImageBrowser/Common/MediaRefContainer.hpp>

Inheritance diagram for MediaRefLinkable:

[legend]
Collaboration diagram for MediaRefLinkable:

[legend]

Public Member Functions

MediaRefLinkable (MediaRefPtr &elem)
MediaRefLinkable (MediaRefPtr &elem)
MediaRefPtr & operator * ()
const MediaRefPtr & | operator * () const
MediaRefPtr & operator * ()
const MediaRefPtr & | operator * () const
BOOLEAN | operator== (const MediaRefLinkable &rhs) const
BOOLEAN | operator== (const MediaRefLinkable &rhs) const

Data Fields

MediaRefPtr m_elem

Detailed Description

The Linkable wrapping a MediaRef smart pointer.

Constructor & Destructor Documentation

MediaRefLinkable::MediaRefLinkable ( MediaRefPtr & elem ) [inline, explicit]

MediaRefLinkable::MediaRefLinkable ( MediaRefPtr & elem ) [inline, explicit]

Member Function Documentation

MediaRefPtr& MediaRefLinkable::operator * ( ) [inline]

const MediaRefPtr& MediaRefLinkable::operator * ( ) const [inline]

MediaRefPtr& MediaRefLinkable::operator * ( ) [inline]

const MediaRefPtr& MediaRefLinkable::operator * ( ) const [inline]

BOOLEAN MediaRefLinkable::operator== ( const MediaRefLinkable & rhs ) const [inline]

BOOLEAN MediaRefLinkable::operator== ( const MediaRefLinkable & rhs ) const [inline]

Field Documentation

MediaRefPtr MediaRefLinkable::m_elem

The documentation for this struct was generated from the following files:
  • Applications/ImageBrowser/Common/MediaRefContainer.hpp
  • Applications/SoundBrowser/Common/MediaRefContainer.hpp
Generated on Wed Jan 25 01:27:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaVisitor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaVisitor Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/MediaVisitor.hpp>

Inheritance diagram for MediaVisitor:

[legend]

Public Member Functions

virtual void | Visit (const MediaRef &media_ref)=0
virtual void | Visit (const MediaRef &media_ref)=0
virtual | ~MediaVisitor ()
virtual | ~MediaVisitor ()

Protected Member Functions

MediaVisitor ()
MediaVisitor ()

Detailed Description

Abstract base class for media references like image or sound references. This class defines the interface for setting and getting the metadata for the content.

Constructor & Destructor Documentation

MediaVisitor::MediaVisitor ( ) [protected]

MediaVisitor::~MediaVisitor ( ) [virtual]

MediaVisitor::MediaVisitor ( ) [protected]

virtual MediaVisitor::~MediaVisitor ( ) [virtual]

Member Function Documentation

virtual void MediaVisitor::Visit ( const MediaRef & media_ref ) [pure virtual]

Implemented in MediaPathnameVisitor, and MediaPathnameVisitor.

virtual void MediaVisitor::Visit ( const MediaRef & media_ref ) [pure virtual]

Implemented in MediaPathnameVisitor, and MediaPathnameVisitor.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaVisitor.hpp
  • Applications/SoundBrowser/Common/MediaVisitor.hpp
  • Applications/ImageBrowser/Common/MediaVisitor.cpp
  • Applications/SoundBrowser/Common/MediaVisitor.cpp
Generated on Wed Jan 25 01:27:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Melody Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Melody Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/Melody.hpp>

Inheritance diagram for Melody:

[legend]
Collaboration diagram for Melody:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual Audio::ToneData * | GetToneData ()
Returns a valid buffer to native data of the melody.
void | Init (BOOLEAN copyrighted=FALSE)
virtual BOOLEAN | IsCopyrighted () const
Returns TRUE if the sound is copyrighted, FALSE otherwise.
Melody (BOOLEAN copyrighted=FALSE)
virtual BOOLEAN | Play (AudioContext *context)
virtual void | SetCopyright (BOOLEAN state)
virtual | ~Melody ()

Protected Member Functions

void | SetName (const WCHAR *name)
Sets the name the sound. The text is buffered by the object.

Detailed Description

Obsolete - all sound classes from AddOns/MultiMedia have been replaced by a new audio concept. Use the AudioDeviceManager instead for playing sounds.

Constructor & Destructor Documentation

Melody::Melody ( BOOLEAN copyrighted = FALSE )

Melody::~Melody ( ) [virtual]

Member Function Documentation

const WCHAR * Melody::GetName ( ) const [virtual]

See also:
Sound::GetName

Implements Sound.

Audio::ToneData * Melody::GetToneData ( ) [virtual]

Returns a valid buffer to native data of the melody.

Reimplemented in IMelody.

void Melody::Init ( BOOLEAN copyrighted = FALSE )

BOOLEAN Melody::IsCopyrighted ( ) const [virtual]

Returns TRUE if the sound is copyrighted, FALSE otherwise.

BOOLEAN Melody::Play ( AudioContext * context ) [virtual]

See also:
Sound::Play

Implements Sound.

void Melody::SetCopyright ( BOOLEAN state ) [virtual]

void Melody::SetName ( const WCHAR * name ) [inline, protected]

Sets the name the sound. The text is buffered by the object.

The documentation for this class was generated from the following files:
  • Compat/Melody.hpp
  • Compat/Melody.cpp
Generated on Wed Jan 25 01:27:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MemMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MemMap Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/BinData.hpp>

Public Member Functions

const UINT8 * | GetHandle (UINT32 idx=0) const
UINT32 | GetLength () const
Returns the number of bytes which are accessable.
MemMap (void *ptr, UINT32 len, INT id)
UINT32 | Read (UINT32 idx, void *buf, UINT32 byte_count) const
BOOLEAN | Read (UINT32 idx, UINT8 &val) const
virtual | ~MemMap ()

Friends

class | BinData

Detailed Description

MemMap provides read only access to a range of bytes from BinData.

Constructor & Destructor Documentation

MemMap::MemMap | ( | void * | ptr,
 |  | UINT32 | len,
 |  | INT | id
 | ) |

Constructs a memory map object with the given data.

Parameters:
ptr | Pointer to the data.
len | Length of data.
id | ID of instance.

MemMap::~MemMap ( ) [virtual]

Member Function Documentation

const UINT8 * MemMap::GetHandle ( UINT32 idx = 0 ) const

Returns a pointer to the value at the given index idx, or 0 if the index is not valid.

UINT32 MemMap::GetLength ( ) const [inline]

Returns the number of bytes which are accessable.

UINT32 MemMap::Read | ( | UINT32 | idx,
 |  | void * | buf,
 |  | UINT32 | byte_count
 | ) | const

Read byte_count bytes starting from the index idx to the buffer buf. Returns the number of read bytes.

BOOLEAN MemMap::Read | ( | UINT32 | idx,
 |  | UINT8 & | val
 | ) | const

Returns a single byte in val at the given index idx. val is not changed if idx does not exist.

Returns:
TRUE if a value at the index exists, FALSE otherwise.

Friends And Related Function Documentation

friend class BinData [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/BinData.hpp
  • Auxiliary/BinData.cpp
Generated on Wed Jan 25 01:27:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MemoryConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MemoryConfig Class Reference
[Config]

#include <MemoryConfig.hpp>

Static Public Member Functions

static HeapVector::HeapTableEntry * | GetHeapBase ()
static BOOLEAN | IsInRom (const void *ptr)

Detailed Description

Allows accessing the memory configuration. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static HeapVector::HeapTableEntry* MemoryConfig::GetHeapBase ( ) [static]

Returns the heap base table required for the memory management. It should not be necessary for the MMI to use this method in a direct manner.

static BOOLEAN MemoryConfig::IsInRom ( const void * ptr ) [static]

Returns TRUE if the data where ptr points to is located inside the ROM.

The documentation for this class was generated from the following file:
  • MemoryConfig.hpp
Generated on Wed Jan 25 01:27:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MemPool Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MemPool Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/MemPool.hpp>

Collaboration diagram for MemPool:

[legend]

Public Member Functions

void * | Alloc (INT size)
MemPool ()
void | Release (void *data, INT size)
virtual | ~MemPool ()

Constructor & Destructor Documentation

MemPool::MemPool ( )

MemPool::~MemPool ( ) [virtual]

Member Function Documentation

void * MemPool::Alloc ( INT size )

void MemPool::Release | ( | void * | data,
 |  | INT | size
 | ) |

The documentation for this class was generated from the following files:
  • Auxiliary/MemPool.hpp
  • Auxiliary/MemPool.cpp
Generated on Wed Jan 25 01:27:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MemPoolEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MemPoolEntry Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/MemPool.hpp>

Inheritance diagram for MemPoolEntry:

[legend]
Collaboration diagram for MemPoolEntry:

[legend]

Public Member Functions

void * | Alloc (INT size)
BOOLEAN | Contains (void *data) const
MemPoolEntry ()
void | Release (void *p, INT size)

Constructor & Destructor Documentation

MemPoolEntry::MemPoolEntry ( )

Member Function Documentation

void * MemPoolEntry::Alloc ( INT size )

BOOLEAN MemPoolEntry::Contains ( void * data ) const [inline]

void MemPoolEntry::Release | ( | void * | p,
 |  | INT | size
 | ) |

The documentation for this class was generated from the following files:
  • Auxiliary/MemPool.hpp
  • Auxiliary/MemPool.cpp
Generated on Wed Jan 25 01:27:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Menu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Menu Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/Menu.hpp>

Inheritance diagram for Menu:

[legend]
Collaboration diagram for Menu:

[legend]

Public Member Functions

virtual void | Back ()
Invokes the menu to go one level back.
virtual void | ChangeMenuAccessor (AbstractMenuAccessor *accessor, BOOLEAN is_sub_accessor=FALSE)
virtual INT | GetCellCount () const
virtual XYDIM | GetCellHeight () const
virtual XYDIM | GetCellWidth () const
virtual INT | GetColumnCount () const
AbstractMenuAccessor * | GetMenuAccessor () const
void | Init (Control *parent, AbstractMenuAccessor *menu_accessor)
Menu ()
virtual void | Trigger (INT index=-1)
void | UpdateItemCount ()
virtual | ~Menu ()

Protected Member Functions

virtual void | Cleanup ()
virtual void | OnBack ()
This method will be called every time the menu wants to step back one level.
virtual void | OnLanguageChanged ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnSelectionChanged ()
virtual void | OnTrigger ()
This method will be called every time the menu triggers on .
virtual void | Refresh (const Rect &rect)

Detailed Description

Obsolete - use the classes ItemMenu or ItemTree instead, as they allow in an easier but more flexible way the creation of a menu-tree.

Constructor & Destructor Documentation

Menu::Menu ( )

Menu::~Menu ( ) [virtual]

Member Function Documentation

void Menu::Back ( ) [virtual]

Invokes the menu to go one level back.

void Menu::ChangeMenuAccessor | ( | AbstractMenuAccessor * | accessor,
 |  | BOOLEAN | is_sub_accessor = FALSE
 | ) | [virtual]

Changes the accessor of the menu to accessor. For traversing the menu hierarchy it is recommended to use the methods Menu::Trigger and Menu::Back, the method ChangeMenuAccessor is meant to replace a current menu accessor by another one and is usually only used by customized implementations of the class AbstractMenuAccessor. It should not be necessary for the application developer to invoke this method.

Parameters:
accessor | Pointer to the new accessor.
is_sub_accessor | If set to FALSE, the current accessor will be replaced by accessor. If set to TRUE, accessor will be embedded as sub-accessor to the current accessor.

void Menu::Cleanup ( ) [protected, virtual]

See also:
Control::Cleanup

Reimplemented from Control.

INT Menu::GetCellCount ( ) const [virtual]

See also:
AbstractGrid::GetCellCount

Implements AbstractGrid.

XYDIM Menu::GetCellHeight ( ) const [virtual]

See also:
AbstractGrid::GetCellHeight

Implements AbstractGrid.

XYDIM Menu::GetCellWidth ( ) const [virtual]

See also:
AbstractGrid::GetCellWidth

Reimplemented from AbstractGrid.

INT Menu::GetColumnCount ( ) const [virtual]

See also:
AbstractGrid::GetColumnCount

Implements AbstractGrid.

AbstractMenuAccessor* Menu::GetMenuAccessor ( ) const [inline]

Returns:
Pointer to the current MenuAccessor.

void Menu::Init | ( | Control * | parent,
 |  | AbstractMenuAccessor * | menu_accessor
 | ) |

Parameters:
parent | Control which embeds the Menu.
menu_accessor | Pointer to the accessor of the main menu.

void Menu::OnBack ( ) [protected, virtual]

This method will be called every time the menu wants to step back one level.

void Menu::OnLanguageChanged ( ) [protected, virtual]

See also:
Control::OnLanguageChanged

Reimplemented from Control.

BOOLEAN Menu::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Component.

void Menu::OnSelectionChanged ( ) [protected, virtual]

See also:
AbstractGrid::OnSelectionChanged

Reimplemented from AbstractGrid.

void Menu::OnTrigger ( ) [protected, virtual]

This method will be called every time the menu triggers on .

void Menu::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from AbstractGrid.

void Menu::Trigger ( INT index = -1 ) [virtual]

Invokes the menu to trigger the currently selected item. This meens that the menu automatically changes in presence of a submenu. Per default the selected item is triggered.

Parameters:
index Index of the item which should get triggered. If the index is < 0, the selected item is triggered.

void Menu::UpdateItemCount ( )

The menu buffers the number of items for efficiency reasons. If the number of menu-items in the menu-accessor are changed, this method must be invoked to get a consistent state.

The documentation for this class was generated from the following files:
  • Compat/Menu.hpp
  • Compat/Menu.cpp
Generated on Wed Jan 25 01:27:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuAccessor Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/MenuAccessor.hpp>

Inheritance diagram for MenuAccessor:

[legend]
Collaboration diagram for MenuAccessor:

[legend]

Public Member Functions

virtual void | Back (Menu *menu)
virtual void | Draw (DeviceContext *dc, const Rect &draw_rect, BOOLEAN highlighted)
virtual INT | GetColumnCount () const
virtual XYDIM | GetItemHeight () const
virtual const BitmapRes * | GetItemIcon (BOOLEAN highlighted)
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
INT | GetSelectedIndex () const
const WCHAR * | GetTitle () const
void | Init (const WCHAR *title)
void | Init (INT columns=1, INT selected_idx=0)
virtual BOOLEAN | IsRoot ()
MenuAccessor (const WCHAR *title)
MenuAccessor (INT columns, INT selected_idx=0)
MenuAccessor ()
void | SetColumnCount (INT columns)
void | SetItemHeight (XYDIM item_height)
void | SetSelectedIndex (INT selected_idx)
void | SetTitle (const WCHAR *title)
virtual void | Trigger (Menu *menu)
virtual | ~MenuAccessor ()

Protected Member Functions

virtual AbstractMenuAccessor * | GetChild ()
virtual AbstractMenuAccessor * | GetParent () const
virtual void | OnActivate (Menu *menu, AbstractMenuAccessor *parent_accessor)
virtual void | OnDeactivate (Menu *menu)
virtual void | OnLanguageChanged ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnSelectionChanged (INT selected_idx)
This method will be called every time the selection of the menu changes.
virtual void | OnTrigger (INT selected_idx)

Detailed Description

Obsolete - the class Menu, which uses the MenuAccessor, has been replaced by the classes ItemMenu and ItemTree.

The MenuAccessor is an abstract class which represents one menu level and gives access to its corresponding menu items. The following pure virtual methods must be implemented by derived classes:

  • AbstractMenuAccessor::First()
  • AbstractMenuAccessor::Next() Also at least one of the methods:
  • MenuAccessor::GetItemText()
  • MenuAccessor::GetItemIcon() must be overwritten to return the a text or an icon for an item.

The menu-accessor automatically does a horizontal scrolling of the text, if an item is selected and does not fit into the available width.

Constructor & Destructor Documentation

MenuAccessor::MenuAccessor ( )

MenuAccessor::MenuAccessor | ( | INT | columns,
 |  | INT | selected_idx = 0
 | ) |

MenuAccessor::MenuAccessor ( const WCHAR * title )

MenuAccessor::~MenuAccessor ( ) [virtual]

Member Function Documentation

void MenuAccessor::Back ( Menu * menu ) [virtual]

See also:
AbstractMenuAccessor::Back

Implements AbstractMenuAccessor.

void MenuAccessor::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | draw_rect,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

Draws the menu item.

Parameters:
dc | Pointer to the device context for drawing.
draw_rect | Rectangle which describes the area where to draw the menu item.
highlighted | TRUE, if the menu item to be drawn is the currently selected one.

Implements AbstractMenuAccessor.

AbstractMenuAccessor * MenuAccessor::GetChild ( ) [protected, virtual]

Returns:
Pointer to the child MenuAccessor representing the submenu. Return 0 if the current menu item has no submenu.

Reimplemented in AbstractActionMenuAccessor.

INT MenuAccessor::GetColumnCount ( ) const [virtual]

Returns:
Number of columns.

Reimplemented from AbstractMenuAccessor.

XYDIM MenuAccessor::GetItemHeight ( ) const [virtual]

If no item-height has been set by SetItemHeight(), the height of the current menu-font is returned. Otherwise the height set by SetItemHeight() is returned.

Implements AbstractMenuAccessor.

const BitmapRes * MenuAccessor::GetItemIcon ( BOOLEAN highlighted ) [virtual]

Returns the item-icon for the currently iterated item. The input-parameter highlighted indicates, whether the item is highlighted. Per default 0 is returned, hence this method should be overwritten when an icon is needed.

Reimplemented in AbstractActionMenuAccessor.

const WCHAR * MenuAccessor::GetItemText ( BOOLEAN highlighted ) [virtual]

Returns the item-text for the currently iterated item. The input-parameter highlighted indicates, whether the item is highlighted. Per default 0 is returned, hence this method should be overwritten when a text is needed.

Reimplemented in AbstractActionMenuAccessor.

AbstractMenuAccessor * MenuAccessor::GetParent ( ) const [protected, virtual]

INT MenuAccessor::GetSelectedIndex ( ) const [inline]

Returns:
Index of the selected menu item.

const WCHAR* MenuAccessor::GetTitle ( ) const [inline]

void MenuAccessor::Init ( const WCHAR * title )

Reimplemented in AbstractActionMenuAccessor.

void MenuAccessor::Init | ( | INT | columns = 1,
 |  | INT | selected_idx = 0
 | ) |

Parameters:
colums | Number of columns to be shown.
selected_idx | Index of the selected menu item.

BOOLEAN MenuAccessor::IsRoot ( ) [virtual]

See also:
AbstractMenuAccessor::IsRoot

Reimplemented from AbstractMenuAccessor.

void MenuAccessor::OnActivate | ( | Menu * | menu,
 |  | AbstractMenuAccessor * | parent_accessor
 | ) | [protected, virtual]

See also:
AbstractMenuAccessor::OnActivate

Reimplemented from AbstractMenuAccessor.

void MenuAccessor::OnDeactivate ( Menu * menu ) [protected, virtual]

See also:
AbstractMenuAccessor::OnDeactivate

Reimplemented from AbstractMenuAccessor.

void MenuAccessor::OnLanguageChanged ( ) [protected, virtual]

See also:
AbstractMenuAccessor::OnLanguageChanged

Reimplemented from AbstractMenuAccessor.

Reimplemented in AbstractActionMenuAccessor.

BOOLEAN MenuAccessor::OnMessage ( const Message & msg ) [protected, virtual]

See also:
AbstractMenuAccessor::OnMessage

Reimplemented from AbstractMenuAccessor.

void MenuAccessor::OnSelectionChanged ( INT selected_idx ) [protected, virtual]

This method will be called every time the selection of the menu changes.

Reimplemented from AbstractMenuAccessor.

void MenuAccessor::OnTrigger ( INT selected_idx ) [protected, virtual]

This method will be called every time a menu item with no submenu has been triggerd.

Parameters:
selected_idx Index of the currently selected menu item.

Reimplemented in AbstractActionMenuAccessor, and ActionMenuAccessor.

void MenuAccessor::SetColumnCount ( INT columns ) [inline]

Parameters:
columns Number of columns.

void MenuAccessor::SetItemHeight ( XYDIM item_height ) [inline]

Sets the height of an item in pixels. If a value <= 0 is used, GetItemHeight() returns the height of the current menu-font.

void MenuAccessor::SetSelectedIndex ( INT selected_idx )

Parameters:
selected_idx Index of the selected menu item.

void MenuAccessor::SetTitle ( const WCHAR * title )

void MenuAccessor::Trigger ( Menu * menu ) [virtual]

See also:
AbstractMenuAccessor::Trigger

Implements AbstractMenuAccessor.

Reimplemented in AbstractActionMenuAccessor.

The documentation for this class was generated from the following files:
  • Compat/MenuAccessor.hpp
  • Compat/MenuAccessor.cpp
Generated on Wed Jan 25 01:27:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuDesc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuDesc Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/MenuDesc.hpp>

Collaboration diagram for MenuDesc:

[legend]

Public Member Functions

FeatureItemContainer * | GetItemContainer () const
const MenuProperties * | GetMenuProperties () const
void | Init (FeatureItemContainer *container, const MenuProperties *menu_properties)
MenuDesc (FeatureItemContainer *container, const MenuProperties *menu_properties)
MenuDesc ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~MenuDesc ()

Detailed Description

This configuration class contains a feature item container and menu properties to be applied for it
See also:
FeatureItemContainer

MenuProperties

Constructor & Destructor Documentation

MenuDesc::MenuDesc ( )

MenuDesc::MenuDesc | ( | FeatureItemContainer * | container,
 |  | const MenuProperties * | menu_properties
 | ) |

MenuDesc::~MenuDesc ( ) [virtual]

Member Function Documentation

FeatureItemContainer* MenuDesc::GetItemContainer ( ) const [inline]

const MenuProperties* MenuDesc::GetMenuProperties ( ) const [inline]

void MenuDesc::Init | ( | FeatureItemContainer * | container,
 |  | const MenuProperties * | menu_properties
 | ) |

BOOLEAN MenuDesc::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

The documentation for this class was generated from the following files:
  • Atl/Context/MenuDesc.hpp
  • Atl/Context/MenuDesc.cpp
Generated on Wed Jan 25 01:27:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuDescObj Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuDescObj Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/MenuDescObj.hpp>

Inheritance diagram for MenuDescObj:

[legend]
Collaboration diagram for MenuDescObj:

[legend]

Public Member Functions

virtual GenericObject * | Copy () const
Creates a copy of the object itself.
const MenuDesc & | GetMenuDesc ()
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself.
MenuDescObj (const MenuDesc &menu_desc)
void | SetMenuDesc (const MenuDesc &menu_desc)
virtual | ~MenuDescObj ()

Constructor & Destructor Documentation

MenuDescObj::MenuDescObj ( const MenuDesc & menu_desc )

The documentation for this class was generated from the following files:
  • Atl/Context/MenuDescObj.hpp
  • Atl/Context/MenuDescObj.cpp
Generated on Wed Jan 25 01:27:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuIdObj Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuIdObj Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/MenuIdObj.hpp>

Inheritance diagram for MenuIdObj:

[legend]
Collaboration diagram for MenuIdObj:

[legend]

Public Member Functions

virtual GenericObject * | Copy () const
Creates a copy of the object itself.
const MenuID & | GetMenuId ()
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object.
MenuIdObj (const MenuID &menu_id)
void | SetMenuID (const MenuID &menu_id)
virtual | ~MenuIdObj ()

Constructor & Destructor Documentation

MenuIdObj::MenuIdObj ( const MenuID & menu_id )

MenuIdObj::~MenuIdObj ( ) [virtual]

Member Function Documentation

GenericObject * MenuIdObj::Copy ( ) const [virtual]

Creates a copy of the object itself.

Implements GenericObject.

const MenuID& MenuIdObj::GetMenuId ( ) [inline]

GenericTypeId MenuIdObj::GetTypeId ( ) [virtual]

Returns the identity of the class.

Implements GenericObject.

BOOLEAN MenuIdObj::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object.

Implements GenericObject.

void MenuIdObj::SetMenuID ( const MenuID & menu_id ) [inline]

The documentation for this class was generated from the following files:
  • Atl/Features/MenuIdObj.hpp
  • Atl/Features/MenuIdObj.cpp
Generated on Wed Jan 25 01:27:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuItem Class Reference

#include <Apoxi/Compat/MenuItem.hpp>

Inheritance diagram for MenuItem:

[legend]
Collaboration diagram for MenuItem:

[legend]

Public Member Functions

Action * | GetAction () const
void | Init (Action *action)
MenuItem (Action *action)
MenuItem ()
void | SetAction (Action *action)

Detailed Description

Obsolete - a menu-item is needed by a MenuList, which is obsolete. Use Menu and MenuAccessor from Gui instead.

Constructor & Destructor Documentation

MenuItem::MenuItem ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

MenuItem::MenuItem ( Action * action )

Member Function Documentation

Action* MenuItem::GetAction ( ) const [inline]

void MenuItem::Init ( Action * action )

void MenuItem::SetAction ( Action * action ) [inline]

The documentation for this class was generated from the following files:
  • Compat/MenuItem.hpp
  • Compat/MenuItem.cpp
Generated on Wed Jan 25 01:27:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuList Class Reference

Obsolete - use Menu and MenuAccessor from Gui instead. More...

#include <Apoxi/Compat/MenuList.hpp>

Inheritance diagram for MenuList:

[legend]
Collaboration diagram for MenuList:

[legend]

Public Member Functions

void | AddItem (MenuItem *item, Action *action) const
void | AddItem (MenuItem *item, MenuItem *after=0)
MenuItem * | GetFirstItem () const
void | Init (Window *parent)
MenuList (Window *parent)
MenuList ()
void | RemoveAllItems () const
void | RemoveItem (MenuItem *item)
virtual | ~MenuList ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual void | OnItemSelected ()
virtual void | OnLanguageChanged ()
virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Detailed Description

Obsolete - use Menu and MenuAccessor from Gui instead.

Constructor & Destructor Documentation

MenuList::MenuList ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

MenuList::MenuList ( Window * parent )

Parameters:
parent Pointer to the window, which embedds the MenuList.

MenuList::~MenuList ( ) [virtual]

Member Function Documentation

void MenuList::AddItem | ( | MenuItem * | item,
 |  | Action * | action
 | ) | const

void MenuList::AddItem | ( | MenuItem * | item,
 |  | MenuItem * | after = 0
 | ) |

Parameters:
item | MenuItem to be added to the item list.
after | By default (0) the item is appended to the end of the item list. Otherwise it will be inserted after this item.

Model * MenuList::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

MenuItem * MenuList::GetFirstItem ( ) const

Returns:
First item of the item list.

void MenuList::Init ( Window * parent )

Parameters:
parent Pointer to the window, which embedds the MenuList.

void MenuList::OnItemSelected ( ) [protected, virtual]

See also:
AbstractMenuList::OnItemSelected

Reimplemented from AbstractMenuList.

void MenuList::OnLanguageChanged ( ) [protected, virtual]

See also:
Control::OnLanguageChanged

Reimplemented from Control.

void MenuList::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from AbstractListBox.

void MenuList::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect &rect)

Reimplemented from AbstractListBox.

void MenuList::RemoveAllItems ( ) const

void MenuList::RemoveItem ( MenuItem * item )

Parameters:
item MenuItem to be removed from the item list.

The documentation for this class was generated from the following files:
  • Compat/MenuList.hpp
  • Compat/MenuList.cpp
Generated on Wed Jan 25 01:27:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuListView Class Reference

#include <Apoxi/Compat/MenuList.hpp>

Inheritance diagram for MenuListView:

[legend]
Collaboration diagram for MenuListView:

[legend]

Public Member Functions

virtual void | DrawItem (const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const
MenuListView (XYDIM item_height)
MenuListView ()
virtual | ~MenuListView ()

Protected Member Functions

virtual void | DrawMenuItem (const MenuItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const

Constructor & Destructor Documentation

MenuListView::MenuListView ( )

MenuListView::MenuListView ( XYDIM item_height )

MenuListView::~MenuListView ( ) [virtual]

Member Function Documentation

void MenuListView::DrawItem | ( | const AbstractListBox & | listbox,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [virtual]

Reimplemented from AbstractListBoxView.

void MenuListView::DrawMenuItem | ( | const MenuItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

The documentation for this class was generated from the following files:
  • Compat/MenuList.hpp
  • Compat/MenuList.cpp
Generated on Wed Jan 25 01:27:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuPool Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuPool Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/MenuPool.hpp>

Inheritance diagram for MenuPool:

[legend]
Collaboration diagram for MenuPool:

[legend]

Public Types

enum itemType {
itemTypeNone = 0, itemTypeFeatureItem, itemTypeContextFeatureItem, itemTypeFixedContextFeatureItem,
itemTypePropertyItem, itemTypeFeatureItemContainer
}

Public Member Functions

virtual MenuDesc * | GetMenu (const MenuID &id)
virtual void | InitMenus ()
BOOLEAN | MenuFileExists () const
MenuPool ()
constructor
virtual void | OnFeatureAdded (Feature *feature)
virtual void | OnFeatureStatusChanged (Feature *feature)
virtual | ~MenuPool ()
destructor

Data Structures

struct | FeatureItemContainerContentTableEntry
struct | FeatureItemContainerTableEntry
class | MenuMapItem
struct | MenuTableEntry

Detailed Description

The MenuPool creates menus out of configuration data. Configuration data is either provided by an Aragon resource file (which can be located in a customization pack or directly in the ffs), or by a static configuration. For the static configuration, MenuTableNodes have to be created where the configuration data is provided by following structs:
  • FeatureItemContainerTableEntry
  • MenuTableEntry
  • FeatureItemContainerContentTableEntry

Such MenuTableNodes can be created anywhere in the code. The nodes are linked together like a linked list and read in by the MenuPool.

If building with Aragon and an Aragon configuration is available, the menus are constructed using this Aragon configuration. If no Aragon configuration can be found, the static configuration is used.

Member Enumeration Documentation

enum MenuPool::itemType

Enumerator:
itemTypeNone
itemTypeFeatureItem
itemTypeContextFeatureItem
itemTypeFixedContextFeatureItem
itemTypePropertyItem
itemTypeFeatureItemContainer

Constructor & Destructor Documentation

MenuPool::MenuPool ( )

constructor

MenuPool::~MenuPool ( ) [virtual]

destructor

Member Function Documentation

MenuDesc * MenuPool::GetMenu ( const MenuID & id ) [virtual]

Parameters:
MenuID of the requested menu
Returns:
MenuDesc of the requested menu.

void MenuPool::InitMenus ( ) [virtual]

Initializes the menus. Constructs the MenuResourceTable needed for reading in the Aragon configuration file.

BOOLEAN MenuPool::MenuFileExists ( ) const

Returns TRUE, if an Aragon configuration file exists. Looks for Aragon configuration file in CustomizationPack and in FFS.

void MenuPool::OnFeatureAdded ( Feature * feature ) [virtual]

Parameters:
pointer to feature, which has been added.

void MenuPool::OnFeatureStatusChanged ( Feature * feature ) [virtual]

Parameters:
pointer to feature, whose status has changed The FeatureItemContainer, which contains the feature, is invalidated.

The documentation for this class was generated from the following files:
  • Atl/Features/MenuPool.hpp
  • Atl/Features/MenuPool.cpp
Generated on Wed Jan 25 01:27:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuPool::FeatureItemContainerContentTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MenuPool::FeatureItemContainerContentTableEntry

MenuPool::FeatureItemContainerContentTableEntry Struct Reference

#include <Apoxi/Atl/Features/MenuPool.hpp>

Collaboration diagram for MenuPool::FeatureItemContainerContentTableEntry:

[legend]

Data Fields

const CHAR * | application_id
const FeatureItemContainerTableEntry
HUGE_64K * 		container_table_entry
const CHAR * | context_id
const void * | datum
const CHAR * | feature_id
const CHAR * | icon_id
UINT8 | item_type
const CHAR * | property_editor_id
const CHAR * | text

Detailed Description

FeatureItemContainerContentTableEntry: item_type: Type of Item (FeatureItem, ContextFeatureItem, FeatureItemContainer ...) container_table_entry: submenu, needed if the item type is a FeatureItemContainer applicaton_id: ApplicationID of application the Feature belongs to feature_id: FeatureID of Feature; icon_id: icon URI datum: Pointer to DataItem or pointer to PropertyDescriptor property_editor_id: PropertyID defining the Editor to edit a PropertyItem context_id: ContextID of this Item

Field Documentation

const CHAR* MenuPool::FeatureItemContainerContentTableEntry::application_id

const FeatureItemContainerTableEntry HUGE_64K* MenuPool::FeatureItemContainerContentTableEntry::container_table_entry

const CHAR* MenuPool::FeatureItemContainerContentTableEntry::context_id

const void* MenuPool::FeatureItemContainerContentTableEntry::datum

const CHAR* MenuPool::FeatureItemContainerContentTableEntry::feature_id

const CHAR* MenuPool::FeatureItemContainerContentTableEntry::icon_id

UINT8 MenuPool::FeatureItemContainerContentTableEntry::item_type

const CHAR* MenuPool::FeatureItemContainerContentTableEntry::property_editor_id

const CHAR* MenuPool::FeatureItemContainerContentTableEntry::text

The documentation for this struct was generated from the following file:
  • Atl/Features/MenuPool.hpp
Generated on Wed Jan 25 01:28:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuPool::FeatureItemContainerTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MenuPool::FeatureItemContainerTableEntry

MenuPool::FeatureItemContainerTableEntry Struct Reference

#include <Apoxi/Atl/Features/MenuPool.hpp>

Collaboration diagram for MenuPool::FeatureItemContainerTableEntry:

[legend]

Data Fields

const FeatureItemContainerContentTableEntry
HUGE_64K * 		container_content_table_entry
const CHAR * | container_id
const CHAR * | context_id
const CHAR * | icon_id
const ItemRendererProperties * | render_properties
const CHAR * | text

Detailed Description

FeatureItemContainerTableEntry feature_item_container_content_table: Reference to the configuration of the items of the FeatureItemContainer text: Text to be displayed in the menu icon_id: Icon to be displayed in the menu renderer_properties: defines how the items of the FeatureItemContainer has to be displayed Context_id: ContextID of this FeatureItemContainer

Field Documentation

const FeatureItemContainerContentTableEntry HUGE_64K* MenuPool::FeatureItemContainerTableEntry::container_content_table_entry

const CHAR* MenuPool::FeatureItemContainerTableEntry::container_id

const CHAR* MenuPool::FeatureItemContainerTableEntry::context_id

const CHAR* MenuPool::FeatureItemContainerTableEntry::icon_id

const ItemRendererProperties* MenuPool::FeatureItemContainerTableEntry::render_properties

const CHAR* MenuPool::FeatureItemContainerTableEntry::text

The documentation for this struct was generated from the following file:
  • Atl/Features/MenuPool.hpp
Generated on Wed Jan 25 01:28:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuPool::MenuTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MenuPool::MenuTableEntry

MenuPool::MenuTableEntry Struct Reference

#include <Apoxi/Atl/Features/MenuPool.hpp>

Collaboration diagram for MenuPool::MenuTableEntry:

[legend]

Data Fields

const FeatureItemContainerTableEntry
HUGE_64K * 		container_table_entry
const CHAR * | menu_id
const MenuProperties * | menu_properties

Detailed Description

MenuTableEntry container_table_entry: Reference to the configuration of the FeatureItemContainer menu_id: MenuID of the menu menu_properties: Properties of menu window

Field Documentation

const FeatureItemContainerTableEntry HUGE_64K* MenuPool::MenuTableEntry::container_table_entry

const CHAR* MenuPool::MenuTableEntry::menu_id

const MenuProperties* MenuPool::MenuTableEntry::menu_properties

The documentation for this struct was generated from the following file:
  • Atl/Features/MenuPool.hpp
Generated on Wed Jan 25 01:28:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuProperties Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuProperties Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/MenuProperties.hpp>

Collaboration diagram for MenuProperties:

[legend]

Public Types

enum | Corner { TopLeft, TopRight, BottomLeft, BottomRight }
enum | MenuType { FullSize, PopUp }
enum TitleTextType {
NoTitle, ItemContainerText, ItemText, ParentItemText,
ContextDependantTitle, UndefinedTitleText
}

Public Member Functions

BOOLEAN | CloseAfterTrigger () const
Corner | GetCorner () const
MenuType | GetMenuType () const
const Point & | GetPos () const
TitleTextType | GetTitleTextType () const
MenuProperties (MenuType=FullSize, BOOLEAN close_after_trigger=FALSE, TitleTextType=UndefinedTitleText)
void | SetCloseAfterTrigger (BOOLEAN flag)
void | SetCorner (Corner corner)
void | SetMenuType (MenuType menu_type)
void | SetPos (const Point &pos)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetTitleTextType (TitleTextType title_text)
virtual | ~MenuProperties ()

Detailed Description

This configuration class specifies following menu properties:
  • Menu type (FullSize | Popup>
  • In case of Popup menus: Corner to which the popup menu should be aligned
  • In case of Popup menus: Explicit position of the popup menu
  • Close after trigger: This flag defines, whether the menu window should close, after a menu item has been triggered

Member Enumeration Documentation

enum MenuProperties::Corner

Enumerator:
TopLeft
TopRight
BottomLeft
BottomRight

enum MenuProperties::MenuType

Enumerator:
FullSize
PopUp

enum MenuProperties::TitleTextType

TitleTextType: defines the title display properties of the menu NoTitle: No title is displayed ItemContainerText: Text of ItemContainer displayed as title - except the case that only the icons of the menu items are displayed, in this case the text of the selected item will be displayed as title. ItemText: Text of selected item displayed as title ParentItemText: Text of selected item of parent window displayed as title - only applicable for popup menus ContextDependantTitle: Text of the title is defined by the context id of the window / the FeatureItemContainer / the selected FeatureItem UndefinedTitleText: No special type of title text defined, the default behaviour will be applied, means for fullsize menus ItemContainerText and for popup menus NoTitle

Enumerator:
NoTitle
ItemContainerText
ItemText
ParentItemText
ContextDependantTitle
UndefinedTitleText

Constructor & Destructor Documentation

MenuProperties::MenuProperties | ( | MenuType | = FullSize,
 |  | BOOLEAN | close_after_trigger = FALSE,
 |  | TitleTextType | = UndefinedTitleText
 | ) |

Constructor

Parameters:
MenuType | defines MenuType of Configuration, default value is FullSize menu
close_after_trigger | default value is FALSE
TitleTextType | default value is UndefinedTitleText

MenuProperties::~MenuProperties ( ) [virtual]

Member Function Documentation

BOOLEAN MenuProperties::CloseAfterTrigger ( ) const [inline]

Returns:
BOOLEAN value of m_close_after_trigger

Corner MenuProperties::GetCorner ( ) const [inline]

Returns:
Corner of configuration

MenuType MenuProperties::GetMenuType ( ) const [inline]

Returns:
MenuType of configuration

const Point& MenuProperties::GetPos ( ) const [inline]

Returns:
Point of configuration

TitleTextType MenuProperties::GetTitleTextType ( ) const [inline]

Returns the type of title disply properties

void MenuProperties::SetCloseAfterTrigger ( BOOLEAN flag ) [inline]

Parameters:
flag sets the close_after_trigger value of configuration

void MenuProperties::SetCorner ( Corner corner ) [inline]

void MenuProperties::SetMenuType ( MenuType menu_type ) [inline]

Parameters:
menu_type sets the MenuType of configuration

void MenuProperties::SetPos ( const Point & pos ) [inline]

BOOLEAN MenuProperties::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

void MenuProperties::SetTitleTextType ( TitleTextType title_text ) [inline]

Sets the type of title display properties

The documentation for this class was generated from the following files:
  • Atl/Context/MenuProperties.hpp
  • Atl/Context/MenuProperties.cpp
Generated on Wed Jan 25 01:28:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuSelectionRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuSelectionRejArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for MenuSelectionRejArg:

[legend]
Collaboration diagram for MenuSelectionRejArg:

[legend]

Public Types

enum | { ID = 1312 }

Public Member Functions

MenuSelectionRejArg ()

Static Public Member Functions

static const MenuSelectionRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MenuSelectionRejArg: reflects arguments of signal SI_MENU_SELECTION_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MenuSelectionRejArg::MenuSelectionRejArg ( )

Member Function Documentation

const MenuSelectionRejArg & MenuSelectionRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:28:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuSelectionReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuSelectionReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for MenuSelectionReqArg:

[legend]
Collaboration diagram for MenuSelectionReqArg:

[legend]

Public Types

enum | { ID = 2312 }

Public Member Functions

const SimItemId & | GetItemId () const
BOOLEAN | IsInfoRequested () const
MenuSelectionReqArg ()
MenuSelectionReqArg (const SimItemId &item_id, BOOLEAN info_requested)
void | SetInfoRequested (BOOLEAN info_requested)
void | SetItemId (const SimItemId &item_id)

Static Public Member Functions

static const MenuSelectionReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MenuSelectionReqArg: reflects arguments of signal SI_MENU_SELECTION_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MenuSelectionReqArg::MenuSelectionReqArg | ( | const SimItemId & | item_id,
 |  | BOOLEAN | info_requested
 | ) |

MenuSelectionReqArg::MenuSelectionReqArg ( )

Member Function Documentation

const MenuSelectionReqArg & MenuSelectionReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimItemId& MenuSelectionReqArg::GetItemId ( ) const [inline]

BOOLEAN MenuSelectionReqArg::IsInfoRequested ( ) const [inline]

void MenuSelectionReqArg::SetInfoRequested ( BOOLEAN info_requested ) [inline]

void MenuSelectionReqArg::SetItemId ( const SimItemId & item_id ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:28:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuTable Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/MenuTable.hpp>

Collaboration diagram for MenuTable:

[legend]

Static Public Member Functions

static const MenuTableNode * | GetRoot ()
static INT | GetSize ()

Friends

class | MenuTableNode

Member Function Documentation

static const MenuTableNode* MenuTable::GetRoot ( ) [inline, static]

Returns:
the root of the linked list

INT MenuTable::GetSize ( ) [static]

Returns:
the size of the linked list

Friends And Related Function Documentation

friend class MenuTableNode [friend]

The documentation for this class was generated from the following files:
  • Atl/Features/MenuTable.hpp
  • Atl/Features/MenuTable.cpp
Generated on Wed Jan 25 01:28:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuTableNode Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/MenuTableNode.hpp>

Collaboration diagram for MenuTableNode:

[legend]

Public Member Functions

const MenuPool::MenuTableEntry * | GetEntry () const
const MenuTableNode * | GetNext () const
MenuTableNode (const MenuPool::MenuTableEntry *entry)
virtual | ~MenuTableNode ()
destructor

Friends

class | MenuTable

Constructor & Destructor Documentation

MenuTableNode::MenuTableNode ( const MenuPool::MenuTableEntry * entry )

constructor

Parameters:
MenuTableEntry,: provides all information needed to construct a MenuDesc.

MenuTableNode::~MenuTableNode ( ) [virtual]

destructor

Member Function Documentation

const MenuPool::MenuTableEntry* MenuTableNode::GetEntry ( ) const [inline]

Returns:
MenuTableEntry: all information needed to construct a ContextDescription.

const MenuTableNode* MenuTableNode::GetNext ( ) const [inline]

Returns:
the next node of this linked list to iterate through this linked list.

Friends And Related Function Documentation

friend class MenuTable [friend]

The documentation for this class was generated from the following files:
  • Atl/Features/MenuTableNode.hpp
  • Atl/Features/MenuTableNode.cpp
Generated on Wed Jan 25 01:28:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuTextIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuTextIterator Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/MenuTextIterator.hpp>

Inheritance diagram for MenuTextIterator:

[legend]

Public Member Functions

virtual INT | ItemCount () const =0
virtual const WCHAR * | operator() (INT idx) const =0

Detailed Description

Obsolete - the class Menu, which uses the MenuTextIterator, has been replaced by the classes ItemMenu and ItemTree.

The class MenuTextIterator is an abstract class for the iteration of a text-array.

Member Function Documentation

virtual INT MenuTextIterator::ItemCount ( ) const [pure virtual]

Implemented in MenuTextPtrArrayIterator.

virtual const WCHAR* MenuTextIterator::operator() ( INT idx ) const [pure virtual]

Implemented in MenuTextPtrArrayIterator.

The documentation for this class was generated from the following file:
  • Compat/MenuTextIterator.hpp
Generated on Wed Jan 25 01:28:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuTextPtrArrayIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuTextPtrArrayIterator Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/MenuTextPtrArrayIterator.hpp>

Inheritance diagram for MenuTextPtrArrayIterator:

[legend]
Collaboration diagram for MenuTextPtrArrayIterator:

[legend]

Public Member Functions

void | Init (INT item_count, const WCHAR **menu_text)
virtual INT | ItemCount () const
MenuTextPtrArrayIterator (INT item_count=0, const WCHAR **menu_text=0)
virtual const WCHAR * | operator() (INT idx) const

Detailed Description

Obsolete - the class Menu, which uses the MenuTextPtrArrayIterator, has been replaced by the classes ItemMenu and ItemTree.

Iterator for a text-array with a specified size. This iterator is useful for e. g. the Text-Menu-Accessor.

Constructor & Destructor Documentation

MenuTextPtrArrayIterator::MenuTextPtrArrayIterator | ( | INT | item_count = 0,
 |  | const WCHAR ** | menu_text = 0
 | ) |

Member Function Documentation

void MenuTextPtrArrayIterator::Init | ( | INT | item_count,
 |  | const WCHAR ** | menu_text
 | ) |

INT MenuTextPtrArrayIterator::ItemCount ( ) const [virtual]

Implements MenuTextIterator.

const WCHAR * MenuTextPtrArrayIterator::operator() ( INT idx ) const [virtual]

Implements MenuTextIterator.

The documentation for this class was generated from the following files:
  • Compat/MenuTextPtrArrayIterator.hpp
  • Compat/MenuTextPtrArrayIterator.cpp
Generated on Wed Jan 25 01:28:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuView Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/Menu.hpp>

Inheritance diagram for MenuView:

[legend]
Collaboration diagram for MenuView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
BOOLEAN | IsBackgrDrawingEnabled () const
MenuView ()
virtual | ~MenuView ()

Constructor & Destructor Documentation

MenuView::MenuView ( )

MenuView::~MenuView ( ) [virtual]

Member Function Documentation

void MenuView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

BOOLEAN MenuView::IsBackgrDrawingEnabled ( ) const [inline]

The documentation for this class was generated from the following files:
  • Compat/Menu.hpp
  • Compat/Menu.cpp
Generated on Wed Jan 25 01:28:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MenuWindow Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MenuWindow Class Reference

#include <Apoxi/Compat/MenuWindow.hpp>

Inheritance diagram for MenuWindow:

[legend]
Collaboration diagram for MenuWindow:

[legend]

Public Member Functions

MenuWindow ()
virtual | ~MenuWindow ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()

Detailed Description

Obsolete - it is recommended to use the classes Menu and MenuAccessor from Gui instead of this class.

Constructor & Destructor Documentation

MenuWindow::MenuWindow ( )

MenuWindow::~MenuWindow ( ) [virtual]

Member Function Documentation

BOOLEAN MenuWindow::OnCancel ( ) [protected, virtual]

See also:
Window::OnCancel.

The documentation for this class was generated from the following files:
  • Compat/MenuWindow.hpp
  • Compat/MenuWindow.cpp
Generated on Wed Jan 25 01:28:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MePhonebookDescription Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MePhonebookDescription Class Reference

#include <Apoxi/Apc/AtcTypes.hpp>

Collaboration diagram for MePhonebookDescription:

[legend]

Public Member Functions

BOOLEAN | AppendMePhonebookDescriptor (const MePhonebookDescriptor &desc)
Appends an MePhonebookDescriptor object to the list.
const MePhonebookDescriptor & | Get (INT idx) const
UINT | GetCount () const
overall number of appended MePhonebookDescriptor objects
MePhonebookDescription (const MePhonebookDescription &desc)
MePhonebookDescription ()
MePhonebookDescription & | operator= (const MePhonebookDescription &desc)

Constructor & Destructor Documentation

MePhonebookDescription::MePhonebookDescription ( ) [inline]

MePhonebookDescription::MePhonebookDescription ( const MePhonebookDescription & desc ) [inline]

Member Function Documentation

BOOLEAN MePhonebookDescription::AppendMePhonebookDescriptor ( const MePhonebookDescriptor & desc ) [inline]

Appends an MePhonebookDescriptor object to the list.

const MePhonebookDescriptor& MePhonebookDescription::Get ( INT idx ) const [inline]

UINT MePhonebookDescription::GetCount ( ) const [inline]

overall number of appended MePhonebookDescriptor objects

MePhonebookDescription& MePhonebookDescription::operator= ( const MePhonebookDescription & desc ) [inline]

The documentation for this class was generated from the following file:
  • Apc/AtcTypes.hpp
Generated on Wed Jan 25 01:28:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MePhonebookDescriptor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MePhonebookDescriptor Class Reference

#include <Apoxi/Apc/AtcTypes.hpp>

Public Member Functions

INT | GetMaxAlphaLen () const
MePhoneBookType | GetMePhoneBookType () const
INT | GetTotalEntries () const
MePhonebookDescriptor (const MePhonebookDescriptor &desc)
MePhonebookDescriptor ()
MePhonebookDescriptor (MePhoneBookType type, INT totalentries, INT maxalphalen)
constructor
MePhonebookDescriptor & | operator= (const MePhonebookDescriptor &desc)

Constructor & Destructor Documentation

MePhonebookDescriptor::MePhonebookDescriptor | ( | MePhoneBookType | type,
 |  | INT | totalentries,
 |  | INT | maxalphalen
 | ) | [inline]

constructor

MePhonebookDescriptor::MePhonebookDescriptor ( ) [inline]

MePhonebookDescriptor::MePhonebookDescriptor ( const MePhonebookDescriptor & desc ) [inline]

Member Function Documentation

INT MePhonebookDescriptor::GetMaxAlphaLen ( ) const [inline]

MePhoneBookType MePhonebookDescriptor::GetMePhoneBookType ( ) const [inline]

INT MePhonebookDescriptor::GetTotalEntries ( ) const [inline]

MePhonebookDescriptor& MePhonebookDescriptor::operator= ( const MePhonebookDescriptor & desc ) [inline]

The documentation for this class was generated from the following file:
  • Apc/AtcTypes.hpp
Generated on Wed Jan 25 01:28:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MergeProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MergeProvider Class Reference
[AuxExtensions]

#include <Apoxi/AddOns/AuxExtensions/MergeProvider.hpp>

Inheritance diagram for MergeProvider:

[legend]
Collaboration diagram for MergeProvider:

[legend]

Public Types

enum | AffectedProvider { Both, ChildOnly, MergeOnly, None }
Which provider should be affected by modifing operations. More...

Public Member Functions

virtual BOOLEAN | AppendRow ()
Appends a row to the affected provider.
virtual INT | ColumnCount () const
virtual BOOLEAN | CommitRow (INT row)
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
virtual BOOLEAN | DeleteRow (INT row)
AffectedProvider GetAffectedProvider ()
GetAffectedProvider returns the AffectedProvider value which was set via SetParameter.
INT | GetChildKeyColumnId () const
GetFirstKeyColumn returns the id of the key column of the first child-provider.
virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
GetChildRow returns the effective row of the child-provider.
virtual const ColumnInfo * | GetColumnInfo (INT column)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
virtual BOOLEAN | GetDefaultDataItem (INT columnid, INT row, DataItem &item)
INT | GetMergedKeyColumnId () const
GetSecondKeyColumn returns the id of the key column of the second child-provider.
Provider * GetMergedProvider ()
GetMergeProvider returns the provider which is merged into the child provider.
JoinRule * GetMergeRule ()
GetMergeRule returns the current rule for merging.
virtual INT | GetProviderId () const
GetProviderId() reflects the provider Id of the child-provider.
void | Init (INT provider_id, Provider *child_provider, Provider *merged_provider, INT child_key_colid, INT merge_key_colid, JoinRule *merge_rule, UINT max_cache_depth=6)
The same interface as the constructor.
virtual BOOLEAN | InsertRow (INT row)
Inserts a row in front of the row specified in the affected provider.
virtual BOOLEAN | Lock ()
Lock locks both child providers.
MergeProvider (INT provider_id, Provider *child_provider, Provider *merge_provider, INT child_key_colid, INT merge_key_colid, JoinRule *merge_rule, UINT max_cache_depth=6)
MergeProvider ()
virtual void | OnExecutingListener (Provider *provider=0)
Called by DelegationProviderListener to modify the progress value.
virtual BOOLEAN | SelectRow (INT row)
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
void | SetForceUpdate ()
void | SetMergedProvider (Provider *merged_provider, INT merge_key_colid)
SetMergeProvider changes the provider which should be merged into the child provider.
void | SetMergeRule (JoinRule *merge_rule)
SetMergeRule sets the current rule for merging.
virtual BOOLEAN | SetParameter (const DataItem &item)
virtual BOOLEAN | ToggleRow (INT row)
virtual BOOLEAN | Unlock ()
Unlock unlocks both child providers.
virtual BOOLEAN | Update (ProviderListener *listener=0)
virtual | ~MergeProvider ()
Destructor.

Protected Member Functions

INT | BinSearchRow (INT size, const DataItem &item, DataItem *cache=0, UINT cache_size=0, UINT8 cache_depth=0)
UINT | GetCacheSize (UINT8 max_cache_depth, INT row_count)
Returns the size of the cache for a given maximum cache depth and "row_count" data rows.
void | InitIndexTable ()
virtual BOOLEAN | IsLess (const DataItem &item1, const DataItem &item2)
virtual void | OnChildProviderModification (Provider *provider, const Provider::Modification &modification)
void | QuickSortDataItems (INT &size, INT low, INT high)
BOOLEAN | UpdateIndexTable (ModificationType type, BOOLEAN child_prov_affected, INT row=c_no_row)

Protected Attributes

INT | m_child_key_id
UINT | m_max_cache_depth
INT8 | m_max_progress
INT | m_merge_key_id
BOOLEAN | m_merge_needed
Provider * m_merge_provider
JoinRule * m_merge_rule
IndexTable< INT > | m_merged_rows
INT8 | m_min_progress
IndexTable< INT > | m_sorted_table

Detailed Description

A MergeProvider merges the columns of two providers by the specified column id for the specified merge rule. The result contains all rows of the source provider, joined with the first matching row of the merge provider. If no row matshes, c_merged_row_id will return c_no_row.
This provider offers the folling additional columns:
c_merged_row_id | NumberType | The joined key row. Must be used for append and insert.
c_merged_provider_id | ProviderType | The merged provider (may be 0).

Member Enumeration Documentation

enum MergeProvider::AffectedProvider

Which provider should be affected by modifing operations.

Enumerator:
Both | both providers, this is default
ChildOnly | only the first
MergeOnly | only the second
None | Read only.

Constructor & Destructor Documentation

MergeProvider::MergeProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

MergeProvider::MergeProvider | ( | INT | provider_id,
 |  | Provider * | child_provider,
 |  | Provider * | merge_provider,
 |  | INT | child_key_colid,
 |  | INT | merge_key_colid,
 |  | JoinRule * | merge_rule,
 |  | UINT | max_cache_depth = 6
 | ) |

On construction the following parameters have to be specified:

  • provider_id: The provider id for this MergeProvider.
  • child_provider: The provider which should be appended.
  • merge_provider: The provider which is merged into src_provider.
  • child_colid: The column id of the source provider which should be used as join key.
  • merge_colid: The column id of the merge provider which should be used as join key.
  • merge_rule: The first child provider which should be joined.
  • max_cache_depth: The maximum recursive depth of temporary cached rows during a complete update. Please be aware, that the given cache depth results in (2^n-1) cache entries, the default cache depth is 6, so per default a maximum of 63 DataItems are cached. The memory of this cache is allocated during Update() and freed afterwards automatically.

MergeProvider::~MergeProvider ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN MergeProvider::AppendRow ( ) [virtual]

Appends a row to the affected provider.

Reimplemented from AbstractDelegationProvider.

Reimplemented in PbMergeProvider.

INT MergeProvider::BinSearchRow | ( | INT | size,
 |  | const DataItem & | item,
 |  | DataItem * | cache = 0,
 |  | UINT | cache_size = 0,
 |  | UINT8 | cache_depth = 0
 | ) | [protected]

INT MergeProvider::ColumnCount ( ) const [virtual]

See also:
Provider::ColumnCount()

Reimplemented from AbstractDelegationProvider.

BOOLEAN MergeProvider::CommitRow ( INT row ) [virtual]

Commits only the rows of the affected providers.

See also:
SetParameter

Provider::Commit

Reimplemented from AbstractDelegationProvider.

BOOLEAN MergeProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all merged rows of the affected providers.

See also:
SetParameter

Provider::DeleteAllRows

Reimplemented from AbstractDelegationProvider.

Reimplemented in PbMergeProvider.

BOOLEAN MergeProvider::DeleteRow ( INT row ) [virtual]

Deletes only the rows of the affected providers.

See also:
SetParameter

Provider::DeleteRow

Reimplemented from AbstractDelegationProvider.

Reimplemented in PbMergeProvider.

AffectedProvider MergeProvider::GetAffectedProvider ( ) [inline]

GetAffectedProvider returns the AffectedProvider value which was set via SetParameter.

UINT MergeProvider::GetCacheSize | ( | UINT8 | max_cache_depth,
 |  | INT | row_count
 | ) | [protected]

Returns the size of the cache for a given maximum cache depth and "row_count" data rows.

INT MergeProvider::GetChildKeyColumnId ( ) const [inline]

GetFirstKeyColumn returns the id of the key column of the first child-provider.

BOOLEAN MergeProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

GetChildRow returns the effective row of the child-provider.

Implements AbstractDelegationProvider.

const ColumnInfo * MergeProvider::GetColumnInfo ( INT column ) [virtual]

See also:
Provider::GetColumnInfo()

Reimplemented from AbstractDelegationProvider.

BOOLEAN MergeProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
Provider::GetDataItem

Implements AbstractDelegationProvider.

BOOLEAN MergeProvider::GetDefaultDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

Called if GetDataItem is invoked on a column of the merge provider for a row which is not supported by the merge provider. Returns FALSE.

Reimplemented in PhoneNumberMergeProvider, and PbMergeProvider.

INT MergeProvider::GetMergedKeyColumnId ( ) const [inline]

GetSecondKeyColumn returns the id of the key column of the second child-provider.

Provider* MergeProvider::GetMergedProvider ( ) [inline]

GetMergeProvider returns the provider which is merged into the child provider.

JoinRule* MergeProvider::GetMergeRule ( ) [inline]

GetMergeRule returns the current rule for merging.

INT MergeProvider::GetProviderId ( ) const [virtual]

GetProviderId() reflects the provider Id of the child-provider.

Reimplemented from AbstractDelegationProvider.

void MergeProvider::Init | ( | INT | provider_id,
 |  | Provider * | child_provider,
 |  | Provider * | merged_provider,
 |  | INT | child_key_colid,
 |  | INT | merge_key_colid,
 |  | JoinRule * | merge_rule,
 |  | UINT | max_cache_depth = 6
 | ) |

The same interface as the constructor.

void MergeProvider::InitIndexTable ( ) [protected]

BOOLEAN MergeProvider::InsertRow ( INT row ) [virtual]

Inserts a row in front of the row specified in the affected provider.

Reimplemented from AbstractDelegationProvider.

BOOLEAN MergeProvider::IsLess | ( | const DataItem & | item1,
 |  | const DataItem & | item2
 | ) | [protected, virtual]

Reimplemented in PhoneNumberMergeProvider.

BOOLEAN MergeProvider::Lock ( ) [virtual]

Lock locks both child providers.

Reimplemented from AbstractDelegationProvider.

void MergeProvider::OnChildProviderModification | ( | Provider * | provider,
 |  | const Provider::Modification & | modification
 | ) | [protected, virtual]

Reimplemented from AbstractDelegationProvider.

void MergeProvider::OnExecutingListener ( Provider * provider = 0 ) [virtual]

Called by DelegationProviderListener to modify the progress value.

Reimplemented from AbstractDelegationProvider.

void MergeProvider::QuickSortDataItems | ( | INT & | size,
 |  | INT | low,
 |  | INT | high
 | ) | [protected]

BOOLEAN MergeProvider::SelectRow ( INT row ) [virtual]

Selects only the rows of the affected providers.

See also:
SetParameter

Provider::SelectRow

Reimplemented from AbstractDelegationProvider.

BOOLEAN MergeProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

See also:
Provider::SetDataItem

Reimplemented from AbstractDelegationProvider.

void MergeProvider::SetForceUpdate ( ) [inline]

void MergeProvider::SetMergedProvider | ( | Provider * | merged_provider,
 |  | INT | merge_key_colid
 | ) |

SetMergeProvider changes the provider which should be merged into the child provider.

void MergeProvider::SetMergeRule ( JoinRule * merge_rule )

SetMergeRule sets the current rule for merging.

BOOLEAN MergeProvider::SetParameter ( const DataItem & item ) [virtual]

Set the affected providers for all modifying operations using AffectedProvider enum as number type in item.

Reimplemented from AbstractDelegationProvider.

Reimplemented in PbMergeProvider.

BOOLEAN MergeProvider::ToggleRow ( INT row ) [virtual]

Toggles only the rows of the affected providers.

See also:
SetParameter

Provider::ToggleRow

Reimplemented from AbstractDelegationProvider.

BOOLEAN MergeProvider::Unlock ( ) [virtual]

Unlock unlocks both child providers.

Reimplemented from AbstractDelegationProvider.

BOOLEAN MergeProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update updates both underlaying providers if they are not up to date and forces a new merge.

Reimplemented from AbstractDelegationProvider.

Reimplemented in PbMergeProvider.

BOOLEAN MergeProvider::UpdateIndexTable | ( | ModificationType | type,
 |  | BOOLEAN | child_prov_affected,
 |  | INT | row = c_no_row
 | ) | [protected]

Field Documentation

INT MergeProvider::m_child_key_id [protected]

UINT MergeProvider::m_max_cache_depth [protected]

INT8 MergeProvider::m_max_progress [protected]

INT MergeProvider::m_merge_key_id [protected]

BOOLEAN MergeProvider::m_merge_needed [protected]

Provider* MergeProvider::m_merge_provider [protected]

JoinRule* MergeProvider::m_merge_rule [protected]

IndexTable<INT> MergeProvider::m_merged_rows [protected]

INT8 MergeProvider::m_min_progress [protected]

IndexTable<INT> MergeProvider::m_sorted_table [protected]

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/MergeProvider.hpp
  • AddOns/AuxExtensions/MergeProvider.cpp
Generated on Wed Jan 25 01:28:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Message Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Message Class Reference
[Kernel]

#include <Apoxi/Kernel/Message.hpp>

Inheritance diagram for Message:

[legend]

Public Member Functions

MsgCategory | Category () const
virtual Message * | Clone () const =0
virtual const MsgMetaData & | GetMetaData () const =0
MsgId | Id () const
Message ()
MsgOrigin | Origin () const
void | Post () const
virtual | ~Message ()

Friends

class | AppContainer
class | MessageReferrer
class | MessageRouter

Detailed Description

Every message has an unique id and and may get the following kind of message category:
  • MC_SYSTEM: For default messages. After passing a message to the message-router, the messages are broadcasted to all applications. Note that an application must register itself for messages it wants to receive.
  • MC_FOCUS: For messages, which should be send to the focused application/control. The applications don not need to register for messages which have the category MC_FOCUS.
  • MC_CONTEXT: For messages which should be forwarded to one specific context only. Note that each message with the category MC_CONTEXT is an instance of the class ContextMsg and hence contains a pointer to the ExecutionContext, which should get the message. The context does not need to register for messages with the category MC_CONTEXT. Messages of the category MC_CONTEXT only make sense for asynchronous messages, which are sent using method Message::Post().
  • MC_APP: Only for backward compatibility. Application is derived from ExecutionContext.
  • MC_CONTROL: For messages which should be forwarded to one specific control only. Note that each message with the category MC_CONTROL is an instance of the class ControlMsg and hence contains a pointer to the control, which should get the message. Messages of the category MC_CONTROL only make sense for synchronous messages, which are send by application.SendSelf(...).
  • MC_IPC: For messages (inter process communication) to communication between applications, containers and signal-handler. After passing a message to the message-router, the messages are broadcast to all applications. Note that an application must register itself for messages it wants to receive. (same functionality as MC_SYSTEM)
  • MC_BROADCAST: For messages which should be broadcast to every application. No registration for these message is needed!
  • MC_SIGNAL: For internal messages, which are to protocol stack via SignalHandler (only to be used in ADC & ASC)
  • MC_AT: For internal messages, which are used to an possibly existing AtHandler (APC stack communication modul like the SignalHandler) Other message categories are available (see class MsgCategory for details), but are used only internally.

Constructor & Destructor Documentation

Message::Message ( )

Message::~Message ( ) [virtual]

Member Function Documentation

MsgCategory Message::Category ( ) const [inline]

virtual Message* Message::Clone ( ) const [pure virtual]

Implemented in DataControlModificationMsg, DataControlStartBootMsg, DataControlBootProgressMsg, DataControlBootMsg, DataControlEndBootMsg, DataControlPhonebookStateMsg, UsimPbReadyMsg, UsimPbResetedMsg, FatFsUsbMassStorageRequestMsg, FatFsUsbMassStorageReleaseMsg, DrmWapPushMsg, AppActionExecutedMsg, LocationNotifInvokeMsg, LocationResMsg, LocationErrMsg, AbortResMsg, ProviderChangedMsg, ProcessMolrMsg, SetupDataConnMsg, SendRequestMsg, GltpConnStatusMsg, CloseDataConnMsg, EmServThreadMsg, MediaManagerMsg, MCServiceInterfaceMsg, MmCallStatusMsg, MmCallDisconnectingMsg, MmMocSetupAcceptMsg, MmCallSetupProgressMsg, MmCallInfoMsg, MmCallNotifyMsg, MmCurrentChargeDataMsg, MmCurrentCallMeterMsg, MmAocChargingStatusMsg, MmCallAcceptMsg, MmCallReleaseMsg, FtpServiceMessage, FtpErrorMessage, FtpTransferMessage, FtpRequestMessage, FtpConnectMessage, FtpDisconnectMessage, HttpServiceMessage, HttpErrorMessage, HttpRequestMessage, HttpConnectMessage, HttpDisconnectMessage, SvgDecodingFinishedMsg, SvgStatusMsg, SvgHyperlinkSelectMsg, DBItemChangedMsg, VrPromptMsg, VrResultMsg, VrErrorMsg, VrWarningMsg, VrRecognitionAbortedMsg, VrTrainingAbortedMsg, VrRecognitionStoppedMsg, VrTrainingResultMsg, VrPlaybackFinishedMsg, VrTrainingFailedMsg, VrRecognitionFailedMsg, RegNotifyMsg, RegCbNotifyMsg, FileChunkOperationProgressMsg, RfsMediaAvailableStatusMsg, RfsStorageDeviceRegistrationStatusMsg, FromStackMsg, ToStackMsg, SsMessage, SimStateChangedMsg, SimLockStatusMsg, GprsStatusMsg, CallEventMsg, CallControlIndMsg, SsControlIndMsg, UssdControlIndMsg, SmsControlIndMsg, ChvChangedMsg, PdpContextActivationStatusMsg, GprsAttachStatusMsg, ExternalPdpContextInfoMsg, CallAcceptMsg, CallReleaseMsg, MptyCallReleaseMsg, CfuStatusMsg, SimErrorMsg, NetworkInformationMsg, TimeZoneMsg, LsaIdentityMsg, SiChannelOpenPromptReqMsg, SiChannelCloseInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelReceiveInfoIndMsg, AlarmMsg, MinuteTickMsg, SignalStrengthLevelMsg, SignalQualityLevelMsg, AccessoryIndMsg, RegistrationSuccessMsg, RegistrationChangeMsg, PlmnScanFinishedMsg, RegistrationAllowedMsg, SimCallSetupMsg, SimSmsSentMsg, SimSsSentMsg, SimRefreshMsg, SimRefreshResetMsg, SimResetConfirmationMsg, SimResetDoneMsg, SimDisplayTextMsg, SimGetInputMsg, SimGetInkeyMsg, SimSelectItemMsg, SimSetupMenuMsg, SimMenuItemSelectionFailedMsg, SimPlayToneMsg, SimSetupIdleModeTextMsg, SimEndTransactionMsg, SimCallSetupRejectedMsg, CallOnHoldMsg, CallHoldRejectedMsg, MptyOnHoldMsg, MptyHoldRejectedMsg, SimTkLanguageNotificationMsg, SimTkSetupEventMsg, TermRspCnfMsg, SimTkRefreshStartMsg, SimTkProfileGetCnfMsg, SimTkProfileSetCnfMsg, SimTkProfileSetRejMsg, SimLaunchBrowserReqMsg, SimLaunchBrowserPromptReqMsg, SimBrowserTermResMsg, OmMultiSlotIndMsg, DhChannelOpenReqMsg, DhChannelCloseReqMsg, DhChannelSendReqMsg, DhChannelDataAvailableResMsg, DhChannelReceiveReqMsg, DhChannelChangeStatusResMsg, SimTkRunAtCmdInfoIndMsg, SimTkSendDtmfIndMsg, SimTkSendDtmfEndIndMsg, PowerModeIndMsg, MocSetupAcceptMsg, CalledPartyAlertingMsg, MtcArrivedMsg, MtcReadyMsg, CallSetupProgressMsg, CallDisconnectingMsg, CallDisconnectedMsg, CallInfoMsg, DtmfStartCnfMsg, DtmfStopCnfMsg, DtmfRejectMsg, DtmfBufferCleanedMsg, RemotePartyActionMsg, ConnectionStatusMsg, CallNotifyMsg, RedialStartedMsg, RedialStoppedMsg, RedialSetupMsg, RedialSuccessMsg, AocChargingStatusMsg, CurrentCallMeterMsg, CurrentChargeDataMsg, DiagnosticIndMsg, RedialStatusMsg, CallControlInfoMsg, MocSetupRejectIndMsg, ForwardingInfoReceivedMsg, BarringInfoReceivedMsg, SsDataReceivedMsg, SsNotificationMsg, InterrogationResultMsg, PasswordReceivedMsg, UssDataReceivedMsg, HlrSsDataCorruptMsg, SsSuccessMsg, SsEndMsg, SsRejectedMsg, SsErrIndicationMsg, PasswordInquiryMsg, PasswordRejectedMsg, UssdIndicationMsg, UssdResentMsg, SsFacilityRejectedMsg, SsInfoMsg, CcbsRecallMsg, CcbsStatusMsg, CcbsResultMsg, UssdAnswerMsg, EngineeringReportMsg, BandSelectionMsg, HomezoneMsg, NwDiscStartIndMsg, RatStateMsg, GsmBandStateMsg, BandStatusMsg, EngineeringModeControlResponseMsg, RatChangeModeChangedMsg, CellInfoMsg, SmsNewMessageMsg, SmsNewStatusReportMsg, SmsNewSocketDataMsg, SmsPortDataRecvMsg, SmsSendConfirmMsg, SmsSendRejectMsg, SmsSpaceExceededMsg, SmsSpaceAvailableMsg, CbsNewDataMsg, SmsPrefStorageMediaChangedMsg, SmsMessageWaitingChangedMsg, CbsLimitMsg, PbSizeRequestMsg, PbEntryRequestMsg, PbAlphaTagRequestMsg, CallDeflectionIndMsg, CallDeflectionErrIndicationMsg, CallDeflectionRejectedMsg, CtmInfoIndMsg, SsRequestSentMsg, SsRequestAcceptedMsg, SsRequestRejectedMsg, CallWaitingActivatedMsg, CallWaitingDeactivatedMsg, CallWaitingStatusMsg, EmlppRegisteredMsg, EmlppStatusMsg, NetworkSsErrorMsg, NetworkSsRejectedMsg, StackSsRejectedMsg, ClirNotSurpressedMsg, CallForwardingActiveMsg, CallHeldMsg, CallRetrievedMsg, CallIsWaitingMsg, CallBarredMsg, ForwardedCallIncomingMsg, HlrDataCorruptedMsg, CugCallMsg, OutgoingCallForwardedMsg, IncomingCallForwardedMsg, MultiPartyCallInvokedMsg, EctActiveMsg, EctAlertingMsg, CnapInfoReceivedMsg, CallForwardingActivatedMsg, CallForwardingDeactivatedMsg, CallForwardingStatusMsg, CallForwardingRegisteredMsg, CallForwardingErasedMsg, CallBarringActivatedMsg, CallBarringDeactivatedMsg, CallBarringStatusMsg, ClipStatusMsg, ColpStatusMsg, ColrStatusMsg, CnapStatusMsg, ClirStatusMsg, CallBarringPasswordChangedMsg, SsErrorMsg, UssdRequestMsg, UssdNotifyMsg, UssdEndMsg, UssdDataMsg, UssdRequestResentMsg, GetPasswordMsg, UusStatusMsg, UusQueryRejectedMsg, UusNotificationMsg, UusRegisteredMsg, UusErasedMsg, UssdBeginMsg, IndicatorBarUpdateMsg, CloseAllMsg, UpdateContextItemMsg, FeatureChangedMsg, PropertyTriggerMsg, FeatureTriggerMsg, ContextFeatureTriggerMsg, UpdateItemMsg, DisabledFeatureTriggeredMsg, AudioDeviceStatusMsg, AudioErrorMsg, AudioGetPlayPositionMsg, AudioUserDefinedMsg, AudioRecordingStoppedMsg, AudioAccessoryConnectedMsg, AudioFmRadioSeekMsg, AudioFmRadioRssiMsg, AudioFmRadioRdsRawDataMsg, AudioFmRadioRdsStationNameMsg, AudioFmRadioRdsRadioTextMsg, AudioFmRadioRdsInfoMsg, AudioFmRadioRdsAlternativeFrequenciesMsg, AudioFastForwardStartedMsg, AudioRewindStartedMsg, AudioMsg, AudioPlayTimeMsg, AudioRadioDeviceNotificationMsg, AudioRestartedMsg, AudioResumedMsg, AudioStartedMsg, AudioStoppedMsg, AudioStreamingSyncMsg, AudioSuspendedMsg, AudioVoiceMemoOutOfSpaceMsg, BtAvrcpNotificationMessage, BtAvrcpOperationServiceMessage, BtAvrcpRequestStateChangedMessage, BtBipProgressMsg, BtBppRequestStateChangedMessage, BtApplicationMessage, BtGapAndSdapApplicationMessage, BtGapAndSdapRemoteRequestMessage, BtPasskeyRequiredMessage, BtAuthorizationRequiredMessage, BtGapAndSdapNotificationMessage, BtRemoteDevicePairMessage, BtGapAndSdapRequestMessage, BtStateChangedMessage, BtLocalSettingsMessage, BtLocalNameMessage, BtDiscoverabilityMessage, BtPairabilityMessage, BtConnectabilityMessage, BtProfileActivationMessage, BtSendPasskeyMessage, BtRespondAuthorizationMessage, BtDeviceSearchMessage, BtRemoteDeviceMessage, BtRemoteDeviceNameMessage, BtCancelSearchMessage, BtSetRemoteDeviceNameMessage, BtDevicePairMessage, BtDeviceUnpairMessage, BtDeviceTrustMessage, BtDeviceUntrustMessage, BtQuerySupportedProfilesMessage, BtHsSupportedProfileMessage, BtHfSupportedProfileMessage, BtPaSupportedProfileMessage, BtServiceVerifyMessage, BtServiceVerifyResultMessage, BtCancelVerifyMessage, BtRequestMessage, BtOpenMessage, BtCloseMessage, BtRequestOperationMessage, BtSddbRequestStateChangedMessage, BtServiceMessage, BtRequestStateChangedMessage, BtDunApplicationMessage, BtDunConnectMessage, BtDunDisconnectMessage, BtDunRequestStateChangedMessage, BtFaxApplicationMessage, BtFaxConnectMessage, BtFaxDisconnectMessage, BtFaxRequestStateChangedMessage, BtHfNotificationMessage, BtHfRequestStateChangedMessage, BtHsNotificationMessage, BtHsRequestStateChangedMessage, BtObexServerNotificationMessage, BtObexClientNotificationMessage, BtObexServerRequestStateChangedMessage, BtObexClientRequestStateChangedMessage, ChargerInfoMsg, BatteryLoadLevelMsg, DisplayInfoMsg, LedNotificationMsg, TransportNotificationMsg, RtcInfoMsg, FocusNextControlMsg, FocusPreviousControlMsg, SelectionChangedMsg, InvalidateMsg, ImageDecodingProgressMsg, ViewfinderErrorMsg, ContextMenuClosedMsg, RefreshComponentMsg, CloseWindowMsg, AragonMsg, T9NoWordFoundMsg, T9AddWordMsg, T9EnteredUnknownWordMsg, T9SymbolEntryRequestMsg, T9MatrixModeKeypressed, Zi8NoWordFoundMsg, Zi8AddWordMsg, Zi8EnteredUnknownWordMsg, ImageDrawingInterruptedMsg, DeleteComponentMsg, ImageEncodingProgressMsg, ItemRendererPropertiesChangedMsg, RedrawDisplayMsg, NoMessage, PowerOnMsg, PowerOffMsg, AppOpenMsg, AppCloseMsg, AppUpdateDisplayMsg, ThemeChangedMsg, LanguageChangedMsg, PowerWakeupMsg, KeyDownMsg, KeyUpMsg, LongKeyPressMsg, VeryLongKeyPressMsg, KeyAutoRepeatMsg, FlipMsg, LockedKeyDownMsg, LockedKeyMsg, InputCharMsg, PenDownMsg, PenUpMsg, ExternalTimeoutMsg, ItemPropertiesChangedMsg, ActionExecutedMsg, RtcTimeChangedMsg, RtcDateChangedMsg, RtcAlarmReachedMsg, ServiceThreadTerminateMsg, AppGetFocusMsg, AppLoseFocusMsg, SharedTimerMsg, ThreadletNotificationMsg, ContextWakeupMsg, ShutdownRequestMsg, AlarmNotificationMsg, TimerTimeoutMsg, ContextExecuteMsg, GetFocusMsg, LoseFocusMsg, ObexAppMsg, ObexMsg, ObexTriggerMsg, ObexAddrMsg, ObexTransportMsg, ObexVCardMsg, SocketControlMsg, DataConnInfoMsg, DataConnProfileInfoMsg, AsyncUnitTestMsg, UtcStatusMessage, JumpToRowMsg, OpenPbWinMsg, SaveEntryInPhonebookMsg, SyncProgressMsg, ProviderUpdateMsg, PhonebookRenumberedMsg, BtIndicatorMsg, CameraMsgStartViewfinding, CameraMsgStopViewfinding, SmsServiceMsg, SmsServiceDocumentMsg, SendSmsMsg, ImageBrowserDeleteImageMsg, ImageBrowserRenameImageMsg, ImageBrowserServiceMsg, LcsAppTransferLocMsg, LcsAppRegisterForMtlrMsg, LcsAppResWinMsg, OnDataRcvdMsg, StartSocketTestMsg, NextSocketTestMsg, ContinueSocketTestMsg, StopSocketTestMsg, SkipSocketTestMsg, SoundBrowserServiceMsg, UibRegisterMsg, UibNotifyMsg, and UibUpdateMsg.

virtual const MsgMetaData& Message::GetMetaData ( ) const [pure virtual]

Implemented in DataControlModificationMsg, DataControlStartBootMsg, DataControlBootProgressMsg, DataControlBootMsg, DataControlEndBootMsg, DataControlPhonebookStateMsg, UsimPbReadyMsg, UsimPbResetedMsg, FatFsUsbMassStorageRequestMsg, FatFsUsbMassStorageReleaseMsg, DrmWapPushMsg, AppActionExecutedMsg, LocationNotifInvokeMsg, LocationResMsg, LocationErrMsg, AbortResMsg, ProviderChangedMsg, ProcessMolrMsg, SetupDataConnMsg, SendRequestMsg, GltpConnStatusMsg, CloseDataConnMsg, EmServThreadMsg, MediaManagerMsg, MCServiceInterfaceMsg, MmCallStatusMsg, MmCallDisconnectingMsg, MmMocSetupAcceptMsg, MmCallSetupProgressMsg, MmCallInfoMsg, MmCallNotifyMsg, MmCurrentChargeDataMsg, MmCurrentCallMeterMsg, MmAocChargingStatusMsg, MmCallAcceptMsg, MmCallReleaseMsg, FtpServiceMessage, FtpErrorMessage, FtpTransferMessage, FtpRequestMessage, FtpConnectMessage, FtpDisconnectMessage, HttpServiceMessage, HttpErrorMessage, HttpRequestMessage, HttpConnectMessage, HttpDisconnectMessage, SvgDecodingFinishedMsg, SvgStatusMsg, SvgHyperlinkSelectMsg, DBItemChangedMsg, VrPromptMsg, VrResultMsg, VrErrorMsg, VrWarningMsg, VrRecognitionAbortedMsg, VrTrainingAbortedMsg, VrRecognitionStoppedMsg, VrTrainingResultMsg, VrPlaybackFinishedMsg, VrTrainingFailedMsg, VrRecognitionFailedMsg, RegNotifyMsg, FileChunkOperationProgressMsg, RfsMediaAvailableStatusMsg, RfsStorageDeviceRegistrationStatusMsg, FromStackMsg, ToStackMsg, SsMessage, SimStateChangedMsg, SimLockStatusMsg, GprsStatusMsg, CallEventMsg, CallControlIndMsg, SsControlIndMsg, UssdControlIndMsg, SmsControlIndMsg, ChvChangedMsg, PdpContextActivationStatusMsg, GprsAttachStatusMsg, ExternalPdpContextInfoMsg, CallAcceptMsg, CallReleaseMsg, MptyCallReleaseMsg, CfuStatusMsg, SimErrorMsg, NetworkInformationMsg, TimeZoneMsg, LsaIdentityMsg, SiChannelOpenPromptReqMsg, SiChannelCloseInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelReceiveInfoIndMsg, AlarmMsg, MinuteTickMsg, SignalStrengthLevelMsg, SignalQualityLevelMsg, AccessoryIndMsg, RegistrationSuccessMsg, RegistrationChangeMsg, PlmnScanFinishedMsg, RegistrationAllowedMsg, SimCallSetupMsg, SimSmsSentMsg, SimSsSentMsg, SimRefreshMsg, SimRefreshResetMsg, SimResetConfirmationMsg, SimResetDoneMsg, SimDisplayTextMsg, SimGetInputMsg, SimGetInkeyMsg, SimSelectItemMsg, SimSetupMenuMsg, SimMenuItemSelectionFailedMsg, SimPlayToneMsg, SimSetupIdleModeTextMsg, SimEndTransactionMsg, SimCallSetupRejectedMsg, CallOnHoldMsg, CallHoldRejectedMsg, MptyOnHoldMsg, MptyHoldRejectedMsg, SimTkLanguageNotificationMsg, SimTkSetupEventMsg, TermRspCnfMsg, SimTkRefreshStartMsg, SimTkProfileGetCnfMsg, SimTkProfileSetCnfMsg, SimTkProfileSetRejMsg, SimLaunchBrowserReqMsg, SimLaunchBrowserPromptReqMsg, SimBrowserTermResMsg, OmMultiSlotIndMsg, DhChannelOpenReqMsg, DhChannelCloseReqMsg, DhChannelSendReqMsg, DhChannelDataAvailableResMsg, DhChannelReceiveReqMsg, DhChannelChangeStatusResMsg, SimTkRunAtCmdInfoIndMsg, SimTkSendDtmfIndMsg, SimTkSendDtmfEndIndMsg, PowerModeIndMsg, MocSetupAcceptMsg, CalledPartyAlertingMsg, MtcArrivedMsg, MtcReadyMsg, CallSetupProgressMsg, CallDisconnectingMsg, CallDisconnectedMsg, CallInfoMsg, DtmfStartCnfMsg, DtmfStopCnfMsg, DtmfRejectMsg, DtmfBufferCleanedMsg, RemotePartyActionMsg, ConnectionStatusMsg, CallNotifyMsg, RedialStartedMsg, RedialStoppedMsg, RedialSetupMsg, RedialSuccessMsg, AocChargingStatusMsg, CurrentCallMeterMsg, CurrentChargeDataMsg, DiagnosticIndMsg, RedialStatusMsg, CallControlInfoMsg, MocSetupRejectIndMsg, ForwardingInfoReceivedMsg, BarringInfoReceivedMsg, SsDataReceivedMsg, SsNotificationMsg, InterrogationResultMsg, PasswordReceivedMsg, UssDataReceivedMsg, HlrSsDataCorruptMsg, SsSuccessMsg, SsEndMsg, SsRejectedMsg, SsErrIndicationMsg, PasswordInquiryMsg, PasswordRejectedMsg, UssdIndicationMsg, UssdResentMsg, SsFacilityRejectedMsg, SsInfoMsg, CcbsRecallMsg, CcbsStatusMsg, CcbsResultMsg, UssdAnswerMsg, EngineeringReportMsg, BandSelectionMsg, HomezoneMsg, NwDiscStartIndMsg, RatStateMsg, GsmBandStateMsg, BandStatusMsg, EngineeringModeControlResponseMsg, RatChangeModeChangedMsg, CellInfoMsg, SmsNewMessageMsg, SmsNewStatusReportMsg, SmsNewSocketDataMsg, SmsPortDataRecvMsg, SmsSendConfirmMsg, SmsSendRejectMsg, SmsSpaceExceededMsg, SmsSpaceAvailableMsg, CbsNewDataMsg, SmsPrefStorageMediaChangedMsg, SmsMessageWaitingChangedMsg, CbsLimitMsg, PbSizeRequestMsg, PbEntryRequestMsg, PbAlphaTagRequestMsg, CallDeflectionIndMsg, CallDeflectionErrIndicationMsg, CallDeflectionRejectedMsg, CtmInfoIndMsg, SsRequestSentMsg, SsRequestAcceptedMsg, SsRequestRejectedMsg, CallWaitingActivatedMsg, CallWaitingDeactivatedMsg, CallWaitingStatusMsg, EmlppRegisteredMsg, EmlppStatusMsg, NetworkSsErrorMsg, NetworkSsRejectedMsg, StackSsRejectedMsg, ClirNotSurpressedMsg, CallForwardingActiveMsg, CallHeldMsg, CallRetrievedMsg, CallIsWaitingMsg, CallBarredMsg, ForwardedCallIncomingMsg, HlrDataCorruptedMsg, CugCallMsg, OutgoingCallForwardedMsg, IncomingCallForwardedMsg, MultiPartyCallInvokedMsg, EctActiveMsg, EctAlertingMsg, CnapInfoReceivedMsg, CallForwardingActivatedMsg, CallForwardingDeactivatedMsg, CallForwardingStatusMsg, CallForwardingRegisteredMsg, CallForwardingErasedMsg, CallBarringActivatedMsg, CallBarringDeactivatedMsg, CallBarringStatusMsg, ClipStatusMsg, ColpStatusMsg, ColrStatusMsg, CnapStatusMsg, ClirStatusMsg, CallBarringPasswordChangedMsg, SsErrorMsg, UssdRequestMsg, UssdNotifyMsg, UssdEndMsg, UssdDataMsg, UssdRequestResentMsg, GetPasswordMsg, UusStatusMsg, UusQueryRejectedMsg, UusNotificationMsg, UusRegisteredMsg, UusErasedMsg, UssdBeginMsg, IndicatorBarUpdateMsg, CloseAllMsg, UpdateContextItemMsg, FeatureChangedMsg, PropertyTriggerMsg, FeatureTriggerMsg, ContextFeatureTriggerMsg, UpdateItemMsg, DisabledFeatureTriggeredMsg, AudioDeviceStatusMsg, AudioErrorMsg, AudioGetPlayPositionMsg, AudioUserDefinedMsg, AudioRecordingStoppedMsg, AudioAccessoryConnectedMsg, AudioFmRadioSeekMsg, AudioFmRadioRssiMsg, AudioFmRadioRdsRawDataMsg, AudioFmRadioRdsStationNameMsg, AudioFmRadioRdsRadioTextMsg, AudioFmRadioRdsInfoMsg, AudioFmRadioRdsAlternativeFrequenciesMsg, AudioFastForwardStartedMsg, AudioRewindStartedMsg, AudioMsg, AudioPlayTimeMsg, AudioRadioDeviceNotificationMsg, AudioRestartedMsg, AudioResumedMsg, AudioStartedMsg, AudioStoppedMsg, AudioStreamingSyncMsg, AudioSuspendedMsg, AudioVoiceMemoOutOfSpaceMsg, BtAvrcpNotificationMessage, BtAvrcpOperationServiceMessage, BtAvrcpRequestStateChangedMessage, BtBipProgressMsg, BtBppRequestStateChangedMessage, BtApplicationMessage, BtGapAndSdapApplicationMessage, BtGapAndSdapRemoteRequestMessage, BtPasskeyRequiredMessage, BtAuthorizationRequiredMessage, BtGapAndSdapNotificationMessage, BtRemoteDevicePairMessage, BtGapAndSdapRequestMessage, BtStateChangedMessage, BtLocalSettingsMessage, BtLocalNameMessage, BtDiscoverabilityMessage, BtPairabilityMessage, BtConnectabilityMessage, BtProfileActivationMessage, BtSendPasskeyMessage, BtRespondAuthorizationMessage, BtDeviceSearchMessage, BtRemoteDeviceMessage, BtRemoteDeviceNameMessage, BtCancelSearchMessage, BtSetRemoteDeviceNameMessage, BtDevicePairMessage, BtDeviceUnpairMessage, BtDeviceTrustMessage, BtDeviceUntrustMessage, BtQuerySupportedProfilesMessage, BtHsSupportedProfileMessage, BtHfSupportedProfileMessage, BtPaSupportedProfileMessage, BtServiceVerifyMessage, BtServiceVerifyResultMessage, BtCancelVerifyMessage, BtRequestMessage, BtOpenMessage, BtCloseMessage, BtRequestOperationMessage, BtSddbRequestStateChangedMessage, BtServiceMessage, BtRequestStateChangedMessage, BtDunApplicationMessage, BtDunConnectMessage, BtDunDisconnectMessage, BtDunRequestStateChangedMessage, BtFaxApplicationMessage, BtFaxConnectMessage, BtFaxDisconnectMessage, BtFaxRequestStateChangedMessage, BtHfNotificationMessage, BtHfRequestStateChangedMessage, BtHsNotificationMessage, BtHsRequestStateChangedMessage, BtObexServerNotificationMessage, BtObexClientNotificationMessage, BtObexServerRequestStateChangedMessage, BtObexClientRequestStateChangedMessage, ChargerInfoMsg, BatteryLoadLevelMsg, DisplayInfoMsg, LedNotificationMsg, TransportNotificationMsg, RtcInfoMsg, FocusNextControlMsg, FocusPreviousControlMsg, SelectionChangedMsg, InvalidateMsg, ImageDecodingProgressMsg, ViewfinderErrorMsg, ContextMenuClosedMsg, RefreshComponentMsg, CloseWindowMsg, AragonMsg, T9NoWordFoundMsg, T9AddWordMsg, T9EnteredUnknownWordMsg, T9SymbolEntryRequestMsg, T9MatrixModeKeypressed, Zi8NoWordFoundMsg, Zi8AddWordMsg, Zi8EnteredUnknownWordMsg, ImageDrawingInterruptedMsg, DeleteComponentMsg, ImageEncodingProgressMsg, ItemRendererPropertiesChangedMsg, RedrawDisplayMsg, ContextMsg, ControlMsg, NoMessage, PowerOnMsg, PowerOffMsg, AppOpenMsg, AppCloseMsg, AppUpdateDisplayMsg, ThemeChangedMsg, LanguageChangedMsg, PowerWakeupMsg, KeyDownMsg, KeyUpMsg, LongKeyPressMsg, VeryLongKeyPressMsg, KeyAutoRepeatMsg, FlipMsg, LockedKeyDownMsg, LockedKeyMsg, InputCharMsg, PenDownMsg, PenUpMsg, ExternalTimeoutMsg, ItemPropertiesChangedMsg, ActionExecutedMsg, RtcTimeChangedMsg, RtcDateChangedMsg, RtcAlarmReachedMsg, ServiceThreadTerminateMsg, AppGetFocusMsg, AppLoseFocusMsg, SharedTimerMsg, ThreadletNotificationMsg, ContextWakeupMsg, ShutdownRequestMsg, AlarmNotificationMsg, TimerTimeoutMsg, ContextExecuteMsg, GetFocusMsg, LoseFocusMsg, ObexAppMsg, ObexMsg, ObexTriggerMsg, ObexAddrMsg, ObexTransportMsg, ObexVCardMsg, SocketControlMsg, DataConnInfoMsg, DataConnProfileInfoMsg, AsyncUnitTestMsg, UtcStatusMessage, JumpToRowMsg, OpenPbWinMsg, SaveEntryInPhonebookMsg, SyncProgressMsg, ProviderUpdateMsg, PhonebookRenumberedMsg, BtIndicatorMsg, CameraMsgStartViewfinding, CameraMsgStopViewfinding, SmsServiceMsg, SmsServiceDocumentMsg, SendSmsMsg, ImageBrowserDeleteImageMsg, ImageBrowserRenameImageMsg, ImageBrowserServiceMsg, LcsAppTransferLocMsg, LcsAppRegisterForMtlrMsg, LcsAppResWinMsg, OnDataRcvdMsg, StartSocketTestMsg, NextSocketTestMsg, ContinueSocketTestMsg, StopSocketTestMsg, SkipSocketTestMsg, SoundBrowserServiceMsg, UibRegisterMsg, UibNotifyMsg, and UibUpdateMsg.

MsgId Message::Id ( ) const [inline]

MsgOrigin Message::Origin ( ) const [inline]

void Message::Post ( ) const [inline]

Friends And Related Function Documentation

friend class AppContainer [friend]

friend class MessageReferrer [friend]

friend class MessageRouter [friend]

The documentation for this class was generated from the following files:
  • Kernel/Message.hpp
  • Kernel/Message.cpp
Generated on Wed Jan 25 01:28:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageBox Class Reference
[Components]

#include <Apoxi/Gui/MessageBox.hpp>

Inheritance diagram for MessageBox:

[legend]
Collaboration diagram for MessageBox:

[legend]

Public Types

enum | { ID = 16 }
enum | ReturnId { OkId, CancelId, YesId, NoId }
Specifies the selection of the user. More...
enum | Type { Ok, OkCancel, YesNo }
Specifies the type of the message box. More...

Public Member Functions

void | Init (Type type, const WCHAR *title=0, const WCHAR *message=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
MessageBox (Type type, const WCHAR *title=0, const WCHAR *message=0)
MessageBox ()
virtual INT | Open (const WCHAR *title=0, const WCHAR *message=0)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~MessageBox ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual void | OnLayoutClient ()

Detailed Description

Represents a message box which may contain any kind of text. If the text does not fit into the available are, it is possible to scroll through text with the up- and down-keys. For closing the message box a user interaction is required.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Window.

enum MessageBox::ReturnId

Specifies the selection of the user.

Enumerator:
OkId | User selected Ok.
CancelId | User selected Cancel.
YesId | User selected Yes.
NoId | User selected No.

enum MessageBox::Type

Specifies the type of the message box.

Enumerator:
Ok | User can accept the message only by a OK. Note concerning usability: In this case it is better to use an Alert.
OkCancel | Ok and Cancel are offered.
YesNo | Yes and No are offered.

Constructor & Destructor Documentation

MessageBox::MessageBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

MessageBox::MessageBox | ( | Type | type,
 |  | const WCHAR * | title = 0,
 |  | const WCHAR * | message = 0
 | ) |

Parameters:
type | Type of the message box. See MessageBox::Type.
title | Text of the message box title.
message | Text of the message box content.

MessageBox::~MessageBox ( ) [virtual]

Member Function Documentation

void MessageBox::Init | ( | Type | type,
 |  | const WCHAR * | title = 0,
 |  | const WCHAR * | message = 0
 | ) |

Parameters:
type | Type of the message box. See MessageBox::Type.
title | Text of the message box title.
message | Text of the message box content.

BOOLEAN MessageBox::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Window.

void MessageBox::OnActionExecuted ( Action * action ) [protected, virtual]

See also:
Window::OnActionExecuted

Reimplemented from Window.

void MessageBox::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Window.

INT MessageBox::Open | ( | const WCHAR * | title = 0,
 |  | const WCHAR * | message = 0
 | ) | [virtual]

Opens the message box modal and allows to set the title and text.

Parameters:
title | Text of the message box title.
message | Text of the message box content.
Returns:
Returns the corresponding MessageBox::ReturnId of the user selection.

BOOLEAN MessageBox::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from Window.

The documentation for this class was generated from the following files:
  • Gui/MessageBox.hpp
  • Gui/MessageBox.cpp
Generated on Wed Jan 25 01:28:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageHook Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageHook Class Reference
[Kernel]

#include <Apoxi/Kernel/MessageHook.hpp>

Collaboration diagram for MessageHook:

[legend]

Public Types

enum | Mode { Asynchronous, Synchronous }
Defines in which context MessageHook::OnMessage is called. More...

Public Member Functions

virtual BOOLEAN | Attach (MsgId message_id, Mode mode=Asynchronous)
virtual void | Detach ()
Removes this instance of the MessageHook from the global message hook list.
ExecutionContext * | GetExecutionContext () const
MsgId | GetMessageId () const
BOOLEAN | IsAsynchronous () const
BOOLEAN | IsAttached () const
MessageHook ()
virtual | ~MessageHook ()

Protected Member Functions

virtual BOOLEAN | OnMessage (Message &message)=0

Friends

class | MessageHookNotificationMsg
class | MessageHookReferrer
class | MessageRouter

Data Structures

class | Protector

Detailed Description

MessageHook is the base class to implement a hook to any message in the system.

Member Enumeration Documentation

enum MessageHook::Mode

Defines in which context MessageHook::OnMessage is called.

Enumerator:
Asynchronous | OnMessage method is called in context of the MessageHook's owner.
Synchronous | OnMessage is called directly in an undefined execution context.

Constructor & Destructor Documentation

MessageHook::MessageHook ( )

MessageHook::~MessageHook ( ) [virtual]

Member Function Documentation

BOOLEAN MessageHook::Attach | ( | MsgId | message_id,
 |  | Mode | mode = Asynchronous
 | ) | [virtual]

Attaches this MessageHook instance to the global list of MessageHooks.

Parameters:
message_id | message identifier of the message to be hooked.
mode | defines, in which context the method OnMessage is called.
Returns:
false, if attach fails of any reason (like already attached, memory allocation fails).

void MessageHook::Detach ( ) [virtual]

Removes this instance of the MessageHook from the global message hook list.

ExecutionContext* MessageHook::GetExecutionContext ( ) const [inline]

Returns the execution context of an asynchronous message hook. In case of a synchronous message hook there is no need to run in a defined execution context and the return value is zero. Also the return value is zero if the message hook is not attached.

MsgId MessageHook::GetMessageId ( ) const [inline]

BOOLEAN MessageHook::IsAsynchronous ( ) const [inline]

BOOLEAN MessageHook::IsAttached ( ) const [inline]

virtual BOOLEAN MessageHook::OnMessage ( Message & message ) [protected, pure virtual]

If a message gets hooked, by a corresponding message hook OnMessage is called. The inherited class decides by the return code of it's OnMessage implementation, if the hooked message should be sent or not. It is possible to modify the original message and also to discard the message, so that no registered recipient will ever get the message delivered. ATTENTION: There are two strong restriction to the implementation of OnMessage, if the MessageHook is used in Synchronous mode. First, it is NOT ALLOWED to implement any time-consuming, blocking or conditional waiting code (like the active wait construct) within this method. Also be aware of unobvious active waits called by any other class/method. And second, be aware that the you are NOT in any defined ExecutionContext (e.g. Application). This means any call (e.g. System::GetActiveApplication(), any ASC handler access, any ADC Provider access, ...) refering to such a context is also NOT ALLOWED. Just manipulation on the inherited MessageHook itself, the message parameter or any global object are VALID! So please handle this powerful construct with extreme care, otherwise you may break the whole system stability!!!

Parameters:
message original hooked message, which can also be modified
Returns:
return TRUE, if the hooked message should be released and dispatched to the official registered recipients.

Friends And Related Function Documentation

friend class MessageHookNotificationMsg [friend]

friend class MessageHookReferrer [friend]

friend class MessageRouter [friend]

The documentation for this class was generated from the following files:
  • Kernel/MessageHook.hpp
  • Kernel/MessageHook.cpp
Generated on Wed Jan 25 01:28:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageIdentifier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageIdentifier Class Reference

Message Identifier - 3GPP TS 23.041 V4.1.0 [9.4.1.2.2]. More...

#include <Apoxi/Apc/MessageIdentifier.hpp>

Collaboration diagram for MessageIdentifier:

[legend]

Public Types

enum Range {
PlmnOperatorAssociationsMessageBegin = 0x0000, PlmnOperatorAssociationsMessageEnd = 0x03e7, LocationServicesRangeBegin = 0x03e8, LocationServicesRangeEnd = 0x03ec,
UnsecureCellBroadcastDataDownloadRangeBegin = 0x1000, UnsecureCellBroadcastDataDownloadRangeEnd = 0x107f, SecureCellBroadcastDataDownloadRangeBegin = 0x1080, SecureCellBroadcastDataDownloadRangeEnd = 0x10ff,
PlmnOperatorSpecificRangeBegin = 0xa000, PlmnOperatorSpecificRangeEnd = 0xafff, ForStandardizationInFutureVersionsRange1Begin = 0x03ec, ForStandardizationInFutureVersionsRange1End = 0x0fff,
ForStandardizationInFutureVersionsRange2Begin = 0x1100, ForStandardizationInFutureVersionsRange2End = 0x9fff, ForPlmnOperatorSpecificInFutureVersionsRangeBegin = 0xb000, ForPlmnOperatorSpecificInFutureVersionsRangeEnd = 0xfffe
}
enum Type {
InPlmnOperatorAssociationsRange = 0x0000, LcsEOtdAssistanceDataMessage = 0x03e8, LcsDGpsCorrectionDataMessage = 0x03e9, LcsGpsEphemerisAndClockCorrectionDataMessage = 0x03ea,
LcsGpsAlmanacAndOtherDataMessage = 0x03eb, InUnsecureCellBroadcastDataDownloadRange = 0x1000, InSecureCellBroadcastDataDownloadRange = 0x1080, InPlmnOperatorSpecificRange = 0xa000,
InPlmnOperatorSpecificForFutureVersionsRange = 0x03ec, InReservedForFutureVersionsRange = 0xfffe, InvalidType = 0xffff
}

Public Member Functions

void | Clear ()
UINT16 | Get () const
Type | GetType () const
MessageIdentifier (const MessageIdentifier &mid)
MessageIdentifier (UINT16 incoming_word)
MessageIdentifier ()
BOOLEAN | operator== (const MessageIdentifier &mid) const
void | SetType (Type type)

Detailed Description

Message Identifier - 3GPP TS 23.041 V4.1.0 [9.4.1.2.2].

Member Enumeration Documentation

enum MessageIdentifier::Range

Enumerator:
PlmnOperatorAssociationsMessageBegin
PlmnOperatorAssociationsMessageEnd
LocationServicesRangeBegin
LocationServicesRangeEnd
UnsecureCellBroadcastDataDownloadRangeBegin
UnsecureCellBroadcastDataDownloadRangeEnd
SecureCellBroadcastDataDownloadRangeBegin
SecureCellBroadcastDataDownloadRangeEnd
PlmnOperatorSpecificRangeBegin
PlmnOperatorSpecificRangeEnd
ForStandardizationInFutureVersionsRange1Begin | reserved range for future use.
ForStandardizationInFutureVersionsRange1End
ForStandardizationInFutureVersionsRange2Begin | reserved range for future use.
ForStandardizationInFutureVersionsRange2End
ForPlmnOperatorSpecificInFutureVersionsRangeBegin | reserved range for future use.
ForPlmnOperatorSpecificInFutureVersionsRangeEnd

enum MessageIdentifier::Type

Enumerator:
InPlmnOperatorAssociationsRange | To be allocated by PLMN operator associations. If a Message Identifier from this range is in the "search list", the ME shall attempt to receive such CBS message. This version of GSM 03.41 does not prohibit networks from using Message Identifiers in the range 0000 - 03E7 (hex) for Cell Broadcast Data Download to the SIM.
LcsEOtdAssistanceDataMessage | LCS CBS Message Identifier for E-OTD Assistance Data message.
LcsDGpsCorrectionDataMessage | LCS CBS Message Identifier for DGPS Correction Data message.
LcsGpsEphemerisAndClockCorrectionDataMessage | LCS CBS Message Identifier for GPS Ephemeris and Clock Correction Data message.
LcsGpsAlmanacAndOtherDataMessage | LCS CBS Message Identifier for GPS Almanac and Other Data message.
InUnsecureCellBroadcastDataDownloadRange | Networks shall only use Message Identifiers from this range for Cell Broadcast Data Download in "clear" (i.e. unsecured) to the SIM (see GSM 11.14). If a message Identifier from this range is in the "search list", the ME shall attempt to receive this CBS message.
InSecureCellBroadcastDataDownloadRange | Networks shall only use Message Identifiers from this range for Cell Broadcast Data Download secured according to GSM 03.48 [15] to the SIM (see GSM 11.14). If a message Identifier from this range is in the "search list", the ME shall attempt to receive this CBS message.
InPlmnOperatorSpecificRange | PLMN operator specific range. The type of information provided by PLMN operators using these Message Identifiers is not guaranteed to be the same across different PLMNs. If a Message Identifier from this range is in the "search list", the ME shall attempt to receive this CBS message.
InPlmnOperatorSpecificForFutureVersionsRange | Intended for standardization in future versions of GSM 03.41. These values shall not be transmitted by networks that are compliant to this version of GSM 03.41. If a Message Identifier from this range is in the "search list", the ME shall attempt to receive this CBS message.
InReservedForFutureVersionsRange | Intended for standardization or PLMN operator specific range in future versions of GSM 03.41. These values shall not be transmitted by networks that are compliant to this version of GSM 03.41. If a Message Identifier from this range is in the "search list", the ME shall attempt to receive this CBS message.
InvalidType | Reserved, and should not be used for new services, as this value is used on the SIM to indicate that no Message Identifier is stored in those two octets of the SIM. If this Message Identifier is in the "search list", the ME shall attempt to receive this CBS message.

Constructor & Destructor Documentation

MessageIdentifier::MessageIdentifier ( ) [inline]

MessageIdentifier::MessageIdentifier ( UINT16 incoming_word ) [inline]

MessageIdentifier::MessageIdentifier ( const MessageIdentifier & mid ) [inline]

Member Function Documentation

void MessageIdentifier::Clear ( ) [inline]

UINT16 MessageIdentifier::Get ( ) const [inline]

MessageIdentifier::Type MessageIdentifier::GetType ( ) const

BOOLEAN MessageIdentifier::operator== ( const MessageIdentifier & mid ) const [inline]

void MessageIdentifier::SetType ( Type type )

The documentation for this class was generated from the following files:
  • Apc/MessageIdentifier.hpp
  • Apc/MessageIdentifier.cpp
Generated on Wed Jan 25 01:28:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageIdentifierContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageIdentifierContainer Class Reference

used for cell broadcast filter, this class is only used internally. More...

#include <Apoxi/Apc/MessageIdentifier.hpp>

Collaboration diagram for MessageIdentifierContainer:

[legend]

Public Types

enum | { c_inrease_step = 32, c_max_apoxi_no_of_message_identifiers = 128 }

Public Member Functions

BOOLEAN | AppendDistinct (const MessageIdentifierRange &range)
BOOLEAN | AppendSorted (const MessageIdentifierPair &pair)
BOOLEAN | Clear ()
BOOLEAN | Exists (const MessageIdentifierRange &range) const
INT | GetSize () const
BOOLEAN | Limit (INT limit)
BOOLEAN | Merge (const MessageIdentifierContainer &midcont)
MessageIdentifierContainer (const MessageIdentifierContainer &midcont)
MessageIdentifierContainer (INT preallocsize)
MessageIdentifierContainer ()
MessageIdentifierContainer & | operator= (const MessageIdentifierContainer &midcont)
const MessageIdentifierRange | operator[] (INT idx) const
BOOLEAN | Optimize ()
BOOLEAN | Remove (const MessageIdentifierRange &range)
~MessageIdentifierContainer ()

Data Structures

class | MessageIdentifierPair

Detailed Description

used for cell broadcast filter, this class is only used internally.

Member Enumeration Documentation

anonymous enum

Enumerator:
c_inrease_step
c_max_apoxi_no_of_message_identifiers

Constructor & Destructor Documentation

MessageIdentifierContainer::MessageIdentifierContainer ( )

MessageIdentifierContainer::MessageIdentifierContainer ( INT preallocsize )

MessageIdentifierContainer::MessageIdentifierContainer ( const MessageIdentifierContainer & midcont )

MessageIdentifierContainer::~MessageIdentifierContainer ( )

Member Function Documentation

BOOLEAN MessageIdentifierContainer::AppendDistinct ( const MessageIdentifierRange & range )

BOOLEAN MessageIdentifierContainer::AppendSorted ( const MessageIdentifierPair & pair )

BOOLEAN MessageIdentifierContainer::Clear ( ) [inline]

BOOLEAN MessageIdentifierContainer::Exists ( const MessageIdentifierRange & range ) const

INT MessageIdentifierContainer::GetSize ( ) const [inline]

BOOLEAN MessageIdentifierContainer::Limit ( INT limit )

BOOLEAN MessageIdentifierContainer::Merge ( const MessageIdentifierContainer & midcont )

MessageIdentifierContainer & MessageIdentifierContainer::operator= ( const MessageIdentifierContainer & midcont )

const MessageIdentifierRange MessageIdentifierContainer::operator[] ( INT idx ) const [inline]

BOOLEAN MessageIdentifierContainer::Optimize ( )

BOOLEAN MessageIdentifierContainer::Remove ( const MessageIdentifierRange & range )

The documentation for this class was generated from the following files:
  • Apc/MessageIdentifier.hpp
  • Apc/MessageIdentifier.cpp
Generated on Wed Jan 25 01:28:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageIdentifierContainer::MessageIdentifierPair Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MessageIdentifierContainer::MessageIdentifierPair

MessageIdentifierContainer::MessageIdentifierPair Class Reference

#include <Apoxi/Apc/MessageIdentifier.hpp>

Public Member Functions

MessageIdentifierPair (const MessageIdentifierRange &range)
MessageIdentifierPair (const MessageIdentifierPair &midpair)
MessageIdentifierPair (UINT16 begin, UINT16 end)
MessageIdentifierPair (MessageIdentifier begin, MessageIdentifier end)
MessageIdentifierPair ()
BOOLEAN | operator== (const MessageIdentifierRange &midrange) const
BOOLEAN | operator== (const MessageIdentifierPair &midpair) const

Data Fields

UINT16 | m_begin
UINT16 | m_end

Constructor & Destructor Documentation

MessageIdentifierContainer::MessageIdentifierPair::MessageIdentifierPair ( ) [inline]

MessageIdentifierContainer::MessageIdentifierPair::MessageIdentifierPair | ( | MessageIdentifier | begin,
 |  | MessageIdentifier | end
 | ) | [inline]

MessageIdentifierContainer::MessageIdentifierPair::MessageIdentifierPair | ( | UINT16 | begin,
 |  | UINT16 | end
 | ) | [inline]

MessageIdentifierContainer::MessageIdentifierPair::MessageIdentifierPair ( const MessageIdentifierPair & midpair ) [inline]

MessageIdentifierContainer::MessageIdentifierPair::MessageIdentifierPair ( const MessageIdentifierRange & range ) [inline]

Member Function Documentation

BOOLEAN MessageIdentifierContainer::MessageIdentifierPair::operator== ( const MessageIdentifierRange & midrange ) const [inline]

BOOLEAN MessageIdentifierContainer::MessageIdentifierPair::operator== ( const MessageIdentifierPair & midpair ) const [inline]

Field Documentation

UINT16 MessageIdentifierContainer::MessageIdentifierPair::m_begin

UINT16 MessageIdentifierContainer::MessageIdentifierPair::m_end

The documentation for this class was generated from the following file:
  • Apc/MessageIdentifier.hpp
Generated on Wed Jan 25 01:28:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageIdentifierRange Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageIdentifierRange Class Reference

used for cell broadcast filter. More...

#include <Apoxi/Apc/MessageIdentifier.hpp>

Inheritance diagram for MessageIdentifierRange:

[legend]
Collaboration diagram for MessageIdentifierRange:

[legend]

Public Member Functions

void | Begin (const MessageIdentifier &begin)
const MessageIdentifier & | Begin () const
void | End (const MessageIdentifier &end)
const MessageIdentifier & | End () const
BOOLEAN | IsValid ()
MessageIdentifierRange (const MessageIdentifierRange &midrange)
MessageIdentifierRange (const MessageIdentifier &begin, const MessageIdentifier &end=MessageIdentifier())
MessageIdentifierRange ()
BOOLEAN | operator== (const MessageIdentifierRange &mid_range) const

Detailed Description

used for cell broadcast filter.

Constructor & Destructor Documentation

MessageIdentifierRange::MessageIdentifierRange ( )

MessageIdentifierRange::MessageIdentifierRange | ( | const MessageIdentifier & | begin,
 |  | const MessageIdentifier & | end = MessageIdentifier()
 | ) |

MessageIdentifierRange::MessageIdentifierRange ( const MessageIdentifierRange & midrange ) [inline]

Member Function Documentation

void MessageIdentifierRange::Begin ( const MessageIdentifier & begin ) [inline]

const MessageIdentifier& MessageIdentifierRange::Begin ( ) const [inline]

void MessageIdentifierRange::End ( const MessageIdentifier & end ) [inline]

const MessageIdentifier& MessageIdentifierRange::End ( ) const [inline]

BOOLEAN MessageIdentifierRange::IsValid ( ) [inline]

BOOLEAN MessageIdentifierRange::operator== ( const MessageIdentifierRange & mid_range ) const

The documentation for this class was generated from the following files:
  • Apc/MessageIdentifier.hpp
  • Apc/MessageIdentifier.cpp
Generated on Wed Jan 25 01:28:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageMap< T > Struct Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageMap< T > Struct Template Reference
[Kernel]

#include <Apoxi/Kernel/MessageMap.hpp>

Inheritance diagram for MessageMap< T >:

[legend]

Data Fields

BOOLEAN(T::* func )(const Message &msg)
MsgId msg_id

template<class T>
struct MessageMap< T >

Field Documentation

template<class T>
BOOLEAN(T::* MessageMap< T >::func)(const Message &msg)

template<class T>
MsgId MessageMap< T >::msg_id

The documentation for this struct was generated from the following file:
  • Kernel/MessageMap.hpp
Generated on Wed Jan 25 01:28:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageMapContainer< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageMapContainer< T > Class Template Reference
[Kernel]

#include <Apoxi/Kernel/MessageMap.hpp>

Inheritance diagram for MessageMapContainer< T >:

[legend]
Collaboration diagram for MessageMapContainer< T >:

[legend]

Public Member Functions

virtual BOOLEAN | Execute (const Message &msg) const
virtual void | Init (T *dispatcher, const MessageMap< T > *msg_map)
MessageMapContainer (T *dispatcher=0, const MessageMap< T > *msg_map=0)
virtual void | Register () const
virtual void | Unregister () const

template<class T>
class MessageMapContainer< T >

Constructor & Destructor Documentation

template<class T>
MessageMapContainer< T >::MessageMapContainer | ( | T * | dispatcher = 0,
 |  | const MessageMap< T > * | msg_map = 0
 | ) | [inline]

Member Function Documentation

template<class T>
virtual BOOLEAN MessageMapContainer< T >::Execute ( const Message & msg ) const [inline, virtual]

Implements AbstractMessageMapContainer.

template<class T>
virtual void MessageMapContainer< T >::Init | ( | T * | dispatcher,
 |  | const MessageMap< T > * | msg_map
 | ) | [inline, virtual]

template<class T>
virtual void MessageMapContainer< T >::Register ( ) const [inline, virtual]

Implements AbstractMessageMapContainer.

template<class T>
virtual void MessageMapContainer< T >::Unregister ( ) const [inline, virtual]

Implements AbstractMessageMapContainer.

The documentation for this class was generated from the following file:
  • Kernel/MessageMap.hpp
Generated on Wed Jan 25 01:28:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageMapDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageMapDispatcher Class Reference
[Kernel]

#include <Apoxi/Kernel/MessageMapDispatcher.hpp>

Inheritance diagram for MessageMapDispatcher:

[legend]
Collaboration diagram for MessageMapDispatcher:

[legend]

Public Member Functions

void | Init (const AbstractMessageMapContainer *msg_map_container)
MessageMapDispatcher (const AbstractMessageMapContainer *msg_map_container=0)
virtual | ~MessageMapDispatcher ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | RegisterMessages () const
virtual void | UnregisterMessages () const

Detailed Description

Holds a MessageMapContainer which is more or less a table of message ID's and method pointers. When receiving a message with a listed ID the OnMessage method calls automatically the corresponding method in the list. So mapping between message IDs and the corresponding functionality is much easier to handle then a not reviewable switch statement in the OnMessage method.

Constructor & Destructor Documentation

MessageMapDispatcher::MessageMapDispatcher ( const AbstractMessageMapContainer * msg_map_container = 0 )

MessageMapDispatcher::~MessageMapDispatcher ( ) [virtual]

Member Function Documentation

void MessageMapDispatcher::Init ( const AbstractMessageMapContainer * msg_map_container ) [inline]

Reimplemented in ActiveWaitDispatcher.

BOOLEAN MessageMapDispatcher::OnMessage ( const Message & msg ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void MessageMapDispatcher::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented from UserDispatcher.

void MessageMapDispatcher::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented from UserDispatcher.

The documentation for this class was generated from the following files:
  • Kernel/MessageMapDispatcher.hpp
  • Kernel/MessageMapDispatcher.cpp
Generated on Wed Jan 25 01:28:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageReferrer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageReferrer Class Reference
[Kernel]

#include <Apoxi/Kernel/MessageReferrer.hpp>

Collaboration diagram for MessageReferrer:

[legend]

Public Member Functions

Message * | GetMessage () const
MessageReferrer (const MessageReferrer &mr)
MessageReferrer (Message *msg=0)
virtual MessageReferrer & | operator= (const MessageReferrer &mr)
virtual | ~MessageReferrer ()

Constructor & Destructor Documentation

MessageReferrer::MessageReferrer ( Message * msg = 0 )

MessageReferrer::MessageReferrer ( const MessageReferrer & mr )

MessageReferrer::~MessageReferrer ( ) [virtual]

Member Function Documentation

Message* MessageReferrer::GetMessage ( ) const [inline]

MessageReferrer & MessageReferrer::operator= ( const MessageReferrer & mr ) [virtual]

The documentation for this class was generated from the following files:
  • Kernel/MessageReferrer.hpp
  • Kernel/MessageReferrer.cpp
Generated on Wed Jan 25 01:28:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageRouter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageRouter Class Reference
[Kernel]

#include <Apoxi/Kernel/MessageRouter.hpp>

Collaboration diagram for MessageRouter:

[legend]

Public Types

typedef SingleArgHook< const
Message & > 		PostMsgHook
typedef PostMsgHook::HookFn | PostMsgHookFn

Static Public Member Functions

static BOOLEAN | AddPostMsgHook (PostMsgHookFn fn)
static ExternalCommunicationHandler * | GetExternalCommunicator ()
static void | Init (ExternalCommunicationHandler *external_communicator=0)
static void | Post (const AbstractExternalData &external_data)
static void | Post (const Message &msg)
static void | PostFocusTransferMsg (const Message &msg)
static BOOLEAN | RemovePostMsgHook (PostMsgHookFn fn)

Friends

class | MessageHook
class | StartUp

Detailed Description

MessageRouter is a static class to collect the base functionality of APOXI message routing. Posting a message in general means to enqueue the message to those message queues of application containers or service threads which are ready to receive this message.

Member Typedef Documentation

typedef SingleArgHook<const Message&> MessageRouter::PostMsgHook

typedef PostMsgHook::HookFn MessageRouter::PostMsgHookFn

Member Function Documentation

BOOLEAN MessageRouter::AddPostMsgHook ( PostMsgHookFn fn ) [static]

Adds a PostMsgHookFn function pointer to the MessageRouter. Every time MessageRouter::Post is invoked, the callback function is called.

Parameters:
fn Function pointer to be added to the hook.
Returns:
Status if the hook was successfully added.

static ExternalCommunicationHandler* MessageRouter::GetExternalCommunicator ( ) [inline, static]

static void MessageRouter::Init ( ExternalCommunicationHandler * external_communicator = 0 ) [inline, static]

void MessageRouter::Post ( const AbstractExternalData & external_data ) [static]

Processes any SDL signal coming (part of the sdl process node) in from the environment.

void MessageRouter::Post ( const Message & msg ) [static]

Posts an asynchronous message to the system.

void MessageRouter::PostFocusTransferMsg ( const Message & msg ) [static]

BOOLEAN MessageRouter::RemovePostMsgHook ( PostMsgHookFn fn ) [static]

Removes a PostMsgHookFn function pointer from the MessageRouter.

Parameters:
fn Function pointer to be removed from the hook.
Returns:
Status if the hook was successfully removed.

Friends And Related Function Documentation

friend class MessageHook [friend]

friend class StartUp [friend]

The documentation for this class was generated from the following files:
  • Kernel/MessageRouter.hpp
  • Kernel/MessageRouter.cpp
Generated on Wed Jan 25 01:28:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MessageTypeIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MessageTypeIndicator Class Reference

#include <Apoxi/Apc/MessageTypeIndicator.hpp>

Public Types

enum Type {
DeliverReport = 0, Submit, Command, Deliver,
SubmitReport, StatusReport, ReservedType, InvalidType
}
enum | Usage { MobileOriginated, MobileTerminated, InvalidUsage }

Public Member Functions

void | Clear ()
Type | GetOriginType () const
Type | GetType () const
Usage | GetUsage () const
BOOLEAN | IsInvalid () const
MessageTypeIndicator (Usage usage, UINT8 *data=0)
MessageTypeIndicator ()
void | SetType (Type format)
void | SetUsage (Usage usage)

Detailed Description

3GPP 23.040 V5.1.0 [9.2.3.1] - Attention: This class is a wrapper over a data-stream (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Member Enumeration Documentation

enum MessageTypeIndicator::Type

Enumerator:
DeliverReport | mobile originated
Submit | mobile originated
Command | mobile originated
Deliver | mobile terminated
SubmitReport | mobile terminated
StatusReport | mobile terminated
ReservedType
InvalidType

enum MessageTypeIndicator::Usage

Enumerator:
MobileOriginated
MobileTerminated
InvalidUsage

Constructor & Destructor Documentation

MessageTypeIndicator::MessageTypeIndicator ( )

MessageTypeIndicator::MessageTypeIndicator | ( | Usage | usage,
 |  | UINT8 * | data = 0
 | ) |

Member Function Documentation

void MessageTypeIndicator::Clear ( )

MessageTypeIndicator::Type MessageTypeIndicator::GetOriginType ( ) const

MessageTypeIndicator::Type MessageTypeIndicator::GetType ( ) const

Usage MessageTypeIndicator::GetUsage ( ) const [inline]

BOOLEAN MessageTypeIndicator::IsInvalid ( ) const

void MessageTypeIndicator::SetType ( Type format )

void MessageTypeIndicator::SetUsage ( Usage usage ) [inline]

The documentation for this class was generated from the following files:
  • Apc/MessageTypeIndicator.hpp
  • Apc/MessageTypeIndicator.cpp
Generated on Wed Jan 25 01:28:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MetaData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MetaData Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/MetaData.hpp>

Inheritance diagram for MetaData:

[legend]
Collaboration diagram for MetaData:

[legend]

Public Member Functions

const WString & | GetDisplayedName () const
Gets the name which is displayed.
const WString & | GetDisplayedName () const
Gets the name which is displayed.
INT32 | GetIndex () const
INT32 | GetIndex () const
virtual WString | GetInfoText () const
Returns metadata information in form of a pretty formatted string.
virtual WString | GetInfoText () const
Returns metadata information in form of a pretty formatted string.
BOOLEAN | GetMarkDelete () const
BOOLEAN | GetMarkDelete () const
virtual const MetaDataRecord & | GetMetaDataRecord () const =0
Returns the constant metadata record.
virtual MetaDataRecord & | GetMetaDataRecord ()=0
Returns the metadata record.
virtual const MetaDataRecord & | GetMetaDataRecord () const =0
Returns the constant metadata record.
virtual MetaDataRecord & | GetMetaDataRecord ()=0
Returns the metadata record.
MimeType | GetMimeType () const
Returns the Mime type extracted from the path profile.
MimeType | GetMimeType () const
Returns the Mime type extracted from the path profile.
Path | GetPath () const
Returns the path of the media resource.
Path | GetPath () const
Returns the path of the media resource.
UINT32 | GetSize () const
Returns the size of the media resource in bytes.
UINT32 | GetSize () const
Returns the size of the media resource in bytes.
void | Init (const Path &path, UINT32 size=0)
void | Init (const Path &path, UINT32 size=0)
MetaData ()
MetaData ()
void | SetDisplayedName (const WString &displayed_name)
Set the name which is displayed.
void | SetDisplayedName (const WString &displayed_name)
Set the name which is displayed.
void | SetIndex (INT32 index)
void | SetIndex (INT32 index)
void | SetMarkDelete (BOOLEAN mark_delete)
void | SetMarkDelete (BOOLEAN mark_delete)
void | SetPath (const Path &path)
Sets the path of the media resource.
void | SetPath (const Path &path)
Sets the path of the media resource.
void | SetSize (UINT32 size)
Sets the size of the media resource in bytes.
void | SetSize (UINT32 size)
Sets the size of the media resource in bytes.
virtual | ~MetaData ()
virtual | ~MetaData ()

Detailed Description

Abstract base class for handling metadata of media references. Derived classes embed a concrete metadata record derived from structure MetaDataRecord which can be accessed using method GetMetaDataRecord().

Constructor & Destructor Documentation

MetaData::MetaData ( )

MetaData::~MetaData ( ) [virtual]

MetaData::MetaData ( )

virtual MetaData::~MetaData ( ) [virtual]

Member Function Documentation

const WString& MetaData::GetDisplayedName ( ) const [inline]

Gets the name which is displayed.

const WString& MetaData::GetDisplayedName ( ) const [inline]

Gets the name which is displayed.

INT32 MetaData::GetIndex ( ) const [inline]

INT32 MetaData::GetIndex ( ) const [inline]

virtual WString MetaData::GetInfoText ( ) const [virtual]

Returns metadata information in form of a pretty formatted string.

Reimplemented in ImageMetaData.

WString MetaData::GetInfoText ( ) const [virtual]

Returns metadata information in form of a pretty formatted string.

Reimplemented in ImageMetaData.

BOOLEAN MetaData::GetMarkDelete ( ) const [inline]

BOOLEAN MetaData::GetMarkDelete ( ) const [inline]

virtual const MetaDataRecord& MetaData::GetMetaDataRecord ( ) const [pure virtual]

Returns the constant metadata record.

Implemented in ImageMetaData, and SoundMetaData.

virtual MetaDataRecord& MetaData::GetMetaDataRecord ( ) [pure virtual]

Returns the metadata record.

Implemented in ImageMetaData, and SoundMetaData.

virtual const MetaDataRecord& MetaData::GetMetaDataRecord ( ) const [pure virtual]

Returns the constant metadata record.

Implemented in ImageMetaData, and SoundMetaData.

virtual MetaDataRecord& MetaData::GetMetaDataRecord ( ) [pure virtual]

Returns the metadata record.

Implemented in ImageMetaData, and SoundMetaData.

MimeType MetaData::GetMimeType ( ) const [inline]

Returns the Mime type extracted from the path profile.

MimeType MetaData::GetMimeType ( ) const [inline]

Returns the Mime type extracted from the path profile.

Path MetaData::GetPath ( ) const [inline]

Returns the path of the media resource.

Path MetaData::GetPath ( ) const [inline]

Returns the path of the media resource.

UINT32 MetaData::GetSize ( ) const [inline]

Returns the size of the media resource in bytes.

UINT32 MetaData::GetSize ( ) const [inline]

Returns the size of the media resource in bytes.

void MetaData::Init | ( | const Path & | path,
 |  | UINT32 | size = 0
 | ) |

void MetaData::Init | ( | const Path & | path,
 |  | UINT32 | size = 0
 | ) |

void MetaData::SetDisplayedName ( const WString & displayed_name ) [inline]

Set the name which is displayed.

void MetaData::SetDisplayedName ( const WString & displayed_name ) [inline]

Set the name which is displayed.

void MetaData::SetIndex ( INT32 index ) [inline]

void MetaData::SetIndex ( INT32 index ) [inline]

void MetaData::SetMarkDelete ( BOOLEAN mark_delete )

void MetaData::SetMarkDelete ( BOOLEAN mark_delete )

void MetaData::SetPath ( const Path & path ) [inline]

Sets the path of the media resource.

void MetaData::SetPath ( const Path & path ) [inline]

Sets the path of the media resource.

void MetaData::SetSize ( UINT32 size ) [inline]

Sets the size of the media resource in bytes.

void MetaData::SetSize ( UINT32 size ) [inline]

Sets the size of the media resource in bytes.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MetaData.hpp
  • Applications/SoundBrowser/Common/MetaData.hpp
  • Applications/ImageBrowser/Common/MetaData.cpp
  • Applications/SoundBrowser/Common/MetaData.cpp
Generated on Wed Jan 25 01:28:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MetaDataRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MetaDataRecord Struct Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/MetaData.hpp>

Inheritance diagram for MetaDataRecord:

[legend]
Collaboration diagram for MetaDataRecord:

[legend]

Public Member Functions

MetaDataRecord ()
MetaDataRecord ()
virtual | ~MetaDataRecord ()
virtual | ~MetaDataRecord ()

Data Fields

INT32 | m_index
UINT8 | m_mark_delete
PathProfile m_resource_path_profile
UINT32 | m_size

Detailed Description

Structure designed for storing metadata of media references in a file. A metadata record stores at least a path profile for storing the path of the media resource, Drm information, and the size of the media resource in bytes.

Constructor & Destructor Documentation

MetaDataRecord::MetaDataRecord ( )

MetaDataRecord::~MetaDataRecord ( ) [virtual]

MetaDataRecord::MetaDataRecord ( )

virtual MetaDataRecord::~MetaDataRecord ( ) [virtual]

Field Documentation

INT32 MetaDataRecord::m_index

UINT8 MetaDataRecord::m_mark_delete

PathProfile MetaDataRecord::m_resource_path_profile

UINT32 MetaDataRecord::m_size

The documentation for this struct was generated from the following files:
  • Applications/ImageBrowser/Common/MetaData.hpp
  • Applications/SoundBrowser/Common/MetaData.hpp
  • Applications/ImageBrowser/Common/MetaData.cpp
  • Applications/SoundBrowser/Common/MetaData.cpp
Generated on Wed Jan 25 01:28:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MexeDescriptor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MexeDescriptor Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimAuxHandler.hpp>

Public Member Functions

UINT16 | GetCertLength () const
UINT16 | GetCertOffset () const
UINT | GetCertType () const
UINT8 * | GetKeyIdBuffer () const
UINT8 | GetKeyIdLength () const
MexeCertType | GetMexeCertType () const
SimFileId | GetSimFileId () const
BOOLEAN | IsAuthorityCert () const
BOOLEAN | IsValid () const
MexeDescriptor (MexeCertType type, const UINT8 *buffer, UINT16 len)
~MexeDescriptor ()

Constructor & Destructor Documentation

MexeDescriptor::MexeDescriptor | ( | MexeCertType | type,
 |  | const UINT8 * | buffer,
 |  | UINT16 | len
 | ) | [inline]

The documentation for this class was generated from the following file:
  • Adc/SimAuxHandler.hpp
Generated on Wed Jan 25 01:28:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MidiSound Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MidiSound Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/MidiSound.hpp>

Inheritance diagram for MidiSound:

[legend]
Collaboration diagram for MidiSound:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

virtual const BinData * | GetBinData () const
Returns the i-melody data in the ems specific format.
virtual INT | GetId () const
void | Init (BinData *bin_data)
MidiSound (BinData *bin_data)
MidiSound ()
virtual | ~MidiSound ()

Detailed Description

Obsolete - all sound classes from AddOns/MultiMedia have been replaced by a new audio concept. Use the AudioDeviceManager instead for playing sounds.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MidiSound::MidiSound ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

MidiSound::MidiSound ( BinData * bin_data ) [explicit]

Initializes an MIDI sound with the given bin_data.

Parameters:
bin_data Pointer to a binary data stream which contains the i-melody data. After passing the binary data stream, the stream is obtained by the MIDI sound and hence automatically released in the destructor of the MIDI sound.

MidiSound::~MidiSound ( ) [virtual]

Member Function Documentation

const BinData * MidiSound::GetBinData ( ) const [virtual]

Returns the i-melody data in the ems specific format.

Reimplemented from Sound.

INT MidiSound::GetId ( ) const [virtual]

See also:
Sound::GetId

Implements Sound.

void MidiSound::Init ( BinData * bin_data )

Initializes an MIDI sound with the given bin_data.

Parameters:
bin_data Pointer to a binary data stream which contains the i-melody data. After passing the binary data stream, the stream is obtained by the MIDI sound and hence automatically released in the destructor of the MIDI sound.

The documentation for this class was generated from the following files:
  • Compat/MidiSound.hpp
  • Compat/MidiSound.cpp
Generated on Wed Jan 25 01:28:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MimeCoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MimeCoder Class Reference

#include <Apoxi/AddOns/AuxExtensions/MimeCoding.hpp>

Inheritance diagram for MimeCoder:

[legend]

Public Member Functions

void | Advance (INT amount)
BOOLEAN | Check (INT amount) const
BOOLEAN | IsText () const
MimeCoder (CHAR *buffer=0, INT buffer_length=0, BOOLEAN is_text=TRUE)

Protected Attributes

INT | m_buffer_left
INT | m_buffer_length
CHAR * | m_buffer_ptr
BOOLEAN | m_is_text
INT | m_line_length

Constructor & Destructor Documentation

MimeCoder::MimeCoder | ( | CHAR * | buffer = 0,
 |  | INT | buffer_length = 0,
 |  | BOOLEAN | is_text = TRUE
 | ) |

Member Function Documentation

void MimeCoder::Advance ( INT amount )

BOOLEAN MimeCoder::Check ( INT amount ) const

BOOLEAN MimeCoder::IsText ( ) const [inline]

Field Documentation

INT MimeCoder::m_buffer_left [protected]

INT MimeCoder::m_buffer_length [protected]

CHAR* MimeCoder::m_buffer_ptr [protected]

BOOLEAN MimeCoder::m_is_text [protected]

INT MimeCoder::m_line_length [protected]

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/MimeCoding.hpp
  • AddOns/AuxExtensions/MimeCoding.cpp
Generated on Wed Jan 25 01:28:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MimeCoding Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MimeCoding Class Reference

#include <Apoxi/AddOns/AuxExtensions/MimeCoding.hpp>

Static Public Member Functions

static INT | DecodeBase64 (CHAR *buffer, INT buffer_length, const CHAR *data, INT data_length, BOOLEAN is_text)
static INT | DecodeQuotedPrintable (CHAR *buffer, INT buffer_length, const CHAR *data, INT data_length, BOOLEAN is_text)
static INT | EncodeBase64 (CHAR *buffer, INT buffer_length, const CHAR *data, INT data_length, BOOLEAN is_text)
static INT | EncodeQuotedPrintable (CHAR *buffer, INT buffer_length, const CHAR *data, INT data_length, BOOLEAN is_text)

Detailed Description

MimeCoding

MIME Content-Transfer-Encoding as defined in RFC 1521, chapter 5

Author:
Christoph Bartelmus

Member Function Documentation

INT MimeCoding::DecodeBase64 | ( | CHAR * | buffer,
 |  | INT | buffer_length,
 |  | const CHAR * | data,
 |  | INT | data_length,
 |  | BOOLEAN | is_text
 | ) | [static]

decode given BASE64 data

Parameters:
buffer,: output buffer provided by caller
buffer_length,: size of output buffer in bytes
data,: input data buffer
data_length,: size of data buffer in bytes
is_text,: set to TRUE if the data consists of text (note that the encoding will behave differently depending on whether the data is text or binary)
Returns:
number of bytes of the output used during decoding, -1 if the output buffer was too small to hold the data or an error occured during decoding

INT MimeCoding::DecodeQuotedPrintable | ( | CHAR * | buffer,
 |  | INT | buffer_length,
 |  | const CHAR * | data,
 |  | INT | data_length,
 |  | BOOLEAN | is_text
 | ) | [static]

decode given Quoted-Printable data

Parameters:
buffer,: output buffer provided by caller
buffer_length,: size of output buffer in bytes
data,: input data buffer
data_length,: size of data buffer in bytes
is_text,: set to TRUE if the data consists of text (note that the encoding will behave differently depending on whether the data is text or binary)
Returns:
number of bytes of the output used during decoding, -1 if the output buffer was too small to hold the data or an error occured during decoding

INT MimeCoding::EncodeBase64 | ( | CHAR * | buffer,
 |  | INT | buffer_length,
 |  | const CHAR * | data,
 |  | INT | data_length,
 |  | BOOLEAN | is_text
 | ) | [static]

transform given data to BASE64 Encoding

The size of the output after encoding will be about 33 percent bigger than the size of the input buffer.

Parameters:
buffer,: output buffer provided by caller
buffer_length,: size of output buffer in bytes
data,: input data buffer
data_length,: size of data buffer in bytes
is_text,: set to TRUE if the data consists of text (note that the encoding will behave differently depending on whether the data is text or binary)
Returns:
number of bytes of the output used during encoding, -1 if the output buffer was too small to hold the data

INT MimeCoding::EncodeQuotedPrintable | ( | CHAR * | buffer,
 |  | INT | buffer_length,
 |  | const CHAR * | data,
 |  | INT | data_length,
 |  | BOOLEAN | is_text
 | ) | [static]

encode given data to Quoted-Printable Encoding

Note that if the input consists mostly of binary data, then you should consider BASE64 encoding as Quoted-Printable is only efficient for data that consists mainly of ASCII characters.

Parameters:
buffer,: output buffer provided by caller
buffer_length,: size of output buffer in bytes
data,: input data buffer
data_length,: size of data buffer in bytes
is_text,: set to TRUE if the data consists of text (note that the encoding will behave differently depending on whether the data is text or binary)
Returns:
number of bytes of the output used during encoding, -1 if the output buffer was too small to hold the data

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/MimeCoding.hpp
  • AddOns/AuxExtensions/MimeCoding.cpp
Generated on Wed Jan 25 01:28:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MimeTypeFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MimeTypeFilter Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

#include <Applications/ImageBrowser/Common/MediaFilter.hpp>

Inheritance diagram for MimeTypeFilter:

[legend]
Collaboration diagram for MimeTypeFilter:

[legend]

Public Member Functions

virtual BOOLEAN | IsAllowed (const MediaRef &media_ref) const
virtual BOOLEAN | IsAllowed (const MediaRef &media_ref) const
MimeTypeFilter (MimeType mime_type)
MimeTypeFilter (MimeType mime_type)
virtual void | SetMimeType (MimeType mime_type)
Sets the allowed Mime type.
virtual void | SetMimeType (MimeType mime_type)
Sets the allowed Mime type.
virtual | ~MimeTypeFilter ()
virtual | ~MimeTypeFilter ()

Detailed Description

Filter that allows media reference objects to be filtered according to heir Mime type.

Constructor & Destructor Documentation

MimeTypeFilter::MimeTypeFilter ( MimeType mime_type )

MimeTypeFilter::~MimeTypeFilter ( ) [virtual]

MimeTypeFilter::MimeTypeFilter ( MimeType mime_type )

virtual MimeTypeFilter::~MimeTypeFilter ( ) [virtual]

Member Function Documentation

virtual BOOLEAN MimeTypeFilter::IsAllowed ( const MediaRef & media_ref ) const [virtual]

See also:
MediaFilter::IsAllowed()

Reimplemented from MediaFilter.

BOOLEAN MimeTypeFilter::IsAllowed ( const MediaRef & media_ref ) const [virtual]

See also:
MediaFilter::IsAllowed()

Reimplemented from MediaFilter.

virtual void MimeTypeFilter::SetMimeType ( MimeType mime_type ) [virtual]

Sets the allowed Mime type.

void MimeTypeFilter::SetMimeType ( MimeType mime_type ) [virtual]

Sets the allowed Mime type.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaFilter.hpp
  • Applications/SoundBrowser/Common/MediaFilter.hpp
  • Applications/ImageBrowser/Common/MediaFilter.cpp
  • Applications/SoundBrowser/Common/MediaFilter.cpp
Generated on Wed Jan 25 01:28:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MimeTypeTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MimeTypeTable Class Reference
[Auxiliary]

User-extendable MIME type registry. More...

#include <Apoxi/Auxiliary/MimeTypeTable.hpp>

Collaboration diagram for MimeTypeTable:

[legend]

Static Public Member Functions

static const CHAR * | GetExtByMimeStr (const CHAR *mime_str)
Obtains the default file extension for a given MIME string.
static const CHAR * | GetExtByMimeType (MimeType mime_type, UINT8 offset=0)
Obtains the default file extension for a given MimeType Id.
static const CHAR * | GetFirstExtByMimeStr (const CHAR *mime_str)
Obtains the default file extension for a given MIME string.
static const CHAR * | GetFirstExtByMimeType (MimeType mime_type)
Obtains the default file extension for a given MimeType Id.
static MimeType | GetMaxMimeTypeId ()
Returns the largest MimeType registered with MimeTypeTable.
static const CHAR * | GetMimeStrByExt (const CHAR *file_ext)
Returns the MIME string associated with a file extension.
static const CHAR * | GetMimeStrByMimeType (MimeType mime_type)
Returns the MIME string associated with a MimeType Id.
static MimeType | GetMimeTypeByExt (const CHAR *file_ext)
Returns the MimeType Id associated with a file extension.
static MimeType | GetMimeTypeByExt (const CHAR *file_ext, UINT8 &idx)
Returns the MimeType Id associated with a file extension.
static MimeType | GetMimeTypeByMimeStr (const CHAR *mime_str)
Returns the MimeType Id associated with a MIME string.
static const CHAR * | GetNextExtension (const CHAR *file_ext)
Obtains the next synonym from a list of file extensions.
static INT | IsBinaryByExt (const CHAR *file_ext)
Tells whether MIME data is encoded in a binary format.
static INT | IsBinaryByMimeStr (const CHAR *mime_str)
Tells whether MIME data is encoded in a binary format.
static INT | IsTextByExt (const CHAR *file_ext)
Tells whether MIME data is encoded in a text-based format.
static INT | IsTextByMimeStr (const CHAR *mime_str)
Tells whether MIME data is encoded in a text-based format.

Friends

class | Partition

Data Structures

class | Partition
Represents a partition of the APOXI MimeTypeTable. More...

Detailed Description

User-extendable MIME type registry.

Class MimeTypeTable provides static methods for conversions between MIME type, file extension, and MIME type string. It also can tell whether MIME data is encoded in a binary or textual format.

User SW can register additional MIME types for use with MimeTypeTable. This can be accomplished using the macros from MimeTypeTableUtils.hpp to set up an extension table, which automatically registers with MimeTypeTable by means of a small 'hook' class.

Note:Currently only one instance of an extension table is supported (system-wide !). Attempting to set up a second one will result in an assertion.

Member Function Documentation

const CHAR * MimeTypeTable::GetExtByMimeStr ( const CHAR * mime_str ) [static]

Obtains the default file extension for a given MIME string.

Deprecated: Please use GetFirstExtByMimeStr().

const CHAR * MimeTypeTable::GetExtByMimeType | ( | MimeType | mime_type,
 |  | UINT8 | offset = 0
 | ) | [static]

Obtains the default file extension for a given MimeType Id.

Parameters:
offset The offset of the file extension for a particular mime type, which should be returned. This is useful if more than one file extension exists for a mime type.

const CHAR * MimeTypeTable::GetFirstExtByMimeStr ( const CHAR * mime_str ) [static]

Obtains the default file extension for a given MIME string.

The default extension is listed first, following entries are optional and can be accessed by calling GetNextExtension().

Parameters:
mime_str MIME string to look up in MimeTypeTable.
Returns:
Pointer to C-string containing the first file extension associated with 'mime_type' or pointer to an empty string when 'mime_type' when is unknown by APOXI.

const CHAR * MimeTypeTable::GetFirstExtByMimeType ( MimeType mime_type ) [static]

Obtains the default file extension for a given MimeType Id.

The default extension is listed first, following entries are optional and can be accessed by calling GetNextExtByMimeType().

Parameters:
mime_type MimeType Id to look up in MimeTypeTable.
Returns:
Pointer to C-string containing the first file extension associated with 'mime_type' or pointer to an empty string when 'mime_type' when is unknown by APOXI.

MimeType MimeTypeTable::GetMaxMimeTypeId ( ) [static]

Returns the largest MimeType registered with MimeTypeTable.

const CHAR * MimeTypeTable::GetMimeStrByExt ( const CHAR * file_ext ) [static]

Returns the MIME string associated with a file extension.

Parameters:
file_ext Pointer to a C-string containing a file extension.
Returns:
Pointer to the first associated MIME string when the file extension matches one of the file extension strings known by MimeTypeTable, pointer to an empty string otherwise.

const CHAR * MimeTypeTable::GetMimeStrByMimeType ( MimeType mime_type ) [static]

Returns the MIME string associated with a MimeType Id.

Parameters:
mime_type MimeType Id to look up in MimeTypeTable.
Returns:
Pointer to the first associated MIME string when the MimeType Id is known by MimeTypeTable, pointer to an empty string otherwise.

MimeType MimeTypeTable::GetMimeTypeByExt ( const CHAR * file_ext ) [static]

Returns the MimeType Id associated with a file extension.

Parameters:
file_ext Pointer to a C-string containing a file extension.
Returns:
Corresponding MimeType Id when the file extension matches one of the file extension strings known by MimeTypeTable, c_mime_unknown otherwise.

MimeType MimeTypeTable::GetMimeTypeByExt | ( | const CHAR * | file_ext,
 |  | UINT8 & | idx
 | ) | [static]

Returns the MimeType Id associated with a file extension.

Parameters:
file_ext | Pointer to a C-string containing a file extension.
idx | The index of the file extension in the MimeTypeTableEntry of this mime type.
Returns:
Corresponding MimeType Id when the file extension matches one of the file extension strings known by MimeTypeTable, c_mime_unknown otherwise.

MimeType MimeTypeTable::GetMimeTypeByMimeStr ( const CHAR * mime_str ) [static]

Returns the MimeType Id associated with a MIME string.

Parameters:
mime_str Pointer to a C-string containing a MIME string.
Returns:
Corresponding MimeType Id when 'mime_str' is known by MimeTypeTable, c_mime_unknown otherwise.

const CHAR * MimeTypeTable::GetNextExtension ( const CHAR * file_ext ) [static]

Obtains the next synonym from a list of file extensions.

Parameters:
file_ext File extension string which must have been obtained by calling either GetFirstExtByMimeType() or GetFirstExtByMimeStr() or GetNextExtension().
Returns:
Pointer to C-string containing the next file extension from the list or '0' when none is available.

INT MimeTypeTable::IsBinaryByExt ( const CHAR * file_ext ) [static]

Tells whether MIME data is encoded in a binary format.

Parameters:
file_ext Pointer to a C-string containing a file extension.
Returns:
'TRUE' when 'file_ext' is known by MimeTypeTable and data representation is binary, 'FALSE' otherwise.

INT MimeTypeTable::IsBinaryByMimeStr ( const CHAR * mime_str ) [static]

Tells whether MIME data is encoded in a binary format.

Parameters:
mime_str Pointer to a C-string containing a MIME string.
Returns:
'TRUE' when 'mime_str' is known by MimeTypeTable and data representation is binarytext, 'FALSE' otherwise.

INT MimeTypeTable::IsTextByExt ( const CHAR * file_ext ) [static]

Tells whether MIME data is encoded in a text-based format.

Parameters:
file_ext Pointer to a C-string containing a file extension.
Returns:
'TRUE' when 'file_ext' is known by MimeTypeTable and data representation is text, 'FALSE' otherwise.

INT MimeTypeTable::IsTextByMimeStr ( const CHAR * mime_str ) [static]

Tells whether MIME data is encoded in a text-based format.

Parameters:
mime_str Pointer to a C-string containing a MIME string.
Returns:
'TRUE' when 'mime_str' is known by MimeTypeTable and data representation is text, 'FALSE' otherwise.

Friends And Related Function Documentation

friend class Partition [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/MimeTypeTable.hpp
  • Auxiliary/MimeTypeTable.cpp
Generated on Wed Jan 25 01:28:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MimeTypeTable::Partition Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MimeTypeTable::Partition

MimeTypeTable::Partition Class Reference

Represents a partition of the APOXI MimeTypeTable. More...

#include <Apoxi/Auxiliary/MimeTypeTable.hpp>

Collaboration diagram for MimeTypeTable::Partition:

[legend]

Public Member Functions

MimeType | GetMaxMimeTypeId () const
MimeType | GetMinMimeTypeId () const
Partition (const MimeTypeTableEntry table[], UINT no_entries)
Constructs a Partition instance and adds it to MimeTypeTable.

Friends

class | MimeTypeTable

Detailed Description

Represents a partition of the APOXI MimeTypeTable.

Currently only two partitions are allowed ! One of them is directly instantiated by MimeTypeTable and contains the MIME types directly defined by APOXI. A second instance may be allocated by user SW to support additional MIME types which are normally not supported by APOXI. User SW should not explicitly instantiate Partition. Instead, include file MimeTypeTableUtils.hpp and use the helper macros found there.

Constructor & Destructor Documentation

MimeTypeTable::Partition::Partition | ( | const MimeTypeTableEntry | table[],
 |  | UINT | no_entries
 | ) |

Constructs a Partition instance and adds it to MimeTypeTable.

Member Function Documentation

MimeType MimeTypeTable::Partition::GetMaxMimeTypeId ( ) const

MimeType MimeTypeTable::Partition::GetMinMimeTypeId ( ) const

Friends And Related Function Documentation

friend class MimeTypeTable [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/MimeTypeTable.hpp
  • Auxiliary/MimeTypeTable.cpp
Generated on Wed Jan 25 01:28:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MimeTypeTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MimeTypeTableEntry Struct Reference
[Auxiliary]

MIME type description record. More...

#include <Apoxi/Auxiliary/MimeTypeTable.hpp>

Data Fields

const CHAR * | file_ext_substr_list
File name extensions associated with the MIME type.
BOOLEAN | is_binary
Indicates that data of this type is considered binary.
const CHAR * | mime_str
MIME type string, for example "image/jpeg".
MimeType mime_type
MimeType constant - must be system-wide unique !

Detailed Description

MIME type description record.

An instance of this structure defines the properties of one MIME type.

Note:This structure should not be instantiated explicitly. Use the macro APOXI_DEF_MIME_TYPE instead.

Field Documentation

const CHAR* MimeTypeTableEntry::file_ext_substr_list

File name extensions associated with the MIME type.

Multiple file extension can be specified in one string. Each extension must be terminated by an extra '' within the string. The first entry is mandatory and serves as default file extension of that type. The extension string should be built using the macro APOXI_MIME_EXT Example: "jpg\0jpe\0jpeg\0"

BOOLEAN MimeTypeTableEntry::is_binary

Indicates that data of this type is considered binary.

const CHAR* MimeTypeTableEntry::mime_str

MIME type string, for example "image/jpeg".

MimeType MimeTypeTableEntry::mime_type

MimeType constant - must be system-wide unique !

The documentation for this struct was generated from the following file:
  • Auxiliary/MimeTypeTable.hpp
Generated on Wed Jan 25 01:28:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MinuteTickMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MinuteTickMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MinuteTickMsg:

[legend]
Collaboration diagram for MinuteTickMsg:

[legend]

Public Types

enum | { ID = 18021 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
MinuteTickMsg ()
virtual | ~MinuteTickMsg ()

Detailed Description

MinuteTickMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MinuteTickMsg::MinuteTickMsg ( )

MinuteTickMsg::~MinuteTickMsg ( ) [virtual]

Member Function Documentation

Message * MinuteTickMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & MinuteTickMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:28:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MiscAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MiscAudioDevice Class Reference

#include <Apoxi/Devices/Win32/MiscAudioDevice.hpp>

Inheritance diagram for MiscAudioDevice:

[legend]
Collaboration diagram for MiscAudioDevice:

[legend]

Public Types

enum Accessory {
AccessoryNormal, AccessoryHeadset, AccessoryStereoPhones, AccessoryBtHeadset,
AccessoryCarKit
}
Available accessory. More...

Public Member Functions

virtual const WCHAR * | GetName () const

Static Public Member Functions

static void | CheckTime ()
static AvailableHW | GetAvailableHW ()
static PowerStatus | GetPowerStatus ()
static void | RestartHf ()
static void | SetAccessory (Accessory accessory)
static void | SetVmic (UINT8 status)

Data Structures

struct | AvailableHW
Available HW. If a member variable is TRUE the hardware is available. More...
struct | PowerStatus
Power status. If a member variable is TRUE the device is powered on. More...

Detailed Description

MiscAudioDevice
Class Miscellaneous audio functions.

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Member Enumeration Documentation

enum MiscAudioDevice::Accessory

Available accessory.

Enumerator:
AccessoryNormal | Normal.
AccessoryHeadset | Headset.
AccessoryStereoPhones | Stereo phones.
AccessoryBtHeadset | Headset.
AccessoryCarKit | Car kit.

Member Function Documentation

void MiscAudioDevice::CheckTime ( ) [static]

In order for the audio driver to work properly this function must be called from GSM layer 1 upon all frame interrupts.

static AvailableHW MiscAudioDevice::GetAvailableHW ( ) [static]

Returns which resources there are available.

Returns:
structure of available hardware of all devices.

virtual const WCHAR* MiscAudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

static PowerStatus MiscAudioDevice::GetPowerStatus ( ) [static]

Returns status about which audio HW is currently powered on. In the return parameter there is a bit for each HW block control by the audio driver.

Returns:
structure of power status of all devices.

void MiscAudioDevice::RestartHf ( ) [static]

Whenever GSM layer 1 gives TCH26 command to the DSP, layer 1 must also call this audio function. This is because the TCH26 command resets some of the audio algorithm (echo canceller, voice memo etc.) running on the DSP, and the audio has restart these algorithms.

void MiscAudioDevice::SetAccessory ( Accessory accessory ) [static]

Instructs the audio driver to setup the audio to use an inserted accessory, e.g. a headset.
When the accessory is removed, this function must be called again to instruct the audio driver to use the normal audio path.

Parameters:
accessory Accessory to set.

void MiscAudioDevice::SetVmic ( UINT8 status ) [static]

Powers the microphone voltage on. This is used in some accessory detection concepts.

Parameters:
status

The documentation for this class was generated from the following files:
  • Devices/Win32/MiscAudioDevice.hpp
  • Devices/Win32/MiscAudioDevice.cpp
Generated on Wed Jan 25 01:28:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MiscAudioDevice::AvailableHW Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MiscAudioDevice::AvailableHW

MiscAudioDevice::AvailableHW Struct Reference

Available HW. If a member variable is TRUE the hardware is available. More...

#include <Apoxi/Devices/Win32/MiscAudioDevice.hpp>

Data Fields

BOOLEAN | amplifier: 1
External amplifier availability.
BOOLEAN | mp3_player: 1
MP3 player availability.
BOOLEAN | radio: 1
FM-radio availability.
BOOLEAN | ringer: 1
Ringer availability.
BOOLEAN | speech: 1
Speech availability.
BOOLEAN | tone_generator: 1
Tone generator availability.
BOOLEAN | vm_play: 1
VM playback availability.
BOOLEAN | vm_rec: 1
VM recording availability.

Detailed Description

Available HW. If a member variable is TRUE the hardware is available.

Field Documentation

BOOLEAN MiscAudioDevice::AvailableHW::amplifier

External amplifier availability.

BOOLEAN MiscAudioDevice::AvailableHW::mp3_player

MP3 player availability.

BOOLEAN MiscAudioDevice::AvailableHW::radio

FM-radio availability.

BOOLEAN MiscAudioDevice::AvailableHW::ringer

Ringer availability.

BOOLEAN MiscAudioDevice::AvailableHW::speech

Speech availability.

BOOLEAN MiscAudioDevice::AvailableHW::tone_generator

Tone generator availability.

BOOLEAN MiscAudioDevice::AvailableHW::vm_play

VM playback availability.

BOOLEAN MiscAudioDevice::AvailableHW::vm_rec

VM recording availability.

The documentation for this struct was generated from the following file:
  • Devices/Win32/MiscAudioDevice.hpp
Generated on Wed Jan 25 01:28:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MiscAudioDevice::PowerStatus Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MiscAudioDevice::PowerStatus

MiscAudioDevice::PowerStatus Struct Reference

Power status. If a member variable is TRUE the device is powered on. More...

#include <Apoxi/Devices/Win32/MiscAudioDevice.hpp>

Data Fields

BOOLEAN | amplifier: 1
External amplifier.
BOOLEAN | mp3_player: 1
MP3 player.
BOOLEAN | radio: 1
FM-radio.
BOOLEAN | ringer: 1
Ringer.
BOOLEAN | speech: 1
Speech (including DSP tone generator).
BOOLEAN | vibrator: 1
BOOLEAN | vm_play: 1
VM playback.
BOOLEAN | vm_rec: 1
VM recording.

Detailed Description

Power status. If a member variable is TRUE the device is powered on.

Field Documentation

BOOLEAN MiscAudioDevice::PowerStatus::amplifier

External amplifier.

BOOLEAN MiscAudioDevice::PowerStatus::mp3_player

MP3 player.

BOOLEAN MiscAudioDevice::PowerStatus::radio

FM-radio.

BOOLEAN MiscAudioDevice::PowerStatus::ringer

Ringer.

BOOLEAN MiscAudioDevice::PowerStatus::speech

Speech (including DSP tone generator).

BOOLEAN MiscAudioDevice::PowerStatus::vibrator

Vibrator (if the vibrator is controlled by a poly tone ringer (MA2/MA3) it might not be possible to give a correct status for the vibrator)

BOOLEAN MiscAudioDevice::PowerStatus::vm_play

VM playback.

BOOLEAN MiscAudioDevice::PowerStatus::vm_rec

VM recording.

The documentation for this struct was generated from the following file:
  • Devices/Win32/MiscAudioDevice.hpp
Generated on Wed Jan 25 01:28:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MlcNumber Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MlcNumber Struct Reference

Unique Number of the GMLC through which the transfer location is routed. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Public Types

enum | { MAX_SIZE = 10 }
Maximum Size of Mlc number in bytes. More...

Public Member Functions

MlcNumber ()
Constructor.

Data Fields

BYTE | m_mlc_number [MAX_SIZE]
The Mlc number coded in BCD format.

Detailed Description

Unique Number of the GMLC through which the transfer location is routed.

Member Enumeration Documentation

anonymous enum

Maximum Size of Mlc number in bytes.

Enumerator:
MAX_SIZE

Constructor & Destructor Documentation

MlcNumber::MlcNumber ( ) [inline]

Constructor.

Field Documentation

BYTE MlcNumber::m_mlc_number[MAX_SIZE]

The Mlc number coded in BCD format.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:28:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmAocChargingStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmAocChargingStatusMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmAocChargingStatusMsg:

[legend]
Collaboration diagram for MmAocChargingStatusMsg:

[legend]

Public Types

enum | { ID = 19118 }

Public Member Functions

virtual Message * | Clone () const
const AocChargingStatus & | GetAocChargingStatus () const
const CallIndex & | GetCallIndex () const
virtual const MsgMetaData & | GetMetaData () const
MmAocChargingStatusMsg (ExecutionContext *context, const CallIndex &call_index, const AocChargingStatus &aoc_charging_status)
virtual | ~MmAocChargingStatusMsg ()

Detailed Description

Indicating a change of the AOC Status

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmAocChargingStatusMsg::MmAocChargingStatusMsg | ( | ExecutionContext * | context,
 |  | const CallIndex & | call_index,
 |  | const AocChargingStatus & | aoc_charging_status
 | ) |

MmAocChargingStatusMsg::~MmAocChargingStatusMsg ( ) [virtual]

Member Function Documentation

Message * MmAocChargingStatusMsg::Clone ( ) const [virtual]

Implements Message.

const AocChargingStatus& MmAocChargingStatusMsg::GetAocChargingStatus ( ) const [inline]

const CallIndex& MmAocChargingStatusMsg::GetCallIndex ( ) const [inline]

const MsgMetaData & MmAocChargingStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallAcceptMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallAcceptMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCallAcceptMsg:

[legend]
Collaboration diagram for MmCallAcceptMsg:

[legend]

Public Types

enum | { ID = 19119 }

Public Member Functions

virtual Message * | Clone () const
const CallIndex & | GetCallIndex () const
virtual const MsgMetaData & | GetMetaData () const
MmCallAcceptMsg (const CallIndex &call_index)
virtual | ~MmCallAcceptMsg ()

Detailed Description

CallAcceptMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCallAcceptMsg::MmCallAcceptMsg ( const CallIndex & call_index )

MmCallAcceptMsg::~MmCallAcceptMsg ( ) [virtual]

Member Function Documentation

Message * MmCallAcceptMsg::Clone ( ) const [virtual]

Implements Message.

const CallIndex& MmCallAcceptMsg::GetCallIndex ( ) const [inline]

const MsgMetaData & MmCallAcceptMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallDisconnectingMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallDisconnectingMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCallDisconnectingMsg:

[legend]
Collaboration diagram for MmCallDisconnectingMsg:

[legend]

Public Types

enum | { ID = 19111 }

Public Member Functions

virtual Message * | Clone () const
UINT32 | GetCallDurationInSecs () const
const CallErrorCause & | GetErrorCause () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetPhoneNumber () const
MmCallDisconnectingMsg (ExecutionContext *context, const MmCallState &state, const CallIndex &call_index, const PhoneNumber &phone_number, const CallErrorCause &error_cause, UINT32 call_duration_in_secs)
virtual | ~MmCallDisconnectingMsg ()

Detailed Description

Message indicating an ongoing disconnection of an Mm Call.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCallDisconnectingMsg::MmCallDisconnectingMsg | ( | ExecutionContext * | context,
 |  | const MmCallState & | state,
 |  | const CallIndex & | call_index,
 |  | const PhoneNumber & | phone_number,
 |  | const CallErrorCause & | error_cause,
 |  | UINT32 | call_duration_in_secs
 | ) |

MmCallDisconnectingMsg::~MmCallDisconnectingMsg ( ) [virtual]

Member Function Documentation

Message * MmCallDisconnectingMsg::Clone ( ) const [virtual]

Reimplemented from MmCallStatusMsg.

UINT32 MmCallDisconnectingMsg::GetCallDurationInSecs ( ) const [inline]

const CallErrorCause& MmCallDisconnectingMsg::GetErrorCause ( ) const [inline]

const MsgMetaData & MmCallDisconnectingMsg::GetMetaData ( ) const [virtual]

Reimplemented from MmCallStatusMsg.

const PhoneNumber& MmCallDisconnectingMsg::GetPhoneNumber ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallDispatcher Class Reference

#include <Apoxi/AddOns/MmCall/MmCallDispatcher.hpp>

Inheritance diagram for MmCallDispatcher:

[legend]
Collaboration diagram for MmCallDispatcher:

[legend]

Public Member Functions

MmCallDispatcher (MmCallHandler *call_handler)
virtual | ~MmCallDispatcher ()
Destructor.

Protected Member Functions

BOOLEAN | OnTerminalEvent (const StackMsgArgument &arg)
Called on FromStack Message with ArgumentID == SerialTerminalArgID.

Detailed Description

Listens for AtResponseMessages and calls OnTerminalResponse at MmCallHandler at received AtResponseMessages

Constructor & Destructor Documentation

MmCallDispatcher::MmCallDispatcher ( MmCallHandler * call_handler )

Constructor

Parameters:
call_handler related MmCallHandler

MmCallDispatcher::~MmCallDispatcher ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN MmCallDispatcher::OnTerminalEvent ( const StackMsgArgument & arg ) [protected]

Called on FromStack Message with ArgumentID == SerialTerminalArgID.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallDispatcher.hpp
  • AddOns/MmCall/MmCallDispatcher.cpp
Generated on Wed Jan 25 01:29:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallHandler Class Reference

#include <Apoxi/AddOns/MmCall/MmCallHandler.hpp>

Collaboration diagram for MmCallHandler:

[legend]

Public Member Functions

CallApiRc | Accept (const CallIndex call_index)
void | DisconnectActivePsdCalls ()
CallApiRc | GetCurrentCallMeter (const CallIndex call_index)
CallApiRc | GetCurrentChargeData (const CallIndex call_index)
virtual HandlerId | GetHandlerId () const
returns the Handler ID of the MmCallHandler
Socket * | GetSocket (CallIndex call_index)
BOOLEAN | IsInOnlineMode (SerialTerminal *terminal)
BOOLEAN | IsMmCall (CallIndex call_index) const
BOOLEAN | IsMobileOriginated (CallIndex call_index) const
BOOLEAN | IsMobileTerminated (CallIndex call_index) const
BOOLEAN | IsPsdCallActive ()
MmCallHandler ()
void | OnTerminalResponse (SerialTerminal *terminal, const AtResponse &response)
CallApiRc | Reject (const CallIndex call_index, ClearCause cause=SubscriberBusy, BOOLEAN wait_condition=FALSE)
CallApiRc | RejectAllMtc (BOOLEAN activate)
virtual CallApiRc | Release (const CallIndex call_index, TimeSpan *calling_time=0, BOOLEAN wait_condition=FALSE)
void | ReportCurrentCallMeter (BOOLEAN activate)
void | ReportCurrentCharge (BOOLEAN activate)
CallApiRc | Setup (const CallIndex call_index, const PhoneNumber &phone_no, ClirMode clir_mode=DontCare)
virtual | ~MmCallHandler ()

Detailed Description

MmCallHandler is the central class for handling call events. It provides methods for setting up a call, accepting or rejecting an incoming call and releasing an active call. Furthermore it provides access to the CallHandlingData object held by the MainHandler.

The MmCallHandler has to be subscribed (StackControl::Subscribe(MmCallHandlerId);) on startup of the application. All further initialization of the components needed by the MmCallHandler are intitialzed within the Handler or its subcomponents.

Constructor & Destructor Documentation

MmCallHandler::MmCallHandler ( )

MmCallHandler::~MmCallHandler ( ) [virtual]

Member Function Documentation

CallApiRc MmCallHandler::Accept ( const CallIndex call_index )

Accepts an incoming (mobile terminated) multi-media call. Returns NoError if it has been successfully accepted. A MmCallSetupProgressMsg is sent during execution of Accept(). Refer to the documentation of CallApiRc for a detailed description of the return values.

Parameters:
call_index Apoxi Id of the call to accept
Returns:
NoError - If executed successfully. In case of error one of the following values will be returned: CallDataLocked, ActiveCallDetected, InvalidCallIndex, VoidCallIndex or CallDisconnected.

void MmCallHandler::DisconnectActivePsdCalls ( )

Disconnects all active psd calls

CallApiRc MmCallHandler::GetCurrentCallMeter ( const CallIndex call_index )

Initiates the sending of the message MmCurrentChargeDataMsg for one time if the call identified by call_index exists.

Returns:
VoidCallIndex if the CallHdl is not valid any more, SupplementaryService failed if AoC is not supported for this call, NoError otherwise.

CallApiRc MmCallHandler::GetCurrentChargeData ( const CallIndex call_index )

Initiates the sending of the message MmCurrentCallMeterMsg for one time, if the call identified by call_index exists.

Returns:
VoidCallIndex if the MmCallHdl is not valid any more, SupplementaryService failed if AoC is not supported for this call, NoError otherwise.

virtual HandlerId MmCallHandler::GetHandlerId ( ) const [inline, virtual]

returns the Handler ID of the MmCallHandler

Socket * MmCallHandler::GetSocket ( CallIndex call_index )

Returns the socket for the data connection. Write and Read methods at the returned socket cause an error if the call is not in active state

Parameters:
index Index of the call the socket belongs to

BOOLEAN MmCallHandler::IsInOnlineMode ( SerialTerminal * terminal )

Returns TRUE if the SerialTerminal provided in the parameter terminal is in online mode or not.

Parameters:
terminal Terminal that is either in online mode or not
Returns:
TRUE if terminal is in online mode, FALSE otherwise

BOOLEAN MmCallHandler::IsMmCall ( CallIndex call_index ) const

Returns:
TRUE if call with call index index is an multi media call

BOOLEAN MmCallHandler::IsMobileOriginated ( CallIndex call_index ) const

Returns:
TRUE if the MmCallHdl refers to a mobile originated call, FALSE otherwise.

BOOLEAN MmCallHandler::IsMobileTerminated ( CallIndex call_index ) const

Returns:
TRUE if the MmCallHdl refers to a mobile terminated call, FALSE otherwise.

BOOLEAN MmCallHandler::IsPsdCallActive ( )

Returns wheter a PSD call is currently active

Returns:
TRUE if at least one PSD call is currently active, FALSE otherwise

void MmCallHandler::OnTerminalResponse | ( | SerialTerminal * | terminal,
 |  | const AtResponse & | response
 | ) |

Call back method for terminal responses. Is called when data received at a terminal was identified as valid AT response

Parameters:
terminal | Terminal which received the response
response | Received response

CallApiRc MmCallHandler::Reject | ( | const CallIndex | call_index,
 |  | ClearCause | cause = SubscriberBusy,
 |  | BOOLEAN | wait_condition = FALSE
 | ) |

Releases a mobile terminated call before it is accepted and sends the calling party information about the cause for the release..

Parameters:
call_index | Apoxi Id of the call to reject
cause | The default cause SubscriberBusy, is used when the called user has indicated the inability to accept another call.
Returns:
See CallHdl::Release.

CallApiRc MmCallHandler::RejectAllMtc ( BOOLEAN activate )

Enables/disables blocking of all mobile terminated calls.

Parameters:
activate TRUE activates, FALSE deactivates blocking.
Returns:
NoError - If blocking successfully enabled or disabled. CallDataLocked if another thread currently blocks the internal data structures.

CallApiRc MmCallHandler::Release | ( | const CallIndex | call_index,
 |  | TimeSpan * | calling_time = 0,
 |  | BOOLEAN | wait_condition = FALSE
 | ) | [virtual]

Releases a mobile terminated or mobile originated voice call. May be invoked during call setup and call active phase. The internal data will be immediately updated. There is no active wait for the networks release confirmation, since the confirmation will be generated by the protocol stack if the network fails to answer within 30 sec. Refer to the documentation of CallApiRc for a detailed description of the return values.

Parameters:
call_index | Apoxi Id of the call to release
calling_time | - Is set to the call duration (time span).
wait_condition | TRUE for synchronous waiting of release
Returns:
NoError - If executed successfully. In case of error, one of the following values will be returned: CallDataLocked, InvalidCallIndex, VoidCallIndex.

void MmCallHandler::ReportCurrentCallMeter ( BOOLEAN activate )

Starts the automatic reporting of the current call meter (CCM) in home units. The message MmCurrentCallMeterMsg will be sent each time when the CCM is calculated (but not more than once within 2 seconds) until the automatic reporting is stopped by calling this method with parameter activate set to FALSE.

Parameters:
activate Starts reporting of CCM if TRUE, stops reporting if FALSE.

void MmCallHandler::ReportCurrentCharge ( BOOLEAN activate )

Starts the automatic reporting of the current charge in currency units. The message MmCurrentChargeDataMsg will be sent each time when the CCM is calculated until the automatic reporting is stopped by calling this method with parameter activate set to FALSE.

Parameters:
activate Starts reporting of current charge if TRUE, stops reporting if FALSE.

CallApiRc MmCallHandler::Setup | ( | const CallIndex | call_index,
 |  | const PhoneNumber & | phone_no,
 |  | ClirMode | clir_mode = DontCare
 | ) |

Establishes a mobile originated multi-media call. During the execution of Setup(const PhoneNumber & phone_no), several info-messages on setup progress are sent.

Parameters:
call_index | Apoxi Id of the call to setup
phone_no | The phone number of the call to be set up.
clir_mode | SuppressPhoneNumber or DisplayPhoneNumber. By default DontCare will be used.
Returns:
NoError - If executed successfully. In case of error one of the following values will be returned: CallDataLocked, NoNetwork, ActiveCallDetected, SetupCallDetected, MaxCallCountExceeded, CallDisconnected, CallSetupRejected.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallHandler.hpp
  • AddOns/MmCall/MmCallHandler.cpp
Generated on Wed Jan 25 01:29:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallHdl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallHdl Class Reference

Class to establish and release Mm calls. Calls are identified by a call_index. More...

#include <Apoxi/AddOns/MmCall/MmCallHdl.hpp>

Public Member Functions

CallApiRc Accept ()
virtual TimeSpan | GetCallDuration () const
virtual CallIndex | GetCallIndex () const
CallType | GetCallType () const
ClirMode | GetClirMode () const
const PhoneNumber & | GetConnectedToPhoneNumber () const
CallApiRc GetCurrentCallMeter ()
CallApiRc GetCurrentChargeData ()
const PhoneNumber & | GetPhoneNumber () const
Socket * | GetSocket () const
virtual DateTime | GetStartTime () const
virtual void | Invalidate ()
Sets the reference of a MmCallHdl object to the void reference.
BOOLEAN | IsAcceptPermitted () const
virtual BOOLEAN | IsActive () const
BOOLEAN | IsInSetup () const
BOOLEAN | IsMobileOriginated () const
BOOLEAN | IsMobileTerminated () const
BOOLEAN | IsSetupPermitted () const
virtual BOOLEAN | IsValid () const
MmCallHdl (CallIndex call_index=c_null_call_index)
BOOLEAN | operator== (const MmCallHdl &call) const
CallApiRc | Reject (ClearCause cause=SubscriberBusy, BOOLEAN wait_condition=FALSE)
virtual CallApiRc | Release (TimeSpan *calling_time=0, BOOLEAN wait_condition=FALSE)
CallApiRc | Setup (const PhoneNumber &phone_no, ClirMode clir_mode=DontCare)
virtual | ~MmCallHdl ()

Static Public Member Functions

static void | DisconnectActivePsdCalls ()
static BOOLEAN | IsPsdCallActive ()
static CallApiRc | RejectAllMtc (BOOLEAN activate)
static void | ReportCurrentCallMeter (BOOLEAN activate)
static void | ReportCurrentCharge (BOOLEAN activate)

Detailed Description

Class to establish and release Mm calls. Calls are identified by a call_index.

Constructor & Destructor Documentation

MmCallHdl::MmCallHdl ( CallIndex call_index = c_null_call_index )

Creates a well-initialized MmCallHdl object.

Parameters:
call_index A reference to a call. If omitted, which is the standard case, c_null_call_index is used by default.

MmCallHdl::~MmCallHdl ( ) [virtual]

Member Function Documentation

CallApiRc MmCallHdl::Accept ( )

Accepts an incoming (mobile terminated) multimedia call. Returns NoError if it has been successfully accepted. A CallEventMsg is sent after having established an MTC. Refer to the documentation of CallApiRc for a detailed description of the return values.

Returns:
NoError - If executed successfully. In case of error one of the following values will be returned: CallDataLocked, ActiveCallDetected, InvalidCallIndex, VoidCallIndex or CallDisconnected.

void MmCallHdl::DisconnectActivePsdCalls ( ) [static]

Disconnects all active psd calls

TimeSpan MmCallHdl::GetCallDuration ( ) const [virtual]

Returns a TimeSpan object for the duration of the call represented by an MmCallHdl. The method is applicable to MmCallHdl.

Returns:
A zero value if the MmCallHdl is not valid. Also zero if a single call has not been successfully established. The time span from the successful establishment of of a single call or multiparty call to the time of execution of this method.

virtual CallIndex MmCallHdl::GetCallIndex ( ) const [inline, virtual]

Returns:
the call index of the MmCallHdl object.

CallType MmCallHdl::GetCallType ( ) const

Returns:
The CallType of the call

ClirMode MmCallHdl::GetClirMode ( ) const

Returns:
The ClirMode which has been used for MOC setup

const PhoneNumber & MmCallHdl::GetConnectedToPhoneNumber ( ) const

Returns a reference to a PhoneNumber object where a mobile originated call is actually connected to. If the dialled number is equal to the connected to number, the return value is identical to the return of GetPhoneNumber(). If applied to an MmCallHdl which represents an MTC the return value is equal to the return value of GetPhoneNumber(). The MmCallHdl shall contain a valid CallIndex!!

See also:
GetPhoneNumber().
Returns:
A constant reference to a PhoneNumber.

CallApiRc MmCallHdl::GetCurrentCallMeter ( )

Initiates the sending of the message MmCurrentCallMeterMsg for one time, if the respective call exists.

Returns:
VoidCallIndex if the MmCallHdl is not valid any more, SupplementaryService failed if AoC is not supported for this call, NoError otherwise.

CallApiRc MmCallHdl::GetCurrentChargeData ( )

Initiates the sending of the message MmCurrentChargeDataMsg for one time if the respective call exists.

Returns:
VoidCallIndex if the CallHdl is not valid any more, SupplementaryService failed if AoC is not supported for this call, NoError otherwise.

const PhoneNumber & MmCallHdl::GetPhoneNumber ( ) const

Returns a reference to a PhoneNumber object containing the phone number of a MOC or MTC. If the phone number has not yet been transmitted by network, the returned PhoneNumber is empty (MTC). If invoked during the setup phase of a MOC, the return value is the dialled phone number. The MmCallHdl shall contain a valid CallIndex, i.e., c_null_call_index < CallIndex < c_max_calls.

Returns:
A constant reference to a PhoneNumber.

Socket * MmCallHdl::GetSocket ( ) const

Returns the socket for the data connection. Write and Read methods at the returned socket cause an error if the call is not in active state

Returns:
Socket uded for data communication

DateTime MmCallHdl::GetStartTime ( ) const [virtual]

Returns the time when the call was established. The MmCallHdl shall contain a valid CallIndex. See also GetPhoneNumber().

Returns:
A DateTime object containing the time the call was established. Contains 0 if applied to a non existent call.

virtual void MmCallHdl::Invalidate ( ) [inline, virtual]

Sets the reference of a MmCallHdl object to the void reference.

BOOLEAN MmCallHdl::IsAcceptPermitted ( ) const

Returns:
TRUE if the preconditions for accepting an mtc are fulfilled.

BOOLEAN MmCallHdl::IsActive ( ) const [virtual]

Returns TRUE if the given MmCallHdl refers to the active call, FALSE otherwise (also when containing a void reference).

BOOLEAN MmCallHdl::IsInSetup ( ) const

Returns TRUE if the given MmCallHdl refers to the call in setup phase, FALSE otherwise.

BOOLEAN MmCallHdl::IsMobileOriginated ( ) const

Returns TRUE if the MmCallHdl refers to a mobile originated call, FALSE otherwise.

BOOLEAN MmCallHdl::IsMobileTerminated ( ) const

Returns TRUE if the MmCallHdl refers to a mobile terminated call, FALSE otherwise.

BOOLEAN MmCallHdl::IsPsdCallActive ( ) [static]

Returns wheter a PSD call is currently active

Returns:
TRUE if at least one PSD call is currently active, FALSE otherwise

BOOLEAN MmCallHdl::IsSetupPermitted ( ) const

Returns:
TRUE if the preconditions for a moc (voice) are fulfilled.

BOOLEAN MmCallHdl::IsValid ( ) const [virtual]

An MmCallHdl object is valid if it's reference is different to the void reference.

Returns:
FALSE - If the reference is the void reference.
TRUE - Otherwise.

BOOLEAN MmCallHdl::operator== ( const MmCallHdl & call ) const

Checks the CallIndices of both MmCallHdl objects.

Returns:
TRUE - If both objects refer to the same call.
FALSE - If the references are different or both objects keep a void reference.

CallApiRc MmCallHdl::Reject | ( | ClearCause | cause = SubscriberBusy,
 |  | BOOLEAN | wait_condition = FALSE
 | ) |

Releases a mobile terminated multimedia call before it is accepted and sends the calling party information about the cause for the release.

Parameters:
cause The default cause SubscriberBusy, is used when the called user has indicated the inability to accept another call.
Returns:
See CallHdl::Release.

CallApiRc MmCallHdl::RejectAllMtc ( BOOLEAN activate ) [static]

Enables/disables blocking of all mobile terminated calls.

Parameters:
activate TRUE activates, FALSE deactivates blocking.
Returns:
NoError - If blocking successfully enabled or disabled. CallDataLocked if another thread currently blocks the internal data structures.

CallApiRc MmCallHdl::Release | ( | TimeSpan * | calling_time = 0,
 |  | BOOLEAN | wait_condition = FALSE
 | ) | [virtual]

Releases a mobile terminated or mobile originated multimedia call. May be invoked during call setup and call active phase. The internal data will be updated immediately. The CallIndex of the MmCallHdl is set to c_null_call_index. Refer to the documentation of CallApiRc for a detailed description of the return values.

Parameters:
calling_time | - Is set to the call duration (time span).
wait_condition | TRUE for synchronous waiting of release
Returns:
NoError - If executed successfully. In case of error, one of the following values will be returned: CallDataLocked, InvalidCallIndex, UnexpectedResult.

void MmCallHdl::ReportCurrentCallMeter ( BOOLEAN activate ) [static]

Starts automatic reporting of current call meter (CCM). The message MmCurrentCallMeterMsg will be sent each time when the CCM is calculated until the automatic reporting is stopped by calling this method with parameter activate set to FALSE.

Parameters:
activate Starts reporting of CCM if TRUE, stops reporting if FALSE.

void MmCallHdl::ReportCurrentCharge ( BOOLEAN activate ) [static]

Starts automatic reporting of current charge. The message MmCurrentChargeMsg will be sent each time when the CCM is calculated (but not more than once within 2 seconds) until the automatic reporting is stopped by calling this method with parameter activate set to FALSE.

Parameters:
activate Starts reporting of current charge if TRUE, stops reporting if FALSE.

CallApiRc MmCallHdl::Setup | ( | const PhoneNumber & | phone_no,
 |  | ClirMode | clir_mode = DontCare
 | ) |

Establishes a mobile originated multimedia call. Assigns the CallIndex in the MmCallHdl as soon it is available by the AT interface and returns NoError, if the call setup was successful. In case of any error, the CallIndex will be set to c_null_call_index. During the execution of Setup(const PhoneNumber & phone_no), several info-messages are sent (active wait loop). The messages supply information on setup progress and are the following: MmMocSetupAcceptMsg, MmCallStatusMsg, and MmCallSetupProgressMsg. Refer to the documentation of CallApiRc for a detailed description of the return values. The CLIR mode is defaulted to the network settings.

Parameters:
phone_no | The phone number of the call to be set up.
clir_mode | SuppressPhoneNumber or DisplayPhoneNumber. By default DontCare will be used.
Returns:
NoError - If executed successfully. In case of error one of the following values will be returned: CallDataLocked, NoNetwork, ActiveCallDetected, SetupCallDetected, MaxCallCountExceeded, CallDisconnected, CallSetupRejected.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallHdl.hpp
  • AddOns/MmCall/MmCallHdl.cpp
Generated on Wed Jan 25 01:29:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallInfo Class Reference

#include <Apoxi/AddOns/MmCall/MmCallInfo.hpp>

Collaboration diagram for MmCallInfo:

[legend]

Public Types

enum | CallDirection { MobileOriginatedCall, MobileTerminatedCall, NoCall }
Different call directions. More...
enum CallState {
InSetup, InAccept, InReject, InRelease,
InCall, Closed
}
State of a call. More...

Public Member Functions

CallDirection | GetCallDirection () const
Get the call direction.
INT8 | GetCallId () const
Get the call id retrieved from the AT interface.
CallIndex | GetCallIndex () const
Get the Apoxi/Asc call index.
CallState | GetCallState () const
Get the call state.
SerialTerminal * | GetDataTerminal () const
SerialTerminalSocket * GetSocket ()
void | Invalidate ()
Set members to defined, invalid values.
BOOLEAN | IsInOnlineMode () const
Get data mode.
MmCallInfo ()
Constructor.
void | SetCallDirection (CallDirection call_dir)
Set the call direction.
void | SetCallId (INT8 call_id)
Set the call id retrieved from the AT interface.
void | SetCallIndex (CallIndex call_index)
Set the Apoxi/Asc call index.
void | SetCallState (CallState state)
Set the call state.
void | SetOnlineMode (BOOLEAN in_online_mode)
Set data mode. Data mode is set to TRUE when the call is connected.
~MmCallInfo ()
Destructor.

Detailed Description

Mapps call_ids received from the AT interface to call_indices which are used from Apoxi. Holds terminal and socket for a call and stores call direction and call status NOTE: It is not allowed to derive from AtResponseParameter (no virtual destructor).

Member Enumeration Documentation

enum MmCallInfo::CallDirection

Different call directions.

Enumerator:
MobileOriginatedCall
MobileTerminatedCall
NoCall

enum MmCallInfo::CallState

State of a call.

Enumerator:
InSetup
InAccept
InReject
InRelease
InCall
Closed

Constructor & Destructor Documentation

MmCallInfo::MmCallInfo ( )

Constructor.

MmCallInfo::~MmCallInfo ( )

Destructor.

Member Function Documentation

CallDirection MmCallInfo::GetCallDirection ( ) const [inline]

Get the call direction.

INT8 MmCallInfo::GetCallId ( ) const [inline]

Get the call id retrieved from the AT interface.

CallIndex MmCallInfo::GetCallIndex ( ) const [inline]

Get the Apoxi/Asc call index.

CallState MmCallInfo::GetCallState ( ) const [inline]

Get the call state.

SerialTerminal* MmCallInfo::GetDataTerminal ( ) const [inline]

Returns the terminal which is used for data communication. The socket returned by GetSocket() uses this terminal for data communication

SerialTerminalSocket* MmCallInfo::GetSocket ( ) [inline]

Returns a socket for data communication. If the socket is used before the call is connected, Read/Write calls fail

void MmCallInfo::Invalidate ( )

Set members to defined, invalid values.

BOOLEAN MmCallInfo::IsInOnlineMode ( ) const [inline]

Get data mode.

void MmCallInfo::SetCallDirection ( CallDirection call_dir ) [inline]

Set the call direction.

void MmCallInfo::SetCallId ( INT8 call_id ) [inline]

Set the call id retrieved from the AT interface.

void MmCallInfo::SetCallIndex ( CallIndex call_index ) [inline]

Set the Apoxi/Asc call index.

void MmCallInfo::SetCallState ( CallState state ) [inline]

Set the call state.

void MmCallInfo::SetOnlineMode ( BOOLEAN in_online_mode ) [inline]

Set data mode. Data mode is set to TRUE when the call is connected.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallInfo.hpp
  • AddOns/MmCall/MmCallInfo.cpp
Generated on Wed Jan 25 01:29:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallInfoMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCallInfoMsg:

[legend]
Collaboration diagram for MmCallInfoMsg:

[legend]

Public Types

enum | { ID = 19114 }

Public Member Functions

virtual Message * | Clone () const
const CallIndex & | GetCallIndex () const
const CallState & | GetCallState () const
const CallType & | GetCallType () const
virtual const MsgMetaData & | GetMetaData () const
MmCallInfoMsg (ExecutionContext *context, const CallIndex &call_index, const CallState &call_state, const CallType &call_type)
virtual | ~MmCallInfoMsg ()

Detailed Description

Contains state and type of call identified by call_index

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCallInfoMsg::MmCallInfoMsg | ( | ExecutionContext * | context,
 |  | const CallIndex & | call_index,
 |  | const CallState & | call_state,
 |  | const CallType & | call_type
 | ) |

MmCallInfoMsg::~MmCallInfoMsg ( ) [virtual]

Member Function Documentation

Message * MmCallInfoMsg::Clone ( ) const [virtual]

Implements Message.

const CallIndex& MmCallInfoMsg::GetCallIndex ( ) const [inline]

const CallState& MmCallInfoMsg::GetCallState ( ) const [inline]

const CallType& MmCallInfoMsg::GetCallType ( ) const [inline]

const MsgMetaData & MmCallInfoMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallNotifyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallNotifyMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCallNotifyMsg:

[legend]
Collaboration diagram for MmCallNotifyMsg:

[legend]

Public Types

enum | { ID = 19115 }

Public Member Functions

virtual Message * | Clone () const
const CallIndex & | GetCallIndex () const
virtual const MsgMetaData & | GetMetaData () const
const NotificationDescription & | GetNotificationDescription () const
MmCallNotifyMsg (ExecutionContext *context, const CallIndex &call_index, const NotificationDescription &notification_description)
virtual | ~MmCallNotifyMsg ()

Detailed Description

Notifies about changes of an active call

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCallNotifyMsg::MmCallNotifyMsg | ( | ExecutionContext * | context,
 |  | const CallIndex & | call_index,
 |  | const NotificationDescription & | notification_description
 | ) |

MmCallNotifyMsg::~MmCallNotifyMsg ( ) [virtual]

Member Function Documentation

Message * MmCallNotifyMsg::Clone ( ) const [virtual]

Implements Message.

const CallIndex& MmCallNotifyMsg::GetCallIndex ( ) const [inline]

const MsgMetaData & MmCallNotifyMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const NotificationDescription& MmCallNotifyMsg::GetNotificationDescription ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallReleaseMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallReleaseMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCallReleaseMsg:

[legend]
Collaboration diagram for MmCallReleaseMsg:

[legend]

Public Types

enum | { ID = 19120 }

Public Member Functions

virtual Message * | Clone () const
const CallIndex & | GetCallIndex () const
virtual const MsgMetaData & | GetMetaData () const
MmCallReleaseMsg (const CallIndex &call_index)
virtual | ~MmCallReleaseMsg ()

Detailed Description

CallReleaseMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCallReleaseMsg::MmCallReleaseMsg ( const CallIndex & call_index )

MmCallReleaseMsg::~MmCallReleaseMsg ( ) [virtual]

Member Function Documentation

Message * MmCallReleaseMsg::Clone ( ) const [virtual]

Implements Message.

const CallIndex& MmCallReleaseMsg::GetCallIndex ( ) const [inline]

const MsgMetaData & MmCallReleaseMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallSerialTerminalListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallSerialTerminalListener Class Reference

#include <Apoxi/AddOns/MmCall/MmCallSerialTerminalListener.hpp>

Inheritance diagram for MmCallSerialTerminalListener:

[legend]
Collaboration diagram for MmCallSerialTerminalListener:

[legend]

Public Types

typedef SerialTerminalListener | Base

Public Member Functions

MmCallSerialTerminalListener ()
Constructor.
virtual void | OnTerminalEvent (SerialTerminal &terminal, SerialTerminal::Event event)
virtual | ~MmCallSerialTerminalListener ()
Destructor.

Detailed Description

Implements the interface SerialTerminalListener. MmCallSerialTerminalListener maps terminal events to FromStack messages with appropriate arguments

Member Typedef Documentation

typedef SerialTerminalListener MmCallSerialTerminalListener::Base

Constructor & Destructor Documentation

MmCallSerialTerminalListener::MmCallSerialTerminalListener ( )

Constructor.

MmCallSerialTerminalListener::~MmCallSerialTerminalListener ( ) [virtual]

Destructor.

Member Function Documentation

void MmCallSerialTerminalListener::OnTerminalEvent | ( | SerialTerminal & | terminal,
 |  | SerialTerminal::Event | event
 | ) | [virtual]

See also:
SerialTerminlListener::OnTerminalEvent

Implements SerialTerminalListener.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallSerialTerminalListener.hpp
  • AddOns/MmCall/MmCallSerialTerminalListener.cpp
Generated on Wed Jan 25 01:29:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallSetupProgressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallSetupProgressMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCallSetupProgressMsg:

[legend]
Collaboration diagram for MmCallSetupProgressMsg:

[legend]

Public Types

enum | { ID = 19113 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const CallProgressInd & | GetProgressIndication () const
MmCallSetupProgressMsg (ExecutionContext *context, const MmCallState &state, const CallIndex &call_index, const CallProgressInd &progress_indication)
virtual | ~MmCallSetupProgressMsg ()

Detailed Description

Message indicating a disconnection of an Mm Call.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCallSetupProgressMsg::MmCallSetupProgressMsg | ( | ExecutionContext * | context,
 |  | const MmCallState & | state,
 |  | const CallIndex & | call_index,
 |  | const CallProgressInd & | progress_indication
 | ) |

MmCallSetupProgressMsg::~MmCallSetupProgressMsg ( ) [virtual]

Member Function Documentation

Message * MmCallSetupProgressMsg::Clone ( ) const [virtual]

Reimplemented from MmCallStatusMsg.

const MsgMetaData & MmCallSetupProgressMsg::GetMetaData ( ) const [virtual]

Reimplemented from MmCallStatusMsg.

const CallProgressInd& MmCallSetupProgressMsg::GetProgressIndication ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCallStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCallStatusMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCallStatusMsg:

[legend]
Collaboration diagram for MmCallStatusMsg:

[legend]

Public Types

enum | { ID = 19110 }

Public Member Functions

virtual Message * | Clone () const
const CallIndex & | GetCallIndex () const
virtual const MsgMetaData & | GetMetaData () const
const MmCallState & | GetState () const
MmCallStatusMsg (ExecutionContext *context, const MmCallState &state, const CallIndex &call_index)
virtual | ~MmCallStatusMsg ()

Detailed Description

Base class for messages indicating the status of an Mm Call

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCallStatusMsg::MmCallStatusMsg | ( | ExecutionContext * | context,
 |  | const MmCallState & | state,
 |  | const CallIndex & | call_index
 | ) |

MmCallStatusMsg::~MmCallStatusMsg ( ) [virtual]

Member Function Documentation

Message * MmCallStatusMsg::Clone ( ) const [virtual]

Implements Message.

Reimplemented in MmCallDisconnectingMsg, MmMocSetupAcceptMsg, and MmCallSetupProgressMsg.

const CallIndex& MmCallStatusMsg::GetCallIndex ( ) const [inline]

const MsgMetaData & MmCallStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

Reimplemented in MmCallDisconnectingMsg, MmMocSetupAcceptMsg, and MmCallSetupProgressMsg.

const MmCallState& MmCallStatusMsg::GetState ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCellChangeCnts Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCellChangeCnts Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Data Fields

UINT8 | cr_success
UINT8 | ir_cr_attempt
UINT8 | ir_cr_success
UINT8 | ir_ho_attempt
UINT8 | ir_ho_success

Field Documentation

UINT8 MmCellChangeCnts::cr_success

UINT8 MmCellChangeCnts::ir_cr_attempt

UINT8 MmCellChangeCnts::ir_cr_success

UINT8 MmCellChangeCnts::ir_ho_attempt

UINT8 MmCellChangeCnts::ir_ho_success

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 01:29:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCoordParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCoordParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

BOOLEAN | IsGprsClassInvalid ()
BOOLEAN | IsGsmBandInvalid ()
BOOLEAN | IsRegStateInvalid ()
BOOLEAN | IsStateInvalid ()
BOOLEAN | IsTimerInvalid ()
MmCoordParam ()
MmCoordParam | operator= (T_MMCOORD_TESTPARAM mmcoord_testparam)

Data Fields

GprsClass gprs_class
GsmBand gsm_band
RegState reg_state
INT | state
INT | timer

Constructor & Destructor Documentation

MmCoordParam::MmCoordParam ( ) [inline]

Member Function Documentation

BOOLEAN MmCoordParam::IsGprsClassInvalid ( ) [inline]

BOOLEAN MmCoordParam::IsGsmBandInvalid ( ) [inline]

BOOLEAN MmCoordParam::IsRegStateInvalid ( ) [inline]

BOOLEAN MmCoordParam::IsStateInvalid ( ) [inline]

BOOLEAN MmCoordParam::IsTimerInvalid ( ) [inline]

MmCoordParam MmCoordParam::operator= ( T_MMCOORD_TESTPARAM mmcoord_testparam )

Field Documentation

GprsClass MmCoordParam::gprs_class

GsmBand MmCoordParam::gsm_band

RegState MmCoordParam::reg_state

INT MmCoordParam::state

INT MmCoordParam::timer

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:29:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmcsParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmcsParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

BOOLEAN | IsServiceStateInvalid ()
BOOLEAN | IsStateInvalid ()
BOOLEAN | IsTimerInvalid ()
BOOLEAN | IsUpdateStatusInvalid ()
MmcsParam ()
MmcsParam | operator= (T_MMCS_TESTPARAM mmcs_testparam)

Data Fields

INT | service_state
INT | state
INT | timer
INT | update_status

Constructor & Destructor Documentation

MmcsParam::MmcsParam ( ) [inline]

Member Function Documentation

BOOLEAN MmcsParam::IsServiceStateInvalid ( ) [inline]

BOOLEAN MmcsParam::IsStateInvalid ( ) [inline]

BOOLEAN MmcsParam::IsTimerInvalid ( ) [inline]

BOOLEAN MmcsParam::IsUpdateStatusInvalid ( ) [inline]

MmcsParam MmcsParam::operator= ( T_MMCS_TESTPARAM mmcs_testparam )

Field Documentation

INT MmcsParam::service_state

INT MmcsParam::state

INT MmcsParam::timer

INT MmcsParam::update_status

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:29:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCurrentCallMeterMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCurrentCallMeterMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCurrentCallMeterMsg:

[legend]
Collaboration diagram for MmCurrentCallMeterMsg:

[legend]

Public Types

enum | { ID = 19117 }

Public Member Functions

virtual Message * | Clone () const
ULONG | GetAccumulatedCallCcm () const
const CallIndex & | GetCallIndex () const
ULONG | GetCurrentCallCcm () const
virtual const MsgMetaData & | GetMetaData () const
MmCurrentCallMeterMsg (ExecutionContext *context, const CallIndex &call_index, ULONG current_call_ccm, ULONG accumulated_call_ccm)
virtual | ~MmCurrentCallMeterMsg ()

Detailed Description

Notification about value of current charge and accumulated call meter

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCurrentCallMeterMsg::MmCurrentCallMeterMsg | ( | ExecutionContext * | context,
 |  | const CallIndex & | call_index,
 |  | ULONG | current_call_ccm,
 |  | ULONG | accumulated_call_ccm
 | ) |

MmCurrentCallMeterMsg::~MmCurrentCallMeterMsg ( ) [virtual]

Member Function Documentation

Message * MmCurrentCallMeterMsg::Clone ( ) const [virtual]

Implements Message.

ULONG MmCurrentCallMeterMsg::GetAccumulatedCallCcm ( ) const [inline]

const CallIndex& MmCurrentCallMeterMsg::GetCallIndex ( ) const [inline]

ULONG MmCurrentCallMeterMsg::GetCurrentCallCcm ( ) const [inline]

const MsgMetaData & MmCurrentCallMeterMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmCurrentChargeDataMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmCurrentChargeDataMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmCurrentChargeDataMsg:

[legend]
Collaboration diagram for MmCurrentChargeDataMsg:

[legend]

Public Types

enum | { ID = 19116 }

Public Member Functions

virtual Message * | Clone () const
const AocChargeData & | GetAccumulatedCallCharge () const
const CallIndex & | GetCallIndex () const
const AocChargeData & | GetCurrentCallCharge () const
virtual const MsgMetaData & | GetMetaData () const
MmCurrentChargeDataMsg (ExecutionContext *context, const CallIndex &call_index, const AocChargeData &current_call_charge, const AocChargeData &accumulated_call_charge)
virtual | ~MmCurrentChargeDataMsg ()

Detailed Description

Notification about value of current charge and accumulated charge

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmCurrentChargeDataMsg::MmCurrentChargeDataMsg | ( | ExecutionContext * | context,
 |  | const CallIndex & | call_index,
 |  | const AocChargeData & | current_call_charge,
 |  | const AocChargeData & | accumulated_call_charge
 | ) |

MmCurrentChargeDataMsg::~MmCurrentChargeDataMsg ( ) [virtual]

Member Function Documentation

Message * MmCurrentChargeDataMsg::Clone ( ) const [virtual]

Implements Message.

const AocChargeData& MmCurrentChargeDataMsg::GetAccumulatedCallCharge ( ) const [inline]

const CallIndex& MmCurrentChargeDataMsg::GetCallIndex ( ) const [inline]

const AocChargeData& MmCurrentChargeDataMsg::GetCurrentCallCharge ( ) const [inline]

const MsgMetaData & MmCurrentChargeDataMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmfPlayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmfPlayer Class Reference
[Audio]

#include <Apoxi/Audio/MmfPlayer.hpp>

Inheritance diagram for MmfPlayer:

[legend]
Collaboration diagram for MmfPlayer:

[legend]

Public Member Functions

virtual BOOLEAN | CanPlay (const AudioActiveReference &active_reference) const
virtual BOOLEAN | CanResume (const AudioActiveReference &active_reference) const
virtual BOOLEAN | CanSuspend (const AudioActiveReference &active_reference) const
virtual SharedPtr< AudioReference > | CreateAudioReferenceFromBinData (MimeType mime_type, BinData *bin_data)
virtual SharedPtr< AudioReference > | CreateAudioReferenceFromRamBuffer (MimeType mime_type, ConstBuffer buffer, UINT32 buffer_size)
virtual SharedPtr< AudioReference > | CreateAudioReferenceFromRfsFile (MimeType mime_type, const Path &path)
virtual BOOLEAN | ExecuteFeature (Feature feature, GenericObject *data=0)
virtual UINT16 | GetDeviceID () const
Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).
virtual Vector< MimeTypeSupportInfo > | GetMimeTypeSupportInfo () const
virtual BOOLEAN | GetPlayPosition (AudioActiveReference &active_reference)
virtual AudioSource | GetSource () const
virtual BOOLEAN | GetTotalPlayTime (AudioActiveReference &active_reference)
virtual BOOLEAN | IsFeatureSupported (Feature feature, MimeType mime_type=c_mime_unknown, AudioReference::SoundDataSource sound_data_source=AudioReference::InvalidSoundDataSource) const
BOOLEAN | OnMessage (const Message &message)
virtual void | Play (AudioActiveReference &active_reference)
virtual void | ResumeSuspended (AudioActiveReference &active_reference)
virtual void | Stop (AudioActiveReference &active_reference)
virtual void | StopSuspended (AudioActiveReference &active_reference)
virtual void | Suspend (AudioActiveReference &active_reference)

Static Public Member Functions

static AudioDeviceBase * | GetInstance ()

Protected Member Functions

void | AddDataMapping (MmfPlayer::MediaPlayerInstanceData &instance_data, MediaPlayer *media_player)
virtual BOOLEAN | ApplyDeviceVolume ()
BOOLEAN | FastForward (GenericFeatureData *data)
MmfPlayer::MediaPlayerInstanceData | FindData (MediaPlayer *media_player)
BOOLEAN | GetAudioTrackInfo (GenericFeatureData *data)
BOOLEAN | GetTrackInfo (GenericFeatureData *data)
void | RemoveDataMapping (MediaPlayer *media_player)
BOOLEAN | Rewind (GenericFeatureData *data)

Friends

class | AudioActiveReference

Data Structures

struct | MediaPlayerInstanceData

Member Function Documentation

void MmfPlayer::AddDataMapping | ( | MmfPlayer::MediaPlayerInstanceData & | instance_data,
 |  | MediaPlayer * | media_player
 | ) | [protected]

BOOLEAN MmfPlayer::ApplyDeviceVolume ( ) [protected, virtual]

Reimplemented from AudioDeviceBase.

BOOLEAN MmfPlayer::CanPlay ( const AudioActiveReference & active_reference ) const [virtual]

BOOLEAN MmfPlayer::CanResume ( const AudioActiveReference & active_reference ) const [virtual]

BOOLEAN MmfPlayer::CanSuspend ( const AudioActiveReference & active_reference ) const [virtual]

SharedPtr< AudioReference > MmfPlayer::CreateAudioReferenceFromBinData | ( | MimeType | mime_type,
 |  | BinData * | bin_data
 | ) | [virtual]

SharedPtr< AudioReference > MmfPlayer::CreateAudioReferenceFromRamBuffer | ( | MimeType | mime_type,
 |  | ConstBuffer | buffer,
 |  | UINT32 | buffer_size
 | ) | [virtual]

SharedPtr< AudioReference > MmfPlayer::CreateAudioReferenceFromRfsFile | ( | MimeType | mime_type,
 |  | const Path & | path
 | ) | [virtual]

BOOLEAN MmfPlayer::ExecuteFeature | ( | Feature | feature,
 |  | GenericObject * | data = 0
 | ) | [virtual]

Executes the feature using the supplied data. The device should check whether it is getting the kind of data it expects using the mechanisms of GenericObject. The effects of executing the feature are not specified here, and can be freely specified by the device.

Parameters:
feature | identifies the feature.
data | feature-specific data. The feature implementation and feature clients have to agree on this.
Returns:
TRUE if the request could be made successfully.

Reimplemented from AudioDeviceBase.

BOOLEAN MmfPlayer::FastForward ( GenericFeatureData * data ) [protected]

MmfPlayer::MediaPlayerInstanceData MmfPlayer::FindData ( MediaPlayer * media_player ) [protected]

BOOLEAN MmfPlayer::GetAudioTrackInfo ( GenericFeatureData * data ) [protected]

virtual UINT16 MmfPlayer::GetDeviceID ( ) const [inline, virtual]

Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).

Implements AudioDeviceBase.

AudioDeviceBase * MmfPlayer::GetInstance ( ) [static]

Vector< AudioPlayer::MimeTypeSupportInfo > MmfPlayer::GetMimeTypeSupportInfo ( ) const [virtual]

BOOLEAN MmfPlayer::GetPlayPosition ( AudioActiveReference & active_reference ) [virtual]

virtual AudioSource MmfPlayer::GetSource ( ) const [inline, virtual]

BOOLEAN MmfPlayer::GetTotalPlayTime ( AudioActiveReference & active_reference ) [virtual]

BOOLEAN MmfPlayer::GetTrackInfo ( GenericFeatureData * data ) [protected]

BOOLEAN MmfPlayer::IsFeatureSupported | ( | Feature | feature,
 |  | MimeType | mime_type = c_mime_unknown,
 |  | AudioReference::SoundDataSource | sound_data_source = AudioReference::InvalidSoundDataSource
 | ) | const [virtual]

Queries the device whether it supports the feature.

Parameters:
feature | identifies the feature.
mime_type | the mime type for which support is queried. The default means the feature has to be supported for all mime types.
sound_data_source | the SoundDataSource for which support is queried. The default means the feature has to be supported for all SoundDataSources.
Returns:
TRUE if the feature is supported for the supplied mime type and SoundDataSource.

Reimplemented from AudioDeviceBase.

BOOLEAN MmfPlayer::OnMessage ( const Message & message )

void MmfPlayer::Play ( AudioActiveReference & active_reference ) [virtual]

void MmfPlayer::RemoveDataMapping ( MediaPlayer * media_player ) [protected]

void MmfPlayer::ResumeSuspended ( AudioActiveReference & active_reference ) [virtual]

BOOLEAN MmfPlayer::Rewind ( GenericFeatureData * data ) [protected]

void MmfPlayer::Stop ( AudioActiveReference & active_reference ) [virtual]

void MmfPlayer::StopSuspended ( AudioActiveReference & active_reference ) [virtual]

void MmfPlayer::Suspend ( AudioActiveReference & active_reference ) [virtual]

Friends And Related Function Documentation

friend class AudioActiveReference [friend]

The documentation for this class was generated from the following files:
  • Audio/MmfPlayer.hpp
  • Audio/MmfPlayer.cpp
Generated on Wed Jan 25 01:29:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmfPlayer::MediaPlayerInstanceData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MmfPlayer::MediaPlayerInstanceData

MmfPlayer::MediaPlayerInstanceData Struct Reference

#include <Apoxi/Audio/MmfPlayer.hpp>

Collaboration diagram for MmfPlayer::MediaPlayerInstanceData:

[legend]

Data Fields

MediaInfo * info
AudioActiveReference * m_active_ref
BinData * m_bin_data
BOOLEAN m_bin_data_provided
MediaPlayer * m_media_player

Field Documentation

MediaInfo* MmfPlayer::MediaPlayerInstanceData::info

AudioActiveReference* MmfPlayer::MediaPlayerInstanceData::m_active_ref

BinData* MmfPlayer::MediaPlayerInstanceData::m_bin_data

BOOLEAN MmfPlayer::MediaPlayerInstanceData::m_bin_data_provided

MediaPlayer* MmfPlayer::MediaPlayerInstanceData::m_media_player

The documentation for this struct was generated from the following file:
  • Audio/MmfPlayer.hpp
Generated on Wed Jan 25 01:29:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmiSimClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmiSimClient Class Reference

#include <Apoxi/Devices/Win32/MmiSimClient.hpp>

Collaboration diagram for MmiSimClient:

[legend]

Public Member Functions

void | Connect ()
void | Disconnect ()
void | SetBacklightState (BOOLEAN state, UINT8 display_idx=0)
void | SetLedState (BOOLEAN state, UINT32 color)
void | SetVibrationState (BOOLEAN state)
void | UpdateDisplay (const Bitmap &bitmap, const Rect &blit_rect, int display_idx)
virtual | ~MmiSimClient ()

Static Public Member Functions

static MmiSimClient * | GetClient ()

Constructor & Destructor Documentation

MmiSimClient::~MmiSimClient ( ) [virtual]

Member Function Documentation

void MmiSimClient::Connect ( )

void MmiSimClient::Disconnect ( )

MmiSimClient * MmiSimClient::GetClient ( ) [static]

void MmiSimClient::SetBacklightState | ( | BOOLEAN | state,
 |  | UINT8 | display_idx = 0
 | ) |

void MmiSimClient::SetLedState | ( | BOOLEAN | state,
 |  | UINT32 | color
 | ) |

void MmiSimClient::SetVibrationState ( BOOLEAN state )

void MmiSimClient::UpdateDisplay | ( | const Bitmap & | bitmap,
 |  | const Rect & | blit_rect,
 |  | int | display_idx
 | ) |

The documentation for this class was generated from the following files:
  • Devices/Win32/MmiSimClient.hpp
  • Devices/Win32/MmiSimClient.cpp
Generated on Wed Jan 25 01:29:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmiSimMsg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmiSimMsg Struct Reference

MmiSimMsg consist of a unique id and four MmiSimMsgArgs. More...

#include <Apoxi/Devices/Win32/MmiSimProtocol.hpp>

Collaboration diagram for MmiSimMsg:

[legend]

Data Fields

MmiSimMsgArg | args [4]
short | id

Detailed Description

MmiSimMsg consist of a unique id and four MmiSimMsgArgs.

Field Documentation

MmiSimMsgArg MmiSimMsg::args[4]

short MmiSimMsg::id

The documentation for this struct was generated from the following file:
  • Devices/Win32/MmiSimProtocol.hpp
Generated on Wed Jan 25 01:29:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmiSimMsgArg Union Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmiSimMsgArg Union Reference

MmiSimMsgArg contains a generic MmiSimMsg argument. More...

#include <Apoxi/Devices/Win32/MmiSimProtocol.hpp>

Data Fields

unsigned char | t_byte [4]
char | t_char [4]
int | t_int
short | t_int16 [2]
int | t_int32
char | t_int8 [4]
unsigned char | t_uchar [4]
unsigned short | t_uint [2]
unsigned int | t_uint32
void * | t_void
unsigned short | t_wchar [2]
short | t_xydim [2]

Detailed Description

MmiSimMsgArg contains a generic MmiSimMsg argument.

Field Documentation

unsigned char MmiSimMsgArg::t_byte[4]

char MmiSimMsgArg::t_char[4]

int MmiSimMsgArg::t_int

short MmiSimMsgArg::t_int16[2]

int MmiSimMsgArg::t_int32

char MmiSimMsgArg::t_int8[4]

unsigned char MmiSimMsgArg::t_uchar[4]

unsigned short MmiSimMsgArg::t_uint[2]

unsigned int MmiSimMsgArg::t_uint32

void* MmiSimMsgArg::t_void

unsigned short MmiSimMsgArg::t_wchar[2]

short MmiSimMsgArg::t_xydim[2]

The documentation for this union was generated from the following file:
  • Devices/Win32/MmiSimProtocol.hpp
Generated on Wed Jan 25 01:29:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmiSimServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmiSimServer Class Reference

#include <Apoxi/Devices/Win32/MmiSimServer.hpp>

Public Types

enum | { ID = 0 }
enum MmiSimCmdId {
MmiSimDisplayUpdateHeaderId = 1, MmiSimDisplayUpdateDataId = 2, MmiSimBacklightStateId = 10, MmiSimVibrationStateId = 11,
MmiSimLedStateId = 12, MmiSimPowerStateId = 13, MmiSimClipStateId = 14, MmiSimKeyDownId = 200,
MmiSimKeyUpId = 201, MmiSimCharId = 220, MmiSimPenDownId = 250, MmiSimPenUpId = 251,
MmiSimPenMoveId = 252
}

Public Member Functions

void | SetBacklightState (BOOLEAN state, INT backlight_idx=0)
void | SetClipState (BOOLEAN state)
void | SetLedState (BOOLEAN state, UINT32 color, INT led_idx=0)
void | SetPowerState (BOOLEAN state, INT display_idx)
void | SetVibrationState (BOOLEAN state)
void | UpdateDisplay (const Rect &blit_rect, INT display_idx)

Static Public Member Functions

static GatiServer * | CreateInstance ()
static MmiSimServer & | GetInstance ()

Friends

class | ClientHandler

Detailed Description

Implements a GATI server for the MMI Simulator.

Member Enumeration Documentation

anonymous enum

Unique ID of this GatiServer

Enumerator:
ID

enum MmiSimServer::MmiSimCmdId

All MmiSim commands used for communication with the connected clients

Enumerator:
MmiSimDisplayUpdateHeaderId
MmiSimDisplayUpdateDataId
MmiSimBacklightStateId
MmiSimVibrationStateId
MmiSimLedStateId
MmiSimPowerStateId
MmiSimClipStateId
MmiSimKeyDownId
MmiSimKeyUpId
MmiSimCharId
MmiSimPenDownId
MmiSimPenUpId
MmiSimPenMoveId

Member Function Documentation

GatiServer * MmiSimServer::CreateInstance ( ) [static]

Returns a new instance of internal handler class, which implements the GatiServer interface.

Returns:
a pointer to a new GatiServer handler instance.

MmiSimServer & MmiSimServer::GetInstance ( ) [static]

Returns the singleton instance of the class MmiSimServer.

Returns:
a reference to singleton MmiSimServer instance.

void MmiSimServer::SetBacklightState | ( | BOOLEAN | state,
 |  | INT | backlight_idx = 0
 | ) |

This method has to be called every time the backlight state has changed in order to send all connected clients the new backlight state.

Parameters:
state[in] | : the state of the backlight
state[in] | : the index of the backlight changed

void MmiSimServer::SetClipState ( BOOLEAN state )

This method has to be called every time the clip/flap state has changed in order to send all connected clients the new clip/flap state.

Parameters:
state[in] : the state of the clip/flap

void MmiSimServer::SetLedState | ( | BOOLEAN | state,
 |  | UINT32 | color,
 |  | INT | led_idx = 0
 | ) |

This method has to be called every time the led state has changed in order to send all connected clients the new led state and color.

Parameters:
state[in] | : the state of the led
state[in] | : the color of the led
state[in] | : the index of the led changed

void MmiSimServer::SetPowerState | ( | BOOLEAN | state,
 |  | INT | display_idx
 | ) |

This method has to be called every time the power state of a display has changed in order to send all connected clients the new power state.

Parameters:
state[in] | : the display power state
display_idx[in] | : the system index of the affected display

void MmiSimServer::SetVibrationState ( BOOLEAN state )

This method has to be called every time the vibration state has changed in order to send all connected clients the new vibration state.

Parameters:
state[in] : the state of the vibrator

void MmiSimServer::UpdateDisplay | ( | const Rect & | blit_rect,
 |  | INT | display_idx
 | ) |

This method has to be called every time a display has been updated in order to send all connected clients the display change.

Parameters:
blit_rect[in] | : the bounding rectangle which was updated on the display
display_idx[in] | : the system index of the display which was updated

Friends And Related Function Documentation

friend class ClientHandler [friend]

The documentation for this class was generated from the following files:
  • Devices/Win32/MmiSimServer.hpp
  • Devices/Win32/MmiSimServer.cpp
Generated on Wed Jan 25 01:29:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MmMocSetupAcceptMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MmMocSetupAcceptMsg Class Reference

#include <Apoxi/AddOns/MmCall/MmCallMessages.hpp>

Inheritance diagram for MmMocSetupAcceptMsg:

[legend]
Collaboration diagram for MmMocSetupAcceptMsg:

[legend]

Public Types

enum | { ID = 19112 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsEstCauseChanged () const
MmMocSetupAcceptMsg (ExecutionContext *context, const MmCallState &state, const CallIndex &call_index, BOOLEAN est_cause_changed)
virtual | ~MmMocSetupAcceptMsg ()

Detailed Description

Message indicating that setting up an MOC is allowed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MmMocSetupAcceptMsg::MmMocSetupAcceptMsg | ( | ExecutionContext * | context,
 |  | const MmCallState & | state,
 |  | const CallIndex & | call_index,
 |  | BOOLEAN | est_cause_changed
 | ) |

MmMocSetupAcceptMsg::~MmMocSetupAcceptMsg ( ) [virtual]

Member Function Documentation

Message * MmMocSetupAcceptMsg::Clone ( ) const [virtual]

Reimplemented from MmCallStatusMsg.

const MsgMetaData & MmMocSetupAcceptMsg::GetMetaData ( ) const [virtual]

Reimplemented from MmCallStatusMsg.

BOOLEAN MmMocSetupAcceptMsg::IsEstCauseChanged ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/MmCall/MmCallMessages.hpp
  • AddOns/MmCall/MmCallMessages.cpp
Generated on Wed Jan 25 01:29:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MnInformationIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MnInformationIndArg Class Reference

#include <Apoxi/Apc/NetworkStackMsgArgs.hpp>

Inheritance diagram for MnInformationIndArg:

[legend]
Collaboration diagram for MnInformationIndArg:

[legend]

Public Types

enum | { ID = 2182 }

Public Member Functions

const DateTime & | GetDateTime () const
UINT8 | GetDaylightSavingTime () const
const GsmService & | GetGsmService () const
const LsaIdentifier & | GetLsaIdentifier () const
const WString & | GetNetworkNameLong () const
const WString & | GetNetworkNameShort () const
INT | GetTimeZone () const
BOOLEAN | IsDateTimePresent () const
BOOLEAN | IsDaylightSavingTimePresent () const
BOOLEAN | IsLsaIdentifierPresent () const
BOOLEAN | IsNetworkNameLongAddCi () const
BOOLEAN | IsNetworkNameShortAddCi () const
BOOLEAN | IsTimeZonePresent () const
MnInformationIndArg ()
void | SetDateTime (const DateTime &date_time)
void | SetDateTimePresent (BOOLEAN date_time_present)
void | SetDaylightSavingTime (UINT8 daylight_saving_time)
void | SetDaylightSavingTimePresent (BOOLEAN daylight_saving_time_present)
void | SetGsmService (const GsmService &gsm_service)
void | SetLsaIdentifier (const LsaIdentifier &lsa_identifier)
void | SetLsaIdentifierPresent (BOOLEAN lsa_identifier_present)
void | SetNetworkNameLong (const WString &network_name_long)
void | SetNetworkNameLongAddCi (BOOLEAN network_name_long_add_ci)
void | SetNetworkNameShort (const WString &network_name_short)
void | SetNetworkNameShortAddCi (BOOLEAN network_name_short_add_ci)
void | SetTimeZone (INT time_zone)
void | SetTimeZonePresent (BOOLEAN time_zone_present)

Static Public Member Functions

static const MnInformationIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MnInformationIndArg: reflects arguments of signal MN_INFORMATION_IND Network-Identifier and Time-Zone (NITZ) defined in ETSI TS 122 042

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MnInformationIndArg::MnInformationIndArg ( )

Member Function Documentation

const MnInformationIndArg & MnInformationIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const DateTime& MnInformationIndArg::GetDateTime ( ) const [inline]

UINT8 MnInformationIndArg::GetDaylightSavingTime ( ) const [inline]

const GsmService& MnInformationIndArg::GetGsmService ( ) const [inline]

const LsaIdentifier& MnInformationIndArg::GetLsaIdentifier ( ) const [inline]

const WString& MnInformationIndArg::GetNetworkNameLong ( ) const [inline]

const WString& MnInformationIndArg::GetNetworkNameShort ( ) const [inline]

INT MnInformationIndArg::GetTimeZone ( ) const [inline]

BOOLEAN MnInformationIndArg::IsDateTimePresent ( ) const [inline]

BOOLEAN MnInformationIndArg::IsDaylightSavingTimePresent ( ) const [inline]

BOOLEAN MnInformationIndArg::IsLsaIdentifierPresent ( ) const [inline]

BOOLEAN MnInformationIndArg::IsNetworkNameLongAddCi ( ) const [inline]

BOOLEAN MnInformationIndArg::IsNetworkNameShortAddCi ( ) const [inline]

BOOLEAN MnInformationIndArg::IsTimeZonePresent ( ) const [inline]

void MnInformationIndArg::SetDateTime ( const DateTime & date_time ) [inline]

void MnInformationIndArg::SetDateTimePresent ( BOOLEAN date_time_present ) [inline]

void MnInformationIndArg::SetDaylightSavingTime ( UINT8 daylight_saving_time ) [inline]

void MnInformationIndArg::SetDaylightSavingTimePresent ( BOOLEAN daylight_saving_time_present ) [inline]

void MnInformationIndArg::SetGsmService ( const GsmService & gsm_service ) [inline]

void MnInformationIndArg::SetLsaIdentifier ( const LsaIdentifier & lsa_identifier ) [inline]

void MnInformationIndArg::SetLsaIdentifierPresent ( BOOLEAN lsa_identifier_present ) [inline]

void MnInformationIndArg::SetNetworkNameLong ( const WString & network_name_long ) [inline]

void MnInformationIndArg::SetNetworkNameLongAddCi ( BOOLEAN network_name_long_add_ci ) [inline]

void MnInformationIndArg::SetNetworkNameShort ( const WString & network_name_short ) [inline]

void MnInformationIndArg::SetNetworkNameShortAddCi ( BOOLEAN network_name_short_add_ci ) [inline]

void MnInformationIndArg::SetTimeZone ( INT time_zone ) [inline]

void MnInformationIndArg::SetTimeZonePresent ( BOOLEAN time_zone_present ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/NetworkStackMsgArgs.hpp
  • Apc/NetworkStackMsgArgs.cpp
Generated on Wed Jan 25 01:29:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MnNetworkSearchModeReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MnNetworkSearchModeReqArg Class Reference

#include <Apoxi/Apc/NetworkStackMsgArgs.hpp>

Inheritance diagram for MnNetworkSearchModeReqArg:

[legend]
Collaboration diagram for MnNetworkSearchModeReqArg:

[legend]

Public Types

enum | { ID = 2187 }

Public Member Functions

const NetworkSearchMode & | GetNetworkSearchMode () const
MnNetworkSearchModeReqArg ()
MnNetworkSearchModeReqArg (const NetworkSearchMode &network_search_mode)

Static Public Member Functions

static const MnNetworkSearchModeReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

NetworkSearchModeReqArg: reflects arguments of signal MN_NETWORK_SEARCH_MODE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MnNetworkSearchModeReqArg::MnNetworkSearchModeReqArg ( const NetworkSearchMode & network_search_mode )

MnNetworkSearchModeReqArg::MnNetworkSearchModeReqArg ( )

Member Function Documentation

const MnNetworkSearchModeReqArg & MnNetworkSearchModeReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const NetworkSearchMode& MnNetworkSearchModeReqArg::GetNetworkSearchMode ( ) const [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/NetworkStackMsgArgs.hpp
  • Apc/NetworkStackMsgArgs.cpp
Generated on Wed Jan 25 01:29:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MnTriggerReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MnTriggerReqArg Class Reference

#include <Apoxi/Apc/NetworkStackMsgArgs.hpp>

Inheritance diagram for MnTriggerReqArg:

[legend]
Collaboration diagram for MnTriggerReqArg:

[legend]

Public Types

enum | { ID = 2186 }

Public Member Functions

BOOLEAN | IsFlipOpen () const
MnTriggerReqArg ()
MnTriggerReqArg (BOOLEAN flip_open)

Static Public Member Functions

static const MnTriggerReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MnTriggerReqArg: reflects arguments of signal MN_TRIGGER_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MnTriggerReqArg::MnTriggerReqArg ( BOOLEAN flip_open )

MnTriggerReqArg::MnTriggerReqArg ( )

Member Function Documentation

const MnTriggerReqArg & MnTriggerReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN MnTriggerReqArg::IsFlipOpen ( ) const [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/NetworkStackMsgArgs.hpp
  • Apc/NetworkStackMsgArgs.cpp
Generated on Wed Jan 25 01:29:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MobileOriginatedUssdHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MobileOriginatedUssdHandler Class Reference

#include <Apoxi/Asc/MobileOriginatedUssdHandler.hpp>

Inheritance diagram for MobileOriginatedUssdHandler:

[legend]
Collaboration diagram for MobileOriginatedUssdHandler:

[legend]

Public Types

enum | { ID = MoUssdHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
MobileOriginatedUssdHandler ()
virtual SsBaseHandler::ReturnCode | ProcessStackMsgArgument (const SsStackMsgArgument &arg)
virtual void | RegisterTransaction (Tipd tipd)
SsApiRc | SendUssdRequest (const WString &ss_ctrl_sequence, const DataCodingScheme &dcs, BOOLEAN register_only=FALSE)
SsApiRc | TerminateUssdTransaction (Tipd tipd)
virtual | ~MobileOriginatedUssdHandler ()

Detailed Description

The MobileOriginatedUssdHandler is a SS handler responsible for handling and conducting mobile-originated USSD transactions.
The class provides methods to initiate UUSD transaction, parse the data provided by the mobile network and forward that data as messages.
After the transaction has started the mobile network might reply with UUSD notifies and replies as well. The superclass's methods can be used to react to such messages.
See also:
SsMainHandler

SsDispatcher

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Reimplemented from UssdHandler.

Constructor & Destructor Documentation

MobileOriginatedUssdHandler::MobileOriginatedUssdHandler ( )

MobileOriginatedUssdHandler::~MobileOriginatedUssdHandler ( ) [virtual]

Member Function Documentation

HandlerId MobileOriginatedUssdHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
MoUssdHandlerId

Reimplemented from UssdHandler.

SsBaseHandler::ReturnCode MobileOriginatedUssdHandler::ProcessStackMsgArgument ( const SsStackMsgArgument & arg ) [virtual]

This method is called by the SsDispatcher upon receiving a StackMsgArgument. The method checks whether the given argument is processable in any way (contains correct data), creates a new message object using the appropriate Create*Msg methods and stores the message by means of its superclass.

Parameters:
arg The wrapper object which should contain either a SsUnstructIndArg or a SsUssdResentIndArg to be processed.
Returns:
OkMessageReady - if a message was created,
TipdMismatch - if the tipd of the argument does not match the tipd of the current transaction,
OperationCodeMismatch - if the argument's operation code does not match the expected operation code associated with the initial request,
UnexpectedArgument - if the argument is not either a SsUnstructIndArg or a SsUssdResentIndArg,
or any other code the Create*Msg methods might return.
See also:
SsBaseHandler

SsDispatcher

Reimplemented from UssdHandler.

void MobileOriginatedUssdHandler::RegisterTransaction ( Tipd tipd ) [virtual]

Overloaded method of SsBaseHandler::RegisterTransaction to add sending of a UssdRequestResentMsg when a transaction is registered after Ussd resent.

Parameters:
tipd The tipd of the transaction after Ussd resent.

SsApiRc MobileOriginatedUssdHandler::SendUssdRequest | ( | const WString & | ss_ctrl_sequence,
 |  | const DataCodingScheme & | dcs,
 |  | BOOLEAN | register_only = FALSE
 | ) |

Sends a new UUSD request to the mobile network.
This method sends a new UUSD request to the mobile network using the main handler.
If there is no transaction currently active a new transaction will be established. Otherwise the request will be sent as part of the current transaction.

Parameters:
ss_ctrl_sequence | The control sequence containing the request and its data.
dcs | The data coding scheme for the request.
register_only | A flag that indicates if the request is sent to the GSM stack or only registered at SsMainHandler.
Returns:
Any value SsMainHandler::EndTransaction might return, or any other value SsMainHandler::PostArgument might return.

SsApiRc MobileOriginatedUssdHandler::TerminateUssdTransaction ( Tipd tipd )

Terminates the given transaction.
The given transaction (which is the current one since multiple concurrent transactions are not supported) is terminated using the main handler. All stored parameters are reset during the process.

Parameters:
tipd The tipd of the current transaction (not used).
Returns:
Any value SsMainHandler::EndTransaction might return.
See also:
SsMainHandler

The documentation for this class was generated from the following files:
  • Asc/MobileOriginatedUssdHandler.hpp
  • Asc/MobileOriginatedUssdHandler.cpp
Generated on Wed Jan 25 01:29:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MocAlertIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MocAlertIndArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for MocAlertIndArg:

[legend]
Collaboration diagram for MocAlertIndArg:

[legend]

Public Types

enum | { ID = 1142 }

Public Member Functions

const Tipd & | GetTipd () const
MocAlertIndArg ()
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MocAlertIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MocAlertIndArg: reflects arguments of signal MN_ALERT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MocAlertIndArg::MocAlertIndArg ( )

Member Function Documentation

const MocAlertIndArg & MocAlertIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& MocAlertIndArg::GetTipd ( ) const [inline]

void MocAlertIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:29:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MoCallAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MoCallAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for MoCallAction:

[legend]
Collaboration diagram for MoCallAction:

[legend]

Public Types

enum | Type { Default, DisplayPhoneNumber, SurpressPhoneNumber }

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
MoCallAction::Type | GetMocType () const
Returns the type of the MOC.
const PhoneNumber & | GetPhoneNumber () const
Returns the valid phonenumber object which can be used for call setup.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
MoCallAction (const PhoneNumber &phnr)
MoCallAction ()
virtual | ~MoCallAction ()

Detailed Description

MoCallAction analyzes if the input string has the meaning of a valid mobile originated call (a valid phonenumber). Execute has to be overwritten to implement the call setup

Member Enumeration Documentation

enum MoCallAction::Type

Enumerator:
Default
DisplayPhoneNumber
SurpressPhoneNumber

Constructor & Destructor Documentation

MoCallAction::MoCallAction ( )

MoCallAction::MoCallAction ( const PhoneNumber & phnr ) [explicit]

MoCallAction::~MoCallAction ( ) [virtual]

Member Function Documentation

InputAction * MoCallAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType MoCallAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

MoCallAction::Type MoCallAction::GetMocType ( ) const [inline]

Returns the type of the MOC.

const PhoneNumber& MoCallAction::GetPhoneNumber ( ) const [inline]

Returns the valid phonenumber object which can be used for call setup.

BOOLEAN MoCallAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:29:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MocSetupAccArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MocSetupAccArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for MocSetupAccArg:

[legend]
Collaboration diagram for MocSetupAccArg:

[legend]

Public Types

enum | { ID = 1141 }

Public Member Functions

const EccCategory & | GetEccCategory () const
const CallEstCause & | GetEstCause () const
const Tipd & | GetTipd () const
MocSetupAccArg ()
void | SetEccCategory (const EccCategory &ecc_category)
void | SetEstCause (const CallEstCause &est_cause)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MocSetupAccArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MocSetupAccArg: reflects arguments of signal MN_SETUP_ACC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MocSetupAccArg::MocSetupAccArg ( )

Member Function Documentation

const MocSetupAccArg & MocSetupAccArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const EccCategory& MocSetupAccArg::GetEccCategory ( ) const [inline]

const CallEstCause& MocSetupAccArg::GetEstCause ( ) const [inline]

const Tipd& MocSetupAccArg::GetTipd ( ) const [inline]

void MocSetupAccArg::SetEccCategory ( const EccCategory & ecc_category ) [inline]

void MocSetupAccArg::SetEstCause ( const CallEstCause & est_cause ) [inline]

void MocSetupAccArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:29:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MocSetupAcceptMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MocSetupAcceptMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MocSetupAcceptMsg:

[legend]
Collaboration diagram for MocSetupAcceptMsg:

[legend]

Public Types

enum | { ID = 18400 }

Public Member Functions

virtual Message * | Clone () const
const CallHdl & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsEstCauseChanged () const
MocSetupAcceptMsg (ExecutionContext *context, const CallHdl &arg, BOOLEAN est_cause_changed=FALSE)
void | SetArg (const CallHdl &arg)
void | SetEstCauseChanged (BOOLEAN est_cause_changed)
virtual | ~MocSetupAcceptMsg ()

Detailed Description

MocSetupAcceptMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MocSetupAcceptMsg::MocSetupAcceptMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | arg,
 |  | BOOLEAN | est_cause_changed = FALSE
 | ) |

MocSetupAcceptMsg::~MocSetupAcceptMsg ( ) [virtual]

Member Function Documentation

Message * MocSetupAcceptMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& MocSetupAcceptMsg::GetArg ( ) const [inline]

const MsgMetaData & MocSetupAcceptMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BOOLEAN MocSetupAcceptMsg::IsEstCauseChanged ( ) const [inline]

void MocSetupAcceptMsg::SetArg ( const CallHdl & arg ) [inline]

void MocSetupAcceptMsg::SetEstCauseChanged ( BOOLEAN est_cause_changed ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:29:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MocSetupCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MocSetupCnfArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for MocSetupCnfArg:

[legend]
Collaboration diagram for MocSetupCnfArg:

[legend]

Public Types

enum | { ID = 1143 }

Public Member Functions

const PhoneNumber & | GetConnectedNo () const
const CallRelatedSsCode & | GetCrssCode () const
const Tipd & | GetTipd () const
MocSetupCnfArg ()
void | SetConnectedNo (const PhoneNumber &connected_no)
void | SetCrssCode (const CallRelatedSsCode &crss_code)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MocSetupCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MocSetupCnfArg: reflects arguments of signal MN_SETUP_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MocSetupCnfArg::MocSetupCnfArg ( )

Member Function Documentation

const MocSetupCnfArg & MocSetupCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PhoneNumber& MocSetupCnfArg::GetConnectedNo ( ) const [inline]

const CallRelatedSsCode& MocSetupCnfArg::GetCrssCode ( ) const [inline]

const Tipd& MocSetupCnfArg::GetTipd ( ) const [inline]

void MocSetupCnfArg::SetConnectedNo ( const PhoneNumber & connected_no ) [inline]

void MocSetupCnfArg::SetCrssCode ( const CallRelatedSsCode & crss_code ) [inline]

void MocSetupCnfArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:29:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MocSetupRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MocSetupRejArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for MocSetupRejArg:

[legend]
Collaboration diagram for MocSetupRejArg:

[legend]

Public Types

enum | { ID = 1140 }

Public Member Functions

const CallErrorCause & | GetRejectCause () const
MocSetupRejArg ()
void | SetRejectCause (const CallErrorCause &reject_cause)

Static Public Member Functions

static const MocSetupRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MocSetupRejArg: reflects arguments of signal MN_SETUP_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MocSetupRejArg::MocSetupRejArg ( )

Member Function Documentation

const MocSetupRejArg & MocSetupRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& MocSetupRejArg::GetRejectCause ( ) const [inline]

void MocSetupRejArg::SetRejectCause ( const CallErrorCause & reject_cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:29:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MocSetupRejectIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MocSetupRejectIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MocSetupRejectIndMsg:

[legend]
Collaboration diagram for MocSetupRejectIndMsg:

[legend]

Public Types

enum | { ID = 18425 }

Public Member Functions

virtual Message * | Clone () const
const CallErrorCause & | GetCause () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetPhoneNumber () const
MocSetupRejectIndMsg (ExecutionContext *context, const PhoneNumber &phone_number, const CallErrorCause &cause)
virtual | ~MocSetupRejectIndMsg ()

Detailed Description

MocSetupRejectIndMsg: sent when MN_SETUP_REJ_IND is received from stack

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MocSetupRejectIndMsg::MocSetupRejectIndMsg | ( | ExecutionContext * | context,
 |  | const PhoneNumber & | phone_number,
 |  | const CallErrorCause & | cause
 | ) |

MocSetupRejectIndMsg::~MocSetupRejectIndMsg ( ) [virtual]

Member Function Documentation

Message * MocSetupRejectIndMsg::Clone ( ) const [virtual]

Implements Message.

const CallErrorCause& MocSetupRejectIndMsg::GetCause ( ) const [inline]

const MsgMetaData & MocSetupRejectIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& MocSetupRejectIndMsg::GetPhoneNumber ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:29:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MocSetupRejIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MocSetupRejIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for MocSetupRejIndArg:

[legend]
Collaboration diagram for MocSetupRejIndArg:

[legend]

Public Types

enum | { ID = 1137 }

Public Member Functions

const CallErrorCause & | GetCause () const
const PhoneNumber & | GetPhoneNumber () const
MocSetupRejIndArg ()
void | SetCause (const CallErrorCause &cause)
void | SetPhoneNumber (const PhoneNumber &phone_number)

Static Public Member Functions

static const MocSetupRejIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MocSetupRejIndArg:

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MocSetupRejIndArg::MocSetupRejIndArg ( )

Member Function Documentation

const MocSetupRejIndArg & MocSetupRejIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& MocSetupRejIndArg::GetCause ( ) const [inline]

const PhoneNumber& MocSetupRejIndArg::GetPhoneNumber ( ) const [inline]

void MocSetupRejIndArg::SetCause ( const CallErrorCause & cause ) [inline]

void MocSetupRejIndArg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MocSetupReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MocSetupReqArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for MocSetupReqArg:

[legend]
Collaboration diagram for MocSetupReqArg:

[legend]

Public Types

enum | { ID = 2140 }

Public Member Functions

const CallEstCause & | GetCallEstCause () const
const LineSelector & | GetCallLine () const
const ClirMode & | GetClirMode () const
const CugDescriptor & | GetCug () const
const EccCategory & | GetEccCategory () const
const PhoneNumber & | GetPhoneNo () const
BOOLEAN | IsAutoCallSetup () const
BOOLEAN | IsCtm () const
MocSetupReqArg ()
MocSetupReqArg (const CallEstCause &call_est_cause, const PhoneNumber &phone_no, const ClirMode &clir_mode, const CugDescriptor &cug, BOOLEAN auto_call_setup, const LineSelector &call_line, BOOLEAN ctm, const EccCategory &ecc_category)
void | SetAutoCallSetup (BOOLEAN auto_call_setup)
void | SetCallEstCause (const CallEstCause &call_est_cause)
void | SetCallLine (const LineSelector &call_line)
void | SetClirMode (const ClirMode &clir_mode)
void | SetCtm (BOOLEAN ctm)
void | SetCug (const CugDescriptor &cug)
void | SetEccCategory (const EccCategory &ecc_category)
void | SetPhoneNo (const PhoneNumber &phone_no)

Static Public Member Functions

static const MocSetupReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MocSetupReqArg: reflects arguments of signal MN_SETUP_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MocSetupReqArg::MocSetupReqArg | ( | const CallEstCause & | call_est_cause,
 |  | const PhoneNumber & | phone_no,
 |  | const ClirMode & | clir_mode,
 |  | const CugDescriptor & | cug,
 |  | BOOLEAN | auto_call_setup,
 |  | const LineSelector & | call_line,
 |  | BOOLEAN | ctm,
 |  | const EccCategory & | ecc_category
 | ) |

MocSetupReqArg::MocSetupReqArg ( )

Member Function Documentation

const MocSetupReqArg & MocSetupReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallEstCause& MocSetupReqArg::GetCallEstCause ( ) const [inline]

const LineSelector& MocSetupReqArg::GetCallLine ( ) const [inline]

const ClirMode& MocSetupReqArg::GetClirMode ( ) const [inline]

const CugDescriptor& MocSetupReqArg::GetCug ( ) const [inline]

const EccCategory& MocSetupReqArg::GetEccCategory ( ) const [inline]

const PhoneNumber& MocSetupReqArg::GetPhoneNo ( ) const [inline]

BOOLEAN MocSetupReqArg::IsAutoCallSetup ( ) const [inline]

BOOLEAN MocSetupReqArg::IsCtm ( ) const [inline]

void MocSetupReqArg::SetAutoCallSetup ( BOOLEAN auto_call_setup ) [inline]

void MocSetupReqArg::SetCallEstCause ( const CallEstCause & call_est_cause ) [inline]

void MocSetupReqArg::SetCallLine ( const LineSelector & call_line ) [inline]

void MocSetupReqArg::SetClirMode ( const ClirMode & clir_mode ) [inline]

void MocSetupReqArg::SetCtm ( BOOLEAN ctm ) [inline]

void MocSetupReqArg::SetCug ( const CugDescriptor & cug ) [inline]

void MocSetupReqArg::SetEccCategory ( const EccCategory & ecc_category ) [inline]

void MocSetupReqArg::SetPhoneNo ( const PhoneNumber & phone_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Model Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Model Class Reference
[GUI]

#include <Apoxi/Gui/Model.hpp>

Inheritance diagram for Model:

[legend]
Collaboration diagram for Model:

[legend]

Public Member Functions

void | Init ()
Model ()
virtual | ~Model ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)

Detailed Description

Abstract class, which describes the data of a component. Every component may have a model, but it is not a requirement. Messages which are not dispatched by the component are forwarded to the model.

Constructor & Destructor Documentation

Model::Model ( )

Model::~Model ( ) [virtual]

Member Function Documentation

void Model::Init ( )

BOOLEAN Model::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Implements Dispatcher.

The documentation for this class was generated from the following files:
  • Gui/Model.hpp
  • Gui/Model.cpp
Generated on Wed Jan 25 01:30:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MolrInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MolrInfo Struct Reference

#include <Apoxi/AddOns/Lcs/Common/LcsDecls.hpp>

Inheritance diagram for MolrInfo:

[legend]
Collaboration diagram for MolrInfo:

[legend]

Public Member Functions

MolrInfo (MolrType molr_type, LocationMethod location_method, const LcsQos &lcs_qos, const ClientId &client_id, const MlcNumber &mlc_number, INT32 repeat_interval, const Application *app, const LcsProviderImplBase *provider)
Argument Constructor.
virtual | ~MolrInfo ()
Destructor.

Data Fields

Application * m_app
Timeout duration.
ClientId m_client_id
LcsQos m_lcs_qos
LocationMethod m_location_method
MlcNumber m_mlc_number
MolrType m_molr_type
Attributes.
LcsProviderImplBase * m_provider
INT32 | m_repeat_interval

Detailed Description

This stores the state information for a MO-LR that either needs response from the network or is yet to be sent to the network

Constructor & Destructor Documentation

MolrInfo::MolrInfo | ( | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsQos & | lcs_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number,
 |  | INT32 | repeat_interval,
 |  | const Application * | app,
 |  | const LcsProviderImplBase * | provider
 | ) | [inline]

Argument Constructor.

virtual MolrInfo::~MolrInfo ( ) [inline, virtual]

Destructor.

Field Documentation

Application* MolrInfo::m_app

Timeout duration.

ClientId MolrInfo::m_client_id

LcsQos MolrInfo::m_lcs_qos

LocationMethod MolrInfo::m_location_method

MlcNumber MolrInfo::m_mlc_number

MolrType MolrInfo::m_molr_type

Attributes.

LcsProviderImplBase* MolrInfo::m_provider

INT32 MolrInfo::m_repeat_interval

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsDecls.hpp
Generated on Wed Jan 25 01:30:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MolrParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MolrParams Class Reference

This class is used to fill the MN_SS_LCS_MOLR_REQ SDL signal. More...

#include <Apoxi/AddOns/Lcs/Common/LcsDecls.hpp>

Public Member Functions

const T_MN_MOLR_REQ & GetMolrParams () const
MolrParams (MolrType molr_type, LocationMethod loc_method, const LcsQos &lcs_qos, const ClientId &client_id, const MlcNumber &mlc_number)
Argument constructor.

Detailed Description

This class is used to fill the MN_SS_LCS_MOLR_REQ SDL signal.

Constructor & Destructor Documentation

MolrParams::MolrParams | ( | MolrType | molr_type,
 |  | LocationMethod | loc_method,
 |  | const LcsQos & | lcs_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number
 | ) | [inline]

Argument constructor.

Member Function Documentation

const T_MN_MOLR_REQ& MolrParams::GetMolrParams ( ) const [inline]

The documentation for this class was generated from the following file:
  • AddOns/Lcs/Common/LcsDecls.hpp
Generated on Wed Jan 25 01:30:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MolrRepeatInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MolrRepeatInfo Struct Reference

#include <Apoxi/AddOns/Lcs/Common/LcsDecls.hpp>

Inheritance diagram for MolrRepeatInfo:

[legend]
Collaboration diagram for MolrRepeatInfo:

[legend]

Public Types

typedef MolrInfo | Base

Public Member Functions

MolrRepeatInfo (MolrType molr_type, LocationMethod location_method, const LcsQos &lcs_qos, const ClientId &client_id, const MlcNumber &mlc_number, INT32 repeat_interval, const Application *app, const LcsProviderImplBase *provider)
Argument Constructor.
virtual | ~MolrRepeatInfo ()
Destructor.

Data Fields

UINT16 | m_invoke_id
Attributes.
LcsRepeatTimer m_rep_timer

Detailed Description

This stores the state information for a MO-LR that is to be sent at regular intervals to the network

Member Typedef Documentation

typedef MolrInfo MolrRepeatInfo::Base

Reimplemented from Linkable< MolrInfo >.

Constructor & Destructor Documentation

MolrRepeatInfo::MolrRepeatInfo | ( | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsQos & | lcs_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number,
 |  | INT32 | repeat_interval,
 |  | const Application * | app,
 |  | const LcsProviderImplBase * | provider
 | ) | [inline]

Argument Constructor.

virtual MolrRepeatInfo::~MolrRepeatInfo ( ) [inline, virtual]

Destructor.

Field Documentation

UINT16 MolrRepeatInfo::m_invoke_id

Attributes.

LcsRepeatTimer MolrRepeatInfo::m_rep_timer

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsDecls.hpp
Generated on Wed Jan 25 01:30:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Mp3AudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Mp3AudioDevice Class Reference

#include <Apoxi/Devices/Win32/Mp3AudioDevice.hpp>

Inheritance diagram for Mp3AudioDevice:

[legend]
Collaboration diagram for Mp3AudioDevice:

[legend]

Public Member Functions

void | AudioReturnSuspend ()
Suspend playback.
virtual const WCHAR * | GetName () const
virtual AudioReturnCode | Init (Priority prio)
Mp3AudioDevice ()
AudioReturnCode Resume ()
AudioReturnCode Seek ()
AudioReturnCode | Set (UINT16 seconds)
void | SetStartParam (const StartParam *p_start_param)
Set start parameter.
virtual AudioReturnCode | Start (BOOLEAN auto_release=TRUE)
virtual AudioReturnCode | Stop (UINT8 channel=0)
virtual | ~Mp3AudioDevice ()

Data Structures

struct | StartParam
Start parameter. More...

Detailed Description

Class Mp3AudioDevice
Class for Mp3 player access.

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Constructor & Destructor Documentation

Mp3AudioDevice::Mp3AudioDevice ( )

Mp3AudioDevice::~Mp3AudioDevice ( ) [virtual]

Member Function Documentation

void Mp3AudioDevice::AudioReturnSuspend ( )

Suspend playback.

const WCHAR * Mp3AudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from GenericAudioDevice.

Mp3AudioDevice::AudioReturnCode Mp3AudioDevice::Init ( Priority prio ) [virtual]

See also:
GenericAudioDevice::Init

Mp3AudioDevice::AudioReturnCode Mp3AudioDevice::Resume ( )

Resume playback

Returns:
Result of operation.

Mp3AudioDevice::AudioReturnCode Mp3AudioDevice::Seek ( )

Seek

Returns:
Result of operation.

Mp3AudioDevice::AudioReturnCode Mp3AudioDevice::Set ( UINT16 seconds )

Set

Parameters:
seconds Seconds to seek.
Returns:
Result of operation.

void Mp3AudioDevice::SetStartParam ( const StartParam * p_start_param )

Set start parameter.

Mp3AudioDevice::AudioReturnCode Mp3AudioDevice::Start ( BOOLEAN auto_release = TRUE ) [virtual]

See also:
GenericAudioDevice::Start

Reimplemented from GenericAudioDevice.

Mp3AudioDevice::AudioReturnCode Mp3AudioDevice::Stop ( UINT8 channel = 0 ) [virtual]

See also:
GenericAudioDevice::Stop

Reimplemented from GenericAudioDevice.

The documentation for this class was generated from the following files:
  • Devices/Win32/Mp3AudioDevice.hpp
  • Devices/Win32/Mp3AudioDevice.cpp
Generated on Wed Jan 25 01:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Mp3AudioDevice::StartParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Mp3AudioDevice::StartParam

Mp3AudioDevice::StartParam Struct Reference

Start parameter. More...

#include <Apoxi/Devices/Win32/Mp3AudioDevice.hpp>

Detailed Description

Start parameter.

The documentation for this struct was generated from the following file:
  • Devices/Win32/Mp3AudioDevice.hpp
Generated on Wed Jan 25 01:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MP3AudioPlayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MP3AudioPlayer Class Reference
[Audio]

#include <Apoxi/Audio/Mp3AudioPlayer.hpp>

Inheritance diagram for MP3AudioPlayer:

[legend]
Collaboration diagram for MP3AudioPlayer:

[legend]

Public Member Functions

virtual SharedPtr< AudioReference > | CreateAudioReferenceFromRamBuffer (MimeType mime_type, ConstBuffer buffer, UINT32 buffer_size)
virtual SharedPtr< AudioReference > | CreateAudioReferenceFromRfsFile (MimeType mime_type, const Path &path)
virtual SharedPtr< AudioReference > | CreateAudioReferenceFromStream (MimeType mime_type, StreamAudioReference::GetAudioBufferFunction func, void *user_data=0)
BOOLEAN | FastForward (AudioActiveReference &active_reference, UINT32 frame)
BOOLEAN | FastReverse (AudioActiveReference &active_reference, UINT32 frame)
BOOLEAN | GetCurrentFrame (AudioActiveReference &playing_reference)
virtual void | Play (AudioActiveReference &active_reference)
virtual void | ResumeSuspended (AudioActiveReference &active_reference)
virtual void | Stop (AudioActiveReference &active_reference)
virtual void | StopSuspended (AudioActiveReference &active_reference)
virtual void | Suspend (AudioActiveReference &active_reference)
virtual | ~MP3AudioPlayer ()

Detailed Description

The MP3 player implementation class. Use the base class or the methods of AudioDeviceManager, the AudioReference, or the AudioActiveReference.

Constructor & Destructor Documentation

MP3AudioPlayer::~MP3AudioPlayer ( ) [virtual]

Member Function Documentation

SharedPtr< AudioReference > MP3AudioPlayer::CreateAudioReferenceFromRamBuffer | ( | MimeType | mime_type,
 |  | ConstBuffer | buffer,
 |  | UINT32 | buffer_size
 | ) | [virtual]

SharedPtr< AudioReference > MP3AudioPlayer::CreateAudioReferenceFromRfsFile | ( | MimeType | mime_type,
 |  | const Path & | path
 | ) | [virtual]

SharedPtr< AudioReference > MP3AudioPlayer::CreateAudioReferenceFromStream | ( | MimeType | mime_type,
 |  | StreamAudioReference::GetAudioBufferFunction | func,
 |  | void * | user_data = 0
 | ) | [virtual]

BOOLEAN MP3AudioPlayer::FastForward | ( | AudioActiveReference & | active_reference,
 |  | UINT32 | frame
 | ) |

Scans forward through the current playback

Parameters:
active_reference. | The playing reference to be scanned
frame. | Number of frames to be moved forward
Returns:
TRUE if the scan can be done.
Note:
If frame is out of range the value will be ignored.

BOOLEAN MP3AudioPlayer::FastReverse | ( | AudioActiveReference & | active_reference,
 |  | UINT32 | frame
 | ) |

Scans backward through the current playback

Parameters:
active_reference. | The playing reference to be scanned
frame. | Number of frames to be moved backward
Returns:
TRUE if the scan can be done.
Note:
If the frame is out of range the value will be ignored. See GetNumberOfFrames() and GetCurrentFrame() functions

BOOLEAN MP3AudioPlayer::GetCurrentFrame ( AudioActiveReference & playing_reference )

(Not yet implemented) Get the current frame position. The application will receive the AudioMP3CurrentFrameMsg APOXI message containing the current frame position.

Parameters:
playing_reference. The playing reference to get the current frame
Returns:
TRUE if no errors

void MP3AudioPlayer::Play ( AudioActiveReference & active_reference ) [virtual]

void MP3AudioPlayer::ResumeSuspended ( AudioActiveReference & active_reference ) [virtual]

void MP3AudioPlayer::Stop ( AudioActiveReference & active_reference ) [virtual]

void MP3AudioPlayer::StopSuspended ( AudioActiveReference & active_reference ) [virtual]

void MP3AudioPlayer::Suspend ( AudioActiveReference & active_reference ) [virtual]

The documentation for this class was generated from the following files:
  • Audio/Mp3AudioPlayer.hpp
  • Audio/Mp3AudioPlayer.cpp
Generated on Wed Jan 25 01:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MP3AudioReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MP3AudioReference Class Reference
[Audio]

#include <Apoxi/Audio/Mp3AudioReference.hpp>

Inheritance diagram for MP3AudioReference:

[legend]
Collaboration diagram for MP3AudioReference:

[legend]

Public Member Functions

UINT32 | GetStartFrame () const
void | SetStartFrame (const UINT32 start_frame)

Detailed Description

A reference to a MP3 audio data format

Member Function Documentation

UINT32 MP3AudioReference::GetStartFrame ( ) const

Get the start frame

Returns:
The frame number where to start the playback.

void MP3AudioReference::SetStartFrame ( const UINT32 start_frame )

Set the start frame

Parameters:
frame. The number of frames that should be skipped at start.

The documentation for this class was generated from the following files:
  • Audio/Mp3AudioReference.hpp
  • Audio/Mp3AudioReference.cpp
Generated on Wed Jan 25 01:30:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Mp3Header Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Mp3Header Struct Reference

#include <Apoxi/Devices/Win32/HostAudioDriver.hpp>

Data Fields

UINT16 | mpg_br
INT | mpg_freq
UINT8 | mpg_layer
UINT8 | mpg_pad_bit
UINT8 | mpg_ver

Field Documentation

UINT16 Mp3Header::mpg_br

INT Mp3Header::mpg_freq

UINT8 Mp3Header::mpg_layer

UINT8 Mp3Header::mpg_pad_bit

UINT8 Mp3Header::mpg_ver

The documentation for this struct was generated from the following file:
  • Devices/Win32/HostAudioDriver.hpp
Generated on Wed Jan 25 01:30:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Mp3Param Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Mp3Param Struct Reference

#include <Apoxi/Devices/Win32/HostAudioDriver.hpp>

Collaboration diagram for Mp3Param:

[legend]

Data Fields

UINT16 | buffer_size
UINT16 * | file_handle
UINT8 | handle
UINT32 | id_offset
Mp3Header m_mpghead
aud_media_enum | media
UINT32 | start_frame

Field Documentation

UINT16 Mp3Param::buffer_size

UINT16* Mp3Param::file_handle

UINT8 Mp3Param::handle

UINT32 Mp3Param::id_offset

Mp3Header Mp3Param::m_mpghead

aud_media_enum Mp3Param::media

UINT32 Mp3Param::start_frame

The documentation for this struct was generated from the following file:
  • Devices/Win32/HostAudioDriver.hpp
Generated on Wed Jan 25 01:30:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MptyCallHdl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MptyCallHdl Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/MptyCallHdl.hpp>

Inheritance diagram for MptyCallHdl:

[legend]
Collaboration diagram for MptyCallHdl:

[legend]

Public Member Functions

virtual TimeSpan | GetCallDuration () const
virtual CallIndex | GetCallIndex () const
CallHdl | GetMember (INT pos=0) const
INT | GetMemberCount () const
Returns the number of members of a multi-party call.
ChannelNo | GetMptyChannelNo () const
Returns the channel nunber of the MptyCallHdl object.
virtual DateTime | GetStartTime () const
virtual CallApiRc | Hold ()
virtual void | Invalidate ()
Sets the reference to the multi-party call to the void reference.
virtual BOOLEAN | IsActive () const
Returns TRUE if the multy-party call is active, FALSE otherwise.
virtual BOOLEAN | IsHeld () const
Returns TRUE if the multy-party call is held, FALSE otherwise.
virtual BOOLEAN | IsHoldPermitted () const
Returns TRUE if the preconditions for holding a call are fulfilled.
virtual BOOLEAN | IsRetrievePermitted () const
Returns TRUE if the preconditions for retrieving a call are fulfilled.
virtual BOOLEAN | IsSame (const MptyCallHdl &mpty_call) const
Returns TRUE if both handles refer to the same multi-party call, FALSE otherwise.
BOOLEAN | IsSplitPermitted (const CallHdl &call) const
Returns TRUE if an active multi-party call exists, FALSE otherwise.
virtual BOOLEAN | IsValid () const
Returns true if the handle refers to an existing multi-party call, FALSE otherwise.
MptyCallHdl (ChannelNo channel_no=c_null_channel_no)
virtual CallApiRc | Release (TimeSpan *calling_time=0, BOOLEAN wait_condition=FALSE)
virtual CallApiRc | Retrieve ()
CallApiRc | Split (const CallHdl &active_call) const
virtual CallApiRc | StartDtmfToneGeneration (KeyCode key)
virtual CallApiRc | StopDtmfToneGeneration ()
virtual | ~MptyCallHdl ()

Static Public Member Functions

static MptyCallHdl | GetMptyCallHdl ()

Detailed Description

The class MptyCallHdl is intended to represent multi-party calls. It provides methods for all common operations on multi-party calls, like Release, Hold, Retrieve, etc. Furthermore, methods are available to access the members of the multi-party call, the time when the multi-party call was set up, and some comparison methods. Also available are methods, which indicate if a corresponding operation (like Hold, Retrieve, Split, etc.) is permitted for the respective MptyCallHdl.
The class keeps the number of the channel where the multi-party call is located.

Constructor & Destructor Documentation

MptyCallHdl::MptyCallHdl ( ChannelNo channel_no = c_null_channel_no ) [explicit]

MptyCallHdl::~MptyCallHdl ( ) [virtual]

Member Function Documentation

TimeSpan MptyCallHdl::GetCallDuration ( ) const [virtual]

Returns a TimeSpan object for the duration of the call represented by a CallHdl. The method is applicable to MptyCallHdl.

Returns:
A zero value if the MptyCallHdl is not valid. Also zero if a single call has not been successfully established. The time span from the successful establishment of of a single call or multiparty call to the time of execution of this method.

Implements CallHdlBase.

virtual CallIndex MptyCallHdl::GetCallIndex ( ) const [inline, virtual]

Default implementation. Returns c_mpty_indication.

See also:
MptyCallHdl::GetMemberCount and MptyCallHdl::GetMember for more information how to access multi-party call data.

Implements CallHdlBase.

CallHdl MptyCallHdl::GetMember ( INT pos = 0 ) const

Returns a CallHdl referring to the call which is found at the position pos in the multi-party call. If no call is found at position pos a CallHdl with CallIndex c_null_call_index, i.e., an invalid CallHdl is returned.

Parameters:
pos The position of the member in the multi-party call.
Returns:
A CallHdl object.

INT MptyCallHdl::GetMemberCount ( ) const

Returns the number of members of a multi-party call.

MptyCallHdl MptyCallHdl::GetMptyCallHdl ( ) [static]

Returns a MptyCallHdl object with a reference to the multi- party call. If no multi-party call exists, the MptyCallHdl() will refer to the c_null_channel_no.

Returns:
A MptyCallHdl referring to the multi-party call.

ChannelNo MptyCallHdl::GetMptyChannelNo ( ) const [inline]

Returns the channel nunber of the MptyCallHdl object.

DateTime MptyCallHdl::GetStartTime ( ) const [virtual]

Returns the time at the point where the multi-party call was established.

Returns:
The time of multi-party call setup.

Implements CallHdlBase.

CallApiRc MptyCallHdl::Hold ( ) [virtual]

Holds all calls of an active multi-party call.

Returns:
NoError - If executed successfully. In case of any error, one of the following values is returned: CallDataLocked, HeldCallDetected, ActiveCallRequired, InvalidCallIndex, VoidCallIndex, CallDisconnected, SupplementaryServiceFailed, HoldRequestRejected.

virtual void MptyCallHdl::Invalidate ( ) [inline, virtual]

Sets the reference to the multi-party call to the void reference.

Implements CallHdlBase.

BOOLEAN MptyCallHdl::IsActive ( ) const [virtual]

Returns TRUE if the multy-party call is active, FALSE otherwise.

Implements CallHdlBase.

BOOLEAN MptyCallHdl::IsHeld ( ) const [virtual]

Returns TRUE if the multy-party call is held, FALSE otherwise.

Implements CallHdlBase.

BOOLEAN MptyCallHdl::IsHoldPermitted ( ) const [virtual]

Returns TRUE if the preconditions for holding a call are fulfilled.

Implements CallHdlBase.

BOOLEAN MptyCallHdl::IsRetrievePermitted ( ) const [virtual]

Returns TRUE if the preconditions for retrieving a call are fulfilled.

Implements CallHdlBase.

BOOLEAN MptyCallHdl::IsSame ( const MptyCallHdl & mpty_call ) const [virtual]

Returns TRUE if both handles refer to the same multi-party call, FALSE otherwise.

BOOLEAN MptyCallHdl::IsSplitPermitted ( const CallHdl & call ) const

Returns TRUE if an active multi-party call exists, FALSE otherwise.

virtual BOOLEAN MptyCallHdl::IsValid ( ) const [inline, virtual]

Returns true if the handle refers to an existing multi-party call, FALSE otherwise.

Implements CallHdlBase.

CallApiRc MptyCallHdl::Release | ( | TimeSpan * | calling_time = 0,
 |  | BOOLEAN | wait_condition = FALSE
 | ) | [virtual]

Releases all members of a multi-party call and terminates the multi- party call. The multi-party call may be in state active or hold. The internal data structures are updated immediately, since the MN confirms the release if the network fails to confirm the release within 30 sec.

Parameters:
call_duration | The duration of the mpty-call (TimeSpan).
wait_condition | TRUE for synchronous waiting of release
Returns:
NoError - If executed successfully .In case of an error, one of the following values is returned: CallDataLocked, InvalidCallIndex, VoidCallIndex.

Implements CallHdlBase.

CallApiRc MptyCallHdl::Retrieve ( ) [virtual]

Retrieves all calls of a previously held multi-party call.

Returns:
NoError - If executed successfully.In case of any error, one of the following values is returned: CallDataLocked, ActiveCallDetected, HeldCallRequired, InvalidCallIndex, VoidCallIndex, CallDisconnected, SupplementaryServiceFailed, RetrieveRequestRejected.

CallApiRc MptyCallHdl::Split ( const CallHdl & active_call ) const

Sets an active multiy-party call to hold except of one particular call defined by active_call

Parameters:
active_call The call to be splitted off the multy-party call.
Returns:
NoError - In case of successful execution. In case of any error, one of the following values will be returned: CallDataLocked, ActiveMptyRequired, HeldCallDetected, CallNotMptyMember, InvalidCallIndex, VoidCallIndex, CallDisconnected, SupplementaryServiceFailed.

CallApiRc MptyCallHdl::StartDtmfToneGeneration ( KeyCode key ) [virtual]

Starts the generation of a DTMF tone during an active voice call. Refer to the documentation of CallApiRc for a detailed description of the return values.

Parameters:
key A KeyCode 0, 1, ... 9, * or #.
Returns:
NoError - If successful. In case of an error, one of the following values is returned: CallDataLocked, VoidCallIndex, InvalidCallIndex, ActiveCallRequired, SpeechCallRequired, InvalidMptyMemberCount,

Reimplemented from CallHdlBase.

CallApiRc MptyCallHdl::StopDtmfToneGeneration ( ) [virtual]

Stops the started generation of a DTMF tone.

Returns:
See CallHdl::StartDtmfToneGeneration(...).

Reimplemented from CallHdlBase.

The documentation for this class was generated from the following files:
  • Asc/MptyCallHdl.hpp
  • Asc/MptyCallHdl.cpp
Generated on Wed Jan 25 01:30:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MptyCallReleaseMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MptyCallReleaseMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MptyCallReleaseMsg:

[legend]
Collaboration diagram for MptyCallReleaseMsg:

[legend]

Public Types

enum | { ID = 18714 }

Public Member Functions

virtual Message * | Clone () const
const MptyCallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
MptyCallReleaseMsg (const MptyCallHdl &call_hdl)
virtual | ~MptyCallReleaseMsg ()

Detailed Description

MptyCallReleaseMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MptyCallReleaseMsg::MptyCallReleaseMsg ( const MptyCallHdl & call_hdl )

MptyCallReleaseMsg::~MptyCallReleaseMsg ( ) [virtual]

Member Function Documentation

Message * MptyCallReleaseMsg::Clone ( ) const [virtual]

Implements Message.

const MptyCallHdl& MptyCallReleaseMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & MptyCallReleaseMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:30:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MptyCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MptyCnfArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for MptyCnfArg:

[legend]
Collaboration diagram for MptyCnfArg:

[legend]

Public Types

enum | { ID = 1064 }

Public Member Functions

const CallRelatedSs & | GetCrss () const
const Tipd & | GetTipd () const
MptyCnfArg ()
void | SetCrss (const CallRelatedSs &crss)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MptyCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MptyCnfArg: reflects arguments of signal MN_MPTY_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MptyCnfArg::MptyCnfArg ( )

Member Function Documentation

const MptyCnfArg & MptyCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallRelatedSs& MptyCnfArg::GetCrss ( ) const [inline]

const Tipd& MptyCnfArg::GetTipd ( ) const [inline]

void MptyCnfArg::SetCrss ( const CallRelatedSs & crss ) [inline]

void MptyCnfArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MptyHoldRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MptyHoldRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MptyHoldRejectedMsg:

[legend]
Collaboration diagram for MptyHoldRejectedMsg:

[legend]

Public Types

enum | { ID = 18323 }

Public Member Functions

virtual Message * | Clone () const
const SsErrorCode & | GetErrorCode () const
virtual const MsgMetaData & | GetMetaData () const
MptyHoldRejectedMsg (ExecutionContext *context, const SsErrorCode &error_code)
void | SetErrorCode (const SsErrorCode &error_code)
virtual | ~MptyHoldRejectedMsg ()

Detailed Description

MptyHoldRejectedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MptyHoldRejectedMsg::MptyHoldRejectedMsg | ( | ExecutionContext * | context,
 |  | const SsErrorCode & | error_code
 | ) |

MptyHoldRejectedMsg::~MptyHoldRejectedMsg ( ) [virtual]

Member Function Documentation

Message * MptyHoldRejectedMsg::Clone ( ) const [virtual]

Implements Message.

const SsErrorCode& MptyHoldRejectedMsg::GetErrorCode ( void ) const [inline]

const MsgMetaData & MptyHoldRejectedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void MptyHoldRejectedMsg::SetErrorCode ( const SsErrorCode & error_code ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:30:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MptyOnHoldMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MptyOnHoldMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MptyOnHoldMsg:

[legend]
Collaboration diagram for MptyOnHoldMsg:

[legend]

Public Types

enum | { ID = 18322 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
MptyOnHoldMsg (ExecutionContext *context)
virtual | ~MptyOnHoldMsg ()

Detailed Description

MptyOnHoldMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MptyOnHoldMsg::MptyOnHoldMsg ( ExecutionContext * context )

MptyOnHoldMsg::~MptyOnHoldMsg ( ) [virtual]

Member Function Documentation

Message * MptyOnHoldMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & MptyOnHoldMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:30:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MsapPackedData_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MsapPackedData_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for MsapPackedData_s:

[legend]

Data Fields

TMsapPackedDataArray data
unsigned short private_idx
byte result

Field Documentation

TMsapPackedDataArray MsapPackedData_s::data

unsigned short MsapPackedData_s::private_idx

byte MsapPackedData_s::result

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:30:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MsgMetaData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MsgMetaData Struct Reference
[Kernel]

#include <Apoxi/Kernel/MsgCategory.hpp>

Data Fields

MsgCategory msg_class
MsgId msg_id
MsgOrigin msg_origin

Field Documentation

MsgCategory MsgMetaData::msg_class

MsgId MsgMetaData::msg_id

MsgOrigin MsgMetaData::msg_origin

The documentation for this struct was generated from the following file:
  • Kernel/MsgCategory.hpp
Generated on Wed Jan 25 01:30:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MsgQueue Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MsgQueue Class Reference
[Kernel]

#include <Apoxi/Kernel/MsgQueue.hpp>

Collaboration diagram for MsgQueue:

[legend]

Public Member Functions

MsgQueue ()
BOOLEAN | Push (const MessageReferrer &msg_ref)
void | TriggerIsrDataProcessing ()
BOOLEAN | Wait (MessageReferrer &msg_ref, Ticks timeout=Ticks::Infinite())

Static Public Member Functions

static BOOLEAN | IsFocusMsgProcessingBlocked ()
static BOOLEAN | PassBackFocusMsg (const MessageReferrer &msg_ref)
static BOOLEAN | PushFocusMsg (const MessageReferrer &msg_ref)
static void | SetFocusMsgProcessingBlocked (BOOLEAN block)

Friends

class | AppContainer
class | ServiceThread

Data Structures

class | QueueEntry

Detailed Description

Describes a message queue.

Constructor & Destructor Documentation

MsgQueue::MsgQueue ( )

Member Function Documentation

static BOOLEAN MsgQueue::IsFocusMsgProcessingBlocked ( ) [inline, static]

BOOLEAN MsgQueue::PassBackFocusMsg ( const MessageReferrer & msg_ref ) [static]

Calling this method is useful if one application wants to switch the focus to another application triggered by a key press BUT wants the new focused application to handle the key event again.

BOOLEAN MsgQueue::Push ( const MessageReferrer & msg_ref )

Adds a MessageReferrer to the queue. Messages of category MC_FOCUS have to be added by using MsgQueue::PushFocusMsg!

Parameters:
msg_ref MessageReferrer, which should be added at the end of the queue.

BOOLEAN MsgQueue::PushFocusMsg ( const MessageReferrer & msg_ref ) [static]

Like MsgQueue::Push but only for messages of category MC_FOCUS.

static void MsgQueue::SetFocusMsgProcessingBlocked ( BOOLEAN block ) [inline, static]

void MsgQueue::TriggerIsrDataProcessing ( ) [inline]

BOOLEAN MsgQueue::Wait | ( | MessageReferrer & | msg_ref,
 |  | Ticks | timeout = Ticks::Infinite()
 | ) |

Waits until the first entry of the queue can be received. The first entry will be deleted after receiving.

Parameters:
msg_ref | Out-parameter, which contains the first entry of the queue.
timeout | Timeout in milliseconds for waiting.
Returns:
TRUE, if the first entry could be received before the specified timeout. If FALSE is returned, the content of parameter entry is undefined.

Friends And Related Function Documentation

friend class AppContainer [friend]

friend class ServiceThread [friend]

The documentation for this class was generated from the following files:
  • Kernel/MsgQueue.hpp
  • Kernel/MsgQueue.cpp
Generated on Wed Jan 25 01:30:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtcAcceptArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtcAcceptArg Class Reference

#include <Apoxi/Apc/MtcStackMsgArgs.hpp>

Inheritance diagram for MtcAcceptArg:

[legend]
Collaboration diagram for MtcAcceptArg:

[legend]

Public Types

enum | { ID = 2160 }

Public Member Functions

const Tipd & | GetTipd () const
MtcAcceptArg ()
MtcAcceptArg (const Tipd &tipd)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MtcAcceptArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MtcAcceptArg: reflects arguments of signal MN_CALL_ACC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MtcAcceptArg::MtcAcceptArg ( const Tipd & tipd )

MtcAcceptArg::MtcAcceptArg ( )

Member Function Documentation

const MtcAcceptArg & MtcAcceptArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& MtcAcceptArg::GetTipd ( ) const [inline]

void MtcAcceptArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MtcStackMsgArgs.hpp
  • Apc/MtcStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtcAcceptRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtcAcceptRejArg Class Reference

#include <Apoxi/Apc/MtcStackMsgArgs.hpp>

Inheritance diagram for MtcAcceptRejArg:

[legend]
Collaboration diagram for MtcAcceptRejArg:

[legend]

Public Types

enum | { ID = 1163 }

Public Member Functions

const Tipd & | GetTipd () const
MtcAcceptRejArg ()
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MtcAcceptRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MtcAcceptRejArg::MtcAcceptRejArg ( )

Member Function Documentation

const MtcAcceptRejArg & MtcAcceptRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& MtcAcceptRejArg::GetTipd ( ) const [inline]

void MtcAcceptRejArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MtcStackMsgArgs.hpp
  • Apc/MtcStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtcAlertReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtcAlertReqArg Class Reference

#include <Apoxi/Apc/MtcStackMsgArgs.hpp>

Inheritance diagram for MtcAlertReqArg:

[legend]
Collaboration diagram for MtcAlertReqArg:

[legend]

Public Types

enum | { ID = 2161 }

Public Member Functions

const Tipd & | GetTipd () const
MtcAlertReqArg ()
MtcAlertReqArg (const Tipd &tipd)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MtcAlertReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

MtcAlertReqArg: reflects arguments of signal MN_ALERT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MtcAlertReqArg::MtcAlertReqArg ( const Tipd & tipd )

MtcAlertReqArg::MtcAlertReqArg ( )

Member Function Documentation

const MtcAlertReqArg & MtcAlertReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& MtcAlertReqArg::GetTipd ( ) const [inline]

void MtcAlertReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MtcStackMsgArgs.hpp
  • Apc/MtcStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtcArrivedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtcArrivedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MtcArrivedMsg:

[legend]
Collaboration diagram for MtcArrivedMsg:

[legend]

Public Types

enum | { ID = 18402 }

Public Member Functions

virtual Message * | Clone () const
const CallHdl & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
MtcArrivedMsg (ExecutionContext *context, const CallHdl &arg)
void | SetArg (const CallHdl &arg)
virtual | ~MtcArrivedMsg ()

Detailed Description

MtcArrivedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MtcArrivedMsg::MtcArrivedMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | arg
 | ) |

MtcArrivedMsg::~MtcArrivedMsg ( ) [virtual]

Member Function Documentation

Message * MtcArrivedMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& MtcArrivedMsg::GetArg ( ) const [inline]

const MsgMetaData & MtcArrivedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void MtcArrivedMsg::SetArg ( const CallHdl & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:30:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtcConfIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtcConfIndArg Class Reference

#include <Apoxi/Apc/MtcStackMsgArgs.hpp>

Inheritance diagram for MtcConfIndArg:

[legend]
Collaboration diagram for MtcConfIndArg:

[legend]

Public Types

enum | { ID = 1160 }

Public Member Functions

const Tipd & | GetTipd () const
MtcConfIndArg ()
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MtcConfIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MtcConfIndArg::MtcConfIndArg ( )

Member Function Documentation

const MtcConfIndArg & MtcConfIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& MtcConfIndArg::GetTipd ( ) const [inline]

void MtcConfIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MtcStackMsgArgs.hpp
  • Apc/MtcStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtcReadyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtcReadyMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MtcReadyMsg:

[legend]
Collaboration diagram for MtcReadyMsg:

[legend]

Public Types

enum | { ID = 18403 }

Public Member Functions

virtual Message * | Clone () const
const CallHdl & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
MtcReadyMsg (ExecutionContext *context, const CallHdl &arg)
void | SetArg (const CallHdl &arg)
virtual | ~MtcReadyMsg ()

Detailed Description

MtcReadyMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MtcReadyMsg::MtcReadyMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | arg
 | ) |

MtcReadyMsg::~MtcReadyMsg ( ) [virtual]

Member Function Documentation

Message * MtcReadyMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& MtcReadyMsg::GetArg ( ) const [inline]

const MsgMetaData & MtcReadyMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void MtcReadyMsg::SetArg ( const CallHdl & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:30:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtcSetupComplArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtcSetupComplArg Class Reference

#include <Apoxi/Apc/MtcStackMsgArgs.hpp>

Inheritance diagram for MtcSetupComplArg:

[legend]
Collaboration diagram for MtcSetupComplArg:

[legend]

Public Types

enum | { ID = 1162 }

Public Member Functions

const CallType & | GetCallType () const
const CallRelatedSsCode & | GetCrssCode () const
const Tipd & | GetTipd () const
MtcSetupComplArg ()
void | SetCallType (const CallType &call_type)
void | SetCrssCode (const CallRelatedSsCode &crss_code)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MtcSetupComplArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MtcSetupComplArg::MtcSetupComplArg ( )

Member Function Documentation

const MtcSetupComplArg & MtcSetupComplArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallType& MtcSetupComplArg::GetCallType ( ) const [inline]

const CallRelatedSsCode& MtcSetupComplArg::GetCrssCode ( ) const [inline]

const Tipd& MtcSetupComplArg::GetTipd ( ) const [inline]

void MtcSetupComplArg::SetCallType ( const CallType & call_type ) [inline]

void MtcSetupComplArg::SetCrssCode ( const CallRelatedSsCode & crss_code ) [inline]

void MtcSetupComplArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MtcStackMsgArgs.hpp
  • Apc/MtcStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtcSetupIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtcSetupIndArg Class Reference

#include <Apoxi/Apc/MtcStackMsgArgs.hpp>

Inheritance diagram for MtcSetupIndArg:

[legend]
Collaboration diagram for MtcSetupIndArg:

[legend]

Public Types

enum | { ID = 1161 }

Public Member Functions

const LineSelector & | GetCallLine () const
const CallType & | GetCallType () const
const PhoneNumber & | GetConnectedNo () const
const GsmSignal & | GetGsmSignal () const
const Tipd & | GetTipd () const
BOOLEAN | IsCtm () const
MtcSetupIndArg ()
void | SetCallLine (const LineSelector &call_line)
void | SetCallType (const CallType &call_type)
void | SetConnectedNo (const PhoneNumber &connected_no)
void | SetCtm (BOOLEAN ctm)
void | SetGsmSignal (const GsmSignal &gsm_signal)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const MtcSetupIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MtcSetupIndArg::MtcSetupIndArg ( )

Member Function Documentation

const MtcSetupIndArg & MtcSetupIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const LineSelector& MtcSetupIndArg::GetCallLine ( ) const [inline]

const CallType& MtcSetupIndArg::GetCallType ( ) const [inline]

const PhoneNumber& MtcSetupIndArg::GetConnectedNo ( ) const [inline]

const GsmSignal& MtcSetupIndArg::GetGsmSignal ( ) const [inline]

const Tipd& MtcSetupIndArg::GetTipd ( ) const [inline]

BOOLEAN MtcSetupIndArg::IsCtm ( ) const [inline]

void MtcSetupIndArg::SetCallLine ( const LineSelector & call_line ) [inline]

void MtcSetupIndArg::SetCallType ( const CallType & call_type ) [inline]

void MtcSetupIndArg::SetConnectedNo ( const PhoneNumber & connected_no ) [inline]

void MtcSetupIndArg::SetCtm ( BOOLEAN ctm ) [inline]

void MtcSetupIndArg::SetGsmSignal ( const GsmSignal & gsm_signal ) [inline]

void MtcSetupIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MtcStackMsgArgs.hpp
  • Apc/MtcStackMsgArgs.cpp
Generated on Wed Jan 25 01:30:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MtlrInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MtlrInfo Struct Reference

#include <Apoxi/AddOns/Lcs/Common/LcsDecls.hpp>

Inheritance diagram for MtlrInfo:

[legend]
Collaboration diagram for MtlrInfo:

[legend]

Public Member Functions

MtlrInfo (BYTE ti_pd, LcsNotificationType notif_type, const LcsProviderImplBase *provider)
Argument Constructor.
virtual | ~MtlrInfo ()
Destructor.

Data Fields

UINT16 | m_invoke_id
LcsTimer m_lcs_timer
LcsNotificationType m_notif_type
LcsProviderImplBase * m_provider
BYTE | m_ti_pd
Attributes.

Detailed Description

This stores the state information for a MT-LR that needs verification response from the user

Constructor & Destructor Documentation

MtlrInfo::MtlrInfo | ( | BYTE | ti_pd,
 |  | LcsNotificationType | notif_type,
 |  | const LcsProviderImplBase * | provider
 | ) | [inline]

Argument Constructor.

virtual MtlrInfo::~MtlrInfo ( ) [inline, virtual]

Destructor.

Field Documentation

UINT16 MtlrInfo::m_invoke_id

LcsTimer MtlrInfo::m_lcs_timer

LcsNotificationType MtlrInfo::m_notif_type

LcsProviderImplBase* MtlrInfo::m_provider

BYTE MtlrInfo::m_ti_pd

Attributes.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsDecls.hpp
Generated on Wed Jan 25 01:30:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiLineEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiLineEditor Class Reference
[Editors]

#include <Apoxi/Gui/MultiLineEditor.hpp>

Inheritance diagram for MultiLineEditor:

[legend]
Collaboration diagram for MultiLineEditor:

[legend]

Public Types

enum | { ID = 33 }

Public Member Functions

const Font & | GetFont () const
INT | GetMaxTextLength () const
const WString & | GetText () const
void | Init (Control *parent, INT input_mapper_id, const WCHAR *text=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
MultiLineEditor (Control *parent, INT input_mapper_id, const WCHAR *text=0)
MultiLineEditor ()
void | SetFont (const Font &font)
void | SetLineHeight (XYDIM line_height)
void | SetMaxTextLength (INT max_tex_len)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual void | SetReadOnly (BOOLEAN read_only)
void | SetText (const WCHAR *text)
virtual | ~MultiLineEditor ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual void | OnThemeChanged ()

Detailed Description

Editor for editing a text in a vertical scrollable area.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractMultiLineEditor.

Constructor & Destructor Documentation

MultiLineEditor::MultiLineEditor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

MultiLineEditor::MultiLineEditor | ( | Control * | parent,
 |  | INT | input_mapper_id,
 |  | const WCHAR * | text = 0
 | ) |

Parameters:
parent | Pointer to the parent-control.
input_mapper_id | Id of Input-Mapper. The resulting instance of the Input-Mapper can be defined in EditConfig::CreateInputMapper().
text | Pointer to text, which will be copied to the internal buffer.

MultiLineEditor::~MultiLineEditor ( ) [virtual]

Member Function Documentation

Model * MultiLineEditor::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

const Font & MultiLineEditor::GetFont ( ) const

Returns the font of the text-editor document.

See also:
TextEditorDocument::SetFont

TextEditorDocument::GetFont

INT MultiLineEditor::GetMaxTextLength ( ) const

Returns:
The maximum text length ( is not counted). If -1 is returned, no maximum text length is given and only restricted by the available memory.

const WString & MultiLineEditor::GetText ( ) const

Returns:
Reference to a WString, which represents the text of the internal buffer.

void MultiLineEditor::Init | ( | Control * | parent,
 |  | INT | input_mapper_id,
 |  | const WCHAR * | text = 0
 | ) |

Parameters:
parent | Pointer to the parent-control.
input_mapper_id | Id of Input-Mapper. The resulting instance of the Input-Mapper can be defined in EditConfig::CreateInputMapper().
text | Pointer to text, which will be copied to the internal buffer.

BOOLEAN MultiLineEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractMultiLineEditor.

void MultiLineEditor::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged

Reimplemented from Control.

void MultiLineEditor::SetFont ( const Font & font )

Sets the font of the text-editor document. Per default the font defined by Font::TextEditor is used.

See also:
TextEditorDocument::SetFont

TextEditorDocument::GetFont

void MultiLineEditor::SetLineHeight ( XYDIM line_height )

Sets the line-height of the text-editor document.

See also:
TextEditorDocument::SetLineHeight

TextEditorDocument::GetLineHeight

void MultiLineEditor::SetMaxTextLength ( INT max_tex_len )

Sets the maximum text length ( is not counted). If a value < 0 is used, no maximum text length is given and hence only restricted by the available memory.

BOOLEAN MultiLineEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractMultiLineEditor.

void MultiLineEditor::SetReadOnly ( BOOLEAN read_only ) [virtual]

See also:
AbstractEditor::SetReadOnly

Reimplemented from AbstractEditor.

void MultiLineEditor::SetText ( const WCHAR * text )

Parameters:
text Pointer to text, which will be copied to the internal buffer.

The documentation for this class was generated from the following files:
  • Gui/MultiLineEditor.hpp
  • Gui/MultiLineEditor.cpp
Generated on Wed Jan 25 01:30:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiMediaEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiMediaEditor Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/MultiMediaEditor.hpp>

Inheritance diagram for MultiMediaEditor:

[legend]
Collaboration diagram for MultiMediaEditor:

[legend]

Public Types

enum | { ID = 36 }

Public Member Functions

virtual BOOLEAN | Backspace ()
const Color & | GetBackgroundColor () const
UINT8 | GetBottomLineGap () const
virtual BOOLEAN | GetCharItem (INT index, WCHAR &chr) const
const Font & | GetFont () const
const Color & | GetForegroundColor () const
TextAttr | GetTextAttr () const
UINT8 | GetTopLineGap () const
void | Init (Control *parent, INT input_mapper_id)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | IsInstanceOf (INT id) const
MultiMediaEditor (Control *parent, INT input_mapper_id)
MultiMediaEditor ()
virtual void | OnItemMarked (const AbstractEditorItem *item)
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
void | SetBackgroundColor (const Color &color)
void | SetBottomLineGap (UINT8 gap)
virtual void | SetFirstVisibleLineIndex (INT line_idx)
void | SetFont (const Font &font)
void | SetForegroundColor (const Color &color)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual void | SetReadOnly (BOOLEAN read_only)
void | SetTextAttr (TextAttr text_attr)
void | SetTopLineGap (UINT8 gap)
virtual void | Update ()
virtual | ~MultiMediaEditor ()

Protected Member Functions

virtual void | Cleanup ()
virtual Model * | CreateModel () const
virtual BOOLEAN | DestroyModel (Model *model)
virtual void | DrawMarkedItemSelection (DeviceContext *dc, const Rect &item_rect, INT item_index)
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
virtual void | OnPaint (const Rect &repaint_rect)
virtual void | Refresh (const Rect &rect)

Detailed Description

Represents an editor wich may contain:
  • texts with adjustable font, foreground-color, background-color and text-attributes (bold, italic, underlined, stroked)
  • images and animations
  • sound objects
  • alignable paragraphs (default, left, right, centered) with a variable line-gap

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractMultiLineEditor.

Constructor & Destructor Documentation

MultiMediaEditor::MultiMediaEditor ( )

MultiMediaEditor::MultiMediaEditor | ( | Control * | parent,
 |  | INT | input_mapper_id
 | ) |

Parameters:
parent | Pointer to the parent-control, where the editor is embedded.
input_mapper_id | ID of used input-mapper. The corresponding instance of the input-mapper can be defined in the factory-method EditConfig::AllocInputMapper().

MultiMediaEditor::~MultiMediaEditor ( ) [virtual]

Member Function Documentation

BOOLEAN MultiMediaEditor::Backspace ( ) [virtual]

See also:
AbstractEditor::Backspace

Reimplemented from AbstractMultiLineEditor.

Reimplemented in EmsEditor.

void MultiMediaEditor::Cleanup ( ) [protected, virtual]

See also:
Component::Cleanup

Reimplemented from AbstractEditor.

Model * MultiMediaEditor::CreateModel ( ) const [protected, virtual]

Factory method for creating a model. Must be implemented by every class, which needs it's own model. By default a component has no model and 0 is returned. If a model is dynamically created by 'new', it must be deleted in the destructor by e. g. delete GetModel();.

Returns:
Pointer to the model.

Reimplemented from Component.

Reimplemented in EmsEditor.

BOOLEAN MultiMediaEditor::DestroyModel ( Model * model ) [protected, virtual]

Reimplemented in EmsEditor.

void MultiMediaEditor::DrawMarkedItemSelection | ( | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | INT | item_index
 | ) | [protected, virtual]

Draws the selection for a marked item. Per default an alpha blended frame is drawn in the selection color is drawn. The item itself is drawn before the selection, otherwise non transparent images would hide the selection.

Parameters:
dc | Device context where the drawing is done.
item_rect | Boundaries of the selection.
item_index | Index of the marked item.

const Color& MultiMediaEditor::GetBackgroundColor ( ) const [inline]

UINT8 MultiMediaEditor::GetBottomLineGap ( ) const

Returns the gap on the bottom of each line of the document.

See also:
SetBottomLineGap

MultiMediaEditorDocument::GetBottomLineGap

BOOLEAN MultiMediaEditor::GetCharItem | ( | INT | index,
 |  | WCHAR & | chr
 | ) | const [virtual]

See also:
AbstractMultiLineEditor::GetCharItem

Reimplemented from AbstractMultiLineEditor.

const Font& MultiMediaEditor::GetFont ( ) const [inline]

const Color& MultiMediaEditor::GetForegroundColor ( ) const [inline]

TextAttr MultiMediaEditor::GetTextAttr ( ) const [inline]

UINT8 MultiMediaEditor::GetTopLineGap ( ) const

Returns the gap on the top of each line of the document.

See also:
SetTopLineGap

MultiMediaEditorDocument::GetTopLineGap

void MultiMediaEditor::Init | ( | Control * | parent,
 |  | INT | input_mapper_id
 | ) |

Parameters:
parent | Pointer to the parent-control, where the editor is embedded.
input_mapper_id | ID of used input-mapper. The corresponding instance of the input-mapper can be defined in the factory-method EditConfig::AllocInputMapper().

Reimplemented from AbstractMultiLineEditor.

BOOLEAN MultiMediaEditor::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::InsertItem

Reimplemented from AbstractMultiLineEditor.

Reimplemented in EmsEditor.

BOOLEAN MultiMediaEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractMultiLineEditor.

void MultiMediaEditor::OnItemMarked ( const AbstractEditorItem * item ) [virtual]

Is invoked, in the read-only-mode, when an Abstract-Editor-Item is marked.

Parameters:
item Marked item (0, if no item is marked).

Reimplemented in EmsEditor.

BOOLEAN MultiMediaEditor::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from AbstractMultiLineEditor.

void MultiMediaEditor::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from AbstractMultiLineEditor.

void MultiMediaEditor::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

See also:
Control::OnPaint

Reimplemented from AbstractMultiLineEditor.

void MultiMediaEditor::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Component::Refresh

Reimplemented from AbstractMultiLineEditor.

BOOLEAN MultiMediaEditor::RemoveItem ( INT index = -1 ) [virtual]

See also:
AbstractEditor::RemoveItem

Reimplemented from AbstractMultiLineEditor.

Reimplemented in EmsEditor.

BOOLEAN MultiMediaEditor::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::ReplaceItem()

Reimplemented from AbstractMultiLineEditor.

Reimplemented in EmsEditor.

void MultiMediaEditor::SetBackgroundColor ( const Color & color )

void MultiMediaEditor::SetBottomLineGap ( UINT8 gap )

Every line of the document may have a gap on bottom of the line. Per default the gap is set to 0.

See also:
MultiMediaEditorDocument::SetBottomLineGap

void MultiMediaEditor::SetFirstVisibleLineIndex ( INT line_idx ) [virtual]

See also:
AbstractMultiLineEditor::SetFirstVisibleLineIndex

Reimplemented from AbstractMultiLineEditor.

void MultiMediaEditor::SetFont ( const Font & font )

void MultiMediaEditor::SetForegroundColor ( const Color & color )

BOOLEAN MultiMediaEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractMultiLineEditor.

void MultiMediaEditor::SetReadOnly ( BOOLEAN read_only ) [virtual]

See also:
AbstractEditor::SetReadOnly

Reimplemented from AbstractEditor.

void MultiMediaEditor::SetTextAttr ( TextAttr text_attr )

void MultiMediaEditor::SetTopLineGap ( UINT8 gap )

Every line of the document may have a gap on top of the line. Per default the gap is set to 0.

See also:
MultiMediaEditorDocument::SetTopLineGap

void MultiMediaEditor::Update ( ) [virtual]

See also:
AbstractEditor::Update()

Reimplemented from AbstractMultiLineEditor.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/MultiMediaEditor.hpp
  • AddOns/MultiMedia/MultiMediaEditor.cpp
Generated on Wed Jan 25 01:30:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiMediaEditorDocument Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiMediaEditorDocument Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/MultiMediaEditorDocument.hpp>

Inheritance diagram for MultiMediaEditorDocument:

[legend]
Collaboration diagram for MultiMediaEditorDocument:

[legend]

Public Member Functions

virtual void | Clear ()
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT item_index, INT count) const
UINT8 | GetBottomLineGap () const
virtual const CompoundItem & | GetCompoundItem (INT ci_index, INT *start_item_index=0) const
virtual INT | GetCompoundItemCount () const
INT | GetCompoundItemIndex (INT item_index) const
virtual INT | GetItemCount () const
virtual void | GetItemScope (INT item_index, INT count, INT sub_index, XYDIM *x, XYDIM *width) const
virtual LineAlignment | GetLineAlignment (INT item_index, INT count) const
virtual XYDIM | GetLineHeight (INT item_index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT item_index, INT count) const
virtual INT | GetMaxItemCount () const
UINT8 | GetTopLineGap () const
virtual BOOLEAN | InsertCompoundItem (CompoundItem *compound_item, INT ci_index=-1)
virtual BOOLEAN | InsertCompoundItemBeforeItem (CompoundItem *compound_item, INT item_index=-1)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT item_index)
virtual BOOLEAN | IsEditableAfterLastItem () const
virtual BOOLEAN | IsRightToLeftItem (INT item_index) const
MultiMediaEditorDocument ()
virtual void | OnChangedLayout (const Vector< EditorLine > &line, INT from=-1, INT count=0)
virtual BOOLEAN | RemoveCompoundItem (INT ci_index=-1)
virtual BOOLEAN | RemoveItem (INT item_index)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT item_index)
void | SetBottomLineGap (UINT8 gap)
void | SetLineAlignment (LineAlignment alignment)
void | SetTopLineGap (UINT8 gap)
virtual INT | WrapLine (INT item_index, XYDIM width, WrapPolicy wrap_policy=WhitespaceWrap) const
virtual | ~MultiMediaEditorDocument ()

Friends

class | CompoundItemIterator

Data Structures

class | TextManager

Detailed Description

May contain a variable number of compound items of any type. When modifying the document directly during the editor is open, don't forget to invoke Editor::Update() after the modification. For doing text operations on the document it is helpful to use the helper class MultiMediaEditorDocument::TextManager.

Constructor & Destructor Documentation

MultiMediaEditorDocument::MultiMediaEditorDocument ( )

MultiMediaEditorDocument::~MultiMediaEditorDocument ( ) [virtual]

Member Function Documentation

void MultiMediaEditorDocument::Clear ( ) [virtual]

See also:
EditorDocument::Clear()

Reimplemented from EditorDocument.

void MultiMediaEditorDocument::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | item_index,
 |  | INT | count
 | ) | const [virtual]

See also:
EditorDocument::Draw()

Implements EditorDocument.

UINT8 MultiMediaEditorDocument::GetBottomLineGap ( ) const

Returns the gap on the bottom of each line of the document.

See also:
SetBottomLineGap

const CompoundItem & MultiMediaEditorDocument::GetCompoundItem | ( | INT | ci_index,
 |  | INT * | start_item_index = 0
 | ) | const [virtual]

See also:
EditorDocument::GetCompoundItem()

Implements EditorDocument.

INT MultiMediaEditorDocument::GetCompoundItemCount ( ) const [virtual]

See also:
EditorDocument::RemoveItem()

Reimplemented from EditorDocument.

INT MultiMediaEditorDocument::GetCompoundItemIndex ( INT item_index ) const

Returns:
Index of the compound-item, where its start-index >= item_index and the index is inside the range of the compound-item.

INT MultiMediaEditorDocument::GetItemCount ( ) const [virtual]

See also:
EditorDocument::GetItemCount()

Implements EditorDocument.

void MultiMediaEditorDocument::GetItemScope | ( | INT | item_index,
 |  | INT | count,
 |  | INT | sub_index,
 |  | XYDIM * | x,
 |  | XYDIM * | width
 | ) | const [virtual]

See also:
EditorDocument::GetItemScope()

Reimplemented from EditorDocument.

LineAlignment MultiMediaEditorDocument::GetLineAlignment | ( | INT | item_index,
 |  | INT | count
 | ) | const [virtual]

See also:
EditorDocument::GetLineAlignment()

Reimplemented from EditorDocument.

XYDIM MultiMediaEditorDocument::GetLineHeight | ( | INT | item_index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
EditorDocument::GetLineHeight()

Implements EditorDocument.

XYDIM MultiMediaEditorDocument::GetLineWidth | ( | INT | item_index,
 |  | INT | count
 | ) | const [virtual]

See also:
EditorDocument::GetLineWidth()

Implements EditorDocument.

INT MultiMediaEditorDocument::GetMaxItemCount ( ) const [virtual]

See also:
EditorDocument::GetMaxItemCount()

Implements EditorDocument.

UINT8 MultiMediaEditorDocument::GetTopLineGap ( ) const

Returns the gap on the top of each line of the document.

See also:
SetTopLineGap

BOOLEAN MultiMediaEditorDocument::InsertCompoundItem | ( | CompoundItem * | compound_item,
 |  | INT | ci_index = -1
 | ) | [virtual]

See also:
EditorDocument::InsertCompoundItem()

Reimplemented from EditorDocument.

BOOLEAN MultiMediaEditorDocument::InsertCompoundItemBeforeItem | ( | CompoundItem * | compound_item,
 |  | INT | item_index = -1
 | ) | [virtual]

See also:
EditorDocument::InsertCompoundItemBeforeItem()

Reimplemented from EditorDocument.

BOOLEAN MultiMediaEditorDocument::InsertItem | ( | const AtomItem & | item,
 |  | INT | item_index
 | ) | [virtual]

See also:
EditorDocument::InsertItem()

Implements EditorDocument.

BOOLEAN MultiMediaEditorDocument::IsEditableAfterLastItem ( ) const [virtual]

See also:
EditorDocument::IsEditableAfterLastItem()

Reimplemented from EditorDocument.

BOOLEAN MultiMediaEditorDocument::IsRightToLeftItem ( INT item_index ) const [virtual]

See also:
EditorDocument::IsRightToLeftItem

Reimplemented from EditorDocument.

void MultiMediaEditorDocument::OnChangedLayout | ( | const Vector< EditorLine > & | line,
 |  | INT | from = -1,
 |  | INT | count = 0
 | ) | [virtual]

See also:
EditorDocument::OnChangedLayout

Reimplemented from EditorDocument.

BOOLEAN MultiMediaEditorDocument::RemoveCompoundItem ( INT ci_index = -1 ) [virtual]

See also:
EditorDocument::RemoveCompoundItem

Reimplemented from EditorDocument.

BOOLEAN MultiMediaEditorDocument::RemoveItem ( INT item_index ) [virtual]

See also:
EditorDocument::RemoveItem()

Implements EditorDocument.

BOOLEAN MultiMediaEditorDocument::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | item_index
 | ) | [virtual]

See also:
EditorDocument::ReplaceItem()

Implements EditorDocument.

void MultiMediaEditorDocument::SetBottomLineGap ( UINT8 gap )

Every line of the document may have a gap on bottom of the line. Per default the gap is set to 0.

void MultiMediaEditorDocument::SetLineAlignment ( LineAlignment alignment )

Sets the line alignment for the whole document. Inserted paragraphs may overwrite this line alignment. See also EditorDocument::GetLineAlignment.

void MultiMediaEditorDocument::SetTopLineGap ( UINT8 gap )

Every line of the document may have a gap on top of the line. Per default the gap is set to 0.

INT MultiMediaEditorDocument::WrapLine | ( | INT | item_index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = WhitespaceWrap
 | ) | const [virtual]

See also:
EditorDocument::WrapLine()

Implements EditorDocument.

Friends And Related Function Documentation

friend class CompoundItemIterator [friend]

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/MultiMediaEditorDocument.hpp
  • AddOns/MultiMedia/MultiMediaEditorDocument.cpp
Generated on Wed Jan 25 01:30:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiMediaEditorDocument::TextManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
MultiMediaEditorDocument::TextManager

MultiMediaEditorDocument::TextManager Class Reference

#include <Apoxi/AddOns/MultiMedia/MultiMediaEditorDocument.hpp>

Collaboration diagram for MultiMediaEditorDocument::TextManager:

[legend]

Public Member Functions

BOOLEAN | InsertText (const WString &text, INT item_index=-1, TextAttr attr=TextFormat::Normal, const Font *font=0, const Color *foreground_color=0, const Color *background_color=0)
BOOLEAN | SetBackgroundColor (INT item_index, INT item_count, const Color &color)
BOOLEAN | SetFont (INT item_index, INT item_count, const Font &font)
BOOLEAN | SetForegroundColor (INT item_index, INT item_count, const Color &color)
BOOLEAN | SetTextAttr (INT item_index, INT item_count, TextAttr attr)
TextManager (MultiMediaEditorDocument &doc)
virtual | ~TextManager ()

Detailed Description

Allows to do text operations on a multimedia editor document in an easy manner. Using this class is not mandatory, as the multimedia editor itself offers all possibilities for text operations too. But the offered methods from the class MultiMediaEditorDocument are very generic and not specialized for text operations. By using the TextManager it is very easy to e. g. underline the whole text inside the document although several images might be embedded already:
MultiMediaEditorDocument::TextManager text_man(doc);
text_man.SetTextAttr(0, doc->GetItemCount(), TextFormat::Underlined);

Constructor & Destructor Documentation

MultiMediaEditorDocument::TextManager::TextManager ( MultiMediaEditorDocument & doc )

Constructs the text manager which operates on the document doc. If the text manager operates on a document which is already opened by an editor, don't forget to invoke Editor::Update() after the modification.

MultiMediaEditorDocument::TextManager::~TextManager ( ) [virtual]

Member Function Documentation

BOOLEAN MultiMediaEditorDocument::TextManager::InsertText | ( | const WString & | text,
 |  | INT | item_index = -1,
 |  | TextAttr | attr = TextFormat::Normal,
 |  | const Font * | font = 0,
 |  | const Color * | foreground_color = 0,
 |  | const Color * | background_color = 0
 | ) |

Inserts a text at the given item index.

Parameters:
text | Text which should be inserted.
item_index | Index of the item where the text should get inserted. If a value < 0 is used, the text will be appended at the end of the document.
text_attr | Attribute of the text (Normal, Underlined, Italic, Bold, Strikethrough). Setting two attributes at the same time can be done the following way: TextAttr text_attr = TextFormat::Italic | TextFormat::Bold;
font | Pointer to the used font. If a null pointer is passed, the font Font::TextEditor is used per default. The passed font object is a read-only parameter which can be deleted immediately after invoking this method.
foreground_color | Background color of the text. If a null-pointer is passed, the background will be transparent. The passed color object is a read-only parameter which can be deleted immediately after invoking this method.
background_color | Foreground color of the text. If a null-pointer is passed, the color Color::ClientForeground will be used. The passed color object is a read-only parameter which can be deleted immediately after invoking this method.
Returns:
TRUE if the inserting of the text has been successful.

BOOLEAN MultiMediaEditorDocument::TextManager::SetBackgroundColor | ( | INT | item_index,
 |  | INT | item_count,
 |  | const Color & | color
 | ) |

Sets the background color of the text for a specified range.

Parameters:
item_index | Index of the first item where the background color should be changed.
item_count | Number of items where the background color should be changed.
color | New background color for the text inside the specified range.
Returns:
TRUE, if the setting of the background color has been successful.

BOOLEAN MultiMediaEditorDocument::TextManager::SetFont | ( | INT | item_index,
 |  | INT | item_count,
 |  | const Font & | font
 | ) |

Sets the font of the text for a specified range.

Parameters:
item_index | Index of the first item where the font should be changed.
item_count | Number of items where the font should be changed.
font | New font for the text inside the specified range.
Returns:
TRUE, if the setting of the font has been successful.

BOOLEAN MultiMediaEditorDocument::TextManager::SetForegroundColor | ( | INT | item_index,
 |  | INT | item_count,
 |  | const Color & | color
 | ) |

Sets the foreground color of the text for a specified range.

Parameters:
item_index | Index of the first item where the foreground color should be changed.
item_count | Number of items where the foreground color should be changed.
color | New foreground color for the text inside the specified range.
Returns:
TRUE, if the setting of the foreground color has been successful.

BOOLEAN MultiMediaEditorDocument::TextManager::SetTextAttr | ( | INT | item_index,
 |  | INT | item_count,
 |  | TextAttr | attr
 | ) |

Sets the text attribute of the text for a specified range (Normal, Underlined, Italic, Bold, Strikethrough). Setting two attributes at the same time can be done the following way: TextAttr text_attr = TextFormat::Italic | TextFormat::Bold;

Parameters:
item_index | Index of the first item where the text attribute should be changed.
item_count | Number of items where the text attribute should be changed.
attr | New text attribute for the text inside the specified range.
Returns:
TRUE, if the setting of the text attribute has been successful.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/MultiMediaEditorDocument.hpp
  • AddOns/MultiMedia/MultiMediaEditorDocument.cpp
Generated on Wed Jan 25 01:30:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiPartData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiPartData Struct Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/MultipartParser.hpp>

Collaboration diagram for MultiPartData:

[legend]

Data Fields

INT | m_bound_num
Boundary number.
INT | m_content_len
INT | m_content_offset
Content information.
Vector< HeaderData > m_header
All name & value Header information is stored inthis vector.

Detailed Description

MultiPartData is a used to store the parsed information for a given bounday number. If memory is allocated, it is responcibility of user to free it

Field Documentation

INT MultiPartData::m_bound_num

Boundary number.

INT MultiPartData::m_content_len

INT MultiPartData::m_content_offset

Content information.

Vector<HeaderData> MultiPartData::m_header

All name & value Header information is stored inthis vector.

The documentation for this struct was generated from the following file:
  • AddOns/Drm/MultipartParser.hpp
Generated on Wed Jan 25 01:30:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultipartParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultipartParser Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/MultipartParser.hpp>

Public Member Functions

MultipartParser ()
~MultipartParser ()

Static Public Member Functions

static INT | GetIndexForValue (CHAR *header_name, MultiPartData *data)
static INT | GetNumBoundaries (const CHAR *msg, INT len)
static INT | GetNumBoundaries (const String &msg)
static INT | GetNumBoundaries (const BinData &msg)
static INT | Parse (const CHAR *msg, INT len, INT bound_num, MultiPartData *data)
static INT | Parse (const String &msg, INT bound_num, MultiPartData *data)
static INT | Parse (const BinData &msg, INT bound_num, MultiPartData *data)

Detailed Description

MultipartParser is used to parse the multipart message. The class provides functionality to get the
  • Number of parts in the message,
  • Parse the message to get header fields, content offset and length. Each header field is stored in a vector as header name & value pair for a given boundary number

Constructor & Destructor Documentation

MultipartParser::MultipartParser ( )

MultipartParser::~MultipartParser ( )

Member Function Documentation

INT MultipartParser::GetIndexForValue | ( | CHAR * | header_name,
 |  | MultiPartData * | data
 | ) | [static]

GetIndexForValue The function searches for the given header name in the vector, if found returns the index.

Parameters:
header_name | Name of the header field in the vector
data | parsed information, which contains the vector
Returns:
Curresponding vector ndex for the given header name OR Error code

INT MultipartParser::GetNumBoundaries | ( | const CHAR * | msg,
 |  | INT | len
 | ) | [static]

INT MultipartParser::GetNumBoundaries ( const String & msg ) [static]

INT MultipartParser::GetNumBoundaries ( const BinData & msg ) [static]

GetNumBoundaries Gets the number of boundaries in the given multipart message.

Parameters:
msg Referance/Pointer to the message
Returns:
Number of boundaries in the message / Parsing error code.

INT MultipartParser::Parse | ( | const CHAR * | msg,
 |  | INT | len,
 |  | INT | bound_num,
 |  | MultiPartData * | data
 | ) | [static]

INT MultipartParser::Parse | ( | const String & | msg,
 |  | INT | bound_num,
 |  | MultiPartData * | data
 | ) | [static]

INT MultipartParser::Parse | ( | const BinData & | msg,
 |  | INT | bound_num,
 |  | MultiPartData * | data
 | ) | [static]

Parse Parses the multipart message to get header information and content information for the given boundary.

Parameters:
msg | Referance/Poiner to the message.
bound_num | Bounday number of the message to be parsed.
data | pointer varibale in which parsed information is filled up.
Returns:
Success OR multipart parser error code

The documentation for this class was generated from the following files:
  • AddOns/Drm/MultipartParser.hpp
  • AddOns/Drm/MultipartParser.cpp
Generated on Wed Jan 25 01:30:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiPartyCallInvokedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiPartyCallInvokedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for MultiPartyCallInvokedMsg:

[legend]
Collaboration diagram for MultiPartyCallInvokedMsg:

[legend]

Public Types

enum | { ID = 18534 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
MultiPartyCallInvokedMsg (ExecutionContext *context, const Tipd &tipd)
virtual | ~MultiPartyCallInvokedMsg ()

Detailed Description

MultiPartyCallInvokedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MultiPartyCallInvokedMsg::MultiPartyCallInvokedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd
 | ) |

MultiPartyCallInvokedMsg::~MultiPartyCallInvokedMsg ( ) [virtual]

Member Function Documentation

Message * MultiPartyCallInvokedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & MultiPartyCallInvokedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& MultiPartyCallInvokedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:30:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiSlotDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiSlotDispatcher Class Reference

Active Wait Dispatcher to catch the OmRatChangeCnf-Message-Arg. More...

#include <Apoxi/Asc/MultiSlotDispatcher.hpp>

Inheritance diagram for MultiSlotDispatcher:

[legend]
Collaboration diagram for MultiSlotDispatcher:

[legend]

Public Member Functions

BOOLEAN | GetMultiModeSetResult ()
MultiSlotDispatcher ()
Constructor.
virtual | ~MultiSlotDispatcher ()
Destructor.

Protected Member Functions

BOOLEAN | OnOmMultiSlotInd (const StackMsgArgument &arg)

Detailed Description

Active Wait Dispatcher to catch the OmRatChangeCnf-Message-Arg.

Constructor & Destructor Documentation

MultiSlotDispatcher::MultiSlotDispatcher ( )

Constructor.

MultiSlotDispatcher::~MultiSlotDispatcher ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN MultiSlotDispatcher::GetMultiModeSetResult ( ) [inline]

BOOLEAN MultiSlotDispatcher::OnOmMultiSlotInd ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/MultiSlotDispatcher.hpp
  • Asc/MultiSlotDispatcher.cpp
Generated on Wed Jan 25 01:30:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiSlotHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiSlotHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/MultiSlotHandler.hpp>

Collaboration diagram for MultiSlotHandler:

[legend]

Public Types

enum | { ID = MultiSlotHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
MultiSlotHandler ()
BOOLEAN | SetMultiSlot (MultiSlotMode multi_slot_mode)
virtual | ~MultiSlotHandler ()

Detailed Description

The MultiSlotHandler holds the functionality for setting the MultiSlotMode setting indication load level.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

MultiSlotHandler::MultiSlotHandler ( )

MultiSlotHandler::~MultiSlotHandler ( ) [virtual]

Member Function Documentation

HandlerId MultiSlotHandler::GetHandlerId ( ) const [virtual]

BOOLEAN MultiSlotHandler::SetMultiSlot ( MultiSlotMode multi_slot_mode )

The documentation for this class was generated from the following files:
  • Asc/MultiSlotHandler.hpp
  • Asc/MultiSlotHandler.cpp
Generated on Wed Jan 25 01:30:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiSlotMode Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiSlotMode Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

MultiSlotMode ()
MultiSlotMode | operator= (T_MULTI_SLOT multi_slot)

Data Fields

UINT8 | multi_slot_class

Constructor & Destructor Documentation

MultiSlotMode::MultiSlotMode ( ) [inline]

Member Function Documentation

MultiSlotMode MultiSlotMode::operator= ( T_MULTI_SLOT multi_slot )

Field Documentation

UINT8 MultiSlotMode::multi_slot_class

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:30:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiTapCaret Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiTapCaret Class Reference
[Editors]

Caret specialized for multi-tab input-mode. More...

#include <Apoxi/Gui/MultiTapCaret.hpp>

Inheritance diagram for MultiTapCaret:

[legend]
Collaboration diagram for MultiTapCaret:

[legend]

Public Member Functions

virtual void | Draw (DeviceContext *dc, const Rect &bounds, BOOLEAN right_to_left=FALSE) const
virtual XYDIM | GetMinimalWidth () const
const WCHAR * | GetPreview (INT *prev_idx=0) const
BOOLEAN | IsTabbing () const
MultiTapCaret (AbstractEditor *editor, UINT32 blink_rate, BOOLEAN show_preview=TRUE, Caret::Mode mode=Insert)
MultiTapCaret ()
void | SetPreview (const WCHAR *preview, INT index)
void | SetTabbing (BOOLEAN flag)
virtual void | ShowHint () const
virtual | ~MultiTapCaret ()

Detailed Description

Caret specialized for multi-tab input-mode.

Constructor & Destructor Documentation

MultiTapCaret::MultiTapCaret ( )

MultiTapCaret::MultiTapCaret | ( | AbstractEditor * | editor,
 |  | UINT32 | blink_rate,
 |  | BOOLEAN | show_preview = TRUE,
 |  | Caret::Mode | mode = Insert
 | ) |

Parameters:
editor | Pointer to the corresponding editor.
blink_rate | Blink speed of the caret.
show_preview | When TRUE, the preview of the tabbing is shown inside the editor.
mode | See Caret::Mode.

MultiTapCaret::~MultiTapCaret ( ) [virtual]

Member Function Documentation

void MultiTapCaret::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds,
 |  | BOOLEAN | right_to_left = FALSE
 | ) | const [virtual]

See also:
Caret::Draw()

Reimplemented from DefaultCaret.

XYDIM MultiTapCaret::GetMinimalWidth ( ) const [virtual]

See also:
Caret::GetMinimalWidth()

Reimplemented from DefaultCaret.

const WCHAR * MultiTapCaret::GetPreview ( INT * prev_idx = 0 ) const

BOOLEAN MultiTapCaret::IsTabbing ( ) const [inline]

void MultiTapCaret::SetPreview | ( | const WCHAR * | preview,
 |  | INT | index
 | ) |

void MultiTapCaret::SetTabbing ( BOOLEAN flag ) [inline]

void MultiTapCaret::ShowHint ( ) const [virtual]

See also:
Caret::ShowHint()

Reimplemented from Caret.

The documentation for this class was generated from the following files:
  • Gui/MultiTapCaret.hpp
  • Gui/MultiTapCaret.cpp
Generated on Wed Jan 25 01:31:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiTapInputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MultiTapInputMapper Class Reference
[Editors]

#include <Apoxi/Gui/MultiTapInputMapper.hpp>

Inheritance diagram for MultiTapInputMapper:

[legend]
Collaboration diagram for MultiTapInputMapper:

[legend]

Public Types

enum | CapitalizationMode { UserTriggeredCapitalization, AutoCapitalization, NameCapitalization }

Public Member Functions

virtual Alphabet | GetAlphabet () const
virtual Caret * | GetCaret ()
virtual INT | GetId () const
MultiTapInputMapper (BOOLEAN show_preview=TRUE, Alphabet alphabet=InputMapper::Ucs2Alphabet, CapitalizationMode capitalization_mode=UserTriggeredCapitalization)
virtual void | SetEditor (AbstractEditor *editor)
virtual | ~MultiTapInputMapper ()

Protected Member Functions

virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Friends

class | TriggerTimer< MultiTapInputMapper >

Detailed Description

Manages the input of characters by the multi-tap method. E. g. pressing the key 2 once results in an 'a', pressing key 2 twice results in 'b'.

Member Enumeration Documentation

enum MultiTapInputMapper::CapitalizationMode

Defines the mode which is used for the capitalization of characters.

Enumerator:
UserTriggeredCapitalization | The user must explicitly switch between upper and lower case.
AutoCapitalization | After a punctuation mark followed by a blank the next character is switched to upper case automatically.
NameCapitalization | After a blank the next character is switched to upper case automatically. This mode is useful for editing names.

Constructor & Destructor Documentation

MultiTapInputMapper::MultiTapInputMapper | ( | BOOLEAN | show_preview = TRUE,
 |  | Alphabet | alphabet = InputMapper::Ucs2Alphabet,
 |  | CapitalizationMode | capitalization_mode = UserTriggeredCapitalization
 | ) | [explicit]

Parameters:
show_preview | If set to TRUE, a small box containing the available characters to a key is popped up dynamically.
alphabet | The multitap input-mapper may be configured to any kind of alphabet defined in GPP TS 23038 V430 (2001-09). Note that the paging-map-entries defined in LocaleConfig::GetPagingMap should correspond to the alphabet, otherwise the character will not be inserted by the input-mapper.
capitalization_mode | Defines the capitalization mode (see CapitalizationMode). Per default the mode CapitalizationMode::UserTriggeredCapitalization is used.

MultiTapInputMapper::~MultiTapInputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet MultiTapInputMapper::GetAlphabet ( ) const [virtual]

Returns the alphabet specified by the constructor.

See also:
InputMapper::GetAlphabet.

Reimplemented from InputMapper.

Caret * MultiTapInputMapper::GetCaret ( ) [virtual]

See also:
InputMapper::GetCaret()

Reimplemented from InputMapper.

INT MultiTapInputMapper::GetId ( ) const [virtual]

See also:
InputMapper::GetId()

Implements InputMapper.

BOOLEAN MultiTapInputMapper::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
InputMapper::OnKeyDown()

Reimplemented from InputMapper.

void MultiTapInputMapper::SetEditor ( AbstractEditor * editor ) [virtual]

See also:
InputMapper::SetEditor()

Reimplemented from InputMapper.

Friends And Related Function Documentation

friend class TriggerTimer< MultiTapInputMapper > [friend]

The documentation for this class was generated from the following files:
  • Gui/MultiTapInputMapper.hpp
  • Gui/MultiTapInputMapper.cpp
Generated on Wed Jan 25 01:31:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Mutex Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Mutex Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/Mutex.hpp>

Inheritance diagram for Mutex:

[legend]
Collaboration diagram for Mutex:

[legend]

Public Member Functions

BOOLEAN | Create (BOOLEAN locked=TRUE)
Mutex ()
BOOLEAN | Obtain (const Ticks &timeout=Ticks::Infinite())
void | Release ()
virtual | ~Mutex ()

Detailed Description

When two or more threads need to access a shared resource at the same time, synchronization is a coordination process to ensure that the resource is used by only one thread at a time. Mutex is a synchronization primitive that allows exclusive access to the shared resource to only one thread. If the mutex lock of an object is acquired by a thread, the second thread that wants to acquire the lock is suspended until the lock is released by the first thread.

Constructor & Destructor Documentation

Mutex::Mutex ( )

Mutex::~Mutex ( ) [virtual]

Member Function Documentation

BOOLEAN Mutex::Create ( BOOLEAN locked = TRUE )

Parameters:
locked TRUE to create the mutex in non-signaled state, FALSE for signaled state.

BOOLEAN Mutex::Obtain ( const Ticks & timeout = Ticks::Infinite() )

Obtain is used to request ownership of the mutex. The state of the mutex is signaled if no thread owns it. The thread that owns a mutex can specify the same mutex in repeated Obtain function calls without blocking its execution.

Parameters:
timeout Specifies the time-out interval, in milliseconds.
Returns:
TRUE if the state is signaled. FALSE if the time-out interval elapsed.

void Mutex::Release ( )

The thread must call Release the same number of times to release ownership of the mutex lock.

The documentation for this class was generated from the following files:
  • Kernel/Os/Mutex.hpp
  • Kernel/Os/Mutex.cpp
Generated on Wed Jan 25 01:31:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MutexObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MutexObtainer Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/MutexObtainer.hpp>

Inheritance diagram for MutexObtainer:

[legend]
Collaboration diagram for MutexObtainer:

[legend]

Public Member Functions

BOOLEAN | IsObtained () const
MutexObtainer (Mutex *mtx)
MutexObtainer (Mutex *mtx, const Ticks &timeout)
BOOLEAN | Obtain ()
BOOLEAN | Obtain (const Ticks &timeout)
void | Release ()
~MutexObtainer ()

Detailed Description

Obtains a mutex in the constructor and automatically releases the mutex in the destructor.

Constructor & Destructor Documentation

MutexObtainer::MutexObtainer | ( | Mutex * | mtx,
 |  | const Ticks & | timeout
 | ) |

Obtains the mutex mtx.

Parameters:
mtx | Pointer to the mutex, which should be obtained.
timeout | Timeout for obtaining.

MutexObtainer::MutexObtainer ( Mutex * mtx )

Instead of calling MutexObtainer(mtc, Ticks::Infinite())

MutexObtainer::~MutexObtainer ( ) [inline]

Releases the mutex, if it has not already been released by Release.

Member Function Documentation

BOOLEAN MutexObtainer::IsObtained ( ) const [inline]

Returns:
TRUE, if the mutex is obtained.

BOOLEAN MutexObtainer::Obtain ( )

See also:
Mutex::Obtain

BOOLEAN MutexObtainer::Obtain ( const Ticks & timeout )

See also:
Mutex::Obtain

void MutexObtainer::Release ( )

See also:
Mutex::Release

The documentation for this class was generated from the following files:
  • Kernel/Os/MutexObtainer.hpp
  • Kernel/Os/MutexObtainer.cpp
Generated on Wed Jan 25 01:31:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NameIndicator Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NameIndicator Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for NameIndicator:

[legend]

Data Fields

CallingName calling_name
BOOLEAN name_indicator_present

Field Documentation

CallingName NameIndicator::calling_name

BOOLEAN NameIndicator::name_indicator_present

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:31:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NamePatternFileFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NamePatternFileFilter Class Reference
[Root File System]

File filter filtering files by a name pattern More...

#include <Apoxi/Afs/Rfs/FileFilter.hpp>

Inheritance diagram for NamePatternFileFilter:

[legend]
Collaboration diagram for NamePatternFileFilter:

[legend]

Public Member Functions

virtual BOOLEAN | Complies (const Path &path)
const WString & | GetNamePattern () const
Returns the name pattern.
NamePatternFileFilter (const WString &name_pattern, BOOLEAN case_sensitive=TRUE, BOOLEAN filter_dirs=FALSE)

Protected Member Functions

virtual | ~NamePatternFileFilter ()
Destroys a name pattern file filter.

Protected Attributes

BOOLEAN | m_case_sensitive
Flag indicating case sensitivity during file name compare.
BOOLEAN | m_filter_dirs
Tells if directories shall be filtered.
WString m_name_pattern
The pattern for the file names to iterate on.

Detailed Description

File filter filtering files by a name pattern

Class NamePatternFileFilter is a predefined file filter functor which filters files by comparing the filename to a name pattern which is allowed to contain the asterisk * and/or question mark ? wildcards. Optionally directories get filtered, too.

Constructor & Destructor Documentation

NamePatternFileFilter::NamePatternFileFilter | ( | const WString & | name_pattern,
 |  | BOOLEAN | case_sensitive = TRUE,
 |  | BOOLEAN | filter_dirs = FALSE
 | ) |

Constructs a name pattern file filter. The name_pattern is allowed to contain the wildcards * and/or ?. Argument case_sensitive specifies whether the name pattern is treated case sensitive or not. If filter_dirs is TRUE then all directories get filtered, too.

Parameters:
name_pattern | A name pattern optionally using wildcards * and/or ?.
case_sensitive | Case sensitivity of name pattern.
filter_dirs | Tells if directories shall be filtered.

NamePatternFileFilter::~NamePatternFileFilter ( ) [protected, virtual]

Destroys a name pattern file filter.

Member Function Documentation

BOOLEAN NamePatternFileFilter::Complies ( const Path & path ) [virtual]

Tells if the file with path complies with the name pattern specified on construction or is a directory in case it shall filter directories, too.

Parameters:
path The path of the file to filter.
Returns:
Tells if the file with path complies with the filter.

Implements FileFilter.

const WString& NamePatternFileFilter::GetNamePattern ( ) const [inline]

Returns the name pattern.

Field Documentation

BOOLEAN NamePatternFileFilter::m_case_sensitive [protected]

Flag indicating case sensitivity during file name compare.

BOOLEAN NamePatternFileFilter::m_filter_dirs [protected]

Tells if directories shall be filtered.

WString NamePatternFileFilter::m_name_pattern [protected]

The pattern for the file names to iterate on.

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileFilter.hpp
  • Afs/Rfs/FileFilter.cpp
Generated on Wed Jan 25 01:31:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NamePatternStorageDeviceFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NamePatternStorageDeviceFilter Class Reference
[Root File System]

Storage device filter filtering storage devices by a name pattern. More...

#include <Apoxi/Afs/Rfs/StorageDeviceFilter.hpp>

Inheritance diagram for NamePatternStorageDeviceFilter:

[legend]
Collaboration diagram for NamePatternStorageDeviceFilter:

[legend]

Public Member Functions

virtual BOOLEAN | Complies (const StorageDevicePtr &device)
NamePatternStorageDeviceFilter (const WString &name_pattern)

Protected Member Functions

virtual | ~NamePatternStorageDeviceFilter ()
Destroys a storage device filter.

Protected Attributes

WString m_name_pattern
The pattern for the device Id strings to iterate on.

Detailed Description

Storage device filter filtering storage devices by a name pattern.

Class NamePatternStorageDeviceFilter is a predefined storage device filter functor which filters storage devices by comparing the storage device Id string to a name pattern which is allowed to contain the asterisk * and/or question mark ? wildcards.

Constructor & Destructor Documentation

NamePatternStorageDeviceFilter::NamePatternStorageDeviceFilter ( const WString & name_pattern )

Constructs a name pattern storage device filter. The filter is initialized with the name pattern which is allowed to contain the wildcards * and/or ?.

Parameters:
name_pattern A name pattern optionally using wildcards * and/or ?.

NamePatternStorageDeviceFilter::~NamePatternStorageDeviceFilter ( ) [protected, virtual]

Destroys a storage device filter.

Member Function Documentation

BOOLEAN NamePatternStorageDeviceFilter::Complies ( const StorageDevicePtr & device ) [virtual]

Tells if the device Id string of device complies with the name pattern m_name_pattern.

Parameters:
device The storage device smart-pointer.
Returns:
Tells if device complies with the filter.

Implements StorageDeviceFilter.

Field Documentation

WString NamePatternStorageDeviceFilter::m_name_pattern [protected]

The pattern for the device Id strings to iterate on.

The documentation for this class was generated from the following files:
  • Afs/Rfs/StorageDeviceFilter.hpp
  • Afs/Rfs/StorageDeviceFilter.cpp
Generated on Wed Jan 25 01:31:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Native16Bit Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Native16Bit Class Reference

#include <Apoxi/Kernel/MachType.hpp>

Inheritance diagram for Native16Bit:

[legend]
Collaboration diagram for Native16Bit:

[legend]

Public Member Functions

Native16Bit (const LittleEndian16Bit &v)
Native16Bit (const BigEndian16Bit &v)
Native16Bit (UINT16 v=0)
Native16Bit & | operator= (const LittleEndian16Bit &v)
Native16Bit & | operator= (const BigEndian16Bit &v)

Detailed Description

Native16Bit defines a 16 bit unsigned integer value in format of the native target architecture (little or big endian)

Constructor & Destructor Documentation

Native16Bit::Native16Bit ( UINT16 v = 0 ) [inline]

Constructs a native integer from a native value

Native16Bit::Native16Bit ( const BigEndian16Bit & v ) [inline]

Constructs a native integer from a big endian value. If native architecture uses big endian, the conversion expands to a null statement

Native16Bit::Native16Bit ( const LittleEndian16Bit & v ) [inline]

Constructs a native number from a little endian value. If native architecture uses little endian, the conversion expands to a null statement

Member Function Documentation

Native16Bit & Native16Bit::operator= ( const LittleEndian16Bit & v ) [inline]

Assigns little endian number to native number

Native16Bit & Native16Bit::operator= ( const BigEndian16Bit & v ) [inline]

Assigns big endian number to native number

Reimplemented from LittleEndian16Bit.

The documentation for this class was generated from the following file:
  • Kernel/MachType.hpp
Generated on Wed Jan 25 01:31:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Native32Bit Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Native32Bit Class Reference

#include <Apoxi/Kernel/MachType.hpp>

Inheritance diagram for Native32Bit:

[legend]
Collaboration diagram for Native32Bit:

[legend]

Public Member Functions

Native32Bit (const LittleEndian32Bit &v)
Native32Bit (const BigEndian32Bit &v)
Native32Bit (UINT32 v=0)
Native32Bit & | operator= (const LittleEndian32Bit &v)
Native32Bit & | operator= (const BigEndian32Bit &v)

Detailed Description

Native32Bit defines a 32 bit unsigned integer value in format of the native target architecture (little or big endian)

Constructor & Destructor Documentation

Native32Bit::Native32Bit ( UINT32 v = 0 ) [inline]

Constructs a native integer from a native value

Native32Bit::Native32Bit ( const BigEndian32Bit & v ) [inline]

Constructs a native integer from a big endian value. If native architecture uses big endian, the conversion expands to a null statement

Native32Bit::Native32Bit ( const LittleEndian32Bit & v ) [inline]

Constructs a native number from a little endian value. If native architecture uses little endian, the conversion expands to a null statement

Member Function Documentation

Native32Bit & Native32Bit::operator= ( const LittleEndian32Bit & v ) [inline]

Assigns little endian number to native number

Native32Bit & Native32Bit::operator= ( const BigEndian32Bit & v ) [inline]

Assigns big endian number to native number

Reimplemented from LittleEndian32Bit.

The documentation for this class was generated from the following file:
  • Kernel/MachType.hpp
Generated on Wed Jan 25 01:31:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NativeImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NativeImage Class Reference
[GUI]

#include <Apoxi/Gui/NativeImage.hpp>

Inheritance diagram for NativeImage:

[legend]
Collaboration diagram for NativeImage:

[legend]

Public Types

enum | { ID = 6 }

Public Member Functions

virtual BOOLEAN | DecodeSynchronously () const
virtual BOOLEAN | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT frame_idx, XYDIM scaled_width=-1, XYDIM scaled_height=-1, const Rect &clip_rect=Rect()) const
virtual const BinData * | GetBinData () const
virtual UINT32 | GetFrameDelay (INT frame_idx) const
virtual INT | GetNextFrame (INT frame_idx) const
void | Init (const BitmapRes *const *animation_res, INT frame_count, UINT32 frame_delay=0)
void | Init (BinData *bin_data)
void | Init (const BitmapRes *bitmap_res)
void | Init (Bitmap *bitmap)
BOOLEAN | IsCompressed (INT frame_idx=0) const
Returns TRUE if the image is compressed with run length encoding.
virtual BOOLEAN | IsCopyrighted () const
Returns TRUE if the image is marked as copyrighted.
virtual BOOLEAN | IsInstanceOf (INT id) const
NativeImage (const BitmapRes *const *animation_res, UINT frame_count, UINT32 frame_delay=0)
NativeImage (BinData *bin_data)
NativeImage (const BitmapRes *bitmap_res)
NativeImage (Bitmap *bitmap)
NativeImage ()
void | SetFrameDelay (UINT32 frame_delay)
virtual | ~NativeImage ()

Protected Member Functions

virtual void * | BeginScanlineDrawing (INT frame_idx) const
virtual void | DrawScanline (void *context, DeviceContext *dc, XYDIM x, XYDIM y, INT scanline_idx, INT old_scanline_idx) const
virtual void | EndScanlineDrawing (void *context) const
virtual ColorValue | GetTransparentColor (void *context) const
virtual BOOLEAN | IsTransparent (void *context) const

Friends

class | NativeImageDecoder

Detailed Description

The class NativeImage is a wrapper-class for APOXI-bitmaps. A native image can hold a reference to an instance of the class Bitmap, BitmapRes or a BitmapRes-animation. APOXI-bitmaps usually need more memory than e. g. a GIF image or JPEG image, but may be drawn very fast. It is also possible to read APOXI-bitmaps out of a binary data stream, which may be generated with the APOXI Resource Compiler.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Image.

Constructor & Destructor Documentation

NativeImage::NativeImage ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

NativeImage::NativeImage ( Bitmap * bitmap )

Parameters:
bitmap Pointer to a bitmap.

NativeImage::NativeImage ( const BitmapRes * bitmap_res )

Parameters:
BitmapRes Pointer to an bitmap resource.

NativeImage::NativeImage ( BinData * bin_data )

Parameters:
bin_data Pointer to a binary data stream which contains the native image data. After passing the binary data stream, the stream is obtained by the native image and hence automatically released in the destructor of the native image. A native-image-data-stream can be generated with the APOXI Resource Compiler.

NativeImage::NativeImage | ( | const BitmapRes *const * | animation_res,
 |  | UINT | frame_count,
 |  | UINT32 | frame_delay = 0
 | ) |

Initializes the native image with an animation represented by an array of bitmap resources.

Parameters:
animation_res | Pointer to an array of bitmap-pointers.
frame_count | Number of bitmaps specified by the bitmap-array.
frame_delay | The delay given in milliseconds between 2 frames. If frame_delay is 0, the default-value will be used.

NativeImage::~NativeImage ( ) [virtual]

Member Function Documentation

void * NativeImage::BeginScanlineDrawing ( INT frame_idx ) const [protected, virtual]

See also:
Image::BeginScanlineDrawing

Reimplemented from Image.

BOOLEAN NativeImage::DecodeSynchronously ( ) const [virtual]

Returns TRUE.

See also:
Image::DecodeSynchronously

Reimplemented from Image.

BOOLEAN NativeImage::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | frame_idx,
 |  | XYDIM | scaled_width = -1,
 |  | XYDIM | scaled_height = -1,
 |  | const Rect & | clip_rect = Rect()
 | ) | const [virtual]

See also:
Image::Draw

Reimplemented from Image.

void NativeImage::DrawScanline | ( | void * | context,
 |  | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

See also:
Image::DrawScanline

Reimplemented from Image.

void NativeImage::EndScanlineDrawing ( void * context ) const [protected, virtual]

See also:
Image::EndScanlineDrawing

Reimplemented from Image.

const BinData * NativeImage::GetBinData ( ) const [virtual]

See also:
Image::GetBinData

Reimplemented from Image.

UINT32 NativeImage::GetFrameDelay ( INT frame_idx ) const [virtual]

See also:
Image::GetFrameDelay

Implements Image.

INT NativeImage::GetNextFrame ( INT frame_idx ) const [virtual]

See also:
Image::GetNextFrame

Implements Image.

ColorValue NativeImage::GetTransparentColor ( void * context ) const [protected, virtual]

See also:
Image::GetTransparentColor

Reimplemented from Image.

void NativeImage::Init | ( | const BitmapRes *const * | animation_res,
 |  | INT | frame_count,
 |  | UINT32 | frame_delay = 0
 | ) |

Initializes the NativeImage with an animation represented by an array of bitmap resources.

Parameters:
animation_res | Pointer to an array of bitmap-pointers.
frame_count | Number of bitmaps specified by the bitmap-array.
frame_delay | The delay given in milliseconds between 2 frames. If frame_delay is 0, the default-value will be used.

void NativeImage::Init ( BinData * bin_data )

Parameters:
bin_data Pointer to a binary data stream which contains the native image data. After passing the binary data stream, the stream is obtained by the native image and hence automatically released in the destructor of the native image. A native-image-data-stream can be generated with the APOXI Resource Compiler.

void NativeImage::Init ( const BitmapRes * bitmap_res )

Parameters:
bitmap_res Pointer to an bitmap resource.

void NativeImage::Init ( Bitmap * bitmap )

Parameters:
bitmap Pointer to a bitmap.

BOOLEAN NativeImage::IsCompressed ( INT frame_idx = 0 ) const

Returns TRUE if the image is compressed with run length encoding.

BOOLEAN NativeImage::IsCopyrighted ( ) const [virtual]

Returns TRUE if the image is marked as copyrighted.

Reimplemented from Image.

BOOLEAN NativeImage::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Image.

BOOLEAN NativeImage::IsTransparent ( void * context ) const [protected, virtual]

See also:
Image::IsTransparent

Reimplemented from Image.

void NativeImage::SetFrameDelay ( UINT32 frame_delay )

Sets the delay given in milliseconds between 2 frames. If frame_delay is 0, the default-value will be used.

Friends And Related Function Documentation

friend class NativeImageDecoder [friend]

The documentation for this class was generated from the following files:
  • Gui/NativeImage.hpp
  • Gui/NativeImage.cpp
Generated on Wed Jan 25 01:31:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NeighbourCell Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NeighbourCell Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for NeighbourCell:

[legend]

Public Member Functions

BOOLEAN | IsArfcnInvalid ()
BOOLEAN | IsBsicInvalid ()
BOOLEAN | IsC1Invalid ()
BOOLEAN | IsC2Invalid ()
BOOLEAN | IsC31Invalid ()
BOOLEAN | IsC32Invalid ()
BOOLEAN | IsCellIdInvalid ()
BOOLEAN | IsLacInvalid ()
BOOLEAN | IsMccInvalid ()
BOOLEAN | IsMncInvalid ()
BOOLEAN | IsPlmnInvalid ()
BOOLEAN | IsRankingValueInvalid ()
BOOLEAN | IsRankPosInvalid ()
BOOLEAN | IsRxlevInvalid ()
NeighbourCell ()
NeighbourCell | operator= (T_NCELL_PARAM ncell_param)

Data Fields

UINT16 | arfcn
BYTE | bsic
INT | c1
INT | c2
INT | c31
INT | c32
UINT16 | cell_id
UINT16 | lac
UINT16 | mcc
UINT16 | mnc
Plmn plmn
UINT8 | rank_pos
EmRankingStatus ranking_status
UINT16 | ranking_value
SignalStrengthLevel rxlev

Constructor & Destructor Documentation

NeighbourCell::NeighbourCell ( ) [inline]

Member Function Documentation

BOOLEAN NeighbourCell::IsArfcnInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsBsicInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsC1Invalid ( ) [inline]

BOOLEAN NeighbourCell::IsC2Invalid ( ) [inline]

BOOLEAN NeighbourCell::IsC31Invalid ( ) [inline]

BOOLEAN NeighbourCell::IsC32Invalid ( ) [inline]

BOOLEAN NeighbourCell::IsCellIdInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsLacInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsMccInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsMncInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsPlmnInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsRankingValueInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsRankPosInvalid ( ) [inline]

BOOLEAN NeighbourCell::IsRxlevInvalid ( ) [inline]

NeighbourCell NeighbourCell::operator= ( T_NCELL_PARAM ncell_param )

Field Documentation

UINT16 NeighbourCell::arfcn

BYTE NeighbourCell::bsic

INT NeighbourCell::c1

INT NeighbourCell::c2

INT NeighbourCell::c31

INT NeighbourCell::c32

UINT16 NeighbourCell::cell_id

UINT16 NeighbourCell::lac

UINT16 NeighbourCell::mcc

UINT16 NeighbourCell::mnc

Plmn NeighbourCell::plmn

UINT8 NeighbourCell::rank_pos

EmRankingStatus NeighbourCell::ranking_status

UINT16 NeighbourCell::ranking_value

SignalStrengthLevel NeighbourCell::rxlev

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:31:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NeighbourCellList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NeighbourCellList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for NeighbourCellList:

[legend]

Public Types

enum | { MaxListSize = MAX_NCELL_PARAM }

Public Member Functions

BOOLEAN | IsEmpty ()
NeighbourCellList | operator= (T_GSM_NCELL_PARAM_LIST gsm_ncell_param_list)
NeighbourCell & | operator[] (INT index)

Data Fields

NeighbourCell | neighbour_cells [MaxListSize]
UINT8 | nr_of_cells

Member Enumeration Documentation

anonymous enum

Enumerator:
MaxListSize

Member Function Documentation

BOOLEAN NeighbourCellList::IsEmpty ( ) [inline]

NeighbourCellList NeighbourCellList::operator= ( T_GSM_NCELL_PARAM_LIST gsm_ncell_param_list )

NeighbourCell& NeighbourCellList::operator[] ( INT index ) [inline]

Field Documentation

NeighbourCell NeighbourCellList::neighbour_cells[MaxListSize]

UINT8 NeighbourCellList::nr_of_cells

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:31:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetAdapter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NetAdapter Class Reference

#include <Apoxi/Socket/NetAdapterHandler.hpp>

Inheritance diagram for NetAdapter:

[legend]
Collaboration diagram for NetAdapter:

[legend]

Public Types

enum | Event { c_event_data_sent, c_event_data_received, c_event_adapter_closed }
typedef UINT | Id
enum | Type { c_type_udp, c_type_tcp }

Public Member Functions

Id | GetId () const
Type | GetType () const
NetAdapter (NetAdapterHandler *handler, Id id, Type type)

Protected Attributes

NetAdapterHandler * m_handler
Id m_id
Type m_type

Data Structures

struct | DataReceivedEventArgs
struct | DataSentEventArgs
struct | EventArgs

Member Typedef Documentation

typedef UINT NetAdapter::Id

NetAdapter identifier.

Member Enumeration Documentation

enum NetAdapter::Event

NetAdapter events.

Enumerator:
c_event_data_sent
c_event_data_received
c_event_adapter_closed

enum NetAdapter::Type

NetAdapter types.

Enumerator:
c_type_udp
c_type_tcp

Constructor & Destructor Documentation

NetAdapter::NetAdapter | ( | NetAdapterHandler * | handler,
 |  | Id | id,
 |  | Type | type
 | ) |

Member Function Documentation

Id NetAdapter::GetId ( ) const [inline]

Type NetAdapter::GetType ( ) const [inline]

Field Documentation

NetAdapterHandler* NetAdapter::m_handler [protected]

Id NetAdapter::m_id [protected]

Type NetAdapter::m_type [protected]

The documentation for this class was generated from the following files:
  • Socket/NetAdapterHandler.hpp
  • Socket/NetAdapterHandler.cpp
Generated on Wed Jan 25 01:31:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetAdapter::DataReceivedEventArgs Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
NetAdapter::DataReceivedEventArgs

NetAdapter::DataReceivedEventArgs Struct Reference

#include <Apoxi/Socket/NetAdapterHandler.hpp>

Inheritance diagram for NetAdapter::DataReceivedEventArgs:

[legend]
Collaboration diagram for NetAdapter::DataReceivedEventArgs:

[legend]

Public Member Functions

virtual const DataReceivedEventArgs & | GetDataReceivedEventArgs () const

Data Fields

UINT8 * | m_buffer
UINT32 | m_data_len
InetSocketAddr m_recv_from

Member Function Documentation

virtual const DataReceivedEventArgs& NetAdapter::DataReceivedEventArgs::GetDataReceivedEventArgs ( ) const [inline, virtual]

Reimplemented from NetAdapter::EventArgs.

Field Documentation

UINT8* NetAdapter::DataReceivedEventArgs::m_buffer

UINT32 NetAdapter::DataReceivedEventArgs::m_data_len

InetSocketAddr NetAdapter::DataReceivedEventArgs::m_recv_from

The documentation for this struct was generated from the following file:
  • Socket/NetAdapterHandler.hpp
Generated on Wed Jan 25 01:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetAdapter::DataSentEventArgs Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
NetAdapter::DataSentEventArgs

NetAdapter::DataSentEventArgs Struct Reference

#include <Apoxi/Socket/NetAdapterHandler.hpp>

Inheritance diagram for NetAdapter::DataSentEventArgs:

[legend]
Collaboration diagram for NetAdapter::DataSentEventArgs:

[legend]

Public Member Functions

virtual const DataSentEventArgs & | GetDataSentEventArgs () const

Data Fields

UINT32 | m_data_len

Member Function Documentation

virtual const DataSentEventArgs& NetAdapter::DataSentEventArgs::GetDataSentEventArgs ( ) const [inline, virtual]

Reimplemented from NetAdapter::EventArgs.

Field Documentation

UINT32 NetAdapter::DataSentEventArgs::m_data_len

The documentation for this struct was generated from the following file:
  • Socket/NetAdapterHandler.hpp
Generated on Wed Jan 25 01:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetAdapter::EventArgs Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
NetAdapter::EventArgs

NetAdapter::EventArgs Struct Reference

#include <Apoxi/Socket/NetAdapterHandler.hpp>

Inheritance diagram for NetAdapter::EventArgs:

[legend]

Public Member Functions

virtual const DataReceivedEventArgs & | GetDataReceivedEventArgs () const
virtual const DataSentEventArgs & | GetDataSentEventArgs () const

Member Function Documentation

virtual const DataReceivedEventArgs& NetAdapter::EventArgs::GetDataReceivedEventArgs ( ) const [inline, virtual]

Reimplemented in NetAdapter::DataReceivedEventArgs.

virtual const DataSentEventArgs& NetAdapter::EventArgs::GetDataSentEventArgs ( ) const [inline, virtual]

Reimplemented in NetAdapter::DataSentEventArgs.

The documentation for this struct was generated from the following file:
  • Socket/NetAdapterHandler.hpp
Generated on Wed Jan 25 01:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetAdapterHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NetAdapterHandler Class Reference

#include <Apoxi/Socket/NetAdapterHandler.hpp>

Inheritance diagram for NetAdapterHandler:

[legend]
Collaboration diagram for NetAdapterHandler:

[legend]

Public Types

typedef void(* | NetAdapterHandlerCallback )(void *client_arg, NetAdapterHandler &handler, NetAdapter &net_adapter, NetAdapter::Event event, const NetAdapter::EventArgs &event_args)
typedef NiSharedPtr< NetAdapter > | NetAdapterPtr

Public Member Functions

void | CloseAllNetAdapters ()
BOOLEAN | CloseNetAdapter (NetAdapter::Id id)
NetAdapterPtr | GetNetAdapter (NetAdapter::Id id) const
NetAdapterHandler (NetAdapterHandlerCallback callback, void *client_arg, UINT32 recv_buffer_size=512)
NetAdapter::Id | OpenClientNetAdapter (DataConnProfileId dc_id, NetAdapter::Type net_adapter_type, const IpAddr &remote_address, const IpPortNo &remote_port, IpPortNo *local_port=0)
NetAdapter::Id | OpenServerNetAdapter (DataConnProfileId dc_id, NetAdapter::Type net_adapter_type, const IpPortNo &local_port)
BOOLEAN | Send (NetAdapter::Id id, const UINT8 *buffer, UINT32 len, InetSocketAddr *to=0) const
~NetAdapterHandler ()

Static Public Member Functions

static UINT | GetInvalidNetAdapterId ()

Protected Member Functions

virtual void | OnDataReceived (NetAdapter &netadapter, const NetAdapter::DataReceivedEventArgs &args)
virtual void | OnDataSent (NetAdapter &netadapter, const NetAdapter::DataSentEventArgs &args)
virtual void | OnNetAdapterClosed (NetAdapter &netadapter)

Friends

class | ClientNetAdapter
class | NetAdapter

Member Typedef Documentation

typedef void(* NetAdapterHandler::NetAdapterHandlerCallback)(void *client_arg, NetAdapterHandler &handler, NetAdapter &net_adapter, NetAdapter::Event event, const NetAdapter::EventArgs &event_args)

Handler callback.

typedef NiSharedPtr<NetAdapter> NetAdapterHandler::NetAdapterPtr

Constructor & Destructor Documentation

NetAdapterHandler::NetAdapterHandler | ( | NetAdapterHandlerCallback | callback,
 |  | void * | client_arg,
 |  | UINT32 | recv_buffer_size = 512
 | ) |

Constructor.

NetAdapterHandler::~NetAdapterHandler ( )

Destructor.

Member Function Documentation

void NetAdapterHandler::CloseAllNetAdapters ( )

BOOLEAN NetAdapterHandler::CloseNetAdapter ( NetAdapter::Id id )

static UINT NetAdapterHandler::GetInvalidNetAdapterId ( ) [inline, static]

Returns the invalid NetAdapter identifier.

NetAdapterHandler::NetAdapterPtr NetAdapterHandler::GetNetAdapter ( NetAdapter::Id id ) const

virtual void NetAdapterHandler::OnDataReceived | ( | NetAdapter & | netadapter,
 |  | const NetAdapter::DataReceivedEventArgs & | args
 | ) | [inline, protected, virtual]

virtual void NetAdapterHandler::OnDataSent | ( | NetAdapter & | netadapter,
 |  | const NetAdapter::DataSentEventArgs & | args
 | ) | [inline, protected, virtual]

virtual void NetAdapterHandler::OnNetAdapterClosed ( NetAdapter & netadapter ) [inline, protected, virtual]

NetAdapter::Id NetAdapterHandler::OpenClientNetAdapter | ( | DataConnProfileId | dc_id,
 |  | NetAdapter::Type | net_adapter_type,
 |  | const IpAddr & | remote_address,
 |  | const IpPortNo & | remote_port,
 |  | IpPortNo * | local_port = 0
 | ) |

NetAdapter::Id NetAdapterHandler::OpenServerNetAdapter | ( | DataConnProfileId | dc_id,
 |  | NetAdapter::Type | net_adapter_type,
 |  | const IpPortNo & | local_port
 | ) |

BOOLEAN NetAdapterHandler::Send | ( | NetAdapter::Id | id,
 |  | const UINT8 * | buffer,
 |  | UINT32 | len,
 |  | InetSocketAddr * | to = 0
 | ) | const

Friends And Related Function Documentation

friend class ClientNetAdapter [friend]

friend class NetAdapter [friend]

The documentation for this class was generated from the following files:
  • Socket/NetAdapterHandler.hpp
  • Socket/NetAdapterHandler.cpp
Generated on Wed Jan 25 01:31:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetworkDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NetworkDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/NetworkDispatcher.hpp>

Inheritance diagram for NetworkDispatcher:

[legend]
Collaboration diagram for NetworkDispatcher:

[legend]

Public Member Functions

NetworkDispatcher ()
Default constructor.
virtual | ~NetworkDispatcher ()

Protected Member Functions

BOOLEAN | OnBandSelectionInd (const StackMsgArgument &arg)
Indicates whether OM_BAND_CNF or OM_BAND_REJ are sent.
BOOLEAN | OnCellInfoInd (const StackMsgArgument &arg)
BOOLEAN | OnConnectionInd (const StackMsgArgument &arg)
BOOLEAN | OnEngineeringModeControlResponse (const StackMsgArgument &arg)
Handles URRC_EM_CTRL_CNF/em> (Engineering-Mode).
BOOLEAN | OnHomezoneInd (const StackMsgArgument &arg)
BOOLEAN | OnMnInformationInd (const StackMsgArgument &arg)
Handles NITZ Signal.
BOOLEAN | OnOmBandStatusCnf (const StackMsgArgument &arg)
BOOLEAN | OnTestparamInd (const StackMsgArgument &arg)
Handles MN_TESTPARAM_IND/em> (Engineering-Mode).

Constructor & Destructor Documentation

NetworkDispatcher::NetworkDispatcher ( )

Default constructor.

NetworkDispatcher::~NetworkDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN NetworkDispatcher::OnBandSelectionInd ( const StackMsgArgument & arg ) [protected]

Indicates whether OM_BAND_CNF or OM_BAND_REJ are sent.

BOOLEAN NetworkDispatcher::OnCellInfoInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN NetworkDispatcher::OnConnectionInd ( const StackMsgArgument & arg ) [protected]

Sends a ConnectionStatusMsg message. This messages keeps information if ciphering is on or off and if any other connections are active at the moment. Refer to ConnectionStatusArg for a detailed description of the message data.

Parameters:
msg A constant reference to CallConnectionIndMsg.

BOOLEAN NetworkDispatcher::OnEngineeringModeControlResponse ( const StackMsgArgument & arg ) [protected]

Handles URRC_EM_CTRL_CNF/em> (Engineering-Mode).

BOOLEAN NetworkDispatcher::OnHomezoneInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN NetworkDispatcher::OnMnInformationInd ( const StackMsgArgument & arg ) [protected]

Handles NITZ Signal.

BOOLEAN NetworkDispatcher::OnOmBandStatusCnf ( const StackMsgArgument & arg ) [protected]

BOOLEAN NetworkDispatcher::OnTestparamInd ( const StackMsgArgument & arg ) [protected]

Handles MN_TESTPARAM_IND/em> (Engineering-Mode).

The documentation for this class was generated from the following files:
  • Asc/NetworkDispatcher.hpp
  • Asc/NetworkDispatcher.cpp
Generated on Wed Jan 25 01:31:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetworkHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NetworkHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/NetworkHandler.hpp>

Collaboration diagram for NetworkHandler:

[legend]

Public Types

enum | { ID = NetworkHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
NetworkHandler ()
virtual | ~NetworkHandler ()

Static Public Member Functions

static BOOLEAN | BandSelection (GsmBandList gsm_band_list)
Manual Band Selection.
static BOOLEAN | BandSelection (GsmBand first_band, GsmBand second_band)
Manual Band Selection.
static BOOLEAN | ReceiveEngineeringModeReport (BOOLEAN enable)
starts/stops receiving engineering mode report messages
static BOOLEAN | RequestBandConfig ()
Request the band-configuration.
static BOOLEAN | SendEngineeringModeControlRequest (EngineeringModeControl function, ULONG param=0)
Necessary for Engineering Mode.
static BOOLEAN | SetNetworkSearchMode (NetworkSearchMode network_search_mode)
select the network search mode (normal or fast)

Detailed Description

The NetworkHandler holds the functionality for receiving network connection info events.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NetworkHandler::NetworkHandler ( )

NetworkHandler::~NetworkHandler ( ) [virtual]

Member Function Documentation

BOOLEAN NetworkHandler::BandSelection ( GsmBandList gsm_band_list ) [static]

Manual Band Selection.

BOOLEAN NetworkHandler::BandSelection | ( | GsmBand | first_band,
 |  | GsmBand | second_band
 | ) | [static]

Manual Band Selection.

HandlerId NetworkHandler::GetHandlerId ( ) const [virtual]

BOOLEAN NetworkHandler::ReceiveEngineeringModeReport ( BOOLEAN enable ) [static]

starts/stops receiving engineering mode report messages

BOOLEAN NetworkHandler::RequestBandConfig ( ) [static]

Request the band-configuration.

BOOLEAN NetworkHandler::SendEngineeringModeControlRequest | ( | EngineeringModeControl | function,
 |  | ULONG | param = 0
 | ) | [static]

Necessary for Engineering Mode.

change the engineering mode control, according to the parameter. The method is only available if the define APOXI_EM_CONTROL_ENABLED is set.

BOOLEAN NetworkHandler::SetNetworkSearchMode ( NetworkSearchMode network_search_mode ) [static]

select the network search mode (normal or fast)

The documentation for this class was generated from the following files:
  • Asc/NetworkHandler.hpp
  • Asc/NetworkHandler.cpp
Generated on Wed Jan 25 01:31:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetworkInformationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NetworkInformationMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for NetworkInformationMsg:

[legend]
Collaboration diagram for NetworkInformationMsg:

[legend]

Public Types

enum | { ID = 18601 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetNetworkNameLong () const
const WString & | GetNetworkNameShort () const
BOOLEAN | IsNetworkNameLongAddCi () const
BOOLEAN | IsNetworkNameShortAddCi () const
NetworkInformationMsg (const WString &network_name_long, const WString &network_name_short, BOOLEAN network_name_long_add_ci, BOOLEAN network_name_short_add_ci)
void | SetNetworkNameLong (const WString &network_name_long)
void | SetNetworkNameLongAddCi (BOOLEAN network_name_long_add_ci)
void | SetNetworkNameShort (const WString &network_name_short)
void | SetNetworkNameShortAddCi (BOOLEAN network_name_short_add_ci)
virtual | ~NetworkInformationMsg ()

Detailed Description

NetworkInformationMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NetworkInformationMsg::NetworkInformationMsg | ( | const WString & | network_name_long,
 |  | const WString & | network_name_short,
 |  | BOOLEAN | network_name_long_add_ci,
 |  | BOOLEAN | network_name_short_add_ci
 | ) |

NetworkInformationMsg::~NetworkInformationMsg ( ) [virtual]

Member Function Documentation

Message * NetworkInformationMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & NetworkInformationMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& NetworkInformationMsg::GetNetworkNameLong ( ) const [inline]

const WString& NetworkInformationMsg::GetNetworkNameShort ( ) const [inline]

BOOLEAN NetworkInformationMsg::IsNetworkNameLongAddCi ( ) const [inline]

BOOLEAN NetworkInformationMsg::IsNetworkNameShortAddCi ( ) const [inline]

void NetworkInformationMsg::SetNetworkNameLong ( const WString & network_name_long ) [inline]

void NetworkInformationMsg::SetNetworkNameLongAddCi ( BOOLEAN network_name_long_add_ci ) [inline]

void NetworkInformationMsg::SetNetworkNameShort ( const WString & network_name_short ) [inline]

void NetworkInformationMsg::SetNetworkNameShortAddCi ( BOOLEAN network_name_short_add_ci ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:31:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetworkSsErrorMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NetworkSsErrorMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for NetworkSsErrorMsg:

[legend]
Collaboration diagram for NetworkSsErrorMsg:

[legend]

Public Types

enum | { ID = 18522 }

Public Member Functions

virtual Message * | Clone () const
const ServiceGroup & | GetBasicService () const
const SsErrorCode & | GetErrorCode () const
virtual const MsgMetaData & | GetMetaData () const
const SsOperationCode & | GetOperationCode () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
NetworkSsErrorMsg (ExecutionContext *context, const Tipd &tipd, const SsErrorCode &error_code, const SsCode &ss_code, const ServiceGroup &basic_service, const SsOperationCode &operation_code)
virtual | ~NetworkSsErrorMsg ()

Detailed Description

NetworkSsErrorMsg: Network had an error processing the request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NetworkSsErrorMsg::NetworkSsErrorMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsErrorCode & | error_code,
 |  | const SsCode & | ss_code,
 |  | const ServiceGroup & | basic_service,
 |  | const SsOperationCode & | operation_code
 | ) |

NetworkSsErrorMsg::~NetworkSsErrorMsg ( ) [virtual]

Member Function Documentation

Message * NetworkSsErrorMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& NetworkSsErrorMsg::GetBasicService ( ) const [inline]

const SsErrorCode& NetworkSsErrorMsg::GetErrorCode ( void ) const [inline]

const MsgMetaData & NetworkSsErrorMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsOperationCode& NetworkSsErrorMsg::GetOperationCode ( ) const [inline]

const SsCode& NetworkSsErrorMsg::GetSsCode ( ) const [inline]

const Tipd& NetworkSsErrorMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:31:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NetworkSsRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NetworkSsRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for NetworkSsRejectedMsg:

[legend]
Collaboration diagram for NetworkSsRejectedMsg:

[legend]

Public Types

enum | { ID = 18523 }

Public Member Functions

virtual Message * | Clone () const
const ServiceGroup & | GetBasicService () const
virtual const MsgMetaData & | GetMetaData () const
const SsOperationCode & | GetOperationCode () const
const SsCode & | GetSsCode () const
const TaggedProblemCode & | GetTaggedProblemCode () const
const Tipd & | GetTipd () const
NetworkSsRejectedMsg (ExecutionContext *context, const Tipd &tipd, const TaggedProblemCode &tagged_problem_code, const SsCode &ss_code, const ServiceGroup &basic_service, const SsOperationCode &operation_code)
virtual | ~NetworkSsRejectedMsg ()

Detailed Description

NetworkSsRejectedMsg: the network rejected the request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NetworkSsRejectedMsg::NetworkSsRejectedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const TaggedProblemCode & | tagged_problem_code,
 |  | const SsCode & | ss_code,
 |  | const ServiceGroup & | basic_service,
 |  | const SsOperationCode & | operation_code
 | ) |

NetworkSsRejectedMsg::~NetworkSsRejectedMsg ( ) [virtual]

Member Function Documentation

Message * NetworkSsRejectedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& NetworkSsRejectedMsg::GetBasicService ( ) const [inline]

const MsgMetaData & NetworkSsRejectedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsOperationCode& NetworkSsRejectedMsg::GetOperationCode ( ) const [inline]

const SsCode& NetworkSsRejectedMsg::GetSsCode ( ) const [inline]

const TaggedProblemCode& NetworkSsRejectedMsg::GetTaggedProblemCode ( ) const [inline]

const Tipd& NetworkSsRejectedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:31:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NextSocketTestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NextSocketTestMsg Class Reference

#include <Applications/SocketTest/SocketTestMsgTypes.hpp>

Inheritance diagram for NextSocketTestMsg:

[legend]
Collaboration diagram for NextSocketTestMsg:

[legend]

Public Types

enum | { ID = 21901 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
NextSocketTestMsg (ExecutionContext *context)
virtual | ~NextSocketTestMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NextSocketTestMsg::NextSocketTestMsg ( ExecutionContext * context )

NextSocketTestMsg::~NextSocketTestMsg ( ) [virtual]

Member Function Documentation

Message * NextSocketTestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & NextSocketTestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestMsgTypes.hpp
  • Applications/SocketTest/SocketTestMsgTypes.cpp
Generated on Wed Jan 25 01:31:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NiSharedPtr< X > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NiSharedPtr< X > Class Template Reference

#include <Apoxi/Auxiliary/NiSharedPtr.hpp>

Public Member Functions

X * | Get () const
Returns the encapsulated pointer. Avoid using this method if possible.
BOOLEAN | IsValid () const
Checks whether this smart pointer actually points to an object.
NiSharedPtr (const NiSharedPtr &r)
Copy constructor.
NiSharedPtr (X *p=0)
Constructs a smart-pointer for pointer p.
X & | operator * () const
X * | operator-> () const
NiSharedPtr & | operator= (const NiSharedPtr &r)
Assignment operator.
void | Release ()
BOOLEAN | Unique () const
Tells if the encapsulated pointer is referenced exactly once.
~NiSharedPtr ()
Destructs the smart-pointer.

Data Structures

struct | ItemRef

Detailed Description

template<typename X>
class NiSharedPtr< X >

Template class NiSharedPtr implements a shared reference-counting non-intrusive smart-pointer. The smart-pointer is non-intrusive with respect to the objects that get reference counted, i.e. the objects don't have to be derived from some dedicated base-class and may stay as they are. For this, the smart-pointer in addition to the pointer for the counted object controls a counter, too. Since the target compilers do not all support member templates (we would need the templated copy constructor and templated assignment operator) there is no way to cast an instance of the smart-pointer to a related instance of another smart-pointer. APOXI also provides an intrusive smart-pointer called SharedPtr. This smart-pointer on the one hand requires the reference counted object to be derived from ReferableObject but on the other hand for this provides the possibility to cast an instance of the smart-pointer to a related instance of another smart-pointer with some effort. For details on this please have a look in the documentation of class SharedPtr.

Constructor & Destructor Documentation

template<typename X>
NiSharedPtr< X >::NiSharedPtr ( X * p = 0 ) [inline, explicit]

Constructs a smart-pointer for pointer p.

template<typename X>
NiSharedPtr< X >::~NiSharedPtr ( )

Destructs the smart-pointer.

template<typename X>
NiSharedPtr< X >::NiSharedPtr ( const NiSharedPtr< X > & r ) [inline]

Copy constructor.

Member Function Documentation

template<typename X>
X* NiSharedPtr< X >::Get ( ) const [inline]

Returns the encapsulated pointer. Avoid using this method if possible.

template<typename X>
BOOLEAN NiSharedPtr< X >::IsValid ( ) const [inline]

Checks whether this smart pointer actually points to an object.

template<typename X>
X& NiSharedPtr< X >::operator * ( ) const [inline]

Dereferencing operator to access the object the smart-pointer points to. Note that an assertion will hold if the smart-pointer does actually not point to an object! You can use the methods of the underlying instance like this:

            (*smart_ptr).memberfun()

template<typename X>
X* NiSharedPtr< X >::operator-> ( ) const [inline]

Member selection operator to access a member of the object the smart-pointer points to. Note that an assertion will hold if the smart pointer does actually not point to an object! You can use the methods of the underlying instance like this:

            smart_ptr->memberfun()

template<typename X>
NiSharedPtr& NiSharedPtr< X >::operator= ( const NiSharedPtr< X > & r )

Assignment operator.

template<typename X>
void NiSharedPtr< X >::Release ( ) [inline]

Releases the reference counted object and deletes it if this was the last reference.

template<typename X>
BOOLEAN NiSharedPtr< X >::Unique ( ) const [inline]

Tells if the encapsulated pointer is referenced exactly once.

The documentation for this class was generated from the following file:
  • Auxiliary/NiSharedPtr.hpp
Generated on Wed Jan 25 01:31:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NmeaUartSettings Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NmeaUartSettings Struct Reference

UART Settings for NMEA data transfer. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Public Member Functions

NmeaUartSettings ()
Constructor.

Data Fields

UartBaudRate m_baud_rate
UartDataBits m_data_bits
UartFlowControl m_flow_control
UartParity m_parity
UartStopBits m_stop_bits

Detailed Description

UART Settings for NMEA data transfer.

Constructor & Destructor Documentation

NmeaUartSettings::NmeaUartSettings ( ) [inline]

Constructor.

Field Documentation

UartBaudRate NmeaUartSettings::m_baud_rate

UartDataBits NmeaUartSettings::m_data_bits

UartFlowControl NmeaUartSettings::m_flow_control

UartParity NmeaUartSettings::m_parity

UartStopBits NmeaUartSettings::m_stop_bits

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:31:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NodeFileHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NodeFileHandler Class Reference
[Afs]

#include <Apoxi/Afs/NodeFileHandler.hpp>

Static Public Member Functions

static RegResult | AddInteriorNodeEntry (INT16 transaction_id, INT16 file_id, const Uri &uri, INT16 int_file_id)
Overloaded to add an interior node.
static RegResult | AddNodeEntry (INT16 transaction_id, INT16 file_id, const String &node_name, const DataItem &dataitem, INT16 &blob_file_id)
Add a node record.
static RegResult | CreateInteriorNodeEntry (const Uri &abs_uri, INT16 &file_id)
static RegResult | CreateInteriorNodeEntry (INT16 &file_id)
creates new interiornode
static RegResult | GetNodeEntry (INT16 transaction_id, INT16 file_id, const Uri &uri, DataItem &dataitem)
retrieves the node record
static BOOLEAN | IsNodeExisting (const Uri &passed_uri, INT16 parent_file_id)
static RegResult | RemoveInteriorNodeEntry (INT16 file_id)
Deletes the interiornode.
static RegResult | RemoveNodeEntry (INT16 transaction_id, INT16 file_id, const Uri &uri, INT16 &blob_file_id)
Remove a Node record.
static RegResult | ReplaceNodeEntry (INT16 transaction_id, INT16 file_id, const String &node_name, const DataItem &dataitem, INT16 &old_blob_id, INT16 &new_file_id)
Replace a node record.

Detailed Description

structure of node file handler

Member Function Documentation

RegResult NodeFileHandler::AddInteriorNodeEntry | ( | INT16 | transaction_id,
 |  | INT16 | file_id,
 |  | const Uri & | passed_uri,
 |  | INT16 | int_file_id
 | ) | [static]

Overloaded to add an interior node.

------------------------------------------------------------------------ AddInteriorNodeEntry ------------------------------------------------------------------------

RegResult NodeFileHandler::AddNodeEntry | ( | INT16 | transaction_id,
 |  | INT16 | file_id,
 |  | const String & | node_name,
 |  | const DataItem & | data_item,
 |  | INT16 & | blob_file_id
 | ) | [static]

Add a node record.

------------------------------------------------------------------------ AddNodeEntry ------------------------------------------------------------------------

RegResult NodeFileHandler::CreateInteriorNodeEntry | ( | const Uri & | abs_uri,
 |  | INT16 & | file_id
 | ) | [static]

------------------------------------------------------------------------ CreateInteriorNodeEntry ------------------------------------------------------------------------

RegResult NodeFileHandler::CreateInteriorNodeEntry ( INT16 & file_id ) [static]

creates new interiornode

------------------------------------------------------------------------ CreateInteriorNodeEntry ------------------------------------------------------------------------

RegResult NodeFileHandler::GetNodeEntry | ( | INT16 | transaction_id,
 |  | INT16 | file_id,
 |  | const Uri & | passed_uri,
 |  | DataItem & | data_item
 | ) | [static]

retrieves the node record

------------------------------------------------------------------------ GetNodeEntry ------------------------------------------------------------------------

BOOLEAN NodeFileHandler::IsNodeExisting | ( | const Uri & | passed_uri,
 |  | INT16 | parent_file_id
 | ) | [static]

------------------------------------------------------------------------ IsNodeExisting ------------------------------------------------------------------------

RegResult NodeFileHandler::RemoveInteriorNodeEntry ( INT16 file_id ) [static]

Deletes the interiornode.

------------------------------------------------------------------------ RemoveInteriorNodeEntry ------------------------------------------------------------------------

RegResult NodeFileHandler::RemoveNodeEntry | ( | INT16 | transaction_id,
 |  | INT16 | file_id,
 |  | const Uri & | passed_uri,
 |  | INT16 & | blob_file_id
 | ) | [static]

Remove a Node record.

------------------------------------------------------------------------ RemoveNodeEntry ------------------------------------------------------------------------

RegResult NodeFileHandler::ReplaceNodeEntry | ( | INT16 | transaction_id,
 |  | INT16 | file_id,
 |  | const String & | child_name,
 |  | const DataItem & | data_item,
 |  | INT16 & | old_blob_id,
 |  | INT16 & | new_blob_id
 | ) | [static]

Replace a node record.

------------------------------------------------------------------------ ReplaceNodeEntry ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/NodeFileHandler.hpp
  • Afs/NodeFileHandler.cpp
Generated on Wed Jan 25 01:31:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NoMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NoMessage Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for NoMessage:

[legend]
Collaboration diagram for NoMessage:

[legend]

Public Types

enum | { ID = 0 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
NoMessage ()
virtual | ~NoMessage ()

Detailed Description

Messages

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NoMessage::NoMessage ( )

NoMessage::~NoMessage ( ) [virtual]

Member Function Documentation

Message * NoMessage::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & NoMessage::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:31:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NonCloneable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NonCloneable Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/NonCloneable.hpp>

Inheritance diagram for NonCloneable:

[legend]

Public Member Functions

NonCloneable ()
virtual ~NonCloneable ()

Constructor & Destructor Documentation

NonCloneable::NonCloneable ( )

NonCloneable::~NonCloneable ( ) [virtual]

The documentation for this class was generated from the following files:
  • Auxiliary/NonCloneable.hpp
  • Auxiliary/NonCloneable.cpp
Generated on Wed Jan 25 01:31:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NonCopyable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NonCopyable Class Reference
[Audio]

#include <Apoxi/Audio/AudioDeviceBase.hpp>

Inheritance diagram for NonCopyable:

[legend]

Protected Member Functions

NonCopyable ()
~NonCopyable ()

Constructor & Destructor Documentation

NonCopyable::NonCopyable ( ) [inline, protected]

NonCopyable::~NonCopyable ( ) [inline, protected]

The documentation for this class was generated from the following file:
  • Audio/AudioDeviceBase.hpp
Generated on Wed Jan 25 01:31:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NonsharedBinDataDataSource Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NonsharedBinDataDataSource Class Reference

#include <Apoxi/Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.hpp>

Inheritance diagram for NonsharedBinDataDataSource:

[legend]
Collaboration diagram for NonsharedBinDataDataSource:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | GetSize (UINT32 &size) const
virtual BOOLEAN | IsOpen () const
NonsharedBinDataDataSource (const BinData *bin_data)
virtual BOOLEAN | Open ()
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 count)
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | Read (void HUGE *buffer, UINT32 count)
virtual | ~NonsharedBinDataDataSource ()

Protected Attributes

const BinData * | m_bin_data
BOOLEAN | m_is_open
UINT32 | m_offset

Detailed Description

Like a BinDataDataSource, but the BinData is kept in a plain * pointer.

Constructor & Destructor Documentation

NonsharedBinDataDataSource::NonsharedBinDataDataSource ( const BinData * bin_data )

Creates a BinData data source instance. This data source reads from the BinData. To ensure, that the BinData object isn't destroyed before the DataSource, a shared pointer is used.

Parameters:
bin_data Shared pointer to BinData

NonsharedBinDataDataSource::~NonsharedBinDataDataSource ( ) [virtual]

Destroys the BinData data source.

Member Function Documentation

BOOLEAN NonsharedBinDataDataSource::Close ( ) [virtual]

Closes the data source. After closing the data source it can not be read any more.

Returns:
Success of operation.

Implements DataSource.

BOOLEAN NonsharedBinDataDataSource::GetSize ( UINT32 & size ) const [virtual]

Returns the size of the data source in terms of bytes.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN NonsharedBinDataDataSource::IsOpen ( ) const [virtual]

Returns whether the data source is currently open or closed.

Returns:
Whether the data source is open or not.

Implements DataSource.

BOOLEAN NonsharedBinDataDataSource::Open ( ) [virtual]

Opens the data source for reading. Opening sets the current read position to the beginning of the data source. The read methods that do not use an offset argument always start to read at the current read position. A data source can only be read if it has been opened before.

Returns:
Success of operation.

Implements DataSource.

BOOLEAN NonsharedBinDataDataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [virtual]

Reads up to max_count bytes from this data source starting at offset and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. parameter offset is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! Note that this method does not affect the current read position. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadRandomDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 offset = 0;
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(offset, buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...

                    // Increase offset where to read next.
                    offset += bytes_read;
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN NonsharedBinDataDataSource::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [virtual]

Reads exactly count bytes from this data source starting at offset and copies them to the provided buffer. Note that this method does not affect the current read position.

Parameters:
offset | The zero-based position where to start reading the data source.
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN NonsharedBinDataDataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [virtual]

Reads up to max_count bytes from this data source starting at the current read position and copies them to the provided buffer. If the read operation was successful then argument bytes_read is set to the actual number of bytes read. This number may differ from max_count due to reaching the end of data while reading. Therefore it is essential to check bytes_read if TRUE is returned! Take care that if you start reading at the end of the data source, i.e. the current read position is greater than or equal to the size of the data source, this method sets bytes_read to 0 and returns TRUE, signaling end of data! The current read position is updated. Please see the following sample function for completely reading a data source:

            static BOOLEAN ReadSequentialDataSource(DataSource &open_ds)
            {
                ASSERT_DEBUG(open_ds.IsOpen());

                // Define read buffer.
                const UINT buf_size = 128;
                CHAR buf[buf_size];

                // Define variables used for reading.
                UINT32 bytes_read;
                BOOLEAN ok;

                // Read whole data source in a loop.
                while ((ok = open_ds.Read(buf, buf_size, bytes_read)) &&
                    bytes_read != 0)
                {
                    // Use buf which is filled with valid data from index 0 to index
                    // (bytes_read - 1).
                    // ...
                }

                // ok is FALSE if a read error occurred, otherwise TRUE.
                return ok;
            }

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least max_count bytes in size.
max_count | The number of bytes to read.
bytes_read | Bytes actually read.
Returns:
Success of operation.

Implements DataSource.

BOOLEAN NonsharedBinDataDataSource::Read | ( | void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [virtual]

Reads exactly count bytes from this data source starting at the current read position and copies them to the provided buffer. The current read position is updated.

Parameters:
buffer | The pointer to the buffer where the bytes read have to be copied to. It must be a valid pointer and the buffer must be at least count bytes in size.
count | The number of bytes to read.
Returns:
Success of operation.

Implements DataSource.

Field Documentation

const BinData* NonsharedBinDataDataSource::m_bin_data [protected]

BOOLEAN NonsharedBinDataDataSource::m_is_open [protected]

UINT32 NonsharedBinDataDataSource::m_offset [protected]

The documentation for this class was generated from the following files:
  • Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.hpp
  • Devices/MPEU/Extensions/AtiW2282/NonsharedBinDataDataSource.cpp
Generated on Wed Jan 25 01:31:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NoStackMsgArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NoStackMsgArg Class Reference

#include <Apoxi/Apc/StackMsgArgument.hpp>

Inheritance diagram for NoStackMsgArg:

[legend]
Collaboration diagram for NoStackMsgArg:

[legend]

Public Types

enum | { ID = 0 }

Public Member Functions

NoStackMsgArg ()
~NoStackMsgArg ()

Friends

class | StackMsgArgument

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NoStackMsgArg::NoStackMsgArg ( )

NoStackMsgArg::~NoStackMsgArg ( )

Friends And Related Function Documentation

friend class StackMsgArgument [friend]

The documentation for this class was generated from the following files:
  • Apc/StackMsgArgument.hpp
  • Apc/StackMsgArgument.cpp
Generated on Wed Jan 25 01:31:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NotEqualsRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NotEqualsRule Class Reference
[Auxiliary]

NotEqualsRule checks whether data item is not equal to rule item More...

#include <Apoxi/Auxiliary/FilterRule.hpp>

Inheritance diagram for NotEqualsRule:

[legend]
Collaboration diagram for NotEqualsRule:

[legend]

Public Types

typedef FilterRule | Base

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)
NotEqualsRule (const DataItem &ruleitem)
NotEqualsRule ()
virtual | ~NotEqualsRule ()

Detailed Description

NotEqualsRule checks whether data item is not equal to rule item

Member Typedef Documentation

typedef FilterRule NotEqualsRule::Base

Reimplemented in DistinctRule.

Constructor & Destructor Documentation

NotEqualsRule::NotEqualsRule ( )

NotEqualsRule::NotEqualsRule ( const DataItem & ruleitem )

NotEqualsRule::~NotEqualsRule ( ) [virtual]

Member Function Documentation

BOOLEAN NotEqualsRule::ExecuteRule ( const DataItem & dataitem ) [virtual]

ExecuteRule does the actual comparision between the data item given in the argument and the value stored when the filter rule is constructed.

Implements FilterRule.

Reimplemented in DistinctRule.

The documentation for this class was generated from the following files:
  • Auxiliary/FilterRule.hpp
  • Auxiliary/FilterRule.cpp
Generated on Wed Jan 25 01:31:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NotificationArray Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NotificationArray Class Reference
[Afs]

#include <Apoxi/Afs/NotificationTable.hpp>

Inheritance diagram for NotificationArray:

[legend]
Collaboration diagram for NotificationArray:

[legend]

Public Types

enum | { c_table_size = APOXI_REGISTERED_TABLE_SIZE, c_table_full = -1 }

Public Member Functions

INT16 | AddUri (const Uri &uri, Cb_function_ptr cb_function_ptr, Application *app_ptr)
INT16 | DeleteUri (const Uri &uri, Cb_function_ptr cb_function_ptr, Application *app_ptr)
INT16 | SearchUri (const Uri &uri, Cb_function_ptr cb_fn_ptr, Application *app_ptr)
void | SendNotification (const Uri &uri)

Detailed Description

This is a table containing the NotificationTableEntries. If the table gets exhausted new table is created

structure of NotificationArray

Member Enumeration Documentation

anonymous enum

Enumerator:
c_table_size
c_table_full

Member Function Documentation

INT16 NotificationArray::AddUri | ( | const Uri & | uri,
 |  | Cb_function_ptr | cb_fn_ptr,
 |  | Application * | app_ptr
 | ) |

------------------------------------------------------------------------ AddUri ------------------------------------------------------------------------

INT16 NotificationArray::DeleteUri | ( | const Uri & | uri,
 |  | Cb_function_ptr | cb_function_ptr,
 |  | Application * | app_ptr
 | ) |

INT16 NotificationArray::SearchUri | ( | const Uri & | uri,
 |  | Cb_function_ptr | cb_fn_ptr,
 |  | Application * | app_ptr
 | ) |

------------------------------------------------------------------------ SearchUri ------------------------------------------------------------------------

void NotificationArray::SendNotification ( const Uri & uri )

------------------------------------------------------------------------ SendNotification ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/NotificationTable.hpp
  • Afs/NotificationTable.cpp
Generated on Wed Jan 25 01:31:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NotificationTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NotificationTable Class Reference
[Afs]

#include <Apoxi/Afs/NotificationTable.hpp>

Collaboration diagram for NotificationTable:

[legend]

Public Member Functions

BOOLEAN | AddRegistration (const Uri &uri, Cb_function_ptr cb_function_ptr, Application *app_ptr)
BOOLEAN | DeleteRegistration (const Uri &uri, Cb_function_ptr cb_function_ptr, Application *app_ptr)
void | SendNotificationsToApps (const Uri &uri) const
~NotificationTable ()

Static Public Member Functions

static NotificationTable * | GetTable ()

Detailed Description

structure of NotificationTable

Constructor & Destructor Documentation

NotificationTable::~NotificationTable ( ) [inline]

Destructor takes care of deleting the nodes pointed to by linked list. The linked list itself is destroyed when it goes out of scope

Member Function Documentation

BOOLEAN NotificationTable::AddRegistration | ( | const Uri & | uri,
 |  | Cb_function_ptr | cb_function_ptr,
 |  | Application * | app_ptr
 | ) |

------------------------------------------------------------------------ AddRegistration ------------------------------------------------------------------------

BOOLEAN NotificationTable::DeleteRegistration | ( | const Uri & | uri,
 |  | Cb_function_ptr | cb_function_ptr,
 |  | Application * | app_ptr
 | ) |

------------------------------------------------------------------------ Deelete Registration ------------------------------------------------------------------------

NotificationTable * NotificationTable::GetTable ( ) [static]

------------------------------------------------------------------------ GetTable ------------------------------------------------------------------------

void NotificationTable::SendNotificationsToApps ( const Uri & uri ) const

------------------------------------------------------------------------ SendNotificationsToApps ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/NotificationTable.hpp
  • Afs/NotificationTable.cpp
Generated on Wed Jan 25 01:31:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NotificationTableEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NotificationTableEntry Class Reference
[Afs]

NotificationTableEntry contains the URI -> Callback/App_ptr mapping. More...

#include <Apoxi/Afs/NotificationTable.hpp>

Collaboration diagram for NotificationTableEntry:

[legend]

Public Member Functions

Application * GetAppPtr ()
Cb_function_ptr GetCbFunction ()
Uri | GetUri () const
NotificationTableEntry (NotificationTableEntry *rhs)
NotificationTableEntry (Uri &uri, Cb_function_ptr cb_function_ptr, Application *app_ptr)
NotificationTableEntry ()
BOOLEAN | operator< (NotificationTableEntry &rhs) const
BOOLEAN | operator== (NotificationTableEntry &rhs) const
void | SetAppPtr (Application *app_ptr)
void | SetCbFunction (Cb_function_ptr cb_function_ptr)
void | SetUri (const Uri &uri)
~NotificationTableEntry ()

Detailed Description

NotificationTableEntry contains the URI -> Callback/App_ptr mapping.

Constructor & Destructor Documentation

NotificationTableEntry::NotificationTableEntry ( ) [inline]

NotificationTableEntry::NotificationTableEntry | ( | Uri & | uri,
 |  | Cb_function_ptr | cb_function_ptr,
 |  | Application * | app_ptr
 | ) | [inline]

NotificationTableEntry::NotificationTableEntry ( NotificationTableEntry * rhs ) [inline]

NotificationTableEntry::~NotificationTableEntry ( ) [inline]

Member Function Documentation

Application* NotificationTableEntry::GetAppPtr ( ) [inline]

Cb_function_ptr NotificationTableEntry::GetCbFunction ( ) [inline]

Uri NotificationTableEntry::GetUri ( ) const [inline]

BOOLEAN NotificationTableEntry::operator< ( NotificationTableEntry & rhs ) const

------------------------------------------------------------------------ operator < ------------------------------------------------------------------------

BOOLEAN NotificationTableEntry::operator== ( NotificationTableEntry & rhs ) const

------------------------------------------------------------------------ operator == ------------------------------------------------------------------------

void NotificationTableEntry::SetAppPtr ( Application * app_ptr ) [inline]

void NotificationTableEntry::SetCbFunction ( Cb_function_ptr cb_function_ptr ) [inline]

void NotificationTableEntry::SetUri ( const Uri & uri ) [inline]

The documentation for this class was generated from the following files:
  • Afs/NotificationTable.hpp
  • Afs/NotificationTable.cpp
Generated on Wed Jan 25 01:31:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NotifyIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NotifyIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for NotifyIndArg:

[legend]
Collaboration diagram for NotifyIndArg:

[legend]

Public Types

enum | { ID = 1128 }

Public Member Functions

const NotificationDescription & | GetDescription () const
const Tipd & | GetTipd () const
NotifyIndArg ()
void | SetDescription (const NotificationDescription &description)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const NotifyIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

NotifyIndArg: reflects arguments of signal MN_NOTIFY_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NotifyIndArg::NotifyIndArg ( )

Member Function Documentation

const NotifyIndArg & NotifyIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const NotificationDescription& NotifyIndArg::GetDescription ( ) const [inline]

const Tipd& NotifyIndArg::GetTipd ( ) const [inline]

void NotifyIndArg::SetDescription ( const NotificationDescription & description ) [inline]

void NotifyIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:31:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NotifySsArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NotifySsArg Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for NotifySsArg:

[legend]

Data Fields

HoldIndicator call_hold_indicator
BOOLEAN | call_wait_indicator
BOOLEAN | clir_supp_rejected
INT | cug_index
EctIndicator ect_indicator
BOOLEAN | mpty_indicator
NameIndicator name_indicator
CallRelatedSsCode ss_code
SsNotification ss_notification
SsStatus ss_status

Field Documentation

HoldIndicator NotifySsArg::call_hold_indicator

BOOLEAN NotifySsArg::call_wait_indicator

BOOLEAN NotifySsArg::clir_supp_rejected

INT NotifySsArg::cug_index

EctIndicator NotifySsArg::ect_indicator

BOOLEAN NotifySsArg::mpty_indicator

NameIndicator NotifySsArg::name_indicator

CallRelatedSsCode NotifySsArg::ss_code

SsNotification NotifySsArg::ss_notification

SsStatus NotifySsArg::ss_status

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:31:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NRegStateIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NRegStateIndArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for NRegStateIndArg:

[legend]
Collaboration diagram for NRegStateIndArg:

[legend]

Public Types

enum | { ID = 5360 }

Public Member Functions

const RegisterRejectCause & | GetCause () const
const GsmBand & | GetGsmBand () const
const GsmErrorCause & | GetGsmErrorCause () const
const Plmn & | GetPlmn () const
const RadioAccessTechnology & | GetRadioAccessTechnology () const
const RegisterStatus & | GetStatus () const
BOOLEAN | IsPlmnSearchActive () const
NRegStateIndArg ()
void | SetCause (const RegisterRejectCause &cause)
void | SetGsmBand (const GsmBand &gsm_band)
void | SetGsmErrorCause (const GsmErrorCause &gsm_error_cause)
void | SetPlmn (const Plmn &plmn)
void | SetPlmnSearchActive (BOOLEAN plmn_search_active)
void | SetRadioAccessTechnology (const RadioAccessTechnology &radio_access_technology)
void | SetStatus (const RegisterStatus &status)

Static Public Member Functions

static const NRegStateIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

NRegStateIndArg: reflects arguments of signal MN_NREG_STATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NRegStateIndArg::NRegStateIndArg ( )

Member Function Documentation

const NRegStateIndArg & NRegStateIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const RegisterRejectCause& NRegStateIndArg::GetCause ( ) const [inline]

const GsmBand& NRegStateIndArg::GetGsmBand ( ) const [inline]

const GsmErrorCause& NRegStateIndArg::GetGsmErrorCause ( ) const [inline]

const Plmn& NRegStateIndArg::GetPlmn ( ) const [inline]

const RadioAccessTechnology& NRegStateIndArg::GetRadioAccessTechnology ( ) const [inline]

const RegisterStatus& NRegStateIndArg::GetStatus ( ) const [inline]

BOOLEAN NRegStateIndArg::IsPlmnSearchActive ( ) const [inline]

void NRegStateIndArg::SetCause ( const RegisterRejectCause & cause ) [inline]

void NRegStateIndArg::SetGsmBand ( const GsmBand & gsm_band ) [inline]

void NRegStateIndArg::SetGsmErrorCause ( const GsmErrorCause & gsm_error_cause ) [inline]

void NRegStateIndArg::SetPlmn ( const Plmn & plmn ) [inline]

void NRegStateIndArg::SetPlmnSearchActive ( BOOLEAN plmn_search_active ) [inline]

void NRegStateIndArg::SetRadioAccessTechnology ( const RadioAccessTechnology & radio_access_technology ) [inline]

void NRegStateIndArg::SetStatus ( const RegisterStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:31:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NumberIdentificationAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NumberIdentificationAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for NumberIdentificationAction:

[legend]
Collaboration diagram for NumberIdentificationAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
InputParser::SsProcedure | GetSsProcedure () const
Returns the procedure type.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
NumberIdentificationAction ()
virtual | ~NumberIdentificationAction ()

Protected Member Functions

virtual InputParser::SsCode | GetSsCode () const =0

Detailed Description

Base class NumberIdentificationAction analyzes if the input string has the meaning of interrogation of CLIP, COLP and COLR. Execute has to be overwritten to implement the sending of the SS string.

Constructor & Destructor Documentation

NumberIdentificationAction::NumberIdentificationAction ( )

NumberIdentificationAction::~NumberIdentificationAction ( ) [virtual]

Member Function Documentation

InputAction * NumberIdentificationAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

virtual InputParser::SsCode NumberIdentificationAction::GetSsCode ( ) const [protected, pure virtual]

Implemented in ClipAction, CnapAction, ColpAction, and ColrAction.

InputParser::SsProcedure NumberIdentificationAction::GetSsProcedure ( ) const [inline]

Returns the procedure type.

BOOLEAN NumberIdentificationAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:31:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NumberPrompt Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NumberPrompt Class Reference
[DataConn]

#include <Applications/DataConn/NumberPrompt.hpp>

Public Types

typedef MmiPrompt | Base

Public Member Functions

INT | GetInt () const
UINT | GetUInt () const
void | Init (const WCHAR *title=0)
NumberPrompt ()
void | SetInt (INT i)
void | SetUInt (UINT ui)
virtual | ~NumberPrompt ()

Member Typedef Documentation

typedef MmiPrompt NumberPrompt::Base

Constructor & Destructor Documentation

NumberPrompt::NumberPrompt ( )

NumberPrompt::~NumberPrompt ( ) [virtual]

Member Function Documentation

INT NumberPrompt::GetInt ( ) const

UINT NumberPrompt::GetUInt ( ) const

void NumberPrompt::Init ( const WCHAR * title = 0 )

void NumberPrompt::SetInt ( INT i )

void NumberPrompt::SetUInt ( UINT ui )

The documentation for this class was generated from the following files:
  • Applications/DataConn/NumberPrompt.hpp
  • Applications/DataConn/NumberPrompt.cpp
Generated on Wed Jan 25 01:31:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NumericInputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NumericInputMapper Class Reference
[Editors]

#include <Apoxi/Gui/NumericInputMapper.hpp>

Inheritance diagram for NumericInputMapper:

[legend]
Collaboration diagram for NumericInputMapper:

[legend]

Public Member Functions

virtual Alphabet | GetAlphabet () const
virtual INT | GetId () const
NumericInputMapper ()
virtual | ~NumericInputMapper ()

Protected Member Functions

virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Detailed Description

Allows to input the numbers 0 to 9 into an editor.

Constructor & Destructor Documentation

NumericInputMapper::NumericInputMapper ( ) [explicit]

NumericInputMapper::~NumericInputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet NumericInputMapper::GetAlphabet ( ) const [virtual]

Returns SevenBitAlphabet.

See also:
InputMapper::GetAlphabet.

Reimplemented from InputMapper.

Reimplemented in CalculatorInputMapper, DateTimeInputMapper, IpAddrInputMapper, and PhoneNumberInputMapper.

INT NumericInputMapper::GetId ( ) const [virtual]

See also:
InputMapper::GetId()

Implements InputMapper.

Reimplemented in CalculatorInputMapper, DateTimeInputMapper, IpAddrInputMapper, and PhoneNumberInputMapper.

BOOLEAN NumericInputMapper::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
InputMapper::OnKeyDown()

Reimplemented from InputMapper.

Reimplemented in CalculatorInputMapper, DateTimeInputMapper, IpAddrInputMapper, and PhoneNumberInputMapper.

The documentation for this class was generated from the following files:
  • Gui/NumericInputMapper.hpp
  • Gui/NumericInputMapper.cpp
Generated on Wed Jan 25 01:31:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NvRamBlockInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NvRamBlockInfo Struct Reference

#include <Apoxi/Compat/NvRamStorage.hpp>

Data Fields

INT | array_size
DataRecordId id
INT | size

Field Documentation

INT NvRamBlockInfo::array_size

DataRecordId NvRamBlockInfo::id

INT NvRamBlockInfo::size

The documentation for this struct was generated from the following file:
  • Compat/NvRamStorage.hpp
Generated on Wed Jan 25 01:31:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NvRamDataRecordHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NvRamDataRecordHandler Class Reference

#include <Apoxi/Compat/NvRamDataRecordHandler.hpp>

Inheritance diagram for NvRamDataRecordHandler:

[legend]
Collaboration diagram for NvRamDataRecordHandler:

[legend]

Public Member Functions

virtual BOOLEAN | AddRecord (const DataRecord *rec)
virtual BOOLEAN | DeleteRecord (INT row)
void | Init ()
virtual BOOLEAN | LoadRecord (INT row, DataRecord *rec)
NvRamDataRecordHandler (const INT record_length, DataRecord &record)
virtual BOOLEAN | StoreRecord (INT row, const DataRecord *rec)

Constructor & Destructor Documentation

NvRamDataRecordHandler::NvRamDataRecordHandler | ( | const INT | record_length,
 |  | DataRecord & | record
 | ) |

Member Function Documentation

BOOLEAN NvRamDataRecordHandler::AddRecord ( const DataRecord * rec ) [virtual]

AddRecord is used to add a DataRecord.

Parameters:
*rec,: pointer to the DataRecord to be added.
Returns:
TRUE if record is successfully added, FALSE otherwise.

Implements DataRecordHandler.

BOOLEAN NvRamDataRecordHandler::DeleteRecord ( INT row ) [virtual]

DeleteRecord is used to delete a DataRecord on a specific row.

Parameters:
row,: row which to be deleted.
Returns:
TRUE if record is successfully deleted, FALSE otherwise.

Implements DataRecordHandler.

void NvRamDataRecordHandler::Init ( )

BOOLEAN NvRamDataRecordHandler::LoadRecord | ( | INT | row,
 |  | DataRecord * | rec
 | ) | [virtual]

LoadRecord is used to load a DataRecord from a specific row.

Parameters:
row,: row from which to load.
*rec,: pointer to the DataRecord (buffer) where the loaded record is stored.
Returns:
TRUE if record is successfully loaded, FALSE otherwise.

Implements DataRecordHandler.

BOOLEAN NvRamDataRecordHandler::StoreRecord | ( | INT | row,
 |  | const DataRecord * | rec
 | ) | [virtual]

StoreRecord is used to store a DataRecord into a specific row. The row has to be already filled with a record. Use AddRecord if this is not the case.

Parameters:
row,: row in which to store
*rec,: pointer to the DataRecord to be stored.
Returns:
TRUE if record is successfully stored, FALSE otherwise.

Implements DataRecordHandler.

The documentation for this class was generated from the following files:
  • Compat/NvRamDataRecordHandler.hpp
  • Compat/NvRamDataRecordHandler.cpp
Generated on Wed Jan 25 01:31:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NvRamStorage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NvRamStorage Class Reference

#include <Apoxi/Compat/NvRamStorage.hpp>

Collaboration diagram for NvRamStorage:

[legend]

Public Member Functions

BOOLEAN | GetBlockInfo (DataRecordId block_id, NvRamBlockInfo &info)
BOOLEAN | Read (DataRecord *record, INT idx=0)
BOOLEAN | Store (const DataRecord *record, INT idx=0)

Static Public Member Functions

static NvRamStorage * | GetStorage ()
static void | SetNvRamStorageInfo (const NvRamBlockInfo *info)

Member Function Documentation

BOOLEAN NvRamStorage::GetBlockInfo | ( | DataRecordId | block_id,
 |  | NvRamBlockInfo & | info
 | ) |

NvRamStorage * NvRamStorage::GetStorage ( ) [static]

BOOLEAN NvRamStorage::Read | ( | DataRecord * | record,
 |  | INT | idx = 0
 | ) |

static void NvRamStorage::SetNvRamStorageInfo ( const NvRamBlockInfo * info ) [inline, static]

BOOLEAN NvRamStorage::Store | ( | const DataRecord * | record,
 |  | INT | idx = 0
 | ) |

The documentation for this class was generated from the following files:
  • Compat/NvRamStorage.hpp
  • Compat/NvRamStorage.cpp
Generated on Wed Jan 25 01:31:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: NwDiscStartIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

NwDiscStartIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for NwDiscStartIndMsg:

[legend]
Collaboration diagram for NwDiscStartIndMsg:

[legend]

Public Types

enum | { ID = 18606 }

Public Member Functions

virtual Message * | Clone () const
const MnCause & | GetCallClearingCause () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
NwDiscStartIndMsg (ExecutionContext *context, const CallHdl &call_hdl, const MnCause &call_clearing_cause)
void | SetCallClearingCause (const MnCause &call_clearing_cause)
void | SetCallHdl (const CallHdl &call_hdl)
virtual | ~NwDiscStartIndMsg ()

Detailed Description

NwDiscStartIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

NwDiscStartIndMsg::NwDiscStartIndMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl,
 |  | const MnCause & | call_clearing_cause
 | ) |

NwDiscStartIndMsg::~NwDiscStartIndMsg ( ) [virtual]

Member Function Documentation

Message * NwDiscStartIndMsg::Clone ( ) const [virtual]

Implements Message.

const MnCause& NwDiscStartIndMsg::GetCallClearingCause ( ) const [inline]

const CallHdl& NwDiscStartIndMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & NwDiscStartIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void NwDiscStartIndMsg::SetCallClearingCause ( const MnCause & call_clearing_cause ) [inline]

void NwDiscStartIndMsg::SetCallHdl ( const CallHdl & call_hdl ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:31:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexAbstractPort Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexAbstractPort Class Reference
[OBEX]

Internal base class for OBEX transport interfaces. More...

#include <Apoxi/Obex/ObexAbstractPort.hpp>

Inheritance diagram for ObexAbstractPort:

[legend]
Collaboration diagram for ObexAbstractPort:

[legend]

Public Types

enum EventType {
FSM_INTERNAL_EVENTS, EvOpen, EvClose, EvOpComplete,
EvResolveComplete, EvAvsChanged, EvAvsReady, EvAvsIsBad,
EvResolveSuccess, EvResolveFailure, EvOpenSuccess, EvOpenFailure,
EvReleaseComplete
}
Event opcodes for the port's Finite State Machine (fsm). More...

Public Member Functions

BOOLEAN | AcceptsMessage (const ObexAddrMsg &msg)
Try to dispatch an ObexAddrMsg in the context of the port.
BOOLEAN | AcceptsMessage (const ObexMsg &msg)
Try to dispatch an ObexMsg in the context of the port.
void | CheckTransportAvailable ()
Check whether the transport is still available.
void | Close ()
Starts the close procedure on the channel.
const ObexChannel & | GetChannel () const
Returns the ObexChannel associated with the port.
ObexProtocol & GetProtocol ()
Returns the ObexProtocol associated with the port.
BOOLEAN | IsBoundTo (const ObexChannel &ch) const
Tells whether the port is bound to the passed channel.
void | Open ()
Starts the open procedure on the channel.
virtual | ~ObexAbstractPort ()
Destructor.

Protected Member Functions

virtual void | AbortAddrResolution ()=0
Abort running address resolution procedure.
EventType | AbortResolveAction (FsmEngine &, EventType, ObjectObtainer &)
virtual BOOLEAN | AcquireChannel (ObexChannel &channel, const ObexAddrPtr &addr_ptr, ObexResult result)=0
Check address and obtain channel.
EventType | CloseAction (FsmEngine &, EventType, ObjectObtainer &)
virtual void | CloseChannel (ObexResult cause)=0
Close the channel associated with the port.
EventType | CloseCompleteAction (FsmEngine &, EventType, ObjectObtainer &)
EventType | DefaultAction (FsmEngine &, EventType, ObjectObtainer &)
EventType | DestroyAction (FsmEngine &, EventType, ObjectObtainer &)
EventType | EvalAvsAction (FsmEngine &, EventType, ObjectObtainer &)
void | ExternalEvent (EventType ev_type, ObtainableObject *ev_data_ptr)
const ObexAddrPtr & | GetAddress ()
virtual const CHAR * | GetTraceInfo () const
ObexAbstractTransport & GetTransport ()
const ObexOperationId & | GetTransportOperId () const
BOOLEAN | IsAvsReady () const
BOOLEAN | IsInState (const FsmEngine::StateInfo &state) const
ObexAbstractPort (ObexAbstractTransport &transport, ObexProtocol &protocol, const FsmEngine::StateInfo &initial_state)
Constructor.
virtual void | OnChannelClosed ()=0
Indicates completion of a Close() operation.
virtual void | OnChannelOpened (ObexResult result)=0
Indicates completion of an Open() operation.
EventType | OpenAction (FsmEngine &, EventType, ObjectObtainer &)
virtual void | OpenChannel (const ObexAddrPtr &addr_ptr)=0
Open the channel associated with the port.
EventType | OpenCompleteAction (FsmEngine &, EventType, ObjectObtainer &)
EventType | ReleaseAction (FsmEngine &, EventType, ObjectObtainer &)
void | ReleaseAddress ()
virtual void | ReleaseChannel ()
Release the channel associated with the port.
EventType | ResolveCompleteAction (FsmEngine &, EventType, ObjectObtainer &)
void | SetAddress (const ObexAddrPtr &addr_ptr)
virtual void | StartAddrResolution ()=0
Resolve an OBEX URL string using the transport's interface.
ObexOperationId & StartOperation ()
Start a new asynchronous operation and returns its id.
EventType | StartResolveAction (FsmEngine &, EventType, ObjectObtainer &)

Friends

class | FsmEngine

Data Structures

struct | AddressEvent
Event data type for EvResolveComplete. More...
struct | CompleteEvent
Event data type for EvOpComplete. More...

Detailed Description

Internal base class for OBEX transport interfaces.

Warning;
This is an internal interface and must not be used outside APOXI OBEX at all.

Its purpose is to specify an interface towards the different transport layers used by OBEX. The concept is similar to BSD sockets with the exception that all operations are performed asynchronously. Therefore each port implementation contains a state machine which controls port behaviour. Additionally the class provides common functions used by the derived classes ObexServerPort and ObexClientPort which implement the interface to realize server- and client type ports.

Member Enumeration Documentation

enum ObexAbstractPort::EventType

Event opcodes for the port's Finite State Machine (fsm).

Enumerator:
FSM_INTERNAL_EVENTS
EvOpen | Triggers open procedure.
EvClose | Triggers close procedure.
EvOpComplete | OnComplete() was called.
EvResolveComplete | ReturnObexAddress() was called.
EvAvsChanged | Transport's AVS has changed.
EvAvsReady | Transport's AVS is AvsReady.
EvAvsIsBad | Transport's AVS is not AvsReady.
EvResolveSuccess | Address resolution completed successfully.
EvResolveFailure | Address resolution completed with error(s).
EvOpenSuccess | Channel open procedure completed successfully.
EvOpenFailure | Channel open procedure completed with error(s).
EvReleaseComplete | Channel was released.

Constructor & Destructor Documentation

ObexAbstractPort::~ObexAbstractPort ( ) [virtual]

Destructor.

ObexAbstractPort::ObexAbstractPort | ( | ObexAbstractTransport & | transport,
 |  | ObexProtocol & | protocol,
 |  | const FsmEngine::StateInfo & | initial_state
 | ) | [protected]

Constructor.

Member Function Documentation

virtual void ObexAbstractPort::AbortAddrResolution ( ) [protected, pure virtual]

Abort running address resolution procedure.

Implemented in ObexClientPort, and ObexServerPort.

ObexAbstractPort::EventType ObexAbstractPort::AbortResolveAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

BOOLEAN ObexAbstractPort::AcceptsMessage ( const ObexAddrMsg & msg )

Try to dispatch an ObexAddrMsg in the context of the port.

When the message type and operation id match that of an operation ongoing for the port, the operation is completed an 'TRUE' is returned. The message may be considered as dispatched then. In any other case, 'FALSE' is returned and dispatching should continue.

BOOLEAN ObexAbstractPort::AcceptsMessage ( const ObexMsg & msg )

Try to dispatch an ObexMsg in the context of the port.

When the message type and operation id match that of an operation ongoing for the port, the operation is completed an 'TRUE' is returned. The message may be considered as dispatched then. In any other case, 'FALSE' is returned and dispatching should continue.

virtual BOOLEAN ObexAbstractPort::AcquireChannel | ( | ObexChannel & | channel,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | ObexResult | result
 | ) | [protected, pure virtual]

Check address and obtain channel.

Returns:
'TRUE' on success, 'FALSE' on failure.

Implemented in ObexClientPort, and ObexServerPort.

void ObexAbstractPort::CheckTransportAvailable ( )

Check whether the transport is still available.

Must be called when an ObexTransportMsg is received which affects the transport associated with the port.

void ObexAbstractPort::Close ( )

Starts the close procedure on the channel.

This launches an asynchronous procedure which is completed by calling OnChannelClosed().

ObexAbstractPort::EventType ObexAbstractPort::CloseAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

virtual void ObexAbstractPort::CloseChannel ( ObexResult cause ) [protected, pure virtual]

Close the channel associated with the port.

Implemented in ObexClientPort, and ObexServerPort.

EventType ObexAbstractPort::CloseCompleteAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

ObexAbstractPort::EventType ObexAbstractPort::DefaultAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

ObexAbstractPort::EventType ObexAbstractPort::DestroyAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

ObexAbstractPort::EventType ObexAbstractPort::EvalAvsAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

const CHAR * ObexAbstractPort::GetTraceInfo ( ) const [protected, virtual]

BOOLEAN ObexAbstractPort::IsAvsReady ( ) const [protected]

virtual void ObexAbstractPort::OnChannelClosed ( ) [protected, pure virtual]

Indicates completion of a Close() operation.

Implemented in ObexClientPort, and ObexServerPort.

virtual void ObexAbstractPort::OnChannelOpened ( ObexResult result ) [protected, pure virtual]

Indicates completion of an Open() operation.

Implemented in ObexClientPort, and ObexServerPort.

void ObexAbstractPort::Open ( )

Starts the open procedure on the channel.

This launches an asynchronous procedure which is completed by calling OnChannelOpened().

ObexAbstractPort::EventType ObexAbstractPort::OpenAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

virtual void ObexAbstractPort::OpenChannel ( const ObexAddrPtr & addr_ptr ) [protected, pure virtual]

Open the channel associated with the port.

Implemented in ObexClientPort, and ObexServerPort.

ObexAbstractPort::EventType ObexAbstractPort::OpenCompleteAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

ObexAbstractPort::EventType ObexAbstractPort::ReleaseAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

void ObexAbstractPort::ReleaseChannel ( ) [protected, virtual]

Release the channel associated with the port.

ObexAbstractPort::EventType ObexAbstractPort::ResolveCompleteAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

virtual void ObexAbstractPort::StartAddrResolution ( ) [protected, pure virtual]

Resolve an OBEX URL string using the transport's interface.

Implemented in ObexClientPort, and ObexServerPort.

ObexOperationId & ObexAbstractPort::StartOperation ( ) [protected]

Start a new asynchronous operation and returns its id.

ObexAbstractPort::EventType ObexAbstractPort::StartResolveAction | ( | FsmEngine & | ,
 |  | EventType | ,
 |  | ObjectObtainer & |
 | ) | [protected]

Friends And Related Function Documentation

friend class FsmEngine [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexAbstractPort.hpp
  • Obex/ObexAbstractPort.cpp
Generated on Wed Jan 25 01:32:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexAbstractPort::AddressEvent Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ObexAbstractPort::AddressEvent

ObexAbstractPort::AddressEvent Struct Reference

Event data type for EvResolveComplete. More...

#include <Apoxi/Obex/ObexAbstractPort.hpp>

Inheritance diagram for ObexAbstractPort::AddressEvent:

[legend]
Collaboration diagram for ObexAbstractPort::AddressEvent:

[legend]

Public Member Functions

AddressEvent (const ObexAddrMsg &addr_msg)

Data Fields

const ObexAddrMsg & m_addr_msg

Detailed Description

Event data type for EvResolveComplete.

Constructor & Destructor Documentation

ObexAbstractPort::AddressEvent::AddressEvent ( const ObexAddrMsg & addr_msg ) [inline]

Field Documentation

const ObexAddrMsg& ObexAbstractPort::AddressEvent::m_addr_msg

The documentation for this struct was generated from the following file:
  • Obex/ObexAbstractPort.hpp
Generated on Wed Jan 25 01:32:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexAbstractPort::CompleteEvent Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ObexAbstractPort::CompleteEvent

ObexAbstractPort::CompleteEvent Struct Reference

Event data type for EvOpComplete. More...

#include <Apoxi/Obex/ObexAbstractPort.hpp>

Inheritance diagram for ObexAbstractPort::CompleteEvent:

[legend]
Collaboration diagram for ObexAbstractPort::CompleteEvent:

[legend]

Public Member Functions

CompleteEvent (const ObexMsg &obex_msg)

Data Fields

const ObexResult c_result

Detailed Description

Event data type for EvOpComplete.

Constructor & Destructor Documentation

ObexAbstractPort::CompleteEvent::CompleteEvent ( const ObexMsg & obex_msg ) [inline]

Field Documentation

const ObexResult ObexAbstractPort::CompleteEvent::c_result

The documentation for this struct was generated from the following file:
  • Obex/ObexAbstractPort.hpp
Generated on Wed Jan 25 01:32:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexAbstractTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexAbstractTransport Class Reference
[OBEX]

Internal abstract interface base class for OBEX transports. More...

#include <Apoxi/Obex/ObexTransport.hpp>

Inheritance diagram for ObexAbstractTransport:

[legend]
Collaboration diagram for ObexAbstractTransport:

[legend]

Public Types

enum | { ClientAddrTypeId = 0, ServerAddrTypeId = 0x80 }
enum | { NoObjectId = APOXI_OBEX_MAX_NO_TRANSPORTS }
typedef ObexTransportId | ObjectId

Public Member Functions

virtual void | AbortResolveClientAddr (const ObexOperationId &job_id)
Aborts a running client address resolution procedure.
ObexAddrTypeId | GetClientAddrTypeId () const
Returns the type identifier of a client address.
AbstractTransport & | GetDeviceAbstraction () const
Returns the associated transport device abstraction.
ObjectId | GetObjectId () const
Return the unique object id of the transport.
virtual ObexProtocol * | GetProtocol (ObexProtocolId level)=0
Provides access to the protocol layer object of the specified level.
ObexAddrTypeId | GetServerAddrTypeId () const
Returns the type identifier of a server address.
const CHAR * | GetUrlScheme () const
Returns the URL scheme (name that preceedes ://).
BOOLEAN | IsMatchedByUrl (const String &obex_url) const
Tells if the passed URL scheme matches the transport.
virtual void | ResolveClientAddr (const String &remote_url, ObexProtocolId prot_id, ObexOperationId job_id)=0
Resolves an OBEX client address URL.
virtual void | ResolveServerAddr (const String &local_url, ObexProtocolId prot_id, BOOLEAN sdb_autocreate, ObexOperationId job_id)=0
Resolves an OBEX server address URL.

Protected Member Functions

void | Init (AbstractTransport &device_abs, const CHAR *scheme_url)
ObexAbstractTransport ()
Restricts construction to derived classes.
virtual void | OnUpdate (ObservableObject *obs_obj)
void | Register ()
Registers a transport implementation with the ObexMngr.
void | ReturnObexAddress (const ObexAddrPtr &addr_ptr, ObexOperationId oper_id, ObexResult result)
Return an OBEX address to the requester asynchronously.

Detailed Description

Internal abstract interface base class for OBEX transports.

Warning;
This is an internal interface and must not be used outside APOXI at all.

It must be implemented by all transport adapters, hence developers of transport adapters for APOXI OBEX will need to understand the concepts explained in the following paragraphs.

This class mainly serves the following purposes:

  • Abstraction of transport stack and underlying hardware.
    Each instance of a class derived from ObexAbstractTransport registers itself with the Transport Registry by calling Register() at startup time. It also becomes an observer of the related transport hardware abstraction and notifies OBEX servers and clients when the state of the hardware changes (for example, when an USB cable is plugged or infrared is turned off) by sending out an ObexTransportMsg.

  • Providing access to the stack-specific OBEX implementation.
    The GetProtocol() method must be implemented to return a pointer to the transport-specific OBEX implementation when ObexPrIdOpp is passed as actual parameter. Other protocols may be supported as well. The OBEX protocol implementation must provide an instance of a class derived from ObexLayer. This class is responsible for forwarding outbound events to the protocol stack and notifying incoming events to APOXI OBEX.

  • Address resolution for server- and client addresses.
    Server address resolution may involve checking the address for ambiguity and entering it into a database to advertise the offered service to remote devices (Bluetooth SDB, IrDA IRIAS). Client address resolution usually means service discovery and obtaining a logical address suitable for establishing a transport connection to a remote server.

Member Typedef Documentation

typedef ObexTransportId ObexAbstractTransport::ObjectId

Unique id of a transport instance. The object id is assigned to the transport when it registers with the Transport Manager.

See also:
NoTransportId

Member Enumeration Documentation

anonymous enum

Enumerator:
ClientAddrTypeId | Offset for server addresses.
ServerAddrTypeId | Offset for client addresses.

anonymous enum

Enumerator:
NoObjectId Object Id of an unregistered transport.

Constructor & Destructor Documentation

ObexAbstractTransport::ObexAbstractTransport ( ) [protected]

Restricts construction to derived classes.

As all transport implementations are supposed to be statically allocated singletons initialization is done by calling the Init() method.

Member Function Documentation

virtual void ObexAbstractTransport::AbortResolveClientAddr ( const ObexOperationId & job_id ) [inline, virtual]

Aborts a running client address resolution procedure.

Parameters:
job_id Operation Id of the procedure to be aborted.

Reimplemented in IrdaObexTransport.

virtual ObexProtocol* ObexAbstractTransport::GetProtocol ( ObexProtocolId level ) [pure virtual]

Provides access to the protocol layer object of the specified level.

Parameters:
level Protocol level / layer
Returns:
Pointer to object or '0' if protocol is unsupported.
Note: All transports must support at least ObexProtocol::ObexLevel !

Implemented in UsbObexTransport, BtObexTransport, and IrdaObexTransport.

void ObexAbstractTransport::Init | ( | AbstractTransport & | device_abs,
 |  | const CHAR * | scheme_url
 | ) | [protected]

Initialization method restricted to derived classes.

Parameters:
scheme_url Scheme identifier from URL. The URL takes the form: <scheme>://<address>{,<options>}
device_abs Transport device abstraction object

Note: scheme_url must be unique among all transport implementations within the system, otherwise registration Register() will fail

Reimplemented in StreamObexTransport.

BOOLEAN ObexAbstractTransport::IsMatchedByUrl ( const String & obex_url ) const

Tells if the passed URL scheme matches the transport.

Returns:
'TRUE' When the 'scheme' within the URL equals the one associated with the transport or is the wildcard designator '*', 'FALSE' otherwise

void ObexAbstractTransport::OnUpdate ( ObservableObject * obs_obj ) [protected, virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from Observer.

Reimplemented in UsbObexTransport.

void ObexAbstractTransport::Register ( ) [protected]

Registers a transport implementation with the ObexMngr.

Should be called by every transport implementation at startup time, but only after initialization of internal objects has been completed.

virtual void ObexAbstractTransport::ResolveClientAddr | ( | const String & | remote_url,
 |  | ObexProtocolId | prot_id,
 |  | ObexOperationId | job_id
 | ) | [pure virtual]

Resolves an OBEX client address URL.

This is a factory method which evaluates the URL given in string format and creates an address information object which may contain specific information for the transport. This is accomplished by deriving a subclass from ObexClientAddr and creating an address information object from this class. Then a smartpointer of type ObexAddrPtr to this object and the job_id which was supplied with the URL must be returned by calling ReturnObexAddress().

Parameters:
remote_url | Remote address in URL format - the URL the client is going to connect to.
prot_id | Protocol which will be bound to the address
job_id | Reference to associate request and response

Implemented in UsbObexTransport, BtObexTransport, and IrdaObexTransport.

virtual void ObexAbstractTransport::ResolveServerAddr | ( | const String & | local_url,
 |  | ObexProtocolId | prot_id,
 |  | BOOLEAN | sdb_autocreate,
 |  | ObexOperationId | job_id
 | ) | [pure virtual]

Resolves an OBEX server address URL.

This is a factory method which evaluates the URL given in string format and creates an address information object which may contain specific information for the transport. This is accomplished by deriving a subclass from ObexServerAddr and creating an address information object from this class. Then a smartpointer of type ObexAddrPtr to this object and the job_id which was supplied with the URL must be returned by calling ReturnObexAddress().

Parameters:
local_url | Local server address in URL format - the URL the server is going to listen on.
prot_id | Protocol which will be bound to the address
sdb_autocreate | Check whether address can be autoregistered
job_id | Reference to associate request and response

Implemented in UsbObexTransport, BtObexTransport, and IrdaObexTransport.

void ObexAbstractTransport::ReturnObexAddress | ( | const ObexAddrPtr & | addr_ptr,
 |  | ObexOperationId | oper_id,
 |  | ObexResult | result
 | ) | [protected]

Return an OBEX address to the requester asynchronously.

Parameters:
addr_ptr | ObexAddrPtr which holds the ObexAddress instance to be delivered.
oper_id | Associated Operation Id which was passed to ResolveClientAddr() or ResolveServerAddr()
result | ObexResult::Ok() should be passed when URL parsing has produced a valid address instance. Otherwise, addr_ptr should be left empty (pass ObexAddrPtr()) and the result should indicate an appropriate error cause.

The documentation for this class was generated from the following files:
  • Obex/ObexTransport.hpp
  • Obex/ObexTransport.cpp
Generated on Wed Jan 25 01:32:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexAddress Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexAddress Class Reference
[OBEX]

Base class for client- and server address information. More...

#include <Apoxi/Obex/ObexAddress.hpp>

Inheritance diagram for ObexAddress:

[legend]
Collaboration diagram for ObexAddress:

[legend]

Public Types

typedef ReferableObject | Base

Public Member Functions

ObexAbstractTransport & | GetTransport () const
Returns the transport associated with the address.
ObexTransportId | GetTransportId () const
Returns the id of the transport associated with the address.
virtual ObexAddrTypeId | GetTypeId () const =0
Returns the unique id of the ObexAddrInfo subclass.
virtual ObexResult | ToString (String &obex_url) const
Converts the ObexAddrInfo into string format.

Protected Member Functions

ObexAddress (ObexTransportId transport_id)
Constructor. Restricts construction to derived classes.

Detailed Description

Base class for client- and server address information.

Not intended for user derivation - derive from either ObexClientAddr or ObexServerAddr instead !

Member Typedef Documentation

typedef ReferableObject ObexAddress::Base

Reimplemented in IrdaObexClientAddr, IrdaObexServerAddr, ObexClientAddr, and ObexServerAddr.

Constructor & Destructor Documentation

ObexAddress::ObexAddress ( ObexTransportId transport_id ) [protected]

Constructor. Restricts construction to derived classes.

Member Function Documentation

ObexAbstractTransport & ObexAddress::GetTransport ( ) const

Returns the transport associated with the address.

virtual ObexAddrTypeId ObexAddress::GetTypeId ( ) const [pure virtual]

Returns the unique id of the ObexAddrInfo subclass.

Implemented in ObexClientAddr, and ObexServerAddr.

ObexResult ObexAddress::ToString ( String & obex_url ) const [virtual]

Converts the ObexAddrInfo into string format.

Parameters:
obex_url String to append the result to
Returns:
TRUE if the conversion was successful, FALSE otherwise.

Reimplemented in UsbObexServerAddr, BtObexClientAddr, BtObexServerAddr, IrdaObexClientAddr, and IrdaObexServerAddr.

The documentation for this class was generated from the following files:
  • Obex/ObexAddress.hpp
  • Obex/ObexAddress.cpp
Generated on Wed Jan 25 01:32:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexAddrMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexAddrMsg Class Reference

#include <Apoxi/Obex/ObexMessages.hpp>

Inheritance diagram for ObexAddrMsg:

[legend]
Collaboration diagram for ObexAddrMsg:

[legend]

Public Types

enum | { ID = 11002 }

Public Member Functions

virtual Message * | Clone () const
const ObexAddrPtr & | GetAddrPtr () const
virtual const MsgMetaData & | GetMetaData () const
const ObexOperationId & | GetOperationId () const
const ObexResult & | GetResult () const
ObexAddrMsg (const ObexResult &result, const ObexOperationId &operation_id, const ObexAddrPtr &addr_ptr=ObexAddrPtr())
virtual | ~ObexAddrMsg ()

Detailed Description

Sent by ObexTransport in response to a request for an OBEX address

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ObexAddrMsg::ObexAddrMsg | ( | const ObexResult & | result,
 |  | const ObexOperationId & | operation_id,
 |  | const ObexAddrPtr & | addr_ptr = ObexAddrPtr()
 | ) |

ObexAddrMsg::~ObexAddrMsg ( ) [virtual]

Member Function Documentation

Message * ObexAddrMsg::Clone ( ) const [virtual]

Implements Message.

const ObexAddrPtr& ObexAddrMsg::GetAddrPtr ( ) const [inline]

const MsgMetaData & ObexAddrMsg::GetMetaData ( ) const [virtual]

Implements Message.

const ObexOperationId& ObexAddrMsg::GetOperationId ( ) const [inline]

const ObexResult& ObexAddrMsg::GetResult ( ) const [inline]

The documentation for this class was generated from the following files:
  • Obex/ObexMessages.hpp
  • Obex/ObexMessages.cpp
Generated on Wed Jan 25 01:32:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexApp Class Reference
[ObexApp]

#include <Applications/ObexApp/ObexApp.hpp>

Collaboration diagram for ObexApp:

[legend]

Public Member Functions

void | Init ()
virtual | ~ObexApp ()
Destructor.

Static Public Member Functions

static ObexApp * | GetInstance ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()

Constructor & Destructor Documentation

ObexApp::~ObexApp ( ) [virtual]

Destructor.

Member Function Documentation

ObexApp * ObexApp::GetInstance ( ) [static]

void ObexApp::Init ( )

BOOLEAN ObexApp::OnMessage ( const Message & msg ) [protected, virtual]

void ObexApp::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/ObexApp/ObexApp.hpp
  • Applications/ObexApp/ObexApp.cpp
Generated on Wed Jan 25 01:32:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexAppMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexAppMsg Class Reference

#include <Apoxi/Obex/ObexAppMsg.hpp>

Inheritance diagram for ObexAppMsg:

[legend]
Collaboration diagram for ObexAppMsg:

[legend]

Public Types

enum | { ID = 11005 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const ObexAppMsgType & | GetMsgType () const
ObexAppMsg (ExecutionContext *context, const ObexAppMsgType &msg_type)
virtual | ~ObexAppMsg ()

Detailed Description

Sent by APOXI OBEX when user interaction is required

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ObexAppMsg::ObexAppMsg | ( | ExecutionContext * | context,
 |  | const ObexAppMsgType & | msg_type
 | ) |

ObexAppMsg::~ObexAppMsg ( ) [virtual]

Member Function Documentation

Message * ObexAppMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ObexAppMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const ObexAppMsgType& ObexAppMsg::GetMsgType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Obex/ObexAppMsg.hpp
  • Obex/ObexAppMsg.cpp
Generated on Wed Jan 25 01:32:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexBuffer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexBuffer Class Reference
[OBEX]

Provides exclusive access to a buffer holding BODY data. More...

#include <Apoxi/Obex/ObexBuffer.hpp>

Collaboration diagram for ObexBuffer:

[legend]

Public Types

typedef const UINT8 * | ConstDataPtr
typedef UINT8 * | DataPtr
typedef UINT32 | Offset
typedef UINT32 | Size

Public Member Functions

void | Empty ()
Makes a valid non-empty buffer appear empty again.
Size | GetCapacity () const
Returns the maximum data site which can be stored in the buffer.
Size | GetSize () const
Returns the size of the data block.
BOOLEAN | IsValid () const
Tells whether the buffer refers to a data block.
ObexBuffer (ObexBuffer &take_from)
Copy constructor with transfer of ownership semantics !
ObexBuffer (Size capacity)
Constructs an ObexBuffer and allocates memory for it.
ObexBuffer ()
Constructs an invalid ObexBuffer.
ObexBuffer & | operator= (ObexBuffer &take_from)
Assignment operator with transfer of ownership semantics !
void | Release ()
Release memory allocated by constructor and initialize object to virgin state.
~ObexBuffer ()
Destroys an ObexBuffer object.

Friends

class | Factory
class | Reader
class | Writer

Data Structures

class | Factory
Factory class for ObexBuffers with user-defined memory manangement strategy. More...
class | Reader
Accessor class to read data from an ObexBuffer. More...
class | Writer
Accessor class to write data into an ObexBuffer. More...

Detailed Description

Provides exclusive access to a buffer holding BODY data.

This class manages memory buffers according to a transfer-of-ownership paradigm similar to that of the auto_ptr<> class of the STL. The buffers hold OBEX BODY data which is either transferred from application layer towards the Transport Adapter and stack or vice-versa. Access to the manages buffer is granted only through accessor object instances which must be passed an ObexBuffer instance as constructor parameter. The accessor classes Reader and Writer are available as public inner classes of ObexBuffer.

Destruction of a valid ObexBuffer instance also means destruction of the managed memory buffer which helps to avoid memory leaks. Buffers can be allocated either by the constructor (this will allocate memory using new) or by means of a custom buffer factory, which must be derived from the public inner class Factory. While in the former case the destructor takes care of releasing buffer memory, explicitly allocated memory must be deallocated by the associated factory instance, too. Failure to do so will cause the destructor to trigger an assertion. Therefore, unless forced by special circumstances, one should use the standard way of allocating buffer space using the constructor.

Example: The following code sample demonstrates how copy construction and assignment operations affect ownership of a memory buffer managed by ObexBuffer instances.

    static void ShowTransferOfOwnerShip()
    {
       // Create a new ObexBuffer instance which manages a buffer of
       //   1024 bytes of memory allocated on the heap.
       ObexBuffer   new_buffer(1024);

       // 'new_buffer' now manages a memory buffer.
       ASSERT(new_buffer.IsValid());

       // Obtain ownership by copy construction
       ObexBuffer   obtain_by_copy( new_buffer );

       // 'new_buffer' does no longer refer to a memory buffer !
       ASSERT( ! new_buffer.IsValid );

       // ... because 'obtain_by_copy' holds it now !
       ASSERT( obtain_by_copy.IsValid() );

       // but now lets transfer the ownership back to 'new_buffer' by assignment
       new_buffer = obtain_by_copy;

       ASSERT( ! obtain_by_copy.IsValid() );
       ASSERT( new_buffer.IsValid() );
       // On return from the function 'new_buffer' is destroyed releasing the
       // buffer allocated by the constructor.
    }

Member Typedef Documentation

typedef const UINT8* ObexBuffer::ConstDataPtr

typedef UINT8* ObexBuffer::DataPtr

typedef UINT32 ObexBuffer::Offset

typedef UINT32 ObexBuffer::Size

Constructor & Destructor Documentation

ObexBuffer::ObexBuffer ( )

Constructs an invalid ObexBuffer.

The invalid ObexBuffer can obtain ownership of a data buffer by assigning a valid ObexBuffer object to it.

ObexBuffer::ObexBuffer ( Size capacity )

Constructs an ObexBuffer and allocates memory for it.

At construction time, 'capacity' size bytes of memory are allocated using either new or Os::HugeAlloc() as necessary. On destruction of the ObexBuffer object this memory is automatically freed.

Parameters:
size Capacity of the buffer in bytes.

ObexBuffer::ObexBuffer ( ObexBuffer & take_from )

Copy constructor with transfer of ownership semantics !

Assigning a source buffer to a destination buffer will render the source buffer invalid, i.e. it will no longer refer to the chunk of memory it had owner before. This behaviour is much like the auto_ptr<> of the STL !

ObexBuffer::~ObexBuffer ( )

Destroys an ObexBuffer object.

If the internal data buffer was allocated by the ObexBuffer class, it is automatically deleted in an appropriate way. Otherwise no action is taken.

Member Function Documentation

ObexBuffer & ObexBuffer::operator= ( ObexBuffer & take_from )

Assignment operator with transfer of ownership semantics !

Assigning a source buffer to a destination buffer will render the source buffer invalid, i.e. it will no longer refer to the chunk of memory it had owner before. This behaviour is much like the auto_ptr<> of the STL !

Friends And Related Function Documentation

friend class Factory [friend]

friend class Reader [friend]

friend class Writer [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexBuffer.hpp
  • Obex/ObexBuffer.cpp
Generated on Wed Jan 25 01:32:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexBuffer::Factory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ObexBuffer::Factory

ObexBuffer::Factory Class Reference

Factory class for ObexBuffers with user-defined memory manangement strategy. More...

#include <Apoxi/Obex/ObexBuffer.hpp>

Inheritance diagram for ObexBuffer::Factory:

[legend]
Collaboration diagram for ObexBuffer::Factory:

[legend]

Public Member Functions

void | Destroy (ObexBuffer &buffer)
Destroys object previously created by the factory.

Protected Member Functions

void | Construct (ObexBuffer &init_obj, DataPtr data_ptr, Size capacity, Size size=0)
Factory ()
Default constructor.
virtual void | OnRelease (DataPtr user_ptr, Size capacity)=0
Returns an internal data buffer to the factory.

Detailed Description

Factory class for ObexBuffers with user-defined memory manangement strategy.

Applications or OBEX implementations which want to implement their own buffer management strategy (for example, to make use of static buffers provided by a protocol stack) should derive from this class and implement the Create() and OnDestroy() methods accordingly.

Constructor & Destructor Documentation

ObexBuffer::Factory::Factory ( ) [protected]

Default constructor.

Member Function Documentation

void ObexBuffer::Factory::Construct | ( | ObexBuffer & | init_obj,
 |  | DataPtr | data_ptr,
 |  | Size | capacity,
 |  | Size | size = 0
 | ) | [protected]

void ObexBuffer::Factory::Destroy ( ObexBuffer & buffer )

Destroys object previously created by the factory.

Calling destroy takes the ownership of the managed data buffer from the ObexBuffer and, by invoking OnRelease(), passes the internal data buffer back to the factory which should know how to handle it (perhaps nothing, in case of a static buffer, or kepping it in an internal free-list.

Parameters:
ObexBuffer to be recycled.

virtual void ObexBuffer::Factory::OnRelease | ( | DataPtr | user_ptr,
 |  | Size | capacity
 | ) | [protected, pure virtual]

Returns an internal data buffer to the factory.

See also:
Destroy()
Parameters:
user_ptr | Pointer to the internal buffer
capacity | Size of the buffer to be returned
If any cleanup action is required in order to avoid a resource leak, it must be triggered from within this method. It is invoked directly after the ObexBuffer being deleted has released ownership of user_ptr.

The documentation for this class was generated from the following files:
  • Obex/ObexBuffer.hpp
  • Obex/ObexBuffer.cpp
Generated on Wed Jan 25 01:32:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexBuffer::Reader Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ObexBuffer::Reader

ObexBuffer::Reader Class Reference

Accessor class to read data from an ObexBuffer. More...

#include <Apoxi/Obex/ObexBuffer.hpp>

Collaboration diagram for ObexBuffer::Reader:

[legend]

Public Member Functions

void | Commit (Size no_bytes)
Acknowledges that data has been read from the buffer.
Size | CopyTo (DataPtr dest_ptr, Size dest_size)
Copies data into an external buffer.
Size | GetNoBytesReadable () const
Returns the number of bytes which can be read.
Size | GetOffset () const
Returns the buffer offset where data will be read next.
DataPtr | GetPtr () const
Returns the pointer to the data which can be read.
Reader (ObexBuffer &buffer, Size offset=0)
Creates a Reader and attaches it to an ObexBuffer.

Detailed Description

Accessor class to read data from an ObexBuffer.

Constructor & Destructor Documentation

ObexBuffer::Reader::Reader | ( | ObexBuffer & | buffer,
 |  | Size | offset = 0
 | ) |

Creates a Reader and attaches it to an ObexBuffer.

Member Function Documentation

void ObexBuffer::Reader::Commit ( Size no_bytes )

Acknowledges that data has been read from the buffer.

ObexBuffer::Size ObexBuffer::Reader::CopyTo | ( | DataPtr | dest_ptr,
 |  | Size | dest_size
 | ) |

Copies data into an external buffer.

This method reads at most dest_size octets from the ObexBuffer and copies them into the external buffer referenced by 'dest_ptr'. After reading, the offset of the reader is advanced automatically, so don't call Commit() manually when you use this style of reading.

Parameters:
dest_ptr | Pointer to a destination buffer where data read from the ObexBuffer is copied
dest_size | Size of the destination buffer where data read from the ObexBuffer is copied
Returns:
Number of octets actually copied. This is a value between '0' and 'dest_size'.

ObexBuffer::Size ObexBuffer::Reader::GetNoBytesReadable ( ) const

Returns the number of bytes which can be read.

The documentation for this class was generated from the following files:
  • Obex/ObexBuffer.hpp
  • Obex/ObexBuffer.cpp
Generated on Wed Jan 25 01:32:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexBuffer::Writer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ObexBuffer::Writer

ObexBuffer::Writer Class Reference

Accessor class to write data into an ObexBuffer. More...

#include <Apoxi/Obex/ObexBuffer.hpp>

Collaboration diagram for ObexBuffer::Writer:

[legend]

Public Member Functions

void | Commit (Size no_bytes)
Acknowledges that data has been written to the buffer.
Size | CopyFrom (ConstDataPtr from_ptr, Size from_size)
Copies data from an external buffer.
Size | GetNoBytesWritable () const
Returns the number of bytes which can be written.
Size | GetOffset () const
Returns the buffer offset where data is written next.
DataPtr | GetPtr () const
Returns the pointer to the place where data can be written to.
Writer (ObexBuffer &buffer)
Creates a Writer and attaches it to an ObexBuffer.

Detailed Description

Accessor class to write data into an ObexBuffer.

Constructor & Destructor Documentation

ObexBuffer::Writer::Writer ( ObexBuffer & buffer )

Creates a Writer and attaches it to an ObexBuffer.

Member Function Documentation

void ObexBuffer::Writer::Commit ( Size no_bytes )

Acknowledges that data has been written to the buffer.

ObexBuffer::Size ObexBuffer::Writer::CopyFrom | ( | ConstDataPtr | from_ptr,
 |  | Size | from_size
 | ) |

Copies data from an external buffer.

This method reads at most 'from_size' octets from the external buffer referenced by 'from_ptr' and copies them into the ObexBuffer. The size of the ObexBuffer is updated automatically, so don't call Commit() manually when you use this style of writing.

Parameters:
from_ptr | Pointer to an external buffer from which data is read and copied into the ObexBuffer
from_size | Size of the data block which can be read from 'from_ptr'.
Returns:
Number of octets actually copied. This is a value between '0' and 'from_size'.

ObexBuffer::Size ObexBuffer::Writer::GetNoBytesWritable ( ) const

Returns the number of bytes which can be written.

The documentation for this class was generated from the following files:
  • Obex/ObexBuffer.hpp
  • Obex/ObexBuffer.cpp
Generated on Wed Jan 25 01:32:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexChannel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexChannel Class Reference
[OBEX]

Internal association class used to address an OBEX transport channel. More...

#include <Apoxi/Obex/ObexChannel.hpp>

Collaboration diagram for ObexChannel:

[legend]

Public Member Functions

UINT16 | GetIndex () const
Returns the index specified at construction time.
ObexProtocolId | GetProtocolId () const
Returns the type of the associated protocol implementation.
ObexTransportId | GetTransportId () const
Returns the object id of the associated transport implementation.
void | Invalidate ()
Invalidate channel. Initialize the channel as if it had just beed default-constructed.
BOOLEAN | IsClient () const
Tells if the channel is associated with a client.
BOOLEAN | IsServer () const
Tells if the channel is associated with a server.
BOOLEAN | IsUnique () const
Tells if the channel uniquely identifies an OBEX connection.
BOOLEAN | IsValid () const
Tells if the connection is valid.
ObexChannel (const ObexChannel &)
Copy constructor.
ObexChannel (ObexTransportId transport_id, ObexProtocolId protocol_id, BOOLEAN is_server, BOOLEAN is_unique, UINT16 impl_index)
Constructor intended to by used by ObexTransport.
ObexChannel ()
Default constructor. Constructs an invalid 'empty' channel.
ObexChannel & | operator= (const ObexChannel &)
Assignment operator.

Friends

BOOLEAN | operator!= (const ObexChannel &lhs, const ObexChannel &rhs)
Comparison for inequality.
BOOLEAN | operator== (const ObexChannel &lhs, const ObexChannel &rhs)
Comparison for equality.

Detailed Description

Internal association class used to address an OBEX transport channel.

Warning;
This is an internal interface and must not be used outside APOXI at all. However, developers of Transport Adapters for APOXI OBEX will need to understand the concepts explained in the following paragraphs.

ObexChannel instances serve as associations used by the OBEX API classes to refer to a transport connection at Transport Adapter level.

ObexChannel objects are constructed by the factory methods ObexProtocol::AcquireClientChannel and ObexProtocol::AcquireClientChannel which must be implemented by each Transport Adapter implementation. At construction time, the protocol implementation must supply the transport type, the protocol type and an index which can be freely chosen by the implementation class.

Concepts:

Mutual exclusive execution of OBEX operations:

One ObexChannel instance can have only one pending OBEX operation at a time, even if a channel is shared by multiple OBEX connections.

ObexChannel instances come in two flavours:

  • Shared channels ('is_unique' parameter in constructor set to 'FALSE') permit multiple OBEX connections to share one transport connection. Dispatching of incoming server requests is then performed by examining OBEX headers, mainly the MIME type of the object and possibly a TARGET or CONNECTION ID.
  • Unique channels ('is_unique' parameter in constructor set to 'TRUE'), permit exactly one OBEX connection per channel instance. In this case, dispatching can be performed solely by comparing channels.

Channel lifetime:

Each time a channel is created it is assigned an internal 'serial number' which causes 2 channels seperately created specifying the same constructor parameters to appear different from each other. Therefore, when a channel is created within a Transport Adapter, it should be stored in a member variable until ObexProtocol::AcquireClientChannel() is called to request its deletion. Then, after having performed necessary internal cleanup actions, Invalidate() should be called on the corresponding ObexChannel instance.

Constructor & Destructor Documentation

ObexChannel::ObexChannel | ( | ObexTransportId | transport_id,
 |  | ObexProtocolId | protocol_id,
 |  | BOOLEAN | is_server,
 |  | BOOLEAN | is_unique,
 |  | UINT16 | impl_index
 | ) |

Constructor intended to by used by ObexTransport.

See also:
ObexProtocol::AcquireServerChannel()

ObexProtocol::AcquireClientChannel()

Parameters:
transport_id | Pass <your_transport>.GetObjectId()
protocol_id | Pass <your_protocol>.GetTypeId()
is_server | Pass 'TRUE' for a server channel, 'FALSE' otherwise.
impl_index | Pass an integer you would like to act as a reference to internal resources of your implementation used by this channel. For example, it can be used as an index into an internal array or vector of strcutures associated with a transport channel at stack level.

Friends And Related Function Documentation

BOOLEAN operator!= | ( | const ObexChannel & | lhs,
 |  | const ObexChannel & | rhs
 | ) | [friend]

Comparison for inequality.

BOOLEAN operator== | ( | const ObexChannel & | lhs,
 |  | const ObexChannel & | rhs
 | ) | [friend]

Comparison for equality.

The documentation for this class was generated from the following files:
  • Obex/ObexChannel.hpp
  • Obex/ObexChannel.cpp
Generated on Wed Jan 25 01:32:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexClient Class Reference
[OBEX]

Base class for OBEX clients within applications. More...

#include <Apoxi/Obex/ObexClient.hpp>

Inheritance diagram for ObexClient:

[legend]
Collaboration diagram for ObexClient:

[legend]

Public Types

typedef ObexClientDispatcher | Base

Public Member Functions

ObexResult | Abort (const ObexObject &abort_req)
Aborts an ongoing PUT or GET operation.
ObexResult | Connect (const ObexObject &conn_req)
Connects to a remote OBEX server.
ObexResult | DataProcessed (ObexBuffer &buffer)
Transfers ownership of a data buffer back to APOXI OBEX.
ObexResult | Disconnect (const ObexObject &disc_req)
Disconnects from the remote OBEX server.
ObexResult | Get (const ObexObject &get_req)
Starts or continues an OBEX GET operation.
UINT32 | GetConnectionId () const
Returns the connection id of a directed connection.
UINT32 | GetProgressInBytes () const
Returns the cumulative progress in transferring data.
ObexClient (ExecutionContext *ctx_ptr)
Constructor. Constructs a usable object instance.
ObexClient ()
Default constructor.
ObexResult | Put (const ObexObject &put_req)
Starts or continues an OBEX PUT operation.
ObexResult | SetPath (const ObexObject &setpath_req)
Starts an OBEX SETPATH operation.
virtual | ~ObexClient ()
Destructor. Destroys an ObexClient object.

Protected Member Functions

virtual void | OnAbort (const ObexObject &abort_resp, ObexResult result)
Indicates that an operation was aborted.
virtual BOOLEAN | OnChannelsMatch (const ClientPortPtr &port_ptr, const ObexMsg &msg)
virtual void | OnClose (ObexResult result)
Indicates completion of a Close() operation.
virtual void | OnConnect (const ObexObject &conn_resp, ObexResult result)
Indicates completion of a CONNECT operation.
virtual void | OnDataProcessed (ObexBuffer &buffer)
Returns ownership of a buffer back to the application.
virtual void | OnDisconnect (const ObexObject &disc_resp, ObexResult result)
Indicates completion of a DISCONNECT operation.
virtual void | OnGetComplete (ObexResult result)
Indicates completion of a GET operation.
virtual void | OnGetResponse (const ObexObject &get_resp)
Delivers a GET response returned by a remote server.
virtual void | OnOpen (ObexResult result)
Indicates completion of an Open() operation.
virtual void | OnPutComplete (ObexResult result)
Indicates completion of a PUT operation.
virtual void | OnPutResponse (const ObexObject &put_resp)
Delivers a PUT response returned by a remote server.
virtual void | OnSetPath (const ObexObject &setp_resp, ObexResult result)
Indicates completion of a SETPATH operation.

Detailed Description

Base class for OBEX clients within applications.

Member Typedef Documentation

typedef ObexClientDispatcher ObexClient::Base

Reimplemented from ObexClientDispatcher.

Constructor & Destructor Documentation

ObexClient::ObexClient ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexClient::ObexClient ( ExecutionContext * ctx_ptr )

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
ctx_ptr Execution context in which the client is to be run. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the current context must be valid at construction time.

ObexClient::~ObexClient ( ) [virtual]

Destructor. Destroys an ObexClient object.

Member Function Documentation

ObexResult ObexClient::Abort ( const ObexObject & abort_req )

Aborts an ongoing PUT or GET operation.

Parameters:
abort_req OBEX object which carries the ABORT headers.
Returns:
ObexResult which evaluates to 'TRUE' when the current operation was aborted successfully, 'FALSE' otherwise.

ObexResult ObexClient::Connect ( const ObexObject & conn_req )

Connects to a remote OBEX server.

Parameters:
conn_req OBEX object which carries the CONNECT headers.
Returns:
ObexResult which evaluates to 'TRUE' when the operation was initiated successfully, 'FALSE' otherwise.

ObexResult ObexClient::DataProcessed ( ObexBuffer & buffer )

Transfers ownership of a data buffer back to APOXI OBEX.

Must be invoked on any buffer which was delivered within a response after having processed the buffer content.

See also:
OnGetResponse

Reimplemented in ObexClientOppImpl.

ObexResult ObexClient::Disconnect ( const ObexObject & disc_req )

Disconnects from the remote OBEX server.

Parameters:
disc_req OBEX object which carries the DISCONNECT headers.
Returns:
ObexResult which evaluates to 'TRUE' when the operation was initiated successfully, 'FALSE' otherwise.

ObexResult ObexClient::Get ( const ObexObject & get_req )

Starts or continues an OBEX GET operation.

Parameters:
get_req OBEX object which carries the GET headers and optionally BODY data in an ObexBuffer.
Returns:
ObexResult which evaluates to 'TRUE' when the operation was initiated successfully, 'FALSE' otherwise.

void ObexClient::OnAbort | ( | const ObexObject & | abort_resp,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates that an operation was aborted.

Parameters:
abort_resp | ObexObject containing the (optional) response headers and the Response Code.
result | 'TRUE' if the operation was successfully aborted due to a preceeding call of Abort(), 'FALSE' otherwise.

Reimplemented in ObexClientOppImpl.

BOOLEAN ObexClient::OnChannelsMatch | ( | const ClientPortPtr & | port_ptr,
 |  | const ObexMsg & | msg
 | ) | [protected, virtual]

void ObexClient::OnClose ( ObexResult result ) [protected, virtual]

Indicates completion of a Close() operation.

Implements ObexClientDispatcher.

Reimplemented in ObexClientOppImpl.

void ObexClient::OnConnect | ( | const ObexObject & | conn_resp,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates completion of a CONNECT operation.

Parameters:
conn_resp | ObexObject containing the response headers and the Response Code.
result | Evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented in ObexClientOppImpl.

void ObexClient::OnDataProcessed ( ObexBuffer & buffer ) [protected, virtual]

Returns ownership of a buffer back to the application.

The passed data buffer had been produced by the application and may be now either recycled or disposed.

Parameters:
buffer ObexBuffer belonging to the application.

Reimplemented in ObexClientOppImpl.

void ObexClient::OnDisconnect | ( | const ObexObject & | disc_resp,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates completion of a DISCONNECT operation.

Parameters:
disc_resp | ObexObject containing the response headers and the Response Code.
result | Evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented in ObexClientOppImpl.

void ObexClient::OnGetComplete ( ObexResult result ) [protected, virtual]

Indicates completion of a GET operation.

Parameters:
result Evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented in ObexClientOppImpl.

void ObexClient::OnGetResponse ( const ObexObject & get_resp ) [protected, virtual]

Delivers a GET response returned by a remote server.

Parameters:
get_resp ObexObject containing the response headers and the Response Code, and possibly data !

Reimplemented in ObexClientOppImpl.

void ObexClient::OnOpen ( ObexResult result ) [protected, virtual]

Indicates completion of an Open() operation.

Implements ObexClientDispatcher.

Reimplemented in ObexClientOppImpl.

void ObexClient::OnPutComplete ( ObexResult result ) [protected, virtual]

Indicates completion of a PUT operation.

Parameters:
result Evaluates 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented in ObexClientOppImpl.

void ObexClient::OnPutResponse ( const ObexObject & put_resp ) [protected, virtual]

Delivers a PUT response returned by a remote server.

Parameters:
put_resp ObexObject containing the response headers and the Response Code.

Reimplemented in ObexClientOppImpl.

void ObexClient::OnSetPath | ( | const ObexObject & | setp_resp,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates completion of a SETPATH operation.

Parameters:
setp_resp | ObexObject containing the response headers and the Response Code.
result | Evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

ObexResult ObexClient::Put ( const ObexObject & put_req )

Starts or continues an OBEX PUT operation.

Parameters:
put_req OBEX object which carries the PUT headers and optionally BODY data in an ObexBuffer.
Returns:
ObexResult which evaluates to 'TRUE' when the operation was initiated successfully, 'FALSE' otherwise.

ObexResult ObexClient::SetPath ( const ObexObject & setpath_req )

Starts an OBEX SETPATH operation.

Parameters:
setpath_req OBEX object which carries the SETPATH headers.
Returns:
ObexResult which evaluates to 'TRUE' when the operation was initiated successfully, 'FALSE' otherwise.

The documentation for this class was generated from the following files:
  • Obex/ObexClient.hpp
  • Obex/ObexClient.cpp
Generated on Wed Jan 25 01:32:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexClientAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexClientAddr Class Reference
[OBEX]

Base class for client address information classes. More...

#include <Apoxi/Obex/ObexAddress.hpp>

Inheritance diagram for ObexClientAddr:

[legend]
Collaboration diagram for ObexClientAddr:

[legend]

Public Types

typedef ObexAddress | Base

Public Member Functions

virtual ObexAddrTypeId | GetTypeId () const
Returns the unique id of the ObexClientAddrInfo subclass.

Protected Member Functions

ObexClientAddr (ObexTransportId transport_id)
Constructor. Restricts construction to derived classes.

Detailed Description

Base class for client address information classes.

This class should be derived for each transport implementation and extended as necessary to contain transport-specific information relevant for a client.

Member Typedef Documentation

typedef ObexAddress ObexClientAddr::Base

Reimplemented from ObexAddress.

Reimplemented in IrdaObexClientAddr.

Constructor & Destructor Documentation

ObexClientAddr::ObexClientAddr ( ObexTransportId transport_id ) [protected]

Constructor. Restricts construction to derived classes.

Member Function Documentation

ObexAddrTypeId ObexClientAddr::GetTypeId ( ) const [virtual]

Returns the unique id of the ObexClientAddrInfo subclass.

Implements ObexAddress.

The documentation for this class was generated from the following files:
  • Obex/ObexAddress.hpp
  • Obex/ObexAddress.cpp
Generated on Wed Jan 25 01:32:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexClientDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexClientDispatcher Class Reference
[OBEX]

Internal abstraction of a client OBEX transport connection. More...

#include <Apoxi/Obex/ObexClientDispatcher.hpp>

Inheritance diagram for ObexClientDispatcher:

[legend]
Collaboration diagram for ObexClientDispatcher:

[legend]

Public Types

typedef ObexEventHandler | Base

Public Member Functions

virtual ObexResult | Close ()
Closes an open transport connection.
ObexAddrPtr | GetRemoteAddrPtr () const
Returns the address of the service the client is connected to.
virtual void | Init (ExecutionContext *ctx_ptr)
Initializes a default-constructed object.
virtual ObexResult | Open (const String &obex_addr_url)
Opens a transport connection to a remote server.
virtual | ~ObexClientDispatcher ()
Destructor. Destroys an ObexClientDispatcher object.

Protected Types

typedef NiSharedPtr< ObexClientPort > | ClientPortPtr

Protected Member Functions

void | AbortSelection ()
Abort user interaction (Transport Address Selection procedure).
virtual ObexResult | CloseAction ()
Action method initiating closing of a transport connection.
ClientPortPtr | GetActivePortPtr () const
Returns a smartpointer to the active port.
virtual BOOLEAN | IsValidContext () const
ObexClientDispatcher ()
Default constructor.
virtual BOOLEAN | OnChannelsMatch (const ClientPortPtr &port_ptr, const ObexMsg &msg)=0
Indicates reception of an OBEX event.
virtual void | OnClose (ObexResult result)=0
Indicates completion of a Close() operation.
virtual BOOLEAN | OnObexAddrMsg (const ObexAddrMsg &msg)
Invoked when an ObexAddrMsg was received.
virtual BOOLEAN | OnObexMsg (const ObexMsg &msg)
Invoked when an ObexMsg was received.
virtual BOOLEAN | OnObexTransportMsg (const ObexTransportMsg &msg)
Invoked when an ObexTransportMsg was received.
virtual void | OnOpen (ObexResult result)=0
Indicates completion of an Open() operation.
virtual ObexResult | OpenAction ()
Action method initiating opening of a transport connection.

Static Protected Member Functions

static BOOLEAN | IsValidPortPtr (const ClientPortPtr &port_ptr)

Friends

class | ObexClientPort

Detailed Description

Internal abstraction of a client OBEX transport connection.

Warning;
This is an internal interface and must not be used outside APOXI OBEX at all.

Its purpose is to provide an abstraction of the underlying transport connection and notify OBEX protocol events to the application layer without further evaluation. This activity is left to derived classes.

Member Typedef Documentation

typedef ObexEventHandler ObexClientDispatcher::Base

Reimplemented in ObexClient.

typedef NiSharedPtr<ObexClientPort> ObexClientDispatcher::ClientPortPtr [protected]

Constructor & Destructor Documentation

ObexClientDispatcher::~ObexClientDispatcher ( ) [virtual]

Destructor. Destroys an ObexClientDispatcher object.

ObexClientDispatcher::ObexClientDispatcher ( ) [protected]

Default constructor.

Default-constructed objects must be initialized using Init() before using them the first time.

Member Function Documentation

void ObexClientDispatcher::AbortSelection ( ) [protected]

Abort user interaction (Transport Address Selection procedure).

ObexResult ObexClientDispatcher::Close ( ) [virtual]

Closes an open transport connection.

When the procedure was properly initiated, the ObexResult value returned indicates success, otherwise it carries an error code. In the former case, the notification method OnClose() is called on completion of the asynchronous procedure.

Note:
When Close() is called while a call to Open() is still pending, the running open operation will be cancelled and OnOpen() be invoked with the error code ObexResult::OperationAborted. In this case, OnClose() is not invoked.

ObexResult ObexClientDispatcher::CloseAction ( ) [protected, virtual]

Action method initiating closing of a transport connection.

Derived classes may re-implement this method to perform additional tasks when a transport connection is opened.

Implementations should follow the example below:

            class MyClientImpl : public ObexClientDispatcher {
                public:
                    // ... other declarations
                protected:
                    virtual ObexResult  CloseAction();
                    // ... other declarations
            };

            ObexResult  MyClientImpl::CloseAction()
            {
                // Call inherited method first
                ObexResult  result = Base::CloseAction();

                // Don't proceed when inherited method failed !
                if ( result.IsOk() ) {
                    // Your new code goes here ...
                }
                return result;
            }

ObexClientDispatcher::ClientPortPtr ObexClientDispatcher::GetActivePortPtr ( ) const [protected]

Returns a smartpointer to the active port.

Returns:
Pointer to the active port, empty smartpointer if the server is idle.

ObexAddrPtr ObexClientDispatcher::GetRemoteAddrPtr ( ) const [inline]

Returns the address of the service the client is connected to.

Returns:
When the client is connected to a remote server, the smartpointer which is returned refers to an instance of a class was derived from ObexClientAddr. When the client is not connected, an empty smartpointer is returned.

void ObexClientDispatcher::Init ( ExecutionContext * ctx_ptr ) [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr Execution context to be used by the dispatcher. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the context must be valid when Init() is called.

BOOLEAN ObexClientDispatcher::IsValidContext ( ) const [protected, virtual]

Tells whether the current context is valid for handling notifications.

This method must be implemented by derived classes whose instances might be shared by multiple execution contexts to tell whether an event may be processed and notified in the current execution context or not. The default implementation returns 'TRUE', which is appropriate for all implementations which are run in a single execution context.

Implements ObexEventHandler.

Reimplemented in ObexClientOppImpl.

virtual BOOLEAN ObexClientDispatcher::OnChannelsMatch | ( | const ClientPortPtr & | port_ptr,
 |  | const ObexMsg & | msg
 | ) | [protected, pure virtual]

Indicates reception of an OBEX event.

This notification method is called whenever an ObexMsg is received which is related to the transport channel opened by the related ObexClientDispatcher instance. Derived classes mut implement it to dispatch the various events resulting from communication using an OBEX-based protocol.

Parameters:
port_ptr | Port from which the OBEX event was received
msg | ObexMsg containing the event type and data

virtual void ObexClientDispatcher::OnClose ( ObexResult result ) [protected, pure virtual]

Indicates completion of a Close() operation.

Implemented in ObexClient, and ObexClientOppImpl.

BOOLEAN ObexClientDispatcher::OnObexAddrMsg ( const ObexAddrMsg & msg ) [protected, virtual]

Invoked when an ObexAddrMsg was received.

Implements ObexEventHandler.

BOOLEAN ObexClientDispatcher::OnObexMsg ( const ObexMsg & msg ) [protected, virtual]

Invoked when an ObexMsg was received.

Implements ObexEventHandler.

BOOLEAN ObexClientDispatcher::OnObexTransportMsg ( const ObexTransportMsg & msg ) [protected, virtual]

Invoked when an ObexTransportMsg was received.

Implements ObexEventHandler.

virtual void ObexClientDispatcher::OnOpen ( ObexResult result ) [protected, pure virtual]

Indicates completion of an Open() operation.

Implemented in ObexClient, and ObexClientOppImpl.

ObexResult ObexClientDispatcher::Open ( const String & obex_addr_url ) [virtual]

Opens a transport connection to a remote server.

When the procedure was properly initiated, the ObexResult value returned indicates success, otherwise it carries an error code. In the former case, the notification method OnOpen() is called on completion of the asynchronous procedure.

Parameters:
obex_addr_url OBEX address in URL format. Please see OBEX URL's for further explanation.

ObexResult ObexClientDispatcher::OpenAction ( ) [protected, virtual]

Action method initiating opening of a transport connection.

Derived classes may re-implement this method to perform additional tasks when a transport connection is opened. Implementations should follow the example below:

            class MyClientImpl : public ObexClientDispatcher {
                public:
                    // ... other declarations
                protected:
                    virtual ObexResult  OpenAction();
                    // ... other declarations
            };

            ObexResult  MyClientImpl::OpenAction()
            {
                // Call inherited method first
                ObexResult  result = Base::OpenAction();

                // Don't proceed when inherited method failed !
                if ( result.IsOk() ) {
                    // Your new code goes here ...
                }
                return result;
            }

Friends And Related Function Documentation

friend class ObexClientPort [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexClientDispatcher.hpp
  • Obex/ObexClientDispatcher.cpp
Generated on Wed Jan 25 01:32:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexClientOppImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexClientOppImpl Class Reference
[OBEX]

Internal client implementation of the OPP profile. More...

#include <Apoxi/Obex/ObexClientOppImpl.hpp>

Inheritance diagram for ObexClientOppImpl:

[legend]
Collaboration diagram for ObexClientOppImpl:

[legend]

Public Member Functions

ObexResult | Abort (const WString &desc, BOOLEAN force_sync)
void | CloseConnection ()
Closes the transport connection to the remote server.
ObexResult | DataProcessed (ObexBuffer &app_data)
Returns an empty OBEX buffer in case of a PULL operation.
void | Disconnect ()
Initiates disconnection from the remote server.
BOOLEAN | IsActiveOppClient (const ObexOppClient *client_ptr) const
Tells whether an OPP client is currently served by ObexClientOppImpl.
ObexResult | ProvideData (ObexBuffer &app_data, BOOLEAN end_data)
Provides OBEX BODY data and resumes data transmission.
ObexResult | Pull (const ObexObject &push_req)
Starts an OPP PULL operation.
ObexResult | Push (const ObexObject &push_req)
Starts an OPP PUSH operation.
ObexResult | StartOperation (ObexOppClient *opp_client_ptr)
Starts executing an OPP client operation.

Static Public Member Functions

static ObexClientOppImpl & | GetInstance ()
Singleton accessor.

Protected Member Functions

virtual BOOLEAN | IsValidContext () const
virtual void | OnAbort (const ObexObject &abort_resp, ObexResult result)
Indicates that an operation was aborted.
virtual void | OnClose (ObexResult result)
Indicates completion of a Close() operation.
virtual void | OnConnect (const ObexObject &conn_resp, ObexResult result)
Indicates completion of a CONNECT operation.
virtual void | OnDataProcessed (ObexBuffer &buffer)
Returns ownership of a buffer back to the application.
virtual void | OnDisconnect (const ObexObject &disc_resp, ObexResult result)
Indicates completion of a DISCONNECT operation.
virtual void | OnGetComplete (ObexResult result)
Indicates completion of a GET operation.
virtual void | OnGetResponse (const ObexObject &get_resp)
Delivers a GET response returned by a remote server.
virtual void | OnOpen (ObexResult result)
Indicates completion of an Open() operation.
virtual void | OnPutComplete (ObexResult result)
Indicates completion of a PUT operation.
virtual void | OnPutResponse (const ObexObject &put_resp)
Delivers a PUT response returned by a remote server.

Detailed Description

Internal client implementation of the OPP profile.

Warning;
This is an internal implementation class which must not be used outside APOXI OBEX at all.

It provides an implementation of an OPP (Object Push Pull) profile client based on plain OBEX functionality, hence the OPP profile can be used with all transport implementations regardless whether they support OPP natively or not.

Limitations:

This OPP client implementation supports only one transport connection at a time. Competing requests for initiating OPP operations are therefore queued within the requesting objects which are instances of ObexOppClient and derived classes. At the end of each OPP operation an ObexTriggerMsg is sent out, which initiates a retry of the previously deferred operations.

Concept:

ObexClientOppImpl is a singleton class instantiated when at least one ObexOppClient instance is used. Message handling and notifications execute in the context of the ObexOppClient instance which initiated the respective operation. When no ObexOppClient is active, the ExecutionContext at creation time is 'abused' for message handling.

Member Function Documentation

ObexResult ObexClientOppImpl::Abort | ( | const WString & | desc,
 |  | BOOLEAN | force_sync
 | ) |

Cancels an ongoing OPP operation.

Cancelling an OPP operation is much more complex than an OBEX ABORT since it might involve cancelling service discovery, establishmend of a transport connection, disconnecting an OBEX connection or aborting an OBEX operation depending on the state of the OPP operation at the point of time when Abort() is called.

Parameters:
desc | Text to be included in the description header of an OBEX ABORT request, when possible.
force_sync | When this parameter is set to 'TRUE', any further notifications are suppressed until the current OPP operation has been completed. This is particularly useful during shutdown.

void ObexClientOppImpl::CloseConnection ( )

Closes the transport connection to the remote server.

ObexResult ObexClientOppImpl::DataProcessed ( ObexBuffer & app_data )

Returns an empty OBEX buffer in case of a PULL operation.

Reimplemented from ObexClient.

void ObexClientOppImpl::Disconnect ( )

Initiates disconnection from the remote server.

ObexClientOppImpl & ObexClientOppImpl::GetInstance ( ) [static]

Singleton accessor.

BOOLEAN ObexClientOppImpl::IsActiveOppClient ( const ObexOppClient * client_ptr ) const [inline]

Tells whether an OPP client is currently served by ObexClientOppImpl.

BOOLEAN ObexClientOppImpl::IsValidContext ( ) const [protected, virtual]

Tells whether the current context is valid for handling notifications.

This method must be implemented by derived classes whose instances might be shared by multiple execution contexts to tell whether an event may be processed and notified in the current execution context or not. The default implementation returns 'TRUE', which is appropriate for all implementations which are run in a single execution context.

Reimplemented from ObexClientDispatcher.

void ObexClientOppImpl::OnAbort | ( | const ObexObject & | abort_resp,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates that an operation was aborted.

Parameters:
abort_resp | ObexObject containing the (optional) response headers and the Response Code.
result | 'TRUE' if the operation was successfully aborted due to a preceeding call of Abort(), 'FALSE' otherwise.

Reimplemented from ObexClient.

void ObexClientOppImpl::OnClose ( ObexResult result ) [protected, virtual]

Indicates completion of a Close() operation.

Reimplemented from ObexClient.

void ObexClientOppImpl::OnConnect | ( | const ObexObject & | conn_resp,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates completion of a CONNECT operation.

Parameters:
conn_resp | ObexObject containing the response headers and the Response Code.
result | Evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented from ObexClient.

void ObexClientOppImpl::OnDataProcessed ( ObexBuffer & buffer ) [protected, virtual]

Returns ownership of a buffer back to the application.

The passed data buffer had been produced by the application and may be now either recycled or disposed.

Parameters:
buffer ObexBuffer belonging to the application.

Reimplemented from ObexClient.

void ObexClientOppImpl::OnDisconnect | ( | const ObexObject & | disc_resp,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates completion of a DISCONNECT operation.

Parameters:
disc_resp | ObexObject containing the response headers and the Response Code.
result | Evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented from ObexClient.

void ObexClientOppImpl::OnGetComplete ( ObexResult result ) [protected, virtual]

Indicates completion of a GET operation.

Parameters:
result Evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented from ObexClient.

void ObexClientOppImpl::OnGetResponse ( const ObexObject & get_resp ) [protected, virtual]

Delivers a GET response returned by a remote server.

Parameters:
get_resp ObexObject containing the response headers and the Response Code, and possibly data !

Reimplemented from ObexClient.

void ObexClientOppImpl::OnOpen ( ObexResult result ) [protected, virtual]

Indicates completion of an Open() operation.

Reimplemented from ObexClient.

void ObexClientOppImpl::OnPutComplete ( ObexResult result ) [protected, virtual]

Indicates completion of a PUT operation.

Parameters:
result Evaluates 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented from ObexClient.

void ObexClientOppImpl::OnPutResponse ( const ObexObject & put_resp ) [protected, virtual]

Delivers a PUT response returned by a remote server.

Parameters:
put_resp ObexObject containing the response headers and the Response Code.

Reimplemented from ObexClient.

ObexResult ObexClientOppImpl::ProvideData | ( | ObexBuffer & | app_data,
 |  | BOOLEAN | end_data
 | ) |

Provides OBEX BODY data and resumes data transmission.

Parameters:
app_data | OBEX BODY date to be transmitted.
end_data | When set to 'TRUE', indicates end of data for the current operation.

ObexResult ObexClientOppImpl::Pull ( const ObexObject & push_req )

Starts an OPP PULL operation.

ObexResult ObexClientOppImpl::Push ( const ObexObject & push_req )

Starts an OPP PUSH operation.

ObexResult ObexClientOppImpl::StartOperation ( ObexOppClient * opp_client_ptr )

Starts executing an OPP client operation.

When ObexClientOppImpl is idle, the operation is initiated immediately, otherwise just nothing happens but the method indicates success. In this case, the operation will be restarted later by means of an ObexTriggerMsg which is received by ObexOppClient instances and tells them to call StartOperation() again.

When an operation was successfully initiated, the OnOppInitiated() method of the corresponding ObexOppClient instance is called.

Parameters:
opp_client_ptr Pointer to the OPP client which wants to start the operation.

The documentation for this class was generated from the following files:
  • Obex/ObexClientOppImpl.hpp
  • Obex/ObexClientOppImpl.cpp
Generated on Wed Jan 25 01:32:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexClientPort Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexClientPort Class Reference
[OBEX]

Internal implementation class for OBEX transport interfaces. More...

#include <Apoxi/Obex/ObexClientPort.hpp>

Inheritance diagram for ObexClientPort:

[legend]
Collaboration diagram for ObexClientPort:

[legend]

Public Types

typedef ObexAbstractPort | Base

Public Member Functions

BOOLEAN | IsConnected () const
Tells whether the port is connected.
ObexClientPort (ObexAbstractTransport &transport, ObexProtocol &protocol, ObexClientDispatcher &client)
Constructor.

Protected Member Functions

virtual void | AbortAddrResolution ()
Abort running address resolution procedure.
virtual BOOLEAN | AcquireChannel (ObexChannel &channel, const ObexAddrPtr &addr_ptr, ObexResult result)
Check address and obtain channel.
virtual void | CloseChannel (ObexResult cause)
Close the channel associated with the port.
virtual void | OnChannelClosed ()
Indicates completion of a Close() operation.
virtual void | OnChannelOpened (ObexResult result)
Indicates completion of an Open() operation.
virtual void | OpenChannel (const ObexAddrPtr &addr_ptr)
Open the channel associated with the port.
virtual void | StartAddrResolution ()
Resolve an OBEX URL string using the transport's interface.

Detailed Description

Internal implementation class for OBEX transport interfaces.

Warning;
This is an internal implementation class which must not be used outside APOXI OBEX at all.

It provides an implementation of the ObexAbstractPort interface suitable for client connections which is mainly a two-level nested state machine. The first level is implemented by ObexClientPort itself and represents the port state. The second level is used only temporarily to track the asynchronous execution of the following procedures:

  • Address resolution (device search and service discovery).

  • Establishing a transport connection.

  • Disconnecting a transport connection.

The 2nd level state descriptions and there actions are inherited from the base class.

Member Typedef Documentation

typedef ObexAbstractPort ObexClientPort::Base

Constructor & Destructor Documentation

ObexClientPort::ObexClientPort | ( | ObexAbstractTransport & | transport,
 |  | ObexProtocol & | protocol,
 |  | ObexClientDispatcher & | client
 | ) |

Constructor.

Parameters:
transport | Instance of the transport implementation (HW abstraction) related to the transport.
protocol | Instance of the transport adapter related to the transport and the OBEX-based protocol to be used with the port.
client | Instance of an ObexClientDispatcher to handle the protocol events received by the port.

Member Function Documentation

void ObexClientPort::AbortAddrResolution ( ) [protected, virtual]

Abort running address resolution procedure.

Implements ObexAbstractPort.

BOOLEAN ObexClientPort::AcquireChannel | ( | ObexChannel & | channel,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | ObexResult | result
 | ) | [protected, virtual]

Check address and obtain channel.

Returns:
'TRUE' on success, 'FALSE' on failure.

Implements ObexAbstractPort.

void ObexClientPort::CloseChannel ( ObexResult cause ) [protected, virtual]

Close the channel associated with the port.

Implements ObexAbstractPort.

void ObexClientPort::OnChannelClosed ( ) [protected, virtual]

Indicates completion of a Close() operation.

Implements ObexAbstractPort.

void ObexClientPort::OnChannelOpened ( ObexResult result ) [protected, virtual]

Indicates completion of an Open() operation.

Implements ObexAbstractPort.

void ObexClientPort::OpenChannel ( const ObexAddrPtr & addr_ptr ) [protected, virtual]

Open the channel associated with the port.

Implements ObexAbstractPort.

void ObexClientPort::StartAddrResolution ( ) [protected, virtual]

Resolve an OBEX URL string using the transport's interface.

Implements ObexAbstractPort.

The documentation for this class was generated from the following files:
  • Obex/ObexClientPort.hpp
  • Obex/ObexClientPort.cpp
Generated on Wed Jan 25 01:32:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexDataServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexDataServer Class Reference
[OBEX]

OBEX server which uses the BinData and DataSink interfaces for transferring data. More...

#include <Apoxi/Obex/ObexDataServer.hpp>

Inheritance diagram for ObexDataServer:

[legend]
Collaboration diagram for ObexDataServer:

[legend]

Public Types

enum | { MinGetFragSize = 256, DefGetFragSize = 4096 }
Buffer sizes used by the server during GET operations. More...

Public Member Functions

ObexResult | AcceptData (DataSink *data_sink_ptr, UINT32 max_data_size)
Accepts incoming BODY data within a PUT or GET operation.
UINT32 | GetProgressInBytes () const
Returns the cumulative progress in transferring data.
ObexHeaderList & GetResponseHeaderList ()
Provides access to the header list of the next response to be sent.
virtual void | Init (ExecutionContext *ctx_ptr)
Initializes a default-constructed object.
ObexResult | InitResponse (ObexObject::ResponseCode resp_code)
Manually sets up the next response to be sent.
ObexDataServer (ExecutionContext *ctx_ptr)
Constructor. Constructs a usable object instance.
ObexDataServer ()
Default constructor.
ObexResult PostResponse ()
Schedules response for transmission.
ObexResult | ProvideData (BinData *data_src_ptr)
Provides outbound BODY data within a GET operation.
void | SetGetFragSize (UINT frag_size)
Sets the fragment or 'chunk' size for GET operations.
virtual | ~ObexDataServer ()
Destructor. Destroys an ObexDataServer object.

Protected Member Functions

virtual void | OnAbort (const ObexHeaderList &headers)
Indicates the current PUT or GET operation is being aborted by the remote client.
virtual void | OnConnect (const ObexHeaderList &headers, UINT8 flags)
Indicates an incoming CONNECT request.
virtual void | OnDataAvailable ()
Indicates OBEX BODY data is available.
virtual void | OnDataComplete ()
Indicates that a complete OBEX object BODY has been received.
virtual void | OnDataRequested ()
Indicates OBEX BODY data can be sent now.
virtual void | OnDelete ()
Indicates the current PUT operation is a PUT DELETE.
virtual void | OnDisconnect (const ObexHeaderList &headers)
Indicates an incoming DISCONNECT request.
virtual void | OnGetComplete (ObexResult result)
Indicates completion of a GET operation.
virtual void | OnGetHeaders (const ObexHeaderList &headers)
Indicates reception of OBEX headers within a GET operation.
virtual void | OnGetIncoming ()
Indicates the beginning of an incoming GET operation.
virtual void | OnPutComplete (ObexResult result)
Indicates completion of a PUT operation.
virtual void | OnPutHeaders (const ObexHeaderList &headers)
Indicates reception of OBEX headers within a PUT operation.
virtual void | OnPutIncoming ()
Indicates the beginning of an incoming PUT operation.
virtual void | OnSetPath (const ObexHeaderList &headers, UINT8 flags)
Indicates an incoming SETPATH operation.

Friends

class | OperConfirm
class | OperGetData
class | OperGetRequest
class | OperPutData
class | OperPutRequest

Detailed Description

OBEX server which uses the BinData and DataSink interfaces for transferring data.

This class offers a more convenient interface than the ObexServer by relieving the application programmer from the tedious job of assembling and segmenting application data. It is therefore the recommended base class for both MMI applications and APOXI extensions wishing to provide server services based on OBEX.

Member Enumeration Documentation

anonymous enum

Buffer sizes used by the server during GET operations.

Enumerator:
MinGetFragSize | Minimum buffer size supported.
DefGetFragSize | Default buffer size.

Constructor & Destructor Documentation

ObexDataServer::ObexDataServer ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexDataServer::ObexDataServer ( ExecutionContext * ctx_ptr )

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
ctx_ptr Execution context to be used by the server. All notification methods (protected: On.....()) will be called from this context. You may pass '0' as actual parameter to specify the currently active context, which must be valid at construction the time.

ObexDataServer::~ObexDataServer ( ) [virtual]

Destructor. Destroys an ObexDataServer object.

Member Function Documentation

ObexResult ObexDataServer::AcceptData | ( | DataSink * | data_sink_ptr,
 |  | UINT32 | max_data_size
 | ) |

Accepts incoming BODY data within a PUT or GET operation.

May be called only after OnDataAvailable() was signalled to the server. Calling AcceptData() implies posting a SUCCESS response which means it does not make sense to call PostResponse() synchronously before or after AcceptData().

Parameters:
data_sink_ptr | Pointer to a DataSink instance to hold the data sent by the remote client.
max_data_size | Maximum amount of data (in octets) which can be written to the DataSink instance. When this limit is exceeded, data transfer is automatically cancelled by the server.
Returns:
ObexResult which evaluates to 'TRUE' when the data transfer procedure was successfully initiated, 'FALSE' otherwise.

UINT32 ObexDataServer::GetProgressInBytes ( ) const

Returns the cumulative progress in transferring data.

This method returns the amount of data already transferred for a pending PUT (inbound data) or GET (outbound data) operation. The final value is preserved even beyond completion of that operation, hence it is reset to '0' when a new operation is accepted.

Reimplemented from ObexServer.

ObexHeaderList & ObexDataServer::GetResponseHeaderList ( )

Provides access to the header list of the next response to be sent.

A new response header (SUCCESS response) is automatically set up when a request is accepted by the server. If an error response is needed, it can be set up by calling InitResponse(). This method can then be used to gain access to the header list of the response, which permits adding headers by calling the various AddHeader() methods provided by ObexHeaderList.

See also:
ObexHeaderList.

void ObexDataServer::Init ( ExecutionContext * ctx_ptr ) [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr Execution context in which the server is to be run. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the current context must be valid when Init() is called.

Reimplemented from ObexServer.

ObexResult ObexDataServer::InitResponse ( ObexObject::ResponseCode resp_code )

Manually sets up the next response to be sent.

Parameters:
resp_code OBEX response code to be used.
A new response header (SUCCESS response) is automatically set up when a request is accepted by the server. It can be overwritten by calling this method.

virtual void ObexDataServer::OnAbort ( const ObexHeaderList & headers ) [inline, protected, virtual]

Indicates the current PUT or GET operation is being aborted by the remote client.

On return from this method, an ABORT response is automatically transmitted.

Parameters:
headers Header list which may or may not contain optional ABORT headers sent by the remote client.

void ObexDataServer::OnConnect | ( | const ObexHeaderList & | headers,
 |  | UINT8 | flags
 | ) | [protected, virtual]

Indicates an incoming CONNECT request.

When a TARGET was specified as part of the server's OBEX URL it will accept only CONNECT requests with a matching TARGET header. Therefore this does not need to be checked by application SW. On entry to OnConnect, the server will build a SUCCESS response. When the server was opened specifying a TARGET, a CONNECTION ID is assigned and the pre-build response will contain the following headers: CONNECTION_ID=<set_by_server>}, TARGET=<client's WHO>, WHO=<server's TARGET>.

Please note that PostResponse() must be called in order to continue the ongoing operation.

Parameters:
headers Header list which contains the headers of the CONNECT request sent by the remote client, for example TARGET and WHO.

Reimplemented in ObexFtpDataServer.

void ObexDataServer::OnDataAvailable ( ) [protected, virtual]

Indicates OBEX BODY data is available.

This notification method is normally called within a PUT operation to indicate the availability of OBEX BODY data. To initiate data transfer, call AcceptData() and pass it a DataSink instance responsible for storing received data and the maximum data size to be received. When the size limit is exceeded, data transmission is automatically cancelled and an Internal Server Error is signalled to the remote client.

Reimplemented in ObexFtpDataServer.

void ObexDataServer::OnDataComplete ( ) [protected, virtual]

Indicates that a complete OBEX object BODY has been received.

When this method is called all incoming OBEX BODY data of the current operation has been received and written to the DataSink instance which was passed to Accept(). Now that the whole object is available to the server, it can be parsed to prepare for the decision whether it should be considered valid or not. Under normal circumstances (valid data was received) PostResponse() can be called to acknowledge data reception. In case of error, first call InitResponse() to set the error cause and optionally add response headers, then invoke PostResponse().

Calling PostResponse() will cause the final response to be sent to the remote client, informing it on the server's decision and finish the operation.

The default implementation of this method just calls PostResponse(), so if you override the method please don't call the inherited method from your own implementation !

void ObexDataServer::OnDataRequested ( ) [protected, virtual]

Indicates OBEX BODY data can be sent now.

This notification method is called within a GET operation to indicate the end of the request phase. In other words, all headers specifying the object to be retrieved have been sent and the server is now waiting for response headers and data. OBEX Headers required to describe the properties of the returned object should be added now. These could include for example TYPE, NAME and LENGTH headers. Then automatic data transmission can be launched by calling ProvideData() and passing it an instance of BinData responsible for providing the object content.

Reimplemented in ObexFtpDataServer.

void ObexDataServer::OnDelete ( ) [protected, virtual]

Indicates the current PUT operation is a PUT DELETE.

This notificatiom method indicates that the current PUT operation does not contain any BODY headers and therefore represents a PUT DELETE.

Reimplemented in ObexFtpDataServer.

virtual void ObexDataServer::OnDisconnect ( const ObexHeaderList & headers ) [inline, protected, virtual]

Indicates an incoming DISCONNECT request.

This method is invoked when an OBEX DISCONNECT request was received. On entry to OnDisconnect, the server will build a SUCCESS response. Since the OBEX specification forbids rejecting a DISCONNECT request for other reasons than a non-existing service, the implementation should not use InitResponse() to set a response code. However, it is possible to add headers, for example a DESCRIPTION header before the response is sent by invoking PostResponse().

Therefore the minimal implementation of the method only contains a call to PostResponse(). On completion of the DISCONNECT operation, OnDisconnected() is called with an ObexResult parameter indicating success.

Parameters:
headers Header list which optionally contains the headers of the DISCONNECT request sent by the remote client.

Reimplemented in ObexFtpDataServer.

virtual void ObexDataServer::OnGetComplete ( ObexResult result ) [inline, protected, virtual]

Indicates completion of a GET operation.

Parameters:
result ObexResult which evaluates to 'TRUE' when the operation was completed successfully, 'FALSE' when the operation terminated abnormally. Check the error code then to obtain more detailed information.

Reimplemented in ObexFtpDataServer.

virtual void ObexDataServer::OnGetHeaders ( const ObexHeaderList & headers ) [inline, protected, virtual]

Indicates reception of OBEX headers within a GET operation.

This method delivers headers received within an ongoing GET operation. Please note that PostResponse() must be called in order to continue the ongoing operation.

Reimplemented in ObexFtpDataServer.

virtual void ObexDataServer::OnGetIncoming ( ) [inline, protected, virtual]

Indicates the beginning of an incoming GET operation.

Reimplemented in ObexFtpDataServer.

virtual void ObexDataServer::OnPutComplete ( ObexResult result ) [inline, protected, virtual]

Indicates completion of a PUT operation.

Parameters:
result ObexResult which evaluates to 'TRUE' when the operation was completed successfully, 'FALSE' when the operation terminated abnormally. Check the error code then to obtain more detailed information.

Reimplemented in ObexFtpDataServer.

virtual void ObexDataServer::OnPutHeaders ( const ObexHeaderList & headers ) [inline, protected, virtual]

Indicates reception of OBEX headers within a PUT operation.

This method delivers headers received within an ongoing PUT operation. Please note that PostResponse() must be called in order to continue the ongoing operation.

Reimplemented in ObexFtpDataServer.

virtual void ObexDataServer::OnPutIncoming ( ) [inline, protected, virtual]

Indicates the beginning of an incoming PUT operation.

Reimplemented in ObexFtpDataServer.

void ObexDataServer::OnSetPath | ( | const ObexHeaderList & | headers,
 |  | UINT8 | flags
 | ) | [protected, virtual]

Indicates an incoming SETPATH operation.

Parameters:
headers | Header list which normally contains a NAME header which specifies the directory to change into.
flags | SETPATH flags which specify the intended behaviour of the SETPATH operation.
If ObexObject::SetpBackup is set, the current directory should be changed to the parent directory, like "cd .." would do under UNIX.

If ObexObject::SetpDontCreate is set and the directory specified by the NAME header does not exist, it must not be created.

See also:
ObexObject::SetPathFlags

Reimplemented in ObexFtpDataServer.

ObexResult ObexDataServer::PostResponse ( )

Schedules response for transmission.

When a request is currently being handled, the response is send out immediately. Otherwise, especially while data is being transferred after AcceptData() or ProvideData() have been called, the response is queued and sent out at the next opportunity to do so.

Returns:
ObexResult which evaluates to 'TRUE' when the current response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexDataServer::ProvideData ( BinData * data_src_ptr )

Provides outbound BODY data within a GET operation.

May be called only after OnDataRequested() was signalled to the server. Calling ProvideData() implies posting a SUCCESS response which means that headers describing the object to be sent should be added before AcceptData() is called. Therefore it also does not make sense to call PostResponse() synchronously before or after AcceptData().

Returns:
ObexResult which evaluates to 'TRUE' when the data transfer procedure was successfully initiated, 'FALSE' otherwise.

void ObexDataServer::SetGetFragSize ( UINT frag_size )

Sets the fragment or 'chunk' size for GET operations.

This method specifies the size of the buffer used transfer data within a GET operation. Very small sizes may affect performance due to an unnecessary high number of APOXI messages being used while very large sizes may affect system responsiveness.

The buffer size for PUT operations is determined by the transport implementation and therefore can't be changed by this API.

Parameters:
frag_size Buffer size in octets, must be at least MinGetFragSize.

Friends And Related Function Documentation

friend class OperConfirm [friend]

friend class OperGetData [friend]

friend class OperGetRequest [friend]

friend class OperPutData [friend]

friend class OperPutRequest [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexDataServer.hpp
  • Obex/ObexDataServer.cpp
Generated on Wed Jan 25 01:32:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexDispatcher Class Reference
[OBEX]

Internal OBEX message dispatcher. More...

#include <Apoxi/Obex/ObexDispatcher.hpp>

Inheritance diagram for ObexDispatcher:

[legend]
Collaboration diagram for ObexDispatcher:

[legend]

Public Member Functions

void | Attach ()
Attach to application.
void | Detach ()
Detach from application.
Application * | GetAppPtr () const
Return the application associated with the dispatcher. Deprecated - use GetContext().
ExecutionContext & | GetContext () const
Returns the execution context of the dispatcher.
ObexProtocolId | GetTypeId () const
virtual void | Init (ExecutionContext *ctx_ptr, ObexEventHandler *handler_ptr)
Initializes a default-constructed object.
BOOLEAN | IsInValidContext () const
Tells whether the dispatcher context is the current context or not.
ObexDispatcher (ObexProtocolId type_id)
Default constructor.
virtual | ~ObexDispatcher ()
Destroys an ObexDispatcher instance.

Detailed Description

Internal OBEX message dispatcher.

This is an internal implementation class which must not be used outside APOXI OBEX at all.

Its purpose is to pick OBEX-related messages from an execution context and forward them to an ObexEventHandler instance.

Constructor & Destructor Documentation

ObexDispatcher::ObexDispatcher ( ObexProtocolId type_id )

Default constructor.

Init() must be called on the resulting object before using it.

ObexDispatcher::~ObexDispatcher ( ) [virtual]

Destroys an ObexDispatcher instance.

Member Function Documentation

void ObexDispatcher::Attach ( )

Attach to application.

Adds the ObexDispatcher to the associated execution context and registers all messages handled by the dispatcher .

void ObexDispatcher::Detach ( )

Detach from application.

Unregisters the messages handled by the ObexDispatcher and removes itself from the associated execution context.

void ObexDispatcher::Init | ( | ExecutionContext * | ctx_ptr,
 |  | ObexEventHandler * | handler_ptr
 | ) | [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr Execution context in which the dispatcher receives and dispatches messages. You may pass '0' as actual parameter to specify the current execution context, which must be valid when Init() is called.

BOOLEAN ObexDispatcher::IsInValidContext ( ) const

Tells whether the dispatcher context is the current context or not.

The documentation for this class was generated from the following files:
  • Obex/ObexDispatcher.hpp
  • Obex/ObexDispatcher.cpp
Generated on Wed Jan 25 01:32:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexEventHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexEventHandler Class Reference
[OBEX]

Internal interface for handling OBEX protocol events. More...

#include <Apoxi/Obex/ObexDispatcher.hpp>

Inheritance diagram for ObexEventHandler:

[legend]

Public Member Functions

virtual | ~ObexEventHandler ()
Destructor.

Protected Member Functions

virtual BOOLEAN | IsValidContext () const =0
ObexEventHandler ()
Constructor.
virtual BOOLEAN | OnObexAddrMsg (const ObexAddrMsg &msg)=0
Invoked when an ObexAddrMsg was received.
virtual BOOLEAN | OnObexMsg (const ObexMsg &msg)=0
Invoked when an ObexMsg was received.
virtual BOOLEAN | OnObexTransportMsg (const ObexTransportMsg &msg)=0
Invoked when an ObexTransportMsg was received.

Friends

class | ObexDispatcher

Detailed Description

Internal interface for handling OBEX protocol events.

Warning;
This is an internal interface which must not be used outside APOXI OBEX at all.

ObexEventHandler is an interface which notifies events which are received by one or more instances of an ObexDispatcher. Each event is notified by invoking an abstract method when an associated ObexDispatcher has received the corresponding message.

This concept avoids message switches and ugly type casts in classes which need to handle OBEX events - they just have to implement this interface by deriving from the abstract class ObexEventHandler.

Additionally, it allows for associating multiple ObexDispatcher instances with one ObexEventHandler instance, sharing an event handler (for example an OBEX server) among multiple execution contexts.

Constructor & Destructor Documentation

virtual ObexEventHandler::~ObexEventHandler ( ) [inline, virtual]

Destructor.

ObexEventHandler::ObexEventHandler ( ) [inline, protected]

Constructor.

Member Function Documentation

virtual BOOLEAN ObexEventHandler::IsValidContext ( ) const [protected, pure virtual]

Tells whether the current context is valid for message processing.

When an OBEX event handler is shared among multiple execution contexts (this means multiple ObexDispatcher instances are associated with one ObexEventHandler instance), this method should be implemented to return 'TRUE' in the context where processing and notification of OBEX events is appropriate, 'FALSE' otherwise.

In the simple case where the event handler is receiving messages from only one execution context, the method may be implemented to always return 'TRUE'.

Implemented in ObexClientDispatcher, ObexClientOppImpl, ObexServerDispatcher, and ObexServerOppImpl.

virtual BOOLEAN ObexEventHandler::OnObexAddrMsg ( const ObexAddrMsg & msg ) [protected, pure virtual]

Invoked when an ObexAddrMsg was received.

Implemented in ObexClientDispatcher, and ObexServerDispatcher.

virtual BOOLEAN ObexEventHandler::OnObexMsg ( const ObexMsg & msg ) [protected, pure virtual]

Invoked when an ObexMsg was received.

Implemented in ObexClientDispatcher, and ObexServerDispatcher.

virtual BOOLEAN ObexEventHandler::OnObexTransportMsg ( const ObexTransportMsg & msg ) [protected, pure virtual]

Invoked when an ObexTransportMsg was received.

Implemented in ObexClientDispatcher, and ObexServerDispatcher.

Friends And Related Function Documentation

friend class ObexDispatcher [friend]

The documentation for this class was generated from the following file:
  • Obex/ObexDispatcher.hpp
Generated on Wed Jan 25 01:32:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexFtpDataServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexFtpDataServer Class Reference
[OBEX]

Internal implementation class which handles the OBEX FTP logic used by the class ObexFtpServer. More...

#include <Apoxi/Obex/ObexFtpDataServer.hpp>

Inheritance diagram for ObexFtpDataServer:

[legend]
Collaboration diagram for ObexFtpDataServer:

[legend]

Public Types

typedef SimpleMap< String,
String > 		FolderListingEntryProps

Public Member Functions

const WString & | GetCurrentFolder () const
ObexResult | HandleConnectionRequest (ObexObject::ResponseCode resp_code)
ObexResult | HandleDeleteObjectRequest (ObexObject::ResponseCode resp_code)
ObexResult | HandleFilePullRequest (ObexObject::ResponseCode resp_code, DataSourcePtr data_src_ptr)
ObexResult | HandleFilePushRequest (ObexObject::ResponseCode resp_code, DataSinkPtr data_sink_ptr, UINT32 max_size=0)
ObexResult | HandleFolderListingRequest (ObexObject::ResponseCode resp_code)
ObexResult HandleProvideFolderListingEntriesFinished ()
ObexResult | HandleProvideFolderListingEntry (BOOLEAN isFolder, const String &name, const FolderListingEntryProps &props)
ObexResult | HandleSetCurrentFolderRequest (ObexObject::ResponseCode resp_code)
virtual void | Init (ObexFtpServer *frontend, ExecutionContext *ctx_ptr)
Initializes a default-constructed object.
ObexFtpDataServer (ObexFtpServer *frontend, ExecutionContext *ctx_ptr)
Constructor. Constructs a usable object instance.
ObexFtpDataServer ()
Default constructor.
virtual | ~ObexFtpDataServer ()
Destructor. Destroys an ObexFtpDataServer object.

Protected Member Functions

void | ClearHeaderFields ()
void | ExtractHeaderFields (const ObexHeaderList &headers)
virtual void | OnBind (const ObexAddrPtr &addr_ptr, ObexResult result)
Indicates binding of a transport channel to the server.
virtual void | OnConnect (const ObexHeaderList &headers, UINT8 flags)
Indicates an incoming CONNECT request.
virtual void | OnDataAvailable ()
Indicates OBEX BODY data is available.
virtual void | OnDataRequested ()
Indicates OBEX BODY data can be sent now.
virtual void | OnDelete ()
Indicates the current PUT operation is a PUT DELETE.
virtual void | OnDisconnect (const ObexHeaderList &headers)
Indicates an incoming DISCONNECT request.
virtual void | OnDisconnected (ObexResult result)
Indicates that the current client has disconnected.
virtual void | OnGetComplete (ObexResult result)
Indicates completion of a GET operation.
virtual void | OnGetHeaders (const ObexHeaderList &headers)
Indicates reception of OBEX headers within a GET operation.
virtual void | OnGetIncoming ()
Indicates the beginning of an incoming GET operation.
virtual void | OnPutComplete (ObexResult result)
Indicates completion of a PUT operation.
virtual void | OnPutHeaders (const ObexHeaderList &headers)
Indicates reception of OBEX headers within a PUT operation.
virtual void | OnPutIncoming ()
Indicates the beginning of an incoming PUT operation.
virtual void | OnSetPath (const ObexHeaderList &headers, UINT8 flags)
Indicates an incoming SETPATH operation.
ObexResult | SubmitResponse (ObexObject::ResponseCode resp_code)

Detailed Description

Internal implementation class which handles the OBEX FTP logic used by the class ObexFtpServer.

Warning;
The class may not be used outside APOXI OBEX in a direct manner and its interface may be subject to change in future releases!

Member Typedef Documentation

typedef SimpleMap<String, String> ObexFtpDataServer::FolderListingEntryProps

The FolderListingEntryProps type is a key-value map based on strings. This is the most flexible and generic solution for generating XML folder listings containing different attributes and values.

Constructor & Destructor Documentation

ObexFtpDataServer::ObexFtpDataServer ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexFtpDataServer::ObexFtpDataServer | ( | ObexFtpServer * | frontend,
 |  | ExecutionContext * | ctx_ptr
 | ) |

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
frontend | Pointer to a frontend instance of the OBEX FTP server.
ctx_ptr | Execution context to be used by the server. All notification methods (On.....()) will be called from this context. You may pass '0' as actual parameter to specify the currently active context, which must be valid at construction the time.

ObexFtpDataServer::~ObexFtpDataServer ( ) [virtual]

Destructor. Destroys an ObexFtpDataServer object.

Member Function Documentation

void ObexFtpDataServer::ClearHeaderFields ( ) [protected]

void ObexFtpDataServer::ExtractHeaderFields ( const ObexHeaderList & headers ) [protected]

const WString & ObexFtpDataServer::GetCurrentFolder ( ) const

Returns the current folder of the server.

ObexResult ObexFtpDataServer::HandleConnectionRequest ( ObexObject::ResponseCode resp_code )

ObexResult ObexFtpDataServer::HandleDeleteObjectRequest ( ObexObject::ResponseCode resp_code )

ObexResult ObexFtpDataServer::HandleFilePullRequest | ( | ObexObject::ResponseCode | resp_code,
 |  | DataSourcePtr | data_src_ptr
 | ) |

ObexResult ObexFtpDataServer::HandleFilePushRequest | ( | ObexObject::ResponseCode | resp_code,
 |  | DataSinkPtr | data_sink_ptr,
 |  | UINT32 | max_size = 0
 | ) |

ObexResult ObexFtpDataServer::HandleFolderListingRequest ( ObexObject::ResponseCode resp_code )

ObexResult ObexFtpDataServer::HandleProvideFolderListingEntriesFinished ( )

ObexResult ObexFtpDataServer::HandleProvideFolderListingEntry | ( | BOOLEAN | isFolder,
 |  | const String & | name,
 |  | const FolderListingEntryProps & | props
 | ) |

ObexResult ObexFtpDataServer::HandleSetCurrentFolderRequest ( ObexObject::ResponseCode resp_code )

void ObexFtpDataServer::Init | ( | ObexFtpServer * | frontend,
 |  | ExecutionContext * | ctx_ptr
 | ) | [virtual]

Initializes a default-constructed object.

Parameters:
frontend | Pointer to a frontend instance of the OBEX FTP server.
ctx_ptr | Execution context in which the server is to be run. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the current context must be valid when Init() is called.

void ObexFtpDataServer::OnBind | ( | const ObexAddrPtr & | addr_ptr,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates binding of a transport channel to the server.

Parameters:
addr_ptr | Smartpointer to OBEX address that was attempted to bind.
result | Either tells that the bind operation was successful or provides error information.

Reimplemented from ObexServerDispatcher.

void ObexFtpDataServer::OnConnect | ( | const ObexHeaderList & | headers,
 |  | UINT8 | flags
 | ) | [protected, virtual]

Indicates an incoming CONNECT request.

When a TARGET was specified as part of the server's OBEX URL it will accept only CONNECT requests with a matching TARGET header. Therefore this does not need to be checked by application SW. On entry to OnConnect, the server will build a SUCCESS response. When the server was opened specifying a TARGET, a CONNECTION ID is assigned and the pre-build response will contain the following headers: CONNECTION_ID=<set_by_server>}, TARGET=<client's WHO>, WHO=<server's TARGET>.

Please note that PostResponse() must be called in order to continue the ongoing operation.

Parameters:
headers Header list which contains the headers of the CONNECT request sent by the remote client, for example TARGET and WHO.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnDataAvailable ( ) [protected, virtual]

Indicates OBEX BODY data is available.

This notification method is normally called within a PUT operation to indicate the availability of OBEX BODY data. To initiate data transfer, call AcceptData() and pass it a DataSink instance responsible for storing received data and the maximum data size to be received. When the size limit is exceeded, data transmission is automatically cancelled and an Internal Server Error is signalled to the remote client.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnDataRequested ( ) [protected, virtual]

Indicates OBEX BODY data can be sent now.

This notification method is called within a GET operation to indicate the end of the request phase. In other words, all headers specifying the object to be retrieved have been sent and the server is now waiting for response headers and data. OBEX Headers required to describe the properties of the returned object should be added now. These could include for example TYPE, NAME and LENGTH headers. Then automatic data transmission can be launched by calling ProvideData() and passing it an instance of BinData responsible for providing the object content.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnDelete ( ) [protected, virtual]

Indicates the current PUT operation is a PUT DELETE.

This notificatiom method indicates that the current PUT operation does not contain any BODY headers and therefore represents a PUT DELETE.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnDisconnect ( const ObexHeaderList & headers ) [protected, virtual]

Indicates an incoming DISCONNECT request.

This method is invoked when an OBEX DISCONNECT request was received. On entry to OnDisconnect, the server will build a SUCCESS response. Since the OBEX specification forbids rejecting a DISCONNECT request for other reasons than a non-existing service, the implementation should not use InitResponse() to set a response code. However, it is possible to add headers, for example a DESCRIPTION header before the response is sent by invoking PostResponse().

Therefore the minimal implementation of the method only contains a call to PostResponse(). On completion of the DISCONNECT operation, OnDisconnected() is called with an ObexResult parameter indicating success.

Parameters:
headers Header list which optionally contains the headers of the DISCONNECT request sent by the remote client.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnDisconnected ( ObexResult result ) [protected, virtual]

Indicates that the current client has disconnected.

When the method is called, the client has (or has been) disconnected and the server should release any temporary resources and reset itself to a virgin state suitable for accepting a new client connection.

Parameters:
result ObexResult which evaluates to 'TRUE' when the connection was disconnected using a proper OBEX DISCONNECT request, 'FALSE' when a spontaneous disconnection occured. Check the error code then to obtain more detailed information.

Reimplemented from ObexServer.

void ObexFtpDataServer::OnGetComplete ( ObexResult result ) [protected, virtual]

Indicates completion of a GET operation.

Parameters:
result ObexResult which evaluates to 'TRUE' when the operation was completed successfully, 'FALSE' when the operation terminated abnormally. Check the error code then to obtain more detailed information.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnGetHeaders ( const ObexHeaderList & headers ) [protected, virtual]

Indicates reception of OBEX headers within a GET operation.

This method delivers headers received within an ongoing GET operation. Please note that PostResponse() must be called in order to continue the ongoing operation.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnGetIncoming ( ) [protected, virtual]

Indicates the beginning of an incoming GET operation.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnPutComplete ( ObexResult result ) [protected, virtual]

Indicates completion of a PUT operation.

Parameters:
result ObexResult which evaluates to 'TRUE' when the operation was completed successfully, 'FALSE' when the operation terminated abnormally. Check the error code then to obtain more detailed information.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnPutHeaders ( const ObexHeaderList & headers ) [protected, virtual]

Indicates reception of OBEX headers within a PUT operation.

This method delivers headers received within an ongoing PUT operation. Please note that PostResponse() must be called in order to continue the ongoing operation.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnPutIncoming ( ) [protected, virtual]

Indicates the beginning of an incoming PUT operation.

Reimplemented from ObexDataServer.

void ObexFtpDataServer::OnSetPath | ( | const ObexHeaderList & | headers,
 |  | UINT8 | flags
 | ) | [protected, virtual]

Indicates an incoming SETPATH operation.

Parameters:
headers | Header list which normally contains a NAME header which specifies the directory to change into.
flags | SETPATH flags which specify the intended behaviour of the SETPATH operation.
If ObexObject::SetpBackup is set, the current directory should be changed to the parent directory, like "cd .." would do under UNIX.

If ObexObject::SetpDontCreate is set and the directory specified by the NAME header does not exist, it must not be created.

See also:
ObexObject::SetPathFlags

Reimplemented from ObexDataServer.

ObexResult ObexFtpDataServer::SubmitResponse ( ObexObject::ResponseCode resp_code ) [protected]

The documentation for this class was generated from the following files:
  • Obex/ObexFtpDataServer.hpp
  • Obex/ObexFtpDataServer.cpp
Generated on Wed Jan 25 01:32:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexFtpServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexFtpServer Class Reference
[OBEX]

OBEX FTP server which offers an abstract interface to be implemented for a specific file system. More...

#include <Apoxi/Obex/ObexFtpServer.hpp>

Inheritance diagram for ObexFtpServer:

[legend]
Collaboration diagram for ObexFtpServer:

[legend]

Public Types

typedef ObexFtpDataServer::FolderListingEntryProps | FolderListingEntryProperties

Public Member Functions

ObexResult AcceptConnectRequest ()
Used to accept an incoming CONNECT request.
ObexResult AcceptDeleteObjectRequest ()
Used to accept an incoming object delete request.
ObexResult | AcceptFilePullRequest (DataSourcePtr data_src_ptr)
Used to accept an incoming file pull request.
ObexResult | AcceptFilePushRequest (DataSinkPtr data_sink_ptr, UINT32 max_size=0xFFFFFFFFul)
Used to accept an incoming file push request.
ObexResult AcceptFolderListingRequest ()
Used to accept an incoming folder listing request.
ObexResult AcceptSetCurrentFolderRequest ()
Used to accept an incoming current-folder change request.
ObexResult Close ()
Deactivates the server and releases its bindings.
const WString & | GetCurrentFolder () const
Returns the current folder of the server.
virtual void | Init (ExecutionContext *ctx_ptr)
Initializes a default-constructed object.
ObexFtpServer (ExecutionContext *ctx_ptr)
Constructor. Constructs a usable object instance.
ObexFtpServer ()
Default constructor.
virtual void | OnBind (const ObexAddrPtr &addr_ptr, ObexResult result)
Indicates binding of a transport channel to the server.
virtual void | OnClose (ObexResult result)
Indicates completion of a Close() operation.
virtual void | OnConnect (const ObexHeaderList &headers, UINT8 flags)=0
Indicates an incoming CONNECT request.
virtual void | OnDeleteObject (const WString &current_folder, const WString &object)=0
Indicates an incoming object delete request.
virtual void | OnDisconnected (ObexResult result)=0
Indicates that the current client has disconnected.
virtual void | OnFilePull (const WString &current_folder, const WString &filename)=0
Indicates an incoming file pull request.
virtual void | OnFilePullRequestCompleted (ObexResult result)=0
Indicates the completion of a file pull operation.
virtual void | OnFilePush (const WString &current_folder, const WString &filename, UINT32 size)=0
Indicates an incoming file push request.
virtual void | OnFilePushRequestCompleted (ObexResult result)=0
Indicates the completion of a file push operation.
virtual void | OnGetFolderListing (const WString &current_folder)=0
Indicates an incoming folder listing request.
virtual void | OnProvideFolderListingEntries (const WString &current_folder)=0
Indicates that folder entries have to be provided now.
virtual void | OnSetCurrentFolder (const WString &current_folder, const WString &new_current_folder, BOOLEAN create)=0
Indicates an incoming current-folder change request.
ObexResult | Open (const String &obex_addr_url, UINT8 open_flags=0)
Activates the server and binds its address to one or more transport channels.
ObexResult Open ()
Activates the server and binds it to the default OBEX FTP address and to all available transport channels, also creates automatically a Service Discovery Database entry by using 'SdbAutoRegister' as open flag.
ObexResult ProvideFolderListingEntriesFinished ()
Indicates the server that all folder listing entries are provided.
ObexResult | ProvideFolderListingEntry (BOOLEAN isFolder, const String &name, const FolderListingEntryProperties &properties)
Provides a folder listing entry to the server.
ObexResult | RejectConnectRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming CONNECT request.
ObexResult | RejectDeleteObjectRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming object delete request.
ObexResult | RejectFilePullRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming file pull request.
ObexResult | RejectFilePushRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming file push request.
ObexResult | RejectFolderListingRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming folder listing request.
ObexResult | RejectSetCurrentFolderRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming current-folder change request.
virtual | ~ObexFtpServer ()
Destructor. Destroys an ObexFtpServer object.

Detailed Description

OBEX FTP server which offers an abstract interface to be implemented for a specific file system.

This class offers a more convenient interface to implement an OBEX FTP server than using the ObexDataServer class directly. All the OBEX FTP logic is handled by this abstract class, the application programmer must only implemented all abstract methods (these are more or less all specified OBEX FTP commands) to adapt the server to a specific file system.

See also:
RfsObexFtpServer

Member Typedef Documentation

typedef ObexFtpDataServer::FolderListingEntryProps ObexFtpServer::FolderListingEntryProperties

The FolderListingEntryProperties type is a key-value map based on strings. This is the most flexible and generic solution for generating XML folder listings containing different attributes and values.

Constructor & Destructor Documentation

ObexFtpServer::ObexFtpServer ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexFtpServer::ObexFtpServer ( ExecutionContext * ctx_ptr )

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
ctx_ptr Execution context to be used by the server. All notification methods (On.....()) will be called from this context. You may pass '0' as actual parameter to specify the currently active context, which must be valid at construction the time.

ObexFtpServer::~ObexFtpServer ( ) [virtual]

Destructor. Destroys an ObexFtpServer object.

Member Function Documentation

void ObexFtpServer::Init ( ExecutionContext * ctx_ptr ) [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr Execution context in which the server is to be run. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the current context must be valid when Init() is called.

virtual void ObexFtpServer::OnBind | ( | const ObexAddrPtr & | addr_ptr,
 |  | ObexResult | result
 | ) | [inline, virtual]

Indicates binding of a transport channel to the server.

Parameters:
addr_ptr | Smart pointer to OBEX address that was attempted to bind.
result | Either tells that the bind operation was successful or provides error information.

Reimplemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnClose ( ObexResult result ) [inline, virtual]

Indicates completion of a Close() operation.

virtual void ObexFtpServer::OnConnect | ( | const ObexHeaderList & | headers,
 |  | UINT8 | flags
 | ) | [pure virtual]

Indicates an incoming CONNECT request.

When a TARGET was specified as part of the server's OBEX URL it will accept only CONNECT requests with a matching TARGET header. Therefore this does not need to be checked by application SW. When the server was opened specifying a TARGET, a CONNECTION ID is assigned and the pre-build response will contain the following headers: CONNECTION_ID=<set_by_server>}, TARGET=<client's WHO>, WHO=<server's TARGET>. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept the request AcceptConnectRequest(), to reject the request RejectConnectRequest(resp_code) must be called.

Parameters:
headers Header list which contains the headers of the CONNECT request sent by the remote client, for example TARGET and WHO.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnDeleteObject | ( | const WString & | current_folder,
 |  | const WString & | object
 | ) | [pure virtual]

Indicates an incoming object delete request.

When this method is called, the client requests to delete an object in the current directory. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptDeleteObjectRequest() must be called, to reject the request the method RejectDeleteObjectRequest() has to be invoked.

Parameters:
current_folder | The current folder (absolute, e.g. "/UserData/MyMusic/").
object | The name of the object the client requests to be deleted in the current folder. Note: This object name can refer either to a file or folder.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnDisconnected ( ObexResult result ) [pure virtual]

Indicates that the current client has disconnected.

When the method is called, the client has (or has been) disconnected and the server should release any temporary resources and reset itself to a virgin state suitable for accepting a new client connection.

Parameters:
result ObexResult which evaluates to 'TRUE' when the connection was disconnected using a proper OBEX DISCONNECT request, 'FALSE' when a spontaneous disconnection occurred. Check the error code then to obtain more detailed information.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnFilePull | ( | const WString & | current_folder,
 |  | const WString & | filename
 | ) | [pure virtual]

Indicates an incoming file pull request.

When this method is called, the client requests to pull a file from the current directory. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptFilePullRequest() must be called, to reject the request the method RejectFilePullRequest() has to be invoked.

Parameters:
current_folder | The current folder (absolute, e.g "/UserData/MyMusic/").
filename | The file name of the file the client requests to pull from the current folder.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnFilePullRequestCompleted ( ObexResult result ) [pure virtual]

Indicates the completion of a file pull operation.

When an incoming file pull request was accept before by calling AcceptFilePullRequest(...) this method will be invoked later on when the file pull operation has finished.

Parameters:
result ObexResult which evaluates to 'TRUE' when the current operation was completed successfully, 'FALSE' otherwise.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnFilePush | ( | const WString & | current_folder,
 |  | const WString & | filename,
 |  | UINT32 | size
 | ) | [pure virtual]

Indicates an incoming file push request.

When this method is called, the client requests to push a file to the current directory. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptFilePushRequest() must be called, to reject the request the method RejectFilePushRequest() has to be invoked.

Parameters:
current_folder | The current folder (absolute, e.g "/UserData/MyMusic/").
filename | The file name of the file the client requests to push to the current folder.
size | Size of the whole file to be pushed as read from the OBEX LENGTH header. If the size equals '0', it is not yet known.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnFilePushRequestCompleted ( ObexResult result ) [pure virtual]

Indicates the completion of a file push operation.

When a incoming file push request was accept before by calling AcceptFilePushRequest(...) this method will be invoked later on when the file push operation has finished.

Parameters:
result ObexResult which evaluates to 'TRUE' when the current operation was completed successfully, 'FALSE' otherwise.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnGetFolderListing ( const WString & current_folder ) [pure virtual]

Indicates an incoming folder listing request.

When this method is called, the client requests the folder listing of the current folder. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptFolderListingRequest() has to be invoked. To reject this folder listing request RejectFolderListingRequest(resp_code) has to be called.

Parameters:
current_folder The current folder (absolute, e.g "/UserData/MyMusic/") the client requests the folder listing of.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnProvideFolderListingEntries ( const WString & current_folder ) [pure virtual]

Indicates that folder entries have to be provided now.

This method is invoked by the server to indicate that the server is now ready to transfer the the requested folder listing to the client and that the folder listing entries have to be provided now. In order to continue the ongoing operation, the folder listing entries have to be provided by calling ProvideFolderListingEntry(...) for each entry and by finally calling ProvideFolderListingEntriesFinished() when all entries have been provided.

Parameters:
current_folder The current folder (absolute, e.g "/UserData/MyMusic/") the client requests the folder listing of.

Implemented in RfsObexFtpServer.

virtual void ObexFtpServer::OnSetCurrentFolder | ( | const WString & | current_folder,
 |  | const WString & | new_current_folder,
 |  | BOOLEAN | create
 | ) | [pure virtual]

Indicates an incoming current-folder change request.

When this method is called, the client requests a change of the current folder. The current folder and the requested current folder are passed to this method. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptSetCurrentFolderRequest() has to be invoked, to reject the folder change request the method RejectFolderListingRequest(resp_code) has to be invoked.

Parameters:
current_folder | The current folder (absolute, e.g "/UserData/MyMusic/").
new_current_folder | The new folder the current folder should be changed to (absolute, e.g. "/UserData/MyMusic/Ringtones/".
create | Flag indicating if the folder should be created if it doesn't exist yet.

Implemented in RfsObexFtpServer.

The documentation for this class was generated from the following files:
  • Obex/ObexFtpServer.hpp
  • Obex/ObexFtpServer.cpp
Generated on Wed Jan 25 01:32:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexHeader Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexHeader Class Reference
[OBEX]

Represents an OBEX header. More...

#include <Apoxi/Obex/ObexHeader.hpp>

Inheritance diagram for ObexHeader:

[legend]
Collaboration diagram for ObexHeader:

[legend]

Public Types

enum | { MaxHeaderLength = 255 }
Maximum header length supported by the implementation. More...
enum | { NoConnectionId = 0xFFFFFFFF }
enum | ByteOrder { HostByteOrder, ObexByteOrder }
enum HeaderId {
Invalid = 0x00, Count = 0x00 | LongType, Name = 0x01 | UnicodeType, Type = 0x02 | ByteSeqType,
Length = 0x03 | LongType, Description = 0x05 | UnicodeType, Target = 0x06 | ByteSeqType, Http = 0x07 | ByteSeqType,
Who = 0x0A | ByteSeqType, ConnectionId = 0x0B | LongType, AppParams = 0x0C | ByteSeqType, AuthChallenge = 0x0D | ByteSeqType,
AuthResponse = 0x0E | ByteSeqType, CreatorId = 0x0F | LongType, WanUuid = 0x10 | ByteSeqType, ObjectClass = 0x11 | ByteSeqType,
SessionParams = 0x12 | ByteSeqType, SessionSeqNum = 0x13 | ByteType
}
enum | HeaderType { UnicodeType = 0x00, ByteSeqType = 0x40, ByteType = 0x80, LongType = 0xC0 }

Public Member Functions

UINT8 | GetId () const
Returns the header id.
UINT16 | GetSize () const
Returns the size of the header value in octets.
HeaderType | GetType () const
Returns the header type.
BOOLEAN | IsValid () const
Tells whether the header carries a valid value.
ObexResult | PutValue (UINT8 buffer[], UINT16 size, ByteOrder format=ObexByteOrder) const
Serializes the header value into a flat octet string.
UINT8 | ToByte () const
Returns the header value as a 8-bit unsigned integer.
const ByteBuffer & | ToByteBuffer () const
Returns the header value as byte buffer.
const CHAR * | ToCStr () const
Returns the header value as string.
UINT32 | ToLong () const
Returns the header value as a 32-bit unsigned integer.
const String | ToString () const
Returns the header value as string.
const WString & | ToWString () const
Returns the header value as a Unicode string.

Static Public Member Functions

static HeaderType | TypeOfId (INT id)
Tells the type associated with a header id.

Friends

class | ObexHeaderBuilder
class | ObexHeaderList

Data Structures

union | HeaderVariant
Header data variant.

Detailed Description

Represents an OBEX header.

OBEX headers consist of a Header identifier and the associated header data. The upper two bits of the 8-bit Header identifier specify the data type. Some headers are defined by the OBEX specification, but applications may additionally define their own headers.

It is not possible for applications to create instances of ObexHeader directly. Instead, the AddHeader method of class ObexHeaderList must be used. It is also not possible to modify header instances or delete them 'manually' - ObexHeader instances are immutable.

See also:
HeaderType - Data types supported by OBEX headers.

HeaderId - Header ID's of standard OBEX headers.

ObexHeaderList - List managing ObexHeader instances

Member Enumeration Documentation

anonymous enum

Maximum header length supported by the implementation.

Enumerator:
MaxHeaderLength

anonymous enum

Enumerator:
NoConnectionId Indicates that no Connection Id has been assigned.

enum ObexHeader::ByteOrder

Enumerator:
HostByteOrder | Native byte order of the local system.
ObexByteOrder | OBEX network byte order - BIG ENDIAN !

enum ObexHeader::HeaderId

Lists the Header identifiers that are predefined by the OBEX specification.

Enumerator:
Invalid
Count
Name
Type
Length
Description
Target
Http
Who
ConnectionId
AppParams
AuthChallenge
AuthResponse
CreatorId
WanUuid
ObjectClass
SessionParams
SessionSeqNum

enum ObexHeader::HeaderType

Lists the data types supported by OBEX headers

Enumerator:
UnicodeType | Unicode text.
ByteSeqType | Octet string.
ByteType | Single byte integer (8 bits).
LongType | Quad byte integer (32 bits).

Member Function Documentation

UINT16 ObexHeader::GetSize ( ) const

Returns the size of the header value in octets.

ObexResult ObexHeader::PutValue | ( | UINT8 | buffer[],
 |  | UINT16 | size,
 |  | ByteOrder | format = ObexByteOrder
 | ) | const

Serializes the header value into a flat octet string.

The method converts the header value into a flat octet stream. Conversion into target byte order is performed on the fly when required. When the buffer provided by the caller is not large enough to hold the output, it is left untouched and an error is returned.

Parameters:
buffer | Buffer to hold the byte stream output, must be large enough to hold at least size bytes !
size | Size of the buffer passed as 1st parameter (in octets).
format | Output format to be produced by the function, the default is ObexByteOrder (big endian).
Returns:
ObexResult which evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

UINT8 ObexHeader::ToByte ( ) const

Returns the header value as a 8-bit unsigned integer.

Warning:Invoking this method when the header type is different from ByteType is illegal and will trigger an assertion !

const ByteBuffer & ObexHeader::ToByteBuffer ( ) const

Returns the header value as byte buffer.

Warning:Invoking this method when the header type is different from ByteSeqType is illegal and will trigger an assertion !

const CHAR* ObexHeader::ToCStr ( ) const

Returns the header value as string.

Note:This only makes sense when the header does not contain binary data (especially 0x00 bytes), otherwise the string will be truncated. Use ByteBuffer to work with binary data.

Warning:Invoking this method when the header type is different from ByteSeqType is illegal and will trigger an assertion !

UINT32 ObexHeader::ToLong ( ) const

Returns the header value as a 32-bit unsigned integer.

Warning:Invoking this method when the header type is different from LongType is illegal and will trigger an assertion !

const String ObexHeader::ToString ( ) const

Returns the header value as string.

Note:This only makes sense when the header does not contain binary data (especially 0x00 bytes), otherwise the string will be truncated. Use ByteBuffer to work with binary data.

Warning:Invoking this method when the header type is different from ByteSeqType is illegal and will trigger an assertion !

const WString & ObexHeader::ToWString ( ) const

Returns the header value as a Unicode string.

Warning:Invoking this method when the header type is different from UnicodeType is illegal and will trigger an assertion !

Friends And Related Function Documentation

friend class ObexHeaderBuilder [friend]

friend class ObexHeaderList [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexHeader.hpp
  • Obex/ObexHeader.cpp
Generated on Wed Jan 25 01:32:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexHeaderBuilder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexHeaderBuilder Class Reference
[OBEX]

Helps to assemble an OBEX header from several chunks of data. More...

#include <Apoxi/Obex/ObexHeaderBuilder.hpp>

Collaboration diagram for ObexHeaderBuilder:

[legend]

Public Member Functions

ObexResult | AppendData (const UINT8 data[], UINT16 length)
Appends data bytes to the header under construction.
BOOLEAN | IsComplete () const
Tells whether the header being built is complete.
ObexResult | NewHeader (UINT8 id, UINT16 max_size=0)
Starts a new OBEX header.
ObexHeaderBuilder (ObexHeader::ByteOrder format=ObexHeader::ObexByteOrder)
Constructs an ObexHeaderBuilder instance.
ObexResult | SetValue (UINT32 value)
Builds a 1 or 4 byte header from a 32 integer value.

Friends

class | ObexHeaderList

Detailed Description

Helps to assemble an OBEX header from several chunks of data.

Warning;
This is an internal utility class interface and must not be used outside APOXI at all. However, developers of Transport Adapters for APOXI OBEX may find this class helpful.

It is used to assemble ObexHeader objects from multiple chunks of data as it becomes necessary when the transport protocol does segmentation of OBEX packets. Additionally, presentation decoding is supported which becomes necessary when the host byte order is different from OBEX byte order.

See also:
ObexHeaderList

Constructor & Destructor Documentation

ObexHeaderBuilder::ObexHeaderBuilder ( ObexHeader::ByteOrder format = ObexHeader::ObexByteOrder )

Constructs an ObexHeaderBuilder instance.

Parameters:
format Specifies the presentation format in which header data is passed to the builder.

Member Function Documentation

ObexResult ObexHeaderBuilder::AppendData | ( | const UINT8 | data[],
 |  | UINT16 | length
 | ) |

Appends data bytes to the header under construction.

Parameters:
data | Data buffer from which data can be read
length | Length of the data block in octets.
Returns:
ObexResult which evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

BOOLEAN ObexHeaderBuilder::IsComplete ( ) const

Tells whether the header being built is complete.

Returns:
'TRUE' when the size of the header value is equal or greater than the size provided when NewHeader() was called, \'FALSE' otherwise.

ObexResult ObexHeaderBuilder::NewHeader | ( | UINT8 | id,
 |  | UINT16 | max_size = 0
 | ) |

Starts a new OBEX header.

Tells the builder to start building a new OBEX header and reserves space for 'max_size' octets of header data. The header type is determined from 'id'. If the header type is ByteType or LongType the size is automatically set to the correct value and 'max_size' is ignored, hence the parameter can be omitted in this case.

Parameters:
id | OBEX Header Id of the header to be assembled
max_size | Maximum size of the header to be assembled
Returns:
ObexResult which evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

ObexResult ObexHeaderBuilder::SetValue ( UINT32 value )

Builds a 1 or 4 byte header from a 32 integer value.

This function should be called only if the entity under construction is an OBEX 1 Byte or 4 Byte header. It is mainly provided to ease interfacing with the Extended Systems IrDA stack.

Parameters:
value Value to construct header from, in HOST byte order !
Returns:
ObexResult which evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Friends And Related Function Documentation

friend class ObexHeaderList [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexHeaderBuilder.hpp
  • Obex/ObexHeaderBuilder.cpp
Generated on Wed Jan 25 01:32:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexHeaderList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexHeaderList Class Reference
[OBEX]

Managing list of OBEX headers. More...

#include <Apoxi/Obex/ObexHeaderList.hpp>

Inheritance diagram for ObexHeaderList:

[legend]
Collaboration diagram for ObexHeaderList:

[legend]

Public Member Functions

ObexResult | AddMimeType (MimeType mime_type)
Adds an OBEX Type header to the list.
ConstIterator | Begin () const
Returns an iterator which points to the first header of the list.
BOOLEAN | Contains (ObexHeader::HeaderId id) const
Tells if the list contains at least one header whose header Id equals the given one.
BOOLEAN | Contains (ObexHeader::HeaderId id, ConstIterator from) const
Tells if the list contains at least one header whose header Id equals the given one.
ConstIterator | Find (ObexHeader::HeaderId id) const
Find first header whose header Id equals the given one.
ConstIterator | Find (ObexHeader::HeaderId id, ConstIterator from) const
Find first header whose header Id equals the given one.
ObexHeaderList ()
Default constructor. Constructs an empty ObexHeaderList.
MimeType | ObtainMimeType () const
Determines the mime type of an object from the header list.
~ObexHeaderList ()
Destructor. Destroys an ObexHeaderList.
ObexResult | AddHeader (ObexHeaderBuilder &builder)
Adds an OBEX header build by an ObexHeaderBuilder to the list.
ObexResult | AddHeader (INT id, UINT32 long_data)
Adds an quad byte (long) type OBEX header to the list.
ObexResult | AddHeader (INT id, UINT8 byte_data)
Adds an single byte type OBEX header to the list.
ObexResult | AddHeader (INT id, const UINT8 data[], UINT16 data_size)
Adds an byte sequence type OBEX header to the list.
ObexResult | AddHeader (INT id, const String &byteseq_data)
Adds an byte sequence type OBEX header to the list.
ObexResult | AddHeader (INT id, const WString &unicode_data)
Adds an unicode type OBEX header to the list.

Friends

class | ObexObjectData

Data Structures

class | ConstIterator

Detailed Description

Managing list of OBEX headers.

This class serves as a container for ObexHeader elements. List elements are immutable and are managed by the list, therefore when an ObexHeaderList instance is deleted all its elements are destroyed, too.

The list offers an iterator which can be used to conveniently examine individual headers and extract their value.

Example:

    // Function extracts NAME and TYPE header values, when available ...
    static void ExtractNameAndType(const ObexHeaderList &   list)
    {
        // Loop over list elements one after another
        for ( ObexHeaderList::ConstIterator it = list.Begin();
                                            it.IsValid();
                                          ++it ) {
            WString     name_str;
            String      type_str;

            // Check for desired headers by looking at their ID's
            switch( it->GetId() ) {
                case ObexHeader::Name :
                    // NAME headers present (unicode), save value
                    name_str = it->ToWString();
                    break;

                case ObexHeader::Type :
                    // TYPE header present (ascii), save value
                    type_str = it->ToString();
                    break;

                default:
                    // Ignore other header types
                    break;
            }
        }
        // Evaluate name / type information ...
    }

Constructor & Destructor Documentation

ObexHeaderList::ObexHeaderList ( )

Default constructor. Constructs an empty ObexHeaderList.

ObexHeaderList::~ObexHeaderList ( )

Destructor. Destroys an ObexHeaderList.

At destruction time, all ObexHeader elements within the list are deleted. Any iterators referring to the list must not be used anymore.

Member Function Documentation

ObexResult ObexHeaderList::AddHeader ( ObexHeaderBuilder & builder )

Adds an OBEX header build by an ObexHeaderBuilder to the list.

Parameters:
id | Header id of the header to be added.
long_data | Data to be stored within the OBEX header.
Returns:
'TRUE' in case of success, 'FALSE' otherwise.

ObexResult ObexHeaderList::AddHeader | ( | INT | id,
 |  | UINT32 | long_data
 | ) |

Adds an quad byte (long) type OBEX header to the list.

Example:

            ObexResult  res = list.AddHeader( ObexHeader::Length, 1000) );

Parameters:
id | Header id of the header to be added.
long_data | Data to be stored within the OBEX header.
Returns:
'TRUE' in case of success, 'FALSE' otherwise.

ObexResult ObexHeaderList::AddHeader | ( | INT | id,
 |  | UINT8 | byte_data
 | ) |

Adds an single byte type OBEX header to the list.

Example:

            ObexResult  res = list.AddHeader( ObexHeader::SessionSeqNum, 1) );

Parameters:
id | Header id of the header to be added.
byte_data | Data to be stored within the OBEX header.
Returns:
'TRUE' in case of success, 'FALSE' otherwise.

ObexResult ObexHeaderList::AddHeader | ( | INT | id,
 |  | const UINT8 | data[],
 |  | UINT16 | data_size
 | ) |

Adds an byte sequence type OBEX header to the list.

Example:

            UINT8 data[] = {0x00, 0x01, 0x02, 0x03};

            ObexResult  res = list.AddHeader( ObexHeader::AppParams, data, sizeof(data)) );

Parameters:
id | Header id of the header to be added.
data | Byte array from which data is copied into the header.
data_size | Size of the data within the array in octets.
Returns:
'TRUE' in case of success, 'FALSE' otherwise.

ObexResult ObexHeaderList::AddHeader | ( | INT | id,
 |  | const String & | byteseq_data
 | ) |

Adds an byte sequence type OBEX header to the list.

Example:

            ObexResult  res = list.AddHeader( ObexHeader::Type, "text/x-vcard") );

Parameters:
id | Header id of the header to be added.
byteseq_data | Data to be stored within the OBEX header.
Returns:
'TRUE' in case of success, 'FALSE' otherwise.

ObexResult ObexHeaderList::AddHeader | ( | INT | id,
 |  | const WString & | unicode_data
 | ) |

Adds an unicode type OBEX header to the list.

Example:

            ObexResult  res = list.AddHeader( ObexHeader::Name, L("mycard.vcf") );

Parameters:
id | Header id of the header to be added.
unicode_data | Data to be stored within the OBEX header.
Returns:
'TRUE' in case of success, 'FALSE' otherwise.

ObexResult ObexHeaderList::AddMimeType ( MimeType mime_type )

Adds an OBEX Type header to the list.

Parameters:
mime_type Mime type to be specified by the type header.
Returns:
'TRUE' in case of success, 'FALSE' otherwise.

ObexHeaderList::ConstIterator ObexHeaderList::Find | ( | ObexHeader::HeaderId | id,
 |  | ConstIterator | from
 | ) | const

Find first header whose header Id equals the given one.

Parameters:
id | Header Id of the OBEX header to be retrieved.
from | Position in the list where to start searching.
Returns:
Iterator referring to the corresponding header if one was found, invalid iterator otherwise.

MimeType ObexHeaderList::ObtainMimeType ( ) const

Determines the mime type of an object from the header list.

This method scans the header list for a TYPE header. If found, it is used to determine the mimetype, otherwise when a NAME header is present an attempt is made to obtain the type from its extension.

Returns:
MimeType of the object in case of success, 'c_mime_unknown' in case of error.

Friends And Related Function Documentation

friend class ObexObjectData [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexHeaderList.hpp
  • Obex/ObexHeaderList.cpp
Generated on Wed Jan 25 01:32:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexHeaderList::ConstIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ObexHeaderList::ConstIterator

ObexHeaderList::ConstIterator Class Reference

#include <Apoxi/Obex/ObexHeaderList.hpp>

Collaboration diagram for ObexHeaderList::ConstIterator:

[legend]

Public Member Functions

void | Advance ()
Advance the iterator. This has the effect of making it point to the next available list element. If there is no more element to point at, the iterator will become the invalid iterator.
ConstIterator (const ConstIterator &from)
Copy constructor.
ConstIterator ()
Default constructor. Constructs the invalid iterator.
BOOLEAN | IsValid () const
Tells whether the iterator is valid.
const ObexHeader & | operator * () const
Access currently denoted header by reference.
ConstIterator & operator++ ()
const ObexHeader * | operator-> () const
Access currently denoted header by pointer.
ConstIterator & | operator= (const ConstIterator &from)
Assigment operator.

Friends

class | ObexHeaderList

Member Function Documentation

void ObexHeaderList::ConstIterator::Advance ( )

Advance the iterator. This has the effect of making it point to the next available list element. If there is no more element to point at, the iterator will become the invalid iterator.

See also:
IsValid()

Friends And Related Function Documentation

friend class ObexHeaderList [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexHeaderList.hpp
  • Obex/ObexHeaderList.cpp
Generated on Wed Jan 25 01:32:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexLayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexLayer Class Reference
[OBEX]

Internal interface base class for direct access to the OBEX layer. More...

#include <Apoxi/Obex/ObexLayer.hpp>

Inheritance diagram for ObexLayer:

[legend]
Collaboration diagram for ObexLayer:

[legend]

Public Member Functions

virtual void | Abort (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &abort_req)=0
Aborts an ongoing OBEX client operation.
virtual void | Connect (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)=0
Starts an OBEX CONNECT operation.
virtual void | DataProcessed (const ObexChannel &channel, ObexOperationId oper_id, ObexBuffer &obex_buffer)=0
Confirm processing of data delivered to an application.
virtual void | Disconnect (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &disc_req)=0
Starts an OBEX DISCONNECT operation.
virtual void | Get (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &get_req)=0
Starts or continues an OBEX GET operation.
virtual void | Put (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &put_req)=0
Starts or continues an OBEX PUT operation.
virtual void | ReturnResponse (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &server_resp)=0
Sends a response to a client request.
virtual void | SetPath (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &setp_req)=0
Starts an OBEX SETPATH operation.

Protected Member Functions

ObexLayer ()
void | OnAbort (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &abort_req, ObexServerId server_id=ObexServerInfo::NoServerId)
Indicates abort of an ongoing OBEX operation to a server.
void | OnConnect (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Forwards an incoming OBEX CONNECT request to a server.
void | OnDataProcessed (const ObexChannel &channel, ObexOperationId oper_id, ObexBuffer &app_buffer)
Confirms processing of data supplied by an application.
void | OnDisconnect (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &disc_req)
Forwards an incoming OBEX DISCONNECT request to a server.
ObexServerId | OnGet (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &get_req)
Forwards an incoming OBEX GET request to a server.
ObexServerId | OnPut (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &put_req)
Forwards an incoming OBEX PUT request to a server.
void | OnResponse (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &server_resp)
Returns an OBEX response to a client.
void | OnSetPath (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexObject &setp_req)
Forwards an incoming OBEX SETPATH request to a server.

Detailed Description

Internal interface base class for direct access to the OBEX layer.

Warning;
This is an internal interface and must not be used outside APOXI at all.

It must be implemented by all transport adapters, hence developers of transport adapters for APOXI OBEX will need to understand the concepts explained in the following paragraphs:

Outbound client requests and server responses.

Outbound requests to the protocol stack are represented by public abstract methods, which must be implemented by each transport adapter module. Class ObexProtocol defines the transport-level interface with operations related to opening an closing a physical connection, while ObexLayer extends it to support OBEX operations over that transport abstraction.

Inbound client responses and server requests.

Inbound requests from the protocol stack must be handled by calling the appropriate protected On<event_occured> methods. These methods execute in the context of the caller, which is mostly a stack callback function. The caller may safely assume that no application software functions are ever directly invoked from this context. Instead, the server registry is checked to verify if there is a server capable of handling the request. If yes, an ObexMsg is sent which is later received by an ObexDispatcher running in an ExecutionContext of APOXI. If not, the request is immediately rejected by synchronously sending an error response from the context of the caller, and no message is sent.

OBEX Operations.

An OBEX operation is composed from at least one Request-Response pair followed by OnComplete() being invoked to indicate the end of the operation. OBEX PUT and GET operations may (and usually will) involve multiple request-response pairs, while the simple OBEX operations CONNECT, DISCONNECT, and SETPATH each utilize exactly one request-response pair.

See also:
ObexProtocol
Please don't forget to feed the transport interface inherited from ObexProtocol, especially the OnComplete() method which must be called on completion of every OBEX- and transport operation.

Constructor & Destructor Documentation

ObexLayer::ObexLayer ( ) [protected]

Member Function Documentation

virtual void ObexLayer::Abort | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | abort_req
 | ) | [pure virtual]

Aborts an ongoing OBEX client operation.

Only a currently pending PUT or GET operation can be aborted, and only clients may issue ABORT requests.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier of the operation to be aborted
abort_req | OBEX object which holds the headers to be included in the ABORT request.

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual void ObexLayer::Connect | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [pure virtual]

Starts an OBEX CONNECT operation.

The channel must be a valid client channel in state 'OPEN'.

See also:
OpenClientChannel(). The result is delivered asynchronously by means of a call to OnResponse().

OnResponse()

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
conn_req | OBEX object which holds the headers to be included in the CONNECT request and flags according to OBEX Spec. 3.3.1.2, but no data !

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual void ObexLayer::DataProcessed | ( | const ObexChannel & | channel,
 |  | ObexOperationId | oper_id,
 |  | ObexBuffer & | obex_buffer
 | ) | [pure virtual]

Confirm processing of data delivered to an application.

By calling this method the application layer returns the ownership of a buffer back to the protocol implementation which had produced the buffer and therefore knows how to dispose it.

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual void ObexLayer::Disconnect | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | disc_req
 | ) | [pure virtual]

Starts an OBEX DISCONNECT operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
disc_req | OBEX object which holds the headers to be included in the DISCONNECT request.

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual void ObexLayer::Get | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | get_req
 | ) | [pure virtual]

Starts or continues an OBEX GET operation.

Note that in rare cases a GET request may contain a BODY header !

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier.
get_req | OBEX object which holds the headers to be included in the GET request and possibly BODY data within an ObexBuffer.

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

void ObexLayer::OnAbort | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | abort_req,
 |  | ObexServerId | server_id = ObexServerInfo::NoServerId
 | ) | [protected]

Indicates abort of an ongoing OBEX operation to a server.

This method must be called by the protocol implementation to indicate that the remote client has ordered an abort of the current operation. The channel must be a valid server channel.

See also:
OpenServerChannel(). The result of the operation is delivered asynchronously by means of a call to ReturnResponse().

ReturnResponse(). In order to avoid race conditions when the first PUT or GET request has been indicated to ObexLayer but not yet been dispatched by the application layer, it is advisable to store the ServerId returned by OnPut() and OnGet() for each channel within the transport implementation and include it when calling OnAbort().

Parameters:
server_chan | Server channel associated with the request.
oper_id | Operation identifier of the operation to be aborted
abort_req | OBEX object which holds the headers included in the ABORT request.
server_id | ObexServerId returned by a preceeding OnPut() or OnGet() of the operation to be aborted.

void ObexLayer::OnConnect | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [protected]

Forwards an incoming OBEX CONNECT request to a server.

This method must be called by the protocol implementation to indicate an incoming CONNECT request to a server. The channel must be a valid server channel.

See also:
OpenServerChannel(). The result of the operation is delivered asynchronously by means of a call to ReturnResponse().

ReturnResponse() An ObexOperationId must be assigned using ObexOperationId::Create() !

Parameters:
server_chan | Server channel associated with the request.
oper_id | Operation identifier (issued by implementation)
conn_req | OBEX object which holds the headers included in the CONNECT request and flags according to OBEX Spec. 3.3.1.2, but no data !

void ObexLayer::OnDataProcessed | ( | const ObexChannel & | channel,
 |  | ObexOperationId | oper_id,
 |  | ObexBuffer & | app_buffer
 | ) | [protected]

Confirms processing of data supplied by an application.

By calling this method the protocol implementation returns the ownership of a buffer back to the application layer which had produced the buffer and therefore knows how to dispose it.

Parameters:
channel | ObexChannel the operation is running on.
oper_id | Operation identifier of the operation the buffer is associated with.
app_buffer | ObexBuffer to be returned to the application layer.

void ObexLayer::OnDisconnect | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | disc_req
 | ) | [protected]

Forwards an incoming OBEX DISCONNECT request to a server.

This method must be called by the protocol implementation to indicate an incoming DISCONNECT request to a server. The channel must be a valid server channel.

See also:
OpenServerChannel(). The result of the operation is delivered asynchronously by means of a call to ReturnResponse().

ReturnResponse() An ObexOperationId must be assigned using ObexOperationId::Create() !

Parameters:
server_chan | Server channel associated with the request.
oper_id | Operation identifier (issued by implementation)
conn_req | OBEX object which holds the headers included in the DISCONNECT request, but no data !

ObexServerId ObexLayer::OnGet | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | get_req
 | ) | [protected]

Forwards an incoming OBEX GET request to a server.

This method must be called by the protocol implementation to indicate an incoming GET request to a server. The channel must be a valid server channel.

See also:
OpenServerChannel(). The result of the operation is delivered asynchronously by means of a call to ReturnResponse().

ReturnResponse()

For each GET operation, an ObexOperationId must be assigned using ObexOperationId::Create() !. If one GET operation comprises multiple requests, the following requests must use the same operation id as the first one (therefore it seems wise to save the operation id until the operation is complete !).

Parameters:
server_chan | Server channel associated with the request.
oper_id | Operation identifier (issued by implementation)
get_req | OBEX object which holds the headers included in the GET request and possibly (in rare cases) BODY data within an ObexBuffer.
Returns:
ObexServerId of the server which is going to handle the request or NoServerId when no suitable server was found. In the latter case, ReturnResponse() is called synchronously from this function indicating an error.

ObexServerId ObexLayer::OnPut | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | put_req
 | ) | [protected]

Forwards an incoming OBEX PUT request to a server.

This method must be called by the protocol implementation to indicate an incoming PUT request to a server. The channel must be a valid server channel.

See also:
OpenServerChannel(). The result of the operation is delivered asynchronously by means of a call to ReturnResponse().

ReturnResponse()

For each PUT operation, an ObexOperationId must be assigned using ObexOperationId::Create() !. If one PUT operation comprises multiple requests, the following requests must use the same operation id as the first one (therefore it seems wise to save the operation id until the operation is complete !).

Parameters:
server_chan | Server channel associated with the request.
oper_id | Operation identifier (issued by implementation)
put_req | OBEX object which holds the headers included in the PUT request and possibly BODY data within an ObexBuffer.
Returns:
ObexServerId of the server which is going to handle the request or NoServerId when no suitable server was found. In the latter case, ReturnResponse() is called synchronously from this function indicating an error.

void ObexLayer::OnResponse | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | server_resp
 | ) | [protected]

Returns an OBEX response to a client.

This method is used by protocol implementations for specific transports which derive their implementation from this base class. It should be called to deliver OBEX responses returned by a remote OBEX server.

Parameters:
client_chan | Client channel associated with the response.
oper_id | Operation identifier (same as in request).
server_resp | OBEX object holding headers, a response code and possibly BODY data within an ObexBuffer returned by the remote server.

void ObexLayer::OnSetPath | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | setp_req
 | ) | [protected]

Forwards an incoming OBEX SETPATH request to a server.

This method must be called by the protocol implementation to indicate an incoming SETPATH request to a server. The channel must be a valid server channel.

See also:
OpenServerChannel(). The result of the operation is delivered asynchronously by means of a call to ReturnResponse().

ReturnResponse() An ObexOperationId must be assigned using ObexOperationId::Create() !

Parameters:
server_chan | Server channel associated with the request.
oper_id | Operation identifier (issued by implementation)
setp_req | OBEX object which holds the headers included in the SETPATH request and flags according to OBEX Spec. 3.3.6.1, but no data !

virtual void ObexLayer::Put | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | put_req
 | ) | [pure virtual]

Starts or continues an OBEX PUT operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
put_req | OBEX object which holds the headers to be included in the PUT request and possibly BODY data within an ObexBuffer.

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual void ObexLayer::ReturnResponse | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | server_resp
 | ) | [pure virtual]

Sends a response to a client request.

Parameters:
server_chan | Server channel associated with the response.
oper_id | Operation identifier of the request to respond to (it was passed along with the request).
server_resp | OBEX object which holds the headers to be included in the response, the response code and possibly BODY data within an ObexBuffer.

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual void ObexLayer::SetPath | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | setp_req
 | ) | [pure virtual]

Starts an OBEX SETPATH operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
setp_req | OBEX object which holds the headers to be included in the SETPATH request and flags according to OBEX Spec. 3.3.6.1, but no data !

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

The documentation for this class was generated from the following files:
  • Obex/ObexLayer.hpp
  • Obex/ObexLayer.cpp
Generated on Wed Jan 25 01:32:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexMngr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexMngr Class Reference
[OBEX]

OBEX Manager. Singleton. Facade to global APOXI OBEX functionality. More...

#include <Apoxi/Obex/ObexMngr.hpp>

Collaboration diagram for ObexMngr:

[legend]

Public Member Functions

void | AbortSelection (ObexOperationId oper_id)
Aborts transport selection by MMI user.
ObexTransportSet | EnumTransports (const String &filter_url=c_any_url) const
Enumerates available transports.
ObexProtocol & | GetProtocol (const ObexChannel &channel) const
Obtains the protocol object associated with a transport channel.
ObexAbstractTransport & | GetTransport (ObexTransportId transport_id) const
Obtains the transport object associated with a transport id.
ObexAbstractTransport & | GetTransport (const ObexChannel &channel) const
Obtains the transport object asociated with a transport channel.
void | RegisterObexApp (Application &obex_app)
Lets an application take the role of the OBEX application.
ObexResult | SelectTransport (ObexAbstractTransport *selected)
Return result of Transport Selection procedure.
ObexOperationId | StartSelection (ObexTransportSet sel_from)
Requests transport selection by MMI user.

Static Public Member Functions

static ObexMngr & | GetInstance ()
Singleton accessor.

Static Public Attributes

static const CHAR * | c_any_url = "*://"

Friends

class | ObexAbstractTransport
class | ObexLayer
class | ObexOppServer
class | ObexOppServerTest
class | ObexServer
class | ObexServerInfo
class | TransportManager

Data Structures

class | SelectCommand
Internal class representing a transport selection request.
class | TransportMngr
Internal registry for Transport Adapters.
class | TransportVisitor
Internal visitor interface for visiting transports.

Detailed Description

OBEX Manager. Singleton. Facade to global APOXI OBEX functionality.

The OBEX manager is a singleton class which provides access to several global interfaces affecting the APOXI OBEX module.

Warning;
Only the OBEX Application Interface is intended to be used by MMI, all other functions not mentioned in the next paragraph below may be used exclusively by APOXI OBEX.

The OBEX Application Interface provides methods suitable to present a choice of transport protocols to the MMI user, who can then select the appropriate transport. This funtionality must be implemented within a privileged MMI application, the so-called OBEX Application. A MMI application becomes the OBEX Application by calling RegisterObexApp() passing its own 'this' pointer as parameter. Whenever an OBEX client tries to open a transport connection without specifying the transport address (i.e. when ObexClientDispatcher::Open() is called with an OBEX URL parameter containing a wildcard character instead of a transport name like "*://"), an ObexAppMsg is sent to the OBEX Application requesting that the MMI user should be prompted to select a transport media.

This procedure is called Transport Address Selection. When the OBEX Application receives an ObexAppMsg, it should call EnumTransports() to obtain a set of available transports. The ObexTransportSet instance returned offers an iterator which can be used to access the individual transports an query their name. Then MMI should prompt the user to select on of the transports. After the user has chosen a transport SelectTransport() should be called passing a pointer to the selected OBEX transport instance. When the selection is cancelled by the MMI, a '0' pointer shall pe passed instead, this aborts the current Transport Address Selection and the ObexClientDispatcher which has initiated it is notified that Open() has failed with the result ObexResult::OperationAborted.

See also:
ObexTransportSet

ObexAbstractTransport

Member Function Documentation

void ObexMngr::AbortSelection ( ObexOperationId oper_id )

Aborts transport selection by MMI user.

Should be called only by APOXI OBEX.

Parameters:
oper_id Operation id of the procedure to be aborted.

ObexMngr & ObexMngr::GetInstance ( ) [static]

Singleton accessor.

ObexProtocol& ObexMngr::GetProtocol ( const ObexChannel & channel ) const

Obtains the protocol object associated with a transport channel.

Parameters:
channel Valid transport channel. If the channel is invalid (i.e. not associated with any ObexProtocol) an assertion is triggered.
Returns:
Reference to the ObexProtocol object associated with channel. To specific protocol functionality, it should be downcasted to an adequate subclass.

ObexAbstractTransport & ObexMngr::GetTransport ( ObexTransportId transport_id ) const

Obtains the transport object associated with a transport id.

Parameters:
transport_id Valid transport id. If the id is invalid (i.e. not associated with any ObexTransport) an assertion is triggered.
Returns:
Reference to the ObexTransport object associated with channel.

ObexAbstractTransport& ObexMngr::GetTransport ( const ObexChannel & channel ) const

Obtains the transport object asociated with a transport channel.

Parameters:
channel Valid transport channel. If the channel is invalid (i.e. not associated with any ObexTransport) an assertion is triggered.
Returns:
Reference to the ObexTransport object associated with channel.

void ObexMngr::RegisterObexApp ( Application & obex_app )

Lets an application take the role of the OBEX application.

Calling this method on an application object registers the app with the OBEX Manager. Whenever transport address selection is demanded, an ObexAppMsg is sent to this application known as OBEX app.

Parameters:
obex_app Reference to the OBEX application object.

ObexResult ObexMngr::SelectTransport ( ObexAbstractTransport * selected )

Return result of Transport Selection procedure.

Must be called by the responsible application at the end of the Transport Selection procedure to deliver the user's choice to APOXI OBEX and indicate completion of the procedure.

Parameters:
selected Pointer to ObexTransport instance chosen or '0' to cancel the Transport Address Selection procedure.
Returns:
ObexResult which evaluates to TRUE when the choice has been accepted by APOXI OBEX, FALSE otherwise.

ObexOperationId ObexMngr::StartSelection ( ObexTransportSet sel_from )

Requests transport selection by MMI user.

Invoking this function prompts the MMI user to pick a transport from the given set. User interaction will be carried out by the OBEX application, which is supposed to call SelectTransport() on completion of the procedure. When the procedure is already running, the request will be queued and launched after completion of the pending operation. Should be called only by APOXI OBEX.

Parameters:
sel_from ObexTransportSet to pick an address from.
Returns:
When the request has been accepted, a valid ObexOperationId is returned which will be included in the ObexTransportMsg sent when a transport is selected. In case of error, an invalid ObexOperationId is returned.

Friends And Related Function Documentation

friend class ObexAbstractTransport [friend]

See also:
RegisterTransport().

friend class ObexLayer [friend]

friend class ObexOppServer [friend]

friend class ObexOppServerTest [friend]

friend class ObexServer [friend]

friend class ObexServerInfo [friend]

friend class TransportManager [friend]

Field Documentation

const CHAR * ObexMngr::c_any_url = "*://" [static]

The documentation for this class was generated from the following files:
  • Obex/ObexMngr.hpp
  • Obex/ObexMngr.cpp
Generated on Wed Jan 25 01:32:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexMsg Class Reference

#include <Apoxi/Obex/ObexMessages.hpp>

Inheritance diagram for ObexMsg:

[legend]
Collaboration diagram for ObexMsg:

[legend]

Public Types

enum | { ID = 11000 }

Public Member Functions

virtual Message * | Clone () const
const ObexChannel & | GetChannel () const
virtual const MsgMetaData & | GetMetaData () const
const ObexMsgType & | GetMsgType () const
const ObexObject & | GetObject () const
const ObexOperationId & | GetOperationId () const
const ObexResult & | GetResult () const
const ObexServerId & | GetServerId () const
ObexMsg (const ObexMsgType &msg_type, const ObexServerId &server_id, const ObexResult &result, const ObexOperationId &operation_id, const ObexChannel &channel, const ObexObject &object=ObexObject())
virtual | ~ObexMsg ()

Detailed Description

Sent by APOXI when an OBEX event has been received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ObexMsg::ObexMsg | ( | const ObexMsgType & | msg_type,
 |  | const ObexServerId & | server_id,
 |  | const ObexResult & | result,
 |  | const ObexOperationId & | operation_id,
 |  | const ObexChannel & | channel,
 |  | const ObexObject & | object = ObexObject()
 | ) |

ObexMsg::~ObexMsg ( ) [virtual]

Member Function Documentation

Message * ObexMsg::Clone ( ) const [virtual]

Implements Message.

const ObexChannel& ObexMsg::GetChannel ( ) const [inline]

const MsgMetaData & ObexMsg::GetMetaData ( ) const [virtual]

Implements Message.

const ObexMsgType& ObexMsg::GetMsgType ( ) const [inline]

const ObexObject& ObexMsg::GetObject ( ) const [inline]

const ObexOperationId& ObexMsg::GetOperationId ( ) const [inline]

const ObexResult& ObexMsg::GetResult ( ) const [inline]

const ObexServerId& ObexMsg::GetServerId ( ) const [inline]

The documentation for this class was generated from the following files:
  • Obex/ObexMessages.hpp
  • Obex/ObexMessages.cpp
Generated on Wed Jan 25 01:32:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexObject Class Reference
[OBEX]

Handle class which provides access to OBEX protocol data. More...

#include <Apoxi/Obex/ObexObject.hpp>

Collaboration diagram for ObexObject:

[legend]

Public Types

enum | ConnectFlags { ConnMultipleIrlmpLsapSel = 0x01 }
Flags for CONNECT shall be composed by or-ing these values. More...
enum ResponseCode {
Request = 0, RespOk = 0x20, RespMultipleChoices = 0x30, RespMovedPermanently = 0x31,
RespMovedTemporarily = 0x32, RespSeeOther = 0x33, RespNotModified = 0x34, RespUseProxy = 0x35,
RespBadRequest = 0x40, RespUnauthorized = 0x41, RespPaymentRequired = 0x42, RespForbidden = 0x43,
RespNotFound = 0x44, RespMethodNotAllowed = 0x45, RespNotAcceptable = 0x46, RespProxyAuthenticationRequired = 0x47,
RespRequestTimeOut = 0x48, RespConflict = 0x49, RespGone = 0x4A, RespLengthRequired = 0x4B,
RespPreconditionFailed = 0x4C, RespRequestedEntityTooLarge = 0x4D, RespRequestUrlTooLarge = 0x4E, RespRequestUnsupportedMediaType = 0x4F,
RespInternalServerError = 0x50, RespNotImplemented = 0x51, RespBadGateWay = 0x52, RespServiceUnavailable = 0x53,
RespGatewayTimeOut = 0x54, RespHttpVersionNotSupported = 0x55, RespDatabaseFull = 0x60, RespDatabaseLocked = 0x61
}
OBEX response codes as specified in the OBEX specification, 3.2.1. More...
enum | SetPathFlags { SetpBackup = 0x01, SetpDontCreate = 0x02 }
Flags for SETPATH shall be composed by or-ing these values. More...

Public Member Functions

void | CommitBuffer (ObexBuffer &source_buffer)
Transfers ownership of the ObexBuffer to the ObexObject.
UINT32 | GetDataFractionSize () const
Returns the size of the BODY data chunk contained in the object.
ObexHeaderList & | GetHeaderList () const
Provides access to the internal list of OBEX headers.
UINT8 | GetRequestFlags () const
Returns the flags for an OBEX request.
ResponseCode | GetResponseCode () const
Returns the response code of the operation in which the ObexObject was received.
ObexResult | Init (ResponseCode response_code, ObexBuffer &source_buffer)
Initializes an ObexObject producing a valid object.
ObexResult | Init (ObexBuffer &source_buffer)
Initializes an ObexObject producing a valid request object.
ObexResult | Init (ResponseCode response_code=Request)
Initializes an ObexObject producing a valid object.
BOOLEAN | IsEndOfData () const
Tells whether this is the last object containg data for the current OBEX operation.
BOOLEAN | IsSuccessResponse () const
Tells whether the object represents a SUCCESS response.
BOOLEAN | IsValid () const
Tells whether the object may be accessed.
BOOLEAN | IsWritable () const
Tells whether the object may be modified.
ObexObject (ObexObject const &from)
Copy constructor.
ObexObject ()
Default constructor. Constructs an invalid ObexObject.
BOOLEAN | ObtainBuffer (ObexBuffer &target_buffer)
Obtains ownership of the buffer from the OBEX object.
ObexObject & | operator= (ObexObject const &rhs)
Assignment operator.
void | Release ()
Releases the reference to the internal body data.
void | SetEndOfData (BOOLEAN end_of_data=TRUE)
Sets the flag indicating end-of-data.
void | SetRequestFlags (UINT8 req_flags)
Sets the flags for an OBEX request.
void | SetResponseCode (ResponseCode r)
Sets the response code of an obex operation.
~ObexObject ()
Destructor.

Detailed Description

Handle class which provides access to OBEX protocol data.

ObexObject instances provide shared access to OBEX protocol data stored within an internal ObexObjectData instance, which is managed employing shared reference-counting. Therefore assignment and copy-construction of ObexObject instances are cheap operations as only the handle is copied. These operations are also protected by an internal semaphore permitting to share object instances among multiple execution contexts. A special policy permits modification of an object only when it is not shared. Memory management is entirely performed by the handle class ObexObject, which provides Init() methods for creating virgin, unshared instances as well as a Release() method for invalidating the handle.

Member Enumeration Documentation

enum ObexObject::ConnectFlags

Flags for CONNECT shall be composed by or-ing these values.

Enumerator:
ConnMultipleIrlmpLsapSel

enum ObexObject::ResponseCode

OBEX response codes as specified in the OBEX specification, 3.2.1.

Enumerator:
Request
RespOk RespOk represents both SUCCESS and CONTINUE.
RespMultipleChoices
RespMovedPermanently
RespMovedTemporarily
RespSeeOther
RespNotModified
RespUseProxy
RespBadRequest
RespUnauthorized
RespPaymentRequired
RespForbidden
RespNotFound
RespMethodNotAllowed
RespNotAcceptable
RespProxyAuthenticationRequired
RespRequestTimeOut
RespConflict
RespGone
RespLengthRequired
RespPreconditionFailed
RespRequestedEntityTooLarge
RespRequestUrlTooLarge
RespRequestUnsupportedMediaType
RespInternalServerError
RespNotImplemented
RespBadGateWay
RespServiceUnavailable
RespGatewayTimeOut
RespHttpVersionNotSupported
RespDatabaseFull
RespDatabaseLocked

enum ObexObject::SetPathFlags

Flags for SETPATH shall be composed by or-ing these values.

Enumerator:
SetpBackup | Navigate directory tree towards the root.
SetpDontCreate | Do not create non-existing directories.

Constructor & Destructor Documentation

ObexObject::ObexObject ( )

Default constructor. Constructs an invalid ObexObject.

Init() must be called on the resulting object in order to make it valid. !

See also:
Init()

IsValid()

ObexObject::ObexObject ( ObexObject const & from )

Copy constructor.

Parameters:
from When 'from' refers to a valid ObexObject then the new object will becomes valid to and the reference count of the object is incremented, therefore the new object becomes a shared object, otherwise the newly created ObexObject becomes invalid, too.

ObexObject::~ObexObject ( )

Destructor.

Releases the ObexObjectData the current instance refers to, and destroys the current instance then.

Member Function Documentation

void ObexObject::CommitBuffer ( ObexBuffer & source_buffer )

Transfers ownership of the ObexBuffer to the ObexObject.

This takes the buffer ownership away from the source buffer !

Parameters:
source_buffer Valid ObexBuffer

UINT32 ObexObject::GetDataFractionSize ( ) const

Returns the size of the BODY data chunk contained in the object.

When the object instance is invalid or does not contain an ObexBuffer, '0' is returned. This method is mainly provided to support progress reporting which does not require direct access to the ObexBuffer.

ObexHeaderList & ObexObject::GetHeaderList ( ) const

Provides access to the internal list of OBEX headers.

UINT8 ObexObject::GetRequestFlags ( ) const

Returns the flags for an OBEX request.

Only used with CONNECT and SETPATH requests.

ObexObject::ResponseCode ObexObject::GetResponseCode ( ) const

Returns the response code of the operation in which the ObexObject was received.

ObexResult ObexObject::Init | ( | ResponseCode | response_code,
 |  | ObexBuffer & | source_buffer
 | ) |

Initializes an ObexObject producing a valid object.

If the object is the only referrer of the internally managed data, it is reinitialized. This is cheaper than overwriting it with a freshly created one because a dynamic memory allocation is saved. If multiple or no referrers exist, a new ObexObjectData object is allocated. After a successful call to Init(), the freshly initialized object is referenced only once and therefore writable.

Parameters:
response_code | OBEX response code or RespOk.
source_buffer | ObexBuffer to construct ObexObject instance from, this will take ownership of the data buffer and render 'source_buffer' invalid.

ObexResult ObexObject::Init ( ResponseCode response_code = Request )

Initializes an ObexObject producing a valid object.

If the object is the only referrer of the internally managed data, it is reinitialized. This is cheaper than overwriting it with a freshly created one because a dynamic memory allocation is saved. If multiple or no referrers exist, a new ObexObjectData object is allocated. After a successful call to Init(), the freshly initialized object is referenced only once and therefore writable.

Parameters:
response_code OBEX response code or RespOk when a request object is to be constructed, 'Request' otherwise (default).
Returns:
ObexResult which evaluates to 'TRUE' in case of successful initialization, 'FALSE' otherwise.

BOOLEAN ObexObject::IsEndOfData ( ) const

Tells whether this is the last object containg data for the current OBEX operation.

BOOLEAN ObexObject::IsWritable ( ) const

Tells whether the object may be modified.

When this method returns 'FALSE', the object is shared and neither the object itself nor its header list may be modified. The only exception is ObtainBuffer(), which may be called also on a shared object.

BOOLEAN ObexObject::ObtainBuffer ( ObexBuffer & target_buffer )

Obtains ownership of the buffer from the OBEX object.

This takes the buffer ownership away from the OBEX object !

Parameters:
target_buffer ObexBuffer to be assigned the buffer from the OBEX object.
Returns:
'TRUE' if ownership of a valid buffer was acquired, 'FALSE' otherwise. Equivalent to checking IsValid() on the target_buffer after the calling the method.

ObexObject & ObexObject::operator= ( ObexObject const & rhs )

Assignment operator.

When the current instance is valid, the managed ObexObjectData instance is released first. Then the current instance becomes a referrer of the object denoted by 'rhs'. If 'rhs' is an invalid ObexObject, the current instance becomes invalid, too.

void ObexObject::Release ( )

Releases the reference to the internal body data.

This method will release the internally managed data and make the ObexObject become a 'virgin' handle again, just as if it had been constructed by the default constructor. You will loose access to all information previously store within the ObexObject. If no other referrers exist, the managed ObexObjectData instance is deleted, too.

void ObexObject::SetEndOfData ( BOOLEAN end_of_data = TRUE )

Sets the flag indicating end-of-data.

Caution: The object must be writable, otherwise this method will trigger an assertion. When in doubt, check IsWritable() first.

Depending on the context end-of-data can denote both a FINAL request (GET request) and indictate an END-OF-BODY header.

See also:
IsEndOfData()

void ObexObject::SetRequestFlags ( UINT8 req_flags )

Sets the flags for an OBEX request.

Only used with CONNECT and SETPATH requests.

Caution: The object must be writable, otherwise this method will trigger an assertion. When in doubt, check IsWritable() first.

void ObexObject::SetResponseCode ( ResponseCode r )

Sets the response code of an obex operation.

Caution: The object must be writable, otherwise this method will trigger an assertion. When in doubt, check IsWritable() first.

Parameters:
r OBEX response code.

The documentation for this class was generated from the following files:
  • Obex/ObexObject.hpp
  • Obex/ObexObject.cpp
Generated on Wed Jan 25 01:33:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexObjectData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexObjectData Class Reference
[OBEX]

Internal body class for OBEX objects. More...

#include <Apoxi/Obex/ObexObjectData.hpp>

Inheritance diagram for ObexObjectData:

[legend]
Collaboration diagram for ObexObjectData:

[legend]

Public Types

typedef ReferableObject | Base

Friends

class | ObexObject

Data Structures

class | LockObtainer
Can Contain a SemObtainer or MutexObtainer.

Detailed Description

Internal body class for OBEX objects.

Warning;
This is an internal implementation class which must not be used outside APOXI OBEX at all.

The class extends the interface ReferableObject to implement reference-counted shared access to its instances which are managed exclusively by class ObexObject. Manipulations of the reference counter are protected by means of a semaphore, making ObexObjectData instances suitable for data exchange among different execution contexts such as APOXI applications and stack processes.

Member Typedef Documentation

typedef ReferableObject ObexObjectData::Base

Friends And Related Function Documentation

friend class ObexObject [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexObjectData.hpp
  • Obex/ObexObject.cpp
Generated on Wed Jan 25 01:33:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexOperationId Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexOperationId Class Reference
[OBEX]

Internal association class for requests and responses related to an operation. More...

#include <Apoxi/Obex/ObexOperationId.hpp>

Public Member Functions

UINT16 | GetSeqNr () const
Returns the sequence number of the operation.
void | Invalidate ()
Marks the ObexOperationId as invalid.
BOOLEAN | IsValid () const
Tells whether the Operation Id is valid.
ObexOperationId (const ObexOperationId &from)
Copy constructor.
ObexOperationId ()
Default constructor. Constructs an invalid ObexOperationId.
ObexOperationId & | operator= (const ObexOperationId &from)
Assignment operator.

Static Public Member Functions

static ObexOperationId | Create ()
Returns a valid, hopefully unique ObexOperationId.

Friends

BOOLEAN | operator!= (const ObexOperationId &lhs, const ObexOperationId &rhs)
Comparison for inequality.
BOOLEAN | operator== (const ObexOperationId &lhs, const ObexOperationId &rhs)
Comparison for equality.

Detailed Description

Internal association class for requests and responses related to an operation.

Warning;
This is an internal interface and must not be used outside APOXI at all. However, developers of Transport Adapters for APOXI OBEX will need to understand the concepts explained in the following paragraphs.

ObexOperationId instances serve as associations used by the OBEX API classes and Transport Adapters to associate requests and responses with an OBEX operation. Transport operations (opening and closing a transport connection) are also handled like OBEX operations since they follow the same asynchronous request-response pattern.

Concept:
The initiator of an operation (Transport Adapter for server operations, application interface for client operations) allocates a new ObexOperationId by calling the named constructor Create() and stores it in a member variable. It is then used as parameter to all calls made to ObexProtocol and ObexLayer or further derived classes. An ObexOperationId represents the OBEX operation which can be exclusively pending on one transport connection represented by ObexChannel. At the end of each client- or server operation, ObexProtocol::OnComplete() is called passing the ObexOperationId as a parameter for the last time. After completion of an operation the Transport Adapter should immediatly invalidate the stored ObexOperationId by calling Invalidate() on it. When the application interface receives the ObexMsg indicating the operation result, it should clean up any state information related to the operation. This includes invalidating the stored ObexOperationId.

Friends And Related Function Documentation

BOOLEAN operator!= | ( | const ObexOperationId & | lhs,
 |  | const ObexOperationId & | rhs
 | ) | [friend]

Comparison for inequality.

BOOLEAN operator== | ( | const ObexOperationId & | lhs,
 |  | const ObexOperationId & | rhs
 | ) | [friend]

Comparison for equality.

The documentation for this class was generated from the following files:
  • Obex/ObexOperationId.hpp
  • Obex/ObexOperationId.cpp
Generated on Wed Jan 25 01:33:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexOppBinDataPushClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexOppBinDataPushClient Class Reference
[OBEX]

Reads data from a BinData instance and pushes it towards a remote OPP server. More...

#include <Apoxi/Obex/ObexOppBinDataPushClient.hpp>

Inheritance diagram for ObexOppBinDataPushClient:

[legend]
Collaboration diagram for ObexOppBinDataPushClient:

[legend]

Public Types

enum | { DefFragSize = 4096 }
Application data fragment size. More...

Public Member Functions

ObexResult | Abort (const WString &desc, BOOLEAN force_sync=FALSE)
Aborts a pending PUSH or PULL operation.
ObexOppBinDataPushClient (ExecutionContext *ctx_ptr)
Constructor. Constructs a usable object instance.
ObexOppBinDataPushClient ()
Default constructor.
ObexResult | Push (const String &obex_url, BinData *obj_src_ptr, MimeType obj_type, const WString &obj_name, const WString &obj_desc=L"")
Initiates pushing an object towards a remote OPP server.
virtual | ~ObexOppBinDataPushClient ()
Destructor. Destroys an ObexOppBinDataPushClient object.

Protected Member Functions

virtual void | OnPushComplete (ObexResult result, ObexObject::ResponseCode resp_code, const WString &push_desc)
Indicates completion of a PUSH operation.

Detailed Description

Reads data from a BinData instance and pushes it towards a remote OPP server.

This class offers a simplified asynchronous interface to applications which need to act as an OBEX OPP (Object Push Profile) client.

Concept:
Users must subclass ObexOppBinDataPushClient and implement the abstract method OnPushComplete() to get notified when an ongoing operation is completed. An object PUSH operation is initiated by calling Push() and submitting an instance of an class derived from the BinData interface class. Data is then automatically read from the user-supplied BinData object and transmitted to the remote OPP server chunk by chunk. While the procedure is running, the ObexOppBinDataPushClient instance is busy and will not accept another call to Push(). An ongoing operation may be cancelled by calling Abort().

In any case, OnPushComplete() is called at the end of the asynchronous procedure and indicates either success (good ObexResult) or failure. When the operation was rejected or cancelled by the remote server, the remote server's OBEX response code and optional DESCRIPTION header are also available to the user. After OnPushComplete() has been invoked, the ObexOppBinDataPushClient instance is ready for the next PUSH operation.

Since ObexOppBinDataPushClient is derived from ObexOppClient, multiple instances share a single OPP protocol implementation for all transports. When Push() is called on a ObexOppBinDataPushClient instance while another one is already active, the PUSH operation is queued until the protocol implementation becomes available again, then automatically resumed. Each ObexOppBinDataPushClient can hold exactly one PUSH request.

Member Enumeration Documentation

anonymous enum

Application data fragment size.

Data is transferred between application layer and Transport Adapter using an internal buffer, whose size affects performance. When this value is chosen to low, message load will increase, forcing the protocol stack to wait for the application layer most of the time. When chosen too high, individual operations might last too long, especially copying of memory blocks which will decrease system responsiveness and also require more memory for buffering.

Enumerator:
DefFragSize Default fragment size.

Constructor & Destructor Documentation

ObexOppBinDataPushClient::ObexOppBinDataPushClient ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexOppBinDataPushClient::ObexOppBinDataPushClient ( ExecutionContext * ctx_ptr )

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new). Hint: Avoid using new() - if you can, allocate instances statically.

Parameters:
ctx_ptr Execution context to be used by the client, for example an application pointer. You may pass '0' as actual parameter to specify the currently active context, which must be valid at the time Init() is called.

ObexOppBinDataPushClient::~ObexOppBinDataPushClient ( ) [virtual]

Destructor. Destroys an ObexOppBinDataPushClient object.

Member Function Documentation

ObexResult ObexOppBinDataPushClient::Abort | ( | const WString & | desc,
 |  | BOOLEAN | force_sync = FALSE
 | ) |

Aborts a pending PUSH or PULL operation.

After the pending operation has been aborted, OnPushComplete() is invoked with an ObexResult indication that the operation was aborted. A different behaviour can be achieved by setting 'force_sync' to 'TRUE', this will terminate any pending operation synchronously from the API point of view. This behaviour might be useful when sudden application shutdown must be dealt with.

Parameters:
desc | Textual description of the abort cause.
force_sync | Force synchronous ABORT, this means that on return from the call any BinData instance is no longer referenced and can be destroyed and OnPushComplete() will NOT be invoked.

Reimplemented from ObexOppClient.

void ObexOppBinDataPushClient::OnPushComplete | ( | ObexResult | result,
 |  | ObexObject::ResponseCode | resp_code,
 |  | const WString & | push_desc
 | ) | [protected, virtual]

Indicates completion of a PUSH operation.

Completion of an operation does not necessarily mean success. Check the result parameter to find out whether an operation terminated successfully or not.

Caution:
Don't forget to call the base classes' implementation of this method from your overridden one. This should be the first statement of your implementation.

Example:

            class MyObexOppBinDataPushClient : public ObexOppBinDataPushClient {
                public:
                    // Your stuff ...

                protected:
                    virtual void OnPushComplete(ObexResult                  result,
                                                ObexObject::ResponseCode    resp_code,
                                                const WString &             push_desc);
                private:
                    typedef ObexOppBinDataPushClient    Base;
                    // Your stuff ...
            };

            void MyObexOppBinDataPushClient::OnPushComplete(ObexResult                  result,
                                                            ObexObject::ResponseCode    resp_code,
                                                            const WString &             push_desc)
            {
                // Notify base-class implementation
                Base::OnPushComplete(result, resp_code, push_desc);

                // Your stuff - notify application etc.
            }

Parameters:
result | Either indicates success or carries an error code (for example, 'OperationAborted').
resp_code | Contains the OBEX response code returned by the remote server. Particularly interesting when result equals 'ObexError' ...
push_desc | Contains the description if one was returned by the remote server.

Reimplemented from ObexOppClient.

ObexResult ObexOppBinDataPushClient::Push | ( | const String & | obex_url,
 |  | BinData * | obj_src_ptr,
 |  | MimeType | obj_type,
 |  | const WString & | obj_name,
 |  | const WString & | obj_desc = L""
 | ) |

Initiates pushing an object towards a remote OPP server.

Parameters:
obex_url | URL of the OBEX transport to use.
obj_src_ptr | Pointer to an instance of a class derived from APOXI BinData.
obj_type | Mime type of the object to be transferred. Will be encoded as an OBEX TYPE header. Must be known by MimeTypeTable class !
obj_name | Name of the OBEX object name to be transferred. Will be encoded as an OBEX NAME header.
obj_desc | Description of the object to be transferred. When provided, it will be encoded as an OBEX DESCRIPTION header.
Returns:
ObexResult which evaluates to 'TRUE' when the operation has been started, 'FALSE' otherwise.

The documentation for this class was generated from the following files:
  • Obex/ObexOppBinDataPushClient.hpp
  • Obex/ObexOppBinDataPushClient.cpp
Generated on Wed Jan 25 01:33:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexOppClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexOppClient Class Reference
[OBEX]

Base class for OPP clients within applications. More...

#include <Apoxi/Obex/ObexOppClient.hpp>

Inheritance diagram for ObexOppClient:

[legend]
Collaboration diagram for ObexOppClient:

[legend]

Public Member Functions

ObexResult | Abort (const WString &desc, BOOLEAN force_sync=FALSE)
Aborts a pending PUSH or PULL operation.
ObexResult Close ()
Release a logical connection to a remote server.
ObexResult | DataProcessed (ObexBuffer &app_data)
Acknowledges processing of a received PULL data buffer.
UINT32 | GetProgressInBytes () const
Returns the cumulative progress in transferring data.
virtual void | Init (Application *app_ptr)
Initializes a default-constructed object.
ObexOppClient (Application *app_ptr)
Constructor. Constructs a usable object instance.
ObexOppClient ()
Default constructor.
ObexResult | Open (const String &obex_url)
Establish a logical connection to a remote server.
ObexResult | ProvideData (ObexBuffer &app_data, BOOLEAN end_data=FALSE)
Submit data to be transferred within a PUSH operation.
ObexResult | Pull (const String &obex_url, MimeType obj_type=c_mime_unknown, const WString &obj_name=L"")
Starts pulling an object from a remote OPP server.
ObexResult | Push (const String &obex_url, const WString &obj_name, MimeType obj_type, const WString &obj_desc, UINT32 obj_size)
Starts pushing an object towards a remote OPP server.
virtual | ~ObexOppClient ()
Destructor. Destroys an ObexClient object.

Protected Member Functions

virtual void | OnDataAvailable (ObexBuffer &app_data, BOOLEAN end_data)
Delivers the next chunk of data to the application.
virtual void | OnDataProcessed (ObexBuffer &app_data)
Confirms data transmission by APOXI OBEX.
virtual void | OnPullComplete (ObexResult result, ObexObject::ResponseCode resp_code, const WString &pull_desc)
Indicates completion of a PULL operation.
virtual void | OnPullConfirmed (const WString &obj_name, const WString &obj_desc, UINT32 obj_size)
Confirms PULL and tells about the object being pulled.
virtual void | OnPushComplete (ObexResult result, ObexObject::ResponseCode resp_code, const WString &push_desc)
Indicates completion of a PUSH operation.
virtual void | OnPushConfirmed ()
Confirms that the remote server has accepted a PUSH.

Friends

class | ObexClientOppImpl
class | ObexOppClientPull
class | ObexOppClientPush
class | OppDispatcher

Data Structures

class | OppDispatcher
Internal dispatcher for OBEX messages related to OPP.

Detailed Description

Base class for OPP clients within applications.

The present class offers an interface to run OPP (Object Push Pull) over OBEX. All instances of this interface share the common internal implementation class ObexClientOppImpl which contains the protocol automaton. Multiple instances of this interface can be used simultaneously by the application layer, but operations will be queued and processed in a serial manner since the implementation supports only one OBEX connection.

When only a PUSH service is required, it is much more comfortable to use the front-end class ObexOppBinDataPushClient as this will spare application SW the tedious job of data buffer management and segmentation.

Constructor & Destructor Documentation

ObexOppClient::ObexOppClient ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexOppClient::ObexOppClient ( Application * app_ptr )

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
app_ptr Application pointer of the application which provides the context for the client.

ObexOppClient::~ObexOppClient ( ) [virtual]

Destructor. Destroys an ObexClient object.

Member Function Documentation

ObexResult ObexOppClient::Abort | ( | const WString & | desc,
 |  | BOOLEAN | force_sync = FALSE
 | ) |

Aborts a pending PUSH or PULL operation.

After the pending operation has been aborted, either OnPullComplete() or OnPushComplete() are invoked with an ObexResult indication that the operation was aborted. A different behaviour can be achieved by setting 'force_sync' to 'TRUE', this will terminate any pending operation synchronously from the API point of view. This behaviour might be useful when sudden application shutdown must be dealt with.

Parameters:
desc | Textual description of the abort cause.
force_sync | Force synchronous ABORT, this means that on return from the call any BinData instance is no longer referenced and can be destroyed and OnPushComplete() will NOT be invoked.

Reimplemented in ObexOppBinDataPushClient.

ObexResult ObexOppClient::Close ( )

Release a logical connection to a remote server.

ObexResult ObexOppClient::DataProcessed ( ObexBuffer & app_data )

Acknowledges processing of a received PULL data buffer.

Parameters:
app_data ObexBuffer which was passed by OnDataAvailable(). This call invalidates the buffer which must not be accessed by the application afterwards.

UINT32 ObexOppClient::GetProgressInBytes ( ) const

Returns the cumulative progress in transferring data.

This method returns the amount of data already transferred for a pending PUSH (outbound data) or PULL (inbound data) operation. The final value is preserved even beyond completion of that operation, hence it is reset to '0' when a new operation is initiated.

void ObexOppClient::Init ( Application * app_ptr ) [virtual]

Initializes a default-constructed object.

Parameters:
app_ptr Application pointer of the application which provides the context for the client. You may pass '0' as actual parameter to specify the currently active application.

void ObexOppClient::OnDataAvailable | ( | ObexBuffer & | app_data,
 |  | BOOLEAN | end_data
 | ) | [protected, virtual]

Delivers the next chunk of data to the application.

Invoked within a PULL operation to indicate that another chunk of data is available for the application. After processing, the app must call DataProcessed() on the buffer.

Parameters:
app_data | Buffer which holds the data pulled from the remote server.
end_data | Tells wether this is the last chunk of data delivered by the remote server. Useful in case the object size is initially unknown.

void ObexOppClient::OnDataProcessed ( ObexBuffer & app_data ) [protected, virtual]

Confirms data transmission by APOXI OBEX.

Returns ownership of the buffer back to the application.

Parameters:
app_data ObexBuffer which was passed to APOXI OBEX via invoking Push() or ProvideData().

void ObexOppClient::OnPullComplete | ( | ObexResult | result,
 |  | ObexObject::ResponseCode | resp_code,
 |  | const WString & | pull_desc
 | ) | [protected, virtual]

Indicates completion of a PULL operation.

Parameters:
result | Either indicates success or carries an error code, for example loss of the transport connection.
resp_code | Contains the OBEX response code returned by the remote server.
pull_desc | Contains a textual description if one was returned by the remote server.

void ObexOppClient::OnPullConfirmed | ( | const WString & | obj_name,
 |  | const WString & | obj_desc,
 |  | UINT32 | obj_size
 | ) | [protected, virtual]

Confirms PULL and tells about the object being pulled.

The remote server has begun to process a PULL operation and is now delivering data.

Parameters:
obj_name | OBEX object name.
obj_desc | Description of the object to be pushed.
obj_size | Total size of the whole object to be pushed. '0' indicates that the total object size is unknown.

void ObexOppClient::OnPushComplete | ( | ObexResult | result,
 |  | ObexObject::ResponseCode | resp_code,
 |  | const WString & | push_desc
 | ) | [protected, virtual]

Indicates completion of a PUSH operation.

Parameters:
result | Either indicates success or carries an error code.
resp_code | Contains the OBEX response code returned by the remote server.
push_desc | Contains the description if one was returned by the remote server.

Reimplemented in ObexOppBinDataPushClient.

void ObexOppClient::OnPushConfirmed ( ) [protected, virtual]

Confirms that the remote server has accepted a PUSH.

The remote server has begun to process a PUSH operation and is now waiting for data.

ObexResult ObexOppClient::Open ( const String & obex_url )

Establish a logical connection to a remote server.

When more than one object is going to be pushed to or pulled from the same device open should be called specifying the URL of the remote service. Multiple consecutive push and/or pull operations can then be initiated without having to select a transport and device for each of the objects. After successful completion of the last operation please don't forget to call Close().

Parameters:
obex_url URL of the OBEX transport to use.

ObexResult ObexOppClient::ProvideData | ( | ObexBuffer & | app_data,
 |  | BOOLEAN | end_data = FALSE
 | ) |

Submit data to be transferred within a PUSH operation.

Parameters:
app_data | Buffer which holds the data to be pushed.
end_data | Indicates that this is the last data chunk to be pushed within this operation. Only required when 'obj_size' was set to '0' in the first call to Push().

ObexResult ObexOppClient::Pull | ( | const String & | obex_url,
 |  | MimeType | obj_type = c_mime_unknown,
 |  | const WString & | obj_name = L""
 | ) |

Starts pulling an object from a remote OPP server.

Parameters:
obex_url | URL of the OBEX transport to use.
obj_type | Mime type of the object to be pulled.
obj_name | OBEX object name of the object to be pulled.

ObexResult ObexOppClient::Push | ( | const String & | obex_url,
 |  | const WString & | obj_name,
 |  | MimeType | obj_type,
 |  | const WString & | obj_desc,
 |  | UINT32 | obj_size
 | ) |

Starts pushing an object towards a remote OPP server.

Parameters:
obex_url | URL of the OBEX transport to use.
obj_name | OBEX object name.
obj_type | Mime type of the object to be pushed.
obj_desc | Description of the object to be pushed.
obj_size | Total size of the whole object to be pushed. When the size is unknown, it should be set to '0'.

Friends And Related Function Documentation

friend class ObexClientOppImpl [friend]

friend class ObexOppClientPull [friend]

friend class ObexOppClientPush [friend]

friend class OppDispatcher [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexOppClient.hpp
  • Obex/ObexOppClient.cpp
Generated on Wed Jan 25 01:33:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexOppClientOperation Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexOppClientOperation Class Reference
[OBEX]

Internal abstraction of an OPP client operation. More...

#include <Apoxi/Obex/ObexClientOppImpl.hpp>

Inheritance diagram for ObexOppClientOperation:

[legend]

Public Member Functions

virtual ObexResult | Initiate (const ObexObject &request) const =0
Initiates the operation and indicates whether it was started.
ObexOppClientOperation ()
Constructor.
virtual void | OnFailure (ObexOppClient &client, const ObexResult &result) const =0
Asynchronously indicates failure of an operation.
virtual | ~ObexOppClientOperation ()
Destructor.

Detailed Description

Internal abstraction of an OPP client operation.

Warning;
This is an internal interface and must not be used outside APOXI OBEX at all.

Its purpose is to provide an abstraction of an OPP command (PUSH /PULL) to permit queuing and deferred execution of OPP operations when the OBEX client implementing the OPP profile is temporarily busy with another operation.

Constructor & Destructor Documentation

ObexOppClientOperation::ObexOppClientOperation ( )

Constructor.

ObexOppClientOperation::~ObexOppClientOperation ( ) [virtual]

Destructor.

Member Function Documentation

virtual ObexResult ObexOppClientOperation::Initiate ( const ObexObject & request ) const [pure virtual]

Initiates the operation and indicates whether it was started.

Implemented in ObexOppClientPush, and ObexOppClientPull.

virtual void ObexOppClientOperation::OnFailure | ( | ObexOppClient & | client,
 |  | const ObexResult & | result
 | ) | const [pure virtual]

Asynchronously indicates failure of an operation.

Implemented in ObexOppClientPush, and ObexOppClientPull.

The documentation for this class was generated from the following files:
  • Obex/ObexClientOppImpl.hpp
  • Obex/ObexClientOppImpl.cpp
Generated on Wed Jan 25 01:33:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexOppClientPull Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexOppClientPull Class Reference
[OBEX]

Internal implementation of an OPP PULL operation.. More...

#include <Apoxi/Obex/ObexClientOppImpl.hpp>

Inheritance diagram for ObexOppClientPull:

[legend]
Collaboration diagram for ObexOppClientPull:

[legend]

Public Member Functions

virtual ObexResult | Initiate (const ObexObject &request) const
Initiates the operation and indicates whether it was started.
virtual void | OnFailure (ObexOppClient &client, const ObexResult &result) const
Asynchronously indicates failure of an operation.

Static Public Member Functions

static ObexOppClientOperation & | GetInstance ()

Detailed Description

Internal implementation of an OPP PULL operation..

Warning;
This is an internal implementation class which must not be used outside APOXI OBEX at all.

Member Function Documentation

static ObexOppClientOperation& ObexOppClientPull::GetInstance ( ) [inline, static]

ObexResult ObexOppClientPull::Initiate ( const ObexObject & request ) const [virtual]

Initiates the operation and indicates whether it was started.

Implements ObexOppClientOperation.

void ObexOppClientPull::OnFailure | ( | ObexOppClient & | client,
 |  | const ObexResult & | result
 | ) | const [virtual]

Asynchronously indicates failure of an operation.

Implements ObexOppClientOperation.

The documentation for this class was generated from the following files:
  • Obex/ObexClientOppImpl.hpp
  • Obex/ObexClientOppImpl.cpp
Generated on Wed Jan 25 01:33:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexOppClientPush Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexOppClientPush Class Reference
[OBEX]

Internal implementation of an OPP PUSH operation.. More...

#include <Apoxi/Obex/ObexClientOppImpl.hpp>

Inheritance diagram for ObexOppClientPush:

[legend]
Collaboration diagram for ObexOppClientPush:

[legend]

Public Member Functions

virtual ObexResult | Initiate (const ObexObject &request) const
Initiates the operation and indicates whether it was started.
virtual void | OnFailure (ObexOppClient &client, const ObexResult &result) const
Asynchronously indicates failure of an operation.

Static Public Member Functions

static ObexOppClientOperation & | GetInstance ()

Detailed Description

Internal implementation of an OPP PUSH operation..

Warning;
This is an internal implementation class which must not be used outside APOXI OBEX at all.

Member Function Documentation

static ObexOppClientOperation& ObexOppClientPush::GetInstance ( ) [inline, static]

ObexResult ObexOppClientPush::Initiate ( const ObexObject & request ) const [virtual]

Initiates the operation and indicates whether it was started.

Implements ObexOppClientOperation.

void ObexOppClientPush::OnFailure | ( | ObexOppClient & | client,
 |  | const ObexResult & | result
 | ) | const [virtual]

Asynchronously indicates failure of an operation.

Implements ObexOppClientOperation.

The documentation for this class was generated from the following files:
  • Obex/ObexClientOppImpl.hpp
  • Obex/ObexClientOppImpl.cpp
Generated on Wed Jan 25 01:33:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexOppDataSinkPushServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexOppDataSinkPushServer Class Reference
[OBEX]

Receives data pushed in by a remote OPP client and saves it to a to a DataSink instance. More...

#include <Apoxi/Obex/ObexOppDataSinkPushServer.hpp>

Inheritance diagram for ObexOppDataSinkPushServer:

[legend]
Collaboration diagram for ObexOppDataSinkPushServer:

[legend]

Public Member Functions

ObexResult | Accept (DataSink *obj_sink_ptr, UINT32 max_obj_size=0xFFFFFFFFul)
Accepts an incoming PUSH operation.
ObexResult | BindToMimeType (MimeType mime_type)
Binds the server to an additional mime type.
ObexResult | Cancel (ObexObject::ResponseCode resp_code, const WString &resp_desc=L"")
Rejects an incoming PUSH operation or cancels an already ongoing one.
ObexResult Close ()
Closes the OPP server. Closes the OPP server to client requests.
ObexResult Confirm ()
Confirms that the client operation has been successfully performed.
UINT32 | GetProgressInBytes () const
Returns the cumulative progress in transferring data.
virtual void | Init (ExecutionContext *ctx_ptr, MimeType mime_type)
Initializes a default-constructed object.
ObexOppDataSinkPushServer (MimeType mime_type, ExecutionContext *ctx_ptr)
Constructor. Constructs a usable object instance.
ObexOppDataSinkPushServer ()
Default constructor.
virtual void | OnDataComplete ()
Indicates that a complete OBEX object BODY has been received.
virtual void | OnPushComplete (ObexResult result, const WString &description)=0
Indicates completion of a PUSH operation.
virtual void | OnPushIncoming (const WString &obj_name, MimeType obj_type, const WString &obj_desc, UINT32 obj_size)=0
Indicates an incoming push operation.
ObexResult Open ()
Opens the OPP server for client requests.
ObexResult | UnbindMimeType (MimeType mime_type)
Unbinds the server from a mime type.
virtual | ~ObexOppDataSinkPushServer ()
Destructor. Destroys an ObexOppDataSinkPushServer object.

Data Structures

class | OppImpl

Detailed Description

Receives data pushed in by a remote OPP client and saves it to a to a DataSink instance.

This class offers a simplified asynchronous interface to applications who need to act as an OBEX OPP (Object Push Pull) server.

Users must subclass ObexOppDataSinkPushServer and implement at least the abstract methods OnPushIncoming() and OnPushComplete().

OnPushIncoming() is called to indicate when an object PUSH operation is initiated by a remote client. A server can then either accept the operation by calling Accept() and submitting an instance of an class derived from the DataSink interface class, or reject it by calling Cancel().

When Accept() is called the incoming operation becomes the currently ongoing operation and data will be automatically received chunk by chunk and written to the user-supplied DataSink object until either the whole object has been received or the maximum object size has been exceeded. When an object has been entirely received OnDataComplete() is invoked. This method may be overridden to intercept the operation just before the last response is sent towards the client. Calling Cancel() will cancel the operation, telling the remote client that the operation was rejected by the server, whereas calling Confirm() informs the client that the operation terminated successfully.

When a request was accepted by the server OnPushComplete() is called at the end of the operation and indicates either success (good ObexResult, evaluates to 'TRUE') or failure. When the operation was aborted by the remote client, the client's optional DESCRIPTION header is also available to the user.

After OnPushComplete() has been invoked, the ObexOppDataSinkPushServer instance is ready to handle the next incoming PUSH operation.

Constructor & Destructor Documentation

ObexOppDataSinkPushServer::ObexOppDataSinkPushServer ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexOppDataSinkPushServer::ObexOppDataSinkPushServer | ( | MimeType | mime_type,
 |  | ExecutionContext * | ctx_ptr
 | ) |

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
ctx_ptr | Execution context to be used by the server. All notification methods (protected: On.....()) will be called from this context. You may pass '0' as actual parameter to specify the currently active context, which must be valid at construction the time.
mime_type | Mime type of the objects the server is interested in.

ObexOppDataSinkPushServer::~ObexOppDataSinkPushServer ( ) [virtual]

Destructor. Destroys an ObexOppDataSinkPushServer object.

Member Function Documentation

void ObexOppDataSinkPushServer::Init | ( | ExecutionContext * | ctx_ptr,
 |  | MimeType | mime_type
 | ) | [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr | Execution context to be used by the server. All notification methods (protected: On.....()) will be called from this context. You may pass '0' as actual parameter to specify the currently active context, which must be valid at the time Init() is called.
mime_type | Mime type of the objects the server is interested in.

Reimplemented from ObexOppServer.

void ObexOppDataSinkPushServer::OnDataComplete ( ) [virtual]

Indicates that a complete OBEX object BODY has been received.

When this method is called all OBEX BODY data of the current PUSH operation has been received and written to the DataSink instance which was passed to Accept(). Now that the whole object is available to the server, it can be elaborated (for example, parsing a VCard) to prepare for the decision whether it should be either kept ( call Confirm() ) or discarded ( call Cancel() ).

This will cause the final response to be sent to the remote client, informing it on the server's decision and finish the operation.

The default implementation of this method calls Confirm(), so if you override the method please don't call the inherited method from your implementation !

virtual void ObexOppDataSinkPushServer::OnPushComplete | ( | ObexResult | result,
 |  | const WString & | description
 | ) | [pure virtual]

Indicates completion of a PUSH operation.

Parameters:
result | Evaluates to 'TRUE' when the operation was completed successfully, 'FALSE' otherwise.
description | In case of a client ABORT this parameter optionally contains a verbal description of the error cause.

Reimplemented from ObexOppServer.

virtual void ObexOppDataSinkPushServer::OnPushIncoming | ( | const WString & | obj_name,
 |  | MimeType | obj_type,
 |  | const WString & | obj_desc,
 |  | UINT32 | obj_size
 | ) | [pure virtual]

Indicates an incoming push operation.

After evaluation of the parameters, either call Accept() to begin the data transfer or Cancel() to reject the operation. In the latter case, no operation is started and therefore neither OnDataComplete() nor OnPushComplete() are called.

Parameters:
obj_name | Name of the object being pushed.
obj_type | MimeType of the object being pushed. This is always one of the MimeTypes the server has registered for.
obj_desc | Textual description of the object content.
obj_size | Size of the whole object as read from the OBEX LENGTH header when present. If the size equals '0', it is not yet known.

The documentation for this class was generated from the following files:
  • Obex/ObexOppDataSinkPushServer.hpp
  • Obex/ObexOppDataSinkPushServer.cpp
Generated on Wed Jan 25 01:33:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexOppServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexOppServer Class Reference
[OBEX]

Base class for OPP servers within applications. More...

#include <Apoxi/Obex/ObexOppServer.hpp>

Inheritance diagram for ObexOppServer:

[legend]
Collaboration diagram for ObexOppServer:

[legend]

Public Member Functions

ObexResult | AcceptPull (const WString &obj_name, const WString &obj_desc, UINT32 obj_size)
Accepts an incoming PULL operation.
ObexResult AcceptPush ()
Accepts an incoming PUSH operation.
ObexResult | BindToMimeType (MimeType mime_type)
Binds the server to an additional mime type.
ObexResult | CancelOperation (ObexObject::ResponseCode resp_code, const WString &resp_desc=WString())
Rejects an incoming or cancels an already ongoing PUSH or PULL operation.
ObexResult Close ()
Closes the OPP server.
ObexResult DataProcessed ()
Acknowledges processing of a received PUSH data buffer.
ObexResult | DataProcessed (ObexBuffer &app_data)
Acknowledges processing of a received PUSH data buffer.
UINT32 | GetProgressInBytes () const
Returns the cumulative progress in transferring data.
virtual void | Init (ExecutionContext *ctx_ptr, MimeType mime_type)
Initializes a default-constructed object.
BOOLEAN | IsActiveOperation (const ObexOperationId oper_id) const
Tells whether 'oper_id' is the currently active OPP operation.
BOOLEAN | IsBoundToChannel (const ObexChannel &channel) const
Tells whether the local server is listening on 'channel'.
BOOLEAN | IsBoundToMimeType (MimeType mime_type) const
Tells whether the local server has subscribed to MIME type 'mime_type'.
BOOLEAN | IsBoundToServerId (ObexServerId id) const
Tells whether the local server has been registered under 'id'.
ObexOppServer (ExecutionContext *ctx_ptr, MimeType mime_type)
Constructor. Constructs a usable object instance.
ObexOppServer ()
Default constructor.
ObexResult Open ()
Open the OPP server for client requests.
ObexResult | ProvideData (ObexBuffer &app_data, BOOLEAN end_data=FALSE)
Provides another chunk of data within a PULL operation.
ObexResult | UnbindMimeType (MimeType mime_type)
Unbinds the server from a mime type.

Protected Member Functions

virtual void | OnAbort ()
Indicates that the currently ongoing operation has been aborted.
virtual void | OnDataAvailable (ObexBuffer &app_data, BOOLEAN end_data)
Offers the next chunk of data to the application.
virtual void | OnDataProcessed (ObexBuffer &buffer)
Returns ownership of a buffer back to the application.
virtual void | OnPull (const WString &obj_name, const String &obj_type)
Indicates an incoming pull operation.
virtual void | OnPullComplete (ObexResult result, const WString &description)
Indicates completion of a PULL operation.
virtual void | OnPush (const WString &obj_name, const String &obj_type, const WString &obj_desc, UINT32 obj_size)
Indicates an incoming push operation.
virtual void | OnPushComplete (ObexResult result, const WString &description)
Indicates completion of a PUSH operation.

Friends

class | DupeChecker
class | ObexServerOppImpl

Data Structures

class | OppDispatcher
Internal dispatcher for OBEX messages related to OPP.
class | ServerInfo
ServerInfo record used to register with the Server Manager.

Detailed Description

Base class for OPP servers within applications.

The present class offers an interface to run OPP (Object Push Pull) over OBEX as a server. All instances of this interface share the common internal implementation class ObexServerOppImpl which contains the protocol automaton. Multiple instances of this interface can be used simultaneously by the application layer, but only one OPP connection at a time is supported. Hence any incoming OPP operation will be rejected when on is already being processed.

Dispatching of OPP requests is done based on the MIME type of the object to be pushed or pulled, therefore an OPP server must register at least on object type passed as a constructor or Init() method parameter. Each server can subscribe to additional MIME types by using the BindToMimeType() method, but each MIME type might be bound to only one OPP server. Therefore, if two OPP servers try to register the same MIME type, Open() will fail when called on the second server instance.

When only a PUSH service is required, it is much more comfortable to use the front-end class ObexOppDataSinkPushServer as this will spare application SW the tedious job of data buffer management and segmentation.

Constructor & Destructor Documentation

ObexOppServer::ObexOppServer ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexOppServer::ObexOppServer | ( | ExecutionContext * | ctx_ptr,
 |  | MimeType | mime_type
 | ) |

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
ctx_ptr | Pointer to an execution context in which the server should be run.
mime_type | Mime type of the objects the server is interested in.

Member Function Documentation

ObexResult ObexOppServer::AcceptPull | ( | const WString & | obj_name,
 |  | const WString & | obj_desc,
 |  | UINT32 | obj_size
 | ) |

Accepts an incoming PULL operation.

Parameters:
obj_name | OBEX object name.
obj_desc | Description of the object to be pulled.
obj_size | Total size of the whole object to be pulled. '0' indicates that the total object size is unknown.

ObexResult ObexOppServer::AcceptPush ( )

Accepts an incoming PUSH operation.

ObexResult ObexOppServer::BindToMimeType ( MimeType mime_type )

Binds the server to an additional mime type.

When the same type of processing is desired for several different mimetypes (for example, saving images to the filesystem) it is more convenient and also resource - saving to bind the same server to multiple mime types than running a seperate server instance for each mime type. This can be accomplished by calling BindToMimeType() on the server for each of the additional MIME types to be handled.

Caution: The server should be in closed state when calling this method. Each mime type may be registered by only one server.

Parameters:
mime_type MIME type identifier.
Returns:
ObexResult which evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented in ObexOppDataSinkPushServer.

ObexResult ObexOppServer::CancelOperation | ( | ObexObject::ResponseCode | resp_code,
 |  | const WString & | resp_desc = WString()
 | ) |

Rejects an incoming or cancels an already ongoing PUSH or PULL operation.

Parameters:
resp_code | OBEX response (error) code.
resp_desc | Textual description of the error (optional).

ObexResult ObexOppServer::Close ( )

Closes the OPP server.

Reimplemented in ObexOppDataSinkPushServer.

ObexResult ObexOppServer::DataProcessed ( )

Acknowledges processing of a received PUSH data buffer.

Only to be used when ObexOppServer has ownership of the buffer.

ObexResult ObexOppServer::DataProcessed ( ObexBuffer & app_data )

Acknowledges processing of a received PUSH data buffer.

This call invalidates the buffer which must not be accessed by the application afterwards.

Parameters:
app_data ObexBuffer which was passed in OnDataAvailable().

UINT32 ObexOppServer::GetProgressInBytes ( ) const

Returns the cumulative progress in transferring data.

This method returns the amount of data already transferred for a pending PUSH (inbound data) or PULL (outbound data) operation. The final value is preserved even beyond completion of that operation, hence it is reset to '0' when a new operation is accepted.

Reimplemented in ObexOppDataSinkPushServer.

void ObexOppServer::Init | ( | ExecutionContext * | ctx_ptr,
 |  | MimeType | mime_type
 | ) | [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr | Pointer to the excution context in which the client should be run. You may pass '0' as actual parameter to specify the currently active execution context.
mime_type | Mime type of the objects the server is interested in.

Reimplemented in ObexOppDataSinkPushServer.

BOOLEAN ObexOppServer::IsActiveOperation ( const ObexOperationId oper_id ) const

Tells whether 'oper_id' is the currently active OPP operation.

BOOLEAN ObexOppServer::IsBoundToChannel ( const ObexChannel & channel ) const

Tells whether the local server is listening on 'channel'.

BOOLEAN ObexOppServer::IsBoundToMimeType ( MimeType mime_type ) const

Tells whether the local server has subscribed to MIME type 'mime_type'.

BOOLEAN ObexOppServer::IsBoundToServerId ( ObexServerId id ) const [inline]

Tells whether the local server has been registered under 'id'.

void ObexOppServer::OnAbort ( ) [protected, virtual]

Indicates that the currently ongoing operation has been aborted.

void ObexOppServer::OnDataAvailable | ( | ObexBuffer & | app_data,
 |  | BOOLEAN | end_data
 | ) | [protected, virtual]

Offers the next chunk of data to the application.

The application may now access the data provided by the ObexBuffer object. After data processing has been completed, the application must call DataProcessed() on the buffer object. This invalidates the buffer and tells the client to ask for the next chunk of data.

Parameters:
app_data | Buffer which holds the data pushed by the remote client.
end_data | Tells whether this is the last chunk of data delivered by the remote client.

void ObexOppServer::OnDataProcessed ( ObexBuffer & buffer ) [protected, virtual]

Returns ownership of a buffer back to the application.

The passed data buffer had been produced by the application and may be now either recycled or disposed.

Parameters:
buffer ObexBuffer belonging to the application.

void ObexOppServer::OnPull | ( | const WString & | obj_name,
 |  | const String & | obj_type
 | ) | [protected, virtual]

Indicates an incoming pull operation.

Parameters:
obj_name | Name of the object to be pulled from the server.
obj_type | Mime string of the object to be pulled. Unless the server is not the default one, this should always match the MimeType it registered for at construction time.

void ObexOppServer::OnPullComplete | ( | ObexResult | result,
 |  | const WString & | description
 | ) | [protected, virtual]

Indicates completion of a PULL operation.

Parameters:
result | Evaluates to 'TRUE' when the operation was completed successfully, 'FALSE' otherwise.
description | In case of unsuccessful completion of an operation this parameter optionally contains a verbal description of the error cause.

void ObexOppServer::OnPush | ( | const WString & | obj_name,
 |  | const String & | obj_type,
 |  | const WString & | obj_desc,
 |  | UINT32 | obj_size
 | ) | [protected, virtual]

Indicates an incoming push operation.

Parameters:
obj_name | Name of the object being pushed.
obj_type | Mime string of the object being pushed. Unless the server is not the default one, this should always match the MimeType it registered for at construction time.
obj_desc | Textual description of the object content.
obj_size | Size of the whole object (may be larger than the size of a singe data buffer. If the size equals '0', it is not yet known.

void ObexOppServer::OnPushComplete | ( | ObexResult | result,
 |  | const WString & | description
 | ) | [protected, virtual]

Indicates completion of a PUSH operation.

Parameters:
result | Evaluates to 'TRUE' when the operation was completed successfully, 'FALSE' otherwise.
description | In case of unsuccessful completion of an operation this parameter optionally contains a verbal description of the error cause.

Reimplemented in ObexOppDataSinkPushServer.

ObexResult ObexOppServer::Open ( )

Open the OPP server for client requests.

Reimplemented in ObexOppDataSinkPushServer.

ObexResult ObexOppServer::ProvideData | ( | ObexBuffer & | app_data,
 |  | BOOLEAN | end_data = FALSE
 | ) |

Provides another chunk of data within a PULL operation.

Parameters:
app_data | Buffer which holds the data to be delivered.
end_data | Indicates that this is the last data chunk to be delivered within this operation.

ObexResult ObexOppServer::UnbindMimeType ( MimeType mime_type )

Unbinds the server from a mime type.

Calling UnbindMimeType() removes the binding to the specified mimetype to the server.

Caution: The server should be in closed state when calling this method.

Parameters:
type_info MIME type identifier.
Returns:
ObexResult which evaluates to 'TRUE' is case of success, 'FALSE' otherwise.

Reimplemented in ObexOppDataSinkPushServer.

Friends And Related Function Documentation

friend class DupeChecker [friend]

friend class ObexServerOppImpl [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexOppServer.hpp
  • Obex/ObexOppServer.cpp
Generated on Wed Jan 25 01:33:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexProtocol Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexProtocol Class Reference
[OBEX]

Internal interface base class for protocol layer abstractions. More...

#include <Apoxi/Obex/ObexProtocol.hpp>

Inheritance diagram for ObexProtocol:

[legend]
Collaboration diagram for ObexProtocol:

[legend]

Public Types

typedef ObexProtocolId | TypeId

Public Member Functions

virtual ObexResult | AcquireClientChannel (ObexChannel &result, const ObexAddrPtr &addr_ptr, BOOLEAN reserve)=0
Abstract factory method for client transport channels.
virtual ObexResult | AcquireServerChannel (ObexChannel &result, const ObexAddrPtr &addr_ptr, BOOLEAN reserve)=0
Abstract factory method for server transport channels.
virtual void | BindServerChannel (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexAddrPtr &addr_ptr)=0
Binds a server transport channel to an OBEX address.
virtual void | CloseChannel (const ObexChannel &channel, ObexOperationId oper_id)=0
Closes a transport channel.
TypeId | GetTypeId () const
Returns the protocol type identifier.
virtual void | OpenClientChannel (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexAddrPtr &addr_ptr)=0
Opens an OBEX client transport channel.
virtual ObexResult | ReleaseChannel (ObexChannel &channel)=0
Releases an ObexChannel.

Protected Member Functions

ObexProtocol (TypeId type_id)
void | OnComplete (const ObexChannel &channel, ObexOperationId oper_id, ObexResult result)
Returns operation result.
void | OnTransportError (const ObexChannel &channel, ObexOperationId oper_id, ObexResult status)
Indicates disconnection of the transport layer.

Detailed Description

Internal interface base class for protocol layer abstractions.

Warning;
This is an internal interface and must not be used outside APOXI at all. However, developers of Transport Adapters for APOXI OBEX will need to understand the concepts explained in the following paragraph.

This interface encapsules an abstraction of the transport protocol layer to be used with OBEX and possible protocols building on OBEX. Transport connections are referred to by ObexChannel instances, which must be obtained from (AcquireClientChannel(), AcquireServerChannel()) and and returned to (ReleaseChannel()) a specific transport implementation. The Transport Adapter therefore acts as channel factory and is therefore able to set channel properties to reflect the behaviour of that specific transport.

See also:
ObexChannel
All public members which take a parameter of type ObexOperationId execute asynchronsly, their completion must be indicated by calling OnComplete() passing the ObexOperationId of the operation just completed.
See also:
ObexOperationId

Member Typedef Documentation

typedef ObexProtocolId ObexProtocol::TypeId

Constructor & Destructor Documentation

ObexProtocol::ObexProtocol ( TypeId type_id ) [protected]

Constructor.

Derived concrete classes must assign a unique TypeId value which should be one of the values of the global enum type ObexProtocolId.

Member Function Documentation

virtual ObexResult ObexProtocol::AcquireClientChannel | ( | ObexChannel & | result,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | BOOLEAN | reserve
 | ) | [pure virtual]

Abstract factory method for client transport channels.

Must be implemented to return a client channel object for the specified protocol. The Channel object must be unique among all channels of the same transport and protocol. However, the under- lying transport service may be shared with other channels.

Parameters:
result | Reference to a channel object to hold the result. It will be overwritten in case of success.
addr_ptr | Smartpointer holding a valid transport address, necessary to determine whether the channel is unique or not.
Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise (possibly lack of resources).

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual ObexResult ObexProtocol::AcquireServerChannel | ( | ObexChannel & | result,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | BOOLEAN | reserve
 | ) | [pure virtual]

Abstract factory method for server transport channels.

Must be implemented to return a server channel object for the specified protocol. The Channel object must be unique among all channels of the same transport and protocol. However, the under- lying transport service may be shared with other channels.

Parameters:
result | Reference to a channel object to hold the result. It will be overwritten in case of success.
addr_ptr | Smartpointer holding a valid transport address, necessary to determine whether the channel is unique or not.
reserve | If set to TRUE, indicates that private transport resources should be reserved for this channel. However, an implementation may choose to silently ignore this hint.
Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise (possibly lack of resources).

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual void ObexProtocol::BindServerChannel | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexAddrPtr & | addr_ptr
 | ) | [pure virtual]

Binds a server transport channel to an OBEX address.

The channel must have been previously obtained by calling AcquireServerChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
server_chan | Server transport channel to open.
oper_id | Operation identifier
addr_ptr | Smartpointer holding the OBEX address of the service to connect to

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual void ObexProtocol::CloseChannel | ( | const ObexChannel & | channel,
 |  | ObexOperationId | oper_id
 | ) | [pure virtual]

Closes a transport channel.

The channel must have been previously obtained by calling AcquireServerChannel() or AcquireClientChannel(). In case of a client channel, it must have been opened by invoking OpenClientChannel(). In case of a server channel, it must have been bound to a service by invoking BindServerChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
channel | Transport channel to close.
oper_id | Operation identifier

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

void ObexProtocol::OnComplete | ( | const ObexChannel & | channel,
 |  | ObexOperationId | oper_id,
 |  | ObexResult | result
 | ) | [protected]

Returns operation result.

This method is used by protocol implementations for specific transports which derive their implementationm from this base class. It should be called to indicate completion of a pending request.

Parameters:
channel | Transport channel associated with the request.
oper_id | Operation identifier associated with the request.
result | Return code indicating either success or an error cause.

void ObexProtocol::OnTransportError | ( | const ObexChannel & | channel,
 |  | ObexOperationId | oper_id,
 |  | ObexResult | status
 | ) | [protected]

Indicates disconnection of the transport layer.

In case of abnormal transport or protocol disconnection (IrDA device gets out of sight, USB plug pulled etc.) or other spontanous malfunctions detected by the protocol implementation this method must be invoked.

It must be called for each channel affected by the problem !

Parameters:
channel | Affected transport channel.
oper_id | Operation id of the operation pending for that channel, or an invalid operation id if not applicable !
status | Error code further describing the problem.

virtual void ObexProtocol::OpenClientChannel | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexAddrPtr & | addr_ptr
 | ) | [pure virtual]

Opens an OBEX client transport channel.

The channel must have been previously obtained by calling AcquireClientChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
obex_chan | Channel to open
oper_id | Operation identifier
addr_ptr | Smartpointer holding the OBEX address of the service to connect to

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

virtual ObexResult ObexProtocol::ReleaseChannel ( ObexChannel & channel ) [pure virtual]

Releases an ObexChannel.

Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise.

Implemented in StreamObexImpl, BtObexImpl, and IrdaObexImpl.

The documentation for this class was generated from the following files:
  • Obex/ObexProtocol.hpp
  • Obex/ObexProtocol.cpp
Generated on Wed Jan 25 01:33:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexResult Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexResult Class Reference
[OBEX]

Indicates success or failure of OBEX API functions and operations. More...

#include <Apoxi/Obex/ObexResult.hpp>

Public Types

enum ErrorCode {
Success = 0, ObexError = 1, OperationAborted = 2, TransportDisconnected = 3,
OperationAlreadyRunning = 8, OperationAlreadyComplete = 9, OperationNotSupported = 10, OperationNotPermitted = 11,
InvalidHeadersInRequest = 14, ResourceNotAvailable = 16, OutOfMemory = 17, ServerAlreadyOpen = 32,
ServerAlreadyClosed = 33, ServerAlreadyKnown = 34, ClientAlreadyOpen = 64, ClientAlreadyClosed = 65,
InvalidHeaderId = 96, UnknownMimeType = 97, ObjectNotWritable = 98, SyntaxErrorInUrl = 128,
UnknownParameterInUrl = 129, InvalidParameterInUrl = 130, InvalidExecutionContext = 192, Unspecified = 255
}

Public Member Functions

ErrorCode | GetErrorCode () const
Returns the error code, or in case of no error, Success.
BOOLEAN | IsError () const
Tells whether this result indicates an error.
BOOLEAN | IsOk () const
Tells whether this result indicates success.
ObexResult (const ObexResult &from)
Copy constructor.
ObexResult (ErrorCode e=Unspecified)
Constructor and default constructor.
operator BOOLEAN () const
Conversion operator to BOOLEAN.
ObexResult & | operator= (const ObexResult &from)
Assigmnent operator.

Static Public Member Functions

static ObexResult | Ok ()
Constructs an ObexResult object that indicates success.

Detailed Description

Indicates success or failure of OBEX API functions and operations.

This class defines an implicit conversion to BOOLEAN where 'TRUE' indicates success whereas 'FALSE' means that an error has occured. In the latter case, GetErrorCode() can be used to obtain more specific information on the error cause.

Default-constructed instances indicate an 'Unspecified' error. Use the named constructor Ok() to obtain an ObexResult object that means success.

Member Enumeration Documentation

enum ObexResult::ErrorCode

Enumerator:
Success
ObexError
OperationAborted
TransportDisconnected
OperationAlreadyRunning
OperationAlreadyComplete
OperationNotSupported
OperationNotPermitted
InvalidHeadersInRequest
ResourceNotAvailable
OutOfMemory
ServerAlreadyOpen
ServerAlreadyClosed
ServerAlreadyKnown
ClientAlreadyOpen
ClientAlreadyClosed
InvalidHeaderId
UnknownMimeType
ObjectNotWritable
SyntaxErrorInUrl
UnknownParameterInUrl
InvalidParameterInUrl
InvalidExecutionContext
Unspecified

The documentation for this class was generated from the following file:
  • Obex/ObexResult.hpp
Generated on Wed Jan 25 01:33:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexServer Class Reference
[OBEX]

Internal base class for OBEX servers within applications. More...

#include <Apoxi/Obex/ObexServer.hpp>

Inheritance diagram for ObexServer:

[legend]
Collaboration diagram for ObexServer:

[legend]

Public Types

typedef ObexServerDispatcher | Base
enum Operation {
OConnect, ODisconnect, OPut, OGet,
OSetPath, OAbort, ONone
}
Request type being currently serviced. More...

Public Member Functions

ObexResult | DataProcessed (ObexBuffer &buffer, BOOLEAN proceed=FALSE)
Transfers ownership of a data buffer back to APOXI OBEX.
UINT32 | GetConnectionId () const
Returns the Connection Id of the current connection.
UINT32 | GetProgressInBytes () const
Returns the cumulative progress in transferring data.
const ByteBuffer & | GetTarget () const
Returns the target associated with a particular server instance.
virtual void | Init (ExecutionContext *ctx_ptr)
Initializes a default-constructed object.
BOOLEAN | IsActiveOperation (const ObexOperationId &oper_id) const
BOOLEAN | IsBoundToServerId (ObexServerId id) const
Internal interface methods not intended for use by application SW.
BOOLEAN | IsBoundToTarget () const
BOOLEAN | IsBoundToTarget (const ByteBuffer &target) const
BOOLEAN | IsConnected () const
Tells whether the server has accepted an OBEX CONNECT.
ObexServer (ExecutionContext *ctx_ptr)
Constructor. Constructs a usable object instance.
ObexServer ()
Default constructor.
ObexResult | ReturnResponse (const ObexObject &obex_resp)
Sends a response to a client.
virtual | ~ObexServer ()
Destructor. Destroys an ObexServer object.

Protected Member Functions

virtual ObexResult | CloseAction ()
virtual ObexServerId | GetDefaultServerId () const
Returns the server id when no target is specified.
virtual BOOLEAN | IsRequestForMe (const ObexMsg &msg, ObexDispatcher *&dispatcher_ptr)
virtual void | OnAbort (const ObexObject &abort_req)
Indicates that the server has accepted an incoming OBEX ABORT.
virtual void | OnBeginOperation (ObexDispatcher *dispatcher_ptr)
virtual BOOLEAN | OnChannelsMatch (const ServerPortPtr &port_ptr, const ObexMsg &msg)
virtual void | OnComplete (Operation op, ObexResult result)
Indicates that the current operation has been completed.
virtual void | OnConnect (const ObexObject &conn_req)
Indicates that the server has accepted an incoming OBEX CONNECT.
virtual void | OnDataProcessed (ObexBuffer &buffer)
Returns ownership of a buffer back to the application.
virtual void | OnDisconnect (const ObexObject &disc_req)
Indicates that the server has accepted an incoming OBEX DISCONNECT.
virtual void | OnDisconnected (ObexResult result)
Indicates that the current client has disconnected.
virtual void | OnGet (const ObexObject &get_req, BOOLEAN initial)
Indicates that the server has accepted an incoming OBEX GET.
virtual void | OnPut (const ObexObject &put_req, BOOLEAN initial)
Indicates that the server has accepted an incoming OBEX PUT.
virtual void | OnSetPath (const ObexObject &setp_req)
Indicates that the server has accepted an incoming OBEX SETPATH.
virtual ObexResult | OpenAction ()

Data Structures

class | ServerInfo
ServerInfo record used to register with the Server Manager.

Detailed Description

Internal base class for OBEX servers within applications.

This class offers a low-level, asynchronous interface to OBEX server functionality. It is therefore not intended for application usage as its interface might be subject to change.
For implementing custom OBEX-aware services, use the ObexDataServer interface instead, it provides a much higher level of abstraction.

When only simple object PUSH is required (no CONNECT with TARGET header), consider using ObexOppDataSinkPushServer, while the need for a directed connection will call for ObexDataServer.

Member Typedef Documentation

typedef ObexServerDispatcher ObexServer::Base

Reimplemented from ObexServerDispatcher.

Member Enumeration Documentation

enum ObexServer::Operation

Request type being currently serviced.

Enumerator:
OConnect
ODisconnect
OPut
OGet
OSetPath
OAbort
ONone

Constructor & Destructor Documentation

ObexServer::ObexServer ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

ObexServer::ObexServer ( ExecutionContext * ctx_ptr )

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
ctx_ptr Execution context in which the server is to be run. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the current context must be valid at construction time.

ObexServer::~ObexServer ( ) [virtual]

Destructor. Destroys an ObexServer object.

Member Function Documentation

ObexResult ObexServer::CloseAction ( ) [protected, virtual]

Reimplemented from ObexServerDispatcher.

ObexResult ObexServer::DataProcessed | ( | ObexBuffer & | buffer,
 |  | BOOLEAN | proceed = FALSE
 | ) |

Transfers ownership of a data buffer back to APOXI OBEX.

Must be invoked on any buffer which was delivered within a response after having processed the buffer content.

See also:
OnPut()

OnGet()

Parameters:
buffer | ObexBuffer belonging to APOXI OBEX.
proceed | Instructs APOXI OBEX to automatically send a continue response to proceed transferring data. Otherwise a call to ReturnResponse() would be required.

ObexServerId ObexServer::GetDefaultServerId ( ) const [protected, virtual]

Returns the server id when no target is specified.

Reimplemented in ObexServerOppImpl.

UINT32 ObexServer::GetProgressInBytes ( ) const

Returns the cumulative progress in transferring data.

This method returns the amount of data already transferred for a pending PUT (inbound data) or GET (outbound data) operation. The final value is preserved even beyond completion of that operation, hence it is reset to '0' when a new operation is initiated.

Reimplemented in ObexDataServer.

void ObexServer::Init ( ExecutionContext * ctx_ptr ) [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr Execution context in which the server is to be run. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the current context must be valid when Init() is called.

Reimplemented from ObexServerDispatcher.

Reimplemented in ObexDataServer.

BOOLEAN ObexServer::IsActiveOperation ( const ObexOperationId & oper_id ) const

BOOLEAN ObexServer::IsBoundToServerId ( ObexServerId id ) const [inline]

Internal interface methods not intended for use by application SW.

BOOLEAN ObexServer::IsBoundToTarget ( ) const

BOOLEAN ObexServer::IsBoundToTarget ( const ByteBuffer & target ) const

BOOLEAN ObexServer::IsRequestForMe | ( | const ObexMsg & | msg,
 |  | ObexDispatcher *& | dispatcher_ptr
 | ) | [protected, virtual]

Reimplemented in ObexServerOppImpl.

void ObexServer::OnAbort ( const ObexObject & abort_req ) [protected, virtual]

Indicates that the server has accepted an incoming OBEX ABORT.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnAbort() from your method !!!

Parameters:
abort_req OBEX object containing the ABORT headers.

Reimplemented in ObexServerOppImpl.

virtual void ObexServer::OnBeginOperation ( ObexDispatcher * dispatcher_ptr ) [inline, protected, virtual]

Reimplemented in ObexServerOppImpl.

BOOLEAN ObexServer::OnChannelsMatch | ( | const ServerPortPtr & | port_ptr,
 |  | const ObexMsg & | msg
 | ) | [protected, virtual]

void ObexServer::OnComplete | ( | Operation | op,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates that the current operation has been completed.

Parameters:
op | Type of operation
result | Result of the operation

void ObexServer::OnConnect ( const ObexObject & conn_req ) [protected, virtual]

Indicates that the server has accepted an incoming OBEX CONNECT.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnConnect() from your method !!!

Parameters:
conn_req OBEX object containing the CONNECT headers and flags

Reimplemented in ObexServerOppImpl.

void ObexServer::OnDataProcessed ( ObexBuffer & buffer ) [protected, virtual]

Returns ownership of a buffer back to the application.

The passed data buffer had been produced by the application and may be now either recycled or disposed.

Parameters:
buffer ObexBuffer belonging to the application.

Reimplemented in ObexServerOppImpl.

void ObexServer::OnDisconnect ( const ObexObject & disc_req ) [protected, virtual]

Indicates that the server has accepted an incoming OBEX DISCONNECT.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnDisconnect() from your method !!!

Parameters:
disc_req OBEX object containing the DISCONNECT headers.

Reimplemented in ObexServerOppImpl.

virtual void ObexServer::OnDisconnected ( ObexResult result ) [inline, protected, virtual]

Indicates that the current client has disconnected.

When the method is called, the client has (or has been) disconnected and the server should release any temporary resources and reset itself to a virgin state suitable for accepting a new client connection.

Parameters:
result ObexResult which evaluates to 'TRUE' when the connection was disconnected using a proper OBEX DISCONNECT request, 'FALSE' when a spontaneous disconnection occured. Check the error code then to obtain more detailed information.

Reimplemented in ObexFtpDataServer.

void ObexServer::OnGet | ( | const ObexObject & | get_req,
 |  | BOOLEAN | initial
 | ) | [protected, virtual]

Indicates that the server has accepted an incoming OBEX GET.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnGet() from your method !!! If the ObexObject contains BODY data (ObexObject::ObtainBuffer returns TRUE) don't forget to call DataProcessed() on the buffer when it is not needed anymore.

Parameters:
get_req | OBEX object containing the GET headers and possibly even BODY data in an ObexBuffer.
initial | 'TRUE' if a new GET operation is initiated by this request, 'FALSE' if an already ongoing operation is continued.

Reimplemented in ObexServerOppImpl.

void ObexServer::OnPut | ( | const ObexObject & | put_req,
 |  | BOOLEAN | initial
 | ) | [protected, virtual]

Indicates that the server has accepted an incoming OBEX PUT.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnPut() from your method !!! If the ObexObject contains BODY data (ObexObject::ObtainBuffer returns TRUE) don't forget to call DataProcessed() on the buffer when it is not needed anymore.

Parameters:
put_req | OBEX object containing the PUT headers and possibly BODY data in an ObexBuffer.
initial | 'TRUE' if a new PUT operation is initiated by this request, 'FALSE' if an already ongoing operation is continued.

Reimplemented in ObexServerOppImpl.

void ObexServer::OnSetPath ( const ObexObject & setp_req ) [protected, virtual]

Indicates that the server has accepted an incoming OBEX SETPATH.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnSetPath() from your method !!!

Parameters:
setp_req OBEX object containing the SETPATH headers and flags.

ObexResult ObexServer::OpenAction ( ) [protected, virtual]

Reimplemented from ObexServerDispatcher.

ObexResult ObexServer::ReturnResponse ( const ObexObject & obex_resp )

Sends a response to a client.

Parameters:
obex_resp OBEX object containing the response headers, the response code and possibly BODY data in an ObexBuffer (most likely for a GET).

The documentation for this class was generated from the following files:
  • Obex/ObexServer.hpp
  • Obex/ObexServer.cpp
Generated on Wed Jan 25 01:33:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexServerAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexServerAddr Class Reference
[OBEX]

Base class for server address information classes. More...

#include <Apoxi/Obex/ObexAddress.hpp>

Inheritance diagram for ObexServerAddr:

[legend]
Collaboration diagram for ObexServerAddr:

[legend]

Public Types

typedef ObexAddress | Base

Public Member Functions

virtual ObexAddrTypeId | GetTypeId () const
Returns the unique id of the ObexServerAddrInfo subclass.
virtual BOOLEAN | IsAutoRegistered () const

Protected Member Functions

ObexServerAddr (ObexTransportId transport_id)
Constructor. Restricts construction to derived classes.

Detailed Description

Base class for server address information classes.

This class should be derived for each transport implementation and extended as necessary to contain transport-specific information relevant for a server.

Member Typedef Documentation

typedef ObexAddress ObexServerAddr::Base

Reimplemented from ObexAddress.

Reimplemented in IrdaObexServerAddr.

Constructor & Destructor Documentation

ObexServerAddr::ObexServerAddr ( ObexTransportId transport_id ) [protected]

Constructor. Restricts construction to derived classes.

Member Function Documentation

ObexAddrTypeId ObexServerAddr::GetTypeId ( ) const [virtual]

Returns the unique id of the ObexServerAddrInfo subclass.

Implements ObexAddress.

BOOLEAN ObexServerAddr::IsAutoRegistered ( ) const [virtual]

The documentation for this class was generated from the following files:
  • Obex/ObexAddress.hpp
  • Obex/ObexAddress.cpp
Generated on Wed Jan 25 01:33:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexServerDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexServerDispatcher Class Reference
[OBEX]

Internal abstraction of an OBEX server at transport level. More...

#include <Apoxi/Obex/ObexServerDispatcher.hpp>

Inheritance diagram for ObexServerDispatcher:

[legend]
Collaboration diagram for ObexServerDispatcher:

[legend]

Public Types

typedef ObexEventHandler | Base
enum | OpenFlags { SdbAutoRegister = 1, PrivateTransport = 2 }

Public Member Functions

virtual ObexResult | Close ()
Deactivates the server and releases its bindings.
UINT8 | GetNrOfOpenedTransports () const
Returns the number of transports opened by Open().
virtual void | Init (ExecutionContext *ctx_ptr)
Initializes a default-constructed object.
BOOLEAN | IsBoundToChannel (const ObexChannel &channel) const
Tells whether the current server is bound to 'channel'.
virtual ObexResult | Open (const String &obex_addr_url, UINT8 open_flags=0, const ObexTransportSet &excl_xport_set=ObexTransportSet())
Activates the server and binds its address to one or more transport channels.
virtual | ~ObexServerDispatcher ()
Destructor. Destroys an ObexServerDispatcher object.

Protected Types

typedef NiSharedPtr< ObexServerPort > | ServerPortPtr

Protected Member Functions

virtual ObexResult | CloseAction ()
ServerPortPtr | GetActivePortPtr () const
Returns a smartpointer to the active port.
const String & | GetUrlStr () const
Returns the OBEX URL string which was passed to Open().
virtual void | HangUp ()
Forces a disconnection at transport layer level.
BOOLEAN | IsAcceptable (const ServerPortPtr &port_ptr) const
Tells whether 'port_ptr' can be accepted as active port.
BOOLEAN | IsActive (const ServerPortPtr &port_ptr) const
Tells whether a port is currently active.
BOOLEAN | IsActive () const
Tells whether any port is currently active.
BOOLEAN | IsShuttingDown () const
Tells whether the server is currently being shut down.
virtual BOOLEAN | IsValidContext () const
ObexServerDispatcher ()
Default constructor.
virtual void | OnBind (const ObexAddrPtr &addr_ptr, ObexResult result)
Indicates binding of a transport channel to the server.
virtual BOOLEAN | OnChannelsMatch (const ServerPortPtr &port_ptr, const ObexMsg &msg)=0
virtual void | OnClose (ObexResult result)
virtual BOOLEAN | OnObexAddrMsg (const ObexAddrMsg &msg)
Invoked when an ObexAddrMsg was received.
virtual BOOLEAN | OnObexMsg (const ObexMsg &msg)
Invoked when an ObexMsg was received.
virtual BOOLEAN | OnObexTransportMsg (const ObexTransportMsg &msg)
Invoked when an ObexTransportMsg was received.
virtual void | OnRelease (const ObexAddrPtr &addr_ptr, ObexResult result)
Indicates loss of a transport channel binding.
virtual ObexResult | OpenAction ()
void | SetActive (const ServerPortPtr &port_ptr)
Makes active_port_ptr the active port.
void | SetIdle ()
Clears the active port so a new one can be accepted.

Static Protected Member Functions

static BOOLEAN | IsPortPtrValid (const ServerPortPtr &port_ptr)
Tells whether the passed pointer is valid or not.

Friends

class | ObexServerPort

Detailed Description

Internal abstraction of an OBEX server at transport level.

Warning;
This is an internal interface and must not be used outside APOXI OBEX at all.

Its purpose is to provide an abstraction of the underlying transport connections and notify OBEX protocol events to the application layer without further evaluation. This activity is left to derived classes.

An ObexServerDispatcher may comprise multiple ObexServerPort instances listening for incoming transport connections, but only one port can be active at a time. While one port is active, incoming connection requests from all other ports are rejected.

ObexServerPort instances are bound dynamically when a transport media is enabled and released when it is disabled. These events are notified by calls to OnBind() / OnRelease().

Member Typedef Documentation

typedef ObexEventHandler ObexServerDispatcher::Base

Reimplemented in ObexServer.

typedef NiSharedPtr<ObexServerPort> ObexServerDispatcher::ServerPortPtr [protected]

Member Enumeration Documentation

enum ObexServerDispatcher::OpenFlags

The following flags are used to customize server behaviour. They can be combined using the '|' operator. When adding new flags, please be aware that each flag should have its own bit, so all values must be powers of 2.

See also:
Open()
Enumerator:
SdbAutoRegister | Attempt to automatically create a Service Discovery Database entry.
PrivateTransport | Reserve a transport channel for this server.

Constructor & Destructor Documentation

ObexServerDispatcher::~ObexServerDispatcher ( ) [virtual]

Destructor. Destroys an ObexServerDispatcher object.

ObexServerDispatcher::ObexServerDispatcher ( ) [protected]

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

Member Function Documentation

ObexResult ObexServerDispatcher::Close ( ) [virtual]

Deactivates the server and releases its bindings.

After the Close() operation has been completed, the server will no longer accept incoming requests.

ObexResult ObexServerDispatcher::CloseAction ( ) [protected, virtual]

Reimplemented in ObexServer.

ObexServerDispatcher::ServerPortPtr ObexServerDispatcher::GetActivePortPtr ( ) const [protected]

Returns a smartpointer to the active port.

Returns:
Pointer to the active port, empty smartpointer if the server is idle.

void ObexServerDispatcher::HangUp ( ) [protected, virtual]

Forces a disconnection at transport layer level.

void ObexServerDispatcher::Init ( ExecutionContext * ctx_ptr ) [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr Execution context to be used by the dispatcher. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the context must be valid when Init() is called.

Reimplemented in ObexDataServer, and ObexServer.

BOOLEAN ObexServerDispatcher::IsAcceptable ( const ServerPortPtr & port_ptr ) const [protected]

Tells whether 'port_ptr' can be accepted as active port.

BOOLEAN ObexServerDispatcher::IsBoundToChannel ( const ObexChannel & channel ) const

Tells whether the current server is bound to 'channel'.

BOOLEAN ObexServerDispatcher::IsValidContext ( ) const [protected, virtual]

Tells whether the current context is valid for message processing.

When an OBEX event handler is shared among multiple execution contexts (this means multiple ObexDispatcher instances are associated with one ObexEventHandler instance), this method should be implemented to return 'TRUE' in the context where processing and notification of OBEX events is appropriate, 'FALSE' otherwise.

In the simple case where the event handler is receiving messages from only one execution context, the method may be implemented to always return 'TRUE'.

Implements ObexEventHandler.

Reimplemented in ObexServerOppImpl.

void ObexServerDispatcher::OnBind | ( | const ObexAddrPtr & | addr_ptr,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates binding of a transport channel to the server.

Parameters:
addr_ptr | Smartpointer to OBEX address that was attempted to bind.
result | Either tells that the bind operation was successful or provides error information.

Reimplemented in ObexFtpDataServer.

virtual BOOLEAN ObexServerDispatcher::OnChannelsMatch | ( | const ServerPortPtr & | port_ptr,
 |  | const ObexMsg & | msg
 | ) | [protected, pure virtual]

void ObexServerDispatcher::OnClose ( ObexResult result ) [protected, virtual]

BOOLEAN ObexServerDispatcher::OnObexAddrMsg ( const ObexAddrMsg & msg ) [protected, virtual]

Invoked when an ObexAddrMsg was received.

Implements ObexEventHandler.

BOOLEAN ObexServerDispatcher::OnObexMsg ( const ObexMsg & msg ) [protected, virtual]

Invoked when an ObexMsg was received.

Implements ObexEventHandler.

BOOLEAN ObexServerDispatcher::OnObexTransportMsg ( const ObexTransportMsg & msg ) [protected, virtual]

Invoked when an ObexTransportMsg was received.

Implements ObexEventHandler.

void ObexServerDispatcher::OnRelease | ( | const ObexAddrPtr & | addr_ptr,
 |  | ObexResult | result
 | ) | [protected, virtual]

Indicates loss of a transport channel binding.

Parameters:
addr_ptr | Smartpointer to OBEX address whose binding was released.
result | If the result indicates success, the binding was removed due to a call to Close(), otherwise it happened due to a spontanous event further described by the error code.

ObexResult ObexServerDispatcher::Open | ( | const String & | obex_addr_url,
 |  | UINT8 | open_flags = 0,
 |  | const ObexTransportSet & | excl_xport_set = ObexTransportSet()
 | ) | [virtual]

Activates the server and binds its address to one or more transport channels.

Open() must be called on the server in order to resolve the specified address in URL format and bind it to one or more transport channels. For each transport channel bound OnBind() is called once.

Parameters:
obex_addr_url | OBEX address in URL format incl. Target. Please see OBEX URL's for more information.
open_flags | Flags used to customize server behaviour.
excl_xport_set | Set of transports not to be bound by the server
See also:
OpenFlags

ObexResult ObexServerDispatcher::OpenAction ( ) [protected, virtual]

Reimplemented in ObexServer.

void ObexServerDispatcher::SetActive ( const ServerPortPtr & port_ptr ) [protected]

Makes active_port_ptr the active port.

void ObexServerDispatcher::SetIdle ( ) [protected]

Clears the active port so a new one can be accepted.

Friends And Related Function Documentation

friend class ObexServerPort [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexServerDispatcher.hpp
  • Obex/ObexServerDispatcher.cpp
Generated on Wed Jan 25 01:33:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexServerInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexServerInfo Class Reference
[OBEX]

Internal interface used to register OBEX servers with the Server Registry. More...

#include <Apoxi/Obex/ObexServerInfo.hpp>

Inheritance diagram for ObexServerInfo:

[legend]
Collaboration diagram for ObexServerInfo:

[legend]

Public Types

enum | { NoServerId = 0, FirstServerId = 1, DefaultServerId = 254, OppImplServerId = 255 }
Reserved values of the type ObexServerId. More...

Public Member Functions

virtual BOOLEAN | Accept (ObexServerVisitor &v)=0
Enables usage of the visitor pattern on derived classes.
void | Deregister ()
Removes a server information record from the server manager.
ObexServerId | GetServerId () const
ObexServerInfo ()
Default constructor.
ObexResult | Register (ObexServerVisitor &checker, ObexServerId propose_id=FirstServerId)
virtual | ~ObexServerInfo ()
Destructor.

Friends

class | ObexServerMngr

Detailed Description

Internal interface used to register OBEX servers with the Server Registry.

Warning;
This is an internal interface which must not be used outside APOXI OBEX at all.

In order to facilitate dispatching of incoming requests by TARGET header, MIME type and possibly other criteria servers must register with a central Server Registry. This registry assigns each server a system-wide unique id, the ObexServerId. Furthermore, it provides the infrastructure for mapping incoming requests onto server id's by employing a Visitor Pattern.

Concrete server implementations must implement this interface and aggregate an instance of it in order to be able to enroll themselves with the Server Registry.

See also:
ObexServerMngr

ObexServerVisitor

Member Enumeration Documentation

anonymous enum

Reserved values of the type ObexServerId.

Enumerator:
NoServerId
  • Server not registered
FirstServerId
  • First id for a dedicated server
DefaultServerId
  • Server handles default inbox
OppImplServerId
  • Server handles OPP

Constructor & Destructor Documentation

ObexServerInfo::ObexServerInfo ( )

Default constructor.

ObexServerInfo::~ObexServerInfo ( ) [virtual]

Destructor.

Member Function Documentation

virtual BOOLEAN ObexServerInfo::Accept ( ObexServerVisitor & v ) [pure virtual]

Enables usage of the visitor pattern on derived classes.

This method must be implemented by each concrete derived class to call the related Visit...() method exposed by ObexServerVisitor. The visitor pattern concept is used to scan the server registry for a server which matches certain properties. When Accept() returns 'FALSE', scanning is terminated. The result and possible parameters must be stored within the concrete visitor instance.

Parameters:
v ObexServerVisitor instance.
Returns:
'FALSE' to terminate iterating over instances, 'TRUE' otherwise.

void ObexServerInfo::Deregister ( )

Removes a server information record from the server manager.

ObexResult ObexServerInfo::Register | ( | ObexServerVisitor & | checker,
 |  | ObexServerId | propose_id = FirstServerId
 | ) |

Friends And Related Function Documentation

friend class ObexServerMngr [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexServerInfo.hpp
  • Obex/ObexServerInfo.cpp
Generated on Wed Jan 25 01:33:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexServerMngr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexServerMngr Class Reference
[OBEX]

Internal implementation of an OBEX Server Registry. More...

#include <Apoxi/Obex/ObexServerMngr.hpp>

Collaboration diagram for ObexServerMngr:

[legend]

Public Member Functions

void | Deregister (ObexServerInfo &server_info)
Remove a registered server from the Server Registry.
ObexServerId | Iterate (ObexServerVisitor &visitor)
Iterate over the Server Registry visiting entries.
ObexServerMngr ()
Default constructor.
ObexServerId | Register (ObexServerInfo &info_item, ObexServerVisitor &checker, ObexServerId special_id)
Registers a server with the Server Registry.

Detailed Description

Internal implementation of an OBEX Server Registry.

Warning;
This is an internal interface which must not be used outside APOXI OBEX at all.

In order to facilitate dispatching of incoming requests by TARGET header, MIME type and possibly other criteria servers must register with a central Server Registry. This registry assigns each server a system-wide unique id, the ObexServerId. Furthermore, it provides the infrastructure for mapping incoming requests onto server id's by employing a Visitor Pattern. Internally, server records are kept in a list sorted by ascending ObexServerId values.

The Server Registry is represented by an instance of this class which can be accessed by calling ObexMngr::GetServerMngr().

See also:
ObexMngr

ObexServerInfo

ObexServerVisitor

Constructor & Destructor Documentation

ObexServerMngr::ObexServerMngr ( )

Default constructor.

Member Function Documentation

void ObexServerMngr::Deregister ( ObexServerInfo & server_info )

Remove a registered server from the Server Registry.

Parameters:
server_info ObexServerInfo record of the server to be removed from the registry.

ObexServerId ObexServerMngr::Iterate ( ObexServerVisitor & visitor )

Iterate over the Server Registry visiting entries.

Visits entries of the Server Registry until ObexServerInfo::Accept() returns 'TRUE'. In this case, the ObexServerId of that entry is returned, otherwise the method returns ObexServerInfo::NoServerId.

Parameters:
visitor Visitor instance to be applied to Server Registry entries.
Returns:
ObexServerId of the server record whose Accept() method returned TRUE.

ObexServerId ObexServerMngr::Register | ( | ObexServerInfo & | info_item,
 |  | ObexServerVisitor & | checker,
 |  | ObexServerId | special_id
 | ) |

Registers a server with the Server Registry.

Parameters:
info_item | ObexServerInfo record of the server to be registered.
checker | Visitor instance to check for server ambiguity.
special_id | ObexServerId proposed for this server, this is necessary for handling special cases like OPP dispatching (based on MIME types) and default INBOX For servers using directed connections, pass ObexServerInfo::FirstServerId

The documentation for this class was generated from the following files:
  • Obex/ObexServerMngr.hpp
  • Obex/ObexServerMngr.cpp
Generated on Wed Jan 25 01:33:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexServerOppImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexServerOppImpl Class Reference
[OBEX]

Internal server implementation of the OPP profile. More...

#include <Apoxi/Obex/ObexServerOppImpl.hpp>

Inheritance diagram for ObexServerOppImpl:

[legend]
Collaboration diagram for ObexServerOppImpl:

[legend]

Public Member Functions

ObexResult | AcceptPull (const WString &obj_name, const WString &obj_desc, UINT32 obj_size)
Accepts an incoming PULL operation.
ObexResult AcceptPush ()
Accepts an incoming PUSH operation.
ObexResult | AttachOppServer (ObexOppServer *self_ptr)
Registers an ObexOppServer instance with ObexServerOppImpl.
ObexResult | CancelOperation (ObexObject::ResponseCode resp_code, const WString &resp_desc)
Cancels an OBEX operation by sending an error response.
ObexResult DataProcessed ()
Informs server implementation that the internal buffer is available.
ObexResult | DataProcessed (ObexBuffer &app_data)
Returns an empty ObexBuffer to the server implementation.
void | DetachOppServer (ObexOppServer *self_ptr)
Deregisters an ObexOppServer instance.
BOOLEAN | IsActiveOppServer (const ObexOppServer *srvr_ptr) const
Tells whether an OPP server is currently served by ObexServerOppImpl.
ObexResult | ProvideData (ObexBuffer &app_data, BOOLEAN end_data)
Provides outbound BODY data within an ObexBuffer.

Static Public Member Functions

static ObexServerOppImpl & | GetInstance ()
Singleton accessor.

Protected Member Functions

virtual ObexServerId | GetDefaultServerId () const
Returns the server id when no target is specified.
virtual BOOLEAN | IsRequestForMe (const ObexMsg &msg, ObexDispatcher *&dispatcher_ptr)
virtual BOOLEAN | IsValidContext () const
virtual void | OnAbort (const ObexObject &abort_req)
Indicates that the server has accepted an incoming OBEX ABORT.
virtual void | OnBeginOperation (ObexDispatcher *dispatcher_ptr)
virtual void | OnComplete (Operation op, ObexResult result)
virtual void | OnConnect (const ObexObject &conn_req)
Indicates that the server has accepted an incoming OBEX CONNECT.
virtual void | OnDataProcessed (ObexBuffer &buffer)
Returns ownership of a buffer back to the application.
virtual void | OnDisconnect (const ObexObject &disc_req)
Indicates that the server has accepted an incoming OBEX DISCONNECT.
virtual void | OnGet (const ObexObject &put_req, BOOLEAN initial)
Indicates that the server has accepted an incoming OBEX GET.
virtual void | OnPut (const ObexObject &put_req, BOOLEAN initial)
Indicates that the server has accepted an incoming OBEX PUT.

Data Structures

class | HeaderCollector
Internal helper class for accumulatig headers split over multiple packets.

Detailed Description

Internal server implementation of the OPP profile.

Warning;
This is an internal implementation class which must not be used outside APOXI OBEX at all.

It provides an implementation of an OPP (Object Push Pull) profile server based on plain OBEX functionality, hence the OPP profile can be used with all transport implementations regardless whether they support OPP natively or not.

Limitations:

This OPP server implementation supports only one transport connection at a time. In case of competing incoming requests ony the first one is accepted.

Concept:

ObexServerOppImpl is a singleton class instantiated when at least one ObexOppServer instance is used. Message handling and notifications execute in the context of the ObexOppServer instance which handles the respective operation. When no ObexOppServer is active, the ExecutionContext at creation time is 'abused' for message handling.

Member Function Documentation

ObexResult ObexServerOppImpl::AcceptPull | ( | const WString & | obj_name,
 |  | const WString & | obj_desc,
 |  | UINT32 | obj_size
 | ) |

Accepts an incoming PULL operation.

Parameters:
obj_name | Pathname to be returned within the NAME header.
obj_desc | Optional, human readable text to be returned within the DESCRIPTION header.
obj_size | Object size to be returned within the LENGTH header or '0' if unknown.

ObexResult ObexServerOppImpl::AcceptPush ( )

Accepts an incoming PUSH operation.

ObexResult ObexServerOppImpl::AttachOppServer ( ObexOppServer * self_ptr )

Registers an ObexOppServer instance with ObexServerOppImpl.

ObexResult ObexServerOppImpl::CancelOperation | ( | ObexObject::ResponseCode | resp_code,
 |  | const WString & | resp_desc
 | ) |

Cancels an OBEX operation by sending an error response.

Parameters:
resp_code | Response code, must be different from ObexObject::RespOk !
resp_desc | Optional description (human readable text) to be placed within a DESCRIPTION header.

ObexResult ObexServerOppImpl::DataProcessed ( )

Informs server implementation that the internal buffer is available.

ObexResult ObexServerOppImpl::DataProcessed ( ObexBuffer & app_data )

Returns an empty ObexBuffer to the server implementation.

void ObexServerOppImpl::DetachOppServer ( ObexOppServer * self_ptr )

Deregisters an ObexOppServer instance.

ObexServerId ObexServerOppImpl::GetDefaultServerId ( ) const [protected, virtual]

Returns the server id when no target is specified.

Reimplemented from ObexServer.

ObexServerOppImpl & ObexServerOppImpl::GetInstance ( ) [static]

Singleton accessor.

BOOLEAN ObexServerOppImpl::IsActiveOppServer ( const ObexOppServer * srvr_ptr ) const [inline]

Tells whether an OPP server is currently served by ObexServerOppImpl.

BOOLEAN ObexServerOppImpl::IsRequestForMe | ( | const ObexMsg & | msg,
 |  | ObexDispatcher *& | dispatcher_ptr
 | ) | [protected, virtual]

Reimplemented from ObexServer.

BOOLEAN ObexServerOppImpl::IsValidContext ( ) const [protected, virtual]

Tells whether the current context is valid for message processing.

When an OBEX event handler is shared among multiple execution contexts (this means multiple ObexDispatcher instances are associated with one ObexEventHandler instance), this method should be implemented to return 'TRUE' in the context where processing and notification of OBEX events is appropriate, 'FALSE' otherwise.

In the simple case where the event handler is receiving messages from only one execution context, the method may be implemented to always return 'TRUE'.

Reimplemented from ObexServerDispatcher.

void ObexServerOppImpl::OnAbort ( const ObexObject & abort_req ) [protected, virtual]

Indicates that the server has accepted an incoming OBEX ABORT.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnAbort() from your method !!!

Parameters:
abort_req OBEX object containing the ABORT headers.

Reimplemented from ObexServer.

void ObexServerOppImpl::OnBeginOperation ( ObexDispatcher * dispatcher_ptr ) [protected, virtual]

Reimplemented from ObexServer.

void ObexServerOppImpl::OnComplete | ( | Operation | op,
 |  | ObexResult | result
 | ) | [protected, virtual]

void ObexServerOppImpl::OnConnect ( const ObexObject & conn_req ) [protected, virtual]

Indicates that the server has accepted an incoming OBEX CONNECT.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnConnect() from your method !!!

Parameters:
conn_req OBEX object containing the CONNECT headers and flags

Reimplemented from ObexServer.

void ObexServerOppImpl::OnDataProcessed ( ObexBuffer & buffer ) [protected, virtual]

Returns ownership of a buffer back to the application.

The passed data buffer had been produced by the application and may be now either recycled or disposed.

Parameters:
buffer ObexBuffer belonging to the application.

Reimplemented from ObexServer.

void ObexServerOppImpl::OnDisconnect ( const ObexObject & disc_req ) [protected, virtual]

Indicates that the server has accepted an incoming OBEX DISCONNECT.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnDisconnect() from your method !!!

Parameters:
disc_req OBEX object containing the DISCONNECT headers.

Reimplemented from ObexServer.

void ObexServerOppImpl::OnGet | ( | const ObexObject & | put_req,
 |  | BOOLEAN | initial
 | ) | [protected, virtual]

Indicates that the server has accepted an incoming OBEX GET.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnGet() from your method !!! If the ObexObject contains BODY data (ObexObject::ObtainBuffer returns TRUE) don't forget to call DataProcessed() on the buffer when it is not needed anymore.

Parameters:
get_req | OBEX object containing the GET headers and possibly even BODY data in an ObexBuffer.
initial | 'TRUE' if a new GET operation is initiated by this request, 'FALSE' if an already ongoing operation is continued.

Reimplemented from ObexServer.

void ObexServerOppImpl::OnPut | ( | const ObexObject & | put_req,
 |  | BOOLEAN | initial
 | ) | [protected, virtual]

Indicates that the server has accepted an incoming OBEX PUT.

The default implementation of this method rejects the request as 'not implemented', therefore if you re-implement this method in your derived class, you should NEVER call Base::OnPut() from your method !!! If the ObexObject contains BODY data (ObexObject::ObtainBuffer returns TRUE) don't forget to call DataProcessed() on the buffer when it is not needed anymore.

Parameters:
put_req | OBEX object containing the PUT headers and possibly BODY data in an ObexBuffer.
initial | 'TRUE' if a new PUT operation is initiated by this request, 'FALSE' if an already ongoing operation is continued.

Reimplemented from ObexServer.

ObexResult ObexServerOppImpl::ProvideData | ( | ObexBuffer & | app_data,
 |  | BOOLEAN | end_data
 | ) |

Provides outbound BODY data within an ObexBuffer.

The documentation for this class was generated from the following files:
  • Obex/ObexServerOppImpl.hpp
  • Obex/ObexServerOppImpl.cpp
Generated on Wed Jan 25 01:33:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexServerPort Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexServerPort Class Reference
[OBEX]

Internal implementation class for OBEX transport interfaces. More...

#include <Apoxi/Obex/ObexServerPort.hpp>

Inheritance diagram for ObexServerPort:

[legend]
Collaboration diagram for ObexServerPort:

[legend]

Public Types

typedef ObexAbstractPort | Base

Public Member Functions

BOOLEAN | IsListening () const
Tells whether the port is listening to incoming connection requests.
ObexServerPort (ObexAbstractTransport &transport, ObexProtocol &protocol, ObexServerDispatcher &server)
Constructor.
void | Reset ()
Close the port and immediately reopen it.

Protected Member Functions

virtual void | AbortAddrResolution ()
Abort running address resolution procedure.
virtual BOOLEAN | AcquireChannel (ObexChannel &channel, const ObexAddrPtr &addr_ptr, ObexResult result)
Check address and obtain channel.
virtual void | CloseChannel (ObexResult cause)
Close the channel associated with the port.
virtual void | OnChannelClosed ()
Indicates completion of a Close() operation.
virtual void | OnChannelOpened (ObexResult result)
Indicates completion of an Open() operation.
virtual void | OpenChannel (const ObexAddrPtr &addr_ptr)
Open the channel associated with the port.
virtual void | StartAddrResolution ()
Resolve an OBEX URL string using the transport's interface.

Detailed Description

Internal implementation class for OBEX transport interfaces.

Warning;
This is an internal implementation class which must not be used outside APOXI OBEX at all.

It provides an implementation of the ObexAbstractPort interface suitable for server connections which is mainly a two-level nested state machine. The first level is implemented by ObexServerPort itself and represents the port state. The second level is used only temporarily to track the asynchronous execution of the following procedures:

  • Address resolution (updating of a service registry).

  • Detect when hardware becomes available and listen for incoming connection requests.

  • Detect when hardware becomes unavailable and release the associated resources.

The 2nd level state descriptions and there actions are inherited from the base class.

Member Typedef Documentation

typedef ObexAbstractPort ObexServerPort::Base

Constructor & Destructor Documentation

ObexServerPort::ObexServerPort | ( | ObexAbstractTransport & | transport,
 |  | ObexProtocol & | protocol,
 |  | ObexServerDispatcher & | server
 | ) |

Constructor.

Parameters:
transport | Instance of the transport implementation (HW abstraction) related to the transport.
protocol | Instance of the transport adapter related to the transport and the OBEX-based protocol to be used with the port.
server | Instance of an ObexServerDispatcher to handle the protocol events received by the port.

Member Function Documentation

void ObexServerPort::AbortAddrResolution ( ) [protected, virtual]

Abort running address resolution procedure.

Implements ObexAbstractPort.

BOOLEAN ObexServerPort::AcquireChannel | ( | ObexChannel & | channel,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | ObexResult | result
 | ) | [protected, virtual]

Check address and obtain channel.

Returns:
'TRUE' on success, 'FALSE' on failure.

Implements ObexAbstractPort.

void ObexServerPort::CloseChannel ( ObexResult cause ) [protected, virtual]

Close the channel associated with the port.

Implements ObexAbstractPort.

void ObexServerPort::OnChannelClosed ( ) [protected, virtual]

Indicates completion of a Close() operation.

Implements ObexAbstractPort.

void ObexServerPort::OnChannelOpened ( ObexResult result ) [protected, virtual]

Indicates completion of an Open() operation.

Implements ObexAbstractPort.

void ObexServerPort::OpenChannel ( const ObexAddrPtr & addr_ptr ) [protected, virtual]

Open the channel associated with the port.

Implements ObexAbstractPort.

void ObexServerPort::Reset ( )

Close the port and immediately reopen it.

This is used to force transport disconnection in case of a protocol error.

void ObexServerPort::StartAddrResolution ( ) [protected, virtual]

Resolve an OBEX URL string using the transport's interface.

Implements ObexAbstractPort.

The documentation for this class was generated from the following files:
  • Obex/ObexServerPort.hpp
  • Obex/ObexServerPort.cpp
Generated on Wed Jan 25 01:33:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexServerVisitor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexServerVisitor Class Reference
[OBEX]

Internal interface used to scan the OBEX Server Registry. More...

#include <Apoxi/Obex/ObexServerVisitor.hpp>

Inheritance diagram for ObexServerVisitor:

[legend]

Public Member Functions

virtual BOOLEAN | VisitObexServer (const ObexServer &server)
Visits instances of the class ObexServer.
virtual BOOLEAN | VisitOppServer (const ObexOppServer &server)
Visits instances of the class ObexOppServer.
virtual | ~ObexServerVisitor ()
Destructor.

Protected Member Functions

ObexServerVisitor ()

Detailed Description

Internal interface used to scan the OBEX Server Registry.

Warning;
This is an internal interface which must not be used outside APOXI OBEX at all.

In order to facilitate dispatching of incoming requests by TARGET header, MIME type and possibly other criteria servers must register with a central Server Registry. This registry assigns each server a system-wide unique id, the ObexServerId. Furthermore, it provides the infrastructure for mapping incoming requests onto server id's by employing a Visitor Pattern.

This class represents the abstract Visitor class of the Visitor Pattern. Concrete implementations must overwrite at least one of the Visit...() methods. When searching the Server Registry for a server meeting certain conditions, a Visit...() method should return 'TRUE' when the conditions are met, i.e. a matching server was found. This will tell the ObexServerMngr::Iterate() method to stop iterating over registry entries an return the ObexServerId of the matching server.

See also:
ObexServerMngr

ObexServerInfo

Constructor & Destructor Documentation

ObexServerVisitor::~ObexServerVisitor ( ) [virtual]

Destructor.

ObexServerVisitor::ObexServerVisitor ( ) [protected]

Member Function Documentation

BOOLEAN ObexServerVisitor::VisitObexServer ( const ObexServer & server ) [virtual]

Visits instances of the class ObexServer.

BOOLEAN ObexServerVisitor::VisitOppServer ( const ObexOppServer & server ) [virtual]

Visits instances of the class ObexOppServer.

The documentation for this class was generated from the following files:
  • Obex/ObexServerVisitor.hpp
  • Obex/ObexServerVisitor.cpp
Generated on Wed Jan 25 01:33:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexTransportMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexTransportMsg Class Reference

#include <Apoxi/Obex/ObexTransportMsg.hpp>

Inheritance diagram for ObexTransportMsg:

[legend]
Collaboration diagram for ObexTransportMsg:

[legend]

Public Types

enum | { ID = 11004 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const ObexTransportMsgType & | GetMsgType () const
const ObexOperationId & | GetOperationId () const
const ObexTransportId & | GetTransportId () const
ObexTransportMsg (const ObexTransportMsgType &msg_type, const ObexTransportId &transport_id, const ObexOperationId &operation_id=ObexOperationId())
virtual | ~ObexTransportMsg ()

Detailed Description

Sent by ObexTransport when its availability state has changed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ObexTransportMsg::ObexTransportMsg | ( | const ObexTransportMsgType & | msg_type,
 |  | const ObexTransportId & | transport_id,
 |  | const ObexOperationId & | operation_id = ObexOperationId()
 | ) |

ObexTransportMsg::~ObexTransportMsg ( ) [virtual]

Member Function Documentation

Message * ObexTransportMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ObexTransportMsg::GetMetaData ( ) const [virtual]

Implements Message.

const ObexTransportMsgType& ObexTransportMsg::GetMsgType ( ) const [inline]

const ObexOperationId& ObexTransportMsg::GetOperationId ( ) const [inline]

const ObexTransportId& ObexTransportMsg::GetTransportId ( ) const [inline]

The documentation for this class was generated from the following files:
  • Obex/ObexTransportMsg.hpp
  • Obex/ObexTransportMsg.cpp
Generated on Wed Jan 25 01:33:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexTransportSet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexTransportSet Class Reference
[OBEX]

Set representing multiple transport media to be used with APOXI OBEX. More...

#include <Apoxi/Obex/ObexTransportSet.hpp>

Collaboration diagram for ObexTransportSet:

[legend]

Public Member Functions

Iterator Begin ()
Returns an iterator which refers to the first element of the set.
BOOLEAN | Contains (ObexTransportId id) const
Tells whether the set contains the id 'id' or not.
void | Exclude (const ObexTransportSet &xs)
Removes transports from the set which are contained in a second set.
UINT8 | GetCount () const
Returns the number of transports contained in the set.
void | Include (const ObexTransportSet &xs)
Includes another transport set into the current one.
void | Include (const String &scheme)
Adds a transport to the set.
void | Include (const ObexAbstractTransport &xp)
Adds a transport to the set.
BOOLEAN | IsEmpty () const
Tells whether the set contains any element(s).
ObexTransportSet (const ObexTransportSet &from)
Copy constructor.
ObexTransportSet ()
Default constructor. Constructs an empty set.
ObexTransportSet & | operator= (const ObexTransportSet &from)
Assignment operator.

Data Structures

class | Iterator
Utility class to iterate over set elements. More...

Detailed Description

Set representing multiple transport media to be used with APOXI OBEX.

This class is mainly used for two purposes:

  • Implementing Transport Address Selection, which is carried out by the OBEX application. After having received an ObexAppMsg, the OBEX application will need to set up a dialog for choosing transports similar to the following example:

      void  MySelectionDialog::FillTransports()
      {
         ObexTransportSet           set  = ObexMngr::GetInstance().EnumTransports();
         ObexTransportSet::Iterator iter = set.Begin();

         // Iterate over transports contained in the set
         for ( ; iter.IsValid(); ++iter ) {
            // Add entry to selection dialog
            AddTransport( iter->GetObjectId(), iter->GetMmiName() );
         }
      }

  • Specifying an exclusion set to restrict an ObexServer to bind to some transports when using wildcard addressing ( Open("*://", ...) ).

See also:
ObexMngr

ObexServerDispatcher

Constructor & Destructor Documentation

ObexTransportSet::ObexTransportSet ( ) [inline]

Default constructor. Constructs an empty set.

Transports can be added at a later time by calling the Add() method on it.

Member Function Documentation

UINT8 ObexTransportSet::GetCount ( ) const

Returns the number of transports contained in the set.

void ObexTransportSet::Include ( const String & scheme )

Adds a transport to the set.

Example:

            ObexTransportSet    set;

            //  Build a transport set containing the IrDA and Bluetooth transports.
            set.Include("irdaobex");
            set.Include("btgoep");

Parameters:
scheme String containing the protocol identifier or so-called 'URL scheme' of the transport to be added to the set.

void ObexTransportSet::Include ( const ObexAbstractTransport & xp )

Adds a transport to the set.

Parameters:
xp Reference to the transport to be added to the set.

The documentation for this class was generated from the following files:
  • Obex/ObexTransportSet.hpp
  • Obex/ObexTransportSet.cpp
Generated on Wed Jan 25 01:33:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexTransportSet::Iterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ObexTransportSet::Iterator

ObexTransportSet::Iterator Class Reference

Utility class to iterate over set elements. More...

#include <Apoxi/Obex/ObexTransportSet.hpp>

Collaboration diagram for ObexTransportSet::Iterator:

[legend]

Public Member Functions

void | Advance ()
BOOLEAN | IsValid () const
Tells whether the iterator is valid.
Iterator (const Iterator &from)
Copy constructor.
Iterator ()
Default constructor.
ObexAbstractTransport & | operator * () const
Iterator & operator++ ()
ObexAbstractTransport * | operator-> () const
Iterator & | operator= (const Iterator &from)
Assignment operator.

Friends

class | ObexTransportSet

Detailed Description

Utility class to iterate over set elements.

Member Function Documentation

void ObexTransportSet::Iterator::Advance ( )

Advance the iterator. This has the effect of making it point to the next available set element. If there is no more element to point at, the iterator will become the invalid iterator.

See also:
IsValid()

ObexAbstractTransport & ObexTransportSet::Iterator::operator * ( ) const

Access currently denoted transport by reference.

See also:
IsValid()

ObexAbstractTransport * ObexTransportSet::Iterator::operator-> ( ) const

Access currently denoted transport by pointer.

See also:
IsValid()

Friends And Related Function Documentation

friend class ObexTransportSet [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexTransportSet.hpp
  • Obex/ObexTransportSet.cpp
Generated on Wed Jan 25 01:33:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexTransportWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexTransportWin Class Reference
[ObexApp]

#include <Applications/ObexApp/ObexTransportWin.hpp>

Collaboration diagram for ObexTransportWin:

[legend]

Public Member Functions

void | Init ()
To Initialize actions and action accessors.
ObexTransportWin ()
Constructor.
virtual | ~ObexTransportWin ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual void | OnClose ()
virtual BOOLEAN | OnConfirm ()
BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
The documentation for this class was generated from the following files:
  • Applications/ObexApp/ObexTransportWin.hpp
  • Applications/ObexApp/ObexTransportWin.cpp
Generated on Wed Jan 25 01:33:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexTriggerMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexTriggerMsg Class Reference

#include <Apoxi/Obex/ObexMessages.hpp>

Inheritance diagram for ObexTriggerMsg:

[legend]
Collaboration diagram for ObexTriggerMsg:

[legend]

Public Types

enum | { ID = 11001 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const ObexProtocolId & | GetProtocolId () const
ObexTriggerMsg (const ObexProtocolId &protocol_id)
virtual | ~ObexTriggerMsg ()

Detailed Description

Sent by APOXI OBEX to (re)start a deferred operation.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ObexTriggerMsg::ObexTriggerMsg ( const ObexProtocolId & protocol_id )

ObexTriggerMsg::~ObexTriggerMsg ( ) [virtual]

Member Function Documentation

Message * ObexTriggerMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ObexTriggerMsg::GetMetaData ( ) const [virtual]

Implements Message.

const ObexProtocolId& ObexTriggerMsg::GetProtocolId ( ) const [inline]

The documentation for this class was generated from the following files:
  • Obex/ObexMessages.hpp
  • Obex/ObexMessages.cpp
Generated on Wed Jan 25 01:33:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexUrlStrParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexUrlStrParser Class Reference
[OBEX]

Internal utility class used to parse an OBEX URL. More...

#include <Apoxi/Obex/ObexUrlParser.hpp>

Collaboration diagram for ObexUrlStrParser:

[legend]

Public Member Functions

ObexUrlStrParser (const String &url_str)
Constructor.
ObexResult | ParseTarget (ByteBuffer &out_val)
Extracts a TARGET specifiation from the OBEX URL.

Protected Member Functions

BOOLEAN | IsAtEnd () const
Checks whether the parser has reached the end of the input text.
BOOLEAN | MatchString (const CHAR *key_str)
BOOLEAN | MatchSymbol (char symbol)
BOOLEAN | ScanAsciiString (ByteBuffer &out_val)
BOOLEAN | ScanOctetString (ByteBuffer &out_val)
BOOLEAN | StartSymbol (char symbol)

Detailed Description

Internal utility class used to parse an OBEX URL.

Warning:
This is an internal implementation class which must not be used outside APOXI OBEX at all.

It extracts the APOXI-specific part of an OBEX URL which is an extension of the format defined by the Java JSR-82 specification. The extension is mainly required to be able to specify an OBEX TARGET which is needed for logical addressing of incoming server connections.

Constructor & Destructor Documentation

ObexUrlStrParser::ObexUrlStrParser ( const String & url_str ) [inline]

Constructor.

Parameters:
url_str OBEX URL string to be parsed.

Member Function Documentation

BOOLEAN ObexUrlStrParser::IsAtEnd ( ) const [inline, protected]

Checks whether the parser has reached the end of the input text.

BOOLEAN ObexUrlStrParser::MatchString ( const CHAR * key_str ) [protected]

BOOLEAN ObexUrlStrParser::MatchSymbol ( char symbol ) [protected]

ObexResult ObexUrlStrParser::ParseTarget ( ByteBuffer & out_val )

Extracts a TARGET specifiation from the OBEX URL.

Parameters:
Reference to a bytebuffer object where the result is stored in case of success. Any previous content will be overwritten. When no TARGET is specified by the URL the length of the bytebuffer is set to '0'.
Returns:
ObexResult which evaluates to 'TRUE' when parsing was successfull, 'FALSE' otherwise.

BOOLEAN ObexUrlStrParser::ScanAsciiString ( ByteBuffer & out_val ) [protected]

BOOLEAN ObexUrlStrParser::ScanOctetString ( ByteBuffer & out_val ) [protected]

BOOLEAN ObexUrlStrParser::StartSymbol ( char symbol ) [protected]

The documentation for this class was generated from the following files:
  • Obex/ObexUrlParser.hpp
  • Obex/ObexUrlParser.cpp
Generated on Wed Jan 25 01:33:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexVCardMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObexVCardMsg Class Reference

#include <Apoxi/Obex/ObexVCardMsg.hpp>

Inheritance diagram for ObexVCardMsg:

[legend]
Collaboration diagram for ObexVCardMsg:

[legend]

Public Types

enum | { ID = 22001 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const VCard & | GetVCard () const
ObexVCardMsg (const VCard &vCard)
virtual | ~ObexVCardMsg ()

Protected Member Functions

virtual void | Dump (OutputStream &ostr) const

Friends

OutputStream & | operator<< (OutputStream &ostr, const ObexVCardMsg &cls)
InputStream & | operator>> (InputStream &istr, ObexVCardMsg &cls)

Detailed Description

sent by Obex service when VCard object has been received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ObexVCardMsg::ObexVCardMsg ( const VCard & vCard )

ObexVCardMsg::~ObexVCardMsg ( ) [virtual]

Member Function Documentation

Message * ObexVCardMsg::Clone ( ) const [virtual]

Implements Message.

void ObexVCardMsg::Dump ( OutputStream & ostr ) const [protected, virtual]

const MsgMetaData & ObexVCardMsg::GetMetaData ( ) const [virtual]

Implements Message.

const VCard& ObexVCardMsg::GetVCard ( ) const [inline]

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const ObexVCardMsg & | cls
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | ObexVCardMsg & | cls
 | ) | [friend]

The documentation for this class was generated from the following files:
  • Obex/ObexVCardMsg.hpp
  • Obex/ObexVCardMsg.cpp
Generated on Wed Jan 25 01:33:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObjectDataConverter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObjectDataConverter Class Reference
[Afs]

#include <Apoxi/Afs/ObjectDataConverter.hpp>

Static Public Member Functions

static BOOLEAN | ConvertDataItemToObjectData (const DataItem &data_item, RegObjectData &object_data)
converts DataItem to RegObjectData
static void | ConvertObjectDataToDataItem (const RegObjectData &object_data, DataItem &data_item)
converts RegObjectData to DataItem

Detailed Description

structure of object data converter

Member Function Documentation

BOOLEAN ObjectDataConverter::ConvertDataItemToObjectData | ( | const DataItem & | data_item,
 |  | RegObjectData & | object
 | ) | [static]

converts DataItem to RegObjectData

------------------------------------------------------------------------ ConvertDataItemToObjectData ------------------------------------------------------------------------

void ObjectDataConverter::ConvertObjectDataToDataItem | ( | const RegObjectData & | object,
 |  | DataItem & | data_item
 | ) | [static]

converts RegObjectData to DataItem

------------------------------------------------------------------------ ConvertObjectDataToDataItem ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/ObjectDataConverter.hpp
  • Afs/ObjectDataConverter.cpp
Generated on Wed Jan 25 01:33:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObjectObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObjectObtainer Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/ObjectObtainer.hpp>

Inheritance diagram for ObjectObtainer:

[legend]
Collaboration diagram for ObjectObtainer:

[legend]

Public Member Functions

const ObtainableObject * | GetObject () const
ObtainableObject * GetObject ()
UINT | GetObjectHint () const
ObjectObtainer (const ObjectObtainer &obtainer)
ObjectObtainer (ObtainableObject *object, BOOLEAN disposable, UINT8 object_hint=0)
ObjectObtainer ()
ObjectObtainer & | operator= (const ObjectObtainer &obtainer)
virtual | ~ObjectObtainer ()

Detailed Description

Obtains an ObtainableObject and destructs it when necessary. An object-obtainer does a reference-counting, hence when all object-obtainers are destructed and the object-obtainer has been initialized to obtain a disposable obtainable-object, the obtainable-object itself will get deleted too.

Constructor & Destructor Documentation

ObjectObtainer::ObjectObtainer ( )

ObjectObtainer::ObjectObtainer | ( | ObtainableObject * | object,
 |  | BOOLEAN | disposable,
 |  | UINT8 | object_hint = 0
 | ) |

Parameters:
object | Pointer to the obtainable-object, which may be shared.
disposable | If set to TRUE, the obtainable-object object will get deleted automatically, when no object-obtainer references this obtainable-object anymore.
object_hint | Sets a hint for the object (see ObjectObtainer::GetObjectHint for details).

ObjectObtainer::ObjectObtainer ( const ObjectObtainer & obtainer )

ObjectObtainer::~ObjectObtainer ( ) [virtual]

Member Function Documentation

const ObtainableObject* ObjectObtainer::GetObject ( ) const [inline]

ObtainableObject* ObjectObtainer::GetObject ( ) [inline]

UINT ObjectObtainer::GetObjectHint ( ) const [inline]

Returns the object-hint which can be assigned when constructing an ObjectObtainer. The object-hint allows derived classes to add e. g. a runtime type information of the passed object for a dynamic cast.

ObjectObtainer & ObjectObtainer::operator= ( const ObjectObtainer & obtainer )

The documentation for this class was generated from the following files:
  • Auxiliary/ObjectObtainer.hpp
  • Auxiliary/ObjectObtainer.cpp
Generated on Wed Jan 25 01:33:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObjectTreeService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObjectTreeService Class Reference
[Afs]

#include <Apoxi/Afs/ObjectTreeService.hpp>

Inheritance diagram for ObjectTreeService:

[legend]
Collaboration diagram for ObjectTreeService:

[legend]

Public Member Functions

virtual RegResult | Add (const CHAR *uri, const RegObjectData &reg_data_object)=0
virtual RegResult | Delete (const CHAR *uri)=0
virtual RegResult | Get (const CHAR *uri, RegObjectData &reg_data_object, INT16 bufsize)=0
virtual RegResult | Lock (const CHAR *uri, INT16 lockid)=0
ObjectTreeService (const Guid &guid)
virtual RegResult | Replace (const CHAR *uri, const RegObjectData &reg_data_object)=0
virtual RegResult | Unlock (INT16 lockid)=0
virtual | ~ObjectTreeService ()

Detailed Description

structure of object tree service

Constructor & Destructor Documentation

ObjectTreeService::ObjectTreeService ( const Guid & guid )

------------------------------------------------------------------------ Ctor ------------------------------------------------------------------------

ObjectTreeService::~ObjectTreeService ( ) [virtual]

------------------------------------------------------------------------ Dtor ------------------------------------------------------------------------

Member Function Documentation

virtual RegResult ObjectTreeService::Add | ( | const CHAR * | uri,
 |  | const RegObjectData & | reg_data_object
 | ) | [pure virtual]

virtual RegResult ObjectTreeService::Delete ( const CHAR * uri ) [pure virtual]

virtual RegResult ObjectTreeService::Get | ( | const CHAR * | uri,
 |  | RegObjectData & | reg_data_object,
 |  | INT16 | bufsize
 | ) | [pure virtual]

virtual RegResult ObjectTreeService::Lock | ( | const CHAR * | uri,
 |  | INT16 | lockid
 | ) | [pure virtual]

virtual RegResult ObjectTreeService::Replace | ( | const CHAR * | uri,
 |  | const RegObjectData & | reg_data_object
 | ) | [pure virtual]

virtual RegResult ObjectTreeService::Unlock ( INT16 lockid ) [pure virtual]

The documentation for this class was generated from the following files:
  • Afs/ObjectTreeService.hpp
  • Afs/ObjectTreeService.cpp
Generated on Wed Jan 25 01:33:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObservableObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObservableObject Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/ObservableObject.hpp>

Inheritance diagram for ObservableObject:

[legend]
Collaboration diagram for ObservableObject:

[legend]

Public Types

typedef Observer * | ObserverPtr

Public Member Functions

void | Attach (Observer *observer)
void | Detach (Observer *observer)
Detaches the Observer observer from the observer-list.
BOOLEAN | IsAttached (Observer *observer) const
Returns TRUE, if the Observer is attached.
void | NotifyObservers ()
ObservableObject ()
~ObservableObject ()

Detailed Description

An Observable-Object can be observed by several instances of the class Observer. Whenever the state of an Observable-Object is changed, NotifyObservers() is invoked, which calls Observer::OnUpdate(this) for all attached Observers. Hence all Observers can react on the state-change of the Observable-Object.

Please be aware that this class is not designed to be and therefore never meant to be thread-safe! The invocation and execution of Observer::OnUpdate(this) for all attached Observers will be done by the execution context which invoked NotifyObservers() !!!

See also:
Observer

Member Typedef Documentation

typedef Observer* ObservableObject::ObserverPtr

Constructor & Destructor Documentation

ObservableObject::ObservableObject ( )

ObservableObject::~ObservableObject ( )

Member Function Documentation

void ObservableObject::Attach ( Observer * observer )

Attaches the Observer observer to the observer-list. For every attached observer Observer::OnUpdate(this) is invoked, whenever the state of the Observable-Object changes.

void ObservableObject::Detach ( Observer * observer )

Detaches the Observer observer from the observer-list.

BOOLEAN ObservableObject::IsAttached ( Observer * observer ) const

Returns TRUE, if the Observer is attached.

void ObservableObject::NotifyObservers ( )

Invokes Observer::OnUpdate(this) for all attached Observers. Call this method when a state of the Observable-Object changes.

The documentation for this class was generated from the following files:
  • Auxiliary/ObservableObject.hpp
  • Auxiliary/ObservableObject.cpp
Generated on Wed Jan 25 01:33:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Observer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Observer Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Observer.hpp>

Inheritance diagram for Observer:

[legend]

Public Member Functions

Observer ()
virtual | ~Observer ()

Protected Member Functions

virtual void | OnUpdate (ObservableObject *obs_obj)

Friends

class | ObservableObject

Detailed Description

An Observer is informed about the change of a state of an Observable-Object by Observer::OnUpdate(ObservableObject *obs_obj). To get informed every Observer must attach itself to the Observable-Object by ObservableObject::Attach(this). An Observer may attach itself to several Observable-Objects.

See also:
ObservableObject

Constructor & Destructor Documentation

Observer::Observer ( )

Observer::~Observer ( ) [virtual]

Member Function Documentation

void Observer::OnUpdate ( ObservableObject * obs_obj ) [protected, virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented in UsbObexTransport, ProviderProxyContainer, ProviderProxyItem, AbstractDelegationProvider, IndicatorBar, IndicatorPaneObject, ObexAbstractTransport, UibFolderWin, UibInboxProvider, UibInboxTest, and UibPerformanceTest.

Friends And Related Function Documentation

friend class ObservableObject [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/Observer.hpp
  • Auxiliary/Observer.cpp
Generated on Wed Jan 25 01:33:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObtainableObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ObtainableObject Class Reference
[Auxiliary]

Base class for objects, that can be controled by an ObjectObtainer. More...

#include <Apoxi/Auxiliary/ObjectObtainer.hpp>

Inheritance diagram for ObtainableObject:

[legend]
Collaboration diagram for ObtainableObject:

[legend]

Public Member Functions

INT | GetObtainedCount ()
ObtainableObject ()
virtual | ~ObtainableObject ()

Friends

class | ObjectObtainer

Detailed Description

Base class for objects, that can be controled by an ObjectObtainer.

Constructor & Destructor Documentation

ObtainableObject::ObtainableObject ( )

ObtainableObject::~ObtainableObject ( ) [virtual]

Member Function Documentation

INT ObtainableObject::GetObtainedCount ( )

Friends And Related Function Documentation

friend class ObjectObtainer [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/ObjectObtainer.hpp
  • Auxiliary/ObjectObtainer.cpp
Generated on Wed Jan 25 01:33:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmBandStatusCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmBandStatusCnfArg Class Reference

#include <Apoxi/Apc/OmStackMsgArgs.hpp>

Inheritance diagram for OmBandStatusCnfArg:

[legend]
Collaboration diagram for OmBandStatusCnfArg:

[legend]

Public Types

enum | { ID = 1601 }

Public Member Functions

const GsmBandList & | GetSupportedBandList () const
const GsmBandList & | GetUsedBandList () const
OmBandStatusCnfArg ()
void | SetSupportedBandList (const GsmBandList &supported_band_list)
void | SetUsedBandList (const GsmBandList &used_band_list)

Static Public Member Functions

static const OmBandStatusCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BandStatusIndArg: reflects arguments of signal OM_BAND_STATUS_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmBandStatusCnfArg::OmBandStatusCnfArg ( )

Member Function Documentation

const OmBandStatusCnfArg & OmBandStatusCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GsmBandList& OmBandStatusCnfArg::GetSupportedBandList ( ) const [inline]

const GsmBandList& OmBandStatusCnfArg::GetUsedBandList ( ) const [inline]

void OmBandStatusCnfArg::SetSupportedBandList ( const GsmBandList & supported_band_list ) [inline]

void OmBandStatusCnfArg::SetUsedBandList ( const GsmBandList & used_band_list ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/OmStackMsgArgs.hpp
  • Apc/OmStackMsgArgs.cpp
Generated on Wed Jan 25 01:33:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmBandStatusReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmBandStatusReqArg Class Reference

#include <Apoxi/Apc/OmStackMsgArgs.hpp>

Inheritance diagram for OmBandStatusReqArg:

[legend]
Collaboration diagram for OmBandStatusReqArg:

[legend]

Public Types

enum | { ID = 2601 }

Public Member Functions

OmBandStatusReqArg ()

Static Public Member Functions

static const OmBandStatusReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

BandStatusReqArg: reflects arguments of signal OM_BAND_STATUS_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmBandStatusReqArg::OmBandStatusReqArg ( )

Member Function Documentation

const OmBandStatusReqArg & OmBandStatusReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/OmStackMsgArgs.hpp
  • Apc/OmStackMsgArgs.cpp
Generated on Wed Jan 25 01:33:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmControlIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmControlIndArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for OmControlIndArg:

[legend]
Collaboration diagram for OmControlIndArg:

[legend]

Public Types

enum | { ID = 1241 }

Public Member Functions

const PowerMode & | GetPowerMode () const
OmControlIndArg ()
OmControlIndArg (const PowerMode &power_mode)
void | SetPowerMode (const PowerMode &power_mode)
~OmControlIndArg ()

Static Public Member Functions

static const OmControlIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmControlIndArg: reflects arguments of signal OM_CONTROL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmControlIndArg::OmControlIndArg ( const PowerMode & power_mode )

OmControlIndArg::OmControlIndArg ( )

OmControlIndArg::~OmControlIndArg ( )

Member Function Documentation

const OmControlIndArg & OmControlIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PowerMode& OmControlIndArg::GetPowerMode ( ) const [inline]

void OmControlIndArg::SetPowerMode ( const PowerMode & power_mode ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmFactoryResetIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmFactoryResetIndArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for OmFactoryResetIndArg:

[legend]
Collaboration diagram for OmFactoryResetIndArg:

[legend]

Public Types

enum | { ID = 2106 }

Public Member Functions

OmFactoryResetIndArg ()

Static Public Member Functions

static const OmFactoryResetIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmFactoryResetIndArg: reflects arguments of signal OM_FACTORY_RESET_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmFactoryResetIndArg::OmFactoryResetIndArg ( )

Member Function Documentation

const OmFactoryResetIndArg & OmFactoryResetIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmGetTermProfileCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmGetTermProfileCnfArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for OmGetTermProfileCnfArg:

[legend]
Collaboration diagram for OmGetTermProfileCnfArg:

[legend]

Public Types

enum | { ID = 1114 }

Public Member Functions

const SimTkProfile & | GetSimTkProfile () const
OmGetTermProfileCnfArg ()
void | SetSimTkProfile (const SimTkProfile &sim_tk_profile)

Static Public Member Functions

static const OmGetTermProfileCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmGetTermProfileCnfArg: reflects arguments of signal OM_GET_TERM_PROFILE_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmGetTermProfileCnfArg::OmGetTermProfileCnfArg ( )

Member Function Documentation

const OmGetTermProfileCnfArg & OmGetTermProfileCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkProfile& OmGetTermProfileCnfArg::GetSimTkProfile ( ) const [inline]

void OmGetTermProfileCnfArg::SetSimTkProfile ( const SimTkProfile & sim_tk_profile ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmGetTermProfileReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmGetTermProfileReqArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for OmGetTermProfileReqArg:

[legend]
Collaboration diagram for OmGetTermProfileReqArg:

[legend]

Public Types

enum | { ID = 2107 }

Public Member Functions

OmGetTermProfileReqArg ()

Static Public Member Functions

static const OmGetTermProfileReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmGetTermProfileReqArg: reflects arguments of signal OM_GET_TERM_PROFILE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmGetTermProfileReqArg::OmGetTermProfileReqArg ( )

Member Function Documentation

const OmGetTermProfileReqArg & OmGetTermProfileReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmMultiSlotIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmMultiSlotIndArg Class Reference

#include <Apoxi/Apc/OmStackMsgArgs.hpp>

Inheritance diagram for OmMultiSlotIndArg:

[legend]
Collaboration diagram for OmMultiSlotIndArg:

[legend]

Public Types

enum | { ID = 1600 }

Public Member Functions

BOOLEAN | IsSuccess () const
OmMultiSlotIndArg ()
void | SetSuccess (BOOLEAN success)

Static Public Member Functions

static const OmMultiSlotIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmMultiSlotCnfArg: reflects arguments of signal OM_MULTI_SLOT_CNF and OM_MULTI_SLOT_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmMultiSlotIndArg::OmMultiSlotIndArg ( )

Member Function Documentation

const OmMultiSlotIndArg & OmMultiSlotIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN OmMultiSlotIndArg::IsSuccess ( ) const [inline]

void OmMultiSlotIndArg::SetSuccess ( BOOLEAN success ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/OmStackMsgArgs.hpp
  • Apc/OmStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmMultiSlotIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmMultiSlotIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for OmMultiSlotIndMsg:

[legend]
Collaboration diagram for OmMultiSlotIndMsg:

[legend]

Public Types

enum | { ID = 18334 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsSuccess () const
OmMultiSlotIndMsg (ExecutionContext *context, BOOLEAN success)
void | SetSuccess (BOOLEAN success)
virtual | ~OmMultiSlotIndMsg ()

Detailed Description

OmMultiSlotIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmMultiSlotIndMsg::OmMultiSlotIndMsg | ( | ExecutionContext * | context,
 |  | BOOLEAN | success
 | ) |

OmMultiSlotIndMsg::~OmMultiSlotIndMsg ( ) [virtual]

Member Function Documentation

Message * OmMultiSlotIndMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & OmMultiSlotIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BOOLEAN OmMultiSlotIndMsg::IsSuccess ( ) const [inline]

void OmMultiSlotIndMsg::SetSuccess ( BOOLEAN success ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:34:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmMultiSlotReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmMultiSlotReqArg Class Reference

#include <Apoxi/Apc/OmStackMsgArgs.hpp>

Inheritance diagram for OmMultiSlotReqArg:

[legend]
Collaboration diagram for OmMultiSlotReqArg:

[legend]

Public Types

enum | { ID = 2600 }

Public Member Functions

const MultiSlotMode & | GetMultiSlotMode () const
OmMultiSlotReqArg ()
OmMultiSlotReqArg (const MultiSlotMode &multi_slot_mode)
void | SetMultiSlotMode (const MultiSlotMode &multi_slot_mode)

Static Public Member Functions

static const OmMultiSlotReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmMultiSlotReqArg: reflects arguments of signal OM_MULTI_SLOT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmMultiSlotReqArg::OmMultiSlotReqArg ( const MultiSlotMode & multi_slot_mode )

OmMultiSlotReqArg::OmMultiSlotReqArg ( )

Member Function Documentation

const OmMultiSlotReqArg & OmMultiSlotReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MultiSlotMode& OmMultiSlotReqArg::GetMultiSlotMode ( ) const [inline]

void OmMultiSlotReqArg::SetMultiSlotMode ( const MultiSlotMode & multi_slot_mode ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/OmStackMsgArgs.hpp
  • Apc/OmStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmPowerUpArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmPowerUpArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for OmPowerUpArg:

[legend]
Collaboration diagram for OmPowerUpArg:

[legend]

Public Types

enum | { ID = 2240 }

Public Member Functions

const PowerMode & | GetPowerMode () const
OmPowerUpArg ()
OmPowerUpArg (const PowerMode &power_mode)
void | SetPowerMode (const PowerMode &power_mode)

Static Public Member Functions

static const OmPowerUpArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmPowerUpArg: reflects arguments of signal OM_CONTROL_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmPowerUpArg::OmPowerUpArg ( const PowerMode & power_mode )

OmPowerUpArg::OmPowerUpArg ( )

Member Function Documentation

const OmPowerUpArg & OmPowerUpArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PowerMode& OmPowerUpArg::GetPowerMode ( ) const [inline]

void OmPowerUpArg::SetPowerMode ( const PowerMode & power_mode ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmRatChangeCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmRatChangeCnfArg Class Reference

#include <Apoxi/Apc/OmStackMsgArgs.hpp>

Inheritance diagram for OmRatChangeCnfArg:

[legend]
Collaboration diagram for OmRatChangeCnfArg:

[legend]

Public Types

enum | { ID = 1602 }

Public Member Functions

OmRatChangeCnfArg ()

Static Public Member Functions

static const OmRatChangeCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmRatChangeCnfArg: reflects arguments of signal OM_RAT_CHANGE_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmRatChangeCnfArg::OmRatChangeCnfArg ( )

Member Function Documentation

const OmRatChangeCnfArg & OmRatChangeCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/OmStackMsgArgs.hpp
  • Apc/OmStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmRatChangeIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmRatChangeIndArg Class Reference

#include <Apoxi/Apc/OmStackMsgArgs.hpp>

Inheritance diagram for OmRatChangeIndArg:

[legend]
Collaboration diagram for OmRatChangeIndArg:

[legend]

Public Types

enum | { ID = 1603 }

Public Member Functions

const RatChangeMode & | GetRatChangeMode () const
OmRatChangeIndArg ()
void | SetRatChangeMode (const RatChangeMode &rat_change_mode)

Static Public Member Functions

static const OmRatChangeIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmRatChangeIndArg: reflects arguments of signal OM_RAT_CHANGE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmRatChangeIndArg::OmRatChangeIndArg ( )

Member Function Documentation

const OmRatChangeIndArg & OmRatChangeIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const RatChangeMode& OmRatChangeIndArg::GetRatChangeMode ( ) const [inline]

void OmRatChangeIndArg::SetRatChangeMode ( const RatChangeMode & rat_change_mode ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/OmStackMsgArgs.hpp
  • Apc/OmStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmRatChangeReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmRatChangeReqArg Class Reference

#include <Apoxi/Apc/OmStackMsgArgs.hpp>

Inheritance diagram for OmRatChangeReqArg:

[legend]
Collaboration diagram for OmRatChangeReqArg:

[legend]

Public Types

enum | { ID = 2602 }

Public Member Functions

const RatChangeMode & | GetRatChangeMode () const
OmRatChangeReqArg ()
OmRatChangeReqArg (const RatChangeMode &rat_change_mode)

Static Public Member Functions

static const OmRatChangeReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmRatChangeReqArg: reflects arguments of signal OM_RAT_CHANGE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmRatChangeReqArg::OmRatChangeReqArg ( const RatChangeMode & rat_change_mode )

OmRatChangeReqArg::OmRatChangeReqArg ( )

Member Function Documentation

const OmRatChangeReqArg & OmRatChangeReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const RatChangeMode& OmRatChangeReqArg::GetRatChangeMode ( ) const [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/OmStackMsgArgs.hpp
  • Apc/OmStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmSetTermProfileCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmSetTermProfileCnfArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for OmSetTermProfileCnfArg:

[legend]
Collaboration diagram for OmSetTermProfileCnfArg:

[legend]

Public Types

enum | { ID = 1115 }

Public Member Functions

OmSetTermProfileCnfArg ()

Static Public Member Functions

static const OmSetTermProfileCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmSetTermProfileCnfArg: reflects arguments of signal OM_SET_TERM_PROFILE_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmSetTermProfileCnfArg::OmSetTermProfileCnfArg ( )

Member Function Documentation

const OmSetTermProfileCnfArg & OmSetTermProfileCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmSetTermProfileRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmSetTermProfileRejArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for OmSetTermProfileRejArg:

[legend]
Collaboration diagram for OmSetTermProfileRejArg:

[legend]

Public Types

enum | { ID = 1116 }

Public Member Functions

OmSetTermProfileRejArg ()

Static Public Member Functions

static const OmSetTermProfileRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmSetTermProfileRejArg: reflects arguments of signal OM_SET_TERM_PROFILE_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmSetTermProfileRejArg::OmSetTermProfileRejArg ( )

Member Function Documentation

const OmSetTermProfileRejArg & OmSetTermProfileRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OmSetTermProfileReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OmSetTermProfileReqArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for OmSetTermProfileReqArg:

[legend]
Collaboration diagram for OmSetTermProfileReqArg:

[legend]

Public Types

enum | { ID = 2108 }

Public Member Functions

const SimTkProfile & | GetSimTkProfile () const
OmSetTermProfileReqArg ()
OmSetTermProfileReqArg (const SimTkProfile &sim_tk_profile)
void | SetSimTkProfile (const SimTkProfile &sim_tk_profile)

Static Public Member Functions

static const OmSetTermProfileReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

OmSetTermProfileReqArg: reflects arguments of signal OM_SET_TERM_PROFILE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OmSetTermProfileReqArg::OmSetTermProfileReqArg ( const SimTkProfile & sim_tk_profile )

OmSetTermProfileReqArg::OmSetTermProfileReqArg ( )

Member Function Documentation

const OmSetTermProfileReqArg & OmSetTermProfileReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkProfile& OmSetTermProfileReqArg::GetSimTkProfile ( ) const [inline]

void OmSetTermProfileReqArg::SetSimTkProfile ( const SimTkProfile & sim_tk_profile ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:34:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OnDataRcvdMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OnDataRcvdMsg Class Reference

#include <Applications/LcsTransports/GLTP/GltpAppMsgTypes.hpp>

Inheritance diagram for OnDataRcvdMsg:

[legend]
Collaboration diagram for OnDataRcvdMsg:

[legend]

Public Types

enum | { ID = 22235 }

Public Member Functions

virtual Message * | Clone () const
BYTE * | GetBuffer () const
virtual const MsgMetaData & | GetMetaData () const
INT | GetSize () const
OnDataRcvdMsg (Application *application, BYTE *buffer, INT size)
virtual | ~OnDataRcvdMsg ()

Protected Member Functions

virtual void | Dump (OutputStream &ostr) const

Friends

OutputStream & | operator<< (OutputStream &ostr, const OnDataRcvdMsg &cls)
InputStream & | operator>> (InputStream &istr, OnDataRcvdMsg &cls)

Detailed Description

This message indicates that data has been received on the socket

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OnDataRcvdMsg::OnDataRcvdMsg | ( | Application * | application,
 |  | BYTE * | buffer,
 |  | INT | size
 | ) |

OnDataRcvdMsg::~OnDataRcvdMsg ( ) [virtual]

Member Function Documentation

Message * OnDataRcvdMsg::Clone ( ) const [virtual]

Implements Message.

void OnDataRcvdMsg::Dump ( OutputStream & ostr ) const [protected, virtual]

BYTE* OnDataRcvdMsg::GetBuffer ( ) const [inline]

const MsgMetaData & OnDataRcvdMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

INT OnDataRcvdMsg::GetSize ( ) const [inline]

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const OnDataRcvdMsg & | cls
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | OnDataRcvdMsg & | cls
 | ) | [friend]

The documentation for this class was generated from the following files:
  • Applications/LcsTransports/GLTP/GltpAppMsgTypes.hpp
  • Applications/LcsTransports/GLTP/GltpAppMsgTypes.cpp
Generated on Wed Jan 25 01:34:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OpenContextMenuAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OpenContextMenuAction Class Reference
[Items]

#include <Apoxi/Gui/OpenContextMenuAction.hpp>

Inheritance diagram for OpenContextMenuAction:

[legend]
Collaboration diagram for OpenContextMenuAction:

[legend]

Public Member Functions

BOOLEAN | AddItem (Item *item)
virtual BOOLEAN | Execute ()
AbstractItemContainer * | GetItemContainer () const
void | Init (Dispatcher *dispatcher, const WString &text, AbstractItemContainer *item_cont=0, ContextMenu::Corner corner=ContextMenu::BottomLeft, XYDIM x=-1, XYDIM y=-1)
void | Init (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE, AbstractItemContainer *item_cont=0, ContextMenu::Corner corner=ContextMenu::BottomLeft, XYDIM x=-1, XYDIM y=-1)
OpenContextMenuAction (Dispatcher *dispatcher, const WString &text, AbstractItemContainer *item_cont=0, ContextMenu::Corner corner=ContextMenu::BottomLeft, XYDIM x=-1, XYDIM y=-1)
OpenContextMenuAction (Dispatcher *dispatcher, const WString &text, const ImageObtainer &icon, BOOLEAN enabled=TRUE, AbstractItemContainer *item_cont=0, ContextMenu::Corner corner=ContextMenu::BottomLeft, XYDIM x=-1, XYDIM y=-1)
OpenContextMenuAction ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual | ~OpenContextMenuAction ()

Detailed Description

Opens a context-menu on execution. The context-menu is defined by an item-container which can be assigned by the constructor. Optionally the items can be added later by OpenContextMenuAction::AddItem without specifying an explicit item-container.

Constructor & Destructor Documentation

OpenContextMenuAction::OpenContextMenuAction ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

OpenContextMenuAction::OpenContextMenuAction | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE,
 |  | AbstractItemContainer * | item_cont = 0,
 |  | ContextMenu::Corner | corner = ContextMenu::BottomLeft,
 |  | XYDIM | x = -1,
 |  | XYDIM | y = -1
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.
item_cont | Item-container which contains the items of the context-menu.
corner | Corner of the context-menu.
x | x-position of the corner. Use -1, if a default value should be used (0 for the corners BottomLeft and TopLeft, the right display side for the corners BottomRight and TopRight)
y | y-position of the corner. Use -1, if a default value should be used. (0 for the corners TopLeft and TopRight, the bottom display side for the corners BottomRight and BottomLeft)

OpenContextMenuAction::OpenContextMenuAction | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | AbstractItemContainer * | item_cont = 0,
 |  | ContextMenu::Corner | corner = ContextMenu::BottomLeft,
 |  | XYDIM | x = -1,
 |  | XYDIM | y = -1
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
item_cont | Item-container which contains the items of the context-menu.
corner | Corner of the context-menu.
x | x-position of the corner. Use -1, if a default value should be used (0 for the corners BottomLeft and TopLeft, the right display side for the corners BottomRight and TopRight)
y | y-position of the corner. Use -1, if a default value should be used. (0 for the corners TopLeft and TopRight, the bottom display side for the corners BottomRight and BottomLeft)

OpenContextMenuAction::~OpenContextMenuAction ( ) [virtual]

Member Function Documentation

BOOLEAN OpenContextMenuAction::AddItem ( Item * item )

Adds the item item after the already added items. For other item-operations use AbstractItemGrid::GetItemContainer and invoke the corresponding methods. If no item-container has been specified by the constructor, a default item-container is used.

BOOLEAN OpenContextMenuAction::Execute ( ) [virtual]

Opens a context-menu with the added items as content.

Reimplemented from Action.

AbstractItemContainer* OpenContextMenuAction::GetItemContainer ( ) const [inline]

void OpenContextMenuAction::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | AbstractItemContainer * | item_cont = 0,
 |  | ContextMenu::Corner | corner = ContextMenu::BottomLeft,
 |  | XYDIM | x = -1,
 |  | XYDIM | y = -1
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
item_cont | Item-container which contains the items of the context-menu.
corner | Corner of the context-menu.
x | x-position of the corner. Use -1, if a default value should be used (0 for the corners BottomLeft and TopLeft, the right display side for the corners BottomRight and TopRight)
y | y-position of the corner. Use -1, if a default value should be used. (0 for the corners TopLeft and TopRight, the bottom display side for the corners BottomRight and BottomLeft)

void OpenContextMenuAction::Init | ( | Dispatcher * | dispatcher,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon,
 |  | BOOLEAN | enabled = TRUE,
 |  | AbstractItemContainer * | item_cont = 0,
 |  | ContextMenu::Corner | corner = ContextMenu::BottomLeft,
 |  | XYDIM | x = -1,
 |  | XYDIM | y = -1
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
enabled | Sets the enabled-property. The GUI-component using the item usually indicates the enabled-property by a different look of the text.
item_cont | Item-container which contains the items of the context-menu.
corner | Corner of the context-menu.
x | x-position of the corner. Use -1, if a default value should be used (0 for the corners BottomLeft and TopLeft, the right display side for the corners BottomRight and TopRight)
y | y-position of the corner. Use -1, if a default value should be used. (0 for the corners TopLeft and TopRight, the bottom display side for the corners BottomRight and BottomLeft)

BOOLEAN OpenContextMenuAction::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Action.

The documentation for this class was generated from the following files:
  • Gui/OpenContextMenuAction.hpp
  • Gui/OpenContextMenuAction.cpp
Generated on Wed Jan 25 01:34:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OpenPbWinMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OpenPbWinMsg Class Reference

#include <Applications/AdvPhonebook/AdvPbMsgTypes.hpp>

Inheritance diagram for OpenPbWinMsg:

[legend]
Collaboration diagram for OpenPbWinMsg:

[legend]

Public Types

enum | { ID = 30004 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
PbAbstractWin * | GetWin () const
OpenPbWinMsg (ExecutionContext *context, PbAbstractWin *win)
void | SetWin (PbAbstractWin *win)
virtual | ~OpenPbWinMsg ()

Detailed Description

Phonebook

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OpenPbWinMsg::OpenPbWinMsg | ( | ExecutionContext * | context,
 |  | PbAbstractWin * | win
 | ) |

OpenPbWinMsg::~OpenPbWinMsg ( ) [virtual]

Member Function Documentation

Message * OpenPbWinMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & OpenPbWinMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

PbAbstractWin* OpenPbWinMsg::GetWin ( ) const [inline]

void OpenPbWinMsg::SetWin ( PbAbstractWin * win ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbMsgTypes.hpp
  • Applications/AdvPhonebook/AdvPbMsgTypes.cpp
Generated on Wed Jan 25 01:34:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OpenWindowAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OpenWindowAction Class Reference
[Items]

#include <Apoxi/Gui/OpenWindowAction.hpp>

Inheritance diagram for OpenWindowAction:

[legend]
Collaboration diagram for OpenWindowAction:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
void | Init (Window *win, BOOLEAN modal, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
void | Init (Window *win, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
void | Init (Dispatcher *dispatcher, Window *win, const WString &text, const ImageObtainer &icon=ImageObtainer(), BOOLEAN modal=FALSE)
OpenWindowAction (Window *win, BOOLEAN modal, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
OpenWindowAction (Window *win, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
OpenWindowAction (Dispatcher *dispatcher, Window *win, const WString &text, const ImageObtainer &icon=ImageObtainer(), BOOLEAN modal=FALSE)
OpenWindowAction ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
void | SetWindow (Window *win)
virtual | ~OpenWindowAction ()

Detailed Description

Opens a window modal or modeless, if it is executed.

Constructor & Destructor Documentation

OpenWindowAction::OpenWindowAction ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

OpenWindowAction::OpenWindowAction | ( | Dispatcher * | dispatcher,
 |  | Window * | win,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon = ImageObtainer(),
 |  | BOOLEAN | modal = FALSE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
win | Pointer to the window, which should be opened.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
modal | TRUE to open the window modal, FALSE to open it modeless.

OpenWindowAction::~OpenWindowAction ( ) [virtual]

OpenWindowAction::OpenWindowAction | ( | Window * | win,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Obsolete - use constructor with a dispatcher as input-parameter instead.

Parameters:
win Pointer to the window, which should be opened.

OpenWindowAction::OpenWindowAction | ( | Window * | win,
 |  | BOOLEAN | modal,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Obsolete - use constructor with a dispatcher as input-parameter instead.

Parameters:
win | Pointer to the window, which should be opened.
modal | TRUE to open the window modal, FALSE to open it modeless.

Member Function Documentation

BOOLEAN OpenWindowAction::Execute ( ) [virtual]

Opens the window, which was set with the constructor or the method Init.

Reimplemented from Action.

void OpenWindowAction::Init | ( | Window * | win,
 |  | BOOLEAN | modal,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Obsolete - use a Init with a dispatcher as input-parameter instead.

Parameters:
win | Pointer to the window, which should be opened.
modal | TRUE to open the window modal, FALSE to open it modeless.

void OpenWindowAction::Init | ( | Window * | win,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Obsolete - use a Init with a dispatcher as input-parameter instead.

Parameters:
win Pointer to the window, which should be opened.

void OpenWindowAction::Init | ( | Dispatcher * | dispatcher,
 |  | Window * | win,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon = ImageObtainer(),
 |  | BOOLEAN | modal = FALSE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes. Usually a window or control is used as dispatcher.
win | Pointer to the window, which should be opened.
text | Text of the item. The GUI-component using the item decides whether the text will be shown.
icon | Icon of the item. The GUI-component using the item decides whether the icon will be shown.
modal | TRUE to open the window modal, FALSE to open it modeless.

BOOLEAN OpenWindowAction::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Action.

void OpenWindowAction::SetWindow ( Window * win ) [inline]

The documentation for this class was generated from the following files:
  • Gui/OpenWindowAction.hpp
  • Gui/OpenWindowAction.cpp
Generated on Wed Jan 25 01:34:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OplEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OplEntry Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimAuxHandler.hpp>

Public Types

enum | { c_opl_buffer_len = 8 }

Public Member Functions

UINT16 | GetLacHigh () const
UINT16 | GetLacLow () const
INT | GetPnnRecordId ()
BOOLEAN | HasEntireLacRange () const
BOOLEAN | HasPnnRecordId () const
BOOLEAN | IsBcdPlmnMatching (BcdPlmn checkplmn) const
OplEntry (const UINT8 *buffer)

Data Fields

UINT8 | m_buffer [c_opl_buffer_len]

Member Enumeration Documentation

anonymous enum

Enumerator:
c_opl_buffer_len

The documentation for this class was generated from the following file:
  • Adc/SimAuxHandler.hpp
Generated on Wed Jan 25 01:34:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OptionalConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OptionalConfig Class Reference
[Config]

#include <OptionalConfig.hpp>

Inheritance diagram for OptionalConfig:

[legend]
Collaboration diagram for OptionalConfig:

[legend]

Static Public Member Functions

static BOOLEAN GetSetting (INT group_id, INT setting_id, INT &result)

Detailed Description

Defines the optional configuration for features, which already have a default setting. All features have a group-id and a setting-id, which define a unique key. For descriptions of the group-id and setting-id have a look at the documentation to OptionalConfigBase.

This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

See also:
OptionalConfigBase

Member Function Documentation

static BOOLEAN OptionalConfig::GetSetting | ( | INT | group_id,
 |  | INT | setting_id,
 |  | INT & | result
 | ) | [static]

Returns:
TRUE, if the setting specified by group_id and setting_id is available. The setting will be written to result. Enumerations for group-ids

The documentation for this class was generated from the following file:
  • OptionalConfig.hpp
Generated on Wed Jan 25 01:34:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OptionalConfigBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OptionalConfigBase Class Reference
[GUI]

#include <Apoxi/Gui/OptionalConfigBase.hpp>

Inheritance diagram for OptionalConfigBase:

[legend]

Public Types

enum GroupIds {
Display = 0, Editor = 1, Keyboard = 2, Locale = 3,
Theme = 4, GuiEngine = 5, Custom = 1000
}
enum SettingIds {
DimmedBacklightBrightness = 0, ScrollbarAlignment = 0, ScrollbarDisplayPolicy = 1, MaxDecoderDelay = 2,
ScrollGap = 3, HideClippedText = 4, SmoothScrollSteps = 5, MaxEncoderDelay = 6,
HorizontalScrollBehavior = 7, TabButtonDefaultHeight = 8, TabButtonDefaultWidth = 9, TabButtonMinimumWidth = 10,
TabButtonMaximumWidth = 11, TabButtonClippedWidth = 12, ShowParentPosition = 13, PositionSeparator = 14,
SelectionStyle = 15
}

Detailed Description

Base-class for the class OptionalConfig. Defines enumerations for reserved group-IDs and settings-IDs.

Member Enumeration Documentation

enum OptionalConfigBase::GroupIds

A group ID summarizes settings. The group ID and the settings ID allow to access a unique settings value.

Enumerator:
Display
Editor
Keyboard
Locale
Theme
GuiEngine
Custom

enum OptionalConfigBase::SettingIds

Each setting ID belongs to a group ID. The group ID and the settings ID allow to access a unique settings value.

Enumerator:
DimmedBacklightBrightness
ScrollbarAlignment | Defines alignment of the scrollbar: 0 means scrollbar always on the right, 1 means scrollbar always on the left. It is recommmended to let APOXI decide the alignment dependant from the current used language: right for e. g. English, left for e. g. Arabic. If this is wanted, just don't specify any scrollbar alignment.
ScrollbarDisplayPolicy | Defines the display-policy of the scrollbar: 0 means, that the scrollbar is only displayed, if the number of visible items is smaller than the number of current items (= default). 1 means, that the scrollbar is displayed always and 2 means, that the scrollbar is never displayed.
MaxDecoderDelay | Defines the maximum delay of image decoders in milliseconds: When decoding large images the decoding might need some seconds. To give the user a visual response about the progress, the display is updated when the decoding exceeds the maximum delay. Hence if the maximum delay is set to 500 and the decoding of an images needs 2 seconds, the display is updated 4 times to show the current progress. The default value is 500 milliseconds.
ScrollGap | Defines the gap between the selection and the top/bottom of a scrollable area, where the scrolling should start. Per default the a gap of 0 is used, which means that the scrolling starts after the selection reaches the top/bottom of a scrollable area. The gap is only respected when using the scrollbehaviors DefaultBehavior or RotateBehavior, which may be specified by GuiEngineConfig::GetScrollBehavior(). A gap of -1 indicates, that the selection should always be centered vertically. Using -1 only works with the EndlessLoopBehavior, otherwise the gap will be ignored.
HideClippedText | Hides the text of an item, if it is clipped at the bottom of an ItemTree, ItemMenu or ItemList. 0 means that the text is not hidden and clipped (= default), 1 hides the text. Note that enabling this option should not be necessary if the sizes of the fonts are chosen well. Having an empty space instead of a clipped text does not automatically lead to a well designed screen layout, so enabling this option just hides a weak designed screen layout.
SmoothScrollSteps | Defines the number of steps which should be used for scrolling between two points. A higher value means a smoother scrolling but also might decrease the performance. The default setting 3 is used if no value is set.
MaxEncoderDelay | Delay in milliseconds until the encoder sends a ImageEncodingProgressMsg to the system.
HorizontalScrollBehavior | Defines the scrollbehavior for controls which allow horizontal scrolling (e. g. the TabControl). If 0 is returned, a cyclic scrolling is done (= default). If 1 is returned, reaching the left or right border does not lead to any scrolling.
TabButtonDefaultHeight | Defines the default width of a tab button. This parameter is only used by the DefaultTheme. When implementing a custom theme it might be an alternative option to hardcode this value in the TabButtonView implementation.
TabButtonDefaultWidth | Defines the default width of a tab button. This parameter is only used by the DefaultTheme. When implementing a custom theme it might be an alternative option to hardcode this value in the TabButtonView implementation.
TabButtonMinimumWidth | Defines the minimum width of a tab button. This parameter is only used by the DefaultTheme. When implementing a custom theme it might be an alternative option to hardcode this value in the TabButtonView implementation.
TabButtonMaximumWidth | Defines the maximum width of a tab button. This parameter is only used by the DefaultTheme. When implementing a custom theme it might be an alternative option to hardcode this value in the TabButtonView implementation.
TabButtonClippedWidth | If not all tab buttons fit into the tab control width, TabButtonClippedWidth describes the preferred width of the clipped tab button on the left or right. This parameter is only used by the DefaultTheme. When implementing a custom theme it might be an alternative option to hardcode this value in the TabButtonView implementation.
ShowParentPosition | Defines whether the parent position of an item menu should be shown in the upper right corner of a window (the feature APOXI_ENABLE_POSITION_PREVIEW must be enabled). If 0 is returned, only the position of the currently selected item is shown (= default value). If 1 is returned, the parent position will be shown too. The separator of the positions can be defined also in the class OptionalConfig by the parameter SettingIds::PositionSeparator.
PositionSeparator | Defines the separator which is used between position indicators (see SettingIds::ShowParentPosition). The returned value must be encoded in UCS-2 (e. g. use static_cast<INT>(L'/') for returning a '/' as separator. Per default a '.' is used as separator.
SelectionStyle | Defines the default selection style of the editors. If 0 is returned, the selection style AbstractEditor::InvertedSelection is used (= default setting). If 1 is returned, the selection style AbstractEditor::TransparentSelection is used.

The documentation for this class was generated from the following file:
  • Gui/OptionalConfigBase.hpp
Generated on Wed Jan 25 01:34:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Os Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Os Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/OsClass.hpp>

Static Public Member Functions

static void * | Alloc (INT size, UINT heapid=0)
Allocates a memory block in a certain heap.
static void | DbgOut (UINT16 index, const CHAR *fmt,...)
static void | DbgOut (UINT16 index, const WCHAR *fmt,...)
static void | DbgOut (const CHAR *fmt,...)
static void | DbgOut (const WCHAR *fmt,...)
static void | DbgOutStackUsage ()
static void | Free (void *p, UINT virtid=~0)
Frees a memory block.
static Ticks | GetTicks (void)
static void HUGE * | HugeAlloc (UINT32 size, UINT heapid=0)
Allocates a HUGE memory block in a certain heap.
static void | HugeFree (void HUGE *p, UINT virtid=~0)
Frees a HUGE memory block.
static void HUGE * | HugeRealloc (void HUGE *oldaddress, UINT32 newsize, BOOLEAN shallcopy=FALSE)
Reallocates a HUGE memory block in a certain heap.
static BOOLEAN | IsLineBreak (WCHAR ch)
static BOOLEAN | IsWhiteSpace (WCHAR ch)
static void * | Realloc (void *oldaddress, INT newsize, BOOLEAN shallcopy=FALSE)
Reallocates a memory block in a certain heap.
static void | Sleep (UINT32 timeout)
static void * | StackAlloc (INT size)
Allocates a memory block which can be freed by the stack.
static void | StackFree (void *p)
Frees a memory block which is allocated by the stack.

Detailed Description

This methods are implemented OS specific and shall be called from C++ code.

Member Function Documentation

void * Os::Alloc | ( | INT | size,
 |  | UINT | heapid = 0
 | ) | [static]

Allocates a memory block in a certain heap.

void Os::DbgOut | ( | UINT16 | index,
 |  | const CHAR * | fmt,
 |  |  | ...
 | ) | [static]

void Os::DbgOut | ( | UINT16 | index,
 |  | const WCHAR * | fmt,
 |  |  | ...
 | ) | [static]

void Os::DbgOut | ( | const CHAR * | fmt,
 |  |  | ...
 | ) | [static]

void Os::DbgOut | ( | const WCHAR * | fmt,
 |  |  | ...
 | ) | [static]

void Os::DbgOutStackUsage ( ) [static]

void Os::Free | ( | void * | p,
 |  | UINT | virtid = ~0
 | ) | [static]

Frees a memory block.

Ticks Os::GetTicks ( void ) [static]

void HUGE * Os::HugeAlloc | ( | UINT32 | size,
 |  | UINT | heapid = 0
 | ) | [static]

Allocates a HUGE memory block in a certain heap.

void Os::HugeFree | ( | void HUGE * | p,
 |  | UINT | virtid = ~0
 | ) | [static]

Frees a HUGE memory block.

void HUGE * Os::HugeRealloc | ( | void HUGE * | oldaddress,
 |  | UINT32 | newsize,
 |  | BOOLEAN | shallcopy = FALSE
 | ) | [static]

Reallocates a HUGE memory block in a certain heap.

BOOLEAN Os::IsLineBreak ( WCHAR ch ) [static]

BOOLEAN Os::IsWhiteSpace ( WCHAR ch ) [static]

void * Os::Realloc | ( | void * | oldaddress,
 |  | INT | newsize,
 |  | BOOLEAN | shallcopy = FALSE
 | ) | [static]

Reallocates a memory block in a certain heap.

void Os::Sleep ( UINT32 timeout ) [static]

The Sleep function suspends the execution of the current thread for the specified interval. When using Sleep the message handling of the whole Thread is blocked!

void * Os::StackAlloc ( INT size ) [static]

Allocates a memory block which can be freed by the stack.

void Os::StackFree ( void * p ) [static]

Frees a memory block which is allocated by the stack.

The documentation for this class was generated from the following files:
  • Kernel/Os/OsClass.hpp
  • Kernel/Os/Nuc32/Nuc32.cpp
  • Kernel/Os/Win32/Win32.cpp
Generated on Wed Jan 25 01:34:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OutgoingCallForwardedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OutgoingCallForwardedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for OutgoingCallForwardedMsg:

[legend]
Collaboration diagram for OutgoingCallForwardedMsg:

[legend]

Public Types

enum | { ID = 18532 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
OutgoingCallForwardedMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code)
virtual | ~OutgoingCallForwardedMsg ()

Detailed Description

OutgoingCUGCallMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

OutgoingCallForwardedMsg::OutgoingCallForwardedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code
 | ) |

OutgoingCallForwardedMsg::~OutgoingCallForwardedMsg ( ) [virtual]

Member Function Documentation

Message * OutgoingCallForwardedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & OutgoingCallForwardedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& OutgoingCallForwardedMsg::GetSsCode ( ) const [inline]

const Tipd& OutgoingCallForwardedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:34:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OutputStream Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

OutputStream Class Reference
[Kernel]

#include <Apoxi/Compat/OutputStream.hpp>

Inheritance diagram for OutputStream:

[legend]

Public Member Functions

virtual void | Flush ()
virtual OutputStream & | operator<< (const unsigned long n)
virtual OutputStream & | operator<< (const long n)
virtual OutputStream & | operator<< (const unsigned int n)
virtual OutputStream & | operator<< (const int n)
virtual OutputStream & | operator<< (const unsigned short n)
virtual OutputStream & | operator<< (const short n)
virtual OutputStream & | operator<< (const wchar_t *w)
virtual OutputStream & | operator<< (const signed char *s)
virtual OutputStream & | operator<< (const unsigned char *s)
virtual OutputStream & | operator<< (const char *s)
virtual OutputStream & | operator<< (const signed char c)
virtual OutputStream & | operator<< (const unsigned char c)
virtual OutputStream & | operator<< (const char c)
OutputStream ()
virtual INT | Write (const BYTE *data, INT offset, INT len)
virtual INT | Write (const BYTE *data, INT len)
virtual INT | Write (const BYTE data)=0
virtual | ~OutputStream ()

Constructor & Destructor Documentation

OutputStream::OutputStream ( )

OutputStream::~OutputStream ( ) [virtual]

Member Function Documentation

void OutputStream::Flush ( ) [virtual]

Reimplemented in BufferedOutputStream, DebugOutputStream, FileOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const unsigned long n ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const long n ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const unsigned int n ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const int n ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const unsigned short n ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const short n ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const wchar_t * w ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const signed char * s ) [virtual]

OutputStream & OutputStream::operator<< ( const unsigned char * s ) [virtual]

OutputStream & OutputStream::operator<< ( const char * s ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const signed char c ) [virtual]

Reimplemented in DebugOutputStream.

OutputStream & OutputStream::operator<< ( const unsigned char c ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

OutputStream & OutputStream::operator<< ( const char c ) [virtual]

Reimplemented in DebugOutputStream, and TraceOutputStream.

INT OutputStream::Write | ( | const BYTE * | data,
 |  | INT | offset,
 |  | INT | len
 | ) | [virtual]

INT OutputStream::Write | ( | const BYTE * | data,
 |  | INT | len
 | ) | [virtual]

Reimplemented in BufferedOutputStream, DebugOutputStream, FileOutputStream, and TraceOutputStream.

virtual INT OutputStream::Write ( const BYTE data ) [pure virtual]

Implemented in BufferedOutputStream, DebugOutputStream, FileOutputStream, and TraceOutputStream.

The documentation for this class was generated from the following files:
  • Compat/OutputStream.hpp
  • Compat/OutputStream.cpp
Generated on Wed Jan 25 01:34:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PackedTimePeriod Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PackedTimePeriod Class Reference

3GPP 23.040 V5.1.0 [9.2.3.12.1] More...

#include <Apoxi/Apc/ValidityPeriod.hpp>

Public Types

enum | Unit { FiveMinutes = 5, HalfHourAfter12 = 30, Day = 1440, Week = 10080 }

Public Member Functions

UINT8 | GetCode () const
UINT8 | GetTimes () const
TimeSpan | GetTimeSpan () const
Unit | GetUnit () const
PackedTimePeriod (UINT8 times, Unit unit)
PackedTimePeriod (const TimeSpan &time_span)
PackedTimePeriod (UINT8 code=0)

Detailed Description

3GPP 23.040 V5.1.0 [9.2.3.12.1]

Member Enumeration Documentation

enum PackedTimePeriod::Unit

Enumerator:
FiveMinutes | valid mulitplier are 1..144 (5min - 12h)
HalfHourAfter12 | valid mulitplier are 1..24 (12h30min - 1d)
Day | valid mulitplier are 2..30 (2d - 30d)
Week | valid mulitplier are 5..63 (5w - 63w)

Constructor & Destructor Documentation

PackedTimePeriod::PackedTimePeriod ( UINT8 code = 0 )

PackedTimePeriod::PackedTimePeriod ( const TimeSpan & time_span )

PackedTimePeriod::PackedTimePeriod | ( | UINT8 | times,
 |  | Unit | unit
 | ) |

Member Function Documentation

UINT8 PackedTimePeriod::GetCode ( ) const

UINT8 PackedTimePeriod::GetTimes ( ) const [inline]

TimeSpan PackedTimePeriod::GetTimeSpan ( ) const

Unit PackedTimePeriod::GetUnit ( ) const [inline]

The documentation for this class was generated from the following files:
  • Apc/ValidityPeriod.hpp
  • Apc/ValidityPeriod.cpp
Generated on Wed Jan 25 01:34:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PagingMap Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PagingMap Struct Reference

#include <Apoxi/Gui/PagingMap.hpp>

Collaboration diagram for PagingMap:

[legend]

Public Member Functions

const WCHAR * | GetLowerCaseChar (KeyCode key_code) const
WCHAR | GetNumber (KeyCode key_code) const
const PagingMapEntry & | GetPagingMapEntry (KeyCode key_code) const

Data Fields

const PagingMapEntry * | m_pme

Member Function Documentation

const WCHAR* PagingMap::GetLowerCaseChar ( KeyCode key_code ) const [inline]

WCHAR PagingMap::GetNumber ( KeyCode key_code ) const [inline]

const PagingMapEntry& PagingMap::GetPagingMapEntry ( KeyCode key_code ) const [inline]

Field Documentation

const PagingMapEntry* PagingMap::m_pme

The documentation for this struct was generated from the following file:
  • Gui/PagingMap.hpp
Generated on Wed Jan 25 01:34:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PagingMapEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PagingMapEntry Struct Reference

#include <Apoxi/Gui/PagingMap.hpp>

Public Member Functions

UINT8 | GetKeyCode () const
const WCHAR * | GetLowerCaseChar () const
WCHAR | GetNumber () const
const WCHAR * | GetUpperCaseChar () const
BOOLEAN | IsSwitch () const
BOOLEAN | IsValid () const

Data Fields

UINT8 | keycode
const WCHAR * | lowercase
WCHAR | number
const WCHAR * | uppercase

Member Function Documentation

UINT8 PagingMapEntry::GetKeyCode ( ) const [inline]

const WCHAR* PagingMapEntry::GetLowerCaseChar ( ) const [inline]

WCHAR PagingMapEntry::GetNumber ( ) const [inline]

const WCHAR* PagingMapEntry::GetUpperCaseChar ( ) const [inline]

BOOLEAN PagingMapEntry::IsSwitch ( ) const [inline]

BOOLEAN PagingMapEntry::IsValid ( ) const [inline]

Field Documentation

UINT8 PagingMapEntry::keycode

const WCHAR* PagingMapEntry::lowercase

WCHAR PagingMapEntry::number

const WCHAR* PagingMapEntry::uppercase

The documentation for this struct was generated from the following file:
  • Gui/PagingMap.hpp
Generated on Wed Jan 25 01:34:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PaintDc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PaintDc Class Reference
[GUI]

#include <Apoxi/Gui/PaintDc.hpp>

Inheritance diagram for PaintDc:

[legend]
Collaboration diagram for PaintDc:

[legend]

Public Member Functions

PaintDc (DeviceContext *dc)
virtual ~PaintDc ()
Invokes an EndUpdate.

Detailed Description

Allows a comfortable usage for working on a Device-Context while not changing the default Device-Context. The constructor invokes a BeginUpdate and the destructor invokes an EndUpdate.

Constructor & Destructor Documentation

PaintDc::PaintDc ( DeviceContext * dc )

The paint Device-Context is initialized with the same parameters as given by the default Device-Context and a BeginUpdate is done.

Parameters:
dc Pointer to the default Device-Context.

PaintDc::~PaintDc ( ) [virtual]

Invokes an EndUpdate.

The documentation for this class was generated from the following files:
  • Gui/PaintDc.hpp
  • Gui/PaintDc.cpp
Generated on Wed Jan 25 01:34:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Palette Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Palette Struct Reference
[GUI]

#include <Apoxi/Gui/ColorTable.hpp>

Data Fields

UINT8 | blue
UINT8 | green
UINT8 | red

Field Documentation

UINT8 Palette::blue

UINT8 Palette::green

UINT8 Palette::red

The documentation for this struct was generated from the following file:
  • Gui/ColorTable.hpp
Generated on Wed Jan 25 01:34:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Panel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Panel Class Reference
[GUI]

#include <Apoxi/Gui/Panel.hpp>

Inheritance diagram for Panel:

[legend]
Collaboration diagram for Panel:

[legend]

Public Types

enum | { ID = 17 }

Public Member Functions

XYDIM | GetComponentsSize () const
const Window * | GetOwner () const
virtual BOOLEAN | IsInstanceOf (INT id) const
Panel ()
void | SetOwner (Window *owner)
virtual | ~Panel ()

Protected Member Functions

virtual void | OnLayoutClient ()
virtual void | OnThemeChanged ()

Detailed Description

A Panel is instanciated by each application to show the state of its currently focused window. Per default the softkey-actions of the focused window are synchronized with the panel, so that the panel is responsible for showing the softkey-actions, whereas the window acts as container for the softkey-actions. See also Application::CreatePanel for informations how to instanciate an extended panel.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Window.

Constructor & Destructor Documentation

Panel::Panel ( )

Panel::~Panel ( ) [virtual]

Member Function Documentation

XYDIM Panel::GetComponentsSize ( ) const

const Window* Panel::GetOwner ( ) const [inline]

Returns the owner of the panel, which usually is the top level window of an application.

See also:
Panel::SetOwner

BOOLEAN Panel::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Window.

void Panel::OnLayoutClient ( ) [protected, virtual]

See also:
Component::OnLayoutClient

Reimplemented from Window.

void Panel::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from Window.

void Panel::SetOwner ( Window * owner ) [inline]

Sets the owner of the panel, which usually is the top level window of an application. It should not be necessary to adjust the owner manually, as this is done internally inside APOXI already.

The documentation for this class was generated from the following files:
  • Gui/Panel.hpp
  • Gui/Panel.cpp
Generated on Wed Jan 25 01:34:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PanelView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PanelView Class Reference
[GUI]

Describes the view of a panel. More...

#include <Apoxi/Gui/Panel.hpp>

Inheritance diagram for PanelView:

[legend]
Collaboration diagram for PanelView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
PanelView (XYDIM default_height)
PanelView ()
virtual | ~PanelView ()

Protected Member Functions

virtual void | DrawPanel (const Panel &panel, DeviceContext *dc, const Rect &repaint_rect) const =0

Detailed Description

Describes the view of a panel.

Constructor & Destructor Documentation

PanelView::PanelView ( )

PanelView::PanelView ( XYDIM default_height )

PanelView::~PanelView ( ) [virtual]

Member Function Documentation

void PanelView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

virtual void PanelView::DrawPanel | ( | const Panel & | panel,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Implemented in CTPanelView, DefaultPanelView, and FoggyPanelView.

The documentation for this class was generated from the following files:
  • Gui/Panel.hpp
  • Gui/Panel.cpp
Generated on Wed Jan 25 01:34:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PaneObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PaneObject Class Reference
[GUI]

#include <Apoxi/Gui/GlassPane.hpp>

Inheritance diagram for PaneObject:

[legend]
Collaboration diagram for PaneObject:

[legend]

Public Member Functions

virtual void | Draw (DeviceContext *dc)
const Rect & | GetBoundingRect () const
Point | GetPos () const
Size | GetSize () const
void | Init (const Rect &bounding_rect, AbstractRenderer *renderer=0)
void | Invalidate ()
PaneObject (const Rect &bounding_rect, AbstractRenderer *renderer=0)
PaneObject ()
void | SetBoundingRect (const Rect &bounding_rect)
void | SetPos (XYDIM x, XYDIM y)
void | SetSize (XYDIM width, XYDIM height)
~PaneObject ()

Detailed Description

A pane-object is a graphical object which is part of the glass-pane and is drawn above all windows. Each pane-object has a bounding-rectangle and may have a renderer which is able to draw the content of any object. If no renderer is required, the drawing simply can be done by overwriting the method PaneObject::Draw.

Constructor & Destructor Documentation

PaneObject::PaneObject ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

PaneObject::PaneObject | ( | const Rect & | bounding_rect,
 |  | AbstractRenderer * | renderer = 0
 | ) |

Parameters:
bounding_rect | Rectangle which describes the boundaries.
renderer | Optional parameter which specifies a renderer which is automatically triggered in PaneObject::Draw

PaneObject::~PaneObject ( )

Member Function Documentation

void PaneObject::Draw ( DeviceContext * dc ) [virtual]

If a renderer has been specified, it is triggered automatically which results in drawing the object to be rendered. If no renderer is needed, this method may be overwritten to draw the content of the pane-object.

Reimplemented in IndicatorPaneObject, and IndicatorBarPaneObject.

const Rect& PaneObject::GetBoundingRect ( ) const [inline]

Point PaneObject::GetPos ( ) const

Size PaneObject::GetSize ( ) const

void PaneObject::Init | ( | const Rect & | bounding_rect,
 |  | AbstractRenderer * | renderer = 0
 | ) |

Parameters:
bounding_rect | Rectangle which describes the boundaries.
renderer | Optional parameter which specifies a renderer which is automatically triggered in PaneObject::Draw

void PaneObject::Invalidate ( )

Results into an asynchronous redrawing of the pane-object. This method must be invoked each time the state of the pane-object has been changed.

void PaneObject::SetBoundingRect ( const Rect & bounding_rect )

void PaneObject::SetPos | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

void PaneObject::SetSize | ( | XYDIM | width,
 |  | XYDIM | height
 | ) |

The documentation for this class was generated from the following files:
  • Gui/GlassPane.hpp
  • Gui/GlassPane.cpp
Generated on Wed Jan 25 01:34:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ParagraphCompoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ParagraphCompoundItem Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/ParagraphCompoundItem.hpp>

Inheritance diagram for ParagraphCompoundItem:

[legend]
Collaboration diagram for ParagraphCompoundItem:

[legend]

Public Types

enum | { ID = 11 }

Public Member Functions

virtual void | Clear ()
virtual CompoundItem * | Clone () const
void | ConvertBidiLine (INT item_index, INT count) const
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
UINT8 | GetBottomLineGap () const
const CompoundItem & | GetCompoundItem (INT index, INT *start_index=0) const
INT | GetCompoundItemCount () const
INT | GetCompoundItemIndex (INT item_index) const
virtual INT | GetId () const
virtual INT | GetItemCount () const
LineAlignment | GetLineAlignment (INT index, INT count) const
Returns the line alignment for the paragraph.
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT index, INT count) const
UINT8 | GetTopLineGap () const
BOOLEAN | InsertCompoundItem (CompoundItem *item, INT ci_index=-1)
virtual BOOLEAN | InsertCompoundItemBeforeItem (CompoundItem *comp_item, INT item_index=-1)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | RemoveCompoundItem (INT ci_index=-1)
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
void | SetBottomLineGap (UINT8 gap)
void | SetLineAlignment (LineAlignment alignment)
void | SetTopLineGap (UINT8 gap)
virtual BOOLEAN | Split (INT index, CompoundItem **compound_item)
void | UpdateBidiBuffer () const
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=EditorDocument::WhitespaceWrap) const
virtual | ~ParagraphCompoundItem ()

Static Public Member Functions

static ParagraphCompoundItem * | CreateInstance (LineAlignment alignment=EditorDocument::DefaultAlign)
Creates and returns an object of this class.

Protected Member Functions

void | BeginInternalUpdate ()
void | EndInternalUpdate ()
CompoundItem * | GetCompoundItem (INT index, INT *start_item_index=0)
BOOLEAN | IsInternalUpdate () const
BOOLEAN | MoveToParagraph (ParagraphCompoundItem *paragraph)
ParagraphCompoundItem (LineAlignment alignment=EditorDocument::DefaultAlign)
void | UpdateStartIndices (INT ci_index)

Friends

class | MultiMediaEditorDocument

Detailed Description

Contains a variable number of compound items, which are aligned horizontally by the ParagraphCompoundItem. Note that every ParagraphCompoundItem contains at least one TextCompoundItem with
as last character to indicate the end of a paragraph.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from CompoundItem.

Constructor & Destructor Documentation

ParagraphCompoundItem::~ParagraphCompoundItem ( ) [virtual]

ParagraphCompoundItem::ParagraphCompoundItem ( LineAlignment alignment = EditorDocument::DefaultAlign ) [protected]

Member Function Documentation

void ParagraphCompoundItem::BeginInternalUpdate ( ) [inline, protected]

void ParagraphCompoundItem::Clear ( ) [virtual]

See also:
CompoundItem::Clear

Reimplemented from CompoundItem.

CompoundItem * ParagraphCompoundItem::Clone ( ) const [virtual]

See also:
CompoundItem::Clone

Reimplemented from CompoundItem.

void ParagraphCompoundItem::ConvertBidiLine | ( | INT | item_index,
 |  | INT | count
 | ) | const

Converts the items indicated by item_index and count to a bidirectional layout. It should not be required that this method is invoked by an application directly.

ParagraphCompoundItem * ParagraphCompoundItem::CreateInstance ( LineAlignment alignment = EditorDocument::DefaultAlign ) [static]

Creates and returns an object of this class.

void ParagraphCompoundItem::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::Draw

Implements CompoundItem.

void ParagraphCompoundItem::EndInternalUpdate ( ) [inline, protected]

UINT8 ParagraphCompoundItem::GetBottomLineGap ( ) const [inline]

Returns the gap on the bottom of each line of the paragraph.

See also:
SetBottomLineGap

CompoundItem * ParagraphCompoundItem::GetCompoundItem | ( | INT | index,
 |  | INT * | start_item_index = 0
 | ) | [protected]

Returns the Compound-Item with the index index.

Parameters:
index | Index of the Compound-Item (the number of available compound items can be retrieved by GetCompoundItemCount()).
start_item_index | Output-parameter, which contains the index of the first Item of the Compound-Item compared to all Items of the document.
Returns:
Compound-Item with the given index.

const CompoundItem & ParagraphCompoundItem::GetCompoundItem | ( | INT | index,
 |  | INT * | start_index = 0
 | ) | const

Returns the Compound-Item with the index index.

Parameters:
index | Index of the Compound-Item (the number of available compound items can be retrieved by GetCompoundItemCount()).
start_index | Output-parameter, which contains the index of the first Item of the Compound-Item compared to all Items of the document.
Returns:
Compound-Item with the given index.

INT ParagraphCompoundItem::GetCompoundItemCount ( ) const

Returns the number of compound items of the document. Every paragraph contains at least one compound item.

INT ParagraphCompoundItem::GetCompoundItemIndex ( INT item_index ) const

Returns:
Index of the compound-item, where its start-index >= item_index and the index is inside the range of the compound-item.

INT ParagraphCompoundItem::GetId ( ) const [virtual]

See also:
CompoundItem::GetId()

Reimplemented from CompoundItem.

INT ParagraphCompoundItem::GetItemCount ( ) const [virtual]

See also:
CompoundItem::GetItemCount

Implements CompoundItem.

LineAlignment ParagraphCompoundItem::GetLineAlignment | ( | INT | index,
 |  | INT | count
 | ) | const

Returns the line alignment for the paragraph.

XYDIM ParagraphCompoundItem::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
CompoundItem::GetLineHeight

Implements CompoundItem.

XYDIM ParagraphCompoundItem::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::GetLineWidth

Implements CompoundItem.

UINT8 ParagraphCompoundItem::GetTopLineGap ( ) const [inline]

Returns the gap on the top of each line of the paragraph.

See also:
SetTopLineGap

BOOLEAN ParagraphCompoundItem::InsertCompoundItem | ( | CompoundItem * | item,
 |  | INT | ci_index = -1
 | ) |

Inserts a compound-item, which has to be created by CompoundItem::CreateInstance(), into the paragraph. The paragraph takes care about splitting, merging and deleting compound-items by CompoundItem::ReleaseInstance(), hence the pointer to every passed compound-item might be invalid after invoking InsertCompoundItem (e. g. when inserting the content of the compound-item might be merged to the previous compound-item and the inserted compound-item will be deleted immediatly).

Inserting a paragraph inside a paragraph is not allowed and FALSE is returned. To insert a paragraph into the document use MultiMediaEditorDocument::InsertCompoundItem.

Parameters:
comp_item | Compound-item, which should be inserted.
ci_index | Index of the compound-item, which will be the successor of the compound-item comp_item. If the index is smaller than 0, the compound-item will be appended at the end of the document.
Returns:
TRUE, if the insert-process has been successful.

BOOLEAN ParagraphCompoundItem::InsertCompoundItemBeforeItem | ( | CompoundItem * | comp_item,
 |  | INT | item_index = -1
 | ) | [virtual]

Inserts a compound-item into the paragraph. In opposite to InsertCompoundItem the compound-item can be inserted before a variable item, not only before a compound-item. The paragraph takes care about splitting, merging and deleting compound-items by CompoundItem::ReleaseInstance(), hence the pointer to every passed compound-item might be invalid after invoking InsertCompoundItemBeforeItem (e. g. when inserting the content of the compound-item might be merged to the previous compound-item and the inserted compound-item will be deleted immediatly).

Inserting a paragraph inside a paragraph is not allowed and FALSE is returned. To insert a paragraph into the document use MultiMediaEditorDocument::InsertCompoundItemBeforeItem.

Parameters:
comp_item | Compound-item, which should be inserted.
item_index | Index of the item, which will be the successor of the compound-item comp_item. If the index is smaller than 0, the Compound-Item will be appended at the end of the paragraph.
Returns:
TRUE, if the insert-process has been successful.

BOOLEAN ParagraphCompoundItem::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
CompoundItem::InsertItem

Reimplemented from CompoundItem.

BOOLEAN ParagraphCompoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from CompoundItem.

BOOLEAN ParagraphCompoundItem::IsInternalUpdate ( ) const [inline, protected]

BOOLEAN ParagraphCompoundItem::MoveToParagraph ( ParagraphCompoundItem * paragraph ) [protected]

BOOLEAN ParagraphCompoundItem::RemoveCompoundItem ( INT ci_index = -1 )

Removes the compound item with the given index.

Parameters:
ci_index Index of the compound item, which should be removed. If the index is smaller than 0, the last compound item will be deleted.

BOOLEAN ParagraphCompoundItem::RemoveItem ( INT index = -1 ) [virtual]

See also:
CompoundItem::InsertItem

Reimplemented from CompoundItem.

BOOLEAN ParagraphCompoundItem::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
CompoundItem::InsertItem

Reimplemented from CompoundItem.

void ParagraphCompoundItem::SetBottomLineGap ( UINT8 gap ) [inline]

Every line of a paragraph may have a gap on bottom of the line. Per default the gap is set to 0.

void ParagraphCompoundItem::SetLineAlignment ( LineAlignment alignment ) [inline]

Sets the line alignment for the paragraph. See also EditorDocument::GetLineAlignment.

void ParagraphCompoundItem::SetTopLineGap ( UINT8 gap ) [inline]

Every line of a paragraph may have a gap on top of the line. Per default the gap is set to 0.

BOOLEAN ParagraphCompoundItem::Split | ( | INT | index,
 |  | CompoundItem ** | compound_item
 | ) | [virtual]

See also:
CompoundItem::Split

Reimplemented from CompoundItem.

void ParagraphCompoundItem::UpdateBidiBuffer ( ) const

Updates the text buffer for the bidirectional text engine. It should not be required that this method is invoked by an application directly.

void ParagraphCompoundItem::UpdateStartIndices ( INT ci_index ) [protected]

Updates the start-index of each Compound-Item-Referrer starting at the Compound-Item with the index ci_index.

INT ParagraphCompoundItem::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = EditorDocument::WhitespaceWrap
 | ) | const [virtual]

See also:
CompoundItem::WrapLine

Implements CompoundItem.

Friends And Related Function Documentation

friend class MultiMediaEditorDocument [friend]

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/ParagraphCompoundItem.hpp
  • AddOns/MultiMedia/ParagraphCompoundItem.cpp
Generated on Wed Jan 25 01:34:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ParagraphMarker Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ParagraphMarker Class Reference
[MultiMedia]

Represents the marker at the end of each Paragraph. More...

#include <Apoxi/AddOns/MultiMedia/ParagraphMarker.hpp>

Inheritance diagram for ParagraphMarker:

[legend]
Collaboration diagram for ParagraphMarker:

[legend]

Public Types

enum | { ID = 13 }

Public Member Functions

virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
virtual INT | GetId () const
virtual INT | GetItemCount () const
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT index, INT count) const
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=EditorDocument::WhitespaceWrap) const
virtual | ~ParagraphMarker ()

Static Public Member Functions

static ParagraphMarker * | CreateInstance ()
Creates and returns an object of this class.

Protected Member Functions

ParagraphMarker ()

Detailed Description

Represents the marker at the end of each Paragraph.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from CompoundItem.

Constructor & Destructor Documentation

ParagraphMarker::~ParagraphMarker ( ) [virtual]

ParagraphMarker::ParagraphMarker ( ) [protected]

Member Function Documentation

ParagraphMarker * ParagraphMarker::CreateInstance ( ) [static]

Creates and returns an object of this class.

void ParagraphMarker::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::Draw

Implements CompoundItem.

INT ParagraphMarker::GetId ( ) const [virtual]

See also:
CompoundItem::GetId()

Reimplemented from CompoundItem.

INT ParagraphMarker::GetItemCount ( ) const [virtual]

See also:
CompoundItem::GetItemCount

Implements CompoundItem.

XYDIM ParagraphMarker::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
CompoundItem::GetLineHeight

Implements CompoundItem.

XYDIM ParagraphMarker::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::GetLineWidth

Implements CompoundItem.

BOOLEAN ParagraphMarker::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from CompoundItem.

INT ParagraphMarker::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = EditorDocument::WhitespaceWrap
 | ) | const [virtual]

See also:
CompoundItem::WrapLine

Implements CompoundItem.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/ParagraphMarker.hpp
  • AddOns/MultiMedia/ParagraphMarker.cpp
Generated on Wed Jan 25 01:34:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ParameterIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ParameterIndicator Class Reference

3GPP TS 23.040 V5.1.0 [9.2.3.27] More...

#include <Apoxi/Apc/ParameterIndicator.hpp>

Collaboration diagram for ParameterIndicator:

[legend]

Public Member Functions

void | Clear ()
BOOLEAN | DataCodingSchemeExists () const
BOOLEAN | ExtensionExists () const
UINT8 | Get () const
BOOLEAN | IsValid () const
ParameterIndicator (UINT8 incoming_byte, BOOLEAN valid=FALSE)
ParameterIndicator ()
BOOLEAN | ProtocolIdentifierExists () const
void | SetDataCodingSchemeExists ()
void | SetExtension ()
void | SetProtocolIdentifierExists ()
void | SetUserDataExists ()
void | SetValid (BOOLEAN valid=TRUE)
BOOLEAN | UserDataExists () const

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.3.27]

Constructor & Destructor Documentation

ParameterIndicator::ParameterIndicator ( )

ParameterIndicator::ParameterIndicator | ( | UINT8 | incoming_byte,
 |  | BOOLEAN | valid = FALSE
 | ) |

Member Function Documentation

void ParameterIndicator::Clear ( )

BOOLEAN ParameterIndicator::DataCodingSchemeExists ( ) const

BOOLEAN ParameterIndicator::ExtensionExists ( ) const

UINT8 ParameterIndicator::Get ( ) const

BOOLEAN ParameterIndicator::IsValid ( ) const [inline]

BOOLEAN ParameterIndicator::ProtocolIdentifierExists ( ) const

void ParameterIndicator::SetDataCodingSchemeExists ( )

void ParameterIndicator::SetExtension ( )

void ParameterIndicator::SetProtocolIdentifierExists ( )

void ParameterIndicator::SetUserDataExists ( )

void ParameterIndicator::SetValid ( BOOLEAN valid = TRUE ) [inline]

BOOLEAN ParameterIndicator::UserDataExists ( ) const

The documentation for this class was generated from the following files:
  • Apc/ParameterIndicator.hpp
  • Apc/ParameterIndicator.cpp
Generated on Wed Jan 25 01:34:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PasswordChangeSsAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PasswordChangeSsAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for PasswordChangeSsAction:

[legend]
Collaboration diagram for PasswordChangeSsAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
const WString & | GetNewPassword () const
Returns the password.
const WString & | GetNewPassword2 () const
Returns the password.
const WString & | GetOldPassword () const
Returns the password.
InputParser::SsCode | GetSsCode () const
Returns the ss code.
InputParser::SsProcedure | GetSsProcedure () const
Returns the procedure type.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
PasswordChangeSsAction ()
virtual | ~PasswordChangeSsAction ()

Detailed Description

PasswordChangeSsAction analyzes if the input string has the meaning of changing a password of Supplementary Services. Execute has to be overwritten to implement the sending of the SS string.

Constructor & Destructor Documentation

PasswordChangeSsAction::PasswordChangeSsAction ( )

PasswordChangeSsAction::~PasswordChangeSsAction ( ) [virtual]

Member Function Documentation

InputAction * PasswordChangeSsAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType PasswordChangeSsAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

const WString& PasswordChangeSsAction::GetNewPassword ( ) const [inline]

Returns the password.

const WString& PasswordChangeSsAction::GetNewPassword2 ( ) const [inline]

Returns the password.

const WString& PasswordChangeSsAction::GetOldPassword ( ) const [inline]

Returns the password.

InputParser::SsCode PasswordChangeSsAction::GetSsCode ( ) const [inline]

Returns the ss code.

InputParser::SsProcedure PasswordChangeSsAction::GetSsProcedure ( ) const [inline]

Returns the procedure type.

BOOLEAN PasswordChangeSsAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:34:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PasswordEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PasswordEditor Class Reference
[Editors]

#include <Apoxi/Gui/PasswordEditor.hpp>

Inheritance diagram for PasswordEditor:

[legend]
Collaboration diagram for PasswordEditor:

[legend]

Public Types

enum | { ID = 34 }

Public Member Functions

virtual BOOLEAN | Backspace ()
INT | GetMaxTextLength () const
const WString & | GetText () const
void | Init (Control *parent, INT input_mapper_id, const WCHAR *text=0, BOOLEAN cleartext_mode=FALSE)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
BOOLEAN | IsClearTextModeEnabled ()
virtual BOOLEAN | IsInstanceOf (INT id) const
PasswordEditor (Control *parent, INT input_mapper_id, const WCHAR *text=0, BOOLEAN cleartext_mode=FALSE)
PasswordEditor ()
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
void | SetClearTextModeEnabled (BOOLEAN cleartext)
void | SetMaxTextLength (INT max_tex_len)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetText (const WCHAR *text)
virtual | ~PasswordEditor ()

Protected Member Functions

virtual Model * | CreateModel () const

Detailed Description

Editor for editing passwords in a line. All characters are shown as stars by default, or cleartext if cleartext mode is set to TRUE.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractLineEditor.

Constructor & Destructor Documentation

PasswordEditor::PasswordEditor ( )

PasswordEditor::PasswordEditor | ( | Control * | parent,
 |  | INT | input_mapper_id,
 |  | const WCHAR * | text = 0,
 |  | BOOLEAN | cleartext_mode = FALSE
 | ) |

PasswordEditor::~PasswordEditor ( ) [virtual]

Member Function Documentation

BOOLEAN PasswordEditor::Backspace ( ) [virtual]

See also:
AbstractEditor::Backspace()

Reimplemented from AbstractLineEditor.

Model * PasswordEditor::CreateModel ( ) const [protected, virtual]

Factory method for creating a model. Must be implemented by every class, which needs it's own model. By default a component has no model and 0 is returned. If a model is dynamically created by 'new', it must be deleted in the destructor by e. g. delete GetModel();.

Returns:
Pointer to the model.

Reimplemented from Component.

INT PasswordEditor::GetMaxTextLength ( ) const

const WString & PasswordEditor::GetText ( ) const

void PasswordEditor::Init | ( | Control * | parent,
 |  | INT | input_mapper_id,
 |  | const WCHAR * | text = 0,
 |  | BOOLEAN | cleartext_mode = FALSE
 | ) |

BOOLEAN PasswordEditor::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::InsertItem()

Reimplemented from AbstractLineEditor.

BOOLEAN PasswordEditor::IsClearTextModeEnabled ( ) [inline]

Returns:
TRUE if cleartext mode is enabled, FALSE otherwise.

BOOLEAN PasswordEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractLineEditor.

BOOLEAN PasswordEditor::RemoveItem ( INT index = -1 ) [virtual]

See also:
AbstractEditor::RemoveItem()

Reimplemented from AbstractLineEditor.

BOOLEAN PasswordEditor::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::ReplaceItem()

Reimplemented from AbstractLineEditor.

void PasswordEditor::SetClearTextModeEnabled ( BOOLEAN cleartext )

Sets the clear text mode. Per default cleartext mode is disabled, thus only asterisks are displayed.

Parameters:
cleartext sets the cleartext mode

void PasswordEditor::SetMaxTextLength ( INT max_tex_len )

BOOLEAN PasswordEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractLineEditor.

void PasswordEditor::SetText ( const WCHAR * text )

The documentation for this class was generated from the following files:
  • Gui/PasswordEditor.hpp
  • Gui/PasswordEditor.cpp
Generated on Wed Jan 25 01:34:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PasswordInquiryMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PasswordInquiryMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PasswordInquiryMsg:

[legend]
Collaboration diagram for PasswordInquiryMsg:

[legend]

Public Types

enum | { ID = 18512 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
PasswordInquiryMsg (ExecutionContext *context)
virtual | ~PasswordInquiryMsg ()

Detailed Description

PasswordInquiryMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PasswordInquiryMsg::PasswordInquiryMsg ( ExecutionContext * context )

PasswordInquiryMsg::~PasswordInquiryMsg ( ) [virtual]

Member Function Documentation

Message * PasswordInquiryMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PasswordInquiryMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:34:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PasswordReceivedArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PasswordReceivedArg Struct Reference
[APOXI Stack Control]

Indication of received password, echoed by the network. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for PasswordReceivedArg:

[legend]

Data Fields

SsOperationCode operation_code
The respective call independent supplementary operation code.
WString password
This is used to convey the password for control of supplementary service procedures to MN.

Detailed Description

Indication of received password, echoed by the network.

Field Documentation

SsOperationCode PasswordReceivedArg::operation_code

The respective call independent supplementary operation code.

WString PasswordReceivedArg::password

This is used to convey the password for control of supplementary service procedures to MN.

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 01:34:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PasswordReceivedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PasswordReceivedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PasswordReceivedMsg:

[legend]
Collaboration diagram for PasswordReceivedMsg:

[legend]

Public Types

enum | { ID = 18505 }

Public Member Functions

virtual Message * | Clone () const
const PasswordReceivedArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
PasswordReceivedMsg (ExecutionContext *context, const PasswordReceivedArg &arg)
void | SetArg (const PasswordReceivedArg &arg)
virtual | ~PasswordReceivedMsg ()

Detailed Description

PasswordReceivedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PasswordReceivedMsg::PasswordReceivedMsg | ( | ExecutionContext * | context,
 |  | const PasswordReceivedArg & | arg
 | ) |

PasswordReceivedMsg::~PasswordReceivedMsg ( ) [virtual]

Member Function Documentation

Message * PasswordReceivedMsg::Clone ( ) const [virtual]

Implements Message.

const PasswordReceivedArg& PasswordReceivedMsg::GetArg ( ) const [inline]

const MsgMetaData & PasswordReceivedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void PasswordReceivedMsg::SetArg ( const PasswordReceivedArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:34:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PasswordRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PasswordRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PasswordRejectedMsg:

[legend]
Collaboration diagram for PasswordRejectedMsg:

[legend]

Public Types

enum | { ID = 18513 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
PasswordRejectedMsg (ExecutionContext *context)
virtual | ~PasswordRejectedMsg ()

Detailed Description

PasswordRejectedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PasswordRejectedMsg::PasswordRejectedMsg ( ExecutionContext * context )

PasswordRejectedMsg::~PasswordRejectedMsg ( ) [virtual]

Member Function Documentation

Message * PasswordRejectedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PasswordRejectedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:34:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Path Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Path Class Reference
[Root File System]

Path identifying a file throughout the system. More...

#include <Apoxi/Afs/Rfs/Path.hpp>

Collaboration diagram for Path:

[legend]

Public Member Functions

MimeType | GetMimeType () const
Returns the Mime type extracted from the pathname.
Pathname & GetPathname ()
Returns the pathname of the path for editing.
const Pathname & | GetPathname () const
Returns the pathname of the path.
const WString & | GetStorageDeviceId () const
Returns the storage device Id of the path.
BOOLEAN | operator== (const Path &rhs) const
Equality operator.
Path (const PathProfile &profile)
Path (const Pathname &pathname, const WString &device_Id=L"rfs")
Path ()
void | ReadFrom (const PathProfile &profile)
void | WriteTo (PathProfile &profile) const
~Path ()
Destructs the path.

Detailed Description

Path identifying a file throughout the system.

Class Path uniquely identifies a file or directory on the mobile station. The two components of a path are

  • a storage device Id and
  • a pathname.

Constructor & Destructor Documentation

Path::Path ( )

Constructs a path initialized with the empty storage device Id and the root path.

Path::Path | ( | const Pathname & | pathname,
 |  | const WString & | device_Id = L"rfs"
 | ) | [explicit]

Constructs a path for storage device with Id device_Id and pathname.

Parameters:
pathname | The pathname of the path.
device_Id | The Id of the storage device default initialized to the root storage device.

Path::Path ( const PathProfile & profile )

Constructs a path with information gathered from path profile.

Parameters:
profile The profile the information is gathered from.

Path::~Path ( )

Destructs the path.

Member Function Documentation

MimeType Path::GetMimeType ( ) const [inline]

Returns the Mime type extracted from the pathname.

Pathname& Path::GetPathname ( ) [inline]

Returns the pathname of the path for editing.

const Pathname& Path::GetPathname ( ) const [inline]

Returns the pathname of the path.

const WString& Path::GetStorageDeviceId ( ) const [inline]

Returns the storage device Id of the path.

BOOLEAN Path::operator== ( const Path & rhs ) const

Equality operator.

void Path::ReadFrom ( const PathProfile & profile )

Reads the path from the specified path profile.

Parameters:
profile The path profile storing the path.

void Path::WriteTo ( PathProfile & profile ) const

Writes the path to the specified path profile.

Parameters:
profile The path profile that stores the path.

The documentation for this class was generated from the following files:
  • Afs/Rfs/Path.hpp
  • Afs/Rfs/Path.cpp
Generated on Wed Jan 25 01:35:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Pathname Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Pathname Class Reference
[Root File System]

Pathname identifying a file relative to a storage device. More...

#include <Apoxi/Afs/Rfs/Pathname.hpp>

Collaboration diagram for Pathname:

[legend]

Public Types

enum | { MAX_PATHNAME_LENGTH = APOXI_MAX_PATHNAME_LENGTH }

Public Member Functions

BOOLEAN | Add (const Pathname &pathname)
BOOLEAN | Add (const WString &str)
BOOLEAN | AddFileExtension (MimeType type)
BOOLEAN | AddFileExtension (const WString &file_extension)
Iterator | Begin () const
Iterator | End () const
WString | GetFileExtension () const
WString | GetHead () const
WString | GetLeaf () const
MimeType | GetMimeType () const
WString | GetSegmentAt (UINT segment_idx) const
UINT | GetSegmentCount () const
Returns the number of segments. */.
WString | GetStrippedFileName () const
BOOLEAN | HasExtension () const
Tells if the pathname has an extension.
BOOLEAN | HasLeaf () const
Tells if the pathname has a leaf.
void | Init (const WString &str)
Initializes the pathname to str.
BOOLEAN | IsRoot () const
BOOLEAN | IsValid () const
BOOLEAN | operator!= (const Pathname &rhs) const
BOOLEAN | operator== (const Pathname &rhs) const
Pathname (const Pathname &pathname)
Copy constructor.
Pathname (const WString &str)
Pathname ()
Constructs a pathname initialized to the root pathname /.
BOOLEAN | RemoveFileExtension ()
BOOLEAN | RemoveHead ()
BOOLEAN | RemoveLeaf ()
void | Reset ()
Resets the pathname to the root pathname.
ReverseIterator | ReverseBegin () const
ReverseIterator | ReverseEnd () const
BOOLEAN | SetFileExtension (MimeType type)
BOOLEAN | SetFileExtension (const WString &file_extension)
const WString & | ToWString () const
Returns a WString object containing the pathname.
~Pathname ()
Destroys this pathname object.

Static Public Member Functions

static WString | GetExtensionSeparator ()
Returns the extension separator character as a string.
static WString | GetSeparator ()
Returns the separator character as a string.

Static Public Attributes

static const WCHAR | s_extension_separator = '.'
The character used for separating file extensions.
static const WCHAR | s_root_pathname = s_separator
The pathname of the root, a simple slash /.
static const WCHAR | s_separator = '/'
The character used for separating segments of a pathname.

Protected Member Functions

void | RemoveTrailingSeparators ()

Data Structures

class | Iterator
Iterates over segments of a pathname. More...
class | ReverseIterator
Iterates over segments of a pathname in reverse order. More...

Detailed Description

Pathname identifying a file relative to a storage device.

Class Pathname simplifies the construction of valid pathnames which locate files and directories within some dedicated storage device. Class Pathname supports absolute pathnames only, relative pathnames are not supported. Moreover, symbols like .. for the parent directory or . for the current directory are not supported. Although there might be different storage devices available on the mobile station, class Pathname ignores this fact and only uniquely identifies a file or directory with respect to a distinct storage device. I.e. a pathname does not store the storage device Id string! To uniquely identify a file or directory in the system use class Path which holds the storage device Id string and the pathname.

A pathname consists of segments separated by slashes /. A valid pathname is either the root pathname / or any sequence of slash-segment pairs. A segment is any string not containing any slashes. A segment is allowed to have as many dots . as wanted, thereby supporting extensions. The size of a pathname is not limited. See the following EBNF grammar:

    pathname      = root_pathname | "/" segment { "/" segment }.
    root_pathname = "/".
    segment       = segment_part { "." segment_part }.
    segment_part  = character { character }.

Samples for valid pathnames are:

  • /
  • /mydir
  • /mydir.ext
  • /myfilename
  • /myfilename.ext
  • /mydir/mysubdir
  • /ffs/mydir/mysubdir/myfilename.ext
  • /mydir.ext/myfilename
  • /ffs/mydir.ext/myfilename.ext.ext

Not valid pathnames are:

  • //
  • /mydir/
  • mydir
  • mydir.ext/
  • myfilename
  • myfilename.ext

The string arguments to methods of class Pathname may specify leading or trailing slashes. However, the provided methods try to combine the string arguments with the current pathname in a way that a valid pathname results, e.g., missing separators will be added and adjacent separators will be removed. However, these methods only care for correct concatenation of the argument strings to the current pathname, the argument strings themselves are not checked for validity. Hence, after having constructed a pathname which was constructed with possibly invalid string arguments, e.g. if you construct the pathname using not validated user input, use method IsValid() for checking if the resulting pathname really is ok.

Many functions return a BOOLEAN value stating if the pathname was modified or not. This information might be useful when interactively constructing pathnames to give feedback to the user. If this information is not needed it can simply be ignored. A final check with IsValid() will be enough, too.

The following sample function shows how to use the pathname API:

    static BOOLEAN ConstructPathname()
    {
        Pathname pathname("/dir");

        pathname.Add("subdir");
        pathname.Add("/file");
        pathname.AddFileExtension("txt");
        pathname.AddFileExtension(".doc");
        // The resulting pathname is "/dir/subdir/file.txt.doc".

        WString last_segment = pathname.GetLeaf();
        // The leaf is "file.txt.doc".

        WString file_extension = pathname.GetFileExtension();
        // The file extension is "doc".

        pathname.RemoveFileExtension();
        // The resulting pathname is "/dir/subdir/file.txt".

        pathname.RemoveLeaf();
        // The pathname name is now "/dir/subdir".

        if (!pathname.IsValid()) {
            // The constructed pathname is not valid syntactically. In this example
            // actually the pathname must be valid! However, if you ask a filename
            // from the user then you can validate with this function if it is
            // syntactically correct. Syntactical correctness doesn't tell anything
            // about existence of the file.
            return FALSE;
        }

        return TRUE;
}

Member Enumeration Documentation

anonymous enum

Enumerator:
MAX_PATHNAME_LENGTH The size of a pathname is not limited. However, the size of a pathname that shall be persisted via class PathProfile is limited due to the current persisting mechanism applied. A pathname to be persisted is limited to MAX_PATHNAME_LENGTH characters including the terminating 0 character, i.e. there may be at most MAX_PATHNAME_LENGTH - 1 significant characters in a pathname to be persisted.

Constructor & Destructor Documentation

Pathname::Pathname ( )

Constructs a pathname initialized to the root pathname /.

Pathname::Pathname ( const WString & str )

Constructs a pathname for str. If str is empty then the pathname for the root pathname / is constructed. A missing leading separator will be added and redundant trailing separators will be removed.

Parameters:
str The string describing a file or directory.

Pathname::Pathname ( const Pathname & pathname )

Copy constructor.

Pathname::~Pathname ( )

Destroys this pathname object.

Member Function Documentation

BOOLEAN Pathname::Add ( const Pathname & pathname )

Adds the specified pathname.

See also:
Add(const WString &str)

BOOLEAN Pathname::Add ( const WString & str )

Adds the specified str. If str is empty or the root pathname / then nothing is done. A missing leading separator will be added and redundant trailing separators will be removed. Adjacent separators will be unified. Please see the following example:

            Pathname pathname("dir/");
            // Results in "/dir".

            pathname.Add("/subdir1/subdir2/");
            // Results in "/dir/subdir1/subdir2".

            pathname.Add("filename.ext/");
            // Results in "/dir/subdir1/subdir2/filename.ext".

Parameters:
str The string to add.
Returns:
Tells if str was added.

BOOLEAN Pathname::AddFileExtension ( MimeType type )

Adds a file extension representing MIME type type. There is no check if a file extension is already present, therefor any number of file extensions can be added by subsequent calls. The extension is added with a dot.

Parameters:
type The MIME type defining the extension to append.
Returns:
Tells if the file extension was added.

BOOLEAN Pathname::AddFileExtension ( const WString & file_extension )

Adds a file extension. There is no check if a file extension is already present, therefor any number of file extensions can be added by subsequent calls. The provided file_extension may start with a dot, if it is missing, it is added. A file extension must not start with a slash, in this case it can't be added. The try to add a file extension immediately after a segment separator, i.e. the root pathname /, will fail.

Parameters:
file_extension The file extension to add, with or without the dot ..
Returns:
Tells if file_extension was added.

Pathname::Iterator Pathname::Begin ( ) const

Returns the begin iterator which either points to the first segment of the pathname or is equal to the end iterator if the pathname contains no segments.

Pathname::Iterator Pathname::End ( ) const

Returns the end iterator which points to the end of the pathname. It is the first iterator which doesn't point to a valid segment any more. The end iterator has one past the end semantics.

WString Pathname::GetExtensionSeparator ( ) [static]

Returns the extension separator character as a string.

WString Pathname::GetFileExtension ( ) const

Returns the last file extension. The extension is returned without the dot. Please see the following example:

            Pathname pathname("file");
            // The resulting pathname is "/file".

            pathname.AddFileExtension("txt");
            // The resulting pathname is "/file.txt".

            pathname.AddFileExtension(".doc");
            // The resulting pathname is "/file.txt.doc"

            WString file_extension = pathname.GetFileExtension();
            // The file extension retrieved is "doc".

Returns:
The last file extension without the dot or an empty string object if a file extension is not present.

WString Pathname::GetHead ( ) const

Returns a string object containing the first pathname segment. This is used to get the top level directory name.

WString Pathname::GetLeaf ( ) const

Returns a string object containing the last pathname segment. This is used to get the file or directory name stripped of any leading directories.

MimeType Pathname::GetMimeType ( ) const

Returns the MIME type corresponding to the file extension. If no file extension is present or there is no MIME type defined for the current file extension then c_mime_unknown is returned.

Returns:
The MIME type of the pathname.

WString Pathname::GetSegmentAt ( UINT segment_idx ) const

Returns the pathname segment at the given index segment_idx. If segment_idx is out of range the empty string is returned.

Parameters:
segment_idx The zero-based index of the segment.
Returns:
A string containing the pathname segment at index segment_idx or the empty string if the index is out of range.

UINT Pathname::GetSegmentCount ( ) const

Returns the number of segments. */.

WString Pathname::GetSeparator ( ) [static]

Returns the separator character as a string.

WString Pathname::GetStrippedFileName ( ) const

Returns the file or directory name stripped of any leading directories and the last extension.

BOOLEAN Pathname::HasExtension ( ) const

Tells if the pathname has an extension.

BOOLEAN Pathname::HasLeaf ( ) const

Tells if the pathname has a leaf.

void Pathname::Init ( const WString & str )

Initializes the pathname to str.

BOOLEAN Pathname::IsRoot ( ) const

Returns TRUE if the pathname is equal to root pathname. The return value is FALSE in all other cases.

BOOLEAN Pathname::IsValid ( ) const

Tells if this pathname complies with the pathname syntax. Syntactical correctness doesn't tell anything about existence of the file. Actually, if you programmatically build a filename then you can assure without calling this function that the resulting pathname conforms to the pathname syntax, provided you used a correct initialization string on construction. However, if you ask a filename from the user then you can validate with this function if it is syntactically correct.

BOOLEAN Pathname::operator!= ( const Pathname & rhs ) const [inline]

Compares this pathname to pathname rhs for inequality. The comparison is a mere string compare.

Returns:
Compare result.

BOOLEAN Pathname::operator== ( const Pathname & rhs ) const

Compares this pathname to pathname rhs. The comparison is a mere string compare.

Returns:
Compare result.

BOOLEAN Pathname::RemoveFileExtension ( )

Removes the last file extension inclusive the dot ..

Returns:
Tells if the file extension was removed.

BOOLEAN Pathname::RemoveHead ( )

Removes the first segment of the pathname. If the pathname is the root pathname nothing is done.

Returns:
Tells if the head was removed.

BOOLEAN Pathname::RemoveLeaf ( )

Removes the last segment of the pathname. If the pathname is the root pathname then nothing is done.

Returns:
Tells if the leaf was removed.

void Pathname::RemoveTrailingSeparators ( ) [protected]

Removes any trailing separators. If there is no trailing separator the pathname is unchanged.

void Pathname::Reset ( )

Resets the pathname to the root pathname.

Pathname::ReverseIterator Pathname::ReverseBegin ( ) const

Returns the reverse begin iterator which either points to the last segment of the pathname or is equal to the reverse end iterator if the pathname contains no segments.

Pathname::ReverseIterator Pathname::ReverseEnd ( ) const

Returns the reverse end iterator which points to the start of the pathname. It is the first reverse iterator which doesn't point to a valid segment any more. The end reverse iterator has one before the first semantics.

BOOLEAN Pathname::SetFileExtension ( MimeType type )

Sets the last file extension representing MIME type type. If a file extension is present it is replaced by the specified one. If no file extension is present then the specified one will be added.

Parameters:
type The MIME type defining the extension to set.
Returns:
Tells if the file extension was set.

BOOLEAN Pathname::SetFileExtension ( const WString & file_extension )

Sets the last file extension to file_extension. If a file extension is present it is replaced by the specified one. If no file extension is present then the specified one will be added.

Parameters:
file_extension The file extension to set, with or without the dot ..
Returns:
Tells if the file extension was set.

const WString & Pathname::ToWString ( ) const

Returns a WString object containing the pathname.

Field Documentation

const WCHAR Pathname::s_extension_separator = '.' [static]

The character used for separating file extensions.

const WCHAR Pathname::s_root_pathname = s_separator [static]

The pathname of the root, a simple slash /.

const WCHAR Pathname::s_separator = '/' [static]

The character used for separating segments of a pathname.

The documentation for this class was generated from the following files:
  • Afs/Rfs/Pathname.hpp
  • Afs/Rfs/Pathname.cpp
Generated on Wed Jan 25 01:35:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Pathname::Iterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Pathname::Iterator

Pathname::Iterator Class Reference

Iterates over segments of a pathname. More...

#include <Apoxi/Afs/Rfs/Pathname.hpp>

Collaboration diagram for Pathname::Iterator:

[legend]

Public Member Functions

Iterator ()
Creates an uninitialized iterator.
WString | operator * () const
Returns the segment the iterator points to.
BOOLEAN | operator!= (const Iterator &itor) const
Iterator | operator++ (INT)
Iterator & operator++ ()
BOOLEAN | operator< (const Iterator &itor) const
BOOLEAN | operator== (const Iterator &itor) const
BOOLEAN | operator> (const Iterator &itor) const

Protected Member Functions

Iterator (const WString *str, UINT pos)

Friends

class | Pathname

Detailed Description

Iterates over segments of a pathname.

Class Iterator iterates over the associated pathname sequentially from the first to the last segment. An iterator points to a distinct pathname segment and can be increased and dereferenced, i.e. the pathname segment the iterator points to can be retrieved.

Constructor & Destructor Documentation

Pathname::Iterator::Iterator ( )

Creates an uninitialized iterator.

Pathname::Iterator::Iterator | ( | const WString * | str,
 |  | UINT | pos
 | ) | [protected]

Creates an iterator on str and initializes it to string position pos.

Member Function Documentation

WString Pathname::Iterator::operator * ( ) const

Returns the segment the iterator points to.

BOOLEAN Pathname::Iterator::operator!= ( const Iterator & itor ) const

Checks if this iterator and itor point to different segments.

Pathname::Iterator Pathname::Iterator::operator++ ( INT )

The postfix increment operator. Increments the iterator to point to the next segment and returns an iterator pointing to the segment before having been incremented.

Returns:
Iterator pointing to the segment before having been incremented.

Pathname::Iterator & Pathname::Iterator::operator++ ( )

The prefix increment operator. Increments the iterator to point to the next segment and returns a reference to itself.

Returns:
Reference to the incremented iterator.

BOOLEAN Pathname::Iterator::operator< ( const Iterator & itor ) const

Checks if this iterator points to a segment that is before the segment that itor points to.

BOOLEAN Pathname::Iterator::operator== ( const Iterator & itor ) const

Checks if this iterator and itor point to the same segment.

BOOLEAN Pathname::Iterator::operator> ( const Iterator & itor ) const

Checks if this iterator points to a segment that is after the segment that itor points to.

Friends And Related Function Documentation

friend class Pathname [friend]

The documentation for this class was generated from the following files:
  • Afs/Rfs/Pathname.hpp
  • Afs/Rfs/Pathname.cpp
Generated on Wed Jan 25 01:35:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Pathname::ReverseIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Pathname::ReverseIterator

Pathname::ReverseIterator Class Reference

Iterates over segments of a pathname in reverse order. More...

#include <Apoxi/Afs/Rfs/Pathname.hpp>

Collaboration diagram for Pathname::ReverseIterator:

[legend]

Public Member Functions

WString | operator * () const
Returns the segment the reverse iterator points to.
BOOLEAN | operator!= (const ReverseIterator &itor) const
ReverseIterator | operator++ (INT)
ReverseIterator & operator++ ()
BOOLEAN | operator< (const ReverseIterator &itor) const
BOOLEAN | operator== (const ReverseIterator &itor) const
BOOLEAN | operator> (const ReverseIterator &itor) const
ReverseIterator ()
Creates an uninitialized reverse iterator.

Protected Member Functions

ReverseIterator (const WString *str, UINT pos)

Friends

class | Pathname

Detailed Description

Iterates over segments of a pathname in reverse order.

ReverseIterator iterates over the associated pathname sequentially from the last to the first segment. A reverse iterator points to a distinct pathname segment and can be increased and dereferenced, i.e. the pathname segment the reverse iterator points to can be retrieved.

Constructor & Destructor Documentation

Pathname::ReverseIterator::ReverseIterator ( )

Creates an uninitialized reverse iterator.

Pathname::ReverseIterator::ReverseIterator | ( | const WString * | str,
 |  | UINT | pos
 | ) | [protected]

Creates a reverse iterator on str and initializes it to string position pos.

Member Function Documentation

WString Pathname::ReverseIterator::operator * ( ) const

Returns the segment the reverse iterator points to.

BOOLEAN Pathname::ReverseIterator::operator!= ( const ReverseIterator & itor ) const

Checks if this reverse iterator and itor point to different segments.

Pathname::ReverseIterator Pathname::ReverseIterator::operator++ ( INT )

The postfix increment operator. Increments the reverse iterator to point to the next segment and returns a reverse iterator pointing to the segment before having been incremented.

Returns:
Reverse iterator pointing to the segment before having been incremented.

Pathname::ReverseIterator & Pathname::ReverseIterator::operator++ ( )

The prefix increment operator. Increments the reverse iterator to point to the next segment and returns a reference to itself.

Returns:
Reference to the incremented reverse iterator.

BOOLEAN Pathname::ReverseIterator::operator< ( const ReverseIterator & itor ) const

Checks if this reverse iterator points to a segment that is before the segment that itor points to.

BOOLEAN Pathname::ReverseIterator::operator== ( const ReverseIterator & itor ) const

Checks if this reverse iterator and itor point to the same segment.

BOOLEAN Pathname::ReverseIterator::operator> ( const ReverseIterator & itor ) const

Checks if this reverse iterator points to a segment that is after the segment that itor points to.

Friends And Related Function Documentation

friend class Pathname [friend]

The documentation for this class was generated from the following files:
  • Afs/Rfs/Pathname.hpp
  • Afs/Rfs/Pathname.cpp
Generated on Wed Jan 25 01:35:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PathProfile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PathProfile Class Reference
[Root File System]

Utility class to persist a path. More...

#include <Apoxi/Afs/Rfs/PathProfile.hpp>

Collaboration diagram for PathProfile:

[legend]

Public Member Functions

PathProfile ()
Creates a new path profile.
virtual | ~PathProfile ()
Deletes a path profile.

Protected Member Functions

const Persist & | GetData () const
Gets the persist structure.
Pathname | GetPathname () const
Gets the pathname.
WString | GetStorageDeviceId () const
Gets the storage device Id string.
void | SetData (const Persist &data)
Sets the persist structure.
void | SetPathname (const Pathname &pathname)
Sets the pathname.
void | SetStorageDeviceId (const WString &Id)
Sets the storage device Id string.

Friends

class | Path
Class Path is granted full access to class PathProfile.

Data Structures

struct | Persist
The structure to persist a path profile. More...

Detailed Description

Utility class to persist a path.

Class PathProfile provides a means to persist a pathname in a format which can easily be stored and loaded e.g. to some file. In order to load and store a path, please see the following sample function:

    static BOOLEAN StoreAndLoadPath()
    {
        Path path(Pathname("/file.txt"), L"ffs");
        PathProfile path_profile;

        // Persist the path to the path profile.
        path.WriteTo(path_profile);

        // Write the path profile to some file.
        const UINT num_of_bytes = sizeof(PathProfile);
        const void *write_buf = &path_profile;

        // Write write_buf with size num_of_bytes to some file...

        // ...

        // Read the path profile from some file.
        void *read_buf = &path_profile;

        // Read the path profile into read_buf with size num_of_bytes from some
        // file...

        // Restore the path declaration from path_profile.
        path.ReadFrom(path_profile);
    }

Constructor & Destructor Documentation

PathProfile::PathProfile ( )

Creates a new path profile.

PathProfile::~PathProfile ( ) [virtual]

Deletes a path profile.

Member Function Documentation

const PathProfile::Persist & PathProfile::GetData ( ) const [protected]

Gets the persist structure.

Pathname PathProfile::GetPathname ( ) const [protected]

Gets the pathname.

WString PathProfile::GetStorageDeviceId ( ) const [protected]

Gets the storage device Id string.

void PathProfile::SetData ( const Persist & data ) [protected]

Sets the persist structure.

void PathProfile::SetPathname ( const Pathname & pathname ) [protected]

Sets the pathname.

void PathProfile::SetStorageDeviceId ( const WString & Id ) [protected]

Sets the storage device Id string.

Friends And Related Function Documentation

friend class Path [friend]

Class Path is granted full access to class PathProfile.

The documentation for this class was generated from the following files:
  • Afs/Rfs/PathProfile.hpp
  • Afs/Rfs/PathProfile.cpp
Generated on Wed Jan 25 01:35:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PathProfile::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PathProfile::Persist

PathProfile::Persist Struct Reference

The structure to persist a path profile. More...

#include <Apoxi/Afs/Rfs/PathProfile.hpp>

Public Member Functions

Persist ()

Data Fields

WCHAR | m_Id [RootFileSystem::MAX_STORAGE_DEVICE_ID_LENGTH]
The storage device Id string to persist.
WCHAR | m_sPathname [Pathname::MAX_PATHNAME_LENGTH]
The pathname to persist.

Detailed Description

The structure to persist a path profile.

Constructor & Destructor Documentation

PathProfile::Persist::Persist ( )

Constructs a clean object. All the memory is set to 0.

Field Documentation

WCHAR PathProfile::Persist::m_Id[RootFileSystem::MAX_STORAGE_DEVICE_ID_LENGTH]

The storage device Id string to persist.

WCHAR PathProfile::Persist::m_sPathname[Pathname::MAX_PATHNAME_LENGTH]

The pathname to persist.

The documentation for this struct was generated from the following files:
  • Afs/Rfs/PathProfile.hpp
  • Afs/Rfs/PathProfile.cpp
Generated on Wed Jan 25 01:35:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAbstractWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAbstractWin Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAbstractWin.hpp>

Inheritance diagram for PbAbstractWin:

[legend]
Collaboration diagram for PbAbstractWin:

[legend]

Public Types

enum | MenuIndex { MainMenu = 1, SubMenu = 2 }

Public Member Functions

void | AddMenuAction (INT idx, Action *action, BOOLEAN separate=FALSE)
void | ChangeMenuAction (INT idx, Action *old_action, Action *new_action)
BOOLEAN | GetDisplaySimPos ()
virtual Provider * | GetMyPbProvider ()
PhonebookApp * | GetPbApplication () const
Provider * GetPbProvider ()
const WString & | GetPbTitle ()
virtual void | GetSelectedItem (INT colid, DataItem &item)=0
virtual INT | GetSelectedRow ()=0
void | Init ()
BOOLEAN | IsConfirmed ()
virtual BOOLEAN | IsReadOnly ()
PbAbstractWin ()
void | SetDisplaySimPos (BOOLEAN display_simpos)
void | SetPbProvider (Provider *provider)
void | SetPbTitle (const WString &title)
virtual void | SetSelectedRow (INT)
virtual void | UpdateWin (BOOLEAN win_only=FALSE)
virtual | ~PbAbstractWin ()

Protected Member Functions

virtual void | DisplaySimPos ()
ActionAccessor * | GetAccessor (INT idx)
virtual BOOLEAN | OnCancel ()
virtual void | OnClose ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLanguageChanged ()
virtual void | OnOpen ()
virtual BOOLEAN | OnSoftkeyPressed (INT idx)
void | RestoreSoftkeys ()
virtual void | UpdateEnabledActions ()

Member Enumeration Documentation

enum PbAbstractWin::MenuIndex

Enumerator:
MainMenu
SubMenu

Constructor & Destructor Documentation

PbAbstractWin::PbAbstractWin ( )

PbAbstractWin::~PbAbstractWin ( ) [virtual]

Member Function Documentation

void PbAbstractWin::AddMenuAction | ( | INT | idx,
 |  | Action * | action,
 |  | BOOLEAN | separate = FALSE
 | ) |

void PbAbstractWin::ChangeMenuAction | ( | INT | idx,
 |  | Action * | old_action,
 |  | Action * | new_action
 | ) |

void PbAbstractWin::DisplaySimPos ( ) [protected, virtual]

Reimplemented in PbDetails.

ActionAccessor * PbAbstractWin::GetAccessor ( INT idx ) [protected]

BOOLEAN PbAbstractWin::GetDisplaySimPos ( ) [inline]

Provider * PbAbstractWin::GetMyPbProvider ( ) [virtual]

Reimplemented in AdvPbWin, PbBaseWin, PbDetails, ProvColListBoxWin, and ProvDetailListBoxWin.

PhonebookApp* PbAbstractWin::GetPbApplication ( ) const [inline]

Provider* PbAbstractWin::GetPbProvider ( ) [inline]

const WString& PbAbstractWin::GetPbTitle ( ) [inline]

virtual void PbAbstractWin::GetSelectedItem | ( | INT | colid,
 |  | DataItem & | item
 | ) | [pure virtual]

Implemented in ProvListBoxWin.

virtual INT PbAbstractWin::GetSelectedRow ( ) [pure virtual]

Implemented in AdvPbWin, PbAdvDetails, PbBaseWin, ProvListBoxWin, and ProvDetailListBoxWin.

void PbAbstractWin::Init ( )

BOOLEAN PbAbstractWin::IsConfirmed ( ) [inline]

virtual BOOLEAN PbAbstractWin::IsReadOnly ( ) [inline, virtual]

Reimplemented in PhonebookWin.

BOOLEAN PbAbstractWin::OnCancel ( ) [protected, virtual]

Reimplemented in PbBaseWin, and PbSelectNumberWin.

void PbAbstractWin::OnClose ( ) [protected, virtual]

BOOLEAN PbAbstractWin::OnConfirm ( ) [protected, virtual]

Reimplemented in PbBaseWin, and PbSelectNumberWin.

void PbAbstractWin::OnGetFocus ( ) [protected, virtual]

Reimplemented in PbBaseWin, PbDetails, and ProvListBoxWin.

BOOLEAN PbAbstractWin::OnKeyDown ( KeyCode key_code ) [protected, virtual]

Reimplemented in PbBaseWin.

void PbAbstractWin::OnLanguageChanged ( ) [protected, virtual]

void PbAbstractWin::OnOpen ( ) [protected, virtual]

Reimplemented in PbSelectNumberWin.

BOOLEAN PbAbstractWin::OnSoftkeyPressed ( INT idx ) [protected, virtual]

void PbAbstractWin::RestoreSoftkeys ( ) [protected]

void PbAbstractWin::SetDisplaySimPos ( BOOLEAN display_simpos ) [inline]

Reimplemented in PhonebookWin.

void PbAbstractWin::SetPbProvider ( Provider * provider ) [inline]

void PbAbstractWin::SetPbTitle ( const WString & title )

void PbAbstractWin::SetSelectedRow ( INT ) [virtual]

Reimplemented in ProvListBoxWin.

void PbAbstractWin::UpdateEnabledActions ( ) [protected, virtual]

Reimplemented in PhonebookWin, and ProvDetailListBoxWin.

void PbAbstractWin::UpdateWin ( BOOLEAN win_only = FALSE ) [virtual]

Reimplemented in ProvListBoxWin, and ProvDetailListBoxWin.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAbstractWin.hpp
  • Applications/AdvPhonebook/PbAbstractWin.cpp
Generated on Wed Jan 25 01:35:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbAction:

[legend]
Collaboration diagram for PbAction:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
PhonebookApp * GetPbApplication ()
void | Init (PhonebookApp *pb_app, const WCHAR *text, const BitmapRes *bitmap=0)
PbAction ()
virtual | ~PbAction ()

Constructor & Destructor Documentation

PbAction::PbAction ( )

PbAction::~PbAction ( ) [virtual]

Member Function Documentation

BOOLEAN PbAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from Action.

Reimplemented in PbAddPhoneNoAction, PbConfirmAddNoAction, PbCancelAddNoAction, PbDelPhonenoAction, PbChangeNoTypeAction, PbSelectGroupAction, SyncSimAllAction, SyncPhoneAllAction, SyncSimAction, SyncPhoneAction, PbSecuredAction, PbAddAction, PbEditDetailAction, PbConfirmEditAction, PbCancelEditAction, PbCallAction, PbDeleteAction, PbDelAllAction, SyncAction, DisplayMemoryAction, AddAllToFdnAction, AddEntryToFdnAction, AddNumberToFdnAction, and CopyToPbAction.

PhonebookApp* PbAction::GetPbApplication ( ) [inline]

Reimplemented in AdvPbAction.

void PbAction::Init | ( | PhonebookApp * | pb_app,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | bitmap = 0
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:35:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAddAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAddAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbAddAction:

[legend]
Collaboration diagram for PbAddAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbAddAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:35:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAddPhoneNoAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAddPhoneNoAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for PbAddPhoneNoAction:

[legend]
Collaboration diagram for PbAddPhoneNoAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbAddPhoneNoAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 01:35:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAdvAddEditEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAdvAddEditEntry Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAdvAddEditEntry.hpp>

Collaboration diagram for PbAdvAddEditEntry:

[legend]

Public Member Functions

const WString & | GetName () const
PhoneNumber | GetPhoneNo () const
void | Init ()
PbAdvAddEditEntry ()
void | SetMaxAlphaTagSize (INT ats)
void | SetName (const WString &name)
void | SetPhoneNo (const PhoneNumber &phone_no)

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

PbAdvAddEditEntry::PbAdvAddEditEntry ( )

Member Function Documentation

const WString & PbAdvAddEditEntry::GetName ( ) const

PhoneNumber PbAdvAddEditEntry::GetPhoneNo ( ) const

void PbAdvAddEditEntry::Init ( )

BOOLEAN PbAdvAddEditEntry::OnConfirm ( ) [protected, virtual]

void PbAdvAddEditEntry::OnLayoutClient ( ) [protected, virtual]

void PbAdvAddEditEntry::OnOpen ( ) [protected, virtual]

void PbAdvAddEditEntry::SetMaxAlphaTagSize ( INT ats )

void PbAdvAddEditEntry::SetName ( const WString & name )

void PbAdvAddEditEntry::SetPhoneNo ( const PhoneNumber & phone_no )

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAdvAddEditEntry.hpp
  • Applications/AdvPhonebook/PbAdvAddEditEntry.cpp
Generated on Wed Jan 25 01:35:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAdvDataHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAdvDataHandler Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbAdvDataHandler.hpp>

Inheritance diagram for PbAdvDataHandler:

[legend]
Collaboration diagram for PbAdvDataHandler:

[legend]

Public Member Functions

virtual Provider * | GetDistinctNameProvider ()
UINT32 | GetLastDeletedUniqueId ()
Provider * GetNameProvider ()
Provider * GetNumberProvider ()
virtual Provider * | GetPbProvider ()
void | Init ()
void | ObserveProvider (BOOLEAN observe)
PbAdvDataHandler ()
virtual void | UpdateProvider (ProviderListener *listener=0)
virtual | ~PbAdvDataHandler ()

Constructor & Destructor Documentation

PbAdvDataHandler::PbAdvDataHandler ( )

PbAdvDataHandler::~PbAdvDataHandler ( ) [virtual]

Member Function Documentation

Provider * PbAdvDataHandler::GetDistinctNameProvider ( ) [virtual]

Reimplemented from PbDataHandler.

UINT32 PbAdvDataHandler::GetLastDeletedUniqueId ( ) [inline]

Provider* PbAdvDataHandler::GetNameProvider ( ) [inline]

Provider* PbAdvDataHandler::GetNumberProvider ( ) [inline]

Provider * PbAdvDataHandler::GetPbProvider ( ) [virtual]

Reimplemented from PbDataHandler.

void PbAdvDataHandler::Init ( )

Reimplemented from PbDataHandler.

void PbAdvDataHandler::ObserveProvider ( BOOLEAN observe )

void PbAdvDataHandler::UpdateProvider ( ProviderListener * listener = 0 ) [virtual]

Reimplemented from PbDataHandler.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAdvDataHandler.hpp
  • Applications/AdvPhonebook/PbAdvDataHandler.cpp
Generated on Wed Jan 25 01:35:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAdvDetailAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAdvDetailAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for PbAdvDetailAction:

[legend]
Collaboration diagram for PbAdvDetailAction:

[legend]

Public Member Functions

PbAdvDetails * GetDetailWin ()
void | Init (PbAdvDetails *detail_win, const WCHAR *text)
PbAdvDetailAction (PbAdvDetails *detail_win, const WCHAR *text)
PbAdvDetailAction ()
virtual | ~PbAdvDetailAction ()

Constructor & Destructor Documentation

PbAdvDetailAction::PbAdvDetailAction ( )

PbAdvDetailAction::PbAdvDetailAction | ( | PbAdvDetails * | detail_win,
 |  | const WCHAR * | text
 | ) |

PbAdvDetailAction::~PbAdvDetailAction ( ) [virtual]

Member Function Documentation

PbAdvDetails* PbAdvDetailAction::GetDetailWin ( ) [inline]

void PbAdvDetailAction::Init | ( | PbAdvDetails * | detail_win,
 |  | const WCHAR * | text
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 01:35:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAdvDetails Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAdvDetails Class Reference
[AdvPhonebook]

#include <Applications/AdvPhonebook/PbAdvDetails.hpp>

Inheritance diagram for PbAdvDetails:

[legend]
Collaboration diagram for PbAdvDetails:

[legend]

Public Member Functions

virtual void | AddNumber ()
virtual void | CancelAddNumber ()
virtual INT | GetSelectedRow ()
void | Init (AdvPbApp *pb_app, AdvPbWin *parent, const INT *detail_columns)
PbAdvDetails ()
virtual | ~PbAdvDetails ()

Protected Member Functions

virtual PbDetailProvider * | GetDetailProvider ()
virtual const WString | GetSavedText (INT colid)
virtual void | GetUpdatedItem (INT colid, DataItem &item)

Constructor & Destructor Documentation

PbAdvDetails::PbAdvDetails ( )

PbAdvDetails::~PbAdvDetails ( ) [virtual]

Member Function Documentation

void PbAdvDetails::AddNumber ( ) [virtual]

void PbAdvDetails::CancelAddNumber ( ) [virtual]

PbDetailProvider * PbAdvDetails::GetDetailProvider ( ) [protected, virtual]

Reimplemented from PbDetails.

const WString PbAdvDetails::GetSavedText ( INT colid ) [protected, virtual]

Reimplemented from PbDetails.

INT PbAdvDetails::GetSelectedRow ( ) [virtual]

Reimplemented from ProvDetailListBoxWin.

void PbAdvDetails::GetUpdatedItem | ( | INT | colid,
 |  | DataItem & | item
 | ) | [protected, virtual]

Reimplemented from PbDetails.

void PbAdvDetails::Init | ( | AdvPbApp * | pb_app,
 |  | AdvPbWin * | parent,
 |  | const INT * | detail_columns
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAdvDetails.hpp
  • Applications/AdvPhonebook/PbAdvDetails.cpp
Generated on Wed Jan 25 01:35:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbAlphaTagRequestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbAlphaTagRequestMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PbAlphaTagRequestMsg:

[legend]
Collaboration diagram for PbAlphaTagRequestMsg:

[legend]

Public Types

enum | { ID = 18928 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetPhoneNumber () const
PbAlphaTagRequestMsg (ExecutionContext *context, const PhoneNumber &phone_number)
void | SetPhoneNumber (const PhoneNumber &phone_number)
virtual | ~PbAlphaTagRequestMsg ()

Detailed Description

PbAlphaTagRequestMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbAlphaTagRequestMsg::PbAlphaTagRequestMsg | ( | ExecutionContext * | context,
 |  | const PhoneNumber & | phone_number
 | ) |

PbAlphaTagRequestMsg::~PbAlphaTagRequestMsg ( ) [virtual]

Member Function Documentation

Message * PbAlphaTagRequestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PbAlphaTagRequestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& PbAlphaTagRequestMsg::GetPhoneNumber ( ) const [inline]

void PbAlphaTagRequestMsg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:35:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbBaseProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbBaseProvider Class Reference
[Provider]

#include <Apoxi/Adc/PbBaseProvider.hpp>

Inheritance diagram for PbBaseProvider:

[legend]
Collaboration diagram for PbBaseProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | AppendRow ()
Append a row.
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
SimPbEntry * | GetEntry (INT row)
virtual INT | GetProgress ()
GetProgress indicates the progress of the updating in percent.
virtual INT | GetProviderId () const
Returns the provider id.
virtual INT | GetSortedColumnId () const
If the provider is sorted, overwrite GetSortedColumnId and return the column id of the sorted column.
virtual const WString * | GetWString (INT columnid, INT row)
GetWString returns a pointer to a WString object or zero. em>SetDataItem writes data items to an internal buffer.
void | Init (SimPbBaseHandler *handler, Protector *protector, INT provid)
virtual BOOLEAN | IsWStringDataCached () const
Overwrite IsWStringDataCached if the WString data is cached in RAM (necessary for faster sorting).
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
PbBaseProvider ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener)
Update makes the Provider ready to use and enables listener.
virtual | ~PbBaseProvider ()

Protected Member Functions

void | ClearBufferVariables ()
BOOLEAN | DefaultAppendRow ()
BOOLEAN | DefaultCommitRow (INT row)
BOOLEAN | DefaultDeleteAllRows (ProviderListener *listener=0)
BOOLEAN | DefaultDeleteRow (INT row)
INT | GetAlphaTagSize ()
SimPbBaseHandler * GetHandler ()
INT | GetTagSize ()

Protected Attributes

Number m_commit_cmi_no
PhoneNumber m_commit_phonenumber
WString m_commit_string
SimPbBaseHandler * m_handler
INT | m_provid

Detailed Description

PbBaseProvider is the base provider for all types of SIM phonebooks: ADN GSM 11.11 V8.2.0 10.5.1 FDN GSM 11.11 V8.2.0 10.5.2 MSISDN GSM 11.11 V8.2.0 10.5.5 LND GSM 11.11 V8.2.0 10.5.8 SDN GSM 11.11 V8.2.0 10.5.9 BDN GSM 11.11 V8.2.0 10.5.13 CPHS_MBOX CPHS 4.2 Standard CPHS_INFONO CPHS 4.2 Standard

it allows retrieving data from and changing data on the sim. This class is an abstract base class and cannot be instantiated.

Following column ids are defined: c_simpos_id :NumberType: returns the position in the sim file c_phone_no_id :PhoneNumberType: returns the phonenumber of the entry, might be empty (invalid) c_name_id :WStringType: returns the name of the entry coded in GSM 11.11 V8.2.0 Annex B. c_alphatagsize_id :NumberType: returns the maximal size of the name in bytes. c_nextfreeposition_id :NumberType: returns the next sim storage position. c_freeextrecords_id :NumberType: returns the number of free ext-records for the phonebook. c_index_level_id :NumberType: returns the index level indicator from 0-15, only valid for c_cphs_infono_provider_id. c_nw_spec_id :NumberType: returns if the nework specific indicator is set, only valid for c_cphs_infono_provider_id. c_premium_serv_id :NumberType: returns if the premium service indicator is set, only valid for c_cphs_infono_provider_id. c_cmi_record_id :NumberType: returns the record id which points to the EF-CMI file, only valid for c_bdn_provider_id. If the value 255 is returned or set, the value does not refer to the EF-CMI file. Valid ranges are 1-254, Value 1 represents the Row 0 inside the CmiProvider.

Member Typedef Documentation

typedef ThreadSafeProvider PbBaseProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

PbBaseProvider::PbBaseProvider ( )

PbBaseProvider::~PbBaseProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PbBaseProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

void PbBaseProvider::ClearBufferVariables ( ) [protected]

BOOLEAN PbBaseProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN PbBaseProvider::DefaultAppendRow ( ) [protected]

BOOLEAN PbBaseProvider::DefaultCommitRow ( INT row ) [protected]

BOOLEAN PbBaseProvider::DefaultDeleteAllRows ( ProviderListener * listener = 0 ) [protected]

BOOLEAN PbBaseProvider::DefaultDeleteRow ( INT row ) [protected]

BOOLEAN PbBaseProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from Provider.

BOOLEAN PbBaseProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

INT PbBaseProvider::GetAlphaTagSize ( ) [protected]

BOOLEAN PbBaseProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

SimPbEntry* PbBaseProvider::GetEntry ( INT row ) [inline]

SimPbBaseHandler* PbBaseProvider::GetHandler ( ) [inline, protected]

INT PbBaseProvider::GetProgress ( ) [virtual]

GetProgress indicates the progress of the updating in percent.

Reimplemented from Provider.

INT PbBaseProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

INT PbBaseProvider::GetSortedColumnId ( ) const [virtual]

If the provider is sorted, overwrite GetSortedColumnId and return the column id of the sorted column.

Reimplemented from Provider.

INT PbBaseProvider::GetTagSize ( ) [protected]

const WString * PbBaseProvider::GetWString | ( | INT | columnid,
 |  | INT | row
 | ) | [virtual]

GetWString returns a pointer to a WString object or zero. em>SetDataItem writes data items to an internal buffer.

Reimplemented from Provider.

void PbBaseProvider::Init | ( | SimPbBaseHandler * | handler,
 |  | Protector * | protector,
 |  | INT | provid
 | ) |

BOOLEAN PbBaseProvider::IsWStringDataCached ( ) const [virtual]

Overwrite IsWStringDataCached if the WString data is cached in RAM (necessary for faster sorting).

Reimplemented from Provider.

INT PbBaseProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT PbBaseProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN PbBaseProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN PbBaseProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN PbBaseProvider::Update ( ProviderListener * listener ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

Field Documentation

Number PbBaseProvider::m_commit_cmi_no [protected]

PhoneNumber PbBaseProvider::m_commit_phonenumber [protected]

WString PbBaseProvider::m_commit_string [protected]

SimPbBaseHandler* PbBaseProvider::m_handler [protected]

INT PbBaseProvider::m_provid [protected]

The documentation for this class was generated from the following files:
  • Adc/PbBaseProvider.hpp
  • Adc/PbBaseProvider.cpp
Generated on Wed Jan 25 01:35:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbBaseWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbBaseWin Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbBaseWin.hpp>

Inheritance diagram for PbBaseWin:

[legend]
Collaboration diagram for PbBaseWin:

[legend]

Public Types

typedef ProvColListBoxWin | Base

Public Member Functions

virtual Provider * | GetMyPbProvider ()
virtual INT | GetSelectedRow ()
void | Init (Provider *pb_provider=0, INT sort_colid=c_name_id)
PbBaseWin ()
virtual | ~PbBaseWin ()

Protected Member Functions

virtual INT | GetListBoxRow (INT prov_row)
virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &msg)

Member Typedef Documentation

typedef ProvColListBoxWin PbBaseWin::Base

Reimplemented from ProvColListBoxWin.

Reimplemented in BasicPbWin, PbSelectNumberWin, and PhonebookWin.

Constructor & Destructor Documentation

PbBaseWin::PbBaseWin ( )

PbBaseWin::~PbBaseWin ( ) [virtual]

Member Function Documentation

INT PbBaseWin::GetListBoxRow ( INT prov_row ) [protected, virtual]

Reimplemented from ProvListBoxWin.

Reimplemented in AdvPbWin.

Provider * PbBaseWin::GetMyPbProvider ( ) [virtual]

Reimplemented from ProvColListBoxWin.

Reimplemented in AdvPbWin.

INT PbBaseWin::GetSelectedRow ( ) [virtual]

Reimplemented from ProvListBoxWin.

Reimplemented in AdvPbWin.

void PbBaseWin::Init | ( | Provider * | pb_provider = 0,
 |  | INT | sort_colid = c_name_id
 | ) |

BOOLEAN PbBaseWin::OnCancel ( ) [protected, virtual]

Reimplemented from PbAbstractWin.

Reimplemented in PbSelectNumberWin.

BOOLEAN PbBaseWin::OnConfirm ( ) [protected, virtual]

Reimplemented from PbAbstractWin.

Reimplemented in PbSelectNumberWin.

void PbBaseWin::OnGetFocus ( ) [protected, virtual]

Reimplemented from ProvListBoxWin.

BOOLEAN PbBaseWin::OnKeyDown ( KeyCode key_code ) [protected, virtual]

Reimplemented from PbAbstractWin.

void PbBaseWin::OnLayoutClient ( ) [protected, virtual]

BOOLEAN PbBaseWin::OnMessage ( const Message & msg ) [protected, virtual]

Reimplemented from ProvListBoxWin.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbBaseWin.hpp
  • Applications/AdvPhonebook/PbBaseWin.cpp
Generated on Wed Jan 25 01:35:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbCallAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbCallAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbCallAction:

[legend]
Collaboration diagram for PbCallAction:

[legend]

Public Types

typedef PbAction | Base

Public Member Functions

virtual BOOLEAN | Execute ()

Member Typedef Documentation

typedef PbAction PbCallAction::Base

Reimplemented from PbAction.

Member Function Documentation

BOOLEAN PbCallAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:35:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbCancelAddNoAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbCancelAddNoAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for PbCancelAddNoAction:

[legend]
Collaboration diagram for PbCancelAddNoAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbCancelAddNoAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 01:35:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbCancelEditAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbCancelEditAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbCancelEditAction:

[legend]
Collaboration diagram for PbCancelEditAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbCancelEditAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:35:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbChangeNoTypeAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbChangeNoTypeAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for PbChangeNoTypeAction:

[legend]
Collaboration diagram for PbChangeNoTypeAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbChangeNoTypeAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 01:35:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbConfirmAddNoAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbConfirmAddNoAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for PbConfirmAddNoAction:

[legend]
Collaboration diagram for PbConfirmAddNoAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

virtual BOOLEAN PbConfirmAddNoAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following file:
  • Applications/AdvPhonebook/AdvPbAction.hpp
Generated on Wed Jan 25 01:35:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbConfirmEditAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbConfirmEditAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbConfirmEditAction:

[legend]
Collaboration diagram for PbConfirmEditAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbConfirmEditAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:35:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbCopyHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbCopyHandler Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/CopyHandler.hpp>

Inheritance diagram for PbCopyHandler:

[legend]
Collaboration diagram for PbCopyHandler:

[legend]

Public Member Functions

BOOLEAN | CopyPbRow (INT row)
void | Init (Provider *src_prov, Provider *dst_prov)
PbCopyHandler ()
virtual | ~PbCopyHandler ()

Constructor & Destructor Documentation

PbCopyHandler::PbCopyHandler ( )

PbCopyHandler::~PbCopyHandler ( ) [virtual]

Member Function Documentation

BOOLEAN PbCopyHandler::CopyPbRow ( INT row )

void PbCopyHandler::Init | ( | Provider * | src_prov,
 |  | Provider * | dst_prov
 | ) |

Reimplemented from CopyHandler.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/CopyHandler.hpp
  • Applications/AdvPhonebook/CopyHandler.cpp
Generated on Wed Jan 25 01:35:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbCountIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbCountIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for PbCountIndArg:

[legend]
Collaboration diagram for PbCountIndArg:

[legend]

Public Types

enum | { ID = 1203 }

Public Member Functions

UINT8 | GetCount () const
const PhoneBookCntType & | GetPbCntType () const
const SimUpdateStatus & | GetStatus () const
PbCountIndArg ()
void | SetCount (UINT8 count)
void | SetPbCntType (const PhoneBookCntType &pb_cnt_type)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const PbCountIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PbCountIndArg: reflects arguments of signal SI_PHONE_COUNT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbCountIndArg::PbCountIndArg ( )

Member Function Documentation

const PbCountIndArg & PbCountIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 PbCountIndArg::GetCount ( ) const [inline]

const PhoneBookCntType& PbCountIndArg::GetPbCntType ( ) const [inline]

const SimUpdateStatus& PbCountIndArg::GetStatus ( ) const [inline]

void PbCountIndArg::SetCount ( UINT8 count ) [inline]

void PbCountIndArg::SetPbCntType ( const PhoneBookCntType & pb_cnt_type ) [inline]

void PbCountIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 01:35:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbCountReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbCountReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for PbCountReqArg:

[legend]
Collaboration diagram for PbCountReqArg:

[legend]

Public Types

enum | { ID = 2203 }

Public Member Functions

const PhoneBookCntType & | GetPbCntType () const
PbCountReqArg ()
PbCountReqArg (const PhoneBookCntType &pb_cnt_type)
void | SetPbCntType (const PhoneBookCntType &pb_cnt_type)

Static Public Member Functions

static const PbCountReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PbCountReqArg: reflects arguments of signal SI_PHONE_COUNT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbCountReqArg::PbCountReqArg ( const PhoneBookCntType & pb_cnt_type )

PbCountReqArg::PbCountReqArg ( )

Member Function Documentation

const PbCountReqArg & PbCountReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PhoneBookCntType& PbCountReqArg::GetPbCntType ( ) const [inline]

void PbCountReqArg::SetPbCntType ( const PhoneBookCntType & pb_cnt_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 01:35:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDataHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDataHandler Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbDataHandler.hpp>

Inheritance diagram for PbDataHandler:

[legend]
Collaboration diagram for PbDataHandler:

[legend]

Public Member Functions

Provider * GetAdnProvider ()
Provider * GetBdnProvider ()
virtual Provider * | GetDistinctNameProvider ()
Provider * GetFdnProvider ()
Provider * GetMsIsdnProvider ()
virtual Provider * | GetPbProvider ()
Provider * GetSdnProvider ()
virtual SortProvider * | GetSortedNumberProvider ()
void | Init ()
PbDataHandler ()
virtual void | UpdateProvider (ProviderListener *listener=0)
virtual void | UpdateSortedProvider (ProviderListener *listener=0)
virtual | ~PbDataHandler ()

Constructor & Destructor Documentation

PbDataHandler::PbDataHandler ( )

PbDataHandler::~PbDataHandler ( ) [virtual]

Member Function Documentation

Provider* PbDataHandler::GetAdnProvider ( ) [inline]

Provider* PbDataHandler::GetBdnProvider ( ) [inline]

Provider * PbDataHandler::GetDistinctNameProvider ( ) [virtual]

Reimplemented in PbAdvDataHandler.

Provider* PbDataHandler::GetFdnProvider ( ) [inline]

Provider* PbDataHandler::GetMsIsdnProvider ( ) [inline]

Provider * PbDataHandler::GetPbProvider ( ) [virtual]

Reimplemented in PbAdvDataHandler.

Provider* PbDataHandler::GetSdnProvider ( ) [inline]

SortProvider * PbDataHandler::GetSortedNumberProvider ( ) [virtual]

void PbDataHandler::Init ( )

Reimplemented in PbAdvDataHandler.

void PbDataHandler::UpdateProvider ( ProviderListener * listener = 0 ) [virtual]

Reimplemented in PbAdvDataHandler.

void PbDataHandler::UpdateSortedProvider ( ProviderListener * listener = 0 ) [virtual]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbDataHandler.hpp
  • Applications/AdvPhonebook/PbDataHandler.cpp
Generated on Wed Jan 25 01:35:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDelAllAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDelAllAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbDelAllAction:

[legend]
Collaboration diagram for PbDelAllAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbDelAllAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:35:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDeleteAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDeleteAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbDeleteAction:

[legend]
Collaboration diagram for PbDeleteAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbDeleteAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:35:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDelPhonenoAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDelPhonenoAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for PbDelPhonenoAction:

[legend]
Collaboration diagram for PbDelPhonenoAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbDelPhonenoAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 01:35:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDetailAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDetailAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbDetailAction:

[legend]
Collaboration diagram for PbDetailAction:

[legend]

Public Member Functions

PbDetails * GetDetailWin ()
void | Init (PbDetails *detail_win, const WCHAR *text)
PbDetailAction (PbDetails *detail_win, const WCHAR *text)
PbDetailAction ()
virtual | ~PbDetailAction ()

Constructor & Destructor Documentation

PbDetailAction::PbDetailAction ( )

PbDetailAction::PbDetailAction | ( | PbDetails * | detail_win,
 |  | const WCHAR * | text
 | ) |

PbDetailAction::~PbDetailAction ( ) [virtual]

Member Function Documentation

PbDetails* PbDetailAction::GetDetailWin ( ) [inline]

void PbDetailAction::Init | ( | PbDetails * | detail_win,
 |  | const WCHAR * | text
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:35:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDetailEditBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDetailEditBox Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbDetails.hpp>

Inheritance diagram for PbDetailEditBox:

[legend]
Collaboration diagram for PbDetailEditBox:

[legend]

Public Member Functions

PbDetailEditBox ()
virtual | ~PbDetailEditBox ()

Protected Member Functions

virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Constructor & Destructor Documentation

PbDetailEditBox::PbDetailEditBox ( )

PbDetailEditBox::~PbDetailEditBox ( ) [virtual]

Member Function Documentation

BOOLEAN PbDetailEditBox::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
LineEditor::OnKeyDown

Reimplemented from PbNameEditBox.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbDetails.hpp
  • Applications/AdvPhonebook/PbDetails.cpp
Generated on Wed Jan 25 01:35:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDetailListBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDetailListBox Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbDetailListBox.hpp>

Inheritance diagram for PbDetailListBox:

[legend]
Collaboration diagram for PbDetailListBox:

[legend]

Public Member Functions

INT | GetSelectedNoIndex ()
INT | GetSelectedNoRow ()
const WCHAR * | GetSelectedText ()
XYDIM | GetSelectedYPos () const
void | Init (ProvListBoxWin *parent, const INT *detail_columns, INT filt_colid=c_phone_no_id)
PbDetailListBox (ProvListBoxWin *parent, const INT *detail_columns, INT filt_colid=c_phone_no_id)
PbDetailListBox ()
void | SetDetailColumns (const INT *detail_columns)
void | SetSelectedNoIndex (INT no_idx)
virtual | ~PbDetailListBox ()

Protected Member Functions

virtual Model * | CreateModel () const

Constructor & Destructor Documentation

PbDetailListBox::PbDetailListBox ( )

PbDetailListBox::PbDetailListBox | ( | ProvListBoxWin * | parent,
 |  | const INT * | detail_columns,
 |  | INT | filt_colid = c_phone_no_id
 | ) |

PbDetailListBox::~PbDetailListBox ( ) [virtual]

Member Function Documentation

Model * PbDetailListBox::CreateModel ( ) const [protected, virtual]

INT PbDetailListBox::GetSelectedNoIndex ( ) [inline]

INT PbDetailListBox::GetSelectedNoRow ( ) [inline]

const WCHAR* PbDetailListBox::GetSelectedText ( ) [inline]

XYDIM PbDetailListBox::GetSelectedYPos ( ) const

void PbDetailListBox::Init | ( | ProvListBoxWin * | parent,
 |  | const INT * | detail_columns,
 |  | INT | filt_colid = c_phone_no_id
 | ) |

void PbDetailListBox::SetDetailColumns ( const INT * detail_columns ) [inline]

void PbDetailListBox::SetSelectedNoIndex ( INT no_idx ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbDetailListBox.hpp
  • Applications/AdvPhonebook/PbDetailListBox.cpp
Generated on Wed Jan 25 01:36:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDetailListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDetailListBoxModel Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbDetailListBox.hpp>

Inheritance diagram for PbDetailListBoxModel:

[legend]
Collaboration diagram for PbDetailListBoxModel:

[legend]

Public Member Functions

INT | GetSelectedNoIndex (INT index=-1)
INT | GetSelectedNoRow (INT index=-1)
void | Init (DrawableObjectListBox *listbox, const INT *detail_columns, INT filt_colid=c_phone_no_id)
PbDetailListBoxModel (DrawableObjectListBox *listbox, const INT *detail_columns, INT filt_colid=c_phone_no_id)
PbDetailListBoxModel ()
void | SetDetailColumns (const INT *detail_columns)
void | SetSelectedNoIndex (INT no_index)
virtual void | UpdateNoOfItems ()

Protected Member Functions

virtual INT | GetColumnId (INT index)
virtual INT | GetRow (INT index)

Constructor & Destructor Documentation

PbDetailListBoxModel::PbDetailListBoxModel ( )

PbDetailListBoxModel::PbDetailListBoxModel | ( | DrawableObjectListBox * | listbox,
 |  | const INT * | detail_columns,
 |  | INT | filt_colid = c_phone_no_id
 | ) |

Member Function Documentation

INT PbDetailListBoxModel::GetColumnId ( INT index ) [protected, virtual]

Implements PbProvListBoxModel.

INT PbDetailListBoxModel::GetRow ( INT index ) [protected, virtual]

Reimplemented from PbProvListBoxModel.

INT PbDetailListBoxModel::GetSelectedNoIndex ( INT index = -1 )

INT PbDetailListBoxModel::GetSelectedNoRow ( INT index = -1 )

void PbDetailListBoxModel::Init | ( | DrawableObjectListBox * | listbox,
 |  | const INT * | detail_columns,
 |  | INT | filt_colid = c_phone_no_id
 | ) |

void PbDetailListBoxModel::SetDetailColumns ( const INT * detail_columns )

void PbDetailListBoxModel::SetSelectedNoIndex ( INT no_index )

void PbDetailListBoxModel::UpdateNoOfItems ( ) [virtual]

Reimplemented from PbProvListBoxModel.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbDetailListBox.hpp
  • Applications/AdvPhonebook/PbDetailListBox.cpp
Generated on Wed Jan 25 01:36:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDetailProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDetailProvider Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbDetailFilterProvider.hpp>

Inheritance diagram for PbDetailProvider:

[legend]
Collaboration diagram for PbDetailProvider:

[legend]

Public Member Functions

virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
virtual INT | GetDetailRow ()
const DataItem & | GetKeyItem ()
void | Init (Provider *provider, INT detail_row=c_no_row)
PbDetailProvider (Provider *provider, INT detail_row=c_no_row)
PbDetailProvider ()
virtual INT | RowCount ()
virtual void | SetDetailRow (INT detail_row)
void | SetKeyItem (const DataItem &key_item)
void | SetProvider (Provider *provider)
virtual BOOLEAN | Update (ProviderListener *listener=0)
~PbDetailProvider ()

Constructor & Destructor Documentation

PbDetailProvider::PbDetailProvider ( )

PbDetailProvider::PbDetailProvider | ( | Provider * | provider,
 |  | INT | detail_row = c_no_row
 | ) |

PbDetailProvider::~PbDetailProvider ( )

Member Function Documentation

BOOLEAN PbDetailProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

GetChildRow returns the effective row of the child-provider.

Implements AbstractDelegationProvider.

Reimplemented in PbNumberFilterProvider.

BOOLEAN PbDetailProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
Provider::GetDataItem

Implements AbstractDelegationProvider.

Reimplemented in PbNumberFilterProvider.

INT PbDetailProvider::GetDetailRow ( ) [virtual]

const DataItem& PbDetailProvider::GetKeyItem ( ) [inline]

void PbDetailProvider::Init | ( | Provider * | provider,
 |  | INT | detail_row = c_no_row
 | ) |

Reimplemented in PbNumberFilterProvider.

INT PbDetailProvider::RowCount ( ) [virtual]

RowCount reflects RowCount of the child-provider or 0 if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

Reimplemented in PbNumberFilterProvider.

void PbDetailProvider::SetDetailRow ( INT detail_row ) [virtual]

void PbDetailProvider::SetKeyItem ( const DataItem & key_item ) [inline]

void PbDetailProvider::SetProvider ( Provider * provider ) [inline]

BOOLEAN PbDetailProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update updates the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

Reimplemented in PbNumberFilterProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbDetailFilterProvider.hpp
  • Applications/AdvPhonebook/PbDetailFilterProvider.cpp
Generated on Wed Jan 25 01:36:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbDetails Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbDetails Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbDetails.hpp>

Inheritance diagram for PbDetails:

[legend]
Collaboration diagram for PbDetails:

[legend]

Public Member Functions

virtual void | CancelEdit ()
virtual void | EditDetail ()
virtual Provider * | GetMyPbProvider ()
void | Init (ProvListBoxWin *parent, const INT *detail_columns)
PbDetails ()
virtual void | SaveEdit ()
virtual | ~PbDetails ()

Protected Member Functions

void | CloseEditbox ()
virtual void | DisplaySimPos ()
virtual PbDetailProvider * | GetDetailProvider ()
virtual const WString | GetSavedText (INT colid)
virtual void | GetUpdatedItem (INT colid, DataItem &item)
virtual void | OnGetFocus ()
void | OpenEditBox ()
void | SwitchToEditboxMenu ()

Protected Attributes

PbCancelEditAction m_cancel_editbox_action
PbConfirmEditAction m_confirm_edit_action
PbDetailListBox * m_detail_listbox
PbEditDetailAction m_edit_detail_action
PbDetailEditBox m_editbox

Constructor & Destructor Documentation

PbDetails::PbDetails ( )

PbDetails::~PbDetails ( ) [virtual]

Member Function Documentation

virtual void PbDetails::CancelEdit ( ) [inline, virtual]

void PbDetails::CloseEditbox ( ) [protected]

void PbDetails::DisplaySimPos ( ) [protected, virtual]

Reimplemented from PbAbstractWin.

void PbDetails::EditDetail ( ) [virtual]

virtual PbDetailProvider* PbDetails::GetDetailProvider ( ) [inline, protected, virtual]

Implements ProvDetailListBoxWin.

Reimplemented in PbAdvDetails.

Provider * PbDetails::GetMyPbProvider ( ) [virtual]

Reimplemented from ProvDetailListBoxWin.

const WString PbDetails::GetSavedText ( INT colid ) [protected, virtual]

Reimplemented in PbAdvDetails.

void PbDetails::GetUpdatedItem | ( | INT | colid,
 |  | DataItem & | item
 | ) | [protected, virtual]

Reimplemented in PbAdvDetails.

void PbDetails::Init | ( | ProvListBoxWin * | parent,
 |  | const INT * | detail_columns
 | ) |

void PbDetails::OnGetFocus ( ) [protected, virtual]

Reimplemented from ProvListBoxWin.

void PbDetails::OpenEditBox ( ) [protected]

void PbDetails::SaveEdit ( ) [virtual]

void PbDetails::SwitchToEditboxMenu ( ) [protected]

Field Documentation

PbCancelEditAction PbDetails::m_cancel_editbox_action [protected]

PbConfirmEditAction PbDetails::m_confirm_edit_action [protected]

PbDetailListBox* PbDetails::m_detail_listbox [protected]

Reimplemented from ProvDetailListBoxWin.

PbEditDetailAction PbDetails::m_edit_detail_action [protected]

PbDetailEditBox PbDetails::m_editbox [protected]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbDetails.hpp
  • Applications/AdvPhonebook/PbDetails.cpp
Generated on Wed Jan 25 01:36:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbEditDetailAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbEditDetailAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbEditDetailAction:

[legend]
Collaboration diagram for PbEditDetailAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbEditDetailAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:36:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbEntryReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbEntryReadIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for PbEntryReadIndArg:

[legend]
Collaboration diagram for PbEntryReadIndArg:

[legend]

Public Types

enum | { ID = 1201 }

Public Member Functions

INT | GetAlphaLength () const
INT | GetDataLength () const
const SimPhoneBookEntry & | GetEntry () const
const PhoneBookType & | GetPbtype () const
INT | GetRecno () const
const SimUpdateStatus & | GetStatus () const
PbEntryReadIndArg ()
void | SetAlphaLength (INT alpha_length)
void | SetDataLength (INT data_length)
void | SetEntry (const SimPhoneBookEntry &entry)
void | SetPbtype (const PhoneBookType &pbtype)
void | SetRecno (INT recno)
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const PbEntryReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbEntryReadIndArg::PbEntryReadIndArg ( )

Member Function Documentation

const PbEntryReadIndArg & PbEntryReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT PbEntryReadIndArg::GetAlphaLength ( ) const [inline]

INT PbEntryReadIndArg::GetDataLength ( ) const [inline]

const SimPhoneBookEntry& PbEntryReadIndArg::GetEntry ( ) const [inline]

const PhoneBookType& PbEntryReadIndArg::GetPbtype ( ) const [inline]

INT PbEntryReadIndArg::GetRecno ( ) const [inline]

const SimUpdateStatus& PbEntryReadIndArg::GetStatus ( ) const [inline]

void PbEntryReadIndArg::SetAlphaLength ( INT alpha_length ) [inline]

void PbEntryReadIndArg::SetDataLength ( INT data_length ) [inline]

void PbEntryReadIndArg::SetEntry ( const SimPhoneBookEntry & entry ) [inline]

void PbEntryReadIndArg::SetPbtype ( const PhoneBookType & pbtype ) [inline]

void PbEntryReadIndArg::SetRecno ( INT recno ) [inline]

void PbEntryReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 01:36:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbEntryReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbEntryReadReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for PbEntryReadReqArg:

[legend]
Collaboration diagram for PbEntryReadReqArg:

[legend]

Public Types

enum | { ID = 2201 }

Public Member Functions

const PhoneBookType & | GetPbtype () const
INT | GetRecno () const
PbEntryReadReqArg ()
PbEntryReadReqArg (INT recno, const PhoneBookType &pbtype)
void | SetPbtype (const PhoneBookType &pbtype)
void | SetRecno (INT recno)

Static Public Member Functions

static const PbEntryReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PbEntryReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbEntryReadReqArg::PbEntryReadReqArg | ( | INT | recno,
 |  | const PhoneBookType & | pbtype
 | ) |

PbEntryReadReqArg::PbEntryReadReqArg ( )

Member Function Documentation

const PbEntryReadReqArg & PbEntryReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PhoneBookType& PbEntryReadReqArg::GetPbtype ( ) const [inline]

INT PbEntryReadReqArg::GetRecno ( ) const [inline]

void PbEntryReadReqArg::SetPbtype ( const PhoneBookType & pbtype ) [inline]

void PbEntryReadReqArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 01:36:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbEntryRequestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbEntryRequestMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PbEntryRequestMsg:

[legend]
Collaboration diagram for PbEntryRequestMsg:

[legend]

Public Types

enum | { ID = 18927 }

Public Member Functions

virtual Message * | Clone () const
const MePhoneBookType & | GetMePhoneBookType () const
virtual const MsgMetaData & | GetMetaData () const
INT | GetRecordNumber () const
PbEntryRequestMsg (ExecutionContext *context, const MePhoneBookType &me_phone_book_type, INT record_number)
void | SetMePhoneBookType (const MePhoneBookType &me_phone_book_type)
void | SetRecordNumber (INT record_number)
virtual | ~PbEntryRequestMsg ()

Detailed Description

PbEntryRequestMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbEntryRequestMsg::PbEntryRequestMsg | ( | ExecutionContext * | context,
 |  | const MePhoneBookType & | me_phone_book_type,
 |  | INT | record_number
 | ) |

PbEntryRequestMsg::~PbEntryRequestMsg ( ) [virtual]

Member Function Documentation

Message * PbEntryRequestMsg::Clone ( ) const [virtual]

Implements Message.

const MePhoneBookType& PbEntryRequestMsg::GetMePhoneBookType ( ) const [inline]

const MsgMetaData & PbEntryRequestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

INT PbEntryRequestMsg::GetRecordNumber ( ) const [inline]

void PbEntryRequestMsg::SetMePhoneBookType ( const MePhoneBookType & me_phone_book_type ) [inline]

void PbEntryRequestMsg::SetRecordNumber ( INT record_number ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:36:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbEntryShowAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbEntryShowAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for PbEntryShowAction:

[legend]
Collaboration diagram for PbEntryShowAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
INT | GetEntryNr () const
Returns the phonebook record nummer.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
PbEntryShowAction (INT entrynr)
PbEntryShowAction ()
virtual BOOLEAN | ShallExecuteImmediatly ()
Will always deliver TRUE because input of # shall start execution immediatly.
virtual | ~PbEntryShowAction ()

Detailed Description

PbEntryShowAction analyzes if the input string has the meaning of showing a telephonebook entry with the syntax "sim-recno#" e.g. "23#" will show the record 23 of the ADN phonebook. Execute has to be overwritten to implement the showing of this phonebook entry.

Constructor & Destructor Documentation

PbEntryShowAction::PbEntryShowAction ( )

PbEntryShowAction::PbEntryShowAction ( INT entrynr ) [explicit]

PbEntryShowAction::~PbEntryShowAction ( ) [virtual]

Member Function Documentation

InputAction * PbEntryShowAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType PbEntryShowAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

INT PbEntryShowAction::GetEntryNr ( ) const [inline]

Returns the phonebook record nummer.

BOOLEAN PbEntryShowAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

BOOLEAN PbEntryShowAction::ShallExecuteImmediatly ( ) [virtual]

Will always deliver TRUE because input of # shall start execution immediatly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:36:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbEntryUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbEntryUpdIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for PbEntryUpdIndArg:

[legend]
Collaboration diagram for PbEntryUpdIndArg:

[legend]

Public Types

enum | { ID = 1202 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
PbEntryUpdIndArg ()
void | SetStatus (const SimUpdateStatus &status)

Static Public Member Functions

static const PbEntryUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PbEntryUpdIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbEntryUpdIndArg::PbEntryUpdIndArg ( )

Member Function Documentation

const PbEntryUpdIndArg & PbEntryUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& PbEntryUpdIndArg::GetStatus ( ) const [inline]

void PbEntryUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 01:36:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbEntryUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbEntryUpdReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for PbEntryUpdReqArg:

[legend]
Collaboration diagram for PbEntryUpdReqArg:

[legend]

Public Types

enum | { ID = 2202 }

Public Member Functions

const T_DATA & | GetData () const
const PhoneBookType & | GetPbtype () const
INT | GetRecno () const
PbEntryUpdReqArg ()
PbEntryUpdReqArg (INT recno, const PhoneBookType &pbtype, const T_DATA &data)
PbEntryUpdReqArg (INT recno, const PhoneBookType &pbtype, INT length, const UINT8 *pData)
void | SetData (const T_DATA &data)
void | SetPbtype (const PhoneBookType &pbtype)
void | SetRecno (INT recno)

Static Public Member Functions

static const PbEntryUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PbEntryUpdReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbEntryUpdReqArg::PbEntryUpdReqArg | ( | INT | recno,
 |  | const PhoneBookType & | pbtype,
 |  | INT | length,
 |  | const UINT8 * | pData
 | ) |

PbEntryUpdReqArg::PbEntryUpdReqArg | ( | INT | recno,
 |  | const PhoneBookType & | pbtype,
 |  | const T_DATA & | data
 | ) |

PbEntryUpdReqArg::PbEntryUpdReqArg ( )

Member Function Documentation

const PbEntryUpdReqArg & PbEntryUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& PbEntryUpdReqArg::GetData ( ) const [inline]

const PhoneBookType& PbEntryUpdReqArg::GetPbtype ( ) const [inline]

INT PbEntryUpdReqArg::GetRecno ( ) const [inline]

void PbEntryUpdReqArg::SetData ( const T_DATA & data ) [inline]

void PbEntryUpdReqArg::SetPbtype ( const PhoneBookType & pbtype ) [inline]

void PbEntryUpdReqArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 01:36:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbFfsNameHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbFfsNameHandler Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbFfsNameHandler.hpp>

Inheritance diagram for PbFfsNameHandler:

[legend]
Collaboration diagram for PbFfsNameHandler:

[legend]

Public Member Functions

virtual void | Init ()
virtual INT | MaxRowCount ()
PbFfsNameHandler ()
virtual | ~PbFfsNameHandler ()

Protected Member Functions

virtual Record * | GetDataRecord ()
virtual RecordHandler * | GetDataRecordHandler ()

Detailed Description

The class PbFfsNameHandler will be used to change, write and read phone book entries. All phone book entries will be stored in a file on FFS.

Constructor & Destructor Documentation

PbFfsNameHandler::PbFfsNameHandler ( )

Class constructor

PbFfsNameHandler::~PbFfsNameHandler ( ) [virtual]

Class destructor

Member Function Documentation

virtual Record* PbFfsNameHandler::GetDataRecord ( ) [inline, protected, virtual]

Implements PbRecordHandler.

virtual RecordHandler* PbFfsNameHandler::GetDataRecordHandler ( ) [inline, protected, virtual]

Implements PbRecordHandler.

void PbFfsNameHandler::Init ( ) [virtual]

Class initialisation; File with saved phone book entry will be read from FFS. If no file is existing a new file will be created.

Reimplemented from PbRecordHandler.

INT PbFfsNameHandler::MaxRowCount ( ) [virtual]

Method returns max. number of supported phone book entries.

Returns:
Method returns number of max. supported phone book entries.

Implements PbRecordHandler.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbFfsNameHandler.hpp
  • Applications/AdvPhonebook/PbFfsNameHandler.cpp
Generated on Wed Jan 25 01:36:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbFfsNumberHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbFfsNumberHandler Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbFfsNumberHandler.hpp>

Inheritance diagram for PbFfsNumberHandler:

[legend]
Collaboration diagram for PbFfsNumberHandler:

[legend]

Public Member Functions

void | Init ()
virtual INT | MaxRowCount ()
PbFfsNumberHandler ()
virtual | ~PbFfsNumberHandler ()

Protected Member Functions

virtual Record * | GetDataRecord ()
virtual RecordHandler * | GetDataRecordHandler ()

Detailed Description

The class PbFfsNumberHandler will be used to change, write and read phone numbers. All phone numbers will be stored in a file on FFS.

Constructor & Destructor Documentation

PbFfsNumberHandler::PbFfsNumberHandler ( )

Class constructor

PbFfsNumberHandler::~PbFfsNumberHandler ( ) [virtual]

Class destructor

Member Function Documentation

Record * PbFfsNumberHandler::GetDataRecord ( ) [protected, virtual]

Implements PbRecordHandler.

RecordHandler * PbFfsNumberHandler::GetDataRecordHandler ( ) [protected, virtual]

Implements PbRecordHandler.

void PbFfsNumberHandler::Init ( ) [virtual]

Class initialisation; File with saved phone book entry will be read from FFS. If no file is existing a new file will be created.

Reimplemented from PbRecordHandler.

INT PbFfsNumberHandler::MaxRowCount ( ) [virtual]

Method returns max. number of supported phone numbers.

Returns:
Method returns number of max. supported phone numbers.

Implements PbRecordHandler.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbFfsNumberHandler.hpp
  • Applications/AdvPhonebook/PbFfsNumberHandler.cpp
Generated on Wed Jan 25 01:36:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbInfoReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbInfoReadIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for PbInfoReadIndArg:

[legend]
Collaboration diagram for PbInfoReadIndArg:

[legend]

Public Types

enum | { ID = 1200 }

Public Member Functions

const PhoneBookInfo & | GetInfo () const
PbInfoReadIndArg ()
void | SetInfo (const PhoneBookInfo &info)

Static Public Member Functions

static const PbInfoReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PbInfoReadIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbInfoReadIndArg::PbInfoReadIndArg ( )

Member Function Documentation

const PbInfoReadIndArg & PbInfoReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PhoneBookInfo& PbInfoReadIndArg::GetInfo ( ) const [inline]

void PbInfoReadIndArg::SetInfo ( const PhoneBookInfo & info ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 01:36:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbInfoReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbInfoReadReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for PbInfoReadReqArg:

[legend]
Collaboration diagram for PbInfoReadReqArg:

[legend]

Public Types

enum | { ID = 2200 }

Public Member Functions

PbInfoReadReqArg ()

Static Public Member Functions

static const PbInfoReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PbInfoReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbInfoReadReqArg::PbInfoReadReqArg ( )

Member Function Documentation

const PbInfoReadReqArg & PbInfoReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 01:36:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbLazySynchronizer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbLazySynchronizer Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbLazySynchronizer.hpp>

Inheritance diagram for PbLazySynchronizer:

[legend]
Collaboration diagram for PbLazySynchronizer:

[legend]

Public Member Functions

virtual BOOLEAN | AutoDeletePhone (INT sim_row)
virtual BOOLEAN | AutoDeleteSim (INT phone_row)
virtual BOOLEAN | AutoSyncPhone (INT sim_row)
virtual BOOLEAN | AutoSyncSim (INT phone_row)
PbLazySynchronizer ()
virtual | ~PbLazySynchronizer ()

Protected Member Functions

virtual BOOLEAN | SyncPhone (INT)
virtual BOOLEAN | SyncSim (INT)

Constructor & Destructor Documentation

PbLazySynchronizer::PbLazySynchronizer ( )

PbLazySynchronizer::~PbLazySynchronizer ( ) [virtual]

Member Function Documentation

BOOLEAN PbLazySynchronizer::AutoDeletePhone ( INT sim_row ) [virtual]

Implements PbSynchronizer.

BOOLEAN PbLazySynchronizer::AutoDeleteSim ( INT phone_row ) [virtual]

Implements PbSynchronizer.

BOOLEAN PbLazySynchronizer::AutoSyncPhone ( INT sim_row ) [virtual]

Implements PbSynchronizer.

BOOLEAN PbLazySynchronizer::AutoSyncSim ( INT phone_row ) [virtual]

Implements PbSynchronizer.

BOOLEAN PbLazySynchronizer::SyncPhone ( INT ) [protected, virtual]

Implements PbSynchronizer.

Reimplemented in PbManualSynchronizer.

BOOLEAN PbLazySynchronizer::SyncSim ( INT ) [protected, virtual]

Implements PbSynchronizer.

Reimplemented in PbManualSynchronizer.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbLazySynchronizer.hpp
  • Applications/AdvPhonebook/PbLazySynchronizer.cpp
Generated on Wed Jan 25 01:36:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbManualSynchronizer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbManualSynchronizer Class Reference
[AdvPhonebook]

#include <Applications/AdvPhonebook/PbManualSynchronizer.hpp>

Inheritance diagram for PbManualSynchronizer:

[legend]
Collaboration diagram for PbManualSynchronizer:

[legend]

Public Member Functions

void | Init (PhonebookApp *app, Provider *pb_prov, Provider *sim_prov)
PbManualSynchronizer ()
virtual void | Update ()
virtual | ~PbManualSynchronizer ()

Protected Member Functions

BOOLEAN | AddNumber (INT name_row, const DataItem &phoneno, const DataItem &simpos)
BOOLEAN | AddPbEntry (const DataItem &name, const DataItem &phoneno, const DataItem &sim_pos)
BOOLEAN | AddSimEntry (const DataItem &name, const DataItem &phoneno)
BOOLEAN | AlphaTagSizeError (const WString &str)
BOOLEAN | DoAddNumber (INT name_row)
BOOLEAN | EqualName (INT pb_no_row, INT sim_row)
BOOLEAN | EqualNumber (INT sim_row, INT pb_row)
INT | FindRow (Provider *prov, const DataItem &name, const DataItem &phoneno) const
INT | GetProvRow (Provider *prov, const DataItem &item, INT column_id) const
void | GetUniqueString (WString &str)
void | ShrinkString (WString &str)
virtual BOOLEAN | SyncPhone (INT no_row)
virtual BOOLEAN | SyncSim (INT no_row)
BOOLEAN | UpdateItem (Provider *prov, INT row, const DataItem &item, INT column_id)

Constructor & Destructor Documentation

PbManualSynchronizer::PbManualSynchronizer ( )

PbManualSynchronizer::~PbManualSynchronizer ( ) [virtual]

Member Function Documentation

BOOLEAN PbManualSynchronizer::AddNumber | ( | INT | name_row,
 |  | const DataItem & | phoneno,
 |  | const DataItem & | simpos
 | ) | [protected]

BOOLEAN PbManualSynchronizer::AddPbEntry | ( | const DataItem & | name,
 |  | const DataItem & | phoneno,
 |  | const DataItem & | sim_pos
 | ) | [protected]

BOOLEAN PbManualSynchronizer::AddSimEntry | ( | const DataItem & | name,
 |  | const DataItem & | phoneno
 | ) | [protected]

BOOLEAN PbManualSynchronizer::AlphaTagSizeError ( const WString & str ) [protected]

BOOLEAN PbManualSynchronizer::DoAddNumber ( INT name_row ) [protected]

BOOLEAN PbManualSynchronizer::EqualName | ( | INT | pb_no_row,
 |  | INT | sim_row
 | ) | [protected]

BOOLEAN PbManualSynchronizer::EqualNumber | ( | INT | sim_row,
 |  | INT | pb_row
 | ) | [protected]

INT PbManualSynchronizer::FindRow | ( | Provider * | prov,
 |  | const DataItem & | name,
 |  | const DataItem & | phoneno
 | ) | const [protected]

INT PbManualSynchronizer::GetProvRow | ( | Provider * | prov,
 |  | const DataItem & | item,
 |  | INT | column_id
 | ) | const [protected]

void PbManualSynchronizer::GetUniqueString ( WString & str ) [protected]

void PbManualSynchronizer::Init | ( | PhonebookApp * | app,
 |  | Provider * | pb_prov,
 |  | Provider * | sim_prov
 | ) |

void PbManualSynchronizer::ShrinkString ( WString & str ) [protected]

BOOLEAN PbManualSynchronizer::SyncPhone ( INT no_row ) [protected, virtual]

Reimplemented from PbLazySynchronizer.

BOOLEAN PbManualSynchronizer::SyncSim ( INT no_row ) [protected, virtual]

Reimplemented from PbLazySynchronizer.

void PbManualSynchronizer::Update ( ) [virtual]

Reimplemented from PbSynchronizer.

BOOLEAN PbManualSynchronizer::UpdateItem | ( | Provider * | prov,
 |  | INT | row,
 |  | const DataItem & | item,
 |  | INT | column_id
 | ) | [protected]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbManualSynchronizer.hpp
  • Applications/AdvPhonebook/PbManualSynchronizer.cpp
Generated on Wed Jan 25 01:36:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbMergeProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbMergeProvider Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbMergeProvider.hpp>

Inheritance diagram for PbMergeProvider:

[legend]
Collaboration diagram for PbMergeProvider:

[legend]

Public Member Functions

virtual BOOLEAN | AppendRow ()
Appends a row to the affected provider.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
virtual BOOLEAN | DeleteRow (INT row)
virtual BOOLEAN | GetDefaultDataItem (INT columnid, INT row, DataItem &item)
UINT32 | GetLastDeletedUniqueId ()
void | Init (PbNameProvider *name_prov, PbNumberProvider *no_prov)
virtual INT | MaxRowCount ()
PbMergeProvider ()
virtual BOOLEAN | SetParameter (const DataItem &item)
virtual BOOLEAN | Update (ProviderListener *listener=0)
virtual | ~PbMergeProvider ()

Constructor & Destructor Documentation

PbMergeProvider::PbMergeProvider ( )

PbMergeProvider::~PbMergeProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PbMergeProvider::AppendRow ( ) [virtual]

Appends a row to the affected provider.

Reimplemented from MergeProvider.

BOOLEAN PbMergeProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all merged rows of the affected providers.

See also:
SetParameter

Provider::DeleteAllRows

Reimplemented from MergeProvider.

BOOLEAN PbMergeProvider::DeleteRow ( INT row ) [virtual]

Deletes only the rows of the affected providers.

See also:
SetParameter

Provider::DeleteRow

Reimplemented from MergeProvider.

BOOLEAN PbMergeProvider::GetDefaultDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

Called if GetDataItem is invoked on a column of the merge provider for a row which is not supported by the merge provider. Returns FALSE.

Reimplemented from MergeProvider.

UINT32 PbMergeProvider::GetLastDeletedUniqueId ( ) [inline]

Method to Get the last modified row's unique id..

Returns:
unique id of last modified entry.

void PbMergeProvider::Init | ( | PbNameProvider * | name_prov,
 |  | PbNumberProvider * | no_prov
 | ) |

INT PbMergeProvider::MaxRowCount ( ) [virtual]

RowCount reflects MaxRowCount of the child-provider or 0 if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

BOOLEAN PbMergeProvider::SetParameter ( const DataItem & item ) [virtual]

Set the affected providers for all modifying operations using AffectedProvider enum as number type in item.

Reimplemented from MergeProvider.

BOOLEAN PbMergeProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update updates both underlaying providers if they are not up to date and forces a new merge.

Reimplemented from MergeProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbMergeProvider.hpp
  • Applications/AdvPhonebook/PbMergeProvider.cpp
Generated on Wed Jan 25 01:36:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNameEditBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNameEditBox Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbNameEditBox.hpp>

Inheritance diagram for PbNameEditBox:

[legend]
Collaboration diagram for PbNameEditBox:

[legend]

Public Member Functions

void | Init (Control *parent)
PbNameEditBox ()
void | SetMaxAlphaTagSize (INT max_ats)
virtual | ~PbNameEditBox ()

Protected Member Functions

virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Constructor & Destructor Documentation

PbNameEditBox::PbNameEditBox ( )

PbNameEditBox::~PbNameEditBox ( ) [virtual]

Member Function Documentation

void PbNameEditBox::Init ( Control * parent )

BOOLEAN PbNameEditBox::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
LineEditor::OnKeyDown

Reimplemented from AbstractLineEditor.

Reimplemented in PbDetailEditBox.

void PbNameEditBox::SetMaxAlphaTagSize ( INT max_ats ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNameEditBox.hpp
  • Applications/AdvPhonebook/PbNameEditBox.cpp
Generated on Wed Jan 25 01:36:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNameFilterProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNameFilterProvider Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbNameFilterProvider.hpp>

Inheritance diagram for PbNameFilterProvider:

[legend]
Collaboration diagram for PbNameFilterProvider:

[legend]

Public Types

typedef FilterProvider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
GetProviderId() reflects the provider Id of the child-provider.
virtual Status | GetStatus () const
Returns the status of the provider.
PbNameFilterProvider (Provider *provider, FilterRule *rule, INT columnid=0, BOOLEAN negation=FALSE)
PbNameFilterProvider ()
virtual BOOLEAN | SetParameter (const DataItem &item)
virtual BOOLEAN | Update (ProviderListener *listener)
Update makes the Provider ready to use and starts the filter process.
virtual | ~PbNameFilterProvider ()

Member Typedef Documentation

typedef FilterProvider PbNameFilterProvider::Base

Reimplemented from FilterProvider.

Constructor & Destructor Documentation

PbNameFilterProvider::PbNameFilterProvider ( )

PbNameFilterProvider::PbNameFilterProvider | ( | Provider * | provider,
 |  | FilterRule * | rule,
 |  | INT | columnid = 0,
 |  | BOOLEAN | negation = FALSE
 | ) |

PbNameFilterProvider::~PbNameFilterProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PbNameFilterProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Reimplemented from FilterProvider.

INT PbNameFilterProvider::GetProviderId ( ) const [virtual]

GetProviderId() reflects the provider Id of the child-provider.

Reimplemented from AbstractDelegationProvider.

Provider::Status PbNameFilterProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

BOOLEAN PbNameFilterProvider::SetParameter ( const DataItem & item ) [virtual]

GetColumnInfoPerId reflects GetColumnInfoPerId of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from FilterProvider.

BOOLEAN PbNameFilterProvider::Update ( ProviderListener * listener ) [virtual]

Update makes the Provider ready to use and starts the filter process.

Reimplemented from FilterProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNameFilterProvider.hpp
  • Applications/AdvPhonebook/PbNameFilterProvider.cpp
Generated on Wed Jan 25 01:36:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNameHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNameHandler Class Reference

#include <Applications/AdvPhonebook/PbNameHandler.hpp>

Inheritance diagram for PbNameHandler:

[legend]
Collaboration diagram for PbNameHandler:

[legend]

Public Member Functions

virtual void | Init ()
PbNameHandler ()
virtual | ~PbNameHandler ()

Protected Member Functions

virtual DataRecord * | GetDataRecord ()
virtual DataRecordHandler * | GetDataRecordHandler ()

Constructor & Destructor Documentation

PbNameHandler::PbNameHandler ( )

PbNameHandler::~PbNameHandler ( ) [virtual]

Member Function Documentation

virtual DataRecord* PbNameHandler::GetDataRecord ( ) [inline, protected, virtual]

Implements PbRecordHandler.

virtual DataRecordHandler* PbNameHandler::GetDataRecordHandler ( ) [inline, protected, virtual]

Implements PbRecordHandler.

void PbNameHandler::Init ( ) [virtual]

Reimplemented from PbRecordHandler.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNameHandler.hpp
  • Applications/AdvPhonebook/PbNameHandler.cpp
Generated on Wed Jan 25 01:36:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNameNumberProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNameNumberProvider Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbNameNumberProvider.hpp>

Inheritance diagram for PbNameNumberProvider:

[legend]
Collaboration diagram for PbNameNumberProvider:

[legend]

Public Types

typedef AbstractDelegationProvider | Base

Public Member Functions

virtual BOOLEAN | GetChildRow (INT &child_row, INT row)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
virtual INT | GetProviderId () const
GetProviderId() reflects the provider Id of the child-provider.
void | Init (Provider *provider)
The same interface as the constructor.
PbNameNumberProvider (Provider *provider)
PbNameNumberProvider ()
virtual | ~PbNameNumberProvider ()

Member Typedef Documentation

typedef AbstractDelegationProvider PbNameNumberProvider::Base

Reimplemented from AbstractDelegationProvider.

Constructor & Destructor Documentation

PbNameNumberProvider::PbNameNumberProvider ( )

PbNameNumberProvider::PbNameNumberProvider ( Provider * provider )

PbNameNumberProvider::~PbNameNumberProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PbNameNumberProvider::GetChildRow | ( | INT & | child_row,
 |  | INT | row
 | ) | [virtual]

GetChildRow returns the effective row of the child-provider.

Implements AbstractDelegationProvider.

BOOLEAN PbNameNumberProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
Provider::GetDataItem

Implements AbstractDelegationProvider.

INT PbNameNumberProvider::GetProviderId ( ) const [virtual]

GetProviderId() reflects the provider Id of the child-provider.

Reimplemented from AbstractDelegationProvider.

void PbNameNumberProvider::Init ( Provider * provider )

The same interface as the constructor.

Reimplemented from AbstractDelegationProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNameNumberProvider.hpp
  • Applications/AdvPhonebook/PbNameNumberProvider.cpp
Generated on Wed Jan 25 01:36:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNameProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNameProvider Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbNameProvider.hpp>

Inheritance diagram for PbNameProvider:

[legend]
Collaboration diagram for PbNameProvider:

[legend]

Public Types

typedef PbRecordProvider | Base

Public Member Functions

virtual BOOLEAN | AppendRow ()
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
virtual BOOLEAN | DeleteRow (INT row)
virtual BOOLEAN | GetDataItem (IN INT columnid, IN INT row, OUT DataItem &item)
INT | GetNameRowForRecNo (Number record_number)
virtual INT | GetProviderId () const
void | Init (Protector *protector, PbRecordHandler *name_handler)
PbNameProvider (Protector *protector, PbRecordHandler *name_handler)
PbNameProvider ()
virtual BOOLEAN | SetDataItem (IN const DataItem &item, IN INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
virtual | ~PbNameProvider ()

Protected Member Functions

virtual Record * | GetDataRecord ()
virtual void | InitRecord ()

Detailed Description

The class PbNameProvider will be used to store phone book entries in non-volatile memory. All methods to take access to phone book entries are defined in this class.

Member Typedef Documentation

typedef PbRecordProvider PbNameProvider::Base

Reimplemented from PbRecordProvider.

Constructor & Destructor Documentation

PbNameProvider::PbNameProvider ( )

Class constructor

PbNameProvider::PbNameProvider | ( | Protector * | protector,
 |  | PbRecordHandler * | name_handler
 | ) |

Class constructor with predefined protector and handler;

Parameters:
protector | Necessary to prevent the generation of more than one instances of this class at the same time.
name_handler | This handler defines the data storage process.

PbNameProvider::~PbNameProvider ( ) [virtual]

Class destructor;

Member Function Documentation

BOOLEAN PbNameProvider::AppendRow ( ) [virtual]

Method adds a new phone book entry data row.

Returns:
Method returns TRUE if new phone book entry data was added successful.

Reimplemented from PbRecordProvider.

BOOLEAN PbNameProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Method deletes all phone book entry data rows.

Returns:
Method returns TRUE in case of successful data deletion.

Reimplemented from PbRecordProvider.

BOOLEAN PbNameProvider::DeleteRow ( INT row ) [virtual]

Method deletes a specific phone book entry data row.

Parameters:
row Phone book entry data row that should be deleted.
Returns:
Method returns TRUE in case of successful data deletion.

Reimplemented from PbRecordProvider.

virtual BOOLEAN PbNameProvider::GetDataItem | ( | IN INT | columnid,
 |  | IN INT | row,
 |  | OUT DataItem & | item
 | ) | [virtual]

Method reads a certain phone book entry data item.

Parameters:
columnid | Provider column identifier to determine the data field that should be read.
row | Provider row identifier.
item | Pointer to data item. The read data will be saved in this structure.
Returns:
Method returns TRUE if all parameter values are valid and the several provider settings could be read without any errors.

Implements PbRecordProvider.

Record * PbNameProvider::GetDataRecord ( ) [protected, virtual]

Implements PbRecordProvider.

INT PbNameProvider::GetNameRowForRecNo ( Number record_number )

INT PbNameProvider::GetProviderId ( ) const [virtual]

Method returns the phone book entry provider ID.

Returns:
hone book entry provider ID

Implements Provider.

void PbNameProvider::Init | ( | Protector * | protector,
 |  | PbRecordHandler * | name_handler
 | ) |

Class initialisation; File with saved phone book entry will be read from FFS. If no file is existing a new file will be created.

Parameters:
protector | Necessary to prevent the generation of more than one instances of this class at the same time.
name_handler | This handler defines the data storage process.

Reimplemented from PbRecordProvider.

void PbNameProvider::InitRecord ( ) [protected, virtual]

Implements PbRecordProvider.

virtual BOOLEAN PbNameProvider::SetDataItem | ( | IN const DataItem & | item,
 |  | IN INT | columnid
 | ) | [virtual]

Method saves phone book entry data in file.

Parameters:
item | Pointer to data item with data that should be stored in a file.
columnid | Provider column identifier to determine the data field that should be replaced.
Returns:
Method returns TRUE if all parameter values are valid and the several provider settings could be saved without any errors.

Implements PbRecordProvider.

BOOLEAN PbNameProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Method makes the Provider ready to use, enables listener and reloads the phone book entry data from FFS.

Parameters:
listener Pointer to ProviderListener. Necessary to see the progress state in calling application.
Returns:
Method returns TRUE in case of successful data update.

Reimplemented from PbRecordProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNameProvider.hpp
  • Applications/AdvPhonebook/PbNameProvider.cpp
Generated on Wed Jan 25 01:36:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNextFreeIdRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNextFreeIdRecord Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbNextFreeIdRecord.hpp>

Inheritance diagram for PbNextFreeIdRecord:

[legend]
Collaboration diagram for PbNextFreeIdRecord:

[legend]

Public Member Functions

virtual const UINT8 * | GetData ()
UINT32 | GetNextFreeUniqueId ()
virtual INT | GetPersistentSize ()
PbNextFreeIdRecord ()
virtual void | SetData (const UINT8 *data)
void | SetNextFreeUniqueId (UINT32 next_free_unique_id)

Data Structures

struct | Persist

Detailed Description

PbNextFreeIdRecord specifies the interface for data records to be stored persistently by means of RecordHandler to the ffs.

Constructor & Destructor Documentation

PbNextFreeIdRecord::PbNextFreeIdRecord ( )

Constructor

Returns:
NONE

Member Function Documentation

const UINT8 * PbNextFreeIdRecord::GetData ( ) [virtual]

Invoked by RecordHandler, to get record data.

Returns:
UINT8*

Implements Record.

UINT32 PbNextFreeIdRecord::GetNextFreeUniqueId ( ) [inline]

Gets the next_free_unique_id.

Returns:
UINT32

INT PbNextFreeIdRecord::GetPersistentSize ( ) [virtual]

Invoked by RecordHandler, to get the record size.

Returns:
INT

Implements Record.

void PbNextFreeIdRecord::SetData ( const UINT8 * data ) [virtual]

Invoked by RecordHandler, to set the record data.

Parameters:
UINT8* : data.
Returns:
NONE

Implements Record.

void PbNextFreeIdRecord::SetNextFreeUniqueId ( UINT32 next_free_unique_id ) [inline]

Sets the next free unique id.

Parameters:
next_free_unique_id : next_free_unique_id.
Returns:
NONE

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNextFreeIdRecord.hpp
  • Applications/AdvPhonebook/PbNextFreeIdRecord.cpp
Generated on Wed Jan 25 01:36:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNumberFilterProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNumberFilterProvider Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbDetailFilterProvider.hpp>

Inheritance diagram for PbNumberFilterProvider:

[legend]
Collaboration diagram for PbNumberFilterProvider:

[legend]

Public Member Functions

virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
virtual INT | GetProviderId () const
GetProviderId() reflects the provider Id of the child-provider.
virtual Status | GetStatus () const
Returns the status of the provider.
void | Init (Provider *provider, INT name_row=c_no_row)
PbNumberFilterProvider (Provider *provider, INT name_row=c_no_row)
PbNumberFilterProvider ()
virtual INT | RowCount ()
virtual BOOLEAN | SetParameter (const DataItem &item)
virtual BOOLEAN | Update (ProviderListener *listener=0)
~PbNumberFilterProvider ()

Constructor & Destructor Documentation

PbNumberFilterProvider::PbNumberFilterProvider ( )

PbNumberFilterProvider::PbNumberFilterProvider | ( | Provider * | provider,
 |  | INT | name_row = c_no_row
 | ) |

PbNumberFilterProvider::~PbNumberFilterProvider ( )

Member Function Documentation

BOOLEAN PbNumberFilterProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

GetChildRow returns the effective row of the child-provider.

Reimplemented from PbDetailProvider.

BOOLEAN PbNumberFilterProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
Provider::GetDataItem

Reimplemented from PbDetailProvider.

INT PbNumberFilterProvider::GetProviderId ( ) const [virtual]

GetProviderId() reflects the provider Id of the child-provider.

Reimplemented from AbstractDelegationProvider.

Provider::Status PbNumberFilterProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

void PbNumberFilterProvider::Init | ( | Provider * | provider,
 |  | INT | name_row = c_no_row
 | ) |

Reimplemented from PbDetailProvider.

INT PbNumberFilterProvider::RowCount ( ) [virtual]

RowCount reflects RowCount of the child-provider or 0 if no child-provider was set.

Reimplemented from PbDetailProvider.

BOOLEAN PbNumberFilterProvider::SetParameter ( const DataItem & item ) [virtual]

GetColumnInfoPerId reflects GetColumnInfoPerId of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

BOOLEAN PbNumberFilterProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update updates the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from PbDetailProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbDetailFilterProvider.hpp
  • Applications/AdvPhonebook/PbDetailFilterProvider.cpp
Generated on Wed Jan 25 01:36:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNumberHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNumberHandler Class Reference

#include <Applications/AdvPhonebook/PbNumberHandler.hpp>

Inheritance diagram for PbNumberHandler:

[legend]
Collaboration diagram for PbNumberHandler:

[legend]

Public Member Functions

void | InitFile (PbNameProvider *name_prov)
PbNumberHandler (DataRecordHandler *record_handler)
PbNumberHandler ()
virtual | ~PbNumberHandler ()

Protected Member Functions

virtual DataRecord * | GetDataRecord ()
virtual DataRecordHandler * | GetDataRecordHandler ()

Constructor & Destructor Documentation

PbNumberHandler::PbNumberHandler ( )

PbNumberHandler::PbNumberHandler ( DataRecordHandler * record_handler )

PbNumberHandler::~PbNumberHandler ( ) [virtual]

Member Function Documentation

virtual DataRecord* PbNumberHandler::GetDataRecord ( ) [inline, protected, virtual]

Implements PbRecordHandler.

virtual DataRecordHandler* PbNumberHandler::GetDataRecordHandler ( ) [inline, protected, virtual]

Implements PbRecordHandler.

void PbNumberHandler::InitFile ( PbNameProvider * name_prov )

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNumberHandler.hpp
  • Applications/AdvPhonebook/PbNumberHandler.cpp
Generated on Wed Jan 25 01:36:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNumberProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNumberProvider Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbNumberProvider.hpp>

Inheritance diagram for PbNumberProvider:

[legend]
Collaboration diagram for PbNumberProvider:

[legend]

Public Types

typedef PbRecordProvider | Base

Public Member Functions

virtual BOOLEAN | AppendRow ()
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
virtual BOOLEAN | DeleteRow (INT row)
virtual BOOLEAN | GetDataItem (IN INT columnid, IN INT row, OUT DataItem &item)
virtual INT | GetProviderId () const
void | Init (Protector *protector, PbRecordHandler *m_handler)
PbNumberProvider (Protector *protector, PbRecordHandler *no_handler)
PbNumberProvider ()
virtual BOOLEAN | SetDataItem (IN const DataItem &item, IN INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
virtual | ~PbNumberProvider ()

Protected Member Functions

virtual Record * | GetDataRecord ()
virtual void | InitRecord ()

Detailed Description

The class PbNumberProvider will be used to store phone numbers in non-volatile memory. All methods to take access to phone numbers are defined in this class.

Member Typedef Documentation

typedef PbRecordProvider PbNumberProvider::Base

Reimplemented from PbRecordProvider.

Constructor & Destructor Documentation

PbNumberProvider::PbNumberProvider ( )

Class constructor

PbNumberProvider::PbNumberProvider | ( | Protector * | protector,
 |  | PbRecordHandler * | no_handler
 | ) |

Class constructor with predefined protector and handler;

Parameters:
protector | Necessary to prevent the generation of more than one instances of this class at the same time.
name_handler | This handler defines the data storage process.

PbNumberProvider::~PbNumberProvider ( ) [virtual]

Class destructor;

Member Function Documentation

BOOLEAN PbNumberProvider::AppendRow ( ) [virtual]

Method adds a new phone number data row.

Returns:
Method returns TRUE if new phone book entry data was added successful.

Reimplemented from PbRecordProvider.

BOOLEAN PbNumberProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Method deletes all phone number data rows.

Returns:
Method returns TRUE in case of successful data deletion.

Reimplemented from PbRecordProvider.

BOOLEAN PbNumberProvider::DeleteRow ( INT row ) [virtual]

Method deletes a specific phone number data row.

Parameters:
row Phone number data row that should be deleted.
Returns:
Method returns TRUE in case of successful data deletion.

Reimplemented from PbRecordProvider.

virtual BOOLEAN PbNumberProvider::GetDataItem | ( | IN INT | columnid,
 |  | IN INT | row,
 |  | OUT DataItem & | item
 | ) | [virtual]

Method reads a certain phone number data item.

Parameters:
columnid | Provider column identifier to determine the data field that should be read.
row | Provider row identifier.
item | Pointer to data item. The read data will be saved in this structure.
Returns:
Method returns TRUE if all parameter values are valid and the several provider settings could be read without any errors.

Implements PbRecordProvider.

Record * PbNumberProvider::GetDataRecord ( ) [protected, virtual]

Implements PbRecordProvider.

INT PbNumberProvider::GetProviderId ( ) const [virtual]

Method returns the phone number provider ID.

Returns:
hone book entry provider ID

Implements Provider.

void PbNumberProvider::Init | ( | Protector * | protector,
 |  | PbRecordHandler * | m_handler
 | ) |

Class initialisation; File with saved phone number data will be read from FFS. If no file is existing a new file will be created.

Parameters:
protector | Necessary to prevent the generation of more than one instances of this class at the same time.
name_handler | This handler defines the data storage process.

Reimplemented from PbRecordProvider.

void PbNumberProvider::InitRecord ( ) [protected, virtual]

Implements PbRecordProvider.

virtual BOOLEAN PbNumberProvider::SetDataItem | ( | IN const DataItem & | item,
 |  | IN INT | columnid
 | ) | [virtual]

Method saves phone number data in file.

Parameters:
item | Pointer to data item with data that should be stored in a file.
columnid | Provider column identifier to determine the data field that should be replaced.
Returns:
Method returns TRUE if all parameter values are valid and the several provider settings could be saved without any errors.

Implements PbRecordProvider.

BOOLEAN PbNumberProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Method makes the Provider ready to use, enables listener and reloads the phone number data from FFS.

Parameters:
listener Pointer to ProviderListener. Necessary to see the progress state in calling application.
Returns:
Method returns TRUE in case of successful data update.

Reimplemented from PbRecordProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNumberProvider.hpp
  • Applications/AdvPhonebook/PbNumberProvider.cpp
Generated on Wed Jan 25 01:36:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNumberRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNumberRecord Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbRecord.hpp>

Inheritance diagram for PbNumberRecord:

[legend]
Collaboration diagram for PbNumberRecord:

[legend]

Public Member Functions

virtual const UINT8 * | GetData ()
const UINT16 | GetNameRecNo () const
const UINT | GetNoId () const
virtual INT | GetPersistentSize ()
const PhoneNoType | GetPhoneNoType () const
const PhoneNumber | GetPhoneNumber () const
const UINT | GetSimRecNo () const
const UINT32 | GetUniqueId () const
const BOOLEAN | IsOnSim () const
virtual BOOLEAN | IsRecordDeleted ()
BOOLEAN | IsValid ()
virtual void | MarkDeleted ()
PbNumberRecord ()
virtual void | SetData (const UINT8 *data)
void | SetIsOnSim (BOOLEAN on_sim)
void | SetNameRecNo (UINT16 name_recno)
void | SetNoId (UINT no_id)
void | SetPhoneNoType (PhoneNoType no_type)
void | SetPhoneNumber (const PhoneNumber &phoneno)
void | SetSimRecNo (UINT16 sim_recno)
void | SetUniqueId (UINT32 unique_id)
void | SetValid (BOOLEAN valid)

Data Fields

PbNumberRecord::Persist m_data

Data Structures

struct | Persist

Detailed Description

The class PbNumberRecord will be used to store phone numbers in non-volatile memory. All methods to take access to the saved Pb entry data are defined in this class.

Constructor & Destructor Documentation

PbNumberRecord::PbNumberRecord ( )

Member Function Documentation

const UINT8 * PbNumberRecord::GetData ( ) [virtual]

Method reads phone number data from non-volatile memory.

Returns:
Pointer to phone book data field that contains current data

Implements Record.

const UINT16 PbNumberRecord::GetNameRecNo ( ) const [inline]

Method returns the current name rocord number of current phone number data field.

Returns:
Name rocord number of current phone number data field.

const UINT PbNumberRecord::GetNoId ( ) const [inline]

Method returns the number order identifier of current phone number data field.This number identifier defines the phone number illustration order.

Returns:
Number order identifier for current phone number data field.

INT PbNumberRecord::GetPersistentSize ( ) [virtual]

Method determines the size of the phone number data field.

Returns:
Size of phone number data field (in bytes).

Implements Record.

const PhoneNoType PbNumberRecord::GetPhoneNoType ( ) const [inline]

Method returns the phone number type of the current phone number data field (Mobil, Home, Office, Fax etc.).

Returns:
Current phone number type.

const PhoneNumber PbNumberRecord::GetPhoneNumber ( ) const

Method returns the phone number of the current phone number data field.

Returns:
Current phone number.

const UINT PbNumberRecord::GetSimRecNo ( ) const [inline]

Method returns the SIM record number of current phone number data field.

Returns:
SIM record number of current phone number data field.

const UINT32 PbNumberRecord::GetUniqueId ( ) const [inline]

Method returns the UNIQUE identifier of each Phonebook entry

const BOOLEAN PbNumberRecord::IsOnSim ( ) const [inline]

Method returns the "on SIM-Flag" of current phone number data field (TRUE = Phone number is saved on SIM; FALSE = Phone number is not saved on SIM).

Returns:
"on SIM-Flag" of current phone number data field.

BOOLEAN PbNumberRecord::IsRecordDeleted ( ) [virtual]

Method checks if current phone number data field is valid.

Returns:
TRUE = data field is deleted or invalid; FALSE = data field is valid.

Reimplemented from Record.

BOOLEAN PbNumberRecord::IsValid ( ) [inline]

void PbNumberRecord::MarkDeleted ( ) [virtual]

Method sets the currentphone number data state to "deleted". This means that the saved data are invalid and could not be read anymore. This method is called if phone book entries will be deleted. Furtermore during the parent class initialisation if the provider data file will be created new with empty phone book entries.

Reimplemented from Record.

void PbNumberRecord::SetData ( const UINT8 * data ) [virtual]

Method writes phone number data to non-volatile memory.

Parameters:
data Phone number data field that should be stored on non-volatile memory

Implements Record.

void PbNumberRecord::SetIsOnSim ( BOOLEAN on_sim ) [inline]

The "on SIM-Flag" will be set by this method (TRUE = Phone number is saved on SIM; FALSE = Phone number is not saved on SIM).

Parameters:
on_sim New "on SIM-Flag" value.

void PbNumberRecord::SetNameRecNo ( UINT16 name_recno ) [inline]

Method updates the name rocord number of current phone number data field. With this name rocord number it is possible to determine the appropriate phone book entry.

Parameters:
name New name rocord number for current phone number data field.

void PbNumberRecord::SetNoId ( UINT no_id ) [inline]

Method updates the number order identifier of current phone number data field. This number identifier defines the phone number illustration order.

Parameters:
no_id Number order identifier for current phone number data field.

void PbNumberRecord::SetPhoneNoType ( PhoneNoType no_type ) [inline]

Method defines the type of the current phone number (Mobil, Home, Office, Fax etc.).

Parameters:
no_type New phone number type.

void PbNumberRecord::SetPhoneNumber ( const PhoneNumber & phoneno ) [inline]

Method updates the phone number of the current phone number data field.

Parameters:
phoneno New phone number.

void PbNumberRecord::SetSimRecNo ( UINT16 sim_recno ) [inline]

Method updates the SIM record number of current phone number data field (Only available if phone number is saved on SIM).

Parameters:
sim_recno New SIM record number.

void PbNumberRecord::SetUniqueId ( UINT32 unique_id ) [inline]

Method updates the UNIQUE identifier of each Phonebook entry

void PbNumberRecord::SetValid ( BOOLEAN valid ) [inline]

Field Documentation

struct PbNumberRecord::Persist PbNumberRecord::m_data

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbRecord.hpp
  • Applications/AdvPhonebook/PbRecord.cpp
Generated on Wed Jan 25 01:36:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNumberRecord::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PbNumberRecord::Persist

PbNumberRecord::Persist Struct Reference

#include <Applications/AdvPhonebook/PbRecord.hpp>

Collaboration diagram for PbNumberRecord::Persist:

[legend]

Data Fields

struct {
BOOLEAN deleted: 1
BOOLEAN is_on_sim: 1
UINT no_id: 4
PhoneNoType phoneno_type: 4
BOOLEAN valid: 1
} m_bits
UINT16 | m_name_recno
PhoneNumber::Persist m_phoneno_persist
UINT16 | m_sim_recno
UINT32 | m_unique_id
UINT8 | type

Field Documentation

BOOLEAN PbNumberRecord::Persist::deleted

BOOLEAN PbNumberRecord::Persist::is_on_sim

struct { ... } PbNumberRecord::Persist::m_bits

UINT16 PbNumberRecord::Persist::m_name_recno

PhoneNumber::Persist PbNumberRecord::Persist::m_phoneno_persist

UINT16 PbNumberRecord::Persist::m_sim_recno

UINT32 PbNumberRecord::Persist::m_unique_id

UINT PbNumberRecord::Persist::no_id

PhoneNoType PbNumberRecord::Persist::phoneno_type

UINT8 PbNumberRecord::Persist::type

BOOLEAN PbNumberRecord::Persist::valid

The documentation for this struct was generated from the following file:
  • Applications/AdvPhonebook/PbRecord.hpp
Generated on Wed Jan 25 01:36:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNvRamNameHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNvRamNameHandler Class Reference

#include <Applications/AdvPhonebook/PbNvRamNameHandler.hpp>

Inheritance diagram for PbNvRamNameHandler:

[legend]
Collaboration diagram for PbNvRamNameHandler:

[legend]

Public Member Functions

virtual void | Init ()
virtual INT | MaxRowCount ()
PbNvRamNameHandler ()
virtual | ~PbNvRamNameHandler ()

Protected Member Functions

virtual DataRecord * | GetDataRecord ()
virtual DataRecordHandler * | GetDataRecordHandler ()

Constructor & Destructor Documentation

PbNvRamNameHandler::PbNvRamNameHandler ( )

PbNvRamNameHandler::~PbNvRamNameHandler ( ) [virtual]

Member Function Documentation

virtual DataRecord* PbNvRamNameHandler::GetDataRecord ( ) [inline, protected, virtual]

Implements PbRecordHandler.

virtual DataRecordHandler* PbNvRamNameHandler::GetDataRecordHandler ( ) [inline, protected, virtual]

Implements PbRecordHandler.

void PbNvRamNameHandler::Init ( ) [virtual]

Reimplemented from PbRecordHandler.

virtual INT PbNvRamNameHandler::MaxRowCount ( ) [inline, virtual]

Implements PbRecordHandler.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNvRamNameHandler.hpp
  • Applications/AdvPhonebook/PbNvRamNameHandler.cpp
Generated on Wed Jan 25 01:36:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbNvRamNumberHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbNvRamNumberHandler Class Reference

#include <Applications/AdvPhonebook/PbNvRamNumberHandler.hpp>

Inheritance diagram for PbNvRamNumberHandler:

[legend]
Collaboration diagram for PbNvRamNumberHandler:

[legend]

Public Member Functions

void | Init ()
virtual INT | MaxRowCount ()
PbNvRamNumberHandler (DataRecordHandler *record_handler)
PbNvRamNumberHandler ()
virtual | ~PbNvRamNumberHandler ()

Protected Member Functions

virtual DataRecord * | GetDataRecord ()
virtual DataRecordHandler * | GetDataRecordHandler ()

Constructor & Destructor Documentation

PbNvRamNumberHandler::PbNvRamNumberHandler ( )

PbNvRamNumberHandler::PbNvRamNumberHandler ( DataRecordHandler * record_handler )

PbNvRamNumberHandler::~PbNvRamNumberHandler ( ) [virtual]

Member Function Documentation

virtual DataRecord* PbNvRamNumberHandler::GetDataRecord ( ) [inline, protected, virtual]

Implements PbRecordHandler.

virtual DataRecordHandler* PbNvRamNumberHandler::GetDataRecordHandler ( ) [inline, protected, virtual]

Implements PbRecordHandler.

void PbNvRamNumberHandler::Init ( ) [virtual]

Reimplemented from PbRecordHandler.

virtual INT PbNvRamNumberHandler::MaxRowCount ( ) [inline, virtual]

Implements PbRecordHandler.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbNvRamNumberHandler.hpp
  • Applications/AdvPhonebook/PbNvRamNumberHandler.cpp
Generated on Wed Jan 25 01:36:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbPhoneNumberPrompt Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbPhoneNumberPrompt Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp>

Collaboration diagram for PbPhoneNumberPrompt:

[legend]

Public Member Functions

void | Init ()
PbPhoneNumberPrompt ()
void | SavePhoneNo ()
virtual | ~PbPhoneNumberPrompt ()

Protected Member Functions

virtual void | OnOpen ()

Constructor & Destructor Documentation

PbPhoneNumberPrompt::PbPhoneNumberPrompt ( )

PbPhoneNumberPrompt::~PbPhoneNumberPrompt ( ) [virtual]

Member Function Documentation

void PbPhoneNumberPrompt::Init ( )

void PbPhoneNumberPrompt::OnOpen ( ) [protected, virtual]

void PbPhoneNumberPrompt::SavePhoneNo ( )

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp
  • Applications/AdvPhonebook/PbPhoneNumberPrompt.cpp
Generated on Wed Jan 25 01:36:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbProvColListBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbProvColListBox Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbProvListBox.hpp>

Inheritance diagram for PbProvColListBox:

[legend]
Collaboration diagram for PbProvColListBox:

[legend]

Public Member Functions

void | Init (ProvListBoxWin *parent, INT colid, INT sort_colid)
void | SetColumnId (INT colid) const

Protected Member Functions

virtual Model * | CreateModel () const

Member Function Documentation

Model * PbProvColListBox::CreateModel ( ) const [protected, virtual]

void PbProvColListBox::Init | ( | ProvListBoxWin * | parent,
 |  | INT | colid,
 |  | INT | sort_colid
 | ) |

void PbProvColListBox::SetColumnId ( INT colid ) const [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbProvListBox.hpp
  • Applications/AdvPhonebook/PbProvListBox.cpp
Generated on Wed Jan 25 01:36:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbProvColListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbProvColListBoxModel Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbProvListBox.hpp>

Inheritance diagram for PbProvColListBoxModel:

[legend]
Collaboration diagram for PbProvColListBoxModel:

[legend]

Public Member Functions

virtual const BitmapRes * | GetCellIcon (INT index, BOOLEAN highlighted)
void | Init (DrawableObjectListBox *listbox, INT colid, INT sort_colid)
PbProvColListBoxModel (DrawableObjectListBox *listbox, INT colid, INT sort_colid)
PbProvColListBoxModel ()
void | SetColumnId (INT colid)
virtual | ~PbProvColListBoxModel ()

Protected Member Functions

virtual INT | GetColumnId (INT index)

Constructor & Destructor Documentation

PbProvColListBoxModel::PbProvColListBoxModel ( )

PbProvColListBoxModel::PbProvColListBoxModel | ( | DrawableObjectListBox * | listbox,
 |  | INT | colid,
 |  | INT | sort_colid
 | ) |

PbProvColListBoxModel::~PbProvColListBoxModel ( ) [virtual]

Member Function Documentation

const BitmapRes * PbProvColListBoxModel::GetCellIcon | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

Reimplemented from PbProvListBoxModel.

virtual INT PbProvColListBoxModel::GetColumnId ( INT index ) [inline, protected, virtual]

Implements PbProvListBoxModel.

void PbProvColListBoxModel::Init | ( | DrawableObjectListBox * | listbox,
 |  | INT | colid,
 |  | INT | sort_colid
 | ) |

void PbProvColListBoxModel::SetColumnId ( INT colid ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbProvListBox.hpp
  • Applications/AdvPhonebook/PbProvListBox.cpp
Generated on Wed Jan 25 01:36:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbProviderListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbProviderListener Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbProviderListener.hpp>

Inheritance diagram for PbProviderListener:

[legend]
Collaboration diagram for PbProviderListener:

[legend]

Public Member Functions

virtual void | OnExecuting ()
Will be called during execution, Provider can be asked for the progress value.
virtual void | OnStarted (Provider *prov)
Will be called when operation starts, has to be overwritten but also has to be called from subclass.
PbProviderListener (ProviderListener *child_listener)
void | SetChildListener (ProviderListener *listener)
virtual | ~PbProviderListener ()

Constructor & Destructor Documentation

PbProviderListener::PbProviderListener ( ProviderListener * child_listener )

PbProviderListener::~PbProviderListener ( ) [virtual]

Member Function Documentation

void PbProviderListener::OnExecuting ( ) [virtual]

Will be called during execution, Provider can be asked for the progress value.

Reimplemented from ProviderListener.

void PbProviderListener::OnStarted ( Provider * prov ) [virtual]

Will be called when operation starts, has to be overwritten but also has to be called from subclass.

Reimplemented from ProviderListener.

void PbProviderListener::SetChildListener ( ProviderListener * listener ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbProviderListener.hpp
  • Applications/AdvPhonebook/PbProviderListener.cpp
Generated on Wed Jan 25 01:36:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbProvListBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbProvListBox Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbProvListBox.hpp>

Inheritance diagram for PbProvListBox:

[legend]
Collaboration diagram for PbProvListBox:

[legend]

Public Member Functions

Provider * GetProvider ()
INT | GetSelectedColumnId () const
INT | GetSelectedRow () const
void | Init (ProvListBoxWin *parent)
PbProvListBox (ProvListBoxWin *parent)
PbProvListBox ()
void | SetProvider (Provider *provider)
void | SetSelectedRow (INT row)
virtual void | Update (INT item_count=-1)
virtual | ~PbProvListBox ()

Protected Member Functions

ProvListBoxWin * GetParent ()
virtual void | OnSelectionChanged ()

Constructor & Destructor Documentation

PbProvListBox::PbProvListBox ( )

PbProvListBox::PbProvListBox ( ProvListBoxWin * parent )

PbProvListBox::~PbProvListBox ( ) [virtual]

Member Function Documentation

ProvListBoxWin* PbProvListBox::GetParent ( ) [inline, protected]

Provider* PbProvListBox::GetProvider ( ) [inline]

INT PbProvListBox::GetSelectedColumnId ( ) const [inline]

INT PbProvListBox::GetSelectedRow ( ) const [inline]

void PbProvListBox::Init ( ProvListBoxWin * parent )

void PbProvListBox::OnSelectionChanged ( ) [protected, virtual]

void PbProvListBox::SetProvider ( Provider * provider ) [inline]

void PbProvListBox::SetSelectedRow ( INT row )

void PbProvListBox::Update ( INT item_count = -1 ) [virtual]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbProvListBox.hpp
  • Applications/AdvPhonebook/PbProvListBox.cpp
Generated on Wed Jan 25 01:37:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbProvListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbProvListBoxModel Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbProvListBox.hpp>

Inheritance diagram for PbProvListBoxModel:

[legend]
Collaboration diagram for PbProvListBoxModel:

[legend]

Public Member Functions

virtual const BitmapRes * | GetCellIcon (INT index, BOOLEAN highlighted)
virtual const WCHAR * | GetCellText (INT index, BOOLEAN highlighted)
virtual Provider * | GetProvider ()
const WCHAR * | GetProvText (INT index)
virtual INT | GetSelectedColumnId ()
virtual INT | GetSelectedProvRow ()
PbProvListBoxModel (DrawableObjectListBox *listbox)
PbProvListBoxModel ()
virtual void | SetProvider (Provider *provider)
virtual void | SetSelectedRow (INT recno)
virtual void | UpdateNoOfItems ()
virtual | ~PbProvListBoxModel ()

Protected Member Functions

virtual INT | GetColumnId (INT index)=0
virtual INT | GetProvRow (INT index)
virtual INT | GetRow (INT index)

Constructor & Destructor Documentation

PbProvListBoxModel::PbProvListBoxModel ( )

PbProvListBoxModel::PbProvListBoxModel ( DrawableObjectListBox * listbox )

PbProvListBoxModel::~PbProvListBoxModel ( ) [virtual]

Member Function Documentation

const BitmapRes * PbProvListBoxModel::GetCellIcon | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

Reimplemented in PbProvColListBoxModel.

const WCHAR * PbProvListBoxModel::GetCellText | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

virtual INT PbProvListBoxModel::GetColumnId ( INT index ) [protected, pure virtual]

Implemented in PbDetailListBoxModel, and PbProvColListBoxModel.

Provider * PbProvListBoxModel::GetProvider ( ) [virtual]

INT PbProvListBoxModel::GetProvRow ( INT index ) [protected, virtual]

const WCHAR * PbProvListBoxModel::GetProvText ( INT index )

INT PbProvListBoxModel::GetRow ( INT index ) [protected, virtual]

Reimplemented in PbDetailListBoxModel.

INT PbProvListBoxModel::GetSelectedColumnId ( ) [virtual]

INT PbProvListBoxModel::GetSelectedProvRow ( ) [virtual]

void PbProvListBoxModel::SetProvider ( Provider * provider ) [virtual]

void PbProvListBoxModel::SetSelectedRow ( INT recno ) [virtual]

void PbProvListBoxModel::UpdateNoOfItems ( ) [virtual]

Reimplemented in PbDetailListBoxModel.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbProvListBox.hpp
  • Applications/AdvPhonebook/PbProvListBox.cpp
Generated on Wed Jan 25 01:37:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbRecord Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbRecord.hpp>

Inheritance diagram for PbRecord:

[legend]
Collaboration diagram for PbRecord:

[legend]

Public Member Functions

virtual const UINT8 * | GetData ()
const CHAR * | GetEmail () const
const UINT | GetGroupId () const
const INT | GetIccId ()
const WCHAR * | GetName () const
virtual INT | GetPersistentSize ()
virtual BOOLEAN | IsRecordDeleted ()
BOOLEAN | IsValid ()
virtual void | MarkDeleted ()
PbRecord ()
virtual void | SetData (const UINT8 *data)
void | SetEmail (const String &email)
void | SetGroupId (UINT grp_id)
void | SetIccId (INT icc_id)
void | SetName (const WString &name)
void | SetValid (BOOLEAN valid)

Data Fields

PbRecord::Persist m_data

Data Structures

struct | Persist

Detailed Description

The class PbRecord will be used to store phone book entries in non-volatile memory. All methods to take access to the saved Pb entry data are defined in this class. Because some phone numbers could be added to one Pb entry the class PbNumberRecord was generated

Constructor & Destructor Documentation

PbRecord::PbRecord ( )

Member Function Documentation

const UINT8 * PbRecord::GetData ( ) [virtual]

Method reads phone book data from non-volatile memory.

Returns:
Pointer to phone book data field that contains current data

Implements Record.

const CHAR* PbRecord::GetEmail ( ) const [inline]

Method returns the current saved Email string.

Returns:
Email string of current phone book entry.

const UINT PbRecord::GetGroupId ( ) const [inline]

Method returns the current saved group membership identifier.

Returns:
Group membership identifier of current phone book entry.

const INT PbRecord::GetIccId ( ) [inline]

Method returns the master or guest SIM membership of current phone book entry. Take care, this feature is not available yet.

Returns:
Master or guest SIM identifier.

const WCHAR* PbRecord::GetName ( ) const [inline]

Method returns the current saved name string.

Returns:
Name string of current phone book entry.

INT PbRecord::GetPersistentSize ( ) [virtual]

Method determines the size of the phone book data field.

Returns:
Size of phone book data field (in bytes).

Implements Record.

BOOLEAN PbRecord::IsRecordDeleted ( ) [virtual]

Method checks if current phone book data field is valid.

Returns:
TRUE = data field is deleted or invalid; FALSE = data field is valid.

Reimplemented from Record.

BOOLEAN PbRecord::IsValid ( ) [inline]

void PbRecord::MarkDeleted ( ) [virtual]

Method sets the current provider data state to "deleted". This means that the saved data are invalid and could not be read anymore. This method is called if phone book entries will be deleted. Furtermore during the parent class initialisation if the provider data file will be created new with empty phone book entries.

Reimplemented from Record.

void PbRecord::SetData ( const UINT8 * data ) [virtual]

Method writes phone book data to non-volatile memory.

Parameters:
data phone book data field that should be stored on non-volatile memory

Implements Record.

void PbRecord::SetEmail ( const String & email ) [inline]

Method updates current saved Email string.

Parameters:
email New Email string for current phone book entry.

void PbRecord::SetGroupId ( UINT grp_id ) [inline]

Method updates the group membership of current saved phone book entry.

Parameters:
grp_id New group identifier that shoulb be set.

void PbRecord::SetIccId ( INT icc_id ) [inline]

Method sets master or guest SIM membership of current phone book entry. Take care, this feature is not available yet.

Parameters:
icc_id New SIM membership (master or guest)

void PbRecord::SetName ( const WString & name ) [inline]

Method updates current saved name string.

Parameters:
name New name string for current phone book entry.

void PbRecord::SetValid ( BOOLEAN valid ) [inline]

Field Documentation

struct PbRecord::Persist PbRecord::m_data

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbRecord.hpp
  • Applications/AdvPhonebook/PbRecord.cpp
Generated on Wed Jan 25 01:37:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbRecord::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PbRecord::Persist

PbRecord::Persist Struct Reference

#include <Applications/AdvPhonebook/PbRecord.hpp>

Data Fields

struct {
BOOLEAN deleted: 1
UINT group_id: 4
INT icc_id: 2
BOOLEAN valid: 1
} m_bits
CHAR | m_email [c_max_email_len+1]
WCHAR | m_name [c_max_name_len+1]
UINT8 | type

Field Documentation

BOOLEAN PbRecord::Persist::deleted

UINT PbRecord::Persist::group_id

INT PbRecord::Persist::icc_id

struct { ... } PbRecord::Persist::m_bits

CHAR PbRecord::Persist::m_email[c_max_email_len+1]

WCHAR PbRecord::Persist::m_name[c_max_name_len+1]

UINT8 PbRecord::Persist::type

BOOLEAN PbRecord::Persist::valid

The documentation for this struct was generated from the following file:
  • Applications/AdvPhonebook/PbRecord.hpp
Generated on Wed Jan 25 01:37:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbRecordHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbRecordHandler Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbRecordHandler.hpp>

Inheritance diagram for PbRecordHandler:

[legend]

Public Member Functions

virtual BOOLEAN | DeleteEntries (ProviderListener *listener=0)
virtual BOOLEAN | DeleteEntry (INT recno)
BOOLEAN | ExistsEntry (INT recno)
virtual BOOLEAN | GetEntry (INT recno, Record *pb_rec)
INT | GetProgress () const
virtual void | Init ()
BOOLEAN | Lock ()
Keeps the RecordHandler's File permanently Open.
virtual INT | MaxRowCount ()=0
PbRecordHandler ()
INT | RowCount ()
BOOLEAN | Unlock ()
Closes the RecordHandler's File.
virtual BOOLEAN | UpdateEntry (INT recno, Record *pb_entry)
virtual | ~PbRecordHandler ()

Protected Member Functions

virtual Record * | GetDataRecord ()=0
virtual RecordHandler * | GetDataRecordHandler ()=0

Constructor & Destructor Documentation

PbRecordHandler::PbRecordHandler ( )

PbRecordHandler::~PbRecordHandler ( ) [virtual]

Member Function Documentation

BOOLEAN PbRecordHandler::DeleteEntries ( ProviderListener * listener = 0 ) [virtual]

BOOLEAN PbRecordHandler::DeleteEntry ( INT recno ) [virtual]

BOOLEAN PbRecordHandler::ExistsEntry ( INT recno ) [inline]

virtual Record* PbRecordHandler::GetDataRecord ( ) [protected, pure virtual]

Implemented in PbFfsNameHandler, PbFfsNumberHandler, PbNameHandler, PbNumberHandler, PbNvRamNameHandler, and PbNvRamNumberHandler.

virtual RecordHandler* PbRecordHandler::GetDataRecordHandler ( ) [protected, pure virtual]

Implemented in PbFfsNameHandler, PbFfsNumberHandler, PbNameHandler, PbNumberHandler, PbNvRamNameHandler, and PbNvRamNumberHandler.

BOOLEAN PbRecordHandler::GetEntry | ( | INT | recno,
 |  | Record * | pb_rec
 | ) | [virtual]

INT PbRecordHandler::GetProgress ( ) const [inline]

void PbRecordHandler::Init ( ) [virtual]

Reimplemented in PbFfsNameHandler, PbFfsNumberHandler, PbNameHandler, PbNvRamNameHandler, and PbNvRamNumberHandler.

BOOLEAN PbRecordHandler::Lock ( )

Keeps the RecordHandler's File permanently Open.

virtual INT PbRecordHandler::MaxRowCount ( ) [pure virtual]

Implemented in PbFfsNameHandler, PbFfsNumberHandler, PbNvRamNameHandler, and PbNvRamNumberHandler.

INT PbRecordHandler::RowCount ( ) [inline]

BOOLEAN PbRecordHandler::Unlock ( )

Closes the RecordHandler's File.

BOOLEAN PbRecordHandler::UpdateEntry | ( | INT | recno,
 |  | Record * | pb_entry
 | ) | [virtual]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbRecordHandler.hpp
  • Applications/AdvPhonebook/PbRecordHandler.cpp
Generated on Wed Jan 25 01:37:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbRecordProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbRecordProvider Class Reference
[AdvPhonebookProvider]

#include <Applications/AdvPhonebook/PbRecordProvider.hpp>

Inheritance diagram for PbRecordProvider:

[legend]
Collaboration diagram for PbRecordProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base
enum LastChange {
Append, Commit, Delete, DeleteAll,
None
}

Public Member Functions

virtual BOOLEAN | AppendRow ()
Append a row.
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (IN INT columnid, IN INT row, OUT DataItem &item)=0
INT | GetKeyId () const
void | Init (Protector *protector, PbRecordHandler *m_handler)
virtual BOOLEAN | Lock ()
Keeps the RecordHandler's File permanently Open.
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
PbRecordProvider (Protector *protector, PbRecordHandler *m_handler)
PbRecordProvider ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (IN const DataItem &item, IN INT columnid)=0
virtual BOOLEAN | Unlock ()
Closes the RecordHandler's File.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~PbRecordProvider ()

Protected Member Functions

virtual Record * | GetDataRecord ()=0
INT | GetFirstFreeRecNo ()
PbRecordHandler * GetHandler ()
const IndexTable< INT > * | GetRowTable ()
virtual void | InitRecord ()=0

Member Typedef Documentation

typedef ThreadSafeProvider PbRecordProvider::Base

Reimplemented from ThreadSafeProvider.

Reimplemented in PbNameProvider, and PbNumberProvider.

Member Enumeration Documentation

enum PbRecordProvider::LastChange

Enumerator:
Append
Commit
Delete
DeleteAll
None

Constructor & Destructor Documentation

PbRecordProvider::PbRecordProvider ( )

PbRecordProvider::PbRecordProvider | ( | Protector * | protector,
 |  | PbRecordHandler * | m_handler
 | ) |

PbRecordProvider::~PbRecordProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PbRecordProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

Reimplemented in PbNameProvider, and PbNumberProvider.

BOOLEAN PbRecordProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN PbRecordProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from Provider.

Reimplemented in PbNameProvider, and PbNumberProvider.

BOOLEAN PbRecordProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

Reimplemented in PbNameProvider, and PbNumberProvider.

virtual BOOLEAN PbRecordProvider::GetDataItem | ( | IN INT | columnid,
 |  | IN INT | row,
 |  | OUT DataItem & | item
 | ) | [pure virtual]

Implemented in PbNameProvider, and PbNumberProvider.

virtual Record* PbRecordProvider::GetDataRecord ( ) [protected, pure virtual]

Implemented in PbNameProvider, and PbNumberProvider.

INT PbRecordProvider::GetFirstFreeRecNo ( ) [protected]

PbRecordHandler* PbRecordProvider::GetHandler ( ) [inline, protected]

INT PbRecordProvider::GetKeyId ( ) const [inline]

const IndexTable<INT>* PbRecordProvider::GetRowTable ( ) [inline, protected]

void PbRecordProvider::Init | ( | Protector * | protector,
 |  | PbRecordHandler * | m_handler
 | ) |

Reimplemented in PbNameProvider, and PbNumberProvider.

virtual void PbRecordProvider::InitRecord ( ) [protected, pure virtual]

Implemented in PbNameProvider, and PbNumberProvider.

BOOLEAN PbRecordProvider::Lock ( ) [virtual]

Keeps the RecordHandler's File permanently Open.

Reimplemented from ThreadSafeProvider.

INT PbRecordProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT PbRecordProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN PbRecordProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

virtual BOOLEAN PbRecordProvider::SetDataItem | ( | IN const DataItem & | item,
 |  | IN INT | columnid
 | ) | [pure virtual]

Implemented in PbNameProvider, and PbNumberProvider.

BOOLEAN PbRecordProvider::Unlock ( ) [virtual]

Closes the RecordHandler's File.

Reimplemented from ThreadSafeProvider.

BOOLEAN PbRecordProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

Reimplemented in PbNameProvider, and PbNumberProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbRecordProvider.hpp
  • Applications/AdvPhonebook/PbRecordProvider.cpp
Generated on Wed Jan 25 01:37:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSecuredAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSecuredAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbSecuredAction:

[legend]
Collaboration diagram for PbSecuredAction:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
BOOLEAN | IsExecuting ()
PbSecuredAction ()
virtual | ~PbSecuredAction ()

Constructor & Destructor Documentation

PbSecuredAction::PbSecuredAction ( )

PbSecuredAction::~PbSecuredAction ( ) [virtual]

Member Function Documentation

BOOLEAN PbSecuredAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbAction.

Reimplemented in PbAddPhoneNoAction, PbConfirmAddNoAction, PbCancelAddNoAction, PbDelPhonenoAction, PbChangeNoTypeAction, PbSelectGroupAction, SyncSimAllAction, SyncPhoneAllAction, SyncSimAction, SyncPhoneAction, PbAddAction, PbEditDetailAction, PbConfirmEditAction, PbCancelEditAction, PbDeleteAction, PbDelAllAction, AddAllToFdnAction, AddEntryToFdnAction, AddNumberToFdnAction, and CopyToPbAction.

BOOLEAN PbSecuredAction::IsExecuting ( ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:37:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSelectGroup Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSelectGroup Class Reference
[AdvPhonebook]

#include <Applications/AdvPhonebook/PbSelectGroup.hpp>

Collaboration diagram for PbSelectGroup:

[legend]

Public Member Functions

INT | GetSelectedGroupIndex () const
void | Init ()
PbSelectGroup ()
void | SetSelectedGroupIndex (INT index)
virtual | ~PbSelectGroup ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)

Constructor & Destructor Documentation

PbSelectGroup::PbSelectGroup ( )

PbSelectGroup::~PbSelectGroup ( ) [virtual]

Member Function Documentation

INT PbSelectGroup::GetSelectedGroupIndex ( ) const

void PbSelectGroup::Init ( )

void PbSelectGroup::OnActionExecuted ( Action * action ) [protected, virtual]

See also:
Window::OnActionExecuted

void PbSelectGroup::SetSelectedGroupIndex ( INT index )

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbSelectGroup.hpp
  • Applications/AdvPhonebook/PbSelectGroup.cpp
Generated on Wed Jan 25 01:37:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSelectGroupAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSelectGroupAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for PbSelectGroupAction:

[legend]
Collaboration diagram for PbSelectGroupAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN PbSelectGroupAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 01:37:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSelectNoType Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSelectNoType Class Reference
[AdvPhonebook]

#include <Applications/AdvPhonebook/PbSelectNoType.hpp>

Collaboration diagram for PbSelectNoType:

[legend]

Public Member Functions

INT | GetSelectedNumberTypeIndex () const
void | Init ()
PbSelectNoType ()
void | SetSelectedNumberTypeIndex (INT index)
virtual | ~PbSelectNoType ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)

Constructor & Destructor Documentation

PbSelectNoType::PbSelectNoType ( )

PbSelectNoType::~PbSelectNoType ( ) [virtual]

Member Function Documentation

INT PbSelectNoType::GetSelectedNumberTypeIndex ( ) const

void PbSelectNoType::Init ( )

void PbSelectNoType::OnActionExecuted ( Action * action ) [protected, virtual]

See also:
Window::OnActionExecuted

void PbSelectNoType::SetSelectedNumberTypeIndex ( INT index )

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbSelectNoType.hpp
  • Applications/AdvPhonebook/PbSelectNoType.cpp
Generated on Wed Jan 25 01:37:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSelectNumberWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSelectNumberWin Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbSelectNumberWin.hpp>

Inheritance diagram for PbSelectNumberWin:

[legend]
Collaboration diagram for PbSelectNumberWin:

[legend]

Public Types

typedef PbBaseWin | Base

Public Member Functions

void | EnterNumber ()
PhoneNumber | GetSelectedNumber () const
void | Init (Provider *pb_provider=0)
PbSelectNumberWin ()
virtual | ~PbSelectNumberWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()

Member Typedef Documentation

typedef PbBaseWin PbSelectNumberWin::Base

Reimplemented from PbBaseWin.

Constructor & Destructor Documentation

PbSelectNumberWin::PbSelectNumberWin ( )

PbSelectNumberWin::~PbSelectNumberWin ( ) [virtual]

Member Function Documentation

void PbSelectNumberWin::EnterNumber ( )

PhoneNumber PbSelectNumberWin::GetSelectedNumber ( ) const [inline]

void PbSelectNumberWin::Init ( Provider * pb_provider = 0 )

void PbSelectNumberWin::OnActionExecuted ( Action * action ) [protected, virtual]

BOOLEAN PbSelectNumberWin::OnCancel ( ) [protected, virtual]

Reimplemented from PbBaseWin.

BOOLEAN PbSelectNumberWin::OnConfirm ( ) [protected, virtual]

Reimplemented from PbBaseWin.

void PbSelectNumberWin::OnOpen ( ) [protected, virtual]

Reimplemented from PbAbstractWin.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbSelectNumberWin.hpp
  • Applications/AdvPhonebook/PbSelectNumberWin.cpp
Generated on Wed Jan 25 01:37:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSimProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSimProvider Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbSimProvider.hpp>

Inheritance diagram for PbSimProvider:

[legend]
Collaboration diagram for PbSimProvider:

[legend]

Public Types

typedef AbstractDelegationProvider | Base

Public Member Functions

virtual INT | ColumnCount () const
BOOLEAN | ExistColumn (INT colid)
ExistColumn checks whether a column with a specific id exists
virtual BOOLEAN | GetChildRow (INT &child_row, INT row)
INT | GetColumnId (INT column)
GetColumnId converts a column into its id.
virtual const ColumnInfo * | GetColumnInfo (INT column)
const ColumnInfo * | GetColumnInfoPerId (INT id)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
virtual INT | GetProgress ()
virtual INT | GetProviderId () const
GetProviderId() reflects the provider Id of the child-provider.
virtual Status | GetStatus () const
Returns the status of the provider.
void | Init (Provider *provider=0, INT provider_id=c_invalid_colid)
PbSimProvider (Provider *provider, INT provider_id=c_invalid_colid)
PbSimProvider ()
virtual | ~PbSimProvider ()

Member Typedef Documentation

typedef AbstractDelegationProvider PbSimProvider::Base

Reimplemented from AbstractDelegationProvider.

Constructor & Destructor Documentation

PbSimProvider::PbSimProvider ( )

PbSimProvider::PbSimProvider | ( | Provider * | provider,
 |  | INT | provider_id = c_invalid_colid
 | ) |

PbSimProvider::~PbSimProvider ( ) [virtual]

Member Function Documentation

INT PbSimProvider::ColumnCount ( ) const [virtual]

ColumnCount reflects ColumnCount of the child-provider or 0 if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

BOOLEAN PbSimProvider::ExistColumn ( INT colid ) [inline, virtual]

ExistColumn checks whether a column with a specific id exists

Reimplemented from Provider.

BOOLEAN PbSimProvider::GetChildRow | ( | INT & | child_row,
 |  | INT | row
 | ) | [virtual]

GetChildRow returns the effective row of the child-provider.

Implements AbstractDelegationProvider.

INT PbSimProvider::GetColumnId ( INT column ) [inline, virtual]

GetColumnId converts a column into its id.

em>GetColumnInfoPerId returns column info for a column specified by id. See also GetColumnInfo.

Reimplemented from Provider.

const ColumnInfo * PbSimProvider::GetColumnInfo ( INT column ) [virtual]

GetColumnInfo reflects GetColumnInfo of the child-provider. Returns 0 if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

const ColumnInfo* PbSimProvider::GetColumnInfoPerId ( INT id ) [inline, virtual]

Reimplemented from Provider.

BOOLEAN PbSimProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
Provider::GetDataItem

Implements AbstractDelegationProvider.

INT PbSimProvider::GetProgress ( ) [virtual]

GetProgress reflects GetProgress of the child-provider. Returns 0 if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

INT PbSimProvider::GetProviderId ( ) const [virtual]

GetProviderId() reflects the provider Id of the child-provider.

Reimplemented from AbstractDelegationProvider.

Provider::Status PbSimProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

void PbSimProvider::Init | ( | Provider * | provider = 0,
 |  | INT | provider_id = c_invalid_colid
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbSimProvider.hpp
  • Applications/AdvPhonebook/PbSimProvider.cpp
Generated on Wed Jan 25 01:37:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSizeRequestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSizeRequestMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PbSizeRequestMsg:

[legend]
Collaboration diagram for PbSizeRequestMsg:

[legend]

Public Types

enum | { ID = 18926 }

Public Member Functions

virtual Message * | Clone () const
const MePhoneBookType & | GetMePhoneBookType () const
virtual const MsgMetaData & | GetMetaData () const
PbSizeRequestMsg (ExecutionContext *context, const MePhoneBookType &me_phone_book_type)
void | SetMePhoneBookType (const MePhoneBookType &me_phone_book_type)
virtual | ~PbSizeRequestMsg ()

Detailed Description

PbSizeRequestMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PbSizeRequestMsg::PbSizeRequestMsg | ( | ExecutionContext * | context,
 |  | const MePhoneBookType & | me_phone_book_type
 | ) |

PbSizeRequestMsg::~PbSizeRequestMsg ( ) [virtual]

Member Function Documentation

Message * PbSizeRequestMsg::Clone ( ) const [virtual]

Implements Message.

const MePhoneBookType& PbSizeRequestMsg::GetMePhoneBookType ( ) const [inline]

const MsgMetaData & PbSizeRequestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void PbSizeRequestMsg::SetMePhoneBookType ( const MePhoneBookType & me_phone_book_type ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:37:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSortedProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSortedProvider Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbSortedProvider.hpp>

Inheritance diagram for PbSortedProvider:

[legend]
Collaboration diagram for PbSortedProvider:

[legend]

Public Types

typedef QuickSortProvider | Base

Public Member Functions

virtual BOOLEAN | DeleteAllRows (ProviderListener *listener)
virtual Status | GetStatus () const
Returns the status of the provider.
PbSortedProvider ()
virtual BOOLEAN | Update (ProviderListener *listener)
Update makes the Provider ready to use and executes the sort process.
virtual | ~PbSortedProvider ()

Member Typedef Documentation

typedef QuickSortProvider PbSortedProvider::Base

Reimplemented from QuickSortProvider.

Constructor & Destructor Documentation

PbSortedProvider::PbSortedProvider ( )

PbSortedProvider::~PbSortedProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PbSortedProvider::DeleteAllRows ( ProviderListener * listener ) [virtual]

DeleteAllRows reflects DeleteAllRows of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

Provider::Status PbSortedProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

BOOLEAN PbSortedProvider::Update ( ProviderListener * listener ) [virtual]

Update makes the Provider ready to use and executes the sort process.

Reimplemented from QuickSortProvider.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbSortedProvider.hpp
  • Applications/AdvPhonebook/PbSortedProvider.cpp
Generated on Wed Jan 25 01:37:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbSynchronizer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbSynchronizer Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbSynchronizer.hpp>

Inheritance diagram for PbSynchronizer:

[legend]
Collaboration diagram for PbSynchronizer:

[legend]

Public Member Functions

virtual BOOLEAN | AutoDeletePhone (INT sim_row)=0
virtual BOOLEAN | AutoDeleteSim (INT phone_row)=0
virtual BOOLEAN | AutoSyncPhone (INT sim_row)=0
virtual BOOLEAN | AutoSyncSim (INT phone_row)=0
Provider * GetPbProvider ()
INT | GetProgress ()
Provider * GetSimProvider ()
BOOLEAN | HasPbGrown ()
void | Init (Application *app, Provider *pb_prov, Provider *sim_prov)
BOOLEAN | IsCanceled ()
BOOLEAN | IsSynchronized () const
BOOLEAN | IsSynchronizing () const
PbSynchronizer ()
void | SetCanceled (BOOLEAN cancel)
void | SetPbHasGrown (BOOLEAN grown)
virtual BOOLEAN | Synchronize (MmiAdvancedProgressBox *sync_progress_box=0)
virtual BOOLEAN | SyncPhoneAll (MmiAdvancedProgressBox *sync_progress_box=0)
virtual BOOLEAN | SyncPhoneOne (INT sim_row)
virtual BOOLEAN | SyncSimAll (MmiAdvancedProgressBox *sync_progress_box=0)
virtual BOOLEAN | SyncSimOne (INT phone_row)
virtual void | Update ()
virtual | ~PbSynchronizer ()

Protected Member Functions

Application * | GetApplication () const
void | SetSynchronized (BOOLEAN sync)
void | SetSynchronizing (BOOLEAN sync)
virtual BOOLEAN | SyncPhone (INT no_row)=0
virtual BOOLEAN | SyncSim (INT no_row)=0

Constructor & Destructor Documentation

PbSynchronizer::PbSynchronizer ( )

PbSynchronizer::~PbSynchronizer ( ) [virtual]

Member Function Documentation

virtual BOOLEAN PbSynchronizer::AutoDeletePhone ( INT sim_row ) [pure virtual]

Implemented in PbLazySynchronizer.

virtual BOOLEAN PbSynchronizer::AutoDeleteSim ( INT phone_row ) [pure virtual]

Implemented in PbLazySynchronizer.

virtual BOOLEAN PbSynchronizer::AutoSyncPhone ( INT sim_row ) [pure virtual]

Implemented in PbLazySynchronizer.

virtual BOOLEAN PbSynchronizer::AutoSyncSim ( INT phone_row ) [pure virtual]

Implemented in PbLazySynchronizer.

Application* PbSynchronizer::GetApplication ( ) const [inline, protected]

Provider* PbSynchronizer::GetPbProvider ( ) [inline]

INT PbSynchronizer::GetProgress ( ) [inline]

Provider* PbSynchronizer::GetSimProvider ( ) [inline]

BOOLEAN PbSynchronizer::HasPbGrown ( ) [inline]

void PbSynchronizer::Init | ( | Application * | app,
 |  | Provider * | pb_prov,
 |  | Provider * | sim_prov
 | ) |

BOOLEAN PbSynchronizer::IsCanceled ( ) [inline]

BOOLEAN PbSynchronizer::IsSynchronized ( ) const [inline]

BOOLEAN PbSynchronizer::IsSynchronizing ( ) const [inline]

void PbSynchronizer::SetCanceled ( BOOLEAN cancel ) [inline]

void PbSynchronizer::SetPbHasGrown ( BOOLEAN grown ) [inline]

void PbSynchronizer::SetSynchronized ( BOOLEAN sync ) [inline, protected]

void PbSynchronizer::SetSynchronizing ( BOOLEAN sync ) [inline, protected]

BOOLEAN PbSynchronizer::Synchronize ( MmiAdvancedProgressBox * sync_progress_box = 0 ) [virtual]

virtual BOOLEAN PbSynchronizer::SyncPhone ( INT no_row ) [protected, pure virtual]

Implemented in PbLazySynchronizer, and PbManualSynchronizer.

BOOLEAN PbSynchronizer::SyncPhoneAll ( MmiAdvancedProgressBox * sync_progress_box = 0 ) [virtual]

BOOLEAN PbSynchronizer::SyncPhoneOne ( INT sim_row ) [virtual]

virtual BOOLEAN PbSynchronizer::SyncSim ( INT no_row ) [protected, pure virtual]

Implemented in PbLazySynchronizer, and PbManualSynchronizer.

BOOLEAN PbSynchronizer::SyncSimAll ( MmiAdvancedProgressBox * sync_progress_box = 0 ) [virtual]

BOOLEAN PbSynchronizer::SyncSimOne ( INT phone_row ) [virtual]

void PbSynchronizer::Update ( ) [virtual]

Reimplemented in PbManualSynchronizer.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbSynchronizer.hpp
  • Applications/AdvPhonebook/PbSynchronizer.cpp
Generated on Wed Jan 25 01:37:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PbToggleAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PbToggleAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for PbToggleAction:

[legend]
Collaboration diagram for PbToggleAction:

[legend]

Public Member Functions

PhonebookApp * GetPbApplication ()
void | Init (PhonebookApp *pb_app, const WCHAR *text)
PbToggleAction ()
virtual | ~PbToggleAction ()

Constructor & Destructor Documentation

PbToggleAction::PbToggleAction ( )

PbToggleAction::~PbToggleAction ( ) [virtual]

Member Function Documentation

PhonebookApp* PbToggleAction::GetPbApplication ( ) [inline]

void PbToggleAction::Init | ( | PhonebookApp * | pb_app,
 |  | const WCHAR * | text
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 01:37:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PcmParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PcmParam Struct Reference

#include <Apoxi/Devices/Win32/HostAudioDriver.hpp>

Data Fields

UINT8 | bit_rate
UINT32 | buffer_size
UINT16 * | file_handle
aud_pcm_format_enum | format
UINT8 | handle
aud_media_enum | media
aud_pcm_mode_enum | mode
aud_pcm_sample_rate_enum | sample_rate

Field Documentation

UINT8 PcmParam::bit_rate

UINT32 PcmParam::buffer_size

UINT16* PcmParam::file_handle

aud_pcm_format_enum PcmParam::format

UINT8 PcmParam::handle

aud_media_enum PcmParam::media

aud_pcm_mode_enum PcmParam::mode

aud_pcm_sample_rate_enum PcmParam::sample_rate

The documentation for this struct was generated from the following file:
  • Devices/Win32/HostAudioDriver.hpp
Generated on Wed Jan 25 01:37:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpAuthTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpAuthTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for PdpAuthTable:

[legend]
Collaboration diagram for PdpAuthTable:

[legend]

Static Public Member Functions

static const WCHAR * | GetAuthentication (AuthType auth_type)
static AuthType | GetAuthType (INT idx)
static const UINT | GetSize ()

Member Function Documentation

static const WCHAR* PdpAuthTable::GetAuthentication ( AuthType auth_type ) [inline, static]

static AuthType PdpAuthTable::GetAuthType ( INT idx ) [inline, static]

static const UINT PdpAuthTable::GetSize ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:37:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpContext Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/PdpContext.hpp>

Inheritance diagram for PdpContext:

[legend]
Collaboration diagram for PdpContext:

[legend]

Public Types

enum | { c_max_access_point_name_len, PdpContext }
enum | DataCompression { NoDataCompression = 0, PreferredDataCompression = 1, V42bis = 2, V44 = 3 }
a numeric parameter that controls PDP data compression (applicable for SNDCP only) (refer 3GPP TS 44.065 [61]) More...
typedef UINT32 | DataUnits
Typically DataUnits represent Bytes but other units are imaginable like packets, etc.
enum ErrorCause {
IllegalMs, PdpContext, IllegalMe, PdpContext,
GprsServiceNotAllowed, PdpContext, PlmnNotAllowed, PdpContext,
LaNotAllowed, PdpContext, NationalRoamingNotAllowed, PdpContext,
LlcOrSndcpFailure, PdpContext, InsufficientRessources, PdpContext,
MissingOrUnknownApn, PdpContext, UnknownPdpAddress, PdpContext,
AuthenticationFailure, PdpContext, ActivationRejectedByGgsn, PdpContext,
UnspecifiedActivationRejection, PdpContext, ServiceOptionNotSupported, PdpContext,
RequestedServiceOptionNotSubscribed, PdpContext, ServiceOptionTemporaryOutOfOrder, PdpContext,
NsapiAlreadyUsed, PdpContext, RegularDeactivation, PdpContext,
QosNotAccepted, PdpContext, NetworkFailure, PdpContext,
ReactivationRequired, PdpContext, InvalidTi, PdpContext,
SemanticIncorrectMsg, PdpContext, InvalidMandatoryIe, PdpContext,
MsgTypeNotExistent, PdpContext, MsgTypeNotCompatible, PdpContext,
IeNonExistent, PdpContext, ConditionalIeError, PdpContext,
MsgNotCompatible, PdpContext, UnspecifiedProtocolError, PdpContext,
UndefinedError, PdpContext, NoError, PdpContext
}
enum HeaderCompression {
NoHeaderCompression = 0, PreferredHeaderCompression = 1, Rfc1144 = 2, Rfc2507 = 3,
Rfc3095 = 4
}
a numeric parameter that controls PDP header compression (refer 3GPP TS 44.065 [61] and 3GPP TS 25.323 [62]) More...
typedef INT | Id
typedef UINT8 | NsApi
enum Origin {
Network, PdpContext, MobileStation, PdpContext,
UnknownOrigin, PdpContext
}
enum Protocol {
NullProtocol, PdpContext, PppProtocol, PdpContext,
PadProtocol, PdpContext, X25Protocol, PdpContext,
NoProtocol, PdpContext
}
enum | State { Undefined, Defined, Activated, Connected }
Context state. More...
enum Type {
IpType, PdpContext, IpStaticType, PdpContext,
IpDynamicType, PdpContext, PppType, PdpContext,
NoType, PdpContext
}

Public Member Functions

BOOLEAN | Accept (Type type=NoType, const Address &address=Address())
BOOLEAN | Activate (const PppFrame &ppp_frame)
BOOLEAN | Activate ()
Activates a context.
BOOLEAN | Authenticate (const Authentication &authentication)
Used to send an authentication request.
BOOLEAN | Connect (Protocol protocol)
BOOLEAN | Deactivate ()
Deactivates a context.
BOOLEAN | Define (DataCompression data_compression=NoDataCompression, HeaderCompression header_compression=NoHeaderCompression)
Defines and updates a secondary context (which is still in DEFINED state).
BOOLEAN | Define (Type type, const Address &address=Address(), const String &access_point_name=String(), DataCompression data_compression=NoDataCompression, HeaderCompression header_compression=NoHeaderCompression)
Defines and updates a primary context (which is still in DEFINED state).
NsApi | GetAccessPointId () const
const String & | GetAccessPointName () const
const ActivationStatus & | GetActivationStatus () const
Return activation status.
const Address & | GetAddress () const
DataCompression | GetDataCompression () const
HeaderCompression | GetHeaderCompression () const
Id | GetId () const
Returns ID of PDP context.
const QualityOfService & | GetMinimumQualityOfService () const
const PppFrame & | GetPppFrame () const
Return PPP Frame.
Id | GetPrimaryId () const
Returns the primary ID of the PDP context.
Protocol | GetProtocol () const
const QualityOfService & | GetQualityOfService () const
State | GetState () const
Returns context state.
Type | GetType () const
BOOLEAN | IsActive () const
Returns that context is running (active or connected).
BOOLEAN | IsAddressAllocatedDynamically () const
Returns if PDP address is dynamically assigned by the net.
BOOLEAN | IsAuthenticated () const
Return whether the context is already authenticated or not.
BOOLEAN | IsSecondary () const
Return whether the context is a secondary PdpContext or not.
BOOLEAN | ReadCounter ()
Reads the data counter values.
BOOLEAN | ReadNegotiatedDnsServerAddress ()
BOOLEAN | SetAutomaticDnsServerNegotiation (BOOLEAN enable)
BOOLEAN | SetCounter (DataUnits bytes_sent=0, DataUnits bytes_received=0)
Sets the data counters to the given values.
BOOLEAN | SetMinimumQualityOfService (const QualityOfService &quality_of_service)
BOOLEAN | SetPacketFilter (const PacketFilter &packet_filter)
Sets a packet filter.
BOOLEAN | SetQualityOfService (const QualityOfService &quality_of_service)
BOOLEAN | Undefine ()
Undefines a context and deletes it from context list.
BOOLEAN | UnsetPacketFilter (UINT8 packet_filter_id=0)

Static Public Member Functions

static void | Reject ()

Friends

class | PdpContextManager
class | PdpContextSignalProcessor

Data Structures

class | ActivationStatus
class | Address
class | Authentication
class | PacketFilter
PacketFilter, (see 3GPP TS 23.060). More...
class | QualityOfService

Member Typedef Documentation

typedef UINT32 PdpContext::DataUnits

Typically DataUnits represent Bytes but other units are imaginable like packets, etc.

typedef INT PdpContext::Id

typedef UINT8 PdpContext::NsApi

Member Enumeration Documentation

anonymous enum

Enumerator:
c_max_access_point_name_len
PdpContext

enum PdpContext::DataCompression

a numeric parameter that controls PDP data compression (applicable for SNDCP only) (refer 3GPP TS 44.065 [61])

Enumerator:
NoDataCompression
PreferredDataCompression
V42bis
V44

enum PdpContext::ErrorCause

Enumerator:
IllegalMs
PdpContext
IllegalMe
PdpContext
GprsServiceNotAllowed
PdpContext
PlmnNotAllowed
PdpContext
LaNotAllowed
PdpContext
NationalRoamingNotAllowed
PdpContext
LlcOrSndcpFailure
PdpContext
InsufficientRessources
PdpContext
MissingOrUnknownApn
PdpContext
UnknownPdpAddress
PdpContext
AuthenticationFailure
PdpContext
ActivationRejectedByGgsn
PdpContext
UnspecifiedActivationRejection
PdpContext
ServiceOptionNotSupported
PdpContext
RequestedServiceOptionNotSubscribed
PdpContext
ServiceOptionTemporaryOutOfOrder
PdpContext
NsapiAlreadyUsed
PdpContext
RegularDeactivation
PdpContext
QosNotAccepted
PdpContext
NetworkFailure
PdpContext
ReactivationRequired
PdpContext
InvalidTi
PdpContext
SemanticIncorrectMsg
PdpContext
InvalidMandatoryIe
PdpContext
MsgTypeNotExistent
PdpContext
MsgTypeNotCompatible
PdpContext
IeNonExistent
PdpContext
ConditionalIeError
PdpContext
MsgNotCompatible
PdpContext
UnspecifiedProtocolError
PdpContext
UndefinedError
PdpContext
NoError
PdpContext

enum PdpContext::HeaderCompression

a numeric parameter that controls PDP header compression (refer 3GPP TS 44.065 [61] and 3GPP TS 25.323 [62])

Enumerator:
NoHeaderCompression
PreferredHeaderCompression
Rfc1144
Rfc2507
Rfc3095

enum PdpContext::Origin

Enumerator:
Network
PdpContext
MobileStation
PdpContext
UnknownOrigin
PdpContext

enum PdpContext::Protocol

Enumerator:
NullProtocol
PdpContext
PppProtocol
PdpContext
PadProtocol
PdpContext
X25Protocol
PdpContext
NoProtocol
PdpContext

enum PdpContext::State

Context state.

Enumerator:
Undefined
Defined
Activated
Connected

enum PdpContext::Type

Enumerator:
IpType
PdpContext
IpStaticType
PdpContext
IpDynamicType
PdpContext
PppType
PdpContext
NoType
PdpContext

Member Function Documentation

BOOLEAN PdpContext::Accept | ( | Type | type = NoType,
 |  | const Address & | address = Address()
 | ) |

Accept a context activation request from the net, using m_id as new context - response should be used within the PdpContextManagerControl::OnActivateContextIndication() method.

BOOLEAN PdpContext::Activate ( const PppFrame & ppp_frame )

Used to send an activation request encoded in a ppp_frame. This request includes automatic user authentication. The only callback invoked afterwards is PdpContextControl::OnActivateCompleted(). Callback PdpContextControl::OnAuthenticateCompleted() is not invoked in this case.

BOOLEAN PdpContext::Activate ( )

Activates a context.

BOOLEAN PdpContext::Authenticate ( const Authentication & authentication )

Used to send an authentication request.

BOOLEAN PdpContext::Connect ( Protocol protocol )

Activates a context and establishes a connection. When connection is successfully established, then the access point id, and the current quality of service are available.

BOOLEAN PdpContext::Deactivate ( )

Deactivates a context.

BOOLEAN PdpContext::Define | ( | DataCompression | data_compression = NoDataCompression,
 |  | HeaderCompression | header_compression = NoHeaderCompression
 | ) |

Defines and updates a secondary context (which is still in DEFINED state).

BOOLEAN PdpContext::Define | ( | Type | type,
 |  | const Address & | address = Address(),
 |  | const String & | access_point_name = String(),
 |  | DataCompression | data_compression = NoDataCompression,
 |  | HeaderCompression | header_compression = NoHeaderCompression
 | ) |

Defines and updates a primary context (which is still in DEFINED state).

NsApi PdpContext::GetAccessPointId ( ) const [inline]

Return network service access point identifier

const String& PdpContext::GetAccessPointName ( ) const [inline]

Return name of access point name (APN).

const ActivationStatus& PdpContext::GetActivationStatus ( ) const [inline]

Return activation status.

const Address& PdpContext::GetAddress ( ) const [inline]

Return PDP address used for context definition (no address means dynamically allocation).

DataCompression PdpContext::GetDataCompression ( ) const [inline]

True if data compression is enabled (currently not supported)

HeaderCompression PdpContext::GetHeaderCompression ( ) const [inline]

True if header compression is enabled (currently not supported)

Id PdpContext::GetId ( ) const [inline]

Returns ID of PDP context.

const QualityOfService& PdpContext::GetMinimumQualityOfService ( ) const [inline]

Return minimum quality of service

const PppFrame& PdpContext::GetPppFrame ( ) const [inline]

Return PPP Frame.

Id PdpContext::GetPrimaryId ( ) const [inline]

Returns the primary ID of the PDP context.

Protocol PdpContext::GetProtocol ( ) const [inline]

Return layer 2 protocol

const QualityOfService& PdpContext::GetQualityOfService ( ) const [inline]

Return defined quality of service

State PdpContext::GetState ( ) const [inline]

Returns context state.

Type PdpContext::GetType ( ) const [inline]

Returns PDP type.

BOOLEAN PdpContext::IsActive ( ) const

Returns that context is running (active or connected).

BOOLEAN PdpContext::IsAddressAllocatedDynamically ( ) const [inline]

Returns if PDP address is dynamically assigned by the net.

BOOLEAN PdpContext::IsAuthenticated ( ) const [inline]

Return whether the context is already authenticated or not.

BOOLEAN PdpContext::IsSecondary ( ) const [inline]

Return whether the context is a secondary PdpContext or not.

BOOLEAN PdpContext::ReadCounter ( )

Reads the data counter values.

BOOLEAN PdpContext::ReadNegotiatedDnsServerAddress ( )

Reads the negotiated DNS server address. Note that this method just sends the read request to the stack. The DNS server address itself can be then read within the PdpContextControl::ReadNegotiatedDnsServerAddressCompleted() callback using the PdpContextManager::GetLastNegotiatedDnsServerAddrress() method.

void PdpContext::Reject ( ) [static]

Reject a context activation request from the net - response should be used within the PdpContextManagerControl::OnActivateContextIndication() method.

BOOLEAN PdpContext::SetAutomaticDnsServerNegotiation ( BOOLEAN enable )

Enables/disables the automatic DNS server address negotiation functionality. By default this functionality is disabled in stack. Therefore, to be able to read the negotiated DNS server address late on after the PDP context activation, this feature has to be enabled first. Note that enabling or disabling of the automatic DNS server address negotiation has to be done before activating the PDP context.

BOOLEAN PdpContext::SetCounter | ( | DataUnits | bytes_sent = 0,
 |  | DataUnits | bytes_received = 0
 | ) |

Sets the data counters to the given values.

BOOLEAN PdpContext::SetMinimumQualityOfService ( const QualityOfService & quality_of_service )

Define the minium requirements on quality of service. This change request must be sent before the context is activated!

BOOLEAN PdpContext::SetPacketFilter ( const PacketFilter & packet_filter )

Sets a packet filter.

BOOLEAN PdpContext::SetQualityOfService ( const QualityOfService & quality_of_service )

Used to send a change request for the quality of service profile. This change request must be sent before the context is activated!

BOOLEAN PdpContext::Undefine ( )

Undefines a context and deletes it from context list.

BOOLEAN PdpContext::UnsetPacketFilter ( UINT8 packet_filter_id = 0 )

Unsets/deletes a specified packet filter or unsets/deletes all packet filters if the packet_filter_id is set to 0.

Friends And Related Function Documentation

friend class PdpContextManager [friend]

friend class PdpContextSignalProcessor [friend]

The documentation for this class was generated from the following files:
  • Asc/PdpContext.hpp
  • Asc/Host/PdpContext.host.cpp
  • Asc/PdpContext.cpp
  • Asc/Target/PdpContext.target.cpp
Generated on Wed Jan 25 01:37:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContext::ActivationStatus Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PdpContext::ActivationStatus

PdpContext::ActivationStatus Class Reference

#include <Apoxi/Asc/PdpContext.hpp>

Collaboration diagram for PdpContext::ActivationStatus:

[legend]

Public Types

enum LlcSapi {
LlcSapi_NotAssigned, PdpContext_ActivationStatus, LlcSapi_1, PdpContext_ActivationStatus,
LlcSapi_3, PdpContext_ActivationStatus, LlcSapi_5, PdpContext_ActivationStatus,
LlcSapi_7, PdpContext_ActivationStatus, LlcSapi_9, PdpContext_ActivationStatus,
LlcSapi_11, PdpContext_ActivationStatus, LlcSapi_Invalid, PdpContext_ActivationStatus
}
LLC Service Access Point Identifier (SAPI) (see 3GPP 24.008 10.5.6.9). More...
enum RadioPriority {
RadioPriorityLevel_1, PdpContext_ActivationStatus, RadioPriorityLevel_2, PdpContext_ActivationStatus,
RadioPriorityLevel_3, PdpContext_ActivationStatus, RadioPriorityLevel_4, PdpContext_ActivationStatus,
RadioPriorityLevel_Undefined, PdpContext_ActivationStatus
}
Radio priority (see 3GPP 24.008 10.5.7.2). More...
enum State {
StateAccepted, PdpContext_ActivationStatus, StateRejected, PdpContext_ActivationStatus,
StateFiveTimeT3380Expiry, PdpContext_ActivationStatus, StateUserInteruption, PdpContext_ActivationStatus,
StateUnknownCause, PdpContext_ActivationStatus
}
Context activation state enumeration. More...

Public Member Functions

ActivationStatus (State state=StateUnknownCause, INT reject_cause=0, const QualityOfService &quality_of_service=QualityOfService(), LlcSapi llc_sapi=LlcSapi_NotAssigned, RadioPriority radio_priority=RadioPriorityLevel_Undefined, const Address &address=Address(), const String &apn=String(), INT t3380_expiries=0)
const String & | GetAccessPointName () const
Access Point Name.
const Address & | GetAddress () const
PDP Address.
LlcSapi | GetLlcSapi () const
Negotiated LLC Service Access Point Identifier (SAPI) (see 3GPP 24.008 10.5.6.9).
const QualityOfService & | GetQualityOfService () const
Negotiated Quality of Service.
RadioPriority | GetRadioPriority () const
Radio Priority (see 3GPP 24.008 10.5.7.2).
INT | GetRejectCause () const
Reject cause according to 3GPP 24.008 10.5.6.6.
State | GetState () const
Context Activation state.
INT | GetT3380Expiries () const
Number of T3380 expiries.
void | Reset ()
void | SetAccessPointName (const String &apn)
void | SetAddress (const Address &address)
void | SetLlcSapi (LlcSapi llc_sapi)
void | SetQualityOfService (const QualityOfService &quality_of_service)
void | SetRadioPriority (RadioPriority radio_priority)
void | SetRejectCause (INT reject_cause)
void | SetState (State state)
void | SetT3380Expiries (INT t3380_expiries)
~ActivationStatus ()

Member Enumeration Documentation

enum PdpContext::ActivationStatus::LlcSapi

LLC Service Access Point Identifier (SAPI) (see 3GPP 24.008 10.5.6.9).

Enumerator:
LlcSapi_NotAssigned
PdpContext_ActivationStatus
LlcSapi_1
PdpContext_ActivationStatus
LlcSapi_3
PdpContext_ActivationStatus
LlcSapi_5
PdpContext_ActivationStatus
LlcSapi_7
PdpContext_ActivationStatus
LlcSapi_9
PdpContext_ActivationStatus
LlcSapi_11
PdpContext_ActivationStatus
LlcSapi_Invalid
PdpContext_ActivationStatus

enum PdpContext::ActivationStatus::RadioPriority

Radio priority (see 3GPP 24.008 10.5.7.2).

Enumerator:
RadioPriorityLevel_1
PdpContext_ActivationStatus
RadioPriorityLevel_2
PdpContext_ActivationStatus
RadioPriorityLevel_3
PdpContext_ActivationStatus
RadioPriorityLevel_4
PdpContext_ActivationStatus
RadioPriorityLevel_Undefined
PdpContext_ActivationStatus

enum PdpContext::ActivationStatus::State

Context activation state enumeration.

Enumerator:
StateAccepted
PdpContext_ActivationStatus
StateRejected
PdpContext_ActivationStatus
StateFiveTimeT3380Expiry
PdpContext_ActivationStatus
StateUserInteruption
PdpContext_ActivationStatus
StateUnknownCause
PdpContext_ActivationStatus

Constructor & Destructor Documentation

PdpContext::ActivationStatus::ActivationStatus | ( | State | state = StateUnknownCause,
 |  | INT | reject_cause = 0,
 |  | const QualityOfService & | quality_of_service = QualityOfService(),
 |  | LlcSapi | llc_sapi = LlcSapi_NotAssigned,
 |  | RadioPriority | radio_priority = RadioPriorityLevel_Undefined,
 |  | const Address & | address = Address(),
 |  | const String & | apn = String(),
 |  | INT | t3380_expiries = 0
 | ) |

PdpContext::ActivationStatus::~ActivationStatus ( )

Member Function Documentation

const String& PdpContext::ActivationStatus::GetAccessPointName ( ) const [inline]

Access Point Name.

const Address& PdpContext::ActivationStatus::GetAddress ( ) const [inline]

PDP Address.

LlcSapi PdpContext::ActivationStatus::GetLlcSapi ( ) const [inline]

Negotiated LLC Service Access Point Identifier (SAPI) (see 3GPP 24.008 10.5.6.9).

const QualityOfService& PdpContext::ActivationStatus::GetQualityOfService ( ) const [inline]

Negotiated Quality of Service.

RadioPriority PdpContext::ActivationStatus::GetRadioPriority ( ) const [inline]

Radio Priority (see 3GPP 24.008 10.5.7.2).

INT PdpContext::ActivationStatus::GetRejectCause ( ) const [inline]

Reject cause according to 3GPP 24.008 10.5.6.6.

State PdpContext::ActivationStatus::GetState ( ) const [inline]

Context Activation state.

INT PdpContext::ActivationStatus::GetT3380Expiries ( ) const [inline]

Number of T3380 expiries.

void PdpContext::ActivationStatus::Reset ( )

void PdpContext::ActivationStatus::SetAccessPointName ( const String & apn ) [inline]

void PdpContext::ActivationStatus::SetAddress ( const Address & address ) [inline]

void PdpContext::ActivationStatus::SetLlcSapi ( LlcSapi llc_sapi ) [inline]

void PdpContext::ActivationStatus::SetQualityOfService ( const QualityOfService & quality_of_service ) [inline]

void PdpContext::ActivationStatus::SetRadioPriority ( RadioPriority radio_priority ) [inline]

void PdpContext::ActivationStatus::SetRejectCause ( INT reject_cause ) [inline]

void PdpContext::ActivationStatus::SetState ( State state ) [inline]

void PdpContext::ActivationStatus::SetT3380Expiries ( INT t3380_expiries ) [inline]

The documentation for this class was generated from the following files:
  • Asc/PdpContext.hpp
  • Asc/PdpContext.cpp
Generated on Wed Jan 25 01:37:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContext::Address Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PdpContext::Address

PdpContext::Address Class Reference

#include <Apoxi/Asc/PdpContext.hpp>

Public Types

enum | { c_max_len, PdpContext_Address }

Public Member Functions

Address (IpAddr ip_addr)
Set IPv4 address (three byte GSM Header is fix defined!!!).
Address (UINT8 *data=0, INT len=c_max_len)
Data consists of a three byte GSM Header and the following IPv4 (4 bytes) resp. IPv6 (16 bytes) address.
const UINT8 * | GetData () const
Returns pointer to address data.
IpAddr | GetIpAddr () const
Returns the IPv4 address.
String | GetIPv4String () const
Returns string representation.
UINT | GetLength () const
Returns length of address data.
BOOLEAN | IsIPv4 () const
Returns TRUE, if address is an IPv4 address.
BOOLEAN | IsValid () const
Returns, if address data is valid.
void | Reset ()
Resets the address buffer.

Member Enumeration Documentation

anonymous enum

Enumerator:
c_max_len
PdpContext_Address

Constructor & Destructor Documentation

PdpContext::Address::Address | ( | UINT8 * | data = 0,
 |  | INT | len = c_max_len
 | ) |

Data consists of a three byte GSM Header and the following IPv4 (4 bytes) resp. IPv6 (16 bytes) address.

PdpContext::Address::Address ( IpAddr ip_addr )

Set IPv4 address (three byte GSM Header is fix defined!!!).

Member Function Documentation

const UINT8 * PdpContext::Address::GetData ( ) const

Returns pointer to address data.

IpAddr PdpContext::Address::GetIpAddr ( ) const

Returns the IPv4 address.

String PdpContext::Address::GetIPv4String ( ) const

Returns string representation.

UINT PdpContext::Address::GetLength ( ) const

Returns length of address data.

BOOLEAN PdpContext::Address::IsIPv4 ( ) const

Returns TRUE, if address is an IPv4 address.

BOOLEAN PdpContext::Address::IsValid ( ) const

Returns, if address data is valid.

void PdpContext::Address::Reset ( )

Resets the address buffer.

The documentation for this class was generated from the following files:
  • Asc/PdpContext.hpp
  • Asc/PdpContext.cpp
Generated on Wed Jan 25 01:37:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContext::Authentication Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PdpContext::Authentication

PdpContext::Authentication Class Reference

#include <Apoxi/Asc/PdpContext.hpp>

Collaboration diagram for PdpContext::Authentication:

[legend]

Public Types

enum | { c_max_account_len, PdpContext_Authentication, c_max_password_len, PdpContext_Authentication }
enum Type {
None, PdpContext_Authentication, Pap, PdpContext_Authentication,
Chap, PdpContext_Authentication
}

Public Member Functions

Authentication (Type type=None, const String &account=String(), const String &password=String())
const String & | GetAccount () const
const String & | GetPassword () const
Type | GetType () const
void | SetAccount (const String &account)
Length restricted apply according to c_max_account_len.
void | SetPassword (const String &password)
Length restricted apply according to c_max_password_len.
void | SetType (Type type)
~Authentication ()

Member Enumeration Documentation

anonymous enum

Enumerator:
c_max_account_len
PdpContext_Authentication
c_max_password_len
PdpContext_Authentication

enum PdpContext::Authentication::Type

Enumerator:
None
PdpContext_Authentication
Pap
PdpContext_Authentication
Chap
PdpContext_Authentication

Constructor & Destructor Documentation

PdpContext::Authentication::Authentication | ( | Type | type = None,
 |  | const String & | account = String(),
 |  | const String & | password = String()
 | ) |

PdpContext::Authentication::~Authentication ( )

Member Function Documentation

const String& PdpContext::Authentication::GetAccount ( ) const [inline]

const String& PdpContext::Authentication::GetPassword ( ) const [inline]

Type PdpContext::Authentication::GetType ( ) const [inline]

void PdpContext::Authentication::SetAccount ( const String & account ) [inline]

Length restricted apply according to c_max_account_len.

void PdpContext::Authentication::SetPassword ( const String & password ) [inline]

Length restricted apply according to c_max_password_len.

void PdpContext::Authentication::SetType ( Type type ) [inline]

The documentation for this class was generated from the following files:
  • Asc/PdpContext.hpp
  • Asc/PdpContext.cpp
Generated on Wed Jan 25 01:38:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContext::PacketFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PdpContext::PacketFilter

PdpContext::PacketFilter Class Reference

PacketFilter, (see 3GPP TS 23.060). More...

#include <Apoxi/Asc/PdpContext.hpp>

Collaboration diagram for PdpContext::PacketFilter:

[legend]

Public Types

enum Type {
Type_1, PdpContext_PacketFilter, Type_2, PdpContext_PacketFilter,
Type_3, PdpContext_PacketFilter, Type_Unknown, PdpContext_PacketFilter
}
Packet Filter Type. More...

Public Member Functions

UINT8 | GetEvaluationPrecedenceIndex () const
Returns the Evaluation Precedence Index (EPI).
UINT32 | GetFlowLabel () const
Returns the Flow Label (IPv6).
UINT8 | GetId () const
Returns the Packet Filter Identifier (PFI).
UINT32 | GetIpSecSecurityParameterIndex () const
Returns the IPSec Security Parameter Index (IPSec SPI).
const IpPortNo & | GetLowerDestinationPort () const
Returns the lower port of the Destination Port Range.
const IpPortNo & | GetLowerSourcePort () const
Returns the lower port of the Source Port Range.
UINT8 | GetProtocolNumberOrNextHeader () const
Returns the Protocol Number (IPv4) / Next Header (IPv6).
const AddressAndMask & | GetSourceAddressAndSubnetMask () const
Returns the Source Address and Subnet Mask.
Type | GetType () const
Returns the Packet Filter Type (Type 1, 2, 3 or Unknown).
UINT8 | GetTypeOfServiceMaskOrTrafficClassMask () const
Returns the Mask of Type of Service (TOS) (IPv4) / Traffic Class (IPv6).
UINT8 | GetTypeOfServiceOrTrafficClass () const
Returns the Type of Service (TOS) (IPv4) / Traffic Class (IPv6).
const IpPortNo & | GetUpperDestinationPort () const
Returns the upper port of the Destination Port Range.
const IpPortNo & | GetUpperSourcePort () const
Returns the upper port of the Source Port Range.
BOOLEAN | IsDestinationPortRangePresent () const
Returns the precedence of the Destination Port Range.
BOOLEAN | IsFlowLabelPresent () const
Returns the precedence of the Flow Label (IPv6).
BOOLEAN | IsIpSecSecurityParameterIndexPresent () const
Returns the precedence of the IPSec Security Parameter Index (IPSec SPI).
BOOLEAN | IsProtocolNumberOrNextHeaderPresent () const
Returns the precedence of the Protocol Number (IPv4) / Next Header (IPv6).
BOOLEAN | IsSourceAddressAndSubnetMaskPresent () const
Returns the precedence of the Protocol Number (IPv4) / Next Header (IPv6).
BOOLEAN | IsSourcePortRangePresent () const
Returns the precedence of the Source Port Range.
BOOLEAN | IsTypeOfServiceAndMaskOrTrafficClassAndMaskPresent () const
Returns the precedence of the Type of Service (TOS) (IPv4) and Mask / Traffic Class (IPv6) and Mask.
PacketFilter (UINT8 id, UINT8 evaluation_precedence_index, const AddressAndMask &src_addr_and_mask, UINT8 tos_or_traffic_class, UINT8 tos_mask_or_traffic_class_mask, UINT32 flow_label)
PacketFilter constructor - Type 3.
PacketFilter (UINT8 id, UINT8 evaluation_precedence_index, const AddressAndMask &src_addr_and_mask, UINT8 prot_nbr_or_nxt_hdr, UINT32 ipsec_security_param_idx, UINT8 tos_or_traffic_class, UINT8 tos_mask_or_traffic_class_mask)
PacketFilter constructor - Type 2.
PacketFilter (UINT8 id, UINT8 evaluation_precedence_index, const AddressAndMask &src_addr_and_mask, UINT8 prot_nbr_or_nxt_hdr, const IpPortNo &lower_dst_port, const IpPortNo &upper_dst_port, const IpPortNo &lower_src_port, const IpPortNo &upper_src_port, UINT8 tos_or_traffic_class, UINT8 tos_mask_or_traffic_class_mask)
PacketFilter constructor - Type 1.
~PacketFilter ()

Friends

class | PdpContext

Data Structures

union | AddressAndMask

Detailed Description

PacketFilter, (see 3GPP TS 23.060).

Member Enumeration Documentation

enum PdpContext::PacketFilter::Type

Packet Filter Type.

Enumerator:
Type_1
PdpContext_PacketFilter
Type_2
PdpContext_PacketFilter
Type_3
PdpContext_PacketFilter
Type_Unknown
PdpContext_PacketFilter

Constructor & Destructor Documentation

PdpContext::PacketFilter::PacketFilter | ( | UINT8 | id,
 |  | UINT8 | evaluation_precedence_index,
 |  | const AddressAndMask & | src_addr_and_mask,
 |  | UINT8 | prot_nbr_or_nxt_hdr,
 |  | const IpPortNo & | lower_dst_port,
 |  | const IpPortNo & | upper_dst_port,
 |  | const IpPortNo & | lower_src_port,
 |  | const IpPortNo & | upper_src_port,
 |  | UINT8 | tos_or_traffic_class,
 |  | UINT8 | tos_mask_or_traffic_class_mask
 | ) |

PacketFilter constructor - Type 1.

PdpContext::PacketFilter::PacketFilter | ( | UINT8 | id,
 |  | UINT8 | evaluation_precedence_index,
 |  | const AddressAndMask & | src_addr_and_mask,
 |  | UINT8 | prot_nbr_or_nxt_hdr,
 |  | UINT32 | ipsec_security_param_idx,
 |  | UINT8 | tos_or_traffic_class,
 |  | UINT8 | tos_mask_or_traffic_class_mask
 | ) |

PacketFilter constructor - Type 2.

PdpContext::PacketFilter::PacketFilter | ( | UINT8 | id,
 |  | UINT8 | evaluation_precedence_index,
 |  | const AddressAndMask & | src_addr_and_mask,
 |  | UINT8 | tos_or_traffic_class,
 |  | UINT8 | tos_mask_or_traffic_class_mask,
 |  | UINT32 | flow_label
 | ) |

PacketFilter constructor - Type 3.

PdpContext::PacketFilter::~PacketFilter ( )

Member Function Documentation

UINT8 PdpContext::PacketFilter::GetEvaluationPrecedenceIndex ( ) const [inline]

Returns the Evaluation Precedence Index (EPI).

UINT32 PdpContext::PacketFilter::GetFlowLabel ( ) const [inline]

Returns the Flow Label (IPv6).

UINT8 PdpContext::PacketFilter::GetId ( ) const [inline]

Returns the Packet Filter Identifier (PFI).

UINT32 PdpContext::PacketFilter::GetIpSecSecurityParameterIndex ( ) const [inline]

Returns the IPSec Security Parameter Index (IPSec SPI).

const IpPortNo& PdpContext::PacketFilter::GetLowerDestinationPort ( ) const [inline]

Returns the lower port of the Destination Port Range.

const IpPortNo& PdpContext::PacketFilter::GetLowerSourcePort ( ) const [inline]

Returns the lower port of the Source Port Range.

UINT8 PdpContext::PacketFilter::GetProtocolNumberOrNextHeader ( ) const [inline]

Returns the Protocol Number (IPv4) / Next Header (IPv6).

const AddressAndMask& PdpContext::PacketFilter::GetSourceAddressAndSubnetMask ( ) const [inline]

Returns the Source Address and Subnet Mask.

PdpContext::PacketFilter::Type PdpContext::PacketFilter::GetType ( ) const

Returns the Packet Filter Type (Type 1, 2, 3 or Unknown).

UINT8 PdpContext::PacketFilter::GetTypeOfServiceMaskOrTrafficClassMask ( ) const [inline]

Returns the Mask of Type of Service (TOS) (IPv4) / Traffic Class (IPv6).

UINT8 PdpContext::PacketFilter::GetTypeOfServiceOrTrafficClass ( ) const [inline]

Returns the Type of Service (TOS) (IPv4) / Traffic Class (IPv6).

const IpPortNo& PdpContext::PacketFilter::GetUpperDestinationPort ( ) const [inline]

Returns the upper port of the Destination Port Range.

const IpPortNo& PdpContext::PacketFilter::GetUpperSourcePort ( ) const [inline]

Returns the upper port of the Source Port Range.

BOOLEAN PdpContext::PacketFilter::IsDestinationPortRangePresent ( ) const [inline]

Returns the precedence of the Destination Port Range.

BOOLEAN PdpContext::PacketFilter::IsFlowLabelPresent ( ) const [inline]

Returns the precedence of the Flow Label (IPv6).

BOOLEAN PdpContext::PacketFilter::IsIpSecSecurityParameterIndexPresent ( ) const [inline]

Returns the precedence of the IPSec Security Parameter Index (IPSec SPI).

BOOLEAN PdpContext::PacketFilter::IsProtocolNumberOrNextHeaderPresent ( ) const [inline]

Returns the precedence of the Protocol Number (IPv4) / Next Header (IPv6).

BOOLEAN PdpContext::PacketFilter::IsSourceAddressAndSubnetMaskPresent ( ) const [inline]

Returns the precedence of the Protocol Number (IPv4) / Next Header (IPv6).

BOOLEAN PdpContext::PacketFilter::IsSourcePortRangePresent ( ) const [inline]

Returns the precedence of the Source Port Range.

BOOLEAN PdpContext::PacketFilter::IsTypeOfServiceAndMaskOrTrafficClassAndMaskPresent ( ) const [inline]

Returns the precedence of the Type of Service (TOS) (IPv4) and Mask / Traffic Class (IPv6) and Mask.

Friends And Related Function Documentation

friend class PdpContext [friend]

The documentation for this class was generated from the following files:
  • Asc/PdpContext.hpp
  • Asc/PdpContext.cpp
Generated on Wed Jan 25 01:38:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContext::PacketFilter::AddressAndMask Union Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PdpContext::PacketFilter::AddressAndMask

PdpContext::PacketFilter::AddressAndMask Union Reference

#include <Apoxi/Asc/PdpContext.hpp>

Public Member Functions

AddressAndMask ()

Data Fields

struct {
UINT8 m_address [4]
UINT8 m_subnet [4]
} m_ipv4_address_and_mask
IPv4: in total 8 bytes; first 4 bytes IP, next 4 bytes Subnet Mask.
struct {
UINT8 m_address [16]
UINT8 m_subnet [16]
} m_ipv6_address_and_mask
IPv6: in total 32 bytes, first 16 bytes IP, next 16 bytes Subnet Mask.

Constructor & Destructor Documentation

PdpContext::PacketFilter::AddressAndMask::AddressAndMask ( ) [inline]

Field Documentation

UINT8 PdpContext::PacketFilter::AddressAndMask::m_address[16]

struct { ... } PdpContext::PacketFilter::AddressAndMask::m_ipv4_address_and_mask

IPv4: in total 8 bytes; first 4 bytes IP, next 4 bytes Subnet Mask.

struct { ... } PdpContext::PacketFilter::AddressAndMask::m_ipv6_address_and_mask

IPv6: in total 32 bytes, first 16 bytes IP, next 16 bytes Subnet Mask.

UINT8 PdpContext::PacketFilter::AddressAndMask::m_subnet[16]

The documentation for this union was generated from the following file:
  • Asc/PdpContext.hpp
Generated on Wed Jan 25 01:38:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContext::QualityOfService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PdpContext::QualityOfService

PdpContext::QualityOfService Class Reference

#include <Apoxi/Asc/PdpContext.hpp>

Public Types

enum Delay {
DelaySubscribed, PdpContext_QualityOfService, DelayClass1, PdpContext_QualityOfService,
DelayClass2, PdpContext_QualityOfService, DelayClass3, PdpContext_QualityOfService,
DelayBestEffort, PdpContext_QualityOfService, DelayReserved, PdpContext_QualityOfService
}
enum MeanRate {
MeanRateSubscribed, PdpContext_QualityOfService, MeanRate100, PdpContext_QualityOfService,
MeanRate200, PdpContext_QualityOfService, MeanRate500, PdpContext_QualityOfService,
MeanRate1K, PdpContext_QualityOfService, MeanRate2K, PdpContext_QualityOfService,
MeanRate5K, PdpContext_QualityOfService, MeanRate10K, PdpContext_QualityOfService,
MeanRate20K, PdpContext_QualityOfService, MeanRate50K, PdpContext_QualityOfService,
MeanRate100K, PdpContext_QualityOfService, MeanRate200K, PdpContext_QualityOfService,
MeanRate500K, PdpContext_QualityOfService, MeanRate1M, PdpContext_QualityOfService,
MeanRate2M, PdpContext_QualityOfService, MeanRate5M, PdpContext_QualityOfService,
MeanRate10M, PdpContext_QualityOfService, MeanRate20M, PdpContext_QualityOfService,
MeanRate50M, PdpContext_QualityOfService, MeanRateReserved, PdpContext_QualityOfService,
MeanRateBestEffort, PdpContext_QualityOfService
}
enum PeakRate {
PeakRateSubscribed, PdpContext_QualityOfService, PeakRate1K, PdpContext_QualityOfService,
PeakRate2K, PdpContext_QualityOfService, PeakRate4K, PdpContext_QualityOfService,
PeakRate8K, PdpContext_QualityOfService, PeakRate16K, PdpContext_QualityOfService,
PeakRate32K, PdpContext_QualityOfService, PeakRate64K, PdpContext_QualityOfService,
PeakRate128K, PdpContext_QualityOfService, PeakRate256K, PdpContext_QualityOfService,
PeakRateReserved, PdpContext_QualityOfService
}
enum Precedence {
PrecedenceSubscribed, PdpContext_QualityOfService, PrecedenceHigh, PdpContext_QualityOfService,
PrecedenceNormal, PdpContext_QualityOfService, PrecedenceLow, PdpContext_QualityOfService,
PrecedenceReserved, PdpContext_QualityOfService
}
enum Reliability {
ReliabilitySubscribed, PdpContext_QualityOfService, ReliabilityClass1, PdpContext_QualityOfService,
ReliabilityClass2, PdpContext_QualityOfService, ReliabilityClass3, PdpContext_QualityOfService,
ReliabilityClass4, PdpContext_QualityOfService, ReliabilityClass5, PdpContext_QualityOfService,
ReliabilityClass6, PdpContext_QualityOfService, ReliabilityReserved, PdpContext_QualityOfService
}

Public Member Functions

Delay | GetDelay () const
MeanRate | GetMeanRate () const
PeakRate | GetPeakRate () const
Precedence | GetPrecedence () const
Reliability | GetReliability () const
QualityOfService (Precedence precedence=PrecedenceSubscribed, Delay delay=DelaySubscribed, Reliability reliability=ReliabilitySubscribed, PeakRate peak_rate=PeakRateSubscribed, MeanRate mean_rate=MeanRateSubscribed)
void | Reset ()
void | SetDelay (Delay delay)
void | SetMeanRate (MeanRate mean_rate)
void | SetPeakRate (PeakRate peak_rate)
void | SetPrecedence (Precedence precedence)
void | SetReliability (Reliability reliability)
~QualityOfService ()

Member Enumeration Documentation

enum PdpContext::QualityOfService::Delay

Enumerator:
DelaySubscribed
PdpContext_QualityOfService
DelayClass1
PdpContext_QualityOfService
DelayClass2
PdpContext_QualityOfService
DelayClass3
PdpContext_QualityOfService
DelayBestEffort
PdpContext_QualityOfService
DelayReserved
PdpContext_QualityOfService

enum PdpContext::QualityOfService::MeanRate

Enumerator:
MeanRateSubscribed
PdpContext_QualityOfService
MeanRate100
PdpContext_QualityOfService
MeanRate200
PdpContext_QualityOfService
MeanRate500
PdpContext_QualityOfService
MeanRate1K
PdpContext_QualityOfService
MeanRate2K
PdpContext_QualityOfService
MeanRate5K
PdpContext_QualityOfService
MeanRate10K
PdpContext_QualityOfService
MeanRate20K
PdpContext_QualityOfService
MeanRate50K
PdpContext_QualityOfService
MeanRate100K
PdpContext_QualityOfService
MeanRate200K
PdpContext_QualityOfService
MeanRate500K
PdpContext_QualityOfService
MeanRate1M
PdpContext_QualityOfService
MeanRate2M
PdpContext_QualityOfService
MeanRate5M
PdpContext_QualityOfService
MeanRate10M
PdpContext_QualityOfService
MeanRate20M
PdpContext_QualityOfService
MeanRate50M
PdpContext_QualityOfService
MeanRateReserved
PdpContext_QualityOfService
MeanRateBestEffort
PdpContext_QualityOfService

enum PdpContext::QualityOfService::PeakRate

Enumerator:
PeakRateSubscribed
PdpContext_QualityOfService
PeakRate1K
PdpContext_QualityOfService
PeakRate2K
PdpContext_QualityOfService
PeakRate4K
PdpContext_QualityOfService
PeakRate8K
PdpContext_QualityOfService
PeakRate16K
PdpContext_QualityOfService
PeakRate32K
PdpContext_QualityOfService
PeakRate64K
PdpContext_QualityOfService
PeakRate128K
PdpContext_QualityOfService
PeakRate256K
PdpContext_QualityOfService
PeakRateReserved
PdpContext_QualityOfService

enum PdpContext::QualityOfService::Precedence

Enumerator:
PrecedenceSubscribed
PdpContext_QualityOfService
PrecedenceHigh
PdpContext_QualityOfService
PrecedenceNormal
PdpContext_QualityOfService
PrecedenceLow
PdpContext_QualityOfService
PrecedenceReserved
PdpContext_QualityOfService

enum PdpContext::QualityOfService::Reliability

Enumerator:
ReliabilitySubscribed
PdpContext_QualityOfService
ReliabilityClass1
PdpContext_QualityOfService
ReliabilityClass2
PdpContext_QualityOfService
ReliabilityClass3
PdpContext_QualityOfService
ReliabilityClass4
PdpContext_QualityOfService
ReliabilityClass5
PdpContext_QualityOfService
ReliabilityClass6
PdpContext_QualityOfService
ReliabilityReserved
PdpContext_QualityOfService

Constructor & Destructor Documentation

PdpContext::QualityOfService::QualityOfService | ( | Precedence | precedence = PrecedenceSubscribed,
 |  | Delay | delay = DelaySubscribed,
 |  | Reliability | reliability = ReliabilitySubscribed,
 |  | PeakRate | peak_rate = PeakRateSubscribed,
 |  | MeanRate | mean_rate = MeanRateSubscribed
 | ) |

PdpContext::QualityOfService::~QualityOfService ( )

Member Function Documentation

Delay PdpContext::QualityOfService::GetDelay ( ) const [inline]

MeanRate PdpContext::QualityOfService::GetMeanRate ( ) const [inline]

PeakRate PdpContext::QualityOfService::GetPeakRate ( ) const [inline]

Precedence PdpContext::QualityOfService::GetPrecedence ( ) const [inline]

Reliability PdpContext::QualityOfService::GetReliability ( ) const [inline]

void PdpContext::QualityOfService::Reset ( )

void PdpContext::QualityOfService::SetDelay ( Delay delay ) [inline]

void PdpContext::QualityOfService::SetMeanRate ( MeanRate mean_rate ) [inline]

void PdpContext::QualityOfService::SetPeakRate ( PeakRate peak_rate ) [inline]

void PdpContext::QualityOfService::SetPrecedence ( Precedence precedence ) [inline]

void PdpContext::QualityOfService::SetReliability ( Reliability reliability ) [inline]

The documentation for this class was generated from the following files:
  • Asc/PdpContext.hpp
  • Asc/PdpContext.cpp
Generated on Wed Jan 25 01:38:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContextActivationStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpContextActivationStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PdpContextActivationStatusMsg:

[legend]
Collaboration diagram for PdpContextActivationStatusMsg:

[legend]

Public Types

enum | { ID = 18709 }

Public Member Functions

virtual Message * | Clone () const
const PdpContext::ActivationStatus & | GetActivationStatus () const
INT | GetContextId () const
virtual const MsgMetaData & | GetMetaData () const
PdpContextActivationStatusMsg (INT contextId, const PdpContext::ActivationStatus &activationStatus)
void | SetActivationStatus (const PdpContext::ActivationStatus &activationStatus)
void | SetContextId (INT contextId)
virtual | ~PdpContextActivationStatusMsg ()

Detailed Description

PdpContextActivationStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PdpContextActivationStatusMsg::PdpContextActivationStatusMsg | ( | INT | contextId,
 |  | const PdpContext::ActivationStatus & | activationStatus
 | ) |

PdpContextActivationStatusMsg::~PdpContextActivationStatusMsg ( ) [virtual]

Member Function Documentation

Message * PdpContextActivationStatusMsg::Clone ( ) const [virtual]

Implements Message.

const PdpContext::ActivationStatus& PdpContextActivationStatusMsg::GetActivationStatus ( ) const [inline]

INT PdpContextActivationStatusMsg::GetContextId ( ) const [inline]

const MsgMetaData & PdpContextActivationStatusMsg::GetMetaData ( ) const [virtual]

Implements Message.

void PdpContextActivationStatusMsg::SetActivationStatus ( const PdpContext::ActivationStatus & activationStatus ) [inline]

void PdpContextActivationStatusMsg::SetContextId ( INT contextId ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:38:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContextControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpContextControl Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/PdpContextControl.hpp>

Inheritance diagram for PdpContextControl:

[legend]
Collaboration diagram for PdpContextControl:

[legend]

Public Member Functions

PdpContext * | GetContext () const
PdpContextControl ()
virtual | ~PdpContextControl ()
Requested asynchronous responses
These callbacks are asynchronously called as responses to previously put requests.

virtual void | OnActivateCompleted (PdpContext::ErrorCause cause)
virtual void | OnAuthenticateCompleted (PdpContext::ErrorCause cause)
virtual void | OnConnectCompleted (PdpContext::ErrorCause cause)
virtual void | OnDeactivateCompleted (PdpContext::ErrorCause cause)
virtual void | OnDefineCompleted (PdpContext::ErrorCause cause)
virtual void | OnReadCounterCompleted (PdpContext::ErrorCause cause)
virtual void | OnReadNegotiatedDnsServerAddressCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetAutomaticDnsServerNegotiationCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetCounterCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetMinimumQualityOfServiceCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetPacketFilterCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetQualityOfServiceCompleted (PdpContext::ErrorCause cause)
virtual void | OnUndefineCompleted (PdpContext::ErrorCause cause)
virtual void | OnUnsetPacketFilterCompleted (PdpContext::ErrorCause cause)
Unsolicited asynchronous indications
These callbacks are asynchronously called either by the network or by another process (ATC) to indicate certain events.

virtual void | OnActivationStatusContextIndication ()
virtual void | OnDeactivateIndication (PdpContext::ErrorCause cause, PdpContext::Origin origin=PdpContext::UnknownOrigin)
virtual void | OnReactivateIndication ()

Friends

class | PdpContextManager

Detailed Description

This class contains the callback routines called upon arrival of signals dedicated to the associated PDP context.

Constructor & Destructor Documentation

PdpContextControl::PdpContextControl ( ) [inline]

virtual PdpContextControl::~PdpContextControl ( ) [inline, virtual]

Member Function Documentation

PdpContext* PdpContextControl::GetContext ( ) const [inline]

Returns the PDP context that this context control is attached to. If it is currently not attached, then 0 is returned.

virtual void PdpContextControl::OnActivateCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Activate(). If activation was triggered using a PPP frame, then the context's internal PPP frame represents the PPP frame returned by the stack, otherwise the context's internal PPP frame is empty.

virtual void PdpContextControl::OnActivationStatusContextIndication ( ) [inline, virtual]

Invoked upon receipt of the stack indication of an unsolicited context activation status event.

virtual void PdpContextControl::OnAuthenticateCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Authenticate().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnConnectCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Connect().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnDeactivateCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Deactivate().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnDeactivateIndication | ( | PdpContext::ErrorCause | cause,
 |  | PdpContext::Origin | origin = PdpContext::UnknownOrigin
 | ) | [inline, virtual]

Invoked upon receipt of the stack indication of an unsolicited context deactivation event.

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnDefineCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Define().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnReactivateIndication ( ) [inline, virtual]

Invoked upon receipt of the stack indication of an unsolicited context reactivation event coming up from the net.

virtual void PdpContextControl::OnReadCounterCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::ReadCounter().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnReadNegotiatedDnsServerAddressCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::ReadNegotiatedDnsServerAddress().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnSetAutomaticDnsServerNegotiationCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetAutomaticDnsServerNegotiation().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnSetCounterCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetCounter().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnSetMinimumQualityOfServiceCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetMinimumQualityOfService().

virtual void PdpContextControl::OnSetPacketFilterCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetPacketFilter().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnSetQualityOfServiceCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetQualityOfService().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnUndefineCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Undefine().

Reimplemented in PsdDataConn.

virtual void PdpContextControl::OnUnsetPacketFilterCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::UnsetPacketFilter().

Friends And Related Function Documentation

friend class PdpContextManager [friend]

The documentation for this class was generated from the following file:
  • Asc/PdpContextControl.hpp
Generated on Wed Jan 25 01:38:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContextManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpContextManager Class Reference

#include <Apoxi/Asc/PdpContextManager.hpp>

Collaboration diagram for PdpContextManager:

[legend]

Public Types

enum | { c_max_cid_array_len, PdpContextManager }
enum ExternalContextState {
c_ext_ctx_state_invalid = 0, c_ext_ctx_state_connecting = 1, c_ext_ctx_state_connected = 2, c_ext_ctx_state_disconnecting = 3,
c_ext_ctx_state_disconnected = 4
}
enum State {
Idle, AttachPending, DetachPending, ResetCountersPending,
ReadCountersPending, PrimaryDefinePending, PrimaryUndefinePending, SecondaryDefinePending,
SecondaryUndefinePending, AuthenticatePending, SetQualityOfServicePending, SetMinimumQualityOfServicePending,
ActivatePending, NetworkRequestPending, DeactivatePending, ConnectPending,
SetCounterPending, ReadCounterPending, SetPacketFilterPending, UnsetPacketFilterPending,
SetAutomaticDnsServerNegotiationPending, ReadNegotiatedDnsServerAddressPending
}

Static Public Member Functions

static void | Attach ()
Requests a GPRS attach.
static BOOLEAN | AttachManagerControl (PdpContextManagerControl *context_manager_control=0)
static PdpContext * | CreateContext (PdpContextControl &context_control, PdpContext *primary_context=0)
static void | Detach ()
Requests a GPRS detach.
static PdpContext * | FindContext (PdpContext::Id id)
static const AttachStatus & | GetAttachStatus ()
Returns the GPRS attach status.
static PdpContextControl * | GetContextControl (PdpContext *context)
static PdpContextManagerControl * | GetContextManagerControl ()
Retrieve the actual PDP context manager control object.
static BOOLEAN | GetDataCounters (UINT32 &sent, UINT32 &received)
static void | GetLastNegotiatedDnsServerAddresses (IpAddr &primary_dns, IpAddr &secondary_dns)
static const DataCounters & | GetLastStackDataCounters ()
static State | GetState ()
Returns the current state of the PDP context manager.
static void | Init ()
static BOOLEAN | IsAttached ()
Tells if GPRS is attached or not.
static void | Register ()
static BOOLEAN | ResetDataCounters ()

Static Protected Member Functions

static Semaphore & | GetSemaphore ()

Friends

class | PdpContext
class | PdpContextSignalProcessor

Data Structures

class | AttachStatus
struct | DataCounters
struct | PdpContextInfo
Structure for storing a PDP context ID and its current usage state.

Detailed Description

Provides registration of PDP contexts to the system and manages all registered PDP contexts.

Member Enumeration Documentation

anonymous enum

Enumerator:
c_max_cid_array_len
PdpContextManager

enum PdpContextManager::ExternalContextState

Enumerator:
c_ext_ctx_state_invalid | Invalid state.
c_ext_ctx_state_connecting | Enter L2-protocol.
c_ext_ctx_state_connected | Start data transfer.
c_ext_ctx_state_disconnecting | Request end of data transfer.
c_ext_ctx_state_disconnected | End data transfer.

enum PdpContextManager::State

Enumerator:
Idle
AttachPending
DetachPending
ResetCountersPending
ReadCountersPending
PrimaryDefinePending
PrimaryUndefinePending
SecondaryDefinePending
SecondaryUndefinePending
AuthenticatePending
SetQualityOfServicePending
SetMinimumQualityOfServicePending
ActivatePending
NetworkRequestPending
DeactivatePending
ConnectPending
SetCounterPending
ReadCounterPending
SetPacketFilterPending
UnsetPacketFilterPending
SetAutomaticDnsServerNegotiationPending
ReadNegotiatedDnsServerAddressPending

Member Function Documentation

void PdpContextManager::Attach ( ) [static]

Requests a GPRS attach.

BOOLEAN PdpContextManager::AttachManagerControl ( PdpContextManagerControl * context_manager_control = 0 ) [static]

Attaches the specified PDP context manager control object context_manager_control to the PDP context manager. If context_manager_control is 0 then the context managers control object is reset.

PdpContext * PdpContextManager::CreateContext | ( | PdpContextControl & | context_control,
 |  | PdpContext * | primary_context = 0
 | ) | [static]

Creates and returns a new PDP context which is attached to the specified PDP context_control. This new PDP context is owned by this context manager. If the stack runs out of resources for allocating a new context, then 0 is returned. By default a primary context will be created. If an additional primary context is specified, then a secondary context will be created which uses primary_context as its primary context. However, if the additional primary context doesn't exist or is a secondary context, then the secondary context can't be created and therefore 0 will be returned.

void PdpContextManager::Detach ( ) [static]

Requests a GPRS detach.

PdpContext * PdpContextManager::FindContext ( PdpContext::Id id ) [static]

Looks up if the context (primary or secondary) with the given id exists and returns it.

static const AttachStatus& PdpContextManager::GetAttachStatus ( ) [inline, static]

Returns the GPRS attach status.

static PdpContextControl* PdpContextManager::GetContextControl ( PdpContext * context ) [inline, static]

Retrieve the PDP context control object for the specified PDP context.

static PdpContextManagerControl* PdpContextManager::GetContextManagerControl ( ) [inline, static]

Retrieve the actual PDP context manager control object.

BOOLEAN PdpContextManager::GetDataCounters | ( | UINT32 & | sent,
 |  | UINT32 & | received
 | ) | [static]

Returns the sent and received data counter from all contexts. The values represent the counted data since power-up or last resetting them using PdpContextManager::ResetDataCounters(). Please note: This method does an active wait until all counters have been read.

static void PdpContextManager::GetLastNegotiatedDnsServerAddresses | ( | IpAddr & | primary_dns,
 |  | IpAddr & | secondary_dns
 | ) | [inline, static]

Returns the result of the last DNS server read request. This method must only be used on the PdpContext::OnReadDnsServerCompleted() callback!!!

static const DataCounters& PdpContextManager::GetLastStackDataCounters ( ) [inline, static]

Returns the result of the last data counter stack request. This method must only be used on the PdpContext::OnReadCounterCompleted() callback!!!

static Semaphore& PdpContextManager::GetSemaphore ( ) [inline, static, protected]

static State PdpContextManager::GetState ( ) [inline, static]

Returns the current state of the PDP context manager.

void PdpContextManager::Init ( ) [static]

Initializes the PDP context manager. Must only be called in the StackControl::OnPowerUp() method!!!

static BOOLEAN PdpContextManager::IsAttached ( ) [inline, static]

Tells if GPRS is attached or not.

void PdpContextManager::Register ( ) [static]

Register the interface to the PCH thread. This should be performed at startup time (PowerUp).

BOOLEAN PdpContextManager::ResetDataCounters ( ) [static]

Resets data counters of all contexts. Please note: This method does an active wait until all counters have been reseted.

Friends And Related Function Documentation

friend class PdpContext [friend]

friend class PdpContextSignalProcessor [friend]

The documentation for this class was generated from the following files:
  • Asc/PdpContextManager.hpp
  • Asc/Host/PdpContextManager.host.cpp
  • Asc/PdpContextManager.cpp
  • Asc/Target/PdpContextManager.target.cpp
Generated on Wed Jan 25 01:38:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContextManager::AttachStatus Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PdpContextManager::AttachStatus

PdpContextManager::AttachStatus Class Reference

#include <Apoxi/Asc/PdpContextManager.hpp>

Public Types

enum State {
StateAccepted, PdpContextManager_AttachStatus, StateRejected, PdpContextManager_AttachStatus,
StateFiveTimeT3310Expiry, PdpContextManager_AttachStatus, StateUserInteruption, PdpContextManager_AttachStatus,
StateUnknownCause, PdpContextManager_AttachStatus
}
Attach state enumeration. More...

Public Member Functions

AttachStatus (State state=StateUnknownCause, UINT8 ready_timer=0, UINT8 reject_cause=0, INT t3310_expiries=0)
UINT8 | GetReadyTimer () const
Get ready timer according to 3GPP 24.008 10.5.7.3.
UINT8 | GetRejectCause () const
Get reject cause according to 3GPP 24.008 10.5.5.14.
State | GetState () const
Get attach state.
INT | GetT3310Expiries () const
Get number of T3310 expiries.
void | Reset ()
void | SetReadyTimer (UINT8 ready_timer)
Set ready timer according to 3GPP 24.008 10.5.7.3.
void | SetRejectCause (UINT8 reject_cause)
Set reject cause according to 3GPP 24.008 10.5.5.14.
void | SetState (State state)
Set attach state.
void | SetT3310Expiries (INT t3310_expiries)
Set number of T3310 expiries.
~AttachStatus ()

Member Enumeration Documentation

enum PdpContextManager::AttachStatus::State

Attach state enumeration.

Enumerator:
StateAccepted
PdpContextManager_AttachStatus
StateRejected
PdpContextManager_AttachStatus
StateFiveTimeT3310Expiry
PdpContextManager_AttachStatus
StateUserInteruption
PdpContextManager_AttachStatus
StateUnknownCause
PdpContextManager_AttachStatus

Constructor & Destructor Documentation

PdpContextManager::AttachStatus::AttachStatus | ( | State | state = StateUnknownCause,
 |  | UINT8 | ready_timer = 0,
 |  | UINT8 | reject_cause = 0,
 |  | INT | t3310_expiries = 0
 | ) |

PdpContextManager::AttachStatus::~AttachStatus ( )

Member Function Documentation

UINT8 PdpContextManager::AttachStatus::GetReadyTimer ( ) const [inline]

Get ready timer according to 3GPP 24.008 10.5.7.3.

UINT8 PdpContextManager::AttachStatus::GetRejectCause ( ) const [inline]

Get reject cause according to 3GPP 24.008 10.5.5.14.

State PdpContextManager::AttachStatus::GetState ( ) const [inline]

Get attach state.

INT PdpContextManager::AttachStatus::GetT3310Expiries ( ) const [inline]

Get number of T3310 expiries.

void PdpContextManager::AttachStatus::Reset ( )

void PdpContextManager::AttachStatus::SetReadyTimer ( UINT8 ready_timer ) [inline]

Set ready timer according to 3GPP 24.008 10.5.7.3.

void PdpContextManager::AttachStatus::SetRejectCause ( UINT8 reject_cause ) [inline]

Set reject cause according to 3GPP 24.008 10.5.5.14.

void PdpContextManager::AttachStatus::SetState ( State state ) [inline]

Set attach state.

void PdpContextManager::AttachStatus::SetT3310Expiries ( INT t3310_expiries ) [inline]

Set number of T3310 expiries.

The documentation for this class was generated from the following files:
  • Asc/PdpContextManager.hpp
  • Asc/PdpContextManager.cpp
Generated on Wed Jan 25 01:38:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContextManager::DataCounters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PdpContextManager::DataCounters

PdpContextManager::DataCounters Struct Reference

#include <Apoxi/Asc/PdpContextManager.hpp>

Public Member Functions

void | Reset ()

Data Fields

UINT32 | m_session_received
UINT32 | m_session_sent
UINT32 | m_total_received
UINT32 | m_total_sent

Member Function Documentation

void PdpContextManager::DataCounters::Reset ( ) [inline]

Field Documentation

UINT32 PdpContextManager::DataCounters::m_session_received

UINT32 PdpContextManager::DataCounters::m_session_sent

UINT32 PdpContextManager::DataCounters::m_total_received

UINT32 PdpContextManager::DataCounters::m_total_sent

The documentation for this struct was generated from the following file:
  • Asc/PdpContextManager.hpp
Generated on Wed Jan 25 01:38:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContextManagerControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpContextManagerControl Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/PdpContextManagerControl.hpp>

Public Member Functions

PdpContextManagerControl ()
virtual | ~PdpContextManagerControl ()
Unsolicited asynchronous indications
These callbacks are asynchronously called either by the network or by another process (ATC) to indicate certain events.

virtual void | OnActivateContextIndication (PdpContext::Type type, PdpContext::Address address)
virtual void | OnAttachRep (BOOLEAN attached)
virtual void | OnAttachStatusIndication ()
virtual void | OnDetachIndication (PdpContext::ErrorCause cause, PdpContext::Origin origin=PdpContext::UnknownOrigin)
Requested asynchronous responses
These callbacks are asynchronously called as responses to previously put requests.

virtual void | OnAttachCompleted (PdpContext::ErrorCause cause)
virtual void | OnDetachCompleted (PdpContext::ErrorCause cause)

Detailed Description

This class contains the callback routines called upon arrival of signals dedicated to the PDP context manager.

Constructor & Destructor Documentation

PdpContextManagerControl::PdpContextManagerControl ( ) [inline]

virtual PdpContextManagerControl::~PdpContextManagerControl ( ) [inline, virtual]

Member Function Documentation

virtual void PdpContextManagerControl::OnActivateContextIndication | ( | PdpContext::Type | type,
 |  | PdpContext::Address | address
 | ) | [inline, virtual]

Invoked upon receipt of the stack indication of an unsolicited context activation event coming up from the net. Response must be performed by using any new PdpContext, and it's Accept()-method, or by rejecting the request using PdpContext's static method Reject().

virtual void PdpContextManagerControl::OnAttachCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContextManager::Attach().

virtual void PdpContextManagerControl::OnAttachRep ( BOOLEAN attached ) [inline, virtual]

Invoked upon receipt of the stack report of an unsolicited attach event.

virtual void PdpContextManagerControl::OnAttachStatusIndication ( ) [inline, virtual]

Invoked upon receipt of the stack report of an unsolicited attach status event.

virtual void PdpContextManagerControl::OnDetachCompleted ( PdpContext::ErrorCause cause ) [inline, virtual]

Invoked upon receipt of the stack response of previously submitted PdpContextManager::Detach().

virtual void PdpContextManagerControl::OnDetachIndication | ( | PdpContext::ErrorCause | cause,
 |  | PdpContext::Origin | origin = PdpContext::UnknownOrigin
 | ) | [inline, virtual]

Invoked upon receipt of the stack indication of an unsolicited detach event.

The documentation for this class was generated from the following file:
  • Asc/PdpContextManagerControl.hpp
Generated on Wed Jan 25 01:38:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContextSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpContextSignalMapTableNode Class Reference

#include <Apoxi/Asc/Target/PdpContextSignalMapTableNode.hpp>

Inheritance diagram for PdpContextSignalMapTableNode:

[legend]
Collaboration diagram for PdpContextSignalMapTableNode:

[legend]

Static Public Member Functions

static PdpContextSignalMapTableNode * GetInstance ()

Member Function Documentation

PdpContextSignalMapTableNode * PdpContextSignalMapTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Asc/Target/PdpContextSignalMapTableNode.hpp
  • Asc/Target/PdpContextSignalMapTableNode.cpp
Generated on Wed Jan 25 01:38:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpContextSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpContextSignalProcessor Class Reference

#include <Apoxi/Asc/Target/PdpContextSignalProcessor.hpp>

Static Public Member Functions

static void | ProcessMnAttachStatusInd (const ProcessPtr &process_ptr)
static void | ProcessPchActCompleteInd (const ProcessPtr &process_ptr)
static void | ProcessPchActFailedInd (const ProcessPtr &process_ptr)
static void | ProcessPchActivateCnf (const ProcessPtr &process_ptr)
static void | ProcessPchActivateInd (const ProcessPtr &process_ptr)
static void | ProcessPchActivateRej (const ProcessPtr &process_ptr)
static void | ProcessPchActivateStatusInd (const ProcessPtr &process_ptr)
static void | ProcessPchAttachCnf (const ProcessPtr &process_ptr)
static void | ProcessPchAttachRej (const ProcessPtr &process_ptr)
static void | ProcessPchAttachRep (const ProcessPtr &process_ptr)
static void | ProcessPchAuthCnf (const ProcessPtr &process_ptr)
static void | ProcessPchAuthRej (const ProcessPtr &process_ptr)
static void | ProcessPchCgdsContCnf (const ProcessPtr &process_ptr)
static void | ProcessPchCgdsContRej (const ProcessPtr &process_ptr)
static void | ProcessPchCgTftCnf (const ProcessPtr &process_ptr)
static void | ProcessPchCgTftRej (const ProcessPtr &process_ptr)
static void | ProcessPchDataStateCnf (const ProcessPtr &process_ptr)
static void | ProcessPchDataStateRej (const ProcessPtr &process_ptr)
static void | ProcessPchDeactivateCnf (const ProcessPtr &process_ptr)
static void | ProcessPchDeactivateInd (const ProcessPtr &process_ptr)
static void | ProcessPchDefContCnf (const ProcessPtr &process_ptr)
static void | ProcessPchDefContRej (const ProcessPtr &process_ptr)
static void | ProcessPchDetachCnf (const ProcessPtr &process_ptr)
static void | ProcessPchDetachInd (const ProcessPtr &process_ptr)
static void | ProcessPchPppActCnf (const ProcessPtr &process_ptr)
static void | ProcessPchReactivateInd (const ProcessPtr &process_ptr)
static void | ProcessPchReadCntInd (const ProcessPtr &process_ptr)
static void | ProcessPchReadCntRej (const ProcessPtr &process_ptr)
static void | ProcessPchReadDnsCnf (const ProcessPtr &process_ptr)
static void | ProcessPchReadDnsRej (const ProcessPtr &process_ptr)
static void | ProcessPchSetCntCnf (const ProcessPtr &process_ptr)
static void | ProcessPchSetCntRej (const ProcessPtr &process_ptr)
static void | ProcessPchSetDnsCnf (const ProcessPtr &process_ptr)
static void | ProcessPchSetDnsRej (const ProcessPtr &process_ptr)
static void | ProcessPchSetQosCnf (const ProcessPtr &process_ptr)
static void | ProcessPchSetQosMinCnf (const ProcessPtr &process_ptr)
static void | ProcessPchSetQosMinRej (const ProcessPtr &process_ptr)
static void | ProcessPchSetQosRej (const ProcessPtr &process_ptr)

Detailed Description

PdpContextSignalProcessor

Member Function Documentation

void PdpContextSignalProcessor::ProcessMnAttachStatusInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchActCompleteInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchActFailedInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchActivateCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchActivateInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchActivateRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchActivateStatusInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchAttachCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchAttachRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchAttachRep ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchAuthCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchAuthRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchCgdsContCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchCgdsContRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchCgTftCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchCgTftRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchDataStateCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchDataStateRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchDeactivateCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchDeactivateInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchDefContCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchDefContRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchDetachCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchDetachInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchPppActCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchReactivateInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchReadCntInd ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchReadCntRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchReadDnsCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchReadDnsRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchSetCntCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchSetCntRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchSetDnsCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchSetDnsRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchSetQosCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchSetQosMinCnf ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchSetQosMinRej ( const ProcessPtr & process_ptr ) [static]

void PdpContextSignalProcessor::ProcessPchSetQosRej ( const ProcessPtr & process_ptr ) [static]

The documentation for this class was generated from the following files:
  • Asc/Target/PdpContextSignalProcessor.hpp
  • Asc/Target/PdpContextSignalProcessor.cpp
Generated on Wed Jan 25 01:38:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpQoSDelayTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpQoSDelayTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for PdpQoSDelayTable:

[legend]
Collaboration diagram for PdpQoSDelayTable:

[legend]

Static Public Member Functions

static const WCHAR * | GetQoS (QoS::Delay qos_delay)
static QoS::Delay | GetQoSType (INT idx)
static const UINT | GetSize ()

Member Function Documentation

static const WCHAR* PdpQoSDelayTable::GetQoS ( QoS::Delay qos_delay ) [inline, static]

static QoS::Delay PdpQoSDelayTable::GetQoSType ( INT idx ) [inline, static]

static const UINT PdpQoSDelayTable::GetSize ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:38:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpQoSMeanRateTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpQoSMeanRateTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for PdpQoSMeanRateTable:

[legend]
Collaboration diagram for PdpQoSMeanRateTable:

[legend]

Static Public Member Functions

static const WCHAR * | GetQoS (PdpContext::QualityOfService::MeanRate qos_mean_rate)
static QoS::MeanRate | GetQoSType (INT idx)
static const UINT | GetSize ()

Member Function Documentation

static const WCHAR* PdpQoSMeanRateTable::GetQoS ( PdpContext::QualityOfService::MeanRate qos_mean_rate ) [inline, static]

static QoS::MeanRate PdpQoSMeanRateTable::GetQoSType ( INT idx ) [inline, static]

static const UINT PdpQoSMeanRateTable::GetSize ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:38:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpQoSPeakRateTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpQoSPeakRateTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for PdpQoSPeakRateTable:

[legend]
Collaboration diagram for PdpQoSPeakRateTable:

[legend]

Static Public Member Functions

static const WCHAR * | GetQoS (PdpContext::QualityOfService::PeakRate qos_peak_rate)
static QoS::PeakRate | GetQoSType (INT idx)
static const UINT | GetSize ()

Member Function Documentation

static const WCHAR* PdpQoSPeakRateTable::GetQoS ( PdpContext::QualityOfService::PeakRate qos_peak_rate ) [inline, static]

static QoS::PeakRate PdpQoSPeakRateTable::GetQoSType ( INT idx ) [inline, static]

static const UINT PdpQoSPeakRateTable::GetSize ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:38:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpQoSPrecedenceTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpQoSPrecedenceTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for PdpQoSPrecedenceTable:

[legend]
Collaboration diagram for PdpQoSPrecedenceTable:

[legend]

Static Public Member Functions

static const WCHAR * | GetQoS (QoS::Precedence qos_precedence)
static QoS::Precedence | GetQoSType (INT idx)
static const UINT | GetSize ()

Member Function Documentation

static const WCHAR* PdpQoSPrecedenceTable::GetQoS ( QoS::Precedence qos_precedence ) [inline, static]

static QoS::Precedence PdpQoSPrecedenceTable::GetQoSType ( INT idx ) [inline, static]

static const UINT PdpQoSPrecedenceTable::GetSize ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:38:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PdpQoSReliabilityTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PdpQoSReliabilityTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for PdpQoSReliabilityTable:

[legend]
Collaboration diagram for PdpQoSReliabilityTable:

[legend]

Static Public Member Functions

static const WCHAR * | GetQoS (QoS::Reliability qos_reliability)
static QoS::Reliability | GetQoSType (INT idx)
static const UINT | GetSize ()

Member Function Documentation

static const WCHAR* PdpQoSReliabilityTable::GetQoS ( QoS::Reliability qos_reliability ) [inline, static]

static QoS::Reliability PdpQoSReliabilityTable::GetQoSType ( INT idx ) [inline, static]

static const UINT PdpQoSReliabilityTable::GetSize ( ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:38:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Pen Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Pen Class Reference
[GUI]

#include <Apoxi/Gui/Pen.hpp>

Collaboration diagram for Pen:

[legend]

Public Types

enum | PenStyle { Solid, Dotted, Dashed, SemiDashed }

Public Member Functions

const Color & | GetColor () const
ColorValue | GetColorValue () const
Returns the color-value of the pen.
PenStyle | GetStyle () const
Returns the style of the pen.
Pen (PenStyle style=Solid, Color color=Color())
Constructor of the pen.
void | SetColor (const Color &color)
void | SetColorHsv (UINT8 hue, UINT8 saturation, UINT8 value, UINT8 alpha=255)
void | SetColorRgb (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha=255)
void | SetColorValue (ColorValue color_value)
Sets the color of the pen to the value represented by color_value.
void | SetStyle (PenStyle style)
Sets the style of the pen to style (not supported yet).

Detailed Description

Is used graphical operations on the Device-Context and defines the color and the style of a pen.

Member Enumeration Documentation

enum Pen::PenStyle

Enumerator:
Solid
Dotted
Dashed
SemiDashed

Constructor & Destructor Documentation

Pen::Pen | ( | PenStyle | style = Solid,
 |  | Color | color = Color()
 | ) |

Constructor of the pen.

Member Function Documentation

const Color& Pen::GetColor ( ) const [inline]

ColorValue Pen::GetColorValue ( ) const [inline]

Returns the color-value of the pen.

PenStyle Pen::GetStyle ( ) const [inline]

Returns the style of the pen.

void Pen::SetColor ( const Color & color ) [inline]

void Pen::SetColorHsv | ( | UINT8 | hue,
 |  | UINT8 | saturation,
 |  | UINT8 | value,
 |  | UINT8 | alpha = 255
 | ) | [inline]

Sets the color of the pen to the value represented by hue, saturation and the value. Optionally an alpha-channel can be specified.

void Pen::SetColorRgb | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha = 255
 | ) | [inline]

Sets the color of the pen to the value represented by red-, green- and blue-portions. Optionally an alpha-channel can be specified.

void Pen::SetColorValue ( ColorValue color_value ) [inline]

Sets the color of the pen to the value represented by color_value.

void Pen::SetStyle ( PenStyle style ) [inline]

Sets the style of the pen to style (not supported yet).

The documentation for this class was generated from the following files:
  • Gui/Pen.hpp
  • Gui/Pen.cpp
Generated on Wed Jan 25 01:38:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PenDownMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PenDownMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for PenDownMsg:

[legend]
Collaboration diagram for PenDownMsg:

[legend]

Public Types

enum | { ID = 240 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
XYDIM | GetPosX () const
XYDIM | GetPosY () const
PenDownMsg (XYDIM pos_x, XYDIM pos_y)
void | SetPosX (XYDIM pos_x)
void | SetPosY (XYDIM pos_y)
virtual | ~PenDownMsg ()

Detailed Description

This message is sent when the pen touches the display. Arguments: Position of the Pen

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PenDownMsg::PenDownMsg | ( | XYDIM | pos_x,
 |  | XYDIM | pos_y
 | ) |

PenDownMsg::~PenDownMsg ( ) [virtual]

Member Function Documentation

Message * PenDownMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PenDownMsg::GetMetaData ( ) const [virtual]

Implements Message.

XYDIM PenDownMsg::GetPosX ( ) const [inline]

XYDIM PenDownMsg::GetPosY ( ) const [inline]

void PenDownMsg::SetPosX ( XYDIM pos_x ) [inline]

void PenDownMsg::SetPosY ( XYDIM pos_y ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:38:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PenUpMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PenUpMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for PenUpMsg:

[legend]
Collaboration diagram for PenUpMsg:

[legend]

Public Types

enum | { ID = 241 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
XYDIM | GetPosX () const
XYDIM | GetPosY () const
PenUpMsg (XYDIM pos_x, XYDIM pos_y)
void | SetPosX (XYDIM pos_x)
void | SetPosY (XYDIM pos_y)
virtual | ~PenUpMsg ()

Detailed Description

This message is sent when the pen leaves the display. Arguments: Position of the Pen

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PenUpMsg::PenUpMsg | ( | XYDIM | pos_x,
 |  | XYDIM | pos_y
 | ) |

PenUpMsg::~PenUpMsg ( ) [virtual]

Member Function Documentation

Message * PenUpMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PenUpMsg::GetMetaData ( ) const [virtual]

Implements Message.

XYDIM PenUpMsg::GetPosX ( ) const [inline]

XYDIM PenUpMsg::GetPosY ( ) const [inline]

void PenUpMsg::SetPosX ( XYDIM pos_x ) [inline]

void PenUpMsg::SetPosY ( XYDIM pos_y ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:38:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PersistDataConnProfile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PersistDataConnProfile Class Reference
[Socket]

#include <Apoxi/Socket/PersistDataConnProfile.hpp>

Collaboration diagram for PersistDataConnProfile:

[legend]

Public Member Functions

DataConnProfilePtr | CreateDataConnProfile () const
PersistDataConnProfile ()

Friends

class | CsdDataConnProfile
class | DataConnProfile
class | DataConnProfileManager
class | PsdDataConnProfile

Detailed Description

Class PersistDataConnProfile is used to save data connection profiles of any type (circuit switched, packet switched, or serial) to persistent memory (e.g. NVRAM or flash file system).

Constructor & Destructor Documentation

PersistDataConnProfile::PersistDataConnProfile ( ) [inline]

Member Function Documentation

DataConnProfilePtr PersistDataConnProfile::CreateDataConnProfile ( ) const

Returns a new data connection profile of appropriate type wrapped into a smart pointer. The returned object is initialized to the settings stored in this persist profile.

Returns:
A DataConnProfilePtr wrapping either a new data connection profile or 0 if there is not enough memory left.

Friends And Related Function Documentation

friend class CsdDataConnProfile [friend]

friend class DataConnProfile [friend]

friend class DataConnProfileManager [friend]

friend class PsdDataConnProfile [friend]

The documentation for this class was generated from the following files:
  • Socket/PersistDataConnProfile.hpp
  • Socket/PersistDataConnProfile.cpp
Generated on Wed Jan 25 01:38:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhonebookApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhonebookApp Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PhonebookApp.hpp>

Inheritance diagram for PhonebookApp:

[legend]
Collaboration diagram for PhonebookApp:

[legend]

Public Types

enum | AffectedProvider { NameProv, NumberProv, Both }
enum | ProviderUpdateState { Started, Finished }

Public Member Functions

BOOLEAN | AddAllToFdn ()
BOOLEAN | AddEntryToFdn ()
BOOLEAN | AddNumber (INT name_row, const PhoneNumber &phoneno, INT no_id)
BOOLEAN | AddNumberToFdn ()
BOOLEAN | AddPbEntry (const WString &name, const PhoneNumber &phoneno, const WString &email)
void | CallSelectedNumber ()
BOOLEAN | CopyToPb ()
BOOLEAN | DeleteAllEntries ()
BOOLEAN | DeleteSelectedNumber (BOOLEAN feedback=TRUE)
BOOLEAN | DeleteSelectedPbEntry (BOOLEAN feedback=TRUE)
virtual void | DisplayMemory ()
void | EnterNewEntry (const WString &default_name, const PhoneNumber &default_phoneno, const WString &default_mail)
PbAbstractWin * GetActiveWin ()
Action * GetAddAction ()
Action * GetCallAction ()
Action * GetDelAllAction ()
Action * GetDeleteAction ()
virtual INT | GetMaxPhonenos ()=0
virtual ServiceResult | GetName (const PhoneNumber &phoneno, WString &name)
Provider * GetPbProvider ()
virtual PhonebookWin * | GetPhonebook ()=0
void | GetSelectedItem (INT colid, DataItem &item)
INT | GetSelectedPbRow ()
INT | GetSelectedRow ()
Provider * GetWindowProvider ()
virtual ServiceResult | InvokePhonebook ()
BOOLEAN | IsEmptyRow (Provider *prov, INT row)
virtual BOOLEAN | IsPbAvailable ()
INT | NumberCount (INT name_row)
PhonebookApp (UINT stacksize=0)
virtual ServiceResult | SaveEntryInPhonebook (const WString &name, const WString &email_address)
virtual ServiceResult | SaveEntryInPhonebook (const WString &name, const PhoneNumber &phoneno)
virtual ServiceResult | SaveNumberInPhonebook (const PhoneNumber &phoneno)
INT | SearchRow (SortProvider *prov, const DataItem &item, INT col_id)
virtual ServiceResult | SelectEmailAddress (WString &email, const WString &title=WString())
virtual ServiceResult | SelectPhoneNumber (PhoneNumber &phoneno, const WString &title=WString())
virtual ServiceResult | SelectSimPos (INT sim_pos)
void | SetActiveWin (PbAbstractWin *win)
void | StartWaitingAnimation ()
void | StopWaitingAnimation ()
void | SwitchDisplaySimPos ()
BOOLEAN | Synchronize ()
virtual void | UpdateEnabledActions ()
BOOLEAN | UpdatePbEntry (INT colid, const DataItem &item)
virtual | ~PhonebookApp ()

Protected Member Functions

void | EnablePhonebook (BOOLEAN flag)
virtual void | EnableSimActions (BOOLEAN flag)
OpenWindowAction * GetOpenPbWinAction ()
virtual PbDataHandler * | GetPbDataControl ()=0
MmiProviderProgressBox * | GetProgressBox ()
virtual PbSynchronizer * | GetSynchronizer ()=0
BOOLEAN | NewSim ()
BOOLEAN | NoEntrySelected ()
virtual void | OnClose ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnPbWindowClosed (const PbAbstractWin *win)
virtual void | OnSimChanged (SimChangeType chg_type)
virtual void | OnSimNotPresent ()
virtual void | OnSimPresent ()
virtual void | OnSimReady ()
virtual void | OnSimStateChanged (SimIndicator sim_ind)
virtual void | OnStartup ()
virtual void | OnTriggerNotification (INT16 type)
void | OpenPhonebook ()
BOOLEAN | ProvShowsEmptyRows (Provider *prov)
virtual BOOLEAN | ServiceReady ()
virtual void | UpdatePbs (DataControlType data_type)

Static Protected Attributes

static UpdatePbThreadlet | m_update_threadlet

Friends

class | PbAbstractWin

Member Enumeration Documentation

enum PhonebookApp::AffectedProvider

Enumerator:
NameProv
NumberProv
Both

enum PhonebookApp::ProviderUpdateState

Enumerator:
Started
Finished

Constructor & Destructor Documentation

PhonebookApp::PhonebookApp ( UINT stacksize = 0 )

PhonebookApp::~PhonebookApp ( ) [virtual]

Member Function Documentation

BOOLEAN PhonebookApp::AddAllToFdn ( )

BOOLEAN PhonebookApp::AddEntryToFdn ( )

BOOLEAN PhonebookApp::AddNumber | ( | INT | name_row,
 |  | const PhoneNumber & | phoneno,
 |  | INT | no_id
 | ) |

BOOLEAN PhonebookApp::AddNumberToFdn ( )

BOOLEAN PhonebookApp::AddPbEntry | ( | const WString & | name,
 |  | const PhoneNumber & | phoneno,
 |  | const WString & | email
 | ) |

void PhonebookApp::CallSelectedNumber ( )

BOOLEAN PhonebookApp::CopyToPb ( )

BOOLEAN PhonebookApp::DeleteAllEntries ( )

BOOLEAN PhonebookApp::DeleteSelectedNumber ( BOOLEAN feedback = TRUE )

BOOLEAN PhonebookApp::DeleteSelectedPbEntry ( BOOLEAN feedback = TRUE )

void PhonebookApp::DisplayMemory ( ) [virtual]

Reimplemented in AdvPbApp.

void PhonebookApp::EnablePhonebook ( BOOLEAN flag ) [inline, protected]

void PhonebookApp::EnableSimActions ( BOOLEAN flag ) [protected, virtual]

void PhonebookApp::EnterNewEntry | ( | const WString & | default_name,
 |  | const PhoneNumber & | default_phoneno,
 |  | const WString & | default_mail
 | ) |

PbAbstractWin* PhonebookApp::GetActiveWin ( ) [inline]

Action* PhonebookApp::GetAddAction ( ) [inline]

Action* PhonebookApp::GetCallAction ( ) [inline]

Action* PhonebookApp::GetDelAllAction ( ) [inline]

Action* PhonebookApp::GetDeleteAction ( ) [inline]

virtual INT PhonebookApp::GetMaxPhonenos ( ) [pure virtual]

Implemented in AdvPbApp.

ServiceResult PhonebookApp::GetName | ( | const PhoneNumber & | phoneno,
 |  | WString & | name
 | ) | [virtual]

OpenWindowAction* PhonebookApp::GetOpenPbWinAction ( ) [inline, protected]

virtual PbDataHandler* PhonebookApp::GetPbDataControl ( ) [protected, pure virtual]

Implemented in AdvPbApp.

Provider* PhonebookApp::GetPbProvider ( ) [inline]

virtual PhonebookWin* PhonebookApp::GetPhonebook ( ) [pure virtual]

Implemented in AdvPbApp.

MmiProviderProgressBox* PhonebookApp::GetProgressBox ( ) [inline, protected]

void PhonebookApp::GetSelectedItem | ( | INT | colid,
 |  | DataItem & | item
 | ) | [inline]

INT PhonebookApp::GetSelectedPbRow ( ) [inline]

INT PhonebookApp::GetSelectedRow ( ) [inline]

virtual PbSynchronizer* PhonebookApp::GetSynchronizer ( ) [protected, pure virtual]

Implemented in AdvPbApp.

Provider * PhonebookApp::GetWindowProvider ( )

ServiceResult PhonebookApp::InvokePhonebook ( ) [virtual]

BOOLEAN PhonebookApp::IsEmptyRow | ( | Provider * | prov,
 |  | INT | row
 | ) |

virtual BOOLEAN PhonebookApp::IsPbAvailable ( ) [inline, virtual]

Reimplemented in AdvPbApp.

BOOLEAN PhonebookApp::NewSim ( ) [inline, protected]

BOOLEAN PhonebookApp::NoEntrySelected ( ) [protected]

INT PhonebookApp::NumberCount ( INT name_row )

void PhonebookApp::OnClose ( ) [protected, virtual]

BOOLEAN PhonebookApp::OnMessage ( const Message & msg ) [protected, virtual]

Reimplemented in AdvPbApp.

void PhonebookApp::OnOpen ( ) [protected, virtual]

void PhonebookApp::OnPbWindowClosed ( const PbAbstractWin * win ) [protected, virtual]

Reimplemented in AdvPbApp.

void PhonebookApp::OnSimChanged ( SimChangeType chg_type ) [protected, virtual]

virtual void PhonebookApp::OnSimNotPresent ( ) [inline, protected, virtual]

Reimplemented in AdvPbApp.

virtual void PhonebookApp::OnSimPresent ( ) [inline, protected, virtual]

Reimplemented in AdvPbApp.

void PhonebookApp::OnSimReady ( ) [protected, virtual]

Reimplemented in AdvPbApp.

void PhonebookApp::OnSimStateChanged ( SimIndicator sim_ind ) [protected, virtual]

void PhonebookApp::OnStartup ( ) [protected, virtual]

void PhonebookApp::OnTriggerNotification ( INT16 type ) [protected, virtual]

void PhonebookApp::OpenPhonebook ( ) [protected]

BOOLEAN PhonebookApp::ProvShowsEmptyRows ( Provider * prov ) [protected]

ServiceResult PhonebookApp::SaveEntryInPhonebook | ( | const WString & | name,
 |  | const WString & | email_address
 | ) | [virtual]

ServiceResult PhonebookApp::SaveEntryInPhonebook | ( | const WString & | name,
 |  | const PhoneNumber & | phoneno
 | ) | [virtual]

ServiceResult PhonebookApp::SaveNumberInPhonebook ( const PhoneNumber & phoneno ) [virtual]

INT PhonebookApp::SearchRow | ( | SortProvider * | prov,
 |  | const DataItem & | item,
 |  | INT | col_id
 | ) |

ServiceResult PhonebookApp::SelectEmailAddress | ( | WString & | email,
 |  | const WString & | title = WString()
 | ) | [virtual]

Reimplemented in AdvPbApp.

ServiceResult PhonebookApp::SelectPhoneNumber | ( | PhoneNumber & | phoneno,
 |  | const WString & | title = WString()
 | ) | [virtual]

ServiceResult PhonebookApp::SelectSimPos ( INT sim_pos ) [virtual]

BOOLEAN PhonebookApp::ServiceReady ( ) [protected, virtual]

Reimplemented in AdvPbApp.

void PhonebookApp::SetActiveWin ( PbAbstractWin * win ) [inline]

void PhonebookApp::StartWaitingAnimation ( )

void PhonebookApp::StopWaitingAnimation ( )

void PhonebookApp::SwitchDisplaySimPos ( )

BOOLEAN PhonebookApp::Synchronize ( )

void PhonebookApp::UpdateEnabledActions ( ) [virtual]

Reimplemented in AdvPbApp.

BOOLEAN PhonebookApp::UpdatePbEntry | ( | INT | colid,
 |  | const DataItem & | item
 | ) |

void PhonebookApp::UpdatePbs ( DataControlType data_type ) [protected, virtual]

Friends And Related Function Documentation

friend class PbAbstractWin [friend]

Field Documentation

UpdatePbThreadlet PhonebookApp::m_update_threadlet [static, protected]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PhonebookApp.hpp
  • Applications/AdvPhonebook/PhonebookApp.cpp
Generated on Wed Jan 25 01:39:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhoneBookInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhoneBookInfo Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

INT | adn_size
INT | adn_tagsize
INT | bdn_size
INT | bdn_tagsize
INT | cphs_infono_size
INT | cphs_infono_tagsize
INT | cphs_mbox_size
INT | cphs_mbox_tagsize
INT | fdn_size
INT | fdn_tagsize
INT | lnd_size
INT | lnd_tagsize
INT | mbdn_size
INT | mbdn_tagsize
INT | msisdn_size
INT | msisdn_tagsize
INT | sdn_size
INT | sdn_tagsize

Field Documentation

INT PhoneBookInfo::adn_size

INT PhoneBookInfo::adn_tagsize

INT PhoneBookInfo::bdn_size

INT PhoneBookInfo::bdn_tagsize

INT PhoneBookInfo::cphs_infono_size

INT PhoneBookInfo::cphs_infono_tagsize

INT PhoneBookInfo::cphs_mbox_size

INT PhoneBookInfo::cphs_mbox_tagsize

INT PhoneBookInfo::fdn_size

INT PhoneBookInfo::fdn_tagsize

INT PhoneBookInfo::lnd_size

INT PhoneBookInfo::lnd_tagsize

INT PhoneBookInfo::mbdn_size

INT PhoneBookInfo::mbdn_tagsize

INT PhoneBookInfo::msisdn_size

INT PhoneBookInfo::msisdn_tagsize

INT PhoneBookInfo::sdn_size

INT PhoneBookInfo::sdn_tagsize

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:39:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhonebookRenumberedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhonebookRenumberedMsg Class Reference

#include <Applications/AdvPhonebook/AdvPbMsgTypes.hpp>

Inheritance diagram for PhonebookRenumberedMsg:

[legend]
Collaboration diagram for PhonebookRenumberedMsg:

[legend]

Public Types

enum | { ID = 30008 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
PhonebookRenumberedMsg ()
virtual | ~PhonebookRenumberedMsg ()

Detailed Description

Phonebook

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PhonebookRenumberedMsg::PhonebookRenumberedMsg ( )

PhonebookRenumberedMsg::~PhonebookRenumberedMsg ( ) [virtual]

Member Function Documentation

Message * PhonebookRenumberedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PhonebookRenumberedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbMsgTypes.hpp
  • Applications/AdvPhonebook/AdvPbMsgTypes.cpp
Generated on Wed Jan 25 01:39:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhonebookWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhonebookWin Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PhonebookWin.hpp>

Inheritance diagram for PhonebookWin:

[legend]
Collaboration diagram for PhonebookWin:

[legend]

Public Types

typedef PbBaseWin | Base

Public Member Functions

void | AddDetailMenuAction (Action *action, BOOLEAN separate=FALSE)
virtual PbDetails * | GetDetailWin ()=0
void | Init (Provider *pb_provider=0, INT sort_colid=c_name_id, BOOLEAN read_only=FALSE)
virtual BOOLEAN | IsReadOnly ()
PhonebookWin ()
virtual void | SetDisplaySimPos (BOOLEAN display_simpos)
void | Update ()
virtual | ~PhonebookWin ()

Protected Member Functions

virtual void | UpdateEnabledActions ()

Member Typedef Documentation

typedef PbBaseWin PhonebookWin::Base

Reimplemented from PbBaseWin.

Reimplemented in BasicPbWin.

Constructor & Destructor Documentation

PhonebookWin::PhonebookWin ( )

PhonebookWin::~PhonebookWin ( ) [virtual]

Member Function Documentation

void PhonebookWin::AddDetailMenuAction | ( | Action * | action,
 |  | BOOLEAN | separate = FALSE
 | ) |

virtual PbDetails* PhonebookWin::GetDetailWin ( ) [pure virtual]

Implemented in AdvPbWin, and BasicPbWin.

void PhonebookWin::Init | ( | Provider * | pb_provider = 0,
 |  | INT | sort_colid = c_name_id,
 |  | BOOLEAN | read_only = FALSE
 | ) |

Reimplemented in BasicPbWin.

BOOLEAN PhonebookWin::IsReadOnly ( ) [virtual]

Reimplemented from PbAbstractWin.

void PhonebookWin::SetDisplaySimPos ( BOOLEAN display_simpos ) [virtual]

Reimplemented from PbAbstractWin.

void PhonebookWin::Update ( )

void PhonebookWin::UpdateEnabledActions ( ) [protected, virtual]

Reimplemented from PbAbstractWin.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PhonebookWin.hpp
  • Applications/AdvPhonebook/PhonebookWin.cpp
Generated on Wed Jan 25 01:39:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhoneNumber Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhoneNumber Class Reference
[Auxiliary]

PhoneNumber implements bcd coded phone numbers regarding to GSM 04.08. More...

#include <Apoxi/Auxiliary/PhoneNumber.hpp>

Public Types

typedef UINT16 | Key
enum PresentationIndicator {
PresentationAllowed = 0, PresentationRestricted = 1, NumberNotAllowed = 2, PresentationReserved = 3,
PresentationUndefined = 0xff
}
Defines the presentation indication of an incoming phonenumber. More...
enum ScreeningIndicator {
NotScreened = 0, VerifiedAndPassed = 1, VerifiedAndFailed = 2, NetworkProvided = 3,
ScreeningUndefined = 0xff
}
Defines the screening indication of an incoming phonenumber. More...
enum | Type { In, Out, Tpdu, Invalid }
Defines if the phonenumber is an in or outgoing phonennumber. More...

Public Member Functions

BOOLEAN | ChangeType (Type type)
Changes the type of the phonenumber object. (possible from In, Out, Tpdu to Out or Tpdu).
void | Clear ()
Clear the phone number object and make it invalid.
INT | Compare (const PhoneNumber &right) const
UINT8 * | GetBCD () const
Returns the buffer containing the bcd coded phonenumber.
INT | GetBCDLength () const
Returns the number of bytes which contains bcd coded digits.
UINT16 | GetHashValue () const
compute a hashvalue
Key | GetKey () const
PhoneNumber | GetNonDtmfPhoneNumber () const
Returns a phonenumber object without a DTMF seperator based on the the phonenumber object.
TypeOfAddress::NumberingPlanIdentification | GetNPI () const
Returns the NPI id of the phonenumber object.
INT | GetNumOfValidDigits () const
Returns the number of valid digits before the DTMF seperator.
PresentationIndicator | GetPresentationInd () const
Returns the presentation ind of the incoming phonenumber object.
UINT8 * | GetRawBCDBuffer () const
Returns the buffer containing the phonenumber coded in GSM 04.08.
INT | GetRawBCDLength () const
Returns the number of bytes used for the phonenumber coded in GSM 04.08.
ScreeningIndicator | GetScreeningInd () const
Returns the screening ind of the incoming phonenumber object.
String | GetString () const
Returns the string presentation of the phonenumber object.
TypeOfAddress::TypeOfNumber | GetTON () const
Returns the TON id of the phonenumber object.
UINT8 | GetTONNPI () const
Returns the raw TON and NPI byte of the phonenumber object.
Type | GetType () const
Returns the type of the phonenumber object.
WString | GetWString () const
Returns the wstring presentation of the phonenumber object.
BOOLEAN | HasClirOverrideCategory () const
Returns true, if this number has CLIR override category (presentation restricted, but number available).
BOOLEAN | HasDtmf () const
Determines of the phonenumber contains a DTMF seperator.
BOOLEAN | IsEmpty () const
Returns TRUE if phone number is empty, FALSE otherwise.
BOOLEAN | IsInvalid () const
Returns true, if the phonenumber is invalid (uninitialized).
BOOLEAN | IsMatching (const PhoneNumber &right, INT depth) const
Checks whether the phonenumber object is matching the same digits as the right object.
BOOLEAN | IsMatching (const PhoneNumber &right) const
Checks whether the phonenumber object is matching the same digits as the right object.
BOOLEAN | IsPresentationAllowed () const
Returns if the presentation of the phonenumber string is allowed.
BOOLEAN | operator< (const PhoneNumber &right) const
Checks whether the phonenumber object is less (string based) to the right object.
void | operator<< (const PhoneNumber::Persist &phonenumber)
PhoneNumber & | operator= (const PhoneNumber &value)
Assigns a phonenumber object.
PhoneNumber & | operator= (const PhoneNumber *value)
Assigns a phonenumber object.
BOOLEAN | operator== (const PhoneNumber &right) const
Checks whether the phonenumber object is identical to the right object.
BOOLEAN | operator> (const PhoneNumber &right) const
Checks whether the phonenumber object is greater (string based) to the right object.
void | operator>> (PhoneNumber::Persist &phonenumber) const
PhoneNumber (Type type, const WCHAR *telnr)
PhoneNumber (Type type, const WString &telnr)
PhoneNumber (UINT8 tonnpi, UINT8 datalen, UINT8 *data)
Creates an Out phonenumber based on the tonnpi and a byte buffer.
PhoneNumber (Type type, const UINT8 *rawbcd)
Creates a phonenumber object based on the raw byte buffer .
PhoneNumber (const PhoneNumber *number)
Creates a phonenumber object identical to the number object.
PhoneNumber (const PhoneNumber &number)
Creates a phonenumber object identical to the number object.
PhoneNumber ()
Creates an empty phonenumber object.
INT | TransformToReversedByteBuffer (UINT8 *buffer, INT len) const
INT | TransformToWCharBuffer (WCHAR *buffer, INT len) const
~PhoneNumber ()

Static Public Member Functions

static WCHAR | BcdNibbleToWChar (UINT8 value)
Returns an ASCII/Unicode coded digit based on a 4-bit bcd coded nibble.
static INT | Compare (const PhoneNumber &ph1, const PhoneNumber &ph2)
static INT | GetRawBCDLength (Type type, const UINT8 *buffer)
Computes the number of bytes used for a phonenumber buffer coded in GSM 04.08.
static WCHAR | GetWCharForBcdCode (UINT8 nibble)
static BOOLEAN | IsStorable (const WCHAR *phnostring)
Checks if the phonenumber is storable in phonebooks.
static void | SetEmptyNumberText (const WCHAR *text)
Specifies the text returned in GetWString for empty phone numbers.
static void | SetInvalidNumberText (const WCHAR *text)
Specifies the text returned in GetWString for invalid phone numbers.
static void | SetNumberNotAvailableText (const WCHAR *text)
Specifies the text returned in GetWString if phone number is not available.
static void | SetRestrictedNumberText (const WCHAR *text)
Specifies the text returned in GetWString for resricted phone numbers.
static void | SetWCharForBcdCode (BCDConversionNibble nibble, WCHAR character)
static UINT8 | WCharToBcdNibble (WCHAR value)
Returns a 4-bit coded nibble based on a ASCII/Unicode coded digit.

Protected Attributes

UINT8 | m_bcd_number [c_max_bcd_number_size]
Type m_type

Data Structures

struct | Persist

Detailed Description

PhoneNumber implements bcd coded phone numbers regarding to GSM 04.08.

Member Typedef Documentation

typedef UINT16 PhoneNumber::Key

Member Enumeration Documentation

enum PhoneNumber::PresentationIndicator

Defines the presentation indication of an incoming phonenumber.

Enumerator:
PresentationAllowed
PresentationRestricted
NumberNotAllowed
PresentationReserved
PresentationUndefined

enum PhoneNumber::ScreeningIndicator

Defines the screening indication of an incoming phonenumber.

Enumerator:
NotScreened
VerifiedAndPassed
VerifiedAndFailed
NetworkProvided
ScreeningUndefined

enum PhoneNumber::Type

Defines if the phonenumber is an in or outgoing phonennumber.

Enumerator:
In | Mobile terminated phonenumbers.
Out | Mobile originated phonenumbers.
Tpdu | Phonenumbers used inside Tpdus.
Invalid | Invalid phonenumber (empty phonenumber).

Constructor & Destructor Documentation

PhoneNumber::PhoneNumber ( )

Creates an empty phonenumber object.

PhoneNumber::PhoneNumber ( const PhoneNumber & number )

Creates a phonenumber object identical to the number object.

PhoneNumber::PhoneNumber ( const PhoneNumber * number )

Creates a phonenumber object identical to the number object.

PhoneNumber::PhoneNumber | ( | Type | type,
 |  | const UINT8 * | rawbcd
 | ) |

Creates a phonenumber object based on the raw byte buffer .

PhoneNumber::PhoneNumber | ( | UINT8 | tonnpi,
 |  | UINT8 | datalen,
 |  | UINT8 * | data
 | ) |

Creates an Out phonenumber based on the tonnpi and a byte buffer.

PhoneNumber::PhoneNumber | ( | Type | type,
 |  | const WString & | telnr
 | ) |

Creates a phonenumber object based on a wstring object containing digits and TON and NPI parameters.

PhoneNumber::PhoneNumber | ( | Type | type,
 |  | const WCHAR * | telnr
 | ) |

Creates a phonenumber object based on a wchar string containing digits and TON and NPI parameters.

PhoneNumber::~PhoneNumber ( )

Member Function Documentation

static WCHAR PhoneNumber::BcdNibbleToWChar ( UINT8 value ) [inline, static]

Returns an ASCII/Unicode coded digit based on a 4-bit bcd coded nibble.

BOOLEAN PhoneNumber::ChangeType ( Type type )

Changes the type of the phonenumber object. (possible from In, Out, Tpdu to Out or Tpdu).

void PhoneNumber::Clear ( ) [inline]

Clear the phone number object and make it invalid.

static INT PhoneNumber::Compare | ( | const PhoneNumber & | ph1,
 |  | const PhoneNumber & | ph2
 | ) | [inline, static]

INT PhoneNumber::Compare ( const PhoneNumber & right ) const

UINT8* PhoneNumber::GetBCD ( ) const [inline]

Returns the buffer containing the bcd coded phonenumber.

INT PhoneNumber::GetBCDLength ( ) const

Returns the number of bytes which contains bcd coded digits.

UINT16 PhoneNumber::GetHashValue ( ) const

compute a hashvalue

Key PhoneNumber::GetKey ( ) const [inline]

PhoneNumber PhoneNumber::GetNonDtmfPhoneNumber ( ) const

Returns a phonenumber object without a DTMF seperator based on the the phonenumber object.

TypeOfAddress::NumberingPlanIdentification PhoneNumber::GetNPI ( ) const

Returns the NPI id of the phonenumber object.

INT PhoneNumber::GetNumOfValidDigits ( ) const

Returns the number of valid digits before the DTMF seperator.

PhoneNumber::PresentationIndicator PhoneNumber::GetPresentationInd ( ) const

Returns the presentation ind of the incoming phonenumber object.

UINT8* PhoneNumber::GetRawBCDBuffer ( ) const [inline]

Returns the buffer containing the phonenumber coded in GSM 04.08.

INT PhoneNumber::GetRawBCDLength | ( | Type | type,
 |  | const UINT8 * | buffer
 | ) | [static]

Computes the number of bytes used for a phonenumber buffer coded in GSM 04.08.

INT PhoneNumber::GetRawBCDLength ( ) const [inline]

Returns the number of bytes used for the phonenumber coded in GSM 04.08.

PhoneNumber::ScreeningIndicator PhoneNumber::GetScreeningInd ( ) const

Returns the screening ind of the incoming phonenumber object.

String PhoneNumber::GetString ( ) const

Returns the string presentation of the phonenumber object.

TypeOfAddress::TypeOfNumber PhoneNumber::GetTON ( ) const

Returns the TON id of the phonenumber object.

UINT8 PhoneNumber::GetTONNPI ( ) const [inline]

Returns the raw TON and NPI byte of the phonenumber object.

Type PhoneNumber::GetType ( ) const [inline]

Returns the type of the phonenumber object.

WCHAR PhoneNumber::GetWCharForBcdCode ( UINT8 nibble ) [static]

Returns the ASCII/Unicode representation of the DtmfValue, WildcardValue and ExpansionValue.

WString PhoneNumber::GetWString ( ) const

Returns the wstring presentation of the phonenumber object.

BOOLEAN PhoneNumber::HasClirOverrideCategory ( ) const

Returns true, if this number has CLIR override category (presentation restricted, but number available).

BOOLEAN PhoneNumber::HasDtmf ( ) const

Determines of the phonenumber contains a DTMF seperator.

BOOLEAN PhoneNumber::IsEmpty ( ) const [inline]

Returns TRUE if phone number is empty, FALSE otherwise.

BOOLEAN PhoneNumber::IsInvalid ( ) const [inline]

Returns true, if the phonenumber is invalid (uninitialized).

BOOLEAN PhoneNumber::IsMatching | ( | const PhoneNumber & | right,
 |  | INT | depth
 | ) | const

Checks whether the phonenumber object is matching the same digits as the right object.

BOOLEAN PhoneNumber::IsMatching ( const PhoneNumber & right ) const

Checks whether the phonenumber object is matching the same digits as the right object.

BOOLEAN PhoneNumber::IsPresentationAllowed ( ) const

Returns if the presentation of the phonenumber string is allowed.

BOOLEAN PhoneNumber::IsStorable ( const WCHAR * phnostring ) [static]

Checks if the phonenumber is storable in phonebooks.

BOOLEAN PhoneNumber::operator< ( const PhoneNumber & right ) const

Checks whether the phonenumber object is less (string based) to the right object.

void PhoneNumber::operator<< ( const PhoneNumber::Persist & phonenumber )

PhoneNumber & PhoneNumber::operator= ( const PhoneNumber & value )

Assigns a phonenumber object.

PhoneNumber & PhoneNumber::operator= ( const PhoneNumber * value )

Assigns a phonenumber object.

BOOLEAN PhoneNumber::operator== ( const PhoneNumber & right ) const

Checks whether the phonenumber object is identical to the right object.

BOOLEAN PhoneNumber::operator> ( const PhoneNumber & right ) const

Checks whether the phonenumber object is greater (string based) to the right object.

void PhoneNumber::operator>> ( PhoneNumber::Persist & phonenumber ) const

static void PhoneNumber::SetEmptyNumberText ( const WCHAR * text ) [inline, static]

Specifies the text returned in GetWString for empty phone numbers.

static void PhoneNumber::SetInvalidNumberText ( const WCHAR * text ) [inline, static]

Specifies the text returned in GetWString for invalid phone numbers.

static void PhoneNumber::SetNumberNotAvailableText ( const WCHAR * text ) [inline, static]

Specifies the text returned in GetWString if phone number is not available.

static void PhoneNumber::SetRestrictedNumberText ( const WCHAR * text ) [inline, static]

Specifies the text returned in GetWString for resricted phone numbers.

void PhoneNumber::SetWCharForBcdCode | ( | BCDConversionNibble | nibble,
 |  | WCHAR | character
 | ) | [static]

Allows changing the ASCII/Unicode representation of the DtmfValue, WildcardValue and ExpansionValue. Should only changed once during runtime of the ME.

INT PhoneNumber::TransformToReversedByteBuffer | ( | UINT8 * | buffer,
 |  | INT | len
 | ) | const

INT PhoneNumber::TransformToWCharBuffer | ( | WCHAR * | buffer,
 |  | INT | len
 | ) | const

UINT8 PhoneNumber::WCharToBcdNibble ( WCHAR value ) [static]

Returns a 4-bit coded nibble based on a ASCII/Unicode coded digit.

Field Documentation

UINT8 PhoneNumber::m_bcd_number[c_max_bcd_number_size] [protected]

Type PhoneNumber::m_type [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/PhoneNumber.hpp
  • Auxiliary/PhoneNumber.cpp
Generated on Wed Jan 25 01:39:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhoneNumber::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PhoneNumber::Persist

PhoneNumber::Persist Struct Reference

#include <Apoxi/Auxiliary/PhoneNumber.hpp>

Data Fields

UINT8 m_persist [c_max_bcd_number_size+1]

Field Documentation

UINT8 PhoneNumber::Persist::m_persist[c_max_bcd_number_size+1]

The documentation for this struct was generated from the following file:
  • Auxiliary/PhoneNumber.hpp
Generated on Wed Jan 25 01:39:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhoneNumberInputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhoneNumberInputMapper Class Reference
[Editors]

#include <Apoxi/Gui/PhoneNumberInputMapper.hpp>

Inheritance diagram for PhoneNumberInputMapper:

[legend]
Collaboration diagram for PhoneNumberInputMapper:

[legend]

Public Member Functions

virtual Alphabet | GetAlphabet () const
virtual INT | GetId () const
PhoneNumberInputMapper ()
virtual | ~PhoneNumberInputMapper ()

Protected Member Functions

virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual BOOLEAN | OnLongKeyPress (KeyCode key_code)

Detailed Description

Allows to input a phone number including the numbers 0 to 9 and the characters *, + and #.

Constructor & Destructor Documentation

PhoneNumberInputMapper::PhoneNumberInputMapper ( ) [explicit]

PhoneNumberInputMapper::~PhoneNumberInputMapper ( ) [virtual]

Member Function Documentation

InputMapper::Alphabet PhoneNumberInputMapper::GetAlphabet ( ) const [virtual]

Returns SevenBitAlphabet.

See also:
InputMapper::GetAlphabet.

Reimplemented from NumericInputMapper.

INT PhoneNumberInputMapper::GetId ( ) const [virtual]

See also:
InputMapper::GetId()

Reimplemented from NumericInputMapper.

BOOLEAN PhoneNumberInputMapper::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
InputMapper::OnKeyDown()

Reimplemented from NumericInputMapper.

BOOLEAN PhoneNumberInputMapper::OnLongKeyPress ( KeyCode key_code ) [protected, virtual]

See also:
InputMapper::OnLongKeyPress()

Reimplemented from InputMapper.

The documentation for this class was generated from the following files:
  • Gui/PhoneNumberInputMapper.hpp
  • Gui/PhoneNumberInputMapper.cpp
Generated on Wed Jan 25 01:39:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhoneNumberJoinRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhoneNumberJoinRule Class Reference
[AuxExtensions]

#include <Apoxi/AddOns/AuxExtensions/JoinRule.hpp>

Inheritance diagram for PhoneNumberJoinRule:

[legend]
Collaboration diagram for PhoneNumberJoinRule:

[legend]

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &fst_item, const DataItem &snd_item)
virtual JoinRule::RelationType | GetType ()
virtual BOOLEAN | MatchPhoneNumbers (const PhoneNumber &number1, const PhoneNumber &number2)
PhoneNumberJoinRule ()
virtual | ~PhoneNumberJoinRule ()

Constructor & Destructor Documentation

PhoneNumberJoinRule::PhoneNumberJoinRule ( )

PhoneNumberJoinRule::~PhoneNumberJoinRule ( ) [virtual]

Member Function Documentation

BOOLEAN PhoneNumberJoinRule::ExecuteRule | ( | const DataItem & | fst_item,
 |  | const DataItem & | snd_item
 | ) | [virtual]

ExecuteRule does the actual comparision between the data items given in the arguments.

Implements JoinRule.

JoinRule::RelationType PhoneNumberJoinRule::GetType ( ) [virtual]

Returns:
Bijective.

Implements JoinRule.

BOOLEAN PhoneNumberJoinRule::MatchPhoneNumbers | ( | const PhoneNumber & | number1,
 |  | const PhoneNumber & | number2
 | ) | [virtual]

Called by ExecuteRule to test, if the phone numbers are matching. Returns number1.IsMatching(number2).

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/JoinRule.hpp
  • AddOns/AuxExtensions/JoinRule.cpp
Generated on Wed Jan 25 01:39:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhoneNumberMatchRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhoneNumberMatchRule Class Reference
[APOXI Template Layer]

PhoneNumberMatchRule: Compares two PhoneNumbers by using the PhoneNumber::IsMatching method. More...

#include <Apoxi/Atl/PhoneNumberMatchRule.hpp>

Inheritance diagram for PhoneNumberMatchRule:

[legend]
Collaboration diagram for PhoneNumberMatchRule:

[legend]

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)
void | Init (const DataItem &ruleitem)
PhoneNumberMatchRule (const DataItem &ruleitem)
PhoneNumberMatchRule ()
virtual | ~PhoneNumberMatchRule ()
Destructor.

Detailed Description

PhoneNumberMatchRule: Compares two PhoneNumbers by using the PhoneNumber::IsMatching method.

Constructor & Destructor Documentation

PhoneNumberMatchRule::PhoneNumberMatchRule ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

PhoneNumberMatchRule::PhoneNumberMatchRule ( const DataItem & ruleitem )

Parameters:
ruleitem DataItem holding the PhoneNumber to compare

PhoneNumberMatchRule::~PhoneNumberMatchRule ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN PhoneNumberMatchRule::ExecuteRule ( const DataItem & dataitem ) [virtual]

ExecuteRule Expects a DataItem of PhoneNumberType does the actual comparision between the PhoneNumber given in the argument and the PhoneNumber stored when the PhoneNumberMatchRule was constructed. Comparison is done by calling PhoneNumber::IsMatching

Implements FilterRule.

void PhoneNumberMatchRule::Init ( const DataItem & ruleitem )

Parameters:
ruleitem DataItem holding the PhoneNumber to compare

Reimplemented from FilterRule.

The documentation for this class was generated from the following files:
  • Atl/PhoneNumberMatchRule.hpp
  • Atl/PhoneNumberMatchRule.cpp
Generated on Wed Jan 25 01:39:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PhoneNumberMergeProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PhoneNumberMergeProvider Class Reference
[AuxExtensions]

#include <Apoxi/AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp>

Inheritance diagram for PhoneNumberMergeProvider:

[legend]
Collaboration diagram for PhoneNumberMergeProvider:

[legend]

Public Member Functions

virtual BOOLEAN | GetDefaultDataItem (INT columnid, INT row, DataItem &item)
Returns the textual representation of the phone number, if the column has type WStringType.
void | Init (INT provider_id, Provider *child_provider, Provider *merge_provider, INT child_key_colid, INT merge_key_colid, PhoneNumberJoinRule *merge_rule)
The same interface as the constructor.
PhoneNumberMergeProvider (INT provider_id, Provider *child_provider, Provider *merged_provider, INT child_key_colid, INT merge_key_colid, PhoneNumberJoinRule *merge_rule)
PhoneNumberMergeProvider ()
virtual | ~PhoneNumberMergeProvider ()

Protected Member Functions

virtual BOOLEAN | IsLess (const DataItem &item1, const DataItem &item2)
virtual BOOLEAN | IsPhoneNumberTextDefaultData (INT columnid, INT row)

Constructor & Destructor Documentation

PhoneNumberMergeProvider::PhoneNumberMergeProvider ( )

PhoneNumberMergeProvider::PhoneNumberMergeProvider | ( | INT | provider_id,
 |  | Provider * | child_provider,
 |  | Provider * | merged_provider,
 |  | INT | child_key_colid,
 |  | INT | merge_key_colid,
 |  | PhoneNumberJoinRule * | merge_rule
 | ) |

On construction the following parameters have to be specified:

  • provider_id: The provider id for this PhoneNumberMergeProvider.
  • child_provider: The provider which should be appended.
  • merge_provider: The provider which is merged into src_provider.
  • child_colid: The column id of the source provider which should be used as join key.
  • merge_colid: The column id of the merge provider which should be used as join key.
  • merge_rule: The first child provider which should be joined.

PhoneNumberMergeProvider::~PhoneNumberMergeProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PhoneNumberMergeProvider::GetDefaultDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

Returns the textual representation of the phone number, if the column has type WStringType.

Reimplemented from MergeProvider.

void PhoneNumberMergeProvider::Init | ( | INT | provider_id,
 |  | Provider * | child_provider,
 |  | Provider * | merge_provider,
 |  | INT | child_key_colid,
 |  | INT | merge_key_colid,
 |  | PhoneNumberJoinRule * | merge_rule
 | ) |

The same interface as the constructor.

BOOLEAN PhoneNumberMergeProvider::IsLess | ( | const DataItem & | item1,
 |  | const DataItem & | item2
 | ) | [protected, virtual]

Reimplemented from MergeProvider.

BOOLEAN PhoneNumberMergeProvider::IsPhoneNumberTextDefaultData | ( | INT | columnid,
 |  | INT | row
 | ) | [protected, virtual]

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/PhoneNumberMergeProvider.hpp
  • AddOns/AuxExtensions/PhoneNumberMergeProvider.cpp
Generated on Wed Jan 25 01:39:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PinAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PinAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for PinAction:

[legend]
Collaboration diagram for PinAction:

[legend]

Public Types

enum | Type { ChangePin, UnblockPin, Invalid }
Defines the kind of action which should be taken. More...

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
ChvNo | GetChvNo () const
Returns if Pin1 or Pin2 shall be changed or unblocked.
const WString & | GetNewPin () const
Returns the new pin .
const WString & | GetNewPin2 () const
Returns the copy of the new pin.
const WString & | GetOldPin () const
Returns the old pin which shall be changed.
PinAction::Type | GetType () const
Returns the type of action, changing or unblocking.
const WString & | GetUnblockPin () const
Returns the unblock pin which shall be used for unblocking.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
PinAction ()
virtual BOOLEAN | ShallExecuteImmediatly ()
Will always deliver TRUE because input of # shall start execution immediatly.
virtual | ~PinAction ()

Detailed Description

PinAction analyzes if the input string has the meaning of changing and unblocking pin1 or pin2. Execute has to be overwritten to implement the changing and unblocking of the pins.

Member Enumeration Documentation

enum PinAction::Type

Defines the kind of action which should be taken.

Enumerator:
ChangePin
UnblockPin
Invalid

Constructor & Destructor Documentation

PinAction::PinAction ( )

PinAction::~PinAction ( ) [virtual]

Member Function Documentation

InputAction * PinAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType PinAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

ChvNo PinAction::GetChvNo ( ) const [inline]

Returns if Pin1 or Pin2 shall be changed or unblocked.

const WString& PinAction::GetNewPin ( ) const [inline]

Returns the new pin .

const WString& PinAction::GetNewPin2 ( ) const [inline]

Returns the copy of the new pin.

const WString& PinAction::GetOldPin ( ) const [inline]

Returns the old pin which shall be changed.

PinAction::Type PinAction::GetType ( ) const [inline]

Returns the type of action, changing or unblocking.

const WString& PinAction::GetUnblockPin ( ) const [inline]

Returns the unblock pin which shall be used for unblocking.

BOOLEAN PinAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

BOOLEAN PinAction::ShallExecuteImmediatly ( ) [virtual]

Will always deliver TRUE because input of # shall start execution immediatly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 01:39:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PinDisableIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PinDisableIndArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for PinDisableIndArg:

[legend]
Collaboration diagram for PinDisableIndArg:

[legend]

Public Types

enum | { ID = 1047 }

Public Member Functions

INT8 | GetAddResult () const
const ChvNo & | GetChvno () const
BOOLEAN | IsResult () const
PinDisableIndArg ()
void | SetAddResult (INT8 add_result)
void | SetChvno (const ChvNo &chvno)
void | SetResult (BOOLEAN result)

Static Public Member Functions

static const PinDisableIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PinDisableIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PinDisableIndArg::PinDisableIndArg ( )

Member Function Documentation

const PinDisableIndArg & PinDisableIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT8 PinDisableIndArg::GetAddResult ( ) const [inline]

const ChvNo& PinDisableIndArg::GetChvno ( ) const [inline]

BOOLEAN PinDisableIndArg::IsResult ( ) const [inline]

void PinDisableIndArg::SetAddResult ( INT8 add_result ) [inline]

void PinDisableIndArg::SetChvno ( const ChvNo & chvno ) [inline]

void PinDisableIndArg::SetResult ( BOOLEAN result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PinDisableReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PinDisableReqArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for PinDisableReqArg:

[legend]
Collaboration diagram for PinDisableReqArg:

[legend]

Public Types

enum | { ID = 2046 }

Public Member Functions

const T_SI_CHV & | GetChv () const
const ChvNo & | GetChvno () const
PinDisableReqArg ()
PinDisableReqArg (const ChvNo &chvno, const T_SI_CHV &chv)
PinDisableReqArg (const ChvNo &chvno, const CHAR *pin)
void | SetChv (const T_SI_CHV &chv)
void | SetChvno (const ChvNo &chvno)

Static Public Member Functions

static const PinDisableReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PinDisableReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PinDisableReqArg::PinDisableReqArg | ( | const ChvNo & | chvno,
 |  | const CHAR * | pin
 | ) |

PinDisableReqArg::PinDisableReqArg | ( | const ChvNo & | chvno,
 |  | const T_SI_CHV & | chv
 | ) |

PinDisableReqArg::PinDisableReqArg ( )

Member Function Documentation

const PinDisableReqArg & PinDisableReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_SI_CHV& PinDisableReqArg::GetChv ( ) const [inline]

const ChvNo& PinDisableReqArg::GetChvno ( ) const [inline]

void PinDisableReqArg::SetChv ( const T_SI_CHV & chv ) [inline]

void PinDisableReqArg::SetChvno ( const ChvNo & chvno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PinEnableIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PinEnableIndArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for PinEnableIndArg:

[legend]
Collaboration diagram for PinEnableIndArg:

[legend]

Public Types

enum | { ID = 1046 }

Public Member Functions

INT8 | GetAddResult () const
const ChvNo & | GetChvno () const
BOOLEAN | IsResult () const
PinEnableIndArg ()
void | SetAddResult (INT8 add_result)
void | SetChvno (const ChvNo &chvno)
void | SetResult (BOOLEAN result)

Static Public Member Functions

static const PinEnableIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PinEnableIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PinEnableIndArg::PinEnableIndArg ( )

Member Function Documentation

const PinEnableIndArg & PinEnableIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT8 PinEnableIndArg::GetAddResult ( ) const [inline]

const ChvNo& PinEnableIndArg::GetChvno ( ) const [inline]

BOOLEAN PinEnableIndArg::IsResult ( ) const [inline]

void PinEnableIndArg::SetAddResult ( INT8 add_result ) [inline]

void PinEnableIndArg::SetChvno ( const ChvNo & chvno ) [inline]

void PinEnableIndArg::SetResult ( BOOLEAN result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PinEnableReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PinEnableReqArg Class Reference

#include <Apoxi/Apc/ChvStackMsgArgs.hpp>

Inheritance diagram for PinEnableReqArg:

[legend]
Collaboration diagram for PinEnableReqArg:

[legend]

Public Types

enum | { ID = 2045 }

Public Member Functions

const T_SI_CHV & | GetChv () const
const ChvNo & | GetChvno () const
PinEnableReqArg ()
PinEnableReqArg (const ChvNo &chvno, const T_SI_CHV &chv)
PinEnableReqArg (const ChvNo &chvno, const CHAR *pin)
void | SetChv (const T_SI_CHV &chv)
void | SetChvno (const ChvNo &chvno)

Static Public Member Functions

static const PinEnableReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PinEnableReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PinEnableReqArg::PinEnableReqArg | ( | const ChvNo & | chvno,
 |  | const CHAR * | pin
 | ) |

PinEnableReqArg::PinEnableReqArg | ( | const ChvNo & | chvno,
 |  | const T_SI_CHV & | chv
 | ) |

PinEnableReqArg::PinEnableReqArg ( )

Member Function Documentation

const PinEnableReqArg & PinEnableReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_SI_CHV& PinEnableReqArg::GetChv ( ) const [inline]

const ChvNo& PinEnableReqArg::GetChvno ( ) const [inline]

void PinEnableReqArg::SetChv ( const T_SI_CHV & chv ) [inline]

void PinEnableReqArg::SetChvno ( const ChvNo & chvno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/ChvStackMsgArgs.hpp
  • Apc/ChvStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlayToneReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlayToneReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for PlayToneReqArg:

[legend]
Collaboration diagram for PlayToneReqArg:

[legend]

Public Types

enum | { ID = 1313 }

Public Member Functions

const SimIconIdentifier & | GetIcon () const
const SimAlphaIdentifier & | GetInfoAlpha () const
const SimTkTransactionId & | GetTid () const
const AudioTone & | GetTone () const
PlayToneReqArg ()
void | SetIcon (const SimIconIdentifier &icon)
void | SetInfoAlpha (const SimAlphaIdentifier &info_alpha)
void | SetTid (const SimTkTransactionId &tid)
void | SetTone (const AudioTone &tone)

Static Public Member Functions

static const PlayToneReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PlayToneReqArg: reflects arguments of signal SI_PLAY_TONE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlayToneReqArg::PlayToneReqArg ( )

Member Function Documentation

const PlayToneReqArg & PlayToneReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconIdentifier& PlayToneReqArg::GetIcon ( ) const [inline]

const SimAlphaIdentifier& PlayToneReqArg::GetInfoAlpha ( ) const [inline]

const SimTkTransactionId& PlayToneReqArg::GetTid ( ) const [inline]

const AudioTone& PlayToneReqArg::GetTone ( ) const [inline]

void PlayToneReqArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void PlayToneReqArg::SetInfoAlpha ( const SimAlphaIdentifier & info_alpha ) [inline]

void PlayToneReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

void PlayToneReqArg::SetTone ( const AudioTone & tone ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlayToneRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlayToneRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for PlayToneRspArg:

[legend]
Collaboration diagram for PlayToneRspArg:

[legend]

Public Types

enum | { ID = 2313 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
PlayToneRspArg ()
PlayToneRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const PlayToneRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PlayToneRspArg: reflects arguments of signal SI_PLAY_TONE_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlayToneRspArg::PlayToneRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

PlayToneRspArg::PlayToneRspArg ( )

Member Function Documentation

const PlayToneRspArg & PlayToneRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& PlayToneRspArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& PlayToneRspArg::GetTid ( ) const [inline]

void PlayToneRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void PlayToneRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Plmn Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Plmn Class Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

void | Init (Mcc _mcc, Mnc _mnc, BOOLEAN _threedigitmnc=FALSE)
BOOLEAN | IsEqual (const Plmn &plmn) const
BOOLEAN | IsInvalid () const
Plmn | operator= (const BcdPlmn &bcdplmn)
Plmn (const Plmn &plmn)
Plmn (Mcc _mcc, Mnc _mnc, BOOLEAN _threedigitmnc=FALSE)
Plmn ()
void | SetInvalid ()

Data Fields

Mcc mcc
Mobile Country Code integer coded.
Mnc mnc
Mobile Network Code integer coded.
BOOLEAN | threedigitmnc
is set to TRUE if the mnc has three digits, means for example 001 until 999

Constructor & Destructor Documentation

Plmn::Plmn ( ) [inline]

Plmn::Plmn | ( | Mcc | _mcc,
 |  | Mnc | _mnc,
 |  | BOOLEAN | _threedigitmnc = FALSE
 | ) | [inline]

Plmn::Plmn ( const Plmn & plmn ) [inline]

Member Function Documentation

void Plmn::Init | ( | Mcc | _mcc,
 |  | Mnc | _mnc,
 |  | BOOLEAN | _threedigitmnc = FALSE
 | ) | [inline]

BOOLEAN Plmn::IsEqual ( const Plmn & plmn ) const [inline]

BOOLEAN Plmn::IsInvalid ( ) const [inline]

Plmn Plmn::operator= ( const BcdPlmn & bcdplmn )

void Plmn::SetInvalid ( ) [inline]

Field Documentation

Mcc Plmn::mcc

Mobile Country Code integer coded.

Mnc Plmn::mnc

Mobile Network Code integer coded.

BOOLEAN Plmn::threedigitmnc

is set to TRUE if the mnc has three digits, means for example 001 until 999

The documentation for this class was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:39:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnDispatcher Class Reference

#include <Apoxi/Asc/PlmnDispatcher.hpp>

Inheritance diagram for PlmnDispatcher:

[legend]
Collaboration diagram for PlmnDispatcher:

[legend]

Public Member Functions

void | Detach (RadioAccessTechnology rat_mode) const
void | Detach (const RatChangeMode rat_change_mode, RadioAccessTechnology rat_mode=RatNotAvailable) const
void | Detach (const GsmService gsm_service) const
Detach from network, set new GSM-Service and attach afterwards.
void | Detach () const
Detach from network.
BOOLEAN | IsAttachAllowed () const
BOOLEAN | IsRatChangePossible () const
PlmnDispatcher ()
void | Register (const RegisterMode &mode, const Plmn &plmn, RadioAccessTechnology plmn_rat_mode, RatChangeMode rat_change_mode=InvalidRatChangeMode, RadioAccessTechnology rat_mode=RatNotAvailable, GsmService gsm_service=InvalidGsmService) const
Register to network.
void | SetBlockingScan (BOOLEAN blocking_scan)
virtual | ~PlmnDispatcher ()

Protected Member Functions

BOOLEAN | OnAttachAllowedInd (const StackMsgArgument &arg)
BOOLEAN | OnAttachCnf (const StackMsgArgument &arg)
BOOLEAN | OnAttachRej (const StackMsgArgument &arg)
BOOLEAN | OnDetachCnf (const StackMsgArgument &arg)
BOOLEAN | OnGprsClassInd (const StackMsgArgument &arg)
BOOLEAN | OnNRegStateInd (const StackMsgArgument &arg)
BOOLEAN | OnOmRatChangeInd (const StackMsgArgument &arg)
BOOLEAN | OnPlmnListCnf (const StackMsgArgument &arg)
BOOLEAN | OnPlmnListRej (const StackMsgArgument &arg)
BOOLEAN | OnRegStateInd (const StackMsgArgument &arg)

Constructor & Destructor Documentation

PlmnDispatcher::PlmnDispatcher ( )

PlmnDispatcher::~PlmnDispatcher ( ) [virtual]

Member Function Documentation

void PlmnDispatcher::Detach ( RadioAccessTechnology rat_mode ) const

Detach from network, set RadioAccesTechnology and attach afterwards This makes only sense in case of RatChangeMode is RatChangeModeDual

void PlmnDispatcher::Detach | ( | const RatChangeMode | rat_change_mode,
 |  | RadioAccessTechnology | rat_mode = RatNotAvailable
 | ) | const

Detach from network, set RatChangeMode and prefered RadioAccesTechnology and attach afterwards. This makes only sense in case of RatChangeMode is RatChangeModeDual

void PlmnDispatcher::Detach ( const GsmService gsm_service ) const

Detach from network, set new GSM-Service and attach afterwards.

void PlmnDispatcher::Detach ( ) const

Detach from network.

BOOLEAN PlmnDispatcher::IsAttachAllowed ( ) const [inline]

BOOLEAN PlmnDispatcher::IsRatChangePossible ( ) const

BOOLEAN PlmnDispatcher::OnAttachAllowedInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnAttachCnf ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnAttachRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnDetachCnf ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnGprsClassInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnNRegStateInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnOmRatChangeInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnPlmnListCnf ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnPlmnListRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN PlmnDispatcher::OnRegStateInd ( const StackMsgArgument & arg ) [protected]

void PlmnDispatcher::Register | ( | const RegisterMode & | mode,
 |  | const Plmn & | plmn,
 |  | RadioAccessTechnology | plmn_rat_mode,
 |  | RatChangeMode | rat_change_mode = InvalidRatChangeMode,
 |  | RadioAccessTechnology | rat_mode = RatNotAvailable,
 |  | GsmService | gsm_service = InvalidGsmService
 | ) | const

Register to network.

void PlmnDispatcher::SetBlockingScan ( BOOLEAN blocking_scan ) [inline]

The documentation for this class was generated from the following files:
  • Asc/PlmnDispatcher.hpp
  • Asc/PlmnDispatcher.cpp
Generated on Wed Jan 25 01:39:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/PlmnHandler.hpp>

Collaboration diagram for PlmnHandler:

[legend]

Public Types

enum | { ID = PlmnHandlerId }

Public Member Functions

void | ChangeGprsClass (const GprsClass &gprs_class) const
BOOLEAN | ChangePreferedRatMode (RadioAccessTechnology rat_mode) const
BOOLEAN | ChangePrefService (GsmService gsm_service) const
BOOLEAN | ChangeRatMode (RatChangeMode rat_change_mode, RadioAccessTechnology rat_mode=RatNotAvailable) const
void | Detach () const
virtual HandlerId | GetHandlerId () const
RadioAccessTechnology | GetPreferedRatMode () const
GsmService | GetPrefService () const
void | InterruptScan () const
BOOLEAN | IsRatChangePossible () const
BOOLEAN | IsRegistrationAllowed () const
returns TRUE, if registration can be performed (allowed by protocolstack)
BOOLEAN | IsScanInProgress () const
PlmnHandler ()
void | Register (const RegisterMode &mode, const Plmn &plmn=InvalidPlmn, RadioAccessTechnology plmn_rat_mode=RatNotAvailable) const
BOOLEAN | Scan ()
BOOLEAN | Scan (PlmnScanList &plmn_scan_list)
virtual | ~PlmnHandler ()

Detailed Description

The PlmnHandler holds the functionality for receiving asynchronous plmn- and network-specific signals coming up from the protocolstack (like registration changes, etc) and provides an interface for the application to setup various plmn- and network-specific requests.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlmnHandler::PlmnHandler ( )

PlmnHandler::~PlmnHandler ( ) [virtual]

Member Function Documentation

void PlmnHandler::ChangeGprsClass ( const GprsClass & gprs_class ) const

The method ChangeGprsClass() is used to change the current GPRS mobile class. This function is detaching the ME from network, sets the gprs-class and is re-attaching the ME to the network The current active class can be read out from the StatusProvider.

BOOLEAN PlmnHandler::ChangePreferedRatMode ( RadioAccessTechnology rat_mode ) const

Change the prefered RAT(Radio Acces Technology). This function is detaching the ME from network, sets the prefered RAT and is re-attaching the ME to the network if it was attached before. Using this function makes no sense if the RatChangeMode is not set to RatChangeModeDual because only in this case this has any effect.

Parameters:
rat_mode RatGsm or RatUmts
Returns:
TRUE if possible

BOOLEAN PlmnHandler::ChangePrefService ( GsmService gsm_service ) const

Set the prefered service to CircuitSwitched or PacketSwitched, other values are not allowed!! This imply a detach and a attack because the setting can only take effect before attaching.

Parameters:
gsm_service CircuitSwitched or PacketSwitched is allowed

BOOLEAN PlmnHandler::ChangeRatMode | ( | RatChangeMode | rat_change_mode,
 |  | RadioAccessTechnology | rat_mode = RatNotAvailable
 | ) | const

Change the RAT-mode of the MS. This function is detaching the ME from network, sets the rat-mode and is re-attaching the ME to the network if it was attached before.

Parameters:
rat_change_mode | - Change of rat-mode makes only sense if protocol-stack is supporting this feature(UMTS dual mode) otherwise this setting will have no effect.
rat_mode | - Change of prefered rat mode. This makes only sense if the stack is supporting this feature(UMTS dual mode) and the rat_change_mode is set to RatChangeModeDual otherwise this setting has no effect
Returns:
TRUE if possible

void PlmnHandler::Detach ( ) const

The method Detach() is used to detach and disable the GSM service. the registration of a specific plmn.

HandlerId PlmnHandler::GetHandlerId ( ) const [virtual]

RadioAccessTechnology PlmnHandler::GetPreferedRatMode ( ) const

Get the actual prefered RadioAccessTechnology

Returns:
RatNotAvailable if not available

GsmService PlmnHandler::GetPrefService ( ) const

Get the currently set GsmService

void PlmnHandler::InterruptScan ( ) const

The method InterruptScan() interrupts an active scanning for plmns.

BOOLEAN PlmnHandler::IsRatChangePossible ( ) const

Check if the change of RAT-mode(Radio Access Technology) is possible

Returns:
TRUE if possible

BOOLEAN PlmnHandler::IsRegistrationAllowed ( ) const

returns TRUE, if registration can be performed (allowed by protocolstack)

BOOLEAN PlmnHandler::IsScanInProgress ( ) const

Check if there is already a Scan in progress.

void PlmnHandler::Register | ( | const RegisterMode & | mode,
 |  | const Plmn & | plmn = InvalidPlmn,
 |  | RadioAccessTechnology | plmn_rat_mode = RatNotAvailable
 | ) | const

The method Register(const RegisterMode &mode, const Plmn &plmn, RatChangeMode rat_change_mode = InvalidRatChangeMode) is used to attach the GSM service of a specific plmn. The method can be called with two different modes, the automatic or the manual mode. The response for the registration is sent via an asynchronous registration message.

Parameters:
mode | Automatic or the Manual mode.
plmn | plmn to register - only needed by manual registration.
rat_mode | - RadioAccessTechnology for register-plmn. Only available in case of manual registration.

BOOLEAN PlmnHandler::Scan ( )

The method Scan() starts the scanning for all available plmns in a non-blocking way. The answer (list of available PLMNs is returned by the message PlmnScanFinishedMsg.

Returns:
FALSE if other scan is running

BOOLEAN PlmnHandler::Scan ( PlmnScanList & plmn_scan_list )

The method Scan(PlmnScanList &) does the scanning for all available plmns in a blocking mode. The function returns, when the network-request has finished.

Parameters:
plmn_scan_list a list of all the currently available plmns.
Returns:
FALSE if other scan is running

The documentation for this class was generated from the following files:
  • Asc/PlmnHandler.hpp
  • Asc/PlmnHandler.cpp
Generated on Wed Jan 25 01:39:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnInfoReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnInfoReqArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for PlmnInfoReqArg:

[legend]
Collaboration diagram for PlmnInfoReqArg:

[legend]

Public Types

enum | { ID = 6362 }

Public Member Functions

const PlmnIndicator & | GetIndicator () const
const RegisterMode & | GetMode () const
const Plmn & | GetPlmn () const
PlmnInfoReqArg ()
PlmnInfoReqArg (const RegisterMode &mode, const PlmnIndicator &indicator, const Plmn &plmn)
void | SetIndicator (const PlmnIndicator &indicator)
void | SetMode (const RegisterMode &mode)
void | SetPlmn (const Plmn &plmn)

Static Public Member Functions

static const PlmnInfoReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PlmnInfoReqArg: reflects arguments of signal MN_PLMN_INFO_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlmnInfoReqArg::PlmnInfoReqArg | ( | const RegisterMode & | mode,
 |  | const PlmnIndicator & | indicator,
 |  | const Plmn & | plmn
 | ) |

PlmnInfoReqArg::PlmnInfoReqArg ( )

Member Function Documentation

const PlmnInfoReqArg & PlmnInfoReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PlmnIndicator& PlmnInfoReqArg::GetIndicator ( ) const [inline]

const RegisterMode& PlmnInfoReqArg::GetMode ( ) const [inline]

const Plmn& PlmnInfoReqArg::GetPlmn ( ) const [inline]

void PlmnInfoReqArg::SetIndicator ( const PlmnIndicator & indicator ) [inline]

void PlmnInfoReqArg::SetMode ( const RegisterMode & mode ) [inline]

void PlmnInfoReqArg::SetPlmn ( const Plmn & plmn ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnListAbortArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnListAbortArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for PlmnListAbortArg:

[legend]
Collaboration diagram for PlmnListAbortArg:

[legend]

Public Types

enum | { ID = 2363 }

Public Member Functions

PlmnListAbortArg ()

Static Public Member Functions

static const PlmnListAbortArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PlmnListAbortArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlmnListAbortArg::PlmnListAbortArg ( )

Member Function Documentation

const PlmnListAbortArg & PlmnListAbortArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnListCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnListCnfArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for PlmnListCnfArg:

[legend]
Collaboration diagram for PlmnListCnfArg:

[legend]

Public Types

enum | { ID = 1360 }

Public Member Functions

const PlmnScanList & | GetPlmnScanList () const
PlmnListCnfArg ()
void | SetPlmnScanList (const PlmnScanList &plmn_scan_list)

Static Public Member Functions

static const PlmnListCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PlmnListCnfArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlmnListCnfArg::PlmnListCnfArg ( )

Member Function Documentation

const PlmnListCnfArg & PlmnListCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PlmnScanList& PlmnListCnfArg::GetPlmnScanList ( ) const [inline]

void PlmnListCnfArg::SetPlmnScanList ( const PlmnScanList & plmn_scan_list ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnListEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnListEntry Class Reference

plmn list entry (ms.h: T_SEL_SINGLE_PLMN) More...

#include <Apoxi/Apc/PlmnScanList.hpp>

Inheritance diagram for PlmnListEntry:

[legend]
Collaboration diagram for PlmnListEntry:

[legend]

Public Member Functions

const Plmn & | GetPlmn () const
INT | GetPos () const
RadioAccessTechnology | GetRadioAccessTechnology () const
void | Init (const Plmn &plmn, PlmnForbiddenIndicator f_ind, PlmnPlacementIndicator p_ind, RadioAccessTechnology rat)
BOOLEAN | IsForbidden () const
BOOLEAN | operator< (const PlmnListEntry &plmn_list_entry) const
BOOLEAN | operator== (const PlmnListEntry &plmn_list_entry) const
PlmnListEntry ()
virtual | ~PlmnListEntry ()

Detailed Description

plmn list entry (ms.h: T_SEL_SINGLE_PLMN)

Constructor & Destructor Documentation

PlmnListEntry::PlmnListEntry ( )

PlmnListEntry::~PlmnListEntry ( ) [virtual]

Member Function Documentation

const Plmn& PlmnListEntry::GetPlmn ( ) const [inline]

INT PlmnListEntry::GetPos ( ) const [inline]

RadioAccessTechnology PlmnListEntry::GetRadioAccessTechnology ( ) const [inline]

void PlmnListEntry::Init | ( | const Plmn & | plmn,
 |  | PlmnForbiddenIndicator | f_ind,
 |  | PlmnPlacementIndicator | p_ind,
 |  | RadioAccessTechnology | rat
 | ) |

BOOLEAN PlmnListEntry::IsForbidden ( ) const [inline]

BOOLEAN PlmnListEntry::operator< ( const PlmnListEntry & plmn_list_entry ) const

BOOLEAN PlmnListEntry::operator== ( const PlmnListEntry & plmn_list_entry ) const

The documentation for this class was generated from the following files:
  • Apc/PlmnScanList.hpp
  • Apc/PlmnScanList.cpp
Generated on Wed Jan 25 01:39:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnListRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnListRejArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for PlmnListRejArg:

[legend]
Collaboration diagram for PlmnListRejArg:

[legend]

Public Types

enum | { ID = 1361 }

Public Member Functions

PlmnListRejArg ()

Static Public Member Functions

static const PlmnListRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlmnListRejArg::PlmnListRejArg ( )

Member Function Documentation

const PlmnListRejArg & PlmnListRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnListReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnListReqArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for PlmnListReqArg:

[legend]
Collaboration diagram for PlmnListReqArg:

[legend]

Public Types

enum | { ID = 6365 }

Public Member Functions

const PlmnScanMode & | GetMode () const
PlmnListReqArg ()
PlmnListReqArg (const PlmnScanMode &mode)
void | SetMode (const PlmnScanMode &mode)

Static Public Member Functions

static const PlmnListReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PlmnListReqArg: reflects arguments of signal MN_PLMN_LIST_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlmnListReqArg::PlmnListReqArg ( const PlmnScanMode & mode )

PlmnListReqArg::PlmnListReqArg ( )

Member Function Documentation

const PlmnListReqArg & PlmnListReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PlmnScanMode& PlmnListReqArg::GetMode ( ) const [inline]

void PlmnListReqArg::SetMode ( const PlmnScanMode & mode ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:39:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnProvider Class Reference
[Provider]

#include <Apoxi/Adc/PlmnProvider.hpp>

Inheritance diagram for PlmnProvider:

[legend]
Collaboration diagram for PlmnProvider:

[legend]

Public Types

typedef Provider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
virtual Status | GetStatus () const
Returns the status of the provider.
BOOLEAN | LookupPlmnRow (INT &row, Mcc mcc, Mnc mnc)
retrieves the row which matches the mobile country and mobile network code
PlmnProvider ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual | ~PlmnProvider ()

Detailed Description

PlmnProvider is the provider to retrieve data about plmns. An instance of this class is part of the the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_plmn_provider_id

Following column ids are defined: c_mnc_id :NumberType: returns the mobile network code. c_mcc_id :NumberType: returns the mobile country code. c_cc_id :NumberType: returns the ITU-T E.164 country code. c_country_shortname_id :WStringType: returns the countries short name. c_plmn_name_id :WStringType: returns the plmns name. c_plmn_shortname_id :WStringType: returns the plmns short name. c_networktype_id :NumberType: returns the networktype of the plmn (enumeration of NetType : Gsm900, Gsm1800, Gsm900_1800, Gsm1900, Gsm900_1900, Gsm1800_1900, Gsm900_1800_1900, ThirdGeneration)

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef Provider PlmnProvider::Base

Constructor & Destructor Documentation

PlmnProvider::PlmnProvider ( )

PlmnProvider::~PlmnProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PlmnProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT PlmnProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

Provider::Status PlmnProvider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

BOOLEAN PlmnProvider::LookupPlmnRow | ( | INT & | row,
 |  | Mcc | mcc,
 |  | Mnc | mnc
 | ) |

retrieves the row which matches the mobile country and mobile network code

INT PlmnProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

The documentation for this class was generated from the following files:
  • Adc/PlmnProvider.hpp
  • Adc/PlmnProvider.cpp
Generated on Wed Jan 25 01:39:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnRatDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnRatDispatcher Class Reference

Active Wait Dispatcher to catch the OmRatChangeCnf-Message-Arg. More...

#include <Apoxi/Asc/PlmnRatDispatcher.hpp>

Inheritance diagram for PlmnRatDispatcher:

[legend]
Collaboration diagram for PlmnRatDispatcher:

[legend]

Public Member Functions

PlmnRatDispatcher ()
Constructor.
virtual | ~PlmnRatDispatcher ()
Destructor.

Protected Member Functions

BOOLEAN | OnOmRatChangeCnf (const StackMsgArgument &arg)

Detailed Description

Active Wait Dispatcher to catch the OmRatChangeCnf-Message-Arg.

Constructor & Destructor Documentation

PlmnRatDispatcher::PlmnRatDispatcher ( )

Constructor.

PlmnRatDispatcher::~PlmnRatDispatcher ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN PlmnRatDispatcher::OnOmRatChangeCnf ( const StackMsgArgument & arg ) [protected]

Returns always TRUE. Its only a confirmation that the RAT-mode has been set. PlmnHandler.gprs returns from blocking.

Returns:
TRUE

The documentation for this class was generated from the following files:
  • Asc/PlmnRatDispatcher.hpp
  • Asc/PlmnRatDispatcher.cpp
Generated on Wed Jan 25 01:39:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnScanDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnScanDispatcher Class Reference

#include <Apoxi/Asc/PlmnScanDispatcher.hpp>

Inheritance diagram for PlmnScanDispatcher:

[legend]
Collaboration diagram for PlmnScanDispatcher:

[legend]

Public Member Functions

PlmnScanDispatcher (PlmnScanList &plmn_scan_list)
virtual | ~PlmnScanDispatcher ()
destruction

Protected Member Functions

BOOLEAN | OnPlmnListCnf (const StackMsgArgument &arg)
BOOLEAN | OnPlmnListRej (const StackMsgArgument &arg)

Constructor & Destructor Documentation

PlmnScanDispatcher::PlmnScanDispatcher ( PlmnScanList & plmn_scan_list )

construction

Parameters:
plmn_scan_list,this list will be filled. with scned plmn's

PlmnScanDispatcher::~PlmnScanDispatcher ( ) [virtual]

destruction

Member Function Documentation

BOOLEAN PlmnScanDispatcher::OnPlmnListCnf ( const StackMsgArgument & arg ) [protected]

The PlmnList has been successfully received

Returns:
TRUE

BOOLEAN PlmnScanDispatcher::OnPlmnListRej ( const StackMsgArgument & arg ) [protected]

The PlmnList could not be received

Returns:
TRUE

The documentation for this class was generated from the following files:
  • Asc/PlmnScanDispatcher.hpp
  • Asc/PlmnScanDispatcher.cpp
Generated on Wed Jan 25 01:39:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PlmnScanFinishedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PlmnScanFinishedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PlmnScanFinishedMsg:

[legend]
Collaboration diagram for PlmnScanFinishedMsg:

[legend]

Public Types

enum | { ID = 18202 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const PlmnScanList & | GetPlmnScanList () const
BOOLEAN | IsRejected () const
PlmnScanFinishedMsg (ExecutionContext *context, BOOLEAN rejected, const PlmnScanList &plmn_scan_list)
void | SetPlmnScanList (const PlmnScanList &plmn_scan_list)
void | SetRejected (BOOLEAN rejected)
virtual | ~PlmnScanFinishedMsg ()

Detailed Description

PlmnScanFinishedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PlmnScanFinishedMsg::PlmnScanFinishedMsg | ( | ExecutionContext * | context,
 |  | BOOLEAN | rejected,
 |  | const PlmnScanList & | plmn_scan_list
 | ) |

PlmnScanFinishedMsg::~PlmnScanFinishedMsg ( ) [virtual]

Member Function Documentation

Message * PlmnScanFinishedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PlmnScanFinishedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PlmnScanList& PlmnScanFinishedMsg::GetPlmnScanList ( ) const [inline]

BOOLEAN PlmnScanFinishedMsg::IsRejected ( ) const [inline]

void PlmnScanFinishedMsg::SetPlmnScanList ( const PlmnScanList & plmn_scan_list ) [inline]

void PlmnScanFinishedMsg::SetRejected ( BOOLEAN rejected ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:39:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PngDecoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PngDecoder Class Reference
[MultiMedia]

Class for decoding PNG images. More...

#include <Apoxi/AddOns/MultiMedia/PngDecoder.hpp>

Collaboration diagram for PngDecoder:

[legend]

Public Types

enum Error {
NoError, NoPngFormatError, DecoderInitError, OutOfMemoryError,
DecodingError
}

Public Member Functions

BOOLEAN | Attach (const BinData &data)
BOOLEAN | BeginDecoding (const BinData &data)
BOOLEAN | DecodeNextScanline ()
void | EndDecoding ()
INT | GetHeight () const
Error | GetLastError () const
void | GetNextPixelColor (UINT8 &red, UINT8 &green, UINT8 &blue, UINT8 &alpha)
Color | GetTransparentColor () const
INT | GetWidth () const
BOOLEAN | HasNativeAlphaChannel () const
void | InitPixelColorAccess (INT scanline_idx=0)
BOOLEAN | IsInterlaced () const
BOOLEAN | IsTransparent () const
void | ReleaseInstance ()

Static Public Member Functions

static PngDecoder * | GetInstance ()
static BOOLEAN | IsPng (const BinData &data)

Protected Member Functions

void | CleanUp ()
void | FreePng ()
BOOLEAN | InitDecoderLib ()
PngDecoder ()
void | SetErr (Error code, BOOLEAN cleanup=TRUE)
virtual | ~PngDecoder ()

Static Protected Member Functions

static void | PngLibraryFreeFunction (png_structp png_struct, png_voidp ptr)
static png_voidp | PngLibraryMallocFunction (png_structp png_struct, png_size_t size)
static void | PngLibraryReadFunction (png_structp png_struct, png_bytep data, png_size_t length)

Protected Attributes

ColorValue m_background_color
Specifies the color which should be painted as background.
BOOLEAN | m_background_specified
Tells if a background color for a transparent image is specified.
int | m_bit_depth
UINT8 | m_bkgd_blue
UINT8 | m_bkgd_green
UINT8 | m_bkgd_red
int | m_color_type
const BinData * | m_data
UINT32 | m_data_idx
Current read position in data stream m_data.
BOOLEAN | m_has_native_alpha_channel
Tells if the image data has a native alpha channel.
png_uint_32 | m_height
png_infop | m_info_ptr
int | m_interlace_type
BOOLEAN | m_is_transparent
Tells if the image is transparent.
Error m_last_error
Code of last error occured.
png_structp | m_png_ptr
png_bytep | m_scanline
INT | m_scanline_idx
Current read position in scanline buffer m_scanline.
Color m_transparent_color
Specifies the color which codes a transparent pixel.
UINT8 | m_trns_blue
UINT8 | m_trns_green
UINT8 | m_trns_red
png_uint_32 | m_width

Static Protected Attributes

static PngDecoder * | c_decoder = 0
Singleton PNG decoder instance.
static const INT | c_pixel_channels = 4
static Semaphore | c_sem
static BOOLEAN | c_sem_created = FALSE
Access control.
static png_voidp | m_huge_mem = 0
The huge pointer taking the zlib buffer.

Detailed Description

Class for decoding PNG images.

Member Enumeration Documentation

enum PngDecoder::Error

Enumerator:
NoError
NoPngFormatError
DecoderInitError
OutOfMemoryError
DecodingError

Constructor & Destructor Documentation

PngDecoder::PngDecoder ( ) [protected]

PngDecoder::~PngDecoder ( ) [protected, virtual]

Member Function Documentation

BOOLEAN PngDecoder::Attach ( const BinData & data )

Attaches the data stream data to the decoder. If data is in PNG format then basic image metrics information is read and stored and can be interrogated on successful return. This method is intended to pre-analyze data and extract basic image metrics information prior to decoding the image. On successful return one can use the methods given in the see-clause to get image metrics information.

See also:
GetWidth()

GetHeight()

IsInterlaced()

BOOLEAN PngDecoder::BeginDecoding ( const BinData & data )

Calls Attach() and initializes the decoding process. After this method has been called the decoder can be asked if the image uses transparency.

See also:
TransparentMode()

void PngDecoder::CleanUp ( ) [protected]

Frees memory and resets member variables.

BOOLEAN PngDecoder::DecodeNextScanline ( )

Decodes one scanline and writes it into the internal scanline buffer m_scanline.

void PngDecoder::EndDecoding ( )

Ends decoding by cleaning up dynamic memory.

void PngDecoder::FreePng ( ) [protected]

Frees libpng structures.

INT PngDecoder::GetHeight ( ) const

Returns the height of the image. Valid only after successful attach.

See also:
Attach()

PngDecoder * PngDecoder::GetInstance ( ) [static]

Returns the singleton instance of the PNG decoder. The instance is protected using a semaphore.

PngDecoder::Error PngDecoder::GetLastError ( ) const

Worker methods of this class return TRUE on success and FALSE on failure of their work. In case of failure this method can be called to get more information on the problem encountered.

void PngDecoder::GetNextPixelColor | ( | UINT8 & | red,
 |  | UINT8 & | green,
 |  | UINT8 & | blue,
 |  | UINT8 & | alpha
 | ) |

Retrieves the color of the next pixel in Rgba format. If it is a fully transparent pixel, either simple or alpha channel transparency, then FALSE is returned signalling that nothing should be drawn. Background color information provided in the image is ignored, the preferred method is to use the client background instead.

Color PngDecoder::GetTransparentColor ( ) const

Returns the transparent color. This is only valid if IsTransparent() is TRUE.

INT PngDecoder::GetWidth ( ) const

Returns the width of the image. Valid only after successful attach.

See also:
Attach()

BOOLEAN PngDecoder::HasNativeAlphaChannel ( ) const

Tells if the native image data (image data before any transformation) provides alpha channel information. Valid only after successful begin of decoding.

See also:
BeginDecoding()

BOOLEAN PngDecoder::InitDecoderLib ( ) [protected]

Allocates libpng structures and reads the PNG image header.

void PngDecoder::InitPixelColorAccess ( INT scanline_idx = 0 )

Initializes sequential access to the decoded pixel colors currently residing in the scanline buffer m_scanline. The color information can be read pixel-wise using method GetNextPixelColor() starting at index scanline_idx.

Parameters:
scanline_idx Index where to start reading the pixels of the currently decoded scanline.
See also:
GetNextPixelColor()

BOOLEAN PngDecoder::IsInterlaced ( ) const

Tells if the image is to be drawn in interlaced mode. Valid only after successful attach.

See also:
Attach()

BOOLEAN PngDecoder::IsPng ( const BinData & data ) [static]

Determines if the data stream data starts like a valid PNG image data stream.

BOOLEAN PngDecoder::IsTransparent ( ) const

Tells if the image is to be drawn in transparent mode. Valid only after successful begin of decoding.

See also:
BeginDecoding()

void PngDecoder::PngLibraryFreeFunction | ( | png_structp | png_struct,
 |  | png_voidp | ptr
 | ) | [static, protected]

Free function needed by libpng to free from dedicated memory pool.

png_voidp PngDecoder::PngLibraryMallocFunction | ( | png_structp | png_struct,
 |  | png_size_t | size
 | ) | [static, protected]

Malloc function needed by libpng to use only dedicated memory pool.

void PngDecoder::PngLibraryReadFunction | ( | png_structp | png_struct,
 |  | png_bytep | data,
 |  | png_size_t | length
 | ) | [static, protected]

Read function needed by libpng for reading from data stream.

void PngDecoder::ReleaseInstance ( )

Releases the PNG decoder, i.e. the semaphore is released and the singleton instance is deleted.

void PngDecoder::SetErr | ( | Error | code,
 |  | BOOLEAN | cleanup = TRUE
 | ) | [protected]

Sets error code and optionally performs a cleanup.

Field Documentation

PngDecoder * PngDecoder::c_decoder = 0 [static, protected]

Singleton PNG decoder instance.

const INT PngDecoder::c_pixel_channels = 4 [static, protected]

Semaphore PngDecoder::c_sem [static, protected]

BOOLEAN PngDecoder::c_sem_created = FALSE [static, protected]

Access control.

ColorValue PngDecoder::m_background_color [protected]

Specifies the color which should be painted as background.

BOOLEAN PngDecoder::m_background_specified [protected]

Tells if a background color for a transparent image is specified.

int PngDecoder::m_bit_depth [protected]

UINT8 PngDecoder::m_bkgd_blue [protected]

UINT8 PngDecoder::m_bkgd_green [protected]

UINT8 PngDecoder::m_bkgd_red [protected]

int PngDecoder::m_color_type [protected]

const BinData* PngDecoder::m_data [protected]

UINT32 PngDecoder::m_data_idx [protected]

Current read position in data stream m_data.

BOOLEAN PngDecoder::m_has_native_alpha_channel [protected]

Tells if the image data has a native alpha channel.

png_uint_32 PngDecoder::m_height [protected]

png_voidp PngDecoder::m_huge_mem = 0 [static, protected]

The huge pointer taking the zlib buffer.

png_infop PngDecoder::m_info_ptr [protected]

int PngDecoder::m_interlace_type [protected]

BOOLEAN PngDecoder::m_is_transparent [protected]

Tells if the image is transparent.

Error PngDecoder::m_last_error [protected]

Code of last error occured.

png_structp PngDecoder::m_png_ptr [protected]

Members used to communicate with libpng. They have exactly the same data types as libpng uses to assure proper communication.

png_bytep PngDecoder::m_scanline [protected]

INT PngDecoder::m_scanline_idx [protected]

Current read position in scanline buffer m_scanline.

Color PngDecoder::m_transparent_color [protected]

Specifies the color which codes a transparent pixel.

UINT8 PngDecoder::m_trns_blue [protected]

UINT8 PngDecoder::m_trns_green [protected]

UINT8 PngDecoder::m_trns_red [protected]

png_uint_32 PngDecoder::m_width [protected]

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/PngDecoder.hpp
  • AddOns/MultiMedia/PngDecoder.cpp
Generated on Wed Jan 25 01:40:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PngEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PngEncoder Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/PngEncoder.hpp>

Inheritance diagram for PngEncoder:

[legend]
Collaboration diagram for PngEncoder:

[legend]

Public Member Functions

virtual BOOLEAN | Encode (const Image &img, DataSink &dest, BOOLEAN block=TRUE)
virtual BOOLEAN | Encode (BinData &src, const Image::MetaData &src_params, DataSink &dest, BOOLEAN block=TRUE, void *context=0, Cb_ImageEncoded=0)
PngEncoder (const EncodingParameters &param)
virtual | ~PngEncoder ()

Protected Member Functions

virtual BOOLEAN | BeginEncoding (DataSink &dest)
virtual BOOLEAN | EncodeSynchronously (const Image &img, DataSink &dest)
virtual BOOLEAN | EncodeSynchronously (BinData &src, const Image::MetaData &src_params, DataSink &dest)
virtual BOOLEAN | EndEncoding (DataSink &dest)

Data Structures

class | EncodingParameters

Detailed Description

Allows to encode PNG images from various RGB source formats.

Constructor & Destructor Documentation

PngEncoder::PngEncoder ( const EncodingParameters & param )

Constructor, which initializes the PngEncoder with the PNG encoding parameters.

Parameters:
param EncodingParameters for the PngEncoder

PngEncoder::~PngEncoder ( ) [virtual]

Destructor, frees all required memory which was needed for encoding

Member Function Documentation

BOOLEAN PngEncoder::BeginEncoding ( DataSink & dest ) [protected, virtual]

See also:
ImageEncoder::BeginEncoding

Reimplemented from ImageEncoder.

BOOLEAN PngEncoder::Encode | ( | const Image & | img,
 |  | DataSink & | dest,
 |  | BOOLEAN | block = TRUE
 | ) | [virtual]

See also:
ImageEncoder::Encode

Implements ImageEncoder.

BOOLEAN PngEncoder::Encode | ( | BinData & | src,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest,
 |  | BOOLEAN | block = TRUE,
 |  | void * | context = 0,
 |  | Cb_ImageEncoded | = 0
 | ) | [virtual]

See also:
ImageEncoder::Encode
Parameters:
block | = 0
context | = 0
callback | = 0

BOOLEAN PngEncoder::EncodeSynchronously | ( | const Image & | img,
 |  | DataSink & | dest
 | ) | [protected, virtual]

See also:
ImageEncoder::EncodeSynchronously

Reimplemented from ImageEncoder.

BOOLEAN PngEncoder::EncodeSynchronously | ( | BinData & | src,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest
 | ) | [protected, virtual]

See also:
ImageEncoder::EncodeSynchronously

Reimplemented from ImageEncoder.

BOOLEAN PngEncoder::EndEncoding ( DataSink & dest ) [protected, virtual]

See also:
ImageEncoder::EndDecoding

Reimplemented from ImageEncoder.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/PngEncoder.hpp
  • AddOns/MultiMedia/PngEncoder.cpp
Generated on Wed Jan 25 01:40:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PngEncoder::EncodingParameters Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PngEncoder::EncodingParameters

PngEncoder::EncodingParameters Class Reference

#include <Apoxi/AddOns/MultiMedia/PngEncoder.hpp>

Inheritance diagram for PngEncoder::EncodingParameters:

[legend]
Collaboration diagram for PngEncoder::EncodingParameters:

[legend]

Public Types

enum EncodingFormat {
GrayScaleFormat, RgbFormat, PaletteFormat, GrayScaleAlphaFormat,
RgbAlphaFormat
}

Public Member Functions

EncodingParameters (XYDIM width, XYDIM height)
EncodingFormat | GetEncodingFormat () const
void | SetEncodingFormat (EncodingFormat format)

Detailed Description

Describes the encoding parameters like color format, size and quality level.

Member Enumeration Documentation

enum PngEncoder::EncodingParameters::EncodingFormat

Encoding format of the PNG image. The encoding format can be changed by PngEncoder::SetEncodingFormat. Currently only the RgbFormat is supported.

Enumerator:
GrayScaleFormat
RgbFormat
PaletteFormat
GrayScaleAlphaFormat
RgbAlphaFormat

Constructor & Destructor Documentation

PngEncoder::EncodingParameters::EncodingParameters | ( | XYDIM | width,
 |  | XYDIM | height
 | ) | [inline]

Constructor of EncodingParameters

Parameters:
width | Output width (is ignored in case of calling Encode with Bindata)
height | Output height (is ignored in case of calling Encode with BinData)

Reimplemented from ImageEncoder::EncodingParameters.

Member Function Documentation

EncodingFormat PngEncoder::EncodingParameters::GetEncodingFormat ( ) const [inline]

Returns the used encoding format.

void PngEncoder::EncodingParameters::SetEncodingFormat ( EncodingFormat format ) [inline]

Sets the used encoding format, which has impacts on the quality and size of the JPEG image.

The documentation for this class was generated from the following file:
  • AddOns/MultiMedia/PngEncoder.hpp
Generated on Wed Jan 25 01:40:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PngEncodingThreadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PngEncodingThreadlet Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/PngEncodingThreadlet.hpp>

Inheritance diagram for PngEncodingThreadlet:

[legend]
Collaboration diagram for PngEncodingThreadlet:

[legend]

Public Member Functions

virtual | ~PngEncodingThreadlet ()

Static Public Member Functions

static PngEncodingThreadlet * | CreateInstance (PngEncoder &encoder, BinData &source, const Image::MetaData &src_params, DataSink &dest)
static PngEncodingThreadlet * | CreateInstance (PngEncoder &encoder, const Image &source, DataSink &dest)

Protected Member Functions

PngEncodingThreadlet (PngEncoder &encoder, BinData &source, const Image::MetaData &src_params, DataSink &dest)
PngEncodingThreadlet (PngEncoder &encoder, const Image &source, DataSink &dest)

Detailed Description

PngEncodingThreadlet uses an own thread for encoding a PNG image.

Constructor & Destructor Documentation

PngEncodingThreadlet::~PngEncodingThreadlet ( ) [virtual]

PngEncodingThreadlet::PngEncodingThreadlet | ( | PngEncoder & | encoder,
 |  | const Image & | source,
 |  | DataSink & | dest
 | ) | [protected]

PngEncodingThreadlet::PngEncodingThreadlet | ( | PngEncoder & | encoder,
 |  | BinData & | source,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest
 | ) | [protected]

Member Function Documentation

PngEncodingThreadlet * PngEncodingThreadlet::CreateInstance | ( | PngEncoder & | encoder,
 |  | BinData & | source,
 |  | const Image::MetaData & | src_params,
 |  | DataSink & | dest
 | ) | [static]

Creates an encoding-threadlet and releases itself automatically after the threadlet has been executed.

PngEncodingThreadlet * PngEncodingThreadlet::CreateInstance | ( | PngEncoder & | encoder,
 |  | const Image & | source,
 |  | DataSink & | dest
 | ) | [static]

Creates an encoding-threadlet and releases itself automatically after the threadlet has been executed.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/PngEncodingThreadlet.hpp
  • AddOns/MultiMedia/PngEncodingThreadlet.cpp
Generated on Wed Jan 25 01:40:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PngImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PngImage Class Reference
[MultiMedia]

Class to contain, decompress and draw a PNG compatible image. More...

#include <Apoxi/AddOns/MultiMedia/PngImage.hpp>

Inheritance diagram for PngImage:

[legend]
Collaboration diagram for PngImage:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

virtual BOOLEAN | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT frame_idx, XYDIM scaled_width=-1, XYDIM scaled_height=-1, const Rect &clip_rect=Rect()) const
virtual const BinData * | GetBinData () const
Returns the binary data of the image. Per default 0 is returned.
virtual UINT32 | GetFrameDelay (INT frame_idx) const
virtual INT | GetNextFrame (INT frame_idx) const
Returns the index of the frame wich follows the specified frame in frame_idx.
BOOLEAN | Init (BinData *data)
virtual BOOLEAN | IsInstanceOf (INT id) const
PngImage (BinData *data, BOOLEAN *success=0)
PngImage ()
virtual | ~PngImage ()

Protected Member Functions

PngDecoder * | BeginDrawing () const
BOOLEAN | DecodeNextScanline (DeviceContext *dc, PngDecoder &decoder, XYDIM x, XYDIM y, XYDIM scaled_width, XYDIM scaled_height) const
void | DrawHeightScaledScanline (PngDecoder &decoder, PaintDc &pdc, const Rect &clip_rect, XYDIM y) const
void | DrawPixel (PngDecoder &decoder, PaintDc &pdc, const Rect &clip_rect, XYDIM x, XYDIM y, const Color &color) const
void | DrawScaledPixel (PngDecoder &decoder, PaintDc &pdc, const Rect &clip_rect, XYDIM x, XYDIM y, const Color &color) const
virtual void | DrawScanline (PngDecoder &decoder, PaintDc &pdc, const Rect &clip_rect, XYDIM y, UINT thickness=1) const
void | EndDrawing (PngDecoder &decoder) const
void | FreeImage ()
virtual ColorValue | GetTransparentColor (void *context) const
virtual BOOLEAN | HasAlphaChannel (void *context) const
virtual BOOLEAN | IsTransparent (void *context) const
void | SetupDrawingMode (const PngDecoder &decoder, XYDIM &scaled_width, XYDIM &scaled_height, XYDIM x_origin, XYDIM y_origin, INT frame_idx) const
void | SmartDrawPixel (PngDecoder &decoder, PaintDc &pdc, const Rect &clip_rect, XYDIM x, XYDIM y) const
void | SmartDrawScanline (PngDecoder &decoder, PaintDc &pdc, const Rect &clip_rect, XYDIM y) const

Protected Attributes

BinData * m_data
BOOLEAN | m_is_interlaced
XYDIM | m_last_unscaled_height_idx
XYDIM | m_last_unscaled_width_idx
BOOLEAN | m_scaled_bottom_edge_cutted
XYDIM | m_scaled_height
BOOLEAN | m_scaled_right_edge_cutted
XYDIM | m_scaled_width
BOOLEAN | m_scaling_height
BOOLEAN | m_scaling_width
UINT32 | m_shifted_pixel_height
UINT32 | m_shifted_pixel_width
XYDIM | m_x_origin
XYDIM | m_y_origin

Static Protected Attributes

static const UINT32 | c_shift = 15

Detailed Description

Class to contain, decompress and draw a PNG compatible image.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Image.

Constructor & Destructor Documentation

PngImage::PngImage ( )

If the default constructor is used, the parameters have to be provided by using method Init().

PngImage::PngImage | ( | BinData * | data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
data | Pointer to a binary data stream which contains the PNG data. After passing the binary data stream, the stream is obtained by the PNG image and hence automatically released in the destructor of the PNG image.
success | Output-parameter, which indicates whether the initialization has been successful.

PngImage::~PngImage ( ) [virtual]

Releases the binary data stream m_data if it is still obtained and destructs the object.

Member Function Documentation

PngDecoder * PngImage::BeginDrawing ( ) const [protected]

Initializes the drawing process.

BOOLEAN PngImage::DecodeNextScanline | ( | DeviceContext * | dc,
 |  | PngDecoder & | decoder,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | scaled_width,
 |  | XYDIM | scaled_height
 | ) | const [protected]

Decodes the next scanline. If not successfull the corrupt image sign is drawn.

BOOLEAN PngImage::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | frame_idx,
 |  | XYDIM | scaled_width = -1,
 |  | XYDIM | scaled_height = -1,
 |  | const Rect & | clip_rect = Rect()
 | ) | const [virtual]

Drawing a PNG image with the base-implementation of Draw() doesn't work for all kinds of PNG images: Alpha channel images can't be drawn since drawing transparent pixels is only supported using a dedicated transparent color. In case of an alpha channel image, this transparency color is not available since transparency is coded into the alpha channel. Adam-7 interlaced images can't be drawn scanline by scanline since the pixels stored are not packed in scanlines. The Adam-7 interlaced scheme is also called sparkling method. To overcome these shortcuts the base class' Draw() method is overridden and implements the whole drawing itself.

Reimplemented from Image.

void PngImage::DrawHeightScaledScanline | ( | PngDecoder & | decoder,
 |  | PaintDc & | pdc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | y
 | ) | const [protected]

Draws the scanline at row y taking into account height scaling.

void PngImage::DrawPixel | ( | PngDecoder & | decoder,
 |  | PaintDc & | pdc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | const Color & | color
 | ) | const [inline, protected]

Draws the pixel at position (x, y) with the given color. The pixel is drawn in device context pdc and in the internal bitmap buffer if buffering is possible.

void PngImage::DrawScaledPixel | ( | PngDecoder & | decoder,
 |  | PaintDc & | pdc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | const Color & | color
 | ) | const [inline, protected]

Draws the the pixel at position (x, y) taking into account scaling.

void PngImage::DrawScanline | ( | PngDecoder & | decoder,
 |  | PaintDc & | pdc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | y,
 |  | UINT | thickness = 1
 | ) | const [protected, virtual]

Draws the scanline at row y using the colors currently residing in the scanline buffer of the decoder. The scanline is drawn in device context pdc and in the internal bitmap buffer if buffering is possible. The width in pixels of the scanline is defined by thickness. The method automatically scales the width if required.

Parameters:
thickness Specifies how thick in pixels the scanline should be drawn. Minimum is 1.

void PngImage::EndDrawing ( PngDecoder & decoder ) const [protected]

Deinitializes the drawing process.

void PngImage::FreeImage ( ) [protected]

Frees the obtained image.

const BinData * PngImage::GetBinData ( ) const [virtual]

Returns the binary data of the image. Per default 0 is returned.

Reimplemented from Image.

UINT32 PngImage::GetFrameDelay ( INT frame_idx ) const [virtual]

Returns the time in milliseconds the specified frame should be displayed. The value Image::c_unlimited means that it should be displayed _forever_.

Implements Image.

INT PngImage::GetNextFrame ( INT frame_idx ) const [virtual]

Returns the index of the frame wich follows the specified frame in frame_idx.

Implements Image.

ColorValue PngImage::GetTransparentColor ( void * context ) const [protected, virtual]

Returns the color-value of the transparent color. The value is only valid, if IsTransparent is TRUE. Per default 0 is returned.

Parameters:
context Pointer to the context-object, which can be retrieved within Image::BeginScanlineDrawing.

Reimplemented from Image.

BOOLEAN PngImage::HasAlphaChannel ( void * context ) const [protected, virtual]

Returns TRUE, if the image supports alpha blending. Per default, FALSE is returned.

Parameters:
context Pointer to the context-object, which can be retrieved within Image::BeginScanlineDrawing.

Reimplemented from Image.

BOOLEAN PngImage::Init ( BinData * data )

Parameters:
data Pointer to a binary data stream which contains the PNG data. After passing the binary data stream, the stream is obtained by the PNG image and hence automatically released in the destructor of the PNG image.
Returns:
Indicates the success of the initialization.

BOOLEAN PngImage::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Image.

BOOLEAN PngImage::IsTransparent ( void * context ) const [protected, virtual]

Returns TRUE, if the image has transparent pixels. Having transparent pixels may slow down the displaying-process of an image. Per default FALSE is returned.

Parameters:
context Pointer to the context-object, which can be retrieved in BeginScanlineDrawing.

Reimplemented from Image.

void PngImage::SetupDrawingMode | ( | const PngDecoder & | decoder,
 |  | XYDIM & | scaled_width,
 |  | XYDIM & | scaled_height,
 |  | XYDIM | x_origin,
 |  | XYDIM | y_origin,
 |  | INT | frame_idx
 | ) | const [protected]

Sets up the drawing for either scaled or unscaled mode and also installs the bitmap buffer if the image gets buffered.

void PngImage::SmartDrawPixel | ( | PngDecoder & | decoder,
 |  | PaintDc & | pdc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | x,
 |  | XYDIM | y
 | ) | const [inline, protected]

Draws a single pixel at position (x, y) knowing if drawing has to be done in unscaled or scaled mode.

void PngImage::SmartDrawScanline | ( | PngDecoder & | decoder,
 |  | PaintDc & | pdc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | y
 | ) | const [protected]

Draws the scanline at row y knowing if drawing has to be done in unscaled or scaled mode.

Field Documentation

const UINT32 PngImage::c_shift = 15 [static, protected]

BinData* PngImage::m_data [protected]

BOOLEAN PngImage::m_is_interlaced [protected]

XYDIM PngImage::m_last_unscaled_height_idx [mutable, protected]

XYDIM PngImage::m_last_unscaled_width_idx [mutable, protected]

BOOLEAN PngImage::m_scaled_bottom_edge_cutted [mutable, protected]

XYDIM PngImage::m_scaled_height [mutable, protected]

BOOLEAN PngImage::m_scaled_right_edge_cutted [mutable, protected]

XYDIM PngImage::m_scaled_width [mutable, protected]

BOOLEAN PngImage::m_scaling_height [mutable, protected]

BOOLEAN PngImage::m_scaling_width [mutable, protected]

UINT32 PngImage::m_shifted_pixel_height [mutable, protected]

UINT32 PngImage::m_shifted_pixel_width [mutable, protected]

XYDIM PngImage::m_x_origin [mutable, protected]

XYDIM PngImage::m_y_origin [mutable, protected]

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/PngImage.hpp
  • AddOns/MultiMedia/PngImage.cpp
Generated on Wed Jan 25 01:40:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PnnEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PnnEntry Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimAuxHandler.hpp>

Collaboration diagram for PnnEntry:

[legend]

Public Member Functions

PnnEntry ()

Data Fields

BOOLEAN | m_longci
WString m_longname
BOOLEAN | m_shortci
WString m_shortname

Constructor & Destructor Documentation

PnnEntry::PnnEntry ( ) [inline]

The documentation for this class was generated from the following file:
  • Adc/SimAuxHandler.hpp
Generated on Wed Jan 25 01:40:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Point Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Point Class Reference
[GUI]

Combines the x- and y-coordinate. More...

#include <Apoxi/Gui/Point.hpp>

Public Member Functions

XYDIM | GetX () const
Returns the x-value of the point.
XYDIM | GetY () const
Sets the y-value of the point.
BOOLEAN | IsInside (const Rect &rect) const
Checks the Point, if its coordinates are inside.
void | Move (XYDIM dx, XYDIM dy)
Point (const Point &point)
Constructor for a point.
Point (XYDIM x=0, XYDIM y=0)
Constructor for a point.
void | SetX (XYDIM x)
Sets the x-value of the point.
void | SetY (XYDIM y)
Sets the y-value of the point.

Detailed Description

Combines the x- and y-coordinate.

Constructor & Destructor Documentation

Point::Point | ( | XYDIM | x = 0,
 |  | XYDIM | y = 0
 | ) | [inline]

Constructor for a point.

Point::Point ( const Point & point ) [inline]

Constructor for a point.

Member Function Documentation

XYDIM Point::GetX ( ) const [inline]

Returns the x-value of the point.

XYDIM Point::GetY ( ) const [inline]

Sets the y-value of the point.

BOOLEAN Point::IsInside ( const Rect & rect ) const

Checks the Point, if its coordinates are inside.

void Point::Move | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [inline]

Parameters:
dx | horizontal movement
dy | vertical movement

void Point::SetX ( XYDIM x ) [inline]

Sets the x-value of the point.

void Point::SetY ( XYDIM y ) [inline]

Sets the y-value of the point.

The documentation for this class was generated from the following files:
  • Gui/Point.hpp
  • Gui/Point.cpp
Generated on Wed Jan 25 01:40:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PortHeaderInformation Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PortHeaderInformation Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/PortHeaderInformation.hpp>

Inheritance diagram for PortHeaderInformation:

[legend]
Collaboration diagram for PortHeaderInformation:

[legend]

Public Member Functions

UINT8 | GetConcMaxNo () const
UINT16 | GetConcRefNo () const
UINT8 | GetConcSeqNo () const
UINT8 * | GetPayloadData () const
UINT8 | GetPayloadSize () const
const PhoneNumber & | GetPhoneNumber () const
SmsPortNo | GetSmsDestinationPortNo () const
SmsPortNo | GetSmsOriginatorPortNo () const
BOOLEAN | HasSmsPortNo () const
BOOLEAN | IsConcateneted () const
PortHeaderInformation (Tpdu *tpdu=0)
virtual | ~PortHeaderInformation ()

Constructor & Destructor Documentation

PortHeaderInformation::PortHeaderInformation ( Tpdu * tpdu = 0 )

PortHeaderInformation::~PortHeaderInformation ( ) [virtual]

Member Function Documentation

UINT8 PortHeaderInformation::GetConcMaxNo ( ) const [inline]

UINT16 PortHeaderInformation::GetConcRefNo ( ) const [inline]

UINT8 PortHeaderInformation::GetConcSeqNo ( ) const [inline]

UINT8* PortHeaderInformation::GetPayloadData ( ) const [inline]

UINT8 PortHeaderInformation::GetPayloadSize ( ) const [inline]

const PhoneNumber& PortHeaderInformation::GetPhoneNumber ( ) const [inline]

SmsPortNo PortHeaderInformation::GetSmsDestinationPortNo ( ) const [inline]

SmsPortNo PortHeaderInformation::GetSmsOriginatorPortNo ( ) const [inline]

BOOLEAN PortHeaderInformation::HasSmsPortNo ( ) const [inline]

BOOLEAN PortHeaderInformation::IsConcateneted ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/PortHeaderInformation.hpp
  • Asc/PortHeaderInformation.cpp
Generated on Wed Jan 25 01:40:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PositionIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PositionIndicator Class Reference
[Components]

#include <Apoxi/Gui/PositionIndicator.hpp>

Inheritance diagram for PositionIndicator:

[legend]
Collaboration diagram for PositionIndicator:

[legend]

Public Types

enum | { ID = 18 }
enum | Orientation { Horizontal, Vertical }

Public Member Functions

INT | GetMaxValue () const
INT | GetMinValue () const
Orientation | GetOrientation () const
INT | GetValue () const
INT | GetVisibleValuesCount () const
void | Init (Control *control, Orientation orientation, INT min_value, INT max_value, INT visible_values_count=-1, INT value=-1, BOOLEAN auto_draw=TRUE)
BOOLEAN | IsFullsized () const
virtual BOOLEAN | IsInstanceOf (INT id) const
PositionIndicator (Control *control, Orientation orientation, INT min_value, INT max_value, INT visible_values_count=-1, INT value=-1, BOOLEAN auto_draw=TRUE)
PositionIndicator ()
void | SetMaxValue (INT max_value)
void | SetMinValue (INT min_value)
void | SetOrientation (Orientation orientation)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetRange (INT min_value, INT max_value)
void | SetValue (INT value)
void | SetVisibleValuesCount (INT visible_values_count)
virtual | ~PositionIndicator ()

Protected Member Functions

virtual void | OnThemeChanged ()

Detailed Description

Indicates the position of a range, which is partly visible. The range is defined by a minimum value and a maximum value, the current position by a value. Additionaly it must be defined, how many values can be visible. The Position-Indicator can be aligned horizontal or vertical.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from DrawableObject.

enum PositionIndicator::Orientation

Enumerator:
Horizontal
Vertical

Constructor & Destructor Documentation

PositionIndicator::PositionIndicator ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

PositionIndicator::PositionIndicator | ( | Control * | control,
 |  | Orientation | orientation,
 |  | INT | min_value,
 |  | INT | max_value,
 |  | INT | visible_values_count = -1,
 |  | INT | value = -1,
 |  | BOOLEAN | auto_draw = TRUE
 | ) |

Parameters:
control | Pointer to the parent-Control.
orientation | Orientation: Horizontal or Vertical.
min_value | Minimum value (must be <= maximum value).
max_value | Maximum value (must be >= minimum value).
visible_values_count | Number of visible values (default: 1).
value | Value (default: minimum value)
auto_draw | TRUE, if the position-indicator should be drawn automatically in Control::OnPaint()

PositionIndicator::~PositionIndicator ( ) [virtual]

Member Function Documentation

INT PositionIndicator::GetMaxValue ( ) const [inline]

Returns:
Maximum value of the range.

INT PositionIndicator::GetMinValue ( ) const [inline]

Returns:
Minimum value of the range.

Orientation PositionIndicator::GetOrientation ( ) const [inline]

Returns:
Orientation: Horizontal or Vertical.

INT PositionIndicator::GetValue ( ) const [inline]

Parameters:
value Value (minimum value <= value <= maximum value).

INT PositionIndicator::GetVisibleValuesCount ( ) const [inline]

Returns:
Number of visible values.

void PositionIndicator::Init | ( | Control * | control,
 |  | Orientation | orientation,
 |  | INT | min_value,
 |  | INT | max_value,
 |  | INT | visible_values_count = -1,
 |  | INT | value = -1,
 |  | BOOLEAN | auto_draw = TRUE
 | ) |

Parameters:
control | Pointer to the parent-Control.
orientation | Orientation: Horizontal or Vertical.
min_value | Minimum value (must be <= maximum value).
max_value | Maximum value (must be >= minimum value).
visible_values_count | Number of visible values (default: 1).
value | Value (default: minimum value)
auto_draw | TRUE, if the position-indicator should be drawn automatically in Control::OnPaint()

BOOLEAN PositionIndicator::IsFullsized ( ) const

Returns:
TRUE, if all values are visible.

BOOLEAN PositionIndicator::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from DrawableObject.

void PositionIndicator::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged()

Reimplemented from DrawableObject.

void PositionIndicator::SetMaxValue ( INT max_value )

Parameters:
max_value Maximum value of the range (must be >= minimum value).

void PositionIndicator::SetMinValue ( INT min_value )

Parameters:
min_value Minimum value of the range (must be <= maximum value).

void PositionIndicator::SetOrientation ( Orientation orientation )

Sets the orientation (Horizontal or Vertical). The height is adjusted corresponding the settings in the view, when the orientation is Horizontal. The width is adjusted to the corresponding settings in the view, when the orientation is Vertical.

BOOLEAN PositionIndicator::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from DrawableObject.

void PositionIndicator::SetRange | ( | INT | min_value,
 |  | INT | max_value
 | ) |

Parameters:
min_value | Minimum value (must be <= maximum value).
max_value | Maximum value (must be >= minimum value).

void PositionIndicator::SetValue ( INT value )

Sets the value. It is guaranteed by the method, that value is >= minimum value and <= maximum value.

Parameters:
value Value.

void PositionIndicator::SetVisibleValuesCount ( INT visible_values_count )

Sets the number of visible values. If e. g. GetValue() returns 5 and the number of visible values is 3, the values 5, 6 and 7 are indicated as visible. It is guaranteed by the method, that the visible_values_count is valid.

The documentation for this class was generated from the following files:
  • Gui/PositionIndicator.hpp
  • Gui/PositionIndicator.cpp
Generated on Wed Jan 25 01:40:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PositionIndicatorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PositionIndicatorView Class Reference
[Components]

#include <Apoxi/Gui/PositionIndicator.hpp>

Inheritance diagram for PositionIndicatorView:

[legend]
Collaboration diagram for PositionIndicatorView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
XYDIM | GetSize () const
PositionIndicatorView (XYDIM size)
PositionIndicatorView ()
void | SetSize (XYDIM size)
virtual | ~PositionIndicatorView ()

Protected Member Functions

virtual void | DrawPositionIndicator (const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const =0

Constructor & Destructor Documentation

PositionIndicatorView::PositionIndicatorView ( )

PositionIndicatorView::PositionIndicatorView ( XYDIM size )

PositionIndicatorView::~PositionIndicatorView ( ) [virtual]

Member Function Documentation

void PositionIndicatorView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

virtual void PositionIndicatorView::DrawPositionIndicator | ( | const PositionIndicator & | pos_ind,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Draws the data of a position indicator described by the model. Must be implemented in the corresponding theme view.

Parameters:
pos_ind | Position-Indicator which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implemented in BlueSkyPositionIndicatorView, DefaultPositionIndicatorView, TestPositionIndicatorView, CTPositionIndicatorView, DefaultPositionIndicatorView, and FoggyPositionIndicatorView.

XYDIM PositionIndicatorView::GetSize ( ) const [inline]

void PositionIndicatorView::SetSize ( XYDIM size ) [inline]

The documentation for this class was generated from the following files:
  • Gui/PositionIndicator.hpp
  • Gui/PositionIndicator.cpp
Generated on Wed Jan 25 01:40:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/PowerDispatcher.hpp>

Inheritance diagram for PowerDispatcher:

[legend]
Collaboration diagram for PowerDispatcher:

[legend]

Public Member Functions

PowerDispatcher ()
Default constructor.
virtual | ~PowerDispatcher ()

Protected Member Functions

BOOLEAN | OnOmControlInd (const StackMsgArgument &arg)

Constructor & Destructor Documentation

PowerDispatcher::PowerDispatcher ( )

Default constructor.

PowerDispatcher::~PowerDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN PowerDispatcher::OnOmControlInd ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/PowerDispatcher.hpp
  • Asc/PowerDispatcher.cpp
Generated on Wed Jan 25 01:40:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerDownCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerDownCnfArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for PowerDownCnfArg:

[legend]
Collaboration diagram for PowerDownCnfArg:

[legend]

Public Types

enum | { ID = 1240 }

Public Member Functions

PowerDownCnfArg ()

Static Public Member Functions

static const PowerDownCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PowerDownCnfArg: reflects arguments of signal MN_POWER_DOWN_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PowerDownCnfArg::PowerDownCnfArg ( )

Member Function Documentation

const PowerDownCnfArg & PowerDownCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 01:40:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerDownDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerDownDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/PowerDownDispatcher.hpp>

Inheritance diagram for PowerDownDispatcher:

[legend]
Collaboration diagram for PowerDownDispatcher:

[legend]

Public Member Functions

PowerDownDispatcher ()
virtual | ~PowerDownDispatcher ()

Protected Member Functions

BOOLEAN | OnPowerDownCnf (const StackMsgArgument &arg)

Constructor & Destructor Documentation

PowerDownDispatcher::PowerDownDispatcher ( )

PowerDownDispatcher::~PowerDownDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN PowerDownDispatcher::OnPowerDownCnf ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/PowerDownDispatcher.hpp
  • Asc/PowerDownDispatcher.cpp
Generated on Wed Jan 25 01:40:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerDownIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerDownIndArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for PowerDownIndArg:

[legend]
Collaboration diagram for PowerDownIndArg:

[legend]

Public Types

enum | { ID = 5240 }

Public Member Functions

PowerDownIndArg ()

Static Public Member Functions

static const PowerDownIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PowerDownIndArg: reflects arguments of signal MN_POWER_DOWN_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PowerDownIndArg::PowerDownIndArg ( )

Member Function Documentation

const PowerDownIndArg & PowerDownIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 01:40:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerDownReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerDownReqArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for PowerDownReqArg:

[legend]
Collaboration diagram for PowerDownReqArg:

[legend]

Public Types

enum | { ID = 2241 }

Public Member Functions

PowerDownReqArg ()

Static Public Member Functions

static const PowerDownReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PowerDownReqArg: reflects arguments of signal MN_POWER_DOWN_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PowerDownReqArg::PowerDownReqArg ( )

Member Function Documentation

const PowerDownReqArg & PowerDownReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 01:40:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/PowerHandler.hpp>

Collaboration diagram for PowerHandler:

[legend]

Public Types

enum | { ID = PowerHandlerId }
typedef BaseHandler | Base

Public Member Functions

virtual HandlerId | GetHandlerId () const
returns the id of the handler.
PowerHandler ()
virtual | ~PowerHandler ()

Static Public Member Functions

static BOOLEAN | IsMobileNetworkStarted ()
static void | PowerDown ()
static void | PowerUp (const ProcessPtr process_ptr=GetApoxiProcessPtr())
static void | StartAirplaneMode (const ProcessPtr process_ptr=GetApoxiProcessPtr())
static void | StartMobileNetwork (const ProcessPtr process_ptr=GetApoxiProcessPtr())
static void | StartSilentReset ()
static void | StopMobileNetwork ()

Friends

class | ShutDown

Detailed Description

The PowerHandler provides an interface for the application to start up and terminate the protocolstack.

Member Typedef Documentation

typedef BaseHandler PowerHandler::Base

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PowerHandler::PowerHandler ( )

PowerHandler::~PowerHandler ( ) [virtual]

Member Function Documentation

virtual HandlerId PowerHandler::GetHandlerId ( ) const [inline, virtual]

returns the id of the handler.

static BOOLEAN PowerHandler::IsMobileNetworkStarted ( ) [inline, static]

Returns:
Status if MN has been started.

void PowerHandler::PowerDown ( ) [static]

The function PowerDown() performs the powering down of the whole system.

void PowerHandler::PowerUp ( const ProcessPtr process_ptr = GetApoxiProcessPtr() ) [static]

This method has simply the same functionality as PowerUp(), but is not dependent on any initialization, so is can be called on the very early startup.

void PowerHandler::StartAirplaneMode ( const ProcessPtr process_ptr = GetApoxiProcessPtr() ) [static]

The function StartAirplaneMode() performs the silent reset of the system.

void PowerHandler::StartMobileNetwork ( const ProcessPtr process_ptr = GetApoxiProcessPtr() ) [static]

This method has simply the same functionality as StartMobileNetwork(), but is not dependent on any initialization, so is can be called on the very early startup.

void PowerHandler::StartSilentReset ( ) [static]

The function StartSilentReset() performs the silent reset of the system.

void PowerHandler::StopMobileNetwork ( ) [static]

The function StopMobileNetwork() stop the mobile network functionality, inclusive the monitors for the signal-strength.

Friends And Related Function Documentation

friend class ShutDown [friend]

The documentation for this class was generated from the following files:
  • Asc/PowerHandler.hpp
  • Asc/PowerHandler.cpp
Generated on Wed Jan 25 01:40:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerModeIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerModeIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for PowerModeIndMsg:

[legend]
Collaboration diagram for PowerModeIndMsg:

[legend]

Public Types

enum | { ID = 18390 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const PowerMode & | GetPowerMode () const
PowerModeIndMsg (ExecutionContext *context, const PowerMode &power_mode)
void | SetPowerMode (const PowerMode &power_mode)
virtual | ~PowerModeIndMsg ()

Detailed Description

PowerModeIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PowerModeIndMsg::PowerModeIndMsg | ( | ExecutionContext * | context,
 |  | const PowerMode & | power_mode
 | ) |

PowerModeIndMsg::~PowerModeIndMsg ( ) [virtual]

Member Function Documentation

Message * PowerModeIndMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PowerModeIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PowerMode& PowerModeIndMsg::GetPowerMode ( ) const [inline]

void PowerModeIndMsg::SetPowerMode ( const PowerMode & power_mode ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:40:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerOffMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerOffMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for PowerOffMsg:

[legend]
Collaboration diagram for PowerOffMsg:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
PowerOffMsg ()
virtual | ~PowerOffMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PowerOffMsg::PowerOffMsg ( )

PowerOffMsg::~PowerOffMsg ( ) [virtual]

Member Function Documentation

Message * PowerOffMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PowerOffMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:40:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerOnMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerOnMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for PowerOnMsg:

[legend]
Collaboration diagram for PowerOnMsg:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
PowerOnMsg ()
virtual | ~PowerOnMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PowerOnMsg::PowerOnMsg ( )

PowerOnMsg::~PowerOnMsg ( ) [virtual]

Member Function Documentation

Message * PowerOnMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PowerOnMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:40:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PowerWakeupMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PowerWakeupMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for PowerWakeupMsg:

[legend]
Collaboration diagram for PowerWakeupMsg:

[legend]

Public Types

enum | { ID = 130 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
PowerWakeupMsg ()
virtual | ~PowerWakeupMsg ()

Detailed Description

PowerWakeupMsg Is sent every time, when CPU awakes from power saving.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PowerWakeupMsg::PowerWakeupMsg ( )

PowerWakeupMsg::~PowerWakeupMsg ( ) [virtual]

Member Function Documentation

Message * PowerWakeupMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PowerWakeupMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:40:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PppCallBackData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PppCallBackData Struct Reference
[Socket]

Types needed for lwIP PPP connections. More...

#include <Apoxi/Socket/Sys/SysSocketBase.hpp>

Inheritance diagram for PppCallBackData:

[legend]

Detailed Description

Types needed for lwIP PPP connections.

The documentation for this struct was generated from the following file:
  • Socket/Sys/SysSocketBase.hpp
Generated on Wed Jan 25 01:40:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PppDataConn Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PppDataConn Class Reference
[Socket]

#include <Apoxi/Socket/PppDataConn.hpp>

Inheritance diagram for PppDataConn:

[legend]
Collaboration diagram for PppDataConn:

[legend]

Protected Member Functions

virtual BOOLEAN | CancelSetup ()
virtual void | Cleanup ()
virtual void | DoRelease ()
virtual void | DoSetup ()
void | DoStartPppRelease ()
void | DoStartPppSetup ()
virtual BOOLEAN | GetIpAddress (IpAddr &addr) const
virtual void | OnAfterPppRelease ()
virtual void | OnBeforePppSetup ()
void | OnPppSetup (INT error, const PppSetupCallBackData *data)
void | OnPppStop (INT error)
PppDataConn (const DataConnProfilePtr &profile)
void | ReleasePPP ()
virtual | ~PppDataConn ()

Constructor & Destructor Documentation

PppDataConn::PppDataConn ( const DataConnProfilePtr & profile ) [protected]

Creates a PPP data connection which uses profile on setup. The given profile smart pointer must be valid, otherwise an assertion holds.

PppDataConn::~PppDataConn ( ) [protected, virtual]

Member Function Documentation

BOOLEAN PppDataConn::CancelSetup ( ) [protected, virtual]

This method is called when a data connection shall be canceled during the setup phase. Derived classes can override this method to immediately stop the setup process. This is especially needed if the setup process might take a long time. If this method is not overridden then the data connection continues the setup process completely but then immediately shuts it down again since a cancel request was issued during the setup process.

Returns:
Tells if the cancellation was done.

Reimplemented from DataConn.

void PppDataConn::Cleanup ( ) [protected, virtual]

Cleans up the internals to virginal state.

Reimplemented from DataConn.

Reimplemented in CsdDataConn.

virtual void PppDataConn::DoRelease ( ) [inline, protected, virtual]

Asynchronous data connection release request.

Implements DataConn.

virtual void PppDataConn::DoSetup ( ) [inline, protected, virtual]

Asynchronous data connection setup request.

Implements DataConn.

void PppDataConn::DoStartPppRelease ( ) [protected]

Starts the PPP release process. On successful start the release process proceeds, otherwise the base state machine receives the external event that the setup failed.

void PppDataConn::DoStartPppSetup ( ) [protected]

Starts the PPP setup process. On successful start the setup process proceeds, otherwise the base state machine receives the external event that the setup failed.

BOOLEAN PppDataConn::GetIpAddress ( IpAddr & addr ) const [protected, virtual]

Retrieves the IP address that is currently assigned to this PPP data connection. If the PPP connection is currently not up and running and hence no address can be retrieved then FALSE will be returned.

Implements DataConn.

virtual void PppDataConn::OnAfterPppRelease ( ) [inline, protected, virtual]

Give derived class the chance to do something after PPP has been released (regardless of setup success or failure). The override must finally call ReleasedEvent(), otherwise we end up in a deadlock.

Reimplemented in CsdDataConn.

virtual void PppDataConn::OnBeforePppSetup ( ) [inline, protected, virtual]

Give derived class the chance to do something before PPP setup starts. If the override succeeds with its task, then it must finally call DoStartPppSetup(); if the override fails with its task, then it has to call SetupFailedEvent(). If neither is called, we end up in a deadlock.

Reimplemented in CsdDataConn.

void PppDataConn::OnPppSetup | ( | INT | error,
 |  | const PppSetupCallBackData * | data
 | ) | [protected]

Method called by PppSetupCallbackHandler() to react when the PPP setup process is finished. Depending on the success of the PPP setup, the base state machine receives the respective external event.

void PppDataConn::OnPppStop ( INT error ) [protected]

Method called by PppStopCallbackHandler() to react when the PPP connection is stopped.

void PppDataConn::ReleasePPP ( ) [protected]

The documentation for this class was generated from the following files:
  • Socket/PppDataConn.hpp
  • Socket/PppDataConn.cpp
Generated on Wed Jan 25 01:40:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PppFrame Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PppFrame Class Reference

#include <Apoxi/Asc/PppFrame.hpp>

Inheritance diagram for PppFrame:

[legend]
Collaboration diagram for PppFrame:

[legend]

Public Member Functions

operator T_AUTH_PPP_FRAME () const
Conversion operator to T_AUTH_PPP_FRAME.
PppFrame & operator= (const T_AUTH_PPP_FRAME &auth_ppp_frame)
Assigns a new value to the PppFrame object.
PppFrame (const T_AUTH_PPP_FRAME *ppp_frame)
PppFrame (const T_AUTH_PPP_FRAME &ppp_frame)
PppFrame ()
Creates an empty PppFrame object.

Constructor & Destructor Documentation

PppFrame::PppFrame ( ) [inline]

Creates an empty PppFrame object.

PppFrame::PppFrame ( const T_AUTH_PPP_FRAME & ppp_frame ) [inline]

PppFrame::PppFrame ( const T_AUTH_PPP_FRAME * ppp_frame ) [inline]

Member Function Documentation

PppFrame::operator T_AUTH_PPP_FRAME ( ) const

Conversion operator to T_AUTH_PPP_FRAME.

PppFrame & PppFrame::operator= ( const T_AUTH_PPP_FRAME & auth_ppp_frame )

Assigns a new value to the PppFrame object.

The documentation for this class was generated from the following files:
  • Asc/PppFrame.hpp
  • Asc/PppFrame.cpp
Generated on Wed Jan 25 01:40:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PppSetupCallBackData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PppSetupCallBackData Struct Reference
[Socket]

#include <Apoxi/Socket/Sys/SysSocketBase.hpp>

Inheritance diagram for PppSetupCallBackData:

[legend]
Collaboration diagram for PppSetupCallBackData:

[legend]

Public Member Functions

void Reset ()

Data Fields

IpAddr m_interface_address
IpAddr m_primary_dns_server_address
IpAddr m_secondary_dns_server_address

Member Function Documentation

void PppSetupCallBackData::Reset ( void ) [inline]

Field Documentation

IpAddr PppSetupCallBackData::m_interface_address

IpAddr PppSetupCallBackData::m_primary_dns_server_address

IpAddr PppSetupCallBackData::m_secondary_dns_server_address

The documentation for this struct was generated from the following file:
  • Socket/Sys/SysSocketBase.hpp
Generated on Wed Jan 25 01:40:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PredefinedEmsImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PredefinedEmsImage Class Reference
[EMS]

#include <Applications/Ems/PredefinedEmsImage.hpp>

Inheritance diagram for PredefinedEmsImage:

[legend]
Collaboration diagram for PredefinedEmsImage:

[legend]

Public Types

enum | { ID = 4 }

Public Member Functions

virtual INT | GetId () const
InformationElement::PredefinedAnimationType | GetPredefinedType () const
PredefinedEmsImage (InformationElement::PredefinedAnimationType type)
virtual | ~PredefinedEmsImage ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from NativeImage.

Constructor & Destructor Documentation

PredefinedEmsImage::PredefinedEmsImage ( InformationElement::PredefinedAnimationType type ) [explicit]

PredefinedEmsImage::~PredefinedEmsImage ( ) [virtual]

Member Function Documentation

INT PredefinedEmsImage::GetId ( ) const [virtual]

InformationElement::PredefinedAnimationType PredefinedEmsImage::GetPredefinedType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Applications/Ems/PredefinedEmsImage.hpp
  • Applications/Ems/PredefinedEmsImage.cpp
Generated on Wed Jan 25 01:40:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PredefinedEmsSound Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PredefinedEmsSound Class Reference
[EMS]

#include <Applications/Ems/PredefinedEmsSound.hpp>

Inheritance diagram for PredefinedEmsSound:

[legend]
Collaboration diagram for PredefinedEmsSound:

[legend]

Public Types

enum | { ID = 4 }
The id for a predefined ems sound. More...

Public Member Functions

virtual INT | GetId () const
InformationElement::PredefinedSoundType | GetPredefinedType () const
PredefinedEmsSound (InformationElement::PredefinedSoundType type)
virtual | ~PredefinedEmsSound ()

Member Enumeration Documentation

anonymous enum

The id for a predefined ems sound.

Enumerator:
ID

Reimplemented from PreparedSound.

Constructor & Destructor Documentation

PredefinedEmsSound::PredefinedEmsSound ( InformationElement::PredefinedSoundType type ) [explicit]

PredefinedEmsSound::~PredefinedEmsSound ( ) [virtual]

Member Function Documentation

INT PredefinedEmsSound::GetId ( ) const [virtual]

See also:
Sound::GetId

Reimplemented from PreparedSound.

InformationElement::PredefinedSoundType PredefinedEmsSound::GetPredefinedType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Applications/Ems/PredefinedEmsSound.hpp
  • Applications/Ems/PredefinedEmsSound.cpp
Generated on Wed Jan 25 01:40:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PredInputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PredInputMapper Class Reference
[Editors]

Abstract base class for predictive input-mappers. More...

#include <Apoxi/Gui/PredInputMapper.hpp>

Inheritance diagram for PredInputMapper:

[legend]
Collaboration diagram for PredInputMapper:

[legend]

Public Types

enum PredMode {
PredEnglish, PredMultiTap, PredPinyin, PredSimplifiedChineseStroke,
PredTraditionalChineseStroke, PredBpmf, PredNone, PredSymbol,
PredArabic, PredThai, PredThaiMatrix, PredHebrew
}
Predictive Input methods. More...
enum | Type { T9, Zi8 }

Public Member Functions

virtual PredMode | GetMode () const =0
Discover the current input method.
virtual const WCHAR * | GetPhonetics (INT *selected_idx=0) const =0
virtual INT | GetSelectedIndex () const =0
virtual const WCHAR * | GetSelection () const =0
virtual const WCHAR * | GetStatusInfo () const =0
A human-readable name for the current input method.
virtual const WCHAR * | GetStrokes () const =0
virtual Type | GetType () const =0
virtual BOOLEAN | IsModeSupported (PredMode mode)=0
Can be used to test supported modes and languages.
PredInputMapper (AbstractEditor *editor=0)
virtual BOOLEAN | SetMode (PredMode mode)=0
Set the current input method.
virtual | ~PredInputMapper ()

Protected Member Functions

virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Protected Attributes

BOOLEAN | m_number_input_mode

Detailed Description

Abstract base class for predictive input-mappers.

Member Enumeration Documentation

enum PredInputMapper::PredMode

Predictive Input methods.

Enumerator:
PredEnglish
PredMultiTap | e.g. 3 taps to get C from a key marked ABC.
PredPinyin | Simplified Chinese Phonetic.
PredSimplifiedChineseStroke
PredTraditionalChineseStroke
PredBpmf | Traditional Chinese Phonetic.
PredNone
PredSymbol
PredArabic
PredThai
PredThaiMatrix
PredHebrew

enum PredInputMapper::Type

Enumerator:
T9 | Uses the predictive input method T9.
Zi8 | Uses the predictive input eZi text.

Constructor & Destructor Documentation

PredInputMapper::PredInputMapper ( AbstractEditor * editor = 0 ) [explicit]

PredInputMapper::~PredInputMapper ( ) [virtual]

Member Function Documentation

virtual PredMode PredInputMapper::GetMode ( ) const [pure virtual]

Discover the current input method.

Implemented in ChineseT9InputMapper, EnglishT9InputMapper, T9InputMapper, and Zi8InputMapper.

virtual const WCHAR* PredInputMapper::GetPhonetics ( INT * selected_idx = 0 ) const [pure virtual]

Implemented in ChineseT9InputMapper, T9InputMapper, and Zi8InputMapper.

virtual INT PredInputMapper::GetSelectedIndex ( ) const [pure virtual]

Implemented in ChineseT9InputMapper, T9InputMapper, and Zi8InputMapper.

virtual const WCHAR* PredInputMapper::GetSelection ( ) const [pure virtual]

Implemented in ChineseT9InputMapper, T9InputMapper, and Zi8InputMapper.

virtual const WCHAR* PredInputMapper::GetStatusInfo ( ) const [pure virtual]

A human-readable name for the current input method.

Implemented in ChineseT9InputMapper, EnglishT9InputMapper, T9InputMapper, and Zi8InputMapper.

virtual const WCHAR* PredInputMapper::GetStrokes ( ) const [pure virtual]

Implemented in ChineseT9InputMapper, T9InputMapper, and Zi8InputMapper.

virtual Type PredInputMapper::GetType ( ) const [pure virtual]

Implemented in T9InputMapper, and Zi8InputMapper.

virtual BOOLEAN PredInputMapper::IsModeSupported ( PredMode mode ) [pure virtual]

Can be used to test supported modes and languages.

BOOLEAN PredInputMapper::OnKeyDown ( KeyCode key_code ) [protected, virtual]

Is invoked by the editor when a key has been pressed.

Reimplemented from InputMapper.

virtual BOOLEAN PredInputMapper::SetMode ( PredMode mode ) [pure virtual]

Set the current input method.

Field Documentation

BOOLEAN PredInputMapper::m_number_input_mode [protected]

The documentation for this class was generated from the following files:
  • Gui/PredInputMapper.hpp
  • Gui/PredInputMapper.cpp
Generated on Wed Jan 25 01:40:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PrefExtLangProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PrefExtLangProvider Class Reference
[Provider]

#include <Apoxi/Adc/PrefExtLangProvider.hpp>

Inheritance diagram for PrefExtLangProvider:

[legend]
Collaboration diagram for PrefExtLangProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | AppendRow ()
Append a row.
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *aux_handler, Protector *protector, INT instance_nr=0)
virtual BOOLEAN | InsertRow (INT row)
Insert a row in front of the row specified.
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
PrefExtLangProvider ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~PrefExtLangProvider ()

Detailed Description

PrefExtLangProvider is the provider to retrieve and manipulate the EF-ELP file of the sim (GSM 11.11 V8.2.0 10.1.2). An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_preflang_provider_id

In case of UMTS build a second instance is used which can be retrieved with

c_preflang2_provider_id

In case of UMTS build and USIM c_preflang_provider_id will retrieve the file EF-LI and c_preflang2_provider_id will retrieve EF-PL. In case of EDGE/GPRS and SIM only c_preflang_provider_id shall be used as it represents EF-ELP.

Following column ids are defined: c_ext_lang_pref_id :WStringType

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider PrefExtLangProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

PrefExtLangProvider::PrefExtLangProvider ( )

PrefExtLangProvider::~PrefExtLangProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PrefExtLangProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

BOOLEAN PrefExtLangProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN PrefExtLangProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from Provider.

BOOLEAN PrefExtLangProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN PrefExtLangProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT PrefExtLangProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void PrefExtLangProvider::Init | ( | SimAuxHandler * | aux_handler,
 |  | Protector * | protector,
 |  | INT | instance_nr = 0
 | ) |

BOOLEAN PrefExtLangProvider::InsertRow ( INT row ) [virtual]

Insert a row in front of the row specified.

Reimplemented from Provider.

INT PrefExtLangProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT PrefExtLangProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN PrefExtLangProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN PrefExtLangProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/PrefExtLangProvider.hpp
  • Adc/PrefExtLangProvider.cpp
Generated on Wed Jan 25 01:40:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PrefLangProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PrefLangProvider Class Reference
[Provider]

#include <Apoxi/Adc/PrefLangProvider.hpp>

Inheritance diagram for PrefLangProvider:

[legend]
Collaboration diagram for PrefLangProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | AppendRow ()
Append a row.
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *aux_handler, Protector *protector)
virtual BOOLEAN | InsertRow (INT row)
Insert a row in front of the row specified.
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
PrefLangProvider ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~PrefLangProvider ()

Detailed Description

PrefLangProvider is the provider to retrieve and manipulate the prefered languages of the sim (GSM 11.11 V8.2.0 10.3.1). An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_preflang_provider_id

Following column ids are defined: c_lang_pref_id :NumberType

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider PrefLangProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

PrefLangProvider::PrefLangProvider ( )

PrefLangProvider::~PrefLangProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PrefLangProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

BOOLEAN PrefLangProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN PrefLangProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from Provider.

BOOLEAN PrefLangProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN PrefLangProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT PrefLangProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void PrefLangProvider::Init | ( | SimAuxHandler * | aux_handler,
 |  | Protector * | protector
 | ) |

BOOLEAN PrefLangProvider::InsertRow ( INT row ) [virtual]

Insert a row in front of the row specified.

Reimplemented from Provider.

INT PrefLangProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT PrefLangProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN PrefLangProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN PrefLangProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/PrefLangProvider.hpp
  • Adc/PrefLangProvider.cpp
Generated on Wed Jan 25 01:40:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PrefPlmnChangeArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PrefPlmnChangeArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for PrefPlmnChangeArg:

[legend]
Collaboration diagram for PrefPlmnChangeArg:

[legend]

Public Types

enum | { ID = 2364 }

Public Member Functions

PrefPlmnChangeArg ()

Static Public Member Functions

static const PrefPlmnChangeArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PrefPlmnChangeArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PrefPlmnChangeArg::PrefPlmnChangeArg ( )

Member Function Documentation

const PrefPlmnChangeArg & PrefPlmnChangeArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:40:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PrefPlmnProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PrefPlmnProvider Class Reference
[Provider]

#include <Apoxi/Adc/PrefPlmnProvider.hpp>

Inheritance diagram for PrefPlmnProvider:

[legend]
Collaboration diagram for PrefPlmnProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | AppendRow ()
Append a row.
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *aux_handler, Protector *protector)
virtual BOOLEAN | InsertRow (INT row)
Insert a row in front of the row specified.
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
PrefPlmnProvider ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~PrefPlmnProvider ()

Detailed Description

PrefPlmnProvider is the provider to retrieve and manipulate the prefered plmns of the sim (GSM 11.11 V8.2.0 10.3.4). An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_prefplmn_provider_id

Following column ids are defined: c_mcc_id :NumberType: mobile country code c_mnc_id :NumberType: mobile network code c_access_technology_id NumberType: returns access technology. c_act_supported_id NumberType: returns a BOOLEAN value if access technology is supported.

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider PrefPlmnProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

PrefPlmnProvider::PrefPlmnProvider ( )

PrefPlmnProvider::~PrefPlmnProvider ( ) [virtual]

Member Function Documentation

BOOLEAN PrefPlmnProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

BOOLEAN PrefPlmnProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN PrefPlmnProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from Provider.

BOOLEAN PrefPlmnProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN PrefPlmnProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT PrefPlmnProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void PrefPlmnProvider::Init | ( | SimAuxHandler * | aux_handler,
 |  | Protector * | protector
 | ) |

BOOLEAN PrefPlmnProvider::InsertRow ( INT row ) [virtual]

Insert a row in front of the row specified.

Reimplemented from Provider.

INT PrefPlmnProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT PrefPlmnProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN PrefPlmnProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN PrefPlmnProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN PrefPlmnProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/PrefPlmnProvider.hpp
  • Adc/PrefPlmnProvider.cpp
Generated on Wed Jan 25 01:40:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PrefServiceSetReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PrefServiceSetReqArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for PrefServiceSetReqArg:

[legend]
Collaboration diagram for PrefServiceSetReqArg:

[legend]

Public Types

enum | { ID = 2366 }

Public Member Functions

const GsmService & | GetGsmService () const
PrefServiceSetReqArg ()
PrefServiceSetReqArg (const GsmService &gsm_service)

Static Public Member Functions

static const PrefServiceSetReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

PrefServiceSetReqArg: reflects arguments of signal MN_PREF_SERVICE_SET_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PrefServiceSetReqArg::PrefServiceSetReqArg ( const GsmService & gsm_service )

PrefServiceSetReqArg::PrefServiceSetReqArg ( )

Member Function Documentation

const PrefServiceSetReqArg & PrefServiceSetReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GsmService& PrefServiceSetReqArg::GetGsmService ( ) const [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:40:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PreparedSound Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PreparedSound Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/PreparedSound.hpp>

Inheritance diagram for PreparedSound:

[legend]
Collaboration diagram for PreparedSound:

[legend]

Public Types

enum | { ID = 1 }
The id for a predefined sound. More...

Public Member Functions

virtual INT | GetId () const
virtual const WCHAR * | GetName () const
INT | GetRepeatCount () const
Returns the nubmer of repeats.
Audio::AudioToneId | GetToneId () const
Returns the id of the predefined sound.
void | Init (const WCHAR *name)
virtual BOOLEAN | Play (AudioContext *context)
PreparedSound (const WCHAR *name)
PreparedSound ()
void | SetName (const WCHAR *name)
void | SetRepeatCount (INT times)
Set how many times the sound should be played.
void | SetToneId (Audio::AudioToneId tone_id)
Set the id of the predefined sound.
virtual | ~PreparedSound ()

Detailed Description

Obsolete - all sound classes from AddOns/MultiMedia have been replaced by a new audio concept. Use the AudioDeviceManager instead for playing sounds.

Member Enumeration Documentation

anonymous enum

The id for a predefined sound.

Enumerator:
ID

Constructor & Destructor Documentation

PreparedSound::PreparedSound ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

PreparedSound::PreparedSound ( const WCHAR * name )

Parameters:
name Name of the sound. The text ist not buffered by the object.

PreparedSound::~PreparedSound ( ) [virtual]

Member Function Documentation

INT PreparedSound::GetId ( ) const [virtual]

See also:
Sound::GetId

Implements Sound.

Reimplemented in PredefinedEmsSound.

const WCHAR * PreparedSound::GetName ( ) const [virtual]

See also:
Sound::GetName

Implements Sound.

INT PreparedSound::GetRepeatCount ( ) const [inline]

Returns the nubmer of repeats.

Audio::AudioToneId PreparedSound::GetToneId ( ) const [inline]

Returns the id of the predefined sound.

void PreparedSound::Init ( const WCHAR * name )

Parameters:
name Name of the sound. The text ist not buffered by the object.

BOOLEAN PreparedSound::Play ( AudioContext * context ) [virtual]

See also:
Sound::Play

Implements Sound.

void PreparedSound::SetName ( const WCHAR * name ) [inline]

Sets the name the sound. The text is not buffered by the object.

void PreparedSound::SetRepeatCount ( INT times ) [inline]

Set how many times the sound should be played.

void PreparedSound::SetToneId ( Audio::AudioToneId tone_id ) [inline]

Set the id of the predefined sound.

The documentation for this class was generated from the following files:
  • Compat/PreparedSound.hpp
  • Compat/PreparedSound.cpp
Generated on Wed Jan 25 01:41:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PresetAudioReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PresetAudioReference Class Reference
[Audio]

#include <Apoxi/Audio/PresetAudioReference.hpp>

Inheritance diagram for PresetAudioReference:

[legend]
Collaboration diagram for PresetAudioReference:

[legend]

Public Types

typedef UINT | ToneID

Public Member Functions

virtual enumClassType | GetClassType () const
WString | GetPresetName () const
ToneID | GetToneID () const
void | SetToneID (ToneID val)
virtual | ~PresetAudioReference ()

Protected Member Functions

PresetAudioReference (ToneID tone_id)

Protected Attributes

ToneID m_tone_id

Detailed Description

A reference to a preset sound rather than a Custom sound. See AudioPresetStore.

Member Typedef Documentation

typedef UINT PresetAudioReference::ToneID

Constructor & Destructor Documentation

PresetAudioReference::~PresetAudioReference ( ) [virtual]

PresetAudioReference::PresetAudioReference ( ToneID tone_id ) [protected]

Member Function Documentation

AudioReference::enumClassType PresetAudioReference::GetClassType ( ) const [virtual]

Implements AudioReference.

WString PresetAudioReference::GetPresetName ( ) const

Gets the name from the PresetStore. This is just a shortcut.

PresetAudioReference::ToneID PresetAudioReference::GetToneID ( ) const

void PresetAudioReference::SetToneID ( ToneID val )

Field Documentation

ToneID PresetAudioReference::m_tone_id [protected]

The documentation for this class was generated from the following files:
  • Audio/PresetAudioReference.hpp
  • Audio/PresetAudioReference.cpp
Generated on Wed Jan 25 01:41:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProactiveCauseMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProactiveCauseMapper Class Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Static Public Member Functions

static T_MI_PROACTIVE_CAUSE | ToSdl (ProactiveCause pc, BOOLEAN return_default=TRUE)
static T_MI_PROACTIVE_CAUSE | ToSdlExt (ProactiveCause pc, SdlByte &general_result, SdlByte &additional_result)

Member Function Documentation

T_MI_PROACTIVE_CAUSE ProactiveCauseMapper::ToSdl | ( | ProactiveCause | pc,
 |  | BOOLEAN | return_default = TRUE
 | ) | [static]

T_MI_PROACTIVE_CAUSE ProactiveCauseMapper::ToSdlExt | ( | ProactiveCause | pc,
 |  | SdlByte & | general_result,
 |  | SdlByte & | additional_result
 | ) | [static]

The documentation for this class was generated from the following files:
  • Apc/SimTkTypes.hpp
  • Apc/SimTkTypes.cpp
Generated on Wed Jan 25 01:41:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProcessMolrMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProcessMolrMsg Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>

Inheritance diagram for ProcessMolrMsg:

[legend]
Collaboration diagram for ProcessMolrMsg:

[legend]

Public Types

enum | { ID = 4210 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
MolrInfo * | GetMolrInfo () const
ProcessMolrMsg (MolrInfo *molr_info)
virtual | ~ProcessMolrMsg ()

Detailed Description

This message is sent to trigger MO-LR processing by the appropriate provider implementation

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ProcessMolrMsg::ProcessMolrMsg ( MolrInfo * molr_info )

ProcessMolrMsg::~ProcessMolrMsg ( ) [virtual]

Member Function Documentation

Message * ProcessMolrMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ProcessMolrMsg::GetMetaData ( ) const [virtual]

Implements Message.

MolrInfo* ProcessMolrMsg::GetMolrInfo ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonMsgTypes.hpp
  • AddOns/Lcs/Common/LcsCommonMsgTypes.cpp
Generated on Wed Jan 25 01:41:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProcessNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProcessNode Class Reference
[APC]

ProcessNode maintains the global SDL process pointer. More...

#include <Apoxi/Apc/SignalHandler/ProcessNode.hpp>

Inheritance diagram for ProcessNode:

[legend]
Collaboration diagram for ProcessNode:

[legend]

Public Member Functions

ProcessPtr | GetProcessPtr () const
SdlSignalId | GetSignalId () const
SdlSignalName | GetSignalName () const
void | Init (const ProcessPtr process_ptr)
BOOLEAN | IsEqualSignal (const SignalMapTableEntry &signal) const
ProcessNode (const ProcessPtr process_ptr=0)
void | Refresh (const ProcessPtr process_ptr)
virtual | ~ProcessNode ()

Static Public Member Functions

static BOOLEAN | IsSignalNameAvailable ()

Detailed Description

ProcessNode maintains the global SDL process pointer.

Constructor & Destructor Documentation

ProcessNode::ProcessNode ( const ProcessPtr process_ptr = 0 )

ProcessNode::~ProcessNode ( ) [virtual]

Member Function Documentation

ProcessPtr ProcessNode::GetProcessPtr ( ) const [inline]

SdlSignalId ProcessNode::GetSignalId ( ) const

SdlSignalName ProcessNode::GetSignalName ( ) const

void ProcessNode::Init ( const ProcessPtr process_ptr )

BOOLEAN ProcessNode::IsEqualSignal ( const SignalMapTableEntry & signal ) const

BOOLEAN ProcessNode::IsSignalNameAvailable ( ) [static]

void ProcessNode::Refresh ( const ProcessPtr process_ptr )

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/ProcessNode.hpp
  • Apc/SignalHandler/ProcessNode.cpp
Generated on Wed Jan 25 01:41:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProgressBar Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProgressBar Class Reference
[Components]

#include <Apoxi/Gui/ProgressBar.hpp>

Inheritance diagram for ProgressBar:

[legend]
Collaboration diagram for ProgressBar:

[legend]

Public Types

enum | { ID = 19 }
typedef DrawableObject | Base

Public Member Functions

INT | GetProgress () const
void | Init (Control *control, INT progress=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
ProgressBar (Control *control, INT progress=0)
ProgressBar ()
void | SetProgress (INT progress)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~ProgressBar ()

Protected Member Functions

virtual void | OnThemeChanged ()

Detailed Description

Indicates the progress of an operation.

Member Typedef Documentation

typedef DrawableObject ProgressBar::Base

Reimplemented from DrawableObject.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

ProgressBar::ProgressBar ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ProgressBar::ProgressBar | ( | Control * | control,
 |  | INT | progress = 0
 | ) |

Parameters:
win | Pointer to the window containing the progress bar.
progress | Progress in percentage (0 - 100)

ProgressBar::~ProgressBar ( ) [virtual]

Member Function Documentation

INT ProgressBar::GetProgress ( ) const [inline]

Returns:
Progress in percentage (0 - 100).

void ProgressBar::Init | ( | Control * | control,
 |  | INT | progress = 0
 | ) |

Parameters:
win | Pointer to the window containing the progress bar.
progress | Progress in percentage (0 - 100)

BOOLEAN ProgressBar::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from DrawableObject.

void ProgressBar::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged()

Reimplemented from DrawableObject.

void ProgressBar::SetProgress ( INT progress )

Parameters:
progress Progress in percentage (0 - 100).

BOOLEAN ProgressBar::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from DrawableObject.

The documentation for this class was generated from the following files:
  • Gui/ProgressBar.hpp
  • Gui/ProgressBar.cpp
Generated on Wed Jan 25 01:41:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProgressBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProgressBarView Class Reference
[Components]

#include <Apoxi/Gui/ProgressBar.hpp>

Inheritance diagram for ProgressBarView:

[legend]
Collaboration diagram for ProgressBarView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
ProgressBarView (XYDIM default_height)
ProgressBarView ()
virtual | ~ProgressBarView ()

Protected Member Functions

virtual void | DrawProgressBar (const ProgressBar &progress_bar, DeviceContext *dc, const Rect &repaint_rect) const =0

Constructor & Destructor Documentation

ProgressBarView::ProgressBarView ( )

ProgressBarView::ProgressBarView ( XYDIM default_height )

ProgressBarView::~ProgressBarView ( ) [virtual]

Member Function Documentation

void ProgressBarView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

virtual void ProgressBarView::DrawProgressBar | ( | const ProgressBar & | progress_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Implemented in BlueSkyProgressBarView, DefaultProgressBarView, CTProgressBarView, and DefaultProgressBarView.

The documentation for this class was generated from the following files:
  • Gui/ProgressBar.hpp
  • Gui/ProgressBar.cpp
Generated on Wed Jan 25 01:41:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Property Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Property Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Properties/Property.hpp>

Inheritance diagram for Property:

[legend]
Collaboration diagram for Property:

[legend]

Public Types

enum | { ID = 4 }
enum Notification {
NotifyNever = 0, NotifyValidateSet = 1, NotifyPreviewChanged = 2, NotifySet = 4,
NotifyCanceled = 8
}
enum | PropertyAttributeId { ValueAttributeId = 2 }

Public Member Functions

virtual void | GetAsWString (WString &text) const
BOOLEAN | GetBoolean () const
Returns the a boolean value of the object.
const DataItem & | GetDataItem () const
BOOLEAN | GetDate (Date &date) const
Returns the date of the object.
Date | GetDate () const
Returns the date of theobject.
BOOLEAN | GetDateTime (DateTime &date) const
Returns the date and time of the object.
DateTime | GetDateTime () const
Returns the date and time of theobject.
const PropertyDescriptor * | GetDefaultDescriptor () const
GenericObject * | GetGenericObject () const
Returns a copy of the generic object.
const GenericObject * | GetGenericObjectPtr () const
Returns the pointer of the generic object.
Number | GetNumber () const
Returns the a numeric value of the object.
BOOLEAN | GetPhoneNumber (PhoneNumber &bcdnr) const
Returns the phonenumber of the object.
PhoneNumber | GetPhoneNumber () const
Returns the phonenumber of the object.
BOOLEAN | GetString (String &strdata) const
Returns the string of the object.
String | GetString () const
Returns the string of the object.
BOOLEAN | GetTime (Time &time) const
Returns the time of the object.
Time | GetTime () const
Returns the time of the object.
BOOLEAN | GetWString (WString &strdata) const
Returns the unicode string of the object.
WString | GetWString () const
Returns the unicode string of the object.
BOOLEAN | HasNotification (const Notification rule) const
void | Init (AtlApplication *app, const FeatureID &id, const UINT8 notification_rule, const DataItem &value, BOOLEAN available, BOOLEAN enabled)
void | Init (AtlApplication *app, const FeatureID &id, const DataItem &value, BOOLEAN available, BOOLEAN enabled)
void | Init (AtlApplication *app, const FeatureID &id, const UINT8 notification_rule, const DataItem &value)
void | Init (AtlApplication *app, const FeatureID &id, const UINT8 notification_rule)
void | Init (AtlApplication *app, const FeatureID &id)
void | Init (AtlApplication *app, const FeatureID &id, const DataItem &value)
virtual BOOLEAN | IsInstanceOf (INT id) const
Property (AtlApplication *app, const FeatureID &id, const UINT8 notification_rule, const DataItem &value)
Property (AtlApplication *app, const FeatureID &id, const DataItem &value)
Property (AtlApplication *app, const FeatureID &id)
Property ()
void | SetBoolean (const BOOLEAN data)
Set the object with a Boolean value.
void | SetDataItem (const DataItem &value)
void | SetDate (const Date &date)
Fills the object with a date object.
void | SetDateTime (const DateTime::Persist &date)
Fills the object with a datetime object.
void | SetDateTime (const DateTime &date)
Fills the object with a datetime object.
void | SetDefaultDescriptor (PropertyDescriptor *descriptor)
void | SetGenericObject (const GenericObject *const genobject)
Fills the object with a generic object.
void | SetNumber (const Number data)
Set the object with a numeric value.
void | SetPhoneNumber (const PhoneNumber &bcdnr)
Fills the object with a phonenumber object.
void | SetProvider (Provider *provider)
Set the object with a pointer to a provider.
void | SetString (const CHAR *strdata)
Fills the object with a string.
void | SetString (const String &strdata)
Fills the object with a string.
void | SetTime (const Time &time)
Fills the object with a time object.
void | SetWString (const WCHAR *strdata)
Fills the object with a unicode string.
void | SetWString (const WString &strdata)
Fills the object with a unicode string.
virtual | ~Property ()

Protected Attributes

PropertyDescriptor * m_descriptor
UINT8 | m_notification_rule
DataItem m_value

Detailed Description

Special feature representing a settings value maintained by an application. If the value is changed by a Property Editor, the notification rule of the property specifies, when the application is notified. A Property Descriptor specifies how to present the property value.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Feature.

enum Property::Notification

Enumerator:
NotifyNever | Never notify the application of a change.
NotifyValidateSet | Notify the application before value is set to the property. If the application does not validate the value, it is not set.
NotifyPreviewChanged | For previewing the changed value.
NotifySet | Notify when value is set to the property.
NotifyCanceled | Notify when Property editor is closed.

enum Property::PropertyAttributeId

Enumerator:
ValueAttributeId

Constructor & Destructor Documentation

Property::Property ( )

Property::Property | ( | AtlApplication * | app,
 |  | const FeatureID & | id
 | ) |

Property::Property | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | const DataItem & | value
 | ) |

Property::Property | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | const UINT8 | notification_rule,
 |  | const DataItem & | value
 | ) |

Property::~Property ( ) [virtual]

Member Function Documentation

void Property::GetAsWString ( WString & text ) const [virtual]

Parameters:
text For available properties, the representation text specified by the property descriptor is returned. If no descriptor is set, default text representations for the data types are provided.

BOOLEAN Property::GetBoolean ( ) const [inline]

Returns the a boolean value of the object.

const DataItem& Property::GetDataItem ( ) const [inline]

Returns:
Property value

BOOLEAN Property::GetDate ( Date & date ) const [inline]

Returns the date of the object.

Date Property::GetDate ( ) const [inline]

Returns the date of theobject.

BOOLEAN Property::GetDateTime ( DateTime & date ) const [inline]

Returns the date and time of the object.

DateTime Property::GetDateTime ( ) const [inline]

Returns the date and time of theobject.

const PropertyDescriptor* Property::GetDefaultDescriptor ( ) const [inline]

Returns:
Default descriptor for this property

GenericObject* Property::GetGenericObject ( ) const [inline]

Returns a copy of the generic object.

const GenericObject* Property::GetGenericObjectPtr ( ) const [inline]

Returns the pointer of the generic object.

Number Property::GetNumber ( ) const [inline]

Returns the a numeric value of the object.

BOOLEAN Property::GetPhoneNumber ( PhoneNumber & bcdnr ) const [inline]

Returns the phonenumber of the object.

PhoneNumber Property::GetPhoneNumber ( ) const [inline]

Returns the phonenumber of the object.

BOOLEAN Property::GetString ( String & strdata ) const [inline]

Returns the string of the object.

String Property::GetString ( ) const [inline]

Returns the string of the object.

BOOLEAN Property::GetTime ( Time & time ) const [inline]

Returns the time of the object.

Time Property::GetTime ( ) const [inline]

Returns the time of the object.

BOOLEAN Property::GetWString ( WString & strdata ) const [inline]

Returns the unicode string of the object.

WString Property::GetWString ( ) const [inline]

Returns the unicode string of the object.

BOOLEAN Property::HasNotification ( const Notification rule ) const [inline]

Parameters:
rule Notification rule to be checked
Returns:
TRUE if given rule matches the rule of the property

void Property::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | const UINT8 | notification_rule,
 |  | const DataItem & | value,
 |  | BOOLEAN | available,
 |  | BOOLEAN | enabled
 | ) |

void Property::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | const DataItem & | value,
 |  | BOOLEAN | available,
 |  | BOOLEAN | enabled
 | ) |

void Property::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | const UINT8 | notification_rule,
 |  | const DataItem & | value
 | ) |

void Property::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | const UINT8 | notification_rule
 | ) |

void Property::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id
 | ) |

Reimplemented from Feature.

void Property::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | const DataItem & | value
 | ) |

BOOLEAN Property::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from Feature.

void Property::SetBoolean ( const BOOLEAN data )

Set the object with a Boolean value.

void Property::SetDataItem ( const DataItem & value )

Parameters:
value Property value

void Property::SetDate ( const Date & date )

Fills the object with a date object.

void Property::SetDateTime ( const DateTime::Persist & date )

Fills the object with a datetime object.

void Property::SetDateTime ( const DateTime & date )

Fills the object with a datetime object.

void Property::SetDefaultDescriptor ( PropertyDescriptor * descriptor ) [inline]

Parameters:
descriptor Default descriptor for this property

void Property::SetGenericObject ( const GenericObject *const genobject )

Fills the object with a generic object.

void Property::SetNumber ( const Number data )

Set the object with a numeric value.

void Property::SetPhoneNumber ( const PhoneNumber & bcdnr )

Fills the object with a phonenumber object.

void Property::SetProvider ( Provider * provider )

Set the object with a pointer to a provider.

void Property::SetString ( const CHAR * strdata )

Fills the object with a string.

void Property::SetString ( const String & strdata )

Fills the object with a string.

void Property::SetTime ( const Time & time )

Fills the object with a time object.

void Property::SetWString ( const WCHAR * strdata )

Fills the object with a unicode string.

void Property::SetWString ( const WString & strdata )

Fills the object with a unicode string.

Field Documentation

PropertyDescriptor* Property::m_descriptor [protected]

UINT8 Property::m_notification_rule [protected]

DataItem Property::m_value [protected]

The documentation for this class was generated from the following files:
  • Atl/Properties/Property.hpp
  • Atl/Properties/Property.cpp
Generated on Wed Jan 25 01:41:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PropertyDescriptor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PropertyDescriptor Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Properties/PropertyDescriptor.hpp>

Inheritance diagram for PropertyDescriptor:

[legend]
Collaboration diagram for PropertyDescriptor:

[legend]

Public Types

enum | { ID = 1 }

Public Member Functions

const ContextID & | GetContextId () const
returns ContextID of PropertyDescriptor
virtual ImageObtainer | GetIcon (const DataItem &item) const
Obsolete method.
virtual ImageObtainer | GetIcon (const Property *property) const
const WString & | GetLabel () const
Returns the text configured for the associated PropertyEditor.
virtual WString | GetText (const DataItem &item) const
Obsolete method.
virtual WString | GetText (const Property *property) const
const WString & | GetTitle () const
Returns the title configured for the associated PropertyEditor.
void | Init (const CHAR *context_id, const WCHAR *label=0)
void | Init (const ContextID &context_id, const WString &label)
void | Init (const WCHAR *title, const WCHAR *label=0)
void | Init (const WString &title, const WString &label)
virtual BOOLEAN | IsInstanceOf (const INT id) const
PropertyDescriptor (const CHAR *context_id, const WCHAR *label=0)
PropertyDescriptor (const ContextID &context_id, const WString &label)
PropertyDescriptor (const WCHAR *title, const WCHAR *label=0)
PropertyDescriptor (const WString &title, const WString &label)
PropertyDescriptor (const WString &title)
param title WString defining the title of the PropertyEditor
PropertyDescriptor ()
void | SetLabel (const WString &label)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
Sets its properties defined by the APOXI GUI Editor.
void | SetTitle (const WString &title)
virtual | ~PropertyDescriptor ()
Destructor.

Protected Attributes

ContextID m_context_id
WString m_label
WString m_title

Detailed Description

Base class for different type-specific property descriptors Describes the display of Property values for PropertyItems and IndicatorItems In case of PropertyItems additionally the title and the label of the associated PropertyEditor can be defined Configurable with the APOXI GUI Editor

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PropertyDescriptor::PropertyDescriptor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

PropertyDescriptor::PropertyDescriptor ( const WString & title )

param title WString defining the title of the PropertyEditor

PropertyDescriptor::PropertyDescriptor | ( | const WString & | title,
 |  | const WString & | label
 | ) |

Parameters:
title | WString defining the title of the PropertyEditor
label | WString defining the label of the PropertyEditor

PropertyDescriptor::PropertyDescriptor | ( | const WCHAR * | title,
 |  | const WCHAR * | label = 0
 | ) |

Parameters:
title | WCHAR* defining the title of the PropertyEditor
label | WCHAR* defining the label of the PropertyEditor

PropertyDescriptor::PropertyDescriptor | ( | const ContextID & | context_id,
 |  | const WString & | label
 | ) |

Parameters:
context_id | ContextID of the PropertyDescriptor, configures title, softkeys and keymapping of PropertyEditor. Overwrites ContextID of PropertyEditor.
label | text of PropertyDescriptor

PropertyDescriptor::PropertyDescriptor | ( | const CHAR * | context_id,
 |  | const WCHAR * | label = 0
 | ) |

Parameters:
context_id | CHAR* ContextID of the PropertyDescriptor, configures title, softkeys and keymapping of PropertyEditor. Overwrites ContextID of PropertyEditor.
label | label WCHAR* defining text of PropertyDescriptor

PropertyDescriptor::~PropertyDescriptor ( ) [virtual]

Destructor.

Member Function Documentation

const ContextID& PropertyDescriptor::GetContextId ( ) const [inline]

returns ContextID of PropertyDescriptor

ImageObtainer PropertyDescriptor::GetIcon ( const DataItem & item ) const [virtual]

Obsolete method.

Reimplemented in ValueMappingPropertyDescriptor< T_Container >.

ImageObtainer PropertyDescriptor::GetIcon ( const Property * property ) const [virtual]

Returns an empty ImageObtainer if not overwritten Can be overwritten to define the icon that represents the actual property value

Parameters:
property Property holding a property value

Reimplemented in ValueMappingPropertyDescriptor< T_Container >.

const WString& PropertyDescriptor::GetLabel ( ) const [inline]

Returns the text configured for the associated PropertyEditor.

WString PropertyDescriptor::GetText ( const DataItem & item ) const [virtual]

Obsolete method.

Reimplemented in ValueMappingPropertyDescriptor< T_Container >.

WString PropertyDescriptor::GetText ( const Property * property ) const [virtual]

Returns the actual value of the given property represented as WString. Can be overwritten to define textual representation of the actual value given by the property

Parameters:
property Property holding a property value

Reimplemented in ValueMappingPropertyDescriptor< T_Container >.

const WString& PropertyDescriptor::GetTitle ( ) const [inline]

Returns the title configured for the associated PropertyEditor.

void PropertyDescriptor::Init | ( | const CHAR * | context_id,
 |  | const WCHAR * | label = 0
 | ) |

Parameters:
context_id | ContextID of the PropertyDescriptor, configures title, softkeys and keymapping of Descriptor. Overwrites ContextID of PropertyEditor.
label | text of PropertyEditor

void PropertyDescriptor::Init | ( | const ContextID & | context_id,
 |  | const WString & | label
 | ) |

Parameters:
context_id | ContextID of the PropertyDescriptor, configures title, softkeys and keymapping of Descriptor. Overwrites ContextID of PropertyEditor.
label | text of PropertyEditor

void PropertyDescriptor::Init | ( | const WCHAR * | title,
 |  | const WCHAR * | label = 0
 | ) |

Parameters:
title | WCHAR* defining the title of the PropertyEditor
label | WCHAR* defining the label of the PropertyEditor

void PropertyDescriptor::Init | ( | const WString & | title,
 |  | const WString & | label
 | ) |

Parameters:
title | WString defining the title of the PropertyEditor
label | WString defining the label of the PropertyEditor

BOOLEAN PropertyDescriptor::IsInstanceOf ( const INT id ) const [virtual]

Returns TRUE, if the PropertyDescriptor is an instance of the PropertyDescriptor-class with the ID id.

Reimplemented in ListPropertyDescriptor, and ValueMappingPropertyDescriptor< T_Container >.

void PropertyDescriptor::SetLabel ( const WString & label ) [inline]

Parameters:
label WString defining the label of the PropertyEditor

BOOLEAN PropertyDescriptor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Sets its properties defined by the APOXI GUI Editor.

Reimplemented in ListPropertyDescriptor, and ValueMappingPropertyDescriptor< T_Container >.

void PropertyDescriptor::SetTitle ( const WString & title ) [inline]

Parameters:
title WString defining the title of the PropertyEditor

Field Documentation

ContextID PropertyDescriptor::m_context_id [protected]

WString PropertyDescriptor::m_label [protected]

WString PropertyDescriptor::m_title [protected]

The documentation for this class was generated from the following files:
  • Atl/Properties/PropertyDescriptor.hpp
  • Atl/Properties/PropertyDescriptor.cpp
Generated on Wed Jan 25 01:41:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PropertyEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PropertyEditor Class Reference
[APOXI Template Layer]

Interface for property editors. More...

#include <Apoxi/Atl/Properties/PropertyEditor.hpp>

Inheritance diagram for PropertyEditor:

[legend]
Collaboration diagram for PropertyEditor:

[legend]

Public Member Functions

virtual BOOLEAN | EditProperty (PropertyItem &item)
virtual const PropertyEditorID & | GetID () const
virtual void | GetNewPropertyValue (DataItem &value)=0
PropertyEditor (const PropertyEditorID &id, ContextID &context)
PropertyEditor (const PropertyEditorID &id)
virtual | ~PropertyEditor ()

Protected Member Functions

virtual BOOLEAN | CanEdit ()
const PropertyDescriptor * | GetDescriptor ()
const PropertyItem * | GetPropertyItem ()
virtual void | Init ()
virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
BOOLEAN | SendNotification (const Property::Notification notification, BOOLEAN new_data=TRUE)
void | SetDescriptor (const PropertyDescriptor *descriptor)
void | SetPropertyItem (PropertyItem &item)

Detailed Description

Interface for property editors.

Constructor & Destructor Documentation

PropertyEditor::PropertyEditor ( const PropertyEditorID & id )

PropertyEditor::PropertyEditor | ( | const PropertyEditorID & | id,
 |  | ContextID & | context
 | ) |

PropertyEditor::~PropertyEditor ( ) [virtual]

Member Function Documentation

BOOLEAN PropertyEditor::CanEdit ( ) [protected, virtual]

Returns:
TRUE, only if the editor is able to edit the value of the property */

BOOLEAN PropertyEditor::EditProperty ( PropertyItem & item ) [virtual]

Parameters:
item Property item, which shall be edited
Returns:
TRUE, only if the editor is able to edit the value of the property

const PropertyDescriptor* PropertyEditor::GetDescriptor ( ) [inline, protected]

Parameters:
None
Returns:
Property descriptor pointer

virtual const PropertyEditorID& PropertyEditor::GetID ( ) const [inline, virtual]

Returns:
Resource ID of this editor

virtual void PropertyEditor::GetNewPropertyValue ( DataItem & value ) [pure virtual]

Parameters:
value The new property value from the user input

const PropertyItem* PropertyEditor::GetPropertyItem ( ) [inline, protected]

Parameters:
None
Returns:
Property item pointer

void PropertyEditor::Init ( ) [protected, virtual]

Initialization of the property editor

BOOLEAN PropertyEditor::OnCancel ( ) [protected, virtual]

Reimplemented from AtlWindow.

BOOLEAN PropertyEditor::OnKeyDown ( KeyCode key_code ) [protected, virtual]

On the confirm key, the new property value is set to the property according to it's notification rule.

Returns:
TRUE if key down message is dispatched.

Reimplemented from AtlWindow.

BOOLEAN PropertyEditor::SendNotification | ( | const Property::Notification | notification,
 |  | BOOLEAN | new_data = TRUE
 | ) | [protected]

Parameters:
notification If given notification is valid for the property, the application is notified accordingly
Returns:
TRUE

void PropertyEditor::SetDescriptor ( const PropertyDescriptor * descriptor ) [protected]

Parameters:
descriptor PropertyDescriptor which shall be set
Returns:
void

void PropertyEditor::SetPropertyItem ( PropertyItem & item ) [inline, protected]

Parameters:
item Property item, which shall be set
Returns:
void

The documentation for this class was generated from the following files:
  • Atl/Properties/PropertyEditor.hpp
  • Atl/Properties/PropertyEditor.cpp
Generated on Wed Jan 25 01:41:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PropertyEditorFactory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PropertyEditorFactory Class Reference
[APOXI Template Layer]

Singleton class for handling property editors. More...

#include <Apoxi/Atl/Properties/PropertyEditorFactory.hpp>

Collaboration diagram for PropertyEditorFactory:

[legend]

Public Member Functions

BOOLEAN | Edit (PropertyItem *property)
virtual | ~PropertyEditorFactory ()

Static Public Member Functions

static PropertyEditorFactory * | GetInstance ()

Detailed Description

Singleton class for handling property editors.

Constructor & Destructor Documentation

PropertyEditorFactory::~PropertyEditorFactory ( ) [virtual]

Member Function Documentation

BOOLEAN PropertyEditorFactory::Edit ( PropertyItem * property )

Parameters:
Property item to be edited
Returns:
TRUE, if factory has a matching editor available

static PropertyEditorFactory* PropertyEditorFactory::GetInstance ( ) [inline, static]

Get The Instance of the PropertyEditorFactory Singleton

The documentation for this class was generated from the following files:
  • Atl/Properties/PropertyEditorFactory.hpp
  • Atl/Properties/PropertyEditorFactory.cpp
Generated on Wed Jan 25 01:41:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PropertyItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PropertyItem Class Reference
[APOXI Template Layer]

Encapsulates a property. The PropertyItem can be used for GUI controls. More...

#include <Apoxi/Atl/Properties/PropertyItem.hpp>

Inheritance diagram for PropertyItem:

[legend]
Collaboration diagram for PropertyItem:

[legend]

Public Types

enum | { ID = 104 }

Public Member Functions

virtual BOOLEAN | Execute ()
const PropertyDescriptor * | GetDescriptor () const
const PropertyEditorID & | GetPropertyEditorID () const
void | Init (Property *property, const WString &text="", const ImageObtainer &icon=ImageObtainer())
virtual BOOLEAN | IsInstanceOf (INT id) const
PropertyItem (Property *property, const WString &text="", const ImageObtainer &icon=ImageObtainer())
PropertyItem ()
void | SetDescriptor (PropertyDescriptor *descriptor)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
void | SetPropertyEditorID (const PropertyEditorID &id)
virtual void | Update ()
sets the updated icon after the property's value has changed
virtual | ~PropertyItem ()

Detailed Description

Encapsulates a property. The PropertyItem can be used for GUI controls.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from FeatureItem.

Constructor & Destructor Documentation

PropertyItem::PropertyItem ( )

PropertyItem::PropertyItem | ( | Property * | property,
 |  | const WString & | text = "",
 |  | const ImageObtainer & | icon = ImageObtainer()
 | ) |

PropertyItem::~PropertyItem ( ) [virtual]

Member Function Documentation

BOOLEAN PropertyItem::Execute ( ) [virtual]

The property-providing application is posted a PropertyTriggerMsg. If the property editor factory is not able to handle the property, the particular application must handle the property itself.

Reimplemented from FeatureItem.

const PropertyDescriptor * PropertyItem::GetDescriptor ( ) const

Returns:
Property descriptor of this item

const PropertyEditorID & PropertyItem::GetPropertyEditorID ( ) const

Returns:
ID of the editor, which is configured to be used to edit the property value

void PropertyItem::Init | ( | Property * | property,
 |  | const WString & | text = "",
 |  | const ImageObtainer & | icon = ImageObtainer()
 | ) |

BOOLEAN PropertyItem::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from FeatureItem.

void PropertyItem::SetDescriptor ( PropertyDescriptor * descriptor )

Parameters:
descriptor For changing the property descriptor of this item

BOOLEAN PropertyItem::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from FeatureItem.

void PropertyItem::SetPropertyEditorID ( const PropertyEditorID & id )

Parameters:
id ID of the editor, which is configured to be used to edit the property value

void PropertyItem::Update ( ) [virtual]

sets the updated icon after the property's value has changed

Reimplemented from FeatureItem.

The documentation for this class was generated from the following files:
  • Atl/Properties/PropertyItem.hpp
  • Atl/Properties/PropertyItem.cpp
Generated on Wed Jan 25 01:41:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PropertyTriggerMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PropertyTriggerMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for PropertyTriggerMsg:

[legend]
Collaboration diagram for PropertyTriggerMsg:

[legend]

Public Types

enum | { ID = 13004 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
PropertyItem * | GetPropertyItem () const
PropertyTriggerMsg (ExecutionContext *context, PropertyItem *property_item)
void | SetPropertyItem (PropertyItem *property_item)
virtual | ~PropertyTriggerMsg ()

Detailed Description

PropertyTrigger

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

PropertyTriggerMsg::PropertyTriggerMsg | ( | ExecutionContext * | context,
 |  | PropertyItem * | property_item
 | ) |

PropertyTriggerMsg::~PropertyTriggerMsg ( ) [virtual]

Member Function Documentation

Message * PropertyTriggerMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & PropertyTriggerMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

PropertyItem* PropertyTriggerMsg::GetPropertyItem ( ) const [inline]

void PropertyTriggerMsg::SetPropertyItem ( PropertyItem * property_item ) [inline]

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 01:41:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Protector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Protector Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Protector.hpp>

Collaboration diagram for Protector:

[legend]

Public Member Functions

void | Init ()
Initializes the mutex object inside the object.
BOOLEAN | IsInitialized ()
Checks if the protector is initalized.
virtual BOOLEAN | Lock ()
Protector ()
virtual BOOLEAN | Unlock ()
virtual | ~Protector ()

Detailed Description

A Protector is used to synchronize data access especially for Providers which are derived from ThreadSafeProvider.

Constructor & Destructor Documentation

Protector::Protector ( )

Protector::~Protector ( ) [virtual]

Member Function Documentation

void Protector::Init ( )

Initializes the mutex object inside the object.

BOOLEAN Protector::IsInitialized ( ) [inline]

Checks if the protector is initalized.

BOOLEAN Protector::Lock ( ) [virtual]

BOOLEAN Protector::Unlock ( ) [virtual]

The documentation for this class was generated from the following files:
  • Auxiliary/Protector.hpp
  • Auxiliary/Protector.cpp
Generated on Wed Jan 25 01:41:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProtocolIdentifier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProtocolIdentifier Class Reference

3GPP TS 23.040 V5.1.0 [9.2.3.9] More...

#include <Apoxi/Apc/ProtocolIdentifier.hpp>

Collaboration diagram for ProtocolIdentifier:

[legend]

Public Types

enum | { InvalidPid = 0x80 }
enum | Interworking { SmeToSme, Telematic, InvalidInterworking }
enum MessageType {
ShortMessageType0 = 0, ReplaceShortMessageType1, ReplaceShortMessageType2, ReplaceShortMessageType3,
ReplaceShortMessageType4, ReplaceShortMessageType5, ReplaceShortMessageType6, ReplaceShortMessageType7,
EnhancedMessageType, ReturnCallMessage, Ansi136, MeDataDownload,
MeDepersonalizationShortMessage, USimDataDownload, ReservedMessageType, InvalidMessageType
}
enum TelematicDevice {
Implicit, Telex, Group3Telefax, Group4Telefax,
VoiceTelephone, Ermes, NationalPagingSystem, Videotex,
TeletexCarrierUnspecified, TeletexPspdn, TeletexCspdn, TeletexAnalogPstn,
TeletexDigitalIsdn, Uci, MessageHandlingFacility, X400,
InternetElectronicMail, ServiceCenterSpecificTelematicDevice, GsmUmts, ReservedTelematicDevice,
InvalidTelematicDevice
}
enum | Usage { Normal, ReservedUsage, ServiceCenterSpecificUsage, InvalidUsage }
describes the various kinds of groups More...
enum | UsageGroup { Group00, Group01, InvalidGroup }
describes the various kinds of groups More...

Public Member Functions

void | Clear ()
UINT8 | Get () const
Interworking | GetInterworking () const
MessageType | GetMessageType () const
TelematicDevice | GetTelematicDevice () const
Usage | GetUsage () const
BOOLEAN | IsInvalid () const
BOOLEAN | IsNormalUsage () const
BOOLEAN | IsTelematicDevice () const
ProtocolIdentifier (UINT8 incoming_byte)
ProtocolIdentifier ()
void | SetInterworking (Interworking interworking)
void | SetMessageType (MessageType message_type)
void | SetTelematicDevice (TelematicDevice telematic_device)
void | SetUsage (Usage usage)

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.3.9]

Member Enumeration Documentation

anonymous enum

Enumerator:
InvalidPid

enum ProtocolIdentifier::Interworking

Enumerator:
SmeToSme no interworking, but SME-to-SME protocol
Telematic
InvalidInterworking

enum ProtocolIdentifier::MessageType

Enumerator:
ShortMessageType0
ReplaceShortMessageType1
ReplaceShortMessageType2
ReplaceShortMessageType3
ReplaceShortMessageType4
ReplaceShortMessageType5
ReplaceShortMessageType6
ReplaceShortMessageType7
EnhancedMessageType | obsolete
ReturnCallMessage
Ansi136 | Ansi-136 R-DATA.
MeDataDownload
MeDepersonalizationShortMessage
USimDataDownload
ReservedMessageType
InvalidMessageType

enum ProtocolIdentifier::TelematicDevice

Enumerator:
Implicit | device type is specific to this SC, or can be concluded on the basis of the address
Telex
Group3Telefax
Group4Telefax
VoiceTelephone | i.e. conversion to speech
Ermes | European Radio Messaging System.
NationalPagingSystem | known to the SC
Videotex | T.100 [20] / T.101 [21].
TeletexCarrierUnspecified
TeletexPspdn
TeletexCspdn
TeletexAnalogPstn
TeletexDigitalIsdn
Uci | Universal Computer Interface (ETSI DE/PS 3 01-3).
MessageHandlingFacility
X400 | any public X.400-based message handling system
InternetElectronicMail
ServiceCenterSpecificTelematicDevice
GsmUmts
ReservedTelematicDevice
InvalidTelematicDevice | known to the SC

enum ProtocolIdentifier::Usage

describes the various kinds of groups

Enumerator:
Normal
ReservedUsage
ServiceCenterSpecificUsage
InvalidUsage

enum ProtocolIdentifier::UsageGroup

describes the various kinds of groups

Enumerator:
Group00 index describes the bits 7..6 (eg. 00 for UsageGroup00)
Group01
InvalidGroup

Constructor & Destructor Documentation

ProtocolIdentifier::ProtocolIdentifier ( )

ProtocolIdentifier::ProtocolIdentifier ( UINT8 incoming_byte )

Member Function Documentation

void ProtocolIdentifier::Clear ( ) [inline]

UINT8 ProtocolIdentifier::Get ( ) const [inline]

ProtocolIdentifier::Interworking ProtocolIdentifier::GetInterworking ( ) const

ProtocolIdentifier::MessageType ProtocolIdentifier::GetMessageType ( ) const

ProtocolIdentifier::TelematicDevice ProtocolIdentifier::GetTelematicDevice ( ) const

ProtocolIdentifier::Usage ProtocolIdentifier::GetUsage ( ) const

BOOLEAN ProtocolIdentifier::IsInvalid ( ) const [inline]

BOOLEAN ProtocolIdentifier::IsNormalUsage ( ) const [inline]

BOOLEAN ProtocolIdentifier::IsTelematicDevice ( ) const [inline]

void ProtocolIdentifier::SetInterworking ( Interworking interworking )

void ProtocolIdentifier::SetMessageType ( MessageType message_type )

void ProtocolIdentifier::SetTelematicDevice ( TelematicDevice telematic_device )

void ProtocolIdentifier::SetUsage ( Usage usage )

The documentation for this class was generated from the following files:
  • Apc/ProtocolIdentifier.hpp
  • Apc/ProtocolIdentifier.cpp
Generated on Wed Jan 25 01:41:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProvColListBoxWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProvColListBoxWin Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/ProvListBoxWin.hpp>

Inheritance diagram for ProvColListBoxWin:

[legend]
Collaboration diagram for ProvColListBoxWin:

[legend]

Public Member Functions

virtual Provider * | GetMyPbProvider ()
void | Init (INT column_id, INT sort_colid=c_invalid_colid)
ProvColListBoxWin (INT column_id)
ProvColListBoxWin ()
virtual | ~ProvColListBoxWin ()

Protected Member Functions

virtual PbProvListBox * | GetListBox ()

Constructor & Destructor Documentation

ProvColListBoxWin::ProvColListBoxWin ( )

ProvColListBoxWin::ProvColListBoxWin ( INT column_id )

ProvColListBoxWin::~ProvColListBoxWin ( ) [virtual]

Member Function Documentation

PbProvListBox * ProvColListBoxWin::GetListBox ( ) [protected, virtual]

Implements ProvListBoxWin.

Provider * ProvColListBoxWin::GetMyPbProvider ( ) [virtual]

Reimplemented from PbAbstractWin.

Reimplemented in AdvPbWin, and PbBaseWin.

void ProvColListBoxWin::Init | ( | INT | column_id,
 |  | INT | sort_colid = c_invalid_colid
 | ) |

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/ProvListBoxWin.hpp
  • Applications/AdvPhonebook/ProvListBoxWin.cpp
Generated on Wed Jan 25 01:41:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProvDetailListBoxWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProvDetailListBoxWin Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/ProvListBoxWin.hpp>

Inheritance diagram for ProvDetailListBoxWin:

[legend]
Collaboration diagram for ProvDetailListBoxWin:

[legend]

Public Member Functions

virtual Provider * | GetMyPbProvider ()
virtual INT | GetSelectedRow ()
void | Init (ProvListBoxWin *parent, const INT *detail_columns, INT filt_colid)
ProvDetailListBoxWin (ProvListBoxWin *parent, const INT *detail_columns, INT filt_colid)
ProvDetailListBoxWin ()
void | SetDetailColumns (const INT *detail_columns)
virtual void | SetProvider (Provider *provider)
void | SetRow (int row)
virtual void | UpdateEnabledActions ()
virtual void | UpdateWin (BOOLEAN win_only=FALSE)
virtual | ~ProvDetailListBoxWin ()

Protected Member Functions

virtual PbDetailProvider * | GetDetailProvider ()=0
virtual PbProvListBox * | GetListBox ()
virtual ProvListBoxWin * | GetParent ()
virtual void | Refresh (const Rect &rect)
virtual void | UpdateTitle ()

Constructor & Destructor Documentation

ProvDetailListBoxWin::ProvDetailListBoxWin ( )

ProvDetailListBoxWin::ProvDetailListBoxWin | ( | ProvListBoxWin * | parent,
 |  | const INT * | detail_columns,
 |  | INT | filt_colid
 | ) |

ProvDetailListBoxWin::~ProvDetailListBoxWin ( ) [virtual]

Member Function Documentation

virtual PbDetailProvider* ProvDetailListBoxWin::GetDetailProvider ( ) [protected, pure virtual]

Implemented in PbAdvDetails, and PbDetails.

PbProvListBox * ProvDetailListBoxWin::GetListBox ( ) [protected, virtual]

Implements ProvListBoxWin.

Provider * ProvDetailListBoxWin::GetMyPbProvider ( ) [virtual]

Reimplemented from PbAbstractWin.

Reimplemented in PbDetails.

ProvListBoxWin * ProvDetailListBoxWin::GetParent ( ) [protected, virtual]

INT ProvDetailListBoxWin::GetSelectedRow ( ) [virtual]

Reimplemented from ProvListBoxWin.

Reimplemented in PbAdvDetails.

void ProvDetailListBoxWin::Init | ( | ProvListBoxWin * | parent,
 |  | const INT * | detail_columns,
 |  | INT | filt_colid
 | ) |

void ProvDetailListBoxWin::Refresh ( const Rect & rect ) [protected, virtual]

Reimplemented from ProvListBoxWin.

void ProvDetailListBoxWin::SetDetailColumns ( const INT * detail_columns ) [inline]

void ProvDetailListBoxWin::SetProvider ( Provider * provider ) [virtual]

Reimplemented from ProvListBoxWin.

void ProvDetailListBoxWin::SetRow ( int row )

void ProvDetailListBoxWin::UpdateEnabledActions ( ) [virtual]

Reimplemented from PbAbstractWin.

void ProvDetailListBoxWin::UpdateTitle ( ) [protected, virtual]

void ProvDetailListBoxWin::UpdateWin ( BOOLEAN win_only = FALSE ) [virtual]

Reimplemented from ProvListBoxWin.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/ProvListBoxWin.hpp
  • Applications/AdvPhonebook/ProvListBoxWin.cpp
Generated on Wed Jan 25 01:41:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Provider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Provider Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Provider.hpp>

Inheritance diagram for Provider:

[legend]
Collaboration diagram for Provider:

[legend]

Public Types

enum ModificationType {
Append, Insert, Commit, Delete,
DeleteAll, Toggle, UndefinedModification
}
Change types of the provider. More...
enum | Status { undefined, updated, updating, changed }
States of the provider. More...

Public Member Functions

virtual BOOLEAN | AppendRow ()
Append a row.
virtual INT | ColumnCount () const
ColumnCount returns the number of columns.
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | ExistColumn (INT colid)
ExistColumn checks whether a column with a specific id exists
virtual INT | GetBaseRow (INT row)
GetBaseRow returns the row of the last child provider.
virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
Retrieves the effective row of the child provider if existing.
virtual INT | GetColumnId (INT column)
GetColumnId converts a column into its id.
virtual const ColumnInfo * | GetColumnInfo (INT column)
GetColumnInfo returns column id and data type of column number.
virtual const ColumnInfo * | GetColumnInfoPerId (INT id)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)=0
GetDataItem reads data items
const Provider::Modification & | GetLastModification () const
GetLastModification returns the last modification.
Provider::ModificationType | GetModificationType () const
GetModificationType returns the type of the last modification.
INT | GetModifiedRow () const
GetModifiedRow returns the row number of the last modified row.
virtual INT | GetProgress ()
GetProgress indicates the progress of the updating in percent.
virtual INT | GetProviderId () const =0
Returns the provider id.
virtual INT | GetSortedColumnId () const
If the provider is sorted, overwrite GetSortedColumnId and return the column id of the sorted column.
virtual Status | GetStatus () const
Returns the status of the provider.
virtual const WString * | GetWString (INT columnid, INT row)
GetWString returns a pointer to a WString object or zero. em>SetDataItem writes data items to an internal buffer.
virtual BOOLEAN | InsertRow (INT row)
Insert a row in front of the row specified.
BOOLEAN | IsUpdating () const
IsUpdating checks if the same instance is currently updating.
virtual BOOLEAN | IsWStringDataCached () const
Overwrite IsWStringDataCached if the WString data is cached in RAM (necessary for faster sorting).
virtual BOOLEAN | Lock ()
Lock locks the provider and protect access to data inside the provider.
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
Provider ()
Default constructor.
void | ResetModification ()
ResetModification resets the last modification to it's default values "UndefinedModification" and "c_no_row".
virtual INT | RowCount ()=0
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
void | SetLastModification (const Provider::Modification &modification)
SetLastModification sets the last modification.
void | SetModificationType (Provider::ModificationType type)
SetModificationType sets the type of the last modification.
void | SetModifiedRow (INT row)
SetModifiedRow sets the row number of the last modified row.
virtual BOOLEAN | SetParameter (const DataItem &item)
void | SetStatus (Status status)
SetSatus shall not be called outside APOXI.
virtual BOOLEAN | ToggleRow (INT row)
Changes the state of a row, might be result that a row will not be a part of the provider.
virtual BOOLEAN | Unlock ()
Unlock unlocks the provider and allows access to the provider again.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~Provider ()
Destructor.

Protected Member Functions

BOOLEAN | IsInRange (INT row)
void | SetColumnInfoTable (const ColumnInfo *table)
void | UpdateModification (ModificationType mod_type, INT row)

Protected Attributes

const ColumnInfo * | m_columninfo
Status m_status

Data Structures

class | Modification

Detailed Description

A Provider is used to store DataItems in a tabular manner. Reading data is done by GetDataItem. Writing is done row by row. A row has to be locked first, data is modified by calls of SetDataItem, the changes have to be committed (either by Commit, AppendRow, DeleteRow, or InsertRow), and finally the procedure is closed by Unlock.

Member Enumeration Documentation

enum Provider::ModificationType

Change types of the provider.

Enumerator:
Append
Insert
Commit
Delete
DeleteAll
Toggle
UndefinedModification

enum Provider::Status

States of the provider.

Enumerator:
undefined
updated
updating
changed

Constructor & Destructor Documentation

Provider::Provider ( )

Default constructor.

Provider::~Provider ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN Provider::AppendRow ( ) [virtual]

Append a row.

Reimplemented in PbBaseProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SmsParamProvider, AppendProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, PbMergeProvider, PbNameProvider, PbNumberProvider, PbRecordProvider, CalendarProvider, DataConnProvider, and ToDoProvider.

INT Provider::ColumnCount ( ) const [virtual]

ColumnCount returns the number of columns.

Reimplemented in JoinProvider, MergeProvider, AbstractDelegationProvider, and PbSimProvider.

BOOLEAN Provider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented in AuxProvider, CbmiProvider, CbmiRangeProvider, CphsAuxProvider, CphsServPflProvider, MbiProvider, PbBaseProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SmsParamProvider, SmsProvider, StatusProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, DistinctProvider, PbRecordProvider, BtHfProvider, CalendarProvider, DataConnProvider, SmsSettingsProvider, FmRadioSettingsProvider, FmRadioStationsProvider, ToDoProvider, and UibSettingsProvider.

BOOLEAN Provider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented in CbmiProvider, CbmiRangeProvider, PbBaseProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SmsClass0Provider, SmsProvider, AppendProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, FilterProvider, FindProvider, PbMergeProvider, PbNameProvider, PbNumberProvider, PbRecordProvider, and PbSortedProvider.

BOOLEAN Provider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented in CbmiProvider, CbmiRangeProvider, PbBaseProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SmsClass0Provider, SmsParamProvider, SmsProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, DistinctProvider, PbMergeProvider, PbNameProvider, PbNumberProvider, PbRecordProvider, CalendarProvider, DataConnProvider, and ToDoProvider.

BOOLEAN Provider::ExistColumn ( INT colid ) [virtual]

ExistColumn checks whether a column with a specific id exists

Reimplemented in PbSimProvider.

INT Provider::GetBaseRow ( INT row ) [virtual]

GetBaseRow returns the row of the last child provider.

Reimplemented in AbstractDelegationProvider.

BOOLEAN Provider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

Retrieves the effective row of the child provider if existing.

Reimplemented in AppendProvider, MergeProvider, AbstractDelegationProvider, DistinctProvider, FilterProvider, FindProvider, SortProvider, PbDetailProvider, PbNumberFilterProvider, PbNameNumberProvider, PbSimProvider, SmsBasicProvider, and SmsFolderProvider.

INT Provider::GetColumnId ( INT column ) [virtual]

GetColumnId converts a column into its id.

em>GetColumnInfoPerId returns column info for a column specified by id. See also GetColumnInfo.

Reimplemented in PbSimProvider.

const ColumnInfo * Provider::GetColumnInfo ( INT column ) [virtual]

GetColumnInfo returns column id and data type of column number.

Reimplemented in JoinProvider, MergeProvider, AbstractDelegationProvider, and PbSimProvider.

const ColumnInfo * Provider::GetColumnInfoPerId ( INT id ) [virtual]

Reimplemented in PbSimProvider.

virtual BOOLEAN Provider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [pure virtual]

GetDataItem reads data items

Implemented in AuxProvider, CbmiProvider, CbmiRangeProvider, ChvProvider, CmiProvider, CountryProvider, CphsAuxProvider, CphsServPflProvider, EccProvider, LockProvider, MbiProvider, PbBaseProvider, PlmnProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SimTkMainMenuProvider, SmsClass0Provider, SmsParamProvider, SmsProvider, SmsCountProvider, SmsMsgWaitingProvider, SstProvider, StatusProvider, LanguageProvider, AppendProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, DistinctProvider, FilterProvider, FindProvider, SortProvider, PbDetailProvider, PbNumberFilterProvider, PbNameFilterProvider, PbNameNumberProvider, PbSimProvider, BtDeviceListProvider, BtHfProvider, CalendarProvider, CsdDataConnProvider, DataConnProvider, PsdDataConnProvider, SerDataConnProvider, SmsBasicProvider, SmsFolderProvider, SmsSettingsProvider, SmsTemplateProvider, FmRadioSettingsProvider, FmRadioStationsProvider, ToDoProvider, UibInboxProvider, and UibSettingsProvider.

const Provider::Modification& Provider::GetLastModification ( ) const [inline]

GetLastModification returns the last modification.

Provider::ModificationType Provider::GetModificationType ( ) const [inline]

GetModificationType returns the type of the last modification.

INT Provider::GetModifiedRow ( ) const [inline]

GetModifiedRow returns the row number of the last modified row.

INT Provider::GetProgress ( ) [virtual]

GetProgress indicates the progress of the updating in percent.

Reimplemented in PbBaseProvider, SmsClass0Provider, SmsProvider, AppendProvider, JoinProvider, AbstractDelegationProvider, and PbSimProvider.

virtual INT Provider::GetProviderId ( ) const [pure virtual]

Returns the provider id.

Implemented in AuxProvider, CbmiProvider, CbmiRangeProvider, ChvProvider, CmiProvider, CountryProvider, CphsAuxProvider, CphsServPflProvider, EccProvider, LockProvider, MbiProvider, PbBaseProvider, PlmnProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SimTkMainMenuProvider, SmsClass0Provider, SmsParamProvider, SmsProvider, SmsCountProvider, SmsMsgWaitingProvider, SmsReadProvider, SmsSentProvider, SmsUnreadProvider, SmsUnsentProvider, SstProvider, StatusProvider, LanguageProvider, AppendProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, GroupProvider, PbNumberFilterProvider, PbNameFilterProvider, PbNameNumberProvider, PbNameProvider, PbNumberProvider, PbSimProvider, BtDeviceListProvider, BtHfProvider, CalendarProvider, CsdDataConnProvider, DataConnProvider, PsdDataConnProvider, SerDataConnProvider, SmsSettingsProvider, SmsTemplateProvider, FmRadioSettingsProvider, FmRadioStationsProvider, ToDoProvider, and UibSettingsProvider.

INT Provider::GetSortedColumnId ( ) const [virtual]

If the provider is sorted, overwrite GetSortedColumnId and return the column id of the sorted column.

Reimplemented in PbBaseProvider, AppendProvider, and AbstractDelegationProvider.

Provider::Status Provider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented in ChvProvider, CmiProvider, CountryProvider, PlmnProvider, SmsClass0Provider, SettingsProvider, PbNumberFilterProvider, PbNameFilterProvider, PbSimProvider, PbSortedProvider, and BtDeviceListProvider.

const WString * Provider::GetWString | ( | INT | columnid,
 |  | INT | row
 | ) | [virtual]

GetWString returns a pointer to a WString object or zero. em>SetDataItem writes data items to an internal buffer.

Reimplemented in PbBaseProvider.

BOOLEAN Provider::InsertRow ( INT row ) [virtual]

Insert a row in front of the row specified.

Reimplemented in PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, FilterProvider, and SortProvider.

BOOLEAN Provider::IsInRange ( INT row ) [protected]

BOOLEAN Provider::IsUpdating ( ) const

IsUpdating checks if the same instance is currently updating.

BOOLEAN Provider::IsWStringDataCached ( ) const [virtual]

Overwrite IsWStringDataCached if the WString data is cached in RAM (necessary for faster sorting).

Reimplemented in PbBaseProvider, and AbstractDelegationProvider.

BOOLEAN Provider::Lock ( ) [virtual]

Lock locks the provider and protect access to data inside the provider.

Reimplemented in AppendProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, ThreadSafeProvider, PbRecordProvider, and SmsBasicProvider.

INT Provider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented in CbmiProvider, CbmiRangeProvider, MbiProvider, PbBaseProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SmsClass0Provider, SmsParamProvider, SmsProvider, AppendProvider, JoinProvider, AbstractDelegationProvider, PbMergeProvider, PbRecordProvider, BtHfProvider, CalendarProvider, SmsSettingsProvider, FmRadioSettingsProvider, FmRadioStationsProvider, and ToDoProvider.

void Provider::ResetModification ( )

ResetModification resets the last modification to it's default values "UndefinedModification" and "c_no_row".

virtual INT Provider::RowCount ( ) [pure virtual]

RowCount returns the number of rows.

Implemented in AuxProvider, CbmiProvider, CbmiRangeProvider, ChvProvider, CmiProvider, CountryProvider, CphsAuxProvider, CphsServPflProvider, EccProvider, LockProvider, MbiProvider, PbBaseProvider, PlmnProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SimTkMainMenuProvider, SmsClass0Provider, SmsParamProvider, SmsProvider, SmsCountProvider, SmsMsgWaitingProvider, SmsReadProvider, SmsSentProvider, SmsUnreadProvider, SmsUnsentProvider, SstProvider, StatusProvider, LanguageProvider, AppendProvider, JoinProvider, SettingsProvider, AbstractDelegationProvider, FilterProvider, FindProvider, GroupProvider, PbDetailProvider, PbNumberFilterProvider, PbRecordProvider, BtDeviceListProvider, CalendarProvider, DataConnProvider, SmsSettingsProvider, SmsTemplateProvider, FmRadioStationsProvider, ToDoProvider, and UibSettingsProvider.

BOOLEAN Provider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented in MbiProvider, PbBaseProvider, PrefPlmnProvider, SmsParamProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, PbRecordProvider, BtHfProvider, CalendarProvider, DataConnProvider, SmsSettingsProvider, FmRadioSettingsProvider, FmRadioStationsProvider, ToDoProvider, and UibSettingsProvider.

void Provider::SetColumnInfoTable ( const ColumnInfo * table ) [inline, protected]

BOOLEAN Provider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented in AuxProvider, CbmiProvider, CbmiRangeProvider, CphsAuxProvider, CphsServPflProvider, MbiProvider, PbBaseProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SmsParamProvider, SmsProvider, StatusProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, DistinctProvider, BtHfProvider, CalendarProvider, CsdDataConnProvider, DataConnProvider, PsdDataConnProvider, SerDataConnProvider, SmsSettingsProvider, FmRadioSettingsProvider, FmRadioStationsProvider, ToDoProvider, and UibSettingsProvider.

void Provider::SetLastModification ( const Provider::Modification & modification ) [inline]

SetLastModification sets the last modification.

void Provider::SetModificationType ( Provider::ModificationType type ) [inline]

SetModificationType sets the type of the last modification.

void Provider::SetModifiedRow ( INT row ) [inline]

SetModifiedRow sets the row number of the last modified row.

BOOLEAN Provider::SetParameter ( const DataItem & item ) [virtual]

Reimplemented in AppendProvider, DualFilterProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, FilterProvider, PbNumberFilterProvider, PbMergeProvider, and PbNameFilterProvider.

void Provider::SetStatus ( Status status ) [inline]

SetSatus shall not be called outside APOXI.

BOOLEAN Provider::ToggleRow ( INT row ) [virtual]

Changes the state of a row, might be result that a row will not be a part of the provider.

Reimplemented in SmsClass0Provider, SmsProvider, JoinProvider, MergeProvider, and AbstractDelegationProvider.

BOOLEAN Provider::Unlock ( ) [virtual]

Unlock unlocks the provider and allows access to the provider again.

Reimplemented in AppendProvider, JoinProvider, MergeProvider, AbstractDelegationProvider, ThreadSafeProvider, PbRecordProvider, and SmsBasicProvider.

BOOLEAN Provider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented in AuxProvider, CbmiProvider, CbmiRangeProvider, ChvProvider, CmiProvider, CphsAuxProvider, CphsServPflProvider, EccProvider, MbiProvider, PbBaseProvider, PrefExtLangProvider, PrefLangProvider, PrefPlmnProvider, SimTkMainMenuProvider, SmsClass0Provider, SmsParamProvider, SmsProvider, SmsCountProvider, SmsMsgWaitingProvider, SstProvider, AppendProvider, JoinProvider, MergeProvider, SettingsProvider, AbstractDelegationProvider, BubbleSortProvider, CachingSortProvider, ChineseQuickSortProvider, DistinctProvider, FilterProvider, Find2Provider, FindProvider, QuickSortProvider, SortProvider, PbDetailProvider, PbNumberFilterProvider, PbMergeProvider, PbNameFilterProvider, PbNameProvider, PbNumberProvider, PbRecordProvider, PbSortedProvider, SmsSettingsProvider, and FmRadioStationsProvider.

void Provider::UpdateModification | ( | ModificationType | mod_type,
 |  | INT | row
 | ) | [protected]

Field Documentation

const ColumnInfo* Provider::m_columninfo [protected]

Status Provider::m_status [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/Provider.hpp
  • Auxiliary/Provider.cpp
Generated on Wed Jan 25 01:41:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Provider::Modification Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Provider::Modification

Provider::Modification Class Reference

#include <Apoxi/Auxiliary/Provider.hpp>

Public Member Functions

INT | GetOriginalRow () const
INT | GetRow () const
ModificationType | GetType () const
Modification (ModificationType type, INT row, INT original_row)
Modification (ModificationType type=UndefinedModification, INT row=c_no_row)
void | SetOriginalRow (INT original_row)
void | SetRow (INT row)
void | SetType (ModificationType type)

Constructor & Destructor Documentation

Provider::Modification::Modification | ( | ModificationType | type = UndefinedModification,
 |  | INT | row = c_no_row
 | ) | [inline]

Provider::Modification::Modification | ( | ModificationType | type,
 |  | INT | row,
 |  | INT | original_row
 | ) | [inline]

Member Function Documentation

INT Provider::Modification::GetOriginalRow ( ) const [inline]

INT Provider::Modification::GetRow ( ) const [inline]

ModificationType Provider::Modification::GetType ( ) const [inline]

void Provider::Modification::SetOriginalRow ( INT original_row ) [inline]

void Provider::Modification::SetRow ( INT row ) [inline]

void Provider::Modification::SetType ( ModificationType type ) [inline]

The documentation for this class was generated from the following file:
  • Auxiliary/Provider.hpp
Generated on Wed Jan 25 01:41:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderChangedMsg Class Reference

#include <Apoxi/AddOns/Lcs/Common/LcsCommonMsgTypes.hpp>

Inheritance diagram for ProviderChangedMsg:

[legend]
Collaboration diagram for ProviderChangedMsg:

[legend]

Public Types

enum | { ID = 4209 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const LcsTransportType & | GetProtocol () const
LcsProviderImplBase * | GetProvider () const
ProviderChangedMsg (const LcsTransportType &protocol, LcsProviderImplBase *provider)
virtual | ~ProviderChangedMsg ()

Detailed Description

This message is sent to GltpConnApp so that it can register itself with GltpProviderImpl

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ProviderChangedMsg::ProviderChangedMsg | ( | const LcsTransportType & | protocol,
 |  | LcsProviderImplBase * | provider
 | ) |

ProviderChangedMsg::~ProviderChangedMsg ( ) [virtual]

Member Function Documentation

Message * ProviderChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ProviderChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

const LcsTransportType& ProviderChangedMsg::GetProtocol ( ) const [inline]

LcsProviderImplBase* ProviderChangedMsg::GetProvider ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/Common/LcsCommonMsgTypes.hpp
  • AddOns/Lcs/Common/LcsCommonMsgTypes.cpp
Generated on Wed Jan 25 01:41:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderListBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderListBox Class Reference

Abstract ListBox, which shows a WString row of a provider. More...

#include <Apoxi/Compat/ProviderListBox.hpp>

Inheritance diagram for ProviderListBox:

[legend]
Collaboration diagram for ProviderListBox:

[legend]

Public Member Functions

void | Init (Control *parent, Provider *provider, INT col_id)
ProviderListBox (Control *parent, Provider *provider, INT col_id)
ProviderListBox ()
virtual void | Update ()
If the provider is updated the ProviderListBox has to be updated by means of this method.
virtual | ~ProviderListBox ()

Protected Member Functions

virtual Model * | CreateModel () const

Detailed Description

Abstract ListBox, which shows a WString row of a provider.

Constructor & Destructor Documentation

ProviderListBox::ProviderListBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ProviderListBox::ProviderListBox | ( | Control * | parent,
 |  | Provider * | provider,
 |  | INT | col_id
 | ) |

ProviderListBox::~ProviderListBox ( ) [virtual]

Member Function Documentation

Model * ProviderListBox::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

void ProviderListBox::Init | ( | Control * | parent,
 |  | Provider * | provider,
 |  | INT | col_id
 | ) |

void ProviderListBox::Update ( ) [virtual]

If the provider is updated the ProviderListBox has to be updated by means of this method.

The documentation for this class was generated from the following files:
  • Compat/ProviderListBox.hpp
  • Compat/ProviderListBox.cpp
Generated on Wed Jan 25 01:41:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderListBoxModel Class Reference

Describes the model of a ProviderListBox. More...

#include <Apoxi/Compat/ProviderListBox.hpp>

Inheritance diagram for ProviderListBoxModel:

[legend]
Collaboration diagram for ProviderListBoxModel:

[legend]

Public Member Functions

virtual INT | GetColId () const
virtual Provider * | GetProvider () const
virtual BOOLEAN | GetProviderEntry (INT col_id, INT row, DataItem &item) const
void | Init (Provider *provider, INT col_id)
ProviderListBoxModel (Provider *provider, INT col_id)
ProviderListBoxModel ()
virtual void | SetColId (INT col_id)
virtual void | SetProvider (Provider *provider)
virtual void | UpdateNoOfItems ()
virtual | ~ProviderListBoxModel ()

Detailed Description

Describes the model of a ProviderListBox.

Constructor & Destructor Documentation

ProviderListBoxModel::ProviderListBoxModel ( )

ProviderListBoxModel::ProviderListBoxModel | ( | Provider * | provider,
 |  | INT | col_id
 | ) |

ProviderListBoxModel::~ProviderListBoxModel ( ) [virtual]

Member Function Documentation

INT ProviderListBoxModel::GetColId ( ) const [virtual]

virtual Provider* ProviderListBoxModel::GetProvider ( ) const [inline, virtual]

BOOLEAN ProviderListBoxModel::GetProviderEntry | ( | INT | col_id,
 |  | INT | row,
 |  | DataItem & | item
 | ) | const [virtual]

void ProviderListBoxModel::Init | ( | Provider * | provider,
 |  | INT | col_id
 | ) |

void ProviderListBoxModel::SetColId ( INT col_id ) [virtual]

void ProviderListBoxModel::SetProvider ( Provider * provider ) [virtual]

void ProviderListBoxModel::UpdateNoOfItems ( ) [virtual]

The documentation for this class was generated from the following files:
  • Compat/ProviderListBox.hpp
  • Compat/ProviderListBox.cpp
Generated on Wed Jan 25 01:41:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderListBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderListBoxView Class Reference

Describes the view of a ProviderListBox. More...

#include <Apoxi/Compat/ProviderListBox.hpp>

Inheritance diagram for ProviderListBoxView:

[legend]
Collaboration diagram for ProviderListBoxView:

[legend]

Public Member Functions

virtual void | DrawItem (const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const
ProviderListBoxView (XYDIM item_height)
ProviderListBoxView ()
virtual | ~ProviderListBoxView ()

Detailed Description

Describes the view of a ProviderListBox.

Constructor & Destructor Documentation

ProviderListBoxView::ProviderListBoxView ( )

ProviderListBoxView::ProviderListBoxView ( XYDIM item_height )

ProviderListBoxView::~ProviderListBoxView ( ) [virtual]

Member Function Documentation

void ProviderListBoxView::DrawItem | ( | const AbstractListBox & | listbox,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [virtual]

Reimplemented from AbstractListBoxView.

The documentation for this class was generated from the following files:
  • Compat/ProviderListBox.hpp
  • Compat/ProviderListBox.cpp
Generated on Wed Jan 25 01:41:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderListener Class Reference

#include <Apoxi/Auxiliary/ProviderListener.hpp>

Inheritance diagram for ProviderListener:

[legend]
Collaboration diagram for ProviderListener:

[legend]

Public Member Functions

Provider * | GetProvider () const
Returns the provider which is listened to.
virtual void | OnExecuting ()
Will be called during execution, Provider can be asked for the progress value.
virtual void | OnFinished ()
Will be called when operation is finished, can be overwritten.
virtual void | OnStarted (Provider *provider)
Will be called when operation starts, has to be overwritten but also has to be called from subclass.
ProviderListener ()
virtual | ~ProviderListener ()

Constructor & Destructor Documentation

ProviderListener::ProviderListener ( )

ProviderListener::~ProviderListener ( ) [virtual]

Member Function Documentation

Provider* ProviderListener::GetProvider ( ) const [inline]

Returns the provider which is listened to.

void ProviderListener::OnExecuting ( ) [virtual]

Will be called during execution, Provider can be asked for the progress value.

Reimplemented in JoinProviderListener, DelegationProviderListener, and PbProviderListener.

void ProviderListener::OnFinished ( ) [virtual]

Will be called when operation is finished, can be overwritten.

void ProviderListener::OnStarted ( Provider * provider ) [virtual]

Will be called when operation starts, has to be overwritten but also has to be called from subclass.

Reimplemented in PbProviderListener.

The documentation for this class was generated from the following files:
  • Auxiliary/ProviderListener.hpp
  • Auxiliary/ProviderListener.cpp
Generated on Wed Jan 25 01:42:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderProxyContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderProxyContainer Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/ProviderProxyContainer.hpp>

Inheritance diagram for ProviderProxyContainer:

[legend]
Collaboration diagram for ProviderProxyContainer:

[legend]

Public Types

enum | { ID = 105 }

Public Member Functions

virtual BOOLEAN | AddItem (Item *item)
Returns FALSE as it is not allowed to add items to the ProviderProxyContainer.
INT | GetIconColumnId () const
Returns the columnid of the provider representing the icon of the displayed items.
virtual AbstractItemContainer * | GetParentContainer ()
Returns 0, as no parent container can be set.
Provider * GetProvider ()
Returns the represented provider.
INT | GetTextColumnId () const
Returns the columnid of the provider representing the text of the displayed items.
void | Init (Dispatcher *disp, Provider *provider, const WString &text, const ImageObtainer &img_obt, INT text_col_id, INT icon_col_id=c_invalid_colid)
void | Init (Dispatcher *disp, Provider *provider, const WString &text, INT text_col_id, INT icon_col_id=c_invalid_colid)
void | Init (Dispatcher *disp, Provider *provider, INT text_col_id, INT icon_col_id=c_invalid_colid)
virtual BOOLEAN | InsertItem (INT index, Item *item)
Returns FALSE as it is not allowed to insert items to the ProviderProxyContainer.
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual void | OnUpdate (ObservableObject *obs_obj)
ProviderProxyContainer (Dispatcher *disp, Provider *provider, INT text_col_id, INT icon_col_id=c_invalid_colid)
ProviderProxyContainer ()
virtual BOOLEAN | RemoveAllItems ()
Deletes all the provider rows.
virtual BOOLEAN | RemoveItem (INT index)
Deletes the corresponding row of the provider.
void | SetIconColumnId (INT icon_col_id)
Sets the columnid of the provider for the displayed icons.
virtual BOOLEAN | SetParentContainer (AbstractItemContainer *container)
Returns FALSE, as the ProviderProxyContainer cannot have a parent container.
BOOLEAN | SetProvider (Provider *provider)
Sets the represented provider.
void | SetTextColumnId (INT text_col_id)
Sets the columnid of the provider for the displayed texts.
virtual | ~ProviderProxyContainer ()

Detailed Description

The ProviderProxyContainer is an ItemContainer that represents text and icon specified by a provider. The representation of the provider data is done by using ProviderProxyItems. The represented provider together with the columnid for text and icon has to be defined The attached provider is observed. So, if provider rows get changed, added or deleted, the number of items are adapted correspondingly and an ItemPropertiesChangeMsg is posted with the corresponding PropertyId.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from ItemContainer.

Constructor & Destructor Documentation

ProviderProxyContainer::ProviderProxyContainer ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ProviderProxyContainer::ProviderProxyContainer | ( | Dispatcher * | disp,
 |  | Provider * | provider,
 |  | INT | text_col_id,
 |  | INT | icon_col_id = c_invalid_colid
 | ) |

Parameters:
disp | Dispatcher, which will be notified when the ProviderProxyContainer changes
provider | Represented provider
text_id | Columnid of the provider defining the text of the items
icon_id | Columnid of the provider representing the icon of the items, if invalid no icons are displayed.

ProviderProxyContainer::~ProviderProxyContainer ( ) [virtual]

Member Function Documentation

BOOLEAN ProviderProxyContainer::AddItem ( Item * item ) [virtual]

Returns FALSE as it is not allowed to add items to the ProviderProxyContainer.

Reimplemented from ItemContainer.

INT ProviderProxyContainer::GetIconColumnId ( ) const [inline]

Returns the columnid of the provider representing the icon of the displayed items.

AbstractItemContainer * ProviderProxyContainer::GetParentContainer ( ) [virtual]

Returns 0, as no parent container can be set.

Reimplemented from ItemContainer.

Provider* ProviderProxyContainer::GetProvider ( ) [inline]

Returns the represented provider.

INT ProviderProxyContainer::GetTextColumnId ( ) const [inline]

Returns the columnid of the provider representing the text of the displayed items.

void ProviderProxyContainer::Init | ( | Dispatcher * | disp,
 |  | Provider * | provider,
 |  | const WString & | text,
 |  | const ImageObtainer & | img_obt,
 |  | INT | text_col_id,
 |  | INT | icon_col_id = c_invalid_colid
 | ) |

Parameters:
disp | Dispatcher, which will be notified when the ProviderProxyContainer changes
provider | Represented provider
text | Text of the ProviderProxyContainer
img_obt | Icon of the ProviderProxyContainer
text_id | Columnid of the provider representing the text of the items
icon_id | Columnid of the provider representing the icon of the items, if invalid no icons are displayed.

void ProviderProxyContainer::Init | ( | Dispatcher * | disp,
 |  | Provider * | provider,
 |  | const WString & | text,
 |  | INT | text_col_id,
 |  | INT | icon_col_id = c_invalid_colid
 | ) |

Parameters:
disp | Dispatcher, which will be notified when the ProviderProxyContainer changes
provider | Represented provider
text | Text of the ProviderProxyContainer
text_id | Columnid of the provider defining the text of the items
icon_id | Columnid of the provider representing the icon of the items, if invalid no icons are displayed.

void ProviderProxyContainer::Init | ( | Dispatcher * | disp,
 |  | Provider * | provider,
 |  | INT | text_col_id,
 |  | INT | icon_col_id = c_invalid_colid
 | ) |

Parameters:
disp | Dispatcher, which will be notified when the ProviderProxyContainer changes
provider | Represented provider
text_id | Columnid of the provider defining the text of the items
icon_id | Columnid of the provider representing the icon of the items, if invalid no icons are displayed.

BOOLEAN ProviderProxyContainer::InsertItem | ( | INT | index,
 |  | Item * | item
 | ) | [virtual]

Returns FALSE as it is not allowed to insert items to the ProviderProxyContainer.

Reimplemented from ItemContainer.

BOOLEAN ProviderProxyContainer::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from ItemContainer.

void ProviderProxyContainer::OnUpdate ( ObservableObject * obs_obj ) [virtual]

Is called, when the provider has been modified,

See also:
Observer::OnUpdate Reacts on the different types of modifications by adding or removing items. Notifications are done dependent on the provider change

Reimplemented from Observer.

BOOLEAN ProviderProxyContainer::RemoveAllItems ( ) [virtual]

Deletes all the provider rows.

Reimplemented from ItemContainer.

BOOLEAN ProviderProxyContainer::RemoveItem ( INT index ) [virtual]

Deletes the corresponding row of the provider.

Reimplemented from ItemContainer.

void ProviderProxyContainer::SetIconColumnId ( INT icon_col_id ) [inline]

Sets the columnid of the provider for the displayed icons.

BOOLEAN ProviderProxyContainer::SetParentContainer ( AbstractItemContainer * container ) [virtual]

Returns FALSE, as the ProviderProxyContainer cannot have a parent container.

Reimplemented from ItemContainer.

BOOLEAN ProviderProxyContainer::SetProvider ( Provider * provider )

Sets the represented provider.

void ProviderProxyContainer::SetTextColumnId ( INT text_col_id ) [inline]

Sets the columnid of the provider for the displayed texts.

The documentation for this class was generated from the following files:
  • Atl/Features/ProviderProxyContainer.hpp
  • Atl/Features/ProviderProxyContainer.cpp
Generated on Wed Jan 25 01:42:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderProxyItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderProxyItem Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Features/ProviderProxyItem.hpp>

Inheritance diagram for ProviderProxyItem:

[legend]
Collaboration diagram for ProviderProxyItem:

[legend]

Public Types

enum | { ID = 106 }

Public Member Functions

BOOLEAN | GetData (INT data_id, DataItem &data_item) const
virtual const ImageObtainer & | GetIcon (const IconState &icon_state) const
INT | GetItemColumnIconId (void)
INT | GetItemColumnTextId ()
Provider * GetProvider ()
Returns the represented provider.
INT | GetProviderRow () const
Returns the represented row.
virtual const WString & | GetText () const
void | Init (Dispatcher *disp, Provider *m_container, INT row=c_no_row, INT text_id=c_invalid_colid, INT icon_id=c_invalid_colid, BOOLEAN obs_prov=TRUE)
void | Init (Provider *provider, INT row=c_no_row, INT text_id=c_invalid_colid, INT icon_id=c_invalid_colid, BOOLEAN obs_prov=TRUE)
void | InvalidateIcon ()
Invalidates the icon - this leads to a provider access in GetIcon.
void | InvalidateText ()
Invalidates the text - this leads to a provider access in GetText.
virtual BOOLEAN | IsEqual (const Item &item) const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsInvalid () const
Returns TRUE if the represented row is not valid anymore. This is e.g. the case if the represented row got deleted.
void | ObserveProvider (BOOLEAN flag)
Defines if the provider should be observed or not.
virtual void | OnUpdate (ObservableObject *obs_obj)
ProviderProxyItem & | operator= (const ProviderProxyItem &ppi)
Assignment operator.
ProviderProxyItem (const ProviderProxyItem &ppi)
Copy constructor of the ProviderProxyItem class.
ProviderProxyItem (Dispatcher *disp, Provider *m_provider, INT row=c_no_row, INT text_id=c_invalid_colid, INT icon_id=c_invalid_colid, BOOLEAN obs_prov=TRUE)
ProviderProxyItem (Provider *provider, INT row=c_no_row, INT text_id=c_invalid_colid, INT icon_id=c_invalid_colid, BOOLEAN obs_prov=TRUE)
ProviderProxyItem ()
void | SetData (INT data_id, DataItem &data_item)
void | SetInvalid ()
Sets the ProviderProxyItem to invalid.
void | SetItemColumnIds (INT text_id, INT icon_id)
void | SetProvider (Provider *provider)
Sets the represented provider.
void | SetProviderRow (INT row)
virtual | ~ProviderProxyItem ()

Detailed Description

Represents a specific row of a provider. The provider and the columnids that represents text and icon has to be specified. Additionally, it can be defined, if the provider should be observed or not. If the provider is not observed, the represented row always stays the same and no notification is done, when the data of the provider row changes. Such items are e.g. used by the ProviderProxyContainer. Each ProviderProxyItem just represents a fixed provider row and the notification is handled by the ProviderProxyContainer If the provider is observed, the attached row always represents the originally specified row. A notification is done, in case the provider data representing text and icon changes. This means that if a new row is inserted to the provider, which is smaller than the observed row, the observed row is increased, to make sure that always the same data is represented. In case the observed row gets deleted, the row is set to c_no_row and the ProviderProxyItem> is set to invalid. The observed row is decreased, if a row smaller then the observed row is deleted. The provider is observed per default.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Item.

Constructor & Destructor Documentation

ProviderProxyItem::ProviderProxyItem ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

ProviderProxyItem::ProviderProxyItem | ( | Provider * | provider,
 |  | INT | row = c_no_row,
 |  | INT | text_id = c_invalid_colid,
 |  | INT | icon_id = c_invalid_colid,
 |  | BOOLEAN | obs_prov = TRUE
 | ) |

Parameters:
provider | Provider containing the row to be represented
row | Represented row, can be defined after initialization by calling SetProviderRow
text_id | Columnid of the provider representing the text of the ProviderProxyItem can be defined after construction by calling SetItemColumnIds
icon_id | Columnid of the provider representing the icon of the ProviderProxyItem can be defined after construction by calling SetItemColumnIds
obs_prov | Specifies if the provider should be observed or not. Per default the provider is observed.

ProviderProxyItem::ProviderProxyItem | ( | Dispatcher * | disp,
 |  | Provider * | m_provider,
 |  | INT | row = c_no_row,
 |  | INT | text_id = c_invalid_colid,
 |  | INT | icon_id = c_invalid_colid,
 |  | BOOLEAN | obs_prov = TRUE
 | ) |

Parameters:
disp | Dispatcher, which will be notified if text and icon of the ProviderProxyItem changes
provider | Provider containing the row to be represented
row | Represented row, can be defined after initialization by calling SetProviderRow
text_id | Columnid of the provider representing the text of the ProviderProxyItem can be defined after construction by calling SetItemColumnIds
icon_id | Columnid of the provider representing the icon of the ProviderProxyItem can be defined after construction by calling SetItemColumnIds
obs_prov | Specifies if the provider should be observed or not. Per default the provider is observed.

ProviderProxyItem::ProviderProxyItem ( const ProviderProxyItem & ppi )

Copy constructor of the ProviderProxyItem class.

ProviderProxyItem::~ProviderProxyItem ( ) [virtual]

Member Function Documentation

BOOLEAN ProviderProxyItem::GetData | ( | INT | data_id,
 |  | DataItem & | data_item
 | ) | const

Parameters:
data_id | Columnid of the provider, specifying the column from which the data should be retrieved
data_item | DataItem representing the value for the specified columnid

const ImageObtainer & ProviderProxyItem::GetIcon ( const IconState & icon_state ) const [virtual]

Parameters:
icon_state@see Gui/Item
Returns:
Icon specified by the provider for the defined row and columnid. The provider is only accessed, if the icon has been invalidated before, see InvalidateIcon If no invalidation was done, it is assumed that the data of the provider did not change. Hence, Base::GetIcon is returned.

Reimplemented from Item.

INT ProviderProxyItem::GetItemColumnIconId ( void ) [inline]

Returns:
Columnid of the provider representing the icon

INT ProviderProxyItem::GetItemColumnTextId ( ) [inline]

Returns:
Columnid of the provider representing the text

Provider* ProviderProxyItem::GetProvider ( ) [inline]

Returns the represented provider.

INT ProviderProxyItem::GetProviderRow ( ) const [inline]

Returns the represented row.

const WString & ProviderProxyItem::GetText ( ) const [virtual]

Returns:
Text specified by the provider for the defined row and columnid. The provider is only accessed, if the text has been invalidated before, see InvalidateText If no invalidation was done, it is assumed that the data of the provider did not change. Hence, Base::GetText is returned.

Reimplemented from Item.

void ProviderProxyItem::Init | ( | Dispatcher * | disp,
 |  | Provider * | m_container,
 |  | INT | row = c_no_row,
 |  | INT | text_id = c_invalid_colid,
 |  | INT | icon_id = c_invalid_colid,
 |  | BOOLEAN | obs_prov = TRUE
 | ) |

Parameters:
disp | Dispatcher, which will be notified if text and icon of the ProviderProxyItem changes
provider | Provider containing the row to be represented
row | Represented row, can be defined after initialization by calling SetProviderRow
text_id | Columnid of the provider representing the text of the ProviderProxyItem can be defined after construction by calling SetItemColumnIds
icon_id | Columnid of the provider representing the icon of the ProviderProxyItem can be defined after construction by calling SetItemColumnIds
obs_prov | Specifies if the provider should be observed or not. Per default the provider is observed.

void ProviderProxyItem::Init | ( | Provider * | provider,
 |  | INT | row = c_no_row,
 |  | INT | text_id = c_invalid_colid,
 |  | INT | icon_id = c_invalid_colid,
 |  | BOOLEAN | obs_prov = TRUE
 | ) |

Parameters:
provider | Provider containing the row to be represented
row | Represented row, can be defined after initialization by calling SetProviderRow
text_id | Columnid of the provider representing the text of the ProviderProxyItem can be defined after construction by calling SetItemColumnIds
icon_id | Columnid of the provider representing the icon of the ProviderProxyItem can be defined after construction by calling SetItemColumnIds
obs_prov | Specifies if the provider should be observed or not. Per default the provider is observed.

void ProviderProxyItem::InvalidateIcon ( )

Invalidates the icon - this leads to a provider access in GetIcon.

void ProviderProxyItem::InvalidateText ( )

Invalidates the text - this leads to a provider access in GetText.

BOOLEAN ProviderProxyItem::IsEqual ( const Item & item ) const [virtual]

See also:
Item

Reimplemented from Item.

BOOLEAN ProviderProxyItem::IsInstanceOf ( INT id ) const [virtual]

See also:
Item

Reimplemented from Item.

BOOLEAN ProviderProxyItem::IsInvalid ( ) const [inline]

Returns TRUE if the represented row is not valid anymore. This is e.g. the case if the represented row got deleted.

void ProviderProxyItem::ObserveProvider ( BOOLEAN flag )

Defines if the provider should be observed or not.

void ProviderProxyItem::OnUpdate ( ObservableObject * obs_obj ) [virtual]

Is called, when the provider has been modified,

See also:
Observer::OnUpdate Dependent on the provider change the row is adapted and notifications are done

Reimplemented from Observer.

ProviderProxyItem & ProviderProxyItem::operator= ( const ProviderProxyItem & ppi )

Assignment operator.

void ProviderProxyItem::SetData | ( | INT | data_id,
 |  | DataItem & | data_item
 | ) |

Parameters:
data_id | Columnid of the provider
data_item | DataItem specifying the value to be set to the provider

void ProviderProxyItem::SetInvalid ( )

Sets the ProviderProxyItem to invalid.

void ProviderProxyItem::SetItemColumnIds | ( | INT | text_id,
 |  | INT | icon_id
 | ) |

Parameters:
text_id | Columnid of the provider representing the text of the ProviderProxyItem
icon_id | Columnid of the provider representing the icon of the ProviderProxyItem

void ProviderProxyItem::SetProvider ( Provider * provider ) [inline]

Sets the represented provider.

void ProviderProxyItem::SetProviderRow ( INT row )

Parameters:
row Specifies the represented row

The documentation for this class was generated from the following files:
  • Atl/Features/ProviderProxyItem.hpp
  • Atl/Features/ProviderProxyItem.cpp
Generated on Wed Jan 25 01:42:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderPtr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderPtr Class Reference

#include <Apoxi/Auxiliary/MainProvider.hpp>

Inheritance diagram for ProviderPtr:

[legend]
Collaboration diagram for ProviderPtr:

[legend]

Public Member Functions

void | DecRefCount ()
INT | GetId () const
Provider * | GetProvider () const
INT | GetRefCount () const
void | IncRefCount ()
BOOLEAN | operator== (const ProviderPtr &ptr) const
ProviderPtr (Provider *provider)
ProviderPtr ()
virtual | ~ProviderPtr ()

Constructor & Destructor Documentation

ProviderPtr::ProviderPtr ( ) [inline]

ProviderPtr::ProviderPtr ( Provider * provider ) [inline]

virtual ProviderPtr::~ProviderPtr ( ) [inline, virtual]

Member Function Documentation

void ProviderPtr::DecRefCount ( ) [inline]

INT ProviderPtr::GetId ( ) const [inline]

Provider* ProviderPtr::GetProvider ( ) const [inline]

INT ProviderPtr::GetRefCount ( ) const [inline]

void ProviderPtr::IncRefCount ( ) [inline]

BOOLEAN ProviderPtr::operator== ( const ProviderPtr & ptr ) const [inline]

The documentation for this class was generated from the following file:
  • Auxiliary/MainProvider.hpp
Generated on Wed Jan 25 01:42:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProviderUpdateMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProviderUpdateMsg Class Reference

#include <Applications/AdvPhonebook/AdvPbMsgTypes.hpp>

Inheritance diagram for ProviderUpdateMsg:

[legend]
Collaboration diagram for ProviderUpdateMsg:

[legend]

Public Types

enum | { ID = 30007 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
Provider * | GetProvider () const
INT | GetState () const
ProviderUpdateMsg (ExecutionContext *context, Provider *provider, INT state)
void | SetProvider (Provider *provider)
void | SetState (INT state)
virtual | ~ProviderUpdateMsg ()

Detailed Description

Phonebook

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ProviderUpdateMsg::ProviderUpdateMsg | ( | ExecutionContext * | context,
 |  | Provider * | provider,
 |  | INT | state
 | ) |

ProviderUpdateMsg::~ProviderUpdateMsg ( ) [virtual]

Member Function Documentation

Message * ProviderUpdateMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ProviderUpdateMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

Provider* ProviderUpdateMsg::GetProvider ( ) const [inline]

INT ProviderUpdateMsg::GetState ( ) const [inline]

void ProviderUpdateMsg::SetProvider ( Provider * provider ) [inline]

void ProviderUpdateMsg::SetState ( INT state ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbMsgTypes.hpp
  • Applications/AdvPhonebook/AdvPbMsgTypes.cpp
Generated on Wed Jan 25 01:42:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ProvListBoxWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ProvListBoxWin Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/ProvListBoxWin.hpp>

Inheritance diagram for ProvListBoxWin:

[legend]
Collaboration diagram for ProvListBoxWin:

[legend]

Public Member Functions

virtual Provider * | GetProvider ()
virtual void | GetSelectedItem (INT colid, DataItem &item)
virtual INT | GetSelectedRow ()
ProvListBoxWin ()
virtual void | SetProvider (Provider *provider)
virtual void | SetSelectedRow (INT row)
virtual void | UpdateWin (BOOLEAN win_only=FALSE)
virtual | ~ProvListBoxWin ()

Protected Member Functions

virtual PbProvListBox * | GetListBox ()=0
virtual INT | GetListBoxRow (INT row)
virtual void | OnGetFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | Refresh (const Rect &rect)

Constructor & Destructor Documentation

ProvListBoxWin::ProvListBoxWin ( )

ProvListBoxWin::~ProvListBoxWin ( ) [virtual]

Member Function Documentation

virtual PbProvListBox* ProvListBoxWin::GetListBox ( ) [protected, pure virtual]

Implemented in ProvColListBoxWin, and ProvDetailListBoxWin.

INT ProvListBoxWin::GetListBoxRow ( INT row ) [protected, virtual]

Reimplemented in AdvPbWin, and PbBaseWin.

Provider * ProvListBoxWin::GetProvider ( ) [virtual]

void ProvListBoxWin::GetSelectedItem | ( | INT | colid,
 |  | DataItem & | item
 | ) | [virtual]

Implements PbAbstractWin.

INT ProvListBoxWin::GetSelectedRow ( ) [virtual]

Implements PbAbstractWin.

Reimplemented in AdvPbWin, PbAdvDetails, PbBaseWin, and ProvDetailListBoxWin.

void ProvListBoxWin::OnGetFocus ( ) [protected, virtual]

Reimplemented from PbAbstractWin.

Reimplemented in PbBaseWin, and PbDetails.

BOOLEAN ProvListBoxWin::OnMessage ( const Message & msg ) [protected, virtual]

Reimplemented in PbBaseWin.

void ProvListBoxWin::Refresh ( const Rect & rect ) [protected, virtual]

Reimplemented in ProvDetailListBoxWin.

void ProvListBoxWin::SetProvider ( Provider * provider ) [virtual]

Reimplemented in ProvDetailListBoxWin.

void ProvListBoxWin::SetSelectedRow ( INT row ) [virtual]

Reimplemented from PbAbstractWin.

void ProvListBoxWin::UpdateWin ( BOOLEAN win_only = FALSE ) [virtual]

Reimplemented from PbAbstractWin.

Reimplemented in ProvDetailListBoxWin.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/ProvListBoxWin.hpp
  • Applications/AdvPhonebook/ProvListBoxWin.cpp
Generated on Wed Jan 25 01:42:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PsdDataConn Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PsdDataConn Class Reference
[Socket]

#include <Apoxi/Socket/PsdDataConn.hpp>

Inheritance diagram for PsdDataConn:

[legend]
Collaboration diagram for PsdDataConn:

[legend]

Public Member Functions

BOOLEAN | GetDataCounters (UINT32 &session_sent, UINT32 &session_received, UINT32 &total_sent, UINT32 &total_received) const
virtual BOOLEAN | GetIpAddress (IpAddr &addr) const
virtual UINT8 | GetNsapi () const
virtual void | OnAuthenticateCompleted (PdpContext::ErrorCause cause)
virtual void | OnConnectCompleted (PdpContext::ErrorCause cause)
virtual void | OnDeactivateCompleted (PdpContext::ErrorCause cause)
virtual void | OnDeactivateIndication (PdpContext::ErrorCause cause, PdpContext::Origin origin=PdpContext::UnknownOrigin)
virtual void | OnDefineCompleted (PdpContext::ErrorCause cause)
virtual void | OnPsdLinkDownCompleted (INT error)
virtual void | OnPsdLinkUpCompleted (INT error)
virtual void | OnReadCounterCompleted (PdpContext::ErrorCause cause)
virtual void | OnReadNegotiatedDnsServerAddressCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetAutomaticDnsServerNegotiationCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetCounterCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetPacketFilterCompleted (PdpContext::ErrorCause cause)
virtual void | OnSetQualityOfServiceCompleted (PdpContext::ErrorCause cause)
virtual void | OnUndefineCompleted (PdpContext::ErrorCause cause)
BOOLEAN | SetDataCounters (UINT32 total_sent=0, UINT32 total_received=0)

Protected Member Functions

void | Authenticate ()
virtual void | Cleanup ()
void | Connect ()
void | CreatePdpContext ()
virtual BOOLEAN | DataConnIsBlocked () const
void | DeactivateContext ()
void | DefinePdpContext ()
virtual void | DoRelease ()
virtual void | DoSetup ()
void | LinkDown ()
void | LinkUp ()
const PsdDataConnProfile & | MyProfile () const
void | OnReleaseResponse (PdpContext::ErrorCause cause, SocketControlMsgType success_scmt, DataConnCtrlCb on_release_callback)
void | OnSetupResponse (PdpContext::ErrorCause cause, SocketControlMsgType success_scmt, DataConnCtrlCb on_success_callback)
virtual void | PostInfoMsg (MessageType type) const
PsdDataConn (const DataConnProfilePtr &profile)
void | ReadNegotiatedDnsServerAddress ()
void | SetAutomaticDnsServerNegotiation ()
void | SetPacketFilter ()
void | SetQualityOfService ()
void | UndefineContext ()
virtual | ~PsdDataConn ()

Protected Attributes

BOOLEAN | m_context_active
Context is active.
BOOLEAN | m_context_defined
Context is defined.
PdpContext * m_pdp_context
PDP context of PSD connection.
PdpContext::ErrorCause m_pdp_error
Error code of last operation.
BOOLEAN | m_psd_linked_up
The connection is linked up.

Friends

class | DataConnProfile
class | NiSharedPtr< DataConn >
class | PsdDataConnCtrlCbs

Constructor & Destructor Documentation

PsdDataConn::PsdDataConn ( const DataConnProfilePtr & profile ) [protected]

Creates a PSD data connection which uses profile on setup. The given profile smart pointer must be valid, otherwise an assertion holds.

PsdDataConn::~PsdDataConn ( ) [protected, virtual]

Member Function Documentation

void PsdDataConn::Authenticate ( ) [protected]

void PsdDataConn::Cleanup ( ) [protected, virtual]

Cleans up the internals to virginal state.

Reimplemented from DataConn.

void PsdDataConn::Connect ( ) [protected]

void PsdDataConn::CreatePdpContext ( ) [protected]

BOOLEAN PsdDataConn::DataConnIsBlocked ( ) const [protected, virtual]

If there are some special conditions which block the data connection from being setup, override this method and return TRUE in case. You also have to post a DataConnInfoMsg indicating the reason for blocking in order to inform the context for it can react accordingly.

Reimplemented from DataConn.

void PsdDataConn::DeactivateContext ( ) [protected]

void PsdDataConn::DefinePdpContext ( ) [protected]

void PsdDataConn::DoRelease ( ) [protected, virtual]

Asynchronous data connection release request.

Implements DataConn.

virtual void PsdDataConn::DoSetup ( ) [inline, protected, virtual]

Asynchronous data connection setup request.

Implements DataConn.

BOOLEAN PsdDataConn::GetDataCounters | ( | UINT32 & | session_sent,
 |  | UINT32 & | session_received,
 |  | UINT32 & | total_sent,
 |  | UINT32 & | total_received
 | ) | const

Returns the current data counters per session and in total.

BOOLEAN PsdDataConn::GetIpAddress ( IpAddr & addr ) const [virtual]

Retrieves the IP address that is currently assigned to this PSD data connection. If the PSD connection is currently not up and running and hence no address can be retrieved then FALSE will be returned. Actually, the IP address can only be retrieved if the data connection is in state st_active.

Implements DataConn.

UINT8 PsdDataConn::GetNsapi ( ) const [virtual]

Returns the network service access point identifier of the PDP context used. Note: This method must only be invoked if the data connection is active.

Reimplemented from DataConn.

void PsdDataConn::LinkDown ( ) [protected]

void PsdDataConn::LinkUp ( ) [protected]

const PsdDataConnProfile& PsdDataConn::MyProfile ( ) const [inline, protected]

Reimplemented from DataConn.

void PsdDataConn::OnAuthenticateCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Authenticate().

Reimplemented from PdpContextControl.

void PsdDataConn::OnConnectCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Connect().

Reimplemented from PdpContextControl.

void PsdDataConn::OnDeactivateCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Deactivate().

Reimplemented from PdpContextControl.

void PsdDataConn::OnDeactivateIndication | ( | PdpContext::ErrorCause | cause,
 |  | PdpContext::Origin | origin = PdpContext::UnknownOrigin
 | ) | [virtual]

Invoked upon receipt of the stack indication of an unsolicited context deactivation event.

Reimplemented from PdpContextControl.

void PsdDataConn::OnDefineCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Define().

Reimplemented from PdpContextControl.

void PsdDataConn::OnPsdLinkDownCompleted ( INT error ) [virtual]

void PsdDataConn::OnPsdLinkUpCompleted ( INT error ) [virtual]

void PsdDataConn::OnReadCounterCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::ReadCounter().

Reimplemented from PdpContextControl.

void PsdDataConn::OnReadNegotiatedDnsServerAddressCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::ReadNegotiatedDnsServerAddress().

Reimplemented from PdpContextControl.

void PsdDataConn::OnReleaseResponse | ( | PdpContext::ErrorCause | cause,
 |  | SocketControlMsgType | success_scmt,
 |  | DataConnCtrlCb | on_release_callback
 | ) | [protected]

void PsdDataConn::OnSetAutomaticDnsServerNegotiationCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetAutomaticDnsServerNegotiation().

Reimplemented from PdpContextControl.

void PsdDataConn::OnSetCounterCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetCounter().

Reimplemented from PdpContextControl.

void PsdDataConn::OnSetPacketFilterCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetPacketFilter().

Reimplemented from PdpContextControl.

void PsdDataConn::OnSetQualityOfServiceCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::SetQualityOfService().

Reimplemented from PdpContextControl.

void PsdDataConn::OnSetupResponse | ( | PdpContext::ErrorCause | cause,
 |  | SocketControlMsgType | success_scmt,
 |  | DataConnCtrlCb | on_success_callback
 | ) | [protected]

void PsdDataConn::OnUndefineCompleted ( PdpContext::ErrorCause cause ) [virtual]

Invoked upon receipt of the stack response of previously submitted PdpContext::Undefine().

Reimplemented from PdpContextControl.

void PsdDataConn::PostInfoMsg ( MessageType type ) const [protected, virtual]

void PsdDataConn::ReadNegotiatedDnsServerAddress ( ) [protected]

void PsdDataConn::SetAutomaticDnsServerNegotiation ( ) [protected]

BOOLEAN PsdDataConn::SetDataCounters | ( | UINT32 | total_sent = 0,
 |  | UINT32 | total_received = 0
 | ) |

Sets the total data counters to the given values and resets the session counters back to 0.

void PsdDataConn::SetPacketFilter ( ) [protected]

void PsdDataConn::SetQualityOfService ( ) [protected]

void PsdDataConn::UndefineContext ( ) [protected]

Friends And Related Function Documentation

friend class DataConnProfile [friend]

Reimplemented from DataConn.

friend class NiSharedPtr< DataConn > [friend]

Reimplemented from DataConn.

friend class PsdDataConnCtrlCbs [friend]

Field Documentation

BOOLEAN PsdDataConn::m_context_active [protected]

Context is active.

BOOLEAN PsdDataConn::m_context_defined [protected]

Context is defined.

PdpContext* PsdDataConn::m_pdp_context [protected]

PDP context of PSD connection.

Reimplemented from PdpContextControl.

PdpContext::ErrorCause PsdDataConn::m_pdp_error [protected]

Error code of last operation.

BOOLEAN PsdDataConn::m_psd_linked_up [protected]

The connection is linked up.

The documentation for this class was generated from the following files:
  • Socket/PsdDataConn.hpp
  • Socket/PsdDataConn.cpp
Generated on Wed Jan 25 01:42:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PsdDataConnAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PsdDataConnAccessor Class Reference
[DataConn]

#include <Applications/DataConn/DataConnAccessor.hpp>

Inheritance diagram for PsdDataConnAccessor:

[legend]
Collaboration diagram for PsdDataConnAccessor:

[legend]

Public Member Functions

virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
void | Init ()
PsdDataConnAccessor (PsdDataConnProfile *profile)
virtual void | Update ()
virtual | ~PsdDataConnAccessor ()

Protected Member Functions

virtual INT | CountSettings () const
virtual void | OnTrigger (INT selected_idx)

Constructor & Destructor Documentation

PsdDataConnAccessor::PsdDataConnAccessor ( PsdDataConnProfile * profile )

PsdDataConnAccessor::~PsdDataConnAccessor ( ) [virtual]

Member Function Documentation

INT PsdDataConnAccessor::CountSettings ( ) const [protected, virtual]

Reimplemented from DataConnAccessor.

const WCHAR * PsdDataConnAccessor::GetItemText ( BOOLEAN highlighted ) [virtual]

Reimplemented from DataConnAccessor.

void PsdDataConnAccessor::Init ( )

Reimplemented from DataConnAccessor.

void PsdDataConnAccessor::OnTrigger ( INT selected_idx ) [protected, virtual]

Reimplemented from DataConnAccessor.

void PsdDataConnAccessor::Update ( ) [virtual]

Reimplemented from DataConnAccessor.

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnAccessor.hpp
  • Applications/DataConn/DataConnAccessor.cpp
Generated on Wed Jan 25 01:42:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PsdDataConnProfile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PsdDataConnProfile Class Reference
[Socket]

#include <Apoxi/Socket/PsdDataConnProfile.hpp>

Inheritance diagram for PsdDataConnProfile:

[legend]
Collaboration diagram for PsdDataConnProfile:

[legend]

Public Types

typedef PdpContext::Authentication::Type | AuthType
typedef PdpContext::QualityOfService::Delay | QosDelay
typedef PdpContext::QualityOfService::MeanRate | QosMeanRate
typedef PdpContext::QualityOfService::PeakRate | QosPeakRate
typedef PdpContext::QualityOfService::Precedence | QosPrecedence
typedef PdpContext::QualityOfService::Reliability | QosReliability

Public Member Functions

BOOLEAN | DoDataCompr () const
BOOLEAN | DoHeaderCompr () const
void | EnableDataCompr (BOOLEAN enable=TRUE)
void | EnableHeaderCompr (BOOLEAN enable=TRUE)
const String & | GetApnName () const
AuthType | GetAuthType () const
const IpAddr & | GetLocalAddr () const
PdpPacketFilterPtr | GetPacketFilter (UINT8 id) const
DataConnProfileId | GetPrimaryProfileId () const
QosDelay | GetQosDelay () const
QosMeanRate | GetQosMeanRate () const
QosPeakRate | GetQosPeakRate () const
QosPrecedence | GetQosPrecedence () const
QosReliability | GetQosReliability () const
PsdDataConnProfile ()
void | SetApnName (const String &apn)
void | SetAuthType (AuthType at)
void | SetLocalAddr (const IpAddr &local)
BOOLEAN | SetPacketFilter (const PdpPacketFilterPtr &filter)
BOOLEAN | SetPrimaryProfileId (DataConnProfileId profile_id)
void | SetQosDelay (QosDelay qd)
void | SetQosMeanRate (QosMeanRate qmr)
void | SetQosPeakRate (QosPeakRate qpr)
void | SetQosPrecedence (QosPrecedence qp)
void | SetQosReliability (QosReliability qr)
BOOLEAN | UnsetPacketFilter (UINT8 id)
BOOLEAN | UsesSecondaryPdpContext () const
virtual | ~PsdDataConnProfile ()

Protected Member Functions

virtual void | Assign (const DataConnProfile &from_dcp)
virtual DataConnProfile * | New () const
virtual void | SaveFrom (const PersistDataConnProfile &bpp)
virtual void | SaveTo (PersistDataConnProfile &bpp) const

Data Structures

struct | Bit
struct | Persist

Detailed Description

Packet switched bearer profile. Use this profile type to define PSD data connections (i.e. context).

Member Typedef Documentation

typedef PdpContext::Authentication::Type PsdDataConnProfile::AuthType

typedef PdpContext::QualityOfService::Delay PsdDataConnProfile::QosDelay

typedef PdpContext::QualityOfService::MeanRate PsdDataConnProfile::QosMeanRate

typedef PdpContext::QualityOfService::PeakRate PsdDataConnProfile::QosPeakRate

typedef PdpContext::QualityOfService::Precedence PsdDataConnProfile::QosPrecedence

typedef PdpContext::QualityOfService::Reliability PsdDataConnProfile::QosReliability

Constructor & Destructor Documentation

PsdDataConnProfile::PsdDataConnProfile ( )

PsdDataConnProfile::~PsdDataConnProfile ( ) [virtual]

Member Function Documentation

void PsdDataConnProfile::Assign ( const DataConnProfile & from_dcp ) [protected, virtual]

Copies and sets all properties of the given data connection profile object, especially used for cloning.

Reimplemented from DataConnProfile.

BOOLEAN PsdDataConnProfile::DoDataCompr ( ) const [inline]

TRUE if data compression is enabled (currently not supported).

BOOLEAN PsdDataConnProfile::DoHeaderCompr ( ) const [inline]

TRUE if header compression is enabled (currently not supported).

void PsdDataConnProfile::EnableDataCompr ( BOOLEAN enable = TRUE ) [inline]

Enable/disable compressed data transfer.

void PsdDataConnProfile::EnableHeaderCompr ( BOOLEAN enable = TRUE ) [inline]

Enable/disable header compression.

const String& PsdDataConnProfile::GetApnName ( ) const [inline]

Return name of APN.

AuthType PsdDataConnProfile::GetAuthType ( ) const [inline]

Return authentication type.

const IpAddr& PsdDataConnProfile::GetLocalAddr ( ) const [inline]

Returns local IP address. Note that it does not return the dynamically assigned IP address. Only applicable in networks with fixed IP address configuration.

PdpPacketFilterPtr PsdDataConnProfile::GetPacketFilter ( UINT8 id ) const

Returns the packet filter identified by id. Valid IDs are values from 1 to 8. If the ID is out of range or no packet filter with id is set, then the empty shared pointer is returned.

DataConnProfileId PsdDataConnProfile::GetPrimaryProfileId ( ) const [inline]

Returns the profile ID of the PSD data connection whose primary PDP context shall be used to define a PSD data connection using a secondary PDP context. If this is the invalid profile ID (c_invalid_data_conn_profile_id) then this profile defines a PSD data connection using a primary PDP context.

QosDelay PsdDataConnProfile::GetQosDelay ( ) const [inline]

QosMeanRate PsdDataConnProfile::GetQosMeanRate ( ) const [inline]

QosPeakRate PsdDataConnProfile::GetQosPeakRate ( ) const [inline]

QosPrecedence PsdDataConnProfile::GetQosPrecedence ( ) const [inline]

QosReliability PsdDataConnProfile::GetQosReliability ( ) const [inline]

DataConnProfile * PsdDataConnProfile::New ( ) const [protected, virtual]

Return a new data connection profile object based on the current dynamic type.

Implements DataConnProfile.

void PsdDataConnProfile::SaveFrom ( const PersistDataConnProfile & bpp ) [protected, virtual]

Reimplemented from DataConnProfile.

void PsdDataConnProfile::SaveTo ( PersistDataConnProfile & bpp ) const [protected, virtual]

Reimplemented from DataConnProfile.

void PsdDataConnProfile::SetApnName ( const String & apn ) [inline]

Set APN name. Length restrictions apply according to c_apn_name_len_max.

void PsdDataConnProfile::SetAuthType ( AuthType at ) [inline]

Set authentication type.

void PsdDataConnProfile::SetLocalAddr ( const IpAddr & local ) [inline]

Set local IP address. On context activation the defined address will be used for sending IP packets.

BOOLEAN PsdDataConnProfile::SetPacketFilter ( const PdpPacketFilterPtr & filter )

Sets the packet filter. The filter itself defines its ID which must be a value from 1 to 8. If a packet filter already exists for a specific ID, then it is simply overridden. If and only if the ID is out of range, then FALSE is returned, otherwise TRUE is returned.

See also:
PdpContext::PacketFilter::GetId()

BOOLEAN PsdDataConnProfile::SetPrimaryProfileId ( DataConnProfileId profile_id )

This method is only used for defining a PSD data connection which shall use a secondary PDP context. It sets the profile ID of the PSD data connection whose PDP context shall be used as primary PDP context. If the primary profile_id provided is not the profile ID of a PSD data connection using a primary PDP context, then FALSE is returned.

void PsdDataConnProfile::SetQosDelay ( QosDelay qd ) [inline]

void PsdDataConnProfile::SetQosMeanRate ( QosMeanRate qmr ) [inline]

void PsdDataConnProfile::SetQosPeakRate ( QosPeakRate qpr ) [inline]

void PsdDataConnProfile::SetQosPrecedence ( QosPrecedence qp ) [inline]

void PsdDataConnProfile::SetQosReliability ( QosReliability qr ) [inline]

BOOLEAN PsdDataConnProfile::UnsetPacketFilter ( UINT8 id )

Unsets the packet filter identified by id. Valid IDs are values from 1 to 8. If and only if the ID is out of range, then FALSE is returned, otherwise TRUE is returned.

See also:
PdpContext::PacketFilter::GetId()

BOOLEAN PsdDataConnProfile::UsesSecondaryPdpContext ( ) const [inline]

Tells if this PSD data connection profile uses a secondary PDP context. This is determined by checking if a primary profile ID is set. Only PSD data connections using a secondary PDP context define a primary profile ID, since a secondary PDP context needs a primary PDP context on which it is based on.

The documentation for this class was generated from the following files:
  • Socket/PsdDataConnProfile.hpp
  • Socket/PsdDataConnProfile.cpp
Generated on Wed Jan 25 01:42:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PsdDataConnProfile::Bit Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PsdDataConnProfile::Bit

PsdDataConnProfile::Bit Struct Reference

#include <Apoxi/Socket/PsdDataConnProfile.hpp>

Data Fields

UINT | m_auth_type: 2
UINT | m_data_compr: 1
UINT | m_header_compr: 1
UINT | m_qos_delay: 3
UINT | m_qos_mean_rate: 5
UINT | m_qos_peak_rate: 4
UINT | m_qos_precedence: 2
UINT | m_qos_reliability: 3

Field Documentation

UINT PsdDataConnProfile::Bit::m_auth_type

UINT PsdDataConnProfile::Bit::m_data_compr

UINT PsdDataConnProfile::Bit::m_header_compr

UINT PsdDataConnProfile::Bit::m_qos_delay

UINT PsdDataConnProfile::Bit::m_qos_mean_rate

UINT PsdDataConnProfile::Bit::m_qos_peak_rate

UINT PsdDataConnProfile::Bit::m_qos_precedence

UINT PsdDataConnProfile::Bit::m_qos_reliability

The documentation for this struct was generated from the following file:
  • Socket/PsdDataConnProfile.hpp
Generated on Wed Jan 25 01:42:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PsdDataConnProfile::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
PsdDataConnProfile::Persist

PsdDataConnProfile::Persist Struct Reference

#include <Apoxi/Socket/PsdDataConnProfile.hpp>

Collaboration diagram for PsdDataConnProfile::Persist:

[legend]

Data Fields

CHAR m_apn [c_apn_name_len_max+1]
Bit m_bit
IpAddr::Persist m_local

Field Documentation

CHAR PsdDataConnProfile::Persist::m_apn[c_apn_name_len_max+1]

Bit PsdDataConnProfile::Persist::m_bit

IpAddr::Persist PsdDataConnProfile::Persist::m_local

The documentation for this struct was generated from the following file:
  • Socket/PsdDataConnProfile.hpp
Generated on Wed Jan 25 01:42:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PsdDataConnProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PsdDataConnProvider Class Reference
[Dataconn]

#include <Applications/DataConn/PsdDataConnProvider.hpp>

Inheritance diagram for PsdDataConnProvider:

[legend]
Collaboration diagram for PsdDataConnProvider:

[legend]

Public Types

typedef DataConnProvider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
PsdDataConnProvider ()
virtual BOOLEAN | SetDataItem (const DataItem &item, INT column)
SetDataItem sets data items
virtual | ~PsdDataConnProvider ()
Destructor.

Protected Member Functions

virtual void | ClearProfile ()
virtual DataConnProfile * | GetProfileInstance ()

Member Typedef Documentation

typedef DataConnProvider PsdDataConnProvider::Base

Reimplemented from DataConnProvider.

Constructor & Destructor Documentation

PsdDataConnProvider::PsdDataConnProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

PsdDataConnProvider::~PsdDataConnProvider ( ) [virtual]

Destructor.

Member Function Documentation

void PsdDataConnProvider::ClearProfile ( ) [protected, virtual]

Implements DataConnProvider.

BOOLEAN PsdDataConnProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Reimplemented from DataConnProvider.

virtual DataConnProfile* PsdDataConnProvider::GetProfileInstance ( ) [inline, protected, virtual]

Implements DataConnProvider.

virtual INT PsdDataConnProvider::GetProviderId ( ) const [inline, virtual]

Returns the provider id.

Reimplemented from DataConnProvider.

BOOLEAN PsdDataConnProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | column
 | ) | [virtual]

SetDataItem sets data items

Reimplemented from DataConnProvider.

The documentation for this class was generated from the following files:
  • Applications/DataConn/PsdDataConnProvider.hpp
  • Applications/DataConn/PsdDataConnProvider.cpp
Generated on Wed Jan 25 01:42:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PsdSettingsTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PsdSettingsTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for PsdSettingsTable:

[legend]
Collaboration diagram for PsdSettingsTable:

[legend]

Static Public Member Functions

static const WCHAR * GetSetting (DataConnApp::PsdSettingsTypeId setting)

Member Function Documentation

static const WCHAR* PsdSettingsTable::GetSetting ( DataConnApp::PsdSettingsTypeId setting ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:42:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PsLociData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PsLociData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [14]

Field Documentation

UINT8 PsLociData::val[14]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:42:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Puct Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Puct Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [5]

Field Documentation

UINT8 Puct::val[5]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:42:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PushButton Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PushButton Class Reference
[Components]

#include <Apoxi/Gui/PushButton.hpp>

Inheritance diagram for PushButton:

[legend]
Collaboration diagram for PushButton:

[legend]

Public Types

enum | { ID = 20 }

Public Member Functions

Action * | GetAction () const
Returns a pointer to the action which will be executed if the button has been released.
void | Init (Control *parent, Action *action)
virtual BOOLEAN | IsInstanceOf (INT id) const
PushButton (Control *parent, Action *action)
PushButton ()
void | SetAction (Action *action)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
virtual | ~PushButton ()

Protected Member Functions

virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Detailed Description

A PushButton is a control, which is used to fire an action after pressing.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractButton.

Constructor & Destructor Documentation

PushButton::PushButton ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

PushButton::PushButton | ( | Control * | parent,
 |  | Action * | action
 | ) |

Parameters:
parent | Pointer to the window, which embedds the PushButton.
action | Action, which will be executed, if the button has been released.

PushButton::~PushButton ( ) [virtual]

Member Function Documentation

Action* PushButton::GetAction ( ) const [inline]

Returns a pointer to the action which will be executed if the button has been released.

Reimplemented from AbstractButton.

void PushButton::Init | ( | Control * | parent,
 |  | Action * | action
 | ) |

Parameters:
parent | Pointer to the window, which embedds the PushButton.
action | Action, which will be executed, if the button has been released.

Reimplemented from AbstractButton.

BOOLEAN PushButton::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractButton.

void PushButton::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from Control.

void PushButton::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from Control.

void PushButton::SetAction ( Action * action ) [inline]

Sets the action which will be executed if the button has been released.

Reimplemented from AbstractButton.

BOOLEAN PushButton::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from AbstractButton.

The documentation for this class was generated from the following files:
  • Gui/PushButton.hpp
  • Gui/PushButton.cpp
Generated on Wed Jan 25 01:42:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: PushButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

PushButtonView Class Reference
[Components]

Describes the view of a pushbutton. More...

#include <Apoxi/Gui/PushButton.hpp>

Inheritance diagram for PushButtonView:

[legend]
Collaboration diagram for PushButtonView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
PushButtonView (XYDIM default_height)
PushButtonView ()
virtual | ~PushButtonView ()

Protected Member Functions

virtual void | DrawPushButton (const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const =0

Detailed Description

Describes the view of a pushbutton.

Constructor & Destructor Documentation

PushButtonView::PushButtonView ( )

PushButtonView::PushButtonView ( XYDIM default_height )

PushButtonView::~PushButtonView ( ) [virtual]

Member Function Documentation

void PushButtonView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

virtual void PushButtonView::DrawPushButton | ( | const PushButton & | push_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Implemented in BlueSkyPushButtonView, DefaultPushButtonView, TestPushButtonView, CTPushButtonView, DefaultPushButtonView, and FoggyPushButtonView.

The documentation for this class was generated from the following files:
  • Gui/PushButton.hpp
  • Gui/PushButton.cpp
Generated on Wed Jan 25 01:42:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: QuickSortProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

QuickSortProvider Class Reference

#include <Apoxi/Auxiliary/QuickSortProvider.hpp>

Inheritance diagram for QuickSortProvider:

[legend]
Collaboration diagram for QuickSortProvider:

[legend]

Public Types

typedef SortProvider | Base

Public Member Functions

void | Init (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
The same interface as the constructor.
QuickSortProvider (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
QuickSortProvider ()
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and executes the sort process.
virtual | ~QuickSortProvider ()
Descrutor.

Protected Member Functions

virtual void | QuickSort (INT left, INT right, INT &depth)
void | QuickSortNumber (INT left, INT right, INT &depth)
void | QuickSortWString (INT left, INT right, INT &depth)

Protected Attributes

IndexTable< INT > | m_sortbuffer

Detailed Description

A QuickSortProvider is used to sort rows of a child provider with the quick sort algorithm.

Member Typedef Documentation

typedef SortProvider QuickSortProvider::Base

Reimplemented from SortProvider.

Reimplemented in CachingSortProvider, ChineseQuickSortProvider, and PbSortedProvider.

Constructor & Destructor Documentation

QuickSortProvider::QuickSortProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

QuickSortProvider::QuickSortProvider | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be sorted. columnid: Specify which columnid has to be sorted. order: Specify whether ascending (TRUE) or descending (FALSE).

QuickSortProvider::~QuickSortProvider ( ) [virtual]

Descrutor.

Member Function Documentation

void QuickSortProvider::Init | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

The same interface as the constructor.

Reimplemented from SortProvider.

Reimplemented in CachingSortProvider.

void QuickSortProvider::QuickSort | ( | INT | left,
 |  | INT | right,
 |  | INT & | depth
 | ) | [protected, virtual]

Reimplemented in ChineseQuickSortProvider.

void QuickSortProvider::QuickSortNumber | ( | INT | left,
 |  | INT | right,
 |  | INT & | depth
 | ) | [protected]

void QuickSortProvider::QuickSortWString | ( | INT | left,
 |  | INT | right,
 |  | INT & | depth
 | ) | [protected]

BOOLEAN QuickSortProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and executes the sort process.

Implements SortProvider.

Reimplemented in CachingSortProvider, ChineseQuickSortProvider, and PbSortedProvider.

Field Documentation

IndexTable<INT> QuickSortProvider::m_sortbuffer [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/QuickSortProvider.hpp
  • Auxiliary/QuickSortProvider.cpp
Generated on Wed Jan 25 01:42:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: QuotedPrintableCoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

QuotedPrintableCoder Class Reference

#include <Apoxi/AddOns/AuxExtensions/MimeCoding.hpp>

Inheritance diagram for QuotedPrintableCoder:

[legend]
Collaboration diagram for QuotedPrintableCoder:

[legend]

Public Member Functions

INT | DecodeChar (CHAR data)
INT | DecodeEnd ()
BOOLEAN | DecodePush (CHAR data)
BOOLEAN | EncodeChar (CHAR data, BOOLEAN last, BOOLEAN coded=TRUE)
INT | EncodeEnd ()
BOOLEAN | EncodePush (CHAR data, BOOLEAN last)
QuotedPrintableCoder (CHAR *buffer=0, INT buffer_length=0, BOOLEAN is_text=TRUE)

Constructor & Destructor Documentation

QuotedPrintableCoder::QuotedPrintableCoder | ( | CHAR * | buffer = 0,
 |  | INT | buffer_length = 0,
 |  | BOOLEAN | is_text = TRUE
 | ) |

Member Function Documentation

INT QuotedPrintableCoder::DecodeChar ( CHAR data )

INT QuotedPrintableCoder::DecodeEnd ( )

BOOLEAN QuotedPrintableCoder::DecodePush ( CHAR data )

BOOLEAN QuotedPrintableCoder::EncodeChar | ( | CHAR | data,
 |  | BOOLEAN | last,
 |  | BOOLEAN | coded = TRUE
 | ) |

INT QuotedPrintableCoder::EncodeEnd ( )

BOOLEAN QuotedPrintableCoder::EncodePush | ( | CHAR | data,
 |  | BOOLEAN | last
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/MimeCoding.hpp
  • AddOns/AuxExtensions/MimeCoding.cpp
Generated on Wed Jan 25 01:42:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioAudioDevice Class Reference
[Audio]

APOXI interface to FM Radio device. More...

#include <Apoxi/Audio/RadioAudioDevice.hpp>

Inheritance diagram for RadioAudioDevice:

[legend]
Collaboration diagram for RadioAudioDevice:

[legend]

Public Types

enum | AudioChannel { AudioChannelLeft, AudioChannelRight, AudioChannelBoth }
Audio channels of FM Radio. More...
enum | BandLimits { BandLimitsEuropeUs = 0, BandLimitsJapan = 1 }
Band limits for station search. Currently band limits for Europe/US and Japan are supported. More...
enum | NotificationType { NotificationTypeStationFound, NotificationTypeBandLimitsReached }
Message Type of the AudioRadioDeviceNotificationMsg message. More...
enum | SearchStopLevel { SearchStopLevelLow, SearchStopLevelMid, SearchStopLevelHigh }
Search stop level used for automatic seeking. More...
enum | SeekDirection { SeekDirectionUp, SeekDirectionDown }
Seek direction for station search. More...
enum | SeekMode { SeekModeAuto, SeekModeManual }
Seek mode for station search. In manual mode, the frequency is shifted in steps of 0.1 MHz. More...
enum | StereoMode { ModeStereo = 0, ModeMono = 1 }
Stereo modes of FM Radio (stereo/mono). More...

Public Member Functions

virtual BOOLEAN | Disable ()
Disable FM Radio (turn off).
virtual BOOLEAN | Enable (BOOLEAN suspend_all_others=FALSE)
Enable FM Radio (turn it on).
RadioAudioDevice::BandLimits | GetBandLimits () const
Get current radio reception band limits.
BOOLEAN | GetChannelMuteState (RadioAudioDevice::AudioChannel channel=RadioAudioDevice::AudioChannelBoth) const
Get mute state of a channel.
BOOLEAN | GetHighCutControl () const
Get High Cut Control (HCC) state.
BOOLEAN | GetHighLowSideLoInjection () const
Get High/Low Side LO Injection state.
RadioAudioDevice::SearchStopLevel | GetSearchStopLevel () const
Get current search stop level.
RadioAudioDevice::AudioChannel | GetSelectedMuteChannel () const
Get selected channel to mute.
virtual AudioSourceType | GetSource () const
Get source type of the AudioDevice.
BOOLEAN | GetStationInfo (RadioAudioDevice::StationInfo &info)
Get current station information.
RadioAudioDevice::StereoMode | GetStereoMode () const
Get current stereo mode.
BOOLEAN | SeekStation (RadioAudioDevice::SeekDirection direction, RadioAudioDevice::SeekMode mode)
Seek station.
BOOLEAN | SelectMuteChannel (RadioAudioDevice::AudioChannel channel=RadioAudioDevice::AudioChannelBoth)
Select the channel to mute.
BOOLEAN | SetBandLimits (RadioAudioDevice::BandLimits limits)
Set radio reception band limits .
BOOLEAN | SetHighCutControl (BOOLEAN hcc_on=TRUE)
Set High Cut Control (HCC) state.
BOOLEAN | SetHighLowSideLoInjection (BOOLEAN high=TRUE)
Set High/Low Side LO Injection.
virtual BOOLEAN | SetMute (BOOLEAN enable=TRUE, MuteDirection direction=UpDownlinkDirection)
Mute selected channels.
BOOLEAN | SetSearchStopLevel (RadioAudioDevice::SearchStopLevel level)
Set search stop level used for seeking.
BOOLEAN | SetStation (UINT32 frequency)
Set station.
BOOLEAN | SetStereoMode (RadioAudioDevice::StereoMode mode=RadioAudioDevice::ModeStereo)
Set stereo mode.
virtual | ~RadioAudioDevice ()
Destructs the RadioAudioDevice.

Static Public Member Functions

static RadioAudioDevice & | GetInstance ()
Get singleton instance of RadioAudioDevice.

Friends

class | DwdPlayer

Data Structures

struct | StationInfo
Structure for info about a station. More...

Detailed Description

APOXI interface to FM Radio device.

Class RadioAudioDevice provides an interface for the FM Radio device. It supports all functions needed to operate the FM Radio.

ATTENTION: Be aware that no other sound can be heard if the FM Radio device is enabled. As a consequence, the FM Radio device has to be disabled first, before any other sound can be played.

Member Enumeration Documentation

enum RadioAudioDevice::AudioChannel

Audio channels of FM Radio.

Enumerator:
AudioChannelLeft
AudioChannelRight
AudioChannelBoth

enum RadioAudioDevice::BandLimits

Band limits for station search. Currently band limits for Europe/US and Japan are supported.

Enumerator:
BandLimitsEuropeUs
BandLimitsJapan

enum RadioAudioDevice::NotificationType

Message Type of the AudioRadioDeviceNotificationMsg message.

Enumerator:
NotificationTypeStationFound
NotificationTypeBandLimitsReached

enum RadioAudioDevice::SearchStopLevel

Search stop level used for automatic seeking.

Enumerator:
SearchStopLevelLow
SearchStopLevelMid
SearchStopLevelHigh

enum RadioAudioDevice::SeekDirection

Seek direction for station search.

Enumerator:
SeekDirectionUp
SeekDirectionDown

enum RadioAudioDevice::SeekMode

Seek mode for station search. In manual mode, the frequency is shifted in steps of 0.1 MHz.

Enumerator:
SeekModeAuto
SeekModeManual

enum RadioAudioDevice::StereoMode

Stereo modes of FM Radio (stereo/mono).

Enumerator:
ModeStereo
ModeMono

Constructor & Destructor Documentation

RadioAudioDevice::~RadioAudioDevice ( ) [virtual]

Destructs the RadioAudioDevice.

Member Function Documentation

BOOLEAN RadioAudioDevice::Disable ( ) [virtual]

Disable FM Radio (turn off).

Bring the FM Radio device from Started to Idle mode. This powers down the FM Radio device and reads the current settings from the FM Radio device into RAM. The settings are lost if the mobile station is turned off. When the device is disabled, a AudioDeviceStatusMsg is sent to all applications to inform them, that the FM radio has been disabled.

Returns:
TRUE if succesful, FALSE otherwise.

Implements SimpleAudioDevice.

BOOLEAN RadioAudioDevice::Enable ( BOOLEAN suspend_all_others = FALSE ) [virtual]

Enable FM Radio (turn it on).

Sets the FM Radio device from Idle to Started mode. This powers up the FM Radio device and configures it using the settings given previously by the configuration methods or read from non-volatile memory at last init. When the device is enabled, a AudioDeviceStatusMsg is sent to all applications to inform them, that the FM radio has been enabled.

Returns:
TRUE if succesful, FALSE otherwise.

Implements SimpleAudioDevice.

RadioAudioDevice::BandLimits RadioAudioDevice::GetBandLimits ( ) const

Get current radio reception band limits.

This function returns the current band limits the stations are searched. They are defined by legal authorities. Currently band limits for Europe/US and Japan can be used.

Returns:
Current band limits used.

BOOLEAN RadioAudioDevice::GetChannelMuteState ( RadioAudioDevice::AudioChannel channel = RadioAudioDevice::AudioChannelBoth ) const

Get mute state of a channel.

Determine if a channel is currently muted. If "Both" is given as the channel parameter, it will only return TRUE if both channels are muted.

Parameters:
channel Channel to get mute state of.
Returns:
TRUE if selected channel is muted, FALSE otherwise.

BOOLEAN RadioAudioDevice::GetHighCutControl ( ) const

Get High Cut Control (HCC) state.

Returns:
True, if HCC is on.

BOOLEAN RadioAudioDevice::GetHighLowSideLoInjection ( ) const

Get High/Low Side LO Injection state.

Returns:
TRUE for High Side LO injection, FALSE for Low Side LO injection.

RadioAudioDevice & RadioAudioDevice::GetInstance ( ) [static]

Get singleton instance of RadioAudioDevice.

This function returns the only instance of the RadioAudioDevice class. On the first call, the instance will be initialized and returned,

Returns:
The only instance of RadioAudioDevice.

RadioAudioDevice::SearchStopLevel RadioAudioDevice::GetSearchStopLevel ( ) const

Get current search stop level.

Returns:
Current search stop level used.

RadioAudioDevice::AudioChannel RadioAudioDevice::GetSelectedMuteChannel ( ) const

Get selected channel to mute.

This function returns the selected channel which gets muted/unmuted on an upcoming mute call (method SetMute()).

Returns:
the current selected channel to mute.

AudioDeviceBase::AudioSourceType RadioAudioDevice::GetSource ( ) const [virtual]

Get source type of the AudioDevice.

Returns:
the AudioSourceType of this AudioDevice.

BOOLEAN RadioAudioDevice::GetStationInfo ( RadioAudioDevice::StationInfo & info )

Get current station information.

This method queries the FM radio driver for information about the currently tuned station. This information consists of several fields, like sender name, sender type, frequency, signal quality and stereo mode.

This method does an active wait for receiving the result of the query.

Parameters:
info Buffer for station info
Returns:
TRUE if succesful, FALSE otherwise.

RadioAudioDevice::StereoMode RadioAudioDevice::GetStereoMode ( ) const

Get current stereo mode.

This function returns the current stereo mode the FM radio is set to.

Returns:
the current Stereo mode set

BOOLEAN RadioAudioDevice::SeekStation | ( | RadioAudioDevice::SeekDirection | direction,
 |  | RadioAudioDevice::SeekMode | mode
 | ) |

Seek station.

This function is used to seek to another radio station. Depending on the given direction, it is seeked upwards or downwards starting at the current frequency until a station is found or the frequency band limits are reached.

If the seek mode is set to Manual, the frequency is shifted 0.1 MHz into the given direction.

After the tuning was performed, a "RadioAudioDeviceNotifcation" message is sent.

If the seek mode was set to Auto, the type of the message indicates if a station was found (type = "NotificationTypeStationFound") or the band limits have been reached (type = "NotificationTypeBandLimitsReached").

If the seek mode was set to Manual, the "RadioAudioDeviceNotifcation" message will always have the type set to "NotificationTypeBandLimitsReached", just to inform that tuning is finished.

After the seek the method GetStationInfo should be used to query the current station information.

Parameters:
direction | Seek direction (up or down).
mode | Seek mode (auto or manual).
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN RadioAudioDevice::SelectMuteChannel ( RadioAudioDevice::AudioChannel channel = RadioAudioDevice::AudioChannelBoth )

Select the channel to mute.

This function selects the channel which gets muted/unmuted on an upcoming mute call (method SetMute()).

By default the both audio channels are selected.

Parameters:
channel Channel which shall be selected.
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN RadioAudioDevice::SetBandLimits ( RadioAudioDevice::BandLimits limits )

Set radio reception band limits .

This function sets the band limits used for FM radio reception. The band limits give the frequency range in which stations are searched. They are defined by legal authorities. Currently they can be set for Europe/US and Japan.

The European/US FM band goes from 87,50 to 108,00 MHz, the Japanese FM band from 76,00 to 91,00 Mhz.

Be aware that changing the band limits results in an loss of the current tuned station, because the currently tuned frequency is set to the lower end of the selected band limit.

If FM radio is not enabled when calling this method, the band limits configuration is stored and sent to the FM Radio chip on enable.

Parameters:
band Band limits to set (European-US or Japan)
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN RadioAudioDevice::SetHighCutControl ( BOOLEAN hcc_on = TRUE )

Set High Cut Control (HCC) state.

This function sets the High Cut Control of the FM radio.

If FM radio is not enabled when calling this method, the high cut control configuration is stored and sent to the FM Radio chip on enable.

Parameters:
hcc_on TRUE, if HCC should be turned on.
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN RadioAudioDevice::SetHighLowSideLoInjection ( BOOLEAN high = TRUE )

Set High/Low Side LO Injection.

This function sets the High/Low Side LO Injection of the FM radio.

If FM radio is not enabled when calling this method, the High/Low Side LO Injection configuration is stored and sent to the FM Radio chip on enable.

Parameters:
high If TRUE, High Side LO Injection is set, if FALSE, Low Side LO Injection is set.
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN RadioAudioDevice::SetMute | ( | BOOLEAN | enable = TRUE,
 |  | MuteDirection | direction = UpDownlinkDirection
 | ) | [virtual]

Mute selected channels.

This function can be used to mute or unmute the selected channels (the left, the right or both channels). For instance it is quite useful muting both channels to turn of the noise during a station seek. Be aware, that if you mute the right channel using this function and with another invocation the left channel, both channels are muted.

If one channel is muted, the current station is received in mono.

If FM radio is not enabled when calling this method, the mute configuration is stored and sent to the FM Radio chip on enable.

Note: Use SelectMuteChannel() to select the channel to mute.

Parameters:
enable TRUE enables mute, FALSE disables mute. direction This parameter is ignored in case of RadioAudioDevice.
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN RadioAudioDevice::SetSearchStopLevel ( RadioAudioDevice::SearchStopLevel level )

Set search stop level used for seeking.

This function sets the search stop level of the FM radio.

If FM radio is not enabled when calling this method, the search stop level configuration is stored and sent to the FM Radio chip on enable.

Parameters:
level Search stop level to set (low/mid/high).
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN RadioAudioDevice::SetStation ( UINT32 frequency )

Set station.

Tunes the FM radio to the given station frequency. The frequency has to be given in kHz, e.g. 104.00 MHz -> frequency = 104000

After the tuning was performed, a "RadioAudioDeviceNotifcation" message with the type set to "NotificationTypeBandLimitsReached" is sent, just to inform the application that the tuning is finished.

After that the method GetStationInfo can be used to query the current station information.

Parameters:
frequency Station's frequency in kHz.
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN RadioAudioDevice::SetStereoMode ( RadioAudioDevice::StereoMode mode = RadioAudioDevice::ModeStereo )

Set stereo mode.

This function controls if a station is received in stereo (if possible) or if the FM radio is forced to mono.

If FM radio is not enabled when calling this method, the stereo mode configuration is stored and sent to the FM Radio chip on enable.

Parameters:
mode Stereo mode to be set
Returns:
TRUE if succesful, FALSE otherwise.

Friends And Related Function Documentation

friend class DwdPlayer [friend]

The documentation for this class was generated from the following files:
  • Audio/RadioAudioDevice.hpp
  • Audio/RadioAudioDevice.cpp
Generated on Wed Jan 25 01:42:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioAudioDevice::StationInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RadioAudioDevice::StationInfo

RadioAudioDevice::StationInfo Struct Reference

Structure for info about a station. More...

#include <Apoxi/Audio/RadioAudioDevice.hpp>

Collaboration diagram for RadioAudioDevice::StationInfo:

[legend]

Data Fields

UINT32 | m_frequency
Frequency of the station given in kHz.
UINT8 | m_level
Quality of radio signal (percentage value).
WString m_sender_name
RDS Station Name (for future use, currently not supported by hardware).
StereoMode m_stereo_mode
Stereo mode of station.

Detailed Description

Structure for info about a station.

Field Documentation

UINT32 RadioAudioDevice::StationInfo::m_frequency

Frequency of the station given in kHz.

UINT8 RadioAudioDevice::StationInfo::m_level

Quality of radio signal (percentage value).

WString RadioAudioDevice::StationInfo::m_sender_name

RDS Station Name (for future use, currently not supported by hardware).

StereoMode RadioAudioDevice::StationInfo::m_stereo_mode

Stereo mode of station.

The documentation for this struct was generated from the following file:
  • Audio/RadioAudioDevice.hpp
Generated on Wed Jan 25 01:42:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonAction Class Reference
[Items]

#include <Apoxi/Gui/RadioButtonAction.hpp>

Inheritance diagram for RadioButtonAction:

[legend]
Collaboration diagram for RadioButtonAction:

[legend]

Public Types

enum | { ID = 6 }

Public Member Functions

virtual const BitmapRes * | GetDeselectedIcon () const
Obsolete - see AbstractToggleAction::GetDeselectedIcon.
RadioButtonGroup * GetGroup ()
virtual const BitmapRes * | GetSelectedIcon () const
Obsolete - see AbstractToggleAction::GetSelectedIcon.
void | Init (Dispatcher *dispatcher, const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE, RadioButtonGroup *rb_group=0, INT value=0)
Obsolete - use Init having the radio button group as second parameter instead.
void | Init (const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE, RadioButtonGroup *rb_group=0, INT value=0)
Obsolete - use Init having a dispatcher as input instead.
void | Init (Dispatcher *dispatcher, RadioButtonGroup *rb_group, const WCHAR *text, BOOLEAN selected=FALSE, BOOLEAN enabled=TRUE, INT value=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
RadioButtonAction (Dispatcher *dispatcher, const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE, RadioButtonGroup *rb_group=0, INT value=0)
Obsolete - use constructor having the radio button group as second parameter instead.
RadioButtonAction (const WCHAR *text, BOOLEAN enabled=TRUE, BOOLEAN selected=FALSE, RadioButtonGroup *rb_group=0, INT value=0)
Obsolete - use constructor having a dispatcher as input instead.
RadioButtonAction (Dispatcher *dispatcher, RadioButtonGroup *rb_group, const WCHAR *text, BOOLEAN selected=FALSE, BOOLEAN enabled=TRUE, INT value=0)
RadioButtonAction ()
void | SetGroup (RadioButtonGroup *rb_group)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual void | SetSelected (BOOLEAN select)
virtual BOOLEAN | Toggle (BOOLEAN old_state)
virtual | ~RadioButtonAction ()

Detailed Description

A radiobutton action describes an action which toggles itself on executing between a selected state and a deselected state. A radiobutton action defines a "one of many" choice and hence makes only sense as part of a radiobutton group. A radiobutton group is defined by the class RadioButtonGroup and takes care, that only one radiobutton-action is selected.
See also:
RadioButtonGroup

RadioButtonControl

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractToggleAction.

Constructor & Destructor Documentation

RadioButtonAction::RadioButtonAction ( )

RadioButtonAction::RadioButtonAction | ( | Dispatcher * | dispatcher,
 |  | RadioButtonGroup * | rb_group,
 |  | const WCHAR * | text,
 |  | BOOLEAN | selected = FALSE,
 |  | BOOLEAN | enabled = TRUE,
 |  | INT | value = 0
 | ) | [explicit]

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
rb_group | Radiobutton group the radiobutton belongs too. Only one radiobutton of the radiobutton group may get selected.
text | Text of the action.
selected | Specifies whether the toggle action is in the selected or non selected state.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.
value | Value to the toggle action. This is useful when the name or position of a toggle action is not sufficient.

RadioButtonAction::~RadioButtonAction ( ) [virtual]

RadioButtonAction::RadioButtonAction | ( | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE,
 |  | RadioButtonGroup * | rb_group = 0,
 |  | INT | value = 0
 | ) | [explicit]

Obsolete - use constructor having a dispatcher as input instead.

RadioButtonAction::RadioButtonAction | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE,
 |  | RadioButtonGroup * | rb_group = 0,
 |  | INT | value = 0
 | ) | [explicit]

Obsolete - use constructor having the radio button group as second parameter instead.

Member Function Documentation

const BitmapRes * RadioButtonAction::GetDeselectedIcon ( ) const [virtual]

Obsolete - see AbstractToggleAction::GetDeselectedIcon.

Reimplemented from AbstractToggleAction.

RadioButtonGroup* RadioButtonAction::GetGroup ( ) [inline]

Returns the group the radiobutton belongs to.Only one radiobutton of the group may get selected. If one radiobutton A will get selected although radiobutton B is currently selected, then radiobutton B will automatically get deselected.

const BitmapRes * RadioButtonAction::GetSelectedIcon ( ) const [virtual]

Obsolete - see AbstractToggleAction::GetSelectedIcon.

Reimplemented from AbstractToggleAction.

void RadioButtonAction::Init | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE,
 |  | RadioButtonGroup * | rb_group = 0,
 |  | INT | value = 0
 | ) |

Obsolete - use Init having the radio button group as second parameter instead.

void RadioButtonAction::Init | ( | const WCHAR * | text,
 |  | BOOLEAN | enabled = TRUE,
 |  | BOOLEAN | selected = FALSE,
 |  | RadioButtonGroup * | rb_group = 0,
 |  | INT | value = 0
 | ) |

Obsolete - use Init having a dispatcher as input instead.

void RadioButtonAction::Init | ( | Dispatcher * | dispatcher,
 |  | RadioButtonGroup * | rb_group,
 |  | const WCHAR * | text,
 |  | BOOLEAN | selected = FALSE,
 |  | BOOLEAN | enabled = TRUE,
 |  | INT | value = 0
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
rb_group | Radiobutton group the radiobutton belongs too. Only one radiobutton of the radiobutton group may get selected.
text | Text of the action.
selected | Specifies whether the toggle action is in the selected or non selected state.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.
value | Value to the toggle action. This is useful when the name or position of a toggle action is not sufficient.

BOOLEAN RadioButtonAction::IsInstanceOf ( INT id ) const [virtual]

See also:
Item::IsInstanceOf

Reimplemented from AbstractToggleAction.

void RadioButtonAction::SetGroup ( RadioButtonGroup * rb_group )

Sets the group the radiobutton belongs to. Only one radiobutton of the group may get selected. If one radiobutton A will get selected although radiobutton B is currently selected, then radiobutton B will automatically get deselected.

BOOLEAN RadioButtonAction::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from AbstractToggleAction.

void RadioButtonAction::SetSelected ( BOOLEAN select ) [virtual]

See also:
AbstractToggleAction::SetSelected

Reimplemented from AbstractToggleAction.

BOOLEAN RadioButtonAction::Toggle ( BOOLEAN old_state ) [virtual]

See also:
AbstractToggleAction::Toggle

Implements AbstractToggleAction.

The documentation for this class was generated from the following files:
  • Gui/RadioButtonAction.hpp
  • Gui/RadioButtonAction.cpp
Generated on Wed Jan 25 01:42:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonControl Class Reference
[Components]

#include <Apoxi/Gui/RadioButtonControl.hpp>

Inheritance diagram for RadioButtonControl:

[legend]
Collaboration diagram for RadioButtonControl:

[legend]

Public Types

enum | { ID = 21 }

Public Member Functions

INT | GetValue () const
void | Init (Control *parent, RadioButtonGroup *group, const WCHAR *text, BOOLEAN selected=FALSE)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsSelected () const
RadioButtonControl (Control *parent, RadioButtonGroup *group, const WCHAR *text, BOOLEAN selected=FALSE)
RadioButtonControl ()
void | SetGroup (RadioButtonGroup *group)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetSelected (BOOLEAN selected)
void | SetValue (INT value)
A radiobutton may represent a value, which can be specified.
virtual | ~RadioButtonControl ()

Protected Member Functions

virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Detailed Description

A RadioButtonControl represents a radiobutton, which may be selected or unselected. A radiobutton defines a "one of many" choice and hence makes only sense as part of a radiobutton-group. A radiobutton-group is defined by the class RadioButtonGroup and takes care, that only one radiobutton is selected.
See also:
RadioButtonGroup

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractButton.

Constructor & Destructor Documentation

RadioButtonControl::RadioButtonControl ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

RadioButtonControl::RadioButtonControl | ( | Control * | parent,
 |  | RadioButtonGroup * | group,
 |  | const WCHAR * | text,
 |  | BOOLEAN | selected = FALSE
 | ) |

Parameters:
parent | Pointer to the window, which embeds the radiobutton-control.
group | Pointer to the radiobutton-group, which manages the selection and deselection of grouped radiobuttons.
text | Pointer to the text of the radiobutton-control.
selected | Flag, whether the radiobutton is selected.

RadioButtonControl::~RadioButtonControl ( ) [virtual]

Member Function Documentation

INT RadioButtonControl::GetValue ( ) const [inline]

void RadioButtonControl::Init | ( | Control * | parent,
 |  | RadioButtonGroup * | group,
 |  | const WCHAR * | text,
 |  | BOOLEAN | selected = FALSE
 | ) |

Parameters:
parent | Pointer to the window, which embeds the radiobutton-control.
group | Pointer to the radiobutton-group, which manages the selection and deselection of grouped radiobuttons.
text | Pointer to the text of the radiobutton-control.
selected | Flag, whether the radiobutton is selected.

BOOLEAN RadioButtonControl::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractButton.

BOOLEAN RadioButtonControl::IsSelected ( ) const [inline]

void RadioButtonControl::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged

Reimplemented from Control.

void RadioButtonControl::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from Control.

void RadioButtonControl::SetGroup ( RadioButtonGroup * group ) [inline]

BOOLEAN RadioButtonControl::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from AbstractButton.

void RadioButtonControl::SetSelected ( BOOLEAN selected ) [inline]

Marks the radiobutton as selected. The currently selected radiobutton from the radiobutton-group is deselected automatically.

void RadioButtonControl::SetValue ( INT value ) [inline]

A radiobutton may represent a value, which can be specified.

The documentation for this class was generated from the following files:
  • Gui/RadioButtonControl.hpp
  • Gui/RadioButtonControl.cpp
Generated on Wed Jan 25 01:42:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonControlView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonControlView Class Reference
[Components]

Describes the view of a radiobutton-control. More...

#include <Apoxi/Gui/RadioButtonControl.hpp>

Inheritance diagram for RadioButtonControlView:

[legend]
Collaboration diagram for RadioButtonControlView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
RadioButtonControlView (XYDIM default_height)
RadioButtonControlView ()
virtual void | Update (const Theme &theme)
virtual | ~RadioButtonControlView ()

Detailed Description

Describes the view of a radiobutton-control.

Constructor & Destructor Documentation

RadioButtonControlView::RadioButtonControlView ( )

RadioButtonControlView::RadioButtonControlView ( XYDIM default_height )

RadioButtonControlView::~RadioButtonControlView ( ) [virtual]

Member Function Documentation

void RadioButtonControlView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

void RadioButtonControlView::Update ( const Theme & theme ) [virtual]

See also:
View::Update

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Gui/RadioButtonControl.hpp
  • Gui/RadioButtonControl.cpp
Generated on Wed Jan 25 01:42:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonGroup Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonGroup Class Reference
[Items]

Handles deselection of radiobutton-actions. More...

#include <Apoxi/Gui/RadioButtonGroup.hpp>

Inheritance diagram for RadioButtonGroup:

[legend]
Collaboration diagram for RadioButtonGroup:

[legend]

Public Member Functions

RadioButtonAction * GetSelectedRadioButtonAction ()
void | Init ()
RadioButtonGroup ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetSelectedRadioButtonAction (RadioButtonAction *rb)
virtual | ~RadioButtonGroup ()

Detailed Description

Handles deselection of radiobutton-actions.

Constructor & Destructor Documentation

RadioButtonGroup::RadioButtonGroup ( )

RadioButtonGroup::~RadioButtonGroup ( ) [virtual]

Member Function Documentation

RadioButtonAction* RadioButtonGroup::GetSelectedRadioButtonAction ( ) [inline]

void RadioButtonGroup::Init ( )

Reimplemented from ToggleActionGroup.

BOOLEAN RadioButtonGroup::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Reimplemented from ToggleActionGroup.

void RadioButtonGroup::SetSelectedRadioButtonAction ( RadioButtonAction * rb ) [inline]

The documentation for this class was generated from the following files:
  • Gui/RadioButtonGroup.hpp
  • Gui/RadioButtonGroup.cpp
Generated on Wed Jan 25 01:42:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonItem Class Reference

#include <Apoxi/Compat/RadioButtonItem.hpp>

Inheritance diagram for RadioButtonItem:

[legend]
Collaboration diagram for RadioButtonItem:

[legend]

Public Member Functions

const WCHAR * | GetText () const
INT | GetValue ()
BOOLEAN | IsPressed () const
RadioButtonItem (const WCHAR *text=0, BOOLEAN pressed=FALSE)
void | SetPressed (BOOLEAN pressed)
void | SetText (const WCHAR *text)
void | SetValue (INT value)

Detailed Description

Defines an item which looks like a Radiobutton-Control and can be embedded into a RadioButtonList.

Constructor & Destructor Documentation

RadioButtonItem::RadioButtonItem | ( | const WCHAR * | text = 0,
 |  | BOOLEAN | pressed = FALSE
 | ) | [inline]

Member Function Documentation

const WCHAR* RadioButtonItem::GetText ( ) const [inline]

INT RadioButtonItem::GetValue ( ) [inline]

BOOLEAN RadioButtonItem::IsPressed ( ) const [inline]

void RadioButtonItem::SetPressed ( BOOLEAN pressed ) [inline]

void RadioButtonItem::SetText ( const WCHAR * text ) [inline]

void RadioButtonItem::SetValue ( INT value ) [inline]

The documentation for this class was generated from the following file:
  • Compat/RadioButtonItem.hpp
Generated on Wed Jan 25 01:42:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonList Class Reference

#include <Apoxi/Compat/RadioButtonList.hpp>

Inheritance diagram for RadioButtonList:

[legend]
Collaboration diagram for RadioButtonList:

[legend]

Public Member Functions

void | AddItem (RadioButtonItem *item, const WCHAR *text, INT value, BOOLEAN pressed=FALSE) const
void | AddItem (RadioButtonItem *item, RadioButtonItem *after=0)
RadioButtonItem * | GetFirstItem () const
RadioButtonItem * | GetPressedItem (INT *index=0) const
void | Init (Control *parent)
RadioButtonList (Control *parent)
RadioButtonList ()
void | RemoveAllItems () const
void | RemoveItem (RadioButtonItem *item)
void | SetPressedItem (INT value)
void | SetPressedItem (RadioButtonItem *item)
virtual | ~RadioButtonList ()

Protected Member Functions

virtual Model * | CreateModel () const
virtual void | OnItemSelected ()
virtual void | OnLanguageChanged ()
virtual BOOLEAN | OnSoftkeyPressed (INT idx)
virtual BOOLEAN | OnSoftkeyReleased (INT idx)
virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Detailed Description

Obsolete - use the RadioButtonControl or the RadioButtonAction in combination with a listbox instead.

Constructor & Destructor Documentation

RadioButtonList::RadioButtonList ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

RadioButtonList::RadioButtonList ( Control * parent )

Parameters:
parent Pointer to the window, which embedds the CheckBoxList.

RadioButtonList::~RadioButtonList ( ) [virtual]

Member Function Documentation

void RadioButtonList::AddItem | ( | RadioButtonItem * | item,
 |  | const WCHAR * | text,
 |  | INT | value,
 |  | BOOLEAN | pressed = FALSE
 | ) | const

void RadioButtonList::AddItem | ( | RadioButtonItem * | item,
 |  | RadioButtonItem * | after = 0
 | ) |

See also:
MenuList::AddItem

Model * RadioButtonList::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

RadioButtonItem * RadioButtonList::GetFirstItem ( ) const

Returns:
Pointer to the first item.

Reimplemented in TRadioButtonList< Content >.

RadioButtonItem * RadioButtonList::GetPressedItem ( INT * index = 0 ) const

Parameters:
Output-parameter. Contains index of the pressed item, if index is not 0.
Returns:
Pointer to the pressed item.

void RadioButtonList::Init ( Control * parent )

See also:
RadioButtonList::RadioButtonList

Reimplemented from AbstractListBox.

void RadioButtonList::OnItemSelected ( ) [protected, virtual]

Is called, if an item of the menu has been selected. Invokes Control::OnConfirm of the parent-Control.

Reimplemented from AbstractMenuList.

void RadioButtonList::OnLanguageChanged ( ) [protected, virtual]

See also:
Control::OnLanguageChanged

Reimplemented from Control.

BOOLEAN RadioButtonList::OnSoftkeyPressed ( INT idx ) [protected, virtual]

See also:
Control::OnSoftkeyPressed()

Reimplemented from AbstractMenuList.

BOOLEAN RadioButtonList::OnSoftkeyReleased ( INT idx ) [protected, virtual]

See also:
Control::OnSoftkeyReleased()

void RadioButtonList::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from AbstractListBox.

void RadioButtonList::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect &rect)

Reimplemented from AbstractListBox.

void RadioButtonList::RemoveAllItems ( ) const

void RadioButtonList::RemoveItem ( RadioButtonItem * item )

See also:
MenuList::RemoveItem

void RadioButtonList::SetPressedItem ( INT value )

Parameters:
value Switches the RadioButtonItem with this value to status "pressed".

void RadioButtonList::SetPressedItem ( RadioButtonItem * item )

Parameters:
item Pointer to the item which has to be switches to status "pressed".

The documentation for this class was generated from the following files:
  • Compat/RadioButtonList.hpp
  • Compat/RadioButtonList.cpp
Generated on Wed Jan 25 01:43:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonListView Class Reference

Describes the view of a RadioButtonList. More...

#include <Apoxi/Compat/RadioButtonList.hpp>

Inheritance diagram for RadioButtonListView:

[legend]
Collaboration diagram for RadioButtonListView:

[legend]

Public Member Functions

virtual void | DrawItem (const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const
RadioButtonListView (const RadioButtonView *view, XYDIM item_height)
RadioButtonListView ()
virtual | ~RadioButtonListView ()

Protected Member Functions

virtual void | DrawRadioButtonItem (const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const =0

Protected Attributes

const RadioButtonView * | m_view

Detailed Description

Describes the view of a RadioButtonList.

Constructor & Destructor Documentation

RadioButtonListView::RadioButtonListView ( )

RadioButtonListView::RadioButtonListView | ( | const RadioButtonView * | view,
 |  | XYDIM | item_height
 | ) |

RadioButtonListView::~RadioButtonListView ( ) [virtual]

Member Function Documentation

void RadioButtonListView::DrawItem | ( | const AbstractListBox & | listbox,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [virtual]

Reimplemented from AbstractListBoxView.

virtual void RadioButtonListView::DrawRadioButtonItem | ( | const RadioButtonItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, pure virtual]

Implemented in BlueSkyRadioButtonListView, DefaultRadioButtonListView, TestRadioButtonListView, and DefaultRadioButtonListView.

Field Documentation

const RadioButtonView* RadioButtonListView::m_view [protected]

The documentation for this class was generated from the following files:
  • Compat/RadioButtonList.hpp
  • Compat/RadioButtonList.cpp
Generated on Wed Jan 25 01:43:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonModel Class Reference

#include <Apoxi/Compat/RadioButton.hpp>

Inheritance diagram for RadioButtonModel:

[legend]
Collaboration diagram for RadioButtonModel:

[legend]

Public Types

typedef Model | Base

Public Member Functions

const WCHAR * | GetCaption () const
BOOLEAN | GetState () const
RadioButtonModel (const WCHAR *caption=0, BOOLEAN state=0)
void | SetCaption (const WCHAR *caption)
void | SetState (BOOLEAN state)

Member Typedef Documentation

typedef Model RadioButtonModel::Base

Constructor & Destructor Documentation

RadioButtonModel::RadioButtonModel | ( | const WCHAR * | caption = 0,
 |  | BOOLEAN | state = 0
 | ) | [inline]

Member Function Documentation

const WCHAR* RadioButtonModel::GetCaption ( ) const [inline]

BOOLEAN RadioButtonModel::GetState ( ) const [inline]

void RadioButtonModel::SetCaption ( const WCHAR * caption ) [inline]

void RadioButtonModel::SetState ( BOOLEAN state ) [inline]

The documentation for this class was generated from the following file:
  • Compat/RadioButton.hpp
Generated on Wed Jan 25 01:43:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RadioButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RadioButtonView Class Reference

#include <Apoxi/Compat/RadioButton.hpp>

Inheritance diagram for RadioButtonView:

[legend]
Collaboration diagram for RadioButtonView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShifted (const Rect &shift_rect, const Model &abstract_model, DeviceContext *dc, const Rect &repaint_rect) const
XYDIM | GetItemHeight ()
XYDIM | GetLeftGap () const
XYDIM | GetMiddleGap () const
RadioButtonView (XYDIM item_height, XYDIM left_gap, XYDIM middle_gap)
RadioButtonView ()
void | SetItemHeight (XYDIM item_height)
void | SetLeftGap (XYDIM left_gap)
void | SetMiddleGap (XYDIM middle_gap)
virtual | ~RadioButtonView ()

Protected Member Functions

virtual void | DrawRadioButton (const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const =0
virtual void | DrawShiftedRadioButton (const Rect &shift_rect, const RadioButtonModel &abstract_model, DeviceContext *dc, const Rect &repaint_rect) const =0

Constructor & Destructor Documentation

RadioButtonView::RadioButtonView ( )

RadioButtonView::RadioButtonView | ( | XYDIM | item_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) | [inline]

virtual RadioButtonView::~RadioButtonView ( ) [inline, virtual]

Member Function Documentation

void RadioButtonView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

virtual void RadioButtonView::DrawRadioButton | ( | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Implemented in BlueSkyRadioButtonView, DefaultRadioButtonView, TestRadioButtonView, and DefaultRadioButtonView.

void RadioButtonView::DrawShifted | ( | const Rect & | shift_rect,
 |  | const Model & | abstract_model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

virtual void RadioButtonView::DrawShiftedRadioButton | ( | const Rect & | shift_rect,
 |  | const RadioButtonModel & | abstract_model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Implemented in BlueSkyRadioButtonView, DefaultRadioButtonView, TestRadioButtonView, and DefaultRadioButtonView.

XYDIM RadioButtonView::GetItemHeight ( ) [inline]

XYDIM RadioButtonView::GetLeftGap ( ) const [inline]

XYDIM RadioButtonView::GetMiddleGap ( ) const [inline]

void RadioButtonView::SetItemHeight ( XYDIM item_height ) [inline]

void RadioButtonView::SetLeftGap ( XYDIM left_gap ) [inline]

void RadioButtonView::SetMiddleGap ( XYDIM middle_gap ) [inline]

The documentation for this class was generated from the following files:
  • Compat/RadioButton.hpp
  • Compat/RadioButton.cpp
Generated on Wed Jan 25 01:43:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamBlockData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamBlockData Struct Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamTypes.hpp>

Data Fields

UINT32 | block_index
UINT32 | used_bytes

Field Documentation

UINT32 RamBlockData::block_index

UINT32 RamBlockData::used_bytes

The documentation for this struct was generated from the following file:
  • AddOns/AfsRam/RamTypes.hpp
Generated on Wed Jan 25 01:43:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamData Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/RamData.hpp>

Inheritance diagram for RamData:

[legend]
Collaboration diagram for RamData:

[legend]

Public Member Functions

virtual BinData * | Clone () const
void * | GetBuffer () const
virtual UINT32 | GetLength () const
virtual MemMap * | ObtainMemMap (UINT32 idx, UINT32 size) const
virtual UINT32 | Read (UINT32 idx, void *val, UINT32 nbytes) const
virtual BOOLEAN | Read (UINT32 idx, UINT8 &val) const
virtual void | ReleaseMemMap (MemMap **h_map) const

Static Public Member Functions

static RamData * | CreateInstance (void HUGE *buffer, UINT32 length, DrmLocalId id=c_drm_invalid_local_id)

Protected Member Functions

RamData (void HUGE *buffer, UINT32 length, DrmLocalId id=c_drm_invalid_local_id)
virtual | ~RamData ()

Detailed Description

RamData provides a BinData interface to a dynamically allocated or statically defined RAM memory area. RamData can work on shuge buffers (restriction applies only to C166 architecture).

Constructor & Destructor Documentation

RamData::RamData | ( | void HUGE * | buffer,
 |  | UINT32 | length,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) | [protected]

RamData::~RamData ( ) [protected, virtual]

Member Function Documentation

BinData * RamData::Clone ( ) const [virtual]

See also:
BinData::Clone

Reimplemented from BinData.

Reimplemented in BufferedData.

RamData * RamData::CreateInstance | ( | void HUGE * | buffer,
 |  | UINT32 | length,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) | [static]

Creates and returns an object of this class. Note that RamData will not delete the buffer on object destruction.

void* RamData::GetBuffer ( ) const [inline]

Returns a pointer to the passed buffer. It is recommended to use the Read methods for reading the buffer to comply with the generic BinData interface.

UINT32 RamData::GetLength ( ) const [virtual]

See also:
BinData::GetLength

Implements BinData.

MemMap * RamData::ObtainMemMap | ( | UINT32 | idx,
 |  | UINT32 | size
 | ) | const [virtual]

See also:
BinData::GetMemMap

Reimplemented from BinData.

UINT32 RamData::Read | ( | UINT32 | idx,
 |  | void * | val,
 |  | UINT32 | nbytes
 | ) | const [virtual]

See also:
BinData::Read

Implements BinData.

BOOLEAN RamData::Read | ( | UINT32 | idx,
 |  | UINT8 & | val
 | ) | const [virtual]

See also:
BinData::Read

Implements BinData.

void RamData::ReleaseMemMap ( MemMap ** h_map ) const [virtual]

See also:
BinData::ReleaseMemMap

Reimplemented from BinData.

The documentation for this class was generated from the following files:
  • Auxiliary/RamData.hpp
  • Auxiliary/RamData.cpp
Generated on Wed Jan 25 01:43:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamDataSink Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamDataSink Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamDataSink.hpp>

Inheritance diagram for RamDataSink:

[legend]
Collaboration diagram for RamDataSink:

[legend]

Public Member Functions

RamDataSink (UINT32 initial_size=0, DrmLocalId id=c_drm_invalid_local_id)
BOOLEAN | Save (const Path &file_path, UINT32 copy_buf_size=File::c_copy_buf_size) const
virtual | ~RamDataSink ()

Static Protected Attributes

static UINT | s_instance_cnt

Friends

class | RamDataSource

Detailed Description

Class RamDataSink implements a data sink which writes to memory via a temporary RAM-file. These temporary RAM files are held in a temporary directory called _RAM_DATA_SINK on the RAM storage device. The names of the temporary RAM files are based on the string _ram_file_ appended with a unique ID.

Constructor & Destructor Documentation

RamDataSink::RamDataSink | ( | UINT32 | initial_size = 0,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) |

Creates a RAM data sink instance. This data sink writes to an internally controlled temporary RAM file. The RAM data sink has to be opened using method Open() before writing to it. On destruction, the RAM data sink will be closed if not explicitly done before.

Parameters:
initial_size | Defines the initial size of the RAM data sink.
id | The DRM local ID.

RamDataSink::~RamDataSink ( ) [virtual]

Destroys the RAM data sink. On destruction of the last instance the temporary directory called _RAM_DATA_SINK is removed again.

Member Function Documentation

BOOLEAN RamDataSink::Save | ( | const Path & | file_path,
 |  | UINT32 | copy_buf_size = File::c_copy_buf_size
 | ) | const

Saves the contents of the RAM data sink to a file at file_path. It actually copies the internally controlled temporary RAM file to the specified file_path. Note that the RAM data sink has to be closed before it can be saved, otherwise an assertion holds. In addition, file_path must not specify a directory, otherwise an assertion holds. If the file at file_path already exists the method fails.

Parameters:
file_path | The path of the file where to save the contents of the RAM data sink to.
copy_buf_size | The size of the internally used copy buffer. The size of this buffer significantly affects the performance of this operation.
Returns:
Success of operation.

Friends And Related Function Documentation

friend class RamDataSource [friend]

Field Documentation

UINT RamDataSink::s_instance_cnt [static, protected]

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamDataSink.hpp
  • AddOns/AfsRam/RamDataSink.cpp
Generated on Wed Jan 25 01:43:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamDataSource Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamDataSource Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamDataSource.hpp>

Inheritance diagram for RamDataSource:

[legend]
Collaboration diagram for RamDataSource:

[legend]

Public Member Functions

RamDataSource (const RamDataSinkPtr &sink)
virtual ~RamDataSource ()

Protected Attributes

RamDataSinkPtr m_sink

Detailed Description

Class RamDataSource implements a data source which reads from an associated RamDataSink instance.

Constructor & Destructor Documentation

RamDataSource::RamDataSource ( const RamDataSinkPtr & sink )

Creates a RAM data source instance. This data source reads from an internally controlled temporary RAM file. The file data source has to be opened using method Open() before reading from it. On destruction, the RAM data source will be closed if not explicitly done before.

Parameters:
sink The RAM data sink to read from.

RamDataSource::~RamDataSource ( ) [virtual]

Destroys the RAM data source.

Field Documentation

RamDataSinkPtr RamDataSource::m_sink [protected]

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamDataSource.hpp
  • AddOns/AfsRam/RamDataSource.cpp
Generated on Wed Jan 25 01:43:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamDirectoryIteratorImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamDirectoryIteratorImp Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamDirectoryIteratorImp.hpp>

Inheritance diagram for RamDirectoryIteratorImp:

[legend]
Collaboration diagram for RamDirectoryIteratorImp:

[legend]

Protected Member Functions

virtual DirectoryIterator & | AtomicIncrement ()
RamDirectoryIteratorImp (const Pathname &dir_pathname, const FileFilterPtr &filter)
virtual | ~RamDirectoryIteratorImp ()
Destroys the flash directory iterator.

Friends

class | RamStorageDeviceImp

Detailed Description

Class RamDirectoryIterator implements the directory iterator for the RAM storage device.

Constructor & Destructor Documentation

RamDirectoryIteratorImp::RamDirectoryIteratorImp | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter
 | ) | [explicit, protected]

See also:
DirectoryIterator::DirectoryIterator(const Pathname &, const FileFilterPtr &, const WString &)

RamDirectoryIteratorImp::~RamDirectoryIteratorImp ( ) [protected, virtual]

Destroys the flash directory iterator.

Member Function Documentation

DirectoryIterator & RamDirectoryIteratorImp::AtomicIncrement ( ) [protected, virtual]

Increments the iterator to point to the next pathname in the directory and returns a reference to itself. This increment operation does not consider the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

Returns:
Reference to itself incremented to point to the next pathname or to the root pathname signaling the end iterator.

Implements DirectoryIterator.

Friends And Related Function Documentation

friend class RamStorageDeviceImp [friend]

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamDirectoryIteratorImp.hpp
  • AddOns/AfsRam/RamDirectoryIteratorImp.cpp
Generated on Wed Jan 25 01:43:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamFile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamFile Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamFile.hpp>

Collaboration diagram for RamFile:

[legend]

Public Member Functions

BOOLEAN | AssureInitialized (const CHAR *filename)
BOOLEAN | Close ()
BOOLEAN | Create (const CHAR *filename, UINT32 size)
BOOLEAN | Delete ()
BOOLEAN | GetCreationTimestamp (Date &time_stamp) const
BOOLEAN | GetFileSize (UINT32 &file_size) const
BOOLEAN | GetLastAccessTimestamp (Date &time_stamp) const
RamError | GetLastError () const
BOOLEAN | GetLastUpdateTimestamp (Date &time_stamp) const
BOOLEAN | IsHidden () const
BOOLEAN | IsInitialized () const
BOOLEAN | IsOpen () const
BOOLEAN | IsReadOnly () const
BOOLEAN | Open (const CHAR *filename, RamOpenMode mode)
RamFile ()
BOOLEAN | Read (void HUGE *buffer, UINT32 offset, UINT32 max_no_bytes, UINT32 &bytes_read)
BOOLEAN | Read (void HUGE *buffer, UINT32 offset, UINT32 bytes)
BOOLEAN | Rename (const CHAR *new_filename)
BOOLEAN | Resize (UINT32 new_size)
BOOLEAN | SetHidden (BOOLEAN hidden)
BOOLEAN | SetReadOnly (BOOLEAN read_only)
BOOLEAN | Write (const void HUGE *buffer, UINT32 offset, UINT32 no_bytes)
~RamFile ()

Constructor & Destructor Documentation

RamFile::RamFile ( )

RamFile::~RamFile ( )

Member Function Documentation

BOOLEAN RamFile::AssureInitialized ( const CHAR * filename )

Assures that after the method call the file is initialized.

BOOLEAN RamFile::Close ( )

BOOLEAN RamFile::Create | ( | const CHAR * | filename,
 |  | UINT32 | size
 | ) |

BOOLEAN RamFile::Delete ( )

BOOLEAN RamFile::GetCreationTimestamp ( Date & time_stamp ) const

BOOLEAN RamFile::GetFileSize ( UINT32 & file_size ) const

BOOLEAN RamFile::GetLastAccessTimestamp ( Date & time_stamp ) const

RamError RamFile::GetLastError ( ) const

BOOLEAN RamFile::GetLastUpdateTimestamp ( Date & time_stamp ) const

BOOLEAN RamFile::IsHidden ( ) const

BOOLEAN RamFile::IsInitialized ( ) const [inline]

Tells if the file is initialized, i.e. if it has a valid file handle associated. A valid file handle is assigned when the file is successfully opened or created.

BOOLEAN RamFile::IsOpen ( ) const

BOOLEAN RamFile::IsReadOnly ( ) const

BOOLEAN RamFile::Open | ( | const CHAR * | filename,
 |  | RamOpenMode | mode
 | ) |

BOOLEAN RamFile::Read | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_no_bytes,
 |  | UINT32 & | bytes_read
 | ) |

BOOLEAN RamFile::Read | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | bytes
 | ) |

BOOLEAN RamFile::Rename ( const CHAR * new_filename )

BOOLEAN RamFile::Resize ( UINT32 new_size )

BOOLEAN RamFile::SetHidden ( BOOLEAN hidden )

BOOLEAN RamFile::SetReadOnly ( BOOLEAN read_only )

BOOLEAN RamFile::Write | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | no_bytes
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamFile.hpp
  • AddOns/AfsRam/RamFile.cpp
Generated on Wed Jan 25 01:43:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamFileImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamFileImp Class Reference
[RAM File System support]

File implementation for random access memory (RAM) storage device More...

#include <Apoxi/AddOns/AfsRam/RamFileImp.hpp>

Inheritance diagram for RamFileImp:

[legend]
Collaboration diagram for RamFileImp:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | Create (UINT32 size)
virtual BOOLEAN | CreateDir ()
virtual BOOLEAN | CreateStreaming ()
virtual BOOLEAN | Delete ()
virtual BOOLEAN | GetAccessDate (Date &date) const
virtual BOOLEAN | GetAttributes (Attributes &attributes) const
virtual BOOLEAN | GetCreationDate (Date &date) const
virtual BOOLEAN | GetModificationDate (Date &date) const
virtual BOOLEAN | GetSize (UINT32 &size) const
virtual const WString & | GetStorageDeviceId () const
virtual BOOLEAN | IsArchive () const
virtual BOOLEAN | IsHidden () const
virtual BOOLEAN | IsOpen () const
Tells if the file is open.
virtual BOOLEAN | IsReadOnly () const
virtual BOOLEAN | Open (OpenMode open_mode)
virtual BOOLEAN | OpenStreaming (OpenMode open_mode)
virtual BOOLEAN | Rename (const WString &new_name)
virtual BOOLEAN | Resize (UINT32 new_size, UINT32 copy_buf_size)
virtual BOOLEAN | SetArchive (BOOLEAN archive)
virtual BOOLEAN | SetHidden (BOOLEAN hidden)
virtual BOOLEAN | SetReadOnly (BOOLEAN read_only)

Protected Member Functions

virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 count)
virtual BOOLEAN | DoReadStreaming (void HUGE *buffer, UINT32 count, UINT32 &bytes_read)
virtual BOOLEAN | DoReadStreamingAsync (void HUGE *buffer, UINT32 count, StreamingCallback)
virtual BOOLEAN | DoWrite (const void HUGE *buffer, UINT32 offset, UINT32 count)
virtual BOOLEAN | DoWriteStreaming (const void HUGE *buffer, UINT32 count)
virtual BOOLEAN | DoWriteStreamingAsync (const void HUGE *buffer, UINT32 count, StreamingCallback)
virtual const FileState & | MyState () const
Returns the constant state of the constant file.
virtual FileState & | MyState ()
Returns the state of the file.
RamFileImp (const Pathname &pathname)
virtual | ~RamFileImp ()

Static Protected Member Functions

static Error | ConvertRamErrorToFileError (RamError ram_error)
static RamOpenMode | TranslateOpenMode (OpenMode open_mode)

Friends

class | RamStorageDeviceImp

Detailed Description

File implementation for random access memory (RAM) storage device

Class RamFileImp represents a file stored on the RAM storage device supporting the root file system interface.

See also:
File

Constructor & Destructor Documentation

RamFileImp::RamFileImp ( const Pathname & pathname ) [protected]

RamFileImp::~RamFileImp ( ) [protected, virtual]

Member Function Documentation

BOOLEAN RamFileImp::Close ( ) [virtual]

Closes a previously opened file. An overriding method must call this base implementation at the end of its implementation if the file could be closed successfully to assure that the counter of open files gets set properly.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

File::Error RamFileImp::ConvertRamErrorToFileError ( RamError ram_error ) [static, protected]

BOOLEAN RamFileImp::Create ( UINT32 size ) [virtual]

Creates a physical file with path m_path and initial size specified in bytes. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents operations in mode ReadAndWriteMode and its internal file position is set to 0, independent of the size argument. The file grows itself if it is written beyond its actual size. Creating an empty file with size 0 is allowed. For shrinking or growing the file use method Resize(). An overriding method must call this base implementation at the end of its implementation if the file could be created successfully to assure that the counter of open files gets set properly. This is a file operation and of course the file must not be open on call.

Parameters:
size The initial size of the new file.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RamFileImp::CreateDir ( ) [virtual]

Creates a physical directory with path m_path. The last segment of m_path is taken as name of the new directory to create. The directory can only be created if all the directories specified in m_path already exist and the new directory doesn't exist yet. This is a file operation and of course the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

virtual BOOLEAN RamFileImp::CreateStreaming ( ) [inline, virtual]

Creates a physical file with path m_path. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents in streaming mode.

This means that only the methods:

  • WriteStreaming
  • WriteStreamingAsync
  • ReadStreaming
  • ReadStreamingAsync and not the methods Read() or Write() can be used with this file.

Implements File.

BOOLEAN RamFileImp::Delete ( ) [virtual]

Deletes the file or directory. If the file is actually a directory, then it must be empty in order to be deleted. If the file or directory does not exist the method fails. The method succeeds if and only if the file or directory could successfully be deleted. This is a file operation, the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RamFileImp::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [protected, virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)

Implements File.

BOOLEAN RamFileImp::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 count)

Implements File.

virtual BOOLEAN RamFileImp::DoReadStreaming | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 & | bytes_read
 | ) | [inline, protected, virtual]

See also:
ReadStreaming(void HUGE *buffer, UINT32 count, UINT32 &bytes_read);

Implements File.

virtual BOOLEAN RamFileImp::DoReadStreamingAsync | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [inline, protected, virtual]

See also:
ReadStreamingAsync(void HUGE *buffer, UINT32 count, StreamingCallback);

Implements File.

BOOLEAN RamFileImp::DoWrite | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
Write(const void HUGE *buffer, UINT32 offset, UINT32 count)

Implements File.

virtual BOOLEAN RamFileImp::DoWriteStreaming | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [inline, protected, virtual]

See also:
WriteStreaming(const void HUGE *buffer, UINT32 count);

Implements File.

virtual BOOLEAN RamFileImp::DoWriteStreamingAsync | ( | const void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [inline, protected, virtual]

See also:
WriteStreamingAsync(const void HUGE *buffer, UINT32 count, StreamingCallback);

Implements File.

BOOLEAN RamFileImp::GetAccessDate ( Date & date ) const [virtual]

If the access date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open. Please override this method for storage devices which support retrieving the date of the last file access.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

BOOLEAN RamFileImp::GetAttributes ( Attributes & attributes ) const [virtual]

BOOLEAN RamFileImp::GetCreationDate ( Date & date ) const [virtual]

If the creation date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RamFileImp::GetModificationDate ( Date & date ) const [virtual]

If the modification date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RamFileImp::GetSize ( UINT32 & size ) const [virtual]

If the file size can be retrieved then size is set to the actual file size in bytes and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

const WString & RamFileImp::GetStorageDeviceId ( ) const [virtual]

Returns the storage device ID of the device associated to this file class.

Implements File.

BOOLEAN RamFileImp::IsArchive ( ) const [virtual]

Tells if the file is archive. This is a file operation, the file must not be open on call.

Implements File.

BOOLEAN RamFileImp::IsHidden ( ) const [virtual]

Tells if the file is hidden. This is a file operation, the file must not be open on call.

Implements File.

BOOLEAN RamFileImp::IsOpen ( ) const [virtual]

Tells if the file is open.

Implements File.

BOOLEAN RamFileImp::IsReadOnly ( ) const [virtual]

Tells if the file is read only. This is a file operation, the file must not be open on call.

Implements File.

const File::FileState & RamFileImp::MyState ( ) const [protected, virtual]

Returns the constant state of the constant file.

Implements File.

File::FileState & RamFileImp::MyState ( ) [protected, virtual]

Returns the state of the file.

Implements File.

BOOLEAN RamFileImp::Open ( OpenMode open_mode ) [virtual]

virtual BOOLEAN RamFileImp::OpenStreaming ( OpenMode open_mode ) [inline, virtual]

BOOLEAN RamFileImp::Rename ( const WString & new_name ) [virtual]

Renames the file or directory to new_name. If the file or directory does not exist the method fails. Argument new_name is the file name including the file extension (if any) but without any leading directories. The MIME type of the renamed file is defined by the extension of the new name, if none exists it has general type. If the new name is equal to the old name the method fails. The method succeeds if and only if the file or directory really was renamed. Subclasses have to first check if the new file name is different to the actual one, then physically rename the file, and finally call this base method for changing the name which is controlled within this base class. This base method never fails. For a sample implementation see FlashFileImp::Rename(). This is a file operation, the file must not be open on call.

Parameters:
new_name New name of the file including the file extension (if any). No directory segments are allowed.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RamFileImp::Resize | ( | UINT32 | new_size,
 |  | UINT32 | copy_buf_size
 | ) | [virtual]

Resizes the file to contain new_size bytes. If the new size is less than the original size then the file is truncated. If the new size is bigger than the original size then the newly created part of the file is not initialized and has to be written to be in defined state. Emptying a file by resizing it to size 0 is allowed. This default implementation uses a temporary file for resizing. Override this method if resizing is explicitly supported by the derived file class. This is a file operation, the file must not be open on call.

Parameters:
new_size | The new size of the file.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

BOOLEAN RamFileImp::SetArchive ( BOOLEAN archive ) [virtual]

Sets the archive flag.

Parameters:
archive If TRUE then the file is an archive.

Implements File.

BOOLEAN RamFileImp::SetHidden ( BOOLEAN hidden ) [virtual]

Sets the hidden flag.

Parameters:
hidden If TRUE then the file is hidden.

Implements File.

BOOLEAN RamFileImp::SetReadOnly ( BOOLEAN read_only ) [virtual]

Sets the read only flag.

Parameters:
read_only If TRUE then the file is set to read only mode.

Implements File.

RamOpenMode RamFileImp::TranslateOpenMode ( OpenMode open_mode ) [static, protected]

Friends And Related Function Documentation

friend class RamStorageDeviceImp [friend]

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamFileImp.hpp
  • AddOns/AfsRam/RamFileImp.cpp
Generated on Wed Jan 25 01:43:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamFileInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamFileInfo Struct Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamTypes.hpp>

Collaboration diagram for RamFileInfo:

[legend]

Data Fields

UINT16 | fattribute
UINT16 | padding
Date st_atime
INT32 | st_blksize
INT32 | st_blocks
Date st_ctime
Date st_mtime
UINT32 | st_size

Field Documentation

UINT16 RamFileInfo::fattribute

UINT16 RamFileInfo::padding

Date RamFileInfo::st_atime

INT32 RamFileInfo::st_blksize

INT32 RamFileInfo::st_blocks

Date RamFileInfo::st_ctime

Date RamFileInfo::st_mtime

UINT32 RamFileInfo::st_size

The documentation for this struct was generated from the following file:
  • AddOns/AfsRam/RamTypes.hpp
Generated on Wed Jan 25 01:43:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamFileNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamFileNode Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamFileNode.hpp>

Collaboration diagram for RamFileNode:

[legend]

Public Member Functions

BOOLEAN | DeleteAllEqualNodes ()
BOOLEAN | DeleteAllSubNodes ()
BOOLEAN | DeleteEqualNode (const Pathname &pathname)
BOOLEAN | DeleteSubNode (const Pathname &pathname)
RamFileNode * | GetEqualDirectoryNode () const
RamFileNode * | GetParentNode () const
RamFileObj * | GetRamFileObj () const
WString | GetSegmentName () const
RamFileNode * | GetSubDirectoryNode () const
BOOLEAN | InsertEqualNode (RamFileNode *directory_item)
BOOLEAN | InsertSubNode (RamFileNode *file_item)
RamFileNode (RamFileObj *file_obj=0, RamFileNode *parent=0, RamFileNode *equal_directory_item=0, RamFileNode *sub_directory_item=0)
void | SetRamFileObj (RamFileObj *file_obj)
BOOLEAN | SetSegmentName (const WString &segment_name)
WString TrackPathToRoot ()
~RamFileNode ()

Friends

class | RamFileSystem

Constructor & Destructor Documentation

RamFileNode::RamFileNode | ( | RamFileObj * | file_obj = 0,
 |  | RamFileNode * | parent = 0,
 |  | RamFileNode * | equal_directory_item = 0,
 |  | RamFileNode * | sub_directory_item = 0
 | ) |

RamFileNode::~RamFileNode ( )

Member Function Documentation

BOOLEAN RamFileNode::DeleteAllEqualNodes ( )

BOOLEAN RamFileNode::DeleteAllSubNodes ( )

BOOLEAN RamFileNode::DeleteEqualNode ( const Pathname & pathname )

BOOLEAN RamFileNode::DeleteSubNode ( const Pathname & pathname )

RamFileNode * RamFileNode::GetEqualDirectoryNode ( ) const

RamFileNode * RamFileNode::GetParentNode ( ) const

RamFileObj * RamFileNode::GetRamFileObj ( ) const

WString RamFileNode::GetSegmentName ( ) const

RamFileNode * RamFileNode::GetSubDirectoryNode ( ) const

BOOLEAN RamFileNode::InsertEqualNode ( RamFileNode * directory_item )

BOOLEAN RamFileNode::InsertSubNode ( RamFileNode * file_item )

void RamFileNode::SetRamFileObj ( RamFileObj * file_obj )

BOOLEAN RamFileNode::SetSegmentName ( const WString & segment_name )

WString RamFileNode::TrackPathToRoot ( )

Friends And Related Function Documentation

friend class RamFileSystem [friend]

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamFileNode.hpp
  • AddOns/AfsRam/RamFileNode.cpp
Generated on Wed Jan 25 01:43:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamFileObj Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamFileObj Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamFileObj.hpp>

Collaboration diagram for RamFileObj:

[legend]

Public Member Functions

BOOLEAN | Append (const void HUGE *buffer, UINT32 count)
BOOLEAN | DeleteDataBlocks ()
BOOLEAN | GetAccessDate (Date &date) const
UINT32 | GetAllocatedSize () const
UINT16 | GetAttributes () const
UINT32 | GetBlockCount () const
BOOLEAN | GetCreationDate (Date &date) const
RamError | GetLastError () const
BOOLEAN | GetModificationDate (Date &date) const
const WString | GetName () const
const WString | GetNativeDirectoryPathname () const
const WString | GetNativeFilePathname () const
const Pathname & | GetPathname () const
UINT32 | GetSize () const
BOOLEAN | IsArchive () const
BOOLEAN | IsDirectory () const
BOOLEAN | IsHidden () const
BOOLEAN | IsReadOnly () const
BOOLEAN | IsSystem () const
BOOLEAN | IsVolume () const
RamFileObj (const RamFileObj &another_file_obj)
RamFileObj (const Pathname &pathname, UINT16 attributes=RamFileAttrNormal, UINT32 size=0)
RamFileObj (const WString &pathname, UINT16 attributes=RamFileAttrNormal, UINT32 size=0)
BOOLEAN | Read (UINT32 offset, void HUGE *buffer, UINT32 count, UINT32 &bytes_read)
BOOLEAN | Reset (UINT32 size)
BOOLEAN | Resize (UINT32 new_size)
BOOLEAN | SetArchive (BOOLEAN is_archive)
BOOLEAN | SetAttributes (UINT16 attributes)
BOOLEAN | SetDirectory (BOOLEAN is_directory)
BOOLEAN | SetHidden (BOOLEAN is_hidden)
void | SetPathname (const Pathname &pathname)
BOOLEAN | SetReadOnly (BOOLEAN is_read_only)
BOOLEAN | SetSystem (BOOLEAN is_system)
BOOLEAN | SetVolume (BOOLEAN is_volume)
BOOLEAN | Write (UINT32 offset, const void HUGE *buffer, UINT32 count)
~RamFileObj ()

Constructor & Destructor Documentation

RamFileObj::RamFileObj | ( | const WString & | pathname,
 |  | UINT16 | attributes = RamFileAttrNormal,
 |  | UINT32 | size = 0
 | ) |

RamFileObj::RamFileObj | ( | const Pathname & | pathname,
 |  | UINT16 | attributes = RamFileAttrNormal,
 |  | UINT32 | size = 0
 | ) |

RamFileObj::RamFileObj ( const RamFileObj & another_file_obj )

RamFileObj::~RamFileObj ( )

Member Function Documentation

BOOLEAN RamFileObj::Append | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

BOOLEAN RamFileObj::DeleteDataBlocks ( )

BOOLEAN RamFileObj::GetAccessDate ( Date & date ) const

UINT32 RamFileObj::GetAllocatedSize ( ) const

UINT16 RamFileObj::GetAttributes ( ) const

UINT32 RamFileObj::GetBlockCount ( ) const

BOOLEAN RamFileObj::GetCreationDate ( Date & date ) const

RamError RamFileObj::GetLastError ( ) const

BOOLEAN RamFileObj::GetModificationDate ( Date & date ) const

const WString RamFileObj::GetName ( ) const

const WString RamFileObj::GetNativeDirectoryPathname ( ) const

const WString RamFileObj::GetNativeFilePathname ( ) const

const Pathname & RamFileObj::GetPathname ( ) const

UINT32 RamFileObj::GetSize ( ) const

BOOLEAN RamFileObj::IsArchive ( ) const

BOOLEAN RamFileObj::IsDirectory ( ) const

BOOLEAN RamFileObj::IsHidden ( ) const

BOOLEAN RamFileObj::IsReadOnly ( ) const

BOOLEAN RamFileObj::IsSystem ( ) const

BOOLEAN RamFileObj::IsVolume ( ) const

BOOLEAN RamFileObj::Read | ( | UINT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 & | bytes_read
 | ) |

BOOLEAN RamFileObj::Reset ( UINT32 size )

BOOLEAN RamFileObj::Resize ( UINT32 new_size )

BOOLEAN RamFileObj::SetArchive ( BOOLEAN is_archive )

BOOLEAN RamFileObj::SetAttributes ( UINT16 attributes )

BOOLEAN RamFileObj::SetDirectory ( BOOLEAN is_directory )

BOOLEAN RamFileObj::SetHidden ( BOOLEAN is_hidden )

void RamFileObj::SetPathname ( const Pathname & pathname )

BOOLEAN RamFileObj::SetReadOnly ( BOOLEAN is_read_only )

BOOLEAN RamFileObj::SetSystem ( BOOLEAN is_system )

BOOLEAN RamFileObj::SetVolume ( BOOLEAN is_volume )

BOOLEAN RamFileObj::Write | ( | UINT32 | offset,
 |  | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamFileObj.hpp
  • AddOns/AfsRam/RamFileObj.cpp
Generated on Wed Jan 25 01:43:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamFileSystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamFileSystem Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamFileSystem.hpp>

Collaboration diagram for RamFileSystem:

[legend]

Public Member Functions

BOOLEAN | AssignDriveLetter (UINT8 drive_letter)
BOOLEAN | DeleteNode (const Pathname &pathname, UINT16 attributes)
RamHandle | FindNode (const Pathname &pathname, UINT16 attributes)
BOOLEAN | FormatFileSystem (UINT16 block_size=c_ram_storage_default_block_size)
UINT8 | GetDriveLetter () const
UINT32 | GetFreeSpaceSize () const
RamError | GetLastError () const
RamHandle GetRootNode ()
UINT32 | GetSpaceSize () const
WString | GetTree (RamHandle node, UINT level=0) const
UINT32 | GetUsedSpaceSize () const
RamHandle | InsertNode (RamFileObj *file_obj)
~RamFileSystem ()

Static Public Member Functions

static RamFileSystem * | GetInstance ()

Constructor & Destructor Documentation

RamFileSystem::~RamFileSystem ( )

Destructor of the class.

Member Function Documentation

BOOLEAN RamFileSystem::AssignDriveLetter ( UINT8 drive_letter )

Assigns a drive letter to the Returns a RamHandle to a node with the specified path name and attributes.

Parameters:
drive_letter Drive letter to be assigned.
Returns:
Whether the operation was successful or not.

BOOLEAN RamFileSystem::DeleteNode | ( | const Pathname & | pathname,
 |  | UINT16 | attributes
 | ) |

Deletes a node with the specified path name and attributes.

Parameters:
pathname | Path name which defines a node.
attributes | Attributes of the node. Use RamFileAttrAll to find all nodes.
Returns:
Whether the node could be deleted or not.

RamHandle RamFileSystem::FindNode | ( | const Pathname & | pathname,
 |  | UINT16 | attributes
 | ) |

Returns a RamHandle to a node with the specified path name and attributes.

Parameters:
pathname | Path name which defines a node.
attributes | Attributes of the node. Use RamFileAttrAll to find all nodes.
Returns:
A RamHandle of the found node. 0 if nothing is found.

BOOLEAN RamFileSystem::FormatFileSystem ( UINT16 block_size = c_ram_storage_default_block_size )

Formats the file system with the specified size.

Parameters:
block_size New block size of the file system. Default is c_ram_storage_default_block_size defined in RamTypes.hpp.
Returns:
Whether the operation was successful or not.

UINT8 RamFileSystem::GetDriveLetter ( ) const

Returns the assigned drive letter of the file system.

Returns:
The currently assigned drive letter.

UINT32 RamFileSystem::GetFreeSpaceSize ( ) const

Returns the free size of the file system.

Returns:
The free size of the file system.

static RamFileSystem* RamFileSystem::GetInstance ( ) [inline, static]

Returns the instance of this class which is designed in singleton pattern.

Returns:
The singleton instance of the class.

RamError RamFileSystem::GetLastError ( ) const

Returns the last occurred error.

Returns:
The last occurred error.

RamHandle RamFileSystem::GetRootNode ( )

Returns the root node of the file system.

Returns:
A RamHandle of the root node.

UINT32 RamFileSystem::GetSpaceSize ( ) const

Returns the total size of the file system.

Returns:
The size of the file system.

WString RamFileSystem::GetTree | ( | RamHandle | node,
 |  | UINT | level = 0
 | ) | const

Returns a tree of a node as WString representation. Because this method calls itself recursively the default value for level is zero and is increased for sub nodes in every call.

Parameters:
node | Any node which defines any sub tree of root (or even root).
level | The level of the indentation. Default is zero.
Returns:
A WString representing the tree.

UINT32 RamFileSystem::GetUsedSpaceSize ( ) const

Returns the used size of the file system.

Returns:
The used size of the file system.

RamHandle RamFileSystem::InsertNode ( RamFileObj * file_obj )

Returns a RamHandle to a node which is defined by the specified RamFileObj and inserted into the file system.

Parameters:
file_obj A RamFileObj object which contains the data of the file which has to be inserted.
Returns:
A RamHandle of the found node. 0 if it could not be inserted.

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamFileSystem.hpp
  • AddOns/AfsRam/RamFileSystem.cpp
Generated on Wed Jan 25 01:43:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamHandler Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamHandler.hpp>

Collaboration diagram for RamHandler:

[legend]

Static Public Member Functions

static BOOLEAN | Append (RamHandle hp, const void HUGE *buffer, UINT32 count)
static BOOLEAN | ChangeDir (const WString &dir_name)
static RamHandle | Create (const WString &file_name, UINT32 size)
static void | Deinitialize ()
static BOOLEAN | Delete (const WString &file_name)
static BOOLEAN | FileExists (const WString &file_name)
static RamHandle | Find (const WString &file_name)
static void | FindDone ()
static BOOLEAN | FindFirst (RamHandle *found_file, const WString &filespec)
static BOOLEAN | FindNext (RamHandle *found_file)
static BOOLEAN | Flush (RamHandle hp)
static BOOLEAN | Format (UINT16 block_size=c_ram_storage_default_block_size)
static BOOLEAN | GetAttributes (const WString &filename, UINT16 &attr)
static BOOLEAN | GetCurrentDir (WString &current_dir)
static BOOLEAN | GetFileInfo (const WString &file_name, RamFileInfo *info)
static UINT32 | GetFreeSpaceSize ()
static RamError | GetLastError ()
static UINT32 | GetTotalSpaceSize ()
static UINT32 | GetUsedSpaceSize ()
static void | Initialize ()
static BOOLEAN | IsCurrentDir (const RamHandle current_dir)
static BOOLEAN | IsDirectory (const WString &dir_name)
static BOOLEAN | MakeDir (const WString &dir_name)
static BOOLEAN | Read (RamHandle hp, INT32 offset, void HUGE *buffer, UINT32 count, UINT32 &bytes_read)
static BOOLEAN | RemoveDir (const WString &dir_name)
static BOOLEAN | Rename (const WString &old_file_name, const WString &new_file_name)
static BOOLEAN | Resize (RamHandle file_handle, UINT32 new_size)
static BOOLEAN | SetAttributes (const WString &filename, UINT16 attr)
static BOOLEAN | Truncate (RamHandle hp, UINT32 new_size)
static BOOLEAN | Write (RamHandle hp, INT32 offset, const void HUGE *buffer, UINT32 count)

Member Function Documentation

BOOLEAN RamHandler::Append | ( | RamHandle | hp,
 |  | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [static]

Adds the specified data in the end of the existing file.

Parameters:
hp | The file handle.
buffer | Pointer to the local store where to copy data from.
count | Number of bytes to copy.
Returns:
if the operation is successful.

BOOLEAN RamHandler::ChangeDir ( const WString & dir_name ) [static]

Changes the current working directory.

Parameters:
dir_name The name of the directory to be changed to.
Returns:
if the operation is successful.

RamHandle RamHandler::Create | ( | const WString & | file_name,
 |  | UINT32 | size
 | ) | [static]

Creates an empty file and returns the file-handle.

Parameters:
file_name | The name of the file to create.
size | The initial size of the file.
Returns:
Pointer to the handle of the file.

void RamHandler::Deinitialize ( ) [static]

Destroys the root file system, the current working directory and the capacity of the RAM drive. Must be called before any other method of this class.

BOOLEAN RamHandler::Delete ( const WString & file_name ) [static]

Deletes the file. The file should not be open when the delete operation is requested.

Parameters:
file_name The name of the file to be deleted.
Returns:
if the operation is successful

BOOLEAN RamHandler::FileExists ( const WString & file_name ) [static]

Checks the RAM drive for the presence of the file with the specified name.

Parameters:
file_name The name of the file.
Returns:
TRUE: File already exists. FALSE: File does not exist.

RamHandle RamHandler::Find ( const WString & file_name ) [static]

Finds a file with the specified name and returns the file-handle.

Parameters:
file_name The name of the file to find.
Returns:
Pointer to the handle of the file, null if file does not exist.

void RamHandler::FindDone ( ) [static]

Must be called if the last file is reached according to the file spec

BOOLEAN RamHandler::FindFirst | ( | RamHandle * | found_file,
 |  | const WString & | filespec
 | ) | [static]

Returns the first stored file that matches the filespec.

Parameters:
found_file | Pointer to the file info record where to store data.
filespec | Target file specification (may include the wildcards '?' and '*').
Returns:
TRUE: A file is found FALSE: No file found.

BOOLEAN RamHandler::FindNext ( RamHandle * found_file ) [static]

Returns the next stored file that matches the file specification given in FindFirst().

Parameters:
find_data Pointer to the file info record where to store data.
Returns:
TRUE: A file is found FALSE: No file found.

BOOLEAN RamHandler::Flush ( RamHandle hp ) [static]

After this call completes, the view of the file in the RAM drive is completely consistent with the in memory view.

Returns:
if the operation is successful.

BOOLEAN RamHandler::Format ( UINT16 block_size = c_ram_storage_default_block_size ) [static]

Formats the device with the given size and block size.

Parameters:
block_size New block size of the device.
Returns:
if formatting was successful

BOOLEAN RamHandler::GetAttributes | ( | const WString & | filename,
 |  | UINT16 & | attr
 | ) | [static]

Get the attributes of a file

Parameters:
filename | The file name.
attr | The pointer the UINT16 to store the attributes.
Returns:
if the operation is possible.

BOOLEAN RamHandler::GetCurrentDir ( WString & current_dir ) [static]

Changes the current working directory.

Parameters:
current_dir Buffer where to store the name of the current directory.
Returns:
whether the operation was successful.

BOOLEAN RamHandler::GetFileInfo | ( | const WString & | file_name,
 |  | RamFileInfo * | info
 | ) | [static]

Returns a file info record containing the following info about the file: name, size and timestamp.

Parameters:
file_name | The name of the file.
info | Pointer to the file info record where to store data.
Returns:
if the operation is successful.

UINT32 RamHandler::GetFreeSpaceSize ( ) [static]

Returns the number of available bytes free in the RAM drive.

Returns:
The number of free bytes.

RamError RamHandler::GetLastError ( ) [static]

Get the error code during last file operation

Returns:
the error code met last time.

UINT32 RamHandler::GetTotalSpaceSize ( ) [static]

Returns the number of bytes in the RAM drive.

Returns:
The number of bytes.

UINT32 RamHandler::GetUsedSpaceSize ( ) [static]

Returns the number of bytes used in the RAM drive.

Returns:
The number of used bytes.

void RamHandler::Initialize ( ) [static]

Initializes the root file, the current working directory and the capacity of the RAM drive. Must be called before any other method of this class.

BOOLEAN RamHandler::IsCurrentDir ( const RamHandle current_dir ) [static]

Returns whether the parameter points to the working directory.

Parameters:
current_dir RamHandle which represents the directory to check.
Returns:
whether the parameter handle is the current working directory

BOOLEAN RamHandler::IsDirectory ( const WString & dir_name ) [static]

Returns whether a path name is a directory or not.

Parameters:
dir_name The directory name to be checked.
Returns:
TRUE: the pathname is a directory FALSE: the pathname is not a directory

BOOLEAN RamHandler::MakeDir ( const WString & dir_name ) [static]

Creates a new directory.

Parameters:
dir_name The name of the directory to be created.
Returns:
if the operation is successful.

BOOLEAN RamHandler::Read | ( | RamHandle | hp,
 |  | INT32 | offset,
 |  | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 & | bytes_read
 | ) | [static]

Copies the data from the specified file to the buffer location in RAM. Only possible if the file exists and is opened for read-operations.

Parameters:
hp | The file handle.
offset | The offset within the file where to start copying from.
buffer | Pointer to the local store where to copy data to.
count | Number of bytes to copy.
bytes_read | Number of bytes actually read.
Returns:
if the operation is successful.

BOOLEAN RamHandler::RemoveDir ( const WString & dir_name ) [static]

Deletes the directory including all the files in it.

Parameters:
dir_name The name of the directory to be deleted.
Returns:
if the operation is successful.

BOOLEAN RamHandler::Rename | ( | const WString & | old_file_name,
 |  | const WString & | new_file_name
 | ) | [static]

An existing file with a specified name can be renamed to the new name. Not possible if the file is in the open state.

Parameters:
old_file_name | Specifies the old name of the file.
new_file_name | Specifies the new name for the file.
Returns:
if the operation is successful.

BOOLEAN RamHandler::Resize | ( | RamHandle | file_handle,
 |  | UINT32 | new_size
 | ) | [static]

An existing file can be resized to the new size. Not possible if the file is in the open state.

Parameters:
file_handle | Specifies the handle to the file.
new_size | Specifies the new size for the file.
Returns:
if the operation is successful.

BOOLEAN RamHandler::SetAttributes | ( | const WString & | filename,
 |  | UINT16 | attr
 | ) | [static]

Set the attributes of a file

Parameters:
filename | The file name.
attr | The attribute to set to the file.
Returns:
if the operation is possible.

BOOLEAN RamHandler::Truncate | ( | RamHandle | hp,
 |  | UINT32 | new_size
 | ) | [static]

Truncates the open file at hp to new_size. Any file blocks beyond new_size are freed and the file size is adjusted. The file pointer is left at the new end of the file.

Returns:
if the operation is successful.

BOOLEAN RamHandler::Write | ( | RamHandle | hp,
 |  | INT32 | offset,
 |  | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [static]

Copies the data from the specified location in RAM to the specified location in the file. Only possible if the file exists and is opened for write-operations.

Parameters:
hp | The file handle.
offset | The offset within the file where to start copying to.
buffer | Pointer to the local store where to copy data from.
count | Number of bytes to copy.
Returns:
if the operation is successful.

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamHandler.hpp
  • AddOns/AfsRam/RamHandler.cpp
Generated on Wed Jan 25 01:43:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamStorageDeviceImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamStorageDeviceImp Class Reference
[RAM File System support]

Storage device implementation for RAM storage device. More...

#include <Apoxi/AddOns/AfsRam/RamStorageDeviceImp.hpp>

Inheritance diagram for RamStorageDeviceImp:

[legend]
Collaboration diagram for RamStorageDeviceImp:

[legend]

Public Member Functions

virtual BOOLEAN | Exists (const Pathname &pathname) const
virtual BOOLEAN | Format (BOOLEAN quick=FALSE)
virtual UINT8 | GetDefaultChunkSize () const
virtual UINT32 | GetFreeVolumeSize () const
virtual WString | GetNativeDirectoryPathname (const Pathname &pathname) const
virtual WString | GetNativeFilePathname (const Pathname &pathname) const
virtual UINT32 | GetTotalVolumeSize () const
virtual UINT32 | GetUsedVolumeSize () const
virtual BOOLEAN | IsDirectory (const Pathname &pathname) const
virtual BOOLEAN | IsReady () const

Static Public Member Functions

static const WString & | GetId ()
Returns the storage device ID string.

Protected Member Functions

virtual DirectoryIteratorPtr | CreateDirectoryIterator (const Pathname &dir_pathname, const FileFilterPtr &filter) const
virtual FilePtr | CreateFileObject (const Pathname &pathname) const
RamStorageDeviceImp ()
Creates a new RAM storage device object.
virtual | ~RamStorageDeviceImp ()

Static Protected Member Functions

static BOOLEAN | Setup ()

Friends

class | RootFileSystem

Detailed Description

Storage device implementation for RAM storage device.

Class RamStorageDeviceImp implements the storage device interface for using the RAM file system within the root file system.

Constructor & Destructor Documentation

RamStorageDeviceImp::RamStorageDeviceImp ( ) [protected]

Creates a new RAM storage device object.

RamStorageDeviceImp::~RamStorageDeviceImp ( ) [protected, virtual]

Destroys this RAM storage device and unregisters it from the root file system.

Member Function Documentation

DirectoryIteratorPtr RamStorageDeviceImp::CreateDirectoryIterator | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter
 | ) | const [protected, virtual]

Creates a new directory iterator object for the specified pathname.

Parameters:
dir_pathname | The pathname of the directory.
filter | The filter which selects the files the iterator shall return.
Returns:
A DirectoryIteratorPtr wrapping either a new directory iterator object or 0 if there is not enough memory left.

Implements StorageDevice.

FilePtr RamStorageDeviceImp::CreateFileObject ( const Pathname & pathname ) const [protected, virtual]

Creates a new file object for the specified pathname.

Parameters:
pathname The pathname.
Returns:
A FilePtr wrapping either a new file object or 0 if there is not enough memory left.

Implements StorageDevice.

BOOLEAN RamStorageDeviceImp::Exists ( const Pathname & pathname ) const [virtual]

Tells if pathname exists. If it exists it may either be a file or a directory.

Implements StorageDevice.

BOOLEAN RamStorageDeviceImp::Format ( BOOLEAN quick = FALSE ) [virtual]

This method formats the actual storage device. It is only possible to format real devices. The root storage device cannot be formatted.

Returns:
The success of the operation.

Implements StorageDevice.

UINT8 RamStorageDeviceImp::GetDefaultChunkSize ( ) const [virtual]

Returns the default chunk size for operating in chunk mode on files stored on this storage device.

See also:
File::GetChunkSize()

File::SetChunkSize()

Implements StorageDevice.

UINT32 RamStorageDeviceImp::GetFreeVolumeSize ( ) const [virtual]

Returns the free volume size of the device in bytes.

Returns:
The free volume size of the device in bytes.

Implements StorageDevice.

const WString & RamStorageDeviceImp::GetId ( ) [static]

Returns the storage device ID string.

WString RamStorageDeviceImp::GetNativeDirectoryPathname ( const Pathname & pathname ) const [virtual]

Returns pathname in native directory name format. The native directory name format may differ from storage device to storage device.

Implements StorageDevice.

WString RamStorageDeviceImp::GetNativeFilePathname ( const Pathname & pathname ) const [virtual]

Returns pathname in native file name format. The native file name format may differ from storage device to storage device.

Implements StorageDevice.

UINT32 RamStorageDeviceImp::GetTotalVolumeSize ( ) const [virtual]

Returns the total volume size of the device in bytes.

Returns:
The total volume size of the device in bytes.

Implements StorageDevice.

UINT32 RamStorageDeviceImp::GetUsedVolumeSize ( ) const [virtual]

Returns the used volume size of the device in bytes. Note that this size is usually larger than the sum of the sizes of all stored files, since meta information to control the directory structure is stored on the device, too.

Returns:
The used volume size of the device in bytes.

Implements StorageDevice.

BOOLEAN RamStorageDeviceImp::IsDirectory ( const Pathname & pathname ) const [virtual]

Tells if pathname is a directory. This base implementation returns TRUE only for the root pathname, since every storage device is at least organized in a flat manner which we interpret as having a single root directory. The method is declared as abstract for when implementing a new storage device you can't forget to deal with this issue. If the derived storage device is organized in a flat manner, then the override of this abstract method might be a simple call to this base class implementation. If a derived class supports directories then implement this method accordingly.

Implements StorageDevice.

BOOLEAN RamStorageDeviceImp::IsReady ( ) const [virtual]

Tells if the device is ready for being accessed.

Implements StorageDevice.

BOOLEAN RamStorageDeviceImp::Setup ( ) [static, protected]

Sets up the storage device for usage. The method must be called before using the RAM storage device. It can be called as many times as convenient, however, only the first call does the work. If there is a setup problem FALSE is returned.

Friends And Related Function Documentation

friend class RootFileSystem [friend]

Reimplemented from StorageDevice.

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamStorageDeviceImp.hpp
  • AddOns/AfsRam/RamStorageDeviceImp.cpp
Generated on Wed Jan 25 01:43:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RamStorageMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RamStorageMapper Class Reference
[RAM File System support]

#include <Apoxi/AddOns/AfsRam/RamStorageMapper.hpp>

Collaboration diagram for RamStorageMapper:

[legend]

Public Member Functions

BOOLEAN | DeleteBlock (UINT32 block_index)
BOOLEAN | DeleteBlocks (UINT32 block_index, UINT32 count)
BOOLEAN | FormatStorage (UINT16 block_size=c_ram_storage_default_block_size)
UINT16 | GetBlockSize () const
BOOLEAN | GetFreeBlockIndex (UINT32 &block_index)
UINT32 | GetFreeSize () const
RamError | GetLastError () const
UINT32 | GetSize () const
UINT32 | GetUsedSize () const
BOOLEAN | IsBlockUsed (UINT32 block_index) const
BOOLEAN | ReadBlock (UINT32 block_index, void HUGE *block_buffer)
BOOLEAN | ReadBlocks (UINT32 block_index, void HUGE *buffer, UINT32 count)
BOOLEAN | WriteBlock (UINT32 block_index, const void HUGE *block_data)
BOOLEAN | WriteBlocks (UINT32 block_index, const void HUGE *buffer, UINT32 count)
~RamStorageMapper ()

Static Public Member Functions

static RamStorageMapper * | GetInstance ()

Protected Member Functions

void HUGE * | GetBlock (UINT32 block_index) const

Friends

class | RamFileObj

Constructor & Destructor Documentation

RamStorageMapper::~RamStorageMapper ( )

Destroys the RamStorageMapper

Member Function Documentation

BOOLEAN RamStorageMapper::DeleteBlock ( UINT32 block_index )

Deletes a block in the storage.

Parameters:
block_index The index of the block in the storage.
Returns:
Whether the operation was successful or not.

BOOLEAN RamStorageMapper::DeleteBlocks | ( | UINT32 | block_index,
 |  | UINT32 | count
 | ) |

Deletes several blocks in the storage.

Parameters:
block_index | The index of the first block to be deleted.
count | Number of blocks which shall be deleted.
Returns:
Whether the operation was successful or not.

BOOLEAN RamStorageMapper::FormatStorage ( UINT16 block_size = c_ram_storage_default_block_size )

Formats the storage.

Parameters:
block_size The new size of a block. Default is given by c_ram_storage_default_block_size in RamTypes.hpp.
Returns:
Whether the operation was successful or not.

void HUGE * RamStorageMapper::GetBlock ( UINT32 block_index ) const [protected]

Returns the address of a block with a certain index.

UINT16 RamStorageMapper::GetBlockSize ( ) const

Returns the block size of the RamStorageMapper. Default value is defined in c_ram_storage_default_block_size in RamTypes.hpp.

Returns:
Size of one allocation block in bytes.

BOOLEAN RamStorageMapper::GetFreeBlockIndex ( UINT32 & block_index )

Returns the index of the first unused block in the storage.

Parameters:
block_index A variable the index will be written into.
Returns:
Whether the operation was successful or not. FALSE means that the storage is full.

UINT32 RamStorageMapper::GetFreeSize ( ) const

Returns the size of the unused part of the storage.

Returns:
Unused size of the storage in bytes.

static RamStorageMapper* RamStorageMapper::GetInstance ( ) [inline, static]

Returns the instance of the Singleton implementation.

Returns:
Pointer to the RamStorageMapper instance.

RamError RamStorageMapper::GetLastError ( ) const

Returns the last error which occurred during operations on the storage. The types are defined as enumeration type RamError in RamTypes.hpp.

Returns:
The type of error which occurred in the last operation.

UINT32 RamStorageMapper::GetSize ( ) const

Returns the size of the storage.

Returns:
Total size of the storage in bytes.

UINT32 RamStorageMapper::GetUsedSize ( ) const

Returns the size of the used part of the storage. Default value is defined in c_ram_storage_default_size in RamTypes.hpp.

Returns:
Used size of the storage in bytes.

BOOLEAN RamStorageMapper::IsBlockUsed ( UINT32 block_index ) const

Returns whether a specific block is used or not.

Parameters:
block_index The index of any block in the storage.
Returns:
Whether the block is used or not.

BOOLEAN RamStorageMapper::ReadBlock | ( | UINT32 | block_index,
 |  | void HUGE * | block_buffer
 | ) |

Reads one block with the specified index into a given buffer.

Parameters:
block_index | The index of the block in the storage.
block_buffer | Pointer to a buffer. Its allocation and deallocation must be treated by the user.
Returns:
Whether the operation was successful or not.

BOOLEAN RamStorageMapper::ReadBlocks | ( | UINT32 | block_index,
 |  | void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

Reads several blocks from the storage.

Parameters:
block_index | The index of the first block to read.
buffer | Buffer to write into. Its allocation and deallocation must be treated by the user.
count | Number of blocks which shall be read.
Returns:
Whether the operation was successful or not.

BOOLEAN RamStorageMapper::WriteBlock | ( | UINT32 | block_index,
 |  | const void HUGE * | block_data
 | ) |

Writes one block into the storage.

Parameters:
block_index | The index of the block in the storage.
block_data | Pointer to a buffer containing the data to write into the storage.
Returns:
Whether the operation was successful or not.

BOOLEAN RamStorageMapper::WriteBlocks | ( | UINT32 | block_index,
 |  | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) |

Writes several blocks into the storage.

Parameters:
block_index | The index of the first block to be written.
buffer | Buffer to read content from. Its allocation and deallocation must be treated by the user.
count | Number of blocks which shall be written.
Returns:
Whether the operation was successful or not.

Friends And Related Function Documentation

friend class RamFileObj [friend]

The documentation for this class was generated from the following files:
  • AddOns/AfsRam/RamStorageMapper.hpp
  • AddOns/AfsRam/RamStorageMapper.cpp
Generated on Wed Jan 25 01:43:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RangeMappingPolicy Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RangeMappingPolicy Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Properties/MappingPolicy.hpp>

Inheritance diagram for RangeMappingPolicy:

[legend]
Collaboration diagram for RangeMappingPolicy:

[legend]

Public Member Functions

virtual INT | GetIndex (const DataItem &value) const
@see MappingPolicy::GetIndex
virtual DataItem | GetValue (INT index) const
@see MappingPolicy::GetValue
RangeMappingPolicy (INT range_count)
RangeMappingPolicy ()
default constructor
BOOLEAN | SetProperty (ResourceParser &parser, GuiObjectFactory::PropertyId property_id, INT object_id)
void | SetRangeCount (INT range_count)
virtual | ~RangeMappingPolicy ()
destructor

Detailed Description

RangeMappingPolicy for mapping of values between 0 and 100 to m_range_count number of indices (e.g. if m_range_count = 5: 0...20 -> 0, 21...40 -> 1, 41...60 -> 2, ...).

Constructor & Destructor Documentation

RangeMappingPolicy::RangeMappingPolicy ( )

default constructor

RangeMappingPolicy::RangeMappingPolicy ( INT range_count )

Parameters:
range_count Number of ranges, into which the total range of values should be devided.

RangeMappingPolicy::~RangeMappingPolicy ( ) [virtual]

destructor

Member Function Documentation

INT RangeMappingPolicy::GetIndex ( const DataItem & value ) const [virtual]

@see MappingPolicy::GetIndex

Reimplemented from MappingPolicy.

DataItem RangeMappingPolicy::GetValue ( INT index ) const [virtual]

@see MappingPolicy::GetValue

Reimplemented from MappingPolicy.

BOOLEAN RangeMappingPolicy::SetProperty | ( | ResourceParser & | parser,
 |  | GuiObjectFactory::PropertyId | property_id,
 |  | INT | object_id
 | ) |

Sets the parameters for objects generated by the GuiObjectFactory and Aragon.

Parameters:
parser | parser which parses the aragon file
property-id | id of the object's parameter to be set
object_id | id of the object.

Reimplemented from MappingPolicy.

void RangeMappingPolicy::SetRangeCount ( INT range_count ) [inline]

Parameters:
range_count Number of ranges, into which the total range of values should be devided.

The documentation for this class was generated from the following files:
  • Atl/Properties/MappingPolicy.hpp
  • Atl/Properties/MappingPolicy.cpp
Generated on Wed Jan 25 01:43:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RangeRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RangeRule Class Reference
[Auxiliary]

RangeRule checks whether data item is between rule item and rule2item More...

#include <Apoxi/Auxiliary/FilterRule.hpp>

Inheritance diagram for RangeRule:

[legend]
Collaboration diagram for RangeRule:

[legend]

Public Types

typedef FilterRule | Base

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &dataitem)
RangeRule (const DataItem &ruleitem, const DataItem &rule2item)
RangeRule ()
virtual | ~RangeRule ()

Detailed Description

RangeRule checks whether data item is between rule item and rule2item

Member Typedef Documentation

typedef FilterRule RangeRule::Base

Constructor & Destructor Documentation

RangeRule::RangeRule ( )

RangeRule::RangeRule | ( | const DataItem & | ruleitem,
 |  | const DataItem & | rule2item
 | ) |

RangeRule::~RangeRule ( ) [virtual]

Member Function Documentation

BOOLEAN RangeRule::ExecuteRule ( const DataItem & dataitem ) [virtual]

ExecuteRule does the actual comparision between the data item given in the argument and the value stored when the filter rule is constructed.

Implements FilterRule.

The documentation for this class was generated from the following files:
  • Auxiliary/FilterRule.hpp
  • Auxiliary/FilterRule.cpp
Generated on Wed Jan 25 01:43:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RatChangeModeChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RatChangeModeChangedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RatChangeModeChangedMsg:

[legend]
Collaboration diagram for RatChangeModeChangedMsg:

[legend]

Public Types

enum | { ID = 18612 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const RatChangeMode & | GetRatChangeMode () const
RatChangeModeChangedMsg (ExecutionContext *context, const RatChangeMode &rat_change_mode)
void | SetRatChangeMode (const RatChangeMode &rat_change_mode)
virtual | ~RatChangeModeChangedMsg ()

Detailed Description

RatChangeModeChangedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RatChangeModeChangedMsg::RatChangeModeChangedMsg | ( | ExecutionContext * | context,
 |  | const RatChangeMode & | rat_change_mode
 | ) |

RatChangeModeChangedMsg::~RatChangeModeChangedMsg ( ) [virtual]

Member Function Documentation

Message * RatChangeModeChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RatChangeModeChangedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const RatChangeMode& RatChangeModeChangedMsg::GetRatChangeMode ( ) const [inline]

void RatChangeModeChangedMsg::SetRatChangeMode ( const RatChangeMode & rat_change_mode ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:43:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RatStateMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RatStateMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RatStateMsg:

[legend]
Collaboration diagram for RatStateMsg:

[legend]

Public Types

enum | { ID = 18607 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const RadioAccessTechnology & | GetRadioAccessTechnology () const
RatStateMsg (ExecutionContext *context, const RadioAccessTechnology &radio_access_technology)
void | SetRadioAccessTechnology (const RadioAccessTechnology &radio_access_technology)
virtual | ~RatStateMsg ()

Detailed Description

RatStateMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RatStateMsg::RatStateMsg | ( | ExecutionContext * | context,
 |  | const RadioAccessTechnology & | radio_access_technology
 | ) |

RatStateMsg::~RatStateMsg ( ) [virtual]

Member Function Documentation

Message * RatStateMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RatStateMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const RadioAccessTechnology& RatStateMsg::GetRadioAccessTechnology ( ) const [inline]

void RatStateMsg::SetRadioAccessTechnology ( const RadioAccessTechnology & radio_access_technology ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:43:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Rdn Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Rdn Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for Rdn:

[legend]

Data Fields

PhoneNumber phone_number
RdnChoice selector
Subaddress subaddress

Field Documentation

PhoneNumber Rdn::phone_number

RdnChoice Rdn::selector

Subaddress Rdn::subaddress

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:43:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RealTimeClock Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RealTimeClock Class Reference
[Devices]

#include <Apoxi/Devices/BP30/RealTimeClock.hpp>

Inheritance diagram for RealTimeClock:

[legend]
Collaboration diagram for RealTimeClock:

[legend]

Public Types

enum RtcInfo {
DataNotValid, TimeChanged, DateChanged, MinuteTick,
AlarmReached
}

Public Member Functions

virtual const WCHAR * | GetName () const
virtual | ~RealTimeClock ()

Static Public Member Functions

static void | CleanUp ()
static void | ClearAlarm ()
static ControlArg | Control (INT command, ControlArg arg)
static DateTime | GetAlarm ()
static DateAndTime | GetLocalDateAndTime ()
static DateTime | GetLocalDateTime ()
static DateTime | GetSecureDateTime ()
static BOOLEAN | IsRTCStartUpEvent ()
static BOOLEAN | IsSecureClockValid ()
static void | SetAlarm (DateTime *date_time)
static BOOLEAN | SetLocalDate (Date *date)
static BOOLEAN | SetLocalDateTime (DateTime *date_time)
static BOOLEAN | SetLocalTime (Time *time)
static void | SetSleepMode ()

Protected Member Functions

virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStart ()
virtual void | OnStop ()
virtual void | OnStop ()
virtual void | OnStop ()
virtual void | OnStop ()
virtual void | OnStop ()

Data Structures

struct | DateAndTime

Detailed Description

RealTimeClock is the APOXI device abstraction interface for RTC hardware driver.

Member Enumeration Documentation

enum RealTimeClock::RtcInfo

This enumeration type is used as info parameter for RtcInfoMsg.

Enumerator:
DataNotValid
TimeChanged | RTC data are not valid.
DateChanged | The RTC time has changed.
MinuteTick | The RTC date has changed.
AlarmReached | An alarm has been reached.

Constructor & Destructor Documentation

RealTimeClock::~RealTimeClock ( ) [virtual]

Member Function Documentation

void RealTimeClock::CleanUp ( ) [static]

void RealTimeClock::ClearAlarm ( ) [static]

static ControlArg RealTimeClock::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) | [static]

See also:
AbstractDevice::Control

DateTime RealTimeClock::GetAlarm ( ) [static]

RealTimeClock::DateAndTime RealTimeClock::GetLocalDateAndTime ( ) [static]

Returns:
GMT date and time.

DateTime RealTimeClock::GetLocalDateTime ( ) [static]

const WCHAR * RealTimeClock::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

DateTime RealTimeClock::GetSecureDateTime ( ) [static]

The secure clock can not be changed by the user and is used e.g. for Digital Rights Management.

Returns:
DateTime object of secure clock.

BOOLEAN RealTimeClock::IsRTCStartUpEvent ( ) [static]

BOOLEAN RealTimeClock::IsSecureClockValid ( ) [static]

Returns:
Status of secure clock. FALSE e.g. if hardware indicates a power failure.

virtual void RealTimeClock::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void RealTimeClock::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void RealTimeClock::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void RealTimeClock::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

void RealTimeClock::OnStart ( ) [protected, virtual]

See also:
AbstractDevice::OnStart

Reimplemented from AbstractDevice.

virtual void RealTimeClock::OnStop ( ) [protected, virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

virtual void RealTimeClock::OnStop ( ) [protected, virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

virtual void RealTimeClock::OnStop ( ) [protected, virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

virtual void RealTimeClock::OnStop ( ) [protected, virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

void RealTimeClock::OnStop ( ) [protected, virtual]

See also:
AbstractDevice::OnStop

Reimplemented from AbstractDevice.

void RealTimeClock::SetAlarm ( DateTime * date_time ) [static]

BOOLEAN RealTimeClock::SetLocalDate ( Date * date ) [static]

BOOLEAN RealTimeClock::SetLocalDateTime ( DateTime * date_time ) [static]

BOOLEAN RealTimeClock::SetLocalTime ( Time * time ) [static]

void RealTimeClock::SetSleepMode ( ) [static]

The documentation for this class was generated from the following files:
  • Devices/BP30/RealTimeClock.hpp
  • Devices/MPE/RealTimeClock.hpp
  • Devices/MPEU/RealTimeClock.hpp
  • Devices/RealTimeClockInterface.hpp
  • Devices/SGold/RealTimeClock.hpp
  • Devices/Win32/RealTimeClock.hpp
  • Devices/BP30/RealTimeClock.cpp
  • Devices/MPE/RealTimeClock.cpp
  • Devices/MPEU/RealTimeClock.cpp
  • Devices/SGold/RealTimeClock.cpp
  • Devices/Win32/RealTimeClock.cpp
Generated on Wed Jan 25 01:43:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RealTimeClock::DateAndTime Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RealTimeClock::DateAndTime

RealTimeClock::DateAndTime Struct Reference

#include <Apoxi/Devices/RealTimeClockInterface.hpp>

Data Fields

UINT8 | day
INT16 | gmt_bias
UINT8 | hour
UINT16 | millisec
UINT8 | minute
UINT8 | month
UINT8 | second
UINT16 | year

Field Documentation

UINT8 RealTimeClock::DateAndTime::day

INT16 RealTimeClock::DateAndTime::gmt_bias

UINT8 RealTimeClock::DateAndTime::hour

UINT16 RealTimeClock::DateAndTime::millisec

UINT8 RealTimeClock::DateAndTime::minute

UINT8 RealTimeClock::DateAndTime::month

UINT8 RealTimeClock::DateAndTime::second

UINT16 RealTimeClock::DateAndTime::year

The documentation for this struct was generated from the following file:
  • Devices/RealTimeClockInterface.hpp
Generated on Wed Jan 25 01:43:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Record Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Record Class Reference

#include <Apoxi/AddOns/AdcExtensions/Record.hpp>

Inheritance diagram for Record:

[legend]

Public Member Functions

virtual const UINT8 * | GetData ()=0
virtual INT | GetPersistentSize ()=0
virtual BOOLEAN | IsRecordDeleted ()
virtual void | MarkDeleted ()
Record ()
virtual void | SetData (const UINT8 *data)=0

Detailed Description

Record specifies the interface for data records to be stored persistently by means of RecordHandler.

Constructor & Destructor Documentation

Record::Record ( ) [inline]

Member Function Documentation

virtual const UINT8* Record::GetData ( ) [pure virtual]

Implemented in PbNextFreeIdRecord, PbRecord, PbNumberRecord, BtHfRecord, CalendarRecord, SmsSettingsRecord, FmRadioSettingsRecord, FmRadioStationsRecord, ToDoRecord, and UibSettingsRecord.

virtual INT Record::GetPersistentSize ( ) [pure virtual]

Implemented in PbNextFreeIdRecord, PbRecord, PbNumberRecord, BtHfRecord, CalendarRecord, SmsSettingsRecord, FmRadioSettingsRecord, FmRadioStationsRecord, ToDoRecord, and UibSettingsRecord.

virtual BOOLEAN Record::IsRecordDeleted ( ) [inline, virtual]

Reimplemented in PbRecord, PbNumberRecord, CalendarRecord, SmsSettingsRecord, ToDoRecord, and UibSettingsRecord.

virtual void Record::MarkDeleted ( ) [inline, virtual]

Reimplemented in PbRecord, PbNumberRecord, CalendarRecord, SmsSettingsRecord, ToDoRecord, and UibSettingsRecord.

virtual void Record::SetData ( const UINT8 * data ) [pure virtual]

Implemented in PbNextFreeIdRecord, PbRecord, PbNumberRecord, BtHfRecord, CalendarRecord, SmsSettingsRecord, FmRadioSettingsRecord, FmRadioStationsRecord, ToDoRecord, and UibSettingsRecord.

The documentation for this class was generated from the following file:
  • AddOns/AdcExtensions/Record.hpp
Generated on Wed Jan 25 01:43:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RecordHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RecordHandler Class Reference

#include <Apoxi/AddOns/AdcExtensions/RecordHandler.hpp>

Collaboration diagram for RecordHandler:

[legend]

Public Member Functions

virtual BOOLEAN | AddRecord (Record *rec)
virtual BOOLEAN | DeleteAllRecords ()
virtual BOOLEAN | DeleteRecord (INT row)
virtual BOOLEAN | ExistsRecord (INT row)
INT | GetRowCount () const
BOOLEAN | Init (FilePtr file, Record *record, INT max_rows, BOOLEAN sequential=TRUE)
virtual BOOLEAN | LoadRecord (INT row, Record *rec)
BOOLEAN | Lock ()
Begin Transaction: Prevents File Close Operations.
RecordHandler ()
void | SetRecordTableValue (INT logical, INT physical)
virtual BOOLEAN | StoreRecord (INT row, Record *rec)
BOOLEAN | Unlock ()
End Transaction: Closes the File.
~RecordHandler ()

Data Structures

struct | StructuredDataHeader

Detailed Description

RecordHandler provides access to structured data stored in a File. Clients have to provide
  • a File as data source descriptor,
  • a Record which is used for deleting rows,
  • and the maximum number of rows to be stored in the file.
RecordHandler creates the file with a fixed size according to the maximum row count and fills all rows initially as deleted (row_count = 0). It maintains header information about the file:
  • header size
  • version of the record
  • the length of a record.

Constructor & Destructor Documentation

RecordHandler::RecordHandler ( )

RecordHandler::~RecordHandler ( )

Member Function Documentation

BOOLEAN RecordHandler::AddRecord ( Record * rec ) [virtual]

BOOLEAN RecordHandler::DeleteAllRecords ( ) [virtual]

BOOLEAN RecordHandler::DeleteRecord ( INT row ) [virtual]

BOOLEAN RecordHandler::ExistsRecord ( INT row ) [virtual]

INT RecordHandler::GetRowCount ( ) const

BOOLEAN RecordHandler::Init | ( | FilePtr | file,
 |  | Record * | record,
 |  | INT | max_rows,
 |  | BOOLEAN | sequential = TRUE
 | ) |

BOOLEAN RecordHandler::LoadRecord | ( | INT | row,
 |  | Record * | rec
 | ) | [virtual]

BOOLEAN RecordHandler::Lock ( )

Begin Transaction: Prevents File Close Operations.

void RecordHandler::SetRecordTableValue | ( | INT | logical,
 |  | INT | physical
 | ) |

BOOLEAN RecordHandler::StoreRecord | ( | INT | row,
 |  | Record * | rec
 | ) | [virtual]

BOOLEAN RecordHandler::Unlock ( )

End Transaction: Closes the File.

The documentation for this class was generated from the following files:
  • AddOns/AdcExtensions/RecordHandler.hpp
  • AddOns/AdcExtensions/RecordHandler.cpp
Generated on Wed Jan 25 01:43:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RecordSettings Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RecordSettings Class Reference
[MediaFramework]

#include <Apoxi/AddOns/MediaFramework/RecordSettings.hpp>

Public Types

enum | MediaQuality { QualityLow = 1, QualityNormal, QualityHigh }
Video/audio Quality. More...
enum | MediaSinkType { FilePathname, DataSink }

Public Member Functions

const INT | GetBrightness () const
const BOOLEAN | GetCameraNightMode () const
const INT | GetContrast () const
const UINT32 | GetMaxFileSize () const
const UINT32 | GetMaxRecordingDuration () const
const void * | GetMediaSink () const
const MediaSinkType | GetMediaSinkType () const
const MediaInfo::MediaCodec | GetVideoCodec () const
const MediaQuality | GetVideoQuality () const
RecordSettings (void *media_sink, MediaSinkType media_sink_type, MediaInfo::MediaCodec video_codec, MediaQuality video_quality, INT contrast, INT brightness, BOOLEAN camera_night_mode, UINT32 max_file_size, UINT32 max_recording_duration)
RecordSettings (INT frame_rate, XYDIM width, XYDIM height, UINT8 camera_dev_id, MediaQuality video_quality, MediaQuality audio_quality, MediaInfo::MediaCodec video_codec, MediaInfo::MediaCodec audio_codec, UINT32 max_file_size, class DataSink *media_sink)
RecordSettings (INT frame_rate, XYDIM width, XYDIM height, UINT8 camera_dev_id, MediaQuality video_quality, MediaQuality audio_quality, MediaInfo::MediaCodec video_codec, MediaInfo::MediaCodec audio_codec, UINT32 max_file_size, const char *media_sink)
RecordSettings ()
void | SetAudioCodec (MediaInfo::MediaCodec audio_codec)
void | SetMaxFileSize (UINT32 max_file_size)
void | SetMaxRecordingDuration (UINT32 max_recording_duration)
void | SetMediaSink (void *media_sink)
void | SetMediaSinkType (MediaSinkType sink_type)
void | SetVideoCodec (MediaInfo::MediaCodec video_codec)
~RecordSettings ()

Friends

class | EmApoxiRecordSettings
class | MediaRecorder
Clip info.

Detailed Description

Record settings for the media recorder.
See also:
MediaRecorder

Member Enumeration Documentation

enum RecordSettings::MediaQuality

Video/audio Quality.

Enumerator:
QualityLow
QualityNormal
QualityHigh

enum RecordSettings::MediaSinkType

The type of the media sink.

Enumerator:
FilePathname | the sink is of type Pathname (file name)
DataSink | the sink is of type Stream

Constructor & Destructor Documentation

RecordSettings::RecordSettings ( )

DefaultConstructor

RecordSettings::~RecordSettings ( )

Default Destructor

RecordSettings::RecordSettings | ( | INT | frame_rate,
 |  | XYDIM | width,
 |  | XYDIM | height,
 |  | UINT8 | camera_dev_id,
 |  | MediaQuality | video_quality,
 |  | MediaQuality | audio_quality,
 |  | MediaInfo::MediaCodec | video_codec,
 |  | MediaInfo::MediaCodec | audio_codec,
 |  | UINT32 | max_file_size,
 |  | const char * | media_sink
 | ) |

Constructor.

Parameters:
frame_rate | Video frame rate. If no video is recorded, this value shall be ignored.
width | Video Width. If no video is recorded, this value shall be ignored.
height | Video Height. If no video is recorded, this value shall be ignored.
camera_dev_id | Camera's device ID of the camera to be used. If no video is recorded, this value shall be ignored.
video_quality | Video encoding quality. If no video is recorded, this value shall be ignored.
audio_quality | Audio encoding quality. If no audio is recorded, this value shall be ignored.
video_codec | Video codec type to be used for encoding. If no video has to be recorded, this value has to be set to MediaInfo::UnknownCodec. If this value is set to MediaInfo::DefaultCodec, the Media Framework shall select a suitable/default video codec.
audio_codec | Audio codec type to be used for encoding. If no audio has to be recorded, this value has to be set to MediaInfo::UnknownCodec. If this value is set to MediaInfo::DefaultCodec, the Media Framework shall select a suitable/default audio codec.
max_file_size | Maximum recorded file size (in bytes). If this value is 0, the file size is not limited.
media_sink | Pointer to the media sink (i.e. the recording target which the media is stored to).

RecordSettings::RecordSettings | ( | INT | frame_rate,
 |  | XYDIM | width,
 |  | XYDIM | height,
 |  | UINT8 | camera_dev_id,
 |  | MediaQuality | video_quality,
 |  | MediaQuality | audio_quality,
 |  | MediaInfo::MediaCodec | video_codec,
 |  | MediaInfo::MediaCodec | audio_codec,
 |  | UINT32 | max_file_size,
 |  | class DataSink * | media_sink
 | ) |

Constructor.

Parameters:
frame_rate | Video frame rate. If no video is recorded, this value shall be ignored.
width | Video Width. If no video is recorded, this value shall be ignored.
height | Video Height. If no video is recorded, this value shall be ignored.
camera_dev_id | Camera's device ID of the camera to be used. If no video is recorded, this value shall be ignored.
video_quality | Video encoding quality. If no video is recorded, this value shall be ignored.
audio_quality | Audio encoding quality. If no audio is recorded, this value shall be ignored.
video_codec | Video codec type to be used for encoding. If no video has to be recorded, this value has to be set to MediaInfo::UnknownCodec. If this value is set to MediaInfo::DefaultCodec, the Media Framework shall select a suitable/default video codec.
audio_codec | Audio codec type to be used for encoding. If no audio has to be recorded, this value has to be set to MediaInfo::UnknownCodec. If this value is set to MediaInfo::DefaultCodec, the Media Framework shall select a suitable/default audio codec.
max_file_size | Maximum recorded file size (in bytes). If this value is 0, the file size is not limited.
media_sink | Pointer to the media sink (i.e. the recording target which the media is stored to).

RecordSettings::RecordSettings | ( | void * | media_sink,
 |  | MediaSinkType | media_sink_type,
 |  | MediaInfo::MediaCodec | video_codec,
 |  | MediaQuality | video_quality,
 |  | INT | contrast,
 |  | INT | brightness,
 |  | BOOLEAN | camera_night_mode,
 |  | UINT32 | max_file_size,
 |  | UINT32 | max_recording_duration
 | ) |

Constructor

Parameters:
media_sink | A void pointer to Media Sink. This can be either a character pointer if media_sink_type is FilePathname or could be a DataSink pointer if media_sink_type is DataSink.
media_sink_type | Could be either data sink or file path name.
video_codec | Video codec type to be used for encoding. If no video has to be recorded, this value has to be set to MediaInfo::UnknownCodec. If this value is set to MediaInfo::DefaultCodec, the Media Framework shall select a suitable/default video codec.
video_quality | Video encoding quality. If no video is recorded, this value shall be ignored.
contrast | Camera Contrast during recording session. Takes any value between 0 & 10
brightness | Camera brightness during recording session. Takes any value between 0 & 10.
max_file_size | Maximum recorded file size (in bytes). If this value is 0, the file size is not limited.
max_file_size | Maximum recorded file size (in bytes). If this value is 0, the file size is not limited.
media_sink | Pointer to the media sink (i.e. the recording target which the media is stored to).

Member Function Documentation

const INT RecordSettings::GetBrightness ( ) const [inline]

const BOOLEAN RecordSettings::GetCameraNightMode ( ) const [inline]

const INT RecordSettings::GetContrast ( ) const [inline]

const UINT32 RecordSettings::GetMaxFileSize ( ) const [inline]

const UINT32 RecordSettings::GetMaxRecordingDuration ( ) const [inline]

const void* RecordSettings::GetMediaSink ( ) const [inline]

const MediaSinkType RecordSettings::GetMediaSinkType ( ) const [inline]

const MediaInfo::MediaCodec RecordSettings::GetVideoCodec ( ) const [inline]

const MediaQuality RecordSettings::GetVideoQuality ( ) const [inline]

void RecordSettings::SetAudioCodec ( MediaInfo::MediaCodec audio_codec ) [inline]

void RecordSettings::SetMaxFileSize ( UINT32 max_file_size ) [inline]

void RecordSettings::SetMaxRecordingDuration ( UINT32 max_recording_duration ) [inline]

void RecordSettings::SetMediaSink ( void * media_sink ) [inline]

void RecordSettings::SetMediaSinkType ( MediaSinkType sink_type ) [inline]

void RecordSettings::SetVideoCodec ( MediaInfo::MediaCodec video_codec ) [inline]

Friends And Related Function Documentation

friend class EmApoxiRecordSettings [friend]

friend class MediaRecorder [friend]

Clip info.

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/RecordSettings.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/RecordSettings.cpp
Generated on Wed Jan 25 01:44:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Rect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Rect Class Reference
[GUI]

#include <Apoxi/Gui/Rect.hpp>

Public Member Functions

void | Expand (XYDIM left, XYDIM top=0, XYDIM right=0, XYDIM bottom=0)
XYDIM | GetBottom () const
XYDIM | GetHeight () const
XYDIM | GetLeft () const
Point | GetPos () const
Obsolete - use GetLeft() and GetTop() instead.
XYDIM | GetRight () const
Size | GetSize () const
XYDIM | GetTop () const
XYDIM | GetWidth () const
XYDIM | GetXPos () const
Obsolete - use GetLeft() instead.
XYDIM | GetYPos () const
Obsolete - use GetTop() instead.
const Rect & | Intersect (const Rect &rect)
BOOLEAN | IsEmpty () const
BOOLEAN | IsInside (const Rect &rect) const
void | Move (XYDIM dx, XYDIM dy)
BOOLEAN | operator!= (const Rect &rect) const
Checks whether the rect parameter is not identical to the object.
BOOLEAN | operator== (const Rect &rect) const
Checks whether the rect parameter is identical to the object.
Rect (const Rect &rect)
Rect (const Point &pos, const Size &size)
Rect (XYDIM left, XYDIM top, XYDIM right, XYDIM bottom)
Rect ()
void | Set (XYDIM left, XYDIM top, XYDIM right, XYDIM bottom)
void | SetBottom (XYDIM bottom)
void | SetEmpty ()
void | SetHeight (XYDIM height)
void | SetLeft (XYDIM left)
void | SetPos (XYDIM x, XYDIM y)
Obsolete - use Move() instead.
void | SetPos (const Point &pos)
Obsolete - use Move() instead.
void | SetRight (XYDIM right)
void | SetSize (XYDIM width, XYDIM height)
void | SetSize (const Size &size)
void | SetTop (XYDIM top)
void | SetWidth (XYDIM width)
void | SetXPos (XYDIM x)
Obsolete - use Move() instead.
void | SetYPos (XYDIM y)
Obsolete - use Move() instead.
const Rect & | Union (const Rect &rect)

Protected Attributes

XYDIM | m_bottom
XYDIM | m_left
XYDIM | m_right
XYDIM | m_top

Detailed Description

Describes a rectangle define by the top/left corner and the right/bottom corner.

Constructor & Destructor Documentation

Rect::Rect ( )

Constructor for an empty rectangle.

See also:
Rect::IsEmpty

Rect::Rect | ( | XYDIM | left,
 |  | XYDIM | top,
 |  | XYDIM | right,
 |  | XYDIM | bottom
 | ) |

Rect::Rect | ( | const Point & | pos,
 |  | const Size & | size
 | ) |

Rect::Rect ( const Rect & rect ) [inline]

Member Function Documentation

void Rect::Expand | ( | XYDIM | left,
 |  | XYDIM | top = 0,
 |  | XYDIM | right = 0,
 |  | XYDIM | bottom = 0
 | ) |

XYDIM Rect::GetBottom ( ) const [inline]

XYDIM Rect::GetHeight ( ) const [inline]

XYDIM Rect::GetLeft ( ) const [inline]

Point Rect::GetPos ( ) const

Obsolete - use GetLeft() and GetTop() instead.

XYDIM Rect::GetRight ( ) const [inline]

Size Rect::GetSize ( ) const [inline]

XYDIM Rect::GetTop ( ) const [inline]

XYDIM Rect::GetWidth ( ) const [inline]

XYDIM Rect::GetXPos ( ) const

Obsolete - use GetLeft() instead.

XYDIM Rect::GetYPos ( ) const

Obsolete - use GetTop() instead.

const Rect & Rect::Intersect ( const Rect & rect )

BOOLEAN Rect::IsEmpty ( ) const [inline]

Returns:
TRUE if the rectangle is empty. A rectangle is defined as empty, if GetRight() < GetLeft() or GetTop() < GetBottom()

BOOLEAN Rect::IsInside ( const Rect & rect ) const

void Rect::Move | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

BOOLEAN Rect::operator!= ( const Rect & rect ) const

Checks whether the rect parameter is not identical to the object.

BOOLEAN Rect::operator== ( const Rect & rect ) const

Checks whether the rect parameter is identical to the object.

void Rect::Set | ( | XYDIM | left,
 |  | XYDIM | top,
 |  | XYDIM | right,
 |  | XYDIM | bottom
 | ) |

void Rect::SetBottom ( XYDIM bottom ) [inline]

void Rect::SetEmpty ( )

See also:
Rect::IsEmpty

void Rect::SetHeight ( XYDIM height ) [inline]

void Rect::SetLeft ( XYDIM left ) [inline]

void Rect::SetPos | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

Obsolete - use Move() instead.

void Rect::SetPos ( const Point & pos )

Obsolete - use Move() instead.

void Rect::SetRight ( XYDIM right ) [inline]

void Rect::SetSize | ( | XYDIM | width,
 |  | XYDIM | height
 | ) |

void Rect::SetSize ( const Size & size )

void Rect::SetTop ( XYDIM top ) [inline]

void Rect::SetWidth ( XYDIM width ) [inline]

void Rect::SetXPos ( XYDIM x )

Obsolete - use Move() instead.

void Rect::SetYPos ( XYDIM y )

Obsolete - use Move() instead.

const Rect & Rect::Union ( const Rect & rect )

Field Documentation

XYDIM Rect::m_bottom [protected]

XYDIM Rect::m_left [protected]

XYDIM Rect::m_right [protected]

XYDIM Rect::m_top [protected]

The documentation for this class was generated from the following files:
  • Gui/Rect.hpp
  • Gui/Rect.cpp
Generated on Wed Jan 25 01:44:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialIndArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for RedialIndArg:

[legend]
Collaboration diagram for RedialIndArg:

[legend]

Public Types

enum | { ID = 1144 }

Public Member Functions

RedialIndArg ()

Static Public Member Functions

static const RedialIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

RedialIndArg: reflects the signal MN_REDIAL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialIndArg::RedialIndArg ( )

Member Function Documentation

const RedialIndArg & RedialIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:44:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RediallingDisabledIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RediallingDisabledIndArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for RediallingDisabledIndArg:

[legend]
Collaboration diagram for RediallingDisabledIndArg:

[legend]

Public Types

enum | { ID = 2142 }

Public Member Functions

BOOLEAN | IsDisable () const
RediallingDisabledIndArg ()
RediallingDisabledIndArg (BOOLEAN disable)
void | SetDisable (BOOLEAN disable)

Static Public Member Functions

static const RediallingDisabledIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

RediallingDisabledIndArg: reflects arguments of signal MN_REDIALLING_DISABLED_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RediallingDisabledIndArg::RediallingDisabledIndArg ( BOOLEAN disable )

RediallingDisabledIndArg::RediallingDisabledIndArg ( )

Member Function Documentation

const RediallingDisabledIndArg & RediallingDisabledIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN RediallingDisabledIndArg::IsDisable ( ) const [inline]

void RediallingDisabledIndArg::SetDisable ( BOOLEAN disable ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:44:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialQueryReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialQueryReqArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for RedialQueryReqArg:

[legend]
Collaboration diagram for RedialQueryReqArg:

[legend]

Public Types

enum | { ID = 2125 }

Public Member Functions

RedialQueryReqArg ()

Static Public Member Functions

static const RedialQueryReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

RedialQueryReqArg: reflects arguments of signal MN_REDIALLING_QUERY_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialQueryReqArg::RedialQueryReqArg ( )

Member Function Documentation

const RedialQueryReqArg & RedialQueryReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:44:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialRejArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for RedialRejArg:

[legend]
Collaboration diagram for RedialRejArg:

[legend]

Public Types

enum | { ID = 2141 }

Public Member Functions

RedialRejArg ()

Static Public Member Functions

static const RedialRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

RedialRejArg: reflects arguments of signal MN_REDIAL_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialRejArg::RedialRejArg ( )

Member Function Documentation

const RedialRejArg & RedialRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:44:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialSetupIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialSetupIndArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for RedialSetupIndArg:

[legend]
Collaboration diagram for RedialSetupIndArg:

[legend]

Public Types

enum | { ID = 1145 }

Public Member Functions

const PhoneNumber & | GetCalledPartyNo () const
const EccCategory & | GetEccCategory () const
const CallEstCause & | GetEstCause () const
const ServedCallApplication & | GetServedCallApp () const
const Tipd & | GetTipd () const
RedialSetupIndArg ()
void | SetCalledPartyNo (const PhoneNumber &called_party_no)
void | SetEccCategory (const EccCategory &ecc_category)
void | SetEstCause (const CallEstCause &est_cause)
void | SetServedCallApp (const ServedCallApplication &served_call_app)
void | SetTipd (const Tipd &tipd)

Static Public Member Functions

static const RedialSetupIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

RedialSetupIndArg: reflects arguments of signal MN_REDIAL_SETUP_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialSetupIndArg::RedialSetupIndArg ( )

Member Function Documentation

const RedialSetupIndArg & RedialSetupIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PhoneNumber& RedialSetupIndArg::GetCalledPartyNo ( ) const [inline]

const EccCategory& RedialSetupIndArg::GetEccCategory ( ) const [inline]

const CallEstCause& RedialSetupIndArg::GetEstCause ( ) const [inline]

const ServedCallApplication& RedialSetupIndArg::GetServedCallApp ( ) const [inline]

const Tipd& RedialSetupIndArg::GetTipd ( ) const [inline]

void RedialSetupIndArg::SetCalledPartyNo ( const PhoneNumber & called_party_no ) [inline]

void RedialSetupIndArg::SetEccCategory ( const EccCategory & ecc_category ) [inline]

void RedialSetupIndArg::SetEstCause ( const CallEstCause & est_cause ) [inline]

void RedialSetupIndArg::SetServedCallApp ( const ServedCallApplication & served_call_app ) [inline]

void RedialSetupIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:44:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialSetupMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialSetupMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RedialSetupMsg:

[legend]
Collaboration diagram for RedialSetupMsg:

[legend]

Public Types

enum | { ID = 18417 }

Public Member Functions

virtual Message * | Clone () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetPhoneNo () const
const ServedCallApplication & | GetServedCallApplication () const
RedialSetupMsg (ExecutionContext *context, const CallHdl &call_hdl, const PhoneNumber &phone_no, const ServedCallApplication &served_call_application)
void | SetCallHdl (const CallHdl &call_hdl)
void | SetPhoneNo (const PhoneNumber &phone_no)
void | SetServedCallApplication (const ServedCallApplication &served_call_application)
virtual | ~RedialSetupMsg ()

Detailed Description

RedialSetupMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialSetupMsg::RedialSetupMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl,
 |  | const PhoneNumber & | phone_no,
 |  | const ServedCallApplication & | served_call_application
 | ) |

RedialSetupMsg::~RedialSetupMsg ( ) [virtual]

Member Function Documentation

Message * RedialSetupMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& RedialSetupMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & RedialSetupMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& RedialSetupMsg::GetPhoneNo ( ) const [inline]

const ServedCallApplication& RedialSetupMsg::GetServedCallApplication ( ) const [inline]

void RedialSetupMsg::SetCallHdl ( const CallHdl & call_hdl ) [inline]

void RedialSetupMsg::SetPhoneNo ( const PhoneNumber & phone_no ) [inline]

void RedialSetupMsg::SetServedCallApplication ( const ServedCallApplication & served_call_application ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:44:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialStartedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialStartedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RedialStartedMsg:

[legend]
Collaboration diagram for RedialStartedMsg:

[legend]

Public Types

enum | { ID = 18415 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
RedialStartedMsg (ExecutionContext *context)
virtual | ~RedialStartedMsg ()

Detailed Description

RedialStartedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialStartedMsg::RedialStartedMsg ( ExecutionContext * context )

RedialStartedMsg::~RedialStartedMsg ( ) [virtual]

Member Function Documentation

Message * RedialStartedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RedialStartedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:44:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialStatusIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialStatusIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for RedialStatusIndArg:

[legend]
Collaboration diagram for RedialStatusIndArg:

[legend]

Public Types

enum | { ID = 1135 }

Public Member Functions

BOOLEAN | IsRedialStatus () const
RedialStatusIndArg ()
void | SetRedialStatus (BOOLEAN redial_status)

Static Public Member Functions

static const RedialStatusIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallSetupBySimtTkReqArg: necessary for context switch between SimTkApp and CallHandlingApp

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialStatusIndArg::RedialStatusIndArg ( )

Member Function Documentation

const RedialStatusIndArg & RedialStatusIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN RedialStatusIndArg::IsRedialStatus ( ) const [inline]

void RedialStatusIndArg::SetRedialStatus ( BOOLEAN redial_status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:44:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RedialStatusMsg:

[legend]
Collaboration diagram for RedialStatusMsg:

[legend]

Public Types

enum | { ID = 18423 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsRedialStatus () const
RedialStatusMsg (ExecutionContext *context, BOOLEAN redial_status)
virtual | ~RedialStatusMsg ()

Detailed Description

RedialStatusMsg: sent when MN_REDIAL_STAUTS_IND OR MN_REDAIL_QUERY_IND is received from stack

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialStatusMsg::RedialStatusMsg | ( | ExecutionContext * | context,
 |  | BOOLEAN | redial_status
 | ) |

RedialStatusMsg::~RedialStatusMsg ( ) [virtual]

Member Function Documentation

Message * RedialStatusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RedialStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BOOLEAN RedialStatusMsg::IsRedialStatus ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:44:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialStopIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialStopIndArg Class Reference

#include <Apoxi/Apc/MocStackMsgArgs.hpp>

Inheritance diagram for RedialStopIndArg:

[legend]
Collaboration diagram for RedialStopIndArg:

[legend]

Public Types

enum | { ID = 1146 }

Public Member Functions

RedialStopIndArg ()

Static Public Member Functions

static const RedialStopIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

RedialStopIndArg: reflects the signal MN_REDIAL_STOP_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialStopIndArg::RedialStopIndArg ( )

Member Function Documentation

const RedialStopIndArg & RedialStopIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MocStackMsgArgs.hpp
  • Apc/MocStackMsgArgs.cpp
Generated on Wed Jan 25 01:44:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialStoppedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialStoppedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RedialStoppedMsg:

[legend]
Collaboration diagram for RedialStoppedMsg:

[legend]

Public Types

enum | { ID = 18416 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
RedialStoppedMsg (ExecutionContext *context)
virtual | ~RedialStoppedMsg ()

Detailed Description

RedialStoppedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialStoppedMsg::RedialStoppedMsg ( ExecutionContext * context )

RedialStoppedMsg::~RedialStoppedMsg ( ) [virtual]

Member Function Documentation

Message * RedialStoppedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RedialStoppedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:44:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedialSuccessMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedialSuccessMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RedialSuccessMsg:

[legend]
Collaboration diagram for RedialSuccessMsg:

[legend]

Public Types

enum | { ID = 18418 }

Public Member Functions

virtual Message * | Clone () const
const CallHdl & | GetCallHdl () const
virtual const MsgMetaData & | GetMetaData () const
RedialSuccessMsg (ExecutionContext *context, const CallHdl &call_hdl)
void | SetCallHdl (const CallHdl &call_hdl)
virtual | ~RedialSuccessMsg ()

Detailed Description

RedialSuccessMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedialSuccessMsg::RedialSuccessMsg | ( | ExecutionContext * | context,
 |  | const CallHdl & | call_hdl
 | ) |

RedialSuccessMsg::~RedialSuccessMsg ( ) [virtual]

Member Function Documentation

Message * RedialSuccessMsg::Clone ( ) const [virtual]

Implements Message.

const CallHdl& RedialSuccessMsg::GetCallHdl ( ) const [inline]

const MsgMetaData & RedialSuccessMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void RedialSuccessMsg::SetCallHdl ( const CallHdl & call_hdl ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:44:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RedrawDisplayMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RedrawDisplayMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for RedrawDisplayMsg:

[legend]
Collaboration diagram for RedrawDisplayMsg:

[legend]

Public Types

enum | { ID = 1130 }

Public Member Functions

virtual Message * | Clone () const
INT | GetIndex () const
virtual const MsgMetaData & | GetMetaData () const
RedrawDisplayMsg (INT index)
virtual | ~RedrawDisplayMsg ()

Detailed Description

This message is sent when globally shared item renderer properties have been changed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RedrawDisplayMsg::RedrawDisplayMsg ( INT index )

RedrawDisplayMsg::~RedrawDisplayMsg ( ) [virtual]

Member Function Documentation

Message * RedrawDisplayMsg::Clone ( ) const [virtual]

Implements Message.

INT RedrawDisplayMsg::GetIndex ( ) const [inline]

const MsgMetaData & RedrawDisplayMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:44:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ReferableObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ReferableObject Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/ObjectReferrer.hpp>

Inheritance diagram for ReferableObject:

[legend]

Public Member Functions

virtual void | AddRef () const
virtual INT | RefCount () const
ReferableObject (INT refcount=0)
virtual void | Release () const
virtual | ~ReferableObject ()

Protected Member Functions

virtual void | OnZeroReferrers () const

Constructor & Destructor Documentation

ReferableObject::ReferableObject ( INT refcount = 0 ) [inline]

virtual ReferableObject::~ReferableObject ( ) [inline, virtual]

Member Function Documentation

virtual void ReferableObject::AddRef ( ) const [inline, virtual]

virtual void ReferableObject::OnZeroReferrers ( ) const [inline, protected, virtual]

virtual INT ReferableObject::RefCount ( ) const [inline, virtual]

virtual void ReferableObject::Release ( ) const [inline, virtual]

The documentation for this class was generated from the following file:
  • Auxiliary/ObjectReferrer.hpp
Generated on Wed Jan 25 01:44:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ReferenceLocation Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ReferenceLocation Struct Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpTypes.hpp>

Public Types

enum | { InvalidValue = 0xFFFFFFFF }

Public Member Functions

ReferenceLocation (const ReferenceLocation &rhs)
Copy constructor.
ReferenceLocation (INT32 latitude, INT32 longitude, INT32 altitude=InvalidValue)
Argument constructor.
ReferenceLocation ()
Default constructor.

Data Fields

INT32 | m_altitude
INT32 | m_latitude
Attributes.
INT32 | m_longitude

Member Enumeration Documentation

anonymous enum

Enumerator:
InvalidValue

Constructor & Destructor Documentation

ReferenceLocation::ReferenceLocation ( ) [inline]

Default constructor.

ReferenceLocation::ReferenceLocation | ( | INT32 | latitude,
 |  | INT32 | longitude,
 |  | INT32 | altitude = InvalidValue
 | ) | [inline]

Argument constructor.

ReferenceLocation::ReferenceLocation ( const ReferenceLocation & rhs ) [inline]

Copy constructor.

Field Documentation

INT32 ReferenceLocation::m_altitude

INT32 ReferenceLocation::m_latitude

Attributes.

INT32 ReferenceLocation::m_longitude

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/GLTP/GltpTypes.hpp
Generated on Wed Jan 25 01:44:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ReferenceTime Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ReferenceTime Struct Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpTypes.hpp>

Public Member Functions

ReferenceTime (const ReferenceTime &rhs)
Copy constructor.
ReferenceTime (UINT16 gps_week, UINT32 gps_tow, UINT32 precision)
Argument constructor.
ReferenceTime ()
Default constructor.

Data Fields

UINT32 | m_gps_tow
UINT16 | m_gps_week
Attributes.
UINT32 | m_precision

Constructor & Destructor Documentation

ReferenceTime::ReferenceTime ( ) [inline]

Default constructor.

ReferenceTime::ReferenceTime | ( | UINT16 | gps_week,
 |  | UINT32 | gps_tow,
 |  | UINT32 | precision
 | ) | [inline]

Argument constructor.

ReferenceTime::ReferenceTime ( const ReferenceTime & rhs ) [inline]

Copy constructor.

Field Documentation

UINT32 ReferenceTime::m_gps_tow

UINT16 ReferenceTime::m_gps_week

Attributes.

UINT32 ReferenceTime::m_precision

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/GLTP/GltpTypes.hpp
Generated on Wed Jan 25 01:44:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RefreshComponentMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RefreshComponentMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for RefreshComponentMsg:

[legend]
Collaboration diagram for RefreshComponentMsg:

[legend]

Public Types

enum | { ID = 1123 }

Public Member Functions

virtual Message * | Clone () const
Component * | GetComponent () const
virtual const MsgMetaData & | GetMetaData () const
RefreshComponentMsg (Component *component)
virtual | ~RefreshComponentMsg ()

Detailed Description

This message is sent when a component has to be refrehed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RefreshComponentMsg::RefreshComponentMsg ( Component * component )

RefreshComponentMsg::~RefreshComponentMsg ( ) [virtual]

Member Function Documentation

Message * RefreshComponentMsg::Clone ( ) const [virtual]

Implements Message.

Component* RefreshComponentMsg::GetComponent ( ) const [inline]

const MsgMetaData & RefreshComponentMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:44:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegApp Class Reference

#include <Applications/RegEditorClient/RegApp.hpp>

Collaboration diagram for RegApp:

[legend]

Public Member Functions

void | Init ()
RegApp ()
Constructor.
virtual | ~RegApp ()
Destructor.

Static Public Member Functions

static RegApp * | GetInstance ()

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnStartup ()

Constructor & Destructor Documentation

RegApp::RegApp ( )

Constructor.

RegApp::~RegApp ( ) [virtual]

Destructor.

Member Function Documentation

RegApp * RegApp::GetInstance ( ) [static]

void RegApp::Init ( )

void RegApp::OnClose ( ) [protected, virtual]

BOOLEAN RegApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN RegApp::OnMessage ( const Message & msg ) [protected, virtual]

void RegApp::OnOpen ( ) [protected, virtual]

void RegApp::OnStartup ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/RegEditorClient/RegApp.hpp
  • Applications/RegEditorClient/RegApp.cpp
Generated on Wed Jan 25 01:44:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegAppCommon Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegAppCommon Class Reference

#include <Applications/RegEditorClient/RegAppCommon.hpp>

Collaboration diagram for RegAppCommon:

[legend]

Static Public Member Functions

static DataItem * | GetInstanceDataItem ()
static RegEncoderDecoder::IteratorObjResult * | GetInstanceIteratorObj ()
static RegEncoderDecoder::Mobile2PCMsg * | GetInstanceMobile2PC ()
static RegEncoderDecoder::PC2MobileMsg * | GetInstancePC2Mobile ()
static Uri * | GetInstanceUri ()

Member Function Documentation

DataItem * RegAppCommon::GetInstanceDataItem ( ) [static]

RegEncoderDecoder::IteratorObjResult * RegAppCommon::GetInstanceIteratorObj ( ) [static]

RegEncoderDecoder::Mobile2PCMsg * RegAppCommon::GetInstanceMobile2PC ( ) [static]

RegEncoderDecoder::PC2MobileMsg * RegAppCommon::GetInstancePC2Mobile ( ) [static]

Uri * RegAppCommon::GetInstanceUri ( ) [static]

The documentation for this class was generated from the following files:
  • Applications/RegEditorClient/RegAppCommon.hpp
  • Applications/RegEditorClient/RegAppCommon.cpp
Generated on Wed Jan 25 01:44:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegAppFirstWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegAppFirstWin Class Reference

#include <Applications/RegEditorClient/RegAppFirstWin.hpp>

Collaboration diagram for RegAppFirstWin:

[legend]

Public Member Functions

void | Init ()
RegAppFirstWin ()
virtual | ~RegAppFirstWin ()

Data Fields

RegAppWin * m_result_win1

Protected Member Functions

virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnOpen ()

Constructor & Destructor Documentation

RegAppFirstWin::RegAppFirstWin ( )

RegAppFirstWin::~RegAppFirstWin ( ) [virtual]

Member Function Documentation

void RegAppFirstWin::Init ( )

BOOLEAN RegAppFirstWin::OnConfirm ( ) [protected, virtual]

void RegAppFirstWin::OnLayoutClient ( ) [protected, virtual]

void RegAppFirstWin::OnOpen ( ) [protected, virtual]

Field Documentation

RegAppWin* RegAppFirstWin::m_result_win1

The documentation for this class was generated from the following files:
  • Applications/RegEditorClient/RegAppFirstWin.hpp
  • Applications/RegEditorClient/RegAppFirstWin.cpp
Generated on Wed Jan 25 01:44:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegAppWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegAppWin Class Reference

#include <Applications/RegEditorClient/RegAppWin.hpp>

Collaboration diagram for RegAppWin:

[legend]

Public Member Functions

void | ConnectToPC (const IpAddr &ip_addr, UINT16 port_no)
void | FindDataConnProfiles ()
Only for target.
void | HandleByteStream (UINT8 *ptr)
void | Init ()
void | InitSocket ()
RegAppWin ()
Constructor.
void | SendRegisterNotification (const Uri &uri)
BOOLEAN | SendSetUpMsgToPC ()
Sends setup message to PC on application startup.
~RegAppWin ()
Destructor.

Static Public Member Functions

static RegAppWin * | GetInstance ()

Static Public Attributes

static INT16 | m_lock_id = 0
static BOOLEAN | m_socket_connected = FALSE

Protected Member Functions

virtual void | OnOpen ()

Constructor & Destructor Documentation

RegAppWin::RegAppWin ( )

Constructor.

RegAppWin::~RegAppWin ( )

Destructor.

Member Function Documentation

void RegAppWin::ConnectToPC | ( | const IpAddr & | ip_addr,
 |  | UINT16 | port_no
 | ) |

void RegAppWin::FindDataConnProfiles ( )

Only for target.

RegAppWin * RegAppWin::GetInstance ( ) [static]

void RegAppWin::HandleByteStream ( UINT8 * ptr )

void RegAppWin::Init ( )

void RegAppWin::InitSocket ( )

void RegAppWin::OnOpen ( ) [protected, virtual]

void RegAppWin::SendRegisterNotification ( const Uri & uri )

BOOLEAN RegAppWin::SendSetUpMsgToPC ( )

Sends setup message to PC on application startup.

Field Documentation

INT16 RegAppWin::m_lock_id = 0 [static]

BOOLEAN RegAppWin::m_socket_connected = FALSE [static]

The documentation for this class was generated from the following files:
  • Applications/RegEditorClient/RegAppWin.hpp
  • Applications/RegEditorClient/RegAppWin.cpp
Generated on Wed Jan 25 01:44:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegBlobObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegBlobObject Class Reference

#include <Apoxi/Auxiliary/RegBlobObject.hpp>

Inheritance diagram for RegBlobObject:

[legend]
Collaboration diagram for RegBlobObject:

[legend]

Public Types

typedef BlobObject | Base

Public Member Functions

void | Allocate (INT length)
Allocates memory for the data, existing data will be removed!
void | Append (const UINT8 *data, INT length)
Appends data to the end of RegBlobObject, existing data will not be lost!
void | Clear ()
Clears the data.
virtual GenericObject * | Copy () const
Creates a copy of the object itself. Also the data pointed to and the length is copied.
void | CutOff (INT length)
Cuts off the given length of bytes from the beginning of the data.
virtual GenericTypeId | GetTypeId ()
Returns the identity of the RegBlobObject class.
BOOLEAN | IsEmpty () const
Retruns TRUE, if data is.
virtual BOOLEAN | IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself, must be of the same type RegBlobObject.
RegBlobObject & | operator= (const RegBlobObject &szCopy)
Assignment operator.
INT | Peek (INT offset, UINT8 *&data, INT length)
INT | Poke (INT offset, const UINT8 *data, INT length)
void | Reallocate (INT length)
Reallocates memory for the data, existing data will not be lost!
RegBlobObject (const RegBlobObject &obj)
Copy Constructor.
RegBlobObject (const UINT8 *data, INT length, const CHAR *mimetype)
Constructor which initializes the object with a pointer to data and the data length.
RegBlobObject ()
Default Constructor.
INT32 | RegGetDataSize ()
get blobdata size
BOOLEAN | RegGetMimeType (String &mime_type)
fill in the mime_type with the mimetype of RegBlobObject
INT16 | RegGetMimeTypeSize ()
get Mime Type size
INT32 | RegGetSize ()
fill in the size with the size of the blob object including the mimetype size
BOOLEAN | RegSetMimeType (String &mime_type)
sets the mimetype of RegBlobObject with mime_type
void | Update (const UINT8 *data, INT length, const CHAR *mime_type)
Update the data, existing data will be removed!
virtual | ~RegBlobObject ()
Destructor of the object. The data pointed to is deleted.

Detailed Description

RegBlobObject contains a pointer to allocated data, mimetype of the data and the length of this data. It can be used to export data from a provider where data inside the provider is changed during the usage of the RegBlobObject object. All data is copied during construction time and deleted during destruction time.

Member Typedef Documentation

typedef BlobObject RegBlobObject::Base

Reimplemented from BlobObject.

Constructor & Destructor Documentation

RegBlobObject::RegBlobObject ( )

Default Constructor.

RegBlobObject::RegBlobObject | ( | const UINT8 * | data,
 |  | INT | length,
 |  | const CHAR * | mimetype
 | ) |

Constructor which initializes the object with a pointer to data and the data length.

RegBlobObject::RegBlobObject ( const RegBlobObject & obj )

Copy Constructor.

RegBlobObject::~RegBlobObject ( ) [virtual]

Destructor of the object. The data pointed to is deleted.

Member Function Documentation

void RegBlobObject::Allocate ( INT length )

Allocates memory for the data, existing data will be removed!

Reimplemented from BlobObject.

void RegBlobObject::Append | ( | const UINT8 * | data,
 |  | INT | length
 | ) |

Appends data to the end of RegBlobObject, existing data will not be lost!

Reimplemented from BlobObject.

void RegBlobObject::Clear ( )

Clears the data.

Reimplemented from BlobObject.

GenericObject * RegBlobObject::Copy ( ) const [virtual]

Creates a copy of the object itself. Also the data pointed to and the length is copied.

Reimplemented from BlobObject.

void RegBlobObject::CutOff ( INT length )

Cuts off the given length of bytes from the beginning of the data.

Reimplemented from BlobObject.

GenericTypeId RegBlobObject::GetTypeId ( ) [virtual]

Returns the identity of the RegBlobObject class.

Reimplemented from BlobObject.

BOOLEAN RegBlobObject::IsEmpty ( ) const [inline]

Retruns TRUE, if data is.

Reimplemented from BlobObject.

BOOLEAN RegBlobObject::IsEqual ( GenericObject * object ) [virtual]

Compares the object parameter with the object instance itself, must be of the same type RegBlobObject.

Reimplemented from BlobObject.

RegBlobObject & RegBlobObject::operator= ( const RegBlobObject & szCopy )

Assignment operator.

INT RegBlobObject::Peek | ( | INT | offset,
 |  | UINT8 *& | data,
 |  | INT | length
 | ) |

Reads data with given length out from the RegBlobObject (starting with offset). If length == -1, then the maximum possible data (from offset to end of data) is returned. Returns the number of read bytes.

Reimplemented from BlobObject.

INT RegBlobObject::Poke | ( | INT | offset,
 |  | const UINT8 * | data,
 |  | INT | length
 | ) |

Writes data into the RegBlobObject (starting with offset). Data will be truncated, if there is no more space to store in RegBlobObject. Returns the number of written bytes.

Reimplemented from BlobObject.

void RegBlobObject::Reallocate ( INT length )

Reallocates memory for the data, existing data will not be lost!

Reimplemented from BlobObject.

INT32 RegBlobObject::RegGetDataSize ( ) [inline]

get blobdata size

BOOLEAN RegBlobObject::RegGetMimeType ( String & mime_type )

fill in the mime_type with the mimetype of RegBlobObject

INT16 RegBlobObject::RegGetMimeTypeSize ( ) [inline]

get Mime Type size

INT32 RegBlobObject::RegGetSize ( ) [inline]

fill in the size with the size of the blob object including the mimetype size

BOOLEAN RegBlobObject::RegSetMimeType ( String & mime_type )

sets the mimetype of RegBlobObject with mime_type

void RegBlobObject::Update | ( | const UINT8 * | data,
 |  | INT | length,
 |  | const CHAR * | mime_type
 | ) |

Update the data, existing data will be removed!

The documentation for this class was generated from the following files:
  • Auxiliary/RegBlobObject.hpp
  • Auxiliary/RegBlobObject.cpp
Generated on Wed Jan 25 01:44:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegCbNotifyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegCbNotifyMsg Class Reference
[Afs]

#include <Apoxi/Afs/NotificationTable.hpp>

Inheritance diagram for RegCbNotifyMsg:

[legend]
Collaboration diagram for RegCbNotifyMsg:

[legend]

Public Member Functions

virtual Message * | Clone () const
virtual void | Execute ()
RegCbNotifyMsg (ExecutionContext *context, void *callback, const Uri &uri)
virtual | ~RegCbNotifyMsg ()

Detailed Description

Message Sent from Registry -> Base Application

Constructor & Destructor Documentation

RegCbNotifyMsg::RegCbNotifyMsg | ( | ExecutionContext * | context,
 |  | void * | callback,
 |  | const Uri & | uri
 | ) |

RegCbNotifyMsg::~RegCbNotifyMsg ( ) [virtual]

Member Function Documentation

Message * RegCbNotifyMsg::Clone ( ) const [virtual]

Reimplemented from ContextExecuteMsg.

void RegCbNotifyMsg::Execute ( ) [virtual]

Reimplemented from ContextExecuteMsg.

The documentation for this class was generated from the following files:
  • Afs/NotificationTable.hpp
  • Afs/NotificationTable.cpp
Generated on Wed Jan 25 01:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegDeletionBufferEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegDeletionBufferEntry Class Reference
[Afs]

#include <Apoxi/Afs/RegDeleteBuffer.hpp>

Public Member Functions

void | AddToDeleteBuffer (INT16 file_id, INT16 transac_id)
void | DecrementDelBufCount ()
void | FreeDeletionBuffer (INT16 transaction_id)
UINT | GetDelBufCount ()
void | IncrementDelBufCount ()
void | Init (UINT8 *raw_memory)
void | MoveNextElements (INT16 index)
RegDeletionBufferEntry ()
default constructor
void | ResetDeletionBuffer ()
~RegDeletionBufferEntry ()
default destructor

Constructor & Destructor Documentation

RegDeletionBufferEntry::RegDeletionBufferEntry ( ) [inline]

default constructor

The documentation for this class was generated from the following files:
  • Afs/RegDeleteBuffer.hpp
  • Afs/RegDeleteBuffer.cpp
Generated on Wed Jan 25 01:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegDirtyFile Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegDirtyFile Struct Reference
[Afs]

structure of dirty file More...

#include <Apoxi/Afs/DirtyFileHandler.hpp>

Collaboration diagram for RegDirtyFile:

[legend]

Data Fields

BOOLEAN | m_dirty_flag
RegFileHeader m_file_header
INT16 | m_last_commited_transaction

Detailed Description

structure of dirty file

  +-------------------------------------------------------------------+
  | 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8|
  +---------------------------------+---------------------------------+
  |     Version    |    File Type   |         Node Count (n)          |
  +----------------+----------------+---------------------------------+
  |                       Last Transaction                            |
  +----------------+--------------------------------------------------+
  |  Dirty Flag    |
  +----------------+

Field Documentation

BOOLEAN RegDirtyFile::m_dirty_flag

RegFileHeader RegDirtyFile::m_file_header

INT16 RegDirtyFile::m_last_commited_transaction

The documentation for this struct was generated from the following file:
  • Afs/DirtyFileHandler.hpp
Generated on Wed Jan 25 01:44:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegEncoderDecoder Class Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Collaboration diagram for RegEncoderDecoder:

[legend]

Public Types

enum | IteratorType { IteratorUri = 0x20, IteratorInteriorMetaData = 0x21, IteratorNodeType = 0x22, IteratorLeafMetaData = 0x23 }
typedef RegEncoderDecoder::Mobile2PCMsg | Mobile2PCMsg
enum MsgID {
MobileShutdown = 0x01, Notification = 0x02, ResponseMessage = 0x03, Get = 0x80,
Set = 0x81, CreateInterior = 0x82, Delete = 0x83, Lock = 0x84,
Unlock = 0x85, RegisterNotify = 0x86, ConnectionClose = 0x87, ConnectionResponse = 0x88,
BlobResponse = 0x89, SetExtn = 0x90, GetIterator = 0xC0, SetIterator = 0xC1,
TraverseNext = 0xC2, TraverseUp = 0xC3, TraverseDown = 0xC4, GetLeafMetaData = 0xC5,
GetInteriorMetaData = 0xC6, EnableTransaction = 0xD0, Commit = 0xD1
}
enum | PayloadType { PayloadDataItem, PayloadIteratorObj, PayloadInteger = 0x30 }
typedef RegEncoderDecoder::PC2MobileMsg | PC2MobileMsg
typedef RegEncoderDecoder::Response | Response
enum ResponseType {
RegSuccess = 0x00, RegError = 0x01, NoData = 0x03, Locked = 0x04,
Unlocked = 0x05, RegNoService = 0x06, UnSuppotedType = 0x07, RegResNoGetOnInterior = 0x08,
RegResNodeAlreadyExists = 0x09, RegResChildLocked = 0x0A, InvalidRequest = 0xF0
}
typedef RegEncoderDecoder::SetUpMsg | SetUpMsg
typedef RegEncoderDecoder::UriAndPayload | UriAndPayload

Public Member Functions

BOOLEAN | Decode (UINT8 *buffer, PC2MobileMsg &, FLAG &in_out)
BOOLEAN | Encode (UINT8 *buffer, Mobile2PCMsg &msg, UINT8 packetnumber, UINT16 *NoOfBytesEncoded)
BOOLEAN | EncodeSetupMsg (UINT8 *buffer, UINT16 *NoOfBytesEncoded)
~RegEncoderDecoder ()

Static Public Member Functions

static RegEncoderDecoder * | GetInstance ()

Static Public Attributes

static UINT8 | extra_bytes

Data Structures

struct | IteratorObjResult
struct | Mobile2PCMsg
struct | Payload
struct | PC2MobileMsg
struct | RegIteratorNodeType
struct | Response
struct | SetUpMsg
struct | UriAndPayload

Member Typedef Documentation

typedef struct RegEncoderDecoder::Mobile2PCMsg RegEncoderDecoder::Mobile2PCMsg

typedef struct RegEncoderDecoder::PC2MobileMsg RegEncoderDecoder::PC2MobileMsg

typedef struct RegEncoderDecoder::Response RegEncoderDecoder::Response

typedef struct RegEncoderDecoder::SetUpMsg RegEncoderDecoder::SetUpMsg

typedef struct RegEncoderDecoder::UriAndPayload RegEncoderDecoder::UriAndPayload

Member Enumeration Documentation

enum RegEncoderDecoder::IteratorType

Enumerator:
IteratorUri
IteratorInteriorMetaData
IteratorNodeType
IteratorLeafMetaData

enum RegEncoderDecoder::MsgID

Enumerator:
MobileShutdown
Notification
ResponseMessage
Get
Set
CreateInterior
Delete
Lock
Unlock
RegisterNotify
ConnectionClose
ConnectionResponse
BlobResponse
SetExtn
GetIterator
SetIterator
TraverseNext
TraverseUp
TraverseDown
GetLeafMetaData
GetInteriorMetaData
EnableTransaction
Commit

enum RegEncoderDecoder::PayloadType

Enumerator:
PayloadDataItem
PayloadIteratorObj
PayloadInteger

enum RegEncoderDecoder::ResponseType

Enumerator:
RegSuccess
RegError
NoData
Locked
Unlocked
RegNoService
UnSuppotedType
RegResNoGetOnInterior
RegResNodeAlreadyExists
RegResChildLocked
InvalidRequest

Constructor & Destructor Documentation

RegEncoderDecoder::~RegEncoderDecoder ( ) [inline]

Member Function Documentation

BOOLEAN RegEncoderDecoder::Decode | ( | UINT8 * | buffer,
 |  | PC2MobileMsg & | ,
 |  | FLAG & | in_out
 | ) |

BOOLEAN RegEncoderDecoder::Encode | ( | UINT8 * | buffer,
 |  | Mobile2PCMsg & | msg,
 |  | UINT8 | packetnumber,
 |  | UINT16 * | NoOfBytesEncoded
 | ) |

BOOLEAN RegEncoderDecoder::EncodeSetupMsg | ( | UINT8 * | buffer,
 |  | UINT16 * | NoOfBytesEncoded
 | ) |

RegEncoderDecoder * RegEncoderDecoder::GetInstance ( ) [static]

Field Documentation

UINT8 RegEncoderDecoder::extra_bytes [static]

The documentation for this class was generated from the following files:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
  • Applications/RegEditorClient/RegEncoderDecoder.cpp
Generated on Wed Jan 25 01:44:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::IteratorObjResult Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::IteratorObjResult

RegEncoderDecoder::IteratorObjResult Struct Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Collaboration diagram for RegEncoderDecoder::IteratorObjResult:

[legend]

Data Fields

union {
RegIterator::InteriorMetaData m_interior_meta_data
RegIteratorNodeType m_iter_nodetype
RegIterator::LeafMetaData m_leaf_meta_data
Uri * m_uri
} m_iterator_obj
IteratorType m_iterator_type

Field Documentation

RegIterator::InteriorMetaData RegEncoderDecoder::IteratorObjResult::m_interior_meta_data

RegIteratorNodeType RegEncoderDecoder::IteratorObjResult::m_iter_nodetype

union { ... } RegEncoderDecoder::IteratorObjResult::m_iterator_obj

IteratorType RegEncoderDecoder::IteratorObjResult::m_iterator_type

RegIterator::LeafMetaData RegEncoderDecoder::IteratorObjResult::m_leaf_meta_data

Uri* RegEncoderDecoder::IteratorObjResult::m_uri

The documentation for this struct was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::Mobile2PCMsg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::Mobile2PCMsg

RegEncoderDecoder::Mobile2PCMsg Struct Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Data Fields

MsgID m_msg_id
RegEncoderDecoder::Mobile2PCMsg::msg msg

Data Structures

union msg

Field Documentation

MsgID RegEncoderDecoder::Mobile2PCMsg::m_msg_id

union RegEncoderDecoder::Mobile2PCMsg::msg RegEncoderDecoder::Mobile2PCMsg::msg

The documentation for this struct was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::Mobile2PCMsg::msg Union Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::Mobile2PCMsg::msg

RegEncoderDecoder::Mobile2PCMsg::msg Union Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Collaboration diagram for RegEncoderDecoder::Mobile2PCMsg::msg:

[legend]

Data Fields

Response m_response
Uri * m_uri

Field Documentation

Response RegEncoderDecoder::Mobile2PCMsg::msg::m_response

Uri* RegEncoderDecoder::Mobile2PCMsg::msg::m_uri

The documentation for this union was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::Payload Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::Payload

RegEncoderDecoder::Payload Struct Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Collaboration diagram for RegEncoderDecoder::Payload:

[legend]

Data Fields

PayloadType m_type
union {
DataItem * m_dataitem
IteratorObjResult * m_iterator_res_obj
INT16 m_lockinfo
} payload_obj

Field Documentation

DataItem* RegEncoderDecoder::Payload::m_dataitem

IteratorObjResult* RegEncoderDecoder::Payload::m_iterator_res_obj

INT16 RegEncoderDecoder::Payload::m_lockinfo

PayloadType RegEncoderDecoder::Payload::m_type

union { ... } RegEncoderDecoder::Payload::payload_obj

The documentation for this struct was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::PC2MobileMsg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::PC2MobileMsg

RegEncoderDecoder::PC2MobileMsg Struct Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Data Fields

RegEncoderDecoder::PC2MobileMsg::msg msg
MsgID msg_id

Data Structures

union msg

Field Documentation

union RegEncoderDecoder::PC2MobileMsg::msg RegEncoderDecoder::PC2MobileMsg::msg

MsgID RegEncoderDecoder::PC2MobileMsg::msg_id

The documentation for this struct was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::PC2MobileMsg::msg Union Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::PC2MobileMsg::msg

RegEncoderDecoder::PC2MobileMsg::msg Union Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Collaboration diagram for RegEncoderDecoder::PC2MobileMsg::msg:

[legend]

Data Fields

INT16 m_lock_id
ResponseType m_res_type
Uri * m_uri
UriAndPayload m_uri_payload

Field Documentation

INT16 RegEncoderDecoder::PC2MobileMsg::msg::m_lock_id

ResponseType RegEncoderDecoder::PC2MobileMsg::msg::m_res_type

Uri* RegEncoderDecoder::PC2MobileMsg::msg::m_uri

UriAndPayload RegEncoderDecoder::PC2MobileMsg::msg::m_uri_payload

The documentation for this union was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::RegIteratorNodeType Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::RegIteratorNodeType

RegEncoderDecoder::RegIteratorNodeType Struct Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Collaboration diagram for RegEncoderDecoder::RegIteratorNodeType:

[legend]

Data Fields

RegIterator::NodeType m_node_type
Uri * m_uri

Field Documentation

RegIterator::NodeType RegEncoderDecoder::RegIteratorNodeType::m_node_type

Uri* RegEncoderDecoder::RegIteratorNodeType::m_uri

The documentation for this struct was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::Response Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::Response

RegEncoderDecoder::Response Struct Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Collaboration diagram for RegEncoderDecoder::Response:

[legend]

Data Fields

UINT8 m_additional_info
Payload m_payload
ResponseType m_res_type

Field Documentation

UINT8 RegEncoderDecoder::Response::m_additional_info

Payload RegEncoderDecoder::Response::m_payload

ResponseType RegEncoderDecoder::Response::m_res_type

The documentation for this struct was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::SetUpMsg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::SetUpMsg

RegEncoderDecoder::SetUpMsg Struct Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Data Fields

UINT8 | m_endianess
INT16 | m_max_blob_size
INT16 | m_max_message_size
UINT8 | m_processor_type
UINT8 | m_protocol_version

Field Documentation

UINT8 RegEncoderDecoder::SetUpMsg::m_endianess

INT16 RegEncoderDecoder::SetUpMsg::m_max_blob_size

INT16 RegEncoderDecoder::SetUpMsg::m_max_message_size

UINT8 RegEncoderDecoder::SetUpMsg::m_processor_type

UINT8 RegEncoderDecoder::SetUpMsg::m_protocol_version

The documentation for this struct was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegEncoderDecoder::UriAndPayload Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegEncoderDecoder::UriAndPayload

RegEncoderDecoder::UriAndPayload Struct Reference

#include <Applications/RegEditorClient/RegEncoderDecoder.hpp>

Collaboration diagram for RegEncoderDecoder::UriAndPayload:

[legend]

Data Fields

Payload m_payload
Uri * m_uri

Field Documentation

Payload RegEncoderDecoder::UriAndPayload::m_payload

Uri* RegEncoderDecoder::UriAndPayload::m_uri

The documentation for this struct was generated from the following file:
  • Applications/RegEditorClient/RegEncoderDecoder.hpp
Generated on Wed Jan 25 01:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegFileHeader Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegFileHeader Struct Reference
[Afs]

RegFileHeader. More...

#include <Apoxi/Afs/RegDefines.hpp>

Data Fields

UINT8 | m_file_type
UINT16 | m_node_count
UINT8 | m_version

Detailed Description

RegFileHeader.

Field Documentation

UINT8 RegFileHeader::m_file_type

UINT16 RegFileHeader::m_node_count

UINT8 RegFileHeader::m_version

The documentation for this struct was generated from the following file:
  • Afs/RegDefines.hpp
Generated on Wed Jan 25 01:44:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegistrationAllowedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegistrationAllowedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RegistrationAllowedMsg:

[legend]
Collaboration diagram for RegistrationAllowedMsg:

[legend]

Public Types

enum | { ID = 18203 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsAllowed () const
RegistrationAllowedMsg (ExecutionContext *context, BOOLEAN allowed)
void | SetAllowed (BOOLEAN allowed)
virtual | ~RegistrationAllowedMsg ()

Detailed Description

RegistrationAllowedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RegistrationAllowedMsg::RegistrationAllowedMsg | ( | ExecutionContext * | context,
 |  | BOOLEAN | allowed
 | ) |

RegistrationAllowedMsg::~RegistrationAllowedMsg ( ) [virtual]

Member Function Documentation

Message * RegistrationAllowedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RegistrationAllowedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BOOLEAN RegistrationAllowedMsg::IsAllowed ( ) const [inline]

void RegistrationAllowedMsg::SetAllowed ( BOOLEAN allowed ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:45:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegistrationChangeMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegistrationChangeMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RegistrationChangeMsg:

[legend]
Collaboration diagram for RegistrationChangeMsg:

[legend]

Public Types

enum | { ID = 18201 }

Public Member Functions

virtual Message * | Clone () const
const GsmErrorCause & | GetGsmErrorCause () const
virtual const MsgMetaData & | GetMetaData () const
const Plmn & | GetPlmn () const
const RegisterRejectCause & | GetRejectCause () const
const RegisterStatus & | GetStatus () const
BOOLEAN | IsScanActive () const
RegistrationChangeMsg (ExecutionContext *context, const RegisterStatus &status, const RegisterRejectCause &reject_cause, BOOLEAN scan_active, const Plmn &plmn, const GsmErrorCause &gsm_error_cause)
void | SetGsmErrorCause (const GsmErrorCause &gsm_error_cause)
void | SetPlmn (const Plmn &plmn)
void | SetRejectCause (const RegisterRejectCause &reject_cause)
void | SetScanActive (BOOLEAN scan_active)
void | SetStatus (const RegisterStatus &status)
virtual | ~RegistrationChangeMsg ()

Detailed Description

RegistrationChangeMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RegistrationChangeMsg::RegistrationChangeMsg | ( | ExecutionContext * | context,
 |  | const RegisterStatus & | status,
 |  | const RegisterRejectCause & | reject_cause,
 |  | BOOLEAN | scan_active,
 |  | const Plmn & | plmn,
 |  | const GsmErrorCause & | gsm_error_cause
 | ) |

RegistrationChangeMsg::~RegistrationChangeMsg ( ) [virtual]

Member Function Documentation

Message * RegistrationChangeMsg::Clone ( ) const [virtual]

Implements Message.

const GsmErrorCause& RegistrationChangeMsg::GetGsmErrorCause ( ) const [inline]

const MsgMetaData & RegistrationChangeMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const Plmn& RegistrationChangeMsg::GetPlmn ( ) const [inline]

const RegisterRejectCause& RegistrationChangeMsg::GetRejectCause ( ) const [inline]

const RegisterStatus& RegistrationChangeMsg::GetStatus ( ) const [inline]

BOOLEAN RegistrationChangeMsg::IsScanActive ( ) const [inline]

void RegistrationChangeMsg::SetGsmErrorCause ( const GsmErrorCause & gsm_error_cause ) [inline]

void RegistrationChangeMsg::SetPlmn ( const Plmn & plmn ) [inline]

void RegistrationChangeMsg::SetRejectCause ( const RegisterRejectCause & reject_cause ) [inline]

void RegistrationChangeMsg::SetScanActive ( BOOLEAN scan_active ) [inline]

void RegistrationChangeMsg::SetStatus ( const RegisterStatus & status ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:45:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegistrationSuccessMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegistrationSuccessMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RegistrationSuccessMsg:

[legend]
Collaboration diagram for RegistrationSuccessMsg:

[legend]

Public Types

enum | { ID = 18200 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Plmn & | GetPlmn () const
RegistrationSuccessMsg (ExecutionContext *context, const Plmn &plmn)
void | SetPlmn (const Plmn &plmn)
virtual | ~RegistrationSuccessMsg ()

Detailed Description

RegistrationSuccessMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RegistrationSuccessMsg::RegistrationSuccessMsg | ( | ExecutionContext * | context,
 |  | const Plmn & | plmn
 | ) |

RegistrationSuccessMsg::~RegistrationSuccessMsg ( ) [virtual]

Member Function Documentation

Message * RegistrationSuccessMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RegistrationSuccessMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const Plmn& RegistrationSuccessMsg::GetPlmn ( ) const [inline]

void RegistrationSuccessMsg::SetPlmn ( const Plmn & plmn ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:45:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Registry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Registry Class Reference
[Afs]

#include <Apoxi/Afs/Registry.hpp>

Collaboration diagram for Registry:

[legend]

Static Public Member Functions

static RegResult | Add (const CHAR *uri, const RegObjectData &reg_data_object)
static RegResult | Add (const CHAR *uri, const RegObjectData &reg_data_object, const Ticks &timeout)
static RegResult | CommitTransaction (INT16 transaction_id)
static RegResult | CommitTransaction (INT16 transaction_id, const Ticks &timeout)
static RegResult | CreateInteriorNode (const Uri &uri)
static RegResult | CreateInteriorNode (const Uri &uri, const Ticks &timeout)
static RegResult | Delete (const CHAR *uri)
static RegResult | Delete (const CHAR *uri, const Ticks &timeout)
static RegResult | Delete (const Uri &uri)
static RegResult | Delete (const Uri &uri, const Ticks &timeout)
static RegResult | EnableTransaction (const Uri &uri, INT16 &transaction_id)
static RegResult | EnableTransaction (const Uri &uri, INT16 &transaction_id, const Ticks &timeout)
static RegResult | Get (const CHAR *uri, RegObjectData &reg_data_object, INT16 bufsize)
static RegResult | Get (const CHAR *uri, RegObjectData &reg_data_object, INT16 bufsize, const Ticks &timeout)
static RegResult | Get (const Uri &reg_uri, DataItem &item)
static RegResult | Get (const Uri &reg_uri, DataItem &item, const Ticks &timeout)
static RegResult | GetVersion (INT16 &version)
static RegResult | GetVersion (INT16 &version, const Ticks &timeout)
static RegResult | Lock (const CHAR *uri, INT16 &lockid)
static RegResult | Lock (const CHAR *uri, INT16 &lockid, const Ticks &timeout)
static RegResult | Lock (const Uri &uri, INT16 &lockid)
static RegResult | Lock (const Uri &uri, INT16 &lockid, const Ticks &timeout)
static void | Notify (const CHAR *uri, const RegChangeType *c_type, const INT16 count)
static void | Notify (const CHAR *uri, const RegChangeType *c_type, const INT16 count, const Ticks &timeout)
static RegResult | RegisterNotify (const CHAR *uri)
static RegResult | RegisterNotify (const CHAR *uri, const Ticks &timeout)
static RegResult | RegisterNotify (const CHAR *uri, void(*fp_cbfunction)(const CHAR *changed_uri))
static RegResult | RegisterNotify (const CHAR *uri, void(*fp_cbfunction)(const CHAR *changed_uri), const Ticks &timeout)
static RegResult | RegisterNotify (const Uri &uri)
static RegResult | RegisterNotify (const Uri &uri, const Ticks &timeout)
static RegResult | RegisterRemoteObjectTree (const CHAR *object_tree_root_uri, const Guid &service_id)
static RegResult | RegisterRemoteObjectTree (const CHAR *object_tree_root_uri, const Guid &service_id, const Ticks &timeout)
static RegResult | Replace (const CHAR *uri, const RegObjectData &reg_data_object)
static RegResult | Replace (const CHAR *uri, const RegObjectData &reg_data_object, const Ticks &timeout)
static RegResult | Set (const Uri &node_uri, const DataItem &item)
static RegResult | Set (const Uri &node_uri, const DataItem &item, const Ticks &timeout)
static RegResult | Unlock (INT16 lockid)
static RegResult | Unlock (INT16 lockid, const Ticks &timeout)
static RegResult | UnregisterNotify (const CHAR *uri)
static RegResult | UnregisterNotify (const CHAR *uri, const Ticks &timeout)
static RegResult | UnregisterNotify (const CHAR *uri, void(*fp_cbfunction)(const CHAR *changed_uri))
static RegResult | UnregisterNotify (const CHAR *uri, void(*fp_cbfunction)(const CHAR *changed_uri), const Ticks &timeout)
static RegResult | UnregisterNotify (const Uri &uri)
static RegResult | UnregisterNotify (const Uri &uri, const Ticks &timeout)

Friends

class | NotificationArray
class | RegIterator
class | RegManager

Detailed Description

Registry Interface to external object tree and for local data store

Member Function Documentation

RegResult Registry::Add | ( | const CHAR * | uri,
 |  | const RegObjectData & | reg_data_object
 | ) | [static]

adds the new object node with the specified reg_data_object and uri

RegResult Registry::Add | ( | const CHAR * | uri,
 |  | const RegObjectData & | reg_data_object,
 |  | const Ticks & | timeout
 | ) | [static]

adds the new object node with the specified reg_data_object and uri Returns error if the request is not scheduled in the specified timeout

RegResult Registry::CommitTransaction ( INT16 transaction_id ) [static]

commits the transaction corresponding to the specified transaction_id Only possible if transaction_id exists .)

RegResult Registry::CommitTransaction | ( | INT16 | transaction_id,
 |  | const Ticks & | timeout
 | ) | [static]

commits the transaction corresponding to the specified transaction_id Only possible if transaction_id exists .)

RegResult Registry::CreateInteriorNode ( const Uri & uri ) [static]

creates an interior node and attaches it to parent node derived from uri

RegResult Registry::CreateInteriorNode | ( | const Uri & | uri,
 |  | const Ticks & | timeout
 | ) | [static]

creates an interior node and attaches it to parent node derived from uri

RegResult Registry::Delete ( const CHAR * uri ) [static]

deletes object node corresponding to the specified uri and all its children. Only possible if the node corresponding to the specified uri exists .

RegResult Registry::Delete | ( | const CHAR * | uri,
 |  | const Ticks & | timeout
 | ) | [static]

deletes object node corresponding to the specified uri and all its children. Only possible if the node corresponding to the specified uri exists . Returns error if the request is not scheduled in the specified timeout

RegResult Registry::Delete ( const Uri & uri ) [static]

deletes object node corresponding to the specified uri and all its children. Only possible if the node corresponding to the specified uri exists .

RegResult Registry::Delete | ( | const Uri & | uri,
 |  | const Ticks & | timeout
 | ) | [static]

deletes object node corresponding to the specified uri and all its children. Only possible if the node corresponding to the specified uri exists .

RegResult Registry::EnableTransaction | ( | const Uri & | uri,
 |  | INT16 & | transaction_id
 | ) | [static]

enables transaction on the object node corresponding to the specified uri and all its children and fill in the lockid in lockid Only possible if the node corresponding to the specified uri exists .

RegResult Registry::EnableTransaction | ( | const Uri & | uri,
 |  | INT16 & | transaction_id,
 |  | const Ticks & | timeout
 | ) | [static]

enables transaction on the object node corresponding to the specified uri and all its children and fill in the lockid in lockid Only possible if the node corresponding to the specified uri exists .

RegResult Registry::Get | ( | const CHAR * | uri,
 |  | RegObjectData & | reg_data_object,
 |  | INT16 | bufsize
 | ) | [static]

retrieves the object node corresponding to the specified uri and fill in the specified reg_data_object. Only possible if the node object exists and the bufsize is sufficient.

RegResult Registry::Get | ( | const CHAR * | uri,
 |  | RegObjectData & | reg_data_object,
 |  | INT16 | bufsize,
 |  | const Ticks & | timeout
 | ) | [static]

retrieves the object node corresponding to the specified uri and fill in the specified reg_data_object. Only possible if the node object exists and the bufsize is sufficient. Returns error if the request is not scheduled in the specified timeout

RegResult Registry::Get | ( | const Uri & | reg_uri,
 |  | DataItem & | item
 | ) | [static]

retrieves the node corresponding to the specified uri and fill in the specified item. Only possible if the node exists and is a leaf node.

RegResult Registry::Get | ( | const Uri & | reg_uri,
 |  | DataItem & | item,
 |  | const Ticks & | timeout
 | ) | [static]

retrieves the node corresponding to the specified uri and fill in the specified item. Only possible if the node exists and is a leaf node.

RegResult Registry::GetVersion ( INT16 & version ) [static]

fills the Registry version in version

RegResult Registry::GetVersion | ( | INT16 & | version,
 |  | const Ticks & | timeout
 | ) | [static]

fills the Registry Version in version.This returns error if the request is not scheduled in the specified timeout

RegResult Registry::Lock | ( | const CHAR * | uri,
 |  | INT16 & | lockid
 | ) | [static]

locks the object node corresponding to the specified uri and all its children and fill in the lockid in lockid Only possible if the node corresponding to the specified uri exists .

RegResult Registry::Lock | ( | const CHAR * | uri,
 |  | INT16 & | lockid,
 |  | const Ticks & | timeout
 | ) | [static]

locks the object node corresponding to the specified uri and all its children and fill in the lockid in lockid Only possible if the node corresponding to the specified uri exists . Returns error if the request is not scheduled in the specified timeout

RegResult Registry::Lock | ( | const Uri & | uri,
 |  | INT16 & | lockid
 | ) | [static]

locks the object node corresponding to the specified uri and all its children and fill in the lockid in lockid Only possible if the node corresponding to the specified uri exists .

RegResult Registry::Lock | ( | const Uri & | uri,
 |  | INT16 & | lockid,
 |  | const Ticks & | timeout
 | ) | [static]

locks the object node corresponding to the specified uri and all its children and fill in the lockid in lockid Only possible if the node corresponding to the specified uri exists .

void Registry::Notify | ( | const CHAR * | uri,
 |  | const RegChangeType * | c_type,
 |  | const INT16 | count
 | ) | [static]

notifies the registered application, on any modification to the registered uri

void Registry::Notify | ( | const CHAR * | uri,
 |  | const RegChangeType * | c_type,
 |  | const INT16 | count,
 |  | const Ticks & | timeout
 | ) | [static]

notifies the registered application, on any modification to the registered uri Returns error if the request is not scheduled in the specified timeout

RegResult Registry::RegisterNotify ( const CHAR * uri ) [static]

This function will use Apoxi message to notify.

RegResult Registry::RegisterNotify | ( | const CHAR * | uri,
 |  | const Ticks & | timeout
 | ) | [static]

This function will use Apoxi message to notify. Returns error if the request is not scheduled in the specified timeout

RegResult Registry::RegisterNotify | ( | const CHAR * | uri,
 |  | void(*)(const CHAR *changed_uri) | fp_cbfunction
 | ) | [static]

This function uses the callback to trigger notifications

RegResult Registry::RegisterNotify | ( | const CHAR * | uri,
 |  | void(*)(const CHAR *changed_uri) | fp_cbfunction,
 |  | const Ticks & | timeout
 | ) | [static]

This function uses the callback to trigger notifications Returns error if the request is not scheduled in the specified timeout

RegResult Registry::RegisterNotify ( const Uri & uri ) [static]

This function will use Apoxi message to notify.

RegResult Registry::RegisterNotify | ( | const Uri & | uri,
 |  | const Ticks & | timeout
 | ) | [static]

This function will use Apoxi message to notify.

RegResult Registry::RegisterRemoteObjectTree | ( | const CHAR * | object_tree_root_uri,
 |  | const Guid & | service_id
 | ) | [static]

registers the remote ASOT with the specified object_tree_root_uri and service_id

RegResult Registry::RegisterRemoteObjectTree | ( | const CHAR * | object_tree_root_uri,
 |  | const Guid & | service_id,
 |  | const Ticks & | timeout
 | ) | [static]

registers the remote ASOT with the specified object_tree_root_uri and service_id Returns error if the request is not scheduled in the specified timeout

RegResult Registry::Replace | ( | const CHAR * | uri,
 |  | const RegObjectData & | reg_data_object
 | ) | [static]

replaces the object node corresponding to the specified uri with the specified reg_data_object. Only possible if the node object exists .

RegResult Registry::Replace | ( | const CHAR * | uri,
 |  | const RegObjectData & | reg_data_object,
 |  | const Ticks & | timeout
 | ) | [static]

replaces the object node corresponding to the specified uri with the specified reg_data_object. Only possible if the node object exists . Returns error if the request is not scheduled in the specified timeout

RegResult Registry::Set | ( | const Uri & | node_uri,
 |  | const DataItem & | item
 | ) | [static]

replaces the node corresponding to the specified uri if exists,else adds the new leaf node item to the node corresponding to parent_uri Only possible if parent_uri exists .

RegResult Registry::Set | ( | const Uri & | node_uri,
 |  | const DataItem & | item,
 |  | const Ticks & | timeout
 | ) | [static]

replaces the node corresponding to the specified uri if exists,else adds the new leaf node item to the node corresponding to parent_uri Only possible if parent_uri exists .

RegResult Registry::Unlock ( INT16 lockid ) [static]

unlocks the object node and its children corresponding to the specified lockid Only possible if lockid exists .)

RegResult Registry::Unlock | ( | INT16 | lockid,
 |  | const Ticks & | timeout
 | ) | [static]

unlocks the object node and its children corresponding to the specified lockid Only possible if lockid exists .)

RegResult Registry::UnregisterNotify ( const CHAR * uri ) [static]

------------------------------------------------------------------------

UnregisterNotify Overloaded using Post ------------------------------------------------------------------------

RegResult Registry::UnregisterNotify | ( | const CHAR * | uri,
 |  | const Ticks & | timeout
 | ) | [static]

------------------------------------------------------------------------

UnregisterNotify using Post

------------------------------------------------------------------------

RegResult Registry::UnregisterNotify | ( | const CHAR * | uri,
 |  | void(*)(const CHAR *changed_uri) | fp_cbfunction
 | ) | [static]

------------------------------------------------------------------------

UnregisterNotify Overloaded

------------------------------------------------------------------------

RegResult Registry::UnregisterNotify | ( | const CHAR * | uri,
 |  | void(*)(const CHAR *changed_uri) | fp_cbfunction,
 |  | const Ticks & | timeout
 | ) | [static]

------------------------------------------------------------------------

UnregisterNotify

------------------------------------------------------------------------

RegResult Registry::UnregisterNotify ( const Uri & uri ) [static]

------------------------------------------------------------------------

UnregisterNotify

------------------------------------------------------------------------

RegResult Registry::UnregisterNotify | ( | const Uri & | uri,
 |  | const Ticks & | timeout
 | ) | [static]

------------------------------------------------------------------------

UnregisterNotify

------------------------------------------------------------------------

Friends And Related Function Documentation

friend class NotificationArray [friend]

friend class RegIterator [friend]

friend class RegManager [friend]

The documentation for this class was generated from the following files:
  • Afs/Registry.hpp
  • Afs/Registry.cpp
Generated on Wed Jan 25 01:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegistryInterface Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegistryInterface Class Reference

#include <Applications/RegEditorClient/RegInterface.hpp>

Collaboration diagram for RegistryInterface:

[legend]

Public Member Functions

RegistryInterface ()
constructor
~RegistryInterface ()
destructor

Static Public Member Functions

static UINT8 | RegInterface (RegEncoderDecoder::PC2MobileMsg &, RegEncoderDecoder::Mobile2PCMsg &)

Static Public Attributes

static RegIterator | m_regiterator
for iterator functions

Constructor & Destructor Documentation

RegistryInterface::RegistryInterface ( )

constructor

RegistryInterface::~RegistryInterface ( )

destructor

Member Function Documentation

UINT8 RegistryInterface::RegInterface | ( | RegEncoderDecoder::PC2MobileMsg & | ,
 |  | RegEncoderDecoder::Mobile2PCMsg & |
 | ) | [static]

Field Documentation

RegIterator RegistryInterface::m_regiterator [static]

for iterator functions

The documentation for this class was generated from the following files:
  • Applications/RegEditorClient/RegInterface.hpp
  • Applications/RegEditorClient/RegInterface.cpp
Generated on Wed Jan 25 01:45:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegIterator Class Reference
[Afs]

#include <Apoxi/Afs/RegIterator.hpp>

Collaboration diagram for RegIterator:

[legend]

Public Types

enum LeafnodeType {
BooleanNodeType, StringNodeType, BlobNodeType, IntegerNodeType,
BlobFileType
}
LeafnodeType that is used to get leaf metadata. More...
enum | NodeType { InteriorType, LeafType }

Public Member Functions

RegResult | Get (Uri &it_uri)
returns the node uri where the iterator is pointing to
RegResult | GetInteriorMetaData (InteriorMetaData &metadata)
fill in the metadata with the interior node metadata, valid only for interior node.
RegResult | GetLeafMetaData (LeafMetaData &metadata)
fill in the metadata with the leafnode metadata, valid only for leaf node.
RegIterator ()
default constructor
RegResult | Set (const Uri &it_uri)
sets the iterator to the specified uri
RegResult | TraverseDown (NodeType &nodetype)
moves the iterator to point to its first child
RegResult | TraverseNext (NodeType &nodetype)
moves the itaretor to point to next node
RegResult | TraverseUp (NodeType &nodetype)
moves the iterator to point to its parent
~RegIterator ()
default destructor

Data Structures

struct | InteriorMetaData
holds interior metadata More...
struct | LeafMetaData
holds leaf metadata More...

Detailed Description

Iterator interface to Applications and Registry core

Member Enumeration Documentation

enum RegIterator::LeafnodeType

LeafnodeType that is used to get leaf metadata.

Enumerator:
BooleanNodeType
StringNodeType
BlobNodeType
IntegerNodeType
BlobFileType

enum RegIterator::NodeType

Enumerator:
InteriorType
LeafType

Constructor & Destructor Documentation

RegIterator::RegIterator ( ) [inline]

default constructor

RegIterator::~RegIterator ( ) [inline]

default destructor

Member Function Documentation

RegResult RegIterator::Get ( Uri & it_uri )

returns the node uri where the iterator is pointing to

RegResult RegIterator::GetInteriorMetaData ( InteriorMetaData & metadata )

fill in the metadata with the interior node metadata, valid only for interior node.

RegResult RegIterator::GetLeafMetaData ( LeafMetaData & metadata )

fill in the metadata with the leafnode metadata, valid only for leaf node.

RegResult RegIterator::Set ( const Uri & it_uri )

sets the iterator to the specified uri

RegResult RegIterator::TraverseDown ( NodeType & nodetype )

moves the iterator to point to its first child

RegResult RegIterator::TraverseNext ( NodeType & nodetype )

moves the itaretor to point to next node

RegResult RegIterator::TraverseUp ( NodeType & nodetype )

moves the iterator to point to its parent

The documentation for this class was generated from the following files:
  • Afs/RegIterator.hpp
  • Afs/RegIterator.cpp
Generated on Wed Jan 25 01:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegIterator::InteriorMetaData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegIterator::InteriorMetaData

RegIterator::InteriorMetaData Struct Reference

holds interior metadata More...

#include <Apoxi/Afs/RegIterator.hpp>

Data Fields

UINT16 childcount

Detailed Description

holds interior metadata

Field Documentation

UINT16 RegIterator::InteriorMetaData::childcount

The documentation for this struct was generated from the following file:
  • Afs/RegIterator.hpp
Generated on Wed Jan 25 01:45:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegIterator::LeafMetaData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RegIterator::LeafMetaData

RegIterator::LeafMetaData Struct Reference

holds leaf metadata More...

#include <Apoxi/Afs/RegIterator.hpp>

Data Fields

UINT32 size
LeafnodeType type

Detailed Description

holds leaf metadata

Field Documentation

UINT32 RegIterator::LeafMetaData::size

LeafnodeType RegIterator::LeafMetaData::type

The documentation for this struct was generated from the following file:
  • Afs/RegIterator.hpp
Generated on Wed Jan 25 01:45:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegManager Class Reference
[Afs]

#include <Apoxi/Afs/RegManager.hpp>

Inheritance diagram for RegManager:

[legend]
Collaboration diagram for RegManager:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual UINT8 | GetPriority () const
priority controls the init sequence of SubSystems
virtual BootSequenceState | InvokeAt () const
define the point of time when the RegManager should be invoked
virtual void | OnPowerDown ()
shuts down the RegManager sub-system
virtual void | OnPowerUp ()
starts up the RegManager sub-system
RegManager ()

Static Public Member Functions

static RegManager * | GetInstance ()

Constructor & Destructor Documentation

RegManager::RegManager ( )

Member Function Documentation

static RegManager* RegManager::GetInstance ( ) [inline, static]

virtual const WCHAR* RegManager::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

virtual UINT8 RegManager::GetPriority ( ) const [inline, virtual]

priority controls the init sequence of SubSystems

Reimplemented from SubSystem.

virtual BootSequenceState RegManager::InvokeAt ( ) const [inline, virtual]

define the point of time when the RegManager should be invoked

Implements SubSystem.

void RegManager::OnPowerDown ( ) [virtual]

shuts down the RegManager sub-system

Reimplemented from SubSystem.

void RegManager::OnPowerUp ( ) [virtual]

starts up the RegManager sub-system

Reimplemented from SubSystem.

The documentation for this class was generated from the following files:
  • Afs/RegManager.hpp
  • Afs/RegManager.cpp
Generated on Wed Jan 25 01:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegMemoryBuffer Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegMemoryBuffer Struct Reference
[Afs]

#include <Apoxi/Afs/RegMemoryPool.hpp>

Collaboration diagram for RegMemoryBuffer:

[legend]

Data Fields

UINT16 m_lru_count
RegNodeBuffer m_node_buffer

Detailed Description

structure of reg memory buffer

Field Documentation

UINT16 RegMemoryBuffer::m_lru_count

RegNodeBuffer RegMemoryBuffer::m_node_buffer

The documentation for this struct was generated from the following file:
  • Afs/RegMemoryPool.hpp
Generated on Wed Jan 25 01:45:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegMemoryPool Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegMemoryPool Class Reference
[Afs]

#include <Apoxi/Afs/RegMemoryPool.hpp>

Collaboration diagram for RegMemoryPool:

[legend]

Static Public Member Functions

static void | FlushBuffers (INT16 transaction_id)
static void | FreeNodeBuffer (INT16 file_id)
static RegDeletionBufferEntry * | GetDeletionBuffer ()
static RegNodeBuffer * | GetNodeBuffer (INT16 file_id)
static BOOLEAN | Init ()

Detailed Description

structure of reg memory pool

Member Function Documentation

void RegMemoryPool::FlushBuffers ( INT16 transaction_id ) [static]

void RegMemoryPool::FreeNodeBuffer ( INT16 file_id ) [static]

RegDeletionBufferEntry * RegMemoryPool::GetDeletionBuffer ( ) [static]

RegNodeBuffer * RegMemoryPool::GetNodeBuffer ( INT16 file_id ) [static]

BOOLEAN RegMemoryPool::Init ( ) [static]

The documentation for this class was generated from the following files:
  • Afs/RegMemoryPool.hpp
  • Afs/RegMemoryPool.cpp
Generated on Wed Jan 25 01:45:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegNodeBuffer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegNodeBuffer Class Reference
[Afs]

structure of reg node buffer More...

#include <Apoxi/Afs/RegNodeFile.hpp>

Public Member Functions

BOOLEAN | AddBlobFileNode (INT16 val, const String &node_name)
BOOLEAN | AddBlobNode (RegBlobObject *val, const String &node_name)
BOOLEAN | AddBooleanNode (BOOLEAN val, const String &node_name)
BOOLEAN | AddIntegerNode (INT val, const String &node_name)
BOOLEAN | AddInteriorHeader (const Uri &node_uri)
adds the interiornode header
BOOLEAN | AddInteriorNode (INT16 val, const String &node_name)
BOOLEAN | AddStringNode (String *val, const String &node_name)
BOOLEAN | DeleteNode (UINT idx)
BOOLEAN | GetBlobFileNodePayload (INT16 *val, UINT idx)
BOOLEAN | GetBlobPayload (RegBlobObject *val, UINT idx)
BOOLEAN | GetBooleanPayload (BOOLEAN *val, UINT idx)
INT16 | GetFileId ()
returns the corresponding FFS fileid
BOOLEAN | GetIntegerPayload (INT *val, UINT idx)
BOOLEAN | GetInteriorPayload (INT16 *val, UINT idx)
UINT8 * | GetNodeBufferRawMemory ()
BOOLEAN | GetNodeIndex (String &node_name, UINT &idx)
gets the noderecord index corresponding to the nodename
BOOLEAN | GetNodeRecord (UINT idx, RegNodeRecord *rec)
retrieves the noderecord
RegNodeRecord * | GetNodeRecordPtr (UINT idx)
gets the pointer to node record
UINT | GetNumOfNodeRecord ()
returns the number of noderecords
BOOLEAN | GetStringPayload (String *val, UINT idx)
void | GetUri (Uri &uri)
gets the Uri of nodefile header
void | Init (UINT8 *raw_memory)
BOOLEAN | Read (UINT16 fileid)
copies the file contents to NodeBuffer
RegNodeBuffer ()
default constructor
void | ResetFileId ()
resets the fileid to invalid file id
BOOLEAN | SetBlobFileNode (INT16 val, UINT idx)
BOOLEAN | SetBlobNode (RegBlobObject *val, UINT idx)
BOOLEAN | SetBooleanNode (BOOLEAN val, UINT idx)
BOOLEAN | SetIntegerNode (INT val, UINT idx)
BOOLEAN | SetInteriorNode (INT16 val, UINT idx)
void | SetNumOfNodeRecord (UINT no_of_records)
sets the number of records
void | SetRootFileType ()
BOOLEAN | SetStringNode (String *val, UINT idx)
void | SetUri (Uri &uri)
sets the uri of nodefile header
BOOLEAN | Write (UINT16 fileid)
flush the buffer to file
~RegNodeBuffer ()
default destructor

Detailed Description

structure of reg node buffer

----------------------------------------------------------------- REGISTRY NODE FILE -----------------------------------------------------------------

Constructor & Destructor Documentation

RegNodeBuffer::RegNodeBuffer ( ) [inline]

default constructor

RegNodeBuffer::~RegNodeBuffer ( ) [inline]

default destructor

Member Function Documentation

BOOLEAN RegNodeBuffer::AddBlobFileNode | ( | INT16 | val,
 |  | const String & | uri
 | ) |

------------------------------------------------------------------------ AddBlobFileNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::AddBlobNode | ( | RegBlobObject * | val,
 |  | const String & | uri
 | ) |

------------------------------------------------------------------------ AddBlobNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::AddBooleanNode | ( | BOOLEAN | val,
 |  | const String & | uri
 | ) |

------------------------------------------------------------------------ AddBooleanNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::AddIntegerNode | ( | INT | val,
 |  | const String & | uri
 | ) |

------------------------------------------------------------------------ AddIntegerNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::AddInteriorHeader ( const Uri & node_uri )

adds the interiornode header

------------------------------------------------------------------------ AddInteriorHeader ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::AddInteriorNode | ( | INT16 | val,
 |  | const String & | uri
 | ) |

------------------------------------------------------------------------ AddInteriorNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::AddStringNode | ( | String * | val,
 |  | const String & | uri
 | ) |

------------------------------------------------------------------------ AddStringNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::DeleteNode ( UINT idx )

------------------------------------------------------------------------ DeleteNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::GetBlobFileNodePayload | ( | INT16 * | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ GetBlobFileNodePayload ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::GetBlobPayload | ( | RegBlobObject * | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ GetBlobPayload ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::GetBooleanPayload | ( | BOOLEAN * | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ GetBooleanPayload ------------------------------------------------------------------------

INT16 RegNodeBuffer::GetFileId ( )

returns the corresponding FFS fileid

------------------------------------------------------------------------ GetFileId ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::GetIntegerPayload | ( | INT * | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ GetIntegerPayload ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::GetInteriorPayload | ( | INT16 * | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ GetInteriorPayload ------------------------------------------------------------------------

UINT8 * RegNodeBuffer::GetNodeBufferRawMemory ( )

------------------------------------------------------------------------ GetNodeBufferRawMemory ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::GetNodeIndex | ( | String & | node_name,
 |  | UINT & | idx
 | ) |

gets the noderecord index corresponding to the nodename

------------------------------------------------------------------------ GetNodeIndex ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::GetNodeRecord | ( | UINT | idx,
 |  | RegNodeRecord * | node_rec
 | ) |

retrieves the noderecord

------------------------------------------------------------------------ GetNodeRecord ------------------------------------------------------------------------

RegNodeRecord * RegNodeBuffer::GetNodeRecordPtr ( UINT idx )

gets the pointer to node record

------------------------------------------------------------------------ GetNodeRecordPtr ------------------------------------------------------------------------

UINT RegNodeBuffer::GetNumOfNodeRecord ( )

returns the number of noderecords

------------------------------------------------------------------------ GetNumOfNodeRecord ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::GetStringPayload | ( | String * | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ GetStringPayload ------------------------------------------------------------------------

void RegNodeBuffer::GetUri ( Uri & uri )

gets the Uri of nodefile header

------------------------------------------------------------------------ GetUri ------------------------------------------------------------------------

void RegNodeBuffer::Init ( UINT8 * raw_memory )

------------------------------------------------------------------------ Init ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::Read ( UINT16 file_id )

copies the file contents to NodeBuffer

------------------------------------------------------------------------ Read ------------------------------------------------------------------------

void RegNodeBuffer::ResetFileId ( )

resets the fileid to invalid file id

------------------------------------------------------------------------ ResetFileId ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::SetBlobFileNode | ( | INT16 | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ SetBlobFileNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::SetBlobNode | ( | RegBlobObject * | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ SetBlobNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::SetBooleanNode | ( | BOOLEAN | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ SetBooleanNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::SetIntegerNode | ( | INT | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ SetIntegerNode ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::SetInteriorNode | ( | INT16 | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ SetInteriorNode ------------------------------------------------------------------------

void RegNodeBuffer::SetNumOfNodeRecord ( UINT no_of_records )

sets the number of records

------------------------------------------------------------------------ SetNumOfNodeRecord ------------------------------------------------------------------------

void RegNodeBuffer::SetRootFileType ( )

------------------------------------------------------------------------ SetRootFileType ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::SetStringNode | ( | String * | val,
 |  | UINT | idx
 | ) |

------------------------------------------------------------------------ SetStringNode ------------------------------------------------------------------------

void RegNodeBuffer::SetUri ( Uri & uri )

sets the uri of nodefile header

------------------------------------------------------------------------ SetUri ------------------------------------------------------------------------

BOOLEAN RegNodeBuffer::Write ( UINT16 file_id )

flush the buffer to file

------------------------------------------------------------------------ Write ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/RegNodeFile.hpp
  • Afs/RegNodeFile.cpp
Generated on Wed Jan 25 01:45:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegNodeFileHeader Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegNodeFileHeader Struct Reference
[Afs]

nodefile header structure More...

#include <Apoxi/Afs/RegNodeFile.hpp>

Collaboration diagram for RegNodeFileHeader:

[legend]

Data Fields

RegFileHeader m_file_header
CHAR m_uri [c_reg_uri_size_max]

Detailed Description

nodefile header structure

Field Documentation

RegFileHeader RegNodeFileHeader::m_file_header

CHAR RegNodeFileHeader::m_uri[c_reg_uri_size_max]

The documentation for this struct was generated from the following file:
  • Afs/RegNodeFile.hpp
Generated on Wed Jan 25 01:45:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegNodeRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegNodeRecord Struct Reference
[Afs]

nodefile record structure More...

#include <Apoxi/Afs/RegNodeFile.hpp>

Data Fields

CHAR m_name [c_reg_node_name_size_max]
struct {
UINT16 m_offset_node_payload
UINT16 m_payload_type
} m_payload_bits

Detailed Description

nodefile record structure

Field Documentation

CHAR RegNodeRecord::m_name[c_reg_node_name_size_max]

UINT16 RegNodeRecord::m_offset_node_payload

struct { ... } RegNodeRecord::m_payload_bits

UINT16 RegNodeRecord::m_payload_type

The documentation for this struct was generated from the following file:
  • Afs/RegNodeFile.hpp
Generated on Wed Jan 25 01:45:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegNotifyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegNotifyMsg Class Reference

#include <Apoxi/Afs/AfsMsgTypes.hpp>

Inheritance diagram for RegNotifyMsg:

[legend]
Collaboration diagram for RegNotifyMsg:

[legend]

Public Types

enum | { ID = 16000 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Uri & | GetUri () const
RegNotifyMsg (ExecutionContext *context, const Uri &uri)
virtual | ~RegNotifyMsg ()

Detailed Description

Message Sent from Registry -> Base Application

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RegNotifyMsg::RegNotifyMsg | ( | ExecutionContext * | context,
 |  | const Uri & | uri
 | ) |

RegNotifyMsg::~RegNotifyMsg ( ) [virtual]

Member Function Documentation

Message * RegNotifyMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RegNotifyMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const Uri& RegNotifyMsg::GetUri ( ) const [inline]

The documentation for this class was generated from the following files:
  • Afs/AfsMsgTypes.hpp
  • Afs/AfsMsgTypes.cpp
Generated on Wed Jan 25 01:45:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegObjectData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegObjectData Struct Reference
[Afs]

The object data structure. More...

#include <Apoxi/Afs/RegistryTypes.hpp>

Data Fields

CHAR * | data
RegDataFormat dataformat
INT32 | datasize
const CHAR * | datatype

Detailed Description

The object data structure.

Field Documentation

CHAR* RegObjectData::data

RegDataFormat RegObjectData::dataformat

INT32 RegObjectData::datasize

const CHAR* RegObjectData::datatype

The documentation for this struct was generated from the following file:
  • Afs/RegistryTypes.hpp
Generated on Wed Jan 25 01:45:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegStateIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegStateIndArg Class Reference

#include <Apoxi/Apc/PlmnStackMsgArgs.hpp>

Inheritance diagram for RegStateIndArg:

[legend]
Collaboration diagram for RegStateIndArg:

[legend]

Public Types

enum | { ID = 5361 }

Public Member Functions

const GsmBand & | GetGsmBand () const
const RegisterMode & | GetMode () const
const Plmn & | GetPlmn () const
const RadioAccessTechnology & | GetRadioAccessTechnology () const
RegStateIndArg ()
void | SetGsmBand (const GsmBand &gsm_band)
void | SetMode (const RegisterMode &mode)
void | SetPlmn (const Plmn &plmn)
void | SetRadioAccessTechnology (const RadioAccessTechnology &radio_access_technology)

Static Public Member Functions

static const RegStateIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

RegStateIndArg: reflects arguments of signal MN_REG_STATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RegStateIndArg::RegStateIndArg ( )

Member Function Documentation

const RegStateIndArg & RegStateIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GsmBand& RegStateIndArg::GetGsmBand ( ) const [inline]

const RegisterMode& RegStateIndArg::GetMode ( ) const [inline]

const Plmn& RegStateIndArg::GetPlmn ( ) const [inline]

const RadioAccessTechnology& RegStateIndArg::GetRadioAccessTechnology ( ) const [inline]

void RegStateIndArg::SetGsmBand ( const GsmBand & gsm_band ) [inline]

void RegStateIndArg::SetMode ( const RegisterMode & mode ) [inline]

void RegStateIndArg::SetPlmn ( const Plmn & plmn ) [inline]

void RegStateIndArg::SetRadioAccessTechnology ( const RadioAccessTechnology & radio_access_technology ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PlmnStackMsgArgs.hpp
  • Apc/PlmnStackMsgArgs.cpp
Generated on Wed Jan 25 01:45:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegTcpSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegTcpSocket Class Reference

#include <Applications/RegEditorClient/RegAppWin.hpp>

Inheritance diagram for RegTcpSocket:

[legend]
Collaboration diagram for RegTcpSocket:

[legend]

Public Member Functions

RegTcpSocket ()
Constructor.
~RegTcpSocket ()
Destructor.

Protected Member Functions

virtual void OnAsyncEvent (Event event)

Constructor & Destructor Documentation

RegTcpSocket::RegTcpSocket ( )

Constructor.

RegTcpSocket::~RegTcpSocket ( )

Destructor.

Member Function Documentation

void RegTcpSocket::OnAsyncEvent ( Event event ) [protected, virtual]

This method is invoked when some data is received in the socket & is available for reading

Reimplemented from InetSocket.

The documentation for this class was generated from the following files:
  • Applications/RegEditorClient/RegAppWin.hpp
  • Applications/RegEditorClient/RegAppWin.cpp
Generated on Wed Jan 25 01:45:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RegUriMapFile Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RegUriMapFile Struct Reference
[Afs]

structure of urimapfile More...

#include <Apoxi/Afs/UriMappingTable.hpp>

Collaboration diagram for RegUriMapFile:

[legend]

Data Fields

InteriorNodeRecord m_interior_node_record [c_max_interior_node_records]
RegFileHeader m_map_file_header

Detailed Description

structure of urimapfile

Field Documentation

InteriorNodeRecord RegUriMapFile::m_interior_node_record[c_max_interior_node_records]

RegFileHeader RegUriMapFile::m_map_file_header

The documentation for this struct was generated from the following file:
  • Afs/UriMappingTable.hpp
Generated on Wed Jan 25 01:45:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RejectCallsIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RejectCallsIndArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for RejectCallsIndArg:

[legend]
Collaboration diagram for RejectCallsIndArg:

[legend]

Public Types

enum | { ID = 2124 }

Public Member Functions

const CallRefuseDirection & | GetCallRefuseDirection () const
BOOLEAN | IsActivated () const
RejectCallsIndArg ()
RejectCallsIndArg (BOOLEAN activated, const CallRefuseDirection &call_refuse_direction)
void | SetActivated (BOOLEAN activated)
void | SetCallRefuseDirection (const CallRefuseDirection &call_refuse_direction)

Static Public Member Functions

static const RejectCallsIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

RejectCallsIndArg: reflects arguments of signal MNMI_REJECT_CALLS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RejectCallsIndArg::RejectCallsIndArg | ( | BOOLEAN | activated,
 |  | const CallRefuseDirection & | call_refuse_direction
 | ) |

RejectCallsIndArg::RejectCallsIndArg ( )

Member Function Documentation

const RejectCallsIndArg & RejectCallsIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallRefuseDirection& RejectCallsIndArg::GetCallRefuseDirection ( ) const [inline]

BOOLEAN RejectCallsIndArg::IsActivated ( ) const [inline]

void RejectCallsIndArg::SetActivated ( BOOLEAN activated ) [inline]

void RejectCallsIndArg::SetCallRefuseDirection ( const CallRefuseDirection & call_refuse_direction ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:45:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RemotePartyActionMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RemotePartyActionMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for RemotePartyActionMsg:

[legend]
Collaboration diagram for RemotePartyActionMsg:

[legend]

Public Types

enum | { ID = 18412 }

Public Member Functions

virtual Message * | Clone () const
const RemotePartyActionArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
RemotePartyActionMsg (ExecutionContext *context, const RemotePartyActionArg &arg)
void | SetArg (const RemotePartyActionArg &arg)
virtual | ~RemotePartyActionMsg ()

Detailed Description

RemotePartyActionMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RemotePartyActionMsg::RemotePartyActionMsg | ( | ExecutionContext * | context,
 |  | const RemotePartyActionArg & | arg
 | ) |

RemotePartyActionMsg::~RemotePartyActionMsg ( ) [virtual]

Member Function Documentation

Message * RemotePartyActionMsg::Clone ( ) const [virtual]

Implements Message.

const RemotePartyActionArg& RemotePartyActionMsg::GetArg ( ) const [inline]

const MsgMetaData & RemotePartyActionMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void RemotePartyActionMsg::SetArg ( const RemotePartyActionArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:45:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RenameFileDialog Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RenameFileDialog Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

Dialog for renaming a file with the media browser. More...

#include <Applications/ImageBrowser/Common/RenameFileDialog.hpp>

Collaboration diagram for RenameFileDialog:

[legend]

Public Member Functions

WString | GetNewFilename () const
Returns the filename that has been entered in the textbox.
WString | GetNewFilename () const
Returns the filename that has been entered in the textbox.
BOOLEAN | GetSuccess () const
Returns TRUE if Ok or FALSE if Cancel was pressed.
BOOLEAN | GetSuccess () const
Returns TRUE if Ok or FALSE if Cancel was pressed.
void | Init (Control *control)
void | Init ()
void | Init (Control *control)
void | Init ()
RenameFileDialog ()
RenameFileDialog ()
void | SetCurrentPath (const Path &current_path)
void | SetCurrentPath (const Path &current_path)
virtual | ~RenameFileDialog ()
virtual | ~RenameFileDialog ()

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnLayoutClient ()
virtual void | OnOpen ()
virtual void | OnOpen ()

Detailed Description

Dialog for renaming a file with the media browser.

Constructor & Destructor Documentation

RenameFileDialog::RenameFileDialog ( )

RenameFileDialog::~RenameFileDialog ( ) [virtual]

RenameFileDialog::RenameFileDialog ( )

virtual RenameFileDialog::~RenameFileDialog ( ) [virtual]

Member Function Documentation

WString RenameFileDialog::GetNewFilename ( ) const

Returns the filename that has been entered in the textbox.

WString RenameFileDialog::GetNewFilename ( ) const

Returns the filename that has been entered in the textbox.

BOOLEAN RenameFileDialog::GetSuccess ( ) const

Returns TRUE if Ok or FALSE if Cancel was pressed.

BOOLEAN RenameFileDialog::GetSuccess ( ) const

Returns TRUE if Ok or FALSE if Cancel was pressed.

void RenameFileDialog::Init ( Control * control )

void RenameFileDialog::Init ( )

void RenameFileDialog::Init ( Control * control )

void RenameFileDialog::Init ( )

virtual BOOLEAN RenameFileDialog::OnCancel ( ) [protected, virtual]

See also:
Window::OnCancel

BOOLEAN RenameFileDialog::OnCancel ( ) [protected, virtual]

See also:
Window::OnCancel

virtual BOOLEAN RenameFileDialog::OnConfirm ( ) [protected, virtual]

See also:
Window::OnConfirm

BOOLEAN RenameFileDialog::OnConfirm ( ) [protected, virtual]

See also:
Window::OnConfirm

virtual void RenameFileDialog::OnLayoutClient ( ) [protected, virtual]

See also:
Window::OnLayoutClient

void RenameFileDialog::OnLayoutClient ( ) [protected, virtual]

See also:
Window::OnLayoutClient

virtual void RenameFileDialog::OnOpen ( ) [protected, virtual]

See also:
Window::OnOpen

void RenameFileDialog::OnOpen ( ) [protected, virtual]

See also:
Window::OnOpen

void RenameFileDialog::SetCurrentPath ( const Path & current_path )

Sets the current path of the file to be shown in the textbox when showing the dialog.

Parameters:
current_path Path to initially show.

void RenameFileDialog::SetCurrentPath ( const Path & current_path )

Sets the current path of the file to be shown in the textbox when showing the dialog.

Parameters:
current_path Path to initially show.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/RenameFileDialog.hpp
  • Applications/SoundBrowser/Common/RenameFileDialog.hpp
  • Applications/ImageBrowser/Common/RenameFileDialog.cpp
  • Applications/SoundBrowser/Common/RenameFileDialog.cpp
Generated on Wed Jan 25 01:45:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ResourceID Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ResourceID Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/ResourceID.hpp>

Collaboration diagram for ResourceID:

[legend]

Public Member Functions

BOOLEAN | IsEmpty () const
ResourceID (const CHAR *id)
ResourceID (const String &resourceID)
ResourceID ()
void | SetID (const String &id)
const String & | ToString () const
~ResourceID ()

Friends

BOOLEAN | operator!= (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator< (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator== (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator> (const ResourceID &lhs, const ResourceID &rhs)

Constructor & Destructor Documentation

ResourceID::ResourceID ( )

The documentation for this class was generated from the following files:
  • Atl/ResourceID.hpp
  • Atl/ResourceID.cpp
Generated on Wed Jan 25 01:45:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ResourceManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ResourceManager Class Reference

Obsolete (comments from methods describe the replacement). More...

#include <Apoxi/Compat/ResourceManager.hpp>

Public Member Functions

const ColorTable & | GetColorTable () const
Obsolete - Use DisplayConfig::GetColorTable instead.
const Font & | GetFont (INT id) const
Obsolete - Use FontConfig::GetFont() instead.
const InputMap & | GetInputMap (MapItemType type) const
Obsolete - Use KeyboardConfig::GetInputMap(type) instead.
const PagingMap & | GetPagingMap (INT lang_id=-1) const
Obsolete - Use LocaleConfig::GetPagingMap() instead.

Detailed Description

Obsolete (comments from methods describe the replacement).

Member Function Documentation

const ColorTable & ResourceManager::GetColorTable ( ) const

Obsolete - Use DisplayConfig::GetColorTable instead.

const Font & ResourceManager::GetFont ( INT id ) const

Obsolete - Use FontConfig::GetFont() instead.

const InputMap & ResourceManager::GetInputMap ( MapItemType type ) const

Obsolete - Use KeyboardConfig::GetInputMap(type) instead.

const PagingMap & ResourceManager::GetPagingMap ( INT lang_id = -1 ) const

Obsolete - Use LocaleConfig::GetPagingMap() instead.

The documentation for this class was generated from the following files:
  • Compat/ResourceManager.hpp
  • Compat/ResourceManager.cpp
Generated on Wed Jan 25 01:45:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ResultWinBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ResultWinBase Class Reference

#include <Applications/Lcs/ResultWinBase.hpp>

Inheritance diagram for ResultWinBase:

[legend]
Collaboration diagram for ResultWinBase:

[legend]

Public Types

enum ResWinAction {
ViewPrevious = 0, ViewNext, Pause, CloseWindow,
Invalid
}
Operations. More...

Public Member Functions

void | Init ()
ResultWinBase ()
Constructor.
virtual | ~ResultWinBase ()
Destructor.

Protected Attributes

TextBox m_data1
TextBox m_data2
TextBox m_data3
TextBox m_data4
TextBox m_label1
TextBox m_label2
TextBox m_label3
TextBox m_label4

Detailed Description

Base class for location result window. This window implements the common functionalities of all result windows

Member Enumeration Documentation

enum ResultWinBase::ResWinAction

Operations.

Enumerator:
ViewPrevious
ViewNext
Pause
CloseWindow
Invalid

Constructor & Destructor Documentation

ResultWinBase::ResultWinBase ( )

Constructor.

ResultWinBase::~ResultWinBase ( ) [virtual]

Destructor.

Member Function Documentation

void ResultWinBase::Init ( )

Reimplemented in LocationResultWin, and SatteliteInfoWin.

Field Documentation

TextBox ResultWinBase::m_data1 [protected]

TextBox ResultWinBase::m_data2 [protected]

TextBox ResultWinBase::m_data3 [protected]

TextBox ResultWinBase::m_data4 [protected]

TextBox ResultWinBase::m_label1 [protected]

TextBox ResultWinBase::m_label2 [protected]

TextBox ResultWinBase::m_label3 [protected]

TextBox ResultWinBase::m_label4 [protected]

The documentation for this class was generated from the following files:
  • Applications/Lcs/ResultWinBase.hpp
  • Applications/Lcs/ResultWinBase.cpp
Generated on Wed Jan 25 01:45:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RfcommSocketAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RfcommSocketAddr Class Reference

#include <Apoxi/AddOns/BtSocket/BtSocketAddr.hpp>

Inheritance diagram for RfcommSocketAddr:

[legend]
Collaboration diagram for RfcommSocketAddr:

[legend]

Public Member Functions

void | GetDeviceAddress (BtDeviceAddress &btDevAddr)
unsigned char | GetServerChannel ()
void * | GetSockAddr ()
INT32 | GetSockAddrSize ()
RfcommSocketAddr (BtDeviceAddress &addr, UINT8 serverchannel)
RfcommSocketAddr ()
~RfcommSocketAddr ()

Constructor & Destructor Documentation

RfcommSocketAddr::RfcommSocketAddr ( )

Default constructor.

RfcommSocketAddr::RfcommSocketAddr | ( | BtDeviceAddress & | addr,
 |  | UINT8 | serverchannel
 | ) |

Constructor.

Parameters:
addr | bt device address reference
serverchannel | Server channel.

RfcommSocketAddr::~RfcommSocketAddr ( )

Destructor.

Member Function Documentation

void RfcommSocketAddr::GetDeviceAddress ( BtDeviceAddress & btDevAddr )

Retrieves the device address.

Parameters:
btDevAddr retrieves the device address in this object

unsigned char RfcommSocketAddr::GetServerChannel ( )

Retrieves the server channale.

void * RfcommSocketAddr::GetSockAddr ( ) [virtual]

This is used only for internal purposes.

Implements SocketAddr.

INT32 RfcommSocketAddr::GetSockAddrSize ( ) [virtual]

This is used only for internal purposes.

Implements SocketAddr.

The documentation for this class was generated from the following files:
  • AddOns/BtSocket/BtSocketAddr.hpp
  • AddOns/BtSocket/BtSocketAddr.cpp
Generated on Wed Jan 25 01:45:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RfsMediaAvailableStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RfsMediaAvailableStatusMsg Class Reference

#include <Apoxi/Afs/Rfs/RfsMsgTypes.hpp>

Inheritance diagram for RfsMediaAvailableStatusMsg:

[legend]
Collaboration diagram for RfsMediaAvailableStatusMsg:

[legend]

Public Types

enum | { ID = 16051 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetStorageDeviceId () const
BOOLEAN | IsMediaPresent () const
RfsMediaAvailableStatusMsg (const WString &storage_device_id, BOOLEAN media_present)
virtual | ~RfsMediaAvailableStatusMsg ()

Detailed Description

This message is posted by storage devices which support exchangeable medias each time the availability status of a media changes.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RfsMediaAvailableStatusMsg::RfsMediaAvailableStatusMsg | ( | const WString & | storage_device_id,
 |  | BOOLEAN | media_present
 | ) |

RfsMediaAvailableStatusMsg::~RfsMediaAvailableStatusMsg ( ) [virtual]

Member Function Documentation

Message * RfsMediaAvailableStatusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RfsMediaAvailableStatusMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& RfsMediaAvailableStatusMsg::GetStorageDeviceId ( ) const [inline]

BOOLEAN RfsMediaAvailableStatusMsg::IsMediaPresent ( ) const [inline]

The documentation for this class was generated from the following files:
  • Afs/Rfs/RfsMsgTypes.hpp
  • Afs/Rfs/RfsMsgTypes.cpp
Generated on Wed Jan 25 01:45:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RfsObexFtpServer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RfsObexFtpServer Class Reference

A basic OBEX FTP server for the root file system (RFS). More...

#include <Apoxi/AddOns/RfsObexFtpServer/RfsObexFtpServer.hpp>

Inheritance diagram for RfsObexFtpServer:

[legend]
Collaboration diagram for RfsObexFtpServer:

[legend]

Public Member Functions

virtual void | Init (ExecutionContext *ctx_ptr, const Path &root_path)
Initializes a default-constructed object.
virtual void | OnBind (const ObexAddrPtr &addr_ptr, ObexResult result)
Indicates binding of a transport channel to the server.
virtual void | OnConnect (const ObexHeaderList &headers, UINT8 flags)
Indicates an incoming CONNECT request.
virtual void | OnDeleteObject (const WString &current_folder, const WString &object)
Indicates an incoming object delete request.
virtual void | OnDisconnected (ObexResult result)
Indicates that the current client has disconnected.
virtual void | OnFilePull (const WString &current_folder, const WString &filename)
Indicates an incoming file pull request.
virtual void | OnFilePullRequestCompleted (ObexResult result)
Indicates the completion of a file pull operation.
virtual void | OnFilePush (const WString &current_folder, const WString &filename, UINT32 size)
Indicates an incoming file push request.
virtual void | OnFilePushRequestCompleted (ObexResult result)
Indicates the completion of a file push operation.
virtual void | OnGetFolderListing (const WString &current_folder)
Indicates an incoming folder listing request.
virtual void | OnProvideFolderListingEntries (const WString &current_folder)
Indicates that folder entries have to be provided now.
virtual void | OnSetCurrentFolder (const WString &current_folder, const WString &new_current_folder, BOOLEAN create)
Indicates an incoming current-folder change request.
RfsObexFtpServer (ExecutionContext *ctx_ptr, const Path &root_path)
Constructor. Constructs a usable object instance.
RfsObexFtpServer ()
Default constructor.
virtual | ~RfsObexFtpServer ()
Destructor. Destroys an RfsObexFtpServer object.

Protected Member Functions

Path | GetAbsolutePath (const WString &path, const WString &object=L"")
Returns an absolute path based on the server's root path.

Protected Attributes

DirectoryIteratorPtr m_dir_itor_ptr
Path m_root_path

Detailed Description

A basic OBEX FTP server for the root file system (RFS).

This class implements the abstract OBEX FTP interface provided by the class ObexFtpServer for the root file system (RFS).

See also:
ObexFtpServer

Constructor & Destructor Documentation

RfsObexFtpServer::RfsObexFtpServer ( )

Default constructor.

Default-constructed instances must be initialized using Init() before using them the first time.

RfsObexFtpServer::RfsObexFtpServer | ( | ExecutionContext * | ctx_ptr,
 |  | const Path & | root_path
 | ) |

Constructor. Constructs a usable object instance.

Intended to be used with dynamically allocated objects (new).

Parameters:
ctx_ptr | Execution context to be used by the server. All notification methods (protected: On.....()) will be called from this context. You may pass '0' as actual parameter to specify the currently active context, which must be valid at construction the time.
root_path | Root path of the server.

RfsObexFtpServer::~RfsObexFtpServer ( ) [virtual]

Destructor. Destroys an RfsObexFtpServer object.

Member Function Documentation

Path RfsObexFtpServer::GetAbsolutePath | ( | const WString & | path,
 |  | const WString & | object = L""
 | ) | [protected]

Returns an absolute path based on the server's root path.

void RfsObexFtpServer::Init | ( | ExecutionContext * | ctx_ptr,
 |  | const Path & | root_path
 | ) | [virtual]

Initializes a default-constructed object.

Parameters:
ctx_ptr | Execution context in which the server is to be run. You may pass '0' as actual parameter to specify the current execution context. In the latter case, the current context must be valid when Init() is called.
root_path | Root path of the server.

void RfsObexFtpServer::OnBind | ( | const ObexAddrPtr & | addr_ptr,
 |  | ObexResult | result
 | ) | [virtual]

Indicates binding of a transport channel to the server.

Parameters:
addr_ptr | Smart pointer to OBEX address that was attempted to bind.
result | Either tells that the bind operation was successful or provides error information.

Reimplemented from ObexFtpServer.

void RfsObexFtpServer::OnConnect | ( | const ObexHeaderList & | headers,
 |  | UINT8 | flags
 | ) | [virtual]

Indicates an incoming CONNECT request.

When a TARGET was specified as part of the server's OBEX URL it will accept only CONNECT requests with a matching TARGET header. Therefore this does not need to be checked by application SW. When the server was opened specifying a TARGET, a CONNECTION ID is assigned and the pre-build response will contain the following headers: CONNECTION_ID=<set_by_server>}, TARGET=<client's WHO>, WHO=<server's TARGET>. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept the request AcceptConnectRequest(), to reject the request RejectConnectRequest(resp_code) must be called.

Parameters:
headers Header list which contains the headers of the CONNECT request sent by the remote client, for example TARGET and WHO.

Implements ObexFtpServer.

void RfsObexFtpServer::OnDeleteObject | ( | const WString & | current_folder,
 |  | const WString & | object
 | ) | [virtual]

Indicates an incoming object delete request.

When this method is called, the client requests to delete an object in the current directory. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptDeleteObjectRequest() must be called, to reject the request the method RejectDeleteObjectRequest() has to be invoked.

Parameters:
current_folder | The current folder (absolute, e.g. "/UserData/MyMusic/").
object | The name of the object the client requests to be deleted in the current folder. Note: This object name can refer either to a file or folder.

Implements ObexFtpServer.

void RfsObexFtpServer::OnDisconnected ( ObexResult result ) [virtual]

Indicates that the current client has disconnected.

When the method is called, the client has (or has been) disconnected and the server should release any temporary resources and reset itself to a virgin state suitable for accepting a new client connection.

Parameters:
result ObexResult which evaluates to 'TRUE' when the connection was disconnected using a proper OBEX DISCONNECT request, 'FALSE' when a spontaneous disconnection occurred. Check the error code then to obtain more detailed information.

Implements ObexFtpServer.

void RfsObexFtpServer::OnFilePull | ( | const WString & | current_folder,
 |  | const WString & | filename
 | ) | [virtual]

Indicates an incoming file pull request.

When this method is called, the client requests to pull a file from the current directory. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptFilePullRequest() must be called, to reject the request the method RejectFilePullRequest() has to be invoked.

Parameters:
current_folder | The current folder (absolute, e.g "/UserData/MyMusic/").
filename | The file name of the file the client requests to pull from the current folder.

Implements ObexFtpServer.

void RfsObexFtpServer::OnFilePullRequestCompleted ( ObexResult result ) [virtual]

Indicates the completion of a file pull operation.

When an incoming file pull request was accept before by calling AcceptFilePullRequest(...) this method will be invoked later on when the file pull operation has finished.

Parameters:
result ObexResult which evaluates to 'TRUE' when the current operation was completed successfully, 'FALSE' otherwise.

Implements ObexFtpServer.

void RfsObexFtpServer::OnFilePush | ( | const WString & | current_folder,
 |  | const WString & | filename,
 |  | UINT32 | size
 | ) | [virtual]

Indicates an incoming file push request.

When this method is called, the client requests to push a file to the current directory. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptFilePushRequest() must be called, to reject the request the method RejectFilePushRequest() has to be invoked.

Parameters:
current_folder | The current folder (absolute, e.g "/UserData/MyMusic/").
filename | The file name of the file the client requests to push to the current folder.
size | Size of the whole file to be pushed as read from the OBEX LENGTH header. If the size equals '0', it is not yet known.

Implements ObexFtpServer.

void RfsObexFtpServer::OnFilePushRequestCompleted ( ObexResult result ) [virtual]

Indicates the completion of a file push operation.

When a incoming file push request was accept before by calling AcceptFilePushRequest(...) this method will be invoked later on when the file push operation has finished.

Parameters:
result ObexResult which evaluates to 'TRUE' when the current operation was completed successfully, 'FALSE' otherwise.

Implements ObexFtpServer.

void RfsObexFtpServer::OnGetFolderListing ( const WString & current_folder ) [virtual]

Indicates an incoming folder listing request.

When this method is called, the client requests the folder listing of the current folder. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptFolderListingRequest() has to be invoked. To reject this folder listing request RejectFolderListingRequest(resp_code) has to be called.

Parameters:
current_folder The current folder (absolute, e.g "/UserData/MyMusic/") the client requests the folder listing of.

Implements ObexFtpServer.

void RfsObexFtpServer::OnProvideFolderListingEntries ( const WString & current_folder ) [virtual]

Indicates that folder entries have to be provided now.

This method is invoked by the server to indicate that the server is now ready to transfer the the requested folder listing to the client and that the folder listing entries have to be provided now. In order to continue the ongoing operation, the folder listing entries have to be provided by calling ProvideFolderListingEntry(...) for each entry and by finally calling ProvideFolderListingEntriesFinished() when all entries have been provided.

Parameters:
current_folder The current folder (absolute, e.g "/UserData/MyMusic/") the client requests the folder listing of.

Implements ObexFtpServer.

void RfsObexFtpServer::OnSetCurrentFolder | ( | const WString & | current_folder,
 |  | const WString & | new_current_folder,
 |  | BOOLEAN | create
 | ) | [virtual]

Indicates an incoming current-folder change request.

When this method is called, the client requests a change of the current folder. The current folder and the requested current folder are passed to this method. In order to continue the ongoing operation, the request has to be either accepted or rejected. To accept this request the method AcceptSetCurrentFolderRequest() has to be invoked, to reject the folder change request the method RejectFolderListingRequest(resp_code) has to be invoked.

Parameters:
current_folder | The current folder (absolute, e.g "/UserData/MyMusic/").
new_current_folder | The new folder the current folder should be changed to (absolute, e.g. "/UserData/MyMusic/Ringtones/".
create | Flag indicating if the folder should be created if it doesn't exist yet.

Implements ObexFtpServer.

Field Documentation

DirectoryIteratorPtr RfsObexFtpServer::m_dir_itor_ptr [protected]

Path RfsObexFtpServer::m_root_path [protected]

The documentation for this class was generated from the following files:
  • AddOns/RfsObexFtpServer/RfsObexFtpServer.hpp
  • AddOns/RfsObexFtpServer/RfsObexFtpServer.cpp
Generated on Wed Jan 25 01:45:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RfsStorageDeviceRegistrationStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RfsStorageDeviceRegistrationStatusMsg Class Reference

#include <Apoxi/Afs/Rfs/RfsMsgTypes.hpp>

Inheritance diagram for RfsStorageDeviceRegistrationStatusMsg:

[legend]
Collaboration diagram for RfsStorageDeviceRegistrationStatusMsg:

[legend]

Public Types

enum | { ID = 16052 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetStorageDeviceId () const
BOOLEAN | IsDeviceRegistered () const
RfsStorageDeviceRegistrationStatusMsg (const WString &storage_device_id, BOOLEAN device_registered)
virtual | ~RfsStorageDeviceRegistrationStatusMsg ()

Detailed Description

This message is posted by the root file system when a storage device is registered or deregistered.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RfsStorageDeviceRegistrationStatusMsg::RfsStorageDeviceRegistrationStatusMsg | ( | const WString & | storage_device_id,
 |  | BOOLEAN | device_registered
 | ) |

RfsStorageDeviceRegistrationStatusMsg::~RfsStorageDeviceRegistrationStatusMsg ( ) [virtual]

Member Function Documentation

Message * RfsStorageDeviceRegistrationStatusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RfsStorageDeviceRegistrationStatusMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& RfsStorageDeviceRegistrationStatusMsg::GetStorageDeviceId ( ) const [inline]

BOOLEAN RfsStorageDeviceRegistrationStatusMsg::IsDeviceRegistered ( ) const [inline]

The documentation for this class was generated from the following files:
  • Afs/Rfs/RfsMsgTypes.hpp
  • Afs/Rfs/RfsMsgTypes.cpp
Generated on Wed Jan 25 01:45:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RichTextCompoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RichTextCompoundItem Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/RichTextCompoundItem.hpp>

Inheritance diagram for RichTextCompoundItem:

[legend]
Collaboration diagram for RichTextCompoundItem:

[legend]

Public Types

enum | { ID = 10 }

Public Member Functions

virtual CompoundItem * | Clone () const
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
const Color & | GetBackgroundColor () const
const Color & | GetForegroundColor () const
virtual INT | GetId () const
virtual TextAttr | GetTextAttr () const
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual BOOLEAN | Merge (const CompoundItem &compound_item)
void | SetBackgroundColor (const Color &color)
void | SetForegroundColor (const Color &color)
void | SetTextAttr (TextAttr text_attr)
virtual BOOLEAN | Split (INT index, CompoundItem **compound_item)
virtual | ~RichTextCompoundItem ()

Static Public Member Functions

static RichTextCompoundItem * | CreateInstance (const Font &font, const WCHAR *text=0)
Creates and returns an object of this class.

Protected Member Functions

RichTextCompoundItem (const Font &font, const WCHAR *text=0)

Detailed Description

Contains a variable number of wide-characters. A font and text-attributes can be defined.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from TextCompoundItem.

Constructor & Destructor Documentation

RichTextCompoundItem::~RichTextCompoundItem ( ) [virtual]

RichTextCompoundItem::RichTextCompoundItem | ( | const Font & | font,
 |  | const WCHAR * | text = 0
 | ) | [protected]

Member Function Documentation

CompoundItem * RichTextCompoundItem::Clone ( ) const [virtual]

See also:
CompoundItem::Clone

Reimplemented from TextCompoundItem.

RichTextCompoundItem * RichTextCompoundItem::CreateInstance | ( | const Font & | font,
 |  | const WCHAR * | text = 0
 | ) | [static]

Creates and returns an object of this class.

void RichTextCompoundItem::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::Draw

Reimplemented from TextCompoundItem.

const Color& RichTextCompoundItem::GetBackgroundColor ( ) const [inline]

const Color& RichTextCompoundItem::GetForegroundColor ( ) const [inline]

INT RichTextCompoundItem::GetId ( ) const [virtual]

See also:
CompoundItem::GetId()

Reimplemented from TextCompoundItem.

TextAttr RichTextCompoundItem::GetTextAttr ( ) const [virtual]

Reimplemented from TextCompoundItem.

BOOLEAN RichTextCompoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from TextCompoundItem.

BOOLEAN RichTextCompoundItem::Merge ( const CompoundItem & compound_item ) [virtual]

Merges this Compound-Item with another Compound-Item of the instance RichTextCompoundItem, if the text-attribute, the font and the colors match.

See also:
CompoundItem::Merge

Reimplemented from TextCompoundItem.

void RichTextCompoundItem::SetBackgroundColor ( const Color & color ) [inline]

void RichTextCompoundItem::SetForegroundColor ( const Color & color )

void RichTextCompoundItem::SetTextAttr ( TextAttr text_attr ) [inline]

BOOLEAN RichTextCompoundItem::Split | ( | INT | index,
 |  | CompoundItem ** | compound_item
 | ) | [virtual]

See also:
CompoundItem::Split

Reimplemented from TextCompoundItem.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/RichTextCompoundItem.hpp
  • AddOns/MultiMedia/RichTextCompoundItem.cpp
Generated on Wed Jan 25 01:45:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RingerAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RingerAudioDevice Class Reference

#include <Apoxi/Devices/Win32/RingerAudioDevice.hpp>

Inheritance diagram for RingerAudioDevice:

[legend]
Collaboration diagram for RingerAudioDevice:

[legend]

Public Types

enum Channel {
ChannelAll, Channel1, Channel2, Channel3,
Channel4
}
Available channels (only with SMAF format). More...
enum Format {
FormatSmaf, FormatMidi, FormatSmafPhrase11, FormatRmd,
FormatImelody, FormatBuzzer
}
Sound formats. More...
enum | RingerDevice { RingerDeviceSound, RingerDeviceVibrator, RingerDeviceSoundAndVibrator }
Available output device. More...
enum RingerVolume {
RingerVolumeOff, RingerVolume1, RingerVolume2, RingerVolume3,
RingerVolume4, RingerVolume5, RingerVolumeInCall
}
Volume. More...
enum RingTone {
RingerInfoPowerOff, RingerInfoPowerOn, RingerInfoLowBat, RingerInfoConnection,
RingerInfoError1, RingerInfoError2, RingerInfoDeviceIn, RingerInfoDeviceOut,
RingerInfoMsgFull, RingerMessage1, RingerMessage2, RingerMessage3,
RingerMessage4, RingerMessage5, RingerMessage6, RingerMessage7,
RingerMessage8, RingerMessage9, RingerMessage10, RingerBroadcast1,
RingerBroadcast2, RingerBroadcast3, RingerBroadcast4, RingerBroadcast5,
RingerBroadcast6, RingerBroadcast7, RingerBroadcast8, RingerBroadcast9,
RingerBroadcast10, RingerAlarm1, RingerAlarm2, RingerAlarm3,
RingerAlarm4, RingerAlarm5, RingerAlarm6, RingerAlarm7,
RingerAlarm8, RingerAlarm9, RingerAlarm10, Ringer1,
Ringer2, Ringer3, Ringer4, Ringer5,
Ringer6, Ringer7, Ringer8, Ringer9,
Ringer10, Ringer11, Ringer12, Ringer13,
Ringer14, Ringer15, Ringer16, Ringer17,
Ringer18, Ringer19, Ringer20, Ringer21,
Ringer22, Ringer23, Ringer24, Ringer25,
Ringer26, Ringer27, Ringer28, Ringer29,
Ringer30, Ringer31, Ringer32, Ringer33,
Ringer34, Ringer35, Ringer36, Ringer37,
Ringer38, Ringer39, Ringer40, Ringer41,
Ringer42, Ringer43, Ringer44, Ringer45,
Ringer46, Ringer47, Ringer48, Ringer49,
Ringer50, RingerGame1, RingerGame2, RingerGame3,
RingerGame4, RingerGame5, RingerGame6, RingerGame7,
RingerGame8, RingerGame9, RingerGame10
}
Available fixed tones. More...

Public Member Functions

RingerToneInfo | GetFixedRingerToneInfo (RingTone ring_tone)
virtual const WCHAR * | GetName () const
virtual AudioReturnCode | Init (Priority prio)
RingerAudioDevice ()
void | SetStartParam (const StartParam *p_start_param)
AudioReturnCode | SetVolume (RingerVolume volume=RingerVolume3)
virtual AudioReturnCode | Start (BOOLEAN auto_release=TRUE)
virtual AudioReturnCode | Stop (UINT8 channel=0)
virtual | ~RingerAudioDevice ()

Static Public Member Functions

static AudioReturnCode | ReadRingToneInfoFromFfs (RingTone ring_rone, RingerToneInfo *info)
static AudioReturnCode | WriteDefaultRingToneInfo2Ffs ()
Writes for each RingTone a file containing RingerToneInfo to FFS.
static AudioReturnCode | WriteRingToneInfo2Ffs (RingTone ring_tone, const RingerToneInfo *info)

Data Structures

struct | RingerToneInfo
Detailed information to a fixed ringer tone. See enum ToneId. More...
struct | StartParam
Start parameter. More...

Detailed Description

Class RingerAudioDevice
Class to play ringer tones and other sound formats. All functions in this class deal with the ringer.
The ringer device can either be a traditional ringer or poly tone ringer from YAMAHA (MA2 or MA3).
The vibrator is also control through this class.

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Member Enumeration Documentation

enum RingerAudioDevice::Channel

Available channels (only with SMAF format).

Enumerator:
ChannelAll | only use with method Stop()
Channel1 | Channel1.
Channel2 | Channel2.
Channel3 | Channel3.
Channel4 | Channel4.

enum RingerAudioDevice::Format

Sound formats.

Enumerator:
FormatSmaf SMAF
MA2/MA3 NB: SMAF is not just SMAF. With the MA3 came extensions to the SMAF, which cannot be played on a MA2.
FormatMidi MIDI
MA2/MA3 NB: Be aware that MIDI is many different formats, only following formats are supported: SP-MIDI, SMF format 0 and 1
FormatSmafPhrase11 | SMAF phrasell - MA3.
FormatRmd | RMD - MA3.
FormatImelody | Imelody - MA3.
FormatBuzzer | Buzzer - MA3.

enum RingerAudioDevice::RingerDevice

Available output device.

Enumerator:
RingerDeviceSound | Sound.
RingerDeviceVibrator | Vibrator.
RingerDeviceSoundAndVibrator | Sound and vibrator.

enum RingerAudioDevice::RingerVolume

Volume.

Enumerator:
RingerVolumeOff | Volume off.
RingerVolume1 | Volume 1.
RingerVolume2 | Volume 2.
RingerVolume3 | Volume 3.
RingerVolume4 | Volume 4.
RingerVolume5 | Volume 5.
RingerVolumeInCall | Volume in call.

enum RingerAudioDevice::RingTone

Available fixed tones.

Enumerator:
RingerInfoPowerOff | RingerInfoPowerOff.
RingerInfoPowerOn | RingerInfoPowerOn.
RingerInfoLowBat | RingerInfoLowBat.
RingerInfoConnection | RingerInfoConnection.
RingerInfoError1 | RingerInfoError1.
RingerInfoError2 | RingerInfoError2.
RingerInfoDeviceIn | RingerInfoDeviceIn.
RingerInfoDeviceOut | RingerInfoDeviceOut.
RingerInfoMsgFull | RingerInfoMsgFull.
RingerMessage1 | RingerMessage1.
RingerMessage2 | RingerMessage2.
RingerMessage3 | RingerMessage3.
RingerMessage4 | RingerMessage4.
RingerMessage5 | RingerMessage5.
RingerMessage6 | RingerMessage6.
RingerMessage7 | RingerMessage7.
RingerMessage8 | RingerMessage8.
RingerMessage9 | RingerMessage9.
RingerMessage10 | RingerMessage10.
RingerBroadcast1 | RingerBroadcast1.
RingerBroadcast2 | RingerBroadcast2.
RingerBroadcast3 | RingerBroadcast3.
RingerBroadcast4 | RingerBroadcast4.
RingerBroadcast5 | RingerBroadcast5.
RingerBroadcast6 | RingerBroadcast6.
RingerBroadcast7 | RingerBroadcast7.
RingerBroadcast8 | RingerBroadcast8.
RingerBroadcast9 | RingerBroadcast9.
RingerBroadcast10 | RingerBroadcast10.
RingerAlarm1 | RingerAlarm1.
RingerAlarm2 | RingerAlarm2.
RingerAlarm3 | RingerAlarm3.
RingerAlarm4 | RingerAlarm4.
RingerAlarm5 | RingerAlarm5.
RingerAlarm6 | RingerAlarm6.
RingerAlarm7 | RingerAlarm7.
RingerAlarm8 | RingerAlarm8.
RingerAlarm9 | RingerAlarm9.
RingerAlarm10 | RingerAlarm10.
Ringer1 | Ringer1.
Ringer2 | Ringer2.
Ringer3 | Ringer3.
Ringer4 | Ringer4.
Ringer5 | Ringer5.
Ringer6 | Ringer6.
Ringer7 | Ringer7.
Ringer8 | Ringer8.
Ringer9 | Ringer9.
Ringer10 | Ringer10.
Ringer11 | Ringer11.
Ringer12 | Ringer12.
Ringer13 | Ringer13.
Ringer14 | Ringer14.
Ringer15 | Ringer15.
Ringer16 | Ringer16.
Ringer17 | Ringer17.
Ringer18 | Ringer18.
Ringer19 | Ringer19.
Ringer20 | Ringer20.
Ringer21 | Ringer21.
Ringer22 | Ringer22.
Ringer23 | 3Ringer23
Ringer24 | Ringer24.
Ringer25 | Ringer25.
Ringer26 | Ringer26.
Ringer27 | Ringer27.
Ringer28 | Ringer28.
Ringer29 | Ringer29.
Ringer30 | Ringer30.
Ringer31 | Ringer31.
Ringer32 | Ringer32.
Ringer33 | Ringer33.
Ringer34 | Ringer34.
Ringer35 | Ringer35.
Ringer36 | Ringer36.
Ringer37 | Ringer37.
Ringer38 | Ringer38.
Ringer39 | Ringer39.
Ringer40 | Ringer40.
Ringer41 | Ringer41.
Ringer42 | Ringer42.
Ringer43 | Ringer43.
Ringer44 | Ringer4$.
Ringer45 | Ringer45.
Ringer46 | Ringer46.
Ringer47 | Ringer47.
Ringer48 | Ringer48.
Ringer49 | Ringer49.
Ringer50 | Ringer5.
RingerGame1 | RingerGame1.
RingerGame2 | RingerGame2.
RingerGame3 | RingerGame3.
RingerGame4 | RingerGame4.
RingerGame5 | RingerGame5.
RingerGame6 | RingerGame6.
RingerGame7 | RingerGame7.
RingerGame8 | RingerGame8.
RingerGame9 | RingerGame9.
RingerGame10 | RingerGame10.

Constructor & Destructor Documentation

RingerAudioDevice::RingerAudioDevice ( )

RingerAudioDevice::~RingerAudioDevice ( ) [virtual]

Member Function Documentation

RingerAudioDevice::RingerToneInfo RingerAudioDevice::GetFixedRingerToneInfo ( RingTone ring_tone )

Returns detailed information about a fixed ringer tone.

Parameters:
ring_tone Tone to request detailed information.
Returns:
Tone information.

const WCHAR * RingerAudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from GenericAudioDevice.

RingerAudioDevice::AudioReturnCode RingerAudioDevice::Init ( Priority prio ) [virtual]

See also:
AudioDevice::Init

RingerAudioDevice::AudioReturnCode RingerAudioDevice::ReadRingToneInfoFromFfs | ( | RingTone | ring_rone,
 |  | RingerToneInfo * | info
 | ) | [static]

Returns RingerToneInfo read from FFS.

Parameters:
ring_tone | Tone Id.
info | Pointer to information structure.
Returns:
Result of operation.

void RingerAudioDevice::SetStartParam ( const StartParam * p_start_param )

Set start parameter.

Parameters:
p_start_param,: Pointer to start parameter structure.

RingerAudioDevice::AudioReturnCode RingerAudioDevice::SetVolume ( RingerVolume volume = RingerVolume3 )

Set the volume.
For the MA2/MA3 poly tone ringer 5 volume steps are available, for the buzzer only 3 volume steps (1, 3 and 5) If volume will not remembered after power off.

Parameters:
volume Volume to set
Returns:
Result of operation.

RingerAudioDevice::AudioReturnCode RingerAudioDevice::Start ( BOOLEAN auto_release = TRUE ) [virtual]

Plays the requested ringer tone.
The volume level will be last one selected AudioSetVolume method. If a ringer tone is started before the present one is finished, the present ringer tone will be disabled and the new ringer tone is started, i.e. no suspend/resume functionality.

See also:
GenericAudioDevice::Start

Reimplemented from GenericAudioDevice.

RingerAudioDevice::AudioReturnCode RingerAudioDevice::Stop ( UINT8 channel = 0 ) [virtual]

See also:
GenericAudioDevice::Stop

Reimplemented from GenericAudioDevice.

RingerAudioDevice::AudioReturnCode RingerAudioDevice::WriteDefaultRingToneInfo2Ffs ( ) [static]

Writes for each RingTone a file containing RingerToneInfo to FFS.

RingerAudioDevice::AudioReturnCode RingerAudioDevice::WriteRingToneInfo2Ffs | ( | RingTone | ring_tone,
 |  | const RingerToneInfo * | info
 | ) | [static]

Write for a RingTone the corresponding RingerToneInfo to FFS.

Parameters:
ring_tone | Tone Id.
info | Pointer to information structure.
Returns:
Result of operation.

The documentation for this class was generated from the following files:
  • Devices/Win32/RingerAudioDevice.hpp
  • Devices/Win32/RingerAudioDevice.cpp
Generated on Wed Jan 25 01:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RingerAudioDevice::RingerToneInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RingerAudioDevice::RingerToneInfo

RingerAudioDevice::RingerToneInfo Struct Reference

Detailed information to a fixed ringer tone. See enum ToneId. More...

#include <Apoxi/Devices/Win32/RingerAudioDevice.hpp>

Collaboration diagram for RingerAudioDevice::RingerToneInfo:

[legend]

Data Fields

BOOLEAN | copyright
copyright
UINT16 | duration
Duration in ms.
String name
Name of tone.
RingTone ring_tone_id
ring tone Id

Detailed Description

Detailed information to a fixed ringer tone. See enum ToneId.

Field Documentation

BOOLEAN RingerAudioDevice::RingerToneInfo::copyright

copyright

UINT16 RingerAudioDevice::RingerToneInfo::duration

Duration in ms.

String RingerAudioDevice::RingerToneInfo::name

Name of tone.

RingTone RingerAudioDevice::RingerToneInfo::ring_tone_id

ring tone Id

The documentation for this struct was generated from the following file:
  • Devices/Win32/RingerAudioDevice.hpp
Generated on Wed Jan 25 01:46:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RingerAudioDevice::StartParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RingerAudioDevice::StartParam

RingerAudioDevice::StartParam Struct Reference

Start parameter. More...

#include <Apoxi/Devices/Win32/RingerAudioDevice.hpp>

Public Member Functions

StartParam ()
Constructor for default values.

Data Fields

RingerDevice device
Device used to play the tone.
UINT16 | play_count
How often the tone is to be played.
UINT8 | use_param
1: use union param1; 2: use union param2; 3: use union param3
BYTE * | buffer
Pointer to the melody.
UINT32 | buffer_size
Size of the melody buffer.
Channel channel
Only used if Format == FormatSmaf.
UINT8 | channel_volume
Only used if Format == FormatSmaf. SetVolume must still be called.
Format format
Audioformat.
struct {
RingTone ring_tone
Tone to be played.
} Param1
fixed tone Id
struct {
BYTE * buffer
Pointer to the melody.
UINT32 buffer_size
Size of the melody buffer.
Channel channel
Only used if Format == FormatSmaf.
UINT8 channel_volume
Only used if Format == FormatSmaf. SetVolume must still be called.
Format format
Audioformat.
} Param2
Playback from buffer.
struct {
Channel channel
Only used if Format == FormatSmaf.
UINT8 channel_volume
Only used if Format == FormatSmaf. SetVolume must still be called.
Format format
Audioformat.
WCHAR path
Path of the file to play.
} Param3
Playback form file.

Detailed Description

Start parameter.

Constructor & Destructor Documentation

RingerAudioDevice::StartParam::StartParam ( ) [inline]

Constructor for default values.

Field Documentation

BYTE* RingerAudioDevice::StartParam::buffer

Pointer to the melody.

UINT32 RingerAudioDevice::StartParam::buffer_size

Size of the melody buffer.

Channel RingerAudioDevice::StartParam::channel

Only used if Format == FormatSmaf.

UINT8 RingerAudioDevice::StartParam::channel_volume

Only used if Format == FormatSmaf. SetVolume must still be called.

RingerDevice RingerAudioDevice::StartParam::device

Device used to play the tone.

Format RingerAudioDevice::StartParam::format

Audioformat.

struct { ... } RingerAudioDevice::StartParam::Param1

fixed tone Id

struct { ... } RingerAudioDevice::StartParam::Param2

Playback from buffer.

struct { ... } RingerAudioDevice::StartParam::Param3

Playback form file.

WCHAR RingerAudioDevice::StartParam::path

Path of the file to play.

UINT16 RingerAudioDevice::StartParam::play_count

How often the tone is to be played.

RingTone RingerAudioDevice::StartParam::ring_tone

Tone to be played.

UINT8 RingerAudioDevice::StartParam::use_param

1: use union param1; 2: use union param2; 3: use union param3

The documentation for this struct was generated from the following file:
  • Devices/Win32/RingerAudioDevice.hpp
Generated on Wed Jan 25 01:46:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RomData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RomData Class Reference

#include <Apoxi/Auxiliary/RomData.hpp>

Inheritance diagram for RomData:

[legend]
Collaboration diagram for RomData:

[legend]

Public Member Functions

const void * | GetBuffer () const
virtual UINT32 | GetLength () const
virtual UINT32 | Read (UINT32 idx, void *val, UINT32 nbytes) const
virtual BOOLEAN | Read (UINT32 idx, UINT8 &val) const

Static Public Member Functions

static RomData * | CreateInstance (const void *buffer, UINT32 length, DrmLocalId id=c_drm_invalid_local_id)

Protected Member Functions

RomData (const void *buffer, UINT32 length, DrmLocalId id=c_drm_invalid_local_id)
virtual | ~RomData ()

Detailed Description

RomData provides a BinData interface to a memory area in ROM (Flash). RomData can work on shuge buffers (restriction applies only to C166 architecture).

Constructor & Destructor Documentation

RomData::RomData | ( | const void * | buffer,
 |  | UINT32 | length,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) | [protected]

RomData::~RomData ( ) [protected, virtual]

Member Function Documentation

RomData * RomData::CreateInstance | ( | const void * | buffer,
 |  | UINT32 | length,
 |  | DrmLocalId | id = c_drm_invalid_local_id
 | ) | [static]

Creates and returns an object of this class.

const void* RomData::GetBuffer ( ) const [inline]

UINT32 RomData::GetLength ( ) const [virtual]

See also:
BinData::GetLength

Implements BinData.

UINT32 RomData::Read | ( | UINT32 | idx,
 |  | void * | val,
 |  | UINT32 | nbytes
 | ) | const [virtual]

See also:
BinData::Read

Implements BinData.

BOOLEAN RomData::Read | ( | UINT32 | idx,
 |  | UINT8 & | val
 | ) | const [virtual]

See also:
BinData::Read

Implements BinData.

The documentation for this class was generated from the following files:
  • Auxiliary/RomData.hpp
  • Auxiliary/RomData.cpp
Generated on Wed Jan 25 01:46:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RomDataRes Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RomDataRes Struct Reference

#include <Apoxi/Auxiliary/RomDataRes.hpp>

Data Fields

const UINT8 HUGE * | data
MimeType mimetype
UINT32 | size

Field Documentation

const UINT8 HUGE* RomDataRes::data

MimeType RomDataRes::mimetype

UINT32 RomDataRes::size

The documentation for this struct was generated from the following file:
  • Auxiliary/RomDataRes.hpp
Generated on Wed Jan 25 01:46:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RomFont Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RomFont Class Reference
[GUI]

#include <Apoxi/Gui/RomFont.hpp>

Inheritance diagram for RomFont:

[legend]
Collaboration diagram for RomFont:

[legend]

Public Member Functions

virtual INT | GetBaseline () const
virtual INT | GetGapToNextChar (WCHAR character=0) const
virtual void | GetGlyph (WCHAR chr, TextAttr text_attr, GlyphPtr glyph) const
virtual INT | GetHeight () const
virtual const WCHAR * | GetName () const
RomFont (const FontRes &font_res)
RomFont ()
void | Set (const FontRes &font_res)
virtual BOOLEAN | SupportsTextAttr (TextAttr text_attr) const
virtual | ~RomFont ()

Detailed Description

Implementation of the abstract class Font for accessing fonts located in the ROM.

Constructor & Destructor Documentation

RomFont::RomFont ( )

RomFont::RomFont ( const FontRes & font_res )

RomFont::~RomFont ( ) [virtual]

Member Function Documentation

INT RomFont::GetBaseline ( ) const [virtual]

See also:
Font::GetBaseline

Implements Font.

INT RomFont::GetGapToNextChar ( WCHAR character = 0 ) const [virtual]

See also:
Font::GetGapToNextChar

Implements Font.

void RomFont::GetGlyph | ( | WCHAR | chr,
 |  | TextAttr | text_attr,
 |  | GlyphPtr | glyph
 | ) | const [virtual]

See also:
Font::GetGlyph

Implements Font.

INT RomFont::GetHeight ( ) const [virtual]

See also:
Font::GetHeight

Implements Font.

const WCHAR * RomFont::GetName ( ) const [virtual]

See also:
Font::GetName

Implements Font.

void RomFont::Set ( const FontRes & font_res ) [inline]

BOOLEAN RomFont::SupportsTextAttr ( TextAttr text_attr ) const [virtual]

See also:
Font::Supports

Implements Font.

The documentation for this class was generated from the following files:
  • Gui/RomFont.hpp
  • Gui/RomFont.cpp
Generated on Wed Jan 25 01:46:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RootDirectoryIteratorImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RootDirectoryIteratorImp Class Reference
[Virtual Root File System support]

Directory iterator implementation for root storage device. More...

#include <Apoxi/AddOns/AfsRfs/RootDirectoryIteratorImp.hpp>

Inheritance diagram for RootDirectoryIteratorImp:

[legend]
Collaboration diagram for RootDirectoryIteratorImp:

[legend]

Public Member Functions

virtual File::Error | GetLastError () const
virtual void | Increment ()
RootDirectoryIteratorImp (const Pathname &dir_pathname, const FileFilterPtr &filter, const StorageDeviceFilterPtr &dev_filter)

Protected Member Functions

virtual DirectoryIterator & | AtomicIncrement ()
virtual | ~RootDirectoryIteratorImp ()
Destroys the root directory iterator.

Protected Attributes

Pathname m_cur_dev_pathname
The pathname on the currently iterated storage device.
StorageDevicePtr m_cur_device
The currently iterated storage device.
DirectoryIteratorPtr m_cur_dir_itor
The directory iterator of the currently iterated storage device.
StorageDeviceIteratorPtr m_dev_itor
For the root pathname we have to iterate over the devices.

Detailed Description

Directory iterator implementation for root storage device.

Class RootDirectoryIteratorImp implements the directory iterator for the root storage device.

Constructor & Destructor Documentation

RootDirectoryIteratorImp::RootDirectoryIteratorImp | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter,
 |  | const StorageDeviceFilterPtr & | dev_filter
 | ) | [explicit]

See also:
DirectoryIterator::DirectoryIterator(const Pathname &, const FileFilterPtr &, const WString &)

RootDirectoryIteratorImp::~RootDirectoryIteratorImp ( ) [protected, virtual]

Destroys the root directory iterator.

Member Function Documentation

DirectoryIterator & RootDirectoryIteratorImp::AtomicIncrement ( ) [protected, virtual]

Increments the iterator to point to the next pathname in the directory and returns a reference to itself. This increment operation does not consider the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

Returns:
Reference to itself incremented to point to the next pathname or to the root pathname signaling the end iterator.

Implements DirectoryIterator.

File::Error RootDirectoryIteratorImp::GetLastError ( ) const [virtual]

Returns the error occurred by the last operation.

Reimplemented from DirectoryIterator.

void RootDirectoryIteratorImp::Increment ( ) [virtual]

Since we delegate the iteration to the storages devices they also do the filtering for us. We don't have to filter again.

Reimplemented from DirectoryIterator.

Field Documentation

Pathname RootDirectoryIteratorImp::m_cur_dev_pathname [protected]

The pathname on the currently iterated storage device.

StorageDevicePtr RootDirectoryIteratorImp::m_cur_device [protected]

The currently iterated storage device.

DirectoryIteratorPtr RootDirectoryIteratorImp::m_cur_dir_itor [protected]

The directory iterator of the currently iterated storage device.

StorageDeviceIteratorPtr RootDirectoryIteratorImp::m_dev_itor [protected]

For the root pathname we have to iterate over the devices.

The documentation for this class was generated from the following files:
  • AddOns/AfsRfs/RootDirectoryIteratorImp.hpp
  • AddOns/AfsRfs/RootDirectoryIteratorImp.cpp
Generated on Wed Jan 25 01:46:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RootFileImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RootFileImp Class Reference
[Virtual Root File System support]

File implementation for virtual root storage device More...

#include <Apoxi/AddOns/AfsRfs/RootFileImp.hpp>

Inheritance diagram for RootFileImp:

[legend]
Collaboration diagram for RootFileImp:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | Copy (const Pathname &dest_pathname, const WString &dest_device_Id, UINT32 copy_buf_size)
virtual BOOLEAN | Create (UINT32 size)
virtual BOOLEAN | CreateDir ()
virtual BOOLEAN | CreateStreaming ()
virtual BOOLEAN | Delete ()
virtual BOOLEAN | GetAccessDate (Date &date) const
virtual BOOLEAN | GetAttributes (Attributes &attributes) const
virtual BOOLEAN | GetCreationDate (Date &date) const
virtual BOOLEAN | GetModificationDate (Date &date) const
virtual BOOLEAN | GetNativeProperty (UINT prop_Id, void *val) const
virtual BOOLEAN | GetSize (UINT32 &size) const
virtual const WString & | GetStorageDeviceId () const
virtual BOOLEAN | IsArchive () const
virtual BOOLEAN | IsHidden () const
virtual BOOLEAN | IsOpen () const
Tells if the file is open.
virtual BOOLEAN | IsReadOnly () const
virtual BOOLEAN | Open (OpenMode open_mode)
virtual BOOLEAN | OpenStreaming (OpenMode open_mode)
virtual BOOLEAN | Rename (const WString &new_name)
virtual BOOLEAN | Resize (UINT32 new_size, UINT32 copy_buf_size)
virtual BOOLEAN | SetArchive (BOOLEAN archive)
virtual BOOLEAN | SetHidden (BOOLEAN hidden)
virtual BOOLEAN | SetNativeProperty (UINT prop_Id, const void *val)
virtual BOOLEAN | SetReadOnly (BOOLEAN read_only)
virtual BOOLEAN | Split (UINT32 offset, const Pathname &new_file, UINT32 copy_buf_size)

Protected Member Functions

BOOLEAN | Delegate () const
Tells if we delegate the work to m_file.
virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)
virtual BOOLEAN | DoRead (void HUGE *buffer, UINT32 offset, UINT32 count)
virtual BOOLEAN | DoReadStreaming (void HUGE *buffer, UINT32 count, UINT32 &bytes_read)
virtual BOOLEAN | DoReadStreamingAsync (void HUGE *buffer, UINT32 count, StreamingCallback)
virtual BOOLEAN | DoWrite (const void HUGE *buffer, UINT32 offset, UINT32 count)
virtual BOOLEAN | DoWriteStreaming (const void HUGE *buffer, UINT32 count)
virtual BOOLEAN | DoWriteStreamingAsync (const void HUGE *buffer, UINT32 count, StreamingCallback)
StorageDevicePtr | GetDevice () const
Gets the storage device for the specified device directory.
virtual const FileState & | MyState () const
Returns the constant state of the constant file.
virtual FileState & | MyState ()
Returns the state of the file.
RootFileImp (const Pathname &pathname)
virtual | ~RootFileImp ()

Friends

class | RootStorageDeviceImp

Detailed Description

File implementation for virtual root storage device

Class RootFileImp represents a file stored on the virtual root storage device supporting the root file system interface.

See also:
File

Constructor & Destructor Documentation

RootFileImp::RootFileImp ( const Pathname & pathname ) [protected]

RootFileImp::~RootFileImp ( ) [protected, virtual]

Member Function Documentation

BOOLEAN RootFileImp::Close ( ) [virtual]

Closes a previously opened file. An overriding method must call this base implementation at the end of its implementation if the file could be closed successfully to assure that the counter of open files gets set properly.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RootFileImp::Copy | ( | const Pathname & | dest_pathname,
 |  | const WString & | dest_device_Id,
 |  | UINT32 | copy_buf_size
 | ) | [virtual]

Copies the contents of this file to a file at pathname dest_pathname on the device specified by dest_device_Id. Pathname dest_pathname specifies an existing directory either with or without a filename. If a filename is not specified then the name of this source file is used as destination filename. If the destination file already exists the method fails. If dest_pathname specifies this file nothing is done and TRUE is returned. This file must exist, must not be a directory and must not be open, otherwise an assertion holds.

Parameters:
dest_pathname | The pathname where to copy this file to.
dest_device_Id | Specifies the storage device where to copy to default initialized to the root storage device.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

BOOLEAN RootFileImp::Create ( UINT32 size ) [virtual]

Creates a physical file with path m_path and initial size specified in bytes. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents operations in mode ReadAndWriteMode and its internal file position is set to 0, independent of the size argument. The file grows itself if it is written beyond its actual size. Creating an empty file with size 0 is allowed. For shrinking or growing the file use method Resize(). An overriding method must call this base implementation at the end of its implementation if the file could be created successfully to assure that the counter of open files gets set properly. This is a file operation and of course the file must not be open on call.

Parameters:
size The initial size of the new file.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RootFileImp::CreateDir ( ) [virtual]

Creates a physical directory with path m_path. The last segment of m_path is taken as name of the new directory to create. The directory can only be created if all the directories specified in m_path already exist and the new directory doesn't exist yet. This is a file operation and of course the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RootFileImp::CreateStreaming ( ) [virtual]

Creates a physical file with path m_path. The MIME type of the file is implicitly defined by the extension of m_path. The file can only be created if it doesn't exist yet. After the file has been created successfully, the file is opened automatically for contents in streaming mode.

This means that only the methods:

  • WriteStreaming
  • WriteStreamingAsync
  • ReadStreaming
  • ReadStreamingAsync and not the methods Read() or Write() can be used with this file.

Implements File.

BOOLEAN RootFileImp::Delegate ( ) const [inline, protected]

Tells if we delegate the work to m_file.

BOOLEAN RootFileImp::Delete ( ) [virtual]

Deletes the file or directory. If the file is actually a directory, then it must be empty in order to be deleted. If the file or directory does not exist the method fails. The method succeeds if and only if the file or directory could successfully be deleted. This is a file operation, the file must not be open on call.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RootFileImp::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | max_count,
 |  | UINT32 & | bytes_read
 | ) | [protected, virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 max_count, UINT32 &bytes_read)

Implements File.

BOOLEAN RootFileImp::DoRead | ( | void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
Read(void HUGE *buffer, UINT32 offset, UINT32 count)

Implements File.

BOOLEAN RootFileImp::DoReadStreaming | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | UINT32 & | bytes_read
 | ) | [protected, virtual]

See also:
ReadStreaming(void HUGE *buffer, UINT32 count, UINT32 &bytes_read);

Implements File.

virtual BOOLEAN RootFileImp::DoReadStreamingAsync | ( | void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [protected, virtual]

See also:
ReadStreamingAsync(void HUGE *buffer, UINT32 count, StreamingCallback);

Implements File.

BOOLEAN RootFileImp::DoWrite | ( | const void HUGE * | buffer,
 |  | UINT32 | offset,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
Write(const void HUGE *buffer, UINT32 offset, UINT32 count)

Implements File.

BOOLEAN RootFileImp::DoWriteStreaming | ( | const void HUGE * | buffer,
 |  | UINT32 | count
 | ) | [protected, virtual]

See also:
WriteStreaming(const void HUGE *buffer, UINT32 count);

Implements File.

virtual BOOLEAN RootFileImp::DoWriteStreamingAsync | ( | const void HUGE * | buffer,
 |  | UINT32 | count,
 |  | StreamingCallback |
 | ) | [protected, virtual]

See also:
WriteStreamingAsync(const void HUGE *buffer, UINT32 count, StreamingCallback);

Implements File.

BOOLEAN RootFileImp::GetAccessDate ( Date & date ) const [virtual]

If the access date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open. Please override this method for storage devices which support retrieving the date of the last file access.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

BOOLEAN RootFileImp::GetAttributes ( Attributes & attributes ) const [virtual]

BOOLEAN RootFileImp::GetCreationDate ( Date & date ) const [virtual]

If the creation date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

StorageDevicePtr RootFileImp::GetDevice ( ) const [inline, protected]

Gets the storage device for the specified device directory.

BOOLEAN RootFileImp::GetModificationDate ( Date & date ) const [virtual]

If the modification date of the file is available then date is set to it and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RootFileImp::GetNativeProperty | ( | UINT | prop_Id,
 |  | void * | val
 | ) | const [virtual]

Retrieves the native property identified by prop_Id via argument val. If the property is not supported by the native file (and therefore can't be retrieved) the method fails. The properties that the native file supports are defined by the derived class that implements the native file support. E.g., for knowing which properties a flash file supports look at the documentation of class FlashFileImp, there the respective property IDs are defined. It is crucial that the given property ID prop_Id and the receiving value val really match!

Parameters:
prop_Id | ID of the native file property to retrieve, defined in the derived class that implements the native file support.
val | Valid pointer to the value object that shall be set to the current value of the file property with id prop_Id.
Returns:
Tells if the file property could be retrieved.

Reimplemented from File.

BOOLEAN RootFileImp::GetSize ( UINT32 & size ) const [virtual]

If the file size can be retrieved then size is set to the actual file size in bytes and TRUE is returned, otherwise FALSE is returned. The file need not be open.

Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

const WString & RootFileImp::GetStorageDeviceId ( ) const [virtual]

Returns the storage device ID of the device associated to this file class.

Implements File.

BOOLEAN RootFileImp::IsArchive ( ) const [virtual]

Tells if the file is archive. This is a file operation, the file must not be open on call.

Implements File.

BOOLEAN RootFileImp::IsHidden ( ) const [virtual]

Tells if the file is hidden. This is a file operation, the file must not be open on call.

Implements File.

BOOLEAN RootFileImp::IsOpen ( ) const [virtual]

Tells if the file is open.

Implements File.

BOOLEAN RootFileImp::IsReadOnly ( ) const [virtual]

Tells if the file is read only. This is a file operation, the file must not be open on call.

Implements File.

const File::FileState & RootFileImp::MyState ( ) const [protected, virtual]

Returns the constant state of the constant file.

Implements File.

File::FileState & RootFileImp::MyState ( ) [protected, virtual]

Returns the state of the file.

Implements File.

BOOLEAN RootFileImp::Open ( OpenMode open_mode ) [virtual]

BOOLEAN RootFileImp::OpenStreaming ( OpenMode open_mode ) [virtual]

BOOLEAN RootFileImp::Rename ( const WString & new_name ) [virtual]

Renames the file or directory to new_name. If the file or directory does not exist the method fails. Argument new_name is the file name including the file extension (if any) but without any leading directories. The MIME type of the renamed file is defined by the extension of the new name, if none exists it has general type. If the new name is equal to the old name the method fails. The method succeeds if and only if the file or directory really was renamed. Subclasses have to first check if the new file name is different to the actual one, then physically rename the file, and finally call this base method for changing the name which is controlled within this base class. This base method never fails. For a sample implementation see FlashFileImp::Rename(). This is a file operation, the file must not be open on call.

Parameters:
new_name New name of the file including the file extension (if any). No directory segments are allowed.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Implements File.

BOOLEAN RootFileImp::Resize | ( | UINT32 | new_size,
 |  | UINT32 | copy_buf_size
 | ) | [virtual]

Resizes the file to contain new_size bytes. If the new size is less than the original size then the file is truncated. If the new size is bigger than the original size then the newly created part of the file is not initialized and has to be written to be in defined state. Emptying a file by resizing it to size 0 is allowed. This default implementation uses a temporary file for resizing. Override this method if resizing is explicitly supported by the derived file class. This is a file operation, the file must not be open on call.

Parameters:
new_size | The new size of the file.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

BOOLEAN RootFileImp::SetArchive ( BOOLEAN archive ) [virtual]

Sets the archive flag.

Parameters:
archive If TRUE then the file is an archive.

Implements File.

BOOLEAN RootFileImp::SetHidden ( BOOLEAN hidden ) [virtual]

Sets the hidden flag.

Parameters:
hidden If TRUE then the file is hidden.

Implements File.

BOOLEAN RootFileImp::SetNativeProperty | ( | UINT | prop_Id,
 |  | const void * | val
 | ) | [virtual]

Sets the native property identified by prop_Id to value val. If the property is not supported by the native file (and therefore can't be set) the method fails. The properties that the native file supports are defined by the derived class that implements the native file support. E.g., for knowing which properties a flash file supports look at the documentation of class FlashFileImp, there the respective property IDs are defined. It is crucial that the given property ID prop_Id and the passed value val really match!

Parameters:
prop_Id | ID of the native file property to set, defined in the derived class that implements the native file support.
val | Valid pointer to the value that shall be set for file property with id prop_Id.
Returns:
Tells if the file property could be set.

Reimplemented from File.

BOOLEAN RootFileImp::SetReadOnly ( BOOLEAN read_only ) [virtual]

Sets the read only flag.

Parameters:
read_only If TRUE then the file is set to read only mode.

Implements File.

BOOLEAN RootFileImp::Split | ( | UINT32 | offset,
 |  | const Pathname & | new_file,
 |  | UINT32 | copy_buf_size
 | ) | [virtual]

Splits the contents of this file at offset. The first half of the file remains in this file, the second half of the file will be stored in new_file. Pathname new_file specifies an existing directory with a new filename, i.e. the directory must exist but the file must not exist, otherwise the method fails. If new_file specifies this file nothing is done and FALSE is returned. The specified offset must be greater than 0 and lower than the current size of the file minus 1, otherwise an assertion holds. This file must exist, must not be a directory and must not be open, otherwise an assertion holds.

Parameters:
offset | Number of bytes from origin where to split the file.
new_file | The pathname of the file which will store the second half of the file.
copy_buf_size | The size of the internally used copy buffer, if used at all. The size of this buffer may significantly affect the performance of this operation.
Returns:
Flag indicating success. Please call GetLastError() to get an error code.

Reimplemented from File.

Friends And Related Function Documentation

friend class RootStorageDeviceImp [friend]

The documentation for this class was generated from the following files:
  • AddOns/AfsRfs/RootFileImp.hpp
  • AddOns/AfsRfs/RootFileImp.cpp
Generated on Wed Jan 25 01:46:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RootFileSystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RootFileSystem Class Reference
[Root File System]

Client interface for root file system access. More...

#include <Apoxi/Afs/Rfs/RootFileSystem.hpp>

Collaboration diagram for RootFileSystem:

[legend]

Public Types

enum | { MAX_STORAGE_DEVICE_ID_LENGTH }

Static Public Member Functions

static FilePtr | CreateTempFile (const Path &base_path, UINT32 size)
static FilePtr | CreateTempFile (const Pathname &base_pathname, UINT32 size, const WString &device_Id=L"rfs")
static BOOLEAN | DeleteFile (const Path &filepath)
static BOOLEAN | DeleteFile (const Pathname &file_pathname, const WString &device_Id=L"rfs")
static BOOLEAN | Exists (const Path &path)
static BOOLEAN | Exists (const Pathname &pathname, const WString &device_Id=L"rfs")
static DirectoryIteratorPtr | GetDirectoryIterator (const Path &filepath, const FileFilterPtr &filter)
static DirectoryIteratorPtr | GetDirectoryIterator (const Pathname &dir_pathname, const FileFilterPtr &filter, const WString &device_Id=L"rfs")
static FilePtr | GetFile (const Path &path)
static FilePtr | GetFile (const Pathname &pathname, const WString &device_Id=L"rfs")
static StorageDevicePtr | GetStorageDevice (const WString &device_Id)
static UINT | GetStorageDeviceCount ()
static StorageDeviceIteratorPtr | GetStorageDeviceIterator (const StorageDeviceFilterPtr &filter)
static BOOLEAN | IsDirectory (const Path &path)
static BOOLEAN | IsDirectory (const Pathname &pathname, const WString &device_Id=L"rfs")
static BOOLEAN | MoveFile (const Path &from_file_path, const Path &to_path)
static BOOLEAN | MoveFile (const Pathname &from_file_pathname, const Pathname &to_pathname, const WString &from_device_Id=L"rfs", const WString &to_device_Id=L"rfs")

Static Protected Member Functions

static void | NotifyMediaAvailableStatus (const StorageDevice &device, BOOLEAN media_present)
static BOOLEAN | RegisterStorageDevice (StorageDevicePtr device)
static BOOLEAN | UnregisterStorageDevice (StorageDevicePtr device)

Friends

class | StorageDevice
class | StorageDeviceIterator

Detailed Description

Client interface for root file system access.

Class RootFileSystem enables unified file access to the file systems of the different storage devices available to the mobile station. A file is specified by a storage device Id and a pathname. Method RootFileSystem::GetFile() returns a FilePtr which is a smart-pointer wrapping a File object. File can be considered kind of a file handle and can be used e.g. to create, open, read, write, delete, or rename a file ( see class File).

The following sample function shows how to work with a file, in this case the flash storage device is used:

    static BOOLEAN MyFirstFileWrite()
    {
        const WCHAR text[] = L"My first text I write to a file...";

        Pathname pathname("/my_file.txt");

        // Get the "file handle".
        FilePtr file = RootFileSystem::GetFile(pathname, L"ffs");
        if (!file.IsValid()) {
            // Handle out of memory error.
            return FALSE;
        }

        if (file->Exists()) {
            if (!file->Open(File::ReadAndWriteMode)) {
                // Handle file open error.
                return FALSE;
            }
        }
        else {
            if (!file->Create(sizeof(text))) {
                // Handle file create error.
                return FALSE;
            }
        }

        // Use the file.
        if (!file->Write(text, 0, sizeof(text))) {
            // Handle file write error.
            return FALSE;
        }

        // If we don't explicitly close the file, it is done automatically on
        // destruction.
        return TRUE;
    }

All available storage devices are supposed to be registered with the RootFileSystem. In order to access a registered storage device call RootFileSystem::GetStorageDevice().

Member Enumeration Documentation

anonymous enum

Enumerator:
MAX_STORAGE_DEVICE_ID_LENGTH A storage device Id string is limited to MAX_STORAGE_DEVICE_ID_LENGTH characters including the terminating 0 character, i.e. there may be at most MAX_STORAGE_DEVICE_ID_LENGTH - 1 significant characters in the storage device Id string.

Member Function Documentation

FilePtr RootFileSystem::CreateTempFile | ( | const Path & | base_path,
 |  | UINT32 | size
 | ) | [static]

See also:
CreateTempFile(const WString &, const Pathname &, UINT32)

FilePtr RootFileSystem::CreateTempFile | ( | const Pathname & | base_pathname,
 |  | UINT32 | size,
 |  | const WString & | device_Id = L"rfs"
 | ) | [static]

Returns a smart-pointer wrapping a new temporary File object which is fully created and ready for use. First it is tried to create the file with pathname base_pathname. If this is not successful as many internally defined extensions as necessary to create it successfully are added to the name immediately in front of the file extension. This procedure ensures that the Mime type of the file remains the same as specified by the extension of base_path. If no extension is specified the internally defined extensions are simply appended and the Mime type remains undefined. The temporary file is a file as any other file with the single exception that the physically allocated file is deleted automatically on destruction. If you want to convert a temporary file to a permanent one, invoke method File::MakePermanent() on it.

Parameters:
base_pathname | The base pathname.
size | The initial filesize in bytes.
device_Id | The Id of the storage device default initialized to the root storage device.
Returns:
A FilePtr wrapping either a new temporary File object or 0 if the file could not be created.
See also:
File::MakePermanent()

BOOLEAN RootFileSystem::DeleteFile ( const Path & filepath ) [static]

See also:
DeleteFile(const Pathname &, const WString &)

BOOLEAN RootFileSystem::DeleteFile | ( | const Pathname & | file_pathname,
 |  | const WString & | device_Id = L"rfs"
 | ) | [static]

Deletes file on storage device with storage device Id device_Id and pathname file_pathname.

Returns:
Flag indicating success.

BOOLEAN RootFileSystem::Exists ( const Path & path ) [static]

See also:
Exists(const Pathname &, const WString &)

BOOLEAN RootFileSystem::Exists | ( | const Pathname & | pathname,
 |  | const WString & | device_Id = L"rfs"
 | ) | [static]

Tells if pathname on storage device specified by device_Id exists. If it exists it may either be a file or a directory.

Parameters:
pathname | The pathname to check for existence.
device_Id | The Id of the storage device default initialized to the root storage device.

DirectoryIteratorPtr RootFileSystem::GetDirectoryIterator | ( | const Path & | filepath,
 |  | const FileFilterPtr & | filter
 | ) | [static]

See also:
GetDirectoryIterator(const Pathname &, const FileFilterPtr &, const WString &)

DirectoryIteratorPtr RootFileSystem::GetDirectoryIterator | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter,
 |  | const WString & | device_Id = L"rfs"
 | ) | [static]

Creates a new iterator for directory dir_pathname on storage device with storage device Id device_Id and returns it wrapped into a smart-pointer. On success, the returned iterator loops over files and directories contained in directory dir_pathname. The files and directories listed are filtered using the passed filter functor. To iterate all files and directories just pass the empty file filter functor FileFilterPtr(0).

Elements of subdirectories are not iterated by the returned iterator. In order to iterate elements of subdirectories iterators for these subdirectories have to be created recursively.

If the directory dir_pathname to be iterated does not exist or is not a directory then the returned smart-pointer just wraps the 0 pointer.

Parameters:
dir_pathname | The pathname of the directory whose files and subdirectories are to be iterated by the created iterator.
filter | A filter functor (FileFilterPtr(0) for unfiltered access) to be used by the created iterator.
device_Id | The Id of the storage device (default initialized to the root storage device) where directory dir_pathname is located.
Returns:
A DirectoryIteratorPtr wrapping either a new iterator object or 0 if there is not enough memory left.

FilePtr RootFileSystem::GetFile ( const Path & path ) [static]

See also:
GetFile(const Pathname &, const WString &)

FilePtr RootFileSystem::GetFile | ( | const Pathname & | pathname,
 |  | const WString & | device_Id = L"rfs"
 | ) | [static]

Returns a smart-pointer wrapping a new File object. This file object can be considered kind of a file handle.

Parameters:
pathname | The pathname of the file.
device_Id | The Id of the storage device default initialized to the root storage device.
Returns:
A FilePtr wrapping either a new File object or 0 if the storage device device_Id does not exist or there is not enough memory left.

StorageDevicePtr RootFileSystem::GetStorageDevice ( const WString & device_Id ) [static]

Returns the storage device for the specified device Id. If such a storage device does currently not exist then the 0 smart-pointer is returned.

Parameters:
device_Id The Id of the storage device.

static UINT RootFileSystem::GetStorageDeviceCount ( ) [inline, static]

Returns the actual number of storage devices registered.

StorageDeviceIteratorPtr RootFileSystem::GetStorageDeviceIterator ( const StorageDeviceFilterPtr & filter ) [static]

Creates a new storage device iterator. The storage device iterator iterates over all storage devices which are currently registered to the root file system.

BOOLEAN RootFileSystem::IsDirectory ( const Path & path ) [static]

See also:
IsDirectory(const Pathname &, const WString &)

BOOLEAN RootFileSystem::IsDirectory | ( | const Pathname & | pathname,
 |  | const WString & | device_Id = L"rfs"
 | ) | [static]

Tells if pathname on storage device specified by device_Id locates a directory.

Parameters:
pathname | The pathname of the file.
device_Id | The Id of the storage device default initialized to the root storage device.

BOOLEAN RootFileSystem::MoveFile | ( | const Path & | from_file_path,
 |  | const Path & | to_path
 | ) | [static]

See also:
MoveFile(const Pathname &, const Pathname &, const WString &, const WString &)

BOOLEAN RootFileSystem::MoveFile | ( | const Pathname & | from_file_pathname,
 |  | const Pathname & | to_pathname,
 |  | const WString & | from_device_Id = L"rfs",
 |  | const WString & | to_device_Id = L"rfs"
 | ) | [static]

Moves the file at from_file_pathname on storage device from_device_Id to pathname to_pathname on storage device to_device_Id. Pathname to_pathname specifies an existing directory either with or without a filename. If a filename is not specified then the name of the source file is used as destination filename. If the destination file already exists the method fails. If pathname to_pathname specifies this file nothing is done and TRUE is returned.

Parameters:
from_file_pathname | The pathname of the source file.
to_pathname | The pathname where to copy the source file to.
from_device_Id | Specifies the storage device of the source file.
to_device_Id | Specifies the storage device where to copy the source file to.
Returns:
Flag indicating success.

void RootFileSystem::NotifyMediaAvailableStatus | ( | const StorageDevice & | device,
 |  | BOOLEAN | media_present
 | ) | [static, protected]

Notifies the root file system about the media availability status of the storage device specified by argument device. Argument media_present specifies whether a media is inserted in storage device device. The root file system reacts to this by posting an RfsMediaAvailableStatusMsg to the system. Applications can register for this message and use it to display storage device icons and the like.

Parameters:
device | The storage device for which the status is reported.
media_present | The flag specifying whether a media is inserted or not.

BOOLEAN RootFileSystem::RegisterStorageDevice ( StorageDevicePtr device ) [static, protected]

Registers the specified storage device with the root file system. If another device with storage device Id string of the passed device has already been registered then the passed device can't be registered and FALSE is returned, since storage devices are identified by their distinct storage device Id string. If registering succeeded then TRUE is returned, if for any reason like out of memory the device can't be registered then FALSE is returned. A subclass of class StorageDevice should provide a public static method Setup() which registers a singleton instance of the storage device with the root file system on its first invocation.

Parameters:
device The device to be registered.
Returns:
Tells if the device has been successfully registered.

BOOLEAN RootFileSystem::UnregisterStorageDevice ( StorageDevicePtr device ) [static, protected]

Unregisters the specified storage device from the root file system and returns the success of unregistering. A subclass of class StorageDevice should unregister itself on destruction.

Parameters:
device The device to be unregistered.

Friends And Related Function Documentation

friend class StorageDevice [friend]

friend class StorageDeviceIterator [friend]

The documentation for this class was generated from the following files:
  • Afs/Rfs/RootFileSystem.hpp
  • Afs/Rfs/RootFileSystem.cpp
Generated on Wed Jan 25 01:46:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RootStorageDeviceImp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RootStorageDeviceImp Class Reference
[Virtual Root File System support]

Storage device implementation for virtual root storage device. More...

#include <Apoxi/AddOns/AfsRfs/RootStorageDeviceImp.hpp>

Inheritance diagram for RootStorageDeviceImp:

[legend]
Collaboration diagram for RootStorageDeviceImp:

[legend]

Public Member Functions

virtual BOOLEAN | Exists (const Pathname &pathname) const
virtual BOOLEAN | Format (BOOLEAN quick=FALSE)
virtual UINT8 | GetDefaultChunkSize () const
virtual UINT32 | GetFreeVolumeSize () const
virtual File::Error | GetLastError () const
virtual WString | GetNativeDirectoryPathname (const Pathname &pathname) const
virtual WString | GetNativeFilePathname (const Pathname &pathname) const
virtual BOOLEAN | GetOpenFilesCounter (UINT &counter) const
virtual UINT32 | GetTotalVolumeSize () const
virtual UINT32 | GetUsedVolumeSize () const
virtual BOOLEAN | IsDirectory (const Pathname &pathname) const
virtual BOOLEAN | IsReady () const

Static Public Member Functions

static const WString & | GetId ()
Returns the storage device ID string.

Protected Member Functions

virtual DirectoryIteratorPtr | CreateDirectoryIterator (const Pathname &dir_pathname, const FileFilterPtr &filter) const
virtual FilePtr | CreateFileObject (const Pathname &pathname) const
RootStorageDeviceImp ()
Creates a new root storage device object.
virtual | ~RootStorageDeviceImp ()

Static Protected Member Functions

static BOOLEAN | Setup ()

Friends

class | RootFileSystem

Detailed Description

Storage device implementation for virtual root storage device.

Class RootStorageDeviceImp implements the storage device interface for the virtual root storage device which unifies all other storage devices that are actually registered to the root file system. Each registered storage device is available as first-level subdirectory of the root directory and is named like the short name of the storage device.

Constructor & Destructor Documentation

RootStorageDeviceImp::RootStorageDeviceImp ( ) [protected]

Creates a new root storage device object.

RootStorageDeviceImp::~RootStorageDeviceImp ( ) [protected, virtual]

Destroys this root storage device and unregisters it from the root file system.

Member Function Documentation

DirectoryIteratorPtr RootStorageDeviceImp::CreateDirectoryIterator | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter
 | ) | const [protected, virtual]

Creates a new directory iterator object for the specified pathname.

Parameters:
dir_pathname | The pathname of the directory.
filter | The filter which selects the files the iterator shall return.
Returns:
A DirectoryIteratorPtr wrapping either a new directory iterator object or 0 if there is not enough memory left.

Implements StorageDevice.

FilePtr RootStorageDeviceImp::CreateFileObject ( const Pathname & pathname ) const [protected, virtual]

Creates a new file object for the specified pathname.

Parameters:
pathname The pathname.
Returns:
A FilePtr wrapping either a new file object or 0 if there is not enough memory left.

Implements StorageDevice.

BOOLEAN RootStorageDeviceImp::Exists ( const Pathname & pathname ) const [virtual]

Tells if pathname exists. If it exists it may either be a file or a directory.

Implements StorageDevice.

BOOLEAN RootStorageDeviceImp::Format ( BOOLEAN quick = FALSE ) [virtual]

The virtual root storage device cannot be formatted. It is only possible to format real devices.

Implements StorageDevice.

UINT8 RootStorageDeviceImp::GetDefaultChunkSize ( ) const [virtual]

Returns the default chunk size for operating in chunk mode on files stored on this storage device.

See also:
File::GetChunkSize()

File::SetChunkSize()

Implements StorageDevice.

UINT32 RootStorageDeviceImp::GetFreeVolumeSize ( ) const [virtual]

Returns the free volume size of the device in bytes.

Returns:
The free volume size of the device in bytes.

Implements StorageDevice.

const WString & RootStorageDeviceImp::GetId ( ) [static]

Returns the storage device ID string.

virtual File::Error RootStorageDeviceImp::GetLastError ( ) const [inline, virtual]

Returns the error occurred by the last operation.

Reimplemented from StorageDevice.

WString RootStorageDeviceImp::GetNativeDirectoryPathname ( const Pathname & pathname ) const [virtual]

Returns pathname in native directory name format. The native directory name format may differ from storage device to storage device.

Implements StorageDevice.

WString RootStorageDeviceImp::GetNativeFilePathname ( const Pathname & pathname ) const [virtual]

Returns pathname in native file name format. The native file name format may differ from storage device to storage device.

Implements StorageDevice.

BOOLEAN RootStorageDeviceImp::GetOpenFilesCounter ( UINT & counter ) const [virtual]

Returns the number of currently open file handles.

Reimplemented from StorageDevice.

UINT32 RootStorageDeviceImp::GetTotalVolumeSize ( ) const [virtual]

Returns the total volume size of the device in bytes.

Returns:
The total volume size of the device in bytes.

Implements StorageDevice.

UINT32 RootStorageDeviceImp::GetUsedVolumeSize ( ) const [virtual]

Returns the used volume size of the device in bytes. Note that this size is usually larger than the sum of the sizes of all stored files, since meta information to control the directory structure is stored on the device, too.

Returns:
The used volume size of the device in bytes.

Implements StorageDevice.

BOOLEAN RootStorageDeviceImp::IsDirectory ( const Pathname & pathname ) const [virtual]

Tells if pathname is a directory. This base implementation returns TRUE only for the root pathname, since every storage device is at least organized in a flat manner which we interpret as having a single root directory. The method is declared as abstract for when implementing a new storage device you can't forget to deal with this issue. If the derived storage device is organized in a flat manner, then the override of this abstract method might be a simple call to this base class implementation. If a derived class supports directories then implement this method accordingly.

Implements StorageDevice.

BOOLEAN RootStorageDeviceImp::IsReady ( ) const [virtual]

The virtual root storage device is ready to be used when at least one of the currently registered devices is ready to be used.

Implements StorageDevice.

BOOLEAN RootStorageDeviceImp::Setup ( ) [static, protected]

Sets up the storage device for usage. The method must be called before using the root storage device. It can be called as many times as convenient, however, only the first call does the work. If there is a setup problem FALSE is returned.

Friends And Related Function Documentation

friend class RootFileSystem [friend]

Reimplemented from StorageDevice.

The documentation for this class was generated from the following files:
  • AddOns/AfsRfs/RootStorageDeviceImp.hpp
  • AddOns/AfsRfs/RootStorageDeviceImp.cpp
Generated on Wed Jan 25 01:46:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RootStorageDeviceIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RootStorageDeviceIterator Class Reference
[Root File System]

Device iterator implementation for virtual root storage device. More...

#include <Apoxi/Afs/Rfs/StorageDeviceIterator.hpp>

Inheritance diagram for RootStorageDeviceIterator:

[legend]
Collaboration diagram for RootStorageDeviceIterator:

[legend]

Public Member Functions

virtual BOOLEAN | IsValid () const
RootStorageDeviceIterator (const StorageDeviceFilterPtr &filter)
~RootStorageDeviceIterator ()

Protected Member Functions

virtual StorageDeviceIterator & | AtomicIncrement ()

Friends

class | RootFileSystem

Detailed Description

Device iterator implementation for virtual root storage device.

Class RootStorageDeviceIterator implements the device iterator for the virtual root storage device. This class should be used if the RootStorageDevice should not be returned by the iterator. This is needed for example when the free volume size for the registered devices should be retrieved. Since the RootStorageDevice is only a virtual one it cannot have a volume size.

Constructor & Destructor Documentation

RootStorageDeviceIterator::RootStorageDeviceIterator ( const StorageDeviceFilterPtr & filter )

Constructs a root storage device iterator. The iterator retrieves storage devices which comply to filter. This is the only constructor since a non-initialized storage device iterator is not allowed.

Parameters:
filter A storage device filter functor.

RootStorageDeviceIterator::~RootStorageDeviceIterator ( )

Member Function Documentation

StorageDeviceIterator & RootStorageDeviceIterator::AtomicIncrement ( ) [protected, virtual]

Increments the iterator to point to the next storage device registered to the root file system and returns a reference to itself. This increment operation does not consider the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

Returns:
Reference to itself incremented to point to the next storage device or being the end iterator.

Reimplemented from StorageDeviceIterator.

BOOLEAN RootStorageDeviceIterator::IsValid ( ) const [virtual]

Tells if the iterator points to a storage device. This is determined by simply checking the current storage device smart-pointer. If it wraps 0 it is not valid, otherwise it is valid.

Returns:
Tells if the iterator is valid.

Reimplemented from StorageDeviceIterator.

Friends And Related Function Documentation

friend class RootFileSystem [friend]

Reimplemented from StorageDeviceIterator.

The documentation for this class was generated from the following files:
  • Afs/Rfs/StorageDeviceIterator.hpp
  • Afs/Rfs/StorageDeviceIterator.cpp
Generated on Wed Jan 25 01:46:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RrcParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RrcParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for RrcParam:

[legend]

Public Member Functions

RrcParam | operator= (T_RRC_TESTPARAM *rrc_testparam)
RrcParam ()

Data Fields

UINT8 | as_error_code
MmRrReason chn_rel_cause
DchReport l1_data
INT8 | oos_cnt
PowerSavingMode power_saving_mode
BOOLEAN | ps_transfer
UINT8 | rrc_state
RrcProcessState rrcbp_state
RrcProcessState rrcdc_state
RrcProcessState rrcm_state
UINT8 | tx_pwr
UINT8 | ul_meas_cnt
UmtsMeasEvalParam umts_meas_eval_param
UmtsRrcScellParam umts_scell

Constructor & Destructor Documentation

RrcParam::RrcParam ( ) [inline]

Member Function Documentation

RrcParam RrcParam::operator= ( T_RRC_TESTPARAM * rrc_testparam )

Field Documentation

UINT8 RrcParam::as_error_code

MmRrReason RrcParam::chn_rel_cause

DchReport RrcParam::l1_data

INT8 RrcParam::oos_cnt

PowerSavingMode RrcParam::power_saving_mode

BOOLEAN RrcParam::ps_transfer

UINT8 RrcParam::rrc_state

RrcProcessState RrcParam::rrcbp_state

RrcProcessState RrcParam::rrcdc_state

RrcProcessState RrcParam::rrcm_state

UINT8 RrcParam::tx_pwr

UINT8 RrcParam::ul_meas_cnt

UmtsMeasEvalParam RrcParam::umts_meas_eval_param

UmtsRrcScellParam RrcParam::umts_scell

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:46:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RrcProcessState Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RrcProcessState Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

RrcProcessState | operator= (T_RRC_PROCESS_STATE rrc_process_state)

Data Fields

UINT8 | event
UINT8 | process_state

Member Function Documentation

RrcProcessState RrcProcessState::operator= ( T_RRC_PROCESS_STATE rrc_process_state )

Field Documentation

UINT8 RrcProcessState::event

UINT8 RrcProcessState::process_state

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:46:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RrParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RrParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

BOOLEAN | IsCellReselectionReasonInvalid ()
BOOLEAN | IsChannelReleaseReasonInvalid ()
BOOLEAN | IsStateInvalid ()
RrParam | operator= (T_RR_TESTPARAM *rr_testparam)
RrParam ()

Data Fields

INT | cell_reselection_reason
MmRrReason channel_release_reason
BOOLEAN | limited_service
INT | state

Constructor & Destructor Documentation

RrParam::RrParam ( ) [inline]

Member Function Documentation

BOOLEAN RrParam::IsCellReselectionReasonInvalid ( ) [inline]

BOOLEAN RrParam::IsChannelReleaseReasonInvalid ( ) [inline]

BOOLEAN RrParam::IsStateInvalid ( ) [inline]

RrParam RrParam::operator= ( T_RR_TESTPARAM * rr_testparam )

Field Documentation

INT RrParam::cell_reselection_reason

MmRrReason RrParam::channel_release_reason

BOOLEAN RrParam::limited_service

INT RrParam::state

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 01:46:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtcAlarmReachedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtcAlarmReachedMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for RtcAlarmReachedMsg:

[legend]
Collaboration diagram for RtcAlarmReachedMsg:

[legend]

Public Types

enum | { ID = 2913 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
RtcAlarmReachedMsg ()
virtual | ~RtcAlarmReachedMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RtcAlarmReachedMsg::RtcAlarmReachedMsg ( )

RtcAlarmReachedMsg::~RtcAlarmReachedMsg ( ) [virtual]

Member Function Documentation

Message * RtcAlarmReachedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RtcAlarmReachedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:46:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtcDateChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtcDateChangedMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for RtcDateChangedMsg:

[legend]
Collaboration diagram for RtcDateChangedMsg:

[legend]

Public Types

enum | { ID = 2912 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
RtcDateChangedMsg ()
virtual | ~RtcDateChangedMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RtcDateChangedMsg::RtcDateChangedMsg ( )

RtcDateChangedMsg::~RtcDateChangedMsg ( ) [virtual]

Member Function Documentation

Message * RtcDateChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RtcDateChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:46:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtcInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtcInfoMsg Class Reference

#include <Apoxi/Devices/RtcMsgTypes.hpp>

Inheritance diagram for RtcInfoMsg:

[legend]
Collaboration diagram for RtcInfoMsg:

[legend]

Public Types

enum | { ID = 9050 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const RealTimeClock::RtcInfo & | GetRtcInfo () const
RtcInfoMsg (const RealTimeClock::RtcInfo &rtc_info)
virtual | ~RtcInfoMsg ()

Detailed Description

RtcInfoMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RtcInfoMsg::RtcInfoMsg ( const RealTimeClock::RtcInfo & rtc_info )

RtcInfoMsg::~RtcInfoMsg ( ) [virtual]

Member Function Documentation

Message * RtcInfoMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RtcInfoMsg::GetMetaData ( ) const [virtual]

Implements Message.

const RealTimeClock::RtcInfo& RtcInfoMsg::GetRtcInfo ( ) const [inline]

The documentation for this class was generated from the following files:
  • Devices/RtcMsgTypes.hpp
  • Devices/RtcMsgTypes.cpp
Generated on Wed Jan 25 01:46:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtcSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtcSignalMapTableNode Class Reference

#include <Apoxi/Devices/RtcSignalMapTableNode.hpp>

Inheritance diagram for RtcSignalMapTableNode:

[legend]
Collaboration diagram for RtcSignalMapTableNode:

[legend]

Static Public Member Functions

static RtcSignalMapTableNode * GetInstance ()

Detailed Description

@addtogroup Devices

Member Function Documentation

RtcSignalMapTableNode * RtcSignalMapTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Devices/RtcSignalMapTableNode.hpp
  • Devices/RtcSignalMapTableNode.cpp
Generated on Wed Jan 25 01:46:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtcSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtcSignalProcessor Class Reference

#include <Apoxi/Devices/RtcSignalProcessor.hpp>

Public Types

typedef void(* | RtcEventCallbackFn )()

Static Public Member Functions

static void | PostMinuteTickInd (const ProcessPtr &process_ptr)
static void | PostRtcEventInd (const ProcessPtr &process_ptr)
static void | PostRtcNotValidInd (const ProcessPtr &process_ptr)
static void | SetRtcEventCallbackFn (RtcEventCallbackFn fn)

Detailed Description

@addtogroup Devices

Member Typedef Documentation

typedef void(* RtcSignalProcessor::RtcEventCallbackFn)()

Member Function Documentation

void RtcSignalProcessor::PostMinuteTickInd ( const ProcessPtr & process_ptr ) [static]

void RtcSignalProcessor::PostRtcEventInd ( const ProcessPtr & process_ptr ) [static]

void RtcSignalProcessor::PostRtcNotValidInd ( const ProcessPtr & process_ptr ) [static]

static void RtcSignalProcessor::SetRtcEventCallbackFn ( RtcEventCallbackFn fn ) [inline, static]

The documentation for this class was generated from the following files:
  • Devices/RtcSignalProcessor.hpp
  • Devices/RtcSignalProcessor.cpp
Generated on Wed Jan 25 01:46:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtcTimeChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtcTimeChangedMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for RtcTimeChangedMsg:

[legend]
Collaboration diagram for RtcTimeChangedMsg:

[legend]

Public Types

enum | { ID = 2911 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
RtcTimeChangedMsg ()
virtual | ~RtcTimeChangedMsg ()

Detailed Description

RTC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

RtcTimeChangedMsg::RtcTimeChangedMsg ( )

RtcTimeChangedMsg::~RtcTimeChangedMsg ( ) [virtual]

Member Function Documentation

Message * RtcTimeChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & RtcTimeChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:46:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtStreamingBuffer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtStreamingBuffer Class Reference

Assignable data buffer with transfer-of-ownership semantics. More...

#include <Apoxi/Audio/RtStreaming/RtStreamingBuffer.hpp>

Public Member Functions

void | Clear ()
Resets size and 'end_of_data' flag.
UINT32 | GetCapacity () const
const UINT8 * | GetDataPtr () const
UINT8 * | GetDataPtr ()
UINT32 | GetSize () const
BOOLEAN | IsEndOfData () const
BOOLEAN | IsValid () const
RtStreamingBuffer & | operator= (RtStreamingBuffer &rhs)
Transfer-of-ownership.
void | Release ()
RtStreamingBuffer (UINT32 capacity=0)
Constructor / default constructor.
void | SetEndOfData ()
void | SetSize (UINT32 size)
~RtStreamingBuffer ()
Destructor.

Detailed Description

Assignable data buffer with transfer-of-ownership semantics.

Constructor & Destructor Documentation

RtStreamingBuffer::RtStreamingBuffer ( UINT32 capacity = 0 )

Constructor / default constructor.

RtStreamingBuffer::~RtStreamingBuffer ( )

Destructor.

Member Function Documentation

void RtStreamingBuffer::Clear ( ) [inline]

Resets size and 'end_of_data' flag.

UINT32 RtStreamingBuffer::GetCapacity ( ) const [inline]

const UINT8 * RtStreamingBuffer::GetDataPtr ( ) const [inline]

UINT8 * RtStreamingBuffer::GetDataPtr ( ) [inline]

UINT32 RtStreamingBuffer::GetSize ( ) const [inline]

BOOLEAN RtStreamingBuffer::IsEndOfData ( ) const [inline]

BOOLEAN RtStreamingBuffer::IsValid ( ) const [inline]

RtStreamingBuffer & RtStreamingBuffer::operator= ( RtStreamingBuffer & rhs )

Transfer-of-ownership.

void RtStreamingBuffer::Release ( )

void RtStreamingBuffer::SetEndOfData ( ) [inline]

void RtStreamingBuffer::SetSize ( UINT32 size ) [inline]

The documentation for this class was generated from the following files:
  • Audio/RtStreaming/RtStreamingBuffer.hpp
  • Audio/RtStreaming/RtStreamingBuffer.cpp
Generated on Wed Jan 25 01:46:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtStreamingConn Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtStreamingConn Class Reference

#include <Apoxi/Audio/RtStreaming/RtStreamingConn.hpp>

Inheritance diagram for RtStreamingConn:

[legend]
Collaboration diagram for RtStreamingConn:

[legend]

Public Types

enum | StopCause { StOnEndOfData, StOnCommand, StOnSrcError, StOnSnkError }
Indicates reason why streaming was stopped. More...

Public Member Functions

RtStreamingConn ()
Default constructor.
BOOLEAN | Start ()
Starts streaming data from source into sink.
BOOLEAN | Stop ()
Starts streaming data from source into sink.
virtual | ~RtStreamingConn ()
Destructor.

Protected Member Functions

void | Attach (RtStreamingSource &source)
void | Attach (RtStreamingSink &sink)
virtual void | OnStarted ()
Invoked when data streaming is actually started.
virtual void | OnStopped (StopCause cause)
Invoked when data streaming has been stopped.
virtual BOOLEAN | StopAction ()

Friends

class | RtStreamingEndPoint
class | RtStreamingSink
class | RtStreamingSource

Member Enumeration Documentation

enum RtStreamingConn::StopCause

Indicates reason why streaming was stopped.

Enumerator:
StOnEndOfData | Stopped after end of data was encountered.
StOnCommand | Stopped after Stop() was called.
StOnSrcError | Stopped after error was encountered.
StOnSnkError | Stopped after error was encountered.

Constructor & Destructor Documentation

RtStreamingConn::RtStreamingConn ( )

Default constructor.

RtStreamingConn::~RtStreamingConn ( ) [virtual]

Destructor.

Member Function Documentation

void RtStreamingConn::Attach ( RtStreamingSource & source ) [protected]

void RtStreamingConn::Attach ( RtStreamingSink & sink ) [protected]

virtual void RtStreamingConn::OnStarted ( ) [inline, protected, virtual]

Invoked when data streaming is actually started.

virtual void RtStreamingConn::OnStopped ( StopCause cause ) [inline, protected, virtual]

Invoked when data streaming has been stopped.

Parameters:
cause Identifies the event which has stopped the streaming operation.

BOOLEAN RtStreamingConn::Start ( )

Starts streaming data from source into sink.

This will start both the attached RtStreamingSource and RtStreamingSink instance. When data transmission actually begins, OnStarted() is called. At the end of the data stream OnStopped() is called, which

BOOLEAN RtStreamingConn::Stop ( )

Starts streaming data from source into sink.

This will start both the attached RtStreamingSource and RtStreamingSink instance. When data transmission actually begins, OnStarted() is called

BOOLEAN RtStreamingConn::StopAction ( ) [protected, virtual]

Friends And Related Function Documentation

friend class RtStreamingEndPoint [friend]

friend class RtStreamingSink [friend]

friend class RtStreamingSource [friend]

The documentation for this class was generated from the following files:
  • Audio/RtStreaming/RtStreamingConn.hpp
  • Audio/RtStreaming/RtStreamingConn.cpp
Generated on Wed Jan 25 01:46:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtStreamingEndPoint Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtStreamingEndPoint Class Reference

Base class for RtStreamingSource and RtStreamingSink. More...

#include <Apoxi/Audio/RtStreaming/RtStreamingEndPoint.hpp>

Inheritance diagram for RtStreamingEndPoint:

[legend]
Collaboration diagram for RtStreamingEndPoint:

[legend]

Public Member Functions

BOOLEAN | Close ()
Closes an endpoint and releases its association with a streaming connection.
BOOLEAN | Open (RtStreamingConn &conn)
Opens an endpoint and associates it with a streaming connection.
RtStreamingEndPoint ()
Default constructor.
virtual | ~RtStreamingEndPoint ()
Destructor.

Protected Member Functions

virtual void | Attach ()=0
virtual BOOLEAN | CloseAction ()=0
Implements the concrete Close() behaviour.
virtual void | Detach ()=0
RtStreamingConn & GetConn ()
void | NotifyError ()
Notifies that a streaming error has occured.
void | NotifyStoppedOnCause (RtStreamingConn::StopCause cause)
Notifies that streaming has stopped on cause.
virtual BOOLEAN | OpenAction ()=0
Implements the concrete Open() behaviour.
void | SetConn (RtStreamingConn &conn)

Data Structures

struct | BufferInfo
Contains parameters required for proper buffering. More...

Detailed Description

Base class for RtStreamingSource and RtStreamingSink.

Constructor & Destructor Documentation

RtStreamingEndPoint::RtStreamingEndPoint ( )

Default constructor.

RtStreamingEndPoint::~RtStreamingEndPoint ( ) [virtual]

Destructor.

Destruction of an endpoint still associated with a streaming connection will trigger an assertion.

Member Function Documentation

virtual void RtStreamingEndPoint::Attach ( ) [protected, pure virtual]

Implemented in RtStreamingSink, and RtStreamingSource.

BOOLEAN RtStreamingEndPoint::Close ( )

Closes an endpoint and releases its association with a streaming connection.

virtual BOOLEAN RtStreamingEndPoint::CloseAction ( ) [protected, pure virtual]

Implements the concrete Close() behaviour.

Implemented in DataSourceRtStreamingSource, and AtiAudioPlayerRtStreamingSink.

virtual void RtStreamingEndPoint::Detach ( ) [protected, pure virtual]

Implemented in RtStreamingSink, and RtStreamingSource.

RtStreamingConn& RtStreamingEndPoint::GetConn ( ) [inline, protected]

void RtStreamingEndPoint::NotifyError ( ) [protected]

Notifies that a streaming error has occured.

void RtStreamingEndPoint::NotifyStoppedOnCause ( RtStreamingConn::StopCause cause ) [protected]

Notifies that streaming has stopped on cause.

BOOLEAN RtStreamingEndPoint::Open ( RtStreamingConn & conn )

Opens an endpoint and associates it with a streaming connection.

Parameters:
conn Connection to associate with the current endpoint.
Calls OnOpen() to prepare the data source / sink. When OnOpen() returns 'TRUE' the endpoint is attached to the connection.

virtual BOOLEAN RtStreamingEndPoint::OpenAction ( ) [protected, pure virtual]

Implements the concrete Open() behaviour.

Implemented in DataSourceRtStreamingSource, and AtiAudioPlayerRtStreamingSink.

void RtStreamingEndPoint::SetConn ( RtStreamingConn & conn ) [inline, protected]

The documentation for this class was generated from the following files:
  • Audio/RtStreaming/RtStreamingEndPoint.hpp
  • Audio/RtStreaming/RtStreamingEndPoint.cpp
Generated on Wed Jan 25 01:46:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtStreamingEndPoint::BufferInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
RtStreamingEndPoint::BufferInfo

RtStreamingEndPoint::BufferInfo Struct Reference

Contains parameters required for proper buffering. More...

#include <Apoxi/Audio/RtStreaming/RtStreamingEndPoint.hpp>

Data Fields

UINT32 | buffer_size
Buffer size.
UINT32 | latency_ms
Time required to process one buffer.

Detailed Description

Contains parameters required for proper buffering.

Field Documentation

UINT32 RtStreamingEndPoint::BufferInfo::buffer_size

Buffer size.

UINT32 RtStreamingEndPoint::BufferInfo::latency_ms

Time required to process one buffer.

The documentation for this struct was generated from the following file:
  • Audio/RtStreaming/RtStreamingEndPoint.hpp
Generated on Wed Jan 25 01:46:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtStreamingSink Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtStreamingSink Class Reference

#include <Apoxi/Audio/RtStreaming/RtStreamingSink.hpp>

Inheritance diagram for RtStreamingSink:

[legend]
Collaboration diagram for RtStreamingSink:

[legend]

Public Member Functions

RtStreamingSink ()

Protected Member Functions

virtual void | Attach ()
virtual void | Detach ()
virtual void | GetBufferInfo (BufferInfo &buf_info) const =0
virtual BOOLEAN | StartAction ()=0
virtual BOOLEAN | StopAction (RtStreamingConn::StopCause cause)=0
virtual void | StopOnCause (RtStreamingConn::StopCause cause)=0
void | SwitchBuffer (RtStreamingBuffer &buffer)

Friends

class | RtStreamingConn

Constructor & Destructor Documentation

RtStreamingSink::RtStreamingSink ( )

Member Function Documentation

void RtStreamingSink::Attach ( ) [protected, virtual]

Implements RtStreamingEndPoint.

void RtStreamingSink::Detach ( ) [protected, virtual]

Implements RtStreamingEndPoint.

virtual void RtStreamingSink::GetBufferInfo ( BufferInfo & buf_info ) const [protected, pure virtual]

Implemented in AtiAudioPlayerRtStreamingSink.

virtual BOOLEAN RtStreamingSink::StartAction ( ) [protected, pure virtual]

Implemented in AtiAudioPlayerRtStreamingSink.

virtual BOOLEAN RtStreamingSink::StopAction ( RtStreamingConn::StopCause cause ) [protected, pure virtual]

Implemented in AtiAudioPlayerRtStreamingSink.

virtual void RtStreamingSink::StopOnCause ( RtStreamingConn::StopCause cause ) [protected, pure virtual]

Implemented in AtiAudioPlayerRtStreamingSink.

void RtStreamingSink::SwitchBuffer ( RtStreamingBuffer & buffer ) [protected]

Friends And Related Function Documentation

friend class RtStreamingConn [friend]

The documentation for this class was generated from the following files:
  • Audio/RtStreaming/RtStreamingSink.hpp
  • Audio/RtStreaming/RtStreamingSink.cpp
Generated on Wed Jan 25 01:46:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RtStreamingSource Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RtStreamingSource Class Reference

#include <Apoxi/Audio/RtStreaming/RtStreamingSource.hpp>

Inheritance diagram for RtStreamingSource:

[legend]
Collaboration diagram for RtStreamingSource:

[legend]

Public Member Functions

RtStreamingSource ()

Protected Member Functions

virtual void | Attach ()
virtual void | Detach ()
void | NotifyDataReady ()
Notifies data is available for streaming.
virtual void | OnBufferSwitch (RtStreamingBuffer &buffer)=0
Indicates buffer switch.
virtual BOOLEAN | StartAction (const BufferInfo &buf_info)=0
Implements the concrete Start() behaviour.
virtual BOOLEAN | StopAction ()=0
Implements the concrete Stop() behaviour.

Friends

class | RtStreamingConn

Constructor & Destructor Documentation

RtStreamingSource::RtStreamingSource ( )

Member Function Documentation

void RtStreamingSource::Attach ( ) [protected, virtual]

Implements RtStreamingEndPoint.

void RtStreamingSource::Detach ( ) [protected, virtual]

Implements RtStreamingEndPoint.

void RtStreamingSource::NotifyDataReady ( ) [protected]

Notifies data is available for streaming.

Must be called in response to StartAction().

virtual void RtStreamingSource::OnBufferSwitch ( RtStreamingBuffer & buffer ) [protected, pure virtual]

Indicates buffer switch.

Should be implemented as following:
Gain ownership of 'buffer' and refill it or queue it for asynchronous refilling in background. The assign a buffer containing data to 'buffer', giving ownership to the corresponding RtStreamingSink instance. The last buffer of the stream should have the IsEndOfData() flag set.

Implemented in DataSourceRtStreamingSource.

virtual BOOLEAN RtStreamingSource::StartAction ( const BufferInfo & buf_info ) [protected, pure virtual]

Implements the concrete Start() behaviour.

Implemented in DataSourceRtStreamingSource.

virtual BOOLEAN RtStreamingSource::StopAction ( ) [protected, pure virtual]

Implements the concrete Stop() behaviour.

When this method is invoked the implementation should stop producing data and set the end-of-data flag for the next buffer delivered within the call to OnBufferSwitch().

Implemented in DataSourceRtStreamingSource.

Friends And Related Function Documentation

friend class RtStreamingConn [friend]

The documentation for this class was generated from the following files:
  • Audio/RtStreaming/RtStreamingSource.hpp
  • Audio/RtStreaming/RtStreamingSource.cpp
Generated on Wed Jan 25 01:46:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: S_SvgFixPointTrans Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

S_SvgFixPointTrans Struct Reference
[Svg]

#include <Apoxi/AddOns/Svg/SvgFixPoint.hpp>

Data Fields

SvgFixPoint x_scale
SvgFixPoint x_shear
SvgFixPoint x_trans
SvgFixPoint y_scale
SvgFixPoint y_shear
SvgFixPoint y_trans

Field Documentation

SvgFixPoint S_SvgFixPointTrans::x_scale

SvgFixPoint S_SvgFixPointTrans::x_shear

SvgFixPoint S_SvgFixPointTrans::x_trans

SvgFixPoint S_SvgFixPointTrans::y_scale

SvgFixPoint S_SvgFixPointTrans::y_shear

SvgFixPoint S_SvgFixPointTrans::y_trans

The documentation for this struct was generated from the following file:
  • AddOns/Svg/SvgFixPoint.hpp
Generated on Wed Jan 25 01:46:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaLocationErrArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaLocationErrArg Class Reference

#include <Apoxi/AddOns/Lcs/StandAlone/SaArgs.hpp>

Inheritance diagram for SaLocationErrArg:

[legend]
Collaboration diagram for SaLocationErrArg:

[legend]

Public Types

enum | { ID = 4236 }

Public Member Functions

BYTE | GetErrCause () const
SaLocationErrArg ()
SaLocationErrArg (BYTE err_cause)
~SaLocationErrArg ()

Static Public Member Functions

static const SaLocationErrArg & | Cast (const StackMsgArgument &arg)

Friends

class | SaStackMsgArgsDestroyTableNode

Detailed Description

This argument is sent to the SA dispatcher to inform that MO-LR failed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SaLocationErrArg::SaLocationErrArg ( BYTE err_cause )

SaLocationErrArg::SaLocationErrArg ( )

SaLocationErrArg::~SaLocationErrArg ( )

Member Function Documentation

const SaLocationErrArg & SaLocationErrArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BYTE SaLocationErrArg::GetErrCause ( ) const [inline]

Friends And Related Function Documentation

friend class SaStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/StandAlone/SaArgs.hpp
  • AddOns/Lcs/StandAlone/SaArgs.cpp
Generated on Wed Jan 25 01:46:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaMolrResultArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaMolrResultArg Class Reference

#include <Apoxi/AddOns/Lcs/StandAlone/SaArgs.hpp>

Inheritance diagram for SaMolrResultArg:

[legend]
Collaboration diagram for SaMolrResultArg:

[legend]

Public Types

enum | { ID = 4235 }

Public Member Functions

const LocationEstimate & | GetLocationEstimate () const
BYTE | GetTiPd () const
SaMolrResultArg ()
SaMolrResultArg (BYTE ti_pd, const LocationEstimate &location_estimate)
~SaMolrResultArg ()

Static Public Member Functions

static const SaMolrResultArg & | Cast (const StackMsgArgument &arg)

Friends

class | SaStackMsgArgsDestroyTableNode

Detailed Description

This argument is sent to the SA dispatcher to deliver a MO-LR result

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SaMolrResultArg::SaMolrResultArg | ( | BYTE | ti_pd,
 |  | const LocationEstimate & | location_estimate
 | ) |

SaMolrResultArg::SaMolrResultArg ( )

SaMolrResultArg::~SaMolrResultArg ( )

Member Function Documentation

const SaMolrResultArg & SaMolrResultArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const LocationEstimate& SaMolrResultArg::GetLocationEstimate ( ) const [inline]

BYTE SaMolrResultArg::GetTiPd ( ) const [inline]

Friends And Related Function Documentation

friend class SaStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/StandAlone/SaArgs.hpp
  • AddOns/Lcs/StandAlone/SaArgs.cpp
Generated on Wed Jan 25 01:46:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaMsgProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaMsgProcessor Class Reference

#include <Apoxi/AddOns/Lcs/StandAlone/SaMsgProcessor.hpp>

Inheritance diagram for SaMsgProcessor:

[legend]
Collaboration diagram for SaMsgProcessor:

[legend]

Static Public Member Functions

static void ProcessMolrReq (TI_PD ti_pd, MolrType molr_type, LocationMethod location_method, const LcsQos &lcs_qos, const ClientId &client_id, const MlcNumber &mlc_number)
Forms and sends MN_SS_LCS_MOLR_REQ SDL signal to Lcs stack.

Detailed Description

This class converts APOXI messages to SDL signals & sends them out to the Lcs stack

Member Function Documentation

void SaMsgProcessor::ProcessMolrReq | ( | TI_PD | ti_pd,
 |  | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsQos & | lcs_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number
 | ) | [static]

Forms and sends MN_SS_LCS_MOLR_REQ SDL signal to Lcs stack.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/StandAlone/SaMsgProcessor.hpp
  • AddOns/Lcs/StandAlone/SaMsgProcessor.cpp
Generated on Wed Jan 25 01:47:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaProviderImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaProviderImpl Class Reference

#include <Apoxi/AddOns/Lcs/StandAlone/SaProviderImpl.hpp>

Inheritance diagram for SaProviderImpl:

[legend]
Collaboration diagram for SaProviderImpl:

[legend]

Public Member Functions

virtual void | Init ()
This method performs necessary initializations.
virtual void | OnTimeOut (LcsTimerType timer_type)
Invoked whenever the MO-LR timer expires.
virtual LcsErrorCode | TransferLocationReq (MolrType molr_type, LocationMethod location_method, const LcsMmiQos &lcs_mmi_qos, const ClientId &client_id, const MlcNumber &mlc_number, INT32 repeat_interval)
virtual | ~SaProviderImpl ()
Destructor.

Static Public Member Functions

static SaProviderImpl * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()
The only method to release the instance of this class.

Protected Member Functions

virtual BOOLEAN | OnAbortResponse (const StackMsgArgument &arg)
Receives the abort response message.
BOOLEAN | OnLocationError (const StackMsgArgument &arg)
Receives the MO-LR location error response.
BOOLEAN | OnLocationResponse (const StackMsgArgument &arg)
Receives the MO-LR location result response.
virtual BOOLEAN | OnMessage (const Message &msg)

Constructor & Destructor Documentation

SaProviderImpl::~SaProviderImpl ( ) [virtual]

Destructor.

Member Function Documentation

SaProviderImpl * SaProviderImpl::GetInstance ( ) [static]

The only method to get the instance of this class.

void SaProviderImpl::Init ( ) [virtual]

This method performs necessary initializations.

Reimplemented from LcsProviderImplBase.

BOOLEAN SaProviderImpl::OnAbortResponse ( const StackMsgArgument & arg ) [protected, virtual]

Receives the abort response message.

Reimplemented from LcsProviderImplBase.

BOOLEAN SaProviderImpl::OnLocationError ( const StackMsgArgument & arg ) [protected]

Receives the MO-LR location error response.

BOOLEAN SaProviderImpl::OnLocationResponse ( const StackMsgArgument & arg ) [protected]

Receives the MO-LR location result response.

BOOLEAN SaProviderImpl::OnMessage ( const Message & msg ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Reimplemented from StackMsgDispatcher.

void SaProviderImpl::OnTimeOut ( LcsTimerType timer_type ) [virtual]

Invoked whenever the MO-LR timer expires.

Implements LcsProviderImplBase.

void SaProviderImpl::ReleaseInstance ( ) [static]

The only method to release the instance of this class.

LcsErrorCode SaProviderImpl::TransferLocationReq | ( | MolrType | molr_type,
 |  | LocationMethod | location_method,
 |  | const LcsMmiQos & | lcs_mmi_qos,
 |  | const ClientId & | client_id,
 |  | const MlcNumber & | mlc_number,
 |  | INT32 | repeat_interval
 | ) | [virtual]

This method sends a request to the network to transfer the user's location to another LCS client.

Implements LcsProviderImplBase.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/StandAlone/SaProviderImpl.hpp
  • AddOns/Lcs/StandAlone/SaProviderImpl.cpp
Generated on Wed Jan 25 01:47:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaSignalMapTableNode Class Reference

#include <Apoxi/AddOns/Lcs/StandAlone/SaSignalMapTableNode.hpp>

Inheritance diagram for SaSignalMapTableNode:

[legend]
Collaboration diagram for SaSignalMapTableNode:

[legend]

Public Member Functions

~SaSignalMapTableNode ()
Destructor.

Static Public Member Functions

static SaSignalMapTableNode * | GetInstance ()
The only method to get the instance of this class.
static void | ReleaseInstance ()

Detailed Description

Receives the LCS-related SDL signals and invokes the corresponding callback The base class's constructor registers itself with the SignalMapTable. This code is based on a similar class, CommonSignalMapTableNode/

Constructor & Destructor Documentation

SaSignalMapTableNode::~SaSignalMapTableNode ( )

Destructor.

Member Function Documentation

SaSignalMapTableNode * SaSignalMapTableNode::GetInstance ( ) [static]

The only method to get the instance of this class.

void SaSignalMapTableNode::ReleaseInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/StandAlone/SaSignalMapTableNode.hpp
  • AddOns/Lcs/StandAlone/SaSignalMapTableNode.cpp
Generated on Wed Jan 25 01:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaSignalProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaSignalProcessor Class Reference

#include <Apoxi/AddOns/Lcs/StandAlone/SaSignalProcessor.hpp>

Static Public Member Functions

static void | PostLocationError (const ProcessPtr &process_ptr)
static void | PostMolrResult (const ProcessPtr &process_ptr)
Operations.

Detailed Description

This class generates (and posts) APOXI messages corresponding to the incoming LCS-related SDL signals

Member Function Documentation

void SaSignalProcessor::PostLocationError ( const ProcessPtr & process_ptr ) [static]

Processes MN_LCS_ERR_IND SDL signal, forms and posts SaLocationErrArg message to the dispatcher

void SaSignalProcessor::PostMolrResult ( const ProcessPtr & process_ptr ) [static]

Operations.

Processes MN_SS_LCS_MOLR_IND SDL signal, forms and posts LcsMolrResultArg message to the dispatcher

The documentation for this class was generated from the following files:
  • AddOns/Lcs/StandAlone/SaSignalProcessor.hpp
  • AddOns/Lcs/StandAlone/SaSignalProcessor.cpp
Generated on Wed Jan 25 01:47:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaStackMsgArgsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaStackMsgArgsDestroyTableNode Class Reference

#include <Apoxi/AddOns/Lcs/StandAlone/SaStackMsgArgs.hpp>

Inheritance diagram for SaStackMsgArgsDestroyTableNode:

[legend]
Collaboration diagram for SaStackMsgArgsDestroyTableNode:

[legend]

Static Public Member Functions

static SaStackMsgArgsDestroyTableNode * GetInstance ()

Member Function Documentation

SaStackMsgArgsDestroyTableNode * SaStackMsgArgsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/StandAlone/SaStackMsgArgs.hpp
  • AddOns/Lcs/StandAlone/SaStackMsgArgs.cpp
Generated on Wed Jan 25 01:47:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SatelliteInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SatelliteInfo Struct Reference

Contains information about a visible (& possibly tracked) satellite. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Public Member Functions

SatelliteInfo ()
Constructor.

Data Fields

INT16 | m_azimuth
Azimuthal angle in degrees.
INT16 | m_elevation
Elevation angle in degrees.
UINT32 | m_int_time
Signal integration time in msec.
UINT8 | m_sat_id
INT16 | m_sig_strength
Signal strength estimation in dBm.
INT16 | m_snr
Signal to Noise Ratio.
UINT8 | m_tracked

Detailed Description

Contains information about a visible (& possibly tracked) satellite.

Constructor & Destructor Documentation

SatelliteInfo::SatelliteInfo ( ) [inline]

Constructor.

Field Documentation

INT16 SatelliteInfo::m_azimuth

Azimuthal angle in degrees.

INT16 SatelliteInfo::m_elevation

Elevation angle in degrees.

UINT32 SatelliteInfo::m_int_time

Signal integration time in msec.

UINT8 SatelliteInfo::m_sat_id

INT16 SatelliteInfo::m_sig_strength

Signal strength estimation in dBm.

INT16 SatelliteInfo::m_snr

Signal to Noise Ratio.

UINT8 SatelliteInfo::m_tracked

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:47:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SatteliteGraphWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SatteliteGraphWin Class Reference

This window displays the position fix data. More...

#include <Applications/Lcs/SatteliteGraphWin.hpp>

Public Member Functions

const WCHAR * | GetTitleText () const
void | Init ()
SatteliteGraphWin ()
Constructor.
void | SetGraphData (SatelliteInfo sat_info[], UINT8 num_sats)
virtual | ~SatteliteGraphWin ()
Destructor.

Protected Member Functions

virtual void | OnPaint (const Rect &repaint_rect)

Data Structures

struct | SatelliteBar
Satellite info to be shown for each bar of the graph.

Detailed Description

This window displays the position fix data.

Constructor & Destructor Documentation

SatteliteGraphWin::SatteliteGraphWin ( )

Constructor.

SatteliteGraphWin::~SatteliteGraphWin ( ) [virtual]

Destructor.

Member Function Documentation

const WCHAR * SatteliteGraphWin::GetTitleText ( ) const

void SatteliteGraphWin::Init ( )

void SatteliteGraphWin::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

void SatteliteGraphWin::SetGraphData | ( | SatelliteInfo | sat_info[],
 |  | UINT8 | num_sats
 | ) |

The documentation for this class was generated from the following files:
  • Applications/Lcs/SatteliteGraphWin.hpp
  • Applications/Lcs/SatteliteGraphWin.cpp
Generated on Wed Jan 25 01:47:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SatteliteInfoWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SatteliteInfoWin Class Reference

This window displays the position fix data. More...

#include <Applications/Lcs/SatteliteInfoWin.hpp>

Inheritance diagram for SatteliteInfoWin:

[legend]
Collaboration diagram for SatteliteInfoWin:

[legend]

Public Member Functions

const WCHAR * | GetTitleText () const
void | Init ()
SatteliteInfoWin ()
Constructor.
void | SetSatelliteData (const SatelliteInfo &sat_info)
virtual | ~SatteliteInfoWin ()
Destructor.

Protected Member Functions

virtual void | OnLayoutClient ()

Detailed Description

This window displays the position fix data.

Constructor & Destructor Documentation

SatteliteInfoWin::SatteliteInfoWin ( )

Constructor.

SatteliteInfoWin::~SatteliteInfoWin ( ) [virtual]

Destructor.

Member Function Documentation

const WCHAR * SatteliteInfoWin::GetTitleText ( ) const

void SatteliteInfoWin::Init ( )

Reimplemented from ResultWinBase.

void SatteliteInfoWin::OnLayoutClient ( ) [protected, virtual]

void SatteliteInfoWin::SetSatelliteData ( const SatelliteInfo & sat_info )

The documentation for this class was generated from the following files:
  • Applications/Lcs/SatteliteInfoWin.hpp
  • Applications/Lcs/SatteliteInfoWin.cpp
Generated on Wed Jan 25 01:47:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaveEntryInPhonebookMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaveEntryInPhonebookMsg Class Reference

#include <Applications/AdvPhonebook/AdvPbMsgTypes.hpp>

Inheritance diagram for SaveEntryInPhonebookMsg:

[legend]
Collaboration diagram for SaveEntryInPhonebookMsg:

[legend]

Public Types

enum | { ID = 30005 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetEmail () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetName () const
const PhoneNumber & | GetPhoneNo () const
SaveEntryInPhonebookMsg (ExecutionContext *context, const WString &name, const PhoneNumber &phone_no, const WString &email)
void | SetEmail (const WString &email)
void | SetName (const WString &name)
void | SetPhoneNo (const PhoneNumber &phone_no)
virtual | ~SaveEntryInPhonebookMsg ()

Detailed Description

Phonebook

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SaveEntryInPhonebookMsg::SaveEntryInPhonebookMsg | ( | ExecutionContext * | context,
 |  | const WString & | name,
 |  | const PhoneNumber & | phone_no,
 |  | const WString & | email
 | ) |

SaveEntryInPhonebookMsg::~SaveEntryInPhonebookMsg ( ) [virtual]

Member Function Documentation

Message * SaveEntryInPhonebookMsg::Clone ( ) const [virtual]

Implements Message.

const WString& SaveEntryInPhonebookMsg::GetEmail ( ) const [inline]

const MsgMetaData & SaveEntryInPhonebookMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const WString& SaveEntryInPhonebookMsg::GetName ( ) const [inline]

const PhoneNumber& SaveEntryInPhonebookMsg::GetPhoneNo ( ) const [inline]

void SaveEntryInPhonebookMsg::SetEmail ( const WString & email ) [inline]

void SaveEntryInPhonebookMsg::SetName ( const WString & name ) [inline]

void SaveEntryInPhonebookMsg::SetPhoneNo ( const PhoneNumber & phone_no ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbMsgTypes.hpp
  • Applications/AdvPhonebook/AdvPbMsgTypes.cpp
Generated on Wed Jan 25 01:47:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SaveNoAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SaveNoAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp>

Inheritance diagram for SaveNoAction:

[legend]
Collaboration diagram for SaveNoAction:

[legend]

Public Member Functions

BOOLEAN | Execute ()
SaveNoAction (PbPhoneNumberPrompt *win)
virtual | ~SaveNoAction ()

Constructor & Destructor Documentation

SaveNoAction::SaveNoAction ( PbPhoneNumberPrompt * win )

SaveNoAction::~SaveNoAction ( ) [virtual]

Member Function Documentation

BOOLEAN SaveNoAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from Action.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbPhoneNumberPrompt.hpp
  • Applications/AdvPhonebook/PbPhoneNumberPrompt.cpp
Generated on Wed Jan 25 01:47:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SavingProgressWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SavingProgressWin Class Reference
[ImageBrowser]

#include <Applications/ImageBrowser/SavingProgressWin.hpp>

Inheritance diagram for SavingProgressWin:

[legend]
Collaboration diagram for SavingProgressWin:

[legend]

Public Member Functions

void | Init ()
SavingProgressWin ()
~SavingProgressWin ()

Protected Member Functions

virtual void | OnClose ()
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()

Constructor & Destructor Documentation

SavingProgressWin::SavingProgressWin ( )

SavingProgressWin::~SavingProgressWin ( )

Member Function Documentation

void SavingProgressWin::Init ( )

void SavingProgressWin::OnClose ( ) [protected, virtual]

Is called, if the window will get closed and represents an entry-point for cleaning up things. When the window has the focus child-controls and the window itself will lose the focus after OnClose has been executed.

Reimplemented from Window.

void SavingProgressWin::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Window.

BOOLEAN SavingProgressWin::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Window.

void SavingProgressWin::OnOpen ( ) [protected, virtual]

Is called, when the Window is opened and can be used for further initialization (Window::IsOpen() returns TRUE when it is invoked inside OnOpen). Control::OnGetFocus() is invoked before OnOpen, Control::OnLayoutClient() is invoked after OnOpen. Use Control::SetBlocked() if user-interaction should be forbidden e. g. when reading out a large provider in OnOpen.

See also:
Control::SetBlocked()

Reimplemented from Window.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/SavingProgressWin.hpp
  • Applications/ImageBrowser/SavingProgressWin.cpp
Generated on Wed Jan 25 01:47:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ScanlineAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ScanlineAccessor Class Reference
[Devices, Devices, Devices, Devices, Devices]

#include <Apoxi/Devices/BP30/VirtualDisplay.hpp>

Collaboration diagram for ScanlineAccessor:

[legend]

Public Member Functions

void | Draw (ColorValue color)
Draws the current pixel and advances the current-line-pointer to the next pixel.
void | Draw (UINT8 red, UINT8 green, UINT8 blue)
Draws the current pixel and advances the current-line-pointer to the next pixel.
void | Draw (ColorValue cv)
void | Draw (UINT8 red, UINT8 green, UINT8 blue)
Draws the current pixel and advances the current-line-pointer to the next pixel.
void | Draw (ColorValue cv)
void | Draw (UINT8 red, UINT8 green, UINT8 blue)
Draws the current pixel and advances the current-line-pointer to the next pixel.
void | Draw (ColorValue cv)
void | Draw (UINT8 red, UINT8 green, UINT8 blue)
Draws the current pixel and advances the current-line-pointer to the next pixel.
void | Draw (ColorValue cv)
void | Draw (UINT8 red, UINT8 green, UINT8 blue)
Draws the current pixel and advances the current-line-pointer to the next pixel.
BOOLEAN | HasNext ()
BOOLEAN | HasNext ()
BOOLEAN | HasNext ()
BOOLEAN | HasNext ()
BOOLEAN | HasNext ()
void | Next ()
void | Next ()
void | Next ()
void | Next ()
void | Next ()
ScanlineAccessor (VirtualDisplay *display, XYDIM x, XYDIM y, XYDIM width)
ScanlineAccessor (VirtualDisplay *display, XYDIM x, XYDIM y, XYDIM width)
ScanlineAccessor (VirtualDisplay *display, XYDIM x, XYDIM y, XYDIM width)
ScanlineAccessor (VirtualDisplay *display, XYDIM x, XYDIM y, XYDIM width)
ScanlineAccessor (VirtualDisplay *display, XYDIM x, XYDIM y, XYDIM width)

Detailed Description

The ScanlineAccessor is used to draw a scanline on a display in a fast way by setting the RGB-values for each pixel.

Constructor & Destructor Documentation

ScanlineAccessor::ScanlineAccessor | ( | VirtualDisplay * | display,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | width
 | ) | [inline]

Parameters:
display
x
y
width is later used to determine if there are any pixels left to draw in this scanline

ScanlineAccessor::ScanlineAccessor | ( | VirtualDisplay * | display,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | width
 | ) | [inline]

Parameters:
display
x
y
width is later used to determine if there are any pixels left to draw in this scanline

ScanlineAccessor::ScanlineAccessor | ( | VirtualDisplay * | display,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | width
 | ) | [inline]

Parameters:
display
x
y
width is later used to determine if there are any pixels left to draw in this scanline

ScanlineAccessor::ScanlineAccessor | ( | VirtualDisplay * | display,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | width
 | ) | [inline]

Parameters:
display
x
y
width is later used to determine if there are any pixels left to draw in this scanline

ScanlineAccessor::ScanlineAccessor | ( | VirtualDisplay * | display,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | XYDIM | width
 | ) | [inline]

Parameters:
display
x
y
width is later used to determine if there are any pixels left to draw in this scanline

Member Function Documentation

void ScanlineAccessor::Draw ( ColorValue color ) [inline]

Draws the current pixel and advances the current-line-pointer to the next pixel.

void ScanlineAccessor::Draw | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue
 | ) | [inline]

Draws the current pixel and advances the current-line-pointer to the next pixel.

void ScanlineAccessor::Draw ( ColorValue cv ) [inline]

void ScanlineAccessor::Draw | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue
 | ) | [inline]

Draws the current pixel and advances the current-line-pointer to the next pixel.

void ScanlineAccessor::Draw ( ColorValue cv ) [inline]

void ScanlineAccessor::Draw | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue
 | ) | [inline]

Draws the current pixel and advances the current-line-pointer to the next pixel.

void ScanlineAccessor::Draw ( ColorValue cv ) [inline]

void ScanlineAccessor::Draw | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue
 | ) | [inline]

Draws the current pixel and advances the current-line-pointer to the next pixel.

void ScanlineAccessor::Draw ( ColorValue cv ) [inline]

void ScanlineAccessor::Draw | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue
 | ) | [inline]

Draws the current pixel and advances the current-line-pointer to the next pixel.

BOOLEAN ScanlineAccessor::HasNext ( ) [inline]

Returns:
TRUE if there are more pixels to be drawn in this scanline

BOOLEAN ScanlineAccessor::HasNext ( ) [inline]

Returns:
TRUE if there are more pixels to be drawn in this scanline

BOOLEAN ScanlineAccessor::HasNext ( ) [inline]

Returns:
TRUE if there are more pixels to be drawn in this scanline

BOOLEAN ScanlineAccessor::HasNext ( ) [inline]

Returns:
TRUE if there are more pixels to be drawn in this scanline

BOOLEAN ScanlineAccessor::HasNext ( ) [inline]

Returns:
TRUE if there are more pixels to be drawn in this scanline

void ScanlineAccessor::Next ( ) [inline]

Advances the internal data by one. Use this if you need to skip a call to Draw (e.g. because of a transparent pixel). Does the the same thing as Draw without actually drawing.

void ScanlineAccessor::Next ( ) [inline]

Advances the internal data by one. Use this if you need to skip a call to Draw (e.g. because of a transparent pixel). Does the the same thing as Draw without actually drawing.

void ScanlineAccessor::Next ( ) [inline]

Advances the internal data by one. Use this if you need to skip a call to Draw (e.g. because of a transparent pixel). Does the the same thing as Draw without actually drawing.

void ScanlineAccessor::Next ( ) [inline]

Advances the internal data by one. Use this if you need to skip a call to Draw (e.g. because of a transparent pixel). Does the the same thing as Draw without actually drawing.

void ScanlineAccessor::Next ( ) [inline]

Advances the internal data by one. Use this if you need to skip a call to Draw (e.g. because of a transparent pixel). Does the the same thing as Draw without actually drawing.

The documentation for this class was generated from the following files:
  • Devices/BP30/VirtualDisplay.hpp
  • Devices/MPE/VirtualDisplay.hpp
  • Devices/MPEU/VirtualDisplay.hpp
  • Devices/SGold/VirtualDisplay.hpp
  • Devices/Win32/VirtualDisplay.hpp
Generated on Wed Jan 25 01:47:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Scheduler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Scheduler Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/Nuc32/Scheduler.hpp>

Inheritance diagram for Scheduler:

[legend]
Collaboration diagram for Scheduler:

[legend]

Public Types

typedef AbstractScheduler | Base
typedef AbstractScheduler | Base

Public Member Functions

virtual AbstractAppContext * | CreateAppContext (Application *app)
virtual AbstractAppContext * | CreateAppContext (Application *app)
virtual void | Reschedule ()
Takes away control from the currently active Application, and lets the next Application resume.
virtual void | Reschedule ()
Scheduler (AppContainer *cont)
Scheduler (AppContainer *cont)
virtual void | SendMsg (const Application *app, Message &msg)
virtual void | SendMsg (const Application *app, Message &msg)
virtual void | StartUp ()
virtual void | StartUp ()
virtual void | Wait (const Application *app, const Condition &cond)
virtual void | Wait (const Application *app, const Condition &cond)
virtual | ~Scheduler ()
Destroyes the Scheduler.
virtual | ~Scheduler ()
Destroyes the Scheduler.

Detailed Description

This Scheduler is the Nucleus Scheduler implementation. The Scheduler always runs in the context of the RTOS task. Scheduler functions in turn calls AppContext functions to switch the context. Scheduler's setjmp and AppContext's longjmp changes the context from Scheduler to AppContext. AppContext's setjmp and Scheduler's longjmp changes the context from AppContext to Scheduler.

Member Typedef Documentation

typedef AbstractScheduler Scheduler::Base

typedef AbstractScheduler Scheduler::Base

Constructor & Destructor Documentation

Scheduler::Scheduler ( AppContainer * cont )

Creates the Scheduler

Parameters:
cont the AppContainer that runs the Scheduler.

Scheduler::~Scheduler ( ) [virtual]

Destroyes the Scheduler.

Scheduler::Scheduler ( AppContainer * cont )

Creates the Scheduler

Parameters:
cont the AppContainer that runs the Scheduler.

virtual Scheduler::~Scheduler ( ) [virtual]

Destroyes the Scheduler.

Member Function Documentation

virtual AbstractAppContext* Scheduler::CreateAppContext ( Application * app ) [virtual]

Creates a AppContext for the Application and adds it to the list of AppContexts.

Parameters:
app the Application to be added

Implements AbstractScheduler.

AbstractAppContext * Scheduler::CreateAppContext ( Application * app ) [virtual]

Creates a Nucleus AppContext for the Application and adds it to the list of AppContexts.

Parameters:
app the Application to be added

Implements AbstractScheduler.

virtual void Scheduler::Reschedule ( ) [virtual]

Takes away control from the currently active Application, and lets the next Application resume.

Implements AbstractScheduler.

void Scheduler::Reschedule ( ) [virtual]

Takes away control from the currently active Application to Scheduler's context. Scheduler lets the next Application resume.

Implements AbstractScheduler.

virtual void Scheduler::SendMsg | ( | const Application * | app,
 |  | Message & | msg
 | ) | [virtual]

Wakes up and sends a message to the Application.

Parameters:
app | the receiving Application
msg | the Message to be sent

Implements AbstractScheduler.

void Scheduler::SendMsg | ( | const Application * | app,
 |  | Message & | msg
 | ) | [virtual]

Wakes up and gets the AppContext for the receiving Application. Saves the Scheduler's context and does a context switch to the AppContext's SendMsg, which sends a message to the Application.

Parameters:
app | the receiving Application
msg | the Message to be sent

Implements AbstractScheduler.

virtual void Scheduler::StartUp ( ) [virtual]

Starts all AppContexts, which are then ready to receive messages.

Implements AbstractScheduler.

void Scheduler::StartUp ( ) [virtual]

Traverses the list of AppContexts and starts them one by one. The AppContexts are then ready to receive messages.

Implements AbstractScheduler.

virtual void Scheduler::Wait | ( | const Application * | app,
 |  | const Condition & | cond
 | ) | [virtual]

Takes away control from the Application until the next Message arrives. Will return once the Condition becomes TRUE.

Parameters:
app | the Application that will wait for the Condition
cond | the Condition to wait for

Implements AbstractScheduler.

void Scheduler::Wait | ( | const Application * | app,
 |  | const Condition & | cond
 | ) | [virtual]

Takes away control from the AppContext of the receiving Application, until the next Message arrives. Will return once the Condition becomes TRUE.

Parameters:
app | the Application that will wait for the Condition
cond | the Condition to wait for

Implements AbstractScheduler.

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/Scheduler.hpp
  • Kernel/Os/Win32/Scheduler.hpp
  • Kernel/Os/Nuc32/Scheduler.cpp
  • Kernel/Os/Win32/Scheduler.cpp
Generated on Wed Jan 25 01:47:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ScicosCodecIfLib Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ScicosCodecIfLib Class Reference
[Config]

#include <Apoxi/Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.hpp>

Friends

class CodecConfig

Detailed Description

SciCOS 3020 Video Decoder & Encoder Interface Library class.

Friends And Related Function Documentation

friend class CodecConfig [friend]

The documentation for this class was generated from the following files:
  • Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.hpp
  • Devices/SGold/Companion/Scicos3020/ScicosCodecIfLib.cpp
Generated on Wed Jan 25 01:47:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ScicosMpeg4VideoDecoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ScicosMpeg4VideoDecoder Class Reference
[Devices]

#include <Apoxi/Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.hpp>

Inheritance diagram for ScicosMpeg4VideoDecoder:

[legend]
Collaboration diagram for ScicosMpeg4VideoDecoder:

[legend]

Public Member Functions

virtual CodecManager::ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual CodecManager::ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual CodecManager::ResultType | DecodePacket (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)
virtual CodecManager::ResultType | Flush ()
virtual CodecManager::ResultType | GetCapabilities (CodecManager::VideoCodecCapabilities &caps)
virtual CodecManager::ResultType | GetNumberOfInitialDecodeOperations (UINT8 &operations)
CodecManager::ResultType | GetOutputFrame (const UINT8 HUGE *dec_out_buf, UINT8 HUGE *dest_buf, UINT32 &dest_buf_len)
virtual CodecManager::ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | RegisterCallbackFunctions (UINT32 context, CbFrameDecoded cb_frame_decoded, CbInBufferFree cb_in_buf_free)
virtual CodecManager::ResultType | ReleaseOutputBuffer (const UINT8 HUGE *out_buf)
CodecManager::ResultType | SetOutputFrame (const UINT8 HUGE *src_buf, UINT32 src_buf_len, UINT8 HUGE *&dec_out_buf)
virtual CodecManager::ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | SkipFrames (const UINT8 HUGE **out_buf_array, UINT8 out_buf_count=1)
virtual | ~ScicosMpeg4VideoDecoder ()

Friends

class | ScicosCodecIfLib

Data Structures

struct | StateFlags

Detailed Description

MPEG-4 Simple Profile and H.263 Baseline video decoder interface for sciCOS 3020.

Constructor & Destructor Documentation

ScicosMpeg4VideoDecoder::~ScicosMpeg4VideoDecoder ( ) [virtual]

Destructor.

Member Function Documentation

CodecManager::ResultType ScicosMpeg4VideoDecoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

Allocates a number of output buffers that are used to store the decoded (and post-processed) frames.

Parameters:
out_buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e. the ScicosMpeg4VideoDecoder can adapt the number passed in by the caller if necessary.
out_buf_len | Desired length (in bytes) of one output buffer (all buffers have the same length). If set to 0, the default length will be used. On return, the actual buffer length, i.e. the ScicosMpeg4VideoDecoder can adapt the length passed in by the caller if necessary.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

Implements VideoDecoder.

CodecManager::ResultType ScicosMpeg4VideoDecoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

Decodes a video frame. The input buffer contains always one complete frame. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbVideoFrameDecoded will be invoked.

Parameters:
in_buf | Pointer to the video input buffer (containing the encoded frame).
in_buf_len | Length of the video input buffer (in bytes).
flags | Bit flags as defined by the FlagsType enum indicating if it is the last frame in the stream/file.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

CodecManager::ResultType ScicosMpeg4VideoDecoder::DecodePacket | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [virtual]

Decodes a video packet. Contains one or more packet but the packets are always complete. The actual decoding is done asynchronously, i.e., when a complete frame has been decoded, the callback function CbVideoFrameDecoded will be invoked.

Parameters:
in_buf | Pointer to the video input buffer (containing the encoded packets)
in_buf_len | Length of the video input buffer (in bytes).
flags | Bit flags as defined by the FlagsType enum. It indicates if it is the last packet in the frame and if it is the last frame.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

Implements VideoDecoder.

CodecManager::ResultType ScicosMpeg4VideoDecoder::Flush ( ) [virtual]

Cleares all output and input buffers of the decoder. The currently active decoding process will complete as usual. After this the decoder deletes all pending DecodeFrame() requests and cleares all internal buffers of the decoder. The input buffers already given to the decoder will be released by the decoder at the capture buffer manager.

Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoDecoder::GetCapabilities ( CodecManager::VideoCodecCapabilities & caps ) [virtual]

This function is used to retrieve the capabilities of the video decoder (VideoDecoder sub-class).

Parameters:
caps On return, it contains the capabilities. Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the VideoDecoder sub-class.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoDecoder::GetNumberOfInitialDecodeOperations ( UINT8 & operations ) [virtual]

Gets the number of recommended (preferred) initial DecodeFrame calls for stuffing the decoder.

Parameters:
operations On return, the recommended number.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoDecoder::GetOutputFrame | ( | const UINT8 HUGE * | dec_out_buf,
 |  | UINT8 HUGE * | dest_buf,
 |  | UINT32 & | dest_buf_len
 | ) |

This function is provided for test purposes. It is used to get (copy from) a video decoder output frame, i.e., the content of the output buffer of the decoder is copied into a given destination video frame buffer. The caller has to provide this buffer and ensure that the length of it is sufficient for the video frame, i.e., in general, it should be equal to the length of the decoder output buffer.

Parameters:
dec_out_buf | Pointer to the decoder output buffer from which the video frame content is taken.
dest_buf | Pointer to a buffer where the video frame content shall be copied to.
dest_buf_len | Length of the dest_buf (in bytes). On return it contains the actual length of the filled buffer.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoDecoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

This function retrieves the values of specified parameters in the video decoder.

Parameters:
types_array | Array of the parameter types that specify the parameters to be retrieved.
values_array | On return, array of the retrieved parameter values. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type. The caller has to allocate memory for this array before invoking of this function. The existing elements of the array are then filled with the corresponding parameter values by the video decoder.
array_count | Length (number of elements) of the types_array and types_array i.e., both arrays have always the same length.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoDecoder::RegisterCallbackFunctions | ( | UINT32 | context,
 |  | CbFrameDecoded | cb_frame_decoded,
 |  | CbInBufferFree | cb_in_buf_free
 | ) | [virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the ScicosMpeg4VideoDecoder. This context is then passed as an argument of all callback functions invoked by the ScicosMpeg4VideoDecoder.
cb_frame_decoded | A pointer to a callback function that is invoked by the ScicosMpeg4VideoDecoder when a frame has been decoded (and post-processed) and is ready for rendering.
cb_in_buf_free | A pointer to a callback function that is called by the ScicosMpeg4VideoDecoder when a video input buffer is not used anymore by the decoder (as the data has been already decoded) and can be re-used.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoDecoder::ReleaseOutputBuffer ( const UINT8 HUGE * out_buf ) [virtual]

It releases the output buffer of the decoder and, thus, allows the decoder to fill it with new decoded (and post-processed) frame if available. In general, this function is a notification that is called when the corresponding frame has already been rendered and the renderer (Display device) does not need the content of the buffer any more.

Parameters:
out_buf Pointer to the video output buffer that shall be released.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.
See also:
SkipFrame

Implements VideoDecoder.

CodecManager::ResultType ScicosMpeg4VideoDecoder::SetOutputFrame | ( | const UINT8 HUGE * | src_buf,
 |  | UINT32 | src_buf_len,
 |  | UINT8 HUGE *& | dec_out_buf
 | ) |

This function is provided for test purposes. It is used to set (copy to) a video decoder output frame, i.e., the content of a given source buffer is copied into the output buffer of the decoder.

Parameters:
src_buf | Pointer to the source buffer from which the video frame content is taken.
src_buf_len | Length of the src_buf (in bytes).
dec_out_buf | On return, the pointer to the decoder's output buffer where the video frame content has been copied to.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoDecoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

Sets dynamically one or more decoder parameters.

Parameters:
types_array | Array of the parameter types that specify the parameters to be changed. The corresponding values to be set are delivered in values_array.
values_array | Array of the values to which the corresponding parameters have to be set. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type.
array_count | Length (number of elements) of the types_array and values_array, i.e., both arrays have always the same length.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoDecoder::SkipFrames | ( | const UINT8 HUGE ** | out_buf_array,
 |  | UINT8 | out_buf_count = 1
 | ) | [virtual]

Skip one or more frames, i.e. it releases the specified output buffers of the decoder and, thus, allows the decoder to fill it with new decoded (and post-processed) frames if available. In general, this function is called when the frames shall not been rendered at all.

Parameters:
out_buf_array | Array of pointers to the video decoder output buffers that shall be released.
out_buf_count | Number of elements in out_buf_array, i.e., number of buffers to be released.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.
See also:
ReleaseOutputBuffer

Friends And Related Function Documentation

friend class ScicosCodecIfLib [friend]

The documentation for this class was generated from the following files:
  • Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.hpp
  • Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoDecoder.cpp
Generated on Wed Jan 25 01:47:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ScicosMpeg4VideoEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ScicosMpeg4VideoEncoder Class Reference
[Devices]

#include <Apoxi/Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.hpp>

Inheritance diagram for ScicosMpeg4VideoEncoder:

[legend]
Collaboration diagram for ScicosMpeg4VideoEncoder:

[legend]

Public Member Functions

virtual CodecManager::ResultType | AllocateOutputBuffers (UINT8 HUGE **&out_buf_array, UINT8 &out_buf_count, UINT32 &out_buf_len)
virtual CodecManager::ResultType | EncodeFrame (UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT32 time_stamp, UINT32 key_frame_ind, UINT8 HUGE *out_buf)
virtual CodecManager::ResultType | GetCapabilities (CodecManager::VideoCodecCapabilities &caps)
virtual CodecManager::ResultType | GetConfigStream (UINT8 HUGE *out_buf, UINT32 &out_buf_len)
virtual CodecManager::ResultType | GetParameters (const ParameterType *types_array, UINT32 *values_array, UINT8 array_count)
virtual CodecManager::ResultType | RegisterCallbackFunctions (UINT32 context, CbFrameEncoded cb_frame_encoded)
virtual CodecManager::ResultType | SetParameters (const ParameterType *types_array, const UINT32 *values_array, UINT8 array_count)
virtual | ~ScicosMpeg4VideoEncoder ()

Friends

class | ScicosCodecIfLib

Data Structures

struct | StateFlags

Detailed Description

MPEG-4 Simple Profile and H.263 Baseline video encoder interface for the sciCOS 3020.

Constructor & Destructor Documentation

ScicosMpeg4VideoEncoder::~ScicosMpeg4VideoEncoder ( ) [virtual]

Destructor

Member Function Documentation

CodecManager::ResultType ScicosMpeg4VideoEncoder::AllocateOutputBuffers | ( | UINT8 HUGE **& | out_buf_array,
 |  | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

Allocates a number of output buffers that are used to store the encoded frames.

Parameters:
out_buf_array | On return, a pointer to the output buffer array (the elements of the array are pointers to the actual buffers).
out_buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e. the ScicosMpeg4VideoEncoder adapt the number passed in by the caller if necessary.
out_buf_len | Desired length (in bytes) of one output buffer (all buffers have the same length). If set to 0, the default length will be used. On return, the actual buffer length, i.e. the ScicosMpeg4VideoEncoder adapt the length passed in by the caller if necessary.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoEncoder::EncodeFrame | ( | UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT32 | time_stamp,
 |  | UINT32 | key_frame_ind,
 |  | UINT8 HUGE * | out_buf
 | ) | [virtual]

Encodes a video frame. This is done asynchronously, i.e., when the frame has been encoded, the callback function CbVideoFrameEncoded will be invoked.

Parameters:
in_buf | Points to input raw video data.
in_buf_len | Length of the input raw video data in_buf (in bytes).
time_stamp | Number of primary time units elapsed since the start of encoding process. Time stamp value should be integral multiple of ScicosMpeg4VideoEncoderParameters::timer_resolution/ScicosMpeg4VideoEncoderParametersframe_rate (refer the details on ScicosMpeg4VideoEncoderParameters).
key_frame_ind | Flag indicating the insertion of I-frame. Possible values for this flag are: TRUE, FALSE. TRUE inserts the I-frame. Default value should be FALSE.
out_buf | Buffer in which the encoded stream needs to be written. Enough buffer to hold the encoded stream corresponding to one frame of data should be given. The maximum frame size (i.e. encoding bytes) can be obtained by using GetParameter function.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameEncoded

CodecManager::ResultType ScicosMpeg4VideoEncoder::GetCapabilities ( CodecManager::VideoCodecCapabilities & caps ) [virtual]

This function is used to retrieve the capabilities of the video encoder (VideoEncoder sub-class).

Parameters:
caps On return, it contains the capabilities. Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the VideoDecoder sub-class.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoEncoder::GetConfigStream | ( | UINT8 HUGE * | out_buf,
 |  | UINT32 & | out_buf_len
 | ) | [virtual]

This function is used to get (write) the configuration stream (header) into the specified buffer. The caller has to provide this buffer and ensure that the length of it is sufficient for the config stream.

Parameters:
out_buf | Pointer to a buffer where the config stream shall be written to.
out_buf_len | Length of the out_buf (in bytes). On return contains the actual length of the filled buffer.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoEncoder::GetParameters | ( | const ParameterType * | types_array,
 |  | UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

This function retrieves the values of specified parameters in the video encoder.

Parameters:
types_array | Array of the parameter types that specify the parameters to be retrieved.
values_array | On return, array of the retrieved parameter values. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type. The caller has to allocate memory for this array before invoking of this function. The existing elements of the array are then filled with the corresponding parameter values by the video encoder.
array_count | Length (number of elements) of the types_array and types_array i.e., both arrays have always the same length.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoEncoder::RegisterCallbackFunctions | ( | UINT32 | context,
 |  | CbFrameEncoded | cb_frame_encoded
 | ) | [virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the ScicosMpeg4VideoEncoder. This context is then passed as an argument of all callback functions invoked by the ScicosMpeg4VideoEncoder.
cb_frame_encoded | A pointer to a callback function that is invoked by the ScicosMpeg4VideoEncoder each time when a frame has been encoded.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

CodecManager::ResultType ScicosMpeg4VideoEncoder::SetParameters | ( | const ParameterType * | types_array,
 |  | const UINT32 * | values_array,
 |  | UINT8 | array_count
 | ) | [virtual]

Sets dynamically one or more encoder parameters.

Parameters:
types_array | Array of the parameter types that specify the parameters to be changed. The corresponding values to be set are delivered in values_array.
values_array | Array of the values to which the corresponding parameters have to be set. The first element in this array is of type that is specified by the first element of types_array and so on. In general, the values themselves have to be casted to the actual parameter type.
array_count | Length (number of elements) of the types_array and values_array, i.e., both arrays have always the same length.
Returns:
CodecManager::Success if the operation was successful. Otherwise, an appropriate error code.

Friends And Related Function Documentation

friend class ScicosCodecIfLib [friend]

The documentation for this class was generated from the following files:
  • Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.hpp
  • Devices/SGold/Companion/Scicos3020/ScicosMpeg4VideoEncoder.cpp
Generated on Wed Jan 25 01:47:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SearchBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SearchBox Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbBaseWin.hpp>

Inheritance diagram for SearchBox:

[legend]
Collaboration diagram for SearchBox:

[legend]

Public Member Functions

void | Init (Window *win)
virtual void | MoveCaret (INT steps)
SearchBox ()
virtual | ~SearchBox ()

Constructor & Destructor Documentation

SearchBox::SearchBox ( )

SearchBox::~SearchBox ( ) [virtual]

Member Function Documentation

void SearchBox::Init ( Window * win )

void SearchBox::MoveCaret ( INT steps ) [virtual]

See also:
AbstractEditor::MoveCaret()

Reimplemented from AbstractLineEditor.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbBaseWin.hpp
  • Applications/AdvPhonebook/PbBaseWin.cpp
Generated on Wed Jan 25 01:47:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SecLockCode Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SecLockCode Struct Reference

#include <Apoxi/Apc/LockTypes.hpp>

Data Fields

UINT8 val [17]

Field Documentation

UINT8 SecLockCode::val[17]

The documentation for this struct was generated from the following file:
  • Apc/LockTypes.hpp
Generated on Wed Jan 25 01:47:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SecLockCommand Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SecLockCommand Struct Reference

#include <Apoxi/Apc/LockTypes.hpp>

Collaboration diagram for SecLockCommand:

[legend]

Data Fields

SecLockAction action
SecLockCode newpwd
SecLockCode oldpwd
SecLockType type

Field Documentation

SecLockAction SecLockCommand::action

SecLockCode SecLockCommand::newpwd

SecLockCode SecLockCommand::oldpwd

SecLockType SecLockCommand::type

The documentation for this struct was generated from the following file:
  • Apc/LockTypes.hpp
Generated on Wed Jan 25 01:47:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SecLockDescriptor Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SecLockDescriptor Struct Reference

#include <Apoxi/Apc/LockTypes.hpp>

Data Fields

UINT8 | lock_dcp_sup
UINT8 | lock_order
SecLockResult lock_result
INT | lock_retrial_count
UINT8 | lock_retrial_method
SecLockStatus lock_status
UINT32 | lock_time
SecLockType lock_type

Field Documentation

UINT8 SecLockDescriptor::lock_dcp_sup

UINT8 SecLockDescriptor::lock_order

SecLockResult SecLockDescriptor::lock_result

INT SecLockDescriptor::lock_retrial_count

UINT8 SecLockDescriptor::lock_retrial_method

SecLockStatus SecLockDescriptor::lock_status

UINT32 SecLockDescriptor::lock_time

SecLockType SecLockDescriptor::lock_type

The documentation for this struct was generated from the following file:
  • Apc/LockTypes.hpp
Generated on Wed Jan 25 01:47:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SecLocks Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SecLocks Struct Reference

#include <Apoxi/Apc/LockTypes.hpp>

Collaboration diagram for SecLocks:

[legend]

Data Fields

SecLockDescriptor val [c_max_no_sec_locks]

Field Documentation

SecLockDescriptor SecLocks::val[c_max_no_sec_locks]

The documentation for this struct was generated from the following file:
  • Apc/LockTypes.hpp
Generated on Wed Jan 25 01:47:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SecLockStates Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SecLockStates Struct Reference

#include <Apoxi/Apc/LockTypes.hpp>

Collaboration diagram for SecLockStates:

[legend]

Data Fields

SecLockCause lock_cause
SecLockResult lock_result
SecLocks locks
SecMmiConfigData mmi_configuration
INT | no_locks
UINT8 | no_rfiles
INT | tracediag

Field Documentation

SecLockCause SecLockStates::lock_cause

SecLockResult SecLockStates::lock_result

SecLocks SecLockStates::locks

SecMmiConfigData SecLockStates::mmi_configuration

INT SecLockStates::no_locks

UINT8 SecLockStates::no_rfiles

INT SecLockStates::tracediag

The documentation for this struct was generated from the following file:
  • Apc/LockTypes.hpp
Generated on Wed Jan 25 01:47:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SecMmiConfigData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SecMmiConfigData Struct Reference

#include <Apoxi/Apc/LockTypes.hpp>

Data Fields

UINT8 val [2]

Field Documentation

UINT8 SecMmiConfigData::val[2]

The documentation for this struct was generated from the following file:
  • Apc/LockTypes.hpp
Generated on Wed Jan 25 01:47:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SelectedLineRetriever Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SelectedLineRetriever Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Public Member Functions

virtual LineSelector GetSelectedLine () const =0

Member Function Documentation

virtual LineSelector SelectedLineRetriever::GetSelectedLine ( ) const [pure virtual]

The documentation for this class was generated from the following file:
  • Asc/SupplementaryServiceAction.hpp
Generated on Wed Jan 25 01:47:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SelectionBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SelectionBox Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/T9/SelectionBox.hpp>

Inheritance diagram for SelectionBox:

[legend]
Collaboration diagram for SelectionBox:

[legend]

Public Types

typedef DrawableObject | Base

Public Member Functions

virtual XYDIM | GetDefaultHeight () const
INT | GetSelectedIndex () const
Get index of chinese character list.
const WCHAR * | GetText () const
Get one line of chinese character.
void | Init (Control *control)
SelectionBox (Control *control)
SelectionBox ()
void | SetSelectedIndex (INT selected_idx)
Set index of chinese character list.
void | SetText (const WCHAR *text)
Set one line of chinese character to text.
virtual | ~SelectionBox ()

Member Typedef Documentation

typedef DrawableObject SelectionBox::Base

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

SelectionBox::SelectionBox ( )

SelectionBox::SelectionBox ( Control * control )

SelectionBox::~SelectionBox ( ) [virtual]

Member Function Documentation

XYDIM SelectionBox::GetDefaultHeight ( ) const [virtual]

See also:
Component::GetDefaultHeight

Reimplemented from Component.

INT SelectionBox::GetSelectedIndex ( ) const [inline]

Get index of chinese character list.

const WCHAR* SelectionBox::GetText ( ) const [inline]

Get one line of chinese character.

void SelectionBox::Init ( Control * control )

void SelectionBox::SetSelectedIndex ( INT selected_idx ) [inline]

Set index of chinese character list.

void SelectionBox::SetText ( const WCHAR * text )

Set one line of chinese character to text.

The documentation for this class was generated from the following files:
  • AddOns/T9/SelectionBox.hpp
  • AddOns/T9/SelectionBox.cpp
Generated on Wed Jan 25 01:47:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SelectionBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SelectionBoxView Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/T9/SelectionBox.hpp>

Inheritance diagram for SelectionBoxView:

[legend]
Collaboration diagram for SelectionBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
void | Init ()
SelectionBoxView ()
virtual | ~SelectionBoxView ()

Constructor & Destructor Documentation

SelectionBoxView::SelectionBoxView ( )

SelectionBoxView::~SelectionBoxView ( ) [virtual]

Member Function Documentation

void SelectionBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void SelectionBoxView::Init ( )

The documentation for this class was generated from the following files:
  • AddOns/T9/SelectionBox.hpp
  • AddOns/T9/SelectionBox.cpp
Generated on Wed Jan 25 01:47:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SelectionChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SelectionChangedMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for SelectionChangedMsg:

[legend]
Collaboration diagram for SelectionChangedMsg:

[legend]

Public Types

enum | { ID = 1102 }

Public Member Functions

virtual Message * | Clone () const
INT | GetIndex () const
virtual const MsgMetaData & | GetMetaData () const
const AbstractGrid * | GetSender () const
SelectionChangedMsg (Control *control, INT index, AbstractGrid *sender=0)
virtual | ~SelectionChangedMsg ()

Detailed Description

This message is sent to the parent-window from a listbox-control or grid-control whenever the selection has been changed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SelectionChangedMsg::SelectionChangedMsg | ( | Control * | control,
 |  | INT | index,
 |  | AbstractGrid * | sender = 0
 | ) |

SelectionChangedMsg::~SelectionChangedMsg ( ) [virtual]

Member Function Documentation

Message * SelectionChangedMsg::Clone ( ) const [virtual]

Implements Message.

INT SelectionChangedMsg::GetIndex ( ) const [inline]

const MsgMetaData & SelectionChangedMsg::GetMetaData ( ) const [virtual]

Implements ControlMsg.

const AbstractGrid* SelectionChangedMsg::GetSender ( ) const [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 01:47:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SelectItemReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SelectItemReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SelectItemReqArg:

[legend]
Collaboration diagram for SelectItemReqArg:

[legend]

Public Types

enum | { ID = 1310 }

Public Member Functions

const SimItemId & | GetDefaultItemId () const
const SimIconIdentifier & | GetIconList () const
const SimItemIdentifierList & | GetItemList () const
const SimNextActionIdentifier & | GetItemsNai () const
const SimSelectItemOptions & | GetOptions () const
const SimTkTransactionId & | GetTid () const
const SimAlphaIdentifier & | GetTitleAlpha () const
const SimIconIdentifier & | GetTitleIcon () const
SelectItemReqArg ()
void | SetDefaultItemId (const SimItemId &default_item_id)
void | SetIconList (const SimIconIdentifier &icon_list)
void | SetItemList (const SimItemIdentifierList &item_list)
void | SetItemsNai (const SimNextActionIdentifier &items_nai)
void | SetOptions (const SimSelectItemOptions &options)
void | SetTid (const SimTkTransactionId &tid)
void | SetTitleAlpha (const SimAlphaIdentifier &title_alpha)
void | SetTitleIcon (const SimIconIdentifier &title_icon)

Static Public Member Functions

static const SelectItemReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SelectItemReqArg: reflects arguments of signal SI_SELECT_ITEM_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SelectItemReqArg::SelectItemReqArg ( )

Member Function Documentation

const SelectItemReqArg & SelectItemReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimItemId& SelectItemReqArg::GetDefaultItemId ( ) const [inline]

const SimIconIdentifier& SelectItemReqArg::GetIconList ( ) const [inline]

const SimItemIdentifierList& SelectItemReqArg::GetItemList ( ) const [inline]

const SimNextActionIdentifier& SelectItemReqArg::GetItemsNai ( ) const [inline]

const SimSelectItemOptions& SelectItemReqArg::GetOptions ( ) const [inline]

const SimTkTransactionId& SelectItemReqArg::GetTid ( ) const [inline]

const SimAlphaIdentifier& SelectItemReqArg::GetTitleAlpha ( ) const [inline]

const SimIconIdentifier& SelectItemReqArg::GetTitleIcon ( ) const [inline]

void SelectItemReqArg::SetDefaultItemId ( const SimItemId & default_item_id ) [inline]

void SelectItemReqArg::SetIconList ( const SimIconIdentifier & icon_list ) [inline]

void SelectItemReqArg::SetItemList ( const SimItemIdentifierList & item_list ) [inline]

void SelectItemReqArg::SetItemsNai ( const SimNextActionIdentifier & items_nai ) [inline]

void SelectItemReqArg::SetOptions ( const SimSelectItemOptions & options ) [inline]

void SelectItemReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

void SelectItemReqArg::SetTitleAlpha ( const SimAlphaIdentifier & title_alpha ) [inline]

void SelectItemReqArg::SetTitleIcon ( const SimIconIdentifier & title_icon ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:47:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SelectItemRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SelectItemRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SelectItemRspArg:

[legend]
Collaboration diagram for SelectItemRspArg:

[legend]

Public Types

enum | { ID = 2310 }

Public Member Functions

const SimItemId & | GetItemId () const
const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
SelectItemRspArg ()
SelectItemRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause, const SimItemId &item_id)
void | SetItemId (const SimItemId &item_id)
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)

Static Public Member Functions

static const SelectItemRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SelectItemRspArg: reflects arguments of signal SI_SELECT_ITEM_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SelectItemRspArg::SelectItemRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause,
 |  | const SimItemId & | item_id
 | ) |

SelectItemRspArg::SelectItemRspArg ( )

Member Function Documentation

const SelectItemRspArg & SelectItemRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimItemId& SelectItemRspArg::GetItemId ( ) const [inline]

const ProactiveCause& SelectItemRspArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& SelectItemRspArg::GetTid ( ) const [inline]

void SelectItemRspArg::SetItemId ( const SimItemId & item_id ) [inline]

void SelectItemRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SelectItemRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:47:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SelfLocationDialog Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SelfLocationDialog Class Reference

Class for the self location window. This window takes user input for QoS from the user. More...

#include <Applications/LcsTransports/Settings/SelfLocationDialogWin.hpp>

Collaboration diagram for SelfLocationDialog:

[legend]

Public Member Functions

void | Init ()
SelfLocationDialog ()
Constructor.
virtual | ~SelfLocationDialog ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnOpen ()

Detailed Description

Class for the self location window. This window takes user input for QoS from the user.

Constructor & Destructor Documentation

SelfLocationDialog::SelfLocationDialog ( )

Constructor.

SelfLocationDialog::~SelfLocationDialog ( ) [virtual]

Destructor.

Member Function Documentation

void SelfLocationDialog::Init ( )

BOOLEAN SelfLocationDialog::OnCancel ( ) [protected, virtual]

BOOLEAN SelfLocationDialog::OnConfirm ( ) [protected, virtual]

void SelfLocationDialog::OnLayoutClient ( ) [protected, virtual]

void SelfLocationDialog::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/LcsTransports/Settings/SelfLocationDialogWin.hpp
  • Applications/LcsTransports/Settings/SelfLocationDialogWin.cpp
Generated on Wed Jan 25 01:47:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Semaphore Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Semaphore Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/Nuc32/Semaphore.hpp>

Inheritance diagram for Semaphore:

[legend]
Collaboration diagram for Semaphore:

[legend]

Public Member Functions

BOOLEAN | Create (INT init_val=0, INT max_val=-1)
BOOLEAN | Create (INT init_val=0, INT max_val=-1)
BOOLEAN | Obtain (const Ticks &timeout=Ticks::Infinite())
BOOLEAN | Obtain (Ticks timeout=Ticks::Infinite())
void | Release ()
void | Release ()
Semaphore ()
Semaphore ()
virtual | ~Semaphore ()
virtual | ~Semaphore ()

Detailed Description

Semaphore object is a synchronization object that maintains a count between zero and a specified maximum value. The count is decremented each time a thread completes a wait for the semaphore object and incremented each time a thread releases the semaphore. When the count reaches zero, no more threads can successfully wait for the semaphore object state to become signaled. The state of a semaphore is set to signaled when its count is greater than zero, and nonsignaled when its count is zero.

Semaphore is useful in controlling a shared resource that can support a limited number of users. It acts as a gate that limits the number of threads sharing the resource to a specified maximum number.

Constructor & Destructor Documentation

Semaphore::Semaphore ( )

Semaphore::~Semaphore ( ) [virtual]

Semaphore::Semaphore ( )

virtual Semaphore::~Semaphore ( ) [virtual]

Member Function Documentation

BOOLEAN Semaphore::Create | ( | INT | init_val = 0,
 |  | INT | max_val = -1
 | ) |

Parameters:
init_val | Specifies an initial count for the semaphore object. This value must be greater than or equal to zero and less than or equal to max_val. The state of a semaphore is signaled when its count is greater than zero and nonsignaled when it is zero. The count is decreased by one whenever a wait function releases a thread that was waiting for the semaphore. The count is increased by a specified amount by calling the Release method.
max_val | Specifies the maximum count for the semaphore object. This value must be greater than zero.
Returns:
TRUE if succeeded. FALSE if failed.

BOOLEAN Semaphore::Create | ( | INT | init_val = 0,
 |  | INT | max_val = -1
 | ) |

BOOLEAN Semaphore::Obtain ( const Ticks & timeout = Ticks::Infinite() )

Obtain returns when one of the following occurs:

  • The specified object is in the signaled state.
  • The time-out interval elapses.
    Parameters:
    timeout Specifies the time-out interval, in milliseconds. The function returns if the interval elapses, even if the object's state is nonsignaled. If timeout is zero, the method tests the object's state and returns immediately. If timeout is INFINITE, the method's time-out interval never elapses.
    Returns:
    TRUE if the state is signaled. FALSE if the time-out interval elapsed.

BOOLEAN Semaphore::Obtain ( Ticks timeout = Ticks::Infinite() )

void Semaphore::Release ( )

Release increases the count of the semaphore object. If count exceeds max_val that was specified when the semaphore was created, the count is not changed.

void Semaphore::Release ( )

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/Semaphore.hpp
  • Kernel/Os/Win32/Semaphore.hpp
  • Kernel/Os/Nuc32/Semaphore.cpp
  • Kernel/Os/Win32/Semaphore.cpp
Generated on Wed Jan 25 01:47:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SemObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SemObtainer Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/SemObtainer.hpp>

Inheritance diagram for SemObtainer:

[legend]
Collaboration diagram for SemObtainer:

[legend]

Public Member Functions

BOOLEAN | IsObtained () const
BOOLEAN | Obtain ()
BOOLEAN | Obtain (const Ticks &timeout)
void | Release ()
SemObtainer (Semaphore *sem)
SemObtainer (Semaphore *sem, const Ticks &timeout)
~SemObtainer ()
Releases the semaphore, if it has not already been released by Release.

Detailed Description

Encapsulates the obtaining and releasing of a semaphore into an object. Because the obtaining is done in the constructor and the releasing in the destructor, it is assured that there is no obtain without its corresponding release.

Constructor & Destructor Documentation

SemObtainer::SemObtainer | ( | Semaphore * | sem,
 |  | const Ticks & | timeout
 | ) |

Parameters:
sem | Pointer to the semaphore, which should be obtained.
timeout | Timeout for obtaining.

SemObtainer::SemObtainer ( Semaphore * sem )

Instead of calling SemObtainer(sem, Ticks::Infinite())

SemObtainer::~SemObtainer ( ) [inline]

Releases the semaphore, if it has not already been released by Release.

Member Function Documentation

BOOLEAN SemObtainer::IsObtained ( ) const [inline]

Returns:
TRUE, if the semaphore is obtained.

BOOLEAN SemObtainer::Obtain ( )

See also:
Semaphore::Obtain

BOOLEAN SemObtainer::Obtain ( const Ticks & timeout )

See also:
Semaphore::Obtain

void SemObtainer::Release ( )

See also:
Semaphore::Release

The documentation for this class was generated from the following files:
  • Kernel/Os/SemObtainer.hpp
  • Kernel/Os/SemObtainer.cpp
Generated on Wed Jan 25 01:47:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SendRequestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SendRequestMsg Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpMsgTypes.hpp>

Inheritance diagram for SendRequestMsg:

[legend]
Collaboration diagram for SendRequestMsg:

[legend]

Public Types

enum | { ID = 4231 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BYTE * | GetRequest () const
INT | GetSize () const
SendRequestMsg (ExecutionContext *context, BYTE *request, INT size)
virtual | ~SendRequestMsg ()

Detailed Description

This message informs the GLTP connection application to send the request to the GL server

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SendRequestMsg::SendRequestMsg | ( | ExecutionContext * | context,
 |  | BYTE * | request,
 |  | INT | size
 | ) |

SendRequestMsg::~SendRequestMsg ( ) [virtual]

Member Function Documentation

Message * SendRequestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SendRequestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BYTE* SendRequestMsg::GetRequest ( ) const [inline]

INT SendRequestMsg::GetSize ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpMsgTypes.hpp
  • AddOns/Lcs/GLTP/GltpMsgTypes.cpp
Generated on Wed Jan 25 01:47:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SendSmsMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SendSmsMsg Class Reference

#include <Applications/Ems/Sms/SmsMsgTypes.hpp>

Inheritance diagram for SendSmsMsg:

[legend]
Collaboration diagram for SendSmsMsg:

[legend]

Public Types

enum | { ID = 21502 }

Public Member Functions

virtual Message * | Clone () const
const EditorDocumentObtainer & | GetDocumentObtainer () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetPhoneNumber () const
const PhoneNumber & | GetServiceCenter () const
SendSmsMsg (ExecutionContext *context, const EditorDocumentObtainer &document_obtainer, const PhoneNumber &phone_number, const PhoneNumber &service_center)
void | SetPhoneNumber (const PhoneNumber &phone_number)
void | SetServiceCenter (const PhoneNumber &service_center)
virtual | ~SendSmsMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SendSmsMsg::SendSmsMsg | ( | ExecutionContext * | context,
 |  | const EditorDocumentObtainer & | document_obtainer,
 |  | const PhoneNumber & | phone_number,
 |  | const PhoneNumber & | service_center
 | ) |

SendSmsMsg::~SendSmsMsg ( ) [virtual]

Member Function Documentation

Message * SendSmsMsg::Clone ( ) const [virtual]

Implements Message.

const EditorDocumentObtainer& SendSmsMsg::GetDocumentObtainer ( ) const [inline]

const MsgMetaData & SendSmsMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& SendSmsMsg::GetPhoneNumber ( ) const [inline]

const PhoneNumber& SendSmsMsg::GetServiceCenter ( ) const [inline]

void SendSmsMsg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

void SendSmsMsg::SetServiceCenter ( const PhoneNumber & service_center ) [inline]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsMsgTypes.hpp
  • Applications/Ems/Sms/SmsMsgTypes.cpp
Generated on Wed Jan 25 01:47:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerDataConnAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerDataConnAccessor Class Reference
[DataConn]

#include <Applications/DataConn/DataConnAccessor.hpp>

Inheritance diagram for SerDataConnAccessor:

[legend]
Collaboration diagram for SerDataConnAccessor:

[legend]

Public Member Functions

virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
void | Init ()
SerDataConnAccessor (SerDataConnProfile *profile)
virtual void | Update ()
virtual | ~SerDataConnAccessor ()

Protected Member Functions

virtual INT | CountSettings () const
virtual void | OnTrigger (INT selected_idx)

Constructor & Destructor Documentation

SerDataConnAccessor::SerDataConnAccessor ( SerDataConnProfile * profile )

SerDataConnAccessor::~SerDataConnAccessor ( ) [virtual]

Member Function Documentation

INT SerDataConnAccessor::CountSettings ( ) const [protected, virtual]

Reimplemented from DataConnAccessor.

const WCHAR * SerDataConnAccessor::GetItemText ( BOOLEAN highlighted ) [virtual]

Reimplemented from DataConnAccessor.

void SerDataConnAccessor::Init ( )

Reimplemented from DataConnAccessor.

void SerDataConnAccessor::OnTrigger ( INT selected_idx ) [protected, virtual]

Reimplemented from DataConnAccessor.

void SerDataConnAccessor::Update ( ) [virtual]

Reimplemented from DataConnAccessor.

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnAccessor.hpp
  • Applications/DataConn/DataConnAccessor.cpp
Generated on Wed Jan 25 01:47:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerDataConnProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerDataConnProvider Class Reference
[Dataconn]

#include <Applications/DataConn/SerDataConnProvider.hpp>

Inheritance diagram for SerDataConnProvider:

[legend]
Collaboration diagram for SerDataConnProvider:

[legend]

Public Types

typedef DataConnProvider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
SerDataConnProvider ()
virtual BOOLEAN | SetDataItem (const DataItem &item, INT column)
SetDataItem sets data items
virtual | ~SerDataConnProvider ()
Destructor.

Protected Member Functions

virtual void | ClearProfile ()
virtual DataConnProfile * | GetProfileInstance ()

Member Typedef Documentation

typedef DataConnProvider SerDataConnProvider::Base

Reimplemented from DataConnProvider.

Constructor & Destructor Documentation

SerDataConnProvider::SerDataConnProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

SerDataConnProvider::~SerDataConnProvider ( ) [virtual]

Destructor.

Member Function Documentation

void SerDataConnProvider::ClearProfile ( ) [protected, virtual]

Implements DataConnProvider.

BOOLEAN SerDataConnProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Reimplemented from DataConnProvider.

virtual DataConnProfile* SerDataConnProvider::GetProfileInstance ( ) [inline, protected, virtual]

Implements DataConnProvider.

virtual INT SerDataConnProvider::GetProviderId ( ) const [inline, virtual]

Returns the provider id.

Reimplemented from DataConnProvider.

BOOLEAN SerDataConnProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | column
 | ) | [virtual]

SetDataItem sets data items

Reimplemented from DataConnProvider.

The documentation for this class was generated from the following files:
  • Applications/DataConn/SerDataConnProvider.hpp
  • Applications/DataConn/SerDataConnProvider.cpp
Generated on Wed Jan 25 01:47:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialClientSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialClientSocket Class Reference

#include <Apoxi/AddOns/SerialSocket/SerialClientSocket.hpp>

Inheritance diagram for SerialClientSocket:

[legend]
Collaboration diagram for SerialClientSocket:

[legend]

Public Member Functions

INT | Bind (SocketAddr &sock_addr)
INT | Connect (SocketAddr &serv_addr)
SerialClientSocket ()
virtual | ~SerialClientSocket ()

Protected Attributes

friend | SerialServerSocket

Constructor & Destructor Documentation

SerialClientSocket::SerialClientSocket ( )

SerialClientSocket::~SerialClientSocket ( ) [virtual]

Member Function Documentation

INT SerialClientSocket::Bind ( SocketAddr & sock_addr )

Give the socket the local address.

Parameters:
serv_addr Reference to a SocketAddr object.
Returns:
0 on success and -1 on failure.

INT SerialClientSocket::Connect ( SocketAddr & serv_addr )

Connects the socket to another socket

Parameters:
serv_addr Reference to a SocketAddr object.
Returns:
0 on success and -1 on failure.

Field Documentation

friend SerialClientSocket::SerialServerSocket [protected]

The documentation for this class was generated from the following files:
  • AddOns/SerialSocket/SerialClientSocket.hpp
  • AddOns/SerialSocket/SerialClientSocket.cpp
Generated on Wed Jan 25 01:47:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialIoAdapter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialIoAdapter Class Reference
[SerialSocket]

#include <Apoxi/AddOns/SerialSocket/SerialIoAdapter.hpp>

Public Types

enum ErrorCode {
c_sio_err_none = SIO_ERR_NONE, c_sio_err_acces = SIO_ERR_ACCES, c_sio_err_addrnnotvail = SIO_ERR_ADDRNOTAVAIL, c_sio_err_afnosupport = SIO_ERR_AFNOSUPPORT,
c_sio_err_again = SIO_ERR_AGAIN, c_sio_err__already = SIO_ERR_ALREADY, c_sio_err_badf = SIO_ERR_BADF, c_sio_err_busy = SIO_ERR_BUSY,
c_sio_err_connrefused = SIO_ERR_CONNREFUSED, c_sio_err_fault = SIO_ERR_FAULT, c_sio_err_inprogress = SIO_ERR_INPROGRESS, c_sio_err_inval = SIO_ERR_INVAL,
c_sio_err_nametoolong = SIO_ERR_NAMETOOLONG, c_sio_err_nfile = SIO_ERR_NFILE, c_sio_err_noact = SIO_ERR_NOACT, c_sio_err_nodev = SIO_ERR_NODEV,
c_sio_err_nomem = SIO_ERR_NOMEM, c_sio_err_noopt = SIO_ERR_NOOPT, c_sio_err_noprotoopt = SIO_ERR_NOPROTOOPT, c_sio_err_nosubdev = SIO_ERR_NOSUBDEV,
c_sio_err_nosys = SIO_ERR_NOSYS, c_sio_err_notsock = SIO_ERR_NOTSOCK, c_sio_err_nscan = SIO_ERR_NSCAN, c_sio_err_opnotsupp = SIO_ERR_OPNOTSUPP,
c_sio_err_protonosupport = SIO_ERR_PROTONOSUPPORT, c_sio_err_sockstate = SIO_ERR_SOCKSTATE, c_sio_err_timeout = SIO_ERR_TIMEDOUT, c_sio_err_max = SIO_ERR_MAX
}
enum | SocketFamily { c_sock_pf_undef = 0, c_sock_pf_termio, c_sock_pf_bt, c_sock_pf_max }

Public Member Functions

INT | Accept (SerialSocket &clientSock, SocketAddr &sock_addr)
INT | Bind (SocketAddr &sock_addr)
INT | Close ()
INT | Connect (SocketAddr &serv_addr)
INT | GetErrorNumber (SioErrorDesc &errorinfo)
INT | IoCtl (INT requestcode, INT argument)
INT | Listen (INT backlog)
INT | Open (SocketFamily fam, INT protocol)
INT | OptGet (INT optname, void *optval, INT &optlen)
INT | OptSet (INT optname, void *optval, INT optlen)
INT | Read (void *buf, LONG length)
SerialIoAdapter ()
INT | Write (const void *buf, LONG count)
~SerialIoAdapter ()

Data Fields

friend | SerialIoSet
friend | SerialSocket

Data Structures

struct | SioErrorDesc

Field Documentation

friend SerialIoAdapter::SerialSocket

The documentation for this class was generated from the following files:
  • AddOns/SerialSocket/SerialIoAdapter.hpp
  • AddOns/SerialSocket/SerialIoAdapter.cpp
  • AddOns/SerialSocket/SerialIoAdapterStub.cpp
Generated on Wed Jan 25 01:47:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialIoAdapter::SioErrorDesc Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SerialIoAdapter::SioErrorDesc

SerialIoAdapter::SioErrorDesc Struct Reference
[SerialSocket]

#include <Apoxi/AddOns/SerialSocket/SerialIoAdapter.hpp>

Data Fields

ErrorCode c_global_errno
ErrorCode c_sio_errno
CHAR * | file_name
LONG | line_no

Field Documentation

ErrorCode SerialIoAdapter::SioErrorDesc::c_sio_errno

The documentation for this struct was generated from the following file:
  • AddOns/SerialSocket/SerialIoAdapter.hpp
Generated on Wed Jan 25 01:47:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialIoSet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialIoSet Class Reference
[SerialSocket]

Maintains fd set for the socket operations. More...

#include <Apoxi/AddOns/SerialSocket/SerialIoAdapter.hpp>

Public Types

enum SerialSocketEvent {
NONE, ABORT, CLOSE_REQ, CONNECT_REQ,
CONNECT_SUCCESS, CONNECT_FAIL, DATA_RECEIVED, DATA_SENT,
DISCONNECT_IND, UNKNOWN
}

Public Member Functions

BOOLEAN | Add (const SerialSocketData *s)
INT | AddToReadList (const SerialSocketData *sockdata)
INT | AddToWriteList (const SerialSocketData *sockdata)
SerialSocketEvent | GetEvent (const SerialSocketData *sockdata) const
BOOLEAN | Init ()
BOOLEAN | Remove (const SerialSocketData *s)
INT | RemoveFromReadList (const SerialSocketData *sockdata)
INT | RemoveFromWriteList (const SerialSocketData *sockdata)
INT | Select (const Ticks *t_timeout)
SerialIoSet ()
BOOLEAN | SignalSelect ()
BOOLEAN | TestFor (const SerialSocketData *sockdata) const
~SerialIoSet ()

Data Fields

fd_set_t | m_read_fdset
INT | m_selectid
fd_set_t | m_write_fdset

Detailed Description

Maintains fd set for the socket operations.

Constructor & Destructor Documentation

SerialIoSet::SerialIoSet ( )

The documentation for this class was generated from the following files:
  • AddOns/SerialSocket/SerialIoAdapter.hpp
  • AddOns/SerialSocket/SerialIoAdapter.cpp
  • AddOns/SerialSocket/SerialIoAdapterStub.cpp
Generated on Wed Jan 25 01:47:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialServerSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialServerSocket Class Reference

#include <Apoxi/AddOns/SerialSocket/SerialServerSocket.hpp>

Inheritance diagram for SerialServerSocket:

[legend]
Collaboration diagram for SerialServerSocket:

[legend]

Public Member Functions

INT | Accept (SerialSocket &clientSock, SocketAddr &addr)
INT | Bind (SocketAddr &serv_addr)
INT | Listen (INT backlog)
SerialServerSocket ()
virtual | ~SerialServerSocket ()

Constructor & Destructor Documentation

SerialServerSocket::SerialServerSocket ( )

SerialServerSocket::~SerialServerSocket ( ) [virtual]

Member Function Documentation

INT SerialServerSocket::Accept | ( | SerialSocket & | clientSock,
 |  | SocketAddr & | addr
 | ) |

Accepts the incoming connection on a socket.

Parameters:
clientSock | client socket that will be used for communication after accepting the connection
addr | Reference to a SocketAddr object. This will contain remote device parameters on successful connection
Returns:
0 on success and -1 on failure.

INT SerialServerSocket::Bind ( SocketAddr & serv_addr )

Gives the socket the local address.

Parameters:
serv_addr Reference to a SocketAddr object.
Returns:
0 on success and -1 on failure.

INT SerialServerSocket::Listen ( INT backlog )

Listens for the connections on a socket

Parameters:
Backlog no of the connections that can be queued.
Returns:
0 on success and -1 on failure.

The documentation for this class was generated from the following files:
  • AddOns/SerialSocket/SerialServerSocket.hpp
  • AddOns/SerialSocket/SerialServerSocket.cpp
Generated on Wed Jan 25 01:47:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialSocket Class Reference

#include <Apoxi/AddOns/SerialSocket/SerialSocket.hpp>

Inheritance diagram for SerialSocket:

[legend]
Collaboration diagram for SerialSocket:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
INT | IoCtl (INT requestcode, INT argument)
virtual BOOLEAN | IsBlocking () const
virtual BOOLEAN | IsOpen () const
void | OnControlMsg (const SocketControlMsg &msg)
BOOLEAN | Open (SerialIoAdapter::SocketFamily fam, INT protocol)
INT | OptGet (INT optname, void *optval, INT &optlen)
INT | OptSet (INT optname, const void *optval, INT optlen)
virtual INT | Read (void *buf, INT buflen)
SerialSocket ()
virtual BOOLEAN | SetBlocking (BOOLEAN block=FALSE)
virtual INT | Write (const void *buf, INT buflen)
virtual | ~SerialSocket ()

Protected Attributes

SerialSocketData * m_sd
SerialIoAdapter m_serialio

Friends

class | SerialIoAdapter
class | SerialIoSet

Constructor & Destructor Documentation

SerialSocket::SerialSocket ( )

SerialSocket::~SerialSocket ( ) [virtual]

Member Function Documentation

BOOLEAN SerialSocket::Close ( ) [virtual]

Closes the socket.

Returns:
TRUE on success, FALSE otherwise.

Implements Socket.

INT SerialSocket::IoCtl | ( | INT | requestcode,
 |  | INT | argument
 | ) |

BOOLEAN SerialSocket::IsBlocking ( ) const [virtual]

This function is not supported for this socket. provided here only for compatibility

Implements Socket.

BOOLEAN SerialSocket::IsOpen ( ) const [virtual]

Checks if the socket connection is open.

Returns:
TRUE if open, FALSE otherwise.

Implements Socket.

void SerialSocket::OnControlMsg ( const SocketControlMsg & msg ) [virtual]

Translates the socket control message msg into a socket event and routes it accordingly. If a listener is set, its OnSocketEvent method is called. Otherwise the messages are discarded.

Reimplemented from Socket.

BOOLEAN SerialSocket::Open | ( | SerialIoAdapter::SocketFamily | fam,
 |  | INT | protocol
 | ) |

Please refer to sock_create in sio_sock.h

Parameters:
fam | specifies the socket family.
protocol | specifies the protocol to be used. Refer to BtProtocol in BtSocketAddr.
Returns:
0 on success and -1 on failure.

INT SerialSocket::OptGet | ( | INT | optname,
 |  | void * | optval,
 |  | INT & | optlen
 | ) |

Retrieves the option value.

Parameters:
optname | option name to retrive value
optval | pointer to the option value
optlen | pointer to the option value length
Returns:
0 on success and -1 on failure.

INT SerialSocket::OptSet | ( | INT | optname,
 |  | const void * | optval,
 |  | INT | optlen
 | ) |

Sets the option value.

Parameters:
optname | option name to set value
optval | pointer to the option value
optlen | pointer to the option value length
Returns:
Number of bytes written or -1 on failure.

INT SerialSocket::Read | ( | void * | buf,
 |  | INT | buflen
 | ) | [virtual]

Reads data from the socket.

Parameters:
buf | Pointer to read buffer.
buflen | Length of read buffer.
Returns:
Number of bytes read or -1 on failure.

Implements Socket.

BOOLEAN SerialSocket::SetBlocking ( BOOLEAN block = FALSE ) [virtual]

This function is not supported for this socket. provided here only for compatibility

Implements Socket.

INT SerialSocket::Write | ( | const void * | buf,
 |  | INT | buflen
 | ) | [virtual]

Writes data from into socket.

Parameters:
buf | Pointer to read buffer.
buflen | Length of read buffer.
Returns:
Number of bytes written or -1 on failure.

Implements Socket.

Friends And Related Function Documentation

friend class SerialIoAdapter [friend]

friend class SerialIoSet [friend]

Field Documentation

SerialSocketData* SerialSocket::m_sd [protected]

SerialIoAdapter SerialSocket::m_serialio [protected]

The documentation for this class was generated from the following files:
  • AddOns/SerialSocket/SerialSocket.hpp
  • AddOns/SerialSocket/SerialSocket.cpp
Generated on Wed Jan 25 01:47:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialSocketData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialSocketData Class Reference
[Socket]

#include <Apoxi/AddOns/SerialSocket/SerialSocketData.hpp>

Inheritance diagram for SerialSocketData:

[legend]
Collaboration diagram for SerialSocketData:

[legend]

Public Member Functions

SerialSocket * | GetAttachedSerialSocket () const
ExecutionContext * | GetContext () const
SerialIoSet * | GetSerialIoSet () const
BOOLEAN | IsInUse () const
void | SetSerialIoSet (SerialIoSet *set)

Friends

class | SerialClientSocket
class | SerialServerSocket
class | SerialSocket
class | SerialSocketSubSystem

Member Function Documentation

SerialSocket* SerialSocketData::GetAttachedSerialSocket ( ) const [inline]

ExecutionContext* SerialSocketData::GetContext ( ) const [inline]

Reimplemented from SocketData.

SerialIoSet* SerialSocketData::GetSerialIoSet ( ) const [inline]

BOOLEAN SerialSocketData::IsInUse ( ) const [inline]

Reimplemented from SocketData.

void SerialSocketData::SetSerialIoSet ( SerialIoSet * set ) [inline]

Friends And Related Function Documentation

friend class SerialClientSocket [friend]

friend class SerialServerSocket [friend]

friend class SerialSocket [friend]

friend class SerialSocketSubSystem [friend]

The documentation for this class was generated from the following files:
  • AddOns/SerialSocket/SerialSocketData.hpp
  • AddOns/SerialSocket/SerialSocketData.cpp
Generated on Wed Jan 25 01:47:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialSocketDataLock Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialSocketDataLock Class Reference
[Socket]

#include <Apoxi/AddOns/SerialSocket/SerialSocketDataLock.hpp>

Inheritance diagram for SerialSocketDataLock:

[legend]
Collaboration diagram for SerialSocketDataLock:

[legend]

Public Member Functions

SerialSocketDataLock ()

Detailed Description

SerialSocketDataLock is a private class of Apoxi socket subsystem. It is used to protect shared data from mutual access.

Constructor & Destructor Documentation

SerialSocketDataLock::SerialSocketDataLock ( ) [inline]

The documentation for this class was generated from the following file:
  • AddOns/SerialSocket/SerialSocketDataLock.hpp
Generated on Wed Jan 25 01:47:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialSocketSubSystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialSocketSubSystem Class Reference
[Socket]

#include <Apoxi/AddOns/SerialSocket/SerialSocketSubSystem.hpp>

Inheritance diagram for SerialSocketSubSystem:

[legend]
Collaboration diagram for SerialSocketSubSystem:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual BootSequenceState | InvokeAt () const
virtual void | OnPowerUp ()
SerialSocketSubSystem ()

Static Public Member Functions

static SerialSocketSubSystem * | GetInstance ()

Friends

class | Os
class | SerialClientSocket
class | SerialServerSocket
class | SerialSocket
class | SerialSocketDataLock
class | SerialSocketThread

Detailed Description

Socket private class. SerialSocketSubSystem holds vital data of the Apoxi socket implementation and is responsible to boot and initialize the socket backbone on power on.

Constructor & Destructor Documentation

SerialSocketSubSystem::SerialSocketSubSystem ( )

Member Function Documentation

static SerialSocketSubSystem* SerialSocketSubSystem::GetInstance ( ) [inline, static]

virtual const WCHAR* SerialSocketSubSystem::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

SerialSocketSubSystem::BootSequenceState SerialSocketSubSystem::InvokeAt ( ) const [virtual]

InvokeAt denotes the system boot phase the SubSystem shall be initialized in.

Implements SubSystem.

void SerialSocketSubSystem::OnPowerUp ( ) [virtual]

This method will be invoked on system power on.

Reimplemented from SubSystem.

Friends And Related Function Documentation

friend class Os [friend]

friend class SerialClientSocket [friend]

friend class SerialServerSocket [friend]

friend class SerialSocket [friend]

friend class SerialSocketDataLock [friend]

friend class SerialSocketThread [friend]

The documentation for this class was generated from the following files:
  • AddOns/SerialSocket/SerialSocketSubSystem.hpp
  • AddOns/SerialSocket/SerialSocketSubSystem.cpp
Generated on Wed Jan 25 01:47:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialSocketThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialSocketThread Class Reference
[SerialSocket]

#include <Apoxi/AddOns/SerialSocket/SerialSocketThread.hpp>

Inheritance diagram for SerialSocketThread:

[legend]
Collaboration diagram for SerialSocketThread:

[legend]

Public Member Functions

BOOLEAN | Init ()
SerialSocketThread ()

Static Public Member Functions

static BOOLEAN | AddToList (const SerialSocketData *sd, SerialIoSet &set)
static SerialIoSet * | GetIoSetInstance ()
static BOOLEAN | NotifyOnData (const SerialSocketData *sd, BOOLEAN enable=TRUE)
static BOOLEAN | RemoveFromList (const SerialSocketData *sd, SerialIoSet &set)
static BOOLEAN | Shutdown ()
static BOOLEAN | StopNotifications (const SerialSocketData *sd)
static BOOLEAN | Wakeup ()

Constructor & Destructor Documentation

SerialSocketThread::SerialSocketThread ( )

Member Function Documentation

BOOLEAN SerialSocketThread::AddToList | ( | const SerialSocketData * | sd,
 |  | SerialIoSet & | set
 | ) | [static]

Adds the socket to the notification list.

Returns:
TRUE if successful, FALSE otherwise.

static SerialIoSet* SerialSocketThread::GetIoSetInstance ( ) [inline, static]

BOOLEAN SerialSocketThread::Init ( )

BOOLEAN SerialSocketThread::NotifyOnData | ( | const SerialSocketData * | sd,
 |  | BOOLEAN | enable = TRUE
 | ) | [static]

Request notifications for data sent and data received.

Returns:
TRUE if successful, FALSE otherwise.

BOOLEAN SerialSocketThread::RemoveFromList | ( | const SerialSocketData * | sd,
 |  | SerialIoSet & | set
 | ) | [static]

Removes the socket from the notification list.

Returns:
TRUE if successful, FALSE otherwise.

BOOLEAN SerialSocketThread::Shutdown ( ) [static]

Removes all notifications and terminate the thread.

Returns:
TRUE if successful, FALSE otherwise.

BOOLEAN SerialSocketThread::StopNotifications ( const SerialSocketData * sd ) [static]

Stop notifications for data sent and data received.

Returns:
TRUE if successful, FALSE otherwise.

BOOLEAN SerialSocketThread::Wakeup ( ) [static]

Wakeup the thread while shutdown.

Returns:
TRUE if successful, FALSE otherwise.

The documentation for this class was generated from the following files:
  • AddOns/SerialSocket/SerialSocketThread.hpp
  • AddOns/SerialSocket/SerialSocketThread.cpp
Generated on Wed Jan 25 01:48:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialTerminal Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialTerminal Class Reference

#include <Apoxi/AddOns/MmCall/SerialTerminal.hpp>

Collaboration diagram for SerialTerminal:

[legend]

Public Types

enum | Event { DataAvailable, DataSent }
enum Parity {
ParityNone = SioGlueWrapper::ParityNone, ParityOdd = SioGlueWrapper::ParityOdd, ParityEven = SioGlueWrapper::ParityEvent, ParityMark = SioGlueWrapper::ParityMark,
ParitySpace = SioGlueWrapper::ParitySpace
}
enum | Result { Ok, Error, NotConnected }

Public Member Functions

Result | Connect (const String &connect_string, UINT32 speed, UINT8 stop_bits, UINT8 data_bits, Parity parity)
Result Disconnect ()
Result | GetConnectionParameters (UINT32 *speed, UINT8 *stop_bits, UINT8 *data_bits, Parity *parity) const
BOOLEAN | IsConnected () const
Result | Read (void *buffer, UINT16 buffer_size, UINT16 &bytes_read)
Result | SetAtMode (BOOLEAN enable)
void | SetListener (SerialTerminalListener *listener)
Result | Write (const void *buffer, UINT16 buffer_size, UINT16 &bytes_written)
virtual | ~SerialTerminal ()
Destructor.

Static Public Member Functions

static SerialTerminal * | GetFreeSerialTerminal ()
static void | ReleaseSerialTerminal (SerialTerminal *terminal)

Protected Member Functions

void | OnSignalChange (SioGlueWrapper::SignalType type, void *signal_parameter, void *user_parameter)

Protected Attributes

BOOLEAN | m_is_in_use
Defines if a terminal is currently in use or not.

Friends

class | SioGlueSignalListener

Detailed Description

SerialTerminal is a terminal to the Sio. It can connect and disconnect to the serial IO, and read and write data from and to it.

Member Enumeration Documentation

enum SerialTerminal::Event

Enumerator:
DataAvailable
DataSent

enum SerialTerminal::Parity

Enumerator:
ParityNone
ParityOdd
ParityEven
ParityMark
ParitySpace

enum SerialTerminal::Result

Enumerator:
Ok
Error
NotConnected TBD: check possbile states of terminals!

Constructor & Destructor Documentation

SerialTerminal::~SerialTerminal ( ) [virtual]

Destructor.

Member Function Documentation

SerialTerminal::Result SerialTerminal::Connect | ( | const String & | connect_string,
 |  | UINT32 | speed,
 |  | UINT8 | stop_bits,
 |  | UINT8 | data_bits,
 |  | Parity | parity
 | ) |

Opens a connection to the SIO.

Parameters:
connect_string | string to identify b-party, e.g. phone number
speed | connection speed
stop_bits | nr of stop bits
data_bits | nr. of data bits
parity | parity, e.g. no parity

SerialTerminal::Result SerialTerminal::Disconnect ( )

Closes the connection to the SIO

Returns:
Terminal::Result::c_ok on success

SerialTerminal::Result SerialTerminal::GetConnectionParameters | ( | UINT32 * | speed,
 |  | UINT8 * | stop_bits,
 |  | UINT8 * | data_bits,
 |  | Parity * | parity
 | ) | const

Reads connection parameters from the SIO

Parameters:
speed | connection speed
stop_bits | nr of stop bits
data_bits | nr. of data bits
parity | parity, e.g. no parity
Returns:
Terminal::Result::c_ok on success

SerialTerminal * SerialTerminal::GetFreeSerialTerminal ( ) [static]

Returns:
0 if no free SerialTerminal can be retrieved.

BOOLEAN SerialTerminal::IsConnected ( ) const [inline]

Returns whether the terminal is connected to the SIO or not.

void SerialTerminal::OnSignalChange | ( | SioGlueWrapper::SignalType | type,
 |  | void * | signal_parameter,
 |  | void * | user_parameter
 | ) | [protected]

Handler for SIO Signals

Parameters:
type | type of SIO signal
signal_parameter | signal specific parameter
user_param | user specific paramerter

SerialTerminal::Result SerialTerminal::Read | ( | void * | buffer,
 |  | UINT16 | buffer_size,
 |  | UINT16 & | bytes_read
 | ) |

Reads the data available from SIO and writes it into the buffer. if bytes_read is equal to buffer_size, more data may be available. if bytes_read is 0, then no more data is available at the moment, the client will be informed, when data is available by sending a message.

Parameters:
buffer | pointer to the read buffer
buffer_size | size of the read buffer
bytes_read | specifies size of data actually read from the SIO.
Returns:
Terminal::Result::c_ok on success

static void SerialTerminal::ReleaseSerialTerminal ( SerialTerminal * terminal ) [inline, static]

Release a Terminal, if it is not in use anymore. Be aware, that any use will raise an assertion afterwards. Do not delete the object, but release any reference to it.

Result SerialTerminal::SetAtMode ( BOOLEAN enable )

Enable AT Mode

Parameters:
enable desired state of AT mode
Returns:
Terminal::Result::c_ok on success

void SerialTerminal::SetListener ( SerialTerminalListener * listener )

Set listener wich is called on terminal events

SerialTerminal::Result SerialTerminal::Write | ( | const void * | buffer,
 |  | UINT16 | buffer_size,
 |  | UINT16 & | bytes_written
 | ) |

Writes buffer_size bytes from the buffer to the SIO.

Parameters:
buffer | the buffer to write to the SIO.
buffer_size | size of the buffer handed over
bytes_written | specifies the size of the data written to the SIO.
Returns:
Terminal::Result::c_ok on success

Friends And Related Function Documentation

friend class SioGlueSignalListener [friend]

Field Documentation

BOOLEAN SerialTerminal::m_is_in_use [protected]

Defines if a terminal is currently in use or not.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/SerialTerminal.hpp
  • AddOns/MmCall/SerialTerminal.cpp
Generated on Wed Jan 25 01:48:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialTerminalArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialTerminalArg Class Reference

#include <Apoxi/AddOns/MmCall/SerialTerminalArg.hpp>

Inheritance diagram for SerialTerminalArg:

[legend]
Collaboration diagram for SerialTerminalArg:

[legend]

Public Types

enum | { ID = 9100 }

Public Member Functions

const SerialTerminal::Event & | GetEvent () const
SerialTerminal * | GetTerminal () const
SerialTerminalArg ()
void | SetEvent (const SerialTerminal::Event &event)
void | SetTerminal (SerialTerminal *terminal)

Static Public Member Functions

static const SerialTerminalArg & | Cast (const StackMsgArgument &arg)

Friends

class | SerialTerminalMsgArgsDestroyTableNode

Detailed Description

SerialTerminalArgs: encapsulates serial terminal events

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SerialTerminalArg::SerialTerminalArg ( )

Member Function Documentation

const SerialTerminalArg & SerialTerminalArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SerialTerminal::Event& SerialTerminalArg::GetEvent ( ) const [inline]

SerialTerminal* SerialTerminalArg::GetTerminal ( ) const [inline]

void SerialTerminalArg::SetEvent ( const SerialTerminal::Event & event ) [inline]

void SerialTerminalArg::SetTerminal ( SerialTerminal * terminal ) [inline]

Friends And Related Function Documentation

friend class SerialTerminalMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/MmCall/SerialTerminalArg.hpp
  • AddOns/MmCall/SerialTerminalArg.cpp
Generated on Wed Jan 25 01:48:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialTerminalListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialTerminalListener Class Reference

#include <Apoxi/AddOns/MmCall/SerialTerminalListener.hpp>

Inheritance diagram for SerialTerminalListener:

[legend]

Public Member Functions

virtual void | OnTerminalEvent (SerialTerminal &terminal, SerialTerminal::Event event)=0
SerialTerminalListener ()
Constructor.
virtual | ~SerialTerminalListener ()
Destructor.

Detailed Description

The abstract class SerialTerminalListener is the base for terminal listeners. It defines a call-back interface which is used by the terminal to notify the listener about terminal events.

Constructor & Destructor Documentation

SerialTerminalListener::SerialTerminalListener ( )

Constructor.

SerialTerminalListener::~SerialTerminalListener ( ) [virtual]

Destructor.

Member Function Documentation

virtual void SerialTerminalListener::OnTerminalEvent | ( | SerialTerminal & | terminal,
 |  | SerialTerminal::Event | event
 | ) | [pure virtual]

Call-back method for terminal events

Parameters:
terminal | Terminal which caused event
event | Occured event

Implemented in MmCallSerialTerminalListener, and SocketSerialTerminalListener.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/SerialTerminalListener.hpp
  • AddOns/MmCall/SerialTerminalListener.cpp
Generated on Wed Jan 25 01:48:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialTerminalMsgArgsDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialTerminalMsgArgsDestroyTableNode Class Reference

#include <Apoxi/AddOns/MmCall/SerialTerminalMsgArgs.hpp>

Inheritance diagram for SerialTerminalMsgArgsDestroyTableNode:

[legend]
Collaboration diagram for SerialTerminalMsgArgsDestroyTableNode:

[legend]

Static Public Member Functions

static SerialTerminalMsgArgsDestroyTableNode * GetInstance ()

Member Function Documentation

SerialTerminalMsgArgsDestroyTableNode * SerialTerminalMsgArgsDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/MmCall/SerialTerminalMsgArgs.hpp
  • AddOns/MmCall/SerialTerminalMsgArgs.cpp
Generated on Wed Jan 25 01:48:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialTerminalSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerialTerminalSocket Class Reference

#include <Apoxi/AddOns/MmCall/SerialTerminalSocket.hpp>

Inheritance diagram for SerialTerminalSocket:

[legend]
Collaboration diagram for SerialTerminalSocket:

[legend]

Public Types

typedef Socket | Base

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | IsBlocking () const
virtual BOOLEAN | IsOpen (void) const
virtual BOOLEAN | Open (void)
virtual INT | Read (void *buf, INT buflen)
SerialTerminalSocket ()
Constructor.
virtual BOOLEAN | SetBlocking (BOOLEAN block=0)
virtual void | SetSocketEventListener (SocketEventListener *listener)
void | SetTerminal (SerialTerminal *terminal)
virtual INT | Write (const void *buf, INT buflen)
virtual | ~SerialTerminalSocket ()
Destructor.

Protected Member Functions

SerialTerminal * | GetTerminal () const

Detailed Description

SerialTerminalSocket implements a socket interface to Serial terminal. Base class of MmCallServerSocket and MmCallSocket.

Member Typedef Documentation

typedef Socket SerialTerminalSocket::Base

Constructor & Destructor Documentation

SerialTerminalSocket::SerialTerminalSocket ( )

Constructor.

SerialTerminalSocket::~SerialTerminalSocket ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN SerialTerminalSocket::Close ( ) [virtual]

See also:
Socket::Close

Implements Socket.

SerialTerminal* SerialTerminalSocket::GetTerminal ( ) const [inline, protected]

Returns the serial terminal for data transfer;

BOOLEAN SerialTerminalSocket::IsBlocking ( ) const [virtual]

See also:
Socket::IsBlocking.

Implements Socket.

BOOLEAN SerialTerminalSocket::IsOpen ( void ) const [virtual]

See also:
Socket::IsOpen

Implements Socket.

BOOLEAN SerialTerminalSocket::Open ( void ) [virtual]

See also:
Socket::Open

INT SerialTerminalSocket::Read | ( | void * | buf,
 |  | INT | buflen
 | ) | [virtual]

Read data from the socket

Parameters:
buf | pointer to the read buffer
buflen | length of buffer
Returns:
Number of bytes read or -1 on failure.

Implements Socket.

BOOLEAN SerialTerminalSocket::SetBlocking ( BOOLEAN block = 0 ) [virtual]

See also:
Socket::Close

Implements Socket.

void SerialTerminalSocket::SetSocketEventListener ( SocketEventListener * listener ) [virtual]

Set the socket listener to receive callbacks, when socket events occour. The application holding the listener and the observed socket must be within the same application context!

Parameters:
listener the MmCallSocketListener

Reimplemented from Socket.

void SerialTerminalSocket::SetTerminal ( SerialTerminal * terminal )

Set the terminal which is used by the socket for data transfer Read and Write at the socket fail if terminal is not propperly set. The client application of the socket has to take care about correct obtaining an releasing of the terminal. The SocketEventListener of the socket must be set to a valid SocketEventListener (!0) before the terminal can be set.

INT SerialTerminalSocket::Write | ( | const void * | buf,
 |  | INT | buflen
 | ) | [virtual]

Write data to the buffer

Parameters:
buf | pointer to the read buffer
buflen | length of buffer
Returns:
Number of bytes written or -1 on failure.

Implements Socket.

The documentation for this class was generated from the following files:
  • AddOns/MmCall/SerialTerminalSocket.hpp
  • AddOns/MmCall/SerialTerminalSocket.cpp
Generated on Wed Jan 25 01:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerSettingsTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SerSettingsTable Class Reference
[DataConn]

#include <Applications/DataConn/DataConnTextMaps.hpp>

Inheritance diagram for SerSettingsTable:

[legend]
Collaboration diagram for SerSettingsTable:

[legend]

Static Public Member Functions

static const WCHAR * GetSetting (DataConnApp::SerSettingsTypeId setting)

Member Function Documentation

static const WCHAR* SerSettingsTable::GetSetting ( DataConnApp::SerSettingsTypeId setting ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/DataConn/DataConnTextMaps.hpp
  • Applications/DataConn/DataConnTextMaps.cpp
Generated on Wed Jan 25 01:48:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Server Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Server Class Reference
[SERVER]

#include <Apoxi/AddOns/Server/Server.hpp>

Inheritance diagram for Server:

[legend]
Collaboration diagram for Server:

[legend]

Public Member Functions

virtual INT | GetBacklog ()
virtual ServerClient * | GetClient (UINT clientId)
virtual UINT | GetClientCount ()
virtual UINT | GetMaxUsers ()
virtual BOOLEAN | IsRunning ()
Server (AuthProvider *authProvider, ServerConfig *serverConfig, UINT maxUsers=APOXI_SERVER_DEFAULT_MAX_USERS, INT backlog=APOXI_SERVER_DEFAULT_BACKLOG)
virtual void | SetBacklog (INT backlog)
virtual void | SetMaxUsers (UINT maxUsers)
virtual void | Start (const InetSocketAddr &localAddr, DataConnProfileId dataConnProfileId=c_invalid_data_conn_profile_id)=0
virtual void | Stop ()=0
virtual | ~Server ()=0

Protected Member Functions

virtual BOOLEAN | AddClient (ServerClient *client)
virtual AuthProviderPtr | GetAuthProvider ()
virtual IpAddr | GetHostIp ()=0
virtual IpPortNo | GetPort ()=0
virtual ServerConfigPtr | GetServerConfig ()
virtual void | Init ()=0
virtual void | SetAuthProvider (AuthProviderPtr authProvider)
virtual void | SetServerConfig (ServerConfigPtr serverConfig)
virtual void | Terminate ()=0

Protected Attributes

AuthProviderPtr m_authProvider
INT | m_backlog
SimpleMap< UINT, ServerClient * > | m_clients
UINT | m_maxUsers
BOOLEAN | m_running
ServerConfigPtr m_serverConfig

Constructor & Destructor Documentation

Server::Server | ( | AuthProvider * | authProvider,
 |  | ServerConfig * | serverConfig,
 |  | UINT | maxUsers = APOXI_SERVER_DEFAULT_MAX_USERS,
 |  | INT | backlog = APOXI_SERVER_DEFAULT_BACKLOG
 | ) |

Server::~Server ( ) [pure virtual]

Member Function Documentation

BOOLEAN Server::AddClient ( ServerClient * client ) [protected, virtual]

AuthProviderPtr Server::GetAuthProvider ( ) [protected, virtual]

INT Server::GetBacklog ( ) [virtual]

Gets the value for backlog of FtpServerSocket when listening.

Returns:
Value for backlog of FtpServerSocket when listening.

ServerClient * Server::GetClient ( UINT clientId ) [virtual]

Returns the pointer to the according ServerClient object.

Parameters:
clientId ID of the client.
Returns:
Pointer to the ServerClient object.

Reimplemented in FtpServer, and HttpServer.

UINT Server::GetClientCount ( ) [virtual]

Returns the number of currently connected clients.

Returns:
Number of connected clients.

virtual IpAddr Server::GetHostIp ( ) [protected, pure virtual]

Implemented in FtpServer, and HttpServer.

UINT Server::GetMaxUsers ( ) [virtual]

Gets the maximum amount of currently connected clients.

Returns:
Maximum of currently connected clients.

virtual IpPortNo Server::GetPort ( ) [protected, pure virtual]

Implemented in FtpServer, and HttpServer.

ServerConfigPtr Server::GetServerConfig ( ) [protected, virtual]

virtual void Server::Init ( ) [protected, pure virtual]

Implemented in FtpServer, and HttpServer.

virtual BOOLEAN Server::IsRunning ( ) [inline, virtual]

Returns whether the server is currently running or not.

Returns:
Whether the server is running or not.

void Server::SetAuthProvider ( AuthProviderPtr authProvider ) [protected, virtual]

void Server::SetBacklog ( INT backlog ) [virtual]

Gets the value for backlog of FtpServerSocket when listening.

Returns:
Value for backlog of FtpServerSocket when listening.

void Server::SetMaxUsers ( UINT maxUsers ) [virtual]

Gets the maximum amount of currently connected clients.

Returns:
Maximum of currently connected clients.

void Server::SetServerConfig ( ServerConfigPtr serverConfig ) [protected, virtual]

virtual void Server::Start | ( | const InetSocketAddr & | localAddr,
 |  | DataConnProfileId | dataConnProfileId = c_invalid_data_conn_profile_id
 | ) | [pure virtual]

Public service interface. The implementation has to send messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Parameters:
localAddr | Socket address to bind to.
dataConnProfileId | ID of the DataConn to use for opening sockets.

Implemented in FtpServer, and HttpServer.

virtual void Server::Stop ( ) [pure virtual]

Public service interface. The implementation has to send messages to the server itself to prevent ExecutionContext problems and handling all socket events in the server.

Implemented in FtpServer, and HttpServer.

virtual void Server::Terminate ( ) [protected, pure virtual]

Implemented in FtpServer, and HttpServer.

Field Documentation

AuthProviderPtr Server::m_authProvider [protected]

INT Server::m_backlog [protected]

SimpleMap<UINT, ServerClient*> Server::m_clients [protected]

UINT Server::m_maxUsers [protected]

BOOLEAN Server::m_running [protected]

Reimplemented from ServiceThread.

ServerConfigPtr Server::m_serverConfig [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/Server.hpp
  • AddOns/Server/Server.cpp
Generated on Wed Jan 25 01:48:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServerAddressWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServerAddressWin Class Reference

#include <Applications/LcsTransports/Settings/ServerAddressWin.hpp>

Collaboration diagram for ServerAddressWin:

[legend]

Public Member Functions

void | Init ()
ServerAddressWin ()
Contructor.
virtual | ~ServerAddressWin ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual void | OnClose ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnOpen ()

Detailed Description

This window takes the followinf server addresses from the user 1. GL Server IP address 2. Where Am I server address 3. Friend Finder server address

Constructor & Destructor Documentation

ServerAddressWin::ServerAddressWin ( )

Contructor.

ServerAddressWin::~ServerAddressWin ( ) [virtual]

Destructor.

Member Function Documentation

void ServerAddressWin::Init ( )

BOOLEAN ServerAddressWin::OnCancel ( ) [protected, virtual]

void ServerAddressWin::OnClose ( ) [protected, virtual]

BOOLEAN ServerAddressWin::OnConfirm ( ) [protected, virtual]

void ServerAddressWin::OnLayoutClient ( ) [protected, virtual]

void ServerAddressWin::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/LcsTransports/Settings/ServerAddressWin.hpp
  • Applications/LcsTransports/Settings/ServerAddressWin.cpp
Generated on Wed Jan 25 01:48:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServerClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServerClient Class Reference
[SERVER]

#include <Apoxi/AddOns/Server/ServerClient.hpp>

Inheritance diagram for ServerClient:

[legend]
Collaboration diagram for ServerClient:

[legend]

Public Member Functions

virtual UINT | GetId ()
virtual | ~ServerClient ()

Protected Member Functions

ServerClient (Server *server)

Protected Attributes

UINT | m_clientId
Server * m_server

Static Protected Attributes

static UINT | s_instance_cnt = 0

Friends

class | Server

Constructor & Destructor Documentation

ServerClient::~ServerClient ( ) [virtual]

ServerClient::ServerClient ( Server * server ) [protected]

Member Function Documentation

UINT ServerClient::GetId ( ) [virtual]

Reimplemented in FtpClient, and HttpClient.

Friends And Related Function Documentation

friend class Server [friend]

Field Documentation

UINT ServerClient::m_clientId [protected]

Server* ServerClient::m_server [protected]

UINT ServerClient::s_instance_cnt = 0 [static, protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/ServerClient.hpp
  • AddOns/Server/ServerClient.cpp
Generated on Wed Jan 25 01:48:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServerConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServerConfig Class Reference
[SERVER]

#include <Apoxi/AddOns/Server/ServerConfig.hpp>

Inheritance diagram for ServerConfig:

[legend]
Collaboration diagram for ServerConfig:

[legend]

Public Member Functions

virtual INT | GetBacklog ()
virtual DataConnProfileId | GetDataConnProfileId ()
virtual UINT | GetMaxUsers ()
virtual const Pathname & | GetRootDir ()
ServerConfig ()
virtual void | SetBacklog (INT backlog)
virtual void | SetDataConnProfileId (DataConnProfileId dataConnProfileId)
virtual void | SetMaxUsers (UINT maxUsers)
virtual void | SetRootDir (Pathname rootDir)
virtual | ~ServerConfig ()

Protected Attributes

INT | m_backlog
DataConnProfileId m_dataConnProfileId
UINT | m_maxUsers
Pathname m_rootDir

Constructor & Destructor Documentation

ServerConfig::ServerConfig ( )

Constructor. Initializes all member variables with the default values.

ServerConfig::~ServerConfig ( ) [virtual]

Destructor. Deallocates used resources.

Member Function Documentation

INT ServerConfig::GetBacklog ( ) [virtual]

Returns the value for the backlog of the listening TcpServerSocket.

Returns:
Value for backlog.

DataConnProfileId ServerConfig::GetDataConnProfileId ( ) [virtual]

Returns the ID of the DataConnProfile to use for socket connections.

Returns:
ID of the DataConnProfile to use.

UINT ServerConfig::GetMaxUsers ( ) [virtual]

Returns the maximum number of currently connected clients.

Returns:
Maximum number of clients.

const Pathname & ServerConfig::GetRootDir ( ) [virtual]

Returns the root directory of the server.

Returns:
Root directory of the server.

void ServerConfig::SetBacklog ( INT backlog ) [virtual]

Sets the value for the backlog of the listening TcpServerSocket.

Parameters:
backlog New value for backlog.

void ServerConfig::SetDataConnProfileId ( DataConnProfileId dataConnProfileId ) [virtual]

Sets the ID of the DataConnProfile to use for socket connections.

Parameters:
dataConnProfileId New DataConnProfileId to set.

void ServerConfig::SetMaxUsers ( UINT maxUsers ) [virtual]

Sets the maximum number of currently connected clients.

Parameters:
maxUsers New maximum number of clients.

void ServerConfig::SetRootDir ( Pathname rootDir ) [virtual]

Sets the root directory of the server.

Parameters:
rootDir New root directory to set.

Field Documentation

INT ServerConfig::m_backlog [protected]

DataConnProfileId ServerConfig::m_dataConnProfileId [protected]

UINT ServerConfig::m_maxUsers [protected]

Pathname ServerConfig::m_rootDir [protected]

The documentation for this class was generated from the following files:
  • AddOns/Server/ServerConfig.hpp
  • AddOns/Server/ServerConfig.cpp
Generated on Wed Jan 25 01:48:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Service Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Service Class Reference
[Services]

#include <Apoxi/AddOns/Services/Service.hpp>

Inheritance diagram for Service:

[legend]
Collaboration diagram for Service:

[legend]

Public Types

enum | ServiceResult { ServResSuccess, ServResError }

Public Member Functions

const Guid & | GetGuid () const
Service (Guid guid)
Automatically registeres the service to the service broker.
virtual | ~Service ()

Detailed Description

A service is an abstract interface which can be accessed by a global unique ID (GUID). The implementation of a service is mostly done by an application, which implements the pure virtual methods of a service.

Accessing a service is done by the ServiceBroker, where each service automatically is registered if available.

A service is meant for communication between applications, where it is not defined which application implements which kind of service. So when an application wants to access a service, it asks whether the service is available at all by invoking

ServiceBroker* broker = ServiceBroker::GetBroker(); if (broker != 0) ServicePtr<MyService> service = broker->GetService(MyService::GUID);

If 'service' is not 0, the service is available and the service methods may get invoked. The benefit of this approach is that one application does not require another application to work. So applications just rely on services: if a service is not available a functionality won't be available, but the application will still work with it's core set.

All implementations of service methods must be implemented in a thread safe manner. It is recommended to implement this by posting messages to the application which implements the service, where the code is executed in the context of the application after receiving the message.

See also:
ServiceBroker

Member Enumeration Documentation

enum Service::ServiceResult

Enumerator:
ServResSuccess
ServResError

Constructor & Destructor Documentation

Service::Service ( Guid guid )

Automatically registeres the service to the service broker.

Service::~Service ( ) [virtual]

Member Function Documentation

const Guid & Service::GetGuid ( ) const

The documentation for this class was generated from the following files:
  • AddOns/Services/Service.hpp
  • AddOns/Services/Service.cpp
Generated on Wed Jan 25 01:48:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServiceBroker Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServiceBroker Class Reference
[Services]

#include <Apoxi/AddOns/Services/ServiceBroker.hpp>

Collaboration diagram for ServiceBroker:

[legend]

Public Types

typedef LinkedList< Service > | ServiceList

Public Member Functions

Service * | GetService (const Guid &guid)
BOOLEAN | IsServiceSupported (const Guid &guid)
void | RegisterService (Service *service)
void | UnregisterService (Service *service)

Static Public Member Functions

static ServiceBroker * | GetBroker ()
static void | Release ()

Friends

class | Service
class | ServiceBrokerDestructor

Data Structures

class | ServiceBrokerDestructor

Detailed Description

The service broker allows to retrieve a specific kind of service which is identified by a global unique identifier (GUID). All available services are registered to the service broker. For more details about a service have a look at the class Service.

See also:
Service

Member Typedef Documentation

typedef LinkedList<Service> ServiceBroker::ServiceList

Member Function Documentation

ServiceBroker * ServiceBroker::GetBroker ( ) [static]

Returns a pointer to the service broker instance. Usually a service broker will be always available, but checking for 0 is mandatory.

Service * ServiceBroker::GetService ( const Guid & guid )

Returns a pointer to the service which is specified by the given GUID. If the service is not available, 0 is returned. It is recommended to use the ServicePtr, which automatically does a cast to the service interface: ServicePtr<MyService> service = broker->GetService(MyService::GUID);

BOOLEAN ServiceBroker::IsServiceSupported ( const Guid & guid )

Returns TRUE, if the service with the given GUID is available.

void ServiceBroker::RegisterService ( Service * service )

void ServiceBroker::Release ( ) [static]

void ServiceBroker::UnregisterService ( Service * service )

Friends And Related Function Documentation

friend class Service [friend]

friend class ServiceBrokerDestructor [friend]

The documentation for this class was generated from the following files:
  • AddOns/Services/ServiceBroker.hpp
  • AddOns/Services/ServiceBroker.cpp
Generated on Wed Jan 25 01:48:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServiceProviderStruct Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServiceProviderStruct Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 | dsplcond
UINT8 | name [16]

Field Documentation

UINT8 ServiceProviderStruct::dsplcond

UINT8 ServiceProviderStruct::name[16]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:48:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServicePtr< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServicePtr< T > Class Template Reference
[Services]

#include <Apoxi/AddOns/Services/Service.hpp>

Collaboration diagram for ServicePtr< T >:

[legend]

Public Member Functions

void | Init (Service *serv_ptr)
T & | operator * ()
BOOLEAN | operator!= (const ServicePtr< T > &s) const
T * | operator-> () const
ServicePtr< T > | operator= (const Service *s)
BOOLEAN | operator== (const ServicePtr< T > &s) const
ServicePtr (Service *serv_ptr)
ServicePtr ()

template<class T>
class ServicePtr< T >

Constructor & Destructor Documentation

template<class T>
ServicePtr< T >::ServicePtr ( ) [inline]

template<class T>
ServicePtr< T >::ServicePtr ( Service * serv_ptr ) [inline]

Member Function Documentation

template<class T>
void ServicePtr< T >::Init ( Service * serv_ptr ) [inline]

template<class T>
T& ServicePtr< T >::operator * ( ) [inline]

template<class T>
BOOLEAN ServicePtr< T >::operator!= ( const ServicePtr< T > & s ) const [inline]

template<class T>
T* ServicePtr< T >::operator-> ( ) const [inline]

template<class T>
ServicePtr<T> ServicePtr< T >::operator= ( const Service * s ) [inline]

template<class T>
BOOLEAN ServicePtr< T >::operator== ( const ServicePtr< T > & s ) const [inline]

The documentation for this class was generated from the following file:
  • AddOns/Services/Service.hpp
Generated on Wed Jan 25 01:48:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServiceThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServiceThread Class Reference
[Kernel]

Class ServiceThread is used to implement services, i.e. tasks which perform permanent background activity like network services. A service thread does not need any graphical user interface but needs to run as an own thread. It only always awakes from idle when it receives a message or when a timer expires. To handle the message overwrite method OnMessage(). For an automated start-up and shut-down of the service thread use class ServiceThreadStarter. More...

#include <Apoxi/Kernel/ServiceThread.hpp>

Inheritance diagram for ServiceThread:

[legend]
Collaboration diagram for ServiceThread:

[legend]

Public Member Functions

virtual ExecutionContext::Type | GetType () const
virtual void | RegisterMessage (MsgId msg_id)
BOOLEAN | Run (UINT32 stacksize=4096, void *stack=0)
ServiceThread ()
void | Stop (INT exit_code=0)
virtual void | UnregisterMessage (MsgId msg_id)
virtual | ~ServiceThread ()

Protected Member Functions

virtual BOOLEAN | AcceptMsg (const Message &msg)
virtual void | AddTimer (Timer &timer)
virtual BOOLEAN | HandleMsg (const MessageReferrer &msg_ref)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnPowerDown ()
virtual void | OnPowerUp ()
virtual BOOLEAN | OnTimeout (const Timer &timer)
virtual void | RemoveTimer (Timer &timer)

Friends

class | StartUp

Detailed Description

Class ServiceThread is used to implement services, i.e. tasks which perform permanent background activity like network services. A service thread does not need any graphical user interface but needs to run as an own thread. It only always awakes from idle when it receives a message or when a timer expires. To handle the message overwrite method OnMessage(). For an automated start-up and shut-down of the service thread use class ServiceThreadStarter.

Usage of ServiceThreads

1. Derive your class from ServiceThread and overwrite the following protected methods:

    virtual void OnPowerUp();                   // add the initialization code here
    virtual void OnPowerDown();                 // add the finalization code here
    virtual BOOLEAN OnMessage(const Message& msg);      // handle the messages here

For handling the messages it is also possible to write an own UserDispatcher instead of overwriting OnMessage and add it to the service thread by calling GetContext().AddDispatcher(&my_disp).

2. For automated startup and shutdown of the service thread use class ServiceThreadStarter and add the following code to any module which will not be removed by the linker:

    static ServiceThreadStarter g_my_service_starter(MyServiceThread::GetInstance());

Constructor & Destructor Documentation

ServiceThread::ServiceThread ( )

ServiceThread::~ServiceThread ( ) [virtual]

Member Function Documentation

BOOLEAN ServiceThread::AcceptMsg ( const Message & msg ) [protected, virtual]

Tells if msg is accepted.

Implements ExecutionContext.

void ServiceThread::AddTimer ( Timer & timer ) [protected, virtual]

Adds the timer to the context.

Implements ExecutionContext.

ExecutionContext::Type ServiceThread::GetType ( ) const [virtual]

See also:
ExecutionContext::GetType

Implements ExecutionContext.

BOOLEAN ServiceThread::HandleMsg ( const MessageReferrer & msg_ref ) [protected, virtual]

Handles the message which the message referrer msg_ref points to.

Implements ExecutionContext.

BOOLEAN ServiceThread::OnMessage ( const Message & msg ) [protected, virtual]

Reimplemented in FtpServer, HttpServer, and SimTkLceService.

void ServiceThread::OnPowerDown ( ) [protected, virtual]

This method is called when stopping a ServiceThread.

Reimplemented in SimTkLceService.

void ServiceThread::OnPowerUp ( ) [protected, virtual]

This method is called when starting a ServiceThread.

Reimplemented in SimTkLceService.

BOOLEAN ServiceThread::OnTimeout ( const Timer & timer ) [protected, virtual]

void ServiceThread::RegisterMessage ( MsgId msg_id ) [virtual]

See also:
ExecutionContext::RegisterMessage

Implements ExecutionContext.

void ServiceThread::RemoveTimer ( Timer & timer ) [protected, virtual]

Removes the timer from the context.

Implements ExecutionContext.

BOOLEAN ServiceThread::Run | ( | UINT32 | stacksize = 4096,
 |  | void * | stack = 0
 | ) |

See also:
Thread::Run

Reimplemented from Thread.

void ServiceThread::Stop ( INT exit_code = 0 )

Stops the service thread by sending the ServiceThreadTerminateMsg to itself. After receiving this message ServiceThread::OnPowerDown is called and the thread terminates.

void ServiceThread::UnregisterMessage ( MsgId msg_id ) [virtual]

See also:
ExecutionContext::UnregisterMessage

Implements ExecutionContext.

Friends And Related Function Documentation

friend class StartUp [friend]

The documentation for this class was generated from the following files:
  • Kernel/ServiceThread.hpp
  • Kernel/ServiceThread.cpp
Generated on Wed Jan 25 01:48:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServiceThreadStarter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServiceThreadStarter Class Reference
[Kernel]

#include <Apoxi/Kernel/ServiceThreadStarter.hpp>

Inheritance diagram for ServiceThreadStarter:

[legend]
Collaboration diagram for ServiceThreadStarter:

[legend]

Public Member Functions

ServiceThreadStarter (ServiceThread &service_thread, StartParam *param=0)
virtual | ~ServiceThreadStarter ()

Data Structures

struct | StartParam

Detailed Description

To run an own implemented thread derived from class ServiceThread it is necessary to place some start-up and shut-down code. When using a static instance of ServiceThreadStarter this is done automatically by using a SubSystem. It has only to be used static because otherwise the SubSystem/ServiceThread will not be started!
Example:
    static ServiceThreadStarter my_starter(my_service_thread);

Constructor & Destructor Documentation

ServiceThreadStarter::ServiceThreadStarter | ( | ServiceThread & | service_thread,
 |  | StartParam * | param = 0
 | ) |

Parameters:
service_thread | ServiceThread to start and stop automatically.
param | Pointer to StartParam structure which must be static.

ServiceThreadStarter::~ServiceThreadStarter ( ) [virtual]

The documentation for this class was generated from the following files:
  • Kernel/ServiceThreadStarter.hpp
  • Kernel/ServiceThreadStarter.cpp
Generated on Wed Jan 25 01:48:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServiceThreadStarter::StartParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ServiceThreadStarter::StartParam

ServiceThreadStarter::StartParam Struct Reference

#include <Apoxi/Kernel/ServiceThreadStarter.hpp>

Data Fields

INT | priority
SubSystemManager::BootSequenceState run_level
void * | stack
UINT32 | stacksize

Detailed Description

Start parameter for the service thread.

Field Documentation

INT ServiceThreadStarter::StartParam::priority

SubSystemManager::BootSequenceState ServiceThreadStarter::StartParam::run_level

Stack pointer for the service thread. See Thread::Run

void* ServiceThreadStarter::StartParam::stack

Stack size for the service thread. See Thread::Run

UINT32 ServiceThreadStarter::StartParam::stacksize

Priority level for the service thread. See Thread::PriorityLevel.

The documentation for this struct was generated from the following file:
  • Kernel/ServiceThreadStarter.hpp
Generated on Wed Jan 25 01:48:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ServiceThreadTerminateMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ServiceThreadTerminateMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ServiceThreadTerminateMsg:

[legend]
Collaboration diagram for ServiceThreadTerminateMsg:

[legend]

Public Types

enum | { ID = 102 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
ServiceThreadTerminateMsg (ExecutionContext *context)
virtual | ~ServiceThreadTerminateMsg ()

Detailed Description

This message will be sent when terminating a ServiceThread.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ServiceThreadTerminateMsg::ServiceThreadTerminateMsg ( ExecutionContext * context )

ServiceThreadTerminateMsg::~ServiceThreadTerminateMsg ( ) [virtual]

Member Function Documentation

Message * ServiceThreadTerminateMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ServiceThreadTerminateMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:48:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetAutoChargeArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetAutoChargeArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for SetAutoChargeArg:

[legend]
Collaboration diagram for SetAutoChargeArg:

[legend]

Public Types

enum | { ID = 2061 }

Public Member Functions

BOOLEAN | IsActivateReporting () const
void | SetActivateReporting (BOOLEAN activate_reporting)
SetAutoChargeArg ()
SetAutoChargeArg (BOOLEAN activate_reporting)

Static Public Member Functions

static const SetAutoChargeArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SetAutoChargeArg: reflects arguments of signal MN_SET_AUTO_CHARGE

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SetAutoChargeArg::SetAutoChargeArg ( BOOLEAN activate_reporting )

SetAutoChargeArg::SetAutoChargeArg ( )

Member Function Documentation

const SetAutoChargeArg & SetAutoChargeArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN SetAutoChargeArg::IsActivateReporting ( ) const [inline]

void SetAutoChargeArg::SetActivateReporting ( BOOLEAN activate_reporting ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:48:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetChargeUnitsArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetChargeUnitsArg Class Reference

#include <Apoxi/Apc/CrssStackMsgArgs.hpp>

Inheritance diagram for SetChargeUnitsArg:

[legend]
Collaboration diagram for SetChargeUnitsArg:

[legend]

Public Types

enum | { ID = 2063 }

Public Member Functions

BOOLEAN | IsActivateReporting () const
void | SetActivateReporting (BOOLEAN activate_reporting)
SetChargeUnitsArg ()
SetChargeUnitsArg (BOOLEAN activate_reporting)

Static Public Member Functions

static const SetChargeUnitsArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SetChargeUnitsArg: reflects arguments of signal MN[MI]_SET_CHARGE_UNITS

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SetChargeUnitsArg::SetChargeUnitsArg ( BOOLEAN activate_reporting )

SetChargeUnitsArg::SetChargeUnitsArg ( )

Member Function Documentation

const SetChargeUnitsArg & SetChargeUnitsArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN SetChargeUnitsArg::IsActivateReporting ( ) const [inline]

void SetChargeUnitsArg::SetActivateReporting ( BOOLEAN activate_reporting ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CrssStackMsgArgs.hpp
  • Apc/CrssStackMsgArgs.cpp
Generated on Wed Jan 25 01:48:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetLanguageAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetLanguageAction Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/SetLanguageAction.hpp>

Inheritance diagram for SetLanguageAction:

[legend]
Collaboration diagram for SetLanguageAction:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
void | Init (INT lang_id, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
SetLanguageAction (INT lang_id, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
SetLanguageAction ()
virtual | ~SetLanguageAction ()

Detailed Description

Obsolete - use a simple Action instead and change the language by overwriting the method Window::OnActionExecuted.

Sets the language of the application to the language provided by the constructor or the method Init.

Constructor & Destructor Documentation

SetLanguageAction::SetLanguageAction ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

SetLanguageAction::SetLanguageAction | ( | INT | lang_id,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
lang_id Language-ID of the language, which should be set.

SetLanguageAction::~SetLanguageAction ( ) [virtual]

Member Function Documentation

BOOLEAN SetLanguageAction::Execute ( ) [virtual]

Sets the language to the language provided by the constructor or the method Init.

Reimplemented from Action.

void SetLanguageAction::Init | ( | INT | lang_id,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
lang_id Language-ID of the language, which should be set.

The documentation for this class was generated from the following files:
  • Compat/SetLanguageAction.hpp
  • Compat/SetLanguageAction.cpp
Generated on Wed Jan 25 01:48:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetThemeAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetThemeAction Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/SetThemeAction.hpp>

Inheritance diagram for SetThemeAction:

[legend]
Collaboration diagram for SetThemeAction:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
void | Init (INT theme_id, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
SetThemeAction (INT theme_id, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
SetThemeAction ()
virtual | ~SetThemeAction ()

Detailed Description

Obsolete - use a simple Action instead and change the theme by overwriting the method Window::OnActionExecuted.

Sets the theme to the theme provided by the constructor or the method Init.

Constructor & Destructor Documentation

SetThemeAction::SetThemeAction ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

SetThemeAction::SetThemeAction | ( | INT | theme_id,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
theme_id Theme-ID of the theme, which should be set.

SetThemeAction::~SetThemeAction ( ) [virtual]

Member Function Documentation

BOOLEAN SetThemeAction::Execute ( ) [virtual]

Sets the theme to the theme provided by the constructor or the method Init.

Reimplemented from Action.

void SetThemeAction::Init | ( | INT | theme_id,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
theme_id Theme-ID of the theme, which should be set.

The documentation for this class was generated from the following files:
  • Compat/SetThemeAction.hpp
  • Compat/SetThemeAction.cpp
Generated on Wed Jan 25 01:48:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SettingsProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SettingsProvider Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/SettingsProvider.hpp>

Inheritance diagram for SettingsProvider:

[legend]
Collaboration diagram for SettingsProvider:

[legend]

Public Member Functions

virtual Provider::Status | GetStatus () const
Returns the status of the provider.
virtual void | RestoreFactorySettings ()=0
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.

Member Function Documentation

virtual Provider::Status SettingsProvider::GetStatus ( ) const [inline, virtual]

Returns the status of the provider.

Reimplemented from Provider.

virtual void SettingsProvider::RestoreFactorySettings ( ) [pure virtual]

Implemented in BtHfProvider, SmsSettingsProvider, FmRadioSettingsProvider, FmRadioStationsProvider, ToDoProvider, and UibSettingsProvider.

INT SettingsProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

Reimplemented in SmsSettingsProvider, FmRadioStationsProvider, ToDoProvider, and UibSettingsProvider.

BOOLEAN SettingsProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

Reimplemented in SmsSettingsProvider, and FmRadioStationsProvider.

The documentation for this class was generated from the following files:
  • Atl/SettingsProvider.hpp
  • Atl/SettingsProvider.cpp
Generated on Wed Jan 25 01:48:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetupDataConnMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetupDataConnMsg Class Reference

#include <Apoxi/AddOns/Lcs/GLTP/GltpMsgTypes.hpp>

Inheritance diagram for SetupDataConnMsg:

[legend]
Collaboration diagram for SetupDataConnMsg:

[legend]

Public Types

enum | { ID = 4230 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SetupDataConnMsg (ExecutionContext *context)
virtual | ~SetupDataConnMsg ()

Detailed Description

This message informs the GLTP connection application to setup a data connection to the GL server

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SetupDataConnMsg::SetupDataConnMsg ( ExecutionContext * context )

SetupDataConnMsg::~SetupDataConnMsg ( ) [virtual]

Member Function Documentation

Message * SetupDataConnMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SetupDataConnMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/Lcs/GLTP/GltpMsgTypes.hpp
  • AddOns/Lcs/GLTP/GltpMsgTypes.cpp
Generated on Wed Jan 25 01:48:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetupEventCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetupEventCnfArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SetupEventCnfArg:

[legend]
Collaboration diagram for SetupEventCnfArg:

[legend]

Public Types

enum | { ID = 2315 }

Public Member Functions

const SimTkTransactionId & | GetTid () const
BOOLEAN | IsAccept () const
void | SetAccept (BOOLEAN accept)
void | SetTid (const SimTkTransactionId &tid)
SetupEventCnfArg ()
SetupEventCnfArg (const SimTkTransactionId &tid, BOOLEAN accept)

Static Public Member Functions

static const SetupEventCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SetupEventCnfArg: reflects arguments of signal MISI_SET_UP_EVENT_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SetupEventCnfArg::SetupEventCnfArg | ( | const SimTkTransactionId & | tid,
 |  | BOOLEAN | accept
 | ) |

SetupEventCnfArg::SetupEventCnfArg ( )

Member Function Documentation

const SetupEventCnfArg & SetupEventCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkTransactionId& SetupEventCnfArg::GetTid ( ) const [inline]

BOOLEAN SetupEventCnfArg::IsAccept ( ) const [inline]

void SetupEventCnfArg::SetAccept ( BOOLEAN accept ) [inline]

void SetupEventCnfArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:48:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetupIdleModeTextReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetupIdleModeTextReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SetupIdleModeTextReqArg:

[legend]
Collaboration diagram for SetupIdleModeTextReqArg:

[legend]

Public Types

enum | { ID = 1314 }

Public Member Functions

const SimIconIdentifier & | GetIcon () const
const SimSetupIdleModeTextOptions & | GetOptions () const
const SimTextString & | GetTextString () const
const SimTkTransactionId & | GetTid () const
void | SetIcon (const SimIconIdentifier &icon)
void | SetOptions (const SimSetupIdleModeTextOptions &options)
void | SetTextString (const SimTextString &text_string)
void | SetTid (const SimTkTransactionId &tid)
SetupIdleModeTextReqArg ()

Static Public Member Functions

static const SetupIdleModeTextReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SetupIdleModeTextReqArg: reflects arguments of signal SI_SETUP_IDLEMODE_TEXT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SetupIdleModeTextReqArg::SetupIdleModeTextReqArg ( )

Member Function Documentation

const SetupIdleModeTextReqArg & SetupIdleModeTextReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconIdentifier& SetupIdleModeTextReqArg::GetIcon ( ) const [inline]

const SimSetupIdleModeTextOptions& SetupIdleModeTextReqArg::GetOptions ( ) const [inline]

const SimTextString& SetupIdleModeTextReqArg::GetTextString ( ) const [inline]

const SimTkTransactionId& SetupIdleModeTextReqArg::GetTid ( ) const [inline]

void SetupIdleModeTextReqArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void SetupIdleModeTextReqArg::SetOptions ( const SimSetupIdleModeTextOptions & options ) [inline]

void SetupIdleModeTextReqArg::SetTextString ( const SimTextString & text_string ) [inline]

void SetupIdleModeTextReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:48:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetupIdleModeTextRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetupIdleModeTextRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SetupIdleModeTextRspArg:

[legend]
Collaboration diagram for SetupIdleModeTextRspArg:

[legend]

Public Types

enum | { ID = 2314 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)
SetupIdleModeTextRspArg ()
SetupIdleModeTextRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)

Static Public Member Functions

static const SetupIdleModeTextRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SetupIdleModeTextRspArg: reflects arguments of signal SI_SETUP_IDLEMODE_TEXT_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SetupIdleModeTextRspArg::SetupIdleModeTextRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

SetupIdleModeTextRspArg::SetupIdleModeTextRspArg ( )

Member Function Documentation

const SetupIdleModeTextRspArg & SetupIdleModeTextRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SetupIdleModeTextRspArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& SetupIdleModeTextRspArg::GetTid ( ) const [inline]

void SetupIdleModeTextRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SetupIdleModeTextRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:48:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetupMenuReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetupMenuReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SetupMenuReqArg:

[legend]
Collaboration diagram for SetupMenuReqArg:

[legend]

Public Types

enum | { ID = 1311 }

Public Member Functions

const SimIconIdentifier & | GetIconList () const
const SimItemIdentifierList & | GetItemList () const
const SimNextActionIdentifier & | GetItemsNai () const
const SimSetupMenuOptions & | GetOptions () const
const SimTkTransactionId & | GetTid () const
const SimAlphaIdentifier & | GetTitleAlpha () const
const SimIconIdentifier & | GetTitleIcon () const
void | SetIconList (const SimIconIdentifier &icon_list)
void | SetItemList (const SimItemIdentifierList &item_list)
void | SetItemsNai (const SimNextActionIdentifier &items_nai)
void | SetOptions (const SimSetupMenuOptions &options)
void | SetTid (const SimTkTransactionId &tid)
void | SetTitleAlpha (const SimAlphaIdentifier &title_alpha)
void | SetTitleIcon (const SimIconIdentifier &title_icon)
SetupMenuReqArg ()

Static Public Member Functions

static const SetupMenuReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SetupMenuReqArg: reflects arguments of signal SI_SETUP_MENU_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SetupMenuReqArg::SetupMenuReqArg ( )

Member Function Documentation

const SetupMenuReqArg & SetupMenuReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconIdentifier& SetupMenuReqArg::GetIconList ( ) const [inline]

const SimItemIdentifierList& SetupMenuReqArg::GetItemList ( ) const [inline]

const SimNextActionIdentifier& SetupMenuReqArg::GetItemsNai ( ) const [inline]

const SimSetupMenuOptions& SetupMenuReqArg::GetOptions ( ) const [inline]

const SimTkTransactionId& SetupMenuReqArg::GetTid ( ) const [inline]

const SimAlphaIdentifier& SetupMenuReqArg::GetTitleAlpha ( ) const [inline]

const SimIconIdentifier& SetupMenuReqArg::GetTitleIcon ( ) const [inline]

void SetupMenuReqArg::SetIconList ( const SimIconIdentifier & icon_list ) [inline]

void SetupMenuReqArg::SetItemList ( const SimItemIdentifierList & item_list ) [inline]

void SetupMenuReqArg::SetItemsNai ( const SimNextActionIdentifier & items_nai ) [inline]

void SetupMenuReqArg::SetOptions ( const SimSetupMenuOptions & options ) [inline]

void SetupMenuReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

void SetupMenuReqArg::SetTitleAlpha ( const SimAlphaIdentifier & title_alpha ) [inline]

void SetupMenuReqArg::SetTitleIcon ( const SimIconIdentifier & title_icon ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:48:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SetupMenuRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SetupMenuRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SetupMenuRspArg:

[legend]
Collaboration diagram for SetupMenuRspArg:

[legend]

Public Types

enum | { ID = 2311 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)
SetupMenuRspArg ()
SetupMenuRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)

Static Public Member Functions

static const SetupMenuRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SetupMenuRspArg: reflects arguments of signal SI_SETUP_MENU_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SetupMenuRspArg::SetupMenuRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

SetupMenuRspArg::SetupMenuRspArg ( )

Member Function Documentation

const SetupMenuRspArg & SetupMenuRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SetupMenuRspArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& SetupMenuRspArg::GetTid ( ) const [inline]

void SetupMenuRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SetupMenuRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SharedMemHdl Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SharedMemHdl Struct Reference

#include <Apoxi/Kernel/Os/Win32/Win32.hpp>

Data Fields

HANDLE hdl

Field Documentation

HANDLE SharedMemHdl::hdl

The documentation for this struct was generated from the following file:
  • Kernel/Os/Win32/Win32.hpp
Generated on Wed Jan 25 01:48:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SharedPtr< T_obj > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SharedPtr< T_obj > Class Template Reference
[Devices]

#include <Apoxi/Auxiliary/SharedPtr.hpp>

Inheritance diagram for SharedPtr< T_obj >:

[legend]
Collaboration diagram for SharedPtr< T_obj >:

[legend]

Public Member Functions

virtual void | Clear ()
const T_obj & | operator * () const
T_obj & | operator * ()
operator bool () const
bool | operator!= (const SharedPtr< T_obj > &src) const
Compare the underlying pointers for inequality.
T_obj * | operator-> () const
SharedPtr & | operator= (const SharedPtr< T_obj > &src)
Share ownership.
bool | operator== (const SharedPtr< T_obj > &src) const
Compare the underlying pointers for equality.
SharedPtr (const SharedPtr< T_obj > &src)
SharedPtr (T_obj *pobj)
SharedPtr ()
virtual | ~SharedPtr ()
Copy from different, but castable type.

Protected Member Functions

void | Ref ()
void | Unref ()

Protected Attributes

T_obj * | m_pobj

Detailed Description

template<typename T_obj>
class SharedPtr< T_obj >

A shared reference-counting smart-pointer. For use only with classes that derive from ReferableObject. This is not a real smart-pointer, because the target compilers do not all support templated copy constructors and operator=. This means that you cannot cast an instance of the smart-pointer to a related instance of another smart-pointer. Therefore, methods should never take SmartPointers, but a reference to the underlying type instead. Yes, this is unusual, and requires care. For instance: SharedPtr<Derived> derived = something.GetSomething(); somethingelse.SetSomething(*derived);

Note the alternative is to not use a smart-pointer and to require manual reference-counting. Note that the reference-counting should not really be in the underlying object, but in smart-pointer. Unfortunately in this case it must be in the object (Referable) because we must sometimes create a second smart-pointer to the same underlying object without using the copy constructor.

Boring technical details:

Question: Why can't I implicitly cast a SharedPtr-of-a-derived-class to a SharedPtr-of-a-base-class? Answer: Because that needs a templated copy constructor (a copy constructor that can take any type as the source object), but the compiler does not support templated methods of templated classes. This is easy and normal with standards-compliant compilers.

Question: Why can't I explicitly cast a SharedPtr-of-a-derived-class to a SharedPtr-of-a-base-class, or in the other direction? Answer: Again, that would require a templated method of a templated class, which the compiler does not support.

Question: So, how do I cast a SharedPtr-of-class-A to a SharedPtr-of-a-class-B? Answer: It's ugly, so we try to keep this inside APOXI implementation code.

You need to do this: SharedPtr refA = get_something(); // Function get_something() actually returns a B*. SharedPtr refB = SharedPtr (static_cast<B*>(&(*refA))); // Cast from A* to B*. The second statement

  • dereferences the refA to get A&, with the * dereference operator. This is just like dereferencing a normal A* pointer with * to get A&,
  • gets the address of A&, with &, to get a normal A*,
  • downcasts the A* to B* (it is known that A* is actually a B*), and
  • gives the B* to the SharedPtr constructor, to create a new SharedPtr .

We make it easier for application writers by making all methods take normal references instead of SharedPtr<>s, and telling people to dereference the SharedPtr<> with * to get the reference to give to the method. The compiler can then easily cast that normal reference, and that allows polymorphism to work.

Question: Why is this an intrusive smart-pointer? Wouldn't it be better if the count was in the smart-pointer instead of the object? Answer: Yes, that would be better, but it does not work when we can not cast normally. When we cast, we need to take the object out of the SharedPtr<> and put it into another SharedPtr<>. But both SharedPtr<>s still need to use the same count. Without a templated constructor (see above), the only way to keep the count connected with the object is to put it in the object itself.

Field Documentation

template<typename T_obj>
T_obj* SharedPtr< T_obj >::m_pobj [mutable, protected]

The documentation for this class was generated from the following file:
  • Auxiliary/SharedPtr.hpp
Generated on Wed Jan 25 01:48:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SharedTimer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SharedTimer Class Reference
[Kernel]

#include <Apoxi/Compat/SharedTimer.hpp>

Inheritance diagram for SharedTimer:

[legend]
Collaboration diagram for SharedTimer:

[legend]

Public Member Functions

void | Init (UINT32 timeout, BOOLEAN autotimer=FALSE)
void | Restart ()
void | Resume ()
SharedTimer (UINT32 timeout, BOOLEAN autotimer=FALSE)
SharedTimer ()
void | Start ()
void | Stop ()
virtual | ~SharedTimer ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)

Detailed Description

Timer which can be shared between applications. The timer is automatically switching to the application-context the timer has been startet the first time.

Constructor & Destructor Documentation

SharedTimer::SharedTimer ( )

SharedTimer::SharedTimer | ( | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

See also:
Timer::Timer

SharedTimer::~SharedTimer ( ) [virtual]

Member Function Documentation

void SharedTimer::Init | ( | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

See also:
Timer::Init

Reimplemented from Timer.

BOOLEAN SharedTimer::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Implements Dispatcher.

void SharedTimer::Restart ( )

See also:
Timer::Restart

Reimplemented from Timer.

void SharedTimer::Resume ( )

See also:
Timer::Resume

Reimplemented from Timer.

void SharedTimer::Start ( )

See also:
Timer::Start

Reimplemented from Timer.

void SharedTimer::Stop ( )

See also:
Timer::Stop

Reimplemented from Timer.

The documentation for this class was generated from the following files:
  • Compat/SharedTimer.hpp
  • Compat/SharedTimer.cpp
Generated on Wed Jan 25 01:48:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SharedTimerMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SharedTimerMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for SharedTimerMsg:

[legend]
Collaboration diagram for SharedTimerMsg:

[legend]

Public Types

enum | { ID = 108 }

Public Member Functions

virtual Message * | Clone () const
INT | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
SharedTimerMsg (ExecutionContext *context, INT arg)
virtual | ~SharedTimerMsg ()

Detailed Description

This message will be sent to the SharedTimer dipatcher to get into the right thread context.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SharedTimerMsg::SharedTimerMsg | ( | ExecutionContext * | context,
 |  | INT | arg
 | ) |

SharedTimerMsg::~SharedTimerMsg ( ) [virtual]

Member Function Documentation

Message * SharedTimerMsg::Clone ( ) const [virtual]

Implements Message.

INT SharedTimerMsg::GetArg ( ) const [inline]

const MsgMetaData & SharedTimerMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:48:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SharedTriggerTimer< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SharedTriggerTimer< T > Class Template Reference
[Kernel]

#include <Apoxi/Compat/SharedTimer.hpp>

Inheritance diagram for SharedTriggerTimer< T >:

[legend]
Collaboration diagram for SharedTriggerTimer< T >:

[legend]

Public Member Functions

void | Init (T *t, UINT32 timeout, BOOLEAN autotimer=FALSE)
SharedTriggerTimer (T *t, UINT32 timeout, BOOLEAN autotimer=FALSE)
SharedTriggerTimer ()
virtual | ~SharedTriggerTimer ()

Protected Member Functions

virtual void | OnTimer ()

template<class T>
class SharedTriggerTimer< T >

The documentation for this class was generated from the following file:
  • Compat/SharedTimer.hpp
Generated on Wed Jan 25 01:48:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ShortMessageFailureCause Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ShortMessageFailureCause Class Reference

3GPP TS 23.040 V5.1.0 [9.2.3.22] More...

#include <Apoxi/Apc/ShortMessageFailureCause.hpp>

Collaboration diagram for ShortMessageFailureCause:

[legend]

Public Types

enum Error {
ReservedGeneralErrorBegin = 0x00, ReservedGeneralErrorEnd = 0x0f, TelematicInterworkingNotSupported = 0x80, SmType0NotSupported = 0x81,
CannotReplaceSm = 0x82, ReservedPidErrorBegin, ReservedPidErrorEnd = 0x8e, UnspecifiedPidError = 0x8f,
AlphabetNotSupported = 0x90, MessageClassNotSupported = 0x91, ReservedDcsErrorBegin, ReservedDcsErrorEnd = 0x9e,
UnspecifiedDcsError = 0x9f, CommandCannotBePerformed = 0xa0, CommandUnsupported = 0xa1, ReservedCommandErrorBegin,
ReservedCommandErrorEnd = 0xae, UnspecifiedCommandError = 0xaf, TpduNotSupported = 0xb0, ReservedTpduErrorBegin,
ReservedTpduErrorEnd = 0xbf, ScBusy = 0xc0, NoScSubscription = 0xc1, ScSystemFailure = 0xc2,
InvalidSmeAddress = 0xc3, DestinationSmeBarred = 0xc4, SmRejectedDuplicateSm = 0xc5, VpfNotSupported = 0xc6,
VpNotSupported = 0xc7, ReservedScErrorBegin, ReservedScErrorEnd = 0xcf, USimSmsStorageFull = 0xd0,
NoSmsStorageCapabilityInUSim = 0xd1, ErrorInMs = 0xd2, MemoryCapacityExceeded = 0xd3, USimApplicationToolkitBusy = 0xd4,
USimDataDownloadError = 0xd5, ReservedUSimErrorBegin, ReservedUSimErrorEnd = 0xdf, ReservedApplicationErrorBegin,
ReservedApplicationErrorEnd = 0xfe, UnspecifiedError = 0xff, ReservedErrorValue, InvalidErrorValue
}
enum | Usage { MobileOriginated, MobileTerminated, UndefinedUsage }

Public Member Functions

void | Clear ()
UINT8 | Get () const
Error | GetError () const
void | SetError (Error error)
ShortMessageFailureCause (UINT8 incoming_byte)
ShortMessageFailureCause ()

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.3.22]

Member Enumeration Documentation

enum ShortMessageFailureCause::Error

Enumerator:
ReservedGeneralErrorBegin | insert new application errors before.
ReservedGeneralErrorEnd
TelematicInterworkingNotSupported
SmType0NotSupported
CannotReplaceSm
ReservedPidErrorBegin | insert new pid errors before.
ReservedPidErrorEnd
UnspecifiedPidError
AlphabetNotSupported | Data coding scheme (alphabet) not suppoerted.
MessageClassNotSupported
ReservedDcsErrorBegin | insert new dcs errors before.
ReservedDcsErrorEnd
UnspecifiedDcsError
CommandCannotBePerformed
CommandUnsupported
ReservedCommandErrorBegin | insert new command errors before.
ReservedCommandErrorEnd
UnspecifiedCommandError
TpduNotSupported
ReservedTpduErrorBegin | insert new tpdu errors before.
ReservedTpduErrorEnd
ScBusy
NoScSubscription
ScSystemFailure
InvalidSmeAddress
DestinationSmeBarred
SmRejectedDuplicateSm
VpfNotSupported
VpNotSupported
ReservedScErrorBegin | insert new service center errors before.
ReservedScErrorEnd
USimSmsStorageFull
NoSmsStorageCapabilityInUSim
ErrorInMs
MemoryCapacityExceeded
USimApplicationToolkitBusy
USimDataDownloadError
ReservedUSimErrorBegin | insert new usim errors before.
ReservedUSimErrorEnd
ReservedApplicationErrorBegin | insert new application errors before.
ReservedApplicationErrorEnd
UnspecifiedError
ReservedErrorValue | is used to map all reserved value ranges before.
InvalidErrorValue

enum ShortMessageFailureCause::Usage

Enumerator:
MobileOriginated
MobileTerminated
UndefinedUsage

Constructor & Destructor Documentation

ShortMessageFailureCause::ShortMessageFailureCause ( )

ShortMessageFailureCause::ShortMessageFailureCause ( UINT8 incoming_byte )

Member Function Documentation

void ShortMessageFailureCause::Clear ( ) [inline]

UINT8 ShortMessageFailureCause::Get ( ) const [inline]

ShortMessageFailureCause::Error ShortMessageFailureCause::GetError ( ) const

void ShortMessageFailureCause::SetError ( Error error )

The documentation for this class was generated from the following files:
  • Apc/ShortMessageFailureCause.hpp
  • Apc/ShortMessageFailureCause.cpp
Generated on Wed Jan 25 01:49:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ShortMessageStatus Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ShortMessageStatus Class Reference

3GPP TS 23.040 V5.1.0 [9.2.3.15] More...

#include <Apoxi/Apc/ShortMessageStatus.hpp>

Collaboration diagram for ShortMessageStatus:

[legend]

Public Types

enum Reason {
SmDelivered = 0, SmDeliveredButUnableToConfirm, SmReplaced, ReservedReason,
ServiceCenterSpecificReason, Congestion, SmeBusy, NoResponseFromSme,
ServiceRejected, QualityOfServiceNotAvailable, ErrorInSme, RemoteProcedureError,
IncompatibleDestination, ConnectionRejectedBySme, NotObtainable, NoInterworkingAvailable,
SmValidityPeriodExpired, SmDeletedByOriginatingSme, SmDeletedByScAdministration, SmDoesNotExist,
InvalidReason
}
enum Status {
TransactionCompleted = 0, TemporaryErrorStillTrying, PermanentError, TemporaryError,
ReservedStatus, InvalidStatus
}

Public Member Functions

void | Clear ()
UINT8 | Get () const
Reason | GetReason () const
Status | GetStatus () const
void | SetReason (Reason reason)
void | SetStatus (Status status)
ShortMessageStatus (UINT8 incoming_byte)
ShortMessageStatus ()

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.3.15]

Member Enumeration Documentation

enum ShortMessageStatus::Reason

Enumerator:
SmDelivered | Short message received by the SME (Short Message Entity).
SmDeliveredButUnableToConfirm | Short message forwarded by the SC (Service Center) to the SME but the SC is unable to confirm delivery.
SmReplaced | Short message replaced by the SC.
ReservedReason
ServiceCenterSpecificReason | Values specific to each SC.
Congestion
SmeBusy
NoResponseFromSme
ServiceRejected
QualityOfServiceNotAvailable
ErrorInSme
RemoteProcedureError
IncompatibleDestination
ConnectionRejectedBySme
NotObtainable
NoInterworkingAvailable
SmValidityPeriodExpired
SmDeletedByOriginatingSme
SmDeletedByScAdministration
SmDoesNotExist | The service center has no longer knowledge of a previous existing short message.
InvalidReason

enum ShortMessageStatus::Status

describes the status of a previously submitted SMS-SUBMIT and certain SMS-COMMANDs for which a Status-Report has been requested.

Enumerator:
TransactionCompleted | Short message transaction completed.
TemporaryErrorStillTrying | Temporary error, SC (Service Center) still trying to transfer SM (Short Message).
PermanentError | Permanent error, SC is not making any more transfer attempts.
TemporaryError | Temporary error, SC is not making any more transfer attempts.
ReservedStatus | Reserved values.
InvalidStatus

Constructor & Destructor Documentation

ShortMessageStatus::ShortMessageStatus ( )

ShortMessageStatus::ShortMessageStatus ( UINT8 incoming_byte )

Member Function Documentation

void ShortMessageStatus::Clear ( ) [inline]

UINT8 ShortMessageStatus::Get ( ) const [inline]

ShortMessageStatus::Reason ShortMessageStatus::GetReason ( ) const

ShortMessageStatus::Status ShortMessageStatus::GetStatus ( ) const

void ShortMessageStatus::SetReason ( Reason reason )

void ShortMessageStatus::SetStatus ( Status status )

The documentation for this class was generated from the following files:
  • Apc/ShortMessageStatus.hpp
  • Apc/ShortMessageStatus.cpp
Generated on Wed Jan 25 01:49:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ShutDown Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ShutDown Class Reference
[Devices]

#include <Apoxi/Devices/ShutDown.hpp>

Collaboration diagram for ShutDown:

[legend]

Public Types

enum | Mode { PowerOff, Restart, SilentReset, FirmwareUpdate }

Static Public Member Functions

static void | Execute (Mode mode=PowerOff)
static void | PowerDown (BOOLEAN restart=FALSE)

Friends

class | CommonSignalProcessor

Detailed Description

The class ShutDown is used by APOXI to handle the shutdown procedure. Any MMI application, which wants to invoke a system shutdown, has to use System::ShutDown()

Member Enumeration Documentation

enum ShutDown::Mode

Defines the shut-down behavior when ShutDown::Execute is called.

Enumerator:
PowerOff
Restart | phone powers off after shut-down
SilentReset | restart
FirmwareUpdate | phone restarts in firmware update mode after shut-down

Member Function Documentation

void ShutDown::Execute ( Mode mode = PowerOff ) [static]

This method is called by System::ShutDown an will handle the whole shutdown process. The AppCloseMsg will be posted to all applications (OnClose will be called). Then the System will be checked periodically until all AppContainer are terminated. After that the Mobile Network will be stopped and the power down request is sent to the protocol stack.

void ShutDown::PowerDown ( BOOLEAN restart = FALSE ) [static]

This method simply turns off the power of the phone without doing any defined system clean up. If the flag restart is enabled, the phone will boot up again (currently) in 'normal mode' (kind of simulated ON-key press). It is mainly of internal use and should not be used for normal system shutdowns.

Friends And Related Function Documentation

friend class CommonSignalProcessor [friend]

The documentation for this class was generated from the following files:
  • Devices/ShutDown.hpp
  • Devices/ShutDown.cpp
Generated on Wed Jan 25 01:49:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ShutdownRequestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ShutdownRequestMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ShutdownRequestMsg:

[legend]
Collaboration diagram for ShutdownRequestMsg:

[legend]

Public Types

enum | { ID = 111 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
ShutdownRequestMsg (ExecutionContext *context)
virtual | ~ShutdownRequestMsg ()

Detailed Description

This message will be sent to the application when the system wants to shutdown but the ShutdownAllowed flag of an application is set to FALSE.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ShutdownRequestMsg::ShutdownRequestMsg ( ExecutionContext * context )

ShutdownRequestMsg::~ShutdownRequestMsg ( ) [virtual]

Member Function Documentation

Message * ShutdownRequestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ShutdownRequestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 01:49:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiBearerDesc_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiBearerDesc_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SiBearerDesc_s:

[legend]

Data Fields

byte bearer_type
SiBearerDescArray data

Field Documentation

byte SiBearerDesc_s::bearer_type

SiBearerDescArray SiBearerDesc_s::data

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:49:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiBearerDescArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiBearerDescArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

UINT8 val [6]

Field Documentation

UINT8 SiBearerDescArray::val[6]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:49:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiBearerList_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiBearerList_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SiBearerList_s:

[legend]

Data Fields

byte br_number
SiBearerListArray data

Field Documentation

byte SiBearerList_s::br_number

SiBearerListArray SiBearerList_s::data

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:49:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiBearerListArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiBearerListArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

UINT8 val [4]

Field Documentation

UINT8 SiBearerListArray::val[4]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:49:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelCloseInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelCloseInfoIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelCloseInfoIndArg:

[legend]
Collaboration diagram for SiChannelCloseInfoIndArg:

[legend]

Public Types

enum | { ID = 1328 }

Public Member Functions

UINT8 | GetCidx () const
const SiChannelCloseCause & | GetCloseCause () const
const SimIconIdentifier & | GetIcon () const
const WString & | GetText () const
const SimTkTransactionId & | GetTid () const
void | SetCidx (UINT8 cidx)
void | SetCloseCause (const SiChannelCloseCause &close_cause)
void | SetIcon (const SimIconIdentifier &icon)
void | SetText (const WString &text)
void | SetTid (const SimTkTransactionId &tid)
SiChannelCloseInfoIndArg ()

Static Public Member Functions

static const SiChannelCloseInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SiChannelCloseInfoIndArg: reflects arguments of signal SI_CHANNEL_CLOSE_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelCloseInfoIndArg::SiChannelCloseInfoIndArg ( )

Member Function Documentation

const SiChannelCloseInfoIndArg & SiChannelCloseInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SiChannelCloseInfoIndArg::GetCidx ( ) const [inline]

const SiChannelCloseCause& SiChannelCloseInfoIndArg::GetCloseCause ( ) const [inline]

const SimIconIdentifier& SiChannelCloseInfoIndArg::GetIcon ( ) const [inline]

const WString& SiChannelCloseInfoIndArg::GetText ( ) const [inline]

const SimTkTransactionId& SiChannelCloseInfoIndArg::GetTid ( ) const [inline]

void SiChannelCloseInfoIndArg::SetCidx ( UINT8 cidx ) [inline]

void SiChannelCloseInfoIndArg::SetCloseCause ( const SiChannelCloseCause & close_cause ) [inline]

void SiChannelCloseInfoIndArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void SiChannelCloseInfoIndArg::SetText ( const WString & text ) [inline]

void SiChannelCloseInfoIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelCloseInfoIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelCloseInfoIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SiChannelCloseInfoIndMsg:

[legend]
Collaboration diagram for SiChannelCloseInfoIndMsg:

[legend]

Public Types

enum | { ID = 18336 }

Public Member Functions

virtual Message * | Clone () const
const SiChannelCloseInfoIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SiChannelCloseInfoIndArg &arg)
SiChannelCloseInfoIndMsg (const SiChannelCloseInfoIndArg &arg)
virtual | ~SiChannelCloseInfoIndMsg ()

Detailed Description

SiChannelCloseInfoIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelCloseInfoIndMsg::SiChannelCloseInfoIndMsg ( const SiChannelCloseInfoIndArg & arg )

SiChannelCloseInfoIndMsg::~SiChannelCloseInfoIndMsg ( ) [virtual]

Member Function Documentation

Message * SiChannelCloseInfoIndMsg::Clone ( ) const [virtual]

Implements Message.

const SiChannelCloseInfoIndArg& SiChannelCloseInfoIndMsg::GetArg ( ) const [inline]

const MsgMetaData & SiChannelCloseInfoIndMsg::GetMetaData ( ) const [virtual]

Implements Message.

void SiChannelCloseInfoIndMsg::SetArg ( const SiChannelCloseInfoIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:49:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelCloseInfoResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelCloseInfoResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelCloseInfoResArg:

[legend]
Collaboration diagram for SiChannelCloseInfoResArg:

[legend]

Public Types

enum | { ID = 2329 }

Public Member Functions

UINT8 | GetCidx () const
const GenResultCode & | GetGenResult () const
const SimTkTransactionId & | GetTid () const
void | SetCidx (UINT8 cidx)
void | SetGenResult (const GenResultCode &gen_result)
void | SetTid (const SimTkTransactionId &tid)
SiChannelCloseInfoResArg ()
SiChannelCloseInfoResArg (const SimTkTransactionId &tid, UINT8 cidx, const GenResultCode &gen_result)

Static Public Member Functions

static const SiChannelCloseInfoResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SiChannelCloseInfoResArg: reflects arguments of signal SI_CHANNEL_CLOSE_INFO_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelCloseInfoResArg::SiChannelCloseInfoResArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | const GenResultCode & | gen_result
 | ) |

SiChannelCloseInfoResArg::SiChannelCloseInfoResArg ( )

Member Function Documentation

const SiChannelCloseInfoResArg & SiChannelCloseInfoResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SiChannelCloseInfoResArg::GetCidx ( ) const [inline]

const GenResultCode& SiChannelCloseInfoResArg::GetGenResult ( ) const [inline]

const SimTkTransactionId& SiChannelCloseInfoResArg::GetTid ( ) const [inline]

void SiChannelCloseInfoResArg::SetCidx ( UINT8 cidx ) [inline]

void SiChannelCloseInfoResArg::SetGenResult ( const GenResultCode & gen_result ) [inline]

void SiChannelCloseInfoResArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelCloseReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelCloseReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelCloseReqArg:

[legend]
Collaboration diagram for SiChannelCloseReqArg:

[legend]

Public Types

enum | { ID = 2328 }

Public Member Functions

UINT8 | GetCidx () const
const SimTkTransactionId & | GetTid () const
void | SetCidx (UINT8 cidx)
void | SetTid (const SimTkTransactionId &tid)
SiChannelCloseReqArg ()
SiChannelCloseReqArg (const SimTkTransactionId &tid, UINT8 cidx)

Static Public Member Functions

static const SiChannelCloseReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SiChannelCloseReqArg: reflects arguments of signal SI_CHANNEL_CLOSE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelCloseReqArg::SiChannelCloseReqArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx
 | ) |

SiChannelCloseReqArg::SiChannelCloseReqArg ( )

Member Function Documentation

const SiChannelCloseReqArg & SiChannelCloseReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SiChannelCloseReqArg::GetCidx ( ) const [inline]

const SimTkTransactionId& SiChannelCloseReqArg::GetTid ( ) const [inline]

void SiChannelCloseReqArg::SetCidx ( UINT8 cidx ) [inline]

void SiChannelCloseReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelOpenPromptReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelOpenPromptReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelOpenPromptReqArg:

[legend]
Collaboration diagram for SiChannelOpenPromptReqArg:

[legend]

Public Types

enum | { ID = 1327 }

Public Member Functions

const WString & | GetApn () const
const SiBearerType & | GetBearerType () const
UINT8 | GetCidx () const
const SimIconIdentifier & | GetIcon () const
const PhoneNumber & | GetPhoneNumber () const
const SimSubAddress & | GetSubAddr () const
const WString & | GetText () const
const SimTkTransactionId & | GetTid () const
void | SetApn (const WString &apn)
void | SetBearerType (const SiBearerType &bearer_type)
void | SetCidx (UINT8 cidx)
void | SetIcon (const SimIconIdentifier &icon)
void | SetPhoneNumber (const PhoneNumber &phone_number)
void | SetSubAddr (const SimSubAddress &sub_addr)
void | SetText (const WString &text)
void | SetTid (const SimTkTransactionId &tid)
SiChannelOpenPromptReqArg ()

Static Public Member Functions

static const SiChannelOpenPromptReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SiChannelOpenPromptReqArg: reflects arguments of signal SI_CHANNEL_OPEN_PROMPT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelOpenPromptReqArg::SiChannelOpenPromptReqArg ( )

Member Function Documentation

const SiChannelOpenPromptReqArg & SiChannelOpenPromptReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& SiChannelOpenPromptReqArg::GetApn ( ) const [inline]

const SiBearerType& SiChannelOpenPromptReqArg::GetBearerType ( ) const [inline]

UINT8 SiChannelOpenPromptReqArg::GetCidx ( ) const [inline]

const SimIconIdentifier& SiChannelOpenPromptReqArg::GetIcon ( ) const [inline]

const PhoneNumber& SiChannelOpenPromptReqArg::GetPhoneNumber ( ) const [inline]

const SimSubAddress& SiChannelOpenPromptReqArg::GetSubAddr ( ) const [inline]

const WString& SiChannelOpenPromptReqArg::GetText ( ) const [inline]

const SimTkTransactionId& SiChannelOpenPromptReqArg::GetTid ( ) const [inline]

void SiChannelOpenPromptReqArg::SetApn ( const WString & apn ) [inline]

void SiChannelOpenPromptReqArg::SetBearerType ( const SiBearerType & bearer_type ) [inline]

void SiChannelOpenPromptReqArg::SetCidx ( UINT8 cidx ) [inline]

void SiChannelOpenPromptReqArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void SiChannelOpenPromptReqArg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

void SiChannelOpenPromptReqArg::SetSubAddr ( const SimSubAddress & sub_addr ) [inline]

void SiChannelOpenPromptReqArg::SetText ( const WString & text ) [inline]

void SiChannelOpenPromptReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelOpenPromptReqMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelOpenPromptReqMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SiChannelOpenPromptReqMsg:

[legend]
Collaboration diagram for SiChannelOpenPromptReqMsg:

[legend]

Public Types

enum | { ID = 18335 }

Public Member Functions

virtual Message * | Clone () const
const SiChannelOpenPromptReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SiChannelOpenPromptReqArg &arg)
SiChannelOpenPromptReqMsg (const SiChannelOpenPromptReqArg &arg)
virtual | ~SiChannelOpenPromptReqMsg ()

Detailed Description

SiChannelOpenPromptReqMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelOpenPromptReqMsg::SiChannelOpenPromptReqMsg ( const SiChannelOpenPromptReqArg & arg )

SiChannelOpenPromptReqMsg::~SiChannelOpenPromptReqMsg ( ) [virtual]

Member Function Documentation

Message * SiChannelOpenPromptReqMsg::Clone ( ) const [virtual]

Implements Message.

const SiChannelOpenPromptReqArg& SiChannelOpenPromptReqMsg::GetArg ( ) const [inline]

const MsgMetaData & SiChannelOpenPromptReqMsg::GetMetaData ( ) const [virtual]

Implements Message.

void SiChannelOpenPromptReqMsg::SetArg ( const SiChannelOpenPromptReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:49:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelOpenPromptResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelOpenPromptResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelOpenPromptResArg:

[legend]
Collaboration diagram for SiChannelOpenPromptResArg:

[legend]

Public Types

enum | { ID = 2327 }

Public Member Functions

const GenResultCode & | GetGenResult () const
const SimTkTransactionId & | GetTid () const
void | SetGenResult (const GenResultCode &gen_result)
void | SetTid (const SimTkTransactionId &tid)
SiChannelOpenPromptResArg ()
SiChannelOpenPromptResArg (const SimTkTransactionId &tid, const GenResultCode &gen_result)

Static Public Member Functions

static const SiChannelOpenPromptResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

LaunchBrowserPromptIndArg: reflects arguments of signal SI_CHANNEL_OPEN_PROMPT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelOpenPromptResArg::SiChannelOpenPromptResArg | ( | const SimTkTransactionId & | tid,
 |  | const GenResultCode & | gen_result
 | ) |

SiChannelOpenPromptResArg::SiChannelOpenPromptResArg ( )

Member Function Documentation

const SiChannelOpenPromptResArg & SiChannelOpenPromptResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GenResultCode& SiChannelOpenPromptResArg::GetGenResult ( ) const [inline]

const SimTkTransactionId& SiChannelOpenPromptResArg::GetTid ( ) const [inline]

void SiChannelOpenPromptResArg::SetGenResult ( const GenResultCode & gen_result ) [inline]

void SiChannelOpenPromptResArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelReceiveInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelReceiveInfoIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelReceiveInfoIndArg:

[legend]
Collaboration diagram for SiChannelReceiveInfoIndArg:

[legend]

Public Types

enum | { ID = 1330 }

Public Member Functions

UINT8 | GetChannelDataLength () const
UINT8 | GetCidx () const
const SimIconIdentifier & | GetIcon () const
const SimAlphaIdentifier & | GetText () const
const SimTkTransactionId & | GetTid () const
void | SetChannelDataLength (UINT8 channel_data_length)
void | SetCidx (UINT8 cidx)
void | SetIcon (const SimIconIdentifier &icon)
void | SetText (const SimAlphaIdentifier &text)
void | SetTid (const SimTkTransactionId &tid)
SiChannelReceiveInfoIndArg ()

Static Public Member Functions

static const SiChannelReceiveInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SiChannelReceiveInfoIndArg: reflects arguments of signal SI_CHANNEL_RECEIVE_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelReceiveInfoIndArg::SiChannelReceiveInfoIndArg ( )

Member Function Documentation

const SiChannelReceiveInfoIndArg & SiChannelReceiveInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SiChannelReceiveInfoIndArg::GetChannelDataLength ( ) const [inline]

UINT8 SiChannelReceiveInfoIndArg::GetCidx ( ) const [inline]

const SimIconIdentifier& SiChannelReceiveInfoIndArg::GetIcon ( ) const [inline]

const SimAlphaIdentifier& SiChannelReceiveInfoIndArg::GetText ( ) const [inline]

const SimTkTransactionId& SiChannelReceiveInfoIndArg::GetTid ( ) const [inline]

void SiChannelReceiveInfoIndArg::SetChannelDataLength ( UINT8 channel_data_length ) [inline]

void SiChannelReceiveInfoIndArg::SetCidx ( UINT8 cidx ) [inline]

void SiChannelReceiveInfoIndArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void SiChannelReceiveInfoIndArg::SetText ( const SimAlphaIdentifier & text ) [inline]

void SiChannelReceiveInfoIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelReceiveInfoIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelReceiveInfoIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SiChannelReceiveInfoIndMsg:

[legend]
Collaboration diagram for SiChannelReceiveInfoIndMsg:

[legend]

Public Types

enum | { ID = 18338 }

Public Member Functions

virtual Message * | Clone () const
const SiChannelReceiveInfoIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SiChannelReceiveInfoIndArg &arg)
SiChannelReceiveInfoIndMsg (const SiChannelReceiveInfoIndArg &arg)
virtual | ~SiChannelReceiveInfoIndMsg ()

Detailed Description

SiChannelReceiveInfoIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelReceiveInfoIndMsg::SiChannelReceiveInfoIndMsg ( const SiChannelReceiveInfoIndArg & arg )

SiChannelReceiveInfoIndMsg::~SiChannelReceiveInfoIndMsg ( ) [virtual]

Member Function Documentation

Message * SiChannelReceiveInfoIndMsg::Clone ( ) const [virtual]

Implements Message.

const SiChannelReceiveInfoIndArg& SiChannelReceiveInfoIndMsg::GetArg ( ) const [inline]

const MsgMetaData & SiChannelReceiveInfoIndMsg::GetMetaData ( ) const [virtual]

Implements Message.

void SiChannelReceiveInfoIndMsg::SetArg ( const SiChannelReceiveInfoIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:49:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelReceiveInfoResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelReceiveInfoResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelReceiveInfoResArg:

[legend]
Collaboration diagram for SiChannelReceiveInfoResArg:

[legend]

Public Types

enum | { ID = 2331 }

Public Member Functions

UINT8 | GetCidx () const
const GenResultCode & | GetGenResult () const
const SimTkTransactionId & | GetTid () const
void | SetCidx (UINT8 cidx)
void | SetGenResult (const GenResultCode &gen_result)
void | SetTid (const SimTkTransactionId &tid)
SiChannelReceiveInfoResArg ()
SiChannelReceiveInfoResArg (const SimTkTransactionId &tid, UINT8 cidx, const GenResultCode &gen_result)

Static Public Member Functions

static const SiChannelReceiveInfoResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SiChannelReceiveInfoResArg: reflects arguments of signal SI_CHANNEL_RECEIVE_INFO_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelReceiveInfoResArg::SiChannelReceiveInfoResArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | const GenResultCode & | gen_result
 | ) |

SiChannelReceiveInfoResArg::SiChannelReceiveInfoResArg ( )

Member Function Documentation

const SiChannelReceiveInfoResArg & SiChannelReceiveInfoResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SiChannelReceiveInfoResArg::GetCidx ( ) const [inline]

const GenResultCode& SiChannelReceiveInfoResArg::GetGenResult ( ) const [inline]

const SimTkTransactionId& SiChannelReceiveInfoResArg::GetTid ( ) const [inline]

void SiChannelReceiveInfoResArg::SetCidx ( UINT8 cidx ) [inline]

void SiChannelReceiveInfoResArg::SetGenResult ( const GenResultCode & gen_result ) [inline]

void SiChannelReceiveInfoResArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelSendInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelSendInfoIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelSendInfoIndArg:

[legend]
Collaboration diagram for SiChannelSendInfoIndArg:

[legend]

Public Types

enum | { ID = 1329 }

Public Member Functions

UINT8 | GetChannelDataLength () const
UINT8 | GetCidx () const
const SimIconIdentifier & | GetIcon () const
const SimAlphaIdentifier & | GetText () const
const SimTkTransactionId & | GetTid () const
void | SetChannelDataLength (UINT8 channel_data_length)
void | SetCidx (UINT8 cidx)
void | SetIcon (const SimIconIdentifier &icon)
void | SetText (const SimAlphaIdentifier &text)
void | SetTid (const SimTkTransactionId &tid)
SiChannelSendInfoIndArg ()

Static Public Member Functions

static const SiChannelSendInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SiChannelSendInfoIndArg: reflects arguments of signal SI_CHANNEL_SEND_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelSendInfoIndArg::SiChannelSendInfoIndArg ( )

Member Function Documentation

const SiChannelSendInfoIndArg & SiChannelSendInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SiChannelSendInfoIndArg::GetChannelDataLength ( ) const [inline]

UINT8 SiChannelSendInfoIndArg::GetCidx ( ) const [inline]

const SimIconIdentifier& SiChannelSendInfoIndArg::GetIcon ( ) const [inline]

const SimAlphaIdentifier& SiChannelSendInfoIndArg::GetText ( ) const [inline]

const SimTkTransactionId& SiChannelSendInfoIndArg::GetTid ( ) const [inline]

void SiChannelSendInfoIndArg::SetChannelDataLength ( UINT8 channel_data_length ) [inline]

void SiChannelSendInfoIndArg::SetCidx ( UINT8 cidx ) [inline]

void SiChannelSendInfoIndArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void SiChannelSendInfoIndArg::SetText ( const SimAlphaIdentifier & text ) [inline]

void SiChannelSendInfoIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelSendInfoIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelSendInfoIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SiChannelSendInfoIndMsg:

[legend]
Collaboration diagram for SiChannelSendInfoIndMsg:

[legend]

Public Types

enum | { ID = 18337 }

Public Member Functions

virtual Message * | Clone () const
const SiChannelSendInfoIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SiChannelSendInfoIndArg &arg)
SiChannelSendInfoIndMsg (const SiChannelSendInfoIndArg &arg)
virtual | ~SiChannelSendInfoIndMsg ()

Detailed Description

SiChannelSendInfoIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelSendInfoIndMsg::SiChannelSendInfoIndMsg ( const SiChannelSendInfoIndArg & arg )

SiChannelSendInfoIndMsg::~SiChannelSendInfoIndMsg ( ) [virtual]

Member Function Documentation

Message * SiChannelSendInfoIndMsg::Clone ( ) const [virtual]

Implements Message.

const SiChannelSendInfoIndArg& SiChannelSendInfoIndMsg::GetArg ( ) const [inline]

const MsgMetaData & SiChannelSendInfoIndMsg::GetMetaData ( ) const [virtual]

Implements Message.

void SiChannelSendInfoIndMsg::SetArg ( const SiChannelSendInfoIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:49:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiChannelSendInfoResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiChannelSendInfoResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SiChannelSendInfoResArg:

[legend]
Collaboration diagram for SiChannelSendInfoResArg:

[legend]

Public Types

enum | { ID = 2330 }

Public Member Functions

UINT8 | GetCidx () const
const GenResultCode & | GetGenResult () const
const SimTkTransactionId & | GetTid () const
void | SetCidx (UINT8 cidx)
void | SetGenResult (const GenResultCode &gen_result)
void | SetTid (const SimTkTransactionId &tid)
SiChannelSendInfoResArg ()
SiChannelSendInfoResArg (const SimTkTransactionId &tid, UINT8 cidx, const GenResultCode &gen_result)

Static Public Member Functions

static const SiChannelSendInfoResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SiChannelSendInfoResArg: reflects arguments of signal SI_CHANNEL_SEND_INFO_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SiChannelSendInfoResArg::SiChannelSendInfoResArg | ( | const SimTkTransactionId & | tid,
 |  | UINT8 | cidx,
 |  | const GenResultCode & | gen_result
 | ) |

SiChannelSendInfoResArg::SiChannelSendInfoResArg ( )

Member Function Documentation

const SiChannelSendInfoResArg & SiChannelSendInfoResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SiChannelSendInfoResArg::GetCidx ( ) const [inline]

const GenResultCode& SiChannelSendInfoResArg::GetGenResult ( ) const [inline]

const SimTkTransactionId& SiChannelSendInfoResArg::GetTid ( ) const [inline]

void SiChannelSendInfoResArg::SetCidx ( UINT8 cidx ) [inline]

void SiChannelSendInfoResArg::SetGenResult ( const GenResultCode & gen_result ) [inline]

void SiChannelSendInfoResArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:49:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiDuration_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiDuration_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

byte time_interval
byte time_units

Field Documentation

byte SiDuration_s::time_interval

byte SiDuration_s::time_units

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:49:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SigDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SigDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SigDispatcher.hpp>

Inheritance diagram for SigDispatcher:

[legend]
Collaboration diagram for SigDispatcher:

[legend]

Public Member Functions

SigDispatcher ()
virtual | ~SigDispatcher ()

Protected Member Functions

BOOLEAN | OnSignalStrengthLevelInd (const StackMsgArgument &arg)

Constructor & Destructor Documentation

SigDispatcher::SigDispatcher ( )

SigDispatcher::~SigDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN SigDispatcher::OnSignalStrengthLevelInd ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/SigDispatcher.hpp
  • Asc/SigDispatcher.cpp
Generated on Wed Jan 25 01:49:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SigHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SigHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SigHandler.hpp>

Collaboration diagram for SigHandler:

[legend]

Public Types

enum | { ID = SigHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
SigHandler ()
void | Start (UINT threshold_db=0) const
void | Stop () const
stop receiving radio signal strength indication
virtual | ~SigHandler ()

Detailed Description

The SigHandler holds the functionality for receiving radio signal events.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SigHandler::SigHandler ( )

SigHandler::~SigHandler ( ) [virtual]

Member Function Documentation

HandlerId SigHandler::GetHandlerId ( ) const [virtual]

void SigHandler::Start ( UINT threshold_db = 0 ) const

void SigHandler::Stop ( ) const

stop receiving radio signal strength indication

The documentation for this class was generated from the following files:
  • Asc/SigHandler.hpp
  • Asc/SigHandler.cpp
Generated on Wed Jan 25 01:49:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SignalHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SignalHandler Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/SignalHandler.hpp>

Inheritance diagram for SignalHandler:

[legend]
Collaboration diagram for SignalHandler:

[legend]

Public Member Functions

virtual HandlerType | GetHandlerType () const
virtual void | Init (const AbstractExternalData *external_data)
virtual void | PostMessage (const MessageReferrer &msg_ref)
virtual void | RouteData (const AbstractExternalData &external_data)
virtual | ~SignalHandler ()

Static Public Member Functions

static SignalHandler * | GetInstance ()

Detailed Description

SignalHandler is the connection between the APOXI MessageRouter and the protocol stack.

Constructor & Destructor Documentation

SignalHandler::~SignalHandler ( ) [virtual]

Member Function Documentation

virtual HandlerType SignalHandler::GetHandlerType ( ) const [inline, virtual]

Implements ExternalCommunicationHandler.

SignalHandler * SignalHandler::GetInstance ( ) [static]

void SignalHandler::Init ( const AbstractExternalData * external_data ) [virtual]

Reimplemented from ExternalCommunicationHandler.

void SignalHandler::PostMessage ( const MessageReferrer & msg_ref ) [virtual]

PostMessage converts the APOXI-message which is wrapped by MessageReferrer into an SDL-signal and sends this to the stack.

Reimplemented from ExternalCommunicationHandler.

void SignalHandler::RouteData ( const AbstractExternalData & external_data ) [virtual]

RouteData converts incoming SDL-signals into APOXI-messages and routes them to the APOXI-applications.

Reimplemented from ExternalCommunicationHandler.

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/SignalHandler.hpp
  • Apc/SignalHandler/SignalHandler.cpp
Generated on Wed Jan 25 01:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SignalMapTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SignalMapTable Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/SignalMapTable.hpp>

Collaboration diagram for SignalMapTable:

[legend]

Static Public Member Functions

static void | PostMessage (const ProcessNode &process_node)

Friends

class | SignalMapTableNode

Member Function Documentation

void SignalMapTable::PostMessage ( const ProcessNode & process_node ) [static]

Friends And Related Function Documentation

friend class SignalMapTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/SignalMapTable.hpp
  • Apc/SignalHandler/SignalMapTable.cpp
Generated on Wed Jan 25 01:49:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SignalMapTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SignalMapTableEntry Struct Reference
[APC]

#include <Apoxi/Apc/SignalHandler/SignalMapTableEntry.hpp>

Static Public Member Functions

static BOOLEAN | IsNameAvailable ()

Data Fields

SdlSignalId id
SdlSignalName name
void(* | post_message_func )(const ProcessPtr &)

Member Function Documentation

static BOOLEAN SignalMapTableEntry::IsNameAvailable ( ) [inline, static]

Field Documentation

SdlSignalId SignalMapTableEntry::id

SdlSignalName SignalMapTableEntry::name

void(* SignalMapTableEntry::post_message_func)(const ProcessPtr &)

The documentation for this struct was generated from the following file:
  • Apc/SignalHandler/SignalMapTableEntry.hpp
Generated on Wed Jan 25 01:49:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SignalMapTableNode Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/SignalMapTableNode.hpp>

Inheritance diagram for SignalMapTableNode:

[legend]
Collaboration diagram for SignalMapTableNode:

[legend]

Public Member Functions

void | Remove ()
SignalMapTableNode (const SignalMapTableEntry *map_table, SdlSignalId last_entry, SignalMapTableNode **node=0)

Friends

class | SignalMapTable

Constructor & Destructor Documentation

SignalMapTableNode::SignalMapTableNode | ( | const SignalMapTableEntry * | map_table,
 |  | SdlSignalId | last_entry,
 |  | SignalMapTableNode ** | node = 0
 | ) |

Member Function Documentation

void SignalMapTableNode::Remove ( )

Friends And Related Function Documentation

friend class SignalMapTable [friend]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/SignalMapTableNode.hpp
  • Apc/SignalHandler/SignalMapTableNode.cpp
Generated on Wed Jan 25 01:49:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SignalQualityLevelMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SignalQualityLevelMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SignalQualityLevelMsg:

[legend]
Collaboration diagram for SignalQualityLevelMsg:

[legend]

Public Types

enum | { ID = 18001 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SignalQualityLevel & | GetSignalQualityLevel () const
const SignalQualityMax & | GetSignalQualityMax () const
void | SetSignalQualityLevel (const SignalQualityLevel &signal_quality_level)
void | SetSignalQualityMax (const SignalQualityMax &signal_quality_max)
SignalQualityLevelMsg (ExecutionContext *context, const SignalQualityLevel &signal_quality_level, const SignalQualityMax &signal_quality_max)
virtual | ~SignalQualityLevelMsg ()

Detailed Description

SignalQualityLevelMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SignalQualityLevelMsg::SignalQualityLevelMsg | ( | ExecutionContext * | context,
 |  | const SignalQualityLevel & | signal_quality_level,
 |  | const SignalQualityMax & | signal_quality_max
 | ) |

SignalQualityLevelMsg::~SignalQualityLevelMsg ( ) [virtual]

Member Function Documentation

Message * SignalQualityLevelMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SignalQualityLevelMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const SignalQualityLevel& SignalQualityLevelMsg::GetSignalQualityLevel ( ) const [inline]

const SignalQualityMax& SignalQualityLevelMsg::GetSignalQualityMax ( ) const [inline]

void SignalQualityLevelMsg::SetSignalQualityLevel ( const SignalQualityLevel & signal_quality_level ) [inline]

void SignalQualityLevelMsg::SetSignalQualityMax ( const SignalQualityMax & signal_quality_max ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:49:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SignalStrengthLevelIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SignalStrengthLevelIndArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for SignalStrengthLevelIndArg:

[legend]
Collaboration diagram for SignalStrengthLevelIndArg:

[legend]

Public Types

enum | { ID = 1100 }

Public Member Functions

const SignalStrengthLevel & | GetLevel () const
const SignalQualityLevel & | GetQuality () const
const SignalQualityMax & | GetSignalQualityMax () const
const SignalStrengthMax & | GetSignalStrengthMax () const
BOOLEAN | IsQualityValid () const
void | SetLevel (const SignalStrengthLevel &level)
void | SetQuality (const SignalQualityLevel &quality)
void | SetQualityValid (BOOLEAN quality_valid)
void | SetSignalQualityMax (const SignalQualityMax &signal_quality_max)
void | SetSignalStrengthMax (const SignalStrengthMax &signal_strength_max)
SignalStrengthLevelIndArg ()

Static Public Member Functions

static const SignalStrengthLevelIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SignalStrengthLevelIndArg: reflects arguments of signal RRMI_RXSTAT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SignalStrengthLevelIndArg::SignalStrengthLevelIndArg ( )

Member Function Documentation

const SignalStrengthLevelIndArg & SignalStrengthLevelIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SignalStrengthLevel& SignalStrengthLevelIndArg::GetLevel ( ) const [inline]

const SignalQualityLevel& SignalStrengthLevelIndArg::GetQuality ( ) const [inline]

const SignalQualityMax& SignalStrengthLevelIndArg::GetSignalQualityMax ( ) const [inline]

const SignalStrengthMax& SignalStrengthLevelIndArg::GetSignalStrengthMax ( ) const [inline]

BOOLEAN SignalStrengthLevelIndArg::IsQualityValid ( ) const [inline]

void SignalStrengthLevelIndArg::SetLevel ( const SignalStrengthLevel & level ) [inline]

void SignalStrengthLevelIndArg::SetQuality ( const SignalQualityLevel & quality ) [inline]

void SignalStrengthLevelIndArg::SetQualityValid ( BOOLEAN quality_valid ) [inline]

void SignalStrengthLevelIndArg::SetSignalQualityMax ( const SignalQualityMax & signal_quality_max ) [inline]

void SignalStrengthLevelIndArg::SetSignalStrengthMax ( const SignalStrengthMax & signal_strength_max ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SignalStrengthLevelMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SignalStrengthLevelMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SignalStrengthLevelMsg:

[legend]
Collaboration diagram for SignalStrengthLevelMsg:

[legend]

Public Types

enum | { ID = 18000 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SignalStrengthLevel & | GetSignalStrengthLevel () const
const SignalStrengthMax & | GetSignalStrengthMax () const
void | SetSignalStrengthLevel (const SignalStrengthLevel &signal_strength_level)
void | SetSignalStrengthMax (const SignalStrengthMax &signal_strength_max)
SignalStrengthLevelMsg (ExecutionContext *context, const SignalStrengthLevel &signal_strength_level, const SignalStrengthMax &signal_strength_max)
virtual | ~SignalStrengthLevelMsg ()

Detailed Description

SignalStrengthLevelMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SignalStrengthLevelMsg::SignalStrengthLevelMsg | ( | ExecutionContext * | context,
 |  | const SignalStrengthLevel & | signal_strength_level,
 |  | const SignalStrengthMax & | signal_strength_max
 | ) |

SignalStrengthLevelMsg::~SignalStrengthLevelMsg ( ) [virtual]

Member Function Documentation

Message * SignalStrengthLevelMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SignalStrengthLevelMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const SignalStrengthLevel& SignalStrengthLevelMsg::GetSignalStrengthLevel ( ) const [inline]

const SignalStrengthMax& SignalStrengthLevelMsg::GetSignalStrengthMax ( ) const [inline]

void SignalStrengthLevelMsg::SetSignalStrengthLevel ( const SignalStrengthLevel & signal_strength_level ) [inline]

void SignalStrengthLevelMsg::SetSignalStrengthMax ( const SignalStrengthMax & signal_strength_max ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:50:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SignedValue Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SignedValue Struct Reference

Structure for storing signed values. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Public Member Functions

void | operator *= (const SignedValue &rhs)
*= operator
SignedValue & operator- ()
Unary - operator.
BOOLEAN | operator< (const SignedValue &rhs) const
< operator
BOOLEAN | operator== (const SignedValue &rhs) const
== operator
BOOLEAN | operator> (const SignedValue &rhs) const
> operator

Data Fields

UINT16 | m_exponent
Exponent part.
INT32 | m_mantissa
Mantissa part.

Detailed Description

Structure for storing signed values.

Member Function Documentation

void SignedValue::operator *= ( const SignedValue & rhs ) [inline]

*= operator

SignedValue& SignedValue::operator- ( ) [inline]

Unary - operator.

BOOLEAN SignedValue::operator< ( const SignedValue & rhs ) const [inline]

< operator

BOOLEAN SignedValue::operator== ( const SignedValue & rhs ) const [inline]

== operator

BOOLEAN SignedValue::operator> ( const SignedValue & rhs ) const [inline]

> operator

Field Documentation

UINT16 SignedValue::m_exponent

Exponent part.

INT32 SignedValue::m_mantissa

Mantissa part.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 01:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiIpAddress_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiIpAddress_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SiIpAddress_s:

[legend]

Data Fields

SiIpAddressArray data
byte ip_type

Field Documentation

SiIpAddressArray SiIpAddress_s::data

byte SiIpAddress_s::ip_type

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiIpAddressArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiIpAddressArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

byte val [16]

Field Documentation

byte SiIpAddressArray::val[16]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:50:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAccessor Class Reference
[ADC]

#include <Apoxi/Adc/SimAccessor.hpp>

Collaboration diagram for SimAccessor:

[legend]

Public Member Functions

SimUpdateStatus ActivateBdn ()
SimUpdateStatus ActivateFdn ()
BOOLEAN | ActivateSmsUsage ()
void | CancelAllRequests ()
ChvStatus | ChangeChv (ChvNo chvno, const CHAR *oldchvptr, const CHAR *newchvptr, ChvAttemptsStruct &chvattempts)
void | Cleanup () const
SimUpdateStatus DeactivateBdn ()
SimUpdateStatus DeactivateFdn ()
SimCardType DetectSimCardType ()
ChvStatus | DisableChv1 (const CHAR *chvptr, ChvAttemptsStruct &chvattempts)
ChvStatus | DisablePin (ChvNo chvno, const CHAR *chvptr, ChvAttemptsStruct &chvattempts)
ChvStatus | EnableChv1 (const CHAR *chvptr, ChvAttemptsStruct &chvattempts)
ChvStatus | EnablePin (ChvNo chvno, const CHAR *chvptr, ChvAttemptsStruct &chvattempts)
SimUpdateStatus | GetAcm (INT recno, Acm &data, AcmSelector selector)
BOOLEAN | GetBdnState () const
BOOLEAN | GetCbmi (UINT8 *data, INT maxlen)
SimUpdateStatus | GetCbmi (INT recno, CbmiData &data)
UINT | GetCbmiFileLength ()
BOOLEAN | GetCbmir (UINT8 *data, INT maxlen)
SimUpdateStatus | GetCbmir (INT recno, CbmiRange &data)
UINT | GetCbmirFileLength ()
SimUpdateStatus | GetCmi (UINT recno, CmiRecord &cmirecord)
UINT | GetCmiCount ()
SimUpdateStatus GetCphsCfuf (CphsCfufArray &data)
SimUpdateStatus | GetCphsCsp (LineSelector selector, CphsCspArray &data)
SimUpdateStatus GetCphsIst (CphsIstArray &data)
SimUpdateStatus GetCphsOnm (CphsOnmName &data)
SimUpdateStatus GetCphsOns (CphsOnsName &data)
SimUpdateStatus GetCphsVmwf (CphsVmwfArray &data)
DataAvailability | GetDataAvailability (SimFileId fileid)
SimUpdateStatus | GetDynamic2Flag (UINT8 &data)
SimUpdateStatus | GetDynamicFlag (UINT8 &data)
SimUpdateStatus | GetEccArray (EccArray &eccarray, INT &length)
SimUpdateStatus | GetEmlpp (UINT8 &priority, UINT8 &fastcallsetup)
BOOLEAN | GetFdnState () const
SimUpdateStatus | GetFileInfo (SimFileId fileid, UINT &filesize, UINT &recordlength, ChvNo &chvno)
UINT | GetFileLength (SimFileId fileid)
BOOLEAN | GetImei (Imei &imei)
Sms::StorageType | GetInitialPrefferedStorageMedia () const
SimUpdateStatus GetLastSimUpdateStatus ()
BOOLEAN | GetLociData (LociData &locidata)
SimUpdateStatus GetMaxAcm (Acm &data)
SimUpdateStatus | GetMbi (UINT recno, UINT8 *mbidata, UINT recordlength)
UINT | GetMbiCount (UINT &recordlength)
SimUpdateStatus | GetMexeCertificateContent (SimFileId fileid, UINT size, UINT offset, UINT8 *buffer)
SimUpdateStatus | GetMexeRootPublicKeyProperty (SimFileId fileid, UINT &recordcount, UINT &recordlength)
SimUpdateStatus | GetMexeRootPublicKeyRecord (SimFileId fileid, UINT recordno, UINT recordsize, UINT8 *buffer)
SimUpdateStatus | GetMexeSt (UINT8 &mexest)
BOOLEAN | GetNvRamPduCount (INT &pdu_count)
SimUpdateStatus | GetOplInfo (INT &recordcount, INT &recordlength)
SimUpdateStatus | GetOplRecord (INT recordno, INT recordsize, UINT8 *buffer)
SimUpdateStatus GetOrangeParam (SimEfOrangeParam &data)
SimUpdateStatus | GetPhoneBookCountInfo (PhoneBookCntType phonebooktype, INT &records, INT &usedrecords)
SimUpdateStatus | GetPhoneBookEntry (INT recno, PhoneBookType phonebooktype, INT &textlength, INT &datalength, UINT8 *data)
BOOLEAN | GetPhoneBookInfo (PhoneBookInfo &info)
SimUpdateStatus | GetPlmnList (UINT8 *plmnlist, INT length)
UINT | GetPlmnwActFileLength ()
SimUpdateStatus | GetPlmnwActList (UsimPlmn *plmnlist, INT count)
SimUpdateStatus | GetPnnInfo (INT &recordcount, INT &recordlength)
SimUpdateStatus | GetPnnRecord (INT recordno, INT recordsize, UINT8 *buffer)
Sms::StorageType | GetPreferredStorageMedia () const
SimUpdateStatus | GetPrefExtLanguageArray (INT startpos, ExtLanguageArray &langarray)
UINT | GetPrefExtLanguageFileLength ()
SimUpdateStatus | GetPrefLanguageArray (INT startpos, LanguageArray &langarray)
UINT | GetPrefLanguageFileLength ()
UINT | GetPrefPlmnFileLength ()
SimUpdateStatus | GetPuct (Puct &puct)
SimUpdateStatus | GetServiceTable (SimServiceTable &sst)
const SimChangedState & | GetSimChangedState () const
SimUpdateStatus | GetSimData (SimFileId df_id, SimFileId ef_id, BOOLEAN istransparent, UINT16 offset, UINT8 *data, INT maxlen, BOOLEAN usimcommand=FALSE)
SimUpdateStatus | GetSimFileProperty (SimFileId df_id, SimFileId ef_id, UINT &filesize, UINT &recordlength)
BOOLEAN | GetSimIconDescription (INT recno, SimIconDescription &data)
BOOLEAN | GetSimImage (const SimImageDescriptor &imgdesc, SimImage &data)
SimIndicator GetSimIndicator ()
BOOLEAN | GetSimInfo (SimInfo &siminfo)
BOOLEAN | GetSimPduCount (INT &pdu_count)
SimUpdateStatus | GetSmsParam (INT recno, UINT8 *data, INT len)
BOOLEAN | GetSmsParamFileSizes (UINT8 &reclength, INT &bufferlen)
SimUpdateStatus | GetSmsr (INT recno, UINT8 &link, SmsrData &smsr)
UINT | GetSmsrCount ()
SimUpdateStatus | GetSpdiData (INT length, UINT8 *buffer)
SimUpdateStatus | GetSpdiInfo (INT &length)
SimUpdateStatus | GetSpn (ServiceProviderStruct &spn)
SimUpdateStatus | GetTstFile (UINT8 *data)
SimUpdateStatus | GetUsimFileProperty (SimFileId df_id, SimFileId ef_id, UINT &filesize, UINT &recordlength)
void | Init ()
BOOLEAN | IsAdnReadWritableIfFdnActive () const
BOOLEAN | IsBdnActivated () const
BOOLEAN | IsBdnReadWritableIfBdnNotActive () const
BOOLEAN | IsFdnActivated () const
MdhResult | MdhDeleteSms (MdhViewHdl view_hdl, INT recno, const MdhDeletionCmd &cmd)
SimUpdateStatus | MdhGetSms (MdhViewHdl view_hdl, INT recno, Tpdu &tpdu, MdhTimeStamp &timestamp, MdhExtendedData &ext_data)
MdhResult | MdhGetSms (MdhViewHdl view_hdl, INT recno, TpduConc &tpduconc, MdhTimeStamp &timestamp, MdhExtendedData &ext_data)
MdhResult | MdhGetSmsReport (MdhViewHdl view_hdl, INT recno, SmsrData &data)
MdhResult | MdhMakeView (MdhViewHdl &view_hdl)
BOOLEAN | MdhRequestCsmsRefNo (UINT16 &ref_no)
MdhResult | MdhSetSmsExtendedData (MdhViewHdl view_hdl, INT recno, const MdhExtendedData &ext_data)
MdhResult | MdhSetStorageMedia (MdhWorkMedia work_media)
MdhResult | MdhSetViewConfig (MdhViewHdl view_hdl, const MdhViewConfig &view_config)
SimUpdateStatus | MdhUpdateSms (MdhViewHdl view_hdl, INT recno, const Tpdu &tpdu, INT &storedrecno, MdhTimeStamp &timestamp)
MdhResult | MdhUpdateSms (MdhViewHdl view_hdl, INT recno, const TpduNode &tpdunode, UINT8 &no_saved, INT &storedrecno, MdhTimeStamp &timestamp)
SimUpdateStatus | MdhUpdateSmsStatus (MdhViewHdl view_hdl, INT recno, UINT8 recordstatus)
MdhResult | MdhUpdateSmsStatus (MdhViewHdl view_hdl, INT recno, UINT8 recordstatus, BOOLEAN complete)
BOOLEAN | ModifyLock (const SecLockCommand &command, SecLockStates &lockstates)
SmsMoreMessageType QuerySmsMoreMessageType ()
void | Reset ()
BOOLEAN | SendProactiveCommand (SimApduData *apdu, UINT8 &responsevalue)
BOOLEAN | SendProactiveCommandConfirmation ()
void | SetAdnReadWritableState (BOOLEAN state)
void | SetBdnReadWritableState (BOOLEAN state)
void | SetBdnState (BOOLEAN state)
void | SetFdnState (BOOLEAN state)
void | SetInitialPrefferedStorageMedia (Sms::StorageType type)
SimUpdateStatus | SetSimData (SimFileId df_id, SimFileId ef_id, BOOLEAN istransparent, UINT16 offset, const UINT8 *data, UINT8 length, BOOLEAN usimcommand=FALSE)
void | SetSimIndicator (const SimIndicator indicator)
void | SetSimInfo (const SimInfo &siminfo)
SimAccessor ()
ChvStatus | UnblockChv (ChvNo chvno, const CHAR *unbchvptr, const CHAR *newchvptr, ChvAttemptsStruct &chvattempts)
SimUpdateStatus | UpdateAcm (INT recno, const Acm &data, AcmSelector selector)
SimUpdateStatus | UpdateCbmi (INT recno, const CbmiData &data)
SimUpdateStatus | UpdateCbmir (INT recno, const CbmiRange &data)
SimUpdateStatus | UpdateCphsCfuf (const CphsCfufArray &data)
SimUpdateStatus | UpdateCphsCsp (LineSelector selector, INT noofgroup, const CphsCspArray &data)
SimUpdateStatus | UpdateCphsVmwf (const CphsVmwfArray &data)
SimUpdateStatus | UpdateDynamic2Flag (UINT8 data)
SimUpdateStatus | UpdateDynamicFlag (UINT8 data)
SimUpdateStatus | UpdateMaxAcm (const Acm &data)
SimUpdateStatus | UpdateMbi (UINT recno, const UINT8 *mbidata, UINT recordlength)
SimUpdateStatus | UpdateMruProperty (UINT16 type, UINT8 index, UINT8 bitnumber, UINT8 bitvalue)
SimUpdateStatus | UpdateOrangeParam (const SimEfOrangeParam &data)
SimUpdateStatus | UpdatePhoneBookEntry (INT recno, PhoneBookType phonebooktype, INT datalength, const UINT8 *data)
SimUpdateStatus | UpdatePlmnList (INT start, const UINT8 *plmnlist, INT length)
SimUpdateStatus | UpdatePlmnwActList (INT start, const UsimPlmn *plmnlist, INT length)
SimUpdateStatus | UpdatePrefExtLanguageArray (INT startpos, const ExtLanguageArray &langarray)
SimUpdateStatus | UpdatePrefLanguageArray (INT startpos, const LanguageArray &langarray)
SimUpdateStatus | UpdatePuct (const Puct &puct)
SimUpdateStatus | UpdateSmsParam (INT recno, const UINT8 *data, INT bufferlen)
SimUpdateStatus | UpdateSmsr (INT recno, UINT8 link, const SmsrData &smsr)
SimUpdateStatus | UsimSelect (SimFileId df_id, SimFileId ef_id)
ChvStatus | VerifyChv (ChvNo chvno, const CHAR *chvptr, ChvAttemptsStruct &chvattempts)
virtual | ~SimAccessor ()

Static Public Member Functions

static BOOLEAN | IsSimAccessAllowed ()
static BOOLEAN | IsSimPresent ()
static BOOLEAN | IsUsimInserted ()
static Sms::StorageType | MdhToSmsWorkMediaTranslation (MdhWorkMedia work_media)
static MdhWorkMedia | SmsToMdhWorkMediaTranslation (Sms::StorageType work_media)

Friends

class | MessageQueueEmptyCondition
class | MessageReceivedCondition
class | MessageSendableCondition
class | MessageStartCondition
class | SimUserDispatcher
class | UsimPlmnListDispatcher
class | UsimSmsParamDispatcher

Data Structures

struct | SimAccessorStruct

Constructor & Destructor Documentation

SimAccessor::SimAccessor ( )

SimAccessor::~SimAccessor ( ) [virtual]

Member Function Documentation

SimUpdateStatus SimAccessor::ActivateBdn ( )

SimUpdateStatus SimAccessor::ActivateFdn ( )

BOOLEAN SimAccessor::ActivateSmsUsage ( )

void SimAccessor::CancelAllRequests ( )

ChvStatus SimAccessor::ChangeChv | ( | ChvNo | chvno,
 |  | const CHAR * | oldchvptr,
 |  | const CHAR * | newchvptr,
 |  | ChvAttemptsStruct & | chvattempts
 | ) |

void SimAccessor::Cleanup ( ) const

SimUpdateStatus SimAccessor::DeactivateBdn ( )

SimUpdateStatus SimAccessor::DeactivateFdn ( )

SimCardType SimAccessor::DetectSimCardType ( )

ChvStatus SimAccessor::DisableChv1 | ( | const CHAR * | chvptr,
 |  | ChvAttemptsStruct & | chvattempts
 | ) |

ChvStatus SimAccessor::DisablePin | ( | ChvNo | chvno,
 |  | const CHAR * | chvptr,
 |  | ChvAttemptsStruct & | chvattempts
 | ) |

ChvStatus SimAccessor::EnableChv1 | ( | const CHAR * | chvptr,
 |  | ChvAttemptsStruct & | chvattempts
 | ) |

ChvStatus SimAccessor::EnablePin | ( | ChvNo | chvno,
 |  | const CHAR * | chvptr,
 |  | ChvAttemptsStruct & | chvattempts
 | ) |

SimUpdateStatus SimAccessor::GetAcm | ( | INT | recno,
 |  | Acm & | data,
 |  | AcmSelector | selector
 | ) |

BOOLEAN SimAccessor::GetBdnState ( ) const [inline]

BOOLEAN SimAccessor::GetCbmi | ( | UINT8 * | data,
 |  | INT | maxlen
 | ) |

SimUpdateStatus SimAccessor::GetCbmi | ( | INT | recno,
 |  | CbmiData & | data
 | ) |

UINT SimAccessor::GetCbmiFileLength ( ) [inline]

BOOLEAN SimAccessor::GetCbmir | ( | UINT8 * | data,
 |  | INT | maxlen
 | ) |

SimUpdateStatus SimAccessor::GetCbmir | ( | INT | recno,
 |  | CbmiRange & | data
 | ) |

UINT SimAccessor::GetCbmirFileLength ( ) [inline]

SimUpdateStatus SimAccessor::GetCmi | ( | UINT | recno,
 |  | CmiRecord & | cmirecord
 | ) |

UINT SimAccessor::GetCmiCount ( )

SimUpdateStatus SimAccessor::GetCphsCfuf ( CphsCfufArray & data )

SimUpdateStatus SimAccessor::GetCphsCsp | ( | LineSelector | selector,
 |  | CphsCspArray & | data
 | ) |

SimUpdateStatus SimAccessor::GetCphsIst ( CphsIstArray & data )

SimUpdateStatus SimAccessor::GetCphsOnm ( CphsOnmName & data )

SimUpdateStatus SimAccessor::GetCphsOns ( CphsOnsName & data )

SimUpdateStatus SimAccessor::GetCphsVmwf ( CphsVmwfArray & data )

DataAvailability SimAccessor::GetDataAvailability ( SimFileId fileid )

SimUpdateStatus SimAccessor::GetDynamic2Flag ( UINT8 & data )

SimUpdateStatus SimAccessor::GetDynamicFlag ( UINT8 & data )

SimUpdateStatus SimAccessor::GetEccArray | ( | EccArray & | eccarray,
 |  | INT & | length
 | ) |

SimUpdateStatus SimAccessor::GetEmlpp | ( | UINT8 & | priority,
 |  | UINT8 & | fastcallsetup
 | ) |

BOOLEAN SimAccessor::GetFdnState ( ) const [inline]

SimUpdateStatus SimAccessor::GetFileInfo | ( | SimFileId | fileid,
 |  | UINT & | filesize,
 |  | UINT & | recordlength,
 |  | ChvNo & | chvno
 | ) |

UINT SimAccessor::GetFileLength ( SimFileId fileid )

BOOLEAN SimAccessor::GetImei ( Imei & imei )

Sms::StorageType SimAccessor::GetInitialPrefferedStorageMedia ( ) const [inline]

SimUpdateStatus SimAccessor::GetLastSimUpdateStatus ( )

BOOLEAN SimAccessor::GetLociData ( LociData & locidata )

SimUpdateStatus SimAccessor::GetMaxAcm ( Acm & data )

SimUpdateStatus SimAccessor::GetMbi | ( | UINT | recno,
 |  | UINT8 * | mbidata,
 |  | UINT | recordlength
 | ) |

UINT SimAccessor::GetMbiCount ( UINT & recordlength )

SimUpdateStatus SimAccessor::GetMexeCertificateContent | ( | SimFileId | fileid,
 |  | UINT | size,
 |  | UINT | offset,
 |  | UINT8 * | buffer
 | ) |

SimUpdateStatus SimAccessor::GetMexeRootPublicKeyProperty | ( | SimFileId | fileid,
 |  | UINT & | recordcount,
 |  | UINT & | recordlength
 | ) |

SimUpdateStatus SimAccessor::GetMexeRootPublicKeyRecord | ( | SimFileId | fileid,
 |  | UINT | recordno,
 |  | UINT | recordsize,
 |  | UINT8 * | buffer
 | ) |

SimUpdateStatus SimAccessor::GetMexeSt ( UINT8 & mexest )

BOOLEAN SimAccessor::GetNvRamPduCount ( INT & pdu_count )

SimUpdateStatus SimAccessor::GetOplInfo | ( | INT & | recordcount,
 |  | INT & | recordlength
 | ) |

SimUpdateStatus SimAccessor::GetOplRecord | ( | INT | recordno,
 |  | INT | recordsize,
 |  | UINT8 * | buffer
 | ) |

SimUpdateStatus SimAccessor::GetOrangeParam ( SimEfOrangeParam & data )

SimUpdateStatus SimAccessor::GetPhoneBookCountInfo | ( | PhoneBookCntType | phonebooktype,
 |  | INT & | records,
 |  | INT & | usedrecords
 | ) |

SimUpdateStatus SimAccessor::GetPhoneBookEntry | ( | INT | recno,
 |  | PhoneBookType | phonebooktype,
 |  | INT & | textlength,
 |  | INT & | datalength,
 |  | UINT8 * | data
 | ) |

BOOLEAN SimAccessor::GetPhoneBookInfo ( PhoneBookInfo & info )

SimUpdateStatus SimAccessor::GetPlmnList | ( | UINT8 * | plmnlist,
 |  | INT | length
 | ) |

UINT SimAccessor::GetPlmnwActFileLength ( )

SimUpdateStatus SimAccessor::GetPlmnwActList | ( | UsimPlmn * | plmnlist,
 |  | INT | count
 | ) |

SimUpdateStatus SimAccessor::GetPnnInfo | ( | INT & | recordcount,
 |  | INT & | recordlength
 | ) |

SimUpdateStatus SimAccessor::GetPnnRecord | ( | INT | recordno,
 |  | INT | recordsize,
 |  | UINT8 * | buffer
 | ) |

Sms::StorageType SimAccessor::GetPreferredStorageMedia ( ) const [inline]

SimUpdateStatus SimAccessor::GetPrefExtLanguageArray | ( | INT | startpos,
 |  | ExtLanguageArray & | langarray
 | ) |

UINT SimAccessor::GetPrefExtLanguageFileLength ( ) [inline]

SimUpdateStatus SimAccessor::GetPrefLanguageArray | ( | INT | startpos,
 |  | LanguageArray & | langarray
 | ) |

UINT SimAccessor::GetPrefLanguageFileLength ( ) [inline]

UINT SimAccessor::GetPrefPlmnFileLength ( ) [inline]

SimUpdateStatus SimAccessor::GetPuct ( Puct & puct )

SimUpdateStatus SimAccessor::GetServiceTable ( SimServiceTable & sst )

const SimChangedState& SimAccessor::GetSimChangedState ( ) const [inline]

SimUpdateStatus SimAccessor::GetSimData | ( | SimFileId | df_id,
 |  | SimFileId | ef_id,
 |  | BOOLEAN | istransparent,
 |  | UINT16 | offset,
 |  | UINT8 * | data,
 |  | INT | maxlen,
 |  | BOOLEAN | usimcommand = FALSE
 | ) |

SimUpdateStatus SimAccessor::GetSimFileProperty | ( | SimFileId | df_id,
 |  | SimFileId | ef_id,
 |  | UINT & | filesize,
 |  | UINT & | recordlength
 | ) |

BOOLEAN SimAccessor::GetSimIconDescription | ( | INT | recno,
 |  | SimIconDescription & | data
 | ) |

BOOLEAN SimAccessor::GetSimImage | ( | const SimImageDescriptor & | imgdesc,
 |  | SimImage & | data
 | ) |

SimIndicator SimAccessor::GetSimIndicator ( )

BOOLEAN SimAccessor::GetSimInfo ( SimInfo & siminfo )

BOOLEAN SimAccessor::GetSimPduCount ( INT & pdu_count )

SimUpdateStatus SimAccessor::GetSmsParam | ( | INT | recno,
 |  | UINT8 * | data,
 |  | INT | len
 | ) |

BOOLEAN SimAccessor::GetSmsParamFileSizes | ( | UINT8 & | reclength,
 |  | INT & | bufferlen
 | ) |

SimUpdateStatus SimAccessor::GetSmsr | ( | INT | recno,
 |  | UINT8 & | link,
 |  | SmsrData & | smsr
 | ) |

UINT SimAccessor::GetSmsrCount ( )

SimUpdateStatus SimAccessor::GetSpdiData | ( | INT | length,
 |  | UINT8 * | buffer
 | ) |

SimUpdateStatus SimAccessor::GetSpdiInfo ( INT & length )

SimUpdateStatus SimAccessor::GetSpn ( ServiceProviderStruct & spn )

SimUpdateStatus SimAccessor::GetTstFile ( UINT8 * data )

SimUpdateStatus SimAccessor::GetUsimFileProperty | ( | SimFileId | df_id,
 |  | SimFileId | ef_id,
 |  | UINT & | filesize,
 |  | UINT & | recordlength
 | ) |

void SimAccessor::Init ( )

BOOLEAN SimAccessor::IsAdnReadWritableIfFdnActive ( ) const [inline]

BOOLEAN SimAccessor::IsBdnActivated ( ) const [inline]

BOOLEAN SimAccessor::IsBdnReadWritableIfBdnNotActive ( ) const [inline]

BOOLEAN SimAccessor::IsFdnActivated ( ) const [inline]

BOOLEAN SimAccessor::IsSimAccessAllowed ( ) [static]

BOOLEAN SimAccessor::IsSimPresent ( ) [static]

BOOLEAN SimAccessor::IsUsimInserted ( ) [static]

MdhResult SimAccessor::MdhDeleteSms | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | const MdhDeletionCmd & | cmd
 | ) |

SimUpdateStatus SimAccessor::MdhGetSms | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | Tpdu & | tpdu,
 |  | MdhTimeStamp & | timestamp,
 |  | MdhExtendedData & | ext_data
 | ) |

MdhResult SimAccessor::MdhGetSms | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | TpduConc & | tpduconc,
 |  | MdhTimeStamp & | timestamp,
 |  | MdhExtendedData & | ext_data
 | ) |

MdhResult SimAccessor::MdhGetSmsReport | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | SmsrData & | data
 | ) |

MdhResult SimAccessor::MdhMakeView ( MdhViewHdl & view_hdl )

BOOLEAN SimAccessor::MdhRequestCsmsRefNo ( UINT16 & ref_no )

MdhResult SimAccessor::MdhSetSmsExtendedData | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | const MdhExtendedData & | ext_data
 | ) |

MdhResult SimAccessor::MdhSetStorageMedia ( MdhWorkMedia work_media )

MdhResult SimAccessor::MdhSetViewConfig | ( | MdhViewHdl | view_hdl,
 |  | const MdhViewConfig & | view_config
 | ) |

Sms::StorageType SimAccessor::MdhToSmsWorkMediaTranslation ( MdhWorkMedia work_media ) [static]

SimUpdateStatus SimAccessor::MdhUpdateSms | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | const Tpdu & | tpdu,
 |  | INT & | storedrecno,
 |  | MdhTimeStamp & | timestamp
 | ) |

MdhResult SimAccessor::MdhUpdateSms | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | const TpduNode & | tpdunode,
 |  | UINT8 & | no_saved,
 |  | INT & | storedrecno,
 |  | MdhTimeStamp & | timestamp
 | ) |

SimUpdateStatus SimAccessor::MdhUpdateSmsStatus | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | UINT8 | recordstatus
 | ) |

MdhResult SimAccessor::MdhUpdateSmsStatus | ( | MdhViewHdl | view_hdl,
 |  | INT | recno,
 |  | UINT8 | recordstatus,
 |  | BOOLEAN | complete
 | ) |

BOOLEAN SimAccessor::ModifyLock | ( | const SecLockCommand & | command,
 |  | SecLockStates & | lockstates
 | ) |

SmsMoreMessageType SimAccessor::QuerySmsMoreMessageType ( )

void SimAccessor::Reset ( )

BOOLEAN SimAccessor::SendProactiveCommand | ( | SimApduData * | apdu,
 |  | UINT8 & | responsevalue
 | ) |

BOOLEAN SimAccessor::SendProactiveCommandConfirmation ( )

void SimAccessor::SetAdnReadWritableState ( BOOLEAN state ) [inline]

void SimAccessor::SetBdnReadWritableState ( BOOLEAN state ) [inline]

void SimAccessor::SetBdnState ( BOOLEAN state ) [inline]

void SimAccessor::SetFdnState ( BOOLEAN state ) [inline]

void SimAccessor::SetInitialPrefferedStorageMedia ( Sms::StorageType type ) [inline]

SimUpdateStatus SimAccessor::SetSimData | ( | SimFileId | df_id,
 |  | SimFileId | ef_id,
 |  | BOOLEAN | istransparent,
 |  | UINT16 | offset,
 |  | const UINT8 * | data,
 |  | UINT8 | length,
 |  | BOOLEAN | usimcommand = FALSE
 | ) |

void SimAccessor::SetSimIndicator ( const SimIndicator indicator )

void SimAccessor::SetSimInfo ( const SimInfo & siminfo )

MdhWorkMedia SimAccessor::SmsToMdhWorkMediaTranslation ( Sms::StorageType work_media ) [static]

ChvStatus SimAccessor::UnblockChv | ( | ChvNo | chvno,
 |  | const CHAR * | unbchvptr,
 |  | const CHAR * | newchvptr,
 |  | ChvAttemptsStruct & | chvattempts
 | ) |

SimUpdateStatus SimAccessor::UpdateAcm | ( | INT | recno,
 |  | const Acm & | data,
 |  | AcmSelector | selector
 | ) |

SimUpdateStatus SimAccessor::UpdateCbmi | ( | INT | recno,
 |  | const CbmiData & | data
 | ) |

SimUpdateStatus SimAccessor::UpdateCbmir | ( | INT | recno,
 |  | const CbmiRange & | data
 | ) |

SimUpdateStatus SimAccessor::UpdateCphsCfuf ( const CphsCfufArray & data )

SimUpdateStatus SimAccessor::UpdateCphsCsp | ( | LineSelector | selector,
 |  | INT | noofgroup,
 |  | const CphsCspArray & | data
 | ) |

SimUpdateStatus SimAccessor::UpdateCphsVmwf ( const CphsVmwfArray & data )

SimUpdateStatus SimAccessor::UpdateDynamic2Flag ( UINT8 data )

SimUpdateStatus SimAccessor::UpdateDynamicFlag ( UINT8 data )

SimUpdateStatus SimAccessor::UpdateMaxAcm ( const Acm & data )

SimUpdateStatus SimAccessor::UpdateMbi | ( | UINT | recno,
 |  | const UINT8 * | mbidata,
 |  | UINT | recordlength
 | ) |

SimUpdateStatus SimAccessor::UpdateMruProperty | ( | UINT16 | type,
 |  | UINT8 | index,
 |  | UINT8 | bitnumber,
 |  | UINT8 | bitvalue
 | ) |

SimUpdateStatus SimAccessor::UpdateOrangeParam ( const SimEfOrangeParam & data )

SimUpdateStatus SimAccessor::UpdatePhoneBookEntry | ( | INT | recno,
 |  | PhoneBookType | phonebooktype,
 |  | INT | datalength,
 |  | const UINT8 * | data
 | ) |

SimUpdateStatus SimAccessor::UpdatePlmnList | ( | INT | start,
 |  | const UINT8 * | plmnlist,
 |  | INT | length
 | ) |

SimUpdateStatus SimAccessor::UpdatePlmnwActList | ( | INT | start,
 |  | const UsimPlmn * | plmnlist,
 |  | INT | length
 | ) |

SimUpdateStatus SimAccessor::UpdatePrefExtLanguageArray | ( | INT | startpos,
 |  | const ExtLanguageArray & | langarray
 | ) |

SimUpdateStatus SimAccessor::UpdatePrefLanguageArray | ( | INT | startpos,
 |  | const LanguageArray & | langarray
 | ) |

SimUpdateStatus SimAccessor::UpdatePuct ( const Puct & puct )

SimUpdateStatus SimAccessor::UpdateSmsParam | ( | INT | recno,
 |  | const UINT8 * | data,
 |  | INT | bufferlen
 | ) |

SimUpdateStatus SimAccessor::UpdateSmsr | ( | INT | recno,
 |  | UINT8 | link,
 |  | const SmsrData & | smsr
 | ) |

SimUpdateStatus SimAccessor::UsimSelect | ( | SimFileId | df_id,
 |  | SimFileId | ef_id
 | ) |

ChvStatus SimAccessor::VerifyChv | ( | ChvNo | chvno,
 |  | const CHAR * | chvptr,
 |  | ChvAttemptsStruct & | chvattempts
 | ) |

Friends And Related Function Documentation

friend class MessageQueueEmptyCondition [friend]

friend class MessageReceivedCondition [friend]

friend class MessageSendableCondition [friend]

friend class MessageStartCondition [friend]

friend class SimUserDispatcher [friend]

friend class UsimPlmnListDispatcher [friend]

friend class UsimSmsParamDispatcher [friend]

The documentation for this class was generated from the following files:
  • Adc/SimAccessor.hpp
  • Adc/SimAccessor.cpp
Generated on Wed Jan 25 01:50:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAcmMaxReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAcmMaxReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimAcmMaxReadIndArg:

[legend]
Collaboration diagram for SimAcmMaxReadIndArg:

[legend]

Public Types

enum | { ID = 1406 }

Public Member Functions

const Acm & | GetAcm () const
const SimUpdateStatus & | GetStatus () const
void | SetAcm (const Acm &acm)
void | SetStatus (const SimUpdateStatus &status)
SimAcmMaxReadIndArg ()

Static Public Member Functions

static const SimAcmMaxReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimAcmMaxReadIndArg: reflects arguments of signal SI_ACMMAX_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimAcmMaxReadIndArg::SimAcmMaxReadIndArg ( )

Member Function Documentation

const SimAcmMaxReadIndArg & SimAcmMaxReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Acm& SimAcmMaxReadIndArg::GetAcm ( ) const [inline]

const SimUpdateStatus& SimAcmMaxReadIndArg::GetStatus ( ) const [inline]

void SimAcmMaxReadIndArg::SetAcm ( const Acm & acm ) [inline]

void SimAcmMaxReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAcmMaxReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAcmMaxReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimAcmMaxReadReqArg:

[legend]
Collaboration diagram for SimAcmMaxReadReqArg:

[legend]

Public Types

enum | { ID = 2404 }

Public Member Functions

SimAcmMaxReadReqArg ()

Static Public Member Functions

static const SimAcmMaxReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimAcmMaxReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimAcmMaxReadReqArg::SimAcmMaxReadReqArg ( )

Member Function Documentation

const SimAcmMaxReadReqArg & SimAcmMaxReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAcmMaxUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAcmMaxUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimAcmMaxUpdIndArg:

[legend]
Collaboration diagram for SimAcmMaxUpdIndArg:

[legend]

Public Types

enum | { ID = 1407 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimAcmMaxUpdIndArg ()

Static Public Member Functions

static const SimAcmMaxUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimAcmMaxUpdIndArg: reflects arguments of signal SI_ACMMAX_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimAcmMaxUpdIndArg::SimAcmMaxUpdIndArg ( )

Member Function Documentation

const SimAcmMaxUpdIndArg & SimAcmMaxUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimAcmMaxUpdIndArg::GetStatus ( ) const [inline]

void SimAcmMaxUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAcmMaxUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAcmMaxUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimAcmMaxUpdReqArg:

[legend]
Collaboration diagram for SimAcmMaxUpdReqArg:

[legend]

Public Types

enum | { ID = 2405 }

Public Member Functions

const Acm & | GetAcm () const
void | SetAcm (const Acm &acm)
SimAcmMaxUpdReqArg ()
SimAcmMaxUpdReqArg (const Acm &acm)

Static Public Member Functions

static const SimAcmMaxUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimAcmMaxUpdReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimAcmMaxUpdReqArg::SimAcmMaxUpdReqArg ( const Acm & acm )

SimAcmMaxUpdReqArg::SimAcmMaxUpdReqArg ( )

Member Function Documentation

const SimAcmMaxUpdReqArg & SimAcmMaxUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Acm& SimAcmMaxUpdReqArg::GetAcm ( ) const [inline]

void SimAcmMaxUpdReqArg::SetAcm ( const Acm & acm ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAcmReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAcmReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimAcmReadIndArg:

[legend]
Collaboration diagram for SimAcmReadIndArg:

[legend]

Public Types

enum | { ID = 1404 }

Public Member Functions

const Acm & | GetAcm () const
INT | GetCount () const
INT | GetRecno () const
const AcmSelector & | GetSelector () const
const SimUpdateStatus & | GetStatus () const
void | SetAcm (const Acm &acm)
void | SetCount (INT count)
void | SetRecno (INT recno)
void | SetSelector (const AcmSelector &selector)
void | SetStatus (const SimUpdateStatus &status)
SimAcmReadIndArg ()

Static Public Member Functions

static const SimAcmReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimAcmReadIndArg: reflects arguments of signal SI_ACM_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimAcmReadIndArg::SimAcmReadIndArg ( )

Member Function Documentation

const SimAcmReadIndArg & SimAcmReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Acm& SimAcmReadIndArg::GetAcm ( ) const [inline]

INT SimAcmReadIndArg::GetCount ( ) const [inline]

INT SimAcmReadIndArg::GetRecno ( ) const [inline]

const AcmSelector& SimAcmReadIndArg::GetSelector ( ) const [inline]

const SimUpdateStatus& SimAcmReadIndArg::GetStatus ( ) const [inline]

void SimAcmReadIndArg::SetAcm ( const Acm & acm ) [inline]

void SimAcmReadIndArg::SetCount ( INT count ) [inline]

void SimAcmReadIndArg::SetRecno ( INT recno ) [inline]

void SimAcmReadIndArg::SetSelector ( const AcmSelector & selector ) [inline]

void SimAcmReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAcmReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAcmReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimAcmReadReqArg:

[legend]
Collaboration diagram for SimAcmReadReqArg:

[legend]

Public Types

enum | { ID = 2402 }

Public Member Functions

INT | GetRecNo () const
const AcmSelector & | GetSelector () const
void | SetRecNo (INT rec_no)
void | SetSelector (const AcmSelector &selector)
SimAcmReadReqArg ()
SimAcmReadReqArg (INT rec_no, const AcmSelector &selector)

Static Public Member Functions

static const SimAcmReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimAcmReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimAcmReadReqArg::SimAcmReadReqArg | ( | INT | rec_no,
 |  | const AcmSelector & | selector
 | ) |

SimAcmReadReqArg::SimAcmReadReqArg ( )

Member Function Documentation

const SimAcmReadReqArg & SimAcmReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimAcmReadReqArg::GetRecNo ( ) const [inline]

const AcmSelector& SimAcmReadReqArg::GetSelector ( ) const [inline]

void SimAcmReadReqArg::SetRecNo ( INT rec_no ) [inline]

void SimAcmReadReqArg::SetSelector ( const AcmSelector & selector ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAcmUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAcmUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimAcmUpdIndArg:

[legend]
Collaboration diagram for SimAcmUpdIndArg:

[legend]

Public Types

enum | { ID = 1405 }

Public Member Functions

const AcmSelector & | GetSelector () const
const SimUpdateStatus & | GetStatus () const
void | SetSelector (const AcmSelector &selector)
void | SetStatus (const SimUpdateStatus &status)
SimAcmUpdIndArg ()

Static Public Member Functions

static const SimAcmUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimAcmUpdIndArg: reflects arguments of signal SI_ACM_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimAcmUpdIndArg::SimAcmUpdIndArg ( )

Member Function Documentation

const SimAcmUpdIndArg & SimAcmUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const AcmSelector& SimAcmUpdIndArg::GetSelector ( ) const [inline]

const SimUpdateStatus& SimAcmUpdIndArg::GetStatus ( ) const [inline]

void SimAcmUpdIndArg::SetSelector ( const AcmSelector & selector ) [inline]

void SimAcmUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAcmUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAcmUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimAcmUpdReqArg:

[legend]
Collaboration diagram for SimAcmUpdReqArg:

[legend]

Public Types

enum | { ID = 2403 }

Public Member Functions

const Acm & | GetAcm () const
INT | GetRecNo () const
const AcmSelector & | GetSelector () const
void | SetAcm (const Acm &acm)
void | SetRecNo (INT rec_no)
void | SetSelector (const AcmSelector &selector)
SimAcmUpdReqArg ()
SimAcmUpdReqArg (INT rec_no, const Acm &acm, const AcmSelector &selector)

Static Public Member Functions

static const SimAcmUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimAcmUpdateReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimAcmUpdReqArg::SimAcmUpdReqArg | ( | INT | rec_no,
 |  | const Acm & | acm,
 |  | const AcmSelector & | selector
 | ) |

SimAcmUpdReqArg::SimAcmUpdReqArg ( )

Member Function Documentation

const SimAcmUpdReqArg & SimAcmUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Acm& SimAcmUpdReqArg::GetAcm ( ) const [inline]

INT SimAcmUpdReqArg::GetRecNo ( ) const [inline]

const AcmSelector& SimAcmUpdReqArg::GetSelector ( ) const [inline]

void SimAcmUpdReqArg::SetAcm ( const Acm & acm ) [inline]

void SimAcmUpdReqArg::SetRecNo ( INT rec_no ) [inline]

void SimAcmUpdReqArg::SetSelector ( const AcmSelector & selector ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAlphaIdentifier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAlphaIdentifier Class Reference

represents a tlv alpha identifier - GSM 11.14 [12.2] More...

#include <Apoxi/Apc/SimDataTypes.hpp>

Collaboration diagram for SimAlphaIdentifier:

[legend]

Public Member Functions

void | Clear ()
INT | Convert2Buffer (UINT8 *buffer, INT &len) const
INT | Convert2SdlAlpha (T_ALPHA_IDENTIFIER &sdl_alpha) const
const WString & | GetText () const
BOOLEAN | IsValid () const
Return TRUE if the SimAlphaIdentifier is invalid (not present form SIM).
void | SetValid (BOOLEAN identifier_valid)
Set FALSE if the SimAlphaIdentifier should be invalid.
SimAlphaIdentifier (const WString &text)
SimAlphaIdentifier (const T_ALPHA_IDENTIFIER &sdl_alpha_id)
SimAlphaIdentifier (const Tlv &tlv)
SimAlphaIdentifier (const TlvAtom *data_ptr, const INT len)
SimAlphaIdentifier ()
~SimAlphaIdentifier ()

Detailed Description

represents a tlv alpha identifier - GSM 11.14 [12.2]

Constructor & Destructor Documentation

SimAlphaIdentifier::SimAlphaIdentifier ( )

SimAlphaIdentifier::SimAlphaIdentifier | ( | const TlvAtom * | data_ptr,
 |  | const INT | len
 | ) |

SimAlphaIdentifier::SimAlphaIdentifier ( const Tlv & tlv )

SimAlphaIdentifier::SimAlphaIdentifier ( const T_ALPHA_IDENTIFIER & sdl_alpha_id )

SimAlphaIdentifier::SimAlphaIdentifier ( const WString & text )

SimAlphaIdentifier::~SimAlphaIdentifier ( )

Member Function Documentation

void SimAlphaIdentifier::Clear ( ) [inline]

INT SimAlphaIdentifier::Convert2Buffer | ( | UINT8 * | buffer,
 |  | INT & | len
 | ) | const

updates the given buffer length len to the number of effective converted length and returns the number of converted characters.

INT SimAlphaIdentifier::Convert2SdlAlpha ( T_ALPHA_IDENTIFIER & sdl_alpha ) const

updates the buffer length of the sdl_alpha structure to the number of effective converted length and returns the number of converted characters.

const WString& SimAlphaIdentifier::GetText ( ) const [inline]

BOOLEAN SimAlphaIdentifier::IsValid ( ) const [inline]

Return TRUE if the SimAlphaIdentifier is invalid (not present form SIM).

void SimAlphaIdentifier::SetValid ( BOOLEAN identifier_valid ) [inline]

Set FALSE if the SimAlphaIdentifier should be invalid.

The documentation for this class was generated from the following files:
  • Apc/SimDataTypes.hpp
  • Apc/SimDataTypes.cpp
Generated on Wed Jan 25 01:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimApdu Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimApdu Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [261]

Field Documentation

UINT8 SimApdu::val[261]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:50:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimApduData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimApduData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for SimApduData:

[legend]

Public Member Functions

SimApduData ()

Data Fields

SimApdu apdu
INT length

Constructor & Destructor Documentation

SimApduData::SimApduData ( ) [inline]

Field Documentation

SimApdu SimApduData::apdu

INT SimApduData::length

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:50:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAtom< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAtom< T > Class Template Reference

#include <Apoxi/Apc/SimDataTypes.hpp>

Inheritance diagram for SimAtom< T >:

[legend]
Collaboration diagram for SimAtom< T >:

[legend]

Public Member Functions

void | Clear (UINT8 set=0x00)
const T & | Get () const
BOOLEAN | IsInvalid () const
BOOLEAN | operator< (const T &elem) const
BOOLEAN | operator< (const SimAtom< T > &sim_elem) const
BOOLEAN | operator== (const T &elem) const
BOOLEAN | operator== (const SimAtom< T > &sim_elem) const
SimAtom (const T &elem=0)

template<class T>
class SimAtom< T >

Constructor & Destructor Documentation

template<class T>
SimAtom< T >::SimAtom ( const T & elem = 0 ) [inline]

Member Function Documentation

template<class T>
void SimAtom< T >::Clear ( UINT8 set = 0x00 ) [inline]

template<class T>
const T& SimAtom< T >::Get ( ) const [inline]

template<class T>
BOOLEAN SimAtom< T >::IsInvalid ( ) const [inline]

Reimplemented in SimItemId.

template<class T>
BOOLEAN SimAtom< T >::operator< ( const T & elem ) const [inline]

template<class T>
BOOLEAN SimAtom< T >::operator< ( const SimAtom< T > & sim_elem ) const [inline]

template<class T>
BOOLEAN SimAtom< T >::operator== ( const T & elem ) const [inline]

template<class T>
BOOLEAN SimAtom< T >::operator== ( const SimAtom< T > & sim_elem ) const [inline]

The documentation for this class was generated from the following file:
  • Apc/SimDataTypes.hpp
Generated on Wed Jan 25 01:50:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimAuxHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimAuxHandler Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimAuxHandler.hpp>

Inheritance diagram for SimAuxHandler:

[legend]
Collaboration diagram for SimAuxHandler:

[legend]

Public Member Functions

BOOLEAN | CheckSpnData (const Plmn &regplmn, BOOLEAN &showregplmn, BOOLEAN &showspnname, WString &spnname, BOOLEAN use_spn_display_condition)
BOOLEAN | DeleteAllExtLanguages (INT instance_nr)
BOOLEAN | DeleteAllLanguages ()
BOOLEAN | DeleteAllPlmns ()
BOOLEAN | DeleteAllPlmnwAct ()
BOOLEAN | DeleteExtLanguage (INT idx, INT instance_nr)
BOOLEAN | DeleteLanguage (INT idx)
BOOLEAN | DeletePlmn (INT idx)
BOOLEAN | DeletePlmnwAct (INT idx)
BOOLEAN | DetectChvProtection (UINT16 fileid, ChvNo &chvno)
BOOLEAN | GetAcm (UINT32 &value, AcmSelector selector=Acm1)
WString | GetActiveExtLanguage () const
BcdPlmn | GetBcdPlmn (INT idx) const
BcdPlmn | GetBcdPlmnwAct (INT idx) const
BOOLEAN | GetCbmi (UINT idx, UINT16 &cbmi)
BOOLEAN | GetCbmiRange (UINT idx, UINT16 &rangehigh, UINT16 &rangelow)
BOOLEAN | GetCcp (UINT idx, CcpData &data)
BOOLEAN | GetCmi (UINT idx, WString &alphaid, UINT8 &cmi)
BOOLEAN | GetEcc (UINT idx, WString &eccstr)
UINT8 | GetEccCount () const
BOOLEAN | GetEmlppSetupCallCondition (EmlppPriorityLevel idx, BOOLEAN &condition)
BOOLEAN | GetEmlppSubscription (EmlppPriorityLevel idx, BOOLEAN &subscribed)
BOOLEAN | GetEonsPlmnName (const BcdPlmn &checkplmn, UINT16 lac, WString &longname, WString &shortname)
WString | GetExtLanguage (INT idx, INT instance_nr) const
UINT8 | GetExtLanguageCount (INT instance_nr) const
BOOLEAN | GetFdnState () const
BOOLEAN | GetIccidString (WString &iccid) const
BOOLEAN | GetImeiString (WString &imei)
BcdPlmn | GetImsiBcdPlmn () const
BOOLEAN | GetImsiString (WString &imsi) const
SimInitResult | GetInitResult () const
Language | GetLanguage (INT idx) const
UINT8 | GetLanguageCount () const
BOOLEAN | GetLocationBcdPlmn (BcdPlmn &plmn)
BOOLEAN | GetLocationLac (UINT16 &lac)
BOOLEAN | GetLocationUpdateStatus (LocationUpdateStatus &status)
BOOLEAN | GetMaxAcm (UINT32 &value)
UINT8 | GetMaxCbmiCount () const
UINT8 | GetMaxCbmiRangeCount () const
UINT8 | GetMaxCcpCount () const
UINT8 | GetMaxCmiCount () const
UINT8 | GetMaxExtLangCount (INT instance_nr) const
UINT8 | GetMaxLangCount () const
UINT8 | GetMaxMbiCount () const
UINT8 | GetMaxPlmnCount () const
BOOLEAN | GetMbiRecord (UINT idx, UINT8 *buffer)
UINT8 | GetMbiRecordSize () const
UINT16 | GetPlmnAct (INT idx) const
UINT8 | GetPlmnCount () const
BOOLEAN | GetPuctData (WString &currencycode, UINT &eppu, INT &exponent)
BOOLEAN | GetServiceValues (UINT idx, BOOLEAN &allocated, BOOLEAN &activated)
BOOLEAN | GetSimErrorCode (SimErrorCode &errorcode) const
BOOLEAN | GetSimInfo (SimInfo &siminfo) const
BOOLEAN | GetSimLockStates (SimLockStates &lockstates) const
SimMexeCertificate * | GetSimMexeCertificate (UINT idx)
UINT | GetSimMexeCertificateCount () const
BOOLEAN | GetSpnData (WString &spnstr, BOOLEAN &condition)
UINT8 | GetSstCount () const
BOOLEAN | InitMexe ()
BOOLEAN | InsertExtLanguage (INT idx, const WString &language, INT instance_nr)
BOOLEAN | InsertLanguage (INT idx, Language language)
BOOLEAN | InsertPlmn (INT idx, BcdPlmn plmn)
BOOLEAN | InsertPlmnwAct (INT idx, BcdPlmn plmn, UINT16 rat)
BOOLEAN | IsOfmToBeActivated ()
BOOLEAN | IsPlmnwactPresent ()
BOOLEAN | IsSimRefreshPossible () const
BOOLEAN | IsSimResetPossible () const
BOOLEAN | LookupPlmnName (const Plmn &plmn, WString &longname, WString &shortname, NetType &nettype, WString &countryname)
void | MarkAcmMaxUnread ()
void | MarkAcmUnread ()
void | MarkCbmirUnread ()
void | MarkCbmiUnread ()
void | MarkCcpUnread ()
void | MarkEccUnread ()
void | MarkImsiUnread ()
void | MarkPrefExtLangUnread ()
void | MarkPrefLangUnread ()
void | MarkPrefPlmnUnread ()
void | MarkPuctUnread ()
void | MarkSpnUnread ()
void | MarkSstUnread ()
void | Reset ()
BOOLEAN | RetrieveCbmi ()
BOOLEAN | RetrieveCbmiRanges ()
BOOLEAN | RetrieveCcp ()
BOOLEAN | RetrieveCmi ()
BOOLEAN | RetrieveEccList ()
BOOLEAN | RetrieveEonsData (BOOLEAN pnnenabled, BOOLEAN oplenabled)
BOOLEAN | RetrieveExtLanguageList (INT instance_nr)
BOOLEAN | RetrieveLanguageList ()
BOOLEAN | RetrieveLociData (LociData &locidata)
BOOLEAN | RetrieveMbi ()
BOOLEAN | RetrievePlmnList ()
BOOLEAN | RetrievePlmnwactList ()
BOOLEAN | RetrieveSst ()
void | SetActiveExtLanguage (const WString &language)
void | SetImsi (const Imsi &imsi)
void | SetInitResult (const SimInitResult &initresult)
void | SetSimErrorCode (const SimErrorCode errorcode)
void | SetSimLockStatus (const SimLockStates &lockstates)
void | SetSimRefreshPossible (BOOLEAN refreshable)
void | SetSimResetPossible (BOOLEAN resetable)
SimAuxHandler ()
BOOLEAN | UpdateAcm (UINT32 value, AcmSelector selector=Acm1)
BOOLEAN | UpdateCbmi (UINT idx, UINT16 cbmi)
BOOLEAN | UpdateCbmiRange (UINT idx, UINT16 rangehigh, UINT16 rangelow)
BOOLEAN | UpdateCcp (UINT idx, const CcpData &data)
BOOLEAN | UpdateExtLanguage (INT idx, const WString &language, INT instance_nr)
BOOLEAN | UpdateLanguage (INT idx, Language language)
BOOLEAN | UpdateMaxAcm (UINT32 value)
BOOLEAN | UpdateMbiRecord (UINT idx, const UINT8 *buffer)
BOOLEAN | UpdatePlmn (INT idx, BcdPlmn plmn)
BOOLEAN | UpdatePlmnwAct (INT idx, BcdPlmn plmn, UINT16 rat)
BOOLEAN | UpdatePuctData (const WString &currencycode, UINT eppu, INT exponent)
virtual | ~SimAuxHandler ()

Data Structures

struct | ExtLanguageBuffer
The documentation for this class was generated from the following files:
  • Adc/SimAuxHandler.hpp
  • Adc/SimAuxHandler.cpp
Generated on Wed Jan 25 01:50:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimBrowserTermResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimBrowserTermResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimBrowserTermResArg:

[legend]
Collaboration diagram for SimBrowserTermResArg:

[legend]

Public Types

enum | { ID = 1326 }

Public Member Functions

UINT8 | GetSimResult () const
void | SetSimResult (UINT8 sim_result)
SimBrowserTermResArg ()

Static Public Member Functions

static const SimBrowserTermResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimBrowserTermResArg: reflects arguments of signal SIBR_BROWSER_TERM_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimBrowserTermResArg::SimBrowserTermResArg ( )

Member Function Documentation

const SimBrowserTermResArg & SimBrowserTermResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimBrowserTermResArg::GetSimResult ( ) const [inline]

void SimBrowserTermResArg::SetSimResult ( UINT8 sim_result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimBrowserTermResMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimBrowserTermResMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimBrowserTermResMsg:

[legend]
Collaboration diagram for SimBrowserTermResMsg:

[legend]

Public Types

enum | { ID = 18333 }

Public Member Functions

virtual Message * | Clone () const
const SimBrowserTermResArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimBrowserTermResArg &arg)
SimBrowserTermResMsg (ExecutionContext *context, const SimBrowserTermResArg &arg)
virtual | ~SimBrowserTermResMsg ()

Detailed Description

SimBrowserTermResMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimBrowserTermResMsg::SimBrowserTermResMsg | ( | ExecutionContext * | context,
 |  | const SimBrowserTermResArg & | arg
 | ) |

SimBrowserTermResMsg::~SimBrowserTermResMsg ( ) [virtual]

Member Function Documentation

Message * SimBrowserTermResMsg::Clone ( ) const [virtual]

Implements Message.

const SimBrowserTermResArg& SimBrowserTermResMsg::GetArg ( ) const [inline]

const MsgMetaData & SimBrowserTermResMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimBrowserTermResMsg::SetArg ( const SimBrowserTermResArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:50:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCallSetupMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCallSetupMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimCallSetupMsg:

[legend]
Collaboration diagram for SimCallSetupMsg:

[legend]

Public Types

enum | { ID = 18301 }

Public Member Functions

virtual Message * | Clone () const
const SimTkCallSetupIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimTkCallSetupIndArg &arg)
SimCallSetupMsg (ExecutionContext *context, const SimTkCallSetupIndArg &arg)
virtual | ~SimCallSetupMsg ()

Detailed Description

SimCallSetupMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCallSetupMsg::SimCallSetupMsg | ( | ExecutionContext * | context,
 |  | const SimTkCallSetupIndArg & | arg
 | ) |

SimCallSetupMsg::~SimCallSetupMsg ( ) [virtual]

Member Function Documentation

Message * SimCallSetupMsg::Clone ( ) const [virtual]

Implements Message.

const SimTkCallSetupIndArg& SimCallSetupMsg::GetArg ( ) const [inline]

const MsgMetaData & SimCallSetupMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimCallSetupMsg::SetArg ( const SimTkCallSetupIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:50:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCallSetupRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCallSetupRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimCallSetupRejectedMsg:

[legend]
Collaboration diagram for SimCallSetupRejectedMsg:

[legend]

Public Types

enum | { ID = 18319 }

Public Member Functions

virtual Message * | Clone () const
const CallErrorCause & | GetCause () const
virtual const MsgMetaData & | GetMetaData () const
void | SetCause (const CallErrorCause &cause)
SimCallSetupRejectedMsg (ExecutionContext *context, const CallErrorCause &cause)
virtual | ~SimCallSetupRejectedMsg ()

Detailed Description

SimCallSetupRejectedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCallSetupRejectedMsg::SimCallSetupRejectedMsg | ( | ExecutionContext * | context,
 |  | const CallErrorCause & | cause
 | ) |

SimCallSetupRejectedMsg::~SimCallSetupRejectedMsg ( ) [virtual]

Member Function Documentation

Message * SimCallSetupRejectedMsg::Clone ( ) const [virtual]

Implements Message.

const CallErrorCause& SimCallSetupRejectedMsg::GetCause ( ) const [inline]

const MsgMetaData & SimCallSetupRejectedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimCallSetupRejectedMsg::SetCause ( const CallErrorCause & cause ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:50:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCbmiReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCbmiReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCbmiReadIndArg:

[legend]
Collaboration diagram for SimCbmiReadIndArg:

[legend]

Public Types

enum | { ID = 1428 }

Public Member Functions

const CbmiData & | GetCbmiData () const
const SimUpdateStatus & | GetStatus () const
void | SetCbmiData (const CbmiData &cbmi_data)
void | SetStatus (const SimUpdateStatus &status)
SimCbmiReadIndArg ()

Static Public Member Functions

static const SimCbmiReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCbmiReadIndArg: reflects arguments of signal SI_CBMI_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCbmiReadIndArg::SimCbmiReadIndArg ( )

Member Function Documentation

const SimCbmiReadIndArg & SimCbmiReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CbmiData& SimCbmiReadIndArg::GetCbmiData ( ) const [inline]

const SimUpdateStatus& SimCbmiReadIndArg::GetStatus ( ) const [inline]

void SimCbmiReadIndArg::SetCbmiData ( const CbmiData & cbmi_data ) [inline]

void SimCbmiReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCbmiReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCbmiReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCbmiReadReqArg:

[legend]
Collaboration diagram for SimCbmiReadReqArg:

[legend]

Public Types

enum | { ID = 2426 }

Public Member Functions

INT | GetRecNo () const
void | SetRecNo (INT rec_no)
SimCbmiReadReqArg ()
SimCbmiReadReqArg (INT rec_no)

Static Public Member Functions

static const SimCbmiReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCbmiReadReqArg: reflects arguments of signal SI_CBMI_READ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCbmiReadReqArg::SimCbmiReadReqArg ( INT rec_no )

SimCbmiReadReqArg::SimCbmiReadReqArg ( )

Member Function Documentation

const SimCbmiReadReqArg & SimCbmiReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimCbmiReadReqArg::GetRecNo ( ) const [inline]

void SimCbmiReadReqArg::SetRecNo ( INT rec_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:50:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCbmirReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCbmirReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCbmirReadIndArg:

[legend]
Collaboration diagram for SimCbmirReadIndArg:

[legend]

Public Types

enum | { ID = 1429 }

Public Member Functions

const CbmiRange & | GetCbmiRange () const
const SimUpdateStatus & | GetStatus () const
void | SetCbmiRange (const CbmiRange &cbmi_range)
void | SetStatus (const SimUpdateStatus &status)
SimCbmirReadIndArg ()

Static Public Member Functions

static const SimCbmirReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCbmirReadIndArg: reflects arguments of signal SI_CBMIR_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCbmirReadIndArg::SimCbmirReadIndArg ( )

Member Function Documentation

const SimCbmirReadIndArg & SimCbmirReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CbmiRange& SimCbmirReadIndArg::GetCbmiRange ( ) const [inline]

const SimUpdateStatus& SimCbmirReadIndArg::GetStatus ( ) const [inline]

void SimCbmirReadIndArg::SetCbmiRange ( const CbmiRange & cbmi_range ) [inline]

void SimCbmirReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCbmirReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCbmirReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCbmirReadReqArg:

[legend]
Collaboration diagram for SimCbmirReadReqArg:

[legend]

Public Types

enum | { ID = 2427 }

Public Member Functions

INT | GetRecNo () const
void | SetRecNo (INT rec_no)
SimCbmirReadReqArg ()
SimCbmirReadReqArg (INT rec_no)

Static Public Member Functions

static const SimCbmirReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCbmirReadReqArg: reflects arguments of signal SI_CBMIR_READ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCbmirReadReqArg::SimCbmirReadReqArg ( INT rec_no )

SimCbmirReadReqArg::SimCbmirReadReqArg ( )

Member Function Documentation

const SimCbmirReadReqArg & SimCbmirReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimCbmirReadReqArg::GetRecNo ( ) const [inline]

void SimCbmirReadReqArg::SetRecNo ( INT rec_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCbmirUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCbmirUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCbmirUpdIndArg:

[legend]
Collaboration diagram for SimCbmirUpdIndArg:

[legend]

Public Types

enum | { ID = 1431 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimCbmirUpdIndArg ()

Static Public Member Functions

static const SimCbmirUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCbmirUpdIndArg: reflects arguments of signal SI_CBMIR_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCbmirUpdIndArg::SimCbmirUpdIndArg ( )

Member Function Documentation

const SimCbmirUpdIndArg & SimCbmirUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimCbmirUpdIndArg::GetStatus ( ) const [inline]

void SimCbmirUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCbmirUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCbmirUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCbmirUpdReqArg:

[legend]
Collaboration diagram for SimCbmirUpdReqArg:

[legend]

Public Types

enum | { ID = 2429 }

Public Member Functions

const CbmiRange & | GetCbmiRange () const
INT | GetRecNo () const
void | SetCbmiRange (const CbmiRange &cbmi_range)
void | SetRecNo (INT rec_no)
SimCbmirUpdReqArg ()
SimCbmirUpdReqArg (INT rec_no, const CbmiRange &cbmi_range)

Static Public Member Functions

static const SimCbmirUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCbmirUpdReqArg: reflects arguments of signal SI_CBMIR_UPDATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCbmirUpdReqArg::SimCbmirUpdReqArg | ( | INT | rec_no,
 |  | const CbmiRange & | cbmi_range
 | ) |

SimCbmirUpdReqArg::SimCbmirUpdReqArg ( )

Member Function Documentation

const SimCbmirUpdReqArg & SimCbmirUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CbmiRange& SimCbmirUpdReqArg::GetCbmiRange ( ) const [inline]

INT SimCbmirUpdReqArg::GetRecNo ( ) const [inline]

void SimCbmirUpdReqArg::SetCbmiRange ( const CbmiRange & cbmi_range ) [inline]

void SimCbmirUpdReqArg::SetRecNo ( INT rec_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCbmiUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCbmiUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCbmiUpdIndArg:

[legend]
Collaboration diagram for SimCbmiUpdIndArg:

[legend]

Public Types

enum | { ID = 1430 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimCbmiUpdIndArg ()

Static Public Member Functions

static const SimCbmiUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCbmiUpdIndArg: reflects arguments of signal SI_CBMI_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCbmiUpdIndArg::SimCbmiUpdIndArg ( )

Member Function Documentation

const SimCbmiUpdIndArg & SimCbmiUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimCbmiUpdIndArg::GetStatus ( ) const [inline]

void SimCbmiUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCbmiUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCbmiUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCbmiUpdReqArg:

[legend]
Collaboration diagram for SimCbmiUpdReqArg:

[legend]

Public Types

enum | { ID = 2428 }

Public Member Functions

const CbmiData & | GetCbmiData () const
INT | GetRecNo () const
void | SetCbmiData (const CbmiData &cbmi_data)
void | SetRecNo (INT rec_no)
SimCbmiUpdReqArg ()
SimCbmiUpdReqArg (INT rec_no, const CbmiData &cbmi_data)

Static Public Member Functions

static const SimCbmiUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCbmiReadReqArg: reflects arguments of signal SI_CBMI_UPDATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCbmiUpdReqArg::SimCbmiUpdReqArg | ( | INT | rec_no,
 |  | const CbmiData & | cbmi_data
 | ) |

SimCbmiUpdReqArg::SimCbmiUpdReqArg ( )

Member Function Documentation

const SimCbmiUpdReqArg & SimCbmiUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CbmiData& SimCbmiUpdReqArg::GetCbmiData ( ) const [inline]

INT SimCbmiUpdReqArg::GetRecNo ( ) const [inline]

void SimCbmiUpdReqArg::SetCbmiData ( const CbmiData & cbmi_data ) [inline]

void SimCbmiUpdReqArg::SetRecNo ( INT rec_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCcpReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCcpReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCcpReadIndArg:

[legend]
Collaboration diagram for SimCcpReadIndArg:

[legend]

Public Types

enum | { ID = 1432 }

Public Member Functions

const CcpData & | GetCcpData () const
const SimUpdateStatus & | GetStatus () const
void | SetCcpData (const CcpData &ccp_data)
void | SetStatus (const SimUpdateStatus &status)
SimCcpReadIndArg ()

Static Public Member Functions

static const SimCcpReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCcpReadIndArg: reflects arguments of signal SI_CCP_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCcpReadIndArg::SimCcpReadIndArg ( )

Member Function Documentation

const SimCcpReadIndArg & SimCcpReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CcpData& SimCcpReadIndArg::GetCcpData ( ) const [inline]

const SimUpdateStatus& SimCcpReadIndArg::GetStatus ( ) const [inline]

void SimCcpReadIndArg::SetCcpData ( const CcpData & ccp_data ) [inline]

void SimCcpReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCcpReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCcpReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCcpReadReqArg:

[legend]
Collaboration diagram for SimCcpReadReqArg:

[legend]

Public Types

enum | { ID = 2430 }

Public Member Functions

INT | GetRecNo () const
void | SetRecNo (INT rec_no)
SimCcpReadReqArg ()
SimCcpReadReqArg (INT rec_no)

Static Public Member Functions

static const SimCcpReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCcpReadReqArg: reflects arguments of signal SI_CCP_READ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCcpReadReqArg::SimCcpReadReqArg ( INT rec_no )

SimCcpReadReqArg::SimCcpReadReqArg ( )

Member Function Documentation

const SimCcpReadReqArg & SimCcpReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimCcpReadReqArg::GetRecNo ( ) const [inline]

void SimCcpReadReqArg::SetRecNo ( INT rec_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCcpUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCcpUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCcpUpdIndArg:

[legend]
Collaboration diagram for SimCcpUpdIndArg:

[legend]

Public Types

enum | { ID = 1433 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimCcpUpdIndArg ()

Static Public Member Functions

static const SimCcpUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCcpUpdIndArg: reflects arguments of signal SI_CCP_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCcpUpdIndArg::SimCcpUpdIndArg ( )

Member Function Documentation

const SimCcpUpdIndArg & SimCcpUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimCcpUpdIndArg::GetStatus ( ) const [inline]

void SimCcpUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCcpUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCcpUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCcpUpdReqArg:

[legend]
Collaboration diagram for SimCcpUpdReqArg:

[legend]

Public Types

enum | { ID = 2431 }

Public Member Functions

const CcpData & | GetCcpData () const
INT | GetRecNo () const
void | SetCcpData (const CcpData &ccp_data)
void | SetRecNo (INT rec_no)
SimCcpUpdReqArg ()
SimCcpUpdReqArg (INT rec_no, const CcpData &ccp_data)

Static Public Member Functions

static const SimCcpUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCcpUpdReqArg: reflects arguments of signal SI_CCP_UPDATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCcpUpdReqArg::SimCcpUpdReqArg | ( | INT | rec_no,
 |  | const CcpData & | ccp_data
 | ) |

SimCcpUpdReqArg::SimCcpUpdReqArg ( )

Member Function Documentation

const SimCcpUpdReqArg & SimCcpUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CcpData& SimCcpUpdReqArg::GetCcpData ( ) const [inline]

INT SimCcpUpdReqArg::GetRecNo ( ) const [inline]

void SimCcpUpdReqArg::SetCcpData ( const CcpData & ccp_data ) [inline]

void SimCcpUpdReqArg::SetRecNo ( INT rec_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimChvHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimChvHandler Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimChvHandler.hpp>

Inheritance diagram for SimChvHandler:

[legend]
Collaboration diagram for SimChvHandler:

[legend]

Public Member Functions

ChvStatus | ChangeChv (ChvNo chv_no, const WString &old_chv_str, const WString &new_chv_str)
change Chv
ChvStatus | DisableChv (ChvNo chv_no, const WString &chv_str)
disable Chv
ChvStatus | EnableChv (ChvNo chv_no, const WString &chv_str)
enable Chv
const ChvData & | GetChvData (INT idx) const
const Plmn & | GetImsiPlmn () const
INT | GetMaxNumbersStored () const
const SecLockStates & | GetSecLockStates () const
void | InitChvData (const SimInfo &simInfo)
BOOLEAN | IsUnlockingAllowedKeyBased ()
BOOLEAN | IsUnlockingAllowedOnStartup ()
BOOLEAN | IsUnlockingAllowedPerMenu ()
BOOLEAN | ModifyLock (const SecLockAction lockaction, const SecLockType locktype, const WString &oldpwd, const WString &newpwd)
void | RefreshChvData (const ChvData &chv_data)
void | Reset ()
void | SetImsiPlmn (const Plmn &plmn)
void | SetSecLockStates (const SecLockStates &lockstates)
SimChvHandler ()
ChvStatus | UnblockChv (ChvNo chv_no, const WString &unblocking_str, const WString &new_chv_str)
unblock Chv
BOOLEAN | UpdateChvData (ChvNo no, ChvStatus status, ChvAttempts attempts_left=c_attempts_left_undefined, ChvAttempts unblocking_attempts_left=c_attempts_left_undefined)
ChvStatus | VerifyChv (ChvNo chv_no, const WString &chv_str)
verify Chv
virtual | ~SimChvHandler ()

Constructor & Destructor Documentation

SimChvHandler::SimChvHandler ( )

SimChvHandler::~SimChvHandler ( ) [virtual]

Member Function Documentation

ChvStatus SimChvHandler::ChangeChv | ( | ChvNo | chv_no,
 |  | const WString & | old_chv_str,
 |  | const WString & | new_chv_str
 | ) |

change Chv

ChvStatus SimChvHandler::DisableChv | ( | ChvNo | chv_no,
 |  | const WString & | chv_str
 | ) |

disable Chv

ChvStatus SimChvHandler::EnableChv | ( | ChvNo | chv_no,
 |  | const WString & | chv_str
 | ) |

enable Chv

const ChvData & SimChvHandler::GetChvData ( INT idx ) const

const Plmn& SimChvHandler::GetImsiPlmn ( ) const [inline]

INT SimChvHandler::GetMaxNumbersStored ( ) const

const SecLockStates& SimChvHandler::GetSecLockStates ( ) const [inline]

void SimChvHandler::InitChvData ( const SimInfo & simInfo )

BOOLEAN SimChvHandler::IsUnlockingAllowedKeyBased ( )

BOOLEAN SimChvHandler::IsUnlockingAllowedOnStartup ( )

BOOLEAN SimChvHandler::IsUnlockingAllowedPerMenu ( )

BOOLEAN SimChvHandler::ModifyLock | ( | const SecLockAction | lockaction,
 |  | const SecLockType | locktype,
 |  | const WString & | oldpwd,
 |  | const WString & | newpwd
 | ) |

void SimChvHandler::RefreshChvData ( const ChvData & chv_data )

void SimChvHandler::Reset ( )

void SimChvHandler::SetImsiPlmn ( const Plmn & plmn ) [inline]

void SimChvHandler::SetSecLockStates ( const SecLockStates & lockstates )

ChvStatus SimChvHandler::UnblockChv | ( | ChvNo | chv_no,
 |  | const WString & | unblocking_str,
 |  | const WString & | new_chv_str
 | ) |

unblock Chv

BOOLEAN SimChvHandler::UpdateChvData | ( | ChvNo | no,
 |  | ChvStatus | status,
 |  | ChvAttempts | attempts_left = c_attempts_left_undefined,
 |  | ChvAttempts | unblocking_attempts_left = c_attempts_left_undefined
 | ) |

ChvStatus SimChvHandler::VerifyChv | ( | ChvNo | chv_no,
 |  | const WString & | chv_str
 | ) |

verify Chv

The documentation for this class was generated from the following files:
  • Adc/SimChvHandler.hpp
  • Adc/SimChvHandler.cpp
Generated on Wed Jan 25 01:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimClutEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimClutEntry Class Reference
[APC]

#include <Apoxi/Apc/ImageData.hpp>

Public Member Functions

SimClutEntry ()

Data Fields

UINT8 | blue
UINT8 | green
UINT8 | red

Constructor & Destructor Documentation

SimClutEntry::SimClutEntry ( ) [inline]

Field Documentation

UINT8 SimClutEntry::blue

UINT8 SimClutEntry::green

UINT8 SimClutEntry::red

The documentation for this class was generated from the following file:
  • Apc/ImageData.hpp
Generated on Wed Jan 25 01:51:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCmiReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCmiReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCmiReadIndArg:

[legend]
Collaboration diagram for SimCmiReadIndArg:

[legend]

Public Types

enum | { ID = 1470 }

Public Member Functions

const CmiRecord & | GetCmiRecord () const
const SimUpdateStatus & | GetStatus () const
void | SetCmiRecord (const CmiRecord &cmi_record)
void | SetStatus (const SimUpdateStatus &status)
SimCmiReadIndArg ()

Static Public Member Functions

static const SimCmiReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCmiReadIndArg: reflects arguments of signal SI_CMI_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCmiReadIndArg::SimCmiReadIndArg ( )

Member Function Documentation

const SimCmiReadIndArg & SimCmiReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CmiRecord& SimCmiReadIndArg::GetCmiRecord ( ) const [inline]

const SimUpdateStatus& SimCmiReadIndArg::GetStatus ( ) const [inline]

void SimCmiReadIndArg::SetCmiRecord ( const CmiRecord & cmi_record ) [inline]

void SimCmiReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCmiReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCmiReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimCmiReadReqArg:

[legend]
Collaboration diagram for SimCmiReadReqArg:

[legend]

Public Types

enum | { ID = 2460 }

Public Member Functions

INT | GetRecNo () const
void | SetRecNo (INT rec_no)
SimCmiReadReqArg ()
SimCmiReadReqArg (INT rec_no)

Static Public Member Functions

static const SimCmiReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimCmiReadReqArg: reflects arguments of signal SimCmiReadReqArg request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimCmiReadReqArg::SimCmiReadReqArg ( INT rec_no )

SimCmiReadReqArg::SimCmiReadReqArg ( )

Member Function Documentation

const SimCmiReadReqArg & SimCmiReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimCmiReadReqArg::GetRecNo ( ) const [inline]

void SimCmiReadReqArg::SetRecNo ( INT rec_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimCphsHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimCphsHandler Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimCphsHandler.hpp>

Inheritance diagram for SimCphsHandler:

[legend]
Collaboration diagram for SimCphsHandler:

[legend]

Public Types

enum CphsServGroupCode {
ServCfu = 0x0180, ServCfb = 0x0140, ServCfnry = 0x0120, ServCfnrc = 0x0110,
ServCt = 0x0108, ServBoac = 0x0280, ServBoic = 0x0240, ServBoicExHc = 0x0220,
ServBaic = 0x0210, ServBicRoam = 0x0208, ServMpty = 0x0380, ServCug = 0x0340,
ServAoC = 0x0320, ServPrefCug = 0x0310, ServCugOA = 0x0308, ServHold = 0x0480,
ServCw = 0x0440, ServCcbs = 0x0420, ServUserUserSig = 0x0410, ServSmMt = 0x0580,
ServSmMo = 0x0540, ServSmCb = 0x0520, ServReplyPath = 0x0510, ServDelConf = 0x0508,
ServProtId = 0x0504, ServValPeriod = 0x0502, ServAls = 0x0680, ServClip = 0x0880,
ServCoLr = 0x0820, ServCoLp = 0x0810, ServMci = 0x0808, ServCliSend = 0x0802,
ServCliBlock = 0x0801, ServGprs = 0x0980, ServHscsd = 0x0940, ServVoiceGrpCall = 0x0920,
ServVoiceBcstServ = 0x0910, ServMtplSubscrPfl = 0x0908, ServMtplBand = 0x0904, ServPlmnMode = 0xc080,
ServVps = 0xc040, ServSmmoPaging = 0xc020, ServSmmoEmail = 0xc010, ServFax = 0xc008,
ServData = 0xc004, ServLanguage = 0xc001, ServInfoNumbers = 0xd5ff
}
enum | VoiceMsgType { MsgTypeLine1 = 8, MsgTypeLine2 = 12, MsgTypeFax = 0, MsgTypeData = 4 }

Public Member Functions

BOOLEAN | GetCphsPhase (UINT8 &phase)
BOOLEAN | GetLineInUse (INT &line)
BOOLEAN | GetLineLocked (BOOLEAN &locked)
BOOLEAN | GetOpName (WString &name)
BOOLEAN | GetOpShortName (WString &name)
BOOLEAN | GetOrangeWelcomeMsg (WString &welcomemsg)
void | InitMruDynflags (const SimInfo &info)
BOOLEAN | IsCallFwdUncondActive (VoiceMsgType type, BOOLEAN &active)
BOOLEAN | IsCingularNetworkSelectionMenuControlSupportEnabled (BOOLEAN &enabled)
BOOLEAN | IsCphsPresent (BOOLEAN &present)
BOOLEAN | IsCphsServAccessible (LineSelector line, SimCphsHandler::CphsServGroupCode code, BOOLEAN &accessible)
BOOLEAN | IsCspPlmnModeBitSet (BOOLEAN &isset)
BOOLEAN | IsServiceActivated (UINT idx, BOOLEAN &activated)
BOOLEAN | IsServiceAllocated (UINT idx, BOOLEAN &allocated)
BOOLEAN | IsVoiceMsgWaiting (VoiceMsgType type, BOOLEAN &waiting)
void | MarkCfufUnread ()
void | MarkCphsInfoUnread ()
void | MarkCspUnread ()
void | MarkLineInUseUnread ()
void | MarkLineLockedUnread ()
void | MarkOpNameUnread ()
void | MarkOpSNameUnread ()
void | MarkVmwfUnread ()
void | MarkWelcomeMsgUnread ()
void | Reset ()
BOOLEAN | RetrieveCingularTst ()
BOOLEAN | RetrieveCspData ()
BOOLEAN | SetCallFwdUncondActive (VoiceMsgType type, BOOLEAN active)
BOOLEAN | SetCphsServAccessible (LineSelector line, SimCphsHandler::CphsServGroupCode code, BOOLEAN accessible)
BOOLEAN | SetLineInUse (INT line)
BOOLEAN | SetLineLocked (BOOLEAN locked)
BOOLEAN | SetVoiceMsgWaiting (VoiceMsgType type, BOOLEAN waiting)
SimCphsHandler ()
virtual | ~SimCphsHandler ()

Member Enumeration Documentation

enum SimCphsHandler::CphsServGroupCode

Enumerator:
ServCfu
ServCfb
ServCfnry
ServCfnrc
ServCt
ServBoac
ServBoic
ServBoicExHc
ServBaic
ServBicRoam
ServMpty
ServCug
ServAoC
ServPrefCug
ServCugOA
ServHold
ServCw
ServCcbs
ServUserUserSig
ServSmMt
ServSmMo
ServSmCb
ServReplyPath
ServDelConf
ServProtId
ServValPeriod
ServAls
ServClip
ServCoLr
ServCoLp
ServMci
ServCliSend
ServCliBlock
ServGprs
ServHscsd
ServVoiceGrpCall
ServVoiceBcstServ
ServMtplSubscrPfl
ServMtplBand
ServPlmnMode
ServVps
ServSmmoPaging
ServSmmoEmail
ServFax
ServData
ServLanguage
ServInfoNumbers

enum SimCphsHandler::VoiceMsgType

Enumerator:
MsgTypeLine1
MsgTypeLine2
MsgTypeFax
MsgTypeData

Constructor & Destructor Documentation

SimCphsHandler::SimCphsHandler ( )

SimCphsHandler::~SimCphsHandler ( ) [virtual]

Member Function Documentation

BOOLEAN SimCphsHandler::GetCphsPhase ( UINT8 & phase )

BOOLEAN SimCphsHandler::GetLineInUse ( INT & line )

BOOLEAN SimCphsHandler::GetLineLocked ( BOOLEAN & locked )

BOOLEAN SimCphsHandler::GetOpName ( WString & name )

BOOLEAN SimCphsHandler::GetOpShortName ( WString & name )

BOOLEAN SimCphsHandler::GetOrangeWelcomeMsg ( WString & welcomemsg )

void SimCphsHandler::InitMruDynflags ( const SimInfo & info )

BOOLEAN SimCphsHandler::IsCallFwdUncondActive | ( | VoiceMsgType | type,
 |  | BOOLEAN & | active
 | ) |

BOOLEAN SimCphsHandler::IsCingularNetworkSelectionMenuControlSupportEnabled ( BOOLEAN & enabled )

BOOLEAN SimCphsHandler::IsCphsPresent ( BOOLEAN & present )

BOOLEAN SimCphsHandler::IsCphsServAccessible | ( | LineSelector | line,
 |  | SimCphsHandler::CphsServGroupCode | code,
 |  | BOOLEAN & | accessible
 | ) |

BOOLEAN SimCphsHandler::IsCspPlmnModeBitSet ( BOOLEAN & isset )

BOOLEAN SimCphsHandler::IsServiceActivated | ( | UINT | idx,
 |  | BOOLEAN & | activated
 | ) |

BOOLEAN SimCphsHandler::IsServiceAllocated | ( | UINT | idx,
 |  | BOOLEAN & | allocated
 | ) |

BOOLEAN SimCphsHandler::IsVoiceMsgWaiting | ( | VoiceMsgType | type,
 |  | BOOLEAN & | waiting
 | ) |

void SimCphsHandler::MarkCfufUnread ( ) [inline]

void SimCphsHandler::MarkCphsInfoUnread ( ) [inline]

void SimCphsHandler::MarkCspUnread ( ) [inline]

void SimCphsHandler::MarkLineInUseUnread ( ) [inline]

void SimCphsHandler::MarkLineLockedUnread ( ) [inline]

void SimCphsHandler::MarkOpNameUnread ( ) [inline]

void SimCphsHandler::MarkOpSNameUnread ( ) [inline]

void SimCphsHandler::MarkVmwfUnread ( ) [inline]

void SimCphsHandler::MarkWelcomeMsgUnread ( ) [inline]

void SimCphsHandler::Reset ( )

BOOLEAN SimCphsHandler::RetrieveCingularTst ( )

BOOLEAN SimCphsHandler::RetrieveCspData ( )

BOOLEAN SimCphsHandler::SetCallFwdUncondActive | ( | VoiceMsgType | type,
 |  | BOOLEAN | active
 | ) |

BOOLEAN SimCphsHandler::SetCphsServAccessible | ( | LineSelector | line,
 |  | SimCphsHandler::CphsServGroupCode | code,
 |  | BOOLEAN | accessible
 | ) |

BOOLEAN SimCphsHandler::SetLineInUse ( INT line )

BOOLEAN SimCphsHandler::SetLineLocked ( BOOLEAN locked )

BOOLEAN SimCphsHandler::SetVoiceMsgWaiting | ( | VoiceMsgType | type,
 |  | BOOLEAN | waiting
 | ) |

The documentation for this class was generated from the following files:
  • Adc/SimCphsHandler.hpp
  • Adc/SimCphsHandler.cpp
Generated on Wed Jan 25 01:51:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [32]

Field Documentation

UINT8 SimData::val[32]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:51:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimDfParameters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimDfParameters Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [36]

Field Documentation

UINT8 SimDfParameters::val[36]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:51:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SimDispatcher.hpp>

Inheritance diagram for SimDispatcher:

[legend]
Collaboration diagram for SimDispatcher:

[legend]

Public Member Functions

SimDispatcher ()
virtual | ~SimDispatcher ()

Protected Member Functions

BOOLEAN | OnBdnInd (const StackMsgArgument &arg)
BOOLEAN | OnCfuDataInd (const StackMsgArgument &arg)
BOOLEAN | OnEccListInd (const StackMsgArgument &arg)
BOOLEAN | OnFdnInd (const StackMsgArgument &arg)
BOOLEAN | OnMdhSmsInitFinishedInd (const StackMsgArgument &arg)
BOOLEAN | OnSimChvRefreshInd (const StackMsgArgument &arg)
BOOLEAN | OnSimErrorInd (const StackMsgArgument &arg)
BOOLEAN | OnSimFullAccessInd (const StackMsgArgument &arg)
BOOLEAN | OnSimInfoInd (const StackMsgArgument &arg)
BOOLEAN | OnSimInitInd (const StackMsgArgument &arg)
BOOLEAN | OnSimLockStatusInd (const StackMsgArgument &arg)
BOOLEAN | OnSimMccMncInd (const StackMsgArgument &arg)
BOOLEAN | OnSimMruPropertyRefreshInd (const StackMsgArgument &arg)
BOOLEAN | OnSimRefreshInd (const StackMsgArgument &arg)

Friends

class | SimHandler

Constructor & Destructor Documentation

SimDispatcher::SimDispatcher ( )

SimDispatcher::~SimDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN SimDispatcher::OnBdnInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnCfuDataInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnEccListInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnFdnInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnMdhSmsInitFinishedInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimChvRefreshInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimErrorInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimFullAccessInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimInfoInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimInitInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimLockStatusInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimMccMncInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimMruPropertyRefreshInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SimDispatcher::OnSimRefreshInd ( const StackMsgArgument & arg ) [protected]

Friends And Related Function Documentation

friend class SimHandler [friend]

The documentation for this class was generated from the following files:
  • Asc/SimDispatcher.hpp
  • Asc/SimDispatcher.cpp
Generated on Wed Jan 25 01:51:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimDisplayTextMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimDisplayTextMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimDisplayTextMsg:

[legend]
Collaboration diagram for SimDisplayTextMsg:

[legend]

Public Types

enum | { ID = 18310 }

Public Member Functions

virtual Message * | Clone () const
const DisplayTextReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const DisplayTextReqArg &arg)
SimDisplayTextMsg (ExecutionContext *context, const DisplayTextReqArg &arg)
virtual | ~SimDisplayTextMsg ()

Detailed Description

SimDisplayTextMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimDisplayTextMsg::SimDisplayTextMsg | ( | ExecutionContext * | context,
 |  | const DisplayTextReqArg & | arg
 | ) |

SimDisplayTextMsg::~SimDisplayTextMsg ( ) [virtual]

Member Function Documentation

Message * SimDisplayTextMsg::Clone ( ) const [virtual]

Implements Message.

const DisplayTextReqArg& SimDisplayTextMsg::GetArg ( ) const [inline]

const MsgMetaData & SimDisplayTextMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimDisplayTextMsg::SetArg ( const DisplayTextReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:51:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimDisplayTextOptions Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimDisplayTextOptions Class Reference

describes how the display string should be represented. More...

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimDisplayTextOptions:

[legend]

Public Member Functions

void | Clear ()
BOOLEAN | ClearAfterDelay () const
UINT8 | Get () const
BOOLEAN | HighPriority () const
SimDisplayTextOptions (SdlByte bit_field=0)
~SimDisplayTextOptions ()

Detailed Description

describes how the display string should be represented.

Constructor & Destructor Documentation

SimDisplayTextOptions::SimDisplayTextOptions ( SdlByte bit_field = 0 )

SimDisplayTextOptions::~SimDisplayTextOptions ( )

Member Function Documentation

void SimDisplayTextOptions::Clear ( ) [inline]

BOOLEAN SimDisplayTextOptions::ClearAfterDelay ( ) const [inline]

UINT8 SimDisplayTextOptions::Get ( ) const [inline]

BOOLEAN SimDisplayTextOptions::HighPriority ( ) const [inline]

The documentation for this class was generated from the following files:
  • Apc/SimTkTypes.hpp
  • Apc/SimTkTypes.cpp
Generated on Wed Jan 25 01:51:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimEfOrangeParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimEfOrangeParam Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [37]

Field Documentation

UINT8 SimEfOrangeParam::val[37]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:51:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimEfParameters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimEfParameters Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [17]

Field Documentation

UINT8 SimEfParameters::val[17]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:51:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimEfRefresh Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimEfRefresh Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimEfRefresh:

[legend]

Public Member Functions

BOOLEAN | IsFullRefreshed ()
BOOLEAN | IsRefreshed (UINT i)

Data Fields

BOOLEAN | full_refresh
SimEfRefreshTable table

Member Function Documentation

BOOLEAN SimEfRefresh::IsFullRefreshed ( ) [inline]

BOOLEAN SimEfRefresh::IsRefreshed ( UINT i ) [inline]

Field Documentation

BOOLEAN SimEfRefresh::full_refresh

SimEfRefreshTable SimEfRefresh::table

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:51:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimEfRefreshTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimEfRefreshTable Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

BOOLEAN refresh [NumberOfEfPos]

Field Documentation

BOOLEAN SimEfRefreshTable::refresh[NumberOfEfPos]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:51:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimEndTransactionMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimEndTransactionMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimEndTransactionMsg:

[legend]
Collaboration diagram for SimEndTransactionMsg:

[legend]

Public Types

enum | { ID = 18318 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SimEndTransactionMsg (ExecutionContext *context)
virtual | ~SimEndTransactionMsg ()

Detailed Description

SimEndTransactionMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimEndTransactionMsg::SimEndTransactionMsg ( ExecutionContext * context )

SimEndTransactionMsg::~SimEndTransactionMsg ( ) [virtual]

Member Function Documentation

Message * SimEndTransactionMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimEndTransactionMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:51:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimErrorIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimErrorIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimErrorIndArg:

[legend]
Collaboration diagram for SimErrorIndArg:

[legend]

Public Types

enum | { ID = 1400 }

Public Member Functions

const SimErrorCode & | GetErrorCode () const
void | SetErrorCode (const SimErrorCode &error_code)
SimErrorIndArg ()

Static Public Member Functions

static const SimErrorIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimErrorIndArg: reflects arguments of signal SIMI_ERR_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimErrorIndArg::SimErrorIndArg ( )

Member Function Documentation

const SimErrorIndArg & SimErrorIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimErrorCode& SimErrorIndArg::GetErrorCode ( void ) const [inline]

void SimErrorIndArg::SetErrorCode ( const SimErrorCode & error_code ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimErrorMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimErrorMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimErrorMsg:

[legend]
Collaboration diagram for SimErrorMsg:

[legend]

Public Types

enum | { ID = 18716 }

Public Member Functions

virtual Message * | Clone () const
const SimErrorCode & | GetErrorCode () const
virtual const MsgMetaData & | GetMetaData () const
void | SetErrorCode (const SimErrorCode &error_code)
SimErrorMsg (const SimErrorCode &error_code)
virtual | ~SimErrorMsg ()

Detailed Description

SimErrorMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimErrorMsg::SimErrorMsg ( const SimErrorCode & error_code )

SimErrorMsg::~SimErrorMsg ( ) [virtual]

Member Function Documentation

Message * SimErrorMsg::Clone ( ) const [virtual]

Implements Message.

const SimErrorCode& SimErrorMsg::GetErrorCode ( void ) const [inline]

const MsgMetaData & SimErrorMsg::GetMetaData ( ) const [virtual]

Implements Message.

void SimErrorMsg::SetErrorCode ( const SimErrorCode & error_code ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:51:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimEventList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimEventList Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

UINT8 val [2]

Field Documentation

UINT8 SimEventList::val[2]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:51:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimExtLangReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimExtLangReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimExtLangReadIndArg:

[legend]
Collaboration diagram for SimExtLangReadIndArg:

[legend]

Public Types

enum | { ID = 1413 }

Public Member Functions

const ExtLanguageArray & | GetLanguageArray () const
const SimUpdateStatus & | GetStatus () const
void | SetLanguageArray (const ExtLanguageArray &language_array)
void | SetStatus (const SimUpdateStatus &status)
SimExtLangReadIndArg ()

Static Public Member Functions

static const SimExtLangReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimExtLangReadIndArg: reflects arguments of signal SI_EXT_LANG_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimExtLangReadIndArg::SimExtLangReadIndArg ( )

Member Function Documentation

const SimExtLangReadIndArg & SimExtLangReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ExtLanguageArray& SimExtLangReadIndArg::GetLanguageArray ( ) const [inline]

const SimUpdateStatus& SimExtLangReadIndArg::GetStatus ( ) const [inline]

void SimExtLangReadIndArg::SetLanguageArray ( const ExtLanguageArray & language_array ) [inline]

void SimExtLangReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimExtLangReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimExtLangReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimExtLangReadReqArg:

[legend]
Collaboration diagram for SimExtLangReadReqArg:

[legend]

Public Types

enum | { ID = 2411 }

Public Member Functions

INT | GetStartPos () const
void | SetStartPos (INT start_pos)
SimExtLangReadReqArg ()
SimExtLangReadReqArg (INT start_pos)

Static Public Member Functions

static const SimExtLangReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimExtLangReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimExtLangReadReqArg::SimExtLangReadReqArg ( INT start_pos )

SimExtLangReadReqArg::SimExtLangReadReqArg ( )

Member Function Documentation

const SimExtLangReadReqArg & SimExtLangReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimExtLangReadReqArg::GetStartPos ( ) const [inline]

void SimExtLangReadReqArg::SetStartPos ( INT start_pos ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimExtLangUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimExtLangUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimExtLangUpdIndArg:

[legend]
Collaboration diagram for SimExtLangUpdIndArg:

[legend]

Public Types

enum | { ID = 1414 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimExtLangUpdIndArg ()

Static Public Member Functions

static const SimExtLangUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimExtLangUpdateIndArg: reflects arguments of signal SI_EXT_LANG_UPD_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimExtLangUpdIndArg::SimExtLangUpdIndArg ( )

Member Function Documentation

const SimExtLangUpdIndArg & SimExtLangUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimExtLangUpdIndArg::GetStatus ( ) const [inline]

void SimExtLangUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:51:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimExtLangUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimExtLangUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimExtLangUpdReqArg:

[legend]
Collaboration diagram for SimExtLangUpdReqArg:

[legend]

Public Types

enum | { ID = 2412 }

Public Member Functions

const ExtLanguageArray & | GetLanguageArray () const
INT | GetStartPos () const
void | SetLanguageArray (const ExtLanguageArray &language_array)
void | SetStartPos (INT start_pos)
SimExtLangUpdReqArg ()
SimExtLangUpdReqArg (INT start_pos, const ExtLanguageArray &language_array)

Static Public Member Functions

static const SimExtLangUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimExtLangUpdReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimExtLangUpdReqArg::SimExtLangUpdReqArg | ( | INT | start_pos,
 |  | const ExtLanguageArray & | language_array
 | ) |

SimExtLangUpdReqArg::SimExtLangUpdReqArg ( )

Member Function Documentation

const SimExtLangUpdReqArg & SimExtLangUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ExtLanguageArray& SimExtLangUpdReqArg::GetLanguageArray ( ) const [inline]

INT SimExtLangUpdReqArg::GetStartPos ( ) const [inline]

void SimExtLangUpdReqArg::SetLanguageArray ( const ExtLanguageArray & language_array ) [inline]

void SimExtLangUpdReqArg::SetStartPos ( INT start_pos ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimFileInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimFileInfoIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimFileInfoIndArg:

[legend]
Collaboration diagram for SimFileInfoIndArg:

[legend]

Public Types

enum | { ID = 1417 }

Public Member Functions

const ChvNo & | GetChvNo () const
INT | GetFileId () const
UINT | GetFileSize () const
const SimFileType & | GetFileType () const
UINT8 | GetInvalidation () const
UINT8 | GetRecordLength () const
const SimUpdateStatus & | GetStatus () const
void | SetChvNo (const ChvNo &chv_no)
void | SetFileId (INT file_id)
void | SetFileSize (UINT file_size)
void | SetFileType (const SimFileType &file_type)
void | SetInvalidation (UINT8 invalidation)
void | SetRecordLength (UINT8 record_length)
void | SetStatus (const SimUpdateStatus &status)
SimFileInfoIndArg ()

Static Public Member Functions

static const SimFileInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimFileInfoIndArg: reflects arguments of signal SI_FILE_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimFileInfoIndArg::SimFileInfoIndArg ( )

Member Function Documentation

const SimFileInfoIndArg & SimFileInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ChvNo& SimFileInfoIndArg::GetChvNo ( ) const [inline]

INT SimFileInfoIndArg::GetFileId ( ) const [inline]

UINT SimFileInfoIndArg::GetFileSize ( ) const [inline]

const SimFileType& SimFileInfoIndArg::GetFileType ( ) const [inline]

UINT8 SimFileInfoIndArg::GetInvalidation ( ) const [inline]

UINT8 SimFileInfoIndArg::GetRecordLength ( ) const [inline]

const SimUpdateStatus& SimFileInfoIndArg::GetStatus ( ) const [inline]

void SimFileInfoIndArg::SetChvNo ( const ChvNo & chv_no ) [inline]

void SimFileInfoIndArg::SetFileId ( INT file_id ) [inline]

void SimFileInfoIndArg::SetFileSize ( UINT file_size ) [inline]

void SimFileInfoIndArg::SetFileType ( const SimFileType & file_type ) [inline]

void SimFileInfoIndArg::SetInvalidation ( UINT8 invalidation ) [inline]

void SimFileInfoIndArg::SetRecordLength ( UINT8 record_length ) [inline]

void SimFileInfoIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimFileInfoReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimFileInfoReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimFileInfoReqArg:

[legend]
Collaboration diagram for SimFileInfoReqArg:

[legend]

Public Types

enum | { ID = 2415 }

Public Member Functions

INT | GetFileId () const
void | SetFileId (INT file_id)
SimFileInfoReqArg ()
SimFileInfoReqArg (INT file_id)

Static Public Member Functions

static const SimFileInfoReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimFileInfoReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimFileInfoReqArg::SimFileInfoReqArg ( INT file_id )

SimFileInfoReqArg::SimFileInfoReqArg ( )

Member Function Documentation

const SimFileInfoReqArg & SimFileInfoReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimFileInfoReqArg::GetFileId ( ) const [inline]

void SimFileInfoReqArg::SetFileId ( INT file_id ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimFullAccessIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimFullAccessIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimFullAccessIndArg:

[legend]
Collaboration diagram for SimFullAccessIndArg:

[legend]

Public Types

enum | { ID = 1483 }

Public Member Functions

SimFullAccessIndArg ()

Static Public Member Functions

static const SimFullAccessIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimFullAccessIndArg: reflects arguments of signal SI_FULL_ACCESS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimFullAccessIndArg::SimFullAccessIndArg ( )

Member Function Documentation

const SimFullAccessIndArg & SimFullAccessIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimGenericIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimGenericIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimGenericIndArg:

[legend]
Collaboration diagram for SimGenericIndArg:

[legend]

Public Types

enum | { ID = 1410 }

Public Member Functions

SimApduData * | GetApduDataPtr () const
const SimFileId & | GetDfId () const
INT | GetDfLength () const
const SimDfParameters & | GetDfParams () const
const SimFileId & | GetEfId () const
INT | GetEfLength () const
const SimEfParameters & | GetEfParams () const
void | SetApduDataPtr (SimApduData *apdu_data_ptr)
void | SetDfId (const SimFileId &df_id)
void | SetDfLength (INT df_length)
void | SetDfParams (const SimDfParameters &df_params)
void | SetEfId (const SimFileId &ef_id)
void | SetEfLength (INT ef_length)
void | SetEfParams (const SimEfParameters &ef_params)
SimGenericIndArg ()

Static Public Member Functions

static const SimGenericIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimGenericIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimGenericIndArg::SimGenericIndArg ( )

Member Function Documentation

const SimGenericIndArg & SimGenericIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

SimApduData* SimGenericIndArg::GetApduDataPtr ( ) const [inline]

const SimFileId& SimGenericIndArg::GetDfId ( ) const [inline]

INT SimGenericIndArg::GetDfLength ( ) const [inline]

const SimDfParameters& SimGenericIndArg::GetDfParams ( ) const [inline]

const SimFileId& SimGenericIndArg::GetEfId ( ) const [inline]

INT SimGenericIndArg::GetEfLength ( ) const [inline]

const SimEfParameters& SimGenericIndArg::GetEfParams ( ) const [inline]

void SimGenericIndArg::SetApduDataPtr ( SimApduData * apdu_data_ptr ) [inline]

void SimGenericIndArg::SetDfId ( const SimFileId & df_id ) [inline]

void SimGenericIndArg::SetDfLength ( INT df_length ) [inline]

void SimGenericIndArg::SetDfParams ( const SimDfParameters & df_params ) [inline]

void SimGenericIndArg::SetEfId ( const SimFileId & ef_id ) [inline]

void SimGenericIndArg::SetEfLength ( INT ef_length ) [inline]

void SimGenericIndArg::SetEfParams ( const SimEfParameters & ef_params ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimGenericReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimGenericReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimGenericReqArg:

[legend]
Collaboration diagram for SimGenericReqArg:

[legend]

Public Types

enum | { ID = 2408 }

Public Member Functions

SimApduData * | GetApduDataPtr () const
const SimFileId & | GetDfId () const
const SimFileId & | GetEfId () const
BOOLEAN | IsDfIdFlag () const
BOOLEAN | IsEfIdFlag () const
void | SetApduDataPtr (SimApduData *apdu_data_ptr)
void | SetDfId (const SimFileId &df_id)
void | SetDfIdFlag (BOOLEAN df_id_flag)
void | SetEfId (const SimFileId &ef_id)
void | SetEfIdFlag (BOOLEAN ef_id_flag)
SimGenericReqArg ()
SimGenericReqArg (const SimFileId &df_id, BOOLEAN df_id_flag, const SimFileId &ef_id, BOOLEAN ef_id_flag, SimApduData *apdu_data_ptr)

Static Public Member Functions

static const SimGenericReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimGenericReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimGenericReqArg::SimGenericReqArg | ( | const SimFileId & | df_id,
 |  | BOOLEAN | df_id_flag,
 |  | const SimFileId & | ef_id,
 |  | BOOLEAN | ef_id_flag,
 |  | SimApduData * | apdu_data_ptr
 | ) |

SimGenericReqArg::SimGenericReqArg ( )

Member Function Documentation

const SimGenericReqArg & SimGenericReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

SimApduData* SimGenericReqArg::GetApduDataPtr ( ) const [inline]

const SimFileId& SimGenericReqArg::GetDfId ( ) const [inline]

const SimFileId& SimGenericReqArg::GetEfId ( ) const [inline]

BOOLEAN SimGenericReqArg::IsDfIdFlag ( ) const [inline]

BOOLEAN SimGenericReqArg::IsEfIdFlag ( ) const [inline]

void SimGenericReqArg::SetApduDataPtr ( SimApduData * apdu_data_ptr ) [inline]

void SimGenericReqArg::SetDfId ( const SimFileId & df_id ) [inline]

void SimGenericReqArg::SetDfIdFlag ( BOOLEAN df_id_flag ) [inline]

void SimGenericReqArg::SetEfId ( const SimFileId & ef_id ) [inline]

void SimGenericReqArg::SetEfIdFlag ( BOOLEAN ef_id_flag ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimGetInkeyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimGetInkeyMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimGetInkeyMsg:

[legend]
Collaboration diagram for SimGetInkeyMsg:

[legend]

Public Types

enum | { ID = 18312 }

Public Member Functions

virtual Message * | Clone () const
const GetInkeyReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const GetInkeyReqArg &arg)
SimGetInkeyMsg (ExecutionContext *context, const GetInkeyReqArg &arg)
virtual | ~SimGetInkeyMsg ()

Detailed Description

SimGetInkeyMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimGetInkeyMsg::SimGetInkeyMsg | ( | ExecutionContext * | context,
 |  | const GetInkeyReqArg & | arg
 | ) |

SimGetInkeyMsg::~SimGetInkeyMsg ( ) [virtual]

Member Function Documentation

Message * SimGetInkeyMsg::Clone ( ) const [virtual]

Implements Message.

const GetInkeyReqArg& SimGetInkeyMsg::GetArg ( ) const [inline]

const MsgMetaData & SimGetInkeyMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimGetInkeyMsg::SetArg ( const GetInkeyReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:52:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimGetInkeyOptions Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimGetInkeyOptions Class Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimGetInkeyOptions:

[legend]

Public Member Functions

BOOLEAN | ActivateYesNo () const
void | Clear ()
BOOLEAN | DigitsOnly () const
bit 1: 0 = digits (0-9, *, #, and +) only | 1 = alphabet set
UINT8 | Get () const
BOOLEAN | HelpAvailable () const
bit 8: 0 = no help information available | 1 = help information available
SimGetInkeyOptions (SdlByte bit_field=0)
BOOLEAN | Ucs2 () const
bit 2: 0 = SMS default alphabet | 1 = UCS2 alphabet
~SimGetInkeyOptions ()

Constructor & Destructor Documentation

SimGetInkeyOptions::SimGetInkeyOptions ( SdlByte bit_field = 0 )

SimGetInkeyOptions::~SimGetInkeyOptions ( )

Member Function Documentation

BOOLEAN SimGetInkeyOptions::ActivateYesNo ( ) const [inline]

bit 3: 0 = character sets defined by bit 1 and bit 2 are enabled | 1 = character sets defined by bit 1 and bit 2 are disabled and the "Yes/No" response is requested

void SimGetInkeyOptions::Clear ( ) [inline]

BOOLEAN SimGetInkeyOptions::DigitsOnly ( ) const [inline]

bit 1: 0 = digits (0-9, *, #, and +) only | 1 = alphabet set

UINT8 SimGetInkeyOptions::Get ( ) const [inline]

BOOLEAN SimGetInkeyOptions::HelpAvailable ( ) const [inline]

bit 8: 0 = no help information available | 1 = help information available

BOOLEAN SimGetInkeyOptions::Ucs2 ( ) const [inline]

bit 2: 0 = SMS default alphabet | 1 = UCS2 alphabet

The documentation for this class was generated from the following files:
  • Apc/SimTkTypes.hpp
  • Apc/SimTkTypes.cpp
Generated on Wed Jan 25 01:52:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimGetInputMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimGetInputMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimGetInputMsg:

[legend]
Collaboration diagram for SimGetInputMsg:

[legend]

Public Types

enum | { ID = 18311 }

Public Member Functions

virtual Message * | Clone () const
const GetInputReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const GetInputReqArg &arg)
SimGetInputMsg (ExecutionContext *context, const GetInputReqArg &arg)
virtual | ~SimGetInputMsg ()

Detailed Description

SimGetInputMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimGetInputMsg::SimGetInputMsg | ( | ExecutionContext * | context,
 |  | const GetInputReqArg & | arg
 | ) |

SimGetInputMsg::~SimGetInputMsg ( ) [virtual]

Member Function Documentation

Message * SimGetInputMsg::Clone ( ) const [virtual]

Implements Message.

const GetInputReqArg& SimGetInputMsg::GetArg ( ) const [inline]

const MsgMetaData & SimGetInputMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimGetInputMsg::SetArg ( const GetInputReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:52:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimGetInputOptions Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimGetInputOptions Class Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimGetInputOptions:

[legend]

Public Member Functions

void | Clear ()
BOOLEAN | DigitsOnly () const
bit 1: 0 = digits (0-9, *, #, and +) only | 1 = alphabet set
UINT8 | Get () const
BOOLEAN | HelpAvailable () const
bit 8: 0 = no help information available | 1 = help information available
BOOLEAN | HideUserInput () const
BOOLEAN | PackUserInput () const
bit 4: 0 = user input to be in unpacked format | 1 = user input to be in SMS packed format
SimGetInputOptions (SdlByte bit_field=0)
BOOLEAN | Ucs2 () const
bit 2: 0 = SMS default alphabet | 1 = UCS2 alphabet
~SimGetInputOptions ()

Constructor & Destructor Documentation

SimGetInputOptions::SimGetInputOptions ( SdlByte bit_field = 0 )

SimGetInputOptions::~SimGetInputOptions ( )

Member Function Documentation

void SimGetInputOptions::Clear ( ) [inline]

BOOLEAN SimGetInputOptions::DigitsOnly ( ) const [inline]

bit 1: 0 = digits (0-9, *, #, and +) only | 1 = alphabet set

UINT8 SimGetInputOptions::Get ( ) const [inline]

BOOLEAN SimGetInputOptions::HelpAvailable ( ) const [inline]

bit 8: 0 = no help information available | 1 = help information available

BOOLEAN SimGetInputOptions::HideUserInput ( ) const [inline]

bit 3: 0 = ME may echo user input on the display | 1 = user input shall not be revealed in any way (see note)

BOOLEAN SimGetInputOptions::PackUserInput ( ) const [inline]

bit 4: 0 = user input to be in unpacked format | 1 = user input to be in SMS packed format

BOOLEAN SimGetInputOptions::Ucs2 ( ) const [inline]

bit 2: 0 = SMS default alphabet | 1 = UCS2 alphabet

The documentation for this class was generated from the following files:
  • Apc/SimTkTypes.hpp
  • Apc/SimTkTypes.cpp
Generated on Wed Jan 25 01:52:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimHandler Class Reference

#include <Apoxi/Asc/SimHandler.hpp>

Collaboration diagram for SimHandler:

[legend]

Public Types

enum | { ID = SimHandlerId }

Public Member Functions

BOOLEAN | ActivateBdn ()
BOOLEAN | ActivateFdn ()
BOOLEAN | ConfirmPbAlphaTagRequest (const WString &, const PhoneNumber &, BOOLEAN apoxilookup=FALSE)
BOOLEAN | DeactivateBdn ()
BOOLEAN | DeactivateFdn ()
virtual HandlerId | GetHandlerId () const
void | SetPbAlphaTagRequestBehaviour (PbRequestBehaviour)
SimHandler ()
virtual | ~SimHandler ()

Detailed Description

The SIM handler SimHandler provides an interface for the application for interaction with the SIM.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimHandler::SimHandler ( )

SimHandler::~SimHandler ( ) [virtual]

Member Function Documentation

BOOLEAN SimHandler::ActivateBdn ( )

The method ActivateBdn() activates the use of the barred dialling numbers.

BOOLEAN SimHandler::ActivateFdn ( )

The method ActivateFdn() activates the use of the fixed dialling numbers.

BOOLEAN SimHandler::ConfirmPbAlphaTagRequest | ( | const WString & | ,
 |  | const PhoneNumber & | ,
 |  | BOOLEAN | apoxilookup = FALSE
 | ) | [inline]

This method is obsolete and moved to the AtcHandler

BOOLEAN SimHandler::DeactivateBdn ( )

The method DeactivateBdn() deactivates the use of the barred dialling numbers.

BOOLEAN SimHandler::DeactivateFdn ( )

The method DeactivateFdn() deactivates the use of the fixed dialling numbers.

HandlerId SimHandler::GetHandlerId ( ) const [virtual]

void SimHandler::SetPbAlphaTagRequestBehaviour ( PbRequestBehaviour ) [inline]

This method is obsolete and moved to the AtcHandler

The documentation for this class was generated from the following files:
  • Asc/SimHandler.hpp
  • Asc/SimHandler.cpp
Generated on Wed Jan 25 01:52:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimIconDescription Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimIconDescription Class Reference
[APC]

#include <Apoxi/Apc/ImageData.hpp>

Collaboration diagram for SimIconDescription:

[legend]

Public Member Functions

void | DbgOut () const
void | Fill (const T_SI_ICON_DESCRIPTOR *descriptor)
UINT8 | GetIconId () const
UINT8 | GetNoImages () const
UINT8 | GetRfu () const
const SimImageDescriptor & | GetSimImageDescriptor (INT idx) const
SimIconDescription & | operator= (const SimIconDescription &szCopy)
SimIconDescription (const SimIconDescription &data)
SimIconDescription ()
~SimIconDescription ()

Detailed Description

SimIconDescription retrieves an icon file identified by an id as defined in GSM 11.11 V8.2.0 10.6.1.1. and allows access to its SimImageDescriptor which are used to retrieve the images.

Constructor & Destructor Documentation

SimIconDescription::SimIconDescription ( )

SimIconDescription::SimIconDescription ( const SimIconDescription & data )

SimIconDescription::~SimIconDescription ( )

Member Function Documentation

void SimIconDescription::DbgOut ( ) const

void SimIconDescription::Fill ( const T_SI_ICON_DESCRIPTOR * descriptor )

UINT8 SimIconDescription::GetIconId ( ) const [inline]

UINT8 SimIconDescription::GetNoImages ( ) const [inline]

UINT8 SimIconDescription::GetRfu ( ) const [inline]

const SimImageDescriptor & SimIconDescription::GetSimImageDescriptor ( INT idx ) const

SimIconDescription & SimIconDescription::operator= ( const SimIconDescription & szCopy )

The documentation for this class was generated from the following files:
  • Apc/ImageData.hpp
  • Apc/ImageData.cpp
Generated on Wed Jan 25 01:52:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimIconIdentifier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimIconIdentifier Class Reference

#include <Apoxi/Apc/SimDataTypes.hpp>

Collaboration diagram for SimIconIdentifier:

[legend]

Public Member Functions

void | Clear ()
const SimIconId & | GetId (INT i=0) const
INT | GetNoOfIcons () const
const SimIconQualifier & | GetQualifier () const
SimIconIdentifier & | operator= (const SimIconIdentifier &sim_icon)
SimIconIdentifier (const SimIconIdentifier &sim_icon)
SimIconIdentifier (const T_SI_ICON_ID &sdl_si_icon_id)
SimIconIdentifier (const Tlv &tlv)
SimIconIdentifier (const TlvAtom *data_ptr, const INT len)
SimIconIdentifier ()
~SimIconIdentifier ()

Detailed Description

representing tlv icon identifier - GSM 11.14 [12.31], representing tlv item icon identifier list - GSM 11.14 [12.32]

Constructor & Destructor Documentation

SimIconIdentifier::SimIconIdentifier ( )

SimIconIdentifier::SimIconIdentifier | ( | const TlvAtom * | data_ptr,
 |  | const INT | len
 | ) |

SimIconIdentifier::SimIconIdentifier ( const Tlv & tlv )

SimIconIdentifier::SimIconIdentifier ( const T_SI_ICON_ID & sdl_si_icon_id )

SimIconIdentifier::SimIconIdentifier ( const SimIconIdentifier & sim_icon )

SimIconIdentifier::~SimIconIdentifier ( )

Member Function Documentation

void SimIconIdentifier::Clear ( )

const SimIconId& SimIconIdentifier::GetId ( INT i = 0 ) const [inline]

INT SimIconIdentifier::GetNoOfIcons ( ) const [inline]

const SimIconQualifier& SimIconIdentifier::GetQualifier ( ) const [inline]

SimIconIdentifier & SimIconIdentifier::operator= ( const SimIconIdentifier & sim_icon )

The documentation for this class was generated from the following files:
  • Apc/SimDataTypes.hpp
  • Apc/SimDataTypes.cpp
Generated on Wed Jan 25 01:52:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimIconQualifier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimIconQualifier Class Reference

represents the icon specific options More...

#include <Apoxi/Apc/SimDataTypes.hpp>

Collaboration diagram for SimIconQualifier:

[legend]

Public Member Functions

void | Clear ()
UINT8 | Get () const
BOOLEAN | IsSelfExplanatory () const
SimIconQualifier (TlvAtom bit_field)
SimIconQualifier ()
~SimIconQualifier ()

Detailed Description

represents the icon specific options

Constructor & Destructor Documentation

SimIconQualifier::SimIconQualifier ( )

SimIconQualifier::SimIconQualifier ( TlvAtom bit_field )

SimIconQualifier::~SimIconQualifier ( )

Member Function Documentation

void SimIconQualifier::Clear ( ) [inline]

UINT8 SimIconQualifier::Get ( ) const [inline]

BOOLEAN SimIconQualifier::IsSelfExplanatory ( ) const [inline]

The documentation for this class was generated from the following files:
  • Apc/SimDataTypes.hpp
  • Apc/SimDataTypes.cpp
Generated on Wed Jan 25 01:52:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimImage Class Reference
[APC]

#include <Apoxi/Apc/ImageData.hpp>

Public Member Functions

void | DbgOut () const
void | Fill (const T_SI_IMAGE_HEADER *imgheader)
INT | GetBpp () const
UINT8 * | GetClutBuffer () const
INT | GetClutBufferLength () const
INT | GetClutLocation () const
INT | GetCoding () const
INT | GetHeight () const
UINT8 * | GetImageBuffer () const
INT | GetImageBufferLength () const
INT | GetNrClutEntries () const
SimClutEntry | GetSimClutEntry (INT idx) const
SimImageCodingScheme | GetSimImageCodingScheme () const
INT | GetWidth () const
SimImage & | operator= (const SimImage &szCopy)
SimImage (const SimImage &imagedata)
SimImage ()
~SimImage ()

Detailed Description

SimImage retrieves an image identified by an SimImageDescriptor (GSM 11.11 V8.2.0 10.6.1.2) and allows access to its description and the image itself.

Constructor & Destructor Documentation

SimImage::SimImage ( )

SimImage::SimImage ( const SimImage & imagedata )

SimImage::~SimImage ( )

Member Function Documentation

void SimImage::DbgOut ( ) const

void SimImage::Fill ( const T_SI_IMAGE_HEADER * imgheader )

INT SimImage::GetBpp ( ) const [inline]

UINT8* SimImage::GetClutBuffer ( ) const [inline]

INT SimImage::GetClutBufferLength ( ) const

INT SimImage::GetClutLocation ( ) const [inline]

INT SimImage::GetCoding ( ) const [inline]

INT SimImage::GetHeight ( ) const [inline]

UINT8* SimImage::GetImageBuffer ( ) const [inline]

INT SimImage::GetImageBufferLength ( ) const

INT SimImage::GetNrClutEntries ( ) const [inline]

SimClutEntry SimImage::GetSimClutEntry ( INT idx ) const

SimImageCodingScheme SimImage::GetSimImageCodingScheme ( ) const [inline]

INT SimImage::GetWidth ( ) const [inline]

SimImage & SimImage::operator= ( const SimImage & szCopy )

The documentation for this class was generated from the following files:
  • Apc/ImageData.hpp
  • Apc/ImageData.cpp
Generated on Wed Jan 25 01:52:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimImageDescriptor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimImageDescriptor Class Reference
[APC]

#include <Apoxi/Apc/ImageData.hpp>

Public Member Functions

void | DbgOut () const
void | Fill (const T_SI_IMAGE_DESCRIPTOR *descriptor)
void | Get (T_SI_IMAGE_DESCRIPTOR *descriptor) const
SimImageDescriptor & | operator= (const SimImageDescriptor &desc)
SimImageDescriptor (const SimImageDescriptor &desc)
SimImageDescriptor ()

Data Fields

UINT8 | s_coding_scheme_type
UINT8 | s_file_id_high
UINT8 | s_file_id_low
UINT8 | s_file_instance_length_high
UINT8 | s_file_instance_length_low
UINT8 | s_file_instance_offset_high
UINT8 | s_file_instance_offset_low
UINT8 | s_height
UINT8 | s_width

Detailed Description

SimImageDescriptor describes an image descriptor defined GSM 11.11 V8.2.0 10.6.1.1.

Constructor & Destructor Documentation

SimImageDescriptor::SimImageDescriptor ( )

SimImageDescriptor::SimImageDescriptor ( const SimImageDescriptor & desc )

Member Function Documentation

void SimImageDescriptor::DbgOut ( ) const

void SimImageDescriptor::Fill ( const T_SI_IMAGE_DESCRIPTOR * descriptor )

void SimImageDescriptor::Get ( T_SI_IMAGE_DESCRIPTOR * descriptor ) const

SimImageDescriptor & SimImageDescriptor::operator= ( const SimImageDescriptor & desc )

Field Documentation

UINT8 SimImageDescriptor::s_coding_scheme_type

UINT8 SimImageDescriptor::s_file_id_high

UINT8 SimImageDescriptor::s_file_id_low

UINT8 SimImageDescriptor::s_file_instance_length_high

UINT8 SimImageDescriptor::s_file_instance_length_low

UINT8 SimImageDescriptor::s_file_instance_offset_high

UINT8 SimImageDescriptor::s_file_instance_offset_low

UINT8 SimImageDescriptor::s_height

UINT8 SimImageDescriptor::s_width

The documentation for this class was generated from the following files:
  • Apc/ImageData.hpp
  • Apc/ImageData.cpp
Generated on Wed Jan 25 01:52:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimInfo Struct Reference

#include <Apoxi/Apc/SimMiscTypes.hpp>

Collaboration diagram for SimInfo:

[legend]

Data Fields

AddInfo add_info
UINT8 changed_indication
SimChangedState changed_state
ChvStatus chv1_status
ChvStatus chv2_status
ChvAttemptsStruct chv_attempts
ExtLanguage ext_pref_language
IccId iccid
Language pref_language
SimIndicator sim_indicator
SimPhase sim_phase
SimType sim_type

Field Documentation

AddInfo SimInfo::add_info

UINT8 SimInfo::changed_indication

SimChangedState SimInfo::changed_state

ChvStatus SimInfo::chv1_status

ChvStatus SimInfo::chv2_status

ChvAttemptsStruct SimInfo::chv_attempts

ExtLanguage SimInfo::ext_pref_language

IccId SimInfo::iccid

Language SimInfo::pref_language

SimIndicator SimInfo::sim_indicator

SimPhase SimInfo::sim_phase

SimType SimInfo::sim_type

The documentation for this struct was generated from the following file:
  • Apc/SimMiscTypes.hpp
Generated on Wed Jan 25 01:52:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimInfoIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimInfoIndArg:

[legend]
Collaboration diagram for SimInfoIndArg:

[legend]

Public Types

enum | { ID = 1481 }

Public Member Functions

const SimInfo & | GetSimInfo () const
void | SetSimInfo (const SimInfo &sim_info)
SimInfoIndArg ()

Static Public Member Functions

static const SimInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimInfoIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimInfoIndArg::SimInfoIndArg ( )

Member Function Documentation

const SimInfoIndArg & SimInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimInfo& SimInfoIndArg::GetSimInfo ( ) const [inline]

void SimInfoIndArg::SetSimInfo ( const SimInfo & sim_info ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimInitIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimInitIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimInitIndArg:

[legend]
Collaboration diagram for SimInitIndArg:

[legend]

Public Types

enum | { ID = 1480 }

Public Member Functions

UINT8 | GetAdnByte () const
UINT8 | GetBdnByte () const
const Imsi & | GetImsi () const
const SimInitResult & | GetInitResult () const
const SimUpdateStatus & | GetStatus () const
void | SetAdnByte (UINT8 adn_byte)
void | SetBdnByte (UINT8 bdn_byte)
void | SetImsi (const Imsi &imsi)
void | SetInitResult (const SimInitResult &init_result)
void | SetStatus (const SimUpdateStatus &status)
SimInitIndArg ()

Static Public Member Functions

static const SimInitIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimInitIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimInitIndArg::SimInitIndArg ( )

Member Function Documentation

const SimInitIndArg & SimInitIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimInitIndArg::GetAdnByte ( ) const [inline]

UINT8 SimInitIndArg::GetBdnByte ( ) const [inline]

const Imsi& SimInitIndArg::GetImsi ( ) const [inline]

const SimInitResult& SimInitIndArg::GetInitResult ( ) const [inline]

const SimUpdateStatus& SimInitIndArg::GetStatus ( ) const [inline]

void SimInitIndArg::SetAdnByte ( UINT8 adn_byte ) [inline]

void SimInitIndArg::SetBdnByte ( UINT8 bdn_byte ) [inline]

void SimInitIndArg::SetImsi ( const Imsi & imsi ) [inline]

void SimInitIndArg::SetInitResult ( const SimInitResult & init_result ) [inline]

void SimInitIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimItemId Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimItemId Class Reference

represents a plain sim item id More...

#include <Apoxi/Apc/SimDataTypes.hpp>

Inheritance diagram for SimItemId:

[legend]
Collaboration diagram for SimItemId:

[legend]

Public Types

enum | { InvalidId }
typedef SimAtom< TlvAtom > | Base

Public Member Functions

BOOLEAN | IsInvalid () const
BOOLEAN | operator< (const SimItemId &id) const
SimItemId (const TlvAtom &id)
SimItemId ()
~SimItemId ()

Detailed Description

represents a plain sim item id

Member Typedef Documentation

typedef SimAtom<TlvAtom> SimItemId::Base

Member Enumeration Documentation

anonymous enum

Enumerator:
InvalidId

Constructor & Destructor Documentation

SimItemId::SimItemId ( )

SimItemId::SimItemId ( const TlvAtom & id )

SimItemId::~SimItemId ( )

Member Function Documentation

BOOLEAN SimItemId::IsInvalid ( ) const [inline]

Reimplemented from SimAtom< TlvAtom >.

BOOLEAN SimItemId::operator< ( const SimItemId & id ) const [inline]

The documentation for this class was generated from the following files:
  • Apc/SimDataTypes.hpp
  • Apc/SimDataTypes.cpp
Generated on Wed Jan 25 01:52:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimItemIdentifier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimItemIdentifier Class Reference

#include <Apoxi/Apc/SimDataTypes.hpp>

Inheritance diagram for SimItemIdentifier:

[legend]
Collaboration diagram for SimItemIdentifier:

[legend]

Public Member Functions

void | Clear ()
const SimItemId & | GetId () const
const WString & | GetText () const
BOOLEAN | IsInvalid () const
BOOLEAN | operator< (const SimItemIdentifier &id) const
BOOLEAN | operator== (const SimItemIdentifier &id) const
SimItemIdentifier (const Tlv &tlv)
SimItemIdentifier (const TlvAtom *data_ptr, const INT len)
SimItemIdentifier ()
virtual | ~SimItemIdentifier ()

Detailed Description

representing tlv item - GSM 11.14 [12.9] representing tlv item identifier - GSM 11.14 [12.10]

Constructor & Destructor Documentation

SimItemIdentifier::SimItemIdentifier ( )

SimItemIdentifier::SimItemIdentifier | ( | const TlvAtom * | data_ptr,
 |  | const INT | len
 | ) |

SimItemIdentifier::SimItemIdentifier ( const Tlv & tlv )

SimItemIdentifier::~SimItemIdentifier ( ) [virtual]

Member Function Documentation

void SimItemIdentifier::Clear ( )

const SimItemId& SimItemIdentifier::GetId ( ) const [inline]

const WString& SimItemIdentifier::GetText ( ) const [inline]

BOOLEAN SimItemIdentifier::IsInvalid ( ) const [inline]

BOOLEAN SimItemIdentifier::operator< ( const SimItemIdentifier & id ) const [inline]

BOOLEAN SimItemIdentifier::operator== ( const SimItemIdentifier & id ) const [inline]

The documentation for this class was generated from the following files:
  • Apc/SimDataTypes.hpp
  • Apc/SimDataTypes.cpp
Generated on Wed Jan 25 01:52:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLangReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLangReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimLangReadIndArg:

[legend]
Collaboration diagram for SimLangReadIndArg:

[legend]

Public Types

enum | { ID = 1411 }

Public Member Functions

const LanguageArray & | GetLanguageArray () const
const SimUpdateStatus & | GetStatus () const
void | SetLanguageArray (const LanguageArray &language_array)
void | SetStatus (const SimUpdateStatus &status)
SimLangReadIndArg ()

Static Public Member Functions

static const SimLangReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimLangReadIndArg: reflects arguments of signal SI_LANGUAGE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLangReadIndArg::SimLangReadIndArg ( )

Member Function Documentation

const SimLangReadIndArg & SimLangReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const LanguageArray& SimLangReadIndArg::GetLanguageArray ( ) const [inline]

const SimUpdateStatus& SimLangReadIndArg::GetStatus ( ) const [inline]

void SimLangReadIndArg::SetLanguageArray ( const LanguageArray & language_array ) [inline]

void SimLangReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLangReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLangReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimLangReadReqArg:

[legend]
Collaboration diagram for SimLangReadReqArg:

[legend]

Public Types

enum | { ID = 2409 }

Public Member Functions

INT | GetStartPos () const
void | SetStartPos (INT start_pos)
SimLangReadReqArg ()
SimLangReadReqArg (INT start_pos)

Static Public Member Functions

static const SimLangReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimLangReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLangReadReqArg::SimLangReadReqArg ( INT start_pos )

SimLangReadReqArg::SimLangReadReqArg ( )

Member Function Documentation

const SimLangReadReqArg & SimLangReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimLangReadReqArg::GetStartPos ( ) const [inline]

void SimLangReadReqArg::SetStartPos ( INT start_pos ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLangUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLangUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimLangUpdIndArg:

[legend]
Collaboration diagram for SimLangUpdIndArg:

[legend]

Public Types

enum | { ID = 1412 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimLangUpdIndArg ()

Static Public Member Functions

static const SimLangUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimLangReadIndArg: reflects arguments of signal SI_LANGUAGE_UPD_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLangUpdIndArg::SimLangUpdIndArg ( )

Member Function Documentation

const SimLangUpdIndArg & SimLangUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimLangUpdIndArg::GetStatus ( ) const [inline]

void SimLangUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLangUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLangUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimLangUpdReqArg:

[legend]
Collaboration diagram for SimLangUpdReqArg:

[legend]

Public Types

enum | { ID = 2410 }

Public Member Functions

const LanguageArray & | GetLanguageArray () const
INT | GetStartPos () const
void | SetLanguageArray (const LanguageArray &language_array)
void | SetStartPos (INT start_pos)
SimLangUpdReqArg ()
SimLangUpdReqArg (INT start_pos, const LanguageArray &language_array)

Static Public Member Functions

static const SimLangUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimLangReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLangUpdReqArg::SimLangUpdReqArg | ( | INT | start_pos,
 |  | const LanguageArray & | language_array
 | ) |

SimLangUpdReqArg::SimLangUpdReqArg ( )

Member Function Documentation

const SimLangUpdReqArg & SimLangUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const LanguageArray& SimLangUpdReqArg::GetLanguageArray ( ) const [inline]

INT SimLangUpdReqArg::GetStartPos ( ) const [inline]

void SimLangUpdReqArg::SetLanguageArray ( const LanguageArray & language_array ) [inline]

void SimLangUpdReqArg::SetStartPos ( INT start_pos ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLaunchBrowserPromptReq_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLaunchBrowserPromptReq_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimLaunchBrowserPromptReq_s:

[legend]

Data Fields

TSiUrl Param1
TAlphaIdentifier Param2
TSiIconID Param3

Field Documentation

TSiUrl SimLaunchBrowserPromptReq_s::Param1

TAlphaIdentifier SimLaunchBrowserPromptReq_s::Param2

TSiIconID SimLaunchBrowserPromptReq_s::Param3

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:52:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLaunchBrowserPromptReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLaunchBrowserPromptReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimLaunchBrowserPromptReqArg:

[legend]
Collaboration diagram for SimLaunchBrowserPromptReqArg:

[legend]

Public Types

enum | { ID = 1324 }

Public Member Functions

const SimIconIdentifier & | GetIcon () const
const SimAlphaIdentifier & | GetTextString () const
const SimTkTransactionId & | GetTid () const
const WString & | GetUrl () const
void | SetIcon (const SimIconIdentifier &icon)
void | SetTextString (const SimAlphaIdentifier &text_string)
void | SetTid (const SimTkTransactionId &tid)
void | SetUrl (const WString &url)
SimLaunchBrowserPromptReqArg ()

Static Public Member Functions

static const SimLaunchBrowserPromptReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimLaunchBrowserPromptReqArg: reflects arguments of signal SI_LAUNCH_BROWSER_PROMPT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLaunchBrowserPromptReqArg::SimLaunchBrowserPromptReqArg ( )

Member Function Documentation

const SimLaunchBrowserPromptReqArg & SimLaunchBrowserPromptReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconIdentifier& SimLaunchBrowserPromptReqArg::GetIcon ( ) const [inline]

const SimAlphaIdentifier& SimLaunchBrowserPromptReqArg::GetTextString ( ) const [inline]

const SimTkTransactionId& SimLaunchBrowserPromptReqArg::GetTid ( ) const [inline]

const WString& SimLaunchBrowserPromptReqArg::GetUrl ( ) const [inline]

void SimLaunchBrowserPromptReqArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void SimLaunchBrowserPromptReqArg::SetTextString ( const SimAlphaIdentifier & text_string ) [inline]

void SimLaunchBrowserPromptReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

void SimLaunchBrowserPromptReqArg::SetUrl ( const WString & url ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLaunchBrowserPromptReqMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLaunchBrowserPromptReqMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimLaunchBrowserPromptReqMsg:

[legend]
Collaboration diagram for SimLaunchBrowserPromptReqMsg:

[legend]

Public Types

enum | { ID = 18332 }

Public Member Functions

virtual Message * | Clone () const
const SimLaunchBrowserPromptReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimLaunchBrowserPromptReqArg &arg)
SimLaunchBrowserPromptReqMsg (ExecutionContext *context, const SimLaunchBrowserPromptReqArg &arg)
virtual | ~SimLaunchBrowserPromptReqMsg ()

Detailed Description

SimLaunchBrowserPromptReqMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLaunchBrowserPromptReqMsg::SimLaunchBrowserPromptReqMsg | ( | ExecutionContext * | context,
 |  | const SimLaunchBrowserPromptReqArg & | arg
 | ) |

SimLaunchBrowserPromptReqMsg::~SimLaunchBrowserPromptReqMsg ( ) [virtual]

Member Function Documentation

Message * SimLaunchBrowserPromptReqMsg::Clone ( ) const [virtual]

Implements Message.

const SimLaunchBrowserPromptReqArg& SimLaunchBrowserPromptReqMsg::GetArg ( ) const [inline]

const MsgMetaData & SimLaunchBrowserPromptReqMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimLaunchBrowserPromptReqMsg::SetArg ( const SimLaunchBrowserPromptReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:52:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLaunchBrowserReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLaunchBrowserReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimLaunchBrowserReqArg:

[legend]
Collaboration diagram for SimLaunchBrowserReqArg:

[legend]

Public Types

enum | { ID = 1325 }

Public Member Functions

const SiBearerList & | GetBearerList () const
UINT8 | GetCommandDetails () const
const SimTextString & | GetGateway () const
const SiProvFileRef & | GetProvisionFileRef () const
const SimTkTransactionId & | GetTid () const
const WString & | GetUrl () const
void | SetBearerList (const SiBearerList &bearer_list)
void | SetCommandDetails (UINT8 command_details)
void | SetGateway (const SimTextString &gateway)
void | SetProvisionFileRef (const SiProvFileRef &provision_file_ref)
void | SetTid (const SimTkTransactionId &tid)
void | SetUrl (const WString &url)
SimLaunchBrowserReqArg ()

Static Public Member Functions

static const SimLaunchBrowserReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimLaunchBrowserReqArg: reflects arguments of signal SIBR_LAUNCH_BROWSER_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLaunchBrowserReqArg::SimLaunchBrowserReqArg ( )

Member Function Documentation

const SimLaunchBrowserReqArg & SimLaunchBrowserReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SiBearerList& SimLaunchBrowserReqArg::GetBearerList ( ) const [inline]

UINT8 SimLaunchBrowserReqArg::GetCommandDetails ( ) const [inline]

const SimTextString& SimLaunchBrowserReqArg::GetGateway ( ) const [inline]

const SiProvFileRef& SimLaunchBrowserReqArg::GetProvisionFileRef ( ) const [inline]

const SimTkTransactionId& SimLaunchBrowserReqArg::GetTid ( ) const [inline]

const WString& SimLaunchBrowserReqArg::GetUrl ( ) const [inline]

void SimLaunchBrowserReqArg::SetBearerList ( const SiBearerList & bearer_list ) [inline]

void SimLaunchBrowserReqArg::SetCommandDetails ( UINT8 command_details ) [inline]

void SimLaunchBrowserReqArg::SetGateway ( const SimTextString & gateway ) [inline]

void SimLaunchBrowserReqArg::SetProvisionFileRef ( const SiProvFileRef & provision_file_ref ) [inline]

void SimLaunchBrowserReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

void SimLaunchBrowserReqArg::SetUrl ( const WString & url ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:52:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLaunchBrowserReqMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLaunchBrowserReqMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimLaunchBrowserReqMsg:

[legend]
Collaboration diagram for SimLaunchBrowserReqMsg:

[legend]

Public Types

enum | { ID = 18331 }

Public Member Functions

virtual Message * | Clone () const
const SimLaunchBrowserReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimLaunchBrowserReqArg &arg)
SimLaunchBrowserReqMsg (ExecutionContext *context, const SimLaunchBrowserReqArg &arg)
virtual | ~SimLaunchBrowserReqMsg ()

Detailed Description

SimLaunchBrowserReqMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLaunchBrowserReqMsg::SimLaunchBrowserReqMsg | ( | ExecutionContext * | context,
 |  | const SimLaunchBrowserReqArg & | arg
 | ) |

SimLaunchBrowserReqMsg::~SimLaunchBrowserReqMsg ( ) [virtual]

Member Function Documentation

Message * SimLaunchBrowserReqMsg::Clone ( ) const [virtual]

Implements Message.

const SimLaunchBrowserReqArg& SimLaunchBrowserReqMsg::GetArg ( ) const [inline]

const MsgMetaData & SimLaunchBrowserReqMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimLaunchBrowserReqMsg::SetArg ( const SimLaunchBrowserReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:52:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLockStates Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLockStates Struct Reference

#include <Apoxi/Apc/SimLockTypes.hpp>

Data Fields

LockStatus corporate
LockStatus network
LockStatus sim
LockStatus sp

Field Documentation

LockStatus SimLockStates::corporate

LockStatus SimLockStates::network

LockStatus SimLockStates::sim

LockStatus SimLockStates::sp

The documentation for this struct was generated from the following file:
  • Apc/SimLockTypes.hpp
Generated on Wed Jan 25 01:52:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLockStatusIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLockStatusIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimLockStatusIndArg:

[legend]
Collaboration diagram for SimLockStatusIndArg:

[legend]

Public Types

enum | { ID = 1482 }

Public Member Functions

const SecLockStates & | GetLockStates () const
void | SetLockStates (const SecLockStates &lock_states)
SimLockStatusIndArg ()

Static Public Member Functions

static const SimLockStatusIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimLockStatusIndArg: reflects arguments of signal SI_LOCK_STATUS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLockStatusIndArg::SimLockStatusIndArg ( )

Member Function Documentation

const SimLockStatusIndArg & SimLockStatusIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SecLockStates& SimLockStatusIndArg::GetLockStates ( ) const [inline]

void SimLockStatusIndArg::SetLockStates ( const SecLockStates & lock_states ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimLockStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimLockStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimLockStatusMsg:

[legend]
Collaboration diagram for SimLockStatusMsg:

[legend]

Public Types

enum | { ID = 18701 }

Public Member Functions

virtual Message * | Clone () const
const SecLockResult & | GetLockResult () const
virtual const MsgMetaData & | GetMetaData () const
void | SetLockResult (const SecLockResult &lock_result)
SimLockStatusMsg (const SecLockResult &lock_result)
virtual | ~SimLockStatusMsg ()

Detailed Description

SimLockStatusMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimLockStatusMsg::SimLockStatusMsg ( const SecLockResult & lock_result )

SimLockStatusMsg::~SimLockStatusMsg ( ) [virtual]

Member Function Documentation

Message * SimLockStatusMsg::Clone ( ) const [virtual]

Implements Message.

const SecLockResult& SimLockStatusMsg::GetLockResult ( ) const [inline]

const MsgMetaData & SimLockStatusMsg::GetMetaData ( ) const [virtual]

Implements Message.

void SimLockStatusMsg::SetLockResult ( const SecLockResult & lock_result ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:53:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimMccMncIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimMccMncIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimMccMncIndArg:

[legend]
Collaboration diagram for SimMccMncIndArg:

[legend]

Public Types

enum | { ID = 1436 }

Public Member Functions

const BcdPlmn & | GetBcdPlmn () const
void | SetBcdPlmn (const BcdPlmn &bcd_plmn)
SimMccMncIndArg ()

Static Public Member Functions

static const SimMccMncIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimMccMncIndArg: reflects arguments of signal SI_MCCMNC_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimMccMncIndArg::SimMccMncIndArg ( )

Member Function Documentation

const SimMccMncIndArg & SimMccMncIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const BcdPlmn& SimMccMncIndArg::GetBcdPlmn ( ) const [inline]

void SimMccMncIndArg::SetBcdPlmn ( const BcdPlmn & bcd_plmn ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimMenuItemSelectionFailedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimMenuItemSelectionFailedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimMenuItemSelectionFailedMsg:

[legend]
Collaboration diagram for SimMenuItemSelectionFailedMsg:

[legend]

Public Types

enum | { ID = 18315 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SimMenuItemSelectionFailedMsg (ExecutionContext *context)
virtual | ~SimMenuItemSelectionFailedMsg ()

Detailed Description

SimMenuItemSelectionFailedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimMenuItemSelectionFailedMsg::SimMenuItemSelectionFailedMsg ( ExecutionContext * context )

SimMenuItemSelectionFailedMsg::~SimMenuItemSelectionFailedMsg ( ) [virtual]

Member Function Documentation

Message * SimMenuItemSelectionFailedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimMenuItemSelectionFailedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:53:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimMexeCertificate Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimMexeCertificate Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimAuxHandler.hpp>

Collaboration diagram for SimMexeCertificate:

[legend]

Public Member Functions

const UINT8 * | GetCertBuffer () const
return the pointer to the certificate payload
UINT16 | GetCertSize () const
returns the size of the certificate payload
UINT | GetCertType () const
returns the type of the certificate: 0=WTLS, 1=X509, 2=X9.68, other values means reserved
UINT8 * | GetKeyIdBuffer () const
returns the buffer which contains the key id
UINT8 | GetKeyIdLength () const
returns length of key id
MexeCertType | GetMexeCertType () const
returns the type of the certificate where it is residing on SIM/USIM: ORPK,ARPK,TPRPK
BOOLEAN | IsAuthorityCert () const
returns if the certificate identify an authority as defined in the descriptor
BOOLEAN | IsValid () const
returns if the certificate is valid as defined in the parameter indicator of the descriptor
SimMexeCertificate (MexeDescriptor *certdesc, UINT8 *certbuffer, UINT16 certsize)
constructor shall only be used by APOXI internal, memory will be allocated by APOXI
~SimMexeCertificate ()
destructor only deleted the payload certbuffer, descriptor must be held by APOXI

Detailed Description

SimMexeCertificate contains the certificate payload of a certain DF-Mexe entry, objects are delivered by APOXI and shall be deleted after usage, content is defined in 3GPP TS 51.011 10.4.4.2

Constructor & Destructor Documentation

SimMexeCertificate::SimMexeCertificate | ( | MexeDescriptor * | certdesc,
 |  | UINT8 * | certbuffer,
 |  | UINT16 | certsize
 | ) | [inline]

constructor shall only be used by APOXI internal, memory will be allocated by APOXI

The documentation for this class was generated from the following file:
  • Adc/SimAuxHandler.hpp
Generated on Wed Jan 25 01:53:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimModifyLockIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimModifyLockIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimModifyLockIndArg:

[legend]
Collaboration diagram for SimModifyLockIndArg:

[legend]

Public Types

enum | { ID = 1486 }

Public Member Functions

const SecLockAction & | GetLockAction () const
const SecLockStates & | GetLockStates () const
void | SetLockAction (const SecLockAction &lock_action)
void | SetLockStates (const SecLockStates &lock_states)
SimModifyLockIndArg ()

Static Public Member Functions

static const SimModifyLockIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimModifyLockIndArg: reflects arguments of signal SI_MODIFY_LOCK_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimModifyLockIndArg::SimModifyLockIndArg ( )

Member Function Documentation

const SimModifyLockIndArg & SimModifyLockIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SecLockAction& SimModifyLockIndArg::GetLockAction ( ) const [inline]

const SecLockStates& SimModifyLockIndArg::GetLockStates ( ) const [inline]

void SimModifyLockIndArg::SetLockAction ( const SecLockAction & lock_action ) [inline]

void SimModifyLockIndArg::SetLockStates ( const SecLockStates & lock_states ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimModifyLockReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimModifyLockReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimModifyLockReqArg:

[legend]
Collaboration diagram for SimModifyLockReqArg:

[legend]

Public Types

enum | { ID = 2472 }

Public Member Functions

const SecLockCommand & | GetLockCommand () const
const SecLockStates & | GetLockStates () const
void | SetLockCommand (const SecLockCommand &lock_command)
void | SetLockStates (const SecLockStates &lock_states)
SimModifyLockReqArg ()
SimModifyLockReqArg (const SecLockStates &lock_states, const SecLockCommand &lock_command)

Static Public Member Functions

static const SimModifyLockReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimModifyLockReqArg: reflects arguments of signal SI_MODIFY_LOCK_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimModifyLockReqArg::SimModifyLockReqArg | ( | const SecLockStates & | lock_states,
 |  | const SecLockCommand & | lock_command
 | ) |

SimModifyLockReqArg::SimModifyLockReqArg ( )

Member Function Documentation

const SimModifyLockReqArg & SimModifyLockReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SecLockCommand& SimModifyLockReqArg::GetLockCommand ( ) const [inline]

const SecLockStates& SimModifyLockReqArg::GetLockStates ( ) const [inline]

void SimModifyLockReqArg::SetLockCommand ( const SecLockCommand & lock_command ) [inline]

void SimModifyLockReqArg::SetLockStates ( const SecLockStates & lock_states ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimMruPropertyRefreshIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimMruPropertyRefreshIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimMruPropertyRefreshIndArg:

[legend]
Collaboration diagram for SimMruPropertyRefreshIndArg:

[legend]

Public Types

enum | { ID = 1476 }

Public Member Functions

UINT8 | GetBitNumber () const
UINT8 | GetBitValue () const
UINT8 | GetIndex () const
UINT16 | GetType () const
void | SetBitNumber (UINT8 bit_number)
void | SetBitValue (UINT8 bit_value)
void | SetIndex (UINT8 index)
void | SetType (UINT16 type)
SimMruPropertyRefreshIndArg ()

Static Public Member Functions

static const SimMruPropertyRefreshIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimMruPropertyRefreshIndArg: reflects arguments of signal SI_REFRESH_MRU_PROPERTY_IND request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimMruPropertyRefreshIndArg::SimMruPropertyRefreshIndArg ( )

Member Function Documentation

const SimMruPropertyRefreshIndArg & SimMruPropertyRefreshIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimMruPropertyRefreshIndArg::GetBitNumber ( ) const [inline]

UINT8 SimMruPropertyRefreshIndArg::GetBitValue ( ) const [inline]

UINT8 SimMruPropertyRefreshIndArg::GetIndex ( ) const [inline]

UINT16 SimMruPropertyRefreshIndArg::GetType ( ) const [inline]

void SimMruPropertyRefreshIndArg::SetBitNumber ( UINT8 bit_number ) [inline]

void SimMruPropertyRefreshIndArg::SetBitValue ( UINT8 bit_value ) [inline]

void SimMruPropertyRefreshIndArg::SetIndex ( UINT8 index ) [inline]

void SimMruPropertyRefreshIndArg::SetType ( UINT16 type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimMruPropertyUpdCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimMruPropertyUpdCnfArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimMruPropertyUpdCnfArg:

[legend]
Collaboration diagram for SimMruPropertyUpdCnfArg:

[legend]

Public Types

enum | { ID = 1475 }

Public Member Functions

const SimChangedState & | GetChangedState () const
void | SetChangedState (const SimChangedState &changed_state)
SimMruPropertyUpdCnfArg ()

Static Public Member Functions

static const SimMruPropertyUpdCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimMruPropertyUpdCnfArg: reflects arguments of signal SI_SET_MRU_PROPERTY_CNF request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimMruPropertyUpdCnfArg::SimMruPropertyUpdCnfArg ( )

Member Function Documentation

const SimMruPropertyUpdCnfArg & SimMruPropertyUpdCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimChangedState& SimMruPropertyUpdCnfArg::GetChangedState ( ) const [inline]

void SimMruPropertyUpdCnfArg::SetChangedState ( const SimChangedState & changed_state ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimMruPropertyUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimMruPropertyUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimMruPropertyUpdReqArg:

[legend]
Collaboration diagram for SimMruPropertyUpdReqArg:

[legend]

Public Types

enum | { ID = 2465 }

Public Member Functions

UINT8 | GetBitNumber () const
UINT8 | GetBitValue () const
UINT8 | GetIndex () const
UINT16 | GetType () const
void | SetBitNumber (UINT8 bit_number)
void | SetBitValue (UINT8 bit_value)
void | SetIndex (UINT8 index)
void | SetType (UINT16 type)
SimMruPropertyUpdReqArg ()
SimMruPropertyUpdReqArg (UINT16 type, UINT8 index, UINT8 bit_number, UINT8 bit_value)

Static Public Member Functions

static const SimMruPropertyUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimMruPropertyUpdReqArg: reflects arguments of signal SI_SET_MRU_PROPERTY_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimMruPropertyUpdReqArg::SimMruPropertyUpdReqArg | ( | UINT16 | type,
 |  | UINT8 | index,
 |  | UINT8 | bit_number,
 |  | UINT8 | bit_value
 | ) |

SimMruPropertyUpdReqArg::SimMruPropertyUpdReqArg ( )

Member Function Documentation

const SimMruPropertyUpdReqArg & SimMruPropertyUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimMruPropertyUpdReqArg::GetBitNumber ( ) const [inline]

UINT8 SimMruPropertyUpdReqArg::GetBitValue ( ) const [inline]

UINT8 SimMruPropertyUpdReqArg::GetIndex ( ) const [inline]

UINT16 SimMruPropertyUpdReqArg::GetType ( ) const [inline]

void SimMruPropertyUpdReqArg::SetBitNumber ( UINT8 bit_number ) [inline]

void SimMruPropertyUpdReqArg::SetBitValue ( UINT8 bit_value ) [inline]

void SimMruPropertyUpdReqArg::SetIndex ( UINT8 index ) [inline]

void SimMruPropertyUpdReqArg::SetType ( UINT16 type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimNextActionIdentifier Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimNextActionIdentifier Class Reference

representing tlv items next action indicator - GSM 11.14 [12.24] More...

#include <Apoxi/Apc/SimDataTypes.hpp>

Public Member Functions

void | Clear ()
const Nai & | GetNai (INT i) const
INT | GetNoOfNai () const
SimNextActionIdentifier & | operator= (const SimNextActionIdentifier &sim_items_nai)
SimNextActionIdentifier (const SimNextActionIdentifier &sim_items_nai)
SimNextActionIdentifier (const Tlv &tlv)
SimNextActionIdentifier (const TlvAtom *data_ptr, const INT len)
SimNextActionIdentifier ()
~SimNextActionIdentifier ()

Detailed Description

representing tlv items next action indicator - GSM 11.14 [12.24]

Constructor & Destructor Documentation

SimNextActionIdentifier::SimNextActionIdentifier ( )

SimNextActionIdentifier::SimNextActionIdentifier | ( | const TlvAtom * | data_ptr,
 |  | const INT | len
 | ) |

SimNextActionIdentifier::SimNextActionIdentifier ( const Tlv & tlv )

SimNextActionIdentifier::SimNextActionIdentifier ( const SimNextActionIdentifier & sim_items_nai )

SimNextActionIdentifier::~SimNextActionIdentifier ( )

Member Function Documentation

void SimNextActionIdentifier::Clear ( )

const Nai& SimNextActionIdentifier::GetNai ( INT i ) const [inline]

INT SimNextActionIdentifier::GetNoOfNai ( ) const [inline]

SimNextActionIdentifier & SimNextActionIdentifier::operator= ( const SimNextActionIdentifier & sim_items_nai )

The documentation for this class was generated from the following files:
  • Apc/SimDataTypes.hpp
  • Apc/SimDataTypes.cpp
Generated on Wed Jan 25 01:53:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimODyn2ReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimODyn2ReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimODyn2ReadIndArg:

[legend]
Collaboration diagram for SimODyn2ReadIndArg:

[legend]

Public Types

enum | { ID = 1472 }

Public Member Functions

UINT8 | GetFlag () const
const SimUpdateStatus & | GetStatus () const
void | SetFlag (UINT8 flag)
void | SetStatus (const SimUpdateStatus &status)
SimODyn2ReadIndArg ()

Static Public Member Functions

static const SimODyn2ReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimODyn2ReadIndArg: reflects arguments of signal SI_O_DYN2_READ_IND request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimODyn2ReadIndArg::SimODyn2ReadIndArg ( )

Member Function Documentation

const SimODyn2ReadIndArg & SimODyn2ReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimODyn2ReadIndArg::GetFlag ( ) const [inline]

const SimUpdateStatus& SimODyn2ReadIndArg::GetStatus ( ) const [inline]

void SimODyn2ReadIndArg::SetFlag ( UINT8 flag ) [inline]

void SimODyn2ReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimODyn2ReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimODyn2ReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimODyn2ReadReqArg:

[legend]
Collaboration diagram for SimODyn2ReadReqArg:

[legend]

Public Types

enum | { ID = 2462 }

Public Member Functions

SimODyn2ReadReqArg ()

Static Public Member Functions

static const SimODyn2ReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimODyn2ReadReqArg: reflects arguments of signal SI_O_DYN2_READ_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimODyn2ReadReqArg::SimODyn2ReadReqArg ( )

Member Function Documentation

const SimODyn2ReadReqArg & SimODyn2ReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimODyn2UpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimODyn2UpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimODyn2UpdIndArg:

[legend]
Collaboration diagram for SimODyn2UpdIndArg:

[legend]

Public Types

enum | { ID = 1474 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimODyn2UpdIndArg ()

Static Public Member Functions

static const SimODyn2UpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimODyn2UpdIndArg: reflects arguments of signal SI_O_DYN2_UPDATE_IND request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimODyn2UpdIndArg::SimODyn2UpdIndArg ( )

Member Function Documentation

const SimODyn2UpdIndArg & SimODyn2UpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimODyn2UpdIndArg::GetStatus ( ) const [inline]

void SimODyn2UpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimODyn2UpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimODyn2UpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimODyn2UpdReqArg:

[legend]
Collaboration diagram for SimODyn2UpdReqArg:

[legend]

Public Types

enum | { ID = 2464 }

Public Member Functions

UINT8 | GetFlag () const
void | SetFlag (UINT8 flag)
SimODyn2UpdReqArg ()
SimODyn2UpdReqArg (UINT8 flag)

Static Public Member Functions

static const SimODyn2UpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimODynUpdReqArg: reflects arguments of signal SI_O_DYN2_UPDATE_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimODyn2UpdReqArg::SimODyn2UpdReqArg ( UINT8 flag )

SimODyn2UpdReqArg::SimODyn2UpdReqArg ( )

Member Function Documentation

const SimODyn2UpdReqArg & SimODyn2UpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimODyn2UpdReqArg::GetFlag ( ) const [inline]

void SimODyn2UpdReqArg::SetFlag ( UINT8 flag ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimODynReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimODynReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimODynReadIndArg:

[legend]
Collaboration diagram for SimODynReadIndArg:

[legend]

Public Types

enum | { ID = 1471 }

Public Member Functions

UINT8 | GetFlag () const
const SimUpdateStatus & | GetStatus () const
void | SetFlag (UINT8 flag)
void | SetStatus (const SimUpdateStatus &status)
SimODynReadIndArg ()

Static Public Member Functions

static const SimODynReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimODynReadIndArg: reflects arguments of signal SI_O_DYN_READ_IND request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimODynReadIndArg::SimODynReadIndArg ( )

Member Function Documentation

const SimODynReadIndArg & SimODynReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimODynReadIndArg::GetFlag ( ) const [inline]

const SimUpdateStatus& SimODynReadIndArg::GetStatus ( ) const [inline]

void SimODynReadIndArg::SetFlag ( UINT8 flag ) [inline]

void SimODynReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimODynReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimODynReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimODynReadReqArg:

[legend]
Collaboration diagram for SimODynReadReqArg:

[legend]

Public Types

enum | { ID = 2461 }

Public Member Functions

SimODynReadReqArg ()

Static Public Member Functions

static const SimODynReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimODynReadReqArg: reflects arguments of signal SI_O_DYN_READ_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimODynReadReqArg::SimODynReadReqArg ( )

Member Function Documentation

const SimODynReadReqArg & SimODynReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimODynUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimODynUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimODynUpdIndArg:

[legend]
Collaboration diagram for SimODynUpdIndArg:

[legend]

Public Types

enum | { ID = 1473 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimODynUpdIndArg ()

Static Public Member Functions

static const SimODynUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimODynUpdIndArg: reflects arguments of signal SI_O_DYN_UPDATE_IND request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimODynUpdIndArg::SimODynUpdIndArg ( )

Member Function Documentation

const SimODynUpdIndArg & SimODynUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimODynUpdIndArg::GetStatus ( ) const [inline]

void SimODynUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimODynUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimODynUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimODynUpdReqArg:

[legend]
Collaboration diagram for SimODynUpdReqArg:

[legend]

Public Types

enum | { ID = 2463 }

Public Member Functions

UINT8 | GetFlag () const
void | SetFlag (UINT8 flag)
SimODynUpdReqArg ()
SimODynUpdReqArg (UINT8 flag)

Static Public Member Functions

static const SimODynUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimODynUpdReqArg: reflects arguments of signal SI_O_DYN_UPDATE_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimODynUpdReqArg::SimODynUpdReqArg ( UINT8 flag )

SimODynUpdReqArg::SimODynUpdReqArg ( )

Member Function Documentation

const SimODynUpdReqArg & SimODynUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimODynUpdReqArg::GetFlag ( ) const [inline]

void SimODynUpdReqArg::SetFlag ( UINT8 flag ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:53:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPbBaseHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPbBaseHandler Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimPbBaseHandler.hpp>

Inheritance diagram for SimPbBaseHandler:

[legend]
Collaboration diagram for SimPbBaseHandler:

[legend]

Public Member Functions

BOOLEAN | DeleteEntries (ProviderListener *listener=0)
BOOLEAN | DeleteEntry (INT recno)
BOOLEAN | DeleteLndEntry (INT recno)
INT | GetAlphaTagSize ()
SimPbEntry * | GetEntry (INT recno)
INT | GetExistingCount ()
INT | GetFreeExtRecords ()
INT | GetMaxCount ()
INT | GetNextFreePosition ()
DataControlType | GetNotificationType () const
PhoneBookType | GetPhoneBookType () const
INT | GetProgress () const
INT | GetTagSize ()
void | Init (SimAccessor *handler, PhoneBookType pbtype, DataControlType dctype)
BOOLEAN | Initialize ()
BOOLEAN | IsSimAccessAllowed () const
BOOLEAN | LoadAllEntries (Provider *parentprov, ProviderListener *listener=0)
BOOLEAN | LookupAlphaId (const PhoneNumber &phno, WString &alphaid)
void | Refresh ()
BOOLEAN | RefreshData (INT recno)
void | Reset ()
SimPbBaseHandler ()
BOOLEAN | UpdateEntry (INT recno, const WString &name, const PhoneNumber &bcdnr, UINT8 cmi_no, INT &newrow)
virtual | ~SimPbBaseHandler ()

Protected Member Functions

void | EmptyRWBuffer ()
INT | FillRWBuffer (const WString &name, INT txtlen, const PhoneNumber &bcdnr)
INT | GetAdnTagSize ()
INT | GetBdnTagSize ()
INT | GetCphsInfoNoTagSize ()
INT | GetCphsMBoxTagSize ()
SimPbEntryCont * GetEntryContainer ()
INT | GetFdnTagSize ()
INT | GetLndTagSize ()
INT | GetMaxAdnCount ()
INT | GetMaxBdnCount ()
INT | GetMaxCphsInfoNoCount ()
INT | GetMaxCphsMBoxCount ()
INT | GetMaxFdnCount ()
INT | GetMaxLndCount ()
INT | GetMaxMbdnCount ()
INT | GetMaxMsisdnCount ()
INT | GetMaxSdnCount ()
INT | GetMbdnTagSize ()
INT | GetMsisdnTagSize ()
INT | GetSdnTagSize ()
SimUpdateStatus | LoadContainerEntry (INT recno)
void | SetEntryContainer (SimPbEntryCont *cont)

Static Protected Attributes

static INT | m_adn_maxrecs = 0
static INT | m_adn_tagsize = 0
static INT | m_bdn_maxrecs = 0
static INT | m_bdn_tagsize = 0
static INT | m_cphs_infono_maxrecs = 0
static INT | m_cphs_infono_tagsize = 0
static INT | m_cphs_mbox_maxrecs = 0
static INT | m_cphs_mbox_tagsize = 0
static INT | m_fdn_maxrecs = 0
static INT | m_fdn_tagsize = 0
static INT | m_lnd_maxrecs = 0
static INT | m_lnd_tagsize = 0
static INT | m_mbdn_maxrecs = 0
static INT | m_mbdn_tagsize = 0
static INT | m_msisdn_maxrecs = 0
static INT | m_msisdn_tagsize = 0
static BOOLEAN | m_pbinfo_initialized = FALSE
static INT | m_prefered_alloc_wstring_size = 20
static UINT8 * | m_readwritebuffer = 0
static INT | m_readwritebuffersize = 0
static INT | m_sdn_maxrecs = 0
static INT | m_sdn_tagsize = 0

Constructor & Destructor Documentation

SimPbBaseHandler::SimPbBaseHandler ( )

SimPbBaseHandler::~SimPbBaseHandler ( ) [virtual]

Member Function Documentation

BOOLEAN SimPbBaseHandler::DeleteEntries ( ProviderListener * listener = 0 )

BOOLEAN SimPbBaseHandler::DeleteEntry ( INT recno )

BOOLEAN SimPbBaseHandler::DeleteLndEntry ( INT recno )

void SimPbBaseHandler::EmptyRWBuffer ( ) [inline, protected]

INT SimPbBaseHandler::FillRWBuffer | ( | const WString & | name,
 |  | INT | txtlen,
 |  | const PhoneNumber & | bcdnr
 | ) | [protected]

INT SimPbBaseHandler::GetAdnTagSize ( ) [inline, protected]

INT SimPbBaseHandler::GetAlphaTagSize ( )

INT SimPbBaseHandler::GetBdnTagSize ( ) [inline, protected]

INT SimPbBaseHandler::GetCphsInfoNoTagSize ( ) [inline, protected]

INT SimPbBaseHandler::GetCphsMBoxTagSize ( ) [inline, protected]

SimPbEntry * SimPbBaseHandler::GetEntry ( INT recno )

SimPbEntryCont* SimPbBaseHandler::GetEntryContainer ( ) [inline, protected]

INT SimPbBaseHandler::GetExistingCount ( )

INT SimPbBaseHandler::GetFdnTagSize ( ) [inline, protected]

INT SimPbBaseHandler::GetFreeExtRecords ( )

INT SimPbBaseHandler::GetLndTagSize ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxAdnCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxBdnCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxCount ( )

INT SimPbBaseHandler::GetMaxCphsInfoNoCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxCphsMBoxCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxFdnCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxLndCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxMbdnCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxMsisdnCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMaxSdnCount ( ) [inline, protected]

INT SimPbBaseHandler::GetMbdnTagSize ( ) [inline, protected]

INT SimPbBaseHandler::GetMsisdnTagSize ( ) [inline, protected]

INT SimPbBaseHandler::GetNextFreePosition ( )

DataControlType SimPbBaseHandler::GetNotificationType ( ) const [inline]

PhoneBookType SimPbBaseHandler::GetPhoneBookType ( ) const [inline]

INT SimPbBaseHandler::GetProgress ( ) const [inline]

INT SimPbBaseHandler::GetSdnTagSize ( ) [inline, protected]

INT SimPbBaseHandler::GetTagSize ( )

void SimPbBaseHandler::Init | ( | SimAccessor * | handler,
 |  | PhoneBookType | pbtype,
 |  | DataControlType | dctype
 | ) |

BOOLEAN SimPbBaseHandler::Initialize ( )

BOOLEAN SimPbBaseHandler::IsSimAccessAllowed ( ) const

Reimplemented from BaseDataHandler.

BOOLEAN SimPbBaseHandler::LoadAllEntries | ( | Provider * | parentprov,
 |  | ProviderListener * | listener = 0
 | ) |

SimUpdateStatus SimPbBaseHandler::LoadContainerEntry ( INT recno ) [protected]

BOOLEAN SimPbBaseHandler::LookupAlphaId | ( | const PhoneNumber & | phno,
 |  | WString & | alphaid
 | ) |

void SimPbBaseHandler::Refresh ( )

BOOLEAN SimPbBaseHandler::RefreshData ( INT recno )

void SimPbBaseHandler::Reset ( )

void SimPbBaseHandler::SetEntryContainer ( SimPbEntryCont * cont ) [inline, protected]

BOOLEAN SimPbBaseHandler::UpdateEntry | ( | INT | recno,
 |  | const WString & | name,
 |  | const PhoneNumber & | bcdnr,
 |  | UINT8 | cmi_no,
 |  | INT & | newrow
 | ) |

Field Documentation

INT SimPbBaseHandler::m_adn_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_adn_tagsize = 0 [static, protected]

INT SimPbBaseHandler::m_bdn_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_bdn_tagsize = 0 [static, protected]

INT SimPbBaseHandler::m_cphs_infono_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_cphs_infono_tagsize = 0 [static, protected]

INT SimPbBaseHandler::m_cphs_mbox_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_cphs_mbox_tagsize = 0 [static, protected]

INT SimPbBaseHandler::m_fdn_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_fdn_tagsize = 0 [static, protected]

INT SimPbBaseHandler::m_lnd_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_lnd_tagsize = 0 [static, protected]

INT SimPbBaseHandler::m_mbdn_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_mbdn_tagsize = 0 [static, protected]

INT SimPbBaseHandler::m_msisdn_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_msisdn_tagsize = 0 [static, protected]

BOOLEAN SimPbBaseHandler::m_pbinfo_initialized = FALSE [static, protected]

INT SimPbBaseHandler::m_prefered_alloc_wstring_size = 20 [static, protected]

UINT8 * SimPbBaseHandler::m_readwritebuffer = 0 [static, protected]

INT SimPbBaseHandler::m_readwritebuffersize = 0 [static, protected]

INT SimPbBaseHandler::m_sdn_maxrecs = 0 [static, protected]

INT SimPbBaseHandler::m_sdn_tagsize = 0 [static, protected]

The documentation for this class was generated from the following files:
  • Adc/SimPbBaseHandler.hpp
  • Adc/SimPbBaseHandler.cpp
Generated on Wed Jan 25 01:53:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPbEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPbEntry Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimPbEntry.hpp>

Collaboration diagram for SimPbEntry:

[legend]

Public Member Functions

void | ClearData ()
UINT8 | GetCmiRecordNo () const
INT | GetCphsIndexLevelIndicator () const
UINT8 | GetCphsStatus () const
const WString & | GetName () const
const PhoneNumber & | GetPhoneNumber () const
INT | GetRecNo () const
BOOLEAN | HasCphsNetworkSpecificIndicator () const
BOOLEAN | HasCphsPremiumServiceIndicator () const
BOOLEAN | HasData () const
SimPbEntry & | operator= (const SimPbEntry &szCopy)
void | ResetData ()
void | SetData (INT recno, const PhoneNumber &phno, const WString &name, UINT8 cphsstatus, UINT8 cmi_no)
SimPbEntry (const SimPbEntry &entry)
SimPbEntry ()
~SimPbEntry ()

Constructor & Destructor Documentation

SimPbEntry::SimPbEntry ( )

SimPbEntry::SimPbEntry ( const SimPbEntry & entry )

SimPbEntry::~SimPbEntry ( )

Member Function Documentation

void SimPbEntry::ClearData ( )

UINT8 SimPbEntry::GetCmiRecordNo ( ) const [inline]

INT SimPbEntry::GetCphsIndexLevelIndicator ( ) const [inline]

UINT8 SimPbEntry::GetCphsStatus ( ) const [inline]

const WString& SimPbEntry::GetName ( ) const [inline]

const PhoneNumber& SimPbEntry::GetPhoneNumber ( ) const [inline]

INT SimPbEntry::GetRecNo ( ) const [inline]

BOOLEAN SimPbEntry::HasCphsNetworkSpecificIndicator ( ) const [inline]

BOOLEAN SimPbEntry::HasCphsPremiumServiceIndicator ( ) const [inline]

BOOLEAN SimPbEntry::HasData ( ) const

SimPbEntry & SimPbEntry::operator= ( const SimPbEntry & szCopy )

void SimPbEntry::ResetData ( )

void SimPbEntry::SetData | ( | INT | recno,
 |  | const PhoneNumber & | phno,
 |  | const WString & | name,
 |  | UINT8 | cphsstatus,
 |  | UINT8 | cmi_no
 | ) |

The documentation for this class was generated from the following files:
  • Adc/SimPbEntry.hpp
  • Adc/SimPbEntry.cpp
Generated on Wed Jan 25 01:53:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPbEntryCont Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPbEntryCont Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimPbEntryCont.hpp>

Collaboration diagram for SimPbEntryCont:

[legend]

Public Member Functions

void | DeleteAllData ()
void | DeleteAllObjects ()
void | DeleteData (INT recno)
SimPbEntry * | GetEntry (INT idx) const
INT | GetExistingCount ()
INT | GetFirstFreeSimPosition ()
INT | GetMaxEntries () const
INT | GetTextLength () const
BOOLEAN | IsReady () const
INT | PutData (INT recno, const PhoneNumber &phno, const WString &wstr, UINT8 cphsstatus, UINT8 cmi_no)
void | Reset ()
void | SetReady (BOOLEAN ready=TRUE)
void | SetTextLength (INT length)
SimPbEntryCont (INT nr_entries, BOOLEAN sorted=FALSE)
~SimPbEntryCont ()

Constructor & Destructor Documentation

SimPbEntryCont::SimPbEntryCont | ( | INT | nr_entries,
 |  | BOOLEAN | sorted = FALSE
 | ) |

SimPbEntryCont::~SimPbEntryCont ( )

Member Function Documentation

void SimPbEntryCont::DeleteAllData ( )

void SimPbEntryCont::DeleteAllObjects ( )

void SimPbEntryCont::DeleteData ( INT recno )

SimPbEntry * SimPbEntryCont::GetEntry ( INT idx ) const

INT SimPbEntryCont::GetExistingCount ( ) [inline]

INT SimPbEntryCont::GetFirstFreeSimPosition ( )

INT SimPbEntryCont::GetMaxEntries ( ) const [inline]

INT SimPbEntryCont::GetTextLength ( ) const [inline]

BOOLEAN SimPbEntryCont::IsReady ( ) const [inline]

INT SimPbEntryCont::PutData | ( | INT | recno,
 |  | const PhoneNumber & | phno,
 |  | const WString & | wstr,
 |  | UINT8 | cphsstatus,
 |  | UINT8 | cmi_no
 | ) |

void SimPbEntryCont::Reset ( ) [inline]

void SimPbEntryCont::SetReady ( BOOLEAN ready = TRUE ) [inline]

void SimPbEntryCont::SetTextLength ( INT length ) [inline]

The documentation for this class was generated from the following files:
  • Adc/SimPbEntryCont.hpp
  • Adc/SimPbEntryCont.cpp
Generated on Wed Jan 25 01:53:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPduHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPduHandler Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimPduHandler.hpp>

Inheritance diagram for SimPduHandler:

[legend]
Collaboration diagram for SimPduHandler:

[legend]

Public Member Functions

BOOLEAN | ChangePreferredStorageMedia (Sms::StorageType storagetype)
BOOLEAN | CopyTo (INT tpduno, const Sms::StorageType storage_type, INT &dst_tpduno)
BOOLEAN | CopyTo (INT tpduno, const Sms::StorageType storage_type, ProtocolIdentifier pid, INT &dst_tpduno)
BOOLEAN | DeleteAllSms (SmsDeleteStatus criteriamask, BOOLEAN smsreports)
BOOLEAN | DeleteAllSms (SmsFilterType filter_type)
INT | FindRowByTpduNumber (INT tpduno, SmsFilterType filter)
BOOLEAN | GetHeaderText (INT recno, SmsFilterType filter_type, WString &wstr)
INT | GetMaxCount () const
BOOLEAN | GetNextFreeTpduNo (const Sms::StorageType storage_type, INT &tpduno)
Sms::StorageType | GetPreferredStorageMedia () const
INT | GetProgress () const
INT | GetReadCount () const
INT | GetSentCount () const
BOOLEAN | GetSmsDebugWString (INT recno, SmsFilterType filter_type, WString &wstr)
TpduHeaderInformation * | GetSmsInformation (INT recno, SmsFilterType filter_type)
Tpdu * | GetSmsTpdu (INT recno, SmsFilterType filter_type)
INT | GetSmsTpduPosition (INT recno, SmsFilterType filter_type)
BOOLEAN | GetSmsWString (INT recno, SmsFilterType filter_type, WString &wstr)
Sms::StorageType | GetStorageMediaPrimitive (const Sms::StorageType storage_type)
const TpduCount & | GetTpduCount (TpduCountType type)
TpduCountType | GetTpduCountType (const Sms::StorageType storage_type)
INT | GetUnreadCount () const
INT | GetUnsentCount () const
void | Init (SimAccessor *handler)
BOOLEAN | InitSmsTransmit (INT simno, INT nvramno)
BOOLEAN | IsReloadInProgress () const
BOOLEAN | IsSmsFilterTypeMatch (SmsFilterType filter, INT recno)
BOOLEAN | IsSpaceLeftOnStorageMedia (TpduCountType type, INT required_tpdus=1)
BOOLEAN | IsSpaceLeftOnStorageMedia (const Sms::StorageType storage_type, INT required_tpdus=1)
BOOLEAN | IsSubSystemInitialized () const
void | OnMdhSmsDeletion (const MdhSmsDeletionIndArg &arg)
void | OnNewStatusReportArrived (const MdhNewStatusReportIndArg &arg)
void | Refresh ()
BOOLEAN | RefreshData (INT tpduno, MdhTimeStamp timestamp)
BOOLEAN | RefreshStatusData (INT tpduno, Tpdu::Status newstatus)
void | ReloadNewMsgTpdu (Tpdu &tpdu, INT tpduno)
void | ReloadTpdu (INT tpduno)
void | Reset ()
BOOLEAN | SetSmsExtendedData (INT recno, const MdhExtendedData &ext_data)
BOOLEAN | SetSmsStatus (INT recno, SmsFilterType filter_type, Tpdu::Status newstatus)
SimPduHandler ()
BOOLEAN | StoreSmsTransmit (Tpdu &tpdu, INT tpduno, MdhWorkMedia workmedia, MdhTimeStamp timestamp, MdhExtendedData ext_data)
BOOLEAN | StoreTpdu (const Tpdu &tpdu, const Sms::StorageType storage_type, INT &dst_tpduno)
BOOLEAN | StoreTpdu (const Tpdu &tpdu, const Sms::StorageType storage_type)
BOOLEAN | StoreTpdu (const Tpdu &tpdu, INT tpduno=0)
BOOLEAN | Update (ProviderListener *listener)
BOOLEAN | UpdateTransmit (ProviderListener *listener)
virtual | ~SimPduHandler ()

Static Public Member Functions

static void | EnablePidCheckForConcSms (BOOLEAN pidcheck)
static UINT8 | GetConcSmsPduMaxNo ()
static BOOLEAN | IsPartlyConcSmsStateChangeable ()
static void | SetConcSmsPduMaxNo (UINT8 no)
static void | SetEmptyNumberText (const WCHAR *text)
static void | SetMaxNoOfPduCache (UINT16 pdu_no_cache)
static void | SetPartlyConcSmsStateChangeable (BOOLEAN changeable)
static void | SetSmsHeaderCacheParams (INT noofentries, INT noofchars)

Friends

class | CompoundSmsItem
class | CompoundTpduItem
class | TpduCache

Data Structures

struct | SmsrCache
struct | TpduCount

Constructor & Destructor Documentation

SimPduHandler::SimPduHandler ( )

SimPduHandler::~SimPduHandler ( ) [virtual]

Member Function Documentation

BOOLEAN SimPduHandler::ChangePreferredStorageMedia ( Sms::StorageType storagetype )

BOOLEAN SimPduHandler::CopyTo | ( | INT | tpduno,
 |  | const Sms::StorageType | storage_type,
 |  | INT & | dst_tpduno
 | ) |

BOOLEAN SimPduHandler::CopyTo | ( | INT | tpduno,
 |  | const Sms::StorageType | storage_type,
 |  | ProtocolIdentifier | pid,
 |  | INT & | dst_tpduno
 | ) |

BOOLEAN SimPduHandler::DeleteAllSms | ( | SmsDeleteStatus | criteriamask,
 |  | BOOLEAN | smsreports
 | ) |

BOOLEAN SimPduHandler::DeleteAllSms ( SmsFilterType filter_type )

static void SimPduHandler::EnablePidCheckForConcSms ( BOOLEAN pidcheck ) [inline, static]

INT SimPduHandler::FindRowByTpduNumber | ( | INT | tpduno,
 |  | SmsFilterType | filter
 | ) |

static UINT8 SimPduHandler::GetConcSmsPduMaxNo ( ) [inline, static]

BOOLEAN SimPduHandler::GetHeaderText | ( | INT | recno,
 |  | SmsFilterType | filter_type,
 |  | WString & | wstr
 | ) |

INT SimPduHandler::GetMaxCount ( ) const [inline]

BOOLEAN SimPduHandler::GetNextFreeTpduNo | ( | const Sms::StorageType | storage_type,
 |  | INT & | tpduno
 | ) |

Sms::StorageType SimPduHandler::GetPreferredStorageMedia ( ) const

INT SimPduHandler::GetProgress ( ) const [inline]

INT SimPduHandler::GetReadCount ( ) const [inline]

INT SimPduHandler::GetSentCount ( ) const [inline]

BOOLEAN SimPduHandler::GetSmsDebugWString | ( | INT | recno,
 |  | SmsFilterType | filter_type,
 |  | WString & | wstr
 | ) |

TpduHeaderInformation * SimPduHandler::GetSmsInformation | ( | INT | recno,
 |  | SmsFilterType | filter_type
 | ) |

Tpdu * SimPduHandler::GetSmsTpdu | ( | INT | recno,
 |  | SmsFilterType | filter_type
 | ) |

INT SimPduHandler::GetSmsTpduPosition | ( | INT | recno,
 |  | SmsFilterType | filter_type
 | ) |

BOOLEAN SimPduHandler::GetSmsWString | ( | INT | recno,
 |  | SmsFilterType | filter_type,
 |  | WString & | wstr
 | ) |

Sms::StorageType SimPduHandler::GetStorageMediaPrimitive ( const Sms::StorageType storage_type )

const TpduCount& SimPduHandler::GetTpduCount ( TpduCountType type ) [inline]

TpduCountType SimPduHandler::GetTpduCountType ( const Sms::StorageType storage_type )

INT SimPduHandler::GetUnreadCount ( ) const [inline]

INT SimPduHandler::GetUnsentCount ( ) const [inline]

void SimPduHandler::Init ( SimAccessor * handler )

Reimplemented from BaseDataHandler.

BOOLEAN SimPduHandler::InitSmsTransmit | ( | INT | simno,
 |  | INT | nvramno
 | ) |

static BOOLEAN SimPduHandler::IsPartlyConcSmsStateChangeable ( ) [inline, static]

BOOLEAN SimPduHandler::IsReloadInProgress ( ) const [inline]

BOOLEAN SimPduHandler::IsSmsFilterTypeMatch | ( | SmsFilterType | filter,
 |  | INT | recno
 | ) |

BOOLEAN SimPduHandler::IsSpaceLeftOnStorageMedia | ( | TpduCountType | type,
 |  | INT | required_tpdus = 1
 | ) |

BOOLEAN SimPduHandler::IsSpaceLeftOnStorageMedia | ( | const Sms::StorageType | storage_type,
 |  | INT | required_tpdus = 1
 | ) |

BOOLEAN SimPduHandler::IsSubSystemInitialized ( ) const [inline]

void SimPduHandler::OnMdhSmsDeletion ( const MdhSmsDeletionIndArg & arg )

void SimPduHandler::OnNewStatusReportArrived ( const MdhNewStatusReportIndArg & arg )

void SimPduHandler::Refresh ( )

BOOLEAN SimPduHandler::RefreshData | ( | INT | tpduno,
 |  | MdhTimeStamp | timestamp
 | ) |

BOOLEAN SimPduHandler::RefreshStatusData | ( | INT | tpduno,
 |  | Tpdu::Status | newstatus
 | ) |

void SimPduHandler::ReloadNewMsgTpdu | ( | Tpdu & | tpdu,
 |  | INT | tpduno
 | ) |

void SimPduHandler::ReloadTpdu ( INT tpduno )

void SimPduHandler::Reset ( )

static void SimPduHandler::SetConcSmsPduMaxNo ( UINT8 no ) [inline, static]

static void SimPduHandler::SetEmptyNumberText ( const WCHAR * text ) [inline, static]

static void SimPduHandler::SetMaxNoOfPduCache ( UINT16 pdu_no_cache ) [inline, static]

static void SimPduHandler::SetPartlyConcSmsStateChangeable ( BOOLEAN changeable ) [inline, static]

BOOLEAN SimPduHandler::SetSmsExtendedData | ( | INT | recno,
 |  | const MdhExtendedData & | ext_data
 | ) |

static void SimPduHandler::SetSmsHeaderCacheParams | ( | INT | noofentries,
 |  | INT | noofchars
 | ) | [inline, static]

BOOLEAN SimPduHandler::SetSmsStatus | ( | INT | recno,
 |  | SmsFilterType | filter_type,
 |  | Tpdu::Status | newstatus
 | ) |

BOOLEAN SimPduHandler::StoreSmsTransmit | ( | Tpdu & | tpdu,
 |  | INT | tpduno,
 |  | MdhWorkMedia | workmedia,
 |  | MdhTimeStamp | timestamp,
 |  | MdhExtendedData | ext_data
 | ) |

BOOLEAN SimPduHandler::StoreTpdu | ( | const Tpdu & | tpdu,
 |  | const Sms::StorageType | storage_type,
 |  | INT & | dst_tpduno
 | ) |

BOOLEAN SimPduHandler::StoreTpdu | ( | const Tpdu & | tpdu,
 |  | const Sms::StorageType | storage_type
 | ) |

BOOLEAN SimPduHandler::StoreTpdu | ( | const Tpdu & | tpdu,
 |  | INT | tpduno = 0
 | ) |

BOOLEAN SimPduHandler::Update ( ProviderListener * listener )

BOOLEAN SimPduHandler::UpdateTransmit ( ProviderListener * listener )

Friends And Related Function Documentation

friend class CompoundSmsItem [friend]

friend class CompoundTpduItem [friend]

friend class TpduCache [friend]

The documentation for this class was generated from the following files:
  • Adc/SimPduHandler.hpp
  • Adc/SimPduHandler.cpp
Generated on Wed Jan 25 01:53:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPhoneBookEntry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPhoneBookEntry Class Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Public Member Functions

void | Push (INT length, const UINT8 *data)
SimPhoneBookEntry (const SimPhoneBookEntry &entry)
SimPhoneBookEntry ()
~SimPhoneBookEntry ()

Data Fields

UINT8 * | m_data
INT | m_length

Constructor & Destructor Documentation

SimPhoneBookEntry::SimPhoneBookEntry ( ) [inline]

SimPhoneBookEntry::SimPhoneBookEntry ( const SimPhoneBookEntry & entry ) [inline]

SimPhoneBookEntry::~SimPhoneBookEntry ( ) [inline]

Member Function Documentation

void SimPhoneBookEntry::Push | ( | INT | length,
 |  | const UINT8 * | data
 | ) | [inline]

Field Documentation

UINT8* SimPhoneBookEntry::m_data

INT SimPhoneBookEntry::m_length

The documentation for this class was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:53:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPlayToneMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPlayToneMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimPlayToneMsg:

[legend]
Collaboration diagram for SimPlayToneMsg:

[legend]

Public Types

enum | { ID = 18316 }

Public Member Functions

virtual Message * | Clone () const
const PlayToneReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const PlayToneReqArg &arg)
SimPlayToneMsg (ExecutionContext *context, const PlayToneReqArg &arg)
virtual | ~SimPlayToneMsg ()

Detailed Description

SimPlayToneMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimPlayToneMsg::SimPlayToneMsg | ( | ExecutionContext * | context,
 |  | const PlayToneReqArg & | arg
 | ) |

SimPlayToneMsg::~SimPlayToneMsg ( ) [virtual]

Member Function Documentation

Message * SimPlayToneMsg::Clone ( ) const [virtual]

Implements Message.

const PlayToneReqArg& SimPlayToneMsg::GetArg ( ) const [inline]

const MsgMetaData & SimPlayToneMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimPlayToneMsg::SetArg ( const PlayToneReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:53:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleAppContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimpleAppContext Class Reference
[Kernel]

#include <Apoxi/Kernel/SimpleScheduler.hpp>

Inheritance diagram for SimpleAppContext:

[legend]
Collaboration diagram for SimpleAppContext:

[legend]

Public Types

typedef AbstractAppContext | Base

Public Member Functions

virtual void | MsgLoop ()
virtual void | SendMsg (Message &msg)
SimpleAppContext (SimpleScheduler *scheduler, Application *app)
virtual void | StartUp ()
virtual void | Wait (const Condition &cond)
virtual | ~SimpleAppContext ()

Detailed Description

SimpleAppContext goes hand in hand with SimpleScheduler. It does not keep context information, as all Applications share the same stack.

Member Typedef Documentation

typedef AbstractAppContext SimpleAppContext::Base

Reimplemented from Linkable< AbstractAppContext >.

Constructor & Destructor Documentation

SimpleAppContext::SimpleAppContext | ( | SimpleScheduler * | scheduler,
 |  | Application * | app
 | ) |

Parameters:
scheduler | pointer to the SimpleScheduler that runs the SimpleAppContext
app | pointer to the Application that will be attached

SimpleAppContext::~SimpleAppContext ( ) [virtual]

Member Function Documentation

void SimpleAppContext::MsgLoop ( ) [virtual]

Wakes up on Messages and sends them to the attached Application.

Implements AbstractAppContext.

void SimpleAppContext::SendMsg ( Message & msg ) [virtual]

Wakes up and sends a message to the attached Application. Incoming Messages will continue to trigger Applications.

Parameters:
msg a reference to the Message to be sent

Implements AbstractAppContext.

void SimpleAppContext::StartUp ( ) [virtual]

Sets up the SimpleAppContext for the attached Application and enters MsgLoop.

Reimplemented from AbstractAppContext.

void SimpleAppContext::Wait ( const Condition & cond ) [virtual]

Stops program flow and waits for the Condition to become true.

Parameters:
cond a reference to the Condition to wait for

Implements AbstractAppContext.

The documentation for this class was generated from the following files:
  • Kernel/SimpleScheduler.hpp
  • Kernel/SimpleScheduler.cpp
Generated on Wed Jan 25 01:54:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimpleAudioDevice Class Reference
[Audio]

#include <Apoxi/Audio/SimpleAudioDevice.hpp>

Inheritance diagram for SimpleAudioDevice:

[legend]
Collaboration diagram for SimpleAudioDevice:

[legend]

Public Member Functions

virtual BOOLEAN | Disable ()=0
virtual BOOLEAN | Enable (BOOLEAN suspend_all_others=FALSE)=0
BOOLEAN | IsEnabled () const
SimpleAudioDevice ()
virtual | ~SimpleAudioDevice ()

Protected Member Functions

void | SetStatus (BOOLEAN enable)

Protected Attributes

SharedPtr< AudioActiveReference > m_active_reference
BOOLEAN | m_enabled

Constructor & Destructor Documentation

SimpleAudioDevice::SimpleAudioDevice ( )

SimpleAudioDevice::~SimpleAudioDevice ( ) [virtual]

Member Function Documentation

virtual BOOLEAN SimpleAudioDevice::Disable ( ) [pure virtual]

Stop an audio device. If you specified TRUE for suspend_all_others when you called Enable(), then any sounds that were suspended at that time will now be resumed.

Parameters:
audio_device_reference The reference previsouly obtained from Enable.
Returns:
Whether the device was successfully disabled. The AudioDeviceStatusMsg APOXI message is also sent in case of success for speech and FM radio devices

Implemented in RadioAudioDevice, and SpeechSimpleAudioDevice.

virtual BOOLEAN SimpleAudioDevice::Enable ( BOOLEAN suspend_all_others = FALSE ) [pure virtual]

Start the device.

Parameters:
suspend_all_others Whether all other sounds should be suspended (or stopped, if they can not be suspended).
Returns:
A reference to the active device. Use this when calling Disable(). The AudioDeviceStatusMsg APOXI message is also sent in case of success for speech and FM radio devices

Implemented in RadioAudioDevice, and SpeechSimpleAudioDevice.

BOOLEAN SimpleAudioDevice::IsEnabled ( ) const

void SimpleAudioDevice::SetStatus ( BOOLEAN enable ) [protected]

Field Documentation

SharedPtr<AudioActiveReference> SimpleAudioDevice::m_active_reference [protected]

BOOLEAN SimpleAudioDevice::m_enabled [protected]

The documentation for this class was generated from the following files:
  • Audio/SimpleAudioDevice.hpp
  • Audio/SimpleAudioDevice.cpp
Generated on Wed Jan 25 01:54:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleMap< TKey, TValue > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimpleMap< TKey, TValue > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/SimpleMap.hpp>

Inheritance diagram for SimpleMap< TKey, TValue >:

[legend]
Collaboration diagram for SimpleMap< TKey, TValue >:

[legend]

Public Types

typedef SimpleMapElem< TKey,
TValue > 		Pair

Public Member Functions

BOOLEAN | Exists (const TKey &key) const
Tells if a key already exists.
Iterator | GetIterator () const
Returns an iterator for the simple map.
UINT | GetSize () const
Returns the actual number of key-value pairs.
BOOLEAN | GetValue (const TKey &key, TValue &value) const
BOOLEAN | Ok () const
const TValue & | operator[] (const TKey &key) const
TValue & | operator[] (const TKey &key)
BOOLEAN | Remove (const TKey &key)
void | RemoveAll ()
Removes all entries.
SimpleMap ()
Constructs a simple map.
virtual | ~SimpleMap ()
Destructs a simple map.

Friends

class | Iterator

Data Structures

class | Iterator

Detailed Description

template<class TKey, class TValue>
class SimpleMap< TKey, TValue >

Template class SimpleMap provides a trivially implemented associative array. An associative array is an array whose values can be referenced by passing a key-value which is not restricted to an integral data type. Look at the following sample function:

static void UsaAgeMap()
{
    SimpleMap<WString, INT> age_map;

    // Add two new entries for keys "Fred" and "Thomas". Since the keys don't
    // exist they are created first. Since on creation an out of memory error
    // may occur, we have to check this.
    age_map["Fred"] = 31;
    if (!age_map.Ok()) {
        // Out of memory.
        return;
    }
    age_map["Thomas"] = 35;
    if (!age_map.Ok()) {
        // Out of memory.
        return;
    }

    // Overwrite an existing key's value.
    age_map["Fred"] = 32;

    // Access the elements at existing keys.
    INT age;
    age = age_map["Fred"];
    age = age_map["Thomas"];

    // If a key does not exist, a default initialized element is created first
    // and then the default value is returned. The following line inserts key
    // "John" with default value 0 and returns this default value. Since on
    // creation an out of memory error may occur, we have to check this.
    age = age_map["John"];
    if (!age_map.Ok()) {
        // Out of memory.
        return;
    }

    // Check if some key already exists.
    if (!age_map.Exists("Hugo")) {
        age_map["Hugo"] = 33;
        if (!age_map.Ok()) {
            // Out of memory.
            return;
        }
    }

    // Remove an element.
    if (age_map.Remove("Fred")) {
        // Element existed.
    }
    else {
        // Element didn't exist.
    }

    // Get the number of key-value pairs.
    const UINT size = age_map.GetSize();
}

TKey and TValue may be of any type. The subscript operator returns the value associated with a key gathered by a simple linear search through the list of nodes. If the non-const subscript operator has been applied and the key does not exist, then a default initialized entry with that key is first created and then returned. If an out of memory error occurs, an internal error flag is set which can be checked using method Ok(). If the const subscript operator has been applied and the key does not exist, then this is considered an error condition and an internal error flag is set which can be checked using method Ok(). In any case, method Ok() has to be called after any subscript operator has been applied to check if the operation succeeded.

Member Typedef Documentation

template<class TKey, class TValue>
typedef SimpleMapElem<TKey, TValue> SimpleMap< TKey, TValue >::Pair

Member Function Documentation

template<class TKey, class TValue>
BOOLEAN SimpleMap< TKey, TValue >::Ok ( ) const [inline]

Tells if the last access using a subscript operator or GetValue() was successful. If the last access was not successful, then

  • in case of prior application of the non-const subscript operator an out of memory error occurred, or
  • in case of prior application of the const subscript operator or method GetValue() the element tried to access was not part of the associative array.

Friends And Related Function Documentation

template<class TKey, class TValue>
friend class Iterator [friend]

The documentation for this class was generated from the following file:
  • Auxiliary/SimpleMap.hpp
Generated on Wed Jan 25 01:54:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleMap< TKey, TValue >::Iterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SimpleMap::Iterator

SimpleMap< TKey, TValue >::Iterator Class Reference

#include <Apoxi/Auxiliary/SimpleMap.hpp>

Collaboration diagram for SimpleMap< TKey, TValue >::Iterator:

[legend]

Public Member Functions

Pair & | GetPair () const
void | Increment ()
BOOLEAN | IsValid () const

Protected Member Functions

Iterator (const SimpleMap &map)

Friends

class | SimpleMap< TKey, TValue >

Detailed Description

template<class TKey, class TValue>
class SimpleMap< TKey, TValue >::Iterator

Class SimpleMap::Iterator implements an iterator for iterating over the elements of a simple map.

Constructor & Destructor Documentation

template<class TKey, class TValue>
SimpleMap< TKey, TValue >::Iterator::Iterator ( const SimpleMap & map ) [inline, protected]

Member Function Documentation

template<class TKey, class TValue>
Pair& SimpleMap< TKey, TValue >::Iterator::GetPair ( ) const [inline]

template<class TKey, class TValue>
void SimpleMap< TKey, TValue >::Iterator::Increment ( ) [inline]

template<class TKey, class TValue>
BOOLEAN SimpleMap< TKey, TValue >::Iterator::IsValid ( ) const [inline]

Friends And Related Function Documentation

template<class TKey, class TValue>
friend class SimpleMap< TKey, TValue > [friend]

The documentation for this class was generated from the following file:
  • Auxiliary/SimpleMap.hpp
Generated on Wed Jan 25 01:54:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleMapElem< TKey, TValue > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimpleMapElem< TKey, TValue > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/SimpleMap.hpp>

Inheritance diagram for SimpleMapElem< TKey, TValue >:

[legend]
Collaboration diagram for SimpleMapElem< TKey, TValue >:

[legend]

Public Member Functions

TKey & | GetKey ()
TValue & | GetValue ()
SimpleMapElem (const TKey &key, const TValue &value)

Friends

class | SimpleMap< TKey, TValue >

Detailed Description

template<class TKey, class TValue>
class SimpleMapElem< TKey, TValue >

Template class SimpleMapElem contains the key that a value is associated with, the value, and the link to the next instance of SimpleMapElem in the simply linked list.

Constructor & Destructor Documentation

template<class TKey, class TValue>
SimpleMapElem< TKey, TValue >::SimpleMapElem | ( | const TKey & | key,
 |  | const TValue & | value
 | ) | [inline]

Member Function Documentation

template<class TKey, class TValue>
TKey& SimpleMapElem< TKey, TValue >::GetKey ( ) [inline]

template<class TKey, class TValue>
TValue& SimpleMapElem< TKey, TValue >::GetValue ( ) [inline]

Friends And Related Function Documentation

template<class TKey, class TValue>
friend class SimpleMap< TKey, TValue > [friend]

The documentation for this class was generated from the following file:
  • Auxiliary/SimpleMap.hpp
Generated on Wed Jan 25 01:54:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleMutex Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimpleMutex Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/SimpleMutex.hpp>

Inheritance diagram for SimpleMutex:

[legend]
Collaboration diagram for SimpleMutex:

[legend]

Public Member Functions

BOOLEAN | Create (BOOLEAN locked=TRUE)
void | Obtain ()
void | Release ()
SimpleMutex ()
virtual | ~SimpleMutex ()

Detailed Description

When two or more threads need to access a shared resource at the same time, synchronization is a coordination process to ensure that the resource is used by only one thread at a time. SimpleMutex is a synchronization primitive that allows exclusive access to the shared resource to only one thread. If the mutex lock of an object is acquired by a thread, the second thread that wants to acquire the lock is suspended until the lock is released by the first thread.

Constructor & Destructor Documentation

SimpleMutex::SimpleMutex ( )

SimpleMutex::~SimpleMutex ( ) [virtual]

Member Function Documentation

BOOLEAN SimpleMutex::Create ( BOOLEAN locked = TRUE )

Parameters:
locked TRUE to create the mutex in non-signaled state, FALSE for signaled state.

void SimpleMutex::Obtain ( )

Obtain is used to request ownership of the mutex. The state of the mutex is signaled if no thread owns it. The thread that owns a mutex can specify the same mutex in repeated Obtain function calls without blocking its execution.

void SimpleMutex::Release ( )

The thread must call Release the same number of times to release ownership of the mutex lock.

The documentation for this class was generated from the following files:
  • Kernel/Os/SimpleMutex.hpp
  • Kernel/Os/SimpleMutex.cpp
Generated on Wed Jan 25 01:54:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleScheduler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimpleScheduler Class Reference
[Kernel]

#include <Apoxi/Kernel/SimpleScheduler.hpp>

Inheritance diagram for SimpleScheduler:

[legend]
Collaboration diagram for SimpleScheduler:

[legend]

Public Types

typedef AbstractScheduler | Base

Public Member Functions

virtual AbstractAppContext * | CreateAppContext (Application *app)
virtual void | Reschedule ()
virtual void | SendMsg (const Application *app, Message &msg)
SimpleScheduler (AppContainer *cont)
virtual void | StartUp ()
virtual void | Wait (const Application *app, const Condition &cond)
virtual | ~SimpleScheduler ()

Detailed Description

SimpleScheduler is the simplest possible Scheduler implementation, and works independently from the underlaying operating system specifics. All Applications share the same callstack, which means that:
  • Nested ActiveWaits of different Applications might lead to a deadlock.
  • Nested ActiveWaits will lead to a stack overflows on limited stacksize.

Member Typedef Documentation

typedef AbstractScheduler SimpleScheduler::Base

Constructor & Destructor Documentation

SimpleScheduler::SimpleScheduler ( AppContainer * cont )

Parameters:
cont the AppContainer that runs the SimpleScheduler.

SimpleScheduler::~SimpleScheduler ( ) [virtual]

Member Function Documentation

AbstractAppContext * SimpleScheduler::CreateAppContext ( Application * app ) [virtual]

Creates a SimpleAppContext for the Application and adds it to the list of AppContexts.

Parameters:
app the Application to be added

Implements AbstractScheduler.

void SimpleScheduler::Reschedule ( ) [virtual]

Takes away control from the currently active Application, and lets the next Application resume.

Implements AbstractScheduler.

void SimpleScheduler::SendMsg | ( | const Application * | app,
 |  | Message & | msg
 | ) | [virtual]

Wakes up and sends a message to the Application.

Parameters:
app | the receiving Application
msg | the Message to be sent

Implements AbstractScheduler.

void SimpleScheduler::StartUp ( ) [virtual]

Starts all SimpleAppContexts, which are then ready to receive messages.

Implements AbstractScheduler.

void SimpleScheduler::Wait | ( | const Application * | app,
 |  | const Condition & | cond
 | ) | [virtual]

Takes away control from the Application until the next Message arrives. Will return once the Condition becomes TRUE.

Parameters:
app | the Application that will wait for the Condition
cond | the Condition to wait for

Implements AbstractScheduler.

The documentation for this class was generated from the following files:
  • Kernel/SimpleScheduler.hpp
  • Kernel/SimpleScheduler.cpp
Generated on Wed Jan 25 01:54:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleSemaphore Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimpleSemaphore Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/Nuc32/SimpleSemaphore.hpp>

Inheritance diagram for SimpleSemaphore:

[legend]
Collaboration diagram for SimpleSemaphore:

[legend]

Public Member Functions

BOOLEAN | Create (INT init_val=0, INT max_val=-1)
BOOLEAN | Create (INT init_val=0, INT max_val=-1)
void | Obtain ()
void | Obtain ()
void | Release ()
void | Release ()
SimpleSemaphore ()
SimpleSemaphore ()
virtual | ~SimpleSemaphore ()
virtual | ~SimpleSemaphore ()

Detailed Description

SimpleSemaphore object is a synchronization object that maintains a count between zero and a specified maximum value. The count is decremented each time a thread completes a wait for the semaphore object and incremented each time a thread releases the semaphore. When the count reaches zero, no more threads can successfully wait for the semaphore object state to become signaled. The state of a semaphore is set to signaled when its count is greater than zero, and non-signaled when its count is zero.

SimpleSemaphore is useful in controlling a shared resource that can support a limited number of users. It acts as a gate that limits the number of threads sharing the resource to a specified maximum number.

Constructor & Destructor Documentation

SimpleSemaphore::SimpleSemaphore ( )

SimpleSemaphore::~SimpleSemaphore ( ) [virtual]

SimpleSemaphore::SimpleSemaphore ( )

virtual SimpleSemaphore::~SimpleSemaphore ( ) [virtual]

Member Function Documentation

BOOLEAN SimpleSemaphore::Create | ( | INT | init_val = 0,
 |  | INT | max_val = -1
 | ) |

Parameters:
init_val | Specifies an initial count for the semaphore object. This value must be greater than or equal to zero and less than or equal to max_val. The state of a semaphore is signaled when its count is greater than zero and non-signaled when it is zero. The count is decreased by one whenever a wait function releases a thread that was waiting for the semaphore. The count is increased by a specified amount by calling the Release method.
max_val | Specifies the maximum count for the semaphore object. This value must be greater than zero.
Returns:
TRUE if succeeded. FALSE if failed.

BOOLEAN SimpleSemaphore::Create | ( | INT | init_val = 0,
 |  | INT | max_val = -1
 | ) |

void SimpleSemaphore::Obtain ( )

Obtain returns when the specified object is in the signaled state.

void SimpleSemaphore::Obtain ( )

void SimpleSemaphore::Release ( )

Release increases the count of the semaphore object. If count exceeds max_val that was specified when the semaphore was created, the count is not changed.

void SimpleSemaphore::Release ( )

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/SimpleSemaphore.hpp
  • Kernel/Os/Win32/SimpleSemaphore.hpp
  • Kernel/Os/Nuc32/SimpleSemaphore.cpp
  • Kernel/Os/Win32/SimpleSemaphore.cpp
Generated on Wed Jan 25 01:54:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimpleTextRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimpleTextRenderer Class Reference
[GUI]

#include <Apoxi/Gui/SimpleTextRenderer.hpp>

Inheritance diagram for SimpleTextRenderer:

[legend]
Collaboration diagram for SimpleTextRenderer:

[legend]

Public Member Functions

virtual XYDIM | DrawText (DeviceContext *dc, const Rect &clip_rect, XYDIM x, XYDIM y, const WCHAR *text, INT from, INT char_count)
virtual INT | GetTextWidth (const WCHAR *text, const Font &font, TextAttr text_attr, INT from, INT char_count, BOOLEAN include_gap=FALSE)
virtual INT | WrapLine (const WCHAR *text, const Font &font, TextAttr text_attr, INT char_count, XYDIM max_width=-1, WrapPolicy policy=(WrapPolicy) 0, BOOLEAN include_gap_at_end=FALSE, Size *total_size=0, INT *ws_at_eol_count=0, XYDIM *ws_at_eol_width=0, INT *last_whitespace_index=0)
virtual | ~SimpleTextRenderer ()

Static Public Member Functions

static SimpleTextRenderer & | GetInstance ()
Returns the instance of the Thai text renderer.

Protected Member Functions

virtual Size | GetGlyph (const WCHAR *cur_text_pos, const WCHAR *substitution_char, INT char_count, GlyphPtr glyph, INT &parsed_glyphs, BOOLEAN &is_diacritic)
SimpleTextRenderer ()

Detailed Description

Basic text renderer for all texts where no transformation is needed at all, e.g. German, English, etc.. Just retrieves the glyph for the current character. Does not use member fields, and is threadsafe without using mutexes.

Constructor & Destructor Documentation

SimpleTextRenderer::~SimpleTextRenderer ( ) [virtual]

SimpleTextRenderer::SimpleTextRenderer ( ) [protected]

Member Function Documentation

XYDIM SimpleTextRenderer::DrawText | ( | DeviceContext * | dc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | const WCHAR * | text,
 |  | INT | from,
 |  | INT | char_count
 | ) | [virtual]

See also:
AbstractTextRenderer::DrawText

Reimplemented from AbstractTextRenderer.

Size SimpleTextRenderer::GetGlyph | ( | const WCHAR * | cur_text_pos,
 |  | const WCHAR * | substitution_char,
 |  | INT | char_count,
 |  | GlyphPtr | glyph,
 |  | INT & | parsed_glyphs,
 |  | BOOLEAN & | is_diacritic
 | ) | [protected, virtual]

See also:
AbstractTextRenderer::GetGlyph

Implements AbstractTextRenderer.

static SimpleTextRenderer& SimpleTextRenderer::GetInstance ( ) [inline, static]

Returns the instance of the Thai text renderer.

INT SimpleTextRenderer::GetTextWidth | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | from,
 |  | INT | char_count,
 |  | BOOLEAN | include_gap = FALSE
 | ) | [virtual]

See also:
AbstractTextRenderer::GetTextWidth

Reimplemented from AbstractTextRenderer.

INT SimpleTextRenderer::WrapLine | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | char_count,
 |  | XYDIM | max_width = -1,
 |  | WrapPolicy | policy = (WrapPolicy) 0,
 |  | BOOLEAN | include_gap_at_end = FALSE,
 |  | Size * | total_size = 0,
 |  | INT * | ws_at_eol_count = 0,
 |  | XYDIM * | ws_at_eol_width = 0,
 |  | INT * | last_whitespace_index = 0
 | ) | [virtual]

See also:
AbstractTextRenderer::WrapLine

Reimplemented from AbstractTextRenderer.

The documentation for this class was generated from the following files:
  • Gui/SimpleTextRenderer.hpp
  • Gui/SimpleTextRenderer.cpp
Generated on Wed Jan 25 01:54:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPuctReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPuctReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimPuctReadIndArg:

[legend]
Collaboration diagram for SimPuctReadIndArg:

[legend]

Public Types

enum | { ID = 1408 }

Public Member Functions

const Puct & | GetPuct () const
const SimUpdateStatus & | GetStatus () const
void | SetPuct (const Puct &puct)
void | SetStatus (const SimUpdateStatus &status)
SimPuctReadIndArg ()

Static Public Member Functions

static const SimPuctReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimPuctReadIndArg: reflects arguments of signal SI_PUCT_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimPuctReadIndArg::SimPuctReadIndArg ( )

Member Function Documentation

const SimPuctReadIndArg & SimPuctReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Puct& SimPuctReadIndArg::GetPuct ( ) const [inline]

const SimUpdateStatus& SimPuctReadIndArg::GetStatus ( ) const [inline]

void SimPuctReadIndArg::SetPuct ( const Puct & puct ) [inline]

void SimPuctReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPuctReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPuctReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimPuctReadReqArg:

[legend]
Collaboration diagram for SimPuctReadReqArg:

[legend]

Public Types

enum | { ID = 2406 }

Public Member Functions

SimPuctReadReqArg ()

Static Public Member Functions

static const SimPuctReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimPuctReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimPuctReadReqArg::SimPuctReadReqArg ( )

Member Function Documentation

const SimPuctReadReqArg & SimPuctReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPuctUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPuctUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimPuctUpdIndArg:

[legend]
Collaboration diagram for SimPuctUpdIndArg:

[legend]

Public Types

enum | { ID = 1409 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
SimPuctUpdIndArg ()

Static Public Member Functions

static const SimPuctUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimPuctUpdIndArg: reflects arguments of signal SI_PUCT_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimPuctUpdIndArg::SimPuctUpdIndArg ( )

Member Function Documentation

const SimPuctUpdIndArg & SimPuctUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& SimPuctUpdIndArg::GetStatus ( ) const [inline]

void SimPuctUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimPuctUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimPuctUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimPuctUpdReqArg:

[legend]
Collaboration diagram for SimPuctUpdReqArg:

[legend]

Public Types

enum | { ID = 2407 }

Public Member Functions

const Puct & | GetPuct () const
void | SetPuct (const Puct &puct)
SimPuctUpdReqArg ()
SimPuctUpdReqArg (const Puct &puct)

Static Public Member Functions

static const SimPuctUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimPuctUpdReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimPuctUpdReqArg::SimPuctUpdReqArg ( const Puct & puct )

SimPuctUpdReqArg::SimPuctUpdReqArg ( )

Member Function Documentation

const SimPuctUpdReqArg & SimPuctUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Puct& SimPuctUpdReqArg::GetPuct ( ) const [inline]

void SimPuctUpdReqArg::SetPuct ( const Puct & puct ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimRefreshIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimRefreshIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimRefreshIndArg:

[legend]
Collaboration diagram for SimRefreshIndArg:

[legend]

Public Types

enum | { ID = 1401 }

Public Member Functions

INT | GetFileType () const
INT | GetRecNo () const
const SimRefreshType & | GetRefreshType () const
UINT8 | GetSmsStatus () const
void | SetFileType (INT file_type)
void | SetRecNo (INT rec_no)
void | SetRefreshType (const SimRefreshType &refresh_type)
void | SetSmsStatus (UINT8 sms_status)
SimRefreshIndArg ()

Static Public Member Functions

static const SimRefreshIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimRefreshIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimRefreshIndArg::SimRefreshIndArg ( )

Member Function Documentation

const SimRefreshIndArg & SimRefreshIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimRefreshIndArg::GetFileType ( ) const [inline]

INT SimRefreshIndArg::GetRecNo ( ) const [inline]

const SimRefreshType& SimRefreshIndArg::GetRefreshType ( ) const [inline]

UINT8 SimRefreshIndArg::GetSmsStatus ( ) const [inline]

void SimRefreshIndArg::SetFileType ( INT file_type ) [inline]

void SimRefreshIndArg::SetRecNo ( INT rec_no ) [inline]

void SimRefreshIndArg::SetRefreshType ( const SimRefreshType & refresh_type ) [inline]

void SimRefreshIndArg::SetSmsStatus ( UINT8 sms_status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimRefreshMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimRefreshMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimRefreshMsg:

[legend]
Collaboration diagram for SimRefreshMsg:

[legend]

Public Types

enum | { ID = 18304 }

Public Member Functions

virtual Message * | Clone () const
const SimTkRefreshReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimTkRefreshReqArg &arg)
SimRefreshMsg (ExecutionContext *context, const SimTkRefreshReqArg &arg)
virtual | ~SimRefreshMsg ()

Detailed Description

SimRefreshMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimRefreshMsg::SimRefreshMsg | ( | ExecutionContext * | context,
 |  | const SimTkRefreshReqArg & | arg
 | ) |

SimRefreshMsg::~SimRefreshMsg ( ) [virtual]

Member Function Documentation

Message * SimRefreshMsg::Clone ( ) const [virtual]

Implements Message.

const SimTkRefreshReqArg& SimRefreshMsg::GetArg ( ) const [inline]

const MsgMetaData & SimRefreshMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimRefreshMsg::SetArg ( const SimTkRefreshReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimRefreshReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimRefreshReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimRefreshReqArg:

[legend]
Collaboration diagram for SimRefreshReqArg:

[legend]

Public Types

enum | { ID = 2400 }

Public Member Functions

SimRefreshReqArg ()

Static Public Member Functions

static const SimRefreshReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimRefreshReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimRefreshReqArg::SimRefreshReqArg ( )

Member Function Documentation

const SimRefreshReqArg & SimRefreshReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimRefreshResetMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimRefreshResetMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimRefreshResetMsg:

[legend]
Collaboration diagram for SimRefreshResetMsg:

[legend]

Public Types

enum | { ID = 18305 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SimRefreshResetMsg (ExecutionContext *context)
virtual | ~SimRefreshResetMsg ()

Detailed Description

SimRefreshResetMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimRefreshResetMsg::SimRefreshResetMsg ( ExecutionContext * context )

SimRefreshResetMsg::~SimRefreshResetMsg ( ) [virtual]

Member Function Documentation

Message * SimRefreshResetMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimRefreshResetMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimResetConfirmationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimResetConfirmationMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimResetConfirmationMsg:

[legend]
Collaboration diagram for SimResetConfirmationMsg:

[legend]

Public Types

enum | { ID = 18306 }

Public Member Functions

virtual Message * | Clone () const
const SimTkResetCnfReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimTkResetCnfReqArg &arg)
SimResetConfirmationMsg (ExecutionContext *context, const SimTkResetCnfReqArg &arg)
virtual | ~SimResetConfirmationMsg ()

Detailed Description

SimResetConfirmationMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimResetConfirmationMsg::SimResetConfirmationMsg | ( | ExecutionContext * | context,
 |  | const SimTkResetCnfReqArg & | arg
 | ) |

SimResetConfirmationMsg::~SimResetConfirmationMsg ( ) [virtual]

Member Function Documentation

Message * SimResetConfirmationMsg::Clone ( ) const [virtual]

Implements Message.

const SimTkResetCnfReqArg& SimResetConfirmationMsg::GetArg ( ) const [inline]

const MsgMetaData & SimResetConfirmationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimResetConfirmationMsg::SetArg ( const SimTkResetCnfReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimResetDoneMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimResetDoneMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimResetDoneMsg:

[legend]
Collaboration diagram for SimResetDoneMsg:

[legend]

Public Types

enum | { ID = 18307 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SimResetDoneMsg (ExecutionContext *context)
virtual | ~SimResetDoneMsg ()

Detailed Description

SimResetDoneMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimResetDoneMsg::SimResetDoneMsg ( ExecutionContext * context )

SimResetDoneMsg::~SimResetDoneMsg ( ) [virtual]

Member Function Documentation

Message * SimResetDoneMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimResetDoneMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSelectItemMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSelectItemMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimSelectItemMsg:

[legend]
Collaboration diagram for SimSelectItemMsg:

[legend]

Public Types

enum | { ID = 18313 }

Public Member Functions

virtual Message * | Clone () const
const SelectItemReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SelectItemReqArg &arg)
SimSelectItemMsg (ExecutionContext *context, const SelectItemReqArg &arg)
virtual | ~SimSelectItemMsg ()

Detailed Description

SimSelectItemMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSelectItemMsg::SimSelectItemMsg | ( | ExecutionContext * | context,
 |  | const SelectItemReqArg & | arg
 | ) |

SimSelectItemMsg::~SimSelectItemMsg ( ) [virtual]

Member Function Documentation

Message * SimSelectItemMsg::Clone ( ) const [virtual]

Implements Message.

const SelectItemReqArg& SimSelectItemMsg::GetArg ( ) const [inline]

const MsgMetaData & SimSelectItemMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimSelectItemMsg::SetArg ( const SelectItemReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSelectItemOptions Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSelectItemOptions Class Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimSelectItemOptions:

[legend]

Public Member Functions

void | Clear ()
UINT8 | Get () const
BOOLEAN | HelpAvailable () const
bit 8: 0 = no help information available | 1 = help information available
BOOLEAN | PresentationAsNavigationOptions () const
BOOLEAN | PresentationTypeAvailable () const
bit 1: 0 = presentation type is not specified | 1 = presentation type is specified in bit 2
BOOLEAN | SelectionByUsingSoftkey () const
bit 3: 0 = no selection preference | 1 = selection using soft key preferred
SimSelectItemOptions (SdlByte bit_field=0)
~SimSelectItemOptions ()

Constructor & Destructor Documentation

SimSelectItemOptions::SimSelectItemOptions ( SdlByte bit_field = 0 )

SimSelectItemOptions::~SimSelectItemOptions ( )

Member Function Documentation

void SimSelectItemOptions::Clear ( ) [inline]

UINT8 SimSelectItemOptions::Get ( ) const [inline]

BOOLEAN SimSelectItemOptions::HelpAvailable ( ) const [inline]

bit 8: 0 = no help information available | 1 = help information available

BOOLEAN SimSelectItemOptions::PresentationAsNavigationOptions ( ) const [inline]

bit 2: 0 = presentation as a choice of data values if bit 1 = '1' | 1 = presentation as a choice of navigation options if bit 1 is '1'

BOOLEAN SimSelectItemOptions::PresentationTypeAvailable ( ) const [inline]

bit 1: 0 = presentation type is not specified | 1 = presentation type is specified in bit 2

BOOLEAN SimSelectItemOptions::SelectionByUsingSoftkey ( ) const [inline]

bit 3: 0 = no selection preference | 1 = selection using soft key preferred

The documentation for this class was generated from the following files:
  • Apc/SimTkTypes.hpp
  • Apc/SimTkTypes.cpp
Generated on Wed Jan 25 01:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimServices Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimServices Class Reference
[Provider]

#include <Apoxi/Adc/SstProvider.hpp>

Collaboration diagram for SimServices:

[legend]

Public Member Functions

void | Init (SimAuxHandler *aux_handler)
BOOLEAN | IsSimServiceEnabled (SimServiceId id, BOOLEAN &isenabled)
SimServices ()
virtual | ~SimServices ()

Constructor & Destructor Documentation

SimServices::SimServices ( )

SimServices::~SimServices ( ) [virtual]

Member Function Documentation

void SimServices::Init ( SimAuxHandler * aux_handler )

BOOLEAN SimServices::IsSimServiceEnabled | ( | SimServiceId | id,
 |  | BOOLEAN & | isenabled
 | ) |

The documentation for this class was generated from the following files:
  • Adc/SstProvider.hpp
  • Adc/SstProvider.cpp
Generated on Wed Jan 25 01:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimServiceTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimServiceTable Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [16]

Field Documentation

UINT8 SimServiceTable::val[16]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSetupIdleModeTextMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSetupIdleModeTextMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimSetupIdleModeTextMsg:

[legend]
Collaboration diagram for SimSetupIdleModeTextMsg:

[legend]

Public Types

enum | { ID = 18317 }

Public Member Functions

virtual Message * | Clone () const
const SetupIdleModeTextReqArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SetupIdleModeTextReqArg &arg)
SimSetupIdleModeTextMsg (ExecutionContext *context, const SetupIdleModeTextReqArg &arg)
virtual | ~SimSetupIdleModeTextMsg ()

Detailed Description

SimSetupIdleModeTextMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSetupIdleModeTextMsg::SimSetupIdleModeTextMsg | ( | ExecutionContext * | context,
 |  | const SetupIdleModeTextReqArg & | arg
 | ) |

SimSetupIdleModeTextMsg::~SimSetupIdleModeTextMsg ( ) [virtual]

Member Function Documentation

Message * SimSetupIdleModeTextMsg::Clone ( ) const [virtual]

Implements Message.

const SetupIdleModeTextReqArg& SimSetupIdleModeTextMsg::GetArg ( ) const [inline]

const MsgMetaData & SimSetupIdleModeTextMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimSetupIdleModeTextMsg::SetArg ( const SetupIdleModeTextReqArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSetupIdleModeTextOptions Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSetupIdleModeTextOptions Class Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimSetupIdleModeTextOptions:

[legend]

Public Member Functions

void | Clear ()
UINT8 | Get () const
SimSetupIdleModeTextOptions (SdlByte bit_field=0)
~SimSetupIdleModeTextOptions ()

Constructor & Destructor Documentation

SimSetupIdleModeTextOptions::SimSetupIdleModeTextOptions ( SdlByte bit_field = 0 )

SimSetupIdleModeTextOptions::~SimSetupIdleModeTextOptions ( )

Member Function Documentation

void SimSetupIdleModeTextOptions::Clear ( ) [inline]

UINT8 SimSetupIdleModeTextOptions::Get ( ) const [inline]

The documentation for this class was generated from the following files:
  • Apc/SimTkTypes.hpp
  • Apc/SimTkTypes.cpp
Generated on Wed Jan 25 01:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSetupMenuMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSetupMenuMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimSetupMenuMsg:

[legend]
Collaboration diagram for SimSetupMenuMsg:

[legend]

Public Types

enum | { ID = 18314 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SimTkTransactionId & | GetTid () const
void | SetTid (const SimTkTransactionId &tid)
SimSetupMenuMsg (ExecutionContext *context, const SimTkTransactionId &tid)
virtual | ~SimSetupMenuMsg ()

Detailed Description

SimSetupMenuMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSetupMenuMsg::SimSetupMenuMsg | ( | ExecutionContext * | context,
 |  | const SimTkTransactionId & | tid
 | ) |

SimSetupMenuMsg::~SimSetupMenuMsg ( ) [virtual]

Member Function Documentation

Message * SimSetupMenuMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimSetupMenuMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const SimTkTransactionId& SimSetupMenuMsg::GetTid ( ) const [inline]

void SimSetupMenuMsg::SetTid ( const SimTkTransactionId & tid ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSetupMenuOptions Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSetupMenuOptions Class Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimSetupMenuOptions:

[legend]

Public Member Functions

void | Clear ()
UINT8 | Get () const
BOOLEAN | HelpAvailable () const
bit 8: 0 = no help information available | 1 = help information available
BOOLEAN | SelectionByUsingSoftkey () const
bit 1: 0 = no selection preference | 1 = selection using soft key preferred
SimSetupMenuOptions (SdlByte bit_field=0)
~SimSetupMenuOptions ()

Constructor & Destructor Documentation

SimSetupMenuOptions::SimSetupMenuOptions ( SdlByte bit_field = 0 )

SimSetupMenuOptions::~SimSetupMenuOptions ( )

Member Function Documentation

void SimSetupMenuOptions::Clear ( ) [inline]

UINT8 SimSetupMenuOptions::Get ( ) const [inline]

BOOLEAN SimSetupMenuOptions::HelpAvailable ( ) const [inline]

bit 8: 0 = no help information available | 1 = help information available

BOOLEAN SimSetupMenuOptions::SelectionByUsingSoftkey ( ) const [inline]

bit 1: 0 = no selection preference | 1 = selection using soft key preferred

The documentation for this class was generated from the following files:
  • Apc/SimTkTypes.hpp
  • Apc/SimTkTypes.cpp
Generated on Wed Jan 25 01:54:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSmsParameter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSmsParameter Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimSmsParamHandler.hpp>

Collaboration diagram for SimSmsParameter:

[legend]

Public Member Functions

const WString & | GetName () const
BOOLEAN | GetSmsParameter (SimSmsParameter::Record &record)
const UINT8 * | GetSmspBuffer () const
BOOLEAN | SetSmsParameter (const SimSmsParameter::Record &record)
SimSmsParameter (const WString &name, const UINT8 *buffer)
~SimSmsParameter ()

Data Structures

struct | Record

Constructor & Destructor Documentation

SimSmsParameter::SimSmsParameter | ( | const WString & | name,
 |  | const UINT8 * | buffer
 | ) |

SimSmsParameter::~SimSmsParameter ( )

Member Function Documentation

const WString& SimSmsParameter::GetName ( ) const [inline]

BOOLEAN SimSmsParameter::GetSmsParameter ( SimSmsParameter::Record & record )

const UINT8* SimSmsParameter::GetSmspBuffer ( ) const [inline]

BOOLEAN SimSmsParameter::SetSmsParameter ( const SimSmsParameter::Record & record )

The documentation for this class was generated from the following files:
  • Adc/SimSmsParamHandler.hpp
  • Adc/SimSmsParamHandler.cpp
Generated on Wed Jan 25 01:54:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSmsParameter::Record Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SimSmsParameter::Record

SimSmsParameter::Record Struct Reference

#include <Apoxi/Adc/SimSmsParamHandler.hpp>

Collaboration diagram for SimSmsParameter::Record:

[legend]

Data Fields

PhoneNumber m_da
UINT8 | m_dcs
BOOLEAN | m_exist_da
BOOLEAN | m_exist_dcs
BOOLEAN | m_exist_name
BOOLEAN | m_exist_protid
BOOLEAN | m_exist_sca
BOOLEAN | m_exist_vp
WString m_name
UINT8 | m_protid
PhoneNumber m_sca
UINT8 | m_vp

Field Documentation

PhoneNumber SimSmsParameter::Record::m_da

UINT8 SimSmsParameter::Record::m_dcs

BOOLEAN SimSmsParameter::Record::m_exist_da

BOOLEAN SimSmsParameter::Record::m_exist_dcs

BOOLEAN SimSmsParameter::Record::m_exist_name

BOOLEAN SimSmsParameter::Record::m_exist_protid

BOOLEAN SimSmsParameter::Record::m_exist_sca

BOOLEAN SimSmsParameter::Record::m_exist_vp

WString SimSmsParameter::Record::m_name

UINT8 SimSmsParameter::Record::m_protid

PhoneNumber SimSmsParameter::Record::m_sca

UINT8 SimSmsParameter::Record::m_vp

The documentation for this struct was generated from the following file:
  • Adc/SimSmsParamHandler.hpp
Generated on Wed Jan 25 01:54:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSmsParamHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSmsParamHandler Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimSmsParamHandler.hpp>

Inheritance diagram for SimSmsParamHandler:

[legend]
Collaboration diagram for SimSmsParamHandler:

[legend]

Public Member Functions

BOOLEAN | GetAlphaIdLength (INT &length)
INT | GetMaxSmspCount () const
BOOLEAN | GetSmsParameter (INT recno, SimSmsParameter::Record &record)
void | Refresh ()
BOOLEAN | RefreshData (INT)
void | Reset ()
BOOLEAN | RetrieveSmsServiceParameter ()
BOOLEAN | RetrieveUsimSmsServiceParameter ()
BOOLEAN | SetSmsParameter (INT recno, const SimSmsParameter::Record &record)
SimSmsParamHandler ()
BOOLEAN | UpdateSmsServiceParameter (INT recno, BOOLEAN deleterecord=FALSE)
virtual | ~SimSmsParamHandler ()

Constructor & Destructor Documentation

SimSmsParamHandler::SimSmsParamHandler ( )

SimSmsParamHandler::~SimSmsParamHandler ( ) [virtual]

Member Function Documentation

BOOLEAN SimSmsParamHandler::GetAlphaIdLength ( INT & length )

INT SimSmsParamHandler::GetMaxSmspCount ( ) const [inline]

BOOLEAN SimSmsParamHandler::GetSmsParameter | ( | INT | recno,
 |  | SimSmsParameter::Record & | record
 | ) |

void SimSmsParamHandler::Refresh ( )

BOOLEAN SimSmsParamHandler::RefreshData ( INT )

void SimSmsParamHandler::Reset ( )

BOOLEAN SimSmsParamHandler::RetrieveSmsServiceParameter ( )

BOOLEAN SimSmsParamHandler::RetrieveUsimSmsServiceParameter ( )

BOOLEAN SimSmsParamHandler::SetSmsParameter | ( | INT | recno,
 |  | const SimSmsParameter::Record & | record
 | ) |

BOOLEAN SimSmsParamHandler::UpdateSmsServiceParameter | ( | INT | recno,
 |  | BOOLEAN | deleterecord = FALSE
 | ) |

The documentation for this class was generated from the following files:
  • Adc/SimSmsParamHandler.hpp
  • Adc/SimSmsParamHandler.cpp
Generated on Wed Jan 25 01:54:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSmsrReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSmsrReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimSmsrReadIndArg:

[legend]
Collaboration diagram for SimSmsrReadIndArg:

[legend]

Public Types

enum | { ID = 1434 }

Public Member Functions

UINT8 | GetLink () const
INT | GetRecNo () const
const SmsrData & | GetSmsrData () const
const SimUpdateStatus & | GetStatus () const
void | SetLink (UINT8 link)
void | SetRecNo (INT rec_no)
void | SetSmsrData (const SmsrData &smsr_data)
void | SetStatus (const SimUpdateStatus &status)
SimSmsrReadIndArg ()

Static Public Member Functions

static const SimSmsrReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimSmsrReadIndArg: reflects arguments of signal SI_SMSR_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSmsrReadIndArg::SimSmsrReadIndArg ( )

Member Function Documentation

const SimSmsrReadIndArg & SimSmsrReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimSmsrReadIndArg::GetLink ( ) const [inline]

INT SimSmsrReadIndArg::GetRecNo ( ) const [inline]

const SmsrData& SimSmsrReadIndArg::GetSmsrData ( ) const [inline]

const SimUpdateStatus& SimSmsrReadIndArg::GetStatus ( ) const [inline]

void SimSmsrReadIndArg::SetLink ( UINT8 link ) [inline]

void SimSmsrReadIndArg::SetRecNo ( INT rec_no ) [inline]

void SimSmsrReadIndArg::SetSmsrData ( const SmsrData & smsr_data ) [inline]

void SimSmsrReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSmsrReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSmsrReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimSmsrReadReqArg:

[legend]
Collaboration diagram for SimSmsrReadReqArg:

[legend]

Public Types

enum | { ID = 2432 }

Public Member Functions

INT | GetRecNo () const
void | SetRecNo (INT rec_no)
SimSmsrReadReqArg ()
SimSmsrReadReqArg (INT rec_no)

Static Public Member Functions

static const SimSmsrReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimSmsrReadReqArg: reflects arguments of signal SI_SMSR_READ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSmsrReadReqArg::SimSmsrReadReqArg ( INT rec_no )

SimSmsrReadReqArg::SimSmsrReadReqArg ( )

Member Function Documentation

const SimSmsrReadReqArg & SimSmsrReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimSmsrReadReqArg::GetRecNo ( ) const [inline]

void SimSmsrReadReqArg::SetRecNo ( INT rec_no ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSmsrUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSmsrUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimSmsrUpdIndArg:

[legend]
Collaboration diagram for SimSmsrUpdIndArg:

[legend]

Public Types

enum | { ID = 1435 }

Public Member Functions

INT | GetRecNo () const
const SimUpdateStatus & | GetStatus () const
void | SetRecNo (INT rec_no)
void | SetStatus (const SimUpdateStatus &status)
SimSmsrUpdIndArg ()

Static Public Member Functions

static const SimSmsrUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimSmsrUpdIndArg: reflects arguments of signal SI_SMSR_UPDATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSmsrUpdIndArg::SimSmsrUpdIndArg ( )

Member Function Documentation

const SimSmsrUpdIndArg & SimSmsrUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT SimSmsrUpdIndArg::GetRecNo ( ) const [inline]

const SimUpdateStatus& SimSmsrUpdIndArg::GetStatus ( ) const [inline]

void SimSmsrUpdIndArg::SetRecNo ( INT rec_no ) [inline]

void SimSmsrUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSmsrUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSmsrUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimSmsrUpdReqArg:

[legend]
Collaboration diagram for SimSmsrUpdReqArg:

[legend]

Public Types

enum | { ID = 2433 }

Public Member Functions

UINT8 | GetLink () const
INT | GetRecNo () const
const SmsrData & | GetSmsrData () const
void | SetLink (UINT8 link)
void | SetRecNo (INT rec_no)
void | SetSmsrData (const SmsrData &smsr_data)
SimSmsrUpdReqArg ()
SimSmsrUpdReqArg (INT rec_no, UINT8 link, const SmsrData &smsr_data)

Static Public Member Functions

static const SimSmsrUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimSmsrUpdReqArg: reflects arguments of signal SI_SMSR_UPDATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSmsrUpdReqArg::SimSmsrUpdReqArg | ( | INT | rec_no,
 |  | UINT8 | link,
 |  | const SmsrData & | smsr_data
 | ) |

SimSmsrUpdReqArg::SimSmsrUpdReqArg ( )

Member Function Documentation

const SimSmsrUpdReqArg & SimSmsrUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimSmsrUpdReqArg::GetLink ( ) const [inline]

INT SimSmsrUpdReqArg::GetRecNo ( ) const [inline]

const SmsrData& SimSmsrUpdReqArg::GetSmsrData ( ) const [inline]

void SimSmsrUpdReqArg::SetLink ( UINT8 link ) [inline]

void SimSmsrUpdReqArg::SetRecNo ( INT rec_no ) [inline]

void SimSmsrUpdReqArg::SetSmsrData ( const SmsrData & smsr_data ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSmsSentMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSmsSentMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimSmsSentMsg:

[legend]
Collaboration diagram for SimSmsSentMsg:

[legend]

Public Types

enum | { ID = 18302 }

Public Member Functions

virtual Message * | Clone () const
const SimTkSmsPpIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimTkSmsPpIndArg &arg)
SimSmsSentMsg (ExecutionContext *context, const SimTkSmsPpIndArg &arg)
virtual | ~SimSmsSentMsg ()

Detailed Description

SimSmsSentMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSmsSentMsg::SimSmsSentMsg | ( | ExecutionContext * | context,
 |  | const SimTkSmsPpIndArg & | arg
 | ) |

SimSmsSentMsg::~SimSmsSentMsg ( ) [virtual]

Member Function Documentation

Message * SimSmsSentMsg::Clone ( ) const [virtual]

Implements Message.

const SimTkSmsPpIndArg& SimSmsSentMsg::GetArg ( ) const [inline]

const MsgMetaData & SimSmsSentMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimSmsSentMsg::SetArg ( const SimTkSmsPpIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSpnReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSpnReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimSpnReadIndArg:

[legend]
Collaboration diagram for SimSpnReadIndArg:

[legend]

Public Types

enum | { ID = 1416 }

Public Member Functions

const ServiceProviderStruct & | GetSpnStruct () const
const SimUpdateStatus & | GetStatus () const
void | SetSpnStruct (const ServiceProviderStruct &spn_struct)
void | SetStatus (const SimUpdateStatus &status)
SimSpnReadIndArg ()

Static Public Member Functions

static const SimSpnReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimSpnReadIndArg: reflects arguments of signal SI_SPN_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSpnReadIndArg::SimSpnReadIndArg ( )

Member Function Documentation

const SimSpnReadIndArg & SimSpnReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ServiceProviderStruct& SimSpnReadIndArg::GetSpnStruct ( ) const [inline]

const SimUpdateStatus& SimSpnReadIndArg::GetStatus ( ) const [inline]

void SimSpnReadIndArg::SetSpnStruct ( const ServiceProviderStruct & spn_struct ) [inline]

void SimSpnReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSpnReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSpnReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimSpnReadReqArg:

[legend]
Collaboration diagram for SimSpnReadReqArg:

[legend]

Public Types

enum | { ID = 2414 }

Public Member Functions

SimSpnReadReqArg ()

Static Public Member Functions

static const SimSpnReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimSpnReadReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSpnReadReqArg::SimSpnReadReqArg ( )

Member Function Documentation

const SimSpnReadReqArg & SimSpnReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:54:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSsSentMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSsSentMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimSsSentMsg:

[legend]
Collaboration diagram for SimSsSentMsg:

[legend]

Public Types

enum | { ID = 18303 }

Public Member Functions

virtual Message * | Clone () const
const SimTkSsIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimTkSsIndArg &arg)
SimSsSentMsg (ExecutionContext *context, const SimTkSsIndArg &arg)
virtual | ~SimSsSentMsg ()

Detailed Description

SimSsSentMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSsSentMsg::SimSsSentMsg | ( | ExecutionContext * | context,
 |  | const SimTkSsIndArg & | arg
 | ) |

SimSsSentMsg::~SimSsSentMsg ( ) [virtual]

Member Function Documentation

Message * SimSsSentMsg::Clone ( ) const [virtual]

Implements Message.

const SimTkSsIndArg& SimSsSentMsg::GetArg ( ) const [inline]

const MsgMetaData & SimSsSentMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimSsSentMsg::SetArg ( const SimTkSsIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:54:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSstReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSstReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimSstReadIndArg:

[legend]
Collaboration diagram for SimSstReadIndArg:

[legend]

Public Types

enum | { ID = 1403 }

Public Member Functions

const SimServiceTable & | GetSst () const
const SimUpdateStatus & | GetStatus () const
void | SetSst (const SimServiceTable &sst)
void | SetStatus (const SimUpdateStatus &status)
SimSstReadIndArg ()

Static Public Member Functions

static const SimSstReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimSstIndArg: reflects arguments of signal SI_SST_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSstReadIndArg::SimSstReadIndArg ( )

Member Function Documentation

const SimSstReadIndArg & SimSstReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimServiceTable& SimSstReadIndArg::GetSst ( ) const [inline]

const SimUpdateStatus& SimSstReadIndArg::GetStatus ( ) const [inline]

void SimSstReadIndArg::SetSst ( const SimServiceTable & sst ) [inline]

void SimSstReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSstReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSstReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for SimSstReadReqArg:

[legend]
Collaboration diagram for SimSstReadReqArg:

[legend]

Public Types

enum | { ID = 2401 }

Public Member Functions

SimSstReadReqArg ()

Static Public Member Functions

static const SimSstReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimSstReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimSstReadReqArg::SimSstReadReqArg ( )

Member Function Documentation

const SimSstReadReqArg & SimSstReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimStateChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimStateChangedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimStateChangedMsg:

[legend]
Collaboration diagram for SimStateChangedMsg:

[legend]

Public Types

enum | { ID = 18700 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SimIndicator & | GetSimIndicator () const
void | SetSimIndicator (const SimIndicator &sim_indicator)
SimStateChangedMsg (const SimIndicator &sim_indicator)
virtual | ~SimStateChangedMsg ()

Detailed Description

SimStateChangedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimStateChangedMsg::SimStateChangedMsg ( const SimIndicator & sim_indicator )

SimStateChangedMsg::~SimStateChangedMsg ( ) [virtual]

Member Function Documentation

Message * SimStateChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimStateChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

const SimIndicator& SimStateChangedMsg::GetSimIndicator ( ) const [inline]

void SimStateChangedMsg::SetSimIndicator ( const SimIndicator & sim_indicator ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:55:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimSubAddress Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimSubAddress Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

UINT8 val [22]

Field Documentation

UINT8 SimSubAddress::val[22]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:55:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTextString Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTextString Class Reference

representing tlv text string - GSM 11.14 [12.15] More...

#include <Apoxi/Apc/SimDataTypes.hpp>

Collaboration diagram for SimTextString:

[legend]

Public Types

enum | DataSource { TlvSource, SmsDataSource, CbsDataSource, UssdDataSource }

Public Member Functions

void | Clear ()
INT | Convert2SdlText (T_SI_TEXT &sdl_si_text) const
INT | Convert2UserData (UserData &user_data) const
const DataCodingScheme & | GetDataCodingScheme () const
const WString & | GetText () const
SimTextString (const WString &text, const DataCodingScheme &dcs)
SimTextString (const T_SI_TEXT_PTR &sdl_si_text_ptr)
SimTextString (const T_SI_TEXT &sdl_si_text)
SimTextString (const Tlv &tlv)
SimTextString (const UserData &user_data, const DataCodingScheme &dcs)
SimTextString (const UINT8 *buffer, const INT len, const DataCodingScheme &dcs, DataSource datasource)
encodes data
SimTextString (const UINT8 *buffer, const INT len, const DataCodingScheme &dcs=DataCodingScheme())
encodes data
SimTextString ()
encodes data
~SimTextString ()

Detailed Description

representing tlv text string - GSM 11.14 [12.15]

Member Enumeration Documentation

enum SimTextString::DataSource

Enumerator:
TlvSource
SmsDataSource
CbsDataSource
UssdDataSource

Constructor & Destructor Documentation

SimTextString::SimTextString ( )

encodes data

SimTextString::SimTextString | ( | const UINT8 * | buffer,
 |  | const INT | len,
 |  | const DataCodingScheme & | dcs = DataCodingScheme()
 | ) |

encodes data

SimTextString::SimTextString | ( | const UINT8 * | buffer,
 |  | const INT | len,
 |  | const DataCodingScheme & | dcs,
 |  | DataSource | datasource
 | ) |

encodes data

SimTextString::SimTextString | ( | const UserData & | user_data,
 |  | const DataCodingScheme & | dcs
 | ) |

SimTextString::SimTextString ( const Tlv & tlv )

SimTextString::SimTextString ( const T_SI_TEXT & sdl_si_text )

SimTextString::SimTextString ( const T_SI_TEXT_PTR & sdl_si_text_ptr )

SimTextString::SimTextString | ( | const WString & | text,
 |  | const DataCodingScheme & | dcs
 | ) |

SimTextString::~SimTextString ( )

Member Function Documentation

void SimTextString::Clear ( ) [inline]

INT SimTextString::Convert2SdlText ( T_SI_TEXT & sdl_si_text ) const

updates the buffer length of the sdl_si_text structure to the number of effective converted length and returns the number of converted characters.

INT SimTextString::Convert2UserData ( UserData & user_data ) const

updates (accumulates) the buffer length of the user_data structure to the number of effective converted length and returns the number of converted characters.

const DataCodingScheme& SimTextString::GetDataCodingScheme ( ) const [inline]

const WString& SimTextString::GetText ( ) const [inline]

The documentation for this class was generated from the following files:
  • Apc/SimDataTypes.hpp
  • Apc/SimDataTypes.cpp
Generated on Wed Jan 25 01:55:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkCallSetupAccArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkCallSetupAccArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkCallSetupAccArg:

[legend]
Collaboration diagram for SimTkCallSetupAccArg:

[legend]

Public Types

enum | { ID = 2302 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
BOOLEAN | IsCtm () const
void | SetCtm (BOOLEAN ctm)
void | SetProactiveCause (const ProactiveCause &proactive_cause)
SimTkCallSetupAccArg ()
SimTkCallSetupAccArg (const ProactiveCause &proactive_cause, BOOLEAN ctm)

Static Public Member Functions

static const SimTkCallSetupAccArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkCallSetupAccArg: reflects arguments of signal MN_SIMTK_SETUP_CALL_ACC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkCallSetupAccArg::SimTkCallSetupAccArg | ( | const ProactiveCause & | proactive_cause,
 |  | BOOLEAN | ctm
 | ) |

SimTkCallSetupAccArg::SimTkCallSetupAccArg ( )

Member Function Documentation

const SimTkCallSetupAccArg & SimTkCallSetupAccArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkCallSetupAccArg::GetProactiveCause ( ) const [inline]

BOOLEAN SimTkCallSetupAccArg::IsCtm ( ) const [inline]

void SimTkCallSetupAccArg::SetCtm ( BOOLEAN ctm ) [inline]

void SimTkCallSetupAccArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkCallSetupIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkCallSetupIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkCallSetupIndArg:

[legend]
Collaboration diagram for SimTkCallSetupIndArg:

[legend]

Public Types

enum | { ID = 1300 }

Public Member Functions

const SimAlphaIdentifier & | GetCallEstablishedInfoAlpha () const
const SimIconIdentifier & | GetCallEstablishedInfoIcon () const
const SimAlphaIdentifier & | GetCallInfoAlpha () const
const SimIconIdentifier & | GetCallInfoIcon () const
const SimDummy & | GetDummy () const
const PhoneNumber & | GetPhoneNumber () const
const SimSubAddress & | GetSubAddress () const
void | SetCallEstablishedInfoAlpha (const SimAlphaIdentifier &call_established_info_alpha)
void | SetCallEstablishedInfoIcon (const SimIconIdentifier &call_established_info_icon)
void | SetCallInfoAlpha (const SimAlphaIdentifier &call_info_alpha)
void | SetCallInfoIcon (const SimIconIdentifier &call_info_icon)
void | SetDummy (const SimDummy &dummy)
void | SetPhoneNumber (const PhoneNumber &phone_number)
void | SetSubAddress (const SimSubAddress &sub_address)
SimTkCallSetupIndArg ()

Static Public Member Functions

static const SimTkCallSetupIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkCallSetupIndArg: reflects arguments of signal MN_SIMTK_SETUP_CALL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkCallSetupIndArg::SimTkCallSetupIndArg ( )

Member Function Documentation

const SimTkCallSetupIndArg & SimTkCallSetupIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimAlphaIdentifier& SimTkCallSetupIndArg::GetCallEstablishedInfoAlpha ( ) const [inline]

const SimIconIdentifier& SimTkCallSetupIndArg::GetCallEstablishedInfoIcon ( ) const [inline]

const SimAlphaIdentifier& SimTkCallSetupIndArg::GetCallInfoAlpha ( ) const [inline]

const SimIconIdentifier& SimTkCallSetupIndArg::GetCallInfoIcon ( ) const [inline]

const SimDummy& SimTkCallSetupIndArg::GetDummy ( ) const [inline]

const PhoneNumber& SimTkCallSetupIndArg::GetPhoneNumber ( ) const [inline]

const SimSubAddress& SimTkCallSetupIndArg::GetSubAddress ( ) const [inline]

void SimTkCallSetupIndArg::SetCallEstablishedInfoAlpha ( const SimAlphaIdentifier & call_established_info_alpha ) [inline]

void SimTkCallSetupIndArg::SetCallEstablishedInfoIcon ( const SimIconIdentifier & call_established_info_icon ) [inline]

void SimTkCallSetupIndArg::SetCallInfoAlpha ( const SimAlphaIdentifier & call_info_alpha ) [inline]

void SimTkCallSetupIndArg::SetCallInfoIcon ( const SimIconIdentifier & call_info_icon ) [inline]

void SimTkCallSetupIndArg::SetDummy ( const SimDummy & dummy ) [inline]

void SimTkCallSetupIndArg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

void SimTkCallSetupIndArg::SetSubAddress ( const SimSubAddress & sub_address ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkCallSetupRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkCallSetupRejArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkCallSetupRejArg:

[legend]
Collaboration diagram for SimTkCallSetupRejArg:

[legend]

Public Types

enum | { ID = 2303 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
SimTkCallSetupRejArg ()
SimTkCallSetupRejArg (const ProactiveCause &proactive_cause)

Static Public Member Functions

static const SimTkCallSetupRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkCallSetupRejArg: reflects arguments of signal MNMI_SIMTK_SETUP_CALL_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkCallSetupRejArg::SimTkCallSetupRejArg ( const ProactiveCause & proactive_cause )

SimTkCallSetupRejArg::SimTkCallSetupRejArg ( )

Member Function Documentation

const SimTkCallSetupRejArg & SimTkCallSetupRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkCallSetupRejArg::GetProactiveCause ( ) const [inline]

void SimTkCallSetupRejArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SimTkHandler.hpp>

Public Types

enum | { ID = SimTkHandlerId }

Public Member Functions

CallApiRc | AcceptCallSetup (const ProactiveCause &cause, BOOLEAN ctm=FALSE) const
BOOLEAN | BrowserLaunched (ProactiveCause proactivecause)
BOOLEAN | BrowserLaunched (const SimTkTransactionId &tid, ProactiveCause proactivecause)
BOOLEAN | BrowserTerminated (UINT8 termcause)
BOOLEAN | ConfirmDtmfSending (const ProactiveCause &icon_display_cause)
virtual HandlerId | GetHandlerId () const
BOOLEAN | GetSimIconDescription (INT id, SimIconDescription &data)
BOOLEAN | GetSimImage (const SimImageDescriptor &imgdesc, SimImage &data)
void | GetSimTkProfileReq () const
BOOLEAN | Inkey (const ProactiveCause &cause, SimKey key=SimKeyInvalid) const
BOOLEAN | Inkey (const SimTkTransactionId &tid, const ProactiveCause &cause, SimKey key=SimKeyInvalid) const
BOOLEAN | Inkey (const ProactiveCause &cause, const WString &text, BOOLEAN ucs2_coding=FALSE) const
BOOLEAN | Inkey (const SimTkTransactionId &tid, const ProactiveCause &cause, const WString &text, BOOLEAN ucs2_coding=FALSE) const
BOOLEAN | Input (const ProactiveCause &cause, const WString &text, BOOLEAN ucs2_coding=FALSE, BOOLEAN packed=TRUE) const
BOOLEAN | Input (const SimTkTransactionId &tid, const ProactiveCause &cause, const WString &text, BOOLEAN ucs2_coding=FALSE, BOOLEAN packed=TRUE) const
BOOLEAN | ItemSelected (const ProactiveCause &cause, const SimItemId &item_id) const
BOOLEAN | ItemSelected (const SimTkTransactionId &tid, const ProactiveCause &cause, const SimItemId &item_id) const
BOOLEAN | LaunchBrowser (SdlByte generalresult)
BOOLEAN | LaunchBrowser (const SimTkTransactionId &tid, SdlByte generalresult)
BOOLEAN | MenuItemSelected (const SimItemId &item_id, BOOLEAN help_requested=FALSE) const
BOOLEAN | RegisterBrowser (SiClientFlags siclientflags)
BOOLEAN | RejectCallSetup (const ProactiveCause &cause=UserDidNotAcceptCallSetupRequest) const
BOOLEAN | RunAtCommandResponse (const SimTkTransactionId &tid, ProactiveCause proactivecause)
BOOLEAN | SendIdleScreenAvailEvent ()
BOOLEAN | SendLanguageSelectEvent ()
BOOLEAN | SendSimTkRefreshRsp ()
BOOLEAN | SendUserActivityEvent ()
BOOLEAN | SetActiveExtLanguage (const WString &language)
BOOLEAN | SetSimRefreshPossible (BOOLEAN isrefreshable)
BOOLEAN | SetSimResetPossible (BOOLEAN isresetable)
BOOLEAN | SetupIdleModeTextDone (const ProactiveCause &cause) const
BOOLEAN | SetupIdleModeTextDone (const SimTkTransactionId &tid, const ProactiveCause &cause) const
BOOLEAN | SetupMenuDone (const ProactiveCause &cause) const
BOOLEAN | SetupMenuDone (const SimTkTransactionId &tid, const ProactiveCause &cause) const
SimTkHandler ()
void | SimTkProfileFactoryReset () const
BOOLEAN | SmsSetupResponse (const ProactiveCause &cause, const SimReferenceNumber &ref_no) const
BOOLEAN | SsSetupResponse (const ProactiveCause &cause, const SimReferenceNumber &ref_no) const
BOOLEAN | StopDtmfSending ()
BOOLEAN | TextDisplayed (const ProactiveCause &cause) const
BOOLEAN | TextDisplayed (const SimTkTransactionId &tid, const ProactiveCause &cause) const
BOOLEAN | TonePlayed (const ProactiveCause &cause) const
BOOLEAN | TonePlayed (const SimTkTransactionId &tid, const ProactiveCause &cause) const
void | UpdateSimTkProfileReq (const SimTkProfile &profile_data) const
virtual | ~SimTkHandler ()

Static Public Member Functions

static void | EnableProactiveDtmfTones (BOOLEAN enable=TRUE)

Detailed Description

The SIM Toolkit handler SimTkHandler holds the functionality for receiving SIM Toolkit events coming up from the protocolstack and provides an interface for the application to react to these events. If the underlying stack supports Simtk transaction ids, the methods with the SimTkTransactionId must be called.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkHandler::SimTkHandler ( )

SimTkHandler::~SimTkHandler ( ) [virtual]

Member Function Documentation

CallApiRc SimTkHandler::AcceptCallSetup | ( | const ProactiveCause & | cause,
 |  | BOOLEAN | ctm = FALSE
 | ) | const

The method AcceptCall(const ProactiveCause &) can be executed when SIM Toolkit is waiting for an answer to a previous sent message SimTkCallSetupMsg. With this function the application can accept the call setup request. If the method is executed, while SIM Toolkit is not waiting for a response, it has no effects, that means it will not lead to a call setup!

Parameters:
cause | indicates, if the request was successful processed by the application or not.
ctm,TRUE | if CTM/TTY is used
Returns:
TRUE, if the call accept was successfully initiated.

BOOLEAN SimTkHandler::BrowserLaunched ( ProactiveCause proactivecause )

BOOLEAN SimTkHandler::BrowserLaunched | ( | const SimTkTransactionId & | tid,
 |  | ProactiveCause | proactivecause
 | ) |

The method BrowserLaunched Informs SIM about (un)successful start of browser and re-try possibility. Creates a SIBR_LAUNCH_BROWSER_IND(gen_result, adn_result) message.

BOOLEAN SimTkHandler::BrowserTerminated ( UINT8 termcause )

The method BrowserTerminated Informs SIM about browser termination. Creates a BRSI_BROWSER_TERM_EVENT(term_cause) message.

BOOLEAN SimTkHandler::ConfirmDtmfSending ( const ProactiveCause & icon_display_cause )

The method ConfirmDtmfSending(const ProactiveCause &icon_display_cause) confirms a DTMF sending and is the response for the SIM Toolkit request SimTkSendDtmfIndMsg.

void SimTkHandler::EnableProactiveDtmfTones ( BOOLEAN enable = TRUE ) [static]

The method EnableProcativeDtmfTones call the msap function msap_enable_proactive_dtmf_tones which controls the behaviour of processing DTMF tones regarding proactive commands.

HandlerId SimTkHandler::GetHandlerId ( ) const [virtual]

BOOLEAN SimTkHandler::GetSimIconDescription | ( | INT | id,
 |  | SimIconDescription & | data
 | ) |

The method GetSimIconDescription allows retrieving the icondescription of the icon identified with id. SimIconDescription has access methods to access the image descriptors which then are used to retrieve the image.

BOOLEAN SimTkHandler::GetSimImage | ( | const SimImageDescriptor & | imgdesc,
 |  | SimImage & | data
 | ) |

The method GetSimImage allows retrieving the image identified by the SimImageDescriptor. SimImage allows accessing the image buffer and additional data.

void SimTkHandler::GetSimTkProfileReq ( ) const

The method GetSimTkProfileReq sends a request to the OM-process for retrieving the Terminal Profile. MMI then receives the profile inside the message SimTkProfileGetCnfMsg.

BOOLEAN SimTkHandler::Inkey | ( | const ProactiveCause & | cause,
 |  | SimKey | key = SimKeyInvalid
 | ) | const

BOOLEAN SimTkHandler::Inkey | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | cause,
 |  | SimKey | key = SimKeyInvalid
 | ) | const

BOOLEAN SimTkHandler::Inkey | ( | const ProactiveCause & | cause,
 |  | const WString & | text,
 |  | BOOLEAN | ucs2_coding = FALSE
 | ) | const

BOOLEAN SimTkHandler::Inkey | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | cause,
 |  | const WString & | text,
 |  | BOOLEAN | ucs2_coding = FALSE
 | ) | const

The method Inkey(const ProactiveCause &, const WString &) is the response for the SIM Toolkit request SimGetInkeyMsg.

Parameters:
tid,transaction-id | which must be retrieved from the argument contained in SimGetInkeyMsg.
cause | indicates, if the request was successful processed by the application or not.
text | represents the inkey response from the application, referring to the preceeding (by SIM Toolkit) sent inkey request.
ucs2_coding | is set when UCS2 alphabet should be used to encode the text, by default GSM DefaultAlphabet is used (use_ucs2_alphabet = FALSE).
packed | is used only for GSM DefaultAlphabet coding.
Returns:
TRUE, if the method was successfully initiated.

BOOLEAN SimTkHandler::Input | ( | const ProactiveCause & | cause,
 |  | const WString & | text,
 |  | BOOLEAN | ucs2_coding = FALSE,
 |  | BOOLEAN | packed = TRUE
 | ) | const

BOOLEAN SimTkHandler::Input | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | cause,
 |  | const WString & | text,
 |  | BOOLEAN | ucs2_coding = FALSE,
 |  | BOOLEAN | packed = TRUE
 | ) | const

The method Input(const ProactiveCause &, const WString &) is the response for the SIM Toolkit request SimGetInputMsg.

Parameters:
tid,transaction-id | which must be retrieved from the argument contained in SimGetInputMsg.
cause | indicates, if the request was successful processed by the application or not.
text | represents the input response, referring to the preceeding (by SIM Toolkit) sent input request.
ucs2_coding | is set when UCS2 alphabet should be used to encode the text, by default GSM DefaultAlphabet is used (use_ucs2_alphabet = FALSE).
packed | is used only for GSM DefaultAlphabet coding.
Returns:
TRUE, if the method was successfully initiated.

BOOLEAN SimTkHandler::ItemSelected | ( | const ProactiveCause & | cause,
 |  | const SimItemId & | item_id
 | ) | const

BOOLEAN SimTkHandler::ItemSelected | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | cause,
 |  | const SimItemId & | item_id
 | ) | const

The method ItemSelected(const ProactiveCause &, const SimItemId &) is the response for the SIM Toolkit request SelectItemReqMsg.

Parameters:
tid,transaction-id | which must be retrieved from the argument contained in SelectItemReqMsg.
cause | indicates, if the request was successful processed by the application or not.
item_id | represents the selected item from the previous (by SIM Toolkit) sent item list.
Returns:
TRUE, if the method was successfully initiated.

BOOLEAN SimTkHandler::LaunchBrowser ( SdlByte generalresult )

BOOLEAN SimTkHandler::LaunchBrowser | ( | const SimTkTransactionId & | tid,
 |  | SdlByte | generalresult
 | ) |

The method LaunchBrowser Informs SIM about permission / possibility to start browser. Creates a SI_LAUNCH_BROWSER_PROMPT_IND(gen_result) message.

BOOLEAN SimTkHandler::MenuItemSelected | ( | const SimItemId & | item_id,
 |  | BOOLEAN | help_requested = FALSE
 | ) | const

The method MenuItemSelected(const SimItemId &) is used to select a menu item from a previous (by SIM Toolkit) sent menu. The menu itself is presented by a provider.

Parameters:
item_id | represents the selected menu item from the previous (by SIM Toolkit) sent menu.
help | requested signals, if help n item is requested.
Returns:
TRUE, if the method was successfully initiated.

BOOLEAN SimTkHandler::RegisterBrowser ( SiClientFlags siclientflags )

The method RegisterBrowser Register Browser at SIM to enable the Launch_Browser_Prompt_Request sequence. It is translated into BRSI_REGISTER_REQ(client_flags) message.

BOOLEAN SimTkHandler::RejectCallSetup ( const ProactiveCause & cause = UserDidNotAcceptCallSetupRequest ) const

The method RejectCall() can be executed when SIM Toolkit is waiting for an answer to a previous sent message SimTkCallSetupMsg. With this method the application can reject the call setup request. If the method is executed, while SIM Toolkit is not wating for a response, it has no effects, that means it will not lead to a reject of an existing call! If the user is terminating the sim toolkit session he should give the proactivecause "TerminateByUser" to the method.

Returns:
TRUE, if the call reject was successfully initiated.

BOOLEAN SimTkHandler::RunAtCommandResponse | ( | const SimTkTransactionId & | tid,
 |  | ProactiveCause | proactivecause
 | ) |

The method RunAtCommandResponse response that the AT command request was successful received. Valid causes are SimTkSuccessful or SuccessfulButIconNotDisplayed

BOOLEAN SimTkHandler::SendIdleScreenAvailEvent ( )

The method SendIdleScreenAvailEvent sends the idle screen event to the simtoolkit dependend of retrieved event list.

BOOLEAN SimTkHandler::SendLanguageSelectEvent ( )

The method SendLanguageSelectEvent sends the selected language event to the simtoolkit dependend of retrieved event list. The language 'ExtLanguage' itself is retrieved by the ADC where it has to be set before. Reason for that is because the async language request sent by the simtoolkit reads out the value stored in ADC automatically.

BOOLEAN SimTkHandler::SendSimTkRefreshRsp ( )

The method SendSimTkRefreshRsp sends the SimTkRefreshRspArg back to the stack. The transaction id and cause are stored temporally in SimTkDispatcher. This shall be sent only in case FDN was refreshed.

BOOLEAN SimTkHandler::SendUserActivityEvent ( )

The method SendUserActivityEvent sends the user activity event to the simtoolkit dependend of retrieved event list.

BOOLEAN SimTkHandler::SetActiveExtLanguage ( const WString & language )

The method SetActiveExtLanguage stores the activated language selected by the MMI into ADC. SendLanguageSelectEvent reads out that value and send it back to the SimToolkit when necessary.

BOOLEAN SimTkHandler::SetSimRefreshPossible ( BOOLEAN isrefreshable )

The method SetSimRefreshPossible indicates that the Simtk is allowed or not allowed to refresh the sim.

BOOLEAN SimTkHandler::SetSimResetPossible ( BOOLEAN isresetable )

The method SetSimResetPossible indicates that the Simtk is allowed or not allowed to reset the sim. This is equivalent to a sim-detach / sim-attach procedure.

BOOLEAN SimTkHandler::SetupIdleModeTextDone ( const ProactiveCause & cause ) const

BOOLEAN SimTkHandler::SetupIdleModeTextDone | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | cause
 | ) | const

The method SetupIdleModeTextDone(const ProactiveCause &) is the response for the SIM Toolkit request SetupIdleModeTextReqMsg.

Parameters:
tid,transaction-id | which must be retrieved from the argument contained in SetupIdleModeTextReqMsg.
cause | indicates, if the request was successful processed by the application or not.
Returns:
TRUE, if the method was successfully initiated.

BOOLEAN SimTkHandler::SetupMenuDone ( const ProactiveCause & cause ) const

BOOLEAN SimTkHandler::SetupMenuDone | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | cause
 | ) | const

The method SetupMenuDone(const ProactiveCause &) is the response for the SIM Toolkit request SetupMenuReqMsg.

Parameters:
tid,transaction-id | which must be retrieved from the argument contained in SetupMenuReqMsg.
cause | indicates, if the request was successful processed by the application or not.
Returns:
TRUE, if the method was successfully initiated.

void SimTkHandler::SimTkProfileFactoryReset ( ) const

The method SimTkProfileFactoryReset sends a request to the OM-process to reset the Terminal Profile.

BOOLEAN SimTkHandler::SmsSetupResponse | ( | const ProactiveCause & | cause,
 |  | const SimReferenceNumber & | ref_no
 | ) | const

BOOLEAN SimTkHandler::SsSetupResponse | ( | const ProactiveCause & | cause,
 |  | const SimReferenceNumber & | ref_no
 | ) | const

BOOLEAN SimTkHandler::StopDtmfSending ( )

The method StopDtmfSending() requests to stop the current DTMF sending. Creates a SimTkSendDtmfEndIndMsg message.

BOOLEAN SimTkHandler::TextDisplayed ( const ProactiveCause & cause ) const

BOOLEAN SimTkHandler::TextDisplayed | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | cause
 | ) | const

The method TextDisplayed(const ProactiveCause &) is the response for the SIM Toolkit request SimDisplayTextMsg.

Parameters:
tid,transaction-id | which must be retrieved from the argument contained in SimDisplayTextMsg.
cause | indicates, if the request was successful processed by the application or not.
Returns:
TRUE, if the method was successfully initiated.

BOOLEAN SimTkHandler::TonePlayed ( const ProactiveCause & cause ) const

BOOLEAN SimTkHandler::TonePlayed | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | cause
 | ) | const

The method TonePlayed(const ProactiveCause &) is the response for the SIM Toolkit request PlayToneReqMsg.

Parameters:
tid,transaction-id | which must be retrieved from the argument contained in PlayToneReqMsg.
cause | indicates, if the request was successful processed by the application or not.
Returns:
TRUE, if the method was successfully initiated.

void SimTkHandler::UpdateSimTkProfileReq ( const SimTkProfile & profile_data ) const

The method UpdateSimTkProfileReq sends a request to the OM-process to change the current Terminal Profile. MMI then receives the messages SimTkProfileSetCnfMsg (on success) or SimTkProfileSetRejMsg (no success).

The documentation for this class was generated from the following files:
  • Asc/SimTkHandler.hpp
  • Asc/SimTkHandler.cpp
Generated on Wed Jan 25 01:55:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkInterfaceIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkInterfaceIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkInterfaceIndArg:

[legend]
Collaboration diagram for SimTkInterfaceIndArg:

[legend]

Public Types

enum | { ID = 5300 }

Public Member Functions

const ProcessId & | GetProcessId () const
void | SetProcessId (const ProcessId &process_id)
SimTkInterfaceIndArg ()

Static Public Member Functions

static const SimTkInterfaceIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkInterfaceIndArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkInterfaceIndArg::SimTkInterfaceIndArg ( )

Member Function Documentation

const SimTkInterfaceIndArg & SimTkInterfaceIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProcessId& SimTkInterfaceIndArg::GetProcessId ( ) const [inline]

void SimTkInterfaceIndArg::SetProcessId ( const ProcessId & process_id ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkLanguageNotificationIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkLanguageNotificationIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkLanguageNotificationIndArg:

[legend]
Collaboration diagram for SimTkLanguageNotificationIndArg:

[legend]

Public Types

enum | { ID = 1316 }

Public Member Functions

const ExtLanguage & | GetExtLanguage () const
const SimTkTransactionId & | GetTid () const
void | SetExtLanguage (const ExtLanguage &ext_language)
void | SetTid (const SimTkTransactionId &tid)
SimTkLanguageNotificationIndArg ()

Static Public Member Functions

static const SimTkLanguageNotificationIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkLanguageNotificationIndArg: reflects arguments of signal SI_LANGUAGE_NOTIFCATION_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkLanguageNotificationIndArg::SimTkLanguageNotificationIndArg ( )

Member Function Documentation

const SimTkLanguageNotificationIndArg & SimTkLanguageNotificationIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ExtLanguage& SimTkLanguageNotificationIndArg::GetExtLanguage ( ) const [inline]

const SimTkTransactionId& SimTkLanguageNotificationIndArg::GetTid ( ) const [inline]

void SimTkLanguageNotificationIndArg::SetExtLanguage ( const ExtLanguage & ext_language ) [inline]

void SimTkLanguageNotificationIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkLanguageNotificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkLanguageNotificationMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkLanguageNotificationMsg:

[legend]
Collaboration diagram for SimTkLanguageNotificationMsg:

[legend]

Public Types

enum | { ID = 18324 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetExtLanguage () const
virtual const MsgMetaData & | GetMetaData () const
void | SetExtLanguage (const WString &ext_language)
SimTkLanguageNotificationMsg (ExecutionContext *context, const WString &ext_language)
virtual | ~SimTkLanguageNotificationMsg ()

Detailed Description

SimTkLanguageNotificationMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkLanguageNotificationMsg::SimTkLanguageNotificationMsg | ( | ExecutionContext * | context,
 |  | const WString & | ext_language
 | ) |

SimTkLanguageNotificationMsg::~SimTkLanguageNotificationMsg ( ) [virtual]

Member Function Documentation

Message * SimTkLanguageNotificationMsg::Clone ( ) const [virtual]

Implements Message.

const WString& SimTkLanguageNotificationMsg::GetExtLanguage ( ) const [inline]

const MsgMetaData & SimTkLanguageNotificationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimTkLanguageNotificationMsg::SetExtLanguage ( const WString & ext_language ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:55:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkLceService Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkLceService Class Reference

#include <Apoxi/Asc/SimTkLceService.hpp>

Inheritance diagram for SimTkLceService:

[legend]
Collaboration diagram for SimTkLceService:

[legend]

Public Member Functions

virtual | ~SimTkLceService ()

Static Public Member Functions

static SimTkLceService & | GetInstance ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnPowerDown ()
virtual void | OnPowerUp ()

Constructor & Destructor Documentation

SimTkLceService::~SimTkLceService ( ) [virtual]

Member Function Documentation

SimTkLceService & SimTkLceService::GetInstance ( ) [static]

BOOLEAN SimTkLceService::OnMessage ( const Message & msg ) [protected, virtual]

Reimplemented from ServiceThread.

void SimTkLceService::OnPowerDown ( ) [protected, virtual]

This method is called when stopping a ServiceThread.

Reimplemented from ServiceThread.

void SimTkLceService::OnPowerUp ( ) [protected, virtual]

This method is called when starting a ServiceThread.

Reimplemented from ServiceThread.

The documentation for this class was generated from the following files:
  • Asc/SimTkLceService.hpp
  • Asc/SimTkLceService.cpp
Generated on Wed Jan 25 01:55:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkMainMenuProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkMainMenuProvider Class Reference
[Provider]

#include <Apoxi/Adc/SimTkMainMenuProvider.hpp>

Inheritance diagram for SimTkMainMenuProvider:

[legend]
Collaboration diagram for SimTkMainMenuProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Reset ()
virtual INT | RowCount ()
RowCount returns the number of rows.
void | SetSimTkMainMenu (const SetupMenuReqArg &arg)
SimTkMainMenuProvider ()
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~SimTkMainMenuProvider ()

Detailed Description

SimTkMainMenuProvider is the provider to retrieve the main menu of the sim toolkit. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_simtk_mainmenu_provider_id

Following column ids are defined: c_options_id :NumberType: c_title_id :WStringType: c_title_icon_id :NumberType: c_title_icon_isselfexp_id :NumberType: c_item_string_id :WStringType: c_item_id :NumberType: c_next_action_id :NumberType: c_icon_id :NumberType:

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider SimTkMainMenuProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

SimTkMainMenuProvider::SimTkMainMenuProvider ( )

SimTkMainMenuProvider::~SimTkMainMenuProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SimTkMainMenuProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT SimTkMainMenuProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void SimTkMainMenuProvider::Reset ( )

INT SimTkMainMenuProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

void SimTkMainMenuProvider::SetSimTkMainMenu ( const SetupMenuReqArg & arg )

BOOLEAN SimTkMainMenuProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/SimTkMainMenuProvider.hpp
  • Adc/SimTkMainMenuProvider.cpp
Generated on Wed Jan 25 01:55:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkProfile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkProfile Class Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Public Types

enum Feature {
MenuSelection = (1-1)*8 + (4-1), UCS2EntrySupported = (2-1)*8 + (6-1), UCS2DisplaySupported = (2-1)*8 + (7-1), DisplayExtensionText = (2-1)*8 + (8-1),
BinaryChoiceGetInkey = (8-1)*8 + (4-1), ScreenSizingParameters = (14-1)*8 +(8-1), VariableSizeFontSupport = (15-1)*8 +(8-1), DisplayResizable = (16-1)*8 +(1-1),
TextWrapping = (16-1)*8 +(2-1), TextScrolling = (16-1)*8 +(3-1), WidthReductionInAMenu = (16-1)*8 +(8-1)
}
defined in GSM 11.14 standard chapter 5.2 More...

Public Member Functions

const T_PROFILE & | GetProfile () const
void | SetFeature (Feature no, BOOLEAN set=TRUE)
void | SetNumberOfCharsAcrossDisplay (UINT8 no)
void | SetNumberOfCharsSupportedInDisplay (UINT8 no)
SimTkProfile ()
SimTkProfile (const SimTkProfile &profile)
SimTkProfile (const T_PROFILE &profile)

Member Enumeration Documentation

enum SimTkProfile::Feature

defined in GSM 11.14 standard chapter 5.2

Enumerator:
MenuSelection
UCS2EntrySupported
UCS2DisplaySupported
DisplayExtensionText
BinaryChoiceGetInkey
ScreenSizingParameters
VariableSizeFontSupport
DisplayResizable
TextWrapping
TextScrolling
WidthReductionInAMenu

Constructor & Destructor Documentation

SimTkProfile::SimTkProfile ( const T_PROFILE & profile ) [inline]

SimTkProfile::SimTkProfile ( const SimTkProfile & profile ) [inline]

SimTkProfile::SimTkProfile ( ) [inline]

Member Function Documentation

const T_PROFILE& SimTkProfile::GetProfile ( ) const [inline]

void SimTkProfile::SetFeature | ( | Feature | no,
 |  | BOOLEAN | set = TRUE
 | ) | [inline]

void SimTkProfile::SetNumberOfCharsAcrossDisplay ( UINT8 no ) [inline]

void SimTkProfile::SetNumberOfCharsSupportedInDisplay ( UINT8 no ) [inline]

The documentation for this class was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:55:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkProfileGetCnfMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkProfileGetCnfMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkProfileGetCnfMsg:

[legend]
Collaboration diagram for SimTkProfileGetCnfMsg:

[legend]

Public Types

enum | { ID = 18328 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SimTkProfile & | GetSimTkProfile () const
void | SetSimTkProfile (const SimTkProfile &sim_tk_profile)
SimTkProfileGetCnfMsg (ExecutionContext *context, const SimTkProfile &sim_tk_profile)
virtual | ~SimTkProfileGetCnfMsg ()

Detailed Description

SimTkProfileGetCnfMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkProfileGetCnfMsg::SimTkProfileGetCnfMsg | ( | ExecutionContext * | context,
 |  | const SimTkProfile & | sim_tk_profile
 | ) |

SimTkProfileGetCnfMsg::~SimTkProfileGetCnfMsg ( ) [virtual]

Member Function Documentation

Message * SimTkProfileGetCnfMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimTkProfileGetCnfMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const SimTkProfile& SimTkProfileGetCnfMsg::GetSimTkProfile ( ) const [inline]

void SimTkProfileGetCnfMsg::SetSimTkProfile ( const SimTkProfile & sim_tk_profile ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:55:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkProfileSetCnfMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkProfileSetCnfMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkProfileSetCnfMsg:

[legend]
Collaboration diagram for SimTkProfileSetCnfMsg:

[legend]

Public Types

enum | { ID = 18329 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SimTkProfileSetCnfMsg (ExecutionContext *context)
virtual | ~SimTkProfileSetCnfMsg ()

Detailed Description

SimTkProfileSetCnfMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkProfileSetCnfMsg::SimTkProfileSetCnfMsg ( ExecutionContext * context )

SimTkProfileSetCnfMsg::~SimTkProfileSetCnfMsg ( ) [virtual]

Member Function Documentation

Message * SimTkProfileSetCnfMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimTkProfileSetCnfMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:55:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkProfileSetRejMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkProfileSetRejMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkProfileSetRejMsg:

[legend]
Collaboration diagram for SimTkProfileSetRejMsg:

[legend]

Public Types

enum | { ID = 18330 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SimTkProfileSetRejMsg (ExecutionContext *context)
virtual | ~SimTkProfileSetRejMsg ()

Detailed Description

SimTkProfileSetRejMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkProfileSetRejMsg::SimTkProfileSetRejMsg ( ExecutionContext * context )

SimTkProfileSetRejMsg::~SimTkProfileSetRejMsg ( ) [virtual]

Member Function Documentation

Message * SimTkProfileSetRejMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimTkProfileSetRejMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:55:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshCnfIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshCnfIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshCnfIndArg:

[legend]
Collaboration diagram for SimTkRefreshCnfIndArg:

[legend]

Public Types

enum | { ID = 2322 }

Public Member Functions

const SimTkTransactionId & | GetTid () const
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshCnfIndArg ()
SimTkRefreshCnfIndArg (const SimTkTransactionId &tid)

Static Public Member Functions

static const SimTkRefreshCnfIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshCnfIndArg: reflects arguments of signal SI_SAT_REFRESH_CONFIRM_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshCnfIndArg::SimTkRefreshCnfIndArg ( const SimTkTransactionId & tid )

SimTkRefreshCnfIndArg::SimTkRefreshCnfIndArg ( )

Member Function Documentation

const SimTkRefreshCnfIndArg & SimTkRefreshCnfIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkTransactionId& SimTkRefreshCnfIndArg::GetTid ( ) const [inline]

void SimTkRefreshCnfIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshCnfReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshCnfReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshCnfReqArg:

[legend]
Collaboration diagram for SimTkRefreshCnfReqArg:

[legend]

Public Types

enum | { ID = 1323 }

Public Member Functions

const SimTkTransactionId & | GetTid () const
BOOLEAN | IsRefreshPossible () const
void | SetRefreshPossible (BOOLEAN refresh_possible)
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshCnfReqArg ()

Static Public Member Functions

static const SimTkRefreshCnfReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshCnfReqArg: reflects arguments of signal SI_SAT_REFRESH_CONFIRM_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshCnfReqArg::SimTkRefreshCnfReqArg ( )

Member Function Documentation

const SimTkRefreshCnfReqArg & SimTkRefreshCnfReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkTransactionId& SimTkRefreshCnfReqArg::GetTid ( ) const [inline]

BOOLEAN SimTkRefreshCnfReqArg::IsRefreshPossible ( ) const [inline]

void SimTkRefreshCnfReqArg::SetRefreshPossible ( BOOLEAN refresh_possible ) [inline]

void SimTkRefreshCnfReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshNewReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshNewReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshNewReqArg:

[legend]
Collaboration diagram for SimTkRefreshNewReqArg:

[legend]

Public Types

enum | { ID = 5305 }

Public Member Functions

const SimEfRefresh & | GetEfRefresh () const
const SimTkTransactionId & | GetTid () const
void | SetEfRefresh (const SimEfRefresh &ef_refresh)
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshNewReqArg ()

Static Public Member Functions

static const SimTkRefreshNewReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshNewReqArg: reflects arguments of signal SI_SAT_REFRESH_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshNewReqArg::SimTkRefreshNewReqArg ( )

Member Function Documentation

const SimTkRefreshNewReqArg & SimTkRefreshNewReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimEfRefresh& SimTkRefreshNewReqArg::GetEfRefresh ( ) const [inline]

const SimTkTransactionId& SimTkRefreshNewReqArg::GetTid ( ) const [inline]

void SimTkRefreshNewReqArg::SetEfRefresh ( const SimEfRefresh & ef_refresh ) [inline]

void SimTkRefreshNewReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshNewRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshNewRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshNewRspArg:

[legend]
Collaboration diagram for SimTkRefreshNewRspArg:

[legend]

Public Types

enum | { ID = 2383 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshNewRspArg ()
SimTkRefreshNewRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)

Static Public Member Functions

static const SimTkRefreshNewRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshNewRspArg: reflects arguments of signal SI_SAT_REFRESH_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshNewRspArg::SimTkRefreshNewRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

SimTkRefreshNewRspArg::SimTkRefreshNewRspArg ( )

Member Function Documentation

const SimTkRefreshNewRspArg & SimTkRefreshNewRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkRefreshNewRspArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& SimTkRefreshNewRspArg::GetTid ( ) const [inline]

void SimTkRefreshNewRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SimTkRefreshNewRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshQueryReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshQueryReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshQueryReqArg:

[legend]
Collaboration diagram for SimTkRefreshQueryReqArg:

[legend]

Public Types

enum | { ID = 1322 }

Public Member Functions

const SimEfRefresh & | GetEfRefresh () const
UINT8 | GetRefreshIndicator () const
const SimTkTransactionId & | GetTid () const
void | SetEfRefresh (const SimEfRefresh &ef_refresh)
void | SetRefreshIndicator (UINT8 refresh_indicator)
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshQueryReqArg ()

Static Public Member Functions

static const SimTkRefreshQueryReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshQueryReqArg: reflects arguments of signal SI_SAT_REFRESH_QUERY_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshQueryReqArg::SimTkRefreshQueryReqArg ( )

Member Function Documentation

const SimTkRefreshQueryReqArg & SimTkRefreshQueryReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimEfRefresh& SimTkRefreshQueryReqArg::GetEfRefresh ( ) const [inline]

UINT8 SimTkRefreshQueryReqArg::GetRefreshIndicator ( ) const [inline]

const SimTkTransactionId& SimTkRefreshQueryReqArg::GetTid ( ) const [inline]

void SimTkRefreshQueryReqArg::SetEfRefresh ( const SimEfRefresh & ef_refresh ) [inline]

void SimTkRefreshQueryReqArg::SetRefreshIndicator ( UINT8 refresh_indicator ) [inline]

void SimTkRefreshQueryReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshQueryResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshQueryResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshQueryResArg:

[legend]
Collaboration diagram for SimTkRefreshQueryResArg:

[legend]

Public Types

enum | { ID = 2321 }

Public Member Functions

UINT8 | GetAdditionalResult () const
UINT8 | GetGeneralResult () const
const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
void | SetAdditionalResult (UINT8 additional_result)
void | SetGeneralResult (UINT8 general_result)
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshQueryResArg ()
SimTkRefreshQueryResArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause, UINT8 general_result, UINT8 additional_result)

Static Public Member Functions

static const SimTkRefreshQueryResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshQueryResArg: reflects arguments of signal SI_SAT_REFRESH_QUERY_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshQueryResArg::SimTkRefreshQueryResArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause,
 |  | UINT8 | general_result,
 |  | UINT8 | additional_result
 | ) |

SimTkRefreshQueryResArg::SimTkRefreshQueryResArg ( )

Member Function Documentation

const SimTkRefreshQueryResArg & SimTkRefreshQueryResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8 SimTkRefreshQueryResArg::GetAdditionalResult ( ) const [inline]

UINT8 SimTkRefreshQueryResArg::GetGeneralResult ( ) const [inline]

const ProactiveCause& SimTkRefreshQueryResArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& SimTkRefreshQueryResArg::GetTid ( ) const [inline]

void SimTkRefreshQueryResArg::SetAdditionalResult ( UINT8 additional_result ) [inline]

void SimTkRefreshQueryResArg::SetGeneralResult ( UINT8 general_result ) [inline]

void SimTkRefreshQueryResArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SimTkRefreshQueryResArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshReqArg:

[legend]
Collaboration diagram for SimTkRefreshReqArg:

[legend]

Public Types

enum | { ID = 1303 }

Public Member Functions

const SimEfRefresh & | GetEfRefresh () const
const SimTkTransactionId & | GetTid () const
void | SetEfRefresh (const SimEfRefresh &ef_refresh)
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshReqArg ()

Static Public Member Functions

static const SimTkRefreshReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshReqArg: reflects arguments of signal SIMI_SIMTOOLKIT_REFRESH_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshReqArg::SimTkRefreshReqArg ( )

Member Function Documentation

const SimTkRefreshReqArg & SimTkRefreshReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimEfRefresh& SimTkRefreshReqArg::GetEfRefresh ( ) const [inline]

const SimTkTransactionId& SimTkRefreshReqArg::GetTid ( ) const [inline]

void SimTkRefreshReqArg::SetEfRefresh ( const SimEfRefresh & ef_refresh ) [inline]

void SimTkRefreshReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshResetReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshResetReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshResetReqArg:

[legend]
Collaboration diagram for SimTkRefreshResetReqArg:

[legend]

Public Types

enum | { ID = 1304 }

Public Member Functions

const SimTkTransactionId & | GetTid () const
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshResetReqArg ()

Static Public Member Functions

static const SimTkRefreshResetReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshResetReqArg: reflects arguments of signal SIMI_SIMTK_REFRESH_RST_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshResetReqArg::SimTkRefreshResetReqArg ( )

Member Function Documentation

const SimTkRefreshResetReqArg & SimTkRefreshResetReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkTransactionId& SimTkRefreshResetReqArg::GetTid ( ) const [inline]

void SimTkRefreshResetReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshResetRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshResetRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshResetRspArg:

[legend]
Collaboration diagram for SimTkRefreshResetRspArg:

[legend]

Public Types

enum | { ID = 2305 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshResetRspArg ()
SimTkRefreshResetRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)

Static Public Member Functions

static const SimTkRefreshResetRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshResetRspArg: reflects arguments of signal MISI_SIMTK_REFRESH_RST_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshResetRspArg::SimTkRefreshResetRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

SimTkRefreshResetRspArg::SimTkRefreshResetRspArg ( )

Member Function Documentation

const SimTkRefreshResetRspArg & SimTkRefreshResetRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkRefreshResetRspArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& SimTkRefreshResetRspArg::GetTid ( ) const [inline]

void SimTkRefreshResetRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SimTkRefreshResetRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRefreshRspArg:

[legend]
Collaboration diagram for SimTkRefreshRspArg:

[legend]

Public Types

enum | { ID = 2304 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)
SimTkRefreshRspArg ()
SimTkRefreshRspArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)

Static Public Member Functions

static const SimTkRefreshRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRefreshRspArg: reflects arguments of signal MISI_SIMTOOLKIT_REFRESH_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshRspArg::SimTkRefreshRspArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

SimTkRefreshRspArg::SimTkRefreshRspArg ( )

Member Function Documentation

const SimTkRefreshRspArg & SimTkRefreshRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkRefreshRspArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& SimTkRefreshRspArg::GetTid ( ) const [inline]

void SimTkRefreshRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SimTkRefreshRspArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRefreshStartMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRefreshStartMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkRefreshStartMsg:

[legend]
Collaboration diagram for SimTkRefreshStartMsg:

[legend]

Public Types

enum | { ID = 18327 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SimTkRefreshStartMsg (ExecutionContext *context)
virtual | ~SimTkRefreshStartMsg ()

Detailed Description

SimTkRefreshStartMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRefreshStartMsg::SimTkRefreshStartMsg ( ExecutionContext * context )

SimTkRefreshStartMsg::~SimTkRefreshStartMsg ( ) [virtual]

Member Function Documentation

Message * SimTkRefreshStartMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimTkRefreshStartMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:55:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkResetCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkResetCnfArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkResetCnfArg:

[legend]
Collaboration diagram for SimTkResetCnfArg:

[legend]

Public Types

enum | { ID = 1306 }

Public Member Functions

SimTkResetCnfArg ()

Static Public Member Functions

static const SimTkResetCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkResetCnfArg: reflects arguments of signal SIMI_SIMTK_RESET_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkResetCnfArg::SimTkResetCnfArg ( )

Member Function Documentation

const SimTkResetCnfArg & SimTkResetCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:55:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkResetCnfIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkResetCnfIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkResetCnfIndArg:

[legend]
Collaboration diagram for SimTkResetCnfIndArg:

[legend]

Public Types

enum | { ID = 2306 }

Public Member Functions

const SimTkTransactionId & | GetTid () const
void | SetTid (const SimTkTransactionId &tid)
SimTkResetCnfIndArg ()
SimTkResetCnfIndArg (const SimTkTransactionId &tid)

Static Public Member Functions

static const SimTkResetCnfIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkResetCnfIndArg: reflects arguments of signal MISI_SIMTK_RST_CONFIRM_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkResetCnfIndArg::SimTkResetCnfIndArg ( const SimTkTransactionId & tid )

SimTkResetCnfIndArg::SimTkResetCnfIndArg ( )

Member Function Documentation

const SimTkResetCnfIndArg & SimTkResetCnfIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkTransactionId& SimTkResetCnfIndArg::GetTid ( ) const [inline]

void SimTkResetCnfIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkResetCnfReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkResetCnfReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkResetCnfReqArg:

[legend]
Collaboration diagram for SimTkResetCnfReqArg:

[legend]

Public Types

enum | { ID = 1305 }

Public Member Functions

const SimTkTransactionId & | GetTid () const
BOOLEAN | IsRefreshPossible () const
void | SetRefreshPossible (BOOLEAN refresh_possible)
void | SetTid (const SimTkTransactionId &tid)
SimTkResetCnfReqArg ()

Static Public Member Functions

static const SimTkResetCnfReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkResetCnfReqArg: reflects arguments of signal SIMI_SIMTK_RST_CONFIRM_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkResetCnfReqArg::SimTkResetCnfReqArg ( )

Member Function Documentation

const SimTkResetCnfReqArg & SimTkResetCnfReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimTkTransactionId& SimTkResetCnfReqArg::GetTid ( ) const [inline]

BOOLEAN SimTkResetCnfReqArg::IsRefreshPossible ( ) const [inline]

void SimTkResetCnfReqArg::SetRefreshPossible ( BOOLEAN refresh_possible ) [inline]

void SimTkResetCnfReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRunAtCmdInfoIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRunAtCmdInfoIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRunAtCmdInfoIndArg:

[legend]
Collaboration diagram for SimTkRunAtCmdInfoIndArg:

[legend]

Public Types

enum | { ID = 1340 }

Public Member Functions

const SimIconIdentifier & | GetIcon () const
const SimAlphaIdentifier & | GetTextString () const
const SimTkTransactionId & | GetTid () const
void | SetIcon (const SimIconIdentifier &icon)
void | SetTextString (const SimAlphaIdentifier &text_string)
void | SetTid (const SimTkTransactionId &tid)
SimTkRunAtCmdInfoIndArg ()

Static Public Member Functions

static const SimTkRunAtCmdInfoIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRunAtCmdInfoIndArg: reflects arguments of signal SI_RUN_AT_CMD_INFO_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRunAtCmdInfoIndArg::SimTkRunAtCmdInfoIndArg ( )

Member Function Documentation

const SimTkRunAtCmdInfoIndArg & SimTkRunAtCmdInfoIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconIdentifier& SimTkRunAtCmdInfoIndArg::GetIcon ( ) const [inline]

const SimAlphaIdentifier& SimTkRunAtCmdInfoIndArg::GetTextString ( ) const [inline]

const SimTkTransactionId& SimTkRunAtCmdInfoIndArg::GetTid ( ) const [inline]

void SimTkRunAtCmdInfoIndArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void SimTkRunAtCmdInfoIndArg::SetTextString ( const SimAlphaIdentifier & text_string ) [inline]

void SimTkRunAtCmdInfoIndArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRunAtCmdInfoIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRunAtCmdInfoIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkRunAtCmdInfoIndMsg:

[legend]
Collaboration diagram for SimTkRunAtCmdInfoIndMsg:

[legend]

Public Types

enum | { ID = 18345 }

Public Member Functions

virtual Message * | Clone () const
const SimTkRunAtCmdInfoIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimTkRunAtCmdInfoIndArg &arg)
SimTkRunAtCmdInfoIndMsg (ExecutionContext *context, const SimTkRunAtCmdInfoIndArg &arg)
virtual | ~SimTkRunAtCmdInfoIndMsg ()

Detailed Description

SimTkRunAtCmdInfoIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRunAtCmdInfoIndMsg::SimTkRunAtCmdInfoIndMsg | ( | ExecutionContext * | context,
 |  | const SimTkRunAtCmdInfoIndArg & | arg
 | ) |

SimTkRunAtCmdInfoIndMsg::~SimTkRunAtCmdInfoIndMsg ( ) [virtual]

Member Function Documentation

Message * SimTkRunAtCmdInfoIndMsg::Clone ( ) const [virtual]

Implements Message.

const SimTkRunAtCmdInfoIndArg& SimTkRunAtCmdInfoIndMsg::GetArg ( ) const [inline]

const MsgMetaData & SimTkRunAtCmdInfoIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimTkRunAtCmdInfoIndMsg::SetArg ( const SimTkRunAtCmdInfoIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:56:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkRunAtCmdInfoResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkRunAtCmdInfoResArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkRunAtCmdInfoResArg:

[legend]
Collaboration diagram for SimTkRunAtCmdInfoResArg:

[legend]

Public Types

enum | { ID = 2380 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimTkTransactionId & | GetTid () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetTid (const SimTkTransactionId &tid)
SimTkRunAtCmdInfoResArg ()
SimTkRunAtCmdInfoResArg (const SimTkTransactionId &tid, const ProactiveCause &proactive_cause)

Static Public Member Functions

static const SimTkRunAtCmdInfoResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkRunAtCmdInfoResArg: reflects arguments of signal SI_RUN_AT_CMD_INFO_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkRunAtCmdInfoResArg::SimTkRunAtCmdInfoResArg | ( | const SimTkTransactionId & | tid,
 |  | const ProactiveCause & | proactive_cause
 | ) |

SimTkRunAtCmdInfoResArg::SimTkRunAtCmdInfoResArg ( )

Member Function Documentation

const SimTkRunAtCmdInfoResArg & SimTkRunAtCmdInfoResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkRunAtCmdInfoResArg::GetProactiveCause ( ) const [inline]

const SimTkTransactionId& SimTkRunAtCmdInfoResArg::GetTid ( ) const [inline]

void SimTkRunAtCmdInfoResArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SimTkRunAtCmdInfoResArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSendDtmfCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSendDtmfCnfArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkSendDtmfCnfArg:

[legend]
Collaboration diagram for SimTkSendDtmfCnfArg:

[legend]

Public Types

enum | { ID = 2381 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
SimTkSendDtmfCnfArg ()
SimTkSendDtmfCnfArg (const ProactiveCause &proactive_cause)

Static Public Member Functions

static const SimTkSendDtmfCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkSendDtmfCnfArg: reflects arguments of signal MN_SIM_SEND_DTMF_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSendDtmfCnfArg::SimTkSendDtmfCnfArg ( const ProactiveCause & proactive_cause )

SimTkSendDtmfCnfArg::SimTkSendDtmfCnfArg ( )

Member Function Documentation

const SimTkSendDtmfCnfArg & SimTkSendDtmfCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkSendDtmfCnfArg::GetProactiveCause ( ) const [inline]

void SimTkSendDtmfCnfArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSendDtmfEndIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSendDtmfEndIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkSendDtmfEndIndArg:

[legend]
Collaboration diagram for SimTkSendDtmfEndIndArg:

[legend]

Public Types

enum | { ID = 1342 }

Public Member Functions

const CallErrorCause & | GetCause () const
void | SetCause (const CallErrorCause &cause)
SimTkSendDtmfEndIndArg ()

Static Public Member Functions

static const SimTkSendDtmfEndIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkSendDtmfEndIndArg: reflects arguments of signal MN_SIM_SEND_DTMF_END_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSendDtmfEndIndArg::SimTkSendDtmfEndIndArg ( )

Member Function Documentation

const SimTkSendDtmfEndIndArg & SimTkSendDtmfEndIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& SimTkSendDtmfEndIndArg::GetCause ( ) const [inline]

void SimTkSendDtmfEndIndArg::SetCause ( const CallErrorCause & cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSendDtmfEndIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSendDtmfEndIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkSendDtmfEndIndMsg:

[legend]
Collaboration diagram for SimTkSendDtmfEndIndMsg:

[legend]

Public Types

enum | { ID = 18347 }

Public Member Functions

virtual Message * | Clone () const
const SimTkSendDtmfEndIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimTkSendDtmfEndIndArg &arg)
SimTkSendDtmfEndIndMsg (ExecutionContext *context, const SimTkSendDtmfEndIndArg &arg)
virtual | ~SimTkSendDtmfEndIndMsg ()

Detailed Description

SimTkSendDtmfEndIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSendDtmfEndIndMsg::SimTkSendDtmfEndIndMsg | ( | ExecutionContext * | context,
 |  | const SimTkSendDtmfEndIndArg & | arg
 | ) |

SimTkSendDtmfEndIndMsg::~SimTkSendDtmfEndIndMsg ( ) [virtual]

Member Function Documentation

Message * SimTkSendDtmfEndIndMsg::Clone ( ) const [virtual]

Implements Message.

const SimTkSendDtmfEndIndArg& SimTkSendDtmfEndIndMsg::GetArg ( ) const [inline]

const MsgMetaData & SimTkSendDtmfEndIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimTkSendDtmfEndIndMsg::SetArg ( const SimTkSendDtmfEndIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:56:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSendDtmfIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSendDtmfIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkSendDtmfIndArg:

[legend]
Collaboration diagram for SimTkSendDtmfIndArg:

[legend]

Public Types

enum | { ID = 1341 }

Public Member Functions

const SimIconIdentifier & | GetIcon () const
const SimAlphaIdentifier & | GetTextString () const
void | SetIcon (const SimIconIdentifier &icon)
void | SetTextString (const SimAlphaIdentifier &text_string)
SimTkSendDtmfIndArg ()

Static Public Member Functions

static const SimTkSendDtmfIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkSendDtmfIndArg: reflects arguments of signal MN_SIM_SEND_DTMF_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSendDtmfIndArg::SimTkSendDtmfIndArg ( )

Member Function Documentation

const SimTkSendDtmfIndArg & SimTkSendDtmfIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimIconIdentifier& SimTkSendDtmfIndArg::GetIcon ( ) const [inline]

const SimAlphaIdentifier& SimTkSendDtmfIndArg::GetTextString ( ) const [inline]

void SimTkSendDtmfIndArg::SetIcon ( const SimIconIdentifier & icon ) [inline]

void SimTkSendDtmfIndArg::SetTextString ( const SimAlphaIdentifier & text_string ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSendDtmfIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSendDtmfIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkSendDtmfIndMsg:

[legend]
Collaboration diagram for SimTkSendDtmfIndMsg:

[legend]

Public Types

enum | { ID = 18346 }

Public Member Functions

virtual Message * | Clone () const
const SimTkSendDtmfIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SimTkSendDtmfIndArg &arg)
SimTkSendDtmfIndMsg (ExecutionContext *context, const SimTkSendDtmfIndArg &arg)
virtual | ~SimTkSendDtmfIndMsg ()

Detailed Description

SimTkSendDtmfIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSendDtmfIndMsg::SimTkSendDtmfIndMsg | ( | ExecutionContext * | context,
 |  | const SimTkSendDtmfIndArg & | arg
 | ) |

SimTkSendDtmfIndMsg::~SimTkSendDtmfIndMsg ( ) [virtual]

Member Function Documentation

Message * SimTkSendDtmfIndMsg::Clone ( ) const [virtual]

Implements Message.

const SimTkSendDtmfIndArg& SimTkSendDtmfIndMsg::GetArg ( ) const [inline]

const MsgMetaData & SimTkSendDtmfIndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SimTkSendDtmfIndMsg::SetArg ( const SimTkSendDtmfIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:56:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSetupEventMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSetupEventMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SimTkSetupEventMsg:

[legend]
Collaboration diagram for SimTkSetupEventMsg:

[legend]

Public Types

enum | { ID = 18325 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SimTkSetupEventMsg (ExecutionContext *context)
virtual | ~SimTkSetupEventMsg ()

Detailed Description

SimTkSetupEventMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSetupEventMsg::SimTkSetupEventMsg ( ExecutionContext * context )

SimTkSetupEventMsg::~SimTkSetupEventMsg ( ) [virtual]

Member Function Documentation

Message * SimTkSetupEventMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SimTkSetupEventMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:56:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSetupEventReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSetupEventReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkSetupEventReqArg:

[legend]
Collaboration diagram for SimTkSetupEventReqArg:

[legend]

Public Types

enum | { ID = 1317 }

Public Member Functions

const SimEventList & | GetEventList () const
const SimTkTransactionId & | GetTid () const
void | SetEventList (const SimEventList &event_list)
void | SetTid (const SimTkTransactionId &tid)
SimTkSetupEventReqArg ()

Static Public Member Functions

static const SimTkSetupEventReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkSetupEventReqArg: reflects arguments of signal SIMI_SET_UP_EVENT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSetupEventReqArg::SimTkSetupEventReqArg ( )

Member Function Documentation

const SimTkSetupEventReqArg & SimTkSetupEventReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimEventList& SimTkSetupEventReqArg::GetEventList ( ) const [inline]

const SimTkTransactionId& SimTkSetupEventReqArg::GetTid ( ) const [inline]

void SimTkSetupEventReqArg::SetEventList ( const SimEventList & event_list ) [inline]

void SimTkSetupEventReqArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSmsPpIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSmsPpIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkSmsPpIndArg:

[legend]
Collaboration diagram for SimTkSmsPpIndArg:

[legend]

Public Types

enum | { ID = 1301 }

Public Member Functions

const SimReferenceNumber & | GetReferenceNumber () const
const SimAlphaIdentifier & | GetSmsInfoAlpha () const
const SimIconIdentifier & | GetSmsInfoIcon () const
void | SetReferenceNumber (const SimReferenceNumber &reference_number)
void | SetSmsInfoAlpha (const SimAlphaIdentifier &sms_info_alpha)
void | SetSmsInfoIcon (const SimIconIdentifier &sms_info_icon)
SimTkSmsPpIndArg ()

Static Public Member Functions

static const SimTkSmsPpIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkSmsPpIndArg: reflects arguments of signal MN_SIMTK_SMS_PP_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSmsPpIndArg::SimTkSmsPpIndArg ( )

Member Function Documentation

const SimTkSmsPpIndArg & SimTkSmsPpIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimReferenceNumber& SimTkSmsPpIndArg::GetReferenceNumber ( ) const [inline]

const SimAlphaIdentifier& SimTkSmsPpIndArg::GetSmsInfoAlpha ( ) const [inline]

const SimIconIdentifier& SimTkSmsPpIndArg::GetSmsInfoIcon ( ) const [inline]

void SimTkSmsPpIndArg::SetReferenceNumber ( const SimReferenceNumber & reference_number ) [inline]

void SimTkSmsPpIndArg::SetSmsInfoAlpha ( const SimAlphaIdentifier & sms_info_alpha ) [inline]

void SimTkSmsPpIndArg::SetSmsInfoIcon ( const SimIconIdentifier & sms_info_icon ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSmsPpRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSmsPpRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkSmsPpRspArg:

[legend]
Collaboration diagram for SimTkSmsPpRspArg:

[legend]

Public Types

enum | { ID = 2300 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimReferenceNumber & | GetReferenceNumber () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetReferenceNumber (const SimReferenceNumber &reference_number)
SimTkSmsPpRspArg ()
SimTkSmsPpRspArg (const ProactiveCause &proactive_cause, const SimReferenceNumber &reference_number)

Static Public Member Functions

static const SimTkSmsPpRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkSmsPpRspArg: reflects arguments of signal MN_SIMTK_SS_RSP

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSmsPpRspArg::SimTkSmsPpRspArg | ( | const ProactiveCause & | proactive_cause,
 |  | const SimReferenceNumber & | reference_number
 | ) |

SimTkSmsPpRspArg::SimTkSmsPpRspArg ( )

Member Function Documentation

const SimTkSmsPpRspArg & SimTkSmsPpRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkSmsPpRspArg::GetProactiveCause ( ) const [inline]

const SimReferenceNumber& SimTkSmsPpRspArg::GetReferenceNumber ( ) const [inline]

void SimTkSmsPpRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SimTkSmsPpRspArg::SetReferenceNumber ( const SimReferenceNumber & reference_number ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSsIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSsIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkSsIndArg:

[legend]
Collaboration diagram for SimTkSsIndArg:

[legend]

Public Types

enum | { ID = 1302 }

Public Member Functions

const SimReferenceNumber & | GetReferenceNumber () const
const SimSsType & | GetSimServiceType () const
const SimAlphaIdentifier & | GetSsInfoAlpha () const
const SimIconIdentifier & | GetSsInfoIcon () const
const Tipd & | GetTipd () const
const WString & | GetUserInput () const
const DataCodingScheme::Language & | GetUserInputLanguage () const
void | SetReferenceNumber (const SimReferenceNumber &reference_number)
void | SetSimServiceType (const SimSsType &sim_service_type)
void | SetSsInfoAlpha (const SimAlphaIdentifier &ss_info_alpha)
void | SetSsInfoIcon (const SimIconIdentifier &ss_info_icon)
void | SetTipd (const Tipd &tipd)
void | SetUserInput (const WString &user_input)
void | SetUserInputLanguage (const DataCodingScheme::Language &user_input_language)
SimTkSsIndArg ()

Static Public Member Functions

static const SimTkSsIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkSsIndArg: reflects arguments of signal MN_SIMTK_SS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSsIndArg::SimTkSsIndArg ( )

Member Function Documentation

const SimTkSsIndArg & SimTkSsIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimReferenceNumber& SimTkSsIndArg::GetReferenceNumber ( ) const [inline]

const SimSsType& SimTkSsIndArg::GetSimServiceType ( ) const [inline]

const SimAlphaIdentifier& SimTkSsIndArg::GetSsInfoAlpha ( ) const [inline]

const SimIconIdentifier& SimTkSsIndArg::GetSsInfoIcon ( ) const [inline]

const Tipd& SimTkSsIndArg::GetTipd ( ) const [inline]

const WString& SimTkSsIndArg::GetUserInput ( ) const [inline]

const DataCodingScheme::Language& SimTkSsIndArg::GetUserInputLanguage ( ) const [inline]

void SimTkSsIndArg::SetReferenceNumber ( const SimReferenceNumber & reference_number ) [inline]

void SimTkSsIndArg::SetSimServiceType ( const SimSsType & sim_service_type ) [inline]

void SimTkSsIndArg::SetSsInfoAlpha ( const SimAlphaIdentifier & ss_info_alpha ) [inline]

void SimTkSsIndArg::SetSsInfoIcon ( const SimIconIdentifier & ss_info_icon ) [inline]

void SimTkSsIndArg::SetTipd ( const Tipd & tipd ) [inline]

void SimTkSsIndArg::SetUserInput ( const WString & user_input ) [inline]

void SimTkSsIndArg::SetUserInputLanguage ( const DataCodingScheme::Language & user_input_language ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkSsRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkSsRspArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkSsRspArg:

[legend]
Collaboration diagram for SimTkSsRspArg:

[legend]

Public Types

enum | { ID = 2301 }

Public Member Functions

const ProactiveCause & | GetProactiveCause () const
const SimReferenceNumber & | GetReferenceNumber () const
void | SetProactiveCause (const ProactiveCause &proactive_cause)
void | SetReferenceNumber (const SimReferenceNumber &reference_number)
SimTkSsRspArg ()
SimTkSsRspArg (const ProactiveCause &proactive_cause, const SimReferenceNumber &reference_number)

Static Public Member Functions

static const SimTkSsRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkSsRspArg: reflects arguments of signal MN_SIMTK_SS_RSP

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkSsRspArg::SimTkSsRspArg | ( | const ProactiveCause & | proactive_cause,
 |  | const SimReferenceNumber & | reference_number
 | ) |

SimTkSsRspArg::SimTkSsRspArg ( )

Member Function Documentation

const SimTkSsRspArg & SimTkSsRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ProactiveCause& SimTkSsRspArg::GetProactiveCause ( ) const [inline]

const SimReferenceNumber& SimTkSsRspArg::GetReferenceNumber ( ) const [inline]

void SimTkSsRspArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

void SimTkSsRspArg::SetReferenceNumber ( const SimReferenceNumber & reference_number ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkStopSendDtmfReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkStopSendDtmfReqArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SimTkStopSendDtmfReqArg:

[legend]
Collaboration diagram for SimTkStopSendDtmfReqArg:

[legend]

Public Types

enum | { ID = 2382 }

Public Member Functions

SimTkStopSendDtmfReqArg ()

Static Public Member Functions

static const SimTkStopSendDtmfReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SimTkStopSendDtmfReqArg: reflects arguments of signal MN_STOP_SIM_SEND_DTMF_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SimTkStopSendDtmfReqArg::SimTkStopSendDtmfReqArg ( )

Member Function Documentation

const SimTkStopSendDtmfReqArg & SimTkStopSendDtmfReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:56:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimTkTransactionId Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimTkTransactionId Class Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SimTkTransactionId:

[legend]

Public Member Functions

const T_STK_TRANSACTION_ID & GetId () const
SimTkTransactionId (const T_STK_TRANSACTION_ID &id)
SimTkTransactionId ()

Constructor & Destructor Documentation

SimTkTransactionId::SimTkTransactionId ( ) [inline]

SimTkTransactionId::SimTkTransactionId ( const T_STK_TRANSACTION_ID & id ) [inline]

Member Function Documentation

const T_STK_TRANSACTION_ID& SimTkTransactionId::GetId ( ) const [inline]

The documentation for this class was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:56:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SimUserDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SimUserDispatcher Class Reference
[ADC]

#include <Apoxi/Adc/SimAccessor.hpp>

Inheritance diagram for SimUserDispatcher:

[legend]
Collaboration diagram for SimUserDispatcher:

[legend]

Public Member Functions

SimUserDispatcher (SimAccessor *accessor)
virtual | ~SimUserDispatcher ()

Static Public Member Functions

static BOOLEAN | HasParam (StackMsgArgument *arg, UINT32 param)
static BOOLEAN | HasParamAttribute (StackMsgArgId id)

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)

Constructor & Destructor Documentation

SimUserDispatcher::SimUserDispatcher ( SimAccessor * accessor )

SimUserDispatcher::~SimUserDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN SimUserDispatcher::HasParam | ( | StackMsgArgument * | arg,
 |  | UINT32 | param
 | ) | [static]

BOOLEAN SimUserDispatcher::HasParamAttribute ( StackMsgArgId id ) [static]

BOOLEAN SimUserDispatcher::OnMessage ( const Message & msg ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

The documentation for this class was generated from the following files:
  • Adc/SimAccessor.hpp
  • Adc/SimAccessor.cpp
Generated on Wed Jan 25 01:56:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SingleArgHook< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SingleArgHook< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/SingleArgHook.hpp>

Public Types

typedef void(* | HookFn )(T)

Public Member Functions

BOOLEAN | Add (HookFn fn)
void | Call (T t)
BOOLEAN | Remove (HookFn fn)
SingleArgHook ()
virtual | ~SingleArgHook ()

Detailed Description

template<class T>
class SingleArgHook< T >

Generic concept to allow a simple fn mechanism in APOXI. To define a new point where other modules can hook to, an object SingleArgHook<class T> has to be instantiated. At the place where the hook should be available, the method Call has to be called. This causes the callback function added via Add method to be called. To remove the hook function, method Remove has to be called.

Note: At the moment only one hook function can be added per hooking point!

Member Typedef Documentation

template<class T>
typedef void(* SingleArgHook< T >::HookFn)(T)

Constructor & Destructor Documentation

template<class T>
SingleArgHook< T >::SingleArgHook ( ) [inline]

template<class T>
virtual SingleArgHook< T >::~SingleArgHook ( ) [inline, virtual]

Member Function Documentation

template<class T>
BOOLEAN SingleArgHook< T >::Add ( HookFn fn ) [inline]

Adds the callback function 'fn' to the predefined hook.

template<class T>
void SingleArgHook< T >::Call ( T t ) [inline]

To be called only at this place where the hook callback functions should be called.

template<class T>
BOOLEAN SingleArgHook< T >::Remove ( HookFn fn ) [inline]

Removes the callback function 'fn' from the predefined hook.

The documentation for this class was generated from the following file:
  • Auxiliary/SingleArgHook.hpp
Generated on Wed Jan 25 01:56:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SioGlueSignalListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SioGlueSignalListener Class Reference

#include <Apoxi/AddOns/MmCall/SioGlueSignalListener.hpp>

Collaboration diagram for SioGlueSignalListener:

[legend]

Public Member Functions

void | Init (SerialTerminal *terminal)
Initialize the class by setting the terminal.
void | OnSignalChange (SioGlueWrapper::SignalType type, void *signal_parameter, void *user_parameter)
SioGlueSignalListener ()
Constructor.
virtual | ~SioGlueSignalListener ()
Destructor.

Static Public Member Functions

static void | sio_glue_handler (glue_sig_t sig_code, void *sig_param, void *user_param)

Detailed Description

SioGlueSignalListener fowards SIO callbacks to a listening SerialTerminal

Constructor & Destructor Documentation

SioGlueSignalListener::SioGlueSignalListener ( )

Constructor.

SioGlueSignalListener::~SioGlueSignalListener ( ) [virtual]

Destructor.

Member Function Documentation

void SioGlueSignalListener::Init ( SerialTerminal * terminal ) [inline]

Initialize the class by setting the terminal.

void SioGlueSignalListener::OnSignalChange | ( | SioGlueWrapper::SignalType | type,
 |  | void * | signal_parameter,
 |  | void * | user_parameter
 | ) |

wrapper for callbacks of Sio glue layer; original interface: static void sio_glue_handler (glue_sig_t sig_code, void *sig_param, void *user_param)

Parameters:
type | type of SIO signal, e.g. changed terminal lines
signal_parameter | signal specific parameter e.g. state of terminal lines, see SioGlueWrapper::TermIos
user_parameter | user specific parameter, e.g. a pointer to a signal handler class

void SioGlueSignalListener::sio_glue_handler | ( | glue_sig_t | sig_code,
 |  | void * | sig_param,
 |  | void * | user_param
 | ) | [static]

Define the function pointer for the callback from the Sio Glue Layer

Parameters:
sig_code | specifies type of SIO signal, e.g. changed terminal lines
signal_param | signal specific parameter e.g. state of terminal lines, see SioGlueWrapper::TermIos
user_param | user specific parameter, e.g. pointer to a signal handler class

The documentation for this class was generated from the following files:
  • AddOns/MmCall/SioGlueSignalListener.hpp
  • AddOns/MmCall/SioGlueSignalListener.cpp
Generated on Wed Jan 25 01:56:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SioGlueWrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SioGlueWrapper Class Reference

#include <Apoxi/AddOns/MmCall/SioGlueWrapper.hpp>

Public Types

enum | LineState { SioLineOff = SIO_LINE_OFF, SioLineOn = SIO_LINE_ON, SioLineDontCare = SIO_LINE_ON+1 }
enum Parity {
ParityNone = SIO_PARITY_NONE, ParityOdd = SIO_PARITY_ODD, ParityEvent = SIO_PARITY_EVEN, ParityMark = SIO_PARITY_MARK,
ParitySpace = SIO_PARITY_SPACE
}
enum Result {
SioOk = SIO_STAT_OK, SioError = SIO_STAT_ERROR, SioEnoughBuffer = SIO_STAT_WATER_HIGH, SioBufferLow = SIO_STAT_WATER_LOW,
SioAtBusy = SIO_STAT_AT_BUSY, SioAtComplete = SIO_STAT_AT_COMPL
}
enum | SignalStartStop { SioExecModeStart = GLUE_EXECMODE_START, SioExecModeKill = GLUE_EXECMODE_KILL, SioSigvalLast = GLUE_SIGVAL_LAST }
enum SignalType {
SioDataReq = GLUE_SIG_DATAREQ, SioTermIos = GLUE_SIG_TERMIOS, SioExecMode = GLUE_SIG_EXECMODE, SioClose = GLUE_SIG_CLOSE,
SioOpen = GLUE_SIG_OPEN, SioLast = GLUE_SIG_LAST
}

Static Public Member Functions

static Result | Close (const SioCommId &comm_id)
static Result | GetAtMode (const SioCommId &comm_id, BOOLEAN &at_mode)
static Result | GetBufferSizes (const SioCommId &comm_id, UINT16 &free, UINT16 &size)
static Result | GetStatus (const SioCommId &comm_id, TermIos &state)
static Result | Open (const String &device_name, SioCommId &comm_id)
static Result | ReadData (const SioCommId &comm_id, void *buffer, UINT16 size, UINT16 &read)
static Result | RegisterSignalListener (const SioCommId &comm_id, SioGlueSignalListener &listener)
static Result | SetAtMode (const SioCommId &comm_id, BOOLEAN at_mode)
static Result | SetStatus (const SioCommId &comm_id, const TermIos &state)
static Result | UnRegisterSignalListener (const SioCommId &comm_id, const SioGlueSignalListener &listener)
static Result | WriteData (const SioCommId &comm_id, const void *buffer, UINT16 size, UINT16 &written)

Data Structures

struct | SioCommId
struct | TermIos

Detailed Description

Wraps the c-coded serial input output layer of the mobile phone stack.

Member Enumeration Documentation

enum SioGlueWrapper::LineState

Status of the V.24 lines.

Enumerator:
SioLineOff | Line is off.
SioLineOn | Line is on.
SioLineDontCare | Don't care/don'set line state.

enum SioGlueWrapper::Parity

Parity values.

Enumerator:
ParityNone
ParityOdd
ParityEvent
ParityMark
ParitySpace

enum SioGlueWrapper::Result

Return values of the GlueWrapper.

Enumerator:
SioOk | Success.
SioError | An error occured.
SioEnoughBuffer | Sufficient buffer space is available.
SioBufferLow | The buffer space is in critical state.
SioAtBusy | AT response is incomplete.
SioAtComplete | Complete AT response.

enum SioGlueWrapper::SignalStartStop

List of the signal values from the glue layer to the glue client.

Enumerator:
SioExecModeStart | Activate the client.
SioExecModeKill | Terminate the client.
SioSigvalLast

enum SioGlueWrapper::SignalType

Signal type of Sio, which is forwared to the the Listeners

Enumerator:
SioDataReq | Data from the modem are available.
SioTermIos | Changes of the port settings.
SioExecMode | Tell the glue client the expected execution mode.
SioClose | Switch off the hardware device.
SioOpen | Switch on the hardware device.
SioLast

Member Function Documentation

SioGlueWrapper::Result SioGlueWrapper::Close ( const SioCommId & comm_id ) [static]

Close will deallocate the sio clue descriptor. To deallocate means to make the descriptor available for return by subsequent calls to Open().

Parameters:
comm_id the handle of the sio client that shall be closed.
Returns:
returns c_sio_ok on success, or c_sio_error if an error occured like invalid descriptor.

SioGlueWrapper::Result SioGlueWrapper::GetAtMode | ( | const SioCommId & | comm_id,
 |  | BOOLEAN & | at_mode
 | ) | [static]

Determines if the connection defined by the comm_id parameter is either in online (data is transfered) or offline (at commmands are being transfered) mode.

Parameters:
comm_id | the handle of the sio client.
at_mode | defines if at mode is on or off.

SioGlueWrapper::Result SioGlueWrapper::GetBufferSizes | ( | const SioCommId & | comm_id,
 |  | UINT16 & | free,
 |  | UINT16 & | size
 | ) | [static]

Get information about the size and fress space of the internal buffer of the sio.

Parameters:
comm_id | the handle of the sio client.
free | specifies the number of free bytes of the internal buffer of the sio.
size | specifies the overall size of the internal buffer of the sio.

SioGlueWrapper::Result SioGlueWrapper::GetStatus | ( | const SioCommId & | comm_id,
 |  | TermIos & | state
 | ) | [static]

Returns the current status of the connection (e.g. parity, data_bits, stop_bit, ...) of the sio client and allows to get the states of the v24 serial lines.

Parameters:
comm_id | the handle of the sio client
state | the current state of the connection of the sio client.

SioGlueWrapper::Result SioGlueWrapper::Open | ( | const String & | device_name,
 |  | SioCommId & | comm_id
 | ) | [static]

Open will open the GlueWrapper and connect to Sio.

Parameters:
comm_id | the handle of the sio client that shall be opened.
device_name | the name of the terminal by which the client is identified.
Returns:
returns c_sio_ok on success, or c_sio_error if an error occured like unknown device name or multiple registration

SioGlueWrapper::Result SioGlueWrapper::ReadData | ( | const SioCommId & | comm_id,
 |  | void * | buffer,
 |  | UINT16 | size,
 |  | UINT16 & | read
 | ) | [static]

ReadData() attempts to read up to size bytes into the buffer starting at buffer the beginning of buffer.

Parameters:
comm_id | the handle of the sio client.
buffer | [OUT] Pointer to buffer
size | [IN] size of buffer
read | [OUT] the number of bytes read from Sio and written into buffer
Returns:
returns c_sio_ok on success, or c_sio_error if an error occured like GlueWrapper is closed

SioGlueWrapper::Result SioGlueWrapper::RegisterSignalListener | ( | const SioCommId & | comm_id,
 |  | SioGlueSignalListener & | listener
 | ) | [static]

Registers the callback method of the SioGlueSignalListener at the sio glue layer.

Parameters:
comm_id | the handle of the sio client for which a callback is registered.
listener | the listener to listen on callbacks of the sio.

SioGlueWrapper::Result SioGlueWrapper::SetAtMode | ( | const SioCommId & | comm_id,
 |  | BOOLEAN | at_mode
 | ) | [static]

Sets the terminal connection either into online (data is transfered) or offline (at commmands are being transfered) mode.

Parameters:
comm_id | the handle of the sio client.
at_mode | defines if at mode shall be switched on or off.

SioGlueWrapper::Result SioGlueWrapper::SetStatus | ( | const SioCommId & | comm_id,
 |  | const TermIos & | state
 | ) | [static]

Sets the options for the connection (e.g. parity, data_bits, stop_bit, ...) and allows to switch lines on and off.

Parameters:
comm_id | the handle of the sio client
state | the state that shall be set for the connection of the sio client.

SioGlueWrapper::Result SioGlueWrapper::UnRegisterSignalListener | ( | const SioCommId & | comm_id,
 |  | const SioGlueSignalListener & | listener
 | ) | [static]

Unregisters the callback method of the SioGlueSignalListener from the sio glue layer.

Parameters:
comm_id | the handle of the sio client for which the callback method is unregistered.
listener | the listener to stop listening on callbacks of the sio.

SioGlueWrapper::Result SioGlueWrapper::WriteData | ( | const SioCommId & | comm_id,
 |  | const void * | buffer,
 |  | UINT16 | size,
 |  | UINT16 & | written
 | ) | [static]

WriteData() writes up to size bytes to the glue layer starting at buffer the beginning of buffer.

Parameters:
comm_id | the handle of the sio client.
buffer | [OUT] Pointer to buffer
size | [IN] size of buffer
written | [OUT] the number of bytes written to Sio
Returns:
returns c_sio_enough_buffer, c_sio_buffer_low on success, or c_sio_error if an error occured like GlueWrapper is closed

The documentation for this class was generated from the following files:
  • AddOns/MmCall/SioGlueWrapper.hpp
  • AddOns/MmCall/SioGlueWrapper.cpp
Generated on Wed Jan 25 01:56:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SioGlueWrapper::SioCommId Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SioGlueWrapper::SioCommId

SioGlueWrapper::SioCommId Struct Reference

#include <Apoxi/AddOns/MmCall/SioGlueWrapper.hpp>

Friends

class SioGlueWrapper

Friends And Related Function Documentation

friend class SioGlueWrapper [friend]

The documentation for this struct was generated from the following file:
  • AddOns/MmCall/SioGlueWrapper.hpp
Generated on Wed Jan 25 01:56:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SioGlueWrapper::TermIos Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SioGlueWrapper::TermIos

SioGlueWrapper::TermIos Struct Reference

#include <Apoxi/AddOns/MmCall/SioGlueWrapper.hpp>

Public Member Functions

LineState | GetCts () const
Get modem flow control status.
UINT8 | GetDataBits () const
Get data bits.
LineState | GetDcd () const
Get carrier status.
LineState | GetDsr () const
Get modem connection staus.
LineState | GetDtr () const
Get terminal connection status. (read only).
Parity | GetParity () const
Get parity.
LineState | GetRi () const
Get ring indicator.
LineState | GetRts () const
Get flow control status. (read only).
UINT32 | GetSpeed () const
Get connection speed.
UINT8 | GetStopBits () const
Get stop bits.
void | SetCts (LineState state)
Set modem flow control status.
void | SetDataBits (UINT8 data_bits)
Set data bits.
void | SetDcd (LineState state)
Set carrier status.
void | SetDsr (LineState state)
Get modem connection staus.
void | SetParity (Parity parity)
Set parity.
void | SetRi (LineState state)
Set ring indicator.
void | SetSpeed (UINT32 speed)
Set connection speed.
void | SetStopBits (UINT8 stop_bits)
Set stop bits.
TermIos (sio_termios_t *sio_termios)
TermIos ()
Constructor.
~TermIos ()
Destructor.

Data Fields

friend | SioGlueWrapper

Detailed Description

V.24 signal lines, see glue_termios_t;

Constructor & Destructor Documentation

SioGlueWrapper::TermIos::TermIos ( )

Constructor.

SioGlueWrapper::TermIos::TermIos ( sio_termios_t * sio_termios )

Constructor

Parameters:
sio_termios Structure containing the termios signals

SioGlueWrapper::TermIos::~TermIos ( )

Destructor.

Member Function Documentation

LineState SioGlueWrapper::TermIos::GetCts ( ) const [inline]

Get modem flow control status.

UINT8 SioGlueWrapper::TermIos::GetDataBits ( ) const [inline]

Get data bits.

LineState SioGlueWrapper::TermIos::GetDcd ( ) const [inline]

Get carrier status.

LineState SioGlueWrapper::TermIos::GetDsr ( ) const [inline]

Get modem connection staus.

LineState SioGlueWrapper::TermIos::GetDtr ( ) const [inline]

Get terminal connection status. (read only).

Parity SioGlueWrapper::TermIos::GetParity ( ) const [inline]

Get parity.

LineState SioGlueWrapper::TermIos::GetRi ( ) const [inline]

Get ring indicator.

LineState SioGlueWrapper::TermIos::GetRts ( ) const [inline]

Get flow control status. (read only).

UINT32 SioGlueWrapper::TermIos::GetSpeed ( ) const [inline]

Get connection speed.

UINT8 SioGlueWrapper::TermIos::GetStopBits ( ) const [inline]

Get stop bits.

void SioGlueWrapper::TermIos::SetCts ( LineState state ) [inline]

Set modem flow control status.

void SioGlueWrapper::TermIos::SetDataBits ( UINT8 data_bits ) [inline]

Set data bits.

void SioGlueWrapper::TermIos::SetDcd ( LineState state ) [inline]

Set carrier status.

void SioGlueWrapper::TermIos::SetDsr ( LineState state ) [inline]

Get modem connection staus.

void SioGlueWrapper::TermIos::SetParity ( Parity parity ) [inline]

Set parity.

void SioGlueWrapper::TermIos::SetRi ( LineState state ) [inline]

Set ring indicator.

void SioGlueWrapper::TermIos::SetSpeed ( UINT32 speed ) [inline]

Set connection speed.

void SioGlueWrapper::TermIos::SetStopBits ( UINT8 stop_bits ) [inline]

Set stop bits.

Field Documentation

friend SioGlueWrapper::TermIos::SioGlueWrapper

The documentation for this struct was generated from the following files:
  • AddOns/MmCall/SioGlueWrapper.hpp
  • AddOns/MmCall/SioGlueWrapper.cpp
Generated on Wed Jan 25 01:56:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SioSocketAdapter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SioSocketAdapter Class Reference

#include <Apoxi/AddOns/SioSocketAdapter/SioSocketAdapter.hpp>

Collaboration diagram for SioSocketAdapter:

[legend]

Public Types

typedef void(* | AcceptCb )(SocketId sock_id, INT32 result, SocketId client_sock_id)
typedef UINT16 | IrdaParams
typedef void(* | SimpleCb )(SocketId sock_id, INT32 result)
typedef INT8 | SocketId

Static Public Member Functions

static SocketId | Accept (SocketId sock_id, SocketAddr &client_addr)
static void | Close (SocketId sock_id)
static BOOLEAN | Connect (SocketId sock_id, SocketAddr &serv_addr)
static SocketId | Create (SerialIoAdapter::SocketFamily fam, INT protocol, const SocketAddr *address=0, BOOLEAN is_server=FALSE)
static void | Init (const SioSocketCallbacks &callbacks)
static BOOLEAN | Listen (SocketId sock_id, INT backlog)
static INT | OptGet (INT optname, void *optval, INT &optlen)
static INT | OptSet (INT optname, const void *optval, INT optlen)
static UINT32 | Read (SocketId sock_id, UINT8 *pReadBuf, UINT32 readSize)
static UINT32 | Write (SocketId sock_id, const UINT8 *pDataBuf, UINT32 dataSize)

Friends

class | SioSocketAdapter::SerialClientSockEventListener
class | SioSocketAdapter::SerialServerSockEventListener

Data Structures

class | SerialClientSockEventListener
class | SerialServerSockEventListener
struct | SioSocketCallbacks

Member Typedef Documentation

typedef void(* SioSocketAdapter::AcceptCb)(SocketId sock_id, INT32 result, SocketId client_sock_id)

typedef UINT16 SioSocketAdapter::IrdaParams

typedef void(* SioSocketAdapter::SimpleCb)(SocketId sock_id, INT32 result)

typedef INT8 SioSocketAdapter::SocketId

Member Function Documentation

SioSocketAdapter::SocketId SioSocketAdapter::Accept | ( | SocketId | sock_id,
 |  | SocketAddr & | client_addr
 | ) | [static]

Accepts incoming client connection request. The ID of the new accepted client socket is returned. Asserts if sock_id references a client socket.

Parameters:
sock_id SocketID.
... TO DO comment params...
Returns:
ID of accepted client socket or invalid socket ID.

void SioSocketAdapter::Close ( SocketId sock_id ) [static]

Closes the socket.

Returns:
void.

BOOLEAN SioSocketAdapter::Connect | ( | SocketId | sock_id,
 |  | SocketAddr & | serv_addr
 | ) | [static]

Connects the socket to another socket Asserts if sock_id references a server socket. (to be done)

Parameters:
serv_addr | pointer to a sock_addr_t structure
addr_len | size of the structure pointed to by sock_addr
Returns:
tells if connecting could be triggered.

SioSocketAdapter::SocketId SioSocketAdapter::Create | ( | SerialIoAdapter::SocketFamily | fam,
 |  | INT | protocol,
 |  | const SocketAddr * | address = 0,
 |  | BOOLEAN | is_server = FALSE
 | ) | [static]

Creates a socket and returns the socket ID.

Parameters:
TO DO ... : only to be specified, if transport needs it (BT needs it, IrDA doesn't need it)
Returns:
SocketId The socket identifier. @

void SioSocketAdapter::Init ( const SioSocketCallbacks & callbacks ) [static]

Initializes the SIO socket adapter. If the SIO socket handler is not initialized then all the following calls on it assert.

Parameters:
callbacks Reference to structure of callback function pointers.

BOOLEAN SioSocketAdapter::Listen | ( | SocketId | sock_id,
 |  | INT | backlog
 | ) | [static]

Puts the socket with sock_id into listen state. Asserts if sock_id references a client socket.

Returns:
Success of operation.

INT SioSocketAdapter::OptGet | ( | INT | optname,
 |  | void * | optval,
 |  | INT & | optlen
 | ) | [static]

Retrieves the option value.

Parameters:
optname | option name to retrive value
optval | pointer to the option value
optlen | pointer to the option value length
Returns:
0 on success and -1 on failure.

INT SioSocketAdapter::OptSet | ( | INT | optname,
 |  | const void * | optval,
 |  | INT | optlen
 | ) | [static]

Sets the option value.

Parameters:
optname | option name to set value
optval | pointer to the option value
optlen | pointer to the option value length
Returns:
Number of bytes written or -1 on failure.

UINT32 SioSocketAdapter::Read | ( | SocketId | sock_id,
 |  | UINT8 * | pReadBuf,
 |  | UINT32 | readSize
 | ) | [static]

Reads data from the socket.

Parameters:
buf | Pointer to destination-buffer.
buflen | Length of read buffer.
Returns:
Number of bytes read or -1 on failure.

UINT32 SioSocketAdapter::Write | ( | SocketId | sock_id,
 |  | const UINT8 * | pDataBuf,
 |  | UINT32 | dataSize
 | ) | [static]

Writes data into socket.

Parameters:
sock_id | SocketID.
buf | Pointer to source-buffer.
buflen | Length of source-buffer.
Returns:
Number of bytes written or -1 on failure.

Friends And Related Function Documentation

friend class SioSocketAdapter::SerialClientSockEventListener [friend]

friend class SioSocketAdapter::SerialServerSockEventListener [friend]

The documentation for this class was generated from the following files:
  • AddOns/SioSocketAdapter/SioSocketAdapter.hpp
  • AddOns/SioSocketAdapter/SioSocketAdapter.cpp
Generated on Wed Jan 25 01:56:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SioSocketAdapter::SioSocketCallbacks Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SioSocketAdapter::SioSocketCallbacks

SioSocketAdapter::SioSocketCallbacks Struct Reference

#include <Apoxi/AddOns/SioSocketAdapter/SioSocketAdapter.hpp>

Data Fields

SimpleCb m_connect_cnf_cb
SimpleCb m_connect_ind_cb
SimpleCb m_data_available_ind_cb
SimpleCb m_disconnect_ind_cb
SimpleCb m_write_cnf_cb

Field Documentation

SimpleCb SioSocketAdapter::SioSocketCallbacks::m_connect_cnf_cb

SimpleCb SioSocketAdapter::SioSocketCallbacks::m_connect_ind_cb

SimpleCb SioSocketAdapter::SioSocketCallbacks::m_data_available_ind_cb

SimpleCb SioSocketAdapter::SioSocketCallbacks::m_disconnect_ind_cb

SimpleCb SioSocketAdapter::SioSocketCallbacks::m_write_cnf_cb

The documentation for this struct was generated from the following file:
  • AddOns/SioSocketAdapter/SioSocketAdapter.hpp
Generated on Wed Jan 25 01:56:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiProvFileRef_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiProvFileRef_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SiProvFileRef_s:

[legend]

Data Fields

SiProvFileRefArray data
byte file_number

Field Documentation

SiProvFileRefArray SiProvFileRef_s::data

byte SiProvFileRef_s::file_number

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:56:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiProvFileRefArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiProvFileRefArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

UINT8 val [60]

Field Documentation

UINT8 SiProvFileRefArray::val[60]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:56:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiText_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiText_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for SiText_s:

[legend]

Data Fields

byte data_coding_scheme
byte length
SiTextArray text

Field Documentation

byte SiText_s::data_coding_scheme

byte SiText_s::length

SiTextArray SiText_s::text

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:56:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiTextArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiTextArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

byte val [242]

Field Documentation

byte SiTextArray::val[242]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:56:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SiUrlArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SiUrlArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

byte val [244]

Field Documentation

byte SiUrlArray::val[244]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 01:56:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Size Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Size Class Reference
[GUI]

#include <Apoxi/Gui/Size.hpp>

Public Member Functions

XYDIM | GetHeight () const
XYDIM | GetWidth () const
void | SetHeight (XYDIM height)
void | SetWidth (XYDIM width)
Size (const Size &size)
Size (XYDIM width=0, XYDIM height=0)

Detailed Description

Combines the width and height of a drawable object. The width and height are represented by the type XYDIM.

Constructor & Destructor Documentation

Size::Size | ( | XYDIM | width = 0,
 |  | XYDIM | height = 0
 | ) | [inline]

Size::Size ( const Size & size ) [inline]

Member Function Documentation

XYDIM Size::GetHeight ( ) const [inline]

XYDIM Size::GetWidth ( ) const [inline]

void Size::SetHeight ( XYDIM height ) [inline]

void Size::SetWidth ( XYDIM width ) [inline]

The documentation for this class was generated from the following file:
  • Gui/Size.hpp
Generated on Wed Jan 25 01:56:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SkipSocketTestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SkipSocketTestMsg Class Reference

#include <Applications/SocketTest/SocketTestMsgTypes.hpp>

Inheritance diagram for SkipSocketTestMsg:

[legend]
Collaboration diagram for SkipSocketTestMsg:

[legend]

Public Types

enum | { ID = 21904 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SkipSocketTestMsg (ExecutionContext *context)
virtual | ~SkipSocketTestMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SkipSocketTestMsg::SkipSocketTestMsg ( ExecutionContext * context )

SkipSocketTestMsg::~SkipSocketTestMsg ( ) [virtual]

Member Function Documentation

Message * SkipSocketTestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SkipSocketTestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestMsgTypes.hpp
  • Applications/SocketTest/SocketTestMsgTypes.cpp
Generated on Wed Jan 25 01:56:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmafSound Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmafSound Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/SmafSound.hpp>

Inheritance diagram for SmafSound:

[legend]
Collaboration diagram for SmafSound:

[legend]

Public Types

enum | { ID = 2 }

Public Member Functions

virtual const BinData * | GetBinData () const
Returns the i-melody data in the ems specific format.
virtual INT | GetId () const
void | Init (BinData *bin_data)
SmafSound (BinData *bin_data)
SmafSound ()
virtual | ~SmafSound ()

Detailed Description

Obsolete - all sound classes from AddOns/MultiMedia have been replaced by a new audio concept. Use the AudioDeviceManager instead for playing sounds.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmafSound::SmafSound ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

SmafSound::SmafSound ( BinData * bin_data ) [explicit]

Initializes an SMAF sound with the given bin_data.

Parameters:
bin_data Pointer to a binary data stream which contains the i-melody data. After passing the binary data stream, the stream is obtained by the SMAF sound and hence automatically released in the destructor of the SMAF sound.

SmafSound::~SmafSound ( ) [virtual]

Member Function Documentation

const BinData * SmafSound::GetBinData ( ) const [virtual]

Returns the i-melody data in the ems specific format.

Reimplemented from Sound.

INT SmafSound::GetId ( ) const [virtual]

See also:
Sound::GetId

Implements Sound.

void SmafSound::Init ( BinData * bin_data )

Initializes an SMAF sound with the given bin_data.

Parameters:
bin_data Pointer to a binary data stream which contains the i-melody data. After passing the binary data stream, the stream is obtained by the SMAF sound and hence automatically released in the destructor of the SMAF sound.

The documentation for this class was generated from the following files:
  • Compat/SmafSound.hpp
  • Compat/SmafSound.cpp
Generated on Wed Jan 25 01:56:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Sms Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Sms Class Reference

#include <Apoxi/Apc/Sms.hpp>

Inheritance diagram for Sms:

[legend]
Collaboration diagram for Sms:

[legend]

Public Types

enum Result {
UnassignedNumber = MN_SMS_UNASSIGNED_NUMBER, OpDeterminedBarring = MN_SMS_OP_DETERMINED_BARRING, CallBarred = MN_SMS_CALL_BARRED, CpNetworkFailure = MN_SMS_CP_NETWORK_FAILURE,
TransferRejected = MN_SMS_TRANSFER_REJECTED, MemoryCapacityExceeded = MN_SMS_MEMORY_CAPACITY_EXCEEDED, DestOutOfService = MN_SMS_DEST_OUT_OF_SERVICE, UnidentifiedSubscriber = MN_SMS_UNIDENTIFIED_SUBSCRIBER,
FacilityRejected = MN_SMS_FACILITY_REJECTED, UnknownSubscriber = MN_SMS_UNKNOWN_SUBSCRIBER, NetworkOutOfOrder = MN_SMS_NETWORK_OUT_OF_ORDER, TemporaryFailure = MN_SMS_TEMPORARY_FAILURE,
Congestion = MN_SMS_CONGESTION, ResourcesUnavailable = MN_SMS_RESOURCES_UNAVAILABLE, FacilityNotSubscribed = MN_SMS_FACILITY_NOT_SUBSCRIBED, ReqFaciltyNonImpl = MN_SMS_REQ_FACILTY_NON_IMPL,
InvalidReferenceValue = MN_SMS_INVALID_REFERENCE_VALUE, SemantIncorrectMsg = MN_SMS_SEMANT_INCORRECT_MSG, InvalidMandatoryInfo = MN_SMS_INVALID_MANDATORY_INFO, MsgTypeNonExistent = MN_SMS_MSG_TYPE_NON_EXISTENT,
MsgNotCompatible = MN_SMS_MSG_NOT_COMPATIBLE, IeNonExistent = MN_SMS_IE_NON_EXISTENT, ProtocollError = MN_SMS_PROTOCOLL_ERROR, Interworking = MN_SMS_INTERWORKING,
RpAck = MN_SMS_RP_ACK, TimerExpired = MN_SMS_TIMER_EXPIRED, ForwAvailFailed = MN_SMS_FORW_AVAIL_FAILED, ForwAvailAborted = MN_SMS_FORW_AVAIL_ABORTED,
TpInvalidMti = MN_TP_INVALID_MTI, TpSrfNotInPhase1 = MN_TP_SRF_NOT_IN_PHASE1, TpRdfNotInPhase1 = MN_TP_RDF_NOT_IN_PHASE1, TpRpfNotInPhase1 = MN_TP_RPF_NOT_IN_PHASE1,
TpUdhfNotInPhase1 = MN_TP_UDHF_NOT_IN_PHASE1, TpMissingValidityPeriod = MN_TP_MISSING_VALIDITY_PERIOD, TpInvalidTimeStamp = MN_TP_INVALID_TIME_STAMP, TpMissingDestAddress = MN_TP_MISSING_DEST_ADDRESS,
TpInvalidDestAddress = MN_TP_INVALID_DEST_ADDRESS, TpMissingScAddress = MN_TP_MISSING_SC_ADDRESS, TpInvalidScAddress = MN_TP_INVALID_SC_ADDRESS, TpInvalidAlphabet = MN_TP_INVALID_ALPHABET,
TpInvalidUserDataLength = MN_TP_INVALID_USER_DATA_LENGTH, TpMissingUserData = MN_TP_MISSING_USER_DATA, TpUserDataTooLarge = MN_TP_USER_DATA_TOO_LARGE, TpCmdReqNotInPhase1 = MN_TP_CMD_REQ_NOT_IN_PHASE1,
TpInvalidDestAddrSpecCmds = MN_TP_INVALID_DEST_ADDR_SPEC_CMDS, TpInvalidCmdDataLength = MN_TP_INVALID_CMD_DATA_LENGTH, TpMissingCmdData = MN_TP_MISSING_CMD_DATA, TpInvalidCmdData_Type = MN_TP_INVALID_CMD_DATA_TYPE,
TpCreationOfMnrFailed = MN_TP_CREATION_OF_MNR_FAILED, TpMtConnectionLost = MN_TP_MT_CONNECTION_LOST, TpPendingMoSms = MN_TP_PENDING_MO_SMS, NoError = MN_SMS_NO_ERROR,
NoErrorNoIconDisplay = MN_SMS_NO_ERROR_NO_ICON_DISPLAY, FdnFailed = MN_SMS_FDN_FAILED, BdnFailed = MN_SMS_BDN_FAILED, PpUnspecified = SMS_PP_UNSPECIFIED,
AssemblingError, TpduDataMissing, InvalidStoreLocation, UndefinedResult
}
describes all the return values with sms-transactions. More...
enum StorageType {
Sim = MN_SIM_STORAGE, Flash = MN_FLASH_STORAGE_MODE, None = MN_STORAGE_NONE, SimPreferred,
FlashPreferred, SharedMemory, Preferred
}
describes the location, which can be used for storing the Sms. More...
enum WarningLevel {
CapacityExceed = MdhRejMemoryExceeded, SimIsFull = MdhRejSimIsFull, SimNotUsed = MdhRejSimIsNotInView, NoSmsOnSim = MdhRejSimNoSms,
WarningSimIsFull = MdhWarnSmStorageSimIsFull, SimStorageGetsFree = MdhSmStorageSimIsFree, MemoryFull
}
describes the warning level for the sms memory. More...

Public Member Functions

UINT8 * | GetData () const
PhoneNumber | GetServiceCentreAddress () const
MessageTypeIndicator::Type | GetType () const
void | SetServiceCentreAddress (const PhoneNumber &phone_number)
Sms (Tpdu *tpdu)
~Sms ()

Protected Types

enum | { c_tpdu_size = 164 }

Protected Member Functions

BOOLEAN | GetBit (INT offset, UINT8 bit_no) const
void | Init ()
Initializes internal data (on any change of reference Tpdu m_tpdu).
void | SetBit (INT offset, UINT8 bit_no, BOOLEAN flag)

Protected Attributes

MessageTypeIndicator::Type m_sms_type
UINT8 * | m_tp_data
Tpdu * m_tpdu

Detailed Description

3GPP TS 23.040 V5.1.0 - Attention: This class is a wrapper over a TPDU-reference (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Member Enumeration Documentation

anonymous enum [protected]

Enumerator:
c_tpdu_size Size of the TPDU data (according PDU Type retertoire at SM-TL defined in 3GPP TS 23.040 V5.1.0 [9.2.2.1]).

enum Sms::Result

describes all the return values with sms-transactions.

Enumerator:
UnassignedNumber
OpDeterminedBarring
CallBarred
CpNetworkFailure
TransferRejected
MemoryCapacityExceeded
DestOutOfService
UnidentifiedSubscriber
FacilityRejected
UnknownSubscriber
NetworkOutOfOrder
TemporaryFailure
Congestion
ResourcesUnavailable
FacilityNotSubscribed
ReqFaciltyNonImpl
InvalidReferenceValue
SemantIncorrectMsg
InvalidMandatoryInfo
MsgTypeNonExistent
MsgNotCompatible
IeNonExistent
ProtocollError
Interworking
RpAck
TimerExpired
ForwAvailFailed
ForwAvailAborted
TpInvalidMti
TpSrfNotInPhase1
TpRdfNotInPhase1
TpRpfNotInPhase1
TpUdhfNotInPhase1
TpMissingValidityPeriod
TpInvalidTimeStamp
TpMissingDestAddress
TpInvalidDestAddress
TpMissingScAddress
TpInvalidScAddress
TpInvalidAlphabet
TpInvalidUserDataLength
TpMissingUserData
TpUserDataTooLarge
TpCmdReqNotInPhase1
TpInvalidDestAddrSpecCmds
TpInvalidCmdDataLength
TpMissingCmdData
TpInvalidCmdData_Type
TpCreationOfMnrFailed
TpMtConnectionLost
TpPendingMoSms
NoError
NoErrorNoIconDisplay
FdnFailed
BdnFailed
PpUnspecified
AssemblingError | error while assembling the sms
TpduDataMissing | no tpdu data available (return value of Sending in SmsFactory)
InvalidStoreLocation | sms is tried to be stored on an invalid location.
UndefinedResult

enum Sms::StorageType

describes the location, which can be used for storing the Sms.

Enumerator:
Sim
Flash
None
SimPreferred
FlashPreferred
SharedMemory
Preferred

enum Sms::WarningLevel

describes the warning level for the sms memory.

Enumerator:
CapacityExceed | memory capacity is exceeded - sms couldn't be stored.
SimIsFull | on the SIM there are no free position, but operation is requested on the SIM only (saving of the SMS class 2).
SimNotUsed | SMS class2 is received, but MN view is set to only nvram storage.
NoSmsOnSim | SMS class2 is received, but on the SIM there are no SMS.
WarningSimIsFull | The last free SMS entry on the SIM card is used.
SimStorageGetsFree | SMS storage on the SIM card gets free again .
MemoryFull | memory is full - last sms, which could be stored, backwards compatible

Constructor & Destructor Documentation

Sms::Sms ( Tpdu * tpdu )

Sms::~Sms ( )

Member Function Documentation

BOOLEAN Sms::GetBit | ( | INT | offset,
 |  | UINT8 | bit_no
 | ) | const [protected]

retrieves the value of the bit in bit_no in the byte calculated by the start of the transfer-protocol plus offset.

UINT8* Sms::GetData ( ) const [inline]

PhoneNumber Sms::GetServiceCentreAddress ( ) const

MessageTypeIndicator::Type Sms::GetType ( ) const [inline]

void Sms::Init ( ) [protected]

Initializes internal data (on any change of reference Tpdu m_tpdu).

void Sms::SetBit | ( | INT | offset,
 |  | UINT8 | bit_no,
 |  | BOOLEAN | flag
 | ) | [protected]

updates the bit bit_no in the byte calculated by by the start of the transfer-protocol plus offset with the value flag (0/1).

void Sms::SetServiceCentreAddress ( const PhoneNumber & phone_number )

Field Documentation

MessageTypeIndicator::Type Sms::m_sms_type [protected]

UINT8* Sms::m_tp_data [protected]

Tpdu* Sms::m_tpdu [protected]

The documentation for this class was generated from the following files:
  • Apc/Sms.hpp
  • Apc/Sms.cpp
Generated on Wed Jan 25 01:57:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsAlert Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsAlert Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsAlerts.hpp>

Collaboration diagram for SmsAlert:

[legend]

Public Types

enum SmsAlertType {
SmsSentOkType, SmsReceivedSmsType, SmsPendingSmsType, SmsReceivedStatRepType,
SmsMemoryFullType, SmsSimFullType, SmsStoredOkType, SmsBoxEmpty
}
Alert Types. More...

Public Member Functions

void | Init ()
void | SetSmsAlertType (SmsAlertType type, INT pending_seg_count=-1)
sets the alert text based on alert types
SmsAlert ()
~SmsAlert ()

Detailed Description

The SmsAlert is the class for displaying short informations to the user based on modal dialogs.

Member Enumeration Documentation

enum SmsAlert::SmsAlertType

Alert Types.

Enumerator:
SmsSentOkType
SmsReceivedSmsType
SmsPendingSmsType
SmsReceivedStatRepType
SmsMemoryFullType
SmsSimFullType
SmsStoredOkType
SmsBoxEmpty

Constructor & Destructor Documentation

SmsAlert::SmsAlert ( )

SmsAlert::~SmsAlert ( )

Member Function Documentation

void SmsAlert::Init ( )

void SmsAlert::SetSmsAlertType | ( | SmsAlertType | type,
 |  | INT | pending_seg_count = -1
 | ) |

sets the alert text based on alert types

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsAlerts.hpp
  • Applications/Ems/Sms/SmsAlerts.cpp
Generated on Wed Jan 25 01:57:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsApp Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsApp.hpp>

Inheritance diagram for SmsApp:

[legend]
Collaboration diagram for SmsApp:

[legend]

Public Member Functions

~SmsApp ()

Static Public Member Functions

static SmsApp * GetInstance ()

Detailed Description

Application Class for the SmsClient

Constructor & Destructor Documentation

SmsApp::~SmsApp ( )

Member Function Documentation

SmsApp * SmsApp::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsApp.hpp
  • Applications/Ems/Sms/SmsApp.cpp
Generated on Wed Jan 25 01:57:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsBasicProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsBasicProvider Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsBasicProvider.hpp>

Inheritance diagram for SmsBasicProvider:

[legend]
Collaboration diagram for SmsBasicProvider:

[legend]

Public Member Functions

virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
void | Init (Provider *sms_provider)
void | SetProvider (Provider *provider)
void | SetStatusChanged ()
SmsBasicProvider ()
virtual | ~SmsBasicProvider ()

Protected Member Functions

virtual BOOLEAN | IsPhoneNumberTextDefaultData (INT columnid, INT row)
virtual BOOLEAN | Lock ()
Lock locks the child-provider.
virtual BOOLEAN | Unlock ()
Unlock unlocks the child-provider.

Detailed Description

This class is responsible for merging Sms Entries with the Phonebook. If there has been a change so that you want to Update, you can call the method SetForceUpdate().

Constructor & Destructor Documentation

SmsBasicProvider::SmsBasicProvider ( )

SmsBasicProvider::~SmsBasicProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SmsBasicProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

Gets the child row

Parameters:
childrow | Specifies the child row
row | Specifies the row
See also:
CallRecordsFolderProvider::GetChildRow()

Implements AbstractDelegationProvider.

BOOLEAN SmsBasicProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
parent

Implements AbstractDelegationProvider.

void SmsBasicProvider::Init ( Provider * sms_provider )

Parameters:
sms_provider,: SmsProvider you get from the main provider
pb_provider,: PbProvider you get from the main provider
sms_phonenumber_colid
pb_phonenumber_colid

Reimplemented from AbstractDelegationProvider.

BOOLEAN SmsBasicProvider::IsPhoneNumberTextDefaultData | ( | INT | columnid,
 |  | INT | row
 | ) | [protected, virtual]

BOOLEAN SmsBasicProvider::Lock ( ) [protected, virtual]

Lock locks the child-provider.

Reimplemented from AbstractDelegationProvider.

void SmsBasicProvider::SetProvider ( Provider * provider )

void SmsBasicProvider::SetStatusChanged ( ) [inline]

BOOLEAN SmsBasicProvider::Unlock ( ) [protected, virtual]

Unlock unlocks the child-provider.

Reimplemented from AbstractDelegationProvider.

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsBasicProvider.hpp
  • Applications/Ems/Sms/SmsBasicProvider.cpp
Generated on Wed Jan 25 01:57:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsCapacityAvailableArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsCapacityAvailableArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsCapacityAvailableArg:

[legend]
Collaboration diagram for SmsCapacityAvailableArg:

[legend]

Public Types

enum | { ID = 2565 }

Public Member Functions

SmsCapacityAvailableArg ()

Static Public Member Functions

static const SmsCapacityAvailableArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsCapacityAvailableArg: reflects arguments of signal DR_SM_CAPACITY_AVAIL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsCapacityAvailableArg::SmsCapacityAvailableArg ( )

Member Function Documentation

const SmsCapacityAvailableArg & SmsCapacityAvailableArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:57:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsCapacityExceededArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsCapacityExceededArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsCapacityExceededArg:

[legend]
Collaboration diagram for SmsCapacityExceededArg:

[legend]

Public Types

enum | { ID = 2564 }

Public Member Functions

const Sms::WarningLevel & | GetWarningLevel () const
void | SetWarningLevel (const Sms::WarningLevel &warning_level)
SmsCapacityExceededArg ()

Static Public Member Functions

static const SmsCapacityExceededArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsCapacityExceededArg: reflects arguments of signal DR_SM_CAPACITY_EXCEEDED_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsCapacityExceededArg::SmsCapacityExceededArg ( )

Member Function Documentation

const SmsCapacityExceededArg & SmsCapacityExceededArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Sms::WarningLevel& SmsCapacityExceededArg::GetWarningLevel ( ) const [inline]

void SmsCapacityExceededArg::SetWarningLevel ( const Sms::WarningLevel & warning_level ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:57:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsClass0Provider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsClass0Provider Class Reference
[Provider]

#include <Apoxi/Adc/SmsClass0Provider.hpp>

Inheritance diagram for SmsClass0Provider:

[legend]
Collaboration diagram for SmsClass0Provider:

[legend]

Public Member Functions

virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProgress ()
GetProgress indicates the progress of the updating in percent.
virtual INT | GetProviderId () const
Returns the provider id.
virtual Status | GetStatus () const
Returns the status of the provider.
virtual INT | MaxRowCount ()
returns the maximum number of sms entries of each provider
virtual INT | RowCount ()
RowCount returns the number of rows.
SmsClass0Provider ()
virtual BOOLEAN | ToggleRow (INT row)
changes the states of a row inside a provider, unread->read and unsent->sent
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~SmsClass0Provider ()

Detailed Description

SmsClass0Provider is the provider to retrieve the class 0 sms from the nvram. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_sms_class0_provider_id

Please refer to SmsProvider for possible columns

NOTE: Please do not instantiate this class.

Constructor & Destructor Documentation

SmsClass0Provider::SmsClass0Provider ( )

SmsClass0Provider::~SmsClass0Provider ( ) [virtual]

Member Function Documentation

BOOLEAN SmsClass0Provider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from SmsProvider.

BOOLEAN SmsClass0Provider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from SmsProvider.

BOOLEAN SmsClass0Provider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Reimplemented from SmsProvider.

INT SmsClass0Provider::GetProgress ( ) [virtual]

GetProgress indicates the progress of the updating in percent.

Reimplemented from SmsProvider.

INT SmsClass0Provider::GetProviderId ( ) const [virtual]

Returns the provider id.

Reimplemented from SmsProvider.

Provider::Status SmsClass0Provider::GetStatus ( ) const [virtual]

Returns the status of the provider.

Reimplemented from Provider.

INT SmsClass0Provider::MaxRowCount ( ) [virtual]

returns the maximum number of sms entries of each provider

Reimplemented from SmsProvider.

INT SmsClass0Provider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Reimplemented from SmsProvider.

BOOLEAN SmsClass0Provider::ToggleRow ( INT row ) [virtual]

changes the states of a row inside a provider, unread->read and unsent->sent

Reimplemented from SmsProvider.

BOOLEAN SmsClass0Provider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from SmsProvider.

The documentation for this class was generated from the following files:
  • Adc/SmsClass0Provider.hpp
  • Adc/SmsClass0Provider.cpp
Generated on Wed Jan 25 01:57:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsCommand Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsCommand Class Reference

#include <Apoxi/Apc/Sms.hpp>

Inheritance diagram for SmsCommand:

[legend]
Collaboration diagram for SmsCommand:

[legend]

Public Types

enum | { ID = MessageTypeIndicator::Command }
enum | { c_max_guaranteed_user_data_size = 146 }
typedef Sms | Base

Public Member Functions

UserData | GetCommandData () const
TP-CD: TP-Command-Data (3GPP 23.040 V5.1.0 [9.2.3.21]) TP-CDL: TP-Command-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.20]).
CommandType | GetCommandType () const
TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19]).
PhoneNumber | GetDestinationAddress () const
TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).
INT | GetMaxUserDataSize () const
SmsReferenceNumber | GetMessageNumber () const
TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18]).
SmsReferenceNumber | GetMessageReference () const
TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).
ProtocolIdentifier | GetProtocolIdentifier () const
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
BOOLEAN | RequestReport () const
TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).
void | SetCommandType (CommandType command_type)
TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19]).
void | SetDestinationAddress (const PhoneNumber &phone_number)
TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).
void | SetMessageNumber (SmsReferenceNumber message_number)
TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18]).
void | SetMessageReference (const SmsReferenceNumber &message_reference)
TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).
void | SetProtocolIdentifier (ProtocolIdentifier protocol_identifier)
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
void | SetRequestReport (BOOLEAN flag=TRUE)
TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).
void | SetUserDataHeaderExists (BOOLEAN flag=TRUE)
TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).
SmsCommand (Tpdu *tpdu)
INT | Trim ()
Reduces the size of the TPDU to the maximum needed. Tpdu reallocation is performed!!
BOOLEAN | UserDataHeaderExists () const
TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).
~SmsCommand ()

Friends

class | SmsFactory

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.2.4] - Attention: This class is a wrapper over a data-stream (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Member Typedef Documentation

typedef Sms SmsCommand::Base

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

anonymous enum

Enumerator:
c_max_guaranteed_user_data_size guaranteed length of UserData (excl. UserDataLength byte) - (3GPP 23.040 V5.1.0 [9.2.2.4])

Constructor & Destructor Documentation

SmsCommand::SmsCommand ( Tpdu * tpdu )

SmsCommand::~SmsCommand ( )

Member Function Documentation

UserData SmsCommand::GetCommandData ( ) const

TP-CD: TP-Command-Data (3GPP 23.040 V5.1.0 [9.2.3.21]) TP-CDL: TP-Command-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.20]).

CommandType SmsCommand::GetCommandType ( ) const

TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19]).

PhoneNumber SmsCommand::GetDestinationAddress ( ) const

TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).

INT SmsCommand::GetMaxUserDataSize ( ) const

Returns the maximum possible size (in bytes) of the userdata (inclusive the userdata-length byte). The size varies dependent on the size of the header-parameter.

UINT8 SmsCommand::GetMessageNumber ( ) const

TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18]).

SmsReferenceNumber SmsCommand::GetMessageReference ( ) const

TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).

ProtocolIdentifier SmsCommand::GetProtocolIdentifier ( ) const

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

BOOLEAN SmsCommand::RequestReport ( ) const

TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).

void SmsCommand::SetCommandType ( CommandType command_type )

TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19]).

void SmsCommand::SetDestinationAddress ( const PhoneNumber & phone_number )

TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).

void SmsCommand::SetMessageNumber ( SmsReferenceNumber message_number )

TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18]).

void SmsCommand::SetMessageReference ( const SmsReferenceNumber & message_reference )

TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).

void SmsCommand::SetProtocolIdentifier ( ProtocolIdentifier protocol_identifier )

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

void SmsCommand::SetRequestReport ( BOOLEAN flag = TRUE )

TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).

void SmsCommand::SetUserDataHeaderExists ( BOOLEAN flag = TRUE )

TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).

INT SmsCommand::Trim ( )

Reduces the size of the TPDU to the maximum needed. Tpdu reallocation is performed!!

BOOLEAN SmsCommand::UserDataHeaderExists ( ) const

TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).

Friends And Related Function Documentation

friend class SmsFactory [friend]

The documentation for this class was generated from the following files:
  • Apc/Sms.hpp
  • Apc/Sms.cpp
Generated on Wed Jan 25 01:57:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsComposeWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsComposeWin Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsComposeWin.hpp>

Inheritance diagram for SmsComposeWin:

[legend]
Collaboration diagram for SmsComposeWin:

[legend]

Public Member Functions

UINT8 | GetCharactersPerSegment ()
virtual EditorDocumentObtainer | GetDocumentObtainer () const
void | Init (AbstractSmsApp *sms_app)
virtual void | InsertText (const WString &text)
void | SetCounterText (int segment, int freecounter)
virtual void | SetDocumentObtainer (const EditorDocumentObtainer &obtainer)
SmsComposeWin ()
virtual | ~SmsComposeWin ()

Protected Member Functions

virtual AbstractPredictiveInputBox * | GetPredInputBox ()
virtual void | OnLayoutClient ()
See also:
Window::OnLayoutClient

virtual void | OnOpen ()

Detailed Description

SmsComposeWin is responsible for user interaction during composing a Sms.

Constructor & Destructor Documentation

SmsComposeWin::SmsComposeWin ( )

SmsComposeWin::~SmsComposeWin ( ) [virtual]

Member Function Documentation

UINT8 SmsComposeWin::GetCharactersPerSegment ( )

GetSegments returns chars per segment

Returns:
chars per segment (160 if 1 segment, 153 if more

EditorDocumentObtainer SmsComposeWin::GetDocumentObtainer ( ) const [virtual]

Implements AbstractSmsComposeWin.

AbstractPredictiveInputBox * SmsComposeWin::GetPredInputBox ( ) [protected, virtual]

Implements AbstractSmsComposeWin.

void SmsComposeWin::Init ( AbstractSmsApp * sms_app )

void SmsComposeWin::InsertText ( const WString & text ) [virtual]

Implements AbstractSmsComposeWin.

void SmsComposeWin::OnLayoutClient ( ) [protected, virtual]

See also:
Window::OnLayoutClient

Reimplemented from Window.

void SmsComposeWin::OnOpen ( ) [protected, virtual]

See also:
Window::OnOpen

Reimplemented from AtlWindow.

void SmsComposeWin::SetCounterText | ( | int | segment,
 |  | int | freecounter
 | ) |

SetCounterText sets the current segment number and available free character in that segment. This function is invoked from SmsEditor

Parameters:
segment,: Current segment
freecounter,: Available free character

void SmsComposeWin::SetDocumentObtainer ( const EditorDocumentObtainer & obtainer ) [virtual]

Implements AbstractSmsComposeWin.

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsComposeWin.hpp
  • Applications/Ems/Sms/SmsComposeWin.cpp
Generated on Wed Jan 25 01:57:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsConcatStatusTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsConcatStatusTextMap Class Reference
[SMS]

Sms concatenation status. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsConcatStatusTextMap:

[legend]
Collaboration diagram for SmsConcatStatusTextMap:

[legend]

Static Public Member Functions

static UINT | GetStatusCount ()
static const WCHAR * | GetStatusName (INT index)

Detailed Description

Sms concatenation status.

Member Function Documentation

static UINT SmsConcatStatusTextMap::GetStatusCount ( ) [inline, static]

static const WCHAR* SmsConcatStatusTextMap::GetStatusName ( INT index ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 01:57:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsConfigIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsConfigIndArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsConfigIndArg:

[legend]
Collaboration diagram for SmsConfigIndArg:

[legend]

Public Types

enum | { ID = 2508 }

Public Member Functions

UINT32 | GetTimer () const
void | SetTimer (UINT32 timer)
SmsConfigIndArg ()
SmsConfigIndArg (UINT32 timer)

Static Public Member Functions

static const SmsConfigIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsConfigIndArg: reflects arguments of signal MN_SMS_CONFIG_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsConfigIndArg::SmsConfigIndArg ( UINT32 timer )

SmsConfigIndArg::SmsConfigIndArg ( )

Member Function Documentation

const SmsConfigIndArg & SmsConfigIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT32 SmsConfigIndArg::GetTimer ( ) const [inline]

void SmsConfigIndArg::SetTimer ( UINT32 timer ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:57:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsContext Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsContext Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SmsContext.hpp>

Collaboration diagram for SmsContext:

[legend]

Public Member Functions

void | Clear ()
Clears all context parameters (except the MessageType) to its empty default values.
CommandType | GetCommandType () const
TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19]) - SMS command type only.
InformationElement::Identifier | GetConcatenatedReferenceNoType () const
returns the current type of concatenation reference number
DataCodingScheme | GetDataCodingScheme () const
TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]) - SMS submit type only.
const PhoneNumber & | GetDestinationAddress () const
TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).
SmsPortNo | GetDestinationApplicationPortAddress () const
SmsReferenceNumber | GetMessageNumber () const
TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18]) - SMS command type only.
MessageTypeIndicator::Type | GetMessageType () const
TP-MTI: TP-Message-Type-Indicator - 3GPP 23.040 V5.1.0 [9.2.3.1].
SmsPortNo | GetOriginatorApplicationPortAddress () const
ProtocolIdentifier | GetProtocolIdentifier () const
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
BOOLEAN | GetRejectDuplicates () const
TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25]) - SMS submit type only.
BOOLEAN | GetRequestReplyPath () const
TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]) - SMS submit type only.
BOOLEAN | GetRequestStatusReport () const
TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).
const PhoneNumber & | GetServiceCenterAddress () const
SmsReferenceNumber | GetSmsReferenceNumber () const
TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).
const ValidityPeriod & | GetValidityPeriod () const
TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12]) - SMS submit type only.
BOOLEAN | IsSingleSrrPerSmsEnabled () const
returns whether single srr for SMS is enabled
BOOLEAN | IsValid () const
Returns TRUE, if context is defined whether for SMS command or for SMS submit.
BOOLEAN | ReadSmsProfile (INT profile_number=0)
Reads the SMS context parameters out of the sms parameter provider.
void | SetCommandParameter (const PhoneNumber &service_center_address, const PhoneNumber &destination_address, const ProtocolIdentifier &protocol_identifier, SmsReferenceNumber message_number, const CommandType &command_type, BOOLEAN status_report_request)
void | SetCommandType (const CommandType &ct)
TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19]) - SMS command type only.
void | SetConcatenatedReferenceNoType (InformationElement::Identifier conc_refno_type)
void | SetDataCodingScheme (const DataCodingScheme &dcs)
TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]) - SMS submit type only.
void | SetDestinationAddress (const PhoneNumber &da)
TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).
void | SetDestinationApplicationPortAddress (SmsPortNo destination_port_no)
void | SetMessageNumber (SmsReferenceNumber mn)
TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18]) - SMS command type only.
void | SetMessageType (MessageTypeIndicator::Type mt)
TP-MTI: TP-Message-Type-Indicator - 3GPP 23.040 V5.1.0 [9.2.3.1].
void | SetOriginatorApplicationPortAddress (SmsPortNo originator_port_no)
void | SetProtocolIdentifier (const ProtocolIdentifier &pid)
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
void | SetRejectDuplicates (BOOLEAN rd)
TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25]) - SMS submit type only.
void | SetRequestReplyPath (BOOLEAN rp)
TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]) - SMS submit type only.
void | SetRequestStatusReport (BOOLEAN srr)
TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).
void | SetServiceCenterAddress (const PhoneNumber &sca)
void | SetSingleSrrPerSmsEnabled (BOOLEAN single_srr)
enable/disable the setting of status report request flag for only single (last) part of SMS
void | SetSmsReferenceNumber (SmsReferenceNumber mr)
TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).
void | SetSubmitParameter (const PhoneNumber &service_center_address, const PhoneNumber &destination_address, const ProtocolIdentifier &protocol_identifier, const DataCodingScheme &data_coding_scheme, const ValidityPeriod &valitity_period, BOOLEAN status_report_request, BOOLEAN reply_path, BOOLEAN reject_duplicates)
void | SetValidityPeriod (const ValidityPeriod &vp)
TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12]) - SMS submit type only.
BOOLEAN | ShallRejectDuplicates () const
Obsolete in Apoxi 1.4.
BOOLEAN | ShallRequestReplyPath () const
Obsolete in Apoxi 1.4.
BOOLEAN | ShallRequestStatusReport () const
Obsolete in Apoxi 1.4.
SmsContext (MessageTypeIndicator::Type mt=MessageTypeIndicator::InvalidType)
~SmsContext ()

Detailed Description

The class SmsContext represents the sending/storing context of a mobile originated Sms.

Constructor & Destructor Documentation

SmsContext::SmsContext ( MessageTypeIndicator::Type mt = MessageTypeIndicator::InvalidType )

SmsContext::~SmsContext ( )

Member Function Documentation

void SmsContext::Clear ( )

Clears all context parameters (except the MessageType) to its empty default values.

CommandType SmsContext::GetCommandType ( ) const [inline]

TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19]) - SMS command type only.

InformationElement::Identifier SmsContext::GetConcatenatedReferenceNoType ( ) const

returns the current type of concatenation reference number

DataCodingScheme SmsContext::GetDataCodingScheme ( ) const [inline]

TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]) - SMS submit type only.

const PhoneNumber& SmsContext::GetDestinationAddress ( ) const [inline]

TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).

SmsPortNo SmsContext::GetDestinationApplicationPortAddress ( ) const [inline]

returns the Application Port Address (destination) (3GPP 23.040 V5.1.0 [9.2.3.24.3] resp. 3GPP 23.040 V5.1.0 [9.2.3.24.4])

SmsReferenceNumber SmsContext::GetMessageNumber ( ) const [inline]

TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18]) - SMS command type only.

MessageTypeIndicator::Type SmsContext::GetMessageType ( ) const [inline]

TP-MTI: TP-Message-Type-Indicator - 3GPP 23.040 V5.1.0 [9.2.3.1].

SmsPortNo SmsContext::GetOriginatorApplicationPortAddress ( ) const [inline]

returns the Application Port Address (originator) (3GPP 23.040 V5.1.0 [9.2.3.24.3] resp. 3GPP 23.040 V5.1.0 [9.2.3.24.4])

ProtocolIdentifier SmsContext::GetProtocolIdentifier ( ) const [inline]

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

BOOLEAN SmsContext::GetRejectDuplicates ( ) const [inline]

TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25]) - SMS submit type only.

BOOLEAN SmsContext::GetRequestReplyPath ( ) const [inline]

TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]) - SMS submit type only.

BOOLEAN SmsContext::GetRequestStatusReport ( ) const [inline]

TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).

const PhoneNumber& SmsContext::GetServiceCenterAddress ( ) const [inline]

SmsReferenceNumber SmsContext::GetSmsReferenceNumber ( ) const [inline]

TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).

const ValidityPeriod& SmsContext::GetValidityPeriod ( ) const [inline]

TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12]) - SMS submit type only.

BOOLEAN SmsContext::IsSingleSrrPerSmsEnabled ( ) const [inline]

returns whether single srr for SMS is enabled

BOOLEAN SmsContext::IsValid ( ) const

Returns TRUE, if context is defined whether for SMS command or for SMS submit.

BOOLEAN SmsContext::ReadSmsProfile ( INT profile_number = 0 )

Reads the SMS context parameters out of the sms parameter provider.

void SmsContext::SetCommandParameter | ( | const PhoneNumber & | service_center_address,
 |  | const PhoneNumber & | destination_address,
 |  | const ProtocolIdentifier & | protocol_identifier,
 |  | SmsReferenceNumber | message_number,
 |  | const CommandType & | command_type,
 |  | BOOLEAN | status_report_request
 | ) |

Set context parameters with all SMS command relevant parameter manually and updates the MessageType to SMS command type. All SMS command irrelevant data is cleared.

void SmsContext::SetCommandType ( const CommandType & ct ) [inline]

TP-CT: TP-Command-Type (3GPP 23.040 V5.1.0 [9.2.3.19]) - SMS command type only.

void SmsContext::SetConcatenatedReferenceNoType ( InformationElement::Identifier conc_refno_type )

Interface to change the type of reference number in case of concatenation. Only the values InformationElement::ConcatenatedSm16Bit and InformationElement::ConcatenatedSm8Bit are of use. Default setting is InformationElement::ConcatenatedSm16Bit!

void SmsContext::SetDataCodingScheme ( const DataCodingScheme & dcs ) [inline]

TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]) - SMS submit type only.

void SmsContext::SetDestinationAddress ( const PhoneNumber & da )

TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).

void SmsContext::SetDestinationApplicationPortAddress ( SmsPortNo destination_port_no ) [inline]

If an Application Port Address (destination) is set (!= to InvalidPortNo), all the SMS sent with this context, will have the port address applied (as part of the UDH). Default value is InvalidPortNo. (3GPP 23.040 V5.1.0 [9.2.3.24.3] resp. 3GPP 23.040 V5.1.0 [9.2.3.24.4])

void SmsContext::SetMessageNumber ( SmsReferenceNumber mn ) [inline]

TP-MN: TP-Message-Number (3GPP 23.040 V5.1.0 [9.2.3.18]) - SMS command type only.

void SmsContext::SetMessageType ( MessageTypeIndicator::Type mt ) [inline]

TP-MTI: TP-Message-Type-Indicator - 3GPP 23.040 V5.1.0 [9.2.3.1].

void SmsContext::SetOriginatorApplicationPortAddress ( SmsPortNo originator_port_no ) [inline]

If an Application Port Address (originator) is set (!= to InvalidPortNo), all the SMS sent with this context, will have the port address applied (as part of the UDH). Default value is InvalidPortNo. (3GPP 23.040 V5.1.0 [9.2.3.24.3] resp. 3GPP 23.040 V5.1.0 [9.2.3.24.4])

void SmsContext::SetProtocolIdentifier ( const ProtocolIdentifier & pid ) [inline]

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

void SmsContext::SetRejectDuplicates ( BOOLEAN rd ) [inline]

TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25]) - SMS submit type only.

void SmsContext::SetRequestReplyPath ( BOOLEAN rp ) [inline]

TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]) - SMS submit type only.

void SmsContext::SetRequestStatusReport ( BOOLEAN srr ) [inline]

TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).

void SmsContext::SetServiceCenterAddress ( const PhoneNumber & sca )

void SmsContext::SetSingleSrrPerSmsEnabled ( BOOLEAN single_srr ) [inline]

enable/disable the setting of status report request flag for only single (last) part of SMS

void SmsContext::SetSmsReferenceNumber ( SmsReferenceNumber mr ) [inline]

TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).

void SmsContext::SetSubmitParameter | ( | const PhoneNumber & | service_center_address,
 |  | const PhoneNumber & | destination_address,
 |  | const ProtocolIdentifier & | protocol_identifier,
 |  | const DataCodingScheme & | data_coding_scheme,
 |  | const ValidityPeriod & | valitity_period,
 |  | BOOLEAN | status_report_request,
 |  | BOOLEAN | reply_path,
 |  | BOOLEAN | reject_duplicates
 | ) |

Set context parameters with all SMS submit relevant parameter manually and updates the MessageType to SMS submit type. All SMS submit irrelevant data is cleared.

void SmsContext::SetValidityPeriod ( const ValidityPeriod & vp ) [inline]

TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12]) - SMS submit type only.

BOOLEAN SmsContext::ShallRejectDuplicates ( ) const [inline]

Obsolete in Apoxi 1.4.

BOOLEAN SmsContext::ShallRequestReplyPath ( ) const [inline]

Obsolete in Apoxi 1.4.

BOOLEAN SmsContext::ShallRequestStatusReport ( ) const [inline]

Obsolete in Apoxi 1.4.

The documentation for this class was generated from the following files:
  • Asc/SmsContext.hpp
  • Asc/SmsContext.cpp
Generated on Wed Jan 25 01:57:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsControlIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsControlIndArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for SmsControlIndArg:

[legend]
Collaboration diagram for SmsControlIndArg:

[legend]

Public Types

enum | { ID = 5301 }

Public Member Functions

const SimCallControlResult & | GetCallControlResult () const
const PhoneNumber & | GetDestinationNumber () const
const SimAlphaIdentifier & | GetOrig1TextInfoAlpha () const
const PhoneNumber & | GetScNumber () const
const SimAlphaIdentifier & | GetTextInfoAlpha () const
BOOLEAN | IsSimtkRelated () const
void | SetCallControlResult (const SimCallControlResult &call_control_result)
void | SetDestinationNumber (const PhoneNumber &destination_number)
void | SetOrig1TextInfoAlpha (const SimAlphaIdentifier &orig_1_text_info_alpha)
void | SetScNumber (const PhoneNumber &sc_number)
void | SetSimtkRelated (BOOLEAN simtk_related)
void | SetTextInfoAlpha (const SimAlphaIdentifier &text_info_alpha)
SmsControlIndArg ()

Static Public Member Functions

static const SmsControlIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

CallControlIndArg: reflects arguments of signal MN_MO_SMS_CONTROL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsControlIndArg::SmsControlIndArg ( )

Member Function Documentation

const SmsControlIndArg & SmsControlIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimCallControlResult& SmsControlIndArg::GetCallControlResult ( ) const [inline]

const PhoneNumber& SmsControlIndArg::GetDestinationNumber ( ) const [inline]

const SimAlphaIdentifier& SmsControlIndArg::GetOrig1TextInfoAlpha ( ) const [inline]

const PhoneNumber& SmsControlIndArg::GetScNumber ( ) const [inline]

const SimAlphaIdentifier& SmsControlIndArg::GetTextInfoAlpha ( ) const [inline]

BOOLEAN SmsControlIndArg::IsSimtkRelated ( ) const [inline]

void SmsControlIndArg::SetCallControlResult ( const SimCallControlResult & call_control_result ) [inline]

void SmsControlIndArg::SetDestinationNumber ( const PhoneNumber & destination_number ) [inline]

void SmsControlIndArg::SetOrig1TextInfoAlpha ( const SimAlphaIdentifier & orig_1_text_info_alpha ) [inline]

void SmsControlIndArg::SetScNumber ( const PhoneNumber & sc_number ) [inline]

void SmsControlIndArg::SetSimtkRelated ( BOOLEAN simtk_related ) [inline]

void SmsControlIndArg::SetTextInfoAlpha ( const SimAlphaIdentifier & text_info_alpha ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 01:57:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsControlIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsControlIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsControlIndMsg:

[legend]
Collaboration diagram for SmsControlIndMsg:

[legend]

Public Types

enum | { ID = 18707 }

Public Member Functions

virtual Message * | Clone () const
const SmsControlIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SmsControlIndArg &arg)
SmsControlIndMsg (const SmsControlIndArg &arg)
virtual | ~SmsControlIndMsg ()

Detailed Description

SmsControlIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsControlIndMsg::SmsControlIndMsg ( const SmsControlIndArg & arg )

SmsControlIndMsg::~SmsControlIndMsg ( ) [virtual]

Member Function Documentation

Message * SmsControlIndMsg::Clone ( ) const [virtual]

Implements Message.

const SmsControlIndArg& SmsControlIndMsg::GetArg ( ) const [inline]

const MsgMetaData & SmsControlIndMsg::GetMetaData ( ) const [virtual]

Implements Message.

void SmsControlIndMsg::SetArg ( const SmsControlIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:57:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsCountProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsCountProvider Class Reference
[Provider]

#include <Apoxi/Adc/SmsProvider.hpp>

Inheritance diagram for SmsCountProvider:

[legend]
Collaboration diagram for SmsCountProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimPduHandler *sim_pdu_handler, Protector *protector)
virtual INT | RowCount ()
RowCount returns the number of rows.
SmsCountProvider ()
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~SmsCountProvider ()

Protected Attributes

SimPduHandler * m_sim_pdu_handler

Member Typedef Documentation

typedef ThreadSafeProvider SmsCountProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

SmsCountProvider::SmsCountProvider ( )

SmsCountProvider::~SmsCountProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SmsCountProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT SmsCountProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void SmsCountProvider::Init | ( | SimPduHandler * | sim_pdu_handler,
 |  | Protector * | protector
 | ) |

INT SmsCountProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN SmsCountProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

Field Documentation

SimPduHandler* SmsCountProvider::m_sim_pdu_handler [protected]

The documentation for this class was generated from the following files:
  • Adc/SmsProvider.hpp
  • Adc/SmsProvider.cpp
Generated on Wed Jan 25 01:57:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsDeliver Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsDeliver Class Reference

#include <Apoxi/Apc/Sms.hpp>

Inheritance diagram for SmsDeliver:

[legend]
Collaboration diagram for SmsDeliver:

[legend]

Public Types

enum | { ID = MessageTypeIndicator::Deliver }
enum | { c_max_guaranteed_user_data_size = 140 }
typedef Sms | Base

Public Member Functions

DataCodingScheme | GetDataCodingScheme () const
TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]).
INT | GetMaxUserDataSize () const
PhoneNumber | GetOriginatingAddress () const
TP-OA: TP-Originating-Address (3GPP 23.040 V5.1.0 [9.2.3.7]).
UINT8 * | GetPayloadData () const
Returns the address to the start of the payload data (excl. UserDataHeader).
INT | GetPayloadOffset () const
Returns the offset to the start of the payload (excl. UserDataHeader) from the view of the TPDU raw data.
INT | GetPayloadSize () const
Returns the size (in bytes) of the payload (excl. UserDataHeader).
ProtocolIdentifier | GetProtocolIdentifier () const
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
CodedTimeStamp | GetServiceCentreTimeStamp () const
TP-SCTS: TP-Service-Centre-Time-Stamp (3GPP 23.040 V5.1.0 [9.2.3.11]).
WString | GetText () const
UserData | GetUserData () const
TP-UD: TP-User-Data (3GPP 23.040 V5.1.0 [9.2.3.24]) TP-UDL: TP-User-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.16]).
BOOLEAN | MoreMessagesToSend () const
TP-MMS: TP-More-Messages-to-Send (3GPP 23.040 V5.1.0 [9.2.3.2]).
BOOLEAN | ReplyPathExists () const
TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]).
BOOLEAN | ReturnReport () const
TP-SRI: TP-Status-Report-Indication (3GPP 23.040 V5.1.0 [9.2.3.4]).
void | SetProtocolIdentifier (ProtocolIdentifier protocol_identifier)
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
void | SetReplyPathExists (BOOLEAN flag=TRUE)
TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]).
SmsDeliver (Tpdu *tpdu)
BOOLEAN | UserDataHeaderExists () const
TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).
~SmsDeliver ()

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.2.1] - Attention: This class is a wrapper over a data-stream (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Member Typedef Documentation

typedef Sms SmsDeliver::Base

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

anonymous enum

Enumerator:
c_max_guaranteed_user_data_size guaranteed length of UserData (excl. UserDataLength byte) - (3GPP 23.040 V5.1.0 [9.2.2.1])

Constructor & Destructor Documentation

SmsDeliver::SmsDeliver ( Tpdu * tpdu )

SmsDeliver::~SmsDeliver ( )

Member Function Documentation

DataCodingScheme SmsDeliver::GetDataCodingScheme ( ) const

TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]).

INT SmsDeliver::GetMaxUserDataSize ( ) const

Returns the maximum possible size (in bytes) of the userdata (inclusive the userdata-length byte). The size varies dependent on the size of the header-parameter.

PhoneNumber SmsDeliver::GetOriginatingAddress ( ) const

TP-OA: TP-Originating-Address (3GPP 23.040 V5.1.0 [9.2.3.7]).

UINT8 * SmsDeliver::GetPayloadData ( ) const

Returns the address to the start of the payload data (excl. UserDataHeader).

INT SmsDeliver::GetPayloadOffset ( ) const

Returns the offset to the start of the payload (excl. UserDataHeader) from the view of the TPDU raw data.

INT SmsDeliver::GetPayloadSize ( ) const

Returns the size (in bytes) of the payload (excl. UserDataHeader).

ProtocolIdentifier SmsDeliver::GetProtocolIdentifier ( ) const

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

CodedTimeStamp SmsDeliver::GetServiceCentreTimeStamp ( ) const

TP-SCTS: TP-Service-Centre-Time-Stamp (3GPP 23.040 V5.1.0 [9.2.3.11]).

WString SmsDeliver::GetText ( ) const

UserData SmsDeliver::GetUserData ( ) const

TP-UD: TP-User-Data (3GPP 23.040 V5.1.0 [9.2.3.24]) TP-UDL: TP-User-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.16]).

BOOLEAN SmsDeliver::MoreMessagesToSend ( ) const

TP-MMS: TP-More-Messages-to-Send (3GPP 23.040 V5.1.0 [9.2.3.2]).

BOOLEAN SmsDeliver::ReplyPathExists ( ) const

TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]).

BOOLEAN SmsDeliver::ReturnReport ( ) const

TP-SRI: TP-Status-Report-Indication (3GPP 23.040 V5.1.0 [9.2.3.4]).

void SmsDeliver::SetProtocolIdentifier ( ProtocolIdentifier protocol_identifier )

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

void SmsDeliver::SetReplyPathExists ( BOOLEAN flag = TRUE )

TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]).

BOOLEAN SmsDeliver::UserDataHeaderExists ( ) const

TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).

The documentation for this class was generated from the following files:
  • Apc/Sms.hpp
  • Apc/Sms.cpp
Generated on Wed Jan 25 01:58:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SmsDispatcher.hpp>

Inheritance diagram for SmsDispatcher:

[legend]
Collaboration diagram for SmsDispatcher:

[legend]

Public Member Functions

void | SetBlockingSend (BOOLEAN blocking_send)
SmsDispatcher ()
virtual | ~SmsDispatcher ()

Static Public Member Functions

static SmsSendProtector & | GetProtector ()

Protected Member Functions

BOOLEAN | OnMdhNewStatusReportInd (const StackMsgArgument &arg)
BOOLEAN | OnMdhSmsDeletionInd (const StackMsgArgument &arg)
BOOLEAN | OnMdhSmsNewMessageInd (const StackMsgArgument &arg)
BOOLEAN | OnMdhSmsRefreshInd (const StackMsgArgument &arg)
BOOLEAN | OnMdhSmsStorageRefreshInd (const StackMsgArgument &arg)
BOOLEAN | OnMdhSmsUpdStatusRefreshInd (const StackMsgArgument &arg)
BOOLEAN | OnMdhSmsWaitingInd (const StackMsgArgument &arg)
BOOLEAN | OnSmsCapacityAvailable (const StackMsgArgument &arg)
BOOLEAN | OnSmsCapacityExceeded (const StackMsgArgument &arg)
BOOLEAN | OnSmsSendCnf (const StackMsgArgument &arg)
BOOLEAN | OnSmsSendRej (const StackMsgArgument &arg)

Constructor & Destructor Documentation

SmsDispatcher::SmsDispatcher ( )

SmsDispatcher::~SmsDispatcher ( ) [virtual]

Member Function Documentation

static SmsSendProtector& SmsDispatcher::GetProtector ( ) [inline, static]

BOOLEAN SmsDispatcher::OnMdhNewStatusReportInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnMdhSmsDeletionInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnMdhSmsNewMessageInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnMdhSmsRefreshInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnMdhSmsStorageRefreshInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnMdhSmsUpdStatusRefreshInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnMdhSmsWaitingInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnSmsCapacityAvailable ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnSmsCapacityExceeded ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnSmsSendCnf ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsDispatcher::OnSmsSendRej ( const StackMsgArgument & arg ) [protected]

void SmsDispatcher::SetBlockingSend ( BOOLEAN blocking_send ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SmsDispatcher.hpp
  • Asc/SmsDispatcher.cpp
Generated on Wed Jan 25 01:58:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsEditor Class Reference
[Sms]

#include <Applications/Ems/Sms/SmsEditor.hpp>

Inheritance diagram for SmsEditor:

[legend]
Collaboration diagram for SmsEditor:

[legend]

Public Member Functions

virtual BOOLEAN | Backspace ()
UINT8 | CalcFreeChars (InputMapper::Alphabet mode)
virtual SmsComposeWin * | GetComposeWin ()
UINT8 | GetMaxPduSize () const
void | Init (Control *parent, INT input_mapper_id, INT max_char_limit=10, const WCHAR *text=0)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual void | OnGetFocus ()
virtual BOOLEAN | RemoveItem (INT index=-1)
virtual void | ResetCounter ()
all the counters
SmsEditor (Control *parent, INT input_mapper_id, INT max_char_limit=10, const WCHAR *text=0)
SmsEditor ()
virtual | ~SmsEditor ()

Detailed Description

Editor for editing a text inside a horizontal scrollable line. image html SmsEditor.bmp

Constructor & Destructor Documentation

SmsEditor::SmsEditor ( )

SmsEditor::SmsEditor | ( | Control * | parent,
 |  | INT | input_mapper_id,
 |  | INT | max_char_limit = 10,
 |  | const WCHAR * | text = 0
 | ) |

Parameters:
parent | Pointer to the parent-control.
input_mapper_id | Id of Input-Mapper. The resulting instance of the Input-Mapper can be defined in EditConfig::CreateInputMapper().
text | Pointer to text, which will be copied to the internal buffer.

SmsEditor::~SmsEditor ( ) [virtual]

Member Function Documentation

BOOLEAN SmsEditor::Backspace ( ) [virtual]

See also:
AbstractEditor::Backspace()

Reimplemented from AbstractMultiLineEditor.

UINT8 SmsEditor::CalcFreeChars ( InputMapper::Alphabet mode )

SmsComposeWin * SmsEditor::GetComposeWin ( ) [virtual]

GetComposeWin returns compose win

UINT8 SmsEditor::GetMaxPduSize ( ) const [inline]

void SmsEditor::Init | ( | Control * | parent,
 |  | INT | input_mapper_id,
 |  | INT | max_char_limit = 10,
 |  | const WCHAR * | text = 0
 | ) |

Parameters:
parent | Pointer to the parent-control.
input_mapper_id | Id of Input-Mapper. The resulting instance of the Input-Mapper can be defined in EditConfig::CreateInputMapper().
text | Pointer to text, which will be copied to the internal buffer.

BOOLEAN SmsEditor::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
AbstractEditor::InsertItem()

Reimplemented from AbstractMultiLineEditor.

void SmsEditor::OnGetFocus ( ) [virtual]

See also:
AbstractEditor::OnGetFocus()

Reimplemented from AbstractMultiLineEditor.

BOOLEAN SmsEditor::RemoveItem ( INT index = -1 ) [virtual]

See also:
AbstractEditor::RemoveItem()

Reimplemented from AbstractMultiLineEditor.

void SmsEditor::ResetCounter ( ) [virtual]

all the counters

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsEditor.hpp
  • Applications/Ems/Sms/SmsEditor.cpp
Generated on Wed Jan 25 01:58:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsFactory Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsFactory Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SmsFactory.hpp>

Collaboration diagram for SmsFactory:

[legend]

Public Member Functions

BOOLEAN | Append (const BlobObject &blob)
Append the SMS payload (user data) with binary data using a BLOB.
BOOLEAN | Append (const UINT8 *data_ptr, INT len)
Append the SMS payload (user data) with binary data using a byte-buffer.
BOOLEAN | Append (const WString &text)
Append the SMS payload (user data) with WCHAR strings.
BOOLEAN | Append (const BaseInformationElement &data_ptr)
Append the SMS payload (user data) with InformationElements.
Sms::Result Assemble ()
assembles the given input-data to a ready-to-send tpdu.
INT | GetNoOfTpdus () const
returns the number of created tpdu's (only correct after assembling).
const Tpdu & | GetTpdu (INT i=0) const
returns the tpdu of index i.
void | Init (const PhoneNumber &service_centre_address=PhoneNumber(), INT sms_profile_id=0)
Method will get obsolete in later versions, use Init(const SmsContext&) instead!!!
BOOLEAN | Init (const SmsContext &context)
general initialization method for all sms types.
BOOLEAN | InitSmsCommand (SmsReferenceNumber message_number, const PhoneNumber &destination_address=PhoneNumber(), const CommandType &command_type=CommandType(), const ProtocolIdentifier &protocol_identifier=ProtocolIdentifier(), BOOLEAN request_status_report=TRUE)
Method will get obsolete in later versions, use Init(const SmsContext&) instead!!!
BOOLEAN | InitSmsSubmit (const PhoneNumber &destination_address=PhoneNumber(), const ValidityPeriod &validity_period=ValidityPeriod(), const ProtocolIdentifier &protocol_identifier=ProtocolIdentifier(), BOOLEAN request_reply_path=TRUE, BOOLEAN request_status_report=TRUE, BOOLEAN reject_duplicates=TRUE, const DataCodingScheme &data_coding_scheme=DataCodingScheme())
Method will get obsolete in later versions, use Init(const SmsContext&) instead!!!
void | Reset (BOOLEAN reallocate=TRUE)
Resets the whole SmsFactory, and reallocates internal buffer (if reallocate is TRUE).
Sms::Result | Send (BOOLEAN wait_for_response=TRUE, GsmService service=CircuitSwitched)
INT | SetSendingResult (Sms::Result result, const SmsReferenceNumber &reference_number=0xFF)
INT | SetSendingResult (Sms::Result last_sending_result, Sms::Result &subsequent_sending_result, SmsReferenceNumber reference_number=0xFF)
SmsFactory (const PhoneNumber &service_centre_address, INT sms_profile_id)
Method will get obsolete in later versions, use Init(const SmsContext&) instead!!!
SmsFactory ()
Sms::Result Store ()
Sms::Result | Store (const Sms::StorageType storage_type)
stores the Sms on Sim or Flash and returns if the store-request was successful.
~SmsFactory ()

Detailed Description

The class SmsFactory is used to generate mobile originated Sms.

Constructor & Destructor Documentation

SmsFactory::SmsFactory ( )

SmsFactory::~SmsFactory ( )

SmsFactory::SmsFactory | ( | const PhoneNumber & | service_centre_address,
 |  | INT | sms_profile_id
 | ) |

Method will get obsolete in later versions, use Init(const SmsContext&) instead!!!

Member Function Documentation

BOOLEAN SmsFactory::Append ( const BlobObject & blob )

Append the SMS payload (user data) with binary data using a BLOB.

BOOLEAN SmsFactory::Append | ( | const UINT8 * | data_ptr,
 |  | INT | len
 | ) |

Append the SMS payload (user data) with binary data using a byte-buffer.

BOOLEAN SmsFactory::Append ( const WString & text )

Append the SMS payload (user data) with WCHAR strings.

BOOLEAN SmsFactory::Append ( const BaseInformationElement & data_ptr )

Append the SMS payload (user data) with InformationElements.

Sms::Result SmsFactory::Assemble ( )

assembles the given input-data to a ready-to-send tpdu.

INT SmsFactory::GetNoOfTpdus ( ) const

returns the number of created tpdu's (only correct after assembling).

const Tpdu & SmsFactory::GetTpdu ( INT i = 0 ) const

returns the tpdu of index i.

void SmsFactory::Init | ( | const PhoneNumber & | service_centre_address = PhoneNumber(),
 |  | INT | sms_profile_id = 0
 | ) |

Method will get obsolete in later versions, use Init(const SmsContext&) instead!!!

BOOLEAN SmsFactory::Init ( const SmsContext & context )

general initialization method for all sms types.

BOOLEAN SmsFactory::InitSmsCommand | ( | SmsReferenceNumber | message_number,
 |  | const PhoneNumber & | destination_address = PhoneNumber(),
 |  | const CommandType & | command_type = CommandType(),
 |  | const ProtocolIdentifier & | protocol_identifier = ProtocolIdentifier(),
 |  | BOOLEAN | request_status_report = TRUE
 | ) |

Method will get obsolete in later versions, use Init(const SmsContext&) instead!!!

BOOLEAN SmsFactory::InitSmsSubmit | ( | const PhoneNumber & | destination_address = PhoneNumber(),
 |  | const ValidityPeriod & | validity_period = ValidityPeriod(),
 |  | const ProtocolIdentifier & | protocol_identifier = ProtocolIdentifier(),
 |  | BOOLEAN | request_reply_path = TRUE,
 |  | BOOLEAN | request_status_report = TRUE,
 |  | BOOLEAN | reject_duplicates = TRUE,
 |  | const DataCodingScheme & | data_coding_scheme = DataCodingScheme()
 | ) |

Method will get obsolete in later versions, use Init(const SmsContext&) instead!!!

void SmsFactory::Reset ( BOOLEAN reallocate = TRUE )

Resets the whole SmsFactory, and reallocates internal buffer (if reallocate is TRUE).

Sms::Result SmsFactory::Send | ( | BOOLEAN | wait_for_response = TRUE,
 |  | GsmService | service = CircuitSwitched
 | ) |

In the blocking-mode(wait_for_response = TRUE), there is only the Sms::Result as return parameter available. No further parameters, like the assigned reference-number or the short-message-failure-cause, are reported. These parameters will be available in the asynchronous-mode(wait_for_response = FALSE), by listening to the confirmation and rejection message. In the asynchronous-mode only the first Tpdu in the list is sent. The sending of all other Tpdu's respective the next one in the list is triggered by the method SetSendungResult, which has to be called after receiving the sending confirmation. The parameter service defines the service, which is used for sending the Tpdu.

INT SmsFactory::SetSendingResult | ( | Sms::Result | result,
 |  | const SmsReferenceNumber & | reference_number = 0xFF
 | ) |

Is used only for the non-blocking send method (Send(FALSE)), to update the state and the reference number of the SMS. Furthermore this method triggers the sending of the next Tpdu in the list -> the method handles the iteration through the list of Tpdu's for sending means. The iteration is stopped, when the parameter result signals an error. The return-value provides the number of unsent Tpdu's in the list.

INT SmsFactory::SetSendingResult | ( | Sms::Result | last_sending_result,
 |  | Sms::Result & | subsequent_sending_result,
 |  | SmsReferenceNumber | reference_number = 0xFF
 | ) |

Is used only for the non-blocking send method (Send(FALSE)), to update the state and the reference number of the SMS. Furthermore this method triggers the sending of the next Tpdu in the list -> the method handles the iteration through the list of Tpdu's for sending means. The iteration is stopped, when the parameter result signals an error.

Parameters:
last_sending_result | input parameter for the retrieved sending result (via SmsSendConfirmMsg resp. SmsSendRejectMsg)
subsequent_sending_result | output parameter, who describes the return-code of the internal call Send method, which is done as a subsequent sending (for concatenated SMS)
reference_number | input parameter for the retrieved reference number (via SmsSendConfirmMsg resp. SmsSendRejectMsg), which will be assigned to the currently sent TPDU
Returns:
provides the number of unsent Tpdu's in the list.

Sms::Result SmsFactory::Store ( )

stores the Sms on the preferred storage media and returns if the store-request was successful. ADC methods SetInitialPrefferedStorageMedia and ChangePreferredStorageMedia of DataHandler shall be used to control where MT-SMS and MO-SMS shall be stored.

Sms::Result SmsFactory::Store ( const Sms::StorageType storage_type )

stores the Sms on Sim or Flash and returns if the store-request was successful.

The documentation for this class was generated from the following files:
  • Asc/SmsFactory.hpp
  • Asc/SmsFactory.cpp
Generated on Wed Jan 25 01:58:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsFolderProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsFolderProvider Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsFolderProvider.hpp>

Inheritance diagram for SmsFolderProvider:

[legend]
Collaboration diagram for SmsFolderProvider:

[legend]

Public Member Functions

virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
void | Init (Provider *provider)
The same interface as the constructor.
SmsFolderProvider ()
virtual | ~SmsFolderProvider ()

Protected Member Functions

virtual INT | GetMappedColumnId (INT colid)

Constructor & Destructor Documentation

SmsFolderProvider::SmsFolderProvider ( )

SmsFolderProvider::~SmsFolderProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SmsFolderProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

GetChildRow returns the effective row of the child-provider.

Implements AbstractDelegationProvider.

BOOLEAN SmsFolderProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

See also:
Provider::GetDataItem

Implements AbstractDelegationProvider.

INT SmsFolderProvider::GetMappedColumnId ( INT colid ) [protected, virtual]

void SmsFolderProvider::Init ( Provider * provider )

The same interface as the constructor.

Reimplemented from AbstractDelegationProvider.

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsFolderProvider.hpp
  • Applications/Ems/Sms/SmsFolderProvider.cpp
Generated on Wed Jan 25 01:58:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsGetMoreMessageStatusIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsGetMoreMessageStatusIndArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsGetMoreMessageStatusIndArg:

[legend]
Collaboration diagram for SmsGetMoreMessageStatusIndArg:

[legend]

Public Types

enum | { ID = 2566 }

Public Member Functions

const SmsMoreMessageType & | GetSmsMoreMessageType () const
void | SetSmsMoreMessageType (const SmsMoreMessageType &sms_more_message_type)
SmsGetMoreMessageStatusIndArg ()

Static Public Member Functions

static const SmsGetMoreMessageStatusIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsGetMoreMessageStatusIndArg: reflects arguments of signal MN_MORE_MESSAGES_STATUS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsGetMoreMessageStatusIndArg::SmsGetMoreMessageStatusIndArg ( )

Member Function Documentation

const SmsGetMoreMessageStatusIndArg & SmsGetMoreMessageStatusIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SmsMoreMessageType& SmsGetMoreMessageStatusIndArg::GetSmsMoreMessageType ( ) const [inline]

void SmsGetMoreMessageStatusIndArg::SetSmsMoreMessageType ( const SmsMoreMessageType & sms_more_message_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:58:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsGetMoreMessageStatusReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsGetMoreMessageStatusReqArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsGetMoreMessageStatusReqArg:

[legend]
Collaboration diagram for SmsGetMoreMessageStatusReqArg:

[legend]

Public Types

enum | { ID = 2511 }

Public Member Functions

SmsGetMoreMessageStatusReqArg ()

Static Public Member Functions

static const SmsGetMoreMessageStatusReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsGetMoreMessageStatusReqArg: reflects arguments of signal MN_MORE_MESSAGES_STATUS_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsGetMoreMessageStatusReqArg::SmsGetMoreMessageStatusReqArg ( )

Member Function Documentation

const SmsGetMoreMessageStatusReqArg & SmsGetMoreMessageStatusReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:58:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsGsmServiceTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsGsmServiceTextMap Class Reference
[SMS]

Sms service names. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsGsmServiceTextMap:

[legend]
Collaboration diagram for SmsGsmServiceTextMap:

[legend]

Static Public Member Functions

static UINT | GetGsmServiceCount ()
static const WCHAR * | GetGsmServiceName (INT index)

Detailed Description

Sms service names.

Member Function Documentation

static UINT SmsGsmServiceTextMap::GetGsmServiceCount ( ) [inline, static]

static const WCHAR* SmsGsmServiceTextMap::GetGsmServiceName ( INT index ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 01:58:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SmsHandler.hpp>

Collaboration diagram for SmsHandler:

[legend]

Public Types

enum | { ID = SmsHandlerId }

Public Member Functions

BOOLEAN | ChangePreferredStorageMedia (Sms::StorageType storagetype)
changes the prefered storage media for storing SMS
BOOLEAN | EnableResendingSmsOverCs (UINT32 timer)
virtual HandlerId | GetHandlerId () const
SmsMoreMessageType QuerySmsMoreMessageType ()
Query the stack for the SmsMoreMessage status which is currently set.
Sms::Result | SendSms (Tpdu &tpdu, BOOLEAN wait_for_response=TRUE, GsmService service=CircuitSwitched)
BOOLEAN | SetMessageWaitIndicators (const MdhSetWaitIndicatorArray &wia)
Set the wait indicators for message indications.
void | SetSendingResult (Tpdu &tpdu, Sms::Result result, const SmsReferenceNumber &reference_number=0xFF)
BOOLEAN | SetSmsMoreMessageType (const SmsMoreMessageType &type)
SmsHandler ()
Sms::Result | StoreSms (const Tpdu &tpdu) const
Sms::Result | StoreSms (const Tpdu &tpdu, const Sms::StorageType storage_type) const
stores SMS on SIM or Flash and returns if the store-request was successful.
virtual | ~SmsHandler ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsHandler::SmsHandler ( )

SmsHandler::~SmsHandler ( ) [virtual]

Member Function Documentation

BOOLEAN SmsHandler::ChangePreferredStorageMedia ( Sms::StorageType storagetype )

changes the prefered storage media for storing SMS

BOOLEAN SmsHandler::EnableResendingSmsOverCs ( UINT32 timer )

If sending SMS over GPRS fails, then the MS has the possibilty to resend the SMS over CS for an implementation dependent time.

Parameters:
timer specifies, in milli seconds, how long resending over CS will be implementated before switching the service to CS. If <= 0 no SMS resending will be performed.
Returns:
true if the stack support resending over CS.

HandlerId SmsHandler::GetHandlerId ( ) const [virtual]

SmsMoreMessageType SmsHandler::QuerySmsMoreMessageType ( )

Query the stack for the SmsMoreMessage status which is currently set.

Sms::Result SmsHandler::SendSms | ( | Tpdu & | tpdu,
 |  | BOOLEAN | wait_for_response = TRUE,
 |  | GsmService | service = CircuitSwitched
 | ) |

In the blocking-mode(wait_for_response = TRUE), there is only the Sms::Result as return parameter available. No further parameters, like the assigned reference-number or the short-message-failure-cause, are reported. These parameters will be available in the asynchronous-mode(wait_for_response = FALSE), by listening to the confirmation and rejection message. The parameter service defines the service, which is used for sending the Tpdu.

BOOLEAN SmsHandler::SetMessageWaitIndicators ( const MdhSetWaitIndicatorArray & wia )

Set the wait indicators for message indications.

void SmsHandler::SetSendingResult | ( | Tpdu & | tpdu,
 |  | Sms::Result | result,
 |  | const SmsReferenceNumber & | reference_number = 0xFF
 | ) |

is used for non-blocking send method (Send(tpdu, FALSE)), to update the state of the SMS.

BOOLEAN SmsHandler::SetSmsMoreMessageType ( const SmsMoreMessageType & type )

Controls the more message send feature inside the stack, this means the radio link remains open after sending the subsequent TPDUs. SmsMoreMessageType is an eumeration which might have the following values: SmsDisableMoreMessages, SmsEnableMoreMessages, SmsEnableMoreMessagesUntilTimerExpiry.

Sms::Result SmsHandler::StoreSms ( const Tpdu & tpdu ) const

stores the Sms on the preferred storage media and returns if the store-request was successful. ADC methods SetInitialPrefferedStorageMedia and ChangePreferredStorageMedia of DataHandler shall be used to control where MT-SMS and MO-SMS shall be stored.

Sms::Result SmsHandler::StoreSms | ( | const Tpdu & | tpdu,
 |  | const Sms::StorageType | storage_type
 | ) | const

stores SMS on SIM or Flash and returns if the store-request was successful.

The documentation for this class was generated from the following files:
  • Asc/SmsHandler.hpp
  • Asc/SmsHandler.cpp
Generated on Wed Jan 25 01:58:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsIndicationState Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsIndicationState Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsIndicationState.hpp>

Collaboration diagram for SmsIndicationState:

[legend]

Public Types

enum Indication {
PendingIndication = c_pending_priority, MsgWaitingIndication = c_msg_waiting_priority, NewSmsIndication = c_new_sms_priority, NewStatRepIndication = c_new_status_report_priority,
NoIndication
}

Public Member Functions

Indication GetCurrentIndication ()
BOOLEAN | GetMsgWaitingState ()
BOOLEAN | GetNewSmsState ()
BOOLEAN | GetNewStatRepState ()
BOOLEAN | GetPendingState ()
void | SetCurrentIndication (Indication li)
void | SetFlagState (BOOLEAN &flag, const BOOLEAN &enable, Indication cu)
void | SetMsgWaitingState (BOOLEAN enable)
virtual void | SetNewCurrentIndication ()
void | SetNewSmsState (BOOLEAN enable)
void | SetNewStatRepState (BOOLEAN enable)
void | SetPendingState (BOOLEAN enable)
SmsIndicationState (AbstractSmsApp *app)
virtual | ~SmsIndicationState ()

Detailed Description

The SmsIndicationState class is responsible to inform the SmsApplication which indication has to be requested.

Member Enumeration Documentation

enum SmsIndicationState::Indication

Enumerator:
PendingIndication
MsgWaitingIndication
NewSmsIndication
NewStatRepIndication
NoIndication

Constructor & Destructor Documentation

SmsIndicationState::SmsIndicationState ( AbstractSmsApp * app )

SmsIndicationState::~SmsIndicationState ( ) [virtual]

Member Function Documentation

Indication SmsIndicationState::GetCurrentIndication ( ) [inline]

BOOLEAN SmsIndicationState::GetMsgWaitingState ( ) [inline]

BOOLEAN SmsIndicationState::GetNewSmsState ( ) [inline]

BOOLEAN SmsIndicationState::GetNewStatRepState ( ) [inline]

BOOLEAN SmsIndicationState::GetPendingState ( ) [inline]

void SmsIndicationState::SetCurrentIndication ( Indication li ) [inline]

void SmsIndicationState::SetFlagState | ( | BOOLEAN & | flag,
 |  | const BOOLEAN & | enable,
 |  | Indication | cu
 | ) |

void SmsIndicationState::SetMsgWaitingState ( BOOLEAN enable )

void SmsIndicationState::SetNewCurrentIndication ( ) [virtual]

void SmsIndicationState::SetNewSmsState ( BOOLEAN enable )

void SmsIndicationState::SetNewStatRepState ( BOOLEAN enable )

void SmsIndicationState::SetPendingState ( BOOLEAN enable )

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsIndicationState.hpp
  • Applications/Ems/Sms/SmsIndicationState.cpp
Generated on Wed Jan 25 01:58:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsInfoBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsInfoBox Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsAlerts.hpp>

Collaboration diagram for SmsInfoBox:

[legend]

Public Types

enum SmsInfoBoxType {
SmsClass0Type, SmsSendingType, SmsPendingType, SmsAddToPhonebookErrorType,
SmsSetupCallErrorType, SmsDeleteMessage, SmsDeleteAllInbox, SmsDeleteAllOutbox,
SmsDeleteAllReports, SmsDeleteAllArchive, SmsSendType, SmsStoreType,
SmsRejectType, SmsSendErrorType, SmsSendErrorStoreOptionType, SmsStoreErrorType,
SmsDeleteError
}
Types of information boxes. More...

Public Member Functions

Tpdu & GetTpdu ()
void | Init ()
void | SetErrorInfo (const SmsInfoBoxType &type, Sms::Result result_code, INT pending_seg_count)
special method for error message to inform about error results
void | SetSmsInfoBoxType (const SmsInfoBoxType &type)
Sets the corresponding text and info box type (warning, info, question or error).
SmsInfoBox ()
~SmsInfoBox ()

Detailed Description

The SmsAlert is the standard info box for displaying information to the user in an modeless dialog. On the contrary to the SmsAlert, we can also display icons, animations, etc.

Member Enumeration Documentation

enum SmsInfoBox::SmsInfoBoxType

Types of information boxes.

Enumerator:
SmsClass0Type
SmsSendingType
SmsPendingType
SmsAddToPhonebookErrorType
SmsSetupCallErrorType
SmsDeleteMessage
SmsDeleteAllInbox
SmsDeleteAllOutbox
SmsDeleteAllReports
SmsDeleteAllArchive
SmsSendType
SmsStoreType
SmsRejectType
SmsSendErrorType
SmsSendErrorStoreOptionType
SmsStoreErrorType
SmsDeleteError

Constructor & Destructor Documentation

SmsInfoBox::SmsInfoBox ( )

SmsInfoBox::~SmsInfoBox ( )

Member Function Documentation

Tpdu& SmsInfoBox::GetTpdu ( ) [inline]

void SmsInfoBox::Init ( )

void SmsInfoBox::SetErrorInfo | ( | const SmsInfoBoxType & | type,
 |  | Sms::Result | result_code,
 |  | INT | pending_seg_count
 | ) |

special method for error message to inform about error results

void SmsInfoBox::SetSmsInfoBoxType ( const SmsInfoBoxType & type )

Sets the corresponding text and info box type (warning, info, question or error).

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsAlerts.hpp
  • Applications/Ems/Sms/SmsAlerts.cpp
Generated on Wed Jan 25 01:58:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsMessageWaitingChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsMessageWaitingChangedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsMessageWaitingChangedMsg:

[legend]
Collaboration diagram for SmsMessageWaitingChangedMsg:

[legend]

Public Types

enum | { ID = 18924 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SmsMessageWaitingChangedMsg (ExecutionContext *context)
virtual | ~SmsMessageWaitingChangedMsg ()

Detailed Description

SmsMessageWaitingChangedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsMessageWaitingChangedMsg::SmsMessageWaitingChangedMsg ( ExecutionContext * context )

SmsMessageWaitingChangedMsg::~SmsMessageWaitingChangedMsg ( ) [virtual]

Member Function Documentation

Message * SmsMessageWaitingChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SmsMessageWaitingChangedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:58:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsMsgTypeTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsMsgTypeTextMap Class Reference
[SMS]

Sms message types. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsMsgTypeTextMap:

[legend]
Collaboration diagram for SmsMsgTypeTextMap:

[legend]

Static Public Member Functions

static UINT | GetMsgTypeCount ()
static const WCHAR * | GetMsgTypeName (INT index)

Detailed Description

Sms message types.

Member Function Documentation

static UINT SmsMsgTypeTextMap::GetMsgTypeCount ( ) [inline, static]

static const WCHAR* SmsMsgTypeTextMap::GetMsgTypeName ( INT index ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 01:58:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsMsgTypeUsageTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsMsgTypeUsageTextMap Class Reference
[SMS]

Sms message type usage. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsMsgTypeUsageTextMap:

[legend]
Collaboration diagram for SmsMsgTypeUsageTextMap:

[legend]

Static Public Member Functions

static UINT | GetMsgTypeUsageCount ()
static const WCHAR * | GetMsgTypeUsageName (INT index)

Detailed Description

Sms message type usage.

Member Function Documentation

static UINT SmsMsgTypeUsageTextMap::GetMsgTypeUsageCount ( ) [inline, static]

static const WCHAR* SmsMsgTypeUsageTextMap::GetMsgTypeUsageName ( INT index ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 01:58:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsMsgWaitingProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsMsgWaitingProvider Class Reference
[Provider]

#include <Apoxi/Adc/SmsProvider.hpp>

Inheritance diagram for SmsMsgWaitingProvider:

[legend]
Collaboration diagram for SmsMsgWaitingProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimPduHandler *sim_pdu_handler, Protector *protector)
virtual INT | RowCount ()
RowCount returns the number of rows.
void | SetMdhWaitingIndicatorArray (const MdhWaitIndicatorArray &wia)
SmsMsgWaitingProvider ()
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~SmsMsgWaitingProvider ()

Protected Attributes

SimPduHandler * m_sim_pdu_handler

Member Typedef Documentation

typedef ThreadSafeProvider SmsMsgWaitingProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

SmsMsgWaitingProvider::SmsMsgWaitingProvider ( )

SmsMsgWaitingProvider::~SmsMsgWaitingProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SmsMsgWaitingProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT SmsMsgWaitingProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void SmsMsgWaitingProvider::Init | ( | SimPduHandler * | sim_pdu_handler,
 |  | Protector * | protector
 | ) |

INT SmsMsgWaitingProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

void SmsMsgWaitingProvider::SetMdhWaitingIndicatorArray ( const MdhWaitIndicatorArray & wia )

BOOLEAN SmsMsgWaitingProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

Field Documentation

SimPduHandler* SmsMsgWaitingProvider::m_sim_pdu_handler [protected]

The documentation for this class was generated from the following files:
  • Adc/SmsProvider.hpp
  • Adc/SmsProvider.cpp
Generated on Wed Jan 25 01:58:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsNewMessageIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsNewMessageIndArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsNewMessageIndArg:

[legend]
Collaboration diagram for SmsNewMessageIndArg:

[legend]

Public Types

enum | { ID = 2560 }

Public Member Functions

const DataCodingScheme & | GetDataCodingScheme () const
const PhoneNumber & | GetOaPhoneNumber () const
const ProtocolIdentifier & | GetProtocolIdentifier () const
INT | GetStoragePosition () const
const Sms::StorageType & | GetStorageType () const
void | SetDataCodingScheme (const DataCodingScheme &data_coding_scheme)
void | SetOaPhoneNumber (const PhoneNumber &oa_phone_number)
void | SetProtocolIdentifier (const ProtocolIdentifier &protocol_identifier)
void | SetStoragePosition (INT storage_position)
void | SetStorageType (const Sms::StorageType &storage_type)
SmsNewMessageIndArg ()

Static Public Member Functions

static const SmsNewMessageIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsNewMessageIndArg: reflects arguments of signal MN_SMS_NEW_MSG_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsNewMessageIndArg::SmsNewMessageIndArg ( )

Member Function Documentation

const SmsNewMessageIndArg & SmsNewMessageIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const DataCodingScheme& SmsNewMessageIndArg::GetDataCodingScheme ( ) const [inline]

const PhoneNumber& SmsNewMessageIndArg::GetOaPhoneNumber ( ) const [inline]

const ProtocolIdentifier& SmsNewMessageIndArg::GetProtocolIdentifier ( ) const [inline]

INT SmsNewMessageIndArg::GetStoragePosition ( ) const [inline]

const Sms::StorageType& SmsNewMessageIndArg::GetStorageType ( ) const [inline]

void SmsNewMessageIndArg::SetDataCodingScheme ( const DataCodingScheme & data_coding_scheme ) [inline]

void SmsNewMessageIndArg::SetOaPhoneNumber ( const PhoneNumber & oa_phone_number ) [inline]

void SmsNewMessageIndArg::SetProtocolIdentifier ( const ProtocolIdentifier & protocol_identifier ) [inline]

void SmsNewMessageIndArg::SetStoragePosition ( INT storage_position ) [inline]

void SmsNewMessageIndArg::SetStorageType ( const Sms::StorageType & storage_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:58:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsNewMessageMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsNewMessageMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsNewMessageMsg:

[legend]
Collaboration diagram for SmsNewMessageMsg:

[legend]

Public Types

enum | { ID = 18900 }

Public Member Functions

virtual Message * | Clone () const
const SmsNewMessageIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SmsNewMessageIndArg &arg)
SmsNewMessageMsg (ExecutionContext *context, const SmsNewMessageIndArg &arg)
virtual | ~SmsNewMessageMsg ()

Detailed Description

SmsNewMessageMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsNewMessageMsg::SmsNewMessageMsg | ( | ExecutionContext * | context,
 |  | const SmsNewMessageIndArg & | arg
 | ) |

SmsNewMessageMsg::~SmsNewMessageMsg ( ) [virtual]

Member Function Documentation

Message * SmsNewMessageMsg::Clone ( ) const [virtual]

Implements Message.

const SmsNewMessageIndArg& SmsNewMessageMsg::GetArg ( ) const [inline]

const MsgMetaData & SmsNewMessageMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SmsNewMessageMsg::SetArg ( const SmsNewMessageIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:58:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsNewSocketDataMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsNewSocketDataMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsNewSocketDataMsg:

[legend]
Collaboration diagram for SmsNewSocketDataMsg:

[legend]

Public Types

enum | { ID = 18902 }

Public Member Functions

virtual Message * | Clone () const
const DateTime & | GetDateTime () const
const DataCodingScheme & | GetDcs () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetSca () const
const PhoneNumber & | GetSenderPhonenumber () const
const SmsPortNo & | GetSenderPortNo () const
const SmsPortNo & | GetSmsPortNo () const
void | SetDateTime (const DateTime &date_time)
void | SetDcs (const DataCodingScheme &dcs)
void | SetSca (const PhoneNumber &sca)
void | SetSenderPhonenumber (const PhoneNumber &sender_phonenumber)
void | SetSenderPortNo (const SmsPortNo &sender_port_no)
void | SetSmsPortNo (const SmsPortNo &sms_port_no)
SmsNewSocketDataMsg (ExecutionContext *context, const SmsPortNo &sms_port_no, const PhoneNumber &sender_phonenumber, const DateTime &date_time, const DataCodingScheme &dcs, const SmsPortNo &sender_port_no, const PhoneNumber &sca)
virtual | ~SmsNewSocketDataMsg ()

Detailed Description

SmsNewSocketDataMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsNewSocketDataMsg::SmsNewSocketDataMsg | ( | ExecutionContext * | context,
 |  | const SmsPortNo & | sms_port_no,
 |  | const PhoneNumber & | sender_phonenumber,
 |  | const DateTime & | date_time,
 |  | const DataCodingScheme & | dcs,
 |  | const SmsPortNo & | sender_port_no,
 |  | const PhoneNumber & | sca
 | ) |

SmsNewSocketDataMsg::~SmsNewSocketDataMsg ( ) [virtual]

Member Function Documentation

Message * SmsNewSocketDataMsg::Clone ( ) const [virtual]

Implements Message.

const DateTime& SmsNewSocketDataMsg::GetDateTime ( ) const [inline]

const DataCodingScheme& SmsNewSocketDataMsg::GetDcs ( ) const [inline]

const MsgMetaData & SmsNewSocketDataMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& SmsNewSocketDataMsg::GetSca ( ) const [inline]

const PhoneNumber& SmsNewSocketDataMsg::GetSenderPhonenumber ( ) const [inline]

const SmsPortNo& SmsNewSocketDataMsg::GetSenderPortNo ( ) const [inline]

const SmsPortNo& SmsNewSocketDataMsg::GetSmsPortNo ( ) const [inline]

void SmsNewSocketDataMsg::SetDateTime ( const DateTime & date_time ) [inline]

void SmsNewSocketDataMsg::SetDcs ( const DataCodingScheme & dcs ) [inline]

void SmsNewSocketDataMsg::SetSca ( const PhoneNumber & sca ) [inline]

void SmsNewSocketDataMsg::SetSenderPhonenumber ( const PhoneNumber & sender_phonenumber ) [inline]

void SmsNewSocketDataMsg::SetSenderPortNo ( const SmsPortNo & sender_port_no ) [inline]

void SmsNewSocketDataMsg::SetSmsPortNo ( const SmsPortNo & sms_port_no ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:58:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsNewStatusReportIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsNewStatusReportIndArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsNewStatusReportIndArg:

[legend]
Collaboration diagram for SmsNewStatusReportIndArg:

[legend]

Public Types

enum | { ID = 2561 }

Public Member Functions

const PhoneNumber & | GetRecipientPhoneNumber () const
const SmsReferenceNumber & | GetReferenceNumber () const
const ShortMessageStatus & | GetShortMessageStatus () const
const MdhSmsrLocation & | GetSmsrLocation () const
INT | GetStoragePosition () const
const Sms::StorageType & | GetStorageType () const
void | SetRecipientPhoneNumber (const PhoneNumber &recipient_phone_number)
void | SetReferenceNumber (const SmsReferenceNumber &reference_number)
void | SetShortMessageStatus (const ShortMessageStatus &short_message_status)
void | SetSmsrLocation (const MdhSmsrLocation &smsr_location)
void | SetStoragePosition (INT storage_position)
void | SetStorageType (const Sms::StorageType &storage_type)
SmsNewStatusReportIndArg ()

Static Public Member Functions

static const SmsNewStatusReportIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsNewStatusReportIndArg: reflects arguments of signal MN_SMS_NEW_STATUS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsNewStatusReportIndArg::SmsNewStatusReportIndArg ( )

Member Function Documentation

const SmsNewStatusReportIndArg & SmsNewStatusReportIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PhoneNumber& SmsNewStatusReportIndArg::GetRecipientPhoneNumber ( ) const [inline]

const SmsReferenceNumber& SmsNewStatusReportIndArg::GetReferenceNumber ( ) const [inline]

const ShortMessageStatus& SmsNewStatusReportIndArg::GetShortMessageStatus ( ) const [inline]

const MdhSmsrLocation& SmsNewStatusReportIndArg::GetSmsrLocation ( ) const [inline]

INT SmsNewStatusReportIndArg::GetStoragePosition ( ) const [inline]

const Sms::StorageType& SmsNewStatusReportIndArg::GetStorageType ( ) const [inline]

void SmsNewStatusReportIndArg::SetRecipientPhoneNumber ( const PhoneNumber & recipient_phone_number ) [inline]

void SmsNewStatusReportIndArg::SetReferenceNumber ( const SmsReferenceNumber & reference_number ) [inline]

void SmsNewStatusReportIndArg::SetShortMessageStatus ( const ShortMessageStatus & short_message_status ) [inline]

void SmsNewStatusReportIndArg::SetSmsrLocation ( const MdhSmsrLocation & smsr_location ) [inline]

void SmsNewStatusReportIndArg::SetStoragePosition ( INT storage_position ) [inline]

void SmsNewStatusReportIndArg::SetStorageType ( const Sms::StorageType & storage_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:58:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsNewStatusReportMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsNewStatusReportMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsNewStatusReportMsg:

[legend]
Collaboration diagram for SmsNewStatusReportMsg:

[legend]

Public Types

enum | { ID = 18901 }

Public Member Functions

virtual Message * | Clone () const
const SmsNewStatusReportIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SmsNewStatusReportIndArg &arg)
SmsNewStatusReportMsg (ExecutionContext *context, const SmsNewStatusReportIndArg &arg)
virtual | ~SmsNewStatusReportMsg ()

Detailed Description

SmsNewStatusReportMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsNewStatusReportMsg::SmsNewStatusReportMsg | ( | ExecutionContext * | context,
 |  | const SmsNewStatusReportIndArg & | arg
 | ) |

SmsNewStatusReportMsg::~SmsNewStatusReportMsg ( ) [virtual]

Member Function Documentation

Message * SmsNewStatusReportMsg::Clone ( ) const [virtual]

Implements Message.

const SmsNewStatusReportIndArg& SmsNewStatusReportMsg::GetArg ( ) const [inline]

const MsgMetaData & SmsNewStatusReportMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SmsNewStatusReportMsg::SetArg ( const SmsNewStatusReportIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:58:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsParamProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsParamProvider Class Reference
[Provider]

#include <Apoxi/Adc/SmsParamProvider.hpp>

Inheritance diagram for SmsParamProvider:

[legend]
Collaboration diagram for SmsParamProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | AppendRow ()
Append a row.
virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimSmsParamHandler *smsp_handler, Protector *protector)
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
SmsParamProvider ()
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~SmsParamProvider ()

Detailed Description

SmsParamProvider is the provider to retrieve the sms parameters as defined in GSM 11.11 V8.2.0 10.5.6. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_sms_parameter_provider_id

Following column ids are defined: c_service_center_address_id :PhoneNumberType: c_destination_address_id :PhoneNumberType: c_protocol_identifier_id :NumberType: c_data_coding_scheme_id :NumberType: c_validity_period_id :NumberType: c_sms_param_name_id :WStringType:

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider SmsParamProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

SmsParamProvider::SmsParamProvider ( )

SmsParamProvider::~SmsParamProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SmsParamProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

BOOLEAN SmsParamProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN SmsParamProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN SmsParamProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT SmsParamProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void SmsParamProvider::Init | ( | SimSmsParamHandler * | smsp_handler,
 |  | Protector * | protector
 | ) |

INT SmsParamProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

INT SmsParamProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN SmsParamProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN SmsParamProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

BOOLEAN SmsParamProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/SmsParamProvider.hpp
  • Adc/SmsParamProvider.cpp
Generated on Wed Jan 25 01:58:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsParamRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsParamRecord Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

INT | length
UINT8 | val [c_max_smsparam_entry_len]

Field Documentation

INT SmsParamRecord::length

UINT8 SmsParamRecord::val[c_max_smsparam_entry_len]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:58:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsPortDataRecvMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsPortDataRecvMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsPortDataRecvMsg:

[legend]
Collaboration diagram for SmsPortDataRecvMsg:

[legend]

Public Types

enum | { ID = 18903 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetSenderPhonenumber () const
const SmsPortNo & | GetSmsPortNo () const
void | SetSenderPhonenumber (const PhoneNumber &sender_phonenumber)
void | SetSmsPortNo (const SmsPortNo &sms_port_no)
SmsPortDataRecvMsg (ExecutionContext *context, const SmsPortNo &sms_port_no, const PhoneNumber &sender_phonenumber)
virtual | ~SmsPortDataRecvMsg ()

Detailed Description

SmsPortDataRecvMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsPortDataRecvMsg::SmsPortDataRecvMsg | ( | ExecutionContext * | context,
 |  | const SmsPortNo & | sms_port_no,
 |  | const PhoneNumber & | sender_phonenumber
 | ) |

SmsPortDataRecvMsg::~SmsPortDataRecvMsg ( ) [virtual]

Member Function Documentation

Message * SmsPortDataRecvMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SmsPortDataRecvMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& SmsPortDataRecvMsg::GetSenderPhonenumber ( ) const [inline]

const SmsPortNo& SmsPortDataRecvMsg::GetSmsPortNo ( ) const [inline]

void SmsPortDataRecvMsg::SetSenderPhonenumber ( const PhoneNumber & sender_phonenumber ) [inline]

void SmsPortDataRecvMsg::SetSmsPortNo ( const SmsPortNo & sms_port_no ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:58:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsPrefStorageMediaChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsPrefStorageMediaChangedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsPrefStorageMediaChangedMsg:

[legend]
Collaboration diagram for SmsPrefStorageMediaChangedMsg:

[legend]

Public Types

enum | { ID = 18923 }

Public Member Functions

virtual Message * | Clone () const
const Sms::StorageType & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const Sms::StorageType &arg)
SmsPrefStorageMediaChangedMsg (ExecutionContext *context, const Sms::StorageType &arg)
virtual | ~SmsPrefStorageMediaChangedMsg ()

Detailed Description

SmsPrefStorageMediaChangedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsPrefStorageMediaChangedMsg::SmsPrefStorageMediaChangedMsg | ( | ExecutionContext * | context,
 |  | const Sms::StorageType & | arg
 | ) |

SmsPrefStorageMediaChangedMsg::~SmsPrefStorageMediaChangedMsg ( ) [virtual]

Member Function Documentation

Message * SmsPrefStorageMediaChangedMsg::Clone ( ) const [virtual]

Implements Message.

const Sms::StorageType& SmsPrefStorageMediaChangedMsg::GetArg ( ) const [inline]

const MsgMetaData & SmsPrefStorageMediaChangedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SmsPrefStorageMediaChangedMsg::SetArg ( const Sms::StorageType & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:58:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsProvider Class Reference
[Provider]

#include <Apoxi/Adc/SmsProvider.hpp>

Inheritance diagram for SmsProvider:

[legend]
Collaboration diagram for SmsProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
BOOLEAN | CopyTo (INT row, const Sms::StorageType type, ProtocolIdentifier pid, INT &src_row, INT &dst_row)
BOOLEAN | CopyTo (INT row, const Sms::StorageType type, INT &src_row, INT &dst_row)
virtual BOOLEAN | DeleteAllRows (ProviderListener *listener=0)
Deletes all rows of a provider.
BOOLEAN | DeleteAllSms (SmsDeleteStatus criteriamask, BOOLEAN smsreports=FALSE)
virtual BOOLEAN | DeleteRow (INT row)
Delete the specified row.
INT | FindRowByTpduNumber (INT tpdu_no)
returns the row-number for a given tpdu-number
void | ForceNormalUpdateOnStartup ()
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProgress ()
GetProgress indicates the progress of the updating in percent.
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimPduHandler *sim_pdu_handler, Protector *protector)
virtual INT | MaxRowCount ()
returns the maximum number of sms entries of each provider
BOOLEAN | NotifyAsyncChange ()
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT column_id)
SmsProvider ()
virtual BOOLEAN | ToggleRow (INT row)
changes the states of a row inside a provider, unread->read and unsent->sent
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~SmsProvider ()

Static Public Member Functions

static void | SetEmptyNumberText (const WCHAR *text)
Specifies the text inserted in concateneted SMS if a part is missing.

Protected Member Functions

BOOLEAN | GetDataItem (INT column_id, DataItem &item, TpduHeaderInformation *headerinformation)
virtual Tpdu::Status | GetDestinationTpduStatus () const
virtual SmsFilterType | GetSmsFilterType () const

Protected Attributes

SimPduHandler * m_sim_pdu_handler

Detailed Description

em>SmsProvider is the base provider of all sms providers. It allows retrieving pdus from and changing the state of the pdus on the sim. It presents all sms within the system. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_sms_provider_id

Following column ids are defined: c_sms_recno_id :NumberType: c_sms_pos_id :NumberType: return the effective position on sim or nvram c_sms_status_id :NumberType: return Tpdu::Status enum c_sms_string_id :WStringType: c_sms_phonenumber_id :PhoneNumberType: c_sms_dcs_id :NumberType: return DataCodingScheme value c_sms_msg_class_id :NumberType: return DataCodingScheme::MessageClass enum c_sms_msg_type_id :NumberType: return MessageTypeIndicator::Type enum c_sms_coding_group_id :NumberType: return DataCodingScheme::GroupId enum c_sms_datetime_id :DateTimeType: c_sms_date_id :DateType: c_sms_time_id :TimeType: c_sms_pdu_data_id :GenericType: c_sms_compound_sms_id :GenericType: cast the generic object to SmsCompoundItem c_sms_message_status_id :NumberType: use ShortMessageStatus class for wrapping c_sms_conc_status_id :NumberType: return ConcatenetedStatus enumeration c_sms_refno_id :NumberType: return message reference number c_sms_storage_media_id :NumberType: returns the Sms::StorageType c_sms_protid_id :NumberType: returns the Protocolidentifier c_sms_sca_id :PhoneNumberType: returns the service center address c_sms_reply_path_flag_id :NumberType: cast to BOOLEAN c_sms_conc_tpdu_num_id :NumberType: returns the number of pdus of a conc. SMS c_sms_no_pdu_sim_id :NumberType: returns the number of pdus on Sim c_sms_no_pdu_flash_id :NumberType: returns the number of pdus in Flash c_sms_header_text_id :WStringType: returns the header text of MO-SMS

Member Typedef Documentation

typedef ThreadSafeProvider SmsProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

SmsProvider::SmsProvider ( )

SmsProvider::~SmsProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SmsProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN SmsProvider::CopyTo | ( | INT | row,
 |  | const Sms::StorageType | type,
 |  | ProtocolIdentifier | pid,
 |  | INT & | src_row,
 |  | INT & | dst_row
 | ) |

performs copying of MOSMS & MTSMS to desired storage media (SIM/FLASH) and allows implicit change of PID for copied SMS

Parameters:
row | input parameter for row to copy
type | input parameter for desired storage media type
in | input parameter that specifies the new PID for copied row
src_row | output parameter for getting position of source row (differs from original row in case of change during store procedure)
dst_row | output parameter for getting destination position of copied row

BOOLEAN SmsProvider::CopyTo | ( | INT | row,
 |  | const Sms::StorageType | type,
 |  | INT & | src_row,
 |  | INT & | dst_row
 | ) |

performs copying of MOSMS & MTSMS to desired storage media (SIM/FLASH)

Parameters:
row | input parameter for row to copy
type | input parameter for desired storage media type
src_row | output parameter for getting position of source row (differs from original row in case of change during store procedure)
dst_row | output parameter for getting destination position of copied row

BOOLEAN SmsProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual]

Deletes all rows of a provider.

Reimplemented from Provider.

Reimplemented in SmsClass0Provider.

BOOLEAN SmsProvider::DeleteAllSms | ( | SmsDeleteStatus | criteriamask,
 |  | BOOLEAN | smsreports = FALSE
 | ) | [inline]

deletes sms which fullfill the criteriamask, the deletion of smsreports or sms can be controlled via the smsreports flag. provider must be casted to SmsProvider to use that interface. The enumeration SmsDeleteStatus is defined in SimPduHandler.hpp

BOOLEAN SmsProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

Reimplemented in SmsClass0Provider.

INT SmsProvider::FindRowByTpduNumber ( INT tpdu_no )

returns the row-number for a given tpdu-number

void SmsProvider::ForceNormalUpdateOnStartup ( ) [inline]

BOOLEAN SmsProvider::GetDataItem | ( | INT | column_id,
 |  | DataItem & | item,
 |  | TpduHeaderInformation * | headerinformation
 | ) | [protected]

BOOLEAN SmsProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

Reimplemented in SmsClass0Provider.

virtual Tpdu::Status SmsProvider::GetDestinationTpduStatus ( ) const [inline, protected, virtual]

Reimplemented in SmsReadProvider, SmsSentProvider, SmsUnreadProvider, and SmsUnsentProvider.

INT SmsProvider::GetProgress ( ) [virtual]

GetProgress indicates the progress of the updating in percent.

Reimplemented from Provider.

Reimplemented in SmsClass0Provider.

INT SmsProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

Reimplemented in SmsClass0Provider, SmsReadProvider, SmsSentProvider, SmsUnreadProvider, and SmsUnsentProvider.

virtual SmsFilterType SmsProvider::GetSmsFilterType ( ) const [inline, protected, virtual]

Reimplemented in SmsReadProvider, SmsSentProvider, SmsUnreadProvider, and SmsUnsentProvider.

void SmsProvider::Init | ( | SimPduHandler * | sim_pdu_handler,
 |  | Protector * | protector
 | ) |

INT SmsProvider::MaxRowCount ( ) [virtual]

returns the maximum number of sms entries of each provider

Reimplemented from Provider.

Reimplemented in SmsClass0Provider.

BOOLEAN SmsProvider::NotifyAsyncChange ( )

INT SmsProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

Reimplemented in SmsClass0Provider, SmsReadProvider, SmsSentProvider, SmsUnreadProvider, and SmsUnsentProvider.

BOOLEAN SmsProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | column_id
 | ) | [virtual]

Reimplemented from Provider.

static void SmsProvider::SetEmptyNumberText ( const WCHAR * text ) [inline, static]

Specifies the text inserted in concateneted SMS if a part is missing.

BOOLEAN SmsProvider::ToggleRow ( INT row ) [virtual]

changes the states of a row inside a provider, unread->read and unsent->sent

Reimplemented from Provider.

Reimplemented in SmsClass0Provider.

BOOLEAN SmsProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

Reimplemented in SmsClass0Provider.

Field Documentation

SimPduHandler* SmsProvider::m_sim_pdu_handler [protected]

The documentation for this class was generated from the following files:
  • Adc/SmsProvider.hpp
  • Adc/SmsProvider.cpp
Generated on Wed Jan 25 01:58:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsrData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsrData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [29]

Field Documentation

UINT8 SmsrData::val[29]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:58:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsReadProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsReadProvider Class Reference
[Provider]

#include <Apoxi/Adc/SmsReadProvider.hpp>

Inheritance diagram for SmsReadProvider:

[legend]
Collaboration diagram for SmsReadProvider:

[legend]

Public Member Functions

virtual INT | GetProviderId () const
Returns the provider id.
virtual INT | RowCount ()
RowCount returns the number of rows.
SmsReadProvider ()
virtual | ~SmsReadProvider ()

Protected Member Functions

virtual Tpdu::Status | GetDestinationTpduStatus () const
virtual SmsFilterType | GetSmsFilterType () const

Detailed Description

SmsReadProvider is the provider to retrieve the read sms from the sim. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_sms_read_provider_id

Please refer to SmsProvider for possible columns

NOTE: Please do not instantiate this class.

Constructor & Destructor Documentation

SmsReadProvider::SmsReadProvider ( )

SmsReadProvider::~SmsReadProvider ( ) [virtual]

Member Function Documentation

virtual Tpdu::Status SmsReadProvider::GetDestinationTpduStatus ( ) const [inline, protected, virtual]

Reimplemented from SmsProvider.

INT SmsReadProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Reimplemented from SmsProvider.

virtual SmsFilterType SmsReadProvider::GetSmsFilterType ( ) const [inline, protected, virtual]

Reimplemented from SmsProvider.

INT SmsReadProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Reimplemented from SmsProvider.

The documentation for this class was generated from the following files:
  • Adc/SmsReadProvider.hpp
  • Adc/SmsReadProvider.cpp
Generated on Wed Jan 25 01:59:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsResultTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsResultTextMap Class Reference
[SMS]

Sms result texts. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsResultTextMap:

[legend]
Collaboration diagram for SmsResultTextMap:

[legend]

Static Public Member Functions

static const WCHAR * GetResult (Sms::Result result)

Detailed Description

Sms result texts.

Member Function Documentation

static const WCHAR* SmsResultTextMap::GetResult ( Sms::Result result ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 01:59:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSendCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSendCnfArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsSendCnfArg:

[legend]
Collaboration diagram for SmsSendCnfArg:

[legend]

Public Types

enum | { ID = 2562 }

Public Member Functions

const SmsReferenceNumber & | GetReferenceNumber () const
const Sms::Result & | GetResult () const
const ShortMessageFailureCause & | GetShortMessageFailureCause () const
const SimTkTransactionId & | GetTid () const
BOOLEAN | IsShortMessageFailure () const
void | SetReferenceNumber (const SmsReferenceNumber &reference_number)
void | SetResult (const Sms::Result &result)
void | SetShortMessageFailure (BOOLEAN short_message_failure)
void | SetShortMessageFailureCause (const ShortMessageFailureCause &short_message_failure_cause)
void | SetTid (const SimTkTransactionId &tid)
SmsSendCnfArg ()

Static Public Member Functions

static const SmsSendCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsSendCfnArg: reflects arguments of signal MN_SMS_SEND_PDU_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsSendCnfArg::SmsSendCnfArg ( )

Member Function Documentation

const SmsSendCnfArg & SmsSendCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SmsReferenceNumber& SmsSendCnfArg::GetReferenceNumber ( ) const [inline]

const Sms::Result& SmsSendCnfArg::GetResult ( ) const [inline]

const ShortMessageFailureCause& SmsSendCnfArg::GetShortMessageFailureCause ( ) const [inline]

const SimTkTransactionId& SmsSendCnfArg::GetTid ( ) const [inline]

BOOLEAN SmsSendCnfArg::IsShortMessageFailure ( ) const [inline]

void SmsSendCnfArg::SetReferenceNumber ( const SmsReferenceNumber & reference_number ) [inline]

void SmsSendCnfArg::SetResult ( const Sms::Result & result ) [inline]

void SmsSendCnfArg::SetShortMessageFailure ( BOOLEAN short_message_failure ) [inline]

void SmsSendCnfArg::SetShortMessageFailureCause ( const ShortMessageFailureCause & short_message_failure_cause ) [inline]

void SmsSendCnfArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:59:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSendConfirmMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSendConfirmMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsSendConfirmMsg:

[legend]
Collaboration diagram for SmsSendConfirmMsg:

[legend]

Public Types

enum | { ID = 18910 }

Public Member Functions

virtual Message * | Clone () const
const SmsSendCnfArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SmsSendCnfArg &arg)
SmsSendConfirmMsg (ExecutionContext *context, const SmsSendCnfArg &arg)
virtual | ~SmsSendConfirmMsg ()

Detailed Description

SmsSendConfirmMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsSendConfirmMsg::SmsSendConfirmMsg | ( | ExecutionContext * | context,
 |  | const SmsSendCnfArg & | arg
 | ) |

SmsSendConfirmMsg::~SmsSendConfirmMsg ( ) [virtual]

Member Function Documentation

Message * SmsSendConfirmMsg::Clone ( ) const [virtual]

Implements Message.

const SmsSendCnfArg& SmsSendConfirmMsg::GetArg ( ) const [inline]

const MsgMetaData & SmsSendConfirmMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SmsSendConfirmMsg::SetArg ( const SmsSendCnfArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:59:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSendDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSendDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SmsSendDispatcher.hpp>

Inheritance diagram for SmsSendDispatcher:

[legend]
Collaboration diagram for SmsSendDispatcher:

[legend]

Public Member Functions

const SmsReferenceNumber & | GetReferenceNumber () const
const Sms::Result & | GetResult () const
const ShortMessageFailureCause & | GetShortMessageFailureCause () const
BOOLEAN | ShortMessageFailureExists () const
SmsSendDispatcher ()
virtual | ~SmsSendDispatcher ()

Protected Member Functions

BOOLEAN | OnSmsSendCnf (const StackMsgArgument &arg)
BOOLEAN | OnSmsSendRej (const StackMsgArgument &arg)

Constructor & Destructor Documentation

SmsSendDispatcher::SmsSendDispatcher ( )

SmsSendDispatcher::~SmsSendDispatcher ( ) [virtual]

Member Function Documentation

const SmsReferenceNumber& SmsSendDispatcher::GetReferenceNumber ( ) const [inline]

const Sms::Result& SmsSendDispatcher::GetResult ( ) const [inline]

const ShortMessageFailureCause& SmsSendDispatcher::GetShortMessageFailureCause ( ) const [inline]

BOOLEAN SmsSendDispatcher::OnSmsSendCnf ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsSendDispatcher::OnSmsSendRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN SmsSendDispatcher::ShortMessageFailureExists ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/SmsSendDispatcher.hpp
  • Asc/SmsSendDispatcher.cpp
Generated on Wed Jan 25 01:59:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSendingAnimation Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSendingAnimation Struct Reference
[SMS]

sending animation More...

#include <Applications/Ems/Sms/SmsAlerts.hpp>

Collaboration diagram for SmsSendingAnimation:

[legend]

Static Public Attributes

static const INT | c_sms_sending_anim_img_cnt = sizeof(SmsSendingAnimation::m_bmps)/sizeof(SmsSendingAnimation::m_bmps[0])
static const UINT32 | c_sms_sending_anim_speed = 150
static const BitmapRes * | m_bmps [17]

Detailed Description

sending animation

Field Documentation

const INT SmsSendingAnimation::c_sms_sending_anim_img_cnt = sizeof(SmsSendingAnimation::m_bmps)/sizeof(SmsSendingAnimation::m_bmps[0]) [static]

const UINT32 SmsSendingAnimation::c_sms_sending_anim_speed = 150 [static]

const BitmapRes * SmsSendingAnimation::m_bmps [static]

Initial value:

 {
    &sms_sending_anim_01, &sms_sending_anim_02, &sms_sending_anim_03,
    &sms_sending_anim_04, &sms_sending_anim_05, &sms_sending_anim_06,
    &sms_sending_anim_07, &sms_sending_anim_08, &sms_sending_anim_09,
    &sms_sending_anim_10, &sms_sending_anim_11, &sms_sending_anim_12,
    &sms_sending_anim_13, &sms_sending_anim_14, &sms_sending_anim_15,
    &sms_sending_anim_16, &sms_sending_anim_17
}

The documentation for this struct was generated from the following files:
  • Applications/Ems/Sms/SmsAlerts.hpp
  • Applications/Ems/Sms/SmsAlerts.cpp
Generated on Wed Jan 25 01:59:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSendingConfirmDialog Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSendingConfirmDialog Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsSendingConfirmDialog.hpp>

Collaboration diagram for SmsSendingConfirmDialog:

[legend]

Public Member Functions

void | Init ()
void | SetAddressText (const WString &text)
void | SetSegmentCount (INT segment_count)
void | SetTelematicDeviceText (const WString &text)
void | SetValidityPeriod (const ValidityPeriod &vp)
SmsSendingConfirmDialog ()
~SmsSendingConfirmDialog ()

Protected Member Functions

void | OnOpen ()

Detailed Description

Dialog to confirm Sms Sending

Constructor & Destructor Documentation

SmsSendingConfirmDialog::SmsSendingConfirmDialog ( )

SmsSendingConfirmDialog::~SmsSendingConfirmDialog ( )

Member Function Documentation

void SmsSendingConfirmDialog::Init ( )

void SmsSendingConfirmDialog::OnOpen ( ) [protected]

void SmsSendingConfirmDialog::SetAddressText ( const WString & text ) [inline]

void SmsSendingConfirmDialog::SetSegmentCount ( INT segment_count )

void SmsSendingConfirmDialog::SetTelematicDeviceText ( const WString & text ) [inline]

void SmsSendingConfirmDialog::SetValidityPeriod ( const ValidityPeriod & vp )

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsSendingConfirmDialog.hpp
  • Applications/Ems/Sms/SmsSendingConfirmDialog.cpp
Generated on Wed Jan 25 01:59:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSendRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSendRejArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsSendRejArg:

[legend]
Collaboration diagram for SmsSendRejArg:

[legend]

Public Types

enum | { ID = 2563 }

Public Member Functions

const Sms::Result & | GetResult () const
const SimTkTransactionId & | GetTid () const
void | SetResult (const Sms::Result &result)
void | SetTid (const SimTkTransactionId &tid)
SmsSendRejArg ()

Static Public Member Functions

static const SmsSendRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsSendRejArg: reflects arguments of signal MN_SMS_SEND_PDU_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsSendRejArg::SmsSendRejArg ( )

Member Function Documentation

const SmsSendRejArg & SmsSendRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Sms::Result& SmsSendRejArg::GetResult ( ) const [inline]

const SimTkTransactionId& SmsSendRejArg::GetTid ( ) const [inline]

void SmsSendRejArg::SetResult ( const Sms::Result & result ) [inline]

void SmsSendRejArg::SetTid ( const SimTkTransactionId & tid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:59:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSendRejectMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSendRejectMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsSendRejectMsg:

[legend]
Collaboration diagram for SmsSendRejectMsg:

[legend]

Public Types

enum | { ID = 18911 }

Public Member Functions

virtual Message * | Clone () const
const SmsSendRejArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SmsSendRejArg &arg)
SmsSendRejectMsg (ExecutionContext *context, const SmsSendRejArg &arg)
virtual | ~SmsSendRejectMsg ()

Detailed Description

SmsSendRejectMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsSendRejectMsg::SmsSendRejectMsg | ( | ExecutionContext * | context,
 |  | const SmsSendRejArg & | arg
 | ) |

SmsSendRejectMsg::~SmsSendRejectMsg ( ) [virtual]

Member Function Documentation

Message * SmsSendRejectMsg::Clone ( ) const [virtual]

Implements Message.

const SmsSendRejArg& SmsSendRejectMsg::GetArg ( ) const [inline]

const MsgMetaData & SmsSendRejectMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SmsSendRejectMsg::SetArg ( const SmsSendRejArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:59:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSendReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSendReqArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsSendReqArg:

[legend]
Collaboration diagram for SmsSendReqArg:

[legend]

Public Types

enum | { ID = 2509 }

Public Member Functions

const GsmService & | GetService () const
const Tpdu & | GetTpdu () const
void | SetService (const GsmService &service)
void | SetTpdu (const Tpdu &tpdu)
SmsSendReqArg ()
SmsSendReqArg (const Tpdu &tpdu, const GsmService &service=InvalidGsmService)

Static Public Member Functions

static const SmsSendReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsSendReqArg: reflects arguments of signal MN_SMS_SEND_PDU_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsSendReqArg::SmsSendReqArg | ( | const Tpdu & | tpdu,
 |  | const GsmService & | service = InvalidGsmService
 | ) |

SmsSendReqArg::SmsSendReqArg ( )

Member Function Documentation

const SmsSendReqArg & SmsSendReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const GsmService& SmsSendReqArg::GetService ( ) const [inline]

const Tpdu& SmsSendReqArg::GetTpdu ( ) const [inline]

void SmsSendReqArg::SetService ( const GsmService & service ) [inline]

void SmsSendReqArg::SetTpdu ( const Tpdu & tpdu ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:59:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSentProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSentProvider Class Reference
[Provider]

#include <Apoxi/Adc/SmsSentProvider.hpp>

Inheritance diagram for SmsSentProvider:

[legend]
Collaboration diagram for SmsSentProvider:

[legend]

Public Member Functions

virtual INT | GetProviderId () const
Returns the provider id.
virtual INT | RowCount ()
RowCount returns the number of rows.
SmsSentProvider ()
virtual | ~SmsSentProvider ()

Protected Member Functions

virtual Tpdu::Status | GetDestinationTpduStatus () const
virtual SmsFilterType | GetSmsFilterType () const

Detailed Description

SmsSentProvider is the provider to retrieve the already sent sms from the sim. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_sms_sent_provider_id

Please refer to SmsProvider for possible columns

NOTE: Please do not instantiate this class.

Constructor & Destructor Documentation

SmsSentProvider::SmsSentProvider ( )

SmsSentProvider::~SmsSentProvider ( ) [virtual]

Member Function Documentation

virtual Tpdu::Status SmsSentProvider::GetDestinationTpduStatus ( ) const [inline, protected, virtual]

Reimplemented from SmsProvider.

INT SmsSentProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Reimplemented from SmsProvider.

virtual SmsFilterType SmsSentProvider::GetSmsFilterType ( ) const [inline, protected, virtual]

Reimplemented from SmsProvider.

INT SmsSentProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Reimplemented from SmsProvider.

The documentation for this class was generated from the following files:
  • Adc/SmsSentProvider.hpp
  • Adc/SmsSentProvider.cpp
Generated on Wed Jan 25 01:59:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsServiceDocumentMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsServiceDocumentMsg Class Reference

#include <Applications/Ems/Sms/SmsMsgTypes.hpp>

Inheritance diagram for SmsServiceDocumentMsg:

[legend]
Collaboration diagram for SmsServiceDocumentMsg:

[legend]

Public Types

enum | { ID = 21501 }

Public Member Functions

virtual Message * | Clone () const
INT16 | GetArg () const
const EditorDocumentObtainer & | GetDocumentObtainer () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetPhoneNumber () const
void | SetArg (INT16 arg)
void | SetPhoneNumber (const PhoneNumber &phone_number)
SmsServiceDocumentMsg (ExecutionContext *context, INT16 arg, const EditorDocumentObtainer &document_obtainer, const PhoneNumber &phone_number)
virtual | ~SmsServiceDocumentMsg ()

Detailed Description

Used by SMS-Service to signal SMS processing using EditorDocuments.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsServiceDocumentMsg::SmsServiceDocumentMsg | ( | ExecutionContext * | context,
 |  | INT16 | arg,
 |  | const EditorDocumentObtainer & | document_obtainer,
 |  | const PhoneNumber & | phone_number
 | ) |

SmsServiceDocumentMsg::~SmsServiceDocumentMsg ( ) [virtual]

Member Function Documentation

Message * SmsServiceDocumentMsg::Clone ( ) const [virtual]

Implements Message.

INT16 SmsServiceDocumentMsg::GetArg ( ) const [inline]

const EditorDocumentObtainer& SmsServiceDocumentMsg::GetDocumentObtainer ( ) const [inline]

const MsgMetaData & SmsServiceDocumentMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& SmsServiceDocumentMsg::GetPhoneNumber ( ) const [inline]

void SmsServiceDocumentMsg::SetArg ( INT16 arg ) [inline]

void SmsServiceDocumentMsg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsMsgTypes.hpp
  • Applications/Ems/Sms/SmsMsgTypes.cpp
Generated on Wed Jan 25 01:59:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsServiceMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsServiceMsg Class Reference

#include <Applications/Ems/Sms/SmsMsgTypes.hpp>

Inheritance diagram for SmsServiceMsg:

[legend]
Collaboration diagram for SmsServiceMsg:

[legend]

Public Types

enum | { ID = 21500 }

Public Member Functions

virtual Message * | Clone () const
INT16 | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
const PhoneNumber & | GetPhoneNumber () const
const WString & | GetText () const
void | SetArg (INT16 arg)
void | SetPhoneNumber (const PhoneNumber &phone_number)
void | SetText (const WString &text)
SmsServiceMsg (ExecutionContext *context, INT16 arg, const WString &text, const PhoneNumber &phone_number)
virtual | ~SmsServiceMsg ()

Detailed Description

Used by SMS-Service

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsServiceMsg::SmsServiceMsg | ( | ExecutionContext * | context,
 |  | INT16 | arg,
 |  | const WString & | text,
 |  | const PhoneNumber & | phone_number
 | ) |

SmsServiceMsg::~SmsServiceMsg ( ) [virtual]

Member Function Documentation

Message * SmsServiceMsg::Clone ( ) const [virtual]

Implements Message.

INT16 SmsServiceMsg::GetArg ( ) const [inline]

const MsgMetaData & SmsServiceMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const PhoneNumber& SmsServiceMsg::GetPhoneNumber ( ) const [inline]

const WString& SmsServiceMsg::GetText ( ) const [inline]

void SmsServiceMsg::SetArg ( INT16 arg ) [inline]

void SmsServiceMsg::SetPhoneNumber ( const PhoneNumber & phone_number ) [inline]

void SmsServiceMsg::SetText ( const WString & text ) [inline]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsMsgTypes.hpp
  • Applications/Ems/Sms/SmsMsgTypes.cpp
Generated on Wed Jan 25 01:59:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSetMoreMessageReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSetMoreMessageReqArg Class Reference

#include <Apoxi/Apc/SmsStackMsgArgs.hpp>

Inheritance diagram for SmsSetMoreMessageReqArg:

[legend]
Collaboration diagram for SmsSetMoreMessageReqArg:

[legend]

Public Types

enum | { ID = 2510 }

Public Member Functions

const SmsMoreMessageType & | GetSmsMoreMessageType () const
void | SetSmsMoreMessageType (const SmsMoreMessageType &sms_more_message_type)
SmsSetMoreMessageReqArg ()
SmsSetMoreMessageReqArg (const SmsMoreMessageType &sms_more_message_type)

Static Public Member Functions

static const SmsSetMoreMessageReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SmsSetMoreMessageReqArg: reflects arguments of signal MN_MORE_MESSAGES_SET_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsSetMoreMessageReqArg::SmsSetMoreMessageReqArg ( const SmsMoreMessageType & sms_more_message_type )

SmsSetMoreMessageReqArg::SmsSetMoreMessageReqArg ( )

Member Function Documentation

const SmsSetMoreMessageReqArg & SmsSetMoreMessageReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SmsMoreMessageType& SmsSetMoreMessageReqArg::GetSmsMoreMessageType ( ) const [inline]

void SmsSetMoreMessageReqArg::SetSmsMoreMessageType ( const SmsMoreMessageType & sms_more_message_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SmsStackMsgArgs.hpp
  • Apc/SmsStackMsgArgs.cpp
Generated on Wed Jan 25 01:59:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSettingsProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSettingsProvider Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsSettingsProvider.hpp>

Inheritance diagram for SmsSettingsProvider:

[legend]
Collaboration diagram for SmsSettingsProvider:

[legend]

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
virtual INT | GetProviderId () const
void | Init ()
virtual INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
virtual void | RestoreFactorySettings ()
virtual INT | RowCount ()
virtual BOOLEAN | SelectRow (INT row)
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
SmsSettingsProvider ()
virtual BOOLEAN | Update (ProviderListener *listener=0)
virtual | ~SmsSettingsProvider ()

Detailed Description

Provider for settings of the Basic-MMI SMS application.
Provider ID: c_sms_settings_provider_id

The following columns are available:
ID | Type | Description
c_mmisms_line2_voicebox_address | PhoneNumberType | Sets or Gets voice mailbox number for Line2 (PhoneNumber type)
c_mmisms_pred_input | NumberType | En- or disables the request of pred input. (BOOLEAN type)
c_mmisms_default_profile | NumberType | Id (row in SmsParamProvider) of the selected default profile.
c_mmisms_voicebox_address | PhoneNumberType | Sets or Gets voice mailbox number for Line1 (PhoneNumber type)
c_mmisms_reply_path | NumberType | En- or disables the request of reply path. (BOOLEAN type)
c_mmisms_statusreport | NumberType | En- or disables the request of a status report. (BOOLEAN type)
c_mmisms_statusreport_on_idlescreen | NumberType | En- or disables the immediate display of status reports on idle screen. (BOOLEAN type)
c_mmisms_use_gprs_link | NumberType | GsmService value which is used for connection for Mo-Sms. (GsmService type)
c_mmisms_autostore_sending | NumberType | En- or disables storeing SMS automatically after sending. (BOOLEAN type)
c_mmisms_mandatory_preview | NumberType | En- or disables the preview of a SMS before sending it in any case. (BOOLEAN type)
c_mmisms_sending_confirmation | NumberType | En- or disables the sending confiramtion dialog. (BOOLEAN type)
c_mmisms_inbox_sorting | NumberType | Column Id for sorting the inbox.
c_mmisms_outbox_sorting | NumberType | Column Id for sorting the outbox.
c_mmisms_archive_sorting | NumberType | Column Id for sorting the archive box.
c_mmisms_statusreport_sorting | NumberType | Column Id for sorting the status report box.
c_mmisms_inbox_sorting_order | NumberType | Sorting order for the inbox. (BOOLEAN type; TRUE: Ascending, FALSE: Descending)
c_mmisms_outbox_sorting_order | NumberType | Sorting method for the outbox. (BOOLEAN type; TRUE: Ascending, FALSE: Descending)
c_mmisms_archive_sorting_order | NumberType | Sorting method for the archive box. (BOOLEAN type; TRUE: Ascending, FALSE: Descending)
c_mmisms_statusreport_sorting_order | NumberType | Sorting method for the status report box. (BOOLEAN type; TRUE: Ascending, FALSE: Descending)
c_mmisms_storage_location | NumberType | Preferred Storage for storing SMS messages SmsSimPreferred or SmsFlashPreferred. (BOOLEAN type; TRUE: Ascending, FALSE: Descending)

Constructor & Destructor Documentation

SmsSettingsProvider::SmsSettingsProvider ( )

Class constructor

SmsSettingsProvider::~SmsSettingsProvider ( ) [virtual]

Class destructor

Member Function Documentation

BOOLEAN SmsSettingsProvider::CommitRow ( INT row ) [virtual]

Method stores the current used provider data in a file on FFS.

Parameters:
row CBS Provider row identifier.
Returns:
TRUE if commit row access was successfull

Reimplemented from Provider.

BOOLEAN SmsSettingsProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

Method reads a certain SMS provider data item.

Parameters:
columnid | Provider column identifier to determine the data field that should be read.
row | Provider row identifier.
item | Pointer to data item. The read data will be saved in this structure.
Returns:
Method returns TRUE if all parameter values are valid and the several provider settings could be read without any errors.

Implements Provider.

INT SmsSettingsProvider::GetProviderId ( ) const [virtual]

Method returns the SMS settings provider ID.

Returns:
SMS settings provider ID

Implements Provider.

void SmsSettingsProvider::Init ( )

Class initialisation; File with saved SMS settings will be read from FFS. If no file is existing a new file will be created.

INT SmsSettingsProvider::MaxRowCount ( ) [virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

void SmsSettingsProvider::RestoreFactorySettings ( ) [virtual]

Method sets all SMS provider settings data back to default values.

Implements SettingsProvider.

INT SmsSettingsProvider::RowCount ( ) [virtual]

Method returns the current used number of SMS provider rows.

Returns:
Number of current used SMS provider rows

Reimplemented from SettingsProvider.

BOOLEAN SmsSettingsProvider::SelectRow ( INT row ) [virtual]

Method reads a certain SMS provider data row and copies data into internal buffer.

Parameters:
row SMS Provider row identifier.
Returns:
TRUE if select row access was successfull

Reimplemented from Provider.

BOOLEAN SmsSettingsProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Method saves SMS provider data field settings in file.

Parameters:
item | Pointer to data item. Data item with current data that should be stored in a file.
columnid | Provider column identifier to determine the data field that should be replaced.
Returns:
Method returns TRUE if all parameter values are valid and the several provider settings could be saved without any errors.

Reimplemented from Provider.

BOOLEAN SmsSettingsProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Method makes the Provider ready to use, enables listener and reloads the SMS provider data from FFS.

Parameters:
listener Pointer to ProviderListener. Necessary to see the progress state from the calling application.
Returns:
Method returns always TRUE yet.

Reimplemented from SettingsProvider.

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsSettingsProvider.hpp
  • Applications/Ems/Sms/SmsSettingsProvider.cpp
Generated on Wed Jan 25 01:59:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSettingsRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSettingsRecord Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsSettingsRecord.hpp>

Inheritance diagram for SmsSettingsRecord:

[legend]
Collaboration diagram for SmsSettingsRecord:

[legend]

Public Types

enum | Box { Inbox, Outbox, Archive, StatusReport }

Public Member Functions

virtual const UINT8 * | GetData ()
UINT8 | GetDefaultProfile ()
GsmService | GetGsmService () const
PhoneNumber | GetLine2VoiceBoxNumber () const
virtual INT | GetPersistentSize ()
INT | GetSortingColumnId (Box box) const
UINT8 | GetStorageLocation ()
PhoneNumber | GetVoiceBoxNumber () const
BOOLEAN | IsAscendingOrder (Box box) const
BOOLEAN | IsAutoStorageEnabled () const
BOOLEAN | IsPredInputEnabled () const
virtual BOOLEAN | IsRecordDeleted ()
BOOLEAN | IsReplyPathRequested () const
BOOLEAN | IsSendingConfirmationEnabled () const
BOOLEAN | IsSendPreviewMandatory () const
BOOLEAN | IsStatusReportEnabled () const
BOOLEAN | IsStatusReportOnIdleScreen () const
virtual void | MarkDeleted ()
void | SetAutoStoreEnabled (BOOLEAN flag)
virtual void | SetData (const UINT8 *data)
void | SetDefault ()
void | SetDefaultProfile (UINT8 profile)
void | SetGsmService (GsmService service)
void | SetLine2VoiceBoxNumber (const PhoneNumber &number)
void | SetPredInputEnabled (BOOLEAN flag)
void | SetReplyPathRequested (BOOLEAN flag)
void | SetSendingConfirmationEnabled (BOOLEAN flag)
void | SetSendPreviewMandatory (BOOLEAN flag)
void | SetSorting (Box box, INT colid, BOOLEAN ascending=TRUE)
void | SetStatusReportEnabled (BOOLEAN flag)
void | SetStatusReportOnIdleScreen (BOOLEAN flag)
void | SetStorageLocation (UINT8 storage_location)
void | SetVoiceBoxNumber (const PhoneNumber &number)
SmsSettingsRecord ()

Data Fields

SmsSettingsRecord::Persist m_data

Friends

OutputStream & | operator<< (OutputStream &ostr, const SmsSettingsRecord &tpdu)
InputStream & | operator>> (InputStream &istr, SmsSettingsRecord &tpdu)

Data Structures

struct | Persist

Detailed Description

Record file for Sms Settings

Member Enumeration Documentation

enum SmsSettingsRecord::Box

Enumerator:
Inbox
Outbox
Archive
StatusReport

Constructor & Destructor Documentation

SmsSettingsRecord::SmsSettingsRecord ( )

Class constructor

Member Function Documentation

const UINT8 * SmsSettingsRecord::GetData ( ) [virtual]

Method reads the SMS settings data field from non-volatile memory.

Returns:
Pointer to SMS settings data field that contains current data

Implements Record.

UINT8 SmsSettingsRecord::GetDefaultProfile ( ) [inline]

Method ???.

Returns:
???

GsmService SmsSettingsRecord::GetGsmService ( ) const [inline]

Method returns current value of m_gsm_service data field.

Returns:
Current saved value of m_gsm_service data field.

PhoneNumber SmsSettingsRecord::GetLine2VoiceBoxNumber ( ) const

Method returns current saved <m_line2_voicebox_number phone number.

Returns:
Current saved m_line2_voicebox_number phone number.

INT SmsSettingsRecord::GetPersistentSize ( ) [virtual]

Method determines the size of the SMS settings data field.

Returns:
Size of SMS settings data field (in bytes).

Implements Record.

INT SmsSettingsRecord::GetSortingColumnId ( Box box ) const

Method returns the sorting column ID for a specific SMS list (Inbox, Outbox, Archive and StatusReport).

Parameters:
box SMS list (Inbox, Outbox, Archive or StatusReport).
Returns:
Sorting Column identifier of specific SMS list.

UINT8 SmsSettingsRecord::GetStorageLocation ( ) [inline]

Method returns the storage location of SMS.

Returns:
storage location

PhoneNumber SmsSettingsRecord::GetVoiceBoxNumber ( ) const

Method returns current saved <m_voicebox_number phone number.

Returns:
Current saved m_voicebox_number phone number.

BOOLEAN SmsSettingsRecord::IsAscendingOrder ( Box box ) const

Method checks the sorting order of a specific SMS list (Inbox, Outbox, Archive and StatusReport).

Parameters:
box SMS list (Inbox, Outbox, Archive or StatusReport).
Returns:
TRUE for ascending sorting order, FALSE for sloping sorting order.

BOOLEAN SmsSettingsRecord::IsAutoStorageEnabled ( ) const [inline]

Method returns current value of autostore data field. TRUE means that all sent SMS should be stored automatically.

Returns:
Current saved value of autostore data field.

BOOLEAN SmsSettingsRecord::IsPredInputEnabled ( ) const [inline]

Method returns current value of pred_input data field. TRUE means that the pred input is enabled.

Returns:
Current saved value of pred_input data field

BOOLEAN SmsSettingsRecord::IsRecordDeleted ( ) [virtual]

Reimplemented from Record.

BOOLEAN SmsSettingsRecord::IsReplyPathRequested ( ) const [inline]

Method returns current value of reply_path data field. TRUE means that the reply path is requested.

Returns:
Current saved value of reply_path data field

BOOLEAN SmsSettingsRecord::IsSendingConfirmationEnabled ( ) const [inline]

Method returns current value of sending_confirmation data field. TRUE means that a confirmation dialog should be displayed before sending.

Returns:
Current saved value of sending_confirmation data field.

BOOLEAN SmsSettingsRecord::IsSendPreviewMandatory ( ) const [inline]

Method returns current value of <empreview_mandatoryautostore data field. TRUE means that all all SMS sent by a service should be displayed before sending.

Returns:
Current saved value of preview_mandatory data field.

BOOLEAN SmsSettingsRecord::IsStatusReportEnabled ( ) const [inline]

Method returns current value of status_report data field. TRUE means that the reply path is requested.

Returns:
Current saved value of status_report data field.

BOOLEAN SmsSettingsRecord::IsStatusReportOnIdleScreen ( ) const [inline]

Method returns current value of statrep_on_idlescreen data field. TRUE means that the status reports should be displayed immediately on idle screen.

Returns:
Current saved value of statrep_on_idlescreen data field.

void SmsSettingsRecord::MarkDeleted ( ) [virtual]

Reimplemented from Record.

void SmsSettingsRecord::SetAutoStoreEnabled ( BOOLEAN flag ) [inline]

Method sets value of autostore data field to the given parameter flag. TRUE means that all sent SMS should be stored automatically.

Parameters:
flag New value of autostore data field.

void SmsSettingsRecord::SetData ( const UINT8 * data ) [virtual]

Method writes a SMS settings data field to non-volatile memory.

Parameters:
data SMS settings data field that should be stored on non-volatile memory

Implements Record.

void SmsSettingsRecord::SetDefault ( )

Method sets all SMS provider settings data back to default values.

void SmsSettingsRecord::SetDefaultProfile ( UINT8 profile ) [inline]

Method ???.

Parameters:
profile ???

void SmsSettingsRecord::SetGsmService ( GsmService service ) [inline]

Method sets value of m_gsm_service data field to the given parameter flag.

Parameters:
flag New value of m_gsm_service data field.

void SmsSettingsRecord::SetLine2VoiceBoxNumber ( const PhoneNumber & number ) [inline]

Method sets value of m_line2_voicebox_number data field to the given parameter number.

Parameters:
number New voice box phone number that should be saved.

void SmsSettingsRecord::SetPredInputEnabled ( BOOLEAN flag ) [inline]

Method sets value of pred_input data field to the given parameter flag. TRUE means that the pred. input is enabled.

Parameters:
flag New value of pred_input data field.

void SmsSettingsRecord::SetReplyPathRequested ( BOOLEAN flag ) [inline]

Method sets value of reply_path data field to the given parameter flag. TRUE means that the reply path is requested.

Parameters:
flag New value of reply_path data field.

void SmsSettingsRecord::SetSendingConfirmationEnabled ( BOOLEAN flag ) [inline]

Method sets value of sending_confirmation data field to the given parameter flag. TRUE means that a confirmation dialog should be displayed before sending.

Parameters:
flag New value of sending_confirmation data field.

void SmsSettingsRecord::SetSendPreviewMandatory ( BOOLEAN flag ) [inline]

Method sets value of preview_mandatory data field to the given parameter flag. TRUE means that all SMS sent by a service should be displayed before sending.

Parameters:
flag New value of preview_mandatory data field.

void SmsSettingsRecord::SetSorting | ( | Box | box,
 |  | INT | colid,
 |  | BOOLEAN | ascending = TRUE
 | ) |

With this method the sorting order for SMS lists (Inbox, Outbox, Archive and StatusReport) could be defined.

Parameters:
box | SMS list (Inbox, Outbox, Archive or StatusReport).
colid ???.
ascending | TRUE means ascending sorting order, FALSE means sloping sorting order.

void SmsSettingsRecord::SetStatusReportEnabled ( BOOLEAN flag ) [inline]

Method sets value of status_report data field to the given parameter flag. This value enables or disables the receiving status reports.

Parameters:
flag New value of status_report data field.

void SmsSettingsRecord::SetStatusReportOnIdleScreen ( BOOLEAN flag ) [inline]

Method sets value of statrep_on_idlescreen data field to the given parameter flag. TRUE means that the status reports should be displayed immediately on idle screen

Parameters:
flag New value of statrep_on_idlescreen data field.

void SmsSettingsRecord::SetStorageLocation ( UINT8 storage_location ) [inline]

Method sets the location where SMS should be stored

Parameters:
storage location

void SmsSettingsRecord::SetVoiceBoxNumber ( const PhoneNumber & number ) [inline]

Method sets value of m_voicebox_number data field to the given parameter number.

Parameters:
number New voice box phone number that should be saved.

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const SmsSettingsRecord & | tpdu
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | SmsSettingsRecord & | tpdu
 | ) | [friend]

Field Documentation

struct SmsSettingsRecord::Persist SmsSettingsRecord::m_data

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsSettingsRecord.hpp
  • Applications/Ems/Sms/SmsSettingsRecord.cpp
Generated on Wed Jan 25 01:59:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSettingsRecord::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SmsSettingsRecord::Persist

SmsSettingsRecord::Persist Struct Reference

#include <Applications/Ems/Sms/SmsSettingsRecord.hpp>

Collaboration diagram for SmsSettingsRecord::Persist:

[legend]

Data Fields

INT | archive_sorting_colid
struct {
BOOLEAN archive_ascending_order: 2
BOOLEAN autostore: 2
BOOLEAN inbox_ascending_order: 2
BOOLEAN outbox_ascending_order: 2
BOOLEAN pred_input: 2
BOOLEAN preview_mandatory: 2
BOOLEAN reply_path: 2
BOOLEAN sending_confirmation: 2
BOOLEAN statrep_ascending_order: 2
BOOLEAN statrep_on_idlescreen: 2
BOOLEAN status_report: 2
} flags
INT8 | gsm_service
INT | inbox_sorting_colid
PhoneNumber::Persist line2_voicebox_number
INT | outbox_sorting_colid
UINT8 | profile
INT | statrep_sorting_colid
UINT8 | storage_location
PhoneNumber::Persist voicebox_number

Field Documentation

BOOLEAN SmsSettingsRecord::Persist::archive_ascending_order

INT SmsSettingsRecord::Persist::archive_sorting_colid

BOOLEAN SmsSettingsRecord::Persist::autostore

struct { ... } SmsSettingsRecord::Persist::flags

INT8 SmsSettingsRecord::Persist::gsm_service

BOOLEAN SmsSettingsRecord::Persist::inbox_ascending_order

INT SmsSettingsRecord::Persist::inbox_sorting_colid

PhoneNumber::Persist SmsSettingsRecord::Persist::line2_voicebox_number

BOOLEAN SmsSettingsRecord::Persist::outbox_ascending_order

INT SmsSettingsRecord::Persist::outbox_sorting_colid

BOOLEAN SmsSettingsRecord::Persist::pred_input

BOOLEAN SmsSettingsRecord::Persist::preview_mandatory

UINT8 SmsSettingsRecord::Persist::profile

BOOLEAN SmsSettingsRecord::Persist::reply_path

BOOLEAN SmsSettingsRecord::Persist::sending_confirmation

BOOLEAN SmsSettingsRecord::Persist::statrep_ascending_order

BOOLEAN SmsSettingsRecord::Persist::statrep_on_idlescreen

INT SmsSettingsRecord::Persist::statrep_sorting_colid

BOOLEAN SmsSettingsRecord::Persist::status_report

UINT8 SmsSettingsRecord::Persist::storage_location

PhoneNumber::Persist SmsSettingsRecord::Persist::voicebox_number

The documentation for this struct was generated from the following file:
  • Applications/Ems/Sms/SmsSettingsRecord.hpp
Generated on Wed Jan 25 01:59:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSocket Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SmsSocket.hpp>

Inheritance diagram for SmsSocket:

[legend]
Collaboration diagram for SmsSocket:

[legend]

Public Member Functions

ExecutionContext * | GetExecutionContext () const
SmsPortNo | GetPortNo () const
Returns the port number of the sms socket.
BOOLEAN | Init (SmsPortNo sms_port_no, BOOLEAN force=FALSE)
BOOLEAN | IsActive () const
Returns if the sms socket is activ in listening to its port.
BOOLEAN | Read (WString &wstr)
BOOLEAN | Read (BlobObject &blob, INT no_of_bytes_to_read=-1)
SmsSocket (SmsPortNo sms_port_no=InvalidSmsPortNo)
Initializes the sms socket with a sms port number (if given).
virtual | ~SmsSocket ()

Friends

class | SmsSocketListener

Data Structures

class | PortTpdu

Detailed Description

The class SmsSocket provides the handling of SmsSockets.

Constructor & Destructor Documentation

SmsSocket::SmsSocket ( SmsPortNo sms_port_no = InvalidSmsPortNo )

Initializes the sms socket with a sms port number (if given).

SmsSocket::~SmsSocket ( ) [virtual]

Member Function Documentation

ExecutionContext* SmsSocket::GetExecutionContext ( ) const [inline]

Returns the owner of an active sms socket (this context will get a notification). If the sms socket is inactive the return value will be zero.

SmsPortNo SmsSocket::GetPortNo ( ) const [inline]

Returns the port number of the sms socket.

BOOLEAN SmsSocket::Init | ( | SmsPortNo | sms_port_no,
 |  | BOOLEAN | force = FALSE
 | ) |

Initializes the sms socket with a sms port number. The method fails if it is already active, any data is still stored to be read. The optional parameter force, will reset sms socket also if it is active, or any data is waiting. In this case the any existing data will be wasted.

BOOLEAN SmsSocket::IsActive ( ) const [inline]

Returns if the sms socket is activ in listening to its port.

BOOLEAN SmsSocket::Read ( WString & wstr )

Reads out pending port data in form of unicode characters. This method shall be used if received SMS have textuell content, means 7-bit or unicode characters. Take into account when using this method, the cached data will be cleared, so therefore the Read method (BlobObject) will return no data.

BOOLEAN SmsSocket::Read | ( | BlobObject & | blob,
 |  | INT | no_of_bytes_to_read = -1
 | ) |

Reads out pending port data. The parameter no_of_bytes_to_read defines the amount of bytes to read. If this value is -1 all pending data is returned. Return value is TRUE, if there is more data to read. After reading, the data will be deleted. Reading can only been done by the owner.

Friends And Related Function Documentation

friend class SmsSocketListener [friend]

The documentation for this class was generated from the following files:
  • Asc/SmsSocket.hpp
  • Asc/SmsSocket.cpp
Generated on Wed Jan 25 01:59:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSocketListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSocketListener Class Reference
[APOXI Stack Control]

provides registration of SMS sockets to the system and manages all registered SMS sockets More...

#include <Apoxi/Asc/SmsSocketListener.hpp>

Collaboration diagram for SmsSocketListener:

[legend]

Static Public Member Functions

static BOOLEAN | Confirm (ExecutionContext *context, SmsPortNo portno, BOOLEAN accept)
static void | DumpTables ()
static BOOLEAN | EmptyCache (SmsPortNo portno)
Returns TRUE, if the deletion of all cached pdus, related to one port was successfull.
static SmsSocket * | GetSocket (SmsPortNo sms_port_no)
static BOOLEAN | HasPorts (ExecutionContext *context=0)
Returns TRUE, if the given context has any ports. If context = 0 then the method refers to the active context.
static BOOLEAN | IsInUse (SmsPortNo sms_port_no)
Returns TRUE, if the given port number is already in use in the system.
static BOOLEAN | Register (SmsSocket *sms_socket)
static void | Startup ()
static BOOLEAN | Subscribe (ExecutionContext *context)
Returns TRUE, if the given context was successfully subscribed to get notification if a port sms arrived.
static BOOLEAN | Unregister (SmsSocket *sms_socket)
static BOOLEAN | Unsubscribe (ExecutionContext *context)
Returns TRUE, if the given context was successfully unsubscribed.

Friends

class | Lock
class | SmsSocket
class | SmsSocketSignalMapTableNode

Data Structures

struct | ConfirmInfo
class | Lock

Detailed Description

provides registration of SMS sockets to the system and manages all registered SMS sockets

Member Function Documentation

BOOLEAN SmsSocketListener::Confirm | ( | ExecutionContext * | context,
 |  | SmsPortNo | portno,
 |  | BOOLEAN | accept
 | ) | [static]

Returns TRUE, if the confirmation was successfull, accept shall be set to TRUE, if data for the given port shall be cached until SmsSocket is created.

void SmsSocketListener::DumpTables ( ) [static]

BOOLEAN SmsSocketListener::EmptyCache ( SmsPortNo portno ) [static]

Returns TRUE, if the deletion of all cached pdus, related to one port was successfull.

SmsSocket * SmsSocketListener::GetSocket ( SmsPortNo sms_port_no ) [static]

Returns the socket with the requested port number. A null pointer is returned, when no socket exists or the existing socket was not registered by the calling context.

BOOLEAN SmsSocketListener::HasPorts ( ExecutionContext * context = 0 ) [static]

Returns TRUE, if the given context has any ports. If context = 0 then the method refers to the active context.

BOOLEAN SmsSocketListener::IsInUse ( SmsPortNo sms_port_no ) [static]

Returns TRUE, if the given port number is already in use in the system.

BOOLEAN SmsSocketListener::Register ( SmsSocket * sms_socket ) [static]

Registers a well defined (port_no is valid or not in use) sms socket. If TRUE is returned, then the socket starts listening its port. Method does the same as SmsSocket's Activate

void SmsSocketListener::Startup ( ) [static]

BOOLEAN SmsSocketListener::Subscribe ( ExecutionContext * context ) [static]

Returns TRUE, if the given context was successfully subscribed to get notification if a port sms arrived.

BOOLEAN SmsSocketListener::Unregister ( SmsSocket * sms_socket ) [static]

Deactivates a sms socket from listening to its port. Existing data in the socket will be kept available.

BOOLEAN SmsSocketListener::Unsubscribe ( ExecutionContext * context ) [static]

Returns TRUE, if the given context was successfully unsubscribed.

Friends And Related Function Documentation

friend class Lock [friend]

friend class SmsSocket [friend]

friend class SmsSocketSignalMapTableNode [friend]

The documentation for this class was generated from the following files:
  • Asc/SmsSocketListener.hpp
  • Asc/SmsSocketListener.cpp
Generated on Wed Jan 25 01:59:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSocketSignalMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSocketSignalMapTableNode Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SmsSocketSignalMapTableNode.hpp>

Inheritance diagram for SmsSocketSignalMapTableNode:

[legend]
Collaboration diagram for SmsSocketSignalMapTableNode:

[legend]

Static Public Member Functions

static SmsSocketSignalMapTableNode * GetInstance ()

Member Function Documentation

SmsSocketSignalMapTableNode * SmsSocketSignalMapTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • Asc/SmsSocketSignalMapTableNode.hpp
  • Asc/SmsSocketSignalMapTableNode.cpp
Generated on Wed Jan 25 01:59:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSpaceAvailableMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSpaceAvailableMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsSpaceAvailableMsg:

[legend]
Collaboration diagram for SmsSpaceAvailableMsg:

[legend]

Public Types

enum | { ID = 18921 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SmsSpaceAvailableMsg (ExecutionContext *context)
virtual | ~SmsSpaceAvailableMsg ()

Detailed Description

SmsSpaceAvailableMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsSpaceAvailableMsg::SmsSpaceAvailableMsg ( ExecutionContext * context )

SmsSpaceAvailableMsg::~SmsSpaceAvailableMsg ( ) [virtual]

Member Function Documentation

Message * SmsSpaceAvailableMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SmsSpaceAvailableMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:59:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSpaceExceededMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSpaceExceededMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SmsSpaceExceededMsg:

[legend]
Collaboration diagram for SmsSpaceExceededMsg:

[legend]

Public Types

enum | { ID = 18920 }

Public Member Functions

virtual Message * | Clone () const
const Sms::WarningLevel & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const Sms::WarningLevel &arg)
SmsSpaceExceededMsg (ExecutionContext *context, const Sms::WarningLevel &arg)
virtual | ~SmsSpaceExceededMsg ()

Detailed Description

SmsSpaceExceededMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SmsSpaceExceededMsg::SmsSpaceExceededMsg | ( | ExecutionContext * | context,
 |  | const Sms::WarningLevel & | arg
 | ) |

SmsSpaceExceededMsg::~SmsSpaceExceededMsg ( ) [virtual]

Member Function Documentation

Message * SmsSpaceExceededMsg::Clone ( ) const [virtual]

Implements Message.

const Sms::WarningLevel& SmsSpaceExceededMsg::GetArg ( ) const [inline]

const MsgMetaData & SmsSpaceExceededMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SmsSpaceExceededMsg::SetArg ( const Sms::WarningLevel & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 01:59:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsStatus Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsStatus Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 | lastused
UINT8 | notification

Field Documentation

UINT8 SmsStatus::lastused

UINT8 SmsStatus::notification

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 01:59:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsStatusReport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsStatusReport Class Reference

#include <Apoxi/Apc/Sms.hpp>

Inheritance diagram for SmsStatusReport:

[legend]
Collaboration diagram for SmsStatusReport:

[legend]

Public Types

enum | { ID = MessageTypeIndicator::StatusReport }
enum | { c_max_guaranteed_user_data_size = 131 }
typedef Sms | Base

Public Member Functions

DataCodingScheme | GetDataCodingScheme () const
TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]).
CodedTimeStamp | GetDischargeTime () const
TP-DT: TP-Discharge-Time (3GPP 23.040 V5.1.0 [9.2.3.13]).
MessageTypeIndicator::Type | GetInitialType () const
TP-SRQ: TP-Status-Report-Qualifier (3GPP 23.040 V5.1.0 [9.2.3.26]).
INT | GetMaxUserDataSize () const
SmsReferenceNumber | GetMessageReference () const
TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).
ParameterIndicator | GetParameterIndicator () const
TP-PI: TP-Parameter-Indicator (3GPP 23.040 V5.1.0 [9.2.3.27]).
ProtocolIdentifier | GetProtocolIdentifier () const
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
PhoneNumber | GetRecipientAddress () const
TP-RA: TP-Recipient-Address (3GPP 23.040 V5.1.0 [9.2.3.14]).
ShortMessageStatus | GetResultStatus () const
TP-ST: TP-Status (3GPP 23.040 V5.1.0 [9.2.3.15]).
CodedTimeStamp | GetServiceCentreTimeStamp () const
TP-SCTS: TP-Service-Centre-Time-Stamp (3GPP 23.040 V5.1.0 [9.2.3.11]).
WString | GetText () const
UserData | GetUserData () const
BOOLEAN | MoreMessagesToSend () const
TP-MMS: TP-More-Messages-to-Send (3GPP 23.040 V5.1.0 [9.2.3.2]).
SmsStatusReport (Tpdu *tpdu)
BOOLEAN | UserDataHeaderExists () const
TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).
~SmsStatusReport ()

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.2.3] - Attention: This class is a wrapper over a data-stream (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Member Typedef Documentation

typedef Sms SmsStatusReport::Base

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

anonymous enum

Enumerator:
c_max_guaranteed_user_data_size guaranteed length of UserData (excl. UserDataLength byte) - (3GPP 23.040 V5.1.0 [9.2.2.3])

Constructor & Destructor Documentation

SmsStatusReport::SmsStatusReport ( Tpdu * tpdu )

SmsStatusReport::~SmsStatusReport ( )

Member Function Documentation

DataCodingScheme SmsStatusReport::GetDataCodingScheme ( ) const

TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]).

CodedTimeStamp SmsStatusReport::GetDischargeTime ( ) const

TP-DT: TP-Discharge-Time (3GPP 23.040 V5.1.0 [9.2.3.13]).

MessageTypeIndicator::Type SmsStatusReport::GetInitialType ( ) const

TP-SRQ: TP-Status-Report-Qualifier (3GPP 23.040 V5.1.0 [9.2.3.26]).

INT SmsStatusReport::GetMaxUserDataSize ( ) const

Returns the maximum possible size (in bytes) of the userdata (inclusive the userdata-length byte). The size varies dependent on the size of the header-parameter.

SmsReferenceNumber SmsStatusReport::GetMessageReference ( ) const

TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).

ParameterIndicator SmsStatusReport::GetParameterIndicator ( ) const

TP-PI: TP-Parameter-Indicator (3GPP 23.040 V5.1.0 [9.2.3.27]).

ProtocolIdentifier SmsStatusReport::GetProtocolIdentifier ( ) const

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

PhoneNumber SmsStatusReport::GetRecipientAddress ( ) const

TP-RA: TP-Recipient-Address (3GPP 23.040 V5.1.0 [9.2.3.14]).

ShortMessageStatus SmsStatusReport::GetResultStatus ( ) const

TP-ST: TP-Status (3GPP 23.040 V5.1.0 [9.2.3.15]).

CodedTimeStamp SmsStatusReport::GetServiceCentreTimeStamp ( ) const

TP-SCTS: TP-Service-Centre-Time-Stamp (3GPP 23.040 V5.1.0 [9.2.3.11]).

WString SmsStatusReport::GetText ( ) const

UserData SmsStatusReport::GetUserData ( ) const

TP-UD: TP-User-Data (3GPP 23.040 V5.1.0 [9.2.3.24]) TP-UDL: TP-User-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.16])

BOOLEAN SmsStatusReport::MoreMessagesToSend ( ) const

TP-MMS: TP-More-Messages-to-Send (3GPP 23.040 V5.1.0 [9.2.3.2]).

BOOLEAN SmsStatusReport::UserDataHeaderExists ( ) const

TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).

The documentation for this class was generated from the following files:
  • Apc/Sms.hpp
  • Apc/Sms.cpp
Generated on Wed Jan 25 01:59:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsStatusReportTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsStatusReportTextMap Class Reference
[SMS]

Status report state and reson texts. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsStatusReportTextMap:

[legend]
Collaboration diagram for SmsStatusReportTextMap:

[legend]

Static Public Member Functions

static const WCHAR * | GetReason (ShortMessageStatus::Reason reason)
static const WCHAR * | GetStatus (ShortMessageStatus::Status state)

Detailed Description

Status report state and reson texts.

Member Function Documentation

static const WCHAR* SmsStatusReportTextMap::GetReason ( ShortMessageStatus::Reason reason ) [inline, static]

static const WCHAR* SmsStatusReportTextMap::GetStatus ( ShortMessageStatus::Status state ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 01:59:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsStatusTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsStatusTextMap Class Reference
[SMS]

Sms status. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsStatusTextMap:

[legend]
Collaboration diagram for SmsStatusTextMap:

[legend]

Static Public Member Functions

static UINT | GetStatusCount ()
static const WCHAR * | GetStatusName (INT index)

Detailed Description

Sms status.

Member Function Documentation

static UINT SmsStatusTextMap::GetStatusCount ( ) [inline, static]

static const WCHAR* SmsStatusTextMap::GetStatusName ( INT index ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 01:59:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsStorageTypeTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsStorageTypeTextMap Class Reference
[SMS]

Sms storage types. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsStorageTypeTextMap:

[legend]
Collaboration diagram for SmsStorageTypeTextMap:

[legend]

Static Public Member Functions

static UINT | GetStorageTypeCount ()
static const WCHAR * | GetStorageTypeName (INT index)

Detailed Description

Sms storage types.

Member Function Documentation

static UINT SmsStorageTypeTextMap::GetStorageTypeCount ( ) [inline, static]

static const WCHAR* SmsStorageTypeTextMap::GetStorageTypeName ( INT index ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 01:59:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsSubmit Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsSubmit Class Reference

#include <Apoxi/Apc/Sms.hpp>

Inheritance diagram for SmsSubmit:

[legend]
Collaboration diagram for SmsSubmit:

[legend]

Public Types

enum | { ID = MessageTypeIndicator::Submit }
enum | { c_max_guaranteed_user_data_size = 140 }
typedef Sms | Base

Public Member Functions

DataCodingScheme | GetDataCodingScheme () const
TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]).
PhoneNumber | GetDestinationAddress () const
TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).
INT | GetMaxUserDataSize () const
SmsReferenceNumber | GetMessageReference () const
TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).
ProtocolIdentifier | GetProtocolIdentifier () const
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
WString | GetText () const
UserData | GetUserData () const
TP-UD: TP-User-Data (3GPP 23.040 V5.1.0 [9.2.3.24]) TP-User-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.16]).
ValidityPeriod | GetValidityPeriod () const
TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12]).
ValidityPeriodFormat | GetValidityPeriodFormat () const
TP-VPF: TP-Validity-Period-Format (3GPP 23.040 V5.1.0 [9.2.3.3]).
BOOLEAN | RejectDuplicates () const
TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25]).
BOOLEAN | RequestReplyPath () const
TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]).
BOOLEAN | RequestReport () const
TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).
void | SetDataCodingScheme (const DataCodingScheme &dcs)
TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]).
void | SetDestinationAddress (const PhoneNumber &phone_number)
TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).
void | SetMessageReference (const SmsReferenceNumber &message_reference)
TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).
void | SetProtocolIdentifier (ProtocolIdentifier protocol_identifier)
TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).
void | SetRejectDuplicates (BOOLEAN flag=TRUE)
TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25]).
void | SetRequestReplyPath (BOOLEAN flag=TRUE)
TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]).
void | SetRequestReport (BOOLEAN flag=TRUE)
TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).
void | SetUserDataHeaderExists (BOOLEAN flag=TRUE)
TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).
void | SetValidityPeriod (const ValidityPeriod &vp)
TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12]).
void | SetValidityPeriodFormat (const ValidityPeriodFormat &vpf)
TP-VPF: TP-Validity-Period-Format (3GPP 23.040 V5.1.0 [9.2.3.3]).
SmsSubmit (Tpdu *tpdu)
INT | Trim ()
Reduces the size of the TPDU to the maximum needed. Tpdu reallocation is performed!!
BOOLEAN | UserDataHeaderExists () const
TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).
~SmsSubmit ()

Friends

class | SmsFactory

Detailed Description

3GPP TS 23.040 V5.1.0 [9.2.2.2] - Attention: This class is a wrapper over a data-stream (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Member Typedef Documentation

typedef Sms SmsSubmit::Base

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

anonymous enum

Enumerator:
c_max_guaranteed_user_data_size guaranteed length of UserData (excl. UserDataLength byte) - (3GPP 23.040 V5.1.0 [9.2.2.2])

Constructor & Destructor Documentation

SmsSubmit::SmsSubmit ( Tpdu * tpdu )

SmsSubmit::~SmsSubmit ( )

Member Function Documentation

DataCodingScheme SmsSubmit::GetDataCodingScheme ( ) const

TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]).

PhoneNumber SmsSubmit::GetDestinationAddress ( ) const

TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).

INT SmsSubmit::GetMaxUserDataSize ( ) const

Returns the maximum possible size (in bytes) of the userdata (inclusive the userdata-length byte). The size varies dependent on the size of the header-parameter.

SmsReferenceNumber SmsSubmit::GetMessageReference ( ) const

TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).

ProtocolIdentifier SmsSubmit::GetProtocolIdentifier ( ) const

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

WString SmsSubmit::GetText ( ) const

UserData SmsSubmit::GetUserData ( ) const

TP-UD: TP-User-Data (3GPP 23.040 V5.1.0 [9.2.3.24]) TP-User-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.16]).

ValidityPeriod SmsSubmit::GetValidityPeriod ( ) const

TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12]).

ValidityPeriodFormat SmsSubmit::GetValidityPeriodFormat ( ) const

TP-VPF: TP-Validity-Period-Format (3GPP 23.040 V5.1.0 [9.2.3.3]).

BOOLEAN SmsSubmit::RejectDuplicates ( ) const

TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25]).

BOOLEAN SmsSubmit::RequestReplyPath ( ) const

TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]).

BOOLEAN SmsSubmit::RequestReport ( ) const

TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).

void SmsSubmit::SetDataCodingScheme ( const DataCodingScheme & dcs )

TP-DCS: TP-Data-Coding-Scheme (3GPP 23.040 V5.1.0 [9.2.3.10]).

void SmsSubmit::SetDestinationAddress ( const PhoneNumber & phone_number )

TP-DA: TP-Destination-Address (3GPP 23.040 V5.1.0 [9.2.3.8]).

void SmsSubmit::SetMessageReference ( const SmsReferenceNumber & message_reference )

TP-MR: TP-Message-Reference (3GPP 23.040 V5.1.0 [9.2.3.6]).

void SmsSubmit::SetProtocolIdentifier ( ProtocolIdentifier protocol_identifier )

TP-PID: TP-Protocol-Identifier (3GPP 23.040 V5.1.0 [9.2.3.9]).

void SmsSubmit::SetRejectDuplicates ( BOOLEAN flag = TRUE )

TP-RD: TP-Reject-Duplicates (3GPP 23.040 V5.1.0 [9.2.3.25]).

void SmsSubmit::SetRequestReplyPath ( BOOLEAN flag = TRUE )

TP-RP: TP-Reply-Path (3GPP 23.040 V5.1.0 [9.2.3.17]).

void SmsSubmit::SetRequestReport ( BOOLEAN flag = TRUE )

TP-SRR: TP-Status-Report-Request (3GPP 23.040 V5.1.0 [9.2.3.5]).

void SmsSubmit::SetUserDataHeaderExists ( BOOLEAN flag = TRUE )

TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).

void SmsSubmit::SetValidityPeriod ( const ValidityPeriod & vp )

TP-VP: TP-Validity-Period (3GPP 23.040 V5.1.0 [9.2.3.12]).

void SmsSubmit::SetValidityPeriodFormat ( const ValidityPeriodFormat & vpf )

TP-VPF: TP-Validity-Period-Format (3GPP 23.040 V5.1.0 [9.2.3.3]).

INT SmsSubmit::Trim ( )

Reduces the size of the TPDU to the maximum needed. Tpdu reallocation is performed!!

BOOLEAN SmsSubmit::UserDataHeaderExists ( ) const

TP-UDHI: TP-User-Data-Header-Indication (3GPP 23.040 V5.1.0 [9.2.3.23]).

Friends And Related Function Documentation

friend class SmsFactory [friend]

The documentation for this class was generated from the following files:
  • Apc/Sms.hpp
  • Apc/Sms.cpp
Generated on Wed Jan 25 02:00:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsTelematicDeviceNameTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsTelematicDeviceNameTable Class Reference
[SMS]

Telematice device names. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsTelematicDeviceNameTable:

[legend]
Collaboration diagram for SmsTelematicDeviceNameTable:

[legend]

Static Public Member Functions

static const WCHAR * GetDeviceName (ProtocolIdentifier::TelematicDevice device)

Detailed Description

Telematice device names.

Member Function Documentation

static const WCHAR* SmsTelematicDeviceNameTable::GetDeviceName ( ProtocolIdentifier::TelematicDevice device ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 02:00:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsTemplateProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsTemplateProvider Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsTemplateProvider.hpp>

Inheritance diagram for SmsTemplateProvider:

[legend]
Collaboration diagram for SmsTemplateProvider:

[legend]

Public Member Functions

virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init ()
virtual INT | RowCount ()
RowCount returns the number of rows.
SmsTemplateProvider ()
virtual | ~SmsTemplateProvider ()

Detailed Description

Provider for SMS tamplates. Template texts are defined in SmsTextMaps.

Following column ids are defined:
c_sms_recno_id | NumberType | Returns row + 1.
c_sms_pos_id | NumberType | Returns row + 1.
c_sms_status_id | NumberTypeTpdu::Status enum (usually Tpdu::Unsent) |
c_mmisms_template_title_id | WStringType | The The title for the template.
c_sms_string_id | WStringType | The template text.
c_sms_msg_type_id | NumberType | MessageTypeIndicator::Type enum (usually MessageTypeIndicator::ReservedType).
c_sms_conc_status_id | NumberType | ConcatenetedStatus enumeration (usually NormalSms).
c_sms_dcs_id | NumberType | DataCodingScheme value (usually 0).

Constructor & Destructor Documentation

SmsTemplateProvider::SmsTemplateProvider ( )

SmsTemplateProvider::~SmsTemplateProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SmsTemplateProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT SmsTemplateProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void SmsTemplateProvider::Init ( )

INT SmsTemplateProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTemplateProvider.hpp
  • Applications/Ems/Sms/SmsTemplateProvider.cpp
Generated on Wed Jan 25 02:00:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsTemplateTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsTemplateTextMap Class Reference
[SMS]

Sms templates. More...

#include <Applications/Ems/Sms/SmsTextMaps.hpp>

Inheritance diagram for SmsTemplateTextMap:

[legend]
Collaboration diagram for SmsTemplateTextMap:

[legend]

Static Public Member Functions

static UINT | GetTemplateCount ()
static const WCHAR * | GetTemplateText (INT index)
static const WCHAR * | GetTemplateTitle (INT index)

Detailed Description

Sms templates.

Member Function Documentation

static UINT SmsTemplateTextMap::GetTemplateCount ( ) [inline, static]

static const WCHAR* SmsTemplateTextMap::GetTemplateText ( INT index ) [inline, static]

static const WCHAR* SmsTemplateTextMap::GetTemplateTitle ( INT index ) [inline, static]

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextMaps.hpp
  • Applications/Ems/Sms/SmsTextMaps.cpp
Generated on Wed Jan 25 02:00:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsTextEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsTextEntry Struct Reference
[ExtractSmsTextPlugin]

#include <Applications/Ems/Sms/SmsTextParser.hpp>

Collaboration diagram for SmsTextEntry:

[legend]

Data Fields

INT idxPos
WString text
SmsTextItemType type

Field Documentation

INT SmsTextEntry::idxPos

WString SmsTextEntry::text

SmsTextItemType SmsTextEntry::type

The documentation for this struct was generated from the following file:
  • Applications/Ems/Sms/SmsTextParser.hpp
Generated on Wed Jan 25 02:00:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsTextParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsTextParser Class Reference
[ExtractSmsTextPlugin]

#include <Applications/Ems/Sms/SmsTextParser.hpp>

Collaboration diagram for SmsTextParser:

[legend]

Public Member Functions

const SmsTextEntry & | GetItem (const INT index) const
returns the entry at the given position in the m_textEntries vector
INT | GetItemCount () const
returns the number of entries in the m_textEntries vector
void | Scan (const WString &text)
parses the text and stores the found items into the m_textEntries vector
virtual | ~SmsTextParser ()

Data Structures

struct | SmsTextItemAttributes

Constructor & Destructor Documentation

SmsTextParser::~SmsTextParser ( ) [virtual]

Member Function Documentation

const SmsTextEntry & SmsTextParser::GetItem ( const INT index ) const

returns the entry at the given position in the m_textEntries vector

INT SmsTextParser::GetItemCount ( ) const

returns the number of entries in the m_textEntries vector

void SmsTextParser::Scan ( const WString & text )

parses the text and stores the found items into the m_textEntries vector

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsTextParser.hpp
  • Applications/Ems/Sms/SmsTextParser.cpp
Generated on Wed Jan 25 02:00:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsUnreadProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsUnreadProvider Class Reference
[Provider]

#include <Apoxi/Adc/SmsUnreadProvider.hpp>

Inheritance diagram for SmsUnreadProvider:

[legend]
Collaboration diagram for SmsUnreadProvider:

[legend]

Public Member Functions

virtual INT | GetProviderId () const
Returns the provider id.
virtual INT | RowCount ()
RowCount returns the number of rows.
SmsUnreadProvider ()
virtual | ~SmsUnreadProvider ()

Protected Member Functions

virtual Tpdu::Status | GetDestinationTpduStatus () const
virtual SmsFilterType | GetSmsFilterType () const

Detailed Description

SmsUnreadProvider is the provider to retrieve the unread sms from the sim. The message type indicator can both be Statusreport and Deliver. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_sms_unread_provider_id

NOTE: c_sms_base_unread_provider_id is used if APOXI_SMS_NEW_PROVIDERS is defined.

Please refer to SmsProvider for possible columns

NOTE: Please do not instantiate this class.

Constructor & Destructor Documentation

SmsUnreadProvider::SmsUnreadProvider ( )

SmsUnreadProvider::~SmsUnreadProvider ( ) [virtual]

Member Function Documentation

virtual Tpdu::Status SmsUnreadProvider::GetDestinationTpduStatus ( ) const [inline, protected, virtual]

Reimplemented from SmsProvider.

INT SmsUnreadProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Reimplemented from SmsProvider.

virtual SmsFilterType SmsUnreadProvider::GetSmsFilterType ( ) const [inline, protected, virtual]

Reimplemented from SmsProvider.

INT SmsUnreadProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Reimplemented from SmsProvider.

The documentation for this class was generated from the following files:
  • Adc/SmsUnreadProvider.hpp
  • Adc/SmsUnreadProvider.cpp
Generated on Wed Jan 25 02:00:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsUnsentProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsUnsentProvider Class Reference
[Provider]

#include <Apoxi/Adc/SmsUnsentProvider.hpp>

Inheritance diagram for SmsUnsentProvider:

[legend]
Collaboration diagram for SmsUnsentProvider:

[legend]

Public Member Functions

virtual INT | GetProviderId () const
Returns the provider id.
virtual INT | RowCount ()
RowCount returns the number of rows.
SmsUnsentProvider ()
virtual | ~SmsUnsentProvider ()

Protected Member Functions

virtual Tpdu::Status | GetDestinationTpduStatus () const
virtual SmsFilterType | GetSmsFilterType () const

Detailed Description

SmsUnsentProvider is the provider to retrieve the unsent sms from the sim. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_sms_unsent_provider_id

Please refer to SmsProvider for possible columns

After sending the sms ToogleRow must be called and the state of the sms will be set to sent. The sms will then appear in the SmsSentProvider and disappear in SmsUnsentProvider.

NOTE: Please do not instantiate this class.

Constructor & Destructor Documentation

SmsUnsentProvider::SmsUnsentProvider ( )

SmsUnsentProvider::~SmsUnsentProvider ( ) [virtual]

Member Function Documentation

virtual Tpdu::Status SmsUnsentProvider::GetDestinationTpduStatus ( ) const [inline, protected, virtual]

Reimplemented from SmsProvider.

INT SmsUnsentProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Reimplemented from SmsProvider.

virtual SmsFilterType SmsUnsentProvider::GetSmsFilterType ( ) const [inline, protected, virtual]

Reimplemented from SmsProvider.

INT SmsUnsentProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Reimplemented from SmsProvider.

The documentation for this class was generated from the following files:
  • Adc/SmsUnsentProvider.hpp
  • Adc/SmsUnsentProvider.cpp
Generated on Wed Jan 25 02:00:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsUtility Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsUtility Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsUtility.hpp>

Inheritance diagram for SmsUtility:

[legend]
Collaboration diagram for SmsUtility:

[legend]

Public Member Functions

AbstractSmsComposeWin * GetSmsComposer ()
void | Init ()
void | SendImpl (const SmsContext &profile, const EditorDocumentObtainer &obtainer)
SmsUtility ()
~SmsUtility ()

Static Public Member Functions

static SmsUtility * | GetInstance ()

Detailed Description

Application Class for the SmsClient

Constructor & Destructor Documentation

SmsUtility::SmsUtility ( )

SmsUtility::~SmsUtility ( )

Member Function Documentation

SmsUtility * SmsUtility::GetInstance ( ) [static]

AbstractSmsComposeWin* SmsUtility::GetSmsComposer ( ) [inline, virtual]

Implements AbstractSmsUtilityProcessor.

void SmsUtility::Init ( )

void SmsUtility::SendImpl | ( | const SmsContext & | profile,
 |  | const EditorDocumentObtainer & | obtainer
 | ) | [virtual]

Implements sending of an SMS. If a parameter is set to 0, the previously specified value should be used.

Implements AbstractSmsUtilityProcessor.

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsUtility.hpp
  • Applications/Ems/Sms/SmsUtility.cpp
Generated on Wed Jan 25 02:00:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsViewerWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsViewerWin Class Reference
[SMS]

#include <Applications/Ems/Sms/SmsViewerWin.hpp>

Inheritance diagram for SmsViewerWin:

[legend]
Collaboration diagram for SmsViewerWin:

[legend]

Public Member Functions

virtual const EditorDocument * | GetDocument () const
SmsTextEntry GetSelectedSmsEmbItem ()
void | GoToSmsEmbItems (Direction dir)
void | Init (SmsApp *sms_app)
virtual void | OnGetFocus ()
virtual void | SetDocument (const EditorDocument *doc)
SmsViewerWin ()
virtual | ~SmsViewerWin ()

Protected Member Functions

virtual void | OnDisplaySms (Provider *provider, INT row, INT set_index=-1)
It is an overloaded function which retrieves the text from the information of passed provider and row index and set the text to the MultiLineEditor.
virtual void | OnLayoutClient ()

Detailed Description

SmsViewerWin is the message viewer window responsible for the display of the selected SMS content.

Constructor & Destructor Documentation

SmsViewerWin::SmsViewerWin ( )

SmsViewerWin::~SmsViewerWin ( ) [virtual]

Member Function Documentation

const EditorDocument * SmsViewerWin::GetDocument ( ) const [virtual]

Implements AbstractSmsViewerWin.

SmsTextEntry SmsViewerWin::GetSelectedSmsEmbItem ( ) [virtual]

Implements AbstractSmsViewerWin.

void SmsViewerWin::GoToSmsEmbItems ( Direction dir )

void SmsViewerWin::Init ( SmsApp * sms_app )

void SmsViewerWin::OnDisplaySms | ( | Provider * | provider,
 |  | INT | row,
 |  | INT | set_index = -1
 | ) | [protected, virtual]

It is an overloaded function which retrieves the text from the information of passed provider and row index and set the text to the MultiLineEditor.

Implements AbstractSmsViewerWin.

void SmsViewerWin::OnGetFocus ( ) [virtual]

See also:
Control::OnGetFocus

Reimplemented from AtlWindow.

void SmsViewerWin::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Window.

void SmsViewerWin::SetDocument ( const EditorDocument * doc ) [virtual]

Implements AbstractSmsViewerWin.

The documentation for this class was generated from the following files:
  • Applications/Ems/Sms/SmsViewerWin.hpp
  • Applications/Ems/Sms/SmsViewerWin.cpp
Generated on Wed Jan 25 02:00:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsWStringCache Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SmsWStringCache Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimPduHandler.hpp>

Collaboration diagram for SmsWStringCache:

[legend]

Public Types

enum | { c_invalid_rec_no = 0x2000 }
typedef FixedPtrArray< Entry > | CacheArray

Public Member Functions

UINT16 | GetRecNo (INT index) const
const WString & | GetWString (INT index) const
void | Init (INT noofentries, INT noofchars)
UINT16 | Put (const WString &string, UINT16 newrecno, UINT16 &cacheidx)
void | SetData (INT index, UINT16 recno, const WString &text)
SmsWStringCache ()
~SmsWStringCache ()

Data Structures

class | Entry

Member Typedef Documentation

typedef FixedPtrArray<Entry> SmsWStringCache::CacheArray

Member Enumeration Documentation

anonymous enum

Enumerator:
c_invalid_rec_no

Constructor & Destructor Documentation

SmsWStringCache::SmsWStringCache ( )

SmsWStringCache::~SmsWStringCache ( )

Member Function Documentation

UINT16 SmsWStringCache::GetRecNo ( INT index ) const [inline]

const WString& SmsWStringCache::GetWString ( INT index ) const [inline]

void SmsWStringCache::Init | ( | INT | noofentries,
 |  | INT | noofchars
 | ) |

UINT16 SmsWStringCache::Put | ( | const WString & | string,
 |  | UINT16 | newrecno,
 |  | UINT16 & | cacheidx
 | ) |

void SmsWStringCache::SetData | ( | INT | index,
 |  | UINT16 | recno,
 |  | const WString & | text
 | ) | [inline]

The documentation for this class was generated from the following files:
  • Adc/SimPduHandler.hpp
  • Adc/SimPduHandler.cpp
Generated on Wed Jan 25 02:00:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SmsWStringCache::Entry Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SmsWStringCache::Entry

SmsWStringCache::Entry Class Reference

#include <Apoxi/Adc/SimPduHandler.hpp>

Collaboration diagram for SmsWStringCache::Entry:

[legend]

Public Member Functions

Entry (INT size)
UINT16 | GetRecNo () const
const WString & | GetText () const
void | SetData (UINT16 recno, const WString &text)

Constructor & Destructor Documentation

SmsWStringCache::Entry::Entry ( INT size ) [inline]

Member Function Documentation

UINT16 SmsWStringCache::Entry::GetRecNo ( ) const [inline]

const WString& SmsWStringCache::Entry::GetText ( ) const [inline]

void SmsWStringCache::Entry::SetData | ( | UINT16 | recno,
 |  | const WString & | text
 | ) | [inline]

The documentation for this class was generated from the following file:
  • Adc/SimPduHandler.hpp
Generated on Wed Jan 25 02:00:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Socket Class Reference
[Socket]

#include <Apoxi/Socket/Socket.hpp>

Inheritance diagram for Socket:

[legend]
Collaboration diagram for Socket:

[legend]

Public Types

enum Event {
c_event_data_received, c_event_data_sent, c_event_conn_established, c_event_conn_failed,
c_event_conn_closed, c_event_conn_req_pending, c_event_bearer_lost
}

Public Member Functions

virtual BOOLEAN | Close ()=0
virtual BOOLEAN | IsBlocking () const =0
virtual BOOLEAN | IsOpen () const =0
virtual INT | Read (void *buf, INT buflen)=0
virtual BOOLEAN | SetBlocking (BOOLEAN block=FALSE)=0
virtual void | SetSocketEventListener (SocketEventListener *listener)
Socket ()
Constructor.
virtual INT | Write (const void *buf, INT buflen)=0
virtual | ~Socket ()
Destructor.

Static Public Member Functions

static BOOLEAN | IsInstanceValid (const Socket *socket)

Protected Member Functions

SocketEventListener * | GetSocketEventListener () const
Get current SocketEventListener.
virtual void | OnControlMsg (const SocketControlMsg &msg)

Friends

class | SocketHandler

Detailed Description

Abstract base class for all sockets.

Member Enumeration Documentation

enum Socket::Event

Enumerator:
c_event_data_received | Data has been received, it can be read from the socket.
c_event_data_sent | Data has been sent, it can be written to the socket.
c_event_conn_established | Connection to remote peer established (connection oriented sockets only).
c_event_conn_failed | Connection to remote peer failed (connection oriented sockets only).
c_event_conn_closed | Connection closed by remote peer (connection oriented sockets only).
c_event_conn_req_pending | The socket is waiting on a connection request (sent for server sockets only).
c_event_bearer_lost | The data connection bearer used by this socket has been abruptly lost.

Constructor & Destructor Documentation

Socket::Socket ( )

Constructor.

Socket::~Socket ( ) [virtual]

Destructor.

Member Function Documentation

virtual BOOLEAN Socket::Close ( ) [pure virtual]

Implemented in SerialTerminalSocket, SerialSocket, and InetSocket.

SocketEventListener* Socket::GetSocketEventListener ( ) const [inline, protected]

Get current SocketEventListener.

virtual BOOLEAN Socket::IsBlocking ( ) const [pure virtual]

Tells if the socket is in blocking mode.

Implemented in SerialTerminalSocket, SerialSocket, and InetSocket.

BOOLEAN Socket::IsInstanceValid ( const Socket * socket ) [static]

Checks if socket is a pointer to a valid socket. If the socket has been deleted then the pointer points to an invalid memory area. This method provides means to check if socket is still existing which is used e.g. when you get a pointer to a socket within a message.

Parameters:
socket The socket pointer to check for validity.

virtual BOOLEAN Socket::IsOpen ( ) const [pure virtual]

Implemented in SerialTerminalSocket, SerialSocket, and InetSocket.

void Socket::OnControlMsg ( const SocketControlMsg & msg ) [protected, virtual]

Translates the socket control message msg into a socket event and routes it accordingly. If a listener is set, its OnSocketEvent method is called. Otherwise the messages are discarded.

Reimplemented in SerialSocket, InetSocket, TcpServerSocket, TcpSocket, and UdpSocket.

virtual INT Socket::Read | ( | void * | buf,
 |  | INT | buflen
 | ) | [pure virtual]

Reads data from the socket.

Parameters:
buf | Pointer to read buffer.
buflen | Length of read buffer.
Returns:
Number of bytes written or -1 on failure.

Implemented in SerialTerminalSocket, SerialSocket, InetSocket, and TcpSocket.

virtual BOOLEAN Socket::SetBlocking ( BOOLEAN block = FALSE ) [pure virtual]

Enables/disables blocking mode on sockets. Changing blocking mode with pending Read() or Write() requests may produce unpredictable results. Using APOXI sockets in blocking mode is depreciated, APOXI sockets default to non-blocking mode. Socket events are sent to the socket independent of the blocking mode.

Implemented in SerialTerminalSocket, SerialSocket, and InetSocket.

virtual void Socket::SetSocketEventListener ( SocketEventListener * listener ) [inline, virtual]

Sets the socket listener to receive callbacks when socket events occur. The application holding the listener and the observed socket must be within the same application context!

Parameters:
listener The socket listener.

Reimplemented in SerialTerminalSocket.

virtual INT Socket::Write | ( | const void * | buf,
 |  | INT | buflen
 | ) | [pure virtual]

Writes data to the socket.

Parameters:
buf | Pointer to write buffer.
buflen | Length of write buffer.
Returns:
Number of bytes written or -1 on failure.

Implemented in SerialTerminalSocket, SerialSocket, InetSocket, TcpSocket, and LcsSocket.

Friends And Related Function Documentation

friend class SocketHandler [friend]

Reimplemented in InetSocket.

The documentation for this class was generated from the following files:
  • Socket/Socket.hpp
  • Socket/Socket.cpp
Generated on Wed Jan 25 02:00:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketAddr Class Reference

#include <Apoxi/AddOns/SerialSocket/SockAddress.hpp>

Inheritance diagram for SocketAddr:

[legend]

Public Member Functions

virtual void * | GetSockAddr ()=0
virtual INT32 | GetSockAddrSize ()=0
SocketAddr ()
virtual | ~SocketAddr ()

Constructor & Destructor Documentation

SocketAddr::SocketAddr ( ) [inline]

Default constructor.

virtual SocketAddr::~SocketAddr ( ) [inline, virtual]

Destructor.

Member Function Documentation

virtual void* SocketAddr::GetSockAddr ( ) [pure virtual]

This is used only for internal purposes.

Returns:
void pointer.

Implemented in RfcommSocketAddr, L2CapSocketAddr, and IrSocketAddr.

virtual INT32 SocketAddr::GetSockAddrSize ( ) [pure virtual]

Implemented in RfcommSocketAddr, L2CapSocketAddr, and IrSocketAddr.

The documentation for this class was generated from the following file:
  • AddOns/SerialSocket/SockAddress.hpp
Generated on Wed Jan 25 02:00:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketControlMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketControlMsg Class Reference

#include <Apoxi/Socket/SocketMsg.hpp>

Inheritance diagram for SocketControlMsg:

[legend]
Collaboration diagram for SocketControlMsg:

[legend]

Public Types

enum | { ID = 19101 }

Public Member Functions

virtual Message * | Clone () const
const SocketControlMsgType & | GetControlType () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetMsgId () const
Socket * | GetSocket () const
SocketData * | GetSocketData () const
void | SetControlType (const SocketControlMsgType &control_type)
void | SetSocketData (SocketData *socket_data)
SocketControlMsg (ExecutionContext *context, UINT32 msg_id, Socket *socket, const SocketControlMsgType &control_type)
SocketControlMsg (ExecutionContext *context, UINT32 msg_id, SocketData *socket_data, const SocketControlMsgType &control_type)
virtual | ~SocketControlMsg ()

Detailed Description

APOXI socket sub-system private message.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SocketControlMsg::SocketControlMsg | ( | ExecutionContext * | context,
 |  | UINT32 | msg_id,
 |  | SocketData * | socket_data,
 |  | const SocketControlMsgType & | control_type
 | ) |

SocketControlMsg::SocketControlMsg | ( | ExecutionContext * | context,
 |  | UINT32 | msg_id,
 |  | Socket * | socket,
 |  | const SocketControlMsgType & | control_type
 | ) |

SocketControlMsg::~SocketControlMsg ( ) [virtual]

Member Function Documentation

Message * SocketControlMsg::Clone ( ) const [virtual]

Implements Message.

const SocketControlMsgType& SocketControlMsg::GetControlType ( ) const [inline]

const MsgMetaData & SocketControlMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

UINT32 SocketControlMsg::GetMsgId ( ) const [inline]

Socket * SocketControlMsg::GetSocket ( ) const

SocketData* SocketControlMsg::GetSocketData ( ) const [inline]

void SocketControlMsg::SetControlType ( const SocketControlMsgType & control_type ) [inline]

void SocketControlMsg::SetSocketData ( SocketData * socket_data ) [inline]

The documentation for this class was generated from the following files:
  • Socket/SocketMsg.hpp
  • Socket/SocketMsg.cpp
Generated on Wed Jan 25 02:00:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketData Class Reference
[Socket]

#include <Apoxi/Socket/SocketData.hpp>

Inheritance diagram for SocketData:

[legend]
Collaboration diagram for SocketData:

[legend]

Public Member Functions

BOOLEAN | Close ()
InetSocket * | GetAttachedSocket () const
ExecutionContext * | GetContext () const
DataConn & | GetDataConn () const
DataConnProfileId | GetDataConnProfileId () const
SocketError | GetError () const
BOOLEAN | IsInUse () const
BOOLEAN | Listen (INT backlog)
BOOLEAN | ReleaseDataConn ()
void | ResetDataConnIdleTimer () const
void | SetDataConnProfileId (DataConnProfileId id)
BOOLEAN | SetError (BOOLEAN ok)
BOOLEAN | SetError (SocketError err)
BOOLEAN | SetupDataConn ()

Friends

class | DataConn
class | InetSocket
class | SerialSocketData
class | SocketSubSystem
class | TcpServerSocket
class | TcpSocket
class | UdpSocket

Data Structures

class | SdCond

Member Function Documentation

BOOLEAN SocketData::Close ( )

Closes the socket and resets the internal listening marker.

Reimplemented from SysSocket.

InetSocket* SocketData::GetAttachedSocket ( ) const [inline]

ExecutionContext* SocketData::GetContext ( ) const [inline]

Reimplemented in SerialSocketData.

DataConn & SocketData::GetDataConn ( ) const

Returns reference to the active data connection. This method asserts if the data connection is not set active.

DataConnProfileId SocketData::GetDataConnProfileId ( ) const [inline]

SocketError SocketData::GetError ( ) const [inline]

BOOLEAN SocketData::IsInUse ( ) const [inline]

Reimplemented in SerialSocketData.

BOOLEAN SocketData::Listen ( INT backlog )

Sets the socket to listen mode and internally marks it as such.

Reimplemented from SysSocket.

BOOLEAN SocketData::ReleaseDataConn ( )

Releases a data connection.

void SocketData::ResetDataConnIdleTimer ( ) const

Resets the idle timer of the associated data connection. If there is activity on this socket then the idle timer of the data connection shall be reset.

void SocketData::SetDataConnProfileId ( DataConnProfileId id ) [inline]

BOOLEAN SocketData::SetError ( BOOLEAN ok ) [inline]

BOOLEAN SocketData::SetError ( SocketError err ) [inline]

BOOLEAN SocketData::SetupDataConn ( )

Sets up a data connection.

Friends And Related Function Documentation

friend class DataConn [friend]

Reimplemented from SysSocket.

friend class InetSocket [friend]

friend class SerialSocketData [friend]

friend class SocketSubSystem [friend]

friend class TcpServerSocket [friend]

friend class TcpSocket [friend]

friend class UdpSocket [friend]

The documentation for this class was generated from the following files:
  • Socket/SocketData.hpp
  • Socket/SocketData.cpp
Generated on Wed Jan 25 02:00:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketDataLock Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketDataLock Class Reference
[Socket]

#include <Apoxi/Socket/SocketDataLock.hpp>

Inheritance diagram for SocketDataLock:

[legend]
Collaboration diagram for SocketDataLock:

[legend]

Public Member Functions

SocketDataLock ()

Detailed Description

SocketDataLock is a private class of Apoxi socket subsystem. It is used to protect shared data from mutual access.

Constructor & Destructor Documentation

SocketDataLock::SocketDataLock ( ) [inline]

The documentation for this class was generated from the following file:
  • Socket/SocketDataLock.hpp
Generated on Wed Jan 25 02:00:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketEventListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketEventListener Class Reference
[Socket]

#include <Apoxi/Socket/Socket.hpp>

Inheritance diagram for SocketEventListener:

[legend]

Public Member Functions

virtual void | OnSocketEvent (Socket::Event event, Socket *socket)=0
SocketEventListener ()
virtual | ~SocketEventListener ()

Detailed Description

Abstract base class for SocketEventListener. A SocketEventListener is notified on socket events.

See also:
Socket::SocketEventListener

Constructor & Destructor Documentation

SocketEventListener::SocketEventListener ( )

SocketEventListener::~SocketEventListener ( ) [virtual]

Member Function Documentation

virtual void SocketEventListener::OnSocketEvent | ( | Socket::Event | event,
 |  | Socket * | socket
 | ) | [pure virtual]

Is called on socket events when something with the socket happened, e.g. data can be read or data has been sent successfully.

See also:
Socket::Event
Parameters:
event | Received event.
socket | Socket that receives the event.

The documentation for this class was generated from the following files:
  • Socket/Socket.hpp
  • Socket/Socket.cpp
Generated on Wed Jan 25 02:00:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketHandler Class Reference
[Socket]

#include <Apoxi/Socket/SocketHandler.hpp>

Inheritance diagram for SocketHandler:

[legend]
Collaboration diagram for SocketHandler:

[legend]

Public Member Functions

void | Init ()
void | Release ()
SocketHandler ()
virtual | ~SocketHandler ()

Detailed Description

SocketHandler is the execution context local control instance of sockets. Each execution context using sockets has to create an instance of SocketHandler.

Constructor & Destructor Documentation

SocketHandler::SocketHandler ( )

SocketHandler::~SocketHandler ( ) [virtual]

Member Function Documentation

void SocketHandler::Init ( )

Initialize SocketHandler - sockets wont work for execution context unless SocketHandler has been initialized.

void SocketHandler::Release ( )

Free resources allocated by prior Init call. Free must be invoked before the SocketHandler gets destroyed.

The documentation for this class was generated from the following files:
  • Socket/SocketHandler.hpp
  • Socket/SocketHandler.cpp
Generated on Wed Jan 25 02:00:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketPeer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketPeer Class Reference

#include <Apoxi/Kernel/Os/Nuc32/SocketPeer.hpp>

Public Member Functions

BOOLEAN | Accept (const String &address, UINT16 port)
BOOLEAN | Bind (UINT16 port)
void | Close ()
BOOLEAN | Connect (const String &address, UINT16 port)
UINT32 | GetAvailableCount ()
INT | GetLingerTimeout ()
String | GetLocalName () const
UINT16 | GetLocalPort () const
String | GetPeerName () const
UINT16 | GetPeerPort () const
BOOLEAN | IsLingerEnabled ()
BOOLEAN | Listen (INT backlog=1)
BOOLEAN | Read (BYTE *data, UINT length)
void | SetBlockingEnabled (BOOLEAN flag)
void | SetLinger (BOOLEAN flag, INT timeout)
SocketPeer ()
BOOLEAN | Write (const BYTE *data, UINT length)
virtual | ~SocketPeer ()

Constructor & Destructor Documentation

SocketPeer::SocketPeer ( )

SocketPeer::~SocketPeer ( ) [virtual]

Member Function Documentation

BOOLEAN SocketPeer::Accept | ( | const String & | address,
 |  | UINT16 | port
 | ) |

BOOLEAN SocketPeer::Bind ( UINT16 port )

void SocketPeer::Close ( )

BOOLEAN SocketPeer::Connect | ( | const String & | address,
 |  | UINT16 | port
 | ) |

UINT32 SocketPeer::GetAvailableCount ( )

INT SocketPeer::GetLingerTimeout ( )

String SocketPeer::GetLocalName ( ) const

UINT16 SocketPeer::GetLocalPort ( ) const

String SocketPeer::GetPeerName ( ) const

UINT16 SocketPeer::GetPeerPort ( ) const

BOOLEAN SocketPeer::IsLingerEnabled ( )

BOOLEAN SocketPeer::Listen ( INT backlog = 1 )

BOOLEAN SocketPeer::Read | ( | BYTE * | data,
 |  | UINT | length
 | ) |

void SocketPeer::SetBlockingEnabled ( BOOLEAN flag )

void SocketPeer::SetLinger | ( | BOOLEAN | flag,
 |  | INT | timeout
 | ) |

BOOLEAN SocketPeer::Write | ( | const BYTE * | data,
 |  | UINT | length
 | ) |

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/SocketPeer.hpp
  • Kernel/Os/Nuc32/SocketPeer.cpp
Generated on Wed Jan 25 02:00:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketRxThread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketRxThread Class Reference
[Socket]

#include <Apoxi/Socket/SocketRxThread.hpp>

Inheritance diagram for SocketRxThread:

[legend]
Collaboration diagram for SocketRxThread:

[legend]

Public Member Functions

BOOLEAN | Init ()
SocketRxThread ()

Static Public Member Functions

static BOOLEAN | NotifyOnDataRecv (const SocketData *sd, BOOLEAN enable=TRUE)
static BOOLEAN | NotifyOnReadyToSend (const SocketData *sd, BOOLEAN enable=TRUE)
static BOOLEAN | Shutdown ()
static BOOLEAN | StopNotifications (const SocketData *sd)
static BOOLEAN | Wakeup ()

Constructor & Destructor Documentation

SocketRxThread::SocketRxThread ( )

Member Function Documentation

BOOLEAN SocketRxThread::Init ( )

BOOLEAN SocketRxThread::NotifyOnDataRecv | ( | const SocketData * | sd,
 |  | BOOLEAN | enable = TRUE
 | ) | [static]

BOOLEAN SocketRxThread::NotifyOnReadyToSend | ( | const SocketData * | sd,
 |  | BOOLEAN | enable = TRUE
 | ) | [static]

BOOLEAN SocketRxThread::Shutdown ( ) [static]

BOOLEAN SocketRxThread::StopNotifications ( const SocketData * sd ) [static]

BOOLEAN SocketRxThread::Wakeup ( ) [static]

The documentation for this class was generated from the following files:
  • Socket/SocketRxThread.hpp
  • Socket/SocketRxThread.cpp
Generated on Wed Jan 25 02:00:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketSerialTerminalListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketSerialTerminalListener Class Reference

#include <Apoxi/AddOns/MmCall/SocketSerialTerminalListener.hpp>

Inheritance diagram for SocketSerialTerminalListener:

[legend]
Collaboration diagram for SocketSerialTerminalListener:

[legend]

Public Types

typedef SerialTerminalListener | Base

Public Member Functions

virtual void | OnTerminalEvent (SerialTerminal &terminal, SerialTerminal::Event event)
void | SetActive (BOOLEAN active)
void | SetSocketExecutionContext (ExecutionContext *context)
SocketSerialTerminalListener (SerialTerminalSocket &socket)
Constructor.
virtual | ~SocketSerialTerminalListener ()
Destructor.

Detailed Description

Implements the interface SerialTerminalListener. SocketSerialTerminalListener maps terminal events to SocketControl Messages

Member Typedef Documentation

typedef SerialTerminalListener SocketSerialTerminalListener::Base

Constructor & Destructor Documentation

SocketSerialTerminalListener::SocketSerialTerminalListener ( SerialTerminalSocket & socket )

Constructor.

SocketSerialTerminalListener::~SocketSerialTerminalListener ( ) [virtual]

Destructor.

Member Function Documentation

void SocketSerialTerminalListener::OnTerminalEvent | ( | SerialTerminal & | terminal,
 |  | SerialTerminal::Event | event
 | ) | [virtual]

See also:
SerialTerminlListener::OnTerminalEvent

Implements SerialTerminalListener.

void SocketSerialTerminalListener::SetActive ( BOOLEAN active ) [inline]

Interface for enabling or disabling the listener.

Parameters:
active determines if listener should listen.

void SocketSerialTerminalListener::SetSocketExecutionContext ( ExecutionContext * context ) [inline]

Set the execution contexet of the socket, to enable the listener to send messages to the correct context

Parameters:
context The execution context the socket is assigned to

The documentation for this class was generated from the following files:
  • AddOns/MmCall/SocketSerialTerminalListener.hpp
  • AddOns/MmCall/SocketSerialTerminalListener.cpp
Generated on Wed Jan 25 02:00:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketSubSystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketSubSystem Class Reference
[Socket]

#include <Apoxi/Socket/SocketSubSystem.hpp>

Inheritance diagram for SocketSubSystem:

[legend]
Collaboration diagram for SocketSubSystem:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual BootSequenceState | InvokeAt () const
virtual void | OnPowerDown ()
virtual void | OnPowerUp ()
SocketSubSystem ()

Static Public Member Functions

static SocketSubSystem * | GetInstance ()

Friends

class | DataConn
class | InetSocket
class | Os
class | SocketDataLock
class | SocketRxThread
class | SysSocket
class | TcpServerSocket

Detailed Description

Socket private class. SocketSubSystem holds vital data of the Apoxi socket implementation and is responsible to boot and initialize the socket backbone on power on.

Constructor & Destructor Documentation

SocketSubSystem::SocketSubSystem ( )

Member Function Documentation

static SocketSubSystem* SocketSubSystem::GetInstance ( ) [inline, static]

virtual const WCHAR* SocketSubSystem::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

SocketSubSystem::BootSequenceState SocketSubSystem::InvokeAt ( ) const [virtual]

InvokeAt denotes the system boot phase the SubSystem shall be initialized in.

Implements SubSystem.

void SocketSubSystem::OnPowerDown ( ) [virtual]

This method will be invoked on system power down.

Reimplemented from SubSystem.

void SocketSubSystem::OnPowerUp ( ) [virtual]

This method will be invoked on system power on.

Reimplemented from SubSystem.

Friends And Related Function Documentation

friend class DataConn [friend]

friend class InetSocket [friend]

friend class Os [friend]

friend class SocketDataLock [friend]

friend class SocketRxThread [friend]

friend class SysSocket [friend]

friend class TcpServerSocket [friend]

The documentation for this class was generated from the following files:
  • Socket/SocketSubSystem.hpp
  • Socket/SocketSubSystem.cpp
Generated on Wed Jan 25 02:00:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestApp Class Reference

#include <Applications/SocketTest/SocketTestApp.hpp>

Collaboration diagram for SocketTestApp:

[legend]

Public Member Functions

BOOLEAN | areTestsFinished ()
returns TRUE if tests are finished
void | FindDataConnProfiles ()
finds data connection profiles for all types of connection
INT | GetCurrentTestGroup ()
returns group number of currently executed test group
INT | GetCurrentTestID ()
returns test ID of currently executed test
INT | GetCurrentTestNr ()
returns currently executed test number
FfsTestBase * | GetFfsTestBase ()
returns pointer to FFS tests
INT | GetLastError ()
returns the last error code of current test
UINT32 | GetLastIteration ()
returns number of finished iterations for current test
SocketTestT::Status GetLastStatus ()
returns the status of last executed test
UINT32 | GetSuccessfullIterations ()
returns number of succesful iterations for current test
SocketTestTests * | GetTests ()
returns pointer to tests
UINT32 | GetTotalIterations ()
returns number of iterations for current test
void | Init ()
initialization of SocketTestApp object
void | SkipCurrentTest ()
skips current test
void | StartTests ()
starts execution of tests
void | StartTimeoutTimer ()
Sets timeout after which current test will be stopped.
void | StopTests ()
stops execution of tests
void | StopTimeoutTimer ()
Stops timeout timer.
virtual | ~SocketTestApp ()
destructor

Static Public Member Functions

static SocketTestApp * | GetInstance ()
returns the instance of SocketTestApp object

Data Fields

DataConnProfileId m_nCSDid
Data connection profile ID used for CSD connection.
DataConnProfileId m_nPSDid
Data connection profile ID used for PSD connection.
DataConnProfileId m_nSERid
Data connection profile ID used for PPP connection.
SocketTestApp::menuItems * m_settings

Protected Member Functions

BOOLEAN | OnMessage (const Message &msg)
called when message from system is received
void | OnOpen ()
called on application openeing
virtual void | OnStartup ()
virtual void | OnTimer ()
timeout timer calback function
void | OnTriggerNotification (INT16 arg)
called when notification from system received

Protected Attributes

CommonMessageBox | m_wait_msgbox

Static Protected Attributes

static SocketTestApp | m_app
singleton object instance

Friends

class | TriggerTimer< SocketTestApp >

Data Structures

struct | menuItems

Detailed Description

Main class of Socket Test application.

Constructor & Destructor Documentation

SocketTestApp::~SocketTestApp ( ) [virtual]

destructor

Member Function Documentation

BOOLEAN SocketTestApp::areTestsFinished ( ) [inline]

returns TRUE if tests are finished

void SocketTestApp::FindDataConnProfiles ( )

finds data connection profiles for all types of connection

INT SocketTestApp::GetCurrentTestGroup ( ) [inline]

returns group number of currently executed test group

INT SocketTestApp::GetCurrentTestID ( ) [inline]

returns test ID of currently executed test

INT SocketTestApp::GetCurrentTestNr ( ) [inline]

returns currently executed test number

FfsTestBase* SocketTestApp::GetFfsTestBase ( ) [inline]

returns pointer to FFS tests

static SocketTestApp* SocketTestApp::GetInstance ( ) [inline, static]

returns the instance of SocketTestApp object

INT SocketTestApp::GetLastError ( ) [inline]

returns the last error code of current test

UINT32 SocketTestApp::GetLastIteration ( ) [inline]

returns number of finished iterations for current test

SocketTestT::Status SocketTestApp::GetLastStatus ( ) [inline]

returns the status of last executed test

UINT32 SocketTestApp::GetSuccessfullIterations ( ) [inline]

returns number of succesful iterations for current test

SocketTestTests* SocketTestApp::GetTests ( ) [inline]

returns pointer to tests

UINT32 SocketTestApp::GetTotalIterations ( ) [inline]

returns number of iterations for current test

void SocketTestApp::Init ( )

initialization of SocketTestApp object

BOOLEAN SocketTestApp::OnMessage ( const Message & msg ) [protected]

called when message from system is received

void SocketTestApp::OnOpen ( ) [protected]

called on application openeing

void SocketTestApp::OnStartup ( ) [protected, virtual]

void SocketTestApp::OnTimer ( ) [protected, virtual]

timeout timer calback function

void SocketTestApp::OnTriggerNotification ( INT16 arg ) [protected]

called when notification from system received

void SocketTestApp::SkipCurrentTest ( )

skips current test

void SocketTestApp::StartTests ( )

starts execution of tests

void SocketTestApp::StartTimeoutTimer ( ) [inline]

Sets timeout after which current test will be stopped.

void SocketTestApp::StopTests ( )

stops execution of tests

void SocketTestApp::StopTimeoutTimer ( ) [inline]

Stops timeout timer.

Friends And Related Function Documentation

friend class TriggerTimer< SocketTestApp > [friend]

Field Documentation

SocketTestApp SocketTestApp::m_app [static, protected]

singleton object instance

DataConnProfileId SocketTestApp::m_nCSDid

Data connection profile ID used for CSD connection.

DataConnProfileId SocketTestApp::m_nPSDid

Data connection profile ID used for PSD connection.

DataConnProfileId SocketTestApp::m_nSERid

Data connection profile ID used for PPP connection.

struct SocketTestApp::menuItems * SocketTestApp::m_settings

CommonMessageBox SocketTestApp::m_wait_msgbox [protected]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestApp.hpp
  • Applications/SocketTest/SocketTestApp.cpp
Generated on Wed Jan 25 02:00:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestApp::menuItems Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SocketTestApp::menuItems

SocketTestApp::menuItems Struct Reference

#include <Applications/SocketTest/SocketTestApp.hpp>

Collaboration diagram for SocketTestApp::menuItems:

[legend]

Data Fields

IpAddr m_ipGatewayAddr
gateway IP address
IpPortNo m_nGatewayPort
gateway port
UINT32 | m_nMaxTCPPacketSize
maximal size of TCP packet
UINT32 | m_nMaxTCPSockets
maximal number of simultaneously used TCP sockets
UINT32 | m_nMaxUDPPacketSize
maximal size of UDP packet
UINT32 | m_nMaxUDPSockets
maximal number of simultaneously used UDP sockets
UINT32 | m_nTimeout
timeout (in seconds) after which test fails if no response from server

Field Documentation

IpAddr SocketTestApp::menuItems::m_ipGatewayAddr

gateway IP address

IpPortNo SocketTestApp::menuItems::m_nGatewayPort

gateway port

UINT32 SocketTestApp::menuItems::m_nMaxTCPPacketSize

maximal size of TCP packet

UINT32 SocketTestApp::menuItems::m_nMaxTCPSockets

maximal number of simultaneously used TCP sockets

UINT32 SocketTestApp::menuItems::m_nMaxUDPPacketSize

maximal size of UDP packet

UINT32 SocketTestApp::menuItems::m_nMaxUDPSockets

maximal number of simultaneously used UDP sockets

UINT32 SocketTestApp::menuItems::m_nTimeout

timeout (in seconds) after which test fails if no response from server

The documentation for this struct was generated from the following file:
  • Applications/SocketTest/SocketTestApp.hpp
Generated on Wed Jan 25 02:00:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestMessage Class Reference

#include <Applications/SocketTest/SocketTestT.hpp>

Public Member Functions

BOOLEAN | AddToMessage (enum testMessageType type, UINT32 size=0, UINT32 packets=1, UINT32 freq=0)
adds data to message
void | Clean ()
cleans the message
char * | GetMessage ()
returns pointer to message
INT | GetSize ()
returns message size
SocketTestMessage ()
SocketTestMessage (INT size)
~SocketTestMessage ()

Detailed Description

SocketTestMessage class Used for creation of messages for communication between client and server test application.

Constructor & Destructor Documentation

SocketTestMessage::SocketTestMessage ( INT size )

SocketTestMessage constructor

Parameters:
size - initial size of message Allocates message of specified size.

SocketTestMessage::SocketTestMessage ( )

SocketTestMessage constructor Allocates message of size 1 byte.

SocketTestMessage::~SocketTestMessage ( )

SocketTestMessage destructor Deallocates message.

Member Function Documentation

BOOLEAN SocketTestMessage::AddToMessage | ( | enum testMessageType | type,
 |  | UINT32 | size = 0,
 |  | UINT32 | packets = 1,
 |  | UINT32 | freq = 0
 | ) |

adds data to message

AddToMessage Creates message.

Parameters:
type | - type of message: STOP_UDP, STOP_TCP, SEND_UDP, SEND_TCP, RESPONSE, REPORT
size | - requested size of packets
packets | - requested number of packets
freq | - requested frequency of incoming packets

void SocketTestMessage::Clean ( )

cleans the message

Cleans the message body.

char* SocketTestMessage::GetMessage ( ) [inline]

returns pointer to message

INT SocketTestMessage::GetSize ( ) [inline]

returns message size

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT.hpp
  • Applications/SocketTest/SocketTestT.cpp
Generated on Wed Jan 25 02:00:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestProgressWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestProgressWin Class Reference

#include <Applications/SocketTest/SocketTestProgressWin.hpp>

Collaboration diagram for SocketTestProgressWin:

[legend]

Public Member Functions

void | Init ()
initialization
void | OnTimer ()
void | RefreshScreen ()
refreshes the screen
SocketTestProgressWin ()
constructor
virtual | ~SocketTestProgressWin ()
destructor

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
called action is triggered
virtual void | OnClose ()
called when closing window
virtual void | OnOpen ()
called when opening window
virtual void | OnPaint (const Rect &repaint_rect)
called when window needs repainting

Friends

class | TriggerTimer< SocketTestProgressWin >

Detailed Description

Window that opens when testing is in progress. It displays informations of finished tests and current progress.

Constructor & Destructor Documentation

SocketTestProgressWin::SocketTestProgressWin ( )

constructor

Constructor for progress window.

SocketTestProgressWin::~SocketTestProgressWin ( ) [virtual]

destructor

Destructor for progress window .

Member Function Documentation

void SocketTestProgressWin::Init ( )

initialization

Initializes progress window.

void SocketTestProgressWin::OnActionExecuted ( Action * action ) [protected, virtual]

called action is triggered

void SocketTestProgressWin::OnClose ( ) [protected, virtual]

called when closing window

Called on closing the progress window.

void SocketTestProgressWin::OnOpen ( ) [protected, virtual]

called when opening window

Called on opening the progress window.

void SocketTestProgressWin::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

called when window needs repainting

Called when screen must be repainted.

Parameters:
repaint_rect - rectangle to be repainted

void SocketTestProgressWin::OnTimer ( )

Called regularly on timer.

void SocketTestProgressWin::RefreshScreen ( )

refreshes the screen

Refreshes the screen with test informations.

Friends And Related Function Documentation

friend class TriggerTimer< SocketTestProgressWin > [friend]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestProgressWin.hpp
  • Applications/SocketTest/SocketTestProgressWin.cpp
Generated on Wed Jan 25 02:00:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestResultsWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestResultsWin Class Reference

#include <Applications/SocketTest/SocketTestResultsWin.hpp>

Collaboration diagram for SocketTestResultsWin:

[legend]

Public Member Functions

void | Init ()
SocketTestResultsWin ()
virtual | ~SocketTestResultsWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)

Constructor & Destructor Documentation

SocketTestResultsWin::SocketTestResultsWin ( )

SocketTestResultsWin::~SocketTestResultsWin ( ) [virtual]

Member Function Documentation

void SocketTestResultsWin::Init ( )

void SocketTestResultsWin::OnActionExecuted ( Action * action ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestResultsWin.hpp
  • Applications/SocketTest/SocketTestResultsWin.cpp
Generated on Wed Jan 25 02:00:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestSettingsWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestSettingsWin Class Reference

#include <Applications/SocketTest/SocketTestSettingsWin.hpp>

Collaboration diagram for SocketTestSettingsWin:

[legend]

Public Member Functions

void | Init ()
SocketTestSettingsWin ()
virtual | ~SocketTestSettingsWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)

Constructor & Destructor Documentation

SocketTestSettingsWin::SocketTestSettingsWin ( )

SocketTestSettingsWin::~SocketTestSettingsWin ( ) [virtual]

Member Function Documentation

void SocketTestSettingsWin::Init ( )

void SocketTestSettingsWin::OnActionExecuted ( Action * action ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestSettingsWin.hpp
  • Applications/SocketTest/SocketTestSettingsWin.cpp
Generated on Wed Jan 25 02:00:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT Class Reference

#include <Applications/SocketTest/SocketTestT.hpp>

Inheritance diagram for SocketTestT:

[legend]

Public Types

enum internalStatus {
NotStarted, FinishedOK, FinishedErr, Started,
WaitingForInit, WaitingForConnect, Write, WaitingForWrite,
WaitingForRead, WaitingForClose
}
enum | Status { Skipped, InProgress, Passed, Failed }

Public Member Functions

virtual void | FinishGroup ()
SocketTestT ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
virtual internalStatus | TestC (internalStatus instatus, INT &ErrorCode)
virtual internalStatus | TestD (internalStatus instatus, INT &ErrorCode)
virtual internalStatus | TestE (internalStatus instatus, INT &ErrorCode)
virtual internalStatus | TestF (internalStatus instatus, INT &ErrorCode)
virtual internalStatus | TestG (internalStatus instatus, INT &ErrorCode)
virtual internalStatus | TestH (internalStatus instatus, INT &ErrorCode)
virtual internalStatus | TestI (internalStatus instatus, INT &ErrorCode)
virtual | ~SocketTestT ()

Protected Member Functions

UINT32 | Random (UINT32 start, UINT32 end)
returns random number in range (start, end)

Member Enumeration Documentation

enum SocketTestT::internalStatus

Enumerator:
NotStarted
FinishedOK
FinishedErr
Started
WaitingForInit
WaitingForConnect
Write
WaitingForWrite
WaitingForRead
WaitingForClose

enum SocketTestT::Status

Enumerator:
Skipped | test not performed
InProgress | testing in progress
Passed | test passed
Failed | test failed

Constructor & Destructor Documentation

SocketTestT::SocketTestT ( )

SocketTestT::~SocketTestT ( ) [virtual]

Member Function Documentation

virtual void SocketTestT::FinishGroup ( ) [inline, virtual]

Reimplemented in SocketTestT3, SocketTestT4, SocketTestT5, SocketTestT6, SocketTestT7, and SocketTestT8.

UINT32 SocketTestT::Random | ( | UINT32 | start,
 |  | UINT32 | end
 | ) | [inline, protected]

returns random number in range (start, end)

virtual internalStatus SocketTestT::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

virtual internalStatus SocketTestT::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

virtual internalStatus SocketTestT::TestC | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

virtual internalStatus SocketTestT::TestD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

virtual internalStatus SocketTestT::TestE | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

virtual internalStatus SocketTestT::TestF | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

virtual internalStatus SocketTestT::TestG | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

virtual internalStatus SocketTestT::TestH | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

virtual internalStatus SocketTestT::TestI | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [inline, virtual]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT.hpp
  • Applications/SocketTest/SocketTestT.cpp
Generated on Wed Jan 25 02:01:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT1 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT1 Class Reference

#include <Applications/SocketTest/SocketTestT1.hpp>

Inheritance diagram for SocketTestT1:

[legend]
Collaboration diagram for SocketTestT1:

[legend]

Public Member Functions

SocketTestT1 ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
Implementation of Test T1_A.
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
Implementation of Test T1_B.
virtual | ~SocketTestT1 ()

Detailed Description

Test group T1 (Sockets).

Constructor & Destructor Documentation

SocketTestT1::SocketTestT1 ( ) [inline]

virtual SocketTestT1::~SocketTestT1 ( ) [inline, virtual]

Member Function Documentation

SocketTestT::internalStatus SocketTestT1::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T1_A.

Test T1_A Creating, initializing, closing and deleting of socket. Both UDP and TCP sockets are tested.

SocketTestT::internalStatus SocketTestT1::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T1_B.

Test T1_B Opening and closing multiple sockets. Maximum number of sockets (both TCP and UDP) are opened and then closed. Than sockets are randomly opened and closed in 100 iterations. At the and all opened sockets are closed.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT1.hpp
  • Applications/SocketTest/SocketTestT1.cpp
Generated on Wed Jan 25 02:01:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT2 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT2 Class Reference

#include <Applications/SocketTest/SocketTestT2.hpp>

Inheritance diagram for SocketTestT2:

[legend]
Collaboration diagram for SocketTestT2:

[legend]

Public Member Functions

void | CleanTcpSocket (INT &ErrorCode, SysSocket *aSocket, SocketTestMessage *&pMessage)
void | CleanUdpSocket (INT &ErrorCode, SocketTestMessage *&pMessage)
INT | ClientSend (const void *buf, INT buflen)
INT | ServerRead (void *buf, INT buflen, SysSocket *aSocket)
SocketTestT2 ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
Implementation of Test T2_A.
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
Implementation of Test T2_B.
virtual | ~SocketTestT2 ()

Detailed Description

Test group T2 (LwIP)

Constructor & Destructor Documentation

SocketTestT2::SocketTestT2 ( )

SocketTestT2::~SocketTestT2 ( ) [virtual]

Member Function Documentation

void SocketTestT2::CleanTcpSocket | ( | INT & | ErrorCode,
 |  | SysSocket * | aSocket,
 |  | SocketTestMessage *& | pMessage
 | ) |

void SocketTestT2::CleanUdpSocket | ( | INT & | ErrorCode,
 |  | SocketTestMessage *& | pMessage
 | ) |

INT SocketTestT2::ClientSend | ( | const void * | buf,
 |  | INT | buflen
 | ) |

INT SocketTestT2::ServerRead | ( | void * | buf,
 |  | INT | buflen,
 |  | SysSocket * | aSocket
 | ) |

SocketTestT::internalStatus SocketTestT2::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T2_A.

SocketTestT::internalStatus SocketTestT2::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T2_B.

Test T2_B TCP LwIP test.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT2.hpp
  • Applications/SocketTest/SocketTestT2.cpp
Generated on Wed Jan 25 02:01:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT3 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT3 Class Reference

#include <Applications/SocketTest/SocketTestT3.hpp>

Inheritance diagram for SocketTestT3:

[legend]
Collaboration diagram for SocketTestT3:

[legend]

Public Member Functions

virtual void | FinishGroup ()
SocketTestT3 ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
Implementation of Test T3_A.
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
Implementation of Test T3_B.
virtual internalStatus | TestC (internalStatus instatus, INT &ErrorCode)
Implementation of Test T3_C.
virtual internalStatus | TestD (internalStatus instatus, INT &ErrorCode)
Implementation of Test T3_D.
virtual internalStatus | TestE (internalStatus instatus, INT &ErrorCode)
Implementation of Test T3_E.
virtual | ~SocketTestT3 ()

Data Fields

DownloadSettings m_PsdDownloadSettings

Protected Member Functions

void | SendFinalReport (DataConnProfileId profileId)
internalStatus | TestABCD (internalStatus instatus, INT &ErrorCode, BOOLEAN selfTest=FALSE, BOOLEAN download=FALSE)

Protected Attributes

UINT32 | m_nNumberOfPackets
UINT | m_nNumberOfSockets
DataConnProfileId m_profileId

Detailed Description

Test group T3 (UDP over PSD)

Constructor & Destructor Documentation

SocketTestT3::SocketTestT3 ( )

SocketTestT3 constructor Initializes T3 test class members.

SocketTestT3::~SocketTestT3 ( ) [virtual]

SocketTestT3 destructor Deinitializes T3 test class members.

Member Function Documentation

void SocketTestT3::FinishGroup ( ) [virtual]

FinishGroup When all tests in group are finished this function sends the final report to server.

Reimplemented from SocketTestT.

Reimplemented in SocketTestT5, and SocketTestT7.

void SocketTestT3::SendFinalReport ( DataConnProfileId profileId ) [protected]

SendFinalReport Send the final report to server.

SocketTestT::internalStatus SocketTestT3::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T3_A.

Test T3_A Opening UDP socket and talking to yourself. Sending random packet size to local address.

Reimplemented in SocketTestT5, and SocketTestT7.

SocketTestT::internalStatus SocketTestT3::TestABCD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode,
 |  | BOOLEAN | selfTest = FALSE,
 |  | BOOLEAN | download = FALSE
 | ) | [protected]

Test T3_ABCD Used for all tests.

SocketTestT::internalStatus SocketTestT3::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T3_B.

Test T3_B Opening UDP socket and talking to gateway. Sending random packet size to gateway address.

Reimplemented in SocketTestT5, and SocketTestT7.

SocketTestT::internalStatus SocketTestT3::TestC | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T3_C.

Test T3_C Opening UDP socket and talking to gateway, requesting multiple packets with different sizes.. Sending random packet size to gateway address.

Reimplemented in SocketTestT5, and SocketTestT7.

SocketTestT::internalStatus SocketTestT3::TestD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T3_D.

Test T3_D Opening multiple UDP sockets and talking to gateway. Sending random packet size to gateway address.

Reimplemented in SocketTestT5, and SocketTestT7.

SocketTestT::internalStatus SocketTestT3::TestE | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T3_E.

Test T3_E

Download time measurement.

Reimplemented in SocketTestT5.

Field Documentation

UINT32 SocketTestT3::m_nNumberOfPackets [protected]

UINT SocketTestT3::m_nNumberOfSockets [protected]

DataConnProfileId SocketTestT3::m_profileId [protected]

DownloadSettings SocketTestT3::m_PsdDownloadSettings

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT3.hpp
  • Applications/SocketTest/SocketTestT3.cpp
Generated on Wed Jan 25 02:01:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT4 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT4 Class Reference

#include <Applications/SocketTest/SocketTestT4.hpp>

Inheritance diagram for SocketTestT4:

[legend]
Collaboration diagram for SocketTestT4:

[legend]

Public Member Functions

virtual void | FinishGroup ()
SocketTestT4 ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
Implementation of Test T4_A.
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
Implementation of Test T4_B.
virtual internalStatus | TestC (internalStatus instatus, INT &ErrorCode)
Implementation of Test T4_C.
virtual internalStatus | TestD (internalStatus instatus, INT &ErrorCode)
Implementation of Test T4_D.
virtual | ~SocketTestT4 ()

Protected Member Functions

void | SendFinalReport (DataConnProfileId profileId)
internalStatus | TestAA (internalStatus instatus, INT &ErrorCode)
internalStatus | TestBCD (internalStatus instatus, INT &ErrorCode)

Protected Attributes

INT | m_nCurrentSocket
UINT32 | m_nlenIn
UINT32 | m_nNumberOfPackets
UINT | m_nNumberOfSockets
UINT | m_nStartNumber
INT | m_nWaitingForSockets
SocketTestMessage * m_pMessage
TcpTestSocket * | m_ppTcpSocket [15]
DataConnProfileId m_profileId
TcpTestSocket * m_pTcpInSocket
TcpTestSocket * m_pTcpOutSocket
TcpTestSocket * m_pTcpReportSocket
TcpServerTestSocket * m_pTcpServerSocket

Detailed Description

Test group T4 (TCP over PSD)

Constructor & Destructor Documentation

SocketTestT4::SocketTestT4 ( )

SocketTestT4 constructor Initializes T4 test class members.

SocketTestT4::~SocketTestT4 ( ) [virtual]

SocketTestT4 destructor Deinitializes T4 test class members.

Member Function Documentation

void SocketTestT4::FinishGroup ( ) [virtual]

FinishGroup When all tests in group are finished this function sends the final report to server.

Reimplemented from SocketTestT.

Reimplemented in SocketTestT6, and SocketTestT8.

void SocketTestT4::SendFinalReport ( DataConnProfileId profileId ) [protected]

SendFinalReport Send the final report to server.

SocketTestT::internalStatus SocketTestT4::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T4_A.

Test T4_A Opening TCP socket and talking to yourself. Sending random packet size to local address.

Reimplemented in SocketTestT6, and SocketTestT8.

SocketTestT::internalStatus SocketTestT4::TestAA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [protected]

Test T4_A body. It is used for some other tests also (T6_A and T8_A)

SocketTestT::internalStatus SocketTestT4::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T4_B.

Test T4_B Opening TCP socket and talking to gateway. Sending random packet size to gateway address.

Reimplemented in SocketTestT6, and SocketTestT8.

SocketTestT::internalStatus SocketTestT4::TestBCD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [protected]

Test T4_BCD Used for tests T4_B, T4_C and T4_D.

SocketTestT::internalStatus SocketTestT4::TestC | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T4_C.

Test T4_C Opening TCP socket and talking to gateway, requesting multiple packets with different sizes. Sending random packet size to gateway address.

Reimplemented in SocketTestT6, and SocketTestT8.

SocketTestT::internalStatus SocketTestT4::TestD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T4_D.

Test T4_D Opening multiple TCP sockets and talking to gateway, requesting multiple packets with different sizes. Sending random packet size to gateway address.

Reimplemented in SocketTestT6, and SocketTestT8.

Field Documentation

INT SocketTestT4::m_nCurrentSocket [protected]

UINT32 SocketTestT4::m_nlenIn [protected]

UINT32 SocketTestT4::m_nNumberOfPackets [protected]

UINT SocketTestT4::m_nNumberOfSockets [protected]

UINT SocketTestT4::m_nStartNumber [protected]

INT SocketTestT4::m_nWaitingForSockets [protected]

SocketTestMessage* SocketTestT4::m_pMessage [protected]

TcpTestSocket* SocketTestT4::m_ppTcpSocket[15] [protected]

DataConnProfileId SocketTestT4::m_profileId [protected]

TcpTestSocket* SocketTestT4::m_pTcpInSocket [protected]

TcpTestSocket* SocketTestT4::m_pTcpOutSocket [protected]

TcpTestSocket* SocketTestT4::m_pTcpReportSocket [protected]

TcpServerTestSocket* SocketTestT4::m_pTcpServerSocket [protected]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT4.hpp
  • Applications/SocketTest/SocketTestT4.cpp
Generated on Wed Jan 25 02:01:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT5 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT5 Class Reference

#include <Applications/SocketTest/SocketTestT5.hpp>

Inheritance diagram for SocketTestT5:

[legend]
Collaboration diagram for SocketTestT5:

[legend]

Public Member Functions

virtual void | FinishGroup ()
SocketTestT5 ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
Implementation of Test T5_A.
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
Implementation of Test T5_B.
virtual internalStatus | TestC (internalStatus instatus, INT &ErrorCode)
Implementation of Test T5_C.
virtual internalStatus | TestD (internalStatus instatus, INT &ErrorCode)
Implementation of Test T5_D.
virtual internalStatus | TestE (internalStatus instatus, INT &ErrorCode)
Implementation of Test T5_D.
virtual | ~SocketTestT5 ()

Data Fields

DownloadSettings m_CsdDownloadSettings

Detailed Description

Test group T5 (UDP over CSD)

Constructor & Destructor Documentation

SocketTestT5::SocketTestT5 ( ) [inline]

virtual SocketTestT5::~SocketTestT5 ( ) [inline, virtual]

Member Function Documentation

void SocketTestT5::FinishGroup ( ) [virtual]

FinishGroup When all tests in group are finished this function sends the final report to server.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT5::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T5_A.

Test T5_A Opening UDP socket and talking to yourself. Sending random packet size to local address.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT5::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T5_B.

Test T5_B Opening UDP socket and talking to gateway. Sending random packet size to gateway address.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT5::TestC | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T5_C.

Test T5_C Opening UDP socket and talking to gateway, requesting multiple packets with different sizes.. Sending random packet size to gateway address.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT5::TestD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T5_D.

Test T5_D Opening multiple UDP sockets and talking to gateway. Sending random packet size to gateway address.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT5::TestE | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T5_D.

Test T5_E

Download time measurement.

Reimplemented from SocketTestT3.

Field Documentation

DownloadSettings SocketTestT5::m_CsdDownloadSettings

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT5.hpp
  • Applications/SocketTest/SocketTestT5.cpp
Generated on Wed Jan 25 02:01:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT6 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT6 Class Reference

#include <Applications/SocketTest/SocketTestT6.hpp>

Inheritance diagram for SocketTestT6:

[legend]
Collaboration diagram for SocketTestT6:

[legend]

Public Member Functions

virtual void | FinishGroup ()
SocketTestT6 ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
Implementation of Test T6_A.
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
Implementation of Test T6_B.
virtual internalStatus | TestC (internalStatus instatus, INT &ErrorCode)
Implementation of Test T6_C.
virtual internalStatus | TestD (internalStatus instatus, INT &ErrorCode)
Implementation of Test T6_D.
virtual | ~SocketTestT6 ()

Detailed Description

Test group T6 (TCP over CSD)

Constructor & Destructor Documentation

SocketTestT6::SocketTestT6 ( ) [inline]

virtual SocketTestT6::~SocketTestT6 ( ) [inline, virtual]

Member Function Documentation

void SocketTestT6::FinishGroup ( ) [virtual]

FinishGroup When all tests in group are finished this function sends the final report to server.

Reimplemented from SocketTestT4.

SocketTestT::internalStatus SocketTestT6::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T6_A.

Test T6_A Opening TCP socket and talking to yourself. Sending random packet size to local address.

Reimplemented from SocketTestT4.

SocketTestT::internalStatus SocketTestT6::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T6_B.

Test T6_B Opening TCP socket and talking to gateway. Sending random packet size to gateway address.

Reimplemented from SocketTestT4.

SocketTestT::internalStatus SocketTestT6::TestC | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T6_C.

Test T6_C Opening TCP socket and talking to gateway, requesting multiple packets with different sizes. Sending random packet size to gateway address.

Reimplemented from SocketTestT4.

SocketTestT::internalStatus SocketTestT6::TestD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T6_D.

Test T6_D Opening multiple TCP sockets and talking to gateway, requesting multiple packets with different sizes. Sending random packet size to gateway address.

Reimplemented from SocketTestT4.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT6.hpp
  • Applications/SocketTest/SocketTestT6.cpp
Generated on Wed Jan 25 02:01:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT7 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT7 Class Reference

#include <Applications/SocketTest/SocketTestT7.hpp>

Inheritance diagram for SocketTestT7:

[legend]
Collaboration diagram for SocketTestT7:

[legend]

Public Member Functions

virtual void | FinishGroup ()
SocketTestT7 ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
Implementation of Test T7_A.
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
Implementation of Test T7_B.
virtual internalStatus | TestC (internalStatus instatus, INT &ErrorCode)
Implementation of Test T7_C.
virtual internalStatus | TestD (internalStatus instatus, INT &ErrorCode)
Implementation of Test T7_D.
virtual | ~SocketTestT7 ()

Detailed Description

Test group T7 (UDP over SER)

Constructor & Destructor Documentation

SocketTestT7::SocketTestT7 ( ) [inline]

virtual SocketTestT7::~SocketTestT7 ( ) [inline, virtual]

Member Function Documentation

void SocketTestT7::FinishGroup ( ) [virtual]

FinishGroup When all tests in group are finished this function sends the final report to server.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT7::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T7_A.

Test T7_A Opening UDP socket and talking to yourself. Sending random packet size to local address.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT7::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T7_B.

Test T7_B Opening UDP socket and talking to gateway. Sending random packet size to gateway address.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT7::TestC | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T7_C.

Test T7_C Opening UDP socket and talking to gateway, requesting multiple packets with different sizes. Sending random packet size to gateway address.

Reimplemented from SocketTestT3.

SocketTestT::internalStatus SocketTestT7::TestD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T7_D.

Test T7_D Opening multiple UDP sockets and talking to gateway. Sending random packet size to gateway address.

Reimplemented from SocketTestT3.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT7.hpp
  • Applications/SocketTest/SocketTestT7.cpp
Generated on Wed Jan 25 02:01:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestT8 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestT8 Class Reference

#include <Applications/SocketTest/SocketTestT8.hpp>

Inheritance diagram for SocketTestT8:

[legend]
Collaboration diagram for SocketTestT8:

[legend]

Public Member Functions

virtual void | FinishGroup ()
SocketTestT8 ()
virtual internalStatus | TestA (internalStatus instatus, INT &ErrorCode)
Implementation of Test T8_A.
virtual internalStatus | TestB (internalStatus instatus, INT &ErrorCode)
Implementation of Test T8_B.
virtual internalStatus | TestC (internalStatus instatus, INT &ErrorCode)
Implementation of Test T8_C.
virtual internalStatus | TestD (internalStatus instatus, INT &ErrorCode)
Implementation of Test T8_D.
virtual | ~SocketTestT8 ()

Detailed Description

Test group T8 (TCP over PPP)

Constructor & Destructor Documentation

SocketTestT8::SocketTestT8 ( ) [inline]

virtual SocketTestT8::~SocketTestT8 ( ) [inline, virtual]

Member Function Documentation

void SocketTestT8::FinishGroup ( ) [virtual]

FinishGroup When all tests in group are finished this function sends the final report to server.

Reimplemented from SocketTestT4.

SocketTestT::internalStatus SocketTestT8::TestA | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T8_A.

Test T8_A Opening TCP socket and talking to yourself. Sending random packet size to local address.

Reimplemented from SocketTestT4.

SocketTestT::internalStatus SocketTestT8::TestB | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T8_B.

Test T8_B Opening TCP socket and talking to gateway. Sending random packet size to gateway address.

Reimplemented from SocketTestT4.

SocketTestT::internalStatus SocketTestT8::TestC | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T8_C.

Test T8_C Opening TCP socket and talking to gateway, requesting multiple packets with different sizes. Sending random packet size to gateway address.

Reimplemented from SocketTestT4.

SocketTestT::internalStatus SocketTestT8::TestD | ( | internalStatus | instatus,
 |  | INT & | ErrorCode
 | ) | [virtual]

Implementation of Test T8_D.

Test T8_D Opening multiple TCP sockets and talking to gateway, requesting multiple packets with different sizes. Sending random packet size to gateway address.

Reimplemented from SocketTestT4.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestT8.hpp
  • Applications/SocketTest/SocketTestT8.cpp
Generated on Wed Jan 25 02:01:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestTests::TestGroupInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SocketTestTests::TestGroupInfo

SocketTestTests::TestGroupInfo Struct Reference

#include <Applications/SocketTest/SocketTestTests.hpp>

Data Fields

BOOLEAN | m_bReportSent [m_nMaxNrOfTestsInGroup]
TRUE if report was sent to server.
BOOLEAN | m_bTestEnabled
Indication if group is enabled.
INT | m_nErrorCode [m_nMaxNrOfTestsInGroup]
Error code of failed test.
SocketTestT::internalStatus | m_nInternalStatus [m_nMaxNrOfTestsInGroup]
internal status of test
UINT32 | m_nIterationsDone [m_nMaxNrOfTestsInGroup]
Finished number of iterations of each test in group.
UINT32 | m_nIterationsSuccessfull [m_nMaxNrOfTestsInGroup]
Number of successfully finished iterations of each test in group.
UINT32 | m_nIterationsTotal [m_nMaxNrOfTestsInGroup]
Total number of iterations of each test in group.
UINT | m_nNrOfSubtests
Number of tests in group.
SocketTestT::Status | m_nStatus [m_nMaxNrOfTestsInGroup]
Status of test.
WCHAR | m_wsName [16]
Test group name.

Detailed Description

Structure holding the test group settings.

Field Documentation

BOOLEAN SocketTestTests::TestGroupInfo::m_bReportSent[m_nMaxNrOfTestsInGroup]

TRUE if report was sent to server.

BOOLEAN SocketTestTests::TestGroupInfo::m_bTestEnabled

Indication if group is enabled.

INT SocketTestTests::TestGroupInfo::m_nErrorCode[m_nMaxNrOfTestsInGroup]

Error code of failed test.

SocketTestT::internalStatus SocketTestTests::TestGroupInfo::m_nInternalStatus[m_nMaxNrOfTestsInGroup]

internal status of test

UINT32 SocketTestTests::TestGroupInfo::m_nIterationsDone[m_nMaxNrOfTestsInGroup]

Finished number of iterations of each test in group.

UINT32 SocketTestTests::TestGroupInfo::m_nIterationsSuccessfull[m_nMaxNrOfTestsInGroup]

Number of successfully finished iterations of each test in group.

UINT32 SocketTestTests::TestGroupInfo::m_nIterationsTotal[m_nMaxNrOfTestsInGroup]

Total number of iterations of each test in group.

UINT SocketTestTests::TestGroupInfo::m_nNrOfSubtests

Number of tests in group.

SocketTestT::Status SocketTestTests::TestGroupInfo::m_nStatus[m_nMaxNrOfTestsInGroup]

Status of test.

WCHAR SocketTestTests::TestGroupInfo::m_wsName[16]

Test group name.

The documentation for this struct was generated from the following file:
  • Applications/SocketTest/SocketTestTests.hpp
Generated on Wed Jan 25 02:01:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SocketTestWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SocketTestWin Class Reference

#include <Applications/SocketTest/SocketTestWin.hpp>

Collaboration diagram for SocketTestWin:

[legend]

Public Member Functions

void | Init ()
SocketTestWin ()
virtual | ~SocketTestWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual void | OnOpen ()
virtual void | OnPaint (const Rect &repaint_rect)

Detailed Description

Main Socket Test application window.

Constructor & Destructor Documentation

SocketTestWin::SocketTestWin ( )

SocketTestWin::~SocketTestWin ( ) [virtual]

Member Function Documentation

void SocketTestWin::Init ( )

void SocketTestWin::OnActionExecuted ( Action * action ) [protected, virtual]

void SocketTestWin::OnOpen ( ) [protected, virtual]

void SocketTestWin::OnPaint ( const Rect & repaint_rect ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestWin.hpp
  • Applications/SocketTest/SocketTestWin.cpp
Generated on Wed Jan 25 02:01:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoftkeyBar Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoftkeyBar Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/SoftkeyBar.hpp>

Inheritance diagram for SoftkeyBar:

[legend]
Collaboration diagram for SoftkeyBar:

[legend]

Public Member Functions

Action * | Get (INT idx) const
INT | GetNoOfSoftkeys () const
Obsolete - use GetSoftkeyCount() instead.
INT | GetPressedIndex () const
INT | GetSoftkeyCount () const
void | Init (Window *win)
void | Set (INT idx, Action *action)
void | SetPressedIndex (INT pressed_idx)
SoftkeyBar (Window *win)
SoftkeyBar ()
void | Trigger (INT idx) const
virtual | ~SoftkeyBar ()

Protected Member Functions

virtual void | OnLanguageChanged ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnThemeChanged ()

Detailed Description

Obsolete - use Window::SetSoftkey instead, there is no need anymore to add a softkeybar to the window.

The SoftkeyBar is a container for softkeys. When the softkey has been pressed an action will be executed. The softkeys are numbered from 0 to the number of softkeys - 1 defined in KeyboardConfig.

Constructor & Destructor Documentation

SoftkeyBar::SoftkeyBar ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

SoftkeyBar::SoftkeyBar ( Window * win )

Parameters:
win Pointer to the window, which should contain the softkeybar.

SoftkeyBar::~SoftkeyBar ( ) [virtual]

Member Function Documentation

Action * SoftkeyBar::Get ( INT idx ) const

Parameters:
idx Index of the softkey (>= 0).
Returns:
Pointer to the action, which will be executed when pressing the softkey.

INT SoftkeyBar::GetNoOfSoftkeys ( ) const [inline]

Obsolete - use GetSoftkeyCount() instead.

INT SoftkeyBar::GetPressedIndex ( ) const [inline]

INT SoftkeyBar::GetSoftkeyCount ( ) const

void SoftkeyBar::Init ( Window * win )

Parameters:
win Pointer to the window, which should contain the softkeybar.

void SoftkeyBar::OnLanguageChanged ( ) [protected, virtual]

See also:
Component::OnLanguageChanged

Reimplemented from DrawableObject.

BOOLEAN SoftkeyBar::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from DrawableObject.

void SoftkeyBar::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged

Reimplemented from DrawableObject.

void SoftkeyBar::Set | ( | INT | idx,
 |  | Action * | action
 | ) |

Sets the action for a softkey.

Parameters:
idx | Index of softkey (>= 0).
action | Pointer to the action which will be executed when pressing the softkey.

void SoftkeyBar::SetPressedIndex ( INT pressed_idx )

Sets the index which indicates, that a softkey is pressed. Index of pressed softkey. Use -1 to indicate, that no softkey has been pressed.

void SoftkeyBar::Trigger ( INT idx ) const

Executes the action and fires the message, which has been assigned to the softkey.

Parameters:
idx Index of the softkey, which should be triggered.

The documentation for this class was generated from the following files:
  • Compat/SoftkeyBar.hpp
  • Compat/SoftkeyBar.cpp
Generated on Wed Jan 25 02:01:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoftkeyBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoftkeyBarView Class Reference
[Obsolete GUI classes]

Describes the view of a Softkey-Bar. More...

#include <Apoxi/Compat/SoftkeyBar.hpp>

Inheritance diagram for SoftkeyBarView:

[legend]
Collaboration diagram for SoftkeyBarView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
SoftkeyBarView ()
virtual | ~SoftkeyBarView ()

Protected Member Functions

virtual void | DrawSoftkeyBar (const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const =0

Detailed Description

Describes the view of a Softkey-Bar.

Constructor & Destructor Documentation

SoftkeyBarView::SoftkeyBarView ( )

SoftkeyBarView::~SoftkeyBarView ( ) [virtual]

Member Function Documentation

void SoftkeyBarView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

virtual void SoftkeyBarView::DrawSoftkeyBar | ( | const SoftkeyBar & | softkey_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Draws the Softkey-Bar. Must be implemented in the corresponding theme view.

Parameters:
softkey_bar | Softkey-Bar which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implemented in BlueSkySoftkeyBarView, DefaultSoftkeyBarView, FoggySoftkeyBarView, TestSoftkeyBarView, DefaultSoftkeyBarView, and FoggySoftkeyBarView.

The documentation for this class was generated from the following files:
  • Compat/SoftkeyBar.hpp
  • Compat/SoftkeyBar.cpp
Generated on Wed Jan 25 02:01:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoftkeyDesc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoftkeyDesc Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Context/SoftkeyDesc.hpp>

Collaboration diagram for SoftkeyDesc:

[legend]

Public Member Functions

const AppFeatureID & | GetFeatureId () const
const MenuID & | GetMenuId () const
const ImageObtainer & | GetSkIcon () const
const WString & | GetSkText () const
FeatureItem * | GetSoftkeyFeatureItem (INT sk_id) const
void | SetFeatureId (const AppFeatureID &id)
void | SetMenuId (const MenuID &id)
void | SetSkIcon (const ImageObtainer &icon)
void | SetSkText (const WCHAR *text)
void | SetSkText (const WString &text)
SoftkeyDesc (const MenuID &menu_id, const WString &text)
SoftkeyDesc (const MenuID &menu_id)
SoftkeyDesc (const AppFeatureID &feature_id, const WString &text)
SoftkeyDesc (const AppFeatureID &feature_id)
SoftkeyDesc ()
~SoftkeyDesc ()

Detailed Description

Configuration class for a softkey assignment. Following assignments are possible:
  • Feature specified via AppFeatureID
  • Context menu specified via MenuID
In both cases, it is possible to configure an optional text for cases, when the softkey should display a different text than the feature item contains.

Constructor & Destructor Documentation

SoftkeyDesc::SoftkeyDesc ( )

SoftkeyDesc::SoftkeyDesc ( const AppFeatureID & feature_id ) [inline]

Parameters:
feature_id Encapsulates an ApplicationID as well as a FeatureID, which identify a feature

SoftkeyDesc::SoftkeyDesc | ( | const AppFeatureID & | feature_id,
 |  | const WString & | text
 | ) | [inline]

Parameters:
feature_id | ApplicationID and FeatureID, which identify a feature
text | Alternative text to be displayed on the softkey

SoftkeyDesc::SoftkeyDesc ( const MenuID & menu_id ) [inline]

Parameters:
menu_id Identifies a menu configured in the system's menu pool

SoftkeyDesc::SoftkeyDesc | ( | const MenuID & | menu_id,
 |  | const WString & | text
 | ) | [inline]

Parameters:
menu_id | Identifies a menu configured in the system's menu pool
text | Alternative text to be displayed on the softkey

SoftkeyDesc::~SoftkeyDesc ( )

Member Function Documentation

const AppFeatureID& SoftkeyDesc::GetFeatureId ( ) const [inline]

Returns:
ID of the feature assigned to the softkey

const MenuID& SoftkeyDesc::GetMenuId ( ) const [inline]

Returns:
ID of the menu assigned to the softkey

const ImageObtainer& SoftkeyDesc::GetSkIcon ( ) const [inline]

Returns:
ImageObtainer icon, which should be displayed on the softkey

const WString& SoftkeyDesc::GetSkText ( ) const [inline]

Returns:
Alternative text, which should be displayed on the softkey

FeatureItem * SoftkeyDesc::GetSoftkeyFeatureItem ( INT sk_id ) const

Parameters:
sk_id Softkey index
Returns:
In case of a context menu, an "OpenMenu" context feature is initialized with the configured context menu. If the configured context menu contains only one menu item, this item will be assigned directly to the softkey. In case a feature is configured, the feature will be fetched from FeatureBroker and returned.

void SoftkeyDesc::SetFeatureId ( const AppFeatureID & id ) [inline]

Parameters:
ID fo the feature that should get assigned to the softkey

void SoftkeyDesc::SetMenuId ( const MenuID & id ) [inline]

Parameters:
ID of the menu that should get assigned to the softkey

void SoftkeyDesc::SetSkIcon ( const ImageObtainer & icon ) [inline]

Parameters:
ImageObtainer icon, which should be displayed on the softkey

void SoftkeyDesc::SetSkText ( const WCHAR * text ) [inline]

Parameters:
Alternative text as const WCHAR*, which should be displayed on the softkey

void SoftkeyDesc::SetSkText ( const WString & text ) [inline]

Parameters:
Alternative text as const WString, which should be displayed on the softkey

The documentation for this class was generated from the following files:
  • Atl/Context/SoftkeyDesc.hpp
  • Atl/Context/SoftkeyDesc.cpp
Generated on Wed Jan 25 02:01:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoftkeyDescTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoftkeyDescTableEntry Struct Reference

#include <Apoxi/Atl/Context/ContextDescriptionTypes.hpp>

Data Fields

const CHAR * | app_menu_id
const CHAR * | feature_id
const CHAR * | icon_id
const CHAR * | text

Field Documentation

const CHAR* SoftkeyDescTableEntry::app_menu_id

const CHAR* SoftkeyDescTableEntry::feature_id

const CHAR* SoftkeyDescTableEntry::icon_id

const CHAR* SoftkeyDescTableEntry::text

The documentation for this struct was generated from the following file:
  • Atl/Context/ContextDescriptionTypes.hpp
Generated on Wed Jan 25 02:01:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SortedElementList< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SortedElementList< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/ElementList.hpp>

Inheritance diagram for SortedElementList< T >:

[legend]
Collaboration diagram for SortedElementList< T >:

[legend]

Public Member Functions

T * | GetAt (INT idx) const
Returns the pointer of the element of position idx in the list.
T * | GetFront () const
void | Insert (const T &entry)
Inserts a copy of entry to the sorted linked list.
void | Insert (T *entry)
SortedElementList & | operator= (const SortedElementList< T > &list)
SortedElementList (const SortedElementList< T > &list)
SortedElementList ()

Detailed Description

template<class T>
class SortedElementList< T >

The SortedElementList is a template for a sorted linked list, which manages the memory of its elements.

Member Function Documentation

template<class T>
T* SortedElementList< T >::GetAt ( INT idx ) const [inline]

Returns the pointer of the element of position idx in the list.

Reimplemented from ElementList< T >.

template<class T>
T* SortedElementList< T >::GetFront ( ) const [inline]

Returns a pointer to the first element of the linked list. The elements will not be removed from the list.

Reimplemented from ElementList< T >.

template<class T>
void SortedElementList< T >::Insert ( const T & entry ) [inline]

Inserts a copy of entry to the sorted linked list.

The documentation for this class was generated from the following file:
  • Auxiliary/ElementList.hpp
Generated on Wed Jan 25 02:01:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SortedLinkedList< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SortedLinkedList< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/LinkedList.hpp>

Inheritance diagram for SortedLinkedList< T >:

[legend]
Collaboration diagram for SortedLinkedList< T >:

[legend]

Public Member Functions

T * | GetFront () const
Returns a pointer to the first element of the linked list.
void | Insert (T *elem)

template<class T>
class SortedLinkedList< T >

Member Function Documentation

template<class T>
T* SortedLinkedList< T >::GetFront ( ) const [inline]

Returns a pointer to the first element of the linked list.

Reimplemented from LinkedListBase.

The documentation for this class was generated from the following file:
  • Auxiliary/LinkedList.hpp
Generated on Wed Jan 25 02:01:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SortedLinkedListBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SortedLinkedListBase Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/LinkedList.hpp>

Inheritance diagram for SortedLinkedListBase:

[legend]
Collaboration diagram for SortedLinkedListBase:

[legend]
The documentation for this class was generated from the following file:
  • Auxiliary/LinkedList.hpp
Generated on Wed Jan 25 02:01:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SortProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SortProvider Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/SortProvider.hpp>

Inheritance diagram for SortProvider:

[legend]
Collaboration diagram for SortProvider:

[legend]

Public Types

typedef AbstractDelegationProvider | Base

Public Member Functions

virtual BOOLEAN | GetChildRow (INT &childrow, INT row)
GetChildRow gives the mapping of row to the row in the child provider
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
void | Init (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
The same interface as the constructor.
virtual BOOLEAN | InsertRow (INT row)
If not overwritten, the InsertRow is the same as AppendRow.
virtual void | OnExecutingListener (Provider *provider=0)
void | SetSortColumn (INT sortcolumn)
Specify the column to be sorted.
void | SetSortOrder (BOOLEAN sortorder)
TRUE: ascending sort order; FALSE: descending sort order.
SortProvider (Provider *provider, INT columnid=0, BOOLEAN order=TRUE)
SortProvider ()
virtual BOOLEAN | Update (ProviderListener *listener)=0
Update makes the Provider ready to use and executes the sort process.
virtual | ~SortProvider ()
Destructor.

Protected Member Functions

virtual INT | FindSortedRow (INT row)
virtual void | OnChildProviderModification (Provider *provider, const Provider::Modification &modification)
virtual void | ResizeIndexTable ()
virtual BOOLEAN | UpdateIndexTable (ModificationType type, INT row)

Protected Attributes

INT | m_columnid
BOOLEAN | m_order
IndexTable< INT > | m_SortedRows

Detailed Description

A SortProvider is the base class for all sort of Sorting providers which are able to sort rows of a child provider . NOTE: No writing is possible on a SortProvider. Use GetChildRow to get the row of the child provider and update the child provider directly. See also: Provider, DataItem.

Member Typedef Documentation

typedef AbstractDelegationProvider SortProvider::Base

Reimplemented from AbstractDelegationProvider.

Reimplemented in BubbleSortProvider, CachingSortProvider, ChineseQuickSortProvider, QuickSortProvider, and PbSortedProvider.

Constructor & Destructor Documentation

SortProvider::SortProvider ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

SortProvider::SortProvider | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

On construction the following parameters have to be specified: provider: The provider which should be sorted. columnid: Specify which columnid has to be sorted. order: Specify whether ascending (TRUE) or descending (FALSE).

SortProvider::~SortProvider ( ) [virtual]

Destructor.

Member Function Documentation

INT SortProvider::FindSortedRow ( INT row ) [protected, virtual]

BOOLEAN SortProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual]

GetChildRow gives the mapping of row to the row in the child provider

Implements AbstractDelegationProvider.

BOOLEAN SortProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements AbstractDelegationProvider.

void SortProvider::Init | ( | Provider * | provider,
 |  | INT | columnid = 0,
 |  | BOOLEAN | order = TRUE
 | ) |

The same interface as the constructor.

Reimplemented in BubbleSortProvider, CachingSortProvider, and QuickSortProvider.

BOOLEAN SortProvider::InsertRow ( INT row ) [virtual]

If not overwritten, the InsertRow is the same as AppendRow.

Reimplemented from AbstractDelegationProvider.

void SortProvider::OnChildProviderModification | ( | Provider * | provider,
 |  | const Provider::Modification & | modification
 | ) | [protected, virtual]

Reimplemented from AbstractDelegationProvider.

void SortProvider::OnExecutingListener ( Provider * provider = 0 ) [virtual]

Called by DelegationProviderListener to modify the progress value. The current version reflects the progress value of the child-provider until 99 percent.

Reimplemented from AbstractDelegationProvider.

void SortProvider::ResizeIndexTable ( ) [protected, virtual]

void SortProvider::SetSortColumn ( INT sortcolumn ) [inline]

Specify the column to be sorted.

void SortProvider::SetSortOrder ( BOOLEAN sortorder ) [inline]

TRUE: ascending sort order; FALSE: descending sort order.

virtual BOOLEAN SortProvider::Update ( ProviderListener * listener ) [pure virtual]

Update makes the Provider ready to use and executes the sort process.

Reimplemented from AbstractDelegationProvider.

Implemented in BubbleSortProvider, CachingSortProvider, ChineseQuickSortProvider, QuickSortProvider, and PbSortedProvider.

BOOLEAN SortProvider::UpdateIndexTable | ( | ModificationType | type,
 |  | INT | row
 | ) | [protected, virtual]

Field Documentation

INT SortProvider::m_columnid [protected]

BOOLEAN SortProvider::m_order [protected]

IndexTable<INT> SortProvider::m_SortedRows [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/SortProvider.hpp
  • Auxiliary/SortProvider.cpp
Generated on Wed Jan 25 02:01:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Sound Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Sound Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/Sound.hpp>

Inheritance diagram for Sound:

[legend]
Collaboration diagram for Sound:

[legend]

Public Member Functions

virtual const BinData * | GetBinData () const
Returns the binary data of the sound. Per default 0 is returned.
virtual INT | GetId () const =0
Returns a unique format id for the concret instance.
virtual const WCHAR * | GetName () const =0
Returns the name of the sound.
virtual BOOLEAN | Play (AudioContext *context)=0
Sound ()
virtual | ~Sound ()

Detailed Description

Base class for pre- and userdefined tones, melodies and other sound resources. Every sound has a unique ID. The IDs 0 to 999 are reserved for APOXI:
  • 0 ... IMelody
  • 1 ... PreparedSound
  • 2 ... SmafSound
  • 3 ... MidiSound

Constructor & Destructor Documentation

Sound::Sound ( )

Sound::~Sound ( ) [virtual]

Member Function Documentation

const BinData * Sound::GetBinData ( ) const [virtual]

Returns the binary data of the sound. Per default 0 is returned.

Reimplemented in IMelody, MidiSound, SmafSound, and AmrSound.

virtual INT Sound::GetId ( ) const [pure virtual]

Returns a unique format id for the concret instance.

Implemented in IMelody, MidiSound, PreparedSound, SmafSound, PredefinedEmsSound, and AmrSound.

virtual const WCHAR* Sound::GetName ( ) const [pure virtual]

Returns the name of the sound.

Implemented in Melody, and PreparedSound.

virtual BOOLEAN Sound::Play ( AudioContext * context ) [pure virtual]

Plays the sound via the given AudioContext.

Returns:
Whether or not the sound could be played.

Implemented in Melody, and PreparedSound.

The documentation for this class was generated from the following files:
  • Compat/Sound.hpp
  • Compat/Sound.cpp
Generated on Wed Jan 25 02:01:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundBrowserApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundBrowserApp Class Reference
[SoundBrowser]

#include <Applications/SoundBrowser/SoundBrowserApp.hpp>

Collaboration diagram for SoundBrowserApp:

[legend]

Public Member Functions

ServiceResult | GetResourceNames (Vector< Path > &paths, const SoundFilter &sound_filter=SoundFilter())
ServiceResult | SaveSound (const BinData *raw_data, const Path &path, DrmMimeType drm_mime_type, MimeType mime_type)
ServiceResult | SelectSound (MediaRefPtr &media_ref_ptr, const SoundFilter &snd_filter=SoundFilter())
virtual BOOLEAN | UpdateItem (Item *item)
virtual | ~SoundBrowserApp ()
Destructor.

Static Public Member Functions

static SoundBrowserApp * | GetInstance ()

Protected Member Functions

virtual DataItem | GetContextDataItem (ContextFeature *feature)
void | OnClose ()
BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
BOOLEAN | OnMessage (const Message &msg)
void | OnOpen ()
void | OnStartup ()

Detailed Description

Class SoundBrowserApp implements a sound browser.

Constructor & Destructor Documentation

SoundBrowserApp::~SoundBrowserApp ( ) [virtual]

Destructor.

Member Function Documentation

DataItem SoundBrowserApp::GetContextDataItem ( ContextFeature * feature ) [protected, virtual]

static SoundBrowserApp* SoundBrowserApp::GetInstance ( ) [inline, static]

ServiceResult SoundBrowserApp::GetResourceNames | ( | Vector< Path > & | paths,
 |  | const SoundFilter & | sound_filter = SoundFilter()
 | ) |

GetResourceNames returns a list of paths for all available sounds according to the given sound filter in snd_filter argument. If snd_filter argument is a null object, the path of all images should be returned.

Parameters:
paths | The list of paths is returned in paths argument.
snd_filter. | The filter that should be applied for the search. If snd_filter argument is a null object, the amount of all sounds should be returned.

void SoundBrowserApp::OnClose ( ) [protected]

BOOLEAN SoundBrowserApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected]

BOOLEAN SoundBrowserApp::OnMessage ( const Message & msg ) [protected]

void SoundBrowserApp::OnOpen ( ) [protected]

void SoundBrowserApp::OnStartup ( ) [protected]

ServiceResult SoundBrowserApp::SaveSound | ( | const BinData * | raw_data,
 |  | const Path & | path,
 |  | DrmMimeType | drm_mime_type,
 |  | MimeType | mime_type
 | ) |

SaveSound stores the sound given in sound argument at the location given in path argument.

Parameters:
sound | The sound that should be stored. If sound argument is a null object, the invocation should be ignored, but ServResSuccess should be returned.
path | Path for storing location of the sound. Modification of the storage location should only be possible, if the path argument is a null object.
drm_mime_type | Mime type for Digital Rights Management (DRM) information object for the given image. If DRM Mime type is set to DrmNone, the image is not DRM protected.
mime_type | The Mime type of the image. if the mime type is unknown or invalid, the image is ???

ServiceResult SoundBrowserApp::SelectSound | ( | MediaRefPtr & | media_ref_ptr,
 |  | const SoundFilter & | snd_filter = SoundFilter()
 | ) |

SelectSound presents a list of available sounds filtered using snd_filter argument. If no sound is available, an empty list should be presented. If snd_filter argument is a null object, the list of sounds should not be filtered. If a sound has been selected and the selection has been confirmed, the sound is returned in snd_ref argument, otherwise snd_ref argument is a null object. This Service method is not re-entrant.

BOOLEAN SoundBrowserApp::UpdateItem ( Item * item ) [virtual]

The documentation for this class was generated from the following files:
  • Applications/SoundBrowser/SoundBrowserApp.hpp
  • Applications/SoundBrowser/SoundBrowserApp.cpp
Generated on Wed Jan 25 02:01:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundBrowserServiceMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundBrowserServiceMsg Class Reference

#include <Applications/SoundBrowser/SoundBrowserMsgTypes.hpp>

Inheritance diagram for SoundBrowserServiceMsg:

[legend]
Collaboration diagram for SoundBrowserServiceMsg:

[legend]

Public Types

enum | { ID = 21355 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SoundBrowserServiceMsg (ExecutionContext *context)
virtual | ~SoundBrowserServiceMsg ()

Detailed Description

SoundBrowserServiceMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SoundBrowserServiceMsg::SoundBrowserServiceMsg ( ExecutionContext * context )

SoundBrowserServiceMsg::~SoundBrowserServiceMsg ( ) [virtual]

Member Function Documentation

Message * SoundBrowserServiceMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SoundBrowserServiceMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/SoundBrowser/SoundBrowserMsgTypes.hpp
  • Applications/SoundBrowser/SoundBrowserMsgTypes.cpp
Generated on Wed Jan 25 02:01:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundBrowserTestWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundBrowserTestWin Class Reference
[SoundBrowser]

#include <Applications/SoundBrowser/SoundBrowserTestWin.hpp>

Collaboration diagram for SoundBrowserTestWin:

[legend]

Public Member Functions

void | Init ()
SoundBrowserTestWin ()
virtual | ~SoundBrowserTestWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual BOOLEAN | OnCancel ()
virtual void | OnLayoutClient ()

Constructor & Destructor Documentation

SoundBrowserTestWin::SoundBrowserTestWin ( )

SoundBrowserTestWin::~SoundBrowserTestWin ( ) [virtual]

Member Function Documentation

void SoundBrowserTestWin::Init ( )

void SoundBrowserTestWin::OnActionExecuted ( Action * action ) [protected, virtual]

BOOLEAN SoundBrowserTestWin::OnCancel ( ) [protected, virtual]

void SoundBrowserTestWin::OnLayoutClient ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/SoundBrowser/SoundBrowserTestWin.hpp
  • Applications/SoundBrowser/SoundBrowserTestWin.cpp
Generated on Wed Jan 25 02:01:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundBrowserWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundBrowserWin Class Reference
[SoundBrowser]

#include <Applications/SoundBrowser/SoundBrowserWin.hpp>

Collaboration diagram for SoundBrowserWin:

[legend]

Public Member Functions

MediaRefPtr & GetSelectedSoundRef ()
BOOLEAN | GetSuccess () const
void | Init (BooleanCondition &condition, SoundRefContainer &snd_refs)
void | OnErrorNotification (const SharedPtr< AudioReference > &audio_reference, AudioError::ErrorType err_no)
void | OnStopNotification (const SharedPtr< AudioActiveReference > &active_reference, BOOLEAN auto_stop)
BOOLEAN | SetSoundFilter (const SoundFilter &snd_filter, BOOLEAN show_select_button)
SoundBrowserWin ()
virtual | ~SoundBrowserWin ()

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
virtual BOOLEAN | OnCancel ()
virtual void | OnClose ()
virtual BOOLEAN | OnConfirm ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &msg)
void | OnOpen ()
void | PlaySelectedSound ()
void | StopSound ()

Detailed Description

Main window for the sound browser application. It provides a menu for calling different operations on the sounds stored like renaming, deleting, or loading.

Constructor & Destructor Documentation

SoundBrowserWin::SoundBrowserWin ( )

SoundBrowserWin::~SoundBrowserWin ( ) [virtual]

Member Function Documentation

MediaRefPtr & SoundBrowserWin::GetSelectedSoundRef ( )

Returns the SoundRef object that has been selected by the SoundBrowser.

BOOLEAN SoundBrowserWin::GetSuccess ( ) const

Returns if the selection was successful and confirmed or if cancel has been pressed.

void SoundBrowserWin::Init | ( | BooleanCondition & | condition,
 |  | SoundRefContainer & | snd_refs
 | ) |

Initializes the window with a condition and a SoundRefContainer which has to be created by the SoundBrowserApp.

void SoundBrowserWin::OnActionExecuted ( Action * action ) [protected, virtual]

BOOLEAN SoundBrowserWin::OnCancel ( ) [protected, virtual]

void SoundBrowserWin::OnClose ( ) [protected, virtual]

BOOLEAN SoundBrowserWin::OnConfirm ( ) [protected, virtual]

void SoundBrowserWin::OnErrorNotification | ( | const SharedPtr< AudioReference > & | audio_reference,
 |  | AudioError::ErrorType | err_no
 | ) |

Handle error notification from the framework

BOOLEAN SoundBrowserWin::OnKeyDown ( KeyCode key_code ) [protected, virtual]

void SoundBrowserWin::OnLayoutClient ( ) [protected, virtual]

BOOLEAN SoundBrowserWin::OnMessage ( const Message & msg ) [protected, virtual]

void SoundBrowserWin::OnOpen ( ) [protected]

void SoundBrowserWin::OnStopNotification | ( | const SharedPtr< AudioActiveReference > & | active_reference,
 |  | BOOLEAN | auto_stop
 | ) |

Handle stop notification from the framework

void SoundBrowserWin::PlaySelectedSound ( ) [protected]

BOOLEAN SoundBrowserWin::SetSoundFilter | ( | const SoundFilter & | snd_filter,
 |  | BOOLEAN | show_select_button
 | ) |

Sets the SoundFilter and reloads the entries of the SoundRefContainer by applying the sound filter to every sound.

Parameters:
snd_filter | SoundFilter to apply.
show_select_button | Defines if the select_button should be shown after the snd_filter has been applied to the entries.

void SoundBrowserWin::StopSound ( ) [protected]

The documentation for this class was generated from the following files:
  • Applications/SoundBrowser/SoundBrowserWin.hpp
  • Applications/SoundBrowser/SoundBrowserWin.cpp
Generated on Wed Jan 25 02:01:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundFileFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundFileFilter Class Reference
[Root File System]

File filter filtering sound files More...

#include <Apoxi/Afs/Rfs/FileFilter.hpp>

Inheritance diagram for SoundFileFilter:

[legend]
Collaboration diagram for SoundFileFilter:

[legend]

Public Member Functions

virtual BOOLEAN | Complies (const Path &path)
SoundFileFilter (BOOLEAN filter_dirs=FALSE)

Protected Member Functions

virtual | ~SoundFileFilter ()
Destroys a sound file filter.

Protected Attributes

BOOLEAN | m_filter_dirs
Tells if directories shall be filtered.

Detailed Description

File filter filtering sound files

Class SoundFileFilter is a predefined file filter functor which filters sound files. These are actually midi, mmf, imelody, mpeg, amr, wav, 3gpp, spf, and aac files. Optionally directories get filtered, too.

Constructor & Destructor Documentation

SoundFileFilter::SoundFileFilter ( BOOLEAN filter_dirs = FALSE )

Constructs a sound file filter. If filter_dirs is TRUE then all directories get filtered, too.

Parameters:
filter_dirs Tells if directories shall be filtered.

SoundFileFilter::~SoundFileFilter ( ) [protected, virtual]

Destroys a sound file filter.

Member Function Documentation

BOOLEAN SoundFileFilter::Complies ( const Path & path ) [virtual]

Tells if the file with path is a sound file of type midi, mmf, imelody, mpeg, amr, wav, 3gpp, spf, or aac or is a directory in case it shall filter directories, too.

Implements FileFilter.

Field Documentation

BOOLEAN SoundFileFilter::m_filter_dirs [protected]

Tells if directories shall be filtered.

The documentation for this class was generated from the following files:
  • Afs/Rfs/FileFilter.hpp
  • Afs/Rfs/FileFilter.cpp
Generated on Wed Jan 25 02:01:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundFilter Class Reference
[ImageBrowserCommon, ImageBrowserCommon]

Base class for filters concerning sound references. More...

#include <Applications/ImageBrowser/Common/MediaFilter.hpp>

Inheritance diagram for SoundFilter:

[legend]
Collaboration diagram for SoundFilter:

[legend]

Public Member Functions

virtual BOOLEAN | IsAllowed (const MediaRef &snd_ref) const
virtual BOOLEAN | IsAllowed (const MediaRef &snd_ref) const
SoundFilter ()
SoundFilter ()
virtual | ~SoundFilter ()
virtual | ~SoundFilter ()

Detailed Description

Base class for filters concerning sound references.

Constructor & Destructor Documentation

SoundFilter::SoundFilter ( )

SoundFilter::~SoundFilter ( ) [virtual]

SoundFilter::SoundFilter ( )

virtual SoundFilter::~SoundFilter ( ) [virtual]

Member Function Documentation

virtual BOOLEAN SoundFilter::IsAllowed ( const MediaRef & snd_ref ) const [virtual]

See also:
MediaFilter::IsAllowed()

Reimplemented from MediaFilter.

BOOLEAN SoundFilter::IsAllowed ( const MediaRef & snd_ref ) const [virtual]

See also:
MediaFilter::IsAllowed()

Reimplemented from MediaFilter.

The documentation for this class was generated from the following files:
  • Applications/ImageBrowser/Common/MediaFilter.hpp
  • Applications/SoundBrowser/Common/MediaFilter.hpp
  • Applications/ImageBrowser/Common/MediaFilter.cpp
  • Applications/SoundBrowser/Common/MediaFilter.cpp
Generated on Wed Jan 25 02:01:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundItem Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/SoundItem.hpp>

Inheritance diagram for SoundItem:

[legend]
Collaboration diagram for SoundItem:

[legend]

Public Types

enum | { ID = 5 }

Public Member Functions

virtual AtomItem * | Clone () const
virtual void | Draw (DeviceContext *dc, const Rect &bounds) const
virtual XYDIM | GetHeight () const
virtual INT | GetId () const
const Sound * | GetSound () const
const SoundObtainer & | GetSoundObtainer () const
virtual XYDIM | GetWidth () const
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual void | Play (AudioContext *ac) const
Plays the contained sound with the given AudioContext.
SoundItem (const SoundObtainer &obtainer)
virtual | ~SoundItem ()

Detailed Description

Obsolete - all sound classes from AddOns/MultiMedia have been replaced by a new audio concept. Use the AudioDeviceManager instead for playing sounds.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BoundedItem.

Constructor & Destructor Documentation

SoundItem::SoundItem ( const SoundObtainer & obtainer ) [explicit]

SoundItem::~SoundItem ( ) [virtual]

Member Function Documentation

AtomItem * SoundItem::Clone ( ) const [virtual]

Returns a pointer to a flat copy of this object, hence the cloned object and the original object are pointing to the same sound.

See also:
AtomItem::Clone();

Implements AtomItem.

void SoundItem::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AtomItem::Draw

Implements AtomItem.

XYDIM SoundItem::GetHeight ( ) const [virtual]

Implements BoundedItem.

INT SoundItem::GetId ( ) const [virtual]

See also:
AtomItem::GetId()

Reimplemented from BoundedItem.

const Sound* SoundItem::GetSound ( ) const [inline]

const SoundObtainer& SoundItem::GetSoundObtainer ( ) const [inline]

XYDIM SoundItem::GetWidth ( ) const [virtual]

Implements BoundedItem.

BOOLEAN SoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from BoundedItem.

void SoundItem::Play ( AudioContext * ac ) const [virtual]

Plays the contained sound with the given AudioContext.

The documentation for this class was generated from the following files:
  • Compat/SoundItem.hpp
  • Compat/SoundItem.cpp
Generated on Wed Jan 25 02:01:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundMetaData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundMetaData Class Reference
[SoundBrowser]

#include <Applications/SoundBrowser/SoundMetaData.hpp>

Inheritance diagram for SoundMetaData:

[legend]
Collaboration diagram for SoundMetaData:

[legend]

Public Member Functions

virtual const MetaDataRecord & | GetMetaDataRecord () const
virtual MetaDataRecord & | GetMetaDataRecord ()
SoundMetaData (const Path &path, UINT32 size=0)
SoundMetaData ()
virtual | ~SoundMetaData ()

Detailed Description

Stores metadata of the sounds in a SoundMetaDataRecord and provides setter and getter methods for the properties.

Constructor & Destructor Documentation

SoundMetaData::SoundMetaData ( )

SoundMetaData::SoundMetaData | ( | const Path & | path,
 |  | UINT32 | size = 0
 | ) |

SoundMetaData::~SoundMetaData ( ) [virtual]

Member Function Documentation

const MetaDataRecord & SoundMetaData::GetMetaDataRecord ( ) const [virtual]

See also:
MetaData::GetMetaDataRecord()

Implements MetaData.

MetaDataRecord & SoundMetaData::GetMetaDataRecord ( ) [virtual]

See also:
MetaData::GetMetaDataRecord()

Implements MetaData.

The documentation for this class was generated from the following files:
  • Applications/SoundBrowser/SoundMetaData.hpp
  • Applications/SoundBrowser/SoundMetaData.cpp
Generated on Wed Jan 25 02:01:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundMetaDataRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundMetaDataRecord Struct Reference
[SoundBrowser]

#include <Applications/SoundBrowser/SoundMetaData.hpp>

Inheritance diagram for SoundMetaDataRecord:

[legend]
Collaboration diagram for SoundMetaDataRecord:

[legend]
The documentation for this struct was generated from the following file:
  • Applications/SoundBrowser/SoundMetaData.hpp
Generated on Wed Jan 25 02:01:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundObtainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundObtainer Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/Sound.hpp>

Inheritance diagram for SoundObtainer:

[legend]
Collaboration diagram for SoundObtainer:

[legend]

Public Member Functions

const Sound * | GetSound () const
Sound * GetSound ()
SoundObtainer (const SoundObtainer &sound_obt)
SoundObtainer (Sound *sound, BOOLEAN disposable)
SoundObtainer ()
virtual | ~SoundObtainer ()

Constructor & Destructor Documentation

SoundObtainer::SoundObtainer ( )

SoundObtainer::SoundObtainer | ( | Sound * | sound,
 |  | BOOLEAN | disposable
 | ) |

SoundObtainer::SoundObtainer ( const SoundObtainer & sound_obt ) [inline]

SoundObtainer::~SoundObtainer ( ) [virtual]

Member Function Documentation

const Sound* SoundObtainer::GetSound ( ) const [inline]

Sound* SoundObtainer::GetSound ( ) [inline]

The documentation for this class was generated from the following files:
  • Compat/Sound.hpp
  • Compat/Sound.cpp
Generated on Wed Jan 25 02:01:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundRef Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundRef Class Reference
[SoundBrowser]

#include <Applications/SoundBrowser/SoundRef.hpp>

Inheritance diagram for SoundRef:

[legend]
Collaboration diagram for SoundRef:

[legend]

Public Member Functions

virtual const MetaData & | GetMetaData () const
virtual MetaData & | GetMetaData ()
BinData * | GetSoundBuffer (MimeType &mime_type)
virtual void | SetMetaData (const MetaData &meta_data)
SoundRef ()
virtual | ~SoundRef ()

Detailed Description

SoundRef is used to encapsulate functionality for handing over information about a sound or for loading a sound from the filesystem.
See also:
MediaRef

Constructor & Destructor Documentation

SoundRef::SoundRef ( )

SoundRef::~SoundRef ( ) [virtual]

Member Function Documentation

const MetaData & SoundRef::GetMetaData ( ) const [virtual]

See also:
MediaRef::GetMetaData

Implements MediaRef.

MetaData & SoundRef::GetMetaData ( ) [virtual]

See also:
MediaRef::GetMetaData

Implements MediaRef.

BinData * SoundRef::GetSoundBuffer ( MimeType & mime_type )

void SoundRef::SetMetaData ( const MetaData & meta_data ) [virtual]

See also:
MediaRef::SetMetaData

Implements MediaRef.

The documentation for this class was generated from the following files:
  • Applications/SoundBrowser/SoundRef.hpp
  • Applications/SoundBrowser/SoundRef.cpp
Generated on Wed Jan 25 02:01:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundRefContainer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SoundRefContainer Class Reference
[SoundBrowser]

#include <Applications/SoundBrowser/SoundRefContainer.hpp>

Inheritance diagram for SoundRefContainer:

[legend]
Collaboration diagram for SoundRefContainer:

[legend]

Public Member Functions

virtual BOOLEAN | Add (MediaRefPtr &media_ref)
SoundRefContainer (const Path &database_path)
SoundRefContainer ()
virtual | ~SoundRefContainer ()

Protected Member Functions

virtual MediaRefPtr | CreateMediaRef () const
virtual FileFilterPtr | GetMediaFileFilter () const
virtual UINT32 | GetSizeOfRecord () const
virtual BOOLEAN | SetupMediaObject (MediaRefPtr &media_ref)
virtual BOOLEAN | SetupMediaObject (MetaData &metadata)

Detailed Description

Class SoundRefContainer implements a media container for sounds only.

Constructor & Destructor Documentation

SoundRefContainer::SoundRefContainer ( )

SoundRefContainer::SoundRefContainer ( const Path & database_path )

SoundRefContainer::~SoundRefContainer ( ) [virtual]

Member Function Documentation

BOOLEAN SoundRefContainer::Add ( MediaRefPtr & media_ref ) [virtual]

Adds the sound of the media reference.

See also:
MediaRefContainer::Add()

Reimplemented from MediaRefContainer.

MediaRefPtr SoundRefContainer::CreateMediaRef ( ) const [protected, virtual]

Implements MediaRefContainer.

FileFilterPtr SoundRefContainer::GetMediaFileFilter ( ) const [protected, virtual]

See also:
MediaRefContainer::GetMediaFileFilter()

Implements MediaRefContainer.

UINT32 SoundRefContainer::GetSizeOfRecord ( ) const [protected, virtual]

Returns the size in bytes of one media reference record of the derived class. The size of the media reference records for different media references may differ.

Implements MediaRefContainer.

BOOLEAN SoundRefContainer::SetupMediaObject ( MediaRefPtr & media_ref ) [protected, virtual]

See also:
MediaRefContainer::SetupMediaObject()

Implements MediaRefContainer.

BOOLEAN SoundRefContainer::SetupMediaObject ( MetaData & metadata ) [protected, virtual]

See also:
MediaRefContainer::SetupMediaObject()

The documentation for this class was generated from the following files:
  • Applications/SoundBrowser/SoundRefContainer.hpp
  • Applications/SoundBrowser/SoundRefContainer.cpp
Generated on Wed Jan 25 02:01:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SpeechAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SpeechAudioDevice Class Reference

#include <Apoxi/Devices/Win32/SpeechAudioDevice.hpp>

Inheritance diagram for SpeechAudioDevice:

[legend]
Collaboration diagram for SpeechAudioDevice:

[legend]

Public Types

enum | MuteDirection { MuteUplink, MuteDownlink, MuteUpDownlink }
Mute direction. More...
enum SpeechVolume {
SpeechVolume1 = 1, SpeechVolume2, SpeechVolume3, SpeechVolume4,
SpeechVolume5, SpeechVolume6, SpeechVolume7, SpeechVolume8
}
Speech volume: Steps for speech volume are available, with a 3 dB change for each step. More...

Public Member Functions

virtual const WCHAR * | GetName () const
virtual AudioReturnCode | Init (Priority prio)
AudioReturnCode | Mute (BOOLEAN mute, MuteDirection direction)
AudioReturnCode | SetVolume (SpeechVolume volume)
SpeechAudioDevice ()
virtual AudioReturnCode | Start (BOOLEAN auto_release=TRUE)
virtual AudioReturnCode | Stop (UINT8 channel=0)
virtual | ~SpeechAudioDevice ()

Detailed Description

Class SpeechAudioDevice
Class for handles the speech resource.

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Member Enumeration Documentation

enum SpeechAudioDevice::MuteDirection

Mute direction.

Enumerator:
MuteUplink | Mute up link.
MuteDownlink | Mute down link.
MuteUpDownlink | Mute up and down link.

enum SpeechAudioDevice::SpeechVolume

Speech volume: Steps for speech volume are available, with a 3 dB change for each step.

Enumerator:
SpeechVolume1 | Speech volume 1.
SpeechVolume2 | Speech volume 2.
SpeechVolume3 | Speech volume 3.
SpeechVolume4 | Speech volume 4.
SpeechVolume5 | Speech volume 5.
SpeechVolume6 | Speech volume 6.
SpeechVolume7 | Speech volume 7.
SpeechVolume8 | Speech volume 8.

Constructor & Destructor Documentation

SpeechAudioDevice::SpeechAudioDevice ( )

SpeechAudioDevice::~SpeechAudioDevice ( ) [virtual]

Member Function Documentation

const WCHAR * SpeechAudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from GenericAudioDevice.

SpeechAudioDevice::AudioReturnCode SpeechAudioDevice::Init ( Priority prio ) [virtual]

Enable uplink and downlink audio path for speech.
The volume level will be level last set with AUD_speech_set_volume level.

See also:
GenericAudioDevice::Init

SpeechAudioDevice::AudioReturnCode SpeechAudioDevice::Mute | ( | BOOLEAN | mute,
 |  | MuteDirection | direction
 | ) |

Mutes or unmutes the uplink or downlink (or both) audio path.

Parameters:
direction Direction to mute.
Returns:
Result of operation.

SpeechAudioDevice::AudioReturnCode SpeechAudioDevice::SetVolume ( SpeechVolume volume )

Change the speaker volume.
Change the speaker volume. 8 steps are available, with a 3 dB change for each step. The audio driver only stores the volume in RAM. If the volume should be remembered after a power off, it is up to the MMI to the volume level in the EEPROM.

Parameters:
volume Volume to set
Returns:
Result of operation.

SpeechAudioDevice::AudioReturnCode SpeechAudioDevice::Start ( BOOLEAN auto_release = TRUE ) [virtual]

See also:
GenericAudioDevice::Start

Reimplemented from GenericAudioDevice.

SpeechAudioDevice::AudioReturnCode SpeechAudioDevice::Stop ( UINT8 channel = 0 ) [virtual]

See also:
GenericAudioDevice::Stop

Reimplemented from GenericAudioDevice.

The documentation for this class was generated from the following files:
  • Devices/Win32/SpeechAudioDevice.hpp
  • Devices/Win32/SpeechAudioDevice.cpp
Generated on Wed Jan 25 02:02:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SpeechSimpleAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SpeechSimpleAudioDevice Class Reference
[Audio]

#include <Apoxi/Audio/SpeechSimpleAudioDevice.hpp>

Inheritance diagram for SpeechSimpleAudioDevice:

[legend]
Collaboration diagram for SpeechSimpleAudioDevice:

[legend]

Public Member Functions

virtual BOOLEAN | ApplyDeviceVolume ()
from AudioDeviceBase
virtual BOOLEAN | Disable ()
virtual BOOLEAN | Enable (BOOLEAN suspend_all_others=FALSE)
BOOLEAN | GetMute (BOOLEAN uplink) const
UINT16 | GetNativeVolumeMax ()
Gets minimal value of native speech volume.
UINT16 | GetNativeVolumeMin ()
Gets maximal value of native speech volume.
virtual AudioSourceType | GetSource () const
BOOLEAN | SetMute (BOOLEAN uplink, BOOLEAN enable=TRUE)
virtual | ~SpeechSimpleAudioDevice ()

Static Public Member Functions

static SpeechSimpleAudioDevice * | GetInstance ()

Detailed Description

Speech Device. TODO: This should really be called SpeechAudioDevice, but there is an existing class with the same name. Hopefully that other class will be removed from APOXI eventually. murrayc.

Constructor & Destructor Documentation

SpeechSimpleAudioDevice::~SpeechSimpleAudioDevice ( ) [virtual]

Member Function Documentation

BOOLEAN SpeechSimpleAudioDevice::ApplyDeviceVolume ( ) [virtual]

from AudioDeviceBase

Reimplemented from AudioDeviceBase.

BOOLEAN SpeechSimpleAudioDevice::Disable ( ) [virtual]

Stop the Speech device. If you specified TRUE for suspend_all_others when you called Enable(), then any sounds that were suspended at that time will now be resumed.

Returns:
Whether the device was successfully disabled.

Implements SimpleAudioDevice.

BOOLEAN SpeechSimpleAudioDevice::Enable ( BOOLEAN suspend_all_others = FALSE ) [virtual]

Start the Speech device.

Parameters:
suspend_all_others Whether all other sounds should be suspended (or stopped, if they can not be suspended).
Returns:
Whether the device was successfully enabled.

Implements SimpleAudioDevice.

SpeechSimpleAudioDevice * SpeechSimpleAudioDevice::GetInstance ( ) [static]

Singleton

BOOLEAN SpeechSimpleAudioDevice::GetMute ( BOOLEAN uplink ) const

Discover whether the uplink or downlink is muted.

Parameters:
uplink Whether the uplink or downlink mute status is being requested. Use TRUE for uplink and FALSE for downlink.
Returns:
Whether the mute was successfully retrieved.

UINT16 SpeechSimpleAudioDevice::GetNativeVolumeMax ( )

Gets minimal value of native speech volume.

UINT16 SpeechSimpleAudioDevice::GetNativeVolumeMin ( )

Gets maximal value of native speech volume.

AudioDeviceBase::AudioSourceType SpeechSimpleAudioDevice::GetSource ( ) const [virtual]

BOOLEAN SpeechSimpleAudioDevice::SetMute | ( | BOOLEAN | uplink,
 |  | BOOLEAN | enable = TRUE
 | ) |

This function is obsolete, use AudioDeviceBase::SetMute() instead. Mute the uplink or downlink. uplink Whether the uplink or downlink should be affected. Use TRUE for uplink and FALSE for downlink.

Parameters:
enable Whether the mute should be enabled or disabled.
Returns:
Whether the mute was successfully set.

The documentation for this class was generated from the following files:
  • Audio/SpeechSimpleAudioDevice.hpp
  • Audio/SpeechSimpleAudioDevice.cpp
Generated on Wed Jan 25 02:02:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsBarringIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsBarringIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsBarringIndArg:

[legend]
Collaboration diagram for SsBarringIndArg:

[legend]

Public Types

enum | { ID = 1003 }

Public Member Functions

const CallBarringInfo & | GetCallBarringInfo () const
const SsOperationCode & | GetOperationCode () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetCallBarringInfo (const CallBarringInfo &call_barring_info)
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetTipd (const Tipd &tipd)
SsBarringIndArg ()

Static Public Member Functions

static const SsBarringIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsBarringIndArg: reflects arguments of signal MN_SS_BARRING_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsBarringIndArg::SsBarringIndArg ( )

Member Function Documentation

const SsBarringIndArg & SsBarringIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallBarringInfo& SsBarringIndArg::GetCallBarringInfo ( ) const [inline]

const SsOperationCode& SsBarringIndArg::GetOperationCode ( ) const [inline]

const Tipd& SsBarringIndArg::GetTipd ( ) const [inline]

BOOLEAN SsBarringIndArg::IsReleaseComplete ( ) const [inline]

void SsBarringIndArg::SetCallBarringInfo ( const CallBarringInfo & call_barring_info ) [inline]

void SsBarringIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsBarringIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsBarringIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsBeginAccArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsBeginAccArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsBeginAccArg:

[legend]
Collaboration diagram for SsBeginAccArg:

[legend]

Public Types

enum | { ID = 1000 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsBeginAccArg ()

Static Public Member Functions

static const SsBeginAccArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsBeginAccArg: reflects arguments of signal MN_SS_BEGIN_ACC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsBeginAccArg::SsBeginAccArg ( )

Member Function Documentation

const SsBeginAccArg & SsBeginAccArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsBeginAccArg::GetTipd ( ) const [inline]

void SsBeginAccArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCallBarringActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCallBarringActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsCallBarringActionImpl:

[legend]
Collaboration diagram for SsCallBarringActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE, const SelectedLineRetriever *line_retriever=0)
SsCallBarringActionImpl ()
virtual | ~SsCallBarringActionImpl ()

Constructor & Destructor Documentation

SsCallBarringActionImpl::SsCallBarringActionImpl ( )

SsCallBarringActionImpl::~SsCallBarringActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsCallBarringActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsCallBarringActionImpl::Init | ( | BOOLEAN | registerOnly = FALSE,
 |  | const SelectedLineRetriever * | line_retriever = 0
 | ) |

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCallForwardingActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCallForwardingActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsCallForwardingActionImpl:

[legend]
Collaboration diagram for SsCallForwardingActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE, const SelectedLineRetriever *line_retriever=0)
SsCallForwardingActionImpl ()
virtual | ~SsCallForwardingActionImpl ()

Constructor & Destructor Documentation

SsCallForwardingActionImpl::SsCallForwardingActionImpl ( )

SsCallForwardingActionImpl::~SsCallForwardingActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsCallForwardingActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsCallForwardingActionImpl::Init | ( | BOOLEAN | registerOnly = FALSE,
 |  | const SelectedLineRetriever * | line_retriever = 0
 | ) |

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCallWaitingActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCallWaitingActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsCallWaitingActionImpl:

[legend]
Collaboration diagram for SsCallWaitingActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE, const SelectedLineRetriever *line_retriever=0)
SsCallWaitingActionImpl ()
virtual | ~SsCallWaitingActionImpl ()

Constructor & Destructor Documentation

SsCallWaitingActionImpl::SsCallWaitingActionImpl ( )

SsCallWaitingActionImpl::~SsCallWaitingActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsCallWaitingActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsCallWaitingActionImpl::Init | ( | BOOLEAN | registerOnly = FALSE,
 |  | const SelectedLineRetriever * | line_retriever = 0
 | ) |

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCauseIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCauseIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsCauseIndArg:

[legend]
Collaboration diagram for SsCauseIndArg:

[legend]

Public Types

enum | { ID = 1018 }

Public Member Functions

const MnCause & | GetRejectCause () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetRejectCause (const MnCause &reject_cause)
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetTipd (const Tipd &tipd)
SsCauseIndArg ()

Static Public Member Functions

static const SsCauseIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsCauseIndArg: reflects arguments of signal MN_SS_CAUSE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsCauseIndArg::SsCauseIndArg ( )

Member Function Documentation

const SsCauseIndArg & SsCauseIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MnCause& SsCauseIndArg::GetRejectCause ( ) const [inline]

const Tipd& SsCauseIndArg::GetTipd ( ) const [inline]

BOOLEAN SsCauseIndArg::IsReleaseComplete ( ) const [inline]

void SsCauseIndArg::SetRejectCause ( const MnCause & reject_cause ) [inline]

void SsCauseIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsCauseIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCcbsDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCcbsDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SsCcbsDispatcher.hpp>

Inheritance diagram for SsCcbsDispatcher:

[legend]
Collaboration diagram for SsCcbsDispatcher:

[legend]

Public Member Functions

SsCcbsDispatcher ()
virtual | ~SsCcbsDispatcher ()

Protected Member Functions

BOOLEAN | OnSsCcbsReCallInd (const StackMsgArgument &arg)
BOOLEAN | OnSsCcbsResultInd (const StackMsgArgument &arg)
BOOLEAN | OnSsCcbsStatusInd (const StackMsgArgument &arg)

Constructor & Destructor Documentation

SsCcbsDispatcher::SsCcbsDispatcher ( )

SsCcbsDispatcher::~SsCcbsDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN SsCcbsDispatcher::OnSsCcbsReCallInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsCcbsDispatcher::OnSsCcbsResultInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsCcbsDispatcher::OnSsCcbsStatusInd ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Asc/SsCcbsDispatcher.hpp
  • Asc/SsCcbsDispatcher.cpp
Generated on Wed Jan 25 02:02:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCcbsHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCcbsHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/SsCcbsHandler.hpp>

Collaboration diagram for SsCcbsHandler:

[legend]

Public Types

enum | { ID = SsCcbsHandlerId }

Public Member Functions

virtual HandlerId | GetHandlerId () const
SsApiRc | SendCcbsInvoke () const
SsApiRc | SendCcbsReCallRequest () const
SsApiRc | SendCcbsReject () const
SsCcbsHandler ()
virtual | ~SsCcbsHandler ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsCcbsHandler::SsCcbsHandler ( )

SsCcbsHandler::~SsCcbsHandler ( ) [virtual]

Member Function Documentation

HandlerId SsCcbsHandler::GetHandlerId ( ) const [virtual]

SsApiRc SsCcbsHandler::SendCcbsInvoke ( ) const

SsApiRc SsCcbsHandler::SendCcbsReCallRequest ( ) const

SsApiRc SsCcbsHandler::SendCcbsReject ( ) const

The documentation for this class was generated from the following files:
  • Asc/SsCcbsHandler.hpp
  • Asc/SsCcbsHandler.cpp
Generated on Wed Jan 25 02:02:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCcbsInvokeArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCcbsInvokeArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsCcbsInvokeArg:

[legend]
Collaboration diagram for SsCcbsInvokeArg:

[legend]

Public Types

enum | { ID = 2030 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsCcbsInvokeArg ()
SsCcbsInvokeArg (const Tipd &tipd)

Static Public Member Functions

static const SsCcbsInvokeArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsCcbsInvokeArg reflects arguments of signal MN_CCBS_INVOKE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsCcbsInvokeArg::SsCcbsInvokeArg ( const Tipd & tipd )

SsCcbsInvokeArg::SsCcbsInvokeArg ( )

Member Function Documentation

const SsCcbsInvokeArg & SsCcbsInvokeArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsCcbsInvokeArg::GetTipd ( ) const [inline]

void SsCcbsInvokeArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCcbsReCallIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCcbsReCallIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsCcbsReCallIndArg:

[legend]
Collaboration diagram for SsCcbsReCallIndArg:

[legend]

Public Types

enum | { ID = 1030 }

Public Member Functions

const CcbsEntry & | GetCcbsEntry () const
const Tipd & | GetTipd () const
void | SetCcbsEntry (const CcbsEntry &ccbs_entry)
void | SetTipd (const Tipd &tipd)
SsCcbsReCallIndArg ()

Static Public Member Functions

static const SsCcbsReCallIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsCcbsReCallIndArg reflects arguments of signal MN_CCBS_RECALL_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsCcbsReCallIndArg::SsCcbsReCallIndArg ( )

Member Function Documentation

const SsCcbsReCallIndArg & SsCcbsReCallIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CcbsEntry& SsCcbsReCallIndArg::GetCcbsEntry ( ) const [inline]

const Tipd& SsCcbsReCallIndArg::GetTipd ( ) const [inline]

void SsCcbsReCallIndArg::SetCcbsEntry ( const CcbsEntry & ccbs_entry ) [inline]

void SsCcbsReCallIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCcbsReCallRequestArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCcbsReCallRequestArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsCcbsReCallRequestArg:

[legend]
Collaboration diagram for SsCcbsReCallRequestArg:

[legend]

Public Types

enum | { ID = 2032 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsCcbsReCallRequestArg ()
SsCcbsReCallRequestArg (const Tipd &tipd)

Static Public Member Functions

static const SsCcbsReCallRequestArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsCcbsReCallRequestArg reflects arguments of signal MN_CCBS_RECALL_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsCcbsReCallRequestArg::SsCcbsReCallRequestArg ( const Tipd & tipd )

SsCcbsReCallRequestArg::SsCcbsReCallRequestArg ( )

Member Function Documentation

const SsCcbsReCallRequestArg & SsCcbsReCallRequestArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsCcbsReCallRequestArg::GetTipd ( ) const [inline]

void SsCcbsReCallRequestArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCcbsRejectArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCcbsRejectArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsCcbsRejectArg:

[legend]
Collaboration diagram for SsCcbsRejectArg:

[legend]

Public Types

enum | { ID = 2031 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsCcbsRejectArg ()
SsCcbsRejectArg (const Tipd &tipd)

Static Public Member Functions

static const SsCcbsRejectArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsCcbsRejectArg reflects arguments of signal MN_CCBS_REJ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsCcbsRejectArg::SsCcbsRejectArg ( const Tipd & tipd )

SsCcbsRejectArg::SsCcbsRejectArg ( )

Member Function Documentation

const SsCcbsRejectArg & SsCcbsRejectArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsCcbsRejectArg::GetTipd ( ) const [inline]

void SsCcbsRejectArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCcbsResultIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCcbsResultIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsCcbsResultIndArg:

[legend]
Collaboration diagram for SsCcbsResultIndArg:

[legend]

Public Types

enum | { ID = 1032 }

Public Member Functions

const CcbsAction & | GetCcbsAction () const
const CcbsStatus & | GetCcbsStatus () const
const InterrogateCcbsResult & | GetInterrogateCcbsResult () const
const ReleaseComplete & | GetReleaseComplete () const
const Tipd & | GetTipd () const
void | SetCcbsAction (const CcbsAction &ccbs_action)
void | SetCcbsStatus (const CcbsStatus &ccbs_status)
void | SetInterrogateCcbsResult (const InterrogateCcbsResult &interrogate_ccbs_result)
void | SetReleaseComplete (const ReleaseComplete &release_complete)
void | SetTipd (const Tipd &tipd)
SsCcbsResultIndArg ()

Static Public Member Functions

static const SsCcbsResultIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsCcbsResultIndArg reflects arguments of signal MN_SS_CCBS_RESULT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsCcbsResultIndArg::SsCcbsResultIndArg ( )

Member Function Documentation

const SsCcbsResultIndArg & SsCcbsResultIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CcbsAction& SsCcbsResultIndArg::GetCcbsAction ( ) const [inline]

const CcbsStatus& SsCcbsResultIndArg::GetCcbsStatus ( ) const [inline]

const InterrogateCcbsResult& SsCcbsResultIndArg::GetInterrogateCcbsResult ( ) const [inline]

const ReleaseComplete& SsCcbsResultIndArg::GetReleaseComplete ( ) const [inline]

const Tipd& SsCcbsResultIndArg::GetTipd ( ) const [inline]

void SsCcbsResultIndArg::SetCcbsAction ( const CcbsAction & ccbs_action ) [inline]

void SsCcbsResultIndArg::SetCcbsStatus ( const CcbsStatus & ccbs_status ) [inline]

void SsCcbsResultIndArg::SetInterrogateCcbsResult ( const InterrogateCcbsResult & interrogate_ccbs_result ) [inline]

void SsCcbsResultIndArg::SetReleaseComplete ( const ReleaseComplete & release_complete ) [inline]

void SsCcbsResultIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCcbsStatusIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCcbsStatusIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsCcbsStatusIndArg:

[legend]
Collaboration diagram for SsCcbsStatusIndArg:

[legend]

Public Types

enum | { ID = 1031 }

Public Member Functions

const CcbsStatus & | GetCcbsStatus () const
const Tipd & | GetTipd () const
void | SetCcbsStatus (const CcbsStatus &ccbs_status)
void | SetTipd (const Tipd &tipd)
SsCcbsStatusIndArg ()

Static Public Member Functions

static const SsCcbsStatusIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsCcbsStatusIndArg reflects arguments of signal MN_CCBS_STATUS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsCcbsStatusIndArg::SsCcbsStatusIndArg ( )

Member Function Documentation

const SsCcbsStatusIndArg & SsCcbsStatusIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CcbsStatus& SsCcbsStatusIndArg::GetCcbsStatus ( ) const [inline]

const Tipd& SsCcbsStatusIndArg::GetTipd ( ) const [inline]

void SsCcbsStatusIndArg::SetCcbsStatus ( const CcbsStatus & ccbs_status ) [inline]

void SsCcbsStatusIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsClientRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsClientRejArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsClientRejArg:

[legend]
Collaboration diagram for SsClientRejArg:

[legend]

Public Types

enum | { ID = 1019 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsClientRejArg ()

Static Public Member Functions

static const SsClientRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsClientRejArg: reflects arguments of signal MN_SS_CLIENT_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsClientRejArg::SsClientRejArg ( )

Member Function Documentation

const SsClientRejArg & SsClientRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsClientRejArg::GetTipd ( ) const [inline]

void SsClientRejArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsClipActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsClipActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsClipActionImpl:

[legend]
Collaboration diagram for SsClipActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE)
SsClipActionImpl ()
virtual | ~SsClipActionImpl ()

Constructor & Destructor Documentation

SsClipActionImpl::SsClipActionImpl ( )

SsClipActionImpl::~SsClipActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsClipActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsClipActionImpl::Init ( BOOLEAN registerOnly = FALSE ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsClirActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsClirActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsClirActionImpl:

[legend]
Collaboration diagram for SsClirActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE)
SsClirActionImpl ()
virtual | ~SsClirActionImpl ()

Constructor & Destructor Documentation

SsClirActionImpl::SsClirActionImpl ( )

SsClirActionImpl::~SsClirActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsClirActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsClirActionImpl::Init ( BOOLEAN registerOnly = FALSE ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsCnapActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsCnapActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsCnapActionImpl:

[legend]
Collaboration diagram for SsCnapActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE)
SsCnapActionImpl ()
virtual | ~SsCnapActionImpl ()

Constructor & Destructor Documentation

SsCnapActionImpl::SsCnapActionImpl ( )

SsCnapActionImpl::~SsCnapActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsCnapActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsCnapActionImpl::Init ( BOOLEAN registerOnly = FALSE ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsColpActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsColpActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsColpActionImpl:

[legend]
Collaboration diagram for SsColpActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE)
SsColpActionImpl ()
virtual | ~SsColpActionImpl ()

Constructor & Destructor Documentation

SsColpActionImpl::SsColpActionImpl ( )

SsColpActionImpl::~SsColpActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsColpActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsColpActionImpl::Init ( BOOLEAN registerOnly = FALSE ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsColrActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsColrActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsColrActionImpl:

[legend]
Collaboration diagram for SsColrActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE)
SsColrActionImpl ()
virtual | ~SsColrActionImpl ()

Constructor & Destructor Documentation

SsColrActionImpl::SsColrActionImpl ( )

SsColrActionImpl::~SsColrActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsColrActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsColrActionImpl::Init ( BOOLEAN registerOnly = FALSE ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsControlIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsControlIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsControlIndMsg:

[legend]
Collaboration diagram for SsControlIndMsg:

[legend]

Public Types

enum | { ID = 18705 }

Public Member Functions

virtual Message * | Clone () const
const CallControlSsIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallControlSsIndArg &arg)
SsControlIndMsg (const CallControlSsIndArg &arg)
virtual | ~SsControlIndMsg ()

Detailed Description

SsControlIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsControlIndMsg::SsControlIndMsg ( const CallControlSsIndArg & arg )

SsControlIndMsg::~SsControlIndMsg ( ) [virtual]

Member Function Documentation

Message * SsControlIndMsg::Clone ( ) const [virtual]

Implements Message.

const CallControlSsIndArg& SsControlIndMsg::GetArg ( ) const [inline]

const MsgMetaData & SsControlIndMsg::GetMetaData ( ) const [virtual]

Implements Message.

void SsControlIndMsg::SetArg ( const CallControlSsIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:02:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsData Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for SsData:

[legend]

Data Fields

SsGroupList basic_serv_group_list
CliRestrictionOption cli_restriction_option
EmlppPriority default_priority
OverrideCategory override_category
SsCode ss_code
SsStatus ss_status

Field Documentation

SsGroupList SsData::basic_serv_group_list

CliRestrictionOption SsData::cli_restriction_option

EmlppPriority SsData::default_priority

OverrideCategory SsData::override_category

SsCode SsData::ss_code

SsStatus SsData::ss_status

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:02:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsDataIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsDataIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsDataIndArg:

[legend]
Collaboration diagram for SsDataIndArg:

[legend]

Public Types

enum | { ID = 1004 }

Public Member Functions

const SsOperationCode & | GetOperationCode () const
const SsData & | GetSsData () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetSsData (const SsData &ss_data)
void | SetTipd (const Tipd &tipd)
SsDataIndArg ()

Static Public Member Functions

static const SsDataIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsDataIndArg: reflects arguments of signal MN_SS_DATA_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsDataIndArg::SsDataIndArg ( )

Member Function Documentation

const SsDataIndArg & SsDataIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SsOperationCode& SsDataIndArg::GetOperationCode ( ) const [inline]

const SsData& SsDataIndArg::GetSsData ( ) const [inline]

const Tipd& SsDataIndArg::GetTipd ( ) const [inline]

BOOLEAN SsDataIndArg::IsReleaseComplete ( ) const [inline]

void SsDataIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsDataIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsDataIndArg::SetSsData ( const SsData & ss_data ) [inline]

void SsDataIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsDataReceivedArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsDataReceivedArg Struct Reference
[APOXI Stack Control]

Indication of received supplementary service data. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for SsDataReceivedArg:

[legend]

Data Fields

SsData data
This type is used to pass information, received in a SsData type, to MI.
SsOperationCode operation_code
The respective call independent supplementary operation code.

Detailed Description

Indication of received supplementary service data.

Field Documentation

SsData SsDataReceivedArg::data

This type is used to pass information, received in a SsData type, to MI.

SsOperationCode SsDataReceivedArg::operation_code

The respective call independent supplementary operation code.

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 02:02:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsDataReceivedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsDataReceivedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsDataReceivedMsg:

[legend]
Collaboration diagram for SsDataReceivedMsg:

[legend]

Public Types

enum | { ID = 18502 }

Public Member Functions

virtual Message * | Clone () const
const SsDataReceivedArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SsDataReceivedArg &arg)
SsDataReceivedMsg (ExecutionContext *context, const SsDataReceivedArg &arg)
virtual | ~SsDataReceivedMsg ()

Detailed Description

SsDataReceivedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsDataReceivedMsg::SsDataReceivedMsg | ( | ExecutionContext * | context,
 |  | const SsDataReceivedArg & | arg
 | ) |

SsDataReceivedMsg::~SsDataReceivedMsg ( ) [virtual]

Member Function Documentation

Message * SsDataReceivedMsg::Clone ( ) const [virtual]

Implements Message.

const SsDataReceivedArg& SsDataReceivedMsg::GetArg ( ) const [inline]

const MsgMetaData & SsDataReceivedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SsDataReceivedMsg::SetArg ( const SsDataReceivedArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:02:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Compat/SsDispatcher.hpp>

Inheritance diagram for SsDispatcher:

[legend]
Collaboration diagram for SsDispatcher:

[legend]

Public Member Functions

SsDispatcher ()
virtual | ~SsDispatcher ()

Protected Member Functions

BOOLEAN | OnSsBarringInd (const StackMsgArgument &arg)
BOOLEAN | OnSsBeginAcc (const StackMsgArgument &arg)
BOOLEAN | OnSsCauseInd (const StackMsgArgument &arg)
BOOLEAN | OnSsDataInd (const StackMsgArgument &arg)
BOOLEAN | OnSsEndInd (const StackMsgArgument &arg)
BOOLEAN | OnSsErrInd (const StackMsgArgument &arg)
BOOLEAN | OnSsFacilityRej (const StackMsgArgument &arg)
BOOLEAN | OnSsForwardingInd (const StackMsgArgument &arg)
BOOLEAN | OnSsForwcheckInd (const StackMsgArgument &arg)
BOOLEAN | OnSsGetPasswordInd (const StackMsgArgument &arg)
BOOLEAN | OnSsGetPasswordRej (const StackMsgArgument &arg)
BOOLEAN | OnSsInterrogateInd (const StackMsgArgument &arg)
BOOLEAN | OnSsNotifyInd (const StackMsgArgument &arg)
BOOLEAN | OnSsPasswordInd (const StackMsgArgument &arg)
BOOLEAN | OnSsRej (const StackMsgArgument &arg)
BOOLEAN | OnSsRetResInd (const StackMsgArgument &arg)
BOOLEAN | OnSsUnstructInd (const StackMsgArgument &arg)
BOOLEAN | OnSsUssdInd (const StackMsgArgument &arg)
BOOLEAN | OnSsUssdResentInd (const StackMsgArgument &arg)

Constructor & Destructor Documentation

SsDispatcher::SsDispatcher ( )

SsDispatcher::~SsDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN SsDispatcher::OnSsBarringInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsBeginAcc ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsCauseInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsDataInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsEndInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsErrInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsFacilityRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsForwardingInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsForwcheckInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsGetPasswordInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsGetPasswordRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsInterrogateInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsNotifyInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsPasswordInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsRetResInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsUnstructInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsUssdInd ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsDispatcher::OnSsUssdResentInd ( const StackMsgArgument & arg ) [protected]

The documentation for this class was generated from the following files:
  • Compat/SsDispatcher.hpp
  • Compat/SsDispatcher.cpp
Generated on Wed Jan 25 02:02:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsEmlppActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsEmlppActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsEmlppActionImpl:

[legend]
Collaboration diagram for SsEmlppActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE)
SsEmlppActionImpl ()
virtual | ~SsEmlppActionImpl ()

Constructor & Destructor Documentation

SsEmlppActionImpl::SsEmlppActionImpl ( )

SsEmlppActionImpl::~SsEmlppActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsEmlppActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsEmlppActionImpl::Init ( BOOLEAN registerOnly = FALSE ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:02:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsEndIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsEndIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsEndIndArg:

[legend]
Collaboration diagram for SsEndIndArg:

[legend]

Public Types

enum | { ID = 1011 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsEndIndArg ()

Static Public Member Functions

static const SsEndIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsEndIndArg: reflects arguments of signal MN_SS_END_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsEndIndArg::SsEndIndArg ( )

Member Function Documentation

const SsEndIndArg & SsEndIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsEndIndArg::GetTipd ( ) const [inline]

void SsEndIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsEndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsEndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsEndMsg:

[legend]
Collaboration diagram for SsEndMsg:

[legend]

Public Types

enum | { ID = 18509 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SsEndMsg (ExecutionContext *context)
virtual | ~SsEndMsg ()

Detailed Description

SsEndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsEndMsg::SsEndMsg ( ExecutionContext * context )

SsEndMsg::~SsEndMsg ( ) [virtual]

Member Function Documentation

Message * SsEndMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SsEndMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:02:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsErrIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsErrIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsErrIndArg:

[legend]
Collaboration diagram for SsErrIndArg:

[legend]

Public Types

enum | { ID = 1013 }

Public Member Functions

const SsErrorCode & | GetSsErrorCode () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetSsErrorCode (const SsErrorCode &ss_error_code)
void | SetTipd (const Tipd &tipd)
SsErrIndArg ()

Static Public Member Functions

static const SsErrIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsErrIndArg: reflects arguments of signal MN_SS_ERR_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsErrIndArg::SsErrIndArg ( )

Member Function Documentation

const SsErrIndArg & SsErrIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SsErrorCode& SsErrIndArg::GetSsErrorCode ( ) const [inline]

const Tipd& SsErrIndArg::GetTipd ( ) const [inline]

BOOLEAN SsErrIndArg::IsReleaseComplete ( ) const [inline]

void SsErrIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsErrIndArg::SetSsErrorCode ( const SsErrorCode & ss_error_code ) [inline]

void SsErrIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:02:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsErrIndicationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsErrIndicationMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsErrIndicationMsg:

[legend]
Collaboration diagram for SsErrIndicationMsg:

[legend]

Public Types

enum | { ID = 18511 }

Public Member Functions

virtual Message * | Clone () const
const SsErrorCode & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SsErrorCode &arg)
SsErrIndicationMsg (ExecutionContext *context, const SsErrorCode &arg)
virtual | ~SsErrIndicationMsg ()

Detailed Description

SsErrIndicationMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsErrIndicationMsg::SsErrIndicationMsg | ( | ExecutionContext * | context,
 |  | const SsErrorCode & | arg
 | ) |

SsErrIndicationMsg::~SsErrIndicationMsg ( ) [virtual]

Member Function Documentation

Message * SsErrIndicationMsg::Clone ( ) const [virtual]

Implements Message.

const SsErrorCode& SsErrIndicationMsg::GetArg ( ) const [inline]

const MsgMetaData & SsErrIndicationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SsErrIndicationMsg::SetArg ( const SsErrorCode & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:02:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsErrorCode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsErrorCode Class Reference

Error Codes, [GSM 04.80, 4.5]. More...

#include <Apoxi/Apc/SsErrorCode.hpp>

Public Types

enum Code {
MsIntSsError = 0, MsIntSsTimeOut = 255, UnknownSubscriber = 1, IllegalSubscriber = 9,
BearerServiceNotProvisioned = 10, TeleserviceNotProvisioned = 11, IllegalEquipment = 12, CallBarred = 13,
IllegalSsOperation = 16, SsErrorStatus = 17, SsNotAvailable = 18, SsSubscriptionViolation = 19,
SsIncompatibility = 20, FacilityNotSupported = 21, AbsentSubscriber = 27, SystemFailure = 34,
DataMissing = 35, UnexpectedDataValue = 36, PwRegistrationFailure = 37, NegativePwCheck = 38,
NumberOfPwAttemptsViolation = 43, PositionMethodError = 54, UnknownAlphabet = 71, UssdBusy = 72,
MaxNumberOfMptyParticipantsExceeded = 126, ResourcesNotAvailable = 127, TaggedError = 128, NoError
}
describes the problem code tags. More...

Public Member Functions

UINT8 | GetByte () const
Returns the byte representation of the problem tag.
Code | GetCode () const
Returns the problem tag enumeration value.
void | SetCode (Code code)
Sets the problem tag enumeration value.
SsErrorCode (UINT8 incoming_byte=0)
Constructor of the class.

Detailed Description

Error Codes, [GSM 04.80, 4.5].

Member Enumeration Documentation

enum SsErrorCode::Code

describes the problem code tags.

Enumerator:
MsIntSsError | Used when the SS operation was unsuccessful due to an MS internal reason.
MsIntSsTimeOut | This is used when the SS operation was unsuccessful due to an missing answer from the network.
UnknownSubscriber | The following error codes are sent by the network.
IllegalSubscriber
BearerServiceNotProvisioned
TeleserviceNotProvisioned
IllegalEquipment
CallBarred
IllegalSsOperation
SsErrorStatus
SsNotAvailable
SsSubscriptionViolation
SsIncompatibility
FacilityNotSupported
AbsentSubscriber
SystemFailure
DataMissing
UnexpectedDataValue
PwRegistrationFailure
NegativePwCheck
NumberOfPwAttemptsViolation
PositionMethodError
UnknownAlphabet
UssdBusy
MaxNumberOfMptyParticipantsExceeded
ResourcesNotAvailable
TaggedError
NoError | Initial value.

Constructor & Destructor Documentation

SsErrorCode::SsErrorCode ( UINT8 incoming_byte = 0 ) [inline]

Constructor of the class.

Member Function Documentation

UINT8 SsErrorCode::GetByte ( ) const [inline]

Returns the byte representation of the problem tag.

Code SsErrorCode::GetCode ( ) const [inline]

Returns the problem tag enumeration value.

void SsErrorCode::SetCode ( Code code ) [inline]

Sets the problem tag enumeration value.

The documentation for this class was generated from the following file:
  • Apc/SsErrorCode.hpp
Generated on Wed Jan 25 02:03:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsErrorMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsErrorMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsErrorMsg:

[legend]
Collaboration diagram for SsErrorMsg:

[legend]

Public Types

enum | { ID = 18550 }

Public Member Functions

virtual Message * | Clone () const
const SsBaseHandler::ReturnCode & | GetErrorCode () const
const WString & | GetErrorText () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
SsErrorMsg (ExecutionContext *context, const Tipd &tipd, const SsBaseHandler::ReturnCode &error_code, const WString &error_text)
virtual | ~SsErrorMsg ()

Detailed Description

SsErrorMsg sent when an error in APOXI occured

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsErrorMsg::SsErrorMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsBaseHandler::ReturnCode & | error_code,
 |  | const WString & | error_text
 | ) |

SsErrorMsg::~SsErrorMsg ( ) [virtual]

Member Function Documentation

Message * SsErrorMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const SsBaseHandler::ReturnCode& SsErrorMsg::GetErrorCode ( void ) const [inline]

const WString& SsErrorMsg::GetErrorText ( ) const [inline]

const MsgMetaData & SsErrorMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& SsErrorMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:03:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsErrReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsErrReqArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsErrReqArg:

[legend]
Collaboration diagram for SsErrReqArg:

[legend]

Public Types

enum | { ID = 2003 }

Public Member Functions

const SsErrorCode & | GetErrorCode () const
const Tipd & | GetTipd () const
void | SetErrorCode (const SsErrorCode &error_code)
void | SetTipd (const Tipd &tipd)
SsErrReqArg ()
SsErrReqArg (const Tipd &tipd, const SsErrorCode &error_code)

Static Public Member Functions

static const SsErrReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsErrReqArg: reflects arguments of signal MN_SS_ERR_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsErrReqArg::SsErrReqArg | ( | const Tipd & | tipd,
 |  | const SsErrorCode & | error_code
 | ) |

SsErrReqArg::SsErrReqArg ( )

Member Function Documentation

const SsErrReqArg & SsErrReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SsErrorCode& SsErrReqArg::GetErrorCode ( void ) const [inline]

const Tipd& SsErrReqArg::GetTipd ( ) const [inline]

void SsErrReqArg::SetErrorCode ( const SsErrorCode & error_code ) [inline]

void SsErrReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsFacilityIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsFacilityIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsFacilityIndArg:

[legend]
Collaboration diagram for SsFacilityIndArg:

[legend]

Public Types

enum | { ID = 1029 }

Public Member Functions

const SimAlphaIdentifier & | GetAlphaIdentifier () const
const SimCallControlResult & | GetCallControlResult () const
const WString & | GetSsSequence () const
const Tipd & | GetTipd () const
BOOLEAN | IsCallControlPerformed () const
void | SetAlphaIdentifier (const SimAlphaIdentifier &alpha_identifier)
void | SetCallControlPerformed (BOOLEAN call_control_performed)
void | SetCallControlResult (const SimCallControlResult &call_control_result)
void | SetSsSequence (const WString &ss_sequence)
void | SetTipd (const Tipd &tipd)
SsFacilityIndArg ()

Static Public Member Functions

static const SsFacilityIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsFacilityIndArg: reflects arguments of signal MN_SS_FACILITY_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsFacilityIndArg::SsFacilityIndArg ( )

Member Function Documentation

const SsFacilityIndArg & SsFacilityIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimAlphaIdentifier& SsFacilityIndArg::GetAlphaIdentifier ( ) const [inline]

const SimCallControlResult& SsFacilityIndArg::GetCallControlResult ( ) const [inline]

const WString& SsFacilityIndArg::GetSsSequence ( ) const [inline]

const Tipd& SsFacilityIndArg::GetTipd ( ) const [inline]

BOOLEAN SsFacilityIndArg::IsCallControlPerformed ( ) const [inline]

void SsFacilityIndArg::SetAlphaIdentifier ( const SimAlphaIdentifier & alpha_identifier ) [inline]

void SsFacilityIndArg::SetCallControlPerformed ( BOOLEAN call_control_performed ) [inline]

void SsFacilityIndArg::SetCallControlResult ( const SimCallControlResult & call_control_result ) [inline]

void SsFacilityIndArg::SetSsSequence ( const WString & ss_sequence ) [inline]

void SsFacilityIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsFacilityRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsFacilityRejArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsFacilityRejArg:

[legend]
Collaboration diagram for SsFacilityRejArg:

[legend]

Public Types

enum | { ID = 1001 }

Public Member Functions

const MnCause & | GetRejectCause () const
void | SetRejectCause (const MnCause &reject_cause)
SsFacilityRejArg ()

Static Public Member Functions

static const SsFacilityRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsFacilityRejArg: reflects arguments of signal MN_SS_FACILITY_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsFacilityRejArg::SsFacilityRejArg ( )

Member Function Documentation

const SsFacilityRejArg & SsFacilityRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MnCause& SsFacilityRejArg::GetRejectCause ( ) const [inline]

void SsFacilityRejArg::SetRejectCause ( const MnCause & reject_cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsFacilityRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsFacilityRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsFacilityRejectedMsg:

[legend]
Collaboration diagram for SsFacilityRejectedMsg:

[legend]

Public Types

enum | { ID = 18516 }

Public Member Functions

virtual Message * | Clone () const
const MnCause & | GetCause () const
virtual const MsgMetaData & | GetMetaData () const
void | SetCause (const MnCause &cause)
SsFacilityRejectedMsg (ExecutionContext *context, const MnCause &cause)
virtual | ~SsFacilityRejectedMsg ()

Detailed Description

SsFacilityRejectedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsFacilityRejectedMsg::SsFacilityRejectedMsg | ( | ExecutionContext * | context,
 |  | const MnCause & | cause
 | ) |

SsFacilityRejectedMsg::~SsFacilityRejectedMsg ( ) [virtual]

Member Function Documentation

Message * SsFacilityRejectedMsg::Clone ( ) const [virtual]

Implements Message.

const MnCause& SsFacilityRejectedMsg::GetCause ( ) const [inline]

const MsgMetaData & SsFacilityRejectedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SsFacilityRejectedMsg::SetCause ( const MnCause & cause ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:03:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsForwardingIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsForwardingIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsForwardingIndArg:

[legend]
Collaboration diagram for SsForwardingIndArg:

[legend]

Public Types

enum | { ID = 1002 }

Public Member Functions

const ForwardingInfo & | GetForwardingInfo () const
const SsOperationCode & | GetOperationCode () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetForwardingInfo (const ForwardingInfo &forwarding_info)
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetTipd (const Tipd &tipd)
SsForwardingIndArg ()

Static Public Member Functions

static const SsForwardingIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsForwardingIndArg: reflects arguments of signal MN_SS_FORWARDING_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsForwardingIndArg::SsForwardingIndArg ( )

Member Function Documentation

const SsForwardingIndArg & SsForwardingIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const ForwardingInfo& SsForwardingIndArg::GetForwardingInfo ( ) const [inline]

const SsOperationCode& SsForwardingIndArg::GetOperationCode ( ) const [inline]

const Tipd& SsForwardingIndArg::GetTipd ( ) const [inline]

BOOLEAN SsForwardingIndArg::IsReleaseComplete ( ) const [inline]

void SsForwardingIndArg::SetForwardingInfo ( const ForwardingInfo & forwarding_info ) [inline]

void SsForwardingIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsForwardingIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsForwardingIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsForwcheckIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsForwcheckIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsForwcheckIndArg:

[legend]
Collaboration diagram for SsForwcheckIndArg:

[legend]

Public Types

enum | { ID = 1009 }

Public Member Functions

const SsOperationCode & | GetOperationCode () const
const Tipd & | GetTipd () const
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetTipd (const Tipd &tipd)
SsForwcheckIndArg ()

Static Public Member Functions

static const SsForwcheckIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsForwcheckIndArg: reflects arguments of signal MN_SS_FORWCHECK_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsForwcheckIndArg::SsForwcheckIndArg ( )

Member Function Documentation

const SsForwcheckIndArg & SsForwcheckIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SsOperationCode& SsForwcheckIndArg::GetOperationCode ( ) const [inline]

const Tipd& SsForwcheckIndArg::GetTipd ( ) const [inline]

void SsForwcheckIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsForwcheckIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsGetPasswordIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsGetPasswordIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsGetPasswordIndArg:

[legend]
Collaboration diagram for SsGetPasswordIndArg:

[legend]

Public Types

enum | { ID = 1014 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsGetPasswordIndArg ()

Static Public Member Functions

static const SsGetPasswordIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsDataIndArg: reflects arguments of signal MN_SS_GET_PASSWORD_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsGetPasswordIndArg::SsGetPasswordIndArg ( )

Member Function Documentation

const SsGetPasswordIndArg & SsGetPasswordIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsGetPasswordIndArg::GetTipd ( ) const [inline]

void SsGetPasswordIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsGetPasswordRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsGetPasswordRejArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsGetPasswordRejArg:

[legend]
Collaboration diagram for SsGetPasswordRejArg:

[legend]

Public Types

enum | { ID = 1015 }

Public Member Functions

const MnCause & | GetRejectCause () const
const Tipd & | GetTipd () const
void | SetRejectCause (const MnCause &reject_cause)
void | SetTipd (const Tipd &tipd)
SsGetPasswordRejArg ()

Static Public Member Functions

static const SsGetPasswordRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsGetPasswordRejArg: reflects arguments of signal MN_SS_GET_PASSWORD_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsGetPasswordRejArg::SsGetPasswordRejArg ( )

Member Function Documentation

const SsGetPasswordRejArg & SsGetPasswordRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const MnCause& SsGetPasswordRejArg::GetRejectCause ( ) const [inline]

const Tipd& SsGetPasswordRejArg::GetTipd ( ) const [inline]

void SsGetPasswordRejArg::SetRejectCause ( const MnCause & reject_cause ) [inline]

void SsGetPasswordRejArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsGetPasswordRspArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsGetPasswordRspArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsGetPasswordRspArg:

[legend]
Collaboration diagram for SsGetPasswordRspArg:

[legend]

Public Types

enum | { ID = 2002 }

Public Member Functions

const WString & | GetPassword () const
const Tipd & | GetTipd () const
void | SetPassword (const WString &password)
void | SetTipd (const Tipd &tipd)
SsGetPasswordRspArg ()
SsGetPasswordRspArg (const Tipd &tipd, const WString &password)

Static Public Member Functions

static const SsGetPasswordRspArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsGetPasswordRspArg: reflects arguments of signal MN_SS_GET_PASSWORD_RSP

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsGetPasswordRspArg::SsGetPasswordRspArg | ( | const Tipd & | tipd,
 |  | const WString & | password
 | ) |

SsGetPasswordRspArg::SsGetPasswordRspArg ( )

Member Function Documentation

const SsGetPasswordRspArg & SsGetPasswordRspArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& SsGetPasswordRspArg::GetPassword ( ) const [inline]

const Tipd& SsGetPasswordRspArg::GetTipd ( ) const [inline]

void SsGetPasswordRspArg::SetPassword ( const WString & password ) [inline]

void SsGetPasswordRspArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsGroup Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsGroup Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

SsInd ind
BOOLEAN present
ServiceGroup value

Field Documentation

SsInd SsGroup::ind

BOOLEAN SsGroup::present

ServiceGroup SsGroup::value

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:03:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsGroupList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsGroupList Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for SsGroupList:

[legend]

Data Fields

SsGroup data [c_max_no_basic_service_groups]

Field Documentation

SsGroup SsGroupList::data[c_max_no_basic_service_groups]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:03:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsHandler Class Reference
[APOXI Stack Control]

#include <Apoxi/Compat/SsHandler.hpp>

Collaboration diagram for SsHandler:

[legend]

Public Types

enum | { ID = SsHandlerId }

Public Member Functions

SsApiRc | ActivateCallBarring (const InputParser::SsCode code, const WString &pw, const InputParser::BasicServiceMmiCode bs=InputParser::AllServices) const
SsApiRc | ActivateCallForwarding (const InputParser::SsCode code, const WString &forward_to_no, const InputParser::BasicServiceMmiCode bs=InputParser::AllServices) const
SsApiRc | ActivateCallForwarding (const InputParser::SsCode code, const PhoneNumber &forward_to_no, const InputParser::BasicServiceMmiCode bs=InputParser::AllServices, const WString &time=L"") const
SsApiRc | ActivateCallWaiting (const InputParser::BasicServiceMmiCode bs=InputParser::AllServices) const
SsApiRc | ChangePin (const WString &old_pin, const WString &new_pin) const
SsApiRc | ChangePin2 (const WString &old_pin2, const WString &new_pin2) const
SsApiRc | DeactivateCallBarring (const InputParser::SsCode code, const WString &pw, const InputParser::BasicServiceMmiCode bs=InputParser::AllServices) const
SsApiRc | DeactivateCallForwarding (const InputParser::SsCode code, const InputParser::BasicServiceMmiCode bs=InputParser::AllServices) const
SsApiRc | DeactivateCallWaiting (const InputParser::BasicServiceMmiCode bs=InputParser::AllServices) const
SsApiRc | GetCallBarringStatus (const InputParser::SsCode code) const
SsApiRc | GetCallForwardingStatus (const InputParser::SsCode code, const InputParser::BasicServiceMmiCode bs=InputParser::AllServices) const
SsApiRc | GetCallWaitingStatus () const
SsApiRc | GetClipStatus () const
SsApiRc | GetClirStatus () const
SsApiRc | GetColpStatus () const
SsApiRc | GetColrStatus () const
virtual HandlerId | GetHandlerId () const
SsApiRc | InterrogateClip () const
SsApiRc | InterrogateClir () const
SsApiRc | InterrogateColp () const
SsApiRc | InterrogateColr () const
BOOLEAN | IsSsPending () const
SsApiRc | RegisterNewPw (const WString &old_pw, const WString &new_pw) const
SsApiRc | RejectUssdRequest (const TaggedProblemCode::ProblemCode code=TaggedProblemCode::ResourceLimitation) const
SsApiRc | SendControlString (const WCHAR *code) const
SsApiRc | SendControlString (const WString &code) const
SsApiRc | SendDetectedError (const SsErrorCode::Code error_code) const
SsApiRc | SendPasswordResponse (const WString &password) const
SsApiRc | SendUssdReturnResult (SsOperationCode code, const WString &result) const
SsHandler ()
SsApiRc | TerminateSupplementaryService () const
virtual | ~SsHandler ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsHandler::SsHandler ( )

SsHandler::~SsHandler ( ) [virtual]

Member Function Documentation

SsApiRc SsHandler::ActivateCallBarring | ( | const InputParser::SsCode | code,
 |  | const WString & | pw,
 |  | const InputParser::BasicServiceMmiCode | bs = InputParser::AllServices
 | ) | const

Activates a specific call barring feature defined by the supplementary service code, for one or more (all) basic services.

Parameters:
code | See ActivateCallForwarding.
pw | A password, required for any call barring action. bs See ActivateCallForwarding.
Returns:
See SendControlString(...).

SsApiRc SsHandler::ActivateCallForwarding | ( | const InputParser::SsCode | code,
 |  | const WString & | forward_to_no,
 |  | const InputParser::BasicServiceMmiCode | bs = InputParser::AllServices
 | ) | const [inline]

SsApiRc SsHandler::ActivateCallForwarding | ( | const InputParser::SsCode | code,
 |  | const PhoneNumber & | forward_to_no,
 |  | const InputParser::BasicServiceMmiCode | bs = InputParser::AllServices,
 |  | const WString & | time = L""
 | ) | const

Activates a specific call forwarding feature defined by the supplementary service code, for one or all basic services.

Parameters:
code | Defines the supplementary service CFU, CFBusy, CFNoReply, CFNotReachable, AllCF or AllConditionalCF.
forward_to_no | The phone number where the call is fowarded to.
bs | Defines the basic service which is AllServices, AllTeleServices, Telephony, AllDataServices, FacsimileServices, ShortMessageServices, AllTeleServicesExceptSMS, VoiceGroupCallService, VoiceBroadcastService, AllBearerServices, AllAsyncServices, AllSyncServices, AllDataCircuitSync, AllDataCircuitAsync,AllGPRSBearerServices.
time | Defines the time for that a "CFNoReply" call is waiting until the call will be forwarded This param is just possible for CFNoReply, AllCF or AllConditionalCF but it is not necessary.

SsApiRc SsHandler::ActivateCallWaiting ( const InputParser::BasicServiceMmiCode bs = InputParser::AllServices ) const

Activates the Call Waiting feature for the selected basic service.

Parameters:
bs Defines the basic service for which the Call Waiting is activated. If omitted, all basic serivces are used.
Returns:
See SendControlString(...).

SsApiRc SsHandler::ChangePin | ( | const WString & | old_pin,
 |  | const WString & | new_pin
 | ) | const

Changes the PIN on the SIM.

Parameters:
old_pin | The previously valid PIN.
new_pin | The new PIN.
Returns:
See SendControlString(...).

SsApiRc SsHandler::ChangePin2 | ( | const WString & | old_pin2,
 |  | const WString & | new_pin2
 | ) | const

Changes PIN2 on the SIM.

Parameters:
old_pin2 | The previously valid PIN2.
new_pin2 | The new PIN2.
Returns:
See SendControlString(...).

SsApiRc SsHandler::DeactivateCallBarring | ( | const InputParser::SsCode | code,
 |  | const WString & | pw,
 |  | const InputParser::BasicServiceMmiCode | bs = InputParser::AllServices
 | ) | const

Deactivates a specific call barring feature defined by the supplementary service code, for one ore more (all) basic services.

Parameters:
code | See ActivateCallForwarding.
pw | A password, required for any call barring action.
bs | See ActivateCallForwarding.
Returns:
See SendControlString(...).

SsApiRc SsHandler::DeactivateCallForwarding | ( | const InputParser::SsCode | code,
 |  | const InputParser::BasicServiceMmiCode | bs = InputParser::AllServices
 | ) | const

Deactivates a specific call forwarding feature defined by the supplementary service code, for one or all basic services.

Parameters:
code | See ActivateCallForwarding.
bs | See ActivateCallForwarding.
Returns:
See SendControlString(...).

SsApiRc SsHandler::DeactivateCallWaiting ( const InputParser::BasicServiceMmiCode bs = InputParser::AllServices ) const

Deactivates the Call Waiting feature for the selected basic service.

Parameters:
bs Defines the basic service for which the Call Waiting is deactivated. If omitted, the deactivation refers to all basic serivces.
Returns:
See SendControlString(...).

SsApiRc SsHandler::GetCallBarringStatus ( const InputParser::SsCode code ) const

Interrogates the current status of the call barring feature for all basic services.

Parameters:
code See ActivateCallForwarding.
Returns:
See SendControlString(...).

SsApiRc SsHandler::GetCallForwardingStatus | ( | const InputParser::SsCode | code,
 |  | const InputParser::BasicServiceMmiCode | bs = InputParser::AllServices
 | ) | const

Interrogates the current status of the call forwarding feature for one or all basic services.

Parameters:
code | See ActivateCallForwarding.
bs | See ActivateCallForwarding.
Returns:
See SendControlString(...).

SsApiRc SsHandler::GetCallWaitingStatus ( ) const

Interrogates the current status of the Call Waiting feature.

Returns:
See SendControlString(...).

SsApiRc SsHandler::GetClipStatus ( ) const

Interrogates the current CLIP state of the network.

Returns:
See SendControlString(...).

SsApiRc SsHandler::GetClirStatus ( ) const

Interrogates the current CLIR state of the network.

Returns:
See SendControlString(...).

SsApiRc SsHandler::GetColpStatus ( ) const

Interrogates the current COLP state of the network.

Returns:
See SendControlString(...).

SsApiRc SsHandler::GetColrStatus ( ) const

Interrogate the current COLE state of the network.

Returns:
See SendControlString(...).

HandlerId SsHandler::GetHandlerId ( ) const [virtual]

SsApiRc SsHandler::InterrogateClip ( ) const [inline]

SsApiRc SsHandler::InterrogateClir ( ) const [inline]

SsApiRc SsHandler::InterrogateColp ( ) const [inline]

SsApiRc SsHandler::InterrogateColr ( ) const [inline]

BOOLEAN SsHandler::IsSsPending ( ) const

Returns TRUE if a supplementary service transaction is currently pending, FALSE otherwise.

Returns:
Success - if MN accepted supplementary service request, SupplementaryServicePending if another supplementary service is currently pending, SupplementaryServiceDenied if the supplementary service request was rejected by MN.

SsApiRc SsHandler::RegisterNewPw | ( | const WString & | old_pw,
 |  | const WString & | new_pw
 | ) | const

Registers a new password which is required for all call barring activities.

Parameters:
old_pw | The previously valid password.
new_pw | The new password.
Returns:
See SendControlString(...).

SsApiRc SsHandler::RejectUssdRequest ( const TaggedProblemCode::ProblemCode code = TaggedProblemCode::ResourceLimitation ) const

SsApiRc SsHandler::SendControlString ( const WCHAR * code ) const

See SendControlString before. Avoids obsolete implicit WString constructor calls if called with L"code".

SsApiRc SsHandler::SendControlString ( const WString & code ) const

Sends a supplementary service control string to the network. and (actively) waits until MN accepts or rejects the request. The string format has to be as defined in GSM 2.30 (e.g. #31# for CLIR interrogation).

Parameters:
code WString, conform to GSM 2.30 denoting the supplementary service request.
Returns:
Success - if MN accepted supplementary service request, SupplementaryServicePending if another supplementary service is currently pending, SupplementaryServiceDenied if the supplementary service request was rejected by MN.

SsApiRc SsHandler::SendDetectedError ( const SsErrorCode::Code error_code ) const

Sends an error code to the network in order to indicate, that the USS request or -notify cannot be handeled correctly by the MS,

Returns:
Success - if successfully canceled, SupplementaryServiceNotPending, if no pending supplementary service request found, InvalidTipd if referred request has an invalid TIPD

SsApiRc SsHandler::SendPasswordResponse ( const WString & password ) const

Sends a required password to the network, after the network requested for it with a PasswordInquiryMsg. This happens for example during the execution of a supplemntary service related to call barring.

Returns:
Success - if successfully canceled, SupplementaryServiceNotPending, if no pending supplementary service request found, InvalidTipd if referred request has an invalid TIPD

SsApiRc SsHandler::SendUssdReturnResult | ( | SsOperationCode | code,
 |  | const WString & | result
 | ) | const

SsApiRc SsHandler::TerminateSupplementaryService ( ) const

Cancels a sent supplementary service request.

Returns:
Success - if successfully canceled, SupplementaryServiceNotPending, if no pending supplementary service request found, InvalidTipd if referred request has an invalid TIPD

The documentation for this class was generated from the following files:
  • Compat/SsHandler.hpp
  • Compat/SsHandler.cpp
Generated on Wed Jan 25 02:03:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsInfoMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsInfoMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsInfoMsg:

[legend]
Collaboration diagram for SsInfoMsg:

[legend]

Public Types

enum | { ID = 18573 }

Public Member Functions

virtual Message * | Clone () const
const SimAlphaIdentifier & | GetAlphaIdentifier () const
const SimCallControlResult & | GetCallControlResult () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetSsSequence () const
const Tipd & | GetTipd () const
BOOLEAN | IsCallControlPerformed () const
void | SetAlphaIdentifier (const SimAlphaIdentifier &alpha_identifier)
void | SetCallControlPerformed (BOOLEAN call_control_performed)
void | SetCallControlResult (const SimCallControlResult &call_control_result)
void | SetSsSequence (const WString &ss_sequence)
void | SetTipd (const Tipd &tipd)
SsInfoMsg (ExecutionContext *context, const Tipd &tipd, const WString &ss_sequence, BOOLEAN call_control_performed, const SimCallControlResult &call_control_result, const SimAlphaIdentifier &alpha_identifier)
virtual | ~SsInfoMsg ()

Detailed Description

SsInfoMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsInfoMsg::SsInfoMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const WString & | ss_sequence,
 |  | BOOLEAN | call_control_performed,
 |  | const SimCallControlResult & | call_control_result,
 |  | const SimAlphaIdentifier & | alpha_identifier
 | ) |

SsInfoMsg::~SsInfoMsg ( ) [virtual]

Member Function Documentation

Message * SsInfoMsg::Clone ( ) const [virtual]

Implements Message.

const SimAlphaIdentifier& SsInfoMsg::GetAlphaIdentifier ( ) const [inline]

const SimCallControlResult& SsInfoMsg::GetCallControlResult ( ) const [inline]

const MsgMetaData & SsInfoMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const WString& SsInfoMsg::GetSsSequence ( ) const [inline]

const Tipd& SsInfoMsg::GetTipd ( ) const [inline]

BOOLEAN SsInfoMsg::IsCallControlPerformed ( ) const [inline]

void SsInfoMsg::SetAlphaIdentifier ( const SimAlphaIdentifier & alpha_identifier ) [inline]

void SsInfoMsg::SetCallControlPerformed ( BOOLEAN call_control_performed ) [inline]

void SsInfoMsg::SetCallControlResult ( const SimCallControlResult & call_control_result ) [inline]

void SsInfoMsg::SetSsSequence ( const WString & ss_sequence ) [inline]

void SsInfoMsg::SetTipd ( const Tipd & tipd ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:03:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsInterrogateIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsInterrogateIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsInterrogateIndArg:

[legend]
Collaboration diagram for SsInterrogateIndArg:

[legend]

Public Types

enum | { ID = 1006 }

Public Member Functions

const SsOperationCode & | GetOperationCode () const
const InterrogateSsResult & | GetResult () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetResult (const InterrogateSsResult &result)
void | SetTipd (const Tipd &tipd)
SsInterrogateIndArg ()

Static Public Member Functions

static const SsInterrogateIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsInterrogateIndArg: reflects arguments of signal MN_SS_INTERROGATE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsInterrogateIndArg::SsInterrogateIndArg ( )

Member Function Documentation

const SsInterrogateIndArg & SsInterrogateIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SsOperationCode& SsInterrogateIndArg::GetOperationCode ( ) const [inline]

const InterrogateSsResult& SsInterrogateIndArg::GetResult ( ) const [inline]

const Tipd& SsInterrogateIndArg::GetTipd ( ) const [inline]

BOOLEAN SsInterrogateIndArg::IsReleaseComplete ( ) const [inline]

void SsInterrogateIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsInterrogateIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsInterrogateIndArg::SetResult ( const InterrogateSsResult & result ) [inline]

void SsInterrogateIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsMessage Class Reference

#include <Apoxi/Asc/SsMessage.hpp>

Inheritance diagram for SsMessage:

[legend]
Collaboration diagram for SsMessage:

[legend]

Public Types

enum | { ID = 18499 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SsMessage (ExecutionContext *context)
virtual | ~SsMessage ()

Detailed Description

SsMessage

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsMessage::SsMessage ( ExecutionContext * context )

SsMessage::~SsMessage ( ) [virtual]

Member Function Documentation

Message * SsMessage::Clone ( ) const [virtual]

Implements Message.

Reimplemented in SsRequestSentMsg, SsRequestAcceptedMsg, SsRequestRejectedMsg, CallWaitingActivatedMsg, CallWaitingDeactivatedMsg, CallWaitingStatusMsg, EmlppRegisteredMsg, EmlppStatusMsg, NetworkSsErrorMsg, NetworkSsRejectedMsg, StackSsRejectedMsg, ClirNotSurpressedMsg, CallForwardingActiveMsg, CallHeldMsg, CallRetrievedMsg, CallIsWaitingMsg, CallBarredMsg, ForwardedCallIncomingMsg, HlrDataCorruptedMsg, CugCallMsg, OutgoingCallForwardedMsg, IncomingCallForwardedMsg, MultiPartyCallInvokedMsg, EctActiveMsg, EctAlertingMsg, CnapInfoReceivedMsg, CallForwardingActivatedMsg, CallForwardingDeactivatedMsg, CallForwardingStatusMsg, CallForwardingRegisteredMsg, CallForwardingErasedMsg, CallBarringActivatedMsg, CallBarringDeactivatedMsg, CallBarringStatusMsg, ClipStatusMsg, ColpStatusMsg, ColrStatusMsg, CnapStatusMsg, ClirStatusMsg, CallBarringPasswordChangedMsg, SsErrorMsg, UssdRequestMsg, UssdNotifyMsg, UssdEndMsg, UssdDataMsg, UssdRequestResentMsg, GetPasswordMsg, UusStatusMsg, UusQueryRejectedMsg, UusNotificationMsg, UusRegisteredMsg, and UusErasedMsg.

const MsgMetaData & SsMessage::GetMetaData ( ) const [virtual]

Implements ContextMsg.

Reimplemented in SsRequestSentMsg, SsRequestAcceptedMsg, SsRequestRejectedMsg, CallWaitingActivatedMsg, CallWaitingDeactivatedMsg, CallWaitingStatusMsg, EmlppRegisteredMsg, EmlppStatusMsg, NetworkSsErrorMsg, NetworkSsRejectedMsg, StackSsRejectedMsg, ClirNotSurpressedMsg, CallForwardingActiveMsg, CallHeldMsg, CallRetrievedMsg, CallIsWaitingMsg, CallBarredMsg, ForwardedCallIncomingMsg, HlrDataCorruptedMsg, CugCallMsg, OutgoingCallForwardedMsg, IncomingCallForwardedMsg, MultiPartyCallInvokedMsg, EctActiveMsg, EctAlertingMsg, CnapInfoReceivedMsg, CallForwardingActivatedMsg, CallForwardingDeactivatedMsg, CallForwardingStatusMsg, CallForwardingRegisteredMsg, CallForwardingErasedMsg, CallBarringActivatedMsg, CallBarringDeactivatedMsg, CallBarringStatusMsg, ClipStatusMsg, ColpStatusMsg, ColrStatusMsg, CnapStatusMsg, ClirStatusMsg, CallBarringPasswordChangedMsg, SsErrorMsg, UssdRequestMsg, UssdNotifyMsg, UssdEndMsg, UssdDataMsg, UssdRequestResentMsg, GetPasswordMsg, UusStatusMsg, UusQueryRejectedMsg, UusNotificationMsg, UusRegisteredMsg, and UusErasedMsg.

The documentation for this class was generated from the following files:
  • Asc/SsMessage.hpp
  • Asc/SsMessage.cpp
Generated on Wed Jan 25 02:03:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsNotification Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsNotification Class Reference

Supplementary Service Status [GSM 09.02, 14.7.4]. More...

#include <Apoxi/Apc/SsNotification.hpp>

Public Member Functions

UINT8 | GetByte () const
Returns the byte representation of the problem tag.
BOOLEAN | IsForwardedToCallingSubscriber () const
BOOLEAN | IsForwardedToForwardedToSubscriber () const
BOOLEAN | IsForwardedToForwardingSubscriber () const
SsNotification (UINT8 incoming_byte=0)
Constructor of the class.

Detailed Description

Supplementary Service Status [GSM 09.02, 14.7.4].

Constructor & Destructor Documentation

SsNotification::SsNotification ( UINT8 incoming_byte = 0 ) [inline]

Constructor of the class.

Member Function Documentation

UINT8 SsNotification::GetByte ( ) const [inline]

Returns the byte representation of the problem tag.

BOOLEAN SsNotification::IsForwardedToCallingSubscriber ( ) const [inline]

BOOLEAN SsNotification::IsForwardedToForwardedToSubscriber ( ) const [inline]

BOOLEAN SsNotification::IsForwardedToForwardingSubscriber ( ) const [inline]

The documentation for this class was generated from the following file:
  • Apc/SsNotification.hpp
Generated on Wed Jan 25 02:03:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsNotificationArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsNotificationArg Struct Reference
[APOXI Stack Control]

Indication of an executed supplementary service (also remote). More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for SsNotificationArg:

[legend]

Data Fields

NotifySsArg notify_arg
Contains the notification data.
SsOperationCode operation_code
The respective call independent supplementary operation code.

Detailed Description

Indication of an executed supplementary service (also remote).

Field Documentation

NotifySsArg SsNotificationArg::notify_arg

Contains the notification data.

SsOperationCode SsNotificationArg::operation_code

The respective call independent supplementary operation code.

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 02:03:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsNotificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsNotificationMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsNotificationMsg:

[legend]
Collaboration diagram for SsNotificationMsg:

[legend]

Public Types

enum | { ID = 18503 }

Public Member Functions

virtual Message * | Clone () const
const SsNotificationArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const SsNotificationArg &arg)
SsNotificationMsg (ExecutionContext *context, const SsNotificationArg &arg)
virtual | ~SsNotificationMsg ()

Detailed Description

SsNotificationMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsNotificationMsg::SsNotificationMsg | ( | ExecutionContext * | context,
 |  | const SsNotificationArg & | arg
 | ) |

SsNotificationMsg::~SsNotificationMsg ( ) [virtual]

Member Function Documentation

Message * SsNotificationMsg::Clone ( ) const [virtual]

Implements Message.

const SsNotificationArg& SsNotificationMsg::GetArg ( ) const [inline]

const MsgMetaData & SsNotificationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SsNotificationMsg::SetArg ( const SsNotificationArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:03:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsNotifyIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsNotifyIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsNotifyIndArg:

[legend]
Collaboration diagram for SsNotifyIndArg:

[legend]

Public Types

enum | { ID = 1005 }

Public Member Functions

const NotifySsArg & | GetNotifySsArg () const
const SsOperationCode & | GetSsOperationCode () const
const Tipd & | GetTipd () const
void | SetNotifySsArg (const NotifySsArg &notify_ss_arg)
void | SetSsOperationCode (const SsOperationCode &ss_operation_code)
void | SetTipd (const Tipd &tipd)
SsNotifyIndArg ()

Static Public Member Functions

static const SsNotifyIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsNotifyIndArg: reflects arguments of signal MN_SS_NOTIFYSS_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsNotifyIndArg::SsNotifyIndArg ( )

Member Function Documentation

const SsNotifyIndArg & SsNotifyIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const NotifySsArg& SsNotifyIndArg::GetNotifySsArg ( ) const [inline]

const SsOperationCode& SsNotifyIndArg::GetSsOperationCode ( ) const [inline]

const Tipd& SsNotifyIndArg::GetTipd ( ) const [inline]

void SsNotifyIndArg::SetNotifySsArg ( const NotifySsArg & notify_ss_arg ) [inline]

void SsNotifyIndArg::SetSsOperationCode ( const SsOperationCode & ss_operation_code ) [inline]

void SsNotifyIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsPasswordChangeActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsPasswordChangeActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsPasswordChangeActionImpl:

[legend]
Collaboration diagram for SsPasswordChangeActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE)
SsPasswordChangeActionImpl ()
virtual | ~SsPasswordChangeActionImpl ()

Constructor & Destructor Documentation

SsPasswordChangeActionImpl::SsPasswordChangeActionImpl ( )

SsPasswordChangeActionImpl::~SsPasswordChangeActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsPasswordChangeActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsPasswordChangeActionImpl::Init ( BOOLEAN registerOnly = FALSE ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:03:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsPasswordIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsPasswordIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsPasswordIndArg:

[legend]
Collaboration diagram for SsPasswordIndArg:

[legend]

Public Types

enum | { ID = 1007 }

Public Member Functions

const SsOperationCode & | GetOperationCode () const
const WString & | GetPassword () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetPassword (const WString &password)
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetTipd (const Tipd &tipd)
SsPasswordIndArg ()

Static Public Member Functions

static const SsPasswordIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsPasswordIndArg: reflects arguments of signal MN_SS_PASSWORD_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsPasswordIndArg::SsPasswordIndArg ( )

Member Function Documentation

const SsPasswordIndArg & SsPasswordIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SsOperationCode& SsPasswordIndArg::GetOperationCode ( ) const [inline]

const WString& SsPasswordIndArg::GetPassword ( ) const [inline]

const Tipd& SsPasswordIndArg::GetTipd ( ) const [inline]

BOOLEAN SsPasswordIndArg::IsReleaseComplete ( ) const [inline]

void SsPasswordIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsPasswordIndArg::SetPassword ( const WString & password ) [inline]

void SsPasswordIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsPasswordIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsRejArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsRejArg:

[legend]
Collaboration diagram for SsRejArg:

[legend]

Public Types

enum | { ID = 1012 }

Public Member Functions

const TaggedProblemCode & | GetTaggedProblemCode () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetTaggedProblemCode (const TaggedProblemCode &tagged_problem_code)
void | SetTipd (const Tipd &tipd)
SsRejArg ()

Static Public Member Functions

static const SsRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsRejArg: reflects arguments of signal MN_SS_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsRejArg::SsRejArg ( )

Member Function Documentation

const SsRejArg & SsRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const TaggedProblemCode& SsRejArg::GetTaggedProblemCode ( ) const [inline]

const Tipd& SsRejArg::GetTipd ( ) const [inline]

BOOLEAN SsRejArg::IsReleaseComplete ( ) const [inline]

void SsRejArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsRejArg::SetTaggedProblemCode ( const TaggedProblemCode & tagged_problem_code ) [inline]

void SsRejArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsRejectedMsg:

[legend]
Collaboration diagram for SsRejectedMsg:

[legend]

Public Types

enum | { ID = 18510 }

Public Member Functions

virtual Message * | Clone () const
const TaggedProblemCode & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const TaggedProblemCode &arg)
SsRejectedMsg (ExecutionContext *context, const TaggedProblemCode &arg)
virtual | ~SsRejectedMsg ()

Detailed Description

SsRejectedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsRejectedMsg::SsRejectedMsg | ( | ExecutionContext * | context,
 |  | const TaggedProblemCode & | arg
 | ) |

SsRejectedMsg::~SsRejectedMsg ( ) [virtual]

Member Function Documentation

Message * SsRejectedMsg::Clone ( ) const [virtual]

Implements Message.

const TaggedProblemCode& SsRejectedMsg::GetArg ( ) const [inline]

const MsgMetaData & SsRejectedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void SsRejectedMsg::SetArg ( const TaggedProblemCode & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:03:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsRejReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsRejReqArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsRejReqArg:

[legend]
Collaboration diagram for SsRejReqArg:

[legend]

Public Types

enum | { ID = 2004 }

Public Member Functions

const TaggedProblemCode & | GetTaggedProblemCode () const
const Tipd & | GetTipd () const
void | SetTaggedProblemCode (const TaggedProblemCode &tagged_problem_code)
void | SetTipd (const Tipd &tipd)
SsRejReqArg ()
SsRejReqArg (const Tipd &tipd, const TaggedProblemCode &tagged_problem_code)

Static Public Member Functions

static const SsRejReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsRejReqArg: reflects arguments of signal MN_SS_REJ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsRejReqArg::SsRejReqArg | ( | const Tipd & | tipd,
 |  | const TaggedProblemCode & | tagged_problem_code
 | ) |

SsRejReqArg::SsRejReqArg ( )

Member Function Documentation

const SsRejReqArg & SsRejReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const TaggedProblemCode& SsRejReqArg::GetTaggedProblemCode ( ) const [inline]

const Tipd& SsRejReqArg::GetTipd ( ) const [inline]

void SsRejReqArg::SetTaggedProblemCode ( const TaggedProblemCode & tagged_problem_code ) [inline]

void SsRejReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:03:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsRequestAcceptedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsRequestAcceptedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsRequestAcceptedMsg:

[legend]
Collaboration diagram for SsRequestAcceptedMsg:

[legend]

Public Types

enum | { ID = 18517 }

Public Member Functions

virtual Message * | Clone () const
const ServiceGroup & | GetBasicService () const
virtual const MsgMetaData & | GetMetaData () const
const SsOperationCode & | GetOperationCode () const
const WString & | GetParameter1 () const
const WString & | GetParameter2 () const
const WString & | GetParameter3 () const
const SsCode & | GetSsCode () const
const WString & | GetSsControlSeq () const
const Tipd & | GetTipd () const
SsRequestAcceptedMsg (ExecutionContext *context, const Tipd &tipd, const SsCode &ss_code, const ServiceGroup &basic_service, const SsOperationCode &operation_code, const WString &parameter1, const WString &parameter2, const WString &parameter3, const WString &ss_control_seq)
virtual | ~SsRequestAcceptedMsg ()

Detailed Description

SsRequestSentMsg: sent if SS request was accepted by GSM stack

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsRequestAcceptedMsg::SsRequestAcceptedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsCode & | ss_code,
 |  | const ServiceGroup & | basic_service,
 |  | const SsOperationCode & | operation_code,
 |  | const WString & | parameter1,
 |  | const WString & | parameter2,
 |  | const WString & | parameter3,
 |  | const WString & | ss_control_seq
 | ) |

SsRequestAcceptedMsg::~SsRequestAcceptedMsg ( ) [virtual]

Member Function Documentation

Message * SsRequestAcceptedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& SsRequestAcceptedMsg::GetBasicService ( ) const [inline]

const MsgMetaData & SsRequestAcceptedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsOperationCode& SsRequestAcceptedMsg::GetOperationCode ( ) const [inline]

const WString& SsRequestAcceptedMsg::GetParameter1 ( ) const [inline]

const WString& SsRequestAcceptedMsg::GetParameter2 ( ) const [inline]

const WString& SsRequestAcceptedMsg::GetParameter3 ( ) const [inline]

const SsCode& SsRequestAcceptedMsg::GetSsCode ( ) const [inline]

const WString& SsRequestAcceptedMsg::GetSsControlSeq ( ) const [inline]

const Tipd& SsRequestAcceptedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:04:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsRequestRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsRequestRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsRequestRejectedMsg:

[legend]
Collaboration diagram for SsRequestRejectedMsg:

[legend]

Public Types

enum | { ID = 18518 }

Public Member Functions

virtual Message * | Clone () const
const ServiceGroup & | GetBasicService () const
const CallErrorCause & | GetCause () const
const SsApiRc & | GetErrorCode () const
virtual const MsgMetaData & | GetMetaData () const
const SsOperationCode & | GetOperationCode () const
const WString & | GetParameter1 () const
const WString & | GetParameter2 () const
const WString & | GetParameter3 () const
const SsCode & | GetSsCode () const
SsRequestRejectedMsg (ExecutionContext *context, const SsApiRc &error_code, const SsCode &ss_code, const ServiceGroup &basic_service, const SsOperationCode &operation_code, const WString &parameter1, const WString &parameter2, const WString &parameter3, const CallErrorCause &cause)
virtual | ~SsRequestRejectedMsg ()

Detailed Description

SsRequestRejectedMsg: sent if SS request was rejected

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsRequestRejectedMsg::SsRequestRejectedMsg | ( | ExecutionContext * | context,
 |  | const SsApiRc & | error_code,
 |  | const SsCode & | ss_code,
 |  | const ServiceGroup & | basic_service,
 |  | const SsOperationCode & | operation_code,
 |  | const WString & | parameter1,
 |  | const WString & | parameter2,
 |  | const WString & | parameter3,
 |  | const CallErrorCause & | cause
 | ) |

SsRequestRejectedMsg::~SsRequestRejectedMsg ( ) [virtual]

Member Function Documentation

Message * SsRequestRejectedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& SsRequestRejectedMsg::GetBasicService ( ) const [inline]

const CallErrorCause& SsRequestRejectedMsg::GetCause ( ) const [inline]

const SsApiRc& SsRequestRejectedMsg::GetErrorCode ( void ) const [inline]

const MsgMetaData & SsRequestRejectedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsOperationCode& SsRequestRejectedMsg::GetOperationCode ( ) const [inline]

const WString& SsRequestRejectedMsg::GetParameter1 ( ) const [inline]

const WString& SsRequestRejectedMsg::GetParameter2 ( ) const [inline]

const WString& SsRequestRejectedMsg::GetParameter3 ( ) const [inline]

const SsCode& SsRequestRejectedMsg::GetSsCode ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:04:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsRequestSentMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsRequestSentMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsRequestSentMsg:

[legend]
Collaboration diagram for SsRequestSentMsg:

[legend]

Public Types

enum | { ID = 18557 }

Public Member Functions

virtual Message * | Clone () const
const ServiceGroup & | GetBasicService () const
virtual const MsgMetaData & | GetMetaData () const
const SsOperationCode & | GetOperationCode () const
const WString & | GetParameter1 () const
const WString & | GetParameter2 () const
const WString & | GetParameter3 () const
const SsCode & | GetSsCode () const
const WString & | GetSsControlSeq () const
SsRequestSentMsg (ExecutionContext *context, const WString &ss_control_seq, const SsCode &ss_code, const ServiceGroup &basic_service, const SsOperationCode &operation_code, const WString &parameter1, const WString &parameter2, const WString &parameter3)
virtual | ~SsRequestSentMsg ()

Detailed Description

SsRequestSentMsg: sent if SS request was sent to GSM stack

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsRequestSentMsg::SsRequestSentMsg | ( | ExecutionContext * | context,
 |  | const WString & | ss_control_seq,
 |  | const SsCode & | ss_code,
 |  | const ServiceGroup & | basic_service,
 |  | const SsOperationCode & | operation_code,
 |  | const WString & | parameter1,
 |  | const WString & | parameter2,
 |  | const WString & | parameter3
 | ) |

SsRequestSentMsg::~SsRequestSentMsg ( ) [virtual]

Member Function Documentation

Message * SsRequestSentMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& SsRequestSentMsg::GetBasicService ( ) const [inline]

const MsgMetaData & SsRequestSentMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsOperationCode& SsRequestSentMsg::GetOperationCode ( ) const [inline]

const WString& SsRequestSentMsg::GetParameter1 ( ) const [inline]

const WString& SsRequestSentMsg::GetParameter2 ( ) const [inline]

const WString& SsRequestSentMsg::GetParameter3 ( ) const [inline]

const SsCode& SsRequestSentMsg::GetSsCode ( ) const [inline]

const WString& SsRequestSentMsg::GetSsControlSeq ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:04:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsRetResIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsRetResIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsRetResIndArg:

[legend]
Collaboration diagram for SsRetResIndArg:

[legend]

Public Types

enum | { ID = 1010 }

Public Member Functions

const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetTipd (const Tipd &tipd)
SsRetResIndArg ()

Static Public Member Functions

static const SsRetResIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsRetResIndArg: reflects arguments of signal MN_SS_RET_RES_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsRetResIndArg::SsRetResIndArg ( )

Member Function Documentation

const SsRetResIndArg & SsRetResIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsRetResIndArg::GetTipd ( ) const [inline]

BOOLEAN SsRetResIndArg::IsReleaseComplete ( ) const [inline]

void SsRetResIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsRetResIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsSendEndReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsSendEndReqArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsSendEndReqArg:

[legend]
Collaboration diagram for SsSendEndReqArg:

[legend]

Public Types

enum | { ID = 2001 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsSendEndReqArg ()
SsSendEndReqArg (const Tipd &tipd)

Static Public Member Functions

static const SsSendEndReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsSendReqArg: reflects arguments of signal MN_SS_END_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsSendEndReqArg::SsSendEndReqArg ( const Tipd & tipd )

SsSendEndReqArg::SsSendEndReqArg ( )

Member Function Documentation

const SsSendEndReqArg & SsSendEndReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsSendEndReqArg::GetTipd ( ) const [inline]

void SsSendEndReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsSendReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsSendReqArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsSendReqArg:

[legend]
Collaboration diagram for SsSendReqArg:

[legend]

Public Types

enum | { ID = 2000 }

Public Member Functions

const WString & | GetCtrlInfo () const
const Tipd & | GetTipd () const
void | SetCtrlInfo (const WString &ctrl_info)
void | SetTipd (const Tipd &tipd)
SsSendReqArg ()
SsSendReqArg (const Tipd &tipd, const WString &ctrl_info)

Static Public Member Functions

static const SsSendReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsSendReqArg: reflects arguments of signal MN_SS_FACILITY_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsSendReqArg::SsSendReqArg | ( | const Tipd & | tipd,
 |  | const WString & | ctrl_info
 | ) |

SsSendReqArg::SsSendReqArg ( )

Member Function Documentation

const SsSendReqArg & SsSendReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& SsSendReqArg::GetCtrlInfo ( ) const [inline]

const Tipd& SsSendReqArg::GetTipd ( ) const [inline]

void SsSendReqArg::SetCtrlInfo ( const WString & ctrl_info ) [inline]

void SsSendReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsStatus Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsStatus Class Reference

Supplementary Service Status [GSM 09.02, 14.7.4]. More...

#include <Apoxi/Apc/SsStatus.hpp>

Public Member Functions

UINT8 | GetByte () const
Returns the byte representation of the problem tag.
BOOLEAN | IsActivationBitSet () const
BOOLEAN | IsProvisionBitSet () const
BOOLEAN | IsQuiescentBitSet () const
BOOLEAN | IsRegistrationBitSet () const
SsStatus (UINT8 incoming_byte=0)
Constructor of the class.

Detailed Description

Supplementary Service Status [GSM 09.02, 14.7.4].

Constructor & Destructor Documentation

SsStatus::SsStatus ( UINT8 incoming_byte = 0 ) [inline]

Constructor of the class.

Member Function Documentation

UINT8 SsStatus::GetByte ( ) const [inline]

Returns the byte representation of the problem tag.

BOOLEAN SsStatus::IsActivationBitSet ( ) const [inline]

BOOLEAN SsStatus::IsProvisionBitSet ( ) const [inline]

BOOLEAN SsStatus::IsQuiescentBitSet ( ) const [inline]

BOOLEAN SsStatus::IsRegistrationBitSet ( ) const [inline]

The documentation for this class was generated from the following file:
  • Apc/SsStatus.hpp
Generated on Wed Jan 25 02:04:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsSuccessMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsSuccessMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for SsSuccessMsg:

[legend]
Collaboration diagram for SsSuccessMsg:

[legend]

Public Types

enum | { ID = 18508 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsArg () const
void | SetArg (BOOLEAN arg)
SsSuccessMsg (ExecutionContext *context, BOOLEAN arg)
virtual | ~SsSuccessMsg ()

Detailed Description

SsSuccessMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsSuccessMsg::SsSuccessMsg | ( | ExecutionContext * | context,
 |  | BOOLEAN | arg
 | ) |

SsSuccessMsg::~SsSuccessMsg ( ) [virtual]

Member Function Documentation

Message * SsSuccessMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SsSuccessMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BOOLEAN SsSuccessMsg::IsArg ( ) const [inline]

void SsSuccessMsg::SetArg ( BOOLEAN arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:04:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SstProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SstProvider Class Reference
[Provider]

#include <Apoxi/Adc/SstProvider.hpp>

Inheritance diagram for SstProvider:

[legend]
Collaboration diagram for SstProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init (SimAuxHandler *aux_handler, Protector *protector)
virtual INT | RowCount ()
RowCount returns the number of rows.
SstProvider ()
virtual BOOLEAN | Update (ProviderListener *listener=0)
Update makes the Provider ready to use and enables listener.
virtual | ~SstProvider ()

Member Typedef Documentation

typedef ThreadSafeProvider SstProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

SstProvider::SstProvider ( )

SstProvider::~SstProvider ( ) [virtual]

Member Function Documentation

BOOLEAN SstProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

INT SstProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

void SstProvider::Init | ( | SimAuxHandler * | aux_handler,
 |  | Protector * | protector
 | ) |

INT SstProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

BOOLEAN SstProvider::Update ( ProviderListener * listener = 0 ) [virtual]

Update makes the Provider ready to use and enables listener.

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Adc/SstProvider.hpp
  • Adc/SstProvider.cpp
Generated on Wed Jan 25 02:04:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUnstructIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUnstructIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUnstructIndArg:

[legend]
Collaboration diagram for SsUnstructIndArg:

[legend]

Public Types

enum | { ID = 1008 }

Public Member Functions

const WString & | GetCtrlInfoString () const
const DataCodingScheme & | GetDcs () const
const SsOperationCode & | GetOperationCode () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetCtrlInfoString (const WString &ctrl_info_string)
void | SetDcs (const DataCodingScheme &dcs)
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetTipd (const Tipd &tipd)
SsUnstructIndArg ()

Static Public Member Functions

static const SsUnstructIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUnstructIndArg: reflects arguments of signal MN_SS_UNSTRUCT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUnstructIndArg::SsUnstructIndArg ( )

Member Function Documentation

const SsUnstructIndArg & SsUnstructIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& SsUnstructIndArg::GetCtrlInfoString ( ) const [inline]

const DataCodingScheme& SsUnstructIndArg::GetDcs ( ) const [inline]

const SsOperationCode& SsUnstructIndArg::GetOperationCode ( ) const [inline]

const Tipd& SsUnstructIndArg::GetTipd ( ) const [inline]

BOOLEAN SsUnstructIndArg::IsReleaseComplete ( ) const [inline]

void SsUnstructIndArg::SetCtrlInfoString ( const WString & ctrl_info_string ) [inline]

void SsUnstructIndArg::SetDcs ( const DataCodingScheme & dcs ) [inline]

void SsUnstructIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsUnstructIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsUnstructIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUssdActionImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUssdActionImpl Class Reference
[SupplementaryServiceActions]

#include <Apoxi/Asc/SupplementaryServiceAction.hpp>

Inheritance diagram for SsUssdActionImpl:

[legend]
Collaboration diagram for SsUssdActionImpl:

[legend]

Public Member Functions

virtual BOOLEAN | Execute ()
Executes the InputAction object. This method always has to be overwritten !
void | Init (BOOLEAN registerOnly=FALSE)
SsUssdActionImpl ()
virtual | ~SsUssdActionImpl ()

Constructor & Destructor Documentation

SsUssdActionImpl::SsUssdActionImpl ( )

SsUssdActionImpl::~SsUssdActionImpl ( ) [virtual]

Member Function Documentation

BOOLEAN SsUssdActionImpl::Execute ( ) [virtual]

Executes the InputAction object. This method always has to be overwritten !

Reimplemented from InputAction.

void SsUssdActionImpl::Init ( BOOLEAN registerOnly = FALSE ) [inline]

The documentation for this class was generated from the following files:
  • Asc/SupplementaryServiceAction.hpp
  • Asc/SupplementaryServiceAction.cpp
Generated on Wed Jan 25 02:04:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUssdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUssdIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUssdIndArg:

[legend]
Collaboration diagram for SsUssdIndArg:

[legend]

Public Types

enum | { ID = 1016 }

Public Member Functions

const WString & | GetCtrlInfoString () const
const DataCodingScheme & | GetDcs () const
const SsOperationCode & | GetOperationCode () const
const Tipd & | GetTipd () const
BOOLEAN | IsReleaseComplete () const
void | SetCtrlInfoString (const WString &ctrl_info_string)
void | SetDcs (const DataCodingScheme &dcs)
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetReleaseComplete (BOOLEAN release_complete)
void | SetTipd (const Tipd &tipd)
SsUssdIndArg ()

Static Public Member Functions

static const SsUssdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUssdIndArg: reflects arguments of signal MN_SS_USSD_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUssdIndArg::SsUssdIndArg ( )

Member Function Documentation

const SsUssdIndArg & SsUssdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& SsUssdIndArg::GetCtrlInfoString ( ) const [inline]

const DataCodingScheme& SsUssdIndArg::GetDcs ( ) const [inline]

const SsOperationCode& SsUssdIndArg::GetOperationCode ( ) const [inline]

const Tipd& SsUssdIndArg::GetTipd ( ) const [inline]

BOOLEAN SsUssdIndArg::IsReleaseComplete ( ) const [inline]

void SsUssdIndArg::SetCtrlInfoString ( const WString & ctrl_info_string ) [inline]

void SsUssdIndArg::SetDcs ( const DataCodingScheme & dcs ) [inline]

void SsUssdIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsUssdIndArg::SetReleaseComplete ( BOOLEAN release_complete ) [inline]

void SsUssdIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUssdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUssdReqArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUssdReqArg:

[legend]
Collaboration diagram for SsUssdReqArg:

[legend]

Public Types

enum | { ID = 2005 }

Public Member Functions

const WString & | GetCtrlInfo () const
const SsOperationCode & | GetOperationCode () const
const Tipd & | GetTipd () const
void | SetCtrlInfo (const WString &ctrl_info)
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetTipd (const Tipd &tipd)
SsUssdReqArg ()
SsUssdReqArg (const Tipd &tipd, const SsOperationCode &operation_code, const WString &ctrl_info)

Static Public Member Functions

static const SsUssdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUssdReqArg: reflects arguments of signal MN_SS_USSD_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUssdReqArg::SsUssdReqArg | ( | const Tipd & | tipd,
 |  | const SsOperationCode & | operation_code,
 |  | const WString & | ctrl_info
 | ) |

SsUssdReqArg::SsUssdReqArg ( )

Member Function Documentation

const SsUssdReqArg & SsUssdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& SsUssdReqArg::GetCtrlInfo ( ) const [inline]

const SsOperationCode& SsUssdReqArg::GetOperationCode ( ) const [inline]

const Tipd& SsUssdReqArg::GetTipd ( ) const [inline]

void SsUssdReqArg::SetCtrlInfo ( const WString & ctrl_info ) [inline]

void SsUssdReqArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void SsUssdReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUssdResentIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUssdResentIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUssdResentIndArg:

[legend]
Collaboration diagram for SsUssdResentIndArg:

[legend]

Public Types

enum | { ID = 1017 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
SsUssdResentIndArg ()

Static Public Member Functions

static const SsUssdResentIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUssdResentIndArg: reflects arguments of signal MN_SS_USSD_RESENT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUssdResentIndArg::SsUssdResentIndArg ( )

Member Function Documentation

const SsUssdResentIndArg & SsUssdResentIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& SsUssdResentIndArg::GetTipd ( ) const [inline]

void SsUssdResentIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUus1IndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUus1IndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUus1IndArg:

[legend]
Collaboration diagram for SsUus1IndArg:

[legend]

Public Types

enum | { ID = 1028 }

Public Member Functions

const WString & | GetText () const
const UusInTextType & | GetType () const
void | SetText (const WString &text)
void | SetType (const UusInTextType &type)
SsUus1IndArg ()

Static Public Member Functions

static const SsUus1IndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUus1IndArg: reflects arguments of signal MN_UUS1_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUus1IndArg::SsUus1IndArg ( )

Member Function Documentation

const SsUus1IndArg & SsUus1IndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& SsUus1IndArg::GetText ( ) const [inline]

const UusInTextType& SsUus1IndArg::GetType ( ) const [inline]

void SsUus1IndArg::SetText ( const WString & text ) [inline]

void SsUus1IndArg::SetType ( const UusInTextType & type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUus1QueryIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUus1QueryIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUus1QueryIndArg:

[legend]
Collaboration diagram for SsUus1QueryIndArg:

[legend]

Public Types

enum | { ID = 1026 }

Public Member Functions

const Vector< UusText > & | GetTextList () const
void | SetTextList (const Vector< UusText > &text_list)
SsUus1QueryIndArg ()

Static Public Member Functions

static const SsUus1QueryIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUus1QueryIndArg: reflects arguments of signal MN_UUS1_QUERY_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUus1QueryIndArg::SsUus1QueryIndArg ( )

Member Function Documentation

const SsUus1QueryIndArg & SsUus1QueryIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Vector<UusText>& SsUus1QueryIndArg::GetTextList ( ) const [inline]

void SsUus1QueryIndArg::SetTextList ( const Vector< UusText > & text_list ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUus1QueryRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUus1QueryRejArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUus1QueryRejArg:

[legend]
Collaboration diagram for SsUus1QueryRejArg:

[legend]

Public Types

enum | { ID = 1027 }

Public Member Functions

SsUus1QueryRejArg ()

Static Public Member Functions

static const SsUus1QueryRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUus1QueryRejArg: reflects arguments of signal MN_UUS1_QUERY_REJ_ND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUus1QueryRejArg::SsUus1QueryRejArg ( )

Member Function Documentation

const SsUus1QueryRejArg & SsUus1QueryRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUus1QueryReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUus1QueryReqArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUus1QueryReqArg:

[legend]
Collaboration diagram for SsUus1QueryReqArg:

[legend]

Public Types

enum | { ID = 2035 }

Public Member Functions

SsUus1QueryReqArg ()

Static Public Member Functions

static const SsUus1QueryReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUus1Req reflects arguments of signal MN_UUS1_QUERY_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUus1QueryReqArg::SsUus1QueryReqArg ( )

Member Function Documentation

const SsUus1QueryReqArg & SsUus1QueryReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsUus1ReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsUus1ReqArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for SsUus1ReqArg:

[legend]
Collaboration diagram for SsUus1ReqArg:

[legend]

Public Types

enum | { ID = 2033 }

Public Member Functions

const WString & | GetText () const
const UusOutTextType & | GetType () const
void | SetText (const WString &text)
void | SetType (const UusOutTextType &type)
SsUus1ReqArg ()

Static Public Member Functions

static const SsUus1ReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

SsUus1Req reflects arguments of signal MN_UUS1_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SsUus1ReqArg::SsUus1ReqArg ( )

Member Function Documentation

const SsUus1ReqArg & SsUus1ReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& SsUus1ReqArg::GetText ( ) const [inline]

const UusOutTextType& SsUus1ReqArg::GetType ( ) const [inline]

void SsUus1ReqArg::SetText ( const WString & text ) [inline]

void SsUus1ReqArg::SetType ( const UusOutTextType & type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:04:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SsWaitDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SsWaitDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Compat/SsWaitDispatcher.hpp>

Inheritance diagram for SsWaitDispatcher:

[legend]
Collaboration diagram for SsWaitDispatcher:

[legend]

Public Member Functions

CallErrorCause GetCause ()
Tipd GetTipd ()
SsWaitDispatcher ()
BOOLEAN | WasChangedToMoc ()
BOOLEAN | WasRejected ()
virtual | ~SsWaitDispatcher ()

Protected Member Functions

BOOLEAN | OnCallControlIndMsg (const StackMsgArgument &arg)
BOOLEAN | OnSsBeginAcc (const StackMsgArgument &arg)
BOOLEAN | OnSsFacilityRej (const StackMsgArgument &arg)

Constructor & Destructor Documentation

SsWaitDispatcher::SsWaitDispatcher ( )

SsWaitDispatcher::~SsWaitDispatcher ( ) [virtual]

Member Function Documentation

CallErrorCause SsWaitDispatcher::GetCause ( ) [inline]

Tipd SsWaitDispatcher::GetTipd ( ) [inline]

BOOLEAN SsWaitDispatcher::OnCallControlIndMsg ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsWaitDispatcher::OnSsBeginAcc ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsWaitDispatcher::OnSsFacilityRej ( const StackMsgArgument & arg ) [protected]

BOOLEAN SsWaitDispatcher::WasChangedToMoc ( ) [inline]

BOOLEAN SsWaitDispatcher::WasRejected ( ) [inline]

The documentation for this class was generated from the following files:
  • Compat/SsWaitDispatcher.hpp
  • Compat/SsWaitDispatcher.cpp
Generated on Wed Jan 25 02:04:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackControl Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/StackControl.hpp>

Inheritance diagram for StackControl:

[legend]
Collaboration diagram for StackControl:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
virtual UINT8 | GetPriority () const
priority controls the init sequence of SubSystems
virtual BootSequenceState | InvokeAt () const
define the point of time when the StackControl should be invoked
virtual void | OnPowerDown ()
shuts down the StackControl sub-system
virtual void | OnPowerUp ()
starts up the StackControl sub-system
StackControl ()

Static Public Member Functions

static BaseHandler * | GetHandler (HandlerId id)
static StackControl * | GetInstance ()
static BOOLEAN | Subscribe (HandlerId id)
mounts the handler id to the system (for receiving asynchronous stack events)
static BOOLEAN | Unsubscribe (HandlerId id)
unmounts the handler id (no asynchronous stack events will be received)

Constructor & Destructor Documentation

StackControl::StackControl ( )

Member Function Documentation

BaseHandler * StackControl::GetHandler ( HandlerId id ) [static]

returns the handler of the given handler id (handler will be mounted, if it isn't available). ATTENTION: it is possible to get 0 as return value, if handler isn't accessible (e.g. due to a lock caused by an exclusiv handler like MtcVoiceHandler)

static StackControl* StackControl::GetInstance ( ) [inline, static]

virtual const WCHAR* StackControl::GetName ( ) const [inline, virtual]

Returns:
A meaningfull name for the sub-system.

Implements SubSystem.

virtual UINT8 StackControl::GetPriority ( ) const [inline, virtual]

priority controls the init sequence of SubSystems

Reimplemented from SubSystem.

virtual BootSequenceState StackControl::InvokeAt ( ) const [inline, virtual]

define the point of time when the StackControl should be invoked

Implements SubSystem.

void StackControl::OnPowerDown ( ) [virtual]

shuts down the StackControl sub-system

Reimplemented from SubSystem.

void StackControl::OnPowerUp ( ) [virtual]

starts up the StackControl sub-system

Reimplemented from SubSystem.

BOOLEAN StackControl::Subscribe ( HandlerId id ) [static]

mounts the handler id to the system (for receiving asynchronous stack events)

BOOLEAN StackControl::Unsubscribe ( HandlerId id ) [static]

unmounts the handler id (no asynchronous stack events will be received)

The documentation for this class was generated from the following files:
  • Asc/StackControl.hpp
  • Asc/StackControl.cpp
Generated on Wed Jan 25 02:04:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackInterface Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackInterface Class Reference

#include <Apoxi/Apc/StackInterface.hpp>

Static Public Member Functions

static void | Init ()
static BOOLEAN | IsFastSmsLoadingSupported ()
static BOOLEAN | IsGroupDeletionNotificationSupported ()

Detailed Description

StackInterface is a static class, which does the correct configuration and initialization of the interface for the used stack.

Member Function Documentation

void StackInterface::Init ( ) [static]

BOOLEAN StackInterface::IsFastSmsLoadingSupported ( ) [static]

BOOLEAN StackInterface::IsGroupDeletionNotificationSupported ( ) [static]

The documentation for this class was generated from the following files:
  • Apc/StackInterface.hpp
  • Apc/StackInterface.cpp
Generated on Wed Jan 25 02:04:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgActiveWaitDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgActiveWaitDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/StackMsgActiveWaitDispatcher.hpp>

Inheritance diagram for StackMsgActiveWaitDispatcher:

[legend]
Collaboration diagram for StackMsgActiveWaitDispatcher:

[legend]

Public Member Functions

void | Abort ()
virtual BOOLEAN | IsAborted ()
virtual void | Reset ()
StackMsgActiveWaitDispatcher (const AbstractStackMsgArgMapContainer *arg_map_container=0)
virtual | ~StackMsgActiveWaitDispatcher ()

Protected Member Functions

void | Init (const AbstractStackMsgArgMapContainer *arg_map_container)

Detailed Description

is a dispatcher which has implemented an active wait loop. To release the active wait, the method Done() must be called.

Constructor & Destructor Documentation

StackMsgActiveWaitDispatcher::StackMsgActiveWaitDispatcher ( const AbstractStackMsgArgMapContainer * arg_map_container = 0 )

Parameters:
msg_map The message map holds all messages, to which the dispatcher should listen to.

virtual StackMsgActiveWaitDispatcher::~StackMsgActiveWaitDispatcher ( ) [inline, virtual]

Member Function Documentation

void StackMsgActiveWaitDispatcher::Abort ( ) [inline]

This method is called from another dispatcher when a call's disconnection confirmation arrived. Then, the dispatcher will call Abort() from outside in order to indicate that the active wait loop was terminated due to a call's disconnect and actually terminates the dispatcher by calling Done().

void StackMsgActiveWaitDispatcher::Init ( const AbstractStackMsgArgMapContainer * arg_map_container ) [inline, protected]

virtual BOOLEAN StackMsgActiveWaitDispatcher::IsAborted ( ) [inline, virtual]

IsAborted() checks if the a call was disconnected while the active wait dispatcher was waiting for messages.

Returns:
TRUE - If the preemptive active wait dispatcher was terminated by the disconnection of the call.
FALSE - Otherwise.

void StackMsgActiveWaitDispatcher::Reset ( ) [virtual]

The documentation for this class was generated from the following files:
  • Asc/StackMsgActiveWaitDispatcher.hpp
  • Asc/StackMsgActiveWaitDispatcher.cpp
Generated on Wed Jan 25 02:04:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgArgDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgArgDestroyTableNode Class Reference

#include <Apoxi/Apc/StackMsgArgument.hpp>

Inheritance diagram for StackMsgArgDestroyTableNode:

[legend]
Collaboration diagram for StackMsgArgDestroyTableNode:

[legend]

Public Member Functions

BOOLEAN | Destroy (StackMsgArgument *arg)
void | DestroySelf ()
StackMsgArgDestroyTableNode (const ArgumentDestroyEntry *destroy_table, INT16 table_length)

Protected Member Functions

virtual void | Dummy ()

Friends

class | StackMsgArgument

Constructor & Destructor Documentation

StackMsgArgDestroyTableNode::StackMsgArgDestroyTableNode | ( | const ArgumentDestroyEntry * | destroy_table,
 |  | INT16 | table_length
 | ) |

Member Function Documentation

BOOLEAN StackMsgArgDestroyTableNode::Destroy ( StackMsgArgument * arg )

void StackMsgArgDestroyTableNode::DestroySelf ( )

virtual void StackMsgArgDestroyTableNode::Dummy ( ) [inline, protected, virtual]

Friends And Related Function Documentation

friend class StackMsgArgument [friend]

The documentation for this class was generated from the following files:
  • Apc/StackMsgArgument.hpp
  • Apc/StackMsgArgument.cpp
Generated on Wed Jan 25 02:04:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgArgMap< T > Struct Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgArgMap< T > Struct Template Reference

#include <Apoxi/Apc/StackMsgArgument.hpp>

Inheritance diagram for StackMsgArgMap< T >:

[legend]

Data Fields

StackMsgArgId arg_id
BOOLEAN(T::* OnArg )(const StackMsgArgument &arg)

template<class T>
struct StackMsgArgMap< T >

Field Documentation

template<class T>
StackMsgArgId StackMsgArgMap< T >::arg_id

template<class T>
BOOLEAN(T::* StackMsgArgMap< T >::OnArg)(const StackMsgArgument &arg)

The documentation for this struct was generated from the following file:
  • Apc/StackMsgArgument.hpp
Generated on Wed Jan 25 02:04:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgArgMapContainer< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgArgMapContainer< T > Class Template Reference

#include <Apoxi/Apc/StackMsgArgument.hpp>

Inheritance diagram for StackMsgArgMapContainer< T >:

[legend]
Collaboration diagram for StackMsgArgMapContainer< T >:

[legend]

Public Member Functions

virtual BOOLEAN | Execute (const StackMsgArgument &arg) const
virtual void | Init (T *dispatcher, const StackMsgArgMap< T > *arg_map)
StackMsgArgMapContainer (T *dispatcher=0, const StackMsgArgMap< T > *arg_map=0)

template<class T>
class StackMsgArgMapContainer< T >

Constructor & Destructor Documentation

template<class T>
StackMsgArgMapContainer< T >::StackMsgArgMapContainer | ( | T * | dispatcher = 0,
 |  | const StackMsgArgMap< T > * | arg_map = 0
 | ) | [inline]

Member Function Documentation

template<class T>
virtual BOOLEAN StackMsgArgMapContainer< T >::Execute ( const StackMsgArgument & arg ) const [inline, virtual]

Implements AbstractStackMsgArgMapContainer.

template<class T>
virtual void StackMsgArgMapContainer< T >::Init | ( | T * | dispatcher,
 |  | const StackMsgArgMap< T > * | arg_map
 | ) | [inline, virtual]

The documentation for this class was generated from the following file:
  • Apc/StackMsgArgument.hpp
Generated on Wed Jan 25 02:04:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgArgument Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgArgument Class Reference

#include <Apoxi/Apc/StackMsgArgument.hpp>

Inheritance diagram for StackMsgArgument:

[legend]
Collaboration diagram for StackMsgArgument:

[legend]

Public Member Functions

StackMsgArgId | Id () const
StackMsgArgument (StackMsgArgId id=0)

Friends

class | FromStackMsg
class | SsStackMsgArgument
class | StackMsgArgDestroyTableNode
class | ToStackMsg

Detailed Description

StackMsgArgument represents the base class of any argument of a stack message.

Constructor & Destructor Documentation

StackMsgArgument::StackMsgArgument ( StackMsgArgId id = 0 )

Member Function Documentation

StackMsgArgId StackMsgArgument::Id ( ) const [inline]

Friends And Related Function Documentation

friend class FromStackMsg [friend]

friend class SsStackMsgArgument [friend]

friend class StackMsgArgDestroyTableNode [friend]

friend class ToStackMsg [friend]

The documentation for this class was generated from the following files:
  • Apc/StackMsgArgument.hpp
  • Apc/StackMsgArgument.cpp
Generated on Wed Jan 25 02:04:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgDispatcher Class Reference
[APOXI Stack Control]

is the base for all normal dispatchers, which are used in ASC. More...

#include <Apoxi/Asc/StackMsgDispatcher.hpp>

Inheritance diagram for StackMsgDispatcher:

[legend]
Collaboration diagram for StackMsgDispatcher:

[legend]

Public Member Functions

StackMsgDispatcher (const AbstractStackMsgArgMapContainer *arg_map_container=0)
virtual | ~StackMsgDispatcher ()

Protected Member Functions

BOOLEAN | Activate (ExecutionContext *context=0)
BOOLEAN | Deactivate (ExecutionContext *context=0)
void | Init (const AbstractStackMsgArgMapContainer *arg_map_container)
virtual BOOLEAN | OnMessage (const Message &msg)

Friends

class | BaseHandler

Detailed Description

is the base for all normal dispatchers, which are used in ASC.

Constructor & Destructor Documentation

StackMsgDispatcher::StackMsgDispatcher ( const AbstractStackMsgArgMapContainer * arg_map_container = 0 )

Parameters:
arg_map The argument map holds all arguments of the FromStackMsg, to which the dispatcher should listen to.

StackMsgDispatcher::~StackMsgDispatcher ( ) [virtual]

Member Function Documentation

BOOLEAN StackMsgDispatcher::Activate ( ExecutionContext * context = 0 ) [protected]

BOOLEAN StackMsgDispatcher::Deactivate ( ExecutionContext * context = 0 ) [protected]

void StackMsgDispatcher::Init ( const AbstractStackMsgArgMapContainer * arg_map_container ) [inline, protected]

BOOLEAN StackMsgDispatcher::OnMessage ( const Message & msg ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

Reimplemented in LcsProviderImpl, GltpProviderImpl, and SaProviderImpl.

Friends And Related Function Documentation

friend class BaseHandler [friend]

The documentation for this class was generated from the following files:
  • Asc/StackMsgDispatcher.hpp
  • Asc/StackMsgDispatcher.cpp
Generated on Wed Jan 25 02:04:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgMapTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgMapTable Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/StackMsgMapTable.hpp>

Collaboration diagram for StackMsgMapTable:

[legend]

Static Public Member Functions

static void | SendSignal (const StackMsgArgument &arg)

Friends

class | StackMsgMapTableNode

Member Function Documentation

void StackMsgMapTable::SendSignal ( const StackMsgArgument & arg ) [static]

Friends And Related Function Documentation

friend class StackMsgMapTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/StackMsgMapTable.hpp
  • Apc/SignalHandler/StackMsgMapTable.cpp
Generated on Wed Jan 25 02:04:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgMapTableEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgMapTableEntry Struct Reference
[APC]

#include <Apoxi/Apc/SignalHandler/StackMsgMapTableEntry.hpp>

Static Public Member Functions

static BOOLEAN | IsNameAvailable ()

Data Fields

StackMsgArgId id
StackMsgArgName name
void(* | send_signal_func )(const StackMsgArgument &)

Member Function Documentation

static BOOLEAN StackMsgMapTableEntry::IsNameAvailable ( ) [inline, static]

Field Documentation

StackMsgArgId StackMsgMapTableEntry::id

StackMsgArgName StackMsgMapTableEntry::name

void(* StackMsgMapTableEntry::send_signal_func)(const StackMsgArgument &)

The documentation for this struct was generated from the following file:
  • Apc/SignalHandler/StackMsgMapTableEntry.hpp
Generated on Wed Jan 25 02:04:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgMapTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgMapTableNode Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/StackMsgMapTableNode.hpp>

Inheritance diagram for StackMsgMapTableNode:

[legend]
Collaboration diagram for StackMsgMapTableNode:

[legend]

Public Member Functions

void | Remove ()
StackMsgMapTableNode (const StackMsgMapTableEntry *map_table, StackMsgArgId StackMsgArgId, StackMsgMapTableNode **node=0)

Friends

class | StackMsgMapTable

Constructor & Destructor Documentation

StackMsgMapTableNode::StackMsgMapTableNode | ( | const StackMsgMapTableEntry * | map_table,
 |  | StackMsgArgId | StackMsgArgId,
 |  | StackMsgMapTableNode ** | node = 0
 | ) |

Member Function Documentation

void StackMsgMapTableNode::Remove ( )

Friends And Related Function Documentation

friend class StackMsgMapTable [friend]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/StackMsgMapTableNode.hpp
  • Apc/SignalHandler/StackMsgMapTableNode.cpp
Generated on Wed Jan 25 02:04:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackMsgProcessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackMsgProcessor Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/StackMsgProcessor.hpp>

Inheritance diagram for StackMsgProcessor:

[legend]

Static Public Member Functions

static ProcessPtr | GetProcessPtr ()
static void | Init (const ProcessNode &process_node)
static void | PostFromStackMsg (StackMsgArgument *arg)

Static Protected Attributes

static ProcessPtr | m_process_ptr = 0

Detailed Description

StackMsgProcessor is the base for the translation units, which generates (and sends) SDL signals into the SDL environment out of an internal APOXI messages.

Member Function Documentation

static ProcessPtr StackMsgProcessor::GetProcessPtr ( ) [inline, static]

void StackMsgProcessor::Init ( const ProcessNode & process_node ) [static]

void StackMsgProcessor::PostFromStackMsg ( StackMsgArgument * arg ) [static]

Field Documentation

ProcessPtr StackMsgProcessor::m_process_ptr = 0 [static, protected]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/StackMsgProcessor.hpp
  • Apc/SignalHandler/StackMsgProcessor.cpp
Generated on Wed Jan 25 02:05:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackSsRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackSsRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for StackSsRejectedMsg:

[legend]
Collaboration diagram for StackSsRejectedMsg:

[legend]

Public Types

enum | { ID = 18558 }

Public Member Functions

virtual Message * | Clone () const
const ServiceGroup & | GetBasicService () const
const CallErrorCause & | GetCause () const
virtual const MsgMetaData & | GetMetaData () const
const SsOperationCode & | GetOperationCode () const
const SsCode & | GetSsCode () const
const Tipd & | GetTipd () const
StackSsRejectedMsg (ExecutionContext *context, const Tipd &tipd, const CallErrorCause &cause, const SsCode &ss_code, const ServiceGroup &basic_service, const SsOperationCode &operation_code)
virtual | ~StackSsRejectedMsg ()

Detailed Description

StackSsRejectedMsg: the stack rejected the request _after_ it has already been accepted by BEGIN_ACC

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StackSsRejectedMsg::StackSsRejectedMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const CallErrorCause & | cause,
 |  | const SsCode & | ss_code,
 |  | const ServiceGroup & | basic_service,
 |  | const SsOperationCode & | operation_code
 | ) |

StackSsRejectedMsg::~StackSsRejectedMsg ( ) [virtual]

Member Function Documentation

Message * StackSsRejectedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const ServiceGroup& StackSsRejectedMsg::GetBasicService ( ) const [inline]

const CallErrorCause& StackSsRejectedMsg::GetCause ( ) const [inline]

const MsgMetaData & StackSsRejectedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsOperationCode& StackSsRejectedMsg::GetOperationCode ( ) const [inline]

const SsCode& StackSsRejectedMsg::GetSsCode ( ) const [inline]

const Tipd& StackSsRejectedMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:05:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackTranslator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackTranslator Class Reference
[APC]

#include <Apoxi/Apc/SignalHandler/StackTranslator.hpp>

Static Public Member Functions

static void Init ()

Detailed Description

StackTranslator is a static class, which does the correct configuration and initialization of the translation unit (Processors and MapTableNodes) for the used stack.

Member Function Documentation

void StackTranslator::Init ( ) [static]

The documentation for this class was generated from the following files:
  • Apc/SignalHandler/StackTranslator.hpp
  • Apc/SignalHandler/StackTranslator.cpp
Generated on Wed Jan 25 02:05:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StackWrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StackWrapper Class Reference

#include <Apoxi/Apc/StackWrapper.hpp>

Static Public Member Functions

static INT | FlashDeletePdu (INT position)
static INT | FlashReadPdu (INT position, Tpdu &tpdu)
static INT | FlashWritePdu (const Tpdu &tpdu)
static INT | GetCountryListCc (INT idx)
static INT | GetCountryListLength ()
static Mcc | GetCountryListMcc (INT idx)
static const CHAR * | GetCountryListName (INT idx)
static INT | GetPlmnListCc (INT idx)
static const CHAR * | GetPlmnListCountryName (INT idx)
static INT | GetPlmnListLength ()
static Mcc | GetPlmnListMcc (INT idx)
static Mnc | GetPlmnListMnc (INT idx)
static const CHAR * | GetPlmnListName (INT idx)
static INT | GetPlmnListNetType (INT idx)
static const CHAR * | GetPlmnListShortName (INT idx)
static BOOLEAN | IsBcdPlmnMatching (const BcdPlmn &plmn, UINT16 mcc, UINT8 mnc)
static INT | LookupPlmnEntryIndex (Mcc mcc, Mnc mnc)
static Plmn | TransformBcdPlmnToPlmn (const BcdPlmn &bcd_plmn)
static BcdPlmn | TransformPlmnToBcdPlmn (const Plmn &plmn)

Member Function Documentation

INT StackWrapper::FlashDeletePdu ( INT position ) [static]

INT StackWrapper::FlashReadPdu | ( | INT | position,
 |  | Tpdu & | tpdu
 | ) | [static]

INT StackWrapper::FlashWritePdu ( const Tpdu & tpdu ) [static]

INT StackWrapper::GetCountryListCc ( INT idx ) [static]

INT StackWrapper::GetCountryListLength ( ) [static]

Mcc StackWrapper::GetCountryListMcc ( INT idx ) [static]

const CHAR * StackWrapper::GetCountryListName ( INT idx ) [static]

INT StackWrapper::GetPlmnListCc ( INT idx ) [static]

const CHAR * StackWrapper::GetPlmnListCountryName ( INT idx ) [static]

INT StackWrapper::GetPlmnListLength ( ) [static]

Mcc StackWrapper::GetPlmnListMcc ( INT idx ) [static]

Mnc StackWrapper::GetPlmnListMnc ( INT idx ) [static]

const CHAR * StackWrapper::GetPlmnListName ( INT idx ) [static]

INT StackWrapper::GetPlmnListNetType ( INT idx ) [static]

const CHAR * StackWrapper::GetPlmnListShortName ( INT idx ) [static]

BOOLEAN StackWrapper::IsBcdPlmnMatching | ( | const BcdPlmn & | plmn,
 |  | UINT16 | mcc,
 |  | UINT8 | mnc
 | ) | [static]

INT StackWrapper::LookupPlmnEntryIndex | ( | Mcc | mcc,
 |  | Mnc | mnc
 | ) | [static]

Plmn StackWrapper::TransformBcdPlmnToPlmn ( const BcdPlmn & bcd_plmn ) [static]

BcdPlmn StackWrapper::TransformPlmnToBcdPlmn ( const Plmn & plmn ) [static]

The documentation for this class was generated from the following files:
  • Apc/StackWrapper.hpp
  • Apc/StackWrapper.cpp
Generated on Wed Jan 25 02:05:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StandardJoinRule Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StandardJoinRule Class Reference
[AuxExtensions]

StandardJoinRule is a paramaterizable rule for standard relations More...

#include <Apoxi/AddOns/AuxExtensions/JoinRule.hpp>

Inheritance diagram for StandardJoinRule:

[legend]
Collaboration diagram for StandardJoinRule:

[legend]

Public Types

enum ComparisonType {
EqualType, NotEqualType, LessType, NotLessType,
GreaterType, NotGreaterType, CartesianType
}

Public Member Functions

virtual BOOLEAN | ExecuteRule (const DataItem &fst_item, const DataItem &snd_item)
Returns TRUE if fst_item is equal than snd_item, FALSE otherwise.
virtual JoinRule::RelationType | GetType ()
Returns Bijective.
void | Init (ComparisonType type)
Sets the comparison type.
StandardJoinRule ()
virtual | ~StandardJoinRule ()

Detailed Description

StandardJoinRule is a paramaterizable rule for standard relations

Member Enumeration Documentation

enum StandardJoinRule::ComparisonType

Enumerator:
EqualType | TRUE if both data items are equal, FALSE otherwise; RelationType: Bijective.
NotEqualType | TRUE if both data items are not equal, FALSE otherwise; RelationType: Bijective.
LessType | TRUE if the first data item is less than the second one, FALSE otherwise; RelationType: Cartesian.
NotLessType | TRUE if the first data item is less than the second one, FALSE otherwise; RelationType: Cartesian.
GreaterType | TRUE if the first data item is greater or equal than the second one, FALSE otherwise; RelationType: Cartesian.
NotGreaterType | TRUE if the first data item is greater than the second one, FALSE otherwise; RelationType: Cartesian.
CartesianType | TRUE, RelationType: Cartesian.

Constructor & Destructor Documentation

StandardJoinRule::StandardJoinRule ( )

StandardJoinRule::~StandardJoinRule ( ) [virtual]

Member Function Documentation

BOOLEAN StandardJoinRule::ExecuteRule | ( | const DataItem & | fst_item,
 |  | const DataItem & | snd_item
 | ) | [virtual]

Returns TRUE if fst_item is equal than snd_item, FALSE otherwise.

Implements JoinRule.

JoinRule::RelationType StandardJoinRule::GetType ( ) [virtual]

Returns Bijective.

Implements JoinRule.

void StandardJoinRule::Init ( ComparisonType type )

Sets the comparison type.

The documentation for this class was generated from the following files:
  • AddOns/AuxExtensions/JoinRule.hpp
  • AddOns/AuxExtensions/JoinRule.cpp
Generated on Wed Jan 25 02:05:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StartDtmfCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StartDtmfCnfArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for StartDtmfCnfArg:

[legend]
Collaboration diagram for StartDtmfCnfArg:

[legend]

Public Types

enum | { ID = 1124 }

Public Member Functions

const KeyCode & | GetKey () const
const Tipd & | GetTipd () const
void | SetKey (const KeyCode &key)
void | SetTipd (const Tipd &tipd)
StartDtmfCnfArg ()

Static Public Member Functions

static const StartDtmfCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

StartDtmfCnfArg: reflects arguments of signal MN_START_DTMF_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StartDtmfCnfArg::StartDtmfCnfArg ( )

Member Function Documentation

const StartDtmfCnfArg & StartDtmfCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const KeyCode& StartDtmfCnfArg::GetKey ( ) const [inline]

const Tipd& StartDtmfCnfArg::GetTipd ( ) const [inline]

void StartDtmfCnfArg::SetKey ( const KeyCode & key ) [inline]

void StartDtmfCnfArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:05:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StartDtmfRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StartDtmfRejArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for StartDtmfRejArg:

[legend]
Collaboration diagram for StartDtmfRejArg:

[legend]

Public Types

enum | { ID = 1126 }

Public Member Functions

const CallErrorCause & | GetCause () const
const Tipd & | GetTipd () const
void | SetCause (const CallErrorCause &cause)
void | SetTipd (const Tipd &tipd)
StartDtmfRejArg ()

Static Public Member Functions

static const StartDtmfRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

StartDtmfRejArg reflects arguments of signal MN_START_DTMF_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StartDtmfRejArg::StartDtmfRejArg ( )

Member Function Documentation

const StartDtmfRejArg & StartDtmfRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const CallErrorCause& StartDtmfRejArg::GetCause ( ) const [inline]

const Tipd& StartDtmfRejArg::GetTipd ( ) const [inline]

void StartDtmfRejArg::SetCause ( const CallErrorCause & cause ) [inline]

void StartDtmfRejArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:05:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StartDtmfReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StartDtmfReqArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for StartDtmfReqArg:

[legend]
Collaboration diagram for StartDtmfReqArg:

[legend]

Public Types

enum | { ID = 2122 }

Public Member Functions

const KeyCode & | GetKey () const
const Tipd & | GetTipd () const
void | SetKey (const KeyCode &key)
void | SetTipd (const Tipd &tipd)
StartDtmfReqArg ()
StartDtmfReqArg (const Tipd &tipd, const KeyCode &key)

Static Public Member Functions

static const StartDtmfReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

StartDtmfReqArg: reflects arguments of signal MN_START_DTMF_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StartDtmfReqArg::StartDtmfReqArg | ( | const Tipd & | tipd,
 |  | const KeyCode & | key
 | ) |

StartDtmfReqArg::StartDtmfReqArg ( )

Member Function Documentation

const StartDtmfReqArg & StartDtmfReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const KeyCode& StartDtmfReqArg::GetKey ( ) const [inline]

const Tipd& StartDtmfReqArg::GetTipd ( ) const [inline]

void StartDtmfReqArg::SetKey ( const KeyCode & key ) [inline]

void StartDtmfReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:05:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StartSignalStrengthListeningArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StartSignalStrengthListeningArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for StartSignalStrengthListeningArg:

[legend]
Collaboration diagram for StartSignalStrengthListeningArg:

[legend]

Public Types

enum | { ID = 2246 }

Public Member Functions

UINT | GetThresholdPercentage () const
void | SetThresholdPercentage (UINT threshold_percentage)
StartSignalStrengthListeningArg (UINT threshold_percentage=0)

Static Public Member Functions

static const StartSignalStrengthListeningArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

StartSignalStrengthListeningArg: reflects arguments of signal RRMI_START_RXSTAT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StartSignalStrengthListeningArg::StartSignalStrengthListeningArg ( UINT threshold_percentage = 0 )

Member Function Documentation

const StartSignalStrengthListeningArg & StartSignalStrengthListeningArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT StartSignalStrengthListeningArg::GetThresholdPercentage ( ) const [inline]

void StartSignalStrengthListeningArg::SetThresholdPercentage ( UINT threshold_percentage ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 02:05:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StartSocketTestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StartSocketTestMsg Class Reference

#include <Applications/SocketTest/SocketTestMsgTypes.hpp>

Inheritance diagram for StartSocketTestMsg:

[legend]
Collaboration diagram for StartSocketTestMsg:

[legend]

Public Types

enum | { ID = 21900 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
StartSocketTestMsg (ExecutionContext *context)
virtual | ~StartSocketTestMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StartSocketTestMsg::StartSocketTestMsg ( ExecutionContext * context )

StartSocketTestMsg::~StartSocketTestMsg ( ) [virtual]

Member Function Documentation

Message * StartSocketTestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & StartSocketTestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestMsgTypes.hpp
  • Applications/SocketTest/SocketTestMsgTypes.cpp
Generated on Wed Jan 25 02:05:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StartUp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StartUp Class Reference
[Devices]

#include <Apoxi/Devices/StartUp.hpp>

Collaboration diagram for StartUp:

[legend]

Public Types

enum Cause {
NormalOn = 1, AlarmOn, ChargerOn, ProductionTestOn,
AirplaneOn
}

Static Public Member Functions

static void | Abort ()
static const Data & | GetStartupData ()
static void | Restart (const Data &startup_data)
static void | Start (const Data &startup_data)

Friends

class | AlarmManager

Data Structures

class | Data
struct | Table

Member Enumeration Documentation

enum StartUp::Cause

Can also be a combination of causes. The startup causes reflect mainly the startup causes sent from stack, when APOXI is started. ATTENTION: An update when the startup cause changes on the running system is currently not performed.

Enumerator:
NormalOn | Normal Power On (Keypress...).
AlarmOn | Power on caused by an alarm.
ChargerOn | Power on caused by plugging on the Charger.
ProductionTestOn | Power on for production test.
AirplaneOn | Power on in airplane mode (only available together with Silent Reset).

Member Function Documentation

void StartUp::Abort ( ) [static]

This method cancels the start-up procedure of APOXI without starting any APOXI thread and shuts down the system. It can be called for instance during the initialization of devices or during OnPowerUp of any subsystem which identifies a needless or erroneous start-up. It only has effect when it will be called before StartUp::Restart.

static const Data& StartUp::GetStartupData ( ) [inline, static]

Returns:
The startup data, which has been sent from protocol stack to APOXI, when APOXI was started. ATTENTION: Please use the interfaces for PowerHandler and StartUp::Restart to change the startup data during runtime.
See also:
StartUp::Restart

void StartUp::Restart ( const Data & startup_data ) [static]

This method can be used to change the set of applications (based on the startup data) during runtime. Ensure to change to the corresponding power mode via PowerHandler interface before calling StartUp::Restart. Example to switch form mode ChargerOn to NormalOn: PowerHander::StartMobileNetwork(); StartUp::Data startup_data; startup_data.SetCause(StartUp::NormalOn); StartUp::Restart(startup_data);

void StartUp::Start ( const Data & startup_data ) [static]

This method is called from Apoxi_startup to initialize the APOXI system and starts the APOXI threads.

Friends And Related Function Documentation

friend class AlarmManager [friend]

The documentation for this class was generated from the following files:
  • Devices/StartUp.hpp
  • Devices/StartUp.cpp
Generated on Wed Jan 25 02:05:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StartUp::Data Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
StartUp::Data

StartUp::Data Class Reference

#include <Apoxi/Devices/StartUp.hpp>

Collaboration diagram for StartUp::Data:

[legend]

Public Member Functions

Data (Cause startup_cause)
Data ()
Cause | GetMainCause () const
BOOLEAN | IsCause (Cause cause) const
BOOLEAN | IsSilentReset () const
BOOLEAN | IsValid () const
returns TRUE if any valid startup cause exists
void | Reset ()
void | SetCause (Cause cause, BOOLEAN set=TRUE)
void | SetSilentReset (BOOLEAN set=TRUE)

Constructor & Destructor Documentation

StartUp::Data::Data ( ) [inline]

StartUp::Data::Data ( Cause startup_cause ) [inline]

Member Function Documentation

StartUp::Cause StartUp::Data::GetMainCause ( ) const

Returns:
The main cause for booting the device.

BOOLEAN StartUp::Data::IsCause ( Cause cause ) const [inline]

Using that method it is possible to check for any startup cause, also if multiple causes are set by the system. For example it is possible that both IsCause(ProductionTestOn) and IsCause(NormalOn) are returning TRUE. To ask for the main cause use GetMainCause.

BOOLEAN StartUp::Data::IsSilentReset ( ) const [inline]

BOOLEAN StartUp::Data::IsValid ( ) const [inline]

returns TRUE if any valid startup cause exists

void StartUp::Data::Reset ( void ) [inline]

void StartUp::Data::SetCause | ( | Cause | cause,
 |  | BOOLEAN | set = TRUE
 | ) | [inline]

void StartUp::Data::SetSilentReset ( BOOLEAN set = TRUE ) [inline]

The documentation for this class was generated from the following files:
  • Devices/StartUp.hpp
  • Devices/StartUp.cpp
Generated on Wed Jan 25 02:05:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StartUp::Table Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
StartUp::Table

StartUp::Table Struct Reference

#include <Apoxi/Devices/StartUp.hpp>

Collaboration diagram for StartUp::Table:

[legend]

Data Fields

Application * app
INT | app_cont_idx
BOOLEAN | enabled
UINT | stacksize

Field Documentation

Application* StartUp::Table::app

for debugging purpose: set all applications to TRUE and change to FALSE during startup runtime.

INT StartUp::Table::app_cont_idx

Pointer to the Application

BOOLEAN StartUp::Table::enabled

UINT StartUp::Table::stacksize

Index of AppContainerArray

The documentation for this struct was generated from the following file:
  • Devices/StartUp.hpp
Generated on Wed Jan 25 02:05:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StateMachine Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StateMachine Class Reference

#include <Apoxi/Auxiliary/StateMachine.hpp>

Inheritance diagram for StateMachine:

[legend]
Collaboration diagram for StateMachine:

[legend]

Protected Types

enum | { EVENT_IGNORED = 0xFE, CANNOT_HAPPEN }

Protected Member Functions

void | ExternalEvent (const UINT8[], EventData *=0)
Semaphore & | GetSempahore () const
virtual const StateStruct * | GetStateMap ()=0
void | InternalEvent (UINT8, EventData *=0)
StateMachine (INT maxStates)

Protected Attributes

UINT8 | m_currentState

Detailed Description

Base class for state machines. The code for this state machine implementation is based on the article "State Machine Design in C++" by David Lafreniere which was published in the "C/C++ Users Journal", issue of May 2000.

Member Enumeration Documentation

anonymous enum [protected]

Enumerator:
EVENT_IGNORED
CANNOT_HAPPEN

Constructor & Destructor Documentation

StateMachine::StateMachine ( INT maxStates ) [protected]

Member Function Documentation

void StateMachine::ExternalEvent | ( | const | UINT8[],
 |  | EventData * | = 0
 | ) | [protected]

Generates an external event. Called once per external event to start the state machine executing.

Semaphore& StateMachine::GetSempahore ( ) const [inline, protected]

virtual const StateStruct* StateMachine::GetStateMap ( ) [protected, pure virtual]

void StateMachine::InternalEvent | ( | UINT8 | ,
 |  | EventData * | = 0
 | ) | [protected]

Generates an internal event. Called from within a state function to transition to a new state.

Field Documentation

UINT8 StateMachine::m_currentState [protected]

The documentation for this class was generated from the following files:
  • Auxiliary/StateMachine.hpp
  • Auxiliary/StateMachine.cpp
Generated on Wed Jan 25 02:05:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StateStruct Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StateStruct Struct Reference

#include <Apoxi/Auxiliary/StateMachine.hpp>

Data Fields

StateFunc pStateFunc

Field Documentation

StateFunc StateStruct::pStateFunc

The documentation for this struct was generated from the following file:
  • Auxiliary/StateMachine.hpp
Generated on Wed Jan 25 02:05:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StatusDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StatusDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/StatusDispatcher.hpp>

Inheritance diagram for StatusDispatcher:

[legend]
Collaboration diagram for StatusDispatcher:

[legend]

Public Member Functions

StatusDispatcher ()
virtual ~StatusDispatcher ()

Constructor & Destructor Documentation

StatusDispatcher::StatusDispatcher ( )

StatusDispatcher::~StatusDispatcher ( ) [virtual]

The documentation for this class was generated from the following files:
  • Asc/StatusDispatcher.hpp
  • Asc/StatusDispatcher.cpp
Generated on Wed Jan 25 02:05:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StatusProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StatusProvider Class Reference
[Provider]

#include <Apoxi/Adc/StatusProvider.hpp>

Inheritance diagram for StatusProvider:

[legend]
Collaboration diagram for StatusProvider:

[legend]

Public Types

typedef ThreadSafeProvider | Base

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
BatteryLoadLevel GetBatteryLoadLevel ()
const CfuServiceArray & | GetCfuServiceArray () const
virtual BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
void | GetEepCalibrationStatus (BOOLEAN &eep_calibration_status)
GsmBand GetGsmBand ()
void | GetIsLsaIdentifierPresent (BOOLEAN &lsaidentifier)
void | GetLastCcm (UINT32 &last_ccm)
void | GetLastCcm2 (UINT32 &last_ccm)
void | GetLsaIdentifier (LsaIdentifier &lsaidentifier)
void | GetNetworkNameLong (WString &network_name_long)
void | GetNetworkNameShort (WString &network_name_short)
PowerMode GetPowerMode ()
virtual INT | GetProviderId () const
Returns the provider id.
RadioAccessTechnology GetRadioAccessTechnology ()
RatChangeMode GetRatChangeMode ()
UINT16 | GetRegisteredLac () const
void | GetRegisteredPlmn (Plmn &plmn)
Get the already registered plmn.
Plmn | GetRegisteredPlmn () const
BOOLEAN | GetScanStatus ()
SignalQualityLevel GetSignalQualityLevel ()
SignalQualityMax GetSignalQualityMax ()
SignalStrengthLevel GetSignalStrengthLevel ()
SignalStrengthMax GetSignalStrengthMax ()
void | GetTimeZone (TimeZone &timezone)
void | Reset ()
virtual INT | RowCount ()
RowCount returns the number of rows.
void | SetBatteryLoadLevel (const BatteryLoadLevel level)
void | SetCellId (const CellId &cellid)
void | SetCfuServiceArray (const CfuServiceArray &servicearray)
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
void | SetGprsAttached (BOOLEAN gprs_attached)
void | SetGprsClass (const GprsClass gprs_class)
void | SetGprsClassChangeOrigin (const ProcessSource gprs_class_change_origin)
void | SetGsmBand (const GsmBand band)
void | SetIsLsaIdentifierPresent (const BOOLEAN lsaidentifier)
void | SetLai (const Lai &lai)
void | SetLastCcm (UINT32 last_ccm)
void | SetLastCcm2 (UINT32 last_ccm)
void | SetLsaIdentifier (const LsaIdentifier &lsaidentifier)
void | SetMaxConcRefNo (UINT16 refno)
void | SetNetworkNameLong (const WString &network_name_long)
void | SetNetworkNameShort (const WString &network_name_short)
void | SetPowerMode (PowerMode power_mode)
void | SetRadioAccessTechnology (const RadioAccessTechnology rat)
void | SetRatChangeMode (const RatChangeMode mode)
void | SetRegisteredPlmn (const Plmn &plmn)
void | SetRegisterMode (const RegisterMode mode)
void | SetRegisterRejectCause (const RegisterRejectCause rejectcause)
void | SetRegisterStatus (const RegisterStatus status)
void | SetScanStatus (BOOLEAN scan_status)
void | SetSignalQualityLevel (const SignalQualityLevel signalquality)
void | SetSignalQualityMax (const SignalQualityMax signalquality)
void | SetSignalStrengthLevel (const SignalStrengthLevel signalstrength)
void | SetSignalStrengthMax (const SignalStrengthMax signalstrength)
void | SetTimeZone (const TimeZone &timezone)
StatusProvider ()
virtual | ~StatusProvider ()

Detailed Description

StatusProvider is the provider to retrieve states about the mobile station. An instance of this class is part of the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_status_provider_id

Following column ids are defined: c_mode_id :NumberType: cast to RegisterMode c_state_id :NumberType: cast to RegisterStatus c_reject_cause_id :NumberType: cast to RegisterRejectCause c_mcc_id :NumberType: cast to Mcc c_mnc_id :NumberType: cast to Mnc c_mnc_threedigits_id :NumberType: cast to BOOLEAN, tells if MNC has three digits. c_signal_strength_id :NumberType: cast to SignalStrengthLevel c_signal_quality_id :NumberType: cast to SignalQualityLevel c_signal_strength_max_id:NumberType: cast to SignalStrengthMax c_signal_quality_max_id :NumberType: cast to SignalQualityMax c_battery_load_id :NumberType: cast to BatteryLoadLevel c_clir_mode_id :NumberType: cast to ClirMode c_redialing_active_id :NumberType: cast to BOOLEAN c_network_name_long_id :WStringType: c_network_name_short_id :WStringType: c_gprs_available_id :NumberType: cast to BOOLEAN c_gprs_attached_id :NumberType: cast to BOOLEAN c_tz_offset_id :NumberType: c_tz_dst_id :NumberType: c_succ_16bit_conc_sms_ref_no :NumberType: c_last_ccm_id :NumberType: cast to UINT32 (last current call meter line 1) c_last_ccm2_id :NumberType: cast to UINT32 (last current call meter line 2) c_lai_mcc_id :NumberType: cast to Mcc c_lai_mnc_id :NumberType: cast to Mnc c_lai_lac_id :NumberType: c_eep_calibration_status_id :NumberType: c_cellid_id :NumberType: cast to UINT32

This provider only consists of one fixed row.

NOTE: Please do not instantiate this class.

Member Typedef Documentation

typedef ThreadSafeProvider StatusProvider::Base

Reimplemented from ThreadSafeProvider.

Constructor & Destructor Documentation

StatusProvider::StatusProvider ( )

StatusProvider::~StatusProvider ( ) [virtual]

Member Function Documentation

BOOLEAN StatusProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BatteryLoadLevel StatusProvider::GetBatteryLoadLevel ( ) [inline]

const CfuServiceArray& StatusProvider::GetCfuServiceArray ( ) const [inline]

BOOLEAN StatusProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

void StatusProvider::GetEepCalibrationStatus ( BOOLEAN & eep_calibration_status )

GsmBand StatusProvider::GetGsmBand ( ) [inline]

void StatusProvider::GetIsLsaIdentifierPresent ( BOOLEAN & lsaidentifier ) [inline]

void StatusProvider::GetLastCcm ( UINT32 & last_ccm ) [inline]

void StatusProvider::GetLastCcm2 ( UINT32 & last_ccm ) [inline]

void StatusProvider::GetLsaIdentifier ( LsaIdentifier & lsaidentifier ) [inline]

void StatusProvider::GetNetworkNameLong ( WString & network_name_long ) [inline]

void StatusProvider::GetNetworkNameShort ( WString & network_name_short ) [inline]

PowerMode StatusProvider::GetPowerMode ( ) [inline]

INT StatusProvider::GetProviderId ( ) const [virtual]

Returns the provider id.

Implements Provider.

RadioAccessTechnology StatusProvider::GetRadioAccessTechnology ( ) [inline]

RatChangeMode StatusProvider::GetRatChangeMode ( ) [inline]

UINT16 StatusProvider::GetRegisteredLac ( ) const [inline]

void StatusProvider::GetRegisteredPlmn ( Plmn & plmn ) [inline]

Get the already registered plmn.

Plmn StatusProvider::GetRegisteredPlmn ( ) const [inline]

BOOLEAN StatusProvider::GetScanStatus ( ) [inline]

SignalQualityLevel StatusProvider::GetSignalQualityLevel ( ) [inline]

SignalQualityMax StatusProvider::GetSignalQualityMax ( ) [inline]

SignalStrengthLevel StatusProvider::GetSignalStrengthLevel ( ) [inline]

SignalStrengthMax StatusProvider::GetSignalStrengthMax ( ) [inline]

void StatusProvider::GetTimeZone ( TimeZone & timezone )

void StatusProvider::Reset ( )

INT StatusProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Implements Provider.

void StatusProvider::SetBatteryLoadLevel ( const BatteryLoadLevel level ) [inline]

void StatusProvider::SetCellId ( const CellId & cellid ) [inline]

void StatusProvider::SetCfuServiceArray ( const CfuServiceArray & servicearray ) [inline]

BOOLEAN StatusProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual]

Reimplemented from Provider.

void StatusProvider::SetGprsAttached ( BOOLEAN gprs_attached ) [inline]

void StatusProvider::SetGprsClass ( const GprsClass gprs_class ) [inline]

void StatusProvider::SetGprsClassChangeOrigin ( const ProcessSource gprs_class_change_origin ) [inline]

void StatusProvider::SetGsmBand ( const GsmBand band ) [inline]

void StatusProvider::SetIsLsaIdentifierPresent ( const BOOLEAN lsaidentifier ) [inline]

void StatusProvider::SetLai ( const Lai & lai ) [inline]

void StatusProvider::SetLastCcm ( UINT32 last_ccm ) [inline]

void StatusProvider::SetLastCcm2 ( UINT32 last_ccm ) [inline]

void StatusProvider::SetLsaIdentifier ( const LsaIdentifier & lsaidentifier ) [inline]

void StatusProvider::SetMaxConcRefNo ( UINT16 refno ) [inline]

void StatusProvider::SetNetworkNameLong ( const WString & network_name_long ) [inline]

void StatusProvider::SetNetworkNameShort ( const WString & network_name_short ) [inline]

void StatusProvider::SetPowerMode ( PowerMode power_mode ) [inline]

void StatusProvider::SetRadioAccessTechnology ( const RadioAccessTechnology rat ) [inline]

void StatusProvider::SetRatChangeMode ( const RatChangeMode mode ) [inline]

void StatusProvider::SetRegisteredPlmn ( const Plmn & plmn ) [inline]

void StatusProvider::SetRegisterMode ( const RegisterMode mode ) [inline]

void StatusProvider::SetRegisterRejectCause ( const RegisterRejectCause rejectcause ) [inline]

void StatusProvider::SetRegisterStatus ( const RegisterStatus status ) [inline]

void StatusProvider::SetScanStatus ( BOOLEAN scan_status ) [inline]

void StatusProvider::SetSignalQualityLevel ( const SignalQualityLevel signalquality ) [inline]

void StatusProvider::SetSignalQualityMax ( const SignalQualityMax signalquality ) [inline]

void StatusProvider::SetSignalStrengthLevel ( const SignalStrengthLevel signalstrength ) [inline]

void StatusProvider::SetSignalStrengthMax ( const SignalStrengthMax signalstrength ) [inline]

void StatusProvider::SetTimeZone ( const TimeZone & timezone )

The documentation for this class was generated from the following files:
  • Adc/StatusProvider.hpp
  • Adc/StatusProvider.cpp
Generated on Wed Jan 25 02:05:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StillCamera Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StillCamera Class Reference
[Devices, Devices, Devices, Devices, Devices, Devices]

#include <Apoxi/Devices/BP30/StillCamera.hpp>

Inheritance diagram for StillCamera:

[legend]
Collaboration diagram for StillCamera:

[legend]

Public Types

typedef void(* | CbCaptureFinished )(INT result, void *context, UINT16 frame)
typedef void(* | CbImageCaptured )(INT result, void *context, UINT16 frame)
typedef void(* | CbImageEncoded )(INT result, void *context, UINT16 frame)

Public Member Functions

BOOLEAN | CancelCapture ()
BOOLEAN | Capture (DataSink **sink_array, UINT16 count, void *context, CbImageCaptured cb_image_captured, CbImageEncoded cb_image_encoded, CbCaptureFinished cb_capture_finished)
virtual BOOLEAN | Close ()
virtual BOOLEAN | Close ()
virtual BOOLEAN | Close ()
virtual BOOLEAN | Close ()
BOOLEAN | ConfigureMultiShot (UINT16 no_of_pictures, UINT8 frame_rate_subsampling)
INT | GetJpegQuality () const
virtual const WCHAR * | GetName () const
virtual BOOLEAN | GetSupportedImageSizes (const ImageSizeType *&array, UINT8 &count) const
virtual BOOLEAN | Open ()
virtual BOOLEAN | Open ()
virtual BOOLEAN | SetCaptureImageSize (ImageSizeType capture_image_size, TransformationType capture_transformation=Camera::NoTransformation)
BOOLEAN | SetJpegQuality (INT level)
StillCamera (INT device_id)
virtual | ~StillCamera ()

Friends

class | CameraConfig

Data Structures

struct | BufferInfoType
struct | BufferInfoType
struct | BufferInfoType

Detailed Description

StillCamera device for accessing hardware cameras

Member Typedef Documentation

typedef void(* StillCamera::CbCaptureFinished)(INT result, void *context, UINT16 frame)

Callback, where application will be informed when the multi shot sequence has finished.

Parameters:
result | return result
context | context pointer
frame | captured frame number

typedef void(* StillCamera::CbImageCaptured)(INT result, void *context, UINT16 frame)

Callback, where application will be informed when a snapshot has been taken. Application e.g. may play a shutter sound.

Parameters:
result | return result
context | context pointer
frame | captured frame number

typedef void(* StillCamera::CbImageEncoded)(INT result, void *context, UINT16 frame)

Callback, where application will be informed when the snapshot is ready for saving, e.g. if finally has been encoded into JPEG.

Parameters:
result | return result
context | context pointer
frame | captured frame number

Constructor & Destructor Documentation

StillCamera::StillCamera ( INT device_id )

Parameters:
device_id Camera hardware ID

StillCamera::~StillCamera ( ) [virtual]

Destructor

Member Function Documentation

BOOLEAN StillCamera::CancelCapture ( )

Cancels the capturing of snapshot(s) and aborts possible JPEG encoding.

Returns:
returns FALSE if something went wrong

BOOLEAN StillCamera::Capture | ( | DataSink ** | sink_array,
 |  | UINT16 | count,
 |  | void * | context,
 |  | CbImageCaptured | cb_image_captured,
 |  | CbImageEncoded | cb_image_encoded,
 |  | CbCaptureFinished | cb_capture_finished
 | ) |

Captures a count given number of images in the given sink_array.

Parameters:
sink_array | DataSink (mostly RamDataSink), given by application, where encoded JPEG images are written into.
count | number of images that should be captured.
context | application context pointer.
cb_image_captured | Application callback, when image is captured, e.g. for playing a shutter sound
cb_image_encoded | Application callback, when a certain Image has finished encoding, e.g. for displaying image.
cb_capture_finished | Application callback, when capturing and encoding has completed.

virtual BOOLEAN StillCamera::Close ( ) [virtual]

Close() frees any allocated buffers for capturing and unlocks the camera.

Returns:
returns FALSE if unlocking or buffer deallocation fails.

Reimplemented from Camera.

virtual BOOLEAN StillCamera::Close ( ) [virtual]

Close() frees any allocated buffers for capturing and unlocks the camera.

Returns:
returns FALSE if unlocking or buffer deallocation fails.

Reimplemented from Camera.

virtual BOOLEAN StillCamera::Close ( ) [virtual]

Close() frees any allocated buffers for capturing and unlocks the camera.

Returns:
returns FALSE if unlocking or buffer deallocation fails.

Reimplemented from Camera.

BOOLEAN StillCamera::Close ( ) [virtual]

Close() frees any allocated buffers for capturing and unlocks the camera.

Returns:
returns FALSE if unlocking or buffer deallocation fails.

Reimplemented from Camera.

BOOLEAN StillCamera::ConfigureMultiShot | ( | UINT16 | no_of_pictures,
 |  | UINT8 | frame_rate_subsampling
 | ) |

Buffer allocation is done for multi-shot. Buffers will be deallocated in Close() or in SetImageSize or ConfigureMultiShot again.

Parameters:
no_of_pictures | how many frames should be captured
frame_rate_subsampling | every "frame_rate_subsampling" frame should be captured e.g. every 5th frame
Returns:
returns TRUE is configuration for MultiShot is valid.

const WCHAR * StillCamera::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

BOOLEAN StillCamera::GetSupportedImageSizes | ( | const ImageSizeType *& | array,
 |  | UINT8 & | count
 | ) | const [virtual]

See also:
Camera::GetSupportedImageSizes

virtual BOOLEAN StillCamera::Open ( ) [virtual]

Open() sets default values for the Camera which are available through a CameraConfig or by driver. Furthermore it tries to Lock the Camera for exclusive usage.

Returns:
returns FALSE, if setting values or locking failed.

Reimplemented from Camera.

BOOLEAN StillCamera::Open ( ) [virtual]

Open() sets default values for the Camera which are available through a CameraConfig or by driver. Furthermore it tries to Lock the Camera for exclusive usage.

Returns:
returns FALSE, if setting values or locking failed.

Reimplemented from Camera.

BOOLEAN StillCamera::SetCaptureImageSize | ( | ImageSizeType | capture_image_size,
 |  | TransformationType | capture_transformation = Camera::NoTransformation
 | ) | [virtual]

See also:
Camera::SetCaptureImageSize

BOOLEAN StillCamera::SetJpegQuality ( INT level )

Sets the compression level for the JPEG encoding.

Parameters:
level compression between 0 and 100%
Returns:
returns FALSE if quality value is not possible, TRUE else

Friends And Related Function Documentation

CameraConfig [friend]

The documentation for this class was generated from the following files:
  • Devices/BP30/StillCamera.hpp
  • Devices/MPE/StillCamera.hpp
  • Devices/MPEU/Extensions/AtiW2282/StillCamera.hpp
  • Devices/MPEU/StillCamera.hpp
  • Devices/SGold/StillCamera.hpp
  • Devices/StillCameraInterface.hpp
  • Devices/Win32/StillCamera.hpp
  • Devices/BP30/StillCamera.cpp
  • Devices/MPE/StillCamera.cpp
  • Devices/MPEU/Extensions/AtiW2282/StillCamera.cpp
  • Devices/MPEU/StillCamera.cpp
  • Devices/SGold/StillCamera.cpp
  • Devices/Win32/StillCamera.cpp
Generated on Wed Jan 25 02:05:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StopBatteryLoadListeningArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StopBatteryLoadListeningArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for StopBatteryLoadListeningArg:

[legend]
Collaboration diagram for StopBatteryLoadListeningArg:

[legend]

Public Types

enum | { ID = 2245 }

Public Member Functions

StopBatteryLoadListeningArg ()

Static Public Member Functions

static const StopBatteryLoadListeningArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

StopBatteryLoadListeningArg: reflects arguments of signal MIOM_BATT_CHECK_OFF_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StopBatteryLoadListeningArg::StopBatteryLoadListeningArg ( )

Member Function Documentation

const StopBatteryLoadListeningArg & StopBatteryLoadListeningArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 02:05:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StopDtmfCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StopDtmfCnfArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for StopDtmfCnfArg:

[legend]
Collaboration diagram for StopDtmfCnfArg:

[legend]

Public Types

enum | { ID = 1125 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
StopDtmfCnfArg ()
StopDtmfCnfArg (const Tipd &tipd)
~StopDtmfCnfArg ()

Static Public Member Functions

static const StopDtmfCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

StopDtmfCnfArg: reflects arguments of signal MN_STOP_DTMF_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StopDtmfCnfArg::StopDtmfCnfArg ( const Tipd & tipd )

StopDtmfCnfArg::StopDtmfCnfArg ( )

StopDtmfCnfArg::~StopDtmfCnfArg ( )

Member Function Documentation

const StopDtmfCnfArg & StopDtmfCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& StopDtmfCnfArg::GetTipd ( ) const [inline]

void StopDtmfCnfArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:05:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StopDtmfReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StopDtmfReqArg Class Reference

#include <Apoxi/Apc/CallMiscStackMsgArgs.hpp>

Inheritance diagram for StopDtmfReqArg:

[legend]
Collaboration diagram for StopDtmfReqArg:

[legend]

Public Types

enum | { ID = 2123 }

Public Member Functions

const Tipd & | GetTipd () const
void | SetTipd (const Tipd &tipd)
StopDtmfReqArg ()
StopDtmfReqArg (const Tipd &tipd)

Static Public Member Functions

static const StopDtmfReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

StopDtmfReqArg: reflects arguments of signal MN_STOP_DTMF_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StopDtmfReqArg::StopDtmfReqArg ( const Tipd & tipd )

StopDtmfReqArg::StopDtmfReqArg ( )

Member Function Documentation

const StopDtmfReqArg & StopDtmfReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Tipd& StopDtmfReqArg::GetTipd ( ) const [inline]

void StopDtmfReqArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/CallMiscStackMsgArgs.hpp
  • Apc/CallMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:05:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StopSignalStrengthListeningArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StopSignalStrengthListeningArg Class Reference

#include <Apoxi/Apc/PowerStackMsgArgs.hpp>

Inheritance diagram for StopSignalStrengthListeningArg:

[legend]
Collaboration diagram for StopSignalStrengthListeningArg:

[legend]

Public Types

enum | { ID = 2247 }

Public Member Functions

StopSignalStrengthListeningArg ()

Static Public Member Functions

static const StopSignalStrengthListeningArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

StopSignalStrengthListeningArg: reflects arguments of signal RRMI_END_RXSTAT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StopSignalStrengthListeningArg::StopSignalStrengthListeningArg ( )

Member Function Documentation

const StopSignalStrengthListeningArg & StopSignalStrengthListeningArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PowerStackMsgArgs.hpp
  • Apc/PowerStackMsgArgs.cpp
Generated on Wed Jan 25 02:05:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StopSocketTestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StopSocketTestMsg Class Reference

#include <Applications/SocketTest/SocketTestMsgTypes.hpp>

Inheritance diagram for StopSocketTestMsg:

[legend]
Collaboration diagram for StopSocketTestMsg:

[legend]

Public Types

enum | { ID = 21903 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
StopSocketTestMsg (ExecutionContext *context)
virtual | ~StopSocketTestMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

StopSocketTestMsg::StopSocketTestMsg ( ExecutionContext * context )

StopSocketTestMsg::~StopSocketTestMsg ( ) [virtual]

Member Function Documentation

Message * StopSocketTestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & StopSocketTestMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/SocketTestMsgTypes.hpp
  • Applications/SocketTest/SocketTestMsgTypes.cpp
Generated on Wed Jan 25 02:05:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StorageDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StorageDevice Class Reference
[Root File System]

Client interface and base class for storage devices. More...

#include <Apoxi/Afs/Rfs/StorageDevice.hpp>

Inheritance diagram for StorageDevice:

[legend]
Collaboration diagram for StorageDevice:

[legend]

Public Types

enum DeviceCapability {
DirectorySupport = 0, Removable = 1, ReadOnly = 2, ExchangeableMedia = 3,
MediaAvailableStatusNotification = 4, DEVICE_CAPABILITY_COUNT = 5
}
enum ScanResult {
ScanOk, ScanNotSupported, ScanProblemDetected, ScanRepairableProblemDetected,
ScanNonRepairableProblemDetected, ScanProblemRepaired, ScanRepairFailed, ScanInternalError
}

Public Member Functions

virtual BOOLEAN | Exists (const Pathname &pathname) const =0
virtual BOOLEAN | Flush ()
virtual BOOLEAN | Format (BOOLEAN quick=FALSE)=0
virtual BOOLEAN | GetClusterSize (UINT32 &size) const
virtual UINT8 | GetDefaultChunkSize () const =0
virtual UINT32 | GetFreeVolumeSize () const =0
const WString & | GetId () const
virtual File::Error | GetLastError () const
virtual BOOLEAN | GetMediaAvailableStatus (BOOLEAN &media_present) const
virtual BOOLEAN | GetMediaName (WString &name) const
const WString & | GetName () const
virtual WString | GetNativeDirectoryPathname (const Pathname &pathname) const =0
virtual WString | GetNativeFilePathname (const Pathname &pathname) const =0
virtual BOOLEAN | GetNativeProperty (UINT prop_id, void *val) const
virtual BOOLEAN | GetOpenFilesCounter (UINT &counter) const
virtual BOOLEAN | GetSectorSize (UINT32 &size) const
virtual UINT32 | GetTotalVolumeSize () const =0
virtual UINT32 | GetUsedVolumeSize () const =0
BOOLEAN | IsCapabilitySupported (DeviceCapability device_capability) const
virtual BOOLEAN | IsDirectory (const Pathname &pathname) const =0
virtual BOOLEAN | IsReady () const =0
virtual ScanResult | ScanDisk (BOOLEAN do_repair=FALSE)
virtual BOOLEAN | SetMediaName (const WString &name)
virtual BOOLEAN | SetNativeProperty (UINT prop_id, const void *val)
virtual | ~StorageDevice ()

Protected Member Functions

virtual DirectoryIteratorPtr | CreateDirectoryIterator (const Pathname &dir_pathname, const FileFilterPtr &filter) const =0
virtual FilePtr | CreateFileObject (const Pathname &pathname) const =0
void | DecrementOpenFileCounter ()
void | IncrementOpenFileCounter ()
void | NotifyMediaAvailableStatus (BOOLEAN media_present)
virtual void | OnNotifyMediaAvailableStatus (BOOLEAN media_present)
void | SetDeviceCapability (DeviceCapability device_capability, BOOLEAN value)
virtual BOOLEAN | Shutdown ()
StorageDevice (const WString &device_Id, const WString &name)

Static Protected Member Functions

static BOOLEAN | Register (StorageDevicePtr device)

Protected Attributes

File::Error m_last_error

Friends

class | File
class | RootFileSystem

Detailed Description

Client interface and base class for storage devices.

Abstract class StorageDevice is the superclass of all storage devices which shall be accessible via the root file system. To add a new storage device to the root file system you have to subclass and implement class StorageDevice. The abstract classes File and DirectoryIterator have to be subclassed, too. Subclasses of class File handle device access for storing, reading, and modifying files and directories. Subclasses of class DirectoryIterator handle access of elements within a directory.

By convention, subclasses of class StorageDevice are named by their device name appended by the suffix StorageDeviceImp. Subclasses of class File and class DirectoryIterator are constructed the same way but appended by the suffix FileImp and DirectoryIteratorImp, respectively. The suffixes all end with Imp since these subclasses are never seen by clients of the root file system. They are used exclusively to implement the concrete storage device, file, and directory iterator, respectively. Please see the following existing examples:

  • RootStorageDeviceImp, RootFileImp, and RootDirectoryIteratorImp or
  • FlashStorageDeviceImp, FlashFileImp, and FlashDirectoryIteratorImp.

Every storage device must have its unique storage device ID string for all the available storage devices can be registered to the root file system at the same time. If you implement a subclass of class StorageDevice you have to define the storage device ID string to use. If this is equal to a storage device ID string of another storage device, then only one of those storage devices can be registered to the root file system. Therefore, if you implement a new storage device take care to investigate which storage device ID strings are already used by existing storage devices. If it is already existing choose another storage device ID string for being able to register it with any other storage device at the same time.

To setup a dedicated storage device the subclass should provide a static method Setup() which adds a new instance of the subclass to the root file system if none has been added yet (for a sample see FlashStorageDeviceImp::Setup()). This should be the only moment of instantiating a storage device, therefore the constructors of storage device classes are protected.

On destruction, the storage device shall be automatically unregistered, which has to be implemented in the destructor of the subclass by calling this class' method Shutdown() (for a sample see FlashStorageDeviceImp::~FlashStorageDeviceImp()).

Member Enumeration Documentation

enum StorageDevice::DeviceCapability

This enumeration defines the available device capabilities which can be queried using IsCapabilitySupported().

Enumerator:
DirectorySupport | Tells if the storage device supports directories.
Removable | Tells if the storage device itself is removable (and addable) at runtime. This device capability is supported for plug & play devices.
ReadOnly | Tells if the storage device is read-only.
ExchangeableMedia | Tells if the storage media of the storage device is exchangeable, like smart cards and so on.
MediaAvailableStatusNotification | Tells if the storage device triggers the sending of a notification message when a media is inserted or removed.
DEVICE_CAPABILITY_COUNT | Used internally only to dimension the bit vector m_device_capabilities.

enum StorageDevice::ScanResult

This enumeration defines the result codes of the ScanDisk() method.

Enumerator:
ScanOk | Scanning detected no problem.
ScanNotSupported | Scanning is not supported on this storage device.
ScanProblemDetected | Scanning detected a problem, however, no info is available whether the problem can be repaired.
ScanRepairableProblemDetected | Scanning detected a problem which can be repaired.
ScanNonRepairableProblemDetected | Scanning detected a problem which cannot be repaired.
ScanProblemRepaired | Scanning found problem(s) and could repair those.
ScanRepairFailed | Scanning found problem(s) and could not repair all of them.
ScanInternalError | The scanning itself failed, it can not be decided whether the disk is ok or not.

Constructor & Destructor Documentation

StorageDevice::StorageDevice | ( | const WString & | device_Id,
 |  | const WString & | name
 | ) | [protected]

Creates a new device with ID device_Id and name.

Parameters:
device_Id | The ID has to be unique for every storage device.
name | Human-readable name of the storage device.

StorageDevice::~StorageDevice ( ) [virtual]

Destroys the storage device. An overriding destructor of a subclass has to call Shutdown() to properly end the device.

Member Function Documentation

virtual DirectoryIteratorPtr StorageDevice::CreateDirectoryIterator | ( | const Pathname & | dir_pathname,
 |  | const FileFilterPtr & | filter
 | ) | const [protected, pure virtual]

Creates a new directory iterator object for the specified pathname.

Parameters:
dir_pathname | The pathname of the directory.
filter | The filter which selects the files the iterator shall return.
Returns:
A DirectoryIteratorPtr wrapping either a new directory iterator object or 0 if there is not enough memory left.

Implemented in FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

virtual FilePtr StorageDevice::CreateFileObject ( const Pathname & pathname ) const [protected, pure virtual]

Creates a new file object for the specified pathname.

Parameters:
pathname The pathname.
Returns:
A FilePtr wrapping either a new file object or 0 if there is not enough memory left.

Implemented in FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

void StorageDevice::DecrementOpenFileCounter ( ) [inline, protected]

Decrements the counter of open files.

virtual BOOLEAN StorageDevice::Exists ( const Pathname & pathname ) const [pure virtual]

Tells if pathname exists. If it exists it may either be a file or a directory.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

BOOLEAN StorageDevice::Flush ( ) [virtual]

This method is to be overridden by devices which have to empty buffers when they are shutdown. It might be especially useful for plug and play devices. This base class implementation does nothing.

Returns:
The success of the operation.

Reimplemented in FatStorageDeviceImp.

virtual BOOLEAN StorageDevice::Format ( BOOLEAN quick = FALSE ) [pure virtual]

This method formats the actual storage device. It is only possible to format real devices. The root storage device cannot be formatted.

Returns:
The success of the operation.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

virtual BOOLEAN StorageDevice::GetClusterSize ( UINT32 & size ) const [inline, virtual]

Retrieves the cluster size of the volume in terms of sectors via parameter size. It is only possible to retrieve the cluster size of physical devices. If a storage device supports removable medias and no media is inserted, the method can fail, too.

Returns:
The success of the operation.

virtual UINT8 StorageDevice::GetDefaultChunkSize ( ) const [pure virtual]

Returns the default chunk size for operating in chunk mode on files stored on this storage device.

See also:
File::GetChunkSize()

File::SetChunkSize()

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

virtual UINT32 StorageDevice::GetFreeVolumeSize ( ) const [pure virtual]

Returns the free volume size of the device in bytes.

Returns:
The free volume size of the device in bytes.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

const WString& StorageDevice::GetId ( ) const [inline]

Returns the unique ID of a storage device.

virtual File::Error StorageDevice::GetLastError ( ) const [inline, virtual]

Returns the error occurred by the last operation.

Reimplemented in RootStorageDeviceImp.

virtual BOOLEAN StorageDevice::GetMediaAvailableStatus ( BOOLEAN & media_present ) const [inline, virtual]

Gets the storage media insertion status. This base implementation simply returns FALSE. This method has to be overridden by devices which support exchangeable medias. If the method succeeds then parameter media_present tells whether a storage media is inserted.

Returns:
Tells if the storage media insertion status could be retrieved.

Reimplemented in FatStorageDeviceImp.

BOOLEAN StorageDevice::GetMediaName ( WString & name ) const [virtual]

Gets the name of the inserted storage media. This base implementation simply returns FALSE. This method has to be overridden by devices which support exchangeable medias.

const WString& StorageDevice::GetName ( ) const [inline]

Returns the human-readable name for the device.

virtual WString StorageDevice::GetNativeDirectoryPathname ( const Pathname & pathname ) const [pure virtual]

Returns pathname in native directory name format. The native directory name format may differ from storage device to storage device.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

virtual WString StorageDevice::GetNativeFilePathname ( const Pathname & pathname ) const [pure virtual]

Returns pathname in native file name format. The native file name format may differ from storage device to storage device.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

virtual BOOLEAN StorageDevice::GetNativeProperty | ( | UINT | prop_id,
 |  | void * | val
 | ) | const [inline, virtual]

Retrieves the native property identified by prop_id via argument val. If the property is not supported by the native storage device (and therefore can't be retrieved) the method fails. The properties that the native storage device supports are defined by the derived class that implements the native storage device support. E.g., for knowing which properties a flash storage device supports look at the documentation of class FlashStorageDeviceImp, there the respective property IDs are defined. It is crucial that the given property ID prop_id and the receiving value val really match!

Parameters:
prop_id | ID of the native storage device property to retrieve, defined in the derived class that implements the native storage device support.
val | Valid pointer to the value object that shall be set to the current value of the storage device property with id prop_id.
Returns:
Tells if the storage device property could be retrieved.

BOOLEAN StorageDevice::GetOpenFilesCounter ( UINT & counter ) const [virtual]

Returns the number of currently open file handles.

Reimplemented in RootStorageDeviceImp.

virtual BOOLEAN StorageDevice::GetSectorSize ( UINT32 & size ) const [inline, virtual]

Retrieves the sector size of the volume in terms of bytes via parameter size. It is only possible to retrieve the sector size of physical devices. If a storage device supports removable medias and no media is inserted, the method can fail, too.

Returns:
The success of the operation.

virtual UINT32 StorageDevice::GetTotalVolumeSize ( ) const [pure virtual]

Returns the total volume size of the device in bytes.

Returns:
The total volume size of the device in bytes.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

virtual UINT32 StorageDevice::GetUsedVolumeSize ( ) const [pure virtual]

Returns the used volume size of the device in bytes. Note that this size is usually larger than the sum of the sizes of all stored files, since meta information to control the directory structure is stored on the device, too.

Returns:
The used volume size of the device in bytes.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

void StorageDevice::IncrementOpenFileCounter ( ) [inline, protected]

Increments the counter of open files.

BOOLEAN StorageDevice::IsCapabilitySupported ( DeviceCapability device_capability ) const

Tells if a device capability is supported.

Parameters:
device_capability The device capability.

BOOLEAN StorageDevice::IsDirectory ( const Pathname & pathname ) const [pure virtual]

Tells if pathname is a directory. This base implementation returns TRUE only for the root pathname, since every storage device is at least organized in a flat manner which we interpret as having a single root directory. The method is declared as abstract for when implementing a new storage device you can't forget to deal with this issue. If the derived storage device is organized in a flat manner, then the override of this abstract method might be a simple call to this base class implementation. If a derived class supports directories then implement this method accordingly.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

virtual BOOLEAN StorageDevice::IsReady ( ) const [pure virtual]

Tells if the device is ready for being accessed.

Implemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

void StorageDevice::NotifyMediaAvailableStatus ( BOOLEAN media_present ) [protected]

Notifies the root file system about the media availability status. Argument media_present specifies whether a media is inserted in this storage device. The root file system reacts to this by posting an RfsMediaAvailableStatusMsg to the system. Applications can register for this message and use it to display storage device icons and the like. Subclasses which support exchangeable medias have to call this method each time a media is inserted or removed. After having sent the notification message, this method calls method OnNotifyMediaAvailableStatus(), which can be used to perform some special actions which have to be done on removal or insertion of a storage media.

Parameters:
media_present The flag specifying whether a media is inserted or not.

virtual void StorageDevice::OnNotifyMediaAvailableStatus ( BOOLEAN media_present ) [inline, protected, virtual]

This method has to be overridden if the specific storage device has to perform some special actions on removal or insertion of a storage media. This method is actually called by method NotifyMediaAvailableStatus() after the notification message has been sent.

Parameters:
media_present The flag specifying whether a media is inserted or not.

BOOLEAN StorageDevice::Register ( StorageDevicePtr device ) [static, protected]

Registers device with the root file system and returns the success of the registration.

virtual ScanResult StorageDevice::ScanDisk ( BOOLEAN do_repair = FALSE ) [inline, virtual]

This method scans the actual storage device for data integrity. It is only possible to scan physical devices. The root storage device cannot be scanned. Argument do_repair specifies whether it shall be tried to repair disk problems in case they are encountered.

Returns:
The result code of the operation.

void StorageDevice::SetDeviceCapability | ( | DeviceCapability | device_capability,
 |  | BOOLEAN | value
 | ) | [protected]

Sets the support state of a device capability.

Parameters:
device_capability | The device capability to set.
value | The support state of the device capability.

BOOLEAN StorageDevice::SetMediaName ( const WString & name ) [virtual]

Sets the name of the inserted storage media. This base implementation simply returns FALSE. This method has to be overridden by devices which support exchangeable medias.

virtual BOOLEAN StorageDevice::SetNativeProperty | ( | UINT | prop_id,
 |  | const void * | val
 | ) | [inline, virtual]

Sets the native property identified by prop_id to value val. If the property is not supported by the native storage device (and therefore can't be set) the method fails. The properties that the native storage device supports are defined by the derived class that implements the native storage device support. E.g., for knowing which properties a flash storage device supports look at the documentation of class FlashStorageDeviceImp, there the respective property IDs are defined. It is crucial that the given property ID prop_id and the passed value val really match!

Parameters:
prop_id | ID of the native storage device property to set, defined in the derived class that implements the native storage device support.
val | Valid pointer to the value that shall be set for storage device property with id prop_id.
Returns:
Tells if the storage device property could be set.

BOOLEAN StorageDevice::Shutdown ( ) [protected, virtual]

Shuts down the storage device. Buffers are emptied by calling Flush() and afterwards the storage device is unregistered from the root file system. If something else has to be done on shutdown for this device, then this base method can be overridden and the additional tasks can be performed in the override. In this case please assure that this base implementation is called, too! This method has to be called in the destructor of subclasses!

Friends And Related Function Documentation

friend class File [friend]

friend class RootFileSystem [friend]

Reimplemented in FatStorageDeviceImp, FlashStorageDeviceImp, RamStorageDeviceImp, and RootStorageDeviceImp.

Field Documentation

File::Error StorageDevice::m_last_error [mutable, protected]

The documentation for this class was generated from the following files:
  • Afs/Rfs/StorageDevice.hpp
  • Afs/Rfs/StorageDevice.cpp
Generated on Wed Jan 25 02:06:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StorageDeviceFilter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StorageDeviceFilter Class Reference
[Root File System]

Base class for storage device filters. More...

#include <Apoxi/Afs/Rfs/StorageDeviceFilter.hpp>

Inheritance diagram for StorageDeviceFilter:

[legend]

Public Member Functions

virtual BOOLEAN | Complies (const StorageDevicePtr &device)=0
virtual | ~StorageDeviceFilter ()
Destroys a storage device filter.

Protected Member Functions

StorageDeviceFilter ()
Constructs a storage device filter.

Detailed Description

Base class for storage device filters.

Abstract class StorageDeviceFilter is the base class for storage device filter functors. Concrete filters have to override method Complies(). If a function or method requires a storage device filter to be passed as argument but you are interested in all storage devices then just pass the temporary object of an empty smart-pointer, i.e. StorageDeviceFilterPtr(0).

Constructor & Destructor Documentation

StorageDeviceFilter::~StorageDeviceFilter ( ) [virtual]

Destroys a storage device filter.

StorageDeviceFilter::StorageDeviceFilter ( ) [protected]

Constructs a storage device filter.

Member Function Documentation

virtual BOOLEAN StorageDeviceFilter::Complies ( const StorageDevicePtr & device ) [pure virtual]

Tells if device complies with the filter criteria.

Parameters:
device The storage device smart-pointer.
Returns:
Tells if device complies with the filter.

Implemented in NamePatternStorageDeviceFilter.

The documentation for this class was generated from the following files:
  • Afs/Rfs/StorageDeviceFilter.hpp
  • Afs/Rfs/StorageDeviceFilter.cpp
Generated on Wed Jan 25 02:06:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StorageDeviceIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StorageDeviceIterator Class Reference
[Root File System]

Storage device iterator. More...

#include <Apoxi/Afs/Rfs/StorageDeviceIterator.hpp>

Inheritance diagram for StorageDeviceIterator:

[legend]
Collaboration diagram for StorageDeviceIterator:

[legend]

Public Member Functions

StorageDevicePtr | GetStorageDevice () const
const WString & | GetStorageDeviceId () const
void | Increment ()
BOOLEAN | IsValid () const
~StorageDeviceIterator ()

Static Public Member Functions

static BOOLEAN | Accept (StorageDeviceVisitor &visitor)

Protected Member Functions

StorageDeviceIterator & AtomicIncrement ()
StorageDeviceIterator (const StorageDeviceFilterPtr &filter)

Protected Attributes

SimpleMap< WString, StorageDevicePtr
>::Iterator 		m_cur_device_id
StorageDeviceFilterPtr m_filter
The additional filter method to apply.

Friends

class | RootFileSystem

Detailed Description

Storage device iterator.

Class StorageDeviceIterator implements a storage devices iterator. A storage device iterator iterates over all storage devices which are currently registered to the root file system.

Constructor & Destructor Documentation

StorageDeviceIterator::~StorageDeviceIterator ( )

StorageDeviceIterator::StorageDeviceIterator ( const StorageDeviceFilterPtr & filter ) [explicit, protected]

Constructs a storage device iterator. The iterator retrieves storage devices which comply to filter. This is the only constructor since a non-initialized storage device iterator is not allowed.

Parameters:
filter A storage device filter functor.

Member Function Documentation

BOOLEAN StorageDeviceIterator::Accept ( StorageDeviceVisitor & visitor ) [static]

If all the actually registered devices are ready then the storage device visitor is accepted and TRUE is returned. Accepting the storage device visitor means that for each registered storage device method Visit() of visitor is called. The storage device visitor defines the filter for the storage devices to use. If any of the storage devices is not ready then the visitor can't be accepted and FALSE is returned.

Parameters:
visitor The storage device visitor which operates on the storage devices iterated over.
See also:
StorageDeviceVisitor

StorageDeviceIterator & StorageDeviceIterator::AtomicIncrement ( ) [protected]

Increments the iterator to point to the next storage device registered to the root file system and returns a reference to itself. This increment operation does not consider the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

Returns:
Reference to itself incremented to point to the next storage device or being the end iterator.

Reimplemented in RootStorageDeviceIterator.

StorageDevicePtr StorageDeviceIterator::GetStorageDevice ( ) const

Returns the storage device the iterator currently points to. Only valid iterators are allowed to be accessed. If the iterator is the end iterator, i.e. the current storage device smart-pointer wraps 0, then an assertion holds.

const WString & StorageDeviceIterator::GetStorageDeviceId ( ) const

Returns the storage device Id of the storage device the iterator currently points to. Only valid iterators are allowed to be accessed. If the iterator is the end iterator, i.e. the current storage device smart-pointer wraps 0, then an assertion holds.

void StorageDeviceIterator::Increment ( )

Increments the iterator to refer to the next storage device or it becomes the end iterator. This increment operation considers the filter set on construction. Only valid iterators are allowed to be incremented. If this method gets called on the end iterator an assertion holds.

BOOLEAN StorageDeviceIterator::IsValid ( ) const

Tells if the iterator points to a storage device. This is determined by simply checking the current storage device smart-pointer. If it wraps 0 it is not valid, otherwise it is valid.

Returns:
Tells if the iterator is valid.

Reimplemented in RootStorageDeviceIterator.

Friends And Related Function Documentation

friend class RootFileSystem [friend]

Reimplemented in RootStorageDeviceIterator.

Field Documentation

SimpleMap<WString, StorageDevicePtr>::Iterator StorageDeviceIterator::m_cur_device_id [protected]

Iterator for the map of storage devices which is embodied in class RootFileSystem.

StorageDeviceFilterPtr StorageDeviceIterator::m_filter [protected]

The additional filter method to apply.

The documentation for this class was generated from the following files:
  • Afs/Rfs/StorageDeviceIterator.hpp
  • Afs/Rfs/StorageDeviceIterator.cpp
Generated on Wed Jan 25 02:06:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StorageDeviceVisitor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StorageDeviceVisitor Class Reference
[Root File System]

Base class for storage device visitors. More...

#include <Apoxi/Afs/Rfs/StorageDeviceVisitor.hpp>

Collaboration diagram for StorageDeviceVisitor:

[legend]

Public Member Functions

StorageDeviceFilterPtr | GetIteratorFilter () const
virtual BOOLEAN | Visit (const StorageDevicePtr &device)=0
virtual | ~StorageDeviceVisitor ()

Protected Member Functions

StorageDeviceVisitor (const StorageDeviceFilterPtr &filter)

Protected Attributes

StorageDeviceFilterPtr m_filter

Detailed Description

Base class for storage device visitors.

Class StorageDeviceVisitor implements an operation which shall be executed on certain filtered storage devices actually registered with the root file system. The static method StorageDeviceIterator::Accept() takes a storage device visitor and in case all the relevant storage devices are ready it accepts the visitor and calls its method Visit() on every storage device gathered using a storage device iterator initialized with the filter defined in the storage device visitor. This implements the visitor pattern.

Constructor & Destructor Documentation

StorageDeviceVisitor::~StorageDeviceVisitor ( ) [virtual]

StorageDeviceVisitor::StorageDeviceVisitor ( const StorageDeviceFilterPtr & filter ) [protected]

Constructs a storage device visitor. The filter is used to initialize the storage device iterator which shall be used.

Parameters:
filter The filter functor used to initialize the storage device iterator.

Member Function Documentation

StorageDeviceFilterPtr StorageDeviceVisitor::GetIteratorFilter ( ) const [inline]

Returns the filter functor for intializing the iterator to be used.

virtual BOOLEAN StorageDeviceVisitor::Visit ( const StorageDevicePtr & device ) [pure virtual]

Visits device and performs its operation on it. The return value indicates if the visiting shall continue or shall be aborted.

Field Documentation

StorageDeviceFilterPtr StorageDeviceVisitor::m_filter [protected]

The client provided filter for selecting the storage devices to iterate on.

The documentation for this class was generated from the following files:
  • Afs/Rfs/StorageDeviceVisitor.hpp
  • Afs/Rfs/StorageDeviceVisitor.cpp
Generated on Wed Jan 25 02:06:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StrData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StrData Struct Reference
[Auxiliary]

#include <Apoxi/Auxiliary/String.hpp>

Collaboration diagram for StrData:

[legend]

Public Member Functions

void | DecRefCount ()
UINT | GetBufSize () const
UINT | GetLength () const
BOOLEAN | HasMultipleRefs () const
BOOLEAN | IncRefCount ()
BOOLEAN | IsNullStr () const
void | operator delete (void *p)
void * | operator new (UINT s_strbuf, UINT char_count)
void | ResetRefCount ()
void | SetBufSize (UINT n)
void | SetLength (UINT n)
CHAR * | ToPtr ()
const CHAR * | ToPtr () const

Static Public Member Functions

static StrData * | FromPtr (CHAR *str)
static CHAR * | GetNullStr ()

Data Fields

UINT16 | m_bufsize
UINT8 | m_len
UINT8 | m_refcount

Static Public Attributes

static CHAR * | m_null_str = &g_null_str.m_char
static StrData * | m_null_strbuf = &g_null_str.m_strdata

Detailed Description

StrData is the internal data structure storing the string buffer for a String object. In memory string data is immediately following the object. Object data and method members are private to String class and must not used by any other instance.

Member Function Documentation

void StrData::DecRefCount ( )

Decrement the internal reference counter. Deletes object if last referenced is released.

static StrData* StrData::FromPtr ( CHAR * str ) [inline, static]

Get corresponding StrData object from pointer to string data.

UINT StrData::GetBufSize ( ) const [inline]

Returns the overall buffer size of the string object.

UINT StrData::GetLength ( ) const

Return the length of string data excluding trailing null character.

static CHAR* StrData::GetNullStr ( ) [inline, static]

Get special StrData pointing to null string.

BOOLEAN StrData::HasMultipleRefs ( ) const [inline]

Returns true if multiple String objects reference the StrData object.

BOOLEAN StrData::IncRefCount ( )

Increment the internal reference counter. Returns true on success and false if maximum is reached.

BOOLEAN StrData::IsNullStr ( ) const [inline]

Null has special internal handling. Returns true if the StrData object is the unique null (i.e. string with zero length).

void StrData::operator delete ( void * p )

Delete operator for StrData.

void * StrData::operator new | ( | UINT | s_strbuf,
 |  | UINT | char_count
 | ) |

Operator new allocates a consecutive memory block with size sizeof(StrData) + char_count.

void StrData::ResetRefCount ( )

Reset reference counter of string data.

void StrData::SetBufSize ( UINT n )

Set buffer size of string data.

void StrData::SetLength ( UINT n )

Set length of string data.

CHAR* StrData::ToPtr ( ) [inline]

Get the pointer to string data for this object.

const CHAR* StrData::ToPtr ( ) const [inline]

Get the pointer to constant string data for this object.

Field Documentation

UINT16 StrData::m_bufsize

UINT8 StrData::m_len

CHAR * StrData::m_null_str = &g_null_str.m_char [static]

StrData * StrData::m_null_strbuf = &g_null_str.m_strdata [static]

UINT8 StrData::m_refcount

The documentation for this struct was generated from the following files:
  • Auxiliary/String.hpp
  • Auxiliary/String.cpp
Generated on Wed Jan 25 02:06:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Stream Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Stream Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Stream.hpp>

Public Types

enum | Caps { StreamCanBeRead = 1, StreamCanBeWritten, StreamCanBeReadWritten }
enum | Origin { StreamBegin = 1, StreamEnd, StreamCurrent }

Public Member Functions

virtual void | Close (StreamingInfo &info)=0
virtual Caps | GetCapabilities ()=0
virtual StreamReader * | GetReader ()=0
virtual StreamWriter * | GetWriter ()=0
virtual void | Open (StreamingInfo &info)=0
Stream ()
virtual | ~Stream ()

Detailed Description

Stream is a base class for classes implementing streams. Possible subclasses are FileStream, SocketStream, PipeStream, MemoryStream, OBEXStream, etc. Allows to get stream readers and stream writers which can be used for reading data from and writing data to the stream. Defines open and close methods and allows to query the the capabilites of the stream (input, output, or both).

Member Enumeration Documentation

enum Stream::Caps

Enumeration capabilities of this stream.

Enumerator:
StreamCanBeRead | One can read from this stream.
StreamCanBeWritten | One can write to this stream.
StreamCanBeReadWritten | One can read from and write to this stream.

enum Stream::Origin

Enumeration for origins for seek operations.

Enumerator:
StreamBegin | Start at beginning of a stream.
StreamEnd | Start at end of the stream.
StreamCurrent | Start at current position.

Constructor & Destructor Documentation

Stream::Stream ( )

Default constructor.

Stream::~Stream ( ) [virtual]

Virtual destructor

Member Function Documentation

virtual void Stream::Close ( StreamingInfo & info ) [pure virtual]

Closes this stream

Parameters:
info the info object which will give information about this operation

virtual Caps Stream::GetCapabilities ( ) [pure virtual]

Returns the capabilities for this stream

Returns:
StreamCanBeRead when stream is an input stream only, StreamCanWrite when it is an output stream only, and StreamCanReadWrite when it as input as well as an output stream

virtual StreamReader* Stream::GetReader ( ) [pure virtual]

Gets the reader for this stream.

Returns:
the stream reader to read from this stream, 0 if reading is not supported

virtual StreamWriter* Stream::GetWriter ( ) [pure virtual]

Gets the writer for this stream.

Returns:
the stream writer to write to this, 0 if writing is not supported

virtual void Stream::Open ( StreamingInfo & info ) [pure virtual]

Opens this stream

Parameters:
info the info object which will give information about this operation

The documentation for this class was generated from the following files:
  • Auxiliary/Stream.hpp
  • Auxiliary/Stream.cpp
Generated on Wed Jan 25 02:06:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamAudioPlayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamAudioPlayer Class Reference
[Audio]

#include <Apoxi/Audio/StreamAudioPlayer.hpp>

Inheritance diagram for StreamAudioPlayer:

[legend]
Collaboration diagram for StreamAudioPlayer:

[legend]

Public Types

typedef DwdPlayer | Base

Public Member Functions

virtual BOOLEAN | CanPlay (const AudioActiveReference &active_reference) const
virtual BOOLEAN | CanResume (const AudioActiveReference &active_reference) const
virtual BOOLEAN | CanSuspend (const AudioActiveReference &active_reference) const
UINT32 | GetRecordingDelay () const
virtual AudioSourceType | GetSource () const
BOOLEAN | IsRecording ()
virtual SharedPtr< AudioActiveReference > | Record (const AudioReference &audio_ref)
void | SetRecordingDelay (UINT32 delay)
virtual void | StopRecord (AudioActiveReference &active_reference)
StreamAudioPlayer ()
virtual | ~StreamAudioPlayer ()

Protected Member Functions

void | ForgetRecordingReference ()
See GetRecordingReference().
SharedPtr< const AudioActiveReference > | GetRecordingReference () const
SharedPtr< AudioActiveReference > GetRecordingReference ()
INT | MapMedia (StreamAudioReference::Media media)
virtual void | OnRecordingFinished (INT8 return_code, UINT32 param)
void | ReconstructRecordingWaitCondition ()
void | SetRecordingWaitCondition (BOOLEAN val=TRUE)
virtual BOOLEAN | StopSuspend_Implementation (AudioActiveReference &playing_reference)
Stops the suspended playback.

Protected Attributes

UINT32 | m_delay
TimeoutCondition * m_recording_wait_condition

Detailed Description

The AMR/PCM player's base class.Get this player using AudioDeviceManager::GetAudioPlayer()

Member Typedef Documentation

typedef DwdPlayer StreamAudioPlayer::Base

Constructor & Destructor Documentation

StreamAudioPlayer::StreamAudioPlayer ( )

StreamAudioPlayer::~StreamAudioPlayer ( ) [virtual]

Member Function Documentation

BOOLEAN StreamAudioPlayer::CanPlay ( const AudioActiveReference & active_reference ) const [virtual]

Reimplemented from DwdPlayer.

BOOLEAN StreamAudioPlayer::CanResume ( const AudioActiveReference & active_reference ) const [virtual]

Reimplemented from DwdPlayer.

BOOLEAN StreamAudioPlayer::CanSuspend ( const AudioActiveReference & active_reference ) const [virtual]

Reimplemented from DwdPlayer.

void StreamAudioPlayer::ForgetRecordingReference ( ) [protected]

See GetRecordingReference().

UINT32 StreamAudioPlayer::GetRecordingDelay ( ) const

SharedPtr< const AudioActiveReference > StreamAudioPlayer::GetRecordingReference ( ) const [protected]

SharedPtr< AudioActiveReference > StreamAudioPlayer::GetRecordingReference ( ) [protected]

AudioPlayer::AudioSourceType StreamAudioPlayer::GetSource ( ) const [virtual]

BOOLEAN StreamAudioPlayer::IsRecording ( )

Returns TRUE if the player is recording, FALSE if not recording

INT StreamAudioPlayer::MapMedia ( StreamAudioReference::Media media ) [protected]

Maps the APOXI media into audio driver media

void StreamAudioPlayer::OnRecordingFinished | ( | INT8 | return_code,
 |  | UINT32 | param
 | ) | [protected, virtual]

void StreamAudioPlayer::ReconstructRecordingWaitCondition ( ) [protected]

Reconstructs the wait condition member. Reason: Workaround for the following behavior of Timer: When it is used (Start()) from different contexts, it asserts. With the previous implementation of recording players, such a concurrency situation actually occurs. Dynamic recreation of the wait condition (and hence the Timer) works around the problem because the current execution context is set on construction time.

SharedPtr< AudioActiveReference > StreamAudioPlayer::Record ( const AudioReference & audio_ref ) [virtual]

Start recording. Below is the table which contains all the messages which could be emitted by APOXI at the beginning, during and at the end of recording

AudioRecordingStoppedMsg | This message will be emitted when the recording has stopped for some reason, it will not be emmitted the recording has been explicitly stopped
AudioStreamingSyncMsg | If the streaming instance was created using StreamAudioReference::CreateStream() function, the AudioStreamingSyncMsg APOXI Message will be sent after the first buffer is passed to DSP to be recorded

Parameters:
audio_ref A reference to the location to which the sound should be recorded.
Returns:
A reference to the active recording, for use with StopRecord() and the APOXI Messages.

void StreamAudioPlayer::SetRecordingDelay ( UINT32 delay )

Set the recording delay. It might be possible that the recording has to be delayed for a couple of miliseconds This can be used to avoid recording of key tones or other sounds that have not finished when the recording start

Parameters:
delay The delay to be applied when the recording is started. See Record().

void StreamAudioPlayer::SetRecordingWaitCondition ( BOOLEAN val = TRUE ) [protected]

void StreamAudioPlayer::StopRecord ( AudioActiveReference & active_reference ) [virtual]

Stop recording. See Record(). If RAM has been set as media then StreamAudioReference::GetRecordedSize can be used to get the recorded buffer size

Parameters:
active_reference A reference to the active recording.
Note:
If streaming mode is used this function cannot be invoked from the callback function

BOOLEAN StreamAudioPlayer::StopSuspend_Implementation ( AudioActiveReference & playing_reference ) [protected, virtual]

Stops the suspended playback.

Field Documentation

UINT32 StreamAudioPlayer::m_delay [protected]

TimeoutCondition* StreamAudioPlayer::m_recording_wait_condition [protected]

The documentation for this class was generated from the following files:
  • Audio/StreamAudioPlayer.hpp
  • Audio/StreamAudioPlayer.cpp
Generated on Wed Jan 25 02:06:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamAudioReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamAudioReference Class Reference
[Audio]

#include <Apoxi/Audio/StreamAudioReference.hpp>

Inheritance diagram for StreamAudioReference:

[legend]
Collaboration diagram for StreamAudioReference:

[legend]

Public Types

typedef UINT32 | BufferByteType
typedef AudioPlayer::Buffer | BufferType
typedef AudioPlayer::ConstBuffer | ConstBufferType
enum DspFormat {
PcmDspFormat, AdpcmDspFormat, WaveDspFormat, FrDspFormat,
AmrDspFormat, MP3DspFormat, A2dpFormat
}
DSP Formats. More...
typedef AudioPlayer::GetAudioBufferFunction | GetAudioBufferFunction
enum Media {
FfsMedia, MmcMedia, RamMedia, RfsMedia,
MmfMedia
}
Media Types. More...
enum | Mode { StandbyMode, TchMode }
Modes. More...
typedef UINT8 | MonoStereoType
typedef UINT8 | SampleRateType
See SetSampleRate().

Public Member Functions

BufferType | GetBuffer (BufferByteType &size)
ConstBufferType | GetBuffer (BufferByteType &size) const
virtual enumClassType | GetClassType () const
virtual UINT16 | GetDelay (void) const
Get the delay in milliseconds that could occur from the first callback call to the first played sample. (Valid in streaming mode only).
DspFormat | GetDspFormat () const
Media | GetMediaType () const
Mode | GetMode () const
MonoStereoType | GetMonoStereoMode () const
See SetMonoStereoMode().
const Path & | GetPath () const
BufferByteType GetRecordedSize ()
SampleRateType | GetSampleRate () const
See SetSampleRate().
BOOLEAN | HasAudio () const
void | SetMonoStereoMode (MonoStereoType val)
void | SetRecordingRate (SampleRateType val)
void | SetSampleRate (SampleRateType val)
virtual | ~StreamAudioReference ()

Static Public Member Functions

static UINT32 | CalculateBufferSize (UINT32 seconds, DspFormat format, SampleRateType rec_rate)
static SharedPtr< StreamAudioReference > | CreateFFS (const String &filename, Mode mode, DspFormat format)
static SharedPtr< StreamAudioReference > | CreateFile (const Path &filename, Mode mode, DspFormat format)
static SharedPtr< StreamAudioReference > | CreateRam (ConstBufferType buffer, BufferByteType buffer_size, Mode mode, DspFormat format)
static SharedPtr< StreamAudioReference > | CreateRam (BufferType buffer, BufferByteType buffer_size, Mode mode, DspFormat format)
static SharedPtr< StreamAudioReference > | CreateStream (Mode mode, DspFormat format, GetAudioBufferFunction func, void *user_data=0)
static SharedPtr< StreamAudioReference > | CreateVoiceRecognition ()
static SharedPtr< StreamAudioReference > | MmfCreateStream (Mode mode, DspFormat format, GetAudioBufferFunction func, void *user_data=0, BOOLEAN has_audio=TRUE)

Protected Member Functions

void | CloseFile ()
BOOLEAN | CreateFile ()
void | InitDataOffset ()
BOOLEAN | OpenFile ()
void | SetRecordedSize (BufferByteType rec_size)
StreamAudioReference ()
For use by derived classes only.
StreamAudioReference (Mode mode, DspFormat format)
Constructor for streaming mode.
StreamAudioReference (const String &filename, Mode mode, DspFormat format)
Constructor for File(RFS).
StreamAudioReference (BufferType buffer_handle, BufferByteType buffer_size, Mode mode, DspFormat format)
Constructor for RAM buffer.
StreamAudioReference (const Path &filename, Mode mode, DspFormat format)
Constructor for Path(RFS).

Static Protected Member Functions

static SharedPtr< StreamAudioReference > | Create (const String &fName, BufferType buffer, BufferByteType buffer_size, Mode mode, Media media_type, DspFormat format)
static SharedPtr< StreamAudioReference > | Create (Mode mode, Media media_type, DspFormat format)
The extended function providing a way to create any kind of streaming reference.

Protected Attributes

BufferType m_buffer
BufferByteType m_buffer_size
UINT32 | m_data_offset
Size of the header - so far only used in PCM.
FilePtr m_file_handle
The RFS file handle.
DspFormat m_format
Audio data format.
BOOLEAN | m_has_audio
Media m_media_type
The media type.
Mode m_mode
The playing mode.
MonoStereoType m_mono_stereo_mode
Mode: Tells whether the data are stereo, mono or dual mono(if supported).
Path m_path
The file path.
SampleRateType m_sample_rate
The recording rate.

Friends

class | AudioPriorityManager
class | MP3AudioPlayer
class | PCMAudioPlayer
class | StreamAudioPlayer
class | VoiceMemoAudioPlayer

Detailed Description

A reference to all "streamable" data formats (AMR, PCM, MP3)

Member Typedef Documentation

typedef UINT32 StreamAudioReference::BufferByteType

typedef AudioPlayer::Buffer StreamAudioReference::BufferType

typedef AudioPlayer::ConstBuffer StreamAudioReference::ConstBufferType

typedef AudioPlayer::GetAudioBufferFunction StreamAudioReference::GetAudioBufferFunction

Definition of the function to be invoked by the driver to retrieve the buffer pointer and the size when the mode is set to MmfMedia. See CreateStream().

Parameters:
audio_buffer,: The buffer
size,: The size of the buffer
pUserData,: The application specific data
Note:
The Multimedia Framework (MMF) is responsible for allocating and handling the audio buffers required for audio record and playback. The audio driver invokes this function periodically to retrieve the audio data. During playback, the audio driver invokes this function, when the audio data has to be retrieved to playback. It is also invoked when the audio data from the previous buffer has been played and is time to retrieve a new buffer with new audio data. During recording, the audio driver invokes the provided function to retrieve an empty buffer along with the buffer size, to store the recorded data. When the current buffer is about to be finished, the audio driver invokes this function once again to retrieve a new buffer. The buffer address and the buffer size should be returned immediately by MMF, else synchronization will be lost. The buffer size should be at least one frame data. The callback function is called until the application explicitly call either StreamAudioPlayer::StopRecord() or AudioActiveReference::Stop() functions or if the size of the buffer returned by the callback function is 0 and the buffer is different from NULL. If a NULL pointer is returned as the buffer pointer, then the play/record will not be stopped, a noise might be heard in that case and the function will be called again

The buffer must at least have a size so it can hold data for one frame.
For PCM one frame max. is 1280 bytes, for AMR one frame max is 34 bytes, and for MP3 it is 1042 bytes.
To ensure that the client has enough time to copy data to the buffer a bigger buffer is however needed. On the other side the buffer should not take up the entire RAM, i.e. the buffer size should be a trade off between RAM usage and time for the client to finish coping data to the buffer. Data equivalent to 100 msec would properly be an OK compromise, i.e. for the worst case scenario which would be PCM 48 kHz 16 bit stereo, the buffer size should be 20480 bytes.

typedef UINT8 StreamAudioReference::MonoStereoType

typedef UINT8 StreamAudioReference::SampleRateType

See SetSampleRate().

Member Enumeration Documentation

enum StreamAudioReference::DspFormat

DSP Formats.

Enumerator:
PcmDspFormat | PCM.
AdpcmDspFormat | ADPCM (not yet supported).
WaveDspFormat | Wave (only PCM).
FrDspFormat | AMR Full Rate.
AmrDspFormat | Adaptive Multi-Rate.
MP3DspFormat | MP3.
A2dpFormat | Bluetooth Advanced Audio Distribution Profile.

enum StreamAudioReference::Media

Media Types.

Enumerator:
FfsMedia | Record or Play the memo to/from the Flash File System.
MmcMedia | Record or Play the memo to/from MMC (might not be supported by the hardware).
RamMedia | Record or Play the memo to/from RAM buffer. See SetSampleRate().
RfsMedia | Record or play the memo to/from RFS.
MmfMedia | Record or playback using multimedia framework.

enum StreamAudioReference::Mode

Modes.

Enumerator:
StandbyMode | Standby mode. Use this when no call is active.
TchMode | Traffic Channel mode. Use this during a call.

Constructor & Destructor Documentation

StreamAudioReference::~StreamAudioReference ( ) [virtual]

StreamAudioReference::StreamAudioReference | ( | const Path & | filename,
 |  | Mode | mode,
 |  | DspFormat | format
 | ) | [protected]

Constructor for Path(RFS).

StreamAudioReference::StreamAudioReference | ( | BufferType | buffer_handle,
 |  | BufferByteType | buffer_size,
 |  | Mode | mode,
 |  | DspFormat | format
 | ) | [protected]

Constructor for RAM buffer.

StreamAudioReference::StreamAudioReference | ( | const String & | filename,
 |  | Mode | mode,
 |  | DspFormat | format
 | ) | [protected]

Constructor for File(RFS).

StreamAudioReference::StreamAudioReference | ( | Mode | mode,
 |  | DspFormat | format
 | ) | [protected]

Constructor for streaming mode.

StreamAudioReference::StreamAudioReference ( ) [protected]

For use by derived classes only.

Member Function Documentation

UINT32 StreamAudioReference::CalculateBufferSize | ( | UINT32 | seconds,
 |  | DspFormat | format,
 |  | SampleRateType | rec_rate
 | ) | [static]

Calculates the size of the buffer required by this format. This is just a convenience function. You could do the calculation yourself instead very easily.

Parameters:
seconds. | The duration of the voice memo recording, in seconds.
format. | See CreateRam().
rec_rate | The Sample rate. See SetSampleRate().
Returns:
The required buffer size. Returns 0 if the input paramters were invalid.

void StreamAudioReference::CloseFile ( ) [protected]

SharedPtr< StreamAudioReference > StreamAudioReference::Create | ( | const String & | fName,
 |  | BufferType | buffer,
 |  | BufferByteType | buffer_size,
 |  | Mode | mode,
 |  | Media | media_type,
 |  | DspFormat | format
 | ) | [static, protected]

static SharedPtr<StreamAudioReference> StreamAudioReference::Create | ( | Mode | mode,
 |  | Media | media_type,
 |  | DspFormat | format
 | ) | [static, protected]

The extended function providing a way to create any kind of streaming reference.

SharedPtr< StreamAudioReference > StreamAudioReference::CreateFFS | ( | const String & | filename,
 |  | Mode | mode,
 |  | DspFormat | format
 | ) | [static]

This function is obsolete. Use CreateFile() function instead. Create a reference to audio data to be played from, or recorded to, a Flash File System file.

Parameters:
filename The path to the flash file system file.
mode,: The play/recording mode (ignored in case of MP3 data)
format,: Decoder/player used.
Returns:
A pointer to StreamAudioReference.

BOOLEAN StreamAudioReference::CreateFile ( ) [protected]

SharedPtr< StreamAudioReference > StreamAudioReference::CreateFile | ( | const Path & | filename,
 |  | Mode | mode,
 |  | DspFormat | format
 | ) | [static]

Create a reference to data to be played from, or recorded to, a Root File System file.

Parameters:
filename The path to the root file system file.
mode,: Sound format of the data.
format,: Decoder used.
Returns:
A pointer to StreamAudioReference.
This function is used for an Stream Audio Reference creation in RFS. This function supports FFS and MMC . This function should be called instead of CreateFFS.

SharedPtr< StreamAudioReference > StreamAudioReference::CreateRam | ( | ConstBufferType | buffer,
 |  | BufferByteType | buffer_size,
 |  | Mode | mode,
 |  | DspFormat | format
 | ) | [static]

Create a reference to audio data to be played from a RAM buffer.

Parameters:
buffer,: File handle/ buffer depending on media_type
buffer_size,: The number of bytes of data pointed to by buffer if media_type is RamMedia.
mode,: The playing mode (ignored in case of MP3 data)
format,: Decoder used.
Returns:
A pointer to StreamAudioReference.
This function is used for an Stream Audio Reference creation in RAM.

SharedPtr< StreamAudioReference > StreamAudioReference::CreateRam | ( | BufferType | buffer,
 |  | BufferByteType | buffer_size,
 |  | Mode | mode,
 |  | DspFormat | format
 | ) | [static]

Create a reference to audio data to be recorded to a RAM buffer.

Parameters:
buffer,: File handle/ buffer depending on media_type
buffer_size,: The number of bytes of data pointed to by buffer if media_type is RamMedia.
mode,: The recording mode (ignored in case of MP3 data)
format,: Decoder used.
Returns:
A pointer to StreamAudioReference.
This function is used for an Stream Audio Reference creation in RAM.

SharedPtr< StreamAudioReference > StreamAudioReference::CreateStream | ( | Mode | mode,
 |  | DspFormat | format,
 |  | GetAudioBufferFunction | func,
 |  | void * | user_data = 0
 | ) | [static]

Create a reference to audio data to be played or recorded in streaming mode

Parameters:
mode,: The play/recording mode (ignored in case of MP3 data)
format,: Used decoder.
func,: The callback function given during the initialization of the stream reference will be called by the driver to fetch new data.
user_data,: The application specific data. Neither APOXI nor driver will alter this data.
Returns:
A pointer to StreamAudioReference.
An example how to playback a streaming reference is shown bellow:
 // The MMF side implements a class that will handle the callback function

 class StreamingPlayback
 {
    public:
    // This is the function called by the driver
    static void OnStreamingGetBuffer(UINT8** audio_buffer, UINT16* size, void* pUserData);
 };

 void StreamingPlayback::OnStreamingGetBuffer(UINT8** audio_buffer, UINT16* size, void* pUserData)
 {
 // fill in the buffer and pass back the control to the driver as fast as possible
 }

 //Create a streaming reference to the sound:
 SharedPtr<StreamAudioReference> stream_ref =  StreamAudioReference::CreateStream(mode, dsp_format, &StreamingPlayback::OnStreamingGetBuffer);
 SharedPtr<AudioReference> p_ref = SharedPtr<AudioReference>(&(*stream_ref)); // manual cast because SharedPtr & compiler can't do it

 //Get the appropiate player
 AudioPlayer* p_player = AudioDeviceManager::GetInstance().GetAudioPlayer(*p_ref);

 //Ask the AudioPlayer to play it with an appropriate Player:
 SharedPtr<AudioActiveReference> playing_ref = AudioDeviceManager::Play(*p_ref);
 After starting the playback the OnStreamingGetBuffer will be called by the driver
 // After a while you can call
 if(playing_ref) //If a suitable player was available and the play started successfuly.
 {
   //Pass the playing_ref around and eventually say:
   playing_ref->Stop();
 }

SharedPtr< StreamAudioReference > StreamAudioReference::CreateVoiceRecognition ( ) [static]

Create a reference to audio data to be recorded for voice recognition

Returns:
A pointer to StreamAudioReference.
The reference created should only be used for recording. An example how to record is shown bellow:
  SharedPtr<StreamAudioReference> vr_ref = StreamAudioReference::CreateVoiceRecognition();

  StreamAudioPlayer* p_player = (StreamAudioPlayer*)AudioDeviceManager::GetInstance().GetAudioPlayer(*vr_ref);

  SharedPtr<AudioActiveReference> p_play_ref = p_player->Record(*vr_ref);

  //Due to some OS limitations regarding usage of semaphores in the context oh HISR, the StreamAudioPlayer::StopRecord function
  //cannot be invoked from the callback function!!!
  //The posibilities to stop the recording session are as follows:
  // a) Pass 0 size and buffer different than NULL
  // b) Notify the application that it has to stop the recording
  //  PSEUDO_CODE (NOTIFY_APP_STOP_RECORDING)

Voice recognition data (training and recognition) is recorded in PCM format and can be played from RAM or file. PCM format for voice recognition is allways the same. Mode is mono, sample rate 8KHz, bit rate 16.
An example how to play from RAM and file is shown bellow:
  //if playing from RAM use CreateRAM
  SharedPtr<StramAudioReference> vr_ref = StreamAudioReference::CreateRAM(buffer, buffer_size,
        StreamAudioReference::StandbyMode, StreamAudioReference::PcmDspFormat);

  //if playing from file use CreateFile
  SharedPtr<StramAudioReference> vr_ref = StreamAudioReference::CreateFile(file_name,
    StreamAudioReference::StandbyMode, StreamAudioReference::PcmDspFormat);

  //mono mode, sample rate 8KHz and bit rate 16 are default values so there is no need to set them

  SharedPtr<AudioActiveReference> p_play_ref = AudioDeviceManager::Play(*vr_ref);

  //Playback can be stopped in this way:

  p_play_ref->Stop();

StreamAudioReference::BufferType StreamAudioReference::GetBuffer ( BufferByteType & size )

StreamAudioReference::ConstBufferType StreamAudioReference::GetBuffer ( BufferByteType & size ) const

AudioReference::enumClassType StreamAudioReference::GetClassType ( ) const [virtual]

Implements AudioReference.

UINT16 StreamAudioReference::GetDelay ( void ) const [virtual]

Get the delay in milliseconds that could occur from the first callback call to the first played sample. (Valid in streaming mode only).

StreamAudioReference::DspFormat StreamAudioReference::GetDspFormat ( ) const

StreamAudioReference::Media StreamAudioReference::GetMediaType ( ) const

StreamAudioReference::Mode StreamAudioReference::GetMode ( ) const

StreamAudioReference::MonoStereoType StreamAudioReference::GetMonoStereoMode ( ) const

See SetMonoStereoMode().

const Path& StreamAudioReference::GetPath ( ) const [inline]

StreamAudioReference::BufferByteType StreamAudioReference::GetRecordedSize ( )

Returns the number of the recorded bytes in buffer. (Only valid if recording). When streaming mode is selected then it will provide the number of bytes that have been recorded in the last buffer passed through the callback function. See GetAudioBufferFunction.

StreamAudioReference::SampleRateType StreamAudioReference::GetSampleRate ( ) const

See SetSampleRate().

BOOLEAN StreamAudioReference::HasAudio ( ) const

Returns a flag that specifies whether the reference will provide any audio data to be played or not. See MmfCreateStream()

Returns:
Returns TRUE when data will be given to be rendered

void StreamAudioReference::InitDataOffset ( ) [protected]

SharedPtr< StreamAudioReference > StreamAudioReference::MmfCreateStream | ( | Mode | mode,
 |  | DspFormat | format,
 |  | GetAudioBufferFunction | func,
 |  | void * | user_data = 0,
 |  | BOOLEAN | has_audio = TRUE
 | ) | [static]

Create a reference to audio data to be played or recorded in streaming mode

Parameters:
mode,: The play/recording mode (ignored in case of MP3 data)
format,: Used decoder.
func,: The callback function given during the initialization of the stream reference will be called by the driver to fetch new data.
pUserData,: The application specific data. Neither APOXI nor driver will alter this data.
hasAudio,: Indicates whether the newly created reference has audio data attached or not. Setting this value to FALSE is a very special
case when for instance a .3gp file that contains video only is played. The creation of audio reference is still necessary to be able to prioritize this playback.
Returns:
A pointer to StreamAudioReference.

BOOLEAN StreamAudioReference::OpenFile ( ) [protected]

void StreamAudioReference::SetMonoStereoMode ( MonoStereoType val )

Sets the MonoSteroMode

DspFormat::PcmDspFormat

0: PCM data are in stereo
1: PCM data are in mono (default)
2: PCM data are in mono, but they should be played in both left and right channel

DspFormat::AdpcmDspFormat(Not yet supported)

To be defined

DspFormat::AmrDspFormat - Not supported

void StreamAudioReference::SetRecordedSize ( BufferByteType rec_size ) [protected]

void StreamAudioReference::SetRecordingRate ( SampleRateType val )

Sets the recording rate(obsolete, use SetSampleRate instead)

void StreamAudioReference::SetSampleRate ( SampleRateType val )

Sets the sample rate.

Parameters:
val The sample rate depending on the data type.
Default value is 0. This value is only used when recording the PCM and AMR data and playing raw PCM data. When playing data like MP3, Wave or AMR the information about sample rate is in the header and this value is ignored.

DspFormat::PcmDspFormat

0: 8 kHz
1: 11.025 kHz
2: 12 kHz
3: 16 kHz
4: 22.05 kHz
5: 24 kHz
6: 32 kHz
7: 44.1 kHz
8: 48 kHz

For PCM record: Only 8 kHz and 16 kHz(not yet supported) are possible

DspFormat::AdpcmDspFormat(Not yet supported)

To be defined

DspFormat::AmrDspFormat only used for recording, see the bellow table
Rate | Sampling rate [kBit/sec] | Bytes pr. Speech frame | Bytes pr. Sec. | Bytes pr. Minute
0 | 4,75 | 13 | 650 | 38,1 KB
1 | 5,15 | 14 | 700 | 41,0 KB
2 | 5,90 | 16 | 800 | 46,9 KB
3 | 6,70 | 18 | 900 | 52,7 KB
4 | 7,40 | 20 | 1000 | 58,6 KB
5 | 7,95 | 21 | 1050 | 61,5 KB
6 | 10,20 | 27 | 1350 | 79,1 KB
7 | 12,20 | 32 | 1600 | 93,8 KB
Full rate | Full rate | 34 | 1700 | 99,6 KB

Friends And Related Function Documentation

friend class AudioPriorityManager [friend]

Reimplemented from AudioReference.

friend class MP3AudioPlayer [friend]

friend class PCMAudioPlayer [friend]

friend class StreamAudioPlayer [friend]

friend class VoiceMemoAudioPlayer [friend]

Field Documentation

BufferType StreamAudioReference::m_buffer [protected]

BufferByteType StreamAudioReference::m_buffer_size [protected]

UINT32 StreamAudioReference::m_data_offset [protected]

Size of the header - so far only used in PCM.

FilePtr StreamAudioReference::m_file_handle [protected]

The RFS file handle.

DspFormat StreamAudioReference::m_format [protected]

Audio data format.

BOOLEAN StreamAudioReference::m_has_audio [protected]

Media StreamAudioReference::m_media_type [protected]

The media type.

Mode StreamAudioReference::m_mode [protected]

The playing mode.

MonoStereoType StreamAudioReference::m_mono_stereo_mode [protected]

Mode: Tells whether the data are stereo, mono or dual mono(if supported).

Path StreamAudioReference::m_path [protected]

The file path.

SampleRateType StreamAudioReference::m_sample_rate [protected]

The recording rate.

The documentation for this class was generated from the following files:
  • Audio/StreamAudioReference.hpp
  • Audio/StreamAudioReference.cpp
Generated on Wed Jan 25 02:06:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamingCallback Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamingCallback Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/StreamingCallback.hpp>

Public Member Functions

virtual void | Callback (StreamingInfo &info)=0
virtual void | CallbackRead (StreamingReadInfo &read_info)=0
virtual void | CallbackWrite (StreamingWriteInfo &write_info)=0
StreamingCallback ()
virtual | ~StreamingCallback ()

Detailed Description

StreamingCallback is a generic interface for components receiving the callbacks of streaming operations. For a read operation the CallbackRead, for a write operation the CallbackWrite, and for all other operations, e.g. opening, closing, etc., the Callback method is called.

The callbacks sends various information about the streaming operation, in particular, the state of operation, the data of read and write operations, error messages and the like.

See also:
StreamingInfo, StreamingReadInfo, StreamingWriteInfo

Constructor & Destructor Documentation

StreamingCallback::StreamingCallback ( )

Default costructor

virtual StreamingCallback::~StreamingCallback ( ) [virtual]

Virtual destructor

Member Function Documentation

virtual void StreamingCallback::Callback ( StreamingInfo & info ) [pure virtual]

Callback methods for the any operation, except read and write

Parameters:
info [in/out] the object containing result information about the operation

virtual void StreamingCallback::CallbackRead ( StreamingReadInfo & read_info ) [pure virtual]

Callback methods for read operations by stream readers

Parameters:
read_info [in/out] the object containing result information about the read operation

virtual void StreamingCallback::CallbackWrite ( StreamingWriteInfo & write_info ) [pure virtual]

Callback methods for write operations by stream writers

Parameters:
write_info [in/out] the object containing result information about the write operation

The documentation for this class was generated from the following file:
  • Auxiliary/StreamingCallback.hpp
Generated on Wed Jan 25 02:06:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamingInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamingInfo Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/StreamingInfo.hpp>

Inheritance diagram for StreamingInfo:

[legend]
Collaboration diagram for StreamingInfo:

[legend]

Public Types

enum OperationState {
OperationCompletedSynchroneously, OperationCompleted, OperationNotCompleted, OperationErroneous,
OperationFailed, OperationNotSupported, OperationOtherState
}

Public Member Functions

UINT32 | GetDeviceErrorCode () const
String | GetErrorMessage () const
OperationState | GetOperationState () const
BOOLEAN | IsOperationCompleted () const
BOOLEAN | IsOperationCompletedSynchroneously () const
BOOLEAN | IsOperationErroneous () const
BOOLEAN | IsOperationFailed () const
void | SetDeviceErrorCode (INT32 error_code)
void | SetErrorMessage (const String &error_msg)
void | SetOperationState (OperationState op_state)
StreamingInfo ()
~StreamingInfo ()

Detailed Description

StreamingInfo is used to provide and receive information on a streaming operations. It contains the state of the operation, error messages, and device specific error codes. Use this info class for all streaming operations except for read and write operations.

Member Enumeration Documentation

enum StreamingInfo::OperationState

Enumeration for states of streaming operations.

Enumerator:
OperationCompletedSynchroneously | Operation has been completed synchroneously.
OperationCompleted | Operation has been completed.
OperationNotCompleted | Operation has not been completed so far.
OperationErroneous | Errors have occurred during the operation.
OperationFailed | Operation has failed completely.
OperationNotSupported
OperationOtherState

Constructor & Destructor Documentation

StreamingInfo::StreamingInfo ( )

Default constructor

StreamingInfo::~StreamingInfo ( )

Destructor

Member Function Documentation

UINT32 StreamingInfo::GetDeviceErrorCode ( ) const [inline]

Gives the device specific error code for errors occurred in the streaming operation

Returns:
the error code for the streaming operation

String StreamingInfo::GetErrorMessage ( ) const [inline]

Gives the error message for errors occurred in the streaming operation

Returns:
the error message for the streaming operation

OperationState StreamingInfo::GetOperationState ( ) const [inline]

Gives the state information about the streaming operation

Returns:
the state information about the streaming operation

BOOLEAN StreamingInfo::IsOperationCompleted ( ) const

Tests if the operation has been completed. Is equal to GetOperationsState() == StreamingCompleted.

Returns:
TRUE if operation has been completed, FALSE otherwise.

BOOLEAN StreamingInfo::IsOperationCompletedSynchroneously ( ) const

Tests if the operation has been completed synchroneously. Is equal to GetOperationsState() == StreamingCompletedSynchroneously.

Returns:
TRUE if operation has been completed synchroneously, FALSE otherwise.

BOOLEAN StreamingInfo::IsOperationErroneous ( ) const

Shows if an error has occurred in the streaming operations . Is equal to GetOperationsState() == StreamingErroneous.

Returns:
TRUE if an error has occurred, FALSE otherwise.

BOOLEAN StreamingInfo::IsOperationFailed ( ) const

Shows if the operation has failed and cannot be completed. Is equal to GetOperationsState() == StreamingFailed.

Returns:
TRUE if operation has failed, FALSE otherwise.

void StreamingInfo::SetDeviceErrorCode ( INT32 error_code ) [inline]

Sets the device specific error code for the streaming operation.

Parameters:
error_code [in] the error code

void StreamingInfo::SetErrorMessage ( const String & error_msg ) [inline]

Sets an error message for the streaming operation.

Parameters:
error_msg [in] the error message

void StreamingInfo::SetOperationState ( OperationState op_state ) [inline]

Sets the operation state for the streaming result

Parameters:
op_state [in] the operation state

The documentation for this class was generated from the following files:
  • Auxiliary/StreamingInfo.hpp
  • Auxiliary/StreamingInfo.cpp
Generated on Wed Jan 25 02:06:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamingReadInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamingReadInfo Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/StreamingReadInfo.hpp>

Inheritance diagram for StreamingReadInfo:

[legend]
Collaboration diagram for StreamingReadInfo:

[legend]

Public Member Functions

BOOLEAN | EndOfStream () const
UINT32 | GetAvailableByteCount () const
void * | GetDataRead () const
UINT32 | GetRequestedByteCount () const
void | SetAvailableByteCount (UINT32 available_byte_count)
void | SetDataRead (void *data)
void | SetEndOfStream (BOOLEAN eos)
void | SetRequestedByteCount (UINT32 requested_byte_count)
StreamingReadInfo (UINT32 requested_byte_count=0)
~StreamingReadInfo ()

Detailed Description

StreamingReadInfo is the info object for holding all the information about a read operation. It inherits the properties from base class StreamingInfo and additionally defines properties for holding the pointer to the data to read, for the number of bytes requested in the read operation, for the number of bytes actually available for reading, and to signal end of stream. Use this calls for read operations only.

Constructor & Destructor Documentation

StreamingReadInfo::StreamingReadInfo ( UINT32 requested_byte_count = 0 )

Constructor with parameter for the number of bytes requested in the read operation

Parameters:
requested_byte_count [in] number of bytes requested in the read operation

StreamingReadInfo::~StreamingReadInfo ( )

Destructor

Member Function Documentation

BOOLEAN StreamingReadInfo::EndOfStream ( ) const [inline]

Tests if an end of stream has occurred (only for read operation).

Returns:
TRUE if end of stream occurred, FALSE otherwise.

UINT32 StreamingReadInfo::GetAvailableByteCount ( ) const [inline]

Gets the number of bytes actually available for reading.

Returns:
number of bytes available for reading

void* StreamingReadInfo::GetDataRead ( ) const [inline]

Gets the pointer to the data read

UINT32 StreamingReadInfo::GetRequestedByteCount ( ) const [inline]

Gets the number of bytes requested to be read by this read operation. The callback from the stream reader will occur, when the number of bytes are available. If this property is 0, the callback will occur as soon as any number of bytes are available.

Returns:
number of bytes requested in this read operation

void StreamingReadInfo::SetAvailableByteCount ( UINT32 available_byte_count ) [inline]

Sets the number of bytes acutally available for reading.

Parameters:
available_byte_count [in] number of bytes available for reading

void StreamingReadInfo::SetDataRead ( void * data ) [inline]

Sets the pointer to the data to the data read.

Parameters:
data the pointer to the data

void StreamingReadInfo::SetEndOfStream ( BOOLEAN eos ) [inline]

Sets if end of stream has occurred.

Parameters:
eos [in] the end of stream state

void StreamingReadInfo::SetRequestedByteCount ( UINT32 requested_byte_count ) [inline]

Sets the number of bytes requested in this read operation. The callback from the stream reader will occur, when the number of bytes are available. If this property is 0 the callback will occur as soon as any number of bytes are available.

Parameters:
requested_byte_count [in] number of bytes requested in this read operation

The documentation for this class was generated from the following files:
  • Auxiliary/StreamingReadInfo.hpp
  • Auxiliary/StreamingReadInfo.cpp
Generated on Wed Jan 25 02:06:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamingWriteInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamingWriteInfo Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/StreamingWriteInfo.hpp>

Inheritance diagram for StreamingWriteInfo:

[legend]
Collaboration diagram for StreamingWriteInfo:

[legend]

Public Member Functions

void * | GetDataToWrite () const
UINT32 | GetWriteByteCount () const
UINT32 | GetWrittenByteCount () const
void | SetDataToWrite (void *data)
void | SetWriteByteCount (UINT32 write_byte_count)
void | SetWrittenByteCount (UINT32 written_byte_count)
StreamingWriteInfo (void *data_to_write=0, UINT32 write_byte_count=0)
~StreamingWriteInfo ()

Detailed Description

StreamingWriteInfo is the info object for holding all the information about a write operation. It inherits the properties from base class StreamingInfo and additionally defines properties for holding the pointer to the data to write, for the number of bytes to write, and for the number of bytes actually written. Use this calls for write operations only.

Constructor & Destructor Documentation

StreamingWriteInfo::StreamingWriteInfo | ( | void * | data_to_write = 0,
 |  | UINT32 | write_byte_count = 0
 | ) |

Constructor initializing the pointer to the data and the number of bytes to write.

Parameters:
data_to_write | [in] pointer to the data to write
write_byte_count | [in] number of bytes to write

StreamingWriteInfo::~StreamingWriteInfo ( )

Destructor

Member Function Documentation

void* StreamingWriteInfo::GetDataToWrite ( ) const [inline]

Gets the pointer to the data to write

UINT32 StreamingWriteInfo::GetWriteByteCount ( ) const [inline]

Gets the number of bytes to write in this write operation.

UINT32 StreamingWriteInfo::GetWrittenByteCount ( ) const [inline]

Gets the number of bytes actually read in this read operation.

void StreamingWriteInfo::SetDataToWrite ( void * data ) [inline]

Sets the pointer to the data to the data to write.

Parameters:
data the pointer to the data

void StreamingWriteInfo::SetWriteByteCount ( UINT32 write_byte_count ) [inline]

Sets the number of bytes to write in this write operation.

Parameters:
nr_bytes_to_write [in] number of bytes to write in write operation

void StreamingWriteInfo::SetWrittenByteCount ( UINT32 written_byte_count ) [inline]

Sets the number of bytes acutally written in this write operation.

Parameters:
nr_bytes_written [in] number of bytes actually written in this write operation

The documentation for this class was generated from the following files:
  • Auxiliary/StreamingWriteInfo.hpp
  • Auxiliary/StreamingWriteInfo.cpp
Generated on Wed Jan 25 02:06:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamObexImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamObexImpl Class Reference

#include <Apoxi/AddOns/StreamObex/StreamObexImpl.hpp>

Inheritance diagram for StreamObexImpl:

[legend]
Collaboration diagram for StreamObexImpl:

[legend]

Public Types

enum | Error { SUCCESS = 0, FAIL = 1 }

Public Member Functions

virtual void | Abort (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Aborts an ongoing OBEX client operation.
virtual ObexResult | AcquireClientChannel (ObexChannel &result, const ObexAddrPtr &addr_ptr, BOOLEAN reserve)
Abstract factory method for client transport channels.
virtual ObexResult | AcquireServerChannel (ObexChannel &result, const ObexAddrPtr &addr_ptr, BOOLEAN reserve)
Abstract factory method for server transport channels.
Error | BeginOperation (const ObexChannel &channel)
virtual void | BindServerChannel (const ObexChannel &server_chan, ObexOperationId oper_id, const ObexAddrPtr &addr_ptr)
Binds a server transport channel to an OBEX address.
virtual void | CloseChannel (const ObexChannel &server_chan, ObexOperationId oper_id)
Closes a transport channel.
virtual void | Connect (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Starts an OBEX CONNECT operation.
void | Create ()
create emcpp wrapper
ObexBuffer * | CreateBuffer (const ObexChannel &channel, unsigned short expected_packet_size)
virtual void | DataProcessed (const ObexChannel &client_chan, ObexOperationId oper_id, ObexBuffer &buffer)
Confirm processing of data delivered to an application.
void | Destroy ()
destroy usb transport layer
virtual void | Disconnect (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Starts an OBEX DISCONNECT operation.
Error | EndOperation (const ObexChannel &channel, ObexResult::ErrorCode oper_result)
void | FinalizeBuffer (const ObexChannel &channel)
virtual void | Get (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Starts or continues an OBEX GET operation.
ObexOperationId | GetOperationId (const ObexChannel &channel)
void | GetRequestBuffer (const ObexChannel &channel, ObexBuffer &buffer)
StreamObexTransport & GetTransport ()
void | HandleAbort (const ObexChannel &channel, const ObexObject &object)
void | HandleConnect (const ObexChannel &channel, const ObexObject &object)
void | HandleDisconnect (const ObexChannel &channel, const ObexObject &object)
void | HandleGet (const ObexChannel &channel, const ObexObject &object)
void | HandlePut (const ObexChannel &channel, const ObexObject &object)
void | HandleSetPath (const ObexChannel &channel, const ObexObject &object)
void | HandleTransportDisconnect (const ObexChannel &channel)
void | Init ()
initializes usb transport layer implementation
INT | IsOperationActive (const ObexChannel &channel)
virtual void | OpenClientChannel (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexAddrPtr &addr_ptr)
Opens an OBEX client transport channel.
virtual void | Put (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Starts or continues an OBEX PUT operation.
virtual ObexResult | ReleaseChannel (ObexChannel &channel)
Releases an ObexChannel.
virtual void | ReturnResponse (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Sends a response to a client request.
void | ReturnResponseBuffer (const ObexChannel &channel, ObexBuffer &buffer)
virtual void | SetPath (const ObexChannel &client_chan, ObexOperationId oper_id, const ObexObject &conn_req)
Starts an OBEX SETPATH operation.
StreamObexImpl (StreamObexTransport &stream_obex_transport)
Constructor.
virtual | ~StreamObexImpl ()
Destructor.

Member Enumeration Documentation

enum StreamObexImpl::Error

Enumerator:
SUCCESS
FAIL

Constructor & Destructor Documentation

StreamObexImpl::StreamObexImpl ( StreamObexTransport & stream_obex_transport )

Constructor.

StreamObexImpl::~StreamObexImpl ( ) [virtual]

Destructor.

Member Function Documentation

void StreamObexImpl::Abort | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Aborts an ongoing OBEX client operation.

Only a currently pending PUT or GET operation can be aborted, and only clients may issue ABORT requests.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier of the operation to be aborted
abort_req | OBEX object which holds the headers to be included in the ABORT request.

Implements ObexLayer.

ObexResult StreamObexImpl::AcquireClientChannel | ( | ObexChannel & | result,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | BOOLEAN | reserve
 | ) | [virtual]

Abstract factory method for client transport channels.

Must be implemented to return a client channel object for the specified protocol. The Channel object must be unique among all channels of the same transport and protocol. However, the under- lying transport service may be shared with other channels.

Parameters:
result | Reference to a channel object to hold the result. It will be overwritten in case of success.
addr_ptr | Smartpointer holding a valid transport address, necessary to determine whether the channel is unique or not.
Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise (possibly lack of resources).

Implements ObexProtocol.

ObexResult StreamObexImpl::AcquireServerChannel | ( | ObexChannel & | result,
 |  | const ObexAddrPtr & | addr_ptr,
 |  | BOOLEAN | reserve
 | ) | [virtual]

Abstract factory method for server transport channels.

Must be implemented to return a server channel object for the specified protocol. The Channel object must be unique among all channels of the same transport and protocol. However, the under- lying transport service may be shared with other channels.

Parameters:
result | Reference to a channel object to hold the result. It will be overwritten in case of success.
addr_ptr | Smartpointer holding a valid transport address, necessary to determine whether the channel is unique or not.
reserve | If set to TRUE, indicates that private transport resources should be reserved for this channel. However, an implementation may choose to silently ignore this hint.
Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise (possibly lack of resources).

Implements ObexProtocol.

StreamObexImpl::Error StreamObexImpl::BeginOperation ( const ObexChannel & channel )

void StreamObexImpl::BindServerChannel | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexAddrPtr & | addr_ptr
 | ) | [virtual]

Binds a server transport channel to an OBEX address.

The channel must have been previously obtained by calling AcquireServerChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
server_chan | Server transport channel to open.
oper_id | Operation identifier
addr_ptr | Smartpointer holding the OBEX address of the service to connect to

Implements ObexProtocol.

void StreamObexImpl::CloseChannel | ( | const ObexChannel & | server_chan,
 |  | ObexOperationId | oper_id
 | ) | [virtual]

Closes a transport channel.

The channel must have been previously obtained by calling AcquireServerChannel() or AcquireClientChannel(). In case of a client channel, it must have been opened by invoking OpenClientChannel(). In case of a server channel, it must have been bound to a service by invoking BindServerChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
channel | Transport channel to close.
oper_id | Operation identifier

Implements ObexProtocol.

void StreamObexImpl::Connect | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Starts an OBEX CONNECT operation.

The channel must be a valid client channel in state 'OPEN'.

See also:
OpenClientChannel(). The result is delivered asynchronously by means of a call to OnResponse().

OnResponse()

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
conn_req | OBEX object which holds the headers to be included in the CONNECT request and flags according to OBEX Spec. 3.3.1.2, but no data !

Implements ObexLayer.

void StreamObexImpl::Create ( )

create emcpp wrapper

ObexBuffer* StreamObexImpl::CreateBuffer | ( | const ObexChannel & | channel,
 |  | unsigned short | expected_packet_size
 | ) |

void StreamObexImpl::DataProcessed | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | ObexBuffer & | buffer
 | ) | [virtual]

Confirm processing of data delivered to an application.

By calling this method the application layer returns the ownership of a buffer back to the protocol implementation which had produced the buffer and therefore knows how to dispose it.

Implements ObexLayer.

void StreamObexImpl::Destroy ( )

destroy usb transport layer

void StreamObexImpl::Disconnect | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Starts an OBEX DISCONNECT operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
disc_req | OBEX object which holds the headers to be included in the DISCONNECT request.

Implements ObexLayer.

StreamObexImpl::Error StreamObexImpl::EndOperation | ( | const ObexChannel & | channel,
 |  | ObexResult::ErrorCode | oper_result
 | ) |

void StreamObexImpl::FinalizeBuffer ( const ObexChannel & channel )

void StreamObexImpl::Get | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Starts or continues an OBEX GET operation.

Note that in rare cases a GET request may contain a BODY header !

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier.
get_req | OBEX object which holds the headers to be included in the GET request and possibly BODY data within an ObexBuffer.

Implements ObexLayer.

ObexOperationId StreamObexImpl::GetOperationId ( const ObexChannel & channel )

void StreamObexImpl::GetRequestBuffer | ( | const ObexChannel & | channel,
 |  | ObexBuffer & | buffer
 | ) |

StreamObexTransport& StreamObexImpl::GetTransport ( )

void StreamObexImpl::HandleAbort | ( | const ObexChannel & | channel,
 |  | const ObexObject & | object
 | ) |

void StreamObexImpl::HandleConnect | ( | const ObexChannel & | channel,
 |  | const ObexObject & | object
 | ) |

void StreamObexImpl::HandleDisconnect | ( | const ObexChannel & | channel,
 |  | const ObexObject & | object
 | ) |

void StreamObexImpl::HandleGet | ( | const ObexChannel & | channel,
 |  | const ObexObject & | object
 | ) |

void StreamObexImpl::HandlePut | ( | const ObexChannel & | channel,
 |  | const ObexObject & | object
 | ) |

void StreamObexImpl::HandleSetPath | ( | const ObexChannel & | channel,
 |  | const ObexObject & | object
 | ) |

void StreamObexImpl::HandleTransportDisconnect ( const ObexChannel & channel )

void StreamObexImpl::Init ( )

initializes usb transport layer implementation

INT StreamObexImpl::IsOperationActive ( const ObexChannel & channel )

void StreamObexImpl::OpenClientChannel | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexAddrPtr & | addr_ptr
 | ) | [virtual]

Opens an OBEX client transport channel.

The channel must have been previously obtained by calling AcquireClientChannel(). After the operation has been completed, an implementation must call OnComplete() to return the result asynchronously.

See also:
OnComplete()
Parameters:
obex_chan | Channel to open
oper_id | Operation identifier
addr_ptr | Smartpointer holding the OBEX address of the service to connect to

Implements ObexProtocol.

void StreamObexImpl::Put | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Starts or continues an OBEX PUT operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
put_req | OBEX object which holds the headers to be included in the PUT request and possibly BODY data within an ObexBuffer.

Implements ObexLayer.

ObexResult StreamObexImpl::ReleaseChannel ( ObexChannel & channel ) [virtual]

Releases an ObexChannel.

Returns:
'TRUE' in case of success, ObexResult indicating an error otherwise.

Implements ObexProtocol.

void StreamObexImpl::ReturnResponse | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Sends a response to a client request.

Parameters:
server_chan | Server channel associated with the response.
oper_id | Operation identifier of the request to respond to (it was passed along with the request).
server_resp | OBEX object which holds the headers to be included in the response, the response code and possibly BODY data within an ObexBuffer.

Implements ObexLayer.

void StreamObexImpl::ReturnResponseBuffer | ( | const ObexChannel & | channel,
 |  | ObexBuffer & | buffer
 | ) |

void StreamObexImpl::SetPath | ( | const ObexChannel & | client_chan,
 |  | ObexOperationId | oper_id,
 |  | const ObexObject & | conn_req
 | ) | [virtual]

Starts an OBEX SETPATH operation.

Parameters:
client_chan | Client channel associated with the request.
oper_id | Operation identifier
setp_req | OBEX object which holds the headers to be included in the SETPATH request and flags according to OBEX Spec. 3.3.6.1, but no data !

Implements ObexLayer.

The documentation for this class was generated from the following files:
  • AddOns/StreamObex/StreamObexImpl.hpp
  • AddOns/StreamObex/StreamObexImpl.cpp
Generated on Wed Jan 25 02:06:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamObexTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamObexTransport Class Reference

#include <Apoxi/AddOns/StreamObex/StreamObexTransport.hpp>

Inheritance diagram for StreamObexTransport:

[legend]
Collaboration diagram for StreamObexTransport:

[legend]

Public Member Functions

StreamObexImpl & GetStreamObexImpl ()
void | Init (AbstractTransport &device_abs, const CHAR *scheme_url)
returns the instance of StreamObexTransport releases its instance initializes usn transport implementation
virtual | ~StreamObexTransport ()
Operations Destructor.

Protected Member Functions

StreamObexTransport ()

Constructor & Destructor Documentation

StreamObexTransport::~StreamObexTransport ( ) [virtual]

Operations Destructor.

StreamObexTransport::StreamObexTransport ( ) [protected]

Member Function Documentation

StreamObexImpl& StreamObexTransport::GetStreamObexImpl ( ) [inline]

void StreamObexTransport::Init | ( | AbstractTransport & | device_abs,
 |  | const CHAR * | scheme_url
 | ) |

returns the instance of StreamObexTransport releases its instance initializes usn transport implementation

Reimplemented from ObexAbstractTransport.

The documentation for this class was generated from the following files:
  • AddOns/StreamObex/StreamObexTransport.hpp
  • AddOns/StreamObex/StreamObexTransport.cpp
Generated on Wed Jan 25 02:06:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamReader Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamReader Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/StreamReader.hpp>

Public Member Functions

virtual BOOLEAN | CanSeek () const =0
virtual void | Close (StreamingInfo &info)=0
virtual UINT32 | CurrentPosition (StreamingInfo &info) const =0
virtual UINT32 | DataAvailable () const =0
virtual void | DataProcessed (const void *begin_data, UINT32 byte_count)=0
virtual BOOLEAN | IsDataAvailable (UINT32 byte_count) const =0
virtual void | Open (StreamingInfo &info)=0
virtual void | RequestRead (StreamingReadInfo &read_info, const StreamingCallback *callback_object=0)=0
virtual void | Seek (Stream::Origin origin, INT32 offset, StreamingInfo &info)=0
StreamReader ()
virtual | ~StreamReader ()

Detailed Description

StreamReader is a base class for classes implementing a reader from a stream. StreamReaders are accessed from Streams. Subclasses should derived from this base class for the different streams. For example, for a FileStream and corresponding FileStreamReader should be provided.
See also:
StreamWriter

Constructor & Destructor Documentation

StreamReader::StreamReader ( )

Default constructor.

StreamReader::~StreamReader ( ) [virtual]

Virtual destructor

Member Function Documentation

virtual BOOLEAN StreamReader::CanSeek ( ) const [pure virtual]

Tests if this stream reader allows to seek for positions

virtual void StreamReader::Close ( StreamingInfo & info ) [pure virtual]

Closes this stream reader.

Parameters:
info[in/out] the info object which will give information about this operation

virtual UINT32 StreamReader::CurrentPosition ( StreamingInfo & info ) const [pure virtual]

Gets the current position for reading of this input stream.

Parameters:
info[in/out] the info object which will give information about this operation

virtual UINT32 StreamReader::DataAvailable ( ) const [pure virtual]

Gets the size of data available for reading starting at the current position in number of bytes.

Returns:
the data available for reading in number of bytes.

virtual void StreamReader::DataProcessed | ( | const void * | begin_data,
 |  | UINT32 | byte_count
 | ) | [pure virtual]

Informs the stream reader that the data given has been processed and therefore can be discarded.

Parameters:
begin_data | [in] The pointer to the data processed.
byte_count | [in] The number of bytes processed.

virtual BOOLEAN StreamReader::IsDataAvailable ( UINT32 byte_count ) const [pure virtual]

Tests if the number of bytes are available for reading starting at the current position.

Parameters:
byte_count [in] The number of bytes, which should be available.
Returns:
TRUE if available, FALSE otherwise

virtual void StreamReader::Open ( StreamingInfo & info ) [pure virtual]

Opens this stream reader.

Parameters:
info[in/out] the info object which will give information about this operation

virtual void StreamReader::RequestRead | ( | StreamingReadInfo & | read_info,
 |  | const StreamingCallback * | callback_object = 0
 | ) | [pure virtual]

Requests to read the next bytes beginning at the current position.

This is a non-blocking call and the read operation normally is not completed synchroneously. Instead, the stream reader has to respond with a callback CallbackRead to the given call back object callback_object.

The number of bytes to read are given in the read_info object in field nr_bytes_requested. As soon as the requested number of bytes are available, this stream reader is intended to responds with a CallbackRead to the given callback object. However, when the number of bytes requested is set to 0 (!) in the read_info object, the stream reader is intended to respond as soon as any number of bytes are available. Moreover, when the number of bytes cannot be written, the stream reader is intended to respond with an error state.

The result of the operation is stored in read_info, in particular, if the the read operation has been completed synchroneously or not.

See also:
StreamingReadInfo
Parameters:
read_info | [in/out] The info object for the information about the read operation.
callback_object | [in] The object receiving the asynchroneous callback for this read operation

virtual void StreamReader::Seek | ( | Stream::Origin | origin,
 |  | INT32 | offset,
 |  | StreamingInfo & | info
 | ) | [pure virtual]

Shifts the current reading position of this stream reader offset bytes based on the origin, which might be StreamBegin, StreamEnd, StreamCurrent.

Parameters:
origin[in] | the origin of the seek operation
offset[in] | the offset for repositioning relativ to the origin
info[in/out] | the info object which will give information about this operation

The documentation for this class was generated from the following files:
  • Auxiliary/StreamReader.hpp
  • Auxiliary/StreamReader.cpp
Generated on Wed Jan 25 02:06:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StreamWriter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StreamWriter Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/StreamWriter.hpp>

Public Member Functions

virtual BOOLEAN | CanSeek () const =0
virtual void | Close (StreamingInfo &info)=0
virtual UINT32 | CurrentPosition (StreamingInfo &info) const =0
virtual UINT32 | DataAcceptable () const =0
virtual void | Flush (StreamingInfo &info)=0
virtual BOOLEAN | IsDataAcceptable (UINT32 byte_count) const =0
virtual void | Open (StreamingInfo &info)=0
virtual void | RequestWrite (StreamingWriteInfo &write_info, const StreamingCallback *callback_object=0)=0
virtual void | Seek (Stream::Origin origin, INT32 offset, StreamingInfo &info)=0
StreamWriter ()
virtual | ~StreamWriter ()

Detailed Description

StreamWriter is a base class for classes implementing a writer to a stream. StreamWriters are accessed from Streams. Subclasses should derived from this base class for the different streams. For example, for a FileStream and corresponding FileStreamWriter should be provided.
See also:
StreamReader

Constructor & Destructor Documentation

StreamWriter::StreamWriter ( )

Default constructor.

StreamWriter::~StreamWriter ( ) [virtual]

Virtual destructor

Member Function Documentation

virtual BOOLEAN StreamWriter::CanSeek ( ) const [pure virtual]

Tests if this stream writer allows to seek for positions

virtual void StreamWriter::Close ( StreamingInfo & info ) [pure virtual]

Closes this stream writer. Flushes its buffers before.

Parameters:
info [in/out] the info object which will give information about this operation

virtual UINT32 StreamWriter::CurrentPosition ( StreamingInfo & info ) const [pure virtual]

Gets the current position for writing of this stream

Parameters:
info [in/out] the info object which will hold information about this operation

virtual UINT32 StreamWriter::DataAcceptable ( ) const [pure virtual]

Gets the size of data acceptable to be written to the stream writer in number of bytes.

Returns:
the data acceptable to be written in number of bytes.

virtual void StreamWriter::Flush ( StreamingInfo & info ) [pure virtual]

Flushes the stream writer and all its successors.

Parameters:
info [in/out] the info object which will give information about this operation

virtual BOOLEAN StreamWriter::IsDataAcceptable ( UINT32 byte_count ) const [pure virtual]

Tests if the number of bytes are acceptable to be written.

Parameters:
byte_count [in] the number of bytes, which should be written.
Returns:
TRUE if available, FALSE otherwise

virtual void StreamWriter::Open ( StreamingInfo & info ) [pure virtual]

Opens the stream writer and all its successors.

Parameters:
info [in/out] the info object which will give information about this operation

virtual void StreamWriter::RequestWrite | ( | StreamingWriteInfo & | write_info,
 |  | const StreamingCallback * | callback_object = 0
 | ) | [pure virtual]

Requests to write the data given in write_info object to the stream.

This is a non-blocking call and the write operation normally is not completed synchroneously. Instead, this stream writer has to respond with a callback CallbackWrite to the given call back object callback_object.

The data to write is given in the write_info object in fields data_to_write and nr_bytes_to_write. As soon as the requested number of bytes are written, this stream writer is intended to responds with a CallbackWrite to the given callback object. However, when the number of bytes cannot be written, the stream writer is intended to respond with an error state.

The result of the operation is stored in write_info, in particular, if the the read operation has been completed synchroneously or not.

See also:
StreamingWriteInfo
Parameters:
write_info | [in/out] The object holding all the information about the write operation
callback_object | [in] The object receiving the asynchroneous callback for this write operation

virtual void StreamWriter::Seek | ( | Stream::Origin | origin,
 |  | INT32 | offset,
 |  | StreamingInfo & | info
 | ) | [pure virtual]

Shifts the current writing position of this stream writer offset bytes based on the origin, which might be StreamBegin, StreamEnd, StreamCurrent

Parameters:
origin | [in] the origin of the seek operation
offset | [in] the offset for repositioning relativ to the origin
info | [in/out] the info object which will hold information about this operation

The documentation for this class was generated from the following files:
  • Auxiliary/StreamWriter.hpp
  • Auxiliary/StreamWriter.cpp
Generated on Wed Jan 25 02:06:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: String Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

String Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/String.hpp>

Inheritance diagram for String:

[legend]

Public Member Functions

void | Clear ()
Empties the object and sets its size to zero and also frees used memory.
INT | CompareTo (const CHAR *szOther, INT startpos, INT count=-1) const
Returns 0 if the object is equal count characters from startpos to C-string string szOther, <0 if the object is less than C-string szOther, > 0 otherwise.
INT | CompareTo (const CHAR *szOther) const
Returns 0 if String is equal to C-string szOther, <0 if String is less than C-string szOther, > 0 otherwise.
INT | CompareTo (const String &szOther, INT startpos, INT count=-1) const
Returns 0 if the object is equal to String szOther, <0 if String is less than String szOther, > 0 otherwise.
INT | CompareTo (const String &szOther) const
Returns 0 if the object is equal to String szOther, <0 if String is less than String szOther, > 0 otherwise.
BOOLEAN | EndsWith (const String &other) const
Returns TRUE if the other-String matches with the end of the string.
void | Erase (INT from, INT nchars)
Erase nchars substring starting from position from.
void | Erase (INT frompos)
Empties the object from position frompos until its end and adjusts its size.
void | Format (const CHAR *format,...)
Stores a series of characters and values in the object. Syntax is equivalent to printf.
WString | FromUtf8ToWString () const
const CHAR * | GetCString () const
const UINT8 * | GetData () const
Returns the UINT8 * pointer of the content of the object.
INT | GetLength () const
Returns the current number of characters of the object, excluding terminating zero.
INT | GetMemSize () const
Returns the memory needed by the object. This is implementation dependent.
INT | GetSize () const
Returns the current number of used bytes of the object, excluding terminating zero.
INT | IndexOf (const CHAR *searchstr, INT frompos=0) const
INT | IndexOf (const String &searchstr, INT frompos=0) const
INT | IndexOf (CHAR character, INT frompos=0) const
void | Insert (INT pos, const String &szInsert)
Inserts a String at a given position pos.
void | Insert (INT pos, CHAR character)
Inserts a single character at a given position pos.
BOOLEAN | IsEmpty () const
Checks whether the number of characters of the object is zero.
BOOLEAN | IsNumeric (INT number=-1) const
Checks if the string only contains digits '0' to '9', starting at position number.
INT | LastIndexOf (CHAR character, INT frompos=-1) const
operator const CHAR * () const
BOOLEAN | operator!= (const String &szcompare) const
Checks whether the object and szcompare are not identical.
String | operator+ (const CHAR *pchConcat) const
Returnes the concatenation of the object and the zero terminated CHAR string pchConcat.
String | operator+ (const String &szConcat) const
Returnes the concatenation of the object and the szConcat object.
void | operator+= (const WCHAR *pchConcat)
Concatenates the zero terminated WCHAR string to the object.
void | operator+= (const CHAR *pchConcat)
Concatenates the zero terminated CHAR string to the object.
void | operator+= (const WString &szConcat)
Concatenates WString szConcat to the object.
void | operator+= (const String &szConcat)
Concatenates String szConcat to the object.
BOOLEAN | operator< (const String &right) const
Checks whether the object is smaller than right.
String & | operator<< (INT32 number)
Concatenates number to the object. Repetitive use is possible (a << b << c).
String & | operator<< (const WCHAR *right)
Concatenates a zero terminated WCHAR string to the object. Repetitive use is possible (a << b << c).
String & | operator<< (const CHAR *right)
Concatenates a zero terminated CHAR string to the object. Repetitive use is possible (a << b << c).
String & | operator<< (const WString *right)
Concatenates WString right to the object. Repetitive use is possible (a << b << c).
String & | operator<< (const WString &right)
Concatenates WString right to the object. Repetitive use is possible (a << b << c).
String & | operator<< (const String *right)
Concatenates String right to the object. Repetitive use is possible (a << b << c).
String & | operator<< (const String &right)
Concatenates String right to the object. Repetitive use is possible (a << b << c).
BOOLEAN | operator<= (const String &right) const
Checks whether the object is smaller or equal than right.
String & | operator= (const CHAR *pchCopy)
Assigns a new value to the string object based on zero terminated CHAR string.
String & | operator= (const String &szCopy)
Assigns a new value to the string object.
BOOLEAN | operator== (const CHAR *szcompare) const
Checks whether the object and C-string szcompare are identical.
BOOLEAN | operator== (const String &szcompare) const
Checks whether the object and szcompare are identical.
BOOLEAN | operator> (const String &right) const
Checks whether the object is greater than right.
BOOLEAN | operator>= (const String &right) const
Checks whether the object is greater or equal than right.
CHAR | operator[] (INT nPos) const
Returns the character of the object at position nPos.
BOOLEAN | PreAlloc (UINT nchars)
void | Replace (INT pos, CHAR ch)
Replaces character at position pos with ch.
BOOLEAN | Reserve (UINT nchars)
void | Scan (const CHAR *format,...) const
BOOLEAN | StartsWith (const String &other) const
Returns TRUE if the other-String matches with the start of the string.
void | StrCopy (const CHAR *buffer, INT len)
Initializes the object by len characters of a character buffer.
String (CHAR singlechar)
Creates a string object containing one single character.
String (INT32 val)
Creates a string object that is initialized with the string representing val.
String (const String *szCopy)
Creates a string object based on an existing string object.
String (const String &szCopy)
Creates a string object based on an existing string object.
String (const CHAR *pchCopy, UINT len)
Creates a string object based on len characters of a CHAR string.
String (const CHAR *pchCopy)
Creates a string object based on a zero terminated CHAR string.
String ()
Creates an empty string object.
String | Substring (INT nStart, INT nLength=-1) const
void | Swap (String &swapstr)
Exchanges the content of the object and swapstr.
String & ToLower ()
Converts all characters of the object into lower case characters.
String & ToUpper ()
Converts all characters of the object into upper case characters.
WString | ToWString () const
Returns the content of the object as a WString object.
void | VFormat (const CHAR *format, va_list args)
Accepts a pointer to an argument list. Syntax is equivalent to ANSI vprintf.
~String ()
Destroys the string object and free the memory of the character array.

Static Public Member Functions

static INT | Compare (const String &s1, const String &s2)
Returns 0 if the Strings s1 and s2 are equal, < 0 if s1 is less than s2, > 0 otherwise.
static BOOLEAN | IsNumeric (const CHAR *string, INT number=-1)
Checks if the CHAR string only contains digits '0' to '9', starting at position number.

Friends

class | WString

Constructor & Destructor Documentation

String::String ( )

Creates an empty string object.

String::String ( const CHAR * pchCopy )

Creates a string object based on a zero terminated CHAR string.

String::String | ( | const CHAR * | pchCopy,
 |  | UINT | len
 | ) |

Creates a string object based on len characters of a CHAR string.

String::String ( const String & szCopy )

Creates a string object based on an existing string object.

String::String ( const String * szCopy )

Creates a string object based on an existing string object.

String::String ( INT32 val )

Creates a string object that is initialized with the string representing val.

String::String ( CHAR singlechar )

Creates a string object containing one single character.

String::~String ( )

Destroys the string object and free the memory of the character array.

Member Function Documentation

void String::Clear ( )

Empties the object and sets its size to zero and also frees used memory.

static INT String::Compare | ( | const String & | s1,
 |  | const String & | s2
 | ) | [inline, static]

Returns 0 if the Strings s1 and s2 are equal, < 0 if s1 is less than s2, > 0 otherwise.

INT String::CompareTo | ( | const CHAR * | szOther,
 |  | INT | startpos,
 |  | INT | count = -1
 | ) | const

Returns 0 if the object is equal count characters from startpos to C-string string szOther, <0 if the object is less than C-string szOther, > 0 otherwise.

INT String::CompareTo ( const CHAR * szOther ) const [inline]

Returns 0 if String is equal to C-string szOther, <0 if String is less than C-string szOther, > 0 otherwise.

INT String::CompareTo | ( | const String & | szOther,
 |  | INT | startpos,
 |  | INT | count = -1
 | ) | const [inline]

Returns 0 if the object is equal to String szOther, <0 if String is less than String szOther, > 0 otherwise.

INT String::CompareTo ( const String & szOther ) const [inline]

Returns 0 if the object is equal to String szOther, <0 if String is less than String szOther, > 0 otherwise.

BOOLEAN String::EndsWith ( const String & other ) const

Returns TRUE if the other-String matches with the end of the string.

void String::Erase | ( | INT | from,
 |  | INT | nchars
 | ) |

Erase nchars substring starting from position from.

void String::Erase ( INT frompos )

Empties the object from position frompos until its end and adjusts its size.

void String::Format | ( | const CHAR * | format,
 |  |  | ...
 | ) |

Stores a series of characters and values in the object. Syntax is equivalent to printf.

WString String::FromUtf8ToWString ( ) const

Interprets the content of the object as a UTF-8 string and returns it converted to a NULL-terminated WString object. If the conversion fails for some reason the empty string is returned silently.

const CHAR* String::GetCString ( ) const [inline]

Returns the CHAR * pointer of the content of the object. Please be aware, that this returned pointer is never equal to NULL! Even if the character string is empty, this returned pointer will point to an empty, null-terminated CHAR * string! This means that using this method and comparing it's return value to NULL for testing the String on emptiness is not correct - for checking on emptiness, the method IsEmpty() has to be used instead!

const UINT8* String::GetData ( ) const [inline]

Returns the UINT8 * pointer of the content of the object.

INT String::GetLength ( ) const

Returns the current number of characters of the object, excluding terminating zero.

INT String::GetMemSize ( ) const

Returns the memory needed by the object. This is implementation dependent.

INT String::GetSize ( ) const

Returns the current number of used bytes of the object, excluding terminating zero.

INT String::IndexOf | ( | const CHAR * | searchstr,
 |  | INT | frompos = 0
 | ) | const [inline]

Searches for the first occurrence of searchstr starting from frompos. If frompos is omitted the search starts at position zero. Either the position of the found string or -1 for not found is returned.

INT String::IndexOf | ( | const String & | searchstr,
 |  | INT | frompos = 0
 | ) | const [inline]

Searches for the first occurrence of the String searchstr starting from frompos. If frompos is omitted the search starts at position zero. Either the position of the found string or -1 for not found is returned.

INT String::IndexOf | ( | CHAR | character,
 |  | INT | frompos = 0
 | ) | const

Searches for the first occurrence of the character character starting from frompos. If frompos is omitted the search starts at position zero. Either the position of the found character or -1 for not found is returned.

void String::Insert | ( | INT | pos,
 |  | const String & | szInsert
 | ) |

Inserts a String at a given position pos.

void String::Insert | ( | INT | pos,
 |  | CHAR | character
 | ) |

Inserts a single character at a given position pos.

BOOLEAN String::IsEmpty ( ) const [inline]

Checks whether the number of characters of the object is zero.

BOOLEAN String::IsNumeric | ( | const CHAR * | string,
 |  | INT | number = -1
 | ) | [static]

Checks if the CHAR string only contains digits '0' to '9', starting at position number.

BOOLEAN String::IsNumeric ( INT number = -1 ) const [inline]

Checks if the string only contains digits '0' to '9', starting at position number.

INT String::LastIndexOf | ( | CHAR | character,
 |  | INT | frompos = -1
 | ) | const

Returns the index within this wide character string of the last occurrence of the specified character, searching backwards starting at the specified index. If frompos is omitted the search starts at the end of the string. Either the index of the found character or -1 for not found is returned.

String::operator const CHAR * ( ) const [inline]

Identical to GetCString(). Returns the CHAR * pointer of the content of the object. Please be aware, that this pointer is never equal to NULL! Even if the character string is empty, this returned pointer will point to an empty, null-terminated CHAR * string! This means that using this operator and comparing it's value to NULL for testing the String on emptiness is not correct - for checking on emptiness, the method IsEmpty() has to be used instead!

BOOLEAN String::operator!= ( const String & szcompare ) const [inline]

Checks whether the object and szcompare are not identical.

String String::operator+ ( const CHAR * pchConcat ) const

Returnes the concatenation of the object and the zero terminated CHAR string pchConcat.

String String::operator+ ( const String & szConcat ) const

Returnes the concatenation of the object and the szConcat object.

void String::operator+= ( const WCHAR * pchConcat ) [inline]

Concatenates the zero terminated WCHAR string to the object.

void String::operator+= ( const CHAR * pchConcat ) [inline]

Concatenates the zero terminated CHAR string to the object.

void String::operator+= ( const WString & szConcat ) [inline]

Concatenates WString szConcat to the object.

void String::operator+= ( const String & szConcat ) [inline]

Concatenates String szConcat to the object.

BOOLEAN String::operator< ( const String & right ) const [inline]

Checks whether the object is smaller than right.

String & String::operator<< ( INT32 number )

Concatenates number to the object. Repetitive use is possible (a << b << c).

String & String::operator<< ( const WCHAR * right )

Concatenates a zero terminated WCHAR string to the object. Repetitive use is possible (a << b << c).

String & String::operator<< ( const CHAR * right )

Concatenates a zero terminated CHAR string to the object. Repetitive use is possible (a << b << c).

String & String::operator<< ( const WString * right )

Concatenates WString right to the object. Repetitive use is possible (a << b << c).

String & String::operator<< ( const WString & right )

Concatenates WString right to the object. Repetitive use is possible (a << b << c).

String & String::operator<< ( const String * right )

Concatenates String right to the object. Repetitive use is possible (a << b << c).

String & String::operator<< ( const String & right )

Concatenates String right to the object. Repetitive use is possible (a << b << c).

BOOLEAN String::operator<= ( const String & right ) const [inline]

Checks whether the object is smaller or equal than right.

String & String::operator= ( const CHAR * pchCopy )

Assigns a new value to the string object based on zero terminated CHAR string.

String & String::operator= ( const String & szCopy )

Assigns a new value to the string object.

BOOLEAN String::operator== ( const CHAR * szcompare ) const [inline]

Checks whether the object and C-string szcompare are identical.

BOOLEAN String::operator== ( const String & szcompare ) const [inline]

Checks whether the object and szcompare are identical.

BOOLEAN String::operator> ( const String & right ) const [inline]

Checks whether the object is greater than right.

BOOLEAN String::operator>= ( const String & right ) const [inline]

Checks whether the object is greater or equal than right.

CHAR String::operator[] ( INT nPos ) const

Returns the character of the object at position nPos.

BOOLEAN String::PreAlloc ( UINT nchars ) [inline]

Alloc for internal buffer for at least nchars characters (excluding terminating zero character). Current WString content will be destroyed

void String::Replace | ( | INT | pos,
 |  | CHAR | ch
 | ) |

Replaces character at position pos with ch.

BOOLEAN String::Reserve ( UINT nchars ) [inline]

Reserve internal buffer for at least nchars characters (excluding terminating zero character).

void String::Scan | ( | const CHAR * | format,
 |  |  | ...
 | ) | const

Scans the string for a series of values in the object. Syntax is equivalent to scanf. Please note: If the "vsscanf" function is available on the current plattform, an unlimited number of variable arguments may be passed. However, if the "vsscanf" function is not available (e.g. on WIN32), only up to 10 arguments can be handled at once.

BOOLEAN String::StartsWith ( const String & other ) const

Returns TRUE if the other-String matches with the start of the string.

void String::StrCopy | ( | const CHAR * | buffer,
 |  | INT | len
 | ) |

Initializes the object by len characters of a character buffer.

String String::Substring | ( | INT | nStart,
 |  | INT | nLength = -1
 | ) | const

Returns a substring object starting from position nStart of the length nLength. If nLength is omitted the substring contains all characters from nStart on.

void String::Swap ( String & swapstr )

Exchanges the content of the object and swapstr.

String & String::ToLower ( )

Converts all characters of the object into lower case characters.

String & String::ToUpper ( )

Converts all characters of the object into upper case characters.

WString String::ToWString ( ) const

Returns the content of the object as a WString object.

void String::VFormat | ( | const CHAR * | format,
 |  | va_list | args
 | ) |

Accepts a pointer to an argument list. Syntax is equivalent to ANSI vprintf.

Friends And Related Function Documentation

friend class WString [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/String.hpp
  • Auxiliary/String.cpp
Generated on Wed Jan 25 02:07:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StringDataSink Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StringDataSink Class Reference
[Bluetooth]

#include <Apoxi/Auxiliary/StringDataSink.hpp>

Inheritance diagram for StringDataSink:

[legend]
Collaboration diagram for StringDataSink:

[legend]

Public Member Functions

virtual BOOLEAN | Close ()
virtual BOOLEAN | GetSize (UINT32 &size) const
const String & | GetString ()
virtual BOOLEAN | IsOpen () const
virtual BOOLEAN | Open ()
StringDataSink ()
virtual UINT32 | Write (UINT32 offset, const void HUGE *buf, UINT32 nbytes)
virtual UINT32 | Write (const void HUGE *buf, UINT32 nbytes)
virtual | ~StringDataSink ()

Constructor & Destructor Documentation

StringDataSink::StringDataSink ( )

StringDataSink::~StringDataSink ( ) [virtual]

Destructs this instance.

Member Function Documentation

BOOLEAN StringDataSink::Close ( ) [virtual]

Closes the data sink. After closing the data sink it can not be written any more.

Returns:
Success of operation.

Implements DataSink.

BOOLEAN StringDataSink::GetSize ( UINT32 & size ) const [virtual]

Returns the size of the data sink in terms of bytes. The size of the data sink is actually defined by the amount of data written at the end of the data sink.

Parameters:
size The actual size will be written into this variable.
Returns:
Success of operation.

Implements DataSink.

const String& StringDataSink::GetString ( ) [inline]

Returns the string filled by this DataSink

BOOLEAN StringDataSink::IsOpen ( ) const [virtual]

Returns whether the data sink is currently open or closed.

Returns:
Whether the data sink is open or not.

Implements DataSink.

BOOLEAN StringDataSink::Open ( ) [virtual]

Opens the data sink for writing. The size of a freshly opened data sink is 0. A data sink can only be written if it has been opened before.

Returns:
Success of operation.

Implements DataSink.

UINT32 StringDataSink::Write | ( | UINT32 | offset,
 |  | const void HUGE * | buf,
 |  | UINT32 | nbytes
 | ) | [virtual]

Writes nbytes bytes of buffer buf to the data sink at the given offset. Note, that this method is only allowed to be used to overwrite existing data. Hence, if the given offset plus the number of bytes to write nbytes is larger than the current size of the data sink then an assertion fails. Overriding methods must implement this assertion. Since this method only overrides existing data it does not affect the size of the data sink.

Parameters:
offset | The offset where to start writing.
buf | The buffer to be written.
nbytes | The number of bytes to be written.
Returns:
Number of bytes actually written.

Implements DataSink.

UINT32 StringDataSink::Write | ( | const void HUGE * | buf,
 |  | UINT32 | nbytes
 | ) | [virtual]

Writes nbytes bytes of buffer buf to the data sink. The data is written at the end of the data sink and hence increases the size of the data sink by the amount of bytes written.

Parameters:
buf | The buffer to be written.
nbytes | The number of bytes to be written.
Returns:
Number of bytes actually written.

Implements DataSink.

The documentation for this class was generated from the following files:
  • Auxiliary/StringDataSink.hpp
  • Auxiliary/StringDataSink.cpp
Generated on Wed Jan 25 02:07:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StrokeBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StrokeBox Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/T9/StrokeBox.hpp>

Inheritance diagram for StrokeBox:

[legend]
Collaboration diagram for StrokeBox:

[legend]

Public Types

typedef DrawableObject | Base

Public Member Functions

virtual XYDIM | GetDefaultHeight () const
const WCHAR * | GetText () const
void | Init (Control *control)
void | SetText (const WCHAR *text)
StrokeBox (Control *control)
StrokeBox ()
virtual | ~StrokeBox ()

Member Typedef Documentation

typedef DrawableObject StrokeBox::Base

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

StrokeBox::StrokeBox ( )

StrokeBox::StrokeBox ( Control * control )

StrokeBox::~StrokeBox ( ) [virtual]

Member Function Documentation

XYDIM StrokeBox::GetDefaultHeight ( ) const [virtual]

See also:
Component::GetDefaultHeight

Reimplemented from Component.

const WCHAR* StrokeBox::GetText ( ) const [inline]

void StrokeBox::Init ( Control * control )

void StrokeBox::SetText ( const WCHAR * text )

The documentation for this class was generated from the following files:
  • AddOns/T9/StrokeBox.hpp
  • AddOns/T9/StrokeBox.cpp
Generated on Wed Jan 25 02:07:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: StrokeBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

StrokeBoxView Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/T9/StrokeBox.hpp>

Inheritance diagram for StrokeBoxView:

[legend]
Collaboration diagram for StrokeBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
void | Init ()
StrokeBoxView ()
virtual | ~StrokeBoxView ()

Constructor & Destructor Documentation

StrokeBoxView::StrokeBoxView ( )

StrokeBoxView::~StrokeBoxView ( ) [virtual]

Member Function Documentation

void StrokeBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void StrokeBoxView::Init ( )

The documentation for this class was generated from the following files:
  • AddOns/T9/StrokeBox.hpp
  • AddOns/T9/StrokeBox.cpp
Generated on Wed Jan 25 02:07:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Subaddress Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Subaddress Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for Subaddress:

[legend]

Data Fields

PhoneNumber address
BOOLEAN available

Field Documentation

PhoneNumber Subaddress::address

BOOLEAN Subaddress::available

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:07:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SubMenuAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SubMenuAction Class Reference
[GUI Menu Accessors]

#include <Apoxi/AddOns/GuiMenuAccessors/SubMenuAction.hpp>

Inheritance diagram for SubMenuAction:

[legend]
Collaboration diagram for SubMenuAction:

[legend]

Public Member Functions

void | AddAction (Action *action)
virtual const ActionExtension * | GetExtension () const
AbstractMenuAccessor * GetMenuAccessor ()
void | Init (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
SubMenuAction (Dispatcher *dispatcher, const WCHAR *text, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
SubMenuAction ()
virtual | ~SubMenuAction ()

Detailed Description

Obsolete - the class Menu, which uses the SubMenuAction, has been replaced by the classes ItemMenu and ItemTree.

May contain a menu-accessor and allows together with the class AbstractActionMenuAccessor the implementation of a menu-hierarchy. When an accessor-action is triggered inside a menu, the current accessor of the menu is replaced by the accessor from accessor-action, which means traversing down the menu-hierarchy.

Constructor & Destructor Documentation

SubMenuAction::SubMenuAction ( )

SubMenuAction::SubMenuAction | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

SubMenuAction::~SubMenuAction ( ) [virtual]

Member Function Documentation

void SubMenuAction::AddAction ( Action * action )

const ActionExtension * SubMenuAction::GetExtension ( ) const [virtual]

AbstractMenuAccessor* SubMenuAction::GetMenuAccessor ( ) [inline]

void SubMenuAction::Init | ( | Dispatcher * | dispatcher,
 |  | const WCHAR * | text,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Parameters:
dispatcher | Dispatcher which will be informed about property changes of the action. It is recommended always to specify a dispatcher.
text | Text of the action.
icon | Icon of the action represented by a bitmap.
enabled | Specifies whether the action is enabled. Usually actions which are not enabled may not be executed.

Reimplemented from Action.

The documentation for this class was generated from the following files:
  • AddOns/GuiMenuAccessors/SubMenuAction.hpp
  • AddOns/GuiMenuAccessors/SubMenuAction.cpp
Generated on Wed Jan 25 02:07:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SubstitutedText Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SubstitutedText Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Properties/SubstitutedText.hpp>

Collaboration diagram for SubstitutedText:

[legend]

Public Member Functions

BOOLEAN | ContainsProperty (Property *property) const
WString | GetSubstitutedText () const
const WString & | GetText () const
void | Init (const WString &pattern, const FeatureItem *item)
void | SetText (const WString &pattern)
SubstitutedText ()

Static Public Member Functions

static BOOLEAN | IsSubstitutionNeeded (const WString &pattern_text)

Constructor & Destructor Documentation

SubstitutedText::SubstitutedText ( )

Member Function Documentation

BOOLEAN SubstitutedText::ContainsProperty ( Property * property ) const

WString SubstitutedText::GetSubstitutedText ( ) const

const WString & SubstitutedText::GetText ( ) const

void SubstitutedText::Init | ( | const WString & | pattern,
 |  | const FeatureItem * | item
 | ) |

BOOLEAN SubstitutedText::IsSubstitutionNeeded ( const WString & pattern_text ) [static]

void SubstitutedText::SetText ( const WString & pattern )

The documentation for this class was generated from the following files:
  • Atl/Properties/SubstitutedText.hpp
  • Atl/Properties/SubstitutedText.cpp
Generated on Wed Jan 25 02:07:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SubSystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SubSystem Class Reference
[Kernel]

#include <Apoxi/Kernel/SubSystem.hpp>

Inheritance diagram for SubSystem:

[legend]
Collaboration diagram for SubSystem:

[legend]

Public Types

typedef SubSystemManager::BootSequenceState | BootSequenceState

Public Member Functions

virtual const WCHAR * | GetName () const =0
virtual UINT8 | GetPriority () const
virtual BootSequenceState | InvokeAt () const =0
virtual void | OnPowerDown ()
virtual void | OnPowerUp ()
SubSystem ()
virtual | ~SubSystem ()

Friends

class | SubSystemManager

Detailed Description

A SubSystem is a singleton that needs to initialize on power up or garbage collect on power down system resources. Derivatives of SubSystem must be instantiated in global scope. The constructor of SubSystem will care that for registering sub-systems in SubSystemManager. On special system events like power up / down according methods will be invoked. Thread context of method invokation is not defined - at method invokation time bigger parts of APOXI might not be initialized. Thus functionality should be limited to thread creation, memory allocation, or internal initialization. Typical examples of sub-systems could be inet (tcp/udp) or Bluetooth.

Member Typedef Documentation

typedef SubSystemManager::BootSequenceState SubSystem::BootSequenceState

Constructor & Destructor Documentation

SubSystem::SubSystem ( )

Will automatically register the sub-system in SubSystemManager.

SubSystem::~SubSystem ( ) [virtual]

Does de-registration in SubSystemManager.

Member Function Documentation

virtual const WCHAR* SubSystem::GetName ( ) const [pure virtual]

Returns:
A meaningfull name for the sub-system.

Implemented in DataControl, DrmSubsystem, SerialSocketSubSystem, UsbSubSystem, RegManager, KeyMsgGenerator, StackControl, AudioPresetStore, BtBppController, BtObexController, BtObexSubSystem, GatiManager, IrdaObexSubSystem, GenericWorkerTask, and SocketSubSystem.

UINT8 SubSystem::GetPriority ( ) const [virtual]

Priority controls the init sequence of SubSystems.

Reimplemented in DataControl, DrmSubsystem, RegManager, KeyMsgGenerator, StackControl, BtConnectionBasedController, and BtConnectionlessController.

virtual BootSequenceState SubSystem::InvokeAt ( ) const [pure virtual]

InvokeAt denotes the system boot phase the SubSystem shall be initialized in.

Implemented in DataControl, DrmSubsystem, SerialSocketSubSystem, UsbSubSystem, RegManager, KeyMsgGenerator, StackControl, AudioPresetStore, BtController, BtObexSubSystem, GatiManager, IrdaObexSubSystem, GenericWorkerTask, and SocketSubSystem.

void SubSystem::OnPowerDown ( ) [virtual]

This method will be invoked on system power down.

Reimplemented in DataControl, DrmSubsystem, UsbSubSystem, RegManager, KeyMsgGenerator, StackControl, BtController, GatiManager, GenericWorkerTask, and SocketSubSystem.

void SubSystem::OnPowerUp ( ) [virtual]

This method will be invoked on system power on.

Reimplemented in DataControl, DrmSubsystem, SerialSocketSubSystem, UsbSubSystem, RegManager, KeyMsgGenerator, StackControl, AudioPresetStore, BtController, BtObexSubSystem, GatiManager, IrdaObexSubSystem, GenericWorkerTask, and SocketSubSystem.

Friends And Related Function Documentation

friend class SubSystemManager [friend]

The documentation for this class was generated from the following files:
  • Kernel/SubSystem.hpp
  • Kernel/SubSystem.cpp
Generated on Wed Jan 25 02:07:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SubSystemManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SubSystemManager Class Reference
[Kernel]

#include <Apoxi/Kernel/SubSystemManager.hpp>

Collaboration diagram for SubSystemManager:

[legend]

Public Types

enum | BootSequenceState { c_run_level_1 = 3, c_run_level_3 = 2, c_run_level_5 = 1, c_run_level_7 = 0 }

Static Public Member Functions

static void | SendPowerDownNotification (BootSequenceState state)
static void | SendPowerUpNotification (BootSequenceState state)

Friends

class | SubSystem

Detailed Description

SubSystemManager controls initialization of APOXI sub-systems like Inet. On system power on or down sub-systems will get notifications and initialization requests.

Member Enumeration Documentation

enum SubSystemManager::BootSequenceState

Enumerator:
c_run_level_1
c_run_level_3 | after initialization of static variables
c_run_level_5 | after attaching the applications to the containers
c_run_level_7 | in the context of the first starting AppContainer

Member Function Documentation

void SubSystemManager::SendPowerDownNotification ( BootSequenceState state ) [static]

Invoke in all registered sub-systems the method OnPowerDown

void SubSystemManager::SendPowerUpNotification ( BootSequenceState state ) [static]

Invoke in all registered sub-systems the method OnPowerUp

Friends And Related Function Documentation

friend class SubSystem [friend]

The documentation for this class was generated from the following files:
  • Kernel/SubSystemManager.hpp
  • Kernel/SubSystemManager.cpp
Generated on Wed Jan 25 02:07:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SubUnitReference Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SubUnitReference Class Reference

#include <Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp>

Inheritance diagram for SubUnitReference:

[legend]
Collaboration diagram for SubUnitReference:

[legend]

Public Member Functions

void | ConnectResponse (btapi_avrcp_handle_t avrcp_handle)
BtAvrcpCommandInterface * | GetAvrcpAppReference () const
BtAvrcpProfileOperationService * | GetAvrcpOperationService () const
void | InitAvrcpOperationService ()
void | SetAvrcpOperationService (BtAvrcpProfileOperationService *avrcp_operation_service)
SubUnitReference (BtAvrcpCommandInterface *app_ref, WString app_name)
~SubUnitReference ()

Detailed Description

SubUnitReference is an collection of BtAvrcpCommandInterface a reference to a/v plugin and its name Used in creating a Item Container of SubUnitReference

Constructor & Destructor Documentation

SubUnitReference::SubUnitReference | ( | BtAvrcpCommandInterface * | app_ref,
 |  | WString | app_name
 | ) | [inline]

Constructor

SubUnitReference::~SubUnitReference ( ) [inline]

Destructor

Member Function Documentation

void SubUnitReference::ConnectResponse ( btapi_avrcp_handle_t avrcp_handle ) [inline]

Invoked to send back the response for the connect request. btapi_avrcp_handle_t is sent as a parameter in order to handle further operations

BtAvrcpCommandInterface* SubUnitReference::GetAvrcpAppReference ( ) const [inline]

Returns audio/video application reference (Eg: Media player)

BtAvrcpProfileOperationService* SubUnitReference::GetAvrcpOperationService ( ) const [inline]

Returns reference to the BtAvrcp Operation service Each device(sub unit) is associated with a Operation instance

void SubUnitReference::InitAvrcpOperationService ( ) [inline]

Must be invoked just after creation of the instance of operation service

void SubUnitReference::SetAvrcpOperationService ( BtAvrcpProfileOperationService * avrcp_operation_service ) [inline]

Sets BtAvrcpOperationService instance Invoked while creation of the operation service instance, during handling of connect request from the Controller

The documentation for this class was generated from the following file:
  • Applications/BluetoothAvrcp/BtAvrcpPanelApplication.hpp
Generated on Wed Jan 25 02:07:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgDecodingFinishedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgDecodingFinishedMsg Class Reference

#include <Apoxi/AddOns/Svg/MsgTypes.hpp>

Inheritance diagram for SvgDecodingFinishedMsg:

[legend]
Collaboration diagram for SvgDecodingFinishedMsg:

[legend]

Public Types

enum | { ID = 4400 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SvgPlayer * | GetPlayer () const
const Ticks & | GetTicks () const
SvgDecodingFinishedMsg (SvgPlayer *player, const Ticks &ticks)
virtual | ~SvgDecodingFinishedMsg ()

Detailed Description

This message is sent, when a SVG document has finished decoding the current frame.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SvgDecodingFinishedMsg::SvgDecodingFinishedMsg | ( | SvgPlayer * | player,
 |  | const Ticks & | ticks
 | ) |

SvgDecodingFinishedMsg::~SvgDecodingFinishedMsg ( ) [virtual]

Member Function Documentation

Message * SvgDecodingFinishedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SvgDecodingFinishedMsg::GetMetaData ( ) const [virtual]

Implements Message.

SvgPlayer* SvgDecodingFinishedMsg::GetPlayer ( ) const [inline]

const Ticks& SvgDecodingFinishedMsg::GetTicks ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Svg/MsgTypes.hpp
  • AddOns/Svg/MsgTypes.cpp
Generated on Wed Jan 25 02:07:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgFileWrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgFileWrapper Class Reference
[Svg]

#include <Apoxi/AddOns/Svg/SvgFileWrapper.hpp>

Inheritance diagram for SvgFileWrapper:

[legend]
Collaboration diagram for SvgFileWrapper:

[legend]

Public Member Functions

virtual UINT32 | Read (UINT8 *p_dst_buffer, UINT32 bytes_wanted)
SvgFileWrapper (BinData *p_bin_data, BOOLEAN release_ramdata=FALSE)
SvgFileWrapper (UINT8 *p_buffer, UINT32 buffer_length, BOOLEAN release_ramdata=FALSE)
SvgFileWrapper ()
virtual | ~SvgFileWrapper ()

Detailed Description

SvgFileWrapper, mapping for reading data

Constructor & Destructor Documentation

SvgFileWrapper::SvgFileWrapper ( )

SvgFileWrapper::SvgFileWrapper | ( | UINT8 * | p_buffer,
 |  | UINT32 | buffer_length,
 |  | BOOLEAN | release_ramdata = FALSE
 | ) |

SvgFileWrapper::SvgFileWrapper | ( | BinData * | p_bin_data,
 |  | BOOLEAN | release_ramdata = FALSE
 | ) |

SvgFileWrapper::~SvgFileWrapper ( ) [virtual]

Member Function Documentation

UINT32 SvgFileWrapper::Read | ( | UINT8 * | p_dst_buffer,
 |  | UINT32 | bytes_wanted
 | ) | [virtual]

Implements SvgIoWrapper.

The documentation for this class was generated from the following files:
  • AddOns/Svg/SvgFileWrapper.hpp
  • AddOns/Svg/SvgFileWrapper.cpp
Generated on Wed Jan 25 02:07:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgGzFileWrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgGzFileWrapper Class Reference
[Svg]

#include <Apoxi/AddOns/Svg/SvgGzFileWrapper.hpp>

Inheritance diagram for SvgGzFileWrapper:

[legend]
Collaboration diagram for SvgGzFileWrapper:

[legend]

Public Member Functions

virtual UINT32 | Read (UINT8 *p_dst_buffer, UINT32 bytes_wanted)
SvgGzFileWrapper (BinData *p_bin_data, BOOLEAN *p_success, BOOLEAN release_ramdata=FALSE)
SvgGzFileWrapper (UINT8 *p_buffer, UINT32 buffer_length, BOOLEAN *p_success, BOOLEAN release_ramdata=FALSE)
SvgGzFileWrapper ()
virtual | ~SvgGzFileWrapper ()

Static Public Member Functions

static BOOLEAN | HasValidGzHeader (BinData *p_bin_data)
static BOOLEAN | HasValidGzHeader (UINT8 *p_buffer, INT32 buffer_length)

Detailed Description

Wrapper for reading out of gzipped data. INTERNAL interface only

Constructor & Destructor Documentation

SvgGzFileWrapper::SvgGzFileWrapper ( )

SvgGzFileWrapper::SvgGzFileWrapper | ( | UINT8 * | p_buffer,
 |  | UINT32 | buffer_length,
 |  | BOOLEAN * | p_success,
 |  | BOOLEAN | release_ramdata = FALSE
 | ) |

SvgGzFileWrapper::SvgGzFileWrapper | ( | BinData * | p_bin_data,
 |  | BOOLEAN * | p_success,
 |  | BOOLEAN | release_ramdata = FALSE
 | ) |

SvgGzFileWrapper::~SvgGzFileWrapper ( ) [virtual]

Member Function Documentation

BOOLEAN SvgGzFileWrapper::HasValidGzHeader ( BinData * p_bin_data ) [static]

BOOLEAN SvgGzFileWrapper::HasValidGzHeader | ( | UINT8 * | p_buffer,
 |  | INT32 | buffer_length
 | ) | [static]

UINT32 SvgGzFileWrapper::Read | ( | UINT8 * | p_dst_buffer,
 |  | UINT32 | bytes_wanted
 | ) | [virtual]

Implements SvgIoWrapper.

The documentation for this class was generated from the following files:
  • AddOns/Svg/SvgGzFileWrapper.hpp
  • AddOns/Svg/SvgGzFileWrapper.cpp
Generated on Wed Jan 25 02:07:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgHyperlinkSelectMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgHyperlinkSelectMsg Class Reference

#include <Apoxi/AddOns/Svg/MsgTypes.hpp>

Inheritance diagram for SvgHyperlinkSelectMsg:

[legend]
Collaboration diagram for SvgHyperlinkSelectMsg:

[legend]

Public Types

enum | { ID = 4402 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetHyperlink () const
virtual const MsgMetaData & | GetMetaData () const
SvgPlayer * | GetPlayer () const
SvgHyperlinkSelectMsg (ExecutionContext *context, SvgPlayer *player, const WString &hyperlink)
virtual | ~SvgHyperlinkSelectMsg ()

Detailed Description

This message is sent as the result of selecting the focused hyperlink within the SVG document.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SvgHyperlinkSelectMsg::SvgHyperlinkSelectMsg | ( | ExecutionContext * | context,
 |  | SvgPlayer * | player,
 |  | const WString & | hyperlink
 | ) |

SvgHyperlinkSelectMsg::~SvgHyperlinkSelectMsg ( ) [virtual]

Member Function Documentation

Message * SvgHyperlinkSelectMsg::Clone ( ) const [virtual]

Implements Message.

const WString& SvgHyperlinkSelectMsg::GetHyperlink ( ) const [inline]

const MsgMetaData & SvgHyperlinkSelectMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

SvgPlayer* SvgHyperlinkSelectMsg::GetPlayer ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Svg/MsgTypes.hpp
  • AddOns/Svg/MsgTypes.cpp
Generated on Wed Jan 25 02:07:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgImage Class Reference
[Svg]

#include <Apoxi/AddOns/Svg/SvgImage.hpp>

Inheritance diagram for SvgImage:

[legend]
Collaboration diagram for SvgImage:

[legend]

Public Types

enum | { ID = 9 }

Public Member Functions

virtual BOOLEAN | DecodeSynchronously () const
virtual BOOLEAN | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT frame_idx, XYDIM scaled_width=-1, XYDIM scaled_height=-1, const Rect &clip_rect=Rect()) const
virtual const BinData * | GetBinData () const
virtual UINT32 | GetFrameDelay (INT frame_idx) const
virtual INT | GetNextFrame (INT frame_idx) const
BOOLEAN | Init (BinData *data)
void | Init ()
virtual BOOLEAN | IsBufferingAllowed () const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | Load (BinData *data)
BOOLEAN | Pan (SvgFixPoint dx, SvgFixPoint dy)
void | ResetTransformation ()
BOOLEAN | Rotate (SvgFixPoint angle, SvgFixPoint x, SvgFixPoint y)
BOOLEAN | SetViewportSize (XYDIM width, XYDIM height)
BOOLEAN | SetZoomLevel (SvgFixPoint magnification)
SvgImage (BinData *data, BOOLEAN *p_success=0)
SvgImage ()
BOOLEAN | ToUserSpace (XYDIM viewport_x, XYDIM viewport_y, SvgFixPoint &user_x, SvgFixPoint &user_y) const
BOOLEAN | ToViewportSpace (SvgFixPoint user_x, SvgFixPoint user_y, XYDIM &viewport_x, XYDIM &viewport_y) const
virtual | ~SvgImage ()

Protected Member Functions

virtual ColorValue | GetTransparentColor (void *context) const
virtual BOOLEAN | HasAlphaChannel (void *context) const
virtual BOOLEAN | IsTransparent (void *context) const

Protected Attributes

struct {
UINT first_frame: 1
UINT is_loading: 1
UINT memory_alloc_failure: 1
} m_bits
BinData * m_data
SvgDecoder * | m_decoder
INT32 | m_delta
INT | m_frames
UINT32 | m_normalized_time
UINT32 | m_player_time_offset
INT8 | m_previous_zoom_level
INT | m_set_frame_idx
Bitmap * m_svg_bitmap
XYDIM | m_svg_height
XYDIM | m_svg_width
Ticks m_ticks
SvgFixPointTrans m_trans

Detailed Description

Class to contain, decompress and draw a SVG compatible documents.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Image.

Constructor & Destructor Documentation

SvgImage::SvgImage ( )

Creates an empty SVG image. To fill the image with data invoke SvgImage::Load afterwards, which does the loading in a background thread so that the calling application still can receive messages.

SvgImage::SvgImage | ( | BinData * | data,
 |  | BOOLEAN * | p_success = 0
 | ) |

Creates an SVG image out of the given data. Note that dependant from the complexity of the SVG data the calling application might get blocked for up to 1 second for the loading process. If this is not suitable use the constructor SvgImage::SvgImage() instead and invoke SvgImage::Load afterwards.

Parameters:
data | Pointer to a binary data stream which contains the SVG data. After passing the binary data stream, the stream is obtained by the SVG image and hence automatically released in the destructor of the SVG image.
success | Optional output parameter, which indicates whether the initialization has been successful.

SvgImage::~SvgImage ( ) [virtual]

Releases the binary data stream m_data if it is still obtained and destructs the object.

Member Function Documentation

BOOLEAN SvgImage::DecodeSynchronously ( ) const [virtual]

See also:
Image::DecodeSynchronously

Reimplemented from Image.

BOOLEAN SvgImage::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | frame_idx,
 |  | XYDIM | scaled_width = -1,
 |  | XYDIM | scaled_height = -1,
 |  | const Rect & | clip_rect = Rect()
 | ) | const [virtual]

See also:
Image::Draw

Reimplemented from Image.

const BinData * SvgImage::GetBinData ( ) const [virtual]

See also:
Image::GetBinData()

Reimplemented from Image.

UINT32 SvgImage::GetFrameDelay ( INT frame_idx ) const [virtual]

See also:
Image::GetFrameDelay

Implements Image.

INT SvgImage::GetNextFrame ( INT frame_idx ) const [virtual]

See also:
Image::GetNextFrame

Implements Image.

ColorValue SvgImage::GetTransparentColor ( void * context ) const [protected, virtual]

See also:
Image::GetTransparentColor

Reimplemented from Image.

BOOLEAN SvgImage::HasAlphaChannel ( void * context ) const [protected, virtual]

See also:
Image::HasAlphaChannel

Reimplemented from Image.

BOOLEAN SvgImage::Init ( BinData * data )

Creates an SVG image out of the given data. Note that dependant from the complexity of the SVG data the calling application might get blocked for up to 1 second for the loading process. If this is not suitable use the constructor SvgImage::SvgImage() instead and invoke SvgImage::Load afterwards.

Parameters:
data Pointer to a binary data stream which contains the SVG data. After passing the binary data stream, the stream is obtained by the SVG image and hence automatically released in the destructor of the SVG image.
Returns:
TRUE if the initialization has been successful.

void SvgImage::Init ( )

Creates an empty SVG image. To fill the image with data invoke SvgImage::Load afterwards, which does the loading in a background thread so that the calling application still can receive messages.

BOOLEAN SvgImage::IsBufferingAllowed ( ) const [virtual]

See also:
Image::IsBufferingAllowed

Reimplemented from Image.

BOOLEAN SvgImage::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Image.

BOOLEAN SvgImage::IsTransparent ( void * context ) const [protected, virtual]

See also:
Image::IsTransparent

Reimplemented from Image.

BOOLEAN SvgImage::Load ( BinData * data )

Loads the SVG data into the SVG engine, so that it can be drawn with SvgImage::Draw afterwards. The loading is done inside a separate thread, so that the calling application still can receive messages during the loading. This benefit also has some drawbacks: the calling application must take care that it will not delete the SvgImage instance during the loading is still active. It is recommended that the calling application disables the current focused control or window when invoking SvgImage::Load:

SvgImage* svg_image = new SvgImage();
if (svg_image != 0) {
    window.SetDisabled(TRUE);
    if (svg_image->Load(data)) {
        ...
    }
    window.SetDisabled(FALSE);
}

Disabling the current focused control or window assures that the user cannot trigger e. g. a Window::OnClose, where the SVG-image might get destroyed by the application although the thread still loads the SVG image. If disabling the control is not acceptable, the application itself has to implement an Active Wait mechanism to delay the destruction.

Parameters:
data Pointer to a binary data stream which contains the SVG data. After passing the binary data stream, the stream is obtained by the SVG image and hence automatically released in the destructor of the SVG image.
Returns:
TRUE if the loading has been successful.

BOOLEAN SvgImage::Pan | ( | SvgFixPoint | dx,
 |  | SvgFixPoint | dy
 | ) |

Pan does panning on the SVG document. Only possible, if IsDocumentPanable() returns TRUE.

Parameters:
dx | pan dx pixels horizontal
dy | pan dy pixels vertical
Returns:
returns TRUE if panning was successfully.

void SvgImage::ResetTransformation ( )

Resets all user transformations such as zoom, pan and rotation

BOOLEAN SvgImage::Rotate | ( | SvgFixPoint | angle,
 |  | SvgFixPoint | x,
 |  | SvgFixPoint | y
 | ) |

Rotates the SVG document with given angle by the given rotation point.

Parameters:
angle | Rotation angle.
x | x-coordinate of rotation point.
y | y-coordinate of rotation point.
Returns:
TRUE if rotation is possible, FALSE if not. Use GetErrorCode() to determine more error information.

BOOLEAN SvgImage::SetViewportSize | ( | XYDIM | width,
 |  | XYDIM | height
 | ) |

Sets the size of the viewport in pixels.

BOOLEAN SvgImage::SetZoomLevel ( SvgFixPoint magnification )

SetZoomLevel can be used to zoom into an SVG document. This is only possible, if IsDocumentZoomable() returns TRUE.

Parameters:
magnification Describes the zoom level.
Returns:
TRUE if zooming was successfully.

BOOLEAN SvgImage::ToUserSpace | ( | XYDIM | viewport_x,
 |  | XYDIM | viewport_y,
 |  | SvgFixPoint & | user_x,
 |  | SvgFixPoint & | user_y
 | ) | const

Transforms viewport space coordinates into user space coordinates.

Parameters:
viewport_x | x-coordinate of the viewport space.
viewport_y | y-coordinate of the viewport space.
user_x | Output parameter, which contains the x-coordinate of the user space.
user_y | Output parameter, which contains the y-coordinate of the user space.

BOOLEAN SvgImage::ToViewportSpace | ( | SvgFixPoint | user_x,
 |  | SvgFixPoint | user_y,
 |  | XYDIM & | viewport_x,
 |  | XYDIM & | viewport_y
 | ) | const

Transforms user space coordinates into viewport space coordinates.

Parameters:
user_x | x-coordinate of the user space.
user_y | y-coordinate of the user space.
viewport_x | Output parameter, which contains the x-coordinate of the viewport space.
viewport_y | Output parameter, which contains the y-coordinate of the viewport space.

Field Documentation

UINT SvgImage::first_frame [protected]

UINT SvgImage::is_loading [protected]

struct { ... } SvgImage::m_bits [protected]

Reimplemented from Image.

BinData* SvgImage::m_data [protected]

SvgDecoder* SvgImage::m_decoder [protected]

INT32 SvgImage::m_delta [mutable, protected]

INT SvgImage::m_frames [protected]

UINT32 SvgImage::m_normalized_time [mutable, protected]

UINT32 SvgImage::m_player_time_offset [mutable, protected]

INT8 SvgImage::m_previous_zoom_level [protected]

INT SvgImage::m_set_frame_idx [mutable, protected]

Bitmap* SvgImage::m_svg_bitmap [mutable, protected]

XYDIM SvgImage::m_svg_height [mutable, protected]

XYDIM SvgImage::m_svg_width [mutable, protected]

Ticks SvgImage::m_ticks [protected]

SvgFixPointTrans SvgImage::m_trans [protected]

UINT SvgImage::memory_alloc_failure [protected]

The documentation for this class was generated from the following files:
  • AddOns/Svg/SvgImage.hpp
  • AddOns/Svg/SvgImage.cpp
Generated on Wed Jan 25 02:07:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgImageFileWrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgImageFileWrapper Class Reference
[Svg]

#include <Apoxi/AddOns/Svg/SvgImageFileWrapper.hpp>

Inheritance diagram for SvgImageFileWrapper:

[legend]
Collaboration diagram for SvgImageFileWrapper:

[legend]

Public Member Functions

XYDIM | GetHeight () const
Image * | GetImage () const
XYDIM | GetWidth () const
virtual UINT32 | Read (UINT8 *p_dst_buffer, UINT32 bytes_wanted)
SvgImageFileWrapper (UINT8 *p_img_data, UINT32 img_data_length, UINT8 content_type, BOOLEAN *success)
virtual | ~SvgImageFileWrapper ()

Constructor & Destructor Documentation

SvgImageFileWrapper::SvgImageFileWrapper | ( | UINT8 * | p_img_data,
 |  | UINT32 | img_data_length,
 |  | UINT8 | content_type,
 |  | BOOLEAN * | success
 | ) |

SvgImageFileWrapper::~SvgImageFileWrapper ( ) [virtual]

Member Function Documentation

XYDIM SvgImageFileWrapper::GetHeight ( ) const

Image * SvgImageFileWrapper::GetImage ( ) const

XYDIM SvgImageFileWrapper::GetWidth ( ) const

UINT32 SvgImageFileWrapper::Read | ( | UINT8 * | p_dst_buffer,
 |  | UINT32 | bytes_wanted
 | ) | [virtual]

Implements SvgIoWrapper.

The documentation for this class was generated from the following files:
  • AddOns/Svg/SvgImageFileWrapper.hpp
  • AddOns/Svg/SvgImageFileWrapper.cpp
Generated on Wed Jan 25 02:07:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgIoWrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgIoWrapper Class Reference
[Svg]

#include <Apoxi/AddOns/Svg/SvgIoWrapper.hpp>

Inheritance diagram for SvgIoWrapper:

[legend]

Public Member Functions

virtual UINT32 | Read (UINT8 *p_dst_buffer, UINT32 bytes_wanted)=0
virtual | ~SvgIoWrapper ()

Constructor & Destructor Documentation

SvgIoWrapper::~SvgIoWrapper ( ) [virtual]

Member Function Documentation

virtual UINT32 SvgIoWrapper::Read | ( | UINT8 * | p_dst_buffer,
 |  | UINT32 | bytes_wanted
 | ) | [pure virtual]

Implemented in SvgFileWrapper, SvgGzFileWrapper, and SvgImageFileWrapper.

The documentation for this class was generated from the following files:
  • AddOns/Svg/SvgIoWrapper.hpp
  • AddOns/Svg/SvgIoWrapper.cpp
Generated on Wed Jan 25 02:07:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgMimeUtil Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgMimeUtil Class Reference
[Svg]

#include <Apoxi/AddOns/Svg/SvgMimeUtil.hpp>

Static Public Member Functions

static UINT8 GetMimeContentType (const UINT8 *p_mime)

Member Function Documentation

UINT8 SvgMimeUtil::GetMimeContentType ( const UINT8 * p_mime ) [static]

The documentation for this class was generated from the following files:
  • AddOns/Svg/SvgMimeUtil.hpp
  • AddOns/Svg/SvgMimeUtil.cpp
Generated on Wed Jan 25 02:07:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgPlayer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgPlayer Class Reference
[Svg]

#include <Apoxi/AddOns/Svg/SvgPlayer.hpp>

Inheritance diagram for SvgPlayer:

[legend]
Collaboration diagram for SvgPlayer:

[legend]

Public Types

enum SvgErrorType {
NoError = 0, OutOfMemoryError, InitializationError, AllocationError,
AnimationLoadFailureError, SizeNotSetInDocument, IllegalZoomLevel, AlreadySet,
UnspecifiedError, DecodingInterruptedError, SvgStatusEventHandled = 1
}
enum SvgEventType {
SvgFocusInEvent = 1, SvgFocusOutEvent, SvgUiActivateEvent, SvgActivateEvent,
SvgClickEvent, SvgSelectPreviousHyperlinkEvent, SvgSelectNextHyperlinkEvent, SvgShowHyperlinksEvent,
SvgHideHyperlinksEvent, SvgUndefinedEvent
}

Public Member Functions

virtual XYDIM | GetDefaultHeight (void) const
virtual XYDIM | GetDefaultWidth (void) const
WCHAR * | GetDocumentDescription (void)
WCHAR * | GetDocumentTitle (void)
SvgErrorType | GetErrorCode (void) const
XYDIM | GetHeight () const
WCHAR * | GetPlayerName (void)
WCHAR * | GetPlayerVersion (void)
UINT32 | GetTimePosition (void) const
XYDIM | GetWidth () const
BOOLEAN | Init (Control *parent, BinData *data)
void | Init (Control *parent)
BOOLEAN | IsDecoding () const
BOOLEAN | IsDecodingFinished () const
BOOLEAN | IsDocumentPanable (void) const
BOOLEAN | IsDocumentZoomable (void) const
BOOLEAN | Load (BinData *data)
BOOLEAN | Pan (XYDIM dx, XYDIM dy)
void | Play (UINT32 time=0)
void | Restart ()
BOOLEAN | Rotate (INT16 angle)
void | SetBaseURL (WCHAR *url)
void | SetEvent (SvgEventType event)
void | SetHeight (XYDIM height)
void | SetTimePosition (UINT32 time=0)
void | SetWidth (XYDIM width)
BOOLEAN | SetZoomLevel (INT8 level)
void | Stop ()
SvgPlayer (Control *parent, BinData *p_bindata)
SvgPlayer (Control *parent)
SvgPlayer ()
virtual | ~SvgPlayer (void)

Protected Member Functions

virtual void | Cleanup ()
virtual BOOLEAN | OnMessage (const Message &msg)

Friends

class | LoadingFinishedCondition
class | SvgPlayerView
class | SvgThreadlet
class | TriggerTimer< SvgPlayer >

Detailed Description

Is a drawable object which is able to show an SVG image and allows to modify the view on the fly by commands.

Member Enumeration Documentation

enum SvgPlayer::SvgErrorType

Enumerator:
NoError
OutOfMemoryError
InitializationError
AllocationError
AnimationLoadFailureError
SizeNotSetInDocument
IllegalZoomLevel
AlreadySet
UnspecifiedError
DecodingInterruptedError
SvgStatusEventHandled

enum SvgPlayer::SvgEventType

Enumerator:
SvgFocusInEvent
SvgFocusOutEvent
SvgUiActivateEvent
SvgActivateEvent
SvgClickEvent
SvgSelectPreviousHyperlinkEvent
SvgSelectNextHyperlinkEvent
SvgShowHyperlinksEvent
SvgHideHyperlinksEvent
SvgUndefinedEvent

Constructor & Destructor Documentation

SvgPlayer::SvgPlayer ( )

Creates an empty SVG player. To fill the player with data invoke SvgPlayer::Load afterwards, which does the loading in a background thread so that the calling application still can receive messages.

SvgPlayer::SvgPlayer ( Control * parent )

Creates an empty SVG player. To fill the player with data invoke SvgPlayer::Load afterwards, which does the loading in a background thread so that the calling application still can receive messages.

Parameters:
parent Parent control where the SVG player is embedded.

SvgPlayer::SvgPlayer | ( | Control * | parent,
 |  | BinData * | p_bindata
 | ) |

Creates an SVG player out of the given data. Note that dependant from the complexity of the SVG data the calling application might get blocked for up to 1 second for the loading process. If this is not suitable use the constructor SvgPlayer::SvgPlayer(Control* parent) instead and invoke SvgPlayer::Load afterwards.

Parameters:
parent | Parent control where the SVG player is embedded.
p_bindata | Pointer to a binary data stream which contains the SVG data. After passing the binary data stream, the stream is obtained by the SVG player and hence automatically released in the destructor of the SVG image.

SvgPlayer::~SvgPlayer ( void ) [virtual]

Destructs SvgPlayer and release all allocated resources

Member Function Documentation

void SvgPlayer::Cleanup ( ) [protected, virtual]

See also:
Component::Cleanup

Reimplemented from Component.

XYDIM SvgPlayer::GetDefaultHeight ( void ) const [virtual]

Returns:
returns the default height of the SVG document

Reimplemented from Component.

XYDIM SvgPlayer::GetDefaultWidth ( void ) const [virtual]

Returns:
returns the default width of the SVG document

Reimplemented from Component.

WCHAR * SvgPlayer::GetDocumentDescription ( void )

Handle meta data

Returns:
returns the document describtion.

WCHAR * SvgPlayer::GetDocumentTitle ( void )

Handle meta data that may be present within the SVG document.

Returns:
returns the document title

SvgErrorType SvgPlayer::GetErrorCode ( void ) const [inline]

Returns the error code that the last operation performed generated. Will contain NoError if the operation was successful

Returns:
returns the error code.

XYDIM SvgPlayer::GetHeight ( ) const

Returns:
Height of the bounding rectangle.

Reimplemented from Component.

WCHAR * SvgPlayer::GetPlayerName ( void )

Retrieves the Player Name

Returns:
returns the player name.

WCHAR * SvgPlayer::GetPlayerVersion ( void )

Retrieves the Player version

Returns:
returns the player version.

UINT32 SvgPlayer::GetTimePosition ( void ) const [inline]

Retrieves the actual time postion, where the SVG document is currently rendered at

Returns:
current time position of SVG animation.

XYDIM SvgPlayer::GetWidth ( ) const

Returns:
Width of the bounding rectangle.

Reimplemented from Component.

BOOLEAN SvgPlayer::Init | ( | Control * | parent,
 |  | BinData * | data
 | ) |

Creates an SVG player out of the given data. Note that dependant from the complexity of the SVG data the calling application might get blocked for up to 1 second for the loading process. If this is not suitable use SvgPlayer::Init(Control* parent) instead and invoke SvgPlayer::Load afterwards.

Parameters:
parent | Parent control where the SVG player is embedded.
data | Pointer to a binary data stream which contains the SVG data. After passing the binary data stream, the stream is obtained by the SVG player and hence automatically released in the destructor of the SVG image.

void SvgPlayer::Init ( Control * parent )

Creates an empty SVG player. To fill the player with data invoke SvgPlayer::Load afterwards, which does the loading in a background thread so that the calling application still can receive messages.

Parameters:
parent Parent control where the SVG player is embedded.

BOOLEAN SvgPlayer::IsDecoding ( ) const [inline]

Returns:
returns TRUE if decoding is still decoding

BOOLEAN SvgPlayer::IsDecodingFinished ( ) const [inline]

Returns:
returns TRUE if decoding has finished

BOOLEAN SvgPlayer::IsDocumentPanable ( void ) const

BOOLEAN SvgPlayer::IsDocumentZoomable ( void ) const

BOOLEAN SvgPlayer::Load ( BinData * data )

Loads the SVG data into the SVG engine, so that it can be drawn afterwards. The loading is done inside a separate thread, so that the calling application still can receive messages during the loading. This benefit also has some drawbacks: the calling application must take care that it will not delete the SvgPlayer instance during the loading is still active. It is recommended that the calling application disables the current focused control or window when invoking SvgImage::Load:

SvgPlayer* svg_player = new SvgPlayer(&window);
if (svg_player != 0) {
    window.SetDisabled(TRUE);
    if (svg_player->Load(data)) {
        ...
    }
    window.SetDisabled(FALSE);
}

Disabling the current focused control or window assures that the user cannot trigger e. g. a Window::OnClose, where the SVG player might get destroyed by the application although the thread still loads the SVG data. If disabling the control is not acceptable, the application itself has to implement an Active Wait mechanism to delay the destruction.

Parameters:
data Pointer to a binary data stream which contains the SVG data. After passing the binary data stream, the stream is obtained by the SVG player and hence automatically released in the destructor of the SVG player.
Returns:
TRUE if the loading has been successful.

BOOLEAN SvgPlayer::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Component::OnMessage

Reimplemented from DrawableObject.

BOOLEAN SvgPlayer::Pan | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

Pan does panning on the SVG document. Only possible, if IsDocumentPanable() returns TRUE.

Parameters:
dx | pan dx pixels horizontal
dy | pan dy pixels vertical
Returns:
returns TRUE if panning was successfully.

void SvgPlayer::Play ( UINT32 time = 0 )

After SvgPlayer::Load() or SvgPlayer::Init(), the SVG document can be played. The decoding is done in a threadlet.

Parameters:
time Starting time, at which the document should be first rendered.

void SvgPlayer::Restart ( )

Restarts an SVG animation. Time position will be set to 0.

BOOLEAN SvgPlayer::Rotate ( INT16 angle )

Rotates the SVG document with given angle.

Parameters:
angle Rotation angle
Returns:
Returns TRUE if rotation is possible, FALSE if not. Use GetErrorCode() to determine more error information.

void SvgPlayer::SetBaseURL ( WCHAR * url )

void SvgPlayer::SetEvent ( SvgEventType event )

Send an event to the SVG engine. If there is a result to the operation a message will be sent back to the application.

Parameters:
event Event, which is passed to the SVG engine

void SvgPlayer::SetHeight ( XYDIM height )

Sets a new height for the SVG document

Parameters:
height new height

Reimplemented from Component.

void SvgPlayer::SetTimePosition ( UINT32 time = 0 )

Sets the position of the time index to the given timestamp.

Parameters:
time new time position within the timestamp.

void SvgPlayer::SetWidth ( XYDIM width )

Sets a new width for the SVG document

Parameters:
width new width

Reimplemented from Component.

BOOLEAN SvgPlayer::SetZoomLevel ( INT8 level )

SetZoomLevel can be used to zoom into an SVG document. This is only possible, if IsDocumentZoomable() returns TRUE

Parameters:
level zoom level
Returns:
returns TRUE if zooming was successfully.

void SvgPlayer::Stop ( )

Stops the playback of an SVG animation. This method does not change the time position. Calling Play() will resume at actual time position.

Friends And Related Function Documentation

friend class LoadingFinishedCondition [friend]

friend class SvgPlayerView [friend]

friend class SvgThreadlet [friend]

friend class TriggerTimer< SvgPlayer > [friend]

The documentation for this class was generated from the following files:
  • AddOns/Svg/SvgPlayer.hpp
  • AddOns/Svg/SvgPlayer.cpp
Generated on Wed Jan 25 02:07:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SvgStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SvgStatusMsg Class Reference

#include <Apoxi/AddOns/Svg/MsgTypes.hpp>

Inheritance diagram for SvgStatusMsg:

[legend]
Collaboration diagram for SvgStatusMsg:

[legend]

Public Types

enum | { ID = 4401 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
SvgPlayer * | GetPlayer () const
INT8 | GetStatus () const
SvgStatusMsg (ExecutionContext *context, SvgPlayer *player, INT8 status)
virtual | ~SvgStatusMsg ()

Detailed Description

This message is sent, when an error occurs with decoding the SVG document or when an event has been processed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SvgStatusMsg::SvgStatusMsg | ( | ExecutionContext * | context,
 |  | SvgPlayer * | player,
 |  | INT8 | status
 | ) |

SvgStatusMsg::~SvgStatusMsg ( ) [virtual]

Member Function Documentation

Message * SvgStatusMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SvgStatusMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

SvgPlayer* SvgStatusMsg::GetPlayer ( ) const [inline]

INT8 SvgStatusMsg::GetStatus ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/Svg/MsgTypes.hpp
  • AddOns/Svg/MsgTypes.cpp
Generated on Wed Jan 25 02:07:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SwitchedRleCompression Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SwitchedRleCompression Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/SwitchedRleCompression.hpp>

Static Public Member Functions

static BOOLEAN | CompressBlock (const Context &context, UINT8 *dest, UINT32 &block_size)
static BOOLEAN | DecompressBlock (const Context &context, UINT8 *dest, UINT32 &block_size)
static BOOLEAN | InitContext (const BinData *src, UINT32 offset, Context &context)

Data Structures

class | Context

Detailed Description

SwitchedRleCompression is a class to compress and decompress data from a BinData using SwitchedRLE.

Member Function Documentation

BOOLEAN SwitchedRleCompression::CompressBlock | ( | const Context & | context,
 |  | UINT8 * | dest,
 |  | UINT32 & | block_size
 | ) | [static]

BOOLEAN SwitchedRleCompression::DecompressBlock | ( | const Context & | context,
 |  | UINT8 * | dest,
 |  | UINT32 & | block_size
 | ) | [static]

BOOLEAN SwitchedRleCompression::InitContext | ( | const BinData * | src,
 |  | UINT32 | offset,
 |  | Context & | context
 | ) | [static]

The documentation for this class was generated from the following files:
  • Auxiliary/SwitchedRleCompression.hpp
  • Auxiliary/SwitchedRleCompression.cpp
Generated on Wed Jan 25 02:07:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SwitchedRleCompression::Context Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SwitchedRleCompression::Context

SwitchedRleCompression::Context Class Reference

#include <Apoxi/Auxiliary/SwitchedRleCompression.hpp>

Collaboration diagram for SwitchedRleCompression::Context:

[legend]

Public Member Functions

Context ()
~Context ()

Friends

class SwitchedRleCompression

Constructor & Destructor Documentation

SwitchedRleCompression::Context::Context ( )

SwitchedRleCompression::Context::~Context ( )

Friends And Related Function Documentation

friend class SwitchedRleCompression [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/SwitchedRleCompression.hpp
  • Auxiliary/SwitchedRleCompression.cpp
Generated on Wed Jan 25 02:07:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncAction Class Reference
[Phonebook]

#include <Applications/AdvPhonebook/PbAction.hpp>

Inheritance diagram for SyncAction:

[legend]
Collaboration diagram for SyncAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN SyncAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/PbAction.hpp
  • Applications/AdvPhonebook/PbAction.cpp
Generated on Wed Jan 25 02:07:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLCTCap Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLCTCap Struct Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Collaboration diagram for SyncMLCTCap:

[legend]

Data Fields

const CHAR * | m_ct_type
const SyncMLCTProp *_MSVC_CONST_FLAW | m_prop
List of the properties of this content type.
UINT32 | m_prop_count
Number of SyncMLCTProp elements.

Detailed Description

Structure to specify the content type capabilities of this data store. Corresponds to the CTCap element in the SyncML Device Information DTD.

Field Documentation

const CHAR* SyncMLCTCap::m_ct_type

Specifies the type of a supported content type. Corresponds to the CTType element in the SyncML Device Information DTD.

const SyncMLCTProp* _MSVC_CONST_FLAW SyncMLCTCap::m_prop

List of the properties of this content type.

UINT32 SyncMLCTCap::m_prop_count

Number of SyncMLCTProp elements.

The documentation for this struct was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 02:07:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLCTParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLCTParam Struct Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Collaboration diagram for SyncMLCTParam:

[legend]

Data Fields

const CHAR * | m_param_name
const SyncMLCTValueDef *_MSVC_CONST_FLAW | m_value_def
List of the allowed values for the parameter.
UINT32 | m_value_def_count
Number of SyncMLCTValueDef elements.

Detailed Description

Structure for parameter definitions for content type properties.

Field Documentation

const CHAR* SyncMLCTParam::m_param_name

Specifies name of a supported parameter of a given content type property. Corresponds to the ParamName element in the SyncML Device Information DTD.

const SyncMLCTValueDef* _MSVC_CONST_FLAW SyncMLCTParam::m_value_def

List of the allowed values for the parameter.

UINT32 SyncMLCTParam::m_value_def_count

Number of SyncMLCTValueDef elements.

The documentation for this struct was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 02:07:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLCTProp Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLCTProp Struct Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Collaboration diagram for SyncMLCTProp:

[legend]

Data Fields

const SyncMLCTParam *_MSVC_CONST_FLAW | m_param
List of parameters for the content type property.
UINT32 | m_param_count
Number of SyncMLCTParam elements.
const CHAR * | m_prop_name
const SyncMLCTValueDef *_MSVC_CONST_FLAW | m_value_def
List of the allowed values for the property.
UINT32 | m_value_def_count
Number of SyncMLValueDef elements.

Detailed Description

Structure for property definitions for content type capabilites.

Field Documentation

const SyncMLCTParam* _MSVC_CONST_FLAW SyncMLCTProp::m_param

List of parameters for the content type property.

UINT32 SyncMLCTProp::m_param_count

Number of SyncMLCTParam elements.

const CHAR* SyncMLCTProp::m_prop_name

Specifies the name of the supported property of a content type. Corresponds to the PropName element in the SyncML Device Information DTD.

const SyncMLCTValueDef* _MSVC_CONST_FLAW SyncMLCTProp::m_value_def

List of the allowed values for the property.

UINT32 SyncMLCTProp::m_value_def_count

Number of SyncMLValueDef elements.

The documentation for this struct was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 02:07:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLCTTypeVerCT Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLCTTypeVerCT Struct Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Data Fields

const CHAR * | m_ct_type
const CHAR * | m_ver_ct

Detailed Description

Structure to hold the type and version of a supported content type.

Field Documentation

const CHAR* SyncMLCTTypeVerCT::m_ct_type

Specifies the type of a supported content type. Corresponds to the CTType element in the SyncML Device Information DTD.

const CHAR* SyncMLCTTypeVerCT::m_ver_ct

Specifies the version of a supported content type. Corresponds to the VerCT element in the SyncML Device Information DTD.

The documentation for this struct was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 02:07:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLCTValueDef Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLCTValueDef Struct Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Data Fields

const CHAR * | m_data_type
const CHAR * | m_display_name
UINT32 | m_size
const CHAR * | m_val_enum

Detailed Description

Structure for allowed values of content type properties and parameters. Use one of val_enum or data_type, size, and display_name

Field Documentation

const CHAR* SyncMLCTValueDef::m_data_type

Specifies the type of a supported content type. Corresponds to the DataType element in the SyncML Device Information DTD.

const CHAR* SyncMLCTValueDef::m_display_name

Specifies the display name of the given content type property or parameter. Corresponds to the DisplayName element in the SyncML Device Information DTD.

UINT32 SyncMLCTValueDef::m_size

Specifies the size of a property or a parameter of a given content type. Corresponds to the Size element in the SyncML Device Information DTD.

const CHAR* SyncMLCTValueDef::m_val_enum

Specifies the supported enumerated value of a given content type property. Corresponds to the ValEnum element in the SyncML Device Information DTD.

The documentation for this struct was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 02:07:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLDataStoreProps Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLDataStoreProps Struct Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Collaboration diagram for SyncMLDataStoreProps:

[legend]

Data Fields

const SyncMLCTCap *_MSVC_CONST_FLAW | m_ct_cap
List of supported content type capabilities of this data store.
UINT32 | m_ct_cap_count
Number of SyncMLCTCap elements.
const CHAR * | m_display_name
UINT16 | m_max_guid_size
UINT32 | m_max_id
UINT32 | m_max_mem
const SyncMLCTTypeVerCT *_MSVC_CONST_FLAW | m_rx
UINT16 | m_rx_count
Number of SyncMLCTTypeVerCT elements.
const SyncMLCTTypeVerCT *_MSVC_CONST_FLAW | m_rx_pref
BOOLEAN | m_shared_mem
const CHAR * | m_source_ref
BOOLEAN | m_support_large_objects
const SyncMLSyncType *_MSVC_CONST_FLAW | m_sync_cap
UINT16 | m_sync_type_count
Number of the SyncMLSyncType elements in m_sync_cap.
const SyncMLCTTypeVerCT *_MSVC_CONST_FLAW | m_tx
UINT16 | m_tx_count
Number of SyncMLCTTypeVerCT elements.
const SyncMLCTTypeVerCT *_MSVC_CONST_FLAW | m_tx_pref

Detailed Description

Structure to specify the properties of the datastore. Corresponds to the DataStore element in the SyncML Device Information DTD.

Field Documentation

const SyncMLCTCap* _MSVC_CONST_FLAW SyncMLDataStoreProps::m_ct_cap

List of supported content type capabilities of this data store.

UINT32 SyncMLDataStoreProps::m_ct_cap_count

Number of SyncMLCTCap elements.

const CHAR* SyncMLDataStoreProps::m_display_name

Specifies the display name of the datastore. Corresponds to the DisplayName element in the SyncML Device Information DTD. Optional!

UINT16 SyncMLDataStoreProps::m_max_guid_size

Specifies the maximum size of the global unique identifier for the datastore. Corresponds to the MaxGUIDSize element in the SyncML Device Information DTD. Optional!

UINT32 SyncMLDataStoreProps::m_max_id

Specifies the maximum number of items that can be stored in the datastore. Corresponds to the MaxID element in the SyncML Device Information DTD. Optional!

UINT32 SyncMLDataStoreProps::m_max_mem

Specifies the maximum memory size for a given local datastore, in bytes. Corresponds to the MaxMem element in the SyncML Device Information DTD. Optional!

const SyncMLCTTypeVerCT* _MSVC_CONST_FLAW SyncMLDataStoreProps::m_rx

List of the supported types and versions of a content type which can be received by the device. Corresponds to the Rx element in the SyncML Device Information DTD. Maybe empty!

UINT16 SyncMLDataStoreProps::m_rx_count

Number of SyncMLCTTypeVerCT elements.

const SyncMLCTTypeVerCT* _MSVC_CONST_FLAW SyncMLDataStoreProps::m_rx_pref

Specifies the preferred type and version of a content type received by the device. Corresponds to the Rx-Pref element in the SyncML Device Information DTD. Mandatory!

BOOLEAN SyncMLDataStoreProps::m_shared_mem

Specifies if the datastore memory is shared with other data stores. Corresponds to the SharedMem element in the SyncML Device Information DTD.

const CHAR* SyncMLDataStoreProps::m_source_ref

Specifies the reference URI for the database. Corresponds to the SourceRef element in the SyncML Device Information DTD. Mandatory!

BOOLEAN SyncMLDataStoreProps::m_support_large_objects

Specifies that the data store supports handling of large objects. Corresponds to the SupportLargeObjs element in the SyncML Device Information DTD.

const SyncMLSyncType* _MSVC_CONST_FLAW SyncMLDataStoreProps::m_sync_cap

Specifies the synchronization capabilities of the datastore in the form of a list of supported types of synchronization. Corresponds to the SyncCap element in the SyncML Device Information DTD. Mandatory!

UINT16 SyncMLDataStoreProps::m_sync_type_count

Number of the SyncMLSyncType elements in m_sync_cap.

const SyncMLCTTypeVerCT* _MSVC_CONST_FLAW SyncMLDataStoreProps::m_tx

List of the supported types and versions of a content type which can be transmitted by the device. Corresponds to the Tx element in the SyncML Device Information DTD. Maybe empty!

UINT16 SyncMLDataStoreProps::m_tx_count

Number of SyncMLCTTypeVerCT elements.

const SyncMLCTTypeVerCT* _MSVC_CONST_FLAW SyncMLDataStoreProps::m_tx_pref

Specifies the preferred type and version of a content type transmitted by the device. Corresponds to the Tx-Pref element in the SyncML Device Information DTD. Mandatory!

The documentation for this struct was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 02:07:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLDynamicProps Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLDynamicProps Struct Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Data Fields

UINT32 | m_free_id
UINT32 | m_free_mem

Detailed Description

Structure for device information about dynamic characteristics of the data store.

Field Documentation

UINT32 SyncMLDynamicProps::m_free_id

Specifies the number of free item identifiers available for adding new items to the datastore. Corresponds to the FreeID element in the SyncML Meta-Information DTD.

UINT32 SyncMLDynamicProps::m_free_mem

Specifies the amount of free memory, in bytes, available in the local datastore. Corresponds to the FreeMem element in the SyncML Meta-Information DTD.

The documentation for this struct was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 02:07:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLItemMetaInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLItemMetaInfo Struct Reference

#include <Apoxi/AddOns/SyncML/DBService.hpp>

Collaboration diagram for SyncMLItemMetaInfo:

[legend]

Data Fields

String m_format
String m_mark
UINT32 m_size
String m_type
String m_version

Detailed Description

Structure for meta information about the item data retrieved from the data store. Corresponds to the MetInf element type in the SyncML Meta-Information DTD.

Field Documentation

String SyncMLItemMetaInfo::m_format

Specifies the encoding format of the content information in the data element. Corresponds to the Format element in the SyncML Meta-Information DTD. Has to be one of bin, bool, b64, chr, int, node, null or xml. Mandatory!

String SyncMLItemMetaInfo::m_mark

Specifies a meta-information "mark" on the data object. Should be draft, final, delete, undelete, read, unread, etc. Corresponds to the Mark element in the SyncML Meta-Information DTD. Optional!

UINT32 SyncMLItemMetaInfo::m_size

Specifies the byte size of a data object. Corresponds to the Size element in the SyncML Meta-Information DTD. Optional!

String SyncMLItemMetaInfo::m_type

Specifies the media type of the content information in the Data element. Corresponds to the Type element in the SyncML Meta-Information DTD. Mandatory!

String SyncMLItemMetaInfo::m_version

Specifies the version identifier of a data object. Corresponds to the Version element in the SyncML Meta-Information DTD. Optional!

The documentation for this struct was generated from the following file:
  • AddOns/SyncML/DBService.hpp
Generated on Wed Jan 25 02:07:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncMLManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncMLManager Class Reference

#include <Apoxi/AddOns/SyncML/SyncMLManager.hpp>

Collaboration diagram for SyncMLManager:

[legend]

Public Member Functions

UINT16 | GetDataStoreUri (const String &db_uri) const
String | GetDataStoreUri (UINT16 db_uri) const
DBService * | GetDBServiceFromURI (UINT16 db_uri) const
BOOLEAN | GetDeviceInfo (SyncMLDeviceInfo &device_info) const
UINT16 | GetNumOfDataStores () const
BOOLEAN | GetRegisteredDataStore (UINT16 idx, Guid &db_guid, UINT16 &db_uri_id, String &db_uri_string) const
const Guid & | GetServiceGuid (UINT16 db_uri) const
BOOLEAN | PostItemChangedMsg (UINT16 db_uri, UINT32 item_uri, const DateTime &time_stamp, SyncMLChangeType change_code) const
BOOLEAN | RegisterDataStore (const Guid &db_guid, UINT16 db_uri_id, const String &db_uri_string)
BOOLEAN | RegisterSyncMLApplication (Application *syncml_app)
~SyncMLManager ()
Destructor.

Static Public Member Functions

static SyncMLManager & | GetInstance ()

Data Structures

struct | DbGuidItem

Detailed Description

The SyncMLManager class is a singleton for supporting SyncML applications. It fulfills 3 main tasks: (1) It allows to register datastores as well as the SyncML application and keeps a list of the registered data stores, (2) it provides means for the data store application to signal changes of items, and (3) it allows the SyncML application to retrieve information about the device.

The SyncMLManager maintains a list of registered data stores. Also it keeps a reference to the SyncML application for message posting.

Constructor & Destructor Documentation

SyncMLManager::~SyncMLManager ( )

Destructor.

Member Function Documentation

UINT16 SyncMLManager::GetDataStoreUri ( const String & db_uri ) const

Gets the short id representation of the given Database URI.

Parameters:
db_uri[in] : DBService URI (legible string representation).
Returns:
the short id representation of the DB-URI, 0 if not found.

String SyncMLManager::GetDataStoreUri ( UINT16 db_uri ) const

Gets the legible string representation of the given Database URI.

Parameters:
db_uri[in] : DBService URI (short id representation).
Returns:
the legible string representation of the DB-URI, which is empty if an unknown DB-URI was given.

DBService * SyncMLManager::GetDBServiceFromURI ( UINT16 db_uri ) const

Gets the DBService object corresponding to the database URI.

Parameters:
db_uri[in] : DBService URI.
Returns:
a pointer to the DBService object.

BOOLEAN SyncMLManager::GetDeviceInfo ( SyncMLDeviceInfo & device_info ) const

Retrieve the device information for this device.

Parameters:
device_info[out] : the device information for this device.
Returns:
TRUE if succesful, FALSE otherwise.

SyncMLManager & SyncMLManager::GetInstance ( ) [static]

Returns the singleton instance of the class SyncMLManager.

Returns:
a reference to singleton SyncMLManager instance.

UINT16 SyncMLManager::GetNumOfDataStores ( ) const

Get the total number of registered data stores.

Returns:
the number of registered data stores.

BOOLEAN SyncMLManager::GetRegisteredDataStore | ( | UINT16 | idx,
 |  | Guid & | db_guid,
 |  | UINT16 & | db_uri_id,
 |  | String & | db_uri_string
 | ) | const

Get the data store GUID and URI of the specified index of the internal data store list.

Parameters:
idx[in] | : the index of the data store which should be retrieved
db_guid[out] | : the GUID of the requested data store
db_uri_id[out] | : the URI of the requested data store (short id representation)
db_uri_string[out] | : the URI of the requested data store (legible string representation)
Returns:
TRUE if successful, FALSE otherwise.

const Guid & SyncMLManager::GetServiceGuid ( UINT16 db_uri ) const

Gets the Guid of DBService corresponding to the database URI.

Parameters:
db_uri[in] : Database URI.
Returns:
the GUID of the DBService object.

BOOLEAN SyncMLManager::PostItemChangedMsg | ( | UINT16 | db_uri,
 |  | UINT32 | item_uri,
 |  | const DateTime & | time_stamp,
 |  | SyncMLChangeType | change_code
 | ) | const

Allows posting of item change messages at the Apoxi message router, which are forwarded to the SyncML application (if one exists).

Parameters:
db_uri[in] | : the URI of the data store.
item_uri[in] | : the URI of the data item. In case of SyncMLChangeType::SyncMLItemDeletedAll the item URI must be 0.
time_stamp[in] | : the time stamp of the change.
change_code[in] | : the operation code for the change.
Returns:
TRUE if succesful, FALSE otherwise.

BOOLEAN SyncMLManager::RegisterDataStore | ( | const Guid & | db_guid,
 |  | UINT16 | db_uri_id,
 |  | const String & | db_uri_string
 | ) |

This method is used to register data stores services (DBService objects). Registration is done with the GUID of the DBService object and the URI of the data store.

Parameters:
db_guid[in] | : DBService Guid.
db_uri_id[in] | : Database URI (short id representation).
db_uri_string[in] | : Database URI (legible string representation).
Returns:
TRUE if successful, FALSE otherwise.

BOOLEAN SyncMLManager::RegisterSyncMLApplication ( Application * syncml_app )

Register the SyncML application at the SyncMLManager.

Parameters:
syncml_app[in] : the pointer to the SyncMLApplication object.
Returns:
TRUE if succesful, FALSE otherwise.

The documentation for this class was generated from the following files:
  • AddOns/SyncML/SyncMLManager.hpp
  • AddOns/SyncML/SyncMLManager.cpp
Generated on Wed Jan 25 02:08:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncPaintDc Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncPaintDc Class Reference
[GUI]

#include <Apoxi/Gui/SyncPaintDc.hpp>

Inheritance diagram for SyncPaintDc:

[legend]
Collaboration diagram for SyncPaintDc:

[legend]

Public Member Functions

SyncPaintDc (Control *control)
virtual ~SyncPaintDc ()

Detailed Description

Allows a comfortable usage for working on a Device-Context when doing a synchronous drawing. In opposite to the class PaintDc the class SyncPaintDc is used outside the context of Control::OnPaint.

Constructor & Destructor Documentation

SyncPaintDc::SyncPaintDc ( Control * control )

Parameters:
control Control where the drawing should be done. It is recommended that the auto clearing of the control is disabled by invoking Control::SetAutoClearEnabled(FALSE) on the initialization of the control. This is because usually auto-clearing leads to a flickering in combination with a synchronous drawing.

SyncPaintDc::~SyncPaintDc ( ) [virtual]

The documentation for this class was generated from the following files:
  • Gui/SyncPaintDc.hpp
  • Gui/SyncPaintDc.cpp
Generated on Wed Jan 25 02:08:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncPhoneAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncPhoneAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for SyncPhoneAction:

[legend]
Collaboration diagram for SyncPhoneAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN SyncPhoneAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 02:08:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncPhoneAllAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncPhoneAllAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for SyncPhoneAllAction:

[legend]
Collaboration diagram for SyncPhoneAllAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN SyncPhoneAllAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 02:08:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncPhoneThreadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncPhoneThreadlet Class Reference
[Kernel]

#include <Applications/AdvPhonebook/SyncPhoneThreadlet.hpp>

Inheritance diagram for SyncPhoneThreadlet:

[legend]
Collaboration diagram for SyncPhoneThreadlet:

[legend]

Public Member Functions

virtual INT | Fn ()
void | Init (Application *app, PbSynchronizer *synchronizer)
BOOLEAN | IsRunning ()
virtual void | OnEndOfExecute ()
SyncPhoneThreadlet ()
BOOLEAN | SyncSucceeded ()
virtual | ~SyncPhoneThreadlet ()

Constructor & Destructor Documentation

SyncPhoneThreadlet::SyncPhoneThreadlet ( )

SyncPhoneThreadlet::~SyncPhoneThreadlet ( ) [virtual]

Member Function Documentation

INT SyncPhoneThreadlet::Fn ( ) [virtual]

Fn is the function that will be executed in thread context. Be aware of restrictions to operations that can be performed in thread context.

Implements Threadlet.

void SyncPhoneThreadlet::Init | ( | Application * | app,
 |  | PbSynchronizer * | synchronizer
 | ) |

BOOLEAN SyncPhoneThreadlet::IsRunning ( ) [inline]

void SyncPhoneThreadlet::OnEndOfExecute ( ) [virtual]

Is invoked after Fn has been executed. The default implementation sends the message ThreadletNotificationMsg to the application that executed the threadlet. Important: when overwriting the method invoke the base-method always at the end!

Reimplemented from Threadlet.

BOOLEAN SyncPhoneThreadlet::SyncSucceeded ( ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/SyncPhoneThreadlet.hpp
  • Applications/AdvPhonebook/SyncPhoneThreadlet.cpp
Generated on Wed Jan 25 02:08:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncProgressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncProgressMsg Class Reference

#include <Applications/AdvPhonebook/AdvPbMsgTypes.hpp>

Inheritance diagram for SyncProgressMsg:

[legend]
Collaboration diagram for SyncProgressMsg:

[legend]

Public Types

enum | { ID = 30006 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
INT | GetProgress () const
void | SetProgress (INT progress)
SyncProgressMsg (ExecutionContext *context, INT progress)
virtual | ~SyncProgressMsg ()

Detailed Description

Phonebook

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

SyncProgressMsg::SyncProgressMsg | ( | ExecutionContext * | context,
 |  | INT | progress
 | ) |

SyncProgressMsg::~SyncProgressMsg ( ) [virtual]

Member Function Documentation

Message * SyncProgressMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & SyncProgressMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

INT SyncProgressMsg::GetProgress ( ) const [inline]

void SyncProgressMsg::SetProgress ( INT progress ) [inline]

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbMsgTypes.hpp
  • Applications/AdvPhonebook/AdvPbMsgTypes.cpp
Generated on Wed Jan 25 02:08:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncSimAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncSimAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for SyncSimAction:

[legend]
Collaboration diagram for SyncSimAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN SyncSimAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 02:08:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SyncSimAllAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SyncSimAllAction Class Reference
[AdvPhonebookActions]

#include <Applications/AdvPhonebook/AdvPbAction.hpp>

Inheritance diagram for SyncSimAllAction:

[legend]
Collaboration diagram for SyncSimAllAction:

[legend]

Public Member Functions

virtual BOOLEAN Execute ()

Member Function Documentation

BOOLEAN SyncSimAllAction::Execute ( ) [virtual]

Per default the message ActionExexutedMsg is send to the Dispatcher provided by the constructor or Init. This allows to implement the code for executing e. g. in a Window or an Application. It is also possible to implement the code simply by overwriting this method.

See also:
Window::OnActionExecuted

Reimplemented from PbSecuredAction.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/AdvPbAction.hpp
  • Applications/AdvPhonebook/AdvPbAction.cpp
Generated on Wed Jan 25 02:08:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SysDnsClient Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SysDnsClient Class Reference
[Socket, Socket]

#include <Apoxi/Socket/Sys/GlDummy/DummyDnsClient.hpp>

Collaboration diagram for SysDnsClient:

[legend]

Public Member Functions

void | OnTimer ()

Static Public Member Functions

static INT | GetHostByAddr (const IpAddr &ip_addr, String &name, const DataConnPtr &dc_ptr)
static INT | GetHostByAddr (const IpAddr &ip_addr, String &name, const DataConnPtr &dc_ptr)
static UINT16 | GetHostByAddr (const IpAddr &ip_addr, String &name, DataConnProfile *dc_profile)
Blocking: resolves address, returns success or an error code.
static INT | GetHostByName (const String &name, IpAddr &ip_addr, const DataConnPtr &dc_ptr)
static INT | GetHostByName (const String &name, IpAddr &ip_addr, const DataConnPtr &dc_ptr)
static UINT16 | GetHostByName (const String &name, IpAddr &ip_addr, DataConnProfile *dc_profile)
Blocking: resolves host name, returns success or an error code.
static void | Init ()

Protected Member Functions

INT | GetHostByAddrAsync (const IpAddr &ip_addr)
INT | GetHostByAddrAsync (const IpAddr &ip_addr)
BOOLEAN | GetHostByAddrAsync (DnsClient *dnsc, const IpAddr &ip_addr)
Asynchronous: resolves address.
INT | GetHostByNameAsync (const String &name)
INT | GetHostByNameAsync (const String &name)
BOOLEAN | GetHostByNameAsync (DnsClient *dnsc, const String &name)
Asynchronous: resolves host name.
SysDnsClient (DnsClient *dns_client)
SysDnsClient (DnsClient *dns_client)
SysDnsClient (DataConnProfile *dc_profile)
virtual | ~SysDnsClient ()
virtual | ~SysDnsClient ()
~SysDnsClient ()

Friends

class | DnsClient

Data Structures

struct | AsyncDnsRequest

Detailed Description

SysDnsClient implements a platform specific DNS client to retrieve information synchronously and asynchronously. Application programmers should not use that classes directly, use the common interface of DnsClient.hpp instead.

Constructor & Destructor Documentation

SysDnsClient::SysDnsClient ( DataConnProfile * dc_profile ) [inline, protected]

Creates an instance of DnsClient that can be used for asynchronous requests.

SysDnsClient::~SysDnsClient ( ) [inline, protected]

SysDnsClient::SysDnsClient ( DnsClient * dns_client ) [protected]

Constructor. Creates an instance of SysDnsClient that can be used for asynchronous requests.

virtual SysDnsClient::~SysDnsClient ( ) [protected, virtual]

Destructor. Destroys the SysDnsClient and terminates any open asynchronous DNS requests.

SysDnsClient::SysDnsClient ( DnsClient * dns_client ) [protected]

Constructor. Creates an instance of SysDnsClient that can be used for asynchronous requests.

virtual SysDnsClient::~SysDnsClient ( ) [protected, virtual]

Destructor. Destroys the SysDnsClient and terminates any open asynchronous DNS requests.

Member Function Documentation

static INT SysDnsClient::GetHostByAddr | ( | const IpAddr & | ip_addr,
 |  | String & | name,
 |  | const DataConnPtr & | dc_ptr
 | ) | [static]

Resolves host name using the given data connection, returns success or an error code (synchronous, blocking call).

INT SysDnsClient::GetHostByAddr | ( | const IpAddr & | ip_addr,
 |  | String & | name,
 |  | const DataConnPtr & | dc_ptr
 | ) | [static]

Resolves host name using the given data connection, returns success or an error code (synchronous, blocking call).

static UINT16 SysDnsClient::GetHostByAddr | ( | const IpAddr & | ip_addr,
 |  | String & | name,
 |  | DataConnProfile * | dc_profile
 | ) | [inline, static]

Blocking: resolves address, returns success or an error code.

INT SysDnsClient::GetHostByAddrAsync ( const IpAddr & ip_addr ) [protected]

Resolves host address, returns success or an error code (asynchronous, non-blocking call.

INT SysDnsClient::GetHostByAddrAsync ( const IpAddr & ip_addr ) [protected]

Resolves host address, returns success or an error code (asynchronous, non-blocking call.

BOOLEAN SysDnsClient::GetHostByAddrAsync | ( | DnsClient * | dnsc,
 |  | const IpAddr & | ip_addr
 | ) | [inline, protected]

Asynchronous: resolves address.

static INT SysDnsClient::GetHostByName | ( | const String & | name,
 |  | IpAddr & | ip_addr,
 |  | const DataConnPtr & | dc_ptr
 | ) | [static]

Resolves host name using the given data connection, returns success or an error code (synchronous, blocking call).

INT SysDnsClient::GetHostByName | ( | const String & | name,
 |  | IpAddr & | ip_addr,
 |  | const DataConnPtr & | dc_ptr
 | ) | [static]

Resolves host name using the given data connection, returns success or an error code (synchronous, blocking call).

static UINT16 SysDnsClient::GetHostByName | ( | const String & | name,
 |  | IpAddr & | ip_addr,
 |  | DataConnProfile * | dc_profile
 | ) | [inline, static]

Blocking: resolves host name, returns success or an error code.

INT SysDnsClient::GetHostByNameAsync ( const String & name ) [protected]

Resolves host name, returns success or an error code (asynchronous, non-blocking call.

INT SysDnsClient::GetHostByNameAsync ( const String & name ) [protected]

Resolves host name, returns success or an error code (asynchronous, non-blocking call.

BOOLEAN SysDnsClient::GetHostByNameAsync | ( | DnsClient * | dnsc,
 |  | const String & | name
 | ) | [inline, protected]

Asynchronous: resolves host name.

static void SysDnsClient::Init ( ) [inline, static]

void SysDnsClient::OnTimer ( ) [inline]

Friends And Related Function Documentation

DnsClient [friend]

The documentation for this class was generated from the following files:
  • Socket/Sys/GlDummy/DummyDnsClient.hpp
  • Socket/Sys/GlLwip/LwipSysDnsClient.hpp
  • Socket/Sys/GlWin32/Win32SysDnsClient.hpp
  • Socket/Sys/GlLwip/LwipSysDnsClient.cpp
  • Socket/Sys/GlWin32/Win32SysDnsClient.cpp
Generated on Wed Jan 25 02:08:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SysSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SysSocket Class Reference
[Socket, Socket]

#include <Apoxi/Socket/Sys/GlBsd/BsdSysSocket.hpp>

Inheritance diagram for SysSocket:

[legend]
Collaboration diagram for SysSocket:

[legend]

Public Types

enum | { c_pref_stack_size = 3000 }
enum | { c_pref_stack_size = 3000 }
enum | { c_pref_stack_size = 3000 }
enum | { c_pref_stack_size = 3000 }
enum | { c_pref_stack_size = 3000 }
enum | AddrFamily { c_addr_family_inet = AF_INET, c_addr_family_unspec = AF_UNSPEC }
enum | AddrFamily { c_addr_family_inet = AF_INET, c_addr_family_unspec = AF_UNSPEC }
enum | AddrFamily { c_addr_family_inet = AF_INET, c_addr_family_unspec = AF_UNSPEC }
typedef void(* | LwipPppConnSetupDone )(int error)
typedef INT | Protocol
typedef int | Protocol
typedef int | Protocol
typedef int | Protocol
typedef int | Protocol
typedef UINT32 | SocketHdl
typedef int | SocketHdl
typedef int | SocketHdl
typedef int | SocketHdl
typedef int | SocketHdl
enum | Type { c_type_dgram = SOCK_DGRAM, c_type_stream = SOCK_STREAM, c_type_raw = SOCK_RAW }
enum | Type { c_type_dgram = SOCK_DGRAM, c_type_stream = SOCK_STREAM, c_type_raw = SOCK_RAW }
enum | Type { c_type_dgram = SOCK_DGRAM, c_type_stream = SOCK_STREAM, c_type_raw = SOCK_RAW }

Public Member Functions

BOOLEAN | Accept (SysSocket *s, InetSocketAddr *peer)
BOOLEAN | Accept (SysSocket *s, InetSocketAddr *peer)
BOOLEAN | Accept (SysSocket *s, InetSocketAddr *peer)
BOOLEAN | Accept (SysSocket *s, InetSocketAddr *peer)
BOOLEAN | Accept (SysSocket *s, InetSocketAddr *peer)
BOOLEAN | Bind (const InetSocketAddr &addr)
INT | Bind (const InetSocketAddr &addr)
BOOLEAN | Bind (const InetSocketAddr &addr)
INT | Bind (const InetSocketAddr &addr)
INT | Bind (const InetSocketAddr &addr)
BOOLEAN | Close ()
INT | Close ()
BOOLEAN | Close ()
INT | Close ()
INT | Close ()
BOOLEAN | Connect (const InetSocketAddr &peer)
INT | Connect (const InetSocketAddr &peer)
BOOLEAN | Connect (const InetSocketAddr &peer)
INT | Connect (const InetSocketAddr &peer)
INT | Connect (const InetSocketAddr &peer)
SocketHdl | GetHdl () const
SocketHdl | GetHdl () const
SocketHdl | GetHdl () const
SocketHdl | GetHdl () const
SocketHdl | GetHdl () const
BOOLEAN | GetInBufByteCount (UINT &arg) const
INT | GetInBufByteCount (UINT &arg)
BOOLEAN | GetInBufByteCount (UINT &arg) const
INT | GetInBufByteCount (UINT &arg)
INT | GetInBufByteCount (UINT &arg)
BOOLEAN | GetLingerOption (LingerSetting &linger_setting) const
BOOLEAN | GetLingerOption (LingerSetting &linger_setting) const
BOOLEAN | GetLocal (InetSocketAddr &local) const
INT | GetLocal (InetSocketAddr &local)
BOOLEAN | GetLocal (InetSocketAddr &local) const
INT | GetLocal (InetSocketAddr &local)
INT | GetLocal (InetSocketAddr &local)
BOOLEAN | GetOption (OptionType type, INT &val) const
INT | GetOption (OptionType type, INT &val)
BOOLEAN | GetOption (OptionType type, INT &val) const
INT | GetOption (OptionType type, INT &val)
INT | GetOption (OptionType type, INT &val)
BOOLEAN | GetPeer (InetSocketAddr &peer) const
INT | GetPeer (InetSocketAddr &peer)
BOOLEAN | GetPeer (InetSocketAddr &peer) const
INT | GetPeer (InetSocketAddr &peer)
INT | GetPeer (InetSocketAddr &peer)
SocketError | GetSysError (BOOLEAN include_global_errors=TRUE) const
SocketError GetSysError ()
SocketError | GetSysError (BOOLEAN include_global_errors=TRUE) const
SocketError GetSysError ()
SocketError GetSysError ()
BOOLEAN | Init (INT af, INT type, INT protocol)
BOOLEAN | Init (INT af, INT type, INT protocol)
BOOLEAN | Init (INT af, INT type, INT protocol)
BOOLEAN | IsBlocking () const
BOOLEAN | IsBlocking () const
BOOLEAN | IsValid () const
BOOLEAN | IsValid () const
BOOLEAN | IsValid () const
BOOLEAN | IsValid () const
BOOLEAN | IsValid () const
BOOLEAN | Listen (INT backlog)
INT | Listen (INT backlog)
BOOLEAN | Listen (INT backlog)
INT | Listen (INT backlog)
INT | Listen (INT backlog)
BOOLEAN | Open (AddrFamily af, Type type, Protocol protocol)
BOOLEAN | Open (AddrFamily af, Type type, Protocol protocol)
INT | Recv (void *buf, INT buflen, INT flags)
INT | Recv (void *buf, INT buflen, INT flags)
INT | Recv (void *buf, INT buflen, INT flags)
INT | Recv (void *buf, INT buflen, INT flags)
INT | Recv (void *buf, INT buflen, INT flags)
INT | RecvFrom (void *buf, INT buflen, INT flags, InetSocketAddr &peer)
INT | RecvFrom (void *buf, INT buflen, INT flags, InetSocketAddr &peer)
INT | RecvFrom (void *buf, INT buflen, INT flags, InetSocketAddr &peer)
INT | RecvFrom (void *buf, INT buflen, INT flags, InetSocketAddr &peer)
INT | RecvFrom (void *buf, INT buflen, INT flags, InetSocketAddr &peer)
INT | Send (const void *buf, INT buflen, INT flags)
INT | Send (const void *buf, INT buflen, INT flags)
INT | Send (const void *buf, INT buflen, INT flags)
INT | Send (const void *buf, INT buflen, INT flags)
INT | Send (const void *buf, INT buflen, INT flags)
INT | SendTo (const void *buf, INT buflen, INT flags, const InetSocketAddr &peer)
INT | SendTo (const void *buf, INT buflen, INT flags, const InetSocketAddr &peer)
INT | SendTo (const void *buf, INT buflen, INT flags, const InetSocketAddr &peer)
INT | SendTo (const void *buf, INT buflen, INT flags, const InetSocketAddr &peer)
INT | SendTo (const void *buf, INT buflen, INT flags, const InetSocketAddr &peer)
BOOLEAN | SetBlocking (BOOLEAN blocking=TRUE)
BOOLEAN | SetBlocking (BOOLEAN blocking=TRUE)
BOOLEAN | SetLingerOption (const LingerSetting &linger_setting)
BOOLEAN | SetLingerOption (const LingerSetting &linger_setting)
BOOLEAN | SetNsapi (UINT8 nsapi)
BOOLEAN | SetNsapi (UINT8 nsapi)
BOOLEAN | SetOption (OptionType type, INT val)
INT | SetOption (OptionType type, INT val)
BOOLEAN | SetOption (OptionType type, INT val)
INT | SetOption (OptionType type, INT val)
INT | SetOption (OptionType type, INT val)
BOOLEAN | Shutdown (ShutdownMode how)
INT | Shutdown (INT how)
BOOLEAN | Shutdown (ShutdownMode how)
INT | Shutdown (INT)
INT | Shutdown (INT how)
SysSocket (SocketHdl socket=GetInvalidHdl())
SysSocket (SocketHdl socket=-1)
SysSocket (SocketHdl socket=GetInvalidHdl())
SysSocket (SocketHdl socket=-1)
SysSocket (SocketHdl socket=-1)

Static Public Member Functions

static SocketHdl | GetInvalidHdl ()
static SocketHdl | GetInvalidHdl ()
static SocketHdl | GetInvalidHdl ()
static SocketHdl | GetInvalidHdl ()
static SocketHdl | GetInvalidHdl ()
static UINT8 | GetInvalidNsapi ()
static UINT8 | GetInvalidNsapi ()
static void | LwipPppSetConnInformation (const void *info)
static INT | PsdLinkInit (const UINT8 nsapi)
static INT | PsdLinkStop (const UINT8 nsapi)
static INT | PsdLinkUp (const UINT8 nsapi, BOOLEAN ackmode, UINT32 ipaddr)

Protected Member Functions

SocketError | GetSysErr (BOOLEAN check_errno) const
SocketError | GetSysErr (BOOLEAN check_errno) const

Friends

class | DataConn
class | DataConnManager
class | PppDataConn
class | PsdDataConn
class | SocketRxThread

Data Structures

class | FdSet
class | FdSet
class | FdSet
class | FdSet
class | FdSet

Detailed Description

SysSocket class represents adaptation layer to BSD style socket systems. SysSocket is an Apoxi Socket internal class and must not be used by application layer. This class abstracts BSD style socket interfaces. BSD ist not an official supported system socket type.

Member Typedef Documentation

typedef void(* SysSocket::LwipPppConnSetupDone)(int error)

Type of callback function to use on lwIP PPP setup. This typedef has to be public, otherwise the compiler reports an error that it is inaccessible.

typedef INT SysSocket::Protocol

typedef int SysSocket::Protocol

typedef int SysSocket::Protocol

typedef int SysSocket::Protocol

typedef int SysSocket::Protocol

typedef UINT32 SysSocket::SocketHdl

typedef int SysSocket::SocketHdl

typedef int SysSocket::SocketHdl

typedef int SysSocket::SocketHdl

typedef int SysSocket::SocketHdl

Member Enumeration Documentation

anonymous enum

Enumerator:
c_pref_stack_size The preferred stack size for class SocketRxThread.

anonymous enum

Enumerator:
c_pref_stack_size The preferred stack size for class SocketRxThread.

anonymous enum

Enumerator:
c_pref_stack_size The preferred stack size for class SocketRxThread.

anonymous enum

Enumerator:
c_pref_stack_size The preferred stack size for class SocketRxThread.

anonymous enum

Enumerator:
c_pref_stack_size The preferred stack size for class SocketRxThread.

enum SysSocket::AddrFamily

AddrFamily specifies the address family of the socket (only used internally).

Enumerator:
c_addr_family_inet
c_addr_family_unspec

Reimplemented from SysSocketBase.

enum SysSocket::AddrFamily

AddrFamily specifies the address family of the socket (only used internally).

Enumerator:
c_addr_family_inet
c_addr_family_unspec

Reimplemented from SysSocketBase.

enum SysSocket::AddrFamily

AddrFamily specifies the address family of the socket (only used internally).

Enumerator:
c_addr_family_inet
c_addr_family_unspec

Reimplemented from SysSocketBase.

enum SysSocket::Type

Type specifies the socket type requested (only used internally).

Enumerator:
c_type_dgram
c_type_stream
c_type_raw

Reimplemented from SysSocketBase.

enum SysSocket::Type

Type specifies the socket type requested (only used internally).

Enumerator:
c_type_dgram
c_type_stream
c_type_raw

Reimplemented from SysSocketBase.

enum SysSocket::Type

Type specifies the socket type requested (only used internally).

Enumerator:
c_type_dgram
c_type_stream
c_type_raw

Reimplemented from SysSocketBase.

Constructor & Destructor Documentation

SysSocket::SysSocket ( SocketHdl socket = -1 )

SysSocket::SysSocket ( SocketHdl socket = -1 ) [inline]

SysSocket::SysSocket ( SocketHdl socket = GetInvalidHdl() )

SysSocket::SysSocket ( SocketHdl socket = -1 )

SysSocket::SysSocket ( SocketHdl socket = GetInvalidHdl() )

Member Function Documentation

BOOLEAN SysSocket::Accept | ( | SysSocket * | s,
 |  | InetSocketAddr * | peer
 | ) |

BOOLEAN SysSocket::Accept | ( | SysSocket * | s,
 |  | InetSocketAddr * | peer
 | ) |

BOOLEAN SysSocket::Accept | ( | SysSocket * | s,
 |  | InetSocketAddr * | peer
 | ) |

BOOLEAN SysSocket::Accept | ( | SysSocket * | s,
 |  | InetSocketAddr * | peer
 | ) | [inline]

BOOLEAN SysSocket::Accept | ( | SysSocket * | s,
 |  | InetSocketAddr * | peer
 | ) |

BOOLEAN SysSocket::Bind ( const InetSocketAddr & addr )

INT SysSocket::Bind ( const InetSocketAddr & addr )

BOOLEAN SysSocket::Bind ( const InetSocketAddr & addr )

INT SysSocket::Bind ( const InetSocketAddr & addr ) [inline]

BOOLEAN SysSocket::Bind ( const InetSocketAddr & addr )

BOOLEAN SysSocket::Close ( )

Reimplemented in SocketData.

INT SysSocket::Close ( )

Reimplemented in SocketData.

BOOLEAN SysSocket::Close ( )

Reimplemented in SocketData.

INT SysSocket::Close ( ) [inline]

Reimplemented in SocketData.

BOOLEAN SysSocket::Close ( )

Reimplemented in SocketData.

BOOLEAN SysSocket::Connect ( const InetSocketAddr & peer )

INT SysSocket::Connect ( const InetSocketAddr & peer )

BOOLEAN SysSocket::Connect ( const InetSocketAddr & peer )

INT SysSocket::Connect ( const InetSocketAddr & peer ) [inline]

BOOLEAN SysSocket::Connect ( const InetSocketAddr & peer )

SocketHdl SysSocket::GetHdl ( ) const [inline]

SocketHdl SysSocket::GetHdl ( ) const [inline]

SocketHdl SysSocket::GetHdl ( ) const [inline]

SocketHdl SysSocket::GetHdl ( ) const [inline]

SocketHdl SysSocket::GetHdl ( ) const [inline]

BOOLEAN SysSocket::GetInBufByteCount ( UINT & arg ) const

INT SysSocket::GetInBufByteCount ( UINT & arg ) [inline]

BOOLEAN SysSocket::GetInBufByteCount ( UINT & arg ) const

INT SysSocket::GetInBufByteCount ( UINT & arg ) [inline]

INT SysSocket::GetInBufByteCount ( UINT & arg ) [inline]

static SocketHdl SysSocket::GetInvalidHdl ( ) [static]

static SocketHdl SysSocket::GetInvalidHdl ( ) [inline, static]

static SocketHdl SysSocket::GetInvalidHdl ( ) [static]

static SocketHdl SysSocket::GetInvalidHdl ( ) [inline, static]

SysSocket::SocketHdl SysSocket::GetInvalidHdl ( ) [inline, static]

static UINT8 SysSocket::GetInvalidNsapi ( ) [static]

UINT8 SysSocket::GetInvalidNsapi ( ) [static]

BOOLEAN SysSocket::GetLingerOption ( LingerSetting & linger_setting ) const

BOOLEAN SysSocket::GetLingerOption ( LingerSetting & linger_setting ) const

BOOLEAN SysSocket::GetLocal ( InetSocketAddr & local ) const

INT SysSocket::GetLocal ( InetSocketAddr & local )

BOOLEAN SysSocket::GetLocal ( InetSocketAddr & local ) const

INT SysSocket::GetLocal ( InetSocketAddr & local ) [inline]

INT SysSocket::GetLocal ( InetSocketAddr & local )

BOOLEAN SysSocket::GetOption | ( | OptionType | type,
 |  | INT & | val
 | ) | const

INT SysSocket::GetOption | ( | OptionType | type,
 |  | INT & | val
 | ) |

BOOLEAN SysSocket::GetOption | ( | OptionType | type,
 |  | INT & | val
 | ) | const

INT SysSocket::GetOption | ( | OptionType | type,
 |  | INT & | val
 | ) | [inline]

INT SysSocket::GetOption | ( | OptionType | type,
 |  | INT & | val
 | ) |

BOOLEAN SysSocket::GetPeer ( InetSocketAddr & peer ) const

INT SysSocket::GetPeer ( InetSocketAddr & peer )

BOOLEAN SysSocket::GetPeer ( InetSocketAddr & peer ) const

INT SysSocket::GetPeer ( InetSocketAddr & peer ) [inline]

INT SysSocket::GetPeer ( InetSocketAddr & peer )

SocketError SysSocket::GetSysErr ( BOOLEAN check_errno ) const [protected]

SocketError SysSocket::GetSysErr ( BOOLEAN check_errno ) const [protected]

SocketError SysSocket::GetSysError ( BOOLEAN include_global_errors = TRUE ) const

SocketError SysSocket::GetSysError ( )

SocketError SysSocket::GetSysError ( BOOLEAN include_global_errors = TRUE ) const

SocketError SysSocket::GetSysError ( ) [inline]

SocketError SysSocket::GetSysError ( )

BOOLEAN SysSocket::Init | ( | INT | af,
 |  | INT | type,
 |  | INT | protocol
 | ) |

BOOLEAN SysSocket::Init | ( | INT | af,
 |  | INT | type,
 |  | INT | protocol
 | ) | [inline]

BOOLEAN SysSocket::Init | ( | INT | af,
 |  | INT | type,
 |  | INT | protocol
 | ) |

BOOLEAN SysSocket::IsBlocking ( ) const

Tells if the socket is in blocking or non-blocking mode. The socket has to be open when this method is called.

BOOLEAN SysSocket::IsBlocking ( ) const

Tells if the socket is in blocking or non-blocking mode. The socket has to be open when this method is called.

BOOLEAN SysSocket::IsValid ( ) const

BOOLEAN SysSocket::IsValid ( ) const [inline]

BOOLEAN SysSocket::IsValid ( ) const

BOOLEAN SysSocket::IsValid ( ) const [inline]

BOOLEAN SysSocket::IsValid ( ) const [inline]

BOOLEAN SysSocket::Listen ( INT backlog )

Reimplemented in SocketData.

INT SysSocket::Listen ( INT backlog ) [inline]

Reimplemented in SocketData.

BOOLEAN SysSocket::Listen ( INT backlog )

Reimplemented in SocketData.

INT SysSocket::Listen ( INT backlog ) [inline]

Reimplemented in SocketData.

BOOLEAN SysSocket::Listen ( INT backlog ) [inline]

Reimplemented in SocketData.

static void SysSocket::LwipPppSetConnInformation ( const void * info ) [static]

This is a necessary connection information callback used during lwIP PPP setup. This method has to public, otherwise the compiler reports an error that it is inaccessible.

BOOLEAN SysSocket::Open | ( | AddrFamily | af,
 |  | Type | type,
 |  | Protocol | protocol
 | ) |

BOOLEAN SysSocket::Open | ( | AddrFamily | af,
 |  | Type | type,
 |  | Protocol | protocol
 | ) |

static INT SysSocket::PsdLinkInit ( const UINT8 nsapi ) [inline, static]

static INT SysSocket::PsdLinkStop ( const UINT8 nsapi ) [inline, static]

static INT SysSocket::PsdLinkUp | ( | const UINT8 | nsapi,
 |  | BOOLEAN | ackmode,
 |  | UINT32 | ipaddr
 | ) | [inline, static]

INT SysSocket::Recv | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) |

INT SysSocket::Recv | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) | [inline]

INT SysSocket::Recv | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) |

INT SysSocket::Recv | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) | [inline]

INT SysSocket::Recv | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) | [inline]

INT SysSocket::RecvFrom | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | InetSocketAddr & | peer
 | ) |

INT SysSocket::RecvFrom | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | InetSocketAddr & | peer
 | ) |

INT SysSocket::RecvFrom | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | InetSocketAddr & | peer
 | ) |

INT SysSocket::RecvFrom | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | InetSocketAddr & | peer
 | ) | [inline]

INT SysSocket::RecvFrom | ( | void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | InetSocketAddr & | peer
 | ) |

INT SysSocket::Send | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) |

INT SysSocket::Send | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) | [inline]

INT SysSocket::Send | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) |

INT SysSocket::Send | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) | [inline]

INT SysSocket::Send | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags
 | ) | [inline]

INT SysSocket::SendTo | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | const InetSocketAddr & | peer
 | ) |

INT SysSocket::SendTo | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | const InetSocketAddr & | peer
 | ) |

INT SysSocket::SendTo | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | const InetSocketAddr & | peer
 | ) |

INT SysSocket::SendTo | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | const InetSocketAddr & | peer
 | ) | [inline]

INT SysSocket::SendTo | ( | const void * | buf,
 |  | INT | buflen,
 |  | INT | flags,
 |  | const InetSocketAddr & | peer
 | ) |

BOOLEAN SysSocket::SetBlocking ( BOOLEAN blocking = TRUE )

Sets the socket to either blocking or non-blocking. TRUE is returned if the desired mode could be set or was already set. The socket has to be open when this method is called.

BOOLEAN SysSocket::SetBlocking ( BOOLEAN blocking = TRUE )

Sets the socket to either blocking or non-blocking. TRUE is returned if the desired mode could be set or was already set. The socket has to be open when this method is called.

BOOLEAN SysSocket::SetLingerOption ( const LingerSetting & linger_setting )

BOOLEAN SysSocket::SetLingerOption ( const LingerSetting & linger_setting )

BOOLEAN SysSocket::SetNsapi ( UINT8 nsapi )

BOOLEAN SysSocket::SetNsapi ( UINT8 nsapi )

BOOLEAN SysSocket::SetOption | ( | OptionType | type,
 |  | INT | val
 | ) |

INT SysSocket::SetOption | ( | OptionType | type,
 |  | INT | val
 | ) |

BOOLEAN SysSocket::SetOption | ( | OptionType | type,
 |  | INT | val
 | ) |

INT SysSocket::SetOption | ( | OptionType | type,
 |  | INT | val
 | ) | [inline]

BOOLEAN SysSocket::SetOption | ( | OptionType | type,
 |  | INT | val
 | ) |

BOOLEAN SysSocket::Shutdown ( ShutdownMode how )

INT SysSocket::Shutdown ( INT how ) [inline]

BOOLEAN SysSocket::Shutdown ( ShutdownMode how )

INT SysSocket::Shutdown ( INT ) [inline]

INT SysSocket::Shutdown ( INT how ) [inline]

Friends And Related Function Documentation

DataConn [friend]

Reimplemented in SocketData.

DataConnManager [friend]

PppDataConn [friend]

PsdDataConn [friend]

SocketRxThread [friend]

The documentation for this class was generated from the following files:
  • Socket/Sys/GlBsd/BsdSysSocket.hpp
  • Socket/Sys/GlDummy/DummySysSocket.hpp
  • Socket/Sys/GlLwip/LwipSysSocket.hpp
  • Socket/Sys/GlUsnet/UsnetSysSocket.hpp
  • Socket/Sys/GlWin32/Win32SysSocket.hpp
  • Socket/Sys/GlBsd/BsdSysSocket.cpp
  • Socket/Sys/GlLwip/LwipSysSocket.cpp
  • Socket/Sys/GlUsnet/UsnetSysSocket.cpp
  • Socket/Sys/GlWin32/Win32SysSocket.cpp
Generated on Wed Jan 25 02:08:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SysSocket::FdSet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SysSocket::FdSet

SysSocket::FdSet Class Reference

#include <Apoxi/Socket/Sys/GlBsd/BsdSysSocket.hpp>

The documentation for this class was generated from the following file:
  • Socket/Sys/GlBsd/BsdSysSocket.hpp
Generated on Wed Jan 25 02:08:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SysSocketBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SysSocketBase Class Reference
[Socket]

Base SysSocket. More...

#include <Apoxi/Socket/Sys/SysSocketBase.hpp>

Inheritance diagram for SysSocketBase:

[legend]
Collaboration diagram for SysSocketBase:

[legend]

Public Types

enum | AddrFamily { c_addr_family_inet, c_addr_family_unspec }
enum OptionType {
c_option_error, c_option_debug, c_option_reuse_addr, c_option_keep_alive,
c_option_linger, c_option_dont_route, c_option_broadcast, c_option_snd_buf,
c_option_rcv_buf, c_option_type, c_option_tcp_no_delay, c_option_tcp_max_seg
}
enum | ShutdownMode { c_shutdown_stop_rx, c_shutdown_stop_tx, c_shutdown_stop_rx_tx }
enum | Type { c_type_dgram, c_type_stream, c_type_raw }

Static Protected Attributes

static PppCallback | m_ppp_callback = 0
static PppCallBackData * | m_ppp_callback_data = 0
static PppSetupCallBackData | m_ppp_callback_data_setup
static PppDataConn * | m_ppp_callback_dc = 0

Data Structures

struct | LingerSetting

Detailed Description

Base SysSocket.

Member Enumeration Documentation

enum SysSocketBase::AddrFamily

AddrFamily specifies the address family of the socket (only used internally).

Enumerator:
c_addr_family_inet
c_addr_family_unspec

Reimplemented in SysSocket, SysSocket, and SysSocket.

enum SysSocketBase::OptionType

OptionType specifies the socket option to set or retrieve (only used internally).

Enumerator:
c_option_error
c_option_debug
c_option_reuse_addr
c_option_keep_alive
c_option_linger
c_option_dont_route
c_option_broadcast
c_option_snd_buf
c_option_rcv_buf
c_option_type
c_option_tcp_no_delay
c_option_tcp_max_seg

enum SysSocketBase::ShutdownMode

ShutdownMode specifies how a socket should be shutdown (only used internally).

Enumerator:
c_shutdown_stop_rx
c_shutdown_stop_tx
c_shutdown_stop_rx_tx

enum SysSocketBase::Type

Type specifies the socket type requested (only used internally).

Enumerator:
c_type_dgram
c_type_stream
c_type_raw

Reimplemented in SysSocket, SysSocket, and SysSocket.

Field Documentation

PppCallback SysSocketBase::m_ppp_callback = 0 [static, protected]

PppCallBackData * SysSocketBase::m_ppp_callback_data = 0 [static, protected]

PppSetupCallBackData SysSocketBase::m_ppp_callback_data_setup [static, protected]

PppDataConn * SysSocketBase::m_ppp_callback_dc = 0 [static, protected]

The documentation for this class was generated from the following files:
  • Socket/Sys/SysSocketBase.hpp
  • Socket/Sys/SysSocketBase.cpp
Generated on Wed Jan 25 02:08:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SysSocketBase::LingerSetting Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
SysSocketBase::LingerSetting

SysSocketBase::LingerSetting Struct Reference

#include <Apoxi/Socket/Sys/SysSocketBase.hpp>

Data Fields

BOOLEAN | m_on_off
INT32 | m_timeout

Detailed Description

The LingerSetting structure maintains information about a specific socket that specifies how that socket should behave when data is queued to be sent and the socket is closed.

Field Documentation

BOOLEAN SysSocketBase::LingerSetting::m_on_off

Specifies whether a socket should remain open for a specified amount of time after the socket is closed to enable queued data to be sent.

INT32 SysSocketBase::LingerSetting::m_timeout

Desired time-out (in seconds).

The documentation for this struct was generated from the following file:
  • Socket/Sys/SysSocketBase.hpp
Generated on Wed Jan 25 02:08:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: System Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

System Class Reference
[Kernel]

#include <Apoxi/Kernel/System.hpp>

Collaboration diagram for System:

[legend]

Static Public Member Functions

static void | AddAppContainer (AppContainer *app_cont)
static AppContainer * | GetActiveAppContainer ()
static Application * | GetActiveApplication ()
static ColorValue | GetColorValue (SystemColorId system_color_id)
static INT | GetCurrentFocusPriority ()
Obsolete - use Application::GetFocusPriority instead.
static Display * | GetDisplay (INT display_idx=0)
Obsolete - use DeviceManager::GetDisplay instead.
static AppContainer * | GetFirstAppContainer ()
static AppContainer * | GetFocusedAppContainer ()
static Application * | GetFocusedApplication ()
static const Font & | GetFont (SystemFontId system_font_id)
static INT | GetLanguage ()
Obsolete - Use LanguageManager::GetActiveLanguage instead.
static const MessageRouter & | GetMessageRouter ()
static ClientDc * | GetSharedDc (INT display_idx=0)
Obsolete - use DeviceManager::GetSharedDc instead.
static Semaphore * | GetSystemSemaphore ()
static const Theme & | GetTheme ()
Obsolete - Use ThemeManager::GetActiveTheme instead.
static INT | GetThemeId ()
Obsolete - Use ThemeManager::GetActiveThemeIndex instead.
static void | GrabFocus (Application *app, INT priority, BOOLEAN assign_to_win)
Obsolete - use System::GrabFocus(Application* app) instead.
static BOOLEAN | GrabFocus (Application *app)
static void | Init (ExternalCommunicationHandler *external_communicator=0)
static void | InitLanguage (INT lang_id)
Obsolete - invoking this method is not needed anymore.
static BOOLEAN | IsInitialized ()
static BOOLEAN | LanguageChanged ()
Obsolete - use LanguageManager::HasActiveLanguageChanged instead.
static void | RemoveAppContainer (AppContainer *app_cont)
static void | SetLanguage (INT lang_id)
Obsolete - use LanguageManager::SetActiveLanguage instead.
static void | SetTheme (ThemeId theme_id)
static BOOLEAN | ShutDown (BOOLEAN force=FALSE, ShutDown::Mode mode=ShutDown::PowerOff)

Friends

class | FocusObtainer
class | MessageRouter
class | Os
class | ServiceThread
class | ShutDown
class | StartUp

Detailed Description

Pure static class to encapsulate some generic system calls.

Member Function Documentation

void System::AddAppContainer ( AppContainer * app_cont ) [static]

AppContainer * System::GetActiveAppContainer ( ) [static]

Returns:
Pointer to the currently active application container.

Application * System::GetActiveApplication ( ) [static]

When calling this method while running in the context of an application, the return value always is the pointer to the application. However, calling this method in a non application context returns 0. This is for example in the callback function of a SystemTimer. Note that this method does not return the currently focused application; to get the focused application System::GetFocusedApplication must be invoked.

Returns:
Pointer to the currently active application or 0.

ColorValue System::GetColorValue ( SystemColorId system_color_id ) [static]

Returns:
The color value for the system color specified by system color.

INT System::GetCurrentFocusPriority ( ) [static]

Obsolete - use Application::GetFocusPriority instead.

Display * System::GetDisplay ( INT display_idx = 0 ) [static]

Obsolete - use DeviceManager::GetDisplay instead.

AppContainer * System::GetFirstAppContainer ( ) [static]

Returns:
Pointer to the first application container in the list of all APOXI threads.

AppContainer * System::GetFocusedAppContainer ( ) [static]

Returns:
Pointer to the application container with the focused application.

Application * System::GetFocusedApplication ( ) [static]

Returns:
Pointer to the focused application of all application containers. The focused application is the application which will receive all key presses. The focused application can be but is not necessarily the active application (see System::GetActiveApplication).

const Font & System::GetFont ( SystemFontId system_font_id ) [static]

Returns:
The font identifier for the system font specified by system_font_id

INT System::GetLanguage ( ) [static]

Obsolete - Use LanguageManager::GetActiveLanguage instead.

static const MessageRouter& System::GetMessageRouter ( ) [inline, static]

Returns:
The global MessageRouter

ClientDc * System::GetSharedDc ( INT display_idx = 0 ) [static]

Obsolete - use DeviceManager::GetSharedDc instead.

static Semaphore* System::GetSystemSemaphore ( ) [inline, static]

Returns:
Pointer to the global system semaphore (should be used for initializations, creations of semaphores, ...)

const Theme & System::GetTheme ( ) [static]

Obsolete - Use ThemeManager::GetActiveTheme instead.

INT System::GetThemeId ( ) [static]

Obsolete - Use ThemeManager::GetActiveThemeIndex instead.

void System::GrabFocus | ( | Application * | app,
 |  | INT | priority,
 |  | BOOLEAN | assign_to_win
 | ) | [static]

Obsolete - use System::GrabFocus(Application* app) instead.

BOOLEAN System::GrabFocus ( Application * app ) [static]

Tries to grab the focus for the application app.

Returns:
TRUE is returned, if the application will get the focus. Note that the grabbing of the focus is done asynchronously, which means that invoking Application::HasFocus immediatly after invoking System::GrabFocus will return FALSE.

void System::Init ( ExternalCommunicationHandler * external_communicator = 0 ) [static]

Initializes the System

static void System::InitLanguage ( INT lang_id ) [inline, static]

Obsolete - invoking this method is not needed anymore.

static BOOLEAN System::IsInitialized ( ) [inline, static]

Returns:
TRUE if the System (including all subsystems) is,fully initialized.

static BOOLEAN System::LanguageChanged ( ) [inline, static]

Obsolete - use LanguageManager::HasActiveLanguageChanged instead.

void System::RemoveAppContainer ( AppContainer * app_cont ) [static]

static void System::SetLanguage ( INT lang_id ) [inline, static]

Obsolete - use LanguageManager::SetActiveLanguage instead.

void System::SetTheme ( ThemeId theme_id ) [static]

Sets the theme.

BOOLEAN System::ShutDown | ( | BOOLEAN | force = FALSE,
 |  | ShutDown::Mode | mode = ShutDown::PowerOff
 | ) | [static]

Starts the shut-down sequence. First the applications are checked if shutting down is allowed. If so, ShutDown::Execute is called which posts the AppCloseMsg to all applications and waits until all APOXI threads are terminated.

Parameters:
force | FALSE: shutdown only when all applications allow it TRUE: immediately shutdown.
mode | shut-down mode. See ShutDown::Mode.
Returns:
TRUE, if shutdown is allowed an has been started.
See also:
Application::SetShutdownAllowed

Friends And Related Function Documentation

friend class FocusObtainer [friend]

friend class MessageRouter [friend]

friend class Os [friend]

friend class ServiceThread [friend]

friend class ShutDown [friend]

friend class StartUp [friend]

The documentation for this class was generated from the following files:
  • Kernel/System.hpp
  • Kernel/System.cpp
Generated on Wed Jan 25 02:08:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SystemTimer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

SystemTimer Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/Nuc32/SystemTimer.hpp>

Inheritance diagram for SystemTimer:

[legend]
Collaboration diagram for SystemTimer:

[legend]

Public Types

typedef void(* | CallBackFn )(void *)
typedef void(* | CallBackFn )(void *)

Public Member Functions

UINT32 | GetTimeout () const
UINT32 | GetTimeout () const
void | Init (UINT32 timeout, CallBackFn OnTimer, void *arg=0, BOOLEAN autotimer=FALSE)
void | Init (UINT32 timeout, CallBackFn OnTimer, void *arg=0, BOOLEAN autotimer=FALSE)
BOOLEAN | IsActive () const
BOOLEAN | IsActive () const
void | Restart ()
void | Restart ()
If the timer is already running it will be stopped and restarted from the beginning.
void | SetTimeout (UINT32 timeout)
void | SetTimeout (UINT32 timeout)
void | Start ()
void | Start ()
Starts the timer.
UINT32 | Stop ()
UINT32 | Stop ()
SystemTimer (UINT32 timeout, CallBackFn OnTimer, void *arg=0, BOOLEAN autotimer=FALSE)
SystemTimer ()
SystemTimer (UINT32 timeout, CallBackFn OnTimer, void *arg=0, BOOLEAN autotimer=FALSE)
SystemTimer ()
~SystemTimer ()
~SystemTimer ()

Friends

class | SystemTimerInternals

Data Structures

struct | _call_back
struct | CallBack

Detailed Description

To support timers also outside Application context, SystemTimer defines a generic interface for general purpose application timers.

Member Typedef Documentation

typedef void(* SystemTimer::CallBackFn)(void *)

typedef void(* SystemTimer::CallBackFn)(void *)

Constructor & Destructor Documentation

SystemTimer::SystemTimer ( )

SystemTimer::SystemTimer | ( | UINT32 | timeout,
 |  | CallBackFn | OnTimer,
 |  | void * | arg = 0,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

SystemTimer::~SystemTimer ( )

SystemTimer::SystemTimer ( )

SystemTimer::SystemTimer | ( | UINT32 | timeout,
 |  | CallBackFn | OnTimer,
 |  | void * | arg = 0,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

Parameters:
timeout | Timeout value in milliseconds.
OnTimer | Callback function which is called when the timer expires.
arg | User-supplied callback data.
autotimer | Set this parameter to TRUE if the timer should automatically restart every time it expires.

SystemTimer::~SystemTimer ( )

Member Function Documentation

UINT32 SystemTimer::GetTimeout ( ) const [inline]

UINT32 SystemTimer::GetTimeout ( ) const [inline]

void SystemTimer::Init | ( | UINT32 | timeout,
 |  | CallBackFn | OnTimer,
 |  | void * | arg = 0,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

Parameters:
timeout | Timeout value in milliseconds.
OnTimer | Callback function which is called when the timer expires.
arg | User-supplied callback data.
autotimer | Set this parameter to TRUE if the timer should automatically restart every time it expires.

void SystemTimer::Init | ( | UINT32 | timeout,
 |  | CallBackFn | OnTimer,
 |  | void * | arg = 0,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

BOOLEAN SystemTimer::IsActive ( ) const [inline]

Returns:
The status (running or not) of the timer.

BOOLEAN SystemTimer::IsActive ( ) const [inline]

Returns:
The status (running or not) of the timer.

void SystemTimer::Restart ( )

If the timer is already running it will be stopped and restarted from the beginning.

void SystemTimer::Restart ( )

If the timer is already running it will be stopped and restarted from the beginning.

void SystemTimer::SetTimeout ( UINT32 timeout ) [inline]

Parameters:
timeout Timeout value in milliseconds.

void SystemTimer::SetTimeout ( UINT32 timeout ) [inline]

void SystemTimer::Start ( )

Starts the timer.

void SystemTimer::Start ( )

Starts the timer.

UINT32 SystemTimer::Stop ( )

Stops the timer

Returns:
The remaining time to the expiration of the timer (in milliseconds)

UINT32 SystemTimer::Stop ( )

Stops the timer

Returns:
The remaining time to the expiration of the timer (in milliseconds).

Friends And Related Function Documentation

friend class SystemTimerInternals [friend]

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/SystemTimer.hpp
  • Kernel/Os/Win32/SystemTimer.hpp
  • Kernel/Os/Nuc32/SystemTimer.cpp
  • Kernel/Os/Win32/SystemTimer.cpp
Generated on Wed Jan 25 02:08:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9AddWordMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9AddWordMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for T9AddWordMsg:

[legend]
Collaboration diagram for T9AddWordMsg:

[legend]

Public Types

enum | { ID = 30102 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetNewWord () const
void | SetNewWord (const WString &new_word)
T9AddWordMsg (const WString &new_word)
virtual | ~T9AddWordMsg ()

Detailed Description

This message is sent when the user confirms that he wants to add a new word to T9''s dictionary. Arguments: the word that was not found

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

T9AddWordMsg::T9AddWordMsg ( const WString & new_word )

T9AddWordMsg::~T9AddWordMsg ( ) [virtual]

Member Function Documentation

Message * T9AddWordMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & T9AddWordMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& T9AddWordMsg::GetNewWord ( ) const [inline]

void T9AddWordMsg::SetNewWord ( const WString & new_word ) [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:08:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9EnteredUnknownWordMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9EnteredUnknownWordMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for T9EnteredUnknownWordMsg:

[legend]
Collaboration diagram for T9EnteredUnknownWordMsg:

[legend]

Public Types

enum | { ID = 30103 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetWord () const
void | SetWord (const WString &word)
T9EnteredUnknownWordMsg (const WString &word)
virtual | ~T9EnteredUnknownWordMsg ()

Detailed Description

This message is sent when the user has confirmed that he wants to enter a new word into the T9 UDB. The message can be retrieved by components implementing word entry so they can set a default text. Arguments: the word that was not found

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

T9EnteredUnknownWordMsg::T9EnteredUnknownWordMsg ( const WString & word )

T9EnteredUnknownWordMsg::~T9EnteredUnknownWordMsg ( ) [virtual]

Member Function Documentation

Message * T9EnteredUnknownWordMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & T9EnteredUnknownWordMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& T9EnteredUnknownWordMsg::GetWord ( ) const [inline]

void T9EnteredUnknownWordMsg::SetWord ( const WString & word ) [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:08:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9InputConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9InputConfig Class Reference
[Config]

#include <T9InputConfig.hpp>

Public Types

enum T9FunctionCode {
MenuFunction, NextFunction, PreviousFunction, ShiftFunction,
SpaceFunction, SymbolEntryRequestFunction, ToggleNumericModeFunction
}
T9 functions that should be bound to a key. More...

Static Public Member Functions

static const BitmapRes * | GetBitmap (AbstractPredictiveInputBox::PredBitmapId pred_bitmap_id)
Returns the bitmap used for the given predictive bitmap ID.
static const Font & | GetFont (AbstractPredictiveInputBox::PredFontId pred_font_id)
Returns the used for the given predictive input ID.
static KeyCode | GetKeyForFunction (T9FunctionCode function_code)
static WCHAR | GetObjectReplacementCharacter ()
static WCHAR | GetStroke (INT stroke)
static WCHAR | GetSymbol (UINT8 row, UINT8 page)
static UINT8 | GetSymbolPages ()
Returns the number of symbol pages.
static UINT8 | GetSymbolRows ()
Returns the number of symbol rows.
static INT | GetT9BufferSize ()
static INT | GetT9UdbSize ()
static CHAR * | LoadT9Udb (UINT16 &data_size)
static void | SaveT9Udb ()

Static Public Attributes

static const UINT8 | c_t9_symbol_pages
static const UINT8 | c_t9_symbol_rows

Detailed Description

Allows accessing the configuration for T9. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Enumeration Documentation

enum T9InputConfig::T9FunctionCode

T9 functions that should be bound to a key.

Enumerator:
MenuFunction
NextFunction
PreviousFunction
ShiftFunction
SpaceFunction
SymbolEntryRequestFunction
ToggleNumericModeFunction

Member Function Documentation

static const BitmapRes* T9InputConfig::GetBitmap ( AbstractPredictiveInputBox::PredBitmapId pred_bitmap_id ) [static]

Returns the bitmap used for the given predictive bitmap ID.

static const Font& T9InputConfig::GetFont ( AbstractPredictiveInputBox::PredFontId pred_font_id ) [static]

Returns the used for the given predictive input ID.

static KeyCode T9InputConfig::GetKeyForFunction ( T9FunctionCode function_code ) [static]

Parameters:
function_code the T9 function whose key code is looked for
Returns:
the APOXI keycode for the desired T9 function

static WCHAR T9InputConfig::GetObjectReplacementCharacter ( ) [inline, static]

Returns:
0x0FFFC - this is the Unicode Object Replacement Character

static WCHAR T9InputConfig::GetStroke ( INT stroke ) [static]

static WCHAR T9InputConfig::GetSymbol | ( | UINT8 | row,
 |  | UINT8 | page
 | ) | [static]

static UINT8 T9InputConfig::GetSymbolPages ( ) [static]

Returns the number of symbol pages.

static UINT8 T9InputConfig::GetSymbolRows ( ) [static]

Returns the number of symbol rows.

static INT T9InputConfig::GetT9BufferSize ( ) [static]

static INT T9InputConfig::GetT9UdbSize ( ) [static]

static CHAR* T9InputConfig::LoadT9Udb ( UINT16 & data_size ) [static]

Returns a pointer to a CHAR array containing the user database. If the database does not exist then it is created, with the size specified in GetT9UdbSize(). The size is written to the parameter data_size.

static void T9InputConfig::SaveT9Udb ( ) [static]

Field Documentation

const UINT8 T9InputConfig::c_t9_symbol_pages [static]

const UINT8 T9InputConfig::c_t9_symbol_rows [static]

The documentation for this class was generated from the following file:
  • T9InputConfig.hpp
Generated on Wed Jan 25 02:08:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9InputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9InputMapper Class Reference
[T9]

#include <Apoxi/AddOns/T9/T9InputMapper.hpp>

Inheritance diagram for T9InputMapper:

[legend]
Collaboration diagram for T9InputMapper:

[legend]

Public Types

typedef T9Wrapper::enumConstants | enumConstants
typedef T9Wrapper::t9_language | t9_language

Public Member Functions

virtual BOOLEAN | AddExplicitCharacter (const WCHAR chr)
BOOLEAN | AddExplicitWord (const WString &word)
Adds a word to the T9 buffer and synchronizes the editor with the (new) T9 content.
BOOLEAN | AddNewWordToUdb (const WString &new_word)
BOOLEAN | DeleteActiveWord ()
Deletes the active word from the T9 buffer and synchronizes the editor with the (new) T9 content.
virtual INT | GetId () const
virtual PredMode | GetMode () const
Discover the current input method.
virtual const WCHAR * | GetPhonetics (INT *selected_idx=0) const
virtual INT | GetSelectedIndex () const
virtual const WCHAR * | GetSelection () const
virtual const WCHAR * | GetStatusInfo () const
A human-readable name for the current input method.
virtual const WCHAR * | GetStrokes () const
virtual Type | GetType () const
virtual BOOLEAN | Notify (NotificationType type, INT index=0, const AtomItem *item=0)
virtual void | SetEditor (AbstractEditor *editor)
BOOLEAN | SetMode_T9_Latin (t9_language lang)
T9InputMapper (AbstractEditor *editor=0)
virtual | ~T9InputMapper ()

Protected Member Functions

KeyCode | GetSpaceKeyCode () const
virtual const T9Wrapper * | GetT9Wrapper () const =0
virtual T9Wrapper * | GetT9Wrapper ()=0
Override this to make the InputMapper use a different T9Wrapper.
BOOLEAN | IsTextEditorDocument () const
virtual BOOLEAN | OnKeyUp (KeyCode apoxi_key_code, UINT32 duration)
This is an override.
virtual BOOLEAN | OnLongKeyPress (KeyCode apoxi_key_code)
This is an override.
virtual BOOLEAN | OnLongKeyPress_T9 (KeyCode apoxi_key_code)
virtual BOOLEAN | OnShortKeyUp_T9 (KeyCode apoxi_key_code)
void | SynchronizeBuffers_ApoxiToT9 ()
Copy the document of the editor into the T9 buffer.
void | SynchronizeBuffers_T9ToApoxi ()
Copy the T9 buffer into the document of the editor.
void | UpdateMultiMediaEditorDocument ()
void | UpdateTextEditorDocument ()

Static Protected Member Functions

static KeyCode | GetApoxiKeyCode_Hash ()
Returns the has key-code, which is interpreted as space by T9.
static KeyCode | GetApoxiKeyCode_Menu ()
Returns the key-code, which is interpreted as menu by T9.
static KeyCode | GetApoxiKeyCode_Star ()
Returns the star key-code, which is interpreted as space by T9.

Member Typedef Documentation

typedef T9Wrapper::enumConstants T9InputMapper::enumConstants

typedef T9Wrapper::t9_language T9InputMapper::t9_language

Constructor & Destructor Documentation

T9InputMapper::T9InputMapper ( AbstractEditor * editor = 0 )

T9InputMapper::~T9InputMapper ( ) [virtual]

Member Function Documentation

BOOLEAN T9InputMapper::AddExplicitCharacter ( const WCHAR chr ) [virtual]

BOOLEAN T9InputMapper::AddExplicitWord ( const WString & word )

Adds a word to the T9 buffer and synchronizes the editor with the (new) T9 content.

BOOLEAN T9InputMapper::AddNewWordToUdb ( const WString & new_word )

BOOLEAN T9InputMapper::DeleteActiveWord ( )

Deletes the active word from the T9 buffer and synchronizes the editor with the (new) T9 content.

KeyCode T9InputMapper::GetApoxiKeyCode_Hash ( ) [static, protected]

Returns the has key-code, which is interpreted as space by T9.

KeyCode T9InputMapper::GetApoxiKeyCode_Menu ( ) [static, protected]

Returns the key-code, which is interpreted as menu by T9.

KeyCode T9InputMapper::GetApoxiKeyCode_Star ( ) [static, protected]

Returns the star key-code, which is interpreted as space by T9.

INT T9InputMapper::GetId ( ) const [virtual]

See also:
InputMapper::GetId()

Implements InputMapper.

PredInputMapper::PredMode T9InputMapper::GetMode ( ) const [virtual]

Discover the current input method.

Implements PredInputMapper.

Reimplemented in ChineseT9InputMapper, and EnglishT9InputMapper.

const WCHAR * T9InputMapper::GetPhonetics ( INT * selected_idx = 0 ) const [virtual]

Implements PredInputMapper.

Reimplemented in ChineseT9InputMapper.

INT T9InputMapper::GetSelectedIndex ( ) const [virtual]

Implements PredInputMapper.

Reimplemented in ChineseT9InputMapper.

const WCHAR * T9InputMapper::GetSelection ( ) const [virtual]

Implements PredInputMapper.

Reimplemented in ChineseT9InputMapper.

KeyCode T9InputMapper::GetSpaceKeyCode ( ) const [protected]

const WCHAR * T9InputMapper::GetStatusInfo ( ) const [virtual]

A human-readable name for the current input method.

Implements PredInputMapper.

Reimplemented in ChineseT9InputMapper, and EnglishT9InputMapper.

const WCHAR * T9InputMapper::GetStrokes ( ) const [virtual]

Implements PredInputMapper.

Reimplemented in ChineseT9InputMapper.

virtual const T9Wrapper* T9InputMapper::GetT9Wrapper ( ) const [protected, pure virtual]

Override this to make the InputMapper use a different T9Wrapper. This expects you to new a specific derived T9Wrapper instance, but of course we should not use new with APOXI, so we actually just return a pointer to a member variable. The disadvantage there is that that member variable is then ignored in derived T9InputMapperClasses. Such things happen when you can't use new.

Implemented in ChineseT9InputMapper, and EnglishT9InputMapper.

virtual T9Wrapper* T9InputMapper::GetT9Wrapper ( ) [protected, pure virtual]

Override this to make the InputMapper use a different T9Wrapper.

Implemented in ChineseT9InputMapper, and EnglishT9InputMapper.

PredInputMapper::Type T9InputMapper::GetType ( ) const [virtual]

Implements PredInputMapper.

BOOLEAN T9InputMapper::IsTextEditorDocument ( ) const [protected]

BOOLEAN T9InputMapper::Notify | ( | NotificationType | type,
 |  | INT | index = 0,
 |  | const AtomItem * | item = 0
 | ) | [virtual]

Is invoked by the editor, if an item has been inserted or the content of the editor has been changed. Overwriting this method allows the input mapper to synchronize its buffer with the editor-content.

Reimplemented from InputMapper.

BOOLEAN T9InputMapper::OnKeyUp | ( | KeyCode | apoxi_key_code,
 |  | UINT32 | duration
 | ) | [protected, virtual]

This is an override.

Reimplemented from InputMapper.

BOOLEAN T9InputMapper::OnLongKeyPress ( KeyCode apoxi_key_code ) [protected, virtual]

This is an override.

Reimplemented from InputMapper.

BOOLEAN T9InputMapper::OnLongKeyPress_T9 ( KeyCode apoxi_key_code ) [protected, virtual]

Reimplemented in ChineseT9InputMapper, and EnglishT9InputMapper.

BOOLEAN T9InputMapper::OnShortKeyUp_T9 ( KeyCode apoxi_key_code ) [protected, virtual]

Reimplemented in ChineseT9InputMapper, and EnglishT9InputMapper.

void T9InputMapper::SetEditor ( AbstractEditor * editor ) [virtual]

Parameters:
editor Pointer to the editor the input mapper should belong too. */

Reimplemented from InputMapper.

BOOLEAN T9InputMapper::SetMode_T9_Latin ( t9_language lang )

Sets the language, such as English, German, Greek. But you need the ChineseT9InputMapper instead if you want to use the various Chinese input methods.

Parameters:
For instance, PLDBID_Spanish. The default is PLDBID_English.
Returns:
Whether the method was successful.

void T9InputMapper::SynchronizeBuffers_ApoxiToT9 ( ) [protected]

Copy the document of the editor into the T9 buffer.

void T9InputMapper::SynchronizeBuffers_T9ToApoxi ( ) [protected]

Copy the T9 buffer into the document of the editor.

void T9InputMapper::UpdateMultiMediaEditorDocument ( ) [protected]

void T9InputMapper::UpdateTextEditorDocument ( ) [protected]

The documentation for this class was generated from the following files:
  • AddOns/T9/T9InputMapper.hpp
  • AddOns/T9/T9InputMapper.cpp
Generated on Wed Jan 25 02:08:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9MatrixModeKeypressed Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9MatrixModeKeypressed Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for T9MatrixModeKeypressed:

[legend]
Collaboration diagram for T9MatrixModeKeypressed:

[legend]

Public Types

enum | { ID = 30120 }

Public Member Functions

virtual Message * | Clone () const
const KeyCode & | GetKeyCode () const
virtual const MsgMetaData & | GetMetaData () const
void | SetKeyCode (const KeyCode &key_code)
T9MatrixModeKeypressed (const KeyCode &key_code)
virtual | ~T9MatrixModeKeypressed ()

Detailed Description

This message is sent after every keypress when T9 input is switched to Thai Matrix Mode. After every keypress, a window with all possible characters for this key has to open.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

T9MatrixModeKeypressed::T9MatrixModeKeypressed ( const KeyCode & key_code )

T9MatrixModeKeypressed::~T9MatrixModeKeypressed ( ) [virtual]

Member Function Documentation

Message * T9MatrixModeKeypressed::Clone ( ) const [virtual]

Implements Message.

const KeyCode& T9MatrixModeKeypressed::GetKeyCode ( ) const [inline]

const MsgMetaData & T9MatrixModeKeypressed::GetMetaData ( ) const [virtual]

Implements Message.

void T9MatrixModeKeypressed::SetKeyCode ( const KeyCode & key_code ) [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:08:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9NoWordFoundMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9NoWordFoundMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for T9NoWordFoundMsg:

[legend]
Collaboration diagram for T9NoWordFoundMsg:

[legend]

Public Types

enum | { ID = 30101 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetActiveWord () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveWord (const WString &active_word)
T9NoWordFoundMsg (const WString &active_word)
virtual | ~T9NoWordFoundMsg ()

Detailed Description

This message is sent when the user tries to enter a word T9 cannot find. Arguments: the word that was not found

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

T9NoWordFoundMsg::T9NoWordFoundMsg ( const WString & active_word )

T9NoWordFoundMsg::~T9NoWordFoundMsg ( ) [virtual]

Member Function Documentation

Message * T9NoWordFoundMsg::Clone ( ) const [virtual]

Implements Message.

const WString& T9NoWordFoundMsg::GetActiveWord ( ) const [inline]

const MsgMetaData & T9NoWordFoundMsg::GetMetaData ( ) const [virtual]

Implements Message.

void T9NoWordFoundMsg::SetActiveWord ( const WString & active_word ) [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:08:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9Pack Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9Pack Class Reference

#include <Apoxi/AddOns/T9/T9Pack.hpp>

Inheritance diagram for T9Pack:

[legend]
Collaboration diagram for T9Pack:

[legend]

Public Member Functions

const UINT8 * | GetData (UINT16 index) const
INT32 | GetIndex (UINT16 ldb_id)
UINT16 | GetLdbId (UINT32 index)
UINT32 | GetLdbSize (UINT16 index) const
UINT32 | GetSize (UINT16 index) const
T9Pack (UINT8 *data)
virtual | ~T9Pack ()

Detailed Description

An object of T9Pack encapsulates the data of the T9 pack that is available in the customization pack and provides functionality for the T9PackConnector to access this data.

Constructor & Destructor Documentation

T9Pack::T9Pack ( UINT8 * data )

Constructor for T9Pack. Initializes the T9Pack with the data handed over as parameter.

Parameters:
data Pointer to the starting address of the data for the T9Pack.

T9Pack::~T9Pack ( ) [virtual]

Destructor for T9Pack.

Member Function Documentation

const UINT8 * T9Pack::GetData ( UINT16 index ) const

Returns a pointer to the starting address of the data of the LDB at position index.

Parameters:
index Index of the LDB.
Returns:
pointer to the data of the LDB.

INT32 T9Pack::GetIndex ( UINT16 ldb_id )

Returns the index of the ldb identified by the given id.

Parameters:
ldb_id LDB-ID to search for
Returns:
index of the ldb with the given id.

UINT16 T9Pack::GetLdbId ( UINT32 index )

Returns the LDB-ID for the Ldb at position index.

Parameters:
index Index of the ldb.
Returns:
ID of the ldb at position index.

UINT32 T9Pack::GetLdbSize ( UINT16 index ) const

Returns the size of the LDB at position index.

Parameters:
index Index of the LDB.
Returns:
Size of the LDB at position index.

UINT32 T9Pack::GetSize ( UINT16 index ) const

Returns the size of the LDB + metadata at position index.

Parameters:
index Index of the LDB.
Returns:
Size of the LDB + metadata at position index.

The documentation for this class was generated from the following files:
  • AddOns/T9/T9Pack.hpp
  • AddOns/T9/T9Pack.cpp
Generated on Wed Jan 25 02:08:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9PackConnector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9PackConnector Class Reference

#include <Apoxi/AddOns/T9/T9PackConnector.hpp>

Collaboration diagram for T9PackConnector:

[legend]

Static Public Member Functions

static BOOLEAN | GetLdbIds (INT *ldb_ids, UINT16 size)
static INT16 | GetNumberOfLdbs ()
static UINT32 | GetSizeOfLdb (UINT16 id=m_ldb_id)
static void | Init ()
static BOOLEAN | IsT9PackAvailable ()
static INT | ReadLdbData (UINT32 offset, UINT8 *dst, INT size)
static BOOLEAN | SetActiveLdb (UINT16 id)

Detailed Description

The T9PackConnector provides functionality for accessing the data of a T9 pack.

Member Function Documentation

BOOLEAN T9PackConnector::GetLdbIds | ( | INT * | ldb_ids,
 |  | UINT16 | size
 | ) | [static]

Copies the Ids of the LDBs available in the T9Pack to the array given in parameter ldb_ids. If count is smaller than .... TODO.

Parameters:
ldb_ids | Array where to copy the ids.
size | Size of array

INT16 T9PackConnector::GetNumberOfLdbs ( ) [static]

Returns the number of LDB available in the T9Pack.

UINT32 T9PackConnector::GetSizeOfLdb ( UINT16 id = m_ldb_id ) [static]

Returns the size of the LDB with the given id.

Parameters:
id Id of the LDB. Default value is the id of the active LDB.
Returns:
Size of the LDB identified by the parameter id.

void T9PackConnector::Init ( ) [static]

Initializes the T9PackConnector with the font pack available in the customization pack.

BOOLEAN T9PackConnector::IsT9PackAvailable ( ) [static]

Returns TRUE if a T9Pack is available in the customization pack.

INT T9PackConnector::ReadLdbData | ( | UINT32 | offset,
 |  | UINT8 * | dst,
 |  | INT | size
 | ) | [static]

Reads size UINT8s beginning at offset and copies the data into dst.

Parameters:
offset | Offset where to start reading.
dst | UINT8 Array for copying the data.
size | Number of UINT8s to read.
Returns:
Returns the number of actually read data.

BOOLEAN T9PackConnector::SetActiveLdb ( UINT16 id ) [static]

Sets the LDB identified by the parameter id active.

Parameters:
id Id of the LDB.
Returns:
TRUE if the LDB with the given id was found and set active.

The documentation for this class was generated from the following files:
  • AddOns/T9/T9PackConnector.hpp
  • AddOns/T9/T9PackConnector.cpp
Generated on Wed Jan 25 02:08:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9PinyinBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9PinyinBox Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/T9/T9PinyinBox.hpp>

Inheritance diagram for T9PinyinBox:

[legend]
Collaboration diagram for T9PinyinBox:

[legend]

Public Types

typedef DrawableObject | Base

Public Member Functions

virtual XYDIM | GetDefaultHeight () const
const WCHAR * | GetText (INT *selected_idx=0) const
void | Init (Control *control)
void | SetText (const WCHAR *text, INT selected_idx=-1)
T9PinyinBox (Control *control)
T9PinyinBox ()
virtual | ~T9PinyinBox ()

Member Typedef Documentation

typedef DrawableObject T9PinyinBox::Base

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

T9PinyinBox::T9PinyinBox ( )

T9PinyinBox::T9PinyinBox ( Control * control )

T9PinyinBox::~T9PinyinBox ( ) [virtual]

Member Function Documentation

XYDIM T9PinyinBox::GetDefaultHeight ( ) const [virtual]

See also:
Component::GetDefaultHeight

Reimplemented from Component.

const WCHAR * T9PinyinBox::GetText ( INT * selected_idx = 0 ) const

void T9PinyinBox::Init ( Control * control )

void T9PinyinBox::SetText | ( | const WCHAR * | text,
 |  | INT | selected_idx = -1
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/T9/T9PinyinBox.hpp
  • AddOns/T9/T9PinyinBox.cpp
Generated on Wed Jan 25 02:08:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9PinyinBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9PinyinBoxView Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/T9/T9PinyinBox.hpp>

Inheritance diagram for T9PinyinBoxView:

[legend]
Collaboration diagram for T9PinyinBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
void | Init ()
T9PinyinBoxView ()
virtual | ~T9PinyinBoxView ()

Constructor & Destructor Documentation

T9PinyinBoxView::T9PinyinBoxView ( )

T9PinyinBoxView::~T9PinyinBoxView ( ) [virtual]

Member Function Documentation

void T9PinyinBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void T9PinyinBoxView::Init ( )

The documentation for this class was generated from the following files:
  • AddOns/T9/T9PinyinBox.hpp
  • AddOns/T9/T9PinyinBox.cpp
Generated on Wed Jan 25 02:08:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9PredictiveInputBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9PredictiveInputBox Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/T9/T9PredictiveInputBox.hpp>

Inheritance diagram for T9PredictiveInputBox:

[legend]
Collaboration diagram for T9PredictiveInputBox:

[legend]

Public Member Functions

virtual BOOLEAN | AddNewWordToUdb (const WString &word)
virtual INT | GetCapsStatus () const
void | Init (Control *parent, AbstractMultiLineEditor *m_editor, Window *add_word_to_dict_win=0, Window *ext_punc_win=0)
virtual BOOLEAN | SetMode (PredInputMapper::PredMode mode)
virtual void | SetThaiMatrixModeWindow (T9ThaiMatrixModeWindowInterface *matrix_mode_window)
T9PredictiveInputBox (Control *parent, AbstractMultiLineEditor *m_editor, Window *add_word_to_dict_win=0, Window *ext_punc_win=0)
T9PredictiveInputBox ()
virtual | ~T9PredictiveInputBox ()

Protected Member Functions

virtual void | OnLayoutClient ()
virtual BOOLEAN | OnLongKeyPress (KeyCode key_code)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual BOOLEAN | RouteMessage (const Message &msg)
virtual void | UpdateDrawableObjects ()

Constructor & Destructor Documentation

T9PredictiveInputBox::T9PredictiveInputBox ( )

T9PredictiveInputBox::T9PredictiveInputBox | ( | Control * | parent,
 |  | AbstractMultiLineEditor * | m_editor,
 |  | Window * | add_word_to_dict_win = 0,
 |  | Window * | ext_punc_win = 0
 | ) |

T9PredictiveInputBox::~T9PredictiveInputBox ( ) [virtual]

Member Function Documentation

BOOLEAN T9PredictiveInputBox::AddNewWordToUdb ( const WString & word ) [virtual]

Implements AbstractPredictiveInputBox.

INT T9PredictiveInputBox::GetCapsStatus ( ) const [virtual]

Implements AbstractPredictiveInputBox.

void T9PredictiveInputBox::Init | ( | Control * | parent,
 |  | AbstractMultiLineEditor * | m_editor,
 |  | Window * | add_word_to_dict_win = 0,
 |  | Window * | ext_punc_win = 0
 | ) |

Reimplemented from AbstractPredictiveInputBox.

void T9PredictiveInputBox::OnLayoutClient ( ) [protected, virtual]

Is called, if the client area should be layouted (e. g. when the control is initialized or the size of the client area has changed). The use of the class Layouter for layouting the controls is recommended.

See also:
Layouter

Reimplemented from Control.

BOOLEAN T9PredictiveInputBox::OnLongKeyPress ( KeyCode key_code ) [protected, virtual]

Is called once before the autorepeat starts, if a key is pressed for a long time.

Parameters:
Code of the key.

Reimplemented from Control.

BOOLEAN T9PredictiveInputBox::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage()

Reimplemented from Component.

BOOLEAN T9PredictiveInputBox::RouteMessage ( const Message & msg ) [protected, virtual]

Implements the message routing of controls. It is recommended not to change the default message routing and usually it should not be necessary.

See also:
Dispatcher::RouteMessage

Reimplemented from Control.

BOOLEAN T9PredictiveInputBox::SetMode ( PredInputMapper::PredMode mode ) [virtual]

Reimplemented from AbstractPredictiveInputBox.

virtual void T9PredictiveInputBox::SetThaiMatrixModeWindow ( T9ThaiMatrixModeWindowInterface * matrix_mode_window ) [inline, virtual]

void T9PredictiveInputBox::UpdateDrawableObjects ( ) [protected, virtual]

get index number of chinese character list

Implements AbstractPredictiveInputBox.

The documentation for this class was generated from the following files:
  • AddOns/T9/T9PredictiveInputBox.hpp
  • AddOns/T9/T9PredictiveInputBox.cpp
Generated on Wed Jan 25 02:09:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9SymbolEntryRequestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9SymbolEntryRequestMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for T9SymbolEntryRequestMsg:

[legend]
Collaboration diagram for T9SymbolEntryRequestMsg:

[legend]

Public Types

enum | { ID = 30110 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
T9SymbolEntryRequestMsg ()
virtual | ~T9SymbolEntryRequestMsg ()

Detailed Description

This message is sent when the user wants to enter symbols explicitly. (T9 specifies that a new window with the symbol table should be openend).

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

T9SymbolEntryRequestMsg::T9SymbolEntryRequestMsg ( )

T9SymbolEntryRequestMsg::~T9SymbolEntryRequestMsg ( ) [virtual]

Member Function Documentation

Message * T9SymbolEntryRequestMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & T9SymbolEntryRequestMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:09:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9ThaiMatrixModeWindowInterface Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T9ThaiMatrixModeWindowInterface Class Reference

#include <Apoxi/AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp>

Public Member Functions

virtual INT OpenMatrixWindow (KeyCode key_code)=0

Member Function Documentation

virtual INT T9ThaiMatrixModeWindowInterface::OpenMatrixWindow ( KeyCode key_code ) [pure virtual]

The documentation for this class was generated from the following file:
  • AddOns/T9/T9ThaiMatrixModeWindowInterface.hpp
Generated on Wed Jan 25 02:09:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_CHANGED_FIELD Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_CHANGED_FIELD Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

SDL_Boolean | adn_core
SDL_Boolean | grouping
SDL_Boolean | pbc_hidden_info

Field Documentation

SDL_Boolean T_PB_CHANGED_FIELD::adn_core

SDL_Boolean T_PB_CHANGED_FIELD::grouping

SDL_Boolean T_PB_CHANGED_FIELD::pbc_hidden_info

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_CLIENT_FLAGS Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_CLIENT_FLAGS Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

byte A [1]

Field Documentation

byte T_PB_CLIENT_FLAGS::A[1]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_DESCRIPTOR Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_DESCRIPTOR Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_DESCRIPTOR:

[legend]

Data Fields

T_PB_UNIQUE_FILE aas
T_PB_UNIQUE_FILE adn
T_PB_REF_FILE anr
T_PB_UNIQUE_FILE ccp1
T_PB_REF_FILE email
T_PB_UNIQUE_FILE gas
SDL_Boolean | hidden_key_supported
T_PB_GROUP_NUMBER nof_group
byte nof_slice
T_PB_REF_FILE sne
SDL_Boolean | sync_supported

Field Documentation

T_PB_UNIQUE_FILE T_PB_DESCRIPTOR::aas

T_PB_UNIQUE_FILE T_PB_DESCRIPTOR::adn

T_PB_REF_FILE T_PB_DESCRIPTOR::anr

T_PB_UNIQUE_FILE T_PB_DESCRIPTOR::ccp1

T_PB_REF_FILE T_PB_DESCRIPTOR::email

T_PB_UNIQUE_FILE T_PB_DESCRIPTOR::gas

SDL_Boolean T_PB_DESCRIPTOR::hidden_key_supported

T_PB_GROUP_NUMBER T_PB_DESCRIPTOR::nof_group

byte T_PB_DESCRIPTOR::nof_slice

T_PB_REF_FILE T_PB_DESCRIPTOR::sne

SDL_Boolean T_PB_DESCRIPTOR::sync_supported

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_FILE_A Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_FILE_A Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_FILE_A:

[legend]

Data Fields

T_PB_FILE_IN_SLICE A [PB_MAX_SLICE]

Field Documentation

T_PB_FILE_IN_SLICE T_PB_FILE_A::A[PB_MAX_SLICE]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_FILE_DESC Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_FILE_DESC Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

byte handle
byte l_type
byte len_rec
byte nof_rec

Field Documentation

byte T_PB_FILE_DESC::handle

byte T_PB_FILE_DESC::l_type

byte T_PB_FILE_DESC::len_rec

byte T_PB_FILE_DESC::nof_rec

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_FILE_IN_SLICE Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_FILE_IN_SLICE Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_FILE_IN_SLICE:

[legend]

Data Fields

T_PB_FILE_DESC A [PB_MAX_FILE_TYPE_ENTITY]

Field Documentation

T_PB_FILE_DESC T_PB_FILE_IN_SLICE::A[PB_MAX_FILE_TYPE_ENTITY]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_FILL_STATUS Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_FILL_STATUS Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_FILL_STATUS:

[legend]

Data Fields

T_PB_UNIQUE_FILE_FILL_STATUS aas
T_PB_UNIQUE_FILE_FILL_STATUS adn
T_PB_REF_FILE_FILL_STATUS anr
T_PB_UNIQUE_FILE_FILL_STATUS ccp1
T_PB_REF_FILE_FILL_STATUS email
T_PB_UNIQUE_FILE_FILL_STATUS ext1
T_PB_UNIQUE_FILE_FILL_STATUS gas
T_PB_REF_FILE_FILL_STATUS sne

Field Documentation

T_PB_UNIQUE_FILE_FILL_STATUS T_PB_FILL_STATUS::aas

T_PB_UNIQUE_FILE_FILL_STATUS T_PB_FILL_STATUS::adn

T_PB_REF_FILE_FILL_STATUS T_PB_FILL_STATUS::anr

T_PB_UNIQUE_FILE_FILL_STATUS T_PB_FILL_STATUS::ccp1

T_PB_REF_FILE_FILL_STATUS T_PB_FILL_STATUS::email

T_PB_UNIQUE_FILE_FILL_STATUS T_PB_FILL_STATUS::ext1

T_PB_UNIQUE_FILE_FILL_STATUS T_PB_FILL_STATUS::gas

T_PB_REF_FILE_FILL_STATUS T_PB_FILL_STATUS::sne

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_GROUP_NUMBER Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_GROUP_NUMBER Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

byte A [PB_MAX_SLICE]

Field Documentation

byte T_PB_GROUP_NUMBER::A[PB_MAX_SLICE]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_GROUPING Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_GROUPING Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

byte A [PB_MAX_GROUP]

Field Documentation

byte T_PB_GROUPING::A[PB_MAX_GROUP]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_LOC_REPORT Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_LOC_REPORT Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_LOC_REPORT:

[legend]

Data Fields

T_PB_LOCATION current_loc
T_PB_STATE sim
T_PB_STATE usim_appl
T_PB_STATE usim_global

Field Documentation

T_PB_LOCATION T_PB_LOC_REPORT::current_loc

T_PB_STATE T_PB_LOC_REPORT::sim

T_PB_STATE T_PB_LOC_REPORT::usim_appl

T_PB_STATE T_PB_LOC_REPORT::usim_global

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_RECORD Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_RECORD Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_RECORD:

[legend]

Data Fields

T_DATA adn_core
T_PB_GROUPING grouping
byte pbc_hidden_info
T_PB_CHANGED_FIELD refresh_info
word uid

Field Documentation

T_DATA T_PB_RECORD::adn_core

T_PB_GROUPING T_PB_RECORD::grouping

byte T_PB_RECORD::pbc_hidden_info

T_PB_CHANGED_FIELD T_PB_RECORD::refresh_info

word T_PB_RECORD::uid

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_REF_FILE Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_REF_FILE Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_REF_FILE:

[legend]

Data Fields

T_PB_FILE_A a
word nof_entity

Field Documentation

T_PB_FILE_A T_PB_REF_FILE::a

word T_PB_REF_FILE::nof_entity

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_REF_FILE_FILL_STATUS Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_REF_FILE_FILL_STATUS Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_REF_FILE_FILL_STATUS:

[legend]

Data Fields

T_PB_REF_FILE_FILL_STATUS_A A [PB_MAX_SLICE]

Field Documentation

T_PB_REF_FILE_FILL_STATUS_A T_PB_REF_FILE_FILL_STATUS::A[PB_MAX_SLICE]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_REF_FILE_FILL_STATUS_A Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_REF_FILE_FILL_STATUS_A Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

byte A [PB_MAX_FILE_TYPE_ENTITY]

Field Documentation

byte T_PB_REF_FILE_FILL_STATUS_A::A[PB_MAX_FILE_TYPE_ENTITY]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_REF_RECORD Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_REF_RECORD Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_REF_RECORD:

[legend]

Data Fields

T_PB_REFERENCE anr_ref
T_PB_REFERENCE email_ref
T_PB_REFERENCE sne_ref

Field Documentation

T_PB_REFERENCE T_PB_REF_RECORD::anr_ref

T_PB_REFERENCE T_PB_REF_RECORD::email_ref

T_PB_REFERENCE T_PB_REF_RECORD::sne_ref

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_REFERENCE Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_REFERENCE Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

byte A [PB_MAX_FILE_TYPE_ENTITY]

Field Documentation

byte T_PB_REFERENCE::A[PB_MAX_FILE_TYPE_ENTITY]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_STATE Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_STATE Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

SDL_Boolean | exist
SDL_Boolean | last_used

Field Documentation

SDL_Boolean T_PB_STATE::exist

SDL_Boolean T_PB_STATE::last_used

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_UNIQUE_FILE Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_UNIQUE_FILE Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for T_PB_UNIQUE_FILE:

[legend]

Data Fields

T_PB_FILE_DESC A [PB_MAX_SLICE]

Field Documentation

T_PB_FILE_DESC T_PB_UNIQUE_FILE::A[PB_MAX_SLICE]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_PB_UNIQUE_FILE_FILL_STATUS Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_PB_UNIQUE_FILE_FILL_STATUS Struct Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Data Fields

byte A [PB_MAX_SLICE]

Field Documentation

byte T_PB_UNIQUE_FILE_FILL_STATUS::A[PB_MAX_SLICE]

The documentation for this struct was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:09:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T_STK_TRANSACTION_ID Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

T_STK_TRANSACTION_ID Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

SdlByte cmd_number
SdlByte transaction_id

Field Documentation

SdlByte T_STK_TRANSACTION_ID::cmd_number

SdlByte T_STK_TRANSACTION_ID::transaction_id

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 02:09:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TabButton Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TabButton Class Reference
[Components]

#include <Apoxi/Gui/TabButton.hpp>

Inheritance diagram for TabButton:

[legend]
Collaboration diagram for TabButton:

[legend]

Public Types

enum | { ID = 22 }
enum | PositionHint { LeftPos, MiddlePos, RightPos }

Public Member Functions

PositionHint | GetPositionHint () const
void | Init (Control *parent, const WString &text, const ImageObtainer &icon)
void | Init (Control *parent, const WString &text, const BitmapRes *icon=0)
BOOLEAN | IsActive () const
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetActive (BOOLEAN active)
void | SetPositionHint (PositionHint pos_hint)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
TabButton (Control *parent, const WString &text, const ImageObtainer &icon)
TabButton (Control *parent, const WString &text, const BitmapRes *icon=0)
TabButton ()
virtual | ~TabButton ()

Protected Member Functions

virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Detailed Description

A TabButton is used by the class TabControl for displaying the header of tab pages. The view of a TabButton can be configured by implementing an instance of the class TabButtonView. Usually it is not required that an application instantiates a TabButton itself, as this is done internally by the TabControl.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractButton.

enum TabButton::PositionHint

Gives a hint of the position of the tab button. This is required for the implementation of the view object.

Enumerator:
LeftPos | The tab button is the left most button.
MiddlePos | The tab button is in the middle of the left and right most button. A tab button can only have this hint, if at least 3 tab buttons are part of the tab control.
RightPos | The tab button is the right most button.

Constructor & Destructor Documentation

TabButton::TabButton ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TabButton::TabButton | ( | Control * | parent,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0
 | ) |

Parent control which embeds the tab button. Text of the tab button. Optional icon.

TabButton::TabButton | ( | Control * | parent,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon
 | ) |

Parent control which embeds the tab button. Text of the tab button. Optional icon.

TabButton::~TabButton ( ) [virtual]

Member Function Documentation

PositionHint TabButton::GetPositionHint ( ) const [inline]

void TabButton::Init | ( | Control * | parent,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon
 | ) |

Parent control which embeds the tab button. Text of the tab button. Optional icon.

void TabButton::Init | ( | Control * | parent,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0
 | ) |

Parent control which embeds the tab button. Text of the tab button. Optional icon.

BOOLEAN TabButton::IsActive ( ) const [inline]

BOOLEAN TabButton::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractButton.

void TabButton::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from Control.

void TabButton::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from Control.

void TabButton::SetActive ( BOOLEAN active )

Activates the tab button, which means that the tab page related to this tab button will be shown.

void TabButton::SetPositionHint ( PositionHint pos_hint )

Sets a hint about the position of the tab which is required for the implementation of the tab button view.

BOOLEAN TabButton::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractButton.

The documentation for this class was generated from the following files:
  • Gui/TabButton.hpp
  • Gui/TabButton.cpp
Generated on Wed Jan 25 02:09:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TabButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TabButtonView Class Reference
[Components]

Describes the view of a TabButton. More...

#include <Apoxi/Gui/TabButton.hpp>

Inheritance diagram for TabButtonView:

[legend]
Collaboration diagram for TabButtonView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
XYDIM | GetClippedWidth () const
XYDIM | GetMaximumWidth () const
XYDIM | GetMinimumWidth () const
TabButtonView (XYDIM default_height, XYDIM default_width=-1, XYDIM min_width=-1, XYDIM max_width=-1, XYDIM clipped_width=20)
virtual | ~TabButtonView ()

Protected Member Functions

virtual void | DrawTabButton (const TabButton &tab_button, DeviceContext *dc, const Rect &repaint_rect) const =0
Must be overwritten by the theme for drawing the tab button.
void | SetClippedWidth (XYDIM clipped_width)
void | SetMaximumWidth (XYDIM max_width)
void | SetMinimumWidth (XYDIM min_width)

Detailed Description

Describes the view of a TabButton.

Constructor & Destructor Documentation

TabButtonView::TabButtonView | ( | XYDIM | default_height,
 |  | XYDIM | default_width = -1,
 |  | XYDIM | min_width = -1,
 |  | XYDIM | max_width = -1,
 |  | XYDIM | clipped_width = 20
 | ) |

Parameters:
default_height | Default height of the button. If -1 is used, the height of the client font is used as default setting.
default_width | Default width of the button. If -1 is used, the buttons are stretched in a way that all buttons are visible inside the available tab control width.
min_width | Defines the minimum width a tab button may have. If a value < 1 is used, a minimum of 1 is assumed. Note that when the header line is turned on by TabControl::SetHeaderEnabled(TRUE), the minimum width is used for the width of the tab buttons instead of the default width, as the tab button will not contain any text.
max_width | Defines the maximum width a tab button may have. If a value < 1 is used, no maximum is given.
clipped_width | If not all tab buttons fit into the tab control width, the clipped_width describes the preferred width of the clipped tab button on the left or right.

TabButtonView::~TabButtonView ( ) [virtual]

Member Function Documentation

void TabButtonView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

virtual void TabButtonView::DrawTabButton | ( | const TabButton & | tab_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Must be overwritten by the theme for drawing the tab button.

Implemented in DefaultTabButtonView.

XYDIM TabButtonView::GetClippedWidth ( ) const [inline]

XYDIM TabButtonView::GetMaximumWidth ( ) const [inline]

XYDIM TabButtonView::GetMinimumWidth ( ) const [inline]

void TabButtonView::SetClippedWidth ( XYDIM clipped_width ) [inline, protected]

void TabButtonView::SetMaximumWidth ( XYDIM max_width ) [inline, protected]

void TabButtonView::SetMinimumWidth ( XYDIM min_width ) [inline, protected]

The documentation for this class was generated from the following files:
  • Gui/TabButton.hpp
  • Gui/TabButton.cpp
Generated on Wed Jan 25 02:09:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TabControl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TabControl Class Reference
[Components]

#include <Apoxi/Gui/TabControl.hpp>

Inheritance diagram for TabControl:

[legend]
Collaboration diagram for TabControl:

[legend]

Public Types

enum | { ID = 23 }

Public Member Functions

INT | AddTab (Control *page, const WString &text, const ImageObtainer &icon)
INT | AddTab (Control *page, const WString &text, const BitmapRes *icon=0)
INT | GetActiveTab () const
Returns the index of the currently active tab page.
const ImageObtainer & | GetIcon (INT index) const
Control * | GetPage (INT index) const
INT | GetTabCount () const
const WString & | GetText (INT index) const
void | Init (Control *parent)
INT | InsertTab (INT index, Control *page, const WString &text, const ImageObtainer &icon)
INT | InsertTab (INT index, Control *page, const WString &text, const BitmapRes *icon=0)
BOOLEAN | IsHeaderEnabled () const
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsTabEnabled (INT index) const
Returns TRUE, if the tab page is enabled.
void | RemoveTab (INT index)
void | SetActiveTab (INT index)
void | SetHeaderEnabled (BOOLEAN enabled)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetTabEnabled (INT index, BOOLEAN enabled)
TabControl (Control *parent)
TabControl ()
virtual | ~TabControl ()

Protected Member Functions

virtual void | OnActiveTabChanged (INT old_tab_index)
virtual void | OnFocusNextControl ()
virtual void | OnFocusPreviousControl ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLanguageChanged ()
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)

Data Structures

class | Tab

Detailed Description

A TabControl allows to embed controls inside a variable number of tab pages. The navigation between the tab pages is done by the left and right arrow key. A tab page is represented by a text, an icon and a control which acts as page content.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Control.

Constructor & Destructor Documentation

TabControl::TabControl ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TabControl::TabControl ( Control * parent )

Parameters:
parent Pointer to the control, which embeds the TabControl.

TabControl::~TabControl ( ) [virtual]

Member Function Documentation

INT TabControl::AddTab | ( | Control * | page,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon
 | ) |

Adds a tab page at the end of all embedded tab pages.

Parameters:
page | Pointer to the control which acts as page.
text | Text for the header of the page.
icon | Optional icon for the header of the page.
Returns:
Index of the embedded tab page. -1 is returned, if an error has occured.

INT TabControl::AddTab | ( | Control * | page,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0
 | ) |

Adds a tab page at the end of all embedded tab pages.

Parameters:
page | Pointer to the control which acts as page.
text | Text for the header of the page.
icon | Optional icon for the header of the page.
Returns:
Index of the embedded tab page. -1 is returned, if an error has occured.

INT TabControl::GetActiveTab ( ) const [inline]

Returns the index of the currently active tab page.

const ImageObtainer & TabControl::GetIcon ( INT index ) const

Returns the icon of the tab page on the given index.

Control * TabControl::GetPage ( INT index ) const

Returns the page which is on the given index.

INT TabControl::GetTabCount ( ) const [inline]

Returns the number of tab pages.

const WString & TabControl::GetText ( INT index ) const

Returns the text of the tab page on the given index.

void TabControl::Init ( Control * parent )

Parameters:
parent Pointer to the control, which embeds the TabControl.

INT TabControl::InsertTab | ( | INT | index,
 |  | Control * | page,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon
 | ) |

Inserts a tab page.

Parameters:
index | Index, where the tab page should be inserted. When -1 is used, the tab page will be added to the end of all available tab pages.
page | Pointer to the control which acts as page.
text | Text for the header of the page.
icon | Optional icon for the header of the page.
Returns:
Index of the embedded tab page. -1 is returned, if an error has occured.

INT TabControl::InsertTab | ( | INT | index,
 |  | Control * | page,
 |  | const WString & | text,
 |  | const BitmapRes * | icon = 0
 | ) |

Inserts a tab page.

Parameters:
index | Index, where the tab page should be inserted. When -1 is used, the tab page will be added to the end of all available tab pages.
page | Pointer to the control which acts as page.
text | Text for the header of the page.
icon | Optional icon for the header of the page.
Returns:
Index of the embedded tab page. -1 is returned, if an error has occured.

BOOLEAN TabControl::IsHeaderEnabled ( ) const [inline]

Returns TRUE, if the header for tabs is enabled (see TabControl::SetHeaderEnabled for more details).

BOOLEAN TabControl::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Control.

BOOLEAN TabControl::IsTabEnabled ( INT index ) const

Returns TRUE, if the tab page is enabled.

void TabControl::OnActiveTabChanged ( INT old_tab_index ) [protected, virtual]

Is invoked whenever the active tab page has been changed.

Parameters:
old_tab_index Indicates the index of the previously active tab page. The current index can be retrieved by invoking TabControl::GetActiveTab().

void TabControl::OnFocusNextControl ( ) [protected, virtual]

See also:
Control::OnFocusNextControl

Reimplemented from Control.

void TabControl::OnFocusPreviousControl ( ) [protected, virtual]

See also:
Control::OnFocusPreviousControl

Reimplemented from Control.

BOOLEAN TabControl::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from Control.

void TabControl::OnLanguageChanged ( ) [protected, virtual]

See also:
Component::OnLanguageChanged

Reimplemented from Control.

void TabControl::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Control.

BOOLEAN TabControl::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Component.

void TabControl::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from Control.

void TabControl::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh

Reimplemented from Control.

void TabControl::RemoveTab ( INT index )

Removes the tab page with the given index.

void TabControl::SetActiveTab ( INT index )

Sets the currently active tab page by specifying its index. Also disabled tabs can be set to active, although the default navigation with the left and right arrow key won't activate a disabled tab.

void TabControl::SetHeaderEnabled ( BOOLEAN enabled )

Enables the header for tabs, if enabled is TRUE (per default the header for tabs is disabled). If the header is enabled, a line below the tabs contains the text of the currently active tab and the tab itself only contains the icon. Enabling the header is useful if the tabs contain long texts which don't fit into the available width.

BOOLEAN TabControl::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Control.

void TabControl::SetTabEnabled | ( | INT | index,
 |  | BOOLEAN | enabled
 | ) |

Enables the tab page specified by its index. Per default all tab pages are enabled. A disabled tab page may get activated, but no focus is given to the content of the tab page.

The documentation for this class was generated from the following files:
  • Gui/TabControl.hpp
  • Gui/TabControl.cpp
Generated on Wed Jan 25 02:09:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TabControlView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TabControlView Class Reference
[Components]

#include <Apoxi/Gui/TabControl.hpp>

Inheritance diagram for TabControlView:

[legend]
Collaboration diagram for TabControlView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
XYDIM | GetBorderSize () const
XYDIM | GetHeaderHeight () const
TabControlView (XYDIM border_size, XYDIM header_height=0)
virtual void | Update (const Theme &theme)
virtual | ~TabControlView ()

Protected Member Functions

virtual void | DrawTabControl (const TabControl &tab_control, DeviceContext *dc, const Rect &repaint_rect) const =0
Must be overwritten by the theme for drawing the tab control.

Detailed Description

Describes the view of a tab control. The drawing of the tab buttons is done by an instance of the class TabButtonView.

Constructor & Destructor Documentation

TabControlView::TabControlView | ( | XYDIM | border_size,
 |  | XYDIM | header_height = 0
 | ) |

Parameters:
border_size | Size of the border in pixels between the tab control boundaries and the embedded pages.
header_height | Height of the header in pixels. The header can be enabled by TabControl::SetHeaderEnabled. If the header height is <= 0, the height of the font defined by Font::Client is used.

TabControlView::~TabControlView ( ) [virtual]

Member Function Documentation

void TabControlView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Implements View.

virtual void TabControlView::DrawTabControl | ( | const TabControl & | tab_control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

Must be overwritten by the theme for drawing the tab control.

Implemented in DefaultTabControlView.

XYDIM TabControlView::GetBorderSize ( ) const [inline]

Returns the size of the tab border in pixels. The tab border is defined as the area between the tab control boundaries and the embedded pages.

XYDIM TabControlView::GetHeaderHeight ( ) const [inline]

Returns the height of the header in pixels. The header can be enabled by TabControl::SetHeaderEnabled.

void TabControlView::Update ( const Theme & theme ) [virtual]

See also:
View::Update

Reimplemented from View.

The documentation for this class was generated from the following files:
  • Gui/TabControl.hpp
  • Gui/TabControl.cpp
Generated on Wed Jan 25 02:09:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagCPGlyph Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagCPGlyph Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 | data [1]
UINT8 | size
UINT8 | width

Field Documentation

UINT8 tagCPGlyph::data[1]

UINT8 tagCPGlyph::size

UINT8 tagCPGlyph::width

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagCustFileData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagCustFileData Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 | data [1]
WCHAR | file_name [32]
UINT32 | file_size
UINT8 | mime_type
UINT8 | padding [3]
UINT32 | size

Field Documentation

UINT8 tagCustFileData::data[1]

WCHAR tagCustFileData::file_name[32]

UINT32 tagCustFileData::file_size

UINT8 tagCustFileData::mime_type

UINT8 tagCustFileData::padding[3]

UINT32 tagCustFileData::size

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagCustomizationPack Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagCustomizationPack Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 | data_pack [1]
UINT8 | data_pack_count
UINT32 | header
UINT8 | padding
UINT8 | running_version
UINT32 | size
UINT8 | version

Field Documentation

UINT8 tagCustomizationPack::data_pack[1]

UINT8 tagCustomizationPack::data_pack_count

UINT32 tagCustomizationPack::header

UINT8 tagCustomizationPack::padding

UINT8 tagCustomizationPack::running_version

UINT32 tagCustomizationPack::size

UINT8 tagCustomizationPack::version

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagDataPackHeader Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagDataPackHeader Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 | data_pack_data [1]
DataPackId data_pack_id
UINT16 | entry_count
UINT16 | padding
UINT32 | size

Field Documentation

UINT8 tagDataPackHeader::data_pack_data[1]

DataPackId tagDataPackHeader::data_pack_id

UINT16 tagDataPackHeader::entry_count

UINT16 tagDataPackHeader::padding

UINT32 tagDataPackHeader::size

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagFilePackData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagFilePackData Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 cust_file [1]

Field Documentation

UINT8 tagFilePackData::cust_file[1]

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagFont Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagFont Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Collaboration diagram for tagFont:

[legend]

Data Fields

UINT8 | baseline
UINT8 | bold_index
FontFamily font_family
UINT8 | gap_to_next_char
UINT8 | height
EntryId id
UINT8 | index_table [256]
UINT8 | italic_index
WCHAR | name [16]
UINT16 | num_glyphs
UINT32 | offset_table [1]
UINT8 | padding2
UINT8 | padding3 [2]
UINT32 | size
UINT8 | table_count

Field Documentation

UINT8 tagFont::baseline

UINT8 tagFont::bold_index

FontFamily tagFont::font_family

UINT8 tagFont::gap_to_next_char

UINT8 tagFont::height

EntryId tagFont::id

UINT8 tagFont::index_table[256]

UINT8 tagFont::italic_index

WCHAR tagFont::name[16]

UINT16 tagFont::num_glyphs

UINT32 tagFont::offset_table[1]

UINT8 tagFont::padding2

UINT8 tagFont::padding3[2]

UINT32 tagFont::size

UINT8 tagFont::table_count

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagFontFamily Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagFontFamily Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

WCHAR | family_name [16]
UINT8 | padding [3]
BOOLEAN | serif

Field Documentation

WCHAR tagFontFamily::family_name[16]

UINT8 tagFontFamily::padding[3]

BOOLEAN tagFontFamily::serif

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagFontPack Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagFontPack Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 font [1]

Field Documentation

UINT8 tagFontPack::font[1]

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TaggedProblemCode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TaggedProblemCode Class Reference

Supplementary Service Problem Tag [GSM 04.80, 3.6.7, Table 3.13]. More...

#include <Apoxi/Apc/TaggedProblemCode.hpp>

Public Types

enum ProblemCode {
UnrecognizedComponent = 0x00, MistypedComponent = 0x01, BadlyStructuredComponent = 0x02, DuplicateInvokeId = 0x10,
UnrecognizedOperation = 0x11, MistypedProParameter = 0x12, ResourceLimitation = 0x13, InitiatingRelease = 0x14,
UnrecognizedLinkedId = 0x15, LinkedResponseUnexpected = 0x16, UnexpectedLinkedOperation = 0x17, UnrecognizedInvokeId = 0x20,
ReturnResultUnexpected = 0x21, MistypedResParameter = 0x22, UnrecognizedErrorInvokeId = 0x30, ReturnErrorUnexpected = 0x31,
UnrecognizedError = 0x32, UnexpectedError = 0x33, MistypedErrorParameter = 0x34, InvalidCode = 0x0f
}
enum ProblemTag {
General = 0x00, Invoke = 0x01, ReturnResult = 0x02, ReturnError = 0x03,
InvalidTag = 0x0f
}
describes the problem code tags. More...

Public Member Functions

UINT8 | GetCodeAsByte () const
Returns the byte representation of the problem tag.
ProblemCode | GetProblemCode () const
Returns the problem code enumeration value.
ProblemTag | GetProblemTag () const
Returns the problem tag enumeration value.
UINT8 | GetTagAsByte () const
Returns the byte representation of the problem tag.
void | SetProblemCode (ProblemCode code)
TaggedProblemCode (const ProblemCode code)
Constructor using enum value.
TaggedProblemCode (const TaggedProblemCode &code)
Copy constructor.
TaggedProblemCode (UINT8 incoming_tag=InvalidTag, UINT8 incoming_code=InvalidCode)
Constructor of the class, used if data from stack.

Detailed Description

Supplementary Service Problem Tag [GSM 04.80, 3.6.7, Table 3.13].

Member Enumeration Documentation

enum TaggedProblemCode::ProblemCode

Enumerator:
UnrecognizedComponent | General problem codes Table 3.14.
MistypedComponent
BadlyStructuredComponent
DuplicateInvokeId | Invoke Problem Codes, Table 3.15.
UnrecognizedOperation
MistypedProParameter
ResourceLimitation
InitiatingRelease
UnrecognizedLinkedId
LinkedResponseUnexpected
UnexpectedLinkedOperation
UnrecognizedInvokeId | Return Result Problem Codes, Table 3.16.
ReturnResultUnexpected
MistypedResParameter
UnrecognizedErrorInvokeId | Return Error Problem Codes.
ReturnErrorUnexpected
UnrecognizedError
UnexpectedError
MistypedErrorParameter
InvalidCode | defined for ASC

enum TaggedProblemCode::ProblemTag

describes the problem code tags.

Enumerator:
General
Invoke
ReturnResult
ReturnError
InvalidTag defined for ASC

Constructor & Destructor Documentation

TaggedProblemCode::TaggedProblemCode | ( | UINT8 | incoming_tag = InvalidTag,
 |  | UINT8 | incoming_code = InvalidCode
 | ) | [inline, explicit]

Constructor of the class, used if data from stack.

TaggedProblemCode::TaggedProblemCode ( const TaggedProblemCode & code ) [inline]

Copy constructor.

TaggedProblemCode::TaggedProblemCode ( const ProblemCode code ) [inline]

Constructor using enum value.

Member Function Documentation

UINT8 TaggedProblemCode::GetCodeAsByte ( ) const [inline]

Returns the byte representation of the problem tag.

ProblemCode TaggedProblemCode::GetProblemCode ( ) const [inline]

Returns the problem code enumeration value.

ProblemTag TaggedProblemCode::GetProblemTag ( ) const [inline]

Returns the problem tag enumeration value.

UINT8 TaggedProblemCode::GetTagAsByte ( ) const [inline]

Returns the byte representation of the problem tag.

void TaggedProblemCode::SetProblemCode ( ProblemCode code ) [inline]

The documentation for this class was generated from the following file:
  • Apc/TaggedProblemCode.hpp
Generated on Wed Jan 25 02:09:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagGlyphData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagGlyphData Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 * data_table

Field Documentation

UINT8* tagGlyphData::data_table

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagLanguage Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagLanguage Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

EntryId id
WCHAR | name [16]
WCHAR | native_name [16]
UINT16 | offset_table [1]
UINT8 | padding
UINT32 | size
UINT16 | string_count

Field Documentation

EntryId tagLanguage::id

WCHAR tagLanguage::name[16]

WCHAR tagLanguage::native_name[16]

UINT16 tagLanguage::offset_table[1]

UINT8 tagLanguage::padding

UINT32 tagLanguage::size

UINT16 tagLanguage::string_count

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagLdbData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagLdbData Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 | data [1]
UINT16 | ldb_id
UINT32 | ldb_size
UINT8 | padding [2]
UINT32 | size

Field Documentation

UINT8 tagLdbData::data[1]

UINT16 tagLdbData::ldb_id

UINT32 tagLdbData::ldb_size

UINT8 tagLdbData::padding[2]

UINT32 tagLdbData::size

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagT9Pack Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagT9Pack Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 t9_pack [1]

Field Documentation

UINT8 tagT9Pack::t9_pack[1]

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagTextPack Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagTextPack Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

UINT8 language [1]

Field Documentation

UINT8 tagTextPack::language[1]

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: tagTranslationTable Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

tagTranslationTable Struct Reference

#include <Apoxi/Gui/AcacTypes.hpp>

Data Fields

WCHAR data [1]

Field Documentation

WCHAR tagTranslationTable::data[1]

The documentation for this struct was generated from the following file:
  • Gui/AcacTypes.hpp
Generated on Wed Jan 25 02:09:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TAlphaIdentifier_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TAlphaIdentifier_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for TAlphaIdentifier_s:

[legend]

Data Fields

TAlphaIdentifierArray data
SDL_Boolean identifier_valid
byte length

Field Documentation

TAlphaIdentifierArray TAlphaIdentifier_s::data

SDL_Boolean TAlphaIdentifier_s::identifier_valid

byte TAlphaIdentifier_s::length

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 02:09:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TAlphaIdentifierArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TAlphaIdentifierArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

byte val [SI_MAX_ALPHA_IDENTIFIER_SIZE]

Field Documentation

byte TAlphaIdentifierArray::val[SI_MAX_ALPHA_IDENTIFIER_SIZE]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 02:09:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Task Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Task Struct Reference

#include <Apoxi/Kernel/Os/Win32/Win32.hpp>

Data Fields

HANDLE hdl

Field Documentation

HANDLE Task::hdl

The documentation for this struct was generated from the following file:
  • Kernel/Os/Win32/Win32.hpp
Generated on Wed Jan 25 02:09:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TcpNetAdapter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TcpNetAdapter Class Reference

#include <Apoxi/Socket/NetAdapterHandler.hpp>

Inheritance diagram for TcpNetAdapter:

[legend]
Collaboration diagram for TcpNetAdapter:

[legend]

Public Member Functions

virtual SocketError | GetError () const
virtual INT | GetInBufByteCount ()
virtual INT | Read (void *buf, INT buflen, InetSocketAddr *from=0)
TcpNetAdapter (NetAdapterHandler *handler, NetAdapter::Id id, NetAdapter::Type type)
virtual INT | Write (const void *buf, INT buflen, InetSocketAddr *to=0)

Protected Member Functions

virtual void | OnAsyncEvent (InetSocket::Event event)

Detailed Description

TcpNetAdapter extends the APOXI TcpSocket class to implement asynchronous socket IO event-handling.

Constructor & Destructor Documentation

TcpNetAdapter::TcpNetAdapter | ( | NetAdapterHandler * | handler,
 |  | NetAdapter::Id | id,
 |  | NetAdapter::Type | type
 | ) |

Member Function Documentation

virtual SocketError TcpNetAdapter::GetError ( ) const [inline, virtual]

Implements ClientNetAdapter.

virtual INT TcpNetAdapter::GetInBufByteCount ( ) [inline, virtual]

Implements ClientNetAdapter.

virtual void TcpNetAdapter::OnAsyncEvent ( InetSocket::Event event ) [inline, protected, virtual]

Asynchronous event handler, defined in base class UdpSocket.

virtual INT TcpNetAdapter::Read | ( | void * | buf,
 |  | INT | buflen,
 |  | InetSocketAddr * | from = 0
 | ) | [inline, virtual]

Implements ClientNetAdapter.

virtual INT TcpNetAdapter::Write | ( | const void * | buf,
 |  | INT | buflen,
 |  | InetSocketAddr * | to = 0
 | ) | [inline, virtual]

Implements ClientNetAdapter.

The documentation for this class was generated from the following files:
  • Socket/NetAdapterHandler.hpp
  • Socket/NetAdapterHandler.cpp
Generated on Wed Jan 25 02:09:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TcpServerSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TcpServerSocket Class Reference
[Socket]

#include <Apoxi/Socket/TcpServerSocket.hpp>

Inheritance diagram for TcpServerSocket:

[legend]
Collaboration diagram for TcpServerSocket:

[legend]

Public Types

enum | { c_default_max_pending_requests = 5 }

Public Member Functions

BOOLEAN | Accept (TcpSocket &socket, InetSocketAddr *peer_addr=0)
BOOLEAN | HandOver (TcpServerSocket &to_socket)
BOOLEAN | Listen (INT backlog=c_default_max_pending_requests)
BOOLEAN | Open (const InetSocketAddr &local_addr, BOOLEAN may_reuse_addr=TRUE)

Protected Member Functions

virtual void | OnControlMsg (const SocketControlMsg &msg)

Detailed Description

TcpServerSocket

Member Enumeration Documentation

anonymous enum

Enumerator:
c_default_max_pending_requests

Member Function Documentation

BOOLEAN TcpServerSocket::Accept | ( | TcpSocket & | socket,
 |  | InetSocketAddr * | peer_addr = 0
 | ) |

Accepts a pending connection request. If the method succeeds, then socket is initialized and ready for communication. If addr is given, then it is set to the address of the peer.

Parameters:
socket | Socket of accepted connection.
peer_addr | Socket address of peer.

BOOLEAN TcpServerSocket::HandOver ( TcpServerSocket & to_socket ) [inline]

Hands over itself to to_socket. This socket is then reverted to closed state and hence does not operate any more. Instead, to_socket continues operation. This method should only be used to hand over a socket between execution contexts if needed. Note that if you hand over a socket from one execution context to another, also the execution context to which to_socket belongs must have initialized a socket handler. For the hand over to succeed this socket must be in open state and to_socket must be in closed state. If the hand over can not be performed FALSE is returned.

See also:
ExecutionContext

SocketHandler

Returns:
Success of hand over.

BOOLEAN TcpServerSocket::Listen ( INT backlog = c_default_max_pending_requests )

Puts the server socket into listen state. When the socket is in listen state and a connection request is coming in, then the event c_event_conn_req_pending is triggered.

Parameters:
backlog Maximum number of pending connection requests.

void TcpServerSocket::OnControlMsg ( const SocketControlMsg & msg ) [protected, virtual]

Translates the socket control message msg into a socket event and routes it accordingly. If a listener is set, its OnSocketEvent method is called. Otherwise the messages are discarded.

Implements InetSocket.

BOOLEAN TcpServerSocket::Open | ( | const InetSocketAddr & | local_addr,
 |  | BOOLEAN | may_reuse_addr = TRUE
 | ) |

Opens a TCP server type socket.

Parameters:
local_addr | Mandatory local address to bind server socket to.
may_reuse_addr | Local address may be bound by multiple sockets.

The documentation for this class was generated from the following files:
  • Socket/TcpServerSocket.hpp
  • Socket/TcpServerSocket.cpp
Generated on Wed Jan 25 02:09:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TcpServerTestSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TcpServerTestSocket Class Reference

#include <Applications/SocketTest/TcpServerTestSocket.hpp>

Inheritance diagram for TcpServerTestSocket:

[legend]
Collaboration diagram for TcpServerTestSocket:

[legend]

Public Member Functions

TcpServerTestSocket ()
virtual | ~TcpServerTestSocket ()

Protected Member Functions

virtual void | OnAsyncEvent (Event event)

Constructor & Destructor Documentation

TcpServerTestSocket::TcpServerTestSocket ( )

TcpServerTestSocket class is implementation of TCP server socket used for testing.

TcpServerTestSocket::~TcpServerTestSocket ( ) [virtual]

Member Function Documentation

void TcpServerTestSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Receives the notification of an asynchronous event. The event types are dependent on the socket type, some events are only sent for connection oriented sockets or for server sockets (please see the enumeration Event). A client who uses sockets has to derive an own socket class and implement this method in order to listen to the events that occur on the socket and to react on it according to its communication policy.

Reimplemented from InetSocket.

The documentation for this class was generated from the following files:
  • Applications/SocketTest/TcpServerTestSocket.hpp
  • Applications/SocketTest/TcpServerTestSocket.cpp
Generated on Wed Jan 25 02:09:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TcpSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TcpSocket Class Reference
[Socket]

#include <Apoxi/Socket/TcpSocket.hpp>

Inheritance diagram for TcpSocket:

[legend]
Collaboration diagram for TcpSocket:

[legend]

Public Member Functions

BOOLEAN | Connect (const InetSocketAddr &to, BOOLEAN event=FALSE)
BOOLEAN | HandOver (TcpSocket &to_socket)
BOOLEAN | Open (const InetSocketAddr *local_addr=0, BOOLEAN may_reuse_addr=TRUE)
INT | Read (void *buf, INT buflen)
TcpSocket ()
INT | Write (const void *buf, INT buflen)

Protected Member Functions

virtual void | OnControlMsg (const SocketControlMsg &msg)

Detailed Description

TcpSocket exposes interfaces to write / read data from TCP streams.

Constructor & Destructor Documentation

TcpSocket::TcpSocket ( )

Member Function Documentation

BOOLEAN TcpSocket::Connect | ( | const InetSocketAddr & | to,
 |  | BOOLEAN | event = FALSE
 | ) |

Establish a TCP connection to the specified address.

Parameters:
to | remote address to connect to
event | flag indicating if connect should block (using an active wait) or if it should fire an asynchronous event when the connection to the remote address could be established or not. Per default (due to backwards compatibility) this method will block until the connect operation is finished. As this can take quite some time it is recommended to use the event driven approach by setting this flag to TRUE.

BOOLEAN TcpSocket::HandOver ( TcpSocket & to_socket ) [inline]

Hands over itself to to_socket. This socket is then reverted to closed state and hence does not operate any more. Instead, to_socket continues operation. This method should only be used to hand over a socket between execution contexts if needed. Note that if you hand over a socket from one execution context to another, also the execution context to which to_socket belongs must have initialized a socket handler. For the hand over to succeed this socket must be in open state and to_socket must be in closed state. If the hand over can not be performed FALSE is returned.

See also:
ExecutionContext

SocketHandler

Returns:
Success of hand over.

void TcpSocket::OnControlMsg ( const SocketControlMsg & msg ) [protected, virtual]

Translates the socket control message msg into a socket event and routes it accordingly. If a listener is set, its OnSocketEvent method is called. Otherwise the messages are discarded.

Implements InetSocket.

BOOLEAN TcpSocket::Open | ( | const InetSocketAddr * | local_addr = 0,
 |  | BOOLEAN | may_reuse_addr = TRUE
 | ) | [inline]

Open TCP type socket.

Parameters:
local_addr | local address to bind socket to
may_reuse_addr | local address may be bound by multiple sockets

Reimplemented from TcpSocketBase.

INT TcpSocket::Read | ( | void * | buf,
 |  | INT | buflen
 | ) | [inline, virtual]

Reads data from the socket.

Returns:
Number of bytes read or -1 on failure.

Reimplemented from InetSocket.

INT TcpSocket::Write | ( | const void * | buf,
 |  | INT | buflen
 | ) | [inline, virtual]

Writes data to the socket.

Returns:
Number of bytes written or -1 on failure.

Reimplemented from InetSocket.

The documentation for this class was generated from the following files:
  • Socket/TcpSocket.hpp
  • Socket/TcpSocket.cpp
Generated on Wed Jan 25 02:09:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TcpSocketBase Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TcpSocketBase Class Reference
[Socket]

#include <Apoxi/Socket/TcpSocketBase.hpp>

Inheritance diagram for TcpSocketBase:

[legend]
Collaboration diagram for TcpSocketBase:

[legend]

Public Member Functions

BOOLEAN | GetTcpMaxSetOption (BOOLEAN &nodelay)
BOOLEAN | GetTcpNoDelayOption (BOOLEAN &nodelay)
BOOLEAN | SetTcpMaxSetOption (BOOLEAN nodelay)
BOOLEAN | SetTcpNoDelayOption (BOOLEAN nodelay)

Protected Member Functions

BOOLEAN | Open (const InetSocketAddr *local_addr, BOOLEAN may_reuse_addr)

Detailed Description

InetSocket is an abstract base class for internet sockets.

Member Function Documentation

BOOLEAN TcpSocketBase::GetTcpMaxSetOption ( BOOLEAN & nodelay ) [inline]

BOOLEAN TcpSocketBase::GetTcpNoDelayOption ( BOOLEAN & nodelay ) [inline]

BOOLEAN TcpSocketBase::Open | ( | const InetSocketAddr * | local_addr,
 |  | BOOLEAN | may_reuse_addr
 | ) | [inline, protected]

Reimplemented in TcpSocket.

BOOLEAN TcpSocketBase::SetTcpMaxSetOption ( BOOLEAN nodelay ) [inline]

BOOLEAN TcpSocketBase::SetTcpNoDelayOption ( BOOLEAN nodelay ) [inline]

The documentation for this class was generated from the following file:
  • Socket/TcpSocketBase.hpp
Generated on Wed Jan 25 02:09:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TcpTestSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TcpTestSocket Class Reference

#include <Applications/SocketTest/TcpTestSocket.hpp>

Inheritance diagram for TcpTestSocket:

[legend]
Collaboration diagram for TcpTestSocket:

[legend]

Public Types

enum | _constants { m_nHeaderSize = 32 }

Public Member Functions

void | CollectPackets (INT testid, INT nr_of_packets, INT messageSize)
instructs socket to wait for n packets and send a signal when all received
UINT32 | GetReceivedPackets ()
returns number of received packets
TcpTestSocket (BOOLEAN send_continue_msg=TRUE)
virtual | ~TcpTestSocket ()

Protected Member Functions

virtual void | OnAsyncEvent (Event event)

Protected Attributes

CHAR * | m_nMessageBody
INT | m_nMessagePos
INT | m_nMessageSize
BOOLEAN * | m_nPacketsCollected
Array with info about collected packets.
UINT32 | m_nPacketsReceived
Number of received packets.
INT | m_nTestID
UINT32 | m_nWaitingForPackets
Number of packets socket waits for.
const BOOLEAN | m_send_continue_msg

Detailed Description

TcpTestSocket class is implementation of TCP socket used for testing.

Member Enumeration Documentation

enum TcpTestSocket::_constants

Enumerator:
m_nHeaderSize

Constructor & Destructor Documentation

TcpTestSocket::TcpTestSocket ( BOOLEAN send_continue_msg = TRUE )

TcpTestSocket::~TcpTestSocket ( ) [virtual]

Member Function Documentation

void TcpTestSocket::CollectPackets | ( | INT | testid,
 |  | INT | nr_of_packets,
 |  | INT | messageSize
 | ) |

instructs socket to wait for n packets and send a signal when all received

Start collection of TCP test packets. Allocates and initializes all structures.

UINT32 TcpTestSocket::GetReceivedPackets ( ) [inline]

returns number of received packets

void TcpTestSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Triggered by one of following events on TCP socket:

c_event_data_received - when data is received in TCP protocol, read this data and if this is test packet mark it as received and continue with receiving other packets. If this was last packet that should be received in this test, send a message to application.

c_event_data_sent - when packet was sent, send a message to application

Reimplemented from InetSocket.

Field Documentation

CHAR* TcpTestSocket::m_nMessageBody [protected]

INT TcpTestSocket::m_nMessagePos [protected]

INT TcpTestSocket::m_nMessageSize [protected]

BOOLEAN* TcpTestSocket::m_nPacketsCollected [protected]

Array with info about collected packets.

UINT32 TcpTestSocket::m_nPacketsReceived [protected]

Number of received packets.

INT TcpTestSocket::m_nTestID [protected]

UINT32 TcpTestSocket::m_nWaitingForPackets [protected]

Number of packets socket waits for.

const BOOLEAN TcpTestSocket::m_send_continue_msg [protected]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/TcpTestSocket.hpp
  • Applications/SocketTest/TcpTestSocket.cpp
Generated on Wed Jan 25 02:09:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TelecaVrEngineParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TelecaVrEngineParams Class Reference

#include <Apoxi/AddOns/VoiceRecognition/TelecaVrEngineParams.hpp>

Inheritance diagram for TelecaVrEngineParams:

[legend]
Collaboration diagram for TelecaVrEngineParams:

[legend]

Public Member Functions

virtual void * | GetNativeParams ()
virtual BOOLEAN | SetMaxRecognitionTime (UINT16 time)
Set the maximum duration for recognition (in ms).
virtual BOOLEAN | SetMaxSilenceTime (UINT16 time)
Set max. time of silence after which recognition is ends (in ms).
virtual BOOLEAN | SetRecognitionMode (VrHandler::VrRecognitionMode mode)
Set Recognition mode.
TelecaVrEngineParams ()
construct

Constructor & Destructor Documentation

TelecaVrEngineParams::TelecaVrEngineParams ( )

construct

spectral subtraction for more noise robustness, 0 = off, 1 = on

Number of enabled frequency bands

minimum noise level

minimum noise scale

default value maximum silence in number of states; training will take that long if no speech can be detected during training

maximum size of resulting reference in number of states

window size for training in number of states; maximum training duration is less than (time until first speech segment detected + WindowSize)

compression value for the final reference

time window for complete recognition

time after last recognized digit that may pass before end or recogniton

pointer to an external syntax, NULL if one of the two predefined shall be used

Recognition mode: 0 = isolated word, 1 = connected word; only applies if Syntax_p was set to NULL

sets internal pruning strength

penalty for word references

penalty for garbage references

Penalty affects internal search algorithm

Penalty affects internal search algorithm

Penalty affects internal search algorithm

spectral subtraction for more noise robustness, 0 = off, 1 = on

Number of enabled frequency bands

minimum noise level

minimum noise scale

Member Function Documentation

virtual void* TelecaVrEngineParams::GetNativeParams ( ) [inline, virtual]

Implements VrEngineParams.

BOOLEAN TelecaVrEngineParams::SetMaxRecognitionTime ( UINT16 time ) [virtual]

Set the maximum duration for recognition (in ms).

Implements VrEngineParams.

BOOLEAN TelecaVrEngineParams::SetMaxSilenceTime ( UINT16 time ) [virtual]

Set max. time of silence after which recognition is ends (in ms).

Implements VrEngineParams.

BOOLEAN TelecaVrEngineParams::SetRecognitionMode ( VrHandler::VrRecognitionMode mode ) [virtual]

Set Recognition mode.

Implements VrEngineParams.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/TelecaVrEngineParams.hpp
  • AddOns/VoiceRecognition/TelecaVrEngineParams.cpp
Generated on Wed Jan 25 02:09:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TermRspCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TermRspCnfArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for TermRspCnfArg:

[legend]
Collaboration diagram for TermRspCnfArg:

[legend]

Public Types

enum | { ID = 1321 }

Public Member Functions

const Toc & | GetFinishedCommand () const
const SimStatusCondition & | GetLastStatus () const
const ProactiveCause & | GetProactiveCause () const
void | SetFinishedCommand (const Toc &finished_command)
void | SetLastStatus (const SimStatusCondition &last_status)
void | SetProactiveCause (const ProactiveCause &proactive_cause)
TermRspCnfArg ()

Static Public Member Functions

static const TermRspCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

TermRspCnfArg: reflects arguments of signal SI_TERM_RSP_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

TermRspCnfArg::TermRspCnfArg ( )

Member Function Documentation

const TermRspCnfArg & TermRspCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const Toc& TermRspCnfArg::GetFinishedCommand ( ) const [inline]

const SimStatusCondition& TermRspCnfArg::GetLastStatus ( ) const [inline]

const ProactiveCause& TermRspCnfArg::GetProactiveCause ( ) const [inline]

void TermRspCnfArg::SetFinishedCommand ( const Toc & finished_command ) [inline]

void TermRspCnfArg::SetLastStatus ( const SimStatusCondition & last_status ) [inline]

void TermRspCnfArg::SetProactiveCause ( const ProactiveCause & proactive_cause ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 02:10:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TermRspCnfMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TermRspCnfMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for TermRspCnfMsg:

[legend]
Collaboration diagram for TermRspCnfMsg:

[legend]

Public Types

enum | { ID = 18326 }

Public Member Functions

virtual Message * | Clone () const
const TermRspCnfArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const TermRspCnfArg &arg)
TermRspCnfMsg (ExecutionContext *context, const TermRspCnfArg &arg)
virtual | ~TermRspCnfMsg ()

Detailed Description

SimTkSetupEventMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

TermRspCnfMsg::TermRspCnfMsg | ( | ExecutionContext * | context,
 |  | const TermRspCnfArg & | arg
 | ) |

TermRspCnfMsg::~TermRspCnfMsg ( ) [virtual]

Member Function Documentation

Message * TermRspCnfMsg::Clone ( ) const [virtual]

Implements Message.

const TermRspCnfArg& TermRspCnfMsg::GetArg ( ) const [inline]

const MsgMetaData & TermRspCnfMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void TermRspCnfMsg::SetArg ( const TermRspCnfArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:10:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestCheckBoxListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestCheckBoxListView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestCheckBoxListView.hpp>

Inheritance diagram for TestCheckBoxListView:

[legend]
Collaboration diagram for TestCheckBoxListView:

[legend]

Public Member Functions

TestCheckBoxListView (CheckBoxView *cb_view, XYDIM item_height)
virtual | ~TestCheckBoxListView ()

Protected Member Functions

virtual void | DrawCheckBoxItem (const CheckBoxItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const

Constructor & Destructor Documentation

TestCheckBoxListView::TestCheckBoxListView | ( | CheckBoxView * | cb_view,
 |  | XYDIM | item_height
 | ) |

virtual TestCheckBoxListView::~TestCheckBoxListView ( ) [inline, virtual]

Member Function Documentation

void TestCheckBoxListView::DrawCheckBoxItem | ( | const CheckBoxItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

Implements CheckBoxListView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestCheckBoxListView.hpp
  • Compat/GlobalThemes/TestTheme/TestCheckBoxListView.cpp
Generated on Wed Jan 25 02:10:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestCheckBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestCheckBoxView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestCheckBoxView.hpp>

Inheritance diagram for TestCheckBoxView:

[legend]
Collaboration diagram for TestCheckBoxView:

[legend]

Public Types

typedef CheckBoxView | Base

Public Member Functions

TestCheckBoxView (XYDIM item_height, XYDIM left_gap, XYDIM middle_gap)
virtual | ~TestCheckBoxView ()

Protected Member Functions

virtual void | DrawCheckBox (const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShiftedCheckBox (const Rect &shift_rect, const CheckBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Member Typedef Documentation

typedef CheckBoxView TestCheckBoxView::Base

Reimplemented from CheckBoxView.

Constructor & Destructor Documentation

TestCheckBoxView::TestCheckBoxView | ( | XYDIM | item_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

virtual TestCheckBoxView::~TestCheckBoxView ( ) [inline, virtual]

Member Function Documentation

void TestCheckBoxView::DrawCheckBox | ( | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements CheckBoxView.

void TestCheckBoxView::DrawShiftedCheckBox | ( | const Rect & | shift_rect,
 |  | const CheckBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements CheckBoxView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestCheckBoxView.hpp
  • Compat/GlobalThemes/TestTheme/TestCheckBoxView.cpp
Generated on Wed Jan 25 02:10:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestControlFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestControlFrameView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestControlFrameView.hpp>

Inheritance diagram for TestControlFrameView:

[legend]
Collaboration diagram for TestControlFrameView:

[legend]

Public Member Functions

TestControlFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size)
virtual | ~TestControlFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

TestControlFrameView::TestControlFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size
 | ) |

TestControlFrameView::~TestControlFrameView ( ) [virtual]

Member Function Documentation

void TestControlFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestControlFrameView.hpp
  • Compat/GlobalThemes/TestTheme/TestControlFrameView.cpp
Generated on Wed Jan 25 02:10:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestparamReport Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestparamReport Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for TestparamReport:

[legend]

Public Types

enum TestParamReportComponent {
CsParam, PsParam, CoordParam, RrParam,
Gprs, ServingCell, NeighbourCells, Rat,
EqUplmList, CellChangeCnts, RrMode, RrcParam,
UmtsNeighbourCells
}

Public Member Functions

BOOLEAN | IsComponentSupported (TestParamReportComponent comp) const

Data Fields

CellChangeCnts cell_change_cnts
MmCoordParam coord_param
MmcsParam cs_param
EquivPlmnLists eq_plmn_list
GprsParam gprs
NeighbourCellList neighbour_cells
NetworkOpMode nom
GmmParam ps_param
UINT8 | rat
RrMode rr_mode
RrParam rr_param
RrcParam rrc_param
CellParam serving_cell
UmtsNcellParamList umts_ncell_param

Member Enumeration Documentation

enum TestparamReport::TestParamReportComponent

Enumerator:
CsParam
PsParam
CoordParam
RrParam
Gprs
ServingCell
NeighbourCells
Rat
EqUplmList
CellChangeCnts
RrMode
RrcParam
UmtsNeighbourCells

Member Function Documentation

BOOLEAN TestparamReport::IsComponentSupported ( TestParamReportComponent comp ) const [inline]

Field Documentation

CellChangeCnts TestparamReport::cell_change_cnts

MmCoordParam TestparamReport::coord_param

MmcsParam TestparamReport::cs_param

EquivPlmnLists TestparamReport::eq_plmn_list

GprsParam TestparamReport::gprs

NeighbourCellList TestparamReport::neighbour_cells

NetworkOpMode TestparamReport::nom

GmmParam TestparamReport::ps_param

UINT8 TestparamReport::rat

RrMode TestparamReport::rr_mode

RrParam TestparamReport::rr_param

RrcParam TestparamReport::rrc_param

CellParam TestparamReport::serving_cell

UmtsNcellParamList TestparamReport::umts_ncell_param

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 02:10:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestparamReportArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestparamReportArg Class Reference

#include <Apoxi/Apc/NetworkStackMsgArgs.hpp>

Inheritance diagram for TestparamReportArg:

[legend]
Collaboration diagram for TestparamReportArg:

[legend]

Public Types

enum | { ID = 2183 }

Public Member Functions

const TestparamReport & | GetReport () const
void | SetReport (const TestparamReport &report)
TestparamReportArg ()

Static Public Member Functions

static const TestparamReportArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

TestparamReportArg: reflects arguments of signal MN_TESTPARAM_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

TestparamReportArg::TestparamReportArg ( )

Member Function Documentation

const TestparamReportArg & TestparamReportArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const TestparamReport& TestparamReportArg::GetReport ( ) const [inline]

void TestparamReportArg::SetReport ( const TestparamReport & report ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/NetworkStackMsgArgs.hpp
  • Apc/NetworkStackMsgArgs.cpp
Generated on Wed Jan 25 02:10:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestparamReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestparamReqArg Class Reference

#include <Apoxi/Apc/MiscStackMsgArgs.hpp>

Inheritance diagram for TestparamReqArg:

[legend]
Collaboration diagram for TestparamReqArg:

[legend]

Public Types

enum | { ID = 2104 }

Public Member Functions

BOOLEAN | IsTest () const
void | SetTest (BOOLEAN test)
TestparamReqArg (BOOLEAN test=FALSE)

Static Public Member Functions

static const TestparamReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

TestparamReqArg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

TestparamReqArg::TestparamReqArg ( BOOLEAN test = FALSE )

Member Function Documentation

const TestparamReqArg & TestparamReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

BOOLEAN TestparamReqArg::IsTest ( ) const [inline]

void TestparamReqArg::SetTest ( BOOLEAN test ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/MiscStackMsgArgs.hpp
  • Apc/MiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:10:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestPositionIndicatorView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestPositionIndicatorView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.hpp>

Inheritance diagram for TestPositionIndicatorView:

[legend]
Collaboration diagram for TestPositionIndicatorView:

[legend]

Public Member Functions

TestPositionIndicatorView (XYDIM size)
virtual | ~TestPositionIndicatorView ()

Protected Member Functions

virtual void | DrawPositionIndicator (const PositionIndicator &pos_ind, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

TestPositionIndicatorView::TestPositionIndicatorView ( XYDIM size )

virtual TestPositionIndicatorView::~TestPositionIndicatorView ( ) [inline, virtual]

Member Function Documentation

void TestPositionIndicatorView::DrawPositionIndicator | ( | const PositionIndicator & | pos_ind,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a position indicator described by the model. Must be implemented in the corresponding theme view.

Parameters:
pos_ind | Position-Indicator which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements PositionIndicatorView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.hpp
  • Compat/GlobalThemes/TestTheme/TestPositionIndicatorView.cpp
Generated on Wed Jan 25 02:10:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestPushButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestPushButtonView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestPushButtonView.hpp>

Inheritance diagram for TestPushButtonView:

[legend]
Collaboration diagram for TestPushButtonView:

[legend]

Public Member Functions

TestPushButtonView (XYDIM default_height)
virtual | ~TestPushButtonView ()

Protected Member Functions

virtual void | DrawPushButton (const PushButton &push_button, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

TestPushButtonView::TestPushButtonView ( XYDIM default_height )

virtual TestPushButtonView::~TestPushButtonView ( ) [inline, virtual]

Member Function Documentation

void TestPushButtonView::DrawPushButton | ( | const PushButton & | push_button,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements PushButtonView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestPushButtonView.hpp
  • Compat/GlobalThemes/TestTheme/TestPushButtonView.cpp
Generated on Wed Jan 25 02:10:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestRadioButtonListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestRadioButtonListView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestRadioButtonListView.hpp>

Inheritance diagram for TestRadioButtonListView:

[legend]
Collaboration diagram for TestRadioButtonListView:

[legend]

Public Member Functions

TestRadioButtonListView (RadioButtonView *rb_view, XYDIM item_height)
virtual | ~TestRadioButtonListView ()

Protected Member Functions

virtual void | DrawRadioButtonItem (const RadioButtonItem &item, DeviceContext *dc, const Rect &item_rect, BOOLEAN highlighted) const

Constructor & Destructor Documentation

TestRadioButtonListView::TestRadioButtonListView | ( | RadioButtonView * | rb_view,
 |  | XYDIM | item_height
 | ) |

virtual TestRadioButtonListView::~TestRadioButtonListView ( ) [inline, virtual]

Member Function Documentation

void TestRadioButtonListView::DrawRadioButtonItem | ( | const RadioButtonItem & | item,
 |  | DeviceContext * | dc,
 |  | const Rect & | item_rect,
 |  | BOOLEAN | highlighted
 | ) | const [protected, virtual]

Implements RadioButtonListView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestRadioButtonListView.hpp
  • Compat/GlobalThemes/TestTheme/TestRadioButtonListView.cpp
Generated on Wed Jan 25 02:10:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestRadioButtonView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestRadioButtonView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestRadioButtonView.hpp>

Inheritance diagram for TestRadioButtonView:

[legend]
Collaboration diagram for TestRadioButtonView:

[legend]

Public Types

typedef RadioButtonView | Base

Public Member Functions

TestRadioButtonView (XYDIM item_height, XYDIM left_gap, XYDIM middle_gap)
virtual | ~TestRadioButtonView ()

Protected Member Functions

virtual void | DrawRadioButton (const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawShiftedRadioButton (const Rect &shift_rect, const RadioButtonModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Member Typedef Documentation

typedef RadioButtonView TestRadioButtonView::Base

Reimplemented from RadioButtonView.

Constructor & Destructor Documentation

TestRadioButtonView::TestRadioButtonView | ( | XYDIM | item_height,
 |  | XYDIM | left_gap,
 |  | XYDIM | middle_gap
 | ) |

virtual TestRadioButtonView::~TestRadioButtonView ( ) [inline, virtual]

Member Function Documentation

void TestRadioButtonView::DrawRadioButton | ( | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements RadioButtonView.

void TestRadioButtonView::DrawShiftedRadioButton | ( | const Rect & | shift_rect,
 |  | const RadioButtonModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Implements RadioButtonView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestRadioButtonView.hpp
  • Compat/GlobalThemes/TestTheme/TestRadioButtonView.cpp
Generated on Wed Jan 25 02:10:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestSoftkeyBarView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestSoftkeyBarView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.hpp>

Inheritance diagram for TestSoftkeyBarView:

[legend]
Collaboration diagram for TestSoftkeyBarView:

[legend]

Public Types

typedef SoftkeyBarView | Base

Public Member Functions

virtual | ~TestSoftkeyBarView ()

Protected Member Functions

virtual void | DrawSoftkeyBar (const SoftkeyBar &softkey_bar, DeviceContext *dc, const Rect &repaint_rect) const

Member Typedef Documentation

typedef SoftkeyBarView TestSoftkeyBarView::Base

Reimplemented from DrawableObjectView.

Constructor & Destructor Documentation

virtual TestSoftkeyBarView::~TestSoftkeyBarView ( ) [inline, virtual]

Member Function Documentation

void TestSoftkeyBarView::DrawSoftkeyBar | ( | const SoftkeyBar & | softkey_bar,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the Softkey-Bar. Must be implemented in the corresponding theme view.

Parameters:
softkey_bar | Softkey-Bar which should be drawn.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements SoftkeyBarView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.hpp
  • Compat/GlobalThemes/TestTheme/TestSoftkeyBarView.cpp
Generated on Wed Jan 25 02:10:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestTheme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestTheme Class Reference

Obsolete theme - replaced by themes in Apoxi/GlobalThemes. More...

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestTheme.hpp>

Inheritance diagram for TestTheme:

[legend]
Collaboration diagram for TestTheme:

[legend]

Public Member Functions

virtual const CheckBoxListView * | GetCheckBoxListView () const
virtual const CheckBoxView * | GetCheckBoxView () const
virtual const ControlFrameView * | GetControlFrameView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const
virtual const ProgressBarView * | GetProgressBarView () const
virtual const PushButtonView * | GetPushButtonView () const
virtual const RadioButtonListView * | GetRadioButtonListView () const
virtual const RadioButtonView * | GetRadioButtonView () const
virtual const SoftkeyBarView * | GetSoftkeyBarView () const
virtual const SystemColor | GetSystemColor (SystemColorId id) const
virtual const FontId | GetSystemFontId (SystemFontId id) const
virtual const TextListView * | GetTextListView () const
virtual const WindowFrameView * | GetWindowFrameView () const
TestTheme ()
virtual | ~TestTheme ()

Detailed Description

Obsolete theme - replaced by themes in Apoxi/GlobalThemes.

Constructor & Destructor Documentation

TestTheme::TestTheme ( )

TestTheme::~TestTheme ( ) [virtual]

Member Function Documentation

const CheckBoxListView * TestTheme::GetCheckBoxListView ( ) const [virtual]

const CheckBoxView * TestTheme::GetCheckBoxView ( ) const [virtual]

const ControlFrameView * TestTheme::GetControlFrameView ( ) const [virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implements Theme.

const PositionIndicatorView * TestTheme::GetPositionIndicatorView ( ) const [virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implements Theme.

const ProgressBarView * TestTheme::GetProgressBarView ( ) const [virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implements Theme.

const PushButtonView * TestTheme::GetPushButtonView ( ) const [virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implements Theme.

const RadioButtonListView * TestTheme::GetRadioButtonListView ( ) const [virtual]

const RadioButtonView * TestTheme::GetRadioButtonView ( ) const [virtual]

const SoftkeyBarView * TestTheme::GetSoftkeyBarView ( ) const [virtual]

const SystemColor TestTheme::GetSystemColor ( SystemColorId id ) const [virtual]

Returns a color-value of the system-color with the id id specified by the system-color-table. This method must not be overwritten by derived themes, when GetSystemColorTable has been overwritten. To stay backward-compatible with older versions of APOXI, 0 is returned if no system-color-table is provided.

Reimplemented from Theme.

const FontId TestTheme::GetSystemFontId ( SystemFontId id ) const [virtual]

const TextListView * TestTheme::GetTextListView ( ) const [virtual]

const WindowFrameView * TestTheme::GetWindowFrameView ( ) const [virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implements Theme.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestTheme.hpp
  • Compat/GlobalThemes/TestTheme/TestTheme.cpp
Generated on Wed Jan 25 02:10:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestWindowFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestWindowFrameView Class Reference

#include <Apoxi/Compat/GlobalThemes/TestTheme/TestWindowFrameView.hpp>

Inheritance diagram for TestWindowFrameView:

[legend]
Collaboration diagram for TestWindowFrameView:

[legend]

Public Member Functions

TestWindowFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size, XYDIM title_height, XYDIM softkey_bar_height)
virtual | ~TestWindowFrameView ()

Protected Member Functions

virtual void | DrawControlFrame (const Control &control, DeviceContext *dc, const Rect &repaint_rect) const
virtual void | DrawWindowExtensions (const Window &window, DeviceContext *dc, const Rect &repaint_rect) const

Constructor & Destructor Documentation

TestWindowFrameView::TestWindowFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size,
 |  | XYDIM | title_height,
 |  | XYDIM | softkey_bar_height
 | ) |

TestWindowFrameView::~TestWindowFrameView ( ) [virtual]

Member Function Documentation

void TestWindowFrameView::DrawControlFrame | ( | const Control & | control,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a frame described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a frame.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

Implements ControlFrameView.

void TestWindowFrameView::DrawWindowExtensions | ( | const Window & | window,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

See also:
ControlFrameView::DrawWindowExenstions

Implements WindowFrameView.

The documentation for this class was generated from the following files:
  • Compat/GlobalThemes/TestTheme/TestWindowFrameView.hpp
  • Compat/GlobalThemes/TestTheme/TestWindowFrameView.cpp
Generated on Wed Jan 25 02:10:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TestWriter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TestWriter Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/TestWriter.hpp>

Public Types

enum {
WINDOW_OPENED_MSG = 11, WINDOW_CLOSED_MSG = 12, MENU_OPENED_MSG = 13, MENU_CLOSED_MSG = 14,
MENU_ACTIVATED_MSG = 15, MENU_CHANGED_MSG = 16, SOFTKEY_SHOW_MSG = 17, SOFTKEY_PRESSED_MSG = 18,
PIC_OUTPUT_MSG = 19, TEXT_OUTPUT_MSG = 20, MESSAGE_SENT_MSG = 21, MESSAGE_RECEIVED_MSG = 22,
ACTION_EXECUTED_MSG = 23, VARIABLE_CHANGED_MSG = 24, APP_LOAD_MSG = 25, APP_EXIT_MSG = 26,
METHOD_CALLED_MSG = 27, KEY_RECEIVED_MSG = 28, ANIM_OUTPUT_MSG = 29, ITEM_SELECTED_MSG = 30,
ITEM_COUNT_MSG = 31, RADIO_SELECTED_MSG = 32, RADIO_ACTIVE_MSG = 33, CHECKBOX_ACTIVE_MSG = 34,
CHECKBOX_SELECTED_MSG = 35, ACTION_DISABLED_MSG = 36
}

Static Public Member Functions

static void | WriteCoverageBuffer ()
static void | WriteState (UINT16 eventId, const WCHAR *value=L"",...)
static void | WriteState (UINT16 eventId, const CHAR *value="",...)

Static Public Attributes

static CHAR | array []

Detailed Description

TestWriter class is used to output state information used by APOXI Tester. The method-calls are delegated to the class Tracer, which performs the actual output. Methods of TestWriter should never be called directly. Use the macro WRITE_STATE instead.

Member Enumeration Documentation

anonymous enum

Enumeration containing all defined types of states. If additional states shall be used, this enumeration has to be extended.

Enumerator:
WINDOW_OPENED_MSG
WINDOW_CLOSED_MSG
MENU_OPENED_MSG
MENU_CLOSED_MSG
MENU_ACTIVATED_MSG
MENU_CHANGED_MSG
SOFTKEY_SHOW_MSG
SOFTKEY_PRESSED_MSG
PIC_OUTPUT_MSG
TEXT_OUTPUT_MSG
MESSAGE_SENT_MSG
MESSAGE_RECEIVED_MSG
ACTION_EXECUTED_MSG
VARIABLE_CHANGED_MSG
APP_LOAD_MSG
APP_EXIT_MSG
METHOD_CALLED_MSG
KEY_RECEIVED_MSG
ANIM_OUTPUT_MSG
ITEM_SELECTED_MSG
ITEM_COUNT_MSG
RADIO_SELECTED_MSG
RADIO_ACTIVE_MSG
CHECKBOX_ACTIVE_MSG
CHECKBOX_SELECTED_MSG
ACTION_DISABLED_MSG

Member Function Documentation

void TestWriter::WriteCoverageBuffer ( ) [static]

void TestWriter::WriteState | ( | UINT16 | eventId,
 |  | const WCHAR * | value = L"",
 |  |  | ...
 | ) | [static]

The second WriteState method only differs in the datatype of the second parameter. Whereas the first method is used with CHAR* strings, this method takes a WCHAR* string as value.

void TestWriter::WriteState | ( | UINT16 | eventId,
 |  | const CHAR * | value = "",
 |  |  | ...
 | ) | [static]

WriteState writes a state to the default output media. The output media depends on the used platform and is predefined in the class Tracer

Parameters:
eventId | Specifies the kind of state to output. The value of eventId must be one of the values defined in the enumeration below.
value | A string representing the value of the state. Additionally, you can add a variable number of parameters to be include into the value string (same behaviour as printf). If this parameter is left blank, an empty string is used.

Field Documentation

CHAR TestWriter::array [static]

The documentation for this class was generated from the following files:
  • Kernel/Os/TestWriter.hpp
  • Kernel/Os/TestWriter.cpp
Generated on Wed Jan 25 02:10:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextBox Class Reference
[Components]

#include <Apoxi/Gui/TextBox.hpp>

Inheritance diagram for TextBox:

[legend]
Collaboration diagram for TextBox:

[legend]

Public Types

enum | { ID = 24 }

Public Member Functions

void | Init (Control *control, const WCHAR *text=0, const TextFormat &text_format=TextFormat(), BOOLEAN vertical_centered=FALSE)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsVerticalCentered () const
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetVerticalCentered (BOOLEAN vertical_centered)
TextBox (Control *control, const WCHAR *text=0, const TextFormat &text_format=TextFormat(), BOOLEAN vertical_centered=FALSE)
TextBox ()
virtual | ~TextBox ()

Detailed Description

Represents a drawable object containing a text which is automatically wrapped on whitespaces to fit into the given boundaries of the drawable object. The text may have its own textformat and color.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractTextObject.

Constructor & Destructor Documentation

TextBox::TextBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TextBox::TextBox | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const TextFormat & | text_format = TextFormat(),
 |  | BOOLEAN | vertical_centered = FALSE
 | ) |

Parameters:
control | Pointer to parent control, which includes the text box as child.
text | Text content.
text_format | Format of the text content.
vertical_centered | If set to TRUE, the text will be vertically centered. If FALSE is used, the text is aligned on the top border of the text box.

TextBox::~TextBox ( ) [virtual]

Member Function Documentation

void TextBox::Init | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const TextFormat & | text_format = TextFormat(),
 |  | BOOLEAN | vertical_centered = FALSE
 | ) |

Parameters:
control | Pointer to parent control, which includes the text box as child.
text | Text content.
text_format | Format of the text content.
vertical_centered | If set to TRUE, the text will be vertically centered. If FALSE is used, the text is aligned on the top border of the text box.

BOOLEAN TextBox::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractTextObject.

BOOLEAN TextBox::IsVerticalCentered ( ) const [inline]

Returns TRUE, if the text will be vertically centered. Per default FALSE is returned, which means that the text is aligned on the top border of the text box.

BOOLEAN TextBox::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractTextObject.

void TextBox::SetVerticalCentered ( BOOLEAN vertical_centered )

If set to TRUE, the text will be vertically centered. If FALSE is used, the text is aligned on the top border of the text box.

The documentation for this class was generated from the following files:
  • Gui/TextBox.hpp
  • Gui/TextBox.cpp
Generated on Wed Jan 25 02:10:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextBoxView Class Reference
[Components]

#include <Apoxi/Gui/TextBox.hpp>

Inheritance diagram for TextBoxView:

[legend]
Collaboration diagram for TextBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
virtual | ~TextBoxView ()

Detailed Description

Displays the content of a text box.

Constructor & Destructor Documentation

TextBoxView::~TextBoxView ( ) [virtual]

Member Function Documentation

void TextBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

The documentation for this class was generated from the following files:
  • Gui/TextBox.hpp
  • Gui/TextBox.cpp
Generated on Wed Jan 25 02:10:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextCompoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextCompoundItem Class Reference
[Editors]

Contains a variable number of wide-characters. More...

#include <Apoxi/Gui/TextCompoundItem.hpp>

Inheritance diagram for TextCompoundItem:

[legend]
Collaboration diagram for TextCompoundItem:

[legend]

Public Types

enum | { ID = 6 }

Public Member Functions

virtual void | Clear ()
virtual CompoundItem * | Clone () const
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
WCHAR * | ExportInternalBuffer (UINT length)
const Font & | GetFont () const
virtual INT | GetId () const
virtual INT | GetItemCount () const
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT index, INT count) const
const WString & | GetText () const
virtual TextAttr | GetTextAttr () const
void | Insert (INT index, WCHAR ch)
Wrapper-method for InsertItem using a character.
virtual BOOLEAN | InsertItem (const AtomItem &item, INT index=-1)
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual BOOLEAN | IsStandaloneCharacter (INT index) const
virtual BOOLEAN | Merge (const CompoundItem &compound_item)
void | Remove (INT index, INT count=-1)
Wrapper-method for ReplaceItem.
virtual BOOLEAN | RemoveItem (INT index=-1)
void | Replace (INT index, WCHAR ch)
Wrapper-method for ReplaceItem using a character.
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT index=-1)
void | SetFont (const Font &font)
void | SetText (const WCHAR *text)
Sets the text for the TextCompoundItem. The text is buffered internally.
virtual BOOLEAN | Split (INT index, CompoundItem **compound_item)
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=EditorDocument::WhitespaceWrap) const
virtual | ~TextCompoundItem ()

Static Public Member Functions

static TextCompoundItem * | CreateInstance (const WCHAR *text, const Font &font)
Creates and returns an object of this class.
static TextCompoundItem * | CreateInstance (const WCHAR *text=0)
Creates and returns an object of this class.

Protected Member Functions

void | SetDefaultColorHint (BOOLEAN use_default_color)
TextCompoundItem (const WCHAR *text, const Font &font)
TextCompoundItem (const WCHAR *text=0)

Detailed Description

Contains a variable number of wide-characters.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from CompoundItem.

Constructor & Destructor Documentation

TextCompoundItem::~TextCompoundItem ( ) [virtual]

TextCompoundItem::TextCompoundItem ( const WCHAR * text = 0 ) [protected]

TextCompoundItem::TextCompoundItem | ( | const WCHAR * | text,
 |  | const Font & | font
 | ) | [protected]

Member Function Documentation

void TextCompoundItem::Clear ( ) [virtual]

See also:
CompoundItem::Clear

Reimplemented from CompoundItem.

CompoundItem * TextCompoundItem::Clone ( ) const [virtual]

See also:
CompoundItem::Clone

Reimplemented from CompoundItem.

Reimplemented in RichTextCompoundItem.

TextCompoundItem * TextCompoundItem::CreateInstance | ( | const WCHAR * | text,
 |  | const Font & | font
 | ) | [static]

Creates and returns an object of this class.

TextCompoundItem * TextCompoundItem::CreateInstance ( const WCHAR * text = 0 ) [static]

Creates and returns an object of this class.

void TextCompoundItem::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::Draw

Implements CompoundItem.

Reimplemented in RichTextCompoundItem.

WCHAR * TextCompoundItem::ExportInternalBuffer ( UINT length )

Allocates an internal buffer with the given length and returns a pointer to this buffer. Note that the pointer is invalid after invoking SetText, Insert, Replace or Remove. Having access directly to the buffer might be useful when using e. g. third-party predictive input-methods, which need a pointer to a buffer and manipulate this buffer itself.

const Font& TextCompoundItem::GetFont ( ) const [inline]

INT TextCompoundItem::GetId ( ) const [virtual]

See also:
CompoundItem::GetId()

Reimplemented from CompoundItem.

Reimplemented in RichTextCompoundItem.

INT TextCompoundItem::GetItemCount ( ) const [virtual]

See also:
CompoundItem::GetItemCount

Implements CompoundItem.

XYDIM TextCompoundItem::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
CompoundItem::GetLineHeight

Implements CompoundItem.

XYDIM TextCompoundItem::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::GetLineWidth

Implements CompoundItem.

const WString& TextCompoundItem::GetText ( ) const [inline]

TextAttr TextCompoundItem::GetTextAttr ( ) const [virtual]

Reimplemented in RichTextCompoundItem.

void TextCompoundItem::Insert | ( | INT | index,
 |  | WCHAR | ch
 | ) | [inline]

Wrapper-method for InsertItem using a character.

BOOLEAN TextCompoundItem::InsertItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
CompoundItem::InsertItem

Reimplemented from CompoundItem.

BOOLEAN TextCompoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from CompoundItem.

Reimplemented in RichTextCompoundItem.

BOOLEAN TextCompoundItem::IsStandaloneCharacter ( INT index ) const [virtual]

Tests if a character is rendered standalone in the text, or whether it is a diacritic that modifies preceding or following characters.

Parameters:
index the index of the character to be tested
Returns:
TRUE if the character is can rendered standalone, FALSE otherwise

BOOLEAN TextCompoundItem::Merge ( const CompoundItem & compound_item ) [virtual]

See also:
CompoundItem::Merge

Reimplemented from CompoundItem.

Reimplemented in RichTextCompoundItem.

void TextCompoundItem::Remove | ( | INT | index,
 |  | INT | count = -1
 | ) | [inline]

Wrapper-method for ReplaceItem.

BOOLEAN TextCompoundItem::RemoveItem ( INT index = -1 ) [virtual]

See also:
CompoundItem::InsertItem

Reimplemented from CompoundItem.

void TextCompoundItem::Replace | ( | INT | index,
 |  | WCHAR | ch
 | ) | [inline]

Wrapper-method for ReplaceItem using a character.

BOOLEAN TextCompoundItem::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | index = -1
 | ) | [virtual]

See also:
CompoundItem::InsertItem

Reimplemented from CompoundItem.

void TextCompoundItem::SetDefaultColorHint ( BOOLEAN use_default_color ) [inline, protected]

Tells the text compound item whether it should use the theme dependant default text color or just use the current set color of the device context. This method can be used by derived classes which use TextCompoundItem::Draw.

void TextCompoundItem::SetFont ( const Font & font ) [inline]

void TextCompoundItem::SetText ( const WCHAR * text ) [inline]

Sets the text for the TextCompoundItem. The text is buffered internally.

BOOLEAN TextCompoundItem::Split | ( | INT | index,
 |  | CompoundItem ** | compound_item
 | ) | [virtual]

See also:
CompoundItem::Split

Reimplemented from CompoundItem.

Reimplemented in RichTextCompoundItem.

INT TextCompoundItem::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = EditorDocument::WhitespaceWrap
 | ) | const [virtual]

See also:
CompoundItem::WrapLine

Implements CompoundItem.

The documentation for this class was generated from the following files:
  • Gui/TextCompoundItem.hpp
  • Gui/TextCompoundItem.cpp
Generated on Wed Jan 25 02:10:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextEditorDocument Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextEditorDocument Class Reference
[Editors]

#include <Apoxi/Gui/TextEditorDocument.hpp>

Inheritance diagram for TextEditorDocument:

[legend]
Collaboration diagram for TextEditorDocument:

[legend]

Public Member Functions

virtual void | Clear ()
virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT item_index, INT count) const
virtual const CompoundItem & | GetCompoundItem (INT ci_index, INT *start_item_index=0) const
const Font & | GetFont () const
Returns the used font for the text rendering.
virtual INT | GetItemCount () const
virtual void | GetItemScope (INT item_index, INT count, INT sub_index, XYDIM *x, XYDIM *width) const
virtual XYDIM | GetLineHeight (INT item_index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT item_index, INT count) const
virtual INT | GetMaxItemCount () const
const WString & | GetText () const
Returns the content of the document.
void | Init (const WCHAR *text=0)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT item_index)
BOOLEAN | IsCrSupported () const
virtual BOOLEAN | IsRightToLeftItem (INT item_index) const
virtual BOOLEAN | RemoveItem (INT item_index)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT item_index)
void | SetCrSupported (BOOLEAN flag)
void | SetFont (const Font &font)
void | SetLineHeight (XYDIM line_height)
void | SetMaxItemCount (INT max_item_count)
Sets the maximum number of allowed characters.
void | SetText (const WCHAR *text)
Sets the content of the document.
TextEditorDocument (const WCHAR *text=0)
virtual INT | WrapLine (INT item_index, XYDIM width, WrapPolicy wrap_policy=WhitespaceWrap) const
virtual | ~TextEditorDocument ()

Detailed Description

A text editor document may contain text of a variable length. A maximum length and a font can be specified too.

Constructor & Destructor Documentation

TextEditorDocument::TextEditorDocument ( const WCHAR * text = 0 )

Content of the document.

TextEditorDocument::~TextEditorDocument ( ) [virtual]

Member Function Documentation

void TextEditorDocument::Clear ( ) [virtual]

See also:
EditorDocument::Clear

Reimplemented from EditorDocument.

void TextEditorDocument::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | item_index,
 |  | INT | count
 | ) | const [virtual]

See also:
EditorDocument::Draw()

Implements EditorDocument.

const CompoundItem & TextEditorDocument::GetCompoundItem | ( | INT | ci_index,
 |  | INT * | start_item_index = 0
 | ) | const [virtual]

See also:
EditorDocument::GetCompoundItem()

Implements EditorDocument.

const Font & TextEditorDocument::GetFont ( ) const

Returns the used font for the text rendering.

INT TextEditorDocument::GetItemCount ( ) const [virtual]

See also:
EditorDocument::GetItemCount()

Implements EditorDocument.

void TextEditorDocument::GetItemScope | ( | INT | item_index,
 |  | INT | count,
 |  | INT | sub_index,
 |  | XYDIM * | x,
 |  | XYDIM * | width
 | ) | const [virtual]

See also:
EditorDocument::GetItemScope()

Reimplemented from EditorDocument.

XYDIM TextEditorDocument::GetLineHeight | ( | INT | item_index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

Returns the height of the line in pixels.

See also:
SetLineHeight

EditorDocument::GetLineHeight

Implements EditorDocument.

XYDIM TextEditorDocument::GetLineWidth | ( | INT | item_index,
 |  | INT | count
 | ) | const [virtual]

See also:
EditorDocument::GetLineWidth()

Implements EditorDocument.

INT TextEditorDocument::GetMaxItemCount ( ) const [virtual]

See also:
EditorDocument::GetMaxItemCount()

Implements EditorDocument.

Reimplemented in IpAddrEditorDocument.

const WString & TextEditorDocument::GetText ( ) const

Returns the content of the document.

void TextEditorDocument::Init ( const WCHAR * text = 0 )

Content of the document.

BOOLEAN TextEditorDocument::InsertItem | ( | const AtomItem & | item,
 |  | INT | item_index
 | ) | [virtual]

See also:
EditorDocument::InsertItem()

Implements EditorDocument.

BOOLEAN TextEditorDocument::IsCrSupported ( ) const [inline]

Returns TRUE if the carriage return support corresponding to the standard GSM 03.38 is supported.

BOOLEAN TextEditorDocument::IsRightToLeftItem ( INT item_index ) const [virtual]

See also:
EditorDocument::IsRightToLeftItem

Reimplemented from EditorDocument.

BOOLEAN TextEditorDocument::RemoveItem ( INT item_index ) [virtual]

See also:
EditorDocument::RemoveItem()

Implements EditorDocument.

BOOLEAN TextEditorDocument::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | item_index
 | ) | [virtual]

See also:
EditorDocument::ReplaceItem()

Implements EditorDocument.

void TextEditorDocument::SetCrSupported ( BOOLEAN flag ) [inline]

To fulfill the standard GSM 03.38 this method must get invoked with the parameter TRUE. In this case a carriage return is supported.

void TextEditorDocument::SetFont ( const Font & font )

Sets the font which should be used for the text rendering. Per default the font defined in the APOXI theme for Font::Editor is used.

void TextEditorDocument::SetLineHeight ( XYDIM line_height ) [inline]

Sets the height of the line in pixels. If a value <= 0 is used, the line-height of the text-compound-item is used, which is set to the height of the font Font::Editor.

void TextEditorDocument::SetMaxItemCount ( INT max_item_count )

Sets the maximum number of allowed characters.

void TextEditorDocument::SetText ( const WCHAR * text )

Sets the content of the document.

INT TextEditorDocument::WrapLine | ( | INT | item_index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = WhitespaceWrap
 | ) | const [virtual]

See also:
EditorDocument::WrapLine()

Implements EditorDocument.

The documentation for this class was generated from the following files:
  • Gui/TextEditorDocument.hpp
  • Gui/TextEditorDocument.cpp
Generated on Wed Jan 25 02:10:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextFormat Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextFormat Class Reference
[GUI]

#include <Apoxi/Gui/TextFormat.hpp>

Collaboration diagram for TextFormat:

[legend]

Public Types

enum | FontAlign { Top, Baseline, Bottom }
Defines the vertical text alignment (Top, Baseline or Bottom). More...
enum | TextAlign { Default, Left, Centered, Right }
typedef UINT8 | TextAttr
enum TextAttrValues {
Normal = 0, Underlined = (1 << 0), Italic = (1 << 1), Bold = (1 << 2),
Strikethrough = (1 << 3)
}

Public Member Functions

const Font & | GetFont () const
FontAlign | GetFontAlign () const
Returns the font alignment (Top, Baseline or Bottom).
TextAlign | GetTextAlign () const
Returns the text alignment (Top, Baseline or Bottom).
TextAttr | GetTextAttr () const
Returns the attributes of the text (Normal, Underlined, Italic, Bold or Strikethrough).
void | Init (const Font &font, TextAlign text_align=Default, TextAttr text_attr=Normal, FontAlign font_align=Top)
void | Init (INT system_font_id, TextAlign text_align=Default, TextAttr text_attr=Normal, FontAlign font_align=Top)
BOOLEAN | operator!= (const TextFormat &text_format) const
BOOLEAN | operator== (const TextFormat &text_format) const
void | SetFont (INT system_font_id)
void | SetFont (const Font &font)
void | SetFontAlign (FontAlign font_align)
Sets the font alignment (Top, Baseline or Bottom).
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetTextAlign (TextAlign text_align)
Sets the text alignment (Top, Baseline or Bottom).
void | SetTextAttr (TextAttr text_attr)
TextFormat (const Font &font, TextAlign text_align=Default, TextAttr text_attr=TextFormat::Normal, FontAlign font_align=Top)
TextFormat (INT system_font_id, TextAlign text_align=Default, TextAttr text_attr=TextFormat::Normal, FontAlign font_align=Top)
TextFormat ()

Detailed Description

Describes the format of a text. The type of the horizontal and vertical alignment can be set and it's also possible to specify text attributes like underlined, italic or bold.

Member Typedef Documentation

typedef UINT8 TextFormat::TextAttr

Member Enumeration Documentation

enum TextFormat::FontAlign

Defines the vertical text alignment (Top, Baseline or Bottom).

Enumerator:
Top | The given y coordinate is represented by the top border of the font.
Baseline | The given y coordinate is represented by the baseline of the font.
Bottom | The given y coordinate is represented by the bottom border of the font.

enum TextFormat::TextAlign

Defines the horizontal text alignment (Left, Centered or Right).

Enumerator:
Default | Alignment is corresponding to the used language (usually this means left-aligned).
Left | The text will be aligned on the left side.
Centered | The text will be horizontally centered.
Right | The Text will be aligned on the right side.

enum TextFormat::TextAttrValues

Defines attributes for text output. Note: not all fonts must support any text attribute. Combinations of text attributes can be defined using the bitwise or operator. If a font does not support an attribute (e. g. bold or italic) APOXI tries to emulate the attribute.

Enumerator:
Normal
Underlined
Italic
Bold
Strikethrough

Constructor & Destructor Documentation

TextFormat::TextFormat ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TextFormat::TextFormat | ( | INT | system_font_id,
 |  | TextAlign | text_align = Default,
 |  | TextAttr | text_attr = TextFormat::Normal,
 |  | FontAlign | font_align = Top
 | ) |

Parameters:
system_font_id | ID of the system-font (e. g. Font::Client). Using a system-font instead of a font-reference has the benefit that a system-font may automatically change when a theme or a language has been changed.
text_align | Alignment of the text (Default, Left, Centered or Right).
text_attr | Attribute of the text (Normal, Underlined, Italic, Bold and/or Strikethrough).
font_align | Font alignment (Top, Baseline or Bottom).

TextFormat::TextFormat | ( | const Font & | font,
 |  | TextAlign | text_align = Default,
 |  | TextAttr | text_attr = TextFormat::Normal,
 |  | FontAlign | font_align = Top
 | ) |

Parameters:
system_font_id | Reference to a font (e. g. use FontConfig::GetFont(0)). when a theme or a language has been changed.
text_align | Alignment of the text (Default, Left, Centered or Right).
text_attr | Attribute of the text (Normal, Underlined, Italic, Bold and/or Strikethrough).
font_align | Font alignment (Top, Baseline or Bottom).

Member Function Documentation

const Font & TextFormat::GetFont ( ) const

Returns a reference to the specified font. If the font has been set by specifying a system-font (e. g. SetFont(Font::Client)) the returned font-reference might differ dependant from the current set language and theme.

FontAlign TextFormat::GetFontAlign ( ) const [inline]

Returns the font alignment (Top, Baseline or Bottom).

TextAlign TextFormat::GetTextAlign ( ) const [inline]

Returns the text alignment (Top, Baseline or Bottom).

TextAttr TextFormat::GetTextAttr ( ) const [inline]

Returns the attributes of the text (Normal, Underlined, Italic, Bold or Strikethrough).

void TextFormat::Init | ( | const Font & | font,
 |  | TextAlign | text_align = Default,
 |  | TextAttr | text_attr = Normal,
 |  | FontAlign | font_align = Top
 | ) |

Parameters:
system_font_id | Reference to a font (e. g. use FontConfig::GetFont(0)). when a theme or a language has been changed.
text_align | Alignment of the text (Default, Left, Centered or Right).
text_attr | Attribute of the text (Normal, Underlined, Italic, Bold and/or Strikethrough).
font_align | Font alignment (Top, Baseline or Bottom).

void TextFormat::Init | ( | INT | system_font_id,
 |  | TextAlign | text_align = Default,
 |  | TextAttr | text_attr = Normal,
 |  | FontAlign | font_align = Top
 | ) |

Parameters:
system_font_id | ID of the system-font (e. g. Font::Client). Using a system-font instead of a font-reference has the benefit that a system-font may automatically change when a theme or a language has been changed.
text_align | Alignment of the text (Default, Left, Centered or Right).
text_attr | Attribute of the text (Normal, Underlined, Italic, Bold and/or Strikethrough).
font_align | Font alignment (Top, Baseline or Bottom).

BOOLEAN TextFormat::operator!= ( const TextFormat & text_format ) const

BOOLEAN TextFormat::operator== ( const TextFormat & text_format ) const

void TextFormat::SetFont ( INT system_font_id )

Sets the font by specifying a system-font (e. g. Font::Client). Using a system-font instead of a font-reference has the benefit that a system-font may automatically change when a theme or a language has been changed.

void TextFormat::SetFont ( const Font & font )

Sets to font of the textformat to the given font. In opposite to SetFont(INT system_font_id) the font won't be changed if a theme or a language has been changed.

void TextFormat::SetFontAlign ( FontAlign font_align ) [inline]

Sets the font alignment (Top, Baseline or Bottom).

BOOLEAN TextFormat::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

void TextFormat::SetTextAlign ( TextAlign text_align ) [inline]

Sets the text alignment (Top, Baseline or Bottom).

void TextFormat::SetTextAttr ( TextAttr text_attr ) [inline]

Sets the attributes of the text (Normal, Underlined, Italic, Bold, Strikethrough). Setting two attributes at the same time can be done the following way: text_format.SetTextAttr(TextFormat::Italic | TextFormat::Bold);

The documentation for this class was generated from the following files:
  • Gui/TextFormat.hpp
  • Gui/TextFormat.cpp
Generated on Wed Jan 25 02:10:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextIconPairArray Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextIconPairArray Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Properties/TextIconPairArray.hpp>

Collaboration diagram for TextIconPairArray:

[legend]

Public Member Functions

INT | GetSize () const
virtual void | Init (const TextIconPair *pair, INT size)
const TextIconPair * | operator[] (INT index) const
void | PopBack ()
void | PushBack (TextIconPair pair)
void | SetTextIconPair (const TextIconPair *pair, INT size)
TextIconPairArray (const TextIconPair *pair, INT size)
TextIconPairArray ()
default constructor
virtual | ~TextIconPairArray ()
destructor

Data Structures

class | TextIconPair

Detailed Description

TextIconPairArray is an array of TextIconPairs. A TextIconPair is a pair of simple WCHAR* and BitmapRes, offering a GetText and a GetIcon method.

The documentation for this class was generated from the following files:
  • Atl/Properties/TextIconPairArray.hpp
  • Atl/Properties/TextIconPairArray.cpp
Generated on Wed Jan 25 02:10:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextIconPairArray::TextIconPair Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
TextIconPairArray::TextIconPair

TextIconPairArray::TextIconPair Class Reference

#include <Apoxi/Atl/Properties/TextIconPairArray.hpp>

Collaboration diagram for TextIconPairArray::TextIconPair:

[legend]

Public Member Functions

ImageObtainer | GetIcon () const
const WCHAR * | GetText () const

Data Fields

const BitmapRes * | m_icon
const WCHAR * | m_text

Member Function Documentation

const WCHAR* TextIconPairArray::TextIconPair::GetText ( ) const [inline]

The documentation for this class was generated from the following files:
  • Atl/Properties/TextIconPairArray.hpp
  • Atl/Properties/TextIconPairArray.cpp
Generated on Wed Jan 25 02:10:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextIndicator Class Reference
[APOXI Template Layer]

Indicator that displays an text. More...

#include <Apoxi/Compat/Indicator.hpp>

Inheritance diagram for TextIndicator:

[legend]
Collaboration diagram for TextIndicator:

[legend]

Public Member Functions

virtual void | Draw (DeviceContext *dc, Point pos, Rect draw_rect)
Draws the indicator on the given screen position.
virtual Size | GetSize () const
Returns the size of the indicator.
const WString & | GetText () const
Returns the assigned text.
void | SetText (const WString &text)
TextIndicator (const WString &text)
TextIndicator ()
virtual | ~TextIndicator ()

Detailed Description

Indicator that displays an text.

Constructor & Destructor Documentation

TextIndicator::TextIndicator ( ) [inline]

TextIndicator::TextIndicator ( const WString & text )

TextIndicator::~TextIndicator ( ) [virtual]

Member Function Documentation

void TextIndicator::Draw | ( | DeviceContext * | dc,
 |  | Point | pos,
 |  | Rect | draw_rect
 | ) | [virtual]

Draws the indicator on the given screen position.

Implements Indicator.

Size TextIndicator::GetSize ( ) const [virtual]

Returns the size of the indicator.

Implements Indicator.

Reimplemented in CenteredTextIndicator.

const WString& TextIndicator::GetText ( ) const [inline]

Returns the assigned text.

void TextIndicator::SetText ( const WString & text )

Sets the text for this indicator. If the text is set to 0, the Indicator will be invisible.

The documentation for this class was generated from the following files:
  • Compat/Indicator.hpp
  • Compat/Indicator.cpp
Generated on Wed Jan 25 02:10:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextLine Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextLine Class Reference
[Components]

#include <Apoxi/Gui/TextLine.hpp>

Inheritance diagram for TextLine:

[legend]
Collaboration diagram for TextLine:

[legend]

Public Types

enum | { ID = 25 }

Public Member Functions

void | Init (Control *control, const WCHAR *text=0, const TextFormat &text_format=TextFormat())
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
TextLine (Control *control, const WCHAR *text=0, const TextFormat &text_format=TextFormat())
TextLine ()
virtual | ~TextLine ()

Detailed Description

DrawableObject which contains a text layouted horizontally inside the given boundaries. The text may have its own textformat and color.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractTextObject.

Constructor & Destructor Documentation

TextLine::TextLine ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TextLine::TextLine | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const TextFormat & | text_format = TextFormat()
 | ) |

Parameters:
control | Control which embeds the text object
text | Text of the object.
text_format | Format of the text.

TextLine::~TextLine ( ) [virtual]

Member Function Documentation

void TextLine::Init | ( | Control * | control,
 |  | const WCHAR * | text = 0,
 |  | const TextFormat & | text_format = TextFormat()
 | ) |

Parameters:
control | Control which embeds the text object
text | Text of the object.
text_format | Format of the text.

BOOLEAN TextLine::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractTextObject.

Reimplemented in AnimatedTextLine.

BOOLEAN TextLine::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractTextObject.

Reimplemented in AnimatedTextLine.

The documentation for this class was generated from the following files:
  • Gui/TextLine.hpp
  • Gui/TextLine.cpp
Generated on Wed Jan 25 02:10:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextLineView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextLineView Class Reference
[Components]

View object which draws a textline. More...

#include <Apoxi/Gui/TextLine.hpp>

Inheritance diagram for TextLineView:

[legend]
Collaboration diagram for TextLineView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
void | Init ()
TextLineView ()
virtual | ~TextLineView ()

Detailed Description

View object which draws a textline.

Constructor & Destructor Documentation

TextLineView::TextLineView ( )

TextLineView::~TextLineView ( ) [virtual]

Member Function Documentation

void TextLineView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void TextLineView::Init ( )

The documentation for this class was generated from the following files:
  • Gui/TextLine.hpp
  • Gui/TextLine.cpp
Generated on Wed Jan 25 02:10:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextList Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextList Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/TextList.hpp>

Inheritance diagram for TextList:

[legend]
Collaboration diagram for TextList:

[legend]

Public Member Functions

const WCHAR * | GetText () const
void | Init (Control *parent, const WCHAR *text)
void | SetText (const WCHAR *text)
TextList (Control *parent, const WCHAR *text)
TextList ()
virtual | ~TextList ()

Protected Member Functions

virtual Model * | CreateModel () const
void | Layout (XYDIM width)
virtual void | OnLayoutClient ()
virtual void | OnNextItem ()
virtual void | OnPreviousItem ()
virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)
void | UpdateNavigationGuidance ()

Detailed Description

Obsolete - use a MultiLineEditor in the read-only-mode instead. A Textlist is a listbox, which contains a scrollable text.

Constructor & Destructor Documentation

TextList::TextList ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TextList::TextList | ( | Control * | parent,
 |  | const WCHAR * | text
 | ) |

Parameters:
parent | Pointer to the window, which embedds the TextList.
text | Pointer to the Text to display.

TextList::~TextList ( ) [virtual]

Member Function Documentation

Model * TextList::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

const WCHAR * TextList::GetText ( ) const

void TextList::Init | ( | Control * | parent,
 |  | const WCHAR * | text
 | ) |

Parameters:
parent | Pointer to the window, which embedds the TextList.
text | Pointer to the Text to display.

void TextList::Layout ( XYDIM width ) [protected]

Parameters:
width Width in pixel for layouting the text to fit into.

void TextList::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from AbstractListBox.

void TextList::OnNextItem ( ) [protected, virtual]

See also:
AbstractListBox::OnNextItem

Reimplemented from AbstractListBox.

void TextList::OnPreviousItem ( ) [protected, virtual]

See also:
AbstractListBox::OnPreviousItem

Reimplemented from AbstractListBox.

void TextList::OnThemeChanged ( ) [protected, virtual]

See also:
Control::OnThemeChanged

Reimplemented from AbstractListBox.

void TextList::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect& rect)

Reimplemented from AbstractListBox.

void TextList::SetText ( const WCHAR * text )

void TextList::UpdateNavigationGuidance ( ) [protected]

Updates the state of the navigation guidance of the control respecting the focus switching with the up- and down-arrow keys.

Reimplemented from Control.

The documentation for this class was generated from the following files:
  • Compat/TextList.hpp
  • Compat/TextList.cpp
Generated on Wed Jan 25 02:10:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextListLine Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextListLine Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/TextList.hpp>

Public Member Functions

INT | GetLength () const
INT | GetStartIndex () const
void | SetLength (INT length)
void | SetStartIndex (INT start_index)
TextListLine ()

Constructor & Destructor Documentation

TextListLine::TextListLine ( ) [inline]

Member Function Documentation

INT TextListLine::GetLength ( ) const [inline]

INT TextListLine::GetStartIndex ( ) const [inline]

void TextListLine::SetLength ( INT length ) [inline]

void TextListLine::SetStartIndex ( INT start_index ) [inline]

The documentation for this class was generated from the following file:
  • Compat/TextList.hpp
Generated on Wed Jan 25 02:11:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextListModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextListModel Class Reference
[Obsolete GUI classes]

Describes the model of a textlist. More...

#include <Apoxi/Compat/TextList.hpp>

Inheritance diagram for TextListModel:

[legend]
Collaboration diagram for TextListModel:

[legend]

Public Member Functions

const WCHAR * | GetText () const
void | SetText (const WCHAR *text)
TextListModel (const WCHAR *text)
TextListModel ()

Data Fields

TLLVector m_lines

Detailed Description

Describes the model of a textlist.

Constructor & Destructor Documentation

TextListModel::TextListModel ( )

TextListModel::TextListModel ( const WCHAR * text )

Member Function Documentation

const WCHAR* TextListModel::GetText ( ) const [inline]

void TextListModel::SetText ( const WCHAR * text ) [inline]

Field Documentation

TLLVector TextListModel::m_lines

The documentation for this class was generated from the following files:
  • Compat/TextList.hpp
  • Compat/TextList.cpp
Generated on Wed Jan 25 02:11:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextListView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextListView Class Reference
[Obsolete GUI classes]

Describes the view of a textlist. More...

#include <Apoxi/Compat/TextList.hpp>

Inheritance diagram for TextListView:

[legend]
Collaboration diagram for TextListView:

[legend]

Public Member Functions

virtual void | DrawItem (const AbstractListBox &listbox, DeviceContext *dc, INT index, const Rect &item_rect) const
TextListView (XYDIM item_height)
TextListView ()
virtual | ~TextListView ()

Protected Member Functions

virtual void | DrawTextListItem (const TextList &text_list, DeviceContext *dc, INT index, const Rect &item_rect) const =0

Detailed Description

Describes the view of a textlist.

Constructor & Destructor Documentation

TextListView::TextListView ( )

TextListView::TextListView ( XYDIM item_height ) [inline]

TextListView::~TextListView ( ) [virtual]

Member Function Documentation

void TextListView::DrawItem | ( | const AbstractListBox & | listbox,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [virtual]

Reimplemented from AbstractListBoxView.

virtual void TextListView::DrawTextListItem | ( | const TextList & | text_list,
 |  | DeviceContext * | dc,
 |  | INT | index,
 |  | const Rect & | item_rect
 | ) | const [protected, pure virtual]

Implemented in BlueSkyTextListView, DefaultTextListView, and DefaultTextListView.

The documentation for this class was generated from the following files:
  • Compat/TextList.hpp
  • Compat/TextList.cpp
Generated on Wed Jan 25 02:11:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextMenuAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextMenuAccessor Class Reference
[Obsolete GUI classes]

#include <Apoxi/Compat/TextMenuAccessor.hpp>

Inheritance diagram for TextMenuAccessor:

[legend]
Collaboration diagram for TextMenuAccessor:

[legend]

Public Member Functions

virtual void | Back (Menu *menu)
virtual void | Draw (DeviceContext *dc, const Rect &draw_rect, BOOLEAN highlighted)
virtual BOOLEAN | First ()
virtual XYDIM | GetItemHeight () const
void | Init (const MenuTextIterator *iterator)
void | Init (Dispatcher *dispatcher, const MenuTextIterator *iterator)
virtual BOOLEAN | Next ()
TextMenuAccessor (const MenuTextIterator *iterator)
TextMenuAccessor (Dispatcher *dispatcher, const MenuTextIterator *iterator)
TextMenuAccessor ()
virtual void | Trigger (Menu *menu)
virtual | ~TextMenuAccessor ()

Detailed Description

Obsolete - the class Menu, which uses the TextMenuAccessor, has been replaced by the classes ItemMenu and ItemTree.

Accessor which iterates over a variable number of text-strings. The text-strings are described by an instance of the class MenuTextIterator. The message MenuTriggeredMsg() is sent to the dispatcher (e. g. a Window) specified by the constructor or Init

The following example shows how to embed a Menu using a TextMenuAccessor into a Window. A note to the implementation: for triggering the menu a confirm-action assigned to the left softkey has been used. For an application-framework like BasicMMI it is recommended to derive a sub-class from Window, which already provides a menu and softkeys and hence just a menu-accessor must be assigned to the sub-class.

include <Gui/MenuTextPtrArrayIterator.hpp>
class MyWindow : public Window {
    typedef MmiMenuWindow Base;
    public:
        void Init();
    protected:
        virtual BOOLEAN OnMessage(const Message& msg);
        virtual BOOLEAN OnConfirm();
    private:
        TextMenuAccessor m_accessor;
        MenuTextPtrArrayIterator m_iterator;
        Menu m_menu;
        SoftkeyBar m_softkey_bar;
        ConfirmAction m_confirm_action;
};

include "MyWindow.hpp"
void MyWindow::Init()
{
    Base::Init();
    SetTitle(Tr(L"Menu-Window"));
    // initialize softkey-bar
    m_confirm_action.Init(this, Tr(L"Select"));
    m_softkey_bar.Init(this);
    m_softkey_bar.Set(0, &m_confirm_action);
    // initialize menu
    static const WCHAR* text[] = { L"Item 1", L"Item 2", L"Item 3"};
    m_iterator.Init(3, text);
    m_accessor.Init(this, &m_iterator);
    m_menu.Init(this, &m_accessor);
}
BOOLEAN MyWindow::OnMessage(const Message& msg)
{
    BOOLEAN dispatched = TRUE;
    if (msg.Id() == MenuTriggeredMsg::ID) {
        MenuTriggeredMsg* menu_triggered_msg;
        CastMsg(menu_triggered_msg, &msg);
        switch (menu_triggered_msg->GetIndex()) {
            case 0:	// item 1 has been pressed
                        break;
            case 1:	// item 2 has been pressed
                        break;
            case 2:	// item 3 has been pressed
                        break;
        }
    }
    else
        dispatched = Base::OnMessage(msg);
    return dispatched;
}
BOOLEAN MyWindow::OnConfirm()
{
    // trigger menu, when pressing the left softkey
    m_menu.Trigger();
    return Base::OnConfirm();
}

See also:
MenuTextIterator

MenuTextPtrArrayIterator

Constructor & Destructor Documentation

TextMenuAccessor::TextMenuAccessor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TextMenuAccessor::TextMenuAccessor | ( | Dispatcher * | dispatcher,
 |  | const MenuTextIterator * | iterator
 | ) |

Parameters:
dispatcher | Pointer to the dispatcher, which should get the message MenuTriggeredMsg, when a menu-item is triggered. The message MenuBackMsg is send to the dispatcher, when TextMenuAccessor::Back is invoked.
iterator | Pointer to the iterator, which is able to iterate over a variable number of text-strings.

TextMenuAccessor::~TextMenuAccessor ( ) [virtual]

TextMenuAccessor::TextMenuAccessor ( const MenuTextIterator * iterator )

Obsolete - provided for backward-compatibility for APOXI-versions < 1_6. Use the constructor having a Dispatcher as input-parameter instead. This allows to specify, which Dispatcher (e. g. a Window) should be informed when triggering an item. When no Dispatcher is specified, the messages are send to the parent-window of the Menu containing the TextMenuAccessor.

Member Function Documentation

void TextMenuAccessor::Back ( Menu * menu ) [virtual]

See also:
AbstractMenuAccessor::Back

Implements AbstractMenuAccessor.

void TextMenuAccessor::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | draw_rect,
 |  | BOOLEAN | highlighted
 | ) | [virtual]

See also:
AbstractMenuAccessor::Draw

Implements AbstractMenuAccessor.

BOOLEAN TextMenuAccessor::First ( ) [virtual]

See also:
AbstractMenuAccessor::First

Implements AbstractMenuAccessor.

XYDIM TextMenuAccessor::GetItemHeight ( ) const [virtual]

See also:
AbstractMenuAccessor::GetItemHeight

Implements AbstractMenuAccessor.

void TextMenuAccessor::Init ( const MenuTextIterator * iterator )

Obsolete - provided for backward-compatibility for APOXI-versions < 1_6. Use the Init having a Dispatcher as input-parameter instead. This allows to specify, which Dispatcher (e. g. a Window) should be informed when triggering an item. When no Dispatcher is specified, the messages are send to the parent-window of the Menu containing the TextMenuAccessor.

void TextMenuAccessor::Init | ( | Dispatcher * | dispatcher,
 |  | const MenuTextIterator * | iterator
 | ) |

Parameters:
dispatcher | Pointer to the dispatcher, which should get the message MenuTriggeredMsg, when a menu-item is triggered. The message MenuBackMsg is send to the dispatcher, when TextMenuAccessor::Back is invoked.
iterator | Pointer to the iterator, which is able to iterate over a variable number of text-strings.

BOOLEAN TextMenuAccessor::Next ( ) [virtual]

See also:
AbstractMenuAccessor::Next

Implements AbstractMenuAccessor.

void TextMenuAccessor::Trigger ( Menu * menu ) [virtual]

See also:
AbstractMenuAccessor::Trigger

Implements AbstractMenuAccessor.

The documentation for this class was generated from the following files:
  • Compat/TextMenuAccessor.hpp
  • Compat/TextMenuAccessor.cpp
Generated on Wed Jan 25 02:11:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextPack Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextPack Class Reference

#include <Apoxi/Gui/TextPack.hpp>

Inheritance diagram for TextPack:

[legend]
Collaboration diagram for TextPack:

[legend]

Public Types

typedef DataPack | Base

Public Member Functions

const AcacLanguage * | GetLanguage (UINT16 index) const
TextPack (const UINT8 *data)
virtual | ~TextPack ()

Friends

class | BasicPackConnector

Detailed Description

An object of TextPack encapsulates the data of the text pack that is available in the customization pack and provides functionality for the TextPackConnector to access this data.

Member Typedef Documentation

typedef DataPack TextPack::Base

Constructor & Destructor Documentation

TextPack::TextPack ( const UINT8 * data )

Constructor of TextPack. Initializes the text pack with the data given as parameter.

Parameters:
data Pointer to the data of the TextPack.

TextPack::~TextPack ( ) [virtual]

Destructor of TextPack.

Member Function Documentation

const AcacLanguage * TextPack::GetLanguage ( UINT16 index ) const

Returns the AcacLanguage at position index.

Parameters:
index Index of the Language.
Returns:
AcacLanguage object at position index.

Friends And Related Function Documentation

friend class BasicPackConnector [friend]

Reimplemented from DataPack.

The documentation for this class was generated from the following files:
  • Gui/TextPack.hpp
  • Gui/TextPack.cpp
Generated on Wed Jan 25 02:11:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TextPackConnector Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TextPackConnector Class Reference

#include <Apoxi/Gui/TextPackConnector.hpp>

Collaboration diagram for TextPackConnector:

[legend]

Static Public Member Functions

static BOOLEAN | ContainsLanguage (EntryId id)
static EntryId | GetActiveLanguageId ()
static INT32 | GetIndexOfActiveLanguage ()
static INT32 | GetIndexOfLanguage (const AcacLanguage *language)
static const AcacLanguage * | GetLanguage (EntryId id)
static const AcacLanguage * | GetLanguageAt (UINT16 index)
static BOOLEAN | GetLanguageNames (const WCHAR **language_names, UINT32 size)
static const AcacLanguage ** | GetLanguages ()
static UINT16 | GetNumberOfLanguages ()
static const WCHAR * | GetText (UINT16 index)
static void | Init ()
static BOOLEAN | IsTextPackAvailable ()
static BOOLEAN | SetActiveLanguage (const AcacLanguage *lang)
static BOOLEAN | SetActiveLanguage (EntryId id)
static BOOLEAN | SetActiveLanguageByIndex (UINT16 index)

Detailed Description

The TextPackConnector provides functionality for accessing the data of a text pack.

Member Function Documentation

static BOOLEAN TextPackConnector::ContainsLanguage ( EntryId id ) [static]

Returns TRUE if the text pack contains the language with the id handed over in parameter id.

EntryId TextPackConnector::GetActiveLanguageId ( ) [static]

Returns the id of the active language.

INT32 TextPackConnector::GetIndexOfActiveLanguage ( ) [static]

Returns the index of the active language.

INT32 TextPackConnector::GetIndexOfLanguage ( const AcacLanguage * language ) [static]

Returns the index of the language handed over in parameter lang.

Parameters:
lang Language to get the index of.
Returns:
-1 if not found, otherwise the index of the language in the Text Pack.

const AcacLanguage * TextPackConnector::GetLanguage ( EntryId id ) [static]

Returns the language with the id handed over in parameter id.

const AcacLanguage * TextPackConnector::GetLanguageAt ( UINT16 index ) [static]

Returns the language at position index in the text pack.

BOOLEAN TextPackConnector::GetLanguageNames | ( | const WCHAR ** | language_names,
 |  | UINT32 | size
 | ) | [static]

Fills the array handed over by the caller with the names of the languages.

Parameters:
language_names Array where to write the names of the languages.

static const AcacLanguage** TextPackConnector::GetLanguages ( ) [static]

Returns pointers to the languages available in the text pack.

UINT16 TextPackConnector::GetNumberOfLanguages ( ) [static]

Returns the number of languages that are available in the customization pack.

const WCHAR * TextPackConnector::GetText ( UINT16 index ) [static]

Returns the text of the active language at position index.

void TextPackConnector::Init ( ) [static]

Initializes the TextPackConnector. The default language is set to english.

BOOLEAN TextPackConnector::IsTextPackAvailable ( ) [static]

Returns true if a text pack is available in the customization pack.

BOOLEAN TextPackConnector::SetActiveLanguage ( const AcacLanguage * lang ) [static]

Sets the active language to the language handed over in parameter lang.

Parameters:
lang Language that shall be set active.
Returns:
TRUE if the language given in the parameter has been set active.

BOOLEAN TextPackConnector::SetActiveLanguage ( EntryId id ) [static]

Sets the active language to the language which has the id equal to the parameter id.

Parameters:
id Id of the language that shall be set active.
Returns:
TRUE if the active language has the id given in parameter id.

BOOLEAN TextPackConnector::SetActiveLanguageByIndex ( UINT16 index ) [static]

Sets the active language to the language available at position idx.

Parameters:
idx Index of the language to set active.
Returns:
TRUE if the language at position idx has been set active.

The documentation for this class was generated from the following files:
  • Gui/TextPackConnector.hpp
  • Gui/TextPackConnector.cpp
Generated on Wed Jan 25 02:11:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThaiTextRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ThaiTextRenderer Class Reference
[GUI]

#include <Apoxi/Gui/ThaiTextRenderer.hpp>

Inheritance diagram for ThaiTextRenderer:

[legend]
Collaboration diagram for ThaiTextRenderer:

[legend]

Public Types

enum CharacterClass {
Ctrl = 0, Non = 1, Cons = 2, LV = 3,
FV1 = 4, FV2 = 5, FV3 = 6, BV1 = 7,
BV2 = 8, BD = 9, Tone = 10, AD1 = 11,
AD2 = 12, AD3 = 13, AV1 = 14, AV2 = 15,
AV3 = 16
}
enum | RenderType { Render = 0, Compose = 1, Control = 2 }
Used to determine whether and how to render character combinations. More...

Public Member Functions

virtual XYDIM | DrawText (DeviceContext *dc, const Rect &clip_rect, XYDIM x, XYDIM y, const WCHAR *text, INT from, INT char_count)
virtual INT | GetTextWidth (const WCHAR *text, const Font &font, TextAttr text_attr, INT from, INT char_count, BOOLEAN include_gap=FALSE)
virtual BOOLEAN | IsStandaloneCharacter (const WCHAR *text, INT index)
virtual INT | WrapLine (const WCHAR *text, const Font &font, TextAttr text_attr, INT char_count, XYDIM max_width=-1, WrapPolicy policy=(WrapPolicy) 0, BOOLEAN include_gap_at_end=FALSE, Size *total_size=0, INT *ws_at_eol_count=0, XYDIM *ws_at_eol_width=0, INT *last_completely_fitting_word_length=0)
virtual | ~ThaiTextRenderer ()

Static Public Member Functions

static ThaiTextRenderer & | GetInstance ()
Returns the instance of the Thai text renderer.

Protected Member Functions

virtual BOOLEAN | BeginGlyphRetrieval (const WCHAR *text_start, const Font &font, TextAttr text_attr)
virtual Size | GetGlyph (const WCHAR *cur_text_pos, const WCHAR *substitution_char, INT char_count, GlyphPtr glyph, INT &parsed_glyphs, BOOLEAN &is_diacritic)
ThaiTextRenderer ()

Data Structures

struct | ThaiFontHint

Detailed Description

Renderer for Thai text. Will draw correct diacritics, tonemarks, etc.

Member Enumeration Documentation

enum ThaiTextRenderer::CharacterClass

Thai character classes. Used to determine each Thai character's type, which is used to verify the correct syntax of a Thai text and how to render character combinations. Every character belongs to one class; the mapping is done via g_charclass_table in ThaiTextRenderer.cpp.

Enumerator:
Ctrl
Non
Cons
LV
FV1
FV2
FV3
BV1
BV2
BD
Tone
AD1
AD2
AD3
AV1
AV2
AV3

enum ThaiTextRenderer::RenderType

Used to determine whether and how to render character combinations.

Enumerator:
Render
Compose | render immediately
Control | needs to be combined with preceding character(s)

Constructor & Destructor Documentation

ThaiTextRenderer::~ThaiTextRenderer ( ) [virtual]

ThaiTextRenderer::ThaiTextRenderer ( ) [protected]

Member Function Documentation

BOOLEAN ThaiTextRenderer::BeginGlyphRetrieval | ( | const WCHAR * | text_start,
 |  | const Font & | font,
 |  | TextAttr | text_attr
 | ) | [protected, virtual]

Apart from things performed in

See also:
AbstractTextRenderer::BeginGlyphRetrieval, also also performs the following tasks if the font has been changed since the last call to the Thai text renderer: (1) Retrieves the appropriate font hinting information from

FontConfig::GetThaiFontHints. (2) Constructs glyphs w/o below diacritics for 0x0E0D and 0x0E10.

Reimplemented from AbstractTextRenderer.

XYDIM ThaiTextRenderer::DrawText | ( | DeviceContext * | dc,
 |  | const Rect & | clip_rect,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | const WCHAR * | text,
 |  | INT | from,
 |  | INT | char_count
 | ) | [virtual]

See also:
AbstractTextRenderer::DrawText

Reimplemented from AbstractTextRenderer.

Size ThaiTextRenderer::GetGlyph | ( | const WCHAR * | cur_text_pos,
 |  | const WCHAR * | substitution_char,
 |  | INT | char_count,
 |  | GlyphPtr | glyph,
 |  | INT & | parsed_glyphs,
 |  | BOOLEAN & | is_diacritic
 | ) | [protected, virtual]

Get the glyph for a character. Will return the glyph except if

See also:
ThaiTextRenderer::PrepareText replaced 0x0E0D and 0x0E10 with 0x0E5C and 0x0E5D, respectively. In these two cases, glyphs for 0x0E0D and 0x0E10 with their below diacritics removed will be returned.
For a detailed explanation of parameters etc. please see
See also:
AbstractTextRenderer::GetGlyph.

Implements AbstractTextRenderer.

ThaiTextRenderer & ThaiTextRenderer::GetInstance ( ) [static]

Returns the instance of the Thai text renderer.

INT ThaiTextRenderer::GetTextWidth | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | from,
 |  | INT | char_count,
 |  | BOOLEAN | include_gap = FALSE
 | ) | [virtual]

See also:
AbstractTextRenderer::GetTextWidth

Reimplemented from AbstractTextRenderer.

BOOLEAN ThaiTextRenderer::IsStandaloneCharacter | ( | const WCHAR * | text,
 |  | INT | index
 | ) | [virtual]

See also:
AbstractTextRenderer::IsStandaloneCharacter

Reimplemented from AbstractTextRenderer.

INT ThaiTextRenderer::WrapLine | ( | const WCHAR * | text,
 |  | const Font & | font,
 |  | TextAttr | text_attr,
 |  | INT | char_count,
 |  | XYDIM | max_width = -1,
 |  | WrapPolicy | policy = (WrapPolicy) 0,
 |  | BOOLEAN | include_gap_at_end = FALSE,
 |  | Size * | total_size = 0,
 |  | INT * | ws_at_eol_count = 0,
 |  | XYDIM * | ws_at_eol_width = 0,
 |  | INT * | last_completely_fitting_word_length = 0
 | ) | [virtual]

See also:
AbstractTextRenderer::WrapLine

Reimplemented from AbstractTextRenderer.

The documentation for this class was generated from the following files:
  • Gui/ThaiTextRenderer.hpp
  • Gui/ThaiTextRenderer.cpp
Generated on Wed Jan 25 02:11:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThaiTextRenderer::ThaiFontHint Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ThaiTextRenderer::ThaiFontHint

ThaiTextRenderer::ThaiFontHint Struct Reference

#include <Apoxi/Gui/ThaiTextRenderer.hpp>

Data Fields

XYDIM | m_above_level_y_offset
XYDIM(* | m_cons_offsets )[46]
XYDIM(* | m_diacritics_offsets )[19][5]
XYDIM | m_lo_chula_y_offset
Y-offset for "top" level.
XYDIM | m_mai_tho_toplevel_x_offset
Y-offset for diacritics placed over character 0x0E2C (LO CHULA). Diacritics need to be drawn over ascender.
XYDIM | m_tho_than_diacritic_lines
XYDIM | m_top_level_y_offset
Y-offset for "above" level.
XYDIM | m_yo_ying_diacritic_lines

Detailed Description

Correctly rendering Thai text needs font hints, i.e. information on where to place characters and their diacritics. Every Thai font needs these hints, which are configured in Config/FontConfig.hpp and are retrieved by calling
See also:
FontConfig::GetThaiFontHints.
In general, font hinting has to be done by hand.

Field Documentation

XYDIM ThaiTextRenderer::ThaiFontHint::m_above_level_y_offset

Offsets for diacritics. The values are in the columns are: [0] - x-offset for above level, or kerning distance for characters in group LV (0x0E42, 0x0E43, 0x0E44). For others not in group LV, these are offsets so that the right edge of the diacritic can be placed correctly on the top level. Some diacritics are right-aligned to the modified consonant's right edge, some must be placed so that they overshoot the consonant's right edge. [1] - y-offset for above level. A correction factor for some diacritics so that when they are placed on the above level, they are correctly aligned and do not obscure the consonant. [2] - y-offset correction factor if the character is on above level and another is placed on top level. [3] - x-correction factor for diacritics used in conjunction with a CONS having an ascender. [4] - x-correction factor for diacritics when placed above 0x0E2C. Rows [0 ... 18] are for: 0x0E31, 0x0E34, 0x0E35, 0x0E36, 0x0E37, 0x0E38, 0x0E39, 0x0E3A, 0x0E47, 0x0E48, 0x0E49, 0x0E4A, 0x0E4B, 0x0E4C, 0x0E4D, 0x0E4E, 0x0E42, 0x0E43, and 0x0E44.

XYDIM(* ThaiTextRenderer::ThaiFontHint::m_cons_offsets)[46]

XYDIM(* ThaiTextRenderer::ThaiFontHint::m_diacritics_offsets)[19][5]

Offsets where - in general - diacritics need to be placed in relation to the glyph's right border. Specifies the distance from the left edge of the consonant's glyph to where the right edge of the diacritic placed above the consonant should be. This usually corresponds to the character's width (a glyph is usually wider than the character, as it is a block that may have a pixel or two on the left and right side). However, for some characters this does not correspond, and must be determined by hand.

XYDIM ThaiTextRenderer::ThaiFontHint::m_lo_chula_y_offset

Y-offset for "top" level.

XYDIM ThaiTextRenderer::ThaiFontHint::m_mai_tho_toplevel_x_offset

Y-offset for diacritics placed over character 0x0E2C (LO CHULA). Diacritics need to be drawn over ascender.

XYDIM ThaiTextRenderer::ThaiFontHint::m_tho_than_diacritic_lines

Specifies how many lines must be erased in the 0x0E0D (YO YING) glyph to eliminate its below diacritic. Counted from the glyph's bottom.

XYDIM ThaiTextRenderer::ThaiFontHint::m_top_level_y_offset

Y-offset for "above" level.

XYDIM ThaiTextRenderer::ThaiFontHint::m_yo_ying_diacritic_lines

X-offset for character 0x0E49 (MAI THO). The Thai diacritic MAI THO needs to be shifted to the right if it is placed on the top level; this correction factor determines the amount it is moved to the right.

The documentation for this struct was generated from the following file:
  • Gui/ThaiTextRenderer.hpp
Generated on Wed Jan 25 02:11:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Theme Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Theme Class Reference
[GUI]

#include <Apoxi/Gui/Theme.hpp>

Inheritance diagram for Theme:

[legend]

Public Types

enum | BitmapResId { SelectedCheckBoxId, DeselectedCheckBoxId, SelectedRadioButtonId, DeselectedRadioButtonId }

Public Member Functions

virtual const BitmapRes * | GetBitmap (BitmapResId id) const
virtual const ControlFrameView * | GetControlFrameView () const =0
INT | GetFontId (SystemFontId id) const
Returns the font-ID, which corresponds to the system-font specified by id.
virtual const WCHAR * | GetName () const
Returns the name of the theme. Per default 0 is returned.
virtual const PanelView * | GetPanelView () const
virtual const PositionIndicatorView * | GetPositionIndicatorView () const =0
virtual const ProgressBarView * | GetProgressBarView () const =0
virtual const PushButtonView * | GetPushButtonView () const =0
virtual ColorValue | GetSystemColor (SystemColorId id) const
virtual const ColorTable * | GetSystemColorTable () const
virtual const TabButtonView * | GetTabButtonView () const
virtual const TabControlView * | GetTabControlView () const
virtual const WindowFrameView * | GetWindowFrameView () const =0
virtual void | Update ()

Protected Member Functions

void | SetFontId (SystemFontId id, INT font_id)
void | SetSystemColor (SystemColorId id, ColorValue color_value)
Theme ()
virtual | ~Theme ()

Detailed Description

A theme describes the look of all components like controls, windows and drawable objects.

Member Enumeration Documentation

enum Theme::BitmapResId

The bitmap resource ID allows to classify bitmaps by their rule to receive them in Theme::GetBitmap.

Enumerator:
SelectedCheckBoxId | Bitmap used for a selected checkbox.
DeselectedCheckBoxId | Bitmap used for a deselected checkbox.
SelectedRadioButtonId | Bitmap used for a selected radiobutton.
DeselectedRadioButtonId | Bitmap used for a deselected radionbutton.

Constructor & Destructor Documentation

Theme::Theme ( ) [protected]

Theme::~Theme ( ) [protected, virtual]

Member Function Documentation

const BitmapRes * Theme::GetBitmap ( BitmapResId id ) const [virtual]

Returns a pointer to a bitmap resource which is defined by the ID id.

virtual const ControlFrameView* Theme::GetControlFrameView ( ) const [pure virtual]

Returns a pointer to a control frame view, which is used to draw the frame of a control including the background of the client area.

Implemented in BlackAndWhiteTheme, BlueSkyChineseTheme, BlueSkyTheme, DefaultChineseTheme, DefaultTheme, FoggyTheme, TestTheme, CustomizableTheme, DefaultTheme, and FoggyTheme.

INT Theme::GetFontId ( SystemFontId id ) const

Returns the font-ID, which corresponds to the system-font specified by id.

const WCHAR * Theme::GetName ( ) const [virtual]

Returns the name of the theme. Per default 0 is returned.

Reimplemented in CustomizableTheme, DefaultTheme, and FoggyTheme.

const PanelView * Theme::GetPanelView ( ) const [virtual]

Returns a pointer to a panel view, which is used to draw an instance of the class Panel. The panel usually is aligned at the bottom of the desktop and shows the softkeys.

Reimplemented in CustomizableTheme, DefaultTheme, and FoggyTheme.

virtual const PositionIndicatorView* Theme::GetPositionIndicatorView ( ) const [pure virtual]

Returns a pointer to a position indicator view, which is used to draw an instance of the class PositionIndicator.

Implemented in BlackAndWhiteTheme, BlueSkyChineseTheme, BlueSkyTheme, DefaultChineseTheme, DefaultTheme, FoggyTheme, TestTheme, CustomizableTheme, DefaultTheme, and FoggyTheme.

virtual const ProgressBarView* Theme::GetProgressBarView ( ) const [pure virtual]

Returns a pointer to a progress bar view, which is used to draw an instance of the class ProgressBar.

Implemented in BlackAndWhiteTheme, BlueSkyChineseTheme, BlueSkyTheme, DefaultChineseTheme, DefaultTheme, FoggyTheme, TestTheme, CustomizableTheme, DefaultTheme, and FoggyTheme.

virtual const PushButtonView* Theme::GetPushButtonView ( ) const [pure virtual]

Returns a pointer to a push-button view, which is used to draw an instance of the class PushButton.

Implemented in BlackAndWhiteTheme, BlueSkyChineseTheme, BlueSkyTheme, DefaultChineseTheme, DefaultTheme, FoggyTheme, TestTheme, CustomizableTheme, DefaultTheme, and FoggyTheme.

ColorValue Theme::GetSystemColor ( SystemColorId id ) const [virtual]

Returns a color-value of the system-color with the id id specified by the system-color-table. This method must not be overwritten by derived themes, when GetSystemColorTable has been overwritten. To stay backward-compatible with older versions of APOXI, 0 is returned if no system-color-table is provided.

Reimplemented in BlackAndWhiteTheme, BlueSkyChineseTheme, BlueSkyTheme, DefaultChineseTheme, FoggyTheme, and TestTheme.

const ColorTable * Theme::GetSystemColorTable ( ) const [virtual]

Returns a pointer to the color-table of the system-colors. This method should be overwritten by derived themes providing a pointer to a custom color-table. To stay backward-compatible with older versions of APOXI, 0 is returned in the default-implementation.

Reimplemented in DefaultTheme, CustomizableTheme, DefaultTheme, and FoggyTheme.

const TabButtonView * Theme::GetTabButtonView ( ) const [virtual]

Returns a pointer to a tab button view, which is used to draw an instance of the class TabButton. A tab button is embedded inside a tab control.

Reimplemented in DefaultTheme, and FoggyTheme.

const TabControlView * Theme::GetTabControlView ( ) const [virtual]

Returns a pointer to a tab control view, which is used to draw an instance of the class TabControl.

Reimplemented in DefaultTheme, and FoggyTheme.

virtual const WindowFrameView* Theme::GetWindowFrameView ( ) const [pure virtual]

Returns a pointer to a window frame view, which is used to draw the frame of a window including the background of the client area.

Implemented in BlackAndWhiteTheme, BlueSkyChineseTheme, BlueSkyTheme, DefaultChineseTheme, DefaultTheme, FoggyTheme, TestTheme, CustomizableTheme, DefaultTheme, and FoggyTheme.

void Theme::SetFontId | ( | SystemFontId | id,
 |  | INT | font_id
 | ) | [protected]

void Theme::SetSystemColor | ( | SystemColorId | id,
 |  | ColorValue | color_value
 | ) | [protected]

void Theme::Update ( ) [virtual]

Converts all colors given by the system-color-table to system-colors and invokes View::Update(this) for every View which is part of the theme. Also the fonts are updated which may be specified by ThemeConfig::GetFontId().

Reimplemented in DefaultChineseTheme, DefaultTheme, FoggyTheme, CustomizableTheme, DefaultTheme, and FoggyTheme.

The documentation for this class was generated from the following files:
  • Gui/Theme.hpp
  • Gui/Theme.cpp
Generated on Wed Jan 25 02:11:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThemeChangedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ThemeChangedMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ThemeChangedMsg:

[legend]
Collaboration diagram for ThemeChangedMsg:

[legend]

Public Types

enum | { ID = 120 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
ThemeChangedMsg ()
virtual | ~ThemeChangedMsg ()

Detailed Description

This message is sent when the active theme was changed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ThemeChangedMsg::ThemeChangedMsg ( )

ThemeChangedMsg::~ThemeChangedMsg ( ) [virtual]

Member Function Documentation

Message * ThemeChangedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ThemeChangedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 02:11:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThemeConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ThemeConfig Class Reference
[Config]

#include <ThemeConfig.hpp>

Static Public Member Functions

static INT | GetFontId (SystemFontId id, const Theme &theme)
static const Theme & | GetTheme (INT idx)
static INT | GetThemeCount ()

Detailed Description

Allows accessing the theme configuration. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static INT ThemeConfig::GetFontId | ( | SystemFontId | id,
 |  | const Theme & | theme
 | ) | [static]

Returns:
Font ID which corresponds to the system-font ID id of the theme theme. It is recommended to respect the language settings and dynamically use the corresponding font. E. g. when the current set language is Chinese, another font ID may returned than for English.

static const Theme& ThemeConfig::GetTheme ( INT idx ) [static]

Returns a reference to the theme with the index idx. The number of available themes is defined by ThemeConfig::GetThemeCount.

static INT ThemeConfig::GetThemeCount ( ) [static]

Returns the number of available themes. The theme instances can be accessed by ThemeConfig::GetTheme(INT idx).

The documentation for this class was generated from the following file:
  • ThemeConfig.hpp
Generated on Wed Jan 25 02:11:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThemeManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ThemeManager Class Reference
[GUI]

The theme-manager is able to switch between different themes. More...

#include <Apoxi/Gui/ThemeManager.hpp>

Collaboration diagram for ThemeManager:

[legend]

Static Public Member Functions

static const Theme & | GetActiveTheme ()
Returns the active theme.
static INT | GetActiveThemeIndex ()
static void | SetActiveTheme (INT active_theme_idx)
Sets the active theme.
static void | UpdateThemes ()
Invokes Theme::Update of all themes.

Detailed Description

The theme-manager is able to switch between different themes.

Member Function Documentation

const Theme & ThemeManager::GetActiveTheme ( ) [static]

Returns the active theme.

static INT ThemeManager::GetActiveThemeIndex ( ) [inline, static]

Returns:
Index of active theme.

void ThemeManager::SetActiveTheme ( INT active_theme_idx ) [static]

Sets the active theme.

void ThemeManager::UpdateThemes ( ) [static]

Invokes Theme::Update of all themes.

The documentation for this class was generated from the following files:
  • Gui/ThemeManager.hpp
  • Gui/ThemeManager.cpp
Generated on Wed Jan 25 02:11:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThemeViewIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ThemeViewIterator Class Reference
[GUI]

#include <Apoxi/Gui/Theme.hpp>

Collaboration diagram for ThemeViewIterator:

[legend]

Public Member Functions

void | Begin ()
View * | GetView () const
BOOLEAN | Next ()
ThemeViewIterator (Theme *theme)
virtual | ~ThemeViewIterator ()

Constructor & Destructor Documentation

ThemeViewIterator::ThemeViewIterator ( Theme * theme )

ThemeViewIterator::~ThemeViewIterator ( ) [virtual]

Member Function Documentation

void ThemeViewIterator::Begin ( )

View * ThemeViewIterator::GetView ( ) const

BOOLEAN ThemeViewIterator::Next ( )

The documentation for this class was generated from the following files:
  • Gui/Theme.hpp
  • Gui/Theme.cpp
Generated on Wed Jan 25 02:11:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Thread Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Thread Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/Nuc32/Thread.hpp>

Inheritance diagram for Thread:

[legend]
Collaboration diagram for Thread:

[legend]

Public Types

enum PriorityLevel {
PriorityBackground5 = APOXI_THREAD_PRIORITY_NORMAL + 5, PriorityBackground4 = APOXI_THREAD_PRIORITY_NORMAL + 4, PriorityBackground3 = APOXI_THREAD_PRIORITY_NORMAL + 3, PriorityBackground2 = APOXI_THREAD_PRIORITY_NORMAL + 2,
PriorityBackground1 = APOXI_THREAD_PRIORITY_NORMAL + 1, PriorityNormal = APOXI_THREAD_PRIORITY_NORMAL, PriorityForeground1 = APOXI_THREAD_PRIORITY_NORMAL - 1, PriorityForeground2 = APOXI_THREAD_PRIORITY_NORMAL - 2,
PriorityForeground3 = APOXI_THREAD_PRIORITY_NORMAL - 3, PriorityForeground4 = APOXI_THREAD_PRIORITY_NORMAL - 4, PriorityForeground5 = APOXI_THREAD_PRIORITY_NORMAL - 5
}
enum PriorityLevel {
PriorityBackground5 = APOXI_THREAD_PRIORITY_NORMAL + 5, PriorityBackground4 = APOXI_THREAD_PRIORITY_NORMAL + 4, PriorityBackground3 = APOXI_THREAD_PRIORITY_NORMAL + 3, PriorityBackground2 = APOXI_THREAD_PRIORITY_NORMAL + 2,
PriorityBackground1 = APOXI_THREAD_PRIORITY_NORMAL + 1, PriorityNormal = APOXI_THREAD_PRIORITY_NORMAL, PriorityForeground1 = APOXI_THREAD_PRIORITY_NORMAL - 1, PriorityForeground2 = APOXI_THREAD_PRIORITY_NORMAL - 2,
PriorityForeground3 = APOXI_THREAD_PRIORITY_NORMAL - 3, PriorityForeground4 = APOXI_THREAD_PRIORITY_NORMAL - 4, PriorityForeground5 = APOXI_THREAD_PRIORITY_NORMAL - 5
}

Public Member Functions

BOOLEAN | DecreasePriority ()
BOOLEAN | DecreasePriority ()
const CHAR * | GetName () const
const CHAR * | GetName () const
INT | GetPriority () const
INT | GetPriority () const
UINT32 | GetRequestedStackSize ()
UINT32 | GetRequestedStackSize ()
BOOLEAN | IncreasePriority ()
BOOLEAN | IncreasePriority ()
INT | Resume () const
INT | Resume () const
BOOLEAN | Run (UINT32 stacksize=4096, void *stack=0)
BOOLEAN | Run (UINT32 stacksize=0, void *stack=0)
void | SetName (const CHAR *name)
void | SetName (const CHAR *name)
BOOLEAN | SetPriority (INT priority)
BOOLEAN | SetPriority (INT priority)
void | SetRequestedStackSize (UINT32)
void | SetRequestedStackSize (UINT32 size)
INT | Suspend () const
INT | Suspend () const
BOOLEAN | Terminate (INT exit_code=0)
BOOLEAN | Terminate (INT exit_code=0)
Thread ()
Thread ()
virtual INT | ThreadFn ()=0
virtual INT | ThreadFn ()=0
INT | Yield () const
INT | Yield () const
virtual | ~Thread ()
virtual | ~Thread ()

Static Public Member Functions

static void * | GetThreadData ()
static void * | GetThreadData ()
static ThreadId | GetThreadId ()
static ThreadId | GetThreadId ()
static void | SetThreadData (void *data)
static void | SetThreadData (void *data)

Friends

class | Os

Detailed Description

A Thread is the basic unit to which the operating system allocates processor time.

Member Enumeration Documentation

enum Thread::PriorityLevel

Priority is used to set the thread priority to predefined values. Negative values are predefined priority levels, positive values are used to set the priority directly.

Enumerator:
PriorityBackground5
PriorityBackground4 | lowest priority level
PriorityBackground3
PriorityBackground2
PriorityBackground1
PriorityNormal
PriorityForeground1 | default priority level
PriorityForeground2
PriorityForeground3
PriorityForeground4
PriorityForeground5

enum Thread::PriorityLevel

Enumerator:
PriorityBackground5
PriorityBackground4 | lowest priority level
PriorityBackground3
PriorityBackground2
PriorityBackground1
PriorityNormal
PriorityForeground1 | default priority level
PriorityForeground2
PriorityForeground3
PriorityForeground4
PriorityForeground5

Constructor & Destructor Documentation

Thread::Thread ( )

Thread::~Thread ( ) [virtual]

Thread::Thread ( )

virtual Thread::~Thread ( ) [virtual]

Member Function Documentation

BOOLEAN Thread::DecreasePriority ( )

Decreases the priority by on level (depends on the OS).

BOOLEAN Thread::DecreasePriority ( )

const CHAR* Thread::GetName ( ) const [inline]

Reimplemented in GenericWorkerTask.

const CHAR* Thread::GetName ( ) const [inline]

Reimplemented in GenericWorkerTask.

INT Thread::GetPriority ( ) const [inline]

INT Thread::GetPriority ( ) const [inline]

UINT32 Thread::GetRequestedStackSize ( ) [inline]

UINT32 Thread::GetRequestedStackSize ( ) [inline]

static void* Thread::GetThreadData ( ) [static]

void * Thread::GetThreadData ( ) [static]

static ThreadId Thread::GetThreadId ( ) [static]

ThreadId Thread::GetThreadId ( ) [static]

BOOLEAN Thread::IncreasePriority ( )

Increases the priority by on level (depends on the OS).

BOOLEAN Thread::IncreasePriority ( )

INT Thread::Resume ( ) const

The execution of the thread is resumed.

INT Thread::Resume ( ) const

BOOLEAN Thread::Run | ( | UINT32 | stacksize = 4096,
 |  | void * | stack = 0
 | ) |

Creates the Thread and runs the user-implemented ThreadFn method.

Parameters:
stacksize | Specifies the initial size of the stack, in bytes.
stack | Designates the starting memory location of the task’s stack.

Reimplemented in ServiceThread.

BOOLEAN Thread::Run | ( | UINT32 | stacksize = 0,
 |  | void * | stack = 0
 | ) |

Reimplemented in ServiceThread.

void Thread::SetName ( const CHAR * name )

Set the name of the thread.

void Thread::SetName ( const CHAR * name )

BOOLEAN Thread::SetPriority ( INT priority )

Sets the priority of the thread, whereas a higher value means a higher priority. If the operating system defines a higher value as a lower priority, a mapping has to be done in the implementation. If negative values are passed as defined in enum Thread::PriorityLevel then the given priority level is mapped to an appropriate OS priority, positive values are set directly.

Returns:
If the function succeeds, the return value is TRUE. If the function fails, the return value is FALSE.

BOOLEAN Thread::SetPriority ( INT priority )

void Thread::SetRequestedStackSize ( UINT32 ) [inline]

Requests a stack frame with the given size for the thread.

void Thread::SetRequestedStackSize ( UINT32 size )

static void Thread::SetThreadData ( void * data ) [static]

Parameters:
data Pointer to thread defined data that should be attached to the thread.

void Thread::SetThreadData ( void * data ) [static]

INT Thread::Suspend ( ) const

Suspending a thread causes the thread to stop executing ThreadFn code.

INT Thread::Suspend ( ) const

BOOLEAN Thread::Terminate ( INT exit_code = 0 )

Terminate is used to cause a thread to exit.

BOOLEAN Thread::Terminate ( INT exit_code = 0 )

virtual INT Thread::ThreadFn ( ) [pure virtual]

Specifies the entry function of the task. This function will be executed in thread context.

Implemented in EmzAacDecoderThread, EmzH264DecoderThread, EmzMp3DecoderThread, EmzMpeg4DecoderThread, EmzMpeg4EncoderThread, EmzSbcEncoderThread, EmzAacDecoderThread, EmzH264DecoderThread, EmzMp3DecoderThread, EmzMpeg4DecoderThread, EmzMpeg4EncoderThread, AppContainer, GenericWorkerTask, and FfsTestThread.

virtual INT Thread::ThreadFn ( ) [pure virtual]

Implemented in EmzAacDecoderThread, EmzH264DecoderThread, EmzMp3DecoderThread, EmzMpeg4DecoderThread, EmzMpeg4EncoderThread, EmzSbcEncoderThread, EmzAacDecoderThread, EmzH264DecoderThread, EmzMp3DecoderThread, EmzMpeg4DecoderThread, EmzMpeg4EncoderThread, AppContainer, GenericWorkerTask, and FfsTestThread.

INT Thread::Yield ( ) const

This method causes the calling thread to yield execution to another thread that is ready to run on the current processor. The operating system selects the thread to yield to.

INT Thread::Yield ( ) const

Friends And Related Function Documentation

friend class Os [friend]

Reimplemented in GenericWorkerTask.

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/Thread.hpp
  • Kernel/Os/Win32/Thread.hpp
  • Kernel/Os/Nuc32/Thread.cpp
  • Kernel/Os/Win32/Thread.cpp
Generated on Wed Jan 25 02:11:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Threadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Threadlet Class Reference
[Kernel]

#include <Apoxi/Kernel/Threadlet.hpp>

Inheritance diagram for Threadlet:

[legend]
Collaboration diagram for Threadlet:

[legend]

Public Member Functions

void | Execute (BOOLEAN block=TRUE)
virtual INT | Fn ()=0
virtual UINT | GetReqStackSize () const
BOOLEAN | IsBlocking () const
virtual void | OnEndOfExecute ()
virtual void | ReleaseInstance ()
Threadlet ()
virtual | ~Threadlet ()

Friends

class | GenericWorkerTask

Detailed Description

A threadlet exposes a generic interface to execute parts of an application in context of another thread (i.e the GenericWorkerTask).
See also:
GenericWorkerTask

Constructor & Destructor Documentation

Threadlet::Threadlet ( )

Threadlet::~Threadlet ( ) [virtual]

Member Function Documentation

void Threadlet::Execute ( BOOLEAN block = TRUE )

Launches the execution of the threadlet. If block is TRUE, an active wait is done and hence Execute behaves like a synchronous call. If block is FALSE the execution is started asynchronous and after finishing, the application the threadlet belongs to, will get informed by the message ThreadletNotificationMsg.

virtual INT Threadlet::Fn ( ) [pure virtual]

Fn is the function that will be executed in thread context. Be aware of restrictions to operations that can be performed in thread context.

Implemented in DecodingThreadlet, EncodingThreadlet, SyncPhoneThreadlet, UpdatePbThreadlet, FfsTestThreadlet, and UibUpdateThreadlet.

UINT Threadlet::GetReqStackSize ( ) const [virtual]

Returns:
The stack size requirements of the threadlet. Default implementation will request 1024 bytes.

BOOLEAN Threadlet::IsBlocking ( ) const [inline]

Returns:
TRUE if the threadlet has been initialized to be a blocking threadlet.
See also:
Treadlet::Execute

void Threadlet::OnEndOfExecute ( ) [virtual]

Is invoked after Fn has been executed. The default implementation sends the message ThreadletNotificationMsg to the application that executed the threadlet. Important: when overwriting the method invoke the base-method always at the end!

Reimplemented in SyncPhoneThreadlet, and UpdatePbThreadlet.

void Threadlet::ReleaseInstance ( ) [virtual]

Is invoked, when the threadlet has the permission to destroy itself. Per default nothing is done. Overwriting this method is useful, if a derived class offers a static method CreateInstance, which internally allocates an instance on the heap, so that in ReleaseInstance this instance might be deleted. This releases the application, which created a worker-thread, to taking care about releasing the threadlet by listening to the message ThreadletNotificationMsg.

Reimplemented in DecodingThreadlet, EncodingThreadlet, and FfsTestThreadlet.

Friends And Related Function Documentation

friend class GenericWorkerTask [friend]

The documentation for this class was generated from the following files:
  • Kernel/Threadlet.hpp
  • Kernel/Threadlet.cpp
Generated on Wed Jan 25 02:11:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThreadletNotificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ThreadletNotificationMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for ThreadletNotificationMsg:

[legend]
Collaboration diagram for ThreadletNotificationMsg:

[legend]

Public Types

enum | { ID = 109 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
Threadlet * | GetThreadlet () const
ThreadletNotificationMsg (ExecutionContext *context, Threadlet *threadlet)
virtual | ~ThreadletNotificationMsg ()

Detailed Description

This message will be sent to the Application which started the Threadlet to get the information that the Threadlet has been executed.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ThreadletNotificationMsg::ThreadletNotificationMsg | ( | ExecutionContext * | context,
 |  | Threadlet * | threadlet
 | ) |

ThreadletNotificationMsg::~ThreadletNotificationMsg ( ) [virtual]

Member Function Documentation

Message * ThreadletNotificationMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ThreadletNotificationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

Threadlet* ThreadletNotificationMsg::GetThreadlet ( ) const [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 02:11:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ThreadSafeProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ThreadSafeProvider Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/ThreadSafeProvider.hpp>

Inheritance diagram for ThreadSafeProvider:

[legend]
Collaboration diagram for ThreadSafeProvider:

[legend]

Public Member Functions

void | Init (Protector *protector)
Sets a protector object. The protector object must be in an initialized state.
virtual BOOLEAN | Lock ()
Overwrites the Lock methode of the base class and locks access to the provider.
ThreadSafeProvider (Protector *protector)
ThreadSafeProvider ()
virtual BOOLEAN | Unlock ()
Overwrites the Unlock methode of the base class and allows access to the provider.
virtual | ~ThreadSafeProvider ()

Detailed Description

ThreadSafeProvider is a Provider, which can protect a set of transactions from reentrance. All Providers which shall support this protection shall be derived from this base class. On initialization the provider has to provided with a protector object. This object can be shared between several provider.

Constructor & Destructor Documentation

ThreadSafeProvider::ThreadSafeProvider ( )

ThreadSafeProvider::ThreadSafeProvider ( Protector * protector )

Creates the provider and sets the protector object. The protector object must be in an initialized state.

ThreadSafeProvider::~ThreadSafeProvider ( ) [virtual]

Member Function Documentation

void ThreadSafeProvider::Init ( Protector * protector )

Sets a protector object. The protector object must be in an initialized state.

Reimplemented in CalendarProvider.

BOOLEAN ThreadSafeProvider::Lock ( ) [virtual]

Overwrites the Lock methode of the base class and locks access to the provider.

Reimplemented from Provider.

Reimplemented in PbRecordProvider.

BOOLEAN ThreadSafeProvider::Unlock ( ) [virtual]

Overwrites the Unlock methode of the base class and allows access to the provider.

Reimplemented from Provider.

Reimplemented in PbRecordProvider.

The documentation for this class was generated from the following files:
  • Auxiliary/ThreadSafeProvider.hpp
  • Auxiliary/ThreadSafeProvider.cpp
Generated on Wed Jan 25 02:11:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Ticks Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Ticks Class Reference
[Operating System]

Ticks is a convertion class between OS specific tick values and milliseconds. More...

#include <Apoxi/Kernel/Os/Nuc32/Ticks.hpp>

Public Member Functions

UINT32 | GetExpiredTime (const Ticks &ticks) const
UINT32 | GetExpiredTime () const
UINT32 | GetExpiredTime (const Ticks &ticks) const
UINT32 | GetExpiredTime () const
BOOLEAN | IsEmpty () const
BOOLEAN | IsEmpty () const
BOOLEAN | operator!= (const Ticks &ticks) const
BOOLEAN | operator!= (const Ticks &ticks) const
Ticks | operator+ (const Ticks &ticks) const
Ticks | operator+ (const Ticks &ticks) const
Ticks & | operator+= (const Ticks &ticks)
Ticks & | operator+= (const Ticks &ticks)
Ticks | operator- (const Ticks &ticks) const
Ticks | operator- (const Ticks &ticks) const
Ticks & | operator-= (const Ticks &ticks)
Ticks & | operator-= (const Ticks &ticks)
BOOLEAN | operator< (const Ticks &ticks) const
BOOLEAN | operator< (const Ticks &ticks) const
BOOLEAN | operator<= (const Ticks &ticks) const
BOOLEAN | operator<= (const Ticks &ticks) const
Ticks & | operator= (const Ticks &ticks)
Ticks & | operator= (const Ticks &ticks)
BOOLEAN | operator== (const Ticks &ticks) const
BOOLEAN | operator== (const Ticks &ticks) const
BOOLEAN | operator> (const Ticks &ticks) const
BOOLEAN | operator> (const Ticks &ticks) const
BOOLEAN | operator>= (const Ticks &ticks) const
BOOLEAN | operator>= (const Ticks &ticks) const
void | SetEmpty ()
void | SetEmpty ()
Ticks (const TickValue &tick_value)
Initialization with a TickValue object to set the tick value instead of milliseconds.
Ticks (const Ticks &ticks)
Initialization with another Ticks object.
Ticks (UINT32 ms)
Initialization with ms.
Ticks ()
Initialization with 0.
Ticks (const TickValue &tick_value)
Initialization with a TickValue object to set the tick value instead of milliseconds.
Ticks (const Ticks &ticks)
Initialization with another Ticks object.
Ticks (UINT32 ms)
Initialization with ms.
Ticks ()
Initialization with 0.

Static Public Member Functions

static Ticks | Infinite ()
static Ticks | Infinite ()

Friends

class | Os
class | Semaphore
class | SysSocket
class | Timer

Detailed Description

Ticks is a convertion class between OS specific tick values and milliseconds.

Constructor & Destructor Documentation

Ticks::Ticks ( ) [inline]

Initialization with 0.

Ticks::Ticks ( UINT32 ms ) [inline]

Initialization with ms.

Ticks::Ticks ( const Ticks & ticks ) [inline]

Initialization with another Ticks object.

Ticks::Ticks ( const TickValue & tick_value ) [inline, explicit]

Initialization with a TickValue object to set the tick value instead of milliseconds.

Ticks::Ticks ( ) [inline]

Initialization with 0.

Ticks::Ticks ( UINT32 ms ) [inline]

Initialization with ms.

Ticks::Ticks ( const Ticks & ticks ) [inline]

Initialization with another Ticks object.

Ticks::Ticks ( const TickValue & tick_value ) [inline, explicit]

Initialization with a TickValue object to set the tick value instead of milliseconds.

Member Function Documentation

UINT32 Ticks::GetExpiredTime ( const Ticks & ticks ) const [inline]

Returns:
Milliseconds of expired time till ticks.

UINT32 Ticks::GetExpiredTime ( ) const

Returns:
Milliseconds of expired time till now.

UINT32 Ticks::GetExpiredTime ( const Ticks & ticks ) const

Returns:
Milliseconds of expired time till ticks.

UINT32 Ticks::GetExpiredTime ( ) const

Returns:
Milliseconds of expired time till now.

static Ticks Ticks::Infinite ( ) [inline, static]

static Ticks Ticks::Infinite ( ) [inline, static]

BOOLEAN Ticks::IsEmpty ( ) const [inline]

BOOLEAN Ticks::IsEmpty ( ) const [inline]

BOOLEAN Ticks::operator!= ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator!= ( const Ticks & ticks ) const [inline]

Ticks Ticks::operator+ ( const Ticks & ticks ) const [inline]

Ticks Ticks::operator+ ( const Ticks & ticks ) const [inline]

Ticks& Ticks::operator+= ( const Ticks & ticks ) [inline]

Ticks& Ticks::operator+= ( const Ticks & ticks ) [inline]

Ticks Ticks::operator- ( const Ticks & ticks ) const [inline]

Ticks Ticks::operator- ( const Ticks & ticks ) const [inline]

Ticks& Ticks::operator-= ( const Ticks & ticks ) [inline]

Ticks& Ticks::operator-= ( const Ticks & ticks ) [inline]

BOOLEAN Ticks::operator< ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator< ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator<= ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator<= ( const Ticks & ticks ) const [inline]

Ticks& Ticks::operator= ( const Ticks & ticks ) [inline]

Ticks& Ticks::operator= ( const Ticks & ticks ) [inline]

BOOLEAN Ticks::operator== ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator== ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator> ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator> ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator>= ( const Ticks & ticks ) const [inline]

BOOLEAN Ticks::operator>= ( const Ticks & ticks ) const [inline]

void Ticks::SetEmpty ( ) [inline]

void Ticks::SetEmpty ( ) [inline]

Friends And Related Function Documentation

Os [friend]

Semaphore [friend]

SysSocket [friend]

Timer [friend]

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/Ticks.hpp
  • Kernel/Os/Win32/Ticks.hpp
  • Kernel/Os/Nuc32/Ticks.cpp
  • Kernel/Os/Win32/Ticks.cpp
Generated on Wed Jan 25 02:11:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TickValue Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TickValue Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/TickValue.hpp>

Public Member Functions

UINT32 | Get () const
void | Set (UINT32 tick_value)
TickValue (UINT32 tick_value)
TickValue ()

Detailed Description

Class TickValue is a helper class to store tick values into a Tick object.

Constructor & Destructor Documentation

TickValue::TickValue ( ) [inline]

TickValue::TickValue ( UINT32 tick_value ) [inline]

Member Function Documentation

UINT32 TickValue::Get ( ) const [inline]

void TickValue::Set ( UINT32 tick_value ) [inline]

The documentation for this class was generated from the following file:
  • Kernel/Os/TickValue.hpp
Generated on Wed Jan 25 02:11:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Time Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Time Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Time.hpp>

Public Types

enum | Format { TimeHM, TimeHMS }
Allowed formats for string representation of a Time. More...

Public Member Functions

INT | GetHour () const
Returns the hour value of the time object.
INT | GetMillisecond () const
Returns the millisecond value of the time object.
INT | GetMinute () const
Returns the minute value of the time object.
INT | GetSecond () const
Returns the second value of the time object.
WString | GetWString (const WCHAR *format) const
Returns the string representation defined in the WCHAR format string parameter.
WString | GetWString (Format time_format) const
Returns the string representation of the time object defined in the Format enumeration.
BOOLEAN | operator!= (const Time &time) const
Checks whether the time parameter is not identical to the object.
BOOLEAN | operator< (const Time &time) const
Checks whether the object is smaller than the time parameter object.
void | operator<< (const Time::Persist &time)
BOOLEAN | operator<= (const Time &time) const
Checks whether the object is smaller or equal than the time parameter object.
BOOLEAN | operator== (const Time &time) const
Checks whether the time parameter is identical to the object.
BOOLEAN | operator> (const Time &time) const
Checks whether the object is larger than the time parameter object.
BOOLEAN | operator>= (const Time &time) const
Checks whether the object is larger or equal than the time parameter object.
void | operator>> (Time::Persist &time) const
void | SetHour (INT hour)
Sets the hour value of the time object.
void | SetMillisecond (INT millisecond)
Sets the millisecond value of the time object.
void | SetMinute (INT minute)
Sets the minute value of the time object.
void | SetSecond (INT second)
Sets the second value of the time object.
Time (const Persist &tstruct)
Creates a time object of persistent struct.
Time (INT hour, INT minute, INT second=0, INT millisecond=0)
Creates a time object and initializes it with hour, minute and (optional) second, millisecond values.
Time ()
Creates a time object and initializes it with the current time of system.

Static Public Member Functions

static INT | Compare (const Time::Persist &t1, const Time::Persist &t2)
static INT | Compare (const Time &t1, const Time &t2)

Data Structures

struct | Persist

Detailed Description

Time is used to represent a time value consisting of hours, minutes and seconds.

Member Enumeration Documentation

enum Time::Format

Allowed formats for string representation of a Time.

Enumerator:
TimeHM | hour, minutes
TimeHMS | hour, minutes, seconds

Constructor & Destructor Documentation

Time::Time ( )

Creates a time object and initializes it with the current time of system.

Time::Time | ( | INT | hour,
 |  | INT | minute,
 |  | INT | second = 0,
 |  | INT | millisecond = 0
 | ) |

Creates a time object and initializes it with hour, minute and (optional) second, millisecond values.

Time::Time ( const Persist & tstruct )

Creates a time object of persistent struct.

Member Function Documentation

INT Time::Compare | ( | const Time::Persist & | t1,
 |  | const Time::Persist & | t2
 | ) | [static]

INT Time::Compare | ( | const Time & | t1,
 |  | const Time & | t2
 | ) | [static]

INT Time::GetHour ( ) const [inline]

Returns the hour value of the time object.

INT Time::GetMillisecond ( ) const [inline]

Returns the millisecond value of the time object.

INT Time::GetMinute ( ) const [inline]

Returns the minute value of the time object.

INT Time::GetSecond ( ) const [inline]

Returns the second value of the time object.

WString Time::GetWString ( const WCHAR * format ) const

Returns the string representation defined in the WCHAR format string parameter.

WString Time::GetWString ( Format time_format ) const

Returns the string representation of the time object defined in the Format enumeration.

BOOLEAN Time::operator!= ( const Time & time ) const

Checks whether the time parameter is not identical to the object.

BOOLEAN Time::operator< ( const Time & time ) const

Checks whether the object is smaller than the time parameter object.

void Time::operator<< ( const Time::Persist & time )

BOOLEAN Time::operator<= ( const Time & time ) const

Checks whether the object is smaller or equal than the time parameter object.

BOOLEAN Time::operator== ( const Time & time ) const

Checks whether the time parameter is identical to the object.

BOOLEAN Time::operator> ( const Time & time ) const

Checks whether the object is larger than the time parameter object.

BOOLEAN Time::operator>= ( const Time & time ) const

Checks whether the object is larger or equal than the time parameter object.

void Time::operator>> ( Time::Persist & time ) const

void Time::SetHour ( INT hour )

Sets the hour value of the time object.

void Time::SetMillisecond ( INT millisecond )

Sets the millisecond value of the time object.

void Time::SetMinute ( INT minute )

Sets the minute value of the time object.

void Time::SetSecond ( INT second )

Sets the second value of the time object.

The documentation for this class was generated from the following files:
  • Auxiliary/Time.hpp
  • Auxiliary/Time.cpp
Generated on Wed Jan 25 02:11:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Time::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Time::Persist

Time::Persist Struct Reference

#include <Apoxi/Auxiliary/Time.hpp>

Data Fields

UINT8 | m_hour
UINT8 | m_minute
UINT8 | m_second

Field Documentation

UINT8 Time::Persist::m_hour

UINT8 Time::Persist::m_minute

UINT8 Time::Persist::m_second

The documentation for this struct was generated from the following file:
  • Auxiliary/Time.hpp
Generated on Wed Jan 25 02:11:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeCompoundItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeCompoundItem Class Reference
[Editors]

Contains a time. More...

#include <Apoxi/Gui/TimeCompoundItem.hpp>

Inheritance diagram for TimeCompoundItem:

[legend]
Collaboration diagram for TimeCompoundItem:

[legend]

Public Types

enum | { ID = 7 }

Public Member Functions

virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT index, INT count) const
virtual INT | GetId () const
virtual INT | GetItemCount () const
virtual XYDIM | GetLineHeight (INT index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT index, INT count) const
const Time & | GetTime () const
virtual BOOLEAN | IsInstanceOf (INT id) const
void | SetTime (const Time &time)
virtual INT | WrapLine (INT index, XYDIM width, WrapPolicy wrap_policy=EditorDocument::WhitespaceWrap) const
virtual | ~TimeCompoundItem ()

Static Public Member Functions

static TimeCompoundItem * | CreateInstance (const Time &time=Time())
Creates and returns an object of this class.

Protected Member Functions

TimeCompoundItem (const Time &time=Time())

Detailed Description

Contains a time.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from CompoundItem.

Constructor & Destructor Documentation

TimeCompoundItem::~TimeCompoundItem ( ) [virtual]

TimeCompoundItem::TimeCompoundItem ( const Time & time = Time() ) [protected]

Member Function Documentation

TimeCompoundItem * TimeCompoundItem::CreateInstance ( const Time & time = Time() ) [static]

Creates and returns an object of this class.

void TimeCompoundItem::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::Draw

Implements CompoundItem.

INT TimeCompoundItem::GetId ( ) const [virtual]

See also:
CompoundItem::GetId()

Reimplemented from CompoundItem.

INT TimeCompoundItem::GetItemCount ( ) const [virtual]

See also:
CompoundItem::GetItemCount

Implements CompoundItem.

XYDIM TimeCompoundItem::GetLineHeight | ( | INT | index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
CompoundItem::GetLineHeight

Implements CompoundItem.

XYDIM TimeCompoundItem::GetLineWidth | ( | INT | index,
 |  | INT | count
 | ) | const [virtual]

See also:
CompoundItem::GetLineWidth

Implements CompoundItem.

const Time& TimeCompoundItem::GetTime ( ) const [inline]

BOOLEAN TimeCompoundItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from CompoundItem.

void TimeCompoundItem::SetTime ( const Time & time ) [inline]

INT TimeCompoundItem::WrapLine | ( | INT | index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = EditorDocument::WhitespaceWrap
 | ) | const [virtual]

See also:
CompoundItem::WrapLine

Implements CompoundItem.

The documentation for this class was generated from the following files:
  • Gui/TimeCompoundItem.hpp
  • Gui/TimeCompoundItem.cpp
Generated on Wed Jan 25 02:11:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeEditBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeEditBox Class Reference

Obsolete - use TimeEditor from Gui instead. More...

#include <Apoxi/Compat/TimeEditBox.hpp>

Inheritance diagram for TimeEditBox:

[legend]
Collaboration diagram for TimeEditBox:

[legend]

Public Member Functions

const WCHAR * | GetFormat () const
Time | GetTime () const
void | Init (Control *parent, Time::Format format=Time::TimeHM, const WCHAR *caption=0, CaptionPos caption_pos=CaptionOnTop)
virtual BOOLEAN | IsInputValid () const
void | SetFormat (const WCHAR *format)
void | SetFormat (Time::Format format)
void | SetTime (const Time &time) const
TimeEditBox (Control *parent, Time::Format format=Time::TimeHM, const WCHAR *caption=0, CaptionPos caption_pos=CaptionOnTop)
TimeEditBox ()
virtual | ~TimeEditBox ()

Protected Member Functions

virtual Model * | CreateModel () const
INT | GetHour () const
INT | GetMinute () const
INT | GetSecond () const
virtual const AbstractEditBoxView * | GetView () const
virtual void | MoveCursor (INT inc)
virtual void | OnDeleteChar ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)

Detailed Description

Obsolete - use TimeEditor from Gui instead.

Constructor & Destructor Documentation

TimeEditBox::TimeEditBox ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TimeEditBox::TimeEditBox | ( | Control * | parent,
 |  | Time::Format | format = Time::TimeHM,
 |  | const WCHAR * | caption = 0,
 |  | CaptionPos | caption_pos = CaptionOnTop
 | ) |

Parameters:
parent | Pointer to the window, which embedds the DateEditBox.
format | See Time::Format.
caption | Pointer to the caption.
caption_pos | See CaptionPosType.

TimeEditBox::~TimeEditBox ( ) [virtual]

Member Function Documentation

Model * TimeEditBox::CreateModel ( ) const [protected, virtual]

See also:
Component::CreateModel

Reimplemented from Component.

const WCHAR* TimeEditBox::GetFormat ( ) const [inline]

INT TimeEditBox::GetHour ( ) const [inline, protected]

INT TimeEditBox::GetMinute ( ) const [inline, protected]

INT TimeEditBox::GetSecond ( ) const [inline, protected]

Time TimeEditBox::GetTime ( ) const

const AbstractEditBoxView * TimeEditBox::GetView ( ) const [protected, virtual]

See also:
AbstractEditBox::GetView

Implements AbstractEditBox.

void TimeEditBox::Init | ( | Control * | parent,
 |  | Time::Format | format = Time::TimeHM,
 |  | const WCHAR * | caption = 0,
 |  | CaptionPos | caption_pos = CaptionOnTop
 | ) |

Parameters:
parent | Pointer to the window, which embedds the DateEditBox.
format | See Time::Format.
caption | Pointer to the caption.
caption_pos | See CaptionPosType.

BOOLEAN TimeEditBox::IsInputValid ( ) const [virtual]

See also:
AbstractEditBox::IsInputValid

Reimplemented from AbstractEditBox.

void TimeEditBox::MoveCursor ( INT inc ) [protected, virtual]

See also:
AbstractEditBox::MoveCursor

Reimplemented from AbstractEditBox.

void TimeEditBox::OnDeleteChar ( ) [protected, virtual]

See also:
AbstractEditBox::OnDeleteChar

Reimplemented from AbstractEditBox.

BOOLEAN TimeEditBox::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from Control.

void TimeEditBox::SetFormat ( const WCHAR * format )

void TimeEditBox::SetFormat ( Time::Format format )

void TimeEditBox::SetTime ( const Time & time ) const

The documentation for this class was generated from the following files:
  • Compat/TimeEditBox.hpp
  • Compat/TimeEditBox.cpp
Generated on Wed Jan 25 02:11:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeEditBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeEditBoxModel Class Reference

Describes the model of a time editbox. More...

#include <Apoxi/Compat/TimeEditBox.hpp>

Inheritance diagram for TimeEditBoxModel:

[legend]
Collaboration diagram for TimeEditBoxModel:

[legend]

Detailed Description

Describes the model of a time editbox.

The documentation for this class was generated from the following file:
  • Compat/TimeEditBox.hpp
Generated on Wed Jan 25 02:11:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeEditBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeEditBoxView Class Reference

Describes the view of a time editbox. More...

#include <Apoxi/Compat/TimeEditBox.hpp>

Inheritance diagram for TimeEditBoxView:

[legend]
Collaboration diagram for TimeEditBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
TimeEditBoxView (XYDIM line_height, XYDIM caption_gap, XYDIM caption_width, XYDIM caption_height, XYDIM frame_size, XYDIM default_width=-1, XYDIM default_height=-1)
TimeEditBoxView ()
virtual | ~TimeEditBoxView ()

Protected Member Functions

virtual void | DrawTimeEditBox (const TimeEditBoxModel &model, DeviceContext *dc, const Rect &repaint_rect) const

Detailed Description

Describes the view of a time editbox.

Constructor & Destructor Documentation

TimeEditBoxView::TimeEditBoxView ( )

TimeEditBoxView::TimeEditBoxView | ( | XYDIM | line_height,
 |  | XYDIM | caption_gap,
 |  | XYDIM | caption_width,
 |  | XYDIM | caption_height,
 |  | XYDIM | frame_size,
 |  | XYDIM | default_width = -1,
 |  | XYDIM | default_height = -1
 | ) |

TimeEditBoxView::~TimeEditBoxView ( ) [virtual]

Member Function Documentation

void TimeEditBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void TimeEditBoxView::DrawTimeEditBox | ( | const TimeEditBoxModel & | model,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, virtual]

Draws the data of a timeeditbox described by the model. Must be implemented in the corresponding theme view.

Parameters:
model | Model describing the data of a timeeditbox.
dc | Pointer to the device context, where the drawing should be done.
repaint_rect | Rectangle which indicates, where the repainting must be done.

The documentation for this class was generated from the following files:
  • Compat/TimeEditBox.hpp
  • Compat/TimeEditBox.cpp
Generated on Wed Jan 25 02:11:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeEditor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeEditor Class Reference
[Editors]

#include <Apoxi/Gui/TimeEditor.hpp>

Inheritance diagram for TimeEditor:

[legend]
Collaboration diagram for TimeEditor:

[legend]

Public Types

enum | { ID = 35 }

Public Member Functions

Time | GetTime () const
void | Init (Control *parent, const Time &time=Time())
virtual BOOLEAN | IsInstanceOf (INT id) const
virtual void | MoveCaret (INT steps)
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetTime (const Time &time)
TimeEditor (Control *parent, const Time &time=Time())
TimeEditor ()
virtual | ~TimeEditor ()

Protected Member Functions

virtual Model * | CreateModel () const

Detailed Description

Editor for editing a time in the format HH:MM.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from AbstractLineEditor.

Constructor & Destructor Documentation

TimeEditor::TimeEditor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

TimeEditor::TimeEditor | ( | Control * | parent,
 |  | const Time & | time = Time()
 | ) | [explicit]

Parameters:
parent | Pointer to the Control, which embedds the TimeEditor.
time | Value for Time which should be edited.

TimeEditor::~TimeEditor ( ) [virtual]

Member Function Documentation

Model * TimeEditor::CreateModel ( ) const [protected, virtual]

Factory method for creating a model. Must be implemented by every class, which needs it's own model. By default a component has no model and 0 is returned. If a model is dynamically created by 'new', it must be deleted in the destructor by e. g. delete GetModel();.

Returns:
Pointer to the model.

Reimplemented from Component.

Time TimeEditor::GetTime ( ) const

void TimeEditor::Init | ( | Control * | parent,
 |  | const Time & | time = Time()
 | ) |

Parameters:
parent | Pointer to the Control, which embedds the TimeEditor.
time | Value for Time which should be edited.

BOOLEAN TimeEditor::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from AbstractLineEditor.

void TimeEditor::MoveCaret ( INT steps ) [virtual]

See also:
AbstractEditor::MoveCaret()

Reimplemented from AbstractLineEditor.

BOOLEAN TimeEditor::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from AbstractLineEditor.

void TimeEditor::SetTime ( const Time & time )

The documentation for this class was generated from the following files:
  • Gui/TimeEditor.hpp
  • Gui/TimeEditor.cpp
Generated on Wed Jan 25 02:11:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeEditorDocument Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeEditorDocument Class Reference
[Editors]

A Time-Editor-Document contains a Time-Compound-Item. More...

#include <Apoxi/Gui/TimeEditorDocument.hpp>

Inheritance diagram for TimeEditorDocument:

[legend]
Collaboration diagram for TimeEditorDocument:

[legend]

Public Member Functions

virtual void | Draw (DeviceContext *dc, XYDIM x, XYDIM y, INT item_index, INT count) const
virtual const CompoundItem & | GetCompoundItem (INT item_index, INT *start_item_index=0) const
virtual INT | GetItemCount () const
virtual XYDIM | GetLineHeight (INT item_index, INT count, XYDIM *baseline=0) const
virtual XYDIM | GetLineWidth (INT item_index, INT count) const
virtual INT | GetMaxItemCount () const
const Time & | GetTime () const
void | Init (const Time &time)
virtual BOOLEAN | InsertItem (const AtomItem &item, INT item_index)
BOOLEAN | IsSeparator (INT item_index) const
virtual BOOLEAN | RemoveItem (INT item_index)
virtual BOOLEAN | ReplaceItem (const AtomItem &item, INT item_index)
void | SetTime (const Time &time)
TimeEditorDocument (const Time &time=Time())
virtual INT | WrapLine (INT item_index, XYDIM width, WrapPolicy wrap_policy=WhitespaceWrap) const
virtual | ~TimeEditorDocument ()

Detailed Description

A Time-Editor-Document contains a Time-Compound-Item.

Constructor & Destructor Documentation

TimeEditorDocument::TimeEditorDocument ( const Time & time = Time() )

TimeEditorDocument::~TimeEditorDocument ( ) [virtual]

Member Function Documentation

void TimeEditorDocument::Draw | ( | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | item_index,
 |  | INT | count
 | ) | const [virtual]

See also:
TimeEditorDocument::Draw()

Implements EditorDocument.

const CompoundItem & TimeEditorDocument::GetCompoundItem | ( | INT | item_index,
 |  | INT * | start_item_index = 0
 | ) | const [virtual]

See also:
EditorDocument::GetCompoundItem()

Implements EditorDocument.

INT TimeEditorDocument::GetItemCount ( ) const [virtual]

See also:
EditorDocument::GetItemCount()

Implements EditorDocument.

XYDIM TimeEditorDocument::GetLineHeight | ( | INT | item_index,
 |  | INT | count,
 |  | XYDIM * | baseline = 0
 | ) | const [virtual]

See also:
TimeEditorDocument::GetLineHeight()

Implements EditorDocument.

XYDIM TimeEditorDocument::GetLineWidth | ( | INT | item_index,
 |  | INT | count
 | ) | const [virtual]

See also:
TimeEditorDocument::GetLineWidth()

Implements EditorDocument.

INT TimeEditorDocument::GetMaxItemCount ( ) const [virtual]

See also:
EditorDocument::GetMaxItemCount()

Implements EditorDocument.

const Time & TimeEditorDocument::GetTime ( ) const

void TimeEditorDocument::Init ( const Time & time )

BOOLEAN TimeEditorDocument::InsertItem | ( | const AtomItem & | item,
 |  | INT | item_index
 | ) | [virtual]

See also:
EditorDocument::InsertItem()

Implements EditorDocument.

BOOLEAN TimeEditorDocument::IsSeparator ( INT item_index ) const

BOOLEAN TimeEditorDocument::RemoveItem ( INT item_index ) [virtual]

See also:
EditorDocument::RemoveItem()

Implements EditorDocument.

BOOLEAN TimeEditorDocument::ReplaceItem | ( | const AtomItem & | item,
 |  | INT | item_index
 | ) | [virtual]

See also:
EditorDocument::ReplaceItem()

Implements EditorDocument.

void TimeEditorDocument::SetTime ( const Time & time )

INT TimeEditorDocument::WrapLine | ( | INT | item_index,
 |  | XYDIM | width,
 |  | WrapPolicy | wrap_policy = WhitespaceWrap
 | ) | const [virtual]

See also:
TimeEditorDocument::WrapLine()

Implements EditorDocument.

The documentation for this class was generated from the following files:
  • Gui/TimeEditorDocument.hpp
  • Gui/TimeEditorDocument.cpp
Generated on Wed Jan 25 02:12:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeFeatureObject Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeFeatureObject Class Reference
[Audio]

#include <Apoxi/Audio/TimeFeatureObject.hpp>

Public Member Functions

virtual TimeFeatureObject * | Copy () const
Creates a copy of the object itself, must be overwritten in the derived class.
INT32 | GetChannelId () const
Get channel.
UINT32 | GetTimeStamp () const
Get time.
virtual GenericTypeId | GetTypeId ()
Returns the identity of the class.
virtual BOOLEAN | IsEqual (TimeFeatureObject *object)
Compares the object parameter with the object instance itself, must be overwritten in the derived class.
void | SetChannelId (INT32 channel)
Set channel.
void | SetTimeStamp (UINT32 time)
Set time.
TimeFeatureObject (const TimeFeatureObject &obj)
TimeFeatureObject ()
Constructor.
virtual | ~TimeFeatureObject ()
Destructor.

Static Public Attributes

static const GenericTypeId | c_time_feature_object_id = c_user_base_gentypes

Protected Attributes

INT32 | m_channel
channel
UINT32 | m_time
time

Constructor & Destructor Documentation

TimeFeatureObject::TimeFeatureObject ( )

Constructor.

TimeFeatureObject::TimeFeatureObject ( const TimeFeatureObject & obj )

TimeFeatureObject::~TimeFeatureObject ( ) [virtual]

Destructor.

Member Function Documentation

TimeFeatureObject * TimeFeatureObject::Copy ( ) const [virtual]

Creates a copy of the object itself, must be overwritten in the derived class.

INT32 TimeFeatureObject::GetChannelId ( ) const

Get channel.

UINT32 TimeFeatureObject::GetTimeStamp ( ) const

Get time.

GenericTypeId TimeFeatureObject::GetTypeId ( ) [virtual]

Returns the identity of the class.

BOOLEAN TimeFeatureObject::IsEqual ( TimeFeatureObject * object ) [virtual]

Compares the object parameter with the object instance itself, must be overwritten in the derived class.

void TimeFeatureObject::SetChannelId ( INT32 channel )

Set channel.

void TimeFeatureObject::SetTimeStamp ( UINT32 time )

Set time.

Field Documentation

const GenericTypeId TimeFeatureObject::c_time_feature_object_id = c_user_base_gentypes [static]

INT32 TimeFeatureObject::m_channel [protected]

channel

UINT32 TimeFeatureObject::m_time [protected]

time

The documentation for this class was generated from the following files:
  • Audio/TimeFeatureObject.hpp
  • Audio/TimeFeatureObject.cpp
Generated on Wed Jan 25 02:12:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeoutCondition Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeoutCondition Class Reference
[Kernel]

#include <Apoxi/Kernel/Condition.hpp>

Inheritance diagram for TimeoutCondition:

[legend]
Collaboration diagram for TimeoutCondition:

[legend]

Public Member Functions

void | Init (UINT32 timeout)
BOOLEAN | IsTimerExpired () const
TimeoutCondition (UINT32 timeout)
TimeoutCondition ()
virtual | ~TimeoutCondition ()

Friends

class | TriggerTimer< TimeoutCondition >

Detailed Description

BooleanCondition which can be set to TRUE manually and also by a timer which expires.

Constructor & Destructor Documentation

TimeoutCondition::TimeoutCondition ( )

TimeoutCondition::TimeoutCondition ( UINT32 timeout )

Initializes the condition with FALSE and sets the timeout period.

TimeoutCondition::~TimeoutCondition ( ) [virtual]

Member Function Documentation

void TimeoutCondition::Init ( UINT32 timeout )

Initializes the boolean-condition with FALSE and sets the timeout period.

BOOLEAN TimeoutCondition::IsTimerExpired ( ) const [inline]

Returns:
TRUE if the expiring timer was the reason for setting the condition to TRUE.

Friends And Related Function Documentation

friend class TriggerTimer< TimeoutCondition > [friend]

The documentation for this class was generated from the following files:
  • Kernel/Condition.hpp
  • Kernel/Condition.cpp
Generated on Wed Jan 25 02:12:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Timer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Timer Class Reference
[Kernel]

#include <Apoxi/Kernel/Timer.hpp>

Inheritance diagram for Timer:

[legend]
Collaboration diagram for Timer:

[legend]

Public Member Functions

UINT32 | GetTimeout ()
void | Init (UINT32 timeout, BOOLEAN autotimer=FALSE)
BOOLEAN | IsActive () const
BOOLEAN | operator< (const Timer &timer) const
void | Restart ()
void | Resume ()
void | SetTimeout (UINT32 timeout)
void | Start ()
UINT32 | Stop ()
Timer (UINT32 timeout, BOOLEAN autotimer=FALSE)
Timer ()
virtual | ~Timer ()

Protected Member Functions

virtual void | OnTimer ()

Protected Attributes

ExecutionContext * m_context

Friends

class | Animation
class | AppContainer
class | Application
class | ServiceThread

Detailed Description

A timer can be started, stopped, resumed and restarted. It has a timeout-value, which fires a timer-message after exceeding. A timer always belongs to an application and may not be shared.

Constructor & Destructor Documentation

Timer::Timer ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

Timer::Timer | ( | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

Parameters:
timeout | Timeout in milliseconds.
autotimer | If TRUE, the timer will be restarted automatically after expiring.

Timer::~Timer ( ) [virtual]

Member Function Documentation

UINT32 Timer::GetTimeout ( ) [inline]

Returns the timeout-value of the timer.

void Timer::Init | ( | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) |

Parameters:
timeout | Timeout in milliseconds.
autotimer | If TRUE, the timer will be restarted automatically.

Reimplemented in SharedTimer.

BOOLEAN Timer::IsActive ( ) const [inline]

Returns the status (running or not) of the timer.

void Timer::OnTimer ( ) [protected, virtual]

Is called, if the timout-value of the timer expired. In the default implementation of this method the message TimerTimeoutMsg is sent.

Reimplemented in LcsRepeatTimer, LcsTimer, TriggerTimer< T >, EditBoxBlinkTimer, Animation, EditBoxPagingTimer, SharedTriggerTimer< T >, TriggerTimer< ImageBox >, TriggerTimer< SocketTestProgressWin >, TriggerTimer< MultiTapInputMapper >, TriggerTimer< SvgPlayer >, TriggerTimer< DefaultCaret >, TriggerTimer< AbstractItemGrid >, TriggerTimer< AnimatedTextLine >, TriggerTimer< SocketTestApp >, TriggerTimer< ItemBox >, TriggerTimer< TimeoutCondition >, and TriggerTimer< FfsTestDispWin >.

BOOLEAN Timer::operator< ( const Timer & timer ) const

void Timer::Restart ( )

Reimplemented in SharedTimer.

void Timer::Resume ( )

Reimplemented in AudioActiveReference, and SharedTimer.

void Timer::SetTimeout ( UINT32 timeout )

Specifies the timeout-value, until the timer expires. After exceeding OnTimer is invoked.

void Timer::Start ( )

Starts the timer.

Reimplemented in LcsRepeatTimer, LcsTimer, Animation, and SharedTimer.

UINT32 Timer::Stop ( )

Stops the timer and returns the remaining time to the expiration of the timer (in milliseconds)

Reimplemented in AudioActiveReference, and SharedTimer.

Friends And Related Function Documentation

friend class Animation [friend]

friend class AppContainer [friend]

friend class Application [friend]

friend class ServiceThread [friend]

Field Documentation

ExecutionContext* Timer::m_context [protected]

The documentation for this class was generated from the following files:
  • Kernel/Timer.hpp
  • Kernel/Timer.cpp
Generated on Wed Jan 25 02:12:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimerTimeoutMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimerTimeoutMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for TimerTimeoutMsg:

[legend]
Collaboration diagram for TimerTimeoutMsg:

[legend]

Public Types

enum | { ID = 300 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
Timer * | GetTimer () const
void | SetTimer (Timer *timer)
TimerTimeoutMsg (ExecutionContext *context, Timer *timer)
virtual | ~TimerTimeoutMsg ()

Detailed Description

This message is sent secondary when a AxeTimer times out. Arguments: args[0].t_void ... pointer to the timed out AxeTimer

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

TimerTimeoutMsg::TimerTimeoutMsg | ( | ExecutionContext * | context,
 |  | Timer * | timer
 | ) |

TimerTimeoutMsg::~TimerTimeoutMsg ( ) [virtual]

Member Function Documentation

Message * TimerTimeoutMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & TimerTimeoutMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

Timer* TimerTimeoutMsg::GetTimer ( ) const [inline]

void TimerTimeoutMsg::SetTimer ( Timer * timer ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 02:12:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeSpan Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeSpan Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/TimeSpan.hpp>

Public Member Functions

UINT32 | GetAbsoluteDays () const
Returns the absolute days of the time period.
UINT32 | GetAbsoluteHours () const
Returns the absolute hours of the time period.
UINT32 | GetAbsoluteMinutes () const
Returns the absolute minutes of the time period.
UINT32 | GetAbsoluteSeconds () const
Returns the seconds of the time period.
UINT32 | GetAbsoluteWeeks () const
Returns the absolute weeks of the time period.
UINT | GetHour () const
Returns the relative hours of the time period.
UINT | GetMinute () const
Returns the relative minutes of the time period.
UINT | GetSecond () const
Returns the relative seconds of the time period.
void | SetAbsoluteDays (UINT days)
Sets the seconds value of a TimeSpan object by given days.
void | SetAbsoluteHours (UINT hours)
Sets the seconds value of a TimeSpan object by given hours.
void | SetAbsoluteMinutes (UINT minutes)
Sets the seconds value of a TimeSpan object by given minutes.
void | SetAbsoluteSeconds (UINT32 seconds)
Sets the seconds value of a TimeSpan object.
void | SetAbsoluteWeeks (UINT days)
Sets the seconds value of a TimeSpan object by given weeks.
TimeSpan (UINT hours, UINT minutes, UINT seconds=0)
TimeSpan (UINT32 seconds)
Constructs a TimeSpan object and initializes it with seconds.
TimeSpan ()
Constructs an zeroed TimeSpan object.

Detailed Description

TimeSpan is used to represent a time period in seconds.

Constructor & Destructor Documentation

TimeSpan::TimeSpan ( ) [inline]

Constructs an zeroed TimeSpan object.

TimeSpan::TimeSpan ( UINT32 seconds ) [inline]

Constructs a TimeSpan object and initializes it with seconds.

TimeSpan::TimeSpan | ( | UINT | hours,
 |  | UINT | minutes,
 |  | UINT | seconds = 0
 | ) |

Constructs a TimeSpan object with hours and minutes and optional seconds. The values are absolut values and no relative values like in the Time object.

Member Function Documentation

UINT32 TimeSpan::GetAbsoluteDays ( ) const

Returns the absolute days of the time period.

UINT32 TimeSpan::GetAbsoluteHours ( ) const

Returns the absolute hours of the time period.

UINT32 TimeSpan::GetAbsoluteMinutes ( ) const

Returns the absolute minutes of the time period.

UINT32 TimeSpan::GetAbsoluteSeconds ( ) const [inline]

Returns the seconds of the time period.

UINT32 TimeSpan::GetAbsoluteWeeks ( ) const

Returns the absolute weeks of the time period.

UINT TimeSpan::GetHour ( ) const

Returns the relative hours of the time period.

UINT TimeSpan::GetMinute ( ) const

Returns the relative minutes of the time period.

UINT TimeSpan::GetSecond ( ) const

Returns the relative seconds of the time period.

void TimeSpan::SetAbsoluteDays ( UINT days )

Sets the seconds value of a TimeSpan object by given days.

void TimeSpan::SetAbsoluteHours ( UINT hours )

Sets the seconds value of a TimeSpan object by given hours.

void TimeSpan::SetAbsoluteMinutes ( UINT minutes )

Sets the seconds value of a TimeSpan object by given minutes.

void TimeSpan::SetAbsoluteSeconds ( UINT32 seconds ) [inline]

Sets the seconds value of a TimeSpan object.

void TimeSpan::SetAbsoluteWeeks ( UINT days )

Sets the seconds value of a TimeSpan object by given weeks.

The documentation for this class was generated from the following files:
  • Auxiliary/TimeSpan.hpp
  • Auxiliary/TimeSpan.cpp
Generated on Wed Jan 25 02:12:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeZone Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeZone Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/TimeZone.hpp>

Public Types

enum | { InvalidOffset = 0xffff }
enum | DstIndication { StandardTime = 0, Plus1Hour = 1, Plus2Hours = 2, InvalidDst = 3 }

Public Member Functions

WString | Format (const WCHAR *wchr_format=L"GMT: %o DST: %d", const WCHAR *wchr_invalid_offset=L"n/a", const WCHAR *wchr_invalid_dst=L"n/a") const
DstIndication | GetDstInd () const
INT | GetOffset () const
BOOLEAN | IsDstIndInvalid () const
BOOLEAN | IsOffsetInvalid () const
BOOLEAN | operator!= (const TimeZone &tz) const
BOOLEAN | operator== (const TimeZone &tz) const
void | SetDstInd (DstIndication dst_ind)
void | SetOffset (INT offset)
void | SetTimeZone (const TimeZone &tz)
TimeZone (const TimeZone &tz)
TimeZone (INT offset, DstIndication dst_ind)
TimeZone ()
Creates a TimeZone object with current Time Zone values.
~TimeZone ()

Member Enumeration Documentation

anonymous enum

Enumerator:
InvalidOffset

enum TimeZone::DstIndication

Enumerator:
StandardTime
Plus1Hour
Plus2Hours
InvalidDst

Constructor & Destructor Documentation

TimeZone::TimeZone ( )

Creates a TimeZone object with current Time Zone values.

TimeZone::TimeZone | ( | INT | offset,
 |  | DstIndication | dst_ind
 | ) | [inline]

TimeZone::TimeZone ( const TimeZone & tz )

TimeZone::~TimeZone ( ) [inline]

Member Function Documentation

WString TimeZone::Format | ( | const WCHAR * | wchr_format = L"GMT: %o DST: %d",
 |  | const WCHAR * | wchr_invalid_offset = L"n/a",
 |  | const WCHAR * | wchr_invalid_dst = L"n/a"
 | ) | const

Formats a TimeZoneString by setting tokens for offset (o) and dst (d) restrictions: token o is mandatory and must preceed optional token d !! and replace invalid values with set characters e.g.: Format(L"GMT(o) DST(d)",L"-",L"n/a") may have following output, when dst is invalid: GMT(+13:15) DST(n/a)

DstIndication TimeZone::GetDstInd ( ) const [inline]

INT TimeZone::GetOffset ( ) const [inline]

BOOLEAN TimeZone::IsDstIndInvalid ( ) const [inline]

BOOLEAN TimeZone::IsOffsetInvalid ( ) const [inline]

BOOLEAN TimeZone::operator!= ( const TimeZone & tz ) const [inline]

BOOLEAN TimeZone::operator== ( const TimeZone & tz ) const [inline]

void TimeZone::SetDstInd ( DstIndication dst_ind ) [inline]

void TimeZone::SetOffset ( INT offset ) [inline]

void TimeZone::SetTimeZone ( const TimeZone & tz )

The documentation for this class was generated from the following files:
  • Auxiliary/TimeZone.hpp
  • Auxiliary/TimeZone.cpp
Generated on Wed Jan 25 02:12:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeZoneAndTime Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeZoneAndTime Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Data Fields

UINT8 A [SDL_INTEGER_LIT(6)+1]

Field Documentation

UINT8 TimeZoneAndTime::A[SDL_INTEGER_LIT(6)+1]

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 02:12:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TimeZoneMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TimeZoneMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for TimeZoneMsg:

[legend]
Collaboration diagram for TimeZoneMsg:

[legend]

Public Types

enum | { ID = 18602 }

Public Member Functions

virtual Message * | Clone () const
const DateTime & | GetDatetime () const
virtual const MsgMetaData & | GetMetaData () const
void | SetDatetime (const DateTime &datetime)
TimeZoneMsg (const DateTime &datetime)
virtual | ~TimeZoneMsg ()

Detailed Description

TimeZoneMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

TimeZoneMsg::TimeZoneMsg ( const DateTime & datetime )

TimeZoneMsg::~TimeZoneMsg ( ) [virtual]

Member Function Documentation

Message * TimeZoneMsg::Clone ( ) const [virtual]

Implements Message.

const DateTime& TimeZoneMsg::GetDatetime ( ) const [inline]

const MsgMetaData & TimeZoneMsg::GetMetaData ( ) const [virtual]

Implements Message.

void TimeZoneMsg::SetDatetime ( const DateTime & datetime ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:12:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TipdBasedActiveWaitDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TipdBasedActiveWaitDispatcher Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/TipdBasedActiveWaitDispatcher.hpp>

Inheritance diagram for TipdBasedActiveWaitDispatcher:

[legend]
Collaboration diagram for TipdBasedActiveWaitDispatcher:

[legend]

Public Types

enum | AbortCause { UserAbort, RemoteAbort, NotSpecified }

Public Member Functions

virtual void | AbortIfEqualTipd (Tipd tipd, AbortCause cause=NotSpecified)
AbortCause | GetAbortCause () const
Returns the cause for the abort of the active wait loop.
BOOLEAN | IsEqualTipd (Tipd tipd) const
TipdBasedActiveWaitDispatcher (Tipd tipd)
virtual | ~TipdBasedActiveWaitDispatcher ()

Protected Member Functions

Tipd | GetTipd () const
Getter method for the Tipd of the respective transaction.
void | SetTipd (Tipd tipd)
Setter method vor the Tipd of the respective transaction.

Detailed Description

is a StackMsgActiveWaitDispatcher which keeps the Tipd of the transaction for which the dispatcher is instanciated for. Typical transactions are voice calls, and call independent supplementary services.

Member Enumeration Documentation

enum TipdBasedActiveWaitDispatcher::AbortCause

Enumerator:
UserAbort
RemoteAbort
NotSpecified

Constructor & Destructor Documentation

TipdBasedActiveWaitDispatcher::TipdBasedActiveWaitDispatcher ( Tipd tipd )

Parameters:
tipd Holds the Tipd of the respective call/suppl. service

virtual TipdBasedActiveWaitDispatcher::~TipdBasedActiveWaitDispatcher ( ) [inline, virtual]

Member Function Documentation

void TipdBasedActiveWaitDispatcher::AbortIfEqualTipd | ( | Tipd | tipd,
 |  | AbortCause | cause = NotSpecified
 | ) | [virtual]

Aborts active wait dispatcher only if argument tipd is equal to the tipd of the transaction the acive wait dispatcher is intended for. The AbortCause is set to NotSpecifed.

AbortCause TipdBasedActiveWaitDispatcher::GetAbortCause ( ) const [inline]

Returns the cause for the abort of the active wait loop.

Tipd TipdBasedActiveWaitDispatcher::GetTipd ( ) const [inline, protected]

Getter method for the Tipd of the respective transaction.

BOOLEAN TipdBasedActiveWaitDispatcher::IsEqualTipd ( Tipd tipd ) const [inline]

Returns TRUE if given tipd is equal to the tipd of the transaction of th active wait dispatcher is intended for.

void TipdBasedActiveWaitDispatcher::SetTipd ( Tipd tipd ) [inline, protected]

Setter method vor the Tipd of the respective transaction.

The documentation for this class was generated from the following files:
  • Asc/TipdBasedActiveWaitDispatcher.hpp
  • Asc/TipdBasedActiveWaitDispatcher.cpp
Generated on Wed Jan 25 02:12:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Tlv Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Tlv Class Reference

Simple TLV (TagLengthValue) objects - GSM 11.14 [12]. More...

#include <Apoxi/Apc/Tlv.hpp>

Public Types

enum | LengthCoding { OneByte = 1, TwoByte = 2 }
enum Tag {
UndefinedTag = 0x00, AlphaIdentifierTag = 0x05, TextStringTag = 0x0D, ItemTag = 0x0F,
ItemIdentifierTag = 0x10, ItemsNaiTag = 0x18, IconIdentifierTag = 0x1E, ItemIconIdentifierListTag = 0x1F
}
TLV tag id - GSM 11.14 [13.3], matches bits 6..0 of the incoming tag byte. More...

Public Member Functions

INT | GetStreamSize () const
size is calculated of the length of value + tag-size + length-size
Tag | GetTag () const
INT | GetValLen () const
const TlvAtom * | GetValPtr () const
BOOLEAN | IsComprehensionRequired () const
matches bit 7 of the incoming tag byte, only of interest, if the tag is unknown (see GSM 11.14 [6.10.4])
Tlv & | operator= (const Tlv &tlv)
Tlv (const Tlv &tlv)
Tlv (const Tag tag, const INT val_len=0, const TlvAtom *val_data=0)
Tlv (const TlvAtom *byte_stream=0, const LengthCoding len_coding=OneByte)
virtual | ~Tlv ()

Detailed Description

Simple TLV (TagLengthValue) objects - GSM 11.14 [12].

Member Enumeration Documentation

enum Tlv::LengthCoding

Enumerator:
OneByte
TwoByte

enum Tlv::Tag

TLV tag id - GSM 11.14 [13.3], matches bits 6..0 of the incoming tag byte.

Enumerator:
UndefinedTag
AlphaIdentifierTag
TextStringTag
ItemTag
ItemIdentifierTag
ItemsNaiTag
IconIdentifierTag
ItemIconIdentifierListTag

Constructor & Destructor Documentation

Tlv::Tlv | ( | const TlvAtom * | byte_stream = 0,
 |  | const LengthCoding | len_coding = OneByte
 | ) |

Tlv::Tlv | ( | const Tag | tag,
 |  | const INT | val_len = 0,
 |  | const TlvAtom * | val_data = 0
 | ) |

Tlv::Tlv ( const Tlv & tlv )

Tlv::~Tlv ( ) [virtual]

Member Function Documentation

INT Tlv::GetStreamSize ( ) const [inline]

size is calculated of the length of value + tag-size + length-size

Tag Tlv::GetTag ( ) const [inline]

INT Tlv::GetValLen ( ) const [inline]

const TlvAtom* Tlv::GetValPtr ( ) const [inline]

BOOLEAN Tlv::IsComprehensionRequired ( ) const [inline]

matches bit 7 of the incoming tag byte, only of interest, if the tag is unknown (see GSM 11.14 [6.10.4])

Tlv & Tlv::operator= ( const Tlv & tlv )

The documentation for this class was generated from the following files:
  • Apc/Tlv.hpp
  • Apc/Tlv.cpp
Generated on Wed Jan 25 02:12:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TMsapPackedDataArray Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TMsapPackedDataArray Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

byte val [256]

Field Documentation

byte TMsapPackedDataArray::val[256]

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 02:12:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToDoApp Class Reference

#include <Applications/ToDo/ToDoApp.hpp>

Collaboration diagram for ToDoApp:

[legend]

Public Member Functions

virtual | ~ToDoApp ()
Destructor.

Static Public Member Functions

static ToDoApp * | GetInstance ()

Protected Member Functions

virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnStartup ()

Constructor & Destructor Documentation

ToDoApp::~ToDoApp ( ) [virtual]

Destructor.

Member Function Documentation

ToDoApp * ToDoApp::GetInstance ( ) [static]

Returns:
the singleton istance of the ToDoPlugin

BOOLEAN ToDoApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN ToDoApp::OnMessage ( const Message & msg ) [protected, virtual]

void ToDoApp::OnOpen ( ) [protected, virtual]

void ToDoApp::OnStartup ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/ToDo/ToDoApp.hpp
  • Applications/ToDo/ToDoApp.cpp
Generated on Wed Jan 25 02:12:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoComposeWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToDoComposeWin Class Reference

#include <Applications/ToDo/ToDoComposeWin.hpp>

Collaboration diagram for ToDoComposeWin:

[legend]

Public Member Functions

void | Clean ()
virtual EditorDocumentObtainer | GetDocumentObtainer () const
virtual AbstractPredictiveInputBox * | GetPredInputBox ()
ToDoApp * | GetToDoApplication () const
void | Init (ToDoApp *todo_app)
void | OnClose ()
virtual void | OnInputModeChanged (PredInputMapper::PredMode mode)
void | SetDateDisplay (Date date)
virtual void | SetDocumentObtainer (const EditorDocumentObtainer &obtainer)
void | SetNoteDisplay (WCHAR *note)
void | SetProrityDisplay (INT priority)
void | SetReadOnlyMode (BOOLEAN read_only)
ToDoComposeWin ()
virtual | ~ToDoComposeWin ()

Protected Member Functions

virtual void | OnLayoutClient ()

Constructor & Destructor Documentation

ToDoComposeWin::ToDoComposeWin ( )

ToDoComposeWin::~ToDoComposeWin ( ) [virtual]

Member Function Documentation

void ToDoComposeWin::Clean ( )

EditorDocumentObtainer ToDoComposeWin::GetDocumentObtainer ( ) const [virtual]

AbstractPredictiveInputBox * ToDoComposeWin::GetPredInputBox ( ) [virtual]

ToDoApp* ToDoComposeWin::GetToDoApplication ( ) const [inline]

void ToDoComposeWin::Init ( ToDoApp * todo_app )

void ToDoComposeWin::OnClose ( )

void ToDoComposeWin::OnInputModeChanged ( PredInputMapper::PredMode mode ) [virtual]

void ToDoComposeWin::OnLayoutClient ( ) [protected, virtual]

void ToDoComposeWin::SetDateDisplay ( Date date )

void ToDoComposeWin::SetDocumentObtainer ( const EditorDocumentObtainer & obtainer ) [virtual]

void ToDoComposeWin::SetNoteDisplay ( WCHAR * note )

void ToDoComposeWin::SetProrityDisplay ( INT priority )

void ToDoComposeWin::SetReadOnlyMode ( BOOLEAN read_only )

The documentation for this class was generated from the following files:
  • Applications/ToDo/ToDoComposeWin.hpp
  • Applications/ToDo/ToDoComposeWin.cpp
Generated on Wed Jan 25 02:12:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoDateDialogWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToDoDateDialogWin Class Reference

#include <Applications/ToDo/ToDoDialogWin.hpp>

Collaboration diagram for ToDoDateDialogWin:

[legend]

Public Member Functions

void | Clean ()
DateEditor * GetDate ()
void | Init ()
virtual BOOLEAN | OnCancel ()
BOOLEAN | OnConfirm ()
void | OnLayoutClient ()
void | OnOpen ()
void | SetDate (Date date)
ToDoDateDialogWin ()
virtual | ~ToDoDateDialogWin ()

Constructor & Destructor Documentation

ToDoDateDialogWin::ToDoDateDialogWin ( )

ToDoDateDialogWin::~ToDoDateDialogWin ( ) [virtual]

Member Function Documentation

void ToDoDateDialogWin::Clean ( )

DateEditor * ToDoDateDialogWin::GetDate ( )

void ToDoDateDialogWin::Init ( )

BOOLEAN ToDoDateDialogWin::OnCancel ( ) [virtual]

BOOLEAN ToDoDateDialogWin::OnConfirm ( )

void ToDoDateDialogWin::OnLayoutClient ( )

void ToDoDateDialogWin::OnOpen ( )

void ToDoDateDialogWin::SetDate ( Date date )

The documentation for this class was generated from the following files:
  • Applications/ToDo/ToDoDialogWin.hpp
  • Applications/ToDo/ToDoDialogWin.cpp
Generated on Wed Jan 25 02:12:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoListWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToDoListWin Class Reference
[ToDoListWin, ToDoListWin]

This class declares a new kind of window derived from class MmiItemListWindow. More...

#include <Applications/ToDo/ToDoListWin.hpp>

Collaboration diagram for ToDoListWin:

[legend]

Public Member Functions

INT | GetSelectedIndex ()
void | Init (Dispatcher *dispatcher, Provider *provider=0)
ToDoListWin ()
void | UpdateProvider ()
virtual | ~ToDoListWin ()

Protected Member Functions

virtual void | OnClose ()
virtual void | OnGetFocus ()
BOOLEAN | OnMessage (const Message &message)
virtual void | OnOpen ()
void | OnSelectionChanged (INT selected_index)

Detailed Description

This class declares a new kind of window derived from class MmiItemListWindow.

Constructor & Destructor Documentation

ToDoListWin::ToDoListWin ( )

ToDoListWin::~ToDoListWin ( ) [virtual]

Member Function Documentation

INT ToDoListWin::GetSelectedIndex ( ) [inline]

void ToDoListWin::Init | ( | Dispatcher * | dispatcher,
 |  | Provider * | provider = 0
 | ) |

Parameters:
dispatcher | the dispatcher associated with the window
provider | it is the ProviderProxyContainer associated with the window

void ToDoListWin::OnClose ( ) [protected, virtual]

void ToDoListWin::OnGetFocus ( ) [protected, virtual]

BOOLEAN ToDoListWin::OnMessage ( const Message & message ) [protected]

void ToDoListWin::OnOpen ( ) [protected, virtual]

void ToDoListWin::OnSelectionChanged ( INT selected_index ) [protected]

void ToDoListWin::UpdateProvider ( )

The documentation for this class was generated from the following files:
  • Applications/ToDo/ToDoListWin.hpp
  • Applications/ToDo/ToDoListWin.cpp
Generated on Wed Jan 25 02:12:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoPriorityDialogWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToDoPriorityDialogWin Class Reference

#include <Applications/ToDo/ToDoDialogWin.hpp>

Collaboration diagram for ToDoPriorityDialogWin:

[legend]

Public Member Functions

INT | GetPriority ()
void | Init ()
BOOLEAN | OnConfirm ()
void | OnOpen ()
void | SetPriority (ToDoRecord::ToDoRecProrityLevel priority)

Member Function Documentation

INT ToDoPriorityDialogWin::GetPriority ( ) [inline]

void ToDoPriorityDialogWin::Init ( )

BOOLEAN ToDoPriorityDialogWin::OnConfirm ( )

void ToDoPriorityDialogWin::OnOpen ( )

void ToDoPriorityDialogWin::SetPriority ( ToDoRecord::ToDoRecProrityLevel priority )

The documentation for this class was generated from the following files:
  • Applications/ToDo/ToDoDialogWin.hpp
  • Applications/ToDo/ToDoDialogWin.cpp
Generated on Wed Jan 25 02:12:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToDoProvider Class Reference

#include <Applications/ToDo/ToDoProvider.hpp>

Inheritance diagram for ToDoProvider:

[legend]
Collaboration diagram for ToDoProvider:

[legend]

Public Member Functions

BOOLEAN | AppendRow ()
Append a row.
BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
BOOLEAN | DeleteAllRows ()
BOOLEAN | DeleteEntry (INT recno)
BOOLEAN | DeleteRow (INT row)
Delete the specified row.
BOOLEAN | ExistsRecord (INT row)
BOOLEAN | GetDataItem (INT column, INT row, DataItem &item)
GetDataItem reads data items
BOOLEAN | GetDataRecord (INT row, ToDoRecord *record)
INT | GetProviderId () const
Returns the provider id.
void | Init ()
INT | MaxRowCount ()
MaxRowCount returns the maximal number of rows.
void | RestoreFactorySettings ()
INT | RowCount ()
RowCount returns the number of rows.
BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
BOOLEAN | SetDataItem (const DataItem &item, INT column_id)
ToDoProvider ()
~ToDoProvider ()

Constructor & Destructor Documentation

ToDoProvider::ToDoProvider ( )

ToDoProvider::~ToDoProvider ( )

Member Function Documentation

BOOLEAN ToDoProvider::AppendRow ( ) [virtual]

Append a row.

Reimplemented from Provider.

BOOLEAN ToDoProvider::CommitRow ( INT row ) [virtual]

Commit updates done in a row.

Reimplemented from Provider.

BOOLEAN ToDoProvider::DeleteAllRows ( )

BOOLEAN ToDoProvider::DeleteEntry ( INT recno )

BOOLEAN ToDoProvider::DeleteRow ( INT row ) [virtual]

Delete the specified row.

Reimplemented from Provider.

BOOLEAN ToDoProvider::ExistsRecord ( INT row )

BOOLEAN ToDoProvider::GetDataItem | ( | INT | column,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

GetDataItem reads data items

Implements Provider.

BOOLEAN ToDoProvider::GetDataRecord | ( | INT | row,
 |  | ToDoRecord * | record
 | ) |

INT ToDoProvider::GetProviderId ( ) const [inline, virtual]

Returns the provider id.

Implements Provider.

void ToDoProvider::Init ( )

INT ToDoProvider::MaxRowCount ( ) [inline, virtual]

MaxRowCount returns the maximal number of rows.

Reimplemented from Provider.

void ToDoProvider::RestoreFactorySettings ( ) [virtual]

Implements SettingsProvider.

INT ToDoProvider::RowCount ( ) [virtual]

RowCount returns the number of rows.

Reimplemented from SettingsProvider.

BOOLEAN ToDoProvider::SelectRow ( INT row ) [virtual]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN ToDoProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | column_id
 | ) | [virtual]

Reimplemented from Provider.

The documentation for this class was generated from the following files:
  • Applications/ToDo/ToDoProvider.hpp
  • Applications/ToDo/ToDoProvider.cpp
Generated on Wed Jan 25 02:12:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToDoRecord Class Reference
[Settings]

#include <Applications/ToDo/ToDoRecord.hpp>

Inheritance diagram for ToDoRecord:

[legend]
Collaboration diagram for ToDoRecord:

[legend]

Public Types

enum | ToDoRecMarkLevel { unmarked = 0, marked = 1 }
enum | ToDoRecProrityLevel { Low = 0, Medium = 1, High = 2, PriorityCount = 3 }
enum | Type { Deleted = 0, Used = 1 }

Public Member Functions

virtual const UINT8 * | GetData ()
virtual INT | GetPersistentSize ()
Type | GetType () const
BOOLEAN | IsRecordDeleted ()
void | MarkDeleted ()
virtual void | SetData (const UINT8 *data)
void | SetType (Type type)
ToDoRecord (Type type=Deleted, ToDoRecProrityLevel priorityLevel=Low, Date toDoListDateTime=Date::Today, ToDoRecMarkLevel markLevel=unmarked, WString note=L"\0")

Data Fields

ToDoRecord::Persist m_data

Data Structures

struct | Persist

Member Enumeration Documentation

enum ToDoRecord::ToDoRecMarkLevel

Enumerator:
unmarked
marked

enum ToDoRecord::ToDoRecProrityLevel

Enumerator:
Low
Medium
High
PriorityCount

enum ToDoRecord::Type

Enumerator:
Deleted
Used

Constructor & Destructor Documentation

ToDoRecord::ToDoRecord | ( | Type | type = Deleted,
 |  | ToDoRecProrityLevel | priorityLevel = Low,
 |  | Date | toDoListDateTime = Date::Today,
 |  | ToDoRecMarkLevel | markLevel = unmarked,
 |  | WString | note = L"\0"
 | ) |

Member Function Documentation

const UINT8 * ToDoRecord::GetData ( ) [virtual]

Implements Record.

INT ToDoRecord::GetPersistentSize ( ) [virtual]

Implements Record.

Type ToDoRecord::GetType ( ) const [inline]

BOOLEAN ToDoRecord::IsRecordDeleted ( ) [virtual]

Reimplemented from Record.

void ToDoRecord::MarkDeleted ( ) [virtual]

Reimplemented from Record.

void ToDoRecord::SetData ( const UINT8 * data ) [virtual]

Implements Record.

void ToDoRecord::SetType ( Type type ) [inline]

Field Documentation

struct ToDoRecord::Persist ToDoRecord::m_data

The documentation for this class was generated from the following files:
  • Applications/ToDo/ToDoRecord.hpp
  • Applications/ToDo/ToDoRecord.cpp
Generated on Wed Jan 25 02:12:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoRecord::Persist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ToDoRecord::Persist

ToDoRecord::Persist Struct Reference

#include <Applications/ToDo/ToDoRecord.hpp>

Collaboration diagram for ToDoRecord::Persist:

[legend]

Data Fields

ToDoRecMarkLevel markLevel
WCHAR note [c_note_max_length+1]
ToDoRecProrityLevel priorityLevel
Date toDoListDateTime
Type type

Field Documentation

ToDoRecMarkLevel ToDoRecord::Persist::markLevel

WCHAR ToDoRecord::Persist::note[c_note_max_length+1]

ToDoRecProrityLevel ToDoRecord::Persist::priorityLevel

Date ToDoRecord::Persist::toDoListDateTime

Type ToDoRecord::Persist::type

The documentation for this struct was generated from the following file:
  • Applications/ToDo/ToDoRecord.hpp
Generated on Wed Jan 25 02:12:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToggleActionGroup Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToggleActionGroup Class Reference
[Items]

Handles unique selection of abstract toggle actions. More...

#include <Apoxi/Gui/ToggleActionGroup.hpp>

Inheritance diagram for ToggleActionGroup:

[legend]
Collaboration diagram for ToggleActionGroup:

[legend]

Public Member Functions

AbstractToggleAction * GetSelectedToggleAction ()
void | Init ()
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetSelectedToggleAction (AbstractToggleAction *rb)
ToggleActionGroup ()
virtual | ~ToggleActionGroup ()

Detailed Description

Handles unique selection of abstract toggle actions.

Constructor & Destructor Documentation

ToggleActionGroup::ToggleActionGroup ( )

ToggleActionGroup::~ToggleActionGroup ( ) [virtual]

Member Function Documentation

AbstractToggleAction* ToggleActionGroup::GetSelectedToggleAction ( ) [inline]

void ToggleActionGroup::Init ( )

Reimplemented in RadioButtonGroup.

BOOLEAN ToggleActionGroup::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Reimplemented in RadioButtonGroup.

void ToggleActionGroup::SetSelectedToggleAction ( AbstractToggleAction * rb )

The documentation for this class was generated from the following files:
  • Gui/ToggleActionGroup.hpp
  • Gui/ToggleActionGroup.cpp
Generated on Wed Jan 25 02:12:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToneAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToneAudioDevice Class Reference

#include <Apoxi/Devices/Win32/ToneAudioDevice.hpp>

Inheritance diagram for ToneAudioDevice:

[legend]
Collaboration diagram for ToneAudioDevice:

[legend]

Public Types

enum Tone {
ToneDTMF0, ToneDTMF1, ToneDTMF2, ToneDTMF3,
ToneDTMF4, ToneDTMF5, ToneDTMF6, ToneDTMF7,
ToneDTMF8, ToneDTMF9, ToneDTMFHash, ToneDTMFAsterix,
ToneSvSubscriberBusy, ToneSvCongestion, ToneSvRadioPathAck, ToneSvRadioPathNotAvail,
ToneSvErrorInfo, ToneSvCallWaiting, ToneInfoFreeTone, ToneInfoConnection,
ToneInfoDisconnect, ToneInfoDeviceIn, ToneInfoDeviceOut, ToneInfoMsgFull,
ToneInfoUssd, ToneInfoMinuteMinder, ToneInfoError1, ToneInfoError2,
ToneInfoSmsInCall, ToneInfoBroadcastInCall, ToneInfoAlarmInCall, ToneInfoLowBatInCall,
ToneInfoPowerOff, ToneInfoPowerOn, ToneInfoSingleBeep
}
Available fixed tones. More...
enum | ToneType { NormalUserTone, DualUserTone, TripleUserTone }
Available tone types. More...

Public Member Functions

virtual const WCHAR * | GetName () const
virtual AudioReturnCode | Init (Priority prio)
void | SetStartParam (const StartParam *p_start_param)
virtual AudioReturnCode | Start (BOOLEAN auto_release=TRUE)
virtual AudioReturnCode | Stop (UINT8 channel=0)
ToneAudioDevice ()
virtual | ~ToneAudioDevice ()

Protected Member Functions

INT | ConvertTone2INT (Tone tone)
Map Tone to INT for aud_tone_id_enum-cast.

Data Structures

struct | StartParam
Start paramter. More...
struct | UserTone
User tone. More...

Detailed Description

Class ToneAudioDevice
Class handles the tone generation. All the methods in this class deals with the DSP tone generator. The DSP tone generator is used for supervisory tones and info tones (see aud_tone_id_enum).

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Member Enumeration Documentation

enum ToneAudioDevice::Tone

Available fixed tones.

Enumerator:
ToneDTMF0 | ToneDTMF0.
ToneDTMF1 | ToneDTMF1.
ToneDTMF2 | ToneDTMF2.
ToneDTMF3 | ToneDTMF3.
ToneDTMF4 | ToneDTMF4.
ToneDTMF5 | ToneDTMF5.
ToneDTMF6 | ToneDTMF6.
ToneDTMF7 | ToneDTMF7.
ToneDTMF8 | ToneDTMF8.
ToneDTMF9 | ToneDTMF9.
ToneDTMFHash | ToneDTMFHash.
ToneDTMFAsterix | ToneDTMFAsterix.
ToneSvSubscriberBusy | Subscriber busy.
ToneSvCongestion | Ccongestion.
ToneSvRadioPathAck | Radio path ack.
ToneSvRadioPathNotAvail | Radio path not avail,.
ToneSvErrorInfo | Error info.
ToneSvCallWaiting | Call waiting.
ToneInfoFreeTone | Info free tone.
ToneInfoConnection | Info connection,.
ToneInfoDisconnect | Info disconnect.
ToneInfoDeviceIn | Info device in.
ToneInfoDeviceOut | Info device out,.
ToneInfoMsgFull | Info msg full.
ToneInfoUssd | Info ussd.
ToneInfoMinuteMinder | Info minute minder.
ToneInfoError1 | Info Error 1.
ToneInfoError2 | Info Error 2.
ToneInfoSmsInCall | Info sms in call.
ToneInfoBroadcastInCall | Info breadcast in call.
ToneInfoAlarmInCall | Info alamr in call.
ToneInfoLowBatInCall | Info low bat in call.
ToneInfoPowerOff | Info power off.
ToneInfoPowerOn | Info power on.
ToneInfoSingleBeep | Info single beep.

enum ToneAudioDevice::ToneType

Available tone types.

Enumerator:
NormalUserTone | Normal user tone.
DualUserTone | Dual user tone.
TripleUserTone | Triple user tone.

Constructor & Destructor Documentation

ToneAudioDevice::ToneAudioDevice ( )

ToneAudioDevice::~ToneAudioDevice ( ) [virtual]

Member Function Documentation

INT ToneAudioDevice::ConvertTone2INT ( Tone tone ) [protected]

Map Tone to INT for aud_tone_id_enum-cast.

const WCHAR * ToneAudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from GenericAudioDevice.

ToneAudioDevice::AudioReturnCode ToneAudioDevice::Init ( Priority prio ) [virtual]

See also:
AudioDevice::Init

void ToneAudioDevice::SetStartParam ( const StartParam * p_start_param )

Set start parameter.

Parameters:
p_start_param,: Pointer to start parameter structure.

ToneAudioDevice::AudioReturnCode ToneAudioDevice::Start ( BOOLEAN auto_release = TRUE ) [virtual]

See also:
GenericAudioDevice::Start

Reimplemented from GenericAudioDevice.

ToneAudioDevice::AudioReturnCode ToneAudioDevice::Stop ( UINT8 channel = 0 ) [virtual]

See also:
GenericAudioDevice::Stop

Reimplemented from GenericAudioDevice.

The documentation for this class was generated from the following files:
  • Devices/Win32/ToneAudioDevice.hpp
  • Devices/Win32/ToneAudioDevice.cpp
Generated on Wed Jan 25 02:13:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToneAudioDevice::StartParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ToneAudioDevice::StartParam

ToneAudioDevice::StartParam Struct Reference

Start paramter. More...

#include <Apoxi/Devices/Win32/ToneAudioDevice.hpp>

Collaboration diagram for ToneAudioDevice::StartParam:

[legend]

Public Member Functions

StartParam ()
Constructor for default values.

Data Fields

UINT16 | mix_factor
UINT16 | play_count
How often the tone is to be played.
0 means play infinite.
BOOLEAN | use_tone
TRUE: Tone in union used, FALSE: UTone in union used.
Tone tone
Tone to be played.
UINT32 | tone_count
ToneType tone_type
UserTone * user_tone
Pointer to the tone.
struct {
UINT32 tone_count
ToneType tone_type
UserTone * user_tone
Pointer to the tone.
} UTone

Detailed Description

Start paramter.

Constructor & Destructor Documentation

ToneAudioDevice::StartParam::StartParam ( ) [inline]

Constructor for default values.

Field Documentation

UINT16 ToneAudioDevice::StartParam::mix_factor

Kind of volume with range 0-0x7FFF.
0 - no sound, 0x7FFF is max.
0x4000 will result in a volume level equal to speech.

UINT16 ToneAudioDevice::StartParam::play_count

How often the tone is to be played.
0 means play infinite.

Tone ToneAudioDevice::StartParam::tone

Tone to be played.

UINT32 ToneAudioDevice::StartParam::tone_count

ToneType ToneAudioDevice::StartParam::tone_type

BOOLEAN ToneAudioDevice::StartParam::use_tone

TRUE: Tone in union used, FALSE: UTone in union used.

UserTone* ToneAudioDevice::StartParam::user_tone

Pointer to the tone.

struct { ... } ToneAudioDevice::StartParam::UTone

The documentation for this struct was generated from the following file:
  • Devices/Win32/ToneAudioDevice.hpp
Generated on Wed Jan 25 02:13:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToneAudioDevice::UserTone Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ToneAudioDevice::UserTone

ToneAudioDevice::UserTone Struct Reference

User tone. More...

#include <Apoxi/Devices/Win32/ToneAudioDevice.hpp>

Data Fields

UINT16 | duration
Duration. Duration range is [10 - 8000] ms, the resolution is 5 ms.
UINT16 | frequency
Frequency valid range is [350 3500].

Detailed Description

User tone.

Field Documentation

UINT16 ToneAudioDevice::UserTone::duration

Duration. Duration range is [10 - 8000] ms, the resolution is 5 ms.

UINT16 ToneAudioDevice::UserTone::frequency

Frequency valid range is [350 3500].

The documentation for this struct was generated from the following file:
  • Devices/Win32/ToneAudioDevice.hpp
Generated on Wed Jan 25 02:13:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TopLevelMenu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TopLevelMenu Class Reference
[GUI Menu Accessors]

#include <Apoxi/AddOns/GuiMenuAccessors/TopLevelMenu.hpp>

Inheritance diagram for TopLevelMenu:

[legend]
Collaboration diagram for TopLevelMenu:

[legend]

Public Member Functions

void | AddAction (Action *action)
void | Init (Control *parent, const WCHAR *text)
TopLevelMenu ()

Detailed Description

Obsolete - the class Menu has been replaced by the classes ItemMenu and ItemTree.

Constructor & Destructor Documentation

TopLevelMenu::TopLevelMenu ( )

Member Function Documentation

void TopLevelMenu::AddAction ( Action * action )

void TopLevelMenu::Init | ( | Control * | parent,
 |  | const WCHAR * | text
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/GuiMenuAccessors/TopLevelMenu.hpp
  • AddOns/GuiMenuAccessors/TopLevelMenu.cpp
Generated on Wed Jan 25 02:13:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToStackMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ToStackMsg Class Reference

#include <Apoxi/Apc/Message.hpp>

Inheritance diagram for ToStackMsg:

[legend]
Collaboration diagram for ToStackMsg:

[legend]

Public Types

enum | { ID = 15001 }

Public Member Functions

virtual Message * | Clone () const
StackMsgArgument * | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
virtual ToStackMsg & | operator= (const ToStackMsg &msg)
ToStackMsg (const ToStackMsg &msg)
ToStackMsg (StackMsgArgument *arg=0)
virtual | ~ToStackMsg ()

Detailed Description

ToStackMsg is a specialiced message which is meant to carry information from APOXI TO the protocol stack.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ToStackMsg::ToStackMsg ( StackMsgArgument * arg = 0 )

ToStackMsg::ToStackMsg ( const ToStackMsg & msg )

ToStackMsg::~ToStackMsg ( ) [virtual]

Member Function Documentation

Message * ToStackMsg::Clone ( ) const [virtual]

Implements Message.

StackMsgArgument* ToStackMsg::GetArg ( ) const [inline]

const MsgMetaData & ToStackMsg::GetMetaData ( ) const [virtual]

Implements Message.

ToStackMsg & ToStackMsg::operator= ( const ToStackMsg & msg ) [virtual]

The documentation for this class was generated from the following files:
  • Apc/Message.hpp
  • Apc/MessageImpl.cpp
Generated on Wed Jan 25 02:13:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Tpdu Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Tpdu Class Reference

#include <Apoxi/Apc/Tpdu.hpp>

Inheritance diagram for Tpdu:

[legend]
Collaboration diagram for Tpdu:

[legend]

Public Types

enum Status {
Empty = SI_SM_STATUS_FREE, Read = SI_SM_STATUS_READ, Unread = SI_SM_STATUS_TO_BE_READ, Sent = SI_SM_STATUS_SENT,
SentSmsrReq = 0x0d, SentSmsrNoSmsr = 0x15, SentSmsrInSmsr = 0x1d, Unsent = SI_SM_STATUS_TO_BE_SENT,
UndefinedStatus = SI_SM_STATUS_UNKNOWN
}

Public Member Functions

void | Clear ()
resets the whole object.
void | ClearData ()
clears all data allocated.
void | Convert2Pdu (T_PDU &sdl_pdu) const
void | CopyData (const UINT8 *data)
copies the given data into the member m_data (m_length elems are copied).
UINT8 * | GetData () const
INT | GetLength () const
MessageTypeIndicator | GetMessageTypeIndicator () const
TP-MTI: TP-Message-Type-Indicator (3GPP 23.040 V5.1.0 [9.2.3.1]).
PhoneNumber | GetServiceCentreAddress () const
Status | GetStatus () const
UINT8 * | GetTpData () const
INT | GetTpLength () const
INT | GetTpOffset () const
returns the offset of the real TPDU-data (starting with message type indicator).
void | InitData (UINT8 fill_byte=0x00)
Initializes the whole allocated data with fill_byte.
BOOLEAN | IsMobileOriginated () const
determines, if the pdu is an outgoing type.
BOOLEAN | IsMobileTerminated () const
determines, if the pdu is an incoming type.
BOOLEAN | IsValid () const
Tpdu & | operator= (const Tpdu &tpdu)
BOOLEAN | operator== (const Tpdu &tpdu) const
INT | ReallocateData (INT length)
returns the number of bytes reallocated, already allocated memory is not cleared.
INT | ResizeData (INT length)
returns the number of bytes resized, already allocated memory is cleared.
void | SetDataBuffer (INT length, const UINT8 *data)
void | SetServiceCentreAddress (const PhoneNumber &phone_number)
void | SetStatus (Status status)
Tpdu (const Tpdu &tpdu)
Tpdu (const T_PDU &sdl_pdu)
Tpdu (Status status, INT length=0, const UINT8 *data=0)
Tpdu ()
virtual | ~Tpdu ()

Static Public Member Functions

static INT | GetMaxDataSize ()
Returns the maximum TPDU data size.

Detailed Description

3GPP TS 23.040 V5.1.0 [9] - This class holds the raw data of a transfer protocol data unit.

Member Enumeration Documentation

enum Tpdu::Status

Enumerator:
Empty
Read
Unread
Sent
SentSmsrReq
SentSmsrNoSmsr
SentSmsrInSmsr
Unsent
UndefinedStatus

Constructor & Destructor Documentation

Tpdu::Tpdu ( )

Tpdu::Tpdu | ( | Status | status,
 |  | INT | length = 0,
 |  | const UINT8 * | data = 0
 | ) |

Tpdu::Tpdu ( const T_PDU & sdl_pdu )

Tpdu::~Tpdu ( ) [virtual]

Tpdu::Tpdu ( const Tpdu & tpdu )

Member Function Documentation

void Tpdu::Clear ( )

resets the whole object.

void Tpdu::ClearData ( )

clears all data allocated.

void Tpdu::Convert2Pdu ( T_PDU & sdl_pdu ) const

void Tpdu::CopyData ( const UINT8 * data )

copies the given data into the member m_data (m_length elems are copied).

UINT8* Tpdu::GetData ( ) const [inline]

INT Tpdu::GetLength ( ) const [inline]

INT Tpdu::GetMaxDataSize ( ) [static]

Returns the maximum TPDU data size.

MessageTypeIndicator Tpdu::GetMessageTypeIndicator ( ) const

TP-MTI: TP-Message-Type-Indicator (3GPP 23.040 V5.1.0 [9.2.3.1]).

PhoneNumber Tpdu::GetServiceCentreAddress ( ) const

Status Tpdu::GetStatus ( ) const [inline]

UINT8 * Tpdu::GetTpData ( ) const

INT Tpdu::GetTpLength ( ) const

INT Tpdu::GetTpOffset ( ) const

returns the offset of the real TPDU-data (starting with message type indicator).

void Tpdu::InitData ( UINT8 fill_byte = 0x00 )

Initializes the whole allocated data with fill_byte.

BOOLEAN Tpdu::IsMobileOriginated ( ) const [inline]

determines, if the pdu is an outgoing type.

BOOLEAN Tpdu::IsMobileTerminated ( ) const [inline]

determines, if the pdu is an incoming type.

BOOLEAN Tpdu::IsValid ( ) const

Tpdu & Tpdu::operator= ( const Tpdu & tpdu )

BOOLEAN Tpdu::operator== ( const Tpdu & tpdu ) const

INT Tpdu::ReallocateData ( INT length )

returns the number of bytes reallocated, already allocated memory is not cleared.

INT Tpdu::ResizeData ( INT length )

returns the number of bytes resized, already allocated memory is cleared.

void Tpdu::SetDataBuffer | ( | INT | length,
 |  | const UINT8 * | data
 | ) |

void Tpdu::SetServiceCentreAddress ( const PhoneNumber & phone_number )

void Tpdu::SetStatus ( Status status ) [inline]

The documentation for this class was generated from the following files:
  • Apc/Tpdu.hpp
  • Apc/Tpdu.cpp
Generated on Wed Jan 25 02:13:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TpduCache Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TpduCache Class Reference
[Middle Layer]

#include <Apoxi/Adc/SimPduHandler.hpp>

Collaboration diagram for TpduCache:

[legend]

Public Member Functions

void | Clear ()
Tpdu * | GetTpdu (UINT16 tpduno, MdhViewHdl viewhdl, MdhTimeStamp &timestamp, MdhExtendedData &ext_data)
BOOLEAN | MarkAsInvalid (UINT16 tpduno)
void | Resize (UINT16 maxcache)
void | SetStatus (UINT16 tpduno, Tpdu::Status status)
TpduCache (UINT16 maxcache, SimPduHandler *handler)
~TpduCache ()

Constructor & Destructor Documentation

TpduCache::TpduCache | ( | UINT16 | maxcache,
 |  | SimPduHandler * | handler
 | ) |

TpduCache::~TpduCache ( )

Member Function Documentation

void TpduCache::Clear ( )

Tpdu * TpduCache::GetTpdu | ( | UINT16 | tpduno,
 |  | MdhViewHdl | viewhdl,
 |  | MdhTimeStamp & | timestamp,
 |  | MdhExtendedData & | ext_data
 | ) |

BOOLEAN TpduCache::MarkAsInvalid ( UINT16 tpduno )

void TpduCache::Resize ( UINT16 maxcache )

void TpduCache::SetStatus | ( | UINT16 | tpduno,
 |  | Tpdu::Status | status
 | ) |

The documentation for this class was generated from the following files:
  • Adc/SimPduHandler.hpp
  • Adc/SimPduHandler.cpp
Generated on Wed Jan 25 02:13:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TpduConc Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TpduConc Struct Reference

TpduConc (ms.h: T_PDU_CONCATENATED). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Data Fields

INT | next
T_PDU | pdu
UINT8 | pdu_no
INT | prev

Detailed Description

TpduConc (ms.h: T_PDU_CONCATENATED).

Field Documentation

INT TpduConc::next

T_PDU TpduConc::pdu

UINT8 TpduConc::pdu_no

INT TpduConc::prev

The documentation for this struct was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 02:13:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TpduHeaderInformation Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TpduHeaderInformation Struct Reference
[Middle Layer]

#include <Apoxi/Adc/SimPduHandler.hpp>

Collaboration diagram for TpduHeaderInformation:

[legend]

Public Member Functions

void | Clear ()
ConcatenetedStatus | GetConcatenetedStatus () const
UINT8 | GetConcatenetedTpduNum () const
UINT8 | GetConcMaxNo () const
UINT16 | GetConcRefNo () const
UINT8 | GetConcSeqNo () const
const DateTime::Persist & | GetDateTime () const
DataCodingScheme | GetDcs () const
UINT32 | GetExtendedData () const
UINT8 | GetFlashStoredTpduNum () const
DataCodingScheme::GroupId | GetGroupId () const
UINT16 | GetInternalRecNo () const
DataCodingScheme::MessageClass | GetMessageClass () const
MessageTypeIndicator::Type | GetMessageType () const
UINT8 | GetPayloadSize () const
const TpduPhoneNumberPersist & | GetPhoneNumber () const
ProtocolIdentifier | GetPid () const
const SmsReferenceNumber & | GetReferenceNumber () const
ShortMessageStatus | GetShortMessageStatus () const
UINT8 | GetSimStoredTpduNum () const
SmsPortNo | GetSmsPortNo () const
Sms::StorageType | GetSmsStorageType () const
Tpdu::Status | GetStatus () const
UINT16 | GetWStringCashPos () const
BOOLEAN | HasWrongStatus () const
void | Init ()
BOOLEAN | IsConcateneted () const
BOOLEAN | IsDateTimeValid () const
BOOLEAN | IsValid () const
BOOLEAN | ReplyPathExists () const
void | SetConcatenetedStatus (ConcatenetedStatus status)
void | SetConcatenetedTpduNum (UINT8 conc_num)
void | SetDateTime (const DateTime::Persist &datetime)
void | SetInternalRecNo (UINT16 ref_no)
void | SetSimFlashStoredTpduNum (UINT8 sim_num, UINT8 flash_num)
void | SetSmsStorageType (Sms::StorageType type)
void | SetStatus (Tpdu::Status status)
void | SetTpduInformation (Tpdu &tpdu, Sms::StorageType storagetype, MdhTimeStamp timestamp, MdhExtendedData ext_data)
void | SetWrongStatus (BOOLEAN status)
void | SetWStringCashPos (UINT16 pos)

Static Public Member Functions

static UINT16 | GetMaxConcRefNo ()

Data Fields

struct {
UINT m_coding_group: 4
UINT m_concateneted_status: 2
UINT m_is_concateneted: 1
UINT m_msg_class: 4
UINT m_msg_type: 4
UINT m_reply_path_exists: 1
} m_bitfield
UINT16 | m_cache_pos
UINT8 | m_conc_max_no
UINT8 | m_conc_num
UINT16 | m_conc_ref_no
UINT8 | m_conc_seq_no
DateTime::Persist m_datetime
DataCodingScheme m_dcs
UINT32 | m_extended_data
UINT8 | m_flash_stored
UINT16 | m_int_ref_no
ShortMessageStatus m_msg_status
UINT8 | m_payload_size
TpduPhoneNumberPersist m_phnr
ProtocolIdentifier m_protid
SmsReferenceNumber m_refno
UINT8 | m_sim_stored
SmsPortNo m_sms_port_no
UINT8 | m_status
UINT8 | m_storagetype
BOOLEAN | m_wrong_status

Static Public Attributes

static UINT16 | m_max_conc_ref_no = 0

Member Function Documentation

void TpduHeaderInformation::Clear ( )

ConcatenetedStatus TpduHeaderInformation::GetConcatenetedStatus ( ) const [inline]

UINT8 TpduHeaderInformation::GetConcatenetedTpduNum ( ) const [inline]

UINT8 TpduHeaderInformation::GetConcMaxNo ( ) const [inline]

UINT16 TpduHeaderInformation::GetConcRefNo ( ) const [inline]

UINT8 TpduHeaderInformation::GetConcSeqNo ( ) const [inline]

const DateTime::Persist& TpduHeaderInformation::GetDateTime ( ) const [inline]

DataCodingScheme TpduHeaderInformation::GetDcs ( ) const [inline]

UINT32 TpduHeaderInformation::GetExtendedData ( ) const [inline]

UINT8 TpduHeaderInformation::GetFlashStoredTpduNum ( ) const [inline]

DataCodingScheme::GroupId TpduHeaderInformation::GetGroupId ( ) const [inline]

UINT16 TpduHeaderInformation::GetInternalRecNo ( ) const [inline]

static UINT16 TpduHeaderInformation::GetMaxConcRefNo ( ) [inline, static]

DataCodingScheme::MessageClass TpduHeaderInformation::GetMessageClass ( ) const [inline]

MessageTypeIndicator::Type TpduHeaderInformation::GetMessageType ( ) const [inline]

UINT8 TpduHeaderInformation::GetPayloadSize ( ) const [inline]

const TpduPhoneNumberPersist& TpduHeaderInformation::GetPhoneNumber ( ) const [inline]

ProtocolIdentifier TpduHeaderInformation::GetPid ( ) const [inline]

const SmsReferenceNumber& TpduHeaderInformation::GetReferenceNumber ( ) const [inline]

ShortMessageStatus TpduHeaderInformation::GetShortMessageStatus ( ) const [inline]

UINT8 TpduHeaderInformation::GetSimStoredTpduNum ( ) const [inline]

SmsPortNo TpduHeaderInformation::GetSmsPortNo ( ) const [inline]

Sms::StorageType TpduHeaderInformation::GetSmsStorageType ( ) const [inline]

Tpdu::Status TpduHeaderInformation::GetStatus ( ) const [inline]

UINT16 TpduHeaderInformation::GetWStringCashPos ( ) const [inline]

BOOLEAN TpduHeaderInformation::HasWrongStatus ( ) const [inline]

void TpduHeaderInformation::Init ( )

BOOLEAN TpduHeaderInformation::IsConcateneted ( ) const [inline]

BOOLEAN TpduHeaderInformation::IsDateTimeValid ( ) const [inline]

BOOLEAN TpduHeaderInformation::IsValid ( ) const

BOOLEAN TpduHeaderInformation::ReplyPathExists ( ) const [inline]

void TpduHeaderInformation::SetConcatenetedStatus ( ConcatenetedStatus status ) [inline]

void TpduHeaderInformation::SetConcatenetedTpduNum ( UINT8 conc_num ) [inline]

void TpduHeaderInformation::SetDateTime ( const DateTime::Persist & datetime ) [inline]

void TpduHeaderInformation::SetInternalRecNo ( UINT16 ref_no ) [inline]

void TpduHeaderInformation::SetSimFlashStoredTpduNum | ( | UINT8 | sim_num,
 |  | UINT8 | flash_num
 | ) | [inline]

void TpduHeaderInformation::SetSmsStorageType ( Sms::StorageType type ) [inline]

void TpduHeaderInformation::SetStatus ( Tpdu::Status status ) [inline]

void TpduHeaderInformation::SetTpduInformation | ( | Tpdu & | tpdu,
 |  | Sms::StorageType | storagetype,
 |  | MdhTimeStamp | timestamp,
 |  | MdhExtendedData | ext_data
 | ) |

void TpduHeaderInformation::SetWrongStatus ( BOOLEAN status ) [inline]

void TpduHeaderInformation::SetWStringCashPos ( UINT16 pos ) [inline]

Field Documentation

struct { ... } TpduHeaderInformation::m_bitfield

UINT16 TpduHeaderInformation::m_cache_pos

UINT TpduHeaderInformation::m_coding_group

UINT8 TpduHeaderInformation::m_conc_max_no

UINT8 TpduHeaderInformation::m_conc_num

UINT16 TpduHeaderInformation::m_conc_ref_no

UINT8 TpduHeaderInformation::m_conc_seq_no

UINT TpduHeaderInformation::m_concateneted_status

DateTime::Persist TpduHeaderInformation::m_datetime

DataCodingScheme TpduHeaderInformation::m_dcs

UINT32 TpduHeaderInformation::m_extended_data

UINT8 TpduHeaderInformation::m_flash_stored

UINT16 TpduHeaderInformation::m_int_ref_no

UINT TpduHeaderInformation::m_is_concateneted

UINT16 TpduHeaderInformation::m_max_conc_ref_no = 0 [static]

UINT TpduHeaderInformation::m_msg_class

ShortMessageStatus TpduHeaderInformation::m_msg_status

UINT TpduHeaderInformation::m_msg_type

UINT8 TpduHeaderInformation::m_payload_size

TpduPhoneNumberPersist TpduHeaderInformation::m_phnr

ProtocolIdentifier TpduHeaderInformation::m_protid

SmsReferenceNumber TpduHeaderInformation::m_refno

UINT TpduHeaderInformation::m_reply_path_exists

UINT8 TpduHeaderInformation::m_sim_stored

SmsPortNo TpduHeaderInformation::m_sms_port_no

UINT8 TpduHeaderInformation::m_status

UINT8 TpduHeaderInformation::m_storagetype

BOOLEAN TpduHeaderInformation::m_wrong_status

The documentation for this struct was generated from the following files:
  • Adc/SimPduHandler.hpp
  • Adc/SimPduHandler.cpp
Generated on Wed Jan 25 02:13:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TpduNode Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TpduNode Struct Reference

TpduNode (ms.h: T_PDU_NODE). More...

#include <Apoxi/Apc/MdhTypes.hpp>

Collaboration diagram for TpduNode:

[legend]

Data Fields

TpduNode * next
T_PDU pdu

Detailed Description

TpduNode (ms.h: T_PDU_NODE).

Field Documentation

TpduNode* TpduNode::next

T_PDU TpduNode::pdu

The documentation for this struct was generated from the following file:
  • Apc/MdhTypes.hpp
Generated on Wed Jan 25 02:13:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TpduPhoneNumberPersist Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TpduPhoneNumberPersist Struct Reference
[Middle Layer]

#include <Apoxi/Adc/SimPduHandler.hpp>

Public Member Functions

void | Clear ()
BOOLEAN | IsEqual (const TpduPhoneNumberPersist &persist) const
void | Set (const PhoneNumber &phno)

Data Fields

UINT8 | m_data [12]

Member Function Documentation

void TpduPhoneNumberPersist::Clear ( ) [inline]

BOOLEAN TpduPhoneNumberPersist::IsEqual ( const TpduPhoneNumberPersist & persist ) const [inline]

void TpduPhoneNumberPersist::Set ( const PhoneNumber & phno ) [inline]

Field Documentation

UINT8 TpduPhoneNumberPersist::m_data[12]

The documentation for this struct was generated from the following file:
  • Adc/SimPduHandler.hpp
Generated on Wed Jan 25 02:13:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TraceOutputStream Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TraceOutputStream Class Reference
[Kernel]

#include <Apoxi/Compat/TraceOutputStream.hpp>

Inheritance diagram for TraceOutputStream:

[legend]
Collaboration diagram for TraceOutputStream:

[legend]

Public Member Functions

virtual void | Flush ()
virtual OutputStream & | operator<< (const unsigned long n)
virtual OutputStream & | operator<< (const long n)
virtual OutputStream & | operator<< (const unsigned int n)
virtual OutputStream & | operator<< (const int n)
virtual OutputStream & | operator<< (const unsigned short n)
virtual OutputStream & | operator<< (const short n)
virtual OutputStream & | operator<< (const wchar_t *w)
virtual OutputStream & | operator<< (const char *s)
virtual OutputStream & | operator<< (const unsigned char c)
virtual OutputStream & | operator<< (const char c)
TraceOutputStream (OutputStream *stream)
virtual INT | Write (const BYTE *data, INT len)
virtual INT | Write (const BYTE data)
virtual | ~TraceOutputStream ()

Constructor & Destructor Documentation

TraceOutputStream::TraceOutputStream ( OutputStream * stream )

TraceOutputStream::~TraceOutputStream ( ) [virtual]

Member Function Documentation

void TraceOutputStream::Flush ( ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const unsigned long n ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const long n ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const unsigned int n ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const int n ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const unsigned short n ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const short n ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const wchar_t * w ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const char * s ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const unsigned char c ) [virtual]

Reimplemented from OutputStream.

OutputStream & TraceOutputStream::operator<< ( const char c ) [virtual]

Reimplemented from OutputStream.

INT TraceOutputStream::Write | ( | const BYTE * | data,
 |  | INT | len
 | ) | [virtual]

Reimplemented from OutputStream.

INT TraceOutputStream::Write ( const BYTE data ) [virtual]

Implements OutputStream.

The documentation for this class was generated from the following files:
  • Compat/TraceOutputStream.hpp
  • Compat/TraceOutputStream.cpp
Generated on Wed Jan 25 02:13:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TRadioButtonItem< Content > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TRadioButtonItem< Content > Class Template Reference

#include <Apoxi/Compat/RadioButtonItem.hpp>

Inheritance diagram for TRadioButtonItem< Content >:

[legend]
Collaboration diagram for TRadioButtonItem< Content >:

[legend]

Public Types

typedef RadioButtonItem | Base

Public Member Functions

Content | GetContent () const
void | SetContent (Content content)
TRadioButtonItem (const WCHAR *text, BOOLEAN pressed)
TRadioButtonItem (const WCHAR *text)
TRadioButtonItem ()

Detailed Description

template<class Content>
class TRadioButtonItem< Content >

Defines an item which looks like a Radiobutton-Control and can be embedded into a RadioButtonList. Being a template the content can be whatever is practicle.

Member Typedef Documentation

template<class Content>
typedef RadioButtonItem TRadioButtonItem< Content >::Base

Reimplemented from Linkable< RadioButtonItem >.

Constructor & Destructor Documentation

template<class Content>
TRadioButtonItem< Content >::TRadioButtonItem ( ) [inline]

Parameters:
text | Text of the RadioButtonItem.
pressed | Status of the RadioButtonItem.

template<class Content>
TRadioButtonItem< Content >::TRadioButtonItem ( const WCHAR * text ) [inline]

template<class Content>
TRadioButtonItem< Content >::TRadioButtonItem | ( | const WCHAR * | text,
 |  | BOOLEAN | pressed
 | ) | [inline]

Member Function Documentation

template<class Content>
Content TRadioButtonItem< Content >::GetContent ( ) const [inline]

template<class Content>
void TRadioButtonItem< Content >::SetContent ( Content content ) [inline]

The documentation for this class was generated from the following file:
  • Compat/RadioButtonItem.hpp
Generated on Wed Jan 25 02:13:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TRadioButtonList< Content > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TRadioButtonList< Content > Class Template Reference

#include <Apoxi/Compat/RadioButtonList.hpp>

Inheritance diagram for TRadioButtonList< Content >:

[legend]
Collaboration diagram for TRadioButtonList< Content >:

[legend]

Public Member Functions

void | AddItem (TRadioButtonItem< Content > *item, const WCHAR *text, Content content, BOOLEAN pressed=FALSE)
TRadioButtonItem< Content > * | GetFirstItem () const
TRadioButtonItem< Content > * | GetPressedItem () const
void | SetPressedItem (Content content)
void | SetPressedItem (TRadioButtonItem< Content > *item)

Detailed Description

template<class Content>
class TRadioButtonList< Content >

A TRadioButtonList is a RadioButtonList, which content class is not castable to an INT. Use pointers to your class as content class!

Member Function Documentation

template<class Content>
void TRadioButtonList< Content >::AddItem | ( | TRadioButtonItem< Content > * | item,
 |  | const WCHAR * | text,
 |  | Content | content,
 |  | BOOLEAN | pressed = FALSE
 | ) |

See also:
RadioButtonList::AddItem

template<class Content>
TRadioButtonItem<Content>* TRadioButtonList< Content >::GetFirstItem ( ) const [inline]

See also:
RadioButtonList::GetFirstItem

Reimplemented from RadioButtonList.

template<class Content>
TRadioButtonItem<Content>* TRadioButtonList< Content >::GetPressedItem ( ) const [inline]

See also:
RadioButtonList::GetPressedItem

template<class Content>
void TRadioButtonList< Content >::SetPressedItem ( Content content )

See also:
RadioButtonList::SetPressedItem

template<class Content>
void TRadioButtonList< Content >::SetPressedItem ( TRadioButtonItem< Content > * item ) [inline]

See also:
RadioButtonList::SetPressedItem

The documentation for this class was generated from the following file:
  • Compat/RadioButtonList.hpp
Generated on Wed Jan 25 02:13:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Transaction Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Transaction Struct Reference
[Afs]

#include <Apoxi/Afs/RegMemoryPool.hpp>

Data Fields

INT16 | m_file_id
INT16 | m_transaction_id

Field Documentation

INT16 Transaction::m_file_id

INT16 Transaction::m_transaction_id

The documentation for this struct was generated from the following file:
  • Afs/RegMemoryPool.hpp
Generated on Wed Jan 25 02:13:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TransferLocationDialog Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TransferLocationDialog Class Reference

Class for transfer location window. More...

#include <Applications/Lcs/TransferLocationDialogWin.hpp>

Collaboration diagram for TransferLocationDialog:

[legend]

Public Member Functions

void | Init ()
TransferLocationDialog ()
Constructor.
virtual | ~TransferLocationDialog ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnCancel ()
virtual void | OnClose ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnLayoutClient ()
virtual void | OnOpen ()

Detailed Description

Class for transfer location window.

Constructor & Destructor Documentation

TransferLocationDialog::TransferLocationDialog ( )

Constructor.

TransferLocationDialog::~TransferLocationDialog ( ) [virtual]

Destructor.

Member Function Documentation

void TransferLocationDialog::Init ( )

BOOLEAN TransferLocationDialog::OnCancel ( ) [protected, virtual]

void TransferLocationDialog::OnClose ( ) [protected, virtual]

BOOLEAN TransferLocationDialog::OnConfirm ( ) [protected, virtual]

void TransferLocationDialog::OnLayoutClient ( ) [protected, virtual]

void TransferLocationDialog::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/Lcs/TransferLocationDialogWin.hpp
  • Applications/Lcs/TransferLocationDialogWin.cpp
Generated on Wed Jan 25 02:13:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TransportNotificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TransportNotificationMsg Class Reference

#include <Apoxi/Devices/Messages/TransportNotificationMsg.hpp>

Inheritance diagram for TransportNotificationMsg:

[legend]
Collaboration diagram for TransportNotificationMsg:

[legend]

Public Types

enum | { ID = 9100 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const AbstractTransport::NotificationMsgType & | GetMsgType () const
TransportNotificationMsg (ExecutionContext *context, const AbstractTransport::NotificationMsgType &msg_type)
virtual | ~TransportNotificationMsg ()

Detailed Description

Sent by AbstractTransport to indicate state change

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

TransportNotificationMsg::TransportNotificationMsg | ( | ExecutionContext * | context,
 |  | const AbstractTransport::NotificationMsgType & | msg_type
 | ) |

TransportNotificationMsg::~TransportNotificationMsg ( ) [virtual]

Member Function Documentation

Message * TransportNotificationMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & TransportNotificationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const AbstractTransport::NotificationMsgType& TransportNotificationMsg::GetMsgType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Devices/Messages/TransportNotificationMsg.hpp
  • Devices/Messages/TransportNotificationMsg.cpp
Generated on Wed Jan 25 02:13:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Trap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Trap Class Reference
[Operating System]

#include <Apoxi/Kernel/Os/Nuc32/Trap.hpp>

Static Public Member Functions

static void | Assertion (BOOLEAN arg)
static void | Assertion (BOOLEAN arg, CHAR *filename, INT line)
static void | Assertion (BOOLEAN arg)
static Provider & | GetProvider ()
static Provider & | GetProvider ()
static void | Init ()
static void | Init ()
static void | SetHandler (TrapCB hdl)

Member Function Documentation

static void Trap::Assertion ( BOOLEAN arg ) [static]

Be aware, that assertion handling is different for host and target.

Host

ASSERT from mfc is called

Target

You have to set compiler defines (for example in your local build script file) for apoxi assertion handling
  • standard handling
    Assertion(callstack and some CPU registers) will be stored in flash memory

  • set define APOXI_ENABLE_TRAP_INFO_SCREEN
    Assertion(sourcefile and line) will be displayed at LCD screen

Parameters:
arg raise condition

void Trap::Assertion | ( | BOOLEAN | arg,
 |  | CHAR * | filename,
 |  | INT | line
 | ) | [static]

void Trap::Assertion ( BOOLEAN arg ) [static]

static Provider& Trap::GetProvider ( ) [static]

Returns:
Provider which represents the data of previously occured traps.
Each row in Trap Info Provider represents one trap event. The trap information can be read out of the columns. Depending on the hardware and on the trap class, different information is provided per column. Use method GetDataItem(INT columnid, INT row, DataItem& item) to read out the trap data.

EGold / OSE 166

column | type | description
0 | WString | trap date and time
1 | Number | trap class
2 | WString | system stack
3 | WString | log data

SGold / Nucleus 32

column | type | description
0 | WString | trap date and time
1 | Number | trap class 0..2 HW Trap (Trap Class A..C) > 2 SW Trap
The following columns are only provided if define TRAP_USE_EXTENDED_FORMAT is set by driver.

HW Trap

2 | WString | register R0
3 | WString | register R1
4 | WString | register R2
5 | WString | register R3
6 | WString | register R4
7 | WString | register R5
8 | WString | register R6
9 | WString | register R7
10 | WString | register R8
11 | WString | register R9
12 | WString | register R10
13 | WString | register R11
14 | WString | register R12
15 | WString | register R13
16 | WString | register R14
17 | WString | register R15
18 | WString | register SPSR
19 | WString | register DFAR
20 | WString | register DFSR
21+n | WString | stack data dump

SW Trap

2 | WString | trap ID
3 | WString | file name
4 | WString | line number
5 | WString | log data

Because ColumnCount() is returning different values depending which row is accessed (trap class), SetParameter(const DataItem &item) is used to define the row ID before calling ColumnCount(). For example, if the column count for row 10 is needed, the following sequence has to be called:

            Provider& provider = Trap::GetProvider();
            DataItem data_item;
            data_item.SetNumber(10);
            provider.SetParameter(data_item);
            INT column_count = provicer.ColumnCount(); // column count for row 10

Provider & Trap::GetProvider ( ) [static]

Returns:
Provider which represents the data of previously occured traps.

static void Trap::Init ( ) [static]

void Trap::Init ( ) [static]

static void Trap::SetHandler ( TrapCB hdl ) [inline, static]

The documentation for this class was generated from the following files:
  • Kernel/Os/Nuc32/Trap.hpp
  • Kernel/Os/Win32/Trap.hpp
  • Kernel/Os/Nuc32/Trap.cpp
  • Kernel/Os/Win32/Trap.cpp
Generated on Wed Jan 25 02:13:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TriggerKeyFeature Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TriggerKeyFeature Class Reference
[APOXI Template Layer]

This features posts a key down message with a given key code. It can be used to send key events from a menu item, since this feature can be used in a menu. More...

#include <Apoxi/Atl/Features/TriggerKeyFeature.hpp>

Inheritance diagram for TriggerKeyFeature:

[legend]
Collaboration diagram for TriggerKeyFeature:

[legend]

Public Types

enum | { ID = 5 }

Public Member Functions

virtual BOOLEAN | Execute ()
Posts a KeyDownMessage with given key code.
virtual INT | GetID () const
Type information.
KeyCode | GetKeyCode () const
void | Init (const FeatureID &feature_id, KeyCode key_code)
virtual BOOLEAN | IsEqual (const Feature &feature) const
Comparison.
virtual BOOLEAN | IsInstanceOf (INT id) const
Type information.
void | SetKeyCode (KeyCode key_code)
TriggerKeyFeature ()
virtual | ~TriggerKeyFeature ()

Detailed Description

This features posts a key down message with a given key code. It can be used to send key events from a menu item, since this feature can be used in a menu.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Feature.

Constructor & Destructor Documentation

TriggerKeyFeature::TriggerKeyFeature ( )

TriggerKeyFeature::~TriggerKeyFeature ( ) [virtual]

Member Function Documentation

BOOLEAN TriggerKeyFeature::Execute ( ) [virtual]

Posts a KeyDownMessage with given key code.

Reimplemented from Feature.

INT TriggerKeyFeature::GetID ( ) const [virtual]

Type information.

Reimplemented from Feature.

KeyCode TriggerKeyFeature::GetKeyCode ( ) const [inline]

Returns:
The key code, which will be used for the KeyDownMessage

void TriggerKeyFeature::Init | ( | const FeatureID & | feature_id,
 |  | KeyCode | key_code
 | ) |

Parameters:
feature_id | This features is a platform feature, does not need a particular application for execution
key_code | The key code, which should be used for the KeyDownMessage

BOOLEAN TriggerKeyFeature::IsEqual ( const Feature & feature ) const [virtual]

Comparison.

Reimplemented from Feature.

BOOLEAN TriggerKeyFeature::IsInstanceOf ( INT id ) const [virtual]

Type information.

Reimplemented from Feature.

void TriggerKeyFeature::SetKeyCode ( KeyCode key_code ) [inline]

Parameters:
key_code The key code, which should be used for the KeyDownMessage

The documentation for this class was generated from the following files:
  • Atl/Features/TriggerKeyFeature.hpp
  • Atl/Features/TriggerKeyFeature.cpp
Generated on Wed Jan 25 02:13:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TriggerTimer< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TriggerTimer< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/TriggerTimer.hpp>

Inheritance diagram for TriggerTimer< T >:

[legend]
Collaboration diagram for TriggerTimer< T >:

[legend]

Public Member Functions

void | Init (T *t, UINT32 timeout, BOOLEAN autotimer=FALSE)
TriggerTimer (T *t, UINT32 timeout, BOOLEAN autotimer=FALSE)
TriggerTimer ()
virtual | ~TriggerTimer ()

Protected Member Functions

virtual void | OnTimer ()

template<class T>
class TriggerTimer< T >

The documentation for this class was generated from the following file:
  • Auxiliary/TriggerTimer.hpp
Generated on Wed Jan 25 02:13:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TSiIconID_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TSiIconID_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Data Fields

SDL_Boolean exists
byte id
byte qualifier

Field Documentation

SDL_Boolean TSiIconID_s::exists

byte TSiIconID_s::id

byte TSiIconID_s::qualifier

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 02:13:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TSiUrl_s Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TSiUrl_s Struct Reference

#include <Apoxi/Apc/SimTkTypes.hpp>

Collaboration diagram for TSiUrl_s:

[legend]

Data Fields

SiUrlArray data
byte length

Field Documentation

SiUrlArray TSiUrl_s::data

byte TSiUrl_s::length

The documentation for this struct was generated from the following file:
  • Apc/SimTkTypes.hpp
Generated on Wed Jan 25 02:13:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TtyInterface Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TtyInterface Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/TtyInterface.hpp>

Public Member Functions

TtyMode GetTtyMode ()
BOOLEAN | GetTtyMode (TtyMode &mode)
TtySpeed GetTtySpeed ()
BOOLEAN | GetTtySpeed (TtySpeed &speed)
BOOLEAN | SetTtyMode (TtyMode mode)
BOOLEAN | SetTtySpeed (TtySpeed speed)
TtyInterface ()
BOOLEAN | TtySupported ()
BOOLEAN | TtySupported (BOOLEAN &supported)
virtual | ~TtyInterface ()

Detailed Description

This class provides a interface for get and set some vlues for TTY/CTM The interface is only necessary if the CTM-feature is part of APOXI

Constructor & Destructor Documentation

TtyInterface::TtyInterface ( ) [inline]

virtual TtyInterface::~TtyInterface ( ) [inline, virtual]

Member Function Documentation

TtyMode TtyInterface::GetTtyMode ( )

Get the current TTY/CTM mode

Returns:
the TTY mode, if access to NVRAM was not possible, TtyModeUnknown is returned

BOOLEAN TtyInterface::GetTtyMode ( TtyMode & mode )

Get the current TTY/CTM mode

Parameters:
mode,reference to current TTY/CTM mode
Returns:
TRUE if access to NVRAM was possible

TtySpeed TtyInterface::GetTtySpeed ( )

Get the current TTY/CTM speed

Returns:
the TTY speed, if access to NVRAM was not possible, TtySpeedUnknown is returned

BOOLEAN TtyInterface::GetTtySpeed ( TtySpeed & speed )

Get the current TTY/CTM speed

Parameters:
speed,reference to current TTY/CTM speed
Returns:
TRUE if access to NVRAM was possible

BOOLEAN TtyInterface::SetTtyMode ( TtyMode mode )

Set the TTY/CTM mode

Parameters:
mode,TTY/CTM mode to set
Returns:
TRUE if access to NVRAM was possible

BOOLEAN TtyInterface::SetTtySpeed ( TtySpeed speed )

Set the TTY/CTM speed

Parameters:
speed,TTY/CTM speed to set
Returns:
TRUE if access to NVRAM was possible

BOOLEAN TtyInterface::TtySupported ( )

Check if TTY/CTM is supported

Returns:
FALSE if access to NVRAM was not possible or TTY/CTM is not supported

BOOLEAN TtyInterface::TtySupported ( BOOLEAN & supported )

Check if TTY/CTM is supported

Parameters:
supported,the reference is TRUE if the feature is supported
Returns:
TRUE if access to NVRAM was possible

The documentation for this class was generated from the following files:
  • Asc/TtyInterface.hpp
  • Asc/TtyInterface.cpp
Generated on Wed Jan 25 02:13:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: TypeOfAddress Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

TypeOfAddress Class Reference

Type-of-Address (TON/NPI) - 3GPP TS 23.040 V5.1.0 [9.2.3.9]. More...

#include <Apoxi/Auxiliary/TypeOfAddress.hpp>

Collaboration diagram for TypeOfAddress:

[legend]

Public Types

enum | { InvalidTypeOfAddress = 0x00 }
enum NumberingPlanIdentification {
UnknownNumberingPlan, TelephoneNumberingPlan, DataNumberingPlan, TelexNumberingPlan,
ServiceCentreSpecificPlan, NationalNumberingPlan, PrivateNumberingPlan, ErmesNumberingPlan,
ReservedNumberingPlan, InvalidNumberingPlan
}
describes the numbering plan identification (NPI). More...
enum TypeOfNumber {
UnknownTypeOfNumber = 0, InternationalNumber, NationalNumber, NetworkSpecificNumber,
SubscriberNumber, Alphanumeric, AbbreviatedNumber, ReservedTypeOfNumber,
InvalidTypeOfNumber
}
describes the type of number (TON). More...

Public Member Functions

void | Clear ()
UINT8 | Get () const
Returns the byte representation of the TON/NPI values.
NumberingPlanIdentification | GetNumberingPlanIdentification () const
Returns the NPI enumeration value.
TypeOfNumber | GetTypeOfNumber () const
Returns the TON enumeration value.
BOOLEAN | Is3aExisting () const
checks if the 3a byte exists as defined in 3GPP 24.008
void | Set3aExists ()
void | Set3aNotExists ()
void | SetNumberingPlanIdentification (NumberingPlanIdentification numbering_plan_identification)
Sets the NPI enumeration value.
void | SetTypeOfNumber (TypeOfNumber type_of_number)
Sets the TON enumeration value.
TypeOfAddress (UINT8 incoming_byte)
Constructor of the class.
TypeOfAddress ()
Constructor of the class.

Detailed Description

Type-of-Address (TON/NPI) - 3GPP TS 23.040 V5.1.0 [9.2.3.9].

Member Enumeration Documentation

anonymous enum

Enumerator:
InvalidTypeOfAddress

enum TypeOfAddress::NumberingPlanIdentification

describes the numbering plan identification (NPI).

Enumerator:
UnknownNumberingPlan
TelephoneNumberingPlan | ISDN/telephone numbering plan (E.164 [17] / E.163 [18]).
DataNumberingPlan | data numbering plan (X.121)
TelexNumberingPlan
ServiceCentreSpecificPlan
NationalNumberingPlan
PrivateNumberingPlan
ErmesNumberingPlan | ERMES numbering plan (ETSI DE / PS 3 01-3).
ReservedNumberingPlan
InvalidNumberingPlan

enum TypeOfAddress::TypeOfNumber

describes the type of number (TON).

Enumerator:
UnknownTypeOfNumber
InternationalNumber
NationalNumber
NetworkSpecificNumber
SubscriberNumber
Alphanumeric coded according to 3GPP TS 23.38 [9] GSM 7-bit default alphabet.
AbbreviatedNumber
ReservedTypeOfNumber
InvalidTypeOfNumber

Constructor & Destructor Documentation

TypeOfAddress::TypeOfAddress ( )

Constructor of the class.

TypeOfAddress::TypeOfAddress ( UINT8 incoming_byte )

Constructor of the class.

Member Function Documentation

void TypeOfAddress::Clear ( ) [inline]

UINT8 TypeOfAddress::Get ( ) const [inline]

Returns the byte representation of the TON/NPI values.

TypeOfAddress::NumberingPlanIdentification TypeOfAddress::GetNumberingPlanIdentification ( ) const

Returns the NPI enumeration value.

TypeOfAddress::TypeOfNumber TypeOfAddress::GetTypeOfNumber ( ) const

Returns the TON enumeration value.

BOOLEAN TypeOfAddress::Is3aExisting ( ) const [inline]

checks if the 3a byte exists as defined in 3GPP 24.008

void TypeOfAddress::Set3aExists ( ) [inline]

void TypeOfAddress::Set3aNotExists ( ) [inline]

void TypeOfAddress::SetNumberingPlanIdentification ( NumberingPlanIdentification numbering_plan_identification )

Sets the NPI enumeration value.

void TypeOfAddress::SetTypeOfNumber ( TypeOfNumber type_of_number )

Sets the TON enumeration value.

The documentation for this class was generated from the following files:
  • Auxiliary/TypeOfAddress.hpp
  • Auxiliary/TypeOfAddress.cpp
Generated on Wed Jan 25 02:13:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UdpNetAdapter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UdpNetAdapter Class Reference

#include <Apoxi/Socket/NetAdapterHandler.hpp>

Inheritance diagram for UdpNetAdapter:

[legend]
Collaboration diagram for UdpNetAdapter:

[legend]

Public Member Functions

virtual SocketError | GetError () const
virtual INT | GetInBufByteCount ()
virtual INT | Read (void *buf, INT buflen, InetSocketAddr *from=0)
UdpNetAdapter (NetAdapterHandler *handler, NetAdapter::Id id, NetAdapter::Type type)
virtual INT | Write (const void *buf, INT buflen, InetSocketAddr *to=0)

Protected Member Functions

virtual void | OnAsyncEvent (InetSocket::Event event)

Detailed Description

UdpNetAdapter extends the APOXI UdpSocket class to implement asynchronous socket IO event-handling.

Constructor & Destructor Documentation

UdpNetAdapter::UdpNetAdapter | ( | NetAdapterHandler * | handler,
 |  | NetAdapter::Id | id,
 |  | NetAdapter::Type | type
 | ) |

Member Function Documentation

virtual SocketError UdpNetAdapter::GetError ( ) const [inline, virtual]

Implements ClientNetAdapter.

virtual INT UdpNetAdapter::GetInBufByteCount ( ) [inline, virtual]

Implements ClientNetAdapter.

virtual void UdpNetAdapter::OnAsyncEvent ( InetSocket::Event event ) [inline, protected, virtual]

Asynchronous event handler, defined in base class UdpSocket.

virtual INT UdpNetAdapter::Read | ( | void * | buf,
 |  | INT | buflen,
 |  | InetSocketAddr * | from = 0
 | ) | [inline, virtual]

Implements ClientNetAdapter.

virtual INT UdpNetAdapter::Write | ( | const void * | buf,
 |  | INT | buflen,
 |  | InetSocketAddr * | to = 0
 | ) | [inline, virtual]

Implements ClientNetAdapter.

The documentation for this class was generated from the following files:
  • Socket/NetAdapterHandler.hpp
  • Socket/NetAdapterHandler.cpp
Generated on Wed Jan 25 02:13:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UdpSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UdpSocket Class Reference
[Socket]

#include <Apoxi/Socket/UdpSocket.hpp>

Inheritance diagram for UdpSocket:

[legend]
Collaboration diagram for UdpSocket:

[legend]

Public Member Functions

BOOLEAN | HandOver (UdpSocket &to_socket)
BOOLEAN | Open (const InetSocketAddr *local_addr=0, BOOLEAN may_reuse_addr=TRUE)
INT | Read (void *buf, INT buflen, InetSocketAddr *from=0)
BOOLEAN | SetPeer (const InetSocketAddr &addr)
INT | Write (const void *buf, INT buflen, const InetSocketAddr *to=0)

Protected Member Functions

virtual void | OnControlMsg (const SocketControlMsg &msg)

Detailed Description

UdpSocket exposes interfaces to send/receive UDP datagrams.

Member Function Documentation

BOOLEAN UdpSocket::HandOver ( UdpSocket & to_socket ) [inline]

Hands over itself to to_socket. This socket is then reverted to closed state and hence does not operate any more. Instead, to_socket continues operation. This method should only be used to hand over a socket between execution contexts if needed. Note that if you hand over a socket from one execution context to another, also the execution context to which to_socket belongs must have initialized a socket handler. For the hand over to succeed this socket must be in open state and to_socket must be in closed state. If the hand over can not be performed FALSE is returned.

See also:
ExecutionContext

SocketHandler

Returns:
Success of hand over.

void UdpSocket::OnControlMsg ( const SocketControlMsg & msg ) [protected, virtual]

Translates the socket control message msg into a socket event and routes it accordingly. If a listener is set, its OnSocketEvent method is called. Otherwise the messages are discarded.

Implements InetSocket.

BOOLEAN UdpSocket::Open | ( | const InetSocketAddr * | local_addr = 0,
 |  | BOOLEAN | may_reuse_addr = TRUE
 | ) |

Open UDP type socket.

Parameters:
local_addr | local address to bind socket to
may_reuse_addr | local address may be bound by multiple sockets

INT UdpSocket::Read | ( | void * | buf,
 |  | INT | buflen,
 |  | InetSocketAddr * | from = 0
 | ) | [inline]

Reads data from the socket. The from parameter may be specified for retrieving the source address.

Returns:
Number of bytes read or -1 on failure.

Reimplemented from InetSocket.

Reimplemented in UdpNetAdapter.

BOOLEAN UdpSocket::SetPeer ( const InetSocketAddr & addr )

Sets the default address of peer. Write requests without receiver address will be sent to this default address. Note: Any datagrams received from an address other than the destination address specified will be discarded.

INT UdpSocket::Write | ( | const void * | buf,
 |  | INT | buflen,
 |  | const InetSocketAddr * | to = 0
 | ) | [inline]

Writes data to the socket. The to parameter may specify a destination address. If it is not specified, then the data is sent to the sockets default destination address previously established via SetPeer().

Returns:
Number of bytes written or -1 on failure.

Reimplemented from InetSocket.

The documentation for this class was generated from the following files:
  • Socket/UdpSocket.hpp
  • Socket/UdpSocket.cpp
Generated on Wed Jan 25 02:14:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UdpTestSocket Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UdpTestSocket Class Reference

#include <Applications/SocketTest/UdpTestSocket.hpp>

Inheritance diagram for UdpTestSocket:

[legend]
Collaboration diagram for UdpTestSocket:

[legend]

Public Types

enum | _constants { m_nHeaderSize = 32 }

Public Member Functions

void | CollectPackets (int testid, int nr_of_packets)
instructs socket to wait for n packets and send a signal when all received
UINT32 | GetReceivedPackets ()
returns number of received packets
UdpTestSocket (BOOLEAN send_continue_msg=TRUE)
virtual | ~UdpTestSocket ()

Protected Member Functions

virtual void | OnAsyncEvent (Event event)

Protected Attributes

InetSocketAddr m_addressOut
INT | m_nMessageSize
BOOLEAN * | m_nPacketsCollected
Array with info about collected packets.
UINT32 | m_nPacketsReceived
Number of received packets.
INT | m_nTestID
UINT32 | m_nWaitingForPackets
Number of packets socket waits for.
const BOOLEAN | m_send_continue_msg
Ticks m_ticks

Detailed Description

UdpTestSocket class is implementation of UDP socket used for testing.

Member Enumeration Documentation

enum UdpTestSocket::_constants

Enumerator:
m_nHeaderSize

Constructor & Destructor Documentation

UdpTestSocket::UdpTestSocket ( BOOLEAN send_continue_msg = TRUE )

UdpTestSocket::~UdpTestSocket ( ) [virtual]

Member Function Documentation

void UdpTestSocket::CollectPackets | ( | int | testid,
 |  | int | nr_of_packets
 | ) |

instructs socket to wait for n packets and send a signal when all received

Start collection of UDP test packets. Allocates and initializes all structures.

UINT32 UdpTestSocket::GetReceivedPackets ( ) [inline]

returns number of received packets

void UdpTestSocket::OnAsyncEvent ( Event event ) [protected, virtual]

Triggered by one of following events on UDP socket:

c_event_data_received - when data is received in UDP protocol, read this data and if this is test packet mark it as received and continue with receiving other packets. If this was last packet that should be received in this test, send a message to application.

c_event_data_sent - when packet was sent, send a message to application

Reimplemented from InetSocket.

Field Documentation

InetSocketAddr UdpTestSocket::m_addressOut [protected]

INT UdpTestSocket::m_nMessageSize [protected]

BOOLEAN* UdpTestSocket::m_nPacketsCollected [protected]

Array with info about collected packets.

UINT32 UdpTestSocket::m_nPacketsReceived [protected]

Number of received packets.

INT UdpTestSocket::m_nTestID [protected]

UINT32 UdpTestSocket::m_nWaitingForPackets [protected]

Number of packets socket waits for.

const BOOLEAN UdpTestSocket::m_send_continue_msg [protected]

Ticks UdpTestSocket::m_ticks [protected]

The documentation for this class was generated from the following files:
  • Applications/SocketTest/UdpTestSocket.hpp
  • Applications/SocketTest/UdpTestSocket.cpp
Generated on Wed Jan 25 02:14:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibAccessorTest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibAccessorTest Class Reference
[UnifiedInbox]

#include <Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.hpp>

Collaboration diagram for UibAccessorTest:

[legend]

Public Member Functions

const WCHAR * | GetName ()
Returns the name of the Test Case.
void | Init (MmiUnitTestSuite *suite, BOOLEAN proceed_on_failed=TRUE)
Initalizes TestUibData wiht name and MmiUnitTestSuite.
virtual TestResult | Run ()
Implement the Test Case.
UibAccessorTest (MmiUnitTestSuite *suite, BOOLEAN proceed_on_failed=TRUE)
UibAccessorTest ()
Constructor.
virtual | ~UibAccessorTest ()
Destructor.

Protected Member Functions

void | SetPreconditions ()
void | TestGetAction ()
void | TestGetActionCount ()
void | TestGetActionIndex (const Action &action)
void | TestInsertAction (INT index)
void | TestRemoveAccessor ()
void | TestRemoveAction (INT index)
void | TestRemoveAllActions ()
void | TestSetAccessor (ActionAccessor *accessor)
The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibAccessorTest.cpp
Generated on Wed Jan 25 02:14:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibActionAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibActionAccessor Class Reference
[GuiExtensionMenuAccessors]

#include <Applications/UnifiedInbox/UibActionAccessor.hpp>

Public Member Functions

virtual Action * | GetAction (INT index) const
virtual Action * | GetAction ()
virtual INT | GetActionCount () const
virtual INT | GetActionIndex (const Action &action) const
virtual void | InsertAction (INT index, Action *action)
void | RemoveAccessor ()
virtual void | RemoveAction (INT index)
virtual void | RemoveAllActions ()
void | SetAccessor (AbstractActionAccessor *accessor)
UibActionAccessor ()
~UibActionAccessor ()

Detailed Description

Provides an UibActionAccessor based on Actions. One Action represents one menu-item, hence every menu-item can have a text, an icon and may be enabled/disabled. When triggering a menu-item, the Action representing the item will be executed.
See also:
Action

Constructor & Destructor Documentation

UibActionAccessor::UibActionAccessor ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

UibActionAccessor::~UibActionAccessor ( )

Member Function Documentation

Action * UibActionAccessor::GetAction ( INT index ) const [virtual]

Action * UibActionAccessor::GetAction ( ) [virtual]

See also:
AbstractActionAccessor::GetAction

INT UibActionAccessor::GetActionCount ( ) const [virtual]

INT UibActionAccessor::GetActionIndex ( const Action & action ) const [virtual]

void UibActionAccessor::InsertAction | ( | INT | index,
 |  | Action * | action
 | ) | [virtual]

void UibActionAccessor::RemoveAccessor ( ) [inline]

void UibActionAccessor::RemoveAction ( INT index ) [virtual]

void UibActionAccessor::RemoveAllActions ( ) [virtual]

void UibActionAccessor::SetAccessor ( AbstractActionAccessor * accessor ) [inline]

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibActionAccessor.hpp
  • Applications/UnifiedInbox/UibActionAccessor.cpp
Generated on Wed Jan 25 02:14:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibApp Class Reference
[UnifiedInbox]

#include <Applications/UnifiedInbox/UibApp.hpp>

Collaboration diagram for UibApp:

[legend]

Public Types

enum | UibServiceType { RegisterType, NotifyType }

Public Member Functions

void | DeleteAllMsg (UibConfig::UibFolderTypes folder_type)
Deletes all rows of a specific folder.
virtual DataItem | GetContextDataItem (ContextFeature *feature)
INT | GetMessageType (INT index)
Provider * GetSettingsProvider ()
INT | GetSortColid (UibConfig::UibFolderTypes folder_type)
the id of the column to sort
SortProvider * | GetSortedFolderProvider (UibConfig::UibFolderTypes folder_type)
void | OnSortingChanged (UibConfig::UibFolderTypes folder_type)
void | ShowWaitingBox (BOOLEAN flag)
void | UpdateFolderProvider (UibConfig::UibFolderTypes folder_type)
virtual | ~UibApp ()
Destructor.

Static Public Member Functions

static UibApp * | GetInstance ()
one instance of the class

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &context_item)
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual void | OnGetFocus ()
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual BOOLEAN | OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)
virtual void | OnStartup ()
virtual void | OnUibNotifyService ()
virtual void | OnUibRegisterService (UINT8 box_type, Provider *provider)
The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibApp.hpp
  • Applications/UnifiedInbox/UibApp.cpp
Generated on Wed Jan 25 02:14:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibFolderWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibFolderWin Class Reference
[UnifiedInbox]

#include <Applications/UnifiedInbox/UibFolderWin.hpp>

Inheritance diagram for UibFolderWin:

[legend]
Collaboration diagram for UibFolderWin:

[legend]

Public Member Functions

UibConfig::UibFolderTypes | GetFolderType () const
INT | GetSelectedMsg ()
Returns the selected index of the message.
void | Init (UibApp *uib_app, UibConfig::UibFolderTypes folder_type, AbstractItemContainer *item_cont)
void | SetFolderType (UibConfig::UibFolderTypes folder_type)
void | SetUibContextId ()
UibFolderWin ()
Constructor.
void | Update ()
virtual | ~UibFolderWin ()
Destructor.

Protected Member Functions

virtual void | OnGetFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnSelectionChanged ()
Notifies Context Manager about selection change events.
virtual void | OnUpdate (ObservableObject *obs_obj)
The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibFolderWin.hpp
  • Applications/UnifiedInbox/UibFolderWin.cpp
Generated on Wed Jan 25 02:14:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibInboxProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibInboxProvider Class Reference
[UnifiedInbox]

#include <Applications/UnifiedInbox/UibInboxProvider.hpp>

Inheritance diagram for UibInboxProvider:

[legend]
Collaboration diagram for UibInboxProvider:

[legend]

Public Member Functions

virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
em>GetChildRow returns GetMappedRow
UibInboxProvider ()
~UibInboxProvider ()

Protected Member Functions

virtual void | OnUpdate (ObservableObject *obs_obj)

Constructor & Destructor Documentation

UibInboxProvider::UibInboxProvider ( )

UibInboxProvider::~UibInboxProvider ( )

Member Function Documentation

BOOLEAN UibInboxProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual]

em>GetChildRow returns GetMappedRow

Returns the DataItem from a specific row and columnid

Parameters:
columnid
row
DataItem

Reimplemented from AppendProvider.

virtual void UibInboxProvider::OnUpdate ( ObservableObject * obs_obj ) [inline, protected, virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from AbstractDelegationProvider.

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibInboxProvider.hpp
  • Applications/UnifiedInbox/UibInboxProvider.cpp
Generated on Wed Jan 25 02:14:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibInboxTest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibInboxTest Class Reference

#include <Applications/UnifiedInbox/UibUnitTests/UibInboxTest.hpp>

Inheritance diagram for UibInboxTest:

[legend]
Collaboration diagram for UibInboxTest:

[legend]

Public Types

enum | ContextActions { Action1, Action2, Action3, ActionCnt }

Public Member Functions

void | Init (WCHAR *name, MmiUnitTestSuite *suite)
virtual TestResult | Run ()
Implement the Test Case.
UibInboxTest ()
virtual | ~UibInboxTest ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnUpdate (ObservableObject *obs_obj)

Member Enumeration Documentation

enum UibInboxTest::ContextActions

Enumerator:
Action1
Action2
Action3
ActionCnt

Constructor & Destructor Documentation

UibInboxTest::UibInboxTest ( ) [inline]

UibInboxTest::~UibInboxTest ( ) [virtual]

Member Function Documentation

void UibInboxTest::Init | ( | WCHAR * | name,
 |  | MmiUnitTestSuite * | suite
 | ) |

BOOLEAN UibInboxTest::OnMessage ( const Message & msg ) [protected, virtual]

void UibInboxTest::OnUpdate ( ObservableObject * obs_obj ) [protected, virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from Observer.

TestResult UibInboxTest::Run ( ) [virtual]

Implement the Test Case.

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibInboxTest.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibInboxTest.cpp
Generated on Wed Jan 25 02:14:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibListBoxModel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibListBoxModel Class Reference
[UnifiedInbox]

#include <Applications/UnifiedInbox/UibListBoxModel.hpp>

Collaboration diagram for UibListBoxModel:

[legend]

Public Member Functions

virtual const BitmapRes * | GetCellIcon (INT index, BOOLEAN highlighted)
virtual const WCHAR * | GetCellText (INT index, BOOLEAN highlighted)
Provider * GetProvider ()
void | Init (DrawableObjectListBox *list_box, Provider *provider)
Initialize the UibListBoxModel with DrawableObjectListBox and UibInboxWin.
void | SetProvider (Provider *provider)
UibListBoxModel ()
Constructor.
virtual void | Update (INT item_count=-1)
virtual | ~UibListBoxModel ()
Destructor.
The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibListBoxModel.hpp
  • Applications/UnifiedInbox/UibListBoxModel.cpp
Generated on Wed Jan 25 02:14:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibMsgDisplayTest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibMsgDisplayTest Class Reference
[UnifiedInobx]

#include <Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.hpp>

Collaboration diagram for UibMsgDisplayTest:

[legend]

Public Member Functions

const WCHAR * | GetName ()
Returns the name of the Test Case.
void | Init (MmiUnitTestSuite *suite, BOOLEAN proceed_on_failed=TRUE)
Initalizes TestUibData wiht name and MmiUnitTestSuite.
virtual TestResult | Run ()
Implement the Test Case.
UibMsgDisplayTest (MmiUnitTestSuite *suite, BOOLEAN proceed_on_failed=TRUE)
UibMsgDisplayTest ()
Constructor.
virtual | ~UibMsgDisplayTest ()
Destructor.

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
void | SetPreconditions ()
The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibMsgDisplayTest.cpp
Generated on Wed Jan 25 02:14:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibNotifyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibNotifyMsg Class Reference

#include <Applications/UnifiedInbox/UibMsgTypes.hpp>

Inheritance diagram for UibNotifyMsg:

[legend]
Collaboration diagram for UibNotifyMsg:

[legend]

Public Types

enum | { ID = 30001 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UibNotifyMsg (Application *application)
virtual | ~UibNotifyMsg ()

Protected Member Functions

virtual void | Dump (OutputStream &ostr) const

Friends

OutputStream & | operator<< (OutputStream &ostr, const UibNotifyMsg &cls)
InputStream & | operator>> (InputStream &istr, UibNotifyMsg &cls)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UibNotifyMsg::UibNotifyMsg ( Application * application )

UibNotifyMsg::~UibNotifyMsg ( ) [virtual]

Member Function Documentation

Message * UibNotifyMsg::Clone ( ) const [virtual]

Implements Message.

void UibNotifyMsg::Dump ( OutputStream & ostr ) const [protected, virtual]

const MsgMetaData & UibNotifyMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const UibNotifyMsg & | cls
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | UibNotifyMsg & | cls
 | ) | [friend]

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibMsgTypes.hpp
  • Applications/UnifiedInbox/UibMsgTypes.cpp
Generated on Wed Jan 25 02:14:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibNotifyTest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibNotifyTest Class Reference

#include <Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.hpp>

Collaboration diagram for UibNotifyTest:

[legend]

Public Member Functions

void | Init (WCHAR *name, MmiUnitTestSuite *suite)
virtual TestResult | Run ()
Implement the Test Case.
UibNotifyTest ()
virtual | ~UibNotifyTest ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
void | SetPreconditions ()

Constructor & Destructor Documentation

UibNotifyTest::UibNotifyTest ( ) [inline]

UibNotifyTest::~UibNotifyTest ( ) [virtual]

Member Function Documentation

void UibNotifyTest::Init | ( | WCHAR * | name,
 |  | MmiUnitTestSuite * | suite
 | ) |

BOOLEAN UibNotifyTest::OnMessage ( const Message & msg ) [protected, virtual]

TestResult UibNotifyTest::Run ( ) [virtual]

Implement the Test Case.

void UibNotifyTest::SetPreconditions ( ) [protected]

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibNotifyTest.cpp
Generated on Wed Jan 25 02:14:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibPerformanceTest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibPerformanceTest Class Reference

#include <Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.hpp>

Inheritance diagram for UibPerformanceTest:

[legend]
Collaboration diagram for UibPerformanceTest:

[legend]

Public Member Functions

void | Init (WCHAR *name, MmiUnitTestSuite *suite)
virtual TestResult | Run ()
Implement the Test Case.
void | TestAddEntryPerf ()
void | TestDeleteEntryPerf (INT id)
void | TestUpdateTime (INT sort_colid)
UibPerformanceTest ()
virtual | ~UibPerformanceTest ()

Protected Member Functions

const WCHAR * | GetTextForMsgType (UibConfig::UibMessageTypes msg_type) const
BOOLEAN | OnMessage (const Message &msg)
virtual void | OnUpdate (ObservableObject *obs_obj)

Constructor & Destructor Documentation

UibPerformanceTest::UibPerformanceTest ( ) [inline]

UibPerformanceTest::~UibPerformanceTest ( ) [virtual]

Member Function Documentation

const WCHAR * UibPerformanceTest::GetTextForMsgType ( UibConfig::UibMessageTypes msg_type ) const [protected]

void UibPerformanceTest::Init | ( | WCHAR * | name,
 |  | MmiUnitTestSuite * | suite
 | ) |

BOOLEAN UibPerformanceTest::OnMessage ( const Message & msg ) [protected]

void UibPerformanceTest::OnUpdate ( ObservableObject * obs_obj ) [protected, virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from Observer.

TestResult UibPerformanceTest::Run ( ) [virtual]

Implement the Test Case.

void UibPerformanceTest::TestAddEntryPerf ( )

void UibPerformanceTest::TestDeleteEntryPerf ( INT id )

void UibPerformanceTest::TestUpdateTime ( INT sort_colid )

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibPerformanceTest.cpp
Generated on Wed Jan 25 02:14:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibRegisterMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibRegisterMsg Class Reference

#include <Applications/UnifiedInbox/UibMsgTypes.hpp>

Inheritance diagram for UibRegisterMsg:

[legend]
Collaboration diagram for UibRegisterMsg:

[legend]

Public Types

enum | { ID = 30000 }

Public Member Functions

virtual Message * | Clone () const
UINT8 | GetBoxType () const
Provider * | GetFolder () const
virtual const MsgMetaData & | GetMetaData () const
void | SetBoxType (UINT8 box_type)
void | SetFolder (Provider *folder)
UibRegisterMsg (Application *application, UINT8 box_type, Provider *folder)
virtual | ~UibRegisterMsg ()

Protected Member Functions

virtual void | Dump (OutputStream &ostr) const

Friends

OutputStream & | operator<< (OutputStream &ostr, const UibRegisterMsg &cls)
InputStream & | operator>> (InputStream &istr, UibRegisterMsg &cls)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UibRegisterMsg::UibRegisterMsg | ( | Application * | application,
 |  | UINT8 | box_type,
 |  | Provider * | folder
 | ) |

UibRegisterMsg::~UibRegisterMsg ( ) [virtual]

Member Function Documentation

Message * UibRegisterMsg::Clone ( ) const [virtual]

Implements Message.

void UibRegisterMsg::Dump ( OutputStream & ostr ) const [protected, virtual]

UINT8 UibRegisterMsg::GetBoxType ( ) const [inline]

Provider* UibRegisterMsg::GetFolder ( ) const [inline]

const MsgMetaData & UibRegisterMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void UibRegisterMsg::SetBoxType ( UINT8 box_type ) [inline]

void UibRegisterMsg::SetFolder ( Provider * folder ) [inline]

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const UibRegisterMsg & | cls
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | UibRegisterMsg & | cls
 | ) | [friend]

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibMsgTypes.hpp
  • Applications/UnifiedInbox/UibMsgTypes.cpp
Generated on Wed Jan 25 02:14:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibServiceImpl Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibServiceImpl Class Reference
[UnifiedInbox]

#include <Applications/UnifiedInbox/UibServiceImpl.hpp>

Collaboration diagram for UibServiceImpl:

[legend]

Public Member Functions

void | Init (Application *app)
virtual ServiceResult | NotifyArrival () const
virtual ServiceResult | Register (UINT8 box_type, Provider *folder) const
UibServiceImpl ()
virtual | ~UibServiceImpl ()

Constructor & Destructor Documentation

UibServiceImpl::~UibServiceImpl ( ) [virtual]

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibServiceImpl.hpp
  • Applications/UnifiedInbox/UibServiceImpl.cpp
Generated on Wed Jan 25 02:14:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibSettingsProvider Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibSettingsProvider Class Reference
[UnifiedInbox]

#include <Applications/UnifiedInbox/UibSettingsProvider.hpp>

Inheritance diagram for UibSettingsProvider:

[legend]
Collaboration diagram for UibSettingsProvider:

[legend]

Public Member Functions

virtual BOOLEAN | CommitRow (INT row)
Commit updates done in a row.
virtual BOOLEAN | GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
virtual INT | GetProviderId () const
Returns the provider id.
void | Init ()
virtual void | RestoreFactorySettings ()
Sets all Provider settings back to default.
virtual INT | RowCount ()
RowCount returns the number of rows.
virtual BOOLEAN | SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | SetDataItem (const DataItem &item, INT columnid)
UibSettingsProvider ()
Constructor.
virtual | ~UibSettingsProvider ()
Destructor.
The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibSettingsProvider.hpp
  • Applications/UnifiedInbox/UibSettingsProvider.cpp
Generated on Wed Jan 25 02:14:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibSettingsRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibSettingsRecord Class Reference

#include <Applications/UnifiedInbox/UibSettingsRecord.hpp>

Inheritance diagram for UibSettingsRecord:

[legend]
Collaboration diagram for UibSettingsRecord:

[legend]

Public Member Functions

virtual const UINT8 * | GetData ()
virtual INT | GetPersistentSize ()
UINT8 | GetSortKey () const
Returns the sort key.
virtual BOOLEAN | IsRecordDeleted ()
BOOLEAN | IsSortAsc () const
Returns TRUE if sort order is ascending, FALSE if descending.
virtual void | MarkDeleted ()
virtual void | SetData (const UINT8 *data)
void | SetDefault ()
Sets the default values.
void | SetSortAsc (BOOLEAN flag)
Sets the sort order. TRUE if ascending, FALSE if descending.
void | SetSortKey (UINT8 value)
Sets the sort key.
UibSettingsRecord (UINT8 sort_key=0, BOOLEAN sort_asc=TRUE)

Data Structures

struct | Persist

Constructor & Destructor Documentation

UibSettingsRecord::UibSettingsRecord | ( | UINT8 | sort_key = 0,
 |  | BOOLEAN | sort_asc = TRUE
 | ) |

Member Function Documentation

const UINT8 * UibSettingsRecord::GetData ( ) [virtual]

Method reads the SMS settings data field from non-volatile memory.

Returns:
Pointer to SMS settings data field that contains current data

Implements Record.

INT UibSettingsRecord::GetPersistentSize ( ) [virtual]

Method determines the size of the SMS settings data field.

Returns:
Size of SMS settings data field (in bytes).

Implements Record.

UINT8 UibSettingsRecord::GetSortKey ( ) const [inline]

Returns the sort key.

BOOLEAN UibSettingsRecord::IsRecordDeleted ( ) [virtual]

Reimplemented from Record.

BOOLEAN UibSettingsRecord::IsSortAsc ( ) const [inline]

Returns TRUE if sort order is ascending, FALSE if descending.

void UibSettingsRecord::MarkDeleted ( ) [virtual]

Reimplemented from Record.

void UibSettingsRecord::SetData ( const UINT8 * data ) [virtual]

Method writes a SMS settings data field to non-volatile memory.

Parameters:
data SMS settings data field that should be stored on non-volatile memory

Implements Record.

void UibSettingsRecord::SetDefault ( )

Sets the default values.

void UibSettingsRecord::SetSortAsc ( BOOLEAN flag ) [inline]

Sets the sort order. TRUE if ascending, FALSE if descending.

void UibSettingsRecord::SetSortKey ( UINT8 value ) [inline]

Sets the sort key.

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibSettingsRecord.hpp
  • Applications/UnifiedInbox/UibSettingsRecord.cpp
Generated on Wed Jan 25 02:14:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibSettingsTest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibSettingsTest Class Reference

#include <Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.hpp>

Collaboration diagram for UibSettingsTest:

[legend]

Public Member Functions

void | Init (WCHAR *name, MmiUnitTestSuite *suite)
virtual TestResult | Run ()
Implement the Test Case.
void | TestPredefinedSettings ()
void | TestSettingsDisplay ()
void | TestSettingsModification (const DataItem &sort_crit, const DataItem &sort_asc)
void | TestSettingsProvider (const DataItem &sort_crit, const DataItem &sort_asc)
UibSettingsTest ()
virtual | ~UibSettingsTest ()

Constructor & Destructor Documentation

UibSettingsTest::UibSettingsTest ( ) [inline]

UibSettingsTest::~UibSettingsTest ( ) [virtual]

Member Function Documentation

void UibSettingsTest::Init | ( | WCHAR * | name,
 |  | MmiUnitTestSuite * | suite
 | ) |

TestResult UibSettingsTest::Run ( ) [virtual]

Implement the Test Case.

void UibSettingsTest::TestPredefinedSettings ( )

void UibSettingsTest::TestSettingsDisplay ( )

void UibSettingsTest::TestSettingsModification | ( | const DataItem & | sort_crit,
 |  | const DataItem & | sort_asc
 | ) |

void UibSettingsTest::TestSettingsProvider | ( | const DataItem & | sort_crit,
 |  | const DataItem & | sort_asc
 | ) |

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibSettingsTest.cpp
Generated on Wed Jan 25 02:14:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibSettingsWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibSettingsWin Class Reference
[UnifiedInbox]

#include <Applications/UnifiedInbox/UibSettingsWin.hpp>

Collaboration diagram for UibSettingsWin:

[legend]

Public Member Functions

void | Init (Provider *settings_provider)
void | SetFolderType (UibConfig::UibFolderTypes folder_type)
UibSettingsWin (Provider *settings_provider=0)
UibSettingsWin.
virtual | ~UibSettingsWin ()
Destructor.

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnConfirm ()
virtual void | OnOpen ()
The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibSettingsWin.hpp
  • Applications/UnifiedInbox/UibSettingsWin.cpp
Generated on Wed Jan 25 02:14:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibSortingTest Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibSortingTest Class Reference

#include <Applications/UnifiedInbox/UibUnitTests/UibSortingTest.hpp>

Collaboration diagram for UibSortingTest:

[legend]

Public Member Functions

void | Init (WCHAR *name, MmiUnitTestSuite *suite)
virtual TestResult | Run ()
Implement the Test Case.
UibSortingTest ()
virtual | ~UibSortingTest ()

Constructor & Destructor Documentation

UibSortingTest::UibSortingTest ( ) [inline]

UibSortingTest::~UibSortingTest ( ) [virtual]

Member Function Documentation

void UibSortingTest::Init | ( | WCHAR * | name,
 |  | MmiUnitTestSuite * | suite
 | ) |

TestResult UibSortingTest::Run ( ) [virtual]

Implement the Test Case.

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibSortingTest.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibSortingTest.cpp
Generated on Wed Jan 25 02:14:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibTest1 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibTest1 Class Reference

#include <Applications/UnifiedInbox/UibUnitTests/UibTests.hpp>

Public Member Functions

void | Init (WCHAR *name, MmiUnitTestSuite *suite)
virtual TestResult | Run ()
Implement the Test Case.
UibTest1 ()
virtual | ~UibTest1 ()

Constructor & Destructor Documentation

UibTest1::UibTest1 ( ) [inline]

UibTest1::~UibTest1 ( ) [virtual]

Member Function Documentation

void UibTest1::Init | ( | WCHAR * | name,
 |  | MmiUnitTestSuite * | suite
 | ) |

TestResult UibTest1::Run ( ) [virtual]

Implement the Test Case.

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibTests.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibTests.cpp
Generated on Wed Jan 25 02:14:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibTest2 Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibTest2 Class Reference

#include <Applications/UnifiedInbox/UibUnitTests/UibTests.hpp>

Public Member Functions

void | Init (WCHAR *name, MmiUnitTestSuite *suite)
virtual TestResult | Run ()
Implement the Test Case.
UibTest2 ()
virtual | ~UibTest2 ()

Constructor & Destructor Documentation

UibTest2::UibTest2 ( ) [inline]

UibTest2::~UibTest2 ( ) [virtual]

Member Function Documentation

void UibTest2::Init | ( | WCHAR * | name,
 |  | MmiUnitTestSuite * | suite
 | ) |

TestResult UibTest2::Run ( ) [virtual]

Implement the Test Case.

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUnitTests/UibTests.hpp
  • Applications/UnifiedInbox/UibUnitTests/UibTests.cpp
Generated on Wed Jan 25 02:14:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibUpdateMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibUpdateMsg Class Reference

#include <Applications/UnifiedInbox/UibMsgTypes.hpp>

Inheritance diagram for UibUpdateMsg:

[legend]
Collaboration diagram for UibUpdateMsg:

[legend]

Public Types

enum | { ID = 30002 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UibUpdateMsg (Application *application)
virtual | ~UibUpdateMsg ()

Protected Member Functions

virtual void | Dump (OutputStream &ostr) const

Friends

OutputStream & | operator<< (OutputStream &ostr, const UibUpdateMsg &cls)
InputStream & | operator>> (InputStream &istr, UibUpdateMsg &cls)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UibUpdateMsg::UibUpdateMsg ( Application * application )

UibUpdateMsg::~UibUpdateMsg ( ) [virtual]

Member Function Documentation

Message * UibUpdateMsg::Clone ( ) const [virtual]

Implements Message.

void UibUpdateMsg::Dump ( OutputStream & ostr ) const [protected, virtual]

const MsgMetaData & UibUpdateMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

Friends And Related Function Documentation

OutputStream& operator<< | ( | OutputStream & | ostr,
 |  | const UibUpdateMsg & | cls
 | ) | [friend]

InputStream& operator>> | ( | InputStream & | istr,
 |  | UibUpdateMsg & | cls
 | ) | [friend]

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibMsgTypes.hpp
  • Applications/UnifiedInbox/UibMsgTypes.cpp
Generated on Wed Jan 25 02:14:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UibUpdateThreadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UibUpdateThreadlet Class Reference
[Kernel]

#include <Applications/UnifiedInbox/UibUpdateThreadlet.hpp>

Inheritance diagram for UibUpdateThreadlet:

[legend]
Collaboration diagram for UibUpdateThreadlet:

[legend]

Public Member Functions

virtual INT | Fn ()
void | Init (Provider *provider)
void | SetProvider (Provider *provider)
UibUpdateThreadlet ()
virtual | ~UibUpdateThreadlet ()

Detailed Description

A UibUpdateThreadlet exposes a generic interface to execute parts of an application in context of another thread (i.e the GenericWorkerTask).
See also:
GenericWorkerTask

Constructor & Destructor Documentation

UibUpdateThreadlet::UibUpdateThreadlet ( )

UibUpdateThreadlet::~UibUpdateThreadlet ( ) [virtual]

Member Function Documentation

INT UibUpdateThreadlet::Fn ( ) [virtual]

Fn is the function that will be executed in thread context. Be aware of restrictions to operations that can be performed in thread context.

Implements Threadlet.

void UibUpdateThreadlet::Init ( Provider * provider ) [inline]

void UibUpdateThreadlet::SetProvider ( Provider * provider ) [inline]

The documentation for this class was generated from the following files:
  • Applications/UnifiedInbox/UibUpdateThreadlet.hpp
  • Applications/UnifiedInbox/UibUpdateThreadlet.cpp
Generated on Wed Jan 25 02:14:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UmtsCellList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UmtsCellList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for UmtsCellList:

[legend]

Public Types

enum | { MaxTotalUmtsCells = EM_MAX_TOTAL_UMTS_CELLS }

Public Member Functions

UmtsCellList | operator= (T_UMTS_CELL_LIST umts_cell_list)
UmtsNcellParam & | operator[] (INT index)

Data Fields

UmtsNcellParam | umts_neighbour_cells [MaxTotalUmtsCells]

Member Enumeration Documentation

anonymous enum

Enumerator:
MaxTotalUmtsCells

Member Function Documentation

UmtsCellList UmtsCellList::operator= ( T_UMTS_CELL_LIST umts_cell_list )

UmtsNcellParam& UmtsCellList::operator[] ( INT index ) [inline]

Field Documentation

UmtsNcellParam UmtsCellList::umts_neighbour_cells[MaxTotalUmtsCells]

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 02:14:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UmtsMeasEvalParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UmtsMeasEvalParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for UmtsMeasEvalParam:

[legend]

Public Types

enum | MaxDataElements { MaxMeas = MAXMEAS }

Public Member Functions

BOOLEAN | IsP1Invalid ()
BOOLEAN | IsP2Invalid ()
UmtsMeasEvalParam | operator= (T_UMTS_MEAS_EVAL_PARAM umts_meas_eval_param)
UmtsMeasEvalParam ()

Data Fields

UINT8 | p1
UINT8 | p2
UmtsMeasIdParam | umts_meas_id_params [MaxMeas]

Member Enumeration Documentation

enum UmtsMeasEvalParam::MaxDataElements

Enumerator:
MaxMeas

Constructor & Destructor Documentation

UmtsMeasEvalParam::UmtsMeasEvalParam ( ) [inline]

Member Function Documentation

BOOLEAN UmtsMeasEvalParam::IsP1Invalid ( ) [inline]

BOOLEAN UmtsMeasEvalParam::IsP2Invalid ( ) [inline]

UmtsMeasEvalParam UmtsMeasEvalParam::operator= ( T_UMTS_MEAS_EVAL_PARAM umts_meas_eval_param )

Field Documentation

UINT8 UmtsMeasEvalParam::p1

UINT8 UmtsMeasEvalParam::p2

UmtsMeasIdParam UmtsMeasEvalParam::umts_meas_id_params[MaxMeas]

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 02:14:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UmtsMeasIdParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UmtsMeasIdParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Types

enum | MaxDataElements { MaxDataElementsPerMeasId = MAX_DATA_ELEMENTS_PER_MEAS_ID }

Public Member Functions

BOOLEAN | IsEventIdInvalid ()
BOOLEAN | IsMeasIdInvalid ()
UmtsMeasIdParam | operator= (T_UMTS_MEAS_ID_PARAM umts_meas_id_param_array)
UmtsMeasIdParam ()

Data Fields

UINT8 | data_elements [MaxDataElementsPerMeasId]
UINT8 | event_id
UINT8 | meas_id

Member Enumeration Documentation

enum UmtsMeasIdParam::MaxDataElements

Enumerator:
MaxDataElementsPerMeasId

Constructor & Destructor Documentation

UmtsMeasIdParam::UmtsMeasIdParam ( ) [inline]

Member Function Documentation

BOOLEAN UmtsMeasIdParam::IsEventIdInvalid ( ) [inline]

BOOLEAN UmtsMeasIdParam::IsMeasIdInvalid ( ) [inline]

UmtsMeasIdParam UmtsMeasIdParam::operator= ( T_UMTS_MEAS_ID_PARAM umts_meas_id_param_array )

Field Documentation

UINT8 UmtsMeasIdParam::data_elements[MaxDataElementsPerMeasId]

UINT8 UmtsMeasIdParam::event_id

UINT8 UmtsMeasIdParam::meas_id

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 02:14:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UmtsNcellParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UmtsNcellParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

BOOLEAN | DlUarfcnInvalid ()
BOOLEAN | IsCpichEcn0Invalid ()
BOOLEAN | IsCpichRscpInvalid ()
BOOLEAN | IsCpichScInvalid ()
BOOLEAN | IsRankingValueInvalid ()
BOOLEAN | IsRankPosInvalid ()
UmtsNcellParam | operator= (T_UMTS_NCELL_PARAM umts_ncell_param)
UmtsNcellParam ()

Data Fields

EmCellType cell_type
UINT8 | cpich_ecn0
UINT16 | cpich_rscp
DlSc cpich_sc
Uarfcn dl_uarfcn
UINT8 | rank_pos
EmRankingStatus ranking_status
UINT16 | ranking_value

Constructor & Destructor Documentation

UmtsNcellParam::UmtsNcellParam ( ) [inline]

Member Function Documentation

BOOLEAN UmtsNcellParam::DlUarfcnInvalid ( ) [inline]

BOOLEAN UmtsNcellParam::IsCpichEcn0Invalid ( ) [inline]

BOOLEAN UmtsNcellParam::IsCpichRscpInvalid ( ) [inline]

BOOLEAN UmtsNcellParam::IsCpichScInvalid ( ) [inline]

BOOLEAN UmtsNcellParam::IsRankingValueInvalid ( ) [inline]

BOOLEAN UmtsNcellParam::IsRankPosInvalid ( ) [inline]

UmtsNcellParam UmtsNcellParam::operator= ( T_UMTS_NCELL_PARAM umts_ncell_param )

Field Documentation

EmCellType UmtsNcellParam::cell_type

UINT8 UmtsNcellParam::cpich_ecn0

UINT16 UmtsNcellParam::cpich_rscp

DlSc UmtsNcellParam::cpich_sc

Uarfcn UmtsNcellParam::dl_uarfcn

UINT8 UmtsNcellParam::rank_pos

EmRankingStatus UmtsNcellParam::ranking_status

UINT16 UmtsNcellParam::ranking_value

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 02:14:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UmtsNcellParamList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UmtsNcellParamList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for UmtsNcellParamList:

[legend]

Public Member Functions

UmtsNcellParamList | operator= (T_UMTS_NCELL_PARAM_LIST umts_ncell_param_list)

Data Fields

UINT8 | no_active_set_cells
UINT8 | no_umts_cells
UINT8 | no_virtual_active_set_cells
UmtsCellList umts_ncell_param_list

Member Function Documentation

UmtsNcellParamList UmtsNcellParamList::operator= ( T_UMTS_NCELL_PARAM_LIST umts_ncell_param_list )

Field Documentation

UINT8 UmtsNcellParamList::no_active_set_cells

UINT8 UmtsNcellParamList::no_umts_cells

UINT8 UmtsNcellParamList::no_virtual_active_set_cells

UmtsCellList UmtsNcellParamList::umts_ncell_param_list

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 02:14:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UmtsRrcScellParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UmtsRrcScellParam Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for UmtsRrcScellParam:

[legend]

Public Member Functions

BOOLEAN | IsCellIdentityInvalid ()
BOOLEAN | IsCpichEcn0Invalid ()
BOOLEAN | IsCpichRscpInvalid ()
BOOLEAN | IsDlUarfcnInvalid ()
BOOLEAN | IsLacInvalid ()
BOOLEAN | IsPScInvalid ()
BOOLEAN | IsRacInvalid ()
BOOLEAN | IsRankingValueInvalid ()
BOOLEAN | IsUlUarfcnInvalid ()
UmtsRrcScellParam | operator= (T_UMTS_RRC_SCELL_PARAM umts_rrc_scell_param)
UmtsRrcScellParam ()

Data Fields

UINT32 | cell_identity
BOOLEAN | cipher_on
UINT8 | cpich_ecn0
UINT16 | cpich_rscp
Uarfcn dl_uarfcn
BOOLEAN | hcs_used
BOOLEAN | high_mobility
UINT16 | lac
BOOLEAN | limited_service
BOOLEAN | out_of_service
DlSc p_sc
Uplmn plmn_id
UINT8 | rac
UINT16 | ranking_value
Uarfcn ul_uarfcn

Constructor & Destructor Documentation

UmtsRrcScellParam::UmtsRrcScellParam ( ) [inline]

Member Function Documentation

BOOLEAN UmtsRrcScellParam::IsCellIdentityInvalid ( ) [inline]

BOOLEAN UmtsRrcScellParam::IsCpichEcn0Invalid ( ) [inline]

BOOLEAN UmtsRrcScellParam::IsCpichRscpInvalid ( ) [inline]

BOOLEAN UmtsRrcScellParam::IsDlUarfcnInvalid ( ) [inline]

BOOLEAN UmtsRrcScellParam::IsLacInvalid ( ) [inline]

BOOLEAN UmtsRrcScellParam::IsPScInvalid ( ) [inline]

BOOLEAN UmtsRrcScellParam::IsRacInvalid ( ) [inline]

BOOLEAN UmtsRrcScellParam::IsRankingValueInvalid ( ) [inline]

BOOLEAN UmtsRrcScellParam::IsUlUarfcnInvalid ( ) [inline]

UmtsRrcScellParam UmtsRrcScellParam::operator= ( T_UMTS_RRC_SCELL_PARAM umts_rrc_scell_param )

Field Documentation

UINT32 UmtsRrcScellParam::cell_identity

BOOLEAN UmtsRrcScellParam::cipher_on

UINT8 UmtsRrcScellParam::cpich_ecn0

UINT16 UmtsRrcScellParam::cpich_rscp

Uarfcn UmtsRrcScellParam::dl_uarfcn

BOOLEAN UmtsRrcScellParam::hcs_used

BOOLEAN UmtsRrcScellParam::high_mobility

UINT16 UmtsRrcScellParam::lac

BOOLEAN UmtsRrcScellParam::limited_service

BOOLEAN UmtsRrcScellParam::out_of_service

DlSc UmtsRrcScellParam::p_sc

Uplmn UmtsRrcScellParam::plmn_id

UINT8 UmtsRrcScellParam::rac

UINT16 UmtsRrcScellParam::ranking_value

Uarfcn UmtsRrcScellParam::ul_uarfcn

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 02:14:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UndefinedSsAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UndefinedSsAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for UndefinedSsAction:

[legend]
Collaboration diagram for UndefinedSsAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
UndefinedSsAction ()
virtual | ~UndefinedSsAction ()

Detailed Description

UndefinedSsAction analyzes if the input string has the meaning of an SS string, that means, it starts with an *,#,**,## or *# and ends with an terminating #, this action will be delivered if other SS actions are not returned.

Constructor & Destructor Documentation

UndefinedSsAction::UndefinedSsAction ( )

UndefinedSsAction::~UndefinedSsAction ( ) [virtual]

Member Function Documentation

InputAction * UndefinedSsAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType UndefinedSsAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

BOOLEAN UndefinedSsAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 02:14:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnlockAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UnlockAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for UnlockAction:

[legend]
Collaboration diagram for UnlockAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)=0
virtual BOOLEAN | Execute ()=0
virtual InputActionType | GetActionType () const
never overwrite this method
virtual BOOLEAN | IsExecutionPossible ()=0
UnlockAction ()
virtual | ~UnlockAction ()

Detailed Description

UnlockAction shall analyze if the input string has the meaning of unlocking a lock. This class is only an "abstract" base class. All methods has to be implemented by the application developer, which shall define the various unlock string sequences.

Constructor & Destructor Documentation

UnlockAction::UnlockAction ( )

UnlockAction::~UnlockAction ( ) [virtual]

Member Function Documentation

virtual InputAction* UnlockAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [pure virtual]

overwrite this method, it has to analyze the actionstring, for the certain unlocking codes e.g. #9001key# and #9002key# etc. and set internal states like the unlock-type and the unlocking key in the derived class. Return 0 if there was a syntax error, return "this" if the analyzing was successfull. This method is called automatically by the InputAnalyzer.

Reimplemented from InputAction.

virtual BOOLEAN UnlockAction::Execute ( ) [pure virtual]

overwrite this method: this method shall execute dependend of the analyzed states (type of unlock, unlock key etc. set by the Analyze method) the unlock procedure by calling ADC methods.

Reimplemented from InputAction.

InputActionType UnlockAction::GetActionType ( ) const [virtual]

never overwrite this method

Reimplemented from InputAction.

virtual BOOLEAN UnlockAction::IsExecutionPossible ( ) [pure virtual]

overwrite: the internal state must be set after Analyze was called by the InputAnalyzer and method shall return TRUE if syntax analyzeing was successfull.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 02:14:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnsignedValue Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UnsignedValue Struct Reference

Structure for storing unsigned values. More...

#include <Apoxi/AddOns/Lcs/Common/LcsTypes.hpp>

Public Member Functions

void | operator *= (const UnsignedValue &rhs)
*= operator
BOOLEAN | operator< (const UnsignedValue &rhs) const
< operator
BOOLEAN | operator== (const UnsignedValue &rhs) const
== operator
BOOLEAN | operator> (const UnsignedValue &rhs) const
> operator

Data Fields

UINT16 | m_exponent
Exponent part.
UINT32 | m_mantissa
Mantissa part.

Detailed Description

Structure for storing unsigned values.

Member Function Documentation

void UnsignedValue::operator *= ( const UnsignedValue & rhs ) [inline]

*= operator

BOOLEAN UnsignedValue::operator< ( const UnsignedValue & rhs ) const [inline]

< operator

BOOLEAN UnsignedValue::operator== ( const UnsignedValue & rhs ) const [inline]

== operator

BOOLEAN UnsignedValue::operator> ( const UnsignedValue & rhs ) const [inline]

> operator

Field Documentation

UINT16 UnsignedValue::m_exponent

Exponent part.

UINT32 UnsignedValue::m_mantissa

Mantissa part.

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsTypes.hpp
Generated on Wed Jan 25 02:14:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Unzipper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Unzipper Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/Unzipper.hpp>

Static Public Member Functions

static BOOLEAN | UnzipBinData (BinData *bin_data, const CHAR *file_name, void **extracted_buffer, UINT32 *extracted_buffer_size)
static BOOLEAN | UnzipFfs (const CHAR *zip_file_name, const CHAR *file_name, void **extracted_buffer, UINT32 *extracted_buffer_size)
static BOOLEAN | UnzipFfs (UINT32 zip_file_id, const CHAR *file_name, void **extracted_buffer, UINT32 *extracted_buffer_size)

Member Function Documentation

BOOLEAN Unzipper::UnzipBinData | ( | BinData * | bin_data,
 |  | const CHAR * | file_name,
 |  | void ** | extracted_buffer,
 |  | UINT32 * | extracted_buffer_size
 | ) | [static]

BOOLEAN Unzipper::UnzipFfs | ( | const CHAR * | zip_file_name,
 |  | const CHAR * | file_name,
 |  | void ** | extracted_buffer,
 |  | UINT32 * | extracted_buffer_size
 | ) | [static]

BOOLEAN Unzipper::UnzipFfs | ( | UINT32 | zip_file_id,
 |  | const CHAR * | file_name,
 |  | void ** | extracted_buffer,
 |  | UINT32 * | extracted_buffer_size
 | ) | [static]

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/Unzipper.hpp
  • AddOns/MultiMedia/Unzipper.cpp
Generated on Wed Jan 25 02:14:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UpdateContextItemMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UpdateContextItemMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for UpdateContextItemMsg:

[legend]
Collaboration diagram for UpdateContextItemMsg:

[legend]

Public Types

enum | { ID = 13002 }

Public Member Functions

virtual Message * | Clone () const
ContextFeatureItem * | GetContextItem () const
virtual const MsgMetaData & | GetMetaData () const
UpdateContextItemMsg (ContextFeatureItem *context_item)
virtual | ~UpdateContextItemMsg ()

Detailed Description

UpdateContextItem

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UpdateContextItemMsg::UpdateContextItemMsg ( ContextFeatureItem * context_item )

UpdateContextItemMsg::~UpdateContextItemMsg ( ) [virtual]

Member Function Documentation

Message * UpdateContextItemMsg::Clone ( ) const [virtual]

Implements Message.

ContextFeatureItem* UpdateContextItemMsg::GetContextItem ( ) const [inline]

const MsgMetaData & UpdateContextItemMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 02:14:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UpdateItemMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UpdateItemMsg Class Reference

#include <Apoxi/Atl/AtlMsgTypes.hpp>

Inheritance diagram for UpdateItemMsg:

[legend]
Collaboration diagram for UpdateItemMsg:

[legend]

Public Types

enum | { ID = 13007 }

Public Member Functions

virtual Message * | Clone () const
Item * | GetItem () const
virtual const MsgMetaData & | GetMetaData () const
UpdateItemMsg (ExecutionContext *context, Item *item)
virtual | ~UpdateItemMsg ()

Detailed Description

UpdateItemMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UpdateItemMsg::UpdateItemMsg | ( | ExecutionContext * | context,
 |  | Item * | item
 | ) |

UpdateItemMsg::~UpdateItemMsg ( ) [virtual]

Member Function Documentation

Message * UpdateItemMsg::Clone ( ) const [virtual]

Implements Message.

Item* UpdateItemMsg::GetItem ( ) const [inline]

const MsgMetaData & UpdateItemMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Atl/AtlMsgTypes.hpp
  • Atl/AtlMsgTypes.cpp
Generated on Wed Jan 25 02:14:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UpdatePbThreadlet Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UpdatePbThreadlet Class Reference
[AdvPhonebook]

#include <Applications/AdvPhonebook/UpdatePbThreadlet.hpp>

Inheritance diagram for UpdatePbThreadlet:

[legend]
Collaboration diagram for UpdatePbThreadlet:

[legend]

Public Member Functions

virtual INT | Fn ()
void | Init (Application *app, Provider *provider)
BOOLEAN | IsRunning ()
virtual void | OnEndOfExecute ()
UpdatePbThreadlet ()
virtual | ~UpdatePbThreadlet ()

Constructor & Destructor Documentation

UpdatePbThreadlet::UpdatePbThreadlet ( )

UpdatePbThreadlet::~UpdatePbThreadlet ( ) [virtual]

Member Function Documentation

INT UpdatePbThreadlet::Fn ( ) [virtual]

Fn is the function that will be executed in thread context. Be aware of restrictions to operations that can be performed in thread context.

Implements Threadlet.

void UpdatePbThreadlet::Init | ( | Application * | app,
 |  | Provider * | provider
 | ) |

BOOLEAN UpdatePbThreadlet::IsRunning ( ) [inline]

void UpdatePbThreadlet::OnEndOfExecute ( ) [virtual]

Is invoked after Fn has been executed. The default implementation sends the message ThreadletNotificationMsg to the application that executed the threadlet. Important: when overwriting the method invoke the base-method always at the end!

Reimplemented from Threadlet.

The documentation for this class was generated from the following files:
  • Applications/AdvPhonebook/UpdatePbThreadlet.hpp
  • Applications/AdvPhonebook/UpdatePbThreadlet.cpp
Generated on Wed Jan 25 02:14:59 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Uplmn Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Uplmn Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Public Member Functions

Uplmn | operator= (T_UPLMN t_uplmn)
Uplmn ()

Data Fields

UINT16 | mcc
UINT16 | mnc

Constructor & Destructor Documentation

Uplmn::Uplmn ( ) [inline]

Member Function Documentation

Uplmn Uplmn::operator= ( T_UPLMN t_uplmn )

Field Documentation

UINT16 Uplmn::mcc

UINT16 Uplmn::mnc

The documentation for this struct was generated from the following files:
  • Apc/NetworkTypes.hpp
  • Apc/NetworkTypes.cpp
Generated on Wed Jan 25 02:15:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Uri Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Uri Class Reference
[Afs]

Uri class defines the functionalities fo the class. More...

#include <Apoxi/Afs/Uri.hpp>

Inheritance diagram for Uri:

[legend]
Collaboration diagram for Uri:

[legend]

Public Member Functions

BOOLEAN | endswith (const Uri &other) const
Returns TRUE if the other-Uri matches with the end of the Uri.
void | FormatLockTableUri (Uri &return_string) const
formats the given uri to store in lock table
void | FormatUriHeader (Uri &return_string) const
formats the given uri to store root uri in service table
BOOLEAN | GetChildName (String &node_name) const
returns the last part of the uri
BOOLEAN | GetParentUri (Uri &return_uri) const
truncates the last part of uri & returns the rest
INT | GetUriDepth () const
returns URI depth
void | GetUriHeader (Uri &return_string) const
returns the root uri stores in the service table
BOOLEAN | operator!= (const Uri &szcompare) const
Checks whether the object and szcompare are not identical.
Uri | operator+ (const Uri &szConcat) const
void | operator+= (const Uri &szConcat)
Concatenates Uri szConcat to the object.
Uri & | operator<< (const Uri &right)
Concatenates String right to the object. Repetitive use is possible (a << b << c).
Uri & | operator= (const Uri &szCopy)
Assigns a new value to the Uri object.
BOOLEAN | operator== (const Uri &szcompare) const
Checks whether the object and szcompare are identical.
BOOLEAN | startswith (const Uri &other) const
Returns TRUE if the other-Uri matches with the start of the Uri.
void | TruncateUri (Uri &return_string) const
truncates the syncroot part of uri
Uri (const CHAR *pchCopy)
Uri (const String &szCopy)
Creates a Uri object based on an existing Uri object.
Uri (const Uri *szCopy)
Creates a Uri object based on an existing Uri object.
Uri (const Uri &szCopy)
Creates a Uri object based on an existing Uri object.
Uri ()
Ctor.
BOOLEAN | ValidateUri () const
validates a uri to start with "./"
~Uri ()

Detailed Description

Uri class defines the functionalities fo the class.

Constructor & Destructor Documentation

Uri::Uri ( ) [inline]

Ctor.

Uri::~Uri ( ) [inline]

Uri::Uri ( const Uri & szCopy )

Creates a Uri object based on an existing Uri object.

Uri::Uri ( const Uri * szCopy )

Creates a Uri object based on an existing Uri object.

Uri::Uri ( const String & szCopy )

Creates a Uri object based on an existing Uri object.

Uri::Uri ( const CHAR * pchCopy )

Member Function Documentation

BOOLEAN Uri::endswith ( const Uri & other ) const

Returns TRUE if the other-Uri matches with the end of the Uri.

void Uri::FormatLockTableUri ( Uri & return_string ) const

formats the given uri to store in lock table

------------------------------------------------------------------------ FormatLockTableUri ------------------------------------------------------------------------

void Uri::FormatUriHeader ( Uri & return_string ) const

formats the given uri to store root uri in service table

------------------------------------------------------------------------ FormatUriHeader ------------------------------------------------------------------------

BOOLEAN Uri::GetChildName ( String & node_name ) const

returns the last part of the uri

------------------------------------------------------------------------ GetChildName ------------------------------------------------------------------------

BOOLEAN Uri::GetParentUri ( Uri & return_uri ) const

truncates the last part of uri & returns the rest

------------------------------------------------------------------------ GetParentUri ------------------------------------------------------------------------

INT Uri::GetUriDepth ( ) const

returns URI depth

------------------------------------------------------------------------ GetUriDepth ------------------------------------------------------------------------

void Uri::GetUriHeader ( Uri & return_uri ) const

returns the root uri stores in the service table

------------------------------------------------------------------------ GetUriHeader ------------------------------------------------------------------------

BOOLEAN Uri::operator!= ( const Uri & szcompare ) const

Checks whether the object and szcompare are not identical.

Uri Uri::operator+ ( const Uri & szConcat ) const [inline]

void Uri::operator+= ( const Uri & szConcat )

Concatenates Uri szConcat to the object.

Uri & Uri::operator<< ( const Uri & right )

Concatenates String right to the object. Repetitive use is possible (a << b << c).

Uri & Uri::operator= ( const Uri & szCopy )

Assigns a new value to the Uri object.

BOOLEAN Uri::operator== ( const Uri & szcompare ) const

Checks whether the object and szcompare are identical.

BOOLEAN Uri::startswith ( const Uri & other ) const

Returns TRUE if the other-Uri matches with the start of the Uri.

void Uri::TruncateUri ( Uri & return_string ) const

truncates the syncroot part of uri

------------------------------------------------------------------------ TruncateUri ------------------------------------------------------------------------

BOOLEAN Uri::ValidateUri ( ) const

validates a uri to start with "./"

The documentation for this class was generated from the following files:
  • Afs/Uri.hpp
  • Afs/Uri.cpp
Generated on Wed Jan 25 02:15:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UriMappingTable Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UriMappingTable Class Reference
[Afs]

UriMappingTable. More...

#include <Apoxi/Afs/UriMappingTable.hpp>

Collaboration diagram for UriMappingTable:

[legend]

Public Member Functions

BOOLEAN | FlushMapFile ()
flushes the mapfilebuffer contents to mapfile
INT16 | GetBackupFileId (INT16 file_id)
gets the backup file id for the specified file id
INT16 | GetChildFileId (INT16 parent_file_id, INT &index)
returns fileid of child
INT16 | GetFileId (INT index)
returns fileid of node corresponding to index
INT16 | GetFileId (const Uri &uri)
returns fileid of interiornode corresponding to uri
INT | GetFileIndex (INT16 file_id)
returns index of interiornode
UINT | GetNoOfNodes ()
returns number of noderecords
INT16 | GetTransactionId (INT16 file_id)
gets the transaction id for the specified file id from uri map-table
BOOLEAN | Init ()
Initializes urimapping table.
BOOLEAN | InsertBlobRecord (INT16 blob_file_id, INT16 parent_file_id)
to insert blob file record in map table
BOOLEAN | InsertURIRecord (const CHAR *node_name, INT16 file_id, INT16 parent_file_id, INT depth)
inserts interiornode record
BOOLEAN | InsertURIRecord (const Uri &uri, INT16 file_id)
inserts interiornode record
BOOLEAN | IsBlobFile (UINT index)
BOOLEAN | RemoveBackupFiles (INT16 transaction_id)
to remove backup entries from map table and to delete the entries from map table
BOOLEAN | RemoveBlobFileRecord (INT16 blob_file_id)
to remove blob file record
BOOLEAN | RemoveURIRecord (INT16 file_id)
removes interiornode record
BOOLEAN | RemoveURIRecord (const Uri &uri, INT16 file_id)
removes interiornode record
void | ReplaceFileId (INT16 old_blob_id, INT16 new_blob_id)
to replace blob file id
void | Reset ()
to reset the map table
BOOLEAN | SearchBackupFileId ()
BOOLEAN | SearchFileId (INT16 file_id)
to check file id existence in map-table
BOOLEAN | SetBackupFileId (INT16 file_id, INT16 backup_file_id)
sets the backup file id for the specified fileid
BOOLEAN | SetTransactionId (INT16 file_id, INT16 transaction_id)
sets the transaction id for the specified fileid in the uri map table
~UriMappingTable ()
default destructor

Static Public Member Functions

static UriMappingTable * | GetTable ()
returns urimapping table

Detailed Description

UriMappingTable.

                              URI MAP FILE
  +-------------------------------------------------------------------+
  | 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8| 1 2 3 4 5 6 7 8|
  +----------+---+-+----------------+----------------+----------------+
  |     Version    |    File Type   |         Node Count (n)          |
  +----------+---+------------------+---------------------------------+
  |  Depth (Node 0)| Flags (Node 0) |                                 |
  +----------------+----------------+                                 |
  |                                                                   |
  |                        Node Name (50 Bytes) (Node 0)              |
  |                                                                   |
  +---------------------------------+---------------------------------+
  |            File ID (Node 0)     |       Parent File Id (Node 0)   |
  +----------------+--------------------------------------------------+
  |  Depth (Node 1)| Flags (Node 1) |                                 |
  +----------------+----------------+                                 |
  |                                                                   |
  |                        Node Name (50 Bytes) (Node 1)              |
  |                                                                   |
  +---------------------------------+----------------+----------------+
  |            File ID (Node 1)     |       Parent File Id (Node 1)   |
  +-------------------------------------------------------------------+
  |                               .                                   |
  |                               .                                   |
  |                               .                                   |
  |                               .                                   |
  |                               .                                   |
  |                               .                                   |
  +-------------------------------------------------------------------+
  |  Depth (Node 2)| Flags (Node 2) |                                 |
  +----------------+----------------+                                 |
  |                                                                   |
  |                        Node Name (50 Bytes) (Node 2)              |
  |                                                                   |
  +---------------------------------+---------------------------------+
  |            File ID (Node 2)     |       Parent File Id (Node 2)   |
  +-------------------------------------------------------------------+

Constructor & Destructor Documentation

UriMappingTable::~UriMappingTable ( ) [inline]

default destructor

Member Function Documentation

BOOLEAN UriMappingTable::FlushMapFile ( )

flushes the mapfilebuffer contents to mapfile

------------------------------------------------------------------------ FlushMapFile ------------------------------------------------------------------------

INT16 UriMappingTable::GetBackupFileId ( INT16 file_id )

gets the backup file id for the specified file id

------------------------------------------------------------------------ GetBackupFileId ------------------------------------------------------------------------

INT16 UriMappingTable::GetChildFileId | ( | INT16 | parent_file_id,
 |  | INT & | index
 | ) |

returns fileid of child

------------------------------------------------------------------------ GetChildFileId ------------------------------------------------------------------------

INT16 UriMappingTable::GetFileId ( INT index )

returns fileid of node corresponding to index

------------------------------------------------------------------------ GetFileId ------------------------------------------------------------------------

INT16 UriMappingTable::GetFileId ( const Uri & passed_uri )

returns fileid of interiornode corresponding to uri

------------------------------------------------------------------------ GetFileId ------------------------------------------------------------------------

INT UriMappingTable::GetFileIndex ( INT16 file_id )

returns index of interiornode

------------------------------------------------------------------------ GetFileIndex ------------------------------------------------------------------------

UINT UriMappingTable::GetNoOfNodes ( )

returns number of noderecords

------------------------------------------------------------------------ GetNoOfNodes ------------------------------------------------------------------------

UriMappingTable * UriMappingTable::GetTable ( ) [static]

returns urimapping table

------------------------------------------------------------------------ GetTable ------------------------------------------------------------------------

INT16 UriMappingTable::GetTransactionId ( INT16 file_id )

gets the transaction id for the specified file id from uri map-table

------------------------------------------------------------------------ GetTransactionId ------------------------------------------------------------------------

BOOLEAN UriMappingTable::Init ( )

Initializes urimapping table.

------------------------------------------------------------------------ Init ------------------------------------------------------------------------

BOOLEAN UriMappingTable::InsertBlobRecord | ( | INT16 | blob_file_id,
 |  | INT16 | parent_file_id
 | ) |

to insert blob file record in map table

------------------------------------------------------------------------ InsertBlobRecord ------------------------------------------------------------------------

BOOLEAN UriMappingTable::InsertURIRecord | ( | const CHAR * | node_name,
 |  | INT16 | file_id,
 |  | INT16 | parent_file_id,
 |  | INT | depth
 | ) |

inserts interiornode record

------------------------------------------------------------------------ InsertURIRecord ------------------------------------------------------------------------

BOOLEAN UriMappingTable::InsertURIRecord | ( | const Uri & | passed_uri,
 |  | INT16 | file_id
 | ) |

inserts interiornode record

------------------------------------------------------------------------ InsertURIRecord ------------------------------------------------------------------------

BOOLEAN UriMappingTable::IsBlobFile ( UINT index )

------------------------------------------------------------------------ IsBlobFile ------------------------------------------------------------------------

BOOLEAN UriMappingTable::RemoveBackupFiles ( INT16 transaction_id )

to remove backup entries from map table and to delete the entries from map table

------------------------------------------------------------------------ RemoveBackupFiles ------------------------------------------------------------------------

BOOLEAN UriMappingTable::RemoveBlobFileRecord ( INT16 blob_file_id )

to remove blob file record

------------------------------------------------------------------------ RemoveBlobFileRecord ------------------------------------------------------------------------

BOOLEAN UriMappingTable::RemoveURIRecord ( INT16 file_id )

removes interiornode record

------------------------------------------------------------------------ RemoveURIRecord ------------------------------------------------------------------------

BOOLEAN UriMappingTable::RemoveURIRecord | ( | const Uri & | uri,
 |  | INT16 | file_id
 | ) |

removes interiornode record

------------------------------------------------------------------------ RemoveURIRecord ------------------------------------------------------------------------

void UriMappingTable::ReplaceFileId | ( | INT16 | old_blob_id,
 |  | INT16 | new_blob_id
 | ) |

to replace blob file id

------------------------------------------------------------------------ ReplaceFileId ------------------------------------------------------------------------

void UriMappingTable::Reset ( )

to reset the map table

------------------------------------------------------------------------ Reset ------------------------------------------------------------------------

BOOLEAN UriMappingTable::SearchBackupFileId ( )

------------------------------------------------------------------------ SearchBackupFileId ------------------------------------------------------------------------

BOOLEAN UriMappingTable::SearchFileId ( INT16 file_id )

to check file id existence in map-table

------------------------------------------------------------------------ SearchFileId ------------------------------------------------------------------------

BOOLEAN UriMappingTable::SetBackupFileId | ( | INT16 | file_id,
 |  | INT16 | backup_file_id
 | ) |

sets the backup file id for the specified fileid

------------------------------------------------------------------------ SetBackupFileId ------------------------------------------------------------------------

BOOLEAN UriMappingTable::SetTransactionId | ( | INT16 | file_id,
 |  | INT16 | transaction_id
 | ) |

sets the transaction id for the specified fileid in the uri map table

------------------------------------------------------------------------ SetTransactionId ------------------------------------------------------------------------

The documentation for this class was generated from the following files:
  • Afs/UriMappingTable.hpp
  • Afs/UriMappingTable.cpp
Generated on Wed Jan 25 02:15:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsbApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsbApp Class Reference
[UsbApp]

#include <Applications/UsbApp/UsbApp.hpp>

Collaboration diagram for UsbApp:

[legend]

Public Member Functions

void | Init ()
virtual | ~UsbApp ()
Destructor.

Static Public Member Functions

static UsbApp * | GetInstance ()

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()

Constructor & Destructor Documentation

UsbApp::~UsbApp ( ) [virtual]

Destructor.

Member Function Documentation

UsbApp * UsbApp::GetInstance ( ) [static]

void UsbApp::Init ( )

BOOLEAN UsbApp::OnMessage ( const Message & msg ) [protected, virtual]

void UsbApp::OnOpen ( ) [protected, virtual]

The documentation for this class was generated from the following files:
  • Applications/UsbApp/UsbApp.hpp
  • Applications/UsbApp/UsbApp.cpp
Generated on Wed Jan 25 02:15:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsbObexServerAddr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsbObexServerAddr Class Reference

#include <Apoxi/AddOns/Usb/Obex/UsbObexServerAddress.hpp>

Inheritance diagram for UsbObexServerAddr:

[legend]
Collaboration diagram for UsbObexServerAddr:

[legend]

Public Member Functions

virtual ObexResult ToString (String &obex_url) const
Converts the ObexAddrInfo into string format.
UsbObexServerAddr (UsbObexTransport *obex_transport, String server_url)
Operations Constructor.

Detailed Description

UsbObexServerAddress

Constructor & Destructor Documentation

UsbObexServerAddr::UsbObexServerAddr | ( | UsbObexTransport * | obex_transport,
 |  | String | server_url
 | ) |

Operations Constructor.

Member Function Documentation

ObexResult UsbObexServerAddr::ToString ( String & obex_url ) const [virtual]

Converts the ObexAddrInfo into string format.

Parameters:
obex_url String to append the result to
Returns:
TRUE if the conversion was successful, FALSE otherwise.

Reimplemented from ObexAddress.

The documentation for this class was generated from the following files:
  • AddOns/Usb/Obex/UsbObexServerAddress.hpp
  • AddOns/Usb/Obex/UsbObexServerAddress.cpp
Generated on Wed Jan 25 02:15:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsbObexTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsbObexTransport Class Reference

#include <Apoxi/AddOns/Usb/Obex/UsbObexTransport.hpp>

Inheritance diagram for UsbObexTransport:

[legend]
Collaboration diagram for UsbObexTransport:

[legend]

Public Member Functions

virtual ObexProtocol * | GetProtocol (ObexProtocolId level)
returns pointer to the protocol implementation associated with this transport
void | Init (UsbTransport &usb_transport)
initializes usn transport implementation
virtual void | ResolveClientAddr (const String &client_url, ObexProtocolId prot_id, ObexOperationId job_id)
Resolves an OBEX client address URL.
virtual void | ResolveServerAddr (const String &server_url, ObexProtocolId prot_id, BOOLEAN sdb_autocreate, ObexOperationId job_id)
resolves server url & returns server address asynchronously
UsbObexTransport ()
virtual | ~UsbObexTransport ()
Operations Destructor.

Protected Member Functions

virtual void | OnUpdate (ObservableObject *obs_obj)

Constructor & Destructor Documentation

UsbObexTransport::~UsbObexTransport ( ) [virtual]

Operations Destructor.

UsbObexTransport::UsbObexTransport ( )

Member Function Documentation

ObexProtocol * UsbObexTransport::GetProtocol ( ObexProtocolId level ) [virtual]

returns pointer to the protocol implementation associated with this transport

Implements ObexAbstractTransport.

void UsbObexTransport::Init ( UsbTransport & usb_transport )

initializes usn transport implementation

void UsbObexTransport::OnUpdate ( ObservableObject * obs_obj ) [protected, virtual]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from ObexAbstractTransport.

void UsbObexTransport::ResolveClientAddr | ( | const String & | client_url,
 |  | ObexProtocolId | prot_id,
 |  | ObexOperationId | job_id
 | ) | [virtual]

Resolves an OBEX client address URL.

This is a factory method which evaluates the URL given in string format and creates an address information object which may contain specific information for the transport. This is accomplished by deriving a subclass from ObexClientAddr and creating an address information object from this class. Then a smartpointer of type ObexAddrPtr to this object and the job_id which was supplied with the URL must be returned by calling ReturnObexAddress().

Parameters:
remote_url | Remote address in URL format - the URL the client is going to connect to.
prot_id | Protocol which will be bound to the address
job_id | Reference to associate request and response

Implements ObexAbstractTransport.

void UsbObexTransport::ResolveServerAddr | ( | const String & | server_url,
 |  | ObexProtocolId | prot_id,
 |  | BOOLEAN | sdb_autocreate,
 |  | ObexOperationId | job_id
 | ) | [virtual]

resolves server url & returns server address asynchronously

Implements ObexAbstractTransport.

The documentation for this class was generated from the following files:
  • AddOns/Usb/Obex/UsbObexTransport.hpp
  • AddOns/Usb/Obex/UsbObexTransport.cpp
Generated on Wed Jan 25 02:15:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsbSubSystem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsbSubSystem Class Reference

#include <Apoxi/AddOns/Usb/UsbSubSystem.hpp>

Inheritance diagram for UsbSubSystem:

[legend]
Collaboration diagram for UsbSubSystem:

[legend]

Public Member Functions

virtual const WCHAR * | GetName () const
returns the friendly name
UsbTransport * GetUsbTransport ()
returns the instance of usb transport
virtual BootSequenceState | InvokeAt () const
Returns the state at which this subsytem should be loaded.
virtual void | OnPowerDown ()
This method is invoked on system power down to allow the USB subsytem to deinitialize itself.
virtual void | OnPowerUp ()
This method is invoked on system power on to allow the USB subsytem to initialize itself.
virtual | ~UsbSubSystem ()
Destructor.

Static Public Member Functions

static UsbSubSystem * | GetInstance ()
Operations returns the instance of usb subsystem.

Detailed Description

Since no application interacts directly with USB, the USB add-on is subsytem that gets loaded on power on.

Constructor & Destructor Documentation

UsbSubSystem::~UsbSubSystem ( ) [virtual]

Destructor.

Member Function Documentation

static UsbSubSystem* UsbSubSystem::GetInstance ( ) [inline, static]

Operations returns the instance of usb subsystem.

virtual const WCHAR* UsbSubSystem::GetName ( ) const [inline, virtual]

returns the friendly name

Implements SubSystem.

UsbTransport* UsbSubSystem::GetUsbTransport ( ) [inline]

returns the instance of usb transport

SubSystemManager::BootSequenceState UsbSubSystem::InvokeAt ( ) const [virtual]

Returns the state at which this subsytem should be loaded.

Implements SubSystem.

void UsbSubSystem::OnPowerDown ( ) [virtual]

This method is invoked on system power down to allow the USB subsytem to deinitialize itself.

Reimplemented from SubSystem.

void UsbSubSystem::OnPowerUp ( ) [virtual]

This method is invoked on system power on to allow the USB subsytem to initialize itself.

Reimplemented from SubSystem.

The documentation for this class was generated from the following files:
  • AddOns/Usb/UsbSubSystem.hpp
  • AddOns/Usb/UsbSubSystem.cpp
Generated on Wed Jan 25 02:15:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsbTransport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsbTransport Class Reference

#include <Apoxi/AddOns/Usb/UsbTransport.hpp>

Inheritance diagram for UsbTransport:

[legend]
Collaboration diagram for UsbTransport:

[legend]

Public Member Functions

virtual void | Enable ()
Request enabling of the transport (asynchronously).
virtual BaseTransport::AvState | GetAvState () const
Returns the availability state of the transport.
UsbConnectionInfo & | GetConnectionInfo ()
returns usb connection information
UsbTransport ()
default constructor

Static Public Member Functions

static UsbTransport * | GetInstance ()
returns instance of usb transport
static void | TransportEvent (INT event)

Static Public Attributes

static struct UsbTransport::UsbConnectionInfo | m_usb_conn_info = { UsbTransport::UsbConnectionInfo::Disconnected, WString(L"Usb Device not connected") }
data structure that stores usb connection information

Protected Member Functions

virtual BOOLEAN | OnMessage (const Message &msg)

Data Structures

struct | UsbConnectionInfo
data structure that stores usb connection information

Constructor & Destructor Documentation

UsbTransport::UsbTransport ( )

default constructor

Member Function Documentation

void UsbTransport::Enable ( ) [virtual]

Request enabling of the transport (asynchronously).

This method attempts to enable the transport and delivers the result asynchronously by calling OnAvStateChanged().

Implements AbstractTransport.

AbstractTransport::AvState UsbTransport::GetAvState ( ) const [virtual]

Returns the availability state of the transport.

Implements AbstractTransport.

UsbTransport::UsbConnectionInfo & UsbTransport::GetConnectionInfo ( )

returns usb connection information

UsbTransport * UsbTransport::GetInstance ( ) [static]

returns instance of usb transport

BOOLEAN UsbTransport::OnMessage ( const Message & msg ) [protected, virtual]

Every message routed to a dispatcher may be treated in OnMessage.

Returns:
TRUE is returned, if the message has been dispatched.

Implements Dispatcher.

void UsbTransport::TransportEvent ( INT event ) [static]

Field Documentation

UsbTransport::UsbConnectionInfo UsbTransport::m_usb_conn_info = { UsbTransport::UsbConnectionInfo::Disconnected, WString(L"Usb Device not connected") } [static]

data structure that stores usb connection information

The documentation for this class was generated from the following files:
  • AddOns/Usb/UsbTransport.hpp
  • AddOns/Usb/UsbTransport.cpp
Generated on Wed Jan 25 02:15:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UserActivityEventArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UserActivityEventArg Class Reference

#include <Apoxi/Apc/SimTkStackMsgArgs.hpp>

Inheritance diagram for UserActivityEventArg:

[legend]
Collaboration diagram for UserActivityEventArg:

[legend]

Public Types

enum | { ID = 2316 }

Public Member Functions

UserActivityEventArg ()

Static Public Member Functions

static const UserActivityEventArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UserActivityEventArg: reflects arguments of signal SI_USER_ACTIVITY_EVENT

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UserActivityEventArg::UserActivityEventArg ( )

Member Function Documentation

const UserActivityEventArg & UserActivityEventArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimTkStackMsgArgs.hpp
  • Apc/SimTkStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UserActivityListener Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UserActivityListener Class Reference
[APOXI Template Layer]

#include <Apoxi/Atl/AtlApplication.hpp>

Public Member Functions

virtual void OnUserActivity ()=0
UserActivityListener ()
~UserActivityListener ()

Constructor & Destructor Documentation

UserActivityListener::UserActivityListener ( ) [inline]

UserActivityListener::~UserActivityListener ( ) [inline]

Member Function Documentation

virtual void UserActivityListener::OnUserActivity ( ) [pure virtual]

The documentation for this class was generated from the following file:
  • Atl/AtlApplication.hpp
Generated on Wed Jan 25 02:15:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UserData Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UserData Class Reference

#include <Apoxi/Apc/UserData.hpp>

Collaboration diagram for UserData:

[legend]

Public Member Functions

BOOLEAN | Append (const InformationElement &information_element)
UINT8 * | GetData ()
const UINT8 * | GetData () const
TP-UD: TP-User-Data (3GPP 23.040 V5.1.0 [9.2.3.24]).
INT | GetLength () const
INT | GetPayloadOffset () const
Returns the offset to the start of the payload (excl. UserDataHeader) from the view of the TPDU raw data.
INT | GetPayloadSize () const
Returns the size (in bytes) of the payload (excl. UserDataHeader).
INT | GetRemainingSize () const
Returns the number of bytes, with which the user-data can be filled up (for example).
INT | GetSize () const
Returns the number of used bytes (incl. the length parameter-byte).
const UINT8 * | GetStartAddress () const
returns the startaddress of the whole user-data
INT | GetTextData (UINT8 *&text, UINT8 &padding) const
INT | GetTextDataLength () const
text length of the user data, which can be retrieved with GetTextData().
UserDataHeader | GetUserDataHeader () const
BOOLEAN | HeaderExists () const
void | Init (UINT8 *data_anchor=0, INT max_user_data_size=0, BOOLEAN header_exists=FALSE, const DataCodingScheme &dcs=DataCodingScheme())
WString | Read () const
void | Read (WString &text) const
Reads out the text of the decoded text from the user data.
BlobObject | ReadPayloadData () const
void | ReadPayloadData (BlobObject &blob) const
Reads out the payload data (excl. UserDataHeader) from the user data.
void | Reset ()
resets the whole user data (includes the user data header).
void | SetLength (INT length)
TP-UDL: TP-User-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.16]).
UserData (UINT8 *data_anchor, INT max_user_data_size=0, BOOLEAN header_exists=FALSE, const DataCodingScheme &dcs=DataCodingScheme())
UserData ()
INT | Write (const WString &text)
INT | WritePayloadData (const BlobObject &blob)
~UserData ()

Static Public Member Functions

static INT | CalculateUserDataSize (INT header_size, INT &data_length, const WString *text, INT text_length, DataCodingScheme::Alphabet alphabet)

Detailed Description

Attention: This class is a wrapper over a data-stream (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Constructor & Destructor Documentation

UserData::UserData ( )

UserData::UserData | ( | UINT8 * | data_anchor,
 |  | INT | max_user_data_size = 0,
 |  | BOOLEAN | header_exists = FALSE,
 |  | const DataCodingScheme & | dcs = DataCodingScheme()
 | ) |

UserData::~UserData ( )

Member Function Documentation

BOOLEAN UserData::Append ( const InformationElement & information_element )

Appends InformationElements to UserData (resp. UserDataHeader). It is possible to append more than one InformationElement to the UserData (only limited by the maximum size), but it is not allowed to append any InformationElement after writing the text to the UserData!

INT UserData::CalculateUserDataSize | ( | INT | header_size,
 |  | INT & | data_length,
 |  | const WString * | text,
 |  | INT | text_length,
 |  | DataCodingScheme::Alphabet | alphabet
 | ) | [static]

Returns the size (in bytes) required to code a text (identified by text, text_length and alphabet), which is appended to a header with header_size (in bytes), and a data with data_length (in septets, octets or double-byte). The parameter the data_length is updated to the new coded length (in septets, octets or double-byte). If text_length is less than zero then the correct length of text (text->length) is used.

UINT8 * UserData::GetData ( )

const UINT8 * UserData::GetData ( ) const

TP-UD: TP-User-Data (3GPP 23.040 V5.1.0 [9.2.3.24]).

INT UserData::GetLength ( ) const

TP-UDL: TP-User-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.16]) The length-value can be in septets (if DefaultAlphabet is used) or in octets (otherwise).

INT UserData::GetPayloadOffset ( ) const

Returns the offset to the start of the payload (excl. UserDataHeader) from the view of the TPDU raw data.

INT UserData::GetPayloadSize ( ) const

Returns the size (in bytes) of the payload (excl. UserDataHeader).

INT UserData::GetRemainingSize ( ) const

Returns the number of bytes, with which the user-data can be filled up (for example).

INT UserData::GetSize ( ) const

Returns the number of used bytes (incl. the length parameter-byte).

const UINT8* UserData::GetStartAddress ( ) const [inline]

returns the startaddress of the whole user-data

INT UserData::GetTextData | ( | UINT8 *& | text,
 |  | UINT8 & | padding
 | ) | const

Returns the start address of text, including the padding bits (relevant in case of existing UserDataHeader by using DefaultAlphabet). As return parameter the length of text can be retrieved.

INT UserData::GetTextDataLength ( ) const

text length of the user data, which can be retrieved with GetTextData().

UserDataHeader UserData::GetUserDataHeader ( ) const

BOOLEAN UserData::HeaderExists ( ) const

void UserData::Init | ( | UINT8 * | data_anchor = 0,
 |  | INT | max_user_data_size = 0,
 |  | BOOLEAN | header_exists = FALSE,
 |  | const DataCodingScheme & | dcs = DataCodingScheme()
 | ) |

WString UserData::Read ( ) const

void UserData::Read ( WString & text ) const

Reads out the text of the decoded text from the user data.

BlobObject UserData::ReadPayloadData ( ) const

void UserData::ReadPayloadData ( BlobObject & blob ) const

Reads out the payload data (excl. UserDataHeader) from the user data.

void UserData::Reset ( )

resets the whole user data (includes the user data header).

void UserData::SetLength ( INT length )

TP-UDL: TP-User-Data-Length (3GPP 23.040 V5.1.0 [9.2.3.16]).

INT UserData::Write ( const WString & text )

Writes the text to the user data and returns the number of converted characters. Coding is done internally according the the TPDU's data coding scheme. Writing text on UserData is allowed only once.

INT UserData::WritePayloadData ( const BlobObject & blob )

Writes the payload data (excl. UserDataHeader) to the user data and returns the number of written bytes. No coding is performed, if DCS is set to 8bit alphabet. If the DCS is set to another alphabet, data will be transormed and coded, according to the DCS. Writing text on UserData is allowed only once.

The documentation for this class was generated from the following files:
  • Apc/UserData.hpp
  • Apc/UserData.cpp
Generated on Wed Jan 25 02:15:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UserDataHeader Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UserDataHeader Class Reference

#include <Apoxi/Apc/UserData.hpp>

Public Member Functions

BOOLEAN | Append (const InformationElement &information_element)
UINT8 * | GetData ()
const UINT8 * | GetData () const
pointer to the user header data
InformationElement GetFirstInformationElement ()
INT | GetLength () const
length of header data, which can be retrieved with GetData
InformationElement GetNextInformationElement ()
INT | GetRemainingSize () const
UINT8 | GetSize () const
size of the whole UserDataHeader (incl. the size of the length parameter)
const UINT8 * | GetStartAddress () const
returns the startaddress of the whole user-data-header
BOOLEAN | HasMoreInformationElements () const
void | Init (UINT8 *data_header_anchor)
BOOLEAN | IsValid () const
void | SetLength (INT length)
set length of header data (in bytes)
UserDataHeader (UINT8 *data_header_anchor, INT max_size=-1)
UserDataHeader ()

Detailed Description

Attention: This class is a wrapper over a data-stream (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Constructor & Destructor Documentation

UserDataHeader::UserDataHeader ( )

UserDataHeader::UserDataHeader | ( | UINT8 * | data_header_anchor,
 |  | INT | max_size = -1
 | ) |

Member Function Documentation

BOOLEAN UserDataHeader::Append ( const InformationElement & information_element )

UINT8 * UserDataHeader::GetData ( )

const UINT8 * UserDataHeader::GetData ( ) const

pointer to the user header data

InformationElement UserDataHeader::GetFirstInformationElement ( )

INT UserDataHeader::GetLength ( ) const

length of header data, which can be retrieved with GetData

InformationElement UserDataHeader::GetNextInformationElement ( )

INT UserDataHeader::GetRemainingSize ( ) const

UINT8 UserDataHeader::GetSize ( ) const

size of the whole UserDataHeader (incl. the size of the length parameter)

const UINT8* UserDataHeader::GetStartAddress ( ) const [inline]

returns the startaddress of the whole user-data-header

BOOLEAN UserDataHeader::HasMoreInformationElements ( ) const

void UserDataHeader::Init ( UINT8 * data_header_anchor )

BOOLEAN UserDataHeader::IsValid ( ) const [inline]

void UserDataHeader::SetLength ( INT length )

set length of header data (in bytes)

The documentation for this class was generated from the following files:
  • Apc/UserData.hpp
  • Apc/UserData.cpp
Generated on Wed Jan 25 02:15:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UserDispatcher Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UserDispatcher Class Reference
[Kernel]

#include <Apoxi/Kernel/UserDispatcher.hpp>

Inheritance diagram for UserDispatcher:

[legend]
Collaboration diagram for UserDispatcher:

[legend]

Public Member Functions

UserDispatcher * | GetNext () const
Returns the successor of the current user dispatcher.
void | SetNext (UserDispatcher *next)
UserDispatcher ()
virtual | ~UserDispatcher ()

Protected Member Functions

virtual void | RegisterMessages () const
virtual void | UnregisterMessages () const

Friends

class | ExecutionContext

Detailed Description

A UserDispatcher can be added to any ExecutionContext as additional functional unit which can receive messages.
See also:
ExecutionContext::AddDispatcher()

Constructor & Destructor Documentation

UserDispatcher::UserDispatcher ( )

UserDispatcher::~UserDispatcher ( ) [virtual]

Member Function Documentation

UserDispatcher* UserDispatcher::GetNext ( ) const [inline]

Returns the successor of the current user dispatcher.

void UserDispatcher::RegisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is added to an execution context by ExecutionContext::AddDispatcher(). The derived user dispatcher should register all messages it wants to receive.

Reimplemented in BtAvrcpOperationService, BtAvrcpService, BtBppService, BtDevicePairRequest, BtDeviceSearchRequest, BtDeviceTrustRequest, BtDeviceUnpairRequest, BtDeviceUntrustRequest, BtQuerySupportedProfilesRequest, BtRespondAuthorizationRequest, BtSddbService, BtSendPasskeyRequest, BtServiceVerifyRequest, BtSetRemoteDeviceNameRequest, BtDunService, BtFaxService, BtHfService, BtHsService, BtObexService, and MessageMapDispatcher.

void UserDispatcher::SetNext ( UserDispatcher * next ) [inline]

Sets the successor of the current user dispatcher. It should not be necessary for the MMI to invoke this method in a direct manner.

void UserDispatcher::UnregisterMessages ( ) const [protected, virtual]

This method is invoked as soon as the user dispatcher is removed from an execution context by ExecutionContext::RemoveDispatcher(). The derived user dispatcher should unregister all messages it has registered inside UserDispatcher::RegisterMessages().

Reimplemented in BtAvrcpOperationService, BtAvrcpService, BtBppService, BtDevicePairRequest, BtDeviceSearchRequest, BtDeviceTrustRequest, BtDeviceUnpairRequest, BtDeviceUntrustRequest, BtQuerySupportedProfilesRequest, BtRespondAuthorizationRequest, BtSddbService, BtSendPasskeyRequest, BtServiceVerifyRequest, BtSetRemoteDeviceNameRequest, BtDunService, BtFaxService, BtHfService, BtHsService, BtObexService, and MessageMapDispatcher.

Friends And Related Function Documentation

friend class ExecutionContext [friend]

The documentation for this class was generated from the following files:
  • Kernel/UserDispatcher.hpp
  • Kernel/UserDispatcher.cpp
Generated on Wed Jan 25 02:15:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimCardTypeReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimCardTypeReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimCardTypeReadIndArg:

[legend]
Collaboration diagram for UsimCardTypeReadIndArg:

[legend]

Public Types

enum | { ID = 1450 }

Public Member Functions

const SimCardType & | GetCardType () const
const SimUpdateStatus & | GetStatus () const
void | SetCardType (const SimCardType &card_type)
void | SetStatus (const SimUpdateStatus &status)
UsimCardTypeReadIndArg ()

Static Public Member Functions

static const UsimCardTypeReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimCardTypeReadIndArg: reflects arguments of signal SI_READ_CARD_TYPE_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimCardTypeReadIndArg::UsimCardTypeReadIndArg ( )

Member Function Documentation

const UsimCardTypeReadIndArg & UsimCardTypeReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimCardType& UsimCardTypeReadIndArg::GetCardType ( ) const [inline]

const SimUpdateStatus& UsimCardTypeReadIndArg::GetStatus ( ) const [inline]

void UsimCardTypeReadIndArg::SetCardType ( const SimCardType & card_type ) [inline]

void UsimCardTypeReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimCardTypeReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimCardTypeReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimCardTypeReadReqArg:

[legend]
Collaboration diagram for UsimCardTypeReadReqArg:

[legend]

Public Types

enum | { ID = 2442 }

Public Member Functions

UsimCardTypeReadReqArg ()

Static Public Member Functions

static const UsimCardTypeReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimCardTypeReadReqArg: reflects arguments of signal SI_READ_REQ with USIMAP_READ_CARD_TYPE request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimCardTypeReadReqArg::UsimCardTypeReadReqArg ( )

Member Function Documentation

const UsimCardTypeReadReqArg & UsimCardTypeReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimCsLociReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimCsLociReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimCsLociReadIndArg:

[legend]
Collaboration diagram for UsimCsLociReadIndArg:

[legend]

Public Types

enum | { ID = 1440 }

Public Member Functions

const LociData & | GetLociData () const
const SimUpdateStatus & | GetStatus () const
void | SetLociData (const LociData &loci_data)
void | SetStatus (const SimUpdateStatus &status)
UsimCsLociReadIndArg ()

Static Public Member Functions

static const UsimCsLociReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimReadRejArg: reflects arguments of signal SI_CS_LOCI_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimCsLociReadIndArg::UsimCsLociReadIndArg ( )

Member Function Documentation

const UsimCsLociReadIndArg & UsimCsLociReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const LociData& UsimCsLociReadIndArg::GetLociData ( ) const [inline]

const SimUpdateStatus& UsimCsLociReadIndArg::GetStatus ( ) const [inline]

void UsimCsLociReadIndArg::SetLociData ( const LociData & loci_data ) [inline]

void UsimCsLociReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimCsLociReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimCsLociReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimCsLociReadReqArg:

[legend]
Collaboration diagram for UsimCsLociReadReqArg:

[legend]

Public Types

enum | { ID = 2436 }

Public Member Functions

UsimCsLociReadReqArg ()

Static Public Member Functions

static const UsimCsLociReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimCsLociReadReqArg: reflects arguments of signal SI_READ_REQ with SI_CS_LOCI request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimCsLociReadReqArg::UsimCsLociReadReqArg ( )

Member Function Documentation

const UsimCsLociReadReqArg & UsimCsLociReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimEccReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimEccReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimEccReadIndArg:

[legend]
Collaboration diagram for UsimEccReadIndArg:

[legend]

Public Types

enum | { ID = 1443 }

Public Member Functions

const UsimEccRecord & | GetEccRecord () const
const SimUpdateStatus & | GetStatus () const
void | SetEccRecord (const UsimEccRecord &ecc_record)
void | SetStatus (const SimUpdateStatus &status)
UsimEccReadIndArg ()

Static Public Member Functions

static const UsimEccReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimEccReadIndArg: reflects arguments of signal SI_READ_ECC_CNF request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimEccReadIndArg::UsimEccReadIndArg ( )

Member Function Documentation

const UsimEccReadIndArg & UsimEccReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimEccRecord& UsimEccReadIndArg::GetEccRecord ( ) const [inline]

const SimUpdateStatus& UsimEccReadIndArg::GetStatus ( ) const [inline]

void UsimEccReadIndArg::SetEccRecord ( const UsimEccRecord & ecc_record ) [inline]

void UsimEccReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimEccReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimEccReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimEccReadReqArg:

[legend]
Collaboration diagram for UsimEccReadReqArg:

[legend]

Public Types

enum | { ID = 2439 }

Public Member Functions

INT | GetRecno () const
void | SetRecno (INT recno)
UsimEccReadReqArg ()
UsimEccReadReqArg (INT recno)

Static Public Member Functions

static const UsimEccReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimEccReadReqArg: reflects arguments of signal SI_READ_ECC_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimEccReadReqArg::UsimEccReadReqArg ( INT recno )

UsimEccReadReqArg::UsimEccReadReqArg ( )

Member Function Documentation

const UsimEccReadReqArg & UsimEccReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimEccReadReqArg::GetRecno ( ) const [inline]

void UsimEccReadReqArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimEccRecord Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimEccRecord Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 | alphaid [USIMAP_ALPHA_LEN]
UINT8 | category
UINT8 | ecc [3]
UINT16 | length

Field Documentation

UINT8 UsimEccRecord::alphaid[USIMAP_ALPHA_LEN]

UINT8 UsimEccRecord::category

UINT8 UsimEccRecord::ecc[3]

UINT16 UsimEccRecord::length

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:15:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimEst Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimEst Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [USIMAP_SERVICE_TABLE_LEN]

Field Documentation

UINT8 UsimEst::val[USIMAP_SERVICE_TABLE_LEN]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:15:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimEstReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimEstReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimEstReadIndArg:

[legend]
Collaboration diagram for UsimEstReadIndArg:

[legend]

Public Types

enum | { ID = 1452 }

Public Member Functions

const UsimEst & | GetEst () const
INT | GetLength () const
const SimUpdateStatus & | GetStatus () const
BOOLEAN | IsFlag () const
void | SetEst (const UsimEst &est)
void | SetFlag (BOOLEAN flag)
void | SetLength (INT length)
void | SetStatus (const SimUpdateStatus &status)
UsimEstReadIndArg ()

Static Public Member Functions

static const UsimEstReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimEstReadIndArg: reflects arguments of signal SI_READ_EST_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimEstReadIndArg::UsimEstReadIndArg ( )

Member Function Documentation

const UsimEstReadIndArg & UsimEstReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimEst& UsimEstReadIndArg::GetEst ( ) const [inline]

INT UsimEstReadIndArg::GetLength ( ) const [inline]

const SimUpdateStatus& UsimEstReadIndArg::GetStatus ( ) const [inline]

BOOLEAN UsimEstReadIndArg::IsFlag ( ) const [inline]

void UsimEstReadIndArg::SetEst ( const UsimEst & est ) [inline]

void UsimEstReadIndArg::SetFlag ( BOOLEAN flag ) [inline]

void UsimEstReadIndArg::SetLength ( INT length ) [inline]

void UsimEstReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimEstReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimEstReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimEstReadReqArg:

[legend]
Collaboration diagram for UsimEstReadReqArg:

[legend]

Public Types

enum | { ID = 2444 }

Public Member Functions

UsimEstReadReqArg ()

Static Public Member Functions

static const UsimEstReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimEstReadReqArg: reflects arguments of signal SI_READ_REQ with EST request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimEstReadReqArg::UsimEstReadReqArg ( )

Member Function Documentation

const UsimEstReadReqArg & UsimEstReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimFileProperty Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimFileProperty Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

INT | m_filesize
SimFileType m_filetype
ChvNo m_readchv
INT | m_recordcount
INT | m_recordsize
ChvNo m_updatechv

Field Documentation

INT UsimFileProperty::m_filesize

SimFileType UsimFileProperty::m_filetype

ChvNo UsimFileProperty::m_readchv

INT UsimFileProperty::m_recordcount

INT UsimFileProperty::m_recordsize

ChvNo UsimFileProperty::m_updatechv

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:15:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimFilePropertyIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimFilePropertyIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimFilePropertyIndArg:

[legend]
Collaboration diagram for UsimFilePropertyIndArg:

[legend]

Public Types

enum | { ID = 1454 }

Public Member Functions

const UsimFileProperty & | GetProperty () const
const SimUpdateStatus & | GetStatus () const
void | SetProperty (const UsimFileProperty &property)
void | SetStatus (const SimUpdateStatus &status)
UsimFilePropertyIndArg ()

Static Public Member Functions

static const UsimFilePropertyIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimFilePropertyIndArg: reflects arguments of signal SI_FILE_PROPERTY_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimFilePropertyIndArg::UsimFilePropertyIndArg ( )

Member Function Documentation

const UsimFilePropertyIndArg & UsimFilePropertyIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimFileProperty& UsimFilePropertyIndArg::GetProperty ( ) const [inline]

const SimUpdateStatus& UsimFilePropertyIndArg::GetStatus ( ) const [inline]

void UsimFilePropertyIndArg::SetProperty ( const UsimFileProperty & property ) [inline]

void UsimFilePropertyIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimFilePropertyReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimFilePropertyReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimFilePropertyReqArg:

[legend]
Collaboration diagram for UsimFilePropertyReqArg:

[legend]

Public Types

enum | { ID = 2446 }

Public Member Functions

const UsimReadType & | GetReadType () const
void | SetReadType (const UsimReadType &read_type)
UsimFilePropertyReqArg ()
UsimFilePropertyReqArg (const UsimReadType &read_type)

Static Public Member Functions

static const UsimFilePropertyReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimLangUpdReqArg: reflects arguments of signal SI_FILE_PROPERTY_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimFilePropertyReqArg::UsimFilePropertyReqArg ( const UsimReadType & read_type )

UsimFilePropertyReqArg::UsimFilePropertyReqArg ( )

Member Function Documentation

const UsimFilePropertyReqArg & UsimFilePropertyReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimReadType& UsimFilePropertyReqArg::GetReadType ( ) const [inline]

void UsimFilePropertyReqArg::SetReadType ( const UsimReadType & read_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimLangReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimLangReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimLangReadIndArg:

[legend]
Collaboration diagram for UsimLangReadIndArg:

[legend]

Public Types

enum | { ID = 1442 }

Public Member Functions

const UsimLangFileType & | GetLangFileType () const
const UsimLanguageList & | GetLanguageList () const
INT | GetLength () const
const SimUpdateStatus & | GetStatus () const
void | SetLangFileType (const UsimLangFileType &lang_file_type)
void | SetLanguageList (const UsimLanguageList &language_list)
void | SetLength (INT length)
void | SetStatus (const SimUpdateStatus &status)
UsimLangReadIndArg ()

Static Public Member Functions

static const UsimLangReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimLangReadIndArg: reflects arguments of signal SI_READ_LANGUAGE_CNF request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimLangReadIndArg::UsimLangReadIndArg ( )

Member Function Documentation

const UsimLangReadIndArg & UsimLangReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimLangFileType& UsimLangReadIndArg::GetLangFileType ( ) const [inline]

const UsimLanguageList& UsimLangReadIndArg::GetLanguageList ( ) const [inline]

INT UsimLangReadIndArg::GetLength ( ) const [inline]

const SimUpdateStatus& UsimLangReadIndArg::GetStatus ( ) const [inline]

void UsimLangReadIndArg::SetLangFileType ( const UsimLangFileType & lang_file_type ) [inline]

void UsimLangReadIndArg::SetLanguageList ( const UsimLanguageList & language_list ) [inline]

void UsimLangReadIndArg::SetLength ( INT length ) [inline]

void UsimLangReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimLangReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimLangReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimLangReadReqArg:

[legend]
Collaboration diagram for UsimLangReadReqArg:

[legend]

Public Types

enum | { ID = 2438 }

Public Member Functions

const UsimLangFileType & | GetLangFileType () const
INT | GetListIndex () const
void | SetLangFileType (const UsimLangFileType &lang_file_type)
void | SetListIndex (INT list_index)
UsimLangReadReqArg ()
UsimLangReadReqArg (const UsimLangFileType &lang_file_type, INT list_index)

Static Public Member Functions

static const UsimLangReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimLangReadReqArg: reflects arguments of signal SI_READ_LANGUAGE_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimLangReadReqArg::UsimLangReadReqArg | ( | const UsimLangFileType & | lang_file_type,
 |  | INT | list_index
 | ) |

UsimLangReadReqArg::UsimLangReadReqArg ( )

Member Function Documentation

const UsimLangReadReqArg & UsimLangReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimLangFileType& UsimLangReadReqArg::GetLangFileType ( ) const [inline]

INT UsimLangReadReqArg::GetListIndex ( ) const [inline]

void UsimLangReadReqArg::SetLangFileType ( const UsimLangFileType & lang_file_type ) [inline]

void UsimLangReadReqArg::SetListIndex ( INT list_index ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimLanguage Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimLanguage Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Public Member Functions

WString | GetWString () const
void | Set (const WString &str)

Data Fields

UINT8 | val [2]

Member Function Documentation

WString UsimLanguage::GetWString ( ) const [inline]

void UsimLanguage::Set ( const WString & str ) [inline]

Field Documentation

UINT8 UsimLanguage::val[2]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:15:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimLanguageList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimLanguageList Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for UsimLanguageList:

[legend]

Data Fields

UsimLanguage val [c_maxno_usim_langs]

Field Documentation

UsimLanguage UsimLanguageList::val[c_maxno_usim_langs]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:15:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimLangUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimLangUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimLangUpdIndArg:

[legend]
Collaboration diagram for UsimLangUpdIndArg:

[legend]

Public Types

enum | { ID = 1453 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
UsimLangUpdIndArg ()

Static Public Member Functions

static const UsimLangUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimLangUpdIndArg: reflects arguments of signal SI_UPDATE_REJ of Lang update

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimLangUpdIndArg::UsimLangUpdIndArg ( )

Member Function Documentation

const UsimLangUpdIndArg & UsimLangUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& UsimLangUpdIndArg::GetStatus ( ) const [inline]

void UsimLangUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:15:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimLangUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimLangUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimLangUpdReqArg:

[legend]
Collaboration diagram for UsimLangUpdReqArg:

[legend]

Public Types

enum | { ID = 2445 }

Public Member Functions

const UsimLangFileType & | GetLangFileType () const
const UsimLanguage & | GetLanguage () const
INT | GetRecno () const
const UsimUpdateAction & | GetUpdateAction () const
void | SetLangFileType (const UsimLangFileType &lang_file_type)
void | SetLanguage (const UsimLanguage &language)
void | SetRecno (INT recno)
void | SetUpdateAction (const UsimUpdateAction &update_action)
UsimLangUpdReqArg ()
UsimLangUpdReqArg (const UsimLangFileType &lang_file_type, INT recno, const UsimLanguage &language, const UsimUpdateAction &update_action)

Static Public Member Functions

static const UsimLangUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimLangUpdReqArg: reflects arguments of signal SI_UPDATE_LANGUAGE_IND request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimLangUpdReqArg::UsimLangUpdReqArg | ( | const UsimLangFileType & | lang_file_type,
 |  | INT | recno,
 |  | const UsimLanguage & | language,
 |  | const UsimUpdateAction & | update_action
 | ) |

UsimLangUpdReqArg::UsimLangUpdReqArg ( )

Member Function Documentation

const UsimLangUpdReqArg & UsimLangUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimLangFileType& UsimLangUpdReqArg::GetLangFileType ( ) const [inline]

const UsimLanguage& UsimLangUpdReqArg::GetLanguage ( ) const [inline]

INT UsimLangUpdReqArg::GetRecno ( ) const [inline]

const UsimUpdateAction& UsimLangUpdReqArg::GetUpdateAction ( ) const [inline]

void UsimLangUpdReqArg::SetLangFileType ( const UsimLangFileType & lang_file_type ) [inline]

void UsimLangUpdReqArg::SetLanguage ( const UsimLanguage & language ) [inline]

void UsimLangUpdReqArg::SetRecno ( INT recno ) [inline]

void UsimLangUpdReqArg::SetUpdateAction ( const UsimUpdateAction & update_action ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbChangedField Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbChangedField Class Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for UsimPbChangedField:

[legend]

Public Member Functions

void | Clear ()
UsimPbChangedField & | operator= (const UsimPbChangedField &field)
void | SetAdnChanged (BOOLEAN change=TRUE)
void | SetGroupsChanged (BOOLEAN change=TRUE)
void | SetHiddenInfoChanged (BOOLEAN change=TRUE)
UsimPbChangedField (const T_PB_CHANGED_FIELD &field)
UsimPbChangedField (BOOLEAN adn, BOOLEAN groups=FALSE, BOOLEAN hiddeninfo=FALSE)
UsimPbChangedField (const UsimPbChangedField &field)
UsimPbChangedField ()

Data Fields

T_PB_CHANGED_FIELD m_field

Constructor & Destructor Documentation

UsimPbChangedField::UsimPbChangedField ( )

UsimPbChangedField::UsimPbChangedField ( const UsimPbChangedField & field ) [inline]

UsimPbChangedField::UsimPbChangedField | ( | BOOLEAN | adn,
 |  | BOOLEAN | groups = FALSE,
 |  | BOOLEAN | hiddeninfo = FALSE
 | ) |

UsimPbChangedField::UsimPbChangedField ( const T_PB_CHANGED_FIELD & field ) [inline]

Member Function Documentation

void UsimPbChangedField::Clear ( )

UsimPbChangedField& UsimPbChangedField::operator= ( const UsimPbChangedField & field ) [inline]

void UsimPbChangedField::SetAdnChanged ( BOOLEAN change = TRUE ) [inline]

void UsimPbChangedField::SetGroupsChanged ( BOOLEAN change = TRUE ) [inline]

void UsimPbChangedField::SetHiddenInfoChanged ( BOOLEAN change = TRUE ) [inline]

Field Documentation

T_PB_CHANGED_FIELD UsimPbChangedField::m_field

The documentation for this class was generated from the following files:
  • Apc/UsimPbTypes.hpp
  • Apc/UsimPbTypes.cpp
Generated on Wed Jan 25 02:16:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbFillStatus Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbFillStatus Class Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for UsimPbFillStatus:

[legend]

Public Member Functions

void | Clear ()
UsimPbFillStatus & | operator= (const UsimPbFillStatus &status)
UsimPbFillStatus ()

Data Fields

T_PB_FILL_STATUS m_status

Constructor & Destructor Documentation

UsimPbFillStatus::UsimPbFillStatus ( ) [inline]

Member Function Documentation

void UsimPbFillStatus::Clear ( ) [inline]

UsimPbFillStatus& UsimPbFillStatus::operator= ( const UsimPbFillStatus & status ) [inline]

Field Documentation

T_PB_FILL_STATUS UsimPbFillStatus::m_status

The documentation for this class was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:16:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbFillStatusReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbFillStatusReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbFillStatusReqArg:

[legend]
Collaboration diagram for UsimPbFillStatusReqArg:

[legend]

Public Types

enum | { ID = 2218 }

Public Member Functions

UsimPbFillStatusReqArg ()

Static Public Member Functions

static const UsimPbFillStatusReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbFillStatusReqArg: reflects arguments of signal PB_FILL_STATUS_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbFillStatusReqArg::UsimPbFillStatusReqArg ( )

Member Function Documentation

const UsimPbFillStatusReqArg & UsimPbFillStatusReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbFillStatusResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbFillStatusResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbFillStatusResArg:

[legend]
Collaboration diagram for UsimPbFillStatusResArg:

[legend]

Public Types

enum | { ID = 1221 }

Public Member Functions

const UsimPbFillStatus & | GetPbFillStatus () const
const UsimPbResult & | GetPbResult () const
const UsimPbSignalType & | GetPbSignalType () const
void | SetPbFillStatus (const UsimPbFillStatus &pb_fill_status)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetPbSignalType (const UsimPbSignalType &pb_signal_type)
UsimPbFillStatusResArg ()

Static Public Member Functions

static const UsimPbFillStatusResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbFillStatusResArg: reflects arguments of signal PB_FILL_STATUS_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbFillStatusResArg::UsimPbFillStatusResArg ( )

Member Function Documentation

const UsimPbFillStatusResArg & UsimPbFillStatusResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbFillStatus& UsimPbFillStatusResArg::GetPbFillStatus ( ) const [inline]

const UsimPbResult& UsimPbFillStatusResArg::GetPbResult ( ) const [inline]

const UsimPbSignalType& UsimPbFillStatusResArg::GetPbSignalType ( ) const [inline]

void UsimPbFillStatusResArg::SetPbFillStatus ( const UsimPbFillStatus & pb_fill_status ) [inline]

void UsimPbFillStatusResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbFillStatusResArg::SetPbSignalType ( const UsimPbSignalType & pb_signal_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbGroups Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbGroups Class Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for UsimPbGroups:

[legend]

Public Member Functions

void | Clear ()
UINT8 | GetGroup (UINT idx) const
BOOLEAN | IsUsed () const
UsimPbGroups & | operator= (const UsimPbGroups &groups)
void | SetGroup (UINT idx, UINT8 group)
UsimPbGroups (const T_PB_GROUPING &groups)
UsimPbGroups (const UsimPbGroups &groups)
UsimPbGroups ()
BOOLEAN | WasChanged (UINT idx) const

Data Fields

T_PB_GROUPING m_groups
BitField16 m_set

Constructor & Destructor Documentation

UsimPbGroups::UsimPbGroups ( ) [inline]

UsimPbGroups::UsimPbGroups ( const UsimPbGroups & groups ) [inline]

UsimPbGroups::UsimPbGroups ( const T_PB_GROUPING & groups ) [inline]

Member Function Documentation

void UsimPbGroups::Clear ( ) [inline]

UINT8 UsimPbGroups::GetGroup ( UINT idx ) const [inline]

BOOLEAN UsimPbGroups::IsUsed ( ) const [inline]

UsimPbGroups& UsimPbGroups::operator= ( const UsimPbGroups & groups ) [inline]

void UsimPbGroups::SetGroup | ( | UINT | idx,
 |  | UINT8 | group
 | ) | [inline]

BOOLEAN UsimPbGroups::WasChanged ( UINT idx ) const [inline]

Field Documentation

T_PB_GROUPING UsimPbGroups::m_groups

BitField16 UsimPbGroups::m_set

The documentation for this class was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:16:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbLocationIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbLocationIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbLocationIndArg:

[legend]
Collaboration diagram for UsimPbLocationIndArg:

[legend]

Public Types

enum | { ID = 1210 }

Public Member Functions

const UsimPbLocReport & | GetReport () const
void | SetReport (const UsimPbLocReport &report)
UsimPbLocationIndArg ()

Static Public Member Functions

static const UsimPbLocationIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbLocationIndArg: reflects arguments of signal PB_LOCATION_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbLocationIndArg::UsimPbLocationIndArg ( )

Member Function Documentation

const UsimPbLocationIndArg & UsimPbLocationIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbLocReport& UsimPbLocationIndArg::GetReport ( ) const [inline]

void UsimPbLocationIndArg::SetReport ( const UsimPbLocReport & report ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbLocationReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbLocationReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbLocationReqArg:

[legend]
Collaboration diagram for UsimPbLocationReqArg:

[legend]

Public Types

enum | { ID = 2210 }

Public Member Functions

UsimPbLocationReqArg ()

Static Public Member Functions

static const UsimPbLocationReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbLocationReqArg: reflects arguments of signal PB_LOCATION_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbLocationReqArg::UsimPbLocationReqArg ( )

Member Function Documentation

const UsimPbLocationReqArg & UsimPbLocationReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbLocReport Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbLocReport Class Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for UsimPbLocReport:

[legend]

Public Member Functions

void | Clear ()
UsimPbLocation | GetCurrentSelectedPb () const
returns the current phonebook which is currently selected by the PB process
BOOLEAN | IsApplUsimPbExisting () const
is an application USIM phonebook existing on USIM
BOOLEAN | IsGlobalUsimPbExisting () const
is a global USIM phonebook existing on USIM
BOOLEAN | IsSimPbExisting () const
is a SIM phonebook existing on USIM
UsimPbLocReport & | operator= (const UsimPbLocReport &location_info)
UsimPbLocReport ()
BOOLEAN | WasApplUsimPbLastUsed () const
was the application USIM phonebook last used
BOOLEAN | WasGlobalUsimPbLastUsed () const
was the global USIM phonebook last used
BOOLEAN | WasSimPbLastUsed () const
was this SIM phonebook last used

Data Fields

T_PB_LOC_REPORT m_location_info

Constructor & Destructor Documentation

UsimPbLocReport::UsimPbLocReport ( ) [inline]

Member Function Documentation

void UsimPbLocReport::Clear ( ) [inline]

UsimPbLocation UsimPbLocReport::GetCurrentSelectedPb ( ) const [inline]

returns the current phonebook which is currently selected by the PB process

BOOLEAN UsimPbLocReport::IsApplUsimPbExisting ( ) const [inline]

is an application USIM phonebook existing on USIM

BOOLEAN UsimPbLocReport::IsGlobalUsimPbExisting ( ) const [inline]

is a global USIM phonebook existing on USIM

BOOLEAN UsimPbLocReport::IsSimPbExisting ( ) const [inline]

is a SIM phonebook existing on USIM

UsimPbLocReport& UsimPbLocReport::operator= ( const UsimPbLocReport & location_info ) [inline]

BOOLEAN UsimPbLocReport::WasApplUsimPbLastUsed ( ) const [inline]

was the application USIM phonebook last used

BOOLEAN UsimPbLocReport::WasGlobalUsimPbLastUsed ( ) const [inline]

was the global USIM phonebook last used

BOOLEAN UsimPbLocReport::WasSimPbLastUsed ( ) const [inline]

was this SIM phonebook last used

Field Documentation

T_PB_LOC_REPORT UsimPbLocReport::m_location_info

The documentation for this class was generated from the following file:
  • Apc/UsimPbTypes.hpp
Generated on Wed Jan 25 02:16:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadAsyncIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadAsyncIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadAsyncIndArg:

[legend]
Collaboration diagram for UsimPbReadAsyncIndArg:

[legend]

Public Types

enum | { ID = 1213 }

Public Member Functions

const UsimPbRefRecord & | GetPbRefRecord () const
const UsimPbResult & | GetPbResult () const
const UsimPbRwRecord & | GetPbRwRecord () const
const UsimPbSignalType & | GetPbSignalType () const
INT | GetRecno () const
void | SetPbRefRecord (const UsimPbRefRecord &pb_ref_record)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetPbRwRecord (const UsimPbRwRecord &pb_rw_record)
void | SetPbSignalType (const UsimPbSignalType &pb_signal_type)
void | SetRecno (INT recno)
UsimPbReadAsyncIndArg ()

Static Public Member Functions

static const UsimPbReadAsyncIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadAsyncIndArg: reflects arguments of signal PB_READ_RES(PB_INDICATION,PB_REFRESH)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadAsyncIndArg::UsimPbReadAsyncIndArg ( )

Member Function Documentation

const UsimPbReadAsyncIndArg & UsimPbReadAsyncIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbRefRecord& UsimPbReadAsyncIndArg::GetPbRefRecord ( ) const [inline]

const UsimPbResult& UsimPbReadAsyncIndArg::GetPbResult ( ) const [inline]

const UsimPbRwRecord& UsimPbReadAsyncIndArg::GetPbRwRecord ( ) const [inline]

const UsimPbSignalType& UsimPbReadAsyncIndArg::GetPbSignalType ( ) const [inline]

INT UsimPbReadAsyncIndArg::GetRecno ( ) const [inline]

void UsimPbReadAsyncIndArg::SetPbRefRecord ( const UsimPbRefRecord & pb_ref_record ) [inline]

void UsimPbReadAsyncIndArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbReadAsyncIndArg::SetPbRwRecord ( const UsimPbRwRecord & pb_rw_record ) [inline]

void UsimPbReadAsyncIndArg::SetPbSignalType ( const UsimPbSignalType & pb_signal_type ) [inline]

void UsimPbReadAsyncIndArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadCnfArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadCnfArg:

[legend]
Collaboration diagram for UsimPbReadCnfArg:

[legend]

Public Types

enum | { ID = 2220 }

Public Member Functions

UsimPbReadCnfArg ()

Static Public Member Functions

static const UsimPbReadCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadCnfArg: reflects arguments of signal PB_READ_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadCnfArg::UsimPbReadCnfArg ( )

Member Function Documentation

const UsimPbReadCnfArg & UsimPbReadCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadDataAsyncIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadDataAsyncIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadDataAsyncIndArg:

[legend]
Collaboration diagram for UsimPbReadDataAsyncIndArg:

[legend]

Public Types

enum | { ID = 1217 }

Public Member Functions

const T_DATA & | GetData () const
INT | GetHandle () const
const UsimPbAddType & | GetPbAddType () const
const UsimPbResult & | GetPbResult () const
const UsimPbSignalType & | GetPbSignalType () const
INT | GetRecno () const
void | SetData (const T_DATA &data)
void | SetHandle (INT handle)
void | SetPbAddType (const UsimPbAddType &pb_add_type)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetPbSignalType (const UsimPbSignalType &pb_signal_type)
void | SetRecno (INT recno)
UsimPbReadDataAsyncIndArg ()

Static Public Member Functions

static const UsimPbReadDataAsyncIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadDataAsyncIndArg: reflects arguments of signal PB_READ_DATA_RES(PB_INDICATION,PB_REFRESH)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadDataAsyncIndArg::UsimPbReadDataAsyncIndArg ( )

Member Function Documentation

const UsimPbReadDataAsyncIndArg & UsimPbReadDataAsyncIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& UsimPbReadDataAsyncIndArg::GetData ( ) const [inline]

INT UsimPbReadDataAsyncIndArg::GetHandle ( ) const [inline]

const UsimPbAddType& UsimPbReadDataAsyncIndArg::GetPbAddType ( ) const [inline]

const UsimPbResult& UsimPbReadDataAsyncIndArg::GetPbResult ( ) const [inline]

const UsimPbSignalType& UsimPbReadDataAsyncIndArg::GetPbSignalType ( ) const [inline]

INT UsimPbReadDataAsyncIndArg::GetRecno ( ) const [inline]

void UsimPbReadDataAsyncIndArg::SetData ( const T_DATA & data ) [inline]

void UsimPbReadDataAsyncIndArg::SetHandle ( INT handle ) [inline]

void UsimPbReadDataAsyncIndArg::SetPbAddType ( const UsimPbAddType & pb_add_type ) [inline]

void UsimPbReadDataAsyncIndArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbReadDataAsyncIndArg::SetPbSignalType ( const UsimPbSignalType & pb_signal_type ) [inline]

void UsimPbReadDataAsyncIndArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadDataReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadDataReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadDataReqArg:

[legend]
Collaboration diagram for UsimPbReadDataReqArg:

[legend]

Public Types

enum | { ID = 2214 }

Public Member Functions

const T_DATA & | GetData () const
INT | GetHandle () const
const UsimPbAddType & | GetPbAddType () const
INT | GetRecno () const
void | SetData (const T_DATA &data)
void | SetHandle (INT handle)
void | SetPbAddType (const UsimPbAddType &pb_add_type)
void | SetRecno (INT recno)
UsimPbReadDataReqArg ()
UsimPbReadDataReqArg (const UsimPbAddType &pb_add_type, INT recno, INT handle, const T_DATA &data)

Static Public Member Functions

static const UsimPbReadDataReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadDataReqArg: reflects arguments of signal PB_READ_DATA_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadDataReqArg::UsimPbReadDataReqArg | ( | const UsimPbAddType & | pb_add_type,
 |  | INT | recno,
 |  | INT | handle,
 |  | const T_DATA & | data
 | ) |

UsimPbReadDataReqArg::UsimPbReadDataReqArg ( )

Member Function Documentation

const UsimPbReadDataReqArg & UsimPbReadDataReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& UsimPbReadDataReqArg::GetData ( ) const [inline]

INT UsimPbReadDataReqArg::GetHandle ( ) const [inline]

const UsimPbAddType& UsimPbReadDataReqArg::GetPbAddType ( ) const [inline]

INT UsimPbReadDataReqArg::GetRecno ( ) const [inline]

void UsimPbReadDataReqArg::SetData ( const T_DATA & data ) [inline]

void UsimPbReadDataReqArg::SetHandle ( INT handle ) [inline]

void UsimPbReadDataReqArg::SetPbAddType ( const UsimPbAddType & pb_add_type ) [inline]

void UsimPbReadDataReqArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadDataResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadDataResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadDataResArg:

[legend]
Collaboration diagram for UsimPbReadDataResArg:

[legend]

Public Types

enum | { ID = 1216 }

Public Member Functions

const T_DATA & | GetData () const
INT | GetHandle () const
const UsimPbAddType & | GetPbAddType () const
const UsimPbResult & | GetPbResult () const
const UsimPbSignalType & | GetPbSignalType () const
INT | GetRecno () const
void | SetData (const T_DATA &data)
void | SetHandle (INT handle)
void | SetPbAddType (const UsimPbAddType &pb_add_type)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetPbSignalType (const UsimPbSignalType &pb_signal_type)
void | SetRecno (INT recno)
UsimPbReadDataResArg ()

Static Public Member Functions

static const UsimPbReadDataResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadDataResArg: reflects arguments of signal PB_READ_DATA_RES(PB_RESPONSE)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadDataResArg::UsimPbReadDataResArg ( )

Member Function Documentation

const UsimPbReadDataResArg & UsimPbReadDataResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& UsimPbReadDataResArg::GetData ( ) const [inline]

INT UsimPbReadDataResArg::GetHandle ( ) const [inline]

const UsimPbAddType& UsimPbReadDataResArg::GetPbAddType ( ) const [inline]

const UsimPbResult& UsimPbReadDataResArg::GetPbResult ( ) const [inline]

const UsimPbSignalType& UsimPbReadDataResArg::GetPbSignalType ( ) const [inline]

INT UsimPbReadDataResArg::GetRecno ( ) const [inline]

void UsimPbReadDataResArg::SetData ( const T_DATA & data ) [inline]

void UsimPbReadDataResArg::SetHandle ( INT handle ) [inline]

void UsimPbReadDataResArg::SetPbAddType ( const UsimPbAddType & pb_add_type ) [inline]

void UsimPbReadDataResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbReadDataResArg::SetPbSignalType ( const UsimPbSignalType & pb_signal_type ) [inline]

void UsimPbReadDataResArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadRefAsyncIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadRefAsyncIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadRefAsyncIndArg:

[legend]
Collaboration diagram for UsimPbReadRefAsyncIndArg:

[legend]

Public Types

enum | { ID = 1215 }

Public Member Functions

const T_DATA & | GetData () const
INT | GetHandle () const
const UsimPbRefType & | GetPbRefType () const
const UsimPbResult & | GetPbResult () const
const UsimPbSignalType & | GetPbSignalType () const
INT | GetRecno () const
INT | GetRefRecno () const
void | SetData (const T_DATA &data)
void | SetHandle (INT handle)
void | SetPbRefType (const UsimPbRefType &pb_ref_type)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetPbSignalType (const UsimPbSignalType &pb_signal_type)
void | SetRecno (INT recno)
void | SetRefRecno (INT ref_recno)
UsimPbReadRefAsyncIndArg ()

Static Public Member Functions

static const UsimPbReadRefAsyncIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadRefAsyncIndArg: reflects arguments of signal PB_READ_REF_RES(PB_INDICATION,PB_REFRESH)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadRefAsyncIndArg::UsimPbReadRefAsyncIndArg ( )

Member Function Documentation

const UsimPbReadRefAsyncIndArg & UsimPbReadRefAsyncIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& UsimPbReadRefAsyncIndArg::GetData ( ) const [inline]

INT UsimPbReadRefAsyncIndArg::GetHandle ( ) const [inline]

const UsimPbRefType& UsimPbReadRefAsyncIndArg::GetPbRefType ( ) const [inline]

const UsimPbResult& UsimPbReadRefAsyncIndArg::GetPbResult ( ) const [inline]

const UsimPbSignalType& UsimPbReadRefAsyncIndArg::GetPbSignalType ( ) const [inline]

INT UsimPbReadRefAsyncIndArg::GetRecno ( ) const [inline]

INT UsimPbReadRefAsyncIndArg::GetRefRecno ( ) const [inline]

void UsimPbReadRefAsyncIndArg::SetData ( const T_DATA & data ) [inline]

void UsimPbReadRefAsyncIndArg::SetHandle ( INT handle ) [inline]

void UsimPbReadRefAsyncIndArg::SetPbRefType ( const UsimPbRefType & pb_ref_type ) [inline]

void UsimPbReadRefAsyncIndArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbReadRefAsyncIndArg::SetPbSignalType ( const UsimPbSignalType & pb_signal_type ) [inline]

void UsimPbReadRefAsyncIndArg::SetRecno ( INT recno ) [inline]

void UsimPbReadRefAsyncIndArg::SetRefRecno ( INT ref_recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadRefReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadRefReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadRefReqArg:

[legend]
Collaboration diagram for UsimPbReadRefReqArg:

[legend]

Public Types

enum | { ID = 2213 }

Public Member Functions

const T_DATA & | GetData () const
INT | GetHandle () const
const UsimPbRefType & | GetPbRefType () const
INT | GetRecno () const
INT | GetRefRecno () const
void | SetData (const T_DATA &data)
void | SetHandle (INT handle)
void | SetPbRefType (const UsimPbRefType &pb_ref_type)
void | SetRecno (INT recno)
void | SetRefRecno (INT ref_recno)
UsimPbReadRefReqArg ()
UsimPbReadRefReqArg (const UsimPbRefType &pb_ref_type, INT recno, INT ref_recno, INT handle, const T_DATA &data)

Static Public Member Functions

static const UsimPbReadRefReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadRefReqArg: reflects arguments of signal PB_READ_REF_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadRefReqArg::UsimPbReadRefReqArg | ( | const UsimPbRefType & | pb_ref_type,
 |  | INT | recno,
 |  | INT | ref_recno,
 |  | INT | handle,
 |  | const T_DATA & | data
 | ) |

UsimPbReadRefReqArg::UsimPbReadRefReqArg ( )

Member Function Documentation

const UsimPbReadRefReqArg & UsimPbReadRefReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& UsimPbReadRefReqArg::GetData ( ) const [inline]

INT UsimPbReadRefReqArg::GetHandle ( ) const [inline]

const UsimPbRefType& UsimPbReadRefReqArg::GetPbRefType ( ) const [inline]

INT UsimPbReadRefReqArg::GetRecno ( ) const [inline]

INT UsimPbReadRefReqArg::GetRefRecno ( ) const [inline]

void UsimPbReadRefReqArg::SetData ( const T_DATA & data ) [inline]

void UsimPbReadRefReqArg::SetHandle ( INT handle ) [inline]

void UsimPbReadRefReqArg::SetPbRefType ( const UsimPbRefType & pb_ref_type ) [inline]

void UsimPbReadRefReqArg::SetRecno ( INT recno ) [inline]

void UsimPbReadRefReqArg::SetRefRecno ( INT ref_recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadRefResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadRefResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadRefResArg:

[legend]
Collaboration diagram for UsimPbReadRefResArg:

[legend]

Public Types

enum | { ID = 1214 }

Public Member Functions

const T_DATA & | GetData () const
INT | GetHandle () const
const UsimPbRefType & | GetPbRefType () const
const UsimPbResult & | GetPbResult () const
const UsimPbSignalType & | GetPbSignalType () const
INT | GetRecno () const
INT | GetRefRecno () const
void | SetData (const T_DATA &data)
void | SetHandle (INT handle)
void | SetPbRefType (const UsimPbRefType &pb_ref_type)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetPbSignalType (const UsimPbSignalType &pb_signal_type)
void | SetRecno (INT recno)
void | SetRefRecno (INT ref_recno)
UsimPbReadRefResArg ()

Static Public Member Functions

static const UsimPbReadRefResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadRefResArg: reflects arguments of signal PB_READ_REF_RES(PB_RESPONSE)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadRefResArg::UsimPbReadRefResArg ( )

Member Function Documentation

const UsimPbReadRefResArg & UsimPbReadRefResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& UsimPbReadRefResArg::GetData ( ) const [inline]

INT UsimPbReadRefResArg::GetHandle ( ) const [inline]

const UsimPbRefType& UsimPbReadRefResArg::GetPbRefType ( ) const [inline]

const UsimPbResult& UsimPbReadRefResArg::GetPbResult ( ) const [inline]

const UsimPbSignalType& UsimPbReadRefResArg::GetPbSignalType ( ) const [inline]

INT UsimPbReadRefResArg::GetRecno ( ) const [inline]

INT UsimPbReadRefResArg::GetRefRecno ( ) const [inline]

void UsimPbReadRefResArg::SetData ( const T_DATA & data ) [inline]

void UsimPbReadRefResArg::SetHandle ( INT handle ) [inline]

void UsimPbReadRefResArg::SetPbRefType ( const UsimPbRefType & pb_ref_type ) [inline]

void UsimPbReadRefResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbReadRefResArg::SetPbSignalType ( const UsimPbSignalType & pb_signal_type ) [inline]

void UsimPbReadRefResArg::SetRecno ( INT recno ) [inline]

void UsimPbReadRefResArg::SetRefRecno ( INT ref_recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadReqArg:

[legend]
Collaboration diagram for UsimPbReadReqArg:

[legend]

Public Types

enum | { ID = 2212 }

Public Member Functions

const UsimPbRwRecord & | GetPbRwRecord () const
INT | GetRecno () const
void | SetPbRwRecord (const UsimPbRwRecord &pb_rw_record)
void | SetRecno (INT recno)
UsimPbReadReqArg ()
UsimPbReadReqArg (INT recno, const UsimPbRwRecord &pb_rw_record)

Static Public Member Functions

static const UsimPbReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadReqArg: reflects arguments of signal PB_READ_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadReqArg::UsimPbReadReqArg | ( | INT | recno,
 |  | const UsimPbRwRecord & | pb_rw_record
 | ) |

UsimPbReadReqArg::UsimPbReadReqArg ( )

Member Function Documentation

const UsimPbReadReqArg & UsimPbReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbRwRecord& UsimPbReadReqArg::GetPbRwRecord ( ) const [inline]

INT UsimPbReadReqArg::GetRecno ( ) const [inline]

void UsimPbReadReqArg::SetPbRwRecord ( const UsimPbRwRecord & pb_rw_record ) [inline]

void UsimPbReadReqArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadResArg:

[legend]
Collaboration diagram for UsimPbReadResArg:

[legend]

Public Types

enum | { ID = 1212 }

Public Member Functions

const UsimPbRefRecord & | GetPbRefRecord () const
const UsimPbResult & | GetPbResult () const
const UsimPbRwRecord & | GetPbRwRecord () const
const UsimPbSignalType & | GetPbSignalType () const
INT | GetRecno () const
void | SetPbRefRecord (const UsimPbRefRecord &pb_ref_record)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetPbRwRecord (const UsimPbRwRecord &pb_rw_record)
void | SetPbSignalType (const UsimPbSignalType &pb_signal_type)
void | SetRecno (INT recno)
UsimPbReadResArg ()

Static Public Member Functions

static const UsimPbReadResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadResArg: reflects arguments of signal PB_READ_RES(PB_RESPONSE)

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadResArg::UsimPbReadResArg ( )

Member Function Documentation

const UsimPbReadResArg & UsimPbReadResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbRefRecord& UsimPbReadResArg::GetPbRefRecord ( ) const [inline]

const UsimPbResult& UsimPbReadResArg::GetPbResult ( ) const [inline]

const UsimPbRwRecord& UsimPbReadResArg::GetPbRwRecord ( ) const [inline]

const UsimPbSignalType& UsimPbReadResArg::GetPbSignalType ( ) const [inline]

INT UsimPbReadResArg::GetRecno ( ) const [inline]

void UsimPbReadResArg::SetPbRefRecord ( const UsimPbRefRecord & pb_ref_record ) [inline]

void UsimPbReadResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbReadResArg::SetPbRwRecord ( const UsimPbRwRecord & pb_rw_record ) [inline]

void UsimPbReadResArg::SetPbSignalType ( const UsimPbSignalType & pb_signal_type ) [inline]

void UsimPbReadResArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadyIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadyIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbReadyIndArg:

[legend]
Collaboration diagram for UsimPbReadyIndArg:

[legend]

Public Types

enum | { ID = 1224 }

Public Member Functions

const UsimPbResult & | GetPbResult () const
void | SetPbResult (const UsimPbResult &pb_result)
UsimPbReadyIndArg ()

Static Public Member Functions

static const UsimPbReadyIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbReadyIndArg: reflects arguments of signal PB_READY_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadyIndArg::UsimPbReadyIndArg ( )

Member Function Documentation

const UsimPbReadyIndArg & UsimPbReadyIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbResult& UsimPbReadyIndArg::GetPbResult ( ) const [inline]

void UsimPbReadyIndArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbReadyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbReadyMsg Class Reference

#include <Apoxi/Adc/MsgTypes.hpp>

Inheritance diagram for UsimPbReadyMsg:

[legend]
Collaboration diagram for UsimPbReadyMsg:

[legend]

Public Types

enum | { ID = 19010 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const UsimPbResult & | GetUsimPbResult () const
void | SetUsimPbResult (const UsimPbResult &usim_pb_result)
UsimPbReadyMsg (const UsimPbResult &usim_pb_result)
virtual | ~UsimPbReadyMsg ()

Detailed Description

UsimPbReadyMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbReadyMsg::UsimPbReadyMsg ( const UsimPbResult & usim_pb_result )

UsimPbReadyMsg::~UsimPbReadyMsg ( ) [virtual]

Member Function Documentation

Message * UsimPbReadyMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & UsimPbReadyMsg::GetMetaData ( ) const [virtual]

Implements Message.

const UsimPbResult& UsimPbReadyMsg::GetUsimPbResult ( ) const [inline]

void UsimPbReadyMsg::SetUsimPbResult ( const UsimPbResult & usim_pb_result ) [inline]

The documentation for this class was generated from the following files:
  • Adc/MsgTypes.hpp
  • Adc/MsgTypes.cpp
Generated on Wed Jan 25 02:16:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbRefRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbRefRecord Class Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for UsimPbRefRecord:

[legend]

Public Member Functions

void | Clear ()
UINT8 | GetAnrRecordNo (UINT idx) const
UINT8 | GetEmailRecordNo (UINT idx) const
UINT8 | GetSneRecordNo (UINT idx) const
UsimPbRefRecord & | operator= (const UsimPbRefRecord &record)
UsimPbRefRecord (const T_PB_REF_RECORD &record)
UsimPbRefRecord ()

Data Fields

T_PB_REF_RECORD m_record

Constructor & Destructor Documentation

UsimPbRefRecord::UsimPbRefRecord ( )

UsimPbRefRecord::UsimPbRefRecord ( const T_PB_REF_RECORD & record ) [inline]

Member Function Documentation

void UsimPbRefRecord::Clear ( )

UINT8 UsimPbRefRecord::GetAnrRecordNo ( UINT idx ) const [inline]

UINT8 UsimPbRefRecord::GetEmailRecordNo ( UINT idx ) const [inline]

UINT8 UsimPbRefRecord::GetSneRecordNo ( UINT idx ) const [inline]

UsimPbRefRecord& UsimPbRefRecord::operator= ( const UsimPbRefRecord & record ) [inline]

Field Documentation

T_PB_REF_RECORD UsimPbRefRecord::m_record

The documentation for this class was generated from the following files:
  • Apc/UsimPbTypes.hpp
  • Apc/UsimPbTypes.cpp
Generated on Wed Jan 25 02:16:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbResetedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbResetedMsg Class Reference

#include <Apoxi/Adc/MsgTypes.hpp>

Inheritance diagram for UsimPbResetedMsg:

[legend]
Collaboration diagram for UsimPbResetedMsg:

[legend]

Public Types

enum | { ID = 19011 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UsimPbResetedMsg ()
virtual | ~UsimPbResetedMsg ()

Detailed Description

UsimPbReadyMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbResetedMsg::UsimPbResetedMsg ( )

UsimPbResetedMsg::~UsimPbResetedMsg ( ) [virtual]

Member Function Documentation

Message * UsimPbResetedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & UsimPbResetedMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Adc/MsgTypes.hpp
  • Adc/MsgTypes.cpp
Generated on Wed Jan 25 02:16:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbRwRecord Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbRwRecord Class Reference

#include <Apoxi/Apc/UsimPbTypes.hpp>

Collaboration diagram for UsimPbRwRecord:

[legend]

Public Member Functions

void | Clear ()
const UINT8 * | GetAdnBuffer () const
const UINT8 * | GetGroupVector () const
UINT8 | GetHiddenInfo () const
UINT16 | GetUid () const
UsimPbRwRecord (INT length, UINT8 *buffer, INT grplength=0, UINT8 *groupvector=0, UINT8 hiddeninfo=0x00)
UsimPbRwRecord ()
~UsimPbRwRecord ()

Data Fields

T_PB_RECORD m_record

Constructor & Destructor Documentation

UsimPbRwRecord::UsimPbRwRecord ( )

UsimPbRwRecord::UsimPbRwRecord | ( | INT | length,
 |  | UINT8 * | buffer,
 |  | INT | grplength = 0,
 |  | UINT8 * | groupvector = 0,
 |  | UINT8 | hiddeninfo = 0x00
 | ) |

UsimPbRwRecord::~UsimPbRwRecord ( ) [inline]

Member Function Documentation

void UsimPbRwRecord::Clear ( )

const UINT8* UsimPbRwRecord::GetAdnBuffer ( ) const [inline]

const UINT8* UsimPbRwRecord::GetGroupVector ( ) const [inline]

UINT8 UsimPbRwRecord::GetHiddenInfo ( ) const [inline]

UINT16 UsimPbRwRecord::GetUid ( ) const [inline]

Field Documentation

T_PB_RECORD UsimPbRwRecord::m_record

The documentation for this class was generated from the following files:
  • Apc/UsimPbTypes.hpp
  • Apc/UsimPbTypes.cpp
Generated on Wed Jan 25 02:16:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbSelectReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbSelectReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbSelectReqArg:

[legend]
Collaboration diagram for UsimPbSelectReqArg:

[legend]

Public Types

enum | { ID = 2211 }

Public Member Functions

const UsimPbLocation & | GetPbLocation () const
BOOLEAN | IsCacheFilling () const
void | SetCacheFilling (BOOLEAN cache_filling)
void | SetPbLocation (const UsimPbLocation &pb_location)
UsimPbSelectReqArg ()
UsimPbSelectReqArg (const UsimPbLocation &pb_location, BOOLEAN cache_filling)

Static Public Member Functions

static const UsimPbSelectReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbSelectReqArg: reflects arguments of signal PB_SELECT_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbSelectReqArg::UsimPbSelectReqArg | ( | const UsimPbLocation & | pb_location,
 |  | BOOLEAN | cache_filling
 | ) |

UsimPbSelectReqArg::UsimPbSelectReqArg ( )

Member Function Documentation

const UsimPbSelectReqArg & UsimPbSelectReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbLocation& UsimPbSelectReqArg::GetPbLocation ( ) const [inline]

BOOLEAN UsimPbSelectReqArg::IsCacheFilling ( ) const [inline]

void UsimPbSelectReqArg::SetCacheFilling ( BOOLEAN cache_filling ) [inline]

void UsimPbSelectReqArg::SetPbLocation ( const UsimPbLocation & pb_location ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:16:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbSelectResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbSelectResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbSelectResArg:

[legend]
Collaboration diagram for UsimPbSelectResArg:

[legend]

Public Types

enum | { ID = 1211 }

Public Member Functions

const T_PB_DESCRIPTOR & | GetPbDescriptor () const
const UsimPbLocation & | GetPbLocation () const
const UsimPbResult & | GetPbResult () const
const UsimPbSignalType & | GetPbSignalType () const
void | SetPbDescriptor (const T_PB_DESCRIPTOR &pb_descriptor)
void | SetPbLocation (const UsimPbLocation &pb_location)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetPbSignalType (const UsimPbSignalType &pb_signal_type)
UsimPbSelectResArg ()

Static Public Member Functions

static const UsimPbSelectResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbSelectResArg: reflects arguments of signal PB_SELECT_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbSelectResArg::UsimPbSelectResArg ( )

Member Function Documentation

const UsimPbSelectResArg & UsimPbSelectResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_PB_DESCRIPTOR& UsimPbSelectResArg::GetPbDescriptor ( ) const [inline]

const UsimPbLocation& UsimPbSelectResArg::GetPbLocation ( ) const [inline]

const UsimPbResult& UsimPbSelectResArg::GetPbResult ( ) const [inline]

const UsimPbSignalType& UsimPbSelectResArg::GetPbSignalType ( ) const [inline]

void UsimPbSelectResArg::SetPbDescriptor ( const T_PB_DESCRIPTOR & pb_descriptor ) [inline]

void UsimPbSelectResArg::SetPbLocation ( const UsimPbLocation & pb_location ) [inline]

void UsimPbSelectResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbSelectResArg::SetPbSignalType ( const UsimPbSignalType & pb_signal_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbStopReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbStopReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbStopReqArg:

[legend]
Collaboration diagram for UsimPbStopReqArg:

[legend]

Public Types

enum | { ID = 2219 }

Public Member Functions

UsimPbStopReqArg ()

Static Public Member Functions

static const UsimPbStopReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbStopReqArg: reflects arguments of signal PB_STOP_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbStopReqArg::UsimPbStopReqArg ( )

Member Function Documentation

const UsimPbStopReqArg & UsimPbStopReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbStopResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbStopResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbStopResArg:

[legend]
Collaboration diagram for UsimPbStopResArg:

[legend]

Public Types

enum | { ID = 1222 }

Public Member Functions

const UsimPbResult & | GetPbResult () const
void | SetPbResult (const UsimPbResult &pb_result)
UsimPbStopResArg ()

Static Public Member Functions

static const UsimPbStopResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbStopResArg: reflects arguments of signal PB_STOP_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbStopResArg::UsimPbStopResArg ( )

Member Function Documentation

const UsimPbStopResArg & UsimPbStopResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbResult& UsimPbStopResArg::GetPbResult ( ) const [inline]

void UsimPbStopResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbUidRefreshIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbUidRefreshIndArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbUidRefreshIndArg:

[legend]
Collaboration diagram for UsimPbUidRefreshIndArg:

[legend]

Public Types

enum | { ID = 1223 }

Public Member Functions

UsimPbUidRefreshIndArg ()

Static Public Member Functions

static const UsimPbUidRefreshIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbUidRefreshIndArg: reflects arguments of signal PB_PBID_REFRESH_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbUidRefreshIndArg::UsimPbUidRefreshIndArg ( )

Member Function Documentation

const UsimPbUidRefreshIndArg & UsimPbUidRefreshIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbUpdDataReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbUpdDataReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbUpdDataReqArg:

[legend]
Collaboration diagram for UsimPbUpdDataReqArg:

[legend]

Public Types

enum | { ID = 2217 }

Public Member Functions

const T_DATA & | GetData () const
INT | GetHandle () const
const UsimPbAddType & | GetPbAddType () const
INT | GetRecno () const
void | SetData (const T_DATA &data)
void | SetHandle (INT handle)
void | SetPbAddType (const UsimPbAddType &pb_add_type)
void | SetRecno (INT recno)
UsimPbUpdDataReqArg ()
UsimPbUpdDataReqArg (const UsimPbAddType &pb_add_type, INT handle, INT recno, const T_DATA &data)

Static Public Member Functions

static const UsimPbUpdDataReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbUpdDataReqArg: reflects arguments of signal PB_UPDATE_DATA_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbUpdDataReqArg::UsimPbUpdDataReqArg | ( | const UsimPbAddType & | pb_add_type,
 |  | INT | handle,
 |  | INT | recno,
 |  | const T_DATA & | data
 | ) |

UsimPbUpdDataReqArg::UsimPbUpdDataReqArg ( )

Member Function Documentation

const UsimPbUpdDataReqArg & UsimPbUpdDataReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& UsimPbUpdDataReqArg::GetData ( ) const [inline]

INT UsimPbUpdDataReqArg::GetHandle ( ) const [inline]

const UsimPbAddType& UsimPbUpdDataReqArg::GetPbAddType ( ) const [inline]

INT UsimPbUpdDataReqArg::GetRecno ( ) const [inline]

void UsimPbUpdDataReqArg::SetData ( const T_DATA & data ) [inline]

void UsimPbUpdDataReqArg::SetHandle ( INT handle ) [inline]

void UsimPbUpdDataReqArg::SetPbAddType ( const UsimPbAddType & pb_add_type ) [inline]

void UsimPbUpdDataReqArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbUpdDataResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbUpdDataResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbUpdDataResArg:

[legend]
Collaboration diagram for UsimPbUpdDataResArg:

[legend]

Public Types

enum | { ID = 1220 }

Public Member Functions

INT | GetHandle () const
const UsimPbAddType & | GetPbAddType () const
const UsimPbResult & | GetPbResult () const
INT | GetRecno () const
void | SetHandle (INT handle)
void | SetPbAddType (const UsimPbAddType &pb_add_type)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetRecno (INT recno)
UsimPbUpdDataResArg ()

Static Public Member Functions

static const UsimPbUpdDataResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbUpdDataResArg: reflects arguments of signal PB_UPDATE_DATA_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbUpdDataResArg::UsimPbUpdDataResArg ( )

Member Function Documentation

const UsimPbUpdDataResArg & UsimPbUpdDataResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimPbUpdDataResArg::GetHandle ( ) const [inline]

const UsimPbAddType& UsimPbUpdDataResArg::GetPbAddType ( ) const [inline]

const UsimPbResult& UsimPbUpdDataResArg::GetPbResult ( ) const [inline]

INT UsimPbUpdDataResArg::GetRecno ( ) const [inline]

void UsimPbUpdDataResArg::SetHandle ( INT handle ) [inline]

void UsimPbUpdDataResArg::SetPbAddType ( const UsimPbAddType & pb_add_type ) [inline]

void UsimPbUpdDataResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbUpdDataResArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbUpdRefReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbUpdRefReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbUpdRefReqArg:

[legend]
Collaboration diagram for UsimPbUpdRefReqArg:

[legend]

Public Types

enum | { ID = 2216 }

Public Member Functions

const T_DATA & | GetData () const
INT | GetHandle () const
const UsimPbRefType & | GetPbRefType () const
INT | GetRecno () const
INT | GetRefRecno () const
void | SetData (const T_DATA &data)
void | SetHandle (INT handle)
void | SetPbRefType (const UsimPbRefType &pb_ref_type)
void | SetRecno (INT recno)
void | SetRefRecno (INT ref_recno)
UsimPbUpdRefReqArg ()
UsimPbUpdRefReqArg (const UsimPbRefType &pb_ref_type, INT recno, INT ref_recno, INT handle, const T_DATA &data)

Static Public Member Functions

static const UsimPbUpdRefReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbUpdRefReqArg: reflects arguments of signal PB_UPDATE_REF_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbUpdRefReqArg::UsimPbUpdRefReqArg | ( | const UsimPbRefType & | pb_ref_type,
 |  | INT | recno,
 |  | INT | ref_recno,
 |  | INT | handle,
 |  | const T_DATA & | data
 | ) |

UsimPbUpdRefReqArg::UsimPbUpdRefReqArg ( )

Member Function Documentation

const UsimPbUpdRefReqArg & UsimPbUpdRefReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const T_DATA& UsimPbUpdRefReqArg::GetData ( ) const [inline]

INT UsimPbUpdRefReqArg::GetHandle ( ) const [inline]

const UsimPbRefType& UsimPbUpdRefReqArg::GetPbRefType ( ) const [inline]

INT UsimPbUpdRefReqArg::GetRecno ( ) const [inline]

INT UsimPbUpdRefReqArg::GetRefRecno ( ) const [inline]

void UsimPbUpdRefReqArg::SetData ( const T_DATA & data ) [inline]

void UsimPbUpdRefReqArg::SetHandle ( INT handle ) [inline]

void UsimPbUpdRefReqArg::SetPbRefType ( const UsimPbRefType & pb_ref_type ) [inline]

void UsimPbUpdRefReqArg::SetRecno ( INT recno ) [inline]

void UsimPbUpdRefReqArg::SetRefRecno ( INT ref_recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbUpdRefResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbUpdRefResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbUpdRefResArg:

[legend]
Collaboration diagram for UsimPbUpdRefResArg:

[legend]

Public Types

enum | { ID = 1219 }

Public Member Functions

INT | GetHandle () const
const UsimPbRefType & | GetPbRefType () const
const UsimPbResult & | GetPbResult () const
INT | GetRecno () const
INT | GetRefRecno () const
void | SetHandle (INT handle)
void | SetPbRefType (const UsimPbRefType &pb_ref_type)
void | SetPbResult (const UsimPbResult &pb_result)
void | SetRecno (INT recno)
void | SetRefRecno (INT ref_recno)
UsimPbUpdRefResArg ()

Static Public Member Functions

static const UsimPbUpdRefResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbUpdRefResArg: reflects arguments of signal PB_UPDATE_REF_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbUpdRefResArg::UsimPbUpdRefResArg ( )

Member Function Documentation

const UsimPbUpdRefResArg & UsimPbUpdRefResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimPbUpdRefResArg::GetHandle ( ) const [inline]

const UsimPbRefType& UsimPbUpdRefResArg::GetPbRefType ( ) const [inline]

const UsimPbResult& UsimPbUpdRefResArg::GetPbResult ( ) const [inline]

INT UsimPbUpdRefResArg::GetRecno ( ) const [inline]

INT UsimPbUpdRefResArg::GetRefRecno ( ) const [inline]

void UsimPbUpdRefResArg::SetHandle ( INT handle ) [inline]

void UsimPbUpdRefResArg::SetPbRefType ( const UsimPbRefType & pb_ref_type ) [inline]

void UsimPbUpdRefResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbUpdRefResArg::SetRecno ( INT recno ) [inline]

void UsimPbUpdRefResArg::SetRefRecno ( INT ref_recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbUpdReqArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbUpdReqArg:

[legend]
Collaboration diagram for UsimPbUpdReqArg:

[legend]

Public Types

enum | { ID = 2215 }

Public Member Functions

const UsimPbChangedField & | GetPbChangedField () const
const UsimPbRwRecord & | GetPbRwRecord () const
INT | GetRecno () const
INT | GetStartRecno () const
void | SetPbChangedField (const UsimPbChangedField &pb_changed_field)
void | SetPbRwRecord (const UsimPbRwRecord &pb_rw_record)
void | SetRecno (INT recno)
void | SetStartRecno (INT start_recno)
UsimPbUpdReqArg ()
UsimPbUpdReqArg (INT recno, INT start_recno, const UsimPbChangedField &pb_changed_field, const UsimPbRwRecord &pb_rw_record)

Static Public Member Functions

static const UsimPbUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbUpdReqArg: reflects arguments of signal PB_UPDATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbUpdReqArg::UsimPbUpdReqArg | ( | INT | recno,
 |  | INT | start_recno,
 |  | const UsimPbChangedField & | pb_changed_field,
 |  | const UsimPbRwRecord & | pb_rw_record
 | ) |

UsimPbUpdReqArg::UsimPbUpdReqArg ( )

Member Function Documentation

const UsimPbUpdReqArg & UsimPbUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbChangedField& UsimPbUpdReqArg::GetPbChangedField ( ) const [inline]

const UsimPbRwRecord& UsimPbUpdReqArg::GetPbRwRecord ( ) const [inline]

INT UsimPbUpdReqArg::GetRecno ( ) const [inline]

INT UsimPbUpdReqArg::GetStartRecno ( ) const [inline]

void UsimPbUpdReqArg::SetPbChangedField ( const UsimPbChangedField & pb_changed_field ) [inline]

void UsimPbUpdReqArg::SetPbRwRecord ( const UsimPbRwRecord & pb_rw_record ) [inline]

void UsimPbUpdReqArg::SetRecno ( INT recno ) [inline]

void UsimPbUpdReqArg::SetStartRecno ( INT start_recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPbUpdResArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPbUpdResArg Class Reference

#include <Apoxi/Apc/PhoneBookStackMsgArgs.hpp>

Inheritance diagram for UsimPbUpdResArg:

[legend]
Collaboration diagram for UsimPbUpdResArg:

[legend]

Public Types

enum | { ID = 1218 }

Public Member Functions

const UsimPbResult & | GetPbResult () const
INT | GetRecno () const
UINT16 | GetUid () const
void | SetPbResult (const UsimPbResult &pb_result)
void | SetRecno (INT recno)
void | SetUid (UINT16 uid)
UsimPbUpdResArg ()

Static Public Member Functions

static const UsimPbUpdResArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPbUpdResArg: reflects arguments of signal PB_UPDATE_RES

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPbUpdResArg::UsimPbUpdResArg ( )

Member Function Documentation

const UsimPbUpdResArg & UsimPbUpdResArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPbResult& UsimPbUpdResArg::GetPbResult ( ) const [inline]

INT UsimPbUpdResArg::GetRecno ( ) const [inline]

UINT16 UsimPbUpdResArg::GetUid ( ) const [inline]

void UsimPbUpdResArg::SetPbResult ( const UsimPbResult & pb_result ) [inline]

void UsimPbUpdResArg::SetRecno ( INT recno ) [inline]

void UsimPbUpdResArg::SetUid ( UINT16 uid ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/PhoneBookStackMsgArgs.hpp
  • Apc/PhoneBookStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPlmn Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPlmn Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for UsimPlmn:

[legend]

Data Fields

BcdPlmn m_plmn
UINT16 m_rat

Field Documentation

BcdPlmn UsimPlmn::m_plmn

UINT16 UsimPlmn::m_rat

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 02:17:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPlmnList Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPlmnList Struct Reference

#include <Apoxi/Apc/NetworkTypes.hpp>

Collaboration diagram for UsimPlmnList:

[legend]

Data Fields

UsimPlmn val [c_maxno_usim_plmns]

Field Documentation

UsimPlmn UsimPlmnList::val[c_maxno_usim_plmns]

The documentation for this struct was generated from the following file:
  • Apc/NetworkTypes.hpp
Generated on Wed Jan 25 02:17:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPlmnReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPlmnReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimPlmnReadIndArg:

[legend]
Collaboration diagram for UsimPlmnReadIndArg:

[legend]

Public Types

enum | { ID = 1438 }

Public Member Functions

INT | GetLength () const
const UsimPlmnList & | GetPlmnList () const
const UsimReadType & | GetReadType () const
const SimUpdateStatus & | GetStatus () const
BOOLEAN | IsEndReached () const
void | SetEndReached (BOOLEAN end_reached)
void | SetLength (INT length)
void | SetPlmnList (const UsimPlmnList &plmn_list)
void | SetReadType (const UsimReadType &read_type)
void | SetStatus (const SimUpdateStatus &status)
UsimPlmnReadIndArg ()

Static Public Member Functions

static const UsimPlmnReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPlmnReadIndArg: reflects arguments of signal SI_READ_PLMN_LIST_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPlmnReadIndArg::UsimPlmnReadIndArg ( )

Member Function Documentation

const UsimPlmnReadIndArg & UsimPlmnReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimPlmnReadIndArg::GetLength ( ) const [inline]

const UsimPlmnList& UsimPlmnReadIndArg::GetPlmnList ( ) const [inline]

const UsimReadType& UsimPlmnReadIndArg::GetReadType ( ) const [inline]

const SimUpdateStatus& UsimPlmnReadIndArg::GetStatus ( ) const [inline]

BOOLEAN UsimPlmnReadIndArg::IsEndReached ( ) const [inline]

void UsimPlmnReadIndArg::SetEndReached ( BOOLEAN end_reached ) [inline]

void UsimPlmnReadIndArg::SetLength ( INT length ) [inline]

void UsimPlmnReadIndArg::SetPlmnList ( const UsimPlmnList & plmn_list ) [inline]

void UsimPlmnReadIndArg::SetReadType ( const UsimReadType & read_type ) [inline]

void UsimPlmnReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPlmnReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPlmnReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimPlmnReadReqArg:

[legend]
Collaboration diagram for UsimPlmnReadReqArg:

[legend]

Public Types

enum | { ID = 2435 }

Public Member Functions

const UsimReadType & | GetReadType () const
void | SetReadType (const UsimReadType &read_type)
UsimPlmnReadReqArg ()
UsimPlmnReadReqArg (const UsimReadType &read_type)

Static Public Member Functions

static const UsimPlmnReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPlmnReadReqArg: reflects arguments of signal SI_READ_REQ with PLMNwACT request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPlmnReadReqArg::UsimPlmnReadReqArg ( const UsimReadType & read_type )

UsimPlmnReadReqArg::UsimPlmnReadReqArg ( )

Member Function Documentation

const UsimPlmnReadReqArg & UsimPlmnReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimReadType& UsimPlmnReadReqArg::GetReadType ( ) const [inline]

void UsimPlmnReadReqArg::SetReadType ( const UsimReadType & read_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPlmnUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPlmnUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimPlmnUpdIndArg:

[legend]
Collaboration diagram for UsimPlmnUpdIndArg:

[legend]

Public Types

enum | { ID = 1449 }

Public Member Functions

const SimUpdateStatus & | GetStatus () const
void | SetStatus (const SimUpdateStatus &status)
UsimPlmnUpdIndArg ()

Static Public Member Functions

static const UsimPlmnUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPlmnUpdIndArg: reflects arguments of signal SI_UPDATE_REJ of Plmn update

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPlmnUpdIndArg::UsimPlmnUpdIndArg ( )

Member Function Documentation

const UsimPlmnUpdIndArg & UsimPlmnUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimUpdateStatus& UsimPlmnUpdIndArg::GetStatus ( ) const [inline]

void UsimPlmnUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPlmnUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPlmnUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimPlmnUpdReqArg:

[legend]
Collaboration diagram for UsimPlmnUpdReqArg:

[legend]

Public Types

enum | { ID = 2441 }

Public Member Functions

const UsimPlmn & | GetPlmn () const
INT | GetRecno () const
const UsimUpdateAction & | GetUpdateAction () const
void | SetPlmn (const UsimPlmn &plmn)
void | SetRecno (INT recno)
void | SetUpdateAction (const UsimUpdateAction &update_action)
UsimPlmnUpdReqArg ()
UsimPlmnUpdReqArg (INT recno, const UsimPlmn &plmn, const UsimUpdateAction &update_action)

Static Public Member Functions

static const UsimPlmnUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPlmnUpdReqArg: reflects arguments of signal SI_UPDATE_PLMN_IND request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPlmnUpdReqArg::UsimPlmnUpdReqArg | ( | INT | recno,
 |  | const UsimPlmn & | plmn,
 |  | const UsimUpdateAction & | update_action
 | ) |

UsimPlmnUpdReqArg::UsimPlmnUpdReqArg ( )

Member Function Documentation

const UsimPlmnUpdReqArg & UsimPlmnUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimPlmn& UsimPlmnUpdReqArg::GetPlmn ( ) const [inline]

INT UsimPlmnUpdReqArg::GetRecno ( ) const [inline]

const UsimUpdateAction& UsimPlmnUpdReqArg::GetUpdateAction ( ) const [inline]

void UsimPlmnUpdReqArg::SetPlmn ( const UsimPlmn & plmn ) [inline]

void UsimPlmnUpdReqArg::SetRecno ( INT recno ) [inline]

void UsimPlmnUpdReqArg::SetUpdateAction ( const UsimUpdateAction & update_action ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPsLociReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPsLociReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimPsLociReadIndArg:

[legend]
Collaboration diagram for UsimPsLociReadIndArg:

[legend]

Public Types

enum | { ID = 1441 }

Public Member Functions

const PsLociData & | GetPsLociData () const
const SimUpdateStatus & | GetStatus () const
void | SetPsLociData (const PsLociData &ps_loci_data)
void | SetStatus (const SimUpdateStatus &status)
UsimPsLociReadIndArg ()

Static Public Member Functions

static const UsimPsLociReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimReadRejArg: reflects arguments of signal SI_PS_LOCI_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPsLociReadIndArg::UsimPsLociReadIndArg ( )

Member Function Documentation

const UsimPsLociReadIndArg & UsimPsLociReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const PsLociData& UsimPsLociReadIndArg::GetPsLociData ( ) const [inline]

const SimUpdateStatus& UsimPsLociReadIndArg::GetStatus ( ) const [inline]

void UsimPsLociReadIndArg::SetPsLociData ( const PsLociData & ps_loci_data ) [inline]

void UsimPsLociReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimPsLociReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimPsLociReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimPsLociReadReqArg:

[legend]
Collaboration diagram for UsimPsLociReadReqArg:

[legend]

Public Types

enum | { ID = 2437 }

Public Member Functions

UsimPsLociReadReqArg ()

Static Public Member Functions

static const UsimPsLociReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimPsLociReadReqArg: reflects arguments of signal SI_READ_REQ with SI_PS_LOCI request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimPsLociReadReqArg::UsimPsLociReadReqArg ( )

Member Function Documentation

const UsimPsLociReadReqArg & UsimPsLociReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimReadRecordRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimReadRecordRejArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimReadRecordRejArg:

[legend]
Collaboration diagram for UsimReadRecordRejArg:

[legend]

Public Types

enum | { ID = 1444 }

Public Member Functions

const UsimReadType & | GetReadType () const
const SimUpdateStatus & | GetStatus () const
void | SetReadType (const UsimReadType &read_type)
void | SetStatus (const SimUpdateStatus &status)
UsimReadRecordRejArg ()

Static Public Member Functions

static const UsimReadRecordRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimReadRecordRejArg: reflects arguments of signal SI_READ_RECORD_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimReadRecordRejArg::UsimReadRecordRejArg ( )

Member Function Documentation

const UsimReadRecordRejArg & UsimReadRecordRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimReadType& UsimReadRecordRejArg::GetReadType ( ) const [inline]

const SimUpdateStatus& UsimReadRecordRejArg::GetStatus ( ) const [inline]

void UsimReadRecordRejArg::SetReadType ( const UsimReadType & read_type ) [inline]

void UsimReadRecordRejArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimReadRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimReadRejArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimReadRejArg:

[legend]
Collaboration diagram for UsimReadRejArg:

[legend]

Public Types

enum | { ID = 1439 }

Public Member Functions

const UsimReadType & | GetReadType () const
const SimUpdateStatus & | GetStatus () const
void | SetReadType (const UsimReadType &read_type)
void | SetStatus (const SimUpdateStatus &status)
UsimReadRejArg ()

Static Public Member Functions

static const UsimReadRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimReadRejArg: reflects arguments of signal SI_READ_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimReadRejArg::UsimReadRejArg ( )

Member Function Documentation

const UsimReadRejArg & UsimReadRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimReadType& UsimReadRejArg::GetReadType ( ) const [inline]

const SimUpdateStatus& UsimReadRejArg::GetStatus ( ) const [inline]

void UsimReadRejArg::SetReadType ( const UsimReadType & read_type ) [inline]

void UsimReadRejArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimSmsParamExtIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimSmsParamExtIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimSmsParamExtIndArg:

[legend]
Collaboration diagram for UsimSmsParamExtIndArg:

[legend]

Public Types

enum | { ID = 1446 }

Public Member Functions

const SimData & | GetData () const
INT | GetRecno () const
BOOLEAN | IsAddData () const
void | SetAddData (BOOLEAN add_data)
void | SetData (const SimData &data)
void | SetRecno (INT recno)
UsimSmsParamExtIndArg ()

Static Public Member Functions

static const UsimSmsParamExtIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimSmsParamExtIndArg: reflects arguments of signal SI_SM_PARAM_EXT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimSmsParamExtIndArg::UsimSmsParamExtIndArg ( )

Member Function Documentation

const UsimSmsParamExtIndArg & UsimSmsParamExtIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const SimData& UsimSmsParamExtIndArg::GetData ( ) const [inline]

INT UsimSmsParamExtIndArg::GetRecno ( ) const [inline]

BOOLEAN UsimSmsParamExtIndArg::IsAddData ( ) const [inline]

void UsimSmsParamExtIndArg::SetAddData ( BOOLEAN add_data ) [inline]

void UsimSmsParamExtIndArg::SetData ( const SimData & data ) [inline]

void UsimSmsParamExtIndArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimSmsParamReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimSmsParamReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimSmsParamReadIndArg:

[legend]
Collaboration diagram for UsimSmsParamReadIndArg:

[legend]

Public Types

enum | { ID = 1445 }

Public Member Functions

INT | GetAlphaSize () const
const SimData & | GetData () const
INT | GetRecno () const
const SimUpdateStatus & | GetStatus () const
BOOLEAN | IsAddData () const
void | SetAddData (BOOLEAN add_data)
void | SetAlphaSize (INT alpha_size)
void | SetData (const SimData &data)
void | SetRecno (INT recno)
void | SetStatus (const SimUpdateStatus &status)
UsimSmsParamReadIndArg ()

Static Public Member Functions

static const UsimSmsParamReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimSmsParamReadIndArg: reflects arguments of signal SI_SM_PARAM_READ_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimSmsParamReadIndArg::UsimSmsParamReadIndArg ( )

Member Function Documentation

const UsimSmsParamReadIndArg & UsimSmsParamReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimSmsParamReadIndArg::GetAlphaSize ( ) const [inline]

const SimData& UsimSmsParamReadIndArg::GetData ( ) const [inline]

INT UsimSmsParamReadIndArg::GetRecno ( ) const [inline]

const SimUpdateStatus& UsimSmsParamReadIndArg::GetStatus ( ) const [inline]

BOOLEAN UsimSmsParamReadIndArg::IsAddData ( ) const [inline]

void UsimSmsParamReadIndArg::SetAddData ( BOOLEAN add_data ) [inline]

void UsimSmsParamReadIndArg::SetAlphaSize ( INT alpha_size ) [inline]

void UsimSmsParamReadIndArg::SetData ( const SimData & data ) [inline]

void UsimSmsParamReadIndArg::SetRecno ( INT recno ) [inline]

void UsimSmsParamReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimSmsParamReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimSmsParamReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimSmsParamReadReqArg:

[legend]
Collaboration diagram for UsimSmsParamReadReqArg:

[legend]

Public Types

enum | { ID = 2440 }

Public Member Functions

INT | GetRecno () const
void | SetRecno (INT recno)
UsimSmsParamReadReqArg ()
UsimSmsParamReadReqArg (INT recno)

Static Public Member Functions

static const UsimSmsParamReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimEccReadReqArg: reflects arguments of signal SI_SM_PARAM_READ_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimSmsParamReadReqArg::UsimSmsParamReadReqArg ( INT recno )

UsimSmsParamReadReqArg::UsimSmsParamReadReqArg ( )

Member Function Documentation

const UsimSmsParamReadReqArg & UsimSmsParamReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimSmsParamReadReqArg::GetRecno ( ) const [inline]

void UsimSmsParamReadReqArg::SetRecno ( INT recno ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimSmsParamUpdIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimSmsParamUpdIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimSmsParamUpdIndArg:

[legend]
Collaboration diagram for UsimSmsParamUpdIndArg:

[legend]

Public Types

enum | { ID = 1451 }

Public Member Functions

INT | GetRecno () const
const SimUpdateStatus & | GetStatus () const
void | SetRecno (INT recno)
void | SetStatus (const SimUpdateStatus &status)
UsimSmsParamUpdIndArg ()

Static Public Member Functions

static const UsimSmsParamUpdIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimSmsParamUpdIndArg: reflects arguments of signal SI_SM_PARAM_UPD_IND request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimSmsParamUpdIndArg::UsimSmsParamUpdIndArg ( )

Member Function Documentation

const UsimSmsParamUpdIndArg & UsimSmsParamUpdIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimSmsParamUpdIndArg::GetRecno ( ) const [inline]

const SimUpdateStatus& UsimSmsParamUpdIndArg::GetStatus ( ) const [inline]

void UsimSmsParamUpdIndArg::SetRecno ( INT recno ) [inline]

void UsimSmsParamUpdIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimSmsParamUpdReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimSmsParamUpdReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimSmsParamUpdReqArg:

[legend]
Collaboration diagram for UsimSmsParamUpdReqArg:

[legend]

Public Types

enum | { ID = 2443 }

Public Member Functions

INT | GetRecno () const
const SmsParamRecord & | GetSmsParamRecord () const
void | SetRecno (INT recno)
void | SetSmsParamRecord (const SmsParamRecord &sms_param_record)
UsimSmsParamUpdReqArg ()
UsimSmsParamUpdReqArg (INT recno, const SmsParamRecord &sms_param_record)

Static Public Member Functions

static const UsimSmsParamUpdReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimSmsParamUpdReqArg: reflects arguments of signal SI_SM_PARAM_UPD_REQ request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimSmsParamUpdReqArg::UsimSmsParamUpdReqArg | ( | INT | recno,
 |  | const SmsParamRecord & | sms_param_record
 | ) |

UsimSmsParamUpdReqArg::UsimSmsParamUpdReqArg ( )

Member Function Documentation

const UsimSmsParamUpdReqArg & UsimSmsParamUpdReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimSmsParamUpdReqArg::GetRecno ( ) const [inline]

const SmsParamRecord& UsimSmsParamUpdReqArg::GetSmsParamRecord ( ) const [inline]

void UsimSmsParamUpdReqArg::SetRecno ( INT recno ) [inline]

void UsimSmsParamUpdReqArg::SetSmsParamRecord ( const SmsParamRecord & sms_param_record ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimUpdCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimUpdCnfArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimUpdCnfArg:

[legend]
Collaboration diagram for UsimUpdCnfArg:

[legend]

Public Types

enum | { ID = 1447 }

Public Member Functions

const UsimReadType & | GetReadType () const
void | SetReadType (const UsimReadType &read_type)
UsimUpdCnfArg ()

Static Public Member Functions

static const UsimUpdCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimUpdCnfArg: reflects arguments of signal SI_UPDATE_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimUpdCnfArg::UsimUpdCnfArg ( )

Member Function Documentation

const UsimUpdCnfArg & UsimUpdCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimReadType& UsimUpdCnfArg::GetReadType ( ) const [inline]

void UsimUpdCnfArg::SetReadType ( const UsimReadType & read_type ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimUpdRejArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimUpdRejArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimUpdRejArg:

[legend]
Collaboration diagram for UsimUpdRejArg:

[legend]

Public Types

enum | { ID = 1448 }

Public Member Functions

const UsimReadType & | GetReadType () const
const SimUpdateStatus & | GetStatus () const
void | SetReadType (const UsimReadType &read_type)
void | SetStatus (const SimUpdateStatus &status)
UsimUpdRejArg ()

Static Public Member Functions

static const UsimUpdRejArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimUpdRejArg: reflects arguments of signal SI_UPDATE_REJ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimUpdRejArg::UsimUpdRejArg ( )

Member Function Documentation

const UsimUpdRejArg & UsimUpdRejArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const UsimReadType& UsimUpdRejArg::GetReadType ( ) const [inline]

const SimUpdateStatus& UsimUpdRejArg::GetStatus ( ) const [inline]

void UsimUpdRejArg::SetReadType ( const UsimReadType & read_type ) [inline]

void UsimUpdRejArg::SetStatus ( const SimUpdateStatus & status ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:17:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimUst Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimUst Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Data Fields

UINT8 val [USIMAP_SERVICE_TABLE_LEN]

Field Documentation

UINT8 UsimUst::val[USIMAP_SERVICE_TABLE_LEN]

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:17:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimUstReadIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimUstReadIndArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimUstReadIndArg:

[legend]
Collaboration diagram for UsimUstReadIndArg:

[legend]

Public Types

enum | { ID = 1437 }

Public Member Functions

INT | GetLength () const
const SimUpdateStatus & | GetStatus () const
const UsimUst & | GetUst () const
BOOLEAN | IsFlag () const
void | SetFlag (BOOLEAN flag)
void | SetLength (INT length)
void | SetStatus (const SimUpdateStatus &status)
void | SetUst (const UsimUst &ust)
UsimUstReadIndArg ()

Static Public Member Functions

static const UsimUstReadIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimUstReadIndArg: reflects arguments of signal SI_READ_UST_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimUstReadIndArg::UsimUstReadIndArg ( )

Member Function Documentation

const UsimUstReadIndArg & UsimUstReadIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

INT UsimUstReadIndArg::GetLength ( ) const [inline]

const SimUpdateStatus& UsimUstReadIndArg::GetStatus ( ) const [inline]

const UsimUst& UsimUstReadIndArg::GetUst ( ) const [inline]

BOOLEAN UsimUstReadIndArg::IsFlag ( ) const [inline]

void UsimUstReadIndArg::SetFlag ( BOOLEAN flag ) [inline]

void UsimUstReadIndArg::SetLength ( INT length ) [inline]

void UsimUstReadIndArg::SetStatus ( const SimUpdateStatus & status ) [inline]

void UsimUstReadIndArg::SetUst ( const UsimUst & ust ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:18:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsimUstReadReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UsimUstReadReqArg Class Reference

#include <Apoxi/Apc/SimMiscStackMsgArgs.hpp>

Inheritance diagram for UsimUstReadReqArg:

[legend]
Collaboration diagram for UsimUstReadReqArg:

[legend]

Public Types

enum | { ID = 2434 }

Public Member Functions

UsimUstReadReqArg ()

Static Public Member Functions

static const UsimUstReadReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UsimUstReadReqArg: reflects arguments of signal SI_READ_REQ with UST request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UsimUstReadReqArg::UsimUstReadReqArg ( )

Member Function Documentation

const UsimUstReadReqArg & UsimUstReadReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SimMiscStackMsgArgs.hpp
  • Apc/SimMiscStackMsgArgs.cpp
Generated on Wed Jan 25 02:18:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for UssdAction:

[legend]
Collaboration diagram for UssdAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
UssdAction ()
virtual | ~UssdAction ()

Detailed Description

UssdAction analyzes if the input string has the meaning of an USSD string, that means it fullfills specification in GSM 11.10 v8.1.0, point 31.10.

Constructor & Destructor Documentation

UssdAction::UssdAction ( )

UssdAction::~UssdAction ( ) [virtual]

Member Function Documentation

InputAction * UssdAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType UssdAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

BOOLEAN UssdAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 02:18:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdAnswerIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdAnswerIndArg Class Reference

#include <Apoxi/Apc/SsStackMsgArgs.hpp>

Inheritance diagram for UssdAnswerIndArg:

[legend]
Collaboration diagram for UssdAnswerIndArg:

[legend]

Public Types

enum | { ID = 1033 }

Public Member Functions

const WString & | GetCtrlInfoString () const
const DataCodingScheme & | GetDcs () const
const SsOperationCode & | GetOperationCode () const
const Tipd & | GetTipd () const
void | SetCtrlInfoString (const WString &ctrl_info_string)
void | SetDcs (const DataCodingScheme &dcs)
void | SetOperationCode (const SsOperationCode &operation_code)
void | SetTipd (const Tipd &tipd)
UssdAnswerIndArg ()

Static Public Member Functions

static const UssdAnswerIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | CommonStackMsgArgsDestroyTableNode

Detailed Description

UssdAnswerInd: reflects arguments of signal MN_USSD_ANSWER_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdAnswerIndArg::UssdAnswerIndArg ( )

Member Function Documentation

const UssdAnswerIndArg & UssdAnswerIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const WString& UssdAnswerIndArg::GetCtrlInfoString ( ) const [inline]

const DataCodingScheme& UssdAnswerIndArg::GetDcs ( ) const [inline]

const SsOperationCode& UssdAnswerIndArg::GetOperationCode ( ) const [inline]

const Tipd& UssdAnswerIndArg::GetTipd ( ) const [inline]

void UssdAnswerIndArg::SetCtrlInfoString ( const WString & ctrl_info_string ) [inline]

void UssdAnswerIndArg::SetDcs ( const DataCodingScheme & dcs ) [inline]

void UssdAnswerIndArg::SetOperationCode ( const SsOperationCode & operation_code ) [inline]

void UssdAnswerIndArg::SetTipd ( const Tipd & tipd ) [inline]

Friends And Related Function Documentation

friend class CommonStackMsgArgsDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • Apc/SsStackMsgArgs.hpp
  • Apc/SsStackMsgArgs.cpp
Generated on Wed Jan 25 02:18:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdAnswerMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdAnswerMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdAnswerMsg:

[legend]
Collaboration diagram for UssdAnswerMsg:

[legend]

Public Types

enum | { ID = 18574 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetControlInfoString () const
virtual const MsgMetaData & | GetMetaData () const
const SsOperationCode & | GetSsOpeartionCode () const
const Tipd & | GetTipd () const
void | SetControlInfoString (const WString &control_info_string)
void | SetSsOpeartionCode (const SsOperationCode &ss_opeartion_code)
void | SetTipd (const Tipd &tipd)
UssdAnswerMsg (ExecutionContext *context, const Tipd &tipd, const SsOperationCode &ss_opeartion_code, const WString &control_info_string)
virtual | ~UssdAnswerMsg ()

Detailed Description

UssdAnswerMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdAnswerMsg::UssdAnswerMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const SsOperationCode & | ss_opeartion_code,
 |  | const WString & | control_info_string
 | ) |

UssdAnswerMsg::~UssdAnswerMsg ( ) [virtual]

Member Function Documentation

Message * UssdAnswerMsg::Clone ( ) const [virtual]

Implements Message.

const WString& UssdAnswerMsg::GetControlInfoString ( ) const [inline]

const MsgMetaData & UssdAnswerMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const SsOperationCode& UssdAnswerMsg::GetSsOpeartionCode ( ) const [inline]

const Tipd& UssdAnswerMsg::GetTipd ( ) const [inline]

void UssdAnswerMsg::SetControlInfoString ( const WString & control_info_string ) [inline]

void UssdAnswerMsg::SetSsOpeartionCode ( const SsOperationCode & ss_opeartion_code ) [inline]

void UssdAnswerMsg::SetTipd ( const Tipd & tipd ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssDataArg Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssDataArg Struct Reference
[APOXI Stack Control]

Indication of received unstrucured supplementary service data. More...

#include <Apoxi/Asc/MsgArgs.hpp>

Collaboration diagram for UssDataArg:

[legend]

Data Fields

DataCodingScheme dcs
The data coding scheme can be used as additional information.
SsOperationCode operation_code
The respective call independent supplementary operation code.
WString uss_data
Keeps the USSD user input from the remote party as WString. (not encoded).

Detailed Description

Indication of received unstrucured supplementary service data.

Field Documentation

DataCodingScheme UssDataArg::dcs

The data coding scheme can be used as additional information.

SsOperationCode UssDataArg::operation_code

The respective call independent supplementary operation code.

WString UssDataArg::uss_data

Keeps the USSD user input from the remote party as WString. (not encoded).

The documentation for this struct was generated from the following file:
  • Asc/MsgArgs.hpp
Generated on Wed Jan 25 02:18:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssDataReceivedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssDataReceivedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssDataReceivedMsg:

[legend]
Collaboration diagram for UssDataReceivedMsg:

[legend]

Public Types

enum | { ID = 18506 }

Public Member Functions

virtual Message * | Clone () const
const UssDataArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const UssDataArg &arg)
UssDataReceivedMsg (ExecutionContext *context, const UssDataArg &arg)
virtual | ~UssDataReceivedMsg ()

Detailed Description

UssDataReceivedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssDataReceivedMsg::UssDataReceivedMsg | ( | ExecutionContext * | context,
 |  | const UssDataArg & | arg
 | ) |

UssDataReceivedMsg::~UssDataReceivedMsg ( ) [virtual]

Member Function Documentation

Message * UssDataReceivedMsg::Clone ( ) const [virtual]

Implements Message.

const UssDataArg& UssDataReceivedMsg::GetArg ( ) const [inline]

const MsgMetaData & UssDataReceivedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void UssDataReceivedMsg::SetArg ( const UssDataArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdBeginMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdBeginMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdBeginMsg:

[legend]
Collaboration diagram for UssdBeginMsg:

[legend]

Public Types

enum | { ID = 18554 }

Public Member Functions

SsApiRc BeginTransaction ()
virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
UssdBeginMsg (const Tipd &tipd, const SsStackMsgArgument &argument)
virtual | ~UssdBeginMsg ()

Detailed Description

UssdBeginMsg: sent when a new USSD transaction needs to be confirmed

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdBeginMsg::UssdBeginMsg | ( | const Tipd & | tipd,
 |  | const SsStackMsgArgument & | argument
 | ) |

UssdBeginMsg::~UssdBeginMsg ( ) [virtual]

Member Function Documentation

SsApiRc UssdBeginMsg::BeginTransaction ( )

Message * UssdBeginMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & UssdBeginMsg::GetMetaData ( ) const [virtual]

Implements Message.

const Tipd& UssdBeginMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdControlIndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdControlIndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdControlIndMsg:

[legend]
Collaboration diagram for UssdControlIndMsg:

[legend]

Public Types

enum | { ID = 18706 }

Public Member Functions

virtual Message * | Clone () const
const CallControlUssdIndArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const CallControlUssdIndArg &arg)
UssdControlIndMsg (const CallControlUssdIndArg &arg)
virtual | ~UssdControlIndMsg ()

Detailed Description

UssdControlIndMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdControlIndMsg::UssdControlIndMsg ( const CallControlUssdIndArg & arg )

UssdControlIndMsg::~UssdControlIndMsg ( ) [virtual]

Member Function Documentation

Message * UssdControlIndMsg::Clone ( ) const [virtual]

Implements Message.

const CallControlUssdIndArg& UssdControlIndMsg::GetArg ( ) const [inline]

const MsgMetaData & UssdControlIndMsg::GetMetaData ( ) const [virtual]

Implements Message.

void UssdControlIndMsg::SetArg ( const CallControlUssdIndArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdDataMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdDataMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdDataMsg:

[legend]
Collaboration diagram for UssdDataMsg:

[legend]

Public Types

enum | { ID = 18555 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetData () const
const DataCodingScheme & | GetDataCodingScheme () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
UssdDataMsg (ExecutionContext *context, const Tipd &tipd, const WString &data, const DataCodingScheme &data_coding_scheme)
virtual | ~UssdDataMsg ()

Detailed Description

UssdDataMsg: sent as answer to MO USSD request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdDataMsg::UssdDataMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const WString & | data,
 |  | const DataCodingScheme & | data_coding_scheme
 | ) |

UssdDataMsg::~UssdDataMsg ( ) [virtual]

Member Function Documentation

Message * UssdDataMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const WString& UssdDataMsg::GetData ( ) const [inline]

const DataCodingScheme& UssdDataMsg::GetDataCodingScheme ( ) const [inline]

const MsgMetaData & UssdDataMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& UssdDataMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdEndMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdEndMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdEndMsg:

[legend]
Collaboration diagram for UssdEndMsg:

[legend]

Public Types

enum | { ID = 18553 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
UssdEndMsg (ExecutionContext *context, const Tipd &tipd)
virtual | ~UssdEndMsg ()

Detailed Description

UssdEndMsg: sent when a USSD transaction is terminated

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdEndMsg::UssdEndMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd
 | ) |

UssdEndMsg::~UssdEndMsg ( ) [virtual]

Member Function Documentation

Message * UssdEndMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & UssdEndMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& UssdEndMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdHandler Class Reference

#include <Apoxi/Asc/UssdHandler.hpp>

Inheritance diagram for UssdHandler:

[legend]

Public Types

enum | { ID = UssdHandlerId }

Public Member Functions

virtual SsApiRc | Acknowledge (Tipd tipd)
virtual SsApiRc | Acknowledge (const UssdNotifyMsg &msg)
virtual HandlerId | GetHandlerId () const
virtual SsApiRc | Reply (Tipd tipd, const WString &ctrl_info, const DataCodingScheme &dcs)
virtual SsApiRc | Reply (const UssdRequestMsg &msg, const WString &ctrl_info, const DataCodingScheme &dcs)
virtual SsApiRc | SendError (Tipd tipd, SsErrorCode error_code)
virtual SsApiRc | SendRejection (Tipd tipd, TaggedProblemCode code=TaggedProblemCode::ResourceLimitation)
UssdHandler ()

Protected Member Functions

SsApiRc | BeginTransaction (const SsStackMsgArgument &arg)
virtual ReturnCode | EndTransaction (const Tipd tipd)
virtual ReturnCode | ProcessStackMsgArgument (const SsStackMsgArgument &arg)

Friends

class | UssdBeginMsg

Detailed Description

The UssdHandler is a SS handler responsible for handling and conducting network-originated USSD transactions.
The class provides methods to parse the data provided by the mobile network and forward that data as messages, as well as methods to reply to mobile network requests in various fashions.
The process of conducting transactions is a bit complicated. First the initial argument is received by the SsDispatcher which will create a UssdBeginMsg wrapping the argument. The message will be sent to the MMI applications. The application responsible for handling USSD transaction has to call the BeginTransaction method of the message. This is necessary because since the transaction originates from the mobile network it is not known which applications might be interested and therefore the UssdBeginMsg is sent to all applications.
The message method then will invoke the BeginTransaction of this handler which will register the transaction, extract the initial argument wrapped in the message, create the actual message containing the data and send that message to the application which reacted on the UssdBeginMsg.
After the transaction has been established further communication adheres to the regular communication mechanisms.
See also:
SsMainHandler

SsDispatcher

UssdBeginMsg

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Constructor & Destructor Documentation

UssdHandler::UssdHandler ( )

Member Function Documentation

SsApiRc UssdHandler::Acknowledge ( Tipd tipd ) [virtual]

Sends a notification acknowledgement within the given (current) transaction.
A notification consists of an empty control info string and can only be sent in response to a UssdNotifyMsg. The are no checks performed to ensure the latter.
The method creates an SsUssdReqArg argument with an empty control info string which is sent via the SsMainHandler.

Parameters:
tipd The tipd of the current transaction.
Returns:
InvalidTipd - if the specified tipd does not match the tipd of the current transaction,
or any other code the SsMainHandler (PostArgument) might return.
See also:
SsMainHandler

SsApiRc UssdHandler::Acknowledge ( const UssdNotifyMsg & msg ) [virtual]

Sends a notification acknowledgement within the given (current) transaction.
A notification consists of an empty control info string and can only be sent in response to a UssdNotifyMsg. The are no checks performed to ensure the latter.
The method creates an SsUssdReqArg argument with an empty control info string which is sent via the SsMainHandler. This is a convenience method which extracts the tipd from a previously received message.

Parameters:
msg The message from which to extract the tipd of the current transaction.
Returns:
InvalidTipd - if the specified tipd does not match the tipd of the current transaction,
or any other code the SsMainHandler (PostArgument) might return.
See also:
SsMainHandler

SsApiRc UssdHandler::BeginTransaction ( const SsStackMsgArgument & arg ) [protected]

Called by the UssdBeginMsg (BeginTransaction) to register the new transaction and initiate dispatch of the first message. ProcessStackMsgArgument is used to create the message holding the actual data. The new message is sent via the MessageRouter. Further the transaction (the tipd and this handler) is registered with the SsMainHandler.

Parameters:
arg The initial argument sent by the mobile network which needs to be processed.
Returns:
Success - if the transaction was registered successfully and the new message sent out,
UssdTransactionError - if the handler was unable to create a message from the specified argument,
or any other code RegisterTransaction might return.
See also:
UssdBeginMsg

SsMainHandler

MessageRouter

SsBaseHandler::ReturnCode UssdHandler::EndTransaction ( const Tipd tipd ) [protected, virtual]

Called by the SsDispatcher to indicate the end of the transaction.
Creates and stores the transaction-end message (UssdEndMsg) then delegates to the superclass method for further clean-ups.

Parameters:
tipd The tipd of the transaction to end. This is used for plausability checks since there can only be one concurrent transaction anyway.
Returns:
TipdMismatch - if the tipd of the argument does not match the tipd of the current transaction,
or any other code the superclass method might return.
See also:
SsDispatcher

UssdEndMsg

HandlerId UssdHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
UssdHandlerId

Reimplemented in MobileOriginatedUssdHandler.

SsBaseHandler::ReturnCode UssdHandler::ProcessStackMsgArgument ( const SsStackMsgArgument & arg ) [protected, virtual]

This method is called by the SsDispatcher upon receiving a StackMsgArgument or by the BeginTransaction method. The method checks whether the given argument is processable in any way (contains correct data), creates a new message object using the CreateRequestMsg and CreateNotifyMsg methods and stores the message by means of its superclass. Since the transaction is initiated by the mobile network the tipd has to be stored upon arrival of the first argument of the transaction.

Parameters:
arg The wrapper object which should contain the SsUssdIndArg to be processed.
Returns:
OkMessageReady - if a message was created,
TipdMismatch - if the tipd of the argument does not match the tipd of the current transaction,
UnexpectedOperationCode - if the argument's operation code does not match ScUssdRequest or ScUssdNotify,
UnexpectedArgument - if the argument is not an SsUssdIndArg,
or any other code CreateRequestMsg or CreateNotifyMsg might return.
See also:
SsBaseHandler

SsDispatcher

Reimplemented in MobileOriginatedUssdHandler.

SsApiRc UssdHandler::Reply | ( | Tipd | tipd,
 |  | const WString & | ctrl_info,
 |  | const DataCodingScheme & | dcs
 | ) | [virtual]

Sends a return result within the given (current) transaction.
The method creates an SsUssdReqArg argument which is sent via the SsMainHandler.

Parameters:
tipd | The tipd of the current transaction.
ctrl_info | The control info string containing the data which should be sent.
dcs | The data coding scheme describing how the control info string is encoded.
Returns:
InvalidTipd - if the specified tipd does not match the tipd of the current transaction,
or any other code the SsMainHandler (PostArgument) might return.
See also:
SsMainHandler

SsApiRc UssdHandler::Reply | ( | const UssdRequestMsg & | msg,
 |  | const WString & | ctrl_info,
 |  | const DataCodingScheme & | dcs
 | ) | [virtual]

Sends a return result within the given (current) transaction.
The method creates an SsUssdReqArg argument which is sent via the SsMainHandler. This is a convenience method which extracts the tipd from a previously received message.

Parameters:
msg | The message from which to extract the tipd of the current transaction.
ctrl_info | The control info string containing the data which should be sent.
dcs | The data coding scheme describing how the control info string is encoded.
Returns:
InvalidTipd - if the specified tipd does not match the tipd of the current transaction,
or any other code the SsMainHandler (PostArgument) might return.
See also:
SsMainHandler

SsApiRc UssdHandler::SendError | ( | Tipd | tipd,
 |  | SsErrorCode | error_code
 | ) | [virtual]

Terminates the current transaction with an error request (SsErrReqArg). The argument is sent via the SsMainHandler and afterwards the transaction is released. The handler itself is reset as well.

Parameters:
tipd | The tipd of the transaction to terminate.
error_code | The error code describing the cause of the termination.
Returns:
InvalidTipd - if the specified tipd does not match the tipd of the current transaction,
or any other code the SsMainHandler (PostArgument) might return.
See also:
SsRejReqArg

SsMainHandler

SsApiRc UssdHandler::SendRejection | ( | Tipd | tipd,
 |  | TaggedProblemCode | code = TaggedProblemCode::ResourceLimitation
 | ) | [virtual]

Terminates the current transaction with a reject request (SsRejReqArg). The argument is sent via the SsMainHandler and afterwards the transaction is released. The handler itself is reset as well.

Parameters:
tipd | The tipd of the transaction to terminate.
code | The problem code describing the cause of the rejection.
Returns:
InvalidTipd - if the specified tipd does not match the tipd of the current transaction,
or any other code the SsMainHandler (PostArgument) might return.
See also:
SsRejReqArg

SsMainHandler

Friends And Related Function Documentation

friend class UssdBeginMsg [friend]

This is needed to allow the message object access to the BeginTransaction method.

The documentation for this class was generated from the following files:
  • Asc/UssdHandler.hpp
  • Asc/UssdHandler.cpp
Generated on Wed Jan 25 02:18:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdIndicationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdIndicationMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdIndicationMsg:

[legend]
Collaboration diagram for UssdIndicationMsg:

[legend]

Public Types

enum | { ID = 18514 }

Public Member Functions

virtual Message * | Clone () const
const UssDataArg & | GetArg () const
virtual const MsgMetaData & | GetMetaData () const
void | SetArg (const UssDataArg &arg)
UssdIndicationMsg (ExecutionContext *context, const UssDataArg &arg)
virtual | ~UssdIndicationMsg ()

Detailed Description

UssdIndicationMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdIndicationMsg::UssdIndicationMsg | ( | ExecutionContext * | context,
 |  | const UssDataArg & | arg
 | ) |

UssdIndicationMsg::~UssdIndicationMsg ( ) [virtual]

Member Function Documentation

Message * UssdIndicationMsg::Clone ( ) const [virtual]

Implements Message.

const UssDataArg& UssdIndicationMsg::GetArg ( ) const [inline]

const MsgMetaData & UssdIndicationMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

void UssdIndicationMsg::SetArg ( const UssDataArg & arg ) [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdNotifyMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdNotifyMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdNotifyMsg:

[legend]
Collaboration diagram for UssdNotifyMsg:

[legend]

Public Types

enum | { ID = 18552 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetControlInfo () const
const DataCodingScheme & | GetDataCodingScheme () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
UssdNotifyMsg (ExecutionContext *context, const Tipd &tipd, const WString &control_info, const DataCodingScheme &data_coding_scheme)
virtual | ~UssdNotifyMsg ()

Detailed Description

UssdNotifyMsg: sent when a USSD notify is received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdNotifyMsg::UssdNotifyMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const WString & | control_info,
 |  | const DataCodingScheme & | data_coding_scheme
 | ) |

UssdNotifyMsg::~UssdNotifyMsg ( ) [virtual]

Member Function Documentation

Message * UssdNotifyMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const WString& UssdNotifyMsg::GetControlInfo ( ) const [inline]

const DataCodingScheme& UssdNotifyMsg::GetDataCodingScheme ( ) const [inline]

const MsgMetaData & UssdNotifyMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& UssdNotifyMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdRequestMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdRequestMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdRequestMsg:

[legend]
Collaboration diagram for UssdRequestMsg:

[legend]

Public Types

enum | { ID = 18551 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetControlInfo () const
const DataCodingScheme & | GetDataCodingScheme () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetTipd () const
UssdRequestMsg (ExecutionContext *context, const Tipd &tipd, const WString &control_info, const DataCodingScheme &data_coding_scheme)
virtual | ~UssdRequestMsg ()

Detailed Description

UssdRequestMsg: sent when a USSD request is received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdRequestMsg::UssdRequestMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | tipd,
 |  | const WString & | control_info,
 |  | const DataCodingScheme & | data_coding_scheme
 | ) |

UssdRequestMsg::~UssdRequestMsg ( ) [virtual]

Member Function Documentation

Message * UssdRequestMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const WString& UssdRequestMsg::GetControlInfo ( ) const [inline]

const DataCodingScheme& UssdRequestMsg::GetDataCodingScheme ( ) const [inline]

const MsgMetaData & UssdRequestMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& UssdRequestMsg::GetTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdRequestResentMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdRequestResentMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdRequestResentMsg:

[legend]
Collaboration diagram for UssdRequestResentMsg:

[legend]

Public Types

enum | { ID = 18556 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const Tipd & | GetNewTipd () const
const Tipd & | GetOldTipd () const
UssdRequestResentMsg (ExecutionContext *context, const Tipd &new_tipd, const Tipd &old_tipd)
virtual | ~UssdRequestResentMsg ()

Detailed Description

UssdRequestResentMsg: sent if the GSM stack has to resend the USSD request

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdRequestResentMsg::UssdRequestResentMsg | ( | ExecutionContext * | context,
 |  | const Tipd & | new_tipd,
 |  | const Tipd & | old_tipd
 | ) |

UssdRequestResentMsg::~UssdRequestResentMsg ( ) [virtual]

Member Function Documentation

Message * UssdRequestResentMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & UssdRequestResentMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const Tipd& UssdRequestResentMsg::GetNewTipd ( ) const [inline]

const Tipd& UssdRequestResentMsg::GetOldTipd ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UssdResentMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UssdResentMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UssdResentMsg:

[legend]
Collaboration diagram for UssdResentMsg:

[legend]

Public Types

enum | { ID = 18515 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UssdResentMsg (ExecutionContext *context)
virtual | ~UssdResentMsg ()

Detailed Description

UssdResentMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UssdResentMsg::UssdResentMsg ( ExecutionContext * context )

UssdResentMsg::~UssdResentMsg ( ) [virtual]

Member Function Documentation

Message * UssdResentMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & UssdResentMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UtcStatusMessage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UtcStatusMessage Class Reference

#include <Apoxi/UnitTest/MsgTypes.hpp>

Inheritance diagram for UtcStatusMessage:

[legend]
Collaboration diagram for UtcStatusMessage:

[legend]

Public Types

enum | { ID = 19301 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetMessageText () const
virtual const MsgMetaData & | GetMetaData () const
BOOLEAN | IsConnectionLost () const
void | SetConnectionLost (BOOLEAN ConnectionLost)
void | SetMessageText (const WString &MessageText)
UtcStatusMessage (Application *application, const WString &MessageText, BOOLEAN ConnectionLost)
virtual | ~UtcStatusMessage ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UtcStatusMessage::UtcStatusMessage | ( | Application * | application,
 |  | const WString & | MessageText,
 |  | BOOLEAN | ConnectionLost
 | ) |

UtcStatusMessage::~UtcStatusMessage ( ) [virtual]

Member Function Documentation

Message * UtcStatusMessage::Clone ( ) const [virtual]

Implements Message.

const WString& UtcStatusMessage::GetMessageText ( ) const [inline]

const MsgMetaData & UtcStatusMessage::GetMetaData ( ) const [virtual]

Implements ContextMsg.

BOOLEAN UtcStatusMessage::IsConnectionLost ( ) const [inline]

void UtcStatusMessage::SetConnectionLost ( BOOLEAN ConnectionLost ) [inline]

void UtcStatusMessage::SetMessageText ( const WString & MessageText ) [inline]

The documentation for this class was generated from the following files:
  • UnitTest/MsgTypes.hpp
  • UnitTest/MsgTypes.cpp
Generated on Wed Jan 25 02:18:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UtcTime Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UtcTime Struct Reference

#include <Apoxi/AddOns/Lcs/Common/LcsUtils.hpp>

Data Fields

INT16 | m_day
INT16 | m_hour
INT16 | m_milli_sec
INT16 | m_min
INT16 | m_month
INT16 | m_sec
INT16 | m_year

Field Documentation

INT16 UtcTime::m_day

INT16 UtcTime::m_hour

INT16 UtcTime::m_milli_sec

INT16 UtcTime::m_min

INT16 UtcTime::m_month

INT16 UtcTime::m_sec

INT16 UtcTime::m_year

The documentation for this struct was generated from the following file:
  • AddOns/Lcs/Common/LcsUtils.hpp
Generated on Wed Jan 25 02:18:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UusErasedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UusErasedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UusErasedMsg:

[legend]
Collaboration diagram for UusErasedMsg:

[legend]

Public Types

enum | { ID = 18572 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const UusOutTextType & | GetType () const
UusErasedMsg (ExecutionContext *context, const SsCode &ss_code, const UusOutTextType &type)
virtual | ~UusErasedMsg ()

Detailed Description

UusErasedMsg: sent when UUS text was erased

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UusErasedMsg::UusErasedMsg | ( | ExecutionContext * | context,
 |  | const SsCode & | ss_code,
 |  | const UusOutTextType & | type
 | ) |

UusErasedMsg::~UusErasedMsg ( ) [virtual]

Member Function Documentation

Message * UusErasedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & UusErasedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& UusErasedMsg::GetSsCode ( ) const [inline]

const UusOutTextType& UusErasedMsg::GetType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UusHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UusHandler Class Reference

#include <Apoxi/Asc/UusHandler.hpp>

Public Types

enum | { ID = UusHandlerId }

Public Member Functions

SsApiRc | Erase (SsCode ss_code, UusOutTextType type)
virtual HandlerId | GetHandlerId () const
SsApiRc | Register (SsCode ss_code, const WString &uus_text, UusOutTextType type)
SsApiRc | RequestStatus (SsCode ss_code)
UusHandler ()
virtual | ~UusHandler ()

Protected Member Functions

virtual ReturnCode | ProcessStackMsgArgument (const SsStackMsgArgument &argument)

Detailed Description

The UusHandler is a SS handler responsible for modifying the UUS supplementary service. This includes activating and interrogating the service. Currently only UUS1 implicit is supported. The handler provides various methods for these purposes.

Member Enumeration Documentation

anonymous enum

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

Constructor & Destructor Documentation

UusHandler::UusHandler ( )

UusHandler::~UusHandler ( ) [virtual]

Member Function Documentation

SsApiRc UusHandler::Erase | ( | SsCode | ss_code,
 |  | UusOutTextType | type
 | ) |

Erases a text for UUS
Erases a text currently set for a UUS. If erasing was successful a SsRequestSentMsg is sent beside the return result of this method. Otherwise a SsRequestRejectedMsg is sent containing the error code returned by this method.

Note:
Currently only UUS1 implicit is supported. Unlike for other Supplementary Services, erasing UUS does not involve communication with the network, so no Supplementary Service strings are generated or sent.
Parameters:
ss_code | Has to be UusService1.
type | Type of UUS text that shall be erased
Returns:
Success, if text has been stored successfully ServiceNotSupported, if ss_code was UusService2 or UusService3 InvalidServiceCode, if ss_code was anything other than UUS

HandlerId UusHandler::GetHandlerId ( ) const [virtual]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
UusHandlerId

virtual ReturnCode UusHandler::ProcessStackMsgArgument ( const SsStackMsgArgument & argument ) [inline, protected, virtual]

SsApiRc UusHandler::Register | ( | SsCode | ss_code,
 |  | const WString & | uus_text,
 |  | UusOutTextType | type
 | ) |

Registers a text for UUS
Registers a text for UUS. The text is sent to the other party during a call at the stage of the call defined by the text type. If the registration was successful a SsRequestSentMsg is sent beside the return result of this method. Otherwise a SsRequestRejectedMsg is sent containing the error code returned by this method.

Note:
Currently only UUS1 implicit is supported. Unlike for other Supplementary Services, registering UUS does not involve communication with the network, so no Supplementary Service strings are generated or sent. The given text is hold only in RAM until the next reboot, hence any application that want's UUS texts to be sent has to re-register the texts at startup.
Parameters:
ss_code | Has to be UusService1.
uus_text | Text to send during call.
type | Type of UUS text
Returns:
Success, if text has been stored successfully ServiceNotSupported, if ss_code was UusService2 or UusService3 InvalidServiceCode, if ss_code was anything other than UUS

SsApiRc UusHandler::RequestStatus ( SsCode ss_code )

Interrogates the UUS status.
Queries, which texts are currently active for the given UUS. The result of the query is sent with an UusStatusMsg.

If the query was successful a SsRequestSentMsg is sent beside the return result of this method. Otherwise a SsRequestRejectedMsg is sent containing the error code returned by this method.

Parameters:
ss_code Has to be UusService1.
Returns:
Success, if text has been stored successfully ServiceNotSupported, if ss_code was UusService2 or UusService3 InvalidServiceCode, if ss_code was anything other than UUS

The documentation for this class was generated from the following files:
  • Asc/UusHandler.hpp
  • Asc/UusHandler.cpp
Generated on Wed Jan 25 02:18:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UusNotificationMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UusNotificationMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UusNotificationMsg:

[legend]
Collaboration diagram for UusNotificationMsg:

[legend]

Public Types

enum | { ID = 18568 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const WString & | GetText () const
const UusInTextType & | GetType () const
UusNotificationMsg (ExecutionContext *context, const SsCode &ss_code, const WString &text, const UusInTextType &type)
virtual | ~UusNotificationMsg ()

Detailed Description

UusNotificationMsg: sent when UUS data was received

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UusNotificationMsg::UusNotificationMsg | ( | ExecutionContext * | context,
 |  | const SsCode & | ss_code,
 |  | const WString & | text,
 |  | const UusInTextType & | type
 | ) |

UusNotificationMsg::~UusNotificationMsg ( ) [virtual]

Member Function Documentation

Message * UusNotificationMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & UusNotificationMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& UusNotificationMsg::GetSsCode ( ) const [inline]

const WString& UusNotificationMsg::GetText ( ) const [inline]

const UusInTextType& UusNotificationMsg::GetType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UusQueryRejectedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UusQueryRejectedMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UusQueryRejectedMsg:

[legend]
Collaboration diagram for UusQueryRejectedMsg:

[legend]

Public Types

enum | { ID = 18569 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UusQueryRejectedMsg (ExecutionContext *context)
virtual | ~UusQueryRejectedMsg ()

Detailed Description

UusQueryRejectedMsg: sent when UUS interrogation was rejected

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UusQueryRejectedMsg::UusQueryRejectedMsg ( ExecutionContext * context )

UusQueryRejectedMsg::~UusQueryRejectedMsg ( ) [virtual]

Member Function Documentation

Message * UusQueryRejectedMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & UusQueryRejectedMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UusRegisteredMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UusRegisteredMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UusRegisteredMsg:

[legend]
Collaboration diagram for UusRegisteredMsg:

[legend]

Public Types

enum | { ID = 18571 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const WString & | GetText () const
const UusOutTextType & | GetType () const
UusRegisteredMsg (ExecutionContext *context, const SsCode &ss_code, const WString &text, const UusOutTextType &type)
virtual | ~UusRegisteredMsg ()

Detailed Description

UusRegisteredMsg: sent when UUS text was set

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UusRegisteredMsg::UusRegisteredMsg | ( | ExecutionContext * | context,
 |  | const SsCode & | ss_code,
 |  | const WString & | text,
 |  | const UusOutTextType & | type
 | ) |

UusRegisteredMsg::~UusRegisteredMsg ( ) [virtual]

Member Function Documentation

Message * UusRegisteredMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & UusRegisteredMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& UusRegisteredMsg::GetSsCode ( ) const [inline]

const WString& UusRegisteredMsg::GetText ( ) const [inline]

const UusOutTextType& UusRegisteredMsg::GetType ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UusStatusMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UusStatusMsg Class Reference

#include <Apoxi/Asc/StackIndicationMsgTypes.hpp>

Inheritance diagram for UusStatusMsg:

[legend]
Collaboration diagram for UusStatusMsg:

[legend]

Public Types

enum | { ID = 18567 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const SsCode & | GetSsCode () const
const Vector< UusText > & | GetTextList () const
UusStatusMsg (ExecutionContext *context, const SsCode &ss_code, const Vector< UusText > &text_list)
virtual | ~UusStatusMsg ()

Detailed Description

UusStatusMsg: sent when UUS was interrogated

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

UusStatusMsg::UusStatusMsg | ( | ExecutionContext * | context,
 |  | const SsCode & | ss_code,
 |  | const Vector< UusText > & | text_list
 | ) |

UusStatusMsg::~UusStatusMsg ( ) [virtual]

Member Function Documentation

Message * UusStatusMsg::Clone ( ) const [virtual]

Reimplemented from SsMessage.

const MsgMetaData & UusStatusMsg::GetMetaData ( ) const [virtual]

Reimplemented from SsMessage.

const SsCode& UusStatusMsg::GetSsCode ( ) const [inline]

const Vector<UusText>& UusStatusMsg::GetTextList ( ) const [inline]

The documentation for this class was generated from the following files:
  • Asc/StackIndicationMsgTypes.hpp
  • Asc/StackIndicationMsgTypes.cpp
Generated on Wed Jan 25 02:18:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UusText Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

UusText Struct Reference

#include <Apoxi/Apc/SignalTypes.hpp>

Collaboration diagram for UusText:

[legend]

Data Fields

WString text
UusOutTextType type

Field Documentation

WString UusText::text

UusOutTextType UusText::type

The documentation for this struct was generated from the following file:
  • Apc/SignalTypes.hpp
Generated on Wed Jan 25 02:18:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ValidityPeriod Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ValidityPeriod Class Reference

#include <Apoxi/Apc/ValidityPeriod.hpp>

Collaboration diagram for ValidityPeriod:

[legend]

Public Member Functions

DateTime | GetAbsoluteTime () const
ValidityPeriodFormat GetFormat ()
PackedTimePeriod | GetPackedTime () const
TimeSpan | GetRelativeTime () const
UINT8 | GetSeconds () const
UINT8 | GetSize () const
size of the whole ValidityPeriod
INT | GetTimeZone () const
BOOLEAN | IsAbsolute () const
BOOLEAN | IsInSeconds () const
BOOLEAN | IsInvalid () const
Validity period has no valid format or is not present.
BOOLEAN | IsPacked () const
BOOLEAN | IsRelative () const
BOOLEAN | IsSingleShot () const
The validity period shall be applicable to the single shot short message.
void | SetAbsolutTime (const DateTime &date_time, INT time_zone=0)
void | SetPackedTime (const PackedTimePeriod &packed_time_period)
void | SetRelativeTime (const TimeSpan &time_span)
void | SetSeconds (UINT8 seconds)
void | UpdateData (UINT8 *period_data) const
void | UpdateData (UINT8 *period_format_data, UINT8 *period_data) const
ValidityPeriod (UINT8 data)
This constructor implicit supposes that the validity period format is ValidityPeriodFormat::Relative (only one byte).
ValidityPeriod (const ValidityPeriodFormat &format, const UINT8 *data)
General constructor for all possible validity period formats.
ValidityPeriod ()
General constructor for all possible validity period formats.

Detailed Description

3GPP 23.040 V5.1.0 [9.2.3.12] - Attention: This class is a wrapper over a data-stream (no data is copied). Only the anchor of the byte-stream is needed the initialize the access to the class members.

Constructor & Destructor Documentation

ValidityPeriod::ValidityPeriod ( )

General constructor for all possible validity period formats.

ValidityPeriod::ValidityPeriod | ( | const ValidityPeriodFormat & | format,
 |  | const UINT8 * | data
 | ) |

General constructor for all possible validity period formats.

ValidityPeriod::ValidityPeriod ( UINT8 data )

This constructor implicit supposes that the validity period format is ValidityPeriodFormat::Relative (only one byte).

Member Function Documentation

DateTime ValidityPeriod::GetAbsoluteTime ( ) const

ValidityPeriodFormat ValidityPeriod::GetFormat ( ) [inline]

PackedTimePeriod ValidityPeriod::GetPackedTime ( ) const

TimeSpan ValidityPeriod::GetRelativeTime ( ) const

UINT8 ValidityPeriod::GetSeconds ( ) const

UINT8 ValidityPeriod::GetSize ( ) const

size of the whole ValidityPeriod

INT ValidityPeriod::GetTimeZone ( ) const

BOOLEAN ValidityPeriod::IsAbsolute ( ) const

Validity period is absolute in semi-octet representation. The representation of time uses the class CodedTimeStamp. Use function GetAbsoluteTime.

BOOLEAN ValidityPeriod::IsInSeconds ( ) const

Validity period is relative in integer representation, where values 1..255 represent 1..255 seconds. Value 0 is undefined and reserved for future use. Use function GetSeconds.

BOOLEAN ValidityPeriod::IsInvalid ( ) const

Validity period has no valid format or is not present.

BOOLEAN ValidityPeriod::IsPacked ( ) const

Validity period is as specified for the relative case (PackedTimePeriod). Use function GetPackedTimePeriod.

BOOLEAN ValidityPeriod::IsRelative ( ) const

Validity period is relative in semi-octet representation. The representation of time uses the class Time. Use function GetRelativeTime.

BOOLEAN ValidityPeriod::IsSingleShot ( ) const

The validity period shall be applicable to the single shot short message.

void ValidityPeriod::SetAbsolutTime | ( | const DateTime & | date_time,
 |  | INT | time_zone = 0
 | ) |

void ValidityPeriod::SetPackedTime ( const PackedTimePeriod & packed_time_period )

void ValidityPeriod::SetRelativeTime ( const TimeSpan & time_span )

void ValidityPeriod::SetSeconds ( UINT8 seconds )

void ValidityPeriod::UpdateData ( UINT8 * period_data ) const

void ValidityPeriod::UpdateData | ( | UINT8 * | period_format_data,
 |  | UINT8 * | period_data
 | ) | const

The documentation for this class was generated from the following files:
  • Apc/ValidityPeriod.hpp
  • Apc/ValidityPeriod.cpp
Generated on Wed Jan 25 02:18:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ValidityPeriodFormat Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ValidityPeriodFormat Class Reference

3GPP 23.040 V5.1.0 [9.2.3.3] More...

#include <Apoxi/Apc/ValidityPeriod.hpp>

Collaboration diagram for ValidityPeriodFormat:

[legend]

Public Types

enum | Format { NotPresent = 0, Enhanced, Relative, Absolute }

Public Member Functions

Format | GetFormat () const
void | SetFormat (Format format)
void | UpdateData (UINT8 *data) const
updates the format-relevant bits (bit 3..4) in the given data.
ValidityPeriodFormat (UINT8 bit_field)
ValidityPeriodFormat (Format format)
ValidityPeriodFormat ()

Detailed Description

3GPP 23.040 V5.1.0 [9.2.3.3]

Member Enumeration Documentation

enum ValidityPeriodFormat::Format

Enumerator:
NotPresent | Validity period is not present.
Enhanced | 3GPP 23.040 V5.1.0 [9.2.3.12.3]
Relative | 3GPP 23.040 V5.1.0 [9.2.3.12.1]
Absolute | 3GPP 23.040 V5.1.0 [9.2.3.12.2]

Constructor & Destructor Documentation

ValidityPeriodFormat::ValidityPeriodFormat ( )

ValidityPeriodFormat::ValidityPeriodFormat ( Format format )

ValidityPeriodFormat::ValidityPeriodFormat ( UINT8 bit_field )

Member Function Documentation

ValidityPeriodFormat::Format ValidityPeriodFormat::GetFormat ( ) const

void ValidityPeriodFormat::SetFormat ( Format format )

Bits 4..3 = 01: Enhanced format Bits 4..3 = 10: Relative format Bits 4..3 = 11: Absolute format

void ValidityPeriodFormat::UpdateData ( UINT8 * data ) const

updates the format-relevant bits (bit 3..4) in the given data.

The documentation for this class was generated from the following files:
  • Apc/ValidityPeriod.hpp
  • Apc/ValidityPeriod.cpp
Generated on Wed Jan 25 02:18:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ValueIndicator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ValueIndicator Class Reference
[APOXI Template Layer]

Indicator that has several qualities. More...

#include <Apoxi/Compat/Indicator.hpp>

Inheritance diagram for ValueIndicator:

[legend]
Collaboration diagram for ValueIndicator:

[legend]

Public Member Functions

INT | GetMaximumValue () const
Returns the largest possible value for this indicator (default = 100).
INT | GetMinimumValue () const
Returns the lowest possible value for this indicator (default = 0).
virtual INT | GetStep () const
Returns the calculated value step which is necessary to change the indicatior. (1 per default).
INT | GetValue () const
Returns the currently assigned value.
void | SetRange (INT min, INT max)
void | SetValue (INT value)
ValueIndicator ()
Constructs an ValueIndicator object.
ValueIndicator (IndicatorPosition pos, IndicatorAlignment align)
OBSOLETE SINCE 1.21.
virtual | ~ValueIndicator ()

Detailed Description

Indicator that has several qualities.

Constructor & Destructor Documentation

ValueIndicator::ValueIndicator | ( | IndicatorPosition | pos,
 |  | IndicatorAlignment | align
 | ) |

OBSOLETE SINCE 1.21.

ValueIndicator::ValueIndicator ( )

Constructs an ValueIndicator object.

ValueIndicator::~ValueIndicator ( ) [virtual]

Member Function Documentation

INT ValueIndicator::GetMaximumValue ( ) const [inline]

Returns the largest possible value for this indicator (default = 100).

INT ValueIndicator::GetMinimumValue ( ) const [inline]

Returns the lowest possible value for this indicator (default = 0).

INT ValueIndicator::GetStep ( ) const [virtual]

Returns the calculated value step which is necessary to change the indicatior. (1 per default).

Reimplemented in IconValueIndicator.

INT ValueIndicator::GetValue ( ) const [inline]

Returns the currently assigned value.

void ValueIndicator::SetRange | ( | INT | min,
 |  | INT | max
 | ) |

Specifies the range for this position indicator. Per default the minimum value is 0, the maximum value is 100.

void ValueIndicator::SetValue ( INT value )

Assigns a value to the indicator. Values larger than the value returned by GetMaximumValue are turncated to the maximum value. Values less than the value returned by GetMinimumValue are turncated to the minimum value.

The documentation for this class was generated from the following files:
  • Compat/Indicator.hpp
  • Compat/Indicator.cpp
Generated on Wed Jan 25 02:18:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ValueMappingPropertyDescriptor< T_Container > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ValueMappingPropertyDescriptor< T_Container > Class Template Reference
[APOXI Template Layer]

#include <Apoxi/Atl/Properties/ValueMappingPropertyDescriptor.hpp>

Inheritance diagram for ValueMappingPropertyDescriptor< T_Container >:

[legend]
Collaboration diagram for ValueMappingPropertyDescriptor< T_Container >:

[legend]

Public Types

enum | { ID = 3 }

Public Member Functions

virtual ImageObtainer | GetIcon (INT index) const
virtual ImageObtainer | GetIcon (const DataItem &value) const
Obsolete method.
virtual ImageObtainer | GetIcon (const Property *property) const
virtual INT | GetItemCount () const
const MappingPolicy * | GetMappingPolicy () const
virtual WString | GetText (INT index) const
virtual WString | GetText (const DataItem &value) const
Obsolete method.
virtual WString | GetText (const Property *property) const
INT | GetTextCount () const
Obsolete - use ValueMappingPropertyDescriptor::GetItemCount() instead.
virtual DataItem | GetValue (INT index) const
virtual void | Init (const WString &title, const T_Container &pairs, const MappingPolicy *policy=0)
virtual void | Init (const WCHAR *title, const T_Container &pairs, const MappingPolicy *policy=0)
virtual void | Init (const T_Container &pairs, const MappingPolicy *policy=0, const CHAR *context_id=0)
virtual BOOLEAN | IsInstanceOf (const INT id) const
BOOLEAN | SetProperty (ResourceParser &parser, GuiObjectFactory::PropertyId property_id)
ValueMappingPropertyDescriptor (const WString &title, const T_Container &pairs, const MappingPolicy *policy=0)
ValueMappingPropertyDescriptor (const WCHAR *title, const T_Container &pairs, const MappingPolicy *policy=0)
ValueMappingPropertyDescriptor (const T_Container &pairs, const MappingPolicy *policy=0, const CHAR *context_id=0)
ValueMappingPropertyDescriptor ()
virtual | ~ValueMappingPropertyDescriptor ()
destructor

Detailed Description

template<class T_Container>
class ValueMappingPropertyDescriptor< T_Container >

A ValueMappingPropertyDescriptor holds a container of text icon pairs and a MappingPolicy. Depending on the MappingPolicy and the property's value, the ValueMappingPropertyDescriptor returns the matching text icon pair from the container.

The documentation for this class was generated from the following file:
  • Atl/Properties/ValueMappingPropertyDescriptor.hpp
Generated on Wed Jan 25 02:18:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ValueTextMap Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ValueTextMap Class Reference
[Translation]

#include <Apoxi/AddOns/Translation/ValueTextMap.hpp>

Collaboration diagram for ValueTextMap:

[legend]

Public Member Functions

const WCHAR * | GetText (INT value) const
ValueTextMap (const Table *table_ref=0)
~ValueTextMap ()

Static Public Member Functions

static const WCHAR * | InvalidText ()
static INT | InvalidValue ()

Data Structures

struct | Table

Constructor & Destructor Documentation

ValueTextMap::ValueTextMap ( const Table * table_ref = 0 ) [explicit]

ValueTextMap::~ValueTextMap ( )

Member Function Documentation

const WCHAR * ValueTextMap::GetText ( INT value ) const

static const WCHAR* ValueTextMap::InvalidText ( ) [inline, static]

static INT ValueTextMap::InvalidValue ( ) [inline, static]

The documentation for this class was generated from the following files:
  • AddOns/Translation/ValueTextMap.hpp
  • AddOns/Translation/ValueTextMap.cpp
Generated on Wed Jan 25 02:18:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ValueTextMap::Table Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
ValueTextMap::Table

ValueTextMap::Table Struct Reference

#include <Apoxi/AddOns/Translation/ValueTextMap.hpp>

Data Fields

const WCHAR * | text
INT | value

Field Documentation

const WCHAR* ValueTextMap::Table::text

INT ValueTextMap::Table::value

The documentation for this struct was generated from the following file:
  • AddOns/Translation/ValueTextMap.hpp
Generated on Wed Jan 25 02:18:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VCard Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VCard Class Reference

#include <Apoxi/Auxiliary/VCard.hpp>

Collaboration diagram for VCard:

[legend]

Public Types

typedef UINT | AdrType
typedef UINT | TelType

Public Member Functions

void | AddTelNumber (const WString &number, TelType tel_types)
WString | GetAdditionalNames () const
WString | GetAdditionalOrgUnit () const
AdrType | GetAddressType (UINT index=0) const
WString | GetCountry (UINT index=0) const
WString | GetEmail () const
WString | GetExtendedAddress (UINT index=0) const
WString | GetFamilyName () const
WString | GetFormattedName () const
WString | GetGivenName () const
WString | GetLocality (UINT index=0) const
WString | GetNamePrefix () const
WString | GetNameSuffix () const
INT | GetNumberOfAddresses () const
WString | GetOrganizationalUnit () const
WString | GetOrganizationName () const
WString | GetPostalCode (UINT index=0) const
WString | GetPostOfficeAdress (UINT index=0) const
WString | GetRegion (UINT index=0) const
WString | GetStreet (UINT index=0) const
WString | GetTelNumber (UINT index=0) const
UINT | GetTelNumberCount () const
TelType | GetTelNumberType (UINT index=0) const
WString | GetTitle () const
VCard & | operator= (const VCard &vcard)
UINT32 | ReadBuffer (const CHAR *buffer, UINT32 buffer_len)
void | SetAdditionalNames (const WString &add_name)
void | SetAdditionalOrgUnit (const WString &add_org_unit)
void | SetAddressType (AdrType address_type, UINT index=0)
void | SetCountry (const WString &country, UINT index=0)
void | SetEmail (const WString &email)
void | SetExtendedAddress (const WString &ext_address, UINT index=0)
void | SetFamilyName (const WString &family_name)
void | SetFormattedName (const WString &formatted_name)
void | SetGivenName (const WString &given_name)
void | SetLocality (const WString &locality, UINT index=0)
void | SetNamePrefix (const WString &name_prefix)
void | SetNameSuffix (const WString &name_suffix)
void | SetOrganizationalUnit (const WString &org_unit)
void | SetOrganizationName (const WString &org_name)
void | SetPostalCode (const WString &postal_code, UINT index=0)
void | SetPostOfficeAddress (const WString &po_address, UINT index=0)
void | SetRegion (const WString &region, UINT index=0)
void | SetStreet (const WString &street, UINT index=0)
void | SetTelNumber (const WString &number, UINT index=0)
void | SetTelNumberType (TelType tel_type, UINT index=0)
void | SetTitle (const WString &title)
VCard (const VCard &vCard)
VCard ()
UINT32 | WriteBuffer (CHAR *buffer, UINT32 buffer_len) const
~VCard ()

Friends

class | VCardParser
class | VCardWriter

Detailed Description

the VCard class is used to handle vCards (.vcf).

This class supports vCards as defined in version 2.1 of the vCard specification dated September 18, 1996 [1]. It can be used to parse vCard buffers received from a remote device and retrieve values of interest or to create vCard buffers by setting certain members of the class and writing the vCard data to a given buffer.

For further information about the vCard format including the full specification, RFCs, white papers and a mailing list please visit: http://www.imc.org/pdi/

[1] "vCard - The Electronic Business Card", Version 2.1, 18 September 1996 http://www.imc.org/pdi/vcard-21.doc

Member Typedef Documentation

typedef UINT VCard::AdrType

typedef UINT VCard::TelType

Constructor & Destructor Documentation

VCard::VCard ( )

constructor

VCard::VCard ( const VCard & vCard )

copy constructor

VCard::~VCard ( )

destructor

Member Function Documentation

void VCard::AddTelNumber | ( | const WString & | number,
 |  | TelType | tel_types
 | ) |

AddTelNumber adds a number to the list of phone numbers

Parameters:
number | the new telephone number value
tel_types | the type of the new telephone number

WString VCard::GetAdditionalNames ( ) const

GetAdditionalName returns the additional name property of the vCard.

Returns:
additional name

WString VCard::GetAdditionalOrgUnit ( ) const

GetAdditionalOrgUnit returns the additional organization unit property of the vCard.

Returns:
additional orzanization unit

VCard::AdrType VCard::GetAddressType ( UINT index = 0 ) const

GetAddressType returns the address type of the address at index index.

Parameters:
index index of the selected address
Returns:
address type

WString VCard::GetCountry ( UINT index = 0 ) const

GetCountry returns the country property of the address at index index.

Parameters:
index index of the selected address
Returns:
country property

WString VCard::GetEmail ( ) const

GetEmail returns the email property of the vCard.

Returns:
email

WString VCard::GetExtendedAddress ( UINT index = 0 ) const

GetExtendedAddress returns the extended address property of the address at index index.

Parameters:
index index of the selected address
Returns:
extended address property

WString VCard::GetFamilyName ( ) const

GetFamilyName returns the family name property of the vCard.

Returns:
family name

WString VCard::GetFormattedName ( ) const

GetFormattedName returns the formatted name property of the vCard.

Returns:
formatted name

WString VCard::GetGivenName ( ) const

GetGivenName returns the given name property of the vCard.

Returns:
given name

WString VCard::GetLocality ( UINT index = 0 ) const

GetLocality returns the locality property of the address at index index.

Parameters:
index index of the selected address
Returns:
locality property

WString VCard::GetNamePrefix ( ) const

GetNamePrefix returns the name prefix property of the vCard.

Returns:
name prefix

WString VCard::GetNameSuffix ( ) const

GetNameSuffix returns the name suffix property of the vCard.

Returns:
name suffix

INT VCard::GetNumberOfAddresses ( ) const

GetNumberOfAddresses returns the number of stored addresses in the current object.

Returns:
the number of stored addresses

WString VCard::GetOrganizationalUnit ( ) const

GetOrganizationalUnit returns the organization unit property of the vCard.

Returns:
organization unit

WString VCard::GetOrganizationName ( ) const

GetOrganizationName returns the organization name property of the vCard.

Returns:
organization name

WString VCard::GetPostalCode ( UINT index = 0 ) const

GetPostalCode returns the postal code property of the address at index index.

Parameters:
index index of the selected address
Returns:
postal code property

WString VCard::GetPostOfficeAdress ( UINT index = 0 ) const

GetPostOfficeAdress returns the post office property of the address at index index.

Parameters:
index index of the selected address
Returns:
post office property

WString VCard::GetRegion ( UINT index = 0 ) const

GetRegion returns the region property of the address at index index.

Parameters:
index index of the selected address
Returns:
region property

WString VCard::GetStreet ( UINT index = 0 ) const

GetStreet returns the street property of the address at index index.

Parameters:
index index of the selected address
Returns:
street property

WString VCard::GetTelNumber ( UINT index = 0 ) const

GetTelNumber returns the telephone number with the given index.

Parameters:
index index of the selected telephone number
Returns:
telephone number

UINT VCard::GetTelNumberCount ( ) const

GetTelNumberCount returns number of stored phone numbers

Returns:
number of stored phone numbers

VCard::TelType VCard::GetTelNumberType ( UINT index = 0 ) const

GetTelNumberType returns the telephone number type with the given index.

Parameters:
index index of the selected telephone number
Returns:
telephone number type

WString VCard::GetTitle ( ) const

GetTitle returns the title property of the vCard.

Returns:
title

VCard & VCard::operator= ( const VCard & vcard )

assignment operator

UINT32 VCard::ReadBuffer | ( | const CHAR * | buffer,
 |  | UINT32 | buffer_len
 | ) |

ReadBuffer initializes the vCard with the data provided in buffer.

Parameters:
buffer | vCard data
buffer_len | length of the buffer
Returns:
number of bytes consumed during parsing, (UINT32) -1 in case of error

void VCard::SetAdditionalNames ( const WString & add_name )

SetAdditionalNames sets the additional parts of the name property of the vCard.

Parameters:
add_names the new value

void VCard::SetAdditionalOrgUnit ( const WString & add_org_unit )

SetAdditionalOrgUnit sets the additional organization unit property of the vCard.

Parameters:
add_org_unit the new additional organization unit value

void VCard::SetAddressType | ( | AdrType | address_type,
 |  | UINT | index = 0
 | ) |

SetAddressType sets the address type of the address at index index.

Parameters:
address_type | the new address type
index | index of the selected address

void VCard::SetCountry | ( | const WString & | country,
 |  | UINT | index = 0
 | ) |

SetCountry sets the country property of the address at index index.

Parameters:
country | the new country property value
index | index of the selected address

void VCard::SetEmail ( const WString & email )

SetEmail sets the email property of the vCard.

Parameters:
email the new value

void VCard::SetExtendedAddress | ( | const WString & | ext_address,
 |  | UINT | index = 0
 | ) |

SetExtendedAddress sets the extended address property of the address at index index.

Parameters:
ext_address | the new extended address property value
index | index of the selected address

void VCard::SetFamilyName ( const WString & family_name )

SetFamilyName sets the family name property of the vCard.

Parameters:
family_name the new value

void VCard::SetFormattedName ( const WString & formatted_name )

SetFormattedName sets the formatted name property of the vCard.

Parameters:
formatted_name the new value

void VCard::SetGivenName ( const WString & given_name )

SetGivenName sets the given name property of the vCard.

Parameters:
given_name the new value

void VCard::SetLocality | ( | const WString & | locality,
 |  | UINT | index = 0
 | ) |

SetLocality sets the locality property of the address at index index.

Parameters:
locality | the new locality property value
index | index of the selected address

void VCard::SetNamePrefix ( const WString & name_prefix )

SetNamePrefix sets the name prefix property of the vCard.

Parameters:
name_prefix the new value

void VCard::SetNameSuffix ( const WString & name_suffix )

SetNameSuffix sets the name suffix property of the vCard.

Parameters:
name_suffix the new value

void VCard::SetOrganizationalUnit ( const WString & org_unit )

SetOrganizationalUnit sets the organization unit property of the vCard.

Parameters:
org_unit the new organization unit value

void VCard::SetOrganizationName ( const WString & org_name )

SetOrganizationName sets the organization name property of the vCard.

Parameters:
org_name the new organization name value

void VCard::SetPostalCode | ( | const WString & | postal_code,
 |  | UINT | index = 0
 | ) |

SetPostalCode sets the postal code property of the address at index index.

Parameters:
postal_code | the new postal code property value
index | index of the selected address

void VCard::SetPostOfficeAddress | ( | const WString & | po_address,
 |  | UINT | index = 0
 | ) |

SetPostOfficeAddress sets the post office property of the address at index index.

Parameters:
po_address | the new post office property value
index | index of the selected address

void VCard::SetRegion | ( | const WString & | region,
 |  | UINT | index = 0
 | ) |

SetRegion sets the region property of the address at index index.

Parameters:
region | the new region property value
index | index of the selected address

void VCard::SetStreet | ( | const WString & | street,
 |  | UINT | index = 0
 | ) |

SetStreet sets the street property of the address at index index.

Parameters:
street | the new street property value
index | index of the selected address

void VCard::SetTelNumber | ( | const WString & | number,
 |  | UINT | index = 0
 | ) |

SetTelNumber sets the telephone number with the given index.

Parameters:
number | the new telephone number value
index | index of the selected telephone number

void VCard::SetTelNumberType | ( | TelType | tel_type,
 |  | UINT | index = 0
 | ) |

SetTelNumberType sets the telephone number type with the given index.

Parameters:
tel_type | the new telephone number type
index | index of the selected telephone number

void VCard::SetTitle ( const WString & title )

SetTitle sets the title property of the vCard.

Parameters:
title the new title value

UINT32 VCard::WriteBuffer | ( | CHAR * | buffer,
 |  | UINT32 | buffer_len
 | ) | const

WriteBuffer creates a byte buffer containing the properties of the vCard.

Parameters:
buffer | where to write the vCard data to
buffer_len | length of the buffer
Returns:
amount written, (UINT32) -1 if buffer was too small

Friends And Related Function Documentation

friend class VCardParser [friend]

friend class VCardWriter [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/VCard.hpp
  • Auxiliary/VCard.cpp
Generated on Wed Jan 25 02:19:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VCardItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VCardItem Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/VCardItem.hpp>

Inheritance diagram for VCardItem:

[legend]
Collaboration diagram for VCardItem:

[legend]

Public Types

enum | { ID = 14 }

Public Member Functions

virtual AtomItem * | Clone () const
virtual void | Draw (DeviceContext *dc, const Rect &bounds) const
virtual XYDIM | GetHeight () const
virtual INT | GetId () const
const VCard & | GetVCard () const
Returns the embedded VCard.
virtual XYDIM | GetWidth () const
virtual BOOLEAN | IsInstanceOf (INT id) const
VCardItem (const VCard &vcard)
virtual | ~VCardItem ()

Detailed Description

Represents a bounded item which can get a VCard as input. When adding the VCardItem to the editor document, a clone of the VCardItem will be made so that the original VCardItem can be deleted at any time.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from BoundedItem.

Constructor & Destructor Documentation

VCardItem::VCardItem ( const VCard & vcard ) [explicit]

Parameters:
vcard VCard which should be displayed. A copy of the VCard is kept inside the VCardItem, which means that the passed VCard can be deleted at any time.

VCardItem::~VCardItem ( ) [virtual]

Member Function Documentation

AtomItem * VCardItem::Clone ( ) const [virtual]

Returns a pointer to a flat copy of this object, hence the cloned object and the original object are pointing to the same VCard.

See also:
AtomItem::Clone();

Implements AtomItem.

void VCardItem::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | bounds
 | ) | const [virtual]

See also:
AtomItem::Draw

Implements AtomItem.

XYDIM VCardItem::GetHeight ( ) const [virtual]

See also:
BoundedItem::GetHeight

Implements BoundedItem.

INT VCardItem::GetId ( ) const [virtual]

See also:
AtomItem::GetId()

Reimplemented from BoundedItem.

const VCard& VCardItem::GetVCard ( ) const [inline]

Returns the embedded VCard.

XYDIM VCardItem::GetWidth ( ) const [virtual]

See also:
BoundedItem::GetWidth

Implements BoundedItem.

BOOLEAN VCardItem::IsInstanceOf ( INT id ) const [virtual]

See also:
AbstractEditorItem::IsInstanceOf

Reimplemented from BoundedItem.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/VCardItem.hpp
  • AddOns/MultiMedia/VCardItem.cpp
Generated on Wed Jan 25 02:19:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VCardParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VCardParser Class Reference

#include <Apoxi/Auxiliary/VCard.hpp>

Public Member Functions

UINT32 ReadVCard (const CHAR *vcard_buffer, const UINT32 vcard_buffer_len, VCard *vcard)

Detailed Description

VCardParser parses a buffer which contains a vCard.

Shouldn't be used directly. Use the ReadBuffer() function of the VCard class instead.

Member Function Documentation

UINT32 VCardParser::ReadVCard | ( | const CHAR * | vcard_buffer,
 |  | const UINT32 | vcard_buffer_len,
 |  | VCard * | vcard
 | ) |

ReadVCard reads a byte buffer, which contains a vCard, and sets the values of the VCard object according to the values in the vcard_buffer. According to conversion and memory requirements not all of the items of the vcard_buffer are set in the vCard, only those items which shall be stored in vCard. E.g. binary data of PHOTO is dropped and not stored in the vCard.

Parameters:
vcard_buffer | the byte buffer containing the vCard
vcard_buffer_len | the length of the byte buffer
vCard | the vCard which shall be filled with the values contained in the byte buffer
Returns:
number of bytes read, (UINT32) -1 on error

The documentation for this class was generated from the following files:
  • Auxiliary/VCard.hpp
  • Auxiliary/VCard.cpp
Generated on Wed Jan 25 02:19:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VCardWriter Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VCardWriter Class Reference

#include <Apoxi/Auxiliary/VCard.hpp>

Collaboration diagram for VCardWriter:

[legend]

Public Member Functions

UINT32 WriteVCard (CHAR *buffer, UINT32 buffer_len, const VCard *vcard)

Detailed Description

VCardWriter dumps the content of a VCard object to a vCard stream.

Shouldn't be used directly. Use the WriteBuffer() function of the VCard class instead.

Member Function Documentation

UINT32 VCardWriter::WriteVCard | ( | CHAR * | buffer,
 |  | UINT32 | buffer_len,
 |  | const VCard * | vcard
 | ) |

WriteVCard writes vCard stream using the values from vcard

Parameters:
buffer | the buffer to write to
buffer_len | size of the buffer in bytes
vcard | vcard object
Returns:
size of the write_buffer used on success, (UINT32) -1 if the write_buffer is to small

The documentation for this class was generated from the following files:
  • Auxiliary/VCard.hpp
  • Auxiliary/VCard.cpp
Generated on Wed Jan 25 02:19:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Vector< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Vector< T > Class Template Reference
[Auxiliary]

#include <Apoxi/Auxiliary/Vector.hpp>

Inheritance diagram for Vector< T >:

[legend]
Collaboration diagram for Vector< T >:

[legend]

Public Types

enum | { c_increment = 5 }
typedef const Iterator | ConstIterator
typedef const T & | ConstReference
typedef const Iterator | ConstReverseIterator
typedef INT | DifferenceType
typedef T & | Reference
typedef Iterator | ReverseIterator
typedef INT | SizeType
typedef T | ValueType

Public Member Functions

ConstReference | Back () const
Reference Back ()
Iterator | Begin () const
Returns an iterator pointing at the first element in collection.
SizeType | Capacity () const
Iterator | End () const
void | Erase (const Iterator &first, const Iterator &last)
void | Erase (const Iterator &pos)
ConstReference | Front () const
Reference Front ()
SizeType | GetSize () const
void | Insert (const Iterator &pos, SizeType n, ConstReference x)
void | Insert (const Iterator &pos)
void | Insert (const Iterator &pos, ConstReference x)
BOOLEAN | IsEmpty () const
SizeType | MaxSize () const
Vector< T > & | operator= (const Vector< T > &from)
ConstReference | operator[] (SizeType i) const
Reference operator[] (SizeType i)
void | PopBack ()
void | PushBack (ConstReference x)
ReverseIterator | RBegin () const
ReverseIterator | REnd () const
void | Reserve (SizeType n)
Vector (const Vector< T > &x)
Copy constructor.
Vector (SizeType n)
Vector ()
Default constructor.
Vector (SizeType n, ConstReference value)
~Vector ()
Destructor.

Friends

class | Iterator

Data Structures

class | Iterator
Iterator can be used to iterate elements of a vector. More...

Detailed Description

template<typename T>
class Vector< T >

Class Vector implements a not 100 percent STL-compliant subset of the standard C++ vector class. Naming conventions have been adopted to the APOXI naming conventions.

Member Typedef Documentation

template<typename T>
typedef const Iterator Vector< T >::ConstIterator

template<typename T>
typedef const T& Vector< T >::ConstReference

template<typename T>
typedef const Iterator Vector< T >::ConstReverseIterator

template<typename T>
typedef INT Vector< T >::DifferenceType

Reimplemented in WbxmlVector< T >.

template<typename T>
typedef T& Vector< T >::Reference

template<typename T>
typedef Iterator Vector< T >::ReverseIterator

template<typename T>
typedef INT Vector< T >::SizeType

Reimplemented in WbxmlVector< T >.

template<typename T>
typedef T Vector< T >::ValueType

Member Enumeration Documentation

template<typename T>
anonymous enum

Enumerator:
c_increment

Constructor & Destructor Documentation

template<typename T>
Vector< T >::Vector ( ) [inline]

Default constructor.

template<typename T>
Vector< T >::Vector ( const Vector< T > & x ) [inline]

Copy constructor.

Member Function Documentation

template<typename T>
ConstReference Vector< T >::Back ( ) const [inline]

Returns:
Const reference to the last element in collection.

template<typename T>
Reference Vector< T >::Back ( ) [inline]

Returns:
Reference to the last element in collection.

template<typename T>
Iterator Vector< T >::Begin ( ) const [inline]

Returns an iterator pointing at the first element in collection.

template<typename T>
SizeType Vector< T >::Capacity ( ) const [inline]

template<typename T>
Iterator Vector< T >::End ( ) const [inline]

Returns an iterator pointing past the last element in collection. Please note: *(v.End()) references an invalid element of v.

template<typename T>
ConstReference Vector< T >::Front ( ) const [inline]

Returns:
Const reference to the first element in collection.

template<typename T>
Reference Vector< T >::Front ( ) [inline]

Returns:
Reference to the first element in collection.

template<typename T>
SizeType Vector< T >::GetSize ( ) const [inline]

Returns:
Returns the current number of elements in collection.

template<typename T>
void Vector< T >::Insert ( const Iterator & pos ) [inline]

template<typename T>
BOOLEAN Vector< T >::IsEmpty ( ) const [inline]

Returns:
Returns if collection contains elements (i.e. GetSize() != 0).

template<typename T>
SizeType Vector< T >::MaxSize ( ) const [inline]

Returns:
Returns the maximum elements the collection can store.

template<typename T>
ConstReference Vector< T >::operator[] ( SizeType i ) const [inline]

Parameters:
i Index of element to return.
Returns:
Const reference to element at index i.

template<typename T>
Reference Vector< T >::operator[] ( SizeType i ) [inline]

Parameters:
i Index of element to return.
Returns:
Reference to element at index i.

template<typename T>
ReverseIterator Vector< T >::RBegin ( ) const [inline]

Returns an iterator pointing at the first element in reverse order of collection.

template<typename T>
ReverseIterator Vector< T >::REnd ( ) const [inline]

Returns an iterator pointing past the last element in reverse order of collection. Please note: *(v.REnd()) references an invalid element of v.

Friends And Related Function Documentation

template<typename T>
friend class Iterator [friend]

The documentation for this class was generated from the following file:
  • Auxiliary/Vector.hpp
Generated on Wed Jan 25 02:19:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Vector< T >::Iterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
Vector::Iterator

Vector< T >::Iterator Class Reference

Iterator can be used to iterate elements of a vector. More...

#include <Apoxi/Auxiliary/Vector.hpp>

Public Member Functions

ConstReference | operator * () const
Dereferencing operator to access current element in collection.
Reference operator * ()
Dereferencing operator to access current element in collection.
BOOLEAN | operator!= (const Iterator &i) const
DifferenceType | operator+ (const Iterator &i)
Deprecated.
Iterator | operator+ (DifferenceType n) const
Advance iterator to nth element after current element.
Iterator & | operator++ (INT)
Move iterator to next element of collection.
DifferenceType | operator- (const Iterator &i)
Deprecated.
Iterator | operator- (DifferenceType n) const
Advance iterator to nth element before current element.
Iterator & | operator-- (INT)
Move iterator to previous element of collection.
BOOLEAN | operator< (const Iterator &i) const
BOOLEAN | operator<= (const Iterator &i) const
BOOLEAN | operator== (const Iterator &i) const
BOOLEAN | operator> (const Iterator &i) const
BOOLEAN | operator>= (const Iterator &i) const

Protected Member Functions

Iterator (const Vector< T > *daddy, SizeType i)
Iterator (Vector< T > *daddy, SizeType i)

Protected Attributes

SizeType current
Vector< T > * | owner

Friends

class | Vector< T >

Detailed Description

template<typename T>
class Vector< T >::Iterator

Iterator can be used to iterate elements of a vector.

Constructor & Destructor Documentation

template<typename T>
Vector< T >::Iterator::Iterator | ( | Vector< T > * | daddy,
 |  | SizeType | i
 | ) | [inline, protected]

template<typename T>
Vector< T >::Iterator::Iterator | ( | const Vector< T > * | daddy,
 |  | SizeType | i
 | ) | [inline, protected]

Member Function Documentation

template<typename T>
ConstReference Vector< T >::Iterator::operator * ( ) const [inline]

Dereferencing operator to access current element in collection.

template<typename T>
Reference Vector< T >::Iterator::operator * ( ) [inline]

Dereferencing operator to access current element in collection.

template<typename T>
BOOLEAN Vector< T >::Iterator::operator!= ( const Iterator & i ) const [inline]

template<typename T>
DifferenceType Vector< T >::Iterator::operator+ ( const Iterator & i ) [inline]

Deprecated.

template<typename T>
Iterator Vector< T >::Iterator::operator+ ( DifferenceType n ) const

Advance iterator to nth element after current element.

template<typename T>
Iterator& Vector< T >::Iterator::operator++ ( INT ) [inline]

Move iterator to next element of collection.

Note: Unlike the corresponding STL vector method, this implementation returns a reference to the iterator after it has been modified despite of the postfix syntax being used!

template<typename T>
DifferenceType Vector< T >::Iterator::operator- ( const Iterator & i ) [inline]

Deprecated.

template<typename T>
Iterator Vector< T >::Iterator::operator- ( DifferenceType n ) const

Advance iterator to nth element before current element.

template<typename T>
Iterator& Vector< T >::Iterator::operator-- ( INT ) [inline]

Move iterator to previous element of collection.

Note: Unlike the corresponding STL vector method, this implementation returns a reference to the iterator after it has been modified despite of the postfix syntax being used!

template<typename T>
BOOLEAN Vector< T >::Iterator::operator< ( const Iterator & i ) const [inline]

template<typename T>
BOOLEAN Vector< T >::Iterator::operator<= ( const Iterator & i ) const [inline]

template<typename T>
BOOLEAN Vector< T >::Iterator::operator== ( const Iterator & i ) const [inline]

template<typename T>
BOOLEAN Vector< T >::Iterator::operator> ( const Iterator & i ) const [inline]

template<typename T>
BOOLEAN Vector< T >::Iterator::operator>= ( const Iterator & i ) const [inline]

Friends And Related Function Documentation

template<typename T>
friend class Vector< T > [friend]

Field Documentation

template<typename T>
SizeType Vector< T >::Iterator::current [protected]

template<typename T>
Vector<T>* Vector< T >::Iterator::owner [protected]

The documentation for this class was generated from the following file:
  • Auxiliary/Vector.hpp
Generated on Wed Jan 25 02:19:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VersionInfo Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VersionInfo Class Reference
[Kernel]

#include <Apoxi/Kernel/VersionInfo.hpp>

Collaboration diagram for VersionInfo:

[legend]

Public Types

enum | { c_flag_never_show_on_display = (1U << 0U), c_flag_hide_in_engineering_mode = (1U << 1U), c_flag_add_to_trace_info = (1U << 2U), c_flag_is_build_version = (1U << 3U) }

Public Member Functions

const CHAR * | GetBuildDate () const
Return build date and time of subsystem.
UINT | GetFlags () const
Return flags that specify how to handle or display version information.
const VersionInfo * | GetNext () const
Return next VersionInfo.
const CHAR * | GetSubSystemName () const
Returns the name of the subsystem the version information applies to.
const CHAR * | GetVersionString () const
Return subsystem specific version string.
VersionInfo (const Data *data)

Static Public Member Functions

static const VersionInfo * | GetFirst ()
Return first VersionInfo.

Data Structures

struct | Data

Detailed Description

VersionInfo provides means to supply version information for a specified subsystem. Using this class any part of the system can add version information to the system. The system maintains a list of VersionInfo objects that can be used to display or output to trace version information. Any submodule can add VersionInfo objects to that list. The VersionInfo objects will be linked at power on time automatically.

Member Enumeration Documentation

anonymous enum

Enumerator:
c_flag_never_show_on_display
c_flag_hide_in_engineering_mode
c_flag_add_to_trace_info
c_flag_is_build_version

Constructor & Destructor Documentation

VersionInfo::VersionInfo ( const Data * data )

Member Function Documentation

const CHAR* VersionInfo::GetBuildDate ( ) const [inline]

Return build date and time of subsystem.

static const VersionInfo* VersionInfo::GetFirst ( ) [inline, static]

Return first VersionInfo.

UINT VersionInfo::GetFlags ( ) const [inline]

Return flags that specify how to handle or display version information.

const VersionInfo* VersionInfo::GetNext ( ) const [inline]

Return next VersionInfo.

const CHAR* VersionInfo::GetSubSystemName ( ) const [inline]

Returns the name of the subsystem the version information applies to.

const CHAR* VersionInfo::GetVersionString ( ) const [inline]

Return subsystem specific version string.

The documentation for this class was generated from the following files:
  • Kernel/VersionInfo.hpp
  • Kernel/VersionInfo.cpp
Generated on Wed Jan 25 02:19:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VersionInfo::Data Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
VersionInfo::Data

VersionInfo::Data Struct Reference

#include <Apoxi/Kernel/VersionInfo.hpp>

Data Fields

const CHAR * | m_build_date
UINT | m_flags
const CHAR * | m_subsys_name
const CHAR * | m_version_string

Field Documentation

const CHAR* VersionInfo::Data::m_build_date

UINT VersionInfo::Data::m_flags

const CHAR* VersionInfo::Data::m_subsys_name

const CHAR* VersionInfo::Data::m_version_string

The documentation for this struct was generated from the following file:
  • Kernel/VersionInfo.hpp
Generated on Wed Jan 25 02:19:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VeryLongKeyPressMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VeryLongKeyPressMsg Class Reference

#include <Apoxi/Kernel/MsgTypes.hpp>

Inheritance diagram for VeryLongKeyPressMsg:

[legend]
Collaboration diagram for VeryLongKeyPressMsg:

[legend]

Public Types

enum | { ID = 203 }

Public Member Functions

virtual Message * | Clone () const
const KeyCode & | GetKeyCode () const
virtual const MsgMetaData & | GetMetaData () const
void | SetKeyCode (const KeyCode &key_code)
VeryLongKeyPressMsg (const KeyCode &key_code)
virtual | ~VeryLongKeyPressMsg ()

Detailed Description

This message is sent when for a very long key press event args[0].t_byte[0] ... contains the key code of the key

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VeryLongKeyPressMsg::VeryLongKeyPressMsg ( const KeyCode & key_code )

VeryLongKeyPressMsg::~VeryLongKeyPressMsg ( ) [virtual]

Member Function Documentation

Message * VeryLongKeyPressMsg::Clone ( ) const [virtual]

Implements Message.

const KeyCode& VeryLongKeyPressMsg::GetKeyCode ( ) const [inline]

const MsgMetaData & VeryLongKeyPressMsg::GetMetaData ( ) const [virtual]

Implements Message.

void VeryLongKeyPressMsg::SetKeyCode ( const KeyCode & key_code ) [inline]

The documentation for this class was generated from the following files:
  • Kernel/MsgTypes.hpp
  • Kernel/MsgTypes.cpp
Generated on Wed Jan 25 02:19:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VibratorDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VibratorDevice Class Reference
[Devices]

#include <Apoxi/Devices/VibratorDevice.hpp>

Inheritance diagram for VibratorDevice:

[legend]
Collaboration diagram for VibratorDevice:

[legend]

Public Types

enum VibratorMode {
Vibrator_Sync_Control, Vibrator_Async_1, Vibrator_Async_2, Vibrator_Async_3,
Vibrator_Async_4, Vibrator_Async_5, Vibrator_Async_6
}

Public Member Functions

BOOLEAN | IsVibratorOn ()
BOOLEAN | StartVibrator (VibratorMode mode=Vibrator_Async_1, UINT16 channel=0)
void | StopVibrator ()

Static Public Member Functions

static VibratorDevice & | GetInstance ()

Static Protected Member Functions

static void | OnTimer (void *data)

Protected Attributes

BOOLEAN | m_active
BOOLEAN | m_on
UINT16 | m_PeriodTime

Static Protected Attributes

static VibratorDevice | m_instance

Detailed Description

VibratorDevice is a simple class for controlling the vibrator. It is a singleton - use GetInstance(). Use StartVibrator() to start a vibrator and StopVibrator() to stop it

Member Enumeration Documentation

enum VibratorDevice::VibratorMode

Operating mode of vibrator. Tells which mode the vibrator should be working in.

Enumerator:
Vibrator_Sync_Control | not yet supported
Vibrator_Async_1 | 440ms on, 440ms off
Vibrator_Async_2 | 500ms on, 500ms off
Vibrator_Async_3 | 660ms on, 660ms off
Vibrator_Async_4 | 1second on, 1second off
Vibrator_Async_5 | 2seconds on, 2seconds off
Vibrator_Async_6 | constantly on

Member Function Documentation

VibratorDevice & VibratorDevice::GetInstance ( ) [static]

BOOLEAN VibratorDevice::IsVibratorOn ( )

Returns:
status of Vibrator (on or off)

void VibratorDevice::OnTimer ( void * data ) [static, protected]

Reimplemented from SystemTimer.

BOOLEAN VibratorDevice::StartVibrator | ( | VibratorMode | mode = Vibrator_Async_1,
 |  | UINT16 | channel = 0
 | ) |

Start the Vibrator

Returns:
TRUE is successful

void VibratorDevice::StopVibrator ( )

Stop the Vibrator

Returns:
TRUE is successful

Field Documentation

BOOLEAN VibratorDevice::m_active [protected]

Reimplemented from SystemTimer.

VibratorDevice VibratorDevice::m_instance [static, protected]

BOOLEAN VibratorDevice::m_on [protected]

UINT16 VibratorDevice::m_PeriodTime [protected]

The documentation for this class was generated from the following files:
  • Devices/VibratorDevice.hpp
  • Devices/VibratorDevice.cpp
Generated on Wed Jan 25 02:19:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VideoCamera Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VideoCamera Class Reference
[Devices, Devices, Devices, Devices, Devices, Devices]

#include <Apoxi/Devices/BP30/VideoCamera.hpp>

Inheritance diagram for VideoCamera:

[legend]
Collaboration diagram for VideoCamera:

[legend]

Public Types

enum | BufferLocation { HostLocation, CompanionLocation }
typedef void(* | Cb_FrameCaptured )(INT ret, void *context, UINT8 HUGE *buf, UINT32 size, UINT32 stamp)
typedef void(* | Cb_NotifyCaptureBufferStatus )(void *context, UINT8 free_buffer_count)
typedef void(* | Cb_VideoCapturePaused )(INT ret, void *context)
typedef void(* | Cb_VideoCaptureStopped )(INT ret, void *context)
enum FrameRateType {
Fps3_7_5 = 0, Fps5, Fps7_5, Fps10,
Fps12, Fps15, Fps24, Fps25,
Fps30, EndOfFpsType
}

Public Member Functions

BOOLEAN | AllocateCaptureBuffers (UINT8 &buf_count, UINT32 buf_len=0)
virtual BOOLEAN | Close ()
BOOLEAN | FreeCaptureBuffers ()
FrameRateType | GetFrameRate () const
virtual const WCHAR * | GetName () const
BOOLEAN | GetSupportedFrameRates (const FrameRateType *&array, UINT8 &count) const
virtual BOOLEAN | GetSupportedImageSizes (const ImageSizeType *&array, UINT8 &count) const
virtual BOOLEAN | Open ()
BOOLEAN | PauseVideoCapture (Cb_VideoCapturePaused cb_video_capture_paused=0, void *context=0)
BOOLEAN | ReleaseCaptureBuffer (UINT8 HUGE *buf)
virtual BOOLEAN | SetCaptureImageSize (ImageSizeType capture_image_size, TransformationType capture_transformation=Camera::NoTransformation)
BOOLEAN | SetFrameRate (FrameRateType frame_rate)
virtual BOOLEAN | SetViewfinderRect (Rect &vf_rect, INT display_idx=0, TransformationType view_transformation=NoTransformation, ScalingMethodType view_scaling_method=NoScaling)
virtual BOOLEAN | SetZoom (ActionType action, UINT8 step_size=1)
BOOLEAN | StartVideoCapture (void *context, Cb_FrameCaptured cb_frame_captured, Cb_NotifyCaptureBufferStatus cb_notify_captbuf_status, UINT32 starting_time=0)
virtual BOOLEAN | StartViewfinder ()
BOOLEAN | StopVideoCapture (Cb_VideoCaptureStopped cb_video_capture_stopped=0, void *context=0)
virtual BOOLEAN | StopViewfinder ()
BOOLEAN | UnPauseVideoCapture (UINT32 new_video_capture_clock_time)
VideoCamera (INT device_id)
virtual | ~VideoCamera ()

Friends

class | CameraConfig

Detailed Description

Class for adding Video capturing functionality to Camera.

Member Typedef Documentation

typedef void(* VideoCamera::Cb_FrameCaptured)(INT ret, void *context, UINT8 HUGE *buf, UINT32 size, UINT32 stamp)

Callback function Cb_FrameCaptured is called when a frame is completely stored in the buffer.

Parameters:
ret | ReturnCode of the driver layer
context | The context to which this callback belongs.
buf | currently used buffer to help keeping track of buffers in use
size | size of data stored in buffer
frame_count | number of current frame

typedef void(* VideoCamera::Cb_NotifyCaptureBufferStatus)(void *context, UINT8 free_buffer_count)

Callback function Cb_NotifyCaptureBufferStatus is called when the buffer status is checked.

Parameters:
context | The context to which this callback belongs.
free_buffer_count | The number of free buffers.

typedef void(* VideoCamera::Cb_VideoCapturePaused)(INT ret, void *context)

Callback function Cb_VideoCapturePaused is called when video capture has been paused.

Parameters:
ret | ReturnCode of the driver layer
context | The context to which this callback belongs.

typedef void(* VideoCamera::Cb_VideoCaptureStopped)(INT ret, void *context)

Callback function Cb_VideoCaptureStopped is called when video capture has been stopped.

Parameters:
ret | ReturnCode of the driver layer
context | The context to which this callback belongs.

Member Enumeration Documentation

enum VideoCamera::BufferLocation

Buffer location.

Enumerator:
HostLocation
CompanionLocation

enum VideoCamera::FrameRateType

FrameRate selection

Enumerator:
Fps3_7_5
Fps5
Fps7_5
Fps10
Fps12
Fps15
Fps24
Fps25
Fps30
EndOfFpsType

Constructor & Destructor Documentation

VideoCamera::VideoCamera ( INT device_id )

Parameters:
device_id Camera hardware ID

VideoCamera::~VideoCamera ( ) [virtual]

Destructor

Member Function Documentation

BOOLEAN VideoCamera::AllocateCaptureBuffers | ( | UINT8 & | buf_count,
 |  | UINT32 | buf_len = 0
 | ) |

Allocates buffers for encoded video frames with given buffer count.

Parameters:
buf_count | IN: Number of buffers to be allocated, OUT: Number of allocated buffers. NOTE: There will be no check if number of allocated buffers are identical to requested ones. So this out parameter can be ignored.
buf_len | Requested size of buffers. Parameter will be usually ignored. Therefore it can be omitted.
Returns:
Returns TRUE if allocation was successful, FALSE if not. Check last error for a detailed error code.

BOOLEAN VideoCamera::Close ( ) [virtual]

Close() frees any allocated buffers for capturing and unlocks the camera.

Returns:
returns FALSE if unlocking or buffer deallocation fails.

Reimplemented from Camera.

BOOLEAN VideoCamera::FreeCaptureBuffers ( )

Frees allocated resources such as allocated buffers in case of buffer allocation done by device layer

Returns:
returns TRUE if releasing capture buffers was successful.

const WCHAR * VideoCamera::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

BOOLEAN VideoCamera::GetSupportedFrameRates | ( | const FrameRateType *& | array,
 |  | UINT8 & | count
 | ) | const

Returns an array of available frame rates which are supported by the video camera.

Parameters:
array | array of possible frame rates
count | delivers the number of frame rates

virtual BOOLEAN VideoCamera::GetSupportedImageSizes | ( | const ImageSizeType *& | array,
 |  | UINT8 & | count
 | ) | const [virtual]

Get an array of supported sizes for images.

Parameters:
array | A reference to the array containing the list of supported image sizes.
count | The number of image size contained in the array.
Returns:
TRUE when image size list was created, otherwise FALSE.

BOOLEAN VideoCamera::Open ( ) [virtual]

Open() sets default values for the VideoCamera which are available through a CameraConfig or by driver. Furthermore it trys to Lock the Camera for exclusive usage.

Returns:
returns FALSE, if setting values or locking failed.

Reimplemented from Camera.

BOOLEAN VideoCamera::PauseVideoCapture | ( | Cb_VideoCapturePaused | cb_video_capture_paused = 0,
 |  | void * | context = 0
 | ) |

Pauses video capturing. Applicable only when video capturing is started.

Parameters:
cb_video_capture_paused | Application callback for video capture paused.
context | Context pointer of caller application.
Returns:
Returns TRUE if pausing was successfully, otherwise FALSE.

BOOLEAN VideoCamera::ReleaseCaptureBuffer ( UINT8 HUGE * buf )

ReleaseCaptureBuffer marks the given buffer as being unused.

Parameters:
buf The pointer to the buffer to release.
Returns:
TRUE, if release was successful. Otherwise FALSE.

virtual BOOLEAN VideoCamera::SetCaptureImageSize | ( | ImageSizeType | capture_image_size,
 |  | TransformationType | capture_transformation = Camera::NoTransformation
 | ) | [virtual]

Sets the capture image size for snapshots and video capturing.

Parameters:
capture_image_size | predefined image size for captured image.
capture_transformation | capture image transformation.
Returns:
returns TRUE if given size is possible.

BOOLEAN VideoCamera::SetFrameRate ( FrameRateType frame_rate )

Sets the frame rate for capturing video. This method can be used in before viewfinder is started, during viewfinding and during capturing. The call is optional. Default framerate is 15 fps. This method does not check if twilight mode is enabled. It applies for twilight mode off.

Parameters:
frame_rate Frame rate which will be used for capturing.
Returns:
Returns TRUE if framerate is supported and could be set. Otherwise FALSE. When it returns FALSE check camera error for a detailed reason. The reason can be CameraNotReadyError when GDD does not accept the set framerate or UnsupportedFrameRateError when framerate is not in the list of supported framerates (see GetSupportedFrameRates).

BOOLEAN VideoCamera::SetViewfinderRect | ( | Rect & | vf_rect,
 |  | INT | display_idx = 0,
 |  | TransformationType | view_transformation = NoTransformation,
 |  | ScalingMethodType | view_scaling_method = NoScaling
 | ) | [virtual]

Sets the rectangle, display, orientation and scaling of the camera viewfinder.

Parameters:
vf_rect | Rectangle which describes the viewfinder (in and out parameter)
diplay_idx | Index of display where viewfinder should be drawn at, default is main display
view_transformation | Desired orientation of the viewfinder, default is normal orientation.
view_scaling_method | Desirted scaling method, default is no scaling.
Returns:
Returns TRUE if viewfinder size, position and orientation is valid.

virtual BOOLEAN VideoCamera::SetZoom | ( | ActionType | action,
 |  | UINT8 | step_size = 1
 | ) | [virtual]

Sets the zoom factor for the viewfinder

Parameters:
action | defines which zooming action should be performed. Decrease - decreases zoom level Increase - increases zoom level Reset - resets zoom level to default value
step_size | Step changes the interval on the performed action
Returns:
returns TRUE if zooming was successful

BOOLEAN VideoCamera::StartVideoCapture | ( | void * | context,
 |  | Cb_FrameCaptured | cb_frame_captured,
 |  | Cb_NotifyCaptureBufferStatus | cb_notify_captbuf_status,
 |  | UINT32 | starting_time = 0
 | ) |

Starts the video capturing after setting Video Properties, Viewfinder rect and ImageFormat.

Parameters:
context | Context pointer of caller application.
cb_frame_captured | Application callback for captured frame
cb_notify_captbuf_status | Application callback for notifying the current status of free buffer count
Returns:
returns TRUE if capturing started successfully, FALSE if not

BOOLEAN VideoCamera::StartViewfinder ( ) [virtual]

StartViewfinder() enables the viewfinder on the display and sets the camera into active mode.

Returns:
returns FALSE if viewfinder can not be started due to missing preconditions or a hardware failure.

Reimplemented from Camera.

BOOLEAN VideoCamera::StopVideoCapture | ( | Cb_VideoCaptureStopped | cb_video_capture_stopped = 0,
 |  | void * | context = 0
 | ) |

Stops video capturing.

Parameters:
cb_video_capture_stopped | Application callback for video capture stopped.
context | Context pointer of caller application.
Returns:
Returns TRUE if stopping was successfully, FALSE if not. Check last error code when FALSE is returned!

BOOLEAN VideoCamera::StopViewfinder ( ) [virtual]

StopViewFinder() stops the viewfinder and shuts down the camera.

Returns:
returns FALSE if an hardware error occurred.

Reimplemented from Camera.

BOOLEAN VideoCamera::UnPauseVideoCapture ( UINT32 new_video_capture_clock_time )

Unpauses video capturing. Applicable only when video capturing is paused.

Parameters:
new_video_capture_clock_time E.g. time stamp of last catured/encoded frame.
Returns:
Returns TRUE if unpausing was successfully, otherwise FALSE.

Friends And Related Function Documentation

CameraConfig [friend]

The documentation for this class was generated from the following files:
  • Devices/BP30/VideoCamera.hpp
  • Devices/MPE/VideoCamera.hpp
  • Devices/MPEU/Extensions/AtiW2282/VideoCamera.hpp
  • Devices/MPEU/VideoCamera.hpp
  • Devices/SGold/VideoCamera.hpp
  • Devices/VideoCameraInterface.hpp
  • Devices/Win32/VideoCamera.hpp
  • Devices/BP30/VideoCamera.cpp
  • Devices/MPE/VideoCamera.cpp
  • Devices/MPEU/Extensions/AtiW2282/VideoCamera.cpp
  • Devices/MPEU/VideoCamera.cpp
  • Devices/SGold/Companion/Epson716/VideoCamera.cpp
  • Devices/SGold/Companion/Scicos3020/VideoCamera.cpp
  • Devices/SGold/VideoCamera.cpp
  • Devices/Win32/VideoCamera.cpp
Generated on Wed Jan 25 02:19:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VideoCaptureParameters Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VideoCaptureParameters Class Reference

#include <Apoxi/AddOns/MediaFramework/VideoCaptureParameters.hpp>

Collaboration diagram for VideoCaptureParameters:

[legend]

Public Member Functions

virtual UINT16 | GetMaxBitrate () const
virtual UINT32 | GetMaxDuration () const
virtual void | GetMaxFramerate (UINT16 &max_frame_rate_numerator, UINT16 &max_frame_rate_denominator) const
virtual UINT32 | GetMaxMediaLength () const
virtual Size | GetMaxResolution () const
virtual MimeType | GetPrefMimeType () const
virtual BOOLEAN | IsAudioEnabled () const
VideoCaptureParameters (Size max_resolution=0, UINT16 max_frame_rate_numerator=0, UINT16 max_frame_rate_denominator=0, UINT16 max_bit_rate=0, UINT32 max_duration=0, UINT32 max_media_length=0, BOOLEAN audio_flag=TRUE, MimeType pref_mime_type=c_mime_unknown)
virtual | ~VideoCaptureParameters ()

Constructor & Destructor Documentation

VideoCaptureParameters::VideoCaptureParameters | ( | Size | max_resolution = 0,
 |  | UINT16 | max_frame_rate_numerator = 0,
 |  | UINT16 | max_frame_rate_denominator = 0,
 |  | UINT16 | max_bit_rate = 0,
 |  | UINT32 | max_duration = 0,
 |  | UINT32 | max_media_length = 0,
 |  | BOOLEAN | audio_flag = TRUE,
 |  | MimeType | pref_mime_type = c_mime_unknown
 | ) |

VideoCaptureParameters::~VideoCaptureParameters ( ) [virtual]

Member Function Documentation

UINT16 VideoCaptureParameters::GetMaxBitrate ( ) const [virtual]

UINT32 VideoCaptureParameters::GetMaxDuration ( ) const [virtual]

void VideoCaptureParameters::GetMaxFramerate | ( | UINT16 & | max_frame_rate_numerator,
 |  | UINT16 & | max_frame_rate_denominator
 | ) | const [virtual]

UINT32 VideoCaptureParameters::GetMaxMediaLength ( ) const [virtual]

Size VideoCaptureParameters::GetMaxResolution ( ) const [virtual]

MimeType VideoCaptureParameters::GetPrefMimeType ( ) const [virtual]

BOOLEAN VideoCaptureParameters::IsAudioEnabled ( ) const [virtual]

The documentation for this class was generated from the following files:
  • AddOns/MediaFramework/VideoCaptureParameters.hpp
  • AddOns/MediaFramework/MMfrInterfaceImpl/VideoCaptureParameters.cpp
Generated on Wed Jan 25 02:19:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VideoChannel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VideoChannel Class Reference
[Devices, Devices, Devices, Devices, Devices, Devices]

#include <Apoxi/Devices/BP30/VideoChannel.hpp>

Collaboration diagram for VideoChannel:

[legend]

Public Types

typedef void(* | CbResult )(BOOLEAN result, void *context)
typedef void(* | CbResult )(BOOLEAN result, void *context)
typedef void(* | CbResult )(BOOLEAN result, void *context)
typedef void(* | CbResult )(BOOLEAN result, void *context)
typedef void(* | CbResult )(BOOLEAN result, void *context)
typedef void(* | CbVideoFrameRendered )(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)
typedef void(* | CbVideoFrameRendered )(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)
typedef void(* | CbVideoFrameRendered )(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)
typedef void(* | CbVideoFrameRendered )(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)
typedef void(* | CbVideoFrameRendered )(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)
enum | ScalingMethodType { NoScaling, LetterboxScaling, BestFitScaling }
enum | ScalingMethodType { NoScaling, LetterboxScaling, BestFitScaling }
enum | ScalingMethodType { NoScaling, LetterboxScaling, BestFitScaling }
enum | ScalingMethodType { NoScaling, LetterboxScaling, BestFitScaling }
enum | ScalingMethodType { NoScaling, LetterboxScaling, BestFitScaling }
enum TransformationType {
NoTransformation, Rotation90Transformation, Rotation180Transformation, Rotation270Transformation,
MirrorTransformation, MirrorRotate90Transformation, MirrorRotate180Transformation, MirrorRotate270Transformation
}
enum TransformationType {
NoTransformation, Rotation90Transformation, Rotation180Transformation, Rotation270Transformation,
MirrorTransformation, MirrorRotate90Transformation, MirrorRotate180Transformation, MirrorRotate270Transformation
}
enum TransformationType {
NoTransformation, Rotation90Transformation, Rotation180Transformation, Rotation270Transformation,
MirrorTransformation, MirrorRotate90Transformation, MirrorRotate180Transformation, MirrorRotate270Transformation
}
enum TransformationType {
NoTransformation, Rotation90Transformation, Rotation180Transformation, Rotation270Transformation,
MirrorTransformation, MirrorRotate90Transformation, MirrorRotate180Transformation, MirrorRotate270Transformation
}
enum TransformationType {
NoTransformation, Rotation90Transformation, Rotation180Transformation, Rotation270Transformation,
MirrorTransformation, MirrorRotate90Transformation, MirrorRotate180Transformation, MirrorRotate270Transformation
}
enum | VideoAndViewfinderOrderType { ViewfinderOverVideoPlayback, VideoPlaybackOverViewfinder }
enum | VideoAndViewfinderOrderType { ViewfinderOverVideoPlayback, VideoPlaybackOverViewfinder }
enum | VideoAndViewfinderOrderType { ViewfinderOverVideoPlayback, VideoPlaybackOverViewfinder }
enum | VideoAndViewfinderOrderType { ViewfinderOverVideoPlayback, VideoPlaybackOverViewfinder }
enum | VideoAndViewfinderOrderType { ViewfinderOverVideoPlayback, VideoPlaybackOverViewfinder }
enum VideoParameterType {
Rotate, Mirror, Flip, Antitearing,
SmartOverlay, ZoomFactorMin, ZoomFactorMax
}

Public Member Functions

void | Close ()
void | Close ()
void | Close ()
void | Close ()
void | Close ()
void | Close ()
BOOLEAN | GetParam (VideoParameterType type, UINT32 *value) const
UINT32 | GetRefreshDelay () const
UINT32 | GetRefreshDelay () const
UINT32 | GetRefreshDelay () const
UINT32 | GetRefreshDelay () const
UINT32 | GetRefreshDelay () const
UINT32 | GetRefreshDelay () const
BOOLEAN | IsOpen () const
BOOLEAN | IsOpen () const
BOOLEAN | IsOpen () const
BOOLEAN | IsOpen () const
BOOLEAN | IsOpen () const
BOOLEAN | IsOpen () const
BOOLEAN | Open (CbVideoFrameRendered cb_frame_rendered, void *context)
BOOLEAN | Open (Rect &video_frame_rect, void(*CbVideoFrameRendered)(), void *context=0)
BOOLEAN | Open (CbVideoFrameRendered cb_frame_rendered, void *context)
BOOLEAN | Open (CbVideoFrameRendered cb_frame_rendered, void *context)
BOOLEAN | Open (CbVideoFrameRendered cb_frame_rendered, void *context)
BOOLEAN | Open (CbVideoFrameRendered cb_frame_rendered, void *context)
BOOLEAN | QueryRects (Rect &video_frame_rect, Rect &crop_rect)
void | RenderFrame (void *frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame=FALSE)
void | RenderFrame (void *frame_buffer, UINT32 length, UINT32 frame_id, BOOLEAN auto_skip_frame=FALSE)
void | RenderFrame (void *frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame=FALSE)
void | RenderFrame (void *frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame=FALSE)
void | RenderFrame (void *frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame=FALSE)
void | RenderFrame (void *frame_buf, UINT32 length, UINT32 timestamp, BOOLEAN auto_release_frame=FALSE)
BOOLEAN | SetCropRect (Rect &crop_rect, Rect &effective_playback_rect)
BOOLEAN | SetCropRect (Rect &crop_rect)
BOOLEAN | SetCropRect (Rect &crop_rect, Rect &effective_playback_rect)
BOOLEAN | SetCropRect (Rect &crop_rect, Rect &effective_playback_rect)
BOOLEAN | SetCropRect (Rect &crop_rect, Rect &effective_playback_rect)
BOOLEAN | SetCropRect (Rect &crop_rect, Rect &effective_playback_rect)
BOOLEAN | SetFrameRect (Rect &video_frame_rect)
BOOLEAN | SetParam (VideoParameterType type, UINT32 value)
BOOLEAN | SetPlaybackAndViewfinderOrder (VideoAndViewfinderOrderType video_viewfinder_order)
BOOLEAN | SetPlaybackAndViewfinderOrder (VideoAndViewfinderOrderType video_viewfinder_order)
BOOLEAN | SetPlaybackAndViewfinderOrder (VideoAndViewfinderOrderType video_viewfinder_order)
BOOLEAN | SetPlaybackAndViewfinderOrder (VideoAndViewfinderOrderType video_viewfinder_order)
BOOLEAN | SetPlaybackAndViewfinderOrder (VideoAndViewfinderOrderType video_viewfinder_order)
BOOLEAN | SetPlaybackRect (Rect &playback_rect, TransformationType playback_transformation, ScalingMethodType scaling_method)
BOOLEAN | SetPlaybackRect (Rect &playback_rect, TransformationType playback_transformation, ScalingMethodType scaling_method)
BOOLEAN | SetPlaybackRect (Rect &playback_rect, TransformationType playback_transformation, ScalingMethodType scaling_method)
BOOLEAN | SetPlaybackRect (Rect &playback_rect, TransformationType playback_transformation, ScalingMethodType scaling_method)
BOOLEAN | SetPlaybackRect (Rect &playback_rect, TransformationType playback_transformation, ScalingMethodType scaling_method)
BOOLEAN | SetVideoSize (Size actual_video_size, Size extended_video_size, Point left_top_offset)
void | SetVideoSize (Size video_size)
BOOLEAN | SetVideoSize (Size actual_video_size, Size extended_video_size, Point left_top_offset)
BOOLEAN | SetVideoSize (Size actual_video_size, Size extended_video_size, Point left_top_offset)
BOOLEAN | SetVideoSize (Size actual_video_size, Size extended_video_size, Point left_top_offset)
BOOLEAN | SetVideoSize (Size actual_video_size, Size extended_video_size, Point left_top_offset)
BOOLEAN | Start (CbResult cb_video_channel_started, void *context)
BOOLEAN | Start (CbResult cb_video_channel_started, void *context)
BOOLEAN | Start (CbResult cb_video_channel_started, void *context)
BOOLEAN | Start (CbResult cb_video_channel_started, void *context)
BOOLEAN | Start (CbResult cb_video_channel_started, void *context)
BOOLEAN | Stop (CbResult cb_video_channel_stopped, void *context)
BOOLEAN | Stop (CbResult cb_video_channel_stopped, void *context)
BOOLEAN | Stop (CbResult cb_video_channel_stopped, void *context)
BOOLEAN | Stop (CbResult cb_video_channel_stopped, void *context)
BOOLEAN | Stop (CbResult cb_video_channel_stopped, void *context)
VideoChannel (INT display_idx=0)
VideoChannel (INT display_idx=0)
VideoChannel (INT display_idx=0)
VideoChannel (UINT8 display_idx)
VideoChannel ()
VideoChannel (INT display_idx=0)
VideoChannel (INT display_idx=0)
~VideoChannel ()
~VideoChannel ()
~VideoChannel ()
~VideoChannel ()
~VideoChannel ()
~VideoChannel ()

Data Structures

struct | StateFlags
struct | StateFlags
struct | StateFlags
struct | StateFlags

Detailed Description

The video channel is part of the display device and can be retrieved by invoking Display::GetVideoChannel. It is generally assumed that the content to be displayed via this channel is located in a separate buffer (or certain number of buffers), the process of transfering this content to the display is is called rendering and is typically assisted by hardware (e. g. a companion chip). Rendering includes some transformation like color conversion, resizing, rotation, flipping/mirroring, clipping/cropping. Most crucial for rendering is the correct mixing of the content in this channel with the display content. This is operation is called overlaying.

Member Typedef Documentation

typedef void(* VideoChannel::CbResult)(BOOLEAN result, void *context)

Callback function that is invoked by the VideoChannel when the corresponding asynchronous operation has been finished.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when the corresponding function has been invoked.
See also:
Start

Stop

typedef void(* VideoChannel::CbResult)(BOOLEAN result, void *context)

Callback function that is invoked by the VideoChannel when the corresponding asynchronous operation has been finished.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when the corresponding function has been invoked.
See also:
Start

Stop

typedef void(* VideoChannel::CbResult)(BOOLEAN result, void *context)

Callback function that is invoked by the VideoChannel when the corresponding asynchronous operation has been finished.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when the corresponding function has been invoked.
See also:
Start

Stop

typedef void(* VideoChannel::CbResult)(BOOLEAN result, void *context)

Callback function that is invoked by the VideoChannel when the corresponding asynchronous operation has been finished.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when the corresponding function has been invoked.
See also:
Start

Stop

typedef void(* VideoChannel::CbResult)(BOOLEAN result, void *context)

Callback function that is invoked by the VideoChannel when the corresponding asynchronous operation has been finished.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when the corresponding function has been invoked.
See also:
Start

Stop

typedef void(* VideoChannel::CbVideoFrameRendered)(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)

Callback function that is invoked by the VideoChannel when a frame has been rendered.

Parameters:
result | TRUE if the operation was succesful. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when VideoChannel::Open has been invoked.
frame_buf | Pointer to the video frame buffer that has been rendered.
See also:
RenderFrame

typedef void(* VideoChannel::CbVideoFrameRendered)(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)

Callback function that is invoked by the VideoChannel when a frame has been rendered.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when VideoChannel::Open has been invoked.
frame_buf | Pointer to the video frame buffer that has been rendered.
See also:
RenderFrame

typedef void(* VideoChannel::CbVideoFrameRendered)(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)

Callback function that is invoked by the VideoChannel when a frame has been rendered.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when VideoChannel::Open has been invoked.
frame_buf | Pointer to the video frame buffer that has been rendered.
See also:
RenderFrame

typedef void(* VideoChannel::CbVideoFrameRendered)(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)

Callback function that is invoked by the VideoChannel when a frame has been rendered.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when VideoChannel::Open has been invoked.
frame_buf | Pointer to the video frame buffer that has been rendered.
See also:
RenderFrame

typedef void(* VideoChannel::CbVideoFrameRendered)(BOOLEAN result, void *context, const UINT8 HUGE *frame_buf)

Callback function that is invoked by the VideoChannel when a frame has been rendered.

Parameters:
result | TRUE if the operation was succesfull. Otherwise, FALSE.
context | A context (e.g. this pointer) that has been passed to the VideoChannel object when VideoChannel::Open has been invoked.
frame_buf | Pointer to the video frame buffer that has been rendered.
See also:
RenderFrame

Member Enumeration Documentation

enum VideoChannel::ScalingMethodType

Enumerator:
NoScaling
LetterboxScaling
BestFitScaling

enum VideoChannel::ScalingMethodType

Enumerator:
NoScaling
LetterboxScaling
BestFitScaling

enum VideoChannel::ScalingMethodType

Enumerator:
NoScaling
LetterboxScaling
BestFitScaling

enum VideoChannel::ScalingMethodType

Enumerator:
NoScaling
LetterboxScaling
BestFitScaling

enum VideoChannel::ScalingMethodType

Enumerator:
NoScaling
LetterboxScaling
BestFitScaling

enum VideoChannel::TransformationType

Transformation type. Note: Rotation is counter clockwise.

Enumerator:
NoTransformation
Rotation90Transformation
Rotation180Transformation
Rotation270Transformation
MirrorTransformation
MirrorRotate90Transformation
MirrorRotate180Transformation
MirrorRotate270Transformation

enum VideoChannel::TransformationType

Transformation type. Note: Rotation is counter clockwise.

Enumerator:
NoTransformation
Rotation90Transformation
Rotation180Transformation
Rotation270Transformation
MirrorTransformation
MirrorRotate90Transformation
MirrorRotate180Transformation
MirrorRotate270Transformation

enum VideoChannel::TransformationType

Transformation type. Note: Rotation is counter clockwise.

Enumerator:
NoTransformation
Rotation90Transformation
Rotation180Transformation
Rotation270Transformation
MirrorTransformation
MirrorRotate90Transformation
MirrorRotate180Transformation
MirrorRotate270Transformation

enum VideoChannel::TransformationType

Transformation type. Note: Rotation is counter clockwise.

Enumerator:
NoTransformation
Rotation90Transformation
Rotation180Transformation
Rotation270Transformation
MirrorTransformation
MirrorRotate90Transformation
MirrorRotate180Transformation
MirrorRotate270Transformation

enum VideoChannel::TransformationType

Transformation type. Note: Rotation is counter clockwise.

Enumerator:
NoTransformation
Rotation90Transformation
Rotation180Transformation
Rotation270Transformation
MirrorTransformation
MirrorRotate90Transformation
MirrorRotate180Transformation
MirrorRotate270Transformation

enum VideoChannel::VideoAndViewfinderOrderType

Enumerator:
ViewfinderOverVideoPlayback
VideoPlaybackOverViewfinder

enum VideoChannel::VideoAndViewfinderOrderType

Enumerator:
ViewfinderOverVideoPlayback
VideoPlaybackOverViewfinder

enum VideoChannel::VideoAndViewfinderOrderType

Enumerator:
ViewfinderOverVideoPlayback
VideoPlaybackOverViewfinder

enum VideoChannel::VideoAndViewfinderOrderType

Enumerator:
ViewfinderOverVideoPlayback
VideoPlaybackOverViewfinder

enum VideoChannel::VideoAndViewfinderOrderType

Enumerator:
ViewfinderOverVideoPlayback
VideoPlaybackOverViewfinder

enum VideoChannel::VideoParameterType

Defines the types of available video parameters. The values can be set by VideoChannel::SetParam

Enumerator:
Rotate
Mirror
Flip
Antitearing
SmartOverlay
ZoomFactorMin
ZoomFactorMax

Constructor & Destructor Documentation

VideoChannel::VideoChannel ( INT display_idx = 0 )

Parameters:
display_idx Index of the display where the video channel is attached. Per default the video channel is attached to the display with the index 0, which usually represents the main display.

VideoChannel::~VideoChannel ( )

VideoChannel::VideoChannel ( INT display_idx = 0 )

Parameters:
display_idx Index of the display where the video channel is attached. Per default the video channel is attached to the display with the index 0, which usually represents the main display.

VideoChannel::~VideoChannel ( )

VideoChannel::VideoChannel ( )

VideoChannel::VideoChannel ( UINT8 display_idx )

VideoChannel::~VideoChannel ( )

VideoChannel::VideoChannel ( INT display_idx = 0 )

Parameters:
display_idx Index of the display where the video channel is attached. Per default the video channel is attached to the display with the index 0, which usually represents the main display.

VideoChannel::~VideoChannel ( )

VideoChannel::VideoChannel ( INT display_idx = 0 )

Parameters:
display_idx Index of the display where the video channel is attached. Per default the video channel is attached to the display with the index 0, which usually represents the main display.

VideoChannel::~VideoChannel ( )

VideoChannel::VideoChannel ( INT display_idx = 0 )

Parameters:
display_idx Index of the display where the video channel is attached. Per default the video channel is attached to the display with the index 0, which usually represents the main display.

VideoChannel::~VideoChannel ( )

Member Function Documentation

void VideoChannel::Close ( )

Closes the video channel which has been opened by VideoChannel::Open.

void VideoChannel::Close ( )

Closes the video channel which has been opened by VideoChannel::Open.

void VideoChannel::Close ( )

Closes the video channel which has been opened by VideoChannel::Open.

void VideoChannel::Close ( )

Closes the video channel which has been opened by VideoChannel::Open.

void VideoChannel::Close ( )

Closes the video channel which has been opened by VideoChannel::Open.

void VideoChannel::Close ( )

Closes the video channel which has been opened by VideoChannel::Open.

BOOLEAN VideoChannel::GetParam | ( | VideoParameterType | type,
 |  | UINT32 * | value
 | ) | const

Reads out parameters of the rendering path and transformation blocks. Parameters are set with the complementary function VideoChannel::SetVideoParam.

Parameters:
type | [IN] Type of the parameter to be configured.
value | [OUT] Current value of the parameter.
Returns:
TRUE if the setting of the parameter was successful.

UINT32 VideoChannel::GetRefreshDelay ( ) const

Returns the estimated time needed for the HW to update the display after calling e.g. RenderFrame()

Returns:
Returns the estimated delay in milliseconds

UINT32 VideoChannel::GetRefreshDelay ( ) const

Returns the estimated delay in milliseconds for refreshing the display content.

UINT32 VideoChannel::GetRefreshDelay ( ) const

Returns the estimated time needed for the HW to update the display after calling e.g. RenderFrame()

Returns:
Returns the estimated delay in milliseconds

UINT32 VideoChannel::GetRefreshDelay ( ) const

Returns the estimated time needed for the HW to update the display after calling e.g. RenderFrame()

Returns:
Returns the estimated delay in milliseconds

UINT32 VideoChannel::GetRefreshDelay ( ) const

Returns the estimated time needed for the HW to update the display after calling e.g. RenderFrame()

Returns:
Returns the estimated delay in milliseconds

UINT32 VideoChannel::GetRefreshDelay ( ) const

Returns the estimated time needed for the HW to update the display after calling e.g. RenderFrame()

Returns:
Returns the estimated delay in milliseconds

BOOLEAN VideoChannel::IsOpen ( ) const

Checks if currently the video channel is open

Returns:
TRUE, if a video is shown currently on the display device. This information is useful for the APOXI windowing system.

BOOLEAN VideoChannel::IsOpen ( ) const

Returns:
TRUE, if a video is shown currently on the display device. This information is useful for the APOXI windowing system.

BOOLEAN VideoChannel::IsOpen ( ) const

Checks if currently the video channel is open

Returns:
TRUE, if a video is shown currently on the display device. This information is useful for the APOXI windowing system.

BOOLEAN VideoChannel::IsOpen ( ) const

Checks if currently the video channel is open

Returns:
TRUE, if a video is shown currently on the display device. This information is useful for the APOXI windowing system.

BOOLEAN VideoChannel::IsOpen ( ) const

Checks if currently the video channel is open

Returns:
TRUE, if a video is shown currently on the display device. This information is useful for the APOXI windowing system.

BOOLEAN VideoChannel::IsOpen ( ) const

Checks if currently the video channel is open

Returns:
TRUE, if a video is shown currently on the display device. This information is useful for the APOXI windowing system.

BOOLEAN VideoChannel::Open | ( | CbVideoFrameRendered | cb_frame_rendered,
 |  | void * | context
 | ) |

Opens the video channel and sets the bounding rectangle for the video frames, which will be used to display the video content set by VideoChannel::RenderFrame. VideoChannel::Close should be invoked when the no frames are rendered anymore.

Parameters:
cb_frame_rendered | [IN] Pointer to callback function which is called when the rendering of a frame has been completed (i. e. the frame is written to the display buffer, the transfer of frame from display buffer to LCD is not included).
context | Context (e.g. this pointer) of the calling application. This context will be passed in the callback function.
Returns:
TRUE if the video channel could be opened.
See also:
CbVideoFrameRendered

BOOLEAN VideoChannel::Open | ( | Rect & | video_frame_rect,
 |  | void(*)() | CbVideoFrameRendered,
 |  | void * | context = 0
 | ) |

Opens the video channel and sets the bounding rectangle for the video frames, which will be used to display the video content set by VideoChannel::RenderFrame. VideoChannel::Close should be invoked when the no frames are rendered anymore.

Parameters:
video_frame_rect | [IN/OUT] Position and size of area to be filled with video.
CbVideoFrameRendered | [IN] Pointer to callback function which is called when the rendering of a frame has been completed (i. e. the frame is written to the display buffer, the transfer of frame from display buffer to LCD is not included).
Returns:
TRUE if the video channel could be opened.

BOOLEAN VideoChannel::Open | ( | CbVideoFrameRendered | cb_frame_rendered,
 |  | void * | context
 | ) |

Opens the video channel and sets the bounding rectangle for the video frames, which will be used to display the video content set by VideoChannel::RenderFrame. VideoChannel::Close should be invoked when the no frames are rendered anymore.

Parameters:
cb_frame_rendered | [IN] Pointer to callback function which is called when the rendering of a frame has been completed (i. e. the frame is written to the display buffer, the transfer of frame from display buffer to LCD is not included).
context | Context (e.g. this pointer) of the calling application. This context will be passed in the callback function.
Returns:
TRUE if the video channel could be opened.
See also:
CbVideoFrameRendered

BOOLEAN VideoChannel::Open | ( | CbVideoFrameRendered | cb_frame_rendered,
 |  | void * | context
 | ) |

Opens the video channel and sets the bounding rectangle for the video frames, which will be used to display the video content set by VideoChannel::RenderFrame. VideoChannel::Close should be invoked when the no frames are rendered anymore.

Parameters:
cb_frame_rendered | [IN] Pointer to callback function which is called when the rendering of a frame has been completed (i. e. the frame is written to the display buffer, the transfer of frame from display buffer to LCD is not included).
context | Context (e.g. this pointer) of the calling application. This context will be passed in the callback function.
Returns:
TRUE if the video channel could be opened.
See also:
CbVideoFrameRendered

BOOLEAN VideoChannel::Open | ( | CbVideoFrameRendered | cb_frame_rendered,
 |  | void * | context
 | ) |

Opens the video channel and sets the bounding rectangle for the video frames, which will be used to display the video content set by VideoChannel::RenderFrame. VideoChannel::Close should be invoked when the no frames are rendered anymore.

Parameters:
cb_frame_rendered | [IN] Pointer to callback function which is called when the rendering of a frame has been completed (i. e. the frame is written to the display buffer, the transfer of frame from display buffer to LCD is not included).
context | Context (e.g. this pointer) of the calling application. This context will be passed in the callback function.
Returns:
TRUE if the video channel could be opened.
See also:
CbVideoFrameRendered

BOOLEAN VideoChannel::Open | ( | CbVideoFrameRendered | cb_frame_rendered,
 |  | void * | context
 | ) |

Opens the video channel and sets the bounding rectangle for the video frames, which will be used to display the video content set by VideoChannel::RenderFrame. VideoChannel::Close should be invoked when the no frames are rendered anymore.

Parameters:
cb_frame_rendered | [IN] Pointer to callback function which is called when the rendering of a frame has been completed (i. e. the frame is written to the display buffer, the transfer of frame from display buffer to LCD is not included).
context | Context (e.g. this pointer) of the calling application. This context will be passed in the callback function.
Returns:
TRUE if the video channel could be opened.
See also:
CbVideoFrameRendered

BOOLEAN VideoChannel::QueryRects | ( | Rect & | video_frame_rect,
 |  | Rect & | crop_rect
 | ) |

Reads out the capabilities of the underlying layers to fulfill a certain programming for the video rectangles. Constraints generally come in due to the utilized hardware blocks. Underlying layers try to achieve a best effort to reach the desired rectangles - if this cannot be achieved the nearest possible rectangles are returned. It is ensured, that these rectangles will never be larger. The returned rectangles can the be used in VideoChannel::SetCropRect and VideoChannel::AdjustFrameRect which guarantees that these functions will be successful.

Parameters:
video_frame_rect | [IN/OUT] Position and size of screen area to be filled with video.
crop_rect | [IN/OUT] Position and size of area to be cut out from the original video.
Returns:
TRUE if the setting of the parameter *would be* possible in the underlying hardware. If itwas not possible, FALSE is returned and the video frame rectangle and cropping rectangle contain the best effort of the hardware to fit the desired rectangles

void VideoChannel::RenderFrame | ( | void * | frame_buf,
 |  | UINT32 | length,
 |  | UINT32 | timestamp,
 |  | BOOLEAN | auto_release_frame = FALSE
 | ) |

Renders a video frame inside the video channel. The method VideoChannel::Open must be invoked first, the method VideoChannel::Close should be invoked after the last video frame has been rendered.

Parameters:
frame_buf | Pointer to the video frame buffer which will be mixed within the bounding rectangle specified by OpenVideoChannel.
length | Length of the video frame buffer in bytes.
timestamp | Index/timestamp of currently shown frame.
auto_release_frame | if FALSE, it keeps the current frame for repeated rendering, no automatic buffer release is performed (useful for paused video)

void VideoChannel::RenderFrame | ( | void * | frame_buffer,
 |  | UINT32 | length,
 |  | UINT32 | frame_id,
 |  | BOOLEAN | auto_skip_frame = FALSE
 | ) |

Renders a video frame inside the video channel. The method VideoChannel::Open must be invoked first, the method VideoChannel::Close should be invoked after the last video frame has been rendered.

Parameters:
frame_buffer | Pointer to the frame buffer which will be mixed within the bounding rectangle specified by DisplayChannel::Open.
length | Length of the video frame buffer in bytes.
frame_id | Index of currently shown frame.

void VideoChannel::RenderFrame | ( | void * | frame_buf,
 |  | UINT32 | length,
 |  | UINT32 | timestamp,
 |  | BOOLEAN | auto_release_frame = FALSE
 | ) |

Renders a video frame inside the video channel. The method VideoChannel::Open must be invoked first, the method VideoChannel::Close should be invoked after the last video frame has been rendered.

Parameters:
frame_buf | Pointer to the video frame buffer which will be mixed within the bounding rectangle specified by OpenVideoChannel.
length | Length of the video frame buffer in bytes.
timestamp | Index/timestamp of currently shown frame.
auto_release_frame | if FALSE, it keeps the current frame for repeated rendering, no automatic buffer release is performed (useful for paused video)

void VideoChannel::RenderFrame | ( | void * | frame_buf,
 |  | UINT32 | length,
 |  | UINT32 | timestamp,
 |  | BOOLEAN | auto_release_frame = FALSE
 | ) |

Renders a video frame inside the video channel. The method VideoChannel::Open must be invoked first, the method VideoChannel::Close should be invoked after the last video frame has been rendered.

Parameters:
frame_buf | Pointer to the video frame buffer which will be mixed within the bounding rectangle specified by OpenVideoChannel.
length | Length of the video frame buffer in bytes.
timestamp | Index/timestamp of currently shown frame.
auto_release_frame | if FALSE, it keeps the current frame for repeated rendering, no automatic buffer release is performed (useful for paused video)

void VideoChannel::RenderFrame | ( | void * | frame_buf,
 |  | UINT32 | length,
 |  | UINT32 | timestamp,
 |  | BOOLEAN | auto_release_frame = FALSE
 | ) |

Renders a video frame inside the video channel. The method VideoChannel::Open must be invoked first, the method VideoChannel::Close should be invoked after the last video frame has been rendered.

Parameters:
frame_buf | Pointer to the video frame buffer which will be mixed within the bounding rectangle specified by OpenVideoChannel.
length | Length of the video frame buffer in bytes.
timestamp | Index/timestamp of currently shown frame.
auto_release_frame | if FALSE, it keeps the current frame for repeated rendering, no automatic buffer release is performed (useful for paused video)

void VideoChannel::RenderFrame | ( | void * | frame_buf,
 |  | UINT32 | length,
 |  | UINT32 | timestamp,
 |  | BOOLEAN | auto_release_frame = FALSE
 | ) |

Renders a video frame inside the video channel. The method VideoChannel::Open must be invoked first, the method VideoChannel::Close should be invoked after the last video frame has been rendered.

Parameters:
frame_buf | Pointer to the video frame buffer which will be mixed within the bounding rectangle specified by OpenVideoChannel.
length | Length of the video frame buffer in bytes.
timestamp | Index/timestamp of currently shown frame.
auto_release_frame | if FALSE, it keeps the current frame for repeated rendering, no automatic buffer release is performed (useful for paused video)

BOOLEAN VideoChannel::SetCropRect | ( | Rect & | crop_rect,
 |  | Rect & | effective_playback_rect
 | ) |

Defines a sub rectangle within the decoded video. The coordinates are relative to the upper left corner of the video. The rectangle may never exceed the size of the decoded video i.e. the cropping rectangle must always lie completely within the video. Together with video frame rectangle this implicitly also defines a zoom factor - the content of the cropping rectangle is zoomed up or down to best fit to the video frame rectangle. This is limited by the capability of the transformation blocks for zoom and crop (i.e. in most cases the hardware).

Parameters:
crop_rect | [IN/OUT] Position and size of area to be cut out from the original video.
effective_playback_rect | [OUT] On return, the effective playback rect.
Returns:
TRUE if the setting of the parameter was possible in the transformation blocks. If it was not possible FALSE is returned and the cropping rectangle contains the best effort of the transformation blocks to fit to the desired rectangle.

BOOLEAN VideoChannel::SetCropRect ( Rect & crop_rect )

Defines a sub rectangle within the decoded video. The coordinates are relative to the upper left corner of the video. The rectangle may never exceed the size of the decoded video i.e. the cropping rectangle must always lie completely within the video. Together with video frame rectangle this implicitly also defines a zoom factor - the content of the cropping rectangle is zoomed up or down to best fit to the video frame rectangle. This is limited by the capability of the transformation blocks for zoom and crop (i.e. in most cases the hardware).

Parameters:
crop_rect [IN/OUT] Position and size of area to be cut out from the original video.
Returns:
TRUE if the setting of the parameter was possible in the transformation blocks. If it was not possible FALSE is returned and the cropping rectangle contains the best effort of the transformation blocks to fit to the desired rectangle.

BOOLEAN VideoChannel::SetCropRect | ( | Rect & | crop_rect,
 |  | Rect & | effective_playback_rect
 | ) |

Defines a sub rectangle within the decoded video. The coordinates are relative to the upper left corner of the video. The rectangle may never exceed the size of the decoded video i.e. the cropping rectangle must always lie completely within the video. Together with video frame rectangle this implicitly also defines a zoom factor - the content of the cropping rectangle is zoomed up or down to best fit to the video frame rectangle. This is limited by the capability of the transformation blocks for zoom and crop (i.e. in most cases the hardware).

Parameters:
crop_rect | [IN/OUT] Position and size of area to be cut out from the original video.
effective_playback_rect | [OUT] On return, the effective playback rect.
Returns:
TRUE if the setting of the parameter was possible in the transformation blocks. If it was not possible FALSE is returned and the cropping rectangle contains the best effort of the transformation blocks to fit to the desired rectangle.

BOOLEAN VideoChannel::SetCropRect | ( | Rect & | crop_rect,
 |  | Rect & | effective_playback_rect
 | ) |

Defines a sub rectangle within the decoded video. The coordinates are relative to the upper left corner of the video. The rectangle may never exceed the size of the decoded video i.e. the cropping rectangle must always lie completely within the video. Together with video frame rectangle this implicitly also defines a zoom factor - the content of the cropping rectangle is zoomed up or down to best fit to the video frame rectangle. This is limited by the capability of the transformation blocks for zoom and crop (i.e. in most cases the hardware).

Parameters:
crop_rect | [IN/OUT] Position and size of area to be cut out from the original video.
effective_playback_rect | [OUT] On return, the effective playback rect.
Returns:
TRUE if the setting of the parameter was possible in the transformation blocks. If it was not possible FALSE is returned and the cropping rectangle contains the best effort of the transformation blocks to fit to the desired rectangle.

BOOLEAN VideoChannel::SetCropRect | ( | Rect & | crop_rect,
 |  | Rect & | effective_playback_rect
 | ) |

Defines a sub rectangle within the decoded video. The coordinates are relative to the upper left corner of the video. The rectangle may never exceed the size of the decoded video i.e. the cropping rectangle must always lie completely within the video. Together with video frame rectangle this implicitly also defines a zoom factor - the content of the cropping rectangle is zoomed up or down to best fit to the video frame rectangle. This is limited by the capability of the transformation blocks for zoom and crop (i.e. in most cases the hardware).

Parameters:
crop_rect | [IN/OUT] Position and size of area to be cut out from the original video.
effective_playback_rect | [OUT] On return, the effective playback rect.
Returns:
TRUE if the setting of the parameter was possible in the transformation blocks. If it was not possible FALSE is returned and the cropping rectangle contains the best effort of the transformation blocks to fit to the desired rectangle.

BOOLEAN VideoChannel::SetCropRect | ( | Rect & | crop_rect,
 |  | Rect & | effective_playback_rect
 | ) |

Defines a sub rectangle within the decoded video. The coordinates are relative to the upper left corner of the video. The rectangle may never exceed the size of the decoded video i.e. the cropping rectangle must always lie completely within the video. Together with video frame rectangle this implicitly also defines a zoom factor - the content of the cropping rectangle is zoomed up or down to best fit to the video frame rectangle. This is limited by the capability of the transformation blocks for zoom and crop (i.e. in most cases the hardware).

Parameters:
crop_rect | [IN/OUT] Position and size of area to be cut out from the original video.
effective_playback_rect | [OUT] On return, the effective playback rect.
Returns:
TRUE if the setting of the parameter was possible in the transformation blocks. If it was not possible FALSE is returned and the cropping rectangle contains the best effort of the transformation blocks to fit to the desired rectangle.

BOOLEAN VideoChannel::SetFrameRect ( Rect & video_frame_rect )

Adjusts the size and position of the actual video area on the screen. Rect is initially set when opening a channel with DisplayChannel::Open but can be changed with this function.

Parameters:
video_frame_rect [IN/OUT] Position and size of screen area to be filled with video.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned and the video frame rectangle contains the best effort of the hardware to fit the desired rectangle.

BOOLEAN VideoChannel::SetParam | ( | VideoParameterType | type,
 |  | UINT32 | value
 | ) |

Parameterizes the rendering path and configures the transformation blocks.

Parameters:
type | [IN] Type of the parameter to be configured.
value | [IN] Value to which the parameter type should be set.
Returns:
TRUE if the setting of the parameter was successful.

BOOLEAN VideoChannel::SetPlaybackAndViewfinderOrder ( VideoAndViewfinderOrderType video_viewfinder_order )

Sets the order of the viewfinder and video playback, i.e. it specifies the order of drawing of the corresponding rectangles. It is important in case that the viewfinder and video playback rectangle are overlapping (e.g. in video telephony). If the viewfinder is not activated, this function shall be ignored.

Parameters:
video_viewfinder_order [IN] Order to be set.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned.

BOOLEAN VideoChannel::SetPlaybackAndViewfinderOrder ( VideoAndViewfinderOrderType video_viewfinder_order )

Sets the order of the viewfinder and video playback, i.e. it specifies the order of drawing of the corresponding rectangles. It is important in case that the viewfinder and video playback rectangle are overlapping (e.g. in video telephony). If the viewfinder is not activated, this function shall be ignored.

Parameters:
video_viewfinder_order [IN] Order to be set.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned.

BOOLEAN VideoChannel::SetPlaybackAndViewfinderOrder ( VideoAndViewfinderOrderType video_viewfinder_order )

Sets the order of the viewfinder and video playback, i.e. it specifies the order of drawing of the corresponding rectangles. It is important in case that the viewfinder and video playback rectangle are overlapping (e.g. in video telephony). If the viewfinder is not activated, this function shall be ignored.

Parameters:
video_viewfinder_order [IN] Order to be set.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned.

BOOLEAN VideoChannel::SetPlaybackAndViewfinderOrder ( VideoAndViewfinderOrderType video_viewfinder_order )

Sets the order of the viewfinder and video playback, i.e. it specifies the order of drawing of the corresponding rectangles. It is important in case that the viewfinder and video playback rectangle are overlapping (e.g. in video telephony). If the viewfinder is not activated, this function shall be ignored.

Parameters:
video_viewfinder_order [IN] Order to be set.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned.

BOOLEAN VideoChannel::SetPlaybackAndViewfinderOrder ( VideoAndViewfinderOrderType video_viewfinder_order )

Sets the order of the viewfinder and video playback, i.e. it specifies the order of drawing of the corresponding rectangles. It is important in case that the viewfinder and video playback rectangle are overlapping (e.g. in video telephony). If the viewfinder is not activated, this function shall be ignored.

Parameters:
video_viewfinder_order [IN] Order to be set.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned.

BOOLEAN VideoChannel::SetPlaybackRect | ( | Rect & | playback_rect,
 |  | TransformationType | playback_transformation,
 |  | ScalingMethodType | scaling_method
 | ) |

Adjusts the size and position of the actual video area on the screen. Rect is initially set when opening a channel with VideoChannel::Open() but can be changed with this function.

Parameters:
playback_rect | [IN/OUT] Position and size of screen area to be filled with video. On return, the effective playback rect.
playback_transformation | [IN] Playback transformation.
scaling_method | [IN] Scaling method.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned and the video frame rectangle contains the best effort of the hardware to fit the desired rectangle.

BOOLEAN VideoChannel::SetPlaybackRect | ( | Rect & | playback_rect,
 |  | TransformationType | playback_transformation,
 |  | ScalingMethodType | scaling_method
 | ) |

Adjusts the size and position of the actual video area on the screen. Rect is initially set when opening a channel with VideoChannel::Open() but can be changed with this function.

Parameters:
playback_rect | [IN/OUT] Position and size of screen area to be filled with video. On return, the effective playback rect.
playback_transformation | [IN] Playback transformation.
scaling_method | [IN] Scaling method.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned and the video frame rectangle contains the best effort of the hardware to fit the desired rectangle.

BOOLEAN VideoChannel::SetPlaybackRect | ( | Rect & | playback_rect,
 |  | TransformationType | playback_transformation,
 |  | ScalingMethodType | scaling_method
 | ) |

Adjusts the size and position of the actual video area on the screen. Rect is initially set when opening a channel with VideoChannel::Open() but can be changed with this function.

Parameters:
playback_rect | [IN/OUT] Position and size of screen area to be filled with video. On return, the effective playback rect.
playback_transformation | [IN] Playback transformation.
scaling_method | [IN] Scaling method.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned and the video frame rectangle contains the best effort of the hardware to fit the desired rectangle.

BOOLEAN VideoChannel::SetPlaybackRect | ( | Rect & | playback_rect,
 |  | TransformationType | playback_transformation,
 |  | ScalingMethodType | scaling_method
 | ) |

Adjusts the size and position of the actual video area on the screen. The rectangle is initially set when opening a channel with DisplayChannel::Open but can be changed dynamically with this method.

Parameters:
playback_rect | [IN/OUT] Position and size of screen area to be filled with video. On return, the effective playback rect.
playback_transformation | [IN] Playback transformation.
scaling_method | [IN] Scaling method.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned and the video frame rectangle contains the best effort of the hardware to fit the desired rectangle.

BOOLEAN VideoChannel::SetPlaybackRect | ( | Rect & | playback_rect,
 |  | TransformationType | playback_transformation,
 |  | ScalingMethodType | scaling_method
 | ) |

Adjusts the size and position of the actual video area on the screen. Rect is initially set when opening a channel with VideoChannel::Open() but can be changed with this function.

Parameters:
playback_rect | [IN/OUT] Position and size of screen area to be filled with video. On return, the effective playback rect.
playback_transformation | [IN] Playback transformation.
scaling_method | [IN] Scaling method.
Returns:
TRUE if the setting of the parameter was possible in the underlying HW. If it was not possible, FALSE is returned and the video frame rectangle contains the best effort of the hardware to fit the desired rectangle.

BOOLEAN VideoChannel::SetVideoSize | ( | Size | actual_video_size,
 |  | Size | extended_video_size,
 |  | Point | left_top_offset
 | ) |

Sets the actual and extended size of the video in pixels as well as the left-top offset. The actual size can be determined by analyzing the transport format of the video or the encoded elementary stream directly. (Compare to 'extended size' as defined by some codec standards, which is the actual size rounded up to a full integer number of macroblocks)

Parameters:
actual_video_size | [IN] Actual size of the decoded video.
extended_video_size | [IN] Extended size of the decoded video.
left_top_offset | [IN] Left-top offset of the video.
Returns:
TRUE if the setting of the parameter was successful

void VideoChannel::SetVideoSize ( Size video_size )

Sets the actual size of the video in pixels. The actual size can be determined by analyzing the transport format of the video or the encoded elementary stream directly. (Compare to 'extended size' as defined by some codec standards, which is the actual size rounded up to a full integer number of macroblocks)

Parameters:
video_size [IN] Actual size of the decoded video as determined by analyzing the videos transport format or the elementary stream

BOOLEAN VideoChannel::SetVideoSize | ( | Size | actual_video_size,
 |  | Size | extended_video_size,
 |  | Point | left_top_offset
 | ) |

Sets the actual and extended size of the video in pixels as well as the left-top offset. The actual size can be determined by analyzing the transport format of the video or the encoded elementary stream directly. (Compare to 'extended size' as defined by some codec standards, which is the actual size rounded up to a full integer number of macroblocks)

Parameters:
actual_video_size | [IN] Actual size of the decoded video.
extended_video_size | [IN] Extended size of the decoded video.
left_top_offset | [IN] Left-top offset of the video.
Returns:
TRUE if the setting of the parameter was successful

BOOLEAN VideoChannel::SetVideoSize | ( | Size | actual_video_size,
 |  | Size | extended_video_size,
 |  | Point | left_top_offset
 | ) |

Sets the actual and extended size of the video in pixels as well as the left-top offset. The actual size can be determined by analyzing the transport format of the video or the encoded elementary stream directly. (Compare to 'extended size' as defined by some codec standards, which is the actual size rounded up to a full integer number of macroblocks)

Parameters:
actual_video_size | [IN] Actual size of the decoded video.
extended_video_size | [IN] Extended size of the decoded video.
left_top_offset | [IN] Left-top offset of the video.
Returns:
TRUE if the setting of the parameter was successful

BOOLEAN VideoChannel::SetVideoSize | ( | Size | actual_video_size,
 |  | Size | extended_video_size,
 |  | Point | left_top_offset
 | ) |

Sets the actual and extended size of the video in pixels as well as the left-top offset. The actual size can be determined by analyzing the transport format of the video or the encoded elementary stream directly. (Compare to 'extended size' as defined by some codec standards, which is the actual size rounded up to a full integer number of macroblocks)

Parameters:
actual_video_size | [IN] Actual size of the decoded video.
extended_video_size | [IN] Extended size of the decoded video.
left_top_offset | [IN] Left-top offset of the video.
Returns:
TRUE if the setting of the parameter was successful

BOOLEAN VideoChannel::SetVideoSize | ( | Size | actual_video_size,
 |  | Size | extended_video_size,
 |  | Point | left_top_offset
 | ) |

Sets the actual and extended size of the video in pixels as well as the left-top offset. The actual size can be determined by analyzing the transport format of the video or the encoded elementary stream directly. (Compare to 'extended size' as defined by some codec standards, which is the actual size rounded up to a full integer number of macroblocks)

Parameters:
actual_video_size | [IN] Actual size of the decoded video.
extended_video_size | [IN] Extended size of the decoded video.
left_top_offset | [IN] Left-top offset of the video.
Returns:
TRUE if the setting of the parameter was successful

BOOLEAN VideoChannel::Start | ( | CbResult | cb_video_channel_started,
 |  | void * | context
 | ) |

Starts (asynchronously) the video channel.

Parameters:
cb_video_channel_started | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Stop

BOOLEAN VideoChannel::Start | ( | CbResult | cb_video_channel_started,
 |  | void * | context
 | ) |

Starts (asynchronously) the video channel.

Parameters:
cb_video_channel_started | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Stop

BOOLEAN VideoChannel::Start | ( | CbResult | cb_video_channel_started,
 |  | void * | context
 | ) |

Starts (asynchronously) the video channel.

Parameters:
cb_video_channel_started | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Stop

BOOLEAN VideoChannel::Start | ( | CbResult | cb_video_channel_started,
 |  | void * | context
 | ) |

Starts (asynchronously) the video channel.

Parameters:
cb_video_channel_started | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Stop

BOOLEAN VideoChannel::Start | ( | CbResult | cb_video_channel_started,
 |  | void * | context
 | ) |

Starts (asynchronously) the video channel.

Parameters:
cb_video_channel_started | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Stop

BOOLEAN VideoChannel::Stop | ( | CbResult | cb_video_channel_stopped,
 |  | void * | context
 | ) |

Stops (asynchronously) the video channel.

Parameters:
cb_video_channel_stopped | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Start

BOOLEAN VideoChannel::Stop | ( | CbResult | cb_video_channel_stopped,
 |  | void * | context
 | ) |

Stops (asynchronously) the video channel.

Parameters:
cb_video_channel_stopped | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Start

BOOLEAN VideoChannel::Stop | ( | CbResult | cb_video_channel_stopped,
 |  | void * | context
 | ) |

Stops (asynchronously) the video channel.

Parameters:
cb_video_channel_stopped | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Start

BOOLEAN VideoChannel::Stop | ( | CbResult | cb_video_channel_stopped,
 |  | void * | context
 | ) |

Stops (asynchronously) the video channel.

Parameters:
cb_video_channel_stopped | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Start

BOOLEAN VideoChannel::Stop | ( | CbResult | cb_video_channel_stopped,
 |  | void * | context
 | ) |

Stops (asynchronously) the video channel.

Parameters:
cb_video_channel_stopped | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
TRUE if the operation was successfull.
See also:
CbResult

Start

The documentation for this class was generated from the following files:
  • Devices/BP30/VideoChannel.hpp
  • Devices/MPE/VideoChannel.hpp
  • Devices/MPEU/Extensions/AtiW2282/VideoChannel.hpp
  • Devices/MPEU/VideoChannel.hpp
  • Devices/SGold/VideoChannel.hpp
  • Devices/Win32/VideoChannel.hpp
  • Devices/BP30/VideoChannel.cpp
  • Devices/MPE/VideoChannel.cpp
  • Devices/MPEU/Extensions/AtiW2282/VideoChannel.cpp
  • Devices/MPEU/VideoChannel.cpp
  • Devices/SGold/VideoChannel.cpp
  • Devices/Win32/VideoChannel.cpp
Generated on Wed Jan 25 02:19:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VideoDecoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VideoDecoder Class Reference
[CodecManager]

#include <Apoxi/AddOns/CodecManager/VideoDecoder.hpp>

Inheritance diagram for VideoDecoder:

[legend]
Collaboration diagram for VideoDecoder:

[legend]

Public Types

typedef void(* | CbFrameDecoded )(ResultType result, void *context, const UINT8 HUGE *out_buf, UINT32 time_stamp)
typedef void(* | CbInBufferFree )(void *context, UINT8 HUGE *in_buf)
enum | FlagsType { LastFrameFlag = 1<<0, LastPacketInFrameFlag = 1<<1, ImmediateDecodingFlag = 1<<2, GreatestValueOfFlagsType = ImmediateDecodingFlag }
enum | ParameterType { QualityLevel, EndOfParameterType }

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 &buf_count, UINT32 &buf_len)=0
virtual ResultType | Close ()=0
virtual ResultType | DecodeFrame (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags, UINT32 time_stamp)=0
virtual ResultType | DecodePacket (const UINT8 HUGE *in_buf, UINT32 in_buf_len, UINT16 flags)=0
virtual ResultType | FlushBuffers (CbResult cb_video_decoder_flushed, void *context)=0
virtual ResultType | GetCapabilities (VideoCodecCapabilities &caps)=0
virtual ResultType | GetCurrentVideoClockTime (UINT32 &time_ms)=0
virtual ResultType | Open (VideoDecoderInfo &dec_info)=0
virtual ResultType | RegisterCallbackFunctions (void *context, CbFrameDecoded cb_frame_decoded, CbInBufferFree cb_in_buf_free)=0
virtual ResultType | ReleaseOutputBuffer (const UINT8 HUGE *out_buf)=0
virtual ResultType | SetAssociatedAudioCh (UINT32 audio_channel)=0
virtual ResultType | SetConfig (const UINT8 *config_stream, UINT32 &config_len, const VideoDecoderParameters &params, VideoStreamInfo &stream_info)=0
virtual ResultType | SetVideoClockTime (UINT32 time_ms)=0
virtual ResultType | Start (CbResultAndTimeInfo cb_video_decoder_started, void *context)=0
virtual ResultType | Stop (CbResult cb_video_decoder_stopped, void *context)=0

Friends

class | CodecManager

Detailed Description

Abstract video decoder base class. The sub-classes of this class provide the actual video decoder functionality API. The VideoDecoder sub-class instances are accessed by the clients via the CodecManager API.
See also:
CodecManager::OpenDecoder

CodecManager::CloseDecoder

Member Typedef Documentation

typedef void(* VideoDecoder::CbFrameDecoded)(ResultType result, void *context, const UINT8 HUGE *out_buf, UINT32 time_stamp)

Callback function that is invoked by the VideoDecoder when a frame has been decoded (and post-processed) and is ready for rendering.

Parameters:
result | A result (error) code: Success if the operation was successful. Otherwise, an appropriate error code.
context | A context (e.g. this pointer) that has been passed to the VideoDecoder object when RegisterCallbackFunctions has been invoked.
out_buf | Pointer to the video output buffer with the decoded frame.
time_stamp | Time stamp as retrieved from the frame headers (in milliseconds).
See also:
DecodeFrame

DecodePacket

RegisterCallbackFunctions

typedef void(* VideoDecoder::CbInBufferFree)(void *context, UINT8 HUGE *in_buf)

A callback function that is called by the VideoDecoder when a video input buffer is not used anymore by the decoder (as the data has been already decoded) and can be re-used.

Parameters:
context | A context (e.g. this pointer) that has been passed to the VideoDecoder object when RegisterCallbackFunctions has been invoked.
in_buf | Pointer to the free video input buffer.
See also:
RegisterCallbackFunctions

Member Enumeration Documentation

enum VideoDecoder::FlagsType

Bit flags used for DecodeFrame and DecodePacket functions. If a bit is set, the corresponding indication is true, e.g., if LastFrame bit is set, it indicates that this is the last frame in the stream/file.

Enumerator:
LastFrameFlag | Indicates if it is the last frame of the stream.
LastPacketInFrameFlag | Indicates if this is the last packet in a frame (only for DecodePacket).
ImmediateDecodingFlag | Indicates if the frame shall be decoded (and in case of combined device also rendered) immediately, i.e. the time stamp is ignored in that case.
GreatestValueOfFlagsType

enum VideoDecoder::ParameterType

Parameter type. It is used by the SetParameters and GetParameters functions as well as by the corresponding callback functions.

Enumerator:
QualityLevel This parameter has to be casted to UINT16. It defines the quality level of the decoder. The greater this value, the better the quality. In general, in dependency of this value the post-processsing features (Deinterlacing, Deringing & Deblocking) are enabled/disabled. 0 corresponds to default settings. If the value is greater than the maximum supported quality level (which can be retrieved via GetCapabilities), the maximum level shall be set. Only for SetParameters function.
EndOfParameterType

Member Function Documentation

virtual ResultType VideoDecoder::AllocateOutputBuffers | ( | UINT8 & | buf_count,
 |  | UINT32 & | buf_len
 | ) | [pure virtual]

Allocates a number of output buffers that are used to store the decoded (and post-processed) frames.

Parameters:
buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e., the VideoDecoder can adapt the number passed in by the caller if necessary.
buf_len | Desired length (in bytes) of one output buffer (all buffers have the same length). If set to 0, the default length will be used. On return, the actual buffer length, i.e. the VideoDecoder can adapt the length passed in by the caller if necessary.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in EmzH264Decoder, EmzMpeg4Decoder, AtiMpeg4Decoder, EmzH264Decoder, EmzMpeg4Decoder, and ScicosMpeg4VideoDecoder.

virtual ResultType VideoDecoder::Close ( ) [pure virtual]

Closes and releases the video decoder. This method should be invoked as soon as the video decoder is not needed anymore to allow other video decoders to access the resources.

Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Open

CodecManager::ReleaseDecoder

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::DecodeFrame | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags,
 |  | UINT32 | time_stamp
 | ) | [pure virtual]

Decodes a video frame. The input buffer contains always one complete frame. The actual decoding is done asynchronously, i.e., when the decoding process has finished, the callback function CbVideoFrameDecoded will be invoked.

Parameters:
in_buf | Pointer to the video input buffer (containing the encoded frame).
in_buf_len | Length of the video input buffer (in bytes).
flags | Bit flags as defined by the FlagsType enum indicating if it is the last frame in the stream/file.
time_stamp | time stamp of the frame in milliseconds.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::DecodePacket | ( | const UINT8 HUGE * | in_buf,
 |  | UINT32 | in_buf_len,
 |  | UINT16 | flags
 | ) | [pure virtual]

Decodes a video packet. Contains one or more packet but the packets are always complete. The actual decoding is done asynchronously, i.e., when a complete frame has been decoded, the callback function CbVideoFrameDecoded will be invoked.

Parameters:
in_buf | Pointer to the video input buffer (containing the encoded packets)
in_buf_len | Length of the video input buffer (in bytes).
flags | Bit flags as defined by the FlagsType enum. It indicates if it is the last packet in the frame and if it is the last frame.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameDecoded

Implemented in EmzH264Decoder, EmzMpeg4Decoder, AtiMpeg4Decoder, EmzH264Decoder, EmzMpeg4Decoder, and ScicosMpeg4VideoDecoder.

virtual ResultType VideoDecoder::FlushBuffers | ( | CbResult | cb_video_decoder_flushed,
 |  | void * | context
 | ) | [pure virtual]

Cleares all output and input buffers of the decoder. The currently active decoding process will complete as usual. After this the decoder deletes all pending DecodeFrame() requests and cleares all internal buffers of the decoder. The input buffers already given to the decoder will be released by the decoder at the capture buffer manager.

Parameters:
cb_video_decoder_flushed | Callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that is passed in the callback function.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CodecDevice::CbResult

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::GetCapabilities ( VideoCodecCapabilities & caps ) [pure virtual]

This function is used to retrieve the capabilities of the video decoder (VideoDecoder sub-class).

Parameters:
caps On return, it contains the capabilities. Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the VideoDecoder sub-class.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::GetCurrentVideoClockTime ( UINT32 & time_ms ) [pure virtual]

Gets the current video clock time. This feature is only available if the video decoder supports clock (see CodecManager::VideoDecoderInfo).

Parameters:
time_ms On return the current time (in milliseconds).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::Open ( VideoDecoderInfo & dec_info ) [pure virtual]

Opens and initializes the video decoder. In general, when a decoder is opened, it is reserved for the caller and cannot be used by another caller. Thus, as soon as the video decoder is not needed anymore, it shall be released by using Close.

Parameters:
dec_info On return, it contains the video decoder info.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Close

CodecManager::ObtainDecoder

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbFrameDecoded | cb_frame_decoded,
 |  | CbInBufferFree | cb_in_buf_free
 | ) | [pure virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the VideoDecoder. This context is then passed as an argument of all callback functions invoked by the VideoDecoder.
cb_frame_decoded | A pointer to a callback function that is invoked by the VideoDecoder when a frame has been decoded (and post-processed) and is ready for rendering.
cb_in_buf_free | A pointer to a callback function that is called by the VideoDecoder when a video input buffer is not used anymore by the decoder (as the data has been already decoded) and can be re-used.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType VideoDecoder::ReleaseOutputBuffer ( const UINT8 HUGE * out_buf ) [pure virtual]

Releases the specified output buffer of the decoder and, thus, allows the decoder to fill it with new decoded (and post-processed) frames if available. In general, this function is called when the frame stored in the buffer shall not been rendered at all or it has been rendered but the buffer has not been released automatically.

Parameters:
out_buf Pointer to the video decoder output buffer that shall be released.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in EmzH264Decoder, EmzMpeg4Decoder, AtiMpeg4Decoder, EmzH264Decoder, EmzMpeg4Decoder, and ScicosMpeg4VideoDecoder.

virtual ResultType VideoDecoder::SetAssociatedAudioCh ( UINT32 audio_channel ) [pure virtual]

Sets associated audio channel. The associated audio channel is used for synchronization purposes between audio and video. This feature is only available if the video decoder supports clock (see CodecManager::VideoDecoderInfo).

Parameters:
audio_channel Associated audio channel. If no audio channel is associated, this shall be set to 0xffffffff.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::SetConfig | ( | const UINT8 * | config_stream,
 |  | UINT32 & | config_len,
 |  | const VideoDecoderParameters & | params,
 |  | VideoStreamInfo & | stream_info
 | ) | [pure virtual]

Configures the video decoder. It uses the config_stream (if available) and params to configure the video decoder. If config_stream is available, i.e. not equal to 0, the information contained in it will overrule the corresponding parameters from params.

Parameters:
config_stream | Pointer to the configuration stream for video decoder. If the config stream is not available, this pointer shall be set to 0. In that case, parameters from params will be used to configure the decoder. Otherwise the parameters extracted from the config_stream will overrule the parameters in params. The MPEG-4 e.g. configuration stream consists of Visual Object Sequence (VOS), Visual Object (VO) and Video Object Layer (VOL) layers.
config_len | Length of the configuration stream config_stream in number of bytes. On return it contains the number of bytes consumed.
params | Video decoder parameters. If config_stream is not equal to 0, it overrules the parameters in params.
stream_info | On return, it contains the encoded stream info.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
Stop

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::SetVideoClockTime ( UINT32 time_ms ) [pure virtual]

Sets the video clock time. This feature is only available if the video decoder supports clock (see CodecManager::VideoDecoderInfo).

Parameters:
time_ms Time to be set (in milliseconds).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::Start | ( | CbResultAndTimeInfo | cb_video_decoder_started,
 |  | void * | context
 | ) | [pure virtual]

Starts (asynchronously) the video decoder.

Parameters:
cb_video_decoder_started | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CodecDevice::CbResultAndTimeInfo

Stop

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

virtual ResultType VideoDecoder::Stop | ( | CbResult | cb_video_decoder_stopped,
 |  | void * | context
 | ) | [pure virtual]

Stops the video decoder.

Parameters:
cb_video_decoder_stopped | Pointer to a callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that will be passed in the callback function.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CodecDevice::CbResult

Start

Implemented in AtiMpeg4Decoder, EmzH264Decoder, and EmzMpeg4Decoder.

Friends And Related Function Documentation

friend class CodecManager [friend]

Reimplemented from CodecDevice.

The documentation for this class was generated from the following file:
  • AddOns/CodecManager/VideoDecoder.hpp
Generated on Wed Jan 25 02:19:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VideoEncoder Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VideoEncoder Class Reference
[CodecManager]

#include <Apoxi/AddOns/CodecManager/VideoEncoder.hpp>

Inheritance diagram for VideoEncoder:

[legend]
Collaboration diagram for VideoEncoder:

[legend]

Public Types

typedef void(* | CbVideoFrameEncoded )(ResultType result, void *context, UINT8 HUGE *out_buf, UINT32 out_buf_len_used, UINT32 time_stamp, FrameCodingType vop_coding_type)
enum | FrameCodingType { IFrame, PFrame, EndOfFrameCodingType }

Public Member Functions

virtual ResultType | AllocateOutputBuffers (UINT8 &out_buf_count, UINT32 &out_buf_len)=0
virtual ResultType | Close ()=0
virtual ResultType | EncodeFrame (UINT8 HUGE *in_buf, UINT32 time_stamp, UINT32 key_frame_ind)=0
virtual ResultType | FlushBuffers (CbResult cb_video_encoder_flushed, void *context)=0
virtual ResultType | GetCapabilities (VideoCodecCapabilities &caps)=0
virtual ResultType | GetConfigStream (UINT8 HUGE *&out_buf, UINT32 &out_buf_len)=0
virtual ResultType | InsertKeyFrame ()=0
virtual ResultType | Open ()=0
virtual ResultType | RegisterCallbackFunctions (void *context, CbVideoFrameEncoded cb_video_frame_encoded)=0
virtual ResultType | ReleaseConfigStreamBuffer (UINT8 HUGE *buf)=0
virtual ResultType | ReleaseOutputBuffer (UINT8 HUGE *out_buf)=0
virtual ResultType | SetConfig (const VideoEncoderParameters &params, UINT32 &out_buf_max_len)=0
virtual ResultType | SetDynamicConfig (VideoEncoderDynParameters &params)=0
virtual ResultType | Start ()=0
virtual ResultType | Stop (CbResult cb_video_encoder_stopped, void *context)=0

Friends

class | CodecManager

Data Structures

struct | VideoEncoderDynParameters

Detailed Description

Abstract video encoder base class. The sub-classes of this class provide the actual video encoder functionality API. The VideoEncoder sub-class instances are accessed by the clients via the CodecManager API.
See also:
CodecManager::ObtainEncoder

CodecManager::ReleaseEncoder

Member Typedef Documentation

typedef void(* VideoEncoder::CbVideoFrameEncoded)(ResultType result, void *context, UINT8 HUGE *out_buf, UINT32 out_buf_len_used, UINT32 time_stamp, FrameCodingType vop_coding_type)

Callback function that is invoked by the VideoEncoder when a frame has been encoded.

Parameters:
result | A result (error) code: Success if the operation was successful. Otherwise, an appropriate error code.
context | A context (e.g. this pointer) that has been passed to the VideoEncoder object when RegisterCallbackFunctions has been invoked.
out_buf | Pointer to the video output buffer with the encoded frame.
out_buf_len_used | Length of the video output buffer out_buf (in bytes).
time_stamp | time stamp for the encoded frame
vop_coding_type | The frame (VOP) coded type.
See also:
EncodeFrame

RegisterCallbackFunctions

Member Enumeration Documentation

enum VideoEncoder::FrameCodingType

Frame (VOP) coding type

Enumerator:
IFrame | I-frame or key frame.
PFrame | P-frame.
EndOfFrameCodingType

Member Function Documentation

virtual ResultType VideoEncoder::AllocateOutputBuffers | ( | UINT8 & | out_buf_count,
 |  | UINT32 & | out_buf_len
 | ) | [pure virtual]

Allocates a number of output buffers that are used to store the encoded frames. Note: Output buffers will be freed when VideoEncoder::Stop is invoked.

Parameters:
out_buf_array | On return, a pointer to the output buffer array (the elements of the array are pointers to the actual buffers).
out_buf_count | Desired number of buffers to be allocated in the output buffer array. If set to 0, the default number of buffers will be allocated. On return, the actual number of buffers, i.e. the VideoEncoder adapt the number passed in by the caller if necessary.
out_buf_len | On return, the length of one output buffer in bytes (all buffers have the same length). It corresponds to the maximum possible length of one encoded frame.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::Close ( ) [pure virtual]

Closes (releases) the video encoder opened by Open. This method should be invoked as soon as the video encoder is not needed anymore to allow other video encoders to access the resources.

Returns:
Success if the operation was successful. Otherwise, an aprropriate error code.
See also:
Open

CodecManager::ReleaseEncoder

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::EncodeFrame | ( | UINT8 HUGE * | in_buf,
 |  | UINT32 | time_stamp,
 |  | UINT32 | key_frame_ind
 | ) | [pure virtual]

Encodes a video frame. This is done asynchronously, i.e., when the frame has been encoded, the callback function CbVideoFrameEncoded will be invoked.

Parameters:
in_buf | Points to input raw video data.
time_stamp | Number of primary time units elapsed since the start of encoding process. Time stamp value should be integral multiple of VideoEncoderParameters::m_timer_resolution/ VideoEncoderParameters::m_frame_rate (refer the details on VideoEncoderParameters).
key_frame_ind | Flag indicating the insertion of I-frame. Possible values for this flag are: TRUE, FALSE. TRUE inserts the I-frame. Default value should be FALSE.
out_buf | Buffer in which the encoded stream needs to be written. Enough buffer to hold the encoded stream corresponding to one frame of data should be given. The maximum frame size (i.e. encoding bytes) can be obtained by using GetParameters function.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameEncoded

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::FlushBuffers | ( | CbResult | cb_video_encoder_flushed,
 |  | void * | context
 | ) | [pure virtual]

This function flushes all video encoder buffers.

Parameters:
cb_video_encoder_flushed | Callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that is passed in the callback function.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CodecDevice::CbResult

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::GetCapabilities ( VideoCodecCapabilities & caps ) [pure virtual]

This function is used to retrieve the capabilities of the video encoder (VideoEncoder sub-class).

Parameters:
caps On return, it contains the capabilities. Note: The caller has to create this object (with arbitrary values) before calling this function. The passed object is then filled with the correct values by the VideoDecoder sub-class.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::GetConfigStream | ( | UINT8 HUGE *& | out_buf,
 |  | UINT32 & | out_buf_len
 | ) | [pure virtual]

This function is used to get the configuration stream (header). after this configuration stream has been used, the corresponding buffer has to be freed by using VideoEncoder::ReleaseConfigStreamBuffer.

Parameters:
out_buf | On return, pointer to a buffer where the config stream has been written to.
out_buf_len | On return, length of out_buf (in bytes).
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
ReleaseConfigStreamBuffer

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::InsertKeyFrame ( ) [pure virtual]

This function enforces the video encoder to insert an I frame, i.e. the next frame to be encoded shall be encoded as I frame.

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::Open ( ) [pure virtual]

Opens the video encoder. In general, when a encoder is opened, it is reserved for the caller and cannot be used by another caller. Thus, as soon as the video encoder is not needed anymore, it shall be released by using Close.

Returns:
Success if the operation was successful. Otherwise, an aprropriate error code.
See also:
Close

CodecManager::ObtainEncoder

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::RegisterCallbackFunctions | ( | void * | context,
 |  | CbVideoFrameEncoded | cb_video_frame_encoded
 | ) | [pure virtual]

Register callback functions.

Parameters:
context | A context (e.g. this pointer) that is valid for all callback functions registered with this instance of the VideoEncoder. This context is then passed as an argument of all callback functions invoked by the VideoEncoder.
cb_video_frame_encoded | A pointer to a callback function that is invoked by the VideoEncoder each time when a frame has been encoded.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

virtual ResultType VideoEncoder::ReleaseConfigStreamBuffer ( UINT8 HUGE * buf ) [pure virtual]

This function is used to release (free) the buffer used for providing the configuration stream (header) data.

Parameters:
buf Pointer to the buffer to be released.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
GetConfigStream

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::ReleaseOutputBuffer ( UINT8 HUGE * out_buf ) [pure virtual]

This function is used to release the output buffer of the encoder (buffer containing encoded frame data) so that it can be re-used for the next frame.

Parameters:
out_buf Pointer to the buffer to be released.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::SetConfig | ( | const VideoEncoderParameters & | params,
 |  | UINT32 & | out_buf_max_len
 | ) | [pure virtual]

Configures the video encoder statically, i.e., when the decoder is not active.

Parameters:
params | Video encoder parameters to be set.
out_buf_max_len | On return, it contains the maximum length (in bytes) of the output buffer.
Returns:
Success if the operation was successful. Otherwise, an aprropriate error code.

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::SetDynamicConfig ( VideoEncoderDynParameters & params ) [pure virtual]

Configures the video encoder dynamically, i.e., when the decoder is active.

Parameters:
params Video encoder parameters to be set.
Returns:
Success if the operation was successful. Otherwise, an aprropriate error code.

virtual ResultType VideoEncoder::Start ( ) [pure virtual]

Starts the video frame encode. This is done asynchronously, i.e., when the frame has been encoded, the callback function CbVideoFrameEncoded will be invoked.

Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameEncoded

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

virtual ResultType VideoEncoder::Stop | ( | CbResult | cb_video_encoder_stopped,
 |  | void * | context
 | ) | [pure virtual]

Stops the video frame encode. This is done asynchronously, i.e., when the encoder has been encoded, the callback function cb_video_encoder_stopped will be invoked.

Parameters:
cb_video_encoder_stopped | Callback function that is called when this operation has finished.
context | Context (e.g. this pointer) that is passed in the callback function.
Returns:
Success if the operation was successful. Otherwise, an appropriate error code.
See also:
CbFrameEncoded

Implemented in AtiMpeg4Encoder, and EmzMpeg4Encoder.

Friends And Related Function Documentation

friend class CodecManager [friend]

Reimplemented from CodecDevice.

The documentation for this class was generated from the following file:
  • AddOns/CodecManager/VideoEncoder.hpp
Generated on Wed Jan 25 02:20:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VideoEncoder::VideoEncoderDynParameters Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
VideoEncoder::VideoEncoderDynParameters

VideoEncoder::VideoEncoderDynParameters Struct Reference

#include <Apoxi/AddOns/CodecManager/VideoEncoder.hpp>

Data Fields

UINT32 | m_bit_rate
UINT16 | m_frame_rate_denominator
UINT16 | m_frame_rate_numerator

Detailed Description

Dynamic video encoder parameters.
See also:
SetDynamicConfig

Field Documentation

UINT32 VideoEncoder::VideoEncoderDynParameters::m_bit_rate

Bit rate (in bits/sec).

UINT16 VideoEncoder::VideoEncoderDynParameters::m_frame_rate_denominator

Denominator of the frame rate (in frames per second). The actual frame rate is calculated as m_frame_rate_numerator/m_frame_rate_denominator.

UINT16 VideoEncoder::VideoEncoderDynParameters::m_frame_rate_numerator

Numerator of the frame rate (in frames per second). The actual frame rate is calculated as m_frame_rate_numerator/m_frame_rate_denominator.

The documentation for this struct was generated from the following file:
  • AddOns/CodecManager/VideoEncoder.hpp
Generated on Wed Jan 25 02:20:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VietnameseTextRenderer Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VietnameseTextRenderer Class Reference
[GUI]

#include <Apoxi/Gui/VietnameseTextRenderer.hpp>

Inheritance diagram for VietnameseTextRenderer:

[legend]
Collaboration diagram for VietnameseTextRenderer:

[legend]

Public Member Functions

virtual BOOLEAN | IsStandaloneCharacter (const WCHAR *text, INT index)
virtual | ~VietnameseTextRenderer ()

Static Public Member Functions

static VietnameseTextRenderer & | GetInstance ()
Returns the instance of the Thai text renderer.

Protected Member Functions

virtual Size | GetGlyph (const WCHAR *cur_text_pos, const WCHAR *substitution_char, INT n_chars, GlyphPtr glyph, INT &parsed_glyphs, BOOLEAN &is_diacritic)
VietnameseTextRenderer ()

Detailed Description

Renderer for Vietnamese text. Combines characters and diacritics into their presentation form. Incorrect character sequences are skipped. Supports all storage syntaxes (fully precomposed (NFC); only combining characters, sorted by canonical order (NFD); VN-Combining; VN-canonical; the other one) at the same time; thus is very tolerant of input errors. See .doc for more information about Vietnamese.

Constructor & Destructor Documentation

VietnameseTextRenderer::~VietnameseTextRenderer ( ) [virtual]

VietnameseTextRenderer::VietnameseTextRenderer ( ) [protected]

Member Function Documentation

Size VietnameseTextRenderer::GetGlyph | ( | const WCHAR * | cur_text_pos,
 |  | const WCHAR * | substitution_char,
 |  | INT | n_chars,
 |  | GlyphPtr | glyph,
 |  | INT & | parsed_glyphs,
 |  | BOOLEAN & | is_diacritic
 | ) | [protected, virtual]

Get the correct glyph for a character. This may depend on its position within in the text, the characters preceding and/or following it. This method, in essence, implements the brunt work for correctly rendering text.

Parameters:
cur_text_pos | Pointer to the current character position within the text.
substitution_char | Pointer to a character that should be used instead of the character at cur_text_pos. If it is 0, then the character pointed to by cur_text_pos is used.
char_count | Number of remaining characters.
glyph | A GlyphPointer where the glyph data is stored (output parameter).
parsed_glyph | Stores the number of parsed glyphs (output parameter). This is used by DrawText to determine if characters can be skipped, e.g. if an 'a' is followed by an '`', and the implementing renderer unifies the character to 'ß', then parsed_glyphs is 2. The DrawText algorithm will then not attempt to get a glyph for the '`' character, but skip it and continue with the one following it.
is_diacritic | After calling the method, is_diacritic will reflect whether the character for the glyph is a diacritic or not. This must be respected by callers insofar as diacritics are drawn in the previous character's cell and thus those characters' width must not be considered when drawing text or calculating the text width.
Returns:
The x/y offset for the current glyph. This is used to change the position of the drawn glyph. Thus, using the example above, if the 'a' and '`' are not unified as one character, then the 'a' can be drawn on its own, and the '`' is drawn on its own at a position above the 'a', where the position is specified by the returned Size value. Usually, however, it is (0,0).

Implements AbstractTextRenderer.

VietnameseTextRenderer & VietnameseTextRenderer::GetInstance ( ) [static]

Returns the instance of the Thai text renderer.

BOOLEAN VietnameseTextRenderer::IsStandaloneCharacter | ( | const WCHAR * | text,
 |  | INT | index
 | ) | [virtual]

See also:
AbstractTextRenderer::IsStandaloneCharacter

Reimplemented from AbstractTextRenderer.

The documentation for this class was generated from the following files:
  • Gui/VietnameseTextRenderer.hpp
  • Gui/VietnameseTextRenderer.cpp
Generated on Wed Jan 25 02:20:03 2006 for APOXI by doxygen 1.4.6-NO


APOXI: View Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

View Class Reference
[GUI]

#include <Apoxi/Gui/View.hpp>

Inheritance diagram for View:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const =0
XYDIM | GetDefaultHeight () const
XYDIM | GetDefaultWidth () const
virtual void | Update (const Theme &theme)
View (XYDIM default_width=-1, XYDIM default_height=-1)
virtual | ~View ()

Protected Member Functions

void | SetDefaultHeight (XYDIM height)
void | SetDefaultWidth (XYDIM width)

Detailed Description

Abstract class, which describes the view of a component and is capable of drawing a component. An instance of a View might be shared by several instances of a component. Every view can have a default width or a default height.

Constructor & Destructor Documentation

View::View | ( | XYDIM | default_width = -1,
 |  | XYDIM | default_height = -1
 | ) |

Parameters:
default_width | Default width. -1 means, that no default width is available.
default_height | Default height. -1 means, that no default height is available.

View::~View ( ) [virtual]

Member Function Documentation

virtual void View::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [pure virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implemented in MediaBoxView, SelectionBoxView, StrokeBoxView, T9PinyinBoxView, Zi8AlphabetBoxView, Zi8SelectionBoxView, Zi8StrokeBoxView, ItemLabelView, AbstractListBoxView, AnimationView, CheckBoxView, DateEditBoxView, EditBoxView, GridView, IndicatorBarView, MenuView, RadioButtonView, SoftkeyBarView, TimeEditBoxView, AbstractLineEditorView, AbstractMultiLineEditorView, CheckBoxControlView, ControlFrameView, DateEditorView, ItemBoxView, PanelView, PositionIndicatorView, ProgressBarView, PushButtonView, RadioButtonControlView, TabButtonView, TabControlView, TextBoxView, TextLineView, WindowFrameView, CalendarGridView, and CalendarMonthSelectorView.

XYDIM View::GetDefaultHeight ( void ) const [inline]

Returns:
Default height of the view. If no default height has been specified, -1 is returned.

XYDIM View::GetDefaultWidth ( void ) const [inline]

Returns:
Default width of the view. If no default width has been specified, -1 is returned.

void View::SetDefaultHeight ( XYDIM height ) [inline, protected]

Parameters:
height Default height (use -1 to indicate no default height).

void View::SetDefaultWidth ( XYDIM width ) [inline, protected]

Parameters:
width Default width (use -1 to indicate no default width).

void View::Update ( const Theme & theme ) [virtual]

Reimplemented in DefaultCheckBoxListView, DefaultCheckBoxView, DefaultControlFrameView, DefaultProgressBarView, DefaultPushButtonView, DefaultRadioButtonListView, DefaultRadioButtonView, DefaultTextListView, DefaultWindowFrameView, CTPanelView, CTProgressBarView, CTPushButtonView, DefaultCheckBoxListView, DefaultCheckBoxView, DefaultControlFrameView, DefaultPanelView, DefaultProgressBarView, DefaultPushButtonView, DefaultRadioButtonListView, DefaultRadioButtonView, DefaultTextListView, DefaultWindowFrameView, FoggyPanelView, FoggyPushButtonView, FoggyWindowFrameView, CheckBoxControlView, RadioButtonControlView, and TabControlView.

The documentation for this class was generated from the following files:
  • Gui/View.hpp
  • Gui/View.cpp
Generated on Wed Jan 25 02:20:05 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ViewfinderErrorMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

ViewfinderErrorMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for ViewfinderErrorMsg:

[legend]
Collaboration diagram for ViewfinderErrorMsg:

[legend]

Public Types

enum | { ID = 1121 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
ViewfinderErrorMsg ()
virtual | ~ViewfinderErrorMsg ()

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

ViewfinderErrorMsg::ViewfinderErrorMsg ( )

ViewfinderErrorMsg::~ViewfinderErrorMsg ( ) [virtual]

Member Function Documentation

Message * ViewfinderErrorMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & ViewfinderErrorMsg::GetMetaData ( ) const [virtual]

Implements Message.

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:20:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VirtualDisplay Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VirtualDisplay Class Reference
[Devices, Devices, Devices, Devices, Devices]

#include <Apoxi/Devices/BP30/VirtualDisplay.hpp>

Inheritance diagram for VirtualDisplay:

[legend]
Collaboration diagram for VirtualDisplay:

[legend]

Public Types

enum Type {
Monochrome, Planes2, Planes4, Planes8,
BitsPerPixel8, BitsPerPixel16, BitsPerPixel24, BitsPerPixel32
}
enum Type {
Monochrome, Planes2, Planes4, Planes8,
BitsPerPixel8, BitsPerPixel16, BitsPerPixel24, BitsPerPixel32
}
enum Type {
Monochrome, Planes2, Planes4, Planes8,
BitsPerPixel8, BitsPerPixel16, BitsPerPixel24, BitsPerPixel32
}
enum Type {
Monochrome, Planes2, Planes4, Planes8,
BitsPerPixel8, BitsPerPixel16, BitsPerPixel24, BitsPerPixel32
}
enum Type {
Monochrome, Planes2, Planes4, Planes8,
BitsPerPixel8, BitsPerPixel16, BitsPerPixel24, BitsPerPixel32
}

Public Member Functions

void | AdjustBlitRect (const Rect &rect)
void | AdjustBlitRect (const Rect &rect)
void | AdjustBlitRect (const Rect &rect)
void | AdjustBlitRect (const Rect &rect)
void | AdjustBlitRect (const Rect &rect)
void | BitBlit (XYDIM dest_x, XYDIM dest_y, const BitmapRes &bmp, const Rect &clip_rect, UINT8 trans_mode=0)
void | BitBlit (XYDIM dest_x, XYDIM dest_y, const BitmapRes &bmp, const Rect &clip_rect, UINT8 trans_mode=0)
void | BitBlit (XYDIM dest_x, XYDIM dest_y, const BitmapRes &bmp, const Rect &clip_rect, UINT8 trans_mode=0)
void | BitBlit (XYDIM dest_x, XYDIM dest_y, const BitmapRes &bmp, const Rect &clip_rect, UINT8 trans_mode=0)
void | BitBlit (XYDIM dest_x, XYDIM dest_y, const BitmapRes &bmp, const Rect &clip_rect, UINT8 trans_mode=0)
ControlArg | Control (INT command, ControlArg arg)
ControlArg | Control (INT command, ControlArg arg)
ControlArg | Control (INT command, ControlArg arg)
ControlArg | Control (INT command, ControlArg arg)
ControlArg | Control (INT command, ControlArg arg)
ColorValue | ConvertToColorValue (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const
ColorValue | ConvertToColorValue (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const
ColorValue | ConvertToColorValue (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const
ColorValue | ConvertToColorValue (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const
ColorValue | ConvertToColorValue (UINT8 red, UINT8 green, UINT8 blue, UINT8 alpha) const
void | DrawChar (XYDIM x, XYDIM y, const Glyph &glyph, INT height)
void | DrawChar (XYDIM x, XYDIM y, const Glyph &glyph, INT height)
void | DrawChar (XYDIM x, XYDIM y, const Glyph &glyph, INT height)
void | DrawChar (XYDIM x, XYDIM y, const Glyph &glyph, INT height)
void | DrawChar (XYDIM x, XYDIM y, const Glyph &glyph, INT height)
void | FillRect (const Rect &rect)
void | FillRect (const Rect &rect)
void | FillRect (const Rect &rect)
void | FillRect (const Rect &rect)
void | FillRect (const Rect &rect)
BOOLEAN | GetAlphaBlendingMode () const
BOOLEAN | GetAlphaBlendingMode () const
BOOLEAN | GetAlphaBlendingMode () const
BOOLEAN | GetAlphaBlendingMode () const
BOOLEAN | GetAlphaBlendingMode () const
Bitmap * GetBitmap ()
Bitmap * GetBitmap ()
Bitmap * GetBitmap ()
Bitmap * GetBitmap ()
Bitmap * GetBitmap ()
const Rect & | GetBlitRect () const
const Rect & | GetBlitRect () const
const Rect & | GetBlitRect () const
const Rect & | GetBlitRect () const
const Rect & | GetBlitRect () const
Color | GetColor () const
Color | GetColor () const
Color | GetColor () const
Color | GetColor () const
Color | GetColor () const
ColorValue | GetColorValue () const
ColorValue | GetColorValue () const
ColorValue | GetColorValue () const
ColorValue | GetColorValue () const
ColorValue | GetColorValue () const
XYDIM | GetHeight () const
XYDIM | GetHeight () const
XYDIM | GetHeight () const
XYDIM | GetHeight () const
XYDIM | GetHeight () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
virtual const WCHAR * | GetName () const
Color | GetPixelColor (XYDIM x, XYDIM y) const
Returns the color of the pixel on position x, y.
Color | GetPixelColor (XYDIM x, XYDIM y) const
Returns the color of the pixel on position x, y.
Color | GetPixelColor (XYDIM x, XYDIM y) const
Returns the color of the pixel on position x, y.
Color | GetPixelColor (XYDIM x, XYDIM y) const
Returns the color of the pixel on position x, y.
Color | GetPixelColor (XYDIM x, XYDIM y) const
Returns the color of the pixel on position x, y.
INT | GetScanlineAtomCount () const
Returns the number of atoms of a display-scanline.
INT | GetScanlineAtomCount () const
Returns the number of atoms of a display-scanline.
INT | GetScanlineAtomCount () const
Returns the number of atoms of a display-scanline.
INT | GetScanlineAtomCount () const
Returns the number of atoms of a display-scanline.
INT | GetScanlineAtomCount () const
Returns the number of atoms of a display-scanline.
Type GetType ()
Type GetType ()
Type GetType ()
Type GetType ()
Type GetType ()
XYDIM | GetWidth () const
XYDIM | GetWidth () const
XYDIM | GetWidth () const
XYDIM | GetWidth () const
XYDIM | GetWidth () const
void | Init (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
void | Init (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
void | Init (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
void | Init (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
void | Init (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
void | Init (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
void | Init (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
void | Init (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
void | Init (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
void | Init (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
virtual void | Refresh ()
virtual void | Refresh ()
virtual void | Refresh ()
virtual void | Refresh ()
virtual void | Refresh ()
void | Scroll (const Rect &rect, XYDIM dx, XYDIM dy)
void | Scroll (const Rect &rect, XYDIM dx, XYDIM dy)
void | Scroll (const Rect &rect, XYDIM dx, XYDIM dy)
void | Scroll (const Rect &rect, XYDIM dx, XYDIM dy)
void | Scroll (const Rect &rect, XYDIM dx, XYDIM dy)
void | SetAlphaBlendingMode (BOOLEAN mode)
void | SetAlphaBlendingMode (BOOLEAN mode)
void | SetAlphaBlendingMode (BOOLEAN mode)
void | SetAlphaBlendingMode (BOOLEAN mode)
void | SetAlphaBlendingMode (BOOLEAN mode)
void | SetBlitRect (const Rect &rect=Rect())
void | SetBlitRect (const Rect &rect=Rect())
void | SetBlitRect (const Rect &rect=Rect())
void | SetBlitRect (const Rect &rect=Rect())
void | SetBlitRect (const Rect &rect=Rect())
void | SetColor (Color color)
void | SetColor (Color color)
void | SetColor (Color color)
void | SetColor (Color color)
void | SetColor (Color color)
void | SetColorValue (ColorValue color_value, UINT8 alpha=255)
void | SetColorValue (ColorValue color_value, UINT8 alpha=255)
void | SetColorValue (ColorValue color_value, UINT8 alpha=255)
void | SetColorValue (ColorValue color_value, UINT8 alpha=255)
void | SetColorValue (ColorValue color_value, UINT8 alpha=255)
void | SetPixel (XYDIM x, XYDIM y)
void | SetPixel (XYDIM x, XYDIM y)
void | SetPixel (XYDIM x, XYDIM y)
void | SetPixel (XYDIM x, XYDIM y)
void | SetPixel (XYDIM x, XYDIM y)
VirtualDisplay (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
VirtualDisplay (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
VirtualDisplay (INT index=0)
VirtualDisplay (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
VirtualDisplay (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
VirtualDisplay (INT index=0)
VirtualDisplay (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
VirtualDisplay (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
VirtualDisplay (INT index=0)
VirtualDisplay (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
VirtualDisplay (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
VirtualDisplay (INT index=0)
VirtualDisplay (Bitmap *bitmap, INT bits_per_pixel, BOOLEAN planes=FALSE)
VirtualDisplay (XYDIM width, XYDIM height, INT bits_per_pixel, BOOLEAN planes=FALSE, DDrvAtomPtr buffer=0)
VirtualDisplay (INT index=0)
virtual | ~VirtualDisplay ()
virtual | ~VirtualDisplay ()
virtual | ~VirtualDisplay ()
virtual | ~VirtualDisplay ()
virtual | ~VirtualDisplay ()

Detailed Description

Provides methods for accessing the display in a generic way. For the application developer it is recommended to use the class DeviceContext for drawing operations. Using the display device directly is possible but it is important to know, that this approach bypasses the APOXI window system.

Member Enumeration Documentation

enum VirtualDisplay::Type

Describes the type of the display regarding how the pixels are represented.

Enumerator:
Monochrome | One byte describes 8 pixels.
Planes2 | One byte of a plane describes 8 pixels, 2 planes and hence 4 colors are available.
Planes4 | One byte of a plane describes 8 pixels, 4 planes and hence 16 colors are available.
Planes8 | One byte of a plane describes 8 pixels, 8 planes and hence 256 colors are available.
BitsPerPixel8 | One byte describes the color of one pixel.
BitsPerPixel16 | Two bytes describe the color of one pixel.
BitsPerPixel24 | Three bytes describe the color of one pixel.
BitsPerPixel32 | Four bytes describe the color of one pixel.

enum VirtualDisplay::Type

Describes the type of the display regarding how the pixels are represented.

Enumerator:
Monochrome | One byte describes 8 pixels.
Planes2 | One byte of a plane describes 8 pixels, 2 planes and hence 4 colors are available.
Planes4 | One byte of a plane describes 8 pixels, 4 planes and hence 16 colors are available.
Planes8 | One byte of a plane describes 8 pixels, 8 planes and hence 256 colors are available.
BitsPerPixel8 | One byte describes the color of one pixel.
BitsPerPixel16 | Two bytes describe the color of one pixel.
BitsPerPixel24 | Three bytes describe the color of one pixel.
BitsPerPixel32 | Four bytes describe the color of one pixel.

enum VirtualDisplay::Type

Describes the type of the display regarding how the pixels are represented.

Enumerator:
Monochrome | One byte describes 8 pixels.
Planes2 | One byte of a plane describes 8 pixels, 2 planes and hence 4 colors are available.
Planes4 | One byte of a plane describes 8 pixels, 4 planes and hence 16 colors are available.
Planes8 | One byte of a plane describes 8 pixels, 8 planes and hence 256 colors are available.
BitsPerPixel8 | One byte describes the color of one pixel.
BitsPerPixel16 | Two bytes describe the color of one pixel.
BitsPerPixel24 | Three bytes describe the color of one pixel.
BitsPerPixel32 | Four bytes describe the color of one pixel.

enum VirtualDisplay::Type

Describes the type of the display regarding how the pixels are represented.

Enumerator:
Monochrome | One byte describes 8 pixels.
Planes2 | One byte of a plane describes 8 pixels, 2 planes and hence 4 colors are available.
Planes4 | One byte of a plane describes 8 pixels, 4 planes and hence 16 colors are available.
Planes8 | One byte of a plane describes 8 pixels, 8 planes and hence 256 colors are available.
BitsPerPixel8 | One byte describes the color of one pixel.
BitsPerPixel16 | Two bytes describe the color of one pixel.
BitsPerPixel24 | Three bytes describe the color of one pixel.
BitsPerPixel32 | Four bytes describe the color of one pixel.

enum VirtualDisplay::Type

Describes the type of the display regarding how the pixels are represented.

Enumerator:
Monochrome | One byte describes 8 pixels.
Planes2 | One byte of a plane describes 8 pixels, 2 planes and hence 4 colors are available.
Planes4 | One byte of a plane describes 8 pixels, 4 planes and hence 16 colors are available.
Planes8 | One byte of a plane describes 8 pixels, 8 planes and hence 256 colors are available.
BitsPerPixel8 | One byte describes the color of one pixel.
BitsPerPixel16 | Two bytes describe the color of one pixel.
BitsPerPixel24 | Three bytes describe the color of one pixel.
BitsPerPixel32 | Four bytes describe the color of one pixel.

Constructor & Destructor Documentation

VirtualDisplay::VirtualDisplay ( INT index = 0 )

Parameters:
index Index of the display.

VirtualDisplay::VirtualDisplay | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

VirtualDisplay::VirtualDisplay | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

VirtualDisplay::~VirtualDisplay ( ) [virtual]

VirtualDisplay::VirtualDisplay ( INT index = 0 )

Parameters:
index Index of the display.

VirtualDisplay::VirtualDisplay | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

VirtualDisplay::VirtualDisplay | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

virtual VirtualDisplay::~VirtualDisplay ( ) [virtual]

VirtualDisplay::VirtualDisplay ( INT index = 0 )

Parameters:
index Index of the display.

VirtualDisplay::VirtualDisplay | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

VirtualDisplay::VirtualDisplay | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

virtual VirtualDisplay::~VirtualDisplay ( ) [virtual]

VirtualDisplay::VirtualDisplay ( INT index = 0 )

Parameters:
index Index of the display.

VirtualDisplay::VirtualDisplay | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

VirtualDisplay::VirtualDisplay | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

virtual VirtualDisplay::~VirtualDisplay ( ) [virtual]

VirtualDisplay::VirtualDisplay ( INT index = 0 )

Parameters:
index Index of the display.

VirtualDisplay::VirtualDisplay | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

VirtualDisplay::VirtualDisplay | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

virtual VirtualDisplay::~VirtualDisplay ( ) [virtual]

Member Function Documentation

void VirtualDisplay::AdjustBlitRect ( const Rect & rect ) [inline]

Does a union of the existing blitting rectangle with the rectangle given by rect.

void VirtualDisplay::AdjustBlitRect ( const Rect & rect ) [inline]

Does a union of the existing blitting rectangle with the rectangle given by rect.

void VirtualDisplay::AdjustBlitRect ( const Rect & rect ) [inline]

Does a union of the existing blitting rectangle with the rectangle given by rect.

void VirtualDisplay::AdjustBlitRect ( const Rect & rect ) [inline]

Does a union of the existing blitting rectangle with the rectangle given by rect.

void VirtualDisplay::AdjustBlitRect ( const Rect & rect ) [inline]

Does a union of the existing blitting rectangle with the rectangle given by rect.

void VirtualDisplay::BitBlit | ( | XYDIM | dest_x,
 |  | XYDIM | dest_y,
 |  | const BitmapRes & | bmp,
 |  | const Rect & | clip_rect,
 |  | UINT8 | trans_mode = 0
 | ) |

Blits a bitmap on the specified position.

Parameters:
dest_x | x-position where the bitmap should be blitted.
dest_y | y-position where the bitmap should be blitted.
bmp | Source bitmap.
clip_rect | Clipping rectangle, so that it is also possible to blit only parts of the bitmap. Note: no check for the clipping rectangle is done, the parameters must be inside the available display area.
trans_mode | Transformation mode.

void VirtualDisplay::BitBlit | ( | XYDIM | dest_x,
 |  | XYDIM | dest_y,
 |  | const BitmapRes & | bmp,
 |  | const Rect & | clip_rect,
 |  | UINT8 | trans_mode = 0
 | ) |

Blits a bitmap on the specified position.

Parameters:
dest_x | x-position where the bitmap should be blitted.
dest_y | y-position where the bitmap should be blitted.
bmp | Source bitmap.
clip_rect | Clipping rectangle, so that it is also possible to blit only parts of the bitmap. Note: no check for the clipping rectangle is done, the parameters must be inside the available display area.
trans_mode | Transformation mode.

void VirtualDisplay::BitBlit | ( | XYDIM | dest_x,
 |  | XYDIM | dest_y,
 |  | const BitmapRes & | bmp,
 |  | const Rect & | clip_rect,
 |  | UINT8 | trans_mode = 0
 | ) |

Blits a bitmap on the specified position.

Parameters:
dest_x | x-position where the bitmap should be blitted.
dest_y | y-position where the bitmap should be blitted.
bmp | Source bitmap.
clip_rect | Clipping rectangle, so that it is also possible to blit only parts of the bitmap. Note: no check for the clipping rectangle is done, the parameters must be inside the available display area.
trans_mode | Transformation mode.

void VirtualDisplay::BitBlit | ( | XYDIM | dest_x,
 |  | XYDIM | dest_y,
 |  | const BitmapRes & | bmp,
 |  | const Rect & | clip_rect,
 |  | UINT8 | trans_mode = 0
 | ) |

Blits a bitmap on the specified position.

Parameters:
dest_x | x-position where the bitmap should be blitted.
dest_y | y-position where the bitmap should be blitted.
bmp | Source bitmap.
clip_rect | Clipping rectangle, so that it is also possible to blit only parts of the bitmap. Note: no check for the clipping rectangle is done, the parameters must be inside the available display area.
trans_mode | Transformation mode.

void VirtualDisplay::BitBlit | ( | XYDIM | dest_x,
 |  | XYDIM | dest_y,
 |  | const BitmapRes & | bmp,
 |  | const Rect & | clip_rect,
 |  | UINT8 | trans_mode = 0
 | ) |

Blits a bitmap on the specified position.

Parameters:
dest_x | x-position where the bitmap should be blitted.
dest_y | y-position where the bitmap should be blitted.
bmp | Source bitmap.
clip_rect | Clipping rectangle, so that it is also possible to blit only parts of the bitmap. Note: no check for the clipping rectangle is done, the parameters must be inside the available display area.
trans_mode | Transformation mode.

ControlArg VirtualDisplay::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) |

See also:
AbstractDevice::Control

ControlArg VirtualDisplay::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) |

See also:
AbstractDevice::Control

ControlArg VirtualDisplay::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) |

See also:
AbstractDevice::Control

ControlArg VirtualDisplay::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) |

See also:
AbstractDevice::Control

ControlArg VirtualDisplay::Control | ( | INT | command,
 |  | ControlArg | arg
 | ) |

See also:
AbstractDevice::Control

ColorValue VirtualDisplay::ConvertToColorValue | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha
 | ) | const

Converts a color specified by it's red-, green- and blue-parts to a display-specific color-value.

See also:
SetColorValue()

GetColorValue()

ColorValue VirtualDisplay::ConvertToColorValue | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha
 | ) | const

Converts a color specified by it's red-, green- and blue-parts to a display-specific color-value.

See also:
SetColorValue()

GetColorValue()

ColorValue VirtualDisplay::ConvertToColorValue | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha
 | ) | const

Converts a color specified by it's red-, green- and blue-parts to a display-specific color-value.

See also:
SetColorValue()

GetColorValue()

ColorValue VirtualDisplay::ConvertToColorValue | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha
 | ) | const

Converts a color specified by it's red-, green- and blue-parts to a display-specific color-value.

See also:
SetColorValue()

GetColorValue()

ColorValue VirtualDisplay::ConvertToColorValue | ( | UINT8 | red,
 |  | UINT8 | green,
 |  | UINT8 | blue,
 |  | UINT8 | alpha
 | ) | const

Converts a color specified by it's red-, green- and blue-parts to a display-specific color-value.

See also:
SetColorValue()

GetColorValue()

void VirtualDisplay::DrawChar | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const Glyph & | glyph,
 |  | INT | height
 | ) |

Draws a glyph at the position x and y. Note that no clipping is done, hence it is not allowed to invoke this method if the glyph is not fully visible.

void VirtualDisplay::DrawChar | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const Glyph & | glyph,
 |  | INT | height
 | ) |

Draws a glyph at the position x and y. Note that no clipping is done, hence it is not allowed to invoke this method if the glyph is not fully visible.

void VirtualDisplay::DrawChar | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const Glyph & | glyph,
 |  | INT | height
 | ) |

Draws a glyph at the position x and y. Note that no clipping is done, hence it is not allowed to invoke this method if the glyph is not fully visible.

void VirtualDisplay::DrawChar | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const Glyph & | glyph,
 |  | INT | height
 | ) |

Draws a glyph at the position x and y. Note that no clipping is done, hence it is not allowed to invoke this method if the glyph is not fully visible.

void VirtualDisplay::DrawChar | ( | XYDIM | x,
 |  | XYDIM | y,
 |  | const Glyph & | glyph,
 |  | INT | height
 | ) |

Draws a glyph at the position x and y. Note that no clipping is done, hence it is not allowed to invoke this method if the glyph is not fully visible.

void VirtualDisplay::FillRect ( const Rect & rect )

Fills a rectangle with the current set color. Note: no clipping is done, the parameters must be inside the available display area.

void VirtualDisplay::FillRect ( const Rect & rect )

Fills a rectangle with the current set color. Note: no clipping is done, the parameters must be inside the available display area.

void VirtualDisplay::FillRect ( const Rect & rect )

Fills a rectangle with the current set color. Note: no clipping is done, the parameters must be inside the available display area.

void VirtualDisplay::FillRect ( const Rect & rect )

Fills a rectangle with the current set color. Note: no clipping is done, the parameters must be inside the available display area.

void VirtualDisplay::FillRect ( const Rect & rect )

Fills a rectangle with the current set color. Note: no clipping is done, the parameters must be inside the available display area.

BOOLEAN VirtualDisplay::GetAlphaBlendingMode ( ) const [inline]

Returns:
the current alpha blending mode, TRUE if AlphaMaskBlending is used, FALSE otherwise.

BOOLEAN VirtualDisplay::GetAlphaBlendingMode ( ) const [inline]

Returns:
the current alpha blending mode, TRUE if AlphaMaskBlending is used, FALSE otherwise.

BOOLEAN VirtualDisplay::GetAlphaBlendingMode ( ) const [inline]

Returns:
the current alpha blending mode, TRUE if AlphaMaskBlending is used, FALSE otherwise.

BOOLEAN VirtualDisplay::GetAlphaBlendingMode ( ) const [inline]

Returns:
the current alpha blending mode, TRUE if AlphaMaskBlending is used, FALSE otherwise.

BOOLEAN VirtualDisplay::GetAlphaBlendingMode ( ) const [inline]

Returns:
the current alpha blending mode, TRUE if AlphaMaskBlending is used, FALSE otherwise.

Bitmap* VirtualDisplay::GetBitmap ( ) [inline]

Returns:
Pointer to the bitmap which represents the display.

Bitmap* VirtualDisplay::GetBitmap ( ) [inline]

Returns:
Pointer to the bitmap which represents the display.

Bitmap* VirtualDisplay::GetBitmap ( ) [inline]

Returns:
Pointer to the bitmap which represents the display.

Bitmap* VirtualDisplay::GetBitmap ( ) [inline]

Returns:
Pointer to the bitmap which represents the display.

Bitmap* VirtualDisplay::GetBitmap ( ) [inline]

Returns:
Pointer to the bitmap which represents the display.

const Rect& VirtualDisplay::GetBlitRect ( ) const [inline]

Returns:
Blitting rectangle.

const Rect& VirtualDisplay::GetBlitRect ( ) const [inline]

Returns:
Blitting rectangle.

const Rect& VirtualDisplay::GetBlitRect ( ) const [inline]

Returns:
Blitting rectangle.

const Rect& VirtualDisplay::GetBlitRect ( ) const [inline]

Returns:
Blitting rectangle.

const Rect& VirtualDisplay::GetBlitRect ( ) const [inline]

Returns:
Blitting rectangle.

Color VirtualDisplay::GetColor ( ) const [inline]

Color VirtualDisplay::GetColor ( ) const [inline]

Color VirtualDisplay::GetColor ( ) const [inline]

Color VirtualDisplay::GetColor ( ) const [inline]

Color VirtualDisplay::GetColor ( ) const [inline]

ColorValue VirtualDisplay::GetColorValue ( ) const [inline]

ColorValue VirtualDisplay::GetColorValue ( ) const [inline]

ColorValue VirtualDisplay::GetColorValue ( ) const [inline]

ColorValue VirtualDisplay::GetColorValue ( ) const [inline]

ColorValue VirtualDisplay::GetColorValue ( ) const [inline]

XYDIM VirtualDisplay::GetHeight ( ) const [inline]

Returns:
Height of the display in pixels.

XYDIM VirtualDisplay::GetHeight ( ) const [inline]

Returns:
Height of the display in pixels.

XYDIM VirtualDisplay::GetHeight ( ) const [inline]

Returns:
Height of the display in pixels.

XYDIM VirtualDisplay::GetHeight ( ) const [inline]

Returns:
Height of the display in pixels.

XYDIM VirtualDisplay::GetHeight ( ) const [inline]

Returns:
Height of the display in pixels.

virtual const WCHAR* VirtualDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

virtual const WCHAR* VirtualDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

virtual const WCHAR* VirtualDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

virtual const WCHAR* VirtualDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

const WCHAR * VirtualDisplay::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Implements AbstractDevice.

Reimplemented in DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

Color VirtualDisplay::GetPixelColor | ( | XYDIM | x,
 |  | XYDIM | y
 | ) | const

Returns the color of the pixel on position x, y.

Color VirtualDisplay::GetPixelColor | ( | XYDIM | x,
 |  | XYDIM | y
 | ) | const

Returns the color of the pixel on position x, y.

Color VirtualDisplay::GetPixelColor | ( | XYDIM | x,
 |  | XYDIM | y
 | ) | const

Returns the color of the pixel on position x, y.

Color VirtualDisplay::GetPixelColor | ( | XYDIM | x,
 |  | XYDIM | y
 | ) | const

Returns the color of the pixel on position x, y.

Color VirtualDisplay::GetPixelColor | ( | XYDIM | x,
 |  | XYDIM | y
 | ) | const

Returns the color of the pixel on position x, y.

INT VirtualDisplay::GetScanlineAtomCount ( ) const [inline]

Returns the number of atoms of a display-scanline.

INT VirtualDisplay::GetScanlineAtomCount ( ) const [inline]

Returns the number of atoms of a display-scanline.

INT VirtualDisplay::GetScanlineAtomCount ( ) const [inline]

Returns the number of atoms of a display-scanline.

INT VirtualDisplay::GetScanlineAtomCount ( ) const [inline]

Returns the number of atoms of a display-scanline.

INT VirtualDisplay::GetScanlineAtomCount ( ) const [inline]

Returns the number of atoms of a display-scanline.

Type VirtualDisplay::GetType ( ) [inline]

Returns:
Type of the display (Monochrome, Planes, Bits Per Pixel, ...).

Type VirtualDisplay::GetType ( ) [inline]

Returns:
Type of the display (Monochrome, Planes, Bits Per Pixel, ...).

Type VirtualDisplay::GetType ( ) [inline]

Returns:
Type of the display (Monochrome, Planes, Bits Per Pixel, ...).

Type VirtualDisplay::GetType ( ) [inline]

Returns:
Type of the display (Monochrome, Planes, Bits Per Pixel, ...).

Type VirtualDisplay::GetType ( ) [inline]

Returns:
Type of the display (Monochrome, Planes, Bits Per Pixel, ...).

XYDIM VirtualDisplay::GetWidth ( ) const [inline]

Returns:
Width of the display in pixels.

XYDIM VirtualDisplay::GetWidth ( ) const [inline]

Returns:
Width of the display in pixels.

XYDIM VirtualDisplay::GetWidth ( ) const [inline]

Returns:
Width of the display in pixels.

XYDIM VirtualDisplay::GetWidth ( ) const [inline]

Returns:
Width of the display in pixels.

XYDIM VirtualDisplay::GetWidth ( ) const [inline]

Returns:
Width of the display in pixels.

void VirtualDisplay::Init | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

void VirtualDisplay::Init | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

void VirtualDisplay::Init | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

void VirtualDisplay::Init | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

void VirtualDisplay::Init | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

void VirtualDisplay::Init | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

void VirtualDisplay::Init | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

void VirtualDisplay::Init | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

void VirtualDisplay::Init | ( | Bitmap * | bitmap,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE
 | ) |

void VirtualDisplay::Init | ( | XYDIM | width,
 |  | XYDIM | height,
 |  | INT | bits_per_pixel,
 |  | BOOLEAN | planes = FALSE,
 |  | DDrvAtomPtr | buffer = 0
 | ) |

Parameters:
width | Width in pixels.
height | Height in pixels.
bits_per_pixel | Number of bits used per pixel.
planes | Organization of display-buffer: TRUE means organized as planes, FALSE means organized as bits per pixel.
buffer | If buffer is 0 (= default) the display-device uses the buffer provided by VirtualDisplayConfig::GetFrameBuffer. In APOXI it is possible to use virtual display-devices, which allow a device-context to drawing on a virtual display. For virtual display devices buffer must point to the display buffer, where the drawing operations should be done.

virtual void VirtualDisplay::Refresh ( ) [virtual]

Refreshes the display area specified by the blitting-rectangle (see VirtualDisplay::SetBlitRect and VirtualDisplay::GetBlitRect) and resets the blitting-rectangle to an empty state.

Reimplemented in DefaultDisplay, Display, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

virtual void VirtualDisplay::Refresh ( ) [virtual]

Refreshes the display area specified by the blitting-rectangle (see VirtualDisplay::SetBlitRect and VirtualDisplay::GetBlitRect) and resets the blitting-rectangle to an empty state.

Reimplemented in DefaultDisplay, Display, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

virtual void VirtualDisplay::Refresh ( ) [virtual]

Refreshes the display area specified by the blitting-rectangle (see VirtualDisplay::SetBlitRect and VirtualDisplay::GetBlitRect) and resets the blitting-rectangle to an empty state.

Reimplemented in DefaultDisplay, Display, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

virtual void VirtualDisplay::Refresh ( ) [virtual]

Refreshes the display area specified by the blitting-rectangle (see VirtualDisplay::SetBlitRect and VirtualDisplay::GetBlitRect) and resets the blitting-rectangle to an empty state.

Reimplemented in DefaultDisplay, Display, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void VirtualDisplay::Refresh ( ) [virtual]

Refreshes the display area specified by the blitting-rectangle (see VirtualDisplay::SetBlitRect and VirtualDisplay::GetBlitRect) and resets the blitting-rectangle to an empty state.

Reimplemented in DefaultDisplay, Display, DefaultDisplay, DefaultDisplay, DefaultDisplay, DefaultDisplay, and DefaultDisplay.

void VirtualDisplay::Scroll | ( | const Rect & | rect,
 |  | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

Scrolls a rectangular area.

Parameters:
rect | Area to be scrolled.
dx | Number of pixels to be scrolled horizontally.
dy | Number of pixels to be scrolled vertically.

void VirtualDisplay::Scroll | ( | const Rect & | rect,
 |  | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

Scrolls a rectangular area.

Parameters:
rect | Area to be scrolled.
dx | Number of pixels to be scrolled horizontally.
dy | Number of pixels to be scrolled vertically.

void VirtualDisplay::Scroll | ( | const Rect & | rect,
 |  | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

Scrolls a rectangular area.

Parameters:
rect | Area to be scrolled.
dx | Number of pixels to be scrolled horizontally.
dy | Number of pixels to be scrolled vertically.

void VirtualDisplay::Scroll | ( | const Rect & | rect,
 |  | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

Scrolls a rectangular area.

Parameters:
rect | Area to be scrolled.
dx | Number of pixels to be scrolled horizontally.
dy | Number of pixels to be scrolled vertically.

void VirtualDisplay::Scroll | ( | const Rect & | rect,
 |  | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

Scrolls a rectangular area.

Parameters:
rect | Area to be scrolled.
dx | Number of pixels to be scrolled horizontally.
dy | Number of pixels to be scrolled vertically.

void VirtualDisplay::SetAlphaBlendingMode ( BOOLEAN mode ) [inline]

Sets the alpha blending mode.

Parameters:
mode if TRUE, MaskAlphaBlending is used, ImmediateAlphaBlending otherwise.

void VirtualDisplay::SetAlphaBlendingMode ( BOOLEAN mode ) [inline]

Sets the alpha blending mode.

Parameters:
mode if TRUE, MaskAlphaBlending is used, ImmediateAlphaBlending otherwise.

void VirtualDisplay::SetAlphaBlendingMode ( BOOLEAN mode ) [inline]

Sets the alpha blending mode.

Parameters:
mode if TRUE, MaskAlphaBlending is used, ImmediateAlphaBlending otherwise.

void VirtualDisplay::SetAlphaBlendingMode ( BOOLEAN mode ) [inline]

Sets the alpha blending mode.

Parameters:
mode if TRUE, MaskAlphaBlending is used, ImmediateAlphaBlending otherwise.

void VirtualDisplay::SetAlphaBlendingMode ( BOOLEAN mode ) [inline]

Sets the alpha blending mode.

Parameters:
mode if TRUE, MaskAlphaBlending is used, ImmediateAlphaBlending otherwise.

void VirtualDisplay::SetBlitRect ( const Rect & rect = Rect() ) [inline]

Parameters:
rect Rectangle which describes the blitting rectangle. The blitting rectangle describes the area which is copied from the frame buffer to the phyisical display in VirtualDisplay::Refresh.

void VirtualDisplay::SetBlitRect ( const Rect & rect = Rect() ) [inline]

Parameters:
rect Rectangle which describes the blitting rectangle. The blitting rectangle describes the area which is copied from the frame buffer to the phyisical display in VirtualDisplay::Refresh.

void VirtualDisplay::SetBlitRect ( const Rect & rect = Rect() ) [inline]

Parameters:
rect Rectangle which describes the blitting rectangle. The blitting rectangle describes the area which is copied from the frame buffer to the phyisical display in VirtualDisplay::Refresh.

void VirtualDisplay::SetBlitRect ( const Rect & rect = Rect() ) [inline]

Parameters:
rect Rectangle which describes the blitting rectangle. The blitting rectangle describes the area which is copied from the frame buffer to the phyisical display in VirtualDisplay::Refresh.

void VirtualDisplay::SetBlitRect ( const Rect & rect = Rect() ) [inline]

Parameters:
rect Rectangle which describes the blitting rectangle. The blitting rectangle describes the area which is copied from the frame buffer to the phyisical display in VirtualDisplay::Refresh.

void VirtualDisplay::SetColor ( Color color )

void VirtualDisplay::SetColor ( Color color )

void VirtualDisplay::SetColor ( Color color )

void VirtualDisplay::SetColor ( Color color )

void VirtualDisplay::SetColor ( Color color )

void VirtualDisplay::SetColorValue | ( | ColorValue | color_value,
 |  | UINT8 | alpha = 255
 | ) |

void VirtualDisplay::SetColorValue | ( | ColorValue | color_value,
 |  | UINT8 | alpha = 255
 | ) |

void VirtualDisplay::SetColorValue | ( | ColorValue | color_value,
 |  | UINT8 | alpha = 255
 | ) |

void VirtualDisplay::SetColorValue | ( | ColorValue | color_value,
 |  | UINT8 | alpha = 255
 | ) |

void VirtualDisplay::SetColorValue | ( | ColorValue | color_value,
 |  | UINT8 | alpha = 255
 | ) |

Parameters:
alpha = 255

void VirtualDisplay::SetPixel | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

Sets a pixel on the position x and y. Note: no clipping is done, the parameters must be inside the available display area.

void VirtualDisplay::SetPixel | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

Sets a pixel on the position x and y. Note: no clipping is done, the parameters must be inside the available display area.

void VirtualDisplay::SetPixel | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

Sets a pixel on the position x and y. Note: no clipping is done, the parameters must be inside the available display area.

void VirtualDisplay::SetPixel | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

Sets a pixel on the position x and y. Note: no clipping is done, the parameters must be inside the available display area.

void VirtualDisplay::SetPixel | ( | XYDIM | x,
 |  | XYDIM | y
 | ) |

Sets a pixel on the position x and y. Note: no clipping is done, the parameters must be inside the available display area.

The documentation for this class was generated from the following files:
  • Devices/BP30/VirtualDisplay.hpp
  • Devices/MPE/VirtualDisplay.hpp
  • Devices/MPEU/VirtualDisplay.hpp
  • Devices/SGold/VirtualDisplay.hpp
  • Devices/Win32/VirtualDisplay.hpp
  • Devices/BP30/VirtualDisplay.cpp
  • Devices/MPE/VirtualDisplay.cpp
  • Devices/MPEU/VirtualDisplay.cpp
  • Devices/SGold/VirtualDisplay.cpp
  • Devices/Win32/VirtualDisplay.cpp
Generated on Wed Jan 25 02:20:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VmParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VmParam Struct Reference

#include <Apoxi/Devices/Win32/HostAudioDriver.hpp>

Data Fields

UINT16 | buffer_size
UINT16 * | file_handle
aud_dsp_format_enum | format
UINT8 | handle
aud_media_enum | media
UINT8 | rate
aud_vm_mode_enum | vm_mode

Field Documentation

UINT16 VmParam::buffer_size

UINT16* VmParam::file_handle

aud_dsp_format_enum VmParam::format

UINT8 VmParam::handle

aud_media_enum VmParam::media

UINT8 VmParam::rate

aud_vm_mode_enum VmParam::vm_mode

The documentation for this struct was generated from the following file:
  • Devices/Win32/HostAudioDriver.hpp
Generated on Wed Jan 25 02:20:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VoiceMemoApp Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VoiceMemoApp Class Reference
[VoiceMemoApp]

#include <Applications/VoiceMemo/VoiceMemoApp.hpp>

Collaboration diagram for VoiceMemoApp:

[legend]

Public Member Functions

void | OnErrorNotification (const SharedPtr< AudioActiveReference > &)
virtual ServiceResult | PauseRecording ()
Service to pause a voice memo recording.
virtual ServiceResult | ResumeRecording ()
Service to resume a paused recording.
virtual ServiceResult | StartRecording (SharedPtr< AudioActiveReference > &voicememo_ref)
Service for recording voice memo used by other applications.
virtual ServiceResult | StopRecording ()
Service to stop recording of voice memo.
virtual | ~VoiceMemoApp ()
Destructor.

Static Public Member Functions

static VoiceMemoApp * | GetInstance ()

Protected Member Functions

virtual void | OnClose ()
virtual BOOLEAN | OnFeatureTriggered (const FeatureID &feature_id)
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnOpen ()
virtual void | OnStartup ()

Constructor & Destructor Documentation

VoiceMemoApp::~VoiceMemoApp ( ) [virtual]

Destructor.

Member Function Documentation

VoiceMemoApp * VoiceMemoApp::GetInstance ( ) [static]

void VoiceMemoApp::OnClose ( ) [protected, virtual]

See also:
MmiApplication::OnClose

void VoiceMemoApp::OnErrorNotification ( const SharedPtr< AudioActiveReference > & )

BOOLEAN VoiceMemoApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual]

BOOLEAN VoiceMemoApp::OnMessage ( const Message & msg ) [protected, virtual]

See also:
MmiApplication::OnMessage

void VoiceMemoApp::OnOpen ( ) [protected, virtual]

See also:
MmiApplication::OnOpen

void VoiceMemoApp::OnStartup ( ) [protected, virtual]

ServiceResult VoiceMemoApp::PauseRecording ( ) [virtual]

Service to pause a voice memo recording.

ServiceResult VoiceMemoApp::ResumeRecording ( ) [virtual]

Service to resume a paused recording.

ServiceResult VoiceMemoApp::StartRecording ( SharedPtr< AudioActiveReference > & voicememo_ref ) [virtual]

Service for recording voice memo used by other applications.

ServiceResult VoiceMemoApp::StopRecording ( ) [virtual]

Service to stop recording of voice memo.

The documentation for this class was generated from the following files:
  • Applications/VoiceMemo/VoiceMemoApp.hpp
  • Applications/VoiceMemo/VoiceMemoApp.cpp
Generated on Wed Jan 25 02:20:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VoiceMemoAudioDevice Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VoiceMemoAudioDevice Class Reference

#include <Apoxi/Devices/Win32/VoiceMemoAudioDevice.hpp>

Inheritance diagram for VoiceMemoAudioDevice:

[legend]
Collaboration diagram for VoiceMemoAudioDevice:

[legend]

Public Types

enum | AudioVmMode { VmModeStandby, VmModeTch }
VM mode. More...
enum | DspFormat { DspFormatFullRate, DspFormatAmr }
Available DSP formats. More...
enum | MediaType { MediaTypeFfs, MediaRam, MediaMmc }
Available media types. More...
enum Rate {
Rate0, Rate1, Rate2, Rate3,
Rate4, Rate5, Rate6, Rate7
}
Available Rates. More...
enum | VmPlayMode { VmModePlayback, VmModeRec }
Mode. More...

Public Member Functions

virtual const WCHAR * | GetName () const
virtual AudioReturnCode | Init (Priority prio)
void | SetStartParam (const StartParam *p_start_param)
virtual AudioReturnCode | Start (BOOLEAN auto_release=TRUE)
virtual AudioReturnCode | Stop (UINT8 channel=0)
VoiceMemoAudioDevice (VmPlayMode vm_play_mode=VmModePlayback)
virtual | ~VoiceMemoAudioDevice ()

Data Structures

struct | StartParam
Start paramter. More...

Detailed Description

Class VoiceMemoAudioDevice
This class is used for recording and playback of voice.
The voice memo functionality can be used in both Stand-by and Tch26 mode. The mode is defined as a parameter in the starting methods. In Stand-by, it is possible to record from the microphone and playback to the earpiece. In Tch26 mode it is possible to record and playback both in uplink and downlink direction.

Note: Do not use audio interface given by the *AudioDevices* header files as they are outdated and will be removed.

Member Enumeration Documentation

enum VoiceMemoAudioDevice::AudioVmMode

VM mode.

Enumerator:
VmModeStandby | The voice memo shall be recorded in Stand-by mode.
VmModeTch | The voice memo shall be recorded in Tch26 mode.

enum VoiceMemoAudioDevice::DspFormat

Available DSP formats.

Enumerator:
DspFormatFullRate | Format full rate.
DspFormatAmr | Format AMR.

enum VoiceMemoAudioDevice::MediaType

Available media types.

Enumerator:
MediaTypeFfs | Media type FFS.
MediaRam | Media type RAM.
MediaMmc | Media type MMC.

enum VoiceMemoAudioDevice::Rate

Available Rates.

Enumerator:
Rate0 | Rate 0 - 4,75 kbit/s.
Rate1 | Rate 1.
Rate2 | Rate 2.
Rate3 | Rate 3.
Rate4 | Rate 4.
Rate5 | Rate 5.
Rate6 | Rate 6.
Rate7 | Rate 7 - 12,2 kbit/s.

enum VoiceMemoAudioDevice::VmPlayMode

Mode.

Enumerator:
VmModePlayback | Playback mode.
VmModeRec | Record mode.

Constructor & Destructor Documentation

VoiceMemoAudioDevice::VoiceMemoAudioDevice ( VmPlayMode vm_play_mode = VmModePlayback )

Constructor
An VoiceMemoAudioDevice instance only used for record or playback depending on vm_play_mode.

Parameters:
vm_play_mode Play mode.

VoiceMemoAudioDevice::~VoiceMemoAudioDevice ( ) [virtual]

Member Function Documentation

const WCHAR * VoiceMemoAudioDevice::GetName ( ) const [virtual]

See also:
AbstractDevice::GetName

Reimplemented from GenericAudioDevice.

VoiceMemoAudioDevice::AudioReturnCode VoiceMemoAudioDevice::Init ( Priority prio ) [virtual]

See also:
AudioDevice::Init

void VoiceMemoAudioDevice::SetStartParam ( const StartParam * p_start_param )

Set start parameter.

Parameters:
p_start_param,: Pointer to start parameter structure.

VoiceMemoAudioDevice::AudioReturnCode VoiceMemoAudioDevice::Start ( BOOLEAN auto_release = TRUE ) [virtual]

See also:
GenericAudioDevice::Start

Reimplemented from GenericAudioDevice.

VoiceMemoAudioDevice::AudioReturnCode VoiceMemoAudioDevice::Stop ( UINT8 channel = 0 ) [virtual]

Stops Recording resp. play playback (refer to constructor) see Also GenericAudioDevice::Stop

Reimplemented from GenericAudioDevice.

The documentation for this class was generated from the following files:
  • Devices/Win32/VoiceMemoAudioDevice.hpp
  • Devices/Win32/VoiceMemoAudioDevice.cpp
Generated on Wed Jan 25 02:20:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VoiceMemoAudioDevice::StartParam Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
VoiceMemoAudioDevice::StartParam

VoiceMemoAudioDevice::StartParam Struct Reference

Start paramter. More...

#include <Apoxi/Devices/Win32/VoiceMemoAudioDevice.hpp>

Data Fields

AudioVmMode audio_vm_mode
Mode.
UINT16 * | file_handle
UINT16 | file_handle_size
MediaType media_type
Mode.
DspFormat dsp_format
used vm_play_mode == FALSE (see constructor)
Rate rate

Detailed Description

Start paramter.

Field Documentation

AudioVmMode VoiceMemoAudioDevice::StartParam::audio_vm_mode

Mode.

DspFormat VoiceMemoAudioDevice::StartParam::dsp_format

used vm_play_mode == FALSE (see constructor)

UINT16* VoiceMemoAudioDevice::StartParam::file_handle

UINT16 VoiceMemoAudioDevice::StartParam::file_handle_size

MediaType VoiceMemoAudioDevice::StartParam::media_type

Mode.

Rate VoiceMemoAudioDevice::StartParam::rate

used vm_play_mode == TRUE (see constructor)
Rate is not used if Format == DspFormatFullRate

The documentation for this struct was generated from the following file:
  • Devices/Win32/VoiceMemoAudioDevice.hpp
Generated on Wed Jan 25 02:20:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VoiceMemoMenuAccessor Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VoiceMemoMenuAccessor Class Reference
[VoiceMemoApp]

#include <Applications/VoiceMemo/VoiceMemoMenuAccessor.hpp>

Public Member Functions

virtual BOOLEAN | First ()
virtual const WCHAR * | GetHiglightedText ()
virtual const WCHAR * | GetItemText (BOOLEAN highlighted)
void | Init ()
Init method.
virtual BOOLEAN | Next ()
VoiceMemoMenuAccessor ()
Constructor.
virtual | ~VoiceMemoMenuAccessor ()
Destructor.

Constructor & Destructor Documentation

VoiceMemoMenuAccessor::VoiceMemoMenuAccessor ( )

Constructor.

VoiceMemoMenuAccessor::~VoiceMemoMenuAccessor ( ) [virtual]

Destructor.

Member Function Documentation

BOOLEAN VoiceMemoMenuAccessor::First ( ) [virtual]

See also:
AbstractMmiMenuAccessor::First

const WCHAR * VoiceMemoMenuAccessor::GetHiglightedText ( ) [virtual]

See also:
AbstractMmiMenuAccessor::GetHiglightedText

const WCHAR * VoiceMemoMenuAccessor::GetItemText ( BOOLEAN highlighted ) [virtual]

See also:
AbstractMmiMenuAccessor::GetItemText

void VoiceMemoMenuAccessor::Init ( )

Init method.

BOOLEAN VoiceMemoMenuAccessor::Next ( ) [virtual]

See also:
AbstractMmiMenuAccessor::Next

The documentation for this class was generated from the following files:
  • Applications/VoiceMemo/VoiceMemoMenuAccessor.hpp
  • Applications/VoiceMemo/VoiceMemoMenuAccessor.cpp
Generated on Wed Jan 25 02:20:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VoiceMemoRecordWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VoiceMemoRecordWin Class Reference
[VoiceMemoApp]

#include <Applications/VoiceMemo/VoiceMemoRecordWin.hpp>

Collaboration diagram for VoiceMemoRecordWin:

[legend]

Public Member Functions

SharedPtr< AudioActiveReference > & GetAudioRef ()
void | Init ()
Init method.
BOOLEAN | PauseRecord ()
Pause Record implementation. Used by service.
SharedPtr< AudioActiveReference > | Record (VoiceMemoAudioReference::Mode mode)
Record implementation. Used by service.
BOOLEAN | ResumeRecord ()
Resume Record implementation. Used by service.
BOOLEAN | StopRecord (VoiceMemoAudioReference::Mode mode)
Stop record implementation. Used by service.
VoiceMemoRecordWin ()
Constructor.
~VoiceMemoRecordWin ()
Destructor.

Protected Member Functions

virtual void | OnClose ()
virtual void | OnLayoutClient ()
virtual BOOLEAN | OnTimeout (const Timer &timer)

Constructor & Destructor Documentation

VoiceMemoRecordWin::VoiceMemoRecordWin ( )

Constructor.

VoiceMemoRecordWin::~VoiceMemoRecordWin ( )

Destructor.

Member Function Documentation

SharedPtr<AudioActiveReference>& VoiceMemoRecordWin::GetAudioRef ( ) [inline]

void VoiceMemoRecordWin::Init ( )

Init method.

void VoiceMemoRecordWin::OnClose ( ) [protected, virtual]

void VoiceMemoRecordWin::OnLayoutClient ( ) [protected, virtual]

BOOLEAN VoiceMemoRecordWin::OnTimeout ( const Timer & timer ) [protected, virtual]

BOOLEAN VoiceMemoRecordWin::PauseRecord ( )

Pause Record implementation. Used by service.

SharedPtr< AudioActiveReference > VoiceMemoRecordWin::Record ( VoiceMemoAudioReference::Mode mode )

Record implementation. Used by service.

BOOLEAN VoiceMemoRecordWin::ResumeRecord ( )

Resume Record implementation. Used by service.

BOOLEAN VoiceMemoRecordWin::StopRecord ( VoiceMemoAudioReference::Mode mode )

Stop record implementation. Used by service.

The documentation for this class was generated from the following files:
  • Applications/VoiceMemo/VoiceMemoRecordWin.hpp
  • Applications/VoiceMemo/VoiceMemoRecordWin.cpp
Generated on Wed Jan 25 02:20:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VoiceMemoWin Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VoiceMemoWin Class Reference
[VoiceMemoApp]

#include <Applications/VoiceMemo/VoiceMemoWin.hpp>

Collaboration diagram for VoiceMemoWin:

[legend]

Public Member Functions

void | Init ()
To Initialize actions and action accessors.
BOOLEAN | PauseRecord ()
Pause record service method.
SharedPtr< AudioActiveReference > Record ()
Record service implementation.
BOOLEAN | ResumeRecord ()
Resume record service method.
BOOLEAN | StopRecord ()
StopRecord service method.
VoiceMemoWin ()
Constructor.
virtual | ~VoiceMemoWin ()
Destructor.

Protected Member Functions

virtual void | OnActionExecuted (Action *action)
Called when user performs any actions on the window.

Constructor & Destructor Documentation

VoiceMemoWin::VoiceMemoWin ( )

Constructor.

VoiceMemoWin::~VoiceMemoWin ( ) [virtual]

Destructor.

Member Function Documentation

void VoiceMemoWin::Init ( )

To Initialize actions and action accessors.

void VoiceMemoWin::OnActionExecuted ( Action * action ) [protected, virtual]

Called when user performs any actions on the window.

BOOLEAN VoiceMemoWin::PauseRecord ( )

Pause record service method.

SharedPtr< AudioActiveReference > VoiceMemoWin::Record ( )

Record service implementation.

BOOLEAN VoiceMemoWin::ResumeRecord ( )

Resume record service method.

BOOLEAN VoiceMemoWin::StopRecord ( )

StopRecord service method.

The documentation for this class was generated from the following files:
  • Applications/VoiceMemo/VoiceMemoWin.hpp
  • Applications/VoiceMemo/VoiceMemoWin.cpp
Generated on Wed Jan 25 02:20:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrAbortEngineIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrAbortEngineIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrAbortEngineIndArg:

[legend]
Collaboration diagram for VrAbortEngineIndArg:

[legend]

Public Types

enum | { ID = 5007 }

Public Member Functions

VrAbortEngineIndArg ()
~VrAbortEngineIndArg ()

Static Public Member Functions

static const VrAbortEngineIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrAbortEngineIndArg: reflects arguments of signal VR_SIG_ABORT_ENGINE_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrAbortEngineIndArg::VrAbortEngineIndArg ( )

VrAbortEngineIndArg::~VrAbortEngineIndArg ( )

Member Function Documentation

const VrAbortEngineIndArg & VrAbortEngineIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:20:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrEngineParams Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrEngineParams Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrEngineParams.hpp>

Inheritance diagram for VrEngineParams:

[legend]

Public Member Functions

virtual void * | GetNativeParams ()=0
virtual BOOLEAN | SetMaxRecognitionTime (UINT16 time)=0
Set the maximum duration for recognition (in ms).
virtual BOOLEAN | SetMaxSilenceTime (UINT16 time)=0
Set max. time of silence after which recognition is ends (in ms).
virtual BOOLEAN | SetRecognitionMode (VrHandler::VrRecognitionMode mode)=0
Set Recognition mode.

Member Function Documentation

virtual void* VrEngineParams::GetNativeParams ( ) [pure virtual]

Implemented in DummyVrEngineParams, and TelecaVrEngineParams.

virtual BOOLEAN VrEngineParams::SetMaxRecognitionTime ( UINT16 time ) [pure virtual]

Set the maximum duration for recognition (in ms).

Implemented in DummyVrEngineParams, and TelecaVrEngineParams.

virtual BOOLEAN VrEngineParams::SetMaxSilenceTime ( UINT16 time ) [pure virtual]

Set max. time of silence after which recognition is ends (in ms).

Implemented in DummyVrEngineParams, and TelecaVrEngineParams.

virtual BOOLEAN VrEngineParams::SetRecognitionMode ( VrHandler::VrRecognitionMode mode ) [pure virtual]

Set Recognition mode.

Implemented in DummyVrEngineParams, and TelecaVrEngineParams.

The documentation for this class was generated from the following file:
  • AddOns/VoiceRecognition/VrEngineParams.hpp
Generated on Wed Jan 25 02:20:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrErrorIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrErrorIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrErrorIndArg:

[legend]
Collaboration diagram for VrErrorIndArg:

[legend]

Public Types

enum | { ID = 5010 }

Public Member Functions

const VrErrorCode & | GetErrorCode () const
VrErrorIndArg ()
VrErrorIndArg (const VrErrorCode &error_code)
~VrErrorIndArg ()

Static Public Member Functions

static const VrErrorIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrErrorIndArg: reflects arguments of signal VR_ERROR_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrErrorIndArg::VrErrorIndArg ( const VrErrorCode & error_code )

VrErrorIndArg::VrErrorIndArg ( )

VrErrorIndArg::~VrErrorIndArg ( )

Member Function Documentation

const VrErrorIndArg & VrErrorIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const VrErrorCode& VrErrorIndArg::GetErrorCode ( void ) const [inline]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:20:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrErrorMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrErrorMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrErrorMsg:

[legend]
Collaboration diagram for VrErrorMsg:

[legend]

Public Types

enum | { ID = 19002 }

Public Member Functions

virtual Message * | Clone () const
const VrErrorCode & | GetErrorCode () const
virtual const MsgMetaData & | GetMetaData () const
VrErrorMsg (ExecutionContext *context, const VrErrorCode &error_code)
virtual | ~VrErrorMsg ()

Detailed Description

VrErrorMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrErrorMsg::VrErrorMsg | ( | ExecutionContext * | context,
 |  | const VrErrorCode & | error_code
 | ) |

VrErrorMsg::~VrErrorMsg ( ) [virtual]

Member Function Documentation

Message * VrErrorMsg::Clone ( ) const [virtual]

Implements Message.

const VrErrorCode& VrErrorMsg::GetErrorCode ( void ) const [inline]

const MsgMetaData & VrErrorMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:20:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrG2AResultIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrG2AResultIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrG2AResultIndArg:

[legend]
Collaboration diagram for VrG2AResultIndArg:

[legend]

Public Types

enum | { ID = 5012 }

Public Member Functions

UINT16 * | GetTemplateData () const
UINT32 | GetTemplateDataLength () const
VrG2AResultIndArg ()
VrG2AResultIndArg (UINT16 *template_data, UINT32 template_data_length)
~VrG2AResultIndArg ()

Static Public Member Functions

static const VrG2AResultIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrG2AResultIndArg: reflects arguments of signal VR_SIG_G2A_RESULT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrG2AResultIndArg::VrG2AResultIndArg | ( | UINT16 * | template_data,
 |  | UINT32 | template_data_length
 | ) |

VrG2AResultIndArg::VrG2AResultIndArg ( )

VrG2AResultIndArg::~VrG2AResultIndArg ( )

Member Function Documentation

const VrG2AResultIndArg & VrG2AResultIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT16* VrG2AResultIndArg::GetTemplateData ( ) const [inline]

UINT32 VrG2AResultIndArg::GetTemplateDataLength ( ) const [inline]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:20:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrHandler Class Reference
[Voice Recognition]

Interface for Apoxi VR usage. More...

#include <Apoxi/AddOns/VoiceRecognition/VrHandler.hpp>

Collaboration diagram for VrHandler:

[legend]

Public Types

enum | { ID = VrHandlerId }
enum | VrApiRc { VrSuccess, VrFailed }
Return codes for methods of this class. More...
enum VrCommand {
Digit0, Digit1, Digit2, Digit3,
Digit4, Digit5, Digit6, Digit7,
Digit8, Digit9, Dial, Cancel,
Clear, TrainedCommand, InvalidCommand
}
Predefined VR commands. More...
enum | VrCommandSet { Digits, DigitDialing, Complete }
Sets of predefined commands. More...
enum | VrRecognitionMode { IsolatedWord, ConnectedWord }
Recognition modes. More...

Public Member Functions

VrApiRc Abort ()
Abort currently ongoing training or recognition process. This method does a hard abort of any ongoing process.
void | CreateTemplate (const WString &client_name, const WString &text)
Create template based on a given string using G2A. With G2A speaker independent templates can be created out of a given text. This text must be between 3 and 40 characters long.
VrApiRc | GetAppTemplates (const WString &client_name, Vector< UINT16 > &template_ids)
Return templates of a client, client_name acts as key The ids of the templates belonging to the given client are added to the given vector. The vector must be initialised. It may contain ids before. Template ids are just added to the vector, the vector must be initialised before.
VrCommand | GetCommand (UINT16 template_id)
Return the command behind a predefined template id.
VrApiRc | GetCommandTemplates (VrCommandSet set, Vector< UINT16 > &template_ids)
Return templates for a set of fixed commands.
virtual HandlerId | GetHandlerId () const
Returns the handler's identifier as specified in the anonymous enumeration.
VrApiRc InitVr ()
Initialize Voice Recognition.
BOOLEAN | IsSupported (VrProperty property)
Check if current VR engine supports a function. This method checks if the used VR engine supports a certain function or not.
VrApiRc | PlayTemplate (UINT16 template_id)
Playback trained template.
VrApiRc | RemoveAllTemplates (const WString &client_name)
Delete all templates belonging to a client.
VrApiRc | RemoveTemplate (const WString &client_name, UINT16 template_id)
Remove template.
void | StartRecognition (const Vector< UINT16 > &id_set, VrRecognitionMode mode=ConnectedWord, UINT16 max_time=700, UINT32 max_silence=80)
Start recognition for a set of templates Kicks off an actual recognition process.
void | StartRecording ()
Starts recording for training or recognition after prompt. Starts voice recording for the currently ongoing recognition or training process. This method has to be called by the client after prompting the user to start speaking is done.
void | StartTraining (const WString &client_name)
Start training for a user defined command.
VrApiRc StopRecognition ()
Stop repeated mode recognition after prompt request, feature not yet finished Stops currently ongoing recognition process. This method can be called by a client whilst an recognition process to stop it (e.g. if the received results are sufficent).
VrHandler ()
Creates a new handler instance. This constructor creates a new instance of VrHandler. The VR module is initialized if not done before.
virtual | ~VrHandler ()
Destructs an handler instance, nothing happening (in VR point of view).

Static Public Member Functions

static BOOLEAN | Startup ()
Called by Stack Control on system startup to do some init stuff.

Protected Member Functions

VrApiRc | Abort (BOOLEAN send_message)
void | Error (VrErrorCode error_code)
void | Reset ()

Detailed Description

Interface for Apoxi VR usage.

VrHandler enables usage of voice recognition. Client who want to use voice recgnition have to use this interface. The code samples in the method's documentation show the usage of voice recognition.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrHandler.hpp
  • AddOns/VoiceRecognition/VrHandler.cpp
Generated on Wed Jan 25 02:20:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrInitCnfArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrInitCnfArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrInitCnfArg:

[legend]
Collaboration diagram for VrInitCnfArg:

[legend]

Public Types

enum | { ID = 5001 }

Public Member Functions

VrInitCnfArg ()
~VrInitCnfArg ()

Static Public Member Functions

static const VrInitCnfArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrInitCnfArg: reflects arguments of signal VR_INIT_CNF

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrInitCnfArg::VrInitCnfArg ( )

VrInitCnfArg::~VrInitCnfArg ( )

Member Function Documentation

const VrInitCnfArg & VrInitCnfArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:20:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrIntrmRecResultIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrIntrmRecResultIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrIntrmRecResultIndArg:

[legend]
Collaboration diagram for VrIntrmRecResultIndArg:

[legend]

Public Types

enum | { ID = 5004 }

Public Member Functions

UINT32 | GetQuality () const
UINT32 | GetTemplateId () const
VrIntrmRecResultIndArg ()
VrIntrmRecResultIndArg (UINT32 template_id, UINT32 quality)
~VrIntrmRecResultIndArg ()

Static Public Member Functions

static const VrIntrmRecResultIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrInitCnfArg: reflects arguments of signal VR_INTRM_REC_RESULT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrIntrmRecResultIndArg::VrIntrmRecResultIndArg | ( | UINT32 | template_id,
 |  | UINT32 | quality
 | ) |

VrIntrmRecResultIndArg::VrIntrmRecResultIndArg ( )

VrIntrmRecResultIndArg::~VrIntrmRecResultIndArg ( )

Member Function Documentation

const VrIntrmRecResultIndArg & VrIntrmRecResultIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT32 VrIntrmRecResultIndArg::GetQuality ( ) const [inline]

UINT32 VrIntrmRecResultIndArg::GetTemplateId ( ) const [inline]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:20:45 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrLoadTemplateReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrLoadTemplateReqArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrLoadTemplateReqArg:

[legend]
Collaboration diagram for VrLoadTemplateReqArg:

[legend]

Public Types

enum | { ID = 5002 }

Public Member Functions

UINT32 | GetTemplateId () const
VrLoadTemplateReqArg ()
VrLoadTemplateReqArg (UINT32 template_id)
~VrLoadTemplateReqArg ()

Static Public Member Functions

static const VrLoadTemplateReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrInitCnfArg: reflects arguments of signal VR_LOAD_TEMPLATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrLoadTemplateReqArg::VrLoadTemplateReqArg ( UINT32 template_id )

VrLoadTemplateReqArg::VrLoadTemplateReqArg ( )

VrLoadTemplateReqArg::~VrLoadTemplateReqArg ( )

Member Function Documentation

const VrLoadTemplateReqArg & VrLoadTemplateReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT32 VrLoadTemplateReqArg::GetTemplateId ( ) const [inline]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:20:47 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrParamReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrParamReqArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrParamReqArg:

[legend]
Collaboration diagram for VrParamReqArg:

[legend]

Public Types

enum | { ID = 5000 }

Public Member Functions

VrParamReqArg ()
~VrParamReqArg ()

Static Public Member Functions

static const VrParamReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrParamReqArg: reflects VR_SIG_PARAM_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrParamReqArg::VrParamReqArg ( )

VrParamReqArg::~VrParamReqArg ( )

Member Function Documentation

const VrParamReqArg & VrParamReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:20:48 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrPlaybackFinishedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrPlaybackFinishedMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrPlaybackFinishedMsg:

[legend]
Collaboration diagram for VrPlaybackFinishedMsg:

[legend]

Public Types

enum | { ID = 19008 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetTemplateId () const
VrPlaybackFinishedMsg (ExecutionContext *context, UINT32 template_id)
virtual | ~VrPlaybackFinishedMsg ()

Detailed Description

VrRecognitionStoppedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrPlaybackFinishedMsg::VrPlaybackFinishedMsg | ( | ExecutionContext * | context,
 |  | UINT32 | template_id
 | ) |

VrPlaybackFinishedMsg::~VrPlaybackFinishedMsg ( ) [virtual]

Member Function Documentation

Message * VrPlaybackFinishedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrPlaybackFinishedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

UINT32 VrPlaybackFinishedMsg::GetTemplateId ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:20:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrPromptMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrPromptMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrPromptMsg:

[legend]
Collaboration diagram for VrPromptMsg:

[legend]

Public Types

enum | { ID = 19000 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
VrPromptMsg (ExecutionContext *context)
virtual | ~VrPromptMsg ()

Detailed Description

VrPromptMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrPromptMsg::VrPromptMsg ( ExecutionContext * context )

VrPromptMsg::~VrPromptMsg ( ) [virtual]

Member Function Documentation

Message * VrPromptMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrPromptMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:20:52 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrPropertyResultIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrPropertyResultIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrPropertyResultIndArg:

[legend]
Collaboration diagram for VrPropertyResultIndArg:

[legend]

Public Types

enum | { ID = 5013 }

Public Member Functions

const VrProperty & | GetProperty () const
VrPropertyResultIndArg ()
VrPropertyResultIndArg (const VrProperty &property)
~VrPropertyResultIndArg ()

Static Public Member Functions

static const VrPropertyResultIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrPropertyResultIndArg: reflects arguments of signal VR_SIG_PROPERTY_RESULT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrPropertyResultIndArg::VrPropertyResultIndArg ( const VrProperty & property )

VrPropertyResultIndArg::VrPropertyResultIndArg ( )

VrPropertyResultIndArg::~VrPropertyResultIndArg ( )

Member Function Documentation

const VrPropertyResultIndArg & VrPropertyResultIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const VrProperty& VrPropertyResultIndArg::GetProperty ( ) const [inline]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:20:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrRecognitionAbortedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrRecognitionAbortedMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrRecognitionAbortedMsg:

[legend]
Collaboration diagram for VrRecognitionAbortedMsg:

[legend]

Public Types

enum | { ID = 19004 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
VrRecognitionAbortedMsg (ExecutionContext *context)
virtual | ~VrRecognitionAbortedMsg ()

Detailed Description

VrRecognitionAbortedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrRecognitionAbortedMsg::VrRecognitionAbortedMsg ( ExecutionContext * context )

VrRecognitionAbortedMsg::~VrRecognitionAbortedMsg ( ) [virtual]

Member Function Documentation

Message * VrRecognitionAbortedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrRecognitionAbortedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:20:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrRecognitionFailedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrRecognitionFailedMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrRecognitionFailedMsg:

[legend]
Collaboration diagram for VrRecognitionFailedMsg:

[legend]

Public Types

enum | { ID = 19010 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
VrRecognitionFailedMsg (ExecutionContext *context)
virtual | ~VrRecognitionFailedMsg ()

Detailed Description

VrTrainingFailedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrRecognitionFailedMsg::VrRecognitionFailedMsg ( ExecutionContext * context )

VrRecognitionFailedMsg::~VrRecognitionFailedMsg ( ) [virtual]

Member Function Documentation

Message * VrRecognitionFailedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrRecognitionFailedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:20:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrRecognitionStoppedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrRecognitionStoppedMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrRecognitionStoppedMsg:

[legend]
Collaboration diagram for VrRecognitionStoppedMsg:

[legend]

Public Types

enum | { ID = 19006 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
VrRecognitionStoppedMsg (ExecutionContext *context)
virtual | ~VrRecognitionStoppedMsg ()

Detailed Description

VrRecognitionStoppedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrRecognitionStoppedMsg::VrRecognitionStoppedMsg ( ExecutionContext * context )

VrRecognitionStoppedMsg::~VrRecognitionStoppedMsg ( ) [virtual]

Member Function Documentation

Message * VrRecognitionStoppedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrRecognitionStoppedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:20:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrRecogResultIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrRecogResultIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrRecogResultIndArg:

[legend]
Collaboration diagram for VrRecogResultIndArg:

[legend]

Public Types

enum | { ID = 5005 }

Public Member Functions

UINT32 | GetQuality () const
UINT32 | GetTemplateId () const
VrRecogResultIndArg ()
VrRecogResultIndArg (UINT32 template_id, UINT32 quality)
~VrRecogResultIndArg ()

Static Public Member Functions

static const VrRecogResultIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrInitCnfArg: reflects arguments of signal VR_RECOG_RESULT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrRecogResultIndArg::VrRecogResultIndArg | ( | UINT32 | template_id,
 |  | UINT32 | quality
 | ) |

VrRecogResultIndArg::VrRecogResultIndArg ( )

VrRecogResultIndArg::~VrRecogResultIndArg ( )

Member Function Documentation

const VrRecogResultIndArg & VrRecogResultIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT32 VrRecogResultIndArg::GetQuality ( ) const [inline]

UINT32 VrRecogResultIndArg::GetTemplateId ( ) const [inline]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:21:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrResultMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrResultMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrResultMsg:

[legend]
Collaboration diagram for VrResultMsg:

[legend]

Public Types

enum | { ID = 19001 }

Public Member Functions

virtual Message * | Clone () const
const VrHandler::VrCommand & | GetCommand () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetQuality () const
UINT32 | GetTemplateId () const
BOOLEAN | IsLastResult () const
VrResultMsg (ExecutionContext *context, const VrHandler::VrCommand &command, UINT32 template_id, UINT32 quality, BOOLEAN last_result)
virtual | ~VrResultMsg ()

Detailed Description

VrResultMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrResultMsg::VrResultMsg | ( | ExecutionContext * | context,
 |  | const VrHandler::VrCommand & | command,
 |  | UINT32 | template_id,
 |  | UINT32 | quality,
 |  | BOOLEAN | last_result
 | ) |

VrResultMsg::~VrResultMsg ( ) [virtual]

Member Function Documentation

Message * VrResultMsg::Clone ( ) const [virtual]

Implements Message.

const VrHandler::VrCommand& VrResultMsg::GetCommand ( ) const [inline]

const MsgMetaData & VrResultMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

UINT32 VrResultMsg::GetQuality ( ) const [inline]

UINT32 VrResultMsg::GetTemplateId ( ) const [inline]

BOOLEAN VrResultMsg::IsLastResult ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:21:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrSayNameIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrSayNameIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrSayNameIndArg:

[legend]
Collaboration diagram for VrSayNameIndArg:

[legend]

Public Types

enum | { ID = 5003 }

Public Member Functions

VrSayNameIndArg ()
~VrSayNameIndArg ()

Static Public Member Functions

static const VrSayNameIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrInitCnfArg: reflects arguments of signal VR_SAY_NAME_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrSayNameIndArg::VrSayNameIndArg ( )

VrSayNameIndArg::~VrSayNameIndArg ( )

Member Function Documentation

const VrSayNameIndArg & VrSayNameIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:21:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrStackMsgArgTableDestroyTableNode Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrStackMsgArgTableDestroyTableNode Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgTable.hpp>

Inheritance diagram for VrStackMsgArgTableDestroyTableNode:

[legend]
Collaboration diagram for VrStackMsgArgTableDestroyTableNode:

[legend]

Static Public Member Functions

static VrStackMsgArgTableDestroyTableNode * GetInstance ()

Member Function Documentation

VrStackMsgArgTableDestroyTableNode * VrStackMsgArgTableDestroyTableNode::GetInstance ( ) [static]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgTable.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgTable.cpp
Generated on Wed Jan 25 02:21:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrStopRecogIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrStopRecogIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrStopRecogIndArg:

[legend]
Collaboration diagram for VrStopRecogIndArg:

[legend]

Public Types

enum | { ID = 5008 }

Public Member Functions

VrStopRecogIndArg ()
~VrStopRecogIndArg ()

Static Public Member Functions

static const VrStopRecogIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrStopRecogIndArg: reflects arguments of signal VR_SIG_STOP_RECOG_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrStopRecogIndArg::VrStopRecogIndArg ( )

VrStopRecogIndArg::~VrStopRecogIndArg ( )

Member Function Documentation

const VrStopRecogIndArg & VrStopRecogIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:21:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrStoreTemplateReqArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrStoreTemplateReqArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrStoreTemplateReqArg:

[legend]
Collaboration diagram for VrStoreTemplateReqArg:

[legend]

Public Types

enum | { ID = 5009 }

Public Member Functions

UINT8 * | GetPlaybackSamples () const
UINT32 | GetSampleDataLength () const
UINT16 * | GetTemplateData () const
UINT32 | GetTemplateDataLength () const
VrStoreTemplateReqArg ()
VrStoreTemplateReqArg (UINT16 *template_data, UINT32 template_data_length, UINT8 *playback_samples, UINT32 sample_data_length)
~VrStoreTemplateReqArg ()

Static Public Member Functions

static const VrStoreTemplateReqArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrStoreTemplateReqArg: reflects arguments of signal VR_STORE_TEMPLATE_REQ

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrStoreTemplateReqArg::VrStoreTemplateReqArg | ( | UINT16 * | template_data,
 |  | UINT32 | template_data_length,
 |  | UINT8 * | playback_samples,
 |  | UINT32 | sample_data_length
 | ) |

VrStoreTemplateReqArg::VrStoreTemplateReqArg ( )

VrStoreTemplateReqArg::~VrStoreTemplateReqArg ( )

Member Function Documentation

const VrStoreTemplateReqArg & VrStoreTemplateReqArg::Cast ( const StackMsgArgument & arg ) [inline, static]

UINT8* VrStoreTemplateReqArg::GetPlaybackSamples ( ) const [inline]

UINT32 VrStoreTemplateReqArg::GetSampleDataLength ( ) const [inline]

UINT16* VrStoreTemplateReqArg::GetTemplateData ( ) const [inline]

UINT32 VrStoreTemplateReqArg::GetTemplateDataLength ( ) const [inline]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:21:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrTrainingAbortedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrTrainingAbortedMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrTrainingAbortedMsg:

[legend]
Collaboration diagram for VrTrainingAbortedMsg:

[legend]

Public Types

enum | { ID = 19005 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
VrTrainingAbortedMsg (ExecutionContext *context)
virtual | ~VrTrainingAbortedMsg ()

Detailed Description

VrWarningMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrTrainingAbortedMsg::VrTrainingAbortedMsg ( ExecutionContext * context )

VrTrainingAbortedMsg::~VrTrainingAbortedMsg ( ) [virtual]

Member Function Documentation

Message * VrTrainingAbortedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrTrainingAbortedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:21:10 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrTrainingFailedMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrTrainingFailedMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrTrainingFailedMsg:

[legend]
Collaboration diagram for VrTrainingFailedMsg:

[legend]

Public Types

enum | { ID = 19009 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
VrTrainingFailedMsg (ExecutionContext *context)
virtual | ~VrTrainingFailedMsg ()

Detailed Description

VrTrainingFailedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrTrainingFailedMsg::VrTrainingFailedMsg ( ExecutionContext * context )

VrTrainingFailedMsg::~VrTrainingFailedMsg ( ) [virtual]

Member Function Documentation

Message * VrTrainingFailedMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrTrainingFailedMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:21:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrTrainingResultMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrTrainingResultMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrTrainingResultMsg:

[legend]
Collaboration diagram for VrTrainingResultMsg:

[legend]

Public Types

enum | { ID = 19007 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
UINT32 | GetTemplateId () const
VrTrainingResultMsg (ExecutionContext *context, UINT32 template_id)
virtual | ~VrTrainingResultMsg ()

Detailed Description

VrRecognitionStoppedMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrTrainingResultMsg::VrTrainingResultMsg | ( | ExecutionContext * | context,
 |  | UINT32 | template_id
 | ) |

VrTrainingResultMsg::~VrTrainingResultMsg ( ) [virtual]

Member Function Documentation

Message * VrTrainingResultMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrTrainingResultMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

UINT32 VrTrainingResultMsg::GetTemplateId ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:21:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrTrainResultIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrTrainResultIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrTrainResultIndArg:

[legend]
Collaboration diagram for VrTrainResultIndArg:

[legend]

Public Types

enum | { ID = 5006 }

Public Member Functions

VrTrainResultIndArg ()
~VrTrainResultIndArg ()

Static Public Member Functions

static const VrTrainResultIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrInitCnfArg: reflects arguments of signal VR_SIG_TRAIN_RESULT_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrTrainResultIndArg::VrTrainResultIndArg ( )

VrTrainResultIndArg::~VrTrainResultIndArg ( )

Member Function Documentation

const VrTrainResultIndArg & VrTrainResultIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:21:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrWarningIndArg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrWarningIndArg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/VrStackMsgArgs.hpp>

Inheritance diagram for VrWarningIndArg:

[legend]
Collaboration diagram for VrWarningIndArg:

[legend]

Public Types

enum | { ID = 5011 }

Public Member Functions

const VrWarningCode & | GetWarningCode () const
VrWarningIndArg ()
VrWarningIndArg (const VrWarningCode &warning_code)
~VrWarningIndArg ()

Static Public Member Functions

static const VrWarningIndArg & | Cast (const StackMsgArgument &arg)

Friends

class | VrStackMsgArgTableDestroyTableNode

Detailed Description

VrWarningIndArg: reflects arguments of signal VR_WARNING_IND

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrWarningIndArg::VrWarningIndArg ( const VrWarningCode & warning_code )

VrWarningIndArg::VrWarningIndArg ( )

VrWarningIndArg::~VrWarningIndArg ( )

Member Function Documentation

const VrWarningIndArg & VrWarningIndArg::Cast ( const StackMsgArgument & arg ) [inline, static]

const VrWarningCode& VrWarningIndArg::GetWarningCode ( ) const [inline]

Friends And Related Function Documentation

friend class VrStackMsgArgTableDestroyTableNode [friend]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/VrStackMsgArgs.hpp
  • AddOns/VoiceRecognition/VrStackMsgArgs.cpp
Generated on Wed Jan 25 02:21:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VrWarningMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VrWarningMsg Class Reference

#include <Apoxi/AddOns/VoiceRecognition/MsgTypes.hpp>

Inheritance diagram for VrWarningMsg:

[legend]
Collaboration diagram for VrWarningMsg:

[legend]

Public Types

enum | { ID = 19003 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const VrWarningCode & | GetWarningCode () const
VrWarningMsg (ExecutionContext *context, const VrWarningCode &warning_code)
virtual | ~VrWarningMsg ()

Detailed Description

VrWarningMsg

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

VrWarningMsg::VrWarningMsg | ( | ExecutionContext * | context,
 |  | const VrWarningCode & | warning_code
 | ) |

VrWarningMsg::~VrWarningMsg ( ) [virtual]

Member Function Documentation

Message * VrWarningMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & VrWarningMsg::GetMetaData ( ) const [virtual]

Implements ContextMsg.

const VrWarningCode& VrWarningMsg::GetWarningCode ( ) const [inline]

The documentation for this class was generated from the following files:
  • AddOns/VoiceRecognition/MsgTypes.hpp
  • AddOns/VoiceRecognition/MsgTypes.cpp
Generated on Wed Jan 25 02:21:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WaitSsAction Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WaitSsAction Class Reference
[APOXI Stack Control]

#include <Apoxi/Asc/InputAction.hpp>

Inheritance diagram for WaitSsAction:

[legend]
Collaboration diagram for WaitSsAction:

[legend]

Public Member Functions

virtual InputAction * | Analyze (const WString &actionstring, const InputContext *context)
Analyzes the input string and returns a pointer to itself when analyzing was successfull.
virtual InputActionType | GetActionType () const
Returns the type of the action.
InputParser::BasicServiceMmiCode | GetBasicServiceMmiCode () const
Returns the basic service group.
InputParser::SsProcedure | GetSsProcedure () const
Returns the procedure type.
virtual BOOLEAN | IsExecutionPossible ()
Returns if Execute can be called, that means if the input string is analyzed correctly.
WaitSsAction ()
virtual | ~WaitSsAction ()

Detailed Description

WaitSsAction analyzes if the input string has the meaning of an Wait SS string GSM 02.83 delivered if other SS actions are not returned.

Constructor & Destructor Documentation

WaitSsAction::WaitSsAction ( )

WaitSsAction::~WaitSsAction ( ) [virtual]

Member Function Documentation

InputAction * WaitSsAction::Analyze | ( | const WString & | actionstring,
 |  | const InputContext * | context
 | ) | [virtual]

Analyzes the input string and returns a pointer to itself when analyzing was successfull.

Reimplemented from InputAction.

InputActionType WaitSsAction::GetActionType ( ) const [virtual]

Returns the type of the action.

Reimplemented from InputAction.

InputParser::BasicServiceMmiCode WaitSsAction::GetBasicServiceMmiCode ( ) const [inline]

Returns the basic service group.

InputParser::SsProcedure WaitSsAction::GetSsProcedure ( ) const [inline]

Returns the procedure type.

BOOLEAN WaitSsAction::IsExecutionPossible ( ) [virtual]

Returns if Execute can be called, that means if the input string is analyzed correctly.

Reimplemented from InputAction.

The documentation for this class was generated from the following files:
  • Asc/InputAction.hpp
  • Asc/InputAction.cpp
Generated on Wed Jan 25 02:21:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WapHandler Class Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/HttpWap/WapHandler.hpp>

Inheritance diagram for WapHandler:

[legend]
Collaboration diagram for WapHandler:

[legend]

Public Types

enum | WapSessionStatus { WapSessionConnected, WapSessionSuspended }

Public Member Functions

virtual BOOLEAN | AddRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)
virtual BOOLEAN | AddUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)
virtual BOOLEAN | ClearRootCertificate (INT conn_id, const COMM_ROOT_CERT *pRootCert)
virtual BOOLEAN | ClearUserCertificate (INT conn_id, const COMM_USER_CERT *pUserCert)
virtual BOOLEAN | GetCipherSuiteName (INT conn_id, const UINT8 **pCipherSuiteName)
virtual INT | GetConnIdWap ()
virtual WapSessionStatus | GetSessionStatusWap ()
virtual BOOLEAN | ReadRootCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen)
virtual BOOLEAN | ReadUserCertificate (INT conn_id, UINT8 **certData, UINT32 *certLen, UINT8 **certKey, UINT32 *certKeyLen)
virtual BOOLEAN | RegisterWap (INT pr_id, WString &mime, INT app_id=0)
virtual BOOLEAN | ResumeWap (INT conn_id)
virtual BOOLEAN | SuspendWap (INT conn_id)
virtual BOOLEAN | UnregisterWap (INT pr_id)
WapHandler ()
virtual | ~WapHandler ()

Protected Member Functions

virtual BOOLEAN | DecodeMessage (const Message &msg, INT &conn_id, INT &requ_id, INT &status, WString &header, BinData **body, INT &more, INT &length, WString &url)
virtual BOOLEAN | OnMessage (const Message &msg)=0
virtual BOOLEAN | OnPush (const Message &msg)=0
virtual BOOLEAN | SetWapPushReceived (const CHAR *header, const BinData *body)

Detailed Description

This interface defines the functionality of a WAP handler:
  • opening a WAP connection,
  • suspending and resuming a WAP connection,
  • closing a WAP connection,
  • handle WAP push messages coming in the form of APOXI messages or function calls,
  • query the status of a WAP connection.

Since the function calls lead to asynchronous calls on communication stacks, the return values of the functions indicate the success of the functions and generally not the success of the events in the communication stack or beyond.

Only public and protected functions are described here.

Member Enumeration Documentation

enum WapHandler::WapSessionStatus

Enumerator:
WapSessionConnected
WapSessionSuspended

Constructor & Destructor Documentation

WapHandler::WapHandler ( )

WapHandler::~WapHandler ( ) [virtual]

Member Function Documentation

BOOLEAN WapHandler::AddRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [virtual]

Certificate Management - Used to Add a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

BOOLEAN WapHandler::AddUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [virtual]

Certificate Management - Used to Add a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

BOOLEAN WapHandler::ClearRootCertificate | ( | INT | conn_id,
 |  | const COMM_ROOT_CERT * | pRootCert
 | ) | [virtual]

Certificate Management - Used to Delete a Root Certificate

Parameters:
COMM_ROOT_CERT Root Certificate structure
Returns:
success

BOOLEAN WapHandler::ClearUserCertificate | ( | INT | conn_id,
 |  | const COMM_USER_CERT * | pUserCert
 | ) | [virtual]

Certificate Management - Used to Delete a User Certificate

Parameters:
COMM_USER_CERT User Certificate structure
Returns:
success

BOOLEAN WapHandler::DecodeMessage | ( | const Message & | msg,
 |  | INT & | conn_id,
 |  | INT & | requ_id,
 |  | INT & | status,
 |  | WString & | header,
 |  | BinData ** | body,
 |  | INT & | more,
 |  | INT & | length,
 |  | WString & | url
 | ) | [protected, virtual]

This Method is called by the Application each time it gets a message in the form of msg class. This method decodes the message and fills the appropriate fields

Parameters:
msg | The message handed in
conn_id | Connection id this will be filled by Plugin class
requ_id | request id this will be filled by Plugin class
status | status to be filled by the Plugin class
header | header to be filled by the Plugin class by NULL or with value depending upono the Messages Type
body | body this will be filled by Plugin class
more | indicates if more data is following this packet or not
length | length of he data recived filling depends upon the message type
url | to be filled in by the Plugin calls depending upon the message type
Returns:
Sucess of the method

BOOLEAN WapHandler::GetCipherSuiteName | ( | INT | conn_id,
 |  | const UINT8 ** | pCipherSuiteName
 | ) | [virtual]

INT WapHandler::GetConnIdWap ( ) [virtual]

Used to get the Connection id

Returns:
the connection id

WapHandler::WapSessionStatus WapHandler::GetSessionStatusWap ( ) [virtual]

Used to get the Connection status

Returns:
the connection status

virtual BOOLEAN WapHandler::OnMessage ( const Message & msg ) [protected, pure virtual]

Called by message router.

Parameters:
msg Message handed in.
Returns:
Success of method.

Implements Dispatcher.

virtual BOOLEAN WapHandler::OnPush ( const Message & msg ) [protected, pure virtual]

Used to properly deal with an incoming WAP push message in the form of an APOXI message. Must be overridden by method in child class.

Parameters:
msg Message handed in.
Returns:
Success of method.

BOOLEAN WapHandler::ReadRootCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen
 | ) | [virtual]

Certificate Management - Used to Read a Root Certificate

Parameters:
UINT8** | Certificate data
UINT32* | Certificate length
Returns:
success

BOOLEAN WapHandler::ReadUserCertificate | ( | INT | conn_id,
 |  | UINT8 ** | certData,
 |  | UINT32 * | certLen,
 |  | UINT8 ** | certKey,
 |  | UINT32 * | certKeyLen
 | ) | [virtual]

Certificate Management - Used to Read a User Certificate

Parameters:
UINT8** | Certificate Data
UINT32* | Certificate length
UINT8** | Certificate key information
UINT32* | Certificate key length
Returns:
success

BOOLEAN WapHandler::RegisterWap | ( | INT | pr_id,
 |  | WString & | mime,
 |  | INT | app_id = 0
 | ) | [virtual]

Used to register for WAP push messages.

Function may be called again after a call to wapUnregister.

Parameters:
pr_id | Id of WapProfile to be used. (WapProfile determines if connection is secure/non-secure and connection-oriented/ connectionless).
mime | MIME type supported by registering application.
app_id | Application id according to Open Mobile Naming Authority (OMNA), defaults to 0.
Returns:
Success of method.

BOOLEAN WapHandler::ResumeWap ( INT conn_id ) [virtual]

Used by the application to resume the WAP connection on the WSP level.

Returns:
Success of method.

BOOLEAN WapHandler::SetWapPushReceived | ( | const CHAR * | header,
 |  | const BinData * | body
 | ) | [protected, virtual]

Used to hand in the contents of WAP push messages.

Parameters:
header | Header of WAP push message.
body | Body of WAP push message.
Returns:
Success of method.

BOOLEAN WapHandler::SuspendWap ( INT conn_id ) [virtual]

Used by the application to suspend the WAP connection on the WSP level.

Returns:
Success of method.

BOOLEAN WapHandler::UnregisterWap ( INT pr_id ) [virtual]

Used by the application to unregister for WAP push messages.

WAP connection must be open in order for this function to succeed. wapRegister must have been called before. Function will cancel all outstanding requests.

Returns:
Success of method.

The documentation for this class was generated from the following files:
  • AddOns/HttpWapInterface/HttpWap/WapHandler.hpp
  • AddOns/HttpWapInterface/HttpWap/WapHandler.cpp
Generated on Wed Jan 25 02:21:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapProfile Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WapProfile Class Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp>

Collaboration diagram for WapProfile:

[legend]

Public Types

enum PortService {
WapConnectionless, WapSession, WapSecureConnectionless, WapSecureSession,
WapWtaSecureSession, WapWtaSecureConnectionless, InvalidService
}
enum ProfileConstants {
c_invalid_id = 255, c_invalid_set_id = 255, c_max_proxy_id_len = 32, c_max_proxy_p_id_len = 32,
c_max_proxy_name_len = 16, c_max_profile_name_len1 = 16, c_max_startpage_len = 64, c_max_username_len = 16,
c_max_pwd_len = 16, c_max_url_len1 = 255, c_dataconn_profile_count = 5, c_max_physical_set = 5,
c_max_auth_set = 5, c_max_port_set = 5, c_max_phy_port_set = 5, c_max_domain = 4,
c_max_port_services = 5, c_max_wap_profile_count = 5
}
enum | PxAddrType { IPv4, E164, Invalid }
enum | WapAuthMethod { AuthMethodHttpBasic, AuthMethodHttpDigest, AuthMethodWtlsSs, InvalidMethod }

Public Member Functions

INT | AddAuthorizationSet ()
INT | AddPhysicalPortSet (INT physet=0)
INT | AddPhysicalSet ()
INT | AddPortSet ()
INT | GetActiveAuthorizationSet () const
INT | GetActivePhysicalPortSet (INT physet=0) const
INT | GetActivePhysicalSet () const
INT | GetActivePortSet () const
WapAuthMethod | GetAuthenticationMethod (INT set=0) const
const WCHAR * | GetAuthenticationPassword (INT set=0) const
const WCHAR * | GetAuthenticationUsername (INT set=0) const
INT | GetDataConnId (INT set=0) const
const WCHAR * | GetDomain (INT number) const
INT | GetNoOfAuthorizationSets () const
INT | GetNoOfAuthorizationSetsSupported () const
INT | GetNoOfPhysicalPortSets (INT physet=0) const
INT | GetNoOfPhysicalPortSetsSupported (INT physet=0) const
INT | GetNoOfPhysicalSets () const
INT | GetNoOfPhysicalSetsSupported () const
INT | GetNoOfPortSets () const
INT | GetNoOfPortSetsSupported () const
const WCHAR * | GetPhysicalDomain (INT number, INT set=0) const
UINT | GetPhysicalPortNumber (INT physet=0, INT set=0) const
PortService | GetPhysicalPortService (UINT port, INT physet=0) const
const Ipv4E164 & | GetPhysicalProxyAddress (INT set=0) const
const WCHAR * | GetPhysicalProxyId (INT set=0) const
UINT | GetPortNumber (INT set=0) const
PortService | GetPortService (UINT port) const
WapProfileId | GetProfileId () const
const WCHAR * | GetProfileName () const
const WCHAR * | GetProxyId () const
const WCHAR * | GetProxyName () const
const WCHAR * | GetProxyProviderId () const
const WCHAR * | GetStartpage () const
const WCHAR * | GetStartpagePassword () const
const WCHAR * | GetStartpageUsername () const
BOOLEAN | GetTrust () const
const WCHAR * | GetWspVersion () const
BOOLEAN | IsPhysicalPushEnabled (INT set=0) const
BOOLEAN | IsProfileWriteable () const
BOOLEAN | IsPushEnabled () const
BOOLEAN | RemoveAuthorizationSet (INT set=0)
BOOLEAN | RemovePhysicalPortSet (INT physet=0, INT set=0)
BOOLEAN | RemovePhysicalSet (INT set=1)
BOOLEAN | RemovePortSet (INT set=0)
BOOLEAN | SetActiveAuthorizationSet (INT set=0)
BOOLEAN | SetActivePhysicalPortSet (INT physet=0, INT set=0)
BOOLEAN | SetActivePhysicalSet (INT set=0)
BOOLEAN | SetActivePortSet (INT set=0)
BOOLEAN | SetAuthenticationMethod (WapAuthMethod method, INT set=0)
BOOLEAN | SetAuthenticationPassword (const CHAR *password, INT set=0)
BOOLEAN | SetAuthenticationUsername (const CHAR *username, INT set=0)
BOOLEAN | SetDataConnId (INT id, INT set=0)
BOOLEAN | SetDomain (INT number, const CHAR *domain)
BOOLEAN | SetPhysicalDomain (INT number, const CHAR *domain, INT set=0)
BOOLEAN | SetPhysicalPortNumber (UINT port, INT physet=0, INT set=0)
BOOLEAN | SetPhysicalPortService (UINT port, PortService service, INT physet=0)
BOOLEAN | SetPhysicalProxyAddress (const CHAR *address, PxAddrType addr_type, INT set=0)
BOOLEAN | SetPhysicalProxyId (const CHAR *proxy_id, INT set=0)
BOOLEAN | SetPhysicalPushEnabled (BOOLEAN pushenable, INT set=0)
BOOLEAN | SetPortNumber (UINT port, INT set=0)
BOOLEAN | SetPortService (UINT port, PortService service)
BOOLEAN | SetProfileName (const CHAR *name)
BOOLEAN | SetProfileWriteable (BOOLEAN writeable)
BOOLEAN | SetProxyId (const CHAR *proxy_id)
BOOLEAN | SetProxyName (const CHAR *name)
BOOLEAN | SetProxyProviderId (const CHAR *proxy_p_id)
BOOLEAN | SetPushEnabled (BOOLEAN enable)
BOOLEAN | SetStartpage (const CHAR *startpage)
BOOLEAN | SetStartpagePassword (const CHAR *password)
BOOLEAN | SetStartpageUsername (const CHAR *username)
BOOLEAN | SetTrust (BOOLEAN trust)
BOOLEAN | SetWspVersion (const CHAR *version)
WapProfile ()
~WapProfile ()

Protected Member Functions

BOOLEAN | Load (WapProfileId prof_id)
BOOLEAN | Save ()
BOOLEAN | SetProfileId (INT id)

Static Protected Member Functions

static BOOLEAN | Delete (WapProfileId prof_id)
static BOOLEAN | LoadProfileName (WapProfileId prof_id, WString &prof_name)

Friends

class | WapProfileMgr

Data Structures

struct | Ipv4E164
struct | PxLogicalCharacs

Detailed Description

This interface defines the access to the parameters of a WAP connection (WAP profile). Detailed information on the parameters can be found in the WAP forum document WAP-183-ProvCont-20010724-a, Version 24-July-2001, "Wireless Application Protocol, Provisioning Content".

Class WapProfile basically encapsulates the logical characteristics needed for a WAP request (as defined in PXLOGICAL), and it has a reference to an instance of class DataConnProfile in the form of an index.

The underlying concept is that a WAP profile has

  • logical WAP proxy parameters,
  • 0 or more sets of authorization parameters,
  • 0 or more sets of logical port parameters,
  • 1 or more sets of physical parameters, which are all accessed through a single flat interface, thus simplyfying the use of the interface.

The methods are grouped into logical, authorization, port and physical parameter set methods, set handling methods and general management methods. Each "setter" method is immediately followed by the corresponding "getter" method to enhance readability.

Member Enumeration Documentation

enum WapProfile::PortService

Service offered at a specified port WapConnectionless WAP connection-less session service WapSession WAP session service WapSecureConnectionless WAP secure connection-less service WapSecureSession WAP secure session service WapWtaSecureSession WAP WTA secure session service WapWtaSecureConnectionless WAP WTA secure connection-less service InvalidService Invalid Service Type

Enumerator:
WapConnectionless
WapSession
WapSecureConnectionless
WapSecureSession
WapWtaSecureSession
WapWtaSecureConnectionless
InvalidService

enum WapProfile::ProfileConstants

Wap Profile Specific Constants c_invalid_id = 255, c_invalid_set_id = 255, c_max_proxy_id_len = 32, c_max_proxy_p_id_len = 32, c_max_proxy_name_len = 16, c_max_profile_name_len1 = 16, c_max_startpage_len = 64, c_max_username_len = 16, c_max_pwd_len = 16, c_max_url_len1 = 255, c_dataconn_profile_count = 5, c_max_physical_set = 5, c_max_auth_set = 5, c_max_port_set = 5, c_max_phy_port_set = 5, c_max_domain = 4, c_max_port_services = 5, c_max_wap_profile_count = 5

Enumerator:
c_invalid_id
c_invalid_set_id
c_max_proxy_id_len
c_max_proxy_p_id_len
c_max_proxy_name_len
c_max_profile_name_len1
c_max_startpage_len
c_max_username_len
c_max_pwd_len
c_max_url_len1
c_dataconn_profile_count
c_max_physical_set
c_max_auth_set
c_max_port_set
c_max_phy_port_set
c_max_domain
c_max_port_services
c_max_wap_profile_count

enum WapProfile::PxAddrType

Type of address IPv4 IP version 4 address, decimal with dots E164 Phone number according E164 Invalid Invalid Address Type

Enumerator:
IPv4
E164
Invalid

enum WapProfile::WapAuthMethod

Authentication method to use AuthMethodHttpBasic HTTP Basic AuthMethodHttpDigest HTTP Digest AuthMethodWtlsSs WTLS SS InvalidMethod Invalid Authentication Method

Enumerator:
AuthMethodHttpBasic
AuthMethodHttpDigest
AuthMethodWtlsSs
InvalidMethod

Constructor & Destructor Documentation

WapProfile::WapProfile ( )

WapProfile::~WapProfile ( )

Member Function Documentation

INT WapProfile::AddAuthorizationSet ( )

Used to add an Authorization set to the WAP profile.

Sets are added to the end of the set list.

Returns:
The number of the new Authorization set. Valid Value ranges from 0 to [c_max_auth_set - 1] defined in enum ProfileConstants. Incase of failure, -1 is returned as the set number.

INT WapProfile::AddPhysicalPortSet ( INT physet = 0 )

Used to add a Physical Port set to the WAP profile.

Sets are added to the end of the set list.

Parameters:
physet The set number of physical characteristics to which the new Physical Port is to be added (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
The number of the new Physical Port set. Valid Value ranges from 0 to [c_max_phy_port_set - 1] defined in enum ProfileConstants. Incase of failure, -1 is returned as the set number.

INT WapProfile::AddPhysicalSet ( )

Used to add a Physical set to the WAP profile.

Sets are added to the end of the set list.

Returns:
The number of the new Physical set. Valid Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants. Incase of failure, -1 is returned as the set number.

INT WapProfile::AddPortSet ( )

Used to add a Logical Port set to the WAP profile.

Sets are added to the end of the set list.

Returns:
The number of the new Logical Port set. Valid Value ranges from 0 to [c_max_port_set - 1] defined in enum ProfileConstants. Incase of failure, -1 is returned as the set number.

BOOLEAN WapProfile::Delete ( WapProfileId prof_id ) [static, protected]

Used to remove the specified profile from Memory. This method will be invoked by WapProfileMgr.

Parameters:
prof_id Profile ID whose profile is to be removed from Memory. Value ranges from 0 to [c_max_wap_profile_count-1].
Returns:
TRUE - Success of Method FALSE - Failure of Method.

INT WapProfile::GetActiveAuthorizationSet ( ) const

Used to get the active authorization set of parameters. The parameters of the active set will be used for the WAP session.

Returns:
The set number of the active set. Value ranges from 0 to [c_max_auth_set - 1] defined in enum ProfileConstants.

INT WapProfile::GetActivePhysicalPortSet ( INT physet = 0 ) const

Used to get the active physical port set of parameters.

The parameters of the active set will be used for the WAP session.

Parameters:
physet The set number of physical characteristics (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
The set number of the active set. Value ranges from 0 to [c_max_phy_port_set - 1] defined in enum ProfileConstants.

INT WapProfile::GetActivePhysicalSet ( ) const

Used to get the active physical set of parameters.

The parameters of the active set will be used for the WAP session.

Returns:
The set number of the active set. Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.

INT WapProfile::GetActivePortSet ( ) const

Used to get the active logical port set of parameters.

The parameters of the active set will be used for the WAP session.

Returns:
The set number of the active set. Value ranges from 0 to [c_max_port_set - 1] defined in enum ProfileConstants.

WapProfile::WapAuthMethod WapProfile::GetAuthenticationMethod ( INT set = 0 ) const

Used to get the authentication method.

Returns:
The authentication method to use.

const WCHAR * WapProfile::GetAuthenticationPassword ( INT set = 0 ) const

Used to get proxy authentication password.

Returns:
The password for proxy authentication. Maximum length is 16 characters.

const WCHAR * WapProfile::GetAuthenticationUsername ( INT set = 0 ) const

Used to get proxy authentication username.

Returns:
The username for proxy authentication. Maximum length is 16 characters.

INT WapProfile::GetDataConnId ( INT set = 0 ) const

Used to get the id of the DataConnProfile.

Parameters:
set The set number of physical parameters (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
The unique ID of the data connection profile.

const WCHAR * WapProfile::GetDomain ( INT number ) const

Used to get the value of a domain, for which the proxy is responsible.

4 domains are supported.

Parameters:
number The number of the domain (0 to 3).
Returns:
The domain value specified by the number. A domain name or an absolute URI (IPv4 address).

INT WapProfile::GetNoOfAuthorizationSets ( ) const

Used to get the number of authorization sets available.

Returns:
The number of the authorization sets available. Value ranges from 0 to c_max_auth_set which is defined in enum ProfileConstants.

INT WapProfile::GetNoOfAuthorizationSetsSupported ( ) const

Used to get the number of Authorization sets supported.

The implementation supports only a limited number of sets. This limit can be queryed here.

Returns:
The number of the Authorization sets supported (c_max_auth_set) defined in enum ProfileConstants.

INT WapProfile::GetNoOfPhysicalPortSets ( INT physet = 0 ) const

Used to get the number of Physical Port sets available.

Parameters:
physet The set number of physical characteristics (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
The number of the Physical Port sets available. Value ranges from 0 to c_max_phy_port_set which is defined in enum ProfileConstants.

INT WapProfile::GetNoOfPhysicalPortSetsSupported ( INT physet = 0 ) const

Used to get the number of Physical Port sets supported.

The implementation only supports only a limited number of sets. This limit can be queryed here.

Parameters:
physet The set number of physical characteristics (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
The number of the Physical Port sets supported (c_max_phy_port_set) defined in enum ProfileConstants.

INT WapProfile::GetNoOfPhysicalSets ( ) const

Used to get the number of Physical sets available.

Returns:
The number of the Physical sets available. Value ranges from 0 to c_max_physical_set which is defined in enum ProfileConstants.

INT WapProfile::GetNoOfPhysicalSetsSupported ( ) const

Used to get the number of Physical sets supported.

The implementation supports only a limited number of sets. This limit can be queryed here.

Returns:
The number of the Physical sets supported (c_max_physical_set) defined in enum ProfileConstants.

INT WapProfile::GetNoOfPortSets ( ) const

Used to get the number of Logical Port sets available.

Returns:
The number of the Logical Port sets available. Value ranges from 0 to c_max_port_set which is defined in enum ProfileConstants.

INT WapProfile::GetNoOfPortSetsSupported ( ) const

Used to get the number of Logical Port sets supported.

The implementation supports only a limited number of sets. This limit can be queryed here.

Returns:
The number of the Logical Port sets supported (c_max_port_set) defined in enum ProfileConstants.

const WCHAR * WapProfile::GetPhysicalDomain | ( | INT | number,
 |  | INT | set = 0
 | ) | const

Used to get the physical value of a domain, the proxy is responsible for.

4 domains are supported.

Parameters:
number | The number of the domain (0 to 3).
set | The set number of physical parameters (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
The domain. A domain name or an absolute URI (IPv4 address).

UINT WapProfile::GetPhysicalPortNumber | ( | INT | physet = 0,
 |  | INT | set = 0
 | ) | const

Used to get the port number of Physical Proxy set.

Parameters:
physet | The set number of physical characteristics (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
set | The set number of port information inside the physical set specified (defaults to 0). Value ranges from 0 to [c_max_phy_port_set - 1] defined in enum ProfileConstants.
Returns:
The port number.

WapProfile::PortService WapProfile::GetPhysicalPortService | ( | UINT | port,
 |  | INT | physet = 0
 | ) | const

Used to get the port service, i.e. which service is available behind a port number of Physical Proxy set.

Parameters:
port | The port number.
physet | The set number of physical characteristics (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
The port service (see enum declarations).

const WapProfile::Ipv4E164 & WapProfile::GetPhysicalProxyAddress ( INT set = 0 ) const

Used to get the proxy address.

Parameters:
set The set number of physical parameters (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
A reference to the struct Ipv4E164. It contains a valid IP address or E164 number based on the Address type (see enum declarations). struct Ipv4E164 { IpAddr ipv4_address; WString e164_number; PxAddrType type; };

const WCHAR * WapProfile::GetPhysicalProxyId ( INT set = 0 ) const

Used to get the physical proxy id.

Parameters:
set The set number of physical information (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
The proxy id uniquely identifies the wap profile. It is either a fully qualified internet domain name or a IPv4 address. Maximum length is 32 characters.

UINT WapProfile::GetPortNumber ( INT set = 0 ) const

Used to get the port number.

Returns:
The port number.

WapProfile::PortService WapProfile::GetPortService ( UINT port ) const

Used to get the port service, i.e. which service is available behind a port number.

Parameters:
port The port number.
Returns:
The port service (see enum declarations).

WapProfileId WapProfile::GetProfileId ( ) const

Used to get the numerical identifier of the wap profile.

The id here is only for internal identication purposes. The id will be unique over all the wap profiles.

Returns:
The identifier. Value ranges from 0 to [c_max_wap_profile_count-1].

const WCHAR * WapProfile::GetProfileName ( ) const

Used to get the Name (User Given) of the wap profile.

The name here is only for identication purpose for the User.

Parameters:
name The name.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

const WCHAR * WapProfile::GetProxyId ( ) const

Used to get the logical proxy id.

Returns:
The proxy id uniquely identifies the wap profile. It is either a fully qualified internet domain name or an IPv4 adress. Maximum length is 32 characters.

const WCHAR * WapProfile::GetProxyName ( ) const

Used to get the logical proxy name.

Returns:
The logical proxy name. Maximum length is 16 characters.

const WCHAR * WapProfile::GetProxyProviderId ( ) const

Used to get the logical proxy provider id.

Returns:
The proxy provider id is used to verify the identity when using server based certificate authentication. It is either a fully qualified internet domain name or an IPv4 adress. Maximum length is 32 chara- cters.

const WCHAR * WapProfile::GetStartpage ( ) const

Used to get the startpage.

Returns:
The startpage, a fully qualified URI. May contain the service, if service is omitted, http is as- sumed. Maximum length is 64 characters.

const WCHAR * WapProfile::GetStartpagePassword ( ) const

Used to get the password for the startpage.

Returns:
The password for the startpage. Maximum length is 16 characters.

const WCHAR * WapProfile::GetStartpageUsername ( ) const

Used to get the username for the startpage.

Returns:
The username for the startpage. Maximum length is 16 characters.

BOOLEAN WapProfile::GetTrust ( ) const

Used to get the trustworthiness of the proxy.

Returns:
TRUE - the proxy can be trusted. FALSE - the proxy cannot be trusted.

const WCHAR * WapProfile::GetWspVersion ( ) const

Used to get the WSP encoding Version.

Returns:
The WSP encoding version supported by the proxy.

BOOLEAN WapProfile::IsPhysicalPushEnabled ( INT set = 0 ) const

Used to check whether physical push is enabled/disabled.

Parameters:
set The set number of physical parameters (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - If Push is enabled FALSE - If Push is disabled.

BOOLEAN WapProfile::IsProfileWriteable ( ) const

Used to check whether the profile is writeable or read-only.

Returns:
TRUE - profile is writeable. FALSE - profile is read-only.

BOOLEAN WapProfile::IsPushEnabled ( ) const

Used to check whether push is enabled/disabled.

Returns:
TRUE - Push is enabled FALSE - Push is disabled.

BOOLEAN WapProfile::Load ( WapProfileId prof_id ) [protected]

Used to retrieve the specified profile from Memory. This method will be invoked by WapProfileMgr.

Parameters:
prof_id Profile ID whose parameters are to be retrieved from Memory. Value ranges from 0 to [c_max_wap_profile_count-1].
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::LoadProfileName | ( | WapProfileId | prof_id,
 |  | WString & | prof_name
 | ) | [static, protected]

Used to retrieve the specified profile info (Name/Id) alone from Memory. This method will be invoked by WapProfileMgr.

Parameters:
prof_id | Profile ID whose profile info to be retrieved from Memory. Value ranges from 0 to [c_max_wap_profile_count-1].
prof_name | User given name for the profile specified to be retrieved from Memory.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::RemoveAuthorizationSet ( INT set = 0 )

Used to remove an Authorization set from the WAP profile.

The methods may remove active sets. After removal the first available set in the list will be made active.

Parameters:
set The number of the Authorization set to remove. Value ranges from 0 to [c_max_auth_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::RemovePhysicalPortSet | ( | INT | physet = 0,
 |  | INT | set = 0
 | ) |

Used to remove a Physical Port set from the WAP profile.

The methods may remove active sets. After removal the first available set in the list will be made active.

Parameters:
set | The number of the Physical Port set to remove. Value ranges from 0 to [c_max_phy_port_set - 1] defined in enum ProfileConstants.
physet | The set number of physical characteristics which contains the required port set (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::RemovePhysicalSet ( INT set = 1 )

Used to remove a Physical set from the WAP profile.

The methods may remove active sets. After removal the first available set in the list will be made active.

Parameters:
set The number of the Physical set to remove. The last Physical set cannot be removed. Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::RemovePortSet ( INT set = 0 )

Used to remove a Logical Port set from the WAP profile.

The methods may remove active sets. After removal the first available set in the list will be made active.

Parameters:
set The number of the Logical Port set to remove. Value ranges from 0 to [c_max_port_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::Save ( ) [protected]

Used to write the parameters of the specified profile to Memory. This method will be invoked by WapProfileMgr.

Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetActiveAuthorizationSet ( INT set = 0 )

Used to set the active authorization set of parameters.

The parameters of the active set will be used for the WAP session.

Parameters:
set The set number of the parameters to be used (defaults to 0). Value ranges from 0 to [c_max_auth_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetActivePhysicalPortSet | ( | INT | physet = 0,
 |  | INT | set = 0
 | ) |

Used to set the active physical port set of parameters.

The parameters of the active set will be used for the WAP session.

Parameters:
physet | The set number of physical characteristics (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
set | The set number of the parameters to be used (defaults to 0). Value ranges from 0 to [c_max_phy_port_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetActivePhysicalSet ( INT set = 0 )

Used to set the active physical set of parameters.

The parameters of the active set will be used for the WAP session.

Parameters:
set The set number of the parameters to be used (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetActivePortSet ( INT set = 0 )

Used to set the active logical port set of parameters.

The parameters of the active set will be used for the WAP session.

Parameters:
set The set number of the parameters to be used (defaults to 0). Value ranges from 0 to [c_max_port_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetAuthenticationMethod | ( | WapAuthMethod | method,
 |  | INT | set = 0
 | ) |

Used to set the authentication method.

Parameters:
method | The authentication method to use.
set | The set number of authentication set to use. (defaults to 0).
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetAuthenticationPassword | ( | const CHAR * | password,
 |  | INT | set = 0
 | ) |

Used to set proxy authentication password.

Parameters:
password | The password for proxy authentication. Maximum length is 16 characters.
set | The set number of authentication information (defaults to 0). Value ranges from 0 to [c_max_auth_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetAuthenticationUsername | ( | const CHAR * | username,
 |  | INT | set = 0
 | ) |

Used to set proxy authentication username.

Parameters:
username | The username for proxy authentication. Maximum length is 16 characters.
set | The set number of authentication information (defaults to 0). Value ranges from 0 to [c_max_auth_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetDataConnId | ( | INT | id,
 |  | INT | set = 0
 | ) |

Used to set the id of the DataConnProfile.

Parameters:
id | The number of the data connection profile.
set | The set number of physical parameters (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetDomain | ( | INT | number,
 |  | const CHAR * | domain
 | ) |

Used to set the value of a domain, for which the proxy is responsible.

4 domains are supported.

Parameters:
number | The number of the domain (0 to 3).
domain | The new domain. A domain name or an absolute URI (IPv4 address).
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPhysicalDomain | ( | INT | number,
 |  | const CHAR * | domain,
 |  | INT | set = 0
 | ) |

Used to set the physical value of a domain, the proxy is responsible for.

4 domains are supported.

Parameters:
number | The number of the domain (0 to 3).
domain | The new domain. A domain name or an absolute URI (IPv4 address).
set | The set number of physical parameters (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPhysicalPortNumber | ( | UINT | port,
 |  | INT | physet = 0,
 |  | INT | set = 0
 | ) |

Used to set the port number of Physical Proxy set.

Parameters:
port | The port number.
physet | The set number of physical characteristics (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
set | The set number of port information inside the physical set specified (defaults to 0). Value ranges from 0 to [c_max_phy_port_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPhysicalPortService | ( | UINT | port,
 |  | PortService | service,
 |  | INT | physet = 0
 | ) |

Used to set the port service, i.e. which service is available behind a port number of Physical Proxy set.

Parameters:
port | The port number.
physet | The set number of physical characteristics (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
service | The port service (see top of file).
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPhysicalProxyAddress | ( | const CHAR * | address,
 |  | PxAddrType | addr_type,
 |  | INT | set = 0
 | ) |

Used to set the proxy address.

Parameters:
address The adress of the proxy. It can be one of
  • an IPv4 address in decimal format with dots as delimiters,
  • a phone number (E164 Format).
addr_type | The type of the address, see enum.
set | The set number of physical parameters (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPhysicalProxyId | ( | const CHAR * | proxy_id,
 |  | INT | set = 0
 | ) |

Used to set the physical proxy id.

Parameters:
proxy_id | The proxy id uniquely identifies the wap profile. It is either a fully qualified internet domain name or a IPv4 address. Maximum length is 32 characters.
set | The set number of physical information (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPhysicalPushEnabled | ( | BOOLEAN | pushenable,
 |  | INT | set = 0
 | ) |

Used to enable/disable physical push.

Parameters:
pushenable | Will push be enabled?
set | The set number of physical parameters (defaults to 0). Value ranges from 0 to [c_max_physical_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPortNumber | ( | UINT | port,
 |  | INT | set = 0
 | ) |

Used to set the port number.

Parameters:
port | The port number.
set | The set number of logical port information (defaults to 0). Value ranges from 0 to [c_max_port_set - 1] defined in enum ProfileConstants.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPortService | ( | UINT | port,
 |  | PortService | service
 | ) |

Used to set the port service, i.e. which service is available behind a port number.

Parameters:
port | The port number.
service | The port service (see top of file).
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetProfileId ( INT id ) [protected]

Used to set the numerical identifier of the wap profile. This method will be invoked by WapProfileMgr.

The id here is only for internal identication purposes. The id will be unique over all the wap profiles.

Parameters:
id The identifier. Value ranges from 0 to [c_max_wap_profile_count-1].
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetProfileName ( const CHAR * name )

Used to set the Name (User Given) of the wap profile.

The name here is only for identication purpose for the User.

Parameters:
name The name.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetProfileWriteable ( BOOLEAN writeable )

Used to set the profile as read-write or read-only.

Parameters:
writeable TRUE - profile will be writeable. FALSE - profile will be read-only.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetProxyId ( const CHAR * proxy_id )

Used to set the logical proxy id.

Parameters:
proxy_id The proxy id uniquely identifies the wap profile. It is either a fully qualified internet domain name or an IPv4 adress. Maximum length is 32 chara- cters.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetProxyName ( const CHAR * name )

Used to set the logical proxy name.

Parameters:
name The name is a user readable text. Maximum length is 16 characters.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetProxyProviderId ( const CHAR * proxy_p_id )

Used to set the logical proxy provider id.

Parameters:
proxy_p_id The proxy provider id is used to verify the identity when using server based certificate authentication. It is either a fully qualified internet domain name or an IPv4 adress. Maximum length is 32 chara- cters.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetPushEnabled ( BOOLEAN enable )

Used to enable/disable push.

Parameters:
pushenable Will push be enabled?
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetStartpage ( const CHAR * startpage )

Used to set the startpage.

Parameters:
startpage The startpage, a fully qualified URI. May contain the service, if service is omitted, http is as- sumed. Maximum length is 64 characters.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetStartpagePassword ( const CHAR * password )

Used to set the password for the startpage.

Parameters:
password The password for the startpage. Maximum length is 16 characters.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetStartpageUsername ( const CHAR * username )

Used to set the username for the startpage.

Parameters:
username The username for the startpage. Maximum length is 16 characters.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetTrust ( BOOLEAN trust )

Used to set the trustworthiness of the proxy.

Parameters:
trust TRUE - the proxy can be trusted. FALSE - the proxy cannot be trusted.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfile::SetWspVersion ( const CHAR * version )

Used to set the WSP encoding Version.

Parameters:
version The WSP encoding version supported by the proxy. (Defaults to 1.2)
Returns:
TRUE - Success of Method FALSE - Failure of Method.

Friends And Related Function Documentation

friend class WapProfileMgr [friend]

The documentation for this class was generated from the following files:
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.cpp
Generated on Wed Jan 25 02:21:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapProfile::Ipv4E164 Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
WapProfile::Ipv4E164

WapProfile::Ipv4E164 Struct Reference

#include <Apoxi/AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp>

Collaboration diagram for WapProfile::Ipv4E164:

[legend]

Data Fields

WString e164_number
IpAddr ipv4_address
PxAddrType type

Field Documentation

WString WapProfile::Ipv4E164::e164_number

IpAddr WapProfile::Ipv4E164::ipv4_address

PxAddrType WapProfile::Ipv4E164::type

The documentation for this struct was generated from the following file:
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp
Generated on Wed Jan 25 02:21:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapProfile::PxLogicalCharacs Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
WapProfile::PxLogicalCharacs

WapProfile::PxLogicalCharacs Struct Reference

#include <Apoxi/AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp>

Collaboration diagram for WapProfile::PxLogicalCharacs:

[legend]

Public Member Functions

PxLogicalCharacs ()

Data Fields

WString | m_domain [c_max_domain]
LinkedList< PxPortCharacs > m_list_port
LinkedList< PxAuthInfoCharacs > m_list_pxauthinfo
LinkedList< PxPhysicalCharacs > m_list_pxphysical
WString m_proxy_id
WString m_proxy_name
WString m_proxy_p_id
BOOLEAN | m_proxy_trusted
BOOLEAN | m_push_enabled
WString m_startpage
WString m_startpage_pwd
WString m_startpage_user_name
WString m_wsp_version

Data Structures

struct | PxAuthInfoCharacs
struct | PxPhysicalCharacs
struct | PxPortCharacs

Constructor & Destructor Documentation

WapProfile::PxLogicalCharacs::PxLogicalCharacs ( ) [inline]

Field Documentation

WString WapProfile::PxLogicalCharacs::m_domain[c_max_domain]

LinkedList<PxPortCharacs> WapProfile::PxLogicalCharacs::m_list_port

LinkedList<PxAuthInfoCharacs> WapProfile::PxLogicalCharacs::m_list_pxauthinfo

LinkedList<PxPhysicalCharacs> WapProfile::PxLogicalCharacs::m_list_pxphysical

WString WapProfile::PxLogicalCharacs::m_proxy_id

WString WapProfile::PxLogicalCharacs::m_proxy_name

WString WapProfile::PxLogicalCharacs::m_proxy_p_id

BOOLEAN WapProfile::PxLogicalCharacs::m_proxy_trusted

BOOLEAN WapProfile::PxLogicalCharacs::m_push_enabled

WString WapProfile::PxLogicalCharacs::m_startpage

WString WapProfile::PxLogicalCharacs::m_startpage_pwd

WString WapProfile::PxLogicalCharacs::m_startpage_user_name

WString WapProfile::PxLogicalCharacs::m_wsp_version

The documentation for this struct was generated from the following file:
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp
Generated on Wed Jan 25 02:21:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapProfile::PxLogicalCharacs::PxAuthInfoCharacs Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
WapProfile::PxLogicalCharacs::PxAuthInfoCharacs

WapProfile::PxLogicalCharacs::PxAuthInfoCharacs Struct Reference

#include <Apoxi/AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp>

Inheritance diagram for WapProfile::PxLogicalCharacs::PxAuthInfoCharacs:

[legend]
Collaboration diagram for WapProfile::PxLogicalCharacs::PxAuthInfoCharacs:

[legend]

Data Fields

WString m_auth_pwd
UINT8 m_auth_set_id
WString m_auth_user_name
WapAuthMethod m_proxy_auth_type

Field Documentation

WString WapProfile::PxLogicalCharacs::PxAuthInfoCharacs::m_auth_pwd

UINT8 WapProfile::PxLogicalCharacs::PxAuthInfoCharacs::m_auth_set_id

WString WapProfile::PxLogicalCharacs::PxAuthInfoCharacs::m_auth_user_name

WapAuthMethod WapProfile::PxLogicalCharacs::PxAuthInfoCharacs::m_proxy_auth_type

The documentation for this struct was generated from the following file:
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp
Generated on Wed Jan 25 02:21:55 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapProfile::PxLogicalCharacs::PxPhysicalCharacs Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
WapProfile::PxLogicalCharacs::PxPhysicalCharacs

WapProfile::PxLogicalCharacs::PxPhysicalCharacs Struct Reference

#include <Apoxi/AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp>

Inheritance diagram for WapProfile::PxLogicalCharacs::PxPhysicalCharacs:

[legend]
Collaboration diagram for WapProfile::PxLogicalCharacs::PxPhysicalCharacs:

[legend]

Data Fields

LinkedList< PxPortCharacs > m_list_phy_port
WString | m_phy_domain [c_max_domain]
WString m_phy_proxy_id
BOOLEAN | m_phy_push_enabled
UINT8 | m_physical_set_id
Ipv4E164 m_proxy_addr
UINT8 | m_to_nap_id

Field Documentation

LinkedList<PxPortCharacs> WapProfile::PxLogicalCharacs::PxPhysicalCharacs::m_list_phy_port

WString WapProfile::PxLogicalCharacs::PxPhysicalCharacs::m_phy_domain[c_max_domain]

WString WapProfile::PxLogicalCharacs::PxPhysicalCharacs::m_phy_proxy_id

BOOLEAN WapProfile::PxLogicalCharacs::PxPhysicalCharacs::m_phy_push_enabled

UINT8 WapProfile::PxLogicalCharacs::PxPhysicalCharacs::m_physical_set_id

Ipv4E164 WapProfile::PxLogicalCharacs::PxPhysicalCharacs::m_proxy_addr

UINT8 WapProfile::PxLogicalCharacs::PxPhysicalCharacs::m_to_nap_id

The documentation for this struct was generated from the following file:
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp
Generated on Wed Jan 25 02:21:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapProfile::PxLogicalCharacs::PxPortCharacs Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
WapProfile::PxLogicalCharacs::PxPortCharacs

WapProfile::PxLogicalCharacs::PxPortCharacs Struct Reference

#include <Apoxi/AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp>

Inheritance diagram for WapProfile::PxLogicalCharacs::PxPortCharacs:

[legend]
Collaboration diagram for WapProfile::PxLogicalCharacs::PxPortCharacs:

[legend]

Data Fields

UINT32 | m_port
PortService | m_port_service [c_max_port_services]
UINT8 | m_port_set_id

Field Documentation

UINT32 WapProfile::PxLogicalCharacs::PxPortCharacs::m_port

PortService WapProfile::PxLogicalCharacs::PxPortCharacs::m_port_service[c_max_port_services]

UINT8 WapProfile::PxLogicalCharacs::PxPortCharacs::m_port_set_id

The documentation for this struct was generated from the following file:
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfile.hpp
Generated on Wed Jan 25 02:21:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapProfileMgr Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WapProfileMgr Class Reference
[HTTPWAPIF]

#include <Apoxi/AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp>

Collaboration diagram for WapProfileMgr:

[legend]

Public Member Functions

BOOLEAN | CreateWapProfile (WapProfile &profile)
BOOLEAN | DeleteWapProfile (WapProfileId prof_id)
WapProfileId GetActiveWapProfileId ()
BOOLEAN | GetWapProfile (WapProfileId prof_id, WapProfile &profile)
const LinkedList< WapProfileInfo > & | GetWapProfileInfo () const
BOOLEAN | Init ()
BOOLEAN | SaveWapProfile (WapProfile &profile)
BOOLEAN | SetActiveWapProfile (WapProfileId active_prof_id)
~WapProfileMgr ()
Destructor.

Static Public Member Functions

static WapProfileMgr & | GetInstance ()

Data Structures

struct | WapProfileInfo

Detailed Description

Class WapProfileMgr holds the collection of all WAP Profiles.

There is 0 or 1 profile active. Though there is just one profile active, the id's and names of all WAP profiles are held in WapProfileInfo objects, for selection purposes.

  • WapProfileMgr is a manager class and does not carry out any interaction with the user.
  • WapProfileMgr does not hold browser specific settings such as fonts or colors.

Constructor & Destructor Documentation

WapProfileMgr::~WapProfileMgr ( )

Destructor.

Member Function Documentation

BOOLEAN WapProfileMgr::CreateWapProfile ( WapProfile & profile )

Used to create a new Wap Profile. This method creates a unique profile id and sets it to the profile reference passed as argument. It returns FALSE if there are no free id to be assigned i.e., when the number of profiles has reached the maximum limit.

Parameters:
profile This profile reference is passed by the application to the WapProfileMgr class after instantiation for setting the identifier.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfileMgr::DeleteWapProfile ( WapProfileId prof_id )

Used to delete a Wap Profile from memory.

Parameters:
prof_id Profile ID whose profile is to be deleted from memory. On successful deletion from memory, ProfileInfo list is updated. Value ranges from 0 to [c_max_wap_profile_count-1].
Returns:
TRUE - Success of Method FALSE - Failure of Method.

WapProfileId WapProfileMgr::GetActiveWapProfileId ( ) [inline]

Used to get the active Wap Profile Id in WapProfileMgr class.

Returns:
Value of the active profile id. Value ranges from 0 to [c_max_wap_profile_count-1].

static WapProfileMgr& WapProfileMgr::GetInstance ( ) [inline, static]

Used to get the reference of the Singleton WapProfileMgr class.

Returns:
Reference to the single instance of the WapProfileMgr class.

BOOLEAN WapProfileMgr::GetWapProfile | ( | WapProfileId | prof_id,
 |  | WapProfile & | profile
 | ) |

Used to get the parameter values of the specified Wap Profile from memory.

Parameters:
prof_id | Id of the profile to be retrieved. Value ranges from 0 to [c_max_wap_profile_count-1].
profile | A reference to a profile object which is passed by the application to the WapProfileMgr class. This object is then filled up with values retrieved from the memory corresponding to the specified profile id.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

const LinkedList<WapProfileInfo>& WapProfileMgr::GetWapProfileInfo ( ) const [inline]

Used to retrieve the linked list of WapProfileInfo objects. These objects holds the name and profile id of all the existing profiles.

Returns:
A reference to a LinkedList of WapProfileInfo objects.

BOOLEAN WapProfileMgr::Init ( ) [inline]

Used to initialize the WapProfileMgr class. This method must be called after getting an instance of WapProfileMgr to load all WapProfileInfo objects from Memory onto the linked list in WapProfileMgr object.

Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfileMgr::SaveWapProfile ( WapProfile & profile )

Used to save a Wap Profile to memory.

Parameters:
profile This profile reference is passed after being filled up with appropriate values. The profile is then stored into memory and ProfileInfo list is updated.
Returns:
TRUE - Success of Method FALSE - Failure of Method.

BOOLEAN WapProfileMgr::SetActiveWapProfile ( WapProfileId active_prof_id )

Used to set the active Wap Profile Id in WapProfileMgr class.

Parameters:
active_prof_id Value to be set as active profile id. Value ranges from 0 to [c_max_wap_profile_count-1].
Returns:
TRUE - Success of Method FALSE - Failure of Method.

The documentation for this class was generated from the following files:
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.cpp
Generated on Wed Jan 25 02:22:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WapProfileMgr::WapProfileInfo Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
WapProfileMgr::WapProfileInfo

WapProfileMgr::WapProfileInfo Struct Reference

#include <Apoxi/AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp>

Inheritance diagram for WapProfileMgr::WapProfileInfo:

[legend]
Collaboration diagram for WapProfileMgr::WapProfileInfo:

[legend]

Data Fields

WapProfileId m_prof_id
Identifier of the Profile.
WString m_prof_name
Name of the Profile.

Field Documentation

WapProfileId WapProfileMgr::WapProfileInfo::m_prof_id

Identifier of the Profile.

WString WapProfileMgr::WapProfileInfo::m_prof_name

Name of the Profile.

The documentation for this struct was generated from the following file:
  • AddOns/HttpWapInterface/WapProfileMgmt/WapProfileMgr.hpp
Generated on Wed Jan 25 02:22:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WbmpImage Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WbmpImage Class Reference
[MultiMedia]

#include <Apoxi/AddOns/MultiMedia/WbmpImage.hpp>

Inheritance diagram for WbmpImage:

[legend]
Collaboration diagram for WbmpImage:

[legend]

Public Types

enum | { ID = 5 }

Public Member Functions

virtual const BinData * | GetBinData () const
virtual UINT32 | GetFrameDelay (INT frame_idx) const
virtual INT | GetNextFrame (INT frame_idx) const
Returns the index of the frame wich follows the specified frame in frame_idx.
void | Init (BinData *data, BOOLEAN *success=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
WbmpImage (BinData *data, BOOLEAN *success=0)
WbmpImage ()
virtual | ~WbmpImage ()

Protected Member Functions

virtual void * | BeginScanlineDrawing (INT frame_idx=0) const
virtual void | DrawScanline (void *context, DeviceContext *dc, XYDIM x, XYDIM y, INT scanline_idx, INT old_scanline_idx) const
virtual void | EndScanlineDrawing (void *context) const
virtual ColorValue | GetTransparentColor (void *context) const
virtual BOOLEAN | IsTransparent (void *context) const

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Image.

Constructor & Destructor Documentation

WbmpImage::WbmpImage ( )

WbmpImage::WbmpImage | ( | BinData * | data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
bin_data | Pointer to a binary data stream which contains the WBMP-data. After passing the binary data stream, the stream is obtained by the WBMP-image and hence automatically released in the destructor of the WBMP-image.
success | Output-parameter, which indicates whether the initialization has been successful.

WbmpImage::~WbmpImage ( ) [virtual]

Member Function Documentation

void * WbmpImage::BeginScanlineDrawing ( INT frame_idx = 0 ) const [protected, virtual]

See also:
Image::BeginScanlineDrawing

Reimplemented from Image.

void WbmpImage::DrawScanline | ( | void * | context,
 |  | DeviceContext * | dc,
 |  | XYDIM | x,
 |  | XYDIM | y,
 |  | INT | scanline_idx,
 |  | INT | old_scanline_idx
 | ) | const [protected, virtual]

See also:
Image::DrawScanline

Reimplemented from Image.

void WbmpImage::EndScanlineDrawing ( void * context ) const [protected, virtual]

See also:
Image::EndScanlineDrawing

Reimplemented from Image.

const BinData * WbmpImage::GetBinData ( ) const [virtual]

See also:
Image::GetBinData

Reimplemented from Image.

virtual UINT32 WbmpImage::GetFrameDelay ( INT frame_idx ) const [inline, virtual]

Returns the time in milliseconds the specified frame should be displayed. The value Image::c_unlimited means that it should be displayed _forever_.

Implements Image.

virtual INT WbmpImage::GetNextFrame ( INT frame_idx ) const [inline, virtual]

Returns the index of the frame wich follows the specified frame in frame_idx.

Implements Image.

ColorValue WbmpImage::GetTransparentColor ( void * context ) const [protected, virtual]

See also:
Image::GetTransparentColor

Reimplemented from Image.

void WbmpImage::Init | ( | BinData * | data,
 |  | BOOLEAN * | success = 0
 | ) |

Parameters:
bin_data | Pointer to a binary data stream which contains the WBMP-data. After passing the binary data stream, the stream is obtained by the WBMP-image and hence automatically released in the destructor of the WBMP-image.
success | Output-parameter, which indicates whether the initialization has been successful.

BOOLEAN WbmpImage::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Image.

BOOLEAN WbmpImage::IsTransparent ( void * context ) const [protected, virtual]

See also:
Image::IsTransparent

Reimplemented from Image.

The documentation for this class was generated from the following files:
  • AddOns/MultiMedia/WbmpImage.hpp
  • AddOns/MultiMedia/WbmpImage.cpp
Generated on Wed Jan 25 02:22:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WbxmlParserRel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WbxmlParserRel Class Reference

#include <Apoxi/AddOns/Drm/DrmRelWbxml.hpp>

Collaboration diagram for WbxmlParserRel:

[legend]

Public Types

enum | RelWbxmlAttName_v1_0 { RelWbxmlAttLang = 0x05, RelWbxmlAttDd, RelWbxmlAttSig, RelWbxmlAttNone }
enum | RelWbxmlAttValue_v1_0 { RelWbxmlAttLangVal = 0x05, RelWbxmlAttDdVal, RelWbxmlAttSigVal, RelWbxmlAttValNone }
enum RelWbxmlTag_v1_0 {
RelWbxmlRights = 0x05, RelWbxmlContext, RelWbxmlVersion, RelWbxmlUid,
RelWbxmlAgreement, RelWbxmlAsset, RelWbxmlKeyInfo, RelWbxmlKeyValue,
RelWbxmlPermission, RelWbxmlPlay, RelWbxmlDisplay, RelWbxmlExecute,
RelWbxmlPrint, RelWbxmlConstraint, RelWbxmlCount, RelWbxmlDatetime,
RelWbxmlStart, RelWbxmlEnd, RelWbxmlInterval, RelWbxmlNone
}

Public Member Functions

void | AddDefaultConstraints (DrmPermission *perm)
Default constraints create a Forward Lock object.
void | AddDefaultPermissions ()
Default permissions create a Forward Lock object.
virtual void | characters (const SAXString &chars, byte &tag)
virtual void | endDocument ()
virtual void | endElement (const SAXString &name, byte &tag, size_t depth)
virtual void | error (const SAXParseException &e)
virtual void | fatalError (const SAXParseException &e)
DrmStatus GetParseStatus ()
virtual void | ignorableWhitespace (const SAXChar *ch, size_t length)
virtual void | processingInstruction (const SAXString &target, const SAXString &data)
virtual void | setDocumentLocator (const Locator &locator)
virtual void | startDocument ()
virtual void | startElement (const SAXString &name, const AttributeList &atts, byte &tag, size_t depth)
virtual void | warning (const SAXParseException &e)
WbxmlParserRel (DrmRelParser &rh)
~WbxmlParserRel ()

Member Enumeration Documentation

enum WbxmlParserRel::RelWbxmlAttName_v1_0

Enumerator:
RelWbxmlAttLang
RelWbxmlAttDd
RelWbxmlAttSig
RelWbxmlAttNone

enum WbxmlParserRel::RelWbxmlAttValue_v1_0

Enumerator:
RelWbxmlAttLangVal
RelWbxmlAttDdVal
RelWbxmlAttSigVal
RelWbxmlAttValNone

enum WbxmlParserRel::RelWbxmlTag_v1_0

Enumerator:
RelWbxmlRights
RelWbxmlContext
RelWbxmlVersion
RelWbxmlUid
RelWbxmlAgreement
RelWbxmlAsset
RelWbxmlKeyInfo
RelWbxmlKeyValue
RelWbxmlPermission
RelWbxmlPlay
RelWbxmlDisplay
RelWbxmlExecute
RelWbxmlPrint
RelWbxmlConstraint
RelWbxmlCount
RelWbxmlDatetime
RelWbxmlStart
RelWbxmlEnd
RelWbxmlInterval
RelWbxmlNone

Constructor & Destructor Documentation

WbxmlParserRel::WbxmlParserRel ( DrmRelParser & rh ) [inline]

WbxmlParserRel::~WbxmlParserRel ( )

Member Function Documentation

void WbxmlParserRel::AddDefaultConstraints ( DrmPermission * perm )

Default constraints create a Forward Lock object.

void WbxmlParserRel::AddDefaultPermissions ( )

Default permissions create a Forward Lock object.

void WbxmlParserRel::characters | ( | const SAXString & | chars,
 |  | byte & | tag
 | ) | [virtual]

void WbxmlParserRel::endDocument ( ) [virtual]

void WbxmlParserRel::endElement | ( | const SAXString & | name,
 |  | byte & | tag,
 |  | size_t | depth
 | ) | [virtual]

void WbxmlParserRel::error ( const SAXParseException & e ) [virtual]

void WbxmlParserRel::fatalError ( const SAXParseException & e ) [virtual]

DrmStatus WbxmlParserRel::GetParseStatus ( )

void WbxmlParserRel::ignorableWhitespace | ( | const SAXChar * | ch,
 |  | size_t | length
 | ) | [virtual]

void WbxmlParserRel::processingInstruction | ( | const SAXString & | target,
 |  | const SAXString & | data
 | ) | [virtual]

void WbxmlParserRel::setDocumentLocator ( const Locator & locator ) [virtual]

void WbxmlParserRel::startDocument ( ) [virtual]

void WbxmlParserRel::startElement | ( | const SAXString & | name,
 |  | const AttributeList & | atts,
 |  | byte & | tag,
 |  | size_t | depth
 | ) | [virtual]

void WbxmlParserRel::warning ( const SAXParseException & e ) [virtual]

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRelWbxml.hpp
  • AddOns/Drm/DrmRelWbxml.cpp
Generated on Wed Jan 25 02:22:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WbxmlRelHandler Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WbxmlRelHandler Class Reference

#include <Apoxi/AddOns/Drm/DrmRelWbxml.hpp>

Public Member Functions

virtual void | resolveAttributeName (Token token, CHAR *attributeName, size_t attributeNameLength, CHAR *attributeValuePrefix, size_t attributeValuePrefixLength)
virtual void | resolveAttributeValue (Token token, CHAR *attributeValue, size_t attributeValueLength)
virtual void | resolveTagName (Token token, CHAR *tagName, size_t tagNameLength)

Member Function Documentation

virtual void WbxmlRelHandler::resolveAttributeName | ( | Token | token,
 |  | CHAR * | attributeName,
 |  | size_t | attributeNameLength,
 |  | CHAR * | attributeValuePrefix,
 |  | size_t | attributeValuePrefixLength
 | ) | [inline, virtual]

virtual void WbxmlRelHandler::resolveAttributeValue | ( | Token | token,
 |  | CHAR * | attributeValue,
 |  | size_t | attributeValueLength
 | ) | [inline, virtual]

virtual void WbxmlRelHandler::resolveTagName | ( | Token | token,
 |  | CHAR * | tagName,
 |  | size_t | tagNameLength
 | ) | [inline, virtual]

The documentation for this class was generated from the following file:
  • AddOns/Drm/DrmRelWbxml.hpp
Generated on Wed Jan 25 02:22:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WbxmlVector< T > Class Template Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WbxmlVector< T > Class Template Reference

#include <Apoxi/AddOns/Wbxml/WbxmlVector.hpp>

Inheritance diagram for WbxmlVector< T >:

[legend]
Collaboration diagram for WbxmlVector< T >:

[legend]

Public Types

typedef Vector< T > | Base
typedef INT | DifferenceType
typedef Vector< T >::Iterator | iterator
typedef Vector< T >::ReverseIterator | reverse_iterator
typedef INT | SizeType

Public Member Functions

const T & | back () const
T & | back ()
iterator begin ()
void | clear ()
bool | empty () const
iterator end ()
iterator | erase (const iterator &first, const iterator &last)
iterator | erase (const iterator &pos)
const T & | front () const
T & | front ()
void | insert (const iterator &pos, SizeType n, const T &x)
iterator | insert (const iterator &pos, T &x)
void | push_back (const T &x)
reverse_iterator rbegin ()
reverse_iterator rend ()
void | reserve (SizeType n)
void | resize (SizeType n)
SizeType size ()
WbxmlVector ()

template<class T>
class WbxmlVector< T >

Member Typedef Documentation

template<class T>
typedef Vector<T> WbxmlVector< T >::Base

template<class T>
typedef INT WbxmlVector< T >::DifferenceType

Reimplemented from Vector< T >.

template<class T>
typedef Vector<T>::Iterator WbxmlVector< T >::iterator

template<class T>
typedef Vector<T>::ReverseIterator WbxmlVector< T >::reverse_iterator

template<class T>
typedef INT WbxmlVector< T >::SizeType

Reimplemented from Vector< T >.

Constructor & Destructor Documentation

template<class T>
WbxmlVector< T >::WbxmlVector ( ) [inline]

Member Function Documentation

template<class T>
const T& WbxmlVector< T >::back ( ) const [inline]

template<class T>
T& WbxmlVector< T >::back ( ) [inline]

template<class T>
iterator WbxmlVector< T >::begin ( ) [inline]

template<class T>
void WbxmlVector< T >::clear ( ) [inline]

template<class T>
bool WbxmlVector< T >::empty ( ) const [inline]

template<class T>
iterator WbxmlVector< T >::end ( ) [inline]

template<class T>
iterator WbxmlVector< T >::erase | ( | const iterator & | first,
 |  | const iterator & | last
 | ) | [inline]

template<class T>
iterator WbxmlVector< T >::erase ( const iterator & pos ) [inline]

template<class T>
const T& WbxmlVector< T >::front ( ) const [inline]

template<class T>
T& WbxmlVector< T >::front ( ) [inline]

template<class T>
void WbxmlVector< T >::insert | ( | const iterator & | pos,
 |  | SizeType | n,
 |  | const T & | x
 | ) | [inline]

template<class T>
iterator WbxmlVector< T >::insert | ( | const iterator & | pos,
 |  | T & | x
 | ) | [inline]

template<class T>
void WbxmlVector< T >::push_back ( const T & x ) [inline]

template<class T>
reverse_iterator WbxmlVector< T >::rbegin ( ) [inline]

template<class T>
reverse_iterator WbxmlVector< T >::rend ( ) [inline]

template<class T>
void WbxmlVector< T >::reserve ( SizeType n ) [inline]

template<class T>
void WbxmlVector< T >::resize ( SizeType n ) [inline]

template<class T>
SizeType WbxmlVector< T >::size ( ) [inline]

The documentation for this class was generated from the following file:
  • AddOns/Wbxml/WbxmlVector.hpp
Generated on Wed Jan 25 02:22:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Window Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Window Class Reference
[Components]

#include <Apoxi/Gui/Window.hpp>

Inheritance diagram for Window:

[legend]
Collaboration diagram for Window:

[legend]

Public Types

enum | { ID = 26 }

Public Member Functions

void | AddToTitlebar (DrawableObject &obj, BOOLEAN align_left=TRUE)
virtual BOOLEAN | Close (INT exit_code=0)
virtual Rect | GetClientRect () const
virtual XYDIM | GetDefaultHeight () const
virtual XYDIM | GetDefaultWidth () const
UINT8 | GetFocusPriority () const
Action * | GetLeftSoftkey () const
Wrapper-method for Window::GetSoftkey(0).
Action * | GetRightSoftkey () const
Wrapper-method for Window::GetSoftkey(KeyboardConfig::GetSoftkeyCount() - 1);.
Action * | GetSoftkey (INT index) const
Returns a pointer to the action representing the softkey with the index index.
virtual const WCHAR * | GetTitle () const
BOOLEAN | HasDefaultSize () const
void | Init (Control *parent=0)
virtual BOOLEAN | IsInstanceOf (INT id) const
BOOLEAN | IsOpen () const
Obsolete - use IsParentWindowOpen() instead.
BOOLEAN | IsSyncSoftkeysEnabled () const
BOOLEAN | IsTitleAnimated () const
BOOLEAN | IsTransparent () const
virtual void | Maximize ()
INT | OpenModal ()
virtual INT | OpenModal (const Rect &rect)
void | OpenModeless ()
virtual void | OpenModeless (const Rect &rect)
void | RemoveFromTitlebar (DrawableObject &obj)
virtual void | SetDefaultSize ()
void | SetFocusPriority (UINT8 priority)
void | SetLeftSoftkey (Action *action)
Wrapper-method for Window::SetSoftkey(0, action).
BOOLEAN | SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | SetRightSoftkey (Action *action)
Wrapper-method for Window::SetSoftkey(KeyboardConfig::GetSoftkeyCount() - 1, action).
virtual void | SetSoftkey (INT index, Action *action)
void | SetTitle (const WString &title)
Wrapper-method for SetTitle(w_str.GetCString()).
virtual void | SetTitle (const WCHAR *title)
void | SetTransparent (BOOLEAN enabled)
Window (Control *parent=0)
virtual | ~Window ()

Protected Member Functions

virtual const ControlFrameView * | GetFrameView () const
virtual void | OnActionExecuted (Action *action)
virtual void | OnClose ()
virtual void | OnGetFocus ()
virtual BOOLEAN | OnKeyDown (KeyCode key_code)
virtual void | OnLanguageChanged ()
virtual void | OnLayoutClient ()
virtual void | OnLayoutFrame ()
virtual void | OnLoseFocus ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual void | OnMove (XYDIM dx, XYDIM dy)
virtual void | OnOpen ()
virtual void | OnResize (XYDIM dx, XYDIM dy)
virtual void | OnThemeChanged ()
virtual void | Refresh (const Rect &rect)
void | SetDefaultSizeProperty (BOOLEAN has_default_size)
void | SetSyncSoftkeysEnabled (BOOLEAN enabled)

Detailed Description

A Window is a control with extended features: It can have a title, softkeys an can be opened modal or modeless.

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Reimplemented from Control.

Constructor & Destructor Documentation

Window::Window ( Control * parent = 0 )

Parameters:
parent Pointer to the parent control which embeds the window. Usually a window does only have a parent if it is embedded as child window inside a top level window.

Window::~Window ( ) [virtual]

Member Function Documentation

void Window::AddToTitlebar | ( | DrawableObject & | obj,
 |  | BOOLEAN | align_left = TRUE
 | ) |

Adds a drawable object to the titlebar of the window. If the window has no title, the drawable object won't be visible. Note that the width of the added drawable object won't be touched after adding it and it is recommended to set the desired width explicitely before.

Parameters:
obj | Drawable object which should be added. The object is obtained by the window until Window::RemoveFromTitle is invoked and hence may not be deleted before.
align_left | If set to TRUE, the drawable object will be aligned left from the title. If set to FALSE, it will be aligned right from the title.

BOOLEAN Window::Close ( INT exit_code = 0 ) [virtual]

Closes the window. Before closing the method Window::OnClose is invoked, followed by cleaning up the window and child-controls by invoking Control::Cleanup and reassigning the focus if required.

Parameters:
exit_code
See also:
Window::OnClose

Rect Window::GetClientRect ( ) const [virtual]

Returns the rectangle of the client area of a window in relation to the upper left of the window position. The client area is defined as area below the window title and inside the window border. If the bounding rectangle of the window is required, the method GetBoundingRect (see Component::GetBoundingRect) must be invoked.

See also:
Control::GetClientRect

Reimplemented from Control.

XYDIM Window::GetDefaultHeight ( ) const [virtual]

Returns:
Default height of the window (-1, if no default height has been specified).

Reimplemented from Component.

XYDIM Window::GetDefaultWidth ( ) const [virtual]

Returns:
Default width of the window (-1, if no default width has been specified).

Reimplemented from Component.

UINT8 Window::GetFocusPriority ( ) const [inline]

Returns the focus-priority of the window. Per default each window has the focus priority 127. See Window::SetFocusPriority for further details.

const ControlFrameView * Window::GetFrameView ( ) const [protected, virtual]

The window-frame-view from the current Theme is returned.

See also:
Control::GetFrameView()

Reimplemented from Control.

Action * Window::GetLeftSoftkey ( ) const

Wrapper-method for Window::GetSoftkey(0).

Action * Window::GetRightSoftkey ( ) const

Wrapper-method for Window::GetSoftkey(KeyboardConfig::GetSoftkeyCount() - 1);.

Action * Window::GetSoftkey ( INT index ) const

Returns a pointer to the action representing the softkey with the index index.

const WCHAR * Window::GetTitle ( ) const [virtual]

Returns the title of the window. For backward compatibility with APOXI versions < 1.9.0 a WCHAR-pointer is returned, but internally a WString is used. This means that the returned pointer is only declared as valid until the next SetTitle is invoked.

BOOLEAN Window::HasDefaultSize ( ) const [inline]

Returns TRUE, if the size of the window is the default-size, which means that it is aligned on the whole desktop respecting the panel. Invoking Window::SetSize, Window::SetWidth or SetHeight results in a non-default-size.

void Window::Init ( Control * parent = 0 )

Parameters:
parent Pointer to the parent control which embeds the window. Usually a window does only have a parent if it is embedded as child window inside a top level window.

BOOLEAN Window::IsInstanceOf ( INT id ) const [virtual]

See also:
Component::IsInstanceOf

Reimplemented from Control.

Reimplemented in AtlWindow, AtlItemGridWindow, AtlItemListWindow, AtlItemMenuWindow, Alert, ContextMenu, MessageBox, and Panel.

BOOLEAN Window::IsOpen ( ) const [inline]

Obsolete - use IsParentWindowOpen() instead.

Reimplemented from Control.

BOOLEAN Window::IsSyncSoftkeysEnabled ( ) const [inline]

Returns TRUE, if the synchronization between the softkeys of the window and the panel is enabled. Per default TRUE is returned.

BOOLEAN Window::IsTitleAnimated ( ) const

Returns TRUE, if the currently shown title will be animated automatically if the text exceeds the available width.

BOOLEAN Window::IsTransparent ( ) const [inline]

Returns TRUE, if the window is marked as transparent. See Window::SetTransparent for details.

void Window::Maximize ( ) [virtual]

See also:
Control::Maximize

Reimplemented from Control.

void Window::OnActionExecuted ( Action * action ) [protected, virtual]

Is called in the default-implementation of Action::Execute(), when the Action has been initialized with this control as Dispatcher.

See also:
Action

Reimplemented in AtlWindow, ContextMenu, and MessageBox.

void Window::OnClose ( ) [protected, virtual]

Is called, if the window will get closed and represents an entry-point for cleaning up things. When the window has the focus child-controls and the window itself will lose the focus after OnClose has been executed.

Reimplemented in AtlItemGridWindow, Alert, AbstractSmsViewerWin, ImageBrowserDetailWin, and SavingProgressWin.

void Window::OnGetFocus ( ) [protected, virtual]

See also:
Control::OnGetFocus

Reimplemented from Control.

Reimplemented in AtlWindow, AtlItemGridWindow, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, SmsViewerWin, and UibFolderWin.

BOOLEAN Window::OnKeyDown ( KeyCode key_code ) [protected, virtual]

See also:
Control::OnKeyDown

Reimplemented from Control.

Reimplemented in AtlWindow, AtlItemGridWindow, AtlItemMenuWindow, PropertyEditor, and ImageBrowserDetailWin.

void Window::OnLanguageChanged ( ) [protected, virtual]

See also:
Component::OnLanguageChanged

Reimplemented from Control.

Reimplemented in AtlWindow.

void Window::OnLayoutClient ( ) [protected, virtual]

See also:
Control::OnLayoutClient

Reimplemented from Control.

Reimplemented in AtlLabelListWindow, MessageBox, Panel, EmsComposeWin, SmsComposeWin, SmsViewerWin, ImageBrowserDetailWin, and SavingProgressWin.

void Window::OnLayoutFrame ( ) [protected, virtual]

Is invoked whenever the size of the window-frame is changed and also when opening a window. Represents an entry-point for layouting drawable-objects, which have been added as part of the frame.

See also:
DrawableObject::SetParentArea

DrawableObject::GetParentArea

void Window::OnLoseFocus ( ) [protected, virtual]

See also:
Control::OnLoseFocus

Reimplemented from Control.

Reimplemented in AtlWindow, and AtlItemMenuWindow.

BOOLEAN Window::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage

Reimplemented from Component.

Reimplemented in AtlWindow, AtlItemGridWindow, AtlItemMenuWindow, AtlLabelListWindow, Alert, ContextMenu, SavingProgressWin, and UibFolderWin.

void Window::OnMove | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnMove(dx, dy)

Reimplemented from Control.

void Window::OnOpen ( ) [protected, virtual]

Is called, when the Window is opened and can be used for further initialization (Window::IsOpen() returns TRUE when it is invoked inside OnOpen). Control::OnGetFocus() is invoked before OnOpen, Control::OnLayoutClient() is invoked after OnOpen. Use Control::SetBlocked() if user-interaction should be forbidden e. g. when reading out a large provider in OnOpen.

See also:
Control::SetBlocked()

Reimplemented in AtlWindow, AtlItemGridWindow, AtlItemListWindow, AtlItemMenuWindow, AtlLabelListWindow, BtAvrcpControllerDeviceListWindow, BtAvrcpDeviceListWin, BtDeviceListWindow, SmsComposeWin, FmRadioSelectStrongerFreq, ImageBrowserDetailWin, SavingProgressWin, and UibFolderWin.

void Window::OnResize | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [protected, virtual]

See also:
Component::OnResize(dx, dy)

Reimplemented from Control.

void Window::OnThemeChanged ( ) [protected, virtual]

See also:
Component::OnThemeChanged

Reimplemented from Control.

Reimplemented in AtlWindow, and Panel.

INT Window::OpenModal ( )

Wrapper method for Window::OpenModal(Rect()), which means that the window will be opened fullsized.

INT Window::OpenModal ( const Rect & rect ) [virtual]

Opens the window modal. This means that when invoking this method the caller is blocked until the window gets closed. Note that this does not mean that other applications or the message flow is blocked. Opening a window modeless is e. g. useful for yes/no-dialogs if the result is needed immediately. Opening windows modal lead to a higher call stack, hence it is recommended to avoid opening modal windows in a recursive manner.

Parameters:
rect Specifies the size of the window (by default the window will be opened fullsized).
Returns:
Exit-code (per default 0 is returned).

Reimplemented in Alert.

void Window::OpenModeless ( )

Wrapper method for Window::OpenModeless(Rect()), which means that the window will be opened fullsized.

void Window::OpenModeless ( const Rect & rect ) [virtual]

Opens the window modeless. This means that immediatly after the window has been opened the caller of this method may continue and the closing of the window is done in an asynchronous manner.

Parameters:
rect Specifies the size of the window (by default the window will be opened fullsized).

Reimplemented in Alert, and EmsComposeWin.

void Window::Refresh ( const Rect & rect ) [protected, virtual]

See also:
Control::Refresh(const Rect& rect)

Reimplemented from Control.

Reimplemented in ContextMenu.

void Window::RemoveFromTitlebar ( DrawableObject & obj )

Removes the drawable object obj from the titlebar of the window.

void Window::SetDefaultSize ( ) [virtual]

Sets the size of the window to the default-size, which means that it is aligned on the whole desktop respecting the panel.

Reimplemented in AtlWindow.

void Window::SetDefaultSizeProperty ( BOOLEAN has_default_size ) [inline, protected]

Adjusts the default size property of the window without triggering any resize. This might be useful when derived windows implement their customized strategy for defining a default size of the window and require to invoke Window::SetSize. As application developer it usually should not be necessary to invoke this method (Window::SetDefaultSize should be used instead).

void Window::SetFocusPriority ( UINT8 priority )

Sets the focus-priority of the window. A window with a lower focus-priority then the currently focused window can not get the focus. Per default each window has the focus priority 127. Note that the focus-priority only matters if a window is open, closed windows never may get a focus. If the focus-priority of a window is changed while the window is open, the window-order is changed to respect the settings. This means that the window may lose the focus if the focus-priority is decreased and may get the focus if the priority is increased.

void Window::SetLeftSoftkey ( Action * action )

Wrapper-method for Window::SetSoftkey(0, action).

BOOLEAN Window::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) |

Used by Aragon to read out the windows property out of the resource parser. It is not allowed for an application developer to invoke this method in a direct manner.

Reimplemented from Control.

Reimplemented in AtlWindow, Alert, ContextMenu, and MessageBox.

void Window::SetRightSoftkey ( Action * action )

Wrapper-method for Window::SetSoftkey(KeyboardConfig::GetSoftkeyCount() - 1, action).

void Window::SetSoftkey | ( | INT | index,
 |  | Action * | action
 | ) | [virtual]

Sets the softkey for the window, which will be shown in the panel of the desktop.

Parameters:
index | Index of the softkey. The maximum number of softkeys can be retrieved by KeyboardConfig::GetSoftkeyCount.
action | Action which should be executed when pressing the softkey.

Reimplemented in AtlWindow.

void Window::SetSyncSoftkeysEnabled ( BOOLEAN enabled ) [inline, protected]

Allows to enable/disable the synchronization of the softkeys of the window with the panel. Per default the synchronization is enabled.

void Window::SetTitle ( const WString & title )

Wrapper-method for SetTitle(w_str.GetCString()).

void Window::SetTitle ( const WCHAR * title ) [virtual]

Parameters:
title Title of the window. By default the window has no title. To hide the title while the window is open, SetTitle(0) can be invoked.

Reimplemented in AtlWindow.

void Window::SetTransparent ( BOOLEAN enabled )

Marks the window as transparent if enabled is TRUE. Per default each window is not transparent. To see the transparency the window frame and/or the client area must be drawn by using alpha blending. To keep the resource demand low and the performance high some restrictions are given:

  • The transparency is only respected if the window is in foreground. This means if a window below updates it's content, the transparent foreground window automatically will be redrawn. If the window is marked as transparent and is not in foreground updates of windows behind won't be visible inside the boundaries of the transparent window.
  • The update of windows behind the transparent foreground window are only respected for windows belonging to the same application. Marking the window as transparent mostly is used if a window frame with a fading shadow should be used for popup menus or message boxes.

The documentation for this class was generated from the following files:
  • Gui/Window.hpp
  • Gui/Window.cpp
Generated on Wed Jan 25 02:22:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WindowFrameView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WindowFrameView Class Reference
[GUI]

#include <Apoxi/Gui/WindowFrameView.hpp>

Inheritance diagram for WindowFrameView:

[legend]
Collaboration diagram for WindowFrameView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
XYDIM | GetSoftkeyBarHeight () const
XYDIM | GetTitleHeight () const
const TextFormat & | GetTitleTextFormat () const
BOOLEAN | IsActive (const Control &control) const
WindowFrameView (XYDIM left_size, XYDIM top_size, XYDIM right_size, XYDIM bottom_size, XYDIM title_height, XYDIM softkey_bar_height)
WindowFrameView ()
virtual | ~WindowFrameView ()

Protected Member Functions

virtual void | DrawWindowExtensions (const Window &window, DeviceContext *dc, const Rect &repaint_rect) const =0
void | SetSoftkeyBarHeight (XYDIM height)
void | SetTitleHeight (XYDIM height)
void | SetTitleTextFormat (const TextFormat &text_format)

Detailed Description

View which is able to draw the frame of a window including the window title.

Constructor & Destructor Documentation

WindowFrameView::WindowFrameView ( )

WindowFrameView::WindowFrameView | ( | XYDIM | left_size,
 |  | XYDIM | top_size,
 |  | XYDIM | right_size,
 |  | XYDIM | bottom_size,
 |  | XYDIM | title_height,
 |  | XYDIM | softkey_bar_height
 | ) |

WindowFrameView::~WindowFrameView ( ) [virtual]

Member Function Documentation

void WindowFrameView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

See also:
View::Draw

Reimplemented from ControlFrameView.

virtual void WindowFrameView::DrawWindowExtensions | ( | const Window & | window,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [protected, pure virtual]

See also:
ControlFrameView::DrawWindowExenstions

Implemented in BlueSkyWindowFrameView, DefaultWindowFrameView, TestWindowFrameView, CTWindowFrameView, DefaultWindowFrameView, and FoggyWindowFrameView.

XYDIM WindowFrameView::GetSoftkeyBarHeight ( ) const [inline]

Obsolete - the softkeybar has been replaced by the panel since APOXI-1.8.

XYDIM WindowFrameView::GetTitleHeight ( ) const [inline]

Returns the height of the title in pixels. Note that the outer frame of the window is not part of the title.

const TextFormat& WindowFrameView::GetTitleTextFormat ( ) const [inline]

Returns the textformat used for the window title. Derived views may set the text format in their constructor by invoking WindowFrameView::SetTitleTextFormat().

BOOLEAN WindowFrameView::IsActive ( const Control & control ) const

Returns TRUE, if the frame should be shown in the active mode which usually means that the frame has the focus. It is recommended that the implementation of the methods WindowFrameView::DrawWindowExtensions and WindowFrameView::DrawControlFrame use this method instead of just asking 'BOOLEAN is_active = control.HasFocus()', as WindowFrameView::IsActive includes some optimizations which prevent flickering when switching the focus between applications.

void WindowFrameView::SetSoftkeyBarHeight ( XYDIM height ) [inline, protected]

Obsolete - the softkeybar has been replaced by the panel since APOXI-1.8.

void WindowFrameView::SetTitleHeight ( XYDIM height ) [inline, protected]

Sets the height of the title in pixels. Note that the outer frame of the window is not part of the title.

void WindowFrameView::SetTitleTextFormat ( const TextFormat & text_format ) [inline, protected]

Sets the textformat used for the window title.

The documentation for this class was generated from the following files:
  • Gui/WindowFrameView.hpp
  • Gui/WindowFrameView.cpp
Generated on Wed Jan 25 02:22:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WindowHierarchyIterator Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WindowHierarchyIterator Class Reference
[GUI]

#include <Apoxi/Gui/WindowManager.hpp>

Public Member Functions

BOOLEAN | Begin (const Window *win=0)
Window * | Get (Application **app=0) const
BOOLEAN | Next ()
WindowHierarchyIterator | operator++ (INT)
WindowHierarchyIterator & operator++ ()
WindowHierarchyIterator | operator-- (INT)
WindowHierarchyIterator & operator-- ()
BOOLEAN | Previous ()
void | Release ()
Obsolete - releasing is done automatically in the destructor.
WindowHierarchyIterator (const Window *win=0)
~WindowHierarchyIterator ()

Detailed Description

Allows to iterate over all opened windows in the order of the window stack. Sample code:
{
  const Application* active_app = System::GetActiveApplication();
  for (WindowHierarchyIterator it; it.Get() != 0; ++it) {
      Application* app = 0;
      Window* win = it.Get(&app);
      if (app == active_app) {
        // do something with the window...
      }
    }
  }
} // assure that the destructor of win_it is invoked as early as possible

Note that the window-stack will be locked until the destructor of the WindowHierarchyIterator will be invoked. To assure that the destructor is invoked as early as possible, it is recommended to put an additional scope around the code like shown in the example. It is not allowed to invoke window methods from a different application context than the window belongs to.

Constructor & Destructor Documentation

WindowHierarchyIterator::WindowHierarchyIterator ( const Window * win = 0 )

Parameters:
win Optional input parameter, which defines the starting window. If 0 is used, the window which is on top is used.

WindowHierarchyIterator::~WindowHierarchyIterator ( )

Member Function Documentation

BOOLEAN WindowHierarchyIterator::Begin ( const Window * win = 0 )

Resets the iterator to the begin. Returns TRUE if the window-stack contains at least one window. WindowHierarchyIterator::Get returns this window.

Parameters:
win Optional input parameter, which defines the starting window. If 0 is used, the window which is on top is used.

Window * WindowHierarchyIterator::Get ( Application ** app = 0 ) const

Returns the current window of the iterator.

Parameters:
app Optional output-parameter which contains the application the window belongs too.

BOOLEAN WindowHierarchyIterator::Next ( )

Returns TRUE if the window-stack has a next window. WindowHierarchyIterator::Get returns this window.

WindowHierarchyIterator WindowHierarchyIterator::operator++ ( INT )

Moves the iterator to the next window.

WindowHierarchyIterator & WindowHierarchyIterator::operator++ ( )

Moves the iterator to the next window.

WindowHierarchyIterator WindowHierarchyIterator::operator-- ( INT )

Moves the iterator to the previous window.

WindowHierarchyIterator & WindowHierarchyIterator::operator-- ( )

Moves the iterator to the previous window.

BOOLEAN WindowHierarchyIterator::Previous ( )

Returns TRUE if the window-stack has a previous window. WindowHierarchyIterator::Get returns this window.

void WindowHierarchyIterator::Release ( ) [inline]

Obsolete - releasing is done automatically in the destructor.

The documentation for this class was generated from the following files:
  • Gui/WindowManager.hpp
  • Gui/WindowManager.cpp
Generated on Wed Jan 25 02:22:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WindowManager Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WindowManager Class Reference
[GUI]

#include <Apoxi/Gui/WindowManager.hpp>

Collaboration diagram for WindowManager:

[legend]

Static Public Member Functions

static Window * | GetDisplayForegrWin (INT display_idx)
static Window * | GetForegroundWindow ()
static void | Insert (Window *win, Window *foregr_win=0)
static BOOLEAN | IsAlphaMaskEnabled ()
static void | Remove (Window *win)
static void | SetAlphaMaskEnabled (BOOLEAN flag)

Friends

class | WindowHierarchyIterator

Data Structures

struct | Node

Detailed Description

Central instance managing all currently opened windows. For traversing opened windows it is recommended to use the WindowHierarchyIterator instead of accessing the WindowManager directly.

Member Function Documentation

Window * WindowManager::GetDisplayForegrWin ( INT display_idx ) [static]

Returns a pointer to the foreground window of the display with index display_idx.

static Window* WindowManager::GetForegroundWindow ( ) [inline, static]

Returns a pointer to the window staying in foreground. Note that on the returned window operations may only be invoked if they are executed in the context of its application.

void WindowManager::Insert | ( | Window * | win,
 |  | Window * | foregr_win = 0
 | ) | [static]

Inserts the window win on top of the window-stack, if foregr_win is 0. Otherwise the window is inserted below foregr_win. Invoking this method should not be necessary by the MMI, as it is used internally when opening a window.

BOOLEAN WindowManager::IsAlphaMaskEnabled ( ) [static]

Returns TRUE, if the alpha mask is enabled. See WindowManager::SetAlphaMaskEnabled for details.

void WindowManager::Remove ( Window * win ) [static]

Removes the window win from the window-stack. Invoking this method should not be necessary by the MMI, as it is used internally when closing a window.

void WindowManager::SetAlphaMaskEnabled ( BOOLEAN flag ) [static]

The APOXI display device allows to have an alpha mask, which might get blended with a viewfinder or a video. As updating the alpha mask can get very time consuming, each application has to turn on the alpha mask explicitely by this method, if it shows a viewfinder or a video. It is recommended that the application turns on the alpha channel inside Window::OnOpen and turning off inside Window::OnClose. APOXI does a reference counting internally, so that a nested invoking of different applications does not have any side effects.

Friends And Related Function Documentation

friend class WindowHierarchyIterator [friend]

The documentation for this class was generated from the following files:
  • Gui/WindowManager.hpp
  • Gui/WindowManager.cpp
Generated on Wed Jan 25 02:22:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WinMenuItem Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WinMenuItem Class Reference

#include <Apoxi/Compat/WinMenuItem.hpp>

Inheritance diagram for WinMenuItem:

[legend]
Collaboration diagram for WinMenuItem:

[legend]

Public Member Functions

Window * GetWindow ()
void Init (Window *win, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
WinMenuItem (Window *win, const WCHAR *text=0, const BitmapRes *bitmap=0, BOOLEAN enabled=TRUE)
WinMenuItem ()

Detailed Description

Obsolete - a WinMenuItem is needed by a MenuList, which is obsolete. Use Menu and MenuAccessor from Gui instead.

Constructor & Destructor Documentation

WinMenuItem::WinMenuItem ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

WinMenuItem::WinMenuItem | ( | Window * | win,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

Member Function Documentation

Window* WinMenuItem::GetWindow ( ) [inline]

void WinMenuItem::Init | ( | Window * | win,
 |  | const WCHAR * | text = 0,
 |  | const BitmapRes * | bitmap = 0,
 |  | BOOLEAN | enabled = TRUE
 | ) |

The documentation for this class was generated from the following files:
  • Compat/WinMenuItem.hpp
  • Compat/WinMenuItem.cpp
Generated on Wed Jan 25 02:22:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WinRect Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WinRect Class Reference

#include <Apoxi/Compat/WinRect.hpp>

Collaboration diagram for WinRect:

[legend]

Public Member Functions

XYDIM | GetAbsBottom () const
XYDIM | GetAbsLeft () const
const Rect & | GetAbsRect () const
XYDIM | GetAbsRight () const
XYDIM | GetAbsTop () const
XYDIM | GetBottom () const
XYDIM | GetHeight () const
XYDIM | GetLeft () const
const Rect & | GetRect () const
XYDIM | GetRight () const
Size | GetSize () const
XYDIM | GetTop () const
XYDIM | GetWidth () const
void | Init (const Rect &rect, XYDIM abs_left=0, XYDIM abs_top=0)
void | Move (XYDIM dx, XYDIM dy)
void | SetBottom (XYDIM bottom)
void | SetHeight (XYDIM height)
void | SetLeft (XYDIM left)
void | SetRight (XYDIM right)
void | SetSize (XYDIM width, XYDIM height)
void | SetTop (XYDIM top)
void | SetWidth (XYDIM width)
void | UpdateAbsRect (XYDIM dx, XYDIM dy)
WinRect (const Rect &rect, XYDIM abs_left=0, XYDIM abs_top=0)
WinRect ()

Detailed Description

Obsolete - Describes a rectangle, which is stored in absolute and relative coordinates.

Constructor & Destructor Documentation

WinRect::WinRect ( )

If the default constructor is used, the parameters have to be provided by using the method Init.

WinRect::WinRect | ( | const Rect & | rect,
 |  | XYDIM | abs_left = 0,
 |  | XYDIM | abs_top = 0
 | ) |

Parameters:
rect | Bounding rectangle given in relative coordinates.
abs_left | Left position of the rectangle given in absolute coordinates.
abs_top | Top position of the rectangle given in absolute coordinates.

Member Function Documentation

XYDIM WinRect::GetAbsBottom ( ) const [inline]

Returns:
Bottom position given in absolute coordinates.

XYDIM WinRect::GetAbsLeft ( ) const [inline]

Returns:
Left position given in absolute coordinates.

const Rect & WinRect::GetAbsRect ( ) const

Parameters:
Bounding rectangle in absolute coordinates.

XYDIM WinRect::GetAbsRight ( ) const [inline]

Returns:
Right position given in absolute coordinates.

XYDIM WinRect::GetAbsTop ( ) const [inline]

Returns:
Top position given in absolute coordinates.

XYDIM WinRect::GetBottom ( ) const [inline]

Returns:
Bottom position given in relative coordinates.

XYDIM WinRect::GetHeight ( ) const [inline]

Returns:
Height in relative coordinates.

XYDIM WinRect::GetLeft ( ) const [inline]

Returns:
Left position given in relative coordinates.

const Rect & WinRect::GetRect ( ) const

Returns:
Bounding rectangle in relative coordinates.

XYDIM WinRect::GetRight ( ) const [inline]

Returns:
Right position given in relative coordinates.

Size WinRect::GetSize ( ) const [inline]

Returns:
Size in relative coordinates.

XYDIM WinRect::GetTop ( ) const [inline]

Returns:
Top position given in relative coordinates.

XYDIM WinRect::GetWidth ( ) const [inline]

Returns:
Width given in relative coordinates.

void WinRect::Init | ( | const Rect & | rect,
 |  | XYDIM | abs_left = 0,
 |  | XYDIM | abs_top = 0
 | ) |

Parameters:
rect | Bounding rectangle given in relative coordinates.
abs_left | Left position of the rectangle given in absolute coordinates.
abs_top | Top position of the rectangle given in absolute coordinates.

void WinRect::Move | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) | [inline]

Moves the relative bounding rectangle.

Parameters:
dx | x-difference to the old position.
dy | y-difference to the old position.

void WinRect::SetBottom ( XYDIM bottom )

Parameters:
bottom Bottom position given in relative coordinates.

void WinRect::SetHeight ( XYDIM height ) [inline]

Parameters:
height Height in relative coordinates.

void WinRect::SetLeft ( XYDIM left )

Parameters:
left Left position given in relative coordinates.

void WinRect::SetRight ( XYDIM right )

Parameters:
right Right position given in relative coordinates.

void WinRect::SetSize | ( | XYDIM | width,
 |  | XYDIM | height
 | ) | [inline]

Parameters:
width | Width in relative coordinates.
height | Height in relative coordinates.

void WinRect::SetTop ( XYDIM top )

Parameters:
top Top position given in relative coordinates.

void WinRect::SetWidth ( XYDIM width ) [inline]

Parameters:
width Width given in relative coordinates.

void WinRect::UpdateAbsRect | ( | XYDIM | dx,
 |  | XYDIM | dy
 | ) |

Updates the absolute rectangle.

Parameters:
dx | x-difference to the old position.
dy | y-difference to the old position.

The documentation for this class was generated from the following files:
  • Compat/WinRect.hpp
  • Compat/WinRect.cpp
Generated on Wed Jan 25 02:22:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WStrData Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WStrData Struct Reference
[Auxiliary]

#include <Apoxi/Auxiliary/WString.hpp>

Collaboration diagram for WStrData:

[legend]

Public Member Functions

void | DecRefCount ()
UINT | GetBufSize () const
UINT | GetLength () const
BOOLEAN | HasMultipleRefs () const
BOOLEAN | IncRefCount ()
BOOLEAN | IsNullStr () const
void | operator delete (void *p)
void * | operator new (UINT s, UINT wchar_count)
void | ResetRefCount ()
void | SetBufSize (UINT n)
void | SetLength (UINT n)
WCHAR * | ToPtr ()
const WCHAR * | ToPtr () const

Static Public Member Functions

static WStrData * | FromPtr (WCHAR *str)
static WCHAR * | GetNullStr ()

Data Fields

UINT16 | m_bufsize
UINT8 | m_len
UINT8 | m_refcount

Static Public Attributes

static WCHAR * | m_null_str = &g_null_str.m_wchar
static WStrData * | m_null_strbuf = &g_null_str.m_strdata

Detailed Description

WStrData is the internal data structure storing the string buffer for a WString object. In memory string data is immediately following the object. Object data and method members are private to WString class and must not used by any other instance.

Member Function Documentation

void WStrData::DecRefCount ( )

Decrement the internal reference counter. Deletes object if last referenced is released.

static WStrData* WStrData::FromPtr ( WCHAR * str ) [inline, static]

Get corresponding WStrData object from pointer to string data.

UINT WStrData::GetBufSize ( ) const [inline]

Returns the overall buffer size of the string object.

UINT WStrData::GetLength ( ) const

Return the length of string data excluding trailing null ch.

static WCHAR* WStrData::GetNullStr ( ) [inline, static]

Get special WStrData pointing to null string.

BOOLEAN WStrData::HasMultipleRefs ( ) const [inline]

Returns true if multiple WString objects reference the WStrData object.

BOOLEAN WStrData::IncRefCount ( )

Increment the internal reference counter. Returns true on success and false if maximum is reached.

BOOLEAN WStrData::IsNullStr ( ) const [inline]

Null has special internal handling. Returns true if the WStrData object is the unique null (i.e. string with zero length).

void WStrData::operator delete ( void * p )

Delete operator for WStrData.

void * WStrData::operator new | ( | UINT | s,
 |  | UINT | wchar_count
 | ) |

Operator new allocates a consecutive memory block with size sizeof(WStrData) + wchar_count * 2.

void WStrData::ResetRefCount ( )

Reset reference counter of string data.

void WStrData::SetBufSize ( UINT n )

Set buffer size of string data.

void WStrData::SetLength ( UINT n )

Set length of string data.

WCHAR* WStrData::ToPtr ( ) [inline]

Get the pointer to string data for this object.

const WCHAR* WStrData::ToPtr ( ) const [inline]

Get the pointer to constant string data for this object.

Field Documentation

UINT16 WStrData::m_bufsize

UINT8 WStrData::m_len

WCHAR * WStrData::m_null_str = &g_null_str.m_wchar [static]

WStrData * WStrData::m_null_strbuf = &g_null_str.m_strdata [static]

UINT8 WStrData::m_refcount

The documentation for this struct was generated from the following files:
  • Auxiliary/WString.hpp
  • Auxiliary/WString.cpp
Generated on Wed Jan 25 02:22:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: WString Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

WString Class Reference
[Auxiliary]

#include <Apoxi/Auxiliary/WString.hpp>

Inheritance diagram for WString:

[legend]

Public Member Functions

void | Clear ()
Empties the object and sets its size to zero and also frees used memory.
INT | CompareTo (const WCHAR *other_str, BOOLEAN ignore_case=TRUE, BOOLEAN locale_sensitive=TRUE) const
INT | CompareTo (const WString &other_str, BOOLEAN ignore_case=TRUE, BOOLEAN locale_sensitive=TRUE) const
BOOLEAN | EndsWith (WCHAR chr) const
Returns TRUE if the character chr matches with the end of the string.
BOOLEAN | EndsWith (const WString &other) const
Returns TRUE if the string other matches with the end of the string.
void | Erase (INT from, INT char_count)
Erase char_count substring starting from position from.
void | Erase (INT from)
Empties the object from position from until its end and adjusts its size.
void | Format (const WCHAR *format,...)
Stores a series of characters and values in the object. Syntax is equivalent to printf.
const WCHAR * | GetCString () const
const UINT8 * | GetData () const
Returns the UINT8 * pointer of the content of the object.
INT | GetLength () const
Returns the current number of wide characters of the object, excluding terminating zero.
INT | GetMemSize () const
Returns the memory needed by the object. This is implementation dependent.
INT | GetSize () const
Returns the current number of used bytes of the object, excluding terminating zero.
INT | IndexOf (const WCHAR *str, INT from=0) const
INT | IndexOf (const WString &str, INT from=0) const
INT | IndexOf (WCHAR ch, INT from=0) const
void | Insert (INT pos, const WString &str)
void | Insert (INT pos, WCHAR ch)
BOOLEAN | IsEmpty () const
Checks whether the number of characters of the object is zero.
BOOLEAN | IsNumeric (INT number=-1) const
Checks if the wstring only contains digits '0' to '9', starting at position number.
INT | LastIndexOf (WCHAR ch, INT from=-1) const
operator const WCHAR * () const
BOOLEAN | operator!= (const WString &str) const
Checks whether the object and str are not identical.
WString | operator+ (const WCHAR *str) const
Returnes the concatenation of the object and the zero terminated WCHAR string str.
WString | operator+ (const WString &str) const
Returnes the concatenation of the object and the str object.
void | operator+= (const WCHAR *str)
Concatenates the zero terminated WCHAR string to the object.
void | operator+= (const CHAR *str)
Concatenates the zero terminated CHAR string to the object.
void | operator+= (const WString &str)
Concatenates WString str to the object.
void | operator+= (const String &str)
Concatenates String str to the object.
BOOLEAN | operator< (const WString &right) const
Checks whether the object is smaller than right.
WString & | operator<< (INT32 number)
Concatenates number to the object. Repetitive use is possible (a << b << c).
WString & | operator<< (const WCHAR *right)
Concatenates zero terminated WCHAR right to the object. Repetitive use is possible (a << b << c).
WString & | operator<< (const CHAR *right)
Concatenates zero terminated CHAR right to the object. Repetitive use is possible (a << b << c).
WString & | operator<< (const WString *right)
Concatenates WString right to the object. Repetitive use is possible (a << b << c).
WString & | operator<< (const WString &right)
Concatenates WString right to the object. Repetitive use is possible (a << b << c).
WString & | operator<< (const String *right)
Concatenates String right to the object. Repetitive use is possible (a << b << c).
WString & | operator<< (const String &right)
Concatenates String right to the object. Repetitive use is possible (a << b << c).
BOOLEAN | operator<= (const WString &right) const
Checks whether the object is smaller or equal than right.
WString & | operator= (const WCHAR *str)
Assigns a new value to the wstring object based on zero terminated WCHAR string.
WString & | operator= (const WString &str)
Assigns a new value to the wstring object.
BOOLEAN | operator== (const WCHAR *str) const
Checks whether the object and str are identical.
BOOLEAN | operator== (const WString &str) const
Checks whether the object and str are identical.
BOOLEAN | operator> (const WString &right) const
Checks whether the object is greater than right.
BOOLEAN | operator>= (const WString &right) const
Checks whether the object is greater or equal than right.
WCHAR | operator[] (INT pos) const
Returns the wide ch of the object at position pos.
BOOLEAN | PreAlloc (UINT char_count)
void | Replace (INT pos, WCHAR ch)
Replaces ch at position pos with ch.
BOOLEAN | Reserve (UINT char_count)
void | Scan (const WCHAR *format,...) const
Scans the string for a series of values in the object. Syntax is equivalent to scanf.
BOOLEAN | StartsWith (WCHAR chr) const
Returns TRUE if the character chr matches with the start of the string.
BOOLEAN | StartsWith (const WString &other) const
Returns TRUE if the string other matches with the start of the string.
void | StrCopy (const WCHAR *buffer, INT len)
Initializes the object by len wide characters of a wide character buffer.
WString | Substring (INT start, INT length=-1) const
void | Swap (WString &str)
Exchanges the content of the object and str.
WString & ToLower ()
Converts all characters of the object into lower case characters.
String | ToString () const
Returns the content of the object as a String object.
WString & ToUpper ()
Converts all characters of the object into upper case characters.
String | ToUtf8String () const
void | VFormat (const WCHAR *format, va_list args)
Accepts a pointer to an argument list. Syntax is equivalent to ANSI vprintf.
WString (WCHAR ch)
Creates a WString object containing the single wide character ch.
WString (INT32 val)
Creates a WString object that is initialized with the WString representing val.
WString (const String &str)
Creates a WString object based on a string object.
WString (const CHAR *str)
Creates a WString object based on a zero terminated CHAR string.
WString (const WString *str)
Creates a WString object based on an existing WString object.
WString (const WString &str)
Creates a WString object based on an existing WString object.
WString (const UINT8 *str, UINT len)
Creates a WString object based on len bytes of a byte buffer.
WString (const WCHAR *str, UINT len)
Creates a WString object based on len characters of a WCHAR string.
WString (const WCHAR *str)
Creates a WString object based on a zero terminated WCHAR string.
WString ()
Creates an empty WString object.
~WString ()
Destroys the WString object and frees the memory of the wide character array.

Static Public Member Functions

static INT | Compare (const WString &s1, const WString &s2, BOOLEAN ignore_case=TRUE, BOOLEAN locale_sensitive=TRUE)
static BOOLEAN | IsNumeric (const WCHAR *string, INT number=-1)
Checks if the WCHAR string only contains digits '0' to '9', starting at position number.

Friends

class | String

Constructor & Destructor Documentation

WString::WString ( )

Creates an empty WString object.

WString::WString ( const WCHAR * str )

Creates a WString object based on a zero terminated WCHAR string.

WString::WString | ( | const WCHAR * | str,
 |  | UINT | len
 | ) |

Creates a WString object based on len characters of a WCHAR string.

WString::WString | ( | const UINT8 * | str,
 |  | UINT | len
 | ) |

Creates a WString object based on len bytes of a byte buffer.

WString::WString ( const WString & str )

Creates a WString object based on an existing WString object.

WString::WString ( const WString * str )

Creates a WString object based on an existing WString object.

WString::WString ( const CHAR * str )

Creates a WString object based on a zero terminated CHAR string.

WString::WString ( const String & str )

Creates a WString object based on a string object.

WString::WString ( INT32 val )

Creates a WString object that is initialized with the WString representing val.

WString::WString ( WCHAR ch )

Creates a WString object containing the single wide character ch.

WString::~WString ( )

Destroys the WString object and frees the memory of the wide character array.

Member Function Documentation

void WString::Clear ( )

Empties the object and sets its size to zero and also frees used memory.

static INT WString::Compare | ( | const WString & | s1,
 |  | const WString & | s2,
 |  | BOOLEAN | ignore_case = TRUE,
 |  | BOOLEAN | locale_sensitive = TRUE
 | ) | [inline, static]

Returns 0 if the WStrings s1 and s2 are equal, < 0 if s1 is less than s2, > 0 otherwise.

Parameters:
ignore_case | If set to TRUE, the comparison is done case insensitive, hence the string L"ABC" is interpreted as equal to the string L"abc".
locale_sensitive | If set to TRUE, a locale sensitive comparing is done. Locale sensitive comparing should be done for all sorted strings shown to the user.

INT WString::CompareTo | ( | const WCHAR * | other_str,
 |  | BOOLEAN | ignore_case = TRUE,
 |  | BOOLEAN | locale_sensitive = TRUE
 | ) | const [inline]

Returns 0 if the object is equal to WString other_str, < 0 if the object is less than WString other_str, > 0 otherwise.

Parameters:
ignore_case | If set to TRUE, the comparison is done case insensitive, hence the string L"ABC" is interpreted as equal to the string L"abc".
locale_sensitive | If set to TRUE, a locale sensitive comparing is done. Locale sensitive comparing should be done for all sorted strings shown to the user.

INT WString::CompareTo | ( | const WString & | other_str,
 |  | BOOLEAN | ignore_case = TRUE,
 |  | BOOLEAN | locale_sensitive = TRUE
 | ) | const [inline]

Returns 0 if the object is equal to WString other_str, < 0 if the object is less than WString other_str, > 0 otherwise.

Parameters:
ignore_case | If set to TRUE, the comparison is done case insensitive, hence the string L"ABC" is interpreted as equal to the string L"abc".
locale_sensitive | If set to TRUE, a locale sensitive comparing is done. Locale sensitive comparing should be done for all sorted strings shown to the user.

BOOLEAN WString::EndsWith ( WCHAR chr ) const

Returns TRUE if the character chr matches with the end of the string.

BOOLEAN WString::EndsWith ( const WString & other ) const

Returns TRUE if the string other matches with the end of the string.

void WString::Erase | ( | INT | from,
 |  | INT | char_count
 | ) |

Erase char_count substring starting from position from.

void WString::Erase ( INT from )

Empties the object from position from until its end and adjusts its size.

void WString::Format | ( | const WCHAR * | format,
 |  |  | ...
 | ) |

Stores a series of characters and values in the object. Syntax is equivalent to printf.

const WCHAR* WString::GetCString ( ) const [inline]

Returns the WCHAR * pointer of the content of the object. Please be aware, that this returned pointer is never 0. Even if the wide character string is empty, this returned pointer will point to an empty, null terminated WCHAR * string. This means that using this method and comparing it's return value to 0 for testing the WString on emptyness is not correct - for checking on emptyness, the method IsEmpty() has to be used instead.

const UINT8* WString::GetData ( ) const [inline]

Returns the UINT8 * pointer of the content of the object.

INT WString::GetLength ( ) const

Returns the current number of wide characters of the object, excluding terminating zero.

INT WString::GetMemSize ( ) const

Returns the memory needed by the object. This is implementation dependent.

INT WString::GetSize ( ) const

Returns the current number of used bytes of the object, excluding terminating zero.

INT WString::IndexOf | ( | const WCHAR * | str,
 |  | INT | from = 0
 | ) | const [inline]

Searches for the first occurrence of str starting from from. If from is omitted the search starts at position zero. The position of the found character is returned (-1 is returned if the character has not been found).

INT WString::IndexOf | ( | const WString & | str,
 |  | INT | from = 0
 | ) | const [inline]

Searches for the first occurrence of the WString str starting from from. If from is omitted the search starts at position zero. The position of the found character is returned (-1 is returned if the character has not been found).

INT WString::IndexOf | ( | WCHAR | ch,
 |  | INT | from = 0
 | ) | const

Searches for the first occurrence of the wide character ch starting from from. If from is omitted the search starts at position zero. The position of the found character is returned (-1 is returned if the character has not been found).

void WString::Insert | ( | INT | pos,
 |  | const WString & | str
 | ) |

Inserts the string str at the position pos. If pos is smaller than 0 than the string will be appended to the end.

void WString::Insert | ( | INT | pos,
 |  | WCHAR | ch
 | ) |

Inserts the single character ch at the position pos. If pos is smaller than 0 than the character will be appended to the end.

BOOLEAN WString::IsEmpty ( ) const [inline]

Checks whether the number of characters of the object is zero.

BOOLEAN WString::IsNumeric | ( | const WCHAR * | string,
 |  | INT | number = -1
 | ) | [static]

Checks if the WCHAR string only contains digits '0' to '9', starting at position number.

BOOLEAN WString::IsNumeric ( INT number = -1 ) const [inline]

Checks if the wstring only contains digits '0' to '9', starting at position number.

INT WString::LastIndexOf | ( | WCHAR | ch,
 |  | INT | from = -1
 | ) | const

Returns the index within this wide character string of the last occurrence of the specified character ch, searching backwards starting at the specified index. If from is omitted the search starts at the end of the string. The position of the found character is returned (-1 is returned if the character has not been found).

WString::operator const WCHAR * ( ) const [inline]

Identical to GetCString(). Returns the WCHAR * pointer of the content of the object. Please be aware, that this pointer is never equal to NULL! Even if the wide ch string is empty, this returned pointer will point to an empty, null-terminated WCHAR * string! This means that using this operator and comparing it's value to NULL for testing the WString on emptiness is not correct - for checking on emptiness, the method IsEmpty() has to be used instead!

BOOLEAN WString::operator!= ( const WString & str ) const [inline]

Checks whether the object and str are not identical.

WString WString::operator+ ( const WCHAR * str ) const

Returnes the concatenation of the object and the zero terminated WCHAR string str.

WString WString::operator+ ( const WString & str ) const

Returnes the concatenation of the object and the str object.

void WString::operator+= ( const WCHAR * str ) [inline]

Concatenates the zero terminated WCHAR string to the object.

void WString::operator+= ( const CHAR * str ) [inline]

Concatenates the zero terminated CHAR string to the object.

void WString::operator+= ( const WString & str ) [inline]

Concatenates WString str to the object.

void WString::operator+= ( const String & str ) [inline]

Concatenates String str to the object.

BOOLEAN WString::operator< ( const WString & right ) const [inline]

Checks whether the object is smaller than right.

WString & WString::operator<< ( INT32 number )

Concatenates number to the object. Repetitive use is possible (a << b << c).

WString & WString::operator<< ( const WCHAR * right )

Concatenates zero terminated WCHAR right to the object. Repetitive use is possible (a << b << c).

WString & WString::operator<< ( const CHAR * right )

Concatenates zero terminated CHAR right to the object. Repetitive use is possible (a << b << c).

Reimplemented in LcsWString.

WString & WString::operator<< ( const WString * right )

Concatenates WString right to the object. Repetitive use is possible (a << b << c).

WString & WString::operator<< ( const WString & right )

Concatenates WString right to the object. Repetitive use is possible (a << b << c).

WString & WString::operator<< ( const String * right )

Concatenates String right to the object. Repetitive use is possible (a << b << c).

WString & WString::operator<< ( const String & right )

Concatenates String right to the object. Repetitive use is possible (a << b << c).

BOOLEAN WString::operator<= ( const WString & right ) const [inline]

Checks whether the object is smaller or equal than right.

WString & WString::operator= ( const WCHAR * str )

Assigns a new value to the wstring object based on zero terminated WCHAR string.

WString & WString::operator= ( const WString & str )

Assigns a new value to the wstring object.

Reimplemented in LcsWString.

BOOLEAN WString::operator== ( const WCHAR * str ) const [inline]

Checks whether the object and str are identical.

BOOLEAN WString::operator== ( const WString & str ) const [inline]

Checks whether the object and str are identical.

BOOLEAN WString::operator> ( const WString & right ) const [inline]

Checks whether the object is greater than right.

BOOLEAN WString::operator>= ( const WString & right ) const [inline]

Checks whether the object is greater or equal than right.

WCHAR WString::operator[] ( INT pos ) const

Returns the wide ch of the object at position pos.

BOOLEAN WString::PreAlloc ( UINT char_count ) [inline]

Alloc for internal buffer for at least char_count characters (excluding terminating zero ch). Current WString content will be destroyed

void WString::Replace | ( | INT | pos,
 |  | WCHAR | ch
 | ) |

Replaces ch at position pos with ch.

BOOLEAN WString::Reserve ( UINT char_count ) [inline]

Reserve internal buffer for at least char_count characters (excluding terminating zero ch).

void WString::Scan | ( | const WCHAR * | format,
 |  |  | ...
 | ) | const

Scans the string for a series of values in the object. Syntax is equivalent to scanf.

BOOLEAN WString::StartsWith ( WCHAR chr ) const

Returns TRUE if the character chr matches with the start of the string.

BOOLEAN WString::StartsWith ( const WString & other ) const

Returns TRUE if the string other matches with the start of the string.

void WString::StrCopy | ( | const WCHAR * | buffer,
 |  | INT | len
 | ) |

Initializes the object by len wide characters of a wide character buffer.

WString WString::Substring | ( | INT | start,
 |  | INT | length = -1
 | ) | const

Returns a substring object starting from position start of the length length. If length is omitted the substring contains all characters from start on.

void WString::Swap ( WString & str )

Exchanges the content of the object and str.

WString & WString::ToLower ( )

Converts all characters of the object into lower case characters.

String WString::ToString ( ) const

Returns the content of the object as a String object.

WString & WString::ToUpper ( )

Converts all characters of the object into upper case characters.

String WString::ToUtf8String ( ) const

Returns the content of the object as a NULL-terminated UTF-8 string wrapped into a String object. If the conversion fails for some reason the empty string is returned silently.

void WString::VFormat | ( | const WCHAR * | format,
 |  | va_list | args
 | ) |

Accepts a pointer to an argument list. Syntax is equivalent to ANSI vprintf.

Friends And Related Function Documentation

friend class String [friend]

The documentation for this class was generated from the following files:
  • Auxiliary/WString.hpp
  • Auxiliary/WString.cpp
Generated on Wed Jan 25 02:22:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: XCallInfoResponseParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

XCallInfoResponseParser Class Reference

#include <Apoxi/AddOns/MmCall/XCallInfoResponseParser.hpp>

Collaboration diagram for XCallInfoResponseParser:

[legend]

Public Types

enum | CallDirection { CdNotValid = 0, MOC = 1, MTC = 2 }
enum CallInfoType {
CallInfoNotValid = 0, CallControlCallSetupInfo = 1, CallSetup = 2, CallClearing = 3,
DualServiceCallModification = 4, CrssTransaction = 5
}
enum | CallMode { CallModeNotValid = 0, Voice = 1, Fax = 2, Data = 3 }
enum CallType {
CallTypeNotValid = 0, SingleVoiceCall = 1, SingleFaxCall = 2, SingleDataCall = 3,
DualCall = 4
}
enum | CcPerformed { CCNotValid = 0, CCNotPerformed = 1, CCPerformed = 2 }
enum ClearingState {
ClearingStateNotValid = 0, MocSetupRejected = 1, Disconnected = 2, DisconnectIndicated = 3,
Cleared = 4
}
enum | CliValidity { CliValid = 0, CliWithheldByOriginator = 1, CliNotAvailable = 2, CliInvalid }
enum CrssState {
CrssNotValid = 0, CallHeldStarted = 1, CallHeldRejected = 2, CallHeldCompleted = 3,
CallRetrieveStarted = 4, CallRetrieveRejected = 5, CallRetrieveCompleted = 6, MultiPartyStarted = 7,
MultiPartyRejected = 8, MultiPartyCompleted = 9, MultiPartyHeldStarted = 10, MultiPartyHeldRejected = 11,
MultiPartyHeldCompleted = 12, MultiPartyRetrieveStarted = 13, MultiPartyRetrieveRejected = 14, MultiPartyRetrieveCompleted = 15,
MultiPartySplitStarted = 16, MultiPartySplitRejected = 17, MultiPartySplitCompleted = 18, ExplicitCallTransferStarted = 19,
ExplicitCallTransferRejected = 20, ExplicitCallTransferCompleted = 21, CallDeflectionStarted = 22, CallDeflectionRejected = 23,
CallDeflectionCompleted = 24
}
enum | CtmStatus { CtmNotValid = 0, CtmCall = 1, AudioBasedCall = 2 }
enum | EstablishmentCause { EstCauseNotValid = 0, EmergencyCall = 1, NormalCall = 2 }
enum ModificationState {
ModificationStateNotValid = 0, ModificationIndicated = 1, ModificationStarted = 2, ModificationRejected = 3,
ModificationCompleted = 4
}
enum | SelectedLine { SelLineNotValid = 0, Speech = 1, AuxiliarySpeech = 3 }
enum SetupState {
SetupStateNotValid = 0, MoCallRequested = 1, MoCallDialing = 2, MocRemoteUserAlerted = 3,
MtcConfirmed = 4, MtcIndicated = 5, MtcBcNegotiated = 6, MtcAccepted = 7,
CallActive = 8
}

Public Member Functions

const String | GetAlpha () const
Returns the string added to call information.
CallDirection | GetCallDirection () const
Returns the direction of the call - either MOC or MTC.
INT | GetCallId () const
Returns the ID of the call in stack.
CallMode | GetCallMode () const
Returns the call mode.
CallType | GetCallType () const
Returns the type of the call.
CcPerformed | GetCcPerformed () const
Returns if call control is performed .
INT | GetChannelMode () const
Returns the channel mode.
INT | GetClearingCause () const
Returns the clearing cause.
ClearingState | GetClearingState () const
Returns the clearing state.
CliValidity | GetCliValidity () const
Returns the validity of CLI.
CrssState | GetCrssState () const
Returns the CRSS state.
CtmStatus | GetCtmStatus () const
Returns the Ctm status.
CallMode | GetCurrentCallMode () const
Returns the current call mode.
INT | GetEccCategory () const
Returns the Ecc Category.
EstablishmentCause | GetEstCause () const
Returns the establishment cause.
ModificationState | GetModificationState () const
Returns the modification state .
const PhoneNumber | GetPhoneNumber () const
Returns the phone number of the current call - invalid if call not valid or phonenumber not available.
SelectedLine | GetSelectedLine () const
Returns the used line for the current call.
SetupState | GetSetupState () const
Returns the setup state the call is currently in.
INT | GetSimResult () const
Returns the sim result as integer value.
Tipd | GetTipd () const
Returns the TIPD of the current call.
CallInfoType | GetType () const
Returns the type of the CallInfo .
XCallInfoResponseParser (const AtResponse &response)
~XCallInfoResponseParser ()
Desructor.

Detailed Description

Parser for the response of the +XSERVICE=1 command. ATTENTION: class must not be derived (no virtual destructor)

Member Enumeration Documentation

enum XCallInfoResponseParser::CallDirection

Enumerator:
CdNotValid
MOC
MTC

enum XCallInfoResponseParser::CallInfoType

Enumerator:
CallInfoNotValid
CallControlCallSetupInfo
CallSetup
CallClearing
DualServiceCallModification
CrssTransaction

enum XCallInfoResponseParser::CallMode

Enumerator:
CallModeNotValid
Voice
Fax
Data

enum XCallInfoResponseParser::CallType

Enumerator:
CallTypeNotValid
SingleVoiceCall
SingleFaxCall
SingleDataCall
DualCall

enum XCallInfoResponseParser::CcPerformed

Enumerator:
CCNotValid
CCNotPerformed
CCPerformed

enum XCallInfoResponseParser::ClearingState

Enumerator:
ClearingStateNotValid
MocSetupRejected
Disconnected
DisconnectIndicated
Cleared

enum XCallInfoResponseParser::CliValidity

Enumerator:
CliValid
CliWithheldByOriginator
CliNotAvailable
CliInvalid

enum XCallInfoResponseParser::CrssState

Enumerator:
CrssNotValid
CallHeldStarted
CallHeldRejected
CallHeldCompleted
CallRetrieveStarted
CallRetrieveRejected
CallRetrieveCompleted
MultiPartyStarted
MultiPartyRejected
MultiPartyCompleted
MultiPartyHeldStarted
MultiPartyHeldRejected
MultiPartyHeldCompleted
MultiPartyRetrieveStarted
MultiPartyRetrieveRejected
MultiPartyRetrieveCompleted
MultiPartySplitStarted
MultiPartySplitRejected
MultiPartySplitCompleted
ExplicitCallTransferStarted
ExplicitCallTransferRejected
ExplicitCallTransferCompleted
CallDeflectionStarted
CallDeflectionRejected
CallDeflectionCompleted

enum XCallInfoResponseParser::CtmStatus

Enumerator:
CtmNotValid
CtmCall
AudioBasedCall

enum XCallInfoResponseParser::EstablishmentCause

Enumerator:
EstCauseNotValid
EmergencyCall
NormalCall

enum XCallInfoResponseParser::ModificationState

Enumerator:
ModificationStateNotValid
ModificationIndicated
ModificationStarted
ModificationRejected
ModificationCompleted

enum XCallInfoResponseParser::SelectedLine

Enumerator:
SelLineNotValid
Speech
AuxiliarySpeech

enum XCallInfoResponseParser::SetupState

Enumerator:
SetupStateNotValid
MoCallRequested
MoCallDialing
MocRemoteUserAlerted
MtcConfirmed
MtcIndicated
MtcBcNegotiated
MtcAccepted
CallActive

Constructor & Destructor Documentation

XCallInfoResponseParser::XCallInfoResponseParser ( const AtResponse & response )

Constructor

Parameters:
response received at response used for parsing.

XCallInfoResponseParser::~XCallInfoResponseParser ( )

Desructor.

Member Function Documentation

const String XCallInfoResponseParser::GetAlpha ( ) const

Returns the string added to call information.

XCallInfoResponseParser::CallDirection XCallInfoResponseParser::GetCallDirection ( ) const

Returns the direction of the call - either MOC or MTC.

INT XCallInfoResponseParser::GetCallId ( ) const

Returns the ID of the call in stack.

XCallInfoResponseParser::CallMode XCallInfoResponseParser::GetCallMode ( ) const

Returns the call mode.

XCallInfoResponseParser::CallType XCallInfoResponseParser::GetCallType ( ) const

Returns the type of the call.

XCallInfoResponseParser::CcPerformed XCallInfoResponseParser::GetCcPerformed ( ) const

Returns if call control is performed .

INT XCallInfoResponseParser::GetChannelMode ( ) const

Returns the channel mode.

INT XCallInfoResponseParser::GetClearingCause ( ) const

Returns the clearing cause.

XCallInfoResponseParser::ClearingState XCallInfoResponseParser::GetClearingState ( ) const

Returns the clearing state.

XCallInfoResponseParser::CliValidity XCallInfoResponseParser::GetCliValidity ( ) const

Returns the validity of CLI.

XCallInfoResponseParser::CrssState XCallInfoResponseParser::GetCrssState ( ) const

Returns the CRSS state.

XCallInfoResponseParser::CtmStatus XCallInfoResponseParser::GetCtmStatus ( ) const

Returns the Ctm status.

XCallInfoResponseParser::CallMode XCallInfoResponseParser::GetCurrentCallMode ( ) const

Returns the current call mode.

INT XCallInfoResponseParser::GetEccCategory ( ) const

Returns the Ecc Category.

XCallInfoResponseParser::EstablishmentCause XCallInfoResponseParser::GetEstCause ( ) const

Returns the establishment cause.

XCallInfoResponseParser::ModificationState XCallInfoResponseParser::GetModificationState ( ) const

Returns the modification state .

const PhoneNumber XCallInfoResponseParser::GetPhoneNumber ( ) const

Returns the phone number of the current call - invalid if call not valid or phonenumber not available.

XCallInfoResponseParser::SelectedLine XCallInfoResponseParser::GetSelectedLine ( ) const

Returns the used line for the current call.

XCallInfoResponseParser::SetupState XCallInfoResponseParser::GetSetupState ( ) const

Returns the setup state the call is currently in.

INT XCallInfoResponseParser::GetSimResult ( ) const

Returns the sim result as integer value.

Tipd XCallInfoResponseParser::GetTipd ( ) const

Returns the TIPD of the current call.

XCallInfoResponseParser::CallInfoType XCallInfoResponseParser::GetType ( ) const

Returns the type of the CallInfo .

The documentation for this class was generated from the following files:
  • AddOns/MmCall/XCallInfoResponseParser.hpp
  • AddOns/MmCall/XCallInfoResponseParser.cpp
Generated on Wed Jan 25 02:23:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: XMLParser Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

XMLParser Class Reference

#include <Apoxi/AddOns/XmlParser/xml_parser.hpp>

Inheritance diagram for XMLParser:

[legend]

Public Member Functions

s32 | Parse ()
virtual s32 | XML_Characters_Handler (void *UserData, char *Chars, s32 cbsize)
virtual s32 | XML_End_Handler (void *UserData)
virtual s32 | XML_EndCData_Handler (void *UserData)
virtual s32 | XML_EndElement_Handler (void *UserData, char *uri, char *localname, char *qName)
virtual s32 | XML_Error_Handler (int ErrorCode, int ErrorLine)
virtual s32 | XML_PI_Handler (void *UserData, char *Target, char *Data)
virtual s32 | XML_Start_Handler (void *UserData)
virtual s32 | XML_StartCData_Handler (void *UserData)
virtual s32 | XML_StartElement_Handler (void *UserData, char *uri, char *localname, char *qName, LPVECTOR atts)
XMLParser (char *str)
virtual | ~XMLParser ()

Static Public Member Functions

static s32 | CharactersHandler (LPXMLPARSER parser, void *UserData, char *Chars, s32 cbSize)
static s32 | cstream (char *buf, s32 cBytes, s32 *cBytesActual, void *inputData)
static s32 | EndCDATAHandler (LPXMLPARSER parser, void *UserData)
static s32 | EndDocument (LPXMLPARSER parser, void *UserData)
static s32 | EndElement (LPXMLPARSER parser, void *UserData, char *uri, char *localName, char *qName)
static void | ErrorHandler (LPXMLPARSER parser)
static s32 | PIHandler (LPXMLPARSER parser, void *UserData, char *Target, char *Data)
static s32 | StartCDATAHandler (LPXMLPARSER parser, void *UserData)
static s32 | StartDocument (LPXMLPARSER parser, void *UserData)
static s32 | StartElement (LPXMLPARSER parser, void *UserData, char *uri, char *localName, char *qName, LPVECTOR atts)

Static Public Attributes

static int | prev_readpos = 0
static char * | strbuf = 0

Constructor & Destructor Documentation

XMLParser::XMLParser ( char * str )

XMLParser::~XMLParser ( ) [virtual]

Member Function Documentation

s32 XMLParser::CharactersHandler | ( | LPXMLPARSER | parser,
 |  | void * | UserData,
 |  | char * | Chars,
 |  | s32 | cbSize
 | ) | [static]

s32 XMLParser::cstream | ( | char * | buf,
 |  | s32 | cBytes,
 |  | s32 * | cBytesActual,
 |  | void * | inputData
 | ) | [static]

s32 XMLParser::EndCDATAHandler | ( | LPXMLPARSER | parser,
 |  | void * | UserData
 | ) | [static]

s32 XMLParser::EndDocument | ( | LPXMLPARSER | parser,
 |  | void * | UserData
 | ) | [static]

s32 XMLParser::EndElement | ( | LPXMLPARSER | parser,
 |  | void * | UserData,
 |  | char * | uri,
 |  | char * | localName,
 |  | char * | qName
 | ) | [static]

void XMLParser::ErrorHandler ( LPXMLPARSER parser ) [static]

s32 XMLParser::Parse ( )

Reimplemented in XmlParserRel.

s32 XMLParser::PIHandler | ( | LPXMLPARSER | parser,
 |  | void * | UserData,
 |  | char * | Target,
 |  | char * | Data
 | ) | [static]

s32 XMLParser::StartCDATAHandler | ( | LPXMLPARSER | parser,
 |  | void * | UserData
 | ) | [static]

s32 XMLParser::StartDocument | ( | LPXMLPARSER | parser,
 |  | void * | UserData
 | ) | [static]

s32 XMLParser::StartElement | ( | LPXMLPARSER | parser,
 |  | void * | UserData,
 |  | char * | uri,
 |  | char * | localName,
 |  | char * | qName,
 |  | LPVECTOR | atts
 | ) | [static]

virtual s32 XMLParser::XML_Characters_Handler | ( | void * | UserData,
 |  | char * | Chars,
 |  | s32 | cbsize
 | ) | [inline, virtual]

virtual s32 XMLParser::XML_End_Handler ( void * UserData ) [inline, virtual]

Reimplemented in XmlParserRel.

virtual s32 XMLParser::XML_EndCData_Handler ( void * UserData ) [inline, virtual]

Reimplemented in XmlParserRel.

virtual s32 XMLParser::XML_EndElement_Handler | ( | void * | UserData,
 |  | char * | uri,
 |  | char * | localname,
 |  | char * | qName
 | ) | [inline, virtual]

virtual s32 XMLParser::XML_Error_Handler | ( | int | ErrorCode,
 |  | int | ErrorLine
 | ) | [inline, virtual]

virtual s32 XMLParser::XML_PI_Handler | ( | void * | UserData,
 |  | char * | Target,
 |  | char * | Data
 | ) | [inline, virtual]

virtual s32 XMLParser::XML_Start_Handler ( void * UserData ) [inline, virtual]

Reimplemented in XmlParserRel.

virtual s32 XMLParser::XML_StartCData_Handler ( void * UserData ) [inline, virtual]

Reimplemented in XmlParserRel.

virtual s32 XMLParser::XML_StartElement_Handler | ( | void * | UserData,
 |  | char * | uri,
 |  | char * | localname,
 |  | char * | qName,
 |  | LPVECTOR | atts
 | ) | [inline, virtual]

Field Documentation

INT XMLParser::prev_readpos = 0 [static]

char * XMLParser::strbuf = 0 [static]

The documentation for this class was generated from the following files:
  • AddOns/XmlParser/xml_parser.hpp
  • AddOns/XmlParser/xml_parser.cpp
Generated on Wed Jan 25 02:23:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: XmlParserRel Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

XmlParserRel Class Reference
[Digital Rights Management]

#include <Apoxi/AddOns/Drm/DrmRelXml.hpp>

Inheritance diagram for XmlParserRel:

[legend]
Collaboration diagram for XmlParserRel:

[legend]

Public Types

enum RelTag_v1_0 {
RelTagKeyInfo = 0, RelTagKeyValue, RelTagCount, RelTagDatetime,
RelTagDisplay, RelTagEnd, RelTagExecute, RelTagInterval,
RelTagPlay, RelTagPrint, RelTagStart, RelTagUid,
RelTagVersion, RelTagAgreement, RelTagAsset, RelTagConstraint,
RelTagContext, RelTagPermission, RelTagRights, RelTagNone
}

Public Member Functions

void | AddDefaultConstraints (DrmPermission *perm)
Default constraints create a Forward Lock object.
void | AddDefaultPermissions ()
Default permissions create a Forward Lock object.
s32 | Parse ()
virtual s32 | XML_Characters_Handler (void *UserData, CHAR *Chars, s32 cbsize)
virtual s32 | XML_End_Handler (void *UserData)
virtual s32 | XML_EndCData_Handler (void *UserData)
virtual s32 | XML_EndElement_Handler (void *UserData, CHAR *uri, CHAR *localname, CHAR *qName)
virtual s32 | XML_Error_Handler (INT ErrorCode, INT ErrorLine)
virtual s32 | XML_PI_Handler (void *UserData, CHAR *Target, CHAR *Data)
virtual s32 | XML_Start_Handler (void *UserData)
virtual s32 | XML_StartCData_Handler (void *UserData)
virtual s32 | XML_StartElement_Handler (void *UserData, CHAR *uri, CHAR *localname, CHAR *qName, LPVECTOR atts)
XmlParserRel (CHAR *s, DrmRelParser &rh)
virtual | ~XmlParserRel ()

Static Public Member Functions

static UINT32 | ParseDateString (String &date_data, INT &parse_err)
static UINT32 | ParseInterval (String &validity_data, INT &parse_err)

Member Enumeration Documentation

enum XmlParserRel::RelTag_v1_0

Enumerator:
RelTagKeyInfo
RelTagKeyValue
RelTagCount
RelTagDatetime
RelTagDisplay
RelTagEnd
RelTagExecute
RelTagInterval
RelTagPlay
RelTagPrint
RelTagStart
RelTagUid
RelTagVersion
RelTagAgreement
RelTagAsset
RelTagConstraint
RelTagContext
RelTagPermission
RelTagRights
RelTagNone

The documentation for this class was generated from the following files:
  • AddOns/Drm/DrmRelXml.hpp
  • AddOns/Drm/DrmRelXml.cpp
Generated on Wed Jan 25 02:23:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8AddWordMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8AddWordMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for Zi8AddWordMsg:

[legend]
Collaboration diagram for Zi8AddWordMsg:

[legend]

Public Types

enum | { ID = 30202 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetNewWord () const
void | SetNewWord (const WString &new_word)
Zi8AddWordMsg (const WString &new_word)
virtual | ~Zi8AddWordMsg ()

Detailed Description

This message is sent when the user confirms that he wants to add a new word to Zi8''s dictionary. Arguments: the word that was not found

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

Zi8AddWordMsg::Zi8AddWordMsg ( const WString & new_word )

Zi8AddWordMsg::~Zi8AddWordMsg ( ) [virtual]

Member Function Documentation

Message * Zi8AddWordMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & Zi8AddWordMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& Zi8AddWordMsg::GetNewWord ( ) const [inline]

void Zi8AddWordMsg::SetNewWord ( const WString & new_word ) [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:23:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8AlphabetBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8AlphabetBox Class Reference

#include <Apoxi/AddOns/Zi8/Zi8AlphabetBox.hpp>

Inheritance diagram for Zi8AlphabetBox:

[legend]
Collaboration diagram for Zi8AlphabetBox:

[legend]

Public Types

typedef DrawableObject | Base

Public Member Functions

INT | GetCenterXpos () const
virtual XYDIM | GetDefaultHeight () const
INT | GetEleCount () const
void | GetPageFlag (BOOLEAN *prev_page, BOOLEAN *next_page) const
INT | GetShowCount (const WCHAR *text, INT font_id)
const WCHAR * | GetText (INT *selected_idx=0, INT *caps_status=0) const
void | Init (Control *control)
void | SetEleCount (INT ele_count)
void | SetPageFlag (BOOLEAN prev_page, BOOLEAN next_page)
void | SetText (const WCHAR *text, INT selected_idx=-1, const INT caps_status=0)
Zi8AlphabetBox (Control *control)
Zi8AlphabetBox ()
virtual | ~Zi8AlphabetBox ()

Member Typedef Documentation

typedef DrawableObject Zi8AlphabetBox::Base

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

Zi8AlphabetBox::Zi8AlphabetBox ( )

Zi8AlphabetBox::Zi8AlphabetBox ( Control * control )

Zi8AlphabetBox::~Zi8AlphabetBox ( ) [virtual]

Member Function Documentation

INT Zi8AlphabetBox::GetCenterXpos ( ) const

XYDIM Zi8AlphabetBox::GetDefaultHeight ( ) const [virtual]

Returns:
Default height of the object. If no default height has been specified, -1 is returned. Usually the default height is defined by the view object of the component.

Reimplemented from Component.

INT Zi8AlphabetBox::GetEleCount ( ) const

void Zi8AlphabetBox::GetPageFlag | ( | BOOLEAN * | prev_page,
 |  | BOOLEAN * | next_page
 | ) | const

INT Zi8AlphabetBox::GetShowCount | ( | const WCHAR * | text,
 |  | INT | font_id
 | ) |

const WCHAR * Zi8AlphabetBox::GetText | ( | INT * | selected_idx = 0,
 |  | INT * | caps_status = 0
 | ) | const

void Zi8AlphabetBox::Init ( Control * control )

void Zi8AlphabetBox::SetEleCount ( INT ele_count )

void Zi8AlphabetBox::SetPageFlag | ( | BOOLEAN | prev_page,
 |  | BOOLEAN | next_page
 | ) |

void Zi8AlphabetBox::SetText | ( | const WCHAR * | text,
 |  | INT | selected_idx = -1,
 |  | const INT | caps_status = 0
 | ) |

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8AlphabetBox.hpp
  • AddOns/Zi8/Zi8AlphabetBox.cpp
Generated on Wed Jan 25 02:23:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8AlphabetBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8AlphabetBoxView Class Reference

#include <Apoxi/AddOns/Zi8/Zi8AlphabetBox.hpp>

Inheritance diagram for Zi8AlphabetBoxView:

[legend]
Collaboration diagram for Zi8AlphabetBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
void | Init ()
Zi8AlphabetBoxView ()
virtual | ~Zi8AlphabetBoxView ()

Constructor & Destructor Documentation

Zi8AlphabetBoxView::Zi8AlphabetBoxView ( )

Zi8AlphabetBoxView::~Zi8AlphabetBoxView ( ) [virtual]

Member Function Documentation

void Zi8AlphabetBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void Zi8AlphabetBoxView::Init ( )

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8AlphabetBox.hpp
  • AddOns/Zi8/Zi8AlphabetBox.cpp
Generated on Wed Jan 25 02:23:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8EnteredUnknownWordMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8EnteredUnknownWordMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for Zi8EnteredUnknownWordMsg:

[legend]
Collaboration diagram for Zi8EnteredUnknownWordMsg:

[legend]

Public Types

enum | { ID = 30203 }

Public Member Functions

virtual Message * | Clone () const
virtual const MsgMetaData & | GetMetaData () const
const WString & | GetWord () const
void | SetWord (const WString &word)
Zi8EnteredUnknownWordMsg (const WString &word)
virtual | ~Zi8EnteredUnknownWordMsg ()

Detailed Description

This message is sent when the user has confirmed that he wants to enter a new word into the Zi8 UDB. The message can be retrieved by components implementing word entry so they can set a default text. Arguments: the word that was not found

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

Zi8EnteredUnknownWordMsg::Zi8EnteredUnknownWordMsg ( const WString & word )

Zi8EnteredUnknownWordMsg::~Zi8EnteredUnknownWordMsg ( ) [virtual]

Member Function Documentation

Message * Zi8EnteredUnknownWordMsg::Clone ( ) const [virtual]

Implements Message.

const MsgMetaData & Zi8EnteredUnknownWordMsg::GetMetaData ( ) const [virtual]

Implements Message.

const WString& Zi8EnteredUnknownWordMsg::GetWord ( ) const [inline]

void Zi8EnteredUnknownWordMsg::SetWord ( const WString & word ) [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:23:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8InputConfig Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8InputConfig Class Reference
[Config]

#include <Zi8InputConfig.hpp>

Static Public Member Functions

static const BitmapRes * | GetBitmap (AbstractPredictiveInputBox::PredBitmapId pred_bitmap_id)
static const Font & | GetFont (AbstractPredictiveInputBox::PredFontId pred_font_id)
static const WCHAR | GetStroke (const INT stroke)
static const WCHAR * | GetSymbolCandidates ()
static const UINT8 | GetSymbolCandidatesLength ()
static CHAR * | LoadZi8Udb (UINT16 &data_size)
static void | SaveZi8Udb ()

Detailed Description

Allows accessing the configuration for Zi8. This configuration file is mandatory for APOXI. The header file may not be changed or extended in any manner, it is only allowed to customize the implementation of the methods. If additional methods are needed for the MMI it is required to create a custom configuration file.

Member Function Documentation

static const BitmapRes* Zi8InputConfig::GetBitmap ( AbstractPredictiveInputBox::PredBitmapId pred_bitmap_id ) [static]

static const Font& Zi8InputConfig::GetFont ( AbstractPredictiveInputBox::PredFontId pred_font_id ) [static]

static const WCHAR Zi8InputConfig::GetStroke ( const INT stroke ) [static]

static const WCHAR* Zi8InputConfig::GetSymbolCandidates ( ) [static]

static const UINT8 Zi8InputConfig::GetSymbolCandidatesLength ( ) [static]

static CHAR* Zi8InputConfig::LoadZi8Udb ( UINT16 & data_size ) [static]

static void Zi8InputConfig::SaveZi8Udb ( ) [static]

The documentation for this class was generated from the following file:
  • Zi8InputConfig.hpp
Generated on Wed Jan 25 02:23:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8InputMapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8InputMapper Class Reference

#include <Apoxi/AddOns/Zi8/Zi8InputMapper.hpp>

Inheritance diagram for Zi8InputMapper:

[legend]
Collaboration diagram for Zi8InputMapper:

[legend]

Public Member Functions

BOOLEAN | AddNewWordToUdb (const WString &new_word)
void | ClearEditor ()
INT | GetCapsStatus () const
INT | GetElementCount () const
virtual INT | GetId () const
virtual PredMode | GetMode () const
Discover the current input method.
virtual const WCHAR * | GetPhonetics (INT *selected_idx=0) const
virtual INT | GetSelectedIndex () const
virtual const WCHAR * | GetSelection () const
virtual const WCHAR * | GetStatusInfo () const
A human-readable name for the current input method.
virtual const WCHAR * | GetStrokes () const
virtual Type | GetType () const
BOOLEAN | HasCandidate () const
BOOLEAN | HasNextPage () const
BOOLEAN | HasPrevPage () const
virtual BOOLEAN | IsModeSupported (PredMode mode)
void | ReplaceWithNewWord (const WString &new_word)
replaces the old zi8-candidate word in the editor with new_word
virtual void | SetEditor (AbstractEditor *editor)
virtual BOOLEAN | SetMode (PredMode mode)
Zi8InputMapper (AbstractEditor *editor=0)
virtual | ~Zi8InputMapper ()

Protected Member Functions

virtual BOOLEAN | Notify (NotificationType type, INT index, const AtomItem *item=0)
virtual BOOLEAN | OnKeyUp (KeyCode key_code, UINT32 duration)
virtual BOOLEAN | OnLongKeyPress (KeyCode key_code)

Constructor & Destructor Documentation

Zi8InputMapper::Zi8InputMapper ( AbstractEditor * editor = 0 )

Zi8InputMapper::~Zi8InputMapper ( ) [virtual]

Member Function Documentation

BOOLEAN Zi8InputMapper::AddNewWordToUdb ( const WString & new_word )

void Zi8InputMapper::ClearEditor ( )

INT Zi8InputMapper::GetCapsStatus ( ) const

INT Zi8InputMapper::GetElementCount ( ) const

INT Zi8InputMapper::GetId ( ) const [virtual]

See also:
InputMapper::GetId()

Implements InputMapper.

PredInputMapper::PredMode Zi8InputMapper::GetMode ( ) const [virtual]

Discover the current input method.

Implements PredInputMapper.

const WCHAR * Zi8InputMapper::GetPhonetics ( INT * selected_idx = 0 ) const [virtual]

Implements PredInputMapper.

INT Zi8InputMapper::GetSelectedIndex ( ) const [virtual]

Implements PredInputMapper.

const WCHAR * Zi8InputMapper::GetSelection ( ) const [virtual]

Implements PredInputMapper.

const WCHAR * Zi8InputMapper::GetStatusInfo ( ) const [virtual]

A human-readable name for the current input method.

Implements PredInputMapper.

const WCHAR * Zi8InputMapper::GetStrokes ( ) const [virtual]

Implements PredInputMapper.

PredInputMapper::Type Zi8InputMapper::GetType ( ) const [virtual]

Implements PredInputMapper.

BOOLEAN Zi8InputMapper::HasCandidate ( ) const

BOOLEAN Zi8InputMapper::HasNextPage ( ) const

BOOLEAN Zi8InputMapper::HasPrevPage ( ) const

BOOLEAN Zi8InputMapper::IsModeSupported ( PredMode mode ) [virtual]

BOOLEAN Zi8InputMapper::Notify | ( | NotificationType | type,
 |  | INT | index,
 |  | const AtomItem * | item = 0
 | ) | [protected, virtual]

Is invoked by the editor, if an item has been inserted or the content of the editor has been changed. Overwriting this method allows the input mapper to synchronize its buffer with the editor-content.

Reimplemented from InputMapper.

BOOLEAN Zi8InputMapper::OnKeyUp | ( | KeyCode | key_code,
 |  | UINT32 | duration
 | ) | [protected, virtual]

Is invoked by the editor when a key has been released.

Reimplemented from InputMapper.

BOOLEAN Zi8InputMapper::OnLongKeyPress ( KeyCode key_code ) [protected, virtual]

Is invoked by the editor when a key has been a long time. It is assured that InputMapper::OnKeyDown with the matching key code is invoked before.

Reimplemented from InputMapper.

void Zi8InputMapper::ReplaceWithNewWord ( const WString & new_word )

replaces the old zi8-candidate word in the editor with new_word

void Zi8InputMapper::SetEditor ( AbstractEditor * editor ) [virtual]

Parameters:
editor Pointer to the editor the input mapper should belong too. */

Reimplemented from InputMapper.

BOOLEAN Zi8InputMapper::SetMode ( PredMode mode ) [virtual]

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8InputMapper.hpp
  • AddOns/Zi8/Zi8InputMapper.cpp
Generated on Wed Jan 25 02:23:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8NoWordFoundMsg Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8NoWordFoundMsg Class Reference

#include <Apoxi/Gui/MsgTypes.hpp>

Inheritance diagram for Zi8NoWordFoundMsg:

[legend]
Collaboration diagram for Zi8NoWordFoundMsg:

[legend]

Public Types

enum | { ID = 30201 }

Public Member Functions

virtual Message * | Clone () const
const WString & | GetActiveWord () const
virtual const MsgMetaData & | GetMetaData () const
void | SetActiveWord (const WString &active_word)
Zi8NoWordFoundMsg (const WString &active_word)
virtual | ~Zi8NoWordFoundMsg ()

Detailed Description

This message is sent when the user tries to enter a word Zi8 cannot find. Arguments: the word that was not found

Member Enumeration Documentation

anonymous enum

Enumerator:
ID

Constructor & Destructor Documentation

Zi8NoWordFoundMsg::Zi8NoWordFoundMsg ( const WString & active_word )

Zi8NoWordFoundMsg::~Zi8NoWordFoundMsg ( ) [virtual]

Member Function Documentation

Message * Zi8NoWordFoundMsg::Clone ( ) const [virtual]

Implements Message.

const WString& Zi8NoWordFoundMsg::GetActiveWord ( ) const [inline]

const MsgMetaData & Zi8NoWordFoundMsg::GetMetaData ( ) const [virtual]

Implements Message.

void Zi8NoWordFoundMsg::SetActiveWord ( const WString & active_word ) [inline]

The documentation for this class was generated from the following files:
  • Gui/MsgTypes.hpp
  • Gui/MsgTypes.cpp
Generated on Wed Jan 25 02:23:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8PredictiveInputBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8PredictiveInputBox Class Reference
[GuiInputExtensions]

#include <Apoxi/AddOns/Zi8/Zi8PredictiveInputBox.hpp>

Inheritance diagram for Zi8PredictiveInputBox:

[legend]
Collaboration diagram for Zi8PredictiveInputBox:

[legend]

Public Member Functions

virtual BOOLEAN | AddNewWordToUdb (const WString &word)
virtual INT | GetCapsStatus () const
void | Init (Control *parent, AbstractMultiLineEditor *m_editor, Window *add_word_to_dict_win=0, Window *ext_punc_win=0)
virtual BOOLEAN | SetMode (PredInputMapper::PredMode mode)
Zi8PredictiveInputBox (Control *parent, AbstractMultiLineEditor *m_editor, Window *add_word_to_dict_win=0, Window *ext_punc_win=0)
Zi8PredictiveInputBox ()
virtual | ~Zi8PredictiveInputBox ()

Protected Member Functions

virtual void | OnLayoutClient ()
virtual BOOLEAN | OnMessage (const Message &msg)
virtual BOOLEAN | RouteMessage (const Message &msg)
virtual void | UpdateDrawableObjects ()

Constructor & Destructor Documentation

Zi8PredictiveInputBox::Zi8PredictiveInputBox ( )

Zi8PredictiveInputBox::Zi8PredictiveInputBox | ( | Control * | parent,
 |  | AbstractMultiLineEditor * | m_editor,
 |  | Window * | add_word_to_dict_win = 0,
 |  | Window * | ext_punc_win = 0
 | ) |

Zi8PredictiveInputBox::~Zi8PredictiveInputBox ( ) [virtual]

Member Function Documentation

BOOLEAN Zi8PredictiveInputBox::AddNewWordToUdb ( const WString & word ) [virtual]

Implements AbstractPredictiveInputBox.

INT Zi8PredictiveInputBox::GetCapsStatus ( ) const [virtual]

Implements AbstractPredictiveInputBox.

void Zi8PredictiveInputBox::Init | ( | Control * | parent,
 |  | AbstractMultiLineEditor * | m_editor,
 |  | Window * | add_word_to_dict_win = 0,
 |  | Window * | ext_punc_win = 0
 | ) |

Reimplemented from AbstractPredictiveInputBox.

void Zi8PredictiveInputBox::OnLayoutClient ( ) [protected, virtual]

Is called, if the client area should be layouted (e. g. when the control is initialized or the size of the client area has changed). The use of the class Layouter for layouting the controls is recommended.

See also:
Layouter

Reimplemented from Control.

BOOLEAN Zi8PredictiveInputBox::OnMessage ( const Message & msg ) [protected, virtual]

See also:
Dispatcher::OnMessage()

Reimplemented from Component.

BOOLEAN Zi8PredictiveInputBox::RouteMessage ( const Message & msg ) [protected, virtual]

Implements the message routing of controls. It is recommended not to change the default message routing and usually it should not be necessary.

See also:
Dispatcher::RouteMessage

Reimplemented from Control.

BOOLEAN Zi8PredictiveInputBox::SetMode ( PredInputMapper::PredMode mode ) [virtual]

Reimplemented from AbstractPredictiveInputBox.

void Zi8PredictiveInputBox::UpdateDrawableObjects ( ) [protected, virtual]

Implements AbstractPredictiveInputBox.

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8PredictiveInputBox.hpp
  • AddOns/Zi8/Zi8PredictiveInputBox.cpp
Generated on Wed Jan 25 02:23:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8SelectionBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8SelectionBox Class Reference

#include <Apoxi/AddOns/Zi8/Zi8SelectionBox.hpp>

Inheritance diagram for Zi8SelectionBox:

[legend]
Collaboration diagram for Zi8SelectionBox:

[legend]

Public Types

typedef DrawableObject | Base

Public Member Functions

virtual XYDIM | GetDefaultHeight () const
void | GetPageFlag (BOOLEAN *prev_page, BOOLEAN *next_page) const
INT | GetSelectedIndex () const
Get index of chinese character list.
const WCHAR * | GetText () const
Get one line of chinese character.
void | Init (Control *control)
void | SetPageFlag (BOOLEAN prev_page, BOOLEAN next_page)
void | SetSelectedIndex (INT selected_idx)
Set index of chinese character list.
void | SetText (const WCHAR *text)
Set one line of chinese character to text.
Zi8SelectionBox (Control *control)
Zi8SelectionBox ()
virtual | ~Zi8SelectionBox ()

Member Typedef Documentation

typedef DrawableObject Zi8SelectionBox::Base

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

Zi8SelectionBox::Zi8SelectionBox ( )

Zi8SelectionBox::Zi8SelectionBox ( Control * control )

Zi8SelectionBox::~Zi8SelectionBox ( ) [virtual]

Member Function Documentation

XYDIM Zi8SelectionBox::GetDefaultHeight ( ) const [virtual]

See also:
Component::GetDefaultHeight

Reimplemented from Component.

void Zi8SelectionBox::GetPageFlag | ( | BOOLEAN * | prev_page,
 |  | BOOLEAN * | next_page
 | ) | const

INT Zi8SelectionBox::GetSelectedIndex ( ) const [inline]

Get index of chinese character list.

const WCHAR * Zi8SelectionBox::GetText ( ) const

Get one line of chinese character.

void Zi8SelectionBox::Init ( Control * control )

void Zi8SelectionBox::SetPageFlag | ( | BOOLEAN | prev_page,
 |  | BOOLEAN | next_page
 | ) |

void Zi8SelectionBox::SetSelectedIndex ( INT selected_idx ) [inline]

Set index of chinese character list.

void Zi8SelectionBox::SetText ( const WCHAR * text )

Set one line of chinese character to text.

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8SelectionBox.hpp
  • AddOns/Zi8/Zi8SelectionBox.cpp
Generated on Wed Jan 25 02:23:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8SelectionBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8SelectionBoxView Class Reference

#include <Apoxi/AddOns/Zi8/Zi8SelectionBox.hpp>

Inheritance diagram for Zi8SelectionBoxView:

[legend]
Collaboration diagram for Zi8SelectionBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
void | Init ()
Zi8SelectionBoxView ()
virtual | ~Zi8SelectionBoxView ()

Constructor & Destructor Documentation

Zi8SelectionBoxView::Zi8SelectionBoxView ( )

Zi8SelectionBoxView::~Zi8SelectionBoxView ( ) [virtual]

Member Function Documentation

void Zi8SelectionBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void Zi8SelectionBoxView::Init ( )

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8SelectionBox.hpp
  • AddOns/Zi8/Zi8SelectionBox.cpp
Generated on Wed Jan 25 02:23:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8StrokeBox Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8StrokeBox Class Reference

#include <Apoxi/AddOns/Zi8/Zi8StrokeBox.hpp>

Inheritance diagram for Zi8StrokeBox:

[legend]
Collaboration diagram for Zi8StrokeBox:

[legend]

Public Types

typedef DrawableObject | Base

Public Member Functions

virtual XYDIM | GetDefaultHeight () const
const WCHAR * | GetText () const
void | Init (Control *control)
void | SetText (const WCHAR *text)
Zi8StrokeBox (Control *control)
Zi8StrokeBox ()
virtual | ~Zi8StrokeBox ()

Member Typedef Documentation

typedef DrawableObject Zi8StrokeBox::Base

Reimplemented from DrawableObject.

Constructor & Destructor Documentation

Zi8StrokeBox::Zi8StrokeBox ( )

Zi8StrokeBox::Zi8StrokeBox ( Control * control )

Zi8StrokeBox::~Zi8StrokeBox ( ) [virtual]

Member Function Documentation

XYDIM Zi8StrokeBox::GetDefaultHeight ( ) const [virtual]

See also:
Component::GetDefaultHeight

Reimplemented from Component.

const WCHAR* Zi8StrokeBox::GetText ( ) const [inline]

void Zi8StrokeBox::Init ( Control * control )

void Zi8StrokeBox::SetText ( const WCHAR * text )

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8StrokeBox.hpp
  • AddOns/Zi8/Zi8StrokeBox.cpp
Generated on Wed Jan 25 02:24:00 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8StrokeBoxView Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8StrokeBoxView Class Reference

#include <Apoxi/AddOns/Zi8/Zi8StrokeBox.hpp>

Inheritance diagram for Zi8StrokeBoxView:

[legend]
Collaboration diagram for Zi8StrokeBoxView:

[legend]

Public Member Functions

virtual void | Draw (const Component &component, DeviceContext *dc, const Rect &repaint_rect) const
void | Init ()
Zi8StrokeBoxView ()
virtual | ~Zi8StrokeBoxView ()

Constructor & Destructor Documentation

Zi8StrokeBoxView::Zi8StrokeBoxView ( )

Zi8StrokeBoxView::~Zi8StrokeBoxView ( ) [virtual]

Member Function Documentation

void Zi8StrokeBoxView::Draw | ( | const Component & | component,
 |  | DeviceContext * | dc,
 |  | const Rect & | repaint_rect
 | ) | const [virtual]

Abstract method which must be implemented by derived classes.

Parameters:
component | Component, which contains the data needed for drawing.
dc | Pointer to the device context for drawing.
repaint_rect | Bounding rectangle which describes the area, which must be repainted. For less complex drawing operations, this parameter can be ignored.

Implements View.

void Zi8StrokeBoxView::Init ( )

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8StrokeBox.hpp
  • AddOns/Zi8/Zi8StrokeBox.cpp
Generated on Wed Jan 25 02:24:01 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Zi8Wrapper Class Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

Zi8Wrapper Class Reference

#include <Apoxi/AddOns/Zi8/Zi8Wrapper.hpp>

Public Member Functions

BOOLEAN | AddWordToUdb (const WCHAR *new_word)
void | ClearBuffer ()
INT | GetCandCharCount ()
const WCHAR * | GetCandidatesBuffer () const
const WCHAR * | GetChineseCandidate (INT idx)
INT | GetElementCount ()
INT | GetMode () const
const ZI8WCHAR * | GetPhonetics () const
const WCHAR * | GetSelectedCandidate () const
INT | GetSelectedCandidateLength ()
INT | GetSelectedIndex ()
const ZI8WCHAR * | GetStrokes () const
BOOLEAN | GetToneMode ()
BOOLEAN | HandleEnglishKeyEvent (WCHAR key)
BOOLEAN | HandlePinYinKeyEvent (WCHAR key)
BOOLEAN | HandleStrokeKeyEvent (WCHAR key)
BOOLEAN | HandleToneKeyEvent (WCHAR key)
BOOLEAN | HasCandidate ()
BOOLEAN | HasChineseCandidate ()
BOOLEAN | HasNextCandidates ()
BOOLEAN | HasNextPage ()
BOOLEAN | HasPrevCandidates ()
BOOLEAN | HasPrevPage ()
void | Init ()
BOOLEAN | IsComponent (const WCHAR *chr)
BOOLEAN | IsLanguageSupported (INT language_number) const
void | SelectComponent (const WCHAR *chr)
void | SetAssociatedCandidates (WCHAR chr)
ZI8BOOL | SetBpmfMode ()
ZI8BOOL | SetBpmfSpellingMode ()
INT | SetCandidateSelection (BOOLEAN=FALSE, BOOLEAN=FALSE)
void | SetCapsStatus (INT caps_status)
INT | SetChineseSelection (BOOLEAN=FALSE, BOOLEAN=FALSE)
ZI8BOOL | SetPinYinMode ()
ZI8BOOL | SetPinyinSpellingMode ()
ZI8BOOL | SetScStrokeMode ()
ZI8BOOL | SetTcStrokeMode ()
ZI8BOOL | SetToneMode ()
ZI8BOOL | SetZi8EnglishMode ()
ZI8BOOL | SetZi8GermanMode ()
ZI8BOOL | SetZi8SymbolMode ()
Zi8Wrapper ()
virtual | ~Zi8Wrapper ()

Static Public Member Functions

static INT | Zi8BopomofoCompare (const WString *string1, const WString *string2)
static INT | Zi8PinyinCompare (const WString *string1, const WString *string2)
static INT | Zi8StrokeCompare (const WString *string1, const WString *string2)

Constructor & Destructor Documentation

Zi8Wrapper::Zi8Wrapper ( )

Zi8Wrapper::~Zi8Wrapper ( ) [virtual]

Member Function Documentation

BOOLEAN Zi8Wrapper::AddWordToUdb ( const WCHAR * new_word )

void Zi8Wrapper::ClearBuffer ( )

INT Zi8Wrapper::GetCandCharCount ( )

const WCHAR * Zi8Wrapper::GetCandidatesBuffer ( ) const

const WCHAR * Zi8Wrapper::GetChineseCandidate ( INT idx )

INT Zi8Wrapper::GetElementCount ( )

INT Zi8Wrapper::GetMode ( ) const

const ZI8WCHAR * Zi8Wrapper::GetPhonetics ( ) const

const WCHAR* Zi8Wrapper::GetSelectedCandidate ( ) const [inline]

INT Zi8Wrapper::GetSelectedCandidateLength ( )

INT Zi8Wrapper::GetSelectedIndex ( )

const ZI8WCHAR * Zi8Wrapper::GetStrokes ( ) const

BOOLEAN Zi8Wrapper::GetToneMode ( )

BOOLEAN Zi8Wrapper::HandleEnglishKeyEvent ( WCHAR key )

BOOLEAN Zi8Wrapper::HandlePinYinKeyEvent ( WCHAR key )

BOOLEAN Zi8Wrapper::HandleStrokeKeyEvent ( WCHAR key )

BOOLEAN Zi8Wrapper::HandleToneKeyEvent ( WCHAR key )

BOOLEAN Zi8Wrapper::HasCandidate ( )

BOOLEAN Zi8Wrapper::HasChineseCandidate ( )

BOOLEAN Zi8Wrapper::HasNextCandidates ( )

BOOLEAN Zi8Wrapper::HasNextPage ( )

BOOLEAN Zi8Wrapper::HasPrevCandidates ( )

BOOLEAN Zi8Wrapper::HasPrevPage ( )

void Zi8Wrapper::Init ( )

BOOLEAN Zi8Wrapper::IsComponent ( const WCHAR * chr )

BOOLEAN Zi8Wrapper::IsLanguageSupported ( INT language_number ) const

void Zi8Wrapper::SelectComponent ( const WCHAR * chr )

void Zi8Wrapper::SetAssociatedCandidates ( WCHAR chr )

ZI8BOOL Zi8Wrapper::SetBpmfMode ( )

ZI8BOOL Zi8Wrapper::SetBpmfSpellingMode ( )

INT Zi8Wrapper::SetCandidateSelection | ( | BOOLEAN | = FALSE,
 |  | BOOLEAN | = FALSE
 | ) |

void Zi8Wrapper::SetCapsStatus ( INT caps_status )

INT Zi8Wrapper::SetChineseSelection | ( | BOOLEAN | = FALSE,
 |  | BOOLEAN | = FALSE
 | ) |

ZI8BOOL Zi8Wrapper::SetPinYinMode ( )

ZI8BOOL Zi8Wrapper::SetPinyinSpellingMode ( )

ZI8BOOL Zi8Wrapper::SetScStrokeMode ( )

ZI8BOOL Zi8Wrapper::SetTcStrokeMode ( )

ZI8BOOL Zi8Wrapper::SetToneMode ( )

ZI8BOOL Zi8Wrapper::SetZi8EnglishMode ( )

ZI8BOOL Zi8Wrapper::SetZi8GermanMode ( )

ZI8BOOL Zi8Wrapper::SetZi8SymbolMode ( )

INT Zi8Wrapper::Zi8BopomofoCompare | ( | const WString * | string1,
 |  | const WString * | string2
 | ) | [static]

INT Zi8Wrapper::Zi8PinyinCompare | ( | const WString * | string1,
 |  | const WString * | string2
 | ) | [static]

INT Zi8Wrapper::Zi8StrokeCompare | ( | const WString * | string1,
 |  | const WString * | string2
 | ) | [static]

The documentation for this class was generated from the following files:
  • AddOns/Zi8/Zi8Wrapper.hpp
  • AddOns/Zi8/Zi8Wrapper.cpp
Generated on Wed Jan 25 02:24:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Hierarchical Index

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

APOXI Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:

  • _ApplicationTracer
  • _FunctionTracer< mask >
  • _JUMP_BUFFER
  • _NullApplicationTracer
  • _NullFunctionTracer
  • AbstractDevice
    • AbstractLockableDevice
      • Camera
        • StillCamera
        • StillCamera
        • StillCamera
        • StillCamera
        • StillCamera
        • VideoCamera
        • VideoCamera
        • VideoCamera
        • VideoCamera
        • VideoCamera
      • Camera
      • Camera
      • Camera
      • Camera
    • Audio
    • Audio
    • Audio
    • Audio
    • Audio
    • BackLight
    • BackLight
    • BackLight
    • Charger
    • Charger
    • Charger
    • Charger
    • Charger
    • Fota
    • Fota
    • Fota
    • Fota
    • Fota
    • GenericAudioDevice
      • AmplifierAudioDevice
      • KeyToneAudioDevice
      • Mp3AudioDevice
      • RingerAudioDevice
      • SpeechAudioDevice
      • ToneAudioDevice
      • VoiceMemoAudioDevice
    • Keyboard
    • Keyboard
    • Keyboard
    • Keyboard
    • Keyboard
    • Led
    • Led
    • Led
    • Led
    • Led
    • MiscAudioDevice
    • RealTimeClock
    • RealTimeClock
    • RealTimeClock
    • RealTimeClock
    • RealTimeClock
    • VirtualDisplay
      • Display
        • DefaultDisplay
        • DefaultDisplay
        • DefaultDisplay
        • DefaultDisplay
        • DefaultDisplay
        • DefaultDisplay
    • VirtualDisplay
    • VirtualDisplay
    • VirtualDisplay
    • VirtualDisplay
  • AbstractDevice::ControlArg
  • AbstractEditorItem
    • AtomItem
      • BoundedItem
        • AudioItem
        • ImageItem
        • SoundItem
        • VCardItem
      • CharItem
    • CompoundItem
      • DateCompoundItem
      • GeneralCompoundItem
      • IpAddrCompoundItem
      • ParagraphCompoundItem
      • ParagraphMarker
      • TextCompoundItem
        • RichTextCompoundItem
      • TimeCompoundItem
  • AbstractExternalData
    • ProcessNode
  • AbstractGrid::SmoothScrollInfo
  • AbstractIMelodyParser
  • AbstractItemRenderer
    • DefaultItemRenderer
      • AtlItemRenderer
  • AbstractListBox::SmoothScrollInfo
  • AbstractMessageMapContainer
    • MessageMapContainer< T >
  • AbstractRenderer
  • AbstractScheduler
    • Scheduler
    • Scheduler
    • SimpleScheduler
  • AbstractSmsApp
    • EmsApp
    • SmsApp
  • AbstractSmsUtilityProcessor
    • SmsUtility
  • AbstractStackMsgArgMapContainer
    • StackMsgArgMapContainer< T >
  • AbstractTextRenderer
    • ArabicTextRenderer
    • HindiTextRenderer
    • JapaneseTextRenderer
    • SimpleTextRenderer
    • ThaiTextRenderer
    • VietnameseTextRenderer
  • AcacLanguage
  • Accessory
  • AccHandler
  • AckNackCnt
  • AckNackParamList
  • AckNackTestparamCnt
  • Acm
  • ActionExtension
    • AccessorActionExtension
  • AddInfo
  • AesCrypt
  • AidingData
  • Allocator< T >
  • AlphaCoding
  • AnimationBmpIterator
    • AnimationBmpArrayIterator
    • AnimationBmpPointerArrayIterator
  • AocChargeData
  • AocHandler
  • apoxi_emcpp_OBEXAdapter
  • AppFeatureID
  • ArgumentDestroyEntry
  • ArgumentDestroyEntryCompare
  • AsTestparamDatabase
  • AtcHandler
  • AtCommand
  • AtCommandData
  • AtCommandInfoTable
  • AtCommandMetaInfo
  • AtGenericCmdType
  • AtiCodecsLib
  • AtKeyParser
  • AtlApplicationPluginStartup
  • AtlApplicationPluginStartup::Table
  • AtlConfig
  • AtResponse
  • AtResponseInfoTable
  • AtResponseIterator
  • AtResponseMetaInfo
  • AtResponseParameter
  • Audio::SingleTone
  • Audio::SingleTone
  • Audio::SingleTone
  • Audio::SingleTone
  • Audio::SingleTone
  • Audio::ToneData
  • Audio::ToneData
  • Audio::ToneData
  • Audio::ToneData
  • Audio::ToneData
  • AudioAccessoryStore
  • AudioContext
  • AudioDeviceManager
  • AudioMapiManager
  • AudioMapiManager::MapiCommandType
  • AudioMapiManager::RequestOutcomeType
  • AudioPathManager
  • AudioPlayerEvent
  • AudioPlayerStore
  • AudioPlayerStore::DataFormatDataSource
  • AudioReference::TotalPlayTimeContainer
  • AudioTone
  • AudioToneDuration
  • AudioUtility
  • AuthProvider
    • FtpAuthProvider
    • HttpAuthProvider
  • BackupFileHandler
  • BarringInfoReceivedArg
  • BaseDataHandler
    • SimAuxHandler
    • SimChvHandler
    • SimCphsHandler
    • SimPbBaseHandler
    • SimPduHandler
    • SimSmsParamHandler
  • BaseInformationElement
  • BasicPackConnector
  • BasicSmsService
  • BcdPlmn
  • BidiManager
  • BidiManager::ParagraphContext
  • BigEndian16Bit
  • BigEndian32Bit
  • BinData
    • ChildBinData
    • DataSourceBinData
    • FileBinData
    • RamData
      • BufferedData
    • RomData
  • BinDataInReadStatusInfo
  • BitField< T >
  • Bitmap
  • BitmapRes
  • BitVector< N >
  • BlerTrchInfo
  • BlerTrchInfoList
  • BlockData
  • BootControl
  • BootHandler
  • BootState
  • BrowserSaveWin
  • BrowserView
    • FileNameView
    • FileNameView
    • ImageView
  • Brush
  • BtActiveDeviceWindow
  • BtAlertMessageWindow
  • BtApplication
  • BtAttributeId
  • BtAuthorizationRequiredWindow
  • BtAvrcpAlertMessageWindow
  • BtAvrcpCommandInterface
  • BtAvrcpControllerApplicationWindow
  • BtAvrcpPanelApplication
  • BtAvrcpPanelPassThroughParams
  • BtAvrcpPanelService
    • BtAvrcpPanelServiceImpl
  • BtAvrcpRawFrameParams
  • BtAvrcpRegisterParams
  • BtAvrcpSubunitInfoEntry
  • BtAvrcpSubunitInfoParams
  • BtAvrcpUnitInfoParams
  • BtBipAttachment
  • BtBipAttachmentDesc
  • BtBipAttachmentFormat
  • BtBipClientService
  • BtBipImage
  • BtBipImageDesc
  • BtBipImageFormat
  • BtBipImageFormat::ImageDim
  • BtBipImageHdl
  • BtBipImageHdlDesc
  • BtBipImageList
  • BtBipImageProperties
  • BtBipImagingCapabilities
  • BtBipMsgArg
    • BtBipDeleteImageIndArg
    • BtBipGetImageInd
    • BtBipGetImagePropertiesInd
    • BtBipGetImagesListInd
    • BtBipGetImagingCapabilitesIndArg
    • BtBipGetLinkedAttachmentInd
    • BtBipGetLinkedThumbnailInd
    • BtBipPutImageIndArg
    • BtBipPutLinkedAttachmentInd
    • BtBipPutLinkedThumbnailIndArg
  • BtBipServerNotificationMsgArg
    • BtBipAbortIndArg
    • BtBipConnectIndArg
    • BtBipDeleteImageIndArg
    • BtBipDisconnectIndArg
    • BtBipGetImageIndArg
    • BtBipGetImagePropertiesIndArg
    • BtBipGetImagesListIndArg
    • BtBipGetImagingCapabilitiesIndArg
    • BtBipGetLinkedAttachmentIndArg
    • BtBipGetLinkedThumbnailIndArg
    • BtBipOpFinishedArg
    • BtBipPutImageCompleteArg
    • BtBipPutImageIndArg
    • BtBipPutLinkedAttachmentCompleteArg
    • BtBipPutLinkedAttachmentIndArg
    • BtBipPutLinkedThumbnailCompleteArg
    • BtBipPutLinkedThumbnailIndArg
  • BtBipServerService
  • BtChipBmscr
  • BtChipBmu
  • BtChipVersion
  • BtDevice
  • BtDeviceAddress
  • BtDeviceAndServiceClass
  • BtDeviceDetailWindow
  • BtDeviceFilter
  • BtDeviceList
  • BtDeviceList::BtDeviceListBidirectionalIterator
    • BtDeviceListConstantIterator
      • BtDeviceListIterator
    • BtDeviceListConstantReverseIterator
      • BtDeviceListReverseIterator
  • BtDeviceList::BtDeviceListNode
  • BtDeviceSearchModeWindow
  • BtDunAppPlugin
  • BtEvent
    • BtObexEvent
      • BtObexClientEvent
        • BtObexClientOperationEvent
          • BtObexClientAbortEvent
          • BtObexClientConnectEvent
          • BtObexClientDisconnectEvent
          • BtObexClientGetEvent
          • BtObexClientPutEvent
          • BtObexClientSetPathEvent
        • BtObexRegisterClientEvent
      • BtObexDataBufferIndicationEvent
      • BtObexDataIndicationEvent
      • BtObexHeaderIndicationEvent
      • BtObexHeaderSentEvent
      • BtObexServerEvent
        • BtObexRegisterServerEvent
        • BtObexServerAbortIndicationEvent
        • BtObexServerConnectIndicationEvent
        • BtObexServerDisconnectIndicationEvent
        • BtObexServerGetIndicationEvent
        • BtObexServerPutIndicationEvent
        • BtObexServerSetPathIndicationEvent
      • BtObexTransportDisconnectEvent
      • BtObexUnregisterEvent
    • BtSddbEvent
      • BtSddbRegisterServiceEvent
      • BtSddbUnregisterServiceEvent
  • BtFaxAppPlugin
  • BtHfAppPlugin
  • BtHfAudioPathWindow
  • BtHfFeatureListWin
  • BtHfInbandSettingWin
  • BtHfProfileWindow
  • BtHfRecord::Persist
  • BtHfVolumeSettingsWin
  • BtHsAppPlugin
  • BtHsConnectionSettingWin
  • BtHsInbandSettingWin
  • BtHsVolumeSettingsWin
  • BtJsr82Url
  • BtJsr82Url::Token
  • BtJsr82Url::Token::Keyword
  • BtMultiConnectionController::BtConnection
    • BtObexController::BtObexConnection
  • BtObexHeader
  • BtObexResponseCode
  • BtObexServiceTable
  • BtObexServiceTable::Entry
  • BtObexServiceTable::ObexTarget
  • BtObexServiceTable::Security
  • BtObexServiceTable::ServiceInfo
  • BtPasskeyRequiredWindow
  • BtRequest
    • BtLocalRequest
      • BtCancelableRequest
        • BtCancelableBroadcastRequest
          • BtDeviceSearchRequest
            • BtApplicationDeviceSearchRequest
        • BtCancelableMulticastRequest
          • BtServiceVerifyRequest
            • BtApplicationServiceVerifyRequest
      • BtUncancelableRequest
        • BtUncancelablePointToPointRequest
          • BtDevicePairRequest
            • BtApplicationDevicePairRequest
          • BtDeviceTrustRequest
            • BtApplicationDeviceTrustRequest
          • BtDeviceUnpairRequest
            • BtApplicationDeviceUnpairRequest
          • BtDeviceUntrustRequest
            • BtApplicationDeviceUntrustRequest
          • BtQuerySupportedProfilesRequest
            • BtApplicationQuerySupportedProfilesRequest
          • BtRequestRespondRequest
            • BtRespondAuthorizationRequest
              • BtApplicationRespondAuthorizationRequest
            • BtSendPasskeyRequest
              • BtApplicationSendPasskeyRequest
          • BtSetRemoteDeviceNameRequest
            • BtApplicationSetRemoteDeviceNameRequest
    • BtServiceRequest
      • BtAvrcpRequest
        • BtAvrcpConnectResponse
        • BtAvrcpDeRegisterRequest
        • BtAvrcpOperationRequestResponse
        • BtAvrcpPanelPassThroughRequest
        • BtAvrcpRawFrameRequest
        • BtAvrcpRegisterRequest
        • BtAvrcpSubunitInfoRequest
        • BtAvrcpUnitInfoRequest
      • BtBppReq
        • BtBppSndAbortReqRequest
        • BtBppSndFilePushReqRequest
        • BtBppSndGetRefObjRspRequest
      • BtConnectRequest
      • BtDisconnectRequest
      • BtObexRequest
        • BtObexClientOperationRequest
          • BtObexAbortRequest
          • BtObexConnectRequest
          • BtObexDisconnectRequest
          • BtObexGetRequest
          • BtObexPutRequest
          • BtObexSetPathRequest
        • BtObexRegisterClientRequest
        • BtObexRegisterServerRequest
        • BtObexUnregisterClientRequest
        • BtObexUnregisterServerRequest
  • BtRequestRunningWindow
  • BtSddbDataElement
    • BtSddbDeContainer
      • BtSddbDeAlternative
      • BtSddbDeSequence
    • BtSddbDeOneByteDescriptionType
      • BtSddbDeBaseCType
        • BtSddbDeBoolean
        • BtSddbDeNil
        • BtSddbDeSintBase
          • BtSddbDeSint16
          • BtSddbDeSint32
          • BtSddbDeSint8
        • BtSddbDeUintBase
          • BtSddbDeUint16
          • BtSddbDeUint32
          • BtSddbDeUint8
        • BtSddbDeUuidBase
          • BtSddbDeUuid16
          • BtSddbDeUuid32
      • BtSddbDeByteBlockType
        • BtSddbDeBigSintBase
        • BtSddbDeBigUintBase
          • BtSddbDeSint128
          • BtSddbDeSint64
          • BtSddbDeUint128
          • BtSddbDeUint64
        • BtSddbDeUuid128
    • BtSddbDeVariableLengthType
      • BtSddbDeString
      • BtSddbDeUrl
  • BtSddbDataElementFactory
  • BtSddbServiceAttribute
  • BtSddbServiceRecord
  • BtServiceObserver
    • BtObexServiceObserver
      • BtObexClientServiceObserver
        • BtObexClientObserverImpl
      • BtObexServerServiceObserver
        • BtObexServerObserverImpl
    • BtSddbServiceObserver
      • BtObexSddbServiceObserverImpl
  • BtServiceVerifyResult
  • BtSvrDataElement
  • BtSvrServiceAttribute
  • BtSvrServiceRecord
  • BtTurnOnOffWindow
  • BtUUID
  • BufferPoolManager
  • ByteBuffer
    • PppFrame
  • CalendarAddRecordWin
  • CalendarApp
  • CalendarDialogWin
  • CalendarGotoDateWin
  • CalendarListWin
  • CalendarMonthWin
  • CalendarRecord::Persist
  • CalendarRecordsList
  • CalendarRecordsListBoxModel
  • CallBarringFeature
  • CallBarringFeatureList
  • CallBarringHandler
  • CallBarringInfo
  • CallDeflectionHandler
  • CallDisconnectingArg
  • CallEvent
  • CallForwardingHandler
  • CallHandler
  • CallHdlBase
    • CallHdl
    • MptyCallHdl
  • CallInfoArg
  • CallingName
  • CallSetupProgressArg
  • CallWaitingHandler
  • Camera::ParameterLimits
  • CameraApp
  • CameraCaptureWin
  • CameraOptionSettingsWin
  • CameraSettings
  • CameraSettingsWin
  • CameraViewFinderWin
  • CamWin32
  • Caret
    • DefaultCaret
      • MultiTapCaret
  • CArray< T >
  • CbmiData
  • CbmiRange
  • Cbs
  • Cbs::Filter
  • Cbs::SerialNumber
  • CbsFilterList
  • CbsFilterList::CbsFilterListEntry
  • CbsHandler
  • CcbsEntry
  • CcbsList
  • CcpData
  • Cell
  • CellChangeCnts
  • CellParam
  • CfuService
  • CfuServiceArray
  • ChannelData_s
  • ChannelDataArray
  • ChargerSignalProcessor
  • CharInputMapEntry
  • ChineseT9Wrapper
  • ChvAttemptsStruct
  • ChvData
  • CiTestParam
  • CiTestParamList
  • ClientId
  • ClientInfo
  • ClientName
  • ClipHandler
  • CliRestrictionInfo
  • ClirHandler
  • CmiRecord
  • CnapHandler
  • CodecDevice
    • AudioCapturerEncoder
      • AtiAudioCapturerEncoder
    • AudioDecoder
      • EmzAacDecoder
      • EmzAacDecoder
      • EmzMp3Decoder
      • EmzMp3Decoder
    • AudioDecoderRenderer
      • AtiAudioDecoderRenderer
    • AudioEncoder
      • EmzSbcEncoder
    • VideoDecoder
      • AtiMpeg4Decoder
      • EmzH264Decoder
      • EmzH264Decoder
      • EmzMpeg4Decoder
      • EmzMpeg4Decoder
      • ScicosMpeg4VideoDecoder
    • VideoEncoder
      • AtiMpeg4Encoder
      • EmzMpeg4Encoder
      • EmzMpeg4Encoder
      • ScicosMpeg4VideoEncoder
  • CodecDevice::AudioChannel
  • CodecDevice::AudioCodecCapabilities
  • CodecDevice::AudioDecoderParameters
  • CodecDevice::AudioEncoderParameters
  • CodecDevice::AudioIOBuffer
  • CodecDevice::AudioStreamInfo
  • CodecDevice::Properties
  • CodecDevice::VideoCodecCapabilities
  • CodecDevice::VideoDecoderInfo
  • CodecDevice::VideoDecoderParameters
  • CodecDevice::VideoEncoderInfo
  • CodecDevice::VideoEncoderParameters
  • CodecDevice::VideoStreamInfo
  • CodecManager
  • CodedTimeStamp
  • Color
  • ColorSegmentation
  • ColorTable
  • ColpHandler
  • ColrHandler
  • ColumnInfo
  • comm_root_cert
  • comm_user_cert
  • CommandType
  • CommonSignalProcessor
  • CompoundItemIterator
  • CompoundItemReferrer
  • Condition
    • BooleanCondition
      • BtLocalSettings
      • TimeoutCondition
  • ContextDescription
  • ContextManager
  • ContextTable
  • ContextTableEntry
  • ContextTableNode
  • Control::ComponentIterator
  • Control::NavigationGuidance
  • Conversion
  • CopyHandler
    • PbCopyHandler
  • COverIList
  • CphsCfufArray
  • CphsCspArray
  • CphsIstArray
  • CphsOnmName
  • CphsOnsName
  • CphsVmwfArray
  • CrssHandler
  • CsdDataConnProfile::Bit
  • CsdDataConnProfile::Persist
  • CTResourcePack
  • CugDescriptor
  • CurrencyCode
  • DataCallContext
  • DataCallControl
    • CsdDataConn
  • DataCallHdl
  • DataCallSignalProcessor
  • DataCoding
  • DataCodingScheme
  • DataConnAccessor
    • CsdDataConnAccessor
    • PsdDataConnAccessor
    • SerDataConnAccessor
  • DataConnApp
  • DataConnApp::DataConnDescription
  • DataConnApp::EditableSettingTable
  • DataConnLbModel
  • DataConnManager
  • DataConnOptionWin
  • DataConnProfile
    • CsdDataConnProfile
    • PsdDataConnProfile
  • DataConnProfile::Bit
  • DataConnProfile::Persist
  • DataConnProfileManager
  • DataConnProfileManager::ProfileInfo
  • DataConnProfileStorage
    • FfsDataConnProfileStorage
  • DataConnProfileStorage::Header
  • DataConnTypeWin
  • DataConnWin
  • DataItem
  • DataPack
    • FilePack
    • FontPack
    • T9Pack
    • TextPack
  • DataRecord
  • DataRecordHandler
    • NvRamDataRecordHandler
  • DataSink
    • FileDataSink
      • RamDataSink
    • HeapDataSink
    • StringDataSink
  • DataSource
    • BinDataDataSource
    • FileDataSource
      • RamDataSource
    • HeapDataSource
    • NonsharedBinDataDataSource
  • Date
    • DateTime
  • Date::Persist
  • DateStr
  • datestr
  • DateTime::Persist
  • DbgDump
  • DbgTimingMeasurement
  • DBService::DBItemIterator
  • DchReport
  • DeletedNode
  • DeletedNodeList
  • DeviceContext
    • BitmapDc
    • ControlDc
      • ClientDc
      • FrameDc
    • DisplayDc
    • PaintDc
    • SyncPaintDc
  • DeviceManager
  • DeviceManager::Iterator
  • DirectoryIterator
    • FatDirectoryIteratorImp
    • FlashDirectoryIteratorImp
    • RamDirectoryIteratorImp
    • RootDirectoryIteratorImp
  • DirtyFileHandler
  • Dispatcher
    • AbstractMenuAccessor
      • MenuAccessor
        • AbstractActionMenuAccessor
          • ActionMenuAccessor
      • TextMenuAccessor
    • Application
      • AtlApplication
      • GltpConnApp
    • Component
      • Control
        • AbstractButton
          • CheckBoxControl
          • PushButton
          • RadioButtonControl
          • TabButton
        • AbstractEditBox
          • DateEditBox
          • EditBox
          • TimeEditBox
        • AbstractEditor
          • AbstractLineEditor
            • DateEditor
            • IpAddrEditor
            • LineEditor
              • PbNameEditBox
                • PbDetailEditBox
              • SearchBox
            • PasswordEditor
            • TimeEditor
          • AbstractMultiLineEditor
            • MultiLineEditor
              • SmsEditor
            • MultiMediaEditor
              • EmsEditor
        • AbstractGrid
          • AbstractItemGrid
            • ItemGrid
              • AtlItemGrid
              • ItemMenu
                • AtlItemMenu
            • ItemTree
          • CalendarGrid
          • CalendarMonthSelector
          • Menu
            • TopLevelMenu
        • AbstractListBox
          • AbstractMenuList
            • CheckBoxList
            • MenuList
            • RadioButtonList
              • TRadioButtonList< Content >
          • ProviderListBox
          • TextList
        • AbstractPredictiveInputBox
          • T9PredictiveInputBox
          • Zi8PredictiveInputBox
        • CheckBox
        • FlowLayout
        • Grid
        • GridLayout
        • IndicatorBar
        • TabControl
        • Window
          • Alert
          • AtlWindow
            • AbstractSmsComposeWin
              • EmsComposeWin
              • SmsComposeWin
            • AbstractSmsViewerWin
              • EmsViewerWin
              • SmsViewerWin
            • AtlItemGridWindow
              • AtlItemListWindow
                • AtlLabelListWindow
                • BtAvrcpControllerDeviceListWindow
                • BtAvrcpDeviceListWin
                • BtDeviceListWindow
                • FmRadioSelectStrongerFreq
                • UibFolderWin
              • AtlItemMenuWindow
            • ImageBrowserDetailWin
            • PropertyEditor
          • ContextMenu
          • DialogWindow
          • MenuWindow
          • MessageBox
          • Panel
          • SavingProgressWin
      • DrawableObject
        • AbstractTextObject
          • TextBox
          • TextLine
            • AnimatedTextLine
        • Animation
        • BrowserViewContainer
        • BrowserViewContainer
        • ImageBox
        • ItemBox
          • AtlItemBox
        • ItemLabel
        • MediaBox
        • PositionIndicator
        • ProgressBar
        • SelectionBox
        • SoftkeyBar
        • StrokeBox
        • SvgPlayer
        • T9PinyinBox
        • Zi8AlphabetBox
        • Zi8SelectionBox
        • Zi8StrokeBox
    • Model
      • AbstractEditBoxModel
        • DateEditBoxModel
        • EditBoxModel
        • TimeEditBoxModel
      • AbstractListBoxModel
        • AbstractMenuListModel< Item >
        • GridModel
        • ProviderListBoxModel
        • TextListModel
      • AnimationModel
      • CheckBoxModel
      • EditorDocument
        • DateEditorDocument
        • MultiMediaEditorDocument
        • TextEditorDocument
          • IpAddrEditorDocument
        • TimeEditorDocument
      • RadioButtonModel
    • UserDispatcher
      • AtlApplicationPlugin
      • BtLocalRequest
      • BtLocalSettings
      • BtService
        • BtAudioAccessoryService
          • BtHfService
            • BtHfProfileService
          • BtHsService
            • BtHsProfileService
        • BtAvrcpService
          • BtAvrcpOperationService
            • BtAvrcpProfileOperationService
          • BtAvrcpRegistrationService
            • BtAvrcpProfileRegistrationService
        • BtBppService
          • BtBppClientService
          • BtBppServerService
        • BtDunService
          • BtDunProfileService
        • BtFaxService
          • BtFaxProfileService
        • BtObservableService
          • BtObexService
            • BtObexClientService
              • BtObexClientServiceImpl
            • BtObexServerService
              • BtObexServerServiceImpl
          • BtSddbService
            • BtObexSddbImpl
      • Desktop
        • MainDesktop
      • GenericAudioDevice
      • HttpHandler
      • MessageMapDispatcher
        • ActiveWaitDispatcher
          • StackMsgActiveWaitDispatcher
            • CbsStartDispatcher
            • CbsStopDispatcher
            • MultiSlotDispatcher
            • PlmnRatDispatcher
            • PlmnScanDispatcher
            • PowerDownDispatcher
            • SmsSendDispatcher
            • SsWaitDispatcher
            • TipdBasedActiveWaitDispatcher
        • ObexDispatcher
      • SharedTimer
        • SharedTriggerTimer< T >
      • SimUserDispatcher
      • SocketHandler
      • StackMsgDispatcher
        • AccDispatcher
        • AocDispatcher
        • AtcDispatcher
        • BootDispatcher
        • CbsDispatcher
        • GltpProviderImpl
        • LcsProviderImpl
        • MmCallDispatcher
        • NetworkDispatcher
        • PlmnDispatcher
        • PowerDispatcher
        • SaProviderImpl
        • SigDispatcher
        • SimDispatcher
        • SmsDispatcher
        • SsCcbsDispatcher
        • SsDispatcher
        • StatusDispatcher
      • UsbTransport
      • WapHandler
  • Display::CustomFrameBuffer
  • DisplayConfig
  • DisplaySettings
  • DnsClient
    • DnsClientTest
  • DownloadSettings
  • DrmAsset
  • DrmDcfHeader
  • DrmDcfHeaderData
  • DrmDcfParser
  • DrmInfoPersistStructure
  • DrmMediaObject
  • DrmMessage
  • DrmRelParser
  • DrmRightsMapTableEntry
  • DrmRightsObject
  • DrmRightsObjectContainer
  • DrmRightsObjectFile
  • DrmRightsObjectStore
  • DrmROStoreSingleton
  • DrmSecurity
  • DrmUtils
  • dstat
  • DtmfRejectArg
  • DtmfStartCnfArg
  • DwdDevice
    • AudioVibratorDevice
    • DwdPlayer
      • MapiAudioPlayer
      • StreamAudioPlayer
        • MP3AudioPlayer
    • RadioAudioDevice
    • SpeechSimpleAudioDevice
  • DynamicBitVector
  • EccArray
  • EccCategory
  • EccCustomization
  • EccNetworkArray
  • EccNetworkElement
  • EccNetworkNumber
  • EctIndicator
  • EditConfig
  • EditLine
  • EditorItemNode
  • EditorLine
  • emcpp_apoxi_OBEXAdapter
  • EmlppHandler
  • EmlppPriority
  • EmsCreator
  • EmsCreator::SpaceInfo
  • EmsEditorListener
    • EmsComposeWin
  • EmsIeParser
  • EmsInsertPrompt
  • EmsInsertPromptListBoxModel
  • EmsResourceMaps
  • EmsResourceMaps::AnimNode
  • EmzCodecsLib
  • EmzUtils
  • EmzUtils::Queue< T >
  • EmzUtils::Queue< T >
  • EnumTextMap
    • CallTypeTable
    • CsdSettingsTable
    • DataConnCommonSettingsTable
    • DataRateTable
    • PdpAuthTable
    • PdpQoSDelayTable
    • PdpQoSMeanRateTable
    • PdpQoSPeakRateTable
    • PdpQoSPrecedenceTable
    • PdpQoSReliabilityTable
    • PsdSettingsTable
    • SerSettingsTable
    • SmsConcatStatusTextMap
    • SmsGsmServiceTextMap
    • SmsMsgTypeTextMap
    • SmsMsgTypeUsageTextMap
    • SmsResultTextMap
    • SmsStatusReportTextMap
    • SmsStatusTextMap
    • SmsStorageTypeTextMap
    • SmsTelematicDeviceNameTable
    • SmsTemplateTextMap
  • EnumTextTableEntry
  • EnumTranslationTable
  • EquivPlmnLists
  • EventData
  • ExecutionContext
    • Application
    • ServiceThread
      • Server
        • FtpServer
        • HttpServer
      • SimTkLceService
  • ExtLanguage
  • ExtLanguageArray
  • ExtPsdContextListener_SerialTerminal
  • ExtPsdContextListener_SerialTerminalListener
    • ExtPsdContextListenerImpl_SerialTerminalListener
  • ExtPsdContextListener_SioGlueSignalListener
  • ExtPsdContextListener_SioGlueWrapper
  • ExtPsdContextListener_SioGlueWrapper::SioCommId
  • ExtPsdContextListener_SioGlueWrapper::TermIos
  • FatFile
  • FatFileInfo
  • FatFindData
  • FatHandler
  • Feature
    • BackToIdleFeature
    • ContextFeature
    • Property
    • TriggerKeyFeature
  • FeatureBroker
  • FeatureHandle
    • ContextFeatureHandle
  • FeaturePool
  • ffs_drm_attrib_type
  • ffs_file_info_type
  • ffs_ref_type
  • ffs_time_record_type
  • FfsDrmAttrib
  • FfsFile
  • FfsFileInfo
  • FfsHandler
  • FfsMenu
  • FfsMimeTypeMap
  • FfsMimeTypeMapEntry
  • FfsRefType
  • FfsTestBase::FfsTestInfo
  • FfsTestDispWin
  • FfsTestMenu
  • FfsTestResultsMenu
  • FfsTestResultsSubMenu
  • FfsTests
  • FfsTestSubMenu
  • FfsTimeRecord
  • File
    • FatFileImp
    • FlashFileImp
    • RamFileImp
    • RootFileImp
  • File::Attributes
  • File::FileState
  • FileChunkOperator
  • FileFilter
    • ImageFileFilter
    • NamePatternFileFilter
    • SoundFileFilter
  • FileInfo_s
  • FileInfoInternal_s
  • FileInReadStatusInfo
  • FileNameListBoxModel
  • FilePackConnector
  • FileVisitor
  • FilterRule
    • DcsLanguageFilterRule
    • EqualsRule
    • GreaterRule
    • LessRule
    • NotEqualsRule
      • DistinctRule
    • PhoneNumberMatchRule
    • RangeRule
  • FixedPtrArray< T >
  • FlagCaretaker
  • FlsFile
  • FmRadioApplication
  • FmRadioEditWin
  • FmRadioSettingsRecord::Persist
  • FmRadioStationsRecord::Persist
  • FmRadioWindow
  • Font
    • FontEntry
    • RomFont
  • FontConfig
  • FontManager
  • FontPackConnector
  • FontRes
  • ForwardingFeature
  • ForwardingFeatureList
  • ForwardingInfo
  • ForwardingInfoReceivedArg
  • Fraction
  • fs_registered_info_type
  • fs_stat
  • FsRegistrationInfo
  • FtpRequest
  • FtpTransfer
    • FtpInTransfer
    • FtpOutTransfer
  • FunctionalityIndicator
  • GatiServer
    • AudioGatiServer
  • GenericFeatureData::GenericTrackInfo
  • GenericObject
    • BlobPtr
      • BlobObject
        • RegBlobObject
    • BtDeviceAddressGenericObject
    • CompoundSmsItem
    • CompoundTpduItem
    • GenericFeatureData
    • ImageRefGenContainer
    • ImgObtObj
    • ItemObj
    • MenuDescObj
    • MenuIdObj
  • GlassPane
  • GltpAidDataRequests
  • GltpAidingDataWin
  • GltpAssistanceData
  • GltpRequest
    • GltpAidingRequest
    • GltpHelloRequest
    • GltpMsmtRequest
    • GltpPositionRequest
  • GltpSignalProcessor
  • Glyph
  • GlyphHeader
  • GlyphIndexTab
  • GmmParam
  • GprsParam
  • GpsFixData
  • GpsFixDataInt
  • GroupProvider::GroupRec
  • GsmBandList
  • Guid
  • GuidServiceTable
  • GuidUriTable
  • GuiEngineConfig
  • GuiObjectFactory
  • HandlerData
  • HandlerFactory
  • HashTable
  • HeaderData
  • HeadSet
  • HeapArrayObject< T >
  • HeapManager
  • HeapVector
  • HeapVector::BlockPage
  • HeapVector::FctTable
  • HeapVector::HeapTableEntry
  • HeapVector::Page
  • HeapVector::Stats
  • HeapVector::VarPage
  • HomezoneText
  • HostDebugTimeStamp
  • HostFatFsDeviceDescriptor
  • HostFileStatType
  • HostIniFile
  • HostIterStatType
  • HttpApplication
  • HttpApplicationSupplier
  • HttpRequest
  • HttpRequest::ParamPair
  • HttpResponse
  • HttpWapMgr
  • HttpWapMgrBase
    • HttpWapMgrPlugin
  • Iana
  • IccId
  • IconSet
  • IconState
  • IdentifierHandler
  • Image::CleanupDrawingObtainer
  • Image::MetaData
  • ImageBrowserApp
  • ImageBrowserTestWin
  • ImageBrowserWin
  • ImageDecoder
  • ImageEncoder
    • JpegEncoder
    • PngEncoder
  • ImageEncoder::EncodingParameters
    • JpegEncoder::EncodingParameters
    • PngEncoder::EncodingParameters
  • ImageFactory
  • ImageListBoxModel
    • ImageViewListBoxModel
  • Imei
  • IMelodyData
  • Imsi
  • IncrementalPdcUpdater
    • ImageIncrementalPdcUpdater
  • IndexTable< T >
  • IndicatorDescription
  • IndicatorLocation
  • InetSocketAddr
  • InfoDialog
  • InformationElement
  • InputAction
    • ApoxiCommandAction
    • BarringSsAction
      • SsCallBarringActionImpl
    • CallSsAction
    • ClirAction
      • SsClirActionImpl
    • EmlppAction
      • SsEmlppActionImpl
    • EngModeAction
    • ForwardingSsAction
      • SsCallForwardingActionImpl
    • ImeiShowAction
    • LanguageResetAction
    • MoCallAction
    • NumberIdentificationAction
      • ClipAction
        • SsClipActionImpl
      • CnapAction
        • SsCnapActionImpl
      • ColpAction
        • SsColpActionImpl
      • ColrAction
        • SsColrActionImpl
    • PasswordChangeSsAction
      • SsPasswordChangeActionImpl
    • PbEntryShowAction
    • PinAction
    • UndefinedSsAction
    • UnlockAction
    • UssdAction
      • SsUssdActionImpl
    • WaitSsAction
      • SsCallWaitingActionImpl
  • InputAnalyzer
  • InputContext
  • InputMap
  • InputMapEntry
  • InputMapItem
    • CharInputMapItem
    • KeyDownInputMapItem
    • KeyUpInputMapItem
  • InputMapper
    • MultiTapInputMapper
    • NumericInputMapper
      • CalculatorInputMapper
      • DateTimeInputMapper
      • IpAddrInputMapper
      • PhoneNumberInputMapper
    • PredInputMapper
      • T9InputMapper
        • EnglishT9InputMapper
          • ChineseT9InputMapper
      • Zi8InputMapper
  • InputMapperFactory
  • InputParser
  • InputStream
    • FileInputStream
  • InteriorNodeRecord
  • InternalTracer
  • InternalTracer::TraceHeader
  • InternalTracer::TsStruct
  • InterrogateCcbsResult
  • InterrogateSsResult
  • InterrogationResultArg
  • InvokeId
  • IpAddr
  • IpAddrPrompt
  • IpPortNo
  • IrConnection
  • IrdaApp
  • IrdaWin
  • IsrDataContainer< Data, c_queue_size >
  • IsrDataManager
  • IsrDataMarshaller
  • Item
    • AbstractItemContainer
      • ItemContainer
        • FeatureItemContainer
        • ProviderProxyContainer
    • Action
      • AbstractToggleAction
        • CheckBoxAction
          • PbToggleAction
        • RadioButtonAction
      • AccessorAction
      • ApplicationAction
      • CancelAction
      • CloseWindowAction
      • ConfirmAction
      • FeatureItem
        • ContextFeatureItem
        • IndicatorItem
        • PropertyItem
      • OpenContextMenuAction
      • OpenWindowAction
      • PbAction
        • DisplayMemoryAction
        • PbCallAction
        • PbSecuredAction
          • AddAllToFdnAction
          • AddEntryToFdnAction
          • AddNumberToFdnAction
          • AdvPbAction
            • PbChangeNoTypeAction
            • PbDelPhonenoAction
            • PbSelectGroupAction
            • SyncPhoneAction
            • SyncPhoneAllAction
            • SyncSimAction
            • SyncSimAllAction
          • CopyToPbAction
          • PbAddAction
          • PbAdvDetailAction
            • PbAddPhoneNoAction
            • PbCancelAddNoAction
            • PbConfirmAddNoAction
          • PbDelAllAction
          • PbDeleteAction
          • PbDetailAction
            • PbCancelEditAction
            • PbConfirmEditAction
            • PbEditDetailAction
        • SyncAction
      • SaveNoAction
      • SetLanguageAction
      • SetThemeAction
      • SubMenuAction
    • BtAvrcpControllerDeviceListItem
    • BtDeviceListItem
    • ProviderProxyItem
    • SubUnitReference
  • ItemMenu::LevelInfo
  • ItemRendererProperties
  • JapaneseTranscoder
  • JarBinDataStatusInfo
  • JarFileGlobalInfo_s
  • JarFileStatusInfo
  • JmpBuf
  • JoinRule
    • PhoneNumberJoinRule
    • StandardJoinRule
  • KeyboardConfig
  • KeyDownInputMapEntry
  • KeyManager
  • KeyMapping
  • KeymapTableEntry
  • KeySequence
  • KeySequenceCandidate
  • KeyToneAudioDevice::StartParam
  • KeyUpInputMapEntry
  • L1Param
  • Lai
  • LanguageArray
  • LanguageCodeTableEntry
  • LanguageManager
  • Layouter
  • LcsAppUtils
  • LcsArc
  • LcsCommonSignalProcessor
  • LcsMainApp
  • LcsMainMenuWin
  • LcsMmiQos
  • LcsOptionsMenuWin
  • LcsPoint
  • LcsPointAltitudeUncertEllipsoid
  • LcsPointUncertCircle
  • LcsPointUncertEllipse
  • LcsProvider
  • LcsProviderImplBase
    • GltpProviderImpl
    • LcsProviderImpl
    • SaProviderImpl
  • LcsQos
  • LcsReqProcessor
  • LcsSettingsApp
  • LcsSettingsUtils
  • LcsSignalProcessor
  • LcsUtils
  • LcsWapIntf
  • Led::Color
  • Led::Frame
  • Led::Stream
  • Led::StreamField
  • LedSignalProcessor
  • LexAnalyzer
  • LinkableBase
    • Linkable< T >
    • Linkable< AbstractAppContext >
      • AbstractAppContext
        • AppContext
        • AppContext
        • SimpleAppContext
    • Linkable< ApoxiThread >
      • ApoxiThread
        • AppContainer
        • ServiceThread
    • Linkable< Application >
      • Application
    • Linkable< ApplicationListEntry >
      • ApplicationListEntry
    • Linkable< AppRoutingTableEntry >
      • AppRoutingTableEntry
    • Linkable< AudioAccessoryDetails >
      • AudioAccessoryDetails
    • Linkable< AudioCallback >
    • Linkable< AudioPath >
      • AudioPath
    • Linkable< AudioPreset >
      • AudioPreset
    • Linkable< CheckBoxItem >
      • CheckBoxItem
    • Linkable< class MemPoolEntry >
      • MemPoolEntry
    • Linkable< CondListEntry >
    • Linkable< DataCodingSchemeRange >
      • DataCodingSchemeRange
    • Linkable< DispatcherAction >
      • DispatcherAction
    • Linkable< DrmConstraint >
      • DrmConstraint
    • Linkable< DrmPermission >
      • DrmPermission
    • Linkable< HandlerListEntry >
      • HandlerListEntry
    • Linkable< Hashable >
      • Hashable
        • AppContainerRoutingTableEntry
    • Linkable< InputActionPtr >
      • InputActionPtr
    • Linkable< Key >
      • KeyMsgGenerator::Key
    • Linkable< MainHandler >
      • MainHandler
    • Linkable< MediaRefLinkable >
      • MediaRefLinkable
      • MediaRefLinkable
    • Linkable< MenuItem >
      • MenuItem
        • WinMenuItem
    • Linkable< MessageIdentifierRange >
      • MessageIdentifierRange
    • Linkable< MolrInfo >
      • MolrInfo
        • MolrRepeatInfo
    • Linkable< MtlrInfo >
      • MtlrInfo
    • Linkable< NotificationArray >
      • NotificationArray
    • Linkable< ObexHeader >
      • ObexHeader
    • Linkable< ObexServerInfo >
      • ObexServerInfo
    • Linkable< PdpContext >
      • PdpContext
    • Linkable< PlmnListEntry >
      • PlmnListEntry
    • Linkable< PortHeaderInformation >
      • PortHeaderInformation
    • Linkable< PortTpdu >
    • Linkable< ProviderPtr >
      • ProviderPtr
    • Linkable< PxAuthInfoCharacs >
      • WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
    • Linkable< PxPhysicalCharacs >
      • WapProfile::PxLogicalCharacs::PxPhysicalCharacs
    • Linkable< PxPortCharacs >
      • WapProfile::PxLogicalCharacs::PxPortCharacs
    • Linkable< QueueEntry >
    • Linkable< RadioButtonItem >
      • RadioButtonItem
        • TRadioButtonItem< Content >
    • Linkable< Service >
      • Service
        • DBService
        • ObjectTreeService
    • Linkable< SettingsProvider >
      • SettingsProvider
        • BtHfProvider
        • FmRadioSettingsProvider
        • FmRadioStationsProvider
        • SmsSettingsProvider
        • ToDoProvider
        • UibSettingsProvider
    • Linkable< SharedPtr< T_obj > >
      • SharedPtr< T_obj >
    • Linkable< SimItemIdentifier >
      • SimItemIdentifier
    • Linkable< SimpleMapElem< TKey, TValue > >
      • SimpleMapElem< TKey, TValue >
    • Linkable< SmsSocket >
      • SmsSocket
    • Linkable< Threadlet >
      • Threadlet
        • DecodingThreadlet
        • EncodingThreadlet
          • JpegEncodingThreadlet
          • PngEncodingThreadlet
        • FfsTestThreadlet
        • SyncPhoneThreadlet
        • UibUpdateThreadlet
        • UpdatePbThreadlet
    • Linkable< Timer >
      • Timer
        • Animation
        • AudioActiveReference
        • EditBoxBlinkTimer
        • EditBoxPagingTimer
        • LcsRepeatTimer
        • LcsTimer
        • SharedTimer
        • TriggerTimer< T >
    • Linkable< Tpdu >
      • Tpdu
    • Linkable< WapProfileInfo >
      • WapProfileMgr::WapProfileInfo
  • LinkedListBase
    • ElementListBase
      • ElementList< T >
        • SortedElementList< T >
      • ElementList< InputActionPtr >
        • SortedElementList< InputActionPtr >
          • InputActionList
    • LinkedList< T >
      • FifoLinkedList< T >
    • LinkedList< ObexHeader >
      • ObexHeaderList
    • SortedLinkedListBase
      • SortedLinkedList< T >
  • LittleEndian16Bit
    • Native16Bit
  • LittleEndian32Bit
    • Native32Bit
  • LocalDataStore
  • Locale
  • Locale::LocaleData
  • LocaleConfig
  • LocationEstimate
    • LastLocationEstimate
  • LocationVerifWin
  • LociData
  • LockTable
  • LockTableEntry
  • LockTableList
  • LocResController
  • LookupAlphaIdExtension
  • LsaIdentifier
  • LsaIdentifierArray
  • MainHandlerAccess
  • MainProvider
    • DataHandler
  • MappingPolicy
    • RangeMappingPolicy
  • MdhDeletionCmd
  • MdhExtendedData
  • MdhGors
  • MdhResult
  • MdhSetWaitIndicator
  • MdhSetWaitIndicatorArray
  • MdhViewConfig
  • MdhWaitIndicator
  • MdhWaitIndicatorArray
  • MeasurementData
  • Media::Parameters
  • MediaBrowserUtils
  • MediaFilter
    • ImageFilter
    • ImageFilter
    • MimeTypeFilter
    • MimeTypeFilter
    • SoundFilter
    • SoundFilter
  • MediaFrameworkCaps
  • MediaInfo
  • MediaInfo::ClipInfo
  • MediaInfo::MediaTrackInfo
    • MediaInfo::AudioTrackInfo
    • MediaInfo::VideoTrackInfo
  • MediaManager
  • MediaPlayer
  • MediaRecorder
  • MediaRef
    • ImageRef
    • SoundRef
  • MediaRefContainer
    • ImageRefContainer
    • SoundRefContainer
  • MediaVisitor
    • MediaPathnameVisitor
    • MediaPathnameVisitor
  • MemMap
  • MemoryConfig
  • MemPool
  • MenuDesc
  • MenuPool
    • DynamicMenuPool
  • MenuPool::FeatureItemContainerContentTableEntry
  • MenuPool::FeatureItemContainerTableEntry
  • MenuPool::MenuTableEntry
  • MenuProperties
  • MenuTable
  • MenuTableNode
  • MenuTextIterator
    • MenuTextPtrArrayIterator
  • MePhonebookDescription
  • MePhonebookDescriptor
  • Message
    • ActionExecutedMsg
    • AlarmMsg
    • AppCloseMsg
    • AppOpenMsg
    • AppUpdateDisplayMsg
    • AragonMsg
    • AudioAccessoryConnectedMsg
    • AudioDeviceStatusMsg
    • AudioErrorMsg
    • AudioFastForwardStartedMsg
    • AudioFmRadioRdsAlternativeFrequenciesMsg
    • AudioFmRadioRdsInfoMsg
    • AudioFmRadioRdsRadioTextMsg
    • AudioFmRadioRdsRawDataMsg
    • AudioFmRadioRdsStationNameMsg
    • AudioFmRadioRssiMsg
    • AudioFmRadioSeekMsg
    • AudioGetPlayPositionMsg
    • AudioMsg
    • AudioPlayTimeMsg
    • AudioRadioDeviceNotificationMsg
    • AudioRecordingStoppedMsg
    • AudioRestartedMsg
    • AudioResumedMsg
    • AudioRewindStartedMsg
    • AudioStartedMsg
    • AudioStoppedMsg
    • AudioStreamingSyncMsg
    • AudioSuspendedMsg
    • AudioUserDefinedMsg
    • AudioVoiceMemoOutOfSpaceMsg
    • BatteryLoadLevelMsg
    • BtApplicationMessage
      • BtDunApplicationMessage
        • BtDunConnectMessage
        • BtDunDisconnectMessage
      • BtFaxApplicationMessage
        • BtFaxConnectMessage
        • BtFaxDisconnectMessage
      • BtGapAndSdapApplicationMessage
        • BtGapAndSdapNotificationMessage
          • BtRemoteDevicePairMessage
        • BtGapAndSdapRemoteRequestMessage
          • BtAuthorizationRequiredMessage
          • BtPasskeyRequiredMessage
    • BtIndicatorMsg
    • BtRequestMessage
      • BtCloseMessage
      • BtGapAndSdapRequestMessage
        • BtCancelSearchMessage
        • BtCancelVerifyMessage
        • BtDevicePairMessage
        • BtDeviceSearchMessage
        • BtDeviceTrustMessage
        • BtDeviceUnpairMessage
        • BtDeviceUntrustMessage
        • BtHfSupportedProfileMessage
        • BtHsSupportedProfileMessage
        • BtLocalSettingsMessage
          • BtConnectabilityMessage
          • BtDiscoverabilityMessage
          • BtLocalNameMessage
          • BtPairabilityMessage
          • BtProfileActivationMessage
        • BtPaSupportedProfileMessage
        • BtQuerySupportedProfilesMessage
        • BtRemoteDeviceMessage
        • BtRemoteDeviceNameMessage
        • BtRespondAuthorizationMessage
        • BtSendPasskeyMessage
        • BtServiceVerifyMessage
        • BtServiceVerifyResultMessage
        • BtSetRemoteDeviceNameMessage
        • BtStateChangedMessage
      • BtOpenMessage
    • BtRequestOperationMessage
    • BtServiceMessage
      • BtBipProgressMsg
      • BtRequestStateChangedMessage
        • BtAvrcpRequestStateChangedMessage
        • BtBppRequestStateChangedMessage
        • BtDunRequestStateChangedMessage
        • BtFaxRequestStateChangedMessage
        • BtHfRequestStateChangedMessage
        • BtHsRequestStateChangedMessage
        • BtObexClientRequestStateChangedMessage
        • BtObexServerRequestStateChangedMessage
        • BtSddbRequestStateChangedMessage
    • CallAcceptMsg
    • CallControlIndMsg
    • CallEventMsg
    • CallReleaseMsg
    • CfuStatusMsg
    • ChargerInfoMsg
    • ChvChangedMsg
    • CloseAllMsg
    • CloseWindowMsg
    • ContextMenuClosedMsg
    • ContextMsg
      • AbortResMsg
      • AccessoryIndMsg
      • AlarmNotificationMsg
      • AocChargingStatusMsg
      • AppActionExecutedMsg
      • AppGetFocusMsg
      • AppLoseFocusMsg
      • AsyncUnitTestMsg
      • BandSelectionMsg
      • BandStatusMsg
      • BarringInfoReceivedMsg
      • CallControlInfoMsg
      • CallDeflectionErrIndicationMsg
      • CallDeflectionIndMsg
      • CallDeflectionRejectedMsg
      • CallDisconnectedMsg
      • CallDisconnectingMsg
      • CalledPartyAlertingMsg
      • CallHoldRejectedMsg
      • CallInfoMsg
      • CallNotifyMsg
      • CallOnHoldMsg
      • CallSetupProgressMsg
      • CameraMsgStartViewfinding
      • CameraMsgStopViewfinding
      • CbsLimitMsg
      • CbsNewDataMsg
      • CcbsRecallMsg
      • CcbsResultMsg
      • CcbsStatusMsg
      • CellInfoMsg
      • CloseDataConnMsg
      • ConnectionStatusMsg
      • ContextExecuteMsg
        • RegCbNotifyMsg
      • ContextFeatureTriggerMsg
      • ContextWakeupMsg
      • ContinueSocketTestMsg
      • CtmInfoIndMsg
      • CurrentCallMeterMsg
      • CurrentChargeDataMsg
      • DBItemChangedMsg
      • DeleteComponentMsg
      • DhChannelChangeStatusResMsg
      • DhChannelCloseReqMsg
      • DhChannelDataAvailableResMsg
      • DhChannelOpenReqMsg
      • DhChannelReceiveReqMsg
      • DhChannelSendReqMsg
      • DiagnosticIndMsg
      • DisabledFeatureTriggeredMsg
      • DtmfBufferCleanedMsg
      • DtmfRejectMsg
      • DtmfStartCnfMsg
      • DtmfStopCnfMsg
      • EmServThreadMsg
      • EngineeringModeControlResponseMsg
      • EngineeringReportMsg
      • FeatureTriggerMsg
      • FileChunkOperationProgressMsg
      • ForwardingInfoReceivedMsg
      • GltpConnStatusMsg
      • GsmBandStateMsg
      • HlrSsDataCorruptMsg
      • HomezoneMsg
      • ImageBrowserServiceMsg
      • ImageDrawingInterruptedMsg
      • InterrogationResultMsg
      • LcsAppRegisterForMtlrMsg
      • LcsAppResWinMsg
      • LcsAppTransferLocMsg
      • LocationErrMsg
      • LocationNotifInvokeMsg
      • LocationResMsg
      • MCServiceInterfaceMsg
      • MediaManagerMsg
      • MmAocChargingStatusMsg
      • MmCallInfoMsg
      • MmCallNotifyMsg
      • MmCallStatusMsg
        • MmCallDisconnectingMsg
        • MmCallSetupProgressMsg
        • MmMocSetupAcceptMsg
      • MmCurrentCallMeterMsg
      • MmCurrentChargeDataMsg
      • MocSetupAcceptMsg
      • MocSetupRejectIndMsg
      • MptyHoldRejectedMsg
      • MptyOnHoldMsg
      • MtcArrivedMsg
      • MtcReadyMsg
      • NextSocketTestMsg
      • NwDiscStartIndMsg
      • ObexAppMsg
      • OmMultiSlotIndMsg
      • OnDataRcvdMsg
      • OpenPbWinMsg
      • PasswordInquiryMsg
      • PasswordReceivedMsg
      • PasswordRejectedMsg
      • PbAlphaTagRequestMsg
      • PbEntryRequestMsg
      • PbSizeRequestMsg
      • PlmnScanFinishedMsg
      • PowerModeIndMsg
      • PropertyTriggerMsg
      • ProviderUpdateMsg
      • RatChangeModeChangedMsg
      • RatStateMsg
      • RedialSetupMsg
      • RedialStartedMsg
      • RedialStatusMsg
      • RedialStoppedMsg
      • RedialSuccessMsg
      • RegistrationAllowedMsg
      • RegistrationChangeMsg
      • RegistrationSuccessMsg
      • RegNotifyMsg
      • RemotePartyActionMsg
      • SaveEntryInPhonebookMsg
      • SendRequestMsg
      • SendSmsMsg
      • ServiceThreadTerminateMsg
      • SetupDataConnMsg
      • SharedTimerMsg
      • ShutdownRequestMsg
      • SignalQualityLevelMsg
      • SignalStrengthLevelMsg
      • SimBrowserTermResMsg
      • SimCallSetupMsg
      • SimCallSetupRejectedMsg
      • SimDisplayTextMsg
      • SimEndTransactionMsg
      • SimGetInkeyMsg
      • SimGetInputMsg
      • SimLaunchBrowserPromptReqMsg
      • SimLaunchBrowserReqMsg
      • SimMenuItemSelectionFailedMsg
      • SimPlayToneMsg
      • SimRefreshMsg
      • SimRefreshResetMsg
      • SimResetConfirmationMsg
      • SimResetDoneMsg
      • SimSelectItemMsg
      • SimSetupIdleModeTextMsg
      • SimSetupMenuMsg
      • SimSmsSentMsg
      • SimSsSentMsg
      • SimTkLanguageNotificationMsg
      • SimTkProfileGetCnfMsg
      • SimTkProfileSetCnfMsg
      • SimTkProfileSetRejMsg
      • SimTkRefreshStartMsg
      • SimTkRunAtCmdInfoIndMsg
      • SimTkSendDtmfEndIndMsg
      • SimTkSendDtmfIndMsg
      • SimTkSetupEventMsg
      • SkipSocketTestMsg
      • SmsMessageWaitingChangedMsg
      • SmsNewMessageMsg
      • SmsNewSocketDataMsg
      • SmsNewStatusReportMsg
      • SmsPortDataRecvMsg
      • SmsPrefStorageMediaChangedMsg
      • SmsSendConfirmMsg
      • SmsSendRejectMsg
      • SmsServiceDocumentMsg
      • SmsServiceMsg
      • SmsSpaceAvailableMsg
      • SmsSpaceExceededMsg
      • SocketControlMsg
      • SoundBrowserServiceMsg
      • SsDataReceivedMsg
      • SsEndMsg
      • SsErrIndicationMsg
      • SsFacilityRejectedMsg
      • SsInfoMsg
      • SsMessage
        • CallBarredMsg
        • CallBarringActivatedMsg
        • CallBarringDeactivatedMsg
        • CallBarringPasswordChangedMsg
        • CallBarringStatusMsg
        • CallForwardingActivatedMsg
        • CallForwardingActiveMsg
        • CallForwardingDeactivatedMsg
        • CallForwardingErasedMsg
        • CallForwardingRegisteredMsg
        • CallForwardingStatusMsg
        • CallHeldMsg
        • CallIsWaitingMsg
        • CallRetrievedMsg
        • CallWaitingActivatedMsg
        • CallWaitingDeactivatedMsg
        • CallWaitingStatusMsg
        • ClipStatusMsg
        • ClirNotSurpressedMsg
        • ClirStatusMsg
        • CnapInfoReceivedMsg
        • CnapStatusMsg
        • ColpStatusMsg
        • ColrStatusMsg
        • CugCallMsg
        • EctActiveMsg
        • EctAlertingMsg
        • EmlppRegisteredMsg
        • EmlppStatusMsg
        • ForwardedCallIncomingMsg
        • GetPasswordMsg
        • HlrDataCorruptedMsg
        • IncomingCallForwardedMsg
        • MultiPartyCallInvokedMsg
        • NetworkSsErrorMsg
        • NetworkSsRejectedMsg
        • OutgoingCallForwardedMsg
        • SsErrorMsg
        • SsRequestAcceptedMsg
        • SsRequestRejectedMsg
        • SsRequestSentMsg
        • StackSsRejectedMsg
        • UssdDataMsg
        • UssdEndMsg
        • UssdNotifyMsg
        • UssdRequestMsg
        • UssdRequestResentMsg
        • UusErasedMsg
        • UusNotificationMsg
        • UusQueryRejectedMsg
        • UusRegisteredMsg
        • UusStatusMsg
      • SsNotificationMsg
      • SsRejectedMsg
      • SsSuccessMsg
      • StartSocketTestMsg
      • StopSocketTestMsg
      • SvgHyperlinkSelectMsg
      • SvgStatusMsg
      • SyncProgressMsg
      • TermRspCnfMsg
      • ThreadletNotificationMsg
      • TimerTimeoutMsg
      • TransportNotificationMsg
      • UibNotifyMsg
      • UibRegisterMsg
      • UibUpdateMsg
      • UpdateItemMsg
      • UssdAnswerMsg
      • UssDataReceivedMsg
      • UssdIndicationMsg
      • UssdResentMsg
      • UtcStatusMessage
      • VrErrorMsg
      • VrPlaybackFinishedMsg
      • VrPromptMsg
      • VrRecognitionAbortedMsg
      • VrRecognitionFailedMsg
      • VrRecognitionStoppedMsg
      • VrResultMsg
      • VrTrainingAbortedMsg
      • VrTrainingFailedMsg
      • VrTrainingResultMsg
      • VrWarningMsg
    • ControlMsg
      • FocusNextControlMsg
      • FocusPreviousControlMsg
      • GetFocusMsg
      • JumpToRowMsg
      • LoseFocusMsg
      • SelectionChangedMsg
    • DataConnInfoMsg
    • DataConnProfileInfoMsg
    • DataControlBootMsg
    • DataControlBootProgressMsg
    • DataControlEndBootMsg
    • DataControlModificationMsg
    • DataControlPhonebookStateMsg
    • DataControlStartBootMsg
    • DisplayInfoMsg
    • DrmWapPushMsg
    • ExternalPdpContextInfoMsg
    • ExternalTimeoutMsg
    • FatFsUsbMassStorageReleaseMsg
    • FatFsUsbMassStorageRequestMsg
    • FeatureChangedMsg
    • FlipMsg
    • FromStackMsg
      • BtAvrcpNotificationMessage
      • BtAvrcpOperationServiceMessage
      • BtHfNotificationMessage
      • BtHsNotificationMessage
      • BtObexClientNotificationMessage
      • BtObexServerNotificationMessage
    • FtpConnectMessage
    • FtpDisconnectMessage
    • FtpErrorMessage
    • FtpRequestMessage
    • FtpServiceMessage
    • FtpTransferMessage
    • GprsAttachStatusMsg
    • GprsStatusMsg
    • HttpConnectMessage
    • HttpDisconnectMessage
    • HttpErrorMessage
    • HttpRequestMessage
    • HttpServiceMessage
    • ImageBrowserDeleteImageMsg
    • ImageBrowserRenameImageMsg
    • ImageDecodingProgressMsg
    • ImageEncodingProgressMsg
    • IndicatorBarUpdateMsg
    • InputCharMsg
    • InvalidateMsg
    • ItemPropertiesChangedMsg
    • ItemRendererPropertiesChangedMsg
    • KeyAutoRepeatMsg
    • KeyDownMsg
    • KeyUpMsg
    • LanguageChangedMsg
    • LedNotificationMsg
    • LockedKeyDownMsg
    • LockedKeyMsg
    • LongKeyPressMsg
    • LsaIdentityMsg
    • MinuteTickMsg
    • MmCallAcceptMsg
    • MmCallReleaseMsg
    • MptyCallReleaseMsg
    • NetworkInformationMsg
    • NoMessage
    • ObexAddrMsg
    • ObexMsg
    • ObexTransportMsg
    • ObexTriggerMsg
    • ObexVCardMsg
    • PdpContextActivationStatusMsg
    • PenDownMsg
    • PenUpMsg
    • PhonebookRenumberedMsg
    • PowerOffMsg
    • PowerOnMsg
    • PowerWakeupMsg
    • ProcessMolrMsg
    • ProviderChangedMsg
    • RedrawDisplayMsg
    • RefreshComponentMsg
    • RfsMediaAvailableStatusMsg
    • RfsStorageDeviceRegistrationStatusMsg
    • RtcAlarmReachedMsg
    • RtcDateChangedMsg
    • RtcInfoMsg
    • RtcTimeChangedMsg
    • SiChannelCloseInfoIndMsg
    • SiChannelOpenPromptReqMsg
    • SiChannelReceiveInfoIndMsg
    • SiChannelSendInfoIndMsg
    • SimErrorMsg
    • SimLockStatusMsg
    • SimStateChangedMsg
    • SmsControlIndMsg
    • SsControlIndMsg
    • SvgDecodingFinishedMsg
    • T9AddWordMsg
    • T9EnteredUnknownWordMsg
    • T9MatrixModeKeypressed
    • T9NoWordFoundMsg
    • T9SymbolEntryRequestMsg
    • ThemeChangedMsg
    • TimeZoneMsg
    • ToStackMsg
    • UpdateContextItemMsg
    • UsimPbReadyMsg
    • UsimPbResetedMsg
    • UssdBeginMsg
    • UssdControlIndMsg
    • VeryLongKeyPressMsg
    • ViewfinderErrorMsg
    • Zi8AddWordMsg
    • Zi8EnteredUnknownWordMsg
    • Zi8NoWordFoundMsg
  • MessageHook
  • MessageIdentifier
  • MessageIdentifierContainer
  • MessageIdentifierContainer::MessageIdentifierPair
  • MessageMap< T >
  • MessageReferrer
  • MessageRouter
  • MessageTypeIndicator
  • MetaData
    • ImageMetaData
    • SoundMetaData
  • MetaDataRecord
    • ImageMetaDataRecord
    • SoundMetaDataRecord
  • MexeDescriptor
  • MimeCoder
    • Base64Coder
    • QuotedPrintableCoder
  • MimeCoding
  • MimeTypeTable
  • MimeTypeTable::Partition
  • MimeTypeTableEntry
  • MiscAudioDevice::AvailableHW
  • MiscAudioDevice::PowerStatus
  • MlcNumber
  • MmCallHandler
  • MmCallHdl
  • MmCallInfo
  • MmCellChangeCnts
  • MmCoordParam
  • MmcsParam
  • MmfPlayer::MediaPlayerInstanceData
  • MmiSimClient
  • MmiSimMsg
  • MmiSimMsgArg
  • MmiSimServer
  • MolrParams
  • Mp3AudioDevice::StartParam
  • Mp3Header
  • Mp3Param
  • MsapPackedData_s
  • MsgMetaData
  • MsgQueue
  • MultiMediaEditorDocument::TextManager
  • MultiPartData
  • MultipartParser
  • MultiSlotHandler
  • MultiSlotMode
  • MutexObtainer
    • SerialSocketDataLock
    • SocketDataLock
  • NameIndicator
  • NeighbourCell
  • NeighbourCellList
  • NetAdapter::EventArgs
    • NetAdapter::DataReceivedEventArgs
    • NetAdapter::DataSentEventArgs
  • NetworkHandler
  • NiSharedPtr< X >
  • NmeaUartSettings
  • NodeFileHandler
  • NonCloneable
    • AppMutex
    • AudioError
    • DrmInfo
    • ExternalCommunicationHandler
      • SignalHandler
    • HeapObject< T >
    • Mutex
    • NetAdapter
      • ClientNetAdapter
        • TcpNetAdapter
        • UdpNetAdapter
    • NetAdapterHandler
    • ObexBuffer::Factory
    • ObexProtocol
      • ObexLayer
        • BtObexImpl
        • IrdaObexImpl
        • StreamObexImpl
    • Semaphore
    • Semaphore
    • SimpleMap< TKey, TValue >
    • SimpleMutex
    • SimpleSemaphore
    • SimpleSemaphore
    • Socket
      • InetSocket
        • TcpSocketBase
          • TcpServerSocket
            • FtpDataServerSocket
            • FtpServerSocket
            • HttpServerSocket
            • TcpServerTestSocket
          • TcpSocket
            • FtpDataSocket
            • FtpSocket
            • HttpSocket
            • RegTcpSocket
            • TcpNetAdapter
            • TcpTestSocket
        • UdpSocket
          • LcsSocket
          • UdpNetAdapter
          • UdpTestSocket
      • SerialSocket
        • SerialClientSocket
        • SerialServerSocket
      • SerialTerminalSocket
    • StateMachine
      • DataConn
        • PppDataConn
          • CsdDataConn
        • PsdDataConn
  • NonCopyable
    • AudioDeviceBase
      • AudioPlayer
        • DwdPlayer
        • MmfPlayer
      • AudioVibratorDevice
      • SimpleAudioDevice
        • RadioAudioDevice
        • SpeechSimpleAudioDevice
  • NotificationTable
  • NotificationTableEntry
  • NotifySsArg
  • NumberPrompt
  • NvRamBlockInfo
  • NvRamStorage
  • ObexAbstractPort
    • ObexClientPort
    • ObexServerPort
  • ObexApp
  • ObexBuffer
  • ObexBuffer::Reader
  • ObexBuffer::Writer
  • ObexChannel
  • ObexEventHandler
    • ObexClientDispatcher
      • ObexClient
        • ObexClientOppImpl
    • ObexServerDispatcher
      • ObexServer
        • ObexDataServer
          • ObexFtpDataServer
        • ObexServerOppImpl
  • ObexFtpServer
    • RfsObexFtpServer
  • ObexHeaderBuilder
  • ObexHeaderList::ConstIterator
  • ObexMngr
  • ObexObject
  • ObexOperationId
  • ObexOppClient
    • ObexOppBinDataPushClient
  • ObexOppClientOperation
    • ObexOppClientPull
    • ObexOppClientPush
  • ObexOppServer
    • ObexOppDataSinkPushServer
  • ObexResult
  • ObexServerMngr
  • ObexServerVisitor
  • ObexTransportSet
  • ObexTransportSet::Iterator
  • ObexTransportWin
  • ObexUrlStrParser
  • ObjectDataConverter
  • ObjectObtainer
    • EditorDocumentObtainer
    • ImageObtainer
    • MediaObtainer
    • SoundObtainer
  • ObservableObject
    • AbstractTransport
      • BtTransport
      • IrdaTransport
      • UsbTransport
    • Indicator
      • IconIndicator
      • IconTextIndicator
      • TextIndicator
        • CenteredTextIndicator
      • ValueIndicator
        • IconValueIndicator
    • Provider
      • AbstractDelegationProvider
        • AppendProvider
          • UibInboxProvider
        • FilterProvider
          • DistinctProvider
          • DualFilterProvider
          • PbNameFilterProvider
        • FindProvider
          • Find2Provider
        • MergeProvider
          • PbMergeProvider
          • PhoneNumberMergeProvider
        • PbDetailProvider
          • PbNumberFilterProvider
        • PbNameNumberProvider
        • PbSimProvider
        • SmsBasicProvider
        • SmsFolderProvider
        • SortProvider
          • BubbleSortProvider
          • QuickSortProvider
            • CachingSortProvider
            • ChineseQuickSortProvider
            • PbSortedProvider
      • BtDeviceListProvider
      • CountryProvider
      • DataConnProvider
        • CsdDataConnProvider
        • PsdDataConnProvider
        • SerDataConnProvider
      • GroupProvider
      • JoinProvider
      • LanguageProvider
      • PlmnProvider
      • SettingsProvider
      • SmsTemplateProvider
      • ThreadSafeProvider
        • AuxProvider
        • CalendarProvider
        • CbmiProvider
        • CbmiRangeProvider
        • ChvProvider
        • CmiProvider
        • CphsAuxProvider
        • CphsServPflProvider
        • EccProvider
        • LockProvider
        • MbiProvider
        • PbBaseProvider
        • PbRecordProvider
          • PbNameProvider
          • PbNumberProvider
        • PrefExtLangProvider
        • PrefLangProvider
        • PrefPlmnProvider
        • SimTkMainMenuProvider
        • SmsCountProvider
        • SmsMsgWaitingProvider
        • SmsParamProvider
        • SmsProvider
          • SmsClass0Provider
          • SmsReadProvider
          • SmsSentProvider
          • SmsUnreadProvider
          • SmsUnsentProvider
        • SstProvider
        • StatusProvider
  • Observer
    • AbstractDelegationProvider
    • AtlWindow
    • IndicatorBar
    • IndicatorPaneObject
    • ObexAbstractTransport
      • BtObexTransport
      • IrdaObexTransport
      • StreamObexTransport
        • UsbObexTransport
    • ProviderProxyContainer
    • ProviderProxyItem
    • UibInboxTest
    • UibPerformanceTest
  • ObtainableObject
    • EditorDocument
    • Image
      • BmpImage
      • EmsImage
      • GifImage
      • JpegImage
      • NativeImage
        • PredefinedEmsImage
      • PngImage
      • SvgImage
      • WbmpImage
    • Media
    • ObexAbstractPort::AddressEvent
    • ObexAbstractPort::CompleteEvent
    • Sound
      • Melody
        • AmrSound
        • IMelody
        • MidiSound
        • SmafSound
      • PreparedSound
        • PredefinedEmsSound
  • OplEntry
  • OptionalConfigBase
    • OptionalConfig
  • Os
  • OutputStream
    • BufferedOutputStream
    • DebugOutputStream
    • FileOutputStream
    • TraceOutputStream
  • PackedTimePeriod
  • PagingMap
  • PagingMapEntry
  • Palette
  • PaneObject
    • IndicatorBarPaneObject
    • IndicatorPaneObject
  • ParameterIndicator
  • PasswordReceivedArg
  • Path
  • Pathname
  • Pathname::Iterator
  • Pathname::ReverseIterator
  • PathProfile
  • PathProfile::Persist
  • PbAbstractWin
    • ProvListBoxWin
      • ProvColListBoxWin
        • PbBaseWin
          • PbSelectNumberWin
          • PhonebookWin
            • AdvPbWin
            • BasicPbWin
      • ProvDetailListBoxWin
        • PbDetails
          • PbAdvDetails
  • PbAdvAddEditEntry
  • PbDataHandler
    • PbAdvDataHandler
  • PbNumberRecord::Persist
  • PbPhoneNumberPrompt
  • PbProvListBox
    • PbDetailListBox
    • PbProvColListBox
  • PbProvListBoxModel
    • PbDetailListBoxModel
    • PbProvColListBoxModel
  • PbRecord::Persist
  • PbRecordHandler
    • PbFfsNameHandler
    • PbFfsNumberHandler
    • PbNameHandler
    • PbNumberHandler
    • PbNvRamNameHandler
    • PbNvRamNumberHandler
  • PbSelectGroup
  • PbSelectNoType
  • PbSynchronizer
    • PbLazySynchronizer
      • PbManualSynchronizer
  • PcmParam
  • PdpContext::ActivationStatus
  • PdpContext::Address
  • PdpContext::Authentication
  • PdpContext::PacketFilter
  • PdpContext::PacketFilter::AddressAndMask
  • PdpContext::QualityOfService
  • PdpContextControl
    • PsdDataConn
  • PdpContextManager
  • PdpContextManager::AttachStatus
  • PdpContextManager::DataCounters
  • PdpContextManagerControl
  • PdpContextSignalProcessor
  • Pen
  • PersistDataConnProfile
  • PhonebookApp
    • AdvPbApp
  • PhoneBookInfo
  • PhoneNumber
  • PhoneNumber::Persist
  • Plmn
  • PlmnHandler
  • PngDecoder
  • PnnEntry
  • Point
  • PowerHandler
  • PppCallBackData
    • PppSetupCallBackData
  • ProactiveCauseMapper
  • PropertyDescriptor
    • ListPropertyDescriptor
      • ValueMappingPropertyDescriptor< T_Container >
  • PropertyEditorFactory
  • Protector
  • ProtocolIdentifier
  • Provider::Modification
  • ProviderListener
    • DelegationProviderListener
    • JoinProviderListener
    • PbProviderListener
  • PsdDataConnProfile::Bit
  • PsdDataConnProfile::Persist
  • PsLociData
  • Puct
  • RadioAudioDevice::StationInfo
  • RamBlockData
  • RamFile
  • RamFileInfo
  • RamFileNode
  • RamFileObj
  • RamFileSystem
  • RamHandler
  • RamStorageMapper
  • Rdn
  • RealTimeClock::DateAndTime
  • Record
    • BtHfRecord
    • CalendarRecord
    • FmRadioSettingsRecord
    • FmRadioStationsRecord
    • PbNextFreeIdRecord
    • PbNumberRecord
    • PbRecord
    • SmsSettingsRecord
    • ToDoRecord
    • UibSettingsRecord
  • RecordHandler
  • RecordSettings
  • Rect
  • ReferableObject
    • AudioActiveReference
    • AudioReference
      • CustomRingerAudioReference
        • CustomSmafPhraseAudioReference
      • CustomToneAudioReference
      • MapiAudioReference
      • PresetAudioReference
      • StreamAudioReference
        • MP3AudioReference
    • BtOperationBase
      • BtOperationSelectDevice
      • BtOperationSelectDeviceAndPerformServiceVerify
        • BtObexClientAddrResultNotifier
    • ObexAddress
      • ObexClientAddr
        • BtObexClientAddr
        • IrdaObexClientAddr
      • ObexServerAddr
        • BtObexServerAddr
        • IrdaObexServerAddr
        • UsbObexServerAddr
    • ObexObjectData
  • ReferenceLocation
  • ReferenceTime
  • RegApp
  • RegAppCommon
  • RegAppFirstWin
  • RegAppWin
  • RegDeletionBufferEntry
  • RegDirtyFile
  • RegEncoderDecoder
  • RegEncoderDecoder::IteratorObjResult
  • RegEncoderDecoder::Mobile2PCMsg
  • RegEncoderDecoder::Mobile2PCMsg::msg
  • RegEncoderDecoder::Payload
  • RegEncoderDecoder::PC2MobileMsg
  • RegEncoderDecoder::PC2MobileMsg::msg
  • RegEncoderDecoder::RegIteratorNodeType
  • RegEncoderDecoder::Response
  • RegEncoderDecoder::SetUpMsg
  • RegEncoderDecoder::UriAndPayload
  • RegFileHeader
  • Registry
  • RegistryInterface
  • RegIterator
  • RegIterator::InteriorMetaData
  • RegIterator::LeafMetaData
  • RegMemoryBuffer
  • RegMemoryPool
  • RegNodeBuffer
  • RegNodeFileHeader
  • RegNodeRecord
  • RegObjectData
  • RegUriMapFile
  • RenameFileDialog
  • ResourceID
  • ResourceManager
  • ResultWinBase
    • LocationResultWin
    • SatteliteInfoWin
  • RingerAudioDevice::RingerToneInfo
  • RingerAudioDevice::StartParam
  • RomDataRes
  • RootFileSystem
  • RrcParam
  • RrcProcessState
  • RrParam
  • RtcSignalProcessor
  • RtStreamingBuffer
  • RtStreamingConn
    • AtiAudioPlayerRtStreamingConn
  • RtStreamingEndPoint
    • RtStreamingSink
      • AtiAudioPlayerRtStreamingSink
    • RtStreamingSource
      • DataSourceRtStreamingSource
  • RtStreamingEndPoint::BufferInfo
  • S_SvgFixPointTrans
  • SaSignalProcessor
  • SatelliteInfo
  • SatteliteGraphWin
  • ScanlineAccessor
  • ScicosCodecIfLib
  • SecLockCode
  • SecLockCommand
  • SecLockDescriptor
  • SecLocks
  • SecLockStates
  • SecMmiConfigData
  • SelectedLineRetriever
  • SelfLocationDialog
  • SemObtainer
    • FocusObtainer
  • SerialIoAdapter
  • SerialIoAdapter::SioErrorDesc
  • SerialIoSet
  • SerialTerminal
  • SerialTerminalListener
    • MmCallSerialTerminalListener
    • SocketSerialTerminalListener
  • ServerAddressWin
  • ServerClient
    • FtpClient
    • HttpClient
  • ServerConfig
    • FtpServerConfig
    • HttpServerConfig
  • ServiceBroker
  • ServiceProviderStruct
  • ServicePtr< T >
  • ServiceThreadStarter::StartParam
  • SharedMemHdl
  • ShortMessageFailureCause
  • ShortMessageStatus
  • ShutDown
  • SiBearerDesc_s
  • SiBearerDescArray
  • SiBearerList_s
  • SiBearerListArray
  • SiDuration_s
  • SigHandler
  • SignalMapTable
  • SignalMapTableEntry
  • SignalMapTableNode
    • ChargerSignalMapTableNode
    • CommonSignalMapTableNode
    • DataCallSignalMapTableNode
    • GltpSignalMapTableNode
    • LcsCommonSignalMapTableNode
    • LcsSignalMapTableNode
    • LedSignalMapTableNode
    • PdpContextSignalMapTableNode
    • RtcSignalMapTableNode
    • SaSignalMapTableNode
    • SmsSocketSignalMapTableNode
  • SignedValue
  • SiIpAddress_s
  • SiIpAddressArray
  • SimAccessor
  • SimAlphaIdentifier
  • SimApdu
  • SimApduData
  • SimAtom< T >
  • SimAtom< TlvAtom >
    • SimItemId
  • SimClutEntry
  • SimData
  • SimDfParameters
  • SimDisplayTextOptions
  • SimEfOrangeParam
  • SimEfParameters
  • SimEfRefresh
  • SimEfRefreshTable
  • SimEventList
  • SimGetInkeyOptions
  • SimGetInputOptions
  • SimHandler
  • SimIconDescription
  • SimIconIdentifier
  • SimIconQualifier
  • SimImage
  • SimImageDescriptor
  • SimInfo
  • SimLaunchBrowserPromptReq_s
  • SimLockStates
  • SimMexeCertificate
  • SimNextActionIdentifier
  • SimPbEntry
  • SimPbEntryCont
  • SimPhoneBookEntry
  • SimpleMap< TKey, TValue >::Iterator
  • SimSelectItemOptions
  • SimServices
  • SimServiceTable
  • SimSetupIdleModeTextOptions
  • SimSetupMenuOptions
  • SimSmsParameter
  • SimSmsParameter::Record
  • SimSubAddress
  • SimTextString
  • SimTkHandler
  • SimTkProfile
  • SimTkTransactionId
  • SingleArgHook< T >
  • SioGlueSignalListener
  • SioGlueWrapper
  • SioGlueWrapper::SioCommId
  • SioGlueWrapper::TermIos
  • SioSocketAdapter
  • SioSocketAdapter::SioSocketCallbacks
  • SiProvFileRef_s
  • SiProvFileRefArray
  • SiText_s
  • SiTextArray
  • SiUrlArray
  • Size
  • Sms
    • SmsCommand
    • SmsDeliver
    • SmsStatusReport
    • SmsSubmit
  • SmsAlert
  • SmsContext
  • SmsFactory
  • SmsHandler
  • SmsIndicationState
  • SmsInfoBox
  • SmsParamRecord
  • SmsrData
  • SmsSendingAnimation
  • SmsSendingConfirmDialog
  • SmsSettingsRecord::Persist
  • SmsSocketListener
  • SmsStatus
  • SmsTextEntry
  • SmsTextParser
  • SmsWStringCache
  • SmsWStringCache::Entry
  • SocketAddr
    • IrSocketAddr
    • L2CapSocketAddr
    • RfcommSocketAddr
  • SocketEventListener
  • SocketPeer
  • SocketTestApp
  • SocketTestApp::menuItems
  • SocketTestMessage
  • SocketTestProgressWin
  • SocketTestResultsWin
  • SocketTestSettingsWin
  • SocketTestT
    • SocketTestT1
    • SocketTestT2
    • SocketTestT3
      • SocketTestT5
      • SocketTestT7
    • SocketTestT4
      • SocketTestT6
      • SocketTestT8
  • SocketTestTests::TestGroupInfo
  • SocketTestWin
  • SoftkeyDesc
  • SoftkeyDescTableEntry
  • SoundBrowserApp
  • SoundBrowserTestWin
  • SoundBrowserWin
  • SsCcbsHandler
  • SsData
  • SsDataReceivedArg
  • SsErrorCode
  • SsGroup
  • SsGroupList
  • SsHandler
  • SsNotification
  • SsNotificationArg
  • SsStatus
  • StackInterface
  • StackMsgArgDestroyTableNode
    • BtAvrcpMessageArgumentsDestroyTableNode
    • BtHfMessageArgumentsDestroyTableNode
    • BtHsMessageArgumentsDestroyTableNode
    • BtObexMessageArgumentsDestroyTableNode
    • CommonStackMsgArgsDestroyTableNode
    • GltpStackMsgArgsDestroyTableNode
    • LcsCommonStackMsgArgsDestroyTableNode
    • LcsStackMsgArgsDestroyTableNode
    • SaStackMsgArgsDestroyTableNode
    • SerialTerminalMsgArgsDestroyTableNode
    • VrStackMsgArgTableDestroyTableNode
  • StackMsgArgMap< T >
  • StackMsgArgument
    • AbortResArg
    • AccessoryIndArg
    • AocIndArg
    • AtAccessoryNotificationIndArg
    • AtAccessoryRegisterCnfArg
    • AtAccessoryRegisterReqArg
    • AtAlphaTagCnfArg
    • AtAlphaTagReqArg
    • AtGenericCmdIndArg
    • AtGenericCmdReqArg
    • AtPbInfoIndArg
    • AtPbListCnfArg
    • AtPbListReqArg
    • AtPbSelectCnfArg
    • AtPbSelectReqArg
    • AttachAllowedIndArg
    • AttachCnfArg
    • AttachRejArg
    • AttachReqArg
    • AutoCallRestrictIndArg
    • BandSelectionIndArg
    • BandSelectionReqArg
    • BdnIndArg
    • BdnReqArg
    • BootDispatchingArg
    • BrowserRegisterReqArg
    • BrowserTermEventArg
    • BtAvrcpNmaConnect
    • BtAvrcpNmaDisconnect
    • BtAvrcpNmaPanelPassThrough
    • BtAvrcpNmaRawFrame
    • BtHfCmaAtChldOneCommandReceived
    • BtHfCmaAudioAsynchronous
    • BtHfCmaCheckPendingAudioCallback
    • BtHfCmaMOC
    • BtHfCmaMTC
    • BtHfCmaPhoneNumberRequired
    • BtHfNmaAudioConnectionLost
    • BtHfNmaCallEvent
    • BtHfNmaConnect
    • BtHfNmaDisconnect
    • BtHfNmaLowPowerModeNotPossible
    • BtHfNmaMicrophoneGain
    • BtHfNmaSpeakerGain
    • BtHfNmaTransferAudioToAccessory
    • BtHfNmaTransferAudioToPhone
    • BtHsCmaAudioAsynchronous
    • BtHsCmaAudioTransferOutOfCall
    • BtHsCmaCheckPendingAudioCallback
    • BtHsCmaEnterLowPowerMode
    • BtHsCmaHangUp
    • BtHsNmaAudioConnectionLost
    • BtHsNmaCallEvent
    • BtHsNmaConnect
    • BtHsNmaDisconnect
    • BtHsNmaLowPowerModeNotPossible
    • BtHsNmaMicrophoneGain
    • BtHsNmaSpeakerGain
    • BtHsNmaTransferAudioToAccessory
    • BtHsNmaTransferAudioToPhone
    • BtObexClientNmaDataBufferIndication
    • BtObexClientNmaDataInidication
    • BtObexClientNmaHeaderIndication
    • BtObexClientNmaHeaderSent
    • BtObexClientNmaTransportDisconnect
    • BtObexServerNmaAbort
    • BtObexServerNmaConnect
    • BtObexServerNmaDataBufferIndication
    • BtObexServerNmaDataInidication
    • BtObexServerNmaDisconnect
    • BtObexServerNmaGet
    • BtObexServerNmaHeaderIndication
    • BtObexServerNmaHeaderSent
    • BtObexServerNmaPut
    • BtObexServerNmaSetPath
    • BtObexServerNmaTransportDisconnect
    • CallControlSetupIndArg
    • CallControlSsIndArg
    • CallControlUssdIndArg
    • CallDeflectionIndArg
    • CallDeflectSsReqArg
    • CallDiscIndArg
    • CallDiscReqArg
    • CallHoldCnfArg
    • CallHoldRejArg
    • CallIndArg
    • CallIndCallControlInfoArg
    • CallProgressIndArg
    • CallRelatedSsCnfArg
    • CallRelatedSsRejArg
    • CallRelatedSsReqArg
    • CallRelCnfArg
    • CallRelIndArg
    • CallSetupBySimtTkReqArg
    • CbsLimitIndArg
    • CbsNewDataIndArg
    • CbsNewDataRejArg
    • CbsStartCnfArg
    • CbsStartRejArg
    • CbsStartReqArg
    • CbsStopCnfArg
    • CbsStopRejArg
    • CbsStopReqArg
    • CellInfoIndArg
    • CfuDataIndArg
    • ChargeIndArg
    • ChargeReqArg
    • ChargeUnitsIndArg
    • ChargeUnitsReqArg
    • Chv1DisableIndArg
    • Chv1DisableReqArg
    • Chv1EnableIndArg
    • Chv1EnableReqArg
    • ChvChangeIndArg
    • ChvChangeReqArg
    • ChvRefreshIndArg
    • ChvUnblockIndArg
    • ChvUnblockReqArg
    • ChvVerifyIndArg
    • ChvVerifyReqArg
    • ClearBlackListCnfArg
    • ClearBlacklistReqArg
    • ClientDeregistrationArg
    • ClientRegistrationArg
    • ConnectionIndArg
    • ControlHwDataOnlyArg
    • CphsCfufReadIndArg
    • CphsCfufReadReqArg
    • CphsCfufUpdIndArg
    • CphsCfufUpdReqArg
    • CphsCspReadIndArg
    • CphsCspReadReqArg
    • CphsCspUpdIndArg
    • CphsCspUpdReqArg
    • CphsIstReadIndArg
    • CphsIstReadReqArg
    • CphsOnmReadIndArg
    • CphsOnmReadReqArg
    • CphsOnsReadIndArg
    • CphsOnsReadReqArg
    • CphsVmwfReadIndArg
    • CphsVmwfReadReqArg
    • CphsVmwfUpdIndArg
    • CphsVmwfUpdReqArg
    • CtmInfoIndArg
    • DetachCnfArg
    • DetachReqArg
    • DhChannelChangeStatusEventArg
    • DhChannelChangeStatusResArg
    • DhChannelCloseIndArg
    • DhChannelCloseReqArg
    • DhChannelDataAvailableResArg
    • DhChannelDataAvailEventArg
    • DhChannelOpenCnfArg
    • DhChannelOpenRejArg
    • DhChannelOpenReqArg
    • DhChannelReceiveIndArg
    • DhChannelReceiveReqArg
    • DhChannelSendIndArg
    • DhChannelSendReqArg
    • DiagnosticIndArg
    • DisplayTextReqArg
    • DisplayTextRspArg
    • DtmfBufferClearedIndArg
    • EccListIndArg
    • EctCnfArg
    • EndSimToolkitIndArg
    • EngineeringModeControlRequestArg
    • EngineeringModeControlResponseArg
    • ExtProactiveCmdCnfArg
    • ExtProactiveCmdIndArg
    • ExtProactiveCmdReqArg
    • FdnIndArg
    • FdnReqArg
    • GetInkeyReqArg
    • GetInkeyRspArg
    • GetInputReqArg
    • GetInputRspArg
    • GprsClassIndArg
    • GprsClassReqArg
    • HomezoneIndArg
    • IconDescReadIndArg
    • IconDescReadReqArg
    • IdleScreenAvailEventArg
    • ImageReadIndArg
    • ImageReadReqArg
    • ImeiReadIndArg
    • ImeiReadReqArg
    • LanguageSelectEventArg
    • LanguageSettingIndArg
    • LanguageSettingReqArg
    • LaunchBrowserIndArg
    • LaunchBrowserPromptIndArg
    • LcsMolrResultArg
    • LocationNotifInvokeArg
    • MdhDeregistrationCnfArg
    • MdhDeregistrationReqArg
    • MdhMakeViewCnfArg
    • MdhMakeViewReqArg
    • MdhNewStatusReportIndArg
    • MdhRegistrationCnfArg
    • MdhRegistrationReqArg
    • MdhRemoveViewCnfArg
    • MdhRemoveViewReqArg
    • MdhSetConfigCnfArg
    • MdhSetConfigReqArg
    • MdhSetStorageCnfArg
    • MdhSetStorageReqArg
    • MdhSmsConcRefNumIndArg
    • MdhSmsConcRefNumReqArg
    • MdhSmsDeletionIndArg
    • MdhSmsDeletionReqArg
    • MdhSmsExtendedDataIndArg
    • MdhSmsExtendedDataReqArg
    • MdhSmsInitFinishedIndArg
    • MdhSmsNewMessageIndArg
    • MdhSmsReadIndArg
    • MdhSmsReadReqArg
    • MdhSmsRefreshIndArg
    • MdhSmsReportReadIndArg
    • MdhSmsReportReadReqArg
    • MdhSmsSetWaitingReqArg
    • MdhSmsStatusIndArg
    • MdhSmsStatusReqArg
    • MdhSmsStorageRefreshIndArg
    • MdhSmsTransmitAckArg
    • MdhSmsTransmitIndArg
    • MdhSmsTransmitStartAckArg
    • MdhSmsTransmitStartIndArg
    • MdhSmsTransmitStopIndArg
    • MdhSmsUpdStatusIndArg
    • MdhSmsUpdStatusRefreshIndArg
    • MdhSmsUpdStatusReqArg
    • MdhSmsWaitingIndArg
    • MdhSmsWriteCnfArg
    • MdhSmsWriteReqArg
    • MeasurementDataArg
    • MenuSelectionRejArg
    • MenuSelectionReqArg
    • MnInformationIndArg
    • MnNetworkSearchModeReqArg
    • MnTriggerReqArg
    • MocAlertIndArg
    • MocSetupAccArg
    • MocSetupCnfArg
    • MocSetupRejArg
    • MocSetupRejIndArg
    • MocSetupReqArg
    • MptyCnfArg
    • MtcAcceptArg
    • MtcAcceptRejArg
    • MtcAlertReqArg
    • MtcConfIndArg
    • MtcSetupComplArg
    • MtcSetupIndArg
    • NoStackMsgArg
    • NotifyIndArg
    • NRegStateIndArg
    • OmBandStatusCnfArg
    • OmBandStatusReqArg
    • OmControlIndArg
    • OmFactoryResetIndArg
    • OmGetTermProfileCnfArg
    • OmGetTermProfileReqArg
    • OmMultiSlotIndArg
    • OmMultiSlotReqArg
    • OmPowerUpArg
    • OmRatChangeCnfArg
    • OmRatChangeIndArg
    • OmRatChangeReqArg
    • OmSetTermProfileCnfArg
    • OmSetTermProfileRejArg
    • OmSetTermProfileReqArg
    • PbCountIndArg
    • PbCountReqArg
    • PbEntryReadIndArg
    • PbEntryReadReqArg
    • PbEntryUpdIndArg
    • PbEntryUpdReqArg
    • PbInfoReadIndArg
    • PbInfoReadReqArg
    • PinDisableIndArg
    • PinDisableReqArg
    • PinEnableIndArg
    • PinEnableReqArg
    • PlayToneReqArg
    • PlayToneRspArg
    • PlmnInfoReqArg
    • PlmnListAbortArg
    • PlmnListCnfArg
    • PlmnListRejArg
    • PlmnListReqArg
    • PowerDownCnfArg
    • PowerDownIndArg
    • PowerDownReqArg
    • PrefPlmnChangeArg
    • PrefServiceSetReqArg
    • RedialIndArg
    • RediallingDisabledIndArg
    • RedialQueryReqArg
    • RedialRejArg
    • RedialSetupIndArg
    • RedialStatusIndArg
    • RedialStopIndArg
    • RegStateIndArg
    • RejectCallsIndArg
    • SaLocationErrArg
    • SaMolrResultArg
    • SelectItemReqArg
    • SelectItemRspArg
    • SerialTerminalArg
    • SetAutoChargeArg
    • SetChargeUnitsArg
    • SetupEventCnfArg
    • SetupIdleModeTextReqArg
    • SetupIdleModeTextRspArg
    • SetupMenuReqArg
    • SetupMenuRspArg
    • SiChannelCloseInfoIndArg
    • SiChannelCloseInfoResArg
    • SiChannelCloseReqArg
    • SiChannelOpenPromptReqArg
    • SiChannelOpenPromptResArg
    • SiChannelReceiveInfoIndArg
    • SiChannelReceiveInfoResArg
    • SiChannelSendInfoIndArg
    • SiChannelSendInfoResArg
    • SignalStrengthLevelIndArg
    • SimAcmMaxReadIndArg
    • SimAcmMaxReadReqArg
    • SimAcmMaxUpdIndArg
    • SimAcmMaxUpdReqArg
    • SimAcmReadIndArg
    • SimAcmReadReqArg
    • SimAcmUpdIndArg
    • SimAcmUpdReqArg
    • SimBrowserTermResArg
    • SimCbmiReadIndArg
    • SimCbmiReadReqArg
    • SimCbmirReadIndArg
    • SimCbmirReadReqArg
    • SimCbmirUpdIndArg
    • SimCbmirUpdReqArg
    • SimCbmiUpdIndArg
    • SimCbmiUpdReqArg
    • SimCcpReadIndArg
    • SimCcpReadReqArg
    • SimCcpUpdIndArg
    • SimCcpUpdReqArg
    • SimCmiReadIndArg
    • SimCmiReadReqArg
    • SimErrorIndArg
    • SimExtLangReadIndArg
    • SimExtLangReadReqArg
    • SimExtLangUpdIndArg
    • SimExtLangUpdReqArg
    • SimFileInfoIndArg
    • SimFileInfoReqArg
    • SimFullAccessIndArg
    • SimGenericIndArg
    • SimGenericReqArg
    • SimInfoIndArg
    • SimInitIndArg
    • SimLangReadIndArg
    • SimLangReadReqArg
    • SimLangUpdIndArg
    • SimLangUpdReqArg
    • SimLaunchBrowserPromptReqArg
    • SimLaunchBrowserReqArg
    • SimLockStatusIndArg
    • SimMccMncIndArg
    • SimModifyLockIndArg
    • SimModifyLockReqArg
    • SimMruPropertyRefreshIndArg
    • SimMruPropertyUpdCnfArg
    • SimMruPropertyUpdReqArg
    • SimODyn2ReadIndArg
    • SimODyn2ReadReqArg
    • SimODyn2UpdIndArg
    • SimODyn2UpdReqArg
    • SimODynReadIndArg
    • SimODynReadReqArg
    • SimODynUpdIndArg
    • SimODynUpdReqArg
    • SimPuctReadIndArg
    • SimPuctReadReqArg
    • SimPuctUpdIndArg
    • SimPuctUpdReqArg
    • SimRefreshIndArg
    • SimRefreshReqArg
    • SimSmsrReadIndArg
    • SimSmsrReadReqArg
    • SimSmsrUpdIndArg
    • SimSmsrUpdReqArg
    • SimSpnReadIndArg
    • SimSpnReadReqArg
    • SimSstReadIndArg
    • SimSstReadReqArg
    • SimTkCallSetupAccArg
    • SimTkCallSetupIndArg
    • SimTkCallSetupRejArg
    • SimTkInterfaceIndArg
    • SimTkLanguageNotificationIndArg
    • SimTkRefreshCnfIndArg
    • SimTkRefreshCnfReqArg
    • SimTkRefreshNewReqArg
    • SimTkRefreshNewRspArg
    • SimTkRefreshQueryReqArg
    • SimTkRefreshQueryResArg
    • SimTkRefreshReqArg
    • SimTkRefreshResetReqArg
    • SimTkRefreshResetRspArg
    • SimTkRefreshRspArg
    • SimTkResetCnfArg
    • SimTkResetCnfIndArg
    • SimTkResetCnfReqArg
    • SimTkRunAtCmdInfoIndArg
    • SimTkRunAtCmdInfoResArg
    • SimTkSendDtmfCnfArg
    • SimTkSendDtmfEndIndArg
    • SimTkSendDtmfIndArg
    • SimTkSetupEventReqArg
    • SimTkSmsPpIndArg
    • SimTkSmsPpRspArg
    • SimTkSsIndArg
    • SimTkSsRspArg
    • SimTkStopSendDtmfReqArg
    • SmsCapacityAvailableArg
    • SmsCapacityExceededArg
    • SmsConfigIndArg
    • SmsControlIndArg
    • SmsGetMoreMessageStatusIndArg
    • SmsGetMoreMessageStatusReqArg
    • SmsNewMessageIndArg
    • SmsNewStatusReportIndArg
    • SmsSendCnfArg
    • SmsSendRejArg
    • SmsSendReqArg
    • SmsSetMoreMessageReqArg
    • SsBarringIndArg
    • SsBeginAccArg
    • SsCauseIndArg
    • SsCcbsInvokeArg
    • SsCcbsReCallIndArg
    • SsCcbsReCallRequestArg
    • SsCcbsRejectArg
    • SsCcbsResultIndArg
    • SsCcbsStatusIndArg
    • SsClientRejArg
    • SsDataIndArg
    • SsEndIndArg
    • SsErrIndArg
    • SsErrReqArg
    • SsFacilityIndArg
    • SsFacilityRejArg
    • SsForwardingIndArg
    • SsForwcheckIndArg
    • SsGetPasswordIndArg
    • SsGetPasswordRejArg
    • SsGetPasswordRspArg
    • SsInterrogateIndArg
    • SsNotifyIndArg
    • SsPasswordIndArg
    • SsRejArg
    • SsRejReqArg
    • SsRetResIndArg
    • SsSendEndReqArg
    • SsSendReqArg
    • SsUnstructIndArg
    • SsUssdIndArg
    • SsUssdReqArg
    • SsUssdResentIndArg
    • SsUus1IndArg
    • SsUus1QueryIndArg
    • SsUus1QueryRejArg
    • SsUus1QueryReqArg
    • SsUus1ReqArg
    • StartDtmfCnfArg
    • StartDtmfRejArg
    • StartDtmfReqArg
    • StartSignalStrengthListeningArg
    • StopBatteryLoadListeningArg
    • StopDtmfCnfArg
    • StopDtmfReqArg
    • StopSignalStrengthListeningArg
    • TermRspCnfArg
    • TestparamReportArg
    • TestparamReqArg
    • UserActivityEventArg
    • UsimCardTypeReadIndArg
    • UsimCardTypeReadReqArg
    • UsimCsLociReadIndArg
    • UsimCsLociReadReqArg
    • UsimEccReadIndArg
    • UsimEccReadReqArg
    • UsimEstReadIndArg
    • UsimEstReadReqArg
    • UsimFilePropertyIndArg
    • UsimFilePropertyReqArg
    • UsimLangReadIndArg
    • UsimLangReadReqArg
    • UsimLangUpdIndArg
    • UsimLangUpdReqArg
    • UsimPbFillStatusReqArg
    • UsimPbFillStatusResArg
    • UsimPbLocationIndArg
    • UsimPbLocationReqArg
    • UsimPbReadAsyncIndArg
    • UsimPbReadCnfArg
    • UsimPbReadDataAsyncIndArg
    • UsimPbReadDataReqArg
    • UsimPbReadDataResArg
    • UsimPbReadRefAsyncIndArg
    • UsimPbReadRefReqArg
    • UsimPbReadRefResArg
    • UsimPbReadReqArg
    • UsimPbReadResArg
    • UsimPbReadyIndArg
    • UsimPbSelectReqArg
    • UsimPbSelectResArg
    • UsimPbStopReqArg
    • UsimPbStopResArg
    • UsimPbUidRefreshIndArg
    • UsimPbUpdDataReqArg
    • UsimPbUpdDataResArg
    • UsimPbUpdRefReqArg
    • UsimPbUpdRefResArg
    • UsimPbUpdReqArg
    • UsimPbUpdResArg
    • UsimPlmnReadIndArg
    • UsimPlmnReadReqArg
    • UsimPlmnUpdIndArg
    • UsimPlmnUpdReqArg
    • UsimPsLociReadIndArg
    • UsimPsLociReadReqArg
    • UsimReadRecordRejArg
    • UsimReadRejArg
    • UsimSmsParamExtIndArg
    • UsimSmsParamReadIndArg
    • UsimSmsParamReadReqArg
    • UsimSmsParamUpdIndArg
    • UsimSmsParamUpdReqArg
    • UsimUpdCnfArg
    • UsimUpdRejArg
    • UsimUstReadIndArg
    • UsimUstReadReqArg
    • UssdAnswerIndArg
    • VrAbortEngineIndArg
    • VrErrorIndArg
    • VrG2AResultIndArg
    • VrInitCnfArg
    • VrIntrmRecResultIndArg
    • VrLoadTemplateReqArg
    • VrParamReqArg
    • VrPropertyResultIndArg
    • VrRecogResultIndArg
    • VrSayNameIndArg
    • VrStopRecogIndArg
    • VrStoreTemplateReqArg
    • VrTrainResultIndArg
    • VrWarningIndArg
  • StackMsgMapTable
  • StackMsgMapTableEntry
  • StackMsgMapTableNode
    • CommonStackMsgMapTableNode
  • StackMsgProcessor
    • CommonStackMsgProcessor
    • GltpMsgProcessor
    • LcsCommonMsgProcessor
    • LcsMsgProcessor
    • SaMsgProcessor
  • StackTranslator
  • StackWrapper
  • StartUp
  • StartUp::Data
  • StartUp::Table
  • StateStruct
  • StorageDevice
    • FatStorageDeviceImp
    • FlashStorageDeviceImp
    • RamStorageDeviceImp
    • RootStorageDeviceImp
  • StorageDeviceFilter
    • NamePatternStorageDeviceFilter
  • StorageDeviceIterator
    • RootStorageDeviceIterator
  • StorageDeviceVisitor
  • StrData
  • Stream
  • StreamingCallback
  • StreamingInfo
    • StreamingReadInfo
    • StreamingWriteInfo
  • StreamReader
  • StreamWriter
  • String
    • Uri
  • Subaddress
  • SubstitutedText
  • SubSystem
    • AlarmManager
    • AudioPresetStore
    • BtController
      • BtConnectionBasedController
        • BtMultiConnectionController
          • BtObexController
        • BtSingleConnectionController
          • BtBppController
      • BtConnectionlessController
    • BtObexSubSystem
    • DataControl
    • DrmSubsystem
    • GatiManager
    • GenericWorkerTask
    • IrdaObexSubSystem
    • KeyMsgGenerator
    • RegManager
    • SerialSocketSubSystem
    • ServiceThreadStarter
    • SocketSubSystem
    • StackControl
    • UsbSubSystem
  • SubSystemManager
  • SvgIoWrapper
    • SvgFileWrapper
    • SvgGzFileWrapper
    • SvgImageFileWrapper
  • SvgMimeUtil
  • SwitchedRleCompression
  • SwitchedRleCompression::Context
  • SyncMLCTCap
  • SyncMLCTParam
  • SyncMLCTProp
  • SyncMLCTTypeVerCT
  • SyncMLCTValueDef
  • SyncMLDataStoreProps
  • SyncMLDynamicProps
  • SyncMLItemMetaInfo
  • SyncMLManager
  • SysDnsClient
  • SysSocket::FdSet
  • SysSocket::FdSet
  • SysSocket::FdSet
  • SysSocketBase
    • SysSocket
      • SocketData
        • SerialSocketData
    • SysSocket
    • SysSocket
    • SysSocket
    • SysSocket
  • SysSocketBase::LingerSetting
  • System
  • SystemTimer
    • VibratorDevice
  • T9InputConfig
  • T9PackConnector
  • T9ThaiMatrixModeWindowInterface
  • T_PB_CHANGED_FIELD
  • T_PB_CLIENT_FLAGS
  • T_PB_DESCRIPTOR
  • T_PB_FILE_A
  • T_PB_FILE_DESC
  • T_PB_FILE_IN_SLICE
  • T_PB_FILL_STATUS
  • T_PB_GROUP_NUMBER
  • T_PB_GROUPING
  • T_PB_LOC_REPORT
  • T_PB_RECORD
  • T_PB_REF_FILE
  • T_PB_REF_FILE_FILL_STATUS
  • T_PB_REF_FILE_FILL_STATUS_A
  • T_PB_REF_RECORD
  • T_PB_REFERENCE
  • T_PB_STATE
  • T_PB_UNIQUE_FILE
  • T_PB_UNIQUE_FILE_FILL_STATUS
  • T_STK_TRANSACTION_ID
  • tagCPGlyph
  • tagCustFileData
  • tagCustomizationPack
  • tagDataPackHeader
  • tagFilePackData
  • tagFont
  • tagFontFamily
  • tagFontPack
  • TaggedProblemCode
  • tagGlyphData
  • tagLanguage
  • tagLdbData
  • tagT9Pack
  • tagTextPack
  • tagTranslationTable
  • TAlphaIdentifier_s
  • TAlphaIdentifierArray
  • Task
  • TestparamReport
  • TestWriter
  • TextFormat
  • TextIconPairArray
  • TextIconPairArray::TextIconPair
  • TextListLine
  • TextPackConnector
  • ThaiTextRenderer::ThaiFontHint
  • Theme
    • BlackAndWhiteTheme
    • BlueSkyChineseTheme
    • BlueSkyTheme
    • CustomizableTheme
    • DefaultChineseTheme
    • DefaultTheme
    • DefaultTheme
    • FoggyTheme
    • FoggyTheme
    • TestTheme
  • ThemeConfig
  • ThemeManager
  • ThemeViewIterator
  • Thread
    • ApoxiThread
    • EmzAacDecoderThread
    • EmzAacDecoderThread
    • EmzH264DecoderThread
    • EmzH264DecoderThread
    • EmzMp3DecoderThread
    • EmzMp3DecoderThread
    • EmzMpeg4DecoderThread
    • EmzMpeg4DecoderThread
    • EmzMpeg4EncoderThread
    • EmzMpeg4EncoderThread
    • EmzSbcEncoderThread
    • FfsTestThread
    • GenericWorkerTask
    • SerialSocketThread
    • SocketRxThread
  • Ticks
  • TickValue
  • Time
  • Time::Persist
  • TimeFeatureObject
  • TimeSpan
  • TimeZone
  • TimeZoneAndTime
  • Tlv
  • TMsapPackedDataArray
  • ToDoApp
  • ToDoComposeWin
  • ToDoDateDialogWin
  • ToDoListWin
  • ToDoPriorityDialogWin
  • ToDoRecord::Persist
  • ToggleActionGroup
    • RadioButtonGroup
  • ToneAudioDevice::StartParam
  • ToneAudioDevice::UserTone
  • TpduCache
  • TpduConc
  • TpduHeaderInformation
  • TpduNode
  • TpduPhoneNumberPersist
  • Transaction
  • TransferLocationDialog
  • Trap
  • TSiIconID_s
  • TSiUrl_s
  • TtyInterface
  • TypeOfAddress
  • UibAccessorTest
  • UibActionAccessor
  • UibApp
  • UibListBoxModel
  • UibMsgDisplayTest
  • UibNotifyTest
  • UibServiceImpl
  • UibSettingsTest
  • UibSettingsWin
  • UibSortingTest
  • UibTest1
  • UibTest2
  • UmtsCellList
  • UmtsMeasEvalParam
  • UmtsMeasIdParam
  • UmtsNcellParam
  • UmtsNcellParamList
  • UmtsRrcScellParam
  • UnsignedValue
  • Unzipper
  • Uplmn
  • UriMappingTable
  • UsbApp
  • UserActivityListener
  • UserData
  • UserDataHeader
  • UsimEccRecord
  • UsimEst
  • UsimFileProperty
  • UsimLanguage
  • UsimLanguageList
  • UsimPbChangedField
  • UsimPbFillStatus
  • UsimPbGroups
  • UsimPbLocReport
  • UsimPbRefRecord
  • UsimPbRwRecord
  • UsimPlmn
  • UsimPlmnList
  • UsimUst
  • UssDataArg
  • UssdHandler
    • MobileOriginatedUssdHandler
  • UtcTime
  • UusHandler
  • UusText
  • ValidityPeriod
  • ValidityPeriodFormat
  • ValueTextMap
  • ValueTextMap::Table
  • VCard
  • VCardParser
  • VCardWriter
  • Vector< T >
    • WbxmlVector< T >
  • Vector< T >::Iterator
  • VersionInfo
  • VersionInfo::Data
  • VideoCaptureParameters
  • VideoChannel
  • VideoEncoder::VideoEncoderDynParameters
  • View
    • AbstractEditBoxView
      • DateEditBoxView
      • EditBoxView
      • TimeEditBoxView
    • AbstractLineEditorView
      • DateEditorView
    • AbstractListBoxView
      • CheckBoxListView
        • BlueSkyCheckBoxListView
        • DefaultCheckBoxListView
        • DefaultCheckBoxListView
        • TestCheckBoxListView
      • ImageListBoxView
      • MenuListView
      • ProviderListBoxView
      • RadioButtonListView
        • BlueSkyRadioButtonListView
        • DefaultRadioButtonListView
        • DefaultRadioButtonListView
        • TestRadioButtonListView
      • TextListView
        • BlueSkyTextListView
        • DefaultTextListView
        • DefaultTextListView
    • AbstractMultiLineEditorView
    • CalendarGridView
    • CalendarMonthSelectorView
    • CheckBoxControlView
    • CheckBoxView
      • BlueSkyCheckBoxView
      • DefaultCheckBoxView
      • DefaultCheckBoxView
      • TestCheckBoxView
    • ControlFrameView
      • BlueSkyControlFrameView
      • CTControlFrameView
      • DefaultControlFrameView
      • DefaultControlFrameView
      • TestControlFrameView
      • WindowFrameView
        • BlueSkyWindowFrameView
        • CTWindowFrameView
        • DefaultWindowFrameView
        • DefaultWindowFrameView
        • FoggyWindowFrameView
        • TestWindowFrameView
    • DrawableObjectView
      • AnimationView
      • ImageBoxView
      • ItemBoxView
      • ItemLabelView
      • MediaBoxView
      • PositionIndicatorView
        • BlueSkyPositionIndicatorView
        • CTPositionIndicatorView
        • DefaultPositionIndicatorView
        • DefaultPositionIndicatorView
        • FoggyPositionIndicatorView
        • TestPositionIndicatorView
      • ProgressBarView
        • BlueSkyProgressBarView
        • CTProgressBarView
        • DefaultProgressBarView
        • DefaultProgressBarView
      • SelectionBoxView
      • SoftkeyBarView
        • BlueSkySoftkeyBarView
        • DefaultSoftkeyBarView
        • DefaultSoftkeyBarView
        • FoggySoftkeyBarView
        • FoggySoftkeyBarView
        • TestSoftkeyBarView
      • StrokeBoxView
      • T9PinyinBoxView
      • TextBoxView
      • TextLineView
        • AnimatedTextLineView
      • Zi8AlphabetBoxView
      • Zi8SelectionBoxView
      • Zi8StrokeBoxView
    • GridView
    • IndicatorBarView
    • MenuView
    • PanelView
      • CTPanelView
      • DefaultPanelView
      • FoggyPanelView
    • PushButtonView
      • BlueSkyPushButtonView
      • CTPushButtonView
      • DefaultPushButtonView
      • DefaultPushButtonView
      • FoggyPushButtonView
      • TestPushButtonView
    • RadioButtonControlView
    • RadioButtonView
      • BlueSkyRadioButtonView
      • DefaultRadioButtonView
      • DefaultRadioButtonView
      • TestRadioButtonView
    • TabButtonView
      • DefaultTabButtonView
    • TabControlView
      • DefaultTabControlView
  • VmParam
  • VoiceMemoApp
  • VoiceMemoAudioDevice::StartParam
  • VoiceMemoMenuAccessor
  • VoiceMemoRecordWin
  • VoiceMemoWin
  • VrEngineParams
    • DummyVrEngineParams
    • TelecaVrEngineParams
  • VrHandler
  • WapProfile
  • WapProfile::Ipv4E164
  • WapProfile::PxLogicalCharacs
  • WapProfileMgr
  • WbxmlParserRel
  • WbxmlRelHandler
  • WindowHierarchyIterator
  • WindowManager
  • WinRect
  • WStrData
  • WString
    • LcsWString
  • XCallInfoResponseParser
  • XMLParser
    • XmlParserRel
  • Zi8InputConfig
  • Zi8Wrapper
Generated on Wed Jan 25 00:53:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- _ -

  • _ApplicationTracer() : _ApplicationTracer
  • _constants : UdpTestSocket, TcpTestSocket
  • _FunctionTracer() : _FunctionTracer< mask >
  • _NullApplicationTracer() : _NullApplicationTracer
  • _NullFunctionTracer() : _NullFunctionTracer
Generated on Wed Jan 25 00:53:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- j -

  • January : Date
  • Japanese : LanguageManager
  • jar_bin_data : JarBinDataStatusInfo, BinDataInReadStatusInfo
  • jar_file_handle : JarFileStatusInfo, FileInReadStatusInfo
  • jar_file_id : JarFileStatusInfo
  • jar_file_name : JarFileStatusInfo, FileInReadStatusInfo
  • jb : JmpBuf
  • jb_std : JmpBuf
  • Jis : JapaneseTranscoder
  • Join() : CallHdlBase
  • JoinCalls() : CrssHandler
  • JoinProvider() : JoinProvider
  • JoinProviderListener() : JoinProviderListener
  • JoinRule() : JoinRule
  • JointStereoChannelMode : AudioEncoder
  • JpegEncoder() : JpegEncoder
  • JpegEncodingError : Camera
  • JpegEncodingThreadlet() : JpegEncodingThreadlet
  • JpegFormat : CamWin32
  • JpegImage() : JpegImage
  • July : Date
  • JumpBack() : LexAnalyzer
  • JumpToRowMsg() : JumpToRowMsg
  • June : Date
Generated on Wed Jan 25 00:54:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- k -

  • KeepAspectRatio() : DisplaySettings
  • Kernel : InternalTracer
  • Key : KeyMsgGenerator::Key, PhoneNumber
  • key : DtmfStartCnfArg
  • key_code : KeymapTableEntry
  • KEY_RECEIVED_MSG : TestWriter
  • key_tone : KeyToneAudioDevice::StartParam
  • KeyAutoRepeat : Keyboard
  • KeyAutoRepeatMsg() : KeyAutoRepeatMsg
  • KeyAutoRepeatType : InputMapItem
  • Keyboard : OptionalConfigBase, Led
  • KeyboardCategory : AbstractDevice
  • keycode : PagingMapEntry
  • KeyCode2IA5() : Conversion
  • KeyDown : Keyboard
  • KeyDownInputMapItem() : KeyDownInputMapItem
  • KeyDownMsg() : KeyDownMsg
  • KeyDownType : InputMapItem
  • KeyManager : KeyMapping, AtlApplication
  • keymap : ContextTableEntry
  • keymap_type : KeymapTableEntry
  • KeyMapping : KeyMapping, KeySequence
  • KeyMsgGenerator : KeyMsgGenerator, KeyMsgGenerator::Key
  • KeySequence() : KeySequence
  • KeySequenceCandidate : KeySequenceCandidate, KeySequence
  • KeyTone : KeyToneAudioDevice
  • KeyTone1 : KeyToneAudioDevice
  • KeyTone2 : KeyToneAudioDevice
  • KeyTone3 : KeyToneAudioDevice
  • KeyTone4 : KeyToneAudioDevice
  • KeyTone5 : KeyToneAudioDevice
  • KeyToneAudioDevice() : KeyToneAudioDevice
  • KeyUp : Keyboard
  • KeyUpInputMapItem() : KeyUpInputMapItem
  • KeyUpMsg() : KeyUpMsg
  • KeyUpType : InputMapItem
  • Kissing : InformationElement
Generated on Wed Jan 25 00:54:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • l1_data : RrcParam
  • L1Param() : L1Param
  • L2CapSocketAddr() : L2CapSocketAddr
  • l_type : T_PB_FILE_DESC
  • label : HomezoneText
  • LabelProp : GuiObjectFactory
  • lac : CellParam, NeighbourCell, Lai, UmtsRrcScellParam
  • lang_id : Locale::LocaleData
  • lang_name : LanguageCodeTableEntry
  • Language : DataCodingScheme
  • language : tagTextPack
  • LanguageChanged() : System
  • LanguageChangedMsg() : LanguageChangedMsg
  • LanguageDependend : InformationElement
  • LanguageGroup00 : DataCodingScheme
  • LanguageGroup01 : DataCodingScheme
  • LanguageGroup10 : DataCodingScheme
  • LanguageGroup11 : DataCodingScheme
  • LanguageGroupId : DataCodingScheme
  • LanguageProvider() : LanguageProvider
  • LanguageResetAction() : LanguageResetAction
  • LanguageSelectEventArg() : LanguageSelectEventArg
  • LanguageSelectionGroup : DataCodingScheme
  • LanguageSelectionWithinMessageGroup : DataCodingScheme
  • LanguageSettingIndArg() : LanguageSettingIndArg
  • LanguageSettingReqArg() : LanguageSettingReqArg
  • LanguageType : LanguageManager
  • LaNotAllowed : PdpContext
  • Large : InformationElement
  • LargeAnimation : InformationElement
  • LargeIconProp : GuiObjectFactory
  • LargePicture : InformationElement
  • LargeSize : IconState
  • Last : AbstractSmsViewerWin
  • last_used : T_PB_STATE
  • LastChange : PbRecordProvider
  • LastFrameFlag : VideoDecoder
  • LastIndexOf() : WString, String
  • LastPacketInFrameFlag : VideoDecoder
  • LastSectionEntry : Desktop
  • lastused : SmsStatus
  • latency_ms : RtStreamingEndPoint::BufferInfo
  • Latin : LanguageManager
  • Latvian : LanguageManager
  • LaunchBrowser() : SimTkHandler
  • LaunchBrowserIndArg() : LaunchBrowserIndArg
  • LaunchBrowserPromptIndArg() : LaunchBrowserPromptIndArg
  • Layout() : AbstractMultiLineEditor, TextList, AbstractEditBox
  • LayoutClient() : Control
  • Layouter() : Layouter
  • LayouterControlClassType : GuiObjectFactory
  • lc_fw_vers : BtChipBmscr
  • LcsAppRegisterForMtlrMsg() : LcsAppRegisterForMtlrMsg
  • LcsAppResWinMsg() : LcsAppResWinMsg
  • LcsAppTransferLocMsg() : LcsAppTransferLocMsg
  • LcsCommonStackMsgArgsDestroyTableNode : AbortResArg
  • LcsDGpsCorrectionDataMessage : MessageIdentifier
  • LcsEOtdAssistanceDataMessage : MessageIdentifier
  • LcsGpsAlmanacAndOtherDataMessage : MessageIdentifier
  • LcsGpsEphemerisAndClockCorrectionDataMessage : MessageIdentifier
  • LcsMainMenuWin() : LcsMainMenuWin
  • LcsMmiQos() : LcsMmiQos
  • LcsMolrResultArg() : LcsMolrResultArg
  • LcsOptionsMenuWin() : LcsOptionsMenuWin
  • LcsProviderImplBase() : LcsProviderImplBase
  • LcsRepeatTimer() : LcsRepeatTimer
  • LcsSocket() : LcsSocket
  • LcsStackMsgArgsDestroyTableNode : LcsMolrResultArg, LocationNotifInvokeArg
  • LcsTimer() : LcsTimer
  • LcsWString() : LcsWString
  • ldb_id : tagLdbData
  • ldb_size : tagLdbData
  • LeafnodeType : RegIterator
  • LeafType : RegIterator
  • LedCategory : AbstractDevice
  • LedNotificationMsg() : LedNotificationMsg
  • Left : TextFormat, Layouter, GridLayout, Control::NavigationGuidance, AbstractGrid, Indicator, InformationElement
  • LeftAlign : EditorDocument
  • LeftJustifiedWrap : EditorDocument
  • LeftPos : TabButton
  • LeftSection : Desktop
  • LeftSoftkeyProp : GuiObjectFactory
  • LeftToRight : Locale
  • LeftToRightType : BidiManager
  • len_rec : T_PB_FILE_DESC
  • Length : ObexHeader
  • length : Led::Stream, BtObexServiceTable::ObexTarget, ChannelData_s, SiText_s, TAlphaIdentifier_s, TSiUrl_s, UsimEccRecord, SimApduData, EccArray, SmsParamRecord, CiTestParamList, EquivPlmnLists, AckNackParamList, COverIList, BlerTrchInfoList, LsaIdentifier, HomezoneText
  • LengthCoding : Tlv
  • LengthOfAckNackTestParamCntArray : AckNackParamList
  • LengthOfBlerArray : BlerTrchInfoList
  • LengthOfCiTestparamArray : CiTestParamList
  • LengthOfCOverIArray : COverIList
  • LengthOfPlmnArray : EquivPlmnLists
  • LessRule() : LessRule
  • LessType : StandardJoinRule
  • LetterboxScaling : Camera, VideoChannel
  • level : MdhWaitIndicator
  • LevelInfo() : ItemMenu::LevelInfo
  • levels : BidiManager::ParagraphContext
  • LexAnalyzer() : LexAnalyzer
  • LightColor : CTResourcePack
  • LightOrigin : CTResourcePack
  • LightOriginParseType : CTResourcePack
  • LightOriginType : CTResourcePack
  • LightShadow : CTResourcePack
  • Limit() : MessageIdentifierContainer
  • limited_service : RrParam, AsTestparamDatabase, UmtsRrcScellParam
  • line2_voicebox_number : SmsSettingsRecord::Persist
  • line_no : SerialIoAdapter::SioErrorDesc
  • LineAlignment : EditorDocument
  • LineEditor() : LineEditor
  • LineEditorClassType : GuiObjectFactory
  • LineHeightProp : GuiObjectFactory
  • LineState : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • LinkableBase() : LinkableBase
  • LinkAccessory() : AudioPathManager, AudioDeviceManager
  • LinkDown() : PsdDataConn
  • LinkedList() : LinkedList< T >
  • LinkedListBase() : LinkedListBase
  • LinkedResponseUnexpected : TaggedProblemCode
  • LinkUp() : PsdDataConn
  • Listen() : TcpServerSocket, SysSocket, SocketData, SocketPeer, SioSocketAdapter, SerialServerSocket, SerialIoAdapter
  • ListPropertyDescriptor() : ListPropertyDescriptor
  • Lithuanian : LanguageManager
  • LittleEndian16Bit() : LittleEndian16Bit
  • LittleEndian32Bit() : LittleEndian32Bit
  • LlcOrSndcpFailure : PdpContext
  • LlcSapi : PdpContext::ActivationStatus
  • LlcSapi_1 : PdpContext::ActivationStatus
  • LlcSapi_11 : PdpContext::ActivationStatus
  • LlcSapi_3 : PdpContext::ActivationStatus
  • LlcSapi_5 : PdpContext::ActivationStatus
  • LlcSapi_7 : PdpContext::ActivationStatus
  • LlcSapi_9 : PdpContext::ActivationStatus
  • LlcSapi_Invalid : PdpContext::ActivationStatus
  • LlcSapi_NotAssigned : PdpContext::ActivationStatus
  • lm_fw_vers : BtChipBmscr
  • lnd_size : PhoneBookInfo
  • lnd_tagsize : PhoneBookInfo
  • Load() : SvgPlayer, SvgImage, WapProfile
  • LoadAllEntries() : SimPbBaseHandler
  • LoadCameraSettings() : CameraApp
  • LoadContainerEntry() : SimPbBaseHandler
  • LoadFirstTpdu() : CompoundTpduItem
  • LoadingFinishedCondition : SvgPlayer
  • LoadNextTpdu() : CompoundTpduItem
  • LoadProfileName() : WapProfile
  • LoadRecord() : NvRamDataRecordHandler, RecordHandler, DataRecordHandler
  • LoadT9Udb() : T9InputConfig
  • LoadZi8Udb() : Zi8InputConfig
  • local_id : FfsDrmAttrib, ffs_drm_attrib_type
  • Locale : OptionalConfigBase
  • LocalTime : DateTime
  • LocationAreaWideNormal : Cbs::SerialNumber
  • LocationErrMsg() : LocationErrMsg
  • LocationEstimate() : LocationEstimate
  • LocationNotifInvokeArg() : LocationNotifInvokeArg
  • LocationNotifInvokeMsg() : LocationNotifInvokeMsg
  • LocationResMsg() : LocationResMsg
  • LocationResultWin() : LocationResultWin
  • LocationServicesRangeBegin : MessageIdentifier
  • LocationServicesRangeEnd : MessageIdentifier
  • LocationType : CodecDevice
  • LocationVerifWin() : LocationVerifWin
  • Lock : SmsBasicProvider, PbRecordProvider, PbRecordHandler, AbstractLockableDevice, ThreadSafeProvider, Provider, Protector, AbstractDelegationProvider, HandlerData, Registry, ObjectTreeService, MergeProvider, JoinProvider, AppendProvider, RecordHandler, RegEncoderDecoder, SmsSocketListener
  • lock_cause : SecLockStates
  • lock_dcp_sup : SecLockDescriptor
  • lock_order : SecLockDescriptor
  • lock_owner_id : LockTableEntry
  • lock_result : SecLockStates, SecLockDescriptor
  • lock_retrial_count : SecLockDescriptor
  • lock_retrial_method : SecLockDescriptor
  • lock_status : SecLockDescriptor
  • lock_time : SecLockDescriptor
  • lock_type : SecLockDescriptor
  • LockDataStore() : DBService
  • Locked : RegEncoderDecoder
  • locked_object_uri : LockTableEntry
  • LockedKeyDownMsg() : LockedKeyDownMsg
  • LockedKeyMsg() : LockedKeyMsg
  • LockedShiftstate : EditBox
  • LockProvider() : LockProvider
  • locks : SecLockStates
  • LockTable() : LockTable
  • Long : InternalTracer
  • LongDateDM : Date
  • LongDateDMY : Date
  • LongDateWDM : Date
  • LongDateWDMY : Date
  • longFileName : HostIterStatType, FatFindData, dstat
  • LongKeyPress : Keyboard
  • LongKeyPressMsg() : LongKeyPressMsg
  • LongKeyPressType : InputMapItem
  • LongType : ObexHeader
  • LookupAlphaId() : SimPbBaseHandler, LookupAlphaIdExtension, DataHandler
  • LookupAlphaIdExtension() : LookupAlphaIdExtension
  • LookupPlmnEntryIndex() : StackWrapper
  • LookupPlmnName() : SimAuxHandler, DataHandler
  • LookupPlmnRow() : PlmnProvider
  • LoseFocusMsg() : LoseFocusMsg
  • LoudnessAllocation : AudioEncoder
  • Low : ToDoRecord
  • low : CbmiRange
  • LowBattery : Charger
  • lowercase : PagingMapEntry
  • LowerLeft : CTResourcePack
  • LowerRight : CTResourcePack
  • LowQuality : DisplaySettings
  • lsa_id : LsaIdentifier
  • LsaIdentityMsg() : LsaIdentityMsg
  • LV : ThaiTextRenderer
  • LwipPppConnSetupDone : SysSocket
  • LwipPppSetConnInformation() : SysSocket
Generated on Wed Jan 25 00:54:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • m_a : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit
  • m_above_level_y_offset : ThaiTextRenderer::ThaiFontHint
  • m_abstract_view : Component
  • m_accessory : AudioDeviceManager
  • m_accessory_id : AudioAccessoryDetails
  • m_accessory_list : AudioAccessoryStore
  • m_account : DataConnProfile::Persist
  • m_active : VibratorDevice, AudioAccessoryDetails
  • m_active_ref : MmfPlayer::MediaPlayerInstanceData, AudioVibratorDevice
  • m_active_reference : SimpleAudioDevice
  • m_actual_height : CodecDevice::VideoDecoderParameters, CodecDevice::VideoEncoderParameters, CodecDevice::VideoStreamInfo
  • m_actual_name : AudioAccessoryDetails
  • m_actual_width : CodecDevice::VideoDecoderParameters, CodecDevice::VideoEncoderParameters, CodecDevice::VideoStreamInfo
  • m_add_word_to_dict_win : AbstractPredictiveInputBox
  • m_additional_info : RegEncoderDecoder::Response
  • m_addr_msg : ObexAbstractPort::AddressEvent
  • m_address : PdpContext::PacketFilter::AddressAndMask
  • m_addressOut : UdpTestSocket
  • m_adn_maxrecs : SimPbBaseHandler
  • m_adn_tagsize : SimPbBaseHandler
  • m_album : GenericFeatureData::GenericTrackInfo
  • m_alloc_fct : HeapVector::FctTable
  • m_allocations : HeapVector::Stats
  • m_alpha_bit_count : ColorSegmentation
  • m_altitude : ReferenceLocation, LcsPointAltitudeUncertEllipsoid
  • m_anchor : LinkedListBase
  • m_anim : EmsResourceMaps::AnimNode
  • m_apn : PsdDataConnProfile::Persist
  • m_apoxi_tone_id : AudioPreset
  • m_app : SocketTestApp, AbstractAppContext, Feature, AtlApplicationPlugin, CbsFilterList::CbsFilterListEntry, MolrInfo
  • m_app_id : AppFeatureID
  • m_appcntxt_list : AbstractScheduler
  • m_appDescription : HttpApplication
  • m_appId : HttpApplication
  • m_application_categories : CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_application_category : CodecDevice::VideoEncoderParameters
  • m_appList : HttpApplicationSupplier
  • m_appName : HttpApplication
  • m_array_of_supported_codecs : CodecDevice::Properties, CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_arrow_next : CameraViewFinderWin
  • m_arrow_prev : CameraViewFinderWin
  • m_artist : GenericFeatureData::GenericTrackInfo
  • m_audio_codec : CodecDevice::AudioDecoderParameters
  • m_auth_pwd : WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
  • m_auth_set_id : WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
  • m_auth_type : PsdDataConnProfile::Bit
  • m_auth_user_name : WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
  • m_author : GenericFeatureData::GenericTrackInfo
  • m_authProvider : Server
  • m_auto_release : GenericAudioDevice
  • m_azimuth : SatelliteInfo
  • m_b : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit
  • m_background_color : PngDecoder
  • m_background_specified : PngDecoder
  • m_backlog : ServerConfig, Server
  • m_backup_file_id : InteriorNodeRecord
  • m_base : HeapVector::Page
  • m_base_huge : HeapVector::VarPage
  • m_baud_rate : NmeaUartSettings
  • m_bcd_number : PhoneNumber
  • m_bdn_maxrecs : SimPbBaseHandler
  • m_bdn_tagsize : SimPbBaseHandler
  • m_begin : MessageIdentifierContainer::MessageIdentifierPair
  • m_bin_data : NonsharedBinDataDataSource, BinDataDataSource, MmfPlayer::MediaPlayerInstanceData
  • m_bin_data_provided : MmfPlayer::MediaPlayerInstanceData
  • m_bit : PsdDataConnProfile::Persist, DataConnProfile::Persist, CsdDataConnProfile::Persist
  • m_bit_allocation_method : CodecDevice::AudioEncoderParameters
  • m_bit_depth : PngDecoder
  • m_bit_pool : CodecDevice::AudioEncoderParameters
  • m_bit_rate : VideoEncoder::VideoEncoderDynParameters, CodecDevice::VideoEncoderParameters
  • m_bitfield : TpduHeaderInformation
  • m_bitrate : MediaInfo::MediaTrackInfo
  • m_bits : PbNumberRecord::Persist, PbRecord::Persist, HeapVector::BlockPage, BitmapRes, SvgImage
  • m_bkgd_blue : PngDecoder
  • m_bkgd_green : PngDecoder
  • m_bkgd_red : PngDecoder
  • m_block_len : CodecDevice::AudioEncoderParameters
  • m_block_size : BlockData
  • m_blockcounter : HeapVector::BlockPage
  • m_blocksize : HeapVector::Page
  • m_blue_bit_count : ColorSegmentation
  • m_bmps : SmsSendingAnimation
  • m_body : HttpResponse, HttpRequest
  • m_boolean : AbstractDevice::ControlArg
  • m_bottom : Rect
  • m_bound_num : MultiPartData
  • m_bReportSent : SocketTestTests::TestGroupInfo
  • m_brightness_level : Camera
  • m_bTestEnabled : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_buf_size : DataSourceRtStreamingSource
  • m_buffer : NetAdapter::DataReceivedEventArgs, StreamAudioReference, CustomRingerAudioReference, CodecDevice::AudioIOBuffer, OplEntry
  • m_buffer_left : MimeCoder
  • m_buffer_len : CodecDevice::AudioIOBuffer
  • m_buffer_length : MimeCoder
  • m_buffer_ptr : MimeCoder
  • m_buffer_size : StreamAudioReference, CustomRingerAudioReference
  • m_buffers : AtiAudioPlayerRtStreamingSink
  • m_bufsize : WStrData, StrData
  • m_build_date : VersionInfo::Data
  • m_c : LittleEndian32Bit, BigEndian32Bit
  • m_cache_pos : TpduHeaderInformation
  • m_call_type : CsdDataConnProfile::Bit
  • m_cam_win32 : Camera
  • m_camera : CameraCaptureWin
  • m_camera_capture_canceling : CameraCaptureWin
  • m_cancel_editbox_action : PbDetails
  • m_caption_gap : AbstractEditBoxView
  • m_caption_height : AbstractEditBoxView
  • m_caption_width : AbstractEditBoxView
  • m_capture_image_size : Camera
  • m_caret : InputMapper
  • m_case_sensitive : NamePatternFileFilter
  • m_category : EccNetworkElement
  • m_cb_stop : MapiAudioPlayer
  • m_channel : TimeFeatureObject
  • m_channel_mode : CodecDevice::AudioEncoderParameters
  • m_channelVolume : CustomSmafPhraseAudioReference
  • m_char : CharInputMapEntry
  • m_char_ptr : AbstractDevice::ControlArg
  • m_child_key_id : MergeProvider
  • m_chunk_operator : File::FileState
  • m_chunk_size : File::FileState
  • m_client : IncrementalPdcUpdater
  • m_client_discovery_poll_repeat_counter : IrdaObexTransport
  • m_client_id : ClientInfo, ClientId, MolrInfo
  • m_client_name : ClientInfo, ClientName
  • m_clientId : ServerClient, FtpTransfer, FtpDataSocket
  • m_clients : Server
  • m_clienttimer : IrdaObexTransport
  • m_clock_support : CodecDevice::VideoDecoderInfo
  • m_codec_type : MediaInfo::MediaTrackInfo, CodecDevice::AudioStreamInfo
  • m_coding_group : TpduHeaderInformation
  • m_color_count : ColorTable
  • m_color_type : PngDecoder
  • m_column : FindProvider
  • m_columnid : SortProvider
  • m_columninfo : Provider
  • m_combined_device : CodecDevice::Properties
  • m_command_type : AtCommandData, AtCommandMetaInfo
  • m_comment : GenericFeatureData::GenericTrackInfo
  • m_commit_cmi_no : PbBaseProvider
  • m_commit_phonenumber : PbBaseProvider
  • m_commit_string : PbBaseProvider
  • m_compat_setting : AudioAccessoryDetails
  • m_composer : IMelodyData, GenericFeatureData::GenericTrackInfo
  • m_conc_max_no : TpduHeaderInformation
  • m_conc_num : TpduHeaderInformation
  • m_conc_ref_no : TpduHeaderInformation
  • m_conc_seq_no : TpduHeaderInformation
  • m_concateneted_status : TpduHeaderInformation
  • m_confidence : LcsArc, LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse
  • m_confirm_edit_action : PbDetails
  • m_conn_id_free_Slot : HttpWapMgr
  • m_connect_cnf_cb : SioSocketAdapter::SioSocketCallbacks
  • m_connect_ind_cb : SioSocketAdapter::SioSocketCallbacks
  • m_connected : HttpSocket
  • m_connection_list_mutex : BtMultiConnectionController
  • m_cons_offsets : ThaiTextRenderer::ThaiFontHint
  • m_cont : AbstractScheduler
  • m_content : DrmMediaObject
  • m_content_len : MultiPartData, DrmMediaObject
  • m_content_offset : MultiPartData
  • m_content_type : DrmMediaObject
  • m_context : Timer
  • m_context_active : PsdDataConn
  • m_context_defined : PsdDataConn
  • m_context_id : PropertyDescriptor
  • m_contrast_level : Camera
  • m_copyright : GenericFeatureData::GenericTrackInfo
  • m_cphs_infono_maxrecs : SimPbBaseHandler
  • m_cphs_infono_tagsize : SimPbBaseHandler
  • m_cphs_mbox_maxrecs : SimPbBaseHandler
  • m_cphs_mbox_tagsize : SimPbBaseHandler
  • m_CsdDownloadSettings : SocketTestT5
  • m_ct_cap : SyncMLDataStoreProps
  • m_ct_cap_count : SyncMLDataStoreProps
  • m_ct_type : SyncMLCTCap, SyncMLCTTypeVerCT
  • m_cur_buffer_returned : DataSourceRtStreamingSource
  • m_cur_dev_pathname : RootDirectoryIteratorImp
  • m_cur_device : RootDirectoryIteratorImp
  • m_cur_device_id : StorageDeviceIterator
  • m_cur_dir_itor : RootDirectoryIteratorImp
  • m_cur_file_offset : DataSourceRtStreamingSource
  • m_cur_file_pos : File::FileState
  • m_cur_path : DirectoryIterator
  • m_cur_src : DataSourceRtStreamingSource
  • m_current : HeapVector::Stats
  • m_current_calendar_record : CalendarProvider
  • m_current_camera_idx : CameraCaptureWin
  • m_current_virtual_size : HeapVector::HeapTableEntry
  • m_currentState : StateMachine
  • m_d : LittleEndian32Bit, BigEndian32Bit
  • m_da : SimSmsParameter::Record
  • m_data : ToDoRecord, FmRadioStationsRecord, FmRadioSettingsRecord, SmsSettingsRecord, CalendarRecord, BtHfRecord, PbNumberRecord, PbRecord, Glyph, DataPack, BtSddbDeOneByteDescriptionType, BlobPtr, SimPhoneBookEntry, SvgImage, PngImage, PngDecoder, JpegImage, TpduPhoneNumberPersist
  • m_data1 : ResultWinBase, DateTime::Persist
  • m_data2 : ResultWinBase, DateTime::Persist
  • m_data3 : ResultWinBase, DateTime::Persist
  • m_data4 : ResultWinBase
  • m_data_available_ind_cb : SioSocketAdapter::SioSocketCallbacks
  • m_data_bits : NmeaUartSettings
  • m_data_compr : PsdDataConnProfile::Bit
  • m_data_idx : PngDecoder
  • m_data_in_buffer : FtpDataSocket
  • m_data_len : NetAdapter::DataReceivedEventArgs, NetAdapter::DataSentEventArgs
  • m_data_offset : StreamAudioReference
  • m_data_out_buffer : FtpDataSocket
  • m_data_owned : CustomRingerAudioReference
  • m_data_ptr : AtGenericCmdType
  • m_data_rate : CsdDataConnProfile::Bit
  • m_data_sent : ClientNetAdapter
  • m_data_source : DataSourceBinData
  • m_data_type : SyncMLCTValueDef
  • m_dataConnProfileId : ServerConfig
  • m_dataitem : RegEncoderDecoder::Payload
  • m_date_is_valid : CalendarProvider
  • m_datetime : TpduHeaderInformation
  • m_day : DateTime::Persist, Date, Date::Persist, UtcTime
  • m_dbgout_context_fct : HeapVector::FctTable
  • m_dbgout_fct : HeapVector::FctTable
  • m_dc_err : CsdDataConn
  • m_dch_err : CsdDataConn
  • m_dcs : SimSmsParameter::Record, TpduHeaderInformation
  • m_decoder : SvgImage
  • m_def_profile : DataConnProfileStorage::Header
  • m_delay : StreamAudioPlayer
  • m_delete_record : CalendarProvider
  • m_delta : SvgImage
  • m_description : GenericFeatureData::GenericTrackInfo
  • m_descriptor : Property
  • m_detail_listbox : PbDetails
  • m_dev_itor : RootDirectoryIteratorImp
  • m_device : HostFatFsDeviceDescriptor
  • m_device_id : HostFatFsDeviceDescriptor
  • m_device_list_node : BtDeviceList::BtDeviceListBidirectionalIterator
  • m_device_vibrator : AudioDeviceManager
  • m_diacritics_offsets : ThaiTextRenderer::ThaiFontHint
  • m_dir_itor_ptr : RfsObexFtpServer
  • m_dir_pathname : DirectoryIterator
  • m_direction : CodecDevice::Properties
  • m_dirty_flag : RegDirtyFile
  • m_disconnect_ind_cb : SioSocketAdapter::SioSocketCallbacks
  • m_disconnect_on_complete : FtpTransfer
  • m_display_name : SyncMLDataStoreProps, SyncMLCTValueDef
  • m_domain : WapProfile::PxLogicalCharacs
  • m_downlinkPath : AudioAccessoryDetails
  • m_drm_asset : DataSource, DataSink
  • m_duration : KeyUpInputMapEntry, GenericFeatureData::GenericTrackInfo, MediaInfo::MediaTrackInfo
  • m_dwd_handle : DwdDevice
  • m_ecnr_state : AudioDeviceManager
  • m_edit_detail_action : PbDetails
  • m_editbox : PbDetails
  • m_editor : AbstractPredictiveInputBox
  • m_elem : MediaRefLinkable
  • m_elements : EccNetworkArray
  • m_elevation : SatelliteInfo
  • m_email : PbRecord::Persist
  • m_enable_ecnr : AudioAccessoryDetails
  • m_enabled : SimpleAudioDevice
  • m_end : HeapVector::Page, MessageIdentifierContainer::MessageIdentifierPair
  • m_end_block_num : BlockData
  • m_end_huge : HeapVector::VarPage
  • m_endianess : RegEncoderDecoder::SetUpMsg
  • m_error_code : AudioPlayerEvent
  • m_exist_da : SimSmsParameter::Record
  • m_exist_dcs : SimSmsParameter::Record
  • m_exist_name : SimSmsParameter::Record
  • m_exist_protid : SimSmsParameter::Record
  • m_exist_sca : SimSmsParameter::Record
  • m_exist_vp : SimSmsParameter::Record
  • m_exponent : SignedValue, UnsignedValue
  • m_exposure_level : Camera
  • m_ext_height : CodecDevice::VideoStreamInfo
  • m_ext_punc_win : AbstractPredictiveInputBox
  • m_ext_width : CodecDevice::VideoStreamInfo
  • m_extended_data : TpduHeaderInformation
  • m_fct_table : HeapVector::Page
  • m_fdn_maxrecs : SimPbBaseHandler
  • m_fdn_tagsize : SimPbBaseHandler
  • m_feature : FeatureItem
  • m_feature_id : Feature, AppFeatureID
  • m_featureID : FeatureHandle
  • m_field : UsimPbChangedField
  • m_file : FfsDataConnProfileStorage, FileDataSource, FileDataSink, FileBinData, HttpResponse, FtpTransfer
  • m_file_handle : StreamAudioReference
  • m_file_header : RegNodeFileHeader, RegDirtyFile
  • m_file_id : InteriorNodeRecord, Transaction
  • m_File_Sink_Array : CameraCaptureWin
  • m_file_type : RegFileHeader
  • m_filesize : UsimFileProperty, FtpTransfer
  • m_filetype : UsimFileProperty
  • m_fill_semaphore : DataSourceRtStreamingSource
  • m_filter : CbsFilterList::CbsFilterListEntry, StorageDeviceVisitor, StorageDeviceIterator, FileVisitor, DirectoryIterator
  • m_filter_dirs : SoundFileFilter, ImageFileFilter, NamePatternFileFilter
  • m_FindRow : FindProvider
  • m_fix_data : LocationEstimate
  • m_flag : InteriorNodeRecord
  • m_flags : VersionInfo::Data, BitmapRes
  • m_flash : Camera
  • m_flash_stored : TpduHeaderInformation
  • m_flow_control : NmeaUartSettings
  • m_font : AbstractTextRenderer
  • m_format : IMelodyData, StreamAudioReference, CustomRingerAudioReference, SyncMLItemMetaInfo, CodecDevice::AudioDecoderParameters
  • m_frame : ImageMetaDataRecord
  • m_frame_count : EmsResourceMaps::AnimNode
  • m_frame_rate_denominator : VideoEncoder::VideoEncoderDynParameters, CodecDevice::VideoEncoderParameters, CodecDevice::VideoStreamInfo
  • m_frame_rate_numerator : VideoEncoder::VideoEncoderDynParameters, CodecDevice::VideoEncoderParameters, CodecDevice::VideoStreamInfo
  • m_frame_size : AbstractEditBoxView
  • m_frames : SvgImage
  • m_free : DataConnProfileStorage::Header, HeapVector::VarPage, HeapVector::BlockPage
  • m_free_chars : EmsCreator::SpaceInfo
  • m_free_fct : HeapVector::FctTable
  • m_free_id : SyncMLDynamicProps
  • m_free_mem : SyncMLDynamicProps
  • m_frees : HeapVector::Stats
  • m_frequency : RadioAudioDevice::StationInfo
  • m_ftpInTransfer : FtpDataSocket
  • m_ftpOutTransfer : FtpDataSocket
  • m_ftpSocket : FtpTransfer, FtpDataSocket
  • m_genre : GenericFeatureData::GenericTrackInfo
  • m_getstats_fct : HeapVector::FctTable
  • m_glyph_count : GlyphIndexTab
  • m_glyph_tab : GlyphIndexTab
  • m_gps_tow : GpsFixDataInt, ReferenceTime, GpsFixData
  • m_gps_week : GpsFixDataInt, ReferenceTime, GpsFixData
  • m_green_bit_count : ColorSegmentation
  • m_groups : UsimPbGroups
  • m_handle : AudioPlayerEvent
  • m_handler : CalendarProvider, NetAdapter, PbBaseProvider
  • m_has_audio : StreamAudioReference
  • m_has_native_alpha_channel : PngDecoder
  • m_hdop : GpsFixDataInt, GpsFixData
  • m_header : MultiPartData, DrmDcfHeader
  • m_header_compr : PsdDataConnProfile::Bit
  • m_headers : HttpResponse, HttpRequest
  • m_heap_id : HeapVector::HeapTableEntry
  • m_height : ImageMetaDataRecord, BitmapRes, PngDecoder
  • m_high : HeapVector::Page
  • m_horiz_accuracy : LcsMmiQos, LcsQos
  • m_hour : Time::Persist, DateTime::Persist, UtcTime
  • m_http_plugin : HttpWapMgr
  • m_http_wap_plugin : HttpWapMgrPlugin
  • m_httpVersion : HttpRequest
  • m_huge_mem : PngDecoder
  • m_hw_handle : GenericAudioDevice
  • m_icon : TextIconPairArray::TextIconPair
  • m_id : NetAdapter, DataConnProfile::Bit, BtObexSddbServiceObserverImpl, HandlerData, CodecDevice::AudioChannel
  • m_Id : PathProfile::Persist
  • m_idle_timeout : DataConnProfile::Bit
  • m_ignore_management : AudioPreset
  • m_image_size : Camera
  • m_in_buf_max_len : CodecDevice::VideoEncoderInfo
  • m_included_angle : LcsArc
  • m_index : MetaDataRecord
  • m_info_ptr : PngDecoder
  • m_init_fct : HeapVector::FctTable
  • m_initial_size : FileDataSink
  • m_inner_radius : LcsArc
  • m_input_map_control_id : InputMapEntry
  • m_input_map_id : InputMapEntry
  • m_input_sampling_frequency : CodecDevice::AudioEncoderParameters
  • m_Instance : AudioDeviceManager
  • m_instance : VibratorDevice, AudioPresetStore, AudioPlayerStore, AudioAccessoryStore
  • m_int16 : AbstractDevice::ControlArg
  • m_int32 : AbstractDevice::ControlArg
  • m_int8 : AbstractDevice::ControlArg
  • m_int_ref_no : TpduHeaderInformation
  • m_int_time : SatelliteInfo
  • m_interface_address : PppSetupCallBackData
  • m_interior_meta_data : RegEncoderDecoder::IteratorObjResult
  • m_interior_node_record : RegUriMapFile
  • m_interlace_type : PngDecoder
  • m_invoke_id : MtlrInfo, MolrRepeatInfo
  • m_ipGatewayAddr : SocketTestApp::menuItems
  • m_ipv4_address_and_mask : PdpContext::PacketFilter::AddressAndMask
  • m_ipv6_address_and_mask : PdpContext::PacketFilter::AddressAndMask
  • m_is_concateneted : TpduHeaderInformation
  • m_is_exclusive : HandlerData
  • m_is_in_use : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • m_is_interlaced : PngImage
  • m_is_open : NonsharedBinDataDataSource, BinDataDataSource
  • m_is_registered_mutex : BtRequest
  • m_is_text : MimeCoder
  • m_is_transparent : PngDecoder
  • m_is_valid : DrmRightsMapTableEntry
  • m_isfree_fct : HeapVector::FctTable
  • m_ishuge : HeapVector::Page
  • m_iter_nodetype : RegEncoderDecoder::IteratorObjResult
  • m_iterator_obj : RegEncoderDecoder::IteratorObjResult
  • m_iterator_res_obj : RegEncoderDecoder::Payload
  • m_iterator_type : RegEncoderDecoder::IteratorObjResult
  • m_job_id_client : IrConnection
  • m_jpeg_image : CameraCaptureWin
  • m_key_code : KeyUpInputMapEntry, KeyDownInputMapEntry
  • m_label : PropertyDescriptor
  • m_label1 : ResultWinBase
  • m_label2 : ResultWinBase
  • m_label3 : ResultWinBase
  • m_label4 : ResultWinBase
  • m_last_buffer : CodecDevice::AudioIOBuffer
  • m_last_commited_transaction : RegDirtyFile
  • m_last_error : Camera, StorageDevice, File::FileState, DirectoryIterator, PngDecoder
  • m_last_id : DataConnProfileStorage::Header
  • m_last_loc_est : LcsProviderImplBase
  • m_last_unscaled_height_idx : PngImage
  • m_last_unscaled_width_idx : PngImage
  • m_latitude : ReferenceLocation, LcsPoint
  • m_lcs_qos : MolrInfo
  • m_lcs_timer : MtlrInfo
  • m_leaf_meta_data : RegEncoderDecoder::IteratorObjResult
  • m_left : Rect
  • m_left_offset : CodecDevice::VideoStreamInfo
  • m_len : WStrData, StrData
  • m_length : HeapVector::VarPage, BlobPtr, SimPhoneBookEntry, AtGenericCmdType
  • m_length_of_header_length_field : CodecDevice::VideoDecoderParameters
  • m_length_of_length_field : CodecDevice::VideoDecoderParameters
  • m_level : RadioAudioDevice::StationInfo
  • m_line_height : AbstractEditBoxView
  • m_line_length : MimeCoder
  • m_lines : TextListModel
  • m_linger_timeout : DataConnProfile::Bit
  • m_list_phy_port : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_list_port : WapProfile::PxLogicalCharacs
  • m_list_pxauthinfo : WapProfile::PxLogicalCharacs
  • m_list_pxphysical : WapProfile::PxLogicalCharacs
  • m_lnd_maxrecs : SimPbBaseHandler
  • m_lnd_tagsize : SimPbBaseHandler
  • m_lo_chula_y_offset : ThaiTextRenderer::ThaiFontHint
  • m_loc_error : GpsFixDataInt, GpsFixData
  • m_local : PsdDataConnProfile::Persist
  • m_local_id : DrmRightsMapTableEntry
  • m_location : CodecDevice::VideoEncoderInfo, CodecDevice::VideoDecoderInfo
  • m_location_info : UsimPbLocReport
  • m_location_method : MolrInfo
  • m_lock_id : RegEncoderDecoder::PC2MobileMsg::msg, RegAppWin
  • m_locked_by : HandlerData
  • m_lockinfo : RegEncoderDecoder::Payload
  • m_longci : PnnEntry
  • m_longitude : ReferenceLocation, LcsPoint
  • m_longname : PnnEntry
  • m_low : HeapVector::Page
  • m_low_byte : GlyphHeader
  • m_lru_count : RegMemoryBuffer
  • m_lst : LocationEstimate
  • m_mai_tho_toplevel_x_offset : ThaiTextRenderer::ThaiFontHint
  • m_mantissa : SignedValue, UnsignedValue
  • m_map_entry : CharInputMapEntry, KeyUpInputMapEntry, KeyDownInputMapEntry, InputMap
  • m_map_file_header : RegUriMapFile
  • m_mark : SyncMLItemMetaInfo
  • m_mark_delete : MetaDataRecord
  • m_master_mute : AudioDeviceManager
  • m_master_volume : AudioDeviceManager
  • m_max_bit_rate : CodecDevice::VideoDecoderParameters, CodecDevice::VideoCodecCapabilities, CodecDevice::VideoStreamInfo
  • m_max_blob_size : RegEncoderDecoder::SetUpMsg
  • m_max_cache_depth : MergeProvider
  • m_max_conc_ref_no : TpduHeaderInformation
  • m_max_delay : IncrementalPdcUpdater
  • m_max_frame_rate_denominator : CodecDevice::VideoCodecCapabilities
  • m_max_frame_rate_numerator : CodecDevice::VideoCodecCapabilities
  • m_max_guid_size : SyncMLDataStoreProps
  • m_max_height : CodecDevice::VideoCodecCapabilities
  • m_max_id : SyncMLDataStoreProps
  • m_max_mem : SyncMLDataStoreProps
  • m_max_message_size : RegEncoderDecoder::SetUpMsg
  • m_max_progress : MergeProvider
  • m_max_quality_level : CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_max_subunit_id : BtAvrcpSubunitInfoEntry
  • m_max_virtual_size : HeapVector::HeapTableEntry
  • m_max_width : CodecDevice::VideoCodecCapabilities
  • m_maxUsers : ServerConfig, Server
  • m_mbdn_maxrecs : SimPbBaseHandler
  • m_mbdn_tagsize : SimPbBaseHandler
  • m_media_player : MmfPlayer::MediaPlayerInstanceData
  • m_media_type : StreamAudioReference
  • m_memory : HeapVector::VarPage, HeapVector::BlockPage
  • m_merge_key_id : MergeProvider
  • m_merge_needed : MergeProvider
  • m_merge_provider : MergeProvider
  • m_merge_rule : MergeProvider
  • m_merged_rows : MergeProvider
  • m_metering_mode : Camera
  • m_microsec : GpsFixDataInt, GpsFixData
  • m_milli_sec : UtcTime
  • m_mime_to_source_to_players : AudioPlayerStore
  • m_min : UtcTime
  • m_min_bit_rate : CodecDevice::VideoCodecCapabilities
  • m_min_frame_rate_denominator : CodecDevice::VideoCodecCapabilities
  • m_min_frame_rate_numerator : CodecDevice::VideoCodecCapabilities
  • m_min_height : CodecDevice::VideoCodecCapabilities
  • m_min_progress : MergeProvider
  • m_min_quality_level : CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_min_width : CodecDevice::VideoCodecCapabilities
  • m_minute : Time::Persist, DateTime::Persist
  • m_mirrored : ImageBrowserApp
  • m_mlc_number : MlcNumber, MolrInfo
  • m_mode : StreamAudioReference, FtpDataSocket
  • m_molr_timer : LcsProviderImplBase
  • m_molr_type : MolrInfo
  • m_mono_stereo_mode : StreamAudioReference
  • m_month : DateTime::Persist, Date, Date::Persist, UtcTime
  • m_mpghead : Mp3Param
  • m_msg_class : TpduHeaderInformation
  • m_msg_id : RegEncoderDecoder::Mobile2PCMsg
  • m_msg_status : TpduHeaderInformation
  • m_msg_type : TpduHeaderInformation
  • m_msisdn_maxrecs : SimPbBaseHandler
  • m_msisdn_tagsize : SimPbBaseHandler
  • m_mtlr_app : LcsProviderImplBase
  • m_mute : AudioDeviceBase
  • m_N : HeapVector::Page
  • m_name : PbRecord::Persist, DataConnProfile::Persist, HeapVector::HeapTableEntry, IMelodyData, AudioPreset, RegNodeRecord, HeaderData, DrmDcfHeaderData, SimSmsParameter::Record
  • m_name_pattern : NamePatternStorageDeviceFilter, NamePatternFileFilter
  • m_name_recno : PbNumberRecord::Persist
  • m_nCSDid : SocketTestApp
  • m_nCurrentSocket : SocketTestT4
  • m_nDataSize : DownloadSettings
  • m_nDownloadTime : DownloadSettings
  • m_nErrorCode : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nGatewayPort : SocketTestApp::menuItems
  • m_nHeaderSize : UdpTestSocket, TcpTestSocket
  • m_nInternalStatus : SocketTestTests::TestGroupInfo
  • m_nIterationsDone : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nIterationsSuccessfull : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nIterationsTotal : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nlenIn : SocketTestT4
  • m_nMaxTCPPacketSize : SocketTestApp::menuItems
  • m_nMaxTCPSockets : SocketTestApp::menuItems
  • m_nMaxUDPPacketSize : SocketTestApp::menuItems
  • m_nMaxUDPSockets : SocketTestApp::menuItems
  • m_nMessageBody : TcpTestSocket
  • m_nMessagePos : TcpTestSocket
  • m_nMessageSize : UdpTestSocket, TcpTestSocket
  • m_nNrOfSubtests : SocketTestTests::TestGroupInfo
  • m_nNumberOfPackets : SocketTestT4, SocketTestT3
  • m_nNumberOfSockets : SocketTestT4, SocketTestT3
  • m_no_of_buffers : DataSourceRtStreamingSource
  • m_no_of_tones : CustomToneAudioReference
  • m_node_buffer : RegMemoryBuffer
  • m_node_count : RegFileHeader
  • m_node_name : InteriorNodeRecord
  • m_node_type : RegEncoderDecoder::RegIteratorNodeType
  • m_normalized_time : SvgImage
  • m_notif_type : MtlrInfo
  • m_notification_rule : Property
  • m_nPacketsCollected : UdpTestSocket, TcpTestSocket
  • m_nPacketSize : DownloadSettings
  • m_nPacketsReceived : UdpTestSocket, TcpTestSocket
  • m_nPSDid : SocketTestApp
  • m_nSERid : SocketTestApp
  • m_nServerDelay : DownloadSettings
  • m_nStartNumber : SocketTestT4
  • m_nStatus : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nTestID : UdpTestSocket, TcpTestSocket
  • m_nTimeout : SocketTestApp::menuItems
  • m_null_str : WStrData, StrData
  • m_null_strbuf : WStrData, StrData
  • m_num_of_channels : CodecDevice::AudioStreamInfo
  • m_num_of_subbands : CodecDevice::AudioEncoderParameters
  • m_num_of_supported_codecs : CodecDevice::Properties, CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_num_sats : GpsFixDataInt, GpsFixData
  • m_number : EccNetworkArray, EccNetworkElement
  • m_number_input_mode : PredInputMapper
  • m_number_of_params : AtCommandData
  • m_nWaitingForPackets : UdpTestSocket, TcpTestSocket
  • m_nWaitingForSockets : SocketTestT4
  • m_offset : GlyphHeader, NonsharedBinDataDataSource, BinDataDataSource, FtpTransfer
  • m_offset_angle : LcsArc
  • m_offset_node_payload : RegNodeRecord
  • m_on : VibratorDevice
  • m_on_off : SysSocketBase::LingerSetting
  • m_open_mode : File::FileState
  • m_order : SortProvider
  • m_orientation_angle : LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse
  • m_original_artist : GenericFeatureData::GenericTrackInfo
  • m_out_frame_length : CodecDevice::VideoStreamInfo
  • m_overflows : HeapVector::Stats
  • m_overhead : HeapVector::Stats
  • m_overwrite_existing_file : FileDataSink
  • m_overwritecheck_fct : HeapVector::FctTable
  • m_p_album : MediaInfo::ClipInfo
  • m_p_artist : MediaInfo::ClipInfo
  • m_p_author : MediaInfo::ClipInfo
  • m_p_comment : MediaInfo::ClipInfo
  • m_p_composer : MediaInfo::ClipInfo
  • m_p_copyright : MediaInfo::ClipInfo
  • m_p_description : MediaInfo::ClipInfo
  • m_p_duration : MediaInfo::ClipInfo
  • m_p_genre : MediaInfo::ClipInfo
  • m_p_original_artist : MediaInfo::ClipInfo
  • m_p_rating : MediaInfo::ClipInfo
  • m_p_song_name : MediaInfo::ClipInfo
  • m_p_title : MediaInfo::ClipInfo
  • m_p_track : MediaInfo::ClipInfo
  • m_p_url : MediaInfo::ClipInfo
  • m_p_year : MediaInfo::ClipInfo
  • m_page : HeapVector::Page
  • m_palette : ColorTable
  • m_param : SyncMLCTProp
  • m_param_count : SyncMLCTProp
  • m_param_name : SyncMLCTParam
  • m_parameters : AtCommandData
  • m_parent_file_id : InteriorNodeRecord
  • m_parity : NmeaUartSettings
  • m_passwd : DataConnProfile::Persist
  • m_passwd_query : DataConnProfile::Bit
  • m_path : MediaRefContainer, StreamAudioReference
  • m_paths_active : AudioAccessoryDetails
  • m_payload : RegEncoderDecoder::UriAndPayload, RegEncoderDecoder::Response
  • m_payload_bits : RegNodeRecord
  • m_payload_size : TpduHeaderInformation
  • m_payload_type : RegNodeRecord
  • m_pbinfo_initialized : SimPbBaseHandler
  • m_pcamera_app : CameraCaptureWin
  • m_pdp_context : PsdDataConn
  • m_pdp_error : PsdDataConn
  • m_pdu_count : EmsCreator::SpaceInfo
  • m_peak : HeapVector::Stats
  • m_PeriodTime : VibratorDevice
  • m_permissions : DrmInfoPersistStructure
  • m_persist : PhoneNumber::Persist
  • m_phnr : TpduHeaderInformation
  • m_phone_no : CsdDataConnProfile::Persist
  • m_phoneno_persist : PbNumberRecord::Persist
  • m_phy_domain : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_phy_proxy_id : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_phy_push_enabled : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_physical_set_id : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_playback_state : AudioPlayerEvent
  • m_player : AudioPlayerEvent
  • m_player_time_offset : SvgImage
  • m_plmn : UsimPlmn
  • m_plugin_name : AtlApplicationPlugin
  • m_pme : PagingMap
  • m_pMessage : SocketTestT4
  • m_png_ptr : PngDecoder
  • m_pobj : SharedPtr< T_obj >
  • m_point : LocationEstimate, LcsArc, LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse, LcsPointUncertCircle
  • m_port : WapProfile::PxLogicalCharacs::PxPortCharacs
  • m_port_service : WapProfile::PxLogicalCharacs::PxPortCharacs
  • m_port_set_id : WapProfile::PxLogicalCharacs::PxPortCharacs
  • m_ppp_callback : SysSocketBase
  • m_ppp_callback_data : SysSocketBase
  • m_ppp_callback_data_setup : SysSocketBase
  • m_ppp_callback_dc : SysSocketBase
  • m_ppTcpSocket : SocketTestT4
  • m_precision : ReferenceTime
  • m_prefered_alloc_wstring_size : SimPbBaseHandler
  • m_preset_list : AudioPresetStore
  • m_previous_zoom_level : SvgImage
  • m_primary_dns : DataConnProfile::Persist
  • m_primary_dns_server_address : PppSetupCallBackData
  • m_process_ptr : StackMsgProcessor
  • m_processor_type : RegEncoderDecoder::SetUpMsg
  • m_prof_id : WapProfileMgr::WapProfileInfo
  • m_prof_name : WapProfileMgr::WapProfileInfo
  • m_profile_id : DataConnProfileStorage::Header
  • m_profile_rec_size : DataConnProfileStorage::Header
  • m_profileId : SocketTestT4, SocketTestT3
  • m_prop : SyncMLCTCap
  • m_prop_count : SyncMLCTCap
  • m_prop_name : SyncMLCTProp
  • m_properties : IMelodyData
  • m_protid : SimSmsParameter::Record, TpduHeaderInformation
  • m_protocol_version : RegEncoderDecoder::SetUpMsg
  • m_provid : PbBaseProvider
  • m_provider : MtlrInfo, MolrInfo
  • m_proxy_addr : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_proxy_auth_type : WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
  • m_proxy_id : WapProfile::PxLogicalCharacs
  • m_proxy_name : WapProfile::PxLogicalCharacs
  • m_proxy_p_id : WapProfile::PxLogicalCharacs
  • m_proxy_trusted : WapProfile::PxLogicalCharacs
  • m_psd_linked_up : PsdDataConn
  • m_PsdDownloadSettings : SocketTestT3
  • m_pt_alt_ellipsoid : LocationEstimate
  • m_pt_arc : LocationEstimate
  • m_pt_uncert_circle : LocationEstimate
  • m_pt_uncert_ellipse : LocationEstimate
  • m_pTcpInSocket : SocketTestT4
  • m_pTcpOutSocket : SocketTestT4
  • m_pTcpReportSocket : SocketTestT4
  • m_pTcpServerSocket : SocketTestT4
  • m_push_enabled : WapProfile::PxLogicalCharacs
  • m_qos_delay : PsdDataConnProfile::Bit
  • m_qos_mean_rate : PsdDataConnProfile::Bit
  • m_qos_peak_rate : PsdDataConnProfile::Bit
  • m_qos_precedence : PsdDataConnProfile::Bit
  • m_qos_reliability : PsdDataConnProfile::Bit
  • m_quality_level : CodecDevice::AudioDecoderParameters, CodecDevice::VideoDecoderParameters, CodecDevice::VideoEncoderParameters
  • m_rat : UsimPlmn
  • m_rating : GenericFeatureData::GenericTrackInfo
  • m_read_event_notification : InetSocket
  • m_read_fdset : SerialIoSet
  • m_readchv : UsimFileProperty
  • m_readonly : DataConnProfile::Bit
  • m_readwritebuffer : SimPbBaseHandler
  • m_readwritebuffersize : SimPbBaseHandler
  • m_realloc_fct : HeapVector::FctTable
  • m_reason : AudioPlayerEvent
  • m_rec_max_count : DataConnProfileStorage::Header
  • m_record : UsimPbRefRecord, UsimPbRwRecord
  • m_record_length : DataRecordHandler
  • m_recordcount : UsimFileProperty
  • m_recording_wait_condition : StreamAudioPlayer
  • m_recordsize : UsimFileProperty
  • m_rect : Camera
  • m_recv_buffer : ClientNetAdapter
  • m_recv_from : NetAdapter::DataReceivedEventArgs
  • m_red_bit_count : ColorSegmentation
  • m_refcount : WStrData, StrData
  • m_refno : TpduHeaderInformation
  • m_regiterator : RegistryInterface
  • m_rem_appcntxt_list : AbstractScheduler
  • m_rep_timer : MolrRepeatInfo
  • m_repeat_interval : MolrInfo
  • m_reply_path_exists : TpduHeaderInformation
  • m_request_id_free_Slot : HttpWapMgrPlugin
  • m_requestMethod : HttpRequest
  • m_requestParams : HttpRequest
  • m_requestTarget : HttpRequest
  • m_res_type : RegEncoderDecoder::PC2MobileMsg::msg, RegEncoderDecoder::Response
  • m_resource_path_profile : MetaDataRecord
  • m_response : RegEncoderDecoder::Mobile2PCMsg::msg
  • m_response_type : AtResponseMetaInfo
  • m_result_win1 : RegAppFirstWin
  • m_reversed : ImageBrowserApp
  • m_right : Rect
  • m_ro_file_paths : DrmRightsMapTableEntry
  • m_root_path : RfsObexFtpServer
  • m_rootDir : ServerConfig
  • m_row_count : CalendarProvider
  • m_rsp_time_cat : LcsMmiQos, LcsQos
  • m_rule : FindProvider
  • m_rule2item : FilterRule
  • m_ruleitem : FilterRule
  • m_running : AbstractAppContext, Server, FtpTransfer
  • m_rx : SyncMLDataStoreProps
  • m_rx_count : SyncMLDataStoreProps
  • m_rx_pref : SyncMLDataStoreProps
  • m_sample_rate : StreamAudioReference
  • m_sampling_frequency : CodecDevice::AudioStreamInfo
  • m_sat_id : SatelliteInfo
  • m_sat_info : GpsFixDataInt, GpsFixData
  • m_sca : SimSmsParameter::Record
  • m_scaled_bottom_edge_cutted : PngImage
  • m_scaled_height : PngImage
  • m_scaled_right_edge_cutted : PngImage
  • m_scaled_width : PngImage
  • m_scaling_height : PngImage
  • m_scaling_width : PngImage
  • m_scanline : PngDecoder
  • m_scanline_idx : PngDecoder
  • m_scheduler : AbstractAppContext
  • m_sd : InetSocket, SerialSocket
  • m_sdn_maxrecs : SimPbBaseHandler
  • m_sdn_tagsize : SimPbBaseHandler
  • m_sec : UtcTime
  • m_second : Time::Persist, DateTime::Persist
  • m_secondary_dns : DataConnProfile::Persist
  • m_secondary_dns_server_address : PppSetupCallBackData
  • m_selectid : SerialIoSet
  • m_semi_major_axis : LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse
  • m_semi_minor_axis : LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse
  • m_send_buffer : ClientNetAdapter
  • m_send_buffer_offset : ClientNetAdapter
  • m_send_buffer_size : ClientNetAdapter
  • m_send_continue_msg : UdpTestSocket, TcpTestSocket
  • m_send_error_message : AudioPlayerEvent
  • m_send_progress_messages : File::FileState
  • m_send_sem : ClientNetAdapter
  • m_sender_name : RadioAudioDevice::StationInfo
  • m_serialio : SerialSocket
  • m_server : ServerClient, HttpSocket, FtpSocket, FtpDataSocket
  • m_serverConfig : Server
  • m_session_received : PdpContextManager::DataCounters
  • m_session_sent : PdpContextManager::DataCounters
  • m_set : UsimPbGroups
  • m_set_frame_idx : SvgImage
  • m_settings : SocketTestApp
  • m_shared_mem : SyncMLDataStoreProps
  • m_shifted_pixel_height : PngImage
  • m_shifted_pixel_width : PngImage
  • m_shiftval : HeapVector::VarPage
  • m_shortci : PnnEntry
  • m_shortname : PnnEntry
  • m_sig_strength : SatelliteInfo
  • m_sim_handler : BaseDataHandler
  • m_sim_pdu_handler : SmsMsgWaitingProvider, SmsCountProvider, SmsProvider
  • m_sim_recno : PbNumberRecord::Persist
  • m_sim_stored : TpduHeaderInformation
  • m_sink : RamDataSource
  • m_size : MetaDataRecord, InputMap, SyncMLCTValueDef, SyncMLItemMetaInfo
  • m_size_fct : HeapVector::FctTable
  • m_sizevector : HeapVector::VarPage, HeapVector::BlockPage
  • m_sms_port_no : TpduHeaderInformation
  • m_sms_type : Sms
  • m_snr : SatelliteInfo
  • m_socket_connected : RegAppWin
  • m_song_name : GenericFeatureData::GenericTrackInfo
  • m_sortbuffer : QuickSortProvider
  • m_sorted_table : MergeProvider
  • m_SortedRows : SortProvider
  • m_source : CfuServiceArray
  • m_source_ref : SyncMLDataStoreProps
  • m_sourcestring : InputAction
  • m_sPathname : PathProfile::Persist
  • m_specific_resp_cnt : AtCommandMetaInfo
  • m_specific_responses : AtCommandMetaInfo
  • m_speed : GpsFixDataInt, GpsFixData
  • m_speed_valid : GpsFixDataInt, GpsFixData
  • m_start_block_num : BlockData
  • m_startpage : HeapVector::HeapTableEntry, WapProfile::PxLogicalCharacs
  • m_startpage_pwd : WapProfile::PxLogicalCharacs
  • m_startpage_user_name : WapProfile::PxLogicalCharacs
  • m_state : BtRequest
  • m_status : Provider, UsimPbFillStatus, TpduHeaderInformation
  • m_status_string : CallHdlBase
  • m_statusLine : HttpResponse
  • m_stereo_mode : RadioAudioDevice::StationInfo
  • m_stop_bits : NmeaUartSettings
  • m_stop_requested_by_conn : DataSourceRtStreamingSource
  • m_storagetype : TpduHeaderInformation
  • m_str_presentation : AtResponseMetaInfo, AtCommandMetaInfo
  • m_stream_type : CodecDevice::VideoStreamInfo
  • m_structure : FtpDataSocket
  • m_subnet : PdpContext::PacketFilter::AddressAndMask
  • m_substituted_text : FeatureItem
  • m_subsys_name : VersionInfo::Data
  • m_subunit_type : BtAvrcpSubunitInfoEntry
  • m_support_large_objects : SyncMLDataStoreProps
  • m_svg_bitmap : SvgImage
  • m_svg_height : SvgImage
  • m_svg_width : SvgImage
  • m_sync_cap : SyncMLDataStoreProps
  • m_sync_type_count : SyncMLDataStoreProps
  • m_syntaxerror : InputAction
  • m_temporary : File::FileState
  • m_text : TextIconPairArray::TextIconPair
  • m_text_attr : AbstractTextRenderer
  • m_text_start : AbstractTextRenderer
  • m_textline_settingmode : CameraViewFinderWin
  • m_tho_than_diacritic_lines : ThaiTextRenderer::ThaiFontHint
  • m_ti_pd : MtlrInfo
  • m_ticks : UdpTestSocket, SvgImage
  • m_time : TimeFeatureObject, CodecDevice::AudioIOBuffer
  • m_time_stamp : LastLocationEstimate
  • m_time_tag_delta : GpsFixDataInt, GpsFixData
  • m_timeout : SysSocketBase::LingerSetting
  • m_timer_resolution : CodecDevice::VideoEncoderParameters
  • m_title : GenericFeatureData::GenericTrackInfo, PropertyDescriptor
  • m_to_nap_id : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_tone_data : IMelodyData, CustomToneAudioReference
  • m_tone_id : PresetAudioReference, AudioPreset
  • m_tone_type : CustomToneAudioReference, AudioPreset
  • m_top : Rect
  • m_top_level_y_offset : ThaiTextRenderer::ThaiFontHint
  • m_top_offset : CodecDevice::VideoStreamInfo
  • m_total_play_time_1 : AudioReference::TotalPlayTimeContainer
  • m_total_play_time_2 : AudioReference::TotalPlayTimeContainer
  • m_total_play_time_3 : AudioReference::TotalPlayTimeContainer
  • m_total_play_time_4 : AudioReference::TotalPlayTimeContainer
  • m_total_received : PdpContextManager::DataCounters
  • m_total_sent : PdpContextManager::DataCounters
  • m_tp_data : Sms
  • m_tpdu : Sms
  • m_track : GenericFeatureData::GenericTrackInfo
  • m_track_id : MediaInfo::MediaTrackInfo
  • m_tracked : SatelliteInfo
  • m_trans : SvgImage
  • m_transaction_id : InteriorNodeRecord, Transaction
  • m_transparent_color : BitmapRes, PngDecoder
  • m_tree_level : InteriorNodeRecord
  • m_trns_blue : PngDecoder
  • m_trns_green : PngDecoder
  • m_trns_red : PngDecoder
  • m_tx : SyncMLDataStoreProps
  • m_tx_count : SyncMLDataStoreProps
  • m_tx_pref : SyncMLDataStoreProps
  • m_type : RegEncoderDecoder::Payload, NetAdapter, DataConnProfile::Bit, PhoneNumber, DataItem, SyncMLItemMetaInfo, FtpDataSocket
  • m_type_name : AudioAccessoryDetails
  • m_uid : DrmRightsMapTableEntry
  • m_uint16 : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit, AbstractDevice::ControlArg
  • m_uint16_ar : LittleEndian32Bit, BigEndian32Bit
  • m_uint32 : LittleEndian32Bit, BigEndian32Bit, AbstractDevice::ControlArg
  • m_uint8 : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit, AbstractDevice::ControlArg
  • m_uint8_ar : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit
  • m_unblock_focus_messages : AbstractScheduler
  • m_uncert_altitude : LcsPointAltitudeUncertEllipsoid
  • m_uncert_radius : LcsArc, LcsPointUncertCircle
  • m_unique_id : PbNumberRecord::Persist
  • m_unit_id : GltpRequest
  • m_update_path : AudioAccessoryDetails
  • m_update_threadlet : PhonebookApp
  • m_updatechv : UsimFileProperty
  • m_uplinkPath : AudioAccessoryDetails
  • m_uri : RegEncoderDecoder::PC2MobileMsg::msg, RegEncoderDecoder::Mobile2PCMsg::msg, RegEncoderDecoder::UriAndPayload, RegEncoderDecoder::IteratorObjResult, RegEncoderDecoder::RegIteratorNodeType, RegNodeFileHeader
  • m_uri_payload : RegEncoderDecoder::PC2MobileMsg::msg
  • m_url : GenericFeatureData::GenericTrackInfo
  • m_usb_conn_info : UsbTransport
  • m_val : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit, CfuServiceArray
  • m_val_enum : SyncMLCTValueDef
  • m_value : BtSddbDeVariableLengthType, Property, HeaderData, DrmDcfHeaderData
  • m_value_def : SyncMLCTProp, SyncMLCTParam
  • m_value_def_count : SyncMLCTProp, SyncMLCTParam
  • m_ver_ct : SyncMLCTTypeVerCT
  • m_version : DataConnProfileStorage::Header, IMelodyData, RegFileHeader, SyncMLItemMetaInfo
  • m_version_string : VersionInfo::Data
  • m_vert_accuracy : LcsMmiQos, LcsQos
  • m_view : RadioButtonListView, CheckBoxListView
  • m_view_image_transformation : Camera
  • m_virtual_heap_id : HeapVector::HeapTableEntry
  • m_void_ptr : AbstractDevice::ControlArg
  • m_vp : SimSmsParameter::Record
  • m_wait_msgbox : SocketTestApp
  • m_wchar_ptr : AbstractDevice::ControlArg
  • m_white_balance : Camera
  • m_width : ImageMetaDataRecord, GlyphHeader, Glyph, BitmapRes, PngDecoder
  • m_write_cnf_cb : SioSocketAdapter::SioSocketCallbacks
  • m_write_fdset : SerialIoSet
  • m_wrong_status : TpduHeaderInformation
  • m_wsName : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_wsp_version : WapProfile::PxLogicalCharacs
  • m_wstr_settingmode : CameraViewFinderWin
  • m_wwwDir : HttpServerConfig
  • m_x_origin : PngImage
  • m_y_origin : PngImage
  • m_year : DateTime::Persist, Date, Date::Persist, GenericFeatureData::GenericTrackInfo, UtcTime
  • m_yo_ying_diacritic_lines : ThaiTextRenderer::ThaiFontHint
  • m_zoom_level : Camera
  • Macedonian : LanguageManager
  • MaFli50Hz : CameraOptionSettingsWin
  • MaFli60Hz : CameraOptionSettingsWin
  • MaFliLast : CameraOptionSettingsWin
  • MaFliOff : CameraOptionSettingsWin
  • MaFlsAuto : CameraOptionSettingsWin
  • MaFlsLast : CameraOptionSettingsWin
  • MaFlsOff : CameraOptionSettingsWin
  • MaFlsRedEye : CameraOptionSettingsWin
  • MainDesktop() : MainDesktop
  • MainHandler : MainHandler, HandlerListEntry
  • MainHandlerAccess() : MainHandlerAccess
  • MainMenu : PbAbstractWin
  • MainProvider() : MainProvider
  • MakeDir() : FfsHandler, RamHandler, FatHandler
  • MakeModeNormal() : Cbs::Filter
  • MakePermanent() : File
  • Malay : LanguageManager
  • Maltese : LanguageManager
  • MapAlphabet() : AbstractSmsApp
  • MapAndUpdateVolumes() : AudioDeviceManager
  • MapAnimation() : EmsResourceMaps
  • MapBinaryIdToClassType() : GuiObjectFactory
  • MapBinaryIdToPropertyId() : GuiObjectFactory
  • MapFont() : EmsResourceMaps
  • mapi_return_value : AudioMapiManager::RequestOutcomeType
  • MapiAudioPlayer : MapiAudioReference
  • MapiAudioReference() : MapiAudioReference
  • MapiCommandCodeType : AudioMapiManager
  • MapIso639() : LanguageManager
  • MapItemType : InputMapItem
  • MapKey_English() : EnglishT9InputMapper
  • MapKey_English_Alphabetic() : EnglishT9InputMapper
  • MapKeyToCharacter_Numbers() : EnglishT9InputMapper
  • MapLineAlignment() : EmsResourceMaps
  • MapLocalIdToUid() : DrmRightsObjectStore
  • MapMedia() : StreamAudioPlayer
  • MappingPolicy() : MappingPolicy
  • MappingPolicyClassType : GuiObjectFactory
  • MappingPolicyProp : GuiObjectFactory
  • MapPropertyIdToParseType() : GuiObjectFactory
  • MapSound() : EmsResourceMaps
  • MapTextAlignment() : EmsResourceMaps
  • MapTextColor() : EmsResourceMaps
  • MapUidToLocalId() : DrmRightsObjectStore
  • March : Date
  • MarkAcmMaxUnread() : SimAuxHandler
  • MarkAcmUnread() : SimAuxHandler
  • MarkAsInvalid() : TpduCache
  • MarkCbmirUnread() : SimAuxHandler
  • MarkCbmiUnread() : SimAuxHandler
  • MarkCcpUnread() : SimAuxHandler
  • MarkCfufUnread() : SimCphsHandler
  • MarkCphsInfoUnread() : SimCphsHandler
  • MarkCspUnread() : SimCphsHandler
  • MarkDeleted() : UibSettingsRecord, ToDoRecord, SmsSettingsRecord, CalendarRecord, PbNumberRecord, PbRecord, Record
  • MarkEccUnread() : SimAuxHandler
  • marked : ToDoRecord
  • MarkedPropertyId : Item
  • MarkImsiUnread() : SimAuxHandler
  • markLevel : ToDoRecord::Persist
  • MarkLineInUseUnread() : SimCphsHandler
  • MarkLineLockedUnread() : SimCphsHandler
  • MarkOpNameUnread() : SimCphsHandler
  • MarkOpSNameUnread() : SimCphsHandler
  • MarkPrefExtLangUnread() : SimAuxHandler
  • MarkPrefLangUnread() : SimAuxHandler
  • MarkPrefPlmnUnread() : SimAuxHandler
  • MarkPuctUnread() : SimAuxHandler
  • MarkRecordDeleted() : DataRecordHandler
  • MarkSpnUnread() : SimAuxHandler
  • MarkSstUnread() : SimAuxHandler
  • MarkVmwfUnread() : SimCphsHandler
  • MarkWelcomeMsgUnread() : SimCphsHandler
  • Marshall() : IsrDataMarshaller
  • Mask() : BitField< T >
  • MaskAlphaBlending : DeviceContext
  • Matches() : BtDeviceFilter
  • MatchesType() : BtJsr82Url::Token
  • MatchPhoneNumbers() : PhoneNumberJoinRule
  • MatchString() : ObexUrlStrParser
  • MatchSymbol() : ObexUrlStrParser
  • MaWbAuto : CameraOptionSettingsWin
  • MaWbIndoor : CameraOptionSettingsWin
  • MaWbLast : CameraOptionSettingsWin
  • MaWbOutdoor : CameraOptionSettingsWin
  • max : Camera::ParameterLimits
  • MAX_DATA_LENGTH : InternalTracer
  • max_entitled_priority : CliRestrictionInfo
  • max_height : BtBipImageFormat::ImageDim
  • MAX_LEN_TARGET : BtObexServiceTable
  • MAX_PATHNAME_LENGTH : Pathname
  • MAX_SIZE : MlcNumber, ClientName, ClientId
  • MAX_STORAGE_DEVICE_ID_LENGTH : RootFileSystem
  • max_width : BtBipImageFormat::ImageDim
  • MaxDataElements : UmtsMeasEvalParam, UmtsMeasIdParam
  • MaxDataElementsPerMeasId : UmtsMeasIdParam
  • MaxDecoderDelay : OptionalConfigBase
  • MaxEncoderDelay : OptionalConfigBase
  • MaxGsmBands : GsmBandList
  • MaxHeaderLength : ObexHeader
  • Maximize() : Window, Control
  • MaximizedProp : GuiObjectFactory
  • Maximum : AbstractSmsApp
  • MaxListSize : NeighbourCellList
  • MaxMeas : UmtsMeasEvalParam
  • MaxNumberOfCodersReached : CodecDevice
  • MaxNumberOfMptyParticipantsExceeded : SsErrorCode
  • MaxNumberOfOperationsReached : CodecDevice
  • MaxRowCount() : ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, CalendarProvider, BtHfProvider, PbRecordProvider, PbRecordHandler, PbNvRamNumberHandler, PbNvRamNameHandler, PbMergeProvider, PbFfsNumberHandler, PbFfsNameHandler, Provider, AbstractDelegationProvider, JoinProvider, AppendProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, CbmiRangeProvider, CbmiProvider
  • MaxSize() : Vector< T >
  • MaxTextLengthProp : GuiObjectFactory
  • MaxTotalUmtsCells : UmtsCellList
  • MaxValueProp : GuiObjectFactory
  • May : Date
  • mbdn_size : PhoneBookInfo
  • mbdn_tagsize : PhoneBookInfo
  • MbiProvider() : MbiProvider
  • MC : InputParser
  • mcc : CellParam, NeighbourCell, Plmn, BcdPlmn, Uplmn
  • MCServiceInterfaceMsg() : MCServiceInterfaceMsg
  • MdhDeleteSms() : SimAccessor
  • MdhDeregistrationCnfArg() : MdhDeregistrationCnfArg
  • MdhDeregistrationReqArg() : MdhDeregistrationReqArg
  • MdhExtendedData() : MdhExtendedData
  • MdhGetSms() : SimAccessor
  • MdhGetSmsReport() : SimAccessor
  • MdhGors() : MdhGors
  • MdhMakeView() : SimAccessor
  • MdhMakeViewCnfArg() : MdhMakeViewCnfArg
  • MdhMakeViewReqArg() : MdhMakeViewReqArg
  • MdhNewStatusReportIndArg() : MdhNewStatusReportIndArg
  • MdhRegistrationCnfArg() : MdhRegistrationCnfArg
  • MdhRegistrationReqArg() : MdhRegistrationReqArg
  • MdhRemoveViewCnfArg() : MdhRemoveViewCnfArg
  • MdhRemoveViewReqArg() : MdhRemoveViewReqArg
  • MdhRequestCsmsRefNo() : SimAccessor, DataHandler
  • MdhSetConfigCnfArg() : MdhSetConfigCnfArg
  • MdhSetConfigReqArg() : MdhSetConfigReqArg
  • MdhSetSmsExtendedData() : SimAccessor
  • MdhSetStorageCnfArg() : MdhSetStorageCnfArg
  • MdhSetStorageMedia() : SimAccessor
  • MdhSetStorageReqArg() : MdhSetStorageReqArg
  • MdhSetViewConfig() : SimAccessor
  • MdhSetWaitIndicatorArray() : MdhSetWaitIndicatorArray
  • MdhSmsConcRefNumIndArg() : MdhSmsConcRefNumIndArg
  • MdhSmsConcRefNumReqArg() : MdhSmsConcRefNumReqArg
  • MdhSmsDeletionIndArg() : MdhSmsDeletionIndArg
  • MdhSmsDeletionReqArg() : MdhSmsDeletionReqArg
  • MdhSmsExtendedDataIndArg() : MdhSmsExtendedDataIndArg
  • MdhSmsExtendedDataReqArg() : MdhSmsExtendedDataReqArg
  • MdhSmsInitFinishedIndArg() : MdhSmsInitFinishedIndArg
  • MdhSmsNewMessageIndArg() : MdhSmsNewMessageIndArg
  • MdhSmsReadIndArg() : MdhSmsReadIndArg
  • MdhSmsReadReqArg() : MdhSmsReadReqArg
  • MdhSmsRefreshIndArg() : MdhSmsRefreshIndArg
  • MdhSmsReportReadIndArg() : MdhSmsReportReadIndArg
  • MdhSmsReportReadReqArg() : MdhSmsReportReadReqArg
  • MdhSmsSetWaitingReqArg() : MdhSmsSetWaitingReqArg
  • MdhSmsStatusIndArg() : MdhSmsStatusIndArg
  • MdhSmsStatusReqArg() : MdhSmsStatusReqArg
  • MdhSmsStorageRefreshIndArg() : MdhSmsStorageRefreshIndArg
  • MdhSmsTransmitAckArg() : MdhSmsTransmitAckArg
  • MdhSmsTransmitIndArg() : MdhSmsTransmitIndArg
  • MdhSmsTransmitStartAckArg() : MdhSmsTransmitStartAckArg
  • MdhSmsTransmitStartIndArg() : MdhSmsTransmitStartIndArg
  • MdhSmsTransmitStopIndArg() : MdhSmsTransmitStopIndArg
  • MdhSmsUpdStatusIndArg() : MdhSmsUpdStatusIndArg
  • MdhSmsUpdStatusRefreshIndArg() : MdhSmsUpdStatusRefreshIndArg
  • MdhSmsUpdStatusReqArg() : MdhSmsUpdStatusReqArg
  • MdhSmsWaitingIndArg() : MdhSmsWaitingIndArg
  • MdhSmsWriteCnfArg() : MdhSmsWriteCnfArg
  • MdhSmsWriteReqArg() : MdhSmsWriteReqArg
  • MdhToSmsWorkMediaTranslation() : SimAccessor
  • MdhUpdateSms() : SimAccessor
  • MdhUpdateSmsStatus() : SimAccessor
  • MeanRate : PdpContext::QualityOfService
  • MeanRate100 : PdpContext::QualityOfService
  • MeanRate100K : PdpContext::QualityOfService
  • MeanRate10K : PdpContext::QualityOfService
  • MeanRate10M : PdpContext::QualityOfService
  • MeanRate1K : PdpContext::QualityOfService
  • MeanRate1M : PdpContext::QualityOfService
  • MeanRate200 : PdpContext::QualityOfService
  • MeanRate200K : PdpContext::QualityOfService
  • MeanRate20K : PdpContext::QualityOfService
  • MeanRate20M : PdpContext::QualityOfService
  • MeanRate2K : PdpContext::QualityOfService
  • MeanRate2M : PdpContext::QualityOfService
  • MeanRate500 : PdpContext::QualityOfService
  • MeanRate500K : PdpContext::QualityOfService
  • MeanRate50K : PdpContext::QualityOfService
  • MeanRate50M : PdpContext::QualityOfService
  • MeanRate5K : PdpContext::QualityOfService
  • MeanRate5M : PdpContext::QualityOfService
  • MeanRateBestEffort : PdpContext::QualityOfService
  • MeanRateReserved : PdpContext::QualityOfService
  • MeanRateSubscribed : PdpContext::QualityOfService
  • meas_bler : DchReport, BlerTrchInfo
  • meas_id : UmtsMeasIdParam
  • meas_sir : DchReport
  • MeasurementData() : MeasurementData
  • MeasurementDataArg() : MeasurementDataArg
  • MeDataDownload : ProtocolIdentifier
  • MeDepersonalizationShortMessage : ProtocolIdentifier
  • Media() : StreamAudioReference, Media
  • media : Mp3Param, VmParam, PcmParam
  • media_present : FsRegistrationInfo, fs_registered_info_type
  • media_type : VoiceMemoAudioDevice::StartParam
  • MediaAvailableStatusNotification : StorageDevice
  • MediaBox() : MediaBox
  • MediaBoxView() : MediaBoxView
  • MediaCodec : MediaInfo
  • MediaFailureError : File
  • MediaFilter() : MediaFilter
  • MediaFrameworkCaps() : MediaFrameworkCaps
  • MediaInfo() : MediaInfo
  • MediaInfoObtainedMsg : MediaManager
  • MediaManager : MediaRecorder, MediaPlayer
  • MediaManagerMsg() : MediaManagerMsg
  • MediaMmc : VoiceMemoAudioDevice
  • MediaNotSupported : MediaManager, CodecDevice
  • MediaObtainer : MediaObtainer, Media
  • MediaPathnameVisitor() : MediaPathnameVisitor
  • MediaQuality : RecordSettings
  • MediaRam : VoiceMemoAudioDevice
  • MediaRecorder : RecordSettings
  • MediaRecorderState : MediaRecorder
  • MediaRef() : MediaRef
  • MediaRefContainer() : MediaRefContainer
  • MediaRefExists() : MediaRefContainer
  • MediaRefLinkable() : MediaRefLinkable
  • MediaSinkType : RecordSettings
  • MediaTrackInfo() : MediaInfo::MediaTrackInfo
  • MediaType : VoiceMemoAudioDevice
  • MediaTypeDifferent : MediaManager
  • MediaTypeFfs : VoiceMemoAudioDevice
  • MediaTypeNotSupportedMsg : MediaManager
  • MediaVisitor() : MediaVisitor
  • MEditorProp : GuiObjectFactory
  • Medium : ToDoRecord
  • MediumQuality : DisplaySettings
  • Meeting : CalendarRecord
  • Melody() : Melody
  • Mem : InternalTracer
  • MemMap() : MemMap
  • MemNotAvailableError : File
  • Memo : CalendarRecord
  • memory_alloc_failure : SvgImage
  • MemoryCapacityExceeded : Sms, ShortMessageFailureCause
  • MemoryError : File
  • MemoryFull : Sms
  • MemPool() : MemPool
  • MemPoolEntry() : MemPoolEntry
  • Menu : Menu, Font, AbstractMenuAccessor
  • MENU_ACTIVATED_MSG : TestWriter
  • MENU_CHANGED_MSG : TestWriter
  • MENU_CLOSED_MSG : TestWriter
  • menu_id : MenuPool::MenuTableEntry
  • MENU_OPENED_MSG : TestWriter
  • menu_properties : MenuPool::MenuTableEntry
  • MenuAccessor() : MenuAccessor
  • MenuDesc() : MenuDesc
  • MenuDescClassType : GuiObjectFactory
  • MenuDescObj() : MenuDescObj
  • MenuFileExists() : MenuPool
  • MenuFunction : T9InputConfig
  • MenuIdObj() : MenuIdObj
  • MenuIdProp : GuiObjectFactory
  • MenuIndex : PbAbstractWin
  • MenuItem() : MenuItem
  • MenuItemSelected() : SimTkHandler
  • MenuList() : MenuList
  • MenuListView() : MenuListView
  • MenuMapClassType : GuiObjectFactory
  • MenuMapMenuDescProp : GuiObjectFactory
  • MenuMapMenuIdsProp : GuiObjectFactory
  • MenuPool() : MenuPool
  • MenuPositionProp : GuiObjectFactory
  • MenuProperties() : MenuProperties
  • MenuPropertiesClassType : GuiObjectFactory
  • MenuPropertiesProp : GuiObjectFactory
  • MenuResourceTableEntryMenuIdProp : GuiObjectFactory
  • MenuResourceTableEntryProp : GuiObjectFactory
  • MenuResourceTableEntryResourceIdProp : GuiObjectFactory
  • MenuResourceTableSizeProp : GuiObjectFactory
  • MenuResourceTableType : GuiObjectFactory
  • MenuSelection : SimTkProfile
  • MenuSelectionRejArg() : MenuSelectionRejArg
  • MenuSelectionReqArg() : MenuSelectionReqArg
  • MenuTable : MenuTableNode
  • MenuTableNode : MenuTableNode, MenuTable
  • MenuTextPtrArrayIterator() : MenuTextPtrArrayIterator
  • MenuType : MenuProperties, GuiObjectFactory
  • MenuTypeProp : GuiObjectFactory
  • MenuView() : MenuView
  • MenuWindow() : MenuWindow
  • MePhonebookDescription() : MePhonebookDescription
  • MePhonebookDescriptor() : MePhonebookDescriptor
  • Merge() : TextCompoundItem, Control::NavigationGuidance, CompoundItem, CfuServiceArray, MessageIdentifierContainer, RichTextCompoundItem, GeneralCompoundItem
  • MergeDataCodingSchemeRanges() : Cbs::Filter
  • MergeFilters() : CbsFilterList
  • MergeMessageIdentifierRanges() : Cbs::Filter
  • MergeOnly : MergeProvider
  • MergeProvider() : MergeProvider
  • Message : Message, InternalTracer
  • MESSAGE_RECEIVED_MSG : TestWriter
  • MESSAGE_SENT_MSG : TestWriter
  • MessageBox() : MessageBox
  • MessageBoxClassType : GuiObjectFactory
  • MessageBoxType : GuiObjectFactory
  • MessageClass() : DataCodingScheme, EnumTranslationTable
  • MessageClassNotSupported : ShortMessageFailureCause
  • MessageHandlingFacility : ProtocolIdentifier
  • MessageHook : MessageHook, MessageRouter
  • MessageHookNotificationMsg : MessageHook
  • MessageHookReferrer : MessageHook
  • MessageIdentifier() : MessageIdentifier
  • MessageIdentifierContainer() : MessageIdentifierContainer
  • MessageIdentifierPair() : MessageIdentifierContainer::MessageIdentifierPair
  • MessageIdentifierRange() : MessageIdentifierRange
  • MessageMapContainer() : MessageMapContainer< T >
  • MessageMapDispatcher() : MessageMapDispatcher
  • MessageProp : GuiObjectFactory
  • MessageQueueEmptyCondition : SimAccessor
  • MessageReceivedCondition : SimAccessor
  • MessageReferrer : MessageReferrer, Message
  • MessageResultReason() : EnumTranslationTable
  • MessageRouter : System, MessageHook, Message, ExecutionContext
  • MessageSendableCondition : SimAccessor
  • MessageStartCondition : SimAccessor
  • MessageStatus() : EnumTranslationTable
  • MessageType() : DataConn, ProtocolIdentifier, InformationElement, EnumTranslationTable
  • MessageTypeIndicator() : MessageTypeIndicator, EnumTranslationTable
  • MessageWaitingActive : DataCodingScheme
  • MessageWaitingInactive : DataCodingScheme
  • MessageWaitingInvalid : DataCodingScheme
  • MetaData() : MetaData, Image::MetaData
  • MetaDataRecord() : MetaDataRecord
  • MeteringType : Camera
  • METHOD_CALLED_MSG : TestWriter
  • MexeDescriptor() : MexeDescriptor
  • MicGain : BtHsVolumeSettingsWin, BtHfVolumeSettingsWin
  • Middle : Layouter, GridLayout, FlowLayout, IndicatorLocation
  • MiddlePos : TabButton
  • MIDIRingerDeviceID : AudioDeviceManager
  • MidiSound() : MidiSound
  • millisec : RealTimeClock::DateAndTime
  • mime_str : MimeTypeTableEntry
  • mime_type : tagCustFileData, MimeTypeTableEntry, AudioPlayerStore::DataFormatDataSource, FfsDrmAttrib, ffs_drm_attrib_type, FfsMimeTypeMapEntry, Media::Parameters
  • MimeCoder() : MimeCoder
  • mimetype : RomDataRes
  • MimeTypeFilter() : MimeTypeFilter
  • MimeTypeTable : MimeTypeTable::Partition
  • min : Camera::ParameterLimits, FfsTimeRecord, ffs_time_record_type
  • min_height : BtBipImageFormat::ImageDim
  • min_width : BtBipImageFormat::ImageDim
  • MinGetFragSize : ObexDataServer
  • MinSizeProp : GuiObjectFactory
  • minute : RealTimeClock::DateAndTime
  • MinuteTick : RealTimeClock
  • MinuteTickMsg() : MinuteTickMsg
  • MinValueProp : GuiObjectFactory
  • Mirror : DeviceContext, CamWin32, VideoChannel, Camera
  • MirrorRot180 : DeviceContext
  • MirrorRot270 : DeviceContext
  • MirrorRot90 : DeviceContext
  • MirrorRotate180 : CamWin32, Camera
  • MirrorRotate180Transformation : VideoChannel
  • MirrorRotate270 : CamWin32, Camera
  • MirrorRotate270Transformation : VideoChannel
  • MirrorRotate90 : CamWin32, Camera
  • MirrorRotate90Transformation : VideoChannel
  • MirrorTransformation : VideoChannel
  • Misc : InternalTracer
  • MissingDataError : Image
  • MissingOrUnknownApn : PdpContext
  • MissingPduIE : BaseInformationElement
  • MistypedComponent : TaggedProblemCode
  • MistypedErrorParameter : TaggedProblemCode
  • MistypedProParameter : TaggedProblemCode
  • MistypedResParameter : TaggedProblemCode
  • mix_factor : ToneAudioDevice::StartParam, KeyToneAudioDevice::StartParam
  • MlcNumber() : MlcNumber
  • MmAocChargingStatusMsg() : MmAocChargingStatusMsg
  • MmCallAcceptMsg() : MmCallAcceptMsg
  • MmCallDisconnected : CallEvent
  • MmCallDisconnectingMsg() : MmCallDisconnectingMsg
  • MmCallDispatcher() : MmCallDispatcher
  • MmCallHandler() : MmCallHandler
  • MmCallHdl() : MmCallHdl
  • MmCallInfo() : MmCallInfo
  • MmCallInfoMsg() : MmCallInfoMsg
  • MmCallNotifyMsg() : MmCallNotifyMsg
  • MmCallReleased : CallEvent
  • MmCallReleaseMsg() : MmCallReleaseMsg
  • MmCallSerialTerminalListener() : MmCallSerialTerminalListener
  • MmCallSetupProgressMsg() : MmCallSetupProgressMsg
  • MmCallStatusMsg() : MmCallStatusMsg
  • MmcMedia : StreamAudioReference
  • MmCoordParam() : MmCoordParam
  • MmcsParam() : MmcsParam
  • MmCurrentCallMeterMsg() : MmCurrentCallMeterMsg
  • MmCurrentChargeDataMsg() : MmCurrentChargeDataMsg
  • MmfCreateStream() : StreamAudioReference
  • MmfGetAudioTrackInfo : AudioDeviceBase
  • MmfMedia : StreamAudioReference
  • MmfMsgType : MediaManager
  • MmfResult : MediaManager
  • MmfResumeFeature : AudioDeviceBase
  • MmfSuspendFeature : AudioDeviceBase
  • Mmi : InternalTracer
  • mmi_configuration : SecLockStates
  • MmiSimBacklightStateId : MmiSimServer
  • MmiSimCharId : MmiSimServer
  • MmiSimClipStateId : MmiSimServer
  • MmiSimCmdId : MmiSimServer
  • MmiSimDisplayUpdateDataId : MmiSimServer
  • MmiSimDisplayUpdateHeaderId : MmiSimServer
  • MmiSimKeyDownId : MmiSimServer
  • MmiSimKeyUpId : MmiSimServer
  • MmiSimLedStateId : MmiSimServer
  • MmiSimPenDownId : MmiSimServer
  • MmiSimPenMoveId : MmiSimServer
  • MmiSimPenUpId : MmiSimServer
  • MmiSimPowerStateId : MmiSimServer
  • MmiSimVibrationStateId : MmiSimServer
  • MmMocEstablished : CallEvent
  • MmMocInSetup : CallEvent
  • MmMocRejected : CallEvent
  • MmMocSetupAcceptMsg() : MmMocSetupAcceptMsg
  • MmMtcEstablished : CallEvent
  • MmMtcIsWaiting : CallEvent
  • mnc : CellParam, NeighbourCell, Plmn, BcdPlmn, Uplmn
  • MnInformationIndArg() : MnInformationIndArg
  • MnNetworkSearchModeReqArg() : MnNetworkSearchModeReqArg
  • MnTriggerReqArg() : MnTriggerReqArg
  • Mobile2PCMsg : RegEncoderDecoder
  • MobileOriginated : ShortMessageFailureCause, MessageTypeIndicator
  • MobileOriginatedCall : MmCallInfo
  • MobileOriginatedUssdHandler() : MobileOriginatedUssdHandler
  • MobileShutdown : RegEncoderDecoder
  • MobileStation : PdpContext
  • MobileTerminated : ShortMessageFailureCause, MessageTypeIndicator
  • MobileTerminatedCall : MmCallInfo
  • MOC : XCallInfoResponseParser
  • MocAlertIndArg() : MocAlertIndArg
  • MoCallAction() : MoCallAction
  • MoCallDialing : XCallInfoResponseParser
  • MoCallRequested : XCallInfoResponseParser
  • MocEstablished : CallEvent
  • MocInSetup : CallEvent
  • MocRejected : CallEvent
  • MocRemoteUserAlerted : XCallInfoResponseParser
  • MocSetupAccArg() : MocSetupAccArg
  • MocSetupAcceptMsg() : MocSetupAcceptMsg
  • MocSetupCnfArg() : MocSetupCnfArg
  • MocSetupRejArg() : MocSetupRejArg
  • MocSetupRejected : XCallInfoResponseParser
  • MocSetupRejectIndMsg() : MocSetupRejectIndMsg
  • MocSetupRejIndArg() : MocSetupRejIndArg
  • MocSetupReqArg() : MocSetupReqArg
  • ModalProp : GuiObjectFactory
  • Mode : MessageHook, IconState, Caret, ShutDown, StreamAudioReference, Cbs::Filter
  • mode : PcmParam
  • ModeBluetoothHeadset : Audio
  • ModeHandsfree : Audio
  • ModeHeadset : Audio
  • Model() : Model
  • ModeMono : RadioAudioDevice
  • ModeNormal : Audio
  • ModeProp : GuiObjectFactory
  • ModeStereo : RadioAudioDevice
  • Modification() : Provider::Modification
  • ModificationCompleted : XCallInfoResponseParser
  • ModificationDate : File::Attributes
  • ModificationIndicated : XCallInfoResponseParser
  • ModificationRejected : XCallInfoResponseParser
  • ModificationStarted : XCallInfoResponseParser
  • ModificationState : XCallInfoResponseParser
  • ModificationStateNotValid : XCallInfoResponseParser
  • ModificationTime : File::Attributes
  • ModificationType : Provider
  • Modify() : FfsFile, FfsHandler
  • ModifyLock() : SimChvHandler, SimAccessor, DataHandler
  • ModifySelectedItem() : CalendarRecordsList, CalendarListWin
  • MolrInfo() : MolrInfo
  • MolrParams() : MolrParams
  • MolrProcessed() : LcsReqProcessor
  • MolrRepeatInfo() : MolrRepeatInfo
  • Monday : Date
  • Mono : CodecDevice
  • MonoChannelMode : AudioEncoder
  • Monochrome : VirtualDisplay
  • MonoStereoConfigEnd : CodecDevice
  • MonoStereoType : StreamAudioReference
  • MonoSteroConfig : CodecDevice
  • month : RealTimeClock::DateAndTime, FfsTimeRecord, ffs_time_record_type
  • Month : Date
  • month_name : Date
  • Monthly : CalendarRecord
  • MonthName() : Date
  • MoreMessagesToSend() : SmsStatusReport, SmsDeliver
  • Mount() : MainHandler
  • Move() : Rect, Point, WinRect, File
  • MoveCaret() : SearchBox, TimeEditor, DateEditor, AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor
  • MoveCursor() : TimeEditBox, EditBox, DateEditBox, AbstractEditBox
  • MoveCursorToLine() : AbstractEditBox
  • MoveDirection : AbstractGrid
  • MoveFile() : RootFileSystem
  • MoveNextElements() : RegDeletionBufferEntry
  • MoveSelectedIndex() : AbstractItemGrid, AbstractGrid
  • MoveSmsToArchive() : AbstractSmsApp
  • MoveToParagraph() : ParagraphCompoundItem
  • MoveUnicodeBufferAndAdjustBytes() : DataCoding
  • MoveValue() : IndexTable< T >
  • Mp3 : MediaInfo, CodecDevice
  • mp3_player : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • Mp3AudioDevice() : Mp3AudioDevice
  • MP3AudioPlayer : StreamAudioReference
  • MP3DeviceID : AudioDeviceManager
  • MP3DspFormat : StreamAudioReference
  • Mpeg4Aac : MediaInfo, CodecDevice
  • Mpeg4AacPlusV1 : MediaInfo, CodecDevice
  • Mpeg4AacPlusV2 : MediaInfo, CodecDevice
  • Mpeg4Sp : MediaInfo, CodecDevice
  • mpg_br : Mp3Header
  • mpg_freq : Mp3Header
  • mpg_layer : Mp3Header
  • mpg_pad_bit : Mp3Header
  • mpg_ver : Mp3Header
  • mpty_indicator : NotifySsArg
  • MptyCallHdl() : MptyCallHdl
  • MptyCallReleaseMsg() : MptyCallReleaseMsg
  • MptyCnfArg() : MptyCnfArg
  • MptyHoldRejectedMsg() : MptyHoldRejectedMsg
  • MptyOnHoldMsg() : MptyOnHoldMsg
  • ms_tx_power_max_cch : CellParam
  • msg : RegEncoderDecoder::PC2MobileMsg, RegEncoderDecoder::Mobile2PCMsg
  • msg_class : MsgMetaData
  • msg_id : RegEncoderDecoder::PC2MobileMsg, MsgMetaData, MessageMap< T >
  • msg_origin : MsgMetaData
  • MsgID : RegEncoderDecoder
  • MsgLoop() : SimpleAppContext, AppContext, AppContainer, AbstractAppContext
  • MsgNotCompatible : PdpContext, Sms
  • MsgQueue : MsgQueue, AppContainer
  • MsgTypeData : SimCphsHandler
  • MsgTypeFax : SimCphsHandler
  • MsgTypeLine1 : SimCphsHandler
  • MsgTypeLine2 : SimCphsHandler
  • MsgTypeNonExistent : Sms
  • MsgTypeNotCompatible : PdpContext
  • MsgTypeNotExistent : PdpContext
  • MsgWaitingIndDiscardGroup : DataCodingScheme
  • MsgWaitingIndication : SmsIndicationState
  • MsgWaitingIndStoreDefaultGroup : DataCodingScheme
  • MsgWaitingIndStoreUcs2Group : DataCodingScheme
  • MsIntSsError : SsErrorCode
  • MsIntSsTimeOut : SsErrorCode
  • msisdn_size : PhoneBookInfo
  • msisdn_tagsize : PhoneBookInfo
  • MSP : InputParser
  • mt_data_conn_established : DataConn
  • mt_data_conn_init : DataConn
  • mt_data_conn_init_release : DataConn
  • mt_data_conn_released : DataConn
  • mt_data_conn_setup_blocked : DataConn
  • mt_data_conn_setup_failed : DataConn
  • MTC : XCallInfoResponseParser
  • MtcAcceptArg() : MtcAcceptArg
  • MtcAccepted : XCallInfoResponseParser
  • MtcAcceptRejArg() : MtcAcceptRejArg
  • MtcAlertReqArg() : MtcAlertReqArg
  • MtcArrivedMsg() : MtcArrivedMsg
  • MtcBcNegotiated : XCallInfoResponseParser
  • MtcConfIndArg() : MtcConfIndArg
  • MtcConfirmed : XCallInfoResponseParser
  • MtcEstablished : CallEvent
  • MtcIndicated : XCallInfoResponseParser
  • MtcIsWaiting : CallEvent
  • MtcReadyMsg() : MtcReadyMsg
  • MtcSetupComplArg() : MtcSetupComplArg
  • MtcSetupIndArg() : MtcSetupIndArg
  • MtlrInfo() : MtlrInfo
  • multi_slot_class : MultiSlotMode
  • MultiLineEditor() : MultiLineEditor
  • MultiLineEditorClassType : GuiObjectFactory
  • MultiLineProp : GuiObjectFactory
  • MultiMediaEditor() : MultiMediaEditor
  • MultiMediaEditorClassType : GuiObjectFactory
  • MultiMediaEditorDocument : MultiMediaEditorDocument, ParagraphCompoundItem
  • MultipartParser() : MultipartParser
  • MultiPartyCallInvokedMsg() : MultiPartyCallInvokedMsg
  • MultiPartyCompleted : XCallInfoResponseParser
  • MultiPartyHeldCompleted : XCallInfoResponseParser
  • MultiPartyHeldRejected : XCallInfoResponseParser
  • MultiPartyHeldStarted : XCallInfoResponseParser
  • MultipartyJoin : CallEvent
  • MultiPartyOnHold : CallEvent
  • MultiPartyRejected : XCallInfoResponseParser
  • MultiPartyReleased : CallEvent
  • MultiPartyRetrieveCompleted : XCallInfoResponseParser
  • MultiPartyRetrieved : CallEvent
  • MultiPartyRetrieveRejected : XCallInfoResponseParser
  • MultiPartyRetrieveStarted : XCallInfoResponseParser
  • MultiPartySplitCompleted : XCallInfoResponseParser
  • MultiPartySplitRejected : XCallInfoResponseParser
  • MultiPartySplitStarted : XCallInfoResponseParser
  • MultiPartySplitted : CallEvent
  • MultiPartyStarted : XCallInfoResponseParser
  • MultiSlotDispatcher() : MultiSlotDispatcher
  • MultiSlotHandler() : MultiSlotHandler
  • MultiSlotMode() : MultiSlotMode
  • MultiTab : InputMapper
  • MultiTap : InputMapper
  • MultiTapCaret() : MultiTapCaret
  • MultiTapInputMapper() : MultiTapInputMapper
  • MusicMode() : Led
  • Mute() : SpeechAudioDevice
  • MuteDirection : SpeechAudioDevice, Audio, AudioDeviceBase
  • MuteDownlink : SpeechAudioDevice, Audio
  • MuteSpeech() : Audio
  • MuteTch : Audio
  • MuteUpDownlink : SpeechAudioDevice
  • MuteUplink : SpeechAudioDevice, Audio
  • Mutex() : Mutex
  • MutexObtainer() : MutexObtainer
  • MyProfile() : PsdDataConn, DataConn, CsdDataConn
  • MyState() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
Generated on Wed Jan 25 00:54:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • nack_blocks : AckNackCnt
  • name : GroupProvider::GroupRec, FontRes, tagFont, tagLanguage, RingerAudioDevice::RingerToneInfo, ServiceProviderStruct, StackMsgMapTableEntry, SignalMapTableEntry, HttpRequest::ParamPair
  • Name : ObexHeader, InputMapper
  • name_indicator : NotifySsArg
  • name_indicator_present : NameIndicator
  • name_string : CallingName
  • NameCapitalization : MultiTapInputMapper
  • NamePatternFileFilter() : NamePatternFileFilter
  • NamePatternStorageDeviceFilter() : NamePatternStorageDeviceFilter
  • NameProv : PhonebookApp
  • NationalNumber : TypeOfAddress
  • NationalNumberingPlan : TypeOfAddress
  • NationalPagingSystem : ProtocolIdentifier
  • NationalRoamingNotAllowed : PdpContext
  • Native16Bit() : Native16Bit
  • Native32Bit() : Native32Bit
  • native_name : tagLanguage
  • NativeImage() : NativeImage
  • NativeImageDecoder : NativeImage
  • NaturalReason : AudioPlayerEvent
  • NavigateCaret() : AbstractMultiLineEditor
  • NavigationGuidance() : Control::NavigationGuidance
  • nco : GprsParam
  • NegativeFilter : Camera
  • NegativePwCheck : SsErrorCode
  • neighbour_cells : TestparamReport, NeighbourCellList
  • NeighbourCell() : NeighbourCell
  • NeighbourCells : TestparamReport
  • nestedLevel : InternalTracer::TraceHeader
  • NestedLevel() : InternalTracer
  • net_op_mode : GprsParam
  • NetAdapter : NetAdapter, NetAdapterHandler
  • NetAdapterHandler() : NetAdapterHandler
  • NetAdapterHandlerCallback : NetAdapterHandler
  • NetAdapterPtr : NetAdapterHandler
  • Network : PdpContext
  • network : SimLockStates
  • NetworkDispatcher() : NetworkDispatcher
  • NetworkErrBandWidthTooHigh : MediaManager
  • NetworkErrConnectFailed : MediaManager
  • NetworkErrConnErr : MediaManager
  • NetworkErrConnLostErr : MediaManager
  • NetworkErrCriticalError : MediaManager
  • NetworkErrHTTPError : MediaManager
  • NetworkErrRtpDataError : MediaManager
  • NetworkErrSdpFileOpenError : MediaManager
  • NetworkErrSdpParseError : MediaManager
  • NetworkErrUnknown : MediaManager
  • NetworkErrUnknownServError : MediaManager
  • NetworkErrUrlNotFound : MediaManager
  • NetworkErrUrlNotStreamable : MediaManager
  • NetworkFailure : PdpContext
  • NetworkHandler() : NetworkHandler
  • NetworkInformationMsg() : NetworkInformationMsg
  • NetworkMsgRtcpByeReceived : MediaManager
  • NetworkOutOfOrder : Sms
  • NetworkProvided : PhoneNumber
  • NetworkRequestPending : PdpContextManager
  • NetworkSpecificNumber : TypeOfAddress
  • NetworkSsErrorMsg() : NetworkSsErrorMsg
  • NetworkSsRejectedMsg() : NetworkSsRejectedMsg
  • NeutralType : BidiManager
  • New : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile, InternalTracer
  • NewDataElement() : BtSddbDataElementFactory
  • NewHeader() : ObexHeaderBuilder
  • newpwd : SecLockCommand
  • NewSim() : PhonebookApp
  • NewSint() : BtSddbDataElementFactory
  • NewSmsIndication : SmsIndicationState
  • NewStatRepIndication : SmsIndicationState
  • NewUint() : BtSddbDataElementFactory
  • NewUuid() : BtSddbDataElementFactory
  • Next : VoiceMemoMenuAccessor, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, DataConnAccessor, WindowHierarchyIterator, ThemeViewIterator, Control::ComponentIterator, ScanlineAccessor, TextMenuAccessor, AbstractMenuAccessor, CompoundItemIterator, ActionMenuAccessor, AbstractSmsViewerWin
  • next : TpduNode, TpduConc
  • NextExpiringTimer() : AppContainer
  • NextFunction : T9InputConfig
  • NextSocketTestMsg() : NextSocketTestMsg
  • NiSharedPtr() : NiSharedPtr< X >
  • NiSharedPtr< DataConn > : PsdDataConn, DataConn, CsdDataConn
  • NmeaUartSettings() : NmeaUartSettings
  • no : ChvData
  • no_ack_nack_blocks : GprsParam
  • no_active_set_cells : UmtsNcellParamList
  • no_blocks : CiTestParam
  • no_id : PbNumberRecord::Persist
  • no_locks : SecLockStates
  • NO_PROVIDERS : BootControl, BootState
  • no_rf_chans : CellParam
  • no_rfiles : SecLockStates
  • no_umts_cells : UmtsNcellParamList
  • no_virtual_active_set_cells : UmtsNcellParamList
  • NoAnimation : ItemRendererProperties
  • NoAnswer : AtResponse
  • NoBufferFreeError : BufferPoolManager
  • NoCall : MmCallInfo
  • NoCarrier : AtResponse
  • NoClass : DataCodingScheme
  • NoConnectionId : ObexHeader
  • NoData : RegEncoderDecoder
  • NoDataCompression : PdpContext
  • NodeType : RegIterator
  • NoDialtone : AtResponse
  • NoEntrySelected() : PhonebookApp
  • NoError : ImageEncoder, Image, Camera, BufferPoolManager, PdpContext, SsErrorCode, Sms, File, SvgPlayer, PngDecoder
  • NoErrorNoIconDisplay : Sms
  • NoErrorType : AudioDeviceBase
  • nof_crc_err : BlerTrchInfo
  • nof_entity : T_PB_REF_FILE
  • nof_group : T_PB_DESCRIPTOR
  • nof_rec : T_PB_FILE_DESC
  • nof_repeats : Audio::ToneData
  • nof_slice : T_PB_DESCRIPTOR
  • nof_tones : Audio::ToneData
  • NoFactoryDefaultFileError : File
  • NoFilter : Camera
  • NoFrame : Control
  • NoHeaderCompression : PdpContext
  • NoId : MessageBox
  • NoIndication : SmsIndicationState
  • NoInterworkingAvailable : ShortMessageStatus
  • nom : TestparamReport
  • NoMediaError : File
  • NoMessage() : NoMessage
  • Non : ThaiTextRenderer
  • NonCloneable() : NonCloneable
  • NonCopyable() : NonCopyable
  • None : PbRecordProvider, PdpContext::Authentication, Sms, Accessory, DrmConstraint, MergeProvider, JoinProvider
  • NONE : SerialIoSet
  • NonsharedBinDataDataSource() : NonsharedBinDataDataSource
  • NonTransparent : DataCallContext
  • NonTransparentPreferred : DataCallContext
  • NoObjectId : ObexAbstractTransport
  • NoPngFormatError : PngDecoder
  • NoPowerOn : AlarmManager
  • NoProtocol : PdpContext
  • NoRepeat : CalendarRecord
  • noreply_timer : ForwardingFeature
  • NoResponseFromSme : ShortMessageStatus
  • Normal : TextFormat, ProtocolIdentifier, Cbs::Filter
  • normal : ChineseQuickSortProvider
  • normal_glyph_index_tab : FontRes
  • NormalCall : XCallInfoResponseParser
  • NormalMode : IconState
  • NormalOn : StartUp
  • NormalTone : CustomToneAudioReference
  • NormalUserTone : ToneAudioDevice
  • Norwegian : LanguageManager, DataCodingScheme
  • NoScaling : Camera, VideoChannel
  • NoScSubscription : ShortMessageFailureCause
  • NoServerId : ObexServerInfo
  • NoSmsOnSim : Sms
  • NoSmsStorageCapabilityInUSim : ShortMessageFailureCause
  • NoStackMsgArg() : NoStackMsgArg
  • NotAcceptable : BtObexResponseCode
  • NotConnected : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • note : ToDoRecord::Persist
  • NotEqualsRule() : NotEqualsRule
  • NotEqualType : StandardJoinRule
  • NotFirstAndSecondFilterOp : DualFilterProvider
  • NotFirstOrSecondFilterOp : DualFilterProvider
  • NotFound : BtObexResponseCode
  • NotFoundError : File
  • NotGreaterType : StandardJoinRule
  • Notification : Led, Property, RegEncoderDecoder
  • notification : SmsStatus
  • notification_func : FsRegistrationInfo, fs_registered_info_type
  • NotificationArray : Registry
  • NotificationMsgType : AbstractTransport
  • NotificationTableEntry() : NotificationTableEntry
  • NotificationType : InputMapper, RadioAudioDevice
  • NotificationTypeBandLimitsReached : RadioAudioDevice
  • NotificationTypeStationFound : RadioAudioDevice
  • Notify : InputMapper, BtObservableService, Registry, Zi8InputMapper, T9InputMapper, InformationElement
  • notify_arg : SsNotificationArg
  • NotifyArrival() : UibServiceImpl
  • NotifyAsyncChange() : SmsProvider
  • NotifyAvStateChanged : AbstractTransport
  • NotifyCanceled : Property
  • NotifyContextItemSwitch() : ContextManager
  • NotifyContextSwitch() : ContextManager
  • NotifyDataReady() : RtStreamingSource
  • NotifyDelete() : BrowserViewContainer, BrowserView, ImageViewListBoxModel, ImageView, ImageListBoxModel, BrowserViewContainer, BrowserView
  • NotifyError() : RtStreamingEndPoint
  • NotifyFeatureChange() : Feature
  • NotifyIndArg() : NotifyIndArg
  • NotifyMediaAvailableStatus() : StorageDevice, RootFileSystem
  • NotifyNever : Property
  • NotifyObservers() : ObservableObject
  • NotifyOnData() : SerialSocketThread
  • NotifyOnDataRecv() : SocketRxThread
  • NotifyOnReadyToSend() : SocketRxThread
  • NotifyOutputBufferReleased() : EmzH264Decoder, EmzMpeg4Decoder, EmzH264Decoder
  • NotifyPreviewChanged : Property
  • NotifyPropertyChange() : Item
  • NotifySet : Property
  • NotifyStoppedOnCause() : RtStreamingEndPoint
  • NotifyType : UibApp
  • NotifyValidateSet : Property
  • NotImplemented : BtObexResponseCode
  • NoTitle : MenuProperties
  • NotLessType : StandardJoinRule
  • NotObtainable : ShortMessageStatus
  • NoToneType : AudioPreset
  • NotOpenError : File
  • NotPresent : ValidityPeriodFormat
  • NoTransformation : DeviceContext, CamWin32, Camera, VideoChannel
  • NotScreened : PhoneNumber
  • NotSpecified : TipdBasedActiveWaitDispatcher
  • NotStarted : SocketTestT
  • NoType : PdpContext
  • November : Date
  • nr_of_cells : NeighbourCellList
  • NRegStateIndArg() : NRegStateIndArg
  • NrOfBits : BitField< T >
  • NsApi : PdpContext
  • NsapiAlreadyUsed : PdpContext
  • NullParameter : MediaManager, CodecDevice
  • NullProtocol : PdpContext
  • num_file : JarFileStatusInfo, JarBinDataStatusInfo
  • num_glyphs : tagFont
  • number : PagingMapEntry
  • number_entry : JarFileGlobalInfo_s
  • NumberCount() : PhonebookApp
  • NumberIdentificationAction() : NumberIdentificationAction
  • NumberingPlanIdentification : TypeOfAddress
  • NumberNotAllowed : PhoneNumber
  • NumberOfPwAttemptsViolation : SsErrorCode
  • NumberPrompt() : NumberPrompt
  • NumberProv : PhonebookApp
  • NumberType : ContextFeature
  • Numeric : InputMapper
  • NumericInputMapper() : NumericInputMapper
  • NumericMode : EditBox
  • NvRamDataRecordHandler() : NvRamDataRecordHandler
  • NwDiscStartIndMsg() : NwDiscStartIndMsg
  • NXorRop : DeviceContext
Generated on Wed Jan 25 00:54:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • OAbort : ObexServer
  • obex_channel() : emcpp_apoxi_OBEXAdapter
  • obex_implementation() : emcpp_apoxi_OBEXAdapter
  • obex_target : BtObexServiceTable::Entry
  • ObexAbortRequest() : BtObexController
  • ObexAbstractPort() : ObexAbstractPort
  • ObexAbstractTransport : ObexAbstractTransport, ObexMngr
  • ObexAddHeader() : BtObexController
  • ObexAddress() : ObexAddress
  • ObexAddrMsg() : ObexAddrMsg
  • ObexAppMsg() : ObexAppMsg
  • ObexBuffer() : ObexBuffer
  • ObexByteOrder : ObexHeader
  • ObexChannel() : ObexChannel
  • ObexClient() : ObexClient
  • ObexClientAddr() : ObexClientAddr
  • ObexClientDispatcher() : ObexClientDispatcher
  • ObexClientOppImpl : ObexOppClient
  • ObexClientPort : ObexClientPort, ObexClientDispatcher
  • ObexConnectRequest() : BtObexController
  • ObexDataBufferIndication() : BtObexController
  • ObexDataIndication() : BtObexController
  • ObexDataServer() : ObexDataServer
  • ObexDiscardHeaders() : BtObexController
  • ObexDisconnectRequest() : BtObexController
  • ObexDispatcher : ObexDispatcher, ObexEventHandler
  • ObexError : ObexResult
  • ObexEventHandler() : ObexEventHandler
  • ObexFtpDataServer() : ObexFtpDataServer
  • ObexFtpServer() : ObexFtpServer
  • ObexGetFreeSize() : BtObexController
  • ObexGetRequest() : BtObexController
  • ObexHeaderBuilder : ObexHeaderBuilder, ObexHeader
  • ObexHeaderList : ObexHeaderList, ObexHeaderList::ConstIterator, ObexHeaderBuilder, ObexHeader
  • ObexLayer : ObexLayer, ObexMngr
  • ObexMsg() : ObexMsg
  • ObexObject : ObexObject, ObexObjectData
  • ObexObjectData : ObexHeaderList
  • ObexOperationId() : ObexOperationId
  • ObexOppBinDataPushClient() : ObexOppBinDataPushClient
  • ObexOppClient() : ObexOppClient
  • ObexOppClientOperation() : ObexOppClientOperation
  • ObexOppClientPull : ObexOppClient
  • ObexOppClientPush : ObexOppClient
  • ObexOppDataSinkPushServer() : ObexOppDataSinkPushServer
  • ObexOppServer : ObexOppServer, ObexMngr
  • ObexOppServerTest : ObexMngr
  • ObexProtocol() : ObexProtocol
  • ObexPutRequest() : BtObexController
  • ObexRegisterClientRequest() : BtObexController
  • ObexRegisterServerRequest() : BtObexController
  • ObexResult() : ObexResult
  • ObexSendResponse() : BtObexController
  • ObexServer : ObexServer, ObexMngr
  • ObexServerAddr() : ObexServerAddr
  • ObexServerDispatcher() : ObexServerDispatcher
  • ObexServerInfo : ObexServerInfo, ObexMngr
  • ObexServerMngr : ObexServerMngr, ObexServerInfo
  • ObexServerOppImpl : ObexOppServer
  • ObexServerPort : ObexServerPort, ObexServerDispatcher
  • ObexServerVisitor() : ObexServerVisitor
  • ObexSetPathRequest() : BtObexController
  • ObexTransportMsg() : ObexTransportMsg
  • ObexTransportSet : ObexTransportSet, ObexTransportSet::Iterator
  • ObexTransportWin() : ObexTransportWin
  • ObexTriggerMsg() : ObexTriggerMsg
  • ObexUnregisterClientRequest() : BtObexController
  • ObexUnregisterServerRequest() : BtObexController
  • ObexUrlStrParser() : ObexUrlStrParser
  • ObexVCardMsg() : ObexVCardMsg
  • Obj : InternalTracer
  • ObjectClass : ObexHeader
  • ObjectCreate : InternalTracer
  • ObjectDestroy : InternalTracer
  • ObjectDistributionIndicator : InformationElement
  • ObjectId : ObexAbstractTransport
  • ObjectNotWritable : ObexResult
  • ObjectObtainer : ObjectObtainer, ObtainableObject
  • ObjectReference : GuiObjectFactory
  • ObjectTreeService() : ObjectTreeService
  • ObservableObject : ObservableObject, Observer
  • ObserveProvider() : PbAdvDataHandler, ProviderProxyItem
  • Observer() : Observer
  • ObserverPtr : ObservableObject
  • Obtain() : SimpleSemaphore, Semaphore, SimpleMutex, SemObtainer, SimpleSemaphore, Semaphore, MutexObtainer, Mutex, AppMutex, DeviceContext
  • ObtainableObject() : ObtainableObject
  • ObtainBackgroundImages() : Image
  • ObtainBuffer() : ObexObject
  • ObtainDecoder() : CodecManager
  • ObtainEncoder() : CodecManager
  • ObtainerProp : GuiObjectFactory
  • ObtainItemRenderer() : GuiEngineConfig
  • ObtainMemMap() : RamData, DataSourceBinData, BinData, FileBinData
  • ObtainMimeType() : ObexHeaderList
  • ObtainMutex() : AbstractTextRenderer
  • OConnect : ObexServer
  • October : Date
  • ODisconnect : ObexServer
  • Off : Led, Control::NavigationGuidance
  • Offset : ObexBuffer
  • offset_central_dir : JarFileStatusInfo, JarBinDataStatusInfo
  • offset_curfile : FileInfoInternal_s
  • offset_local_extrafield : FileInReadStatusInfo, BinDataInReadStatusInfo
  • offset_table : tagFont, tagLanguage
  • OffShiftstate : EditBox
  • OGet : ObexServer
  • OilpaintFilter : Camera
  • Ok : ObexResult, BtObexResponseCode, SimpleMap< TKey, TValue >, MessageBox, ExtPsdContextListener_SerialTerminal, SerialTerminal, AtResponse
  • OkCancel : MessageBox
  • OkId : MessageBox
  • oldpwd : SecLockCommand
  • OmBandStatusCnfArg() : OmBandStatusCnfArg
  • OmBandStatusReqArg() : OmBandStatusReqArg
  • OmControlIndArg() : OmControlIndArg
  • OmFactoryResetIndArg() : OmFactoryResetIndArg
  • OmGetTermProfileCnfArg() : OmGetTermProfileCnfArg
  • OmGetTermProfileReqArg() : OmGetTermProfileReqArg
  • OmMultiSlotIndArg() : OmMultiSlotIndArg
  • OmMultiSlotIndMsg() : OmMultiSlotIndMsg
  • OmMultiSlotReqArg() : OmMultiSlotReqArg
  • OmPowerUpArg() : OmPowerUpArg
  • OmRatChangeCnfArg() : OmRatChangeCnfArg
  • OmRatChangeIndArg() : OmRatChangeIndArg
  • OmRatChangeReqArg() : OmRatChangeReqArg
  • OmSetTermProfileCnfArg() : OmSetTermProfileCnfArg
  • OmSetTermProfileRejArg() : OmSetTermProfileRejArg
  • OmSetTermProfileReqArg() : OmSetTermProfileReqArg
  • On() : Led
  • on_time : Led::Frame
  • OnAbort() : ObexServerOppImpl, ObexServer, ObexOppServer, ObexLayer, ObexDataServer, ObexClientOppImpl, ObexClient, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnAbortResponse() : SaProviderImpl, GltpProviderImpl, LcsProviderImplBase, LcsProviderImpl
  • OnAccessoryInd() : AccDispatcher
  • OnActionExecuted() : VoiceMemoWin, SoundBrowserWin, SoundBrowserTestWin, SocketTestWin, SocketTestSettingsWin, SocketTestResultsWin, SocketTestProgressWin, LcsOptionsMenuWin, LcsMainMenuWin, IrdaWin, ImageBrowserTestWin, CameraSettingsWin, CameraOptionSettingsWin, PbSelectNumberWin, PbSelectNoType, PbSelectGroup, Window, MessageBox, ContextMenu, AtlWindow, AtlApplicationPlugin
  • OnActivate() : MenuAccessor, AbstractMenuAccessor
  • OnActivateCompleted() : PdpContextControl
  • OnActivateContextIndication() : PdpContextManagerControl
  • OnActivationStatusContextIndication() : PdpContextControl
  • OnActiveTabChanged() : TabControl
  • OnAddrResponse() : DnsClientTest, DnsClient
  • OnAfterPppRelease() : PppDataConn, CsdDataConn
  • OnAocInd() : AocDispatcher
  • OnAppClose() : BtHsAppPlugin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, AtlApplicationPlugin
  • OnAppGetFocus() : AtlApplicationPlugin
  • OnAppLoseFocus() : AtlApplicationPlugin
  • OnAppOpen() : BtHsAppPlugin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, AtlApplicationPlugin
  • OnArg : StackMsgArgMap< T >
  • OnAsyncEvent() : UdpTestSocket, TcpTestSocket, TcpServerTestSocket, RegTcpSocket, LcsSocket, TcpNetAdapter, UdpNetAdapter, InetSocket, HttpSocket, HttpServerSocket, FtpSocket, FtpServerSocket, FtpDataSocket, FtpDataServerSocket
  • OnAtAlphaTagReq() : AtcDispatcher
  • OnAtPbListReq() : AtcDispatcher
  • OnAtPbSelectReq() : AtcDispatcher
  • OnAttachAllowedInd() : PlmnDispatcher
  • OnAttachCnf() : PlmnDispatcher
  • OnAttachCompleted() : PdpContextManagerControl
  • OnAttachRej() : PlmnDispatcher
  • OnAttachRep() : PdpContextManagerControl
  • OnAttachStatusIndication() : PdpContextManagerControl
  • OnAudioMessageCallback : AudioDeviceManager
  • OnAuthenticateCompleted() : PsdDataConn, PdpContextControl
  • OnAuthorizationRequired() : BtApplication
  • OnAvrcpCommand() : BtAvrcpCommandInterface
  • OnAvrcpNotification() : BtAvrcpPanelApplication
  • OnAvStateChanged() : IrdaTransport, AbstractTransport
  • OnBack() : Menu
  • OnBandSelectionInd() : NetworkDispatcher
  • OnBdnInd() : SimDispatcher
  • OnBeforePppSetup() : PppDataConn, CsdDataConn
  • OnBeginOperation() : ObexServerOppImpl, ObexServer
  • OnBind() : ObexServerDispatcher, ObexFtpServer, ObexFtpDataServer, RfsObexFtpServer
  • OnBlinkTimer() : AbstractEditBox
  • OnBootDispatching() : BootDispatcher
  • OnBtActivated() : BtApplication
  • OnBufferRequested() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnBufferSwitch() : RtStreamingSource, DataSourceRtStreamingSource
  • OnCallControlIndMsg() : SsWaitDispatcher
  • OnCallEventMessage() : BtHsService, BtHfService
  • OnCallTransferToHeadset() : BtHsProfileService
  • OnCallTransferToPhone() : BtHsProfileService
  • OnCancel() : ToDoDateDialogWin, SoundBrowserWin, SoundBrowserTestWin, RenameFileDialog, BrowserSaveWin, ObexTransportWin, ServerAddressWin, SelfLocationDialog, GltpAidingDataWin, TransferLocationDialog, LocationVerifWin, ImageBrowserWin, ImageBrowserTestWin, ImageBrowserDetailWin, RenameFileDialog, BrowserSaveWin, FmRadioSelectStrongerFreq, FmRadioEditWin, CalendarMonthWin, CalendarGotoDateWin, BtHsVolumeSettingsWin, BtHfVolumeSettingsWin, BtHfFeatureListWin, BtHfAudioPathWindow, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtRequestRunningWindow, PbSelectNumberWin, PbBaseWin, PbAbstractWin, MenuWindow, DialogWindow, PropertyEditor, AtlWindow
  • OnCbsLimitInd() : CbsDispatcher
  • OnCbsNewDataInd() : CbsDispatcher
  • OnCbsStartCnf() : CbsStartDispatcher
  • OnCbsStartRej() : CbsStartDispatcher
  • OnCbsStopCnf() : CbsStopDispatcher
  • OnCbsStopRej() : CbsStopDispatcher
  • Once : Animation
  • OnCellInfoInd() : NetworkDispatcher
  • OnCfuDataInd() : SimDispatcher
  • OnChangedLayout() : EditorDocument, MultiMediaEditorDocument
  • OnChangeStatus() : CheckBox
  • OnChannelClosed() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • OnChannelOpened() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • OnChannelsMatch() : ObexServerDispatcher, ObexServer, ObexClientDispatcher, ObexClient
  • OnChargeInd() : AocDispatcher
  • OnChargeUnitsInd() : AocDispatcher
  • OnChildProviderModification() : SortProvider, FindProvider, FilterProvider, AbstractDelegationProvider, MergeProvider, AppendProvider
  • OnClick() : AbstractButton
  • OnClose() : VoiceMemoRecordWin, VoiceMemoApp, UibSettingsWin, UibApp, ToDoListWin, ToDoComposeWin, SoundBrowserWin, SoundBrowserApp, SocketTestProgressWin, FfsTestDispWin, RegApp, ObexTransportWin, ServerAddressWin, LcsSettingsApp, GltpConnApp, TransferLocationDialog, LcsMainApp, IrdaWin, SavingProgressWin, ImageBrowserWin, ImageBrowserDetailWin, ImageBrowserApp, FmRadioWindow, FmRadioApplication, AbstractSmsViewerWin, AbstractSmsApp, DataConnApp, CameraViewFinderWin, CameraSettingsWin, CameraCaptureWin, CameraApp, CalendarListWin, CalendarAddRecordWin, BtApplication, BtAvrcpPanelApplication, PhonebookApp, PbAbstractWin, ObexServerDispatcher, ObexFtpServer, ObexClientOppImpl, ObexClientDispatcher, ObexClient, Application, Window, Alert, AtlItemGridWindow, AtlApplication
  • OnComplete() : ObexServerOppImpl, ObexServer, ObexProtocol
  • OnConfirm() : UibSettingsWin, ToDoPriorityDialogWin, ToDoDateDialogWin, SoundBrowserWin, RenameFileDialog, InfoDialog, BrowserSaveWin, RegAppFirstWin, ObexTransportWin, ServerAddressWin, SelfLocationDialog, GltpAidingDataWin, TransferLocationDialog, LocationVerifWin, ImageBrowserWin, RenameFileDialog, InfoDialog, BrowserSaveWin, FmRadioSelectStrongerFreq, FmRadioEditWin, DataConnOptionWin, CalendarGotoDateWin, CalendarDialogWin, BtDeviceSearchModeWindow, BtTurnOnOffWindow, BtHsVolumeSettingsWin, BtHsInbandSettingWin, BtHsConnectionSettingWin, BtHfVolumeSettingsWin, BtHfFeatureListWin, BtHfInbandSettingWin, BtHfAudioPathWindow, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtAvrcpDeviceListWin, BtAvrcpControllerDeviceListWindow, BtAvrcpControllerApplicationWindow, PbSelectNumberWin, PbBaseWin, PbAdvAddEditEntry, PbAbstractWin, DialogWindow, AtlWindow
  • OnConnect() : BtHsProfileService, BtAvrcpProfileOperationService, ObexServerOppImpl, ObexServer, ObexLayer, ObexFtpServer, ObexFtpDataServer, ObexDataServer, ObexClientOppImpl, ObexClient, AudioGatiServer, GatiServer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver, RfsObexFtpServer
  • OnConnectableMode() : BtLocalSettings
  • OnConnectActionExecuted() : BtDeviceListWindow
  • OnConnectCompleted() : PsdDataConn, PdpContextControl
  • OnConnectionInd() : NetworkDispatcher
  • OnConnectNotification() : BtHfAppPlugin
  • OnConnectRequestFinished() : BtAvrcpControllerApplicationWindow
  • OnContentConsumedEnd() : DrmAsset, DrmRightsObjectContainer, DrmRightsObject, DrmPermission, DrmConstraint
  • OnContentConsumedStart() : DrmAsset, DrmRightsObjectContainer, DrmRightsObject, DrmPermission, DrmConstraint
  • OnContextFeatureTriggered() : UibApp, LcsMainApp, AbstractSmsApp, DataConnApp, BtHsAppPlugin, BtHfAppPlugin, AtlApplicationPlugin, AtlApplication
  • OnContextSwitched() : AtlItemMenuWindow, AtlWindow
  • OnControllerMessage() : BtHsService, BtHfService
  • OnControlMsg() : UdpSocket, TcpSocket, TcpServerSocket, Socket, InetSocket, SerialSocket
  • OnCursorDown() : AbstractEditBox
  • OnCursorLeft() : AbstractEditBox
  • OnCursorRight() : AbstractEditBox
  • OnCursorUp() : AbstractEditBox
  • OnDataAvailable() : ObexOppServer, ObexOppClient, ObexFtpDataServer, ObexDataServer
  • OnDataComplete() : ObexOppDataSinkPushServer, ObexDataServer
  • OnDataProcessed() : ObexServerOppImpl, ObexServer, ObexOppServer, ObexOppClient, ObexLayer, ObexClientOppImpl, ObexClient
  • OnDataRcvdMsg() : OnDataRcvdMsg
  • OnDataReceived() : NetAdapterHandler, AudioGatiServer, GatiServer
  • OnDataRequested() : ObexFtpDataServer, ObexDataServer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnDataSent() : NetAdapterHandler
  • OnDeactivate() : MenuAccessor, AbstractMenuAccessor
  • OnDeactivateCompleted() : PsdDataConn, PdpContextControl
  • OnDeactivateIndication() : PsdDataConn, PdpContextControl
  • OnDefineCompleted() : PsdDataConn, PdpContextControl
  • OnDelete() : ObexFtpDataServer, ObexDataServer
  • OnDeleteChar() : TimeEditBox, EditBox, DateEditBox, AbstractEditBox
  • OnDeleteObject() : ObexFtpServer, RfsObexFtpServer
  • OnDeRegister() : BtAvrcpProfileRegistrationService
  • OnDetachCnf() : PlmnDispatcher
  • OnDetachCompleted() : PdpContextManagerControl
  • OnDetachIndication() : PdpContextManagerControl
  • OnDeviceListWindowClose() : BtHfProfileWindow
  • OnDeviceNameFound() : BtDeviceListWindow
  • OnDeviceSelectActionExecuted() : BtDeviceListWindow
  • OnDisconnect() : BtAvrcpProfileOperationService, ObexServerOppImpl, ObexServer, ObexLayer, ObexFtpDataServer, ObexDataServer, ObexClientOppImpl, ObexClient, AudioGatiServer, GatiServer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnDisconnected() : ObexServer, ObexFtpServer, ObexFtpDataServer, RfsObexFtpServer
  • OnDisconnectNotification() : BtHfAppPlugin
  • OnDisconnectRequestFinished() : BtAvrcpControllerApplicationWindow
  • OnDiscoverableMode() : BtLocalSettings
  • OnDisonnect() : BtHsProfileService
  • OnDisplaySms() : SmsViewerWin, AbstractSmsViewerWin, EmsViewerWin
  • OnDocumentChanged() : EmsEditorListener, EmsComposeWin
  • OnDtmfSeparator() : EditBox
  • OnDunDisconnectRequestFinished() : BtDunAppPlugin
  • One_Day : AbstractSmsApp
  • One_hour : AbstractSmsApp
  • One_Week : AbstractSmsApp
  • OneByte : Tlv
  • OnEccListInd() : SimDispatcher
  • OnEndOfExecute() : UpdatePbThreadlet, SyncPhoneThreadlet, Threadlet
  • OnEngineeringModeControlResponse() : NetworkDispatcher
  • OnError() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnErrorNotification() : VoiceMemoApp, SoundBrowserWin
  • OnEvent() : BtObexServiceObserver, BtObexServerServiceObserver, BtObexClientServiceObserver, BtServiceObserver, BtSddbServiceObserver
  • OnExecuting() : PbProviderListener, ProviderListener, DelegationProviderListener, JoinProviderListener
  • OnExecutingListener() : SortProvider, FindProvider, FilterProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, AppendProvider
  • OnExportConfirmation() : AbstractSmsUtilityProcessor, AbstractSmsApp, EmsApp
  • OnFailure() : ObexOppClientPull, ObexOppClientPush, ObexOppClientOperation
  • OnFaxDisconnectRequestFinished() : BtFaxAppPlugin
  • OnFdnInd() : SimDispatcher
  • OnFeatureAdded() : MenuPool, FeatureBroker
  • OnFeatureChanged() : AtlItemBox
  • OnFeatureStatusChanged() : MenuPool, FeatureBroker
  • OnFeatureTriggered() : VoiceMemoApp, UibApp, ToDoApp, SoundBrowserApp, RegApp, LcsSettingsApp, LcsMainApp, ImageBrowserWin, ImageBrowserApp, FmRadioApplication, AbstractSmsApp, EmsApp, DataConnApp, CameraApp, CalendarApp, BtHsAppPlugin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, BtDeviceListWindow, BtApplication, BtAvrcpPanelApplication, AtlApplicationPlugin, AtlApplication
  • OnFilePull() : ObexFtpServer, RfsObexFtpServer
  • OnFilePullRequestCompleted() : ObexFtpServer, RfsObexFtpServer
  • OnFilePush() : ObexFtpServer, RfsObexFtpServer
  • OnFilePushRequestCompleted() : ObexFtpServer, RfsObexFtpServer
  • OnFileRequest() : HttpClient
  • OnFinished() : ProviderListener
  • OnFinishedSmsLoading() : BootControl
  • OnFocusNextControl() : TabControl, GridLayout, FlowLayout, Control
  • OnFocusPreviousControl() : TabControl, GridLayout, FlowLayout, Control
  • OnGet() : ObexServerOppImpl, ObexServer, ObexLayer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnGetComplete() : ObexFtpDataServer, ObexDataServer, ObexClientOppImpl, ObexClient
  • OnGetFocus() : UibFolderWin, UibApp, ToDoListWin, FileNameView, LcsMainMenuWin, ImageView, FileNameView, SmsViewerWin, SmsEditor, CameraViewFinderWin, CameraCaptureWin, CalendarListWin, CalendarGrid, BtAvrcpDeviceListWin, BtAvrcpControllerDeviceListWindow, BtAvrcpControllerApplicationWindow, ProvListBoxWin, PbDetails, PbBaseWin, PbAbstractWin, Application, Window, IpAddrInputMapper, InputMapper, GridLayout, DateTimeInputMapper, Control, AbstractMultiLineEditor, AbstractItemGrid, AbstractGrid, AbstractEditor, EditBox, CheckBox, AbstractEditBox, AtlItemGridWindow, AtlWindow, AbstractPredictiveInputBox
  • OnGetFolderListing() : ObexFtpServer, RfsObexFtpServer
  • OnGetHeaders() : ObexFtpDataServer, ObexDataServer
  • OnGetIncoming() : ObexFtpDataServer, ObexDataServer
  • OnGetResponse() : ObexClientOppImpl, ObexClient
  • OnGprsClassInd() : PlmnDispatcher
  • OnHeader() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnHeaderSent() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnHfNotification() : BtHfAppPlugin
  • OnHfProfileSupported() : BtQuerySupportedProfilesRequest
  • OnHfSettingsWindowClosed() : BtHfProfileWindow
  • OnHomezoneInd() : NetworkDispatcher
  • OnHsCallTransferToHeadsetRequestFinished() : BtHsAppPlugin
  • OnHsCallTransferToPhoneRequestFinished() : BtHsAppPlugin
  • OnHsConnectRequestFinished() : BtHsAppPlugin
  • OnHsDisconnectRequestFinished() : BtHsAppPlugin
  • OnHsProfileSupported() : BtQuerySupportedProfilesRequest
  • OnHttpGetRequest() : HttpClient
  • OnHttpPostRequest() : HttpClient
  • OnHttpRequest() : HttpClient, HttpApplication
  • OnIndicateIncoming() : AbstractSmsApp
  • OnInputChar() : AtlApplicationPlugin
  • OnInputMap() : CalendarMonthSelector, CalendarGrid, Control, Grid, EditBox, CheckBox, AbstractMenuList, AbstractListBox, AbstractEditBox
  • OnInputModeChanged() : ToDoComposeWin, AbstractSmsComposeWin, EmsComposeWin
  • OnItemMarked() : EmsEditor, MultiMediaEditor
  • OnItemSelected() : RadioButtonList, MenuList, CheckBoxList, AbstractMenuList
  • OnKeyAutoRepeat() : Application, GridLayout, Control, AbstractGrid, AtlApplicationPlugin
  • OnKeyDown() : SoundBrowserWin, ObexTransportWin, ImageBrowserWin, ImageBrowserDetailWin, CalendarGrid, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtAvrcpControllerApplicationWindow, PbNameEditBox, PbDetailEditBox, PbBaseWin, PbAbstractWin, Application, Window, TabControl, PredInputMapper, PhoneNumberInputMapper, NumericInputMapper, MultiTapInputMapper, IpAddrInputMapper, InputMapper, GridLayout, FlowLayout, DateTimeInputMapper, Control, CalculatorInputMapper, AbstractMultiLineEditor, AbstractLineEditor, AbstractGrid, AbstractEditor, TimeEditBox, EditBox, DateEditBox, PropertyEditor, AtlItemMenuWindow, AtlItemGridWindow, AtlWindow, AtlApplicationPlugin, MultiMediaEditor
  • OnKeyUp() : Application, InputMapper, Control, AbstractEditor, AtlApplicationPlugin, Zi8InputMapper, T9InputMapper
  • OnLanguageChanged() : AbstractSmsApp, PbAbstractWin, Application, Window, TabControl, Item, DrawableObject, Control, Component, AbstractTextObject, AbstractItemGrid, AbstractButton, SoftkeyBar, RadioButtonList, MenuList, MenuAccessor, Menu, CheckBoxList, CheckBox, AbstractMenuAccessor, FeatureItem, AtlWindow, AtlApplicationPlugin, AbstractActionMenuAccessor
  • OnLayoutClient() : VoiceMemoRecordWin, ToDoDateDialogWin, ToDoComposeWin, SoundBrowserWin, SoundBrowserTestWin, RenameFileDialog, InfoDialog, BrowserSaveWin, RegAppFirstWin, ObexTransportWin, ServerAddressWin, SelfLocationDialog, GltpAidingDataWin, TransferLocationDialog, SatteliteInfoWin, LocationResultWin, SavingProgressWin, ImageBrowserWin, ImageBrowserTestWin, ImageBrowserDetailWin, RenameFileDialog, InfoDialog, BrowserSaveWin, FmRadioWindow, FmRadioEditWin, SmsViewerWin, SmsComposeWin, EmsComposeWin, CameraViewFinderWin, CameraSettingsWin, CameraOptionSettingsWin, CalendarMonthWin, CalendarGotoDateWin, CalendarAddRecordWin, BtHsVolumeSettingsWin, BtHfVolumeSettingsWin, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, PbBaseWin, PbAdvAddEditEntry, Window, TabControl, Panel, MessageBox, GridLayout, FlowLayout, Control, AbstractMultiLineEditor, AbstractGrid, TextList, AbstractListBox, AtlLabelListWindow, Zi8PredictiveInputBox, T9PredictiveInputBox, MultiMediaEditor
  • OnLayoutFrame() : Window
  • OnLevelChange() : ItemMenu
  • OnLocalName() : BtLocalSettings
  • OnLocationError() : SaProviderImpl
  • OnLocationNotifInvoke() : LcsProviderImpl
  • OnLocationResponse() : SaProviderImpl, LcsProviderImpl
  • OnLockedKeyDown() : Application
  • OnLongKeyPress() : Application, PhoneNumberInputMapper, InputMapper, Control, AbstractEditor, AtlApplicationPlugin, Zi8InputMapper, T9PredictiveInputBox, T9InputMapper
  • OnLongKeyPress_T9() : T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper
  • OnLoseFocus() : UibApp, AbstractSmsApp, CameraViewFinderWin, CameraCaptureWin, Application, Window, IpAddrInputMapper, InputMapper, DateTimeInputMapper, Control, AbstractItemGrid, AbstractEditor, EditBox, CheckBox, AbstractEditBox, AtlItemMenuWindow, AtlWindow
  • OnlyOnce : AnimatedTextLine
  • OnlyOnceAnimation : ItemRendererProperties
  • OnMdhNewStatusReportInd() : SmsDispatcher
  • OnMdhSmsDeletion() : SimPduHandler
  • OnMdhSmsDeletionInd() : SmsDispatcher
  • OnMdhSmsInitFinishedInd() : SimDispatcher
  • OnMdhSmsNewMessageInd() : SmsDispatcher
  • OnMdhSmsRefreshInd() : SmsDispatcher
  • OnMdhSmsStorageRefreshInd() : SmsDispatcher
  • OnMdhSmsUpdStatusRefreshInd() : SmsDispatcher
  • OnMdhSmsWaitingInd() : SmsDispatcher
  • OnMeasurementResp() : GltpProviderImpl
  • OnMessage() : VoiceMemoApp, UsbApp, UibPerformanceTest, UibNotifyTest, UibMsgDisplayTest, UibInboxTest, UibFolderWin, UibApp, ToDoListWin, ToDoApp, SoundBrowserWin, SoundBrowserApp, FileNameView, SocketTestApp, RegApp, ObexApp, LcsSettingsApp, GltpConnApp, LcsMainApp, IrdaApp, SavingProgressWin, ImageView, ImageBrowserApp, FileNameView, FmRadioWindow, FmRadioApplication, AbstractSmsApp, CameraCaptureWin, CameraApp, CalendarRecordsList, BtHsVolumeSettingsWin, BtHsAppPlugin, BtHfVolumeSettingsWin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, BtPasskeyRequiredWindow, BtApplication, BtAvrcpPanelApplication, ProvListBoxWin, PhonebookApp, PbBaseWin, AdvPbApp, ServiceThread, MessageMapDispatcher, MessageHook, Dispatcher, Application, Window, TabControl, Model, ItemTree, ItemBox, ImageBox, DrawableObject, Desktop, ContextMenu, Component, Alert, AbstractItemGrid, AbstractEditor, AbstractButton, GenericAudioDevice, SoftkeyBar, SharedTimer, MenuAccessor, Menu, IndicatorBar, AtlItemMenu, AtlItemGrid, AbstractMenuAccessor, BtObexService, BtHsService, BtHfService, BtFaxService, BtDunService, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtSendPasskeyRequest, BtSddbService, BtRespondAuthorizationRequest, BtQuerySupportedProfilesRequest, BtLocalSettings, BtLocalRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtBppService, BtAvrcpService, BtAvrcpOperationService, MmfPlayer, AtlLabelListWindow, AtlItemMenuWindow, AtlItemGridWindow, AtlItemBox, AtlWindow, AtlApplicationPlugin, AtlApplication, StackMsgDispatcher, SimTkLceService, Zi8PredictiveInputBox, UsbTransport, T9PredictiveInputBox, SvgPlayer, HttpServer, FtpServer, SaProviderImpl, GltpProviderImpl, LcsProviderImpl, WapHandler, HttpHandler, SimUserDispatcher
  • OnMnInformationInd() : NetworkDispatcher
  • OnMove() : Window, ImageBox, DrawableObject, Control, Component
  • OnMoveDown() : Grid
  • OnMoveLeft() : Grid
  • OnMoveRight() : Grid
  • OnMoveUp() : Grid
  • OnNameResponse() : DnsClientTest, DnsClient
  • OnNetAdapterClosed() : NetAdapterHandler
  • OnNewStatusReportArrived() : SimPduHandler
  • OnNextItem() : TextList, AbstractListBox
  • OnNotifyMediaAvailableStatus() : StorageDevice
  • OnNRegStateInd() : PlmnDispatcher
  • OnObexAddrMsg() : ObexServerDispatcher, ObexEventHandler, ObexClientDispatcher
  • OnObexMsg() : ObexServerDispatcher, ObexEventHandler, ObexClientDispatcher
  • OnObexTransportMsg() : ObexServerDispatcher, ObexEventHandler, ObexClientDispatcher
  • OnOmBandStatusCnf() : NetworkDispatcher
  • OnOmControlInd() : PowerDispatcher
  • OnOmMultiSlotInd() : MultiSlotDispatcher
  • OnOmRatChangeCnf() : PlmnRatDispatcher
  • OnOmRatChangeInd() : PlmnDispatcher
  • ONone : ObexServer
  • OnOpen() : VoiceMemoApp, UsbApp, UibSettingsWin, UibFolderWin, UibApp, ToDoListWin, ToDoPriorityDialogWin, ToDoDateDialogWin, ToDoApp, SoundBrowserWin, SoundBrowserApp, RenameFileDialog, BrowserSaveWin, SocketTestWin, SocketTestProgressWin, SocketTestApp, FfsTestDispWin, RegAppWin, RegAppFirstWin, RegApp, ObexApp, ServerAddressWin, SelfLocationDialog, LcsSettingsApp, GltpAidingDataWin, GltpConnApp, TransferLocationDialog, LocationVerifWin, LcsOptionsMenuWin, LcsMainMenuWin, LcsMainApp, IrdaWin, IrdaApp, SavingProgressWin, ImageBrowserWin, ImageBrowserDetailWin, ImageBrowserApp, RenameFileDialog, BrowserSaveWin, FmRadioWindow, FmRadioSelectStrongerFreq, FmRadioApplication, SmsSendingConfirmDialog, SmsComposeWin, AbstractSmsApp, EmsApp, DataConnWin, DataConnApp, CameraViewFinderWin, CameraSettingsWin, CameraOptionSettingsWin, CameraCaptureWin, CameraApp, CalendarRecordsList, CalendarMonthWin, CalendarListWin, CalendarDialogWin, CalendarApp, BtDeviceSearchModeWindow, BtTurnOnOffWindow, BtHsVolumeSettingsWin, BtHsInbandSettingWin, BtHsConnectionSettingWin, BtHfVolumeSettingsWin, BtHfFeatureListWin, BtHfInbandSettingWin, BtHfAudioPathWindow, BtDeviceListWindow, BtDeviceDetailWindow, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtRequestRunningWindow, BtApplication, BtActiveDeviceWindow, BtAvrcpDeviceListWin, BtAvrcpPanelApplication, BtAvrcpControllerDeviceListWindow, BtAvrcpControllerApplicationWindow, PhonebookApp, PbSelectNumberWin, PbPhoneNumberPrompt, PbAdvAddEditEntry, PbAbstractWin, ObexClientOppImpl, ObexClientDispatcher, ObexClient, Application, Window, AtlLabelListWindow, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow, AtlWindow, AtlApplication
  • OnOpenMenu() : AtlApplication
  • OnOperationFinished() : BtDeviceListWindow
  • OnPagingTimer() : EditBox
  • OnPaint() : SocketTestWin, SocketTestProgressWin, FfsTestDispWin, SatteliteGraphWin, CameraViewFinderWin, CameraCaptureWin, Control, Alert, AbstractMultiLineEditor, AbstractItemGrid, AbstractGrid, AbstractEditor, AbstractListBox, MultiMediaEditor
  • OnPairableMode() : BtLocalSettings
  • OnPairDeviceActionExecuted() : BtDeviceListWindow
  • OnPairDeviceActionFinished() : BtDeviceListWindow
  • OnPanelPassThrough() : BtAvrcpProfileOperationService, BtAvrcpPanelApplication, BtAvrcpOperationService
  • OnPanelPassthrough() : BtAvrcpProfileOperationService
  • OnPanelPassthroughRequestFinished() : BtAvrcpControllerApplicationWindow
  • OnPaProfileSupported() : BtQuerySupportedProfilesRequest
  • OnPasskeyRequired() : BtApplication
  • OnPbWindowClosed() : PhonebookApp, AdvPbApp
  • OnPenDown() : AbstractListBox
  • OnPenUp() : AbstractMenuList
  • OnPhoneNumberRequired() : BtHfProfileWindow, BtHfProfileService
  • OnPlmnListCnf() : PlmnScanDispatcher, PlmnDispatcher
  • OnPlmnListRej() : PlmnScanDispatcher, PlmnDispatcher
  • OnPlus() : EditBox
  • OnPowerDown() : SocketSubSystem, SubSystem, ServiceThread, GenericWorkerTask, GatiManager, BtController, StackControl, SimTkLceService, KeyMsgGenerator, RegManager, UsbSubSystem, DrmSubsystem, DataControl
  • OnPowerDownCnf() : PowerDownDispatcher
  • OnPowerUp() : SocketSubSystem, SubSystem, ServiceThread, GenericWorkerTask, IrdaObexSubSystem, GatiManager, BtObexSubSystem, BtController, AudioPresetStore, StackControl, SimTkLceService, KeyMsgGenerator, RegManager, UsbSubSystem, SerialSocketSubSystem, DrmSubsystem, DataControl
  • OnPppSetup() : PppDataConn
  • OnPppStop() : PppDataConn
  • OnPreviousItem() : TextList, AbstractListBox
  • OnProfileActivation() : BtLocalSettings
  • OnPropertyNotification() : UibApp, LcsSettingsApp, IrdaApp, FmRadioApplication, AbstractSmsApp, CameraApp, BtApplication, AtlApplicationPlugin, AtlApplication
  • OnProvideFolderListingEntries() : ObexFtpServer, RfsObexFtpServer
  • OnPsdLinkDownCompleted() : PsdDataConn
  • OnPsdLinkUpCompleted() : PsdDataConn
  • OnPull() : ObexOppServer
  • OnPullComplete() : ObexOppServer, ObexOppClient
  • OnPullConfirmed() : ObexOppClient
  • OnPush() : ObexOppServer, WapHandler
  • OnPushComplete() : ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexOppBinDataPushClient
  • OnPushConfirmed() : ObexOppClient
  • OnPushIncoming() : ObexOppDataSinkPushServer
  • OnPut() : ObexServerOppImpl, ObexServer, ObexLayer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnPutComplete() : ObexFtpDataServer, ObexDataServer, ObexClientOppImpl, ObexClient
  • OnPutHeaders() : ObexFtpDataServer, ObexDataServer
  • OnPutIncoming() : ObexFtpDataServer, ObexDataServer
  • OnPutResponse() : ObexClientOppImpl, ObexClient
  • OnQuerySupportedProfileFinished() : BtDeviceListWindow
  • OnRawFrame() : BtAvrcpProfileOperationService, BtAvrcpOperationService
  • OnReactivateIndication() : PdpContextControl
  • OnReadCounterCompleted() : PsdDataConn, PdpContextControl
  • OnReadNegotiatedDnsServerAddressCompleted() : PsdDataConn, PdpContextControl
  • OnRecordingFinished() : StreamAudioPlayer
  • OnRegister() : BtAvrcpProfileRegistrationService, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnRegisterService() : BtObexSddbServiceObserverImpl, BtSddbServiceObserver
  • OnRegStateInd() : PlmnDispatcher
  • OnRelease() : ObexServerDispatcher, ObexBuffer::Factory, AbstractButton
  • OnReleaseCompleted() : CsdDataConn, DataCallControl
  • OnReleaseResponse() : PsdDataConn
  • OnRemoteConnect() : BtHfProfileWindow
  • OnRemoteDeviceFound() : BtDeviceSearchRequest
  • OnRemoteDeviceName() : BtApplicationDeviceSearchRequest, BtDeviceSearchRequest
  • OnRemoteDeviceSetNameNotification() : BtDeviceListWindow
  • OnRemoteDisconnect() : BtHfProfileWindow
  • OnRepMolrTimeOut() : LcsReqProcessor
  • OnRequestCancel() : BtRequestRunningWindow
  • OnRequestFinished() : BtDeviceListWindow, BtDeviceDetailWindow
  • OnRequestStateChange() : BtHsProfileService, BtHfProfileService, BtFaxProfileService, BtDunProfileService, BtApplicationServiceVerifyRequest, BtApplicationDeviceSearchRequest, BtApplicationSetRemoteDeviceNameRequest, BtApplicationQuerySupportedProfilesRequest, BtApplicationDeviceUntrustRequest, BtApplicationDeviceTrustRequest, BtApplicationDeviceUnpairRequest, BtApplicationDevicePairRequest, BtApplicationRespondAuthorizationRequest, BtApplicationSendPasskeyRequest, BtAvrcpProfileOperationService, BtAvrcpProfileRegistrationService, BtObexServerServiceImpl, BtObexSddbImpl, BtObexClientServiceImpl, BtService, BtLocalRequest, BtBipServerService
  • OnResize() : Window, ItemBox, ImageBox, DrawableObject, Control, Component, AnimatedTextLine, AbstractMultiLineEditor, AbstractItemGrid, AbstractListBox
  • OnResponse() : ObexLayer, BtObexClientObserverImpl, HttpHandler
  • OnResult() : BtObexClientAddrResultNotifier, BtOperationBase
  • OnRfComChannel() : BtObexRegisterServerRequest
  • OnRollback() : DrmAsset, DrmRightsObjectContainer, DrmRightsObject, DrmPermission, DrmConstraint
  • OnSdlSignal() : DwdPlayer, MapiAudioPlayer
  • OnSearchAgainActionExecuted() : BtDeviceListWindow
  • OnSearchAgainActionFinished() : BtDeviceListWindow
  • OnSelectionChanged() : UibFolderWin, ToDoListWin, ImageViewListBoxModel, ImageListBoxModel, DataConnLbModel, BtAvrcpDeviceListWin, BtAvrcpControllerDeviceListWindow, PbProvListBox, ItemMenu, AbstractItemGrid, AbstractGrid, MenuAccessor, Menu, Grid, AbstractMenuAccessor, AbstractListBox, AtlLabelListWindow, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow
  • OnServiceVerifyRequestExecuted() : BtDeviceListWindow
  • OnServiceVerifyRequestFinished() : BtDeviceListWindow
  • OnServiceVerifyResultReceived() : BtServiceVerifyRequest
  • OnSetAutomaticDnsServerNegotiationCompleted() : PsdDataConn, PdpContextControl
  • OnSetCounterCompleted() : PsdDataConn, PdpContextControl
  • OnSetCurrentFolder() : ObexFtpServer, RfsObexFtpServer
  • OnSetDeviceNameActionExecuted() : BtDeviceListWindow
  • OnSetMinimumQualityOfServiceCompleted() : PdpContextControl
  • OnSetPacketFilterCompleted() : PsdDataConn, PdpContextControl
  • OnSetPath() : ObexServer, ObexLayer, ObexFtpDataServer, ObexDataServer, ObexClient, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnSetQualityOfServiceCompleted() : PsdDataConn, PdpContextControl
  • OnSetupCompleted() : CsdDataConn, DataCallControl
  • OnSetupResponse() : PsdDataConn
  • OnShiftKey() : EditBox
  • OnShiftstate : EditBox
  • OnShortKeyUp_T9() : T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper
  • OnShowDetailsActionExecuted() : BtDeviceListWindow
  • OnShutdownRequest() : Application
  • OnSignalChange() : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueSignalListener, SioGlueSignalListener, SerialTerminal
  • OnSignalStrengthLevelInd() : SigDispatcher
  • OnSimChanged() : PhonebookApp
  • OnSimChvRefreshInd() : SimDispatcher
  • OnSimErrorInd() : SimDispatcher
  • OnSimFullAccessInd() : SimDispatcher
  • OnSimInfoInd() : SimDispatcher
  • OnSimInitInd() : SimDispatcher
  • OnSimLockStatusInd() : SimDispatcher
  • OnSimMccMncInd() : SimDispatcher
  • OnSimMruPropertyRefreshInd() : SimDispatcher
  • OnSimNotPresent() : PhonebookApp, AdvPbApp
  • OnSimPresent() : PhonebookApp, AdvPbApp
  • OnSimReady() : PhonebookApp, AdvPbApp
  • OnSimRefreshInd() : SimDispatcher
  • OnSimRemoved() : AbstractSmsApp
  • OnSimSmsReady() : AbstractSmsApp
  • OnSimStateChanged() : PhonebookApp
  • OnSmsCapacityAvailable() : SmsDispatcher
  • OnSmsCapacityExceeded() : SmsDispatcher
  • OnSmsSendCnf() : SmsSendDispatcher, SmsDispatcher
  • OnSmsSendRej() : SmsSendDispatcher, SmsDispatcher
  • OnSmsService() : AbstractSmsApp
  • OnSocketEvent() : SocketEventListener
  • OnSoftkeyPressed() : FfsTestDispWin, PbAbstractWin, RadioButtonList, CheckBox, AbstractMenuList
  • OnSoftkeyReleased() : RadioButtonList
  • OnSortingChanged() : UibApp
  • OnSsBarringInd() : SsDispatcher
  • OnSsBeginAcc() : SsWaitDispatcher, SsDispatcher
  • OnSsCauseInd() : SsDispatcher
  • OnSsCcbsReCallInd() : SsCcbsDispatcher
  • OnSsCcbsResultInd() : SsCcbsDispatcher
  • OnSsCcbsStatusInd() : SsCcbsDispatcher
  • OnSsDataInd() : SsDispatcher
  • OnSsEndInd() : SsDispatcher
  • OnSsErrInd() : SsDispatcher
  • OnSsError() : LcsProviderImpl
  • OnSsFacilityRej() : SsWaitDispatcher, SsDispatcher
  • OnSsForwardingInd() : SsDispatcher
  • OnSsForwcheckInd() : SsDispatcher
  • OnSsGetPasswordInd() : SsDispatcher
  • OnSsGetPasswordRej() : SsDispatcher
  • OnSsInterrogateInd() : SsDispatcher
  • OnSsNotifyInd() : SsDispatcher
  • OnSsPasswordInd() : SsDispatcher
  • OnSsRej() : SsDispatcher
  • OnSsRetResInd() : SsDispatcher
  • OnSsUnstructInd() : SsDispatcher
  • OnSsUssdInd() : SsDispatcher
  • OnSsUssdResentInd() : SsDispatcher
  • OnStart() : RealTimeClock, Led, DefaultDisplay, Charger, RealTimeClock, Led, Keyboard, DefaultDisplay, Charger, RealTimeClock, Led, Keyboard, DefaultDisplay, Charger, RealTimeClock, Led, Keyboard, DefaultDisplay, Charger, RealTimeClock, Led, Keyboard, DefaultDisplay, Charger, AbstractDevice
  • OnStarted() : PbProviderListener, ProviderListener, RtStreamingConn
  • OnStartup() : VoiceMemoApp, UibApp, ToDoApp, SoundBrowserApp, SocketTestApp, RegApp, LcsSettingsApp, GltpConnApp, LcsMainApp, ImageBrowserApp, FmRadioApplication, AbstractSmsApp, EmsApp, DataConnApp, CameraApp, CalendarApp, BtApplication, BtAvrcpPanelApplication, PhonebookApp, Application, AtlApplication
  • OnStateChange() : BtLocalSettings
  • OnStop() : RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, AbstractDevice
  • OnStopNotification() : SoundBrowserWin
  • OnStopped() : RtStreamingConn
  • OnSubunitInfo() : BtAvrcpProfileOperationService
  • OnSubUnitInfoRequestFinished() : BtAvrcpControllerApplicationWindow
  • OnSupportedProfileSearch() : BtDeviceListWindow, BtDeviceDetailWindow
  • OnTerminalEvent() : ExtPsdContextListenerImpl_SerialTerminalListener, ExtPsdContextListener_SerialTerminalListener, SocketSerialTerminalListener, SerialTerminalListener, MmCallSerialTerminalListener, MmCallDispatcher
  • OnTerminalResponse() : MmCallHandler
  • OnTestparamInd() : NetworkDispatcher
  • OnThemeChanged() : Application, Window, TabControl, TabButton, RadioButtonControl, PushButton, ProgressBar, PositionIndicator, Panel, MultiLineEditor, GridLayout, FlowLayout, DrawableObject, Control, Component, CheckBoxControl, AbstractTextObject, AbstractItemGrid, AbstractGrid, TextList, SoftkeyBar, RadioButtonList, MenuList, Grid, CheckBoxList, CheckBox, Animation, AbstractListBox, AbstractEditBox, AtlWindow, AtlApplicationPlugin
  • OnTimeout() : VoiceMemoRecordWin, LcsMainApp, BtPasskeyRequiredWindow, ServiceThread, Application, Control, Alert, AbstractItemGrid, AbstractGrid, AbstractListBox, AtlApplicationPlugin
  • OnTimeOut() : SaProviderImpl, GltpProviderImpl, LcsProviderImplBase, LcsProviderImpl
  • OnTimer() : SocketTestProgressWin, SocketTestApp, FfsTestDispWin, SysDnsClient, Timer, DefaultDisplay, VibratorDevice, DefaultDisplay, SharedTriggerTimer< T >, EditBoxPagingTimer, Animation, EditBoxBlinkTimer, TriggerTimer< T >, LcsTimer, LcsRepeatTimer
  • OnToneStopped() : GenericAudioDevice
  • OnTransferAudioToAccessoryNotification() : BtHfAppPlugin
  • OnTransferAudioToPhoneNotification() : BtHfAppPlugin
  • OnTransferCallToHandsfree() : BtHfProfileWindow
  • OnTransferCallToHandsfreeFinished() : BtHfProfileWindow
  • OnTransferCallToPhone() : BtHfProfileWindow
  • OnTransferCallToPhoneFinished() : BtHfProfileWindow
  • OnTransportDisconnect() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnTransportError() : ObexProtocol
  • OnTrigger() : FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor, MenuAccessor, Menu, ActionMenuAccessor, AbstractActionMenuAccessor
  • OnTriggerNotification() : SocketTestApp, PhonebookApp
  • OnTrustDeviceActionExecuted() : BtDeviceListWindow
  • OnTrustDeviceActionFinished() : BtDeviceListWindow
  • OnUibNotifyService() : UibApp
  • OnUibRegisterService() : UibApp
  • OnUndefineCompleted() : PsdDataConn, PdpContextControl
  • OnUnitInfo() : BtAvrcpProfileOperationService
  • OnUnpairDeviceActionExecuted() : BtDeviceListWindow
  • OnUnpairDeviceActionFinished() : BtDeviceListWindow
  • OnUnregister() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnUnregisterService() : BtObexSddbServiceObserverImpl, BtSddbServiceObserver
  • OnUnsetPacketFilterCompleted() : PdpContextControl
  • OnUntrustDeviceActionExecuted() : BtDeviceListWindow
  • OnUntrustDeviceActionFinished() : BtDeviceListWindow
  • OnUpdate() : UibPerformanceTest, UibInboxTest, UibInboxProvider, UibFolderWin, ObexAbstractTransport, IndicatorPaneObject, IndicatorBar, Observer, AbstractDelegationProvider, ProviderProxyItem, ProviderProxyContainer, UsbObexTransport
  • OnUpdateContextItem() : AtlApplicationPlugin
  • OnUserActivity() : UserActivityListener
  • OnUserConnect() : BtHfProfileWindow
  • OnUserConnectFinished() : BtHfProfileWindow
  • OnUserDisconnect() : BtHfProfileWindow
  • OnUserDisconnectFinished() : BtHfProfileWindow
  • OnVeryLongKeyPress() : Application, AtlApplicationPlugin
  • OnWildcard() : EditBox
  • OnZeroReferrers() : ReferableObject
  • oos_cnt : RrcParam
  • OpDeterminedBarring : Sms
  • Open() : LocResController, FfsDataConnProfileStorage, UdpSocket, TcpSocketBase, TcpSocket, TcpServerSocket, SysSocket, InetSocket, DataConnProfileStorage, ObexServerDispatcher, ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexFtpServer, ObexClientDispatcher, ObexAbstractPort, MessageBox, VideoChannel, StillCamera, VideoCamera, VideoChannel, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoChannel, NonsharedBinDataDataSource, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, VideoChannel, StillCamera, Camera, VideoChannel, FileOutputStream, FileInputStream, FfsFile, StringDataSink, StreamWriter, StreamReader, Stream, HeapDataSource, HeapDataSink, DataSource, DataSink, BinDataDataSource, RtStreamingEndPoint, ExtPsdContextListener_SioGlueWrapper, FileDataSource, FileDataSink, File, FlsFile, FfsHandler, SerialSocket, SerialIoAdapter, SioGlueWrapper, SerialTerminalSocket, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoderRenderer, AudioDecoder, AudioCapturerEncoder, RootFileImp, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile
  • OpenAction() : ObexServerDispatcher, ObexServer, ObexClientDispatcher, ObexAbstractPort, AtiAudioPlayerRtStreamingSink, RtStreamingEndPoint, DataSourceRtStreamingSource
  • OpenChannel() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • OpenClientChannel() : ObexProtocol, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • OpenClientNetAdapter() : NetAdapterHandler
  • OpenCompleteAction() : ObexAbstractPort
  • OpenContextMenuAction() : OpenContextMenuAction
  • OpenCurrentPathWindow() : BtHfAudioPathWindow
  • OpenDatabase() : DBService
  • OpenDefaultPathWindow() : BtHfAudioPathWindow
  • OpenEditBox() : PbDetails
  • OpenFfsFile() : FfsDataConnProfileStorage
  • OpenFile() : StreamAudioReference
  • OpenFileFailure : MediaManager
  • OpenFlags : ObexServerDispatcher
  • OpenHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • OpeningError : File
  • OpenMatrixWindow() : T9ThaiMatrixModeWindowInterface
  • OpenModal() : Window, Alert
  • OpenMode : File
  • OpenModeless() : EmsComposeWin, Window, Alert
  • OpenPbWinMsg() : OpenPbWinMsg
  • OpenPhonebook() : PhonebookApp
  • OpenServerNetAdapter() : NetAdapterHandler
  • OpenStreaming() : File, FlsFile, RootFileImp, RamFileImp, FlashFileImp, FatFileImp, FatFile
  • OpenWindowAction() : OpenWindowAction
  • OpenWindowActionClassType : GuiObjectFactory
  • Operation : ObexServer, DrmInfo, FileChunkOperator
  • operation_code : UssDataArg, PasswordReceivedArg, InterrogationResultArg, SsNotificationArg, SsDataReceivedArg, BarringInfoReceivedArg, ForwardingInfoReceivedArg
  • OperationAborted : ObexResult
  • OperationAlreadyComplete : ObexResult
  • OperationAlreadyRunning : ObexResult
  • OperationCancelledError : File
  • OperationCompleted : StreamingInfo
  • OperationCompletedSynchroneously : StreamingInfo
  • OperationErroneous : StreamingInfo
  • OperationFailed : StreamingInfo
  • OperationFailedError : File
  • OperationNotAllowedError : File
  • OperationNotCompleted : StreamingInfo
  • OperationNotPermitted : ObexResult
  • OperationNotSupported : ObexResult, StreamingInfo
  • OperationOtherState : StreamingInfo
  • OperationRequestResponse() : BtAvrcpOperationService
  • OperationState : StreamingInfo
  • operator *() : MediaRefLinkable, ObexTransportSet::Iterator, ObexHeaderList::ConstIterator, BtDeviceListReverseIterator, BtDeviceListConstantReverseIterator, BtDeviceListIterator, BtDeviceListConstantIterator, Vector< T >::Iterator, SharedPtr< T_obj >, NiSharedPtr< X >, Fraction, Pathname::ReverseIterator, Pathname::Iterator, ServicePtr< T >
  • operator *=() : Fraction, SignedValue, UnsignedValue
  • operator BitmapRes() : Bitmap
  • operator bool() : SharedPtr< T_obj >
  • operator BOOLEAN() : ObexResult, BtObexResponseCode
  • operator const CHAR *() : String
  • operator const WCHAR *() : WString
  • operator delete() : WStrData, StrData
  • operator INT32() : LcsWString
  • operator new() : WStrData, StrData
  • operator T_AUTH_PPP_FRAME() : PppFrame
  • operator UINT32() : LcsWString
  • operator WCHAR() : CharItem
  • operator!=() : ObexOperationId, ObexChannel, Ticks, TextFormat, Rect, IconState, Font, Control::NavigationGuidance, Color, BtSvrDataElement, BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceAndServiceClass, BtDeviceAddress, BtDevice, WString, Vector< T >::Iterator, TimeZone, Time, String, SharedPtr< T_obj >, DateTime, Date, DataItem, ResourceID, Uri, Pathname, Pathname::ReverseIterator, Pathname::Iterator, ServicePtr< T >, Guid
  • operator()() : MenuTextPtrArrayIterator, MenuTextIterator, AnimationBmpPointerArrayIterator, AnimationBmpArrayIterator, AnimationBmpIterator, HeapArrayObject< T >, HeapObject< T >
  • operator+() : Ticks, WString, Vector< T >::Iterator, String, DateTime, Fraction, Uri
  • operator++() : ObexTransportSet::Iterator, ObexHeaderList::ConstIterator, WindowHierarchyIterator, Control::ComponentIterator, DeviceManager::Iterator, BtDeviceListReverseIterator, BtDeviceListConstantReverseIterator, BtDeviceListIterator, BtDeviceListConstantIterator, Vector< T >::Iterator, Pathname::ReverseIterator, Pathname::Iterator
  • operator+=() : Ticks, WString, String, DateTime, Fraction, Uri
  • operator-() : Ticks, Vector< T >::Iterator, DateTime, Fraction, SignedValue
  • operator--() : WindowHierarchyIterator, BtDeviceListReverseIterator, BtDeviceListConstantReverseIterator, BtDeviceListIterator, BtDeviceListConstantIterator, Vector< T >::Iterator
  • operator-=() : Ticks, DateTime, Fraction
  • operator->() : ObexTransportSet::Iterator, ObexHeaderList::ConstIterator, BtDeviceListReverseIterator, BtDeviceListConstantReverseIterator, BtDeviceListIterator, BtDeviceListConstantIterator, SharedPtr< T_obj >, NiSharedPtr< X >, ServicePtr< T >
  • operator/() : Fraction
  • operator/=() : Fraction
  • operator<() : Timer, Ticks, WString, Vector< T >::Iterator, Time, String, PhoneNumber, DateTime, Date, DataItem, ResourceID, InputActionPtr, SimItemIdentifier, SimItemId, SimAtom< T >, PlmnListEntry, Pathname::ReverseIterator, Pathname::Iterator, NotificationTableEntry, SignedValue, UnsignedValue
  • operator<< : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, OnDataRcvdMsg, LcsWString, SmsSettingsRecord, ObexVCardMsg, TraceOutputStream, OutputStream, DebugOutputStream, WString, Time, String, PhoneNumber, IpAddr, DateTime, Date, BitField< T >, Uri, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg
  • operator<=() : Ticks, WString, Vector< T >::Iterator, Time, String, DateTime, Date, DataItem
  • operator=() : LcsWString, ObexTransportSet, ObexTransportSet::Iterator, ObexResult, ObexOperationId, ObexObject, ObexHeaderList::ConstIterator, ObexChannel, ObexBuffer, Ticks, MessageReferrer, Native32Bit, Native16Bit, LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit, IconSet, CharItem, BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtHsNotificationMessage, BtHfNotificationMessage, BtSddbServiceRecord, BtObexResponseCode, BtDeviceAndServiceClass, BtDeviceAddress, BtAvrcpOperationServiceMessage, BtAvrcpNotificationMessage, WString, Vector< T >, VCard, String, SharedPtr< T_obj >, RegBlobObject, PhoneNumber, ObjectObtainer, NiSharedPtr< X >, IndexTable< T >, SortedElementList< T >, ElementList< T >, DynamicBitVector, DataItem, ByteBuffer, BlobPtr, BlobObject, RtStreamingBuffer, AudioPath, ProviderProxyItem, PppFrame, UsimPbFillStatus, UsimPbLocReport, UsimPbGroups, UsimPbChangedField, UsimPbRefRecord, Tpdu, Tlv, SimIconIdentifier, SimNextActionIdentifier, CfuServiceArray, CfuService, EccCategory, L1Param, CiTestParamList, CiTestParam, EquivPlmnLists, RrcParam, RrParam, CellParam, NeighbourCellList, NeighbourCell, MmCoordParam, GmmParam, MmcsParam, GprsParam, AckNackParamList, AckNackTestparamCnt, AckNackCnt, COverIList, GsmBandList, Plmn, BcdPlmn, AsTestparamDatabase, UmtsNcellParamList, CellChangeCnts, RrcProcessState, UmtsCellList, UmtsNcellParam, UmtsMeasEvalParam, UmtsMeasIdParam, UmtsRrcScellParam, Uplmn, DchReport, BlerTrchInfoList, MultiSlotMode, MessageIdentifierContainer, ToStackMsg, FromStackMsg, MdhGors, MdhExtendedData, InformationElement, SimImage, SimIconDescription, SimImageDescriptor, Cbs, Cbs::Filter, BaseInformationElement, MePhonebookDescription, MePhonebookDescriptor, Uri, ServicePtr< T >, AtResponse, AtResponseParameter, LastLocationEstimate, SimPbEntry
  • operator==() : MediaRefLinkable, MediaRef, MediaRefLinkable, MediaRef, ObexOperationId, ObexChannel, Ticks, ApplicationListEntry, TextFormat, Rect, IconState, Font, Control::NavigationGuidance, Color, BtSvrDataElement, BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceAndServiceClass, BtDeviceAddress, BtDevice, WString, Vector< T >::Iterator, TimeZone, Time, String, SharedPtr< T_obj >, PhoneNumber, ProviderPtr, DateTime, Date, DataItem, BitField< T >, AudioPlayerStore::DataFormatDataSource, AudioPath, AudioActiveReference, ResourceID, InputActionPtr, Tpdu, SimItemIdentifier, SimAtom< T >, PlmnListEntry, MessageIdentifierContainer::MessageIdentifierPair, MessageIdentifierRange, MessageIdentifier, DataCodingSchemeRange, DataCodingScheme, Uri, Pathname, Pathname::ReverseIterator, Pathname::Iterator, Path, NotificationTableEntry, ServicePtr< T >, Guid, MmCallHdl, SignedValue, UnsignedValue
  • operator>() : Ticks, WString, Vector< T >::Iterator, Time, String, PhoneNumber, DateTime, Date, DataItem, ResourceID, Pathname::ReverseIterator, Pathname::Iterator, SignedValue, UnsignedValue
  • operator>=() : Ticks, WString, Vector< T >::Iterator, Time, String, DateTime, Date, DataItem
  • operator>> : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, OnDataRcvdMsg, SmsSettingsRecord, ObexVCardMsg, InputStream, Time, PhoneNumber, IpAddr, DateTime, Date, BitField< T >, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg
  • operator[]() : WString, Vector< T >, String, SimpleMap< TKey, TValue >, IndexTable< T >, FixedPtrArray< T >, ElementList< T >, ElementListBase, ByteBuffer, CArray< T >, TextIconPairArray, CiTestParamList, EquivPlmnLists, NeighbourCellList, AckNackParamList, COverIList, GsmBandList, UmtsCellList, BlerTrchInfoList, MessageIdentifierContainer
  • OperConfirm : ObexDataServer
  • OperGetData : ObexDataServer
  • OperGetRequest : ObexDataServer
  • OperPutData : ObexDataServer
  • OperPutRequest : ObexDataServer
  • OplEntry() : OplEntry
  • OppDispatcher : ObexOppClient
  • OppImplServerId : ObexServerInfo
  • OptGet() : SioSocketAdapter, SerialSocket, SerialIoAdapter
  • Optimize() : MessageIdentifierContainer, Cbs::Filter
  • OptimizeAutoClear() : Control
  • option : CliRestrictionInfo
  • options : ForwardingFeature
  • OptionType : SysSocketBase, InetSocket
  • OptSet() : SioSocketAdapter, SerialSocket, SerialIoAdapter
  • OPut : ObexServer
  • OrFilterOp : DualFilterProvider
  • Orientation : PositionIndicator
  • OrientationProp : GuiObjectFactory
  • Origin() : Stream, PdpContext, Message
  • OrRop : DeviceContext
  • Os : SocketSubSystem, System, Ticks, Thread, GenericWorkerTask, AbstractScheduler, SerialSocketSubSystem
  • Os::DbgOutStackUsage : AppContainer
  • Oscillate : Animation
  • OSetPath : ObexServer
  • Other : CalendarRecord
  • OtherMessage : InformationElement, DataCodingScheme
  • Out : PhoneNumber
  • out_of_service : AsTestparamDatabase, UmtsRrcScellParam
  • Outbox : SmsSettingsRecord
  • outbox_ascending_order : SmsSettingsRecord::Persist
  • outbox_sorting_colid : SmsSettingsRecord::Persist
  • OuterBorderColor : CTResourcePack
  • OuterBorderWidth : CTResourcePack
  • OutgBarrServices : InputParser
  • OutgoingCallForwardedMsg() : OutgoingCallForwardedMsg
  • OutOfMemory : ObexResult, MediaManager, CodecDevice
  • OutOfMemoryError : ImageEncoder, Image, BufferPoolManager, File, SvgPlayer, PngDecoder
  • OutputStream() : OutputStream
  • OverallOverwriteCheck() : HeapManager
  • OverpaintRop : DeviceContext
  • override_category : SsData
  • Overwrite : Caret
  • OverwriteCheck() : HeapVector::VarPage, HeapVector::BlockPage
  • OverwriteCheckFunction : HeapVector
  • owner : Vector< T >::Iterator
Generated on Wed Jan 25 00:54:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- z -

  • Zero : DateTime
  • Zi8 : PredInputMapper, InputMapper
  • Zi8AddWordMsg() : Zi8AddWordMsg
  • Zi8AlphabetBox() : Zi8AlphabetBox
  • Zi8AlphabetBoxView() : Zi8AlphabetBoxView
  • Zi8BopomofoCompare() : Zi8Wrapper
  • Zi8EnteredUnknownWordMsg() : Zi8EnteredUnknownWordMsg
  • Zi8InputMapper() : Zi8InputMapper
  • Zi8NoWordFoundMsg() : Zi8NoWordFoundMsg
  • Zi8PinyinCompare() : Zi8Wrapper
  • Zi8PredictiveInputBox() : Zi8PredictiveInputBox
  • Zi8SelectionBox() : Zi8SelectionBox
  • Zi8SelectionBoxView() : Zi8SelectionBoxView
  • Zi8StrokeBox() : Zi8StrokeBox
  • Zi8StrokeBoxView() : Zi8StrokeBoxView
  • Zi8StrokeCompare() : Zi8Wrapper
  • Zi8Wrapper() : Zi8Wrapper
  • Zoom() : MediaRecorder, MediaPlayer
  • ZoomFactorMax : VideoChannel
  • ZoomFactorMin : VideoChannel
  • Zulu : LanguageManager
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- ~ -

  • ~_FunctionTracer() : _FunctionTracer< mask >
  • ~_NullFunctionTracer() : _NullFunctionTracer
  • ~AbortResArg() : AbortResArg
  • ~AbortResMsg() : AbortResMsg
  • ~AbstractActionMenuAccessor() : AbstractActionMenuAccessor
  • ~AbstractAppContext() : AbstractAppContext
  • ~AbstractButton() : AbstractButton
  • ~AbstractDelegationProvider() : AbstractDelegationProvider
  • ~AbstractDevice() : AbstractDevice
  • ~AbstractEditBox() : AbstractEditBox
  • ~AbstractEditBoxModel() : AbstractEditBoxModel
  • ~AbstractEditBoxView() : AbstractEditBoxView
  • ~AbstractEditor() : AbstractEditor
  • ~AbstractEditorItem() : AbstractEditorItem
  • ~AbstractExternalData() : AbstractExternalData
  • ~AbstractGrid() : AbstractGrid
  • ~AbstractIMelodyParser() : AbstractIMelodyParser
  • ~AbstractItemContainer() : AbstractItemContainer
  • ~AbstractItemGrid() : AbstractItemGrid
  • ~AbstractItemRenderer() : AbstractItemRenderer
  • ~AbstractLineEditor() : AbstractLineEditor
  • ~AbstractLineEditorView() : AbstractLineEditorView
  • ~AbstractListBox() : AbstractListBox
  • ~AbstractListBoxModel() : AbstractListBoxModel
  • ~AbstractListBoxView() : AbstractListBoxView
  • ~AbstractMenuAccessor() : AbstractMenuAccessor
  • ~AbstractMenuList() : AbstractMenuList
  • ~AbstractMultiLineEditor() : AbstractMultiLineEditor
  • ~AbstractMultiLineEditorView() : AbstractMultiLineEditorView
  • ~AbstractPredictiveInputBox() : AbstractPredictiveInputBox
  • ~AbstractRenderer() : AbstractRenderer
  • ~AbstractScheduler() : AbstractScheduler
  • ~AbstractSmsApp() : AbstractSmsApp
  • ~AbstractSmsComposeWin() : AbstractSmsComposeWin
  • ~AbstractSmsViewerWin() : AbstractSmsViewerWin
  • ~AbstractTextObject() : AbstractTextObject
  • ~AbstractTextRenderer() : AbstractTextRenderer
  • ~AbstractToggleAction() : AbstractToggleAction
  • ~AcacLanguage() : AcacLanguage
  • ~AccDispatcher() : AccDispatcher
  • ~AccessorAction() : AccessorAction
  • ~AccessorActionExtension() : AccessorActionExtension
  • ~AccessoryIndMsg() : AccessoryIndMsg
  • ~AccHandler() : AccHandler
  • ~Action() : Action
  • ~ActionExecutedMsg() : ActionExecutedMsg
  • ~ActionExtension() : ActionExtension
  • ~ActionMenuAccessor() : ActionMenuAccessor
  • ~ActivationStatus() : PdpContext::ActivationStatus
  • ~ActiveWaitDispatcher() : ActiveWaitDispatcher
  • ~AdvPbAction() : AdvPbAction
  • ~AdvPbApp() : AdvPbApp
  • ~AdvPbWin() : AdvPbWin
  • ~AesCrypt() : AesCrypt
  • ~AidingData() : AidingData
  • ~AlarmManager() : AlarmManager
  • ~AlarmMsg() : AlarmMsg
  • ~AlarmNotificationMsg() : AlarmNotificationMsg
  • ~Alert() : Alert
  • ~AlphaCoding() : AlphaCoding
  • ~AmplifierAudioDevice() : AmplifierAudioDevice
  • ~AmrSound() : AmrSound
  • ~AnimatedTextLine() : AnimatedTextLine
  • ~AnimatedTextLineView() : AnimatedTextLineView
  • ~Animation() : Animation
  • ~AnimationView() : AnimationView
  • ~AocChargingStatusMsg() : AocChargingStatusMsg
  • ~AocDispatcher() : AocDispatcher
  • ~AocHandler() : AocHandler
  • ~apoxi_emcpp_OBEXAdapter() : apoxi_emcpp_OBEXAdapter
  • ~ApoxiCommandAction() : ApoxiCommandAction
  • ~ApoxiThread() : ApoxiThread
  • ~AppActionExecutedMsg() : AppActionExecutedMsg
  • ~AppCloseMsg() : AppCloseMsg
  • ~AppContainerRoutingTableEntry() : AppContainerRoutingTableEntry
  • ~AppContext() : AppContext
  • ~AppendProvider() : AppendProvider
  • ~AppGetFocusMsg() : AppGetFocusMsg
  • ~Application() : Application
  • ~ApplicationAction() : ApplicationAction
  • ~AppLoseFocusMsg() : AppLoseFocusMsg
  • ~AppMutex() : AppMutex
  • ~AppOpenMsg() : AppOpenMsg
  • ~AppUpdateDisplayMsg() : AppUpdateDisplayMsg
  • ~ArabicTextRenderer() : ArabicTextRenderer
  • ~AragonMsg() : AragonMsg
  • ~AsyncUnitTestMsg() : AsyncUnitTestMsg
  • ~AtcDispatcher() : AtcDispatcher
  • ~AtcHandler() : AtcHandler
  • ~AtCommand() : AtCommand
  • ~AtGenericCmdType() : AtGenericCmdType
  • ~AtiAudioCapturerEncoder() : AtiAudioCapturerEncoder
  • ~AtiAudioDecoderRenderer() : AtiAudioDecoderRenderer
  • ~AtiMpeg4Decoder() : AtiMpeg4Decoder
  • ~AtiMpeg4Encoder() : AtiMpeg4Encoder
  • ~AtKeyParser() : AtKeyParser
  • ~AtlApplication() : AtlApplication
  • ~AtlApplicationPlugin() : AtlApplicationPlugin
  • ~AtlItemBox() : AtlItemBox
  • ~AtlItemGrid() : AtlItemGrid
  • ~AtlItemGridWindow() : AtlItemGridWindow
  • ~AtlItemListWindow() : AtlItemListWindow
  • ~AtlItemMenu() : AtlItemMenu
  • ~AtlItemMenuWindow() : AtlItemMenuWindow
  • ~AtlItemRenderer() : AtlItemRenderer
  • ~AtlLabelListWindow() : AtlLabelListWindow
  • ~AtlWindow() : AtlWindow
  • ~AtomItem() : AtomItem
  • ~AtResponse() : AtResponse
  • ~AtResponseIterator() : AtResponseIterator
  • ~AtResponseParameter() : AtResponseParameter
  • ~AttachStatus() : PdpContextManager::AttachStatus
  • ~Audio() : Audio
  • ~AudioAccessoryConnectedMsg() : AudioAccessoryConnectedMsg
  • ~AudioAccessoryStore() : AudioAccessoryStore
  • ~AudioActiveReference() : AudioActiveReference
  • ~AudioCodecCapabilities() : CodecDevice::AudioCodecCapabilities
  • ~AudioContext() : AudioContext
  • ~AudioDeviceBase() : AudioDeviceBase
  • ~AudioDeviceManager() : AudioDeviceManager
  • ~AudioDeviceStatusMsg() : AudioDeviceStatusMsg
  • ~AudioError() : AudioError
  • ~AudioErrorMsg() : AudioErrorMsg
  • ~AudioFastForwardStartedMsg() : AudioFastForwardStartedMsg
  • ~AudioFmRadioRdsAlternativeFrequenciesMsg() : AudioFmRadioRdsAlternativeFrequenciesMsg
  • ~AudioFmRadioRdsInfoMsg() : AudioFmRadioRdsInfoMsg
  • ~AudioFmRadioRdsRadioTextMsg() : AudioFmRadioRdsRadioTextMsg
  • ~AudioFmRadioRdsRawDataMsg() : AudioFmRadioRdsRawDataMsg
  • ~AudioFmRadioRdsStationNameMsg() : AudioFmRadioRdsStationNameMsg
  • ~AudioFmRadioRssiMsg() : AudioFmRadioRssiMsg
  • ~AudioFmRadioSeekMsg() : AudioFmRadioSeekMsg
  • ~AudioGatiServer() : AudioGatiServer
  • ~AudioGetPlayPositionMsg() : AudioGetPlayPositionMsg
  • ~AudioItem() : AudioItem
  • ~AudioMsg() : AudioMsg
  • ~AudioPathManager() : AudioPathManager
  • ~AudioPlayer() : AudioPlayer
  • ~AudioPlayerStore() : AudioPlayerStore
  • ~AudioPlayTimeMsg() : AudioPlayTimeMsg
  • ~AudioPreset() : AudioPreset
  • ~AudioPresetStore() : AudioPresetStore
  • ~AudioRadioDeviceNotificationMsg() : AudioRadioDeviceNotificationMsg
  • ~AudioRecordingStoppedMsg() : AudioRecordingStoppedMsg
  • ~AudioReference() : AudioReference
  • ~AudioRestartedMsg() : AudioRestartedMsg
  • ~AudioResumedMsg() : AudioResumedMsg
  • ~AudioRewindStartedMsg() : AudioRewindStartedMsg
  • ~AudioStartedMsg() : AudioStartedMsg
  • ~AudioStoppedMsg() : AudioStoppedMsg
  • ~AudioStreamingSyncMsg() : AudioStreamingSyncMsg
  • ~AudioSuspendedMsg() : AudioSuspendedMsg
  • ~AudioUserDefinedMsg() : AudioUserDefinedMsg
  • ~AudioUtility() : AudioUtility
  • ~AudioVoiceMemoOutOfSpaceMsg() : AudioVoiceMemoOutOfSpaceMsg
  • ~Authentication() : PdpContext::Authentication
  • ~AuthProvider() : AuthProvider
  • ~AuxProvider() : AuxProvider
  • ~BackToIdleFeature() : BackToIdleFeature
  • ~BandSelectionMsg() : BandSelectionMsg
  • ~BandStatusMsg() : BandStatusMsg
  • ~BarringInfoReceivedMsg() : BarringInfoReceivedMsg
  • ~BarringSsAction() : BarringSsAction
  • ~BaseDataHandler() : BaseDataHandler
  • ~BaseInformationElement() : BaseInformationElement
  • ~BasicPackConnector() : BasicPackConnector
  • ~BasicPbWin() : BasicPbWin
  • ~BasicSmsService() : BasicSmsService
  • ~BatteryLoadLevelMsg() : BatteryLoadLevelMsg
  • ~BinData() : BinData
  • ~BinDataDataSource() : BinDataDataSource
  • ~Bitmap() : Bitmap
  • ~BitmapDc() : BitmapDc
  • ~BlackAndWhiteTheme() : BlackAndWhiteTheme
  • ~BlobObject() : BlobObject
  • ~BlobPtr() : BlobPtr
  • ~BlueSkyCheckBoxListView() : BlueSkyCheckBoxListView
  • ~BlueSkyCheckBoxView() : BlueSkyCheckBoxView
  • ~BlueSkyChineseTheme() : BlueSkyChineseTheme
  • ~BlueSkyControlFrameView() : BlueSkyControlFrameView
  • ~BlueSkyPositionIndicatorView() : BlueSkyPositionIndicatorView
  • ~BlueSkyProgressBarView() : BlueSkyProgressBarView
  • ~BlueSkyPushButtonView() : BlueSkyPushButtonView
  • ~BlueSkyRadioButtonListView() : BlueSkyRadioButtonListView
  • ~BlueSkyRadioButtonView() : BlueSkyRadioButtonView
  • ~BlueSkySoftkeyBarView() : BlueSkySoftkeyBarView
  • ~BlueSkyTextListView() : BlueSkyTextListView
  • ~BlueSkyTheme() : BlueSkyTheme
  • ~BlueSkyWindowFrameView() : BlueSkyWindowFrameView
  • ~BmpImage() : BmpImage
  • ~BooleanCondition() : BooleanCondition
  • ~BootControl() : BootControl
  • ~BootDispatcher() : BootDispatcher
  • ~BootHandler() : BootHandler
  • ~BootState() : BootState
  • ~BoundedItem() : BoundedItem
  • ~BrowserSaveWin() : BrowserSaveWin
  • ~BrowserView() : BrowserView
  • ~BrowserViewContainer() : BrowserViewContainer
  • ~BtActiveDeviceWindow() : BtActiveDeviceWindow
  • ~BtAlertMessageWindow() : BtAlertMessageWindow
  • ~BtApplication() : BtApplication
  • ~BtApplicationDevicePairRequest() : BtApplicationDevicePairRequest
  • ~BtApplicationDeviceSearchRequest() : BtApplicationDeviceSearchRequest
  • ~BtApplicationDeviceTrustRequest() : BtApplicationDeviceTrustRequest
  • ~BtApplicationDeviceUnpairRequest() : BtApplicationDeviceUnpairRequest
  • ~BtApplicationDeviceUntrustRequest() : BtApplicationDeviceUntrustRequest
  • ~BtApplicationMessage() : BtApplicationMessage
  • ~BtApplicationQuerySupportedProfilesRequest() : BtApplicationQuerySupportedProfilesRequest
  • ~BtApplicationRespondAuthorizationRequest() : BtApplicationRespondAuthorizationRequest
  • ~BtApplicationSendPasskeyRequest() : BtApplicationSendPasskeyRequest
  • ~BtApplicationServiceVerifyRequest() : BtApplicationServiceVerifyRequest
  • ~BtApplicationSetRemoteDeviceNameRequest() : BtApplicationSetRemoteDeviceNameRequest
  • ~BtAudioAccessoryService() : BtAudioAccessoryService
  • ~BtAuthorizationRequiredMessage() : BtAuthorizationRequiredMessage
  • ~BtAuthorizationRequiredWindow() : BtAuthorizationRequiredWindow
  • ~BtAvrcpAlertMessageWindow() : BtAvrcpAlertMessageWindow
  • ~BtAvrcpConnectResponse() : BtAvrcpConnectResponse
  • ~BtAvrcpControllerApplicationWindow() : BtAvrcpControllerApplicationWindow
  • ~BtAvrcpControllerDeviceListItem() : BtAvrcpControllerDeviceListItem
  • ~BtAvrcpControllerDeviceListWindow() : BtAvrcpControllerDeviceListWindow
  • ~BtAvrcpDeRegisterRequest() : BtAvrcpDeRegisterRequest
  • ~BtAvrcpDeviceListWin() : BtAvrcpDeviceListWin
  • ~BtAvrcpNmaConnect() : BtAvrcpNmaConnect
  • ~BtAvrcpNmaDisconnect() : BtAvrcpNmaDisconnect
  • ~BtAvrcpNmaPanelPassThrough() : BtAvrcpNmaPanelPassThrough
  • ~BtAvrcpNmaRawFrame() : BtAvrcpNmaRawFrame
  • ~BtAvrcpNotificationMessage() : BtAvrcpNotificationMessage
  • ~BtAvrcpOperationRequestResponse() : BtAvrcpOperationRequestResponse
  • ~BtAvrcpOperationService() : BtAvrcpOperationService
  • ~BtAvrcpOperationServiceMessage() : BtAvrcpOperationServiceMessage
  • ~BtAvrcpPanelApplication() : BtAvrcpPanelApplication
  • ~BtAvrcpPanelPassThroughParams() : BtAvrcpPanelPassThroughParams
  • ~BtAvrcpPanelPassThroughRequest() : BtAvrcpPanelPassThroughRequest
  • ~BtAvrcpPanelServiceImpl() : BtAvrcpPanelServiceImpl
  • ~BtAvrcpProfileOperationService() : BtAvrcpProfileOperationService
  • ~BtAvrcpProfileRegistrationService() : BtAvrcpProfileRegistrationService
  • ~BtAvrcpRawFrameParams() : BtAvrcpRawFrameParams
  • ~BtAvrcpRawFrameRequest() : BtAvrcpRawFrameRequest
  • ~BtAvrcpRegisterParams() : BtAvrcpRegisterParams
  • ~BtAvrcpRegisterRequest() : BtAvrcpRegisterRequest
  • ~BtAvrcpRegistrationService() : BtAvrcpRegistrationService
  • ~BtAvrcpRequest() : BtAvrcpRequest
  • ~BtAvrcpRequestStateChangedMessage() : BtAvrcpRequestStateChangedMessage
  • ~BtAvrcpService() : BtAvrcpService
  • ~BtAvrcpSubunitInfoParams() : BtAvrcpSubunitInfoParams
  • ~BtAvrcpSubunitInfoRequest() : BtAvrcpSubunitInfoRequest
  • ~BtAvrcpUnitInfoParams() : BtAvrcpUnitInfoParams
  • ~BtAvrcpUnitInfoRequest() : BtAvrcpUnitInfoRequest
  • ~BtBipAbortIndArg() : BtBipAbortIndArg
  • ~BtBipAttachmentDesc() : BtBipAttachmentDesc
  • ~BtBipAttachmentFormat() : BtBipAttachmentFormat
  • ~BtBipClientService() : BtBipClientService
  • ~BtBipConnectIndArg() : BtBipConnectIndArg
  • ~BtBipDeleteImageIndArg() : BtBipDeleteImageIndArg
  • ~BtBipDisconnectIndArg() : BtBipDisconnectIndArg
  • ~BtBipGetImageIndArg() : BtBipGetImageIndArg
  • ~BtBipGetImagePropertiesIndArg() : BtBipGetImagePropertiesIndArg
  • ~BtBipGetImagesListIndArg() : BtBipGetImagesListIndArg
  • ~BtBipGetImagingCapabilitiesIndArg() : BtBipGetImagingCapabilitiesIndArg
  • ~BtBipGetLinkedAttachmentIndArg() : BtBipGetLinkedAttachmentIndArg
  • ~BtBipGetLinkedThumbnailIndArg() : BtBipGetLinkedThumbnailIndArg
  • ~BtBipImage() : BtBipImage
  • ~BtBipImageHdl() : BtBipImageHdl
  • ~BtBipImageHdlDesc() : BtBipImageHdlDesc
  • ~BtBipImageList() : BtBipImageList
  • ~BtBipImagingCapabilities() : BtBipImagingCapabilities
  • ~BtBipMsgArg() : BtBipMsgArg
  • ~BtBipOpFinishedArg() : BtBipOpFinishedArg
  • ~BtBipProgressMsg() : BtBipProgressMsg
  • ~BtBipPutImageCompleteArg() : BtBipPutImageCompleteArg
  • ~BtBipPutImageIndArg() : BtBipPutImageIndArg
  • ~BtBipPutLinkedAttachmentCompleteArg() : BtBipPutLinkedAttachmentCompleteArg
  • ~BtBipPutLinkedAttachmentIndArg() : BtBipPutLinkedAttachmentIndArg
  • ~BtBipPutLinkedThumbnailCompleteArg() : BtBipPutLinkedThumbnailCompleteArg
  • ~BtBipPutLinkedThumbnailIndArg() : BtBipPutLinkedThumbnailIndArg
  • ~BtBipServerNotificationMsgArg() : BtBipServerNotificationMsgArg
  • ~BtBipServerService() : BtBipServerService
  • ~BtBppClientService() : BtBppClientService
  • ~BtBppController() : BtBppController
  • ~BtBppReq() : BtBppReq
  • ~BtBppRequestStateChangedMessage() : BtBppRequestStateChangedMessage
  • ~BtBppServerService() : BtBppServerService
  • ~BtBppService() : BtBppService
  • ~BtBppSndAbortReqRequest() : BtBppSndAbortReqRequest
  • ~BtBppSndFilePushReqRequest() : BtBppSndFilePushReqRequest
  • ~BtBppSndGetRefObjRspRequest() : BtBppSndGetRefObjRspRequest
  • ~BtCancelableBroadcastRequest() : BtCancelableBroadcastRequest
  • ~BtCancelableMulticastRequest() : BtCancelableMulticastRequest
  • ~BtCancelableRequest() : BtCancelableRequest
  • ~BtCancelSearchMessage() : BtCancelSearchMessage
  • ~BtCancelVerifyMessage() : BtCancelVerifyMessage
  • ~BtCloseMessage() : BtCloseMessage
  • ~BtConnectabilityMessage() : BtConnectabilityMessage
  • ~BtConnection() : BtMultiConnectionController::BtConnection
  • ~BtConnectionBasedController() : BtConnectionBasedController
  • ~BtConnectionlessController() : BtConnectionlessController
  • ~BtConnectRequest() : BtConnectRequest
  • ~BtController() : BtController
  • ~BtDevice() : BtDevice
  • ~BtDeviceAddress() : BtDeviceAddress
  • ~BtDeviceAddressGenericObject() : BtDeviceAddressGenericObject
  • ~BtDeviceAndServiceClass() : BtDeviceAndServiceClass
  • ~BtDeviceDetailWindow() : BtDeviceDetailWindow
  • ~BtDeviceFilter() : BtDeviceFilter
  • ~BtDeviceList() : BtDeviceList
  • ~BtDeviceListItem() : BtDeviceListItem
  • ~BtDeviceListNode() : BtDeviceList::BtDeviceListNode
  • ~BtDeviceListProvider() : BtDeviceListProvider
  • ~BtDeviceListWindow() : BtDeviceListWindow
  • ~BtDevicePairMessage() : BtDevicePairMessage
  • ~BtDevicePairRequest() : BtDevicePairRequest
  • ~BtDeviceSearchMessage() : BtDeviceSearchMessage
  • ~BtDeviceSearchModeWindow() : BtDeviceSearchModeWindow
  • ~BtDeviceSearchRequest() : BtDeviceSearchRequest
  • ~BtDeviceTrustMessage() : BtDeviceTrustMessage
  • ~BtDeviceTrustRequest() : BtDeviceTrustRequest
  • ~BtDeviceUnpairMessage() : BtDeviceUnpairMessage
  • ~BtDeviceUnpairRequest() : BtDeviceUnpairRequest
  • ~BtDeviceUntrustMessage() : BtDeviceUntrustMessage
  • ~BtDeviceUntrustRequest() : BtDeviceUntrustRequest
  • ~BtDisconnectRequest() : BtDisconnectRequest
  • ~BtDiscoverabilityMessage() : BtDiscoverabilityMessage
  • ~BtDunApplicationMessage() : BtDunApplicationMessage
  • ~BtDunAppPlugin() : BtDunAppPlugin
  • ~BtDunConnectMessage() : BtDunConnectMessage
  • ~BtDunDisconnectMessage() : BtDunDisconnectMessage
  • ~BtDunProfileService() : BtDunProfileService
  • ~BtDunRequestStateChangedMessage() : BtDunRequestStateChangedMessage
  • ~BtDunService() : BtDunService
  • ~BtEvent() : BtEvent
  • ~BtFaxApplicationMessage() : BtFaxApplicationMessage
  • ~BtFaxAppPlugin() : BtFaxAppPlugin
  • ~BtFaxConnectMessage() : BtFaxConnectMessage
  • ~BtFaxDisconnectMessage() : BtFaxDisconnectMessage
  • ~BtFaxProfileService() : BtFaxProfileService
  • ~BtFaxRequestStateChangedMessage() : BtFaxRequestStateChangedMessage
  • ~BtFaxService() : BtFaxService
  • ~BtGapAndSdapApplicationMessage() : BtGapAndSdapApplicationMessage
  • ~BtGapAndSdapNotificationMessage() : BtGapAndSdapNotificationMessage
  • ~BtGapAndSdapRemoteRequestMessage() : BtGapAndSdapRemoteRequestMessage
  • ~BtGapAndSdapRequestMessage() : BtGapAndSdapRequestMessage
  • ~BtHfAppPlugin() : BtHfAppPlugin
  • ~BtHfAudioPathWindow() : BtHfAudioPathWindow
  • ~BtHfCmaAtChldOneCommandReceived() : BtHfCmaAtChldOneCommandReceived
  • ~BtHfCmaAudioAsynchronous() : BtHfCmaAudioAsynchronous
  • ~BtHfCmaCheckPendingAudioCallback() : BtHfCmaCheckPendingAudioCallback
  • ~BtHfCmaMOC() : BtHfCmaMOC
  • ~BtHfCmaMTC() : BtHfCmaMTC
  • ~BtHfCmaPhoneNumberRequired() : BtHfCmaPhoneNumberRequired
  • ~BtHfFeatureListWin() : BtHfFeatureListWin
  • ~BtHfInbandSettingWin() : BtHfInbandSettingWin
  • ~BtHfNmaAudioConnectionLost() : BtHfNmaAudioConnectionLost
  • ~BtHfNmaCallEvent() : BtHfNmaCallEvent
  • ~BtHfNmaConnect() : BtHfNmaConnect
  • ~BtHfNmaDisconnect() : BtHfNmaDisconnect
  • ~BtHfNmaLowPowerModeNotPossible() : BtHfNmaLowPowerModeNotPossible
  • ~BtHfNmaMicrophoneGain() : BtHfNmaMicrophoneGain
  • ~BtHfNmaSpeakerGain() : BtHfNmaSpeakerGain
  • ~BtHfNmaTransferAudioToAccessory() : BtHfNmaTransferAudioToAccessory
  • ~BtHfNmaTransferAudioToPhone() : BtHfNmaTransferAudioToPhone
  • ~BtHfNotificationMessage() : BtHfNotificationMessage
  • ~BtHfProfileService() : BtHfProfileService
  • ~BtHfProfileWindow() : BtHfProfileWindow
  • ~BtHfProvider() : BtHfProvider
  • ~BtHfRecord() : BtHfRecord
  • ~BtHfRequestStateChangedMessage() : BtHfRequestStateChangedMessage
  • ~BtHfService() : BtHfService
  • ~BtHfSupportedProfileMessage() : BtHfSupportedProfileMessage
  • ~BtHfVolumeSettingsWin() : BtHfVolumeSettingsWin
  • ~BtHsAppPlugin() : BtHsAppPlugin
  • ~BtHsCmaAudioAsynchronous() : BtHsCmaAudioAsynchronous
  • ~BtHsCmaAudioTransferOutOfCall() : BtHsCmaAudioTransferOutOfCall
  • ~BtHsCmaCheckPendingAudioCallback() : BtHsCmaCheckPendingAudioCallback
  • ~BtHsCmaEnterLowPowerMode() : BtHsCmaEnterLowPowerMode
  • ~BtHsCmaHangUp() : BtHsCmaHangUp
  • ~BtHsConnectionSettingWin() : BtHsConnectionSettingWin
  • ~BtHsInbandSettingWin() : BtHsInbandSettingWin
  • ~BtHsNmaAudioConnectionLost() : BtHsNmaAudioConnectionLost
  • ~BtHsNmaCallEvent() : BtHsNmaCallEvent
  • ~BtHsNmaConnect() : BtHsNmaConnect
  • ~BtHsNmaDisconnect() : BtHsNmaDisconnect
  • ~BtHsNmaLowPowerModeNotPossible() : BtHsNmaLowPowerModeNotPossible
  • ~BtHsNmaMicrophoneGain() : BtHsNmaMicrophoneGain
  • ~BtHsNmaSpeakerGain() : BtHsNmaSpeakerGain
  • ~BtHsNmaTransferAudioToAccessory() : BtHsNmaTransferAudioToAccessory
  • ~BtHsNmaTransferAudioToPhone() : BtHsNmaTransferAudioToPhone
  • ~BtHsNotificationMessage() : BtHsNotificationMessage
  • ~BtHsProfileService() : BtHsProfileService
  • ~BtHsRequestStateChangedMessage() : BtHsRequestStateChangedMessage
  • ~BtHsService() : BtHsService
  • ~BtHsSupportedProfileMessage() : BtHsSupportedProfileMessage
  • ~BtHsVolumeSettingsWin() : BtHsVolumeSettingsWin
  • ~BtIndicatorMsg() : BtIndicatorMsg
  • ~BtLocalNameMessage() : BtLocalNameMessage
  • ~BtLocalRequest() : BtLocalRequest
  • ~BtLocalSettings() : BtLocalSettings
  • ~BtLocalSettingsMessage() : BtLocalSettingsMessage
  • ~BtMultiConnectionController() : BtMultiConnectionController
  • ~BtObexAbortRequest() : BtObexAbortRequest
  • ~BtObexClientAbortEvent() : BtObexClientAbortEvent
  • ~BtObexClientConnectEvent() : BtObexClientConnectEvent
  • ~BtObexClientDisconnectEvent() : BtObexClientDisconnectEvent
  • ~BtObexClientEvent() : BtObexClientEvent
  • ~BtObexClientGetEvent() : BtObexClientGetEvent
  • ~BtObexClientNmaDataBufferIndication() : BtObexClientNmaDataBufferIndication
  • ~BtObexClientNmaDataInidication() : BtObexClientNmaDataInidication
  • ~BtObexClientNmaHeaderIndication() : BtObexClientNmaHeaderIndication
  • ~BtObexClientNmaHeaderSent() : BtObexClientNmaHeaderSent
  • ~BtObexClientNmaTransportDisconnect() : BtObexClientNmaTransportDisconnect
  • ~BtObexClientNotificationMessage() : BtObexClientNotificationMessage
  • ~BtObexClientObserverImpl() : BtObexClientObserverImpl
  • ~BtObexClientOperationEvent() : BtObexClientOperationEvent
  • ~BtObexClientOperationRequest() : BtObexClientOperationRequest
  • ~BtObexClientPutEvent() : BtObexClientPutEvent
  • ~BtObexClientRequestStateChangedMessage() : BtObexClientRequestStateChangedMessage
  • ~BtObexClientService() : BtObexClientService
  • ~BtObexClientServiceImpl() : BtObexClientServiceImpl
  • ~BtObexClientServiceObserver() : BtObexClientServiceObserver
  • ~BtObexClientSetPathEvent() : BtObexClientSetPathEvent
  • ~BtObexConnection() : BtObexController::BtObexConnection
  • ~BtObexConnectRequest() : BtObexConnectRequest
  • ~BtObexController() : BtObexController
  • ~BtObexDataBufferIndicationEvent() : BtObexDataBufferIndicationEvent
  • ~BtObexDataIndicationEvent() : BtObexDataIndicationEvent
  • ~BtObexDisconnectRequest() : BtObexDisconnectRequest
  • ~BtObexEvent() : BtObexEvent
  • ~BtObexGetRequest() : BtObexGetRequest
  • ~BtObexHeaderIndicationEvent() : BtObexHeaderIndicationEvent
  • ~BtObexHeaderSentEvent() : BtObexHeaderSentEvent
  • ~BtObexImpl() : BtObexImpl
  • ~BtObexPutRequest() : BtObexPutRequest
  • ~BtObexRegisterClientEvent() : BtObexRegisterClientEvent
  • ~BtObexRegisterClientRequest() : BtObexRegisterClientRequest
  • ~BtObexRegisterServerEvent() : BtObexRegisterServerEvent
  • ~BtObexRegisterServerRequest() : BtObexRegisterServerRequest
  • ~BtObexRequest() : BtObexRequest
  • ~BtObexSddbImpl() : BtObexSddbImpl
  • ~BtObexSddbServiceObserverImpl() : BtObexSddbServiceObserverImpl
  • ~BtObexServerAbortIndicationEvent() : BtObexServerAbortIndicationEvent
  • ~BtObexServerConnectIndicationEvent() : BtObexServerConnectIndicationEvent
  • ~BtObexServerDisconnectIndicationEvent() : BtObexServerDisconnectIndicationEvent
  • ~BtObexServerEvent() : BtObexServerEvent
  • ~BtObexServerGetIndicationEvent() : BtObexServerGetIndicationEvent
  • ~BtObexServerNmaAbort() : BtObexServerNmaAbort
  • ~BtObexServerNmaConnect() : BtObexServerNmaConnect
  • ~BtObexServerNmaDataBufferIndication() : BtObexServerNmaDataBufferIndication
  • ~BtObexServerNmaDataInidication() : BtObexServerNmaDataInidication
  • ~BtObexServerNmaDisconnect() : BtObexServerNmaDisconnect
  • ~BtObexServerNmaGet() : BtObexServerNmaGet
  • ~BtObexServerNmaHeaderIndication() : BtObexServerNmaHeaderIndication
  • ~BtObexServerNmaHeaderSent() : BtObexServerNmaHeaderSent
  • ~BtObexServerNmaPut() : BtObexServerNmaPut
  • ~BtObexServerNmaSetPath() : BtObexServerNmaSetPath
  • ~BtObexServerNmaTransportDisconnect() : BtObexServerNmaTransportDisconnect
  • ~BtObexServerNotificationMessage() : BtObexServerNotificationMessage
  • ~BtObexServerObserverImpl() : BtObexServerObserverImpl
  • ~BtObexServerPutIndicationEvent() : BtObexServerPutIndicationEvent
  • ~BtObexServerRequestStateChangedMessage() : BtObexServerRequestStateChangedMessage
  • ~BtObexServerService() : BtObexServerService
  • ~BtObexServerServiceImpl() : BtObexServerServiceImpl
  • ~BtObexServerServiceObserver() : BtObexServerServiceObserver
  • ~BtObexServerSetPathIndicationEvent() : BtObexServerSetPathIndicationEvent
  • ~BtObexService() : BtObexService
  • ~BtObexServiceObserver() : BtObexServiceObserver
  • ~BtObexSetPathRequest() : BtObexSetPathRequest
  • ~BtObexTransport() : BtObexTransport
  • ~BtObexTransportDisconnectEvent() : BtObexTransportDisconnectEvent
  • ~BtObexUnregisterClientRequest() : BtObexUnregisterClientRequest
  • ~BtObexUnregisterEvent() : BtObexUnregisterEvent
  • ~BtObexUnregisterServerRequest() : BtObexUnregisterServerRequest
  • ~BtObservableService() : BtObservableService
  • ~BtOpenMessage() : BtOpenMessage
  • ~BtOperationBase() : BtOperationBase
  • ~BtOperationSelectDevice() : BtOperationSelectDevice
  • ~BtOperationSelectDeviceAndPerformServiceVerify() : BtOperationSelectDeviceAndPerformServiceVerify
  • ~BtPairabilityMessage() : BtPairabilityMessage
  • ~BtPasskeyRequiredMessage() : BtPasskeyRequiredMessage
  • ~BtPasskeyRequiredWindow() : BtPasskeyRequiredWindow
  • ~BtPaSupportedProfileMessage() : BtPaSupportedProfileMessage
  • ~BtProfileActivationMessage() : BtProfileActivationMessage
  • ~BtQuerySupportedProfilesMessage() : BtQuerySupportedProfilesMessage
  • ~BtQuerySupportedProfilesRequest() : BtQuerySupportedProfilesRequest
  • ~BtRemoteDeviceMessage() : BtRemoteDeviceMessage
  • ~BtRemoteDeviceNameMessage() : BtRemoteDeviceNameMessage
  • ~BtRemoteDevicePairMessage() : BtRemoteDevicePairMessage
  • ~BtRequest() : BtRequest
  • ~BtRequestMessage() : BtRequestMessage
  • ~BtRequestOperationMessage() : BtRequestOperationMessage
  • ~BtRequestRespondRequest() : BtRequestRespondRequest
  • ~BtRequestRunningWindow() : BtRequestRunningWindow
  • ~BtRequestStateChangedMessage() : BtRequestStateChangedMessage
  • ~BtRespondAuthorizationMessage() : BtRespondAuthorizationMessage
  • ~BtRespondAuthorizationRequest() : BtRespondAuthorizationRequest
  • ~BtSddbDataElement() : BtSddbDataElement
  • ~BtSddbDataElementFactory() : BtSddbDataElementFactory
  • ~BtSddbDeAlternative() : BtSddbDeAlternative
  • ~BtSddbDeBaseCType() : BtSddbDeBaseCType
  • ~BtSddbDeBigSintBase() : BtSddbDeBigSintBase
  • ~BtSddbDeBigUintBase() : BtSddbDeBigUintBase
  • ~BtSddbDeBoolean() : BtSddbDeBoolean
  • ~BtSddbDeByteBlockType() : BtSddbDeByteBlockType
  • ~BtSddbDeContainer() : BtSddbDeContainer
  • ~BtSddbDeNil() : BtSddbDeNil
  • ~BtSddbDeOneByteDescriptionType() : BtSddbDeOneByteDescriptionType
  • ~BtSddbDeSequence() : BtSddbDeSequence
  • ~BtSddbDeSint128() : BtSddbDeSint128
  • ~BtSddbDeSint16() : BtSddbDeSint16
  • ~BtSddbDeSint32() : BtSddbDeSint32
  • ~BtSddbDeSint64() : BtSddbDeSint64
  • ~BtSddbDeSint8() : BtSddbDeSint8
  • ~BtSddbDeSintBase() : BtSddbDeSintBase
  • ~BtSddbDeString() : BtSddbDeString
  • ~BtSddbDeUint128() : BtSddbDeUint128
  • ~BtSddbDeUint16() : BtSddbDeUint16
  • ~BtSddbDeUint32() : BtSddbDeUint32
  • ~BtSddbDeUint64() : BtSddbDeUint64
  • ~BtSddbDeUint8() : BtSddbDeUint8
  • ~BtSddbDeUintBase() : BtSddbDeUintBase
  • ~BtSddbDeUrl() : BtSddbDeUrl
  • ~BtSddbDeUuid128() : BtSddbDeUuid128
  • ~BtSddbDeUuid16() : BtSddbDeUuid16
  • ~BtSddbDeUuid32() : BtSddbDeUuid32
  • ~BtSddbDeUuidBase() : BtSddbDeUuidBase
  • ~BtSddbDeVariableLengthType() : BtSddbDeVariableLengthType
  • ~BtSddbEvent() : BtSddbEvent
  • ~BtSddbRegisterServiceEvent() : BtSddbRegisterServiceEvent
  • ~BtSddbRequestStateChangedMessage() : BtSddbRequestStateChangedMessage
  • ~BtSddbService() : BtSddbService
  • ~BtSddbServiceAttribute() : BtSddbServiceAttribute
  • ~BtSddbServiceObserver() : BtSddbServiceObserver
  • ~BtSddbServiceRecord() : BtSddbServiceRecord
  • ~BtSddbUnregisterServiceEvent() : BtSddbUnregisterServiceEvent
  • ~BtSendPasskeyMessage() : BtSendPasskeyMessage
  • ~BtSendPasskeyRequest() : BtSendPasskeyRequest
  • ~BtService() : BtService
  • ~BtServiceMessage() : BtServiceMessage
  • ~BtServiceObserver() : BtServiceObserver
  • ~BtServiceRequest() : BtServiceRequest
  • ~BtServiceVerifyMessage() : BtServiceVerifyMessage
  • ~BtServiceVerifyRequest() : BtServiceVerifyRequest
  • ~BtServiceVerifyResult() : BtServiceVerifyResult
  • ~BtServiceVerifyResultMessage() : BtServiceVerifyResultMessage
  • ~BtSetRemoteDeviceNameMessage() : BtSetRemoteDeviceNameMessage
  • ~BtSetRemoteDeviceNameRequest() : BtSetRemoteDeviceNameRequest
  • ~BtSingleConnectionController() : BtSingleConnectionController
  • ~BtStateChangedMessage() : BtStateChangedMessage
  • ~BtSvrDataElement() : BtSvrDataElement
  • ~BtSvrServiceAttribute() : BtSvrServiceAttribute
  • ~BtSvrServiceRecord() : BtSvrServiceRecord
  • ~BtTransport() : BtTransport
  • ~BtTurnOnOffWindow() : BtTurnOnOffWindow
  • ~BtUncancelablePointToPointRequest() : BtUncancelablePointToPointRequest
  • ~BtUncancelableRequest() : BtUncancelableRequest
  • ~BubbleSortProvider() : BubbleSortProvider
  • ~BufferedData() : BufferedData
  • ~BufferedOutputStream() : BufferedOutputStream
  • ~ByteBuffer() : ByteBuffer
  • ~CachingSortProvider() : CachingSortProvider
  • ~CalculatorInputMapper() : CalculatorInputMapper
  • ~CalendarAddRecordWin() : CalendarAddRecordWin
  • ~CalendarApp() : CalendarApp
  • ~CalendarGotoDateWin() : CalendarGotoDateWin
  • ~CalendarGrid() : CalendarGrid
  • ~CalendarGridView() : CalendarGridView
  • ~CalendarListWin() : CalendarListWin
  • ~CalendarMonthSelector() : CalendarMonthSelector
  • ~CalendarMonthSelectorView() : CalendarMonthSelectorView
  • ~CalendarMonthWin() : CalendarMonthWin
  • ~CalendarProvider() : CalendarProvider
  • ~CalendarRecord() : CalendarRecord
  • ~CallAcceptMsg() : CallAcceptMsg
  • ~CallBarredMsg() : CallBarredMsg
  • ~CallBarringActivatedMsg() : CallBarringActivatedMsg
  • ~CallBarringDeactivatedMsg() : CallBarringDeactivatedMsg
  • ~CallBarringHandler() : CallBarringHandler
  • ~CallBarringPasswordChangedMsg() : CallBarringPasswordChangedMsg
  • ~CallBarringStatusMsg() : CallBarringStatusMsg
  • ~CallControlIndMsg() : CallControlIndMsg
  • ~CallControlInfoMsg() : CallControlInfoMsg
  • ~CallDeflectionErrIndicationMsg() : CallDeflectionErrIndicationMsg
  • ~CallDeflectionHandler() : CallDeflectionHandler
  • ~CallDeflectionIndMsg() : CallDeflectionIndMsg
  • ~CallDeflectionRejectedMsg() : CallDeflectionRejectedMsg
  • ~CallDisconnectedMsg() : CallDisconnectedMsg
  • ~CallDisconnectingMsg() : CallDisconnectingMsg
  • ~CalledPartyAlertingMsg() : CalledPartyAlertingMsg
  • ~CallEventMsg() : CallEventMsg
  • ~CallForwardingActivatedMsg() : CallForwardingActivatedMsg
  • ~CallForwardingActiveMsg() : CallForwardingActiveMsg
  • ~CallForwardingDeactivatedMsg() : CallForwardingDeactivatedMsg
  • ~CallForwardingErasedMsg() : CallForwardingErasedMsg
  • ~CallForwardingRegisteredMsg() : CallForwardingRegisteredMsg
  • ~CallForwardingStatusMsg() : CallForwardingStatusMsg
  • ~CallHandler() : CallHandler
  • ~CallHdl() : CallHdl
  • ~CallHdlBase() : CallHdlBase
  • ~CallHeldMsg() : CallHeldMsg
  • ~CallHoldRejectedMsg() : CallHoldRejectedMsg
  • ~CallInfoMsg() : CallInfoMsg
  • ~CallIsWaitingMsg() : CallIsWaitingMsg
  • ~CallNotifyMsg() : CallNotifyMsg
  • ~CallOnHoldMsg() : CallOnHoldMsg
  • ~CallReleaseMsg() : CallReleaseMsg
  • ~CallRetrievedMsg() : CallRetrievedMsg
  • ~CallSetupProgressMsg() : CallSetupProgressMsg
  • ~CallSsAction() : CallSsAction
  • ~CallWaitingActivatedMsg() : CallWaitingActivatedMsg
  • ~CallWaitingDeactivatedMsg() : CallWaitingDeactivatedMsg
  • ~CallWaitingHandler() : CallWaitingHandler
  • ~CallWaitingStatusMsg() : CallWaitingStatusMsg
  • ~Camera() : Camera
  • ~CameraApp() : CameraApp
  • ~CameraMsgStartViewfinding() : CameraMsgStartViewfinding
  • ~CameraMsgStopViewfinding() : CameraMsgStopViewfinding
  • ~CameraOptionSettingsWin() : CameraOptionSettingsWin
  • ~CameraSettings() : CameraSettings
  • ~CameraSettingsWin() : CameraSettingsWin
  • ~CamWin32() : CamWin32
  • ~CancelAction() : CancelAction
  • ~Caret() : Caret
  • ~CbmiProvider() : CbmiProvider
  • ~CbmiRangeProvider() : CbmiRangeProvider
  • ~Cbs() : Cbs
  • ~CbsDispatcher() : CbsDispatcher
  • ~CbsFilterList() : CbsFilterList
  • ~CbsHandler() : CbsHandler
  • ~CbsLimitMsg() : CbsLimitMsg
  • ~CbsNewDataMsg() : CbsNewDataMsg
  • ~CbsNewDataRejArg() : CbsNewDataRejArg
  • ~CbsStartDispatcher() : CbsStartDispatcher
  • ~CbsStopDispatcher() : CbsStopDispatcher
  • ~CcbsRecallMsg() : CcbsRecallMsg
  • ~CcbsResultMsg() : CcbsResultMsg
  • ~CcbsStatusMsg() : CcbsStatusMsg
  • ~CellInfoMsg() : CellInfoMsg
  • ~CenteredTextIndicator() : CenteredTextIndicator
  • ~CfuStatusMsg() : CfuStatusMsg
  • ~Charger() : Charger
  • ~ChargerInfoMsg() : ChargerInfoMsg
  • ~CharItem() : CharItem
  • ~CheckBox() : CheckBox
  • ~CheckBoxAction() : CheckBoxAction
  • ~CheckBoxControl() : CheckBoxControl
  • ~CheckBoxControlView() : CheckBoxControlView
  • ~CheckBoxList() : CheckBoxList
  • ~CheckBoxListView() : CheckBoxListView
  • ~CheckBoxView() : CheckBoxView
  • ~ChildBinData() : ChildBinData
  • ~ChineseQuickSortProvider() : ChineseQuickSortProvider
  • ~ChineseT9InputMapper() : ChineseT9InputMapper
  • ~ChineseT9Wrapper() : ChineseT9Wrapper
  • ~ChvChangedMsg() : ChvChangedMsg
  • ~ChvProvider() : ChvProvider
  • ~CleanupDrawingObtainer() : Image::CleanupDrawingObtainer
  • ~ClientNetAdapter() : ClientNetAdapter
  • ~ClipStatusMsg() : ClipStatusMsg
  • ~ClirAction() : ClirAction
  • ~ClirNotSurpressedMsg() : ClirNotSurpressedMsg
  • ~ClirStatusMsg() : ClirStatusMsg
  • ~CloseAllMsg() : CloseAllMsg
  • ~CloseDataConnMsg() : CloseDataConnMsg
  • ~CloseWindowAction() : CloseWindowAction
  • ~CloseWindowMsg() : CloseWindowMsg
  • ~CmiProvider() : CmiProvider
  • ~CnapInfoReceivedMsg() : CnapInfoReceivedMsg
  • ~CnapStatusMsg() : CnapStatusMsg
  • ~CodecDevice() : CodecDevice
  • ~CodecManager() : CodecManager
  • ~ColpStatusMsg() : ColpStatusMsg
  • ~ColrStatusMsg() : ColrStatusMsg
  • ~Component() : Component
  • ~ComponentIterator() : Control::ComponentIterator
  • ~CompoundItem() : CompoundItem
  • ~CompoundItemIterator() : CompoundItemIterator
  • ~CompoundSmsItem() : CompoundSmsItem
  • ~CompoundTpduItem() : CompoundTpduItem
  • ~Condition() : Condition
  • ~ConfirmAction() : ConfirmAction
  • ~ConnectionStatusMsg() : ConnectionStatusMsg
  • ~Context() : SwitchedRleCompression::Context
  • ~ContextDescription() : ContextDescription
  • ~ContextExecuteMsg() : ContextExecuteMsg
  • ~ContextFeature() : ContextFeature
  • ~ContextFeatureHandle() : ContextFeatureHandle
  • ~ContextFeatureItem() : ContextFeatureItem
  • ~ContextFeatureTriggerMsg() : ContextFeatureTriggerMsg
  • ~ContextManager() : ContextManager
  • ~ContextMenu() : ContextMenu
  • ~ContextMenuClosedMsg() : ContextMenuClosedMsg
  • ~ContextMsg() : ContextMsg
  • ~ContextTableNode() : ContextTableNode
  • ~ContextWakeupMsg() : ContextWakeupMsg
  • ~ContinueSocketTestMsg() : ContinueSocketTestMsg
  • ~Control() : Control
  • ~ControlFrameView() : ControlFrameView
  • ~ControlMsg() : ControlMsg
  • ~CopyHandler() : CopyHandler
  • ~CountryProvider() : CountryProvider
  • ~CphsAuxProvider() : CphsAuxProvider
  • ~CphsServPflProvider() : CphsServPflProvider
  • ~CrssHandler() : CrssHandler
  • ~CsdDataConn() : CsdDataConn
  • ~CsdDataConnAccessor() : CsdDataConnAccessor
  • ~CsdDataConnProfile() : CsdDataConnProfile
  • ~CsdDataConnProvider() : CsdDataConnProvider
  • ~CTControlFrameView() : CTControlFrameView
  • ~CtmInfoIndMsg() : CtmInfoIndMsg
  • ~CTPanelView() : CTPanelView
  • ~CTPositionIndicatorView() : CTPositionIndicatorView
  • ~CTProgressBarView() : CTProgressBarView
  • ~CTPushButtonView() : CTPushButtonView
  • ~CTResourcePack() : CTResourcePack
  • ~CTWindowFrameView() : CTWindowFrameView
  • ~CugCallMsg() : CugCallMsg
  • ~CurrentCallMeterMsg() : CurrentCallMeterMsg
  • ~CurrentChargeDataMsg() : CurrentChargeDataMsg
  • ~CustomizableTheme() : CustomizableTheme
  • ~CustomRingerAudioReference() : CustomRingerAudioReference
  • ~CustomSmafPhraseAudioReference() : CustomSmafPhraseAudioReference
  • ~CustomToneAudioReference() : CustomToneAudioReference
  • ~DataCallContext() : DataCallContext
  • ~DataCallControl() : DataCallControl
  • ~DataCoding() : DataCoding
  • ~DataConn() : DataConn
  • ~DataConnAccessor() : DataConnAccessor
  • ~DataConnApp() : DataConnApp
  • ~DataConnInfoMsg() : DataConnInfoMsg
  • ~DataConnLbModel() : DataConnLbModel
  • ~DataConnOptionWin() : DataConnOptionWin
  • ~DataConnProfile() : DataConnProfile
  • ~DataConnProfileInfoMsg() : DataConnProfileInfoMsg
  • ~DataConnProvider() : DataConnProvider
  • ~DataConnTypeWin() : DataConnTypeWin
  • ~DataConnWin() : DataConnWin
  • ~DataControl() : DataControl
  • ~DataControlBootMsg() : DataControlBootMsg
  • ~DataControlBootProgressMsg() : DataControlBootProgressMsg
  • ~DataControlEndBootMsg() : DataControlEndBootMsg
  • ~DataControlModificationMsg() : DataControlModificationMsg
  • ~DataControlPhonebookStateMsg() : DataControlPhonebookStateMsg
  • ~DataControlStartBootMsg() : DataControlStartBootMsg
  • ~DataHandler() : DataHandler
  • ~DataItem() : DataItem
  • ~DataPack() : DataPack
  • ~DataSink() : DataSink
  • ~DataSource() : DataSource
  • ~DataSourceBinData() : DataSourceBinData
  • ~DateCompoundItem() : DateCompoundItem
  • ~DateEditBox() : DateEditBox
  • ~DateEditBoxView() : DateEditBoxView
  • ~DateEditor() : DateEditor
  • ~DateEditorDocument() : DateEditorDocument
  • ~DateEditorView() : DateEditorView
  • ~DateTimeInputMapper() : DateTimeInputMapper
  • ~DBItemChangedMsg() : DBItemChangedMsg
  • ~DcsLanguageFilterRule() : DcsLanguageFilterRule
  • ~DebugOutputStream() : DebugOutputStream
  • ~DecodingThreadlet() : DecodingThreadlet
  • ~DefaultCaret() : DefaultCaret
  • ~DefaultCheckBoxListView() : DefaultCheckBoxListView
  • ~DefaultCheckBoxView() : DefaultCheckBoxView
  • ~DefaultChineseTheme() : DefaultChineseTheme
  • ~DefaultControlFrameView() : DefaultControlFrameView
  • ~DefaultDisplay() : DefaultDisplay
  • ~DefaultItemRenderer() : DefaultItemRenderer
  • ~DefaultPanelView() : DefaultPanelView
  • ~DefaultPositionIndicatorView() : DefaultPositionIndicatorView
  • ~DefaultProgressBarView() : DefaultProgressBarView
  • ~DefaultPushButtonView() : DefaultPushButtonView
  • ~DefaultRadioButtonListView() : DefaultRadioButtonListView
  • ~DefaultRadioButtonView() : DefaultRadioButtonView
  • ~DefaultSoftkeyBarView() : DefaultSoftkeyBarView
  • ~DefaultTabButtonView() : DefaultTabButtonView
  • ~DefaultTabControlView() : DefaultTabControlView
  • ~DefaultTextListView() : DefaultTextListView
  • ~DefaultTheme() : DefaultTheme
  • ~DefaultWindowFrameView() : DefaultWindowFrameView
  • ~DelegationProviderListener() : DelegationProviderListener
  • ~DeleteComponentMsg() : DeleteComponentMsg
  • ~DeletedNode() : DeletedNode
  • ~DeletedNodeList() : DeletedNodeList
  • ~Desktop() : Desktop
  • ~DeviceContext() : DeviceContext
  • ~DhChannelChangeStatusResMsg() : DhChannelChangeStatusResMsg
  • ~DhChannelCloseReqMsg() : DhChannelCloseReqMsg
  • ~DhChannelDataAvailableResMsg() : DhChannelDataAvailableResMsg
  • ~DhChannelOpenReqMsg() : DhChannelOpenReqMsg
  • ~DhChannelReceiveReqMsg() : DhChannelReceiveReqMsg
  • ~DhChannelSendReqMsg() : DhChannelSendReqMsg
  • ~DiagnosticIndMsg() : DiagnosticIndMsg
  • ~DialogWindow() : DialogWindow
  • ~DirectoryIterator() : DirectoryIterator
  • ~DirtyFileHandler() : DirtyFileHandler
  • ~DisabledFeatureTriggeredMsg() : DisabledFeatureTriggeredMsg
  • ~Dispatcher() : Dispatcher
  • ~Display() : Display
  • ~DisplayDc() : DisplayDc
  • ~DisplayInfoMsg() : DisplayInfoMsg
  • ~DistinctProvider() : DistinctProvider
  • ~DistinctRule() : DistinctRule
  • ~DnsClient() : DnsClient
  • ~DnsClientTest() : DnsClientTest
  • ~DrawableObject() : DrawableObject
  • ~DrawableObjectView() : DrawableObjectView
  • ~DrmConstraint() : DrmConstraint
  • ~DrmDcfParser() : DrmDcfParser
  • ~DrmInfo() : DrmInfo
  • ~DrmMessage() : DrmMessage
  • ~DrmPermission() : DrmPermission
  • ~DrmRightsObject() : DrmRightsObject
  • ~DrmROStoreSingleton() : DrmROStoreSingleton
  • ~DrmSecurity() : DrmSecurity
  • ~DrmWapPushMsg() : DrmWapPushMsg
  • ~DtmfBufferCleanedMsg() : DtmfBufferCleanedMsg
  • ~DtmfRejectMsg() : DtmfRejectMsg
  • ~DtmfStartCnfMsg() : DtmfStartCnfMsg
  • ~DtmfStopCnfMsg() : DtmfStopCnfMsg
  • ~DualFilterProvider() : DualFilterProvider
  • ~DwdDevice() : DwdDevice
  • ~DwdPlayer() : DwdPlayer
  • ~DynamicBitVector() : DynamicBitVector
  • ~DynamicMenuPool() : DynamicMenuPool
  • ~EccProvider() : EccProvider
  • ~EctActiveMsg() : EctActiveMsg
  • ~EctAlertingMsg() : EctAlertingMsg
  • ~EditBox() : EditBox
  • ~EditBoxView() : EditBoxView
  • ~EditorDocument() : EditorDocument
  • ~EditorDocumentObtainer() : EditorDocumentObtainer
  • ~EditorItemNode() : EditorItemNode
  • ~ElementList() : ElementList< T >
  • ~ElementListBase() : ElementListBase
  • ~emcpp_apoxi_OBEXAdapter() : emcpp_apoxi_OBEXAdapter
  • ~EmlppAction() : EmlppAction
  • ~EmlppHandler() : EmlppHandler
  • ~EmlppRegisteredMsg() : EmlppRegisteredMsg
  • ~EmlppStatusMsg() : EmlppStatusMsg
  • ~EmsApp() : EmsApp
  • ~EmsComposeWin() : EmsComposeWin
  • ~EmsCreator() : EmsCreator
  • ~EmsEditor() : EmsEditor
  • ~EmsEditorListener() : EmsEditorListener
  • ~EmServThreadMsg() : EmServThreadMsg
  • ~EmsIeParser() : EmsIeParser
  • ~EmsImage() : EmsImage
  • ~EmsInsertPrompt() : EmsInsertPrompt
  • ~EmsInsertPromptListBoxModel() : EmsInsertPromptListBoxModel
  • ~EmsViewerWin() : EmsViewerWin
  • ~EmzAacDecoder() : EmzAacDecoder
  • ~EmzH264Decoder() : EmzH264Decoder
  • ~EmzMp3Decoder() : EmzMp3Decoder
  • ~EmzMpeg4Decoder() : EmzMpeg4Decoder
  • ~EmzMpeg4Encoder() : EmzMpeg4Encoder
  • ~EmzSbcEncoder() : EmzSbcEncoder
  • ~EncodingThreadlet() : EncodingThreadlet
  • ~EngineeringModeControlResponseMsg() : EngineeringModeControlResponseMsg
  • ~EngineeringReportMsg() : EngineeringReportMsg
  • ~EnglishT9InputMapper() : EnglishT9InputMapper
  • ~EngModeAction() : EngModeAction
  • ~EqualsRule() : EqualsRule
  • ~EventData() : EventData
  • ~ExecutionContext() : ExecutionContext
  • ~ExternalCommunicationHandler() : ExternalCommunicationHandler
  • ~ExternalPdpContextInfoMsg() : ExternalPdpContextInfoMsg
  • ~ExternalTimeoutMsg() : ExternalTimeoutMsg
  • ~ExtPsdContextListener_SerialTerminal() : ExtPsdContextListener_SerialTerminal
  • ~ExtPsdContextListener_SerialTerminalListener() : ExtPsdContextListener_SerialTerminalListener
  • ~ExtPsdContextListener_SioGlueSignalListener() : ExtPsdContextListener_SioGlueSignalListener
  • ~ExtPsdContextListenerImpl_SerialTerminalListener() : ExtPsdContextListenerImpl_SerialTerminalListener
  • ~FatDirectoryIteratorImp() : FatDirectoryIteratorImp
  • ~FatFile() : FatFile
  • ~FatFileImp() : FatFileImp
  • ~FatFsUsbMassStorageReleaseMsg() : FatFsUsbMassStorageReleaseMsg
  • ~FatFsUsbMassStorageRequestMsg() : FatFsUsbMassStorageRequestMsg
  • ~Feature() : Feature
  • ~FeatureBroker() : FeatureBroker
  • ~FeatureChangedMsg() : FeatureChangedMsg
  • ~FeatureHandle() : FeatureHandle
  • ~FeatureItem() : FeatureItem
  • ~FeatureItemContainer() : FeatureItemContainer
  • ~FeatureTriggerMsg() : FeatureTriggerMsg
  • ~FfsFile() : FfsFile
  • ~FfsMenu() : FfsMenu
  • ~FfsTestDispWin() : FfsTestDispWin
  • ~FfsTestMenu() : FfsTestMenu
  • ~FfsTestResultsMenu() : FfsTestResultsMenu
  • ~FfsTestResultsSubMenu() : FfsTestResultsSubMenu
  • ~FfsTests() : FfsTests
  • ~FfsTestSubMenu() : FfsTestSubMenu
  • ~FfsTestThread() : FfsTestThread
  • ~File() : File
  • ~FileBinData() : FileBinData
  • ~FileChunkOperationProgressMsg() : FileChunkOperationProgressMsg
  • ~FileDataSink() : FileDataSink
  • ~FileDataSource() : FileDataSource
  • ~FileFilter() : FileFilter
  • ~FileInputStream() : FileInputStream
  • ~FileNameListBoxModel() : FileNameListBoxModel
  • ~FileNameView() : FileNameView
  • ~FileOutputStream() : FileOutputStream
  • ~FilePack() : FilePack
  • ~FileVisitor() : FileVisitor
  • ~Filter() : Cbs::Filter
  • ~FilterProvider() : FilterProvider
  • ~FilterRule() : FilterRule
  • ~Find2Provider() : Find2Provider
  • ~FindProvider() : FindProvider
  • ~FixedPtrArray() : FixedPtrArray< T >
  • ~FlagCaretaker() : FlagCaretaker
  • ~FlashDirectoryIteratorImp() : FlashDirectoryIteratorImp
  • ~FlashFileImp() : FlashFileImp
  • ~FlashStorageDeviceImp() : FlashStorageDeviceImp
  • ~FlipMsg() : FlipMsg
  • ~FlowLayout() : FlowLayout
  • ~FlsFile() : FlsFile
  • ~FmRadioApplication() : FmRadioApplication
  • ~FmRadioEditWin() : FmRadioEditWin
  • ~FmRadioSelectStrongerFreq() : FmRadioSelectStrongerFreq
  • ~FmRadioSettingsProvider() : FmRadioSettingsProvider
  • ~FmRadioStationsProvider() : FmRadioStationsProvider
  • ~FmRadioWindow() : FmRadioWindow
  • ~FocusNextControlMsg() : FocusNextControlMsg
  • ~FocusPreviousControlMsg() : FocusPreviousControlMsg
  • ~FoggyPanelView() : FoggyPanelView
  • ~FoggyPositionIndicatorView() : FoggyPositionIndicatorView
  • ~FoggyPushButtonView() : FoggyPushButtonView
  • ~FoggySoftkeyBarView() : FoggySoftkeyBarView
  • ~FoggyTheme() : FoggyTheme
  • ~FoggyWindowFrameView() : FoggyWindowFrameView
  • ~Font() : Font
  • ~FontEntry() : FontEntry
  • ~FontPack() : FontPack
  • ~ForwardedCallIncomingMsg() : ForwardedCallIncomingMsg
  • ~ForwardingInfoReceivedMsg() : ForwardingInfoReceivedMsg
  • ~ForwardingSsAction() : ForwardingSsAction
  • ~Fota() : Fota
  • ~Fraction() : Fraction
  • ~FromStackMsg() : FromStackMsg
  • ~FtpAuthProvider() : FtpAuthProvider
  • ~FtpClient() : FtpClient
  • ~FtpConnectMessage() : FtpConnectMessage
  • ~FtpDataServerSocket() : FtpDataServerSocket
  • ~FtpDataSocket() : FtpDataSocket
  • ~FtpDisconnectMessage() : FtpDisconnectMessage
  • ~FtpErrorMessage() : FtpErrorMessage
  • ~FtpInTransfer() : FtpInTransfer
  • ~FtpOutTransfer() : FtpOutTransfer
  • ~FtpRequest() : FtpRequest
  • ~FtpRequestMessage() : FtpRequestMessage
  • ~FtpServer() : FtpServer
  • ~FtpServerConfig() : FtpServerConfig
  • ~FtpServerSocket() : FtpServerSocket
  • ~FtpServiceMessage() : FtpServiceMessage
  • ~FtpSocket() : FtpSocket
  • ~FtpTransfer() : FtpTransfer
  • ~FtpTransferMessage() : FtpTransferMessage
  • ~GatiManager() : GatiManager
  • ~GeneralCompoundItem() : GeneralCompoundItem
  • ~GenericAudioDevice() : GenericAudioDevice
  • ~GenericFeatureData() : GenericFeatureData
  • ~GenericObject() : GenericObject
  • ~GenericWorkerTask() : GenericWorkerTask
  • ~GetFocusMsg() : GetFocusMsg
  • ~GetPasswordMsg() : GetPasswordMsg
  • ~GifImage() : GifImage
  • ~GlassPane() : GlassPane
  • ~GltpAidDataRequests() : GltpAidDataRequests
  • ~GltpAidingDataWin() : GltpAidingDataWin
  • ~GltpAidingRequest() : GltpAidingRequest
  • ~GltpAssistanceData() : GltpAssistanceData
  • ~GltpConnApp() : GltpConnApp
  • ~GltpConnStatusMsg() : GltpConnStatusMsg
  • ~GltpHelloRequest() : GltpHelloRequest
  • ~GltpMsmtRequest() : GltpMsmtRequest
  • ~GltpPositionRequest() : GltpPositionRequest
  • ~GltpProviderImpl() : GltpProviderImpl
  • ~GltpRequest() : GltpRequest
  • ~GltpSignalMapTableNode() : GltpSignalMapTableNode
  • ~GprsAttachStatusMsg() : GprsAttachStatusMsg
  • ~GprsStatusMsg() : GprsStatusMsg
  • ~GreaterRule() : GreaterRule
  • ~Grid() : Grid
  • ~GridLayout() : GridLayout
  • ~GridModel() : GridModel
  • ~GridView() : GridView
  • ~GroupProvider() : GroupProvider
  • ~GsmBandStateMsg() : GsmBandStateMsg
  • ~HandlerListEntry() : HandlerListEntry
  • ~HashTable() : HashTable
  • ~HeapArrayObject() : HeapArrayObject< T >
  • ~HeapDataSink() : HeapDataSink
  • ~HeapDataSource() : HeapDataSource
  • ~HeapObject() : HeapObject< T >
  • ~HindiTextRenderer() : HindiTextRenderer
  • ~HlrDataCorruptedMsg() : HlrDataCorruptedMsg
  • ~HlrSsDataCorruptMsg() : HlrSsDataCorruptMsg
  • ~HomezoneMsg() : HomezoneMsg
  • ~HostDebugTimeStamp() : HostDebugTimeStamp
  • ~HostIniFile() : HostIniFile
  • ~HttpApplication() : HttpApplication
  • ~HttpApplicationSupplier() : HttpApplicationSupplier
  • ~HttpAuthProvider() : HttpAuthProvider
  • ~HttpClient() : HttpClient
  • ~HttpConnectMessage() : HttpConnectMessage
  • ~HttpDisconnectMessage() : HttpDisconnectMessage
  • ~HttpErrorMessage() : HttpErrorMessage
  • ~HttpHandler() : HttpHandler
  • ~HttpRequest() : HttpRequest
  • ~HttpRequestMessage() : HttpRequestMessage
  • ~HttpResponse() : HttpResponse
  • ~HttpServer() : HttpServer
  • ~HttpServerConfig() : HttpServerConfig
  • ~HttpServerSocket() : HttpServerSocket
  • ~HttpServiceMessage() : HttpServiceMessage
  • ~HttpSocket() : HttpSocket
  • ~HttpWapMgr() : HttpWapMgr
  • ~HttpWapMgrBase() : HttpWapMgrBase
  • ~HttpWapMgrPlugin() : HttpWapMgrPlugin
  • ~IconIndicator() : IconIndicator
  • ~IconSet() : IconSet
  • ~IconTextIndicator() : IconTextIndicator
  • ~IconValueIndicator() : IconValueIndicator
  • ~Image() : Image
  • ~ImageBox() : ImageBox
  • ~ImageBoxView() : ImageBoxView
  • ~ImageBrowserApp() : ImageBrowserApp
  • ~ImageBrowserDeleteImageMsg() : ImageBrowserDeleteImageMsg
  • ~ImageBrowserDetailWin() : ImageBrowserDetailWin
  • ~ImageBrowserRenameImageMsg() : ImageBrowserRenameImageMsg
  • ~ImageBrowserServiceMsg() : ImageBrowserServiceMsg
  • ~ImageBrowserTestWin() : ImageBrowserTestWin
  • ~ImageBrowserWin() : ImageBrowserWin
  • ~ImageDecoder() : ImageDecoder
  • ~ImageDecodingProgressMsg() : ImageDecodingProgressMsg
  • ~ImageDrawingInterruptedMsg() : ImageDrawingInterruptedMsg
  • ~ImageEncoder() : ImageEncoder
  • ~ImageEncodingProgressMsg() : ImageEncodingProgressMsg
  • ~ImageFileFilter() : ImageFileFilter
  • ~ImageFilter() : ImageFilter
  • ~ImageIncrementalPdcUpdater() : ImageIncrementalPdcUpdater
  • ~ImageItem() : ImageItem
  • ~ImageListBoxModel() : ImageListBoxModel
  • ~ImageMetaData() : ImageMetaData
  • ~ImageMetaDataRecord() : ImageMetaDataRecord
  • ~ImageObtainer() : ImageObtainer
  • ~ImageRef() : ImageRef
  • ~ImageRefContainer() : ImageRefContainer
  • ~ImageRefGenContainer() : ImageRefGenContainer
  • ~ImageView() : ImageView
  • ~ImageViewListBoxModel() : ImageViewListBoxModel
  • ~ImeiShowAction() : ImeiShowAction
  • ~IMelody() : IMelody
  • ~ImgObtObj() : ImgObtObj
  • ~IncomingCallForwardedMsg() : IncomingCallForwardedMsg
  • ~IncrementalPdcUpdater() : IncrementalPdcUpdater
  • ~IndexTable() : IndexTable< T >
  • ~Indicator() : Indicator
  • ~IndicatorBar() : IndicatorBar
  • ~IndicatorBarPaneObject() : IndicatorBarPaneObject
  • ~IndicatorBarUpdateMsg() : IndicatorBarUpdateMsg
  • ~IndicatorBarView() : IndicatorBarView
  • ~IndicatorDescription() : IndicatorDescription
  • ~IndicatorItem() : IndicatorItem
  • ~IndicatorLocation() : IndicatorLocation
  • ~IndicatorPaneObject() : IndicatorPaneObject
  • ~InetSocket() : InetSocket
  • ~InfoDialog() : InfoDialog
  • ~InformationElement() : InformationElement
  • ~InputAction() : InputAction
  • ~InputAnalyzer() : InputAnalyzer
  • ~InputCharMsg() : InputCharMsg
  • ~InputContext() : InputContext
  • ~InputMapper() : InputMapper
  • ~InputMapperFactory() : InputMapperFactory
  • ~InputParser() : InputParser
  • ~InputStream() : InputStream
  • ~InterrogationResultMsg() : InterrogationResultMsg
  • ~InvalidateMsg() : InvalidateMsg
  • ~IpAddrCompoundItem() : IpAddrCompoundItem
  • ~IpAddrEditor() : IpAddrEditor
  • ~IpAddrEditorDocument() : IpAddrEditorDocument
  • ~IpAddrInputMapper() : IpAddrInputMapper
  • ~IpAddrPrompt() : IpAddrPrompt
  • ~IrdaApp() : IrdaApp
  • ~IrdaObexTransport() : IrdaObexTransport
  • ~IrdaTransport() : IrdaTransport
  • ~IrdaWin() : IrdaWin
  • ~IrSocketAddr() : IrSocketAddr
  • ~IsrDataMarshaller() : IsrDataMarshaller
  • ~Item() : Item
  • ~ItemBox() : ItemBox
  • ~ItemBoxView() : ItemBoxView
  • ~ItemContainer() : ItemContainer
  • ~ItemGrid() : ItemGrid
  • ~ItemLabel() : ItemLabel
  • ~ItemLabelView() : ItemLabelView
  • ~ItemMenu() : ItemMenu
  • ~ItemObj() : ItemObj
  • ~ItemPropertiesChangedMsg() : ItemPropertiesChangedMsg
  • ~ItemRendererProperties() : ItemRendererProperties
  • ~ItemRendererPropertiesChangedMsg() : ItemRendererPropertiesChangedMsg
  • ~ItemTree() : ItemTree
  • ~Iterator() : DeviceManager::Iterator
  • ~JapaneseTextRenderer() : JapaneseTextRenderer
  • ~JapaneseTranscoder() : JapaneseTranscoder
  • ~JoinProvider() : JoinProvider
  • ~JoinProviderListener() : JoinProviderListener
  • ~JoinRule() : JoinRule
  • ~JpegEncoder() : JpegEncoder
  • ~JpegEncodingThreadlet() : JpegEncodingThreadlet
  • ~JpegImage() : JpegImage
  • ~JumpToRowMsg() : JumpToRowMsg
  • ~KeyAutoRepeatMsg() : KeyAutoRepeatMsg
  • ~Keyboard() : Keyboard
  • ~KeyDownMsg() : KeyDownMsg
  • ~KeyManager() : KeyManager
  • ~KeyMapping() : KeyMapping
  • ~KeySequence() : KeySequence
  • ~KeyToneAudioDevice() : KeyToneAudioDevice
  • ~KeyUpMsg() : KeyUpMsg
  • ~L2CapSocketAddr() : L2CapSocketAddr
  • ~LanguageChangedMsg() : LanguageChangedMsg
  • ~LanguageProvider() : LanguageProvider
  • ~LanguageResetAction() : LanguageResetAction
  • ~LcsAppRegisterForMtlrMsg() : LcsAppRegisterForMtlrMsg
  • ~LcsAppResWinMsg() : LcsAppResWinMsg
  • ~LcsAppTransferLocMsg() : LcsAppTransferLocMsg
  • ~LcsAppUtils() : LcsAppUtils
  • ~LcsCommonSignalMapTableNode() : LcsCommonSignalMapTableNode
  • ~LcsMainApp() : LcsMainApp
  • ~LcsMainMenuWin() : LcsMainMenuWin
  • ~LcsMolrResultArg() : LcsMolrResultArg
  • ~LcsOptionsMenuWin() : LcsOptionsMenuWin
  • ~LcsProvider() : LcsProvider
  • ~LcsProviderImpl() : LcsProviderImpl
  • ~LcsProviderImplBase() : LcsProviderImplBase
  • ~LcsRepeatTimer() : LcsRepeatTimer
  • ~LcsReqProcessor() : LcsReqProcessor
  • ~LcsSettingsApp() : LcsSettingsApp
  • ~LcsSettingsUtils() : LcsSettingsUtils
  • ~LcsSignalMapTableNode() : LcsSignalMapTableNode
  • ~LcsSocket() : LcsSocket
  • ~LcsTimer() : LcsTimer
  • ~LcsUtils() : LcsUtils
  • ~LcsWapIntf() : LcsWapIntf
  • ~LcsWString() : LcsWString
  • ~Led() : Led
  • ~LedNotificationMsg() : LedNotificationMsg
  • ~LessRule() : LessRule
  • ~LexAnalyzer() : LexAnalyzer
  • ~LineEditor() : LineEditor
  • ~LinkableBase() : LinkableBase
  • ~ListPropertyDescriptor() : ListPropertyDescriptor
  • ~LocationErrMsg() : LocationErrMsg
  • ~LocationNotifInvokeArg() : LocationNotifInvokeArg
  • ~LocationNotifInvokeMsg() : LocationNotifInvokeMsg
  • ~LocationResMsg() : LocationResMsg
  • ~LocationResultWin() : LocationResultWin
  • ~LocationVerifWin() : LocationVerifWin
  • ~LockedKeyDownMsg() : LockedKeyDownMsg
  • ~LockedKeyMsg() : LockedKeyMsg
  • ~LockProvider() : LockProvider
  • ~LockTable() : LockTable
  • ~LockTableList() : LockTableList
  • ~LocResController() : LocResController
  • ~LongKeyPressMsg() : LongKeyPressMsg
  • ~LookupAlphaIdExtension() : LookupAlphaIdExtension
  • ~LoseFocusMsg() : LoseFocusMsg
  • ~LsaIdentityMsg() : LsaIdentityMsg
  • ~MainHandler() : MainHandler
  • ~MainHandlerAccess() : MainHandlerAccess
  • ~MainProvider() : MainProvider
  • ~MapiAudioReference() : MapiAudioReference
  • ~MappingPolicy() : MappingPolicy
  • ~MbiProvider() : MbiProvider
  • ~MCServiceInterfaceMsg() : MCServiceInterfaceMsg
  • ~MdhGors() : MdhGors
  • ~MeasurementData() : MeasurementData
  • ~MeasurementDataArg() : MeasurementDataArg
  • ~Media() : Media
  • ~MediaBox() : MediaBox
  • ~MediaBoxView() : MediaBoxView
  • ~MediaBrowserUtils() : MediaBrowserUtils
  • ~MediaFilter() : MediaFilter
  • ~MediaInfo() : MediaInfo
  • ~MediaManagerMsg() : MediaManagerMsg
  • ~MediaObtainer() : MediaObtainer
  • ~MediaPathnameVisitor() : MediaPathnameVisitor
  • ~MediaPlayer() : MediaPlayer
  • ~MediaRecorder() : MediaRecorder
  • ~MediaRef() : MediaRef
  • ~MediaRefContainer() : MediaRefContainer
  • ~MediaVisitor() : MediaVisitor
  • ~Melody() : Melody
  • ~MemMap() : MemMap
  • ~MemPool() : MemPool
  • ~Menu() : Menu
  • ~MenuAccessor() : MenuAccessor
  • ~MenuDesc() : MenuDesc
  • ~MenuDescObj() : MenuDescObj
  • ~MenuIdObj() : MenuIdObj
  • ~MenuList() : MenuList
  • ~MenuListView() : MenuListView
  • ~MenuPool() : MenuPool
  • ~MenuProperties() : MenuProperties
  • ~MenuTableNode() : MenuTableNode
  • ~MenuView() : MenuView
  • ~MenuWindow() : MenuWindow
  • ~MergeProvider() : MergeProvider
  • ~Message() : Message
  • ~MessageBox() : MessageBox
  • ~MessageHook() : MessageHook
  • ~MessageIdentifierContainer() : MessageIdentifierContainer
  • ~MessageMapDispatcher() : MessageMapDispatcher
  • ~MessageReferrer() : MessageReferrer
  • ~MetaData() : MetaData, Image::MetaData
  • ~MetaDataRecord() : MetaDataRecord
  • ~MexeDescriptor() : MexeDescriptor
  • ~MidiSound() : MidiSound
  • ~MimeTypeFilter() : MimeTypeFilter
  • ~MinuteTickMsg() : MinuteTickMsg
  • ~MmAocChargingStatusMsg() : MmAocChargingStatusMsg
  • ~MmCallAcceptMsg() : MmCallAcceptMsg
  • ~MmCallDisconnectingMsg() : MmCallDisconnectingMsg
  • ~MmCallDispatcher() : MmCallDispatcher
  • ~MmCallHandler() : MmCallHandler
  • ~MmCallHdl() : MmCallHdl
  • ~MmCallInfo() : MmCallInfo
  • ~MmCallInfoMsg() : MmCallInfoMsg
  • ~MmCallNotifyMsg() : MmCallNotifyMsg
  • ~MmCallReleaseMsg() : MmCallReleaseMsg
  • ~MmCallSerialTerminalListener() : MmCallSerialTerminalListener
  • ~MmCallSetupProgressMsg() : MmCallSetupProgressMsg
  • ~MmCallStatusMsg() : MmCallStatusMsg
  • ~MmCurrentCallMeterMsg() : MmCurrentCallMeterMsg
  • ~MmCurrentChargeDataMsg() : MmCurrentChargeDataMsg
  • ~MmiSimClient() : MmiSimClient
  • ~MmMocSetupAcceptMsg() : MmMocSetupAcceptMsg
  • ~MobileOriginatedUssdHandler() : MobileOriginatedUssdHandler
  • ~MoCallAction() : MoCallAction
  • ~MocSetupAcceptMsg() : MocSetupAcceptMsg
  • ~MocSetupRejectIndMsg() : MocSetupRejectIndMsg
  • ~Model() : Model
  • ~MolrInfo() : MolrInfo
  • ~MolrRepeatInfo() : MolrRepeatInfo
  • ~Mp3AudioDevice() : Mp3AudioDevice
  • ~MP3AudioPlayer() : MP3AudioPlayer
  • ~MptyCallHdl() : MptyCallHdl
  • ~MptyCallReleaseMsg() : MptyCallReleaseMsg
  • ~MptyHoldRejectedMsg() : MptyHoldRejectedMsg
  • ~MptyOnHoldMsg() : MptyOnHoldMsg
  • ~MtcArrivedMsg() : MtcArrivedMsg
  • ~MtcReadyMsg() : MtcReadyMsg
  • ~MtlrInfo() : MtlrInfo
  • ~MultiLineEditor() : MultiLineEditor
  • ~MultiMediaEditor() : MultiMediaEditor
  • ~MultiMediaEditorDocument() : MultiMediaEditorDocument
  • ~MultipartParser() : MultipartParser
  • ~MultiPartyCallInvokedMsg() : MultiPartyCallInvokedMsg
  • ~MultiSlotDispatcher() : MultiSlotDispatcher
  • ~MultiSlotHandler() : MultiSlotHandler
  • ~MultiTapCaret() : MultiTapCaret
  • ~MultiTapInputMapper() : MultiTapInputMapper
  • ~Mutex() : Mutex
  • ~MutexObtainer() : MutexObtainer
  • ~NamePatternFileFilter() : NamePatternFileFilter
  • ~NamePatternStorageDeviceFilter() : NamePatternStorageDeviceFilter
  • ~NativeImage() : NativeImage
  • ~NavigationGuidance() : Control::NavigationGuidance
  • ~NetAdapterHandler() : NetAdapterHandler
  • ~NetworkDispatcher() : NetworkDispatcher
  • ~NetworkHandler() : NetworkHandler
  • ~NetworkInformationMsg() : NetworkInformationMsg
  • ~NetworkSsErrorMsg() : NetworkSsErrorMsg
  • ~NetworkSsRejectedMsg() : NetworkSsRejectedMsg
  • ~NextSocketTestMsg() : NextSocketTestMsg
  • ~NiSharedPtr() : NiSharedPtr< X >
  • ~NoMessage() : NoMessage
  • ~NonCloneable() : NonCloneable
  • ~NonCopyable() : NonCopyable
  • ~NonsharedBinDataDataSource() : NonsharedBinDataDataSource
  • ~NoStackMsgArg() : NoStackMsgArg
  • ~NotEqualsRule() : NotEqualsRule
  • ~NotificationTable() : NotificationTable
  • ~NotificationTableEntry() : NotificationTableEntry
  • ~NumberIdentificationAction() : NumberIdentificationAction
  • ~NumberPrompt() : NumberPrompt
  • ~NumericInputMapper() : NumericInputMapper
  • ~NwDiscStartIndMsg() : NwDiscStartIndMsg
  • ~ObexAbstractPort() : ObexAbstractPort
  • ~ObexAddrMsg() : ObexAddrMsg
  • ~ObexApp() : ObexApp
  • ~ObexAppMsg() : ObexAppMsg
  • ~ObexBuffer() : ObexBuffer
  • ~ObexClient() : ObexClient
  • ~ObexClientDispatcher() : ObexClientDispatcher
  • ~ObexDataServer() : ObexDataServer
  • ~ObexDispatcher() : ObexDispatcher
  • ~ObexEventHandler() : ObexEventHandler
  • ~ObexFtpDataServer() : ObexFtpDataServer
  • ~ObexFtpServer() : ObexFtpServer
  • ~ObexHeaderList() : ObexHeaderList
  • ~ObexMsg() : ObexMsg
  • ~ObexObject() : ObexObject
  • ~ObexOppBinDataPushClient() : ObexOppBinDataPushClient
  • ~ObexOppClient() : ObexOppClient
  • ~ObexOppClientOperation() : ObexOppClientOperation
  • ~ObexOppDataSinkPushServer() : ObexOppDataSinkPushServer
  • ~ObexServer() : ObexServer
  • ~ObexServerDispatcher() : ObexServerDispatcher
  • ~ObexServerInfo() : ObexServerInfo
  • ~ObexServerVisitor() : ObexServerVisitor
  • ~ObexTransportMsg() : ObexTransportMsg
  • ~ObexTransportWin() : ObexTransportWin
  • ~ObexTriggerMsg() : ObexTriggerMsg
  • ~ObexVCardMsg() : ObexVCardMsg
  • ~ObjectObtainer() : ObjectObtainer
  • ~ObjectTreeService() : ObjectTreeService
  • ~ObservableObject() : ObservableObject
  • ~Observer() : Observer
  • ~ObtainableObject() : ObtainableObject
  • ~OmControlIndArg() : OmControlIndArg
  • ~OmMultiSlotIndMsg() : OmMultiSlotIndMsg
  • ~OnDataRcvdMsg() : OnDataRcvdMsg
  • ~OpenContextMenuAction() : OpenContextMenuAction
  • ~OpenPbWinMsg() : OpenPbWinMsg
  • ~OpenWindowAction() : OpenWindowAction
  • ~OutgoingCallForwardedMsg() : OutgoingCallForwardedMsg
  • ~OutputStream() : OutputStream
  • ~PacketFilter() : PdpContext::PacketFilter
  • ~PaintDc() : PaintDc
  • ~Panel() : Panel
  • ~PanelView() : PanelView
  • ~PaneObject() : PaneObject
  • ~ParagraphCompoundItem() : ParagraphCompoundItem
  • ~ParagraphMarker() : ParagraphMarker
  • ~PasswordChangeSsAction() : PasswordChangeSsAction
  • ~PasswordEditor() : PasswordEditor
  • ~PasswordInquiryMsg() : PasswordInquiryMsg
  • ~PasswordReceivedMsg() : PasswordReceivedMsg
  • ~PasswordRejectedMsg() : PasswordRejectedMsg
  • ~Path() : Path
  • ~Pathname() : Pathname
  • ~PathProfile() : PathProfile
  • ~PbAbstractWin() : PbAbstractWin
  • ~PbAction() : PbAction
  • ~PbAdvDataHandler() : PbAdvDataHandler
  • ~PbAdvDetailAction() : PbAdvDetailAction
  • ~PbAdvDetails() : PbAdvDetails
  • ~PbAlphaTagRequestMsg() : PbAlphaTagRequestMsg
  • ~PbBaseProvider() : PbBaseProvider
  • ~PbBaseWin() : PbBaseWin
  • ~PbCopyHandler() : PbCopyHandler
  • ~PbDataHandler() : PbDataHandler
  • ~PbDetailAction() : PbDetailAction
  • ~PbDetailEditBox() : PbDetailEditBox
  • ~PbDetailListBox() : PbDetailListBox
  • ~PbDetailProvider() : PbDetailProvider
  • ~PbDetails() : PbDetails
  • ~PbEntryRequestMsg() : PbEntryRequestMsg
  • ~PbEntryShowAction() : PbEntryShowAction
  • ~PbFfsNameHandler() : PbFfsNameHandler
  • ~PbFfsNumberHandler() : PbFfsNumberHandler
  • ~PbLazySynchronizer() : PbLazySynchronizer
  • ~PbManualSynchronizer() : PbManualSynchronizer
  • ~PbMergeProvider() : PbMergeProvider
  • ~PbNameEditBox() : PbNameEditBox
  • ~PbNameFilterProvider() : PbNameFilterProvider
  • ~PbNameHandler() : PbNameHandler
  • ~PbNameNumberProvider() : PbNameNumberProvider
  • ~PbNameProvider() : PbNameProvider
  • ~PbNumberFilterProvider() : PbNumberFilterProvider
  • ~PbNumberHandler() : PbNumberHandler
  • ~PbNumberProvider() : PbNumberProvider
  • ~PbNvRamNameHandler() : PbNvRamNameHandler
  • ~PbNvRamNumberHandler() : PbNvRamNumberHandler
  • ~PbPhoneNumberPrompt() : PbPhoneNumberPrompt
  • ~PbProvColListBoxModel() : PbProvColListBoxModel
  • ~PbProviderListener() : PbProviderListener
  • ~PbProvListBox() : PbProvListBox
  • ~PbProvListBoxModel() : PbProvListBoxModel
  • ~PbRecordHandler() : PbRecordHandler
  • ~PbRecordProvider() : PbRecordProvider
  • ~PbSecuredAction() : PbSecuredAction
  • ~PbSelectGroup() : PbSelectGroup
  • ~PbSelectNoType() : PbSelectNoType
  • ~PbSelectNumberWin() : PbSelectNumberWin
  • ~PbSimProvider() : PbSimProvider
  • ~PbSizeRequestMsg() : PbSizeRequestMsg
  • ~PbSortedProvider() : PbSortedProvider
  • ~PbSynchronizer() : PbSynchronizer
  • ~PbToggleAction() : PbToggleAction
  • ~PdpContextActivationStatusMsg() : PdpContextActivationStatusMsg
  • ~PdpContextControl() : PdpContextControl
  • ~PdpContextManagerControl() : PdpContextManagerControl
  • ~PenDownMsg() : PenDownMsg
  • ~PenUpMsg() : PenUpMsg
  • ~PhonebookApp() : PhonebookApp
  • ~PhonebookRenumberedMsg() : PhonebookRenumberedMsg
  • ~PhonebookWin() : PhonebookWin
  • ~PhoneNumber() : PhoneNumber
  • ~PhoneNumberInputMapper() : PhoneNumberInputMapper
  • ~PhoneNumberJoinRule() : PhoneNumberJoinRule
  • ~PhoneNumberMatchRule() : PhoneNumberMatchRule
  • ~PhoneNumberMergeProvider() : PhoneNumberMergeProvider
  • ~PinAction() : PinAction
  • ~PlmnDispatcher() : PlmnDispatcher
  • ~PlmnHandler() : PlmnHandler
  • ~PlmnListEntry() : PlmnListEntry
  • ~PlmnProvider() : PlmnProvider
  • ~PlmnRatDispatcher() : PlmnRatDispatcher
  • ~PlmnScanDispatcher() : PlmnScanDispatcher
  • ~PlmnScanFinishedMsg() : PlmnScanFinishedMsg
  • ~PngDecoder() : PngDecoder
  • ~PngEncoder() : PngEncoder
  • ~PngEncodingThreadlet() : PngEncodingThreadlet
  • ~PngImage() : PngImage
  • ~PortHeaderInformation() : PortHeaderInformation
  • ~PositionIndicator() : PositionIndicator
  • ~PositionIndicatorView() : PositionIndicatorView
  • ~PowerDispatcher() : PowerDispatcher
  • ~PowerDownDispatcher() : PowerDownDispatcher
  • ~PowerHandler() : PowerHandler
  • ~PowerModeIndMsg() : PowerModeIndMsg
  • ~PowerOffMsg() : PowerOffMsg
  • ~PowerOnMsg() : PowerOnMsg
  • ~PowerWakeupMsg() : PowerWakeupMsg
  • ~PppDataConn() : PppDataConn
  • ~PredefinedEmsImage() : PredefinedEmsImage
  • ~PredefinedEmsSound() : PredefinedEmsSound
  • ~PredInputMapper() : PredInputMapper
  • ~PrefExtLangProvider() : PrefExtLangProvider
  • ~PrefLangProvider() : PrefLangProvider
  • ~PrefPlmnProvider() : PrefPlmnProvider
  • ~PreparedSound() : PreparedSound
  • ~PresetAudioReference() : PresetAudioReference
  • ~ProcessMolrMsg() : ProcessMolrMsg
  • ~ProcessNode() : ProcessNode
  • ~ProgressBar() : ProgressBar
  • ~ProgressBarView() : ProgressBarView
  • ~Properties() : CodecDevice::Properties
  • ~Property() : Property
  • ~PropertyDescriptor() : PropertyDescriptor
  • ~PropertyEditor() : PropertyEditor
  • ~PropertyEditorFactory() : PropertyEditorFactory
  • ~PropertyItem() : PropertyItem
  • ~PropertyTriggerMsg() : PropertyTriggerMsg
  • ~Protector() : Protector
  • ~ProvColListBoxWin() : ProvColListBoxWin
  • ~ProvDetailListBoxWin() : ProvDetailListBoxWin
  • ~Provider() : Provider
  • ~ProviderChangedMsg() : ProviderChangedMsg
  • ~ProviderListBox() : ProviderListBox
  • ~ProviderListBoxModel() : ProviderListBoxModel
  • ~ProviderListBoxView() : ProviderListBoxView
  • ~ProviderListener() : ProviderListener
  • ~ProviderProxyContainer() : ProviderProxyContainer
  • ~ProviderProxyItem() : ProviderProxyItem
  • ~ProviderPtr() : ProviderPtr
  • ~ProviderUpdateMsg() : ProviderUpdateMsg
  • ~ProvListBoxWin() : ProvListBoxWin
  • ~PsdDataConn() : PsdDataConn
  • ~PsdDataConnAccessor() : PsdDataConnAccessor
  • ~PsdDataConnProfile() : PsdDataConnProfile
  • ~PsdDataConnProvider() : PsdDataConnProvider
  • ~PushButton() : PushButton
  • ~PushButtonView() : PushButtonView
  • ~QualityOfService() : PdpContext::QualityOfService
  • ~Queue() : EmzUtils::Queue< T >
  • ~QuickSortProvider() : QuickSortProvider
  • ~RadioAudioDevice() : RadioAudioDevice
  • ~RadioButtonAction() : RadioButtonAction
  • ~RadioButtonControl() : RadioButtonControl
  • ~RadioButtonControlView() : RadioButtonControlView
  • ~RadioButtonGroup() : RadioButtonGroup
  • ~RadioButtonList() : RadioButtonList
  • ~RadioButtonListView() : RadioButtonListView
  • ~RadioButtonView() : RadioButtonView
  • ~RamData() : RamData
  • ~RamDataSink() : RamDataSink
  • ~RamDataSource() : RamDataSource
  • ~RamDirectoryIteratorImp() : RamDirectoryIteratorImp
  • ~RamFile() : RamFile
  • ~RamFileImp() : RamFileImp
  • ~RamFileNode() : RamFileNode
  • ~RamFileObj() : RamFileObj
  • ~RamFileSystem() : RamFileSystem
  • ~RamStorageDeviceImp() : RamStorageDeviceImp
  • ~RamStorageMapper() : RamStorageMapper
  • ~RangeMappingPolicy() : RangeMappingPolicy
  • ~RangeRule() : RangeRule
  • ~RatChangeModeChangedMsg() : RatChangeModeChangedMsg
  • ~RatStateMsg() : RatStateMsg
  • ~RealTimeClock() : RealTimeClock
  • ~RecordHandler() : RecordHandler
  • ~RecordSettings() : RecordSettings
  • ~RedialSetupMsg() : RedialSetupMsg
  • ~RedialStartedMsg() : RedialStartedMsg
  • ~RedialStatusMsg() : RedialStatusMsg
  • ~RedialStoppedMsg() : RedialStoppedMsg
  • ~RedialSuccessMsg() : RedialSuccessMsg
  • ~RedrawDisplayMsg() : RedrawDisplayMsg
  • ~ReferableObject() : ReferableObject
  • ~RefreshComponentMsg() : RefreshComponentMsg
  • ~RegApp() : RegApp
  • ~RegAppFirstWin() : RegAppFirstWin
  • ~RegAppWin() : RegAppWin
  • ~RegBlobObject() : RegBlobObject
  • ~RegCbNotifyMsg() : RegCbNotifyMsg
  • ~RegDeletionBufferEntry() : RegDeletionBufferEntry
  • ~RegEncoderDecoder() : RegEncoderDecoder
  • ~RegistrationAllowedMsg() : RegistrationAllowedMsg
  • ~RegistrationChangeMsg() : RegistrationChangeMsg
  • ~RegistrationSuccessMsg() : RegistrationSuccessMsg
  • ~RegistryInterface() : RegistryInterface
  • ~RegIterator() : RegIterator
  • ~RegNodeBuffer() : RegNodeBuffer
  • ~RegNotifyMsg() : RegNotifyMsg
  • ~RegTcpSocket() : RegTcpSocket
  • ~RemotePartyActionMsg() : RemotePartyActionMsg
  • ~RenameFileDialog() : RenameFileDialog
  • ~ResourceID() : ResourceID
  • ~ResultWinBase() : ResultWinBase
  • ~RfcommSocketAddr() : RfcommSocketAddr
  • ~RfsMediaAvailableStatusMsg() : RfsMediaAvailableStatusMsg
  • ~RfsObexFtpServer() : RfsObexFtpServer
  • ~RfsStorageDeviceRegistrationStatusMsg() : RfsStorageDeviceRegistrationStatusMsg
  • ~RichTextCompoundItem() : RichTextCompoundItem
  • ~RingerAudioDevice() : RingerAudioDevice
  • ~RomData() : RomData
  • ~RomFont() : RomFont
  • ~RootDirectoryIteratorImp() : RootDirectoryIteratorImp
  • ~RootFileImp() : RootFileImp
  • ~RootStorageDeviceImp() : RootStorageDeviceImp
  • ~RootStorageDeviceIterator() : RootStorageDeviceIterator
  • ~RtcAlarmReachedMsg() : RtcAlarmReachedMsg
  • ~RtcDateChangedMsg() : RtcDateChangedMsg
  • ~RtcInfoMsg() : RtcInfoMsg
  • ~RtcTimeChangedMsg() : RtcTimeChangedMsg
  • ~RtStreamingBuffer() : RtStreamingBuffer
  • ~RtStreamingConn() : RtStreamingConn
  • ~RtStreamingEndPoint() : RtStreamingEndPoint
  • ~SaLocationErrArg() : SaLocationErrArg
  • ~SaMolrResultArg() : SaMolrResultArg
  • ~SaProviderImpl() : SaProviderImpl
  • ~SaSignalMapTableNode() : SaSignalMapTableNode
  • ~SatteliteGraphWin() : SatteliteGraphWin
  • ~SatteliteInfoWin() : SatteliteInfoWin
  • ~SaveEntryInPhonebookMsg() : SaveEntryInPhonebookMsg
  • ~SaveNoAction() : SaveNoAction
  • ~SavingProgressWin() : SavingProgressWin
  • ~Scheduler() : Scheduler
  • ~ScicosMpeg4VideoDecoder() : ScicosMpeg4VideoDecoder
  • ~ScicosMpeg4VideoEncoder() : ScicosMpeg4VideoEncoder
  • ~SearchBox() : SearchBox
  • ~SelectionBox() : SelectionBox
  • ~SelectionBoxView() : SelectionBoxView
  • ~SelectionChangedMsg() : SelectionChangedMsg
  • ~SelfLocationDialog() : SelfLocationDialog
  • ~Semaphore() : Semaphore
  • ~SemObtainer() : SemObtainer
  • ~SendRequestMsg() : SendRequestMsg
  • ~SendSmsMsg() : SendSmsMsg
  • ~SerDataConnAccessor() : SerDataConnAccessor
  • ~SerDataConnProvider() : SerDataConnProvider
  • ~SerialClientSocket() : SerialClientSocket
  • ~SerialIoAdapter() : SerialIoAdapter
  • ~SerialIoSet() : SerialIoSet
  • ~SerialServerSocket() : SerialServerSocket
  • ~SerialSocket() : SerialSocket
  • ~SerialTerminal() : SerialTerminal
  • ~SerialTerminalListener() : SerialTerminalListener
  • ~SerialTerminalSocket() : SerialTerminalSocket
  • ~Server() : Server
  • ~ServerAddressWin() : ServerAddressWin
  • ~ServerClient() : ServerClient
  • ~ServerConfig() : ServerConfig
  • ~Service() : Service
  • ~ServiceThread() : ServiceThread
  • ~ServiceThreadStarter() : ServiceThreadStarter
  • ~ServiceThreadTerminateMsg() : ServiceThreadTerminateMsg
  • ~SetLanguageAction() : SetLanguageAction
  • ~SetThemeAction() : SetThemeAction
  • ~SetupDataConnMsg() : SetupDataConnMsg
  • ~SharedPtr() : SharedPtr< T_obj >
  • ~SharedTimer() : SharedTimer
  • ~SharedTimerMsg() : SharedTimerMsg
  • ~SharedTriggerTimer() : SharedTriggerTimer< T >
  • ~ShutdownRequestMsg() : ShutdownRequestMsg
  • ~SiChannelCloseInfoIndMsg() : SiChannelCloseInfoIndMsg
  • ~SiChannelOpenPromptReqMsg() : SiChannelOpenPromptReqMsg
  • ~SiChannelReceiveInfoIndMsg() : SiChannelReceiveInfoIndMsg
  • ~SiChannelSendInfoIndMsg() : SiChannelSendInfoIndMsg
  • ~SigDispatcher() : SigDispatcher
  • ~SigHandler() : SigHandler
  • ~SignalHandler() : SignalHandler
  • ~SignalQualityLevelMsg() : SignalQualityLevelMsg
  • ~SignalStrengthLevelMsg() : SignalStrengthLevelMsg
  • ~SimAccessor() : SimAccessor
  • ~SimAlphaIdentifier() : SimAlphaIdentifier
  • ~SimAuxHandler() : SimAuxHandler
  • ~SimBrowserTermResMsg() : SimBrowserTermResMsg
  • ~SimCallSetupMsg() : SimCallSetupMsg
  • ~SimCallSetupRejectedMsg() : SimCallSetupRejectedMsg
  • ~SimChvHandler() : SimChvHandler
  • ~SimCphsHandler() : SimCphsHandler
  • ~SimDispatcher() : SimDispatcher
  • ~SimDisplayTextMsg() : SimDisplayTextMsg
  • ~SimDisplayTextOptions() : SimDisplayTextOptions
  • ~SimEndTransactionMsg() : SimEndTransactionMsg
  • ~SimErrorMsg() : SimErrorMsg
  • ~SimGetInkeyMsg() : SimGetInkeyMsg
  • ~SimGetInkeyOptions() : SimGetInkeyOptions
  • ~SimGetInputMsg() : SimGetInputMsg
  • ~SimGetInputOptions() : SimGetInputOptions
  • ~SimHandler() : SimHandler
  • ~SimIconDescription() : SimIconDescription
  • ~SimIconIdentifier() : SimIconIdentifier
  • ~SimIconQualifier() : SimIconQualifier
  • ~SimImage() : SimImage
  • ~SimItemId() : SimItemId
  • ~SimItemIdentifier() : SimItemIdentifier
  • ~SimLaunchBrowserPromptReqMsg() : SimLaunchBrowserPromptReqMsg
  • ~SimLaunchBrowserReqMsg() : SimLaunchBrowserReqMsg
  • ~SimLockStatusMsg() : SimLockStatusMsg
  • ~SimMenuItemSelectionFailedMsg() : SimMenuItemSelectionFailedMsg
  • ~SimMexeCertificate() : SimMexeCertificate
  • ~SimNextActionIdentifier() : SimNextActionIdentifier
  • ~SimPbBaseHandler() : SimPbBaseHandler
  • ~SimPbEntry() : SimPbEntry
  • ~SimPbEntryCont() : SimPbEntryCont
  • ~SimPduHandler() : SimPduHandler
  • ~SimPhoneBookEntry() : SimPhoneBookEntry
  • ~SimPlayToneMsg() : SimPlayToneMsg
  • ~SimpleAppContext() : SimpleAppContext
  • ~SimpleAudioDevice() : SimpleAudioDevice
  • ~SimpleMap() : SimpleMap< TKey, TValue >
  • ~SimpleMutex() : SimpleMutex
  • ~SimpleScheduler() : SimpleScheduler
  • ~SimpleSemaphore() : SimpleSemaphore
  • ~SimpleTextRenderer() : SimpleTextRenderer
  • ~SimRefreshMsg() : SimRefreshMsg
  • ~SimRefreshResetMsg() : SimRefreshResetMsg
  • ~SimResetConfirmationMsg() : SimResetConfirmationMsg
  • ~SimResetDoneMsg() : SimResetDoneMsg
  • ~SimSelectItemMsg() : SimSelectItemMsg
  • ~SimSelectItemOptions() : SimSelectItemOptions
  • ~SimServices() : SimServices
  • ~SimSetupIdleModeTextMsg() : SimSetupIdleModeTextMsg
  • ~SimSetupIdleModeTextOptions() : SimSetupIdleModeTextOptions
  • ~SimSetupMenuMsg() : SimSetupMenuMsg
  • ~SimSetupMenuOptions() : SimSetupMenuOptions
  • ~SimSmsParameter() : SimSmsParameter
  • ~SimSmsParamHandler() : SimSmsParamHandler
  • ~SimSmsSentMsg() : SimSmsSentMsg
  • ~SimSsSentMsg() : SimSsSentMsg
  • ~SimStateChangedMsg() : SimStateChangedMsg
  • ~SimTextString() : SimTextString
  • ~SimTkHandler() : SimTkHandler
  • ~SimTkLanguageNotificationMsg() : SimTkLanguageNotificationMsg
  • ~SimTkLceService() : SimTkLceService
  • ~SimTkMainMenuProvider() : SimTkMainMenuProvider
  • ~SimTkProfileGetCnfMsg() : SimTkProfileGetCnfMsg
  • ~SimTkProfileSetCnfMsg() : SimTkProfileSetCnfMsg
  • ~SimTkProfileSetRejMsg() : SimTkProfileSetRejMsg
  • ~SimTkRefreshStartMsg() : SimTkRefreshStartMsg
  • ~SimTkRunAtCmdInfoIndMsg() : SimTkRunAtCmdInfoIndMsg
  • ~SimTkSendDtmfEndIndMsg() : SimTkSendDtmfEndIndMsg
  • ~SimTkSendDtmfIndMsg() : SimTkSendDtmfIndMsg
  • ~SimTkSetupEventMsg() : SimTkSetupEventMsg
  • ~SimUserDispatcher() : SimUserDispatcher
  • ~SingleArgHook() : SingleArgHook< T >
  • ~SioGlueSignalListener() : SioGlueSignalListener
  • ~SkipSocketTestMsg() : SkipSocketTestMsg
  • ~SmafSound() : SmafSound
  • ~SmoothScrollInfo() : AbstractGrid::SmoothScrollInfo
  • ~Sms() : Sms
  • ~SmsAlert() : SmsAlert
  • ~SmsApp() : SmsApp
  • ~SmsBasicProvider() : SmsBasicProvider
  • ~SmsClass0Provider() : SmsClass0Provider
  • ~SmsCommand() : SmsCommand
  • ~SmsComposeWin() : SmsComposeWin
  • ~SmsContext() : SmsContext
  • ~SmsControlIndMsg() : SmsControlIndMsg
  • ~SmsCountProvider() : SmsCountProvider
  • ~SmsDeliver() : SmsDeliver
  • ~SmsDispatcher() : SmsDispatcher
  • ~SmsEditor() : SmsEditor
  • ~SmsFactory() : SmsFactory
  • ~SmsFolderProvider() : SmsFolderProvider
  • ~SmsHandler() : SmsHandler
  • ~SmsIndicationState() : SmsIndicationState
  • ~SmsInfoBox() : SmsInfoBox
  • ~SmsMessageWaitingChangedMsg() : SmsMessageWaitingChangedMsg
  • ~SmsMsgWaitingProvider() : SmsMsgWaitingProvider
  • ~SmsNewMessageMsg() : SmsNewMessageMsg
  • ~SmsNewSocketDataMsg() : SmsNewSocketDataMsg
  • ~SmsNewStatusReportMsg() : SmsNewStatusReportMsg
  • ~SmsParamProvider() : SmsParamProvider
  • ~SmsPortDataRecvMsg() : SmsPortDataRecvMsg
  • ~SmsPrefStorageMediaChangedMsg() : SmsPrefStorageMediaChangedMsg
  • ~SmsProvider() : SmsProvider
  • ~SmsReadProvider() : SmsReadProvider
  • ~SmsSendConfirmMsg() : SmsSendConfirmMsg
  • ~SmsSendDispatcher() : SmsSendDispatcher
  • ~SmsSendingConfirmDialog() : SmsSendingConfirmDialog
  • ~SmsSendRejectMsg() : SmsSendRejectMsg
  • ~SmsSentProvider() : SmsSentProvider
  • ~SmsServiceDocumentMsg() : SmsServiceDocumentMsg
  • ~SmsServiceMsg() : SmsServiceMsg
  • ~SmsSettingsProvider() : SmsSettingsProvider
  • ~SmsSocket() : SmsSocket
  • ~SmsSpaceAvailableMsg() : SmsSpaceAvailableMsg
  • ~SmsSpaceExceededMsg() : SmsSpaceExceededMsg
  • ~SmsStatusReport() : SmsStatusReport
  • ~SmsSubmit() : SmsSubmit
  • ~SmsTemplateProvider() : SmsTemplateProvider
  • ~SmsTextParser() : SmsTextParser
  • ~SmsUnreadProvider() : SmsUnreadProvider
  • ~SmsUnsentProvider() : SmsUnsentProvider
  • ~SmsUtility() : SmsUtility
  • ~SmsViewerWin() : SmsViewerWin
  • ~SmsWStringCache() : SmsWStringCache
  • ~Socket() : Socket
  • ~SocketAddr() : SocketAddr
  • ~SocketControlMsg() : SocketControlMsg
  • ~SocketEventListener() : SocketEventListener
  • ~SocketHandler() : SocketHandler
  • ~SocketPeer() : SocketPeer
  • ~SocketSerialTerminalListener() : SocketSerialTerminalListener
  • ~SocketTestApp() : SocketTestApp
  • ~SocketTestMessage() : SocketTestMessage
  • ~SocketTestProgressWin() : SocketTestProgressWin
  • ~SocketTestResultsWin() : SocketTestResultsWin
  • ~SocketTestSettingsWin() : SocketTestSettingsWin
  • ~SocketTestT() : SocketTestT
  • ~SocketTestT1() : SocketTestT1
  • ~SocketTestT2() : SocketTestT2
  • ~SocketTestT3() : SocketTestT3
  • ~SocketTestT4() : SocketTestT4
  • ~SocketTestT5() : SocketTestT5
  • ~SocketTestT6() : SocketTestT6
  • ~SocketTestT7() : SocketTestT7
  • ~SocketTestT8() : SocketTestT8
  • ~SocketTestWin() : SocketTestWin
  • ~SoftkeyBar() : SoftkeyBar
  • ~SoftkeyBarView() : SoftkeyBarView
  • ~SoftkeyDesc() : SoftkeyDesc
  • ~SortProvider() : SortProvider
  • ~Sound() : Sound
  • ~SoundBrowserApp() : SoundBrowserApp
  • ~SoundBrowserServiceMsg() : SoundBrowserServiceMsg
  • ~SoundBrowserTestWin() : SoundBrowserTestWin
  • ~SoundBrowserWin() : SoundBrowserWin
  • ~SoundFileFilter() : SoundFileFilter
  • ~SoundFilter() : SoundFilter
  • ~SoundItem() : SoundItem
  • ~SoundMetaData() : SoundMetaData
  • ~SoundObtainer() : SoundObtainer
  • ~SoundRef() : SoundRef
  • ~SoundRefContainer() : SoundRefContainer
  • ~SpeechAudioDevice() : SpeechAudioDevice
  • ~SpeechSimpleAudioDevice() : SpeechSimpleAudioDevice
  • ~SsCallBarringActionImpl() : SsCallBarringActionImpl
  • ~SsCallForwardingActionImpl() : SsCallForwardingActionImpl
  • ~SsCallWaitingActionImpl() : SsCallWaitingActionImpl
  • ~SsCcbsDispatcher() : SsCcbsDispatcher
  • ~SsCcbsHandler() : SsCcbsHandler
  • ~SsClipActionImpl() : SsClipActionImpl
  • ~SsClirActionImpl() : SsClirActionImpl
  • ~SsCnapActionImpl() : SsCnapActionImpl
  • ~SsColpActionImpl() : SsColpActionImpl
  • ~SsColrActionImpl() : SsColrActionImpl
  • ~SsControlIndMsg() : SsControlIndMsg
  • ~SsDataReceivedMsg() : SsDataReceivedMsg
  • ~SsDispatcher() : SsDispatcher
  • ~SsEmlppActionImpl() : SsEmlppActionImpl
  • ~SsEndMsg() : SsEndMsg
  • ~SsErrIndicationMsg() : SsErrIndicationMsg
  • ~SsErrorMsg() : SsErrorMsg
  • ~SsFacilityRejectedMsg() : SsFacilityRejectedMsg
  • ~SsHandler() : SsHandler
  • ~SsInfoMsg() : SsInfoMsg
  • ~SsMessage() : SsMessage
  • ~SsNotificationMsg() : SsNotificationMsg
  • ~SsPasswordChangeActionImpl() : SsPasswordChangeActionImpl
  • ~SsRejectedMsg() : SsRejectedMsg
  • ~SsRequestAcceptedMsg() : SsRequestAcceptedMsg
  • ~SsRequestRejectedMsg() : SsRequestRejectedMsg
  • ~SsRequestSentMsg() : SsRequestSentMsg
  • ~SsSuccessMsg() : SsSuccessMsg
  • ~SstProvider() : SstProvider
  • ~SsUssdActionImpl() : SsUssdActionImpl
  • ~SsWaitDispatcher() : SsWaitDispatcher
  • ~StackMsgActiveWaitDispatcher() : StackMsgActiveWaitDispatcher
  • ~StackMsgDispatcher() : StackMsgDispatcher
  • ~StackSsRejectedMsg() : StackSsRejectedMsg
  • ~StandardJoinRule() : StandardJoinRule
  • ~StartSocketTestMsg() : StartSocketTestMsg
  • ~StatusDispatcher() : StatusDispatcher
  • ~StatusProvider() : StatusProvider
  • ~StillCamera() : StillCamera
  • ~StopDtmfCnfArg() : StopDtmfCnfArg
  • ~StopSocketTestMsg() : StopSocketTestMsg
  • ~StorageDevice() : StorageDevice
  • ~StorageDeviceFilter() : StorageDeviceFilter
  • ~StorageDeviceIterator() : StorageDeviceIterator
  • ~StorageDeviceVisitor() : StorageDeviceVisitor
  • ~Stream() : Stream
  • ~StreamAudioPlayer() : StreamAudioPlayer
  • ~StreamAudioReference() : StreamAudioReference
  • ~StreamingCallback() : StreamingCallback
  • ~StreamingInfo() : StreamingInfo
  • ~StreamingReadInfo() : StreamingReadInfo
  • ~StreamingWriteInfo() : StreamingWriteInfo
  • ~StreamObexImpl() : StreamObexImpl
  • ~StreamObexTransport() : StreamObexTransport
  • ~StreamReader() : StreamReader
  • ~StreamWriter() : StreamWriter
  • ~String() : String
  • ~StringDataSink() : StringDataSink
  • ~StrokeBox() : StrokeBox
  • ~StrokeBoxView() : StrokeBoxView
  • ~SubMenuAction() : SubMenuAction
  • ~SubSystem() : SubSystem
  • ~SubUnitReference() : SubUnitReference
  • ~SvgDecodingFinishedMsg() : SvgDecodingFinishedMsg
  • ~SvgFileWrapper() : SvgFileWrapper
  • ~SvgGzFileWrapper() : SvgGzFileWrapper
  • ~SvgHyperlinkSelectMsg() : SvgHyperlinkSelectMsg
  • ~SvgImage() : SvgImage
  • ~SvgImageFileWrapper() : SvgImageFileWrapper
  • ~SvgIoWrapper() : SvgIoWrapper
  • ~SvgPlayer() : SvgPlayer
  • ~SvgStatusMsg() : SvgStatusMsg
  • ~SyncMLManager() : SyncMLManager
  • ~SyncPaintDc() : SyncPaintDc
  • ~SyncPhoneThreadlet() : SyncPhoneThreadlet
  • ~SyncProgressMsg() : SyncProgressMsg
  • ~SysDnsClient() : SysDnsClient
  • ~SystemTimer() : SystemTimer
  • ~T9AddWordMsg() : T9AddWordMsg
  • ~T9EnteredUnknownWordMsg() : T9EnteredUnknownWordMsg
  • ~T9InputMapper() : T9InputMapper
  • ~T9MatrixModeKeypressed() : T9MatrixModeKeypressed
  • ~T9NoWordFoundMsg() : T9NoWordFoundMsg
  • ~T9Pack() : T9Pack
  • ~T9PinyinBox() : T9PinyinBox
  • ~T9PinyinBoxView() : T9PinyinBoxView
  • ~T9PredictiveInputBox() : T9PredictiveInputBox
  • ~T9SymbolEntryRequestMsg() : T9SymbolEntryRequestMsg
  • ~TabButton() : TabButton
  • ~TabButtonView() : TabButtonView
  • ~TabControl() : TabControl
  • ~TabControlView() : TabControlView
  • ~TcpServerTestSocket() : TcpServerTestSocket
  • ~TcpTestSocket() : TcpTestSocket
  • ~TermIos() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • ~TermRspCnfMsg() : TermRspCnfMsg
  • ~TestCheckBoxListView() : TestCheckBoxListView
  • ~TestCheckBoxView() : TestCheckBoxView
  • ~TestControlFrameView() : TestControlFrameView
  • ~TestPositionIndicatorView() : TestPositionIndicatorView
  • ~TestPushButtonView() : TestPushButtonView
  • ~TestRadioButtonListView() : TestRadioButtonListView
  • ~TestRadioButtonView() : TestRadioButtonView
  • ~TestSoftkeyBarView() : TestSoftkeyBarView
  • ~TestTheme() : TestTheme
  • ~TestWindowFrameView() : TestWindowFrameView
  • ~TextBox() : TextBox
  • ~TextBoxView() : TextBoxView
  • ~TextCompoundItem() : TextCompoundItem
  • ~TextEditorDocument() : TextEditorDocument
  • ~TextIconPairArray() : TextIconPairArray
  • ~TextIndicator() : TextIndicator
  • ~TextLine() : TextLine
  • ~TextLineView() : TextLineView
  • ~TextList() : TextList
  • ~TextListView() : TextListView
  • ~TextManager() : MultiMediaEditorDocument::TextManager
  • ~TextMenuAccessor() : TextMenuAccessor
  • ~TextPack() : TextPack
  • ~ThaiTextRenderer() : ThaiTextRenderer
  • ~Theme() : Theme
  • ~ThemeChangedMsg() : ThemeChangedMsg
  • ~ThemeViewIterator() : ThemeViewIterator
  • ~Thread() : Thread
  • ~Threadlet() : Threadlet
  • ~ThreadletNotificationMsg() : ThreadletNotificationMsg
  • ~ThreadSafeProvider() : ThreadSafeProvider
  • ~TimeCompoundItem() : TimeCompoundItem
  • ~TimeEditBox() : TimeEditBox
  • ~TimeEditBoxView() : TimeEditBoxView
  • ~TimeEditor() : TimeEditor
  • ~TimeEditorDocument() : TimeEditorDocument
  • ~TimeFeatureObject() : TimeFeatureObject
  • ~TimeoutCondition() : TimeoutCondition
  • ~Timer() : Timer
  • ~TimerTimeoutMsg() : TimerTimeoutMsg
  • ~TimeZone() : TimeZone
  • ~TimeZoneMsg() : TimeZoneMsg
  • ~TipdBasedActiveWaitDispatcher() : TipdBasedActiveWaitDispatcher
  • ~Tlv() : Tlv
  • ~ToDoApp() : ToDoApp
  • ~ToDoComposeWin() : ToDoComposeWin
  • ~ToDoDateDialogWin() : ToDoDateDialogWin
  • ~ToDoListWin() : ToDoListWin
  • ~ToDoProvider() : ToDoProvider
  • ~ToggleActionGroup() : ToggleActionGroup
  • ~ToneAudioDevice() : ToneAudioDevice
  • ~ToStackMsg() : ToStackMsg
  • ~Tpdu() : Tpdu
  • ~TpduCache() : TpduCache
  • ~TraceOutputStream() : TraceOutputStream
  • ~TransferLocationDialog() : TransferLocationDialog
  • ~TransportNotificationMsg() : TransportNotificationMsg
  • ~TriggerKeyFeature() : TriggerKeyFeature
  • ~TriggerTimer() : TriggerTimer< T >
  • ~TtyInterface() : TtyInterface
  • ~UdpTestSocket() : UdpTestSocket
  • ~UibAccessorTest() : UibAccessorTest
  • ~UibActionAccessor() : UibActionAccessor
  • ~UibApp() : UibApp
  • ~UibFolderWin() : UibFolderWin
  • ~UibInboxProvider() : UibInboxProvider
  • ~UibInboxTest() : UibInboxTest
  • ~UibListBoxModel() : UibListBoxModel
  • ~UibMsgDisplayTest() : UibMsgDisplayTest
  • ~UibNotifyMsg() : UibNotifyMsg
  • ~UibNotifyTest() : UibNotifyTest
  • ~UibPerformanceTest() : UibPerformanceTest
  • ~UibRegisterMsg() : UibRegisterMsg
  • ~UibServiceImpl() : UibServiceImpl
  • ~UibSettingsProvider() : UibSettingsProvider
  • ~UibSettingsTest() : UibSettingsTest
  • ~UibSettingsWin() : UibSettingsWin
  • ~UibSortingTest() : UibSortingTest
  • ~UibTest1() : UibTest1
  • ~UibTest2() : UibTest2
  • ~UibUpdateMsg() : UibUpdateMsg
  • ~UibUpdateThreadlet() : UibUpdateThreadlet
  • ~UndefinedSsAction() : UndefinedSsAction
  • ~UnlockAction() : UnlockAction
  • ~UpdateContextItemMsg() : UpdateContextItemMsg
  • ~UpdateItemMsg() : UpdateItemMsg
  • ~UpdatePbThreadlet() : UpdatePbThreadlet
  • ~Uri() : Uri
  • ~UriMappingTable() : UriMappingTable
  • ~UsbApp() : UsbApp
  • ~UsbObexTransport() : UsbObexTransport
  • ~UsbSubSystem() : UsbSubSystem
  • ~UserActivityListener() : UserActivityListener
  • ~UserData() : UserData
  • ~UserDispatcher() : UserDispatcher
  • ~UsimPbReadyMsg() : UsimPbReadyMsg
  • ~UsimPbResetedMsg() : UsimPbResetedMsg
  • ~UsimPbRwRecord() : UsimPbRwRecord
  • ~UssdAction() : UssdAction
  • ~UssdAnswerMsg() : UssdAnswerMsg
  • ~UssDataReceivedMsg() : UssDataReceivedMsg
  • ~UssdBeginMsg() : UssdBeginMsg
  • ~UssdControlIndMsg() : UssdControlIndMsg
  • ~UssdDataMsg() : UssdDataMsg
  • ~UssdEndMsg() : UssdEndMsg
  • ~UssdIndicationMsg() : UssdIndicationMsg
  • ~UssdNotifyMsg() : UssdNotifyMsg
  • ~UssdRequestMsg() : UssdRequestMsg
  • ~UssdRequestResentMsg() : UssdRequestResentMsg
  • ~UssdResentMsg() : UssdResentMsg
  • ~UtcStatusMessage() : UtcStatusMessage
  • ~UusErasedMsg() : UusErasedMsg
  • ~UusHandler() : UusHandler
  • ~UusNotificationMsg() : UusNotificationMsg
  • ~UusQueryRejectedMsg() : UusQueryRejectedMsg
  • ~UusRegisteredMsg() : UusRegisteredMsg
  • ~UusStatusMsg() : UusStatusMsg
  • ~ValueIndicator() : ValueIndicator
  • ~ValueMappingPropertyDescriptor() : ValueMappingPropertyDescriptor< T_Container >
  • ~ValueTextMap() : ValueTextMap
  • ~VCard() : VCard
  • ~VCardItem() : VCardItem
  • ~Vector() : Vector< T >
  • ~VeryLongKeyPressMsg() : VeryLongKeyPressMsg
  • ~VideoCamera() : VideoCamera
  • ~VideoCaptureParameters() : VideoCaptureParameters
  • ~VideoChannel() : VideoChannel
  • ~VideoCodecCapabilities() : CodecDevice::VideoCodecCapabilities
  • ~VietnameseTextRenderer() : VietnameseTextRenderer
  • ~View() : View
  • ~ViewfinderErrorMsg() : ViewfinderErrorMsg
  • ~VirtualDisplay() : VirtualDisplay
  • ~VoiceMemoApp() : VoiceMemoApp
  • ~VoiceMemoAudioDevice() : VoiceMemoAudioDevice
  • ~VoiceMemoMenuAccessor() : VoiceMemoMenuAccessor
  • ~VoiceMemoRecordWin() : VoiceMemoRecordWin
  • ~VoiceMemoWin() : VoiceMemoWin
  • ~VrAbortEngineIndArg() : VrAbortEngineIndArg
  • ~VrErrorIndArg() : VrErrorIndArg
  • ~VrErrorMsg() : VrErrorMsg
  • ~VrG2AResultIndArg() : VrG2AResultIndArg
  • ~VrHandler() : VrHandler
  • ~VrInitCnfArg() : VrInitCnfArg
  • ~VrIntrmRecResultIndArg() : VrIntrmRecResultIndArg
  • ~VrLoadTemplateReqArg() : VrLoadTemplateReqArg
  • ~VrParamReqArg() : VrParamReqArg
  • ~VrPlaybackFinishedMsg() : VrPlaybackFinishedMsg
  • ~VrPromptMsg() : VrPromptMsg
  • ~VrPropertyResultIndArg() : VrPropertyResultIndArg
  • ~VrRecognitionAbortedMsg() : VrRecognitionAbortedMsg
  • ~VrRecognitionFailedMsg() : VrRecognitionFailedMsg
  • ~VrRecognitionStoppedMsg() : VrRecognitionStoppedMsg
  • ~VrRecogResultIndArg() : VrRecogResultIndArg
  • ~VrResultMsg() : VrResultMsg
  • ~VrSayNameIndArg() : VrSayNameIndArg
  • ~VrStopRecogIndArg() : VrStopRecogIndArg
  • ~VrStoreTemplateReqArg() : VrStoreTemplateReqArg
  • ~VrTrainingAbortedMsg() : VrTrainingAbortedMsg
  • ~VrTrainingFailedMsg() : VrTrainingFailedMsg
  • ~VrTrainingResultMsg() : VrTrainingResultMsg
  • ~VrTrainResultIndArg() : VrTrainResultIndArg
  • ~VrWarningIndArg() : VrWarningIndArg
  • ~VrWarningMsg() : VrWarningMsg
  • ~WaitSsAction() : WaitSsAction
  • ~WapHandler() : WapHandler
  • ~WapProfile() : WapProfile
  • ~WapProfileMgr() : WapProfileMgr
  • ~WbmpImage() : WbmpImage
  • ~WbxmlParserRel() : WbxmlParserRel
  • ~Window() : Window
  • ~WindowFrameView() : WindowFrameView
  • ~WindowHierarchyIterator() : WindowHierarchyIterator
  • ~WString() : WString
  • ~XCallInfoResponseParser() : XCallInfoResponseParser
  • ~XMLParser() : XMLParser
  • ~XmlParserRel() : XmlParserRel
  • ~Zi8AddWordMsg() : Zi8AddWordMsg
  • ~Zi8AlphabetBox() : Zi8AlphabetBox
  • ~Zi8AlphabetBoxView() : Zi8AlphabetBoxView
  • ~Zi8EnteredUnknownWordMsg() : Zi8EnteredUnknownWordMsg
  • ~Zi8InputMapper() : Zi8InputMapper
  • ~Zi8NoWordFoundMsg() : Zi8NoWordFoundMsg
  • ~Zi8PredictiveInputBox() : Zi8PredictiveInputBox
  • ~Zi8SelectionBox() : Zi8SelectionBox
  • ~Zi8SelectionBoxView() : Zi8SelectionBoxView
  • ~Zi8StrokeBox() : Zi8StrokeBox
  • ~Zi8StrokeBoxView() : Zi8StrokeBoxView
  • ~Zi8Wrapper() : Zi8Wrapper
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • A : T_PB_CLIENT_FLAGS, T_PB_REF_FILE_FILL_STATUS, T_PB_REF_FILE_FILL_STATUS_A, T_PB_UNIQUE_FILE_FILL_STATUS, T_PB_GROUPING, T_PB_REFERENCE, T_PB_GROUP_NUMBER, T_PB_FILE_A, T_PB_UNIQUE_FILE, T_PB_FILE_IN_SLICE, ChannelDataArray, LsaIdentifierArray, TimeZoneAndTime
  • a : T_PB_REF_FILE
  • A2dpFormat : StreamAudioReference
  • AacAdifOrAdtsFormat : AudioDecoder
  • AacAdtsWithOneRawDataBlockFormat : AudioDecoder
  • AacFormat : CodecDevice
  • AacFormatAdif : CodecDevice
  • AacFormatAdts : CodecDevice
  • AacFormatEnd : CodecDevice
  • AacFormatRaw : CodecDevice
  • AacFormatType : AudioDecoder
  • AacRawFormat : AudioDecoder
  • aas : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • AbbreviatedNumber : TypeOfAddress
  • Abort() : ObexOppClient, ObexOppBinDataPushClient, ObexLayer, ObexClientOppImpl, ObexClient, IrdaObexImpl, StartUp, BtObexImpl, StackMsgActiveWaitDispatcher, GetPasswordMsg, VrHandler, StreamObexImpl
  • ABORT : SerialIoSet
  • AbortAddrResolution() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • AbortCalendarRecordIns() : CalendarApp
  • AbortCause : TipdBasedActiveWaitDispatcher
  • AbortIfEqualTipd() : TipdBasedActiveWaitDispatcher
  • AbortPasswordRequest() : CallBarringHandler
  • AbortReq() : BtBipClientService
  • AbortRequest() : BtObexClientService
  • AbortResArg() : AbortResArg
  • AbortResMsg() : AbortResMsg
  • AbortResolveAction() : ObexAbstractPort
  • AbortResolveClientAddr() : ObexAbstractTransport, IrdaObexTransport
  • AbortRsp() : BtBipServerService
  • AbortSelection() : ObexMngr, ObexClientDispatcher
  • AbortSelfLocReq() : LcsProviderImplBase, LcsProvider
  • AbsentSubscriber : SsErrorCode
  • Absolute : ValidityPeriodFormat
  • AbstractActionMenuAccessor() : AbstractActionMenuAccessor
  • AbstractAppContext() : AbstractAppContext
  • AbstractButton() : AbstractButton
  • AbstractDelegationProvider() : AbstractDelegationProvider
  • AbstractDevice() : AbstractDevice
  • AbstractEditBox() : AbstractEditBox
  • AbstractEditBoxModel() : AbstractEditBoxModel
  • AbstractEditBoxView() : AbstractEditBoxView
  • AbstractEditor : AbstractEditor, InputMapper
  • AbstractEditorClassType : GuiObjectFactory
  • AbstractEditorItem() : AbstractEditorItem
  • AbstractExternalData() : AbstractExternalData
  • AbstractGrid : AbstractGrid, AbstractGrid::SmoothScrollInfo
  • AbstractGridClassType : GuiObjectFactory
  • AbstractIMelodyParser() : AbstractIMelodyParser
  • AbstractItemContainer() : AbstractItemContainer
  • AbstractItemContainerClassType : GuiObjectFactory
  • AbstractItemContainerPropertyId : AbstractItemContainer
  • AbstractItemGrid() : AbstractItemGrid
  • AbstractItemGridClassType : GuiObjectFactory
  • AbstractItemRenderer() : AbstractItemRenderer
  • AbstractLineEditor() : AbstractLineEditor
  • AbstractLineEditorClassType : GuiObjectFactory
  • AbstractLineEditorView() : AbstractLineEditorView
  • AbstractListBox : AbstractListBox, AbstractListBox::SmoothScrollInfo
  • AbstractListBoxModel() : AbstractListBoxModel
  • AbstractListBoxView() : AbstractListBoxView
  • AbstractLockableDevice() : AbstractLockableDevice
  • AbstractMenuAccessor() : AbstractMenuAccessor
  • AbstractMenuList() : AbstractMenuList
  • AbstractMenuListModel() : AbstractMenuListModel< Item >
  • AbstractMultiLineEditor : AbstractMultiLineEditor, InputMapper
  • AbstractMultiLineEditorClassType : GuiObjectFactory
  • AbstractMultiLineEditorView() : AbstractMultiLineEditorView
  • AbstractPredictiveInputBox() : AbstractPredictiveInputBox
  • AbstractPredictiveInputBoxClassType : GuiObjectFactory
  • AbstractRenderer() : AbstractRenderer
  • AbstractScheduler() : AbstractScheduler
  • AbstractSmsApp() : AbstractSmsApp
  • AbstractSmsComposeWin() : AbstractSmsComposeWin
  • AbstractSmsViewerWin() : AbstractSmsViewerWin
  • AbstractTextObject() : AbstractTextObject
  • AbstractTextObjectClassType : GuiObjectFactory
  • AbstractTextRenderer() : AbstractTextRenderer
  • AbstractToggleAction() : AbstractToggleAction
  • AbstractToogleActionPropertyId : AbstractToggleAction
  • AbstractTransport() : AbstractTransport
  • AcacLanguage() : AcacLanguage
  • acc_burst_type : GprsParam
  • acc_thr : GprsParam
  • AccDispatcher() : AccDispatcher
  • Accept() : TcpServerSocket, SysSocket, ObexServerInfo, ObexOppDataSinkPushServer, SocketPeer, PdpContext, CallHdl, StorageDeviceIterator, File, SioSocketAdapter, SerialServerSocket, SerialIoAdapter, MmCallHdl, MmCallHandler
  • acceptance_outcome : AudioMapiManager::RequestOutcomeType
  • AcceptCall() : BtHsService
  • AcceptCallSetup() : SimTkHandler
  • AcceptCb : SioSocketAdapter
  • AcceptChar() : AbstractEditBox
  • AcceptConnectRequest() : ObexFtpServer
  • AcceptData() : ObexDataServer
  • AcceptDeleteObjectRequest() : ObexFtpServer
  • AcceptFilePullRequest() : ObexFtpServer
  • AcceptFilePushRequest() : ObexFtpServer
  • AcceptFolderListingRequest() : ObexFtpServer
  • AcceptMsg() : ServiceThread, ExecutionContext, Application
  • AcceptPull() : ObexServerOppImpl, ObexOppServer
  • AcceptPush() : ObexServerOppImpl, ObexOppServer
  • AcceptSetCurrentFolderRequest() : ObexFtpServer
  • AcceptsMessage() : ObexAbstractPort
  • access_control_class : CellParam
  • AccessDate : File::Attributes
  • AccessDeniedError : File
  • AccessorAction() : AccessorAction
  • AccessorActionExtension() : AccessorActionExtension
  • Accessory() : MiscAudioDevice, Accessory
  • AccessoryBtHeadset : MiscAudioDevice
  • AccessoryCarKit : MiscAudioDevice
  • AccessoryHeadset : MiscAudioDevice
  • AccessoryIndArg() : AccessoryIndArg
  • AccessoryIndMsg() : AccessoryIndMsg
  • AccessoryList : AudioDeviceManager, AudioAccessoryStore
  • AccessoryNormal : MiscAudioDevice
  • AccessoryStereoPhones : MiscAudioDevice
  • AccessTime : File::Attributes
  • AccHandler() : AccHandler
  • AcDcAdaptor : Accessory
  • ack_blocks : AckNackCnt
  • ack_nack_testparam_cnt_array : AckNackParamList
  • AckNackCnt() : AckNackCnt
  • Acknowledge() : UssdHandler
  • AcquireChannel() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • AcquireClientChannel() : ObexProtocol, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • AcquireGlobalProvider() : MainProvider
  • AcquireServerChannel() : ObexProtocol, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • Action() : CallEvent, Action
  • action : CallEvent, SecLockCommand
  • Action1 : UibInboxTest
  • Action2 : UibInboxTest
  • Action3 : UibInboxTest
  • ACTION_DISABLED_MSG : TestWriter
  • ACTION_EXECUTED_MSG : TestWriter
  • ActionClassType : GuiObjectFactory
  • ActionCnt : UibInboxTest
  • ActionExecutedMsg() : ActionExecutedMsg
  • ActionExtension() : ActionExtension
  • ActionMenuAccessor() : ActionMenuAccessor
  • ActionProp : GuiObjectFactory
  • ActionType : Camera
  • Activate() : StackMsgDispatcher, PdpContext, CallWaitingHandler, CallForwardingHandler, CallBarringHandler
  • ActivateBdn() : SimHandler, SimAccessor, DataHandler
  • ActivateCallBarring() : SsHandler
  • ActivateCallForwarding() : SsHandler
  • ActivateCallWaiting() : SsHandler
  • ActivateCompletionOfCalls : CallSsAction
  • Activated : PdpContext
  • ActivateFdn() : SimHandler, SimAccessor, DataHandler
  • ActivatePending : PdpContextManager
  • ActivateSmsUsage() : SimAccessor, DataHandler
  • ActivateYesNo() : SimGetInkeyOptions
  • Activation : InputParser
  • ActivationRejectedByGgsn : PdpContext
  • ActivationStatus() : PdpContext::ActivationStatus
  • ActiveCallExists() : InputContext
  • ActiveFrameBackground : Color
  • ActiveFrameBackgroundColor : CTResourcePack
  • ActiveFrameForeground : Color
  • ActiveFrameForegroundColor : CTResourcePack
  • ActiveMode : IconState
  • ActiveTitle : Font
  • ActiveWaitDispatcher() : ActiveWaitDispatcher
  • ActiveWindowTitle : Color
  • ActualViewProp : GuiObjectFactory
  • AD1 : ThaiTextRenderer
  • AD2 : ThaiTextRenderer
  • AD3 : ThaiTextRenderer
  • Adc : InternalTracer
  • Add() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer, GlassPane, SingleArgHook< T >, Pathname, Registry, ObjectTreeService, SerialIoSet
  • add_info : SimInfo
  • AddAction() : DataConnOptionWin, TopLevelMenu, SubMenuAction, ActionMenuAccessor
  • AddAlignInfo() : FlowLayout
  • AddAllToFdn() : PhonebookApp
  • AddAppContainer() : System
  • AddAppContext() : AbstractScheduler
  • AddApplication() : AppContainerRoutingTableEntry
  • AddAttachment() : BtBipImageProperties
  • AddAttachmentFormat() : BtBipImagingCapabilities
  • AddAudioInfo() : MediaInfo
  • AddAudioPath() : AudioPathManager
  • AddAuthorizationSet() : WapProfile
  • AddBlobFileNode() : RegNodeBuffer
  • AddBlobNode() : RegNodeBuffer
  • AddBookmark() : AbstractSmsApp
  • AddBooleanNode() : RegNodeBuffer
  • AddChildProvider() : AppendProvider
  • AddClient() : Server
  • AddConstraint() : DrmPermission
  • AddControl() : Control
  • AddDataConnDescription() : DataConnApp
  • AddDataMapping() : MmfPlayer
  • AddDays() : Date
  • AddDefaultConstraints() : XmlParserRel, WbxmlParserRel
  • AddDefaultPermissions() : XmlParserRel, WbxmlParserRel
  • AddDetailMenuAction() : PhonebookWin
  • AddDevice() : DeviceManager
  • AddDispatcher() : ExecutionContext
  • AddDispatcherAction() : AppRoutingTableEntry
  • AddDrawableObject() : Control
  • AddElem() : HashTable
  • AddEntryToFdn() : PhonebookApp
  • AddExplicitCharacter() : T9InputMapper
  • AddExplicitWord() : T9InputMapper
  • AddFeature() : FeaturePool
  • AddFeatures() : FeaturePool
  • AddFileExtension() : Pathname
  • AddHeader() : ObexHeaderList, BtObexService
  • AddHeldCall : CallSsAction
  • AddIcon() : IconSet
  • AddImage() : BtBipImageList
  • AddImageFormat() : BtBipImagingCapabilities
  • AddIndicator() : IndicatorBar
  • AddIntegerNode() : RegNodeBuffer
  • AddInteriorHeader() : RegNodeBuffer
  • AddInteriorNode() : RegNodeBuffer, LocalDataStore
  • AddInteriorNodeEntry() : NodeFileHandler
  • AddItem() : OpenContextMenuAction, ItemContainer, ContextMenu, AbstractItemGrid, AbstractItemContainer, TRadioButtonList< Content >, RadioButtonList, MenuList, CheckBoxList, AbstractMenuListModel< Item >, AudioPresetStore, AudioAccessoryStore, ProviderProxyContainer, FeatureItemContainer, DBService
  • AddKeySequenceFeature() : KeyMapping
  • AddLeafNode() : LocalDataStore
  • AddLockUriInTable() : LockTableList
  • AddMenuAction() : PbAbstractWin
  • AddMenuFeature() : BtHfAppPlugin
  • AddMimeType() : ObexHeaderList
  • AddNewWordToUdb() : Zi8PredictiveInputBox, Zi8InputMapper, T9PredictiveInputBox, T9InputMapper, AbstractPredictiveInputBox
  • AddNodeEntry() : NodeFileHandler
  • AddNumber() : PhonebookApp, PbManualSynchronizer, PbAdvDetails
  • AddNumberToFdn() : PhonebookApp
  • AddPbEntry() : PhonebookApp, PbManualSynchronizer
  • AddPermission() : DrmRightsObject
  • AddPhysicalPortSet() : WapProfile
  • AddPhysicalSet() : WapProfile
  • AddPlayer() : AudioPlayerStore
  • AddPortSet() : WapProfile
  • AddPostMsgHook() : MessageRouter
  • AddProfile() : DataConnProfileManager
  • AddRecord() : CalendarMonthWin, NvRamDataRecordHandler, RecordHandler, DataRecordHandler
  • AddRef() : ReferableObject
  • AddReferenceMapping() : DwdDevice
  • AddRegistration() : NotificationTable
  • Address() : PdpContext::Address
  • address : Subaddress
  • AddressAndMask() : PdpContext::PacketFilter::AddressAndMask
  • AddressEvent() : ObexAbstractPort::AddressEvent
  • AddressingScheme16Bit : InformationElement
  • AddressingScheme8Bit : InformationElement
  • AddrFamily : SysSocketBase, SysSocket
  • AddRightsObject() : DrmRightsObjectStore, DrmRightsObjectContainer
  • AddRootCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • AddSimEntry() : PbManualSynchronizer
  • AddStringNode() : RegNodeBuffer
  • AddTab() : TabControl
  • AddTelNumber() : VCard
  • AddTemporaryProfile() : DataConnProfileManager
  • AddTimer() : ServiceThread, ExecutionContext, Application, AppContainer
  • AddTimeSpan() : DateTime
  • AddToDeleteBuffer() : RegDeletionBufferEntry
  • AddToList() : SerialSocketThread
  • AddToMessage() : SocketTestMessage
  • AddToReadList() : SerialIoSet
  • AddToTitlebar() : Window
  • AddToWriteList() : SerialIoSet
  • AddUri() : NotificationArray, LockTable
  • AddUserCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • AddVariant() : BtBipImageProperties
  • AddVideoInfo() : MediaInfo
  • AddView() : BrowserViewContainer
  • AddVKey() : KeyMapping
  • AddVKeyFeature() : KeyMapping
  • AddVKeyLongFeature() : KeyMapping
  • AddVKeyVeryLongFeature() : KeyMapping
  • AddWindow() : Application
  • AddWordToUdb() : Zi8Wrapper
  • AdjustBlitRect() : VirtualDisplay
  • AdjustBoundingRect() : FrameDc, DisplayDc, DeviceContext, ClientDc, BitmapDc
  • AdjustBounds() : CustomizableTheme
  • AdjustParent() : Component
  • AdjustSize() : Image
  • AdjustStrings() : DrawableObject
  • AdjustThemeDependencies() : ImageListBoxModel, DrawableObject, Grid
  • AdjustWindowTitle() : ItemMenu
  • AdjustWinTitleProp : GuiObjectFactory
  • adn : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • adn_core : T_PB_RECORD, T_PB_CHANGED_FIELD
  • adn_size : PhoneBookInfo
  • adn_tagsize : PhoneBookInfo
  • AdpcmDspFormat : StreamAudioReference
  • AdrType : VCard
  • Advance() : ObexTransportSet::Iterator, ObexHeaderList::ConstIterator, MimeCoder
  • AdvPbAction() : AdvPbAction
  • AdvPbWin() : AdvPbWin
  • AesCrypt() : AesCrypt
  • AffectedProvider : PhonebookApp, MergeProvider, JoinProvider
  • Afrikaans : LanguageManager
  • AidingData() : AidingData
  • AirplaneOn : StartUp
  • AlarmManager : StartUp
  • AlarmMsg() : AlarmMsg
  • AlarmNotificationMsg() : AlarmNotificationMsg
  • AlarmOn : StartUp
  • AlarmReached : RealTimeClock
  • Albanian : LanguageManager
  • Alert() : Alert
  • AlertClassType : GuiObjectFactory
  • AlignInfoProps : GuiObjectFactory
  • AlignInfoPropsType : GuiObjectFactory
  • Alignment : FlowLayout, IndicatorLocation, DateTime
  • All : Control::ComponentIterator, Led
  • AllAsyncServices : InputParser
  • AllBarrServices : InputParser
  • AllBearerServices : InputParser
  • AllCF : InputParser
  • AllConditionalCF : InputParser
  • AllDataCircuitAsync : InputParser
  • AllDataCircuitSync : InputParser
  • AllDataServices : InputParser
  • AllGPRSBearerServices : InputParser
  • Alloc() : Os, Allocator< T >, MemPool, MemPoolEntry
  • Allocate() : HeapVector::VarPage, HeapVector::BlockPage, HeapManager, RegBlobObject, ByteBuffer, BlobObject
  • AllocateCaptureBuffers() : VideoCamera
  • AllocateFunction : HeapVector
  • AllocateOutputBuffers() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoder
  • AllocateSuspendSlot() : DwdPlayer
  • AllocationError : SvgPlayer
  • AllocInputMapper() : EditConfig
  • AllServices : InputParser
  • AllSsServices : InputParser
  • AllSyncServices : InputParser
  • AllTeleServices : InputParser
  • AllTeleServicesExceptSMS : InputParser
  • AllUUSServices : InputParser
  • Alphabet() : InputMapper, DataCodingScheme, EnumTranslationTable
  • AlphabetNotSupported : ShortMessageFailureCause
  • AlphaBlendingMode : DeviceContext
  • AlphaCoding() : AlphaCoding
  • alphaid : UsimEccRecord, CmiRecord
  • AlphaIdentifierTag : Tlv
  • alphaidlength : CmiRecord
  • Alphanumeric : TypeOfAddress
  • AlphanumMode : EditBox
  • AlphanumNameMode : EditBox
  • AlphaTagSizeError() : PbManualSynchronizer
  • AlreadyExistsError : File
  • AlreadyOpenError : File
  • AlreadySet : SvgPlayer
  • Always : InternalTracer
  • always_editable : DataConnApp::EditableSettingTable
  • amplifier : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • AmplifierAudioDevice() : AmplifierAudioDevice
  • AmrDspFormat : StreamAudioReference
  • AmrDtxConfig : CodecDevice
  • AmrDtxEnd : CodecDevice
  • AmrDtxOff : CodecDevice
  • AmrDtxOn : CodecDevice
  • AmrFrameFormatConformance : CodecDevice
  • AmrFrameFormatEnd : CodecDevice
  • AmrFrameFormatIf1 : CodecDevice
  • AmrFrameFormatIf2 : CodecDevice
  • AmrFrameFormatMime : CodecDevice
  • AmrFrameFormatUndefined : CodecDevice
  • AmrIfFormat : CodecDevice
  • AmrSound() : AmrSound
  • Analyze() : LanguageResetAction, ApoxiCommandAction, UssdAction, UndefinedSsAction, WaitSsAction, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, NumberIdentificationAction, ClirAction, PinAction, CallSsAction, EngModeAction, ImeiShowAction, MoCallAction, UnlockAction, PbEntryShowAction, InputAction
  • AndFilterOp : DualFilterProvider
  • AndRop : DeviceContext
  • Angular : CTResourcePack
  • ANIM_OUTPUT_MSG : TestWriter
  • AnimatedStyle : AbstractItemRenderer
  • AnimatedTextLine() : AnimatedTextLine
  • AnimatedTextLineAnimType : GuiObjectFactory
  • AnimatedTextLineClassType : GuiObjectFactory
  • AnimatedTextLineView() : AnimatedTextLineView
  • Animation : Animation, Timer
  • AnimationBmpArrayIterator() : AnimationBmpArrayIterator
  • AnimationBmpPointerArrayIterator() : AnimationBmpPointerArrayIterator
  • AnimationLoadFailureError : SvgPlayer
  • AnimationModel() : AnimationModel
  • AnimationType : Animation
  • AnimSpeedProp : GuiObjectFactory
  • AnimType : ItemRendererProperties
  • Anniversary : CalendarRecord
  • anr : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • anr_ref : T_PB_REF_RECORD
  • Ansi136 : ProtocolIdentifier
  • AntiflickerChanged : Camera
  • AntiFlickerDisabled : Camera
  • AntiFlickerHz50 : Camera
  • AntiFlickerHz60 : Camera
  • AntiFlickerNotSupported : Camera
  • AntiFlickerType : Camera, CameraOptionSettingsWin
  • Antitearing : VideoChannel
  • AocChargingStatus() : EnumTranslationTable
  • AocChargingStatusMsg() : AocChargingStatusMsg
  • AocDispatcher() : AocDispatcher
  • AocHandler() : AocHandler
  • AocIndArg() : AocIndArg
  • Apc : InternalTracer
  • apdu : SimApduData
  • apoxi_emcpp_OBEXAdapter() : apoxi_emcpp_OBEXAdapter
  • ApoxiCommandAction() : ApoxiCommandAction
  • ApoxiThread() : ApoxiThread
  • app : StartUp::Table, AtlApplicationPluginStartup::Table
  • App1 : InternalTracer
  • App2 : InternalTracer
  • App3 : InternalTracer
  • App4 : InternalTracer
  • app_cont_idx : StartUp::Table
  • APP_EXIT_MSG : TestWriter
  • APP_LOAD_MSG : TestWriter
  • app_menu_id : SoftkeyDescTableEntry
  • APP_NAME_LENGTH : InternalTracer
  • AppActionExecutedMsg() : AppActionExecutedMsg
  • AppBegin : InternalTracer
  • AppCloseMsg() : AppCloseMsg
  • AppContainer : AppContainer, Timer, MsgQueue, Message, Application, AbstractScheduler
  • AppContainerRoutingTableEntry() : AppContainerRoutingTableEntry
  • AppContext() : AppContext
  • AppEnd : InternalTracer
  • Append : FfsFile, RegBlobObject, ElementList< T >, ByteBuffer, BlobObject, SmsFactory, UserData, UserDataHeader, Cbs::Filter, FfsHandler, HttpResponse, GltpAssistanceData, RamHandler, RamFileObj, FatHandler, PbRecordProvider, Provider
  • AppendData() : ObexHeaderBuilder
  • AppendDistinct() : ElementList< T >, MessageIdentifierContainer
  • AppendEmptyLine() : AbstractEditBoxModel
  • AppendHeader() : HttpResponse
  • AppendMePhonebookDescriptor() : MePhonebookDescription
  • AppendProvider() : AppendProvider
  • AppendRow() : ToDoProvider, DataConnProvider, CalendarProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, PbMergeProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider, AppendProvider, SmsParamProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider
  • AppendSorted() : MessageIdentifierContainer
  • AppFeatureID() : AppFeatureID
  • AppGetFocusMsg() : AppGetFocusMsg
  • appId : InternalTracer::TraceHeader
  • AppIdProp : GuiObjectFactory
  • APPLICATION : ExecutionContext
  • Application : Application, Timer, Control
  • application_id : MenuPool::FeatureItemContainerContentTableEntry
  • ApplicationAction() : ApplicationAction
  • ApplicationCategoriesFlagsType : CodecDevice
  • ApplicationControlError : Camera
  • ApplicationListEntry() : ApplicationListEntry
  • AppLoseFocusMsg() : AppLoseFocusMsg
  • ApplyContext() : AtlItemMenuWindow, AtlItemGridWindow
  • ApplyDeviceVolume() : SpeechSimpleAudioDevice, MmfPlayer, AudioDeviceBase
  • ApplyFilter() : MediaRefContainer
  • ApplyInitialFilter() : DirectoryIterator
  • ApplyMasterVolume() : AudioDeviceBase
  • ApplyVisitorFilter() : MediaRefContainer
  • AppMutex() : AppMutex
  • AppOpenMsg() : AppOpenMsg
  • AppParams : ObexHeader
  • AppRoutingTableEntry() : AppRoutingTableEntry
  • AppUpdateDisplayMsg() : AppUpdateDisplayMsg
  • April : Date
  • Arabic : LanguageManager, DataCodingScheme
  • ArabicTextRenderer() : ArabicTextRenderer
  • AragonMsg() : AragonMsg
  • Archive : SmsSettingsRecord, File::Attributes
  • archive_ascending_order : SmsSettingsRecord::Persist
  • archive_sorting_colid : SmsSettingsRecord::Persist
  • areTestsFinished() : SocketTestApp
  • arfcn : CellParam, NeighbourCell
  • arfcn_ded : CellParam
  • arg_id : StackMsgArgMap< T >
  • args : MmiSimMsg
  • Armenian : LanguageManager
  • Arrange() : Layouter
  • array : TestWriter
  • array_size : NvRamBlockInfo
  • ArrayTooShort : CodecDevice
  • as_error_code : RrcParam, AsTestparamDatabase
  • AsBoolean() : BtSvrDataElement
  • Asc : InternalTracer
  • Assemble() : SmsFactory
  • AssemblingError : Sms
  • Assertion() : Trap
  • Assign() : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile
  • AssignCaptureBufferPool() : EmzMpeg4Encoder
  • AssignDriveLetter() : RamFileSystem
  • AsSigned() : BtSvrDataElement
  • AsString() : BtSvrDataElement, BtDeviceAddress, BtBipImageHdl
  • AssureInitialized() : FlsFile, RamFile, FatFile
  • AssureValidCaretIndex() : AbstractEditor
  • AssureValidIndex() : AbstractEditor
  • AssureVisibleSelection() : AbstractGrid
  • AsUnsigned() : BtSvrDataElement
  • AsUuid() : BtSvrDataElement
  • AsWString() : BtSvrDataElement
  • Asynchronous : MessageHook
  • AsyncUnitTestMsg() : AsyncUnitTestMsg
  • At : AtCommand
  • Ata : AtCommand
  • AtAccessoryNotificationIndArg() : AtAccessoryNotificationIndArg
  • AtAccessoryRegisterCnfArg() : AtAccessoryRegisterCnfArg
  • AtAccessoryRegisterReqArg() : AtAccessoryRegisterReqArg
  • AtAlphaTagCnfArg() : AtAlphaTagCnfArg
  • AtAlphaTagReqArg() : AtAlphaTagReqArg
  • AtCbst : AtCommand
  • AtcDispatcher() : AtcDispatcher
  • AtCeer : AtCommand
  • AtCgact : AtCommand
  • AtCgactQuery : AtCommand
  • AtcHandler : AtcHandler, AtcDispatcher
  • AtChld : AtCommand
  • AtClcc : AtCommand
  • AtClip : AtCommand
  • AtClir : AtCommand
  • AtCmee : AtCommand
  • AtColp : AtCommand
  • AtCommand() : AtCommand
  • AtCops : AtCommand
  • AtCrc : AtCommand
  • Atd : AtCommand
  • AtGenericCmdIndArg() : AtGenericCmdIndArg
  • AtGenericCmdReqArg() : AtGenericCmdReqArg
  • AtGenericCmdType() : AtGenericCmdType
  • Ath : AtCommand
  • AtHandlerType : ExternalCommunicationHandler
  • AtiAudioPlayer : AtiAudioPlayerRtStreamingSink
  • AtiAudioPlayerRtStreamingConn() : AtiAudioPlayerRtStreamingConn
  • AtiAudioPlayerRtStreamingSink() : AtiAudioPlayerRtStreamingSink
  • AtiAudioPlayerSinkThread : AtiAudioPlayerRtStreamingSink
  • AtiCodecsLib : AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder
  • AtKeyParser() : AtKeyParser
  • AtlApplication() : AtlApplication
  • AtlApplicationPlugin : AtlApplicationPlugin, AtlApplication
  • AtlItemBox() : AtlItemBox
  • AtlItemBoxClassType : GuiObjectFactory
  • AtlItemGrid() : AtlItemGrid
  • AtlItemGridWindow() : AtlItemGridWindow
  • AtlItemListWindow() : AtlItemListWindow
  • AtlItemMenu() : AtlItemMenu
  • AtlItemMenuWindow() : AtlItemMenuWindow
  • AtlItemRenderer() : AtlItemRenderer
  • AtlLabelListWindow() : AtlLabelListWindow
  • AtlWindow : AtlWindow, ContextManager
  • AtlWindowClassType : GuiObjectFactory
  • AtomicIncrement() : RootStorageDeviceIterator, StorageDeviceIterator, DirectoryIterator, RootDirectoryIteratorImp, RamDirectoryIteratorImp, FlashDirectoryIteratorImp, FatDirectoryIteratorImp
  • AtomicItem : EditorItemNode
  • AtomItem() : AtomItem
  • AtPbInfoIndArg() : AtPbInfoIndArg
  • AtPbListCnfArg() : AtPbListCnfArg
  • AtPbListReqArg() : AtPbListReqArg
  • AtPbSelectCnfArg() : AtPbSelectCnfArg
  • AtPbSelectReqArg() : AtPbSelectReqArg
  • AtResponse() : AtResponse
  • AtResponseIterator : AtResponseIterator, AtResponse, AtResponseParameter
  • AtResponseParameter() : AtResponseParameter
  • Attach() : InetSocket, ObexDispatcher, MessageHook, AppContainer, BtObexServerService, BtObexClientService, BtSddbService, BtObservableService, ObservableObject, HeapArrayObject< T >, HeapObject< T >, RtStreamingSource, RtStreamingSink, RtStreamingEndPoint, RtStreamingConn, AtlApplicationPlugin, PdpContextManager, PngDecoder
  • AttachAllowedIndArg() : AttachAllowedIndArg
  • AttachAtlApplicationPlugin() : AtlApplication
  • AttachCnfArg() : AttachCnfArg
  • AttachManagerControl() : PdpContextManager
  • AttachOppServer() : ObexServerOppImpl
  • AttachPending : PdpContextManager
  • AttachRejArg() : AttachRejArg
  • AttachReqArg() : AttachReqArg
  • AttachStatus() : PdpContextManager::AttachStatus
  • AttachStorage() : DataConnProfileManager
  • attempts_left : ChvData
  • attribute : BtAttributeId
  • attribute_range : BtAttributeId
  • AtTypeInvalid : AtCommand
  • AtXcallrefuse : AtCommand
  • AtXcallstat : AtCommand
  • AtXcaoc : AtCommand
  • AtXceer : AtCommand
  • AtXprogress : AtCommand
  • AtXservice : AtCommand
  • Audio() : Audio
  • audio_at_phone : BtHfRecord::Persist
  • audio_vm_mode : VoiceMemoAudioDevice::StartParam
  • AudioAccessoryCfgBackspeaker_NormalMic : AudioAccessoryDetails
  • AudioAccessoryCfgBluetoothHandsfree : AudioAccessoryDetails
  • AudioAccessoryCfgBluetoothHeadset : AudioAccessoryDetails
  • AudioAccessoryCfgBluetoothHeadsetRinger : AudioAccessoryDetails
  • AudioAccessoryCfgCarKit : AudioAccessoryDetails
  • AudioAccessoryCfgExtRingerBackspeaker : AudioAccessoryDetails
  • AudioAccessoryCfgExtRingerHeadset : AudioAccessoryDetails
  • AudioAccessoryCfgExtRingerStereoPhones : AudioAccessoryDetails
  • AudioAccessoryCfgHeadset : AudioAccessoryDetails
  • AudioAccessoryCfgNormal : AudioAccessoryDetails
  • AudioAccessoryCfgRecordingBackspeaker : AudioAccessoryDetails
  • AudioAccessoryCfgRecordingNormal : AudioAccessoryDetails
  • AudioAccessoryCfgStereoPhones : AudioAccessoryDetails
  • AudioAccessoryCfgTTY : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined1 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined11 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined12 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined13 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined14 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined15 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined16 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined17 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined18 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined19 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined2 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined3 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined4 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined5 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined6 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined7 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined8 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined9 : AudioAccessoryDetails
  • AudioAccessoryConfigurationType : AudioAccessoryDetails
  • AudioAccessoryConnectedMsg() : AudioAccessoryConnectedMsg
  • AudioAccessoryDetails() : AudioAccessoryDetails
  • AudioAccessoryStore() : AudioAccessoryStore
  • AudioActiveReference : MmfPlayer
  • AudioAndVideo : MediaPlayer
  • AudioBasedCall : XCallInfoResponseParser
  • AudioChannel : RadioAudioDevice
  • AudioChannelBoth : RadioAudioDevice
  • AudioChannelId : CodecDevice
  • AudioChannelLeft : RadioAudioDevice
  • AudioChannelRight : RadioAudioDevice
  • AudioCodecCapabilities() : CodecDevice::AudioCodecCapabilities
  • AudioContext() : AudioContext
  • AudioDataType : AudioUtility
  • AudioDataTypeImelody : AudioUtility
  • AudioDataTypeMidi : AudioUtility
  • AudioDataTypeMp3 : AudioUtility
  • AudioDataTypeSmaf : AudioUtility
  • AudioDataTypeSmafPhrase : AudioUtility
  • AudioDataTypeUnknown : AudioUtility
  • AudioDevice : Audio
  • AudioDeviceBase() : AudioDeviceBase
  • AudioDeviceEndId : AudioDeviceManager
  • AudioDeviceID : AudioDeviceManager
  • AudioDeviceStatus : AudioDeviceBase
  • AudioDeviceStatusMsg() : AudioDeviceStatusMsg
  • AudioErrorMsg() : AudioErrorMsg
  • AudioErrorType : AudioDeviceBase
  • AudioFastForwardStartedMsg() : AudioFastForwardStartedMsg
  • AudioFmRadioRdsAlternativeFrequenciesMsg() : AudioFmRadioRdsAlternativeFrequenciesMsg
  • AudioFmRadioRdsInfoMsg() : AudioFmRadioRdsInfoMsg
  • AudioFmRadioRdsRadioTextMsg() : AudioFmRadioRdsRadioTextMsg
  • AudioFmRadioRdsRawDataMsg() : AudioFmRadioRdsRawDataMsg
  • AudioFmRadioRdsStationNameMsg() : AudioFmRadioRdsStationNameMsg
  • AudioFmRadioRssiMsg() : AudioFmRadioRssiMsg
  • AudioFmRadioSeekMsg() : AudioFmRadioSeekMsg
  • AudioGain : BtHsVolumeSettingsWin, BtHfVolumeSettingsWin
  • AudioGetPlayPositionMsg() : AudioGetPlayPositionMsg
  • AudioInvalidTone : Audio
  • AudioItem() : AudioItem
  • AudioMapiManager : MapiAudioPlayer
  • AudioMode : Audio
  • AudioMsg() : AudioMsg
  • AudioOnly : MediaPlayer
  • AudioPath() : AudioPath
  • AudioPathDownlink : AudioPath
  • AudioPathManager() : AudioPathManager
  • AudioPathType : AudioPath
  • AudioPathUplink : AudioPath
  • AudioPlayer() : AudioPlayer
  • AudioPlayerEvent() : AudioPlayerEvent
  • AudioPlayerStore() : AudioPlayerStore
  • AudioPlayTimeMsg() : AudioPlayTimeMsg
  • AudioPreset() : AudioPreset
  • AudioPresetSoundToneId : AudioPreset
  • AudioPresetStore() : AudioPresetStore
  • AudioPriority : Audio
  • AudioPriorityManager : StreamAudioReference, AudioReference
  • AudioRadioDeviceNotificationMsg() : AudioRadioDeviceNotificationMsg
  • AudioRcAudioDriverDisabled : GenericAudioDevice
  • AudioRcDeviceAlreadyInitialized : GenericAudioDevice
  • AudioRcDeviceNotInitialized : GenericAudioDevice
  • AudioRcError : GenericAudioDevice
  • AudioRcErrorAllocateHW : GenericAudioDevice
  • AudioRcFileCloseError : GenericAudioDevice
  • AudioRcFileNotFound : GenericAudioDevice
  • AudioRcFormatNotSupported : GenericAudioDevice
  • AudioRcfunctionalityNotAvailable : GenericAudioDevice
  • AudioRcHandleNotUsed : GenericAudioDevice
  • AudioRcMimeTypeNotSupported : GenericAudioDevice
  • AudioRcMp3Info : GenericAudioDevice
  • AudioRcNoHwSupport : GenericAudioDevice
  • AudioRcOk : GenericAudioDevice
  • AudioRcParameterOutOfRange : GenericAudioDevice
  • AudioRcRadioInfo : GenericAudioDevice
  • AudioRcResourceConflict : GenericAudioDevice
  • AudioRcResourceInUse : GenericAudioDevice
  • AudioRcRingerToneError : GenericAudioDevice
  • AudioRcRingerToneFinish : GenericAudioDevice
  • AudioRcSharingViolation : GenericAudioDevice
  • AudioRcStartParamNotSet : GenericAudioDevice
  • AudioRcToneFinish : GenericAudioDevice
  • AudioRecordingStoppedMsg() : AudioRecordingStoppedMsg
  • AudioReference() : AudioReference
  • AudioRestartedMsg() : AudioRestartedMsg
  • AudioResumedMsg() : AudioResumedMsg
  • AudioReturnCode : GenericAudioDevice
  • AudioReturnSuspend() : Mp3AudioDevice
  • AudioRewindStartedMsg() : AudioRewindStartedMsg
  • AudioStartedMsg() : AudioStartedMsg
  • AudioStoppedMsg() : AudioStoppedMsg
  • AudioStreamingSyncMsg() : AudioStreamingSyncMsg
  • AudioSuspendedMsg() : AudioSuspendedMsg
  • AudioTone() : AudioTone
  • AudioToneId : Audio
  • AudioToneToneType() : EnumTranslationTable
  • AudioTrackInfo() : MediaInfo::AudioTrackInfo
  • AudioUserDefinedMsg() : AudioUserDefinedMsg
  • AudioVmMode : VoiceMemoAudioDevice
  • AudioVoiceMemoOutOfSpaceMsg() : AudioVoiceMemoOutOfSpaceMsg
  • AudResource : DwdDevice
  • AudReturnCode : AudioVibratorDevice, AudioError
  • AudSamplFreqNotSupported : MediaManager
  • August : Date
  • AuthChallenge : ObexHeader
  • Authenticate() : PsdDataConn, PdpContext
  • AuthenticatePending : PdpContextManager
  • Authentication() : PdpContext::Authentication
  • AuthenticationFailure : PdpContext
  • AuthMethodHttpBasic : WapProfile
  • AuthMethodHttpDigest : WapProfile
  • AuthMethodWtlsSs : WapProfile
  • AuthorizeUser() : HttpAuthProvider, FtpAuthProvider, AuthProvider
  • AuthorizeUserPassword() : HttpAuthProvider, FtpAuthProvider, AuthProvider
  • AuthProvider() : AuthProvider
  • AuthResponse : ObexHeader
  • AuthType : PsdDataConnProfile
  • Auto : JapaneseTranscoder
  • AutoBalance : Camera
  • AutoCallRestrictIndArg() : AutoCallRestrictIndArg
  • AutoCapitalization : MultiTapInputMapper
  • AutoClearEnabledProp : GuiObjectFactory
  • AutoDeletePhone() : PbSynchronizer, PbLazySynchronizer
  • AutoDeleteSim() : PbSynchronizer, PbLazySynchronizer
  • AutoLayoutProp : GuiObjectFactory
  • AutomaticDeletionGroup : DataCodingScheme
  • AutomaticFlash : Camera
  • AutostartProp : GuiObjectFactory
  • autostore : SmsSettingsRecord::Persist
  • AutoSyncPhone() : PbSynchronizer, PbLazySynchronizer
  • AutoSyncSim() : PbSynchronizer, PbLazySynchronizer
  • AutoValue : CamWin32
  • Aux : InternalTracer
  • AuxiliarySpeech : InputParser, XCallInfoResponseParser
  • AuxProvider() : AuxProvider
  • AV1 : ThaiTextRenderer
  • AV2 : ThaiTextRenderer
  • AV3 : ThaiTextRenderer
  • Available() : InputStream, FileInputStream
  • available : Subaddress
  • AvailableAttributeId : Feature
  • AvrcpConnected : BtAvrcpControllerApplicationWindow
  • AvrcpConnectedAndActive : BtAvrcpControllerApplicationWindow
  • AvrcpNotConnected : BtAvrcpControllerApplicationWindow
  • AvrcpNotSelected : BtAvrcpControllerApplicationWindow
  • AvsBusy : AbstractTransport
  • AvsConflict : AbstractTransport
  • AvsDisabled : AbstractTransport
  • AvsReady : AbstractTransport
  • AvState : AbstractTransport
  • AwaitingFastForwardRespState : MediaPlayer
  • AwaitingInitResp : MediaRecorder, MediaPlayer
  • AwaitingPauseRespState : MediaRecorder, MediaPlayer
  • AwaitingPlayRespState : MediaPlayer
  • AwaitingRecordRespState : MediaRecorder
  • AwaitingRewindRespState : MediaPlayer
  • AwaitingStopRespState : MediaRecorder, MediaPlayer
Generated on Wed Jan 25 00:53:53 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • Back() : ItemMenu, TextMenuAccessor, MenuAccessor, Menu, AbstractMenuAccessor, BtDeviceList, Vector< T >
  • back() : WbxmlVector< T >
  • BackgrColorProp : GuiObjectFactory
  • BackgroundcolorProp : GuiObjectFactory
  • BackgroundDim : CTResourcePack
  • BackgroundImageProp : GuiObjectFactory
  • BackLightMode : BackLight
  • BacklightMode : Display
  • BacklightModeAuto : Display
  • BacklightModeOff : Display
  • BacklightModeOn : Display
  • BackLightOff : BackLight
  • BackLightOn : BackLight
  • BacklightTurnedOff : Display
  • BacklightTurnedOn : Display
  • Backspace() : SmsEditor, EmsEditor, PasswordEditor, AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor, MultiMediaEditor
  • BackToIdleFeature() : BackToIdleFeature
  • BadFileError : File
  • BadFormatError : File
  • BadlyStructuredComponent : TaggedProblemCode
  • BadMediaError : File
  • BadRequest : BtObexResponseCode
  • BAIC : InputParser
  • BAICroaming : InputParser
  • BalanceLevel : AudioReference
  • BandLimits : RadioAudioDevice
  • BandLimitsEuropeUs : RadioAudioDevice
  • BandLimitsJapan : RadioAudioDevice
  • BandSelection() : NetworkHandler
  • BandSelectionIndArg() : BandSelectionIndArg
  • BandSelectionMsg() : BandSelectionMsg
  • BandSelectionReqArg() : BandSelectionReqArg
  • BandStatusMsg() : BandStatusMsg
  • BAOC : InputParser
  • BAOIC : InputParser
  • BAOICexchome : InputParser
  • barring_info : BarringInfoReceivedArg
  • BarringInfoReceivedMsg() : BarringInfoReceivedMsg
  • BarringSsAction() : BarringSsAction
  • Base : IpAddrPrompt, SerDataConnProvider, PsdDataConnProvider, NumberPrompt, IpAddrPrompt, DataConnWin, DataConnTypeWin, DataConnProvider, DataConnOptionWin, CsdDataConnProvider, CalendarProvider, PhonebookWin, PbSortedProvider, PbSimProvider, PbSelectNumberWin, PbRecordProvider, PbNumberProvider, PbNameProvider, PbNameNumberProvider, PbNameFilterProvider, PbBaseWin, PbCallAction, GroupProvider, BasicPbWin, ObexServerPort, ObexServerDispatcher, ObexServer, ObexObjectData, ObexClientPort, ObexClientDispatcher, ObexClient, ObexServerAddr, ObexClientAddr, ObexAddress, SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, CharInputMapItem, KeyUpInputMapItem, KeyDownInputMapItem, IrdaObexTransport, IrdaObexServerAddr, IrdaObexClientAddr, IrdaTransport, TextPack, ProgressBar, FontPack, AbstractTransport, TRadioButtonItem< Content >, RadioButtonModel, IconValueIndicator, Grid, TestSoftkeyBarView, TestRadioButtonView, TestCheckBoxView, BlueSkySoftkeyBarView, BlueSkyRadioButtonView, BlueSkyPushButtonView, BlueSkyCheckBoxView, EditBox, EditBoxPagingTimer, CheckBoxModel, Animation, AnimationView, EditBoxBlinkTimer, AbstractEditBoxModel, SortProvider, RegBlobObject, QuickSortProvider, FindProvider, Find2Provider, GreaterRule, LessRule, RangeRule, NotEqualsRule, EqualsRule, FilterProvider, DistinctProvider, DistinctRule, DateTime, ChineseQuickSortProvider, CachingSortProvider, BubbleSortProvider, BlobPtr, BlobObject, AbstractDelegationProvider, StreamAudioPlayer, ImgObtObj, FeatureItemContainer, ContextFeatureItem, PowerHandler, ExtPsdContextListenerImpl_SerialTerminalListener, SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver, SimItemId, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, WbxmlVector< T >, T9PinyinBox, StrokeBox, SelectionBox, SocketSerialTerminalListener, SerialTerminalSocket, MmCallSerialTerminalListener, MolrRepeatInfo, StatusProvider, SstProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SimTkMainMenuProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PlmnProvider, PbBaseProvider, MbiProvider, LockProvider, EccProvider, DataControl, DataHandler, CphsServPflProvider, CphsAuxProvider, CountryProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • Base64Coder() : Base64Coder
  • base_level : BidiManager::ParagraphContext
  • BaseDataHandler() : BaseDataHandler
  • BaseHandler : StackMsgDispatcher
  • BaseInformationElement() : BaseInformationElement
  • Baseline : TextFormat
  • baseline : FontRes, tagFont
  • basic_serv_group_list : SsData, InterrogateSsResult
  • basic_serv_group_list_size : InterrogateSsResult
  • basic_service : CallBarringFeature, ForwardingFeature
  • BasicPackConnector : BasicPackConnector, TextPack, FontPack, DataPack
  • BasicPbWin() : BasicPbWin
  • BasicServiceMmiCode : InputParser
  • BasicSmsService() : BasicSmsService
  • Basque : LanguageManager
  • BatteryEmpty : Charger
  • BatteryIdError : Charger
  • BatteryLoadLevelMsg() : BatteryLoadLevelMsg
  • BcdNibbleToWChar() : PhoneNumber
  • BcdPlmn() : BcdPlmn
  • BD : ThaiTextRenderer
  • bdn_size : PhoneBookInfo
  • bdn_tagsize : PhoneBookInfo
  • BdnFailed : Sms
  • BdnIndArg() : BdnIndArg
  • BdnReqArg() : BdnReqArg
  • bearer_type : SiBearerDesc_s
  • BearerDisconnectedEvent() : DataConn
  • BearerServiceNotProvisioned : SsErrorCode
  • beat : IMelodyData
  • Begin() : ObexTransportSet, ObexHeaderList, WindowHierarchyIterator, ThemeViewIterator, Control::ComponentIterator, DeviceManager::Iterator, BtDeviceList, Vector< T >, MessageIdentifierRange, DataCodingSchemeRange, Pathname, CompoundItemIterator
  • begin() : WbxmlVector< T >
  • BeginDecoding() : ImageDecoder, PngDecoder
  • BeginDrawing() : PngImage
  • BeginEncoding() : ImageEncoder, PngEncoder, JpegEncoder
  • BeginGlyphRetrieval() : ThaiTextRenderer, AbstractTextRenderer
  • BeginInternalUpdate() : ParagraphCompoundItem
  • BeginOperation() : StreamObexImpl
  • BeginProcessing() : BidiManager
  • BeginScanlineDrawing() : NativeImage, Image, WbmpImage, JpegImage, GifImage, BmpImage
  • BeginTransaction() : UssdHandler, UssdBeginMsg
  • BeginUpdate() : DeviceContext
  • BestFitScaling : Camera, VideoChannel
  • BigEndian16Bit() : BigEndian16Bit
  • BigEndian32Bit() : BigEndian32Bit
  • Bijective : JoinRule
  • BinaryChoiceGetInkey : SimTkProfile
  • Bind() : SysSocket, InetSocket, SocketPeer, SerialServerSocket, SerialIoAdapter, SerialClientSocket
  • BinData : BinData, MemMap
  • BinDataDataSource() : BinDataDataSource
  • BinDataSoundDataSource : AudioReference
  • BindServerChannel() : ObexProtocol, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • BindToMimeType() : ObexOppServer, ObexOppDataSinkPushServer
  • BinSearchRow() : MergeProvider
  • Birthday : CalendarRecord
  • bit_rate : PcmParam
  • BitAllocationMethodType : AudioEncoder
  • BitBlit() : VirtualDisplay
  • BitField() : BitField< T >
  • BITFIELDSIZE : BootState
  • Bitmap() : Bitmap
  • BitmapCount() : AnimationBmpPointerArrayIterator, AnimationBmpArrayIterator, AnimationBmpIterator
  • BitmapDc() : BitmapDc
  • BitmapPtr : ImageBox, Image
  • BitmapResArray : IconValueIndicator
  • BitmapResId : Theme
  • BitPool : AudioEncoder
  • BITS_PER_UINT : HeapVector, BootState
  • BitsPerPixel16 : VirtualDisplay
  • BitsPerPixel24 : VirtualDisplay
  • BitsPerPixel32 : VirtualDisplay
  • BitsPerPixel8 : VirtualDisplay
  • BitVector() : BitVector< N >
  • Black : InformationElement
  • BlackAndWhiteTheme() : BlackAndWhiteTheme
  • Blend() : Color
  • BlinkingAnimation : ItemRendererProperties
  • BlobFileType : RegIterator
  • BlobNodeType : RegIterator
  • BlobObject() : BlobObject
  • BlobPtr() : BlobPtr
  • BlobResponse : RegEncoderDecoder
  • block_index : RamBlockData
  • BlockNotification() : Item, Feature
  • blue : Palette, Led::Color, SimClutEntry
  • BlueSkyCheckBoxListView() : BlueSkyCheckBoxListView
  • BlueSkyCheckBoxView() : BlueSkyCheckBoxView
  • BlueSkyChineseTheme() : BlueSkyChineseTheme
  • BlueSkyControlFrameView() : BlueSkyControlFrameView
  • BlueSkyPositionIndicatorView() : BlueSkyPositionIndicatorView
  • BlueSkyProgressBarView() : BlueSkyProgressBarView
  • BlueSkyPushButtonView() : BlueSkyPushButtonView
  • BlueSkyRadioButtonListView() : BlueSkyRadioButtonListView
  • BlueSkyRadioButtonView() : BlueSkyRadioButtonView
  • BlueSkyTextListView() : BlueSkyTextListView
  • BlueSkyTheme() : BlueSkyTheme
  • BlueSkyWindowFrameView() : BlueSkyWindowFrameView
  • BmpImage() : BmpImage
  • bmscr : BtChipVersion
  • bmu : BtChipVersion
  • Bold : TextFormat
  • bold_glyph_index_tab : FontRes
  • bold_index : tagFont
  • BooleanCondition() : BooleanCondition
  • BooleanNodeType : RegIterator
  • BooleanParseType : CTResourcePack
  • BooleanType : GuiObjectFactory
  • BootControl() : BootControl
  • BootDispatcher() : BootDispatcher
  • BootDispatchingArg() : BootDispatchingArg
  • BootHandler() : BootHandler
  • BootSequenceState : SubSystemManager, SubSystem
  • BootState() : BootState
  • bopomofo : ChineseQuickSortProvider
  • BorderCornerMode : CTResourcePack
  • BorderMode : CTResourcePack
  • BorderModeParseType : CTResourcePack
  • BorderModeType : CTResourcePack
  • BorderWidth : CTResourcePack
  • Both : PhonebookApp, MergeProvider, JoinProvider
  • Bottom : TextFormat, Layouter, GridLayout
  • BottomLeft : ContextMenu, MenuProperties
  • BottomLineGapProp : GuiObjectFactory
  • BottomRight : ContextMenu, MenuProperties
  • BottomSection : Desktop
  • Bounce : AnimatedTextLine
  • BounceAnimation : ItemRendererProperties
  • BoundedItem() : BoundedItem
  • BoundsProp : GuiObjectFactory
  • Box : SmsSettingsRecord
  • bpp_state1_initial : BtBppSndFilePushReqRequest
  • bpp_state2_pushsent : BtBppSndFilePushReqRequest
  • bpp_state3_connect_ind_received_failed : BtBppSndFilePushReqRequest
  • bpp_state3_connect_ind_received_ok : BtBppSndFilePushReqRequest
  • bpp_state4_push_cfm_received_failed : BtBppSndFilePushReqRequest
  • bpp_state4_push_cfm_received_ok_final : BtBppSndFilePushReqRequest
  • bpp_state4_push_cfm_received_ok_send_more : BtBppSndFilePushReqRequest
  • bpp_state5_abort_cfm_received : BtBppSndFilePushReqRequest
  • bpp_state6_disconnect_ind_received : BtBppSndFilePushReqRequest
  • BppSndAbortReq() : BtBppController, BtBppClientService
  • BppSndFilePush() : BtBppClientService
  • BppSndFilePushReq() : BtBppController
  • BppSndGetRefObjRsp() : BtBppServerService, BtBppController
  • BppSubstate : BtBppSndFilePushReqRequest
  • br_number : SiBearerList_s
  • Breton : LanguageManager
  • BrightBlue : InformationElement
  • BrightCyan : InformationElement
  • BrightGreen : InformationElement
  • BrightMagenta : InformationElement
  • BrightnessChanged : Camera
  • BrightnessProperty : CamWin32
  • BrightRed : InformationElement
  • BrightYellow : InformationElement
  • Broadcast() : GatiManager
  • BrowserLaunched() : SimTkHandler
  • BrowserRegisterReqArg() : BrowserRegisterReqArg
  • BrowserSaveWin() : BrowserSaveWin
  • BrowserTermEventArg() : BrowserTermEventArg
  • BrowserTerminated() : SimTkHandler
  • BrowserView() : BrowserView
  • BrowserViewContainer() : BrowserViewContainer
  • Brush() : Brush
  • BrushStyle : Brush
  • bs_pa_mfrms : CellParam
  • bsic : CellParam, NeighbourCell
  • bsic_bcc : CellParam
  • bsic_ncc : CellParam
  • BtActiveDeviceWindow() : BtActiveDeviceWindow
  • BtActiveRequest : BtLocalSettings
  • BtAlertMessageWindow() : BtAlertMessageWindow
  • BtAmwAvrcpConnect : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpDeRegister : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpDeviceSelected : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpDisconnect : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpPanelPassthrough : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpRawFrame : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpRegister : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpSubunitInfo : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpUnitInfo : BtAvrcpAlertMessageWindow
  • BtAmwDunConnect : BtAlertMessageWindow
  • BtAmwDunDisconnect : BtAlertMessageWindow
  • BtAmwFaxConnect : BtAlertMessageWindow
  • BtAmwFaxDisconnect : BtAlertMessageWindow
  • BtAmwHfAudio2Hf : BtAlertMessageWindow
  • BtAmwHfAudio2Phone : BtAlertMessageWindow
  • BtAmwHfConnect : BtAlertMessageWindow
  • BtAmwHfDisconnect : BtAlertMessageWindow
  • BtAmwHsCallTransferToHeadset : BtAlertMessageWindow
  • BtAmwHsCallTransferToPhone : BtAlertMessageWindow
  • BtAmwHsConnect : BtAlertMessageWindow
  • BtAmwHsDisconnect : BtAlertMessageWindow
  • BtAmwNotCongested : BtAvrcpAlertMessageWindow
  • BtAmwPair : BtAlertMessageWindow
  • BtAmwQuerySupportedProfiles : BtAlertMessageWindow
  • BtAmwServiceVerify : BtAlertMessageWindow
  • BtAmwSetName : BtAlertMessageWindow
  • BtAmwSupportedProfile : BtAlertMessageWindow
  • BtAmwTrust : BtAlertMessageWindow
  • BtAmwType : BtAlertMessageWindow, BtAvrcpAlertMessageWindow
  • BtAmwUnpair : BtAlertMessageWindow
  • BtAmwUntrust : BtAlertMessageWindow
  • BtApplicationDevicePairRequest : BtApplicationDevicePairRequest, BtDeviceListWindow
  • BtApplicationDeviceSearchRequest : BtApplicationDeviceSearchRequest, BtDeviceListWindow
  • BtApplicationDeviceTrustRequest : BtApplicationDeviceTrustRequest, BtDeviceListWindow
  • BtApplicationDeviceUnpairRequest : BtApplicationDeviceUnpairRequest, BtDeviceListWindow
  • BtApplicationDeviceUntrustRequest : BtApplicationDeviceUntrustRequest, BtDeviceListWindow
  • BtApplicationMessage() : BtApplicationMessage
  • BtApplicationQuerySupportedProfilesRequest : BtApplicationQuerySupportedProfilesRequest, BtDeviceListWindow, BtDeviceDetailWindow
  • BtApplicationRespondAuthorizationRequest() : BtApplicationRespondAuthorizationRequest
  • BtApplicationSendPasskeyRequest() : BtApplicationSendPasskeyRequest
  • BtApplicationServiceVerifyRequest : BtApplicationServiceVerifyRequest, BtDeviceListWindow
  • BtApplicationSetRemoteDeviceNameRequest() : BtApplicationSetRemoteDeviceNameRequest
  • BtArConnectablity : BtLocalSettings
  • BtArDiscoverability : BtLocalSettings
  • BtArLocalName : BtLocalSettings
  • BtArNone : BtLocalSettings
  • BtArPairability : BtLocalSettings
  • BtArProfileActivation : BtLocalSettings
  • BtArSwitchState : BtLocalSettings
  • BtAudioAccessoryService() : BtAudioAccessoryService
  • BtAuthorizationRequiredMessage() : BtAuthorizationRequiredMessage
  • BtAuthorizationRequiredWindow() : BtAuthorizationRequiredWindow
  • BtAvrcpAlertMessageWindow() : BtAvrcpAlertMessageWindow
  • BtAvrcpConnectResponse() : BtAvrcpConnectResponse
  • BtAvrcpControllerApplicationWindow() : BtAvrcpControllerApplicationWindow
  • BtAvrcpControllerConnectRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerDeviceListItem() : BtAvrcpControllerDeviceListItem
  • BtAvrcpControllerDeviceListWindow() : BtAvrcpControllerDeviceListWindow
  • BtAvrcpControllerDisconnectRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerSelectDeviceRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerSetActiveDeviceRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerSetInactiveDeviceRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerSubUnitInfoRequest : BtAvrcpPanelApplication
  • BtAvrcpDeRegisterRequest() : BtAvrcpDeRegisterRequest
  • BtAvrcpDeviceListWin() : BtAvrcpDeviceListWin
  • BtAvrcpMessageArgumentsDestroyTableNode : BtAvrcpNmaRawFrame, BtAvrcpNmaPanelPassThrough, BtAvrcpNmaDisconnect, BtAvrcpNmaConnect
  • BtAvrcpNmaConnect() : BtAvrcpNmaConnect
  • BtAvrcpNmaDisconnect() : BtAvrcpNmaDisconnect
  • BtAvrcpNmaPanelPassThrough() : BtAvrcpNmaPanelPassThrough
  • BtAvrcpNmaRawFrame() : BtAvrcpNmaRawFrame
  • BtAvrcpNotificationMessage() : BtAvrcpNotificationMessage
  • BtAvrcpOpenControllerWindow : BtAvrcpPanelApplication
  • BtAvrcpOperationController : BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationService, BtAvrcpOperationRequestResponse, BtAvrcpConnectResponse
  • BtAvrcpOperationRequestResponse() : BtAvrcpOperationRequestResponse
  • BtAvrcpOperationService : BtAvrcpOperationService, BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse, BtAvrcpConnectResponse
  • BtAvrcpOperationServiceMessage() : BtAvrcpOperationServiceMessage
  • BtAvrcpPanelAppFeatures : BtAvrcpPanelApplication
  • BtAvrcpPanelFeatureCount : BtAvrcpPanelApplication
  • BtAvrcpPanelPassThroughParams() : BtAvrcpPanelPassThroughParams
  • BtAvrcpPanelPassThroughRequest() : BtAvrcpPanelPassThroughRequest
  • BtAvrcpPanelServiceImpl() : BtAvrcpPanelServiceImpl
  • BtAvrcpPanelSetActiveSubUnit : BtAvrcpPanelApplication
  • BtAvrcpProfileOperationService() : BtAvrcpProfileOperationService
  • BtAvrcpProfileRegistrationService() : BtAvrcpProfileRegistrationService
  • BtAvrcpRawFrameParams() : BtAvrcpRawFrameParams
  • BtAvrcpRawFrameRequest() : BtAvrcpRawFrameRequest
  • BtAvrcpRegisterParams() : BtAvrcpRegisterParams
  • BtAvrcpRegisterRequest() : BtAvrcpRegisterRequest
  • BtAvrcpRegistrationController : BtAvrcpRegisterRequest, BtAvrcpDeRegisterRequest
  • BtAvrcpRegistrationService : BtAvrcpRegistrationService, BtAvrcpRegisterRequest, BtAvrcpDeRegisterRequest
  • BtAvrcpRequest() : BtAvrcpRequest
  • BtAvrcpRequestStateChangedMessage() : BtAvrcpRequestStateChangedMessage
  • BtAvrcpService : BtAvrcpService, BtAvrcpRequest
  • BtAvrcpSubunitInfoParams() : BtAvrcpSubunitInfoParams
  • BtAvrcpSubunitInfoRequest() : BtAvrcpSubunitInfoRequest
  • BtAvrcpUnitInfoParams() : BtAvrcpUnitInfoParams
  • BtAvrcpUnitInfoRequest() : BtAvrcpUnitInfoRequest
  • BtBipAbortIndArg() : BtBipAbortIndArg
  • BtBipAttachmentDesc() : BtBipAttachmentDesc
  • BtBipAttachmentFormat() : BtBipAttachmentFormat
  • BtBipAttachmentFormatList : BtBipImagingCapabilities
  • BtBipAttachmentList : BtBipImageProperties
  • BtBipClientService() : BtBipClientService
  • BtBipConnectIndArg() : BtBipConnectIndArg
  • BtBipConnectReq : BtBipClientService
  • BtBipController : BtBipImageHdl, BtBipServerService
  • BtBipDataConverter : BtBipImageHdl
  • BtBipDeleteImageIndArg() : BtBipDeleteImageIndArg
  • BtBipDeleteImageReq : BtBipImageHdl
  • BtBipDisconnectIndArg() : BtBipDisconnectIndArg
  • BtBipGetImageIndArg() : BtBipGetImageIndArg
  • BtBipGetImagePropertiesIndArg() : BtBipGetImagePropertiesIndArg
  • BtBipGetImagePropertiesReq : BtBipImageHdl
  • BtBipGetImageReq : BtBipImageHdl
  • BtBipGetImagesListIndArg() : BtBipGetImagesListIndArg
  • BtBipGetImagingCapabilitiesIndArg() : BtBipGetImagingCapabilitiesIndArg
  • BtBipGetLinkedAttachmentIndArg() : BtBipGetLinkedAttachmentIndArg
  • BtBipGetLinkedAttachmentReq : BtBipImageHdl
  • BtBipGetLinkedThumbnailIndArg() : BtBipGetLinkedThumbnailIndArg
  • BtBipGetLinkedThumbnailReq : BtBipImageHdl
  • BtBipImage() : BtBipImage
  • BtBipImageFormatList : BtBipImagingCapabilities
  • BtBipImageHdlDesc() : BtBipImageHdlDesc
  • BtBipImageList() : BtBipImageList
  • BtBipImagingCapabilities() : BtBipImagingCapabilities
  • BtBipMecelXmlConverter : BtBipImageHdl
  • BtBipMsgArg() : BtBipMsgArg
  • BtBipOpFinishedArg() : BtBipOpFinishedArg
  • BtBipProgressMsg() : BtBipProgressMsg
  • BtBipPutAttachReq : BtBipImageHdl
  • BtBipPutImageCompleteArg() : BtBipPutImageCompleteArg
  • BtBipPutImageIndArg() : BtBipPutImageIndArg
  • BtBipPutImageReq : BtBipImageHdl
  • BtBipPutLinkedAttachmentCompleteArg() : BtBipPutLinkedAttachmentCompleteArg
  • BtBipPutLinkedAttachmentIndArg() : BtBipPutLinkedAttachmentIndArg
  • BtBipPutLinkedThumbnailCompleteArg() : BtBipPutLinkedThumbnailCompleteArg
  • BtBipPutLinkedThumbnailIndArg() : BtBipPutLinkedThumbnailIndArg
  • BtBipPutThumbReq : BtBipImageHdl
  • BtBipServerNotificationMsgArg() : BtBipServerNotificationMsgArg
  • BtBipServerService : BtBipServerService, BtBipImageHdl
  • BtBipVariantList : BtBipImageProperties
  • BtBppClientService : BtBppClientService, BtBppController
  • BtBppController : BtBppController, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBppReq
  • BtBppReq() : BtBppReq
  • BtBppRequestStateChangedMessage() : BtBppRequestStateChangedMessage
  • BtBppServerService : BtBppServerService, BtBppController
  • BtBppService : BtBppService, BtBppController
  • BtBppSndAbortReqRequest : BtBppSndAbortReqRequest, BtBppController, BtBppClientService
  • BtBppSndFilePushReqRequest : BtBppSndFilePushReqRequest, BtBppController, BtBppClientService
  • BtBppSndGetRefObjRspRequest : BtBppSndGetRefObjRspRequest, BtBppController
  • BtCancelableBroadcastRequest() : BtCancelableBroadcastRequest
  • BtCancelableMulticastRequest() : BtCancelableMulticastRequest
  • BtCancelableRequest() : BtCancelableRequest
  • BtCancelSearchMessage() : BtCancelSearchMessage
  • BtCancelVerifyMessage() : BtCancelVerifyMessage
  • BtCloseMessage() : BtCloseMessage
  • BtConnectabilityMessage() : BtConnectabilityMessage
  • BtConnection() : BtMultiConnectionController::BtConnection
  • BtConnectionBasedController() : BtConnectionBasedController
  • BtConnectionlessController() : BtConnectionlessController
  • BtConnectRequest() : BtConnectRequest
  • BtController : BtController, BtServiceRequest, BtRequest
  • BtDevice() : BtDevice
  • BtDeviceAddress() : BtDeviceAddress
  • BtDeviceAddressGenericObject() : BtDeviceAddressGenericObject
  • BtDeviceAndServiceClass() : BtDeviceAndServiceClass
  • BtDeviceDetailWindow() : BtDeviceDetailWindow
  • BtDeviceFilter() : BtDeviceFilter
  • BtDeviceList : BtDeviceList, BtDeviceListIterator, BtDeviceListConstantIterator
  • BtDeviceListBidirectionalIterator : BtDeviceList::BtDeviceListBidirectionalIterator, BtDeviceList::BtDeviceListNode, BtDeviceList
  • BtDeviceListConstantIterator : BtDeviceListConstantIterator, BtDeviceListConstantReverseIterator, BtDeviceList
  • BtDeviceListConstantReverseIterator : BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceList
  • BtDeviceListItem() : BtDeviceListItem
  • BtDeviceListIterator : BtDeviceListIterator, BtDeviceList
  • BtDeviceListNode() : BtDeviceList::BtDeviceListNode
  • BtDeviceListProvider() : BtDeviceListProvider
  • BtDeviceListReverseIteator : BtDeviceListIterator
  • BtDeviceListReverseIterator : BtDeviceListReverseIterator, BtDeviceList
  • BtDeviceListWindow() : BtDeviceListWindow
  • BtDeviceListWindowType : BtDeviceListWindow
  • BtDevicePairMessage() : BtDevicePairMessage
  • BtDevicePairRequest() : BtDevicePairRequest
  • BtDeviceSearchMessage() : BtDeviceSearchMessage
  • BtDeviceSearchModeWindow() : BtDeviceSearchModeWindow
  • BtDeviceSearchRequest() : BtDeviceSearchRequest
  • BtDeviceTrustMessage() : BtDeviceTrustMessage
  • BtDeviceTrustRequest() : BtDeviceTrustRequest
  • BtDeviceUnpairMessage() : BtDeviceUnpairMessage
  • BtDeviceUnpairRequest() : BtDeviceUnpairRequest
  • BtDeviceUntrustMessage() : BtDeviceUntrustMessage
  • BtDeviceUntrustRequest() : BtDeviceUntrustRequest
  • BtDisconnectRequest() : BtDisconnectRequest
  • BtDiscoverabilityMessage() : BtDiscoverabilityMessage
  • BtDlwFoundDevices : BtDeviceListWindow
  • BtDlwPairedDevices : BtDeviceListWindow
  • BtDunApplicationMessage() : BtDunApplicationMessage
  • BtDunConnectMessage() : BtDunConnectMessage
  • BtDunDisconnectMessage() : BtDunDisconnectMessage
  • BtDunProfileService() : BtDunProfileService
  • BtDunRequestStateChangedMessage() : BtDunRequestStateChangedMessage
  • BtDunService() : BtDunService
  • BtErOperationFailure : BtOperationBase
  • BtErOperationResultInvalid : BtOperationBase
  • BtErrorReason : BtOperationBase
  • BtErUnknown : BtOperationBase
  • BtErUserBreak : BtOperationBase
  • BtEvent() : BtEvent
  • BtFaxApplicationMessage() : BtFaxApplicationMessage
  • BtFaxConnectMessage() : BtFaxConnectMessage
  • BtFaxDisconnectMessage() : BtFaxDisconnectMessage
  • BtFaxProfileService() : BtFaxProfileService
  • BtFaxRequestStateChangedMessage() : BtFaxRequestStateChangedMessage
  • BtFaxService() : BtFaxService
  • BtFeatureSetAvailable() : BtApplication
  • BtGapAndSdapApplicationMessage() : BtGapAndSdapApplicationMessage
  • BtGapAndSdapController : BtTransport, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtLocalSettings, BtDeviceSearchRequest, BtDevicePairRequest, BtDeviceList, BtDevice, BtController, BtConnectionlessController, BtConnectionBasedController
  • BtGapAndSdapNotificationMessage() : BtGapAndSdapNotificationMessage
  • BtGapAndSdapRemoteRequestMessage() : BtGapAndSdapRemoteRequestMessage
  • BtGapAndSdapRequestMessage() : BtGapAndSdapRequestMessage
  • BtHfAudioPathWindow() : BtHfAudioPathWindow
  • BtHfCmaAtChldOneCommandReceived() : BtHfCmaAtChldOneCommandReceived
  • BtHfCmaAudioAsynchronous() : BtHfCmaAudioAsynchronous
  • BtHfCmaCheckPendingAudioCallback() : BtHfCmaCheckPendingAudioCallback
  • BtHfCmaMOC() : BtHfCmaMOC
  • BtHfCmaMTC() : BtHfCmaMTC
  • BtHfCmaPhoneNumberRequired() : BtHfCmaPhoneNumberRequired
  • BtHfFeatureListWin() : BtHfFeatureListWin
  • BtHfInbandSettingWin() : BtHfInbandSettingWin
  • BtHfInsertPhoneNr() : BtHfAppPlugin
  • BtHfMessageArgumentsDestroyTableNode : BtHfNmaCallEvent, BtHfNmaLowPowerModeNotPossible, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain, BtHfNmaAudioConnectionLost, BtHfNmaTransferAudioToPhone, BtHfNmaTransferAudioToAccessory, BtHfNmaDisconnect, BtHfNmaConnect, BtHfCmaCheckPendingAudioCallback, BtHfCmaAtChldOneCommandReceived, BtHfCmaAudioAsynchronous, BtHfCmaMOC, BtHfCmaMTC, BtHfCmaPhoneNumberRequired
  • BtHfNmaAudioConnectionLost() : BtHfNmaAudioConnectionLost
  • BtHfNmaCallEvent() : BtHfNmaCallEvent
  • BtHfNmaConnect() : BtHfNmaConnect
  • BtHfNmaDisconnect() : BtHfNmaDisconnect
  • BtHfNmaLowPowerModeNotPossible() : BtHfNmaLowPowerModeNotPossible
  • BtHfNmaMicrophoneGain() : BtHfNmaMicrophoneGain
  • BtHfNmaSpeakerGain() : BtHfNmaSpeakerGain
  • BtHfNmaTransferAudioToAccessory() : BtHfNmaTransferAudioToAccessory
  • BtHfNmaTransferAudioToPhone() : BtHfNmaTransferAudioToPhone
  • BtHfNotificationMessage() : BtHfNotificationMessage
  • BtHfPath : BtHfAudioPathWindow
  • BtHfProfileService : BtHfProfileService, BtHfProfileWindow
  • BtHfProfileWindow() : BtHfProfileWindow
  • BtHfProvider() : BtHfProvider
  • BtHfRecord() : BtHfRecord
  • BtHfRequestStateChangedMessage() : BtHfRequestStateChangedMessage
  • BtHfService() : BtHfService
  • BtHfSupportedProfileMessage() : BtHfSupportedProfileMessage
  • BtHfVolumeSettingsWin() : BtHfVolumeSettingsWin
  • BtHsCmaAudioAsynchronous() : BtHsCmaAudioAsynchronous
  • BtHsCmaAudioTransferOutOfCall() : BtHsCmaAudioTransferOutOfCall
  • BtHsCmaCheckPendingAudioCallback() : BtHsCmaCheckPendingAudioCallback
  • BtHsCmaEnterLowPowerMode() : BtHsCmaEnterLowPowerMode
  • BtHsCmaHangUp() : BtHsCmaHangUp
  • BtHsConnectionSettingWin() : BtHsConnectionSettingWin
  • BtHsInbandSettingWin() : BtHsInbandSettingWin
  • BtHsMessageArgumentsDestroyTableNode : BtHsNmaCallEvent, BtHsNmaLowPowerModeNotPossible, BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHsNmaAudioConnectionLost, BtHsNmaTransferAudioToPhone, BtHsNmaTransferAudioToAccessory, BtHsNmaDisconnect, BtHsNmaConnect, BtHsCmaCheckPendingAudioCallback, BtHsCmaAudioTransferOutOfCall, BtHsCmaEnterLowPowerMode, BtHsCmaAudioAsynchronous, BtHsCmaHangUp
  • BtHsNmaAudioConnectionLost() : BtHsNmaAudioConnectionLost
  • BtHsNmaCallEvent() : BtHsNmaCallEvent
  • BtHsNmaConnect() : BtHsNmaConnect
  • BtHsNmaDisconnect() : BtHsNmaDisconnect
  • BtHsNmaLowPowerModeNotPossible() : BtHsNmaLowPowerModeNotPossible
  • BtHsNmaMicrophoneGain() : BtHsNmaMicrophoneGain
  • BtHsNmaSpeakerGain() : BtHsNmaSpeakerGain
  • BtHsNmaTransferAudioToAccessory() : BtHsNmaTransferAudioToAccessory
  • BtHsNmaTransferAudioToPhone() : BtHsNmaTransferAudioToPhone
  • BtHsNotificationMessage() : BtHsNotificationMessage
  • BtHsProfileService() : BtHsProfileService
  • BtHsRequest : BtHsService
  • BtHsRequestStateChangedMessage() : BtHsRequestStateChangedMessage
  • BtHsRingRequest : BtHsService
  • BtHsService() : BtHsService
  • BtHsSupportedProfileMessage() : BtHsSupportedProfileMessage
  • BtHsVolumeSettingsWin() : BtHsVolumeSettingsWin
  • BtIndicatorMsg() : BtIndicatorMsg
  • BtJsr82Url() : BtJsr82Url
  • BtLocalNameMessage() : BtLocalNameMessage
  • BtLocalRequest() : BtLocalRequest
  • BtLocalSettings() : BtLocalSettings
  • BtLocalSettingsMessage() : BtLocalSettingsMessage
  • BtMultiConnectionController() : BtMultiConnectionController
  • BtObexAbortRequest : BtObexAbortRequest, BtObexController, BtObexClientService
  • BtObexClientAbortEvent() : BtObexClientAbortEvent
  • BtObexClientAddr() : BtObexClientAddr
  • BtObexClientAddrResultNotifier : BtObexClientAddrResultNotifier, BtObexTransport
  • BtObexClientConnectEvent() : BtObexClientConnectEvent
  • BtObexClientConnection : BtObexImpl
  • BtObexClientDisconnectEvent() : BtObexClientDisconnectEvent
  • BtObexClientEvent() : BtObexClientEvent
  • BtObexClientGetEvent() : BtObexClientGetEvent
  • BtObexClientNmaDataBufferIndication() : BtObexClientNmaDataBufferIndication
  • BtObexClientNmaDataInidication() : BtObexClientNmaDataInidication
  • BtObexClientNmaHeaderIndication() : BtObexClientNmaHeaderIndication
  • BtObexClientNmaHeaderSent() : BtObexClientNmaHeaderSent
  • BtObexClientNmaTransportDisconnect() : BtObexClientNmaTransportDisconnect
  • BtObexClientNotificationMessage() : BtObexClientNotificationMessage
  • BtObexClientObserverImpl : BtObexClientObserverImpl, BtObexImpl
  • BtObexClientOperationEvent() : BtObexClientOperationEvent
  • BtObexClientOperationRequest() : BtObexClientOperationRequest
  • BtObexClientPutEvent() : BtObexClientPutEvent
  • BtObexClientRequestStateChangedMessage() : BtObexClientRequestStateChangedMessage
  • BtObexClientService : BtObexClientService, BtObexController, BtObexClientServiceObserver
  • BtObexClientServiceImpl() : BtObexClientServiceImpl
  • BtObexClientServiceObserver() : BtObexClientServiceObserver
  • BtObexClientSetPathEvent() : BtObexClientSetPathEvent
  • BtObexConnection() : BtObexController::BtObexConnection
  • BtObexConnectRequest : BtObexConnectRequest, BtObexController, BtObexClientService
  • BtObexController : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexSetPathRequest, BtObexService, BtObexServerService, BtObexRequest, BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtObexPutRequest, BtObexGetRequest, BtObexDisconnectRequest, BtObexConnectRequest, BtObexClientOperationRequest, BtObexAbortRequest
  • BtObexDataBufferIndicationEvent() : BtObexDataBufferIndicationEvent
  • BtObexDataIndicationEvent() : BtObexDataIndicationEvent
  • BtObexDisconnectRequest : BtObexDisconnectRequest, BtObexController, BtObexClientService
  • BtObexEvent() : BtObexEvent
  • BtObexGetRequest : BtObexGetRequest, BtObexController, BtObexClientService
  • BtObexHeaderIndicationEvent() : BtObexHeaderIndicationEvent
  • BtObexHeaderSentEvent() : BtObexHeaderSentEvent
  • BtObexImpl : BtObexImpl, BtObexServerObserverImpl, BtObexClientObserverImpl
  • BtObexMessageArgumentsDestroyTableNode : BtObexClientNmaTransportDisconnect, BtObexClientNmaDataInidication, BtObexClientNmaDataBufferIndication, BtObexClientNmaHeaderIndication, BtObexClientNmaHeaderSent, BtObexServerNmaTransportDisconnect, BtObexServerNmaDataInidication, BtObexServerNmaDataBufferIndication, BtObexServerNmaHeaderIndication, BtObexServerNmaHeaderSent, BtObexServerNmaAbort, BtObexServerNmaPut, BtObexServerNmaGet, BtObexServerNmaSetPath, BtObexServerNmaDisconnect, BtObexServerNmaConnect
  • BtObexPutRequest : BtObexPutRequest, BtObexController, BtObexClientService
  • BtObexRegisterClientEvent() : BtObexRegisterClientEvent
  • BtObexRegisterClientRequest : BtObexRegisterClientRequest, BtObexController, BtObexClientService
  • BtObexRegisterServerEvent() : BtObexRegisterServerEvent
  • BtObexRegisterServerRequest : BtObexRegisterServerRequest, BtObexServerService, BtObexController
  • BtObexRequest : BtObexRequest, BtObexService
  • BtObexResponseCode() : BtObexResponseCode
  • BtObexSddbImpl() : BtObexSddbImpl
  • BtObexSddbServiceObserverImpl : BtObexSddbServiceObserverImpl, BtObexImpl
  • BtObexSendResponseRequest : BtObexController
  • BtObexServerAbortIndicationEvent() : BtObexServerAbortIndicationEvent
  • BtObexServerAddr() : BtObexServerAddr
  • BtObexServerCodes : BtObexServerAddr
  • BtObexServerConnectIndicationEvent() : BtObexServerConnectIndicationEvent
  • BtObexServerConnection : BtObexImpl
  • BtObexServerDisconnectIndicationEvent() : BtObexServerDisconnectIndicationEvent
  • BtObexServerEvent() : BtObexServerEvent
  • BtObexServerGetIndicationEvent() : BtObexServerGetIndicationEvent
  • BtObexServerNmaAbort() : BtObexServerNmaAbort
  • BtObexServerNmaConnect() : BtObexServerNmaConnect
  • BtObexServerNmaDataBufferIndication() : BtObexServerNmaDataBufferIndication
  • BtObexServerNmaDataInidication() : BtObexServerNmaDataInidication
  • BtObexServerNmaDisconnect() : BtObexServerNmaDisconnect
  • BtObexServerNmaGet() : BtObexServerNmaGet
  • BtObexServerNmaHeaderIndication() : BtObexServerNmaHeaderIndication
  • BtObexServerNmaHeaderSent() : BtObexServerNmaHeaderSent
  • BtObexServerNmaPut() : BtObexServerNmaPut
  • BtObexServerNmaSetPath() : BtObexServerNmaSetPath
  • BtObexServerNmaTransportDisconnect() : BtObexServerNmaTransportDisconnect
  • BtObexServerNotificationMessage() : BtObexServerNotificationMessage
  • BtObexServerObserverImpl : BtObexServerObserverImpl, BtObexServerAddr, BtObexImpl
  • BtObexServerPutIndicationEvent() : BtObexServerPutIndicationEvent
  • BtObexServerRequestStateChangedMessage() : BtObexServerRequestStateChangedMessage
  • BtObexServerService : BtObexServerService, BtObexServerServiceObserver, BtObexController
  • BtObexServerServiceImpl() : BtObexServerServiceImpl
  • BtObexServerServiceObserver() : BtObexServerServiceObserver
  • BtObexServerSetPathIndicationEvent() : BtObexServerSetPathIndicationEvent
  • BtObexService : BtObexService, BtObexServiceObserver, BtObexController
  • BtObexServiceObserver() : BtObexServiceObserver
  • BtObexServiceTable : BtObexServiceTable::ServiceInfo
  • BtObexSetClientAddrInfo() : BtObexClientAddr
  • BtObexSetPathRequest : BtObexSetPathRequest, BtObexController, BtObexClientService
  • BtObexTransport : BtObexTransport, BtObexServerAddr, BtObexClientAddr
  • BtObexTransportDisconnectEvent() : BtObexTransportDisconnectEvent
  • BtObexUnregisterClientRequest : BtObexUnregisterClientRequest, BtObexController, BtObexClientService
  • BtObexUnregisterEvent() : BtObexUnregisterEvent
  • BtObexUnregisterServerRequest : BtObexUnregisterServerRequest, BtObexServerService, BtObexController
  • BtObservableService : BtObservableService, BtServiceObserver
  • BtOpenMessage() : BtOpenMessage
  • BtOperationBase() : BtOperationBase
  • BtOperationSelectDevice() : BtOperationSelectDevice
  • BtOperationSelectDeviceAndPerformServiceVerify : BtOperationSelectDeviceAndPerformServiceVerify, BtServiceVerifyResult
  • BtPairabilityMessage() : BtPairabilityMessage
  • BtPasskeyRequiredMessage() : BtPasskeyRequiredMessage
  • BtPasskeyRequiredWindow() : BtPasskeyRequiredWindow
  • BtPaSupportedProfileMessage() : BtPaSupportedProfileMessage
  • BtProfileActivationMessage() : BtProfileActivationMessage
  • BtQueryRequestSupportWinType : BtApplicationQuerySupportedProfilesRequest
  • BtQuerySupportedProfilesMessage() : BtQuerySupportedProfilesMessage
  • BtQuerySupportedProfilesRequest() : BtQuerySupportedProfilesRequest
  • BtRemoteDeviceListOptions() : BtApplication
  • BtRemoteDeviceMessage() : BtRemoteDeviceMessage
  • BtRemoteDeviceNameMessage() : BtRemoteDeviceNameMessage
  • BtRemoteDevicePairMessage() : BtRemoteDevicePairMessage
  • BtRequest() : BtRequest
  • BtRequestMessage() : BtRequestMessage
  • BtRequestOperationMessage() : BtRequestOperationMessage
  • BtRequestRespondRequest() : BtRequestRespondRequest
  • BtRequestRunningWindow() : BtRequestRunningWindow
  • BtRequestStateChangedMessage() : BtRequestStateChangedMessage
  • BtRespondAuthorizationMessage() : BtRespondAuthorizationMessage
  • BtRespondAuthorizationRequest() : BtRespondAuthorizationRequest
  • BtRrwDeviceSearch : BtRequestRunningWindow
  • BtRrwDunDisconnect : BtRequestRunningWindow
  • BtRrwFaxDisconnect : BtRequestRunningWindow
  • BtRrwHfAudio2Hf : BtRequestRunningWindow
  • BtRrwHfAudio2Phone : BtRequestRunningWindow
  • BtRrwHfConnect : BtRequestRunningWindow
  • BtRrwHfDisconnect : BtRequestRunningWindow
  • BtRrwHsCallTransferToHeadset : BtRequestRunningWindow
  • BtRrwHsCallTransferToPhone : BtRequestRunningWindow
  • BtRrwHsConnect : BtRequestRunningWindow
  • BtRrwHsDisconnect : BtRequestRunningWindow
  • BtRrwPair : BtRequestRunningWindow
  • BtRrwQuerySupportedProfiles : BtRequestRunningWindow
  • BtRrwServiceVerify : BtRequestRunningWindow
  • BtRrwSetName : BtRequestRunningWindow
  • BtRrwTrust : BtRequestRunningWindow
  • BtRrwType : BtRequestRunningWindow
  • BtRrwUnknown : BtRequestRunningWindow
  • BtRrwUnpair : BtRequestRunningWindow
  • BtRrwUntrust : BtRequestRunningWindow
  • BtSddbDataElement() : BtSddbDataElement
  • BtSddbDeAlternative() : BtSddbDeAlternative
  • BtSddbDeBaseCType() : BtSddbDeBaseCType
  • BtSddbDeBigSintBase() : BtSddbDeBigSintBase
  • BtSddbDeBigUintBase() : BtSddbDeBigUintBase
  • BtSddbDeBoolean() : BtSddbDeBoolean
  • BtSddbDeByteBlockType() : BtSddbDeByteBlockType
  • BtSddbDeContainer : BtSddbDeContainer, BtSddbDataElement
  • BtSddbDeNil() : BtSddbDeNil
  • BtSddbDeOneByteDescriptionType() : BtSddbDeOneByteDescriptionType
  • BtSddbDeSequence() : BtSddbDeSequence
  • BtSddbDeSint128() : BtSddbDeSint128
  • BtSddbDeSint16() : BtSddbDeSint16
  • BtSddbDeSint32() : BtSddbDeSint32
  • BtSddbDeSint64() : BtSddbDeSint64
  • BtSddbDeSint8() : BtSddbDeSint8
  • BtSddbDeSintBase() : BtSddbDeSintBase
  • BtSddbDeString() : BtSddbDeString
  • BtSddbDeUint128() : BtSddbDeUint128
  • BtSddbDeUint16() : BtSddbDeUint16
  • BtSddbDeUint32() : BtSddbDeUint32
  • BtSddbDeUint64() : BtSddbDeUint64
  • BtSddbDeUint8() : BtSddbDeUint8
  • BtSddbDeUintBase() : BtSddbDeUintBase
  • BtSddbDeUrl() : BtSddbDeUrl
  • BtSddbDeUuid128() : BtSddbDeUuid128
  • BtSddbDeUuid16() : BtSddbDeUuid16
  • BtSddbDeUuid32() : BtSddbDeUuid32
  • BtSddbDeUuidBase() : BtSddbDeUuidBase
  • BtSddbDeVariableLengthType() : BtSddbDeVariableLengthType
  • BtSddbEvent() : BtSddbEvent
  • BtSddbRegisterServiceEvent() : BtSddbRegisterServiceEvent
  • BtSddbRegisterServiceRecordRequest : BtSddbService
  • BtSddbRequestStateChangedMessage() : BtSddbRequestStateChangedMessage
  • BtSddbService : BtSddbService, BtObexSddbServiceObserverImpl, BtSddbServiceObserver
  • BtSddbServiceAttribute : BtSddbServiceAttribute, BtSddbDataElement
  • BtSddbServiceObserver() : BtSddbServiceObserver
  • BtSddbServiceRecord : BtSddbServiceRecord, BtSddbServiceAttribute
  • BtSddbUnregisterServiceEvent() : BtSddbUnregisterServiceEvent
  • BtSddbUnregisterServiceRecordRequest : BtSddbService
  • BtSendPasskeyMessage() : BtSendPasskeyMessage
  • BtSendPasskeyRequest() : BtSendPasskeyRequest
  • BtService() : BtService
  • BtServiceDiscoveryDatabase : BtSddbServiceRecord
  • BtServiceMessage() : BtServiceMessage
  • BtServiceObserver() : BtServiceObserver
  • BtServiceRequest : BtServiceRequest, BtService
  • BtServiceVerifyMessage() : BtServiceVerifyMessage
  • BtServiceVerifyRequest : BtServiceVerifyRequest, BtServiceVerifyResult
  • BtServiceVerifyResult : BtSvrServiceRecord
  • BtServiceVerifyResultMessage() : BtServiceVerifyResultMessage
  • BtSetRemoteDeviceNameMessage() : BtSetRemoteDeviceNameMessage
  • BtSetRemoteDeviceNameRequest() : BtSetRemoteDeviceNameRequest
  • BtSingleConnectionController : BtSingleConnectionController, BtDisconnectRequest, BtConnectRequest
  • BtStateChangedMessage() : BtStateChangedMessage
  • BtSvrDataElement() : BtSvrDataElement
  • BtSvrServiceAttribute : BtSvrServiceAttribute, BtSvrDataElement
  • BtSvrServiceRecord : BtSvrServiceRecord, BtSvrServiceAttribute
  • BtTurnOnOffWindow() : BtTurnOnOffWindow
  • BtUncancelablePointToPointRequest() : BtUncancelablePointToPointRequest
  • BtUncancelableRequest() : BtUncancelableRequest
  • BubbleSortProvider() : BubbleSortProvider
  • buf : _JUMP_BUFFER
  • buff : BtBppSndFilePushReqRequest
  • buff_used_bytes : BtBppSndFilePushReqRequest
  • buffer : RingerAudioDevice::StartParam, BtObexHeader
  • buffer_size : RingerAudioDevice::StartParam, Mp3Param, VmParam, PcmParam, RtStreamingEndPoint::BufferInfo
  • BufferAdjustedWarning : BufferPoolManager
  • BufferAllocationError : Camera
  • BufferByteType : StreamAudioReference
  • BufferedData() : BufferedData
  • BufferedOutputStream() : BufferedOutputStream
  • BufferingComplete : MediaManager
  • BufferingCompleteState : MediaPlayer
  • BufferingProp : GuiObjectFactory
  • BufferingStart : MediaManager
  • BufferingStartState : MediaPlayer
  • BufferLocation : VideoCamera
  • BufferNotAvailableError : Camera
  • BufferNotExistentError : BufferPoolManager
  • BufferPoolNotAvailableError : BufferPoolManager
  • buffers : DataSourceRtStreamingSource
  • BufferType : StreamAudioReference
  • BufPtr : BinData
  • Bulgarian : LanguageManager
  • Busy : AtResponse
  • ButtonBackground : Color
  • ButtonBackgroundColor : CTResourcePack
  • ButtonForeground : Color
  • ButtonForegroundColor : CTResourcePack
  • BV1 : ThaiTextRenderer
  • BV2 : ThaiTextRenderer
  • Byelorussian : LanguageManager
  • byte_before_the_zipfile : JarFileStatusInfo, FileInReadStatusInfo, JarBinDataStatusInfo, BinDataInReadStatusInfo
  • byte_sequence : BtObexHeader
  • byte_value : BtObexHeader
  • ByteBuffer() : ByteBuffer
  • ByteOrder : ObexHeader
  • ByteSeqType : ObexHeader
  • ByteType : ObexHeader
Generated on Wed Jan 25 00:53:57 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • c1 : CellParam, NeighbourCell
  • c2 : CellParam, NeighbourCell
  • c2_valid_params : CellParam
  • c31 : NeighbourCell, GprsParam
  • c32 : NeighbourCell, GprsParam
  • c_account_len_max : DataConnProfile
  • c_addr_family_inet : SysSocketBase, SysSocket
  • c_addr_family_unspec : SysSocketBase, SysSocket
  • c_analog : CsdDataConnProfile
  • c_any_url : ObexMngr
  • c_asot_max : GuidServiceTable
  • c_auth_tcp : Iana
  • c_auth_udp : Iana
  • c_combined_delivery : DrmInfo
  • c_conference_tcp : Iana
  • c_conference_udp : Iana
  • c_copy_buf_size : File
  • c_data_rate_14400 : CsdDataConnProfile
  • c_data_rate_19200 : CsdDataConnProfile
  • c_data_rate_2400 : CsdDataConnProfile
  • c_data_rate_28800 : CsdDataConnProfile
  • c_data_rate_4800 : CsdDataConnProfile
  • c_data_rate_9600 : CsdDataConnProfile
  • c_dataconn_profile_count : WapProfile
  • c_decoder : PngDecoder
  • c_default_idle_timeout : DataConnProfile
  • c_default_linger_timeout : DataConnProfile
  • c_default_max_pending_requests : TcpServerSocket
  • c_display : DrmInfo
  • c_event_adapter_closed : NetAdapter
  • c_event_bearer_lost : Socket
  • c_event_conn_closed : Socket
  • c_event_conn_established : Socket
  • c_event_conn_failed : Socket
  • c_event_conn_req_pending : Socket
  • c_event_data_received : Socket, NetAdapter
  • c_event_data_sent : Socket, NetAdapter
  • c_execute : DrmInfo
  • c_ext_ctx_state_connected : PdpContextManager
  • c_ext_ctx_state_connecting : PdpContextManager
  • c_ext_ctx_state_disconnected : PdpContextManager
  • c_ext_ctx_state_disconnecting : PdpContextManager
  • c_ext_ctx_state_invalid : PdpContextManager
  • c_file_version : DataConnProfileStorage::Header
  • c_flag_add_to_trace_info : VersionInfo
  • c_flag_hide_in_engineering_mode : VersionInfo
  • c_flag_is_build_version : VersionInfo
  • c_flag_never_show_on_display : VersionInfo
  • c_forward : DrmInfo
  • c_forward_lock : DrmInfo
  • c_ftp_data_tcp : Iana
  • c_ftp_data_udp : Iana
  • c_ftp_tcp : Iana
  • c_ftp_udp : Iana
  • c_ftps_data_tcp : Iana
  • c_ftps_data_udp : Iana
  • c_ftps_tcp : Iana
  • c_ftps_udp : Iana
  • c_global_errno : SerialIoAdapter::SioErrorDesc
  • c_http_request_method_get : HttpRequest
  • c_http_request_method_post : HttpRequest
  • c_http_tcp : Iana
  • c_http_udp : Iana
  • c_https_tcp : Iana
  • c_https_udp : Iana
  • c_iana_private_ports_begin : Iana
  • c_iana_private_ports_end : Iana
  • c_imap3_tcp : Iana
  • c_imap3_udp : Iana
  • c_imap_tcp : Iana
  • c_imap_udp : Iana
  • c_imaps_tcp : Iana
  • c_imaps_udp : Iana
  • c_increment : Vector< T >
  • c_infinite_timeout : DataConnProfile
  • c_inrease_step : MessageIdentifierContainer
  • c_invalid_id : WapProfile
  • c_invalid_port_no : Iana
  • c_invalid_rec_no : SmsWStringCache
  • c_invalid_set_id : WapProfile
  • c_ipaddr_any : IpAddr
  • c_ipaddr_broadcast : IpAddr
  • c_ipaddr_loopback : IpAddr
  • c_irc_tcp : Iana
  • c_irc_udp : Iana
  • c_ircs_tcp : Iana
  • c_ircs_udp : Iana
  • c_isdn : CsdDataConnProfile
  • c_ldap_tcp : Iana
  • c_ldap_udp : Iana
  • c_max_access_point_name_len : PdpContext
  • c_max_account_len : PdpContext::Authentication
  • c_max_apoxi_no_of_message_identifiers : MessageIdentifierContainer, Cbs::Filter
  • c_max_auth_set : WapProfile
  • c_max_cbs_applications : CbsFilterList
  • c_max_cid_array_len : PdpContextManager
  • c_max_domain : WapProfile
  • c_max_guaranteed_user_data_size : SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver
  • c_max_len : PdpContext::Address
  • c_max_password_len : PdpContext::Authentication
  • c_max_phy_port_set : WapProfile
  • c_max_physical_set : WapProfile
  • c_max_port_services : WapProfile
  • c_max_port_set : WapProfile
  • c_max_profile_name_len1 : WapProfile
  • c_max_proxy_id_len : WapProfile
  • c_max_proxy_name_len : WapProfile
  • c_max_proxy_p_id_len : WapProfile
  • c_max_pwd_len : WapProfile
  • c_max_stack_no_of_data_coding_schemes : Cbs::Filter
  • c_max_stack_no_of_message_identifiers : Cbs::Filter
  • c_max_startpage_len : WapProfile
  • c_max_uris_per_table : LockTable
  • c_max_url_len1 : WapProfile
  • c_max_username_len : WapProfile
  • c_max_wap_profile_count : WapProfile
  • c_name_tcp : Iana
  • c_name_udp : Iana
  • c_nameserver_tcp : Iana
  • c_nameserver_udp : Iana
  • c_netnews_tcp : Iana
  • c_netnews_udp : Iana
  • c_nntp_tcp : Iana
  • c_nntp_udp : Iana
  • c_no_lock : DrmInfo
  • c_no_timeout : DataConnProfile
  • c_none : DrmInfo
  • c_opl_buffer_len : OplEntry
  • c_option_broadcast : SysSocketBase
  • c_option_debug : SysSocketBase
  • c_option_dont_route : SysSocketBase
  • c_option_error : SysSocketBase
  • c_option_keep_alive : SysSocketBase
  • c_option_linger : SysSocketBase
  • c_option_rcv_buf : SysSocketBase
  • c_option_reuse_addr : SysSocketBase
  • c_option_snd_buf : SysSocketBase
  • c_option_tcp_max_seg : SysSocketBase
  • c_option_tcp_no_delay : SysSocketBase
  • c_option_type : SysSocketBase
  • c_over_i : GprsParam
  • c_over_i_array : COverIList
  • c_passwd_len_max : DataConnProfile
  • c_pixel_channels : PngDecoder
  • c_play : DrmInfo
  • c_pop3_tcp : Iana
  • c_pop3_udp : Iana
  • c_pop3s_tcp : Iana
  • c_pop3s_udp : Iana
  • c_pref_stack_size : SysSocket
  • c_print : DrmInfo
  • c_profile_type_csd : DataConnProfile
  • c_profile_type_psd : DataConnProfile
  • c_result : ObexAbstractPort::CompleteEvent
  • c_run_level_1 : SubSystemManager
  • c_run_level_3 : SubSystemManager
  • c_run_level_5 : SubSystemManager
  • c_run_level_7 : SubSystemManager
  • c_sem : PngDecoder
  • c_sem_created : PngDecoder
  • c_separate_delivery : DrmInfo
  • c_set_tcp : Iana
  • c_set_udp : Iana
  • c_shift : PngImage
  • c_shutdown_stop_rx : SysSocketBase, InetSocket
  • c_shutdown_stop_rx_tx : SysSocketBase, InetSocket
  • c_shutdown_stop_tx : SysSocketBase, InetSocket
  • c_sio_err__already : SerialIoAdapter
  • c_sio_err_acces : SerialIoAdapter
  • c_sio_err_addrnnotvail : SerialIoAdapter
  • c_sio_err_afnosupport : SerialIoAdapter
  • c_sio_err_again : SerialIoAdapter
  • c_sio_err_badf : SerialIoAdapter
  • c_sio_err_busy : SerialIoAdapter
  • c_sio_err_connrefused : SerialIoAdapter
  • c_sio_err_fault : SerialIoAdapter
  • c_sio_err_inprogress : SerialIoAdapter
  • c_sio_err_inval : SerialIoAdapter
  • c_sio_err_max : SerialIoAdapter
  • c_sio_err_nametoolong : SerialIoAdapter
  • c_sio_err_nfile : SerialIoAdapter
  • c_sio_err_noact : SerialIoAdapter
  • c_sio_err_nodev : SerialIoAdapter
  • c_sio_err_nomem : SerialIoAdapter
  • c_sio_err_none : SerialIoAdapter
  • c_sio_err_noopt : SerialIoAdapter
  • c_sio_err_noprotoopt : SerialIoAdapter
  • c_sio_err_nosubdev : SerialIoAdapter
  • c_sio_err_nosys : SerialIoAdapter
  • c_sio_err_notsock : SerialIoAdapter
  • c_sio_err_nscan : SerialIoAdapter
  • c_sio_err_opnotsupp : SerialIoAdapter
  • c_sio_err_protonosupport : SerialIoAdapter
  • c_sio_err_sockstate : SerialIoAdapter
  • c_sio_err_timeout : SerialIoAdapter
  • c_sio_errno : SerialIoAdapter::SioErrorDesc
  • c_sms_sending_anim_img_cnt : SmsSendingAnimation
  • c_sms_sending_anim_speed : SmsSendingAnimation
  • c_smtp_tcp : Iana
  • c_smtp_udp : Iana
  • c_sock_pf_bt : SerialIoAdapter
  • c_sock_pf_max : SerialIoAdapter
  • c_sock_pf_termio : SerialIoAdapter
  • c_sock_pf_undef : SerialIoAdapter
  • c_ssh_tcp : Iana
  • c_ssh_udp : Iana
  • c_state_logged_in : FtpClient
  • c_state_login_process : FtpClient
  • c_state_not_logged_in : FtpClient
  • c_state_terminated : FtpClient
  • c_t9_symbol_pages : T9InputConfig
  • c_t9_symbol_rows : T9InputConfig
  • c_table_full : NotificationArray, LockTable
  • c_table_size : NotificationArray
  • c_telnet_tcp : Iana
  • c_telnet_udp : Iana
  • c_telnets_tcp : Iana
  • c_telnets_udp : Iana
  • c_tftp_tcp : Iana
  • c_tftp_udp : Iana
  • c_theme_name : CustomizableTheme
  • c_time_feature_object_id : TimeFeatureObject
  • c_tpdu_size : Sms
  • c_type_default : InetSocket
  • c_type_dgram : SysSocketBase, SysSocket, InetSocket
  • c_type_raw : SysSocketBase, SysSocket, InetSocket
  • c_type_stream : SysSocketBase, SysSocket, InetSocket
  • c_type_tcp : NetAdapter
  • c_type_udp : NetAdapter
  • c_unlimited : Image
  • c_wap_push_http_tcp : Iana
  • c_wap_push_http_udp : Iana
  • c_wap_push_https_tcp : Iana
  • c_wap_push_https_udp : Iana
  • c_wap_push_tcp : Iana
  • c_wap_push_udp : Iana
  • c_wap_pushsecure_tcp : Iana
  • c_wap_pushsecure_udp : Iana
  • c_wap_vcal_s_tcp : Iana
  • c_wap_vcal_s_udp : Iana
  • c_wap_vcal_tcp : Iana
  • c_wap_vcal_udp : Iana
  • c_wap_vcard_s_tcp : Iana
  • c_wap_vcard_s_udp : Iana
  • c_wap_vcard_tcp : Iana
  • c_wap_vcard_udp : Iana
  • c_wap_wsp_s_tcp : Iana
  • c_wap_wsp_s_udp : Iana
  • c_wap_wsp_tcp : Iana
  • c_wap_wsp_udp : Iana
  • c_wap_wsp_wtp_s_tcp : Iana
  • c_wap_wsp_wtp_s_udp : Iana
  • c_wap_wsp_wtp_tcp : Iana
  • c_wap_wsp_wtp_udp : Iana
  • c_wimd_tcp : Iana
  • c_wimd_udp : Iana
  • c_www_http_tcp : Iana
  • c_www_http_udp : Iana
  • c_www_tcp : Iana
  • c_www_udp : Iana
  • CacheArray : SmsWStringCache
  • CachingSortProvider() : CachingSortProvider
  • CalcCameraScalingRate() : Camera
  • CalcFileMemOvrhd() : FfsHandler
  • CalcFreeChars() : SmsEditor
  • CalcProgress() : IncrementalPdcUpdater
  • CalculateBufferSize() : StreamAudioReference
  • CalculatePlayTime() : AudioUtility
  • CalculateUserDataSize() : UserData
  • Calculator : InputMapper
  • CalculatorInputMapper() : CalculatorInputMapper
  • CalendarAddRecordWin() : CalendarAddRecordWin
  • CalendarApp() : CalendarApp
  • CalendarCategory : CalendarRecord
  • CalendarGotoDateWin() : CalendarGotoDateWin
  • CalendarGrid() : CalendarGrid
  • CalendarGridView() : CalendarGridView
  • CalendarListWin() : CalendarListWin
  • CalendarMonthSelector() : CalendarMonthSelector
  • CalendarMonthSelectorView() : CalendarMonthSelectorView
  • CalendarMonthWin() : CalendarMonthWin
  • CalendarProvider() : CalendarProvider
  • CalendarRecord() : CalendarRecord
  • CalendarRecordsList() : CalendarRecordsList
  • CalendarRecordsListBoxModel() : CalendarRecordsListBoxModel
  • CalendarRecurrence : CalendarRecord
  • call : CallSetupProgressArg, DtmfRejectArg, DtmfStartCnfArg, CallInfoArg, CallDisconnectingArg
  • Call() : SingleArgHook< T >
  • call_duration : CallDisconnectingArg
  • call_hold_indicator : NotifySsArg
  • call_index : CallEvent
  • call_wait_indicator : NotifySsArg
  • CallAcceptMsg() : CallAcceptMsg
  • CallActive : XCallInfoResponseParser
  • CallApiRc() : EnumTranslationTable
  • Callback() : StreamingCallback
  • CallbackFn : ContextExecuteMsg
  • CallBackFn : SystemTimer
  • CallbackRead() : StreamingCallback
  • CallbackWrite() : StreamingCallback
  • CallBarred : SsErrorCode, Sms
  • CallBarredMsg() : CallBarredMsg
  • CallBarringActivatedMsg() : CallBarringActivatedMsg
  • CallBarringDeactivatedMsg() : CallBarringDeactivatedMsg
  • CallBarringHandler() : CallBarringHandler
  • CallBarringPasswordChangedMsg() : CallBarringPasswordChangedMsg
  • CallBarringStatusMsg() : CallBarringStatusMsg
  • CallClearing : XCallInfoResponseParser
  • CallControlCallSetupInfo : XCallInfoResponseParser
  • CallControlIndMsg() : CallControlIndMsg
  • CallControlInfoMsg() : CallControlInfoMsg
  • CallControlSetupIndArg() : CallControlSetupIndArg
  • CallControlSsIndArg() : CallControlSsIndArg
  • CallControlUssdIndArg() : CallControlUssdIndArg
  • CallDeflectionCompleted : XCallInfoResponseParser
  • CallDeflectionErrIndicationMsg() : CallDeflectionErrIndicationMsg
  • CallDeflectionHandler() : CallDeflectionHandler
  • CallDeflectionIndArg() : CallDeflectionIndArg
  • CallDeflectionIndMsg() : CallDeflectionIndMsg
  • CallDeflectionRejected : XCallInfoResponseParser
  • CallDeflectionRejectedMsg() : CallDeflectionRejectedMsg
  • CallDeflectionStarted : XCallInfoResponseParser
  • CallDeflectSsReqArg() : CallDeflectSsReqArg
  • CallDirection : XCallInfoResponseParser, MmCallInfo
  • CallDiscIndArg() : CallDiscIndArg
  • CallDisconnected : CallEvent
  • CallDisconnectedMsg() : CallDisconnectedMsg
  • CallDisconnectingMsg() : CallDisconnectingMsg
  • CallDiscReqArg() : CallDiscReqArg
  • CalledPartyAlertingMsg() : CalledPartyAlertingMsg
  • CallErrorCause() : EnumTranslationTable
  • CallEventMsg() : CallEventMsg
  • CallForwardingActivatedMsg() : CallForwardingActivatedMsg
  • CallForwardingActiveMsg() : CallForwardingActiveMsg
  • CallForwardingDeactivatedMsg() : CallForwardingDeactivatedMsg
  • CallForwardingErasedMsg() : CallForwardingErasedMsg
  • CallForwardingHandler() : CallForwardingHandler
  • CallForwardingRegisteredMsg() : CallForwardingRegisteredMsg
  • CallForwardingStatusMsg() : CallForwardingStatusMsg
  • CallHandler() : CallHandler
  • CallHdl() : CallHdl
  • CallHdlBase() : CallHdlBase
  • CallHeldCompleted : XCallInfoResponseParser
  • CallHeldMsg() : CallHeldMsg
  • CallHeldRejected : XCallInfoResponseParser
  • CallHeldStarted : XCallInfoResponseParser
  • CallHoldCnfArg() : CallHoldCnfArg
  • CallHoldRejArg() : CallHoldRejArg
  • CallHoldRejectedMsg() : CallHoldRejectedMsg
  • CallIndArg() : CallIndArg
  • CallIndCallControlInfoArg() : CallIndCallControlInfoArg
  • CallInfoMsg() : CallInfoMsg
  • CallInfoNotValid : XCallInfoResponseParser
  • CallInfoType : XCallInfoResponseParser
  • calling_name : NameIndicator
  • CallInSetupExists() : InputContext
  • CallIsHeld : CallEvent
  • CallIsWaitingMsg() : CallIsWaitingMsg
  • CallMode : XCallInfoResponseParser
  • CallModeNotValid : XCallInfoResponseParser
  • CallNotifyMsg() : CallNotifyMsg
  • CallOnHoldMsg() : CallOnHoldMsg
  • CallProgressIndArg() : CallProgressIndArg
  • CallRelatedSsCnfArg() : CallRelatedSsCnfArg
  • CallRelatedSsCode() : EnumTranslationTable
  • CallRelatedSsRejArg() : CallRelatedSsRejArg
  • CallRelatedSsReqArg() : CallRelatedSsReqArg
  • CallRelCnfArg() : CallRelCnfArg
  • CallReleased : CallEvent
  • CallReleaseMsg() : CallReleaseMsg
  • CallRelIndArg() : CallRelIndArg
  • CallRemind : CalendarRecord
  • CallRetrieveCompleted : XCallInfoResponseParser
  • CallRetrieved : CallEvent
  • CallRetrievedMsg() : CallRetrievedMsg
  • CallRetrieveRejected : XCallInfoResponseParser
  • CallRetrieveStarted : XCallInfoResponseParser
  • CallSelectedNumber() : PhonebookApp
  • CallSetup : XCallInfoResponseParser
  • CallSetupBySimtTkReqArg() : CallSetupBySimtTkReqArg
  • CallSetupProgressMsg() : CallSetupProgressMsg
  • CallSsAction() : CallSsAction
  • CallSsActionId : CallSsAction
  • CallStackAdr() : InternalTracer
  • CallState : MmCallInfo
  • CallType : CsdDataConnProfile, XCallInfoResponseParser
  • CallTypeNotValid : XCallInfoResponseParser
  • CallWaitingActivatedMsg() : CallWaitingActivatedMsg
  • CallWaitingDeactivatedMsg() : CallWaitingDeactivatedMsg
  • CallWaitingHandler() : CallWaitingHandler
  • CallWaitingStatusMsg() : CallWaitingStatusMsg
  • Calv : AtResponse
  • Camera() : Camera
  • CameraAlreadyLockedError : Camera
  • CameraConfig : VideoCamera, StillCamera
  • CameraError : Camera
  • CameraMsgStartViewfinding() : CameraMsgStartViewfinding
  • CameraMsgStopViewfinding() : CameraMsgStopViewfinding
  • CameraNotInitializedError : Camera
  • CameraNotReadyError : Camera
  • CameraOptionSettingsWin() : CameraOptionSettingsWin
  • CameraSettings() : CameraSettings
  • CameraSettingsWin() : CameraSettingsWin
  • CameraState : Camera
  • CanActivateAudioPaths() : AudioAccessoryDetails
  • CanCancelRequest() : BtRequest
  • Cancel : ObexOppDataSinkPushServer, BtUncancelableRequest, BtServiceVerifyRequest, BtServiceRequest, BtRequest, BtDeviceSearchRequest, BtBipServerService, FileChunkOperator, VrHandler
  • CancelAction() : CancelAction
  • CancelAddNumber() : PbAdvDetails
  • CancelAllRequests() : SimAccessor
  • CancelAllSimRequests() : DataHandler
  • CancelCamera() : CameraCaptureWin
  • CancelCapture() : StillCamera
  • CancelEdit() : PbDetails
  • CancelHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • CancelId : MessageBox, DialogWindow
  • CancelOperation() : ObexServerOppImpl, ObexOppServer, File
  • CancelRedialling() : CallHdl
  • CancelRequest() : BtRequest
  • CancelSearchRequest() : BtApplicationDeviceSearchRequest
  • CancelSetup() : PppDataConn, DataConn
  • CancelSmoothScrolling() : AbstractGrid
  • CancelStatusReportRequest : CommandType
  • CanDisplay() : FontManager
  • CanEdit() : PropertyEditor
  • CanExecuteRequest() : BtRequest
  • CanLinkAudioPath() : AudioPathManager
  • CANNOT_HAPPEN : StateMachine
  • CannotReplaceSm : ShortMessageFailureCause
  • CanPlay() : StreamAudioPlayer, MmfPlayer, DwdPlayer
  • CanPlayTogetherWith() : CustomSmafPhraseAudioReference, AudioReference
  • CanResume() : StreamAudioPlayer, MmfPlayer, DwdPlayer, MapiAudioPlayer
  • CanSeek() : StreamWriter, StreamReader
  • CanSuspend() : StreamAudioPlayer, MmfPlayer, DwdPlayer, MapiAudioPlayer
  • Capacity() : Vector< T >
  • CapacityExceed : Sms
  • CapitalizationMode : MultiTapInputMapper
  • Caps : Stream
  • CaptionOnLeft : AbstractEditBox
  • CaptionOnTop : AbstractEditBox
  • CaptionPos : AbstractEditBox
  • Capture() : StillCamera
  • Caret() : Caret
  • CaretAction : AbstractMultiLineEditor
  • CaretLeft : AbstractMultiLineEditor
  • CaretLineDown : AbstractMultiLineEditor
  • CaretLineUp : AbstractMultiLineEditor
  • CaretRight : AbstractMultiLineEditor
  • CArray() : CArray< T >
  • Cartesian : JoinRule
  • CartesianType : StandardJoinRule
  • Cast() : BtObexClientNmaTransportDisconnect, BtObexClientNmaDataInidication, BtObexClientNmaDataBufferIndication, BtObexClientNmaHeaderIndication, BtObexClientNmaHeaderSent, BtObexServerNmaTransportDisconnect, BtObexServerNmaDataInidication, BtObexServerNmaDataBufferIndication, BtObexServerNmaHeaderIndication, BtObexServerNmaHeaderSent, BtObexServerNmaAbort, BtObexServerNmaPut, BtObexServerNmaGet, BtObexServerNmaSetPath, BtObexServerNmaDisconnect, BtObexServerNmaConnect, BtHsNmaCallEvent, BtHsNmaLowPowerModeNotPossible, BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHsNmaAudioConnectionLost, BtHsNmaTransferAudioToPhone, BtHsNmaTransferAudioToAccessory, BtHsNmaDisconnect, BtHsNmaConnect, BtHsCmaCheckPendingAudioCallback, BtHsCmaAudioTransferOutOfCall, BtHsCmaEnterLowPowerMode, BtHsCmaAudioAsynchronous, BtHsCmaHangUp, BtHfNmaCallEvent, BtHfNmaLowPowerModeNotPossible, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain, BtHfNmaAudioConnectionLost, BtHfNmaTransferAudioToPhone, BtHfNmaTransferAudioToAccessory, BtHfNmaDisconnect, BtHfNmaConnect, BtHfCmaCheckPendingAudioCallback, BtHfCmaAtChldOneCommandReceived, BtHfCmaAudioAsynchronous, BtHfCmaMOC, BtHfCmaMTC, BtHfCmaPhoneNumberRequired, BtBipGetImagingCapabilitiesIndArg, BtBipDeleteImageIndArg, BtBipGetLinkedAttachmentIndArg, BtBipGetLinkedThumbnailIndArg, BtBipGetImageIndArg, BtBipOpFinishedArg, BtBipGetImagePropertiesIndArg, BtBipGetImagesListIndArg, BtBipPutLinkedAttachmentCompleteArg, BtBipPutLinkedAttachmentIndArg, BtBipPutLinkedThumbnailCompleteArg, BtBipPutLinkedThumbnailIndArg, BtBipPutImageCompleteArg, BtBipPutImageIndArg, BtBipAbortIndArg, BtBipDisconnectIndArg, BtBipConnectIndArg, BtAvrcpNmaRawFrame, BtAvrcpNmaPanelPassThrough, BtAvrcpNmaDisconnect, BtAvrcpNmaConnect, SsUus1QueryReqArg, SsUus1ReqArg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, SsUus1IndArg, SsUus1QueryRejArg, SsUus1QueryIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityRejArg, SsFacilityIndArg, SsBeginAccArg, SmsGetMoreMessageStatusReqArg, SmsSetMoreMessageReqArg, SmsSendReqArg, SmsConfigIndArg, SmsGetMoreMessageStatusIndArg, SmsCapacityAvailableArg, SmsCapacityExceededArg, SmsSendRejArg, SmsSendCnfArg, SmsNewStatusReportIndArg, SmsNewMessageIndArg, SimTkRefreshNewRspArg, SimTkStopSendDtmfReqArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, BrowserTermEventArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, BrowserRegisterReqArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, ExtProactiveCmdIndArg, LanguageSettingIndArg, LanguageSelectEventArg, IdleScreenAvailEventArg, UserActivityEventArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, MenuSelectionReqArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkRefreshNewReqArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, SimTkInterfaceIndArg, SimTkSendDtmfEndIndArg, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimBrowserTermResArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, TermRspCnfArg, ExtProactiveCmdCnfArg, ExtProactiveCmdReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, EndSimToolkitIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, MenuSelectionRejArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg, SimTkSsIndArg, SimTkSmsPpIndArg, SimTkCallSetupIndArg, SimModifyLockReqArg, BdnReqArg, FdnReqArg, SimMruPropertyUpdReqArg, SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadReqArg, SimODynReadReqArg, SimCmiReadReqArg, UsimFilePropertyReqArg, UsimLangUpdReqArg, UsimEstReadReqArg, UsimSmsParamUpdReqArg, UsimCardTypeReadReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimLangReadReqArg, UsimPsLociReadReqArg, UsimCsLociReadReqArg, UsimPlmnReadReqArg, UsimUstReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCfufUpdReqArg, CphsVmwfUpdReqArg, CphsOnsReadReqArg, CphsOnmReadReqArg, CphsCfufReadReqArg, CphsVmwfReadReqArg, CphsIstReadReqArg, SimFileInfoReqArg, SimSpnReadReqArg, SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg, SimGenericReqArg, SimPuctUpdReqArg, SimPuctReadReqArg, SimAcmMaxUpdReqArg, SimAcmMaxReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSstReadReqArg, SimRefreshReqArg, SimModifyLockIndArg, BdnIndArg, FdnIndArg, SimFullAccessIndArg, SimLockStatusIndArg, SimInfoIndArg, SimInitIndArg, SimMruPropertyRefreshIndArg, SimMruPropertyUpdCnfArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimUpdCnfArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimMccMncIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimGenericIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, SimRefreshIndArg, SimErrorIndArg, ControlHwDataOnlyArg, StopSignalStrengthListeningArg, StartSignalStrengthListeningArg, StopBatteryLoadListeningArg, ClientDeregistrationArg, ClientRegistrationArg, PowerDownReqArg, OmPowerUpArg, PowerDownIndArg, OmControlIndArg, PowerDownCnfArg, PlmnListReqArg, GprsClassReqArg, PlmnInfoReqArg, DetachReqArg, AttachReqArg, PrefServiceSetReqArg, PrefPlmnChangeArg, PlmnListAbortArg, GprsClassIndArg, AttachAllowedIndArg, DetachCnfArg, AttachRejArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListRejArg, PlmnListCnfArg, UsimPbReadCnfArg, UsimPbStopReqArg, UsimPbFillStatusReqArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, UsimPbSelectReqArg, UsimPbLocationReqArg, PbCountReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, PbInfoReadReqArg, UsimPbReadyIndArg, UsimPbUidRefreshIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg, UsimPbLocationIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, PbInfoReadIndArg, OmRatChangeReqArg, OmBandStatusReqArg, OmMultiSlotReqArg, OmRatChangeIndArg, OmRatChangeCnfArg, OmBandStatusCnfArg, OmMultiSlotIndArg, MnNetworkSearchModeReqArg, MnTriggerReqArg, HomezoneIndArg, BandSelectionIndArg, TestparamReportArg, MnInformationIndArg, CellInfoIndArg, ConnectionIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, ClearBlacklistReqArg, RediallingDisabledIndArg, RedialRejArg, MocSetupReqArg, ClearBlackListCnfArg, AutoCallRestrictIndArg, RedialStopIndArg, RedialSetupIndArg, RedialIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, MocSetupRejArg, EngineeringModeControlRequestArg, OmSetTermProfileReqArg, OmGetTermProfileReqArg, OmFactoryResetIndArg, BandSelectionReqArg, TestparamReqArg, ImeiReadReqArg, BootDispatchingArg, EccListIndArg, CfuDataIndArg, EngineeringModeControlResponseArg, OmSetTermProfileRejArg, OmSetTermProfileCnfArg, OmGetTermProfileCnfArg, AccessoryIndArg, ImeiReadIndArg, SignalStrengthLevelIndArg, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsConcRefNumReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsSetWaitingReqArg, MdhRemoveViewReqArg, MdhMakeViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSetStorageReqArg, MdhSmsUpdStatusReqArg, MdhSmsStatusReqArg, MdhRegistrationReqArg, MdhDeregistrationReqArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsConcRefNumIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg, MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsStorageRefreshIndArg, MdhSmsRefreshIndArg, MdhNewStatusReportIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg, IconDescReadReqArg, ImageReadReqArg, IconDescReadIndArg, ImageReadIndArg, ChargeUnitsReqArg, SetChargeUnitsArg, ChargeReqArg, SetAutoChargeArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, CallDeflectSsReqArg, CallDeflectionIndArg, CbsStopReqArg, CbsStartReqArg, CbsNewDataRejArg, CbsLimitIndArg, CbsStopCnfArg, CbsStartCnfArg, CbsStopRejArg, CbsStartRejArg, CbsNewDataIndArg, RedialQueryReqArg, RejectCallsIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, MocSetupRejIndArg, CallIndCallControlInfoArg, RedialStatusIndArg, CallSetupBySimtTkReqArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, DtmfBufferClearedIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg, AtAccessoryRegisterCnfArg, AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtPbInfoIndArg, AtPbListCnfArg, AtPbSelectCnfArg, AtAlphaTagCnfArg, AtAccessoryRegisterReqArg, AtGenericCmdReqArg, AtPbListReqArg, AtPbSelectReqArg, AtAlphaTagReqArg, VrPropertyResultIndArg, VrWarningIndArg, VrErrorIndArg, VrG2AResultIndArg, VrStoreTemplateReqArg, VrStopRecogIndArg, VrAbortEngineIndArg, VrTrainResultIndArg, VrRecogResultIndArg, VrIntrmRecResultIndArg, VrSayNameIndArg, VrLoadTemplateReqArg, VrInitCnfArg, VrParamReqArg, SerialTerminalArg, SaLocationErrArg, SaMolrResultArg, MeasurementDataArg, AbortResArg, LcsMolrResultArg, LocationNotifInvokeArg
  • Catalan : LanguageManager
  • Category() : AbstractDevice, Message
  • category : CalendarRecord::Persist, UsimEccRecord
  • CategoryCounts : CalendarRecord
  • cause : DtmfRejectArg, CallDisconnectingArg, MdhResult
  • Cause : StartUp
  • cb_capture_finished() : CameraCaptureWin, CameraApp
  • Cb_FrameCaptured : VideoCamera
  • cb_image_captured() : CameraCaptureWin, CameraApp
  • cb_image_encoded() : CameraCaptureWin, CameraApp
  • Cb_ImageEncoded : ImageEncoder
  • Cb_NotifyCaptureBufferStatus : VideoCamera
  • Cb_VideoCapturePaused : VideoCamera
  • Cb_VideoCaptureStopped : VideoCamera
  • CbCaptureFinished : StillCamera
  • CbFrameDecoded : VideoDecoder, AudioDecoder
  • CbFrameEncoded : AudioEncoder
  • CbImageCaptured : StillCamera
  • CbImageEncoded : StillCamera
  • CbInBufferFree : VideoDecoder
  • CBitmapResPtr : AnimationBmpPointerArrayIterator
  • CbmiProvider() : CbmiProvider
  • CbmiRangeProvider() : CbmiRangeProvider
  • CbReady : AudioDecoderRenderer, AudioCapturerEncoder
  • CbResult : VideoChannel, CodecDevice
  • CbResultAndTimeInfo : CodecDevice
  • Cbs : Cbs, DataCodingScheme
  • CbsDataSource : SimTextString
  • CbsDispatcher() : CbsDispatcher
  • CbsFilterList() : CbsFilterList
  • CbsHandler() : CbsHandler
  • CbsLimitIndArg() : CbsLimitIndArg
  • CbsLimitMsg() : CbsLimitMsg
  • CbsNewDataIndArg() : CbsNewDataIndArg
  • CbsNewDataMsg() : CbsNewDataMsg
  • CbsNewDataRejArg() : CbsNewDataRejArg
  • CbsStartCnfArg() : CbsStartCnfArg
  • CbsStartDispatcher() : CbsStartDispatcher
  • CbsStartRejArg() : CbsStartRejArg
  • CbsStartReqArg() : CbsStartReqArg
  • CbsStopCnfArg() : CbsStopCnfArg
  • CbsStopDispatcher() : CbsStopDispatcher
  • CbsStopRejArg() : CbsStopRejArg
  • CbsStopReqArg() : CbsStopReqArg
  • CbVideoFrameEncoded : VideoEncoder
  • CbVideoFrameRendered : VideoChannel
  • CCBS : InputParser
  • ccbs_entry : CcbsList
  • ccbs_idx : CcbsEntry
  • ccbs_list : InterrogateCcbsResult
  • ccbs_que_length : InterrogateCcbsResult
  • CcbsRecallMsg() : CcbsRecallMsg
  • CcbsResultMsg() : CcbsResultMsg
  • CcbsStatusMsg() : CcbsStatusMsg
  • CCNotPerformed : XCallInfoResponseParser
  • CCNotValid : XCallInfoResponseParser
  • ccp1 : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • CcPerformed : XCallInfoResponseParser
  • CCPerformed : XCallInfoResponseParser
  • Ccwa : AtResponse
  • Ccwv : AtResponse
  • CD : InputParser
  • Cdev : AtResponse
  • Cdip : AtResponse
  • CdNotValid : XCallInfoResponseParser
  • Cell() : Cell
  • cell_bar_access : CellParam
  • cell_bar_qualify : CellParam
  • cell_change_cnt : CellParam
  • cell_change_cnts : TestparamReport
  • cell_change_ind : AsTestparamDatabase
  • cell_id : CellParam, NeighbourCell
  • cell_identity : UmtsRrcScellParam
  • cell_reselect_offset : CellParam
  • cell_reselection_reason : RrParam
  • cell_type : UmtsNcellParam
  • CellChangeCnts : TestparamReport
  • CellInfoIndArg() : CellInfoIndArg
  • CellInfoMsg() : CellInfoMsg
  • CellParam() : CellParam
  • CellPropsType : GuiObjectFactory
  • CellsProp : GuiObjectFactory
  • CellWideImmediate : Cbs::SerialNumber
  • CellWideNormal : Cbs::SerialNumber
  • Center : Layouter, GridLayout, Control::NavigationGuidance, Indicator, InformationElement
  • CenterBasedMetering : Camera
  • Centered : TextFormat
  • CenteredAlign : EditorDocument
  • CenteredTextIndicator() : CenteredTextIndicator
  • CenteredVerticalProp : GuiObjectFactory
  • central_pos : JarFileStatusInfo, JarBinDataStatusInfo
  • CFBusy : InputParser
  • CFNoReply : InputParser
  • CFNotReachable : InputParser
  • CFU : InputParser
  • CfuDataIndArg() : CfuDataIndArg
  • CfuService() : CfuService
  • CfuServiceArray() : CfuServiceArray
  • CfuStatusMsg() : CfuStatusMsg
  • Cgact : AtResponse
  • ChangeActiveDevice() : BtAvrcpPanelApplication
  • ChangeChv() : SimChvHandler, SimAccessor
  • ChangeColor() : Led
  • changed : Provider
  • changed_indication : SimInfo
  • changed_state : SimInfo
  • ChangeDir() : FfsHandler, RamHandler, FatHandler
  • ChangedMediaError : File
  • ChangeGprsClass() : PlmnHandler
  • ChangeMenuAccessor() : Menu
  • ChangeMenuAction() : PbAbstractWin
  • ChangePassword() : CallBarringHandler
  • ChangePhoneticSelection() : ChineseT9Wrapper
  • ChangePin : SsHandler, InputParser, PinAction
  • ChangePin2 : SsHandler, InputParser
  • ChangePreferedRatMode() : PlmnHandler
  • ChangePreferredStorageMedia() : SmsHandler, SimPduHandler, DataHandler
  • ChangePrefService() : PlmnHandler
  • ChangeRatMode() : PlmnHandler
  • ChangeRequestState() : BtObexRequest, BtRequestRespondRequest, BtRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBppReq, BtAvrcpRequest
  • ChangeRequestStateForCancel() : BtRequest
  • ChangeType() : PhoneNumber
  • Channel : RingerAudioDevice
  • channel : RingerAudioDevice::StartParam
  • Channel1 : RingerAudioDevice
  • Channel2 : RingerAudioDevice
  • Channel3 : RingerAudioDevice
  • Channel4 : RingerAudioDevice
  • channel_mode : CellParam
  • channel_release_reason : RrParam
  • channel_type : CellParam
  • channel_volume : RingerAudioDevice::StartParam
  • ChannelAll : RingerAudioDevice
  • ChannelModeType : AudioEncoder
  • ChannelNumber : AudioReference
  • Chap : PdpContext::Authentication
  • Char : InternalTracer
  • CharacterClass : ThaiTextRenderer
  • characters() : WbxmlParserRel
  • CharactersHandler() : XMLParser
  • Charge() : Charger
  • charge_value : AocChargeData
  • ChargeBattery : Charger
  • ChargeEndBatteryIsFull : Charger
  • ChargeEndChargerIsDisconnected : Charger
  • ChargeIndArg() : ChargeIndArg
  • ChargerCategory : AbstractDevice
  • ChargerDisabledBatteryIdError : Charger
  • ChargerDisabledVoltageError : Charger
  • ChargeReqArg() : ChargeReqArg
  • ChargerInfoMsg() : ChargerInfoMsg
  • ChargerMsgType : Charger
  • ChargerOn : StartUp
  • ChargerRemoved : Charger
  • ChargerStatus : Charger
  • ChargeUnitsIndArg() : ChargeUnitsIndArg
  • ChargeUnitsReqArg() : ChargeUnitsReqArg
  • ChargingPaused : Charger
  • ChargingResumed : Charger
  • CharInputMapItem() : CharInputMapItem
  • CharItem() : CharItem
  • CharType : BidiManager
  • Check() : MimeCoder
  • CheckBox() : CheckBox
  • CHECKBOX_ACTIVE_MSG : TestWriter
  • CHECKBOX_SELECTED_MSG : TestWriter
  • CheckBoxAction() : CheckBoxAction
  • CheckBoxControl() : CheckBoxControl
  • CheckBoxControlClassType : GuiObjectFactory
  • CheckBoxControlView() : CheckBoxControlView
  • CheckBoxItem() : CheckBoxItem
  • CheckBoxList() : CheckBoxList
  • CheckBoxListView() : CheckBoxListView
  • CheckBoxModel() : CheckBoxModel
  • CheckBoxView() : CheckBoxView
  • CheckCancelRequest() : DataConn
  • Checkered : Brush
  • CheckForInterrupt() : Image, Image::CleanupDrawingObtainer
  • CheckPoint : InternalTracer
  • CheckSelector() : ClirHandler
  • CheckSpnData() : SimAuxHandler, DataHandler
  • CheckTime() : MiscAudioDevice
  • CheckTimers() : DataConn
  • CheckTransportAvailable() : ObexAbstractPort
  • ChildBinData() : ChildBinData
  • childcount : RegIterator::InteriorMetaData
  • ChildOnly : MergeProvider
  • ChimesHigh : InformationElement
  • ChimesLow : InformationElement
  • Chinese : LanguageManager
  • ChineseQuickSortProvider() : ChineseQuickSortProvider
  • ChineseT9InputMapper() : ChineseT9InputMapper
  • ChineseT9Wrapper() : ChineseT9Wrapper
  • chip_type : BtChipVersion, BtChipBmu, BtChipBmscr
  • chn_rel_cause : RrcParam, AsTestparamDatabase
  • ChordHigh : InformationElement
  • ChordLow : InformationElement
  • chv1_status : SimInfo
  • chv1AttemptsLeft : ChvAttemptsStruct
  • Chv1DisableIndArg() : Chv1DisableIndArg
  • Chv1DisableReqArg() : Chv1DisableReqArg
  • Chv1EnableIndArg() : Chv1EnableIndArg
  • Chv1EnableReqArg() : Chv1EnableReqArg
  • chv1UnblAttemptsLeft : ChvAttemptsStruct
  • chv2_status : SimInfo
  • chv2AttemptsLeft : ChvAttemptsStruct
  • chv2UnblAttemptsLeft : ChvAttemptsStruct
  • chv_attempts : SimInfo
  • ChvChangedMsg() : ChvChangedMsg
  • ChvChangeIndArg() : ChvChangeIndArg
  • ChvChangeReqArg() : ChvChangeReqArg
  • ChvNo() : EnumTranslationTable
  • ChvProvider() : ChvProvider
  • ChvRefreshIndArg() : ChvRefreshIndArg
  • ChvStatus() : EnumTranslationTable
  • ChvUnblockIndArg() : ChvUnblockIndArg
  • ChvUnblockReqArg() : ChvUnblockReqArg
  • ChvVerifyIndArg() : ChvVerifyIndArg
  • ChvVerifyReqArg() : ChvVerifyReqArg
  • ci_param : L1Param
  • ci_testparam_array : CiTestParamList
  • Ciev : AtResponse
  • CifSize : CamWin32, Camera
  • cipher_on : CellParam, AsTestparamDatabase, UmtsRrcScellParam
  • CiTestParam() : CiTestParam
  • Ckev : AtResponse
  • Claps : InformationElement
  • Class0 : DataCodingScheme
  • Class1 : DataCodingScheme
  • Class2 : DataCodingScheme
  • Class3 : DataCodingScheme
  • ClassType : GuiObjectFactory
  • ClassType_AudioActiveReference : AudioActiveReference
  • ClassType_AudioReference : AudioReference
  • ClassType_CombinedDeviceAudioReference : AudioReference
  • ClassType_CustomIMelodyAudioReference : AudioReference
  • ClassType_CustomRingerAudioReference : AudioReference
  • ClassType_CustomSmafMelodyAudioReference : AudioReference
  • ClassType_CustomSmafPhraseAudioReference : AudioReference
  • ClassType_CustomToneAudioReference : AudioReference
  • ClassType_End : AudioReference
  • ClassType_MP3AudioReference : AudioReference
  • ClassType_PCMAudioReference : AudioReference
  • ClassType_PresetAudioReference : AudioReference
  • ClassType_RingerAudioReference : AudioReference
  • ClassType_SimpleAudioReference : AudioReference
  • ClassType_ToneAudioReference : AudioReference
  • ClassType_VoiceMemoAudioReference : AudioReference
  • Clav : AtResponse
  • Clcc : AtResponse
  • Clean() : ToDoDateDialogWin, ToDoComposeWin, SocketTestMessage
  • CleanTcpSocket() : SocketTestT2
  • CleanUdpSocket() : SocketTestT2
  • Cleanup() : PsdDataConn, PppDataConn, DataConn, CsdDataConn, ItemTree, ItemMenu, ItemBox, ImageBox, Control, ContextMenu, Component, AnimatedTextLine, AbstractItemGrid, AbstractEditor, Menu, MainHandler, HandlerListEntry, SvgPlayer, MultiMediaEditor, SimAccessor
  • CleanUp() : BackLight, RealTimeClock, BackLight, BtController, PngDecoder
  • CleanupDrawingObtainer : Image::CleanupDrawingObtainer, Image
  • CleanupImageCache() : AbstractItemGrid
  • CleanUpRequestExecution() : BtSingleConnectionController, BtMultiConnectionController, BtConnectionlessController
  • Clear : MediaRefContainer, TextEditorDocument, TextCompoundItem, EditorDocument, CompoundItem, BtSddbServiceRecord, BtSddbDeContainer, BtDeviceList, WString, TypeOfAddress, String, SharedPtr< T_obj >, RegBlobObject, PhoneNumber, ElementList< T >, BlobObject, BitField< T >, RtStreamingBuffer, SmsContext, InputAction, CbsFilterList::CbsFilterListEntry, FunctionalityIndicator, UsimPbFillStatus, UsimPbLocReport, UsimPbGroups, UsimPbChangedField, UsimPbRefRecord, UsimPbRwRecord, Tpdu, SimSetupIdleModeTextOptions, SimSetupMenuOptions, SimSelectItemOptions, SimGetInkeyOptions, SimGetInputOptions, SimDisplayTextOptions, SimIconIdentifier, SimNextActionIdentifier, SimTextString, SimItemIdentifier, SimAlphaIdentifier, SimIconQualifier, SimAtom< T >, ShortMessageStatus, ShortMessageFailureCause, ProtocolIdentifier, ParameterIndicator, MessageTypeIndicator, MessageIdentifierContainer, MessageIdentifier, DataCodingScheme, CommandType, Cbs, Cbs::SerialNumber, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem, TpduCache, TpduHeaderInformation, TpduPhoneNumberPersist, VrHandler
  • clear() : WbxmlVector< T >
  • ClearAfterDelay() : SimDisplayTextOptions
  • ClearAlarm() : AlarmManager, RealTimeClock
  • ClearBlacklist() : CallHdlBase, CallHandler
  • ClearBlackListCnfArg() : ClearBlackListCnfArg
  • ClearBlacklistReqArg() : ClearBlacklistReqArg
  • ClearBuffer() : Zi8Wrapper
  • ClearBufferVariables() : PbBaseProvider
  • ClearConnectedDevice() : BtSingleConnectionController
  • ClearData() : Tpdu, Cbs, SimPbEntry
  • ClearDatabase() : DBService
  • ClearDataCodingSchemeList() : Cbs::Filter
  • Cleared : XCallInfoResponseParser
  • ClearEditor() : Zi8InputMapper
  • ClearHeaderFields() : ObexFtpDataServer
  • ClearHintBits() : IrdaTransport
  • ClearingState : XCallInfoResponseParser
  • ClearingStateNotValid : XCallInfoResponseParser
  • ClearMessageIdentifierList() : Cbs::Filter
  • ClearProfile() : SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider
  • ClearRect() : DeviceContext
  • ClearRootCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ClearThreadlet() : FfsTestDispWin
  • ClearUserCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • cli_restriction_info : InterrogateSsResult
  • cli_restriction_option : SsData
  • client : BtObexServiceTable::Security
  • Client : Font
  • client_arg : FsRegistrationInfo, fs_registered_info_type
  • ClientAddrTypeId : ObexAbstractTransport
  • ClientAlreadyClosed : ObexResult
  • ClientAlreadyOpen : ObexResult
  • ClientAppContext : IrdaObexImpl
  • ClientArea : DrawableObject
  • ClientBackground : Color
  • ClientBackgroundColor : CTResourcePack
  • ClientCallBack() : IrdaObexTransport
  • ClientDc() : ClientDc
  • ClientDeregistrationArg() : ClientDeregistrationArg
  • ClientForeground : Color
  • ClientForegroundColor : CTResourcePack
  • ClientHandler : MmiSimServer
  • ClientId() : ClientId
  • ClientInfo() : ClientInfo
  • ClientName() : ClientName
  • ClientNetAdapter : ClientNetAdapter, NetAdapterHandler
  • ClientPortPtr : ObexClientDispatcher
  • ClientRegistrationArg() : ClientRegistrationArg
  • ClientSend() : SocketTestT2
  • ClientUrlType : BtJsr82Url
  • CliInvalid : XCallInfoResponseParser
  • CliNotAvailable : XCallInfoResponseParser
  • Clip : AtResponse
  • CLIP : InputParser
  • ClipStatusMsg() : ClipStatusMsg
  • CLIR : InputParser
  • clir_supp_rejected : NotifySsArg
  • ClirAction() : ClirAction
  • ClirNotSurpressedMsg() : ClirNotSurpressedMsg
  • ClirStatusMsg() : ClirStatusMsg
  • CliValid : XCallInfoResponseParser
  • CliValidity : XCallInfoResponseParser
  • CliWithheldByOriginator : XCallInfoResponseParser
  • Clone() : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, SoundBrowserServiceMsg, SkipSocketTestMsg, StopSocketTestMsg, ContinueSocketTestMsg, NextSocketTestMsg, StartSocketTestMsg, OnDataRcvdMsg, LcsAppResWinMsg, LcsAppRegisterForMtlrMsg, LcsAppTransferLocMsg, ImageBrowserServiceMsg, ImageBrowserRenameImageMsg, ImageBrowserDeleteImageMsg, SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, CameraMsgStopViewfinding, CameraMsgStartViewfinding, BtIndicatorMsg, PhonebookRenumberedMsg, ProviderUpdateMsg, SyncProgressMsg, SaveEntryInPhonebookMsg, OpenPbWinMsg, JumpToRowMsg, UtcStatusMessage, AsyncUnitTestMsg, DataConnProfileInfoMsg, DataConnInfoMsg, SocketControlMsg, DataConnProfile, ObexVCardMsg, ObexTransportMsg, ObexAddrMsg, ObexTriggerMsg, ObexMsg, ObexAppMsg, LoseFocusMsg, GetFocusMsg, ContextExecuteMsg, TimerTimeoutMsg, AlarmNotificationMsg, ShutdownRequestMsg, ContextWakeupMsg, ThreadletNotificationMsg, SharedTimerMsg, AppLoseFocusMsg, AppGetFocusMsg, ServiceThreadTerminateMsg, RtcAlarmReachedMsg, RtcDateChangedMsg, RtcTimeChangedMsg, ActionExecutedMsg, ItemPropertiesChangedMsg, ExternalTimeoutMsg, PenUpMsg, PenDownMsg, InputCharMsg, LockedKeyMsg, LockedKeyDownMsg, FlipMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, PowerWakeupMsg, LanguageChangedMsg, ThemeChangedMsg, AppUpdateDisplayMsg, AppCloseMsg, AppOpenMsg, PowerOffMsg, PowerOnMsg, NoMessage, Message, TextCompoundItem, RedrawDisplayMsg, ItemRendererPropertiesChangedMsg, ImageEncodingProgressMsg, DeleteComponentMsg, ImageDrawingInterruptedMsg, Zi8EnteredUnknownWordMsg, Zi8AddWordMsg, Zi8NoWordFoundMsg, T9MatrixModeKeypressed, T9SymbolEntryRequestMsg, T9EnteredUnknownWordMsg, T9AddWordMsg, T9NoWordFoundMsg, AragonMsg, CloseWindowMsg, RefreshComponentMsg, ContextMenuClosedMsg, ViewfinderErrorMsg, ImageDecodingProgressMsg, InvalidateMsg, SelectionChangedMsg, FocusPreviousControlMsg, FocusNextControlMsg, CompoundItem, CharItem, AtomItem, RtcInfoMsg, TransportNotificationMsg, LedNotificationMsg, DisplayInfoMsg, BatteryLoadLevelMsg, ChargerInfoMsg, SoundItem, BtObexClientRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtHsRequestStateChangedMessage, BtHsNotificationMessage, BtHfRequestStateChangedMessage, BtHfNotificationMessage, BtFaxRequestStateChangedMessage, BtFaxDisconnectMessage, BtFaxConnectMessage, BtFaxApplicationMessage, BtDunRequestStateChangedMessage, BtDunDisconnectMessage, BtDunConnectMessage, BtDunApplicationMessage, BtRequestStateChangedMessage, BtServiceMessage, BtSddbRequestStateChangedMessage, BtSddbDeAlternative, BtSddbDeSequence, BtSddbDeUrl, BtSddbDeString, BtSddbDeUuid128, BtSddbDeSint128, BtSddbDeSint64, BtSddbDeUint128, BtSddbDeUint64, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, BtSddbDeNil, BtSddbDataElement, BtRequestOperationMessage, BtCloseMessage, BtOpenMessage, BtRequestMessage, BtCancelVerifyMessage, BtServiceVerifyResultMessage, BtServiceVerifyMessage, BtPaSupportedProfileMessage, BtHfSupportedProfileMessage, BtHsSupportedProfileMessage, BtQuerySupportedProfilesMessage, BtDeviceUntrustMessage, BtDeviceTrustMessage, BtDeviceUnpairMessage, BtDevicePairMessage, BtSetRemoteDeviceNameMessage, BtCancelSearchMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtDeviceSearchMessage, BtRespondAuthorizationMessage, BtSendPasskeyMessage, BtProfileActivationMessage, BtConnectabilityMessage, BtPairabilityMessage, BtDiscoverabilityMessage, BtLocalNameMessage, BtLocalSettingsMessage, BtStateChangedMessage, BtGapAndSdapRequestMessage, BtRemoteDevicePairMessage, BtGapAndSdapNotificationMessage, BtAuthorizationRequiredMessage, BtPasskeyRequiredMessage, BtGapAndSdapRemoteRequestMessage, BtGapAndSdapApplicationMessage, BtApplicationMessage, BtBppRequestStateChangedMessage, BtBipProgressMsg, BtAvrcpRequestStateChangedMessage, BtAvrcpOperationServiceMessage, BtAvrcpNotificationMessage, RamData, BufferedData, BinData, AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStreamingSyncMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRadioDeviceNotificationMsg, AudioPlayTimeMsg, AudioMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioFmRadioRdsAlternativeFrequenciesMsg, AudioFmRadioRdsInfoMsg, AudioFmRadioRdsRadioTextMsg, AudioFmRadioRdsStationNameMsg, AudioFmRadioRdsRawDataMsg, AudioFmRadioRssiMsg, AudioFmRadioSeekMsg, AudioAccessoryConnectedMsg, AudioRecordingStoppedMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg, AudioErrorMsg, AudioDeviceStatusMsg, DisabledFeatureTriggeredMsg, UpdateItemMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg, PropertyTriggerMsg, FeatureChangedMsg, UpdateContextItemMsg, CloseAllMsg, IndicatorBarUpdateMsg, UssdBeginMsg, UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, UusQueryRejectedMsg, UusStatusMsg, GetPasswordMsg, UssdRequestResentMsg, UssdDataMsg, UssdEndMsg, UssdNotifyMsg, UssdRequestMsg, SsErrorMsg, CallBarringPasswordChangedMsg, ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, CnapInfoReceivedMsg, EctAlertingMsg, EctActiveMsg, MultiPartyCallInvokedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, CugCallMsg, HlrDataCorruptedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallIsWaitingMsg, CallRetrievedMsg, CallHeldMsg, CallForwardingActiveMsg, ClirNotSurpressedMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, CtmInfoIndMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, PbAlphaTagRequestMsg, PbEntryRequestMsg, PbSizeRequestMsg, CbsLimitMsg, SmsMessageWaitingChangedMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceAvailableMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsPortDataRecvMsg, SmsNewSocketDataMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, RatChangeModeChangedMsg, EngineeringModeControlResponseMsg, BandStatusMsg, GsmBandStateMsg, RatStateMsg, NwDiscStartIndMsg, HomezoneMsg, BandSelectionMsg, EngineeringReportMsg, UssdAnswerMsg, CcbsResultMsg, CcbsStatusMsg, CcbsRecallMsg, SsInfoMsg, SsFacilityRejectedMsg, UssdResentMsg, UssdIndicationMsg, PasswordRejectedMsg, PasswordInquiryMsg, SsErrIndicationMsg, SsRejectedMsg, SsEndMsg, SsSuccessMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, MocSetupRejectIndMsg, CallControlInfoMsg, RedialStatusMsg, DiagnosticIndMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, RedialStoppedMsg, RedialStartedMsg, CallNotifyMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfBufferCleanedMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, PowerModeIndMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, OmMultiSlotIndMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, SimTkProfileSetRejMsg, SimTkProfileSetCnfMsg, SimTkProfileGetCnfMsg, SimTkRefreshStartMsg, TermRspCnfMsg, SimTkSetupEventMsg, SimTkLanguageNotificationMsg, MptyHoldRejectedMsg, MptyOnHoldMsg, CallHoldRejectedMsg, CallOnHoldMsg, SimCallSetupRejectedMsg, SimEndTransactionMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimMenuItemSelectionFailedMsg, SimSetupMenuMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetDoneMsg, SimResetConfirmationMsg, SimRefreshResetMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, RegistrationAllowedMsg, PlmnScanFinishedMsg, RegistrationChangeMsg, RegistrationSuccessMsg, AccessoryIndMsg, SignalQualityLevelMsg, SignalStrengthLevelMsg, MinuteTickMsg, AlarmMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, LsaIdentityMsg, TimeZoneMsg, NetworkInformationMsg, SimErrorMsg, CfuStatusMsg, MptyCallReleaseMsg, CallReleaseMsg, CallAcceptMsg, ExternalPdpContextInfoMsg, GprsAttachStatusMsg, PdpContextActivationStatusMsg, ChvChangedMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg, CallEventMsg, GprsStatusMsg, SimLockStatusMsg, SimStateChangedMsg, SsMessage, ToStackMsg, FromStackMsg, RfsStorageDeviceRegistrationStatusMsg, RfsMediaAvailableStatusMsg, FileChunkOperationProgressMsg, FileBinData, RegCbNotifyMsg, RegNotifyMsg, VrRecognitionFailedMsg, VrTrainingFailedMsg, VrPlaybackFinishedMsg, VrTrainingResultMsg, VrRecognitionStoppedMsg, VrTrainingAbortedMsg, VrRecognitionAbortedMsg, VrWarningMsg, VrErrorMsg, VrResultMsg, VrPromptMsg, DBItemChangedMsg, SvgHyperlinkSelectMsg, SvgStatusMsg, SvgDecodingFinishedMsg, HttpDisconnectMessage, HttpConnectMessage, HttpRequestMessage, HttpErrorMessage, HttpServiceMessage, FtpDisconnectMessage, FtpConnectMessage, FtpRequestMessage, FtpTransferMessage, FtpErrorMessage, FtpServiceMessage, VCardItem, RichTextCompoundItem, ParagraphCompoundItem, ImageItem, GeneralCompoundItem, AudioItem, MmCallReleaseMsg, MmCallAcceptMsg, MmAocChargingStatusMsg, MmCurrentCallMeterMsg, MmCurrentChargeDataMsg, MmCallNotifyMsg, MmCallInfoMsg, MmCallSetupProgressMsg, MmMocSetupAcceptMsg, MmCallDisconnectingMsg, MmCallStatusMsg, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg, CloseDataConnMsg, GltpConnStatusMsg, SendRequestMsg, SetupDataConnMsg, ProcessMolrMsg, ProviderChangedMsg, AbortResMsg, LocationErrMsg, LocationResMsg, LocationNotifInvokeMsg, AppActionExecutedMsg, DrmWapPushMsg, FatFsUsbMassStorageReleaseMsg, FatFsUsbMassStorageRequestMsg, UsimPbResetedMsg, UsimPbReadyMsg, DataControlPhonebookStateMsg, DataControlEndBootMsg, DataControlBootMsg, DataControlBootProgressMsg, DataControlStartBootMsg, DataControlModificationMsg
  • Close() : FfsDataConnProfileStorage, SysSocket, SocketData, Socket, InetSocket, DataConnProfileStorage, ObexServerDispatcher, ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexFtpServer, ObexClientDispatcher, ObexAbstractPort, SocketPeer, Window, VideoChannel, StillCamera, VideoChannel, StillCamera, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoChannel, VideoCamera, StillCamera, NonsharedBinDataDataSource, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, VideoChannel, StillCamera, Camera, VideoChannel, FileOutputStream, FileInputStream, FfsFile, StringDataSink, StreamWriter, StreamReader, Stream, HeapDataSource, HeapDataSink, DataSource, DataSink, BinDataDataSource, RtStreamingEndPoint, ExtPsdContextListener_SioGlueWrapper, FileDataSource, FileDataSink, File, FlsFile, FfsHandler, SioSocketAdapter, SerialSocket, SerialIoAdapter, SioGlueWrapper, SerialTerminalSocket, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoderRenderer, AudioDecoder, AudioCapturerEncoder, RootFileImp, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile
  • CLOSE_REQ : SerialIoSet
  • CloseAction() : ObexServerDispatcher, ObexServer, ObexClientDispatcher, ObexAbstractPort, AtiAudioPlayerRtStreamingSink, RtStreamingEndPoint, DataSourceRtStreamingSource
  • CloseAfterTrigger() : MenuProperties
  • CloseAfterTriggerProp : GuiObjectFactory
  • CloseAllMsg() : CloseAllMsg
  • CloseAllNetAdapters() : NetAdapterHandler
  • CloseChannel() : ObexServerPort, ObexProtocol, ObexClientPort, ObexAbstractPort, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • CloseCompleteAction() : ObexAbstractPort
  • CloseConnection() : ObexClientOppImpl
  • Closed : MmCallInfo
  • CloseDatabase() : DBService
  • CloseDataConnection() : FtpClient
  • CloseDataConnMsg() : CloseDataConnMsg
  • CloseEditbox() : PbDetails
  • CloseFile() : StreamAudioReference
  • CloseHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • CloseImmediately() : Alert
  • CloseMinimized() : FmRadioWindow
  • CloseMinimizedRadio() : FmRadioApplication
  • CloseNetAdapter() : NetAdapterHandler
  • CloseWindow : ResultWinBase
  • CloseWindowAction() : CloseWindowAction
  • CloseWindowActionClassType : GuiObjectFactory
  • CloseWindowMsg() : CloseWindowMsg
  • CloudyBalance : Camera
  • cmd_number : T_STK_TRANSACTION_ID
  • CmeError : AtResponse
  • cmi : CmiRecord
  • CmiProvider() : CmiProvider
  • cname_selector : CallingName
  • CNAP : InputParser
  • CnapInfoReceivedMsg() : CnapInfoReceivedMsg
  • CnapStatusMsg() : CnapStatusMsg
  • code : EnumTextTableEntry
  • Code : SsErrorCode
  • codeAdr : InternalTracer::TraceHeader
  • CodecCategory : AbstractDevice
  • CodecConfig : ScicosCodecIfLib, AtiCodecsLib, EmzCodecsLib, CodecManager
  • CodecDevice() : CodecDevice
  • CodecManager : AtiAudioDecoderRenderer, VideoEncoder, VideoDecoder, CodecDevice, AudioEncoder, AudioDecoderRenderer, AudioDecoder, AudioCapturerEncoder
  • CodecType : CodecDevice
  • CodedTimeStamp() : CodedTimeStamp
  • ColCountProp : GuiObjectFactory
  • colid : ColumnInfo
  • CollectPackets() : UdpTestSocket, TcpTestSocket
  • Color() : Color
  • color : Led::Frame
  • ColorFormatType : CamWin32
  • ColorParseType : CTResourcePack
  • ColorProp : GuiObjectFactory
  • ColorSpace : Image::MetaData
  • ColorStream() : Led
  • ColorType : GuiObjectFactory
  • Colp : AtResponse
  • COLP : InputParser
  • ColpStatusMsg() : ColpStatusMsg
  • COLR : InputParser
  • ColrStatusMsg() : ColrStatusMsg
  • ColumnCount() : PbSimProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider
  • ColumnCountProp : GuiObjectFactory
  • ColumnPropertiesProp : GuiObjectFactory
  • Command : MessageTypeIndicator
  • command_code : AudioMapiManager::MapiCommandType
  • CommandCannotBePerformed : ShortMessageFailureCause
  • CommandCheckLoad : AudioMapiManager
  • CommandCheckUnload : AudioMapiManager
  • CommandDeviceControl : AudioMapiManager
  • CommandEnd : AudioMapiManager
  • CommandGetContentsData : AudioMapiManager
  • CommandGetMode : AudioMapiManager
  • CommandGetPhraseList : AudioMapiManager
  • CommandInitialize : AudioMapiManager
  • CommandInvalid : AudioMapiManager
  • CommandMelodyClose : AudioMapiManager
  • CommandMelodyControl : AudioMapiManager
  • CommandMelodyLoad : AudioMapiManager
  • CommandMelodyOpen : AudioMapiManager
  • CommandMelodyOpenArgInit : AudioMapiManager
  • CommandMelodySeek : AudioMapiManager
  • CommandMelodyStandby : AudioMapiManager
  • CommandMelodyStart : AudioMapiManager
  • CommandMelodyStop : AudioMapiManager
  • CommandMelodyUnload : AudioMapiManager
  • CommandMelodyWaitReady : AudioMapiManager
  • CommandPhraseAudioClose : AudioMapiManager
  • CommandPhraseAudioControl : AudioMapiManager
  • CommandPhraseAudioLoad : AudioMapiManager
  • CommandPhraseAudioOpen : AudioMapiManager
  • CommandPhraseAudioStandby : AudioMapiManager
  • CommandPhraseAudioStart : AudioMapiManager
  • CommandPhraseAudioStop : AudioMapiManager
  • CommandPhraseAudioUnload : AudioMapiManager
  • CommandPhraseGetLength : AudioMapiManager
  • CommandPhraseGetLink : AudioMapiManager
  • CommandPhraseGetPosition : AudioMapiManager
  • CommandPhraseGetStatus : AudioMapiManager
  • CommandPhraseKill : AudioMapiManager
  • CommandPhrasePause : AudioMapiManager
  • CommandPhrasePlay : AudioMapiManager
  • CommandPhraseRemoveData : AudioMapiManager
  • CommandPhraseRestart : AudioMapiManager
  • CommandPhraseSeek : AudioMapiManager
  • CommandPhraseSetData : AudioMapiManager
  • CommandPhraseSetEvHandler : AudioMapiManager
  • CommandPhraseSetLink : AudioMapiManager
  • CommandPhraseSetPanpot : AudioMapiManager
  • CommandPhraseSetVolume : AudioMapiManager
  • CommandPhraseStop : AudioMapiManager
  • CommandRealtimeMidiClose : AudioMapiManager
  • CommandRealtimeMidiGetChVolume : AudioMapiManager
  • CommandRealtimeMidiOpen : AudioMapiManager
  • CommandRealtimeMidiSendCh : AudioMapiManager
  • CommandRealtimeMidiSendSysExMessage : AudioMapiManager
  • CommandRealtimeMidiSetApiVolume : AudioMapiManager
  • CommandRealtimeStartTimer : AudioMapiManager
  • CommandRealtimeStopTimer : AudioMapiManager
  • CommandReason : AudioPlayerEvent
  • CommandResetMode : AudioMapiManager
  • CommandSetMode : AudioMapiManager
  • CommandTerminate : AudioMapiManager
  • CommandType() : CommandType
  • CommandUnsupported : ShortMessageFailureCause
  • Commit : ObexBuffer::Writer, ObexBuffer::Reader, RegEncoderDecoder, PbRecordProvider, Provider
  • CommitBuffer() : ObexObject
  • CommitPbInformation() : AtcHandler
  • CommitRow() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, DataConnProvider, CalendarProvider, BtHfProvider, PbRecordProvider, Provider, DistinctProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, StatusProvider, SmsProvider, SmsParamProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, CphsServPflProvider, CphsAuxProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • CommitTransaction() : Registry, DBService
  • CommonPropCount : DataConnApp
  • CommonPropertyId : DataConnApp
  • CommonSignalProcessor : ShutDown
  • CommonStackMsgArgsDestroyTableNode : SsUus1QueryReqArg, SsUus1ReqArg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, SsUus1IndArg, SsUus1QueryRejArg, SsUus1QueryIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityRejArg, SsFacilityIndArg, SsBeginAccArg, SmsGetMoreMessageStatusReqArg, SmsSetMoreMessageReqArg, SmsSendReqArg, SmsConfigIndArg, SmsGetMoreMessageStatusIndArg, SmsCapacityAvailableArg, SmsCapacityExceededArg, SmsSendRejArg, SmsSendCnfArg, SmsNewStatusReportIndArg, SmsNewMessageIndArg, SimTkRefreshNewRspArg, SimTkStopSendDtmfReqArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, BrowserTermEventArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, BrowserRegisterReqArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, ExtProactiveCmdIndArg, LanguageSettingIndArg, LanguageSelectEventArg, IdleScreenAvailEventArg, UserActivityEventArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, MenuSelectionReqArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkRefreshNewReqArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, SimTkInterfaceIndArg, SimTkSendDtmfEndIndArg, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimBrowserTermResArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, TermRspCnfArg, ExtProactiveCmdCnfArg, ExtProactiveCmdReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, EndSimToolkitIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, MenuSelectionRejArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg, SimTkSsIndArg, SimTkSmsPpIndArg, SimTkCallSetupIndArg, SimModifyLockReqArg, BdnReqArg, FdnReqArg, SimMruPropertyUpdReqArg, SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadReqArg, SimODynReadReqArg, SimCmiReadReqArg, UsimFilePropertyReqArg, UsimLangUpdReqArg, UsimEstReadReqArg, UsimSmsParamUpdReqArg, UsimCardTypeReadReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimLangReadReqArg, UsimPsLociReadReqArg, UsimCsLociReadReqArg, UsimPlmnReadReqArg, UsimUstReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCfufUpdReqArg, CphsVmwfUpdReqArg, CphsOnsReadReqArg, CphsOnmReadReqArg, CphsCfufReadReqArg, CphsVmwfReadReqArg, CphsIstReadReqArg, SimFileInfoReqArg, SimSpnReadReqArg, SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg, SimGenericReqArg, SimPuctUpdReqArg, SimPuctReadReqArg, SimAcmMaxUpdReqArg, SimAcmMaxReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSstReadReqArg, SimRefreshReqArg, SimModifyLockIndArg, BdnIndArg, FdnIndArg, SimFullAccessIndArg, SimLockStatusIndArg, SimInfoIndArg, SimInitIndArg, SimMruPropertyRefreshIndArg, SimMruPropertyUpdCnfArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimUpdCnfArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimMccMncIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimGenericIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, SimRefreshIndArg, SimErrorIndArg, ControlHwDataOnlyArg, StopSignalStrengthListeningArg, StartSignalStrengthListeningArg, StopBatteryLoadListeningArg, ClientDeregistrationArg, ClientRegistrationArg, PowerDownReqArg, OmPowerUpArg, PowerDownIndArg, OmControlIndArg, PowerDownCnfArg, PlmnListReqArg, GprsClassReqArg, PlmnInfoReqArg, DetachReqArg, AttachReqArg, PrefServiceSetReqArg, PrefPlmnChangeArg, PlmnListAbortArg, GprsClassIndArg, AttachAllowedIndArg, DetachCnfArg, AttachRejArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListRejArg, PlmnListCnfArg, UsimPbReadCnfArg, UsimPbStopReqArg, UsimPbFillStatusReqArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, UsimPbSelectReqArg, UsimPbLocationReqArg, PbCountReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, PbInfoReadReqArg, UsimPbReadyIndArg, UsimPbUidRefreshIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg, UsimPbLocationIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, PbInfoReadIndArg, OmRatChangeReqArg, OmBandStatusReqArg, OmMultiSlotReqArg, OmRatChangeIndArg, OmRatChangeCnfArg, OmBandStatusCnfArg, OmMultiSlotIndArg, MnNetworkSearchModeReqArg, MnTriggerReqArg, HomezoneIndArg, BandSelectionIndArg, TestparamReportArg, MnInformationIndArg, CellInfoIndArg, ConnectionIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, ClearBlacklistReqArg, RediallingDisabledIndArg, RedialRejArg, MocSetupReqArg, ClearBlackListCnfArg, AutoCallRestrictIndArg, RedialStopIndArg, RedialSetupIndArg, RedialIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, MocSetupRejArg, EngineeringModeControlRequestArg, OmSetTermProfileReqArg, OmGetTermProfileReqArg, OmFactoryResetIndArg, BandSelectionReqArg, TestparamReqArg, ImeiReadReqArg, BootDispatchingArg, EccListIndArg, CfuDataIndArg, EngineeringModeControlResponseArg, OmSetTermProfileRejArg, OmSetTermProfileCnfArg, OmGetTermProfileCnfArg, AccessoryIndArg, ImeiReadIndArg, SignalStrengthLevelIndArg, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsConcRefNumReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsSetWaitingReqArg, MdhRemoveViewReqArg, MdhMakeViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSetStorageReqArg, MdhSmsUpdStatusReqArg, MdhSmsStatusReqArg, MdhRegistrationReqArg, MdhDeregistrationReqArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsConcRefNumIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg, MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsStorageRefreshIndArg, MdhSmsRefreshIndArg, MdhNewStatusReportIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg, IconDescReadReqArg, ImageReadReqArg, IconDescReadIndArg, ImageReadIndArg, ChargeUnitsReqArg, SetChargeUnitsArg, ChargeReqArg, SetAutoChargeArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, CallDeflectSsReqArg, CallDeflectionIndArg, CbsStopReqArg, CbsStartReqArg, CbsNewDataRejArg, CbsLimitIndArg, CbsStopCnfArg, CbsStartCnfArg, CbsStopRejArg, CbsStartRejArg, CbsNewDataIndArg, RedialQueryReqArg, RejectCallsIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, MocSetupRejIndArg, CallIndCallControlInfoArg, RedialStatusIndArg, CallSetupBySimtTkReqArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, DtmfBufferClearedIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg, AtAccessoryRegisterCnfArg, AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtPbInfoIndArg, AtPbListCnfArg, AtPbSelectCnfArg, AtAlphaTagCnfArg, AtAccessoryRegisterReqArg, AtGenericCmdReqArg, AtPbListReqArg, AtPbSelectReqArg, AtAlphaTagReqArg
  • CompactWrap : EditorDocument
  • CompanionLocation : VideoCamera, CodecDevice
  • Compare() : WString, Time, String, PhoneNumber, DateTime, Date, ArgumentDestroyEntryCompare
  • CompareTo() : WString, String
  • ComparisonType : StandardJoinRule
  • CompatibleWithEverything : AudioAccessoryDetails
  • Complete : VrHandler
  • CompleteEvent() : ObexAbstractPort::CompleteEvent
  • Complies() : NamePatternStorageDeviceFilter, StorageDeviceFilter, SoundFileFilter, ImageFileFilter, NamePatternFileFilter, FileFilter
  • Component() : Component
  • ComponentBackgroundColor : CTResourcePack
  • ComponentClassType : GuiObjectFactory
  • ComponentForegroundColor : CTResourcePack
  • ComponentIterator() : Control::ComponentIterator
  • ComponentsProp : GuiObjectFactory
  • Compose : ThaiTextRenderer
  • ComposeSms() : BasicSmsService, AbstractSmsApp
  • ComposeSmsType : AbstractSmsApp
  • CompoundItem() : CompoundItem
  • CompoundItemIterator : CompoundItemIterator, MultiMediaEditorDocument
  • CompoundItemReferrer() : CompoundItemReferrer
  • CompoundSmsItem : CompoundSmsItem, SimPduHandler
  • CompoundTpduItem : CompoundTpduItem, SimPduHandler
  • CompressBlock() : SwitchedRleCompression
  • compressed : BitmapRes
  • compressed_size : FileInfo_s
  • Compression() : EnumTranslationTable
  • compression_method : FileInReadStatusInfo, BinDataInReadStatusInfo, FileInfo_s
  • CompressionControl : InformationElement
  • CompressionProperty : CamWin32
  • ConcatenatedSm16Bit : InformationElement
  • ConcatenatedSm8Bit : InformationElement
  • ConcaveFilter : Camera
  • Condition() : Condition
  • ConditionalIeError : PdpContext
  • ConfigureAAC() : AtiAudioCapturerEncoder, AudioCapturerEncoder
  • ConfigureAMR() : AtiAudioCapturerEncoder, AudioCapturerEncoder
  • ConfigureMultiShot() : StillCamera
  • Confirm() : ObexOppDataSinkPushServer, SmsSocketListener
  • ConfirmAction() : ConfirmAction
  • ConfirmDtmfSending() : SimTkHandler
  • ConfirmId : DialogWindow
  • ConfirmKeyInput() : Keyboard
  • ConfirmPbAlphaTagRequest() : SimHandler, AtcHandler
  • ConfirmPbEntryRequest() : AtcHandler
  • ConfirmPbSizeRequest() : AtcHandler
  • Congestion : Sms, ShortMessageStatus
  • Connect : TcpSocket, SysSocket, PsdDataConn, ObexLayer, ObexClient, SocketPeer, IrdaObexImpl, MmiSimClient, BtObexImpl, PdpContext, ExtPsdContextListener_SerialTerminal, StreamObexImpl, SioSocketAdapter, SerialIoAdapter, SerialClientSocket, SerialTerminal, AtResponse
  • CONNECT_FAIL : SerialIoSet
  • CONNECT_REQ : SerialIoSet
  • CONNECT_SUCCESS : SerialIoSet
  • ConnectClient() : HttpServer, FtpServer
  • Connected : PdpContext
  • ConnectedAccessoriesType : AudioAccessoryDetails
  • ConnectedAndBatteryFull : Charger
  • ConnectedAndCharging : Charger
  • ConnectedAndTemperatureProtection : Charger
  • ConnectedWord : VrHandler
  • ConnectFlags : ObexObject
  • ConnectionClose : RegEncoderDecoder
  • ConnectionElement : DataCallContext
  • ConnectionId : ObexHeader
  • ConnectionIndArg() : ConnectionIndArg
  • ConnectionRejectedBySme : ShortMessageStatus
  • ConnectionResponse : RegEncoderDecoder
  • ConnectionStatusMsg() : ConnectionStatusMsg
  • ConnectPending : PdpContextManager
  • ConnectReq() : BtBipClientService
  • ConnectRequest() : BtObexClientService, BtHsService, BtHfService, BtSingleConnectionController, BtAudioAccessoryService, BtAvrcpOperationService
  • ConnectResponse() : SubUnitReference, BtBppServerService, BtAvrcpOperationService
  • ConnectRsp() : BtBipServerService
  • ConnectToPC() : RegAppWin
  • ConnectToUrl() : AbstractSmsApp
  • ConnectTwoCallsAndDisconnectSubscriber : CallSsAction
  • ConnMultipleIrlmpLsapSel : ObexObject
  • ConnType : IrdaTransport
  • Cons : ThaiTextRenderer
  • ConstBufferType : StreamAudioReference
  • ConstDataPtr : ObexBuffer
  • ConstIterator : ObexHeaderList::ConstIterator, Vector< T >
  • ConstReference : Vector< T >
  • ConstReverseIterator : Vector< T >
  • Construct() : ObexBuffer::Factory, Allocator< T >
  • container_content_table_entry : MenuPool::FeatureItemContainerTableEntry
  • container_id : MenuPool::FeatureItemContainerTableEntry
  • container_table_entry : MenuPool::FeatureItemContainerContentTableEntry, MenuPool::MenuTableEntry
  • ContainerType : ContextFeature
  • Contains() : ObexTransportSet, ObexHeaderList, GlassPane, MemPoolEntry, LinkedListBase
  • ContainsAction() : ActionMenuAccessor
  • ContainsControl() : Control
  • ContainsDataPack() : BasicPackConnector
  • ContainsDispatcher() : ExecutionContext
  • ContainsDrawableObject() : Control
  • ContainsFeature() : FeatureItemContainer
  • ContainsFont() : FontPackConnector
  • ContainsItem() : AbstractItemContainer
  • ContainsLanguage() : TextPackConnector
  • ContainsProperty() : SubstitutedText
  • ContainsUserInputMsg() : AppContainer
  • ContainsWindow() : Application
  • Context() : SwitchedRleCompression::Context
  • context_id : MenuPool::FeatureItemContainerTableEntry, MenuPool::FeatureItemContainerContentTableEntry, ContextTableEntry
  • ContextActions : UibInboxTest
  • ContextDependantTitle : MenuProperties
  • ContextDescription() : ContextDescription
  • ContextExecuteMsg() : ContextExecuteMsg
  • ContextFeature() : ContextFeature
  • ContextFeatureHandle() : ContextFeatureHandle
  • ContextFeatureItem() : ContextFeatureItem
  • ContextFeatureItemClassType : GuiObjectFactory
  • ContextFeatureTriggerMsg() : ContextFeatureTriggerMsg
  • ContextId : HeapVector
  • ContextItemProp : GuiObjectFactory
  • ContextManager : AtlConfig
  • ContextMenu() : ContextMenu
  • ContextMenuBackground : Color
  • ContextMenuBackgroundColor : CTResourcePack
  • ContextMenuClassType : GuiObjectFactory
  • ContextMenuClosedMsg() : ContextMenuClosedMsg
  • ContextMsg() : ContextMsg
  • ContextPropertyId : FeatureItemContainer, FeatureItem
  • ContextTable : ContextTableNode
  • ContextTableNode : ContextTableNode, ContextTable
  • ContextType : ContextFeature
  • ContextWakeupMsg() : ContextWakeupMsg
  • Continue : BtObexResponseCode
  • ContinuedExtendedObject : InformationElement
  • ContinueSocketTestMsg() : ContinueSocketTestMsg
  • ContrastChanged : Camera
  • ContrastProperty : CamWin32
  • Control : Control, VirtualDisplay, RealTimeClock, VirtualDisplay, Keyboard, Fota, Charger, VirtualDisplay, AbstractDevice, ThaiTextRenderer, DrawableObject
  • Control::AbsInvalidate : Application
  • Control::PutToForeground : Application
  • ControlArg() : AbstractDevice::ControlArg
  • ControlClassType : GuiObjectFactory
  • ControlDc() : ControlDc
  • ControlFrameControl : CTResourcePack
  • ControlFrameView() : ControlFrameView
  • ControlHwDataOnlyArg() : ControlHwDataOnlyArg
  • ControllerConnectRequest() : BtAvrcpControllerApplicationWindow
  • ControllerDisconnectRequest() : BtAvrcpControllerApplicationWindow
  • ControllerSelectDeviceRequest() : BtAvrcpControllerApplicationWindow
  • ControllerSetActiveDeviceRequest() : BtAvrcpControllerApplicationWindow
  • ControllerSetInactiveDeviceRequest() : BtAvrcpControllerApplicationWindow
  • ControllerSubUnitInfoRequest() : BtAvrcpControllerApplicationWindow
  • ControlMsg() : ControlMsg
  • Controls : Control::ComponentIterator
  • Convert() : JapaneseTranscoder, GpsFixDataInt
  • Convert2AudioReturnCode() : GenericAudioDevice
  • Convert2Buffer() : SimAlphaIdentifier
  • Convert2Pdu() : Tpdu
  • Convert2SdlAlpha() : SimAlphaIdentifier
  • Convert2SdlFilter() : Cbs::Filter
  • Convert2SdlText() : SimTextString
  • Convert2UserData() : SimTextString
  • ConvertBidiLine() : ParagraphCompoundItem
  • ConvertBtApoxiOperationToMmiCommand() : BtAvrcpPanelApplication
  • ConvertDataItemToObjectData() : ObjectDataConverter
  • ConvertFfsErrorToFileError() : FlashStorageDeviceImp
  • ConvertFromHtml() : HttpSocket
  • ConvertKeyTone2INT() : KeyToneAudioDevice
  • ConvertMmiResponseToApoxiResponse() : BtAvrcpPanelApplication
  • ConvertObjectDataToDataItem() : ObjectDataConverter
  • ConvertPriority2INT() : GenericAudioDevice
  • ConvertRamErrorToFileError() : RamFileImp
  • ConvertToBcd() : LcsWString
  • ConvertToBitmap() : Image
  • ConvertToColorValue() : VirtualDisplay
  • ConvertTone2INT() : ToneAudioDevice
  • ConvertToStr() : ClientId
  • coord_param : TestparamReport
  • CoordParam : TestparamReport
  • Copy() : ImageRefGenContainer, BtDeviceAddressGenericObject, BtSddbDeContainer, RegBlobObject, GenericObject, BlobPtr, BlobObject, TimeFeatureObject, GenericFeatureData, ImgObtObj, MenuIdObj, ItemObj, MenuDescObj, File, FlsFile, FfsHandler, RootFileImp, CompoundTpduItem, CompoundSmsItem
  • CopyAll() : CopyHandler
  • CopyCbsUnicodeBufferAndAdjustBytes() : DataCoding
  • CopyContentsTo() : File
  • CopyData() : FilePackConnector, Tpdu, Cbs
  • CopyFrom() : ObexBuffer::Writer
  • CopyHandler() : CopyHandler
  • CopyItem() : DBService
  • CopyPbRow() : PbCopyHandler
  • copyright : RingerAudioDevice::RingerToneInfo
  • copyrighted : BitmapRes
  • CopyRow() : CopyHandler
  • CopyTo() : ObexBuffer::Reader, InformationElement, SmsProvider, SimPduHandler
  • CopyToPb() : PhonebookApp
  • Corner : ContextMenu, MenuProperties
  • CornerModeParseType : CTResourcePack
  • CornerModeType : CTResourcePack
  • CornerProp : GuiObjectFactory
  • CornerType : GuiObjectFactory
  • corporate : SimLockStates
  • CorruptMp3File : MediaManager
  • Corsican : LanguageManager
  • CouldNotAllocateThreadletError : ImageEncoder, Image
  • Count : ObexHeader
  • count : BidiManager::ParagraphContext, MdhSetWaitIndicator, MdhWaitIndicator
  • CountryProvider() : CountryProvider
  • CountSettings() : SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor
  • cphs_infono_size : PhoneBookInfo
  • cphs_infono_tagsize : PhoneBookInfo
  • cphs_mbox_size : PhoneBookInfo
  • cphs_mbox_tagsize : PhoneBookInfo
  • CphsAuxProvider() : CphsAuxProvider
  • CphsCfufReadIndArg() : CphsCfufReadIndArg
  • CphsCfufReadReqArg() : CphsCfufReadReqArg
  • CphsCfufUpdIndArg() : CphsCfufUpdIndArg
  • CphsCfufUpdReqArg() : CphsCfufUpdReqArg
  • CphsCspReadIndArg() : CphsCspReadIndArg
  • CphsCspReadReqArg() : CphsCspReadReqArg
  • CphsCspUpdIndArg() : CphsCspUpdIndArg
  • CphsCspUpdReqArg() : CphsCspUpdReqArg
  • CphsIstReadIndArg() : CphsIstReadIndArg
  • CphsIstReadReqArg() : CphsIstReadReqArg
  • CphsOnmReadIndArg() : CphsOnmReadIndArg
  • CphsOnmReadReqArg() : CphsOnmReadReqArg
  • CphsOnsReadIndArg() : CphsOnsReadIndArg
  • CphsOnsReadReqArg() : CphsOnsReadReqArg
  • CphsServGroupCode : SimCphsHandler
  • CphsServPflProvider() : CphsServPflProvider
  • CphsVmwfReadIndArg() : CphsVmwfReadIndArg
  • CphsVmwfReadReqArg() : CphsVmwfReadReqArg
  • CphsVmwfUpdIndArg() : CphsVmwfUpdIndArg
  • CphsVmwfUpdReqArg() : CphsVmwfUpdReqArg
  • cpich_ecn0 : UmtsNcellParam, UmtsRrcScellParam
  • cpich_rscp : UmtsNcellParam, UmtsRrcScellParam
  • cpich_sc : UmtsNcellParam
  • CpNetworkFailure : Sms
  • Cr : AtResponse
  • cr_cnt : CellChangeCnts
  • cr_cnt_at : CellChangeCnts
  • cr_hyst : GprsParam
  • cr_success : MmCellChangeCnts
  • crc : FileInfo_s
  • crc32 : FileInReadStatusInfo, BinDataInReadStatusInfo
  • crc32_wait : FileInReadStatusInfo, BinDataInReadStatusInfo
  • Create() : GuiObjectFactory, ObexOperationId, SimpleSemaphore, Semaphore, SimpleMutex, SimpleSemaphore, Semaphore, Mutex, AppMutex, FfsFile, BtObexServerAddr, BtObexClientAddr, BtObexClientAddrResultNotifier, StreamAudioReference, CustomToneAudioReference, CustomSmafPhraseAudioReference, CustomRingerAudioReference, AudioActiveReference, File, FlsFile, FfsHandler, MapiAudioReference, StreamObexImpl, SioSocketAdapter, DrmRightsObjectFile, RootFileImp, RamHandler, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile
  • CreateAccHandler() : HandlerFactory
  • CreateAocHandler() : HandlerFactory
  • CreateAppContext() : SimpleScheduler, Scheduler, AbstractScheduler
  • CreateAtcHandler() : HandlerFactory
  • CreateAudioReferenceFromBinData() : MmfPlayer, AudioDeviceManager
  • CreateAudioReferenceFromExtensionSoundDataSource() : AudioDeviceManager, MapiAudioPlayer
  • CreateAudioReferenceFromFFS() : AudioDeviceManager
  • CreateAudioReferenceFromPreset() : AudioDeviceManager
  • CreateAudioReferenceFromRamBuffer() : MP3AudioPlayer, MmfPlayer, AudioDeviceManager
  • CreateAudioReferenceFromRFS() : AudioDeviceManager
  • CreateAudioReferenceFromRfsFile() : MP3AudioPlayer, MmfPlayer
  • CreateAudioReferenceFromStream() : MP3AudioPlayer, AudioDeviceManager
  • CreateBackupFile() : BackupFileHandler
  • CreateBootHandler() : HandlerFactory
  • CreateBuffer() : StreamObexImpl
  • CreateBufferPool() : BufferPoolManager
  • CreateCallBarringHandler() : HandlerFactory
  • CreateCallControlHandler() : HandlerFactory
  • CreateCallDeflectionHandler() : HandlerFactory
  • CreateCallForwardingHandler() : HandlerFactory
  • CreateCallHandler() : HandlerFactory
  • CreateCallWaitingHandler() : HandlerFactory
  • CreateCbsHandler() : HandlerFactory
  • CreateClipHandler() : HandlerFactory
  • CreateClirHandler() : HandlerFactory
  • CreateCnapHandler() : HandlerFactory
  • CreateColpHandler() : HandlerFactory
  • CreateColrHandler() : HandlerFactory
  • CreateContainer() : DrmAsset
  • CreateContext() : PdpContextManager
  • CreateCrssHandler() : HandlerFactory
  • CreateCtResourcePack() : GuiObjectFactory
  • CreateDataConn() : DataConnProfile
  • CreateDataConnProfile() : PersistDataConnProfile
  • CreateDir() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • CreateDirectoryIterator() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp
  • CreateEditor() : AtlConfig
  • CreateEmlppHandler() : HandlerFactory
  • CreateFFS() : StreamAudioReference
  • CreateFile() : StreamAudioReference
  • CreateFileObject() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp
  • CreateGlassPane() : Desktop
  • CreateHandler : HandlerData
  • CreateHexCodes() : DbgDump
  • CreateImage() : ImageFactory
  • CreateImageHdl() : BtBipImageHdl
  • CreateImageObject() : ImageRef
  • CreateInstance() : FfsTestThreadlet, TimeCompoundItem, TextCompoundItem, IpAddrCompoundItem, Desktop, DecodingThreadlet, DateCompoundItem, MmiSimServer, AudioGatiServer, RomData, RamData, DataSourceBinData, ChildBinData, BufferedData, InputMapperFactory, MainDesktop, FileBinData, RichTextCompoundItem, PngEncodingThreadlet, ParagraphMarker, ParagraphCompoundItem, JpegEncodingThreadlet, GeneralCompoundItem
  • CreateInterior : RegEncoderDecoder
  • CreateInteriorNode() : Registry
  • CreateInteriorNodeEntry() : NodeFileHandler
  • CreateInterrogateResultMsg() : ColrHandler, ColpHandler, CnapHandler, ClirHandler, ClipHandler
  • CreateLockTable() : LockTableList
  • CreateMediaPlayer() : MediaManager
  • CreateMediaRecorder() : MediaManager
  • CreateMediaRef() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer
  • CreateMessages() : EmsCreator
  • CreateMocVoiceHandler() : HandlerFactory
  • CreateModel() : EmsEditor, PbProvColListBox, PbDetailListBox, TimeEditor, PasswordEditor, MultiLineEditor, LineEditor, IpAddrEditor, DateEditor, Component, TimeEditBox, TextList, RadioButtonList, ProviderListBox, MenuList, Grid, EditBox, DateEditBox, CheckBoxList, CheckBox, Animation, MultiMediaEditor
  • CreateMoUssdHandler() : HandlerFactory
  • CreateMtcVoiceHandler() : HandlerFactory
  • CreateMultiSlotHandler() : HandlerFactory
  • CreateNetworkHandler() : HandlerFactory
  • CreatePanel() : Application
  • CreatePdpContext() : PsdDataConn
  • CreatePlayerInstance() : MediaBox
  • CreatePlmnHandler() : HandlerFactory
  • CreatePowerHandler() : HandlerFactory
  • CreateRam() : StreamAudioReference
  • CreateReference() : AudioPresetStore
  • CreateSection() : Desktop, MainDesktop
  • CreateSigHandler() : HandlerFactory
  • CreateSimHandler() : HandlerFactory
  • CreateSimTkHandler() : HandlerFactory
  • CreateSmsHandler() : HandlerFactory
  • CreateSsCcbsHandler() : HandlerFactory
  • CreateSsMainHandler() : HandlerFactory
  • CreateStream() : StreamAudioReference
  • CreateStreaming() : File, FlsFile, RootFileImp, RamFileImp, FlashFileImp, FatFileImp, FatFile
  • CreateTempFile() : RootFileSystem
  • CreateTemplate() : VrHandler
  • CreateUssdHandler() : HandlerFactory
  • CreateVoiceRecognition() : StreamAudioReference
  • CreateWapProfile() : WapProfileMgr
  • CreationDate : File::Attributes
  • CreationTime : File::Attributes
  • CreatorId : ObexHeader
  • Creg : AtResponse
  • Cring : AtResponse
  • CriticalErrorMsg : MediaManager
  • Croatian : LanguageManager
  • CrssHandler() : CrssHandler
  • CrssNotValid : XCallInfoResponseParser
  • CrssState : XCallInfoResponseParser
  • CrssTransaction : XCallInfoResponseParser
  • cs_param : TestparamReport
  • CsdDataConn() : CsdDataConn
  • CsdDataConnAccessor() : CsdDataConnAccessor
  • CsdDataConnProfile : CsdDataConnProfile, PersistDataConnProfile
  • CsdDataConnProvider() : CsdDataConnProvider
  • CsdPropCount : DataConnApp
  • CsdPropertyId : DataConnApp
  • CsParam : TestparamReport
  • Cssi : AtResponse
  • Cssu : AtResponse
  • cstream() : XMLParser
  • CTControlFrameView() : CTControlFrameView
  • CtmCall : XCallInfoResponseParser
  • CtmInfoIndArg() : CtmInfoIndArg
  • CtmInfoIndMsg() : CtmInfoIndMsg
  • CtmNotValid : XCallInfoResponseParser
  • CtmStatus : XCallInfoResponseParser
  • CTPanelView() : CTPanelView
  • CTPositionIndicatorView() : CTPositionIndicatorView
  • CTProgressBarView() : CTProgressBarView
  • CTPushButtonView() : CTPushButtonView
  • CTResourcePack() : CTResourcePack
  • CtResourcePackClassType : GuiObjectFactory
  • CTResourceParser : CTResourcePack
  • Ctrl : ThaiTextRenderer
  • CTWindowFrameView() : CTWindowFrameView
  • Ctzv : AtResponse
  • cug_index : NotifySsArg
  • CugCallMsg() : CugCallMsg
  • cur_file_info : JarFileStatusInfo, JarBinDataStatusInfo
  • cur_file_info_internal : JarFileStatusInfo, JarBinDataStatusInfo
  • currency_symbol : Locale::LocaleData
  • current : Vector< T >::Iterator
  • current_file_ok : JarFileStatusInfo, JarBinDataStatusInfo
  • current_loc : T_PB_LOC_REPORT
  • CurrentAudioPath : BtHfAudioPathWindow
  • CurrentCallMeterMsg() : CurrentCallMeterMsg
  • CurrentChargeDataMsg() : CurrentChargeDataMsg
  • CurrentPosition() : StreamWriter, StreamReader
  • CurrentValue : CamWin32
  • Cusd : AtResponse
  • cust_file : tagFilePackData
  • Custom : OptionalConfigBase, InputMapper
  • CustomAnimation : ItemRendererProperties
  • CustomAttributeId : Feature
  • CustomCategory : AbstractDevice
  • CustomDisplayType : ItemRendererProperties
  • CustomFrameBuffer() : Display::CustomFrameBuffer
  • CustomizedDataAvailable() : CTResourcePack
  • CustomPropertyId : Item
  • CustomRingerAudioReference() : CustomRingerAudioReference
  • CustomSmafPhraseAudioReference() : CustomSmafPhraseAudioReference
  • CustomStyle : AbstractItemRenderer
  • CustomToneAudioReference() : CustomToneAudioReference
  • CutOff() : RegBlobObject, BlobObject
  • CutWrap : EditorDocument
  • Cuus1i : AtResponse
  • Cuus1u : AtResponse
  • Cycle : AnimatedTextLine, Animation
  • CycleAnimation : ItemRendererProperties
  • CycleHorizontalAnimation : ItemRendererProperties
  • CycleVerticalAnimation : ItemRendererProperties
  • Czech : LanguageManager, DataCodingScheme
Generated on Wed Jan 25 00:54:04 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • Daily : CalendarRecord
  • Danish : LanguageManager, DataCodingScheme
  • DarkBlue : InformationElement
  • DarkCyan : InformationElement
  • DarkerLightColor : CTResourcePack
  • DarkGreen : InformationElement
  • DarkGrey : InformationElement
  • DarkMagenta : InformationElement
  • DarkRed : InformationElement
  • DarkShadow : CTResourcePack
  • DarkYellow : InformationElement
  • Dashed : Pen
  • data : tagCustFileData, tagLdbData, tagCPGlyph, tagTranslationTable, BtObexServiceTable::ObexTarget, RomDataRes, SsDataReceivedArg, ChannelData_s, SiIpAddress_s, MsapPackedData_s, SiProvFileRef_s, SiBearerDesc_s, SiBearerList_s, TAlphaIdentifier_s, TSiUrl_s, SsGroupList, CallBarringFeatureList, ForwardingFeatureList, RegObjectData
  • Data : StartUp::Data, InternalTracer, XCallInfoResponseParser
  • data1 : Guid
  • data2 : Guid
  • data3 : Guid
  • data4 : Guid
  • data_coding_scheme : SiText_s, CallingName
  • data_elements : UmtsMeasIdParam
  • data_pack : tagCustomizationPack
  • data_pack_count : tagCustomizationPack
  • data_pack_data : tagDataPackHeader
  • data_pack_id : tagDataPackHeader
  • DATA_RECEIVED : SerialIoSet
  • DATA_SENT : SerialIoSet
  • data_table : tagGlyphData
  • DataAcceptable() : StreamWriter
  • DataAvailable : StreamReader, ExtPsdContextListener_SerialTerminal, SerialTerminal
  • DataBufferIndication() : BtObexServerService, BtObexClientService
  • DataCable : Accessory
  • DataCallContext() : DataCallContext
  • DataCallControl() : DataCallControl
  • DataCallSignalProcessor : DataCallHdl
  • DataCoding() : DataCoding
  • DataCodingMsgHandlingGroup : DataCodingScheme
  • DataCodingScheme() : DataCodingScheme
  • DataCodingSchemeExists() : ParameterIndicator
  • DataCodingSchemeRange() : DataCodingSchemeRange
  • DataCompression : PdpContext
  • DataConn : DataConn, SysSocket, SocketSubSystem, SocketData
  • DataConnAccessor() : DataConnAccessor
  • DataConnCtrlCb : DataConn
  • DataConnCtrlCbs : DataConn
  • DataConnDescription() : DataConnApp::DataConnDescription
  • DataConnInfoMsg() : DataConnInfoMsg
  • DataConnIsBlocked() : PsdDataConn, DataConn
  • DataConnLbModel() : DataConnLbModel
  • DataConnManager : SysSocket, DataConnProfile, DataConn
  • DataConnOptionWin() : DataConnOptionWin
  • DataConnProfile : DataConnProfile, PsdDataConn, PersistDataConnProfile, DataConn, CsdDataConn
  • DataConnProfileInfoMsg() : DataConnProfileInfoMsg
  • DataConnProfileManager : PersistDataConnProfile, DataConnProfileManager::ProfileInfo, DataConnProfile
  • DataConnProvider() : DataConnProvider
  • DataConnState : DataConn
  • DataConnTypeWin() : DataConnTypeWin
  • DataConnWin() : DataConnWin
  • DataControl() : DataControl
  • DataControlBootMsg() : DataControlBootMsg
  • DataControlBootProgressMsg() : DataControlBootProgressMsg
  • DataControlEndBootMsg() : DataControlEndBootMsg
  • DataControlModificationMsg() : DataControlModificationMsg
  • DataControlPhonebookStateMsg() : DataControlPhonebookStateMsg
  • DataControlStartBootMsg() : DataControlStartBootMsg
  • dataformat : RegObjectData
  • DataHandler() : DataHandler
  • DataIndication() : BtObexServerService
  • DataItem() : DataItem
  • DataMissing : SsErrorCode
  • DataNotValid : RealTimeClock
  • DataNumberingPlan : TypeOfAddress
  • DataPack() : DataPack
  • DataProcessed() : ObexServerOppImpl, ObexServer, ObexOppServer, ObexOppClient, ObexLayer, ObexClientOppImpl, ObexClient, IrdaObexImpl, BtObexImpl, StreamReader, StreamObexImpl
  • DataPtr : ObexBuffer
  • DataRate : CsdDataConnProfile
  • DataReadyIndication() : BtObexClientService
  • DataRecord() : DataRecord
  • DataRecordHandler : DataRecordHandler, DataRecord
  • DataSent : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • DataSink : DataSink, RecordSettings
  • DataSinkClosedError : ImageEncoder
  • datasize : RegObjectData
  • DataSource() : SimTextString, DataSource
  • DataSourceBinData() : DataSourceBinData
  • DataSourceRtStreamingSource() : DataSourceRtStreamingSource
  • DataTrace : InternalTracer
  • datatype : RegObjectData
  • DataUnits : PdpContext
  • date : CalendarRecord::Persist, DateStr, FfsTimeRecord, ffs_time_record_type, datestr
  • Date : Date, InputMapper
  • DateChanged : RealTimeClock
  • DateCompoundItem() : DateCompoundItem
  • DateEditBox() : DateEditBox
  • DateEditBoxView() : DateEditBoxView
  • DateEditor() : DateEditor
  • DateEditorClassType : GuiObjectFactory
  • DateEditorDocument() : DateEditorDocument
  • DateEditorView() : DateEditorView
  • DateFromDriverDate() : FatFileImp
  • DateProp : GuiObjectFactory
  • dates : Locale::LocaleData
  • DateTime() : DateTime
  • DateTimeInputMapper() : DateTimeInputMapper
  • DateType : GuiObjectFactory
  • datum : MenuPool::FeatureItemContainerContentTableEntry
  • day : RealTimeClock::DateAndTime
  • Day : Date, PackedTimePeriod
  • day_name : Date
  • DayName() : Date
  • DayOfWeek() : Date
  • DayOfYear() : Date
  • days_in_month : Date
  • DaysInMonth() : Date
  • DaysInYear() : Date
  • DbgOut() : Os, HeapVector::VarPage, HeapVector::BlockPage, HeapManager, CfuServiceArray, SimImage, SimIconDescription, SimImageDescriptor, Cbs::Filter
  • DbgOutContext() : HeapVector::VarPage, HeapVector::BlockPage
  • DbgOutContextFunction : HeapVector
  • DbgOutContextUsage() : HeapManager
  • DbgOutFunction : HeapVector
  • DbgOutStackUsage() : Os
  • DbgTimingMeasurement() : DbgTimingMeasurement
  • DBItemChangedMsg() : DBItemChangedMsg
  • DBService() : DBService
  • dcs : UssDataArg
  • dcs_lang_code : LanguageCodeTableEntry
  • DcsGroupId() : EnumTranslationTable
  • DcsLanguageFilterRule() : DcsLanguageFilterRule
  • Deactivate() : StackMsgDispatcher, PdpContext, CallWaitingHandler, CallForwardingHandler, CallBarringHandler
  • DeactivateBdn() : SimHandler, SimAccessor, DataHandler
  • DeactivateCallBarring() : SsHandler
  • DeactivateCallForwarding() : SsHandler
  • DeactivateCallWaiting() : SsHandler
  • DeactivateContext() : PsdDataConn
  • DeactivateFdn() : SimHandler, SimAccessor, DataHandler
  • DeactivatePending : PdpContextManager
  • Deactivation : InputParser
  • DeAllocateDwd() : DwdDevice
  • DeAllocateDwdID() : DwdDevice
  • DebugOutputStream() : DebugOutputStream
  • December : Date
  • decimal_separator : Locale::LocaleData
  • Decode() : RegEncoderDecoder
  • DecodeAlphaField() : AlphaCoding
  • DecodeAltitude() : LcsUtils
  • DecodeAngle() : LcsUtils
  • DecodeBase64() : MimeCoding
  • DecodeBase64Data() : DrmUtils
  • DecodeBuffer() : EmzMp3Decoder, EmzAacDecoder, EmzMp3Decoder, EmzAacDecoder, AudioDecoder
  • DecodeBufferFct : AudioDecoder
  • DecodeChar() : QuotedPrintableCoder
  • DecodeEnd() : Base64Coder, QuotedPrintableCoder
  • DecodeFrame() : ScicosMpeg4VideoDecoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Decoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoDecoder, AudioDecoder
  • DecodeFrameFct : AudioDecoder
  • DecodeInnerRadius() : LcsUtils
  • DecodeLatitude() : LcsUtils
  • DecodeLocEstimate() : LcsUtils
  • DecodeLongitude() : LcsUtils
  • DecodeMessage() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • DecodeNextScanline() : PngImage, PngDecoder
  • DecodePacket() : ScicosMpeg4VideoDecoder, EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Decoder, EmzMpeg4Decoder, EmzH264Decoder, VideoDecoder
  • DecodePush() : Base64Coder, QuotedPrintableCoder
  • DecodePush6Bits() : Base64Coder
  • DecodeQuotedPrintable() : MimeCoding
  • DecodeRenderBuffer() : AtiAudioDecoderRenderer, AudioDecoderRenderer
  • DecoderInitError : PngDecoder
  • DecodeSynchronously() : NativeImage, Image, SvgImage
  • DecodeUncertAltitude() : LcsUtils
  • DecodeUncertRadius() : LcsUtils
  • DecodingDirection : CodecDevice
  • DecodingError : PngDecoder
  • DecodingFunctionType : AudioDecoder
  • DecodingInterruptedError : Image, SvgPlayer
  • DecompressBlock() : SwitchedRleCompression
  • Decrease : Camera
  • DecreasePriority() : Thread
  • DecRefCount() : WStrData, StrData, ProviderPtr
  • DecrementCell() : GridModel
  • DecrementDelBufCount() : RegDeletionBufferEntry
  • DecrementOpenFileCounter() : StorageDevice
  • DecrementRegCount() : ApplicationListEntry
  • DecryptBuffer() : AesCrypt
  • def : Camera::ParameterLimits
  • Default : AlarmManager, TextFormat, GridLayout, MoCallAction, InformationElement
  • default_irda_switch_off_timeout : IrdaTransport
  • default_priority : SsData, CliRestrictionInfo
  • DefaultAction() : ObexAbstractPort
  • DefaultAlign : EditorDocument
  • DefaultAlphabet : DataCodingScheme
  • DefaultAmplitude : CustomToneAudioReference
  • DefaultAppendRow() : PbBaseProvider
  • DefaultAudioPath : BtHfAudioPathWindow
  • DefaultCaret() : DefaultCaret
  • DefaultCheckBoxListView() : DefaultCheckBoxListView
  • DefaultCheckBoxView() : DefaultCheckBoxView
  • DefaultChineseTheme() : DefaultChineseTheme
  • DefaultCodec : MediaInfo, CodecDevice
  • DefaultCommitRow() : PbBaseProvider
  • DefaultControlFrameView() : DefaultControlFrameView
  • DefaultDeleteAllRows() : PbBaseProvider
  • DefaultDeleteRow() : PbBaseProvider
  • DefaultDisplay() : DefaultDisplay
  • DefaultFormat : CamWin32
  • DefaultFrame : Control
  • DefaultItemRenderer() : DefaultItemRenderer
  • DefaultMask : InternalTracer
  • DefaultPositionIndicatorView() : DefaultPositionIndicatorView
  • DefaultProgressBarView() : DefaultProgressBarView
  • DefaultPushButtonView() : DefaultPushButtonView
  • DefaultRadioButtonListView() : DefaultRadioButtonListView
  • DefaultRadioButtonView() : DefaultRadioButtonView
  • DefaultServerId : ObexServerInfo
  • DefaultSize : IconState
  • DefaultStyle : AbstractItemRenderer
  • DefaultTabButtonView() : DefaultTabButtonView
  • DefaultTabControlView() : DefaultTabControlView
  • DefaultTextFormattingIe : EditorItemNode
  • DefaultTextListView() : DefaultTextListView
  • DefaultTheme() : DefaultTheme
  • DefaultValue : CamWin32
  • DefaultViewProp : GuiObjectFactory
  • DefaultWindowFrameView() : DefaultWindowFrameView
  • DefFragSize : ObexOppBinDataPushClient
  • DefGetFragSize : ObexDataServer
  • Define() : PdpContext
  • Defined : PdpContext
  • DefinePdpContext() : PsdDataConn
  • DeInit() : MediaInfo::ClipInfo
  • Deinitialize() : RamHandler
  • Delay : PdpContext::QualityOfService
  • DelayBestEffort : PdpContext::QualityOfService
  • DelayClass1 : PdpContext::QualityOfService
  • DelayClass2 : PdpContext::QualityOfService
  • DelayClass3 : PdpContext::QualityOfService
  • DelayProp : GuiObjectFactory
  • DelayReserved : PdpContext::QualityOfService
  • DelaySubscribed : PdpContext::QualityOfService
  • DelCurrCharMode : EditBox
  • Delegate() : RootFileImp
  • DelegationProviderListener() : DelegationProviderListener
  • Delete : MediaRefContainer, ImageRefContainer, MediaRefContainer, FfsFile, BtSddbServiceRecord, BtSddbDeContainer, File, Registry, ObjectTreeService, LocalDataStore, FlsFile, FfsHandler, WapProfile, DrmRightsObjectFile, RootFileImp, RamHandler, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile, RegEncoderDecoder, PbRecordProvider, InternalTracer, Provider, CommandType
  • DeleteActiveWord() : T9InputMapper
  • DeleteAll : PbRecordProvider, Provider
  • DeleteAllData() : SimPbEntryCont
  • DeleteAllDeviceListItems() : BtAvrcpControllerApplicationWindow
  • DeleteAllEntries() : PhonebookApp
  • DeleteAllEqualNodes() : RamFileNode
  • DeleteAllExtLanguages() : SimAuxHandler
  • DeleteAllItems() : CalendarRecordsListBoxModel, CalendarRecordsList, CalendarListWin
  • DeleteAllLanguages() : SimAuxHandler
  • DeleteAllMsg() : UibApp
  • DeleteAllObjects() : SimPbEntryCont
  • DeleteAllPlmns() : SimAuxHandler
  • DeleteAllPlmnwAct() : SimAuxHandler
  • DeleteAllRecords() : RecordHandler
  • DeleteAllRows() : ToDoProvider, CalendarProvider, PbSortedProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, PbMergeProvider, Provider, FindProvider, FilterProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, AppendProvider, SmsProvider, SmsClass0Provider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, CbmiRangeProvider, CbmiProvider
  • DeleteAllSms() : SmsProvider, SimPduHandler
  • DeleteAllSubNodes() : RamFileNode
  • DeleteAt() : MediaRefContainer
  • DeleteBackupFile() : BackupFileHandler
  • DeleteBlock() : RamStorageMapper
  • DeleteBlocks() : RamStorageMapper
  • DeleteBufferPool() : BufferPoolManager
  • DeleteChar() : AbstractEditBoxModel
  • DeleteComponentMsg() : DeleteComponentMsg
  • deleted : PbNumberRecord::Persist, PbRecord::Persist
  • Deleted : ToDoRecord
  • DeleteData() : SimPbEntryCont
  • DeleteDataBlocks() : RamFileObj
  • DeleteDir() : FfsHandler
  • DeletedNode() : DeletedNode
  • DeletedNodeList() : DeletedNodeList
  • DeleteDrmRights() : DrmAsset
  • DeleteEntries() : PbRecordHandler, SimPbBaseHandler
  • DeleteEntry() : ToDoProvider, PbRecordHandler, SimPbBaseHandler
  • DeleteEqualNode() : RamFileNode
  • DeleteExtLanguage() : SimAuxHandler
  • DeleteFile() : RootFileSystem
  • DeleteImageReq() : BtBipClientService
  • DeleteImageRsp() : BtBipServerService
  • DeleteItem() : CalendarRecordsListBoxModel, DBService
  • DeleteLanguage() : SimAuxHandler
  • DeleteLater() : Component
  • DeleteLndEntry() : SimPbBaseHandler
  • DeleteLockTable() : LockTableList
  • DeleteMode : EditBox
  • DeleteNode() : RegNodeBuffer, RamFileSystem
  • DeletePlmn() : SimAuxHandler
  • DeletePlmnwAct() : SimAuxHandler
  • DeleteProfile() : DataConnProfileManager
  • DeletePtrObj() : FixedPtrArray< T >
  • DeleteRecord() : NvRamDataRecordHandler, RecordHandler, DataRecordHandler
  • DeleteRegistration() : NotificationTable
  • DeleteRightsObject() : DrmRightsObjectStore
  • DeleteRow() : ToDoProvider, DataConnProvider, CalendarProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, PbMergeProvider, Provider, DistinctProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, CbmiRangeProvider, CbmiProvider
  • DeleteSelectedItem() : CalendarRecordsList, CalendarListWin
  • DeleteSelectedNumber() : PhonebookApp
  • DeleteSelectedPbEntry() : PhonebookApp
  • DeleteSms() : AbstractSmsApp
  • DeleteSubNode() : RamFileNode
  • DeleteUri() : NotificationArray
  • DeleteWapProfile() : WapProfileMgr
  • Deliver : MessageTypeIndicator
  • DeliverReport : MessageTypeIndicator
  • DelLeftCharMode : EditBox
  • Deregister() : ObexServerMngr, ObexServerInfo, GatiManager
  • DeregisterApplication() : HttpApplicationSupplier
  • DeregisterAvrcpApp() : BtAvrcpPanelServiceImpl, BtAvrcpPanelService, BtAvrcpPanelApplication
  • DeRegisterRequest() : BtAvrcpRegistrationService
  • Description : ObexHeader
  • description : CalendarRecord::Persist
  • DeselectedCheckBoxBitmap : CTResourcePack
  • DeselectedCheckBoxBitmapUri : CTResourcePack
  • DeselectedCheckBoxId : Theme
  • DeselectedRadioButtonBitmap : CTResourcePack
  • DeselectedRadioButtonBitmapUri : CTResourcePack
  • DeselectedRadioButtonId : Theme
  • DeselectUsimPb() : DataHandler
  • Desktop() : Desktop
  • dest_pos : BidiManager::ParagraphContext
  • dest_text : BidiManager::ParagraphContext
  • DestinationSmeBarred : ShortMessageFailureCause
  • DestOutOfService : Sms
  • Destroy() : GuiObjectFactory, ObexBuffer::Factory, AudioGatiServer, GatiServer, StackMsgArgDestroyTableNode, StreamObexImpl
  • destroy_func : ArgumentDestroyEntry
  • DestroyAction() : ObexAbstractPort
  • DestroyedState : MediaRecorder, MediaPlayer
  • DestroyImage() : ImageFactory
  • DestroyInstance() : DrmROStoreSingleton
  • DestroyMediaPlayer() : MediaManager
  • DestroyMediaRecorder() : MediaManager
  • DestroyModel() : EmsEditor, MultiMediaEditor
  • DestroyPanel() : Application
  • DestroyPlayerInstance() : MediaBox
  • DestroySelf() : StackMsgArgDestroyTableNode
  • DestroyT9() : ChineseT9Wrapper
  • Destruct() : Allocator< T >
  • Detach() : InetSocket, ObexDispatcher, MessageHook, AppContainer, BtObexServerService, BtObexClientService, BtSddbService, BtObservableService, ObservableObject, RtStreamingSource, RtStreamingSink, RtStreamingEndPoint, AtlApplicationPlugin, PlmnHandler, PlmnDispatcher, PdpContextManager
  • DetachCnfArg() : DetachCnfArg
  • DetachOppServer() : ObexServerOppImpl
  • DetachPending : PdpContextManager
  • DetachReqArg() : DetachReqArg
  • DetectChvProtection() : SimAuxHandler
  • DetectEncoding() : JapaneseTranscoder
  • DetectSimCardType() : SimAccessor
  • device : RingerAudioDevice::StartParam, FsRegistrationInfo, fs_registered_info_type
  • DEVICE_CAPABILITY_COUNT : StorageDevice
  • device_id : HostIterStatType
  • DeviceBuzzer : Audio
  • DeviceCapability : StorageDevice
  • DeviceContext() : DeviceContext
  • DeviceContext::EndUpdate : Application
  • DeviceEarPiece : Audio
  • DeviceError : File
  • DeviceIn : Audio
  • DeviceManager : AbstractDevice
  • DeviceMic : Audio
  • DeviceNone : Audio
  • DeviceOut : Audio
  • DeviceSearchCancelRequest() : BtDeviceListWindow
  • DeviceTrembler : Audio
  • Devil : InformationElement
  • DhChannelChangeStatusEventArg() : DhChannelChangeStatusEventArg
  • DhChannelChangeStatusResArg() : DhChannelChangeStatusResArg
  • DhChannelChangeStatusResMsg() : DhChannelChangeStatusResMsg
  • DhChannelCloseIndArg() : DhChannelCloseIndArg
  • DhChannelCloseReqArg() : DhChannelCloseReqArg
  • DhChannelCloseReqMsg() : DhChannelCloseReqMsg
  • DhChannelDataAvailableResArg() : DhChannelDataAvailableResArg
  • DhChannelDataAvailableResMsg() : DhChannelDataAvailableResMsg
  • DhChannelDataAvailEventArg() : DhChannelDataAvailEventArg
  • DhChannelOpenCnfArg() : DhChannelOpenCnfArg
  • DhChannelOpenRejArg() : DhChannelOpenRejArg
  • DhChannelOpenReqArg() : DhChannelOpenReqArg
  • DhChannelOpenReqMsg() : DhChannelOpenReqMsg
  • DhChannelReceiveIndArg() : DhChannelReceiveIndArg
  • DhChannelReceiveReqArg() : DhChannelReceiveReqArg
  • DhChannelReceiveReqMsg() : DhChannelReceiveReqMsg
  • DhChannelSendIndArg() : DhChannelSendIndArg
  • DhChannelSendReqArg() : DhChannelSendReqArg
  • DhChannelSendReqMsg() : DhChannelSendReqMsg
  • DiagnosticIndArg() : DiagnosticIndArg
  • DiagnosticIndMsg() : DiagnosticIndMsg
  • Dial : VrHandler
  • DifferenceType : Vector< T >, WbxmlVector< T >
  • Digit0 : VrHandler
  • Digit1 : VrHandler
  • Digit2 : VrHandler
  • Digit3 : VrHandler
  • Digit4 : VrHandler
  • Digit5 : VrHandler
  • Digit6 : VrHandler
  • Digit7 : VrHandler
  • Digit8 : VrHandler
  • Digit9 : VrHandler
  • DigitDialing : VrHandler
  • Digits : VrHandler
  • DigitsOnly() : SimGetInkeyOptions, SimGetInputOptions
  • DimmedBacklightBrightness : OptionalConfigBase
  • Ding : InformationElement
  • dir_id : FfsRefType, ffs_ref_type
  • Direction : AbstractSmsViewerWin
  • DirectionType : CodecDevice
  • Directory : File::Attributes
  • DirectoryIterator() : DirectoryIterator
  • DirectorySupport : StorageDevice
  • DirSpaceNotAvailableError : File
  • Disable() : IrdaTransport, CamWin32, SpeechSimpleAudioDevice, SimpleAudioDevice, RadioAudioDevice
  • DisableChv() : SimChvHandler
  • DisableChv1() : SimAccessor
  • Disabled : Control::NavigationGuidance, Charger
  • DisabledFeatureTriggeredMsg() : DisabledFeatureTriggeredMsg
  • DisabledMode : IconState
  • DisabledProp : GuiObjectFactory
  • DisableGlobalActiveDuration() : Cbs::Filter
  • DisableGlobalSleepDuration() : Cbs::Filter
  • DisableLoading() : BootControl
  • DisablePin() : SimAccessor
  • DiscardHeaders() : BtObexService
  • Disconnect() : ObexLayer, ObexClientOppImpl, ObexClient, IrdaObexImpl, MmiSimClient, BtObexImpl, ExtPsdContextListener_SerialTerminal, StreamObexImpl, SerialTerminal
  • DISCONNECT_IND : SerialIoSet
  • DisconnectActivePsdCalls() : MmCallHdl, MmCallHandler
  • DisconnectClient() : HttpServer, FtpServer
  • Disconnected : XCallInfoResponseParser
  • DisconnectedAndBatteryFull : Charger
  • DisconnectedAndBatteryNotFull : Charger
  • DisconnectIndicated : XCallInfoResponseParser
  • DisconnectReq() : BtBipClientService
  • DisconnectRequest() : BtObexClientService, BtHsService, BtHfService, BtFaxService, BtDunService, BtSingleConnectionController, BtAudioAccessoryService, BtAvrcpOperationService
  • disk_num_start : FileInfo_s
  • DiskAbort() : FatHandler
  • DiskAssignDriveLetter() : FatHandler
  • DiskClose() : FatHandler
  • DiskFlush() : FatHandler
  • DiskFormat() : FatHandler
  • DiskGetLastDeviceError() : FatHandler
  • DiskInfo() : FatHandler
  • DiskOpen() : FatHandler
  • DiskSetDefaultDevice() : FatHandler
  • Dispatcher() : Dispatcher
  • DispatcherAction() : DispatcherAction
  • DispatcherClassType : GuiObjectFactory
  • DispatcherProp : GuiObjectFactory
  • Display : BtAlertMessageWindow, BtAvrcpAlertMessageWindow, Display, OptionalConfigBase, Led
  • DisplayCategory : AbstractDevice
  • DisplayDc() : DisplayDc
  • DisplayDlg() : MediaBrowserUtils
  • DisplayExtensionText : SimTkProfile
  • DisplayIdxProp : GuiObjectFactory
  • DisplayInfoMsg() : DisplayInfoMsg
  • DisplayMap() : LcsWapIntf
  • DisplayMemory() : PhonebookApp, AdvPbApp
  • DisplayMsg() : LcsSettingsUtils, LcsAppUtils
  • DisplayOnGlassPane() : IndicatorLocation
  • DisplayPhoneNumber : MoCallAction
  • DisplayResizable : SimTkProfile
  • DisplaySettings() : DisplaySettings
  • DisplaySimPos() : PbDetails, PbAbstractWin
  • DisplayTextReqArg() : DisplayTextReqArg
  • DisplayTextRspArg() : DisplayTextRspArg
  • DisplayTimeout : Display
  • DisplayType : ItemRendererProperties
  • DistinctProvider() : DistinctProvider
  • DistinctRule() : DistinctRule
  • dl_blocks : AckNackTestparamCnt
  • dl_uarfcn : UmtsNcellParam, UmtsRrcScellParam
  • DlUarfcnInvalid() : UmtsNcellParam
  • DnsClient : DnsClient, SysDnsClient
  • DnsClientTest() : DnsClientTest
  • DoAddNumber() : PbManualSynchronizer
  • DoDataCompr() : PsdDataConnProfile
  • DoesApply() : DrmConstraint
  • DoesSynchronousDrawing() : Application
  • DoHeaderCompr() : PsdDataConnProfile
  • DoListCmd() : FtpClient
  • Done() : ActiveWaitDispatcher
  • DoOperation() : BtDeviceListWindow
  • DoRead() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoReadStreaming() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoReadStreamingAsync() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoRelease() : PsdDataConn, PppDataConn, DataConn
  • DoRequestOperation() : BtDeviceListWindow
  • DoRetrCmd() : FtpClient
  • dosDate : FileInfo_s
  • DoSetup() : PsdDataConn, PppDataConn, DataConn
  • DoStartPppRelease() : PppDataConn
  • DoStartPppSetup() : PppDataConn
  • DoStorCmd() : FtpClient
  • Dotted : Pen
  • Down : Control::NavigationGuidance, AbstractGrid
  • DownArrowBitmapId : AbstractPredictiveInputBox
  • DownlinkCarKit : AudioPath
  • DownlinkDirection : AudioDeviceBase
  • DownlinkPathBackspeaker : AudioPath
  • DownlinkPathBackspeakerStereo : AudioPath
  • DownlinkPathEarpiece : AudioPath
  • DownlinkPathExtRingerBackspeaker : AudioPath
  • DownlinkPathExtRingerI2S1_Tx : AudioPath
  • DownlinkPathExtRingerMonoHeadset : AudioPath
  • DownlinkPathExtRingerStereoHeadset : AudioPath
  • DownlinkPathFmRadioBackspeaker : AudioPath
  • DownlinkPathFmRadioHeadset : AudioPath
  • DownlinkPathI2S1_Tx : AudioPath
  • DownlinkPathMonoHeadset : AudioPath
  • DownlinkPathNone : AudioPath
  • DownlinkPathStereoHeadset : AudioPath
  • DownlinkPathTTY : AudioPath
  • DownlinkPathType : AudioPath
  • DownscaleToBounds : DisplaySettings
  • DoWrite() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoWriteStreaming() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoWriteStreamingAsync() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • Dr : AtResponse
  • Draw() : EmsImage, CalendarMonthSelectorView, CalendarGridView, WindowFrameView, View, TimeEditorDocument, TimeCompoundItem, TextLineView, TextEditorDocument, TextCompoundItem, TextBoxView, TabControlView, TabButtonView, RadioButtonControlView, PushButtonView, ProgressBarView, PositionIndicatorView, PanelView, NativeImage, MultiTapCaret, ItemBoxView, IpAddrCompoundItem, Image, GlassPane, PaneObject, EditorDocument, DrawableObject, DefaultCaret, DateEditorDocument, DateEditorView, DateCompoundItem, ControlFrameView, Control, CompoundItem, CheckBoxControlView, CharItem, Caret, AtomItem, AbstractRenderer, AbstractMultiLineEditorView, AbstractLineEditorView, ScanlineAccessor, TimeEditBoxView, TextMenuAccessor, SoundItem, SoftkeyBarView, RadioButtonView, MenuAccessor, MenuView, IndicatorBarPaneObject, IndicatorPaneObject, IndicatorBarView, IconValueIndicator, IconTextIndicator, TextIndicator, IconIndicator, Indicator, GridView, EditBoxView, DateEditBoxView, CheckBoxView, AnimationView, AbstractMenuAccessor, AbstractListBoxView, ItemLabelView, Zi8StrokeBoxView, Zi8SelectionBoxView, Zi8AlphabetBoxView, T9PinyinBoxView, StrokeBoxView, SelectionBoxView, SvgImage, VCardItem, RichTextCompoundItem, PngImage, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, ImageItem, GeneralCompoundItem, AudioItem, MediaBoxView
  • DrawableObject() : DrawableObject
  • DrawableObjectClassType : GuiObjectFactory
  • DrawableObjects : Control::ComponentIterator
  • DrawableObjectView() : DrawableObjectView
  • DrawArc() : DeviceContext
  • DrawBackground() : DefaultItemRenderer, AbstractItemRenderer, AtlItemRenderer
  • DrawBitmap : DeviceContext, CTResourcePack
  • DrawCell() : GridView
  • DrawCellPostHighlighted() : GridView
  • DrawCellPreHighlighted() : GridView
  • DrawChar() : VirtualDisplay
  • DrawCheckBox() : DefaultCheckBoxView, TestCheckBoxView, DefaultCheckBoxView, BlueSkyCheckBoxView, CheckBoxView
  • DrawCheckBoxItem() : DefaultCheckBoxListView, TestCheckBoxListView, DefaultCheckBoxListView, BlueSkyCheckBoxListView, CheckBoxListView
  • DrawCircle() : DeviceContext
  • DrawClientAreaBackground() : ControlFrameView, DefaultWindowFrameView
  • DrawComponent() : CustomizableTheme
  • DrawControlFrame() : ControlFrameView, FoggyWindowFrameView, DefaultWindowFrameView, DefaultControlFrameView, CTWindowFrameView, CTControlFrameView, TestWindowFrameView, TestControlFrameView, DefaultWindowFrameView, DefaultControlFrameView, BlueSkyWindowFrameView, BlueSkyControlFrameView
  • DrawCorruptImageSign() : Image
  • DrawCursor() : AbstractEditBox, AbstractEditBoxView
  • DrawDateEditBox() : DateEditBoxView
  • DrawEditBox() : EditBoxView
  • DrawFrameComponents() : ControlFrameView
  • DrawGlyphInItalic() : AbstractTextRenderer
  • DrawGsmBitmap() : DeviceContext
  • DrawHeightScaledScanline() : PngImage
  • DrawItem() : ImageListBoxView, DefaultItemRenderer, AbstractItemRenderer, TextListView, RadioButtonListView, ProviderListBoxView, MenuListView, CheckBoxListView, AtlItemRenderer, AbstractListBoxView
  • DrawItemBorder() : ItemTree, AbstractItemGrid
  • DrawLayer() : Control
  • DrawLine() : DeviceContext
  • DrawMarkedItemSelection() : MultiMediaEditor
  • DrawMenuItem() : MenuListView
  • DrawPanel() : PanelView, FoggyPanelView, DefaultPanelView, CTPanelView
  • DrawPixel() : DeviceContext, PngImage
  • DrawPolygon() : DeviceContext
  • DrawPositionIndicator() : PositionIndicatorView, AbstractGrid, FoggyPositionIndicatorView, DefaultPositionIndicatorView, CTPositionIndicatorView, TestPositionIndicatorView, DefaultPositionIndicatorView, BlueSkyPositionIndicatorView
  • DrawPrimitives : CTResourcePack
  • DrawProgressBar() : ProgressBarView, DefaultProgressBarView, CTProgressBarView, DefaultProgressBarView, BlueSkyProgressBarView
  • DrawPushButton() : PushButtonView, FoggyPushButtonView, DefaultPushButtonView, CTPushButtonView, TestPushButtonView, DefaultPushButtonView, BlueSkyPushButtonView
  • DrawRadioButton() : DefaultRadioButtonView, RadioButtonView, TestRadioButtonView, DefaultRadioButtonView, BlueSkyRadioButtonView
  • DrawRadioButtonItem() : DefaultRadioButtonListView, RadioButtonListView, TestRadioButtonListView, DefaultRadioButtonListView, BlueSkyRadioButtonListView
  • DrawRect() : DeviceContext
  • DrawRoundRect() : DeviceContext
  • DrawScaledPixel() : PngImage
  • DrawScanline() : NativeImage, Image, WbmpImage, PngImage, JpegImage, GifImage, BmpImage
  • DrawSelection() : AbstractEditor
  • DrawShifted() : RadioButtonView, CheckBoxView
  • DrawShiftedCheckBox() : DefaultCheckBoxView, TestCheckBoxView, DefaultCheckBoxView, BlueSkyCheckBoxView, CheckBoxView
  • DrawShiftedRadioButton() : DefaultRadioButtonView, RadioButtonView, TestRadioButtonView, DefaultRadioButtonView, BlueSkyRadioButtonView
  • DrawSoftkeyBar() : FoggySoftkeyBarView, DefaultSoftkeyBarView, SoftkeyBarView, TestSoftkeyBarView, FoggySoftkeyBarView, DefaultSoftkeyBarView, BlueSkySoftkeyBarView
  • DrawTabButton() : TabButtonView, DefaultTabButtonView
  • DrawTabControl() : TabControlView, DefaultTabControlView
  • DrawText() : ThaiTextRenderer, SimpleTextRenderer, DeviceContext, DefaultItemRenderer, ArabicTextRenderer, AbstractTextRenderer
  • DrawTextBox() : DeviceContext
  • DrawTextInvert() : DeviceContext
  • DrawTextListItem() : DefaultTextListView, TextListView, DefaultTextListView, BlueSkyTextListView
  • DrawTimeEditBox() : TimeEditBoxView
  • DrawWindowExtensions() : WindowFrameView, FoggyWindowFrameView, DefaultWindowFrameView, CTWindowFrameView, TestWindowFrameView, DefaultWindowFrameView, BlueSkyWindowFrameView
  • drive_letter : FsRegistrationInfo, fs_registered_info_type
  • driveno : FatFindData, dstat
  • DriverCause : AudioDeviceBase
  • DriverReason : AudioPlayerEvent
  • drm_attrib : FfsFileInfo, ffs_file_info_type
  • Drm_v_1_0 : DrmRelParser
  • Drm_v_None : DrmRelParser
  • DrmAsset() : DrmAsset
  • DrmConstraint() : DrmConstraint
  • DrmCrypt() : DrmSecurity
  • DrmDcfContentDescription : DrmDcfParser
  • DrmDcfContentName : DrmDcfParser
  • DrmDcfContentVendor : DrmDcfParser
  • DrmDcfEncryptionMethod : DrmDcfParser
  • DrmDcfHeaderType : DrmDcfParser
  • DrmDcfIconUriHeader : DrmDcfParser
  • DrmDcfPaddingScheme : DrmDcfParser
  • DrmDcfParser() : DrmDcfParser
  • DrmDcfRightsIssuer : DrmDcfParser
  • DrmDcfUnSupported : DrmDcfParser
  • DrmInfo() : DrmInfo
  • DrmMessage() : DrmMessage
  • DrmPermission() : DrmPermission
  • DrmRelParser() : DrmRelParser
  • DrmRightsObject() : DrmRightsObject
  • DrmRightsObjectStore() : DrmRightsObjectStore
  • DrmROStoreSingleton() : DrmROStoreSingleton
  • DrmSecurity() : DrmSecurity
  • DrmSubsystem() : DrmSubsystem
  • DrmVersion : DrmRelParser
  • DrmWapPushMsg() : DrmWapPushMsg
  • DropShadowColor : CTResourcePack
  • DropShadowDistance : CTResourcePack
  • DropShadowEnabled : CTResourcePack
  • DropShadowMaxAlpha : CTResourcePack
  • DropShadowMinAlpha : CTResourcePack
  • DropShadowWidth : CTResourcePack
  • Drum : InformationElement
  • drx_max : GprsParam
  • dsc : CellParam
  • dsc_pch : L1Param
  • dsc_ppch : L1Param
  • dsp_format : VoiceMemoAudioDevice::StartParam
  • DspFormat : VoiceMemoAudioDevice, StreamAudioReference
  • DspFormatAmr : VoiceMemoAudioDevice
  • DspFormatFullRate : VoiceMemoAudioDevice
  • dsplcond : ServiceProviderStruct
  • DstIndication : TimeZone
  • DtmfBufferCleanedMsg() : DtmfBufferCleanedMsg
  • DtmfBufferClearedIndArg() : DtmfBufferClearedIndArg
  • DtmfRejectMsg() : DtmfRejectMsg
  • DtmfStartCnfMsg() : DtmfStartCnfMsg
  • DtmfStopCnfMsg() : DtmfStopCnfMsg
  • dtx_used : CellParam
  • DualCall : XCallInfoResponseParser
  • DualChannelMode : AudioEncoder
  • DualFilterProvider() : DualFilterProvider
  • DualMono : CodecDevice
  • DualServiceCallModification : XCallInfoResponseParser
  • DualTone : CustomToneAudioReference
  • DualUserTone : ToneAudioDevice
  • Dummy() : StackMsgArgDestroyTableNode
  • DummyVrEngineParams() : DummyVrEngineParams
  • Dump() : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, OnDataRcvdMsg, ObexVCardMsg, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg
  • DumpMemoryConsumptionSnapshot() : HeapManager
  • DumpMemoryContextSnapshot() : HeapManager
  • DumpTables() : SmsSocketListener
  • DupeChecker : ObexOppServer
  • DuplicateInvokeId : TaggedProblemCode
  • dur : Audio::SingleTone
  • duration : ToneAudioDevice::UserTone, RingerAudioDevice::RingerToneInfo, Media::Parameters
  • Dutch : LanguageManager, DataCodingScheme
  • DwdDevice() : DwdDevice
  • DwdHandleType : DwdDevice
  • DwdIDType : DwdDevice
  • DwdPlayer : DwdPlayer, RadioAudioDevice
  • dword_value : BtObexHeader
  • dynamic : FfsFileInfo, ffs_file_info_type
  • DynamicBitVector() : DynamicBitVector
  • DynamicFrame : Control
  • DynamicMenuPool() : DynamicMenuPool
Generated on Wed Jan 25 00:54:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • E164 : WapProfile
  • e164_number : WapProfile::Ipv4E164
  • ecc : UsimEccRecord
  • EccCategory() : EccCategory
  • EccError : File
  • EccListIndArg() : EccListIndArg
  • EccProvider() : EccProvider
  • ECT : InputParser
  • ect_callstate : EctIndicator
  • ect_indicator : NotifySsArg
  • EctAccomplished : CallEvent
  • EctActiveMsg() : EctActiveMsg
  • EctAlertingMsg() : EctAlertingMsg
  • EctCnfArg() : EctCnfArg
  • Edit() : PropertyEditorFactory
  • EditBox() : EditBox
  • EditBoxBlinkTimer : EditBoxBlinkTimer, AbstractEditBox
  • EditBoxPagingTimer : EditBoxPagingTimer, EditBox
  • EditBoxView() : EditBoxView
  • EditDetail() : PbDetails
  • EditLine() : EditLine
  • EditMode : EditBox
  • Editor : OptionalConfigBase
  • EditorDocument() : EditorDocument
  • EditorDocumentObtainer() : EditorDocumentObtainer
  • EditorItemNode() : EditorItemNode
  • EditorLine() : EditorLine
  • EditProperty() : PropertyEditor
  • EightBitAlphabet : InputMapper, DataCodingScheme
  • ElectronicMail : InformationElement
  • ElementList() : ElementList< T >
  • ElementListBase() : ElementListBase
  • ElementUndefined : DataCallContext
  • ElemType : CArray< T >
  • email : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • email_ref : T_PB_REF_RECORD
  • EMailAddress : InputMapper
  • EmailMessage : DataCodingScheme
  • EmApoxiMediaInfo : MediaInfo
  • EmApoxiRecordSettings : RecordSettings
  • EmbossFilter : Camera
  • emcpp_apoxi_OBEXAdapter() : emcpp_apoxi_OBEXAdapter
  • EmergencyCall : XCallInfoResponseParser
  • EMLPP : InputParser
  • EmlppAction() : EmlppAction
  • EmlppHandler() : EmlppHandler
  • EmlppRegisteredMsg() : EmlppRegisteredMsg
  • EmlppStatusMsg() : EmlppStatusMsg
  • emo : GprsParam
  • empty() : WbxmlVector< T >
  • Empty : ObexBuffer, Tpdu
  • EmptyCache() : SmsSocketListener
  • EmptyFile : MediaManager
  • EmptyRWBuffer() : SimPbBaseHandler
  • EmsComposeWin() : EmsComposeWin
  • EmsCreator() : EmsCreator
  • EmsEditor : EmsEditor, EmsEditorListener
  • EmsEditorListener() : EmsEditorListener
  • EmServThreadMsg() : EmServThreadMsg
  • EmsIeParser() : EmsIeParser
  • EmsImage() : EmsImage
  • EmsInsertPrompt() : EmsInsertPrompt
  • EmsInsertPromptListBoxModel() : EmsInsertPromptListBoxModel
  • EmsInsertType : EmsInsertPrompt
  • EmsViewerWin() : EmsViewerWin
  • EmzAacDecoder : EmzAacDecoderThread
  • EmzAacDecoderThread : EmzAacDecoder
  • EmzCodecsLib : EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder
  • EmzH264Decoder : EmzH264DecoderThread
  • EmzH264DecoderThread : EmzH264Decoder
  • EmzMp3Decoder : EmzMp3DecoderThread
  • EmzMp3DecoderThread : EmzMp3Decoder
  • EmzMpeg4Decoder : EmzMpeg4DecoderThread
  • EmzMpeg4DecoderThread : EmzMpeg4Decoder
  • EmzMpeg4Encoder : EmzMpeg4EncoderThread
  • EmzMpeg4EncoderThread : EmzMpeg4Encoder
  • EmzSbcEncoder : EmzSbcEncoderThread
  • EmzSbcEncoderThread : EmzSbcEncoder
  • Enable() : IrdaTransport, CamWin32, AbstractTransport, BtTransport, SpeechSimpleAudioDevice, SimpleAudioDevice, RadioAudioDevice, UsbTransport
  • Enable3dSound() : AudioPathManager
  • EnableBuiltinEccCodes() : DataHandler
  • EnableChv() : SimChvHandler
  • EnableChv1() : SimAccessor
  • enabled : StartUp::Table
  • Enabled : Control::NavigationGuidance
  • EnableDataCompr() : PsdDataConnProfile
  • EnabledAttributeId : Feature
  • EnableDcsListFilter() : Cbs::Filter
  • EnabledProp : GuiObjectFactory
  • EnabledPropertyId : Item
  • EnableEcNr() : AudioAccessoryDetails
  • EnableGlobalActiveDuration() : Cbs::Filter
  • EnableGlobalSleepDuration() : Cbs::Filter
  • EnableHeaderCompr() : PsdDataConnProfile
  • EnableLoading() : BootControl
  • EnableMasterMute() : AudioDeviceManager
  • EnableMidListFilter() : Cbs::Filter
  • EnablePasswdQuery() : DataConnProfile
  • EnablePeakMemoryContextOutput() : HeapManager
  • EnablePhonebook() : PhonebookApp
  • EnablePidCheckForConcSms() : SimPduHandler, DataHandler
  • EnablePin() : SimAccessor
  • EnableProactiveDtmfTones() : SimTkHandler
  • EnableResendingSmsOverCs() : SmsHandler
  • EnableSimActions() : PhonebookApp
  • EnableStatusReportRequest : CommandType
  • EnableTransaction : Registry, RegEncoderDecoder
  • EnableUplinkAudioPaths() : AudioPathManager
  • EnableUsagePureUcs2Encoding() : AlphaCoding
  • Encode() : RegEncoderDecoder, ImageEncoder, PngEncoder, JpegEncoder
  • EncodeAlphaField() : AlphaCoding
  • EncodeBase64() : MimeCoding
  • EncodeBuffer() : EmzSbcEncoder, AudioEncoder
  • EncodeBufferFct : AudioEncoder
  • EncodeChar() : QuotedPrintableCoder
  • EncodeEnd() : Base64Coder, QuotedPrintableCoder
  • EncodeFrame() : ScicosMpeg4VideoEncoder, EmzMpeg4Encoder, AtiMpeg4Encoder, EmzSbcEncoder, EmzMpeg4Encoder, VideoEncoder, AudioEncoder
  • EncodeFrameFct : AudioEncoder
  • EncodePush() : Base64Coder, QuotedPrintableCoder
  • EncodeQuotedPrintable() : MimeCoding
  • EncoderInitError : ImageEncoder
  • EncodeSetupMsg() : RegEncoderDecoder
  • EncodeSynchronously() : ImageEncoder, PngEncoder, JpegEncoder
  • EncodeUncertRadius() : LcsUtils
  • EncodingDirection : CodecDevice
  • EncodingError : ImageEncoder
  • EncodingFormat : PngEncoder::EncodingParameters, JpegEncoder::EncodingParameters
  • EncodingFunctionType : AudioEncoder
  • EncodingParameters() : ImageEncoder::EncodingParameters, PngEncoder::EncodingParameters, JpegEncoder::EncodingParameters
  • EncodingThreadlet : EncodingThreadlet, ImageEncoder
  • EncodingType : JapaneseTranscoder
  • EncQualityConfig : CodecDevice
  • EncQualityHigh : CodecDevice
  • EncQualityLow : CodecDevice
  • EncQualityMid : CodecDevice
  • End : BtDeviceList, Vector< T >, MessageIdentifierRange, DataCodingSchemeRange, Pathname, FlowLayout, IndicatorLocation
  • end() : WbxmlVector< T >
  • EndCDATAHandler() : XMLParser
  • EndDecoding() : ImageDecoder, PngDecoder
  • endDocument() : WbxmlParserRel
  • EndDocument() : XMLParser
  • EndDrawing() : PngImage
  • endElement() : WbxmlParserRel
  • EndElement() : XMLParser
  • EndEncoding() : ImageEncoder, PngEncoder, JpegEncoder
  • EndGlyphRetrieval() : AbstractTextRenderer
  • EndInternalUpdate() : ParagraphCompoundItem
  • EndOfCodecType : MediaInfo, CodecDevice
  • EndOfColorType : CamWin32
  • EndOfDirectionType : CodecDevice
  • EndOfDirectoryError : File
  • EndOfFilterType : Camera
  • EndOfFpsType : CamWin32, VideoCamera
  • EndOfFrameCodingType : VideoEncoder
  • EndOfImageSizeType : CamWin32, Camera
  • EndOfLocationType : CodecDevice
  • EndOfParameterType : VideoDecoder, AudioEncoder, AudioDecoder
  • EndOfPduIE : BaseInformationElement
  • EndOfProperty : CamWin32
  • EndOfPropertyType : CamWin32
  • EndOfResultType : CodecDevice
  • EndOfStream() : StreamingReadInfo
  • EndOperation() : StreamObexImpl
  • EndProcessing() : BidiManager
  • EndScanlineDrawing() : NativeImage, Image, WbmpImage, JpegImage, GifImage, BmpImage
  • EndSimToolkitIndArg() : EndSimToolkitIndArg
  • EndsWith() : WString, String
  • endswith() : Uri
  • EndTransaction() : UssdHandler
  • EndUpdate() : DeviceContext
  • EndUserDefineableViewsProp : GuiObjectFactory
  • EngineeringModeControlRequestArg() : EngineeringModeControlRequestArg
  • EngineeringModeControlResponseArg() : EngineeringModeControlResponseArg
  • EngineeringModeControlResponseMsg() : EngineeringModeControlResponseMsg
  • EngineeringReportMsg() : EngineeringReportMsg
  • English : LanguageManager, DataCodingScheme
  • EnglishT9InputMapper() : EnglishT9InputMapper
  • EngModeAction() : EngModeAction
  • Enhanced : ValidityPeriodFormat
  • EnhancedMessageType : ProtocolIdentifier
  • Enqueue() : AppContainer, KeyMsgGenerator
  • Enquiry : CommandType
  • EnsureContext() : InetSocket
  • EnterNewEntry() : PhonebookApp
  • EnterNumber() : PbSelectNumberWin
  • Entry() : SmsWStringCache::Entry
  • entry_count : tagDataPackHeader
  • enumClassType : AudioReference, AudioActiveReference
  • enumConstants : T9InputMapper
  • EnumTransports() : ObexMngr
  • EOBWBitmap : InformationElement
  • EOBWBitmapAnimation : InformationElement
  • EODataFormatDeliveryRequest : InformationElement
  • Eof() : FileOutputStream, FileInputStream
  • EofProcessing : MediaRecorder, MediaPlayer
  • EofReachedMsg : MediaManager
  • EofReceivedState : MediaPlayer
  • EOiMelody : InformationElement
  • EOPolyphonicMelody : InformationElement
  • EOPredefinedAnimation : InformationElement
  • EOPredefinedSound : InformationElement
  • EOSixBitGrayScale : InformationElement
  • EOSixBitGrayScaleAnimation : InformationElement
  • EOStdWVGObject : InformationElement
  • EOTwoBitGrayScale : InformationElement
  • EOTwoBitGrayScaleAnimation : InformationElement
  • EOvCalendar : InformationElement
  • EOvCard : InformationElement
  • eq_plmn_list : TestparamReport
  • EqualName() : PbManualSynchronizer
  • EqualNumber() : PbManualSynchronizer
  • EqualsRule() : EqualsRule
  • EqualType : StandardJoinRule
  • EqUplmList : TestparamReport
  • Erase() : BtDeviceList, WString, Vector< T >, String, UusHandler, CallForwardingHandler
  • erase() : WbxmlVector< T >
  • EraseCursor() : AbstractEditBox
  • Erasure : InputParser
  • Ermes : ProtocolIdentifier
  • ErmesNumberingPlan : TypeOfAddress
  • error() : WbxmlParserRel
  • Error : ImageEncoder, ShortMessageFailureCause, File, StreamObexImpl, PngDecoder, VrHandler, InternalTracer, ExtPsdContextListener_SerialTerminal, SerialTerminal, AtResponse
  • ErrorAudioDriverDisabled : AudioError
  • ErrorCause : PdpContext
  • ErrorCode : ObexResult, Image, SerialIoAdapter
  • ErrorFormatNotSupported : AudioError
  • ErrorHandleNotUsed : AudioError
  • ErrorHandler() : XMLParser
  • ErrorInMs : ShortMessageFailureCause
  • ErrorInSme : ShortMessageStatus
  • ErrorMissingDspResource : AudioError
  • ErrorNoHwSupport : AudioError
  • ErrorNoPlayback : AudioError
  • ErrorNoPlaytime : AudioError
  • ErrorParameterOutOfRange : AudioError
  • ErrorPerformanceProblems : AudioError
  • ErrorProcessing : MediaRecorder, MediaPlayer
  • ErrorResourceConflict : AudioError
  • ErrorResourceInUse : AudioError
  • ErrorRingerSuspendresumeError : AudioError
  • ErrorRingerToneError : AudioError
  • ErrorRsp() : BtBipServerService
  • ErrorSharingViolation : AudioError
  • ErrorState : Camera, MediaRecorder, MediaPlayer
  • ErrorType : AudioError
  • ErrorUnknown : AudioError
  • ErrorUnknownPosition : AudioError
  • ErrorVmFFSProblems : AudioError
  • ErrorVmPerformanceProblems : AudioError
  • Esperanto : LanguageManager
  • EstablishDataConnection() : FtpClient
  • EstablishmentCause : XCallInfoResponseParser
  • EstCauseNotValid : XCallInfoResponseParser
  • Estonian : LanguageManager
  • Euc : JapaneseTranscoder
  • EvalAvsAction() : ObexAbstractPort
  • EvaluateExecutionResult() : BtObexRequest, BtRequest, BtBppReq
  • EvaluateMessageResult() : BtRequestRespondRequest, BtLocalRequest
  • EvAvsChanged : ObexAbstractPort
  • EvAvsIsBad : ObexAbstractPort
  • EvAvsReady : ObexAbstractPort
  • EvClose : ObexAbstractPort
  • event : RrcProcessState
  • Event : Socket, NetAdapter, ExtPsdContextListener_SerialTerminal, SerialTerminal
  • event_id : UmtsMeasIdParam
  • EVENT_IGNORED : StateMachine
  • EventType : ObexAbstractPort
  • EvOpComplete : ObexAbstractPort
  • EvOpen : ObexAbstractPort
  • EvOpenFailure : ObexAbstractPort
  • EvOpenSuccess : ObexAbstractPort
  • Evrc : MediaInfo, CodecDevice
  • EvReleaseComplete : ObexAbstractPort
  • EvResolveComplete : ObexAbstractPort
  • EvResolveFailure : ObexAbstractPort
  • EvResolveSuccess : ObexAbstractPort
  • ExchangeableMedia : StorageDevice
  • Exclude() : ObexTransportSet
  • ExcludePlayer() : AudioPlayerStore
  • ExecCdupCmd() : FtpClient
  • ExecCmd() : FtpServer, FtpClient
  • ExecCwdCmd() : FtpClient
  • ExecDeleCmd() : FtpClient
  • ExecFn : Action
  • ExecListCmd() : FtpClient
  • ExecMkdCmd() : FtpClient
  • ExecModeCmd() : FtpClient
  • ExecNoopCmd() : FtpClient
  • ExecPassCmd() : FtpClient
  • ExecPasvCmd() : FtpClient
  • ExecPortCmd() : FtpClient
  • ExecPwdCmd() : FtpClient
  • ExecQuitCmd() : FtpClient
  • ExecRetrCmd() : FtpClient
  • ExecRmdCmd() : FtpClient
  • ExecStorCmd() : FtpClient
  • ExecStruCmd() : FtpClient
  • ExecTypeCmd() : FtpClient
  • ExecUserCmd() : FtpClient
  • Execute() : SaveNoAction, CopyToPbAction, AddNumberToFdnAction, AddEntryToFdnAction, AddAllToFdnAction, DisplayMemoryAction, SyncAction, PbDelAllAction, PbDeleteAction, PbCallAction, PbCancelEditAction, PbConfirmEditAction, PbEditDetailAction, PbAddAction, PbSecuredAction, PbAction, SyncPhoneAction, SyncSimAction, SyncPhoneAllAction, SyncSimAllAction, PbSelectGroupAction, PbChangeNoTypeAction, PbDelPhonenoAction, PbCancelAddNoAction, PbConfirmAddNoAction, PbAddPhoneNoAction, Threadlet, ContextExecuteMsg, MessageMapContainer< T >, AbstractMessageMapContainer, OpenWindowAction, OpenContextMenuAction, CloseWindowAction, Action, AbstractToggleAction, ShutDown, SetThemeAction, SetLanguageAction, ConfirmAction, CancelAction, BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexSetPathRequest, BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtObexPutRequest, BtObexGetRequest, BtObexDisconnectRequest, BtObexConnectRequest, BtObexAbortRequest, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtSendPasskeyRequest, BtRespondAuthorizationRequest, BtRequest, BtQuerySupportedProfilesRequest, BtDisconnectRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtConnectRequest, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRegisterRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse, BtAvrcpDeRegisterRequest, BtAvrcpConnectResponse, PropertyItem, TriggerKeyFeature, IndicatorItem, FeatureItem, FeatureHandle, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, ContextFeatureHandle, SsEmlppActionImpl, SsUssdActionImpl, SsCnapActionImpl, SsColpActionImpl, SsColrActionImpl, SsClipActionImpl, SsClirActionImpl, SsCallWaitingActionImpl, SsCallForwardingActionImpl, SsCallBarringActionImpl, SsPasswordChangeActionImpl, UnlockAction, InputAction, StackMsgArgMapContainer< T >, AbstractStackMsgArgMapContainer, RegCbNotifyMsg, ApplicationAction
  • ExecuteFeature() : MmfPlayer, AudioDeviceBase
  • ExecuteRequest() : BtServiceRequest, BtRequest, BtLocalRequest
  • ExecuteRule() : GreaterRule, LessRule, RangeRule, NotEqualsRule, EqualsRule, FilterRule, DistinctRule, PhoneNumberMatchRule, PhoneNumberJoinRule, StandardJoinRule, JoinRule, DcsLanguageFilterRule
  • ExecuteThreadlet() : ImageEncoder
  • ExecutionCallback() : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexSetPathRequest, BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtObexPutRequest, BtObexGetRequest, BtObexDisconnectRequest, BtObexConnectRequest, BtObexAbortRequest, BtServiceRequest, BtRequest, BtLocalRequest, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest
  • ExecutionContext : ExecutionContext, UserDispatcher
  • exist : T_PB_STATE
  • ExistColumn() : PbSimProvider, Provider
  • Exists() : SimpleMap< TKey, TValue >, ElementList< T >, MessageIdentifierContainer, Cbs::Filter, StorageDevice, RootFileSystem, File, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • exists : TSiIconID_s
  • ExistsEntry() : PbRecordHandler
  • ExistsRecord() : ToDoProvider, RecordHandler
  • Expand() : Rect
  • ExplicitCallTransfer() : CrssHandler, CallHdl
  • ExplicitCallTransferCompleted : XCallInfoResponseParser
  • ExplicitCallTransferRejected : XCallInfoResponseParser
  • ExplicitCallTransferStarted : XCallInfoResponseParser
  • exponent : AocChargeData
  • ExportInternalBuffer() : TextCompoundItem
  • ExportSendType : AbstractSmsApp
  • ExportStoreType : AbstractSmsApp
  • ExposureChanged : Camera
  • ext1 : T_PB_FILL_STATUS
  • ext_pref_language : SimInfo
  • ExtendedObject : InformationElement
  • ExtendedObjectType : InformationElement
  • ExtendToUuid128() : BtObexServiceTable
  • ExtensionExists() : FunctionalityIndicator, ParameterIndicator
  • external_fa : FileInfo_s
  • ExternalCommunicationHandler() : ExternalCommunicationHandler
  • ExternalContextState : PdpContextManager
  • ExternalEvent() : ObexAbstractPort, StateMachine
  • ExternalPdpContextInfoMsg() : ExternalPdpContextInfoMsg
  • ExternalTimeoutMsg() : ExternalTimeoutMsg
  • ExtProactiveCmdCnfArg() : ExtProactiveCmdCnfArg
  • ExtProactiveCmdIndArg() : ExtProactiveCmdIndArg
  • ExtProactiveCmdReqArg() : ExtProactiveCmdReqArg
  • ExtPsdContextListener_SerialTerminalListener() : ExtPsdContextListener_SerialTerminalListener
  • ExtPsdContextListener_SioGlueSignalListener : ExtPsdContextListener_SioGlueSignalListener, ExtPsdContextListener_SerialTerminal
  • ExtPsdContextListener_SioGlueWrapper : ExtPsdContextListener_SioGlueWrapper::TermIos, ExtPsdContextListener_SioGlueWrapper::SioCommId
  • ExtPsdContextListenerImpl_SerialTerminalListener() : ExtPsdContextListenerImpl_SerialTerminalListener
  • extra_bytes : RegEncoderDecoder
  • ExtractHeaderFields() : ObexFtpDataServer
Generated on Wed Jan 25 00:54:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • FacilityNotSubscribed : Sms
  • FacilityNotSupported : SsErrorCode
  • FacilityRejected : Sms
  • FacsimileServices : InputParser
  • Factory : ObexBuffer::Factory, ObexBuffer
  • fading_color : Led::StreamField
  • FAIL : StreamObexImpl
  • Failed : SocketTestT
  • family_name : tagFontFamily
  • FanFar : InformationElement
  • FastForward() : MP3AudioPlayer, MmfPlayer, MediaPlayer
  • FastForwardApiCompletionMsg : MediaManager
  • FastForwardingState : MediaPlayer
  • FastReverse() : MP3AudioPlayer
  • FatalError : File, AtResponse
  • fatalError() : WbxmlParserRel
  • FatDirectoryIteratorImp : FatDirectoryIteratorImp, FatStorageDeviceImp
  • FatFile : FatFile, FatStorageDeviceImp
  • FatFileImp : FatFileImp, FatStorageDeviceImp
  • FatFsUsbMassStorageReleaseMsg() : FatFsUsbMassStorageReleaseMsg
  • FatFsUsbMassStorageRequestMsg() : FatFsUsbMassStorageRequestMsg
  • FatStorageDeviceImp : FatFileImp, FatDirectoryIteratorImp
  • FatStorageDeviceImpInternals : FatStorageDeviceImp
  • fattribute : HostFileStatType, HostIterStatType, RamFileInfo, FatFindData, FatFileInfo, fs_stat, dstat
  • Fax : XCallInfoResponseParser
  • FaxMessage : InformationElement, DataCodingScheme
  • fdate : HostIterStatType, FatFindData, dstat
  • fdn_size : PhoneBookInfo
  • fdn_tagsize : PhoneBookInfo
  • FdnFailed : Sms
  • FdnIndArg() : FdnIndArg
  • FdnReqArg() : FdnReqArg
  • FeatDeleteProfile : DataConnApp
  • FeatEditProfile : DataConnApp
  • FeatSaveProfile : DataConnApp
  • FeatSetDefaultProfile : DataConnApp
  • Feature : SimTkProfile, Feature, AudioDeviceBase, FeatureBroker
  • feature_handle : KeymapTableEntry
  • feature_id : MenuPool::FeatureItemContainerContentTableEntry, SoftkeyDescTableEntry
  • feature_list : CallBarringInfo, ForwardingInfo
  • feature_list_size : CallBarringInfo, ForwardingInfo
  • FeatureAttributeId : Feature
  • FeatureChangedMsg() : FeatureChangedMsg
  • FeatureCnt : DataConnApp
  • FeatureHandle() : FeatureHandle
  • FeatureId : DataConnApp
  • FeatureIdProp : GuiObjectFactory
  • FeatureItem() : FeatureItem
  • FeatureItemClassType : GuiObjectFactory
  • FeatureItemContainer() : FeatureItemContainer
  • FeatureItemContainerClassType : GuiObjectFactory
  • FeatureItemContainerIdProp : GuiObjectFactory
  • FeatureItemContainerProp : GuiObjectFactory
  • FeatureItemContainerPropertyId : FeatureItemContainer
  • FeatureItemPropertyId : FeatureItem
  • FeatureKeyProp : GuiObjectFactory
  • FeatureKeyType : GuiObjectFactory
  • FeatureListener : AtlItemBox
  • FeatureNotSupported : MediaManager, CodecDevice
  • FeaturePoolF : FeaturePool
  • FeaturePropertyId : FeatureItem
  • FeatureTriggerMsg() : FeatureTriggerMsg
  • FeatViewDataConnList : DataConnApp
  • February : Date
  • fext : HostIterStatType, FatFindData, dstat
  • FFindFirst() : FfsHandler
  • FFindNext() : FfsHandler
  • ffs_type : FfsMimeTypeMapEntry
  • FfsDataConnProfileStorage() : FfsDataConnProfileStorage
  • FfsFile() : FfsFile
  • FfsMedia : StreamAudioReference
  • FfsMenu() : FfsMenu
  • FfsTest_T1() : FfsTests
  • FfsTest_T2() : FfsTests
  • FfsTest_T3() : FfsTests
  • FfsTest_T4() : FfsTests
  • FfsTest_T5() : FfsTests
  • FfsTest_T6() : FfsTests
  • FfsTestDispWin() : FfsTestDispWin
  • FfsTestMenu() : FfsTestMenu
  • FfsTestResultsMenu() : FfsTestResultsMenu
  • FfsTestResultsSubMenu() : FfsTestResultsSubMenu
  • FfsTests() : FfsTests
  • FfsTestSubMenu() : FfsTestSubMenu
  • FfsTestThread() : FfsTestThread
  • FifoLinkedList() : FifoLinkedList< T >
  • File : File, StorageDevice
  • file_ext_substr_list : MimeTypeTableEntry
  • file_handle : VoiceMemoAudioDevice::StartParam, Mp3Param, VmParam, PcmParam
  • file_handle_size : VoiceMemoAudioDevice::StartParam
  • file_id : FfsRefType, ffs_ref_type
  • file_name : tagCustFileData, SerialIoAdapter::SioErrorDesc
  • file_number : SiProvFileRef_s
  • file_size : tagCustFileData
  • FileBinData() : FileBinData
  • FileChunkOperationProgressMsg() : FileChunkOperationProgressMsg
  • FileChunkOperator : FileChunkOperator, File
  • FileDataSink() : FileDataSink
  • FileDataSource() : FileDataSource
  • FileExist() : FfsHandler
  • FileExists() : RamHandler, FatHandler
  • FileFilter() : FileFilter
  • filehandle : HostIterStatType
  • FileInputStream() : FileInputStream
  • FileNameListBoxModel() : FileNameListBoxModel
  • FileNameView() : FileNameView
  • FileNotFound : MediaManager
  • FileOperationErrorType : AudioDeviceBase
  • FileOutputStream() : FileOutputStream
  • FilePack() : FilePack
  • FilePathname : RecordSettings
  • FileSoundDataSource : AudioReference
  • FileState() : File::FileState
  • FileVisitor() : FileVisitor
  • Fill() : MdhGors, SimImage, SimIconDescription, SimImageDescriptor
  • FillArc() : DeviceContext
  • FillCircle() : DeviceContext
  • FillHeader() : GltpRequest
  • FillIndexValues() : IndexTable< T >
  • FillPolygon() : DeviceContext
  • FillRect() : DeviceContext, VirtualDisplay
  • FillRoundRect() : DeviceContext
  • FillRWBuffer() : SimPbBaseHandler
  • FillZeroes() : IndexTable< T >
  • FilmFilter : Camera
  • filter : MdhViewConfig
  • Filter() : BtDeviceList, Cbs::Filter
  • FilterBankBlockLength : AudioEncoder
  • FilterChanged : Camera
  • FilterOperator : DualFilterProvider
  • FilterProvider() : FilterProvider
  • FilterRule() : FilterRule
  • FilterType : Camera
  • Finalize() : GuiObjectFactory
  • FinalizeBuffer() : StreamObexImpl
  • Find() : ObexHeaderList, BtDeviceList, RamHandler
  • Find2Provider() : Find2Provider
  • FindAudioDataOffset() : AudioUtility
  • FindConnectionByApoxiHandle() : BtMultiConnectionController
  • FindConnectionByDevice() : BtMultiConnectionController
  • FindConnectionByRequest() : BtMultiConnectionController
  • FindContext() : PdpContextManager
  • FindData() : MmfPlayer
  • FindDataConnProfiles() : SocketTestApp, RegAppWin
  • FindDone() : RamHandler, FatHandler
  • FindFirst() : FfsHandler, RamHandler, FatHandler
  • finding_dirs : FfsRefType, ffs_ref_type
  • FindNext() : FfsHandler, RamHandler, FatHandler
  • FindNode() : RamFileSystem
  • FindProvider() : FindProvider
  • FindReference() : DwdDevice
  • FindRow() : PbManualSynchronizer
  • FindRowByTpduNumber() : SmsProvider, SimPduHandler
  • FindSortedRow() : SortProvider
  • FindUriFromTables() : LockTableList
  • Finish() : IncrementalPdcUpdater
  • Finished : PhonebookApp
  • FinishedErr : SocketTestT
  • FinishedOK : SocketTestT
  • FinishGroup() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT
  • Finnish : LanguageManager, DataCodingScheme
  • FirmwareUpdate : ShutDown
  • First : VoiceMemoMenuAccessor, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, DataConnAccessor, TextMenuAccessor, AbstractMenuAccessor, ActionMenuAccessor, AbstractSmsViewerWin
  • first_frame : SvgImage
  • FirstAndNotSecondFilterOp : DualFilterProvider
  • FirstOnly : JoinProvider
  • FirstOrNotSecondFilterOp : DualFilterProvider
  • FirstServerId : ObexServerInfo
  • FiveMinutes : PackedTimePeriod
  • FixedPtrArray() : FixedPtrArray< T >
  • Flag : Keyboard
  • flag : FileInfo_s
  • FlagCaretaker() : FlagCaretaker
  • flags : SmsSettingsRecord::Persist
  • FlagsType : VideoDecoder
  • Flash : Sms
  • FlashDeletePdu() : StackWrapper
  • FlashDirectoryIteratorImp : FlashDirectoryIteratorImp, FlashStorageDeviceImp
  • FlashDisabled : Camera
  • FlashEnabled : Camera
  • FlashFileImp : FlashFileImp, FlashStorageDeviceImp
  • FlashNotSupported : Camera
  • FlashPreferred : Sms
  • FlashReadPdu() : StackWrapper
  • FlashStorageDeviceImp : FlashStorageDeviceImp, FlashFileImp, FlashDirectoryIteratorImp
  • FlashType : Camera, CameraOptionSettingsWin
  • FlashWritePdu() : StackWrapper
  • Flat : CTResourcePack
  • Flip : VideoChannel
  • FlipMsg() : FlipMsg
  • FliType : CameraOptionSettingsWin
  • FlowLayout() : FlowLayout
  • FlsFile : FlsFile, FlashStorageDeviceImp
  • FlsType : CameraOptionSettingsWin
  • FluorescentBalance : Camera
  • Flush() : ScicosMpeg4VideoDecoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, TraceOutputStream, OutputStream, FileOutputStream, DebugOutputStream, BufferedOutputStream, StreamWriter, StorageDevice, RamHandler, FatStorageDeviceImp, FatHandler
  • FlushBuffers() : EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Encoder, AtiMpeg4Decoder, RegMemoryPool, VideoEncoder, VideoDecoder
  • FlushDirtyFile() : DirtyFileHandler
  • FlushMapFile() : UriMappingTable
  • FM : InputParser
  • FmRadioEditWin() : FmRadioEditWin
  • FmRadioRdsAlternativeFrequenciesFeature : AudioDeviceBase
  • FmRadioRdsFeature : AudioDeviceBase
  • FmRadioRdsRadioTextFeature : AudioDeviceBase
  • FmRadioRdsRawDataFeature : AudioDeviceBase
  • FmRadioRdsStationNameFeature : AudioDeviceBase
  • FmRadioRssiLevelFeature : AudioDeviceBase
  • FmRadioSeekStationFeature : AudioDeviceBase
  • FmRadioSelectStrongerFreq() : FmRadioSelectStrongerFreq
  • FmRadioSetStationFeature : AudioDeviceBase
  • FmRadioSettingsProvider() : FmRadioSettingsProvider
  • FmRadioSettingsRecord() : FmRadioSettingsRecord
  • FmRadioSoundDataSource : AudioReference
  • FmRadioStationsProvider() : FmRadioStationsProvider
  • FmRadioStationsRecord() : FmRadioStationsRecord
  • FmRadioWindow() : FmRadioWindow
  • FmRatioSettingsRecord() : FmRadioSettingsRecord
  • Fn() : UibUpdateThreadlet, FfsTestThreadlet, UpdatePbThreadlet, SyncPhoneThreadlet, Threadlet, EncodingThreadlet, DecodingThreadlet
  • fname : HostIterStatType, FatFindData, dstat
  • FocusNextControlMsg() : FocusNextControlMsg
  • FocusObtainer : FocusObtainer, System
  • FocusPreviousControlMsg() : FocusPreviousControlMsg
  • FocusPriorityProp : GuiObjectFactory
  • FoggyPositionIndicatorView() : FoggyPositionIndicatorView
  • FoggyPushButtonView() : FoggyPushButtonView
  • FoggyTheme() : FoggyTheme
  • FoggyWindowFrameView() : FoggyWindowFrameView
  • FolderListingEntryProperties : ObexFtpServer
  • FolderListingEntryProps : ObexFtpDataServer
  • Font() : Font
  • font : tagFontPack
  • font_family : tagFont
  • FontAlign : TextFormat
  • FontAlignParseType : CTResourcePack
  • FontAlignProp : GuiObjectFactory, CTResourcePack
  • FontAlignType : GuiObjectFactory
  • FontEntry() : FontEntry
  • FontPack() : FontPack
  • FontProp : GuiObjectFactory
  • FontSize : InformationElement
  • FontSystemFontIdType : GuiObjectFactory
  • Forbidden : BtObexResponseCode
  • ForceNormalUpdateOnStartup() : SmsProvider
  • ForceWcharsTo7bitWchars() : DataCoding
  • ForegroundcolorProp : GuiObjectFactory
  • ForgetRecordingReference() : StreamAudioPlayer
  • FormAidingRequest() : GltpAidDataRequests
  • Format : RingerAudioDevice, Time, Date, CustomRingerAudioReference, ValidityPeriodFormat, WString, TimeZone, String, DateTime, StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, RamHandler, FlashStorageDeviceImp, FatStorageDeviceImp, AudioDecoder
  • format : RingerAudioDevice::StartParam, VmParam, PcmParam
  • FormatBuzzer : RingerAudioDevice, CustomRingerAudioReference
  • FormatFileSystem() : RamFileSystem
  • FormatImelody : RingerAudioDevice, CustomRingerAudioReference
  • FormatLockTableUri() : Uri
  • FormatMidi : RingerAudioDevice, CustomRingerAudioReference
  • FormatNotSupportedError : ImageEncoder
  • FormatRmd : RingerAudioDevice, CustomRingerAudioReference
  • FormatSmaf : RingerAudioDevice, CustomRingerAudioReference
  • FormatSmafPhrase : CustomRingerAudioReference
  • FormatSmafPhrase11 : RingerAudioDevice
  • FormatStorage() : RamStorageMapper
  • FormatUriHeader() : Uri
  • FormMsmtRequest() : GltpAidDataRequests
  • FormPosnRequest() : GltpAidDataRequests
  • FormQos() : LcsAppUtils, LcsUtils
  • FormRequest() : GltpPositionRequest, GltpMsmtRequest, GltpAidingRequest, GltpHelloRequest
  • ForPlmnOperatorSpecificInFutureVersionsRangeBegin : MessageIdentifier
  • ForPlmnOperatorSpecificInFutureVersionsRangeEnd : MessageIdentifier
  • ForStandardizationInFutureVersionsRange1Begin : MessageIdentifier
  • ForStandardizationInFutureVersionsRange1End : MessageIdentifier
  • ForStandardizationInFutureVersionsRange2Begin : MessageIdentifier
  • ForStandardizationInFutureVersionsRange2End : MessageIdentifier
  • forward_feature_list : InterrogateSsResult
  • forward_feature_list_size : InterrogateSsResult
  • forward_to_number : InterrogateSsResult, ForwardingFeature
  • ForwardCommandToDriver() : MapiAudioPlayer
  • ForwardedCallIncomingMsg() : ForwardedCallIncomingMsg
  • forwarding_info : ForwardingInfoReceivedArg
  • ForwardingInfoReceivedMsg() : ForwardingInfoReceivedMsg
  • ForwardingSsAction() : ForwardingSsAction
  • ForwardSms() : AbstractSmsApp, EmsApp
  • ForwAvailAborted : Sms
  • ForwAvailFailed : Sms
  • Fps10 : CamWin32, VideoCamera
  • Fps12 : CamWin32, VideoCamera
  • Fps15 : CamWin32, VideoCamera
  • Fps24 : CamWin32, VideoCamera
  • Fps25 : CamWin32, VideoCamera
  • Fps30 : CamWin32, VideoCamera
  • Fps3_7_5 : VideoCamera
  • Fps5 : CamWin32, VideoCamera
  • Fps7_5 : CamWin32, VideoCamera
  • FpsNotSupported : MediaManager
  • Fraction() : Fraction
  • frame : Led::StreamField
  • frame_rate_denominator : Media::Parameters
  • frame_rate_numerator : Media::Parameters
  • FrameArea : DrawableObject
  • FrameCodingType : VideoEncoder
  • FrameDc() : FrameDc
  • FrameLayoutHintProp : GuiObjectFactory
  • FrameRateChanged : Camera
  • FrameRateType : CamWin32, VideoCamera
  • FrameType : Control, GuiObjectFactory
  • FrameTypeProp : GuiObjectFactory
  • FrDspFormat : StreamAudioReference
  • Free() : Os, HeapVector::VarPage, HeapVector::BlockPage, HeapManager, Allocator< T >, ByteBuffer
  • FreeCaptureBuffers() : VideoCamera
  • FreeDeletionBuffer() : RegDeletionBufferEntry
  • FreeFunction : HeapVector
  • FreeImage() : PngImage, JpegImage
  • FreeNodeBuffer() : RegMemoryPool
  • FreePng() : PngDecoder
  • FreezeViewFinder() : CamWin32
  • French : LanguageManager, DataCodingScheme
  • freq : Audio::SingleTone
  • frequency : ToneAudioDevice::UserTone
  • Friday : Date
  • from : BidiManager::ParagraphContext
  • FromPtr() : WStrData, StrData
  • FromStackMsg : FromStackMsg, StackMsgArgument
  • FromUtf8ToWString() : String
  • Front() : BtDeviceList, Vector< T >
  • front() : WbxmlVector< T >
  • fsize : HostIterStatType, FatFindData, dstat
  • FSM_INTERNAL_EVENTS : ObexAbstractPort
  • FsmEngine : ObexAbstractPort
  • ftime : HostIterStatType, FatFindData, dstat
  • FtpAuthProvider() : FtpAuthProvider
  • FtpClient : FtpClient, FtpTransfer, FtpSocket, FtpServer, FtpDataSocket, FtpDataServerSocket
  • FtpConnectMessage() : FtpConnectMessage
  • FtpDataServerSocket : FtpDataServerSocket, FtpClient
  • FtpDataSocket : FtpDataSocket, FtpTransfer, FtpSocket, FtpOutTransfer, FtpInTransfer
  • FtpDisconnectMessage() : FtpDisconnectMessage
  • FtpErrorMessage() : FtpErrorMessage
  • FtpInTransfer : FtpInTransfer, FtpSocket, FtpDataSocket
  • FtpOutTransfer : FtpOutTransfer, FtpSocket, FtpDataSocket
  • FtpRequest() : FtpRequest
  • FtpRequestMessage() : FtpRequestMessage
  • FtpServer : FtpServer, FtpTransfer, FtpSocket, FtpOutTransfer, FtpInTransfer, FtpDataSocket, FtpClient
  • FtpServerConfig() : FtpServerConfig
  • FtpServerSocket : FtpServerSocket, FtpSocket
  • FtpServiceMessage() : FtpServiceMessage
  • FtpSocket : FtpSocket, FtpServer
  • FtpTransfer() : FtpTransfer
  • FtpTransferMessage() : FtpTransferMessage
  • full_refresh : SimEfRefresh
  • FullImageMetering : Camera
  • FullScreenPerItem() : ItemRendererProperties
  • FullScreenPerItemProp : GuiObjectFactory
  • FullSize : MenuProperties
  • func : MessageMap< T >
  • Func : InternalTracer
  • FuncStackTrace : InternalTracer
  • FunctionalityIndicator() : FunctionalityIndicator
  • FunctionBegin : InternalTracer
  • FunctionEnd : InternalTracer
  • FV1 : ThaiTextRenderer
  • FV2 : ThaiTextRenderer
  • FV3 : ThaiTextRenderer
  • fw_build : BtChipBmu
  • fw_patch : BtChipBmu
  • fw_revision : BtChipBmu
  • fw_varinat : BtChipBmu
Generated on Wed Jan 25 00:54:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • g_globalMask : InternalTracer
  • gap_to_next_char : FontRes, tagFont
  • GapProp : GuiObjectFactory
  • gas : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • GatiManagerInternals : GatiManager
  • General : TaggedProblemCode
  • GeneralCompoundItem() : GeneralCompoundItem
  • GeneralDataCodingGroup : DataCodingScheme
  • GeneralError : MediaManager, CodecDevice
  • GeneralErrorType : AudioDeviceBase
  • GenerateHandleId() : DwdDevice
  • GenerateMemoryConfig() : HeapManager
  • GenericAudioDevice() : GenericAudioDevice
  • GenericFastForward : AudioDeviceBase
  • GenericFeatureData() : GenericFeatureData
  • GenericGetTrackInfo : AudioDeviceBase
  • GenericObject() : GenericObject
  • GenericRewind : AudioDeviceBase
  • GenericWorkerTask : Threadlet
  • GeographicalScope : Cbs::SerialNumber
  • German : LanguageManager, DataCodingScheme
  • Get : DataConnProfileManager, DataConnManager, ObexLayer, ObexClient, TickValue, IrdaObexImpl, WindowHierarchyIterator, Control::ComponentIterator, DeviceManager::Iterator, SoftkeyBar, BtObexImpl, TypeOfAddress, NiSharedPtr< X >, BitField< T >, FunctionalityIndicator, SimSetupIdleModeTextOptions, SimSetupMenuOptions, SimSelectItemOptions, SimGetInkeyOptions, SimGetInputOptions, SimDisplayTextOptions, SimIconQualifier, SimAtom< T >, ShortMessageStatus, ShortMessageFailureCause, ProtocolIdentifier, ParameterIndicator, MessageIdentifier, MdhDeletionCmd, SimImageDescriptor, DataCodingScheme, CommandType, Cbs::SerialNumber, MePhonebookDescription, RegIterator, Registry, ObjectTreeService, LocalDataStore, StreamObexImpl, CompoundItemIterator, RegEncoderDecoder
  • GetAbortCause() : TipdBasedActiveWaitDispatcher
  • GetAbortDesc() : BtBipAbortIndArg
  • GetAborted() : BtObexClientOperationRequest
  • GetAbsBottom() : WinRect
  • GetAbsClientRect() : Control
  • GetAbsClientXPos() : Control
  • GetAbsClientYPos() : Control
  • GetAbsLeft() : WinRect
  • GetAbsoluteDateTime() : CodedTimeStamp
  • GetAbsoluteDay() : DateTime
  • GetAbsoluteDays() : TimeSpan
  • GetAbsoluteHours() : TimeSpan
  • GetAbsoluteMilliseconds() : DateTime
  • GetAbsoluteMinutes() : TimeSpan
  • GetAbsolutePath() : RfsObexFtpServer
  • GetAbsolutePathname() : HttpClient, FtpClient
  • GetAbsoluteSeconds() : TimeSpan, DateTime
  • GetAbsoluteTime() : ValidityPeriod
  • GetAbsoluteWeeks() : TimeSpan
  • GetAbsRect() : Control, WinRect
  • GetAbsRight() : WinRect
  • GetAbsTop() : WinRect
  • GetAbstractAction() : AbstractButton
  • GetAbsX() : DeviceContext
  • GetAbsXPos() : Control
  • GetAbsY() : DeviceContext
  • GetAbsYPos() : Control
  • GetAcceptAbort() : BtObexPutRequest, BtObexGetRequest, BtObexClientOperationRequest
  • GetAcceptAuthorization() : BtRespondAuthorizationRequest
  • GetAcceptPairing() : BtSendPasskeyRequest
  • GetAccessDate() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FatFileImp
  • GetAccessor() : PbAbstractWin
  • GetAccessory() : AccessoryIndMsg, AccessoryIndArg
  • GetAccessoryByCfgType() : AudioAccessoryStore
  • GetAccessoryByName() : AudioAccessoryStore
  • GetAccessoryConfigurationType() : AudioAccessoryConnectedMsg
  • GetAccessoryList() : AudioDeviceManager, AudioAccessoryStore
  • GetAccessPointId() : PdpContext
  • GetAccessPointName() : PdpContext, PdpContext::ActivationStatus
  • GetAccessTime() : File::Attributes
  • GetAccount() : DataConnProfile, PdpContext::Authentication
  • GetAccumulatedCallCcm() : MmCurrentCallMeterMsg
  • GetAccumulatedCallCharge() : MmCurrentChargeDataMsg
  • GetAcm() : SimAcmMaxUpdReqArg, SimAcmUpdReqArg, SimAcmMaxReadIndArg, SimAcmReadIndArg, SimAuxHandler, SimAccessor
  • GetAction() : UibActionAccessor, ActionExecutedMsg, ItemPropertiesChangedMsg, DispatcherAction, PushButton, AbstractButton, MenuItem, CloseAllMsg, AppActionExecutedMsg, ActionMenuAccessor, AbstractActionMenuAccessor
  • GetActionCount() : UibActionAccessor, ActionMenuAccessor
  • GetActionIndex() : UibActionAccessor, ActionMenuAccessor
  • GetActionType() : LanguageResetAction, ApoxiCommandAction, UssdAction, UndefinedSsAction, WaitSsAction, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, ColrAction, ColpAction, CnapAction, ClipAction, ClirAction, PinAction, CallSsAction, EngModeAction, ImeiShowAction, MoCallAction, UnlockAction, PbEntryShowAction, InputAction
  • GetActivationStatus() : PdpContextActivationStatusMsg, PdpContext
  • GetActiveAccessory_HighestPriority() : AudioAccessoryStore
  • GetActiveAppContainer() : System
  • GetActiveApplication() : System, AppContainer
  • GetActiveAuthorizationSet() : WapProfile
  • GetActiveBitmap() : AnimationModel
  • GetActiveCallHdl() : CallHdl
  • GetActiveDevice() : BtActiveDeviceWindow
  • GetActiveDeviceWindow() : BtApplication
  • GetActiveDuration() : Cbs::Filter
  • GetActiveExtLanguage() : SimAuxHandler, DataHandler
  • GetActiveFontIndex() : FontPackConnector, FontManager
  • GetActiveLanguage() : LanguageManager
  • GetActiveLanguageId() : TextPackConnector
  • GetActiveLanguageType() : LanguageManager
  • GetActivePhysicalPortSet() : WapProfile
  • GetActivePhysicalSet() : WapProfile
  • GetActivePortPtr() : ObexServerDispatcher, ObexClientDispatcher
  • GetActivePortSet() : WapProfile
  • GetActiveReference() : AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioRecordingStoppedMsg, AudioGetPlayPositionMsg, GenericFeatureData
  • GetActiveTab() : TabControl
  • GetActiveTheme() : ThemeManager
  • GetActiveThemeIndex() : ThemeManager
  • GetActiveView() : BrowserViewContainer
  • GetActiveWapProfileId() : WapProfileMgr
  • GetActiveWin() : PhonebookApp
  • GetActiveWord() : Zi8NoWordFoundMsg, T9NoWordFoundMsg
  • GetActualName() : AudioAccessoryDetails
  • GetAddAction() : PhonebookApp
  • GetAdditionalNames() : VCard
  • GetAdditionalOrgUnit() : VCard
  • GetAdditionalResult() : SimTkRefreshQueryResArg
  • GetAddr() : IpAddr
  • GetAddress() : ObexAbstractPort, EctActiveMsg, PdpContext, PdpContext::ActivationStatus
  • GetAddressingScheme16BitDestinationPort() : InformationElement
  • GetAddressingScheme16BitOriginatorPort() : InformationElement
  • GetAddressingScheme8BitDestinationPort() : InformationElement
  • GetAddressingScheme8BitOriginatorPort() : InformationElement
  • GetAddressType() : VCard
  • GetAddResult() : PinDisableIndArg, PinEnableIndArg
  • GetAddrPtr() : ObexAddrMsg
  • GetAdnBuffer() : UsimPbRwRecord
  • GetAdnByte() : SimInitIndArg
  • GetAdnProvider() : PbDataHandler
  • GetAdnResult() : DhChannelReceiveIndArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg
  • GetAdnTagSize() : SimPbBaseHandler
  • GetAffectedProvider() : MergeProvider
  • GetAidingData() : AidingData
  • GetAidingRequest() : GltpAidDataRequests
  • GetAlarm() : RealTimeClock
  • GetAlignInfo() : FlowLayout
  • GetAlignment() : IndicatorLocation, Indicator, DateTime
  • GetAllCallsCcm() : CurrentCallMeterMsg, ChargeUnitsIndArg
  • GetAllCallsCharge() : CurrentChargeDataMsg, ChargeIndArg
  • GetAllItems() : DBService
  • GetAllocatedSize() : RamFileObj
  • GetAllocatedSuspendSlot() : DwdPlayer
  • GetAlpha() : Color, XCallInfoResponseParser
  • GetAlphabet() : PhoneNumberInputMapper, NumericInputMapper, MultiTapInputMapper, IpAddrInputMapper, InputMapper, EditorDocument, DateTimeInputMapper, CalculatorInputMapper, DataCodingScheme, EnglishT9InputMapper, ChineseT9InputMapper
  • GetAlphaBitCount() : ColorSegmentation
  • GetAlphaBlendingMode() : DeviceContext, VirtualDisplay
  • GetAlphaId() : AtAlphaTagCnfArg
  • GetAlphaIdentifier() : SsInfoMsg, CallHdl, SsFacilityIndArg, CallIndCallControlInfoArg, AtPbListCnfArg
  • GetAlphaIdLength() : SimSmsParamHandler
  • GetAlphaLength() : PbEntryReadIndArg
  • GetAlphaMask() : Bitmap, BitmapRes
  • GetAlphaSize() : UsimSmsParamReadIndArg
  • GetAlphaTagSize() : SimPbBaseHandler, PbBaseProvider
  • GetAlphaValue() : Bitmap
  • GetAnimType() : ItemRendererProperties
  • GetAnrRecordNo() : UsimPbRefRecord
  • GetAntiFlicker() : CameraSettings
  • GetAntiFlickerMode() : Camera
  • GetAocChargingStatus() : MmAocChargingStatusMsg
  • GetAPart() : IpAddr
  • GetApduDataPtr() : ExtProactiveCmdIndArg, ExtProactiveCmdReqArg, SimGenericReqArg, SimGenericIndArg
  • GetApiDeviceAddress() : BtDeviceAddress
  • GetApiSettings() : BtConnectRequest, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest
  • GetApn() : DhChannelOpenReqArg, SiChannelOpenPromptReqArg
  • GetApnName() : PsdDataConnProfile
  • GetApoxiHandle() : BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtMultiConnectionController::BtConnection
  • GetApoxiKeyCode_Hash() : T9InputMapper
  • GetApoxiKeyCode_Menu() : T9InputMapper
  • GetApoxiKeyCode_Star() : T9InputMapper
  • GetApoxiToneID() : AudioPreset
  • GetAppContainer() : Application
  • GetAppContext() : AbstractScheduler
  • GetAppFeatureID() : FeatureHandle
  • GetAppHdl() : BtAvrcpNmaDisconnect
  • GetApplication() : PbSynchronizer, ContextMsg, ApplicationListEntry, AbstractAppContext, Control, Feature, AtlApplicationPlugin, MainHandlerAccess, HttpServer, HttpApplicationSupplier, ApplicationAction, DataControlModificationMsg
  • GetApplicationCount() : HttpApplicationSupplier
  • GetAppName() : Application
  • GetAppPtr() : ObexDispatcher, AbstractTransport, NotificationTableEntry
  • GetAppStackBase() : AppContext
  • GetAppStackSize() : AppContext
  • GetAppTemplates() : VrHandler
  • GetArchiveProvider() : AbstractSmsApp
  • GetArg() : SmsServiceDocumentMsg, SmsServiceMsg, SharedTimerMsg, BatteryLoadLevelMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, UssdIndicationMsg, SsErrIndicationMsg, SsRejectedMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, TermRspCnfMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetConfirmationMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg, ToStackMsg, FromStackMsg
  • GetArrivedProvider() : AbstractSmsApp
  • GetArrowDown() : KeyboardConfig
  • GetArrowLeft() : KeyboardConfig
  • GetArrowRight() : KeyboardConfig
  • GetArrowUp() : KeyboardConfig
  • GetAsWString() : Property
  • GetAt() : SortedElementList< T >, ElementList< T >, ElementListBase
  • GetAtMode() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • GetAttachedSerialSocket() : SerialSocketData
  • GetAttachedSocket() : SocketData
  • GetAttachmentDesc() : BtBipPutLinkedAttachmentIndArg
  • GetAttachmentList() : BtBipImageProperties
  • GetAttachStatus() : GprsAttachStatusMsg, PdpContextManager
  • GetAttributeById() : BtSddbServiceRecord
  • GetAttributeId() : BtSvrServiceAttribute, BtSddbServiceAttribute
  • GetAttributes() : File, RootFileImp, RamHandler, RamFileObj, RamFileImp, FlashFileImp, FatHandler, FatFileImp
  • GetAttributesRequested() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetAttributeValue() : BtSvrServiceAttribute, BtSddbServiceAttribute
  • GetAudioAlwaysOnAccessory() : BtAudioAccessoryService
  • GetAudioBufferFunction : StreamAudioReference
  • GetAudioChannelId() : AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, AudioDecoderRenderer, AudioCapturerEncoder
  • GetAudioDeviceToneId() : AudioTone
  • GetAudioDeviceToneRef() : AudioTone
  • GetAudioError() : AudioErrorMsg
  • GetAudioErrorType() : AudioStoppedMsg
  • GetAudioInfo() : MediaInfo
  • GetAudioInfoCount() : MediaInfo
  • GetAudioPathType() : AudioPath
  • GetAudioPlayer() : AudioDeviceManager
  • GetAudioRef() : VoiceMemoRecordWin
  • GetAudioReference() : AudioErrorMsg, AudioActiveReference, AudioItem, MediaPlayer
  • GetAudioSourceType() : AudioPath
  • GetAudioStreamInfo() : EmzMp3Decoder, EmzAacDecoder
  • GetAudioTrackInfo() : MmfPlayer
  • GetAuthentication() : PdpAuthTable
  • GetAuthenticationMethod() : WapProfile
  • GetAuthenticationPassword() : WapProfile
  • GetAuthenticationUsername() : WapProfile
  • GetAuthProvider() : Server
  • GetAuthType() : PdpAuthTable, PsdDataConnProfile
  • GetAutorepeatDelay() : KeyboardConfig
  • GetAutorepeatInterval() : KeyboardConfig
  • GetAvailableByteCount() : StreamingReadInfo
  • GetAvailableCount() : SocketPeer
  • GetAvailableHW() : MiscAudioDevice
  • GetAvailableSuspendSlot() : DwdPlayer
  • GetAvrcpAppReference() : SubUnitReference
  • GetAvrcpOperationService() : SubUnitReference
  • GetAvState() : IrdaTransport, AbstractTransport, BtTransport, UsbTransport
  • GetBack() : EmzUtils::Queue< T >, LinkedListBase
  • GetBackgroundColor() : ItemRendererProperties, RichTextCompoundItem, MultiMediaEditor
  • GetBackgroundImage() : ItemRendererProperties
  • GetBackKey() : KeyboardConfig
  • GetBacklightMode() : DefaultDisplay, Display, DefaultDisplay
  • GetBacklog() : ServerConfig, Server
  • GetBackup() : BtObexSetPathRequest, BtObexServerSetPathIndicationEvent
  • GetBackupFileId() : UriMappingTable
  • GetBalance() : AudioReference
  • GetBandLimits() : RadioAudioDevice
  • GetBaseInformationElement() : CompoundSmsItem
  • GetBaseline() : RomFont, FontManager, FontEntry, Font
  • GetBaseRow() : Provider, AbstractDelegationProvider
  • GetBasicService() : StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg
  • GetBasicServiceList() : CallBarringStatusMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg
  • GetBasicServiceMmiCode() : InputParser, WaitSsAction, ForwardingSsAction, BarringSsAction
  • GetBasicServiceMmiCodeString() : InputParser
  • GetBatteryLoadLevel() : StatusProvider, DataHandler
  • GetBatteryVoltage() : Charger
  • GetBCD() : PhoneNumber
  • GetBCDLength() : PhoneNumber
  • GetBcdPlmn() : SimMccMncIndArg, SimAuxHandler
  • GetBcdPlmnwAct() : SimAuxHandler
  • GetBdnByte() : SimInitIndArg
  • GetBdnProvider() : PbDataHandler
  • GetBdnState() : BdnReqArg, BdnIndArg, SimAccessor
  • GetBdnTagSize() : SimPbBaseHandler
  • GetBearerDesc() : DhChannelOpenCnfArg, DhChannelOpenReqArg
  • GetBearerList() : SimLaunchBrowserReqArg
  • GetBearerType() : SiChannelOpenPromptReqArg
  • GetBehavior() : AbstractListBox
  • GetBehaviour() : GridModel
  • GetBinData() : AmrSound, EmsImage, NativeImage, Image, EncodingThreadlet, Sound, SmafSound, MidiSound, IMelody, SvgImage, WbmpImage, PngImage, JpegImage, GifImage, BmpImage, Media
  • GetBipResult() : BtBipClientService
  • GetBit() : DynamicBitVector, BitVector< N >, BitField< T >, Sms
  • GetBitmap() : Zi8InputConfig, T9InputConfig, Theme, ImageObtainer, ImageBox, AbstractButton, FoggyTheme, DefaultTheme, CustomizableTheme, VirtualDisplay, Display::CustomFrameBuffer, VirtualDisplay
  • GetBitNumber() : SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • GetBitrate() : MediaInfo::MediaTrackInfo
  • GetBits() : Bitmap, BitmapRes
  • GetBitsPerPixel() : DisplayConfig, Image, Image::MetaData
  • GetBitValue() : SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • GetBlinkRate() : EditConfig
  • GetBlitRect() : VirtualDisplay, Display::CustomFrameBuffer, VirtualDisplay
  • GetBlobFileNodePayload() : RegNodeBuffer
  • GetBlobObject() : Cbs
  • GetBlobPayload() : RegNodeBuffer
  • GetBlock() : RamStorageMapper
  • GetBlockCount() : RamFileObj
  • GetBlockDataOffSet() : DrmDcfParser
  • GetBlockInfo() : NvRamStorage
  • GetBlockNo() : HeapVector::VarPage
  • GetBlockSize() : RamStorageMapper
  • GetBlue() : ColorTable, Color
  • GetBlueBitCount() : ColorSegmentation
  • GetBmpIterator() : Animation, AnimationModel
  • GetBody() : HttpResponse, HttpRequest
  • GetBoolean() : DataItem, Property
  • GetBooleanPayload() : RegNodeBuffer
  • GetBoolOption() : InetSocket
  • GetBootControl() : DataControl
  • GetBootState() : DataControlEndBootMsg, DataControlBootMsg
  • GetBopomofoList() : ChineseT9Wrapper
  • GetBorderSize() : TabControlView
  • GetBottom() : Rect, WinRect
  • GetBottomLineGap() : ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor
  • GetBottomSize() : ControlFrameView
  • GetBoundingRect() : PaneObject, Component
  • GetBounds() : DisplaySettings
  • GetBoxType() : UibRegisterMsg
  • GetBPart() : IpAddr
  • GetBpp() : SimImage
  • GetBppSubState() : BtBppSndFilePushReqRequest
  • GetBrightness() : CameraSettings, DefaultDisplay, Display, Camera, DefaultDisplay, RecordSettings
  • GetBrightnessLimits() : Camera
  • GetBroker() : ServiceBroker
  • GetBrush() : DeviceContext
  • GetBrushColor() : DeviceContext
  • GetBrushColorValue() : DeviceContext
  • GetBrushStyle() : DeviceContext
  • GetBtAddress() : BtJsr82Url
  • GetBtapiHdl() : BtAvrcpNmaConnect
  • GetBtApoxiAvrcpSubunitInfo() : BtAvrcpPanelApplication
  • GetBtChannel() : BtJsr82Url
  • GetBtService() : BtJsr82Url
  • GetBuffer() : OnDataRcvdMsg, AtiAudioCapturerEncoder, AbstractEditBox, AbstractEditBoxModel, RomData, RamData, BufferPoolManager, StreamAudioReference, AudioFmRadioRdsRawDataMsg, CustomToneAudioReference, CustomRingerAudioReference, GltpAssistanceData, AudioCapturerEncoder
  • GetBufferByteCount() : Bitmap
  • GetBufferInfo() : AtiAudioPlayerRtStreamingSink, RtStreamingSink
  • GetBufferLength() : DataCoding
  • GetBufferPoolStatus() : BufferPoolManager
  • GetBufferSize() : AudioFmRadioRdsRawDataMsg, CustomRingerAudioReference, DhChannelOpenCnfArg, DhChannelOpenReqArg
  • GetBufferSizes() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • GetBufSize() : WStrData, StrData
  • GetBuildDate() : VersionInfo
  • GetByte() : SsStatus, SsNotification, SsErrorCode
  • GetBytesProcessed() : BtBipProgressMsg
  • GetCacheSize() : MergeProvider
  • GetCalendarAddWin() : CalendarMonthWin
  • GetCalendarListWin() : CalendarMonthWin
  • GetCalendarProvider() : CalendarApp
  • GetCalendarRecord() : CalendarRecordsListBoxModel
  • GetCall() : CallHoldRejectedMsg, CallOnHoldMsg
  • GetCallAction() : PhonebookApp
  • GetCallbackFunctionPointers() : BtController, BtConnectionlessController, BtConnectionBasedController
  • GetCallBarringFeatures() : CallBarringDeactivatedMsg, CallBarringActivatedMsg
  • GetCallBarringInfo() : SsBarringIndArg
  • GetCallBarringStatus() : SsHandler
  • GetCallClearingCause() : NwDiscStartIndMsg
  • GetCallControlResult() : SsInfoMsg, CallHdl, SsFacilityIndArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, CallIndCallControlInfoArg
  • GetCallCount() : CallHdlBase
  • GetCallDataMutex() : MainHandler
  • GetCallDirection() : XCallInfoResponseParser, MmCallInfo
  • GetCallDiscCause() : CallHoldRejArg, CallDiscReqArg, CallRelIndArg, CallDiscIndArg
  • GetCallDispatcher() : CallHandler
  • GetCallDuration() : MptyCallHdl, CallHdlBase, CallHdl, MmCallHdl
  • GetCallDurationInSecs() : MmCallDisconnectingMsg
  • GetCalledPartyNo() : RedialSetupIndArg
  • GetCalledPartyNumber() : CallControlSetupIndArg
  • GetCallErrorCause() : CallIndArg
  • GetCallEstablishedInfoAlpha() : SimTkCallSetupIndArg
  • GetCallEstablishedInfoIcon() : SimTkCallSetupIndArg
  • GetCallEstCause() : MocSetupReqArg
  • GetCallEvent() : BtHsNmaCallEvent, BtHfNmaCallEvent
  • GetCallForwardingStatus() : SsHandler
  • GetCallHandlingData() : MainHandler
  • GetCallHdl() : CtmInfoIndMsg, NwDiscStartIndMsg, CallControlInfoMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, CallNotifyMsg, MptyCallReleaseMsg, CallReleaseMsg, CallAcceptMsg
  • GetCallId() : XCallInfoResponseParser, MmCallInfo
  • GetCallIdx() : CallSsAction
  • GetCallIndex() : MptyCallHdl, CallHdlBase, CallHdl, MmCallReleaseMsg, MmCallAcceptMsg, MmAocChargingStatusMsg, MmCurrentCallMeterMsg, MmCurrentChargeDataMsg, MmCallNotifyMsg, MmCallInfoMsg, MmCallStatusMsg, MmCallInfo, MmCallHdl
  • GetCallInfoAlpha() : SimTkCallSetupIndArg
  • GetCallInfoIcon() : SimTkCallSetupIndArg
  • GetCallLine() : CallHdl, MtcSetupIndArg, MocSetupReqArg, CallIndArg
  • GetCallMode() : XCallInfoResponseParser
  • GetCallProgressInd() : CallProgressIndArg
  • GetCallRefuseDirection() : RejectCallsIndArg
  • GetCallRelatedSs() : CallRelatedSsReqArg, CallDeflectSsReqArg
  • GetCallSsActionId() : CallSsAction
  • GetCallState() : CallIndArg, MmCallInfoMsg, MmCallInfo
  • GetCallType() : CallTypeTable, CsdDataConnProfile, CallHdl, MtcSetupComplArg, MtcSetupIndArg, CallIndArg, XCallInfoResponseParser, MmCallInfoMsg, MmCallHdl
  • GetCallVolume() : AudioUtility
  • GetCallWaitingStatus() : SsHandler
  • GetCameraNightMode() : RecordSettings
  • GetCameraReference() : CameraApp
  • GetCancelableRequest() : BtRequestRunningWindow
  • GetCancelKey() : KeyboardConfig
  • GetCandCharCount() : Zi8Wrapper
  • GetCandidatesBuffer() : Zi8Wrapper
  • GetCanonicalProfileId() : DataConnProfileManager
  • GetCapabilities() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, Stream, MediaManager, MediaFrameworkCaps, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoder
  • GetCapacity() : AbstractSmsApp, ObexBuffer, ByteBuffer, RtStreamingBuffer
  • GetCapacityStatus() : Charger
  • GetCapsStatus() : Zi8PredictiveInputBox, Zi8InputMapper, T9PredictiveInputBox, AbstractPredictiveInputBox
  • GetCaption() : RadioButtonModel, CheckBoxModel, AbstractEditBox, AbstractEditBoxModel
  • GetCaptionGap() : AbstractEditBoxView
  • GetCaptionHeight() : AbstractEditBoxView
  • GetCaptionType() : AbstractEditBoxModel
  • GetCaptionWidth() : AbstractEditBoxView
  • GetCaptureTransformation() : Camera
  • GetCardType() : UsimCardTypeReadIndArg
  • GetCaret() : MultiTapInputMapper, InputMapper, AbstractEditor
  • GetCaretIndex() : AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor
  • GetCategory() : CalendarRecord, AbstractDevice
  • GetCause() : SsWaitDispatcher, StackSsRejectedMsg, SsRequestRejectedMsg, SsFacilityRejectedMsg, MocSetupRejectIndMsg, CallHoldRejectedMsg, SimCallSetupRejectedMsg, SimTkSendDtmfEndIndArg, DetachCnfArg, AttachRejArg, NRegStateIndArg, MocSetupRejIndArg, CallSetupBySimtTkReqArg, StartDtmfRejArg
  • GetCbFunction() : NotificationTableEntry
  • GetCbmi() : SimAuxHandler, SimAccessor
  • GetCbmiData() : SimCbmiUpdReqArg, SimCbmiReadIndArg
  • GetCbmiFileLength() : SimAccessor
  • GetCbmir() : SimAccessor
  • GetCbmiRange() : SimCbmirUpdReqArg, SimCbmirReadIndArg, SimAuxHandler
  • GetCbmirFileLength() : SimAccessor
  • GetCbs() : CbsNewDataIndArg
  • GetCbsFilterList() : CbsHandler, CbsDispatcher
  • GetCbsWchars() : DataCoding
  • GetCcbsAction() : SsCcbsResultIndArg
  • GetCcbsEntry() : SsCcbsReCallIndArg
  • GetCcbsStatus() : CcbsStatusMsg, SsCcbsResultIndArg, SsCcbsStatusIndArg
  • GetCcp() : SimAuxHandler
  • GetCcpData() : SimCcpUpdReqArg, SimCcpReadIndArg
  • GetCcPerformed() : XCallInfoResponseParser
  • GetCellCount() : CalendarMonthSelector, CalendarGrid, AbstractItemGrid, AbstractGrid, Menu
  • GetCellHeight() : CalendarMonthSelector, CalendarGrid, AbstractItemGrid, AbstractGrid, Menu, GridView
  • GetCellIcon() : UibListBoxModel, DataConnLbModel, CalendarRecordsListBoxModel, PbProvColListBoxModel, PbProvListBoxModel
  • GetCellId() : CellInfoIndArg
  • GetCellRect() : AbstractGrid, GridView
  • GetCellSize() : Layouter, GridLayout
  • GetCellText() : UibListBoxModel, FileNameListBoxModel, ImageViewListBoxModel, FileNameListBoxModel, EmsInsertPromptListBoxModel, DataConnLbModel, CalendarRecordsListBoxModel, PbProvListBoxModel
  • GetCellWidth() : CalendarGrid, AbstractGrid, Menu, GridView
  • GetCellXPos() : GridView
  • GetCellYPos() : GridView
  • GetCenterBounds() : Desktop
  • GetCenterXpos() : Zi8AlphabetBox
  • GetCertBuffer() : SimMexeCertificate
  • GetCertLength() : MexeDescriptor
  • GetCertOffset() : MexeDescriptor
  • GetCertSize() : SimMexeCertificate
  • GetCertType() : SimMexeCertificate, MexeDescriptor
  • GetCfuDataSource() : CfuServiceArray
  • GetCfuService() : CfuServiceArray
  • GetCfuServiceArray() : CfuStatusMsg, CfuDataIndArg, StatusProvider, DataHandler
  • GetCfuServiceCode() : CfuService
  • GetChangedState() : DhChannelChangeStatusEventArg, DhChannelDataAvailEventArg, SimMruPropertyUpdCnfArg
  • GetChannel() : ObexMsg, ObexAbstractPort, AudioReference
  • GetChannelData() : DhChannelReceiveIndArg, DhChannelSendReqArg
  • GetChannelDataLength() : DhChannelDataAvailEventArg, DhChannelReceiveReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg
  • GetChannelId() : TimeFeatureObject
  • GetChannelMode() : XCallInfoResponseParser
  • GetChannelMuteState() : RadioAudioDevice
  • GetChannelVolume() : CustomSmafPhraseAudioReference, AudioReference
  • GetChar() : CharInputMapItem, CharItem, AbstractEditBox, AbstractEditBoxModel
  • GetCharacter() : InputCharMsg
  • GetCharactersPerSegment() : SmsComposeWin
  • GetChargerMsgType() : ChargerInfoMsg
  • GetCharItem() : AbstractMultiLineEditor, MultiMediaEditor
  • GetCharset() : BtBipAttachmentDesc, BtBipAttachment, BtBipAttachmentFormat
  • GetCharType() : BidiManager
  • GetCheckBoxListView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetCheckBoxView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetChild() : MenuAccessor, AbstractActionMenuAccessor
  • GetChildFileId() : UriMappingTable
  • GetChildKeyColumnId() : MergeProvider
  • GetChildName() : Uri
  • GetChildProvider() : AbstractDelegationProvider
  • GetChildRow() : SmsFolderProvider, SmsBasicProvider, PbSimProvider, PbNameNumberProvider, PbNumberFilterProvider, PbDetailProvider, SortProvider, Provider, FindProvider, FilterProvider, DistinctProvider, AbstractDelegationProvider, MergeProvider, AppendProvider
  • GetChineseCandidate() : Zi8Wrapper
  • GetChineseKeyBufLen() : ChineseT9Wrapper
  • GetChineseMode_IsAmbiguousPhonetic() : ChineseT9Wrapper
  • GetChineseMode_IsAutoSpell() : ChineseT9Wrapper
  • GetChineseMode_IsComponents() : ChineseT9Wrapper
  • GetChineseMode_IsCUdbSearchOnly() : ChineseT9Wrapper
  • GetChineseMode_IsExplicitPhonetic() : ChineseT9Wrapper
  • GetChineseMode_IsExplicitPhoneticContinualSelection() : ChineseT9Wrapper
  • GetChineseMode_IsFuzzyPinyin() : ChineseT9Wrapper
  • GetChineseMode_IsStroke() : ChineseT9Wrapper
  • GetChineseSelectPage() : ChineseT9Wrapper
  • GetChineseSelectPageNum() : ChineseT9Wrapper
  • GetChipVersion() : BtLocalSettings
  • GetChunkSize() : File
  • GetChv() : PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvVerifyReqArg
  • GetChvAction() : ChvChangedMsg, ChvRefreshIndArg
  • GetChvAttempts() : ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg
  • GetChvData() : SimChvHandler
  • GetChvno() : ChvChangedMsg, PinDisableReqArg, PinEnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg
  • GetChvNo() : PinAction, SimFileInfoIndArg
  • GetCidx() : DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg
  • GetCipherSuiteName() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • GetClassType() : StreamAudioReference, PresetAudioReference, CustomToneAudioReference, CustomSmafPhraseAudioReference, CustomRingerAudioReference, AudioReference, AudioActiveReference, MapiAudioReference
  • GetClearAllKey() : KeyboardConfig
  • GetClearingCause() : XCallInfoResponseParser
  • GetClearingState() : XCallInfoResponseParser
  • GetClient() : MmiSimClient, ClientDeregistrationArg, ClientRegistrationArg, Server, HttpServer, FtpServer
  • GetClientAddrTypeId() : ObexAbstractTransport
  • GetClientCount() : Server
  • GetClientHeight() : Control
  • GetClientId() : LcsAppTransferLocMsg, HttpDisconnectMessage, HttpRequestMessage, FtpDisconnectMessage, FtpTransferMessage, FtpRequest
  • GetClientInfo() : LocationNotifInvokeMsg, LocationNotifInvokeArg
  • GetClientRect() : Window, GridLayout, Control
  • GetClientSecurity() : BtObexServiceTable::ServiceInfo
  • GetClientSize() : Control
  • GetClientWidth() : Control
  • GetClientXPos() : Control
  • GetClientYPos() : Control
  • GetClipInfo() : MediaInfo
  • GetClippedWidth() : TabButtonView
  • GetClipRect() : DeviceContext
  • GetClipStatus() : SsHandler
  • GetCliRestrictionOption() : ClirStatusMsg
  • GetClirMode() : CallHdl, MocSetupReqArg, MmCallHdl
  • GetClirPhoneNumber() : ClirAction
  • GetClirStatus() : SsHandler
  • GetCliValidity() : XCallInfoResponseParser
  • GetCloseCause() : SiChannelCloseInfoIndArg
  • GetCloseKey() : KeyboardConfig
  • GetClusterSize() : StorageDevice
  • GetClutBuffer() : SimImage
  • GetClutBufferLength() : SimImage
  • GetClutLocation() : SimImage
  • GetCmd() : AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtGenericCmdReqArg, HttpErrorMessage, HttpServiceMessage, FtpErrorMessage, FtpServiceMessage, FtpRequest
  • GetCmdQualifier() : DhChannelOpenReqArg
  • GetCmi() : SimAuxHandler, SimAccessor
  • GetCmiCount() : SimAccessor
  • GetCmiRecord() : SimCmiReadIndArg
  • GetCmiRecordNo() : SimPbEntry
  • GetCnapName() : CnapInfoReceivedMsg
  • GetCnfArg() : EngineeringModeControlResponseMsg
  • GetCode() : PackedTimePeriod, SsErrorCode, HttpErrorMessage, FtpErrorMessage
  • GetCodeAsByte() : TaggedProblemCode
  • GetCodedAlphaFieldLen() : AlphaCoding
  • GetCoding() : SimImage
  • GetColId() : ProviderListBoxModel
  • GetColor() : Pen, Brush, AbstractTextObject, VirtualDisplay
  • GetColorCount() : ColorTable
  • GetColorSegmentation() : DisplayConfig
  • GetColorSpace() : Image::MetaData
  • GetColorTable() : DisplayConfig, ResourceManager
  • GetColorValue() : System, Pen, Brush, VirtualDisplay
  • GetColpStatus() : SsHandler
  • GetColrStatus() : SsHandler
  • GetColTitleHeight() : GridView
  • GetColumn() : Caret, Cell
  • GetColumnCount() : CalendarMonthSelector, CalendarGrid, ItemTree, ItemRendererProperties, ItemGrid, GridLayout, AbstractGrid, MenuAccessor, Menu, AbstractMenuAccessor
  • GetColumnId() : PbSimProvider, PbProvColListBoxModel, PbProvListBoxModel, PbDetailListBoxModel, Provider
  • GetColumnInfo() : PbSimProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider
  • GetColumnInfoPerId() : PbSimProvider, Provider
  • GetCommand() : AragonMsg, VrHandler, VrResultMsg
  • GetCommandData() : SmsCommand
  • GetCommandDetails() : SimLaunchBrowserReqArg
  • GetCommandId() : ApoxiCommandAction
  • GetCommandString() : ApoxiCommandAction
  • GetCommandTemplates() : VrHandler
  • GetCommandType() : SmsContext, SmsCommand
  • GetCompanyId() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • GetCompatibilitySettings() : AudioAccessoryDetails
  • GetComplete() : MdhSmsUpdStatusReqArg
  • GetCompleteVisibleRowCount() : AbstractGrid
  • GetComponent() : DeleteComponentMsg, RefreshComponentMsg, InvalidateMsg, Control
  • GetComponentsSize() : Panel
  • GetComposeWin() : SmsEditor
  • GetCompoundItem() : EditorItemNode, TimeEditorDocument, TextEditorDocument, EditorDocument, DateEditorDocument, ParagraphCompoundItem, MultiMediaEditorDocument, CompoundItemReferrer
  • GetCompoundItemCount() : EditorDocument, ParagraphCompoundItem, MultiMediaEditorDocument
  • GetCompoundItemIndex() : ParagraphCompoundItem, MultiMediaEditorDocument
  • GetConcatenatedReferenceNoType() : SmsContext
  • GetConcatenatedSm16BitMaximumNumber() : InformationElement
  • GetConcatenatedSm16BitReferenceNumber() : InformationElement
  • GetConcatenatedSm16BitSequenceNumber() : InformationElement
  • GetConcatenatedSm8BitMaximumNumber() : InformationElement
  • GetConcatenatedSm8BitReferenceNumber() : InformationElement
  • GetConcatenatedSm8BitSequenceNumber() : InformationElement
  • GetConcatenetedStatus() : TpduHeaderInformation
  • GetConcatenetedTpduNum() : TpduHeaderInformation
  • GetConcMaxNo() : PortHeaderInformation, TpduHeaderInformation
  • GetConcRefNo() : PortHeaderInformation, TpduHeaderInformation
  • GetConcSeqNo() : PortHeaderInformation, TpduHeaderInformation
  • GetConcSmsPduMaxNo() : SimPduHandler, DataHandler
  • GetConditionTimer() : ForwardingSsAction
  • GetConfigStream() : ScicosMpeg4VideoEncoder, EmzMpeg4Encoder, AtiMpeg4Encoder, EmzMpeg4Encoder, VideoEncoder
  • GetConfigurationType() : AudioAccessoryDetails
  • GetConfigValues() : GltpProviderImpl
  • GetConfirmKey() : KeyboardConfig
  • GetConn() : RtStreamingEndPoint
  • GetConnApplication() : DataConnWin
  • GetConnectableMode() : BtLocalSettings
  • GetConnected() : AudioAccessoryDetails
  • GetConnectedAccessories() : AudioAccessoryDetails
  • GetConnectedDevice() : BtSingleConnectionController
  • GetConnectedNo() : MtcSetupIndArg, MocSetupCnfArg
  • GetConnectedToPhoneNumber() : CallHdl, MmCallHdl
  • GetConnectionElement() : DataCallContext
  • GetConnectionId() : ObexServer, ObexClient
  • GetConnectionInfo() : UsbTransport
  • GetConnectionOnlyDuringCall() : BtHsService
  • GetConnectionParameters() : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • GetConnIdHttp() : HttpHandler
  • GetConnIdWap() : WapHandler
  • GetConnState() : IrdaTransport
  • GetConnStatusHttp() : HttpWapMgr, HttpHandler
  • GetConnType() : FtpDisconnectMessage
  • GetConstraint() : DrmPermission
  • GetConstraintDefaultValue() : DrmPermission
  • GetConstraintsCount() : DrmPermission
  • GetConsumeLastKey() : KeySequenceCandidate, KeySequence
  • GetContainerId() : FeatureItemContainer
  • GetContent() : TRadioButtonItem< Content >
  • GetContentId() : DrmDcfParser
  • GetContentLeft() : AbstractMultiLineEditor
  • GetContentType() : DrmDcfParser
  • GetContext() : SocketData, ObexDispatcher, ContextMsg, AppContainer, ApoxiThread, PdpContextControl, SerialSocketData
  • GetContextControl() : PdpContextManager
  • GetContextDataItem() : UibApp, SoundBrowserApp, ImageBrowserApp, AtlApplication
  • GetContextDesc() : ContextManager
  • GetContextId() : PropertyDescriptor, AtlItemGridWindow, FeatureItemContainer, FeatureItem, ContextManager, ContextDescription, AtlWindow, AtlApplication, ExternalPdpContextInfoMsg, PdpContextActivationStatusMsg
  • GetContextItem() : ContextFeatureItem, ContextFeatureTriggerMsg, UpdateContextItemMsg
  • GetContextManagerControl() : PdpContextManager
  • GetContextMenu() : ContextMenuClosedMsg
  • GetContextState() : ExternalPdpContextInfoMsg
  • GetContextType() : ContextFeatureItem, ContextFeature
  • GetContinue() : AudioReference, MediaPlayer
  • GetContrast() : CameraSettings, DefaultDisplay, Display, Camera, DefaultDisplay, RecordSettings
  • GetContrastLimits() : Camera
  • GetControl() : ControlMsg, DeviceContext
  • GetControlFrameView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetControlInfo() : UssdNotifyMsg, UssdRequestMsg
  • GetControlInfoString() : UssdAnswerMsg
  • GetControlType() : SocketControlMsg, BtAvrcpRawFrameParams
  • GetConvertedPositions() : BidiManager
  • GetConvertedText() : BidiManager
  • GetCorner() : MenuProperties
  • GetCount() : ObexTransportSet, IndexTable< T >, FixedPtrArray< T >, DrmAsset, SimAcmReadIndArg, PbCountIndArg, MePhonebookDescription, CompoundItemReferrer, DrmRightsObjectContainer, DrmConstraint
  • GetCountConstraint() : DrmRightsObject, DrmPermission
  • GetCountry() : VCard
  • GetCountryListCc() : StackWrapper
  • GetCountryListLength() : StackWrapper
  • GetCountryListMcc() : StackWrapper
  • GetCountryListName() : StackWrapper
  • GetCPart() : IpAddr
  • GetCphsCfuf() : SimAccessor
  • GetCphsCfufArray() : CphsCfufUpdReqArg, CphsCfufReadIndArg
  • GetCphsCsp() : SimAccessor
  • GetCphsCspArray() : CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspReadIndArg
  • GetCphsIndexLevelIndicator() : SimPbEntry
  • GetCphsInfoNoTagSize() : SimPbBaseHandler
  • GetCphsIst() : SimAccessor
  • GetCphsIstArray() : CphsIstReadIndArg
  • GetCphsMBoxTagSize() : SimPbBaseHandler
  • GetCphsOnm() : SimAccessor
  • GetCphsOnmName() : CphsOnmReadIndArg
  • GetCphsOns() : SimAccessor
  • GetCphsOnsName() : CphsOnsReadIndArg
  • GetCphsPhase() : SimCphsHandler
  • GetCphsStatus() : SimPbEntry
  • GetCphsVmwf() : SimAccessor
  • GetCphsVmwfArray() : CphsVmwfUpdReqArg, CphsVmwfReadIndArg
  • GetCreate() : BtObexServerSetPathIndicationEvent
  • GetCreated() : BtBipAttachmentDesc, BtBipImage
  • GetCreateDate() : BtBipAttachment
  • GetCreatedFrom() : BtBipImageHdlDesc
  • GetCreateDirectory() : BtObexSetPathRequest
  • GetCreatedTo() : BtBipImageHdlDesc
  • GetCreateEmptyObject() : BtObexPutRequest, BtObexDataBufferIndicationEvent
  • GetCreateTrust() : BtRespondAuthorizationRequest, BtDevicePairRequest
  • GetCreationDate() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FlashFileImp, FatFileImp
  • GetCreationTime() : File::Attributes
  • GetCreationTimestamp() : RamFile, FatFile
  • GetCrss() : MptyCnfArg
  • GetCrssCode() : MtcSetupComplArg, MocSetupCnfArg
  • GetCrssState() : CallHoldRejArg, CallHoldCnfArg, XCallInfoResponseParser
  • GetCsdDialError() : DataConnInfoMsg
  • GetCsdError() : DataConnInfoMsg
  • GetCString() : WString, String
  • GetCtmStatus() : XCallInfoResponseParser
  • GetCtrlInfo() : SsUssdReqArg, SsSendReqArg
  • GetCtrlInfoString() : UssdAnswerIndArg, SsUssdIndArg, SsUnstructIndArg
  • GetCts() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetCug() : MocSetupReqArg
  • GetCugIndex() : CugCallMsg
  • GetCurApplicationID() : _ApplicationTracer, _NullApplicationTracer
  • GetCurrencySymbol() : Locale
  • GetCurrentCallCcm() : MmCurrentCallMeterMsg
  • GetCurrentCallCharge() : MmCurrentChargeDataMsg
  • GetCurrentCallMeter() : CallHdl, MmCallHdl, MmCallHandler
  • GetCurrentCallMode() : XCallInfoResponseParser
  • GetCurrentChargeData() : CallHdl, MmCallHdl, MmCallHandler
  • GetCurrentContext() : ExecutionContext
  • GetCurrentDate() : CalendarMonthWin
  • GetCurrentDir() : FfsHandler, RamHandler, FatHandler
  • GetCurrentDisplayType() : AtlItemGridWindow
  • GetCurrentFocusPriority() : System
  • GetCurrentFolder() : ObexFtpServer, ObexFtpDataServer
  • GetCurrentFrame() : MP3AudioPlayer
  • GetCurrentImage() : CamWin32
  • GetCurrentImageBufferSize() : CamWin32
  • GetCurrentIndication() : SmsIndicationState
  • GetCurrentLocalTimeZone() : DateTime
  • GetCurrentNumberOfElements() : EmzUtils::Queue< T >
  • GetCurrentSelectedDay() : CalendarGrid
  • GetCurrentSelectedPb() : UsimPbLocReport
  • GetCurrentTest() : FfsTestThreadlet, FfsTestThread
  • GetCurrentTestGroup() : SocketTestApp
  • GetCurrentTestID() : SocketTestApp
  • GetCurrentTestNr() : SocketTestApp
  • GetCurrentVideoClockTime() : EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Decoder, VideoDecoder
  • GetCursorPos() : AbstractEditBoxModel
  • GetCursorRect() : AbstractEditBoxView
  • GetCustomKey() : KeyboardConfig
  • GetData() : UibSettingsRecord, ToDoRecord, LcsSettingsUtils, LcsAppUtils, FmRadioStationsRecord, FmRadioSettingsRecord, SmsSettingsRecord, CalendarRecord, CalendarDialogWin, BtHfRecord, PbNumberRecord, PbRecord, PbNextFreeIdRecord, AragonMsg, Glyph, FilePackConnector, BtSddbDeOneByteDescriptionType, BtServiceVerifyResultMessage, WString, String, ByteBuffer, ProviderProxyItem, UssdDataMsg, PdpContext::Address, UserData, UserDataHeader, Tpdu, Sms, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, PbEntryUpdReqArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, InformationElement, Cbs, PathProfile, T9Pack, Record
  • GetDataAvailability() : SimAccessor, DataHandler
  • GetDataBaudRate() : CsdDataConnProfile
  • GetDataBits() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetDataCallContext() : CsdDataConnProfile
  • GetDataCallType() : CallIndArg
  • GetDataCodingScheme() : UssdDataMsg, UssdNotifyMsg, UssdRequestMsg, CnapInfoReceivedMsg, SmsContext, SmsNewMessageIndArg, SmsStatusReport, SmsSubmit, SmsDeliver, SimTextString, MdhSmsNewMessageIndArg, Cbs
  • GetDataCompression() : PdpContext
  • GetDataConn() : SocketData, DataConnManager
  • GetDataConnByIdx() : DataConnManager
  • GetDataConnByIdxAndType() : DataConnManager
  • GetDataConnCount() : DataConnManager
  • GetDataConnectionType() : FtpClient
  • GetDataConnId() : WapProfile
  • GetDataConnProfileId() : SocketData, InetSocket, ServerConfig, HttpServiceMessage, FtpServiceMessage
  • GetDataConnProfileType() : DataConnApp::DataConnDescription
  • GetDataControlType() : DataControlModificationMsg
  • GetDataCounters() : PsdDataConn, PdpContextManager
  • GetDataElementAtIndex() : BtSvrDataElement
  • GetDataElementDescriptor() : BtSddbDeUuid128, BtSddbDeSint128, BtSddbDeSint64, BtSddbDeUint128, BtSddbDeUint64, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, BtSddbDeNil, BtSddbDeOneByteDescriptionType
  • GetDataElementSizeDescriptor() : BtSddbDeContainer, BtSddbDeVariableLengthType
  • GetDataElementTypeDescriptor() : BtSddbDeAlternative, BtSddbDeSequence, BtSddbDeContainer, BtSddbDeUrl, BtSddbDeString, BtSddbDeVariableLengthType
  • GetDataFractionSize() : ObexObject
  • GetDataHandler() : DataControl
  • GetDataItem() : UibSettingsProvider, UibInboxProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsTemplateProvider, SmsSettingsProvider, SmsFolderProvider, SmsBasicProvider, SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider, CalendarProvider, BtHfProvider, BtDeviceListProvider, PbSimProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, PbNameNumberProvider, PbNameFilterProvider, PbNumberFilterProvider, PbDetailProvider, GroupProvider, SortProvider, Provider, FindProvider, FilterProvider, DistinctProvider, AbstractDelegationProvider, Property, MergeProvider, JoinProvider, AppendProvider, LanguageProvider, StatusProvider, SstProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, SimTkMainMenuProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PlmnProvider, PbBaseProvider, MbiProvider, LockProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CountryProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • GetDataLength() : PbEntryReadIndArg
  • GetDataPack() : BasicPackConnector
  • GetDataPtr() : BlobPtr, RtStreamingBuffer, GenericFeatureData
  • GetDataRate() : DataRateTable, CsdDataConnProfile
  • GetDataRateType() : DataRateTable
  • GetDataRead() : StreamingReadInfo
  • GetDataReceivedEventArgs() : NetAdapter::DataReceivedEventArgs, NetAdapter::EventArgs
  • GetDataRecord() : ToDoProvider, PbRecordProvider, PbRecordHandler, PbNvRamNumberHandler, PbNvRamNameHandler, PbNumberProvider, PbNumberHandler, PbNameProvider, PbNameHandler, PbFfsNumberHandler, PbFfsNameHandler
  • GetDataRecordHandler() : PbRecordHandler, PbNvRamNumberHandler, PbNvRamNameHandler, PbNumberHandler, PbNameHandler, PbFfsNumberHandler, PbFfsNameHandler
  • GetDataSentEventArgs() : NetAdapter::DataSentEventArgs, NetAdapter::EventArgs
  • GetDataSink() : EncodingThreadlet
  • GetDataSize() : BtServiceVerifyResultMessage
  • GetDataStoreUri() : SyncMLManager
  • GetDataTerminal() : MmCallInfo
  • GetDataToWrite() : StreamingWriteInfo
  • GetDataType() : DataItem
  • GetDate() : ToDoDateDialogWin, CalendarRecord, DateEditorDocument, DateEditor, DateCompoundItem, DateEditBox, DateTime, DataItem, Property
  • GetDateConstraint() : DrmRightsObject, DrmPermission
  • GetDateFormat() : Locale, DateEditorDocument, DateEditor, DateCompoundItem
  • GetDatetime() : TimeZoneMsg
  • GetDateTime() : DataItem, Property, SmsNewSocketDataMsg, MnInformationIndArg, DrmConstraint, TpduHeaderInformation
  • GetDay() : Date
  • GetDaylightSavingTime() : MnInformationIndArg
  • GetDBServiceFromURI() : SyncMLManager
  • GetDbUri() : DBItemChangedMsg
  • GetDcd() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetDcfHeader() : DrmDcfParser
  • GetDcs() : SmsNewSocketDataMsg, UssdAnswerIndArg, SsUssdIndArg, SsUnstructIndArg, GetInkeyRspArg, GetInputRspArg, TpduHeaderInformation
  • GetDecimalSeparator() : Locale
  • GetDecimalString() : Fraction
  • GetDecoderCodec() : MediaFrameworkCaps
  • GetDefaultAmplitude() : CustomToneAudioReference
  • GetDefaultChunkSize() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetDefaultClirMode() : CallHandler
  • GetDefaultCugInfo() : CallHandler
  • GetDefaultDataItem() : PbMergeProvider, PhoneNumberMergeProvider, MergeProvider
  • GetDefaultDescriptor() : Property
  • GetDefaultHeight() : Window, View, LineEditor, ItemBox, ImageBox, Component, Animation, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, T9PinyinBox, StrokeBox, SelectionBox, SvgPlayer
  • GetDefaultIcon() : IconSet
  • GetDefaultItemHeight() : AbstractListBoxView
  • GetDefaultItemId() : SelectItemReqArg
  • GetDefaultItemRendererProperties() : GuiEngineConfig
  • GetDefaultPriority() : EmlppStatusMsg, EmlppRegisteredMsg
  • GetDefaultProfile() : SmsSettingsRecord, AbstractSmsApp
  • GetDefaultServerId() : ObexServerOppImpl, ObexServer
  • GetDefaultTextString() : GetInputReqArg
  • GetDefaultWidth() : Window, View, ItemBox, ImageBox, Component, Animation, SvgPlayer
  • GetDeflectNumber() : CallDeflectSsReqArg
  • GetDefProfileId() : DataConnProfileManager
  • GetDelAllAction() : PhonebookApp
  • GetDelay() : Alert, StreamAudioReference, PdpContext::QualityOfService
  • GetDelBufCount() : RegDeletionBufferEntry
  • GetDeleteAction() : PhonebookApp
  • GetDeleteKey() : KeyboardConfig
  • GetDeleteMode() : EditBox
  • GetDeleteObect() : BtObexDataBufferIndicationEvent
  • GetDeleteObject() : BtObexPutRequest
  • GetDeletionBuffer() : RegMemoryPool
  • GetDeletionCmd() : MdhSmsDeletionReqArg, MdhSmsDeletionIndArg
  • GetDelPhonenoAction() : AdvPbApp
  • GetDenominator() : Fraction
  • GetDesc() : AtPbInfoIndArg
  • GetDescription() : CalendarRecord, CallNotifyMsg, NotifyIndArg, HttpApplication
  • GetDescriptor() : PropertyItem, PropertyEditor, IndicatorItem
  • GetDeselectedIcon() : RadioButtonAction, CheckBoxAction, AbstractToggleAction
  • GetDestinationAddress() : AbstractSmsComposeWin, SmsContext, SmsCommand, SmsSubmit
  • GetDestinationApplicationPortAddress() : SmsContext
  • GetDestinationNumber() : SmsControlIndArg
  • GetDestinationTpduStatus() : SmsUnsentProvider, SmsUnreadProvider, SmsSentProvider, SmsReadProvider, SmsProvider
  • GetDestIpAddr() : DhChannelOpenReqArg
  • GetDetailProvider() : ProvDetailListBoxWin, PbDetails, PbAdvDetails
  • GetDetailRow() : PbDetailProvider
  • GetDetailWin() : PhonebookWin, PbDetailAction, BasicPbWin, AdvPbWin, PbAdvDetailAction
  • GetDevice() : BtDeviceDetailWindow, DeviceManager, AudioContext, BtObexServerConnectIndicationEvent, BtHsNmaConnect, BtHfNmaConnect, BtFaxConnectMessage, BtDunConnectMessage, BtUncancelablePointToPointRequest, BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice, BtMultiConnectionController::BtConnection, BtDeviceList::BtDeviceListNode, AudioDeviceManager, AudioActiveReference, RootFileImp
  • GetDeviceAbstraction() : ObexAbstractTransport
  • GetDeviceAddress() : BtDeviceListWindow, BtDeviceListItem, BtDeviceListProvider, BtDeviceAddressGenericObject, BtAvrcpControllerDeviceListItem, BtObexClientAddr, BtServiceVerifyResultMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtGapAndSdapRemoteRequestMessage, BtDevice, L2CapSocketAddr, RfcommSocketAddr
  • GetDeviceAdr() : BtBipConnectIndArg
  • GetDeviceAndServiceClass() : BtRemoteDeviceMessage, BtDeviceSearchRequest, BtDeviceFilter, BtDevice
  • GetDeviceAtIndex() : BtDeviceListProvider
  • GetDeviceClass() : BtDeviceListWindow
  • GetDeviceContext() : Control
  • GetDeviceCount() : BtAvrcpControllerApplicationWindow
  • GetDeviceErrorCode() : StreamingInfo
  • GetDeviceFilter() : BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice
  • GetDeviceIcon() : BtDeviceListWindow
  • GetDeviceId() : AudioDeviceStatusMsg
  • GetDeviceID() : MmfPlayer, AudioVibratorDevice, AudioDeviceBase, MapiAudioPlayer
  • GetDeviceInfo() : SyncMLManager
  • GetDeviceList() : BtDeviceSearchRequest, BtCancelableMulticastRequest
  • GetDeviceListNode() : BtDeviceList::BtDeviceListBidirectionalIterator
  • GetDeviceListProvider() : BtDeviceListWindow
  • GetDeviceListWindow() : BtApplication
  • GetDeviceMajorClass() : BtDeviceListProvider
  • GetDeviceManual() : AbstractSmsApp
  • GetDeviceMinorClass() : BtDeviceListProvider
  • GetDeviceName() : SmsTelematicDeviceNameTable, BtDeviceListWindow, BtDeviceListProvider, BtServiceVerifyResultMessage, BtRemoteDeviceNameMessage, BtGapAndSdapRemoteRequestMessage, BtDevice
  • GetDeviceRelation() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetDeviceState() : BtDeviceFilter
  • GetDeviceStatus() : AudioDeviceStatusMsg
  • GetDeviceVolume() : AudioDeviceBase
  • GetDfId() : SimGenericReqArg, SimGenericIndArg
  • GetDfLength() : SimGenericIndArg
  • GetDfParams() : SimGenericIndArg
  • GetDiagnosticCause() : DiagnosticIndMsg, DiagnosticIndArg
  • GetDiff() : AbstractGrid::SmoothScrollInfo, AbstractListBox::SmoothScrollInfo
  • GetDirection() : FtpTransferMessage
  • GetDirectoryIterator() : RootFileSystem
  • GetDirItemInformation() : FtpClient
  • GetDirtyFlag() : DirtyFileHandler
  • GetDischargeTime() : SmsStatusReport
  • GetDisconnectingMode() : CallDisconnectedMsg, CallDisconnectingMsg
  • GetDiscoverableMode() : BtLocalSettings
  • GetDispatcher() : DispatcherAction, InvalidateMsg, Item, ContextManager, AtlWindow
  • GetDispatcherActionList() : AppRoutingTableEntry
  • GetDisplay() : System, DeviceContext, DeviceManager
  • GetDisplayCount() : DisplayConfig
  • GetDisplayedName() : MetaData
  • GetDisplayForegrWin() : WindowManager
  • GetDisplayIndex() : Control, Camera
  • GetDisplaySimPos() : PbAbstractWin
  • GetDisplayType() : ItemRendererProperties
  • GetDistinctNameProvider() : PbDataHandler, PbAdvDataHandler
  • GetDocument() : SmsViewerWin, AbstractSmsViewerWin, EmsViewerWin, AbstractEditor
  • GetDocumentDescription() : SvgPlayer
  • GetDocumentObtainer() : ToDoComposeWin, SendSmsMsg, SmsServiceDocumentMsg, SmsComposeWin, AbstractSmsComposeWin, EmsComposeWin
  • GetDocumentTitle() : SvgPlayer
  • GetDomain() : WapProfile
  • GetDownlinkPath() : AudioAccessoryDetails
  • GetDPart() : IpAddr
  • GetDpofOptions() : BtBipImagingCapabilities
  • GetDriveLetter() : RamFileSystem
  • GetDrmAsset() : DataSource, DataSink, BinData
  • GetDrmAttrib() : FlsFile, FfsHandler
  • GetDrmLocalId() : DrmAsset
  • GetDrmMimeType() : DrmRightsObject, DrmMessage
  • GetDrmRights() : DrmRightsObjectStore
  • GetDrmVersion() : DrmRelParser
  • GetDrvId() : AudioMsg
  • GetDspFormat() : StreamAudioReference
  • GetDsr() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetDstInd() : TimeZone
  • GetDtmfDispatcher() : CallHandler
  • GetDtmfSeparator() : EditConfig
  • GetDtr() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetDummy() : SimTkCallSetupIndArg
  • GetDuration() : KeyUpMsg, KeyUpInputMapItem, KeyMsgGenerator::Key, AudioTone, MediaInfo::MediaTrackInfo, Media
  • GetDuration1() : DhChannelOpenReqArg
  • GetDuration2() : DhChannelOpenReqArg
  • GetDynamic2Flag() : SimAccessor
  • GetDynamicFlag() : SimAccessor
  • GetDynamicProperties() : DBService
  • GetEcc() : SimAuxHandler
  • GetEccArray() : SimAccessor
  • GetEccCategory() : CallHdl, MocSetupReqArg, RedialSetupIndArg, MocSetupAccArg, CallIndArg, XCallInfoResponseParser, EccProvider, DataHandler
  • GetEccCount() : SimAuxHandler
  • GetEccCustomization() : DataHandler
  • GetEccNetworkArray() : EccListIndArg
  • GetEccRecord() : UsimEccReadIndArg
  • GetEditableTable() : DataConnApp::DataConnDescription
  • GetEditMode() : AbstractEditor, EditBox
  • GetEditor() : IpAddrPrompt, EmsComposeWin, IpAddrPrompt, InputMapper, Caret
  • GetEditorDocument() : EditorDocumentObtainer
  • GetEditorItem() : EditorItemNode
  • GetEepCalibrationStatus() : StatusProvider
  • GetEffectiveViewfinderRect() : Camera
  • GetEffectiveWchars() : DataCoding
  • GetEfId() : SimGenericReqArg, SimGenericIndArg
  • GetEfLength() : SimGenericIndArg
  • GetEfParams() : SimGenericIndArg
  • GetEfRefresh() : SimTkRefreshNewReqArg, SimTkRefreshQueryReqArg, SimTkRefreshReqArg
  • GetEleCount() : Zi8AlphabetBox
  • GetElem() : HashTable
  • GetElementAt() : MediaRefContainer, AtResponseInfoTable, AtCommandInfoTable
  • GetElementCount() : Zi8Wrapper, Zi8InputMapper
  • GetEmail() : PbRecord, SaveEntryInPhonebookMsg, VCard
  • GetEmailRecordNo() : UsimPbRefRecord
  • GetEmlpp() : SimAccessor
  • GetEmlppSetupCallCondition() : SimAuxHandler, DataHandler
  • GetEmlppSubscription() : SimAuxHandler, DataHandler
  • GetEmptyBytesInTx() : DhChannelSendIndArg
  • GetEmsColorCount() : EmsResourceMaps
  • GetEmsColorNames() : EmsResourceMaps
  • GetEmsColors() : EmsResourceMaps
  • GetEmsCreator() : EmsApp
  • GetEncoder() : ImageEncodingProgressMsg, EncodingThreadlet
  • GetEncoderCodec() : MediaFrameworkCaps
  • GetEncoding() : BtBipImageHdlDesc, BtBipImageDesc, BtBipImageFormat
  • GetEncodingFormat() : PngEncoder::EncodingParameters, JpegEncoder::EncodingParameters
  • GetEncodingParams() : ImageEncoder
  • GetEndDate() : DrmAsset
  • GetEntry() : PbRecordHandler, MenuTableNode, ContextTableNode, PbEntryReadIndArg, SimPbEntryCont, SimPbBaseHandler, PbBaseProvider
  • GetEntryContainer() : SimPbBaseHandler
  • GetEntryCount() : CalendarRecordsListBoxModel, CalendarRecordsList
  • GetEntryNr() : PbEntryShowAction
  • GetEonsPlmnName() : SimAuxHandler, DataHandler
  • GetEqualDirectoryNode() : RamFileNode
  • GetErrCause() : SaLocationErrArg
  • GetErrCode() : LocationErrMsg
  • GetError() : SocketData, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket, ShortMessageFailureCause, FtpTransferMessage
  • GetErrorCause() : MmCallDisconnectingMsg
  • GetErrorCode() : ObexResult, Image, SsErrorMsg, NetworkSsErrorMsg, SsRequestRejectedMsg, MptyHoldRejectedMsg, SimErrorMsg, SsErrReqArg, SimErrorIndArg, VrErrorIndArg, VrErrorMsg, SvgPlayer
  • GetErrorMessage() : StreamingInfo
  • GetErrorNumber() : SerialIoAdapter
  • GetErrorPage() : HttpClient
  • GetErrorReason() : BtOperationBase
  • GetErrorText() : SsErrorMsg
  • GetEst() : UsimEstReadIndArg
  • GetEstablishCause() : CallHdl, CallIndArg
  • GetEstCause() : RedialSetupIndArg, MocSetupAccArg, XCallInfoResponseParser
  • GetEvaluationPrecedenceIndex() : PdpContext::PacketFilter
  • GetEvent() : CallEventMsg, SerialIoSet, SerialTerminalArg
  • GetEventCode() : LcsAppResWinMsg
  • GetEventList() : SimTkSetupEventReqArg
  • GetExclusionGroup() : AudioReference
  • GetExecFn() : Action
  • GetExecutingRequest() : BtSingleConnectionController, BtConnectionlessController
  • GetExecutionContext() : MessageHook, SmsSocket, MainHandler
  • GetExistentSmsCount() : AbstractSmsApp
  • GetExistingCount() : SimPbEntryCont, SimPbBaseHandler
  • GetExitCode() : CloseWindowMsg
  • GetExpiredTime() : Ticks
  • GetExposure() : Camera
  • GetExposureLimits() : Camera
  • GetExtByFileType() : FfsMimeTypeMap
  • GetExtByMimeStr() : MimeTypeTable
  • GetExtByMimeType() : MimeTypeTable
  • GetExtData() : MdhExtendedData
  • GetExtendedAddress() : VCard
  • GetExtendedData() : MdhSmsExtendedDataReqArg, MdhSmsTransmitIndArg, MdhSmsReadIndArg, TpduHeaderInformation
  • GetExtendedObjectBuffer() : InformationElement
  • GetExtendedObjectControlDataMayBeForw() : InformationElement
  • GetExtendedObjectControlDataUserPrompt() : InformationElement
  • GetExtendedObjectLength() : InformationElement
  • GetExtendedObjectPosition() : InformationElement
  • GetExtendedObjectReferenceNumber() : InformationElement
  • GetExtendedObjectType() : InformationElement
  • GetExtension() : SubMenuAction, AccessorAction
  • GetExtensionSeparator() : Pathname
  • GetExternalCommunicator() : MessageRouter
  • GetExtLanguage() : SimTkLanguageNotificationMsg, LanguageSettingIndArg, LanguageSelectEventArg, SimTkLanguageNotificationIndArg, SimAuxHandler
  • GetExtLanguageCount() : SimAuxHandler
  • GetFamilyName() : VCard
  • GetFavicon() : HttpClient
  • GetFdnProvider() : PbDataHandler
  • GetFdnState() : FdnReqArg, FdnIndArg, SimAuxHandler, SimAccessor
  • GetFdnTagSize() : SimPbBaseHandler
  • GetFeature() : IdentifierHandler, FeaturePool, FeatureItem, FeatureBroker, KeyMapping, FeatureChangedMsg
  • GetFeatureId() : FeatureItem, Feature, SoftkeyDesc, DisabledFeatureTriggeredMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg
  • GetFeaturePool() : AtlApplication
  • GetFfsTestBase() : SocketTestApp, FfsTestDispWin
  • GetFile() : FilePack, RootFileSystem, FileChunkOperationProgressMsg, HttpResponse
  • GetFileExtension() : Pathname
  • GetFileId() : SimFileInfoReqArg, SimFileInfoIndArg, UriMappingTable, RegNodeBuffer, FfsHandler, DeletedNode
  • GetFileIndex() : UriMappingTable
  • GetFileInfo() : FfsHandler, RamHandler, FatHandler, SimAccessor
  • GetFileLength() : SimAccessor
  • GetFileName() : FilePackConnector, BtBipGetLinkedAttachmentIndArg, FfsHandler
  • GetFileNames() : FilePackConnector
  • GetFileSize() : FilePackConnector, FfsFile, SimFileInfoIndArg, FlsFile, RamFile, FatFile
  • GetFileStatus() : BdnIndArg, FdnIndArg
  • GetFileType() : FfsFile, SimFileInfoIndArg, SimRefreshIndArg, FlsFile
  • GetFileTypeByExt() : FfsMimeTypeMap
  • GetFileTypeByMimeStr() : FfsMimeTypeMap
  • GetFileTypeByMimeType() : FfsMimeTypeMap
  • GetFilter() : CameraSettings, Camera, BtBipGetImagesListIndArg, CbsFilterList, CbsStartReqArg
  • GetFilterParams() : BtBipImagingCapabilities
  • GetFinishedCommand() : TermRspCnfArg
  • GetFirst() : VersionInfo, BtSddbDeContainer, DeletedNodeList
  • GetFirstAppContainer() : System
  • GetFirstApplicationListEntry() : AppContainerRoutingTableEntry
  • GetFirstAttribute() : BtSddbServiceRecord
  • GetFirstCell() : Grid, GridModel
  • GetFirstConnection() : BtMultiConnectionController
  • GetFirstControl() : Control
  • GetFirstDrawableObject() : Control
  • GetFirstExtByMimeStr() : MimeTypeTable
  • GetFirstExtByMimeType() : MimeTypeTable
  • GetFirstFreeRecNo() : PbRecordProvider
  • GetFirstFreeSimPosition() : SimPbEntryCont
  • GetFirstIndex() : BtBipGetImagesListIndArg
  • GetFirstInformationElement() : UserDataHeader
  • GetFirstInputAction() : InputAnalyzer
  • GetFirstItem() : TRadioButtonList< Content >, RadioButtonList, MenuList, CheckBoxList, AbstractMenuListModel< Item >
  • GetFirstKey() : AtKeyParser
  • GetFirstKeyColumnId() : JoinProvider
  • GetFirstLexToken() : LexAnalyzer
  • GetFirstPageEntry() : HeapManager
  • GetFirstProperty() : DataConnApp::DataConnDescription
  • GetFirstProvider() : JoinProvider
  • GetFirstVideoFrame() : MediaPlayer
  • GetFirstVisibleColumn() : ItemMenu::LevelInfo, AbstractGrid
  • GetFirstVisibleIndex() : ItemMenu::LevelInfo, AbstractLineEditor, AbstractGrid, AbstractListBox, AbstractListBoxModel, AbstractEditBoxModel
  • GetFirstVisibleLine() : AbstractEditBoxModel
  • GetFirstVisibleLineIndex() : AbstractMultiLineEditor
  • GetFirstVisibleRow() : GridModel
  • GetFirstWindow() : Application
  • GetFixedRingerToneInfo() : RingerAudioDevice
  • GetFlag() : LockedKeyMsg, SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadIndArg, SimODynReadIndArg
  • GetFlags() : VersionInfo
  • GetFlash() : CameraSettings, Camera
  • GetFlashStoredTpduNum() : TpduHeaderInformation
  • GetFlowLabel() : PdpContext::PacketFilter
  • GetFmRadioSettingsProv() : FmRadioApplication
  • GetFmRadioStationsProv() : FmRadioApplication
  • GetFmRadioWin() : FmRadioApplication
  • GetFocusedAppContainer() : System
  • GetFocusedApplication() : System
  • GetFocusedControl() : Control
  • GetFocusedWindow() : Application
  • GetFocusMsg() : GetFocusMsg
  • GetFocusPriority() : Window
  • GetFolder() : UibRegisterMsg
  • GetFolderType() : UibFolderWin
  • GetFont() : Zi8InputConfig, T9InputConfig, FontConfig, System, TextFormat, TextEditorDocument, TextCompoundItem, MultiLineEditor, LineEditor, FontPackConnector, FontPack, FontManager, DeviceContext, AbstractTextObject, ResourceManager, MultiMediaEditor
  • GetFontAlign() : TextFormat, DeviceContext
  • GetFontCount() : FontConfig
  • GetFontFamilyName() : FontManager, FontEntry
  • GetFontId() : ThemeConfig, Theme
  • GetFontName() : FontManager
  • GetFontNames() : FontPackConnector
  • GetFonts() : FontPack
  • GetForegroundColor() : RichTextCompoundItem, MultiMediaEditor
  • GetForegroundControl() : Control
  • GetForegroundWindow() : Application, WindowManager
  • GetFormat() : TimeEditBox, DateEditBox, CustomRingerAudioReference, ValidityPeriod, ValidityPeriodFormat
  • GetFormattedName() : VCard
  • GetForwardingFeatures() : CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg
  • GetForwardingInfo() : SsForwardingIndArg
  • GetForwardPhoneNumber() : CfuService
  • GetFractionString() : Fraction
  • GetFrame() : ImageMetaData, ImageBox
  • GetFrameBuffer() : DisplayConfig
  • GetFrameCount() : Image, Image::MetaData
  • GetFrameDelay() : EmsImage, NativeImage, Image, SvgImage, WbmpImage, PngImage, JpegImage, GifImage, BmpImage
  • GetFrameHeight() : Image, GifImage
  • GetFrameRate() : VideoCamera, Media
  • GetFrameSize() : AbstractEditBoxView
  • GetFrameType() : Control
  • GetFrameView() : Window, Control
  • GetFrameWidth() : Image, GifImage
  • GetFrameXPos() : Image, GifImage
  • GetFreeBlockIndex() : RamStorageMapper
  • GetFreeConnId() : HttpWapMgr
  • GetFreeExtRecords() : SimPbBaseHandler
  • GetFreeFfsSpace() : FfsHandler
  • GetFreeRequestId() : HttpWapMgrPlugin
  • GetFreeSerialTerminal() : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • GetFreeSize() : BtObexService, RamStorageMapper
  • GetFreeSmsCount() : AbstractSmsApp
  • GetFreeSpaceByType() : FfsHandler
  • GetFreeSpaceInGlobalPool() : FfsHandler
  • GetFreeSpaceSize() : RamHandler, RamFileSystem, FatHandler
  • GetFreeVolumeSize() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetFrequencies() : AudioFmRadioRdsAlternativeFrequenciesMsg
  • GetFrequency() : AudioFmRadioSeekMsg
  • GetFront() : EmzUtils::Queue< T >, SortedLinkedList< T >, LinkedList< T >, LinkedListBase, SortedElementList< T >, ElementList< T >
  • GetFtpDataSocket() : FtpClient
  • GetFtpInTransfer() : FtpDataSocket
  • GetFtpOutTransfer() : FtpDataSocket
  • GetFtpRequest() : FtpRequestMessage
  • GetFtpSocket() : FtpDataSocket, FtpClient
  • GetFunction() : EngineeringModeControlRequestArg, EngineeringModeControlResponseArg
  • GetFunkId() : AudioMsg
  • GetGain() : BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain
  • GetGap() : ItemRendererProperties
  • GetGapToNextChar() : RomFont, FontManager, FontEntry, Font
  • GetGateway() : SimLaunchBrowserReqArg
  • GetGeneralResult() : LaunchBrowserPromptIndArg, SimTkRefreshQueryResArg
  • GetGenericObject() : DataItem, Property
  • GetGenericObjectPtr() : DataItem, Property
  • GetGenericTrackInfo() : GenericFeatureData
  • GetGenResult() : DhChannelReceiveIndArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelOpenPromptResArg
  • GetGeographicalScope() : Cbs::SerialNumber
  • GetGivenName() : VCard
  • GetGlassPane() : Desktop
  • GetGlassPanePosition() : IndicatorLocation
  • GetGlobalProvider() : MainProvider
  • GetGlobalTraceMask() : InternalTracer
  • GetGlyph() : VietnameseTextRenderer, ThaiTextRenderer, SimpleTextRenderer, RomFont, JapaneseTextRenderer, HindiTextRenderer, FontManager, FontEntry, Font, ArabicTextRenderer, AbstractTextRenderer
  • GetGlyphs() : FontManager
  • GetGlyphStartPos() : FontEntry
  • GetGors() : MdhSmsDeletionIndArg
  • GetGprsClass() : GprsClassReqArg, GprsClassIndArg
  • GetGpsFixData() : MeasurementData
  • GetGreen() : ColorTable, Color
  • GetGreenBitCount() : ColorSegmentation
  • GetGreenKey() : KeyboardConfig
  • GetGroup() : RadioButtonAction, UsimPbGroups
  • GetGroupId() : PbRecord, DataCodingScheme, TpduHeaderInformation
  • GetGroupVector() : UsimPbRwRecord
  • GetGsmBand() : GsmBandStateMsg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, StatusProvider, DataHandler
  • GetGsmBandList() : BandSelectionReqArg
  • GetGsmErrorCause() : RegistrationChangeMsg, NRegStateIndArg
  • GetGsmService() : SmsSettingsRecord, PrefServiceSetReqArg, MnInformationIndArg
  • GetGsmServiceCount() : SmsGsmServiceTextMap
  • GetGsmServiceName() : SmsGsmServiceTextMap
  • GetGsmSignal() : CallHdl, MtcSetupIndArg
  • GetGuid() : ExecutionContext, Service
  • GetHandle() : MemMap, AudioMsg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, FlsFile, FatFile
  • GetHandler() : PbRecordProvider, GetPasswordMsg, StackControl, MainHandler, HandlerListEntry, PbBaseProvider
  • GetHandlerId() : SsHandler, UusHandler, UssdHandler, SsCcbsHandler, SmsHandler, SimTkHandler, SimHandler, SigHandler, PowerHandler, PlmnHandler, NetworkHandler, MultiSlotHandler, MobileOriginatedUssdHandler, EmlppHandler, CrssHandler, ColrHandler, ColpHandler, CnapHandler, ClirHandler, ClipHandler, CbsHandler, CallWaitingHandler, CallHandler, CallForwardingHandler, CallDeflectionHandler, CallBarringHandler, BootHandler, AtcHandler, AocHandler, AccHandler, VrHandler, MmCallHandler
  • GetHandlerType() : ExternalCommunicationHandler, SignalHandler
  • GetHashValue() : PhoneNumber
  • GetHdl() : SysSocket
  • GetHead() : Pathname
  • GetHeader() : BtObexClientNmaHeaderIndication, BtObexServerNmaHeaderIndication, BtObexHeaderIndicationEvent
  • GetHeaderBuffer() : BtObexRegisterServerRequest, BtObexRegisterClientRequest
  • GetHeaderBufferSize() : BtObexRegisterServerRequest, BtObexRegisterClientRequest
  • GetHeaderCompression() : PdpContext
  • GetHeaderHeight() : TabControlView, AbstractItemGrid, AbstractGrid
  • GetHeaderItem() : AbstractItemGrid
  • GetHeaderList() : ObexObject
  • GetHeaderRect() : AbstractGrid
  • GetHeaders() : HttpResponse, HttpRequest
  • GetHeaderText() : SimPduHandler
  • GetHeadsetKey() : KeyboardConfig
  • GetHeapBase() : MemoryConfig
  • GetHeight() : DisplayConfig, ImageMetaData, Size, RomFont, Rect, ItemRendererProperties, ImageObtainer, ImageEncoder::EncodingParameters, Image, Image::MetaData, FontManager, FontEntry, Font, EditorLine, DeviceContext, Component, Bitmap, BitmapRes, VirtualDisplay, WinRect, SoundItem, SimImage, SvgPlayer, SvgImageFileWrapper, VCardItem, PngDecoder, ImageItem, BoundedItem, AudioItem, MediaInfo::VideoTrackInfo
  • GetHeldCallHdl() : CallHdl
  • GetHelloRequest() : GltpAidDataRequests
  • GetHfProfileName() : BtHfSupportedProfileMessage
  • GetHfServiceName() : BtQuerySupportedProfilesRequest
  • GetHfSupportedFeatures() : BtHfSupportedProfileMessage
  • GetHiddenInfo() : UsimPbRwRecord
  • GetHighCutControl() : RadioAudioDevice
  • GetHighLowSideLoInjection() : RadioAudioDevice
  • GetHiglightedText() : VoiceMemoMenuAccessor
  • GetHomeBcdPlmn() : DataHandler
  • GetHomePlmn() : DataHandler
  • GetHostByAddr() : SysDnsClient, DnsClient
  • GetHostByAddrAsync() : SysDnsClient, DnsClient
  • GetHostByName() : SysDnsClient, DnsClient
  • GetHostByNameAsync() : SysDnsClient, DnsClient
  • GetHostIp() : Server, HttpServer, FtpServer
  • GetHour() : TimeEditBox, TimeSpan, Time, DateTime
  • GetHsProfileName() : BtHsSupportedProfileMessage
  • GetHsServiceName() : BtQuerySupportedProfilesRequest
  • GetHttpRequest() : HttpRequestMessage
  • GetHttpSocket() : HttpClient
  • GetHttpVersion() : HttpRequest
  • GetHyperlink() : SvgHyperlinkSelectMsg
  • GetHyperlinkFormatElementAbsolutStartPosition() : InformationElement
  • GetHyperlinkFormatElementTitelLength() : InformationElement
  • GetHyperlinkFormatElementUrlLength() : InformationElement
  • GetIccId() : PbRecord
  • GetIccidString() : SimAuxHandler
  • GetIcon() : TabControl, Item, IconSet, IconValueIndicator, IconTextIndicator, IconIndicator, ValueMappingPropertyDescriptor< T_Container >, TextIconPairArray::TextIconPair, PropertyDescriptor, ListPropertyDescriptor, ProviderProxyItem, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimLaunchBrowserPromptReqArg, SetupIdleModeTextReqArg, PlayToneReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • GetIconColorTable() : GuiEngineConfig
  • GetIconColumnId() : ProviderProxyContainer
  • GetIconCount() : IconSet
  • GetIcondesc() : IconDescReadIndArg
  • GetIconId() : SimIconDescription
  • GetIconList() : SetupMenuReqArg, SelectItemReqArg
  • GetIconRect() : DefaultItemRenderer, AbstractItemRenderer, AtlItemRenderer
  • GetIconSize() : GuiEngineConfig
  • GetIconSizeState() : DefaultItemRenderer, AbstractItemRenderer
  • GetID() : PropertyEditor, TriggerKeyFeature, FeatureItemContainer, FeatureItem, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, AtlApplication
  • GetId() : AmrSound, PredefinedEmsSound, PredefinedEmsImage, EmsImage, NetAdapter, DataConnProfile, ObexHeader, TimeCompoundItem, TextCompoundItem, PhoneNumberInputMapper, NumericInputMapper, MultiTapInputMapper, IpAddrInputMapper, IpAddrCompoundItem, InputMapper, FontEntry, DateTimeInputMapper, DateCompoundItem, DataPack, CompoundItem, Component, CharItem, CalculatorInputMapper, AtomItem, AcacLanguage, AbstractEditorItem, AudioGatiServer, GenericAudioDevice, GatiServer, SoundItem, Sound, SmafSound, PreparedSound, MidiSound, IndicatorBar, Indicator, IMelody, ActionExtension, BtObexClientAbortEvent, BtObexClientPutEvent, BtObexClientGetEvent, BtObexClientSetPathEvent, BtObexClientDisconnectEvent, BtObexClientConnectEvent, BtObexRegisterClientEvent, BtObexServerAbortIndicationEvent, BtObexServerPutIndicationEvent, BtObexServerGetIndicationEvent, BtObexServerSetPathIndicationEvent, BtObexServerDisconnectIndicationEvent, BtObexServerConnectIndicationEvent, BtObexRegisterServerEvent, BtObexTransportDisconnectEvent, BtObexDataIndicationEvent, BtObexDataBufferIndicationEvent, BtObexHeaderSentEvent, BtObexHeaderIndicationEvent, BtObexUnregisterEvent, BtSddbUnregisterServiceEvent, BtSddbRegisterServiceEvent, BtEvent, ProviderPtr, InputMapperFactory, PdpContext, PdpContext::PacketFilter, SimTkTransactionId, SimIconIdentifier, SimItemIdentifier, StorageDevice, Zi8InputMapper, T9InputMapper, ServerClient, HttpClient, HttpApplication, FtpClient, VCardItem, RichTextCompoundItem, ParagraphMarker, ParagraphCompoundItem, ImageItem, GeneralCompoundItem, BoundedItem, AudioItem, AccessorActionExtension, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, DataRecord
  • GetIdentifier() : IdentifierHandler, InformationElement
  • GetIdleTimeout() : DataConnProfile
  • GetIdOfFont() : FontManager
  • GetIgnoreManagement() : AudioReference, AudioPreset
  • GetIlluminationMode() : Keyboard
  • GetImage() : ImageRef, ImageDrawingInterruptedMsg, ImageDecodingProgressMsg, ImageObtainer, EncodingThreadlet, ImageReadIndArg, SvgImageFileWrapper, ImageItem
  • GetImageBuffer() : ImageBox, Image, SimImage
  • GetImageBufferLength() : SimImage
  • GetImageBufferMax() : GuiEngineConfig
  • GetImageDesc() : BtBipGetImageIndArg, BtBipPutImageIndArg
  • GetImageDim() : BtBipImageHdlDesc, BtBipImageDesc, BtBipImageFormat
  • GetImageHandle() : BtBipGetImageIndArg
  • GetImageHdl() : BtBipImageProperties, BtBipImage, BtBipDeleteImageIndArg, BtBipGetLinkedAttachmentIndArg, BtBipGetLinkedThumbnailIndArg, BtBipGetImagePropertiesIndArg, BtBipPutLinkedAttachmentCompleteArg, BtBipPutLinkedAttachmentIndArg, BtBipPutLinkedThumbnailCompleteArg, BtBipPutLinkedThumbnailIndArg, BtBipPutImageCompleteArg, BtBipClientService
  • GetImageId() : ImageFactory
  • GetImageList() : BtBipImageList
  • GetImageName() : BtBipImageProperties, BtBipPutImageIndArg
  • GetImageObtainer() : ImageRef, ImageBox, ImageItem
  • GetImageProperties() : BtBipClientService
  • GetImagePropertiesReq() : BtBipClientService
  • GetImagePropertiesRsp() : BtBipServerService
  • GetImageRefObj() : ImageRefGenContainer
  • GetImageReq() : BtBipClientService
  • GetImageRsp() : BtBipServerService
  • GetImageSize() : CameraSettings, BtBipImageDesc
  • GetImageSizeDimensions() : Camera
  • GetImagesList() : BtBipClientService
  • GetImagesListReq() : BtBipClientService
  • GetImagesListRsp() : BtBipServerService
  • GetImagingCapabilites() : BtBipClientService
  • GetImagingCapabilitiesReq() : BtBipClientService
  • GetImagingCapabilitiesRsp() : BtBipServerService
  • GetImei() : SimAccessor
  • GetImei1() : ImeiReadIndArg
  • GetImei2() : ImeiReadIndArg
  • GetImeiString() : SimAuxHandler
  • GetImgdescriptor() : ImageReadReqArg
  • GetImgObt() : ImgObtObj
  • GetImgRequestType() : ImageReadReqArg
  • GetImmediateSearch() : BtDeviceListWindow
  • GetImmediatlyRetrieveRemoteDeviceNames() : BtDeviceSearchRequest
  • GetImsi() : SimInitIndArg
  • GetImsiBcdPlmn() : SimAuxHandler
  • GetImsiPlmn() : SimChvHandler
  • GetImsiString() : SimAuxHandler
  • GetInboxProvider() : AbstractSmsApp
  • GetInboxUnreadProvider() : AbstractSmsApp
  • GetInBufByteCount() : SysSocket, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket
  • GetInc() : AbstractGrid::SmoothScrollInfo, AbstractListBox::SmoothScrollInfo
  • GetIndex() : MetaData, MediaRefContainer, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, MetaData, MediaRefContainer, DataConnAccessor, ObexChannel, RedrawDisplayMsg, SelectionChangedMsg, Caret, DisplayInfoMsg, AbstractDevice, Animation, AnimationModel, EditLine, RangeMappingPolicy, MappingPolicy, SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg, T9Pack
  • GetIndexForValue() : MultipartParser
  • GetIndexOf() : AcacLanguage
  • GetIndexOfActiveLanguage() : TextPackConnector
  • GetIndexOfFile() : FilePackConnector
  • GetIndexOfFont() : FontManager
  • GetIndexOfLanguage() : TextPackConnector
  • GetIndexPage() : HttpClient
  • GetIndexTableIndex() : AbstractDelegationProvider
  • GetIndicator() : HomezoneMsg, PlmnInfoReqArg, AttachReqArg, HomezoneIndArg
  • GetIndicatorbarExpansion() : IndicatorBar
  • GetIndicatorBarId() : IndicatorLocation
  • GetIndicatorBarPosition() : IndicatorLocation
  • GetIndicatorDescription() : Indicator
  • GetIndicatorId() : IndicatorDescription
  • GetIndicatorLocation() : IndicatorDescription
  • GetInfo() : DisplayInfoMsg, PbInfoReadIndArg
  • GetInfoAlpha() : PlayToneReqArg
  • GetInformationElement() : BaseInformationElement
  • GetInfoText() : MetaData, ImageMetaData, MetaData
  • GetInitialPrefferedStorageMedia() : SimAccessor
  • GetInitialType() : SmsStatusReport
  • GetInitResult() : SimInitIndArg, SimAuxHandler
  • GetInkeyReqArg() : GetInkeyReqArg
  • GetInkeyRspArg() : GetInkeyRspArg
  • GetInputAction() : InputActionPtr
  • GetInputMap() : KeyboardConfig, ResourceManager
  • GetInputMapper() : AbstractEditor
  • GetInputReqArg() : GetInputReqArg
  • GetInputRspArg() : GetInputRspArg
  • GetInputTogglingKey() : KeyboardConfig
  • GetInquiryAccessCode() : BtDeviceSearchRequest
  • GetInquiryTimeOut() : BtDeviceSearchRequest
  • GetInstance() : VoiceMemoApp, UsbApp, UibApp, ToDoApp, SoundBrowserApp, MediaBrowserUtils, SocketTestApp, RegEncoderDecoder, RegAppWin, RegApp, ObexApp, LcsSettingsUtils, LcsSettingsApp, GltpConnApp, LocResController, LcsWapIntf, LcsMainApp, LcsAppUtils, IrdaApp, ImageBrowserApp, MediaBrowserUtils, FmRadioApplication, SmsUtility, SmsApp, EmsApp, DataConnApp, CameraApp, CalendarApp, BtHsAppPlugin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, BtApplication, BtAvrcpPanelApplication, AdvPbApp, SocketSubSystem, ObexServerOppImpl, ObexMngr, ObexClientOppImpl, ObexOppClientPull, ObexOppClientPush, GenericWorkerTask, IrdaObexTransport, IrdaTransport, VietnameseTextRenderer, ThaiTextRenderer, SimpleTextRenderer, JapaneseTextRenderer, HindiTextRenderer, Desktop, BidiManager, ArabicTextRenderer, FoggyTheme, DefaultTheme, CustomizableTheme, MmiSimServer, AudioGatiServer, GatiManager, CamWin32, VibratorDevice, RtcSignalMapTableNode, LedSignalMapTableNode, DeviceManager, ChargerSignalMapTableNode, BtObexTransport, BtObexMessageArgumentsDestroyTableNode, BtObexController, BtHsMessageArgumentsDestroyTableNode, BtHfMessageArgumentsDestroyTableNode, BtTransport, BtSddbDataElementFactory, BtBppController, BtAvrcpMessageArgumentsDestroyTableNode, JapaneseTranscoder, BufferPoolManager, SpeechSimpleAudioDevice, RadioAudioDevice, MmfPlayer, AudioPresetStore, AudioPlayerStore, AudioPathManager, AudioError, AudioDeviceManager, AudioAccessoryStore, PropertyEditorFactory, FeatureBroker, KeyManager, ContextManager, PdpContextSignalMapTableNode, DataCallSignalMapTableNode, StackControl, SmsSocketSignalMapTableNode, SimTkLceService, SignalHandler, KeyMsgGenerator, CommonStackMsgMapTableNode, CommonSignalMapTableNode, CommonStackMsgArgsDestroyTableNode, RegManager, MapiAudioPlayer, VrStackMsgArgTableDestroyTableNode, UsbTransport, UsbSubSystem, SyncMLManager, HttpApplicationSupplier, HttpApplication, SerialSocketSubSystem, PngDecoder, SerialTerminalMsgArgsDestroyTableNode, MediaManager, SaStackMsgArgsDestroyTableNode, SaSignalMapTableNode, SaProviderImpl, GltpStackMsgArgsDestroyTableNode, GltpSignalMapTableNode, GltpProviderImpl, LcsUtils, LcsReqProcessor, LcsProvider, LcsCommonStackMsgArgsDestroyTableNode, LcsCommonSignalMapTableNode, LcsStackMsgArgsDestroyTableNode, LcsSignalMapTableNode, LcsProviderImpl, WapProfileMgr, HttpWapMgrPlugin, HttpWapMgr, DrmSubsystem, RamStorageMapper, RamFileSystem, LookupAlphaIdExtension
  • GetInstanceDataItem() : RegAppCommon
  • GetInstanceIteratorObj() : RegAppCommon
  • GetInstanceMobile2PC() : RegAppCommon
  • GetInstancePC2Mobile() : RegAppCommon
  • GetInstanceptr() : MediaManagerMsg
  • GetInstanceUri() : RegAppCommon
  • GetInt() : NumberPrompt
  • GetIntegerPayload() : RegNodeBuffer
  • GetIntegerValue() : AtResponseParameter
  • GetInteriorMetaData : RegIterator, RegEncoderDecoder
  • GetInteriorPayload() : RegNodeBuffer
  • GetInternalDisplayIndex() : Control
  • GetInternalRecNo() : TpduHeaderInformation
  • GetInterrogateCcbsResult() : CcbsResultMsg, SsCcbsResultIndArg
  • GetInterval() : DateTime
  • GetIntervalConstraint() : DrmRightsObject, DrmPermission
  • GetIntervall() : DrmConstraint
  • GetInterworking() : ProtocolIdentifier
  • GetInvalidation() : SimFileInfoIndArg
  • GetInvalidHdl() : SysSocket
  • GetInvalidNetAdapterId() : NetAdapterHandler
  • GetInvalidNsapi() : SysSocket
  • GetInvokeId() : InvokeId, LocationNotifInvokeMsg
  • GetIoSetInstance() : SerialSocketThread
  • GetIpAddr() : IpAddrPrompt, InetSocketAddr, IpAddrEditorDocument, IpAddrEditor, IpAddrCompoundItem, PdpContext::Address
  • GetIpAddress() : PsdDataConn, PppDataConn, DataConn
  • GetIpSecSecurityParameterIndex() : PdpContext::PacketFilter
  • GetIPv4String() : PdpContext::Address
  • GetIsLsaIdentifierPresent() : StatusProvider, DataHandler
  • GetIsProfileActive() : BtLocalSettings
  • GetIsRegistered() : BtController
  • GetIsServer() : BtObexController::BtObexConnection
  • GetIsWin98Mode() : IrdaTransport
  • GetItalicIncrement() : AbstractTextRenderer
  • GetItem() : ImageViewListBoxModel, ImageListBoxModel, SmsTextParser, ItemPropertiesChangedMsg, ItemContainer, ItemBox, AbstractItemContainer, ItemLabel, ItemObj, FeatureItemContainer, UpdateItemMsg, GeneralCompoundItem
  • GetItemColumnIconId() : ProviderProxyItem
  • GetItemColumnTextId() : ProviderProxyItem
  • GetItemContainer() : OpenContextMenuAction, ItemTree, ItemMenu::LevelInfo, ContextMenu, AbstractItemGrid, AtlItemListWindow, MenuDesc
  • GetItemCount() : SmsTextParser, TimeEditorDocument, TimeCompoundItem, TextEditorDocument, TextCompoundItem, ItemContainer, IpAddrCompoundItem, EditorDocument, DateEditorDocument, DateCompoundItem, CompoundItem, AbstractItemContainer, AbstractEditor, AbstractListBox, AbstractListBoxModel, ValueMappingPropertyDescriptor< T_Container >, ListPropertyDescriptor, FeatureItemContainer, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem
  • GetItemData() : DBService
  • GetItemForIndex() : AbstractMenuListModel< Item >
  • GetItemHeight() : DefaultItemRenderer, AbstractItemRenderer, TextMenuAccessor, RadioButtonView, MenuAccessor, CheckBoxView, AbstractMenuAccessor, AbstractListBox
  • GetItemIcon() : FfsTestResultsMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, MenuAccessor, AbstractActionMenuAccessor
  • GetItemId() : MenuSelectionReqArg, SelectItemRspArg
  • GetItemIndex() : ItemContainer, AbstractItemContainer, FeatureItemContainer
  • GetItemList() : SetupMenuReqArg, SelectItemReqArg
  • GetItemMetaInfo() : DBService
  • GetItemRect() : ItemTree, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemGrid, AbstractEditor, AbstractListBoxView
  • GetItemScope() : TextEditorDocument, EditorDocument, MultiMediaEditorDocument
  • GetItemsNai() : SetupMenuReqArg, SelectItemReqArg
  • GetItemText() : VoiceMemoMenuAccessor, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor, MenuAccessor, AbstractActionMenuAccessor
  • GetItemType() : EditorItemNode
  • GetItemUri() : DBItemChangedMsg
  • GetItemWidth() : AbstractMenuAccessor, AbstractListBox
  • GetIterator : SimpleMap< TKey, TValue >, RegEncoderDecoder
  • GetIteratorFilter() : StorageDeviceVisitor, FileVisitor
  • GetJoinRule() : JoinProvider
  • GetJPEGQuality() : CameraSettings
  • GetJpegQuality() : StillCamera
  • GetKey() : SimpleMapElem< TKey, TValue >, PhoneNumber, Hashable, GetInkeyRspArg, StartDtmfReqArg, StartDtmfCnfArg, DrmRightsObject
  • GetKeyCode() : LockedKeyMsg, LockedKeyDownMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, KeyUpInputMapItem, KeyDownInputMapItem, PagingMapEntry, T9MatrixModeKeypressed, TriggerKeyFeature, KeyMsgGenerator::Key
  • GetKeyForFunction() : T9InputConfig
  • GetKeyId() : PbRecordProvider
  • GetKeyIdBuffer() : SimMexeCertificate, MexeDescriptor
  • GetKeyIdLength() : SimMexeCertificate, MexeDescriptor
  • GetKeyItem() : PbDetailProvider
  • GetKeyMap() : ContextManager, ContextDescription
  • GetKeyState() : Keyboard
  • GetLabel() : PropertyDescriptor, AtlLabelListWindow
  • GetLacHigh() : OplEntry
  • GetLacLow() : OplEntry
  • GetLai() : CellInfoIndArg
  • GetLangFileType() : UsimLangUpdReqArg, UsimLangReadReqArg, UsimLangReadIndArg
  • GetLanguage() : System, TextPackConnector, TextPack, Locale, UsimLangUpdReqArg, DataCodingScheme, SimAuxHandler
  • GetLanguageArray() : SimExtLangUpdReqArg, SimLangUpdReqArg, SimExtLangReadIndArg, SimLangReadIndArg
  • GetLanguageAt() : TextPackConnector
  • GetLanguageCode() : LanguageResetAction
  • GetLanguageCount() : LocaleConfig, SimAuxHandler
  • GetLanguageId() : LocaleConfig, Item, Control
  • GetLanguageList() : UsimLangReadIndArg
  • GetLanguageNames() : TextPackConnector
  • GetLanguages() : TextPackConnector
  • GetLanguageType() : LocaleConfig
  • GetLargeAnimationBuffer() : InformationElement
  • GetLargeAnimationLength() : InformationElement
  • GetLargeAnimationStartPosition() : InformationElement
  • GetLargePictureBuffer() : InformationElement
  • GetLargePictureLength() : InformationElement
  • GetLargePictureStartPosition() : InformationElement
  • GetLastAccessTimestamp() : RamFile, FatFile
  • GetLastAesError() : AesCrypt
  • GetLastBufferFilled() : BtObexDataBufferIndicationEvent
  • GetLastCcm() : StatusProvider
  • GetLastCcm2() : StatusProvider
  • GetLastCell() : Grid, GridModel
  • GetLastCompletelyVisibleRow() : GridView
  • GetLastCompleteVisibleIndex() : AbstractGrid
  • GetLastConnectedDevice() : BtHsService
  • GetLastDeletedUniqueId() : PbMergeProvider, PbAdvDataHandler, AdvPbApp
  • GetLastError() : SocketTestApp, ImageEncoder, Camera, FfsFile, StorageDevice, File, DirectoryIterator, FlsFile, PngDecoder, RootStorageDeviceImp, RootDirectoryIteratorImp, RamStorageMapper, RamHandler, RamFileSystem, RamFileObj, RamFile, FatHandler, FatFile
  • GetLastErrorCode() : CrssHandler
  • GetLastFocusedChild() : Control
  • GetLastFocusedControl() : Control
  • GetLastIteration() : SocketTestApp
  • GetLastKnownLocation() : LcsProviderImplBase, LcsProvider
  • GetLastModification() : Provider
  • GetLastNegotiatedDnsServerAddresses() : PdpContextManager
  • GetLastPanelPassThroughRequest() : BtAvrcpControllerDeviceListItem
  • GetLastSimUpdateStatus() : SimAccessor, DataHandler
  • GetLastStackDataCounters() : PdpContextManager
  • GetLastStatus() : SocketTestApp, TermRspCnfArg
  • GetLastTransaction() : DirtyFileHandler
  • GetLastUpdateTimestamp() : RamFile, FatFile
  • GetLastUsed() : MdhSmsStatusIndArg
  • GetLastVisibleIndex() : AbstractGrid, AbstractListBox, AbstractEditBoxModel
  • GetLastVisibleLine() : AbstractEditBoxModel
  • GetLastVisibleRow() : GridView
  • GetLdbId() : T9Pack
  • GetLdbIds() : T9PackConnector
  • GetLdbNumForMode() : EnglishT9InputMapper
  • GetLdbSize() : T9Pack
  • GetLeaf() : Pathname
  • GetLeafMetaData : RegIterator, RegEncoderDecoder
  • GetLedId() : LedNotificationMsg
  • GetLeft() : Rect, WinRect
  • GetLeftGap() : RadioButtonView, CheckBoxView
  • GetLeftSize() : ControlFrameView
  • GetLeftSoftkey() : Window
  • GetLength() : EditorItemNode, EditorLine, TextListLine, EditLine, WString, WStrData, String, StrData, RomData, RamData, DynamicBitVector, DataSourceBinData, ChildBinData, ByteBuffer, BlobPtr, BinData, MemMap, KeySequence, PdpContext::Address, UserData, UserDataHeader, Tpdu, UsimEstReadIndArg, UsimLangReadIndArg, UsimPlmnReadIndArg, UsimUstReadIndArg, InformationElement, Cbs, FileBinData, MeasurementData
  • GetLevel() : ItemMenu, SignalStrengthLevelIndArg
  • GetLevelInfo() : ItemMenu
  • GetLine() : AbstractMultiLineEditor, AbstractEditBoxModel
  • GetLine2VoiceBoxNumber() : SmsSettingsRecord
  • GetLineAlignInc() : AbstractMultiLineEditor
  • GetLineAlignment() : EditorDocument, ParagraphCompoundItem, MultiMediaEditorDocument
  • GetLineCount() : AbstractMultiLineEditor
  • GetLineHeight() : TimeEditorDocument, TimeCompoundItem, TextEditorDocument, TextCompoundItem, IpAddrCompoundItem, EditorDocument, DateEditorDocument, DateCompoundItem, CompoundItem, AbstractEditBoxView, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem
  • GetLineIndex() : AbstractEditBoxModel
  • GetLineInUse() : SimCphsHandler
  • GetLineLength() : AbstractEditBoxModel
  • GetLineLocked() : SimCphsHandler
  • GetLineSelector() : HomezoneMsg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspUpdIndArg, CphsCspReadIndArg, HomezoneIndArg
  • GetLineWidth() : TimeEditorDocument, TimeCompoundItem, TextEditorDocument, TextCompoundItem, IpAddrCompoundItem, EditorDocument, DateEditorDocument, DateCompoundItem, CompoundItem, AbstractEditBox, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem
  • GetLingerOption() : SysSocket
  • GetLingerTimeout() : DataConnProfile, SocketPeer
  • GetLink() : SimSmsrUpdReqArg, SimSmsrReadIndArg, MdhNewStatusReportIndArg
  • GetLinkedAccessory() : AudioDeviceManager
  • GetLinkedAttachmentReq() : BtBipClientService
  • GetLinkedAttachmentRsp() : BtBipServerService
  • GetLinkedThumbnailReq() : BtBipClientService
  • GetLinkedThumbnailRsp() : BtBipServerService
  • GetLinkRecNo() : MdhSmsReportReadIndArg
  • GetList() : AtlItemListWindow
  • GetListBox() : ProvDetailListBoxWin, ProvColListBoxWin, ProvListBoxWin, AbstractListBoxModel
  • GetListBoxRow() : ProvListBoxWin, PbBaseWin, AdvPbWin
  • GetListIndex() : UsimLangReadReqArg
  • GetLlcSapi() : PdpContext::ActivationStatus
  • GetLndTagSize() : SimPbBaseHandler
  • GetLocal() : SysSocket, InetSocket
  • GetLocalAddr() : PsdDataConnProfile
  • GetLocalAddress() : BtLocalSettings
  • GetLocalDataSocketAddr() : FtpClient
  • GetLocalDateAndTime() : RealTimeClock
  • GetLocalDateTime() : RealTimeClock
  • GetLocalId() : DrmWapPushMsg, DrmRightsObject
  • GetLocalIpAddr() : DhChannelOpenReqArg
  • GetLocality() : VCard
  • GetLocalName() : SocketPeer, BtLocalSettings
  • GetLocalPort() : SocketPeer
  • GetLocalSettings() : BtApplication
  • GetLocalSettingsId() : BtLocalSettings
  • GetLocalState() : BtLocalSettings
  • GetLocalTimeZone() : DateTime
  • GetLocation() : MdhSmsReportReadIndArg
  • GetLocationBcdPlmn() : SimAuxHandler
  • GetLocationEstimate() : SaMolrResultArg, LocationResMsg, LcsMolrResultArg
  • GetLocationLac() : SimAuxHandler
  • GetLocationType() : LocationNotifInvokeMsg, LocationNotifInvokeArg
  • GetLocationUpdateStatus() : SimAuxHandler
  • GetLociData() : UsimCsLociReadIndArg, SimAccessor
  • GetLock() : Camera, AbstractLockableDevice
  • GetLockAction() : SimModifyLockIndArg
  • GetLockCommand() : SimModifyLockReqArg
  • GetLockResult() : SimLockStatusMsg
  • GetLockStates() : SimModifyLockReqArg, SimModifyLockIndArg, SimLockStatusIndArg
  • GetLockTable() : LockTableList
  • GetLockTableId() : LockTable
  • GetLockTableList() : LockTableList
  • GetLongFeature() : KeyMapping
  • GetLongKeyDelay() : KeyboardConfig
  • GetLowerCaseChar() : PagingMap, PagingMapEntry
  • GetLowerDestinationPort() : PdpContext::PacketFilter
  • GetLowerSourcePort() : PdpContext::PacketFilter
  • GetLsaIdentifier() : LsaIdentityMsg, MnInformationIndArg, StatusProvider, DataHandler
  • GetMainCause() : StartUp::Data
  • GetMainHandler() : MainHandlerAccess
  • GetMainProvider() : DataControl, DataHandler
  • GetMajorDeviceClass() : BtDeviceAndServiceClass
  • GetMappedColumnId() : SmsFolderProvider
  • GetMappedRow() : DistinctProvider, AbstractDelegationProvider, AppendProvider
  • GetMappingPolicy() : ValueMappingPropertyDescriptor< T_Container >
  • GetMarkDelete() : MetaData
  • GetMaskBuffer() : DisplayConfig
  • GetMasterMute() : AudioDeviceManager
  • GetMasterVolume() : AudioDeviceManager, AudioDeviceBase
  • GetMaxAcm() : SimAuxHandler, SimAccessor
  • GetMaxAdnCount() : SimPbBaseHandler
  • GetMaxAlphaLen() : MePhonebookDescriptor
  • GetMaxAlphaLength() : AtPbSelectCnfArg
  • GetMaxBdnCount() : SimPbBaseHandler
  • GetMaxBitrate() : VideoCaptureParameters
  • GetMaxCbmiCount() : SimAuxHandler
  • GetMaxCbmiRangeCount() : SimAuxHandler
  • GetMaxCcpCount() : SimAuxHandler
  • GetMaxCmiCount() : SimAuxHandler
  • GetMaxConcRefNo() : TpduHeaderInformation
  • GetMaxContentWidth() : AbstractMultiLineEditor
  • GetMaxCount() : SimPduHandler, SimPbBaseHandler
  • GetMaxCphsInfoNoCount() : SimPbBaseHandler
  • GetMaxCphsMBoxCount() : SimPbBaseHandler
  • GetMaxDataSize() : Tpdu, Cbs
  • GetMaxDuration() : VideoCaptureParameters
  • GetMaxEntitledPriority() : EmlppStatusMsg
  • GetMaxEntries() : SimPbEntryCont
  • GetMaxExtLangCount() : SimAuxHandler
  • GetMaxFdnCount() : SimPbBaseHandler
  • GetMaxFileSize() : RecordSettings
  • GetMaxFramerate() : VideoCaptureParameters
  • GetMaxImages() : BtBipGetImagesListIndArg
  • GetMaxImageSize() : BtBipImageDesc, BtBipImageFormat
  • GetMaximalFoundDevices() : BtDeviceSearchRequest
  • GetMaximumValue() : ValueIndicator
  • GetMaximumWidth() : TabButtonView
  • GetMaxInputLen() : GetInputReqArg
  • GetMaxItemCount() : TimeEditorDocument, TextEditorDocument, IpAddrEditorDocument, EditorDocument, DateEditorDocument, AbstractEditor, MultiMediaEditorDocument
  • GetMaxLangCount() : SimAuxHandler
  • GetMaxLndCount() : SimPbBaseHandler
  • GetMaxMbdnCount() : SimPbBaseHandler
  • GetMaxMbiCount() : SimAuxHandler
  • GetMaxMediaLength() : VideoCaptureParameters
  • GetMaxMessageId() : CbsLimitMsg, CbsLimitIndArg
  • GetMaxMimeTypeId() : MimeTypeTable, MimeTypeTable::Partition
  • GetMaxMsisdnCount() : SimPbBaseHandler
  • GetMaxNoOfDcsRanges() : Cbs::Filter
  • GetMaxNoOfMidRanges() : Cbs::Filter
  • GetMaxNumberOfElements() : EmzUtils::Queue< T >
  • GetMaxNumbersStored() : SimChvHandler
  • GetMaxPages() : Cbs
  • GetMaxPduSize() : SmsEditor
  • GetMaxPhonenos() : PhonebookApp, AdvPbApp
  • GetMaxPlmnCount() : SimAuxHandler
  • GetMaxRecordingDuration() : RecordSettings
  • GetMaxResolution() : VideoCaptureParameters
  • GetMaxSdnCount() : SimPbBaseHandler
  • GetMaxSmspCount() : SimSmsParamHandler
  • GetMaxTextLength() : PasswordEditor, MultiLineEditor, LineEditor, AbstractEditBox, AbstractEditBoxModel
  • GetMaxUserDataSize() : SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver
  • GetMaxUsers() : ServerConfig, Server
  • GetMaxValue() : PositionIndicator
  • GetMaxVisibleItems() : AbstractListBox, AbstractListBoxModel
  • GetMaxVisibleRows() : GridModel
  • GetMaxZoomLevel() : CamWin32
  • GetMbdnTagSize() : SimPbBaseHandler
  • GetMbi() : SimAccessor
  • GetMbiCount() : SimAccessor
  • GetMbiRecord() : SimAuxHandler
  • GetMbiRecordSize() : SimAuxHandler
  • GetMCbData() : EmServThreadMsg
  • GetMCbFnPtr() : EmServThreadMsg
  • GetMeanRate() : PdpContext::QualityOfService
  • GetMedia() : MediaObtainer
  • GetMediaAvailableStatus() : StorageDevice, FatStorageDeviceImp
  • GetMediaCodec() : MediaInfo::MediaTrackInfo
  • GetMediaFileFilter() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer
  • GetMediaMimeType() : DrmMessage
  • GetMediaName() : StorageDevice
  • GetMediaObject() : DrmMessage
  • GetMediaObjectLen() : DrmDcfParser
  • GetMediaObjectOffSet() : DrmDcfParser
  • GetMediaSink() : RecordSettings
  • GetMediaSinkType() : RecordSettings
  • GetMediaType() : StreamAudioReference
  • GetMember() : MptyCallHdl
  • GetMemberCount() : MptyCallHdl
  • GetMemMap() : BinData
  • GetMemorySize() : BtSddbServiceRecord, BtSddbServiceAttribute, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeOneByteDescriptionType, BtSddbDataElement
  • GetMemorySizeOfContainedDataElements() : BtSddbDeContainer
  • GetMemSize() : WString, String
  • GetMenu() : AtlItemMenuWindow, MenuPool, FeatureBroker
  • GetMenuAccessor() : Menu, SubMenuAction, AccessorActionExtension, AccessorAction
  • GetMenuDesc() : MenuDescObj
  • GetMenuId() : MenuIdObj, SoftkeyDesc
  • GetMenuID() : AtlItemMenuWindow
  • GetMenuPool() : AtlConfig
  • GetMenuProperties() : MenuDesc
  • GetMenuType() : AtlItemMenuWindow, MenuProperties
  • GetMePhoneBookType() : PbEntryRequestMsg, PbSizeRequestMsg, MePhonebookDescriptor, AtPbListCnfArg, AtPbSelectCnfArg, AtPbListReqArg, AtPbSelectReqArg
  • GetMergedFilter() : CbsFilterList
  • GetMergedKeyColumnId() : MergeProvider
  • GetMergedProvider() : MergeProvider
  • GetMergeRule() : MergeProvider
  • GetMessage() : SocketTestMessage, MessageReferrer
  • GetMessageClass() : DataCodingScheme, TpduHeaderInformation
  • GetMessageCode() : Cbs::SerialNumber
  • GetMessageID() : AudioUserDefinedMsg
  • GetMessageId() : MessageHook
  • GetMessageIdentifier() : CbsNewDataRejArg, Cbs
  • GetMessageNumber() : SmsContext, SmsCommand
  • GetMessageReference() : SmsCommand, SmsStatusReport, SmsSubmit
  • GetMessageRouter() : System
  • GetMessageText() : UtcStatusMessage, AsyncUnitTestMsg
  • GetMessageType() : UibApp, SmsContext, ProtocolIdentifier, TpduHeaderInformation
  • GetMessageTypeIndicator() : Tpdu
  • GetMetaData() : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, SoundRef, SoundBrowserServiceMsg, MediaRef, SkipSocketTestMsg, StopSocketTestMsg, ContinueSocketTestMsg, NextSocketTestMsg, StartSocketTestMsg, OnDataRcvdMsg, LcsAppResWinMsg, LcsAppRegisterForMtlrMsg, LcsAppTransferLocMsg, ImageRef, ImageBrowserServiceMsg, ImageBrowserRenameImageMsg, ImageBrowserDeleteImageMsg, MediaRef, SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, CameraMsgStopViewfinding, CameraMsgStartViewfinding, BtIndicatorMsg, PhonebookRenumberedMsg, ProviderUpdateMsg, SyncProgressMsg, SaveEntryInPhonebookMsg, OpenPbWinMsg, JumpToRowMsg, UtcStatusMessage, AsyncUnitTestMsg, DataConnProfileInfoMsg, DataConnInfoMsg, SocketControlMsg, ObexVCardMsg, ObexTransportMsg, ObexAddrMsg, ObexTriggerMsg, ObexMsg, ObexAppMsg, LoseFocusMsg, GetFocusMsg, ContextExecuteMsg, TimerTimeoutMsg, AlarmNotificationMsg, ShutdownRequestMsg, ContextWakeupMsg, ThreadletNotificationMsg, SharedTimerMsg, AppLoseFocusMsg, AppGetFocusMsg, ServiceThreadTerminateMsg, RtcAlarmReachedMsg, RtcDateChangedMsg, RtcTimeChangedMsg, ActionExecutedMsg, ItemPropertiesChangedMsg, ExternalTimeoutMsg, PenUpMsg, PenDownMsg, InputCharMsg, LockedKeyMsg, LockedKeyDownMsg, FlipMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, PowerWakeupMsg, LanguageChangedMsg, ThemeChangedMsg, AppUpdateDisplayMsg, AppCloseMsg, AppOpenMsg, PowerOffMsg, PowerOnMsg, NoMessage, ControlMsg, ContextMsg, Message, RedrawDisplayMsg, ItemRendererPropertiesChangedMsg, ImageEncodingProgressMsg, DeleteComponentMsg, ImageDrawingInterruptedMsg, Zi8EnteredUnknownWordMsg, Zi8AddWordMsg, Zi8NoWordFoundMsg, T9MatrixModeKeypressed, T9SymbolEntryRequestMsg, T9EnteredUnknownWordMsg, T9AddWordMsg, T9NoWordFoundMsg, AragonMsg, CloseWindowMsg, RefreshComponentMsg, ContextMenuClosedMsg, ViewfinderErrorMsg, ImageDecodingProgressMsg, InvalidateMsg, SelectionChangedMsg, FocusPreviousControlMsg, FocusNextControlMsg, ImageDecoder, Image, EncodingThreadlet, RtcInfoMsg, TransportNotificationMsg, LedNotificationMsg, DisplayInfoMsg, BatteryLoadLevelMsg, ChargerInfoMsg, BtObexClientRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtHsRequestStateChangedMessage, BtHsNotificationMessage, BtHfRequestStateChangedMessage, BtHfNotificationMessage, BtFaxRequestStateChangedMessage, BtFaxDisconnectMessage, BtFaxConnectMessage, BtFaxApplicationMessage, BtDunRequestStateChangedMessage, BtDunDisconnectMessage, BtDunConnectMessage, BtDunApplicationMessage, BtRequestStateChangedMessage, BtServiceMessage, BtSddbRequestStateChangedMessage, BtRequestOperationMessage, BtCloseMessage, BtOpenMessage, BtRequestMessage, BtCancelVerifyMessage, BtServiceVerifyResultMessage, BtServiceVerifyMessage, BtPaSupportedProfileMessage, BtHfSupportedProfileMessage, BtHsSupportedProfileMessage, BtQuerySupportedProfilesMessage, BtDeviceUntrustMessage, BtDeviceTrustMessage, BtDeviceUnpairMessage, BtDevicePairMessage, BtSetRemoteDeviceNameMessage, BtCancelSearchMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtDeviceSearchMessage, BtRespondAuthorizationMessage, BtSendPasskeyMessage, BtProfileActivationMessage, BtConnectabilityMessage, BtPairabilityMessage, BtDiscoverabilityMessage, BtLocalNameMessage, BtLocalSettingsMessage, BtStateChangedMessage, BtGapAndSdapRequestMessage, BtRemoteDevicePairMessage, BtGapAndSdapNotificationMessage, BtAuthorizationRequiredMessage, BtPasskeyRequiredMessage, BtGapAndSdapRemoteRequestMessage, BtGapAndSdapApplicationMessage, BtApplicationMessage, BtBppRequestStateChangedMessage, BtBipProgressMsg, BtAvrcpRequestStateChangedMessage, BtAvrcpOperationServiceMessage, BtAvrcpNotificationMessage, AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStreamingSyncMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRadioDeviceNotificationMsg, AudioPlayTimeMsg, AudioMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioFmRadioRdsAlternativeFrequenciesMsg, AudioFmRadioRdsInfoMsg, AudioFmRadioRdsRadioTextMsg, AudioFmRadioRdsStationNameMsg, AudioFmRadioRdsRawDataMsg, AudioFmRadioRssiMsg, AudioFmRadioSeekMsg, AudioAccessoryConnectedMsg, AudioRecordingStoppedMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg, AudioErrorMsg, AudioDeviceStatusMsg, DisabledFeatureTriggeredMsg, UpdateItemMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg, PropertyTriggerMsg, FeatureChangedMsg, UpdateContextItemMsg, CloseAllMsg, IndicatorBarUpdateMsg, UssdBeginMsg, UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, UusQueryRejectedMsg, UusStatusMsg, GetPasswordMsg, UssdRequestResentMsg, UssdDataMsg, UssdEndMsg, UssdNotifyMsg, UssdRequestMsg, SsErrorMsg, CallBarringPasswordChangedMsg, ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, CnapInfoReceivedMsg, EctAlertingMsg, EctActiveMsg, MultiPartyCallInvokedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, CugCallMsg, HlrDataCorruptedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallIsWaitingMsg, CallRetrievedMsg, CallHeldMsg, CallForwardingActiveMsg, ClirNotSurpressedMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, CtmInfoIndMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, PbAlphaTagRequestMsg, PbEntryRequestMsg, PbSizeRequestMsg, CbsLimitMsg, SmsMessageWaitingChangedMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceAvailableMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsPortDataRecvMsg, SmsNewSocketDataMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, RatChangeModeChangedMsg, EngineeringModeControlResponseMsg, BandStatusMsg, GsmBandStateMsg, RatStateMsg, NwDiscStartIndMsg, HomezoneMsg, BandSelectionMsg, EngineeringReportMsg, UssdAnswerMsg, CcbsResultMsg, CcbsStatusMsg, CcbsRecallMsg, SsInfoMsg, SsFacilityRejectedMsg, UssdResentMsg, UssdIndicationMsg, PasswordRejectedMsg, PasswordInquiryMsg, SsErrIndicationMsg, SsRejectedMsg, SsEndMsg, SsSuccessMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, MocSetupRejectIndMsg, CallControlInfoMsg, RedialStatusMsg, DiagnosticIndMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, RedialStoppedMsg, RedialStartedMsg, CallNotifyMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfBufferCleanedMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, PowerModeIndMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, OmMultiSlotIndMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, SimTkProfileSetRejMsg, SimTkProfileSetCnfMsg, SimTkProfileGetCnfMsg, SimTkRefreshStartMsg, TermRspCnfMsg, SimTkSetupEventMsg, SimTkLanguageNotificationMsg, MptyHoldRejectedMsg, MptyOnHoldMsg, CallHoldRejectedMsg, CallOnHoldMsg, SimCallSetupRejectedMsg, SimEndTransactionMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimMenuItemSelectionFailedMsg, SimSetupMenuMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetDoneMsg, SimResetConfirmationMsg, SimRefreshResetMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, RegistrationAllowedMsg, PlmnScanFinishedMsg, RegistrationChangeMsg, RegistrationSuccessMsg, AccessoryIndMsg, SignalQualityLevelMsg, SignalStrengthLevelMsg, MinuteTickMsg, AlarmMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, LsaIdentityMsg, TimeZoneMsg, NetworkInformationMsg, SimErrorMsg, CfuStatusMsg, MptyCallReleaseMsg, CallReleaseMsg, CallAcceptMsg, ExternalPdpContextInfoMsg, GprsAttachStatusMsg, PdpContextActivationStatusMsg, ChvChangedMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg, CallEventMsg, GprsStatusMsg, SimLockStatusMsg, SimStateChangedMsg, SsMessage, ToStackMsg, FromStackMsg, RfsStorageDeviceRegistrationStatusMsg, RfsMediaAvailableStatusMsg, FileChunkOperationProgressMsg, RegNotifyMsg, VrRecognitionFailedMsg, VrTrainingFailedMsg, VrPlaybackFinishedMsg, VrTrainingResultMsg, VrRecognitionStoppedMsg, VrTrainingAbortedMsg, VrRecognitionAbortedMsg, VrWarningMsg, VrErrorMsg, VrResultMsg, VrPromptMsg, DBItemChangedMsg, SvgHyperlinkSelectMsg, SvgStatusMsg, SvgDecodingFinishedMsg, HttpDisconnectMessage, HttpConnectMessage, HttpRequestMessage, HttpErrorMessage, HttpServiceMessage, FtpDisconnectMessage, FtpConnectMessage, FtpRequestMessage, FtpTransferMessage, FtpErrorMessage, FtpServiceMessage, MmCallReleaseMsg, MmCallAcceptMsg, MmAocChargingStatusMsg, MmCurrentCallMeterMsg, MmCurrentChargeDataMsg, MmCallNotifyMsg, MmCallInfoMsg, MmCallSetupProgressMsg, MmMocSetupAcceptMsg, MmCallDisconnectingMsg, MmCallStatusMsg, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg, CloseDataConnMsg, GltpConnStatusMsg, SendRequestMsg, SetupDataConnMsg, ProcessMolrMsg, ProviderChangedMsg, AbortResMsg, LocationErrMsg, LocationResMsg, LocationNotifInvokeMsg, AppActionExecutedMsg, DrmWapPushMsg, FatFsUsbMassStorageReleaseMsg, FatFsUsbMassStorageRequestMsg, UsimPbResetedMsg, UsimPbReadyMsg, DataControlPhonebookStateMsg, DataControlEndBootMsg, DataControlBootMsg, DataControlBootProgressMsg, DataControlStartBootMsg, DataControlModificationMsg
  • GetMetaDataCapacity() : Fota
  • GetMetaDataRecord() : SoundMetaData, MetaData, ImageMetaData, MetaData
  • GetMeteringMode() : Camera
  • GetMexeCertificateContent() : SimAccessor
  • GetMexeCertType() : SimMexeCertificate, MexeDescriptor
  • GetMexeRootPublicKeyProperty() : SimAccessor
  • GetMexeRootPublicKeyRecord() : SimAccessor
  • GetMexeSt() : SimAccessor
  • GetMHAudDevice() : EmServThreadMsg
  • GetMicrophoneGain() : BtHsService, BtHfService, BtAudioAccessoryService
  • GetMiddleGap() : RadioButtonView, CheckBoxView
  • GetMillisecond() : Time, DateTime
  • GetMimeContentType() : SvgMimeUtil
  • GetMimeStrByExt() : MimeTypeTable
  • GetMimeStrByFileType() : FfsMimeTypeMap
  • GetMimeStrByMimeType() : MimeTypeTable
  • GetMimeType() : MetaData, FilePackConnector, BtBipAttachmentDesc, BtBipAttachment, BtBipAttachmentFormat, Pathname, Path, Media
  • GetMimeTypeByExt() : MimeTypeTable
  • GetMimeTypeByFileType() : FfsMimeTypeMap
  • GetMimeTypeByMimeStr() : MimeTypeTable
  • GetMimeTypeSupportInfo() : MmfPlayer, MapiAudioPlayer
  • GetMinimalWidth() : MultiTapCaret, DefaultCaret, Caret
  • GetMinimumQualityOfService() : PdpContext
  • GetMinimumValue() : ValueIndicator
  • GetMinimumWidth() : TabButtonView
  • GetMinInputLen() : GetInputReqArg
  • GetMinMimeTypeId() : MimeTypeTable::Partition
  • GetMinorDeviceClass() : BtDeviceAndServiceClass
  • GetMinute() : TimeEditBox, TimeSpan, Time, DateTime
  • GetMinValue() : PositionIndicator
  • GetMIsAudioMuted() : EmServThreadMsg
  • GetMlcNumber() : LcsAppTransferLocMsg
  • GetMmfresult() : MediaManagerMsg
  • GetMmiName() : AbstractTransport
  • GetMocType() : MoCallAction
  • GetMode() : PredInputMapper, IconState, Caret, AudioContext, StreamAudioReference, PlmnListReqArg, PlmnInfoReqArg, AttachReqArg, AttachCnfArg, RegStateIndArg, Cbs::Filter, Zi8Wrapper, Zi8InputMapper, T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper, AbstractPredictiveInputBox
  • GetModel() : ImageView, Component
  • GetModificationDate() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FlashFileImp, FatFileImp
  • GetModificationState() : XCallInfoResponseParser
  • GetModificationTime() : File::Attributes
  • GetModificationType() : Provider
  • GetModified() : BtBipImage
  • GetModifiedFrom() : BtBipImageHdlDesc
  • GetModifiedRow() : Provider
  • GetModifiedTo() : BtBipImageHdlDesc
  • GetModifyDate() : BtBipAttachment
  • GetMolr() : LcsReqProcessor
  • GetMolrInfo() : ProcessMolrMsg
  • GetMolrParams() : MolrParams
  • GetMolrStatus() : LcsReqProcessor
  • GetMoMimeType() : DrmRightsObject
  • GetMonoStereoMode() : StreamAudioReference
  • GetMonth() : Date
  • GetMptyCallHdl() : MptyCallHdl
  • GetMptyChannelNo() : MptyCallHdl
  • GetMsgId() : SocketControlMsg, AppRoutingTableEntry
  • GetMsgType() : ObexTransportMsg, ObexMsg, ObexAppMsg, TransportNotificationMsg
  • GetMsgTypeCount() : SmsMsgTypeTextMap
  • GetMsgTypeName() : SmsMsgTypeTextMap
  • GetMsgTypeUsageCount() : SmsMsgTypeUsageTextMap
  • GetMsgTypeUsageName() : SmsMsgTypeUsageTextMap
  • GetMsgWaitingState() : SmsIndicationState
  • GetMsIsdnProvider() : PbDataHandler
  • GetMsisdnTagSize() : SimPbBaseHandler
  • GetMsmtRequest() : GltpAidDataRequests
  • GetMsrData() : MeasurementData, MeasurementDataArg
  • GetMStartStopAudio() : EmServThreadMsg
  • GetMtlr() : LcsReqProcessor
  • GetMultiModeSetResult() : MultiSlotDispatcher
  • GetMultiSlotMode() : OmMultiSlotReqArg
  • GetMute() : SpeechSimpleAudioDevice
  • GetMutex() : FfsTestDispWin, AudioDeviceBase
  • GetMyPbProvider() : ProvDetailListBoxWin, ProvColListBoxWin, PbDetails, PbBaseWin, PbAbstractWin, AdvPbWin
  • GetNai() : SimNextActionIdentifier
  • GetName() : UibMsgDisplayTest, UibAccessorTest, PhonebookApp, PbRecord, PbAdvAddEditEntry, SaveEntryInPhonebookMsg, SocketSubSystem, DataConnProfileManager::ProfileInfo, DataConnProfile, SubSystem, Thread, GenericWorkerTask, Application, IrdaObexSubSystem, Theme, RomFont, FontEntry, Font, AcacLanguage, FoggyTheme, DefaultTheme, CustomizableTheme, CTResourcePack, VoiceMemoAudioDevice, VirtualDisplay, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, MiscAudioDevice, KeyToneAudioDevice, GenericAudioDevice, GatiManager, DefaultDisplay, AmplifierAudioDevice, VideoCamera, StillCamera, VirtualDisplay, DefaultDisplay, BackLight, RealTimeClock, VirtualDisplay, DefaultDisplay, BackLight, VirtualDisplay, DefaultDisplay, BackLight, Led, Keyboard, Fota, Charger, VirtualDisplay, DefaultDisplay, AbstractDevice, Sound, PreparedSound, Melody, Audio, BtObexSubSystem, BtObexController, BtBppController, BtBipAttachmentDesc, BtBipAttachment, AudioPresetStore, AudioPreset, AudioAccessoryStore, AudioAccessoryDetails, StackControl, KeyMsgGenerator, StorageDevice, File, RegManager, UsbSubSystem, HttpApplication, SerialSocketSubSystem, DrmSubsystem, RamFileObj, SimSmsParameter, SimPbEntry, DataControl
  • GetNameForNumber() : AbstractSmsApp
  • GetNamePattern() : NamePatternFileFilter
  • GetNamePrefix() : VCard
  • GetNameProvider() : PbAdvDataHandler
  • GetNameRecNo() : PbNumberRecord
  • GetNameRowForRecNo() : PbNameProvider
  • GetNameSuffix() : VCard
  • GetNativeAddr() : IpAddr
  • GetNativeDirectoryPathname() : StorageDevice, File, RootStorageDeviceImp, RamStorageDeviceImp, RamFileObj, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetNativeEncoding() : BtBipImageProperties
  • GetNativeFilePathname() : StorageDevice, File, RootStorageDeviceImp, RamStorageDeviceImp, RamFileObj, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetNativeFormat() : BtBipImageProperties
  • GetNativeHeight() : BtBipImageProperties
  • GetNativeName() : AcacLanguage
  • GetNativeParams() : VrEngineParams, TelecaVrEngineParams, DummyVrEngineParams
  • GetNativePortNumber() : IpPortNo
  • GetNativeProperty() : StorageDevice, File, RootFileImp, FlashFileImp, FatFileImp
  • GetNativeSize() : BtBipImageProperties
  • GetNativeVolumeMax() : SpeechSimpleAudioDevice
  • GetNativeVolumeMin() : SpeechSimpleAudioDevice
  • GetNativeWidth() : BtBipImageProperties
  • GetNavigationGuidance() : Control
  • GetNetAdapter() : NetAdapterHandler
  • GetNetworkNameLong() : NetworkInformationMsg, MnInformationIndArg, StatusProvider, DataHandler
  • GetNetworkNameShort() : NetworkInformationMsg, MnInformationIndArg, StatusProvider, DataHandler
  • GetNetworkSearchMode() : MnNetworkSearchModeReqArg
  • GetNewChildRow() : AbstractDelegationProvider
  • GetNewchv() : ChvUnblockReqArg, ChvChangeReqArg
  • GetNewFilename() : RenameFileDialog
  • GetNewName() : ImageBrowserRenameImageMsg
  • GetNewPassword() : CallBarringPasswordChangedMsg, PasswordChangeSsAction
  • GetNewPassword2() : PasswordChangeSsAction
  • GetNewPath() : BrowserSaveWin, CameraCaptureWin
  • GetNewPin() : PinAction
  • GetNewPin2() : PinAction
  • GetNewPropertyValue() : PropertyEditor
  • GetNewRequestState() : BtRequestStateChangedMessage
  • GetNewSmsState() : SmsIndicationState
  • GetNewStatRepState() : SmsIndicationState
  • GetNewTipd() : UssdRequestResentMsg
  • GetNewWord() : Zi8AddWordMsg, T9AddWordMsg
  • GetNext() : VersionInfo, UserDispatcher, DrawableObject, Control, BtSddbDeContainer, BtMultiConnectionController::BtConnection, BtDeviceList::BtDeviceListNode, Linkable< T >, LinkableBase, MenuTableNode, ContextTableNode, DeletedNode
  • GetNextAttribute() : BtSddbServiceRecord
  • GetNextConnection() : BtMultiConnectionController
  • GetNextExtension() : MimeTypeTable
  • GetNextFrame() : EmsImage, NativeImage, Image, SvgImage, WbmpImage, PngImage, JpegImage, GifImage, BmpImage
  • GetNextFreeId() : FfsHandler
  • GetNextFreePosition() : SimPbBaseHandler
  • GetNextFreeTpduNo() : SimPduHandler
  • GetNextFreeUniqueId() : PbNextFreeIdRecord
  • GetNextHighDcs() : Cbs::Filter
  • GetNextHighMid() : Cbs::Filter
  • GetNextInformationElement() : UserDataHeader
  • GetNextItem() : DBService::DBItemIterator
  • GetNextItemMetaInfo() : DBService::DBItemIterator
  • GetNextKey() : AtKeyParser
  • GetNextLexToken() : LexAnalyzer
  • GetNextLocalId() : DrmRightsObjectStore
  • GetNextLockTable() : LockTable
  • GetNextLowDcs() : Cbs::Filter
  • GetNextLowMid() : Cbs::Filter
  • GetNextPageEntry() : HeapManager
  • GetNextPixelColor() : PngDecoder
  • GetNextResponse() : AtResponseIterator
  • GetNextToken() : InputParser
  • GetNoBytesReadable() : ObexBuffer::Reader
  • GetNoBytesWritable() : ObexBuffer::Writer
  • GetNodeBuffer() : RegMemoryPool
  • GetNodeBufferRawMemory() : RegNodeBuffer
  • GetNodeEntry() : NodeFileHandler
  • GetNodeIndex() : RegNodeBuffer
  • GetNodeRecord() : RegNodeBuffer
  • GetNodeRecordPtr() : RegNodeBuffer
  • GetNofFiles() : FfsHandler
  • GetNofFilesByType() : FfsHandler
  • GetNoId() : PbNumberRecord
  • GetNoImages() : SimIconDescription
  • GetNonDtmfPhoneNumber() : PhoneNumber
  • GetNoNvramSms() : MdhSmsTransmitStartIndArg
  • GetNoOfApplications() : AppContainerRoutingTableEntry
  • GetNoOfAuthorizationSets() : WapProfile
  • GetNoOfAuthorizationSetsSupported() : WapProfile
  • GetNoOfCells() : Grid, GridModel
  • GetNoOfColumns() : Grid, GridModel
  • GetNoOfDcsRanges() : Cbs::Filter
  • GetNoOfFittingChars() : AbstractEditBox
  • GetNoOfGroups() : CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspReadIndArg
  • GetNoOfIcons() : SimIconIdentifier
  • GetNoOfItems() : AbstractListBox, AbstractListBoxModel
  • GetNoOfLines() : AbstractEditBoxModel
  • GetNoOfMidRanges() : Cbs::Filter
  • GetNoOfNai() : SimNextActionIdentifier
  • GetNoOfNodes() : UriMappingTable
  • GetNoOfPages() : Cbs::Filter
  • GetNoOfPhysicalPortSets() : WapProfile
  • GetNoOfPhysicalPortSetsSupported() : WapProfile
  • GetNoOfPhysicalSets() : WapProfile
  • GetNoOfPhysicalSetsSupported() : WapProfile
  • GetNoOfPortSets() : WapProfile
  • GetNoOfPortSetsSupported() : WapProfile
  • GetNoOfRows() : Grid, GridModel
  • GetNoOfSaved() : MdhSmsWriteCnfArg
  • GetNoOfSoftkeys() : SoftkeyBar
  • GetNoOfSubunitInfoEntries() : BtAvrcpSubunitInfoParams
  • GetNoOfSubunits() : BtAvrcpRegisterParams
  • GetNoOfTpdus() : SmsFactory
  • GetNoOfVisibleLines() : AbstractEditBoxModel
  • GetNoSimSms() : MdhSmsTransmitStartIndArg
  • GetNote() : CalendarRecordsListBoxModel
  • GetNotification() : LedNotificationMsg, MdhSmsStatusIndArg
  • GetNotificationDescription() : MmCallNotifyMsg
  • GetNotificationType() : SimPbBaseHandler
  • GetNotifType() : LocationNotifInvokeMsg, LocationNotifInvokeArg
  • GetNotifySsArg() : SsNotifyIndArg
  • GetNoTypeAction() : AdvPbApp
  • GetNPI() : PhoneNumber
  • GetNrClutEntries() : SimImage
  • GetNrOfBits() : BitField< T >
  • GetNrOfOpenedTransports() : ObexServerDispatcher
  • GetNrOfParameters() : AtResponse
  • GetNsapi() : PsdDataConn, DataConn
  • GetNullStr() : WStrData, StrData
  • GetNumber() : KeyboardConfig, PagingMap, PagingMapEntry, DataItem, GenericFeatureData, Property
  • GetNumberingPlanIdentification() : TypeOfAddress
  • GetNumberOfAddresses() : VCard
  • GetNumberOfAttributes() : BtSddbServiceRecord
  • GetNumberOfAttributesRequested() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetNumberOfBytes() : BtObexClientNmaDataBufferIndication, BtObexServerNmaDataBufferIndication
  • GetNumberOfChannels() : CustomSmafPhraseAudioReference, AudioReference, MediaInfo::AudioTrackInfo
  • GetNumberOfDataElements() : BtSvrDataElement
  • GetNumberOfEntries() : DataPack, BasicPackConnector, AtResponseInfoTable, AtCommandInfoTable
  • GetNumberOfFiles() : FilePackConnector
  • GetNumberOfFonts() : FontPackConnector, FontManager
  • GetNumberOfFrequencies() : AudioFmRadioRdsAlternativeFrequenciesMsg
  • GetNumberOfInitialDecodeOperations() : ScicosMpeg4VideoDecoder, EmzH264Decoder, EmzMpeg4Decoder, EmzH264Decoder
  • GetNumberOfLanguages() : TextPackConnector
  • GetNumberOfLdbs() : T9PackConnector
  • GetNumberOfRingSignals() : BtHsService
  • GetNumberOfServiceAttributes() : BtSvrServiceRecord
  • GetNumberOfServiceRecords() : BtServiceVerifyResult
  • GetNumberOfServicesToVerify() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetNumberOfStrings() : AcacLanguage
  • GetNumberOfTones() : CustomToneAudioReference
  • GetNumberProvider() : PbAdvDataHandler
  • GetNumbersOfFrames() : AudioUtility
  • GetNumBoundaries() : MultipartParser
  • GetNumerator() : Fraction
  • GetNumGlyphs() : FontManager, FontEntry
  • GetNumOfDataStores() : SyncMLManager
  • GetNumOfNodeRecord() : RegNodeBuffer
  • GetNumOfValidDigits() : PhoneNumber
  • GetNvRamPduCount() : SimAccessor
  • GetOaPhoneNumber() : SmsNewMessageIndArg
  • GetObexHandle() : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexController::BtObexConnection
  • GetObexInstance() : BtObexTransport
  • GetObexResponseCode() : BtObexResponseCode, BtBipClientService
  • GetObexResponseCodeByte() : BtObexResponseCode
  • GetObexResult() : BtBipOpFinishedArg
  • GetObexTarget() : BtObexServiceTable::ServiceInfo
  • GetObject() : ObexMsg, ObjectObtainer
  • GetObjectHint() : ObjectObtainer
  • GetObjectId() : ObexAbstractTransport
  • GetObjectReplacementCharacter() : T9InputConfig
  • GetObjectTreeforURI() : GuidServiceTable
  • GetObtainedCount() : ObtainableObject
  • GetObtainedDocument() : EmsEditor
  • GetOffset() : ObexBuffer::Writer, ObexBuffer::Reader, AnimatedTextLine, TimeZone
  • GetOldchv() : ChvChangeReqArg
  • GetOldPassword() : PasswordChangeSsAction
  • GetOldPin() : PinAction
  • GetOldRequestState() : BtRequestStateChangedMessage
  • GetOldTipd() : UssdRequestResentMsg
  • GetOpCode() : BtAvrcpRawFrameParams
  • GetOpcode() : DBItemChangedMsg
  • GetOpenFilesCounter() : StorageDevice, RootStorageDeviceImp
  • GetOpenPbWinAction() : PhonebookApp
  • GetOperands() : BtAvrcpRawFrameParams
  • GetOperandsLength() : BtAvrcpRawFrameParams
  • GetOperation() : BtRequestOperationMessage, BtAvrcpPanelPassThroughParams
  • GetOperationCode() : StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, SsUssdReqArg, UssdAnswerIndArg, SsUssdIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg
  • GetOperationData() : BtAvrcpPanelPassThroughParams
  • GetOperationDataLength() : BtAvrcpPanelPassThroughParams
  • GetOperationId() : ObexTransportMsg, ObexMngr::SelectCommand, ObexAddrMsg, ObexMsg, StreamObexImpl
  • GetOperationService() : BtAvrcpControllerDeviceListItem
  • GetOperationState() : StreamingInfo
  • GetOperationType() : BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice, BtOperationBase
  • GetOplInfo() : SimAccessor
  • GetOplRecord() : SimAccessor
  • GetOpName() : SimCphsHandler
  • GetOpShortName() : SimCphsHandler
  • GetOption() : SysSocket
  • GetOptionKey() : KeyboardConfig
  • GetOptions() : SetupIdleModeTextReqArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • GetOpType() : DrmPermission
  • GetOrangeParam() : SimAccessor
  • GetOrangeWelcomeMsg() : SimCphsHandler
  • GetOrganizationalUnit() : VCard
  • GetOrganizationName() : VCard
  • GetOrientation() : PositionIndicator, IndicatorBar
  • GetOrig1TextInfoAlpha() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • GetOrig2TextInfoAlpha() : CallControlSetupIndArg
  • GetOriginalRow() : Provider::Modification
  • GetOriginatingAddress() : SmsDeliver
  • GetOriginatorApplicationPortAddress() : SmsContext
  • GetOriginType() : MessageTypeIndicator
  • GetOutboxProvider() : AbstractSmsApp
  • GetOutputFrame() : ScicosMpeg4VideoDecoder
  • GetOverallMemUsage() : HeapManager
  • GetOwner() : Panel
  • GetOwnerContext() : InetSocket
  • GetPackedTime() : ValidityPeriod
  • GetPacketFilter() : PsdDataConnProfile
  • GetPage() : TabControl, BtAvrcpSubunitInfoParams
  • GetPageFlag() : Zi8SelectionBox, Zi8AlphabetBox
  • GetPagingMap() : LocaleConfig, ResourceManager
  • GetPagingMapEntry() : PagingMap, AbstractEditBox
  • GetPagingTimeout() : EditConfig
  • GetPair() : SimpleMap< TKey, TValue >::Iterator
  • GetPairableMode() : BtLocalSettings
  • GetPairedDeviceCount() : BtAvrcpControllerApplicationWindow
  • GetPanel() : Application
  • GetPanelAlignment() : Desktop
  • GetPanelBounds() : Desktop
  • GetPanelPassthroughParams() : BtAvrcpNmaPanelPassThrough
  • GetPanelPassThroughParams() : BtAvrcpPanelPassThroughRequest
  • GetPanelView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme
  • GetPaProfileName() : BtPaSupportedProfileMessage
  • GetParam() : VideoChannel, EngineeringModeControlRequestArg, Accessory
  • GetParam1() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • GetParam2() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • GetParam3() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • GetParam4() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • GetParamBasicService() : CallWaitingDeactivatedMsg, CallWaitingActivatedMsg
  • GetParamConfPassword() : CallBarringPasswordChangedMsg
  • GetParameter1() : SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg
  • GetParameter2() : SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg
  • GetParameter3() : SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg
  • GetParameterAt() : AtResponse
  • GetParameterBasicService() : CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg
  • GetParameterIndicator() : SmsStatusReport
  • GetParameterPhonenumber() : CallForwardingRegisteredMsg, CallForwardingActivatedMsg
  • GetParameters() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AudioEncoder, AudioDecoder
  • GetParameterSsCode() : CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg
  • GetParameterTimeOut() : CallForwardingRegisteredMsg, CallForwardingActivatedMsg
  • GetParameterType() : AtResponseParameter
  • GetParamNewPassword() : CallBarringPasswordChangedMsg
  • GetParamOldPassword() : CallBarringPasswordChangedMsg
  • GetParams() : FtpRequest
  • GetParamSsCode() : CallBarringPasswordChangedMsg
  • GetParamValue() : BtJsr82Url
  • GetParent() : ProvDetailListBoxWin, PbProvListBox, Component, MenuAccessor
  • GetParentArea() : DrawableObject
  • GetParentCompoundItem() : EditorDocument
  • GetParentContainer() : ItemContainer, AbstractItemContainer, ProviderProxyContainer
  • GetParentNode() : RamFileNode
  • GetParentUri() : Uri
  • GetParentWindow() : Control
  • GetParity() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetParsePriority() : InputAction
  • GetParseStatus() : WbxmlParserRel
  • GetPaServiceName() : BtQuerySupportedProfilesRequest
  • GetPasswd() : DataConnProfile
  • GetPassword() : PdpContext::Authentication, BarringSsAction, SsGetPasswordRspArg, SsPasswordIndArg
  • GetPasswordMsg() : GetPasswordMsg
  • GetPath() : MetaData, StreamAudioReference, AudioPath, File, DirectoryIterator
  • GetPathControlMode() : AudioReference
  • GetPathname() : PathProfile, Path, File, DirectoryIterator, MCServiceInterfaceMsg, RamFileObj
  • GetPaths() : MediaPathnameVisitor
  • GetPause() : KeyMsgGenerator::Key
  • GetPayloadData() : PortHeaderInformation, SmsDeliver
  • GetPayloadOffset() : UserData, SmsDeliver
  • GetPayloadSize() : PortHeaderInformation, UserData, SmsDeliver, TpduHeaderInformation
  • GetPbAddType() : UsimPbUpdDataReqArg, UsimPbReadDataReqArg, UsimPbUpdDataResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg
  • GetPbAlphaTagRequestBehaviour() : AtcDispatcher
  • GetPbApplication() : PbToggleAction, PbAction, PbAbstractWin, AdvPbAction
  • GetPbChangedField() : UsimPbUpdReqArg
  • GetPbCntType() : PbCountReqArg, PbCountIndArg
  • GetPbDataControl() : PhonebookApp, AdvPbApp
  • GetPbDescriptor() : UsimPbSelectResArg
  • GetPbFillStatus() : UsimPbFillStatusResArg
  • GetPbLocation() : UsimPbSelectReqArg, UsimPbSelectResArg
  • GetPbProvider() : PhonebookApp, PbSynchronizer, PbDataHandler, PbAdvDataHandler, PbAbstractWin
  • GetPbRefRecord() : UsimPbReadAsyncIndArg, UsimPbReadResArg
  • GetPbRefType() : UsimPbUpdRefReqArg, UsimPbReadRefReqArg, UsimPbUpdRefResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • GetPbResult() : UsimPbReadyIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg
  • GetPbRwRecord() : UsimPbUpdReqArg, UsimPbReadReqArg, UsimPbReadAsyncIndArg, UsimPbReadResArg
  • GetPbSignalType() : UsimPbFillStatusResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg
  • GetPbTitle() : PbAbstractWin
  • GetPbtype() : PbEntryUpdReqArg, PbEntryReadReqArg, PbEntryReadIndArg
  • GetPduNode() : MdhSmsWriteReqArg
  • GetPeakRate() : PdpContext::QualityOfService
  • GetPeer() : SysSocket, InetSocket
  • GetPeerAddr() : HttpConnectMessage, FtpConnectMessage, FtpRequest
  • GetPeerDataSocketAddr() : FtpClient
  • GetPeerName() : SocketPeer
  • GetPeerPort() : SocketPeer
  • GetPeerSocket() : HttpConnectMessage, FtpConnectMessage
  • GetPen() : DeviceContext
  • GetPenColor() : DeviceContext
  • GetPenColorValue() : DeviceContext
  • GetPendingState() : SmsIndicationState
  • GetPenStyle() : DeviceContext
  • GetPeriodManual() : AbstractSmsApp
  • GetPermission() : DrmRightsObject
  • GetPermissionsCount() : DrmRightsObject
  • GetPersistentSize() : UibSettingsRecord, ToDoRecord, FmRadioStationsRecord, FmRadioSettingsRecord, SmsSettingsRecord, CalendarRecord, BtHfRecord, PbNumberRecord, PbRecord, PbNextFreeIdRecord, Record
  • GetPhonebook() : PhonebookApp, AdvPbApp
  • GetPhoneBookCountInfo() : SimAccessor
  • GetPhoneBookEntry() : SimAccessor
  • GetPhoneBookInfo() : SimAccessor
  • GetPhoneBookType() : SimPbBaseHandler
  • GetPhoneNo() : PbAdvAddEditEntry, SaveEntryInPhonebookMsg, RedialSetupMsg, MocSetupReqArg
  • GetPhoneNoType() : PbNumberRecord
  • GetPhoneNumber() : SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, PbNumberRecord, CsdDataConnProfile, DataItem, Property, PbAlphaTagRequestMsg, CcbsRecallMsg, MocSetupRejectIndMsg, PortHeaderInformation, ForwardingSsAction, CallSsAction, MoCallAction, CallHdl, DhChannelOpenReqArg, SiChannelOpenPromptReqArg, SimTkCallSetupIndArg, MocSetupRejIndArg, CallIndArg, AtPbListCnfArg, AtAlphaTagCnfArg, AtAlphaTagReqArg, XCallInfoResponseParser, MmCallDisconnectingMsg, MmCallHdl, TpduHeaderInformation, SimPbEntry
  • GetPhoneticCount() : ChineseT9Wrapper
  • GetPhoneticIndex() : ChineseT9Wrapper
  • GetPhoneticList() : ChineseT9Wrapper
  • GetPhonetics() : PredInputMapper, Zi8Wrapper, Zi8InputMapper, T9InputMapper, ChineseT9InputMapper
  • GetPhysicalDomain() : WapProfile
  • GetPhysicalPortNumber() : WapProfile
  • GetPhysicalPortService() : WapProfile
  • GetPhysicalProxyAddress() : WapProfile
  • GetPhysicalProxyId() : WapProfile
  • GetPid() : TpduHeaderInformation
  • GetPinCode() : BtSendPasskeyRequest
  • GetPitch() : AudioReference
  • GetPitchRange() : AudioReference
  • GetPixelColor() : DeviceContext, VirtualDisplay
  • GetPlainData() : EmsImage, IMelody
  • GetPlatformFeatureItem() : AtlConfig
  • GetPlayActive() : BtAvrcpControllerDeviceListItem
  • GetPlaybackSamples() : VrStoreTemplateReqArg
  • GetPlayer() : SvgHyperlinkSelectMsg, SvgStatusMsg, SvgDecodingFinishedMsg
  • GetPlayerInstance() : MediaBox
  • GetPlayerName() : SvgPlayer
  • GetPlayerVersion() : SvgPlayer
  • GetPlayPosition() : MmfPlayer
  • GetPlayTime() : AudioPlayTimeMsg
  • GetPlmn() : RegistrationChangeMsg, RegistrationSuccessMsg, UsimPlmnUpdReqArg, PlmnInfoReqArg, AttachReqArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListEntry
  • GetPlmnAct() : SimAuxHandler
  • GetPlmnCount() : SimAuxHandler
  • GetPlmnList() : UsimPlmnReadIndArg, SimAccessor
  • GetPlmnListCc() : StackWrapper
  • GetPlmnListCountryName() : StackWrapper
  • GetPlmnListLength() : StackWrapper
  • GetPlmnListMcc() : StackWrapper
  • GetPlmnListMnc() : StackWrapper
  • GetPlmnListName() : StackWrapper
  • GetPlmnListNetType() : StackWrapper
  • GetPlmnListShortName() : StackWrapper
  • GetPlmnScanList() : PlmnScanFinishedMsg, PlmnListCnfArg
  • GetPlmnwActFileLength() : SimAccessor
  • GetPlmnwActList() : SimAccessor
  • GetPluginName() : AtlApplicationPlugin
  • GetPnnInfo() : SimAccessor
  • GetPnnRecord() : SimAccessor
  • GetPnnRecordId() : OplEntry
  • GetPort() : DhChannelOpenReqArg, Server, HttpServer, FtpServer
  • GetPortNo() : InetSocketAddr, SmsSocket
  • GetPortNumber() : IpPortNo, WapProfile
  • GetPortService() : WapProfile
  • GetPos() : Rect, PaneObject, Component, MenuProperties, PlmnListEntry
  • GetPosIndicatorWidth() : GridView
  • GetPosition() : EditorItemNode, Indicator, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsTransmitIndArg, MediaRecorder, MediaPlayer
  • GetPositionHint() : TabButton
  • GetPositionIndicator() : GridModel, AbstractListBox
  • GetPositionIndicatorView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetPosnRequest() : GltpAidDataRequests
  • GetPostalCode() : VCard
  • GetPostOfficeAdress() : VCard
  • GetPosX() : PenUpMsg, PenDownMsg
  • GetPosY() : PenUpMsg, PenDownMsg
  • GetPowerMode() : DefaultDisplay, Display, DefaultDisplay, PowerModeIndMsg, OmPowerUpArg, OmControlIndArg, StatusProvider, DataHandler
  • GetPowerStatus() : MiscAudioDevice
  • GetPppFrame() : PdpContext
  • GetPrecedence() : PdpContext::QualityOfService
  • GetPredefinedAnimationStartPosition() : InformationElement
  • GetPredefinedAnimationType() : InformationElement
  • GetPredefinedSoundStartPosition() : InformationElement
  • GetPredefinedSoundType() : InformationElement
  • GetPredefinedType() : PredefinedEmsSound, PredefinedEmsImage
  • GetPredInputBox() : ToDoComposeWin, SmsComposeWin, AbstractSmsComposeWin, EmsComposeWin
  • GetPrefEncoding() : BtBipImagingCapabilities
  • GetPreferedRatMode() : PlmnHandler
  • GetPreferredFormat() : BtBipImagingCapabilities
  • GetPreferredStorageMedia() : SimPduHandler, SimAccessor, DataHandler
  • GetPreferredStorageType() : AbstractSmsApp
  • GetPrefExtLanguageArray() : SimAccessor
  • GetPrefExtLanguageFileLength() : SimAccessor
  • GetPrefLanguageArray() : SimAccessor
  • GetPrefLanguageFileLength() : SimAccessor
  • GetPrefMaxHeight() : BtBipImagingCapabilities
  • GetPrefMaxSize() : BtBipImagingCapabilities
  • GetPrefMaxWidth() : BtBipImagingCapabilities
  • GetPrefMimeType() : VideoCaptureParameters
  • GetPrefMinHeight() : BtBipImagingCapabilities
  • GetPrefMinWidth() : BtBipImagingCapabilities
  • GetPrefPlmnFileLength() : SimAccessor
  • GetPrefService() : PlmnHandler
  • GetPrefTransformation() : BtBipImagingCapabilities
  • GetPresentationInd() : PhoneNumber
  • GetPresentationIndicator() : CnapInfoReceivedMsg
  • GetPresetByID() : AudioPresetStore
  • GetPresetForName() : AudioPresetStore
  • GetPresetList() : AudioPresetStore
  • GetPresetName() : PresetAudioReference, AudioPresetStore
  • GetPressedIndex() : SoftkeyBar
  • GetPressedItem() : TRadioButtonList< Content >, RadioButtonList
  • GetPreview() : MultiTapCaret
  • GetPrevious() : Control, BtDeviceList::BtDeviceListNode, DeletedNode
  • GetPrimaryDnsServerAddress() : DataConnProfile, DataConn
  • GetPrimaryId() : PdpContext
  • GetPrimaryProfileId() : PsdDataConnProfile
  • GetPriority() : ToDoPriorityDialogWin, SubSystem, Thread, Application, AudioContext, BtConnectionlessController, BtConnectionBasedController, AudioReference, StackControl, EmlppAction, KeyMsgGenerator, RegManager, MediaRecorder, MediaPlayer, DrmSubsystem, DataControl
  • GetPriorityGroup() : AudioReference
  • GetProactiveCause() : SimTkRefreshNewRspArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, LaunchBrowserIndArg, SimTkRefreshQueryResArg, SetupIdleModeTextRspArg, PlayToneRspArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, TermRspCnfArg
  • GetProblemCode() : TaggedProblemCode
  • GetProblemTag() : TaggedProblemCode
  • GetProcessId() : SimTkInterfaceIndArg
  • GetProcessPtr() : StackMsgProcessor, ProcessNode
  • GetProcessSource() : GprsClassIndArg
  • GetProfile() : DataConnProvider, BtIndicatorMsg, DataConnInfoMsg, DataConnProfileManager, DataConn, BtObexService, BtHsService, BtHfService, BtFaxService, BtDunService, BtService, BtSddbService, BtCloseMessage, BtOpenMessage, BtAuthorizationRequiredMessage, BtBppService, BtAvrcpService, SimTkProfile
  • GetProfileCount() : DataConnLbModel
  • GetProfileId() : DataConnProvider, DataConnAccessor, DataConnProfileInfoMsg, WapProfile
  • GetProfileIdSet() : DataConnProfileManager
  • GetProfileInfo() : DataConnProfileManager
  • GetProfileInstance() : SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider
  • GetProfileManager() : DataConnProvider
  • GetProfileName() : DataConnProfileInfoMsg, WapProfile
  • GetProfileOffset() : FfsDataConnProfileStorage
  • GetProfileProvider() : AbstractSmsApp
  • GetProfileType() : DataConnTypeWin, DataConnProvider, DataConn
  • GetProgramIdentifier() : AudioFmRadioRdsInfoMsg
  • GetProgramType() : AudioFmRadioRdsInfoMsg
  • GetProgress() : PbSynchronizer, PbSimProvider, PbRecordHandler, SyncProgressMsg, ProgressBar, ImageEncodingProgressMsg, ImageDecodingProgressMsg, Provider, AbstractDelegationProvider, FileChunkOperationProgressMsg, JoinProvider, AppendProvider, SmsProvider, SmsClass0Provider, SimPduHandler, SimPbBaseHandler, PbBaseProvider, DataControlBootProgressMsg
  • GetProgressBarView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetProgressBox() : PhonebookApp
  • GetProgressInBytes() : ObexServer, ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexDataServer, ObexClient, BtBppClientService, BtBipServerService, BtBipClientService
  • GetProgressIndication() : MmCallSetupProgressMsg
  • GetProgressInPercent() : BtBppClientService
  • GetProgressTotalBytes() : BtBppClientService
  • GetPropCnt() : DataConnApp::DataConnDescription
  • GetProperties() : AbstractItemRenderer, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, CodecDevice
  • GetProperty() : CTResourcePack, IdentifierHandler, UsimFilePropertyIndArg, VrPropertyResultIndArg
  • GetPropertyEditorID() : PropertyItem
  • GetPropertyId() : ItemPropertiesChangedMsg, FeatureChangedMsg
  • GetPropertyItem() : PropertyEditor, PropertyTriggerMsg
  • GetPropertyRange() : CamWin32
  • GetPropertyValue() : GuiObjectFactory
  • GetProtector() : SmsDispatcher
  • GetProtocol() : ObexAbstractTransport, ObexMngr, ObexAbstractPort, IrdaObexTransport, BtObexTransport, PdpContext, UsbObexTransport, LcsProviderImplBase, ProviderChangedMsg
  • GetProtocolId() : ObexTriggerMsg, ObexChannel
  • GetProtocolIdentifier() : SmsContext, SmsNewMessageIndArg, SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver, MdhSmsNewMessageIndArg
  • GetProtocolNumberOrNextHeader() : PdpContext::PacketFilter
  • GetProvider() : UibListBoxModel, AbstractSmsViewerWin, DataConnApp::DataConnDescription, ProvListBoxWin, PbProvListBox, PbProvListBoxModel, ProviderUpdateMsg, Trap, ProviderListBoxModel, ProviderListener, MainProvider, ProviderPtr, DataItem, ProviderProxyItem, ProviderProxyContainer, ProviderChangedMsg, DataHandler
  • GetProviderData() : AbstractSmsApp
  • GetProviderEntry() : ProviderListBoxModel
  • GetProviderId() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsTemplateProvider, SmsSettingsProvider, SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider, CalendarProvider, BtHfProvider, BtDeviceListProvider, PbSimProvider, PbNumberProvider, PbNameProvider, PbNameNumberProvider, PbNameFilterProvider, PbNumberFilterProvider, GroupProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider, AppendProvider, LanguageProvider, StatusProvider, SstProvider, SmsUnsentProvider, SmsUnreadProvider, SmsSentProvider, SmsReadProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, SimTkMainMenuProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PlmnProvider, PbBaseProvider, DataControlBootProgressMsg, MbiProvider, LockProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CountryProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • GetProviderRow() : ProviderProxyItem
  • GetProvisionFileRef() : SimLaunchBrowserReqArg
  • GetProvRow() : PbProvListBoxModel, PbManualSynchronizer
  • GetProvText() : PbProvListBoxModel
  • GetProxyId() : WapProfile
  • GetProxyName() : WapProfile
  • GetProxyProviderId() : WapProfile
  • GetPsdError() : DataConnInfoMsg
  • GetPsLociData() : UsimPsLociReadIndArg
  • GetPsm() : L2CapSocketAddr
  • GetPtr() : ObexBuffer::Writer, ObexBuffer::Reader, FixedPtrArray< T >
  • GetPuct() : SimPuctUpdReqArg, SimPuctReadIndArg, SimAccessor
  • GetPuctData() : SimAuxHandler
  • GetPushButtonView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetQoS() : PdpQoSPeakRateTable, PdpQoSMeanRateTable, PdpQoSPrecedenceTable, PdpQoSDelayTable, PdpQoSReliabilityTable
  • GetQosDelay() : PsdDataConnProfile
  • GetQosMeanRate() : PsdDataConnProfile
  • GetQosPeakRate() : PsdDataConnProfile
  • GetQosPrecedence() : PsdDataConnProfile
  • GetQosReliability() : PsdDataConnProfile
  • GetQoSType() : PdpQoSPeakRateTable, PdpQoSMeanRateTable, PdpQoSPrecedenceTable, PdpQoSDelayTable, PdpQoSReliabilityTable
  • GetQualifier() : SimIconIdentifier
  • GetQuality() : SignalStrengthLevelIndArg, VrRecogResultIndArg, VrIntrmRecResultIndArg, VrResultMsg
  • GetQualityLevel() : JpegEncoder::EncodingParameters
  • GetQualityOfService() : PdpContext, PdpContext::ActivationStatus
  • GetQueryRemoteDeviceName() : BtDeviceSearchRequest
  • GetRadioAccessTechnology() : RatStateMsg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListEntry, StatusProvider, DataHandler
  • GetRadioButtonListView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetRadioButtonView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetRadioFreq() : FmRadioStationsRecord
  • GetRadioLastFreq() : FmRadioSettingsRecord
  • GetRadioLastVolume() : FmRadioSettingsRecord
  • GetRadioOn() : FmRadioApplication
  • GetRadioPriority() : PdpContext::ActivationStatus
  • GetRadioText() : AudioFmRadioRdsRadioTextMsg
  • GetRamFileObj() : RamFileNode
  • GetRasterOp() : DeviceContext
  • GetRat() : AttachReqArg
  • GetRatChangeMode() : RatChangeModeChangedMsg, OmRatChangeReqArg, OmRatChangeIndArg, StatusProvider
  • GetRate() : AudioReference
  • GetRateRange() : AudioReference
  • GetRawBCDBuffer() : PhoneNumber
  • GetRawBCDLength() : PhoneNumber
  • GetRawFrameParams() : BtAvrcpRawFrameRequest, BtAvrcpNmaRawFrame
  • GetRawMediaMimeType() : DrmMessage
  • GetRawMediaObject() : DrmMessage
  • GetRdnSelector() : EctActiveMsg
  • GetReadCount() : SimPduHandler
  • GetReader() : Stream
  • GetReadProvider() : AbstractSmsApp
  • GetReadType() : UsimFilePropertyReqArg, UsimPlmnReadReqArg, UsimUpdRejArg, UsimUpdCnfArg, UsimReadRecordRejArg, UsimReadRejArg, UsimPlmnReadIndArg
  • GetReadyTimer() : PdpContextManager::AttachStatus
  • GetReason() : SmsStatusReportTextMap, ShortMessageStatus
  • GetReceivedPackets() : UdpTestSocket, TcpTestSocket
  • GetRecipientAddress() : SmsStatusReport
  • GetRecipientPhoneNumber() : SmsNewStatusReportIndArg
  • GetRecNo() : SimCmiReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimRefreshIndArg, MdhSmsReportReadIndArg, SmsWStringCache, SmsWStringCache::Entry, SimPbEntry
  • GetRecno() : UsimLangUpdReqArg, UsimSmsParamUpdReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimSmsParamUpdIndArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, SimAcmReadIndArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, PbEntryReadIndArg, MdhSmsUpdStatusIndArg, IconDescReadReqArg
  • GetRecordData() : CalendarProvider
  • GetRecordedSize() : StreamAudioReference
  • GetRecordingDelay() : StreamAudioPlayer
  • GetRecordingReference() : StreamAudioPlayer
  • GetRecordLength() : SimFileInfoIndArg
  • GetRecordNumber() : PbEntryRequestMsg, AtPbListCnfArg, AtPbListReqArg
  • GetRecstatus() : MdhSmsUpdStatusReqArg
  • GetRect() : InvalidateMsg, WinRect
  • GetRecurrence() : CalendarRecord
  • GetRed() : ColorTable, Color
  • GetRedBitCount() : ColorSegmentation
  • GetRedKey() : KeyboardConfig
  • GetRefCount() : ProviderPtr, DrmRightsObject
  • GetReference() : AudioActiveReference
  • GetReferenceLocation() : GltpAssistanceData
  • GetReferenceNumber() : SmsSendDispatcher, SmsSendCnfArg, SmsNewStatusReportIndArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkSsIndArg, SimTkSmsPpIndArg, TpduHeaderInformation
  • GetReferenceTime() : GltpAssistanceData
  • GetRefNo() : MdhSmsConcRefNumIndArg
  • GetRefRecno() : UsimPbUpdRefReqArg, UsimPbReadRefReqArg, UsimPbUpdRefResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • GetRefreshDelay() : VideoChannel
  • GetRefreshIndicator() : SimTkRefreshQueryReqArg
  • GetRefreshType() : SimRefreshIndArg
  • GetRegion() : VCard
  • GetRegisteredBcdPlmn() : DataHandler
  • GetRegisteredDataStore() : SyncMLManager
  • GetRegisteredLac() : StatusProvider, DataHandler
  • GetRegisteredPlmn() : StatusProvider, DataHandler
  • GetRegisterParams() : BtAvrcpRegisterRequest
  • GetRejectCause() : RegistrationChangeMsg, PdpContextManager::AttachStatus, PdpContext::ActivationStatus, SsCauseIndArg, SsGetPasswordRejArg, SsFacilityRejArg, MocSetupRejArg
  • GetRejectDuplicates() : SmsContext
  • GetRelativeTime() : ValidityPeriod, CodedTimeStamp
  • GetReleaseComplete() : SsCcbsResultIndArg
  • GetReliability() : PdpContext::QualityOfService
  • GetRemainingDataLength() : DhChannelReceiveIndArg
  • GetRemainingSize() : UserData, UserDataHeader
  • GetRemoteAddr() : IrdaObexServerAddr, IrdaObexClientAddr, BtObexClientAddr
  • GetRemoteAddrPtr() : ObexClientDispatcher
  • GetRemoteDeviceInformation() : BtDevice
  • GetRemoteDeviceName() : BtSetRemoteDeviceNameRequest
  • GetRemoteRfComm() : BtObexClientAddr
  • GetRenderer() : ItemBox, ContextMenu, AbstractItemGrid, ItemLabel
  • GetRendererHint() : ItemRendererProperties
  • GetRendererProperties() : ItemContainer, AbstractItemContainer
  • GetRenderingView() : ImageListBoxModel
  • GetRepaintHint() : GridModel
  • GetRepaintRect() : Control
  • GetRepeatable() : AudioReference
  • GetRepeatCount() : Image, Image::MetaData, PreparedSound, AudioReference, MediaPlayer
  • GetReport() : UsimPbLocationIndArg, TestparamReportArg
  • GetReportArg() : EngineeringReportMsg
  • GetReqStackSize() : Threadlet
  • GetRequest() : BtObexClientService, SendRequestMsg, GltpPositionRequest, GltpMsmtRequest, GltpAidingRequest, GltpHelloRequest, GltpRequest
  • GetRequestBuffer() : StreamObexImpl
  • GetRequestedByteCount() : StreamingReadInfo
  • GetRequestedStackSize() : Thread, Application
  • GetRequestFlags() : ObexObject
  • GetRequestId() : BtRequestMessage, BtRequest
  • GetRequestMethodType() : HttpRequest
  • GetRequestParams() : HttpRequest
  • GetRequestReplyPath() : SmsContext
  • GetRequestState() : BtObexServerService, BtObexClientService, BtHsService, BtHfService, BtFaxService, BtDunService, BtService, BtSddbService, BtRequest, BtBppServerService, BtBppClientService, BtBipServerService, BtBipClientService, BtAvrcpRegistrationService, BtAvrcpOperationService
  • GetRequestStatusReport() : SmsContext
  • GetRequestTarget() : HttpRequest
  • GetRequestType() : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexSetPathRequest, BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtObexPutRequest, BtObexGetRequest, BtObexDisconnectRequest, BtObexConnectRequest, BtObexAbortRequest, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtRequestStateChangedMessage, BtSendPasskeyRequest, BtRespondAuthorizationRequest, BtRequest, BtQuerySupportedProfilesRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBipProgressMsg, BtBipOpFinishedArg, BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRegisterRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse, BtAvrcpDeRegisterRequest, BtAvrcpConnectResponse
  • GetReservedSpace() : FfsHandler
  • GetResolution() : ImageViewListBoxModel, Media
  • GetResourceNames() : SoundBrowserApp, ImageBrowserApp
  • GetResourcePack() : CustomizableTheme
  • GetResourcePackIfActive() : CustomizableTheme
  • GetResourceUri() : CTResourcePack
  • GetResponse() : BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse
  • GetResponseCode() : ObexObject, BtObexClientOperationEvent, BtObexClientOperationRequest
  • GetResponseHeaderList() : ObexDataServer
  • GetResponseString() : AtResponse
  • GetResponseType() : AtResponse
  • GetRest() : InputParser, LexAnalyzer
  • GetResult() : SmsResultTextMap, ObexAddrMsg, ObexMsg, BtObexClientNmaTransportDisconnect, BtObexClientNmaDataInidication, BtObexClientNmaDataBufferIndication, BtObexClientNmaHeaderIndication, BtObexClientNmaHeaderSent, BtObexServerNmaTransportDisconnect, BtObexServerNmaDataInidication, BtObexServerNmaDataBufferIndication, BtObexServerNmaHeaderIndication, BtObexServerNmaHeaderSent, BtObexServerNmaAbort, BtObexServerNmaPut, BtObexServerNmaGet, BtObexServerNmaSetPath, BtObexServerNmaDisconnect, BtObexServerNmaConnect, BtJsr82Url, BtHsNmaLowPowerModeNotPossible, BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHsNmaAudioConnectionLost, BtHsNmaTransferAudioToPhone, BtHsNmaTransferAudioToAccessory, BtHsNmaDisconnect, BtHsNmaConnect, BtHfNmaLowPowerModeNotPossible, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain, BtHfNmaAudioConnectionLost, BtHfNmaTransferAudioToPhone, BtHfNmaTransferAudioToAccessory, BtHfNmaDisconnect, BtHfNmaConnect, BtHfCmaPhoneNumberRequired, BtRequestMessage, BtOperationBase, BtEvent, BtApplicationMessage, BtBppClientService, BtBipClientService, SmsSendDispatcher, SsInterrogateIndArg, SmsSendRejArg, SmsSendCnfArg, ExtProactiveCmdIndArg, EngineeringModeControlResponseArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg
  • GetResultStatus() : SmsStatusReport
  • GetReturnCode() : AudioMsg
  • GetReusedExtendedObjectPosition() : InformationElement
  • GetReusedExtendedObjectReferenceNumber() : InformationElement
  • GetRfc822EmailHeaderLength() : InformationElement
  • GetRfComChannel() : BtObexServerService, BtObexRegisterServerRequest, BtObexRegisterServerEvent, BtBppServerService, BtBipServerService
  • GetRfCommChannel() : BtObexClientAddr
  • GetRfCommPortNumber() : BtObexServerAddr
  • GetRfComPort() : BtObexConnectRequest, BtObexClientService
  • GetRfu() : SimIconDescription
  • GetRgb() : ColorTable, Color
  • GetRi() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetRight() : Rect, WinRect
  • GetRightsIssuer() : DrmMessage
  • GetRightSize() : ControlFrameView
  • GetRightsObject() : DrmRightsObjectFile, DrmRightsObjectContainer, DrmRelParser
  • GetRightSoftkey() : Window
  • GetRingInterval() : BtHsService
  • GetRole() : BtAvrcpRegisterParams, BtAvrcpDeRegisterRequest
  • GetRoot() : MenuTable, ContextTable
  • GetRootDir() : ServerConfig
  • GetRootNode() : RamFileSystem
  • GetRow() : PbProvListBoxModel, PbDetailListBoxModel, Caret, Cell, Provider::Modification
  • GetRowCount() : GridLayout, AbstractGrid, RecordHandler
  • GetRowTable() : PbRecordProvider
  • GetRowTitleWidth() : GridView
  • GetRtcInfo() : RtcInfoMsg
  • GetRts() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetRunning() : FfsTestThreadlet, FfsTestThread
  • GetRunningAbortRequest() : BtObexController::BtObexConnection
  • GetRunningRequest() : BtMultiConnectionController::BtConnection
  • GetSampleDataLength() : VrStoreTemplateReqArg
  • GetSampleFreq() : MediaInfo::AudioTrackInfo
  • GetSampleRate() : StreamAudioReference
  • GetSavedText() : PbDetails, PbAdvDetails
  • GetSca() : SmsNewSocketDataMsg
  • GetScaledHeight() : Image
  • GetScaledWidth() : Image
  • GetScaleType() : DisplaySettings
  • GetScanlineAtomCount() : VirtualDisplay
  • GetScanlineDiff() : Image, GifImage, BmpImage
  • GetScanStatus() : StatusProvider, DataHandler
  • GetScNumber() : SmsControlIndArg
  • GetScreeningInd() : PhoneNumber
  • GetScrollBehavior() : GuiEngineConfig, AbstractGrid, AbstractListBox
  • GetScrollDelay() : ItemRendererProperties
  • GetScrollGap() : ItemRendererProperties
  • GetSd() : InetSocket
  • GetSddbCase() : BtObexServerAddr
  • GetSdnProvider() : PbDataHandler
  • GetSdnTagSize() : SimPbBaseHandler
  • GetSearchStopLevel() : RadioAudioDevice
  • GetSecLockStates() : SimChvHandler
  • GetSecond() : TimeEditBox, TimeSpan, Time, DateTime
  • GetSecondaryDnsServerAddress() : DataConnProfile, DataConn
  • GetSecondKeyColumnId() : JoinProvider
  • GetSecondProvider() : JoinProvider
  • GetSeconds() : ValidityPeriod
  • GetSection() : Desktop, IndicatorBar
  • GetSectionContainerBounds() : Desktop
  • GetSectorSize() : StorageDevice
  • GetSecureDateTime() : RealTimeClock
  • GetSecurity() : BtObexServerAddr, BtObexClientAddr
  • GetSecuritySettings() : BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtJsr82Url
  • GetSegmentAt() : Pathname
  • GetSegmentCount() : Pathname
  • GetSegmentName() : RamFileNode
  • GetSelectedCandidate() : Zi8Wrapper
  • GetSelectedCandidateLength() : Zi8Wrapper
  • GetSelectedCell() : Grid, GridModel
  • GetSelectedColumnId() : PbProvListBox, PbProvListBoxModel
  • GetSelectedDevice() : BtDeviceListWindow
  • GetSelectedDeviceState() : BtAvrcpControllerApplicationWindow
  • GetSelectedGroupIndex() : PbSelectGroup
  • GetSelectedIcon() : RadioButtonAction, CheckBoxAction, AbstractToggleAction
  • GetSelectedImage() : ImageViewListBoxModel, ImageListBoxModel
  • GetSelectedImageRef() : ImageBrowserWin
  • GetSelectedImageSize() : Camera
  • GetSelectedIndex() : ToDoListWin, PredInputMapper, ItemMenu::LevelInfo, AbstractGrid, MenuAccessor, AbstractListBox, AbstractListBoxModel, AtlItemGridWindow, Zi8Wrapper, Zi8SelectionBox, Zi8InputMapper, T9InputMapper, SelectionBox, ChineseT9InputMapper
  • GetSelectedIndexProperty() : AbstractGrid
  • GetSelectedItem() : ProvListBoxWin, PhonebookApp, PbAbstractWin, AbstractItemGrid, AtlItemGridWindow
  • GetSelectedLine() : SelectedLineRetriever, XCallInfoResponseParser
  • GetSelectedMediaRef() : BrowserView
  • GetSelectedMsg() : UibFolderWin
  • GetSelectedMuteChannel() : RadioAudioDevice
  • GetSelectedNoIndex() : PbDetailListBox, PbDetailListBoxModel
  • GetSelectedNoRow() : PbDetailListBox, PbDetailListBoxModel
  • GetSelectedNumber() : PbSelectNumberWin
  • GetSelectedNumberTypeIndex() : PbSelectNoType
  • GetSelectedPbRow() : PhonebookApp
  • GetSelectedProfileId() : DataConnWin, DataConnLbModel
  • GetSelectedProfileInfo() : DataConnLbModel
  • GetSelectedProvRow() : PbProvListBoxModel
  • GetSelectedRadioButtonAction() : RadioButtonGroup
  • GetSelectedRow() : ProvDetailListBoxWin, ProvListBoxWin, PhonebookApp, PbProvListBox, PbBaseWin, PbAdvDetails, PbAbstractWin, AdvPbWin, AtlItemListWindow
  • GetSelectedSms() : AbstractSmsViewerWin
  • GetSelectedSmsEmbItem() : SmsViewerWin, AbstractSmsViewerWin
  • GetSelectedSoundRef() : SoundBrowserWin
  • GetSelectedText() : PbDetailListBox
  • GetSelectedToggleAction() : ToggleActionGroup
  • GetSelectedType() : EmsInsertPrompt
  • GetSelectedUsimPb() : DataHandler
  • GetSelectedValue() : DataConnOptionWin
  • GetSelectedYPos() : PbDetailListBox
  • GetSelectGroupAction() : AdvPbApp
  • GetSelection() : PredInputMapper, AbstractEditor, Zi8InputMapper, T9InputMapper, ChineseT9InputMapper
  • GetSelectionHeight() : ItemRendererProperties, AbstractItemGrid, AbstractGrid
  • GetSelectionMode() : Grid, GridModel
  • GetSelectionStyle() : AbstractEditor
  • GetSelectKey() : KeyboardConfig
  • GetSelector() : SimAcmUpdReqArg, SimAcmReadReqArg, SimAcmUpdIndArg, SimAcmReadIndArg
  • GetSemaphore() : PdpContextManager
  • GetSempahore() : StateMachine
  • GetSendDataType() : DhChannelSendReqArg
  • GetSender() : SelectionChangedMsg
  • GetSenderID() : AudioUserDefinedMsg
  • GetSenderPhonenumber() : SmsPortDataRecvMsg, SmsNewSocketDataMsg
  • GetSenderPortNo() : SmsNewSocketDataMsg
  • GetSentCount() : SimPduHandler
  • GetSentProvider() : AbstractSmsApp
  • GetSeparator() : Pathname
  • GetSeptets() : DataCoding
  • GetSeqNr() : ObexOperationId
  • GetSequence() : BootDispatchingArg
  • GetSequenceFeature() : KeyMapping
  • GetSequenceId() : LedNotificationMsg
  • GetSerialIoSet() : SerialSocketData
  • GetSerialNumber() : CbsNewDataRejArg, Cbs
  • GetSerivceRecordHandle() : BtSddbRegisterServiceEvent
  • GetServedCallApp() : RedialSetupIndArg
  • GetServedCallApplication() : RedialSetupMsg
  • GetServerAddrTypeId() : ObexAbstractTransport
  • GetServerChannel() : RfcommSocketAddr
  • GetServerConfig() : Server
  • GetServerId() : ObexServerInfo, ObexMsg
  • GetServerSecurity() : BtObexServiceTable::ServiceInfo
  • GetService() : BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtServiceRequest, BtServiceMessage, BtAvrcpOperationServiceMessage, BtAvrcpNotificationMessage, SmsSendReqArg, ServiceBroker
  • GetServiceAttributeAtIndex() : BtSvrServiceRecord
  • GetServiceAttributeById() : BtSvrServiceRecord
  • GetServiceCenter() : SendSmsMsg, AbstractSmsComposeWin
  • GetServiceCenterAddress() : SmsContext
  • GetServiceCentreAddress() : Tpdu, Sms
  • GetServiceCentreTimeStamp() : SmsStatusReport, SmsDeliver
  • GetServiceClass() : BtObexServiceTable::ServiceInfo, BtDeviceAndServiceClass
  • GetServiceGuid() : SyncMLManager
  • GetServiceInfoByTarget() : BtObexServiceTable
  • GetServiceInfoByType() : BtObexServiceTable
  • GetServiceInfoByUuid() : BtObexServiceTable
  • GetServiceName() : BtObexServiceTable::ServiceInfo, BtObexServerAddr
  • GetServiceRecordAtIndex() : BtServiceVerifyResult
  • GetServiceRecordHandle() : BtSddbService
  • GetServicesToVerify() : BtServiceVerifyRequest
  • GetServiceTable() : SimAccessor
  • GetServiceToVerify() : BtOperationSelectDeviceAndPerformServiceVerify
  • GetServiceType() : BtObexServiceTable::ServiceInfo
  • GetServiceValues() : SimAuxHandler
  • GetServiceVerifyResult() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetSessionId() : BtBipConnectIndArg
  • GetSessionStatusWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • GetSetting() : OptionalConfig, LocaleConfig, PsdSettingsTable, SerSettingsTable, CsdSettingsTable, DataConnCommonSettingsTable
  • GetSettingsCount() : LocaleConfig
  • GetSettingsProvider() : UibApp, AbstractSmsApp
  • GetSetupCallHdl() : CallHdl
  • GetSetupState() : XCallInfoResponseParser
  • GetSetWaitIndicatorArray() : MdhSmsSetWaitingReqArg
  • GetSharedDc() : System, DeviceManager
  • GetSharedImageBufferMax() : GuiEngineConfig
  • GetShortMessageFailureCause() : SmsSendDispatcher, SmsSendCnfArg
  • GetShortMessageStatus() : SmsNewStatusReportIndArg, TpduHeaderInformation
  • GetShowCount() : Zi8AlphabetBox
  • GetSiClientFlags() : BrowserRegisterReqArg
  • GetSignalId() : ProcessNode
  • GetSignalLevel() : AudioFmRadioRssiMsg
  • GetSignalName() : ProcessNode
  • GetSignalQualityLevel() : SignalQualityLevelMsg, StatusProvider, DataHandler
  • GetSignalQualityMax() : SignalQualityLevelMsg, SignalStrengthLevelIndArg, StatusProvider
  • GetSignalStrength() : BtRemoteDeviceMessage
  • GetSignalStrengthLevel() : SignalStrengthLevelMsg, StatusProvider, DataHandler
  • GetSignalStrengthMax() : SignalStrengthLevelMsg, SignalStrengthLevelIndArg, StatusProvider
  • GetSimAccessor() : DataControl, DataHandler
  • GetSimCallSetupOption() : CallSetupBySimtTkReqArg
  • GetSimChangedState() : SimAccessor
  • GetSimChvHandler() : DataHandler
  • GetSimClutEntry() : SimImage
  • GetSimCphsHandler() : DataHandler
  • GetSimData() : SimAccessor
  • GetSimErrorCode() : SimAuxHandler
  • GetSimFileId() : MexeDescriptor
  • GetSimFileProperty() : SimAccessor
  • GetSimIconDescription() : SimTkHandler, SimAccessor, DataHandler
  • GetSimImage() : SimTkHandler, SimAccessor, DataHandler
  • GetSimImageCodingScheme() : SimImage
  • GetSimImageDescriptor() : SimIconDescription
  • GetSimIndicator() : SimStateChangedMsg, SimAccessor
  • GetSimInfo() : SimInfoIndArg, SimAuxHandler, SimAccessor
  • GetSimLockStates() : SimAuxHandler
  • GetSimMexeCertificate() : SimAuxHandler, DataHandler
  • GetSimMexeCertificateCount() : SimAuxHandler, DataHandler
  • GetSimPduCount() : SimAccessor
  • GetSimPduHandler() : DataHandler
  • GetSimProvider() : PbSynchronizer
  • GetSimRecNo() : PbNumberRecord
  • GetSimResult() : DhChannelChangeStatusResArg, DhChannelDataAvailableResArg, SimBrowserTermResArg, XCallInfoResponseParser
  • GetSimServiceType() : SimTkSsIndArg
  • GetSimStoredTpduNum() : TpduHeaderInformation
  • GetSimTkProfile() : SimTkProfileGetCnfMsg, OmSetTermProfileReqArg, OmGetTermProfileCnfArg
  • GetSimTkProfileReq() : SimTkHandler
  • GetSimUpdateStatus() : BdnIndArg, FdnIndArg
  • GetSize() : MetaData, MediaRefContainer, SocketTestMessage, OnDataRcvdMsg, MetaData, MediaRefContainer, CallTypeTable, DataRateTable, PdpAuthTable, PdpQoSPeakRateTable, PdpQoSMeanRateTable, PdpQoSPrecedenceTable, PdpQoSDelayTable, PdpQoSReliabilityTable, ObexHeader, ObexBuffer, Rect, PositionIndicatorView, IconState, PaneObject, DataPack, Component, NonsharedBinDataDataSource, WinRect, IconValueIndicator, IconTextIndicator, CenteredTextIndicator, TextIndicator, IconIndicator, Indicator, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeUuid128, BtSddbDeSint128, BtSddbDeSint64, BtSddbDeUint128, BtSddbDeUint64, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, BtSddbDeNil, BtSddbDataElement, BtDeviceList, BtBipAttachmentDesc, BtBipAttachment, WString, Vector< T >, StringDataSink, String, SimpleMap< TKey, TValue >, LinkedListBase, IndexTable< T >, HeapDataSource, HeapDataSink, HashTable, DataSource, DataSink, BinDataDataSource, RtStreamingBuffer, TextIconPairArray, MenuTable, ContextTable, ValidityPeriod, UserData, UserDataHeader, MessageIdentifierContainer, InformationElement, FileDataSource, FileDataSink, File, File::Attributes, T9Pack, SendRequestMsg, GltpAssistanceData, GltpPositionRequest, GltpMsmtRequest, GltpAidingRequest, GltpHelloRequest, GltpRequest, RootFileImp, RamStorageMapper, RamFileObj, RamFileImp, FlashFileImp, FatFileImp
  • GetSizeOfDataPack() : BasicPackConnector
  • GetSizeOfLdb() : T9PackConnector
  • GetSizeOfRecord() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer
  • GetSkIcon() : SoftkeyDesc
  • GetSkText() : SoftkeyDesc
  • GetSleepDuration() : Cbs::Filter
  • GetSmallAnimationBuffer() : InformationElement
  • GetSmallAnimationLength() : InformationElement
  • GetSmallAnimationStartPosition() : InformationElement
  • GetSmallPictureBuffer() : InformationElement
  • GetSmallPictureLength() : InformationElement
  • GetSmallPictureStartPosition() : InformationElement
  • GetSmoothScrollInfo() : AbstractGrid, AbstractListBox
  • GetSmsApplication() : AbstractSmsViewerWin
  • GetSmsBasicProvider() : AbstractSmsApp
  • GetSmsClass0Provider() : AbstractSmsApp
  • GetSmsComposer() : SmsUtility, AbstractSmsUtilityProcessor, EmsApp
  • GetSmsDebugWString() : SimPduHandler
  • GetSmsDestinationPortNo() : PortHeaderInformation
  • GetSmsFactory() : AbstractSmsUtilityProcessor, EmsApp
  • GetSmsFilterType() : SmsUnsentProvider, SmsUnreadProvider, SmsSentProvider, SmsReadProvider, SmsProvider
  • GetSmsId() : MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSmsUpdStatusReqArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg
  • GetSmsInfoAlpha() : SimTkSmsPpIndArg
  • GetSmsInfoIcon() : SimTkSmsPpIndArg
  • GetSmsInformation() : SimPduHandler
  • GetSmsMoreMessageType() : SmsSetMoreMessageReqArg, SmsGetMoreMessageStatusIndArg
  • GetSmsOriginatorPortNo() : PortHeaderInformation
  • GetSmsParam() : SimAccessor
  • GetSmsParameter() : SimSmsParamHandler, SimSmsParameter
  • GetSmsParamFileSizes() : SimAccessor
  • GetSmsParamRecord() : UsimSmsParamUpdReqArg
  • GetSmspBuffer() : SimSmsParameter
  • GetSmsPortNo() : SmsPortDataRecvMsg, SmsNewSocketDataMsg, TpduHeaderInformation
  • GetSmsProfile() : AbstractSmsApp
  • GetSmsProvider() : AbstractSmsApp
  • GetSmsr() : SimAccessor
  • GetSmsrCount() : SimAccessor
  • GetSmsrData() : SimSmsrUpdReqArg, SimSmsrReadIndArg, MdhSmsReportReadIndArg
  • GetSmsReferenceNumber() : SmsContext
  • GetSmsrLocation() : SmsNewStatusReportIndArg, MdhNewStatusReportIndArg
  • GetSmsStatus() : SimRefreshIndArg
  • GetSmsStorageType() : TpduHeaderInformation
  • GetSmsTpdu() : SimPduHandler
  • GetSmsTpduPosition() : SimPduHandler
  • GetSmsViewer() : AbstractSmsUtilityProcessor, EmsApp
  • GetSmsWString() : SimPduHandler
  • GetSneRecordNo() : UsimPbRefRecord
  • GetSoBroadcastOption() : InetSocket
  • GetSockAddr() : IrSocketAddr, SocketAddr, L2CapSocketAddr, RfcommSocketAddr
  • GetSockAddrSize() : IrSocketAddr, SocketAddr, L2CapSocketAddr, RfcommSocketAddr
  • GetSocket() : SocketControlMsg, SmsSocketListener, MmCallInfo, MmCallHdl, MmCallHandler
  • GetSocketAddr() : HttpServiceMessage, FtpServiceMessage
  • GetSocketData() : SocketControlMsg, DataConn
  • GetSocketEventListener() : Socket
  • GetSoDebugOption() : InetSocket
  • GetSoDontRouteOption() : InetSocket
  • GetSoftkey() : KeyboardConfig, Window
  • GetSoftkeyBarHeight() : WindowFrameView
  • GetSoftkeyBarView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetSoftkeyCount() : KeyboardConfig, SoftkeyBar
  • GetSoftkeyDesc() : ContextDescription
  • GetSoftkeyFeatureItem() : SoftkeyDesc
  • GetSoKeepAliveOption() : InetSocket
  • GetSoLingerOption() : InetSocket
  • GetSoRcvBufOption() : InetSocket
  • GetSoReuseAddrOption() : InetSocket
  • GetSortByLatestFirst() : BtBipGetImagesListIndArg
  • GetSortColid() : UibApp
  • GetSortedColumnId() : Provider, AbstractDelegationProvider, AppendProvider, PbBaseProvider
  • GetSortedFolderProvider() : UibApp
  • GetSortedNumberProvider() : PbDataHandler
  • GetSortingColumnId() : SmsSettingsRecord
  • GetSortKey() : UibSettingsRecord
  • GetSortMode() : ChineseQuickSortProvider
  • GetSoSndBufOption() : InetSocket
  • GetSoTypeOption() : InetSocket
  • GetSound() : SoundItem, SoundObtainer
  • GetSoundBuffer() : SoundRef
  • GetSoundObtainer() : SoundItem
  • GetSource() : StreamAudioPlayer, SpeechSimpleAudioDevice, RadioAudioDevice, MmfPlayer, AudioVibratorDevice, MapiAudioPlayer
  • GetSourceAddressAndSubnetMask() : PdpContext::PacketFilter
  • GetSourceString() : InputAction
  • GetSpaceInfo() : EmsCreator
  • GetSpaceKeyCode() : T9InputMapper
  • GetSpaceSize() : RamFileSystem
  • GetSpdiData() : SimAccessor
  • GetSpdiInfo() : SimAccessor
  • GetSpeakerGain() : BtHsService, BtHfService, BtAudioAccessoryService
  • GetSpecialSmsMessageCount() : InformationElement
  • GetSpecialSmsMessageIndicationType() : InformationElement
  • GetSpecialSmsMessageType() : InformationElement
  • GetSpeed() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetSpn() : SimAccessor
  • GetSpnData() : SimAuxHandler
  • GetSpnStruct() : SimSpnReadIndArg
  • GetSrPos() : MdhNewStatusReportIndArg
  • GetSrStatus() : MdhNewStatusReportIndArg
  • GetSsCode() : UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, UusStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallForwardingActiveMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, InputParser, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, ColrAction, ColpAction, CnapAction, ClipAction, NumberIdentificationAction, CallHdl
  • GetSSCodeString() : InputParser
  • GetSsControlSeq() : SsRequestAcceptedMsg, SsRequestSentMsg
  • GetSsData() : SsDataIndArg
  • GetSsErrorCode() : SsErrIndArg
  • GetSsInfoAlpha() : SimTkSsIndArg
  • GetSsInfoIcon() : SimTkSsIndArg
  • GetSsOpeartionCode() : UssdAnswerMsg
  • GetSsOperationCode() : SsNotifyIndArg
  • GetSsProcedure() : InputParser, WaitSsAction, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, NumberIdentificationAction, ClirAction
  • GetSSProcedureString() : InputParser
  • GetSsSequence() : SsInfoMsg, SsFacilityIndArg
  • GetSsStatus() : ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallForwardingStatusMsg, CallBarredMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg
  • GetSst() : SimSstReadIndArg
  • GetSstCount() : SimAuxHandler
  • GetStackState() : BtStateChangedMessage
  • GetStartAddress() : UserData, UserDataHeader
  • GetStartDate() : DrmAsset
  • GetStartDelay() : ItemRendererProperties
  • GetStartFrame() : MP3AudioReference
  • GetStartIndex() : EditorLine, TextListLine, CompoundItemReferrer
  • GetStartpage() : WapProfile
  • GetStartpagePassword() : WapProfile
  • GetStartpageUsername() : WapProfile
  • GetStartPos() : SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg
  • GetStartPosition() : AudioReference
  • GetStartRecno() : UsimPbUpdReqArg
  • GetStartTime() : MptyCallHdl, CallHdlBase, CallHdl, MmCallHdl
  • GetStartupData() : StartUp
  • GetState() : ProviderUpdateMsg, DataConn, Control::NavigationGuidance, Camera, RadioButtonModel, BtHsService, BtHfService, BtAvrcpPanelPassThroughParams, PdpContextManager, PdpContextManager::AttachStatus, PdpContext, PdpContext::ActivationStatus, FtpClient, MmCallStatusMsg, MediaRecorder, MediaPlayer
  • GetStateMap() : StateMachine
  • GetStaticProperties() : DBService
  • GetStationInfo() : RadioAudioDevice
  • GetStationName() : AudioFmRadioRdsStationNameMsg
  • GetStats() : HeapVector::VarPage, HeapVector::BlockPage
  • GetStatsFunction : HeapVector
  • GetStatus() : SmsStatusReportTextMap, BtDeviceListProvider, PbSortedProvider, PbSimProvider, PbNameFilterProvider, PbNumberFilterProvider, BackLight, Charger, Provider, SettingsProvider, AocChargingStatusMsg, RegistrationChangeMsg, ChvChangedMsg, ExtPsdContextListener_SioGlueWrapper, Tpdu, SimInitIndArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, ShortMessageStatus, DetachCnfArg, NRegStateIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, ImeiReadIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsRefreshIndArg, AocIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, AtAccessoryRegisterCnfArg, AtGenericCmdIndArg, AtPbListCnfArg, AtPbSelectCnfArg, SvgStatusMsg, SioGlueWrapper, MeasurementData, GltpConnStatusMsg, SmsClass0Provider, TpduHeaderInformation, PlmnProvider, CountryProvider, CmiProvider, ChvProvider
  • GetStatusCount() : SmsConcatStatusTextMap, SmsStatusTextMap
  • GetStatusInfo() : PredInputMapper, Zi8InputMapper, T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper
  • GetStatusLine() : HttpResponse
  • GetStatusName() : SmsConcatStatusTextMap, SmsStatusTextMap
  • GetStatusReportProvider() : AbstractSmsApp
  • GetStatusString() : CallHdlBase
  • GetStep() : AnimatedTextLine, IconValueIndicator, ValueIndicator
  • GetStereoMode() : RadioAudioDevice
  • GetStkCallSetupNo() : CallSetupBySimtTkReqArg
  • GetStopBits() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetStopCause() : AudioStoppedMsg
  • GetStorage() : NvRamStorage
  • GetStorageDevice() : StorageDeviceIterator, RootFileSystem, File
  • GetStorageDeviceCount() : RootFileSystem
  • GetStorageDeviceId() : StorageDeviceIterator, RfsStorageDeviceRegistrationStatusMsg, RfsMediaAvailableStatusMsg, PathProfile, Path, File, RootFileImp, RamFileImp, FlashFileImp, FatFsUsbMassStorageReleaseMsg, FatFsUsbMassStorageRequestMsg, FatFileImp
  • GetStorageDeviceIterator() : RootFileSystem
  • GetStorageLocation() : SmsSettingsRecord
  • GetStorageMediaPrimitive() : SimPduHandler
  • GetStoragePosition() : SmsNewStatusReportIndArg, SmsNewMessageIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsRefreshIndArg
  • GetStorageType() : SmsNewStatusReportIndArg, SmsNewMessageIndArg, MdhSmsNewMessageIndArg
  • GetStorageTypeCount() : SmsStorageTypeTextMap
  • GetStorageTypeName() : SmsStorageTypeTextMap
  • GetStorMedia() : MdhSetStorageReqArg
  • GetStreamObexImpl() : StreamObexTransport
  • GetStreamSize() : Tlv
  • GetStreet() : VCard
  • GetString() : LanguageManager, StringDataSink, PhoneNumber, DataItem, Property
  • GetStringCount() : LocaleConfig
  • GetStringPayload() : RegNodeBuffer
  • GetStringValue() : AtResponseParameter
  • GetStrippedFileName() : Pathname
  • GetStroke() : Zi8InputConfig, T9InputConfig
  • GetStrokeBuffer() : ChineseT9Wrapper
  • GetStrokes() : PredInputMapper, Zi8Wrapper, Zi8InputMapper, T9InputMapper, ChineseT9InputMapper
  • GetStyle() : Pen, Brush
  • GetStyleSheet() : HttpClient
  • GetSubAddr() : DhChannelOpenReqArg, SiChannelOpenPromptReqArg
  • GetSubAddress() : EctActiveMsg, SimTkCallSetupIndArg
  • GetSubDirectoryNode() : RamFileNode
  • GetSubState() : BtBppClientService
  • GetSubstitutedText() : SubstitutedText
  • GetSubSystemName() : VersionInfo
  • GetSubunitId() : BtAvrcpRawFrameParams
  • GetSubunitInfo() : BtAvrcpOperationService
  • GetSubunitInfoEntries() : BtAvrcpSubunitInfoParams
  • GetSubunitInfoParams() : BtAvrcpSubunitInfoRequest
  • GetSubunitInfos() : BtAvrcpRegisterParams
  • GetSubunitType() : BtAvrcpRawFrameParams
  • GetSuccess() : SoundBrowserWin, RenameFileDialog, BrowserSaveWin, ImageBrowserWin, RenameFileDialog, BrowserSaveWin
  • GetSuccessfullIterations() : SocketTestApp
  • GetSupportedAttachmentFormatList() : BtBipImagingCapabilities
  • GetSupportedBandList() : BandStatusMsg, OmBandStatusCnfArg
  • GetSupportedCategories() : BtAvrcpRegisterParams
  • GetSupportedDecoderCodecsCount() : MediaFrameworkCaps
  • GetSupportedEncoderCodecsCount() : MediaFrameworkCaps
  • GetSupportedFeatures() : BtHfService, BtQuerySupportedProfilesRequest
  • GetSupportedFrameRates() : CamWin32, VideoCamera
  • GetSupportedImageFormatList() : BtBipImagingCapabilities
  • GetSupportedImageSizes() : CamWin32, VideoCamera, StillCamera, Camera
  • GetSupportedSensorImageSizes() : CamWin32
  • GetSymbol() : T9InputConfig
  • GetSymbolCandidates() : Zi8InputConfig
  • GetSymbolCandidatesLength() : Zi8InputConfig
  • GetSymbolPages() : T9InputConfig
  • GetSymbolRows() : T9InputConfig
  • GetSynchronizer() : PhonebookApp, AdvPbApp
  • GetSysErr() : SysSocket
  • GetSysError() : SysSocket
  • GetSystemColor() : Theme, TestTheme, FoggyTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetSystemColorTable() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, DefaultTheme
  • GetSystemFontId() : TestTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetSystemSemaphore() : System
  • GetT3310Expiries() : PdpContextManager::AttachStatus
  • GetT3380Expiries() : PdpContext::ActivationStatus
  • GetT9BufferSize() : T9InputConfig
  • GetT9UdbSize() : T9InputConfig
  • GetT9Wrapper() : T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper
  • GetTabButtonView() : Theme, FoggyTheme, DefaultTheme
  • GetTabControlView() : Theme, FoggyTheme, DefaultTheme
  • GetTabCount() : TabControl
  • GetTable() : UriMappingTable, NotificationTable
  • GetTag() : Tlv
  • GetTagAsByte() : TaggedProblemCode
  • GetTaggedProblemCode() : NetworkSsRejectedMsg, SsRejReqArg, SsRejArg
  • GetTagSize() : SimPbBaseHandler, PbBaseProvider
  • GetTarget() : ObexServer
  • GetTargetDevice() : BtHfProfileWindow, BtAvrcpControllerDeviceListItem, BtObexConnectRequest, BtService, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest
  • GetTcpMaxSetOption() : TcpSocketBase
  • GetTcpNoDelayOption() : TcpSocketBase
  • GetTelematicDevice() : ProtocolIdentifier
  • GetTelNumber() : VCard
  • GetTelNumberCount() : VCard
  • GetTelNumberType() : VCard
  • GetTemplateCount() : SmsTemplateTextMap
  • GetTemplateData() : VrG2AResultIndArg, VrStoreTemplateReqArg
  • GetTemplateDataLength() : VrG2AResultIndArg, VrStoreTemplateReqArg
  • GetTemplateId() : VrRecogResultIndArg, VrIntrmRecResultIndArg, VrLoadTemplateReqArg, VrPlaybackFinishedMsg, VrTrainingResultMsg, VrResultMsg
  • GetTemplateProvider() : AbstractSmsApp
  • GetTemplateText() : SmsTemplateTextMap
  • GetTemplateTitle() : SmsTemplateTextMap
  • GetTempo() : AudioReference
  • GetTemporaryLocalTimeZone() : DateTime
  • GetTemporaryProfileIdSet() : DataConnProfileManager
  • GetTermCause() : BrowserTermEventArg
  • GetTerminal() : SerialTerminalSocket, SerialTerminalArg
  • GetTests() : SocketTestApp
  • GetText() : SmsServiceMsg, TextPackConnector, TextEditorDocument, TextCompoundItem, TabControl, PasswordEditor, MultiLineEditor, LineEditor, Item, Alert, AcacLanguage, AbstractTextObject, AbstractButton, TextList, TextListModel, RadioButtonItem, IconTextIndicator, TextIndicator, CheckBoxItem, AbstractEditBox, AbstractEditBoxModel, ValueMappingPropertyDescriptor< T_Container >, TextIconPairArray::TextIconPair, SubstitutedText, PropertyDescriptor, ListPropertyDescriptor, ProviderProxyItem, FeatureItem, EnumTextMap, UusRegisteredMsg, UusNotificationMsg, HomezoneMsg, SsUus1ReqArg, SsUus1IndArg, SmsStatusReport, SmsSubmit, SmsDeliver, GetInkeyRspArg, GetInputRspArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimTextString, SimItemIdentifier, SimAlphaIdentifier, HomezoneIndArg, Cbs, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, ValueTextMap, T9PinyinBox, StrokeBox, SelectionBox, SmsWStringCache::Entry
  • GetTextAlign() : TextFormat, DeviceContext
  • GetTextAlignment() : Locale
  • GetTextAttr() : TextFormat, TextCompoundItem, DeviceContext, RichTextCompoundItem, MultiMediaEditor
  • GetTextColor() : ItemRendererProperties
  • GetTextColumnId() : ProviderProxyContainer
  • GetTextCompression() : DataCodingScheme
  • GetTextCount() : ValueMappingPropertyDescriptor< T_Container >
  • GetTextData() : UserData
  • GetTextDataLength() : UserData
  • GetTextFormat() : ItemRendererProperties, DeviceContext, Alert, AbstractTextObject
  • GetTextFormattingBackgroundColour() : InformationElement
  • GetTextFormattingColour() : InformationElement
  • GetTextFormattingElement() : EditorItemNode
  • GetTextFormattingFontSize() : InformationElement
  • GetTextFormattingForegroundColour() : InformationElement
  • GetTextFormattingLength() : InformationElement
  • GetTextFormattingMode() : InformationElement
  • GetTextFormattingStartPosition() : InformationElement
  • GetTextFormattingTextAlignment() : InformationElement
  • GetTextForMsgType() : UibPerformanceTest
  • GetTextGap() : AnimatedTextLine
  • GetTextInfoAlpha() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • GetTextLength() : AbstractEditBoxModel, SimPbEntryCont
  • GetTextList() : UusStatusMsg, SsUus1QueryIndArg
  • GetTextListView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetTextRenderer() : GuiEngineConfig
  • GetTextSize() : DeviceContext
  • GetTextString() : SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, SimLaunchBrowserPromptReqArg, SetupIdleModeTextReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • GetTextWidth() : ThaiTextRenderer, SimpleTextRenderer, Font, ArabicTextRenderer, AbstractTextRenderer
  • GetThaiFontHints() : FontConfig
  • GetTheme() : ThemeConfig, System
  • GetThemeCount() : ThemeConfig
  • GetThemeId() : System
  • GetThisCallCcm() : CurrentCallMeterMsg, ChargeUnitsIndArg
  • GetThisCallCharge() : CurrentChargeDataMsg, ChargeIndArg
  • GetThousandSeparator() : Locale
  • GetThreadData() : Thread
  • GetThreadId() : Thread
  • GetThreadlet() : FfsTestDispWin, ThreadletNotificationMsg
  • GetThresholdPercentage() : StartSignalStrengthListeningArg
  • GetTicks() : Os, SvgDecodingFinishedMsg
  • GetTid() : SimSetupMenuMsg, SmsSendRejArg, SmsSendCnfArg, SimTkRefreshNewRspArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkRefreshNewReqArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg
  • GetTime() : CalendarRecord, TimeEditorDocument, TimeEditor, TimeCompoundItem, TimeEditBox, DateTime, DataItem, Property
  • GetTimeFeature : AudioDeviceBase
  • GetTimeFormat() : Locale, FunctionalityIndicator
  • GetTimeout() : Timer, SystemTimer, AudioReference
  • GetTimePosition() : SvgPlayer
  • GetTimer() : TimerTimeoutMsg, ExternalTimeoutMsg, AbstractGrid::SmoothScrollInfo, AbstractListBox::SmoothScrollInfo, SmsConfigIndArg
  • GetTimes() : PackedTimePeriod
  • GetTimeSpan() : PackedTimePeriod
  • GetTimeStamp() : HostDebugTimeStamp, TimeFeatureObject, MdhSmsTransmitIndArg, MdhSmsRefreshIndArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, DBItemChangedMsg
  • GetTimestamp() : FfsFile, FlsFile
  • GetTimeZone() : ValidityPeriod, CodedTimeStamp, MnInformationIndArg, StatusProvider, DataHandler
  • GetTiPd() : SaMolrResultArg, LcsMolrResultArg, LocationNotifInvokeArg
  • GetTipd() : SsWaitDispatcher, TipdBasedActiveWaitDispatcher, UssdBeginMsg, GetPasswordMsg, UssdDataMsg, UssdEndMsg, UssdNotifyMsg, UssdRequestMsg, SsErrorMsg, CallBarringPasswordChangedMsg, ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, CnapInfoReceivedMsg, EctAlertingMsg, EctActiveMsg, MultiPartyCallInvokedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, CugCallMsg, HlrDataCorruptedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallIsWaitingMsg, CallRetrievedMsg, CallHeldMsg, CallForwardingActiveMsg, ClirNotSurpressedMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg, SsRequestAcceptedMsg, UssdAnswerMsg, SsInfoMsg, DiagnosticIndMsg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityIndArg, SsBeginAccArg, SimTkSsIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, RedialSetupIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, ChargeUnitsReqArg, ChargeReqArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, CallDeflectSsReqArg, CallDeflectionIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, CallIndCallControlInfoArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg, XCallInfoResponseParser
  • GetTitle() : Window, MenuAccessor, VCard, PropertyDescriptor
  • GetTitleAlpha() : SetupMenuReqArg, SelectItemReqArg
  • GetTitleHeight() : WindowFrameView
  • GetTitleIcon() : SetupMenuReqArg, SelectItemReqArg
  • GetTitleText() : SatteliteInfoWin, SatteliteGraphWin, LocationResultWin
  • GetTitleTextFormat() : WindowFrameView
  • GetTitleTextType() : MenuProperties
  • GetToDoApplication() : ToDoComposeWin
  • GetTON() : PhoneNumber
  • GetTone() : AudioReference, PlayToneReqArg
  • GetToneCount() : AbstractIMelodyParser
  • GetToneData() : Melody, IMelody
  • GetToneID() : PresetAudioReference, AudioPreset
  • GetToneId() : PreparedSound
  • GetToneMode() : Zi8Wrapper
  • GetToneType() : CustomToneAudioReference, AudioPreset, AudioTone
  • GetTONNPI() : PhoneNumber
  • GetTop() : Rect, WinRect
  • GetTopLineGap() : ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor
  • GetTopSize() : ControlFrameView
  • GetTotalEntries() : MePhonebookDescriptor, AtPbSelectCnfArg
  • GetTotalIterations() : SocketTestApp
  • GetTotalPlayTime() : MmfPlayer, AudioReference
  • GetTotalSpace() : FfsHandler
  • GetTotalSpaceSize() : RamHandler
  • GetTotalVolumeSize() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetTpData() : Tpdu
  • GetTpdu() : SmsInfoBox, SmsFactory, SmsSendReqArg, MdhSmsTransmitIndArg, MdhSmsNewMessageIndArg, MdhNewStatusReportIndArg, TpduCache, CompoundTpduItem
  • GetTpduConc() : MdhSmsReadIndArg
  • GetTpduCount() : SimPduHandler
  • GetTpduCountType() : SimPduHandler
  • GetTpLength() : Tpdu
  • GetTpOffset() : Tpdu
  • GetTraceInfo() : ObexAbstractPort
  • GetTrackId() : MediaInfo::MediaTrackInfo
  • GetTrackInfo() : MmfPlayer
  • GetTransactionId() : UriMappingTable
  • GetTransferBuffer() : DisplayConfig
  • GetTransformation() : CameraSettings, ImageBox, BtBipImageDesc, BtBipImageFormat
  • GetTranslationTable() : LocaleConfig
  • GetTransmitCause() : MdhSmsTransmitStartIndArg
  • GetTransparentColor() : NativeImage, Image, Bitmap, BitmapRes, SvgImage, WbmpImage, PngImage, PngDecoder, GifImage, BmpImage
  • GetTranspLayer() : DhChannelOpenReqArg
  • GetTransport() : ObexMngr, ObexAddress, ObexAbstractPort, StreamObexImpl
  • GetTransportDisableReason() : IrdaTransport
  • GetTransportId() : ObexTransportMsg, ObexChannel, ObexAddress
  • GetTransportMutex() : BtObexImpl
  • GetTransportOperId() : ObexAbstractPort
  • GetTree() : RamFileSystem
  • GetTriggeredMessage() : InputMap, Control
  • GetTrust() : WapProfile
  • GetTstFile() : SimAccessor
  • GetTtyMode() : TtyInterface
  • GetTtySpeed() : TtyInterface
  • GetTwilight() : CameraSettings
  • GetTwilightMode() : Camera
  • GetType() : ToDoRecord, BtDeviceListWindow, DataConnProfileInfoMsg, DataConnInfoMsg, NetAdapter, DataConnProfileManager::ProfileInfo, DataConnProfile, ObexHeader, ServiceThread, ExecutionContext, Application, PredInputMapper, AnimatedTextLine, VirtualDisplay, BtSvrDataElement, BtSddbDeAlternative, BtSddbDeSequence, BtSddbDeUrl, BtSddbDeString, BtSddbDeUuid128, BtSddbDeBigSintBase, BtSddbDeBigUintBase, BtSddbDeBoolean, BtSddbDeUuidBase, BtSddbDeSintBase, BtSddbDeUintBase, BtSddbDeNil, BtSddbDataElement, Provider::Modification, PhoneNumber, AudioRadioDeviceNotificationMsg, UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, PdpContext, PdpContext::PacketFilter, PdpContext::Authentication, PinAction, SsUus1ReqArg, SsUus1IndArg, Sms, SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg, MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType, BaseInformationElement, Accessory, Zi8InputMapper, T9InputMapper, XCallInfoResponseParser, AtCommand, MCServiceInterfaceMsg, MediaManagerMsg, DrmConstraint, PhoneNumberJoinRule, StandardJoinRule, JoinRule
  • GetTypeId() : ImageRefGenContainer, BtDeviceAddressGenericObject, ObexProtocol, ObexDispatcher, ObexServerAddr, ObexClientAddr, ObexAddress, BtJsr82Url::Token, RegBlobObject, GenericObject, BlobPtr, BlobObject, TimeFeatureObject, GenericFeatureData, ImgObtObj, MenuIdObj, ItemObj, MenuDescObj, CompoundTpduItem, CompoundSmsItem
  • GetTypeOfNumber() : TypeOfAddress
  • GetTypeOfServiceMaskOrTrafficClassMask() : PdpContext::PacketFilter
  • GetTypeOfServiceOrTrafficClass() : PdpContext::PacketFilter
  • GetUid() : DrmAsset, UsimPbRwRecord, UsimPbUpdResArg, DrmRightsObject, DrmMessage
  • GetUInt() : NumberPrompt
  • GetUint32FromUint8Array() : AudioUtility
  • GetUnblockchv() : ChvUnblockReqArg
  • GetUnblockPin() : PinAction
  • GetUnicodeStringToGsm7DefaultStringLength() : DataCoding
  • GetUniqueId() : PbNumberRecord
  • GetUniqueString() : PbManualSynchronizer
  • GetUnit() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams, PackedTimePeriod
  • GetUnitId() : GltpRequest
  • GetUnitInfo() : BtAvrcpOperationService
  • GetUnitInfoParams() : BtAvrcpUnitInfoRequest
  • GetUnitType() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • GetUnreadCount() : SimPduHandler
  • GetUnreadProvider() : AbstractSmsApp
  • GetUnsentCount() : SimPduHandler
  • GetUnsentProvider() : AbstractSmsApp
  • GetUpdateAction() : UsimLangUpdReqArg, UsimPlmnUpdReqArg
  • GetUpdatedItem() : PbDetails, PbAdvDetails
  • GetUpdateNumber() : Cbs::SerialNumber
  • GetUpdatePath() : AudioAccessoryDetails
  • GetUplinkPath() : AudioAccessoryDetails
  • GetUpperCaseChar() : PagingMapEntry
  • GetUpperDestinationPort() : PdpContext::PacketFilter
  • GetUpperSourcePort() : PdpContext::PacketFilter
  • GetUri() : RegNodeBuffer, NotificationTableEntry, LockTable, RegNotifyMsg
  • GetUriDepth() : Uri
  • GetUriHeader() : Uri
  • GetUrl() : SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg
  • GetUrlScheme() : ObexAbstractTransport
  • GetUrlStr() : ObexServerDispatcher
  • GetUrlType() : BtJsr82Url
  • GetUsage() : ProtocolIdentifier, MessageTypeIndicator
  • GetUsbTransport() : UsbSubSystem
  • GetUsedBandList() : BandStatusMsg, OmBandStatusCnfArg
  • GetUsedEntries() : AtPbSelectCnfArg
  • GetUsedSize() : RamStorageMapper
  • GetUsedSpace() : FfsHandler
  • GetUsedSpaceByType() : FfsHandler
  • GetUsedSpaceInGlobalPool() : FfsHandler
  • GetUsedSpaceSize() : RamHandler, RamFileSystem
  • GetUsedVolumeSize() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetUseInbandRinging() : BtAudioAccessoryService
  • GetUseMessageInterface() : BtObservableService
  • GetUser() : FtpClient
  • GetUserData() : SmsStatusReport, SmsSubmit, SmsDeliver
  • GetUserDataHeader() : UserData
  • GetUserDefinedSoundBuffer() : InformationElement
  • GetUserDefinedSoundLength() : InformationElement
  • GetUserDefinedSoundStartPosition() : InformationElement
  • GetUserHome() : FtpAuthProvider
  • GetUserId() : BtController, BtConnectionlessController, BtConnectionBasedController, FlsFile
  • GetUserInput() : CallControlUssdIndArg, CallControlSsIndArg, SimTkSsIndArg
  • GetUserInputLanguage() : CallControlUssdIndArg, CallControlSsIndArg, SimTkSsIndArg
  • GetUserLogin() : DhChannelOpenReqArg
  • GetUserPassword() : DhChannelOpenReqArg
  • GetUserPromptIndicatorNumberCorrespondingObjects() : InformationElement
  • GetUsimFileProperty() : SimAccessor
  • GetUsimPbLocReport() : DataHandler
  • GetUsimPbResult() : UsimPbReadyMsg
  • GetUst() : UsimUstReadIndArg
  • GetUtilityProcessor() : AbstractSmsApp
  • GetValidityPeriod() : DrmAsset, SmsContext, SmsSubmit
  • GetValidityPeriodFormat() : SmsSubmit
  • GetValLen() : Tlv
  • GetValPtr() : Tlv
  • GetValue() : RadioButtonControl, PositionIndicator, Color, CheckBoxControl, AbstractToggleAction, RadioButtonItem, ValueIndicator, BtJsr82Url::Token, BtSddbDeVariableLengthType, BtSddbDeByteBlockType, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, SimpleMap< TKey, TValue >, SimpleMapElem< TKey, TValue >, IndexTable< T >, ValueMappingPropertyDescriptor< T_Container >, RangeMappingPolicy, MappingPolicy, ListPropertyDescriptor, EccCategory
  • GetValuePointer() : BtSvrDataElement
  • GetValueSize() : BtSvrDataElement
  • GetVariablePictureBuffer() : InformationElement
  • GetVariablePictureHorizontalDimension() : InformationElement
  • GetVariablePictureLength() : InformationElement
  • GetVariablePictureStartPosition() : InformationElement
  • GetVariablePictureVerticalDimension() : InformationElement
  • GetVariantList() : BtBipImageProperties
  • GetVCard() : ObexVCardMsg, VCardItem
  • GetVersion() : Registry, DrmDcfParser
  • GetVersionString() : VersionInfo
  • GetVeryLongFeature() : KeyMapping
  • GetVeryLongKeyDelay() : KeyboardConfig
  • GetVideoChannel() : DefaultDisplay, Display, DefaultDisplay
  • GetVideoCodec() : RecordSettings
  • GetVideoInfo() : MediaInfo
  • GetVideoInfoCount() : MediaInfo
  • GetVideoQuality() : RecordSettings
  • GetView() : ThemeViewIterator, Component, TimeEditBox, IndicatorBar, EditBox, DateEditBox, AbstractEditBox, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg
  • GetViewConfig() : MdhSetConfigReqArg
  • GetViewCount() : BrowserViewContainer
  • GetViewHdl() : MdhRemoveViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSmsUpdStatusReqArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSmsUpdStatusIndArg, MdhRegistrationCnfArg
  • GetViewScalingMethod() : Camera
  • GetVisibleItemCount() : AbstractLineEditor
  • GetVisibleLineCount() : AbstractMultiLineEditor
  • GetVisibleRowCount() : AbstractGrid
  • GetVisibleValuesCount() : PositionIndicator
  • GetVKey() : KeyMapping
  • GetVoiceBoxNumber() : SmsSettingsRecord
  • GetVolume() : AudioContext, AudioReference, AudioDeviceBase, AudioActiveReference, AudioAccessoryDetails
  • GetVolume_Specific() : AudioDeviceBase
  • GetVolumeSet() : AudioReference, AudioActiveReference
  • GetWaitIndicatorArray() : MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg
  • GetWaitingMessage() : DataCodingScheme
  • GetWaitingMessageIndication() : DataCodingScheme
  • GetWapProfile() : WapProfileMgr
  • GetWapProfileInfo() : WapProfileMgr
  • GetWarningCode() : VrWarningIndArg, VrWarningMsg
  • GetWarningLevel() : SmsCapacityExceededArg
  • GetWCharForBcdCode() : PhoneNumber
  • GetWchars() : DataCoding
  • GetWhiteBalance() : Camera
  • GetWidth() : DisplayConfig, ImageMetaData, Size, Rect, ImageObtainer, ImageEncoder::EncodingParameters, Image, Image::MetaData, Glyph, DeviceContext, Component, Bitmap, BitmapRes, VirtualDisplay, WinRect, SoundItem, SimImage, SvgPlayer, SvgImageFileWrapper, VCardItem, PngDecoder, ImageItem, BoundedItem, AudioItem, MediaInfo::VideoTrackInfo
  • GetWildcard() : EditConfig
  • GetWin() : OpenPbWinMsg
  • GetWindow() : CloseWindowMsg, WinMenuItem
  • GetWindowContextId() : AtlItemGridWindow
  • GetWindowFrameView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetWindowProvider() : PhonebookApp
  • GetWindowTitle() : ContextDescription
  • GetWirelessControlMessageProtocolBuffer() : InformationElement
  • GetWirelessControlMessageProtocolLength() : InformationElement
  • GetWord() : Zi8EnteredUnknownWordMsg, T9EnteredUnknownWordMsg
  • GetWorkMedia() : MdhSmsTransmitIndArg, MdhSmsStorageRefreshIndArg
  • GetWrapPolicy() : AbstractMultiLineEditor
  • GetWrapPositions() : AbstractTextRenderer
  • GetWriteByteCount() : StreamingWriteInfo
  • GetWriter() : Stream
  • GetWrittenByteCount() : StreamingWriteInfo
  • GetWspVersion() : WapProfile
  • GetWString() : Time, Provider, PhoneNumber, Date, DataItem, Property, UsimLanguage, ExtLanguage, BaseInformationElement, SmsWStringCache, PbBaseProvider
  • GetWStringCashPos() : TpduHeaderInformation
  • GetWwwDir() : HttpServerConfig, HttpServer
  • GetX() : Point
  • GetXPos() : Rect, Component
  • GetY() : Point
  • GetYear() : Date
  • GetYearYY() : Date
  • GetYearYYYY() : Date
  • GetYPos() : Rect, Component
  • GetZoom() : CameraSettings, Camera
  • GetZoomLevelCount() : Camera
  • gi : JarFileStatusInfo, JarBinDataStatusInfo
  • GifDecoder : GifImage
  • GifImage() : GifImage
  • GlassPane() : GlassPane
  • GlassTileFilter : Camera
  • Global : CTResourcePack
  • GltpAidDataRequests() : GltpAidDataRequests
  • GltpAidingDataWin() : GltpAidingDataWin
  • GltpAidingRequest() : GltpAidingRequest
  • GltpAssistanceData() : GltpAssistanceData
  • GltpConnStatusMsg() : GltpConnStatusMsg
  • GltpHelloRequest() : GltpHelloRequest
  • GltpMsmtRequest() : GltpMsmtRequest
  • GltpPositionRequest() : GltpPositionRequest
  • GltpRequest() : GltpRequest
  • GltpStackMsgArgsDestroyTableNode : MeasurementDataArg
  • GmmParam() : GmmParam
  • gmt_bias : RealTimeClock::DateAndTime
  • GotoDay() : CalendarMonthWin
  • GoToSms() : AbstractSmsViewerWin
  • GoToSmsEmbItems() : SmsViewerWin, AbstractSmsViewerWin
  • gprs : TestparamReport
  • Gprs : TestparamReport
  • gprs_class : MmCoordParam
  • gprs_sup : GprsParam
  • GprsAttachStatusMsg() : GprsAttachStatusMsg
  • GprsClassIndArg() : GprsClassIndArg
  • GprsClassReqArg() : GprsClassReqArg
  • GprsParam() : GprsParam
  • GprsServiceNotAllowed : PdpContext
  • GprsStatusMsg() : GprsStatusMsg
  • GpsModule : Accessory
  • GpsToUtcTime() : LcsUtils
  • GrabFocus() : System, Application, AppContainer, Control
  • GrayScaleAlphaFormat : PngEncoder::EncodingParameters
  • GrayScaleFilter : Camera
  • GrayScaleFormat : PngEncoder::EncodingParameters
  • GreaterRule() : GreaterRule
  • GreaterType : StandardJoinRule
  • GreatestValueOfApplicationCategoriesFlagsType : CodecDevice
  • GreatestValueOfFlagsType : VideoDecoder
  • Greek : LanguageManager, DataCodingScheme
  • green : Palette, Led::Color, SimClutEntry
  • Grey : InformationElement
  • Grid() : Grid
  • GridLayout() : GridLayout
  • GridModel() : GridModel
  • GridView() : GridView
  • Group00 : ProtocolIdentifier
  • Group01 : ProtocolIdentifier
  • Group3Telefax : ProtocolIdentifier
  • Group4Telefax : ProtocolIdentifier
  • group_id : PbRecord::Persist
  • GroupId : DataCodingScheme
  • GroupIds : OptionalConfigBase
  • grouping : T_PB_RECORD, T_PB_CHANGED_FIELD
  • GroupProvider() : GroupProvider
  • Gsm7DefaultStringToUnicodeString() : DataCoding
  • gsm_band : MmCoordParam
  • gsm_bands : GsmBandList
  • gsm_lang_code : LanguageCodeTableEntry
  • gsm_service : SmsSettingsRecord::Persist
  • GsmAmrNb : MediaInfo, CodecDevice
  • GsmBandStateMsg() : GsmBandStateMsg
  • GsmUmts : ProtocolIdentifier
  • Gui : InternalTracer
  • GuiEngine : OptionalConfigBase
Generated on Wed Jan 25 00:54:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • H263Bl : MediaInfo, CodecDevice
  • H264Bp : MediaInfo, CodecDevice
  • HalfHourAfter12 : PackedTimePeriod
  • handle : Mp3Param, VmParam, PcmParam, T_PB_FILE_DESC
  • handle_response() : apoxi_emcpp_OBEXAdapter
  • HandleAbort() : StreamObexImpl
  • HandleAudReturnCode() : DwdDevice
  • HandleByteStream() : RegAppWin
  • HandleConnect() : StreamObexImpl
  • HandleConnectionRequest() : ObexFtpDataServer
  • HandleDeleteObjectRequest() : ObexFtpDataServer
  • HandleDisconnect() : StreamObexImpl
  • HandleDispatcherList() : ExecutionContext
  • HandleEnglishKeyEvent() : Zi8Wrapper
  • HandleFilePullRequest() : ObexFtpDataServer
  • HandleFilePushRequest() : ObexFtpDataServer
  • HandleFolderListingRequest() : ObexFtpDataServer
  • HandleGet() : StreamObexImpl
  • HandleMessage() : KeyManager
  • HandleMsg() : ServiceThread, ExecutionContext, Application
  • HandleOnAsyncEvent() : ClientNetAdapter
  • HandlePinYinKeyEvent() : Zi8Wrapper
  • HandleProvideFolderListingEntriesFinished() : ObexFtpDataServer
  • HandleProvideFolderListingEntry() : ObexFtpDataServer
  • HandlePut() : StreamObexImpl
  • HandleRadioAudioNotification() : FmRadioWindow
  • HandleRequest() : HttpServer, FtpServer
  • HandlerId() : EnumTranslationTable
  • HandlerListEntry() : HandlerListEntry
  • HandlerType : ExternalCommunicationHandler
  • HandleSetCurrentFolderRequest() : ObexFtpDataServer
  • HandleSetPath() : StreamObexImpl
  • HandleStrokeKeyEvent() : Zi8Wrapper
  • HandleToneKeyEvent() : Zi8Wrapper
  • HandleTransportDisconnect() : StreamObexImpl
  • HandleWinEvent() : LocResController
  • HandOver() : UdpSocket, TcpSocket, TcpServerSocket, InetSocket
  • HandsFreeCarKit : Accessory
  • HangUp() : ObexServerDispatcher
  • HardHorizontalAnimation : ItemRendererProperties
  • HardVerticalAnimation : ItemRendererProperties
  • has_native_img_data : BitmapRes
  • HasActiveLanguageChanged() : LanguageManager
  • HasAlphaChannel() : Image, SvgImage, PngImage
  • HasAnyChildLocked() : LockTableList, LockTable
  • HasAudio() : StreamAudioReference
  • HasCandidate() : Zi8Wrapper, Zi8InputMapper
  • HasChineseCandidate() : Zi8Wrapper
  • HasClirOverrideCategory() : PhoneNumber
  • HasCphsNetworkSpecificIndicator() : SimPbEntry
  • HasCphsPremiumServiceIndicator() : SimPbEntry
  • HasData() : SimPbEntry
  • HasDefaultSize() : Window
  • HasDtmf() : PhoneNumber
  • HasEntireLacRange() : OplEntry
  • HasExtension() : Pathname
  • HasFocus() : Application, AppContainer, Control
  • Hash() : HashTable
  • Hashable() : Hashable
  • HasHeader() : AbstractItemGrid, AbstractGrid
  • HashTable() : HashTable
  • HasIcon() : Item
  • HasKeyAtPos() : KeySequence
  • HasLeaf() : Pathname
  • HasMoreInformationElements() : UserDataHeader
  • HasMoreResponses() : AtResponseIterator
  • HasMultipleRefs() : WStrData, StrData
  • HasNativeAlphaChannel() : PngDecoder
  • HasNativeImageData() : Bitmap, BitmapRes
  • HasNext() : ScanlineAccessor, DBService::DBItemIterator
  • HasNextCandidates() : Zi8Wrapper
  • HasNextPage() : Zi8Wrapper, Zi8InputMapper
  • HasNotification() : Property
  • HasOnly7bitChars() : DataCoding
  • HasParam() : SimUserDispatcher
  • HasParamAttribute() : SimUserDispatcher
  • HasPbGrown() : PbSynchronizer
  • HasPendingData() : IsrDataManager
  • HasPnnRecordId() : OplEntry
  • HasPorts() : SmsSocketListener
  • HasPrevCandidates() : Zi8Wrapper
  • HasPrevPage() : Zi8Wrapper, Zi8InputMapper
  • HasProvider() : MainProvider
  • HasRemoteVolumeControl() : BtQuerySupportedProfilesRequest
  • HasSelection() : AbstractEditor
  • HasSmsPortNo() : PortHeaderInformation
  • HasValidGzHeader() : SvgGzFileWrapper
  • HasWrongStatus() : TpduHeaderInformation
  • HasWrongSyntax() : InputAction
  • HazeFilter : Camera
  • hcs_used : UmtsRrcScellParam
  • hdl : SharedMemHdl, Task
  • Header() : DataConnProfileStorage::Header
  • header : tagCustomizationPack
  • header_id : BtObexHeader
  • HEADER_SIZE : GltpRequest
  • header_type : BtObexHeader
  • HeaderCompression : PdpContext
  • HeaderExists() : UserData
  • HeaderId : ObexHeader
  • HeaderStyle : AbstractItemRenderer
  • HeaderType : ObexHeader
  • HeadSet : HeadSet, Accessory
  • HeapArrayObject() : HeapArrayObject< T >
  • HeapDataSink() : HeapDataSink
  • HeapDataSource : HeapDataSource, HeapDataSink
  • HeapManager() : HeapManager
  • HeapObject() : HeapObject< T >
  • HeapVector : HeapManager
  • Hebrew : LanguageManager, DataCodingScheme
  • height : FontRes, tagFont
  • HeightProp : GuiObjectFactory
  • HeldCallExists() : InputContext
  • HelpAvailable() : SimSetupMenuOptions, SimSelectItemOptions, SimGetInkeyOptions, SimGetInputOptions
  • HexCharToUInt8() : HttpSocket
  • Hidden : File::Attributes
  • hidden_key_supported : T_PB_DESCRIPTOR
  • HideClippedText : OptionalConfigBase
  • HideUserInput() : SimGetInputOptions
  • HideViewfinder() : Camera
  • High : ToDoRecord
  • high : CbmiRange
  • high_mobility : UmtsRrcScellParam
  • HighPriority() : SimDisplayTextOptions
  • HighQuality : DisplaySettings
  • Hindi : LanguageManager
  • HindiTextRenderer() : HindiTextRenderer
  • HlrDataCorruptedMsg() : HlrDataCorruptedMsg
  • HlrSsDataCorruptMsg() : HlrSsDataCorruptMsg
  • Hold() : MptyCallHdl, CrssHandler, CallHdl
  • HomezoneIndArg() : HomezoneIndArg
  • HomezoneMsg() : HomezoneMsg
  • HookFn : SingleArgHook< T >
  • HorizBorderAlign : Desktop
  • Horizontal : PositionIndicator
  • horizontal : IndicatorBarView
  • HorizontalProp : GuiObjectFactory
  • HorizontalScrollBehavior : OptionalConfigBase
  • HorrorFilter : Camera
  • HostByteOrder : ObexHeader
  • HostDebugTimeStamp() : HostDebugTimeStamp
  • HostFatFsDeviceDescriptor() : HostFatFsDeviceDescriptor
  • HostIniFile() : HostIniFile
  • HostLocation : VideoCamera, CodecDevice
  • hour : RealTimeClock::DateAndTime, FfsTimeRecord, ffs_time_record_type
  • Http : ObexHeader
  • HttpApplication() : HttpApplication
  • HttpAuthProvider() : HttpAuthProvider
  • HttpClient : HttpClient, HttpSocket, HttpServer, HttpApplicationSupplier, HttpApplication
  • HttpConnClosed : HttpHandler
  • HttpConnectMessage() : HttpConnectMessage
  • HttpConnError : HttpHandler
  • HttpConnOpen : HttpHandler
  • HttpConnStatus : HttpHandler
  • HttpConnSuspended : HttpHandler
  • HttpDisconnectMessage() : HttpDisconnectMessage
  • HttpErrorMessage() : HttpErrorMessage
  • HttpHandler : HttpHandler, HttpWapMgr
  • HttpRequest() : HttpRequest
  • HttpRequestMessage() : HttpRequestMessage
  • HttpRequestMethodType : HttpRequest
  • HttpResponse() : HttpResponse
  • HttpServer : HttpServer, HttpSocket, HttpRequest, HttpClient, HttpApplicationSupplier, HttpApplication
  • HttpServerConfig() : HttpServerConfig
  • HttpServerSocket : HttpServerSocket, HttpServer
  • HttpServiceMessage() : HttpServiceMessage
  • HttpSocket : HttpSocket, HttpServer, HttpRequest
  • HttpWapMgr : HttpWapMgrPlugin
  • HttpWapMgrBase() : HttpWapMgrBase
  • HugeAlloc() : Os
  • HugeAllocate() : HeapVector::VarPage, HeapManager
  • HugeFree() : Os, HeapVector::VarPage, HeapManager
  • HugeRealloc() : Os
  • HugeReAllocate() : HeapVector::VarPage, HeapManager
  • Hungarian : LanguageManager, DataCodingScheme
  • hw_platform : BtChipBmu
  • hw_revision : BtChipBmu
  • hw_variant : BtChipBmu
  • HyperlinkFormatElement : InformationElement
Generated on Wed Jan 25 00:54:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • IA52KeyCode() : Conversion
  • IAmAngry : InformationElement
  • IAmConfused : InformationElement
  • IAmCrying : InformationElement
  • IAmGlad : InformationElement
  • IAmIndifferent : InformationElement
  • IAmIronic : InformationElement
  • IAmLaughing : InformationElement
  • IAmSad : InformationElement
  • IAmSceptic : InformationElement
  • IAmWinking : InformationElement
  • icc_id : PbRecord::Persist
  • iccid : SimInfo
  • Icelandic : LanguageManager, DataCodingScheme
  • icon_id : MenuPool::FeatureItemContainerTableEntry, MenuPool::FeatureItemContainerContentTableEntry, SoftkeyDescTableEntry
  • IconAnimation : ItemRendererProperties
  • IconDescReadIndArg() : IconDescReadIndArg
  • IconDescReadReqArg() : IconDescReadReqArg
  • IconDisplayType : ItemRendererProperties
  • IconIdentifierTag : Tlv
  • IconIndicator() : IconIndicator
  • IconProp : GuiObjectFactory
  • IconPropertyId : Item
  • IconSet() : IconSet
  • IconState() : IconState
  • IconTextIndicator() : IconTextIndicator
  • IconValueIndicator() : IconValueIndicator
  • IconValueMapProp : GuiObjectFactory
  • Id : InputMapper, Message, BtBipServerNotificationMsgArg, HandlerListEntry, HandlerData, StackMsgArgument, NetAdapter, PdpContext
  • id : GroupProvider::GroupRec, InternalTracer::TraceHeader, tagFont, tagLanguage, MmiSimMsg, NvRamBlockInfo, BtAttributeId, ArgumentDestroyEntry, TSiIconID_s, StackMsgMapTableEntry, SignalMapTableEntry
  • ID : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, SoundBrowserServiceMsg, AmrSound, SkipSocketTestMsg, StopSocketTestMsg, ContinueSocketTestMsg, NextSocketTestMsg, StartSocketTestMsg, OnDataRcvdMsg, LcsAppResWinMsg, LcsAppRegisterForMtlrMsg, LcsAppTransferLocMsg, ImageBrowserServiceMsg, ImageBrowserRenameImageMsg, ImageBrowserDeleteImageMsg, SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, PredefinedEmsSound, PredefinedEmsImage, EmsImage, CameraMsgStopViewfinding, CameraMsgStartViewfinding, BtIndicatorMsg, PhonebookRenumberedMsg, ProviderUpdateMsg, SyncProgressMsg, SaveEntryInPhonebookMsg, OpenPbWinMsg, JumpToRowMsg, UtcStatusMessage, AsyncUnitTestMsg, DataConnProfileInfoMsg, DataConnInfoMsg, SocketControlMsg, ObexVCardMsg, ObexTransportMsg, ObexAddrMsg, ObexTriggerMsg, ObexMsg, ObexAppMsg, LoseFocusMsg, GetFocusMsg, ContextExecuteMsg, TimerTimeoutMsg, AlarmNotificationMsg, ShutdownRequestMsg, ContextWakeupMsg, ThreadletNotificationMsg, SharedTimerMsg, AppLoseFocusMsg, AppGetFocusMsg, ServiceThreadTerminateMsg, RtcAlarmReachedMsg, RtcDateChangedMsg, RtcTimeChangedMsg, ActionExecutedMsg, ItemPropertiesChangedMsg, ExternalTimeoutMsg, PenUpMsg, PenDownMsg, InputCharMsg, LockedKeyMsg, LockedKeyDownMsg, FlipMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, PowerWakeupMsg, LanguageChangedMsg, ThemeChangedMsg, AppUpdateDisplayMsg, AppCloseMsg, AppOpenMsg, PowerOffMsg, PowerOnMsg, NoMessage, Window, TimeEditor, TimeCompoundItem, TextLine, TextCompoundItem, TextBox, TabControl, TabButton, RadioButtonControl, RadioButtonAction, PushButton, ProgressBar, PositionIndicator, PasswordEditor, Panel, NativeImage, MultiLineEditor, RedrawDisplayMsg, ItemRendererPropertiesChangedMsg, ImageEncodingProgressMsg, DeleteComponentMsg, ImageDrawingInterruptedMsg, Zi8EnteredUnknownWordMsg, Zi8AddWordMsg, Zi8NoWordFoundMsg, T9MatrixModeKeypressed, T9SymbolEntryRequestMsg, T9EnteredUnknownWordMsg, T9AddWordMsg, T9NoWordFoundMsg, AragonMsg, CloseWindowMsg, RefreshComponentMsg, ContextMenuClosedMsg, ViewfinderErrorMsg, ImageDecodingProgressMsg, InvalidateMsg, SelectionChangedMsg, FocusPreviousControlMsg, FocusNextControlMsg, MessageBox, LineEditor, ItemTree, ItemRendererProperties, ItemMenu, ItemGrid, ItemContainer, ItemBox, Item, IpAddrEditor, IpAddrCompoundItem, ImageBox, Image, GridLayout, FlowLayout, DrawableObject, DateEditor, DateCompoundItem, Control, ContextMenu, CompoundItem, Component, CheckBoxControl, CheckBoxAction, CharItem, AtomItem, AnimatedTextLine, Alert, Action, AbstractToggleAction, AbstractTextObject, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemGrid, AbstractItemContainer, AbstractGrid, AbstractEditor, AbstractButton, MmiSimServer, AudioGatiServer, RtcInfoMsg, TransportNotificationMsg, LedNotificationMsg, DisplayInfoMsg, BatteryLoadLevelMsg, ChargerInfoMsg, SsHandler, SoundItem, SmafSound, PreparedSound, MidiSound, IMelody, BtObexClientRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, BtObexClientNmaTransportDisconnect, BtObexClientNmaDataInidication, BtObexClientNmaDataBufferIndication, BtObexClientNmaHeaderIndication, BtObexClientNmaHeaderSent, BtObexServerNmaTransportDisconnect, BtObexServerNmaDataInidication, BtObexServerNmaDataBufferIndication, BtObexServerNmaHeaderIndication, BtObexServerNmaHeaderSent, BtObexServerNmaAbort, BtObexServerNmaPut, BtObexServerNmaGet, BtObexServerNmaSetPath, BtObexServerNmaDisconnect, BtObexServerNmaConnect, BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtObexClientAbortEvent, BtObexClientPutEvent, BtObexClientGetEvent, BtObexClientSetPathEvent, BtObexClientDisconnectEvent, BtObexClientConnectEvent, BtObexRegisterClientEvent, BtObexServerAbortIndicationEvent, BtObexServerPutIndicationEvent, BtObexServerGetIndicationEvent, BtObexServerSetPathIndicationEvent, BtObexServerDisconnectIndicationEvent, BtObexServerConnectIndicationEvent, BtObexRegisterServerEvent, BtObexTransportDisconnectEvent, BtObexDataIndicationEvent, BtObexDataBufferIndicationEvent, BtObexHeaderSentEvent, BtObexHeaderIndicationEvent, BtObexUnregisterEvent, BtHsRequestStateChangedMessage, BtHsNmaCallEvent, BtHsNmaLowPowerModeNotPossible, BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHsNmaAudioConnectionLost, BtHsNmaTransferAudioToPhone, BtHsNmaTransferAudioToAccessory, BtHsNmaDisconnect, BtHsNmaConnect, BtHsNotificationMessage, BtHsCmaCheckPendingAudioCallback, BtHsCmaAudioTransferOutOfCall, BtHsCmaEnterLowPowerMode, BtHsCmaAudioAsynchronous, BtHsCmaHangUp, BtHfRequestStateChangedMessage, BtHfNmaCallEvent, BtHfNmaLowPowerModeNotPossible, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain, BtHfNmaAudioConnectionLost, BtHfNmaTransferAudioToPhone, BtHfNmaTransferAudioToAccessory, BtHfNmaDisconnect, BtHfNmaConnect, BtHfNotificationMessage, BtHfCmaCheckPendingAudioCallback, BtHfCmaAtChldOneCommandReceived, BtHfCmaAudioAsynchronous, BtHfCmaMOC, BtHfCmaMTC, BtHfCmaPhoneNumberRequired, BtFaxRequestStateChangedMessage, BtFaxDisconnectMessage, BtFaxConnectMessage, BtFaxApplicationMessage, BtDunRequestStateChangedMessage, BtDunDisconnectMessage, BtDunConnectMessage, BtDunApplicationMessage, BtRequestStateChangedMessage, BtServiceMessage, BtSddbRequestStateChangedMessage, BtSddbUnregisterServiceEvent, BtSddbRegisterServiceEvent, BtRequestOperationMessage, BtCloseMessage, BtOpenMessage, BtRequestMessage, BtCancelVerifyMessage, BtServiceVerifyResultMessage, BtServiceVerifyMessage, BtPaSupportedProfileMessage, BtHfSupportedProfileMessage, BtHsSupportedProfileMessage, BtQuerySupportedProfilesMessage, BtDeviceUntrustMessage, BtDeviceTrustMessage, BtDeviceUnpairMessage, BtDevicePairMessage, BtSetRemoteDeviceNameMessage, BtCancelSearchMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtDeviceSearchMessage, BtRespondAuthorizationMessage, BtSendPasskeyMessage, BtProfileActivationMessage, BtConnectabilityMessage, BtPairabilityMessage, BtDiscoverabilityMessage, BtLocalNameMessage, BtLocalSettingsMessage, BtStateChangedMessage, BtGapAndSdapRequestMessage, BtRemoteDevicePairMessage, BtGapAndSdapNotificationMessage, BtAuthorizationRequiredMessage, BtPasskeyRequiredMessage, BtGapAndSdapRemoteRequestMessage, BtGapAndSdapApplicationMessage, BtApplicationMessage, BtBppRequestStateChangedMessage, BtBipProgressMsg, BtBipGetImagingCapabilitiesIndArg, BtBipGetLinkedAttachmentIndArg, BtBipGetLinkedThumbnailIndArg, BtBipGetImageIndArg, BtBipOpFinishedArg, BtBipGetImagePropertiesIndArg, BtBipGetImagesListIndArg, BtBipPutLinkedAttachmentCompleteArg, BtBipPutLinkedAttachmentIndArg, BtBipPutLinkedThumbnailCompleteArg, BtBipPutImageCompleteArg, BtBipAbortIndArg, BtBipDisconnectIndArg, BtBipConnectIndArg, BtAvrcpRequestStateChangedMessage, BtAvrcpNmaRawFrame, BtAvrcpNmaPanelPassThrough, BtAvrcpOperationServiceMessage, BtAvrcpNmaDisconnect, BtAvrcpNmaConnect, BtAvrcpNotificationMessage, AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStreamingSyncMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRadioDeviceNotificationMsg, AudioPlayTimeMsg, AudioMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioFmRadioRdsAlternativeFrequenciesMsg, AudioFmRadioRdsInfoMsg, AudioFmRadioRdsRadioTextMsg, AudioFmRadioRdsStationNameMsg, AudioFmRadioRdsRawDataMsg, AudioFmRadioRssiMsg, AudioFmRadioSeekMsg, AudioAccessoryConnectedMsg, AudioRecordingStoppedMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg, AudioErrorMsg, AudioDeviceStatusMsg, ValueMappingPropertyDescriptor< T_Container >, PropertyItem, PropertyDescriptor, Property, ListPropertyDescriptor, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow, AtlItemBox, TriggerKeyFeature, ProviderProxyItem, ProviderProxyContainer, IndicatorItem, FeatureItemContainer, FeatureItem, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, AtlWindow, DisabledFeatureTriggeredMsg, UpdateItemMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg, PropertyTriggerMsg, FeatureChangedMsg, UpdateContextItemMsg, CloseAllMsg, IndicatorBarUpdateMsg, UusHandler, UssdHandler, UssdBeginMsg, UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, UusQueryRejectedMsg, UusStatusMsg, GetPasswordMsg, UssdRequestResentMsg, UssdDataMsg, UssdEndMsg, UssdNotifyMsg, UssdRequestMsg, SsErrorMsg, CallBarringPasswordChangedMsg, ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, CnapInfoReceivedMsg, EctAlertingMsg, EctActiveMsg, MultiPartyCallInvokedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, CugCallMsg, HlrDataCorruptedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallIsWaitingMsg, CallRetrievedMsg, CallHeldMsg, CallForwardingActiveMsg, ClirNotSurpressedMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, CtmInfoIndMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, PbAlphaTagRequestMsg, PbEntryRequestMsg, PbSizeRequestMsg, CbsLimitMsg, SmsMessageWaitingChangedMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceAvailableMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsPortDataRecvMsg, SmsNewSocketDataMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, RatChangeModeChangedMsg, EngineeringModeControlResponseMsg, BandStatusMsg, GsmBandStateMsg, RatStateMsg, NwDiscStartIndMsg, HomezoneMsg, BandSelectionMsg, EngineeringReportMsg, UssdAnswerMsg, CcbsResultMsg, CcbsStatusMsg, CcbsRecallMsg, SsInfoMsg, SsFacilityRejectedMsg, UssdResentMsg, UssdIndicationMsg, PasswordRejectedMsg, PasswordInquiryMsg, SsErrIndicationMsg, SsRejectedMsg, SsEndMsg, SsSuccessMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, MocSetupRejectIndMsg, CallControlInfoMsg, RedialStatusMsg, DiagnosticIndMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, RedialStoppedMsg, RedialStartedMsg, CallNotifyMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfBufferCleanedMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, PowerModeIndMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, OmMultiSlotIndMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, SimTkProfileSetRejMsg, SimTkProfileSetCnfMsg, SimTkProfileGetCnfMsg, SimTkRefreshStartMsg, TermRspCnfMsg, SimTkSetupEventMsg, SimTkLanguageNotificationMsg, MptyHoldRejectedMsg, MptyOnHoldMsg, CallHoldRejectedMsg, CallOnHoldMsg, SimCallSetupRejectedMsg, SimEndTransactionMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimMenuItemSelectionFailedMsg, SimSetupMenuMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetDoneMsg, SimResetConfirmationMsg, SimRefreshResetMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, RegistrationAllowedMsg, PlmnScanFinishedMsg, RegistrationChangeMsg, RegistrationSuccessMsg, AccessoryIndMsg, SignalQualityLevelMsg, SignalStrengthLevelMsg, MinuteTickMsg, AlarmMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, LsaIdentityMsg, TimeZoneMsg, NetworkInformationMsg, SimErrorMsg, CfuStatusMsg, MptyCallReleaseMsg, CallReleaseMsg, CallAcceptMsg, ExternalPdpContextInfoMsg, GprsAttachStatusMsg, PdpContextActivationStatusMsg, ChvChangedMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg, CallEventMsg, GprsStatusMsg, SimLockStatusMsg, SimStateChangedMsg, SsMessage, SsCcbsHandler, SmsHandler, SimTkHandler, SimHandler, SigHandler, PowerHandler, PlmnHandler, NetworkHandler, MultiSlotHandler, MobileOriginatedUssdHandler, EmlppHandler, CrssHandler, ColrHandler, ColpHandler, CnapHandler, ClirHandler, ClipHandler, CbsHandler, CallWaitingHandler, CallHandler, CallForwardingHandler, CallDeflectionHandler, CallBarringHandler, BootHandler, AtcHandler, AocHandler, AccHandler, NoStackMsgArg, SsUus1QueryReqArg, SsUus1ReqArg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, SsUus1IndArg, SsUus1QueryRejArg, SsUus1QueryIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityRejArg, SsFacilityIndArg, SsBeginAccArg, SmsGetMoreMessageStatusReqArg, SmsSetMoreMessageReqArg, SmsSendReqArg, SmsConfigIndArg, SmsGetMoreMessageStatusIndArg, SmsCapacityAvailableArg, SmsCapacityExceededArg, SmsSendRejArg, SmsSendCnfArg, SmsNewStatusReportIndArg, SmsNewMessageIndArg, SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver, SimTkRefreshNewRspArg, SimTkStopSendDtmfReqArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, BrowserTermEventArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, BrowserRegisterReqArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, ExtProactiveCmdIndArg, LanguageSettingIndArg, LanguageSelectEventArg, IdleScreenAvailEventArg, UserActivityEventArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, MenuSelectionReqArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkRefreshNewReqArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, SimTkInterfaceIndArg, SimTkSendDtmfEndIndArg, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimBrowserTermResArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, TermRspCnfArg, ExtProactiveCmdCnfArg, ExtProactiveCmdReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, EndSimToolkitIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, MenuSelectionRejArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg, SimTkSsIndArg, SimTkSmsPpIndArg, SimTkCallSetupIndArg, SimModifyLockReqArg, BdnReqArg, FdnReqArg, SimMruPropertyUpdReqArg, SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadReqArg, SimODynReadReqArg, SimCmiReadReqArg, UsimFilePropertyReqArg, UsimLangUpdReqArg, UsimEstReadReqArg, UsimSmsParamUpdReqArg, UsimCardTypeReadReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimLangReadReqArg, UsimPsLociReadReqArg, UsimCsLociReadReqArg, UsimPlmnReadReqArg, UsimUstReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCfufUpdReqArg, CphsVmwfUpdReqArg, CphsOnsReadReqArg, CphsOnmReadReqArg, CphsCfufReadReqArg, CphsVmwfReadReqArg, CphsIstReadReqArg, SimFileInfoReqArg, SimSpnReadReqArg, SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg, SimGenericReqArg, SimPuctUpdReqArg, SimPuctReadReqArg, SimAcmMaxUpdReqArg, SimAcmMaxReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSstReadReqArg, SimRefreshReqArg, SimModifyLockIndArg, BdnIndArg, FdnIndArg, SimFullAccessIndArg, SimLockStatusIndArg, SimInfoIndArg, SimInitIndArg, SimMruPropertyRefreshIndArg, SimMruPropertyUpdCnfArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimUpdCnfArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimMccMncIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimGenericIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, SimRefreshIndArg, SimErrorIndArg, ControlHwDataOnlyArg, StopSignalStrengthListeningArg, StartSignalStrengthListeningArg, StopBatteryLoadListeningArg, ClientDeregistrationArg, ClientRegistrationArg, PowerDownReqArg, OmPowerUpArg, PowerDownIndArg, OmControlIndArg, PowerDownCnfArg, PlmnListReqArg, GprsClassReqArg, PlmnInfoReqArg, DetachReqArg, AttachReqArg, PrefServiceSetReqArg, PrefPlmnChangeArg, PlmnListAbortArg, GprsClassIndArg, AttachAllowedIndArg, DetachCnfArg, AttachRejArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListRejArg, PlmnListCnfArg, UsimPbReadCnfArg, UsimPbStopReqArg, UsimPbFillStatusReqArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, UsimPbSelectReqArg, UsimPbLocationReqArg, PbCountReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, PbInfoReadReqArg, UsimPbReadyIndArg, UsimPbUidRefreshIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg, UsimPbLocationIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, PbInfoReadIndArg, OmRatChangeReqArg, OmBandStatusReqArg, OmMultiSlotReqArg, OmRatChangeIndArg, OmRatChangeCnfArg, OmBandStatusCnfArg, OmMultiSlotIndArg, MnNetworkSearchModeReqArg, MnTriggerReqArg, HomezoneIndArg, BandSelectionIndArg, TestparamReportArg, MnInformationIndArg, CellInfoIndArg, ConnectionIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, ClearBlacklistReqArg, RediallingDisabledIndArg, RedialRejArg, MocSetupReqArg, ClearBlackListCnfArg, AutoCallRestrictIndArg, RedialStopIndArg, RedialSetupIndArg, RedialIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, MocSetupRejArg, EngineeringModeControlRequestArg, OmSetTermProfileReqArg, OmGetTermProfileReqArg, OmFactoryResetIndArg, BandSelectionReqArg, TestparamReqArg, ImeiReadReqArg, BootDispatchingArg, EccListIndArg, CfuDataIndArg, EngineeringModeControlResponseArg, OmSetTermProfileRejArg, OmSetTermProfileCnfArg, OmGetTermProfileCnfArg, AccessoryIndArg, ImeiReadIndArg, SignalStrengthLevelIndArg, ToStackMsg, FromStackMsg, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsConcRefNumReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsSetWaitingReqArg, MdhRemoveViewReqArg, MdhMakeViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSetStorageReqArg, MdhSmsUpdStatusReqArg, MdhSmsStatusReqArg, MdhRegistrationReqArg, MdhDeregistrationReqArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsConcRefNumIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg, MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsStorageRefreshIndArg, MdhSmsRefreshIndArg, MdhNewStatusReportIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg, IconDescReadReqArg, ImageReadReqArg, IconDescReadIndArg, ImageReadIndArg, ChargeUnitsReqArg, SetChargeUnitsArg, ChargeReqArg, SetAutoChargeArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, CallDeflectSsReqArg, CallDeflectionIndArg, CbsStopReqArg, CbsStartReqArg, CbsNewDataRejArg, CbsLimitIndArg, CbsStopCnfArg, CbsStartCnfArg, CbsStopRejArg, CbsStartRejArg, CbsNewDataIndArg, RedialQueryReqArg, RejectCallsIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, MocSetupRejIndArg, CallIndCallControlInfoArg, RedialStatusIndArg, CallSetupBySimtTkReqArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, DtmfBufferClearedIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg, AtAccessoryRegisterCnfArg, AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtPbInfoIndArg, AtPbListCnfArg, AtPbSelectCnfArg, AtAlphaTagCnfArg, AtAccessoryRegisterReqArg, AtGenericCmdReqArg, AtPbListReqArg, AtPbSelectReqArg, AtAlphaTagReqArg, RfsStorageDeviceRegistrationStatusMsg, RfsMediaAvailableStatusMsg, FileChunkOperationProgressMsg, RegNotifyMsg, VrPropertyResultIndArg, VrWarningIndArg, VrErrorIndArg, VrG2AResultIndArg, VrStoreTemplateReqArg, VrStopRecogIndArg, VrAbortEngineIndArg, VrTrainResultIndArg, VrRecogResultIndArg, VrIntrmRecResultIndArg, VrSayNameIndArg, VrLoadTemplateReqArg, VrInitCnfArg, VrParamReqArg, VrHandler, VrRecognitionFailedMsg, VrTrainingFailedMsg, VrPlaybackFinishedMsg, VrTrainingResultMsg, VrRecognitionStoppedMsg, VrTrainingAbortedMsg, VrRecognitionAbortedMsg, VrWarningMsg, VrErrorMsg, VrResultMsg, VrPromptMsg, DBItemChangedMsg, SvgImage, SvgHyperlinkSelectMsg, SvgStatusMsg, SvgDecodingFinishedMsg, HttpDisconnectMessage, HttpConnectMessage, HttpRequestMessage, HttpErrorMessage, HttpServiceMessage, FtpDisconnectMessage, FtpConnectMessage, FtpRequestMessage, FtpTransferMessage, FtpErrorMessage, FtpServiceMessage, WbmpImage, VCardItem, RichTextCompoundItem, PngImage, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditor, JpegImage, ImageItem, GifImage, GeneralCompoundItem, BoundedItem, BmpImage, AudioItem, SerialTerminalArg, MmCallReleaseMsg, MmCallAcceptMsg, MmAocChargingStatusMsg, MmCurrentCallMeterMsg, MmCurrentChargeDataMsg, MmCallNotifyMsg, MmCallInfoMsg, MmCallSetupProgressMsg, MmMocSetupAcceptMsg, MmCallDisconnectingMsg, MmCallStatusMsg, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg, SaLocationErrArg, SaMolrResultArg, CloseDataConnMsg, GltpConnStatusMsg, SendRequestMsg, SetupDataConnMsg, MeasurementDataArg, ProcessMolrMsg, ProviderChangedMsg, AbortResMsg, LocationErrMsg, LocationResMsg, LocationNotifInvokeMsg, AbortResArg, LcsMolrResultArg, LocationNotifInvokeArg, AppActionExecutedMsg, AccessorActionExtension, DrmWapPushMsg, FatFsUsbMassStorageReleaseMsg, FatFsUsbMassStorageRequestMsg, UsimPbResetedMsg, UsimPbReadyMsg, DataControlPhonebookStateMsg, DataControlEndBootMsg, DataControlBootMsg, DataControlBootProgressMsg, DataControlStartBootMsg, DataControlModificationMsg
  • id_offset : Mp3Param
  • Identifier : FeatureItemContainer, InformationElement
  • identifier_valid : TAlphaIdentifier_s
  • Idle : PdpContextManager
  • idle_subscriber_no : CcbsEntry
  • IdleScreenAvailEventArg() : IdleScreenAvailEventArg
  • IdleState : Camera
  • idxPos : SmsTextEntry
  • IeNonExistent : PdpContext, Sms
  • IFrame : VideoEncoder
  • IFX_MAPI() : AudioMapiManager
  • ignorableWhitespace() : WbxmlParserRel
  • IgnoreDuplicates() : Cbs::Filter
  • IgnoreUnavailableFeatures() : FeatureItemContainer
  • IllegalDirOperationError : File
  • IllegalEquipment : SsErrorCode
  • IllegalIdError : File
  • IllegalMe : PdpContext
  • IllegalModeError : File
  • IllegalMs : PdpContext
  • IllegalSsOperation : SsErrorCode
  • IllegalSubscriber : SsErrorCode
  • IllegalTypeError : File
  • IllegalUserIdError : File
  • IllegalZoomLevel : SvgPlayer
  • IlluminationMode : Keyboard
  • IlluminationModeAuto : Keyboard
  • IlluminationModeOff : Keyboard
  • IlluminationModeOn : Keyboard
  • Ilrr : AtResponse
  • Image() : Image
  • ImageBox() : ImageBox
  • ImageBoxClassType : GuiObjectFactory
  • ImageBoxView : ImageBox
  • ImageBrowserApp : MediaRefContainer
  • ImageBrowserDeleteImageMsg() : ImageBrowserDeleteImageMsg
  • ImageBrowserDetailWin() : ImageBrowserDetailWin
  • ImageBrowserRenameImageMsg() : ImageBrowserRenameImageMsg
  • ImageBrowserServiceMsg() : ImageBrowserServiceMsg
  • ImageBrowserTestWin() : ImageBrowserTestWin
  • ImageBrowserWin() : ImageBrowserWin
  • ImageCapturingState : Camera
  • ImageDecoder() : ImageDecoder
  • ImageDecodingProgressMsg() : ImageDecodingProgressMsg
  • ImageDrawingInterruptedMsg() : ImageDrawingInterruptedMsg
  • ImageEncoder() : ImageEncoder
  • ImageEncodingProgressMsg() : ImageEncodingProgressMsg
  • ImageFileFilter() : ImageFileFilter
  • ImageFilter() : ImageFilter
  • ImageFormatType : CamWin32
  • ImageIncrementalPdcUpdater() : ImageIncrementalPdcUpdater
  • ImageItem() : ImageItem
  • ImageList : BtBipImageList
  • ImageListBoxModel() : ImageListBoxModel
  • ImageListBoxView() : ImageListBoxView
  • ImageMetaData() : ImageMetaData
  • ImageMetaDataRecord() : ImageMetaDataRecord
  • ImageObtainer() : ImageObtainer
  • ImageObtainerClassType : GuiObjectFactory
  • ImageReadIndArg() : ImageReadIndArg
  • ImageReadReqArg() : ImageReadReqArg
  • ImageRef() : ImageRef
  • ImageRefContainer() : ImageRefContainer
  • ImageRefGenContainer() : ImageRefGenContainer
  • ImageSizeType : CamWin32, Camera
  • ImageUriProp : GuiObjectFactory
  • ImageView() : ImageView
  • ImageViewListBoxModel() : ImageViewListBoxModel
  • ImeiReadIndArg() : ImeiReadIndArg
  • ImeiReadReqArg() : ImeiReadReqArg
  • ImeiShowAction() : ImeiShowAction
  • IMelody() : IMelody
  • ImgObtObj() : ImgObtObj
  • ImmediateAlphaBlending : DeviceContext
  • ImmediateDecodingFlag : VideoDecoder
  • Implicit : ProtocolIdentifier
  • In : PhoneNumber
  • in_use : EmlppPriority
  • InAccept : MmCallInfo
  • InactiveFrameBackground : Color
  • InactiveFrameBackgroundColor : CTResourcePack
  • InactiveFrameForeground : Color
  • InactiveFrameForegroundColor : CTResourcePack
  • InactiveTitle : Font
  • InactiveTitleBarBitmap : CTResourcePack
  • InactiveTitleBarBitmapUri : CTResourcePack
  • InactiveTitleBarHeight : CTResourcePack
  • InactiveWindowFrameControl : CTResourcePack
  • InactiveWindowTitle : Color
  • InactiveWindowTitleBarControl : CTResourcePack
  • Inbox : SmsSettingsRecord
  • inbox_ascending_order : SmsSettingsRecord::Persist
  • inbox_sorting_colid : SmsSettingsRecord::Persist
  • InCall : MmCallInfo
  • IncandescentBalance : Camera
  • IncBarrServices : InputParser
  • Include() : ObexTransportSet
  • IncomingCallForwardedMsg() : IncomingCallForwardedMsg
  • IncompatibleDestination : ShortMessageStatus
  • Incomplete3gppFile : MediaManager
  • InconsistentMemTablesError : File
  • Increase : Camera
  • IncreasePriority() : Thread
  • IncRefCount() : WStrData, StrData, ProviderPtr
  • Increment() : SimpleMap< TKey, TValue >::Iterator, StorageDeviceIterator, DirectoryIterator, RootDirectoryIteratorImp
  • IncrementalPdcUpdater() : IncrementalPdcUpdater
  • IncrementCell() : GridModel
  • IncrementDelBufCount() : RegDeletionBufferEntry
  • IncrementOpenFileCounter() : StorageDevice
  • IncrementRefCount() : DrmAsset
  • IncrementRegCount() : ApplicationListEntry
  • ind : SsGroup
  • index : CugDescriptor
  • index_table : tagFont
  • IndexOf() : WString, String
  • IndexTable() : IndexTable< T >
  • IndicateAlphaMaskUpdate() : Display
  • IndicateItemContainer() : ItemRendererProperties
  • IndicateItemContProp : GuiObjectFactory
  • IndicateSelectionChanged() : AbstractListBox
  • indication : FsRegistrationInfo, fs_registered_info_type
  • Indication : SmsIndicationState
  • Indicator() : Indicator
  • IndicatorAlignment : Indicator
  • IndicatorBar() : IndicatorBar
  • IndicatorBarOrientation : IndicatorBarView
  • IndicatorBarPaneObject() : IndicatorBarPaneObject
  • IndicatorBarUpdateMsg() : IndicatorBarUpdateMsg
  • IndicatorBarView : IndicatorBarView, IndicatorBar
  • IndicatorDescription() : IndicatorDescription
  • IndicatorItem() : IndicatorItem
  • IndicatorItemClassType : GuiObjectFactory
  • IndicatorLocation() : IndicatorLocation
  • IndicatorPaneObject() : IndicatorPaneObject
  • IndicatorPosition : Indicator
  • Indonesian : LanguageManager
  • InetSocket : InetSocket, SocketSubSystem, SocketData
  • InetSocketAddr() : InetSocketAddr
  • Infinite() : Ticks
  • info : MmfPlayer::MediaPlayerInstanceData
  • Info : Display
  • InfoDialog() : InfoDialog
  • InformationElement() : InformationElement
  • Init() : VoiceMemoWin, VoiceMemoRecordWin, VoiceMemoMenuAccessor, UsbApp, UibUpdateThreadlet, UibTest2, UibTest1, UibSortingTest, UibSettingsTest, UibPerformanceTest, UibNotifyTest, UibMsgDisplayTest, UibInboxTest, UibAccessorTest, UibSettingsWin, UibSettingsProvider, UibServiceImpl, UibListBoxModel, UibFolderWin, ToDoProvider, ToDoListWin, ToDoPriorityDialogWin, ToDoDateDialogWin, ToDoComposeWin, SoundBrowserWin, SoundBrowserTestWin, RenameFileDialog, MetaData, MediaRefContainer, InfoDialog, FileNameView, FileNameListBoxModel, BrowserViewContainer, BrowserView, BrowserSaveWin, AmrSound, SocketTestWin, SocketTestSettingsWin, SocketTestResultsWin, SocketTestProgressWin, SocketTestApp, IpAddrPrompt, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsTestDispWin, FfsMenu, RegAppWin, RegAppFirstWin, RegApp, ObexTransportWin, ObexApp, ServerAddressWin, SelfLocationDialog, GltpAidingDataWin, LcsSocket, TransferLocationDialog, SatteliteInfoWin, SatteliteGraphWin, ResultWinBase, LocResController, LocationVerifWin, LocationResultWin, LcsOptionsMenuWin, LcsMainMenuWin, IrdaWin, SavingProgressWin, ImageViewListBoxModel, ImageView, ImageListBoxView, ImageMetaData, ImageListBoxModel, ImageBrowserWin, ImageBrowserTestWin, ImageBrowserDetailWin, RenameFileDialog, MetaData, MediaRefContainer, InfoDialog, FileNameView, FileNameListBoxModel, BrowserViewContainer, BrowserView, BrowserSaveWin, FmRadioWindow, FmRadioStationsProvider, FmRadioSettingsProvider, FmRadioSelectStrongerFreq, FmRadioEditWin, SmsViewerWin, SmsUtility, SmsTemplateProvider, SmsSettingsProvider, SmsSendingConfirmDialog, SmsFolderProvider, SmsEditor, SmsComposeWin, SmsBasicProvider, SmsInfoBox, SmsAlert, AbstractSmsViewerWin, AbstractSmsComposeWin, EmsViewerWin, EmsInsertPrompt, EmsInsertPromptListBoxModel, EmsEditor, EmsComposeWin, NumberPrompt, IpAddrPrompt, DataConnWin, DataConnLbModel, DataConnTypeWin, DataConnOptionWin, SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor, CameraViewFinderWin, CameraSettingsWin, CameraSettings, CameraOptionSettingsWin, CameraCaptureWin, CalendarRecordsListBoxModel, CalendarRecordsList, CalendarRecord, CalendarProvider, CalendarMonthWin, CalendarMonthSelector, CalendarListWin, CalendarGrid, CalendarGotoDateWin, CalendarDialogWin, CalendarAddRecordWin, BtDeviceSearchModeWindow, BtTurnOnOffWindow, BtHsVolumeSettingsWin, BtHsInbandSettingWin, BtHsConnectionSettingWin, BtHsAppPlugin, BtHfVolumeSettingsWin, BtHfProvider, BtHfProfileWindow, BtHfFeatureListWin, BtHfInbandSettingWin, BtHfAudioPathWindow, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, BtDeviceListWindow, BtDeviceDetailWindow, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtRequestRunningWindow, BtAlertMessageWindow, BtActiveDeviceWindow, BtAvrcpPanelServiceImpl, BtAvrcpDeviceListWin, BtAvrcpControllerDeviceListWindow, BtAvrcpControllerApplicationWindow, BtAvrcpAlertMessageWindow, UpdatePbThreadlet, SyncPhoneThreadlet, ProvDetailListBoxWin, ProvColListBoxWin, PhonebookWin, PbSynchronizer, PbSimProvider, PbSelectNumberWin, PbSelectNoType, PbSelectGroup, PbRecordProvider, PbRecordHandler, PbProvColListBox, PbProvListBox, PbProvColListBoxModel, PbPhoneNumberPrompt, PbNvRamNumberHandler, PbNvRamNameHandler, PbNumberProvider, PbNameProvider, PbNameNumberProvider, PbNameHandler, PbNameEditBox, PbMergeProvider, PbManualSynchronizer, PbFfsNumberHandler, PbFfsNameHandler, PbDetails, PbDetailListBox, PbDetailListBoxModel, PbNumberFilterProvider, PbDetailProvider, PbDataHandler, PbBaseWin, SearchBox, PbAdvDetails, PbAdvDataHandler, PbAdvAddEditEntry, PbDetailAction, PbToggleAction, PbAction, PbAbstractWin, GroupProvider, PbCopyHandler, CopyHandler, BasicPbWin, AdvPbWin, PbAdvDetailAction, AdvPbAction, SysSocket, SysDnsClient, SysSocket, SocketRxThread, SocketHandler, DnsClient, DataConn, ObexAbstractTransport, ObexServerDispatcher, ObexServer, ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexObject, ObexFtpServer, ObexFtpDataServer, ObexDispatcher, ObexDataServer, ObexClientDispatcher, Timer, System, Trap, SystemTimer, Trap, SystemTimer, IsrDataManager, InternalTracer, MessageRouter, MessageMapDispatcher, MessageMapContainer< T >, ExternalCommunicationHandler, TimeoutCondition, BooleanCondition, ActiveWaitDispatcher, Window, ToggleActionGroup, TimeEditorDocument, TimeEditor, TextPackConnector, TextLine, TextLineView, TextFormat, TextEditorDocument, TextBox, TabControl, TabButton, RadioButtonGroup, RadioButtonControl, RadioButtonAction, PushButton, ProgressBar, PositionIndicator, PasswordEditor, OpenWindowAction, OpenContextMenuAction, NativeImage, MultiLineEditor, Model, MessageBox, LineEditor, ItemTree, ItemMenu, ItemGrid, ItemContainer, ItemBox, Item, IpAddrEditorDocument, IpAddrEditor, ImageBox, IncrementalPdcUpdater, GridLayout, PaneObject, FontPackConnector, FlowLayout, FilePackConnector, DrawableObject, DisplayDc, DeviceContext, DateEditorDocument, DateEditor, ControlDc, Control, Component, CloseWindowAction, CheckBoxControl, CheckBoxAction, BitmapDc, BasicPackConnector, AnimatedTextLine, Alert, Action, AbstractToggleAction, AbstractTextObject, AbstractMultiLineEditor, AbstractLineEditor, AbstractLineEditorView, AbstractItemGrid, AbstractItemContainer, AbstractGrid, AbstractEditor, AbstractButton, VoiceMemoAudioDevice, VirtualDisplay, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice, GenericAudioDevice, CamWin32, AmplifierAudioDevice, VirtualDisplay, BackLight, VirtualDisplay, EmzUtils::Queue< T >, BackLight, VirtualDisplay, EmzUtils::Queue< T >, BackLight, VirtualDisplay, WinRect, WinMenuItem, TimeEditBox, TextMenuAccessor, TextList, SoftkeyBar, SmafSound, SharedTriggerTimer< T >, SharedTimer, SetThemeAction, SetLanguageAction, RadioButtonList, ProviderListBox, ProviderListBoxModel, PreparedSound, NvRamDataRecordHandler, MidiSound, MenuTextPtrArrayIterator, MenuList, MenuItem, MenuAccessor, Menu, Melody, IndicatorBarPaneObject, IndicatorPaneObject, IndicatorDescription, IndicatorBar, Indicator, IMelody, Grid, GridModel, EditBox, Audio, DateEditBox, ConfirmAction, CheckBoxList, CheckBox, CancelAction, AtlItemGrid, Animation, AnimationBmpPointerArrayIterator, AnimationBmpArrayIterator, AbstractMenuListModel< Item >, AbstractMenuAccessor, AbstractListBoxView, AbstractListBox, AbstractListBoxModel, AbstractEditBox, AbstractEditBoxModel, BtObexTransport, BtHsService, BtHfService, BtController, BtConnectionlessController, BtConnectionBasedController, BtAvrcpService, TriggerTimer< T >, ThreadSafeProvider, SortProvider, QuickSortProvider, Protector, MainProvider, FindProvider, Find2Provider, FilterRule, FilterProvider, DrmInfo, DistinctProvider, CachingSortProvider, BubbleSortProvider, AbstractDelegationProvider, ValueMappingPropertyDescriptor< T_Container >, TextIconPairArray, SubstitutedText, PropertyItem, PropertyEditor, PropertyDescriptor, Property, PhoneNumberMatchRule, InputMapperFactory, ItemLabel, AtlLabelListWindow, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow, AtlItemBox, TriggerKeyFeature, ProviderProxyItem, ProviderProxyContainer, IndicatorItem, FeatureItemContainer, FeatureItem, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, MenuDesc, ContextDescription, AtlWindow, AtlApplicationPlugin, SsEmlppActionImpl, SsUssdActionImpl, SsCnapActionImpl, SsColpActionImpl, SsColrActionImpl, SsClipActionImpl, SsClirActionImpl, SsCallWaitingActionImpl, SsCallForwardingActionImpl, SsCallBarringActionImpl, SsPasswordChangeActionImpl, StackMsgDispatcher, StackMsgActiveWaitDispatcher, SmsSocket, SmsFactory, PdpContextManager, MainHandler, InputAnalyzer, HandlerListEntry, ExtPsdContextListener_SioGlueSignalListener, DataCallHdl, CbsFilterList::CbsFilterListEntry, UserData, UserDataHeader, StackMsgArgMapContainer< T >, StackInterface, Sms, StackTranslator, StackMsgProcessor, SignalHandler, ProcessNode, PlmnListEntry, Plmn, BcdPlmn, UriMappingTable, Pathname, RegNodeBuffer, RegMemoryPool, RegDeletionBufferEntry, DirtyFileHandler, Zi8Wrapper, Zi8StrokeBox, Zi8StrokeBoxView, Zi8SelectionBox, Zi8SelectionBoxView, Zi8PredictiveInputBox, Zi8AlphabetBox, Zi8AlphabetBoxView, UsbObexTransport, T9PredictiveInputBox, T9PinyinBox, T9PinyinBoxView, T9PackConnector, StrokeBox, StrokeBoxView, SelectionBox, SelectionBoxView, ChineseT9Wrapper, SvgPlayer, SvgImage, StreamObexTransport, StreamObexImpl, SioSocketAdapter, ServicePtr< T >, Server, HttpServer, HttpApplication, FtpServer, SerialSocketThread, SerialIoSet, RfsObexFtpServer, WbmpImage, PngImage, MultiMediaEditor, JpegImage, GifImage, BmpImage, SioGlueSignalListener, MediaInfo::ClipInfo, MediaBox, SaProviderImpl, GltpProviderImpl, LcsTimer, LcsRepeatTimer, LcsProviderImplBase, LcsProviderImpl, WapProfileMgr, TopLevelMenu, SubMenuAction, ApplicationAction, ActionMenuAccessor, AccessorAction, AbstractActionMenuAccessor, AbstractPredictiveInputBox, PhoneNumberMergeProvider, MergeProvider, StandardJoinRule, JoinProvider, DualFilterProvider, AppendProvider, RecordHandler, SimServices, SstProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SimPduHandler, TpduHeaderInformation, SmsWStringCache, SimPbBaseHandler, SimAccessor, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, LockProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, BaseDataHandler, AuxProvider
  • InitalizedState : MediaRecorder
  • InitAvrcpOperationService() : SubUnitReference
  • InitChvData() : SimChvHandler
  • InitCompletionMsg : MediaManager
  • InitContext() : SwitchedRleCompression
  • InitData() : Tpdu
  • InitDataOffset() : StreamAudioReference
  • InitDecoderLib() : PngDecoder
  • InitEmsColors() : EmsResourceMaps
  • InitFile() : PbNumberHandler
  • InitFrom() : IpAddr
  • InitGetTotalPlayTimeWaitCondition() : AudioReference
  • InitializationError : Image, SvgPlayer
  • Initialize() : HeapVector::VarPage, HeapVector::BlockPage, HeapManager, RamHandler, SimPbBaseHandler
  • InitializedState : MediaPlayer
  • InitializeFunction : HeapVector
  • InitializeKey() : DrmSecurity
  • InitializingError : File
  • Initiate() : ObexOppClientPull, ObexOppClientPush, ObexOppClientOperation
  • InitiateCall() : AbstractSmsApp
  • InitiateFirmwareUpdate() : Fota
  • InitiatingRelease : TaggedProblemCode
  • InitIndexTable() : MergeProvider
  • InitLanguage() : System
  • InitMenus() : MenuPool
  • InitMexe() : SimAuxHandler, DataHandler
  • InitMruDynflags() : SimCphsHandler
  • InitPixelColorAccess() : PngDecoder
  • InitPlugins() : AtlApplicationPluginStartup
  • InitProperties() : CTResourcePack
  • InitRecord() : PbRecordProvider, PbNumberProvider, PbNameProvider
  • InitResponse() : ObexDataServer
  • InitRightsObjectMapTable() : DrmRightsObjectStore
  • InitSmsCommand() : SmsFactory
  • InitSmsSubmit() : SmsFactory
  • InitSmsTransmit() : SimPduHandler
  • InitSocket() : RegAppWin
  • InitSpeech() : Audio
  • InitVr() : VrHandler
  • Injective : JoinRule
  • Inkey() : SimTkHandler
  • InnerBorderColor : CTResourcePack
  • InPlmnOperatorAssociationsRange : MessageIdentifier
  • InPlmnOperatorSpecificForFutureVersionsRange : MessageIdentifier
  • InPlmnOperatorSpecificRange : MessageIdentifier
  • InProcess : KeyMsgGenerator::Key
  • InProgress : AudioReference, SocketTestT, Image
  • Input() : SimTkHandler
  • InputAction() : InputAction
  • InputActionList() : InputActionList
  • InputActionPtr() : InputActionPtr
  • InputAnalyzer() : InputAnalyzer
  • InputChar : Keyboard
  • InputCharMsg() : InputCharMsg
  • InputCharType : InputMapItem
  • InputContext() : InputContext
  • InputMapItem() : InputMapItem
  • InputMapper() : InputMapper
  • InputMapperFactory() : InputMapperFactory
  • InputMapperIdProp : GuiObjectFactory
  • InputMapperIdType : GuiObjectFactory
  • InputParser() : InputParser
  • InputStream() : InputStream
  • InReject : MmCallInfo
  • InRelease : MmCallInfo
  • InReservedForFutureVersionsRange : MessageIdentifier
  • InSecureCellBroadcastDataDownloadRange : MessageIdentifier
  • Insert : WindowManager, TextCompoundItem, BtSddbServiceRecord, BtSddbDeContainer, BtDeviceList, WString, Vector< T >, String, SortedLinkedList< T >, LinkedListBase, SortedElementList< T >, Caret, Provider
  • insert() : WbxmlVector< T >
  • InsertAction() : UibActionAccessor, ActionMenuAccessor
  • InsertBlobRecord() : UriMappingTable
  • InsertChar() : AbstractEditBox, AbstractEditBoxModel
  • InsertCompoundItem() : EmsEditor, EditorDocument, AbstractEditor, ParagraphCompoundItem, MultiMediaEditorDocument
  • InsertCompoundItemBeforeItem() : EditorDocument, AbstractEditor, ParagraphCompoundItem, MultiMediaEditorDocument
  • InsertConnection() : BtMultiConnectionController
  • InsertedItem : InputMapper
  • InsertEqualNode() : RamFileNode
  • InsertExtLanguage() : SimAuxHandler
  • InsertImage() : EmsComposeWin
  • InsertImageType : EmsInsertPrompt
  • InsertItem() : SmsEditor, EmsEditor, TimeEditorDocument, TextEditorDocument, TextCompoundItem, PasswordEditor, ItemContainer, EditorDocument, DateEditorDocument, CompoundItem, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemContainer, AbstractEditor, ProviderProxyContainer, FeatureItemContainer, ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor, GeneralCompoundItem
  • InsertKeyFrame() : EmzMpeg4Encoder, AtiMpeg4Encoder, VideoEncoder
  • InsertLanguage() : SimAuxHandler
  • InsertNode() : RamFileSystem
  • InsertPlmn() : SimAuxHandler
  • InsertPlmnwAct() : SimAuxHandler
  • InsertRow() : SortProvider, Provider, FilterProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider
  • InsertSound() : EmsComposeWin
  • InsertSoundType : EmsInsertPrompt
  • InsertSubNode() : RamFileNode
  • InsertTab() : TabControl
  • InsertText() : SmsComposeWin, AbstractSmsComposeWin, MultiMediaEditorDocument::TextManager
  • InsertURIRecord() : UriMappingTable
  • InService : Led
  • InSetup : MmCallInfo
  • InsideDefaultSelectMedia : MediaPlayer
  • Instance() : DrmROStoreSingleton
  • InsufficientRessources : PdpContext
  • Int : InternalTracer
  • IntegerNodeType : RegIterator
  • IntegerParseType : CTResourcePack
  • IntegerType : GuiObjectFactory
  • InteriorType : RegIterator
  • internal_fa : FileInfo_s
  • InternalError : File
  • InternalEvent() : StateMachine
  • internalStatus : SocketTestT
  • InternalTracer() : InternalTracer
  • InternationalNumber : TypeOfAddress
  • InternetElectronicMail : ProtocolIdentifier
  • InterrogateClip() : SsHandler
  • InterrogateClir() : SsHandler
  • InterrogateColp() : SsHandler
  • InterrogateColr() : SsHandler
  • Interrogation : InputParser
  • InterrogationResultMsg() : InterrogationResultMsg
  • InterruptScan() : PlmnHandler
  • Intersect() : Rect
  • Intersects() : DynamicBitVector
  • interval : AudioToneDuration
  • Interworking : ProtocolIdentifier, Sms
  • InUnsecureCellBroadcastDataDownloadRange : MessageIdentifier
  • Invalid : ResultWinBase, ObexHeader, Image, PhoneNumber, PinAction, CallSsAction, KeyMsgGenerator::Key, BaseInformationElement, WapProfile
  • Invalid3gppFile : MediaManager
  • invalid_glyph : FontRes
  • InvalidAlphabet : DataCodingScheme
  • Invalidate() : CalendarGrid, ObexOperationId, ObexChannel, PaneObject, DrawableObject, Control, FeatureItemContainer, MptyCallHdl, CallHdlBase, CallHdl, MmCallInfo, MmCallHdl
  • InvalidateClient() : Control
  • InvalidateCursor() : AbstractEditBox
  • InvalidateIcon() : ProviderProxyItem
  • InvalidateMsg() : InvalidateMsg
  • InvalidateSelectedItem() : AbstractListBox
  • InvalidateSockets() : DataConn
  • InvalidateText() : AbstractEditBox, ProviderProxyItem
  • InvalidAudioTrack : MediaManager
  • InvalidCameraParameter : Camera
  • InvalidCause : AudioDeviceBase
  • InvalidClass : DataCodingScheme
  • InvalidCode : TaggedProblemCode
  • InvalidCommand : VrHandler
  • InvalidConnectionElement : DataCallContext
  • InvalidDst : TimeZone
  • InvalidErrorValue : ShortMessageFailureCause
  • InvalidExecutionContext : ObexResult
  • InvalidFileNameError : File
  • InvalidFormatErrorType : AudioDeviceBase
  • InvalidFrameSize : CodecDevice
  • InvalidGroup : ProtocolIdentifier, DataCodingScheme
  • InvalidHandlerType : ExternalCommunicationHandler
  • InvalidHeaderId : ObexResult
  • InvalidHeadersInRequest : ObexResult
  • InvalidId : SimItemId
  • InvalidIdentifier : InformationElement
  • InvalidInterworking : ProtocolIdentifier
  • InvalidItem : EditorItemNode
  • InvalidLanguage : DataCodingScheme
  • InvalidLanguageGroup : DataCodingScheme
  • InvalidMandatoryIe : PdpContext
  • InvalidMandatoryInfo : Sms
  • InvalidMessage : DataCodingScheme
  • InvalidMessageType : ProtocolIdentifier
  • InvalidMethod : WapProfile
  • InvalidMp3File : MediaManager
  • InvalidNumberingPlan : TypeOfAddress
  • InvalidOffset : TimeZone
  • InvalidParameter : MediaManager, CodecDevice
  • InvalidParameterInUrl : ObexResult
  • InvalidPid : ProtocolIdentifier
  • InvalidProcedure : InputParser
  • InvalidReason : AudioPlayerEvent, ShortMessageStatus
  • InvalidReferenceValue : Sms
  • InvalidRequest : RegEncoderDecoder
  • InvalidRfCommPortNumber : BtObexServerAddr
  • InvalidScope : Cbs::SerialNumber
  • InvalidService : WapProfile
  • InvalidServiceGroup : InputParser
  • InvalidSizeError : Image, Camera
  • InvalidSmeAddress : ShortMessageFailureCause
  • InvalidSoundDataSource : AudioReference
  • InvalidSsCode : InputParser
  • InvalidState : MediaManager, CodecDevice
  • InvalidStatus : ShortMessageStatus
  • InvalidStoreLocation : Sms
  • InvalidTag : TaggedProblemCode
  • InvalidTelematicDevice : ProtocolIdentifier
  • InvalidText() : ValueTextMap
  • InvalidTextCompression : DataCodingScheme
  • InvalidTi : PdpContext
  • InvalidType : MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType
  • InvalidTypeOfAddress : TypeOfAddress
  • InvalidTypeOfNumber : TypeOfAddress
  • InvalidUsage : ProtocolIdentifier, MessageTypeIndicator
  • InvalidValue : ValueTextMap, ReferenceLocation
  • InvalidVideoTrack : MediaManager
  • InvertCursor() : AbstractEditBox
  • Inverted : Cbs::Filter
  • InvertedSelection : AbstractEditor
  • InvertRect() : DeviceContext
  • InvertRop : DeviceContext
  • Invoke : TaggedProblemCode
  • InvokeAt() : SocketSubSystem, SubSystem, GenericWorkerTask, IrdaObexSubSystem, GatiManager, BtObexSubSystem, BtController, AudioPresetStore, StackControl, KeyMsgGenerator, RegManager, UsbSubSystem, SerialSocketSubSystem, DrmSubsystem, DataControl
  • InvokeId() : InvokeId
  • InvokePhonebook() : PhonebookApp
  • IoCtl() : SerialSocket, SerialIoAdapter
  • IOError : File
  • ip_type : SiIpAddress_s
  • IpAddr() : IpAddr
  • IpAddrCompoundItem() : IpAddrCompoundItem
  • IpAddrEditor() : IpAddrEditor
  • IpAddrEditorClassType : GuiObjectFactory
  • IpAddrEditorDocument() : IpAddrEditorDocument
  • IpAddress : InputMapper
  • IpAddrInputMapper() : IpAddrInputMapper
  • IpAddrPrompt() : IpAddrPrompt
  • IpAddrProp : GuiObjectFactory
  • IpAddrType : GuiObjectFactory
  • IpDynamicType : PdpContext
  • IpPortNo() : IpPortNo
  • IpStaticType : PdpContext
  • IpType : PdpContext
  • IPv4 : WapProfile
  • ipv4_address : WapProfile::Ipv4E164
  • ir_bind_was_succesful : IrConnection
  • ir_cr_attempt : MmCellChangeCnts
  • ir_cr_cnt_at : CellChangeCnts
  • ir_cr_cnt_su : CellChangeCnts
  • ir_cr_success : MmCellChangeCnts
  • ir_discoverreq_in_progress : IrdaObexTransport
  • ir_ho_attempt : MmCellChangeCnts
  • ir_ho_success : MmCellChangeCnts
  • ir_hocc_cnt_at : CellChangeCnts
  • ir_hocc_cnt_su : CellChangeCnts
  • IrComm : IrdaTransport
  • irconnections : IrdaObexTransport
  • IrdaObexClientAddr() : IrdaObexClientAddr
  • IrdaObexImpl() : IrdaObexImpl
  • IrdaObexServerAddr() : IrdaObexServerAddr
  • IrdaObexTransport() : IrdaObexTransport
  • IrdaParams : SioSocketAdapter
  • IrdaSwitchOffTimeout : IrdaTransport
  • IrdaTransport() : IrdaTransport
  • IrdaWin() : IrdaWin
  • Irish : LanguageManager
  • IrLap : IrdaTransport
  • IrLmp : IrdaTransport
  • IrObex : IrdaTransport
  • IrSocketAddr() : IrSocketAddr
  • Is3aExisting() : TypeOfAddress
  • is_binary : MimeTypeTableEntry
  • is_loading : SvgImage
  • is_on_sim : PbNumberRecord::Persist
  • IsAborted() : StackMsgActiveWaitDispatcher
  • IsAbsolute() : ValidityPeriod
  • IsAccept() : SetupEventCnfArg
  • IsAcceptable() : ObexServerDispatcher
  • IsAcceptPermitted() : CallHdl, MmCallHdl
  • IsAccessBurstTypeInvalid() : GprsParam
  • IsAccessControlClassInvalid() : CellParam
  • IsAccessGranted() : HttpAuthProvider, FtpAuthProvider, AuthProvider
  • IsAccThrInvalid() : GprsParam
  • IsAckBlocksInvalid() : AckNackCnt
  • IsActivated() : RejectCallsIndArg
  • IsActivateReporting() : SetChargeUnitsArg, SetAutoChargeArg
  • IsActivationBitSet() : SsStatus
  • IsActive() : DataConn, ObexServerDispatcher, Timer, SystemTimer, WindowFrameView, TabButton, BidiManager, AudioAccessoryDetails, SmsSocket, PdpContext, MptyCallHdl, CallHdlBase, CallHdl, MmCallHdl
  • IsActiveOperation() : ObexServer, ObexOppServer
  • IsActiveOppClient() : ObexClientOppImpl
  • IsActiveOppServer() : ObexServerOppImpl
  • IsAddData() : UsimSmsParamExtIndArg, UsimSmsParamReadIndArg
  • IsAddressAllocatedDynamically() : PdpContext
  • IsAdnReadWritableIfFdnActive() : SimAccessor, DataHandler
  • IsAidingStale() : GltpAssistanceData
  • IsAlarmDay() : CalendarApp
  • IsAllocatedDynamically() : DataConnApp::DataConnDescription
  • IsAllowed() : MimeTypeFilter, SoundFilter, ImageFilter, MediaFilter, MimeTypeFilter, SoundFilter, ImageFilter, MediaFilter, RegistrationAllowedMsg, AttachAllowedIndArg, DrmRightsObjectContainer, DrmRightsObject, DrmPermission
  • IsAlphaBlendingEnabled() : Bitmap, BitmapRes
  • IsAlphaMaskEnabled() : WindowManager
  • IsAmbulance() : EccCategory
  • IsApplUsimPbExisting() : UsimPbLocReport
  • IsArchive() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FlashFileImp, FatFileImp, FatFile
  • IsArfcnDedInvalid() : CellParam
  • IsArfcnInvalid() : CellParam, NeighbourCell
  • IsArg() : SsSuccessMsg
  • IsAscendingOrder() : SmsSettingsRecord
  • IsAsynchronous() : MessageHook
  • IsAtEnd() : ObexUrlStrParser
  • IsAttachAllowed() : PlmnDispatcher
  • IsAttached() : MessageHook, ObservableObject, GprsStatusMsg, PdpContextManager, HeadSet
  • IsAttachedToProperty() : FeatureItem
  • IsAudioConnected() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • IsAudioEnabled() : VideoCaptureParameters
  • IsAudioSwitchPath() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • IsAuthenticated() : PdpContext
  • IsAuthorityCert() : SimMexeCertificate, MexeDescriptor
  • IsAutoCallSetup() : MocSetupReqArg
  • IsAutoClearEnabled() : Control
  • IsAutoLayoutEnabled() : Control
  • IsAutoRegistered() : ObexServerAddr
  • IsAutoStopped() : AudioStoppedMsg
  • IsAutoStorageEnabled() : SmsSettingsRecord
  • IsAvailable() : FeatureItemContainer, Feature, BootState
  • IsAvsReady() : ObexAbstractPort
  • IsBackgrDrawingEnabled() : MenuView, AbstractListBoxView
  • IsBacklightOn() : DefaultDisplay, Display, DefaultDisplay
  • IsBackup() : BtObexServerNmaSetPath
  • IsBatteryLow() : Charger
  • IsBcdPlmnMatching() : StackWrapper, OplEntry
  • IsBdnActivated() : SimAccessor, DataHandler
  • IsBdnEnabled() : DataControlPhonebookStateMsg
  • IsBdnReadWritableIfBdnNotActive() : SimAccessor, DataHandler
  • IsBinaryByExt() : MimeTypeTable
  • IsBinaryByFileType() : FfsMimeTypeMap
  • IsBinaryByMimeStr() : MimeTypeTable
  • IsBlinking() : DefaultCaret
  • IsBlobFile() : UriMappingTable
  • IsBlocking() : SysSocket, Socket, InetSocket, Threadlet, SerialSocket, SerialTerminalSocket
  • IsBlockUsed() : RamStorageMapper
  • IsBold() : InformationElement
  • IsBoundTo() : ObexAbstractPort
  • IsBoundToChannel() : ObexServerDispatcher, ObexOppServer
  • IsBoundToMimeType() : ObexOppServer
  • IsBoundToServerId() : ObexServer, ObexOppServer
  • IsBoundToTarget() : ObexServer
  • IsBrowserOpen() : LcsWapIntf
  • IsBsicBccInvalid() : CellParam
  • IsBsicInvalid() : CellParam, NeighbourCell
  • IsBsicNccInvalid() : CellParam
  • IsBsPaMfrmsInvalid() : CellParam
  • IsBufferAvailable() : ImageBox
  • IsBufferingAllowed() : Image, SvgImage
  • IsBufferingEnabled() : ImageBox
  • IsBusy() : GenericWorkerTask
  • IsC1Invalid() : CellParam, NeighbourCell
  • IsC2Invalid() : CellParam, NeighbourCell
  • IsC2ValidParamsInvalid() : CellParam
  • IsC31Invalid() : NeighbourCell, GprsParam
  • IsC32Invalid() : NeighbourCell, GprsParam
  • IsCacheFilling() : UsimPbSelectReqArg
  • IsCallActive() : AudioPathManager
  • IsCallbackActive() : DefaultDisplay, Display, DefaultDisplay
  • IsCallControlPerformed() : SsInfoMsg, CallHdl, SsFacilityIndArg, CallIndCallControlInfoArg
  • IsCallFwdUncondActive() : SimCphsHandler
  • IsCancelable() : BtUncancelableRequest, BtServiceRequest, BtRequest, BtCancelableRequest
  • IsCanceled() : PbSynchronizer
  • IsCancelled() : DataConn
  • IsCapabilitySupported() : StorageDevice
  • IsCaretAlwaysVisible() : AbstractEditor
  • IsCause() : StartUp::Data
  • IsCellBarAccessInvalid() : CellParam
  • IsCellBarQualifyInvalid() : CellParam
  • IsCellChangeCntInvalid() : CellParam
  • IsCellIdentityInvalid() : UmtsRrcScellParam
  • IsCellIdInvalid() : CellParam, NeighbourCell
  • IsCellReselectHystInvalid() : GprsParam
  • IsCellReselectionReasonInvalid() : RrParam
  • IsCellReselectOffsetInvalid() : CellParam
  • IsChannelModeInvalid() : CellParam
  • IsChannelReleaseReasonInvalid() : RrParam
  • IsChannelTypeInvalid() : CellParam
  • IsChargerInserted() : Charger
  • IsChild() : Control
  • IsCingularActive() : InputContext
  • IsCingularNetworkSelectionMenuControlSupportEnabled() : SimCphsHandler, DataHandler
  • IsCingularSimInserted() : DataHandler
  • IsClearTextModeEnabled() : PasswordEditor
  • IsClient() : ObexChannel
  • IsColumnTitled() : Grid, GridModel
  • IsCombinedDelivered() : DrmInfo
  • IsComplete() : ObexHeaderBuilder
  • IsComponent() : GuiObjectFactory, Zi8Wrapper
  • IsComponentSupported() : TestparamReport
  • IsComprehensionRequired() : Tlv
  • IsCompressed() : NativeImage, Bitmap, BitmapRes
  • IsConcateneted() : PortHeaderInformation, TpduHeaderInformation
  • IsConfirmed() : PbAbstractWin, BandSelectionMsg, BandSelectionIndArg
  • IsConnected() : BtIndicatorMsg, DataConn, ObexServer, ObexClientPort, BtObexClientService, BtHsService, BtHfService, BtFaxService, BtDunService, BtDevice, BtAudioAccessoryService, BtBppClientService, BtBipClientService, BtAvrcpOperationService, AudioAccessoryConnectedMsg, ExtPsdContextListener_SerialTerminal, ConnectionIndArg, SerialTerminal
  • IsConnectionLost() : UtcStatusMessage
  • IsConstraintAvailable() : DrmRightsObject
  • IsContentValid() : InputMapper
  • IsControllerConnected() : BtAvrcpControllerDeviceListItem
  • IsCopyrighted() : NativeImage, Image, Bitmap, BitmapRes, Melody
  • IsCphsPresent() : SimCphsHandler
  • IsCphsServAccessible() : SimCphsHandler
  • IsCpichEcn0Invalid() : UmtsNcellParam, UmtsRrcScellParam
  • IsCpichRscpInvalid() : UmtsNcellParam, UmtsRrcScellParam
  • IsCpichScInvalid() : UmtsNcellParam
  • IsCreate() : BtObexServerNmaSetPath
  • IsCreateEmpty() : BtObexClientNmaDataBufferIndication, BtObexServerNmaDataBufferIndication
  • IsCrSupported() : TextEditorDocument
  • IsCspPlmnModeBitSet() : SimCphsHandler, DataHandler
  • IsCtm() : CtmInfoIndMsg, SimTkCallSetupAccArg, MtcSetupIndArg, MocSetupReqArg, CtmInfoIndArg, CallIndArg
  • IsCurrentDir() : RamHandler
  • IsCurrentlyDecoded() : Image
  • IsCurrentlyDecodedError : Image
  • IsCursorVisible() : AbstractEditBox, AbstractEditBoxModel
  • IsDataAcceptable() : StreamWriter
  • IsDataAvailable() : StreamReader
  • IsDataConnEstablished() : InetSocket
  • IsDataConnRegistered() : DataConnManager
  • IsDateTimePresent() : MnInformationIndArg
  • IsDateTimeValid() : TpduHeaderInformation
  • IsDaylightSavingTimePresent() : MnInformationIndArg
  • IsDcsListFilterEnabled() : Cbs::Filter
  • IsDecoderCodecSupported() : MediaFrameworkCaps
  • IsDecoding() : ImageBox, SvgPlayer
  • IsDecodingFinished() : ImageBox, SvgPlayer
  • IsDefined() : File::Attributes
  • IsDeleteObject() : BtObexClientNmaDataBufferIndication, BtObexServerNmaDataBufferIndication
  • IsDeletePossible() : LockTableList, LockTable
  • IsDestinationPortRangePresent() : PdpContext::PacketFilter
  • IsDeviceConnected() : BtSingleConnectionController, BtMultiConnectionController, BtConnectionBasedController
  • IsDeviceRegistered() : RfsStorageDeviceRegistrationStatusMsg
  • IsDfIdFlag() : SimGenericReqArg
  • IsDirectory() : StorageDevice, RootFileSystem, File, File::Attributes, FfsHandler, RootStorageDeviceImp, RamStorageDeviceImp, RamHandler, RamFileObj, FlashStorageDeviceImp, FatStorageDeviceImp, FatHandler
  • IsDisable() : RediallingDisabledIndArg
  • IsDisabled() : Control
  • IsDisconnected() : DataConn
  • IsDisplayable() : DrmInfo
  • IsDispMapAllowed() : LcsWapIntf
  • IsDlUarfcnInvalid() : UmtsRrcScellParam
  • IsDocumentPanable() : SvgPlayer
  • IsDocumentZoomable() : SvgPlayer
  • IsDpofOptionSupported() : BtBipImagingCapabilities
  • IsDrmMedia() : MediaRef
  • IsDrmOpValid() : DrmRightsObjectContainer
  • IsDrxMaxInvalid() : GprsParam
  • IsDscInvalid() : CellParam
  • IsDscPchInvalid() : L1Param
  • IsDscPpchInvalid() : L1Param
  • IsDstIndInvalid() : TimeZone
  • IsDtxUsedInvalid() : CellParam
  • IsEccCode() : EccProvider, DataHandler
  • IsEcNrActive() : AudioAccessoryDetails
  • IsEditableAfterLastItem() : EditorDocument, MultiMediaEditorDocument
  • IsEfIdFlag() : SimGenericReqArg
  • IsEmoInvalid() : GprsParam
  • IsEmpty() : ObexTransportSet, Ticks, ApplicationListEntry, Rect, IndicatorBar, BtDeviceList, WString, Vector< T >, String, RegBlobObject, PhoneNumber, LinkedListBase, ByteBuffer, BlobObject, ResourceID, CbsFilterList, CiTestParamList, EquivPlmnLists, NeighbourCellList, AckNackParamList, COverIList, BlerTrchInfoList, MdhGors
  • IsEmptyRow() : PhonebookApp
  • IsEnabled() : DataConnAccessor, ItemContainer, Item, GlassPane, AbstractButton, Audio, AbstractMenuAccessor, SimpleAudioDevice, FeatureItem, Feature, AtAccessoryRegisterReqArg, AbstractActionMenuAccessor
  • IsEnablePassword() : DhChannelOpenReqArg
  • IsEnciphered() : ConnectionIndArg
  • IsEncoderCodecSupported() : MediaFrameworkCaps
  • IsEncoding() : ImageEncoder
  • IsEndOfData() : ObexObject, RtStreamingBuffer
  • IsEndReached() : UsimPlmnReadIndArg
  • IsEndUserDefineableProp : GuiObjectFactory
  • IsEqual() : ImageRefGenContainer, BtDeviceAddressGenericObject, Item, AbstractToggleAction, Cell, RegBlobObject, GenericObject, DataItem, BlobPtr, BlobObject, BitField< T >, TimeFeatureObject, GenericFeatureData, ImgObtObj, TriggerKeyFeature, ProviderProxyItem, MenuIdObj, ItemObj, FeatureItemContainer, FeatureItem, Feature, ContextFeature, BackToIdleFeature, MenuDescObj, Plmn, BcdPlmn, TpduPhoneNumberPersist, CompoundTpduItem, CompoundSmsItem
  • IsEqualSignal() : ProcessNode
  • IsEqualTipd() : TipdBasedActiveWaitDispatcher
  • IsEqualTo() : BtObexServiceTable::ServiceInfo, ByteBuffer
  • IsError() : ObexResult, BtObexResponseCode
  • IsEstCauseChanged() : MocSetupAcceptMsg, MmMocSetupAcceptMsg
  • IsEventIdInvalid() : UmtsMeasIdParam
  • IsExclusive() : HandlerData
  • IsExecutable() : DrmInfo
  • IsExecuting() : PbSecuredAction
  • IsExecutionPossible() : LanguageResetAction, ApoxiCommandAction, UssdAction, UndefinedSsAction, WaitSsAction, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, NumberIdentificationAction, ClirAction, PinAction, CallSsAction, EngModeAction, ImeiShowAction, MoCallAction, UnlockAction, PbEntryShowAction, InputAction
  • IsExplicitCallTransferPermitted() : CallHdl
  • IsFastSmsLoadingSupported() : StackInterface
  • IsFdnActivated() : SimAccessor, DataHandler
  • IsFdnEnabled() : DataControlPhonebookStateMsg
  • IsFeatureSupported() : MmfPlayer, AudioDeviceBase
  • IsFilePackAvailable() : FilePackConnector
  • IsFilterSupported() : BtBipImagingCapabilities
  • IsFinal() : BtObexResponseCode, AtGenericCmdIndArg
  • IsFinished() : BtObexResponseCode, KeySequenceCandidate
  • IsFireBrigade() : EccCategory
  • IsFirstCell() : GridModel
  • IsFixedContext() : ContextFeatureItem
  • IsFlag() : UsimEstReadIndArg, UsimUstReadIndArg
  • IsFlipOpen() : FlipMsg, MnTriggerReqArg
  • IsFlowLabelPresent() : PdpContext::PacketFilter
  • IsFocusMsgProcessingBlocked() : MsgQueue
  • IsFocusPassingEnabled() : AbstractListBox
  • IsFontPackAvailable() : FontPackConnector
  • IsForbidden() : PlmnListEntry
  • IsForwardable() : DrmInfo
  • IsForwardedToCallingSubscriber() : SsNotification
  • IsForwardedToForwardedToSubscriber() : SsNotification
  • IsForwardedToForwardingSubscriber() : SsNotification
  • IsForwardLocked() : DrmInfo
  • IsFreePage() : HeapVector::VarPage, HeapVector::BlockPage
  • IsFreePageFunction : HeapVector
  • IsFullRefreshed() : SimEfRefresh
  • IsFullsized() : PositionIndicator
  • IsFullTraversingEnabled() : Image, GifImage, BmpImage
  • IsGlobalUsimPbExisting() : UsimPbLocReport
  • IsGprsAvailable() : AbstractSmsApp, CellInfoIndArg
  • IsGprsClassInvalid() : MmCoordParam
  • IsGprsFdnActivationCodePresent() : DataHandler
  • IsGprsSupported() : GprsParam
  • IsGreater() : Cell, DataItem
  • IsGreaterEqual() : DataItem
  • IsGroupDeletionNotificationSupported() : StackInterface
  • IsGsmBandInvalid() : MmCoordParam
  • IsHeaderEnabled() : TabControl
  • IsHeld() : MptyCallHdl, CallHdlBase, CallHdl
  • IsHfServiceSupported() : BtQuerySupportedProfilesRequest
  • IsHidden() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • IsHoldPermitted() : MptyCallHdl, CallHdlBase, CallHdl
  • IsHorizontal() : AbstractGrid::SmoothScrollInfo
  • IsHsHasRemoteVolumeControl() : BtHsSupportedProfileMessage
  • IsHsServiceSupported() : BtQuerySupportedProfilesRequest
  • IsIlluminationOn() : Keyboard
  • IsImageInitialized() : ImageRef
  • IsImmediateResponse() : DisplayTextReqArg
  • IsInactive() : DataConn
  • IsInCall() : BtHsService, BtHfService, BtAudioAccessoryService
  • IsInContext() : ExecutionContext
  • IsInDatabase() : MediaRefContainer
  • IsIndex() : Cbs, Cbs::SerialNumber
  • IsIndexVisible() : AbstractEditBoxModel
  • IsIndicatorFullsized() : GridModel
  • IsInForeground() : DeviceContext, Control
  • IsInfoRequested() : MenuSelectionReqArg
  • IsInHold() : DataConn
  • IsInitialized() : System, GenericAudioDevice, Protector, FlsFile, RamFile, FatFile
  • IsInOnlineMode() : MmCallInfo, MmCallHandler
  • IsInputValid() : TimeEditBox, DateEditBox, AbstractEditBox, AbstractEditBoxModel
  • IsInRange() : Provider, DataItem
  • IsInRelease() : DataConn
  • IsInRom() : MemoryConfig
  • IsInSeconds() : ValidityPeriod
  • IsInSetup() : DataConn, CallHdl, MmCallHdl
  • IsInside() : Rect, Point
  • IsInstanceOf() : Window, TimeEditor, TimeCompoundItem, TextLine, TextCompoundItem, TextBox, TabControl, TabButton, RadioButtonControl, RadioButtonAction, PushButton, ProgressBar, PositionIndicator, PasswordEditor, Panel, NativeImage, MultiLineEditor, MessageBox, LineEditor, ItemTree, ItemRendererProperties, ItemMenu, ItemGrid, ItemContainer, ItemBox, Item, IpAddrEditor, IpAddrCompoundItem, ImageBox, Image, GridLayout, FlowLayout, DrawableObject, DateEditor, DateCompoundItem, Control, ContextMenu, CompoundItem, Component, CheckBoxControl, CheckBoxAction, CharItem, AtomItem, AnimatedTextLine, Alert, Action, AbstractToggleAction, AbstractTextObject, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemGrid, AbstractItemContainer, AbstractGrid, AbstractEditorItem, AbstractEditor, AbstractButton, SoundItem, ActionExtension, ValueMappingPropertyDescriptor< T_Container >, PropertyItem, PropertyDescriptor, Property, ListPropertyDescriptor, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow, TriggerKeyFeature, ProviderProxyItem, ProviderProxyContainer, IndicatorItem, FeatureItemContainer, FeatureItem, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, AtlWindow, SvgImage, WbmpImage, VCardItem, RichTextCompoundItem, PngImage, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditor, JpegImage, ImageItem, GifImage, GeneralCompoundItem, BoundedItem, BmpImage, AudioItem, AccessorActionExtension
  • IsInstanceValid() : Socket
  • IsInState() : ObexAbstractPort
  • IsInterlaced() : PngDecoder
  • IsInternalUpdate() : ParagraphCompoundItem
  • IsInUse() : SocketData, SmsSocketListener, SerialSocketData
  • IsInvalid() : IpAddrEditorDocument, PhoneNumber, ProviderProxyItem, ValidityPeriod, SimItemIdentifier, SimItemId, SimAtom< T >, ProtocolIdentifier, Plmn, BcdPlmn, MessageTypeIndicator, DataCodingScheme
  • IsInValidContext() : ObexDispatcher
  • IsIpSecSecurityParameterIndexPresent() : PdpContext::PacketFilter
  • IsIPv4() : PdpContext::Address
  • IsItalic() : InformationElement
  • IsJoinPermitted() : CallHdlBase
  • IsKnown() : BtDevice
  • IsLacInvalid() : CellParam, NeighbourCell, UmtsRrcScellParam
  • IsLanguageSupported() : Zi8Wrapper, ChineseT9Wrapper
  • IsLastCell() : GridModel
  • IsLastResult() : VrResultMsg
  • IsLater() : DateTime::Persist
  • IsLeapYear() : Date
  • IsLess() : Cell, DataItem, PhoneNumberMergeProvider, MergeProvider
  • IsLessEqual() : DataItem
  • IsLineBreak() : Os
  • IsLingerEnabled() : SocketPeer
  • IsListening() : ObexServerPort
  • IsLoadingAllowed() : BootControl
  • IsLocalIdValid() : DrmRightsObjectStore
  • IsLocked() : Keyboard, Display, HandlerData
  • IsLsaIdentifierPresent() : LsaIdentityMsg, MnInformationIndArg
  • IsMarineGuard() : EccCategory
  • IsMarked() : Item
  • IsMatchedByUrl() : ObexAbstractTransport
  • IsMatching() : PhoneNumber, Cbs::Filter
  • IsMaximized() : Control
  • IsMccInvalid() : CellParam, NeighbourCell
  • IsMeasIdInvalid() : UmtsMeasIdParam
  • IsMediaPresent() : RfsMediaAvailableStatusMsg
  • IsMenuInitialized() : FeatureBroker
  • IsMessageForMe() : HttpWapMgrPlugin, HttpWapMgrBase
  • IsMessageRegistered() : AppContainer
  • IsMidListFilterEnabled() : Cbs::Filter
  • IsMirrored() : AbstractGrid::SmoothScrollInfo
  • IsMmCall() : MmCallHandler
  • IsMncInvalid() : CellParam, NeighbourCell
  • IsMobileNetworkStarted() : PowerHandler
  • IsMobileOriginated() : CallHdl, Tpdu, MmCallHdl, MmCallHandler
  • IsMobileTerminated() : CallHdl, Tpdu, MmCallHdl, MmCallHandler
  • IsMocSetupPermitted() : InputContext
  • IsModeSupported() : PredInputMapper, Zi8InputMapper, EnglishT9InputMapper, ChineseT9InputMapper, AbstractPredictiveInputBox
  • IsMono() : HeadSet
  • IsMountainRescue() : EccCategory
  • IsMounted() : MainHandler
  • IsMptyMember() : CallHdl
  • IsMsTxPowerMaxCchInvalid() : CellParam
  • IsMultiKeyMode() : Keyboard
  • IsMultiLine() : ItemRendererProperties
  • IsMute() : AudioContext
  • IsNackBlocksInvalid() : AckNackCnt
  • IsNameAvailable() : StackMsgMapTableEntry, SignalMapTableEntry
  • IsNcoInvalid() : GprsParam
  • IsNetworkNameLongAddCi() : NetworkInformationMsg, MnInformationIndArg
  • IsNetworkNameShortAddCi() : NetworkInformationMsg, MnInformationIndArg
  • IsNetworkOpModeInvalid() : GprsParam
  • IsNoBlocksInvalid() : CiTestParam
  • IsNodeExisting() : NodeFileHandler
  • IsNoRfChansInvalid() : CellParam
  • IsNormalUsage() : ProtocolIdentifier
  • IsNotEqual() : DataItem
  • IsNotificationBlocked() : Item, Feature
  • IsNullStr() : WStrData, StrData
  • IsNumeric() : WString, String
  • iso_2ltr_code : LanguageCodeTableEntry
  • iso_3ltr_code : LanguageCodeTableEntry
  • IsObtained() : SemObtainer, MutexObtainer
  • IsOffsetInvalid() : TimeZone
  • IsOfInterest() : CbsFilterList
  • IsOfmToBeActivated() : SimAuxHandler
  • IsOfType() : BtJsr82Url::Token
  • IsOk() : ObexResult, BtObexResponseCode
  • IsolatedWord : VrHandler
  • IsOnSim() : PbNumberRecord
  • IsOpen() : Socket, InetSocket, Window, Control, VideoChannel, NonsharedBinDataDataSource, VideoChannel, FileOutputStream, FileInputStream, StringDataSink, HeapDataSource, HeapDataSink, DataSource, DataSink, BinDataDataSource, FileDataSource, FileDataSink, File, FlsFile, SerialSocket, SerialTerminalSocket, RootFileImp, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • IsOpenInMode() : File
  • IsOperationActive() : StreamObexImpl
  • IsOperationCompleted() : StreamingInfo
  • IsOperationCompletedSynchroneously() : StreamingInfo
  • IsOperationErroneous() : StreamingInfo
  • IsOperationFailed() : StreamingInfo
  • IsP1Invalid() : UmtsMeasEvalParam
  • IsP2Invalid() : UmtsMeasEvalParam
  • IsPacked() : ValidityPeriod, GetInputRspArg
  • IsPaging() : AbstractEditBoxModel
  • IsPaired() : BtDevice
  • IsPanelEnabled() : Desktop
  • IsParentWindowOpen() : Control
  • IsPartlyConcSmsStateChangeable() : SimPduHandler, DataHandler
  • IsPaServiceSupported() : BtQuerySupportedProfilesRequest
  • IsPasswordMode() : AbstractEditBoxModel
  • IsPathActive() : AudioPathManager
  • IsPbAvailable() : PhonebookApp, AdvPbApp
  • IsPbcchPresent() : GprsParam
  • IsPduDeleted() : MdhGors
  • IsPenaltyTimeInvalid() : CellParam
  • IsPhoneNumberTextDefaultData() : SmsBasicProvider, PhoneNumberMergeProvider
  • IsPhysicalPushEnabled() : WapProfile
  • IsPlayable() : DrmInfo
  • IsPlayOnceEnabled() : ImageBox
  • IsPlmnInvalid() : CellParam, NeighbourCell
  • IsPlmnSearchActive() : NRegStateIndArg
  • IsPlmnwactPresent() : SimAuxHandler
  • IsPng() : PngDecoder
  • IsPolice() : EccCategory
  • IsPortPtrValid() : ObexServerDispatcher
  • IsPositionIndicatorEnabled() : AbstractMultiLineEditor
  • IsPositionIndicatorLeftAligned() : AbstractMultiLineEditor, AbstractGrid
  • IsPositionIndicatorShown() : AbstractGrid, AbstractListBox
  • IsPowerOn() : DefaultDisplay, Display, DefaultDisplay
  • IsPredInputEnabled() : SmsSettingsRecord
  • IsPresentationAllowed() : PhoneNumber
  • IsPressed() : AbstractButton, RadioButtonItem
  • IsPreviewShown() : ImageBox
  • IsPreviousFrameBuffering() : Image
  • IsPrintable() : DrmInfo
  • IsProfileWriteable() : WapProfile
  • IsProgressMsgEnabled() : Image
  • IsProtocolNumberOrNextHeaderPresent() : PdpContext::PacketFilter
  • IsProvisionBitSet() : SsStatus
  • IsPScInvalid() : UmtsRrcScellParam
  • IsPsdCallActive() : MmCallHdl, MmCallHandler
  • IsPsi1RepeatPeriodInvalid() : GprsParam
  • IsPsiCountHrInvalid() : GprsParam
  • IsPsiCountLrInvalid() : GprsParam
  • IsPushEnabled() : WapProfile
  • IsQualityValid() : SignalStrengthLevelIndArg
  • IsQuiescentBitSet() : SsStatus
  • IsRacInvalid() : GprsParam, UmtsRrcScellParam
  • IsRankingValueInvalid() : NeighbourCell, UmtsNcellParam, UmtsRrcScellParam
  • IsRankPosInvalid() : NeighbourCell, UmtsNcellParam
  • IsRatChangePossible() : PlmnHandler, PlmnDispatcher
  • IsrDataContainer() : IsrDataContainer< Data, c_queue_size >
  • IsrDataManager : IsrDataMarshaller
  • IsrDataMarshaller : IsrDataMarshaller, IsrDataManager
  • IsReadOnly() : PhonebookWin, PbAbstractWin, DataConnProfileManager::ProfileInfo, DataConnProfile, AbstractEditor, File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • IsReady() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp, SimPbEntryCont
  • IsReadyForSendingSms() : AbstractSmsApp
  • IsRecordDeleted() : UibSettingsRecord, ToDoRecord, SmsSettingsRecord, CalendarRecord, PbNumberRecord, PbRecord, Record, DataRecordHandler
  • IsRecording() : StreamAudioPlayer
  • IsRedialStatus() : RedialStatusMsg, RedialStatusIndArg
  • IsRefreshed() : SimEfRefresh
  • IsRefreshPossible() : SimTkRefreshCnfReqArg, SimTkResetCnfReqArg
  • IsRegistered() : LookupAlphaIdExtension
  • IsRegistrationAllowed() : PlmnHandler
  • IsRegistrationBitSet() : SsStatus
  • IsRegStateInvalid() : MmCoordParam
  • IsRejected() : PlmnScanFinishedMsg
  • IsRelative() : ValidityPeriod
  • IsReleaseComplete() : SsUssdIndArg, SsCauseIndArg, SsErrIndArg, SsRejArg, SsRetResIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg
  • IsReloadInProgress() : SimPduHandler
  • IsReplyPathRequested() : SmsSettingsRecord
  • IsReqSent() : LcsAppUtils
  • IsRequestForMe() : ObexServerOppImpl, ObexServer
  • IsRequestGranted() : FatFsUsbMassStorageRequestMsg
  • IsRequestReplyPath() : AbstractSmsApp
  • IsRequestStatusReport() : AbstractSmsApp
  • IsRestricted() : AutoCallRestrictIndArg
  • IsResult() : PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg
  • IsRetranslateEnabled() : Item
  • IsRetrievePermitted() : MptyCallHdl, CallHdlBase, CallHdl
  • IsRightToLeftItem() : TextEditorDocument, EditorDocument, MultiMediaEditorDocument
  • IsRinging() : BtHsService, BtHfService, BtAudioAccessoryService
  • IsRllInvalid() : L1Param, CellParam
  • IsRoot() : MenuAccessor, AbstractMenuAccessor, Pathname
  • IsRowFiltered() : FilterProvider, DualFilterProvider
  • IsRowTitled() : Grid, GridModel
  • IsrPushData() : IsrDataContainer< Data, c_queue_size >
  • IsRTCStartUpEvent() : RealTimeClock
  • IsRunning() : UpdatePbThreadlet, SyncPhoneThreadlet, Application, AppContainer, AbstractAppContext, Server, FtpTransfer
  • IsRxlevAccessMinInvalid() : CellParam
  • IsRxlevFullInvalid() : CellParam
  • IsRxlevInvalid() : NeighbourCell
  • IsRxlevServInvalid() : CellParam
  • IsRxlevSubInvalid() : CellParam
  • IsRxqualFullInvalid() : CellParam
  • IsRxqualInvalid() : L1Param
  • IsRxqualSubInvalid() : CellParam
  • IsSame() : MptyCallHdl, CallHdl
  • IsSameType() : GenericObject
  • IsScanActive() : RegistrationChangeMsg
  • IsScanInProgress() : PlmnHandler
  • IsScoPathStatus() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • IsSecondary() : PdpContext
  • IsSecureClockValid() : RealTimeClock
  • IsSelectableCell() : GridModel
  • IsSelected() : RadioButtonControl, CheckBoxControl, AbstractToggleAction, CheckBoxItem, CheckBox, CheckBoxModel
  • IsSelector() : AbstractGrid::SmoothScrollInfo, AbstractListBox::SmoothScrollInfo
  • IsSelfExplanatory() : SimIconQualifier
  • IsSendingConfirmationEnabled() : SmsSettingsRecord
  • IsSendingSmsConfirmed() : AbstractSmsApp
  • IsSendPreviewMandatory() : SmsSettingsRecord
  • IsSeparateDelivered() : DrmInfo
  • IsSeparator() : TimeEditorDocument, Item, IpAddrEditorDocument, DateEditorDocument
  • IsSeparatorProp : GuiObjectFactory
  • IsServer() : ObexChannel
  • IsServerService() : BtObexService, BtObexServerService, BtObexClientService, BtBppService, BtBppServerService, BtBppClientService, BtBipServerService, BtBipClientService
  • IsServiceActivated() : SimCphsHandler
  • IsServiceAllocated() : SimCphsHandler
  • IsServiceAvailable() : AbstractSmsApp
  • IsServiceStateInvalid() : GmmParam, MmcsParam
  • IsServiceSupported() : ServiceBroker
  • IsSet() : BitField< T >
  • IsSetupPermitted() : CallHdl, MmCallHdl
  • IsShallTransmit() : MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg
  • IsShortMessageFailure() : SmsSendCnfArg
  • IsShutdownAllowed() : Application
  • IsShuttingDown() : ObexServerDispatcher
  • IsSi13Present() : GprsParam
  • IsSignalNameAvailable() : ProcessNode
  • IsSilentReset() : StartUp::Data
  • IsSimAccessAllowed() : SimPbBaseHandler, SimAccessor, DataHandler, BaseDataHandler
  • IsSimPbExisting() : UsimPbLocReport
  • IsSimPresent() : SimAccessor, DataHandler, BaseDataHandler
  • IsSimRefreshPossible() : SimAuxHandler, DataHandler
  • IsSimResetPossible() : SimAuxHandler, DataHandler
  • IsSimServiceEnabled() : SimServices, DataHandler
  • IsSimtkRelated() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • IsSingleShot() : ValidityPeriod, FunctionalityIndicator
  • IsSingleSrrPerSmsEnabled() : SmsContext
  • IsSmsComposeEnabled() : AbstractSmsApp
  • IsSmsFilterTypeMatch() : SimPduHandler
  • IsSortAsc() : UibSettingsRecord
  • IsSourceAddressAndSubnetMaskPresent() : PdpContext::PacketFilter
  • IsSourcePortRangePresent() : PdpContext::PacketFilter
  • IsSpaceLeftOnStorageMedia() : SimPduHandler
  • IsSplitPermitted() : MptyCallHdl
  • IsSplitPgCycle() : GprsParam
  • IsSsPending() : SsHandler
  • IsStandaloneCharacter() : VietnameseTextRenderer, ThaiTextRenderer, TextCompoundItem, AbstractTextRenderer
  • IsStandaloneItem() : AbstractMultiLineEditor, AbstractEditor
  • IsStartDtmfToneGenerationPermitted() : CallHdl
  • IsStarted() : AnimatedTextLine
  • IsStartOfSequence() : KeySequence
  • IsStateInvalid() : RrParam, MmCoordParam, GmmParam, MmcsParam
  • IsStatusReportEnabled() : SmsSettingsRecord
  • IsStatusReportOnIdleScreen() : SmsSettingsRecord
  • IsStereo() : AudioFmRadioRssiMsg
  • IsStopEncodingRequested() : ImageEncoder
  • IsStorable() : PhoneNumber
  • IsStorableMocPhoneNumber() : InputAnalyzer
  • IsStrikethrough() : InformationElement
  • IsSubstitutionNeeded() : SubstitutedText
  • IsSubSystemInitialized() : SimPduHandler
  • IsSuccess() : AudioFmRadioSeekMsg, OmMultiSlotIndMsg, OmMultiSlotIndArg
  • IsSuccessResponse() : ObexObject
  • IsSumCOverIInvalid() : CiTestParam
  • IsSupported() : VrHandler
  • IsSwapPermitted() : CallHdlBase
  • IsSwitch() : PagingMapEntry
  • IsSynchronized() : PbSynchronizer
  • IsSynchronizing() : PbSynchronizer
  • IsSyncModeEnabled() : Item
  • IsSyncSoftkeysEnabled() : Window
  • IsSystem() : RamFileObj
  • IsT3192Invalid() : GprsParam
  • IsT3212Invalid() : CellParam
  • IsT9PackAvailable() : T9PackConnector
  • IsTabbing() : MultiTapCaret
  • IsTabEnabled() : TabControl
  • IsTelematicDevice() : ProtocolIdentifier
  • IsTemporary() : DataConnProfileManager::ProfileInfo, File
  • IsTemporaryProfile() : DataConnProfileInfoMsg
  • IsTemporaryProfileId() : DataConnProfileManager
  • IsTerminatingResponse() : AtCommand
  • IsTest() : TestparamReqArg
  • IsText() : MimeCoder
  • IsTextByExt() : MimeTypeTable
  • IsTextByFileType() : FfsMimeTypeMap
  • IsTextByMimeStr() : MimeTypeTable
  • IsTextEditorDocument() : T9InputMapper
  • IsTextPackAvailable() : TextPackConnector
  • IsTimerExpired() : TimeoutCondition
  • IsTimerInvalid() : MmCoordParam, GmmParam, MmcsParam
  • IsTimeZonePresent() : MnInformationIndArg
  • IsTimingAdvanceInvalid() : L1Param, CellParam
  • IsTitleAnimated() : Window
  • IsTmpOffsetInvalid() : CellParam
  • IsTrafficAnnouncementSet() : AudioFmRadioRdsStationNameMsg
  • IsTrafficProgramSet() : AudioFmRadioRdsInfoMsg
  • IsTransparent() : Window, NativeImage, ItemRendererProperties, Image, Bitmap, BitmapRes, SvgImage, WbmpImage, PngImage, PngDecoder, GifImage
  • IsTremblerOn() : Audio
  • IsTrue() : BooleanCondition, Condition
  • IsTrusted() : BtDevice
  • IsTwinViewfinderEnabled() : Camera
  • IsTxPowerLevelInvalid() : L1Param, CellParam
  • IsTypeOfServiceAndMaskOrTrafficClassAndMaskPresent() : PdpContext::PacketFilter
  • IsUlUarfcnInvalid() : UmtsRrcScellParam
  • IsUnderlined() : InformationElement
  • IsUnique() : ObexChannel
  • IsUnlockingAllowedKeyBased() : SimChvHandler
  • IsUnlockingAllowedOnStartup() : SimChvHandler
  • IsUnlockingAllowedPerMenu() : SimChvHandler
  • IsUpdated() : MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, BootState
  • IsUpdateStatusInvalid() : GmmParam, MmcsParam
  • IsUpdating() : Provider
  • IsUpDownPermitted() : AbstractMultiLineEditor
  • IsUrlValid() : BtJsr82Url
  • IsUsbChargingEnabled() : Charger
  • IsUsed() : UsimPbGroups
  • IsUsimInserted() : SimAccessor, DataHandler, BaseDataHandler
  • IsValid() : PbNumberRecord, PbRecord, SysSocket, ObexTransportSet::Iterator, ObexOperationId, ObexObject, ObexHeaderList::ConstIterator, ObexHeader, ObexChannel, ObexBuffer, PagingMapEntry, Bitmap, StartUp::Data, BtObexServiceTable::ServiceInfo, BtSvrServiceRecord, BtSvrServiceAttribute, BtSvrDataElement, BtServiceVerifyResult, BtSddbServiceRecord, BtSddbServiceAttribute, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeByteBlockType, BtSddbDeBaseCType, BtSddbDataElement, SimpleMap< TKey, TValue >::Iterator, NiSharedPtr< X >, Date, RtStreamingBuffer, Fraction, SmsContext, PdpContext::Address, MptyCallHdl, CallHdlBase, CallHdl, UserDataHeader, Tpdu, SimAlphaIdentifier, ParameterIndicator, MessageIdentifierRange, InformationElement, DataCodingSchemeRange, BaseInformationElement, RootStorageDeviceIterator, StorageDeviceIterator, Pathname, DirectoryIterator, MmCallHdl, ClientId, TpduHeaderInformation, SimMexeCertificate, MexeDescriptor
  • IsValidAddress() : HeapManager
  • IsValidContext() : ObexServerOppImpl, ObexServerDispatcher, ObexEventHandler, ObexClientOppImpl, ObexClientDispatcher
  • IsValidHugeAddress() : HeapManager
  • IsValidPortPtr() : ObexClientDispatcher
  • IsValidSequence() : KeySequenceCandidate
  • IsVerticalCentered() : TextBox, ItemRendererProperties
  • IsVibratorOn() : VibratorDevice, Audio, AudioVibratorDevice
  • IsVisible() : DrawableObject, Caret, Indicator
  • IsVoiceMsgWaiting() : SimCphsHandler
  • IsVolume() : RamFileObj
  • IsWCharToGsm7Possible() : DataCoding
  • IsWhiteSpace() : Os
  • IsWritable() : ObexObject
  • IsWStringDataCached() : Provider, AbstractDelegationProvider, PbBaseProvider
  • IsZero() : DateTime::Persist, Date
  • Italian : LanguageManager, DataCodingScheme
  • Italic : TextFormat
  • italic_bold_glyph_index_tab : FontRes
  • italic_glyph_index_tab : FontRes
  • italic_index : tagFont
  • Item() : Item
  • ITEM_COUNT_MSG : TestWriter
  • ITEM_SELECTED_MSG : TestWriter
  • item_type : MenuPool::FeatureItemContainerContentTableEntry
  • ItemBox() : ItemBox
  • ItemBoxClassType : GuiObjectFactory
  • ItemBoxView() : ItemBoxView
  • ItemClassType : GuiObjectFactory
  • ItemContainer() : ItemContainer
  • ItemContainerClassType : GuiObjectFactory
  • ItemContainerText : MenuProperties
  • ItemContProp : GuiObjectFactory
  • ItemCount() : MenuTextPtrArrayIterator, MenuTextIterator
  • ItemGrid() : ItemGrid
  • ItemGridClassType : GuiObjectFactory
  • ItemIconIdentifierListTag : Tlv
  • ItemIdentifierTag : Tlv
  • ItemLabel() : ItemLabel
  • ItemLabelView() : ItemLabelView
  • ItemMenu() : ItemMenu
  • ItemMenuClassType : GuiObjectFactory
  • ItemMenuWindowClassType : GuiObjectFactory
  • ItemObj() : ItemObj
  • ItemProp : GuiObjectFactory
  • ItemPropertiesChangedMsg() : ItemPropertiesChangedMsg
  • ItemPropertyId : Item, AbstractItemContainer
  • ItemRendererAnimTypeProp : GuiObjectFactory
  • ItemRendererDisplayTypeProp : GuiObjectFactory
  • ItemRendererProp : GuiObjectFactory
  • ItemRendererProperties() : ItemRendererProperties
  • ItemRendererPropertiesAnimType : GuiObjectFactory
  • ItemRendererPropertiesChangedMsg() : ItemRendererPropertiesChangedMsg
  • ItemRendererPropertiesClassType : GuiObjectFactory
  • ItemRendererPropertiesDisplayType : GuiObjectFactory
  • ItemRendererPropertiesType : GuiObjectFactory
  • ItemSelected() : SimTkHandler
  • ItemsNaiTag : Tlv
  • ItemsProp : GuiObjectFactory
  • ItemStyle : AbstractItemRenderer
  • ItemTag : Tlv
  • ItemText : MenuProperties
  • ItemTextType : ContextFeature
  • ItemTree() : ItemTree
  • ItemTreeClassType : GuiObjectFactory
  • ItemType : EditorItemNode, ContextFeature
  • itemType : MenuPool
  • itemTypeContextFeatureItem : MenuPool
  • itemTypeFeatureItem : MenuPool
  • itemTypeFeatureItemContainer : MenuPool
  • itemTypeFixedContextFeatureItem : MenuPool
  • itemTypeNone : MenuPool
  • itemTypePropertyItem : MenuPool
  • Iterate() : ObexServerMngr
  • iterations : Led::Stream, Led::Frame
  • iterator : WbxmlVector< T >
  • Iterator : ObexTransportSet::Iterator, DeviceManager::Iterator, Vector< T >::Iterator, SimpleMap< TKey, TValue >::Iterator, Pathname::Iterator, DeviceManager, Vector< T >, SimpleMap< TKey, TValue >
  • IteratorInteriorMetaData : RegEncoderDecoder
  • IteratorLeafMetaData : RegEncoderDecoder
  • IteratorNodeType : RegEncoderDecoder
  • IteratorType : RegEncoderDecoder
  • IteratorUri : RegEncoderDecoder
Generated on Wed Jan 25 00:54:22 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • p1 : UmtsMeasEvalParam
  • p2 : UmtsMeasEvalParam
  • p_sc : UmtsRrcScellParam
  • Packed : FunctionalityIndicator
  • PackedTimePeriod() : PackedTimePeriod
  • PacketFilter() : PdpContext::PacketFilter
  • PackUserInput() : SimGetInputOptions
  • PackWcharsToSeptets() : DataCoding
  • padding : tagCustFileData, tagLdbData, tagFontFamily, tagLanguage, tagDataPackHeader, tagCustomizationPack, RamFileInfo, FatFileInfo, fs_stat
  • padding2 : tagFont
  • padding3 : tagFont
  • PaddingMethod : AesCrypt
  • PaddingMethod2630 : AesCrypt
  • PaddingMethodNone : AesCrypt
  • PadProtocol : PdpContext
  • PageDown : AbstractGrid
  • PageUp : AbstractGrid
  • PaintDc() : PaintDc
  • Pair : SimpleMap< TKey, TValue >
  • PaletteFormat : PngEncoder::EncodingParameters
  • Pan() : SvgPlayer, SvgImage
  • Panel() : Panel
  • PanelAlignment : Desktop
  • PanelOnBottom : Desktop
  • PanelOnLeft : Desktop
  • PanelOnRight : Desktop
  • PanelOnTop : Desktop
  • PanelPassthroughRequest() : BtAvrcpOperationService
  • PanelView() : PanelView
  • PaneObject() : PaneObject
  • Pap : PdpContext::Authentication
  • ParagraphCompoundItem() : ParagraphCompoundItem
  • ParagraphItem : EditorItemNode
  • ParagraphMarker() : ParagraphMarker
  • Param1 : RingerAudioDevice::StartParam, SimLaunchBrowserPromptReq_s
  • Param2 : RingerAudioDevice::StartParam, SimLaunchBrowserPromptReq_s
  • Param3 : RingerAudioDevice::StartParam, SimLaunchBrowserPromptReq_s
  • Parameter : BtJsr82Url
  • ParameterIndicator() : ParameterIndicator
  • ParameterLimits : Camera
  • ParameterType : VideoDecoder, AudioEncoder, AudioDecoder
  • ParamPairList : HttpRequest
  • ParamType : AtResponseParameter
  • ParentArea : DrawableObject
  • ParentAreaProp : GuiObjectFactory
  • ParentAreaType : GuiObjectFactory
  • ParentItemText : MenuProperties
  • Parity : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • ParityEven : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • ParityEvent : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • ParityMark : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • ParityNone : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • ParityOdd : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • ParitySpace : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • parm1 : AudioMapiManager::MapiCommandType
  • parm2 : AudioMapiManager::MapiCommandType
  • parm3 : AudioMapiManager::MapiCommandType
  • parm4 : AudioMapiManager::MapiCommandType
  • parm5 : AudioMapiManager::MapiCommandType
  • parm6 : AudioMapiManager::MapiCommandType
  • parm7 : AudioMapiManager::MapiCommandType
  • Parse() : EmsIeParser, AbstractIMelodyParser, XMLParser, MultipartParser, XmlParserRel, DrmRelParser
  • ParseDateString() : XmlParserRel
  • ParseInterval() : XmlParserRel
  • ParseNumber() : InputAction
  • ParseTarget() : ObexUrlStrParser
  • ParseType : GuiObjectFactory, CTResourcePack
  • ParseWbxmlRel() : DrmRelParser
  • ParseXmlRel() : DrmRelParser
  • PartialContent : BtObexResponseCode
  • Partition : MimeTypeTable::Partition, MimeTypeTable
  • PassBackFocusMsg() : MsgQueue
  • Passed : SocketTestT
  • password : PasswordReceivedArg
  • PasswordChangeSsAction() : PasswordChangeSsAction
  • PasswordEditor() : PasswordEditor
  • PasswordEditorClassType : GuiObjectFactory
  • PasswordInquiryMsg() : PasswordInquiryMsg
  • PasswordPropertyDescriptorClassType : GuiObjectFactory
  • PasswordReceivedMsg() : PasswordReceivedMsg
  • PasswordRejectedMsg() : PasswordRejectedMsg
  • Path : Path, PathProfile
  • path : RingerAudioDevice::StartParam, HostIterStatType, FatFindData, dstat
  • Pathname : Pathname, Pathname::ReverseIterator, Pathname::Iterator
  • PathProfile() : PathProfile
  • patternName : HostIterStatType
  • Pause : MediaPlayer, ResultWinBase
  • PauseApiCompletionMsg : MediaManager
  • PausedState : MediaRecorder, MediaPlayer
  • PauseRecord() : VoiceMemoWin, VoiceMemoRecordWin, MediaRecorder
  • PauseRecording() : VoiceMemoApp
  • PauseVideoCapture() : VideoCamera
  • PAuthenticate : BtJsr82Url
  • PAuthorize : BtJsr82Url
  • payload_obj : RegEncoderDecoder::Payload
  • PayloadDataItem : RegEncoderDecoder
  • PayloadInteger : RegEncoderDecoder
  • PayloadIteratorObj : RegEncoderDecoder
  • PayloadType : RegEncoderDecoder
  • PbAbstractWin : PbAbstractWin, PhonebookApp
  • PbAction() : PbAction
  • PbAdvAddEditEntry() : PbAdvAddEditEntry
  • PbAdvDataHandler() : PbAdvDataHandler
  • PbAdvDetailAction() : PbAdvDetailAction
  • PbAdvDetails() : PbAdvDetails
  • PbAlphaTagRequestMsg() : PbAlphaTagRequestMsg
  • PbBaseProvider() : PbBaseProvider
  • PbBaseWin() : PbBaseWin
  • pbc_hidden_info : T_PB_RECORD, T_PB_CHANGED_FIELD
  • pbcch_present : GprsParam
  • PbCopyHandler() : PbCopyHandler
  • PbCountIndArg() : PbCountIndArg
  • PbCountReqArg() : PbCountReqArg
  • PbDataHandler() : PbDataHandler
  • PbDetailAction() : PbDetailAction
  • PbDetailEditBox() : PbDetailEditBox
  • PbDetailListBox() : PbDetailListBox
  • PbDetailListBoxModel() : PbDetailListBoxModel
  • PbDetailProvider() : PbDetailProvider
  • PbDetails() : PbDetails
  • PbEntryReadIndArg() : PbEntryReadIndArg
  • PbEntryReadReqArg() : PbEntryReadReqArg
  • PbEntryRequestMsg() : PbEntryRequestMsg
  • PbEntryShowAction() : PbEntryShowAction
  • PbEntryUpdIndArg() : PbEntryUpdIndArg
  • PbEntryUpdReqArg() : PbEntryUpdReqArg
  • PbFfsNameHandler() : PbFfsNameHandler
  • PbFfsNumberHandler() : PbFfsNumberHandler
  • PbInfoReadIndArg() : PbInfoReadIndArg
  • PbInfoReadReqArg() : PbInfoReadReqArg
  • PbLazySynchronizer() : PbLazySynchronizer
  • PbManualSynchronizer() : PbManualSynchronizer
  • PbMergeProvider() : PbMergeProvider
  • PbNameEditBox() : PbNameEditBox
  • PbNameFilterProvider() : PbNameFilterProvider
  • PbNameHandler() : PbNameHandler
  • PbNameNumberProvider() : PbNameNumberProvider
  • PbNameProvider() : PbNameProvider
  • PbNextFreeIdRecord() : PbNextFreeIdRecord
  • PbNumberFilterProvider() : PbNumberFilterProvider
  • PbNumberHandler() : PbNumberHandler
  • PbNumberProvider() : PbNumberProvider
  • PbNumberRecord() : PbNumberRecord
  • PbNvRamNameHandler() : PbNvRamNameHandler
  • PbNvRamNumberHandler() : PbNvRamNumberHandler
  • PbPhoneNumberPrompt() : PbPhoneNumberPrompt
  • PbProvColListBoxModel() : PbProvColListBoxModel
  • PbProviderListener() : PbProviderListener
  • PbProvListBox() : PbProvListBox
  • PbProvListBoxModel() : PbProvListBoxModel
  • PbRecord() : PbRecord
  • PbRecordHandler() : PbRecordHandler
  • PbRecordProvider() : PbRecordProvider
  • PbSecuredAction() : PbSecuredAction
  • PbSelectGroup() : PbSelectGroup
  • PbSelectNoType() : PbSelectNoType
  • PbSelectNumberWin() : PbSelectNumberWin
  • PbSimProvider() : PbSimProvider
  • PbSizeRequestMsg() : PbSizeRequestMsg
  • PbSortedProvider() : PbSortedProvider
  • PbSynchronizer() : PbSynchronizer
  • PbToggleAction() : PbToggleAction
  • PC2MobileMsg : RegEncoderDecoder
  • PCMAudioPlayer : StreamAudioReference
  • PCMDeviceID : AudioDeviceManager
  • PcmDspFormat : StreamAudioReference
  • PdpContext : PdpContextManager, PdpContext, PdpContext::PacketFilter
  • PdpContext_ActivationStatus : PdpContext::ActivationStatus
  • PdpContext_Address : PdpContext::Address
  • PdpContext_Authentication : PdpContext::Authentication
  • PdpContext_PacketFilter : PdpContext::PacketFilter
  • PdpContext_QualityOfService : PdpContext::QualityOfService
  • PdpContextActivationStatusMsg() : PdpContextActivationStatusMsg
  • PdpContextControl() : PdpContextControl
  • PdpContextErrorCause() : EnumTranslationTable
  • PdpContextManager : PdpContextManager, PdpContextControl, PdpContext
  • PdpContextManager_AttachStatus : PdpContextManager::AttachStatus
  • PdpContextManagerControl() : PdpContextManagerControl
  • PdpContextManagerState() : EnumTranslationTable
  • PdpContextOrigin() : EnumTranslationTable
  • PdpContextSignalProcessor : PdpContextManager, PdpContext
  • PdpContextState() : EnumTranslationTable
  • pdu : TpduNode, TpduConc
  • pdu_no : TpduConc
  • PeakRate : PdpContext::QualityOfService
  • PeakRate128K : PdpContext::QualityOfService
  • PeakRate16K : PdpContext::QualityOfService
  • PeakRate1K : PdpContext::QualityOfService
  • PeakRate256K : PdpContext::QualityOfService
  • PeakRate2K : PdpContext::QualityOfService
  • PeakRate32K : PdpContext::QualityOfService
  • PeakRate4K : PdpContext::QualityOfService
  • PeakRate64K : PdpContext::QualityOfService
  • PeakRate8K : PdpContext::QualityOfService
  • PeakRateReserved : PdpContext::QualityOfService
  • PeakRateSubscribed : PdpContext::QualityOfService
  • Peek() : FileInputStream, RegBlobObject, BlobObject
  • Pen() : Pen
  • penalty_time : CellParam
  • PEncrypt : BtJsr82Url
  • PendingIndication : SmsIndicationState
  • PenDownMsg() : PenDownMsg
  • PenStyle : Pen
  • PenUpMsg() : PenUpMsg
  • Percent : Layouter, GridLayout
  • PerformConnectControllerCall() : BtConnectRequest
  • PerformDisconnectControllerCall() : BtDisconnectRequest
  • PerformExecutionCallback() : BtController
  • PeriodCount : AbstractSmsApp
  • PeriodData : AbstractSmsApp
  • Peripheral : Led
  • PermanentError : ShortMessageStatus
  • Persist : PathProfile::Persist, IpAddr
  • PersistDataConnProfile : PersistDataConnProfile, DataConnProfile
  • pext : FatFindData, dstat
  • pfile_in_zip_read : JarFileStatusInfo, JarBinDataStatusInfo
  • PFrame : VideoEncoder
  • phone_no : CallDisconnectingArg
  • phone_number : Rdn
  • PhonebookApp() : PhonebookApp
  • PhonebookRenumberedMsg() : PhonebookRenumberedMsg
  • PhonebookWin() : PhonebookWin
  • phoneno_type : PbNumberRecord::Persist
  • PhoneNumber : PhoneNumber, InputMapper
  • PhoneNumberInputMapper() : PhoneNumberInputMapper
  • PhoneNumberJoinRule() : PhoneNumberJoinRule
  • PhoneNumberMatchRule() : PhoneNumberMatchRule
  • PhoneNumberMergeProvider() : PhoneNumberMergeProvider
  • PhoneNumberMode : EditBox
  • PhoneNumberType : ContextFeature
  • PIC_OUTPUT_MSG : TestWriter
  • PictureFrameFilter : Camera
  • PidInterworking() : EnumTranslationTable
  • PIHandler() : XMLParser
  • PinAction() : PinAction
  • PinDisableIndArg() : PinDisableIndArg
  • PinDisableReqArg() : PinDisableReqArg
  • PinEnableIndArg() : PinEnableIndArg
  • PinEnableReqArg() : PinEnableReqArg
  • pinyin : ChineseQuickSortProvider
  • PinyinBoxCharsId : AbstractPredictiveInputBox
  • PinyinBoxNumbersId : AbstractPredictiveInputBox
  • Pixel : Layouter, GridLayout
  • PlaceAllActiveOnHold : CallSsAction
  • PlaceAllActiveOnHoldExceptSpecificCall : CallSsAction
  • Planes2 : VirtualDisplay
  • Planes4 : VirtualDisplay
  • Planes8 : VirtualDisplay
  • PlanesMode() : DisplayConfig
  • Play() : SoundItem, Sound, PreparedSound, Melody, MP3AudioPlayer, MmfPlayer, AudioDeviceManager, MapiAudioPlayer, SvgPlayer, MediaPlayer
  • Play_Allocate() : DwdDevice, AudioVibratorDevice, MapiAudioPlayer
  • Play_Allocate_DWD() : DwdDevice
  • play_count : ToneAudioDevice::StartParam, RingerAudioDevice::StartParam
  • PlayApiCompletionMsg : MediaManager
  • PlayingState : MediaPlayer
  • PlaySelectedSound() : SoundBrowserWin
  • PlaySound() : AudioContext
  • PlayTemplate() : VrHandler
  • PlayToneReqArg() : PlayToneReqArg
  • PlayToneRspArg() : PlayToneRspArg
  • plmn : CellParam, NeighbourCell, Lai
  • Plmn() : Plmn
  • plmn_array : EquivPlmnLists, BlerTrchInfoList
  • plmn_id : UmtsRrcScellParam
  • PlmnDispatcher() : PlmnDispatcher
  • PlmnHandler() : PlmnHandler
  • PlmnInfoReqArg() : PlmnInfoReqArg
  • PlmnListAbortArg() : PlmnListAbortArg
  • PlmnListCnfArg() : PlmnListCnfArg
  • PlmnListEntry() : PlmnListEntry
  • PlmnListRejArg() : PlmnListRejArg
  • PlmnListReqArg() : PlmnListReqArg
  • PlmnNotAllowed : PdpContext
  • PlmnOperatorAssociationsMessageBegin : MessageIdentifier
  • PlmnOperatorAssociationsMessageEnd : MessageIdentifier
  • PlmnOperatorSpecificRangeBegin : MessageIdentifier
  • PlmnOperatorSpecificRangeEnd : MessageIdentifier
  • PlmnProvider() : PlmnProvider
  • PlmnRatDispatcher() : PlmnRatDispatcher
  • PlmnScanDispatcher() : PlmnScanDispatcher
  • PlmnScanFinishedMsg() : PlmnScanFinishedMsg
  • PlmnWideNormal : Cbs::SerialNumber
  • plongFileName : FatFindData, dstat
  • plugin : AtlApplicationPluginStartup::Table
  • Plus1Hour : TimeZone
  • Plus2Hours : TimeZone
  • PMaster : BtJsr82Url
  • pmom : FatFindData, dstat
  • pname : FatFindData, dstat
  • PName : BtJsr82Url
  • pNext : comm_user_cert, comm_root_cert
  • PngDecoder() : PngDecoder
  • PngEncoder() : PngEncoder
  • PngEncodingThreadlet() : PngEncodingThreadlet
  • PngFormat : CamWin32
  • PngImage() : PngImage
  • PngLibraryFreeFunction() : PngDecoder
  • PngLibraryMallocFunction() : PngDecoder
  • PngLibraryReadFunction() : PngDecoder
  • PnnEntry() : PnnEntry
  • pobj : FatFindData, dstat
  • Point() : Point
  • Poke() : RegBlobObject, BlobObject
  • Polish : LanguageManager, DataCodingScheme
  • Pop() : FifoLinkedList< T >
  • PopAll() : EmzUtils::Queue< T >
  • PopBack() : EmzUtils::Queue< T >, BtDeviceList, Vector< T >, LinkedListBase, TextIconPairArray, DeletedNodeList
  • PopFront() : EmzUtils::Queue< T >, BtDeviceList, LinkedListBase
  • PopUp : MenuProperties
  • PortHeaderInformation() : PortHeaderInformation
  • PortNumber : Iana
  • PortService : WapProfile
  • Portuguese : LanguageManager, DataCodingScheme
  • pos : MdhWaitIndicator
  • pos_in_central_dir : JarFileStatusInfo, JarBinDataStatusInfo
  • pos_in_zipfile : FileInReadStatusInfo, BinDataInReadStatusInfo
  • pos_local_extrafield : FileInReadStatusInfo, BinDataInReadStatusInfo
  • PositionHint : TabButton
  • PositionIndicator() : PositionIndicator
  • PositionIndicatorArrowBoxControl : CTResourcePack
  • PositionIndicatorArrowHeight : CTResourcePack
  • PositionIndicatorBarControl : CTResourcePack
  • PositionIndicatorClassType : GuiObjectFactory
  • PositionIndicatorControl : CTResourcePack
  • PositionIndicatorDrawArrows : CTResourcePack
  • PositionIndicatorEnabledProp : GuiObjectFactory
  • PositionIndicatorOrientationType : GuiObjectFactory
  • PositionIndicatorView() : PositionIndicatorView
  • PositionIndicatorWidth : CTResourcePack
  • PositionMethodError : SsErrorCode
  • PositionSeparator : OptionalConfigBase
  • PositionType : GuiObjectFactory
  • PosProp : GuiObjectFactory
  • Post() : MessageRouter, Message, Application
  • post_message_func : SignalMapTableEntry
  • PostAbortResponse() : LcsCommonSignalProcessor
  • PostAcmMaxReadInd() : CommonSignalProcessor
  • PostAcmMaxUpdInd() : CommonSignalProcessor
  • PostAcmReadInd() : CommonSignalProcessor
  • PostAcmUpdInd() : CommonSignalProcessor
  • PostAocInd() : CommonSignalProcessor
  • PostAtAccessoryRegisterReq() : CommonSignalProcessor
  • PostAtAlphaTagReq() : CommonSignalProcessor
  • PostAtGenericCmdReq() : CommonSignalProcessor
  • PostAtKeyReq() : CommonSignalProcessor
  • PostAtPbListReq() : CommonSignalProcessor
  • PostAtPbSelectReq() : CommonSignalProcessor
  • PostAttachAllowedInd() : CommonSignalProcessor
  • PostAttachCnf() : CommonSignalProcessor
  • PostAttachRej() : CommonSignalProcessor
  • PostAudDriverRsp() : CommonSignalProcessor
  • PostAudioUserDefinedMessage() : AudioDeviceManager
  • PostAutoCallRestrictInd() : CommonSignalProcessor
  • PostBandCnf() : CommonSignalProcessor
  • PostBandRej() : CommonSignalProcessor
  • PostBatteryLoadLevelInd() : ChargerSignalProcessor
  • PostBdnInd() : CommonSignalProcessor
  • PostBrowserTermRes() : CommonSignalProcessor
  • PostCallControlSetupInd() : CommonSignalProcessor
  • PostCallControlSsInd() : CommonSignalProcessor
  • PostCallControlUssdInd() : CommonSignalProcessor
  • PostCallDeflectionInd() : CommonSignalProcessor
  • PostCallDiscInd() : CommonSignalProcessor
  • PostCallHoldCnf() : CommonSignalProcessor
  • PostCallHoldRej() : CommonSignalProcessor
  • PostCallProgressInd() : CommonSignalProcessor
  • PostCallRelatedSsCnf() : CommonSignalProcessor
  • PostCallRelatedSsRej() : CommonSignalProcessor
  • PostCallRelCnf() : CommonSignalProcessor
  • PostCallRelInd() : CommonSignalProcessor
  • PostCbmiReadInd() : CommonSignalProcessor
  • PostCbmirReadInd() : CommonSignalProcessor
  • PostCbmirUpdInd() : CommonSignalProcessor
  • PostCbmiUpdInd() : CommonSignalProcessor
  • PostCbsLimitInd() : CommonSignalProcessor
  • PostCbsNewDataInd() : CommonSignalProcessor
  • PostCbsStartCnf() : CommonSignalProcessor
  • PostCbsStartRej() : CommonSignalProcessor
  • PostCbsStopCnf() : CommonSignalProcessor
  • PostCbsStopRej() : CommonSignalProcessor
  • PostCcpReadInd() : CommonSignalProcessor
  • PostCcpUpdInd() : CommonSignalProcessor
  • PostCellInfoInd() : CommonSignalProcessor
  • PostCfuDataInd() : CommonSignalProcessor
  • PostChargeInd() : CommonSignalProcessor
  • PostChargeUnitsInd() : CommonSignalProcessor
  • PostChargingBatteryInd() : ChargerSignalProcessor
  • PostChargingPausedInd() : ChargerSignalProcessor
  • PostChargingResumedInd() : ChargerSignalProcessor
  • PostChv1DisableInd() : CommonSignalProcessor
  • PostChv1EnableInd() : CommonSignalProcessor
  • PostChvChangeInd() : CommonSignalProcessor
  • PostChvRefreshInd() : CommonSignalProcessor
  • PostChvUnblockInd() : CommonSignalProcessor
  • PostChvVerifyInd() : CommonSignalProcessor
  • PostClearBlacklistCnf() : CommonSignalProcessor
  • PostCmiReadInd() : CommonSignalProcessor
  • PostConnectionInd() : CommonSignalProcessor
  • PostCphsCfufReadInd() : CommonSignalProcessor
  • PostCphsCfufUpdInd() : CommonSignalProcessor
  • PostCphsCspReadInd() : CommonSignalProcessor
  • PostCphsCspUpdInd() : CommonSignalProcessor
  • PostCphsIstReadInd() : CommonSignalProcessor
  • PostCphsOnmReadInd() : CommonSignalProcessor
  • PostCphsOnsReadInd() : CommonSignalProcessor
  • PostCphsVmwfReadInd() : CommonSignalProcessor
  • PostCphsVmwfUpdInd() : CommonSignalProcessor
  • PostDataConnControlMsg() : DataConn
  • PostDetachCnf() : CommonSignalProcessor
  • PostDiagnosticInd() : CommonSignalProcessor
  • PostDisplayTextReq() : CommonSignalProcessor
  • PostDtmfBufferClearedInd() : CommonSignalProcessor
  • PostEccListInd() : CommonSignalProcessor
  • PostEctCnf() : CommonSignalProcessor
  • PostEmptyBatteryInd() : ChargerSignalProcessor
  • PostEndSimToolkitInd() : CommonSignalProcessor
  • PostEngineeringModeControlResponse() : CommonSignalProcessor
  • PostExtProactiveCmdInd() : CommonSignalProcessor
  • PostFdnInd() : CommonSignalProcessor
  • PostFocusTransferMsg() : MessageRouter
  • PostFromStackMsg() : StackMsgProcessor
  • PostGetInkeyReq() : CommonSignalProcessor
  • PostGetInputReq() : CommonSignalProcessor
  • PostGetTermProfileCnfInd() : CommonSignalProcessor
  • PostGprsClassInd() : CommonSignalProcessor
  • PostHomezoneInd() : CommonSignalProcessor
  • PostIconDescReadInd() : CommonSignalProcessor
  • PostImageReadInd() : CommonSignalProcessor
  • PostImeiReadInd() : CommonSignalProcessor
  • PostInfoMsg() : PsdDataConn, DataConn, CsdDataConn
  • PostIpdsReleaseCnf() : DataCallSignalProcessor
  • PostIpdsReleaseInd() : DataCallSignalProcessor
  • PostIpdsSetupCnf() : DataCallSignalProcessor
  • PostIpdsSetupRej() : DataCallSignalProcessor
  • PostItemChangedMsg() : SyncMLManager
  • PostKbdtControl() : CommonSignalProcessor
  • PostKeyMsg() : Keyboard
  • PostLanguageNotificationInd() : CommonSignalProcessor
  • PostLanguageSettingReq() : CommonSignalProcessor
  • PostLaunchBrowserPromptReq() : CommonSignalProcessor
  • PostLaunchBrowserReq() : CommonSignalProcessor
  • PostLedStreamStatus() : LedSignalProcessor
  • PostLocationError() : SaSignalProcessor
  • PostLowBatteryInd() : ChargerSignalProcessor
  • PostMdhDeregistrationCnf() : CommonSignalProcessor
  • PostMdhMakeViewCnf() : CommonSignalProcessor
  • PostMdhNewMessageInd() : CommonSignalProcessor
  • PostMdhNewStatusReportInd() : CommonSignalProcessor
  • PostMdhRegistrationCnf() : CommonSignalProcessor
  • PostMdhRemoveViewCnf() : CommonSignalProcessor
  • PostMdhSetConfigCnf() : CommonSignalProcessor
  • PostMdhSetStorageCnf() : CommonSignalProcessor
  • PostMdhSmsConcRefNumInd() : CommonSignalProcessor
  • PostMdhSmsDeletionInd() : CommonSignalProcessor
  • PostMdhSmsExtendedDataInd() : CommonSignalProcessor
  • PostMdhSmsInitFinishedInd() : CommonSignalProcessor
  • PostMdhSmsReadInd() : CommonSignalProcessor
  • PostMdhSmsRefreshInd() : CommonSignalProcessor
  • PostMdhSmsReportReadInd() : CommonSignalProcessor
  • PostMdhSmsStatusInd() : CommonSignalProcessor
  • PostMdhSmsStorageRefreshInd() : CommonSignalProcessor
  • PostMdhSmsTransmitInd() : CommonSignalProcessor
  • PostMdhSmsTransmitStartInd() : CommonSignalProcessor
  • PostMdhSmsTransmitStopInd() : CommonSignalProcessor
  • PostMdhSmsUpdStatusInd() : CommonSignalProcessor
  • PostMdhSmsUpdStatusRefreshInd() : CommonSignalProcessor
  • PostMdhSmsWaitingInd() : CommonSignalProcessor
  • PostMdhSmsWriteCnf() : CommonSignalProcessor
  • PostMeasurementData() : GltpSignalProcessor
  • PostMenuSelectionRej() : CommonSignalProcessor
  • PostMessage() : ExternalCommunicationHandler, SignalMapTable, SignalHandler
  • PostMinuteTickInd() : RtcSignalProcessor
  • PostMnInformationInd() : CommonSignalProcessor
  • PostMocAlertInd() : CommonSignalProcessor
  • PostMocSetupAcc() : CommonSignalProcessor
  • PostMocSetupCnf() : CommonSignalProcessor
  • PostMocSetupRej() : CommonSignalProcessor
  • PostMolrResult() : SaSignalProcessor, LcsSignalProcessor
  • PostMptyCnf() : CommonSignalProcessor
  • PostMsg() : MainHandler
  • PostMsgHook : MessageRouter
  • PostMsgHookFn : MessageRouter
  • PostMtcAcceptRej() : CommonSignalProcessor
  • PostMtcConfInd() : CommonSignalProcessor
  • PostMtcSetupCompl() : CommonSignalProcessor
  • PostMtcSetupInd() : CommonSignalProcessor
  • PostMtlrIndReceived() : LcsSignalProcessor
  • PostNotification() : DataControl
  • PostNotifyInd() : CommonSignalProcessor
  • PostNRegStateInd() : CommonSignalProcessor
  • PostODyn2ReadInd() : CommonSignalProcessor
  • PostODyn2UpdInd() : CommonSignalProcessor
  • PostODynReadInd() : CommonSignalProcessor
  • PostODynUpdInd() : CommonSignalProcessor
  • PostOmBandStatusCnf() : CommonSignalProcessor
  • PostOmControlInd() : CommonSignalProcessor
  • PostOmMultiSlotCnf() : CommonSignalProcessor
  • PostOmMultiSlotRej() : CommonSignalProcessor
  • PostOmRatChangeCnf() : CommonSignalProcessor
  • PostOmRatChangeInd() : CommonSignalProcessor
  • PostPbCountInd() : CommonSignalProcessor
  • PostPbEntryReadInd() : CommonSignalProcessor
  • PostPbEntryUpdInd() : CommonSignalProcessor
  • PostPbInfoReadInd() : CommonSignalProcessor
  • PostPinDisableInd() : CommonSignalProcessor
  • PostPinEnableInd() : CommonSignalProcessor
  • PostPlayToneReq() : CommonSignalProcessor
  • PostPlmnListCnf() : CommonSignalProcessor
  • PostPlmnListRej() : CommonSignalProcessor
  • PostPowerDownCnf() : CommonSignalProcessor
  • PostPowerDownInd() : CommonSignalProcessor
  • PostPrefExtLangReadInd() : CommonSignalProcessor
  • PostPrefExtLangUpdInd() : CommonSignalProcessor
  • PostPrefLangReadInd() : CommonSignalProcessor
  • PostPrefLangUpdInd() : CommonSignalProcessor
  • PostPuctReadInd() : CommonSignalProcessor
  • PostPuctUpdInd() : CommonSignalProcessor
  • PostRedialInd() : CommonSignalProcessor
  • PostRedialQueryInd() : CommonSignalProcessor
  • PostRedialSetupInd() : CommonSignalProcessor
  • PostRedialStatusInd() : CommonSignalProcessor
  • PostRedialStopInd() : CommonSignalProcessor
  • PostRegStateInd() : CommonSignalProcessor
  • PostRemoveChargerInd() : ChargerSignalProcessor
  • PostResponse() : ObexDataServer
  • PostRtcEventInd() : RtcSignalProcessor
  • PostRtcNotValidInd() : RtcSignalProcessor
  • PostSelectItemReq() : CommonSignalProcessor
  • PostSetTermProfileCnfInd() : CommonSignalProcessor
  • PostSetTermProfileRejInd() : CommonSignalProcessor
  • PostSetupEventReq() : CommonSignalProcessor
  • PostSetupIdleModeTextReq() : CommonSignalProcessor
  • PostSetupMenuReq() : CommonSignalProcessor
  • PostSignalStrengthLevelInd() : CommonSignalProcessor
  • PostSimErrorInd() : CommonSignalProcessor
  • PostSimFileInfoInd() : CommonSignalProcessor
  • PostSimFullAccessInd() : CommonSignalProcessor
  • PostSimGenericInd() : CommonSignalProcessor
  • PostSimInfoInd() : CommonSignalProcessor
  • PostSimInitInd() : CommonSignalProcessor
  • PostSimLockStatusInd() : CommonSignalProcessor
  • PostSimMccMncInd() : CommonSignalProcessor
  • PostSimModifyLockInd() : CommonSignalProcessor
  • PostSimMruPropertyRefreshInd() : CommonSignalProcessor
  • PostSimMruPropertyUpdCnf() : CommonSignalProcessor
  • PostSimRefreshInd() : CommonSignalProcessor
  • PostSimTkCallSetupInd() : CommonSignalProcessor
  • PostSimTkInterfaceInd() : CommonSignalProcessor
  • PostSimTkRefreshCnfReq() : CommonSignalProcessor
  • PostSimTkRefreshNewReq() : CommonSignalProcessor
  • PostSimTkRefreshQueryReq() : CommonSignalProcessor
  • PostSimTkRefreshReq() : CommonSignalProcessor
  • PostSimTkRefreshResetReq() : CommonSignalProcessor
  • PostSimTkResetCnf() : CommonSignalProcessor
  • PostSimTkResetCnfReq() : CommonSignalProcessor
  • PostSimTkRunAtCmdInfoInd() : CommonSignalProcessor
  • PostSimTkSendDtmfEndInd() : CommonSignalProcessor
  • PostSimTkSendDtmfInd() : CommonSignalProcessor
  • PostSimTkSmsPpInd() : CommonSignalProcessor
  • PostSimTkSsInd() : CommonSignalProcessor
  • PostSmsCapacityAvailable() : CommonSignalProcessor
  • PostSmsCapacityExceeded() : CommonSignalProcessor
  • PostSmsControlInd() : CommonSignalProcessor
  • PostSmsGetMoreMessageStatusInd() : CommonSignalProcessor
  • PostSmsrReadInd() : CommonSignalProcessor
  • PostSmsrUpdInd() : CommonSignalProcessor
  • PostSmsSendCnf() : CommonSignalProcessor
  • PostSmsSendRej() : CommonSignalProcessor
  • PostSocketControlMsg() : DataConn
  • PostSpnReadInd() : CommonSignalProcessor
  • PostSsBarringInd() : CommonSignalProcessor
  • PostSsBeginAcc() : CommonSignalProcessor
  • PostSsCauseInd() : CommonSignalProcessor
  • PostSsCcbsReCallInd() : CommonSignalProcessor
  • PostSsCcbsResultInd() : CommonSignalProcessor
  • PostSsCcbsStatusInd() : CommonSignalProcessor
  • PostSsClientRej() : CommonSignalProcessor
  • PostSsDataInd() : CommonSignalProcessor
  • PostSsEndInd() : CommonSignalProcessor
  • PostSsErrInd() : CommonSignalProcessor
  • PostSsFacilityRej() : CommonSignalProcessor
  • PostSsForwardingInd() : CommonSignalProcessor
  • PostSsForwcheckInd() : CommonSignalProcessor
  • PostSsGetPasswordInd() : CommonSignalProcessor
  • PostSsGetPasswordRej() : CommonSignalProcessor
  • PostSsInterrogateInd() : CommonSignalProcessor
  • PostSsNotifyInd() : CommonSignalProcessor
  • PostSsPasswordInd() : CommonSignalProcessor
  • PostSsRej() : CommonSignalProcessor
  • PostSsRetResInd() : CommonSignalProcessor
  • PostSstReadInd() : CommonSignalProcessor
  • PostSsUnstructInd() : CommonSignalProcessor
  • PostSsUssdInd() : CommonSignalProcessor
  • PostSsUssdResentInd() : CommonSignalProcessor
  • PostStartDtmfCnf() : CommonSignalProcessor
  • PostStartDtmfRej() : CommonSignalProcessor
  • PostStopChargingBatteryInd() : ChargerSignalProcessor
  • PostStopDtmfCnf() : CommonSignalProcessor
  • PostTermRspCnf() : CommonSignalProcessor
  • PostTestparamInd() : CommonSignalProcessor
  • PostToStackMsg() : MainHandler
  • PostUrrcSignalStrengthLevelInd() : CommonSignalProcessor
  • Power() : LcsUtils
  • power_saving_mode : RrcParam, AsTestparamDatabase
  • PowerDispatcher() : PowerDispatcher
  • PowerDown() : ShutDown, PowerHandler
  • PowerDownCnfArg() : PowerDownCnfArg
  • PowerDownDispatcher() : PowerDownDispatcher
  • PowerDownIndArg() : PowerDownIndArg
  • PowerDownReqArg() : PowerDownReqArg
  • PowerHandler() : PowerHandler
  • PowerMode : Display
  • PowerModeAuto : Display
  • PowerModeIndMsg() : PowerModeIndMsg
  • PowerModeOff : Display
  • PowerModeOn : Display
  • PowerOff : ShutDown
  • PowerOffMsg() : PowerOffMsg
  • PowerOn : AlarmManager
  • PowerOnBehavior : AlarmManager
  • PowerOnMsg() : PowerOnMsg
  • PowerTurnedOff : Display
  • PowerTurnedOn : Display
  • PowerUp() : PowerHandler
  • PowerWakeupMsg() : PowerWakeupMsg
  • PppDataConn : PppDataConn, SysSocket
  • PppFrame() : PppFrame
  • PppProtocol : PdpContext
  • PppType : PdpContext
  • PpUnspecified : Sms
  • PreAlloc() : WString, String, ByteBuffer
  • Precedence : PdpContext::QualityOfService
  • PrecedenceHigh : PdpContext::QualityOfService
  • PrecedenceLow : PdpContext::QualityOfService
  • PrecedenceNormal : PdpContext::QualityOfService
  • PrecedenceReserved : PdpContext::QualityOfService
  • PrecedenceSubscribed : PdpContext::QualityOfService
  • PreconditionFailed : BtObexResponseCode
  • pred_input : SmsSettingsRecord::Persist
  • PredArabic : PredInputMapper
  • PredBitmapId : AbstractPredictiveInputBox
  • PredBpmf : PredInputMapper
  • PredefinedAnimation : InformationElement
  • PredefinedAnimationType : InformationElement
  • PredefinedEmsImage() : PredefinedEmsImage
  • PredefinedEmsSound() : PredefinedEmsSound
  • PredefinedFeature : AudioDeviceBase
  • PredefinedFeatureEnd : AudioDeviceBase
  • PredefinedSound : InformationElement
  • PredefinedSoundDataSource : AudioReference
  • PredefinedSoundDataSourceEnd : AudioReference
  • PredefinedSoundType : InformationElement
  • PredefIpAddr : IpAddr
  • PredEnglish : PredInputMapper
  • PredFontId : AbstractPredictiveInputBox
  • PredHebrew : PredInputMapper
  • Predictive : InputMapper
  • PredInputMapper() : PredInputMapper
  • PredInputMapperPredModeType : GuiObjectFactory
  • PredInputMode : EditBox
  • PredMode : PredInputMapper
  • PredMultiTap : PredInputMapper
  • PredNone : PredInputMapper
  • PredPinyin : PredInputMapper
  • PredSimplifiedChineseStroke : PredInputMapper
  • PredSymbol : PredInputMapper
  • PredThai : PredInputMapper
  • PredThaiMatrix : PredInputMapper
  • PredTraditionalChineseStroke : PredInputMapper
  • pref_language : SimInfo
  • Preferred : Sms
  • PreferredDataCompression : PdpContext
  • PreferredHeaderCompression : PdpContext
  • PrefExtLangProvider() : PrefExtLangProvider
  • PrefLangProvider() : PrefLangProvider
  • PrefPlmnChangeArg() : PrefPlmnChangeArg
  • PrefPlmnProvider() : PrefPlmnProvider
  • PrefServiceSetReqArg() : PrefServiceSetReqArg
  • PreparedSound() : PreparedSound
  • PrepareRename() : File
  • PrepareRequestExecution() : BtSingleConnectionController, BtMultiConnectionController, BtConnectionlessController
  • present : SsGroup
  • PresentationAllowed : PhoneNumber
  • PresentationAsNavigationOptions() : SimSelectItemOptions
  • PresentationIndicator : PhoneNumber
  • PresentationReserved : PhoneNumber
  • PresentationRestricted : PhoneNumber
  • PresentationTypeAvailable() : SimSelectItemOptions
  • PresentationUndefined : PhoneNumber
  • PresetAudioReference() : PresetAudioReference
  • PresetDate : Date
  • PresetList : AudioPresetStore
  • PresetSoundDataSource : AudioReference
  • PresetSoundToneDTMF0 : AudioPreset
  • PresetSoundToneDTMF1 : AudioPreset
  • PresetSoundToneDTMF2 : AudioPreset
  • PresetSoundToneDTMF3 : AudioPreset
  • PresetSoundToneDTMF4 : AudioPreset
  • PresetSoundToneDTMF5 : AudioPreset
  • PresetSoundToneDTMF6 : AudioPreset
  • PresetSoundToneDTMF7 : AudioPreset
  • PresetSoundToneDTMF8 : AudioPreset
  • PresetSoundToneDTMF9 : AudioPreset
  • PresetSoundToneDTMFAsterix : AudioPreset
  • PresetSoundToneDTMFHash : AudioPreset
  • PresetSoundToneInfoAlarmInCall : AudioPreset
  • PresetSoundToneInfoAutoRedial : AudioPreset
  • PresetSoundToneInfoBroadcastInCall : AudioPreset
  • PresetSoundToneInfoConnection : AudioPreset
  • PresetSoundToneInfoDeviceIn : AudioPreset
  • PresetSoundToneInfoDeviceOut : AudioPreset
  • PresetSoundToneInfoDialTone : AudioPreset
  • PresetSoundToneInfoDisconnect : AudioPreset
  • PresetSoundToneInfoError1 : AudioPreset
  • PresetSoundToneInfoError2 : AudioPreset
  • PresetSoundToneInfoFreeTone : AudioPreset
  • PresetSoundToneInfoLowBat : AudioPreset
  • PresetSoundToneInfoLowBatInCall : AudioPreset
  • PresetSoundToneInfoMinutteMinder : AudioPreset
  • PresetSoundToneInfoMsgFull : AudioPreset
  • PresetSoundToneInfoNegativeAcknowledgement : AudioPreset
  • PresetSoundToneInfoNetworkAttention : AudioPreset
  • PresetSoundToneInfoPositiveAcknowledgement : AudioPreset
  • PresetSoundToneInfoPowerOff : AudioPreset
  • PresetSoundToneInfoPowerOn : AudioPreset
  • PresetSoundToneInfoSingleBeep : AudioPreset
  • PresetSoundToneInfoSmsInCall : AudioPreset
  • PresetSoundToneInfoUssd : AudioPreset
  • PresetSoundToneKeyTone1 : AudioPreset
  • PresetSoundToneKeyTone2 : AudioPreset
  • PresetSoundToneKeyTone3 : AudioPreset
  • PresetSoundToneKeyTone4 : AudioPreset
  • PresetSoundToneKeyTone5 : AudioPreset
  • PresetSoundToneRinger1 : AudioPreset
  • PresetSoundToneSvCallWaiting : AudioPreset
  • PresetSoundToneSvCongestion : AudioPreset
  • PresetSoundToneSvErrorInfo : AudioPreset
  • PresetSoundToneSvRadioPatAck : AudioPreset
  • PresetSoundToneSvRadioPathNotAvail : AudioPreset
  • PresetSoundToneSvSubscriberBusy : AudioPreset
  • PresetSoundToneUnknown : AudioPreset
  • PresetToneType : AudioPreset, AudioPresetStore
  • Prev : AbstractSmsViewerWin
  • prev : TpduConc
  • prev_readpos : XMLParser
  • preview_mandatory : SmsSettingsRecord::Persist
  • PreviewState : MediaRecorder
  • Previous() : WindowHierarchyIterator
  • PreviousFunction : T9InputConfig
  • PrimaryDefinePending : PdpContextManager
  • PrimaryUndefinePending : PdpContextManager
  • PrioHigh : GenericAudioDevice
  • PrioNormal : GenericAudioDevice
  • PrioritizePlayer() : AudioPlayerStore
  • priority : ServiceThreadStarter::StartParam
  • Priority : GenericAudioDevice
  • PriorityBackground1 : Thread
  • PriorityBackground2 : Thread
  • PriorityBackground3 : Thread
  • PriorityBackground4 : Thread
  • PriorityBackground5 : Thread
  • PriorityCount : ToDoRecord
  • PriorityForeground1 : Thread
  • PriorityForeground2 : Thread
  • PriorityForeground3 : Thread
  • PriorityForeground4 : Thread
  • PriorityForeground5 : Thread
  • PriorityGroupType : AudioReference
  • PriorityHigh : Audio
  • PriorityLevel : Thread
  • priorityLevel : ToDoRecord::Persist
  • PriorityLow : Audio
  • PriorityManagementCause : AudioDeviceBase
  • PriorityMedium : Audio
  • PriorityNone : Audio
  • PriorityNormal : Thread
  • PriorityType : AudioReference
  • private_idx : MsapPackedData_s
  • private_implementation() : emcpp_apoxi_OBEXAdapter, apoxi_emcpp_OBEXAdapter
  • PrivateNumberingPlan : TypeOfAddress
  • PrivateTransport : ObexServerDispatcher
  • ProblemCode() : TaggedProblemCode, EnumTranslationTable
  • ProblemTag() : TaggedProblemCode, EnumTranslationTable
  • process_state : RrcProcessState
  • ProcessAbortReq() : LcsCommonMsgProcessor
  • ProcessAcmMaxReadReq() : CommonStackMsgProcessor
  • ProcessAcmMaxUpdReq() : CommonStackMsgProcessor
  • ProcessAcmReadReq() : CommonStackMsgProcessor
  • ProcessAcmUpdReq() : CommonStackMsgProcessor
  • ProcessAtAccessoryNotificationInd() : CommonStackMsgProcessor
  • ProcessAtAccessoryRegisterCnf() : CommonStackMsgProcessor
  • ProcessAtAlphaTagCnf() : CommonStackMsgProcessor
  • ProcessAtGenericCmdInd() : CommonStackMsgProcessor
  • ProcessAtPbInfoInd() : CommonStackMsgProcessor
  • ProcessAtPbListCnf() : CommonStackMsgProcessor
  • ProcessAtPbSelectCnf() : CommonStackMsgProcessor
  • ProcessAttachReq() : CommonStackMsgProcessor
  • ProcessBandSelectionReq() : CommonStackMsgProcessor
  • ProcessBdnReq() : CommonStackMsgProcessor
  • ProcessBrowserRegisterReq() : CommonStackMsgProcessor
  • ProcessBrowserTermEvent() : CommonStackMsgProcessor
  • ProcessCallDeflectRequest() : CallDeflectionHandler
  • ProcessCallDeflectSsReq() : CommonStackMsgProcessor
  • ProcessCallDiscReq() : CommonStackMsgProcessor
  • ProcessCallRelatedSsReq() : CommonStackMsgProcessor
  • ProcessCbmiReadReq() : CommonStackMsgProcessor
  • ProcessCbmirReadReq() : CommonStackMsgProcessor
  • ProcessCbmirUpdReq() : CommonStackMsgProcessor
  • ProcessCbmiUpdReq() : CommonStackMsgProcessor
  • ProcessCbsNewDataRej() : CommonStackMsgProcessor
  • ProcessCbsStartReq() : CommonStackMsgProcessor
  • ProcessCbsStopReq() : CommonStackMsgProcessor
  • ProcessCcpReadReq() : CommonStackMsgProcessor
  • ProcessCcpUpdReq() : CommonStackMsgProcessor
  • ProcessChargeReq() : CommonStackMsgProcessor
  • ProcessChargeUnitsReq() : CommonStackMsgProcessor
  • ProcessChv1DisableReq() : CommonStackMsgProcessor
  • ProcessChv1EnableReq() : CommonStackMsgProcessor
  • ProcessChvChangeReq() : CommonStackMsgProcessor
  • ProcessChvUnblockReq() : CommonStackMsgProcessor
  • ProcessChvVerifyReq() : CommonStackMsgProcessor
  • ProcessClearBlacklistReq() : CommonStackMsgProcessor
  • ProcessClientDeregistration() : CommonStackMsgProcessor
  • ProcessClientRegistration() : CommonStackMsgProcessor
  • ProcessCmiReadReq() : CommonStackMsgProcessor
  • ProcessControlHwDataOnlyReq() : CommonStackMsgProcessor
  • ProcessCphsCfufReadReq() : CommonStackMsgProcessor
  • ProcessCphsCfufUpdReq() : CommonStackMsgProcessor
  • ProcessCphsCspReadReq() : CommonStackMsgProcessor
  • ProcessCphsCspUpdReq() : CommonStackMsgProcessor
  • ProcessCphsIstReadReq() : CommonStackMsgProcessor
  • ProcessCphsOnmReadReq() : CommonStackMsgProcessor
  • ProcessCphsOnsReadReq() : CommonStackMsgProcessor
  • ProcessCphsVmwfReadReq() : CommonStackMsgProcessor
  • ProcessCphsVmwfUpdReq() : CommonStackMsgProcessor
  • ProcessDetachReq() : CommonStackMsgProcessor
  • ProcessDhChannelChangeStatusEvent() : CommonStackMsgProcessor
  • ProcessDhChannelCloseInd() : CommonStackMsgProcessor
  • ProcessDhChannelDataAvailEvent() : CommonStackMsgProcessor
  • ProcessDhChannelOpenCnf() : CommonStackMsgProcessor
  • ProcessDhChannelOpenRej() : CommonStackMsgProcessor
  • ProcessDhChannelReceiveInd() : CommonStackMsgProcessor
  • ProcessDhChannelSendInd() : CommonStackMsgProcessor
  • ProcessDisplayTextRsp() : CommonStackMsgProcessor
  • ProcessDispMapDecision() : LcsAppUtils
  • ProcessDrmMessage() : DrmMessage
  • ProcessEngineeringModeControlRequest() : CommonStackMsgProcessor
  • ProcessExtProactiveCmdCnf() : CommonStackMsgProcessor
  • ProcessExtProactiveCmdReq() : CommonStackMsgProcessor
  • ProcessFdnReq() : CommonStackMsgProcessor
  • ProcessGetInkeyRsp() : CommonStackMsgProcessor
  • ProcessGetInputRsp() : CommonStackMsgProcessor
  • ProcessGprsClassReq() : CommonStackMsgProcessor
  • ProcessIconDescReadReq() : CommonStackMsgProcessor
  • ProcessIdleScreenAvailEvent() : CommonStackMsgProcessor
  • ProcessImageReadReq() : CommonStackMsgProcessor
  • ProcessImeiReadReq() : CommonStackMsgProcessor
  • processingInstruction() : WbxmlParserRel
  • ProcessIsrData() : IsrDataManager
  • ProcessLanguageSelectEvent() : CommonStackMsgProcessor
  • ProcessLanguageSettingInd() : CommonStackMsgProcessor
  • ProcessLaunchBrowserInd() : CommonStackMsgProcessor
  • ProcessLaunchBrowserPromptInd() : CommonStackMsgProcessor
  • ProcessLocationError() : LcsAppUtils
  • ProcessMdhDeregistrationReq() : CommonStackMsgProcessor
  • ProcessMdhMakeViewReq() : CommonStackMsgProcessor
  • ProcessMdhRegistrationReq() : CommonStackMsgProcessor
  • ProcessMdhRemoveViewReq() : CommonStackMsgProcessor
  • ProcessMdhSetConfigReq() : CommonStackMsgProcessor
  • ProcessMdhSetStorageReq() : CommonStackMsgProcessor
  • ProcessMdhSmsConcRefNumReq() : CommonStackMsgProcessor
  • ProcessMdhSmsDeletionReq() : CommonStackMsgProcessor
  • ProcessMdhSmsExtendedDataReq() : CommonStackMsgProcessor
  • ProcessMdhSmsReadReq() : CommonStackMsgProcessor
  • ProcessMdhSmsReportReadReq() : CommonStackMsgProcessor
  • ProcessMdhSmsSetWaitingReq() : CommonStackMsgProcessor
  • ProcessMdhSmsStatusReq() : CommonStackMsgProcessor
  • ProcessMdhSmsTransmitAck() : CommonStackMsgProcessor
  • ProcessMdhSmsTransmitStartAck() : CommonStackMsgProcessor
  • ProcessMdhSmsUpdStatusReq() : CommonStackMsgProcessor
  • ProcessMdhSmsWriteReq() : CommonStackMsgProcessor
  • ProcessMeasurementDataReq() : GltpMsgProcessor
  • ProcessMenuSelectionReq() : CommonStackMsgProcessor
  • ProcessMnAttachStatusInd() : PdpContextSignalProcessor
  • ProcessMnNetworkSearchModeReq() : CommonStackMsgProcessor
  • ProcessMnTriggerReq() : CommonStackMsgProcessor
  • ProcessMocSetupReq() : CommonStackMsgProcessor
  • ProcessMolrMsg() : ProcessMolrMsg
  • ProcessMolrReq() : SaMsgProcessor, LcsMsgProcessor
  • ProcessMtcAccept() : CommonStackMsgProcessor
  • ProcessMtcAlertReq() : CommonStackMsgProcessor
  • ProcessNode() : ProcessNode
  • ProcessODyn2ReadReq() : CommonStackMsgProcessor
  • ProcessODyn2UpdReq() : CommonStackMsgProcessor
  • ProcessODynReadReq() : CommonStackMsgProcessor
  • ProcessODynUpdReq() : CommonStackMsgProcessor
  • ProcessOmBandStatusReq() : CommonStackMsgProcessor
  • ProcessOmFactoryResetInd() : CommonStackMsgProcessor
  • ProcessOmGetTermProfileReq() : CommonStackMsgProcessor
  • ProcessOmMultiSlotReq() : CommonStackMsgProcessor
  • ProcessOmPowerUp() : CommonStackMsgProcessor
  • ProcessOmRatChangeReq() : CommonStackMsgProcessor
  • ProcessOmSetTermProfileReq() : CommonStackMsgProcessor
  • ProcessPbCountReq() : CommonStackMsgProcessor
  • ProcessPbEntryReadReq() : CommonStackMsgProcessor
  • ProcessPbEntryUpdReq() : CommonStackMsgProcessor
  • ProcessPbInfoReadReq() : CommonStackMsgProcessor
  • ProcessPchActCompleteInd() : PdpContextSignalProcessor
  • ProcessPchActFailedInd() : PdpContextSignalProcessor
  • ProcessPchActivateCnf() : PdpContextSignalProcessor
  • ProcessPchActivateInd() : PdpContextSignalProcessor
  • ProcessPchActivateRej() : PdpContextSignalProcessor
  • ProcessPchActivateStatusInd() : PdpContextSignalProcessor
  • ProcessPchAttachCnf() : PdpContextSignalProcessor
  • ProcessPchAttachRej() : PdpContextSignalProcessor
  • ProcessPchAttachRep() : PdpContextSignalProcessor
  • ProcessPchAuthCnf() : PdpContextSignalProcessor
  • ProcessPchAuthRej() : PdpContextSignalProcessor
  • ProcessPchCgdsContCnf() : PdpContextSignalProcessor
  • ProcessPchCgdsContRej() : PdpContextSignalProcessor
  • ProcessPchCgTftCnf() : PdpContextSignalProcessor
  • ProcessPchCgTftRej() : PdpContextSignalProcessor
  • ProcessPchDataStateCnf() : PdpContextSignalProcessor
  • ProcessPchDataStateRej() : PdpContextSignalProcessor
  • ProcessPchDeactivateCnf() : PdpContextSignalProcessor
  • ProcessPchDeactivateInd() : PdpContextSignalProcessor
  • ProcessPchDefContCnf() : PdpContextSignalProcessor
  • ProcessPchDefContRej() : PdpContextSignalProcessor
  • ProcessPchDetachCnf() : PdpContextSignalProcessor
  • ProcessPchDetachInd() : PdpContextSignalProcessor
  • ProcessPchPppActCnf() : PdpContextSignalProcessor
  • ProcessPchReactivateInd() : PdpContextSignalProcessor
  • ProcessPchReadCntInd() : PdpContextSignalProcessor
  • ProcessPchReadCntRej() : PdpContextSignalProcessor
  • ProcessPchReadDnsCnf() : PdpContextSignalProcessor
  • ProcessPchReadDnsRej() : PdpContextSignalProcessor
  • ProcessPchSetCntCnf() : PdpContextSignalProcessor
  • ProcessPchSetCntRej() : PdpContextSignalProcessor
  • ProcessPchSetDnsCnf() : PdpContextSignalProcessor
  • ProcessPchSetDnsRej() : PdpContextSignalProcessor
  • ProcessPchSetQosCnf() : PdpContextSignalProcessor
  • ProcessPchSetQosMinCnf() : PdpContextSignalProcessor
  • ProcessPchSetQosMinRej() : PdpContextSignalProcessor
  • ProcessPchSetQosRej() : PdpContextSignalProcessor
  • ProcessPinDisableReq() : CommonStackMsgProcessor
  • ProcessPinEnableReq() : CommonStackMsgProcessor
  • ProcessPlayToneRsp() : CommonStackMsgProcessor
  • ProcessPlmnInfoReq() : CommonStackMsgProcessor
  • ProcessPlmnListAbort() : CommonStackMsgProcessor
  • ProcessPlmnListReq() : CommonStackMsgProcessor
  • ProcessPowerDownReq() : CommonStackMsgProcessor
  • ProcessPrefExtLangReadReq() : CommonStackMsgProcessor
  • ProcessPrefExtLangUpdReq() : CommonStackMsgProcessor
  • ProcessPrefLangReadReq() : CommonStackMsgProcessor
  • ProcessPrefLangUpdReq() : CommonStackMsgProcessor
  • ProcessPrefPlmnChange() : CommonStackMsgProcessor
  • ProcessPrefServiceSetReq() : CommonStackMsgProcessor
  • ProcessPuctReadReq() : CommonStackMsgProcessor
  • ProcessPuctUpdReq() : CommonStackMsgProcessor
  • ProcessRedialingQueryReq() : CommonStackMsgProcessor
  • ProcessRediallingDisabledInd() : CommonStackMsgProcessor
  • ProcessRedialRej() : CommonStackMsgProcessor
  • ProcessReferenceTimeReq() : GltpMsgProcessor
  • ProcessRefLocReq() : GltpMsgProcessor
  • ProcessRejectCallsInd() : CommonStackMsgProcessor
  • ProcessRightsMessage() : DrmMessage
  • ProcessSelectItemRsp() : CommonStackMsgProcessor
  • ProcessSelfLocation() : LcsAppUtils
  • ProcessSetAutoCharge() : CommonStackMsgProcessor
  • ProcessSetChargeUnits() : CommonStackMsgProcessor
  • ProcessSetupEventCnf() : CommonStackMsgProcessor
  • ProcessSetupIdleModeTextRsp() : CommonStackMsgProcessor
  • ProcessSetupMenuRsp() : CommonStackMsgProcessor
  • ProcessSiChannelCloseInfoRes() : CommonStackMsgProcessor
  • ProcessSiChannelCloseReq() : CommonStackMsgProcessor
  • ProcessSiChannelOpenPromptRes() : CommonStackMsgProcessor
  • ProcessSiChannelReceiveInfoRes() : CommonStackMsgProcessor
  • ProcessSiChannelSendInfoRes() : CommonStackMsgProcessor
  • ProcessSimFileInfoReq() : CommonStackMsgProcessor
  • ProcessSimGenericReq() : CommonStackMsgProcessor
  • ProcessSimModifyLockReq() : CommonStackMsgProcessor
  • ProcessSimMruPropertyUpdReq() : CommonStackMsgProcessor
  • ProcessSimTkCallSetupAcc() : CommonStackMsgProcessor
  • ProcessSimTkCallSetupRej() : CommonStackMsgProcessor
  • ProcessSimTkRefreshCnfInd() : CommonStackMsgProcessor
  • ProcessSimTkRefreshNewRsp() : CommonStackMsgProcessor
  • ProcessSimTkRefreshQueryRes() : CommonStackMsgProcessor
  • ProcessSimTkRefreshResetRsp() : CommonStackMsgProcessor
  • ProcessSimTkRefreshRsp() : CommonStackMsgProcessor
  • ProcessSimTkResetCnfInd() : CommonStackMsgProcessor
  • ProcessSimTkRunAtCmdInfoRes() : CommonStackMsgProcessor
  • ProcessSimTkSendDtmfCnf() : CommonStackMsgProcessor
  • ProcessSimTkSmsPpRsp() : CommonStackMsgProcessor
  • ProcessSimTkSsRsp() : CommonStackMsgProcessor
  • ProcessSimTkStopSendDtmfReq() : CommonStackMsgProcessor
  • ProcessSmsConfigIndArg() : CommonStackMsgProcessor
  • ProcessSmsGetMoreMessageStatusReq() : CommonStackMsgProcessor
  • ProcessSmsrReadReq() : CommonStackMsgProcessor
  • ProcessSmsrUpdReq() : CommonStackMsgProcessor
  • ProcessSmsSendReq() : CommonStackMsgProcessor
  • ProcessSmsSetMoreMessageReq() : CommonStackMsgProcessor
  • ProcessSpnReadReq() : CommonStackMsgProcessor
  • ProcessSsCcbsInvoke() : CommonStackMsgProcessor
  • ProcessSsCcbsReCallRequest() : CommonStackMsgProcessor
  • ProcessSsCcbsReject() : CommonStackMsgProcessor
  • ProcessSsErrReq() : CommonStackMsgProcessor
  • ProcessSsGetPasswordRsp() : CommonStackMsgProcessor
  • ProcessSsRejReq() : CommonStackMsgProcessor
  • ProcessSsSendEndReq() : CommonStackMsgProcessor
  • ProcessSsSendReq() : CommonStackMsgProcessor
  • ProcessSstReadReq() : CommonStackMsgProcessor
  • ProcessSsUssdReq() : CommonStackMsgProcessor
  • ProcessStackMsgArgument() : UusHandler, UssdHandler, MobileOriginatedUssdHandler, CallForwardingHandler
  • ProcessStartDtmfReq() : CommonStackMsgProcessor
  • ProcessStartSignalStrengthListening() : CommonStackMsgProcessor
  • ProcessStopBatteryLoadListening() : CommonStackMsgProcessor
  • ProcessStopDtmfReq() : CommonStackMsgProcessor
  • ProcessStopSignalStrengthListening() : CommonStackMsgProcessor
  • ProcessTestparamReq() : CommonStackMsgProcessor
  • ProcessTransferLocation() : LcsAppUtils
  • ProcessUserActivityEvent() : CommonStackMsgProcessor
  • ProcessVerifResp() : LcsMsgProcessor
  • ProductionTestOn : StartUp
  • profile : SmsSettingsRecord::Persist
  • ProfileConstants : WapProfile
  • ProfileType : DataConnProfile
  • progress_ind : CallSetupProgressArg
  • ProgressBar() : ProgressBar
  • ProgressBarBarControl : CTResourcePack
  • ProgressBarBitmap : CTResourcePack
  • ProgressBarClassType : GuiObjectFactory
  • ProgressBarControl : CTResourcePack
  • ProgressBarDrawingMode : CTResourcePack
  • ProgressBarDrawModeParseType : CTResourcePack
  • ProgressBarDrawModeType : CTResourcePack
  • ProgressBarDrawPercentage : CTResourcePack
  • ProgressBarHeight : CTResourcePack
  • ProgressBarView() : ProgressBarView
  • ProgressFtpInTransfer() : FtpDataSocket
  • ProgressFtpOutTransfer() : FtpDataSocket
  • ProgressProp : GuiObjectFactory
  • ProgressPropertyDescriptorClassType : GuiObjectFactory
  • PROP_DRM_ATTRIB : FlashFileImp
  • PROP_NATIVEHANDLE : FlashFileImp, FatFileImp
  • PROP_USERID : FlashFileImp
  • PropAccount : DataConnApp
  • PropagateUserActivity() : AtlApplication
  • PropApnName : DataConnApp
  • PropAuthType : DataConnApp
  • PropCallType : DataConnApp
  • PropCount : GuiObjectFactory
  • PropDataCompr : DataConnApp
  • PropDataRate : DataConnApp
  • Properties() : CodecDevice::Properties
  • Property : CamWin32, Property, FeatureBroker
  • property_editor_id : MenuPool::FeatureItemContainerContentTableEntry
  • PropertyAttributeId : Property
  • PropertyContainerClassType : GuiObjectFactory
  • PropertyDescriptor() : PropertyDescriptor
  • PropertyDescriptorClassType : GuiObjectFactory
  • PropertyDescriptorProp : GuiObjectFactory
  • PropertyEditor() : PropertyEditor
  • PropertyId : GuiObjectFactory
  • PropertyItem() : PropertyItem
  • PropertyItemClassType : GuiObjectFactory
  • PropertyItemEditorProp : GuiObjectFactory
  • PropertyItemTypeProp : GuiObjectFactory
  • PropertyListProp : GuiObjectFactory
  • PropertyTriggerMsg() : PropertyTriggerMsg
  • PropertyType : CTResourcePack, CamWin32
  • PropIdleTimer : DataConnApp
  • PropInvalidId : DataConnApp
  • PropLingerTimer : DataConnApp
  • PropLocalAddr : DataConnApp
  • PropName : DataConnApp
  • PropPasswd : DataConnApp
  • PropPhoneNo : DataConnApp
  • PropPrimaryDnsServerAddress : DataConnApp
  • PropQosDelay : DataConnApp
  • PropQosMeanRate : DataConnApp
  • PropQosPeakRate : DataConnApp
  • PropQosPrecedence : DataConnApp
  • PropQosReliability : DataConnApp
  • PropQueryPasswd : DataConnApp
  • PropSecondaryDnsServerAddress : DataConnApp
  • PropSerIdleTimer : DataConnApp
  • PropSerLingerTimer : DataConnApp
  • Protector() : Protector
  • Protocol : PdpContext, SysSocket
  • ProtocolIdentifier() : ProtocolIdentifier
  • ProtocolIdentifierExists() : ParameterIndicator
  • ProtocollError : Sms
  • ProvColListBoxWin() : ProvColListBoxWin
  • ProvDetailListBoxWin() : ProvDetailListBoxWin
  • ProvideData() : ObexServerOppImpl, ObexOppServer, ObexOppClient, ObexDataServer, ObexClientOppImpl
  • ProvideFolderListingEntriesFinished() : ObexFtpServer
  • ProvideFolderListingEntry() : ObexFtpServer
  • Provider() : Provider
  • ProviderChangedMsg() : ProviderChangedMsg
  • ProviderListBox() : ProviderListBox
  • ProviderListBoxModel() : ProviderListBoxModel
  • ProviderListBoxView() : ProviderListBoxView
  • ProviderListener() : ProviderListener
  • ProviderProxyContainer() : ProviderProxyContainer
  • ProviderProxyItem() : ProviderProxyItem
  • ProviderPtr() : ProviderPtr
  • ProviderType : ContextFeature
  • ProviderUpdateMsg() : ProviderUpdateMsg
  • ProviderUpdateState : PhonebookApp
  • ProvListBoxWin() : ProvListBoxWin
  • ProvShowsEmptyRows() : PhonebookApp
  • ps_param : TestparamReport
  • ps_transfer : RrcParam, AsTestparamDatabase
  • psContent : comm_root_cert
  • PsdDataConn : PsdDataConn, SysSocket
  • PsdDataConnAccessor() : PsdDataConnAccessor
  • PsdDataConnCtrlCbs : PsdDataConn
  • PsdDataConnProfile : PsdDataConnProfile, PersistDataConnProfile
  • PsdDataConnProvider() : PsdDataConnProvider
  • PsdLinkInit() : SysSocket
  • PsdLinkStop() : SysSocket
  • PsdLinkUp() : SysSocket
  • PsdPropCount : DataConnApp
  • PsdPropertyId : DataConnApp
  • psi1_repeat : GprsParam
  • psi_count_hr : GprsParam
  • psi_count_lr : GprsParam
  • psKey : comm_user_cert
  • PsParam : TestparamReport
  • pStateFunc : StateStruct
  • psUserCert : comm_user_cert
  • pszContentType : comm_user_cert, comm_root_cert
  • pszPassword : comm_user_cert
  • PtNoValue : AtResponseParameter
  • PtNumeric : AtResponseParameter
  • PtrT : FixedPtrArray< T >
  • PtString : AtResponseParameter
  • Pull() : ObexOppClient, ObexClientOppImpl
  • Push() : ObexOppClient, ObexOppBinDataPushClient, ObexClientOppImpl, MsgQueue, FifoLinkedList< T >, SimPhoneBookEntry, AtGenericCmdType
  • push_back() : WbxmlVector< T >
  • PushBack() : EmzUtils::Queue< T >, BtDeviceList, Vector< T >, LinkedListBase, TextIconPairArray, DeletedNodeList
  • PushButton() : PushButton
  • PushButtonClassType : GuiObjectFactory
  • PushButtonControl : CTResourcePack
  • PushButtonHeight : CTResourcePack
  • PushButtonView() : PushButtonView
  • PushFocusMsg() : MsgQueue
  • PushFront() : EmzUtils::Queue< T >, BtDeviceList, LinkedListBase
  • Put() : ObexLayer, ObexClient, IrdaObexImpl, BtObexImpl, StreamObexImpl, SmsWStringCache
  • PutAddressingScheme16Bit() : InformationElement
  • PutAddressingScheme8Bit() : InformationElement
  • PutConcatenatedSm16Bit() : InformationElement
  • PutConcatenatedSm8Bit() : InformationElement
  • PutContinuedExtendedObject() : InformationElement
  • PutData() : SimPbEntryCont
  • PutEmsRelativeStartPosition() : InformationElement
  • PutExtendedObject() : InformationElement
  • PutFilter() : CbsFilterList
  • PutImageReq() : BtBipClientService
  • PutImageRsp() : BtBipServerService
  • PutLargeAnimation() : InformationElement
  • PutLargePicture() : InformationElement
  • PutLinkedAttachmentReq() : BtBipClientService
  • PutLinkedAttachmentRsp() : BtBipServerService
  • PutLinkedThumbnailReq() : BtBipClientService
  • PutLinkedThumbnailRsp() : BtBipServerService
  • PutPredefinedAnimation() : InformationElement
  • PutPredefinedSound() : InformationElement
  • PutRequest() : BtObexClientService
  • PutReusedExtendedObject() : InformationElement
  • PutSmallAnimation() : InformationElement
  • PutSmallPicture() : InformationElement
  • PutTextFormatting() : InformationElement
  • PutToForeground() : Control
  • PutUserDefinedSound() : InformationElement
  • PutValue() : ObexHeader
  • PutVariablePicture() : InformationElement
  • PuzzleTileFilter : Camera
  • PwRegistrationFailure : SsErrorCode
  • PxAddrType : WapProfile
  • PxLogicalCharacs() : WapProfile::PxLogicalCharacs
Generated on Wed Jan 25 00:54:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- q -

  • Qcelp : MediaInfo, CodecDevice
  • QcifSize : CamWin32, Camera
  • QosDelay : PsdDataConnProfile
  • QosMeanRate : PsdDataConnProfile
  • QosNotAccepted : PdpContext
  • QosPeakRate : PsdDataConnProfile
  • QosPrecedence : PsdDataConnProfile
  • QosReliability : PsdDataConnProfile
  • QqcifSize : CamWin32, Camera
  • QqvgaSize : CamWin32, Camera
  • QsifSize : CamWin32, Camera
  • qualifier : TSiIconID_s
  • QualityHigh : RecordSettings
  • QualityLevel : VideoDecoder, AudioDecoder
  • QualityLow : RecordSettings
  • QualityNormal : RecordSettings
  • QualityOfService() : PdpContext::QualityOfService
  • QualityOfServiceNotAvailable : ShortMessageStatus
  • QueryForPasswd() : DataConnProfile
  • QueryRects() : VideoChannel
  • QuerySmsMoreMessageType() : SmsHandler, SimAccessor
  • Queue() : EmzUtils::Queue< T >
  • QuickSort() : QuickSortProvider, ChineseQuickSortProvider
  • QuickSortDataItems() : MergeProvider
  • QuickSortNumber() : QuickSortProvider
  • QuickSortProvider() : QuickSortProvider
  • QuickSortWString() : QuickSortProvider
  • QuotedPrintableCoder() : QuotedPrintableCoder
  • QvgaSize : CamWin32, Camera
Generated on Wed Jan 25 00:54:27 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • rac : GprsParam, UmtsRrcScellParam
  • radio : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • RADIO_ACTIVE_MSG : TestWriter
  • radio_freq : FmRadioStationsRecord::Persist
  • radio_last_freq : FmRadioSettingsRecord::Persist
  • radio_last_volume : FmRadioSettingsRecord::Persist
  • RADIO_SELECTED_MSG : TestWriter
  • RadioButtonAction() : RadioButtonAction
  • RadioButtonActionClassType : GuiObjectFactory
  • RadioButtonControl() : RadioButtonControl
  • RadioButtonControlClassType : GuiObjectFactory
  • RadioButtonControlView() : RadioButtonControlView
  • RadioButtonGroup() : RadioButtonGroup
  • RadioButtonGroupClassType : GuiObjectFactory
  • RadioButtonGroupProp : GuiObjectFactory
  • RadioButtonItem() : RadioButtonItem
  • RadioButtonList() : RadioButtonList
  • RadioButtonListView() : RadioButtonListView
  • RadioButtonModel() : RadioButtonModel
  • RadioButtonView() : RadioButtonView
  • RadioDeviceID : AudioDeviceManager
  • RadioFmOff : FmRadioApplication
  • RadioFmOn : FmRadioApplication
  • RadioFmOnMinimized : FmRadioApplication
  • RadioFmState : FmRadioApplication
  • RadioFmToRestart : FmRadioApplication
  • RadioPriority : PdpContext::ActivationStatus
  • RadioPriorityLevel_1 : PdpContext::ActivationStatus
  • RadioPriorityLevel_2 : PdpContext::ActivationStatus
  • RadioPriorityLevel_3 : PdpContext::ActivationStatus
  • RadioPriorityLevel_4 : PdpContext::ActivationStatus
  • RadioPriorityLevel_Undefined : PdpContext::ActivationStatus
  • Raised : CTResourcePack
  • RaisedBorder : CTResourcePack
  • RamData() : RamData
  • RamDataSink() : RamDataSink
  • RamDataSource : RamDataSource, RamDataSink
  • RamDirectoryIteratorImp() : RamDirectoryIteratorImp
  • RamFile() : RamFile
  • RamFileImp() : RamFileImp
  • RamFileNode() : RamFileNode
  • RamFileObj : RamFileObj, RamStorageMapper
  • RamFileSystem : RamFileNode
  • RamMedia : StreamAudioReference
  • RamSoundDataSource : AudioReference
  • RamStorageDeviceImp : RamStorageDeviceImp, RamFileImp, RamDirectoryIteratorImp
  • Random() : SocketTestT
  • Range : MessageIdentifier
  • range : BtAttributeId
  • RangeCountProp : GuiObjectFactory
  • RangeError : File
  • RangeMappingPolicy() : RangeMappingPolicy
  • RangeMappingPolicyClassType : GuiObjectFactory
  • RangeRule() : RangeRule
  • rank_pos : NeighbourCell, UmtsNcellParam
  • ranking_status : NeighbourCell, UmtsNcellParam
  • ranking_value : NeighbourCell, UmtsNcellParam, UmtsRrcScellParam
  • RasterOp : DeviceContext
  • Rat : TestparamReport
  • rat : TestparamReport
  • RatChangeModeChangedMsg() : RatChangeModeChangedMsg
  • Rate : VoiceMemoAudioDevice
  • rate : VoiceMemoAudioDevice::StartParam, VmParam
  • Rate0 : VoiceMemoAudioDevice
  • Rate1 : VoiceMemoAudioDevice
  • Rate2 : VoiceMemoAudioDevice
  • Rate3 : VoiceMemoAudioDevice
  • Rate4 : VoiceMemoAudioDevice
  • Rate5 : VoiceMemoAudioDevice
  • Rate6 : VoiceMemoAudioDevice
  • Rate7 : VoiceMemoAudioDevice
  • RatStateMsg() : RatStateMsg
  • RawFormat : CamWin32
  • RawFrameRequest() : BtAvrcpOperationService
  • RBegin() : BtDeviceList, Vector< T >
  • rbegin() : WbxmlVector< T >
  • rdn : EctIndicator
  • ReactivateBacklight() : DefaultDisplay, Display, DefaultDisplay
  • ReactivateIllumination() : Keyboard
  • ReactivatePower() : DefaultDisplay, Display, DefaultDisplay
  • ReactivationRequired : PdpContext
  • Read : FfsDataConnProfileStorage, UdpSocket, TcpSocket, Socket, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket, DataConnProfileStorage, SocketPeer, NonsharedBinDataDataSource, NvRamStorage, InputStream, FileInputStream, FfsFile, RomData, RamData, HeapDataSource, DataSourceBinData, DataSource, ChildBinData, BinDataDataSource, BinData, MemMap, SmsSocket, ExtPsdContextListener_SerialTerminal, UserData, FileDataSource, FileChunkOperator, FileBinData, File, RegNodeBuffer, FlsFile, FfsHandler, SvgIoWrapper, SvgImageFileWrapper, SvgGzFileWrapper, SvgFileWrapper, SioSocketAdapter, SerialSocket, SerialIoAdapter, SerialTerminalSocket, SerialTerminal, RamHandler, RamFileObj, RamFile, FatHandler, FatFile, Tpdu
  • read_buffer : FileInReadStatusInfo, BinDataInReadStatusInfo
  • ReadAndWriteMode : File
  • ReadBlock() : RamStorageMapper
  • ReadBlocks() : RamStorageMapper
  • ReadBool() : HostIniFile
  • ReadBuffer() : VCard
  • ReadCounter() : PdpContext
  • ReadCounterPending : PdpContextManager
  • ReadCountersPending : PdpContextManager
  • ReadCur() : File
  • ReadData() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • Reader : ObexBuffer::Reader, ObexBuffer
  • ReadFrom() : DrmInfo, Path
  • ReadFromMemory() : BtSddbServiceRecord, BtSddbServiceAttribute, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeOneByteDescriptionType, BtSddbDataElement
  • ReadInteger() : HostIniFile
  • ReadLastMnCause() : CallHdlBase
  • ReadLdbData() : T9PackConnector
  • ReadMetaData() : Fota
  • ReadNegotiatedDnsServerAddress() : PsdDataConn, PdpContext
  • ReadNegotiatedDnsServerAddressPending : PdpContextManager
  • ReadOffsetExact : FileChunkOperator
  • ReadOffsetMax : FileChunkOperator
  • ReadOnly : StorageDevice, File::Attributes
  • ReadOnlyMode : File
  • ReadOnlyProp : GuiObjectFactory
  • ReadPayloadData() : UserData
  • ReadProperties() : CTResourcePack
  • ReadRightsObject() : DrmRightsObjectFile
  • ReadRingToneInfoFromFfs() : RingerAudioDevice
  • ReadROHeaderInfo() : DrmRightsObjectFile
  • ReadRootCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ReadSmsProfile() : SmsContext
  • ReadStreaming() : File, FlsFile, FatHandler, FatFile
  • ReadStreamingAsync() : File, FlsFile, FatHandler, FatFile
  • ReadString() : HostIniFile
  • ReadUserCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ReadVCard() : VCardParser
  • ready_connected : GmmParam
  • ReadyState : MediaPlayer
  • Realloc() : Os
  • Reallocate() : RegBlobObject, ByteBuffer, BlobObject
  • ReAllocate() : HeapVector::VarPage, HeapVector::BlockPage, HeapManager
  • ReallocateData() : Tpdu, Cbs
  • ReAllocateFunction : HeapVector
  • RealTimeClockCategory : AbstractDevice
  • Reason : AudioPlayerEvent, ShortMessageStatus
  • ReceiveEngineeringModeReport() : NetworkHandler
  • Reciprocal() : Fraction
  • ReconstructRecordingWaitCondition() : StreamAudioPlayer
  • Record() : VoiceMemoWin, VoiceMemoRecordWin, StreamAudioPlayer, Record
  • RecordApiCompletionMsg : MediaManager
  • RecordHandler() : RecordHandler
  • RecordingState : MediaRecorder
  • RecordSettings() : RecordSettings
  • Rect() : Rect
  • RectType : GuiObjectFactory
  • recurrence : CalendarRecord::Persist
  • RecurrenceCounts : CalendarRecord
  • Recv() : SysSocket
  • RecvFrom() : SysSocket
  • red : Palette, Led::Color, SimClutEntry
  • RedEyeReductionFlash : Camera
  • RedialIndArg() : RedialIndArg
  • RediallingDisabledIndArg() : RediallingDisabledIndArg
  • RedialQueryReqArg() : RedialQueryReqArg
  • RedialRejArg() : RedialRejArg
  • RedialSetupIndArg() : RedialSetupIndArg
  • RedialSetupMsg() : RedialSetupMsg
  • RedialStartedMsg() : RedialStartedMsg
  • RedialStatusIndArg() : RedialStatusIndArg
  • RedialStatusMsg() : RedialStatusMsg
  • RedialStopIndArg() : RedialStopIndArg
  • RedialStoppedMsg() : RedialStoppedMsg
  • RedialSuccessMsg() : RedialSuccessMsg
  • RedirectCall : CallSsAction
  • RedrawDisplayMsg() : RedrawDisplayMsg
  • RedrawStatusLine() : CameraViewFinderWin
  • Ref() : SharedPtr< T_obj >
  • RefCount() : ReferableObject
  • ReferableObject() : ReferableObject
  • Reference : Vector< T >
  • ReferenceLocation() : ReferenceLocation
  • ReferenceTime() : ReferenceTime
  • Refresh() : MediaRefContainer, ProvDetailListBoxWin, ProvListBoxWin, Window, TabControl, TabButton, RadioButtonControl, PushButton, ItemTree, ItemMenu, ItemBox, ImageBox, DateEditor, Control, ContextMenu, Component, CheckBoxControl, AnimatedTextLine, AbstractMultiLineEditor, AbstractItemGrid, AbstractGrid, AbstractEditor, VirtualDisplay, DefaultDisplay, VirtualDisplay, DefaultDisplay, VirtualDisplay, DefaultDisplay, VirtualDisplay, DefaultDisplay, Display, VirtualDisplay, DefaultDisplay, TextList, RadioButtonList, MenuList, Menu, Grid, CheckBoxList, CheckBox, AbstractListBox, AbstractEditBox, BtDeviceList, AtlItemBox, ProcessNode, MultiMediaEditor, SimSmsParamHandler, SimPduHandler, SimPbBaseHandler
  • refresh : SimEfRefreshTable
  • refresh_info : T_PB_RECORD
  • RefreshChvData() : SimChvHandler
  • RefreshComponentMsg() : RefreshComponentMsg
  • RefreshData() : SimSmsParamHandler, SimPduHandler, SimPbBaseHandler, DataHandler
  • RefreshDataSimTk() : DataHandler
  • RefreshImageCache() : AbstractItemGrid
  • RefreshPhoneticList() : ChineseT9Wrapper
  • RefreshScreen() : SocketTestProgressWin, FfsTestDispWin
  • RefreshSimMruProperty() : DataHandler
  • RefreshStatusData() : SimPduHandler
  • RefreshViewFinder() : CameraViewFinderWin
  • reg_state : MmCoordParam
  • RegApp() : RegApp
  • RegAppFirstWin() : RegAppFirstWin
  • RegAppWin() : RegAppWin
  • RegBlobObject() : RegBlobObject
  • RegCbNotifyMsg() : RegCbNotifyMsg
  • RegCommitTransaction() : LocalDataStore
  • RegDeletionBufferEntry() : RegDeletionBufferEntry
  • RegError : RegEncoderDecoder
  • RegGetDataSize() : RegBlobObject
  • RegGetMimeType() : RegBlobObject
  • RegGetMimeTypeSize() : RegBlobObject
  • RegGetSize() : RegBlobObject
  • RegInterface() : RegistryInterface
  • Register() : UibServiceImpl, ObexAbstractTransport, ObexServerMngr, ObexServerInfo, MessageMapContainer< T >, AbstractMessageMapContainer, AlarmManager, GatiManager, BtController, UusHandler, SmsSocketListener, PlmnHandler, PlmnDispatcher, PdpContextManager, EmlppHandler, CallForwardingHandler, StorageDevice, LookupAlphaIdExtension
  • RegisterApplication() : FeatureBroker, HttpApplicationSupplier
  • RegisterAvrcpApp() : BtAvrcpPanelServiceImpl, BtAvrcpPanelService, BtAvrcpPanelApplication
  • RegisterBipServer() : BtBipServerService
  • RegisterBrowser() : SimTkHandler
  • RegisterCallbackFunctions() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoderRenderer, AudioDecoder, AudioCapturerEncoder
  • RegisterConnApp() : GltpProviderImpl
  • RegisterDataConn() : DataConnManager
  • RegisterDataStore() : SyncMLManager
  • RegisterDecoder() : CodecManager
  • RegisterDispatcher() : BtLocalRequest
  • RegisterEncoder() : CodecManager
  • RegisterForMtlr() : LcsProviderImplBase, LcsProvider
  • RegisterFrameCapturedCB() : CamWin32
  • RegisterGetBufferCB() : CamWin32
  • RegisterGlobalProvider() : MainProvider
  • RegisterHfMessages() : BtHfAppPlugin
  • RegisterInputAction() : InputActionList
  • RegisterMessage() : ServiceThread, ExecutionContext, Application, AppContainer
  • RegisterMessages() : UserDispatcher, MessageMapDispatcher, BtObexService, BtHsService, BtHfService, BtFaxService, BtDunService, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtSendPasskeyRequest, BtSddbService, BtRespondAuthorizationRequest, BtQuerySupportedProfilesRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtBppService, BtBipServerService, BtBipClientService, BtAvrcpService, BtAvrcpOperationService
  • RegisterNewPassword : InputParser
  • RegisterNewPw() : SsHandler
  • RegisterNotify : Registry, RegEncoderDecoder
  • RegisterObexApp() : ObexMngr
  • RegisterPanelToApoxiAvrcp() : BtAvrcpPanelApplication
  • RegisterParser() : IMelody
  • RegisterRejectCause() : EnumTranslationTable
  • RegisterRemoteObjectTree() : Registry
  • RegisterRequest() : BtObexService, BtObexServerService, BtObexClientService, BtBppServerService, BtAvrcpRegistrationService
  • RegisterService() : ServiceBroker
  • RegisterServiceCallback() : BtSddbService
  • RegisterServiceRecordRequest() : BtSddbService
  • RegisterSignalListener() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • RegisterStatus() : EnumTranslationTable
  • RegisterStorageDevice() : RootFileSystem
  • RegisterSyncMLApplication() : SyncMLManager
  • RegisterTransaction() : MobileOriginatedUssdHandler
  • RegisterTransportApp() : AbstractTransport
  • RegisterType : UibApp
  • RegisterUserActivityListener() : AtlApplication
  • RegisterUtility() : AbstractSmsApp
  • RegisterWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • Registration : InputParser
  • RegistrationAllowedMsg() : RegistrationAllowedMsg
  • RegistrationChangeMsg() : RegistrationChangeMsg
  • RegistrationSuccessMsg() : RegistrationSuccessMsg
  • RegistryInterface() : RegistryInterface
  • RegIterator : RegIterator, Registry
  • RegManager : RegManager, Registry
  • RegNodeBuffer() : RegNodeBuffer
  • RegNoService : RegEncoderDecoder
  • RegNotifyMsg() : RegNotifyMsg
  • RegResChildLocked : RegEncoderDecoder
  • RegResNodeAlreadyExists : RegEncoderDecoder
  • RegResNoGetOnInterior : RegEncoderDecoder
  • RegSetMimeType() : RegBlobObject
  • RegStateIndArg() : RegStateIndArg
  • RegSuccess : RegEncoderDecoder
  • RegTcpSocket() : RegTcpSocket
  • RegularDeactivation : PdpContext
  • ReInit() : MediaInfo
  • Reinterpret() : DateEditorDocument
  • Reject() : PdpContext, CallHdl, MmCallHdl, MmCallHandler
  • RejectAllMoc() : CallHdlBase, CallHandler
  • RejectAllMtc() : CallHdlBase, CallHandler, MmCallHdl, MmCallHandler
  • RejectCallSetup() : SimTkHandler
  • RejectCallsIndArg() : RejectCallsIndArg
  • RejectConnectRequest() : ObexFtpServer
  • RejectDeleteObjectRequest() : ObexFtpServer
  • RejectDuplicates() : SmsSubmit
  • RejectFilePullRequest() : ObexFtpServer
  • RejectFilePushRequest() : ObexFtpServer
  • RejectFolderListingRequest() : ObexFtpServer
  • RejectSetCurrentFolderRequest() : ObexFtpServer
  • RejectUssdRequest() : SsHandler
  • RelationType : JoinRule
  • Relative : FunctionalityIndicator, ValidityPeriodFormat
  • RelativeBaseYear : DateTime
  • RelaySms() : AbstractSmsUtilityProcessor, AbstractSmsComposeWin, AbstractSmsApp, EmsComposeWin
  • Release() : SocketHandler, DataConn, ObexObject, ObexBuffer, SimpleSemaphore, Semaphore, SimpleMutex, SemObtainer, SimpleSemaphore, Semaphore, MutexObtainer, Mutex, AppMutex, WindowHierarchyIterator, DeviceContext, Desktop, GenericAudioDevice, ReferableObject, NiSharedPtr< X >, MemPool, MemPoolEntry, RtStreamingBuffer, MptyCallHdl, DataCallHdl, CallHdlBase, CallHdl, CallHandler, DBService::DBItemIterator, ServiceBroker, MmCallHdl, MmCallHandler
  • ReleaseAction() : ObexAbstractPort
  • ReleaseActiveCall() : CrssHandler
  • ReleaseAddress() : ObexAbstractPort
  • ReleaseAllActiveAndAcceptOther : CallSsAction
  • ReleaseAllActiveCalls() : CrssHandler, CallHdlBase
  • ReleaseAllHeldCalls() : CrssHandler, CallHdlBase
  • ReleaseAllHeldOrSetUdub : CallSsAction
  • ReleaseBuffer() : BufferPoolManager
  • ReleaseCall() : BtHsService
  • ReleaseCaptureBuffer() : VideoCamera
  • ReleaseChannel() : ObexProtocol, ObexAbstractPort, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • ReleaseConfigStreamBuffer() : EmzMpeg4Encoder, AtiMpeg4Encoder, VideoEncoder
  • ReleaseConnId() : HttpWapMgr
  • ReleaseDataCall() : CsdDataConn
  • ReleaseDataConn() : SocketData
  • ReleaseDecoder() : CodecManager
  • ReleasedEvent() : DataConn
  • ReleaseEncoder() : CodecManager
  • ReleaseGlobalProvider() : MainProvider
  • ReleaseImage() : ImageRef
  • ReleaseInstance() : FfsTestThreadlet, LcsSettingsUtils, LocResController, LcsWapIntf, LcsAppUtils, Threadlet, EncodingThreadlet, DecodingThreadlet, CompoundItem, BufferedData, BinData, HttpApplicationSupplier, HttpApplication, PngDecoder, SaSignalMapTableNode, SaProviderImpl, GltpSignalMapTableNode, GltpProviderImpl, LcsUtils, LcsReqProcessor, LcsCommonSignalMapTableNode, LcsSignalMapTableNode, LcsProviderImpl
  • ReleaseItemRenderer() : GuiEngineConfig
  • ReleaseMemMap() : RamData, DataSourceBinData, BinData, FileBinData
  • ReleaseMpty() : CrssHandler
  • ReleaseMutex() : AbstractTextRenderer
  • ReleaseOperands() : BtAvrcpRawFrameParams
  • ReleaseOperationData() : BtAvrcpPanelPassThroughParams
  • ReleaseOutputBuffer() : ScicosMpeg4VideoDecoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Encoder, AtiMpeg4Decoder, EmzMpeg4Decoder, EmzH264Decoder, VideoEncoder, VideoDecoder
  • ReleaseParams() : BtAvrcpRegisterRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest
  • ReleasePPP() : PppDataConn
  • ReleaseRequestId() : HttpWapMgrPlugin
  • ReleaseSemaphore() : AtiAudioPlayerRtStreamingSink
  • ReleaseSerialTerminal() : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • ReleaseSpecificCall : CallSsAction
  • ReleaseSpeech() : Audio
  • ReleaseSubunitInfos() : BtAvrcpRegisterParams
  • ReleaseSuspendSlot() : DwdPlayer
  • ReleaseThumbnail() : ImageRef
  • Reliability : PdpContext::QualityOfService
  • ReliabilityClass1 : PdpContext::QualityOfService
  • ReliabilityClass2 : PdpContext::QualityOfService
  • ReliabilityClass3 : PdpContext::QualityOfService
  • ReliabilityClass4 : PdpContext::QualityOfService
  • ReliabilityClass5 : PdpContext::QualityOfService
  • ReliabilityClass6 : PdpContext::QualityOfService
  • ReliabilityReserved : PdpContext::QualityOfService
  • ReliabilitySubscribed : PdpContext::QualityOfService
  • ReloadNewMsgTpdu() : SimPduHandler, DataHandler
  • ReloadTpdu() : SimPduHandler, DataHandler
  • RelTag_v1_0 : XmlParserRel
  • RelTagAgreement : XmlParserRel
  • RelTagAsset : XmlParserRel
  • RelTagConstraint : XmlParserRel
  • RelTagContext : XmlParserRel
  • RelTagCount : XmlParserRel
  • RelTagDatetime : XmlParserRel
  • RelTagDisplay : XmlParserRel
  • RelTagEnd : XmlParserRel
  • RelTagExecute : XmlParserRel
  • RelTagInterval : XmlParserRel
  • RelTagKeyInfo : XmlParserRel
  • RelTagKeyValue : XmlParserRel
  • RelTagNone : XmlParserRel
  • RelTagPermission : XmlParserRel
  • RelTagPlay : XmlParserRel
  • RelTagPrint : XmlParserRel
  • RelTagRights : XmlParserRel
  • RelTagStart : XmlParserRel
  • RelTagUid : XmlParserRel
  • RelTagVersion : XmlParserRel
  • RelWbxmlAgreement : WbxmlParserRel
  • RelWbxmlAsset : WbxmlParserRel
  • RelWbxmlAttDd : WbxmlParserRel
  • RelWbxmlAttDdVal : WbxmlParserRel
  • RelWbxmlAttLang : WbxmlParserRel
  • RelWbxmlAttLangVal : WbxmlParserRel
  • RelWbxmlAttName_v1_0 : WbxmlParserRel
  • RelWbxmlAttNone : WbxmlParserRel
  • RelWbxmlAttSig : WbxmlParserRel
  • RelWbxmlAttSigVal : WbxmlParserRel
  • RelWbxmlAttValNone : WbxmlParserRel
  • RelWbxmlAttValue_v1_0 : WbxmlParserRel
  • RelWbxmlConstraint : WbxmlParserRel
  • RelWbxmlContext : WbxmlParserRel
  • RelWbxmlCount : WbxmlParserRel
  • RelWbxmlDatetime : WbxmlParserRel
  • RelWbxmlDisplay : WbxmlParserRel
  • RelWbxmlEnd : WbxmlParserRel
  • RelWbxmlExecute : WbxmlParserRel
  • RelWbxmlInterval : WbxmlParserRel
  • RelWbxmlKeyInfo : WbxmlParserRel
  • RelWbxmlKeyValue : WbxmlParserRel
  • RelWbxmlNone : WbxmlParserRel
  • RelWbxmlPermission : WbxmlParserRel
  • RelWbxmlPlay : WbxmlParserRel
  • RelWbxmlPrint : WbxmlParserRel
  • RelWbxmlRights : WbxmlParserRel
  • RelWbxmlStart : WbxmlParserRel
  • RelWbxmlTag_v1_0 : WbxmlParserRel
  • RelWbxmlUid : WbxmlParserRel
  • RelWbxmlVersion : WbxmlParserRel
  • RememberRepliedTpdu() : AbstractSmsApp
  • RemoteAbort : TipdBasedActiveWaitDispatcher
  • RemotePartyActionMsg() : RemotePartyActionMsg
  • RemoteProcedureError : ShortMessageStatus
  • removable : FsRegistrationInfo, fs_registered_info_type
  • Removable : StorageDevice
  • Remove() : WindowManager, TextCompoundItem, GlassPane, BtDeviceList, SingleArgHook< T >, SimpleMap< TKey, TValue >, LinkedListBase, FifoLinkedList< T >, ElementList< T >, StackMsgMapTableNode, SignalMapTableNode, MessageIdentifierContainer, Cbs::Filter, SerialIoSet
  • RemoveAccessor() : UibActionAccessor
  • RemoveAction() : UibActionAccessor, ActionMenuAccessor
  • RemoveAlignInfo() : FlowLayout
  • RemoveAll() : SimpleMap< TKey, TValue >
  • RemoveAllActions() : UibActionAccessor, ActionMenuAccessor
  • RemoveAllAudioPaths() : AudioPathManager
  • RemoveAllIcons() : IconSet
  • RemoveAllIndicators() : IndicatorBar
  • RemoveAllItems() : ItemContainer, AbstractItemContainer, RadioButtonList, MenuList, CheckBoxList, AbstractMenuListModel< Item >, ProviderProxyContainer, FeatureItemContainer
  • RemoveAllPaneObjects() : GlassPane
  • RemoveAllTemplates() : VrHandler
  • RemoveAppContainer() : System
  • RemoveAppContext() : AbstractScheduler
  • RemoveApplication() : AppContainerRoutingTableEntry
  • RemoveAudioPath() : AudioPathManager
  • RemoveAuthorizationSet() : WapProfile
  • RemoveBackupFiles() : UriMappingTable
  • RemoveBlobFileRecord() : UriMappingTable
  • RemoveChildProvider() : AppendProvider
  • RemoveCompoundItem() : EmsEditor, EditorDocument, AbstractEditor, ParagraphCompoundItem, MultiMediaEditorDocument
  • RemoveConnection() : BtMultiConnectionController
  • RemoveControl() : Control
  • RemoveDataMapping() : MmfPlayer
  • RemoveDevice() : DeviceManager
  • RemoveDir() : RamHandler, FatHandler
  • RemoveDispatcher() : ExecutionContext, BtBppService
  • RemoveDrawableObject() : Control
  • RemoveElem() : HashTable
  • RemoveEmptyLines() : AbstractEditBoxModel
  • RemoveFileExtension() : Pathname
  • RemoveFilter() : CbsFilterList
  • RemoveFormattingCodes() : BidiManager
  • RemoveFromList() : SerialSocketThread
  • RemoveFromReadList() : SerialIoSet
  • RemoveFromTitlebar() : Window
  • RemoveFromWriteList() : SerialIoSet
  • RemoveHead() : Pathname
  • RemoveIndicator() : IndicatorBar
  • RemoveInteriorNodeEntry() : NodeFileHandler
  • RemoveItem() : SmsEditor, EmsEditor, TimeEditorDocument, TextEditorDocument, TextCompoundItem, PasswordEditor, ItemContainer, EditorDocument, DateEditorDocument, CompoundItem, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemContainer, AbstractEditor, RadioButtonList, MenuList, CheckBoxList, AbstractMenuListModel< Item >, ProviderProxyContainer, FeatureItemContainer, ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor, GeneralCompoundItem
  • RemoveLeaf() : Pathname
  • RemoveLockUriInTable() : LockTableList
  • RemoveMenuFeature() : BtHfAppPlugin
  • RemoveMolr() : LcsReqProcessor
  • RemoveNodeEntry() : NodeFileHandler
  • RemovePhysicalPortSet() : WapProfile
  • RemovePhysicalSet() : WapProfile
  • RemovePortSet() : WapProfile
  • RemovePostMsgHook() : MessageRouter
  • RemoveReferenceMapping() : DwdDevice
  • RemoveTab() : TabControl
  • RemoveTemplate() : VrHandler
  • RemoveTimer() : ServiceThread, ExecutionContext, Application, AppContainer
  • RemoveTrailingSeparators() : Pathname
  • RemoveUri() : LockTable
  • RemoveURIRecord() : UriMappingTable
  • RemoveView() : BrowserViewContainer
  • RemoveWindow() : Application
  • Rename() : MediaRefContainer, ImageRefContainer, MediaRefContainer, FfsFile, File, FlsFile, FfsHandler, RootFileImp, RamHandler, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile
  • RenameFileDialog() : RenameFileDialog
  • rend() : WbxmlVector< T >
  • REnd() : BtDeviceList, Vector< T >
  • Render : ThaiTextRenderer
  • render_properties : MenuPool::FeatureItemContainerTableEntry
  • RendererPropertiesProp : GuiObjectFactory
  • RendererPropertyId : AbstractItemContainer
  • RenderFrame() : VideoChannel
  • RenderType : ThaiTextRenderer
  • Replace() : TextCompoundItem, WString, String, Registry, ObjectTreeService, LocalDataStore
  • ReplaceChar() : AbstractEditBox, AbstractEditBoxModel
  • ReplaceFileId() : UriMappingTable
  • ReplaceItem() : EmsEditor, TimeEditorDocument, TextEditorDocument, TextCompoundItem, PasswordEditor, EditorDocument, DateEditorDocument, CompoundItem, AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor, ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor, GeneralCompoundItem
  • ReplaceNodeEntry() : NodeFileHandler
  • ReplaceShortMessageType1 : ProtocolIdentifier
  • ReplaceShortMessageType2 : ProtocolIdentifier
  • ReplaceShortMessageType3 : ProtocolIdentifier
  • ReplaceShortMessageType4 : ProtocolIdentifier
  • ReplaceShortMessageType5 : ProtocolIdentifier
  • ReplaceShortMessageType6 : ProtocolIdentifier
  • ReplaceShortMessageType7 : ProtocolIdentifier
  • ReplaceWithNewWord() : Zi8InputMapper
  • Reply() : UssdHandler
  • reply_path : SmsSettingsRecord::Persist
  • ReplyMessage() : FtpSocket, FtpClient
  • ReplyPathExists() : SmsDeliver, TpduHeaderInformation
  • ReplySms() : AbstractSmsApp, EmsApp
  • ReportChargeUnits() : AocHandler
  • ReportCurrentCallMeter() : CallHdlBase, MmCallHdl, MmCallHandler
  • ReportCurrentCharge() : CallHdlBase, AocHandler, MmCallHdl, MmCallHandler
  • RepositionImage() : ImageBrowserDetailWin
  • ReqFaciltyNonImpl : Sms
  • Request : ObexObject
  • RequestAcceptanceType : AudioMapiManager
  • RequestAudMapiFailure : AudioMapiManager
  • RequestBandConfig() : NetworkHandler
  • RequestChargeUnits() : AocHandler
  • RequestCurrentCharge() : AocHandler
  • RequestedServiceOptionNotSubscribed : PdpContext
  • RequestExecuted : AudioMapiManager
  • RequestExists() : LcsReqProcessor
  • RequestGetHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • RequestHeadHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • RequestOnStartup() : BootHandler, BootControl
  • RequestPostDataHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • RequestPostHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • RequestRead() : StreamReader
  • RequestRedialStatus() : CallHandler
  • RequestRejected : AudioMapiManager
  • RequestReplyPath() : SmsSubmit
  • RequestReport() : SmsCommand, SmsSubmit
  • RequestStateChangeCallback() : BtObexService, BtFaxService, BtDunService, BtService, BtSddbService, BtBppService, BtBipClientService, BtAvrcpRegistrationService, BtAvrcpOperationService
  • RequestStatus() : UusHandler, EmlppHandler, ColrHandler, ColpHandler, CnapHandler, ClirHandler, ClipHandler, CallWaitingHandler, CallForwardingHandler, CallBarringHandler
  • RequestTimeout : AudioMapiManager
  • RequestUnexpectedCommand : AudioMapiManager
  • RequestWrite() : StreamWriter
  • Reschedule() : SimpleScheduler, Scheduler, AbstractScheduler
  • Reserve() : WString, Vector< T >, String, ByteBuffer
  • reserve() : WbxmlVector< T >
  • reserved : FfsFileInfo, ffs_file_info_type
  • Reserved : InformationElement
  • ReservedAlphabet : DataCodingScheme
  • ReservedApplicationErrorBegin : ShortMessageFailureCause
  • ReservedApplicationErrorEnd : ShortMessageFailureCause
  • ReservedCodingGroup : DataCodingScheme
  • ReservedCommandErrorBegin : ShortMessageFailureCause
  • ReservedCommandErrorEnd : ShortMessageFailureCause
  • ReservedDcsErrorBegin : ShortMessageFailureCause
  • ReservedDcsErrorEnd : ShortMessageFailureCause
  • ReservedErrorValue : ShortMessageFailureCause
  • ReservedGeneralErrorBegin : ShortMessageFailureCause
  • ReservedGeneralErrorEnd : ShortMessageFailureCause
  • ReservedIdentifier : InformationElement
  • ReservedLanguage : DataCodingScheme
  • ReservedMessageType : ProtocolIdentifier
  • ReservedNumberingPlan : TypeOfAddress
  • ReservedPidErrorBegin : ShortMessageFailureCause
  • ReservedPidErrorEnd : ShortMessageFailureCause
  • ReservedReason : ShortMessageStatus
  • ReservedScErrorBegin : ShortMessageFailureCause
  • ReservedScErrorEnd : ShortMessageFailureCause
  • ReservedStatus : ShortMessageStatus
  • ReservedTelematicDevice : ProtocolIdentifier
  • ReservedTimeFormat : FunctionalityIndicator
  • ReservedTpduErrorBegin : ShortMessageFailureCause
  • ReservedTpduErrorEnd : ShortMessageFailureCause
  • ReservedType : MessageTypeIndicator, CommandType
  • ReservedTypeOfNumber : TypeOfAddress
  • ReservedUsage : ProtocolIdentifier
  • ReservedUSimErrorBegin : ShortMessageFailureCause
  • ReservedUSimErrorEnd : ShortMessageFailureCause
  • Reset : PppSetupCallBackData, ObexServerPort, StartUp::Data, EmzUtils::Queue< T >, EmzH264Decoder, EmzUtils::Queue< T >, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, Led, AbstractEditBoxModel, DateTime::Persist, StackMsgActiveWaitDispatcher, SmsFactory, PdpContextManager::AttachStatus, PdpContextManager::DataCounters, PdpContext::ActivationStatus, PdpContext::QualityOfService, PdpContext::Address, DataCallContext, UserData, UriMappingTable, Pathname, VrHandler, RamFileObj, StatusProvider, SimTkMainMenuProvider, SimSmsParamHandler, SimPduHandler, SimPbEntryCont, SimPbBaseHandler, SimCphsHandler, SimChvHandler, SimAuxHandler, SimAccessor, DataHandler, Camera
  • reset_em : AsTestparamDatabase
  • reset_mm_cnt : CellChangeCnts
  • ResetCounter() : SmsEditor
  • ResetCountersPending : PdpContextManager
  • ResetData() : SimPbEntry
  • ResetDataConnIdleTimer() : SocketData, InetSocket
  • ResetDataCounters() : PdpContextManager
  • ResetDeletionBuffer() : RegDeletionBufferEntry
  • ResetFileId() : RegNodeBuffer
  • ResetIdleTimer() : DataConn
  • ResetModification() : Provider
  • ResetRefCount() : WStrData, StrData
  • ResetRequestState() : BtRequest
  • ResetToFactoryDefaults() : DataConnProfileStorage, DataConnProfileManager
  • ResetTransformation() : SvgImage
  • Resize() : IndexTable< T >, FixedPtrArray< T >, File, FlsFile, RootFileImp, RamHandler, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile, TpduCache
  • resize() : WbxmlVector< T >
  • ResizeData() : Tpdu, Cbs
  • ResizeIndexTable() : SortProvider
  • resolution : Media::Parameters
  • resolveAttributeName() : WbxmlRelHandler
  • resolveAttributeValue() : WbxmlRelHandler
  • ResolveClientAddr() : ObexAbstractTransport, IrdaObexTransport, BtObexTransport, UsbObexTransport
  • ResolveCompleteAction() : ObexAbstractPort
  • ResolveServerAddr() : ObexAbstractTransport, IrdaObexTransport, BtObexTransport, UsbObexTransport
  • resolveTagName() : WbxmlRelHandler
  • ResourceID() : ResourceID
  • ResourceLimitation : TaggedProblemCode
  • ResourceNotAvailable : ObexResult
  • ResourcesNotAvailable : SsErrorCode
  • ResourcesUnavailable : Sms
  • ResourceType : CTResourcePack
  • RespBadGateWay : ObexObject
  • RespBadRequest : ObexObject
  • RespConflict : ObexObject
  • RespDatabaseFull : ObexObject
  • RespDatabaseLocked : ObexObject
  • RespForbidden : ObexObject
  • RespGatewayTimeOut : ObexObject
  • RespGone : ObexObject
  • RespHttpVersionNotSupported : ObexObject
  • RespInternalServerError : ObexObject
  • RespLengthRequired : ObexObject
  • RespMethodNotAllowed : ObexObject
  • RespMovedPermanently : ObexObject
  • RespMovedTemporarily : ObexObject
  • RespMultipleChoices : ObexObject
  • RespNotAcceptable : ObexObject
  • RespNotFound : ObexObject
  • RespNotImplemented : ObexObject
  • RespNotModified : ObexObject
  • RespOk : ObexObject
  • Response : RegEncoderDecoder
  • ResponseCode : ObexObject, BtObexResponseCode
  • ResponseMessage : RegEncoderDecoder
  • ResponseType : RegEncoderDecoder, AtResponse
  • RespPaymentRequired : ObexObject
  • RespPreconditionFailed : ObexObject
  • RespProxyAuthenticationRequired : ObexObject
  • RespRequestedEntityTooLarge : ObexObject
  • RespRequestTimeOut : ObexObject
  • RespRequestUnsupportedMediaType : ObexObject
  • RespRequestUrlTooLarge : ObexObject
  • RespSeeOther : ObexObject
  • RespServiceUnavailable : ObexObject
  • RespUnauthorized : ObexObject
  • RespUseProxy : ObexObject
  • rest_read_compressed : FileInReadStatusInfo, BinDataInReadStatusInfo
  • rest_read_uncompressed : FileInReadStatusInfo, BinDataInReadStatusInfo
  • Restart : Timer, SystemTimer, ImageBox, StartUp, SharedTimer, SvgPlayer, ShutDown
  • RestartHf() : MiscAudioDevice
  • RestartViewfinder() : Camera
  • RestoreFactorySettings() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, BtHfProvider, SettingsProvider
  • RestoreSoftkeys() : PbAbstractWin
  • result : InterrogationResultArg, MsapPackedData_s
  • Result : Camera, BtJsr82Url, ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, Sms, SioGlueWrapper, SerialTerminal
  • ResultType : BufferPoolManager, CodecDevice
  • ResultWinBase() : ResultWinBase
  • Resume() : Timer, Thread, Mp3AudioDevice, SharedTimer, AudioActiveReference
  • ResumeHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ResumeRecord() : VoiceMemoWin, VoiceMemoRecordWin, MediaRecorder
  • ResumeRecording() : VoiceMemoApp
  • ResumeSuspended() : MP3AudioPlayer, MmfPlayer
  • ResumeWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • ResWinAction : ResultWinBase
  • ReTranslate() : LanguageManager
  • Retrieve() : MptyCallHdl, CrssHandler, CallHdl
  • RetrieveCbmi() : SimAuxHandler
  • RetrieveCbmiRanges() : SimAuxHandler
  • RetrieveCcp() : SimAuxHandler
  • RetrieveCingularTst() : SimCphsHandler
  • RetrieveCmi() : SimAuxHandler
  • RetrieveCspData() : SimCphsHandler
  • RetrieveEccList() : SimAuxHandler
  • RetrieveEonsData() : SimAuxHandler
  • RetrieveExtLanguageList() : SimAuxHandler
  • RetrieveLanguageList() : SimAuxHandler
  • RetrieveLociData() : SimAuxHandler
  • RetrieveMbi() : SimAuxHandler
  • RetrieveMtlr() : LcsReqProcessor
  • RetrievePlmnList() : SimAuxHandler
  • RetrievePlmnwactList() : SimAuxHandler
  • RetrieveSmsServiceParameter() : SimSmsParamHandler
  • RetrieveSst() : SimAuxHandler
  • RetrieveUsimSmsServiceParameter() : SimSmsParamHandler
  • ReturnCallMessage : ProtocolIdentifier
  • ReturnError : TaggedProblemCode
  • ReturnErrorUnexpected : TaggedProblemCode
  • ReturnId : MessageBox, DialogWindow
  • ReturnObexAddress() : ObexAbstractTransport
  • ReturnReport() : SmsDeliver
  • ReturnResponse() : ObexServer, ObexLayer, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • ReturnResponseBuffer() : StreamObexImpl
  • ReturnResult : TaggedProblemCode
  • ReturnResultUnexpected : TaggedProblemCode
  • ReusedExtendedObject : InformationElement
  • reverse_iterator : WbxmlVector< T >
  • ReverseBegin() : Pathname
  • ReverseEnd() : Pathname
  • ReverseIterator : Pathname::ReverseIterator, Vector< T >
  • Rewind() : MmfPlayer, MediaPlayer
  • RewindApiCompletionMsg : MediaManager
  • RewindingState : MediaPlayer
  • Rfc1144 : PdpContext
  • Rfc2507 : PdpContext
  • Rfc3095 : PdpContext
  • Rfc822EmailHeader : InformationElement
  • RfcommSocketAddr() : RfcommSocketAddr
  • RfsMedia : StreamAudioReference
  • RfsMediaAvailableStatusMsg() : RfsMediaAvailableStatusMsg
  • RfsObexFtpServer() : RfsObexFtpServer
  • RfsStorageDeviceRegistrationStatusMsg() : RfsStorageDeviceRegistrationStatusMsg
  • Rgb565ColorSpace : Image::MetaData
  • Rgb888ColorSpace : Image::MetaData
  • Rgba8888ColorSpace : Image::MetaData
  • RgbAlphaFormat : PngEncoder::EncodingParameters
  • RgbFormat : PngEncoder::EncodingParameters
  • RichTextCompoundItem() : RichTextCompoundItem
  • Right : TextFormat, Layouter, GridLayout, Control::NavigationGuidance, AbstractGrid, Indicator, InformationElement
  • RightAlign : EditorDocument
  • RightPos : TabButton
  • RightSection : Desktop
  • RightSoftkeyProp : GuiObjectFactory
  • RightToLeft : Locale
  • RightToLeftType : BidiManager
  • Ring : AtResponse
  • ring_tone : RingerAudioDevice::StartParam
  • ring_tone_id : RingerAudioDevice::RingerToneInfo
  • ringer : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • Ringer1 : RingerAudioDevice
  • Ringer10 : RingerAudioDevice
  • Ringer11 : RingerAudioDevice
  • Ringer12 : RingerAudioDevice
  • Ringer13 : RingerAudioDevice
  • Ringer14 : RingerAudioDevice
  • Ringer15 : RingerAudioDevice
  • Ringer16 : RingerAudioDevice
  • Ringer17 : RingerAudioDevice
  • Ringer18 : RingerAudioDevice
  • Ringer19 : RingerAudioDevice
  • Ringer2 : RingerAudioDevice
  • Ringer20 : RingerAudioDevice
  • Ringer21 : RingerAudioDevice
  • Ringer22 : RingerAudioDevice
  • Ringer23 : RingerAudioDevice
  • Ringer24 : RingerAudioDevice
  • Ringer25 : RingerAudioDevice
  • Ringer26 : RingerAudioDevice
  • Ringer27 : RingerAudioDevice
  • Ringer28 : RingerAudioDevice
  • Ringer29 : RingerAudioDevice
  • Ringer3 : RingerAudioDevice
  • Ringer30 : RingerAudioDevice
  • Ringer31 : RingerAudioDevice
  • Ringer32 : RingerAudioDevice
  • Ringer33 : RingerAudioDevice
  • Ringer34 : RingerAudioDevice
  • Ringer35 : RingerAudioDevice
  • Ringer36 : RingerAudioDevice
  • Ringer37 : RingerAudioDevice
  • Ringer38 : RingerAudioDevice
  • Ringer39 : RingerAudioDevice
  • Ringer4 : RingerAudioDevice
  • Ringer40 : RingerAudioDevice
  • Ringer41 : RingerAudioDevice
  • Ringer42 : RingerAudioDevice
  • Ringer43 : RingerAudioDevice
  • Ringer44 : RingerAudioDevice
  • Ringer45 : RingerAudioDevice
  • Ringer46 : RingerAudioDevice
  • Ringer47 : RingerAudioDevice
  • Ringer48 : RingerAudioDevice
  • Ringer49 : RingerAudioDevice
  • Ringer5 : RingerAudioDevice
  • Ringer50 : RingerAudioDevice
  • Ringer6 : RingerAudioDevice
  • Ringer7 : RingerAudioDevice
  • Ringer8 : RingerAudioDevice
  • Ringer9 : RingerAudioDevice
  • RingerAlarm1 : RingerAudioDevice
  • RingerAlarm10 : RingerAudioDevice
  • RingerAlarm2 : RingerAudioDevice
  • RingerAlarm3 : RingerAudioDevice
  • RingerAlarm4 : RingerAudioDevice
  • RingerAlarm5 : RingerAudioDevice
  • RingerAlarm6 : RingerAudioDevice
  • RingerAlarm7 : RingerAudioDevice
  • RingerAlarm8 : RingerAudioDevice
  • RingerAlarm9 : RingerAudioDevice
  • RingerAudioDevice() : RingerAudioDevice
  • RingerAudioPlayer : AudioReference
  • RingerBroadcast1 : RingerAudioDevice
  • RingerBroadcast10 : RingerAudioDevice
  • RingerBroadcast2 : RingerAudioDevice
  • RingerBroadcast3 : RingerAudioDevice
  • RingerBroadcast4 : RingerAudioDevice
  • RingerBroadcast5 : RingerAudioDevice
  • RingerBroadcast6 : RingerAudioDevice
  • RingerBroadcast7 : RingerAudioDevice
  • RingerBroadcast8 : RingerAudioDevice
  • RingerBroadcast9 : RingerAudioDevice
  • RingerDevice : RingerAudioDevice
  • RingerDeviceID : AudioDeviceManager
  • RingerDeviceSound : RingerAudioDevice
  • RingerDeviceSoundAndVibrator : RingerAudioDevice
  • RingerDeviceVibrator : RingerAudioDevice
  • RingerGame1 : RingerAudioDevice
  • RingerGame10 : RingerAudioDevice
  • RingerGame2 : RingerAudioDevice
  • RingerGame3 : RingerAudioDevice
  • RingerGame4 : RingerAudioDevice
  • RingerGame5 : RingerAudioDevice
  • RingerGame6 : RingerAudioDevice
  • RingerGame7 : RingerAudioDevice
  • RingerGame8 : RingerAudioDevice
  • RingerGame9 : RingerAudioDevice
  • RingerInfoConnection : RingerAudioDevice
  • RingerInfoDeviceIn : RingerAudioDevice
  • RingerInfoDeviceOut : RingerAudioDevice
  • RingerInfoError1 : RingerAudioDevice
  • RingerInfoError2 : RingerAudioDevice
  • RingerInfoLowBat : RingerAudioDevice
  • RingerInfoMsgFull : RingerAudioDevice
  • RingerInfoPowerOff : RingerAudioDevice
  • RingerInfoPowerOn : RingerAudioDevice
  • RingerMessage1 : RingerAudioDevice
  • RingerMessage10 : RingerAudioDevice
  • RingerMessage2 : RingerAudioDevice
  • RingerMessage3 : RingerAudioDevice
  • RingerMessage4 : RingerAudioDevice
  • RingerMessage5 : RingerAudioDevice
  • RingerMessage6 : RingerAudioDevice
  • RingerMessage7 : RingerAudioDevice
  • RingerMessage8 : RingerAudioDevice
  • RingerMessage9 : RingerAudioDevice
  • RingerType : AudioPreset
  • RingerVolume : RingerAudioDevice
  • RingerVolume1 : RingerAudioDevice
  • RingerVolume2 : RingerAudioDevice
  • RingerVolume3 : RingerAudioDevice
  • RingerVolume4 : RingerAudioDevice
  • RingerVolume5 : RingerAudioDevice
  • RingerVolumeInCall : RingerAudioDevice
  • RingerVolumeOff : RingerAudioDevice
  • RingRequest() : BtHsService
  • RingTone : RingerAudioDevice
  • rll : L1Param, CellParam
  • Rollback() : DBService
  • RollBackTransaction() : BackupFileHandler
  • Romanian : LanguageManager
  • RomData() : RomData
  • RomFont() : RomFont
  • RootDirectoryIteratorImp() : RootDirectoryIteratorImp
  • RootFileImp : RootFileImp, File
  • RootFileSystem : RootStorageDeviceIterator, StorageDeviceIterator, StorageDevice, File, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • RootStorageDeviceImp : RootStorageDeviceImp, RootFileImp
  • RootStorageDeviceIterator() : RootStorageDeviceIterator
  • rooturi : GuidUriTable
  • Rot180 : DeviceContext
  • Rot270 : DeviceContext
  • Rot90 : DeviceContext
  • Rotate : SvgPlayer, SvgImage, VideoChannel
  • Rotate180 : CamWin32, Camera
  • Rotate270 : CamWin32, Camera
  • Rotate90 : CamWin32, Camera
  • Rotation180Transformation : VideoChannel
  • Rotation270Transformation : VideoChannel
  • Rotation90Transformation : VideoChannel
  • Rounded : CTResourcePack
  • RoundedCornerRadius : CTResourcePack
  • RouteData() : ExternalCommunicationHandler, SignalHandler
  • RouteMessage() : Dispatcher, Application, Control, AtlApplication, Zi8PredictiveInputBox, T9PredictiveInputBox
  • RowColumnPropType : GuiObjectFactory
  • RowCount() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, SmsTemplateProvider, SmsSettingsProvider, DataConnProvider, CalendarProvider, BtDeviceListProvider, PbRecordProvider, PbRecordHandler, PbNumberFilterProvider, PbDetailProvider, GroupProvider, Provider, FindProvider, FilterProvider, AbstractDelegationProvider, SettingsProvider, JoinProvider, AppendProvider, LanguageProvider, StatusProvider, SstProvider, SmsUnsentProvider, SmsUnreadProvider, SmsSentProvider, SmsReadProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, SimTkMainMenuProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PlmnProvider, PbBaseProvider, MbiProvider, LockProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CountryProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • RowCountProp : GuiObjectFactory
  • RowPropertiesProp : GuiObjectFactory
  • RpAck : Sms
  • RParameterDuplicatedErr : BtJsr82Url
  • RParameterValueRangeErr : BtJsr82Url
  • RParsing : BtJsr82Url
  • rr_mode : TestparamReport
  • rr_param : TestparamReport
  • rrc_param : TestparamReport
  • rrc_state : RrcParam
  • rrcbp_state : RrcParam, AsTestparamDatabase
  • rrcdc_state : RrcParam, AsTestparamDatabase
  • rrcm_state : RrcParam, AsTestparamDatabase
  • RrcParam : RrcParam, TestparamReport
  • RrMode : TestparamReport
  • RrParam : RrParam, TestparamReport
  • RSecuritySettingsErr : BtJsr82Url
  • RSuccess : BtJsr82Url
  • RSyntaxErr : BtJsr82Url
  • RtcAlarmReachedMsg() : RtcAlarmReachedMsg
  • RtcDateChangedMsg() : RtcDateChangedMsg
  • RtcEventCallbackFn : RtcSignalProcessor
  • RtcInfo : RealTimeClock
  • RtcInfoMsg() : RtcInfoMsg
  • RtcTimeChangedMsg() : RtcTimeChangedMsg
  • RtStreamingBuffer() : RtStreamingBuffer
  • RtStreamingConn : RtStreamingConn, RtStreamingSource, RtStreamingSink
  • RtStreamingEndPoint : RtStreamingEndPoint, RtStreamingConn
  • RtStreamingSink : RtStreamingSink, RtStreamingConn
  • RtStreamingSource : RtStreamingSource, RtStreamingConn
  • Run() : UibTest2, UibTest1, UibSortingTest, UibSettingsTest, UibPerformanceTest, UibNotifyTest, UibMsgDisplayTest, UibInboxTest, UibAccessorTest, ServiceThread, Thread, AppContainer
  • run_level : ServiceThreadStarter::StartParam
  • RunAtCommandResponse() : SimTkHandler
  • running_version : tagCustomizationPack
  • Russian : LanguageManager, DataCodingScheme
  • rxlev : NeighbourCell
  • rxlev_access_min : CellParam
  • rxlev_full : CellParam
  • rxlev_serv : CellParam
  • rxlev_sub : CellParam
  • rxqual : L1Param
  • rxqual_full : CellParam
  • rxqual_sub : CellParam
Generated on Wed Jan 25 00:54:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • s_coding_scheme_type : SimImageDescriptor
  • s_extension_separator : Pathname
  • s_file_id_high : SimImageDescriptor
  • s_file_id_low : SimImageDescriptor
  • s_file_instance_length_high : SimImageDescriptor
  • s_file_instance_length_low : SimImageDescriptor
  • s_file_instance_offset_high : SimImageDescriptor
  • s_file_instance_offset_low : SimImageDescriptor
  • s_height : SimImageDescriptor
  • s_instance : HttpApplication
  • s_instance_cnt : ServerClient, RamDataSink
  • s_root_pathname : Pathname
  • s_separator : Pathname
  • s_width : SimImageDescriptor
  • SaLocationErrArg() : SaLocationErrArg
  • SaMolrResultArg() : SaMolrResultArg
  • sample_rate : PcmParam
  • SampleRateType : StreamAudioReference
  • SamplingFrequencyNotSupportedMsg : MediaManager
  • SaStackMsgArgsDestroyTableNode : SaLocationErrArg, SaMolrResultArg
  • SatelliteInfo() : SatelliteInfo
  • SatteliteGraphWin() : SatteliteGraphWin
  • SatteliteInfoWin() : SatteliteInfoWin
  • Saturday : Date
  • Save() : WapProfile, RamDataSink
  • SaveCalendarRecord() : CalendarApp
  • SaveEdit() : PbDetails
  • SaveEntryInPhonebook() : PhonebookApp
  • SaveEntryInPhonebookMsg() : SaveEntryInPhonebookMsg
  • SaveFrequency() : FmRadioWindow
  • SaveFrom() : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile
  • SaveImage() : ImageBrowserApp
  • SaveMedia() : MediaRefContainer
  • SaveNoAction() : SaveNoAction
  • SaveNumberInPhonebook() : PhonebookApp
  • SavePhoneNo() : PbPhoneNumberPrompt
  • SaveProfile() : DataConnProfileManager
  • SaveSound() : SoundBrowserApp
  • SaveT9Udb() : T9InputConfig
  • SaveTo() : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile
  • SaveWapProfile() : WapProfileMgr
  • SaveZi8Udb() : Zi8InputConfig
  • SavingProgressWin() : SavingProgressWin
  • sc : CallBarringInfo, ForwardingInfo
  • ScaleToBounds : DisplaySettings
  • ScaleType : DisplaySettings
  • ScalingMethodType : VideoChannel, Camera, VideoChannel
  • Scan() : SmsTextParser, WString, String, PlmnHandler
  • ScanAsciiString() : ObexUrlStrParser
  • ScanDisk() : StorageDevice
  • ScanInternalError : StorageDevice
  • ScanlineAccessor() : ScanlineAccessor
  • ScanlineBufferError : Image
  • Scanner : BtJsr82Url::Token, BtJsr82Url
  • ScanNonRepairableProblemDetected : StorageDevice
  • ScanNotSupported : StorageDevice
  • ScanOctetString() : ObexUrlStrParser
  • ScanOk : StorageDevice
  • ScanProblemDetected : StorageDevice
  • ScanProblemRepaired : StorageDevice
  • ScanRepairableProblemDetected : StorageDevice
  • ScanRepairFailed : StorageDevice
  • ScanResult : StorageDevice
  • ScBusy : ShortMessageFailureCause
  • Scheduler() : Scheduler
  • ScicosCodecIfLib : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder
  • ScreeningIndicator : PhoneNumber
  • ScreeningUndefined : PhoneNumber
  • ScreenSizingParameters : SimTkProfile
  • Scroll() : DeviceContext, VirtualDisplay
  • ScrollbarAlignment : OptionalConfigBase
  • ScrollbarDisplayPolicy : OptionalConfigBase
  • ScrollDelayProp : GuiObjectFactory
  • ScrollGap : OptionalConfigBase
  • ScrollGapProp : GuiObjectFactory
  • ScrollText() : DefaultItemRenderer, AbstractItemRenderer
  • ScSystemFailure : ShortMessageFailureCause
  • SdbAutoRegister : ObexServerDispatcher
  • sdn_size : PhoneBookInfo
  • sdn_tagsize : PhoneBookInfo
  • SearchBackupFileId() : UriMappingTable
  • SearchBox() : SearchBox
  • SearchDataItems() : DBService
  • SearchFileId() : UriMappingTable
  • SearchForFiles() : MediaRefContainer
  • SearchRow() : PhonebookApp
  • SearchStopLevel : RadioAudioDevice
  • SearchStopLevelHigh : RadioAudioDevice
  • SearchStopLevelLow : RadioAudioDevice
  • SearchStopLevelMid : RadioAudioDevice
  • SearchUri() : NotificationArray, LockTable
  • SecLockResult() : EnumTranslationTable
  • second : RealTimeClock::DateAndTime
  • SecondaryDefinePending : PdpContextManager
  • SecondaryUndefinePending : PdpContextManager
  • SecondOnly : JoinProvider
  • Seconds : FunctionalityIndicator
  • SectionAlignment : Desktop
  • SectionType : Desktop
  • SecureCellBroadcastDataDownloadRangeBegin : MessageIdentifier
  • SecureCellBroadcastDataDownloadRangeEnd : MessageIdentifier
  • Seek() : Mp3AudioDevice, StreamWriter, StreamReader, File, FatHandler
  • SeekCur : File
  • SeekDirection : RadioAudioDevice
  • SeekDirectionDown : RadioAudioDevice
  • SeekDirectionUp : RadioAudioDevice
  • SeekEnd : File
  • SeekMode : RadioAudioDevice
  • SeekModeAuto : RadioAudioDevice
  • SeekModeManual : RadioAudioDevice
  • SeekOrigin : File
  • SeekSet : File
  • SeekStation() : RadioAudioDevice
  • Select() : SerialIoSet
  • SelectBitmapId : AbstractPredictiveInputBox
  • SelectComponent() : Zi8Wrapper
  • selected_cug : CugDescriptor
  • SelectedCheckBoxBitmap : CTResourcePack
  • SelectedCheckBoxBitmapUri : CTResourcePack
  • SelectedCheckBoxId : Theme
  • SelectedLine : XCallInfoResponseParser
  • SelectedProp : GuiObjectFactory
  • SelectedPropertyId : AbstractToggleAction
  • SelectedRadioButtonBitmap : CTResourcePack
  • SelectedRadioButtonBitmapUri : CTResourcePack
  • SelectedRadioButtonId : Theme
  • SelectedStyle : AbstractItemRenderer
  • SelectEmailAddress() : PhonebookApp, AdvPbApp
  • SelectGroup() : AdvPbApp
  • SelectImage() : ImageBrowserApp
  • SelectionBackground : Color
  • SelectionBackgroundColor : CTResourcePack
  • SelectionBox() : SelectionBox
  • SelectionBoxChineseId : AbstractPredictiveInputBox
  • SelectionBoxComponentsId : AbstractPredictiveInputBox
  • SelectionBoxIndexId : AbstractPredictiveInputBox
  • SelectionBoxSimpId : AbstractPredictiveInputBox
  • SelectionBoxTradId : AbstractPredictiveInputBox
  • SelectionBoxView() : SelectionBoxView
  • SelectionByUsingSoftkey() : SimSetupMenuOptions, SimSelectItemOptions
  • SelectionChangedMsg() : SelectionChangedMsg
  • SelectionForeground : Color
  • SelectionForegroundColor : CTResourcePack
  • SelectionStyle : AbstractEditor, OptionalConfigBase
  • SelectItemReqArg() : SelectItemReqArg
  • SelectItemRspArg() : SelectItemRspArg
  • SelectMediaTracks() : MediaPlayer
  • SelectMuteChannel() : RadioAudioDevice
  • SelectNoType() : AdvPbApp
  • selector : InterrogateSsResult, Rdn
  • SelectPhoneNumber() : PhonebookApp
  • SelectPhoneticChineseWord() : ChineseT9Wrapper
  • SelectRow() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, DataConnProvider, CalendarProvider, BtHfProvider, PbRecordProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider, SmsParamProvider, PrefPlmnProvider, PbBaseProvider, MbiProvider
  • SelectSimPos() : PhonebookApp
  • SelectSound() : SoundBrowserApp
  • SelectStrokeChineseWord() : ChineseT9Wrapper
  • SelectTransport() : ObexMngr
  • SelectUsimPb() : DataHandler
  • SelfLocationDialog() : SelfLocationDialog
  • SelfLocationReq() : LcsProviderImplBase, LcsProvider
  • SelLineNotValid : XCallInfoResponseParser
  • SemanticIncorrectMsg : PdpContext
  • SemantIncorrectMsg : Sms
  • Semaphore : Semaphore, Ticks
  • SemiDashed : Pen
  • SemObtainer() : SemObtainer
  • Send() : SysSocket, ClientNetAdapter, NetAdapterHandler, SmsFactory
  • send_signal_func : StackMsgMapTableEntry
  • SendAbortReq() : LcsAppUtils
  • SendAlertInd() : CallHdl
  • SendAsMms() : MediaRef
  • SendCcbsInvoke() : SsCcbsHandler
  • SendCcbsReCallRequest() : SsCcbsHandler
  • SendCcbsReject() : SsCcbsHandler
  • SendControlString() : SsHandler
  • SendData() : AudioGatiServer, GatiManager
  • SendDataControlBootProgressMsg() : BootControl
  • SendDetectedError() : SsHandler
  • SendEmail() : AbstractSmsApp
  • SendEndReq() : LcsProviderImpl
  • SendEngineeringModeControlRequest() : NetworkHandler
  • SendError() : UssdHandler
  • SendFinalReport() : SocketTestT4, SocketTestT3
  • SendIdleScreenAvailEvent() : SimTkHandler
  • SendImpl() : SmsUtility, AbstractSmsUtilityProcessor, EmsApp
  • sending_confirmation : SmsSettingsRecord::Persist
  • SendingAnimationType : AbstractSmsApp
  • SendInternalSmsType : AbstractSmsApp
  • SendInterruptedMsg() : ImageIncrementalPdcUpdater, IncrementalPdcUpdater
  • SendLanguageSelectEvent() : SimTkHandler
  • SendMsg() : SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, AbstractScheduler, AbstractAppContext
  • SendNmeaData() : LcsProviderImplBase
  • SendNotification() : PropertyEditor, NotificationArray
  • SendNotificationsToApps() : NotificationTable
  • SendPassword() : GetPasswordMsg, CallBarringHandler
  • SendPasswordResponse() : SsHandler
  • SendPowerDownNotification() : SubSystemManager
  • SendPowerUpNotification() : SubSystemManager
  • SendProactiveCommand() : SimAccessor
  • SendProactiveCommandConfirmation() : SimAccessor
  • SendProgressMsg() : ImageIncrementalPdcUpdater, IncrementalPdcUpdater
  • SendRegisterNotification() : RegAppWin
  • SendRejection() : UssdHandler
  • SendRequestMsg() : SendRequestMsg
  • SendResponse() : BtObexServerService, HttpSocket
  • SendSelf() : Dispatcher
  • SendSetUpMsgToPC() : RegAppWin
  • SendSignal() : StackMsgMapTable
  • SendSimTkRefreshRsp() : SimTkHandler
  • SendSms() : BasicSmsService, AbstractSmsApp, SmsHandler
  • SendSmsMsg() : SendSmsMsg
  • SendSmsType : AbstractSmsApp
  • SendTo() : SysSocket
  • SendToManyRecipient() : EmsApp
  • SendUserActivityEvent() : SimTkHandler
  • SendUssdRequest() : MobileOriginatedUssdHandler
  • SendUssdReturnResult() : SsHandler
  • SendVerificationResult() : LcsProviderImplBase, LcsProvider, LcsProviderImpl
  • Sent : Tpdu
  • SentSmsrInSmsr : Tpdu
  • SentSmsrNoSmsr : Tpdu
  • SentSmsrReq : Tpdu
  • SeparatorPropertyId : Item
  • SepiaFilter : Camera
  • September : Date
  • Serbian : LanguageManager
  • SerboCroatian : LanguageManager
  • SerDataConnAccessor() : SerDataConnAccessor
  • SerDataConnProvider() : SerDataConnProvider
  • SerialClientSocket : SerialClientSocket, SerialSocketSubSystem, SerialSocketData
  • SerialIoAdapter : SerialIoAdapter, SerialSocket
  • SerialIoSet : SerialIoSet, SerialSocket, SerialIoAdapter
  • SerialNumber() : Cbs::SerialNumber
  • SerialServerSocket : SerialServerSocket, SerialSocketSubSystem, SerialSocketData, SerialClientSocket
  • SerialSocket : SerialSocket, SerialSocketSubSystem, SerialSocketData, SerialIoAdapter
  • SerialSocketData : SocketData
  • SerialSocketDataLock : SerialSocketDataLock, SerialSocketSubSystem
  • SerialSocketEvent : SerialIoSet
  • SerialSocketSubSystem : SerialSocketSubSystem, SerialSocketData
  • SerialSocketThread : SerialSocketThread, SerialSocketSubSystem
  • SerialTerminalArg() : SerialTerminalArg
  • SerialTerminalListener() : SerialTerminalListener
  • SerialTerminalMsgArgsDestroyTableNode : SerialTerminalArg
  • SerialTerminalSocket() : SerialTerminalSocket
  • serif : tagFontFamily
  • SerPropCount : DataConnApp
  • SerPropertyId : DataConnApp
  • serv_group : CcbsEntry
  • ServAls : SimCphsHandler
  • ServAoC : SimCphsHandler
  • ServBaic : SimCphsHandler
  • ServBicRoam : SimCphsHandler
  • ServBoac : SimCphsHandler
  • ServBoic : SimCphsHandler
  • ServBoicExHc : SimCphsHandler
  • ServCcbs : SimCphsHandler
  • ServCfb : SimCphsHandler
  • ServCfnrc : SimCphsHandler
  • ServCfnry : SimCphsHandler
  • ServCfu : SimCphsHandler
  • ServCliBlock : SimCphsHandler
  • ServClip : SimCphsHandler
  • ServCliSend : SimCphsHandler
  • ServCoLp : SimCphsHandler
  • ServCoLr : SimCphsHandler
  • ServCt : SimCphsHandler
  • ServCug : SimCphsHandler
  • ServCugOA : SimCphsHandler
  • ServCw : SimCphsHandler
  • ServData : SimCphsHandler
  • ServDelConf : SimCphsHandler
  • Server : Server, ServerClient
  • server : BtObexServiceTable::Security
  • ServerAddressWin() : ServerAddressWin
  • ServerAddrTypeId : ObexAbstractTransport
  • ServerAlreadyClosed : ObexResult
  • ServerAlreadyKnown : ObexResult
  • ServerAlreadyOpen : ObexResult
  • ServerAppContext : IrdaObexImpl
  • ServerCallBack() : IrdaObexTransport
  • ServerClient() : ServerClient
  • ServerConfig() : ServerConfig
  • ServerPortPtr : ObexServerDispatcher
  • ServerRead() : SocketTestT2
  • ServerUrlType : BtJsr82Url
  • ServFax : SimCphsHandler
  • ServGprs : SimCphsHandler
  • ServHold : SimCphsHandler
  • ServHscsd : SimCphsHandler
  • Service : Service, ServiceBroker
  • service_class : BtObexServiceTable::Entry
  • service_name : BtObexServiceTable::Entry
  • service_ses : BtObexServiceTable::Entry
  • service_state : GmmParam, MmcsParam
  • SERVICE_THREAD : ExecutionContext
  • service_type : BtObexServiceTable::Entry
  • ServiceBrokerDestructor : ServiceBroker
  • ServiceCenterSpecificReason : ShortMessageStatus
  • ServiceCenterSpecificTelematicDevice : ProtocolIdentifier
  • ServiceCenterSpecificType : CommandType
  • ServiceCenterSpecificUsage : ProtocolIdentifier
  • ServiceCentreSpecificPlan : TypeOfAddress
  • ServiceGroup() : EnumTranslationTable
  • ServiceInfo() : BtObexServiceTable::ServiceInfo
  • ServiceList : ServiceBroker
  • ServiceOptionNotSupported : PdpContext
  • ServiceOptionTemporaryOutOfOrder : PdpContext
  • ServicePlug : Accessory
  • serviceptr : GuidUriTable
  • ServicePtr() : ServicePtr< T >
  • ServiceReady() : PhonebookApp, AdvPbApp
  • ServiceRejected : ShortMessageStatus
  • ServiceResult : Service
  • ServiceThread : ServiceThread, Timer, System, MsgQueue
  • ServiceThreadStarter() : ServiceThreadStarter
  • ServiceThreadTerminateMsg() : ServiceThreadTerminateMsg
  • ServiceType : BtObexServiceTable
  • ServiceUnavailable : BtObexResponseCode
  • ServInfoNumbers : SimCphsHandler
  • serving_cell : TestparamReport
  • ServingCell : TestparamReport
  • ServLanguage : SimCphsHandler
  • ServMci : SimCphsHandler
  • ServMpty : SimCphsHandler
  • ServMtplBand : SimCphsHandler
  • ServMtplSubscrPfl : SimCphsHandler
  • ServPlmnMode : SimCphsHandler
  • ServPrefCug : SimCphsHandler
  • ServProtId : SimCphsHandler
  • ServReplyPath : SimCphsHandler
  • ServResError : Service
  • ServResSuccess : Service
  • ServSmCb : SimCphsHandler
  • ServSmMo : SimCphsHandler
  • ServSmmoEmail : SimCphsHandler
  • ServSmmoPaging : SimCphsHandler
  • ServSmMt : SimCphsHandler
  • ServUserUserSig : SimCphsHandler
  • ServValPeriod : SimCphsHandler
  • ServVoiceBcstServ : SimCphsHandler
  • ServVoiceGrpCall : SimCphsHandler
  • ServVps : SimCphsHandler
  • SessionParams : ObexHeader
  • SessionSeqNum : ObexHeader
  • Set : TickValue, RomFont, Rect, Locale, Mp3AudioDevice, SoftkeyBar, BitField< T >, Fraction, CfuService, UsimLanguage, ExtLanguage, RegIterator, Registry, LocalDataStore, TpduPhoneNumberPersist, RegEncoderDecoder, KeyMsgGenerator::Key
  • Set3aExists() : TypeOfAddress
  • Set3aNotExists() : TypeOfAddress
  • SetAborted() : BtObexClientOperationRequest
  • SetAbsoluteDateTime() : CodedTimeStamp
  • SetAbsoluteDays() : TimeSpan
  • SetAbsoluteHours() : TimeSpan
  • SetAbsoluteMinutes() : TimeSpan
  • SetAbsoluteSeconds() : TimeSpan
  • SetAbsoluteWeeks() : TimeSpan
  • SetAbsolutTime() : ValidityPeriod
  • SetAbstractAction() : AbstractButton
  • SetAbsX() : DeviceContext
  • SetAbsY() : DeviceContext
  • SetAccept() : SetupEventCnfArg
  • SetAcceptAuthorization() : BtRespondAuthorizationRequest
  • SetAcceptPairing() : BtSendPasskeyRequest
  • SetAccessDate() : File::Attributes
  • SetAccessor() : UibActionAccessor
  • SetAccessory() : MiscAudioDevice, AccessoryIndMsg, AccessoryIndArg
  • SetAccessoryConfigurationType() : AudioAccessoryConnectedMsg
  • SetAccessPointName() : PdpContext::ActivationStatus
  • SetAccessTime() : File::Attributes
  • SetAccount() : DataConnProfile, PdpContext::Authentication
  • SetAcm() : SimAcmMaxUpdReqArg, SimAcmUpdReqArg, SimAcmMaxReadIndArg, SimAcmReadIndArg
  • SetAction() : PushButton, AbstractButton, MenuItem, CloseAllMsg, ActionMenuAccessor
  • SetActivated() : RejectCallsIndArg
  • SetActivateReporting() : SetChargeUnitsArg, SetAutoChargeArg
  • SetActivationStatus() : PdpContextActivationStatusMsg
  • SetActive() : ObexServerDispatcher, TabButton, BidiManager, SocketSerialTerminalListener
  • SetActiveAuthorizationSet() : WapProfile
  • SetActiveDevice() : BtActiveDeviceWindow
  • SetActiveDuration() : Cbs::Filter
  • SetActiveExtLanguage() : SimTkHandler, SimAuxHandler, DataHandler
  • SetActiveFont() : FontPackConnector, FontManager
  • SetActiveLanguage() : TextPackConnector, LanguageManager
  • SetActiveLanguageByIndex() : TextPackConnector
  • SetActiveLanguageType() : LanguageManager
  • SetActiveLdb() : T9PackConnector
  • SetActivePhysicalPortSet() : WapProfile
  • SetActivePhysicalSet() : WapProfile
  • SetActivePortSet() : WapProfile
  • SetActiveReference() : AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioRecordingStoppedMsg, AudioGetPlayPositionMsg, GenericFeatureData
  • SetActiveTab() : TabControl
  • SetActiveTheme() : ThemeManager
  • SetActiveView() : BrowserViewContainer
  • SetActiveWapProfile() : WapProfileMgr
  • SetActiveWin() : PhonebookApp
  • SetActiveWord() : Zi8NoWordFoundMsg, T9NoWordFoundMsg
  • SetActualName() : AudioAccessoryDetails
  • SetAddData() : UsimSmsParamExtIndArg, UsimSmsParamReadIndArg
  • SetAdditionalNames() : VCard
  • SetAdditionalOrgUnit() : VCard
  • SetAdditionalResult() : SimTkRefreshQueryResArg
  • SetAddr() : IpAddr
  • SetAddress() : ObexAbstractPort, PdpContext::ActivationStatus
  • SetAddressText() : SmsSendingConfirmDialog
  • SetAddressType() : VCard
  • SetAddResult() : PinDisableIndArg, PinEnableIndArg
  • SetAdjustWindowTitle() : ItemMenu
  • SetAdnByte() : SimInitIndArg
  • SetAdnChanged() : UsimPbChangedField
  • SetAdnReadWritableState() : SimAccessor
  • SetAdnResult() : DhChannelReceiveIndArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg
  • SetAidingStale() : GltpAssistanceData
  • SetAlarm() : AlarmManager, RealTimeClock
  • SetAlignment() : IndicatorLocation, Indicator
  • SetAllCallsCcm() : CurrentCallMeterMsg, ChargeUnitsIndArg
  • SetAllCallsCharge() : CurrentChargeDataMsg, ChargeIndArg
  • SetAllowed() : RegistrationAllowedMsg, AttachAllowedIndArg
  • SetAlpha() : Color
  • SetAlphabet() : EditorDocument, DataCodingScheme
  • SetAlphaBlendingEnabled() : Bitmap
  • SetAlphaBlendingMode() : DeviceContext, VirtualDisplay
  • SetAlphaId() : AtAlphaTagCnfArg
  • SetAlphaIdentifier() : SsInfoMsg, SsFacilityIndArg, CallIndCallControlInfoArg, AtPbListCnfArg
  • SetAlphaLength() : PbEntryReadIndArg
  • SetAlphaMask() : Bitmap
  • SetAlphaMaskEnabled() : WindowManager
  • SetAlphaSize() : UsimSmsParamReadIndArg
  • SetAlphaValue() : Bitmap
  • SetAnimType() : ItemRendererProperties
  • SetAntiFlicker() : CameraSettings
  • SetAntiFlickerMode() : Camera
  • SetAPart() : IpAddr
  • SetApduDataPtr() : ExtProactiveCmdIndArg, ExtProactiveCmdReqArg, SimGenericReqArg, SimGenericIndArg
  • SetApiDeviceAddress() : BtDeviceAddress
  • SetApn() : DhChannelOpenReqArg, SiChannelOpenPromptReqArg
  • SetApnName() : PsdDataConnProfile
  • SetApoxiHandle() : BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtMultiConnectionController::BtConnection
  • SetAppContainer() : Application
  • SetApplication() : ContextMsg, Feature, DataControlModificationMsg
  • SetAppName() : Application
  • SetAppPtr() : NotificationTableEntry
  • SetArchive() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FlashFileImp, FatFileImp, FatFile
  • SetArg() : SmsServiceDocumentMsg, SmsServiceMsg, BatteryLoadLevelMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, UssdIndicationMsg, SsErrIndicationMsg, SsRejectedMsg, SsSuccessMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, TermRspCnfMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetConfirmationMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg
  • SetAssociatedAudioCh() : EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Decoder, VideoDecoder
  • SetAssociatedCandidates() : Zi8Wrapper
  • SetAtMode() : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • SetAttached() : GprsStatusMsg, HeadSet
  • SetAttachmentFormat() : BtBipAttachment
  • SetAttachStatus() : GprsAttachStatusMsg
  • SetAttributeId() : BtSddbServiceAttribute
  • SetAttributes() : RamHandler, RamFileObj, FatHandler
  • SetAttributesRequested() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • SetAttributeValue() : BtSddbServiceAttribute
  • SetAudioAlwaysOnAccessory() : BtAudioAccessoryService
  • SetAudioCodec() : RecordSettings
  • SetAudioConnected() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • SetAudioError() : AudioErrorMsg
  • SetAudioErrorType() : AudioStoppedMsg
  • SetAudioMode() : Audio, AudioContext
  • SetAudioReference() : AudioErrorMsg
  • SetAudioSwitchPath() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • SetAuthenticationMethod() : WapProfile
  • SetAuthenticationPassword() : WapProfile
  • SetAuthenticationUsername() : WapProfile
  • SetAuthProvider() : Server
  • SetAuthType() : PsdDataConnProfile
  • SetAutoCallSetup() : MocSetupReqArg
  • SetAutoChargeArg() : SetAutoChargeArg
  • SetAutoClearEnabled() : Control
  • SetAutoLayoutEnabled() : Control
  • SetAutomaticDnsServerNegotiation() : PsdDataConn, PdpContext
  • SetAutomaticDnsServerNegotiationPending : PdpContextManager
  • SetAutoStopped() : AudioStoppedMsg
  • SetAutoStoreEnabled() : SmsSettingsRecord
  • SetAvailable() : Feature, BootState
  • SetAvailableByteCount() : StreamingReadInfo
  • SetAvrcpOperationService() : SubUnitReference
  • SetBackgroundColor() : ItemRendererProperties, RichTextCompoundItem, MultiMediaEditorDocument::TextManager, MultiMediaEditor
  • SetBackgroundImage() : ItemRendererProperties, Image
  • SetBacklightMode() : DefaultDisplay, Display, DefaultDisplay
  • SetBacklightState() : MmiSimServer, MmiSimClient
  • SetBacklightTimeout() : DefaultDisplay, Display, DefaultDisplay
  • SetBacklog() : ServerConfig, Server
  • SetBackup() : BtObexSetPathRequest
  • SetBackupFileId() : UriMappingTable
  • SetBalance() : AudioReference
  • SetBalanceLevel() : MediaPlayer
  • SetBandLimits() : RadioAudioDevice
  • SetBaseURL() : SvgPlayer
  • SetBassLevel() : MediaPlayer
  • SetBatteryLoadLevel() : StatusProvider, DataHandler
  • SetBcdPlmn() : SimMccMncIndArg
  • SetBdnByte() : SimInitIndArg
  • SetBdnEnabled() : DataControlPhonebookStateMsg
  • SetBdnReadWritableState() : SimAccessor
  • SetBdnState() : BdnReqArg, BdnIndArg, SimAccessor
  • SetBearerDesc() : DhChannelOpenCnfArg, DhChannelOpenReqArg
  • SetBearerList() : SimLaunchBrowserReqArg
  • SetBearerType() : SiChannelOpenPromptReqArg
  • SetBehavior() : AbstractListBox
  • SetBehaviour() : GridModel
  • SetBit() : DynamicBitVector, BitVector< N >, BitField< T >, Sms
  • SetBitmap() : ImageBox, AbstractButton
  • SetBitNumber() : SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • SetBits() : Bitmap
  • SetBitsPerPixel() : Image, Image::MetaData
  • SetBitValue() : SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • SetBlitRect() : VirtualDisplay
  • SetBlobFileNode() : RegNodeBuffer
  • SetBlobNode() : RegNodeBuffer
  • SetBlocking() : SysSocket, Socket, InetSocket, SerialSocket, SerialTerminalSocket
  • SetBlockingEnabled() : SocketPeer
  • SetBlockingScan() : PlmnDispatcher
  • SetBlockingSend() : SmsDispatcher
  • SetBlue() : Color
  • SetBmpIterator() : Animation, AnimationModel
  • SetBody() : HttpRequest
  • SetBoolean() : DataItem, Property
  • SetBooleanNode() : RegNodeBuffer
  • SetBoolOption() : InetSocket
  • SetBootState() : DataControlEndBootMsg, DataControlBootMsg
  • SetBottom() : Rect, WinRect
  • SetBottomLineGap() : ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor
  • SetBottomSize() : ControlFrameView
  • SetBoundingRect() : PaneObject, Component
  • SetBoxType() : UibRegisterMsg
  • SetBPart() : IpAddr
  • SetBpmfMode() : Zi8Wrapper
  • SetBpmfSpellingMode() : Zi8Wrapper
  • SetBppResult() : BtBppReq
  • SetBppSubState() : BtBppSndFilePushReqRequest
  • SetBrightness() : CameraSettings, DefaultDisplay, Display, Camera, DefaultDisplay
  • SetBrowserOpen() : LcsWapIntf
  • SetBrush() : DeviceContext
  • SetBrushColor() : DeviceContext
  • SetBrushColorHsv() : DeviceContext
  • SetBrushColorRgb() : DeviceContext
  • SetBrushColorValue() : DeviceContext
  • SetBrushStyle() : DeviceContext
  • SetBtapiHandle() : BtAvrcpConnectResponse
  • SetBuffer() : AbstractEditBox, AbstractEditBoxModel, BtBppSndFilePushReqRequest
  • SetBufferingEnabled() : ImageBox
  • SetBufferSize() : DhChannelOpenCnfArg, DhChannelOpenReqArg
  • SetBufSize() : WStrData, StrData
  • SetCacheFilling() : UsimPbSelectReqArg
  • SetCall() : CallHoldRejectedMsg, CallOnHoldMsg
  • SetCallbackActive() : DefaultDisplay, Display, DefaultDisplay
  • SetCallBarringInfo() : SsBarringIndArg
  • SetCallClearingCause() : NwDiscStartIndMsg
  • SetCallControlPerformed() : SsInfoMsg, SsFacilityIndArg, CallIndCallControlInfoArg
  • SetCallControlResult() : SsInfoMsg, SsFacilityIndArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, CallIndCallControlInfoArg
  • SetCallDirection() : MmCallInfo
  • SetCallDiscCause() : CallHoldRejArg, CallDiscReqArg, CallRelIndArg, CallDiscIndArg
  • SetCalledPartyNo() : RedialSetupIndArg
  • SetCalledPartyNumber() : CallControlSetupIndArg
  • SetCallErrorCause() : CallIndArg
  • SetCallEstablishedInfoAlpha() : SimTkCallSetupIndArg
  • SetCallEstablishedInfoIcon() : SimTkCallSetupIndArg
  • SetCallEstCause() : MocSetupReqArg
  • SetCallFwdUncondActive() : SimCphsHandler
  • SetCallHdl() : CtmInfoIndMsg, NwDiscStartIndMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, CallNotifyMsg
  • SetCallId() : MmCallInfo
  • SetCallIndex() : MmCallInfo
  • SetCallInfoAlpha() : SimTkCallSetupIndArg
  • SetCallInfoIcon() : SimTkCallSetupIndArg
  • SetCallLine() : MtcSetupIndArg, MocSetupReqArg, CallIndArg
  • SetCallProgressInd() : CallProgressIndArg
  • SetCallRefuseDirection() : RejectCallsIndArg
  • SetCallRelatedSs() : CallRelatedSsReqArg, CallDeflectSsReqArg
  • SetCallState() : CallIndArg, MmCallInfo
  • SetCallType() : CsdDataConnProfile, MtcSetupComplArg, MtcSetupIndArg, CallIndArg
  • SetCameraMirroring() : MediaRecorder
  • SetCameraNightMode() : MediaRecorder
  • SetCancelableRequest() : BtRequestRunningWindow
  • SetCanceled() : PbSynchronizer
  • SetCandidateSelection() : Zi8Wrapper
  • SetCanSelect() : BtDeviceListWindow
  • SetCapsStatus() : Zi8Wrapper
  • SetCaption() : RadioButtonModel, CheckBoxModel, AbstractEditBox, AbstractEditBoxModel
  • SetCaptionType() : AbstractEditBoxModel
  • SetCaptureImageSize() : VideoCamera, StillCamera, Camera
  • SetCardType() : UsimCardTypeReadIndArg
  • SetCaretAlwaysVisible() : AbstractEditor
  • SetCaretIndex() : AbstractEditor
  • SetCategory() : CalendarRecord, CalendarAddRecordWin
  • SetCause() : StartUp::Data, SsFacilityRejectedMsg, CallHoldRejectedMsg, SimCallSetupRejectedMsg, SimTkSendDtmfEndIndArg, DetachCnfArg, AttachRejArg, NRegStateIndArg, MocSetupRejIndArg, CallSetupBySimtTkReqArg, StartDtmfRejArg
  • SetCbFunction() : NotificationTableEntry
  • SetCbmiData() : SimCbmiUpdReqArg, SimCbmiReadIndArg
  • SetCbmiRange() : SimCbmirUpdReqArg, SimCbmirReadIndArg
  • SetCbs() : CbsNewDataIndArg
  • SetCcbsAction() : SsCcbsResultIndArg
  • SetCcbsEntry() : SsCcbsReCallIndArg
  • SetCcbsStatus() : CcbsStatusMsg, SsCcbsResultIndArg, SsCcbsStatusIndArg
  • SetCcpData() : SimCcpUpdReqArg, SimCcpReadIndArg
  • SetCellHeight() : GridView
  • SetCellId() : CellInfoIndArg, StatusProvider, DataHandler
  • SetCellProperties() : GridLayout
  • SetCellWidth() : GridView
  • SetCenter() : Desktop
  • SetCfuServiceArray() : CfuDataIndArg, StatusProvider, DataHandler
  • SetChangedState() : DhChannelChangeStatusEventArg, DhChannelDataAvailEventArg, SimMruPropertyUpdCnfArg
  • SetChannel() : AudioReference
  • SetChannelData() : DhChannelReceiveIndArg, DhChannelSendReqArg
  • SetChannelDataLength() : DhChannelDataAvailEventArg, DhChannelReceiveReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg
  • SetChannelId() : TimeFeatureObject
  • SetChannelVolume() : CustomSmafPhraseAudioReference, AudioReference, AudioActiveReference
  • SetChar() : CharInputMapItem
  • SetCharacter() : InputCharMsg
  • SetChargeUnitsArg() : SetChargeUnitsArg
  • SetCharset() : BtBipAttachmentDesc, BtBipAttachment, BtBipAttachmentFormat
  • SetChildListener() : PbProviderListener
  • SetChildProvider() : AbstractDelegationProvider, JoinProviderListener
  • SetChineseSelection() : Zi8Wrapper
  • SetChunkSize() : File
  • SetChv() : PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvVerifyReqArg
  • SetChvAction() : ChvChangedMsg, ChvRefreshIndArg
  • SetChvAttempts() : ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg
  • SetChvno() : ChvChangedMsg, PinDisableReqArg, PinEnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg
  • SetChvNo() : SimFileInfoIndArg
  • SetCidx() : DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg
  • SetCingularActive() : InputContext
  • SetClearTextModeEnabled() : PasswordEditor
  • SetClient() : ClientDeregistrationArg, ClientRegistrationArg
  • SetClientId() : HttpSocket, FtpSocket, FtpDataSocket
  • SetClipInfo() : MediaInfo
  • SetClippedWidth() : TabButtonView
  • SetClipRect() : DeviceContext
  • SetClipState() : MmiSimServer
  • SetClirMode() : MocSetupReqArg
  • SetCloseAfterTrigger() : MenuProperties
  • SetCloseCause() : SiChannelCloseInfoIndArg
  • SetCmd() : AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtGenericCmdReqArg
  • SetCmdQualifier() : DhChannelOpenReqArg
  • SetCmiRecord() : SimCmiReadIndArg
  • SetCnfArg() : EngineeringModeControlResponseMsg
  • SetCode() : SsErrorCode
  • SetCodec() : EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, CodecDevice
  • SetColId() : ProviderListBoxModel
  • SetColor() : Pen, Brush, AbstractTextObject, VirtualDisplay
  • SetColorFormat() : CamWin32
  • SetColorHsv() : Pen, Brush
  • SetColorModeEnabled() : CamWin32
  • SetColorRgb() : Pen, Brush
  • SetColorSpace() : Image::MetaData
  • SetColorValue() : Pen, Brush, VirtualDisplay
  • SetColTitleHeight() : GridView
  • SetColumn() : DefaultCaret, Caret, Cell
  • SetColumnCount() : ItemRendererProperties, ItemGrid, MenuAccessor
  • SetColumnId() : PbProvColListBox, PbProvColListBoxModel
  • SetColumnInfoTable() : Provider
  • SetColumnProperty() : GridLayout
  • SetColumnTitled() : Grid, GridModel
  • SetCommandDetails() : SimLaunchBrowserReqArg
  • SetCommandExecutedCondition() : MapiAudioPlayer
  • SetCommandParameter() : SmsContext
  • SetCommandType() : SmsContext, SmsCommand
  • SetCompanyId() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • SetComplete() : MdhSmsUpdStatusReqArg
  • SetCompoundItem() : EditorItemNode, CompoundItemReferrer
  • SetConcatenatedReferenceNoType() : SmsContext
  • SetConcatenatedSmMaximumNumber() : InformationElement
  • SetConcatenatedSmReferenceNumber() : InformationElement
  • SetConcatenatedSmSequenceNumber() : InformationElement
  • SetConcatenetedStatus() : TpduHeaderInformation
  • SetConcatenetedTpduNum() : TpduHeaderInformation
  • SetConcSmsPduMaxNo() : SimPduHandler, DataHandler
  • SetConfig() : EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoder
  • SetConfirmed() : BandSelectionMsg, BandSelectionIndArg
  • SetConn() : RtStreamingEndPoint
  • SetConnectableMode() : BtLocalSettings
  • SetConnected() : AudioAccessoryConnectedMsg, AudioAccessoryDetails, ConnectionIndArg
  • SetConnectedDevice() : BtSingleConnectionController
  • SetConnectedNo() : MtcSetupIndArg, MocSetupCnfArg
  • SetConnectedOld() : AudioAccessoryDetails
  • SetConnectionElement() : DataCallContext
  • SetConnectionLost() : UtcStatusMessage
  • SetConnectionOnlyDuringCall() : BtHsService
  • SetConstraintDefaultValue() : DrmPermission
  • SetConsumedCount() : DrmConstraint
  • SetContainerId() : FeatureItemContainer
  • SetContent() : TRadioButtonItem< Content >
  • SetContext() : ContextMsg
  • SetContextId() : FeatureItemContainer, FeatureItem, AtlWindow, PdpContextActivationStatusMsg
  • SetContextItem() : ContextFeatureItem, ContextFeatureTriggerMsg
  • SetContextType() : ContextFeature
  • SetContinue() : AudioReference, MediaPlayer
  • SetContrast() : CameraSettings, DefaultDisplay, Display, Camera, DefaultDisplay
  • SetControl() : ControlMsg, DeviceContext
  • SetControlInfoString() : UssdAnswerMsg
  • SetControlType() : SocketControlMsg, BtAvrcpRawFrameParams
  • SetCopyright() : Melody
  • SetCorner() : MenuProperties
  • SetCount() : SimAcmReadIndArg, PbCountIndArg, DrmConstraint
  • SetCounter() : PdpContext
  • SetCounterPending : PdpContextManager
  • SetCounterText() : SmsComposeWin
  • SetCountry() : VCard
  • SetCPart() : IpAddr
  • SetCphsCfufArray() : CphsCfufUpdReqArg, CphsCfufReadIndArg
  • SetCphsCspArray() : CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspReadIndArg
  • SetCphsIstArray() : CphsIstReadIndArg
  • SetCphsOnmName() : CphsOnmReadIndArg
  • SetCphsOnsName() : CphsOnsReadIndArg
  • SetCphsServAccessible() : SimCphsHandler
  • SetCphsVmwfArray() : CphsVmwfUpdReqArg, CphsVmwfReadIndArg
  • SetCreateDate() : BtBipAttachmentDesc, BtBipAttachment
  • SetCreatedDate() : BtBipImage
  • SetCreatedFrom() : BtBipImageHdlDesc
  • SetCreateDirectory() : BtObexSetPathRequest
  • SetCreatedTo() : BtBipImageHdlDesc
  • SetCreateEmptyObject() : BtObexPutRequest
  • SetCreateTrust() : BtRespondAuthorizationRequest, BtDevicePairRequest
  • SetCreationDate() : File::Attributes
  • SetCreationTime() : File::Attributes
  • SetCropRect() : VideoChannel
  • SetCrss() : MptyCnfArg
  • SetCrssCode() : MtcSetupComplArg, MocSetupCnfArg
  • SetCrssState() : CallHoldRejArg, CallHoldCnfArg
  • SetCrSupported() : TextEditorDocument
  • SetCtm() : CtmInfoIndMsg, SimTkCallSetupAccArg, MtcSetupIndArg, MocSetupReqArg, CtmInfoIndArg, CallIndArg
  • SetCtrlInfo() : SsUssdReqArg, SsSendReqArg
  • SetCtrlInfoString() : UssdAnswerIndArg, SsUssdIndArg, SsUnstructIndArg
  • SetCts() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetCug() : MocSetupReqArg
  • SetCurrencySymbol() : Locale
  • SetCurrentDate() : CalendarMonthWin
  • SetCurrentIndication() : SmsIndicationState
  • SetCurrentPath() : RenameFileDialog
  • SetCurrentRecordIdx() : CalendarApp
  • SetCurrentSelectedDay() : CalendarGrid
  • SetCursorMode() : AbstractEditBox
  • SetCursorPos() : AbstractEditBox, AbstractEditBoxModel
  • SetCursorVisible() : AbstractEditBoxModel
  • SetCustomFrameBufferRect() : DefaultDisplay, Display
  • SetData() : UibSettingsRecord, ToDoRecord, LocationVerifWin, FmRadioStationsRecord, FmRadioSettingsRecord, SmsSettingsRecord, CalendarRecord, CalendarDialogWin, CalendarAddRecordWin, BtHfRecord, PbNumberRecord, PbRecord, PbNextFreeIdRecord, BtSddbDeOneByteDescriptionType, BtServiceVerifyResultMessage, ProviderProxyItem, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, PbEntryUpdReqArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, PathProfile, Record, SmsWStringCache, SmsWStringCache::Entry, SimPbEntry
  • SetDataBits() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetDataBuffer() : Tpdu
  • SetDataCallContext() : CsdDataConnProfile
  • SetDataCallType() : CallIndArg
  • SetDataCodingScheme() : SmsContext, SmsNewMessageIndArg, SmsSubmit, MdhSmsNewMessageIndArg
  • SetDataCodingSchemeExists() : ParameterIndicator
  • SetDataConnectionType() : FtpClient
  • SetDataConnId() : WapProfile
  • SetDataConnProfileId() : SocketData, InetSocket, ServerConfig
  • SetDataConnResult() : GltpProviderImpl
  • SetDataControlType() : DataControlModificationMsg
  • SetDataCounters() : PsdDataConn
  • SetDataItem() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider, CalendarProvider, BtHfProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, Provider, DistinctProvider, AbstractDelegationProvider, Property, MergeProvider, JoinProvider, StatusProvider, SmsProvider, SmsParamProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, CphsServPflProvider, CphsAuxProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • SetDataLength() : PbEntryReadIndArg
  • SetDataPtr() : GenericFeatureData
  • SetDataRate() : CsdDataConnProfile
  • SetDataRead() : StreamingReadInfo
  • SetDataSize() : BtServiceVerifyResultMessage
  • SetDataToWrite() : StreamingWriteInfo
  • SetDataType() : DataItem
  • SetDate() : ToDoDateDialogWin, CalendarRecord, CalendarAddRecordWin, DateEditorDocument, DateEditor, DateCompoundItem, DateEditBox, DateTime, DataItem, Property
  • SetDateDisplay() : ToDoComposeWin
  • SetDateFormat() : Locale, DateEditorDocument, DateEditor, DateCompoundItem
  • SetDateIsValid() : CalendarProvider
  • SetDatetime() : TimeZoneMsg
  • SetDateTime() : DateTime, DataItem, Property, SmsNewSocketDataMsg, MnInformationIndArg, TpduHeaderInformation
  • SetDateTimePresent() : MnInformationIndArg
  • SetDay() : Date
  • SetDaylightSavingTime() : MnInformationIndArg
  • SetDaylightSavingTimePresent() : MnInformationIndArg
  • SetDbPath() : MediaRefContainer
  • SetDcd() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetDcs() : SmsNewSocketDataMsg, UssdAnswerIndArg, SsUssdIndArg, SsUnstructIndArg, GetInkeyRspArg, GetInputRspArg
  • SetDecimalSeparator() : Locale
  • SetDecimalString() : Fraction
  • SetDefault() : UibSettingsRecord, FmRadioSettingsRecord, SmsSettingsRecord
  • SetDefaultClirMode() : CallHandler
  • SetDefaultColorHint() : TextCompoundItem
  • SetDefaultCugInfo() : CallHandler
  • SetDefaultDescriptor() : Property
  • SetDefaultHeight() : View
  • SetDefaultIcon() : IconSet
  • SetDefaultItemHeight() : AbstractListBoxView
  • SetDefaultItemId() : SelectItemReqArg
  • SetDefaultPowerOnBehavior() : AlarmManager
  • SetDefaultProfile() : SmsSettingsRecord
  • SetDefaultProgressBarHeight() : CTProgressBarView
  • SetDefaultPushButtonHeight() : CTPushButtonView
  • SetDefaultSize() : Window, AtlWindow
  • SetDefaultSizeProperty() : Window
  • SetDefaultTextString() : GetInputReqArg
  • SetDefaultWidth() : View
  • SetDeflectNumber() : CallDeflectSsReqArg
  • SetDefProfileId() : DataConnProfileManager
  • SetDelay() : Alert, PdpContext::QualityOfService
  • SetDeleteMode() : EditBox
  • SetDeleteObject() : BtObexPutRequest
  • SetDeletionCmd() : MdhSmsDeletionReqArg, MdhSmsDeletionIndArg
  • SetDenominator() : Fraction
  • SetDesc() : AtPbInfoIndArg
  • SetDescription() : CalendarRecord, CallNotifyMsg, NotifyIndArg
  • SetDescriptor() : PropertyItem, PropertyEditor, IndicatorItem
  • SetDestinationAddress() : AbstractSmsComposeWin, SmsContext, SmsCommand, SmsSubmit
  • SetDestinationApplicationPortAddress() : SmsContext
  • SetDestinationNumber() : SmsControlIndArg
  • SetDestIpAddr() : DhChannelOpenReqArg
  • SetDetailColumns() : ProvDetailListBoxWin, PbDetailListBox, PbDetailListBoxModel
  • SetDetailRow() : PbDetailProvider
  • SetDevice() : BtDeviceDetailWindow, BtFaxConnectMessage, BtDunConnectMessage, BtUncancelablePointToPointRequest, BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice, BtMultiConnectionController::BtConnection, BtDeviceList::BtDeviceListNode, AudioActiveReference
  • SetDeviceAddress() : BtServiceVerifyResultMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtGapAndSdapRemoteRequestMessage
  • SetDeviceAndServiceClass() : BtRemoteDeviceMessage, BtDeviceSearchRequest, BtDeviceFilter
  • SetDeviceCapability() : StorageDevice
  • SetDeviceErrorCode() : StreamingInfo
  • SetDeviceFilter() : BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice
  • SetDeviceId() : AudioDeviceStatusMsg
  • SetDeviceList() : BtDeviceListProvider, BtCancelableMulticastRequest
  • SetDeviceListNode() : BtDeviceList::BtDeviceListBidirectionalIterator
  • SetDeviceName() : BtServiceVerifyResultMessage, BtRemoteDeviceNameMessage, BtGapAndSdapRemoteRequestMessage
  • SetDeviceRelation() : BtServiceVerifyRequest
  • SetDeviceReleation() : BtOperationSelectDeviceAndPerformServiceVerify
  • SetDeviceState() : BtDeviceFilter
  • SetDeviceStatus() : AudioDeviceStatusMsg
  • SetDeviceVolume() : AudioDeviceBase
  • SetDfId() : SimGenericReqArg, SimGenericIndArg
  • SetDfIdFlag() : SimGenericReqArg
  • SetDfLength() : SimGenericIndArg
  • SetDfParams() : SimGenericIndArg
  • SetDiagnosticCause() : DiagnosticIndArg
  • SetDimensions() : CTWindowFrameView, CTControlFrameView
  • SetDirectory() : File::Attributes, RamFileObj
  • SetDirtyFlag() : DirtyFileHandler
  • SetDisable() : RediallingDisabledIndArg
  • SetDisabled() : Control
  • SetDisconnectingMode() : CallDisconnectedMsg, CallDisconnectingMsg
  • SetDiscoverableMode() : BtLocalSettings
  • SetDispatcher() : Item, BtBppService, AtlWindow
  • SetDisplay() : DeviceContext
  • SetDisplayAndRecordSettings() : MediaRecorder
  • SetDisplayedName() : MetaData
  • SetDisplayIndex() : Control
  • SetDisplayLocation() : MediaPlayer
  • SetDisplaySettings() : MediaRecorder, MediaPlayer
  • SetDisplaySimPos() : PhonebookWin, PbAbstractWin
  • SetDisplayType() : ItemRendererProperties
  • SetDispMapAllowed() : LcsWapIntf
  • SetDocument() : SmsViewerWin, AbstractSmsViewerWin, EmsViewerWin
  • setDocumentLocator() : WbxmlParserRel
  • SetDocumentObtainer() : ToDoComposeWin, SmsComposeWin, AbstractSmsComposeWin, EmsComposeWin
  • SetDomain() : WapProfile
  • SetDPart() : IpAddr
  • SetDpofOptions() : BtBipImagingCapabilities
  • SetDrmAttrib() : FlsFile, FfsHandler
  • SetDrmDcfMessage() : DrmDcfParser
  • SetDrmLocalId() : DrmMessage
  • SetDrmVersion() : DrmRelParser
  • SetDrvId() : AudioMsg
  • SetDsr() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetDstInd() : TimeZone
  • SetDummy() : SimTkCallSetupIndArg
  • SetDuration() : KeyUpMsg, KeyUpInputMapItem
  • SetDuration1() : DhChannelOpenReqArg
  • SetDuration2() : DhChannelOpenReqArg
  • SetDynamicConfig() : EmzMpeg4Encoder, AtiMpeg4Encoder, VideoEncoder
  • SetEccCategory() : MocSetupReqArg, RedialSetupIndArg, MocSetupAccArg, CallIndArg
  • SetEccNetworkArray() : EccListIndArg, EccProvider, DataHandler
  • SetEccRecord() : UsimEccReadIndArg
  • SetEditBox() : EditBoxPagingTimer, EditBoxBlinkTimer
  • SetEditEnable() : AbstractSmsApp
  • SetEditMode() : AbstractEditor, EditBox
  • SetEditor() : MultiTapInputMapper, IpAddrInputMapper, InputMapper, DateTimeInputMapper, Zi8InputMapper, T9InputMapper
  • SetEditorItem() : EditorItemNode
  • SetEditorListener() : EmsEditor
  • SetEfId() : SimGenericReqArg, SimGenericIndArg
  • SetEfIdFlag() : SimGenericReqArg
  • SetEfLength() : SimGenericIndArg
  • SetEfParams() : SimGenericIndArg
  • SetEfRefresh() : SimTkRefreshNewReqArg, SimTkRefreshQueryReqArg, SimTkRefreshReqArg
  • SetEleCount() : Zi8AlphabetBox
  • SetEmail() : PbRecord, SaveEntryInPhonebookMsg, VCard
  • SetEmpty() : Ticks, Rect
  • SetEmptyBytesInTx() : DhChannelSendIndArg
  • SetEmptyNumberText() : PhoneNumber, SmsProvider, SimPduHandler
  • SetEnabled() : Item, GlassPane, AbstractButton, FeatureItem, Feature, AtAccessoryRegisterReqArg
  • SetEnabledProperty() : Item
  • SetEnablePassword() : DhChannelOpenReqArg
  • SetEnciphered() : ConnectionIndArg
  • SetEncoding() : BtBipImageHdlDesc, BtBipImageDesc, BtBipImageFormat
  • SetEncodingFormat() : PngEncoder::EncodingParameters, JpegEncoder::EncodingParameters
  • SetEncodingParams() : ImageEncoder
  • SetEndDate() : DrmConstraint
  • SetEndOfData() : ObexObject, RtStreamingBuffer
  • SetEndOfStream() : StreamingReadInfo
  • SetEndReached() : UsimPlmnReadIndArg
  • SetEntry() : PbEntryReadIndArg
  • SetEntryContainer() : SimPbBaseHandler
  • SetErr() : PngDecoder
  • SetError() : SocketData, InetSocket, ShortMessageFailureCause
  • SetErrorCode() : Image, MptyHoldRejectedMsg, SimErrorMsg, SsErrReqArg, SimErrorIndArg
  • SetErrorInfo() : SmsInfoBox
  • SetErrorMessage() : StreamingInfo
  • SetErrorReason() : BtOperationBase
  • SetEst() : UsimEstReadIndArg
  • SetEstablishCause() : CallIndArg
  • SetEstCause() : RedialSetupIndArg, MocSetupAccArg
  • SetEstCauseChanged() : MocSetupAcceptMsg
  • SetEvent() : CallEventMsg, SvgPlayer, SerialTerminalArg
  • SetEventList() : SimTkSetupEventReqArg
  • SetExclusionGroup() : AudioReference
  • SetExecFn() : Action
  • SetExposure() : Camera
  • SetExtData() : MdhExtendedData
  • SetExtendedAddress() : VCard
  • SetExtendedData() : MdhSmsExtendedDataReqArg, MdhSmsTransmitIndArg, MdhSmsReadIndArg
  • SetExtension() : ParameterIndicator
  • SetExtensionExists() : FunctionalityIndicator
  • SetExtLanguage() : SimTkLanguageNotificationMsg, LanguageSettingIndArg, LanguageSelectEventArg, SimTkLanguageNotificationIndArg
  • SetExtn : RegEncoderDecoder
  • SetFalse() : BitField< T >
  • SetFamilyName() : VCard
  • SetFdnEnabled() : DataControlPhonebookStateMsg
  • SetFdnState() : FdnReqArg, FdnIndArg, SimAccessor
  • SetFeature() : FeatureItem, SimTkProfile
  • SetFeatureId() : SoftkeyDesc, DisabledFeatureTriggeredMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg
  • SetFile() : HttpResponse
  • SetFileExtension() : Pathname
  • SetFileId() : SimFileInfoReqArg, SimFileInfoIndArg, DeletedNode
  • SetFileSize() : SimFileInfoIndArg
  • SetFileStatus() : BdnIndArg, FdnIndArg
  • SetFileType() : SimFileInfoIndArg, SimRefreshIndArg
  • SetFilter() : CameraSettings, Camera, CbsStartReqArg
  • SetFilterColumn() : FilterProvider, DistinctProvider
  • SetFilterParamters() : BtBipImagingCapabilities
  • SetFilterRule() : FilterProvider
  • SetFinal() : AtGenericCmdIndArg
  • SetFinishedCommand() : TermRspCnfArg
  • SetFirstCell() : Grid, GridModel
  • SetFirstConsumedInterval() : DrmConstraint
  • SetFirstVisibleColumn() : AbstractGrid
  • SetFirstVisibleIndex() : AbstractLineEditor, AbstractGrid, AbstractListBox, AbstractListBoxModel
  • SetFirstVisibleLine() : AbstractEditBoxModel
  • SetFirstVisibleLineIndex() : AbstractMultiLineEditor, MultiMediaEditor
  • SetFirstVisibleRow() : GridModel
  • SetFlag() : SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadIndArg, SimODynReadIndArg, UsimEstReadIndArg, UsimUstReadIndArg
  • SetFlagState() : SmsIndicationState
  • SetFlash() : CameraSettings, Camera
  • SetFocusMsgProcessingBlocked() : MsgQueue
  • SetFocusPassingEnabled() : AbstractListBox
  • SetFocusPriority() : Window
  • SetFolder() : UibRegisterMsg
  • SetFolderType() : UibSettingsWin, UibFolderWin
  • SetFont() : TextFormat, TextEditorDocument, TextCompoundItem, MultiLineEditor, LineEditor, DeviceContext, AnimatedTextLine, AbstractTextObject, MultiMediaEditorDocument::TextManager, MultiMediaEditor
  • SetFontAlign() : TextFormat, DeviceContext
  • SetFontId() : Theme
  • SetForceUpdate() : MergeProvider
  • SetForegroundColor() : RichTextCompoundItem, MultiMediaEditorDocument::TextManager, MultiMediaEditor
  • SetFormat() : TimeEditBox, DateEditBox, ValidityPeriodFormat
  • SetFormattedName() : VCard
  • SetForwardingInfo() : SsForwardingIndArg
  • SetFractionString() : Fraction
  • SetFrame() : ImageMetaData
  • SetFrameCount() : Image, Image::MetaData
  • SetFrameDelay() : NativeImage
  • SetFrameRate() : CamWin32, VideoCamera
  • SetFrameRect() : VideoChannel
  • SetFrameType() : Control
  • SetFrequency() : FmRadioWindow
  • SetFriendlyName() : BtBipImageProperties
  • SetFtpDataSocket() : FtpClient
  • SetFtpInTransfer() : FtpDataSocket
  • SetFtpOutTransfer() : FtpDataSocket
  • SetFtpSocket() : FtpDataSocket, FtpClient
  • SetFullScreenPerItem() : ItemRendererProperties
  • SetFunction() : EngineeringModeControlRequestArg, EngineeringModeControlResponseArg
  • SetFunkId() : AudioMsg
  • SetGap() : ItemRendererProperties
  • SetGateway() : SimLaunchBrowserReqArg
  • SetGeneralResult() : LaunchBrowserPromptIndArg, SimTkRefreshQueryResArg
  • SetGenericObject() : DataItem, Property
  • SetGenericTrackInfo() : GenericFeatureData
  • SetGenResult() : DhChannelReceiveIndArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelOpenPromptResArg
  • SetGeographicalScope() : Cbs::SerialNumber
  • SetGetFragSize() : ObexDataServer
  • SetGetTotalPlayTimeWaitCondition() : AudioReference
  • SetGivenName() : VCard
  • SetGlassPanePosition() : IndicatorLocation
  • SetGlobalTraceMask() : InternalTracer
  • SetGors() : MdhSmsDeletionIndArg
  • SetGprsAttached() : StatusProvider, DataHandler
  • SetGprsAvailable() : CellInfoIndArg
  • SetGprsClass() : GprsClassReqArg, GprsClassIndArg, StatusProvider, DataHandler
  • SetGprsClassChangeOrigin() : StatusProvider, DataHandler
  • SetGpsFixData() : LocationResultWin
  • SetGraphData() : SatteliteGraphWin
  • SetGreen() : Color
  • SetGroup() : RadioButtonControl, RadioButtonAction, UsimPbGroups
  • SetGroupId() : PbRecord, DataCodingScheme
  • SetGroupsChanged() : UsimPbChangedField
  • SetGsmBand() : GsmBandStateMsg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, StatusProvider, DataHandler
  • SetGsmBandList() : BandSelectionReqArg
  • SetGsmErrorCause() : RegistrationChangeMsg, NRegStateIndArg
  • SetGsmService() : SmsSettingsRecord, MnInformationIndArg
  • SetGsmSignal() : MtcSetupIndArg
  • SetHandle() : AudioMsg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • SetHandler() : Trap
  • SetHeaderBuffer() : BtObexRegisterServerRequest, BtObexRegisterClientRequest
  • SetHeaderEnabled() : TabControl
  • SetHeaderItem() : AbstractItemGrid
  • SetHeight() : ImageMetaData, Size, Rect, ItemRendererProperties, ImageEncoder::EncodingParameters, Image, Image::MetaData, EditorLine, DeviceContext, Component, Bitmap, WinRect, Grid, SvgPlayer
  • SetHfProfileName() : BtHfSupportedProfileMessage
  • SetHfSupportedFeatures() : BtHfSupportedProfileMessage
  • SetHidden() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • SetHiddenInfoChanged() : UsimPbChangedField
  • SetHighCutControl() : RadioAudioDevice
  • SetHighlighted() : AnimatedTextLine
  • SetHighLowSideLoInjection() : RadioAudioDevice
  • SetHintBits() : IrdaTransport
  • SetHour() : Time, DateTime
  • SetHsHasRemoteVolumeControl() : BtHsSupportedProfileMessage
  • SetHsProfileName() : BtHsSupportedProfileMessage
  • SetHsv() : Color
  • SetHttpSocket() : HttpClient
  • SetIccId() : PbRecord
  • SetIcon() : Item, IconTextIndicator, IconIndicator, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimLaunchBrowserPromptReqArg, SetupIdleModeTextReqArg, PlayToneReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • SetIconColumnId() : ProviderProxyContainer
  • SetIcondesc() : IconDescReadIndArg
  • SetIconList() : SetupMenuReqArg, SelectItemReqArg
  • SetIconProperty() : Item
  • SetIcons() : IconValueIndicator
  • SetID() : ResourceID
  • SetId() : Component
  • SetIdentifier() : InformationElement
  • SetIdle() : ObexServerDispatcher
  • SetIdleTimeout() : DataConnProfile
  • SetIgnoreManagement() : AudioReference
  • SetIlluminationMode() : Keyboard
  • SetIlluminationTimeout() : Keyboard
  • SetImage() : ImageRef, ImageReadIndArg
  • SetImageChanged() : ImageListBoxModel
  • SetImageDim() : BtBipImageHdlDesc, BtBipImageDesc, BtBipImageFormat
  • SetImageFilter() : ImageBrowserWin
  • SetImageHandle() : BtBipImageProperties
  • SetImageHdl() : BtBipImage
  • SetImageObtainer() : ImageBox
  • SetImageRefObj() : ImageRefGenContainer
  • SetImageSize() : CameraSettings, CamWin32, BtBipImageDesc
  • SetImei1() : ImeiReadIndArg
  • SetImei2() : ImeiReadIndArg
  • SetImgdescriptor() : ImageReadReqArg
  • SetImgObt() : ImgObtObj
  • SetImgRequestType() : ImageReadReqArg
  • SetImmediateResponse() : DisplayTextReqArg
  • SetImmediateSearch() : BtDeviceListWindow
  • SetImmediatlyRerieveRemoteDeviceNames() : BtDeviceSearchRequest
  • SetImsi() : SimInitIndArg, SimAuxHandler
  • SetImsiPlmn() : SimChvHandler
  • SetIndex() : MetaData, Animation, AnimationModel, EditLine, BtObexServerObserverImpl, BtObexSddbServiceObserverImpl, SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • SetIndicateItemContainer() : ItemRendererProperties
  • SetIndicator() : HomezoneMsg, PlmnInfoReqArg, AttachReqArg, HomezoneIndArg, MdhSetWaitIndicatorArray
  • SetIndicatorbarExpansion() : IndicatorBar
  • SetIndicatorBarId() : IndicatorLocation
  • SetIndicatorBarPosition() : IndicatorLocation
  • SetIndicatorDescription() : Indicator
  • SetIndicatorId() : IndicatorDescription
  • SetIndicatorLocation() : IndicatorDescription
  • SetIndicatorVisible() : BtApplication
  • SetInfo() : PbInfoReadIndArg
  • SetInfoAlpha() : PlayToneReqArg
  • SetInfoRequested() : MenuSelectionReqArg
  • SetInitialPrefferedStorageMedia() : SimAccessor, DataHandler
  • SetInitResult() : SimInitIndArg, SimAuxHandler
  • SetInputMapper() : AbstractEditor
  • SetInputValid() : AbstractEditBox, AbstractEditBoxModel
  • SetInquiryAccessCode() : BtDeviceSearchRequest
  • SetInquiryTimeOut() : BtDeviceSearchRequest
  • SetInstanceptr() : MediaManagerMsg
  • SetInt() : NumberPrompt
  • SetIntegerNode() : RegNodeBuffer
  • SetInteriorNode() : RegNodeBuffer
  • SetInternalDisplayIndex() : Control
  • SetInternalRecNo() : TpduHeaderInformation
  • SetInterrogateCcbsResult() : CcbsResultMsg, SsCcbsResultIndArg
  • SetInterval() : DrmConstraint
  • SetInterworking() : ProtocolIdentifier
  • SetInvalid() : ProviderProxyItem, Plmn, BcdPlmn
  • SetInvalidation() : SimFileInfoIndArg
  • SetInvalidNumberText() : PhoneNumber
  • SetIpAddr() : IpAddrPrompt, InetSocketAddr, IpAddrEditorDocument, IpAddrEditor, IpAddrCompoundItem
  • SetIrdaHwTimeout() : IrdaTransport
  • SetIsLsaIdentifierPresent() : StatusProvider, DataHandler
  • SetIsOnSim() : PbNumberRecord
  • SetIsProfileActive() : BtLocalSettings
  • SetIsRegistered() : BtController
  • SetIsServer() : BtObexController::BtObexConnection
  • SetIsWin98Mode() : IrdaTransport
  • SetItem() : ItemLabel, ItemObj
  • SetItemColumnIds() : ProviderProxyItem
  • SetItemContainer() : AbstractItemGrid, AtlItemListWindow
  • SetItemCount() : AbstractListBox, AbstractListBoxModel
  • SetItemHeight() : RadioButtonView, MenuAccessor, CheckBoxView, AbstractListBox
  • SetItemId() : MenuSelectionReqArg, SelectItemRspArg
  • SetItemList() : SetupMenuReqArg, SelectItemReqArg
  • SetItemsNai() : SetupMenuReqArg, SelectItemReqArg
  • SetItemType() : EditorItemNode
  • SetIterator : RegEncoderDecoder
  • SetJPEGQuality() : CameraSettings
  • SetJpegQuality() : StillCamera
  • SetKey() : GetInkeyRspArg, StartDtmfReqArg, StartDtmfCnfArg, DrmRightsObject, AesCrypt
  • SetKeyCode() : LockedKeyDownMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, KeyUpInputMapItem, KeyDownInputMapItem, T9MatrixModeKeypressed, TriggerKeyFeature
  • SetKeyItem() : PbDetailProvider
  • SetLabel() : PropertyDescriptor, AtlLabelListWindow
  • SetLai() : CellInfoIndArg, StatusProvider, DataHandler
  • SetLangFileType() : UsimLangUpdReqArg, UsimLangReadReqArg, UsimLangReadIndArg
  • SetLanguage() : System, Locale, UsimLangUpdReqArg, DataCodingScheme
  • SetLanguageAction() : SetLanguageAction
  • SetLanguageArray() : SimExtLangUpdReqArg, SimLangUpdReqArg, SimExtLangReadIndArg, SimLangReadIndArg
  • SetLanguageId() : Item
  • SetLanguageList() : UsimLangReadIndArg
  • SetLastCcm() : StatusProvider, DataHandler
  • SetLastCcm2() : StatusProvider, DataHandler
  • SetLastCell() : Grid, GridModel
  • SetLastConnectedDevice() : BtHsService
  • SetLastError() : ImageEncoder
  • SetLastFocusedChild() : Control
  • SetLastFocusedControl() : Control
  • SetLastModification() : Provider
  • SetLastPanelPassThroughRequest() : BtAvrcpControllerDeviceListItem
  • SetLastStatus() : TermRspCnfArg
  • SetLastTransaction() : DirtyFileHandler
  • SetLastUsed() : MdhSmsStatusIndArg
  • SetLedState() : MmiSimServer, MmiSimClient
  • SetLeft() : Rect, WinRect
  • SetLeftGap() : RadioButtonView, CheckBoxView
  • SetLeftSize() : ControlFrameView
  • SetLeftSoftkey() : Window
  • SetLength() : EditorItemNode, EditorLine, TextListLine, EditLine, WStrData, StrData, ByteBuffer, UserData, UserDataHeader, UsimEstReadIndArg, UsimLangReadIndArg, UsimPlmnReadIndArg, UsimUstReadIndArg
  • SetLevel() : SignalStrengthLevelIndArg
  • SetLine2VoiceBoxNumber() : SmsSettingsRecord
  • SetLineAlignment() : ParagraphCompoundItem, MultiMediaEditorDocument
  • SetLineHeight() : TextEditorDocument, MultiLineEditor
  • SetLineIndex() : AbstractEditBoxModel
  • SetLineInUse() : SimCphsHandler
  • SetLineLength() : AbstractEditBoxModel
  • SetLineLocked() : SimCphsHandler
  • SetLineSelector() : HomezoneMsg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspUpdIndArg, CphsCspReadIndArg, HomezoneIndArg
  • SetLinger() : SocketPeer
  • SetLingerOption() : SysSocket
  • SetLingerTimeout() : DataConnProfile
  • SetLink() : SimSmsrUpdReqArg, SimSmsrReadIndArg, MdhNewStatusReportIndArg
  • SetLinkRecNo() : MdhSmsReportReadIndArg
  • SetListBox() : AbstractListBoxModel
  • SetListener() : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • SetListIndex() : UsimLangReadReqArg
  • SetLlcSapi() : PdpContext::ActivationStatus
  • SetLocalAddr() : PsdDataConnProfile
  • SetLocalDataSocketAddr() : FtpClient
  • SetLocalDate() : RealTimeClock
  • SetLocalDateTime() : RealTimeClock
  • SetLocalDrmId() : DrmAsset
  • SetLocalId() : DrmWapPushMsg, DrmRightsObject
  • SetLocalIpAddr() : DhChannelOpenReqArg
  • SetLocality() : VCard
  • SetLocalName() : BtLocalSettings
  • SetLocalTime() : RealTimeClock
  • SetLocalTimeZone() : DateTime
  • SetLocation() : MdhSmsReportReadIndArg
  • SetLocationEstimate() : LocationResultWin
  • SetLociData() : UsimCsLociReadIndArg
  • SetLockAction() : SimModifyLockIndArg
  • SetLockCommand() : SimModifyLockReqArg
  • SetLocked() : Keyboard, Display
  • SetLockResult() : SimLockStatusMsg
  • SetLockStates() : SimModifyLockReqArg, SimModifyLockIndArg, SimLockStatusIndArg
  • SetLockTableId() : LockTable
  • SetLsaIdentifier() : LsaIdentityMsg, MnInformationIndArg, StatusProvider, DataHandler
  • SetLsaIdentifierPresent() : LsaIdentityMsg, MnInformationIndArg
  • SetMajorDeviceClass() : BtDeviceAndServiceClass
  • SetMarkDelete() : MetaData
  • SetMarked() : Item
  • SetMasterVolume() : AudioDeviceManager, AudioDeviceBase
  • SetMaxAlphaLength() : AtPbSelectCnfArg
  • SetMaxAlphaTagSize() : PbNameEditBox, PbAdvAddEditEntry
  • SetMaxConcRefNo() : StatusProvider, DataHandler
  • SetMaxFileSize() : RecordSettings
  • SetMaxImageSize() : BtBipImageDesc, BtBipImageFormat
  • SetMaximalFoundDevice() : BtDeviceSearchRequest
  • SetMaximumWidth() : TabButtonView
  • SetMaxInputLen() : GetInputReqArg
  • SetMaxItemCount() : TextEditorDocument
  • SetMaxMessageId() : CbsLimitMsg, CbsLimitIndArg
  • SetMaxNoOfPduCache() : SimPduHandler, DataHandler
  • SetMaxRecognitionTime() : VrEngineParams, TelecaVrEngineParams, DummyVrEngineParams
  • SetMaxRecordingDuration() : RecordSettings
  • SetMaxSilenceTime() : VrEngineParams, TelecaVrEngineParams, DummyVrEngineParams
  • SetMaxTextLength() : PasswordEditor, MultiLineEditor, LineEditor, AbstractEditBox, AbstractEditBoxModel
  • SetMaxUsers() : ServerConfig, Server
  • SetMaxValue() : PositionIndicator
  • SetMaxVisibleItems() : AbstractListBoxModel
  • SetMaxVisibleRows() : GridModel
  • SetMCbData() : EmServThreadMsg
  • SetMCbFnPtr() : EmServThreadMsg
  • SetMdhWaitingIndicatorArray() : SmsMsgWaitingProvider, DataHandler
  • SetMeanRate() : PdpContext::QualityOfService
  • SetMediaName() : StorageDevice
  • SetMediaSink() : RecordSettings
  • SetMediaSinkType() : RecordSettings
  • SetMenuAccessor() : AccessorActionExtension
  • SetMenuDesc() : MenuDescObj
  • SetMenuId() : SoftkeyDesc
  • SetMenuID() : AtlItemMenuWindow, MenuIdObj
  • SetMenuType() : MenuProperties
  • SetMePhoneBookType() : PbEntryRequestMsg, PbSizeRequestMsg, AtPbListCnfArg, AtPbSelectCnfArg, AtPbListReqArg, AtPbSelectReqArg
  • SetMergedProvider() : MergeProvider
  • SetMergeRule() : MergeProvider
  • SetMessageClass() : DataCodingScheme
  • SetMessageCode() : Cbs::SerialNumber
  • SetMessageID() : AudioUserDefinedMsg
  • SetMessageIdentifier() : CbsNewDataRejArg
  • SetMessageNumber() : SmsContext, SmsCommand
  • SetMessageReference() : SmsCommand, SmsSubmit
  • SetMessageText() : UtcStatusMessage, AsyncUnitTestMsg
  • SetMessageType() : SmsContext, ProtocolIdentifier
  • SetMessageWaitIndicators() : SmsHandler
  • SetMetaData() : SoundRef, MediaRef, ImageRef, MediaRef, Image
  • SetMeteringMode() : Camera
  • SetMHAudDevice() : EmServThreadMsg
  • SetMicrophoneGainRequest() : BtHsService, BtHfService, BtAudioAccessoryService
  • SetMiddleGap() : RadioButtonView, CheckBoxView
  • SetMillisecond() : Time, DateTime
  • SetMimeType() : MimeTypeFilter, BtBipAttachmentDesc, BtBipAttachment, BtBipAttachmentFormat, DrmRightsObject
  • SetMinimumQualityOfService() : PdpContext
  • SetMinimumQualityOfServicePending : PdpContextManager
  • SetMinimumWidth() : TabButtonView
  • SetMinInputLen() : GetInputReqArg
  • SetMinorDeviceClass() : BtDeviceAndServiceClass
  • SetMinute() : Time, DateTime
  • SetMinValue() : PositionIndicator
  • SetMIsAudioMuted() : EmServThreadMsg
  • SetMmfresult() : MediaManagerMsg
  • SetMnRediallingEnabled() : CallHandler
  • SetMode() : PredInputMapper, IconState, Caret, PlmnListReqArg, PlmnInfoReqArg, AttachReqArg, AttachCnfArg, RegStateIndArg, Cbs::Filter, Zi8PredictiveInputBox, Zi8InputMapper, T9PredictiveInputBox, EnglishT9InputMapper, ChineseT9InputMapper, FtpDataSocket, AbstractPredictiveInputBox
  • SetMode_Bopomofo() : ChineseT9Wrapper
  • SetMode_PinYin() : ChineseT9Wrapper
  • SetMode_SimplifiedChineseStroke() : ChineseT9Wrapper
  • SetMode_T9_Latin() : T9InputMapper
  • SetMode_TraditionalChineseStroke() : ChineseT9Wrapper
  • SetModel() : Component
  • SetModificationDate() : File::Attributes
  • SetModificationTime() : File::Attributes
  • SetModificationType() : Provider
  • SetModifiedDate() : BtBipImage
  • SetModifiedFrom() : BtBipImageHdlDesc
  • SetModifiedRow() : Provider
  • SetModifiedTo() : BtBipImageHdlDesc
  • SetModifyDate() : BtBipAttachment
  • SetMoMimeType() : DrmRightsObject
  • SetMonoStereoMode() : StreamAudioReference
  • SetMonth() : Date
  • SetMsgWaitingState() : SmsIndicationState
  • SetMStartStopAudio() : EmServThreadMsg
  • SetMultiKeyMode() : Keyboard
  • SetMultiLine() : ItemRendererProperties
  • SetMultiSlot() : MultiSlotHandler
  • SetMultiSlotMode() : OmMultiSlotReqArg
  • SetMute() : Audio, AudioContext, SpeechSimpleAudioDevice, RadioAudioDevice, AudioDeviceBase, MediaRecorder
  • SetMutex() : FfsTestThread
  • SetName() : PbRecord, PbAdvAddEditEntry, SaveEntryInPhonebookMsg, DataConnProfile, Thread, Application, PreparedSound, Melody, BtBipAttachmentDesc, BtBipAttachment
  • SetNamePrefix() : VCard
  • SetNameRecNo() : PbNumberRecord
  • SetNameSuffix() : VCard
  • SetNativeDim() : BtBipImageProperties
  • SetNativeEncoding() : BtBipImageProperties
  • SetNativeFormat() : BtBipImageProperties
  • SetNativeProperty() : StorageDevice, File, RootFileImp, FlashFileImp
  • SetNativeSize() : BtBipImageProperties
  • SetNavigationGuidance() : Control
  • SetNegation() : FilterProvider
  • SetNetworkNameLong() : NetworkInformationMsg, MnInformationIndArg, StatusProvider, DataHandler
  • SetNetworkNameLongAddCi() : NetworkInformationMsg, MnInformationIndArg
  • SetNetworkNameShort() : NetworkInformationMsg, MnInformationIndArg, StatusProvider, DataHandler
  • SetNetworkNameShortAddCi() : NetworkInformationMsg, MnInformationIndArg
  • SetNetworkSearchMode() : NetworkHandler
  • SetNewchv() : ChvUnblockReqArg, ChvChangeReqArg
  • SetNewCurrentIndication() : SmsIndicationState
  • SetNewRequestState() : BtRequestStateChangedMessage
  • SetNewSmsState() : SmsIndicationState
  • SetNewStatRepState() : SmsIndicationState
  • SetNewWord() : Zi8AddWordMsg, T9AddWordMsg
  • SetNext() : UserDispatcher, DrawableObject, Control, BtMultiConnectionController::BtConnection, BtDeviceList::BtDeviceListNode, LinkableBase, DeletedNode
  • SetNextFreeUniqueId() : PbNextFreeIdRecord
  • SetNextLockTable() : LockTable
  • SetNickname() : IrdaTransport
  • SetNmeaUartSettings() : LcsProviderImplBase, LcsProvider
  • SetNoId() : PbNumberRecord
  • SetNoNvramSms() : MdhSmsTransmitStartIndArg
  • SetNoOfColumns() : Grid, GridModel
  • SetNoOfGroups() : CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspReadIndArg
  • SetNoOfItems() : AbstractListBox, AbstractListBoxModel
  • SetNoOfPages() : Cbs::Filter
  • SetNoOfRows() : Grid, GridModel
  • SetNoOfSaved() : MdhSmsWriteCnfArg
  • SetNoOfSubunitInfoEntries() : BtAvrcpSubunitInfoParams
  • SetNoOfVisibleLines() : AbstractEditBoxModel
  • SetNoSimSms() : MdhSmsTransmitStartIndArg
  • SetNoteDisplay() : ToDoComposeWin
  • SetNotification() : MdhSmsStatusIndArg
  • SetNotifySsArg() : SsNotifyIndArg
  • SetNsapi() : SysSocket
  • SetNumber() : DataItem, GenericFeatureData, Property
  • SetNumberingPlanIdentification() : TypeOfAddress
  • SetNumberNotAvailableText() : PhoneNumber
  • SetNumberOfCharsAcrossDisplay() : SimTkProfile
  • SetNumberOfCharsSupportedInDisplay() : SimTkProfile
  • SetNumberOfRingSignals() : BtHsService
  • SetNumberOfTones() : CustomToneAudioReference
  • SetNumerator() : Fraction
  • SetNumOfNodeRecord() : RegNodeBuffer
  • SetNvRamStorageInfo() : NvRamStorage
  • SetOaPhoneNumber() : SmsNewMessageIndArg
  • SetObexHandle() : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexController::BtObexConnection
  • SetObexResult() : BtBppReq
  • SetObjectDescription() : BtBppSndFilePushReqRequest
  • SetObjectName() : BtBppSndFilePushReqRequest
  • SetObjectTreeURI() : GuidServiceTable
  • SetObjectType() : BtBppSndFilePushReqRequest
  • SetObtainedDocument() : EmsEditor
  • SetOffset() : TimeZone
  • SetOldchv() : ChvChangeReqArg
  • SetOldRequestState() : BtRequestStateChangedMessage
  • SetOnlineMode() : MmCallInfo
  • SetOperands() : BtAvrcpRawFrameParams
  • SetOperandsLength() : BtAvrcpRawFrameParams
  • SetOperation() : BtRequestOperationMessage, BtAvrcpPanelPassThroughParams
  • SetOperationCode() : SsUssdReqArg, UssdAnswerIndArg, SsUssdIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg
  • SetOperationData() : BtAvrcpPanelPassThroughParams
  • SetOperationDataLength() : BtAvrcpPanelPassThroughParams
  • SetOperationService() : BtAvrcpControllerDeviceListItem
  • SetOperationState() : StreamingInfo
  • SetOption() : SysSocket
  • SetOptions() : SetupIdleModeTextReqArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • SetOpType() : DrmPermission
  • SetOrganizationalUnit() : VCard
  • SetOrganizationName() : VCard
  • SetOrientation() : PositionIndicator
  • SetOrig1TextInfoAlpha() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • SetOrig2TextInfoAlpha() : CallControlSetupIndArg
  • SetOriginalRow() : Provider::Modification
  • SetOriginatorApplicationPortAddress() : SmsContext
  • SetOutputFrame() : ScicosMpeg4VideoDecoder
  • SetOwner() : Panel
  • SetPacked() : GetInputRspArg
  • SetPackedTime() : ValidityPeriod
  • SetPacketFilter() : PsdDataConnProfile, PsdDataConn, PdpContext
  • SetPacketFilterPending : PdpContextManager
  • SetPage() : BtAvrcpSubunitInfoParams
  • SetPageFlag() : Zi8SelectionBox, Zi8AlphabetBox
  • SetPaging() : AbstractEditBoxModel
  • SetPairableMode() : BtLocalSettings
  • SetPanelAlignment() : Desktop
  • SetPanelEnabled() : Desktop
  • SetPanelPassThroughParams() : BtAvrcpPanelPassThroughRequest
  • SetPaProfileName() : BtPaSupportedProfileMessage
  • SetParam() : VideoChannel, EngineeringModeControlRequestArg, Accessory
  • SetParam1() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • SetParam2() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • SetParam3() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • SetParam4() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • SetParameter() : PbNameFilterProvider, PbMergeProvider, PbNumberFilterProvider, Provider, FilterProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, DualFilterProvider, AppendProvider
  • SetParameters() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AudioEncoder, AudioDecoder
  • SetParent() : DrawableObject, Control, Component
  • SetParentArea() : DrawableObject
  • SetParentContainer() : ItemContainer, AbstractItemContainer, ProviderProxyContainer
  • SetParentWindow() : AtlItemMenuWindow
  • SetParity() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetPartlyConcSmsStateChangeable() : SimPduHandler, DataHandler
  • SetPasswd() : DataConnProfile
  • SetPassword() : PdpContext::Authentication, SsGetPasswordRspArg, SsPasswordIndArg
  • SetPasswordMode() : AbstractEditBox, AbstractEditBoxModel
  • SetPath() : MetaData, ObexLayer, ObexClient, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • SetPathControlMode() : AudioReference
  • SetPathFlags : ObexObject
  • SetPathname() : PathProfile, MCServiceInterfaceMsg, RamFileObj
  • SetPathRequest() : BtObexClientService
  • SetpBackup : ObexObject
  • SetPbAddType() : UsimPbUpdDataReqArg, UsimPbReadDataReqArg, UsimPbUpdDataResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg
  • SetPbAlphaTagRequestBehaviour() : SimHandler, AtcHandler
  • SetPbChangedField() : UsimPbUpdReqArg
  • SetPbCntType() : PbCountReqArg, PbCountIndArg
  • SetPbDescriptor() : UsimPbSelectResArg
  • SetPbFillStatus() : UsimPbFillStatusResArg
  • SetPbHasGrown() : PbSynchronizer
  • SetPbLocation() : UsimPbSelectReqArg, UsimPbSelectResArg
  • SetPbProvider() : PbAbstractWin
  • SetPbRecordRequestBehaviour() : AtcHandler
  • SetPbRefRecord() : UsimPbReadAsyncIndArg, UsimPbReadResArg
  • SetPbRefType() : UsimPbUpdRefReqArg, UsimPbReadRefReqArg, UsimPbUpdRefResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • SetPbResult() : UsimPbReadyIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg
  • SetPbRwRecord() : UsimPbUpdReqArg, UsimPbReadReqArg, UsimPbReadAsyncIndArg, UsimPbReadResArg
  • SetPbSignalType() : UsimPbFillStatusResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg
  • SetPbTitle() : PbAbstractWin
  • SetPbtype() : PbEntryUpdReqArg, PbEntryReadReqArg, PbEntryReadIndArg
  • SetpDontCreate : ObexObject
  • SetPduNode() : MdhSmsWriteReqArg
  • SetPeakRate() : PdpContext::QualityOfService
  • SetPeer() : UdpSocket
  • SetPeerDataSocketAddr() : FtpClient
  • SetPen() : DeviceContext
  • SetPenColor() : DeviceContext
  • SetPenColorHsv() : DeviceContext
  • SetPenColorRgb() : DeviceContext
  • SetPenColorValue() : DeviceContext
  • SetPendingDataFlag() : IsrDataManager
  • SetPendingState() : SmsIndicationState
  • SetPenStyle() : DeviceContext
  • SetPhoneNo() : PbAdvAddEditEntry, SaveEntryInPhonebookMsg, RedialSetupMsg, MocSetupReqArg
  • SetPhoneNoType() : PbNumberRecord
  • SetPhoneNumber() : SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, PbNumberRecord, CsdDataConnProfile, DataItem, Property, PbAlphaTagRequestMsg, CcbsRecallMsg, DhChannelOpenReqArg, SiChannelOpenPromptReqArg, SimTkCallSetupIndArg, MocSetupRejIndArg, CallIndArg, AtPbListCnfArg, AtAlphaTagCnfArg, AtAlphaTagReqArg
  • SetPhysicalDomain() : WapProfile
  • SetPhysicalPortNumber() : WapProfile
  • SetPhysicalPortService() : WapProfile
  • SetPhysicalProxyAddress() : WapProfile
  • SetPhysicalProxyId() : WapProfile
  • SetPhysicalPushEnabled() : WapProfile
  • SetPinCode() : BtSendPasskeyRequest
  • SetPinYinMode() : Zi8Wrapper
  • SetPinyinSpellingMode() : Zi8Wrapper
  • SetPitch() : AudioReference
  • SetPixel() : VirtualDisplay
  • SetPlayActive() : BtAvrcpControllerDeviceListItem
  • SetPlaybackAndViewfinderOrder() : VideoChannel
  • SetPlaybackContrast() : MediaPlayer
  • SetPlaybackRect() : VideoChannel
  • SetPlaybackVideoQuality() : MediaPlayer
  • SetPlayTime() : AudioPlayTimeMsg
  • SetPlmn() : RegistrationChangeMsg, RegistrationSuccessMsg, UsimPlmnUpdReqArg, PlmnInfoReqArg, AttachReqArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg
  • SetPlmnList() : UsimPlmnReadIndArg
  • SetPlmnScanList() : PlmnScanFinishedMsg, PlmnListCnfArg
  • SetPlmnSearchActive() : NRegStateIndArg
  • SetPluginName() : AtlApplicationPlugin
  • SetPort() : DhChannelOpenReqArg
  • SetPortNo() : InetSocketAddr
  • SetPortNumber() : WapProfile
  • SetPortService() : WapProfile
  • SetPos() : Rect, PaneObject, Component, MenuProperties
  • SetPosIndicatorWidth() : GridView
  • SetPosIndSize() : CTPositionIndicatorView
  • SetPosition() : EditorItemNode, Indicator, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsTransmitIndArg, MediaPlayer
  • SetPositionHint() : TabButton
  • SetPositionIndicatorEnabled() : AbstractMultiLineEditor
  • SetPostalCode() : VCard
  • SetPostOfficeAddress() : VCard
  • SetPosX() : PenUpMsg, PenDownMsg
  • SetPosY() : PenUpMsg, PenDownMsg
  • SetPowerMode() : DefaultDisplay, Display, DefaultDisplay, PowerModeIndMsg, OmPowerUpArg, OmControlIndArg, StatusProvider, DataHandler
  • SetPowerState() : MmiSimServer
  • SetPowerTimeout() : DefaultDisplay, Display, DefaultDisplay
  • SetPrecedence() : PdpContext::QualityOfService
  • SetPreconditions() : UibNotifyTest, UibMsgDisplayTest, UibAccessorTest
  • SetPredInputEnabled() : SmsSettingsRecord
  • SetPreferredFormat() : BtBipImagingCapabilities
  • SetPreferredStorageType() : AbstractSmsApp
  • SetPressed() : RadioButtonItem
  • SetPressedIndex() : SoftkeyBar
  • SetPressedItem() : TRadioButtonList< Content >, RadioButtonList
  • SetPrevConsumedCount() : DrmConstraint
  • SetPrevFirstConsumedInterval() : DrmConstraint
  • SetPreview() : MultiTapCaret
  • SetPrevious() : BtDeviceList::BtDeviceListNode, DeletedNode
  • SetPreviousFrameBuffering() : Image
  • SetPrimaryDnsServerAddress() : DataConnProfile, DataConn
  • SetPrimaryProfileId() : PsdDataConnProfile
  • SetPriority() : ToDoPriorityDialogWin, Thread, Application, AudioContext, AudioReference, MediaRecorder, MediaPlayer
  • SetPriorityGroup() : AudioReference
  • SetProactiveCause() : SimTkRefreshNewRspArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, LaunchBrowserIndArg, SimTkRefreshQueryResArg, SetupIdleModeTextRspArg, PlayToneRspArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, TermRspCnfArg
  • SetProblemCode() : TaggedProblemCode
  • SetProcessId() : SimTkInterfaceIndArg
  • SetProcessSource() : GprsClassIndArg
  • SetProfile() : BtAuthorizationRequiredWindow, DataConnInfoMsg, BtCloseMessage, BtOpenMessage, BtAuthorizationRequiredMessage
  • SetProfileId() : DataConnProfileInfoMsg, WapProfile
  • SetProfileName() : DataConnProfileInfoMsg, WapProfile
  • SetProfileWriteable() : WapProfile
  • SetProgress() : SyncProgressMsg, ProgressBar, AbstractDelegationProvider, JoinProvider, DataControlBootProgressMsg
  • SetProgressMsgEnabled() : Image
  • SetProperties() : AbstractItemRenderer
  • SetProperty() : Window, ToggleActionGroup, TimeEditor, TextLine, TextFormat, TextBox, TabControl, TabButton, RadioButtonGroup, RadioButtonControl, RadioButtonAction, PushButton, ProgressBar, PositionIndicator, PasswordEditor, OpenWindowAction, OpenContextMenuAction, MultiLineEditor, MessageBox, LineEditor, ItemTree, ItemRendererProperties, ItemMenu, ItemGrid, ItemContainer, ItemBox, Item, IpAddrEditor, ImageObtainer, ImageBox, IconSet, GridLayout, FlowLayout, DrawableObject, DateEditor, Control, ContextMenu, Component, CloseWindowAction, CheckBoxControl, CheckBoxAction, AnimatedTextLine, Alert, Action, AbstractToggleAction, AbstractTextObject, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemGrid, AbstractItemContainer, AbstractGrid, AbstractEditor, AbstractButton, CTResourcePack, CamWin32, ValueMappingPropertyDescriptor< T_Container >, PropertyItem, PropertyDescriptor, RangeMappingPolicy, MappingPolicy, ListPropertyDescriptor, IndicatorItem, FeatureItemContainer, FeatureItem, ContextFeatureItem, MenuProperties, MenuDesc, AtlWindow, UsimFilePropertyIndArg, MultiMediaEditor
  • SetPropertyEditorID() : PropertyItem
  • SetPropertyItem() : PropertyEditor, PropertyTriggerMsg
  • SetProrityDisplay() : ToDoComposeWin
  • SetProtocol() : LcsProvider
  • SetProtocolIdentifier() : SmsContext, SmsNewMessageIndArg, SmsCommand, SmsSubmit, SmsDeliver, MdhSmsNewMessageIndArg
  • SetProtocolIdentifierExists() : ParameterIndicator
  • SetProvider() : UibUpdateThreadlet, UibListBoxModel, SmsBasicProvider, ProvDetailListBoxWin, ProvListBoxWin, PbProvListBox, PbProvListBoxModel, PbDetailProvider, ProviderUpdateMsg, ProviderListBoxModel, DataItem, Property, ProviderProxyItem, ProviderProxyContainer
  • SetProviderId() : AppendProvider, DataControlBootProgressMsg
  • SetProviderRow() : ProviderProxyItem
  • SetProvisionFileRef() : SimLaunchBrowserReqArg
  • SetProxyId() : WapProfile
  • SetProxyName() : WapProfile
  • SetProxyProviderId() : WapProfile
  • SetPsLociData() : UsimPsLociReadIndArg
  • SetPtr() : FixedPtrArray< T >
  • SetPuct() : SimPuctUpdReqArg, SimPuctReadIndArg
  • SetPushEnabled() : WapProfile
  • SetQosDelay() : PsdDataConnProfile
  • SetQosMeanRate() : PsdDataConnProfile
  • SetQosPeakRate() : PsdDataConnProfile
  • SetQosPrecedence() : PsdDataConnProfile
  • SetQosReliability() : PsdDataConnProfile
  • SetQuality() : SignalStrengthLevelIndArg
  • SetQualityLevel() : JpegEncoder::EncodingParameters
  • SetQualityOfService() : PsdDataConn, PdpContext, PdpContext::ActivationStatus
  • SetQualityOfServicePending : PdpContextManager
  • SetQualityValid() : SignalStrengthLevelIndArg
  • SetQueryRemoteDeviceName() : BtDeviceSearchRequest
  • SetRadioAccessTechnology() : RatStateMsg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, StatusProvider, DataHandler
  • SetRadioFreq() : FmRadioStationsRecord
  • SetRadioLastFreq() : FmRadioSettingsRecord
  • SetRadioLastVolume() : FmRadioSettingsRecord
  • SetRadioOn() : FmRadioApplication
  • SetRadioPriority() : PdpContext::ActivationStatus
  • SetRamFileObj() : RamFileNode
  • SetRange() : PositionIndicator, ValueIndicator
  • SetRangeCount() : RangeMappingPolicy
  • SetRasterOp() : DeviceContext
  • SetRat() : AttachReqArg
  • SetRatChangeMode() : RatChangeModeChangedMsg, OmRatChangeIndArg, StatusProvider, DataHandler
  • SetRate() : AudioReference
  • SetRawFrameParams() : BtAvrcpRawFrameRequest
  • SetRead() : MdhDeletionCmd
  • SetReadEventNotification() : InetSocket
  • SetReadOnly() : DataConnProfile, MultiLineEditor, AbstractEditor, File, File::Attributes, MultiMediaEditor, RootFileImp, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • SetReadOnlyMode() : ToDoComposeWin
  • SetReadType() : UsimFilePropertyReqArg, UsimPlmnReadReqArg, UsimUpdRejArg, UsimUpdCnfArg, UsimReadRecordRejArg, UsimReadRejArg, UsimPlmnReadIndArg
  • SetReady() : SimPbEntryCont
  • SetReadyTimer() : PdpContextManager::AttachStatus
  • SetReason() : ShortMessageStatus
  • SetRecipientPhoneNumber() : SmsNewStatusReportIndArg
  • SetRecno() : UsimLangUpdReqArg, UsimSmsParamUpdReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimSmsParamUpdIndArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, SimAcmReadIndArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, PbEntryReadIndArg, MdhSmsUpdStatusIndArg, IconDescReadReqArg
  • SetRecNo() : SimCmiReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimRefreshIndArg, MdhSmsReportReadIndArg
  • SetRecognitionMode() : VrEngineParams, TelecaVrEngineParams, DummyVrEngineParams
  • SetRecordedSize() : StreamAudioReference
  • SetRecordingDelay() : StreamAudioPlayer
  • SetRecordingRate() : StreamAudioReference
  • SetRecordingWaitCondition() : StreamAudioPlayer
  • SetRecordLength() : SimFileInfoIndArg
  • SetRecordNumber() : PbEntryRequestMsg, AtPbListCnfArg, AtPbListReqArg
  • SetRecordSettings() : MediaRecorder
  • SetRecordTableValue() : RecordHandler
  • SetRecstatus() : MdhSmsUpdStatusReqArg
  • SetRecurrence() : CalendarRecord, CalendarAddRecordWin
  • SetRed() : Color
  • SetRediallingEnable() : CallHdlBase
  • SetRedialStatus() : RedialStatusIndArg
  • SetRefCount() : DrmRightsObject
  • SetReference() : AudioActiveReference
  • SetReferenceLocation() : GltpAssistanceData
  • SetReferenceNumber() : SmsSendCnfArg, SmsNewStatusReportIndArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkSsIndArg, SimTkSmsPpIndArg
  • SetReferenceTime() : GltpAssistanceData
  • SetRefNo() : MdhSmsConcRefNumIndArg
  • SetRefRecno() : UsimPbUpdRefReqArg, UsimPbReadRefReqArg, UsimPbUpdRefResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • SetRefreshIndicator() : SimTkRefreshQueryReqArg
  • SetRefreshPossible() : SimTkRefreshCnfReqArg, SimTkResetCnfReqArg
  • SetRefreshType() : SimRefreshIndArg
  • SetRegion() : VCard
  • SetRegisteredPlmn() : StatusProvider, DataHandler
  • SetRegisterMode() : StatusProvider, DataHandler
  • SetRegisterParams() : BtAvrcpRegisterRequest
  • SetRegisterRejectCause() : StatusProvider, DataHandler
  • SetRegisterStatus() : StatusProvider, DataHandler
  • SetRejectCause() : RegistrationChangeMsg, PdpContextManager::AttachStatus, PdpContext::ActivationStatus, SsCauseIndArg, SsGetPasswordRejArg, SsFacilityRejArg, MocSetupRejArg
  • SetRejectDuplicates() : SmsContext, SmsSubmit
  • SetRejected() : PlmnScanFinishedMsg
  • SetRelativeTime() : ValidityPeriod, CodedTimeStamp
  • SetReleaseComplete() : SsCcbsResultIndArg, SsUssdIndArg, SsCauseIndArg, SsErrIndArg, SsRejArg, SsRetResIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg
  • SetReliability() : PdpContext::QualityOfService
  • SetRemainingDataLength() : DhChannelReceiveIndArg
  • SetRemoteDeviceAddress() : BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow
  • SetRemoteDeviceName() : BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtSetRemoteDeviceNameRequest
  • SetRenderer() : ItemBox, ContextMenu, AbstractItemGrid, ItemLabel
  • SetRendererHint() : ItemRendererProperties
  • SetRendererProperties() : ItemContainer, AbstractItemContainer
  • SetRepaintHint() : GridModel
  • SetRepeatCount() : Image, Image::MetaData, PreparedSound, AudioReference, MediaPlayer
  • SetReplyPathExists() : SmsDeliver
  • SetReplyPathRequested() : SmsSettingsRecord
  • SetReport() : UsimPbLocationIndArg, TestparamReportArg
  • SetReportArg() : EngineeringReportMsg
  • SetReqSent() : LcsAppUtils
  • SetRequestedByteCount() : StreamingReadInfo
  • SetRequestedStackSize() : Thread, Application
  • SetRequestFlags() : ObexObject
  • SetRequestId() : BtRequestMessage
  • SetRequestReplyPath() : SmsContext, SmsSubmit
  • SetRequestReport() : SmsCommand, SmsSubmit
  • SetRequestState() : BtServiceRequest, BtRequest, BtLocalRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBppReq
  • SetRequestStatusReport() : SmsContext
  • SetRequestType() : BtRequestStateChangedMessage, BtAvrcpOperationRequestResponse
  • SetResourcePack() : CustomizableTheme
  • SetResourceUri() : CTResourcePack
  • SetResponse() : BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest
  • SetResponseCode() : ObexObject, BtObexClientOperationRequest
  • SetResponseType() : BtAvrcpOperationRequestResponse, AtResponse
  • SetRestricted() : AutoCallRestrictIndArg
  • SetRestrictedNumberText() : PhoneNumber
  • SetResult() : BtHfCmaPhoneNumberRequired, BtRequestMessage, BtOperationBase, BtApplicationMessage, SsInterrogateIndArg, SmsSendRejArg, SmsSendCnfArg, ExtProactiveCmdIndArg, EngineeringModeControlResponseArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg
  • SetRetranslateEnabled() : Item
  • SetReturnCode() : AudioMsg
  • SetRfCommPortNumber() : BtObexServerAddr
  • SetRfComPort() : BtObexConnectRequest, BtObexClientService
  • SetRgb() : Color
  • SetRi() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetRight() : Rect, WinRect
  • SetRightSize() : ControlFrameView
  • SetRightSoftkey() : Window
  • SetRingInterval() : BtHsService
  • SetRole() : BtAvrcpRegisterParams, BtAvrcpDeRegisterRequest
  • SetRootDir() : ServerConfig
  • SetRootFileType() : RegNodeBuffer
  • SetRow() : ProvDetailListBoxWin, DefaultCaret, Caret, Cell, Provider::Modification
  • SetRowProperty() : GridLayout
  • SetRowTitled() : Grid, GridModel
  • SetRowTitleWidth() : GridView
  • SetRtcEventCallbackFn() : RtcSignalProcessor
  • SetRunning() : FfsTestThreadlet, FfsTestThread, FtpTransfer
  • SetRunningAbortRequest() : BtObexController::BtObexConnection
  • SetRunningRequest() : BtMultiConnectionController::BtConnection
  • SetSampleRate() : StreamAudioReference
  • SetSatelliteData() : SatteliteInfoWin
  • SetSca() : SmsNewSocketDataMsg
  • SetScanActive() : RegistrationChangeMsg
  • SetScanStatus() : StatusProvider, DataHandler
  • SetScNumber() : SmsControlIndArg
  • SetScoPathStatus() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • SetScrollDelay() : ItemRendererProperties
  • SetScrollGap() : ItemRendererProperties
  • SetScStrokeMode() : Zi8Wrapper
  • SetSddbCase() : BtObexServerAddr
  • SetSearchStopLevel() : RadioAudioDevice
  • SetSecLockStates() : SimChvHandler, DataHandler
  • SetSecond() : Time, DateTime
  • SetSecondaryDnsServerAddress() : DataConnProfile, DataConn
  • SetSecondFilterColumn() : DualFilterProvider
  • SetSecondFilterRule() : DualFilterProvider
  • SetSeconds() : ValidityPeriod
  • SetSecurity() : BtObexServerAddr
  • SetSecuritySettings() : BtObexRegisterServerRequest, BtObexRegisterClientRequest
  • SetSegmentCount() : SmsSendingConfirmDialog
  • SetSegmentName() : RamFileNode
  • SetSelected() : RadioButtonControl, RadioButtonAction, CheckBoxControl, CheckBoxAction, AbstractToggleAction, CheckBoxItem, CheckBox, CheckBoxModel
  • SetSelectedCell() : Grid, GridModel
  • SetSelectedGroupIndex() : PbSelectGroup
  • SetSelectedIndex() : AbstractItemGrid, AbstractGrid, MenuAccessor, AbstractListBox, AbstractListBoxModel, AtlItemGridWindow, Zi8SelectionBox, SelectionBox
  • SetSelectedNoIndex() : PbDetailListBox, PbDetailListBoxModel
  • SetSelectedNumberTypeIndex() : PbSelectNoType
  • SetSelectedRadioButton() : DataConnOptionWin
  • SetSelectedRadioButtonAction() : RadioButtonGroup
  • SetSelectedRow() : ProvListBoxWin, PbProvListBox, PbProvListBoxModel, PbAbstractWin, AtlItemListWindow
  • SetSelectedSms() : AbstractSmsViewerWin
  • SetSelectedToggleAction() : ToggleActionGroup
  • SetSelection() : AbstractEditor
  • SetSelectionHeight() : ItemRendererProperties
  • SetSelectionMode() : Grid, GridModel
  • SetSelectionStyle() : AbstractEditor
  • SetSelector() : SimAcmUpdReqArg, SimAcmReadReqArg, SimAcmUpdIndArg, SimAcmReadIndArg
  • SetSendDataType() : DhChannelSendReqArg
  • SetSenderID() : AudioUserDefinedMsg
  • SetSenderPhonenumber() : SmsPortDataRecvMsg, SmsNewSocketDataMsg
  • SetSenderPortNo() : SmsNewSocketDataMsg
  • SetSendingConfirmationEnabled() : SmsSettingsRecord
  • SetSendingResult() : SmsHandler, SmsFactory
  • SetSendPreviewMandatory() : SmsSettingsRecord
  • SetSensorImageSize() : CamWin32
  • SetSent() : MdhDeletionCmd
  • SetSeparator() : Item
  • SetSequence() : BootDispatchingArg
  • SetSerialIoSet() : SerialSocketData
  • SetSerialNumber() : CbsNewDataRejArg
  • SetServedCallApp() : RedialSetupIndArg
  • SetServedCallApplication() : RedialSetupMsg
  • SetServerConfig() : Server
  • SetServerDefaultParam() : BtObexServerAddr
  • SetServerTargetString() : BtObexServerAddr
  • SetServerUuid128() : BtObexServerAddr
  • SetService() : BtServiceMessage, SmsSendReqArg
  • SetServiceCenter() : SendSmsMsg, AbstractSmsComposeWin
  • SetServiceCenterAddress() : SmsContext
  • SetServiceCentreAddress() : Tpdu, Sms
  • SetServiceClass() : BtDeviceAndServiceClass
  • SetServicesToVerify() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • SetServiceVerifyResult() : BtOperationSelectDeviceAndPerformServiceVerify
  • SetSettingModeTextline() : CameraViewFinderWin
  • SetSetWaitIndicatorArray() : MdhSmsSetWaitingReqArg
  • SetShallTransmit() : MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg
  • SetShortMessageFailure() : SmsSendCnfArg
  • SetShortMessageFailureCause() : SmsSendCnfArg
  • SetShortMessageStatus() : SmsNewStatusReportIndArg
  • SetShutdownAllowed() : Application
  • SetSiClientFlags() : BrowserRegisterReqArg
  • SetSignalQualityLevel() : SignalQualityLevelMsg, StatusProvider, DataHandler
  • SetSignalQualityMax() : SignalQualityLevelMsg, SignalStrengthLevelIndArg, StatusProvider, DataHandler
  • SetSignalStrength() : BtRemoteDeviceMessage
  • SetSignalStrengthLevel() : SignalStrengthLevelMsg, StatusProvider, DataHandler
  • SetSignalStrengthMax() : SignalStrengthLevelMsg, SignalStrengthLevelIndArg, StatusProvider, DataHandler
  • SetSilentReset() : StartUp::Data
  • SetSimAccess() : DataHandler
  • SetSimCallSetupOption() : CallSetupBySimtTkReqArg
  • SetSimData() : SimAccessor
  • SetSimErrorCode() : SimAuxHandler, DataHandler
  • SetSimFlashStoredTpduNum() : TpduHeaderInformation
  • SetSimIndicator() : SimStateChangedMsg, SimAccessor
  • SetSimInfo() : SimInfoIndArg, SimAccessor, DataHandler
  • SetSimInitInfo() : DataHandler
  • SetSimLockStates() : DataHandler
  • SetSimLockStatus() : SimAuxHandler
  • SetSimRecNo() : PbNumberRecord
  • SetSimRefreshPossible() : SimTkHandler, SimAuxHandler, DataHandler
  • SetSimResetPossible() : SimTkHandler, SimAuxHandler, DataHandler
  • SetSimResult() : DhChannelChangeStatusResArg, DhChannelDataAvailableResArg, SimBrowserTermResArg
  • SetSimServiceType() : SimTkSsIndArg
  • SetSimTkMainMenu() : SimTkMainMenuProvider, DataHandler
  • SetSimTkProfile() : SimTkProfileGetCnfMsg, OmSetTermProfileReqArg, OmGetTermProfileCnfArg
  • SetSimtkRelated() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • SetSimUpdateStatus() : BdnIndArg, FdnIndArg
  • SetSingleShot() : FunctionalityIndicator
  • SetSingleSrrPerSmsEnabled() : SmsContext
  • SetSize() : MetaData, Rect, PositionIndicatorView, IconState, PaneObject, Component, WinRect, Grid, BtBipAttachmentDesc, BtBipAttachment, RtStreamingBuffer, File::Attributes
  • SetSkIcon() : SoftkeyDesc
  • SetSkText() : SoftkeyDesc
  • SetSleepDuration() : Cbs::Filter
  • SetSleepMode() : RealTimeClock
  • SetSmsAlertType() : SmsAlert
  • SetSmsComposeEnabled() : AbstractSmsApp
  • SetSmsExtendedData() : SimPduHandler
  • SetSmsHeaderCacheParams() : SimPduHandler, DataHandler
  • SetSmsId() : MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSmsUpdStatusReqArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg
  • SetSmsInfoAlpha() : SimTkSmsPpIndArg
  • SetSmsInfoBoxType() : SmsInfoBox
  • SetSmsInfoIcon() : SimTkSmsPpIndArg
  • SetSmsMoreMessageType() : SmsHandler, SmsSetMoreMessageReqArg, SmsGetMoreMessageStatusIndArg
  • SetSmsParameter() : SimSmsParamHandler, SimSmsParameter
  • SetSmsParamRecord() : UsimSmsParamUpdReqArg
  • SetSmsPortNo() : SmsPortDataRecvMsg, SmsNewSocketDataMsg
  • SetSmsr() : MdhDeletionCmd
  • SetSmsrData() : SimSmsrUpdReqArg, SimSmsrReadIndArg, MdhSmsReportReadIndArg
  • SetSmsReferenceNumber() : SmsContext
  • SetSmsrLocation() : SmsNewStatusReportIndArg, MdhNewStatusReportIndArg
  • SetSmsStatus() : SimRefreshIndArg, SimPduHandler
  • SetSmsStorageType() : TpduHeaderInformation
  • SetSoBroadcastOption() : InetSocket
  • SetSocketData() : SocketControlMsg
  • SetSocketEventListener() : Socket, SerialTerminalSocket
  • SetSocketExecutionContext() : SocketSerialTerminalListener
  • SetSoDebugOption() : InetSocket
  • SetSoDontRouteOption() : InetSocket
  • SetSoftkey() : Window, AtlWindow
  • SetSoftkeyBarHeight() : WindowFrameView
  • SetSoftkeyDesc() : ContextDescription
  • SetSoKeepAliveOption() : InetSocket
  • SetSoLingerOption() : InetSocket
  • SetSoRcvBufOption() : InetSocket
  • SetSoReuseAddrOption() : InetSocket
  • SetSortAsc() : UibSettingsRecord
  • SetSortColumn() : SortProvider
  • SetSorting() : SmsSettingsRecord
  • SetSortKey() : UibSettingsRecord
  • SetSortMode() : ChineseQuickSortProvider
  • SetSortOrder() : SortProvider
  • SetSoSndBufOption() : InetSocket
  • SetSoundFilter() : SoundBrowserWin
  • SetSpeakerGainRequest() : BtHsService, BtHfService, BtAudioAccessoryService
  • SetSpeed() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetSpnStruct() : SimSpnReadIndArg
  • SetSrPos() : MdhNewStatusReportIndArg
  • SetSrStatus() : MdhNewStatusReportIndArg
  • SetSsData() : SsDataIndArg
  • SetSsErrorCode() : SsErrIndArg
  • SetSsInfoAlpha() : SimTkSsIndArg
  • SetSsInfoIcon() : SimTkSsIndArg
  • SetSsOpeartionCode() : UssdAnswerMsg
  • SetSsOperationCode() : SsNotifyIndArg
  • SetSsSequence() : SsInfoMsg, SsFacilityIndArg
  • SetSst() : SimSstReadIndArg
  • SetStackState() : BtStateChangedMessage
  • SetStartDate() : DrmConstraint
  • SetStartDelay() : ItemRendererProperties
  • SetStartFrame() : MP3AudioReference
  • SetStartIndex() : EditorLine, TextListLine, CompoundItemReferrer
  • SetStartpage() : WapProfile
  • SetStartpagePassword() : WapProfile
  • SetStartpageUsername() : WapProfile
  • SetStartParam() : VoiceMemoAudioDevice, ToneAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice
  • SetStartPos() : SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg
  • SetStartPosition() : AudioReference
  • SetStartRecno() : UsimPbUpdReqArg
  • SetState() : ProviderUpdateMsg, Control::NavigationGuidance, Camera, RadioButtonModel, BtAvrcpPanelPassThroughParams, PdpContextManager::AttachStatus, PdpContext::ActivationStatus, FtpClient
  • SetStation() : RadioAudioDevice
  • SetStatus() : LocResController, LcsOptionsMenuWin, LcsMainMenuWin, Provider, SimpleAudioDevice, AocChargingStatusMsg, RegistrationChangeMsg, ChvChangedMsg, ExtPsdContextListener_SioGlueWrapper, Tpdu, SimInitIndArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, ShortMessageStatus, DetachCnfArg, NRegStateIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, ImeiReadIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsRefreshIndArg, AocIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, AtAccessoryRegisterCnfArg, AtGenericCmdIndArg, AtPbListCnfArg, AtPbSelectCnfArg, SioGlueWrapper, TpduCache, TpduHeaderInformation
  • SetStatusChanged() : SmsBasicProvider
  • SetStatusLine() : HttpResponse
  • SetStatusReportEnabled() : SmsSettingsRecord
  • SetStatusReportOnIdleScreen() : SmsSettingsRecord
  • SetStereoMode() : RadioAudioDevice
  • SetStkCallSetupNo() : CallSetupBySimtTkReqArg
  • SetStopBits() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetStopCallback() : MapiAudioPlayer, AudioMapiManager
  • SetStopCause() : AudioStoppedMsg
  • SetStorageDeviceId() : PathProfile
  • SetStorageLocation() : SmsSettingsRecord
  • SetStoragePosition() : SmsNewStatusReportIndArg, SmsNewMessageIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsRefreshIndArg
  • SetStorageType() : SmsNewStatusReportIndArg, SmsNewMessageIndArg, MdhSmsNewMessageIndArg
  • SetStorMedia() : MdhSetStorageReqArg
  • SetStreet() : VCard
  • SetString() : DataItem, Property
  • SetStringDeviceAddress() : BtDeviceAddress
  • SetStringNode() : RegNodeBuffer
  • SetStructure() : FtpDataSocket
  • SetStyle() : Pen, Brush
  • SetSubAddr() : DhChannelOpenReqArg, SiChannelOpenPromptReqArg
  • SetSubAddress() : SimTkCallSetupIndArg
  • SetSubmitParameter() : SmsContext
  • SetSubunitId() : BtAvrcpRawFrameParams
  • SetSubunitInfoEntries() : BtAvrcpSubunitInfoParams
  • SetSubunitInfoParams() : BtAvrcpSubunitInfoRequest
  • SetSubunitInfos() : BtAvrcpRegisterParams
  • SetSubunitType() : BtAvrcpRawFrameParams
  • SetSuccess() : OmMultiSlotIndMsg, OmMultiSlotIndArg
  • SetSupportedBandList() : BandStatusMsg, OmBandStatusCnfArg
  • SetSupportedCategories() : BtAvrcpRegisterParams
  • SetSynchronized() : PbSynchronizer
  • SetSynchronizing() : PbSynchronizer
  • SetSyncModeEnabled() : Item
  • SetSyncSoftkeysEnabled() : Window
  • SetSystem() : RamFileObj
  • SetSystemColor() : Theme
  • SetT3310Expiries() : PdpContextManager::AttachStatus
  • SetT3380Expiries() : PdpContext::ActivationStatus
  • SetTabbing() : MultiTapCaret
  • SetTabEnabled() : TabControl
  • SetTaggedProblemCode() : SsRejReqArg, SsRejArg
  • SetTargetDevice() : BtHfProfileWindow, BtAvrcpControllerDeviceListItem, BtObexConnectRequest, BtHsService, BtHfService, BtService, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest
  • SetTargetPath() : BrowserSaveWin
  • SetTcpMaxSetOption() : TcpSocketBase
  • SetTcpNoDelayOption() : TcpSocketBase
  • SetTcStrokeMode() : Zi8Wrapper
  • SetTelematicDevice() : ProtocolIdentifier
  • SetTelematicDeviceText() : SmsSendingConfirmDialog
  • SetTelNumber() : VCard
  • SetTelNumberType() : VCard
  • SetTempo() : AudioReference
  • SetTemporary() : File
  • SetTemporaryLocalTimeZone() : DateTime
  • SetTemporaryProfile() : DataConnProfileInfoMsg
  • SetTermCause() : BrowserTermEventArg
  • SetTerminal() : SerialTerminalSocket, SerialTerminalArg
  • SetTest() : TestparamReqArg
  • SetText : InfoDialog, SmsServiceMsg, TextEditorDocument, TextCompoundItem, PasswordEditor, MultiLineEditor, LineEditor, Item, AnimatedTextLine, Alert, AbstractTextObject, AbstractButton, TextList, TextListModel, RadioButtonItem, IconTextIndicator, TextIndicator, CheckBoxItem, AbstractEditBox, AbstractEditBoxModel, SubstitutedText, FeatureItem, HomezoneMsg, SsUus1ReqArg, SsUus1IndArg, GetInkeyRspArg, GetInputRspArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, HomezoneIndArg, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, T9PinyinBox, StrokeBox, SelectionBox, InputMapper
  • SetTextAlign() : TextFormat, DeviceContext
  • SetTextAlignment() : Locale
  • SetTextAttr() : TextFormat, DeviceContext, RichTextCompoundItem, MultiMediaEditorDocument::TextManager, MultiMediaEditor
  • SetTextColor() : ItemRendererProperties
  • SetTextColumnId() : ProviderProxyContainer
  • SetTextCompression() : DataCodingScheme
  • SetTextFormat() : ItemRendererProperties, DeviceContext, AnimatedTextLine, Alert, AbstractTextObject
  • SetTextFormatting() : EditorItemNode
  • SetTextIconPair() : TextIconPairArray
  • SetTextInfoAlpha() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • SetTextLength() : AbstractEditBoxModel, SimPbEntryCont
  • SetTextList() : SsUus1QueryIndArg
  • SetTextProperty() : Item
  • SetTextString() : SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, SimLaunchBrowserPromptReqArg, SetupIdleModeTextReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • SetThaiMatrixModeWindow() : T9PredictiveInputBox
  • SetTheme() : System
  • SetThemeAction() : SetThemeAction
  • SetThisCallCcm() : CurrentCallMeterMsg, ChargeUnitsIndArg
  • SetThisCallCharge() : CurrentChargeDataMsg, ChargeIndArg
  • SetThousandSeparator() : Locale
  • SetThreadData() : Thread
  • SetThresholdPercentage() : StartSignalStrengthListeningArg
  • SetTid() : SimSetupMenuMsg, SmsSendRejArg, SmsSendCnfArg, SimTkRefreshNewRspArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkRefreshNewReqArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg
  • SetTime() : LocationVerifWin, LcsOptionsMenuWin, LcsMainMenuWin, CalendarRecord, TimeEditorDocument, TimeEditor, TimeCompoundItem, TimeEditBox, DateTime, DataItem, Property
  • SetTimeFeature : AudioDeviceBase
  • SetTimeFormat() : Locale, FunctionalityIndicator
  • SetTimeout() : Timer, SystemTimer, AudioReference
  • SetTimePosition() : SvgPlayer
  • SetTimer() : TimerTimeoutMsg, ExternalTimeoutMsg, SmsConfigIndArg
  • SetTimeStamp() : TimeFeatureObject, MdhSmsTransmitIndArg, MdhSmsRefreshIndArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg
  • SetTimeZone() : TimeZone, CodedTimeStamp, MnInformationIndArg, StatusProvider, DataHandler
  • SetTimeZonePresent() : MnInformationIndArg
  • setting : MdhWaitIndicator
  • SettingIds : OptionalConfigBase
  • SetTipd() : TipdBasedActiveWaitDispatcher, UssdAnswerMsg, SsInfoMsg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityIndArg, SsBeginAccArg, SimTkSsIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, RedialSetupIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, ChargeUnitsReqArg, ChargeReqArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, CallDeflectSsReqArg, CallDeflectionIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, CallIndCallControlInfoArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg
  • SetTitle() : Window, MenuAccessor, VCard, PropertyDescriptor, AtlWindow
  • SetTitleAlpha() : SetupMenuReqArg, SelectItemReqArg
  • SetTitleHeight() : WindowFrameView
  • SetTitleIcon() : SetupMenuReqArg, SelectItemReqArg
  • SetTitleText() : AbstractSmsViewerWin
  • SetTitleTextFormat() : WindowFrameView
  • SetTitleTextType() : MenuProperties
  • SetTone() : AudioReference, PlayToneReqArg
  • SetToneId() : PreparedSound
  • SetToneID() : PresetAudioReference
  • SetToneMode() : Zi8Wrapper
  • SetToneType() : CustomToneAudioReference
  • SetTop() : Rect, WinRect
  • SetTopLineGap() : ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor
  • SetTopSize() : ControlFrameView
  • SetTotalEntries() : AtPbSelectCnfArg
  • SetTpdu() : SmsSendReqArg, MdhSmsTransmitIndArg, MdhSmsNewMessageIndArg, MdhNewStatusReportIndArg
  • SetTpduConc() : MdhSmsReadIndArg
  • SetTpduInformation() : TpduHeaderInformation
  • SetTransactionId() : UriMappingTable
  • SetTransformation() : ImageBrowserDetailWin, CameraSettings, ImageBox, CamWin32, BtBipImageDesc, BtBipImageFormat
  • SetTransmitCause() : MdhSmsTransmitStartIndArg
  • SetTransparent() : Window, ItemRendererProperties, Bitmap
  • SetTransparentColor() : Bitmap
  • SetTranspLayer() : DhChannelOpenReqArg
  • SetTrebleLevel() : MediaPlayer
  • SetTrue() : BooleanCondition, BitField< T >
  • SetTrust() : WapProfile
  • SetTtyMode() : TtyInterface
  • SetTtySpeed() : TtyInterface
  • SetTwilight() : CameraSettings
  • SetTwilightMode() : Camera
  • SetTwilightModeEnabled() : CamWin32
  • SetTwinViewfinderEnabled() : Camera
  • SetType() : ToDoRecord, CalendarRecordsListBoxModel, CalendarRecordsList, CalendarListWin, BtDeviceListWindow, BtRequestRunningWindow, DataConnProfileInfoMsg, DataConnInfoMsg, Provider::Modification, PdpContext::Authentication, SsUus1ReqArg, SsUus1IndArg, SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg, MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType, Accessory, FtpDataSocket, MCServiceInterfaceMsg, MediaManagerMsg, DrmConstraint
  • SetTypeOfNumber() : TypeOfAddress
  • SetUibContextId() : UibFolderWin
  • SetUid() : UsimPbUpdResArg, DrmRightsObject
  • SetUInt() : NumberPrompt
  • SetUnblockchv() : ChvUnblockReqArg
  • SetUniqueId() : PbNumberRecord
  • SetUnit() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • SetUnitId() : GltpAidDataRequests
  • SetUnitInfoParams() : BtAvrcpUnitInfoRequest
  • SetUnitType() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • SetUnknown() : MdhDeletionCmd
  • SetUnread() : MdhDeletionCmd
  • SetUnsent() : MdhDeletionCmd
  • Setup() : DataConn, DataCallHdl, CallHdl, MmCallHdl, MmCallHandler, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp
  • SetupAndRedial() : CallHdl
  • SetupContext() : DataConn
  • SetupDataConn() : SocketData, InetSocket
  • SetupDataConnMsg() : SetupDataConnMsg
  • SetUpdateAction() : UsimLangUpdReqArg, UsimPlmnUpdReqArg
  • SetUpdated() : MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, BootState
  • SetUpdateNumber() : Cbs::SerialNumber
  • SetUpdateOnClose() : AbstractSmsViewerWin
  • SetUpDownPermitted() : AbstractMultiLineEditor
  • SetupDrawingMode() : PngImage
  • SetupEventCnfArg() : SetupEventCnfArg
  • SetupFailedEvent() : DataConn
  • SetupIdleModeTextDone() : SimTkHandler
  • SetupIdleModeTextReqArg() : SetupIdleModeTextReqArg
  • SetupIdleModeTextRspArg() : SetupIdleModeTextRspArg
  • SetupMediaObject() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer
  • SetupMenuDone() : SimTkHandler
  • SetupMenuReqArg() : SetupMenuReqArg
  • SetupMenuRspArg() : SetupMenuRspArg
  • SetUpMsg : RegEncoderDecoder
  • SetupState : XCallInfoResponseParser
  • SetupStateNotValid : XCallInfoResponseParser
  • SetupSucceededEvent() : DataConn
  • SetUri() : RegNodeBuffer, NotificationTableEntry
  • SetUrl() : SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg
  • SetUsage() : ProtocolIdentifier, MessageTypeIndicator
  • SetUsbCharging() : Charger
  • SetUsedBandList() : BandStatusMsg, OmBandStatusCnfArg
  • SetUsedEntries() : AtPbSelectCnfArg
  • SetUseInbandRinging() : BtHfService, BtAudioAccessoryService
  • SetUseMessageInterface() : BtObservableService
  • SetUserDataExists() : ParameterIndicator
  • SetUserDataHeaderExists() : SmsCommand, SmsSubmit
  • SetUserId() : FlsFile
  • SetUserInput() : CallControlUssdIndArg, CallControlSsIndArg, SimTkSsIndArg
  • SetUserInputLanguage() : CallControlUssdIndArg, CallControlSsIndArg, SimTkSsIndArg
  • SetUserLogin() : DhChannelOpenReqArg
  • SetUserPassword() : DhChannelOpenReqArg
  • SetUseStaticFonts() : FontManager
  • SetUsimPbResult() : UsimPbReadyMsg
  • SetUst() : UsimUstReadIndArg
  • SetValid() : PbNumberRecord, PbRecord, SimAlphaIdentifier, ParameterIndicator
  • SetValidityPeriod() : SmsSendingConfirmDialog, SmsContext, SmsSubmit
  • SetValidityPeriodFormat() : SmsSubmit
  • SetValue() : ObexHeaderBuilder, RadioButtonControl, PositionIndicator, Color, CheckBoxControl, AbstractToggleAction, RadioButtonItem, ValueIndicator, BtSddbDeVariableLengthType, BtSddbDeByteBlockType, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, IndexTable< T >, EccCategory
  • SetVerticalCentered() : TextBox, ItemRendererProperties
  • SetVibrationState() : MmiSimServer, MmiSimClient
  • SetVideoClockTime() : EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Decoder, VideoDecoder
  • SetVideoCodec() : RecordSettings
  • SetVideoSize() : VideoChannel
  • SetView() : Component, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg
  • SetViewConfig() : MdhSetConfigReqArg
  • SetViewFinder() : CamWin32
  • SetViewfinderRect() : VideoCamera, Camera
  • SetViewFinderRectToNewFormat() : CameraViewFinderWin
  • SetViewHdl() : MdhRemoveViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSmsUpdStatusReqArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSmsUpdStatusIndArg, MdhRegistrationCnfArg
  • SetViewportSize() : SvgImage
  • SetViewScalingMethod() : Camera
  • SetVisible() : DrawableObject, DefaultCaret, Caret, Indicator
  • SetVisibleValuesCount() : PositionIndicator
  • SetVmic() : MiscAudioDevice
  • SetVoiceBoxNumber() : SmsSettingsRecord
  • SetVoiceMsgWaiting() : SimCphsHandler
  • SetVolume() : SpeechAudioDevice, RingerAudioDevice, Audio, AudioContext, AudioReference, AudioDeviceBase, AudioActiveReference, AudioAccessoryDetails, RamFileObj
  • SetVolume_Implementation() : DwdPlayer
  • SetVolumeLevel() : MediaPlayer
  • SetVolumeSpeech() : Audio
  • SetWaitIndicatorArray() : MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg
  • SetWaitingBoxVisible() : AbstractSmsApp
  • SetWaitingMessage() : DataCodingScheme
  • SetWaitingMessageIndication() : DataCodingScheme
  • SetWapPushReceived() : WapHandler
  • SetWarningLevel() : SmsCapacityExceededArg
  • SetWCharForBcdCode() : PhoneNumber
  • SetWhiteBalance() : CameraSettings, Camera
  • SetWidth() : ImageMetaData, Size, Rect, ImageEncoder::EncodingParameters, Image, Image::MetaData, DeviceContext, Component, Bitmap, WinRect, Grid, SvgPlayer
  • SetWin() : OpenPbWinMsg
  • SetWindow() : CalendarRecordsList, CalendarListWin, OpenWindowAction, CloseWindowAction
  • SetWindowTitle() : ContextDescription
  • SetWord() : Zi8EnteredUnknownWordMsg, T9EnteredUnknownWordMsg
  • SetWorkMedia() : MdhSmsTransmitIndArg, MdhSmsStorageRefreshIndArg
  • SetWrapPolicy() : AbstractMultiLineEditor
  • SetWriteByteCount() : StreamingWriteInfo
  • SetWrittenByteCount() : StreamingWriteInfo
  • SetWrongStatus() : TpduHeaderInformation
  • SetWspVersion() : WapProfile
  • SetWString() : DataItem, Property
  • SetWStringCashPos() : TpduHeaderInformation
  • SetWwwDir() : HttpServerConfig
  • SetX() : Point
  • SetXPos() : Rect, Component
  • SetY() : Point
  • SetYear() : Date
  • SetYPos() : Rect, Component
  • SetZi8EnglishMode() : Zi8Wrapper
  • SetZi8GermanMode() : Zi8Wrapper
  • SetZi8SymbolMode() : Zi8Wrapper
  • SetZoom() : CameraSettings, VideoCamera, Camera
  • SetZoomLevel() : CamWin32, SvgPlayer, SvgImage
  • SevenBitAlphabet : InputMapper
  • Shaded : Color
  • ShadedColor : CTResourcePack
  • ShallExecuteImmediatly() : LanguageResetAction, PinAction, EngModeAction, ImeiShowAction, PbEntryShowAction, InputAction
  • ShallRejectDuplicates() : SmsContext
  • ShallRequestReplyPath() : SmsContext
  • ShallRequestStatusReport() : SmsContext
  • ShallStoreMessage() : InformationElement
  • SharedMemory : Sms
  • SharedPtr() : SharedPtr< T_obj >
  • SharedTimer() : SharedTimer
  • SharedTimerMsg() : SharedTimerMsg
  • SharedTriggerTimer() : SharedTriggerTimer< T >
  • SharingError : File
  • ShiftFunction : T9InputConfig
  • ShiftIndexTableDown() : AbstractDelegationProvider
  • ShiftIndexTableUp() : AbstractDelegationProvider
  • ShiftIndexTableValues() : AbstractDelegationProvider
  • ShiftState : EditBox
  • Short : InternalTracer
  • short_day_name : Date
  • short_month_name : Date
  • ShortDateDM : Date
  • ShortDateDMY : Date
  • ShortDateWDM : Date
  • ShortDateWDMY : Date
  • ShortDayName() : Date
  • ShortMessageFailureCause() : ShortMessageFailureCause
  • ShortMessageFailureExists() : SmsSendDispatcher
  • ShortMessageServices : InputParser
  • ShortMessageStatus() : ShortMessageStatus
  • ShortMessageType0 : ProtocolIdentifier
  • ShortMonthName() : Date
  • ShowArrivedSms() : AbstractSmsApp
  • ShowHint() : MultiTapCaret, Caret
  • ShowParentPosition : OptionalConfigBase
  • ShowSms() : AbstractSmsApp
  • ShowViewfinder() : Camera
  • ShowWaitingBox() : UibApp
  • ShrinkString() : PbManualSynchronizer
  • ShutDown : System, AbstractScheduler, GatiManager, System, Fota, DeviceManager, PowerHandler
  • Shutdown() : SysSocket, SocketRxThread, InetSocket, DnsClient, StorageDevice, SerialSocketThread, DataHandler
  • ShutdownMode : SysSocketBase, InetSocket
  • ShutdownRequestMsg() : ShutdownRequestMsg
  • si13_present : GprsParam
  • SiChannelCloseInfoIndArg() : SiChannelCloseInfoIndArg
  • SiChannelCloseInfoIndMsg() : SiChannelCloseInfoIndMsg
  • SiChannelCloseInfoResArg() : SiChannelCloseInfoResArg
  • SiChannelCloseReqArg() : SiChannelCloseReqArg
  • SiChannelOpenPromptReqArg() : SiChannelOpenPromptReqArg
  • SiChannelOpenPromptReqMsg() : SiChannelOpenPromptReqMsg
  • SiChannelOpenPromptResArg() : SiChannelOpenPromptResArg
  • SiChannelReceiveInfoIndArg() : SiChannelReceiveInfoIndArg
  • SiChannelReceiveInfoIndMsg() : SiChannelReceiveInfoIndMsg
  • SiChannelReceiveInfoResArg() : SiChannelReceiveInfoResArg
  • SiChannelSendInfoIndArg() : SiChannelSendInfoIndArg
  • SiChannelSendInfoIndMsg() : SiChannelSendInfoIndMsg
  • SiChannelSendInfoResArg() : SiChannelSendInfoResArg
  • SigDispatcher() : SigDispatcher
  • SigHandler() : SigHandler
  • SignalHandlerType : ExternalCommunicationHandler
  • SignalMapTable : SignalMapTableNode
  • SignalMapTableNode : SignalMapTableNode, SignalMapTable
  • SignalQualityLevelMsg() : SignalQualityLevelMsg
  • SignalSelect() : SerialIoSet
  • SignalStartStop : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SignalStrengthLevelIndArg() : SignalStrengthLevelIndArg
  • SignalStrengthLevelMsg() : SignalStrengthLevelMsg
  • SignalType : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SilentReset : ShutDown
  • sim : T_PB_LOC_REPORT, SimLockStates
  • Sim : Sms
  • sim_indicator : SimInfo
  • sim_phase : SimInfo
  • sim_type : SimInfo
  • SimAccessor : SimAccessor, DataHandler
  • SimAcmMaxReadIndArg() : SimAcmMaxReadIndArg
  • SimAcmMaxReadReqArg() : SimAcmMaxReadReqArg
  • SimAcmMaxUpdIndArg() : SimAcmMaxUpdIndArg
  • SimAcmMaxUpdReqArg() : SimAcmMaxUpdReqArg
  • SimAcmReadIndArg() : SimAcmReadIndArg
  • SimAcmReadReqArg() : SimAcmReadReqArg
  • SimAcmUpdIndArg() : SimAcmUpdIndArg
  • SimAcmUpdReqArg() : SimAcmUpdReqArg
  • SimAlphaIdentifier() : SimAlphaIdentifier
  • SimApduData() : SimApduData
  • SimAtom() : SimAtom< T >
  • SimAuxHandler() : SimAuxHandler
  • SimBrowserTermResArg() : SimBrowserTermResArg
  • SimBrowserTermResMsg() : SimBrowserTermResMsg
  • SimCallSetupMsg() : SimCallSetupMsg
  • SimCallSetupRejectedMsg() : SimCallSetupRejectedMsg
  • SimCbmiReadIndArg() : SimCbmiReadIndArg
  • SimCbmiReadReqArg() : SimCbmiReadReqArg
  • SimCbmirReadIndArg() : SimCbmirReadIndArg
  • SimCbmirReadReqArg() : SimCbmirReadReqArg
  • SimCbmirUpdIndArg() : SimCbmirUpdIndArg
  • SimCbmirUpdReqArg() : SimCbmirUpdReqArg
  • SimCbmiUpdIndArg() : SimCbmiUpdIndArg
  • SimCbmiUpdReqArg() : SimCbmiUpdReqArg
  • SimCcpReadIndArg() : SimCcpReadIndArg
  • SimCcpReadReqArg() : SimCcpReadReqArg
  • SimCcpUpdIndArg() : SimCcpUpdIndArg
  • SimCcpUpdReqArg() : SimCcpUpdReqArg
  • SimChvHandler() : SimChvHandler
  • SimClutEntry() : SimClutEntry
  • SimCmiReadIndArg() : SimCmiReadIndArg
  • SimCmiReadReqArg() : SimCmiReadReqArg
  • SimCphsHandler() : SimCphsHandler
  • SimDispatcher() : SimDispatcher
  • SimDisplayTextMsg() : SimDisplayTextMsg
  • SimDisplayTextOptions() : SimDisplayTextOptions
  • SimEndTransactionMsg() : SimEndTransactionMsg
  • SimErrorIndArg() : SimErrorIndArg
  • SimErrorMsg() : SimErrorMsg
  • SimExtLangReadIndArg() : SimExtLangReadIndArg
  • SimExtLangReadReqArg() : SimExtLangReadReqArg
  • SimExtLangUpdIndArg() : SimExtLangUpdIndArg
  • SimExtLangUpdReqArg() : SimExtLangUpdReqArg
  • SimFileInfoIndArg() : SimFileInfoIndArg
  • SimFileInfoReqArg() : SimFileInfoReqArg
  • SimFullAccessIndArg() : SimFullAccessIndArg
  • SimGenericIndArg() : SimGenericIndArg
  • SimGenericReqArg() : SimGenericReqArg
  • SimGetInkeyMsg() : SimGetInkeyMsg
  • SimGetInkeyOptions() : SimGetInkeyOptions
  • SimGetInputMsg() : SimGetInputMsg
  • SimGetInputOptions() : SimGetInputOptions
  • SimHandler : SimHandler, SimDispatcher
  • SimIconDescription() : SimIconDescription
  • SimIconIdentifier() : SimIconIdentifier
  • SimIconQualifier() : SimIconQualifier
  • SimImage() : SimImage
  • SimImageDescriptor() : SimImageDescriptor
  • SimIndicator() : EnumTranslationTable
  • SimInfoIndArg() : SimInfoIndArg
  • SimInitIndArg() : SimInitIndArg
  • SimIsFull : Sms
  • SimItemId() : SimItemId
  • SimItemIdentifier() : SimItemIdentifier
  • SimLangReadIndArg() : SimLangReadIndArg
  • SimLangReadReqArg() : SimLangReadReqArg
  • SimLangUpdIndArg() : SimLangUpdIndArg
  • SimLangUpdReqArg() : SimLangUpdReqArg
  • SimLaunchBrowserPromptReqArg() : SimLaunchBrowserPromptReqArg
  • SimLaunchBrowserPromptReqMsg() : SimLaunchBrowserPromptReqMsg
  • SimLaunchBrowserReqArg() : SimLaunchBrowserReqArg
  • SimLaunchBrowserReqMsg() : SimLaunchBrowserReqMsg
  • SimLockStatusIndArg() : SimLockStatusIndArg
  • SimLockStatusMsg() : SimLockStatusMsg
  • SimMccMncIndArg() : SimMccMncIndArg
  • SimMenuItemSelectionFailedMsg() : SimMenuItemSelectionFailedMsg
  • SimMexeCertificate() : SimMexeCertificate
  • SimModifyLockIndArg() : SimModifyLockIndArg
  • SimModifyLockReqArg() : SimModifyLockReqArg
  • SimMruPropertyRefreshIndArg() : SimMruPropertyRefreshIndArg
  • SimMruPropertyUpdCnfArg() : SimMruPropertyUpdCnfArg
  • SimMruPropertyUpdReqArg() : SimMruPropertyUpdReqArg
  • SimNextActionIdentifier() : SimNextActionIdentifier
  • SimNotUsed : Sms
  • SimODyn2ReadIndArg() : SimODyn2ReadIndArg
  • SimODyn2ReadReqArg() : SimODyn2ReadReqArg
  • SimODyn2UpdIndArg() : SimODyn2UpdIndArg
  • SimODyn2UpdReqArg() : SimODyn2UpdReqArg
  • SimODynReadIndArg() : SimODynReadIndArg
  • SimODynReadReqArg() : SimODynReadReqArg
  • SimODynUpdIndArg() : SimODynUpdIndArg
  • SimODynUpdReqArg() : SimODynUpdReqArg
  • SimPbBaseHandler() : SimPbBaseHandler
  • SimPbEntry() : SimPbEntry
  • SimPbEntryCont() : SimPbEntryCont
  • SimPduHandler : SimPduHandler, DataHandler
  • SimPhoneBookEntry() : SimPhoneBookEntry
  • SimPlayToneMsg() : SimPlayToneMsg
  • SimpleAppContext() : SimpleAppContext
  • SimpleAudioDevice() : SimpleAudioDevice
  • SimpleCb : SioSocketAdapter
  • SimpleMap() : SimpleMap< TKey, TValue >
  • SimpleMap< TKey, TValue > : SimpleMap< TKey, TValue >::Iterator, SimpleMapElem< TKey, TValue >
  • SimpleMapElem() : SimpleMapElem< TKey, TValue >
  • SimpleMutex() : SimpleMutex
  • SimpleScheduler() : SimpleScheduler
  • SimpleSemaphore() : SimpleSemaphore
  • SimpleTextRenderer() : SimpleTextRenderer
  • Simplify() : Fraction
  • SimPreferred : Sms
  • SimPuctReadIndArg() : SimPuctReadIndArg
  • SimPuctReadReqArg() : SimPuctReadReqArg
  • SimPuctUpdIndArg() : SimPuctUpdIndArg
  • SimPuctUpdReqArg() : SimPuctUpdReqArg
  • SimRefreshIndArg() : SimRefreshIndArg
  • SimRefreshMsg() : SimRefreshMsg
  • SimRefreshReqArg() : SimRefreshReqArg
  • SimRefreshResetMsg() : SimRefreshResetMsg
  • SimResetConfirmationMsg() : SimResetConfirmationMsg
  • SimResetDoneMsg() : SimResetDoneMsg
  • SimSelectItemMsg() : SimSelectItemMsg
  • SimSelectItemOptions() : SimSelectItemOptions
  • SimServices() : SimServices
  • SimSetupIdleModeTextMsg() : SimSetupIdleModeTextMsg
  • SimSetupIdleModeTextOptions() : SimSetupIdleModeTextOptions
  • SimSetupMenuMsg() : SimSetupMenuMsg
  • SimSetupMenuOptions() : SimSetupMenuOptions
  • SimSmsParameter() : SimSmsParameter
  • SimSmsParamHandler() : SimSmsParamHandler
  • SimSmsrReadIndArg() : SimSmsrReadIndArg
  • SimSmsrReadReqArg() : SimSmsrReadReqArg
  • SimSmsrUpdIndArg() : SimSmsrUpdIndArg
  • SimSmsrUpdReqArg() : SimSmsrUpdReqArg
  • SimSmsSentMsg() : SimSmsSentMsg
  • SimSpnReadIndArg() : SimSpnReadIndArg
  • SimSpnReadReqArg() : SimSpnReadReqArg
  • SimSsSentMsg() : SimSsSentMsg
  • SimSstReadIndArg() : SimSstReadIndArg
  • SimSstReadReqArg() : SimSstReadReqArg
  • SimStateChangedMsg() : SimStateChangedMsg
  • SimStorageGetsFree : Sms
  • SimTextString() : SimTextString
  • SimTkCallSetupAccArg() : SimTkCallSetupAccArg
  • SimTkCallSetupIndArg() : SimTkCallSetupIndArg
  • SimTkCallSetupRejArg() : SimTkCallSetupRejArg
  • SimTkHandler() : SimTkHandler
  • SimTkInterfaceIndArg() : SimTkInterfaceIndArg
  • SimTkLanguageNotificationIndArg() : SimTkLanguageNotificationIndArg
  • SimTkLanguageNotificationMsg() : SimTkLanguageNotificationMsg
  • SimTkMainMenuProvider() : SimTkMainMenuProvider
  • SimTkProfile() : SimTkProfile
  • SimTkProfileFactoryReset() : SimTkHandler
  • SimTkProfileGetCnfMsg() : SimTkProfileGetCnfMsg
  • SimTkProfileSetCnfMsg() : SimTkProfileSetCnfMsg
  • SimTkProfileSetRejMsg() : SimTkProfileSetRejMsg
  • SimTkRefreshCnfIndArg() : SimTkRefreshCnfIndArg
  • SimTkRefreshCnfReqArg() : SimTkRefreshCnfReqArg
  • SimTkRefreshNewReqArg() : SimTkRefreshNewReqArg
  • SimTkRefreshNewRspArg() : SimTkRefreshNewRspArg
  • SimTkRefreshQueryReqArg() : SimTkRefreshQueryReqArg
  • SimTkRefreshQueryResArg() : SimTkRefreshQueryResArg
  • SimTkRefreshReqArg() : SimTkRefreshReqArg
  • SimTkRefreshResetReqArg() : SimTkRefreshResetReqArg
  • SimTkRefreshResetRspArg() : SimTkRefreshResetRspArg
  • SimTkRefreshRspArg() : SimTkRefreshRspArg
  • SimTkRefreshStartMsg() : SimTkRefreshStartMsg
  • SimTkResetCnfArg() : SimTkResetCnfArg
  • SimTkResetCnfIndArg() : SimTkResetCnfIndArg
  • SimTkResetCnfReqArg() : SimTkResetCnfReqArg
  • SimTkRunAtCmdInfoIndArg() : SimTkRunAtCmdInfoIndArg
  • SimTkRunAtCmdInfoIndMsg() : SimTkRunAtCmdInfoIndMsg
  • SimTkRunAtCmdInfoResArg() : SimTkRunAtCmdInfoResArg
  • SimTkSendDtmfCnfArg() : SimTkSendDtmfCnfArg
  • SimTkSendDtmfEndIndArg() : SimTkSendDtmfEndIndArg
  • SimTkSendDtmfEndIndMsg() : SimTkSendDtmfEndIndMsg
  • SimTkSendDtmfIndArg() : SimTkSendDtmfIndArg
  • SimTkSendDtmfIndMsg() : SimTkSendDtmfIndMsg
  • SimTkSetupEventMsg() : SimTkSetupEventMsg
  • SimTkSetupEventReqArg() : SimTkSetupEventReqArg
  • SimTkSmsPpIndArg() : SimTkSmsPpIndArg
  • SimTkSmsPpRspArg() : SimTkSmsPpRspArg
  • SimTkSsIndArg() : SimTkSsIndArg
  • SimTkSsRspArg() : SimTkSsRspArg
  • SimTkStopSendDtmfReqArg() : SimTkStopSendDtmfReqArg
  • SimTkTransactionId() : SimTkTransactionId
  • SimUserDispatcher : SimUserDispatcher, SimAccessor
  • SingleArgHook() : SingleArgHook< T >
  • SingleDataCall : XCallInfoResponseParser
  • SingleFaxCall : XCallInfoResponseParser
  • SingleVoiceCall : XCallInfoResponseParser
  • sio_glue_handler() : ExtPsdContextListener_SioGlueSignalListener, SioGlueSignalListener
  • SioAtBusy : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioAtComplete : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioBufferLow : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioClose : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioDataReq : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioEnoughBuffer : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioError : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioExecMode : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioExecModeKill : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioExecModeStart : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioGlueSignalListener : SioGlueSignalListener, SerialTerminal
  • SioGlueWrapper : SioGlueWrapper::TermIos, SioGlueWrapper::SioCommId
  • SioLast : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioLineDontCare : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioLineOff : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioLineOn : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioOk : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioOpen : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioSigvalLast : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioSocketAdapter::SerialClientSockEventListener : SioSocketAdapter
  • SioSocketAdapter::SerialServerSockEventListener : SioSocketAdapter
  • SioTermIos : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • size : WbxmlVector< T >, tagCustFileData, tagLdbData, tagCPGlyph, tagFont, tagLanguage, tagDataPackHeader, tagCustomizationPack, NvRamBlockInfo, BtObexHeader, RomDataRes, RegIterator::LeafMetaData, FfsFileInfo, ffs_file_info_type
  • Size : IconState, HeapVector::VarPage, HeapVector::BlockPage, Size, CArray< T >, ObexBuffer, File::Attributes
  • Size1_3Mp : CamWin32, Camera
  • Size1Mp : CamWin32, Camera
  • Size2Mp : CamWin32, Camera
  • Size3Mp : CamWin32, Camera
  • Size96x96 : Camera
  • size_central_dir : JarFileStatusInfo, JarBinDataStatusInfo
  • size_comment : JarFileGlobalInfo_s
  • size_file_comment : FileInfo_s
  • size_file_extra : FileInfo_s
  • size_filename : FileInfo_s
  • size_local_extrafield : FileInReadStatusInfo, BinDataInReadStatusInfo
  • SizeFunction : HeapVector
  • SizeNotSetInDocument : SvgPlayer
  • SizeType : GuiObjectFactory, Vector< T >, WbxmlVector< T >
  • Sjis : JapaneseTranscoder
  • SkActionsProp : GuiObjectFactory
  • SkipCurrentTest() : SocketTestApp
  • SkipFrames() : ScicosMpeg4VideoDecoder
  • Skipped : SocketTestT
  • SkipSocketTestMsg() : SkipSocketTestMsg
  • Sleep() : Os
  • Slovak : LanguageManager
  • Slovenian : LanguageManager
  • SmafSound() : SmafSound
  • Small : InformationElement
  • SmallAnimation : InformationElement
  • SmallBuffer : MediaManager, CodecDevice
  • SmallPicture : InformationElement
  • SmallSize : IconState
  • SmartDrawPixel() : PngImage
  • SmartDrawScanline() : PngImage
  • SmartOverlay : VideoChannel
  • SmDeletedByOriginatingSme : ShortMessageStatus
  • SmDeletedByScAdministration : ShortMessageStatus
  • SmDelivered : ShortMessageStatus
  • SmDeliveredButUnableToConfirm : ShortMessageStatus
  • SmDoesNotExist : ShortMessageStatus
  • SmeBusy : ShortMessageStatus
  • SmeToSme : ProtocolIdentifier
  • SmoothScrollInfo() : AbstractGrid::SmoothScrollInfo
  • SmoothScrollSteps : OptionalConfigBase
  • SmRejectedDuplicateSm : ShortMessageFailureCause
  • SmReplaced : ShortMessageStatus
  • Sms : Sms, DataCodingScheme
  • SmsAddToPhonebookErrorType : SmsInfoBox
  • SmsAlert() : SmsAlert
  • SmsAlertType : SmsAlert
  • SmsBasicProvider() : SmsBasicProvider
  • SmsBoxEmpty : SmsAlert
  • SmsCapacityAvailableArg() : SmsCapacityAvailableArg
  • SmsCapacityExceededArg() : SmsCapacityExceededArg
  • SmscControl : InformationElement
  • SmsClass0Provider() : SmsClass0Provider
  • SmsClass0Type : SmsInfoBox
  • SmsCommand() : SmsCommand
  • SmsComposeWin() : SmsComposeWin
  • SmsConfigIndArg() : SmsConfigIndArg
  • SmsContext() : SmsContext
  • SmsControlIndArg() : SmsControlIndArg
  • SmsControlIndMsg() : SmsControlIndMsg
  • SmsCountProvider() : SmsCountProvider
  • SmsDataSource : SimTextString
  • SmsDeleteAllArchive : SmsInfoBox
  • SmsDeleteAllInbox : SmsInfoBox
  • SmsDeleteAllOutbox : SmsInfoBox
  • SmsDeleteAllReports : SmsInfoBox
  • SmsDeleteError : SmsInfoBox
  • SmsDeleteMessage : SmsInfoBox
  • SmsDeliver() : SmsDeliver
  • SmsDispatcher() : SmsDispatcher
  • SmsEditor() : SmsEditor
  • SmsExportType : AbstractSmsApp
  • SmsFactory : SmsFactory, SmsCommand, SmsSubmit
  • SmsFlashPreferred : AbstractSmsApp
  • SmsFolderProvider() : SmsFolderProvider
  • SmsGetMoreMessageStatusIndArg() : SmsGetMoreMessageStatusIndArg
  • SmsGetMoreMessageStatusReqArg() : SmsGetMoreMessageStatusReqArg
  • SmsHandler() : SmsHandler
  • SmsIndicationState() : SmsIndicationState
  • SmsInfoBox() : SmsInfoBox
  • SmsInfoBoxType : SmsInfoBox
  • SmsLoadingFinishedCondition : BootControl
  • SmsMemoryFullType : SmsAlert
  • SmsMessageWaitingChangedMsg() : SmsMessageWaitingChangedMsg
  • SmsMsgWaitingProvider() : SmsMsgWaitingProvider
  • SmsNewMessageIndArg() : SmsNewMessageIndArg
  • SmsNewMessageMsg() : SmsNewMessageMsg
  • SmsNewSocketDataMsg() : SmsNewSocketDataMsg
  • SmsNewStatusReportIndArg() : SmsNewStatusReportIndArg
  • SmsNewStatusReportMsg() : SmsNewStatusReportMsg
  • SmsParamProvider() : SmsParamProvider
  • SmsPendingSmsType : SmsAlert
  • SmsPendingType : SmsInfoBox
  • SmsPortDataRecvMsg() : SmsPortDataRecvMsg
  • SmsPrefStorageMediaChangedMsg() : SmsPrefStorageMediaChangedMsg
  • SmsProvider() : SmsProvider
  • SmsReadProvider() : SmsReadProvider
  • SmsReceivedSmsType : SmsAlert
  • SmsReceivedStatRepType : SmsAlert
  • SmsRejectType : SmsInfoBox
  • SmsResult() : EnumTranslationTable
  • SmsSendCnfArg() : SmsSendCnfArg
  • SmsSendConfirmMsg() : SmsSendConfirmMsg
  • SmsSendDispatcher() : SmsSendDispatcher
  • SmsSendErrorStoreOptionType : SmsInfoBox
  • SmsSendErrorType : SmsInfoBox
  • SmsSendingAnimationType : AbstractSmsApp
  • SmsSendingConfirmDialog() : SmsSendingConfirmDialog
  • SmsSendingType : SmsInfoBox
  • SmsSendRejArg() : SmsSendRejArg
  • SmsSendRejectMsg() : SmsSendRejectMsg
  • SmsSendReqArg() : SmsSendReqArg
  • SmsSendType : SmsInfoBox
  • SmsSentOkType : SmsAlert
  • SmsSentProvider() : SmsSentProvider
  • SmsServiceDocumentMsg() : SmsServiceDocumentMsg
  • SmsServiceMsg() : SmsServiceMsg
  • SmsServiceType : AbstractSmsApp
  • SmsSetMoreMessageReqArg() : SmsSetMoreMessageReqArg
  • SmsSettingsProvider() : SmsSettingsProvider
  • SmsSettingsRecord() : SmsSettingsRecord
  • SmsSetupCallErrorType : SmsInfoBox
  • SmsSetupResponse() : SimTkHandler
  • SmsSimFullType : SmsAlert
  • SmsSimPreferred : AbstractSmsApp
  • SmsSocket : SmsSocket, SmsSocketListener
  • SmsSocketListener : SmsSocket
  • SmsSocketSignalMapTableNode : SmsSocketListener
  • SmsSpaceAvailableMsg() : SmsSpaceAvailableMsg
  • SmsSpaceExceededMsg() : SmsSpaceExceededMsg
  • SmsStatusReport() : SmsStatusReport
  • SmsStorageType() : AbstractSmsApp, EnumTranslationTable
  • SmsStoredOkType : SmsAlert
  • SmsStoreErrorType : SmsInfoBox
  • SmsStoreType : SmsInfoBox
  • SmsSubmit() : SmsSubmit
  • SmsTemplateProvider() : SmsTemplateProvider
  • SmsToMdhWorkMediaTranslation() : SimAccessor
  • smstype : MdhWaitIndicator
  • SmsUnreadProvider() : SmsUnreadProvider
  • SmsUnsentProvider() : SmsUnsentProvider
  • SmsUtility() : SmsUtility
  • SmsValidtyPeriodType : AbstractSmsApp
  • SmsViewerWin() : SmsViewerWin
  • SmsWarningLevel() : EnumTranslationTable
  • SmsWStringCache() : SmsWStringCache
  • SmType0NotSupported : ShortMessageFailureCause
  • SmValidityPeriodExpired : ShortMessageStatus
  • sne : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • sne_ref : T_PB_REF_RECORD
  • SnrAllocation : AudioEncoder
  • Socket : Socket, InternalTracer
  • SocketAddr() : SocketAddr
  • SocketControlMsg() : SocketControlMsg
  • SocketDataLock : SocketDataLock, SocketSubSystem
  • SocketEventListener() : SocketEventListener
  • SocketFamily : SerialIoAdapter
  • SocketHandler : SocketHandler, Socket, InetSocket
  • SocketHdl : SysSocket
  • SocketId : SioSocketAdapter
  • SocketPeer() : SocketPeer
  • SocketRxThread : SocketRxThread, SysSocket, SocketSubSystem, DataConnManager
  • SocketSerialTerminalListener() : SocketSerialTerminalListener
  • SocketSubSystem : SocketSubSystem, SocketData
  • SocketTestMessage() : SocketTestMessage
  • SocketTestProgressWin() : SocketTestProgressWin
  • SocketTestResultsWin() : SocketTestResultsWin
  • SocketTestSettingsWin() : SocketTestSettingsWin
  • SocketTestT() : SocketTestT
  • SocketTestT1() : SocketTestT1
  • SocketTestT2() : SocketTestT2
  • SocketTestT3() : SocketTestT3
  • SocketTestT4() : SocketTestT4
  • SocketTestT5() : SocketTestT5
  • SocketTestT6() : SocketTestT6
  • SocketTestT7() : SocketTestT7
  • SocketTestT8() : SocketTestT8
  • SocketTestWin() : SocketTestWin
  • SoftHorizontalAnimation : ItemRendererProperties
  • softkey_descriptions : ContextTableEntry
  • SOFTKEY_PRESSED_MSG : TestWriter
  • SOFTKEY_SHOW_MSG : TestWriter
  • SoftkeyBar() : SoftkeyBar
  • SoftkeyBarBackgroundBitmap : CTResourcePack
  • SoftkeyBarBackgroundBitmapUri : CTResourcePack
  • SoftkeyBarButton1Bitmap : CTResourcePack
  • SoftkeyBarButton1BitmapUri : CTResourcePack
  • SoftkeyBarButton2Bitmap : CTResourcePack
  • SoftkeyBarButton2BitmapUri : CTResourcePack
  • SoftkeyBarButtonsControl : CTResourcePack
  • SoftkeyBarButtonSpacing : CTResourcePack
  • SoftkeyBarControl : CTResourcePack
  • SoftkeyBarHeight : CTResourcePack
  • SoftkeyBarNavGuideActiveColor : CTResourcePack
  • SoftkeyBarNavGuideEnabled : CTResourcePack
  • SoftkeyBarNavGuideInactiveColor : CTResourcePack
  • SoftkeyBarView() : SoftkeyBarView
  • SoftkeyDesc() : SoftkeyDesc
  • Softkeys : Font
  • SoftVerticalAnimation : ItemRendererProperties
  • Solid : Pen, Brush
  • sort : MdhViewConfig
  • SortCompare() : ChineseQuickSortProvider
  • SortedElementList() : SortedElementList< T >
  • SortMode : ChineseQuickSortProvider
  • SortProvider() : SortProvider
  • Sound() : Sound
  • SoundBrowserApp : MediaRefContainer
  • SoundBrowserServiceMsg() : SoundBrowserServiceMsg
  • SoundBrowserTestWin() : SoundBrowserTestWin
  • SoundBrowserWin() : SoundBrowserWin
  • SoundDataSource : AudioReference
  • SoundFileFilter() : SoundFileFilter
  • SoundFilter() : SoundFilter
  • SoundItem() : SoundItem
  • SoundMetaData() : SoundMetaData
  • SoundObtainer() : SoundObtainer
  • SoundRef() : SoundRef
  • SoundRefContainer() : SoundRefContainer
  • source : AudioPlayerStore::DataFormatDataSource
  • SourceType : AudioDeviceManager
  • sp : SimLockStates
  • SpaceFunction : T9InputConfig
  • Spanish : LanguageManager, DataCodingScheme
  • SpeakerGain : BtHsVolumeSettingsWin, BtHfVolumeSettingsWin
  • SpecialSms : InformationElement
  • speech : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • Speech : XCallInfoResponseParser
  • SpeechAudioDevice() : SpeechAudioDevice
  • SpeechDeviceID : AudioDeviceManager
  • SpeechVolume : SpeechAudioDevice, Audio
  • SpeechVolume1 : SpeechAudioDevice, Audio
  • SpeechVolume2 : SpeechAudioDevice, Audio
  • SpeechVolume3 : SpeechAudioDevice, Audio
  • SpeechVolume4 : SpeechAudioDevice, Audio
  • SpeechVolume5 : SpeechAudioDevice, Audio
  • SpeechVolume6 : SpeechAudioDevice, Audio
  • SpeechVolume7 : SpeechAudioDevice, Audio
  • SpeechVolume8 : SpeechAudioDevice, Audio
  • Split() : TextCompoundItem, CompoundItem, MptyCallHdl, File, RichTextCompoundItem, ParagraphCompoundItem, GeneralCompoundItem, RootFileImp
  • split_pg_cycle : GprsParam
  • SplitMpty() : CrssHandler
  • SqcifSize : CamWin32, Camera
  • ss_code : SsData, NotifySsArg
  • ss_notification : NotifySsArg
  • ss_status : InterrogateCcbsResult, SsData, InterrogateSsResult, CliRestrictionInfo, CallBarringFeature, ForwardingFeature, NotifySsArg
  • SsBarringIndArg() : SsBarringIndArg
  • SsBaseHandlerReturnCode() : EnumTranslationTable
  • SsBeginAccArg() : SsBeginAccArg
  • SsCallBarringActionImpl() : SsCallBarringActionImpl
  • SsCallForwardingActionImpl() : SsCallForwardingActionImpl
  • SsCallWaitingActionImpl() : SsCallWaitingActionImpl
  • SsCauseIndArg() : SsCauseIndArg
  • SsCcbsDispatcher() : SsCcbsDispatcher
  • SsCcbsHandler() : SsCcbsHandler
  • SsCcbsInvokeArg() : SsCcbsInvokeArg
  • SsCcbsReCallIndArg() : SsCcbsReCallIndArg
  • SsCcbsReCallRequestArg() : SsCcbsReCallRequestArg
  • SsCcbsRejectArg() : SsCcbsRejectArg
  • SsCcbsResultIndArg() : SsCcbsResultIndArg
  • SsCcbsStatusIndArg() : SsCcbsStatusIndArg
  • SsClientRejArg() : SsClientRejArg
  • SsClipActionImpl() : SsClipActionImpl
  • SsClirActionImpl() : SsClirActionImpl
  • SsCnapActionImpl() : SsCnapActionImpl
  • SsCode : InputParser
  • SsColpActionImpl() : SsColpActionImpl
  • SsColrActionImpl() : SsColrActionImpl
  • SsControlIndMsg() : SsControlIndMsg
  • SsDataIndArg() : SsDataIndArg
  • SsDataReceivedMsg() : SsDataReceivedMsg
  • SsDispatcher() : SsDispatcher
  • SsEmlppActionImpl() : SsEmlppActionImpl
  • SsEndIndArg() : SsEndIndArg
  • SsEndMsg() : SsEndMsg
  • SsErrIndArg() : SsErrIndArg
  • SsErrIndicationMsg() : SsErrIndicationMsg
  • SsErrorCode() : SsErrorCode, EnumTranslationTable
  • SsErrorMsg() : SsErrorMsg
  • SsErrorStatus : SsErrorCode
  • SsErrReqArg() : SsErrReqArg
  • SsFacilityIndArg() : SsFacilityIndArg
  • SsFacilityRejArg() : SsFacilityRejArg
  • SsFacilityRejectedMsg() : SsFacilityRejectedMsg
  • SsForwardingIndArg() : SsForwardingIndArg
  • SsForwcheckIndArg() : SsForwcheckIndArg
  • SsGetPasswordIndArg() : SsGetPasswordIndArg
  • SsGetPasswordRejArg() : SsGetPasswordRejArg
  • SsGetPasswordRspArg() : SsGetPasswordRspArg
  • SsHandler() : SsHandler
  • SsIncompatibility : SsErrorCode
  • SsInfoMsg() : SsInfoMsg
  • SsInterrogateIndArg() : SsInterrogateIndArg
  • SsMessage() : SsMessage
  • SsNotAvailable : SsErrorCode
  • SsNotification() : SsNotification
  • SsNotificationMsg() : SsNotificationMsg
  • SsNotifyIndArg() : SsNotifyIndArg
  • SsOperationCode() : EnumTranslationTable
  • SsPasswordChangeActionImpl() : SsPasswordChangeActionImpl
  • SsPasswordIndArg() : SsPasswordIndArg
  • SsProcedure : InputParser
  • SsRejArg() : SsRejArg
  • SsRejectedMsg() : SsRejectedMsg
  • SsRejReqArg() : SsRejReqArg
  • SsRequestAcceptedMsg() : SsRequestAcceptedMsg
  • SsRequestRejectedMsg() : SsRequestRejectedMsg
  • SsRequestSentMsg() : SsRequestSentMsg
  • SsRetResIndArg() : SsRetResIndArg
  • SsSendEndReqArg() : SsSendEndReqArg
  • SsSendReqArg() : SsSendReqArg
  • SsSetupResponse() : SimTkHandler
  • SsStackMsgArgument : StackMsgArgument
  • SsStatus() : SsStatus
  • SsSubscriptionViolation : SsErrorCode
  • SsSuccessMsg() : SsSuccessMsg
  • SstProvider() : SstProvider
  • SsUnstructIndArg() : SsUnstructIndArg
  • SsUssdActionImpl() : SsUssdActionImpl
  • SsUssdIndArg() : SsUssdIndArg
  • SsUssdReqArg() : SsUssdReqArg
  • SsUssdResentIndArg() : SsUssdResentIndArg
  • SsUus1IndArg() : SsUus1IndArg
  • SsUus1QueryIndArg() : SsUus1QueryIndArg
  • SsUus1QueryRejArg() : SsUus1QueryRejArg
  • SsUus1QueryReqArg() : SsUus1QueryReqArg
  • SsUus1ReqArg() : SsUus1ReqArg
  • SsWaitDispatcher() : SsWaitDispatcher
  • st_accesstime : HostFileStatType
  • st_active : DataConn
  • st_atime : RamFileInfo, FatFileInfo, fs_stat
  • st_blksize : RamFileInfo, FatFileInfo, fs_stat
  • st_blocks : RamFileInfo, FatFileInfo, fs_stat
  • st_check_cancel : DataConn
  • st_creationtime : HostFileStatType
  • st_ctime : RamFileInfo, FatFileInfo, fs_stat
  • st_deactivate : DataConn
  • st_dev : FatFileInfo, fs_stat
  • st_deviceId : HostFileStatType
  • st_idle_timeout : DataConn
  • st_ignore_setup_req : DataConn
  • st_in_hold : DataConn
  • st_in_release : DataConn
  • st_in_setup : DataConn
  • st_in_trigger_release : DataConn
  • st_inactive : DataConn
  • st_ino : FatFileInfo, fs_stat
  • st_inode : HostFileStatType
  • st_max_states : DataConn
  • st_mode : HostFileStatType, FatFileInfo, fs_stat
  • st_modificationtime : HostFileStatType
  • st_mtime : RamFileInfo, FatFileInfo, fs_stat
  • st_nlink : HostFileStatType, FatFileInfo, fs_stat
  • st_rdev : HostFileStatType, FatFileInfo, fs_stat
  • st_reactivate : DataConn
  • st_released : DataConn
  • st_set_on_cancel : DataConn
  • st_set_on_wait_for_setup : DataConn
  • st_setup_failure : DataConn
  • st_setup_success : DataConn
  • st_size : HostFileStatType, RamFileInfo, FatFileInfo, fs_stat
  • st_start_release : DataConn
  • st_start_setup : DataConn
  • stack : ServiceThreadStarter::StartParam
  • STACK_TRACE_DEPTH : InternalTracer
  • StackAlloc() : Os
  • StackControl() : StackControl
  • StackFree() : Os
  • StackMsgActiveWaitDispatcher() : StackMsgActiveWaitDispatcher
  • StackMsgArgDestroyTableNode : StackMsgArgDestroyTableNode, StackMsgArgument
  • StackMsgArgMapContainer() : StackMsgArgMapContainer< T >
  • StackMsgArgument : StackMsgArgument, NoStackMsgArg, StackMsgArgDestroyTableNode
  • StackMsgDispatcher() : StackMsgDispatcher
  • StackMsgMapTable : StackMsgMapTableNode
  • StackMsgMapTableNode : StackMsgMapTableNode, StackMsgMapTable
  • stacksize : ServiceThreadStarter::StartParam, StartUp::Table
  • StackSsRejectedMsg() : StackSsRejectedMsg
  • StackTrace() : _FunctionTracer< mask >, _NullFunctionTracer
  • StandardJoinRule() : StandardJoinRule
  • StandardTime : TimeZone
  • StandbyMode : StreamAudioReference
  • Start : Timer, SystemTimer, ImageBox, AnimatedTextLine, VoiceMemoAudioDevice, VideoChannel, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice, GenericAudioDevice, AmplifierAudioDevice, StartUp, VideoChannel, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, VideoChannel, AtiMpeg4Encoder, AtiMpeg4Decoder, VideoChannel, SharedTimer, Animation, RtStreamingConn, SigHandler, CbsHandler, Server, HttpServer, FtpTransfer, FtpServer, FtpOutTransfer, FtpInTransfer, LcsTimer, LcsRepeatTimer, VideoEncoder, VideoDecoder, FlowLayout, IndicatorLocation
  • start_frame : Mp3Param
  • StartAction() : AtiAudioPlayerRtStreamingSink, RtStreamingSource, RtStreamingSink, DataSourceRtStreamingSource
  • StartAddrResolution() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • StartAirplaneMode() : PowerHandler
  • StartAnimationProp : GuiObjectFactory
  • StartBatteryLoadListening() : Charger
  • StartCDATAHandler() : XMLParser
  • StartDelayProp : GuiObjectFactory
  • startDocument() : WbxmlParserRel
  • StartDocument() : XMLParser
  • StartDtmfCnfArg() : StartDtmfCnfArg
  • StartDtmfRejArg() : StartDtmfRejArg
  • StartDtmfReqArg() : StartDtmfReqArg
  • StartDtmfToneGeneration() : MptyCallHdl, CallHdlBase, CallHdl, CallHandler
  • Started : SocketTestT, PhonebookApp
  • startElement() : WbxmlParserRel
  • StartElement() : XMLParser
  • StartIteration() : CompoundSmsItem
  • StartLoading() : BootControl
  • StartMobileNetwork() : PowerHandler
  • StartOperation() : ObexClientOppImpl, ObexAbstractPort
  • StartParam() : ToneAudioDevice::StartParam, RingerAudioDevice::StartParam, KeyToneAudioDevice::StartParam
  • StartPreview() : MediaRecorder
  • StartRecognition() : VrHandler
  • StartRecord() : MediaRecorder
  • StartRecording() : VoiceMemoApp, AudioDeviceManager, VrHandler
  • StartResolveAction() : ObexAbstractPort
  • StartSelection() : ObexMngr, AbstractEditor
  • StartSignalStrengthListeningArg() : StartSignalStrengthListeningArg
  • StartSilentReset() : PowerHandler
  • StartSocketTestMsg() : StartSocketTestMsg
  • StartStop() : ImageBrowserDetailWin
  • StartsWith() : WString, String
  • startswith() : Uri
  • StartSymbol() : ObexUrlStrParser
  • StartTests() : SocketTestApp
  • StartTextFormatting() : EmsEditor
  • StartTextScrolling() : DefaultItemRenderer, AbstractItemRenderer, AtlItemRenderer
  • StartTimeoutTimer() : SocketTestApp
  • StartTone() : Audio
  • StartTraining() : VrHandler
  • StartTransaction() : DBService
  • StartUp : SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, AbstractScheduler, AbstractAppContext, GatiManager, System, ServiceThread, MessageRouter, DeviceManager
  • Startup() : SmsSocketListener, MainHandler, VrHandler, DataHandler
  • StartUp::Restart : Application
  • StartVibrator() : VibratorDevice, Audio, AudioVibratorDevice
  • StartVideoCapture() : CamWin32, VideoCamera
  • StartViewfinder() : VideoCamera, Camera
  • StartViewFinder() : CamWin32
  • StartWaitingAnimation() : PhonebookApp
  • state : CallInfoArg, RrParam, MmCoordParam, GmmParam, MmcsParam
  • State : Control::NavigationGuidance, PdpContextManager::AttachStatus, PdpContextManager, PdpContext::ActivationStatus, PdpContext, KeyMsgGenerator::Key, FtpClient, MediaPlayer
  • StateAccepted : PdpContextManager::AttachStatus, PdpContext::ActivationStatus
  • StateFiveTimeT3310Expiry : PdpContextManager::AttachStatus
  • StateFiveTimeT3380Expiry : PdpContext::ActivationStatus
  • StateMachine() : StateMachine
  • StateRejected : PdpContextManager::AttachStatus, PdpContext::ActivationStatus
  • StateUnknownCause : PdpContextManager::AttachStatus, PdpContext::ActivationStatus
  • StateUserInteruption : PdpContextManager::AttachStatus, PdpContext::ActivationStatus
  • StaticFileError : File
  • StaticFrame : Control
  • statrep_ascending_order : SmsSettingsRecord::Persist
  • statrep_on_idlescreen : SmsSettingsRecord::Persist
  • statrep_sorting_colid : SmsSettingsRecord::Persist
  • Status : SocketTestT, Provider, Tpdu, ShortMessageStatus
  • status : ChvData, MdhResult
  • status_report : SmsSettingsRecord::Persist
  • StatusDisabled : AudioDeviceBase
  • StatusDispatcher() : StatusDispatcher
  • StatusEnabled : AudioDeviceBase
  • StatusProvider() : StatusProvider
  • StatusReport : SmsSettingsRecord, MessageTypeIndicator
  • StepProp : GuiObjectFactory
  • Stereo : CodecDevice
  • StereoChannelMode : AudioEncoder
  • StereoHeadSet : Accessory
  • StereoMode : RadioAudioDevice
  • StillCamera() : StillCamera
  • StillCameraCategory : AbstractDevice
  • StOnCommand : RtStreamingConn
  • StOnEndOfData : RtStreamingConn
  • StOnSnkError : RtStreamingConn
  • StOnSrcError : RtStreamingConn
  • Stop() : Timer, ServiceThread, SystemTimer, DbgTimingMeasurement, AbstractAppContext, ImageBox, AnimatedTextLine, VoiceMemoAudioDevice, VideoChannel, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice, GenericAudioDevice, AmplifierAudioDevice, VideoChannel, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, VideoChannel, AtiMpeg4Encoder, AtiMpeg4Decoder, VideoChannel, SharedTimer, RtStreamingConn, MP3AudioPlayer, MmfPlayer, AudioActiveReference, SigHandler, CbsHandler, MapiAudioPlayer, SvgPlayer, Server, HttpServer, FtpServer, MediaPlayer, VideoEncoder, VideoDecoder
  • StopAction() : AtiAudioPlayerRtStreamingSink, RtStreamingSource, RtStreamingSink, RtStreamingConn, DataSourceRtStreamingSource
  • StopAllSounds() : AudioDeviceManager
  • StopApiCompletionMsg : MediaManager
  • StopBatteryLoadListening() : Charger
  • StopBatteryLoadListeningArg() : StopBatteryLoadListeningArg
  • StopCallbackHaveBeenSet() : MapiAudioPlayer
  • StopCause : RtStreamingConn, AudioDeviceBase
  • StopDecoding() : Image
  • StopDtmfCnfArg() : StopDtmfCnfArg
  • StopDtmfReqArg() : StopDtmfReqArg
  • StopDtmfSending() : SimTkHandler
  • StopDtmfToneGeneration() : MptyCallHdl, CallHdlBase, CallHdl, CallHandler
  • StopEncoding() : ImageEncoder
  • StopMobileNetwork() : PowerHandler
  • StopNotifications() : SocketRxThread, SerialSocketThread
  • StopOnCause() : AtiAudioPlayerRtStreamingSink, RtStreamingSink
  • StopPreview() : MediaRecorder
  • StopRecognition() : VrHandler
  • StopRecord() : VoiceMemoWin, VoiceMemoRecordWin, StreamAudioPlayer, MediaRecorder
  • StopRecording() : VoiceMemoApp, AudioDeviceManager
  • StopRingRequest() : BtHsService
  • StopSelection() : AbstractEditor
  • StopSignalStrengthListeningArg() : StopSignalStrengthListeningArg
  • StopSocketTestMsg() : StopSocketTestMsg
  • StopSound() : SoundBrowserWin, AudioContext
  • StopSuspend_Implementation() : StreamAudioPlayer
  • StopSuspended() : MP3AudioPlayer, MmfPlayer
  • StopTests() : SocketTestApp
  • StopTextScrolling() : DefaultItemRenderer, AbstractItemRenderer, AtlItemRenderer
  • StopTimeoutTimer() : SocketTestApp
  • StopTone() : Audio
  • StopVibrator() : VibratorDevice, Audio, AudioVibratorDevice
  • StopVideoCapture() : CamWin32, VideoCamera
  • StopViewfinder() : VideoCamera, Camera
  • StopViewFinder() : CamWin32
  • StopWaitingAnimation() : PhonebookApp
  • storage : MdhViewConfig
  • storage_location : SmsSettingsRecord::Persist
  • StorageAppCatFlag : CodecDevice
  • StorageDevice : StorageDevice, RootFileSystem
  • StorageDeviceFilter() : StorageDeviceFilter
  • StorageDeviceIterator : StorageDeviceIterator, RootFileSystem
  • StorageDeviceVisitor() : StorageDeviceVisitor
  • StorageIsAttached() : DataConnProfileManager
  • StorageType : Sms
  • Store() : NvRamStorage, SmsFactory
  • StoreAppointment() : CalendarAddRecordWin
  • StoreConfigValues() : GltpProviderImpl
  • StoreData() : LcsSettingsUtils, LcsAppUtils
  • StoreEmailInPhonebook() : AbstractSmsApp
  • StoreImpl() : AbstractSmsUtilityProcessor, EmsApp
  • StoreInPhonebook() : AbstractSmsApp
  • StoreMolr() : LcsReqProcessor
  • StoreMtlr() : LcsReqProcessor
  • StoreRecord() : NvRamDataRecordHandler, RecordHandler, DataRecordHandler
  • StoreSentSms() : AbstractSmsApp
  • StoreSms() : BasicSmsService, AbstractSmsApp, SmsHandler
  • StoreSmsTransmit() : SimPduHandler
  • StoreSmsType : AbstractSmsApp
  • StoreTpdu() : SimPduHandler, DataHandler
  • strbuf : XMLParser
  • StrCopy() : WString, String
  • stream : FileInReadStatusInfo, BinDataInReadStatusInfo
  • Stream() : Stream
  • stream_field : Led::Stream
  • stream_initialised : FileInReadStatusInfo, BinDataInReadStatusInfo
  • StreamAudioPlayer : StreamAudioPlayer, StreamAudioReference
  • StreamAudioReference() : StreamAudioReference
  • StreamBegin : Stream
  • StreamCanBeRead : Stream
  • StreamCanBeReadWritten : Stream
  • StreamCanBeWritten : Stream
  • StreamCurrent : Stream
  • StreamEnd : Stream
  • StreamError : Led
  • StreamFinished : Led
  • StreamingAppCatFlag : CodecDevice
  • StreamingCallback : StreamingCallback, File
  • StreamingDriverReadCallback() : FlsFile, FatFile
  • StreamingDriverWriteCallback() : FlsFile, FatFile
  • StreamingError : File
  • StreamingInfo() : StreamingInfo
  • StreamingReadInfo() : StreamingReadInfo
  • StreamingWriteInfo() : StreamingWriteInfo
  • StreamObexImpl() : StreamObexImpl
  • StreamObexTransport() : StreamObexTransport
  • StreamReader() : StreamReader
  • StreamSoundDataSource : AudioReference
  • StreamStopped : Led
  • StreamWriter() : StreamWriter
  • StretchUnit : Layouter, GridLayout
  • StretchXGrid() : Layouter
  • StretchYGrid() : Layouter
  • StrictWhitespaceWrap : EditorDocument
  • Strikethrough : TextFormat
  • String : String, InternalTracer, WString
  • string_count : tagLanguage
  • StringDataSink() : StringDataSink
  • StringNodeType : RegIterator
  • StringType : GuiObjectFactory
  • StripRelXml() : DrmMessage
  • stroke : ChineseQuickSortProvider
  • StrokeBox() : StrokeBox
  • StrokeBoxId : AbstractPredictiveInputBox
  • StrokeBoxView() : StrokeBoxView
  • style : IMelodyData
  • subaddress : CcbsEntry, Rdn
  • SubComponentPropertyType : CTResourcePack
  • SubFree() : HeapVector::VarPage
  • SubMenu : PbAbstractWin
  • SubMenuAction() : SubMenuAction
  • Submit : MessageTypeIndicator
  • SubmitReport : MessageTypeIndicator
  • SubmitResponse() : ObexFtpDataServer
  • Subscribe() : StackControl, SmsSocketListener
  • SubscribeAudioMessageCallback() : AudioDeviceManager
  • SubscriberNumber : TypeOfAddress
  • SubstitutedText() : SubstitutedText
  • Substring() : WString, String
  • SubSystem : SubSystem, SubSystemManager
  • SubSystemManager : SubSystem
  • SubTimeSpan() : DateTime
  • SubunitInfoRequest() : BtAvrcpOperationService
  • SubUnitReference() : SubUnitReference
  • Succeded() : CbsStopDispatcher, CbsStartDispatcher
  • Success : ObexResult, BtObexResponseCode, MediaManager, CodecDevice
  • SUCCESS : StreamObexImpl
  • sum_c_over_i : CiTestParam
  • Sunday : Date
  • Sunken : CTResourcePack
  • SunkenBorder : CTResourcePack
  • SunlightBalance : Camera
  • SupportsStyle() : FontManager, FontEntry
  • SupportsTextAttr() : RomFont, FontEntry, Font
  • SupportsUnicodeRange() : FontManager, FontEntry
  • suppress_oa : CugDescriptor
  • Surjective : JoinRule
  • SurpressPhoneNumber : MoCallAction
  • Suspend() : Thread, MP3AudioPlayer, MmfPlayer, AudioActiveReference
  • SuspendAllPlayingSounds() : AudioDeviceManager
  • SuspendHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • SuspendSlotType : DwdPlayer
  • SuspendWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • SvgActivateEvent : SvgPlayer
  • SvgaSize : CamWin32, Camera
  • SvgClickEvent : SvgPlayer
  • SvgDecodingFinishedMsg() : SvgDecodingFinishedMsg
  • SvgErrorType : SvgPlayer
  • SvgEventType : SvgPlayer
  • SvgFileWrapper() : SvgFileWrapper
  • SvgFocusInEvent : SvgPlayer
  • SvgFocusOutEvent : SvgPlayer
  • SvgGzFileWrapper() : SvgGzFileWrapper
  • SvgHideHyperlinksEvent : SvgPlayer
  • SvgHyperlinkSelectMsg() : SvgHyperlinkSelectMsg
  • SvgImage() : SvgImage
  • SvgImageFileWrapper() : SvgImageFileWrapper
  • SvgPlayer() : SvgPlayer
  • SvgPlayerView : SvgPlayer
  • SvgSelectNextHyperlinkEvent : SvgPlayer
  • SvgSelectPreviousHyperlinkEvent : SvgPlayer
  • SvgShowHyperlinksEvent : SvgPlayer
  • SvgStatusEventHandled : SvgPlayer
  • SvgStatusMsg() : SvgStatusMsg
  • SvgThreadlet : SvgPlayer
  • SvgUiActivateEvent : SvgPlayer
  • SvgUndefinedEvent : SvgPlayer
  • Swahili : LanguageManager
  • SwallowKey() : KeyManager
  • Swap() : WString, String, ByteBuffer, CallHdlBase
  • SwapCalls() : CrssHandler
  • SwapValues() : IndexTable< T >
  • Swedish : LanguageManager, DataCodingScheme
  • Switch() : BackLight
  • SwitchBuffer() : RtStreamingSink
  • SwitchDisplaySimPos() : PhonebookApp
  • SwitchedRleCompression : SwitchedRleCompression::Context
  • SwitchItemContainer() : AbstractItemGrid
  • SwitchOff() : FmRadioWindow
  • SwitchReadStatus() : AbstractSmsViewerWin, AbstractSmsApp
  • SwitchToEditboxMenu() : PbDetails
  • SxgaSize : Camera
  • SymbolEntryRequestFunction : T9InputConfig
  • sync_supported : T_PB_DESCRIPTOR
  • Synchronize() : PhonebookApp, PbSynchronizer
  • SynchronizeBuffers() : DefaultDisplay
  • SynchronizeBuffers_ApoxiToT9() : T9InputMapper
  • SynchronizeBuffers_T9ToApoxi() : T9InputMapper
  • Synchronous : MessageHook
  • SyncModeEnabledProp : GuiObjectFactory
  • SyncPaintDc() : SyncPaintDc
  • SyncPhone() : PbSynchronizer, PbManualSynchronizer, PbLazySynchronizer, AdvPbApp
  • SyncPhoneAll() : PbSynchronizer, AdvPbApp
  • SyncPhoneOne() : PbSynchronizer
  • SyncPhoneThreadlet() : SyncPhoneThreadlet
  • SyncProgressMsg() : SyncProgressMsg
  • SyncSim() : PbSynchronizer, PbManualSynchronizer, PbLazySynchronizer, AdvPbApp
  • SyncSimAll() : PbSynchronizer, AdvPbApp
  • SyncSimOne() : PbSynchronizer
  • SyncSucceeded() : SyncPhoneThreadlet
  • SyntaxErrorInUrl : ObexResult
  • SysDnsClient : SysDnsClient, DnsClient
  • SysSocket : SysSocket, SocketSubSystem, Ticks
  • System : FocusObtainer, AppContainer
  • SystemColorId : Color
  • SystemColorIdCount : Color
  • SystemColorTable : CTResourcePack
  • SystemFailure : SsErrorCode
  • SystemFontId : Font
  • SystemFontIdCount : Font
  • SystemTimer() : SystemTimer
  • SystemTimerInternals : SystemTimer
Generated on Wed Jan 25 00:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • t3192 : GprsParam
  • t3212 : CellParam
  • T9 : PredInputMapper, InputMapper
  • t9_language : T9InputMapper
  • t9_pack : tagT9Pack
  • T9AddWordMsg() : T9AddWordMsg
  • T9EnteredUnknownWordMsg() : T9EnteredUnknownWordMsg
  • T9FunctionCode : T9InputConfig
  • T9InputMapper() : T9InputMapper
  • T9MatrixModeKeypressed() : T9MatrixModeKeypressed
  • T9NoWordFoundMsg() : T9NoWordFoundMsg
  • T9Pack() : T9Pack
  • T9PinyinBox() : T9PinyinBox
  • T9PinyinBoxView() : T9PinyinBoxView
  • T9PredictiveInputBox() : T9PredictiveInputBox
  • T9SymbolEntryRequestMsg() : T9SymbolEntryRequestMsg
  • t_byte : MmiSimMsgArg
  • t_char : MmiSimMsgArg
  • t_int : MmiSimMsgArg
  • t_int16 : MmiSimMsgArg
  • t_int32 : MmiSimMsgArg
  • t_int8 : MmiSimMsgArg
  • t_uchar : MmiSimMsgArg
  • t_uint : MmiSimMsgArg
  • t_uint32 : MmiSimMsgArg
  • t_void : MmiSimMsgArg
  • t_wchar : MmiSimMsgArg
  • t_xydim : MmiSimMsgArg
  • TabButton() : TabButton
  • TabButtonClippedWidth : OptionalConfigBase
  • TabButtonDefaultHeight : OptionalConfigBase
  • TabButtonDefaultWidth : OptionalConfigBase
  • TabButtonMaximumWidth : OptionalConfigBase
  • TabButtonMinimumWidth : OptionalConfigBase
  • TabButtonView() : TabButtonView
  • TabControl() : TabControl
  • TabControlView() : TabControlView
  • table : SimEfRefresh
  • table_count : tagFont
  • TaDa : InformationElement
  • Tag : Tlv
  • TaggedError : SsErrorCode
  • TaggedProblemCode() : TaggedProblemCode
  • TAmbigous : BtJsr82Url::Token
  • Target : ObexHeader
  • target_sir : DchReport
  • TAsterix : BtJsr82Url::Token
  • TAuthenticate : BtJsr82Url::Token
  • TAuthorize : BtJsr82Url::Token
  • TBadInput : BtJsr82Url::Token
  • TchMode : StreamAudioReference
  • TColon : BtJsr82Url::Token
  • TComma : BtJsr82Url::Token
  • TcpNetAdapter() : TcpNetAdapter
  • TcpServerSocket : SocketSubSystem, SocketData, InetSocket, FtpDataServerSocket
  • TcpServerTestSocket() : TcpServerTestSocket
  • TcpSocket : TcpSocket, SocketData
  • TcpTestSocket() : TcpTestSocket
  • TDecNumber : BtJsr82Url::Token
  • TDeviceDetail : BtApplicationQuerySupportedProfilesRequest
  • TDeviceList : BtApplicationQuerySupportedProfilesRequest
  • TDot : BtJsr82Url::Token
  • TeardownContext() : DataConn
  • TelecaVrEngineParams() : TelecaVrEngineParams
  • Telematic : ProtocolIdentifier
  • TelematicDevice() : ProtocolIdentifier, EnumTranslationTable
  • TelematicInterworkingNotSupported : ShortMessageFailureCause
  • TelephoneNumberingPlan : TypeOfAddress
  • Telephony : InputParser
  • TelephonyAppCatFlag : CodecDevice
  • TeleserviceNotProvisioned : SsErrorCode
  • TeletexAnalogPstn : ProtocolIdentifier
  • TeletexCarrierUnspecified : ProtocolIdentifier
  • TeletexCspdn : ProtocolIdentifier
  • TeletexDigitalIsdn : ProtocolIdentifier
  • TeletexPspdn : ProtocolIdentifier
  • Telex : ProtocolIdentifier
  • TelexNumberingPlan : TypeOfAddress
  • Tell() : File
  • TelType : VCard
  • TempFileCreationError : File
  • TemporaryError : ShortMessageStatus
  • TemporaryErrorStillTrying : ShortMessageStatus
  • TemporaryFailure : Sms
  • TEncrypt : BtJsr82Url::Token
  • TEndInput : BtJsr82Url::Token
  • TEqual : BtJsr82Url::Token
  • Terminate() : Thread, Server, HttpServer, HttpApplication, FtpServer
  • TerminateExtPsdContext() : ExtPsdContextListenerImpl_SerialTerminalListener
  • TerminateSupplementaryService() : SsHandler
  • TerminateUssdTransaction() : MobileOriginatedUssdHandler
  • TermIos() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • TermRspCnfArg() : TermRspCnfArg
  • TermRspCnfMsg() : TermRspCnfMsg
  • TestA() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT2, SocketTestT1, SocketTestT
  • TestAA() : SocketTestT4
  • TestABCD() : SocketTestT3
  • TestAddEntryPerf() : UibPerformanceTest
  • TestB() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT2, SocketTestT1, SocketTestT
  • TestBCD() : SocketTestT4
  • TestC() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT
  • TestCheckBoxListView() : TestCheckBoxListView
  • TestCheckBoxView() : TestCheckBoxView
  • TestControlFrameView() : TestControlFrameView
  • TestD() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT
  • TestDeleteEntryPerf() : UibPerformanceTest
  • TestE() : SocketTestT5, SocketTestT3, SocketTestT
  • TestF() : SocketTestT
  • TestFor() : SerialIoSet
  • TestG() : SocketTestT
  • TestGetAction() : UibAccessorTest
  • TestGetActionCount() : UibAccessorTest
  • TestGetActionIndex() : UibAccessorTest
  • TestH() : SocketTestT
  • TestI() : SocketTestT
  • TestInsertAction() : UibAccessorTest
  • TestparamReportArg() : TestparamReportArg
  • TestParamReportComponent : TestparamReport
  • TestparamReqArg() : TestparamReqArg
  • TestPositionIndicatorView() : TestPositionIndicatorView
  • TestPredefinedSettings() : UibSettingsTest
  • TestPushButtonView() : TestPushButtonView
  • TestRadioButtonListView() : TestRadioButtonListView
  • TestRadioButtonView() : TestRadioButtonView
  • TestRemoveAccessor() : UibAccessorTest
  • TestRemoveAction() : UibAccessorTest
  • TestRemoveAllActions() : UibAccessorTest
  • TestSetAccessor() : UibAccessorTest
  • TestSettingsDisplay() : UibSettingsTest
  • TestSettingsModification() : UibSettingsTest
  • TestSettingsProvider() : UibSettingsTest
  • TestState : InternalTracer
  • TestTheme() : TestTheme
  • TestUpdateTime() : UibPerformanceTest
  • TestWindowFrameView() : TestWindowFrameView
  • text : SmsTextEntry, MenuPool::FeatureItemContainerTableEntry, MenuPool::FeatureItemContainerContentTableEntry, EnumTextTableEntry, SoftkeyDescTableEntry, SiText_s, UusText, ValueTextMap::Table
  • text_align : Locale::LocaleData
  • TEXT_OUTPUT_MSG : TestWriter
  • text_ptr : BtJsr82Url::Token::Keyword
  • TextAboveIconDisplayType : ItemRendererProperties
  • TextAlign : TextFormat
  • TextAlignment : Locale, InformationElement
  • TextAlignParseType : CTResourcePack
  • TextAlignProp : GuiObjectFactory, CTResourcePack
  • TextAlignType : GuiObjectFactory
  • TextAndIconDisplayType : ItemRendererProperties
  • TextAttr : TextFormat
  • TextAttrParseType : CTResourcePack
  • TextAttrProp : GuiObjectFactory, CTResourcePack
  • TextAttrType : GuiObjectFactory
  • TextAttrValues : TextFormat
  • TextBelowIconDisplayType : ItemRendererProperties
  • TextBox() : TextBox
  • TextBoxClassType : GuiObjectFactory
  • TextColour : InformationElement
  • TextCompoundItem() : TextCompoundItem
  • TextCompressed : DataCodingScheme
  • TextCompression : DataCodingScheme
  • TextDisplayed() : SimTkHandler
  • TextDisplayType : ItemRendererProperties
  • TextEditor : Font
  • TextEditorDocument() : TextEditorDocument
  • TextFormat() : TextFormat
  • TextFormatClassType : GuiObjectFactory
  • TextFormatProp : GuiObjectFactory, CTResourcePack
  • TextFormatting : InformationElement
  • TextIconPairArray() : TextIconPairArray
  • TextIconPairCountProp : GuiObjectFactory
  • TextIconPairProp : GuiObjectFactory
  • TextIconPairType : GuiObjectFactory
  • TextIndicator() : TextIndicator
  • TextItem : EditorItemNode
  • TextLine() : TextLine
  • TextLineAnimTypeProp : GuiObjectFactory
  • TextLineClassType : GuiObjectFactory
  • TextLineView() : TextLineView
  • TextList() : TextList
  • TextListLine() : TextListLine
  • TextListModel() : TextListModel
  • TextListView() : TextListView
  • TextManager() : MultiMediaEditorDocument::TextManager
  • TextMenuAccessor() : TextMenuAccessor
  • TextOverlapsIconDisplayType : ItemRendererProperties
  • TextPack() : TextPack
  • TextProp : GuiObjectFactory
  • TextPropertyId : Item
  • TextScrolling : SimTkProfile
  • TextStringTag : Tlv
  • TextUncompressed : DataCodingScheme
  • TextWrapping : SimTkProfile
  • TFalse : BtJsr82Url::Token
  • Thai : LanguageManager
  • ThaiTextRenderer() : ThaiTextRenderer
  • TheDayAfterTomorrow : Date
  • TheDayBeforeYesterday : Date
  • Theme : Theme, OptionalConfigBase
  • ThemeChangedMsg() : ThemeChangedMsg
  • ThemeName : CTResourcePack
  • ThemeViewIterator() : ThemeViewIterator
  • THexNumber : BtJsr82Url::Token
  • Thirty_Days : AbstractSmsApp
  • ThisType : Allocator< T >
  • thousand_separator : Locale::LocaleData
  • Thread() : Thread
  • ThreadFn() : FfsTestThread, Thread, GenericWorkerTask, AppContainer, EmzMpeg4EncoderThread, EmzMpeg4DecoderThread, EmzMp3DecoderThread, EmzH264DecoderThread, EmzAacDecoderThread, EmzSbcEncoderThread, EmzMpeg4EncoderThread, EmzMpeg4DecoderThread, EmzMp3DecoderThread, EmzH264DecoderThread, EmzAacDecoderThread
  • Threadlet : Threadlet, GenericWorkerTask
  • ThreadletNotificationMsg() : ThreadletNotificationMsg
  • ThreadletStoppedError : Image
  • ThreadSafeProvider() : ThreadSafeProvider
  • Three_Months : AbstractSmsApp
  • threedigitmnc : Plmn
  • ThrPopData() : IsrDataContainer< Data, c_queue_size >
  • Thursday : Date
  • Ticks() : Ticks
  • TickValue() : TickValue
  • time : CalendarRecord::Persist, DateStr, datestr
  • Time : Time, InputMapper
  • time_interval : SiDuration_s
  • time_units : SiDuration_s
  • TimeChanged : RealTimeClock
  • TimeCompoundItem() : TimeCompoundItem
  • TimeEditBox() : TimeEditBox
  • TimeEditBoxView() : TimeEditBoxView
  • TimeEditor() : TimeEditor
  • TimeEditorClassType : GuiObjectFactory
  • TimeEditorDocument() : TimeEditorDocument
  • TimeExpired() : IncrementalPdcUpdater
  • TimeFeatureObject() : TimeFeatureObject
  • TimeFormat : FunctionalityIndicator
  • TimeHM : Time
  • TimeHMS : Time
  • TimeoutCondition() : TimeoutCondition
  • TimeoutValue : DataConnProfile
  • TimeProp : GuiObjectFactory
  • Timer : Timer, Ticks, ExecutionContext, AppContainer
  • timer : MmCoordParam, GmmParam, MmcsParam
  • TimerCause : AudioDeviceBase
  • TimerExpired : Sms
  • TimerTimeoutMsg() : TimerTimeoutMsg
  • times : Locale::LocaleData
  • TimeSpan() : TimeSpan
  • timestamp : FfsFileInfo, ffs_file_info_type
  • TimestampMSec : CodecDevice
  • TimeType : GuiObjectFactory
  • TimeZone() : TimeZone
  • TimeZoneMsg() : TimeZoneMsg
  • timing_advance : L1Param, CellParam
  • TipdBasedActiveWaitDispatcher() : TipdBasedActiveWaitDispatcher
  • title : ContextTableEntry
  • TitleBarBitmap : CTResourcePack
  • TitleBarBitmapUri : CTResourcePack
  • TitleBarHeight : CTResourcePack
  • TitleProp : GuiObjectFactory
  • TitleTextType : MenuProperties
  • TLocalhost : BtJsr82Url::Token
  • Tlv() : Tlv
  • TlvSource : SimTextString
  • TMaster : BtJsr82Url::Token
  • tmp_offset : CellParam
  • TName : BtJsr82Url::Token
  • to_key_code : KeymapTableEntry
  • ToByte() : ObexHeader
  • ToByteBuffer() : ObexHeader
  • ToCStr() : ObexHeader
  • Today : Date
  • ToDoComposeWin() : ToDoComposeWin
  • ToDoDateDialogWin() : ToDoDateDialogWin
  • toDoListDateTime : ToDoRecord::Persist
  • ToDoListWin() : ToDoListWin
  • ToDoProvider() : ToDoProvider
  • ToDoRecMarkLevel : ToDoRecord
  • ToDoRecord() : ToDoRecord
  • ToDoRecProrityLevel : ToDoRecord
  • Toggle : RadioButtonAction, CheckBoxControl, CheckBoxAction, AbstractToggleAction, Provider
  • ToggleActionGroup() : ToggleActionGroup
  • ToggleComponentEntryMode() : ChineseT9Wrapper
  • ToggleNumericModeFunction : T9InputConfig
  • ToggleRow() : Provider, AbstractDelegationProvider, MergeProvider, JoinProvider, SmsProvider, SmsClass0Provider
  • ToggleSelection() : IrdaWin
  • ToggleView() : BrowserViewContainer
  • Token : BtJsr82Url
  • ToLong() : ObexHeader
  • ToLower() : WString, String
  • Tomorrow : Date
  • tone : ToneAudioDevice::StartParam
  • Tone : ToneAudioDevice, ThaiTextRenderer
  • tone_count : ToneAudioDevice::StartParam
  • tone_generator : MiscAudioDevice::AvailableHW
  • tone_type : ToneAudioDevice::StartParam
  • ToneAlarm1 : Audio
  • ToneAudioDevice() : ToneAudioDevice
  • ToneAudioPlayer : AudioReference
  • ToneBroadcast1 : Audio
  • ToneBroadcast2 : Audio
  • ToneBroadcast3 : Audio
  • ToneBroadcast4 : Audio
  • ToneDeviceID : AudioDeviceManager
  • ToneDtmf0 : Audio
  • ToneDTMF0 : ToneAudioDevice
  • ToneDTMF1 : ToneAudioDevice
  • ToneDtmf1 : Audio
  • ToneDTMF2 : ToneAudioDevice
  • ToneDtmf2 : Audio
  • ToneDTMF3 : ToneAudioDevice
  • ToneDtmf3 : Audio
  • ToneDTMF4 : ToneAudioDevice
  • ToneDtmf4 : Audio
  • ToneDtmf5 : Audio
  • ToneDTMF5 : ToneAudioDevice
  • ToneDTMF6 : ToneAudioDevice
  • ToneDtmf6 : Audio
  • ToneDtmf7 : Audio
  • ToneDTMF7 : ToneAudioDevice
  • ToneDTMF8 : ToneAudioDevice
  • ToneDtmf8 : Audio
  • ToneDtmf9 : Audio
  • ToneDTMF9 : ToneAudioDevice
  • ToneDTMFAsterix : ToneAudioDevice
  • ToneDTMFHash : ToneAudioDevice
  • ToneDtmfHash : Audio
  • ToneDtmfStar : Audio
  • ToneID : PresetAudioReference, AudioPresetStore, AudioPreset
  • ToneInfoAlarm : Audio
  • ToneInfoAlarmInCall : ToneAudioDevice
  • ToneInfoAutoRedial : Audio
  • ToneInfoBroadcast : Audio
  • ToneInfoBroadcastInCall : ToneAudioDevice
  • ToneInfoConnection : ToneAudioDevice, Audio
  • ToneInfoDeviceIn : ToneAudioDevice, Audio
  • ToneInfoDeviceOut : ToneAudioDevice, Audio
  • ToneInfoDialTone : Audio
  • ToneInfoDisconnect : ToneAudioDevice, Audio
  • ToneInfoError1 : ToneAudioDevice
  • ToneInfoError2 : ToneAudioDevice
  • ToneInfoFree : Audio
  • ToneInfoFreeTone : ToneAudioDevice
  • ToneInfoLowBat : Audio
  • ToneInfoLowBatInCall : ToneAudioDevice, Audio
  • ToneInfoMinuteBeep : Audio
  • ToneInfoMinuteMinder : ToneAudioDevice
  • ToneInfoMsgFull : ToneAudioDevice, Audio
  • ToneInfoNetworkAttention : Audio
  • ToneInfoPowerOff : ToneAudioDevice, Audio
  • ToneInfoPowerOn : ToneAudioDevice, Audio
  • ToneInfoSingleBeep : ToneAudioDevice
  • ToneInfoSmsInCall : ToneAudioDevice
  • ToneInfoSmsReceived : Audio
  • ToneInfoUssd : ToneAudioDevice, Audio
  • ToneKey1 : Audio
  • ToneKey2 : Audio
  • ToneKey3 : Audio
  • ToneKey4 : Audio
  • ToneLevel : AudioReference
  • ToneMessage1 : Audio
  • ToneMessage10 : Audio
  • ToneMessage2 : Audio
  • ToneMessage3 : Audio
  • ToneMessage4 : Audio
  • ToneMessage5 : Audio
  • ToneMessage6 : Audio
  • ToneMessage7 : Audio
  • ToneMessage8 : Audio
  • ToneMessage9 : Audio
  • ToneMessageSingleBeep : Audio
  • TonePlayed() : SimTkHandler
  • ToneRinging1 : Audio
  • ToneRinging10 : Audio
  • ToneRinging11 : Audio
  • ToneRinging12 : Audio
  • ToneRinging13 : Audio
  • ToneRinging14 : Audio
  • ToneRinging15 : Audio
  • ToneRinging16 : Audio
  • ToneRinging17 : Audio
  • ToneRinging18 : Audio
  • ToneRinging19 : Audio
  • ToneRinging2 : Audio
  • ToneRinging20 : Audio
  • ToneRinging21 : Audio
  • ToneRinging22 : Audio
  • ToneRinging23 : Audio
  • ToneRinging24 : Audio
  • ToneRinging25 : Audio
  • ToneRinging26 : Audio
  • ToneRinging27 : Audio
  • ToneRinging28 : Audio
  • ToneRinging29 : Audio
  • ToneRinging3 : Audio
  • ToneRinging30 : Audio
  • ToneRinging31 : Audio
  • ToneRinging32 : Audio
  • ToneRinging33 : Audio
  • ToneRinging34 : Audio
  • ToneRinging35 : Audio
  • ToneRinging36 : Audio
  • ToneRinging37 : Audio
  • ToneRinging38 : Audio
  • ToneRinging39 : Audio
  • ToneRinging4 : Audio
  • ToneRinging40 : Audio
  • ToneRinging41 : Audio
  • ToneRinging42 : Audio
  • ToneRinging43 : Audio
  • ToneRinging44 : Audio
  • ToneRinging45 : Audio
  • ToneRinging46 : Audio
  • ToneRinging47 : Audio
  • ToneRinging48 : Audio
  • ToneRinging5 : Audio
  • ToneRinging6 : Audio
  • ToneRinging7 : Audio
  • ToneRinging8 : Audio
  • ToneRinging9 : Audio
  • tones : Audio::ToneData
  • ToneSupervisoryCallWaiting : Audio
  • ToneSupervisoryCongestion : Audio
  • ToneSupervisoryError : Audio
  • ToneSupervisoryRadioPathAck : Audio
  • ToneSupervisoryRadioPathNotAvail : Audio
  • ToneSupervisorySubsciberBusy : Audio
  • ToneSvCallWaiting : ToneAudioDevice
  • ToneSvCongestion : ToneAudioDevice
  • ToneSvErrorInfo : ToneAudioDevice
  • ToneSvRadioPathAck : ToneAudioDevice
  • ToneSvRadioPathNotAvail : ToneAudioDevice
  • ToneSvSubscriberBusy : ToneAudioDevice
  • ToneType : ToneAudioDevice, CustomToneAudioReference, AudioPreset
  • ToneUserDefined : Audio
  • TongueHangingOut : InformationElement
  • TooManyFilesError : File
  • Top : TextFormat, Layouter, GridLayout
  • TopLeft : ContextMenu, MenuProperties
  • TopLevelMenu() : TopLevelMenu
  • TopLineGapProp : GuiObjectFactory
  • TopRight : ContextMenu, MenuProperties
  • TopSection : Desktop
  • ToPtr() : WStrData, StrData
  • ToSdl() : ProactiveCauseMapper
  • ToSdlExt() : ProactiveCauseMapper
  • ToStackMsg : ToStackMsg, StackMsgArgument
  • ToString() : ObexHeader, ObexAddress, IrdaObexServerAddr, IrdaObexClientAddr, BtObexServerAddr, BtObexClientAddr, WString, ResourceID, UsbObexServerAddr, AtCommand
  • tot_nof_blocks : BlerTrchInfo
  • total_time : Led::Frame
  • ToUpper() : WString, String
  • ToUserSpace() : SvgImage
  • ToUtf8String() : WString
  • ToViewportSpace() : SvgImage
  • ToWString() : ObexHeader, String, Pathname
  • TpCmdReqNotInPhase1 : Sms
  • TpCreationOfMnrFailed : Sms
  • Tpdu : Tpdu, PhoneNumber
  • TpduCache : TpduCache, SimPduHandler
  • TpduDataMissing : Sms
  • TpduNotSupported : ShortMessageFailureCause
  • TpduStatus() : EnumTranslationTable
  • TpInvalidAlphabet : Sms
  • TpInvalidCmdData_Type : Sms
  • TpInvalidCmdDataLength : Sms
  • TpInvalidDestAddress : Sms
  • TpInvalidDestAddrSpecCmds : Sms
  • TpInvalidMti : Sms
  • TpInvalidScAddress : Sms
  • TpInvalidTimeStamp : Sms
  • TpInvalidUserDataLength : Sms
  • TpMissingCmdData : Sms
  • TpMissingDestAddress : Sms
  • TpMissingScAddress : Sms
  • TpMissingUserData : Sms
  • TpMissingValidityPeriod : Sms
  • TpMtConnectionLost : Sms
  • TpPendingMoSms : Sms
  • TpRdfNotInPhase1 : Sms
  • TpRpfNotInPhase1 : Sms
  • TpSrfNotInPhase1 : Sms
  • TpUdhfNotInPhase1 : Sms
  • TpUserDataTooLarge : Sms
  • TraceAppAttach() : InternalTracer
  • TraceAppDetach() : InternalTracer
  • TraceAttach() : _ApplicationTracer, _NullApplicationTracer
  • TraceBuffer() : InternalTracer
  • TraceCheckPoint() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceData() : InternalTracer
  • TraceDelete() : InternalTracer, _FunctionTracer< mask >, _NullFunctionTracer
  • TraceDetach() : _ApplicationTracer, _NullApplicationTracer
  • tracediag : SecLockStates
  • TraceError() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceFuncBegin() : InternalTracer
  • TraceFuncCheckPoint() : InternalTracer
  • TraceFuncEnd() : InternalTracer
  • TraceFuncStackTrace() : InternalTracer
  • TraceId : InternalTracer
  • TraceMask : InternalTracer
  • TraceMessage() : InternalTracer, _FunctionTracer< mask >, _NullFunctionTracer, _NullApplicationTracer
  • TraceMiscData() : InternalTracer
  • TraceNew() : InternalTracer, _FunctionTracer< mask >, _NullFunctionTracer
  • TraceObj() : InternalTracer
  • TraceObjectCreate() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceObjectDestroy() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceOutputStream() : TraceOutputStream
  • TraceTestState() : InternalTracer, _FunctionTracer< mask >, _NullFunctionTracer
  • TraceVariable() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceVersion() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceWarning() : _FunctionTracer< mask >, _NullFunctionTracer
  • TrackPathToRoot() : RamFileNode
  • TrackSelection : MediaPlayer
  • TRadioButtonItem() : TRadioButtonItem< Content >
  • TrainedCommand : VrHandler
  • transac_flag : LockTableEntry
  • transaction_id : T_STK_TRANSACTION_ID
  • TransactionCompleted : ShortMessageStatus
  • TransferAudioToAccessoryRequest() : BtHsService, BtHfService, BtAudioAccessoryService
  • TransferAudioToPhoneRequest() : BtHsService, BtHfService, BtAudioAccessoryService
  • TransferFocus() : Application, AppContainer
  • TransferLocationDialog() : TransferLocationDialog
  • TransferLocationReq() : SaProviderImpl, GltpProviderImpl, LcsProviderImplBase, LcsProvider, LcsProviderImpl
  • TransferRejected : Sms
  • TransformationMode : DeviceContext
  • TransformationType : VideoChannel, CamWin32, VideoChannel, Camera, VideoChannel
  • TransformBcdPlmnToPlmn() : StackWrapper
  • TransformPlmnToBcdPlmn() : StackWrapper
  • TransformToReversedByteBuffer() : PhoneNumber
  • TransformToWCharBuffer() : PhoneNumber
  • Translate() : LanguageManager
  • TranslateOpenMode() : RamFileImp, FatFileImp
  • Transparent : DataCallContext
  • transparent : BitmapRes
  • TransparentPreferred : DataCallContext
  • TransparentProp : GuiObjectFactory
  • TransparentSelection : AbstractEditor
  • TransportDisableReason : IrdaTransport
  • TransportDisableReasonAppRequest : IrdaTransport
  • TransportDisableReasonIdleTimeout : IrdaTransport
  • TransportDisableReasonNotApplicable : IrdaTransport
  • TransportDisableReasonStackError : IrdaTransport
  • TransportDisableReasonUnknown : IrdaTransport
  • TransportDisconnected : ObexResult
  • TransportEvent() : UsbTransport
  • TransportManager : ObexMngr
  • TransportNotificationMsg() : TransportNotificationMsg
  • TraverseDown : RegIterator, RegEncoderDecoder
  • TraverseNext : RegIterator, RegEncoderDecoder
  • TraverseUp : RegIterator, RegEncoderDecoder
  • trch_id : BlerTrchInfo
  • Trigger() : ItemTree, ItemMenu, AbstractButton, TextMenuAccessor, SoftkeyBar, MenuAccessor, Menu, AbstractMenuAccessor, AbstractActionMenuAccessor
  • TriggerFeatureItemUpdate() : AtlApplication
  • TriggerIsrDataProcessing() : MsgQueue, AppContainer
  • TriggerKeyFeature() : TriggerKeyFeature
  • TriggerMenuItem() : AtlItemMenuWindow
  • TriggerTimer() : TriggerTimer< T >
  • TriggerTimer< AbstractItemGrid > : AbstractItemGrid
  • TriggerTimer< AnimatedTextLine > : AnimatedTextLine
  • TriggerTimer< DefaultCaret > : DefaultCaret
  • TriggerTimer< FfsTestDispWin > : FfsTestDispWin
  • TriggerTimer< ImageBox > : ImageBox
  • TriggerTimer< ItemBox > : ItemBox
  • TriggerTimer< MultiTapInputMapper > : MultiTapInputMapper
  • TriggerTimer< SocketTestApp > : SocketTestApp
  • TriggerTimer< SocketTestProgressWin > : SocketTestProgressWin
  • TriggerTimer< SvgPlayer > : SvgPlayer
  • TriggerTimer< TimeoutCondition > : TimeoutCondition
  • Trim() : SmsCommand, SmsSubmit
  • TripleTone : CustomToneAudioReference
  • TripleUserTone : ToneAudioDevice
  • Truncate() : FfsHandler, RamHandler, FatHandler
  • TruncateUri() : Uri
  • ts : InternalTracer::TraceHeader, InternalTracer::TsStruct
  • TScheme : BtJsr82Url::Token
  • TSemicolon : BtJsr82Url::Token
  • TSlashes : BtJsr82Url::Token
  • TText : BtJsr82Url::Token
  • TTrue : BtJsr82Url::Token
  • TtyInterface() : TtyInterface
  • TtySupported() : TtyInterface
  • Tuesday : Date
  • TUnknown : BtJsr82Url::Token
  • Turkish : LanguageManager, DataCodingScheme
  • TurnOff() : BtLocalSettings
  • TurnOn() : BtLocalSettings
  • TurnVolume() : AudioAccessoryDetails
  • Twelve_Hour : AbstractSmsApp
  • TwilightAuto : Camera
  • TwilightChanged : Camera
  • TwilightOff : Camera
  • TwilightOn : Camera
  • TwilightType : Camera
  • TwoByte : Tlv
  • tx_power_level : L1Param, CellParam
  • tx_pwr : RrcParam
  • type : ToDoRecord::Persist, SmsTextEntry, DataConnApp::EditableSettingTable, PbNumberRecord::Persist, PbRecord::Persist, BtUUID, ColumnInfo, CallInfoArg, UusText, SecLockCommand, RegIterator::LeafMetaData, FfsFileInfo, ffs_file_info_type, WapProfile::Ipv4E164
  • Type : ToDoRecord, SysSocketBase, SysSocket, NetAdapter, InetSocket, ExecutionContext, PredInputMapper, MessageBox, Control::ComponentIterator, Control::NavigationGuidance, AnimatedTextLine, VirtualDisplay, PhoneNumber, PdpContext::PacketFilter, PdpContext::Authentication, PdpContext, PinAction, MoCallAction, MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType, BaseInformationElement, Accessory, File::Attributes, AtCommand, DrmConstraint, InputMapItem, ObexHeader
  • Type_1 : PdpContext::PacketFilter
  • Type_2 : PdpContext::PacketFilter
  • Type_3 : PdpContext::PacketFilter
  • type_id : BtJsr82Url::Token::Keyword
  • Type_Unknown : PdpContext::PacketFilter
  • TypeCount : DrmConstraint
  • TypeDateTime : DrmConstraint
  • TypeId : BtJsr82Url::Token, ObexProtocol
  • TypeInterval : DrmConstraint
  • TypeOfAddress() : TypeOfAddress
  • TypeOfId() : ObexHeader
  • TypeOfNumber : TypeOfAddress
  • TypeProp : GuiObjectFactory
  • types : BidiManager::ParagraphContext
Generated on Wed Jan 25 00:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • UChar : InternalTracer
  • Uci : ProtocolIdentifier
  • Ucs2 : SimGetInkeyOptions, SimGetInputOptions, JapaneseTranscoder
  • Ucs2Alphabet : InputMapper, DataCodingScheme
  • UCS2DisplaySupported : SimTkProfile
  • UCS2EntrySupported : SimTkProfile
  • UdhSourceIndicator : InformationElement
  • UdpNetAdapter() : UdpNetAdapter
  • UdpSocket : SocketData
  • UdpTestSocket() : UdpTestSocket
  • UibAccessorTest() : UibAccessorTest
  • UibActionAccessor() : UibActionAccessor
  • UibFolderWin() : UibFolderWin
  • UibInboxProvider() : UibInboxProvider
  • UibInboxTest() : UibInboxTest
  • UibListBoxModel() : UibListBoxModel
  • UibMsgDisplayTest() : UibMsgDisplayTest
  • UibNotifyMsg() : UibNotifyMsg
  • UibNotifyTest() : UibNotifyTest
  • UibPerformanceTest() : UibPerformanceTest
  • UibRegisterMsg() : UibRegisterMsg
  • UibServiceImpl() : UibServiceImpl
  • UibServiceType : UibApp
  • UibSettingsProvider() : UibSettingsProvider
  • UibSettingsRecord() : UibSettingsRecord
  • UibSettingsTest() : UibSettingsTest
  • UibSettingsWin() : UibSettingsWin
  • UibSortingTest() : UibSortingTest
  • UibTest1() : UibTest1
  • UibTest2() : UibTest2
  • UibUpdateMsg() : UibUpdateMsg
  • UibUpdateThreadlet() : UibUpdateThreadlet
  • uiCertLen : comm_user_cert
  • uid : T_PB_RECORD
  • uiKeyLen : comm_user_cert
  • uiLength : comm_root_cert
  • UInt : InternalTracer
  • UInt16ParseType : CTResourcePack
  • UInt16Type : GuiObjectFactory
  • Uint8BufPtr : BinData
  • UInt8ParseType : CTResourcePack
  • UInt8Type : GuiObjectFactory
  • Ukrainian : LanguageManager
  • ul_blocks : AckNackTestparamCnt
  • ul_meas_cnt : RrcParam, AsTestparamDatabase
  • ul_uarfcn : UmtsRrcScellParam
  • ULong : InternalTracer
  • umts_meas_eval_param : RrcParam
  • umts_meas_id_params : UmtsMeasEvalParam
  • umts_ncell_param : TestparamReport
  • umts_ncell_param_list : UmtsNcellParamList
  • umts_neighbour_cells : UmtsCellList
  • umts_scell : RrcParam
  • UmtsMeasEvalParam() : UmtsMeasEvalParam
  • UmtsMeasIdParam() : UmtsMeasIdParam
  • UmtsNcellParam() : UmtsNcellParam
  • UmtsNeighbourCells : TestparamReport
  • UmtsRrcScellParam() : UmtsRrcScellParam
  • UnassignedNumber : Sms
  • Unauthorised : BtObexResponseCode
  • UnavailableFeaturesIgnored() : FeatureItemContainer
  • UnbindMimeType() : ObexOppServer, ObexOppDataSinkPushServer
  • UnbindStack() : IrdaObexTransport
  • UnblockChv() : SimChvHandler, SimAccessor
  • unblocking_attempts_left : ChvData
  • UnblockPin : InputParser, PinAction
  • UnblockPin2 : InputParser
  • uncompressed_size : FileInfo_s
  • Undefine() : PdpContext
  • UndefineContext() : PsdDataConn
  • undefined : Provider
  • Undefined : PdpContext
  • UndefinedAlphabet : InputMapper
  • UndefinedError : PdpContext
  • UndefinedModification : Provider
  • UndefinedResult : Sms
  • UndefinedSsAction() : UndefinedSsAction
  • UndefinedStatus : Tpdu
  • UndefinedTag : Tlv
  • UndefinedTitleText : MenuProperties
  • UndefinedType : ContextFeature
  • UndefinedUsage : ShortMessageFailureCause
  • Underlined : TextFormat
  • UnexpectedDataValue : SsErrorCode
  • UnexpectedError : TaggedProblemCode
  • UnexpectedLinkedOperation : TaggedProblemCode
  • unicode_string : BtObexHeader
  • UnicodeStringToGsm7DefaultString() : DataCoding
  • UnicodeType : ObexHeader
  • UnidentifiedSubscriber : Sms
  • UninitCompletionMsg : MediaManager
  • UnInitializedState : MediaRecorder, MediaPlayer
  • Union() : Rect
  • Unique() : NiSharedPtr< X >
  • Unit : PackedTimePeriod
  • UnitializedState : Camera
  • UnitInfoRequest() : BtAvrcpOperationService
  • units : AudioToneDuration
  • UniversalTime : DateTime
  • Unknown : InternalTracer, Accessory
  • UNKNOWN : SerialIoSet
  • UnknownAlphabet : SsErrorCode
  • UnknownClassType : GuiObjectFactory
  • UnknownCodec : MediaInfo, CodecDevice
  • UnknownError : File
  • UnknownErrorMsg : MediaManager
  • UnknownMimeType : ObexResult
  • UnknownNumberingPlan : TypeOfAddress
  • UnknownOrigin : PdpContext
  • UnknownParameterInUrl : ObexResult
  • UnknownParseType : CTResourcePack
  • UnknownPdpAddress : PdpContext
  • UnknownProp : GuiObjectFactory
  • UnknownPropertyType : CTResourcePack
  • UnknownResponse : AtResponse
  • UnknownSoundDataSource : AudioReference
  • UnknownSubscriber : SsErrorCode, Sms
  • UnknownType : GuiObjectFactory
  • UnknownTypeOfNumber : TypeOfAddress
  • UnknownUrlType : BtJsr82Url
  • Unlock : SmsBasicProvider, PbRecordProvider, PbRecordHandler, AbstractLockableDevice, ThreadSafeProvider, Provider, Protector, AbstractDelegationProvider, HandlerData, Registry, ObjectTreeService, MergeProvider, JoinProvider, AppendProvider, RecordHandler, RegEncoderDecoder
  • UnlockAction() : UnlockAction
  • UnlockDataStore() : DBService
  • Unlocked : RegEncoderDecoder
  • unmarked : ToDoRecord
  • Unmount() : MainHandler
  • UnpackCbsSeptetsToWchars() : DataCoding
  • UnpackSeptetsToWchars() : DataCoding
  • UnPauseVideoCapture() : VideoCamera
  • Unread : Tpdu
  • UnrecognizedComponent : TaggedProblemCode
  • UnrecognizedError : TaggedProblemCode
  • UnrecognizedErrorInvokeId : TaggedProblemCode
  • UnrecognizedInvokeId : TaggedProblemCode
  • UnrecognizedLinkedId : TaggedProblemCode
  • UnrecognizedOperation : TaggedProblemCode
  • Unref() : SharedPtr< T_obj >
  • Unregister() : MessageMapContainer< T >, AbstractMessageMapContainer, BtController, SmsSocketListener, LookupAlphaIdExtension
  • UnregisterCallback() : BtObexService
  • UnregisterDataConn() : DataConnManager
  • UnregisterDecoder() : CodecManager
  • UnregisterDispatcher() : BtLocalRequest
  • UnregisterEncoder() : CodecManager
  • UnregisterGlobalProvider() : MainProvider
  • UnregisterHfMessages() : BtHfAppPlugin
  • UnregisterMessage() : ServiceThread, ExecutionContext, Application, AppContainer
  • UnregisterMessages() : UserDispatcher, MessageMapDispatcher, BtObexService, BtHsService, BtHfService, BtFaxService, BtDunService, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtSendPasskeyRequest, BtSddbService, BtRespondAuthorizationRequest, BtQuerySupportedProfilesRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtBppService, BtBipServerService, BtBipClientService, BtAvrcpService, BtAvrcpOperationService
  • UnregisterNotify() : Registry
  • UnregisterPanelToApoxiAvrcp() : BtAvrcpPanelApplication
  • UnregisterRequest() : BtObexService, BtObexServerService, BtObexClientService, BtBppServerService
  • UnregisterService() : ServiceBroker
  • UnregisterServiceCallback() : BtSddbService
  • UnregisterServiceRecordRequest() : BtObexSddbImpl, BtSddbService
  • UnRegisterSignalListener() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • UnregisterStorageDevice() : RootFileSystem
  • UnregisterUserActivityListener() : AtlApplication
  • UnregisterWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • UnsecureCellBroadcastDataDownloadRangeBegin : MessageIdentifier
  • UnsecureCellBroadcastDataDownloadRangeEnd : MessageIdentifier
  • Unsent : Tpdu
  • UnsetPacketFilter() : PsdDataConnProfile, PdpContext
  • UnsetPacketFilterPending : PdpContextManager
  • UnspecificDirection : CodecDevice
  • Unspecified : ObexResult, BtObexResponseCode, FunctionalityIndicator
  • UnspecifiedActivationRejection : PdpContext
  • UnspecifiedAttributeId : Feature
  • UnspecifiedCommandError : ShortMessageFailureCause
  • UnspecifiedDcsError : ShortMessageFailureCause
  • UnspecifiedError : Image, ShortMessageFailureCause, SvgPlayer
  • UnspecifiedLanguage : DataCodingScheme
  • UnspecifiedPidError : ShortMessageFailureCause
  • UnspecifiedPropertyId : Item
  • UnspecifiedProtocolError : PdpContext
  • Unsubscribe() : StackControl, SmsSocketListener
  • UnsubscribeAudioMessageCallback() : AudioDeviceManager
  • UnsupportedCameraFeature : Camera
  • UnsupportedFrameRateError : Camera
  • UnSuppotedType : RegEncoderDecoder
  • UnzipBinData() : Unzipper
  • UnzipFfs() : Unzipper
  • Unzoom() : MediaRecorder, MediaPlayer
  • Up : Control::NavigationGuidance, AbstractGrid
  • UpArrowBitmapId : AbstractPredictiveInputBox
  • Update() : UibListBoxModel, UibFolderWin, BrowserViewContainer, ImageListBoxModel, BrowserViewContainer, FmRadioStationsProvider, SmsSettingsProvider, AbstractSmsApp, DataConnWin, DataConnLbModel, SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor, CalendarMonthWin, PhonebookWin, PbSynchronizer, PbSortedProvider, PbRecordProvider, PbProvListBox, PbNumberProvider, PbNameProvider, PbNameFilterProvider, PbMergeProvider, PbManualSynchronizer, PbNumberFilterProvider, PbDetailProvider, View, Theme, TabControlView, RadioButtonControlView, IncrementalPdcUpdater, FrameDc, ControlDc, CheckBoxControlView, AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor, FoggyWindowFrameView, FoggyTheme, FoggyPushButtonView, FoggyPanelView, DefaultWindowFrameView, DefaultTheme, DefaultTextListView, DefaultRadioButtonView, DefaultRadioButtonListView, DefaultPushButtonView, DefaultProgressBarView, DefaultPanelView, DefaultControlFrameView, DefaultCheckBoxView, DefaultCheckBoxListView, CustomizableTheme, CTPushButtonView, CTProgressBarView, CTPanelView, ProviderListBox, FoggyTheme, DefaultWindowFrameView, DefaultTheme, DefaultTextListView, DefaultRadioButtonView, DefaultRadioButtonListView, DefaultPushButtonView, DefaultProgressBarView, DefaultControlFrameView, DefaultCheckBoxView, DefaultCheckBoxListView, DefaultChineseTheme, SortProvider, RegBlobObject, QuickSortProvider, Provider, FindProvider, Find2Provider, FilterProvider, DistinctProvider, ChineseQuickSortProvider, CachingSortProvider, BubbleSortProvider, BlobObject, AbstractDelegationProvider, SettingsProvider, PropertyItem, IndicatorItem, FeatureItem, InputContext, MultiMediaEditor, DrmRightsObjectFile, MergeProvider, JoinProvider, AppendProvider, SstProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, SimTkMainMenuProvider, SimPduHandler, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • update : MdhSetWaitIndicator, MdhWaitIndicator
  • update_status : GmmParam, MmcsParam
  • UpdateAbsPos() : DeviceContext
  • UpdateAbsRect() : WinRect
  • UpdateAcm() : SimAuxHandler, SimAccessor
  • UpdateAlarmList() : CalendarApp
  • UpdateAudioPaths() : AudioPathManager
  • UpdateBidiBuffer() : ParagraphCompoundItem
  • UpdateCbmi() : SimAuxHandler, SimAccessor
  • UpdateCbmir() : SimAccessor
  • UpdateCbmiRange() : SimAuxHandler
  • UpdateCcp() : SimAuxHandler
  • UpdateChildProvider() : AbstractDelegationProvider
  • UpdateChvData() : SimChvHandler
  • UpdateConfiguration() : AudioAccessoryDetails
  • UpdateConnectOptions() : BtDeviceListWindow
  • UpdateConnectProfileSelectedWindow() : BtDeviceListWindow
  • UpdateContext() : BtAvrcpPanelApplication
  • UpdateContextItem() : AtlApplication
  • UpdateContextItemMsg() : UpdateContextItemMsg
  • UpdateControllerDeviceListFeaturesAvailable() : BtAvrcpPanelApplication
  • UpdateControllerFeaturesAvailable() : BtAvrcpPanelApplication
  • UpdateCphsCfuf() : SimAccessor
  • UpdateCphsCsp() : SimAccessor
  • UpdateCphsVmwf() : SimAccessor
  • updated : Provider
  • UpdateData() : ValidityPeriod, ValidityPeriodFormat, CodedTimeStamp
  • UpdatedContent : InputMapper
  • UpdateDeviceList() : BtDeviceListWindow
  • UpdateDisplay() : Application, DeviceContext, MmiSimServer, MmiSimClient
  • UpdateDisplayedSms() : AbstractSmsViewerWin
  • UpdateDocumentAlphabet() : AbstractEditor
  • UpdateDrawableObjects() : Zi8PredictiveInputBox, T9PredictiveInputBox, AbstractPredictiveInputBox
  • UpdateDynamic2Flag() : SimAccessor
  • UpdateDynamicFlag() : SimAccessor
  • UpdateEnabledActions() : DataConnWin, ProvDetailListBoxWin, PhonebookWin, PhonebookApp, PbAbstractWin, AdvPbApp
  • UpdateEntry() : PbRecordHandler, SimPbBaseHandler
  • UpdateExpireTime() : KeyMapping
  • UpdateExtLanguage() : SimAuxHandler
  • UpdateFolderProvider() : UibApp
  • UpdateIndexTable() : SortProvider, MergeProvider
  • UpdateItem() : SoundBrowserApp, AbstractSmsApp, DataConnApp, PbManualSynchronizer, AtlApplicationPlugin, AtlApplication, DBService
  • UpdateItemCount() : Menu
  • UpdateItemMsg() : UpdateItemMsg
  • UpdateLanguage() : SimAuxHandler
  • UpdateList() : BtDeviceListWindow
  • UpdateLockInformation() : DataHandler
  • UpdateMaxAcm() : SimAuxHandler, SimAccessor
  • UpdateMbi() : SimAccessor
  • UpdateMbiRecord() : SimAuxHandler
  • UpdateModification() : Provider
  • UpdateMruProperty() : SimAccessor
  • UpdateMultiMediaEditorDocument() : T9InputMapper
  • UpdateNavigationGuidance() : AbstractGrid, TextList
  • UpdateNoOfItems() : PbProvListBoxModel, PbDetailListBoxModel, ProviderListBoxModel
  • UpdateOptionMenu() : BtDeviceListWindow
  • UpdateOrangeParam() : SimAccessor
  • UpdatePbEntry() : PhonebookApp
  • UpdatePbs() : PhonebookApp
  • UpdatePbThreadlet() : UpdatePbThreadlet
  • UpdatePhoneBookEntry() : SimAccessor
  • UpdatePlmn() : SimAuxHandler
  • UpdatePlmnList() : SimAccessor
  • UpdatePlmnwAct() : SimAuxHandler
  • UpdatePlmnwActList() : SimAccessor
  • UpdatePositionIndicator() : AbstractGrid, AbstractListBox
  • UpdatePrefExtLanguageArray() : SimAccessor
  • UpdatePrefLanguageArray() : SimAccessor
  • UpdateProfile() : DataConnProfileManager
  • UpdateProvider() : ToDoListWin, PbDataHandler, PbAdvDataHandler
  • UpdatePuct() : SimAccessor
  • UpdatePuctData() : SimAuxHandler
  • UpdateRadioDisplay() : FmRadioWindow
  • UpdateReferenceVolume() : AudioDeviceBase
  • UpdateRightsObject() : DrmRightsObjectStore
  • UpdateRow() : CalendarRecordsListBoxModel
  • UpdateSettings() : AbstractSmsApp
  • UpdateSimTkProfileReq() : SimTkHandler
  • UpdatesMainDisplay() : IncrementalPdcUpdater
  • UpdateSmsParam() : SimAccessor
  • UpdateSmsr() : SimAccessor
  • UpdateSmsServiceParameter() : SimSmsParamHandler
  • UpdateSoftkeys() : ContextManager
  • UpdateSortedProvider() : PbDataHandler
  • UpdateStartIndices() : ParagraphCompoundItem
  • UpdateTestInfo() : FfsTestThread
  • UpdateTextEditorDocument() : T9InputMapper
  • UpdateThemes() : ThemeManager
  • UpdateTitle() : LocResController, ProvDetailListBoxWin
  • UpdateTransmit() : SimPduHandler
  • UpdateView() : CalendarRecordsList
  • UpdateVoiceMailboxNumbers() : AbstractSmsApp
  • UpdateWin() : ProvDetailListBoxWin, ProvListBoxWin, PbAbstractWin
  • updating : Provider
  • UpDownArrowBitmapId : AbstractPredictiveInputBox
  • UpDownlinkDirection : AudioDeviceBase
  • UplinkCarKit : AudioPath
  • UplinkDirection : AudioDeviceBase
  • UplinkPathDthfMic : AudioPath
  • UplinkPathHandsetMic : AudioPath
  • UplinkPathHeadsetMic : AudioPath
  • UplinkPathI2S1_Rx : AudioPath
  • UplinkPathI2S1InbandRx : AudioPath
  • UplinkPathNone : AudioPath
  • UplinkPathRecordingHandsetMic : AudioPath
  • UplinkPathTTY : AudioPath
  • UplinkPathType : AudioPath
  • Uplmn() : Uplmn
  • uppercase : PagingMapEntry
  • UpperLeft : CTResourcePack
  • UpperRight : CTResourcePack
  • Uri() : Uri
  • UriAndPayload : RegEncoderDecoder
  • Url : InputMapper
  • UrlType : BtJsr82Url
  • Usage : ShortMessageFailureCause, ProtocolIdentifier, MessageTypeIndicator
  • UsageGroup : ProtocolIdentifier
  • UsbObexServerAddr() : UsbObexServerAddr
  • UsbObexTransport() : UsbObexTransport
  • UsbTransport() : UsbTransport
  • use_param : RingerAudioDevice::StartParam
  • use_tone : ToneAudioDevice::StartParam
  • UseAccessory() : AudioAccessoryStore
  • Used : ToDoRecord
  • used_bytes : RamBlockData
  • user_tone : ToneAudioDevice::StartParam
  • UserAbort : TipdBasedActiveWaitDispatcher
  • UserAbortedError : Camera
  • UserActivityEventArg() : UserActivityEventArg
  • UserActivityListener() : UserActivityListener
  • UserData() : UserData
  • UserDataExists() : ParameterIndicator
  • UserDataHeader() : UserDataHeader
  • UserDataHeaderExists() : SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver
  • UserDataHeaderIE : BaseInformationElement
  • UserDefinedSound : InformationElement
  • UserDispatcher() : UserDispatcher
  • UserPromptIndicator : InformationElement
  • UserTriggeredCapitalization : MultiTapInputMapper
  • UsesIconSet() : Item
  • UsesSecondaryPdpContext() : PsdDataConnProfile
  • UseStaticFonts() : FontManager
  • UShort : InternalTracer
  • usim_appl : T_PB_LOC_REPORT
  • usim_global : T_PB_LOC_REPORT
  • USimApplicationToolkitBusy : ShortMessageFailureCause
  • UsimCardTypeReadIndArg() : UsimCardTypeReadIndArg
  • UsimCardTypeReadReqArg() : UsimCardTypeReadReqArg
  • UsimCsLociReadIndArg() : UsimCsLociReadIndArg
  • UsimCsLociReadReqArg() : UsimCsLociReadReqArg
  • USimDataDownload : ProtocolIdentifier
  • USimDataDownloadError : ShortMessageFailureCause
  • UsimEccReadIndArg() : UsimEccReadIndArg
  • UsimEccReadReqArg() : UsimEccReadReqArg
  • UsimEstReadIndArg() : UsimEstReadIndArg
  • UsimEstReadReqArg() : UsimEstReadReqArg
  • UsimFilePropertyIndArg() : UsimFilePropertyIndArg
  • UsimFilePropertyReqArg() : UsimFilePropertyReqArg
  • UsimLangReadIndArg() : UsimLangReadIndArg
  • UsimLangReadReqArg() : UsimLangReadReqArg
  • UsimLangUpdIndArg() : UsimLangUpdIndArg
  • UsimLangUpdReqArg() : UsimLangUpdReqArg
  • UsimPbChangedField() : UsimPbChangedField
  • UsimPbFillStatus() : UsimPbFillStatus
  • UsimPbFillStatusReqArg() : UsimPbFillStatusReqArg
  • UsimPbFillStatusResArg() : UsimPbFillStatusResArg
  • UsimPbGroups() : UsimPbGroups
  • UsimPbLocationIndArg() : UsimPbLocationIndArg
  • UsimPbLocationReqArg() : UsimPbLocationReqArg
  • UsimPbLocReport() : UsimPbLocReport
  • UsimPbReadAsyncIndArg() : UsimPbReadAsyncIndArg
  • UsimPbReadCnfArg() : UsimPbReadCnfArg
  • UsimPbReadDataAsyncIndArg() : UsimPbReadDataAsyncIndArg
  • UsimPbReadDataReqArg() : UsimPbReadDataReqArg
  • UsimPbReadDataResArg() : UsimPbReadDataResArg
  • UsimPbReadRefAsyncIndArg() : UsimPbReadRefAsyncIndArg
  • UsimPbReadRefReqArg() : UsimPbReadRefReqArg
  • UsimPbReadRefResArg() : UsimPbReadRefResArg
  • UsimPbReadReqArg() : UsimPbReadReqArg
  • UsimPbReadResArg() : UsimPbReadResArg
  • UsimPbReadyIndArg() : UsimPbReadyIndArg
  • UsimPbReadyMsg() : UsimPbReadyMsg
  • UsimPbRefRecord() : UsimPbRefRecord
  • UsimPbResetedMsg() : UsimPbResetedMsg
  • UsimPbRwRecord() : UsimPbRwRecord
  • UsimPbSelectReqArg() : UsimPbSelectReqArg
  • UsimPbSelectResArg() : UsimPbSelectResArg
  • UsimPbStopReqArg() : UsimPbStopReqArg
  • UsimPbStopResArg() : UsimPbStopResArg
  • UsimPbUidRefreshIndArg() : UsimPbUidRefreshIndArg
  • UsimPbUpdDataReqArg() : UsimPbUpdDataReqArg
  • UsimPbUpdDataResArg() : UsimPbUpdDataResArg
  • UsimPbUpdRefReqArg() : UsimPbUpdRefReqArg
  • UsimPbUpdRefResArg() : UsimPbUpdRefResArg
  • UsimPbUpdReqArg() : UsimPbUpdReqArg
  • UsimPbUpdResArg() : UsimPbUpdResArg
  • UsimPlmnListDispatcher : SimAccessor
  • UsimPlmnReadIndArg() : UsimPlmnReadIndArg
  • UsimPlmnReadReqArg() : UsimPlmnReadReqArg
  • UsimPlmnUpdIndArg() : UsimPlmnUpdIndArg
  • UsimPlmnUpdReqArg() : UsimPlmnUpdReqArg
  • UsimPsLociReadIndArg() : UsimPsLociReadIndArg
  • UsimPsLociReadReqArg() : UsimPsLociReadReqArg
  • UsimReadRecordRejArg() : UsimReadRecordRejArg
  • UsimReadRejArg() : UsimReadRejArg
  • UsimSelect() : SimAccessor
  • UsimSmsParamDispatcher : SimAccessor
  • UsimSmsParamExtIndArg() : UsimSmsParamExtIndArg
  • UsimSmsParamReadIndArg() : UsimSmsParamReadIndArg
  • UsimSmsParamReadReqArg() : UsimSmsParamReadReqArg
  • UsimSmsParamUpdIndArg() : UsimSmsParamUpdIndArg
  • UsimSmsParamUpdReqArg() : UsimSmsParamUpdReqArg
  • USimSmsStorageFull : ShortMessageFailureCause
  • UsimUpdCnfArg() : UsimUpdCnfArg
  • UsimUpdRejArg() : UsimUpdRejArg
  • UsimUstReadIndArg() : UsimUstReadIndArg
  • UsimUstReadReqArg() : UsimUstReadReqArg
  • uss_data : UssDataArg
  • UssdAction() : UssdAction
  • UssdAnswerIndArg() : UssdAnswerIndArg
  • UssdAnswerMsg() : UssdAnswerMsg
  • UssDataReceivedMsg() : UssDataReceivedMsg
  • UssdBeginMsg : UssdBeginMsg, UssdHandler
  • UssdBusy : SsErrorCode
  • UssdControlIndMsg() : UssdControlIndMsg
  • UssdDataMsg() : UssdDataMsg
  • UssdDataSource : SimTextString
  • UssdEndMsg() : UssdEndMsg
  • UssdHandler() : UssdHandler
  • UssdIndicationMsg() : UssdIndicationMsg
  • UssdNotifyMsg() : UssdNotifyMsg
  • UssdRequestMsg() : UssdRequestMsg
  • UssdRequestResentMsg() : UssdRequestResentMsg
  • UssdResentMsg() : UssdResentMsg
  • UtcStatusMessage() : UtcStatusMessage
  • UTone : ToneAudioDevice::StartParam
  • uuid : BtUUID
  • UusErasedMsg() : UusErasedMsg
  • UusHandler() : UusHandler
  • UusNotificationMsg() : UusNotificationMsg
  • UusQueryRejectedMsg() : UusQueryRejectedMsg
  • UusRegisteredMsg() : UusRegisteredMsg
  • UUSService1 : InputParser
  • UUSService2 : InputParser
  • UUSService3 : InputParser
  • UusStatusMsg() : UusStatusMsg
  • UxgaSize : CamWin32, Camera
Generated on Wed Jan 25 00:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • V42bis : PdpContext
  • V44 : PdpContext
  • val : SiIpAddressArray, SiTextArray, TMsapPackedDataArray, SiProvFileRefArray, SiBearerDescArray, SiBearerListArray, TAlphaIdentifierArray, SiUrlArray, SimSubAddress, SimEventList, AddInfo, CurrencyCode, UsimLanguageList, UsimLanguage, PsLociData, UsimEst, UsimUst, CphsCspArray, CphsOnsName, CphsOnmName, CphsCfufArray, CphsVmwfArray, CphsIstArray, SimEfOrangeParam, SimEfParameters, SimDfParameters, SimApdu, SmsrData, SimData, EccNetworkNumber, EccArray, CcpData, SimServiceTable, Imei, Imsi, Puct, Acm, IccId, ExtLanguageArray, ExtLanguage, LanguageArray, CbmiData, LociData, SmsParamRecord, UsimPlmnList, MdhDeletionCmd, MdhExtendedData, MdhSetWaitIndicatorArray, MdhWaitIndicatorArray, SecLocks, SecMmiConfigData, SecLockCode
  • valid : PbNumberRecord::Persist, PbRecord::Persist
  • Valid : Image
  • Validate() : Image
  • ValidateAsset() : DrmAsset
  • ValidateAudioData() : AudioUtility
  • ValidateFileName() : MediaBrowserUtils
  • ValidateProtocolIdentifier() : AbstractSmsApp
  • ValidateServiceCenterAddress() : AbstractSmsApp
  • ValidateUri() : Uri
  • ValidateValidityPeriod() : AbstractSmsApp
  • ValidationResult : Image
  • ValidityPeriod() : ValidityPeriod
  • ValidityPeriodFormat() : ValidityPeriodFormat, EnumTranslationTable
  • value : GridLayout::LayouterProperties, BtObexHeader, EmlppPriority, SsGroup, ValueTextMap::Table, HttpRequest::ParamPair
  • ValueAttributeId : Property
  • ValueIndicator() : ValueIndicator
  • ValueMappingPropertyDescriptor() : ValueMappingPropertyDescriptor< T_Container >
  • ValueMappingPropertyDescriptorClassType : GuiObjectFactory
  • ValueNotUsed : InformationElement
  • ValueProp : GuiObjectFactory
  • ValuePropertyId : Item, AbstractToggleAction
  • ValueTextMap() : ValueTextMap
  • ValueType : Vector< T >
  • VARIABLE_CHANGED_MSG : TestWriter
  • VariablePicture : InformationElement
  • VariableSizeFontSupport : SimTkProfile
  • VCard() : VCard
  • VCardItem() : VCardItem
  • VCardParser : VCard
  • VCardWriter : VCard
  • Vector() : Vector< T >
  • Vector< T > : Vector< T >::Iterator
  • Verbose() : InetSocketAddr, IpAddr
  • VerifiedAndFailed : PhoneNumber
  • VerifiedAndPassed : PhoneNumber
  • VerifyChv() : SimChvHandler, SimAccessor
  • Version : InternalTracer
  • version : tagCustomizationPack, FileInfo_s
  • version_needed : FileInfo_s
  • VersionInfo() : VersionInfo
  • VertBorderAlign : Desktop
  • Vertical : PositionIndicator
  • vertical : IndicatorBarView
  • VerticalCenteredProp : GuiObjectFactory
  • VeryLongKeyPress : Keyboard
  • VeryLongKeyPressMsg() : VeryLongKeyPressMsg
  • VFormat() : WString, String
  • VgaSize : CamWin32, Camera
  • vibrator : MiscAudioDevice::PowerStatus
  • Vibrator_Async_1 : VibratorDevice
  • Vibrator_Async_2 : VibratorDevice
  • Vibrator_Async_3 : VibratorDevice
  • Vibrator_Async_4 : VibratorDevice
  • Vibrator_Async_5 : VibratorDevice
  • Vibrator_Async_6 : VibratorDevice
  • Vibrator_Sync_Control : VibratorDevice
  • VibratorDeviceID : AudioDeviceManager
  • VibratorMode : VibratorDevice, Audio, AudioVibratorDevice
  • VibratorModeAsync1 : Audio, AudioVibratorDevice
  • VibratorModeAsync2 : Audio, AudioVibratorDevice
  • VibratorModeSync1 : Audio, AudioVibratorDevice
  • VibratorModeSync2 : Audio, AudioVibratorDevice
  • VibratorOffTime : Audio
  • VibratorOffTime200ms : Audio
  • VibratorOffTime300ms : Audio
  • VibratorOffTime400ms : Audio
  • VibratorOffTime600ms : Audio
  • VibratorOffTimeOff : Audio
  • VibratorOnTime : Audio
  • VibratorOnTime1000ms : Audio
  • VibratorOnTime400ms : Audio
  • VibratorOnTime600ms : Audio
  • VibratorOnTime800ms : Audio
  • VibratorOnTimeOn : Audio
  • VideoAndViewfinderOrderType : VideoChannel
  • VideoCamera() : VideoCamera
  • VideoCameraCategory : AbstractDevice
  • VideoCaptureParameters() : VideoCaptureParameters
  • VideoCapturePaused : Camera
  • VideoCaptureStarted : Camera
  • VideoCaptureStopped : Camera
  • VideoCaptureUnPaused : Camera
  • VideoCapturingHiddenState : Camera
  • VideoCapturingPausedState : Camera
  • VideoCapturingState : Camera
  • VideoChannel : VideoChannel, DefaultDisplay
  • VideoCodecCapabilities() : CodecDevice::VideoCodecCapabilities
  • VideoEncoderBufferAllocationError : Camera
  • VideoOnly : MediaPlayer
  • VideoParameterType : VideoChannel
  • VideoPlaybackOverViewfinder : VideoChannel
  • VideoQuality : DisplaySettings
  • Videotex : ProtocolIdentifier
  • VideoTrackInfo() : MediaInfo::VideoTrackInfo
  • VidResNotSupported : MediaManager
  • Vietnamese : LanguageManager
  • VietnameseTextRenderer() : VietnameseTextRenderer
  • View() : View
  • ViewAll() : CalendarMonthWin
  • ViewFinder_CB() : CamWin32
  • ViewfinderErrorMsg() : ViewfinderErrorMsg
  • ViewfinderHiddenState : Camera
  • ViewfinderHoldHiddenState : Camera
  • ViewfinderHoldState : Camera
  • ViewfinderOverVideoPlayback : VideoChannel
  • ViewfinderStarted : Camera
  • ViewfinderStopped : Camera
  • ViewfindingState : Camera
  • ViewNext : ResultWinBase
  • ViewPrevious : ResultWinBase
  • ViewSelectedDay() : CalendarMonthWin
  • VirtualDisplay() : VirtualDisplay
  • VisibleValuesCountProp : GuiObjectFactory
  • Visit() : MediaPathnameVisitor, MediaVisitor, MediaPathnameVisitor, MediaVisitor, StorageDeviceVisitor, FileVisitor
  • VisitDirectories() : FileVisitor
  • VisitObexServer() : ObexServerVisitor
  • VisitOppServer() : ObexServerVisitor
  • vm_mode : VmParam
  • vm_play : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • vm_rec : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • VmModePlayback : VoiceMemoAudioDevice
  • VmModeRec : VoiceMemoAudioDevice
  • VmModeStandby : VoiceMemoAudioDevice
  • VmModeTch : VoiceMemoAudioDevice
  • VmPlayMode : VoiceMemoAudioDevice
  • Voice : XCallInfoResponseParser
  • voicebox_number : SmsSettingsRecord::Persist
  • VoiceBroadcastService : InputParser
  • VoiceGroupCallService : InputParser
  • VoiceMemoAudioDevice() : VoiceMemoAudioDevice
  • VoiceMemoAudioPlayer : StreamAudioReference
  • VoiceMemoDeviceID : AudioDeviceManager
  • VoiceMemoMenuAccessor() : VoiceMemoMenuAccessor
  • VoiceMemoRecordWin() : VoiceMemoRecordWin
  • VoiceMemoWin() : VoiceMemoWin
  • VoiceMessage : InformationElement, DataCodingScheme
  • VoiceMsgType : SimCphsHandler
  • VoiceTelephone : ProtocolIdentifier
  • volume : IMelodyData
  • VolumeLevel : AudioReference, AudioDeviceBase, AudioActiveReference
  • VoluntaryCause : AudioDeviceBase
  • VpfNotSupported : ShortMessageFailureCause
  • VpNotSupported : ShortMessageFailureCause
  • VrAbortEngineIndArg() : VrAbortEngineIndArg
  • VrApiRc : VrHandler
  • VrCommand : VrHandler
  • VrCommandSet : VrHandler
  • VrErrorIndArg() : VrErrorIndArg
  • VrErrorMsg() : VrErrorMsg
  • VrFailed : VrHandler
  • VrG2AResultIndArg() : VrG2AResultIndArg
  • VrHandler() : VrHandler
  • VrInitCnfArg() : VrInitCnfArg
  • VrIntrmRecResultIndArg() : VrIntrmRecResultIndArg
  • VrLoadTemplateReqArg() : VrLoadTemplateReqArg
  • VrParamReqArg() : VrParamReqArg
  • VrPlaybackFinishedMsg() : VrPlaybackFinishedMsg
  • VrPromptMsg() : VrPromptMsg
  • VrPropertyResultIndArg() : VrPropertyResultIndArg
  • VrRecognitionAbortedMsg() : VrRecognitionAbortedMsg
  • VrRecognitionFailedMsg() : VrRecognitionFailedMsg
  • VrRecognitionMode : VrHandler
  • VrRecognitionStoppedMsg() : VrRecognitionStoppedMsg
  • VrRecogResultIndArg() : VrRecogResultIndArg
  • VrResultMsg() : VrResultMsg
  • VrSayNameIndArg() : VrSayNameIndArg
  • VrStackMsgArgTableDestroyTableNode : VrPropertyResultIndArg, VrWarningIndArg, VrErrorIndArg, VrG2AResultIndArg, VrStoreTemplateReqArg, VrStopRecogIndArg, VrAbortEngineIndArg, VrTrainResultIndArg, VrRecogResultIndArg, VrIntrmRecResultIndArg, VrSayNameIndArg, VrLoadTemplateReqArg, VrInitCnfArg, VrParamReqArg
  • VrStopRecogIndArg() : VrStopRecogIndArg
  • VrStoreTemplateReqArg() : VrStoreTemplateReqArg
  • VrSuccess : VrHandler
  • VrTrainingAbortedMsg() : VrTrainingAbortedMsg
  • VrTrainingFailedMsg() : VrTrainingFailedMsg
  • VrTrainingResultMsg() : VrTrainingResultMsg
  • VrTrainResultIndArg() : VrTrainResultIndArg
  • VrWarningIndArg() : VrWarningIndArg
  • VrWarningMsg() : VrWarningMsg
Generated on Wed Jan 25 00:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • Wait : SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, MsgQueue, ExecutionContext, AppContainer, ActiveWaitDispatcher, AbstractScheduler, AbstractAppContext, InputParser
  • WaitForDataRecv() : InetSocket
  • WaitForDataSent() : InetSocket
  • WaitForSetup() : DataConn
  • WaitingForClose : SocketTestT
  • WaitingForConnect : SocketTestT
  • WaitingForConnection : Charger
  • WaitingForInit : SocketTestT
  • WaitingForRead : SocketTestT
  • WaitingForWrite : SocketTestT
  • WaitingMessage() : DataCodingScheme, EnumTranslationTable
  • WaitingMessageIndication() : DataCodingScheme, EnumTranslationTable
  • WaitSsAction() : WaitSsAction
  • WaitUntilDecodingIsFinished() : Image
  • Wakeup() : SocketRxThread, SerialSocketThread
  • WanUuid : ObexHeader
  • WapAuthMethod : WapProfile
  • WapConnectionless : WapProfile
  • WapGroup : DataCodingScheme
  • WapHandler : WapHandler, HttpWapMgr
  • WapProfile() : WapProfile
  • WapProfileMgr : WapProfile
  • WapSecureConnectionless : WapProfile
  • WapSecureSession : WapProfile
  • WapSession : WapProfile
  • WapSessionConnected : WapHandler
  • WapSessionStatus : WapHandler
  • WapSessionSuspended : WapHandler
  • WapWtaSecureConnectionless : WapProfile
  • WapWtaSecureSession : WapProfile
  • Warning : InternalTracer
  • warning() : WbxmlParserRel
  • WarningLevel : Sms
  • WarningSimIsFull : Sms
  • WasApplUsimPbLastUsed() : UsimPbLocReport
  • WasChanged() : UsimPbGroups
  • WasChangedToMoc() : SsWaitDispatcher
  • WasGlobalUsimPbLastUsed() : UsimPbLocReport
  • WasRejected() : SsWaitDispatcher
  • WasSimChanged() : DataHandler
  • WasSimPbLastUsed() : UsimPbLocReport
  • WaveDspFormat : StreamAudioReference
  • WbmpImage() : WbmpImage
  • WbType : CameraOptionSettingsWin
  • WbxmlParserRel : WbxmlParserRel, DrmRelParser
  • WbxmlVector() : WbxmlVector< T >
  • WCharToBcdNibble() : PhoneNumber
  • WearingGlasses : InformationElement
  • Wednesday : Date
  • Week : PackedTimePeriod
  • Weekly : CalendarRecord
  • WeekOfYear() : Date
  • White : InformationElement
  • WhiteBalanceChanged : Camera
  • WhiteBalanceType : Camera, CameraOptionSettingsWin
  • WhitespaceWrap : EditorDocument
  • Who : ObexHeader
  • width : tagCPGlyph
  • WidthReductionInAMenu : SimTkProfile
  • WildCharHandler() : AbstractSmsApp
  • Window : Window, Control
  • WINDOW_CLOSED_MSG : TestWriter
  • WINDOW_OPENED_MSG : TestWriter
  • WindowClassType : GuiObjectFactory
  • WindowFrameControl : CTResourcePack
  • WindowFrameView() : WindowFrameView
  • WindowHierarchyIterator : WindowHierarchyIterator, WindowManager
  • WindowProp : GuiObjectFactory
  • WindowTitleBarControl : CTResourcePack
  • WindowType : CameraOptionSettingsWin
  • WinMenuItem() : WinMenuItem
  • WinRect() : WinRect
  • WirelessControlMessageProtocol : InformationElement
  • WorkerTaskObtainer : GenericWorkerTask
  • Wow : InformationElement
  • WrapLine() : TimeEditorDocument, TimeCompoundItem, ThaiTextRenderer, TextEditorDocument, TextCompoundItem, SimpleTextRenderer, JapaneseTextRenderer, IpAddrCompoundItem, EditorDocument, DateEditorDocument, DateCompoundItem, CompoundItem, ArabicTextRenderer, AbstractTextRenderer, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem
  • WrapPolicy : EditorDocument
  • Write : LcsSocket, FfsDataConnProfileStorage, UdpSocket, TcpSocket, Socket, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket, DataConnProfileStorage, SocketPeer, TraceOutputStream, OutputStream, FileOutputStream, FfsFile, DebugOutputStream, BufferedOutputStream, StringDataSink, HeapDataSink, DataSink, ExtPsdContextListener_SerialTerminal, UserData, FileDataSink, FileChunkOperator, File, RegNodeBuffer, FlsFile, FfsHandler, SioSocketAdapter, SerialSocket, SerialIoAdapter, SerialTerminalSocket, SerialTerminal, RamHandler, RamFileObj, RamFile, FatHandler, FatFile, SocketTestT
  • WriteBlock() : RamStorageMapper
  • WriteBlocks() : RamStorageMapper
  • WriteBool() : HostIniFile
  • WriteBuffer() : VCard
  • WriteCoverageBuffer() : TestWriter
  • WriteCur() : File
  • WriteData() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • WriteDefaultRingToneInfo2Ffs() : RingerAudioDevice
  • WriteError : File
  • WriteInteger() : HostIniFile
  • WriteMetaData() : Fota
  • WriteOffsetExact : FileChunkOperator
  • WritePayloadData() : UserData
  • Writer : ObexBuffer::Writer, ObexBuffer
  • WriteRightsObject() : DrmRightsObjectFile
  • WriteRingToneInfo2Ffs() : RingerAudioDevice
  • WriteState() : TestWriter
  • WriteStreaming() : File, FlsFile, FatHandler, FatFile
  • WriteStreamingAsync() : File, FlsFile, FatHandler, FatFile
  • WriteString() : HostIniFile
  • WriteTo() : DrmInfo, Path
  • WriteToMemory() : BtSddbServiceRecord, BtSddbServiceAttribute, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeOneByteDescriptionType, BtSddbDataElement
  • WriteTpdu() : CompoundTpduItem
  • WriteVCard() : VCardWriter
  • WString : WString, InternalTracer, String
  • WStringIE : BaseInformationElement
  • WStringParseType : CTResourcePack
  • WStringType : GuiObjectFactory, ContextFeature
Generated on Wed Jan 25 00:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- x -

  • X25Protocol : PdpContext
  • X400 : ProtocolIdentifier
  • x_scale : S_SvgFixPointTrans
  • x_shear : S_SvgFixPointTrans
  • x_trans : S_SvgFixPointTrans
  • XAlign : Layouter, GridLayout
  • XaocService : AtResponse
  • Xcallinfo : AtResponse
  • XCallInfoResponseParser() : XCallInfoResponseParser
  • Xcallrefuse : AtResponse
  • Xcallstat : AtResponse
  • Xcaoc : AtResponse
  • Xcccm : AtResponse
  • Xccharge : AtResponse
  • Xceer : AtResponse
  • Xcharge : AtResponse
  • XDefault : Layouter, GridLayout
  • XgaSize : CamWin32, Camera
  • Xhosa : LanguageManager
  • XML_Characters_Handler() : XMLParser, XmlParserRel
  • XML_End_Handler() : XMLParser, XmlParserRel
  • XML_EndCData_Handler() : XMLParser, XmlParserRel
  • XML_EndElement_Handler() : XMLParser, XmlParserRel
  • XML_Error_Handler() : XMLParser, XmlParserRel
  • XML_PI_Handler() : XMLParser, XmlParserRel
  • XML_Start_Handler() : XMLParser, XmlParserRel
  • XML_StartCData_Handler() : XMLParser, XmlParserRel
  • XML_StartElement_Handler() : XMLParser, XmlParserRel
  • XMLParser() : XMLParser
  • XmlParserRel : XmlParserRel, DrmRelParser
  • XorFilterOp : DualFilterProvider
  • XorRop : DeviceContext
  • Xprogress : AtResponse
  • XProp : GuiObjectFactory
  • XyDimParseType : CTResourcePack
  • XyDimType : GuiObjectFactory
Generated on Wed Jan 25 00:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • y_scale : S_SvgFixPointTrans
  • y_shear : S_SvgFixPointTrans
  • y_trans : S_SvgFixPointTrans
  • YAlign : Layouter, GridLayout
  • YamahaMapiId : AudioDeviceManager
  • YDefault : Layouter, GridLayout
  • year : RealTimeClock::DateAndTime, FfsTimeRecord, ffs_time_record_type
  • Yearly : CalendarRecord
  • YesId : MessageBox
  • YesNo : MessageBox
  • Yesterday : Date
  • Yield() : Thread
  • YProp : GuiObjectFactory
  • YUV420 : CamWin32
  • Yuv420 : JpegEncoder::EncodingParameters
  • Yuv420ColorSpace : Image::MetaData
  • Yuv422 : JpegEncoder::EncodingParameters
  • Yuv422ColorSpace : Image::MetaData
Generated on Wed Jan 25 00:54:29 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- _ -

  • _constants : UdpTestSocket, TcpTestSocket
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • KeyTone : KeyToneAudioDevice
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • Language : DataCodingScheme
  • LanguageGroupId : DataCodingScheme
  • LanguageType : LanguageManager
  • LastChange : PbRecordProvider
  • LeafnodeType : RegIterator
  • LengthCoding : Tlv
  • LightOriginType : CTResourcePack
  • LineAlignment : EditorDocument
  • LineState : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • LlcSapi : PdpContext::ActivationStatus
  • LocationType : CodecDevice
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • MapiCommandCodeType : AudioMapiManager
  • MapItemType : InputMapItem
  • MaxDataElements : UmtsMeasEvalParam, UmtsMeasIdParam
  • MeanRate : PdpContext::QualityOfService
  • Media : StreamAudioReference, Media
  • MediaCodec : MediaInfo
  • MediaQuality : RecordSettings
  • MediaRecorderState : MediaRecorder
  • MediaSinkType : RecordSettings
  • MediaType : VoiceMemoAudioDevice
  • MenuIndex : PbAbstractWin
  • MenuType : MenuProperties, GuiObjectFactory
  • MessageClass : DataCodingScheme, EnumTranslationTable
  • MessageType : DataConn, ProtocolIdentifier, InformationElement, EnumTranslationTable
  • MeteringType : Camera
  • MmfMsgType : MediaManager
  • MmfResult : MediaManager
  • MmiSimCmdId : MmiSimServer
  • Mode : MessageHook, IconState, Caret, ShutDown, StreamAudioReference, Cbs::Filter
  • ModificationState : XCallInfoResponseParser
  • ModificationType : Provider
  • MonoSteroConfig : CodecDevice
  • Month : Date
  • MoveDirection : AbstractGrid
  • MsgID : RegEncoderDecoder
  • MuteDirection : SpeechAudioDevice, Audio, AudioDeviceBase
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • NodeType : RegIterator
  • Notification : Led, Property, RegEncoderDecoder
  • NotificationMsgType : AbstractTransport
  • NotificationType : InputMapper, RadioAudioDevice
  • NumberingPlanIdentification : TypeOfAddress
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • OpenFlags : ObexServerDispatcher
  • OpenMode : File
  • Operation : ObexServer, DrmInfo, FileChunkOperator
  • OperationState : StreamingInfo
  • OptionType : SysSocketBase, InetSocket
  • Orientation : PositionIndicator
  • Origin : Stream, PdpContext, Message
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • AacFormat : CodecDevice
  • AacFormatType : AudioDecoder
  • AbortCause : TipdBasedActiveWaitDispatcher
  • AbstractItemContainerPropertyId : AbstractItemContainer
  • AbstractToogleActionPropertyId : AbstractToggleAction
  • Accessory : MiscAudioDevice, Accessory
  • Action : CallEvent, Action
  • ActionType : Camera
  • AddrFamily : SysSocketBase, SysSocket
  • AffectedProvider : PhonebookApp, MergeProvider, JoinProvider
  • Alignment : FlowLayout, IndicatorLocation, DateTime
  • Alphabet : InputMapper, DataCodingScheme, EnumTranslationTable
  • AlphaBlendingMode : DeviceContext
  • AmrDtxConfig : CodecDevice
  • AmrIfFormat : CodecDevice
  • AnimationType : Animation
  • AnimType : ItemRendererProperties
  • AntiFlickerType : Camera, CameraOptionSettingsWin
  • ApplicationCategoriesFlagsType : CodecDevice
  • AudioAccessoryConfigurationType : AudioAccessoryDetails
  • AudioChannel : RadioAudioDevice
  • AudioDataType : AudioUtility
  • AudioDevice : Audio
  • AudioDeviceID : AudioDeviceManager
  • AudioDeviceStatus : AudioDeviceBase
  • AudioErrorType : AudioDeviceBase
  • AudioGain : BtHsVolumeSettingsWin, BtHfVolumeSettingsWin
  • AudioMode : Audio
  • AudioPathType : AudioPath
  • AudioPresetSoundToneId : AudioPreset
  • AudioPriority : Audio
  • AudioReturnCode : GenericAudioDevice
  • AudioToneId : Audio
  • AudioVmMode : VoiceMemoAudioDevice
  • AvState : AbstractTransport
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • BackLightMode : BackLight
  • BacklightMode : Display
  • BandLimits : RadioAudioDevice
  • BasicServiceMmiCode : InputParser
  • BitAllocationMethodType : AudioEncoder
  • BitmapResId : Theme
  • BootSequenceState : SubSystemManager, SubSystem
  • BorderModeType : CTResourcePack
  • Box : SmsSettingsRecord
  • BppSubstate : BtBppSndFilePushReqRequest
  • BrushStyle : Brush
  • BtActiveRequest : BtLocalSettings
  • BtAmwType : BtAlertMessageWindow, BtAvrcpAlertMessageWindow
  • BtAvrcpPanelAppFeatures : BtAvrcpPanelApplication
  • BtDeviceListWindowType : BtDeviceListWindow
  • BtErrorReason : BtOperationBase
  • BtHfPath : BtHfAudioPathWindow
  • BtObexServerCodes : BtObexServerAddr
  • BtQueryRequestSupportWinType : BtApplicationQuerySupportedProfilesRequest
  • BtRrwType : BtRequestRunningWindow
  • BufferLocation : VideoCamera
  • ByteOrder : ObexHeader
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • CalendarCategory : CalendarRecord
  • CalendarRecurrence : CalendarRecord
  • CallDirection : XCallInfoResponseParser, MmCallInfo
  • CallInfoType : XCallInfoResponseParser
  • CallMode : XCallInfoResponseParser
  • CallSsActionId : CallSsAction
  • CallState : MmCallInfo
  • CallType : CsdDataConnProfile, XCallInfoResponseParser
  • CameraError : Camera
  • CameraState : Camera
  • CapitalizationMode : MultiTapInputMapper
  • Caps : Stream
  • CaptionPos : AbstractEditBox
  • CaretAction : AbstractMultiLineEditor
  • Category : AbstractDevice, Message
  • Cause : StartUp
  • CcPerformed : XCallInfoResponseParser
  • Channel : RingerAudioDevice
  • ChannelModeType : AudioEncoder
  • CharacterClass : ThaiTextRenderer
  • ChargerMsgType : Charger
  • ChargerStatus : Charger
  • CharType : BidiManager
  • ClassType : GuiObjectFactory
  • ClearingState : XCallInfoResponseParser
  • CliValidity : XCallInfoResponseParser
  • Code : SsErrorCode
  • CodecType : CodecDevice
  • ColorFormatType : CamWin32
  • ColorSpace : Image::MetaData
  • CommonPropertyId : DataConnApp
  • ComparisonType : StandardJoinRule
  • ConnectFlags : ObexObject
  • ConnectionElement : DataCallContext
  • ConnType : IrdaTransport
  • ContextActions : UibInboxTest
  • ContextType : ContextFeature
  • Corner : ContextMenu, MenuProperties
  • CornerModeType : CTResourcePack
  • CphsServGroupCode : SimCphsHandler
  • CrssState : XCallInfoResponseParser
  • CsdPropertyId : DataConnApp
  • CtmStatus : XCallInfoResponseParser
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • DataCompression : PdpContext
  • DataConnState : DataConn
  • DataRate : CsdDataConnProfile
  • DataSource : SimTextString, DataSource
  • Day : Date, PackedTimePeriod
  • DecodingFunctionType : AudioDecoder
  • Delay : PdpContext::QualityOfService
  • DeleteMode : EditBox
  • DeviceCapability : StorageDevice
  • Direction : AbstractSmsViewerWin
  • DirectionType : CodecDevice
  • DisplayType : ItemRendererProperties
  • DownlinkPathType : AudioPath
  • DrmDcfHeaderType : DrmDcfParser
  • DrmVersion : DrmRelParser
  • DspFormat : VoiceMemoAudioDevice, StreamAudioReference
  • DstIndication : TimeZone
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • EditMode : EditBox
  • EmsInsertType : EmsInsertPrompt
  • EncodingFormat : PngEncoder::EncodingParameters, JpegEncoder::EncodingParameters
  • EncodingFunctionType : AudioEncoder
  • EncodingType : JapaneseTranscoder
  • EncQualityConfig : CodecDevice
  • enumClassType : AudioReference, AudioActiveReference
  • Error : ImageEncoder, ShortMessageFailureCause, File, StreamObexImpl, PngDecoder, VrHandler, InternalTracer, ExtPsdContextListener_SerialTerminal, SerialTerminal, AtResponse
  • ErrorCause : PdpContext
  • ErrorCode : ObexResult, Image, SerialIoAdapter
  • ErrorType : AudioError
  • EstablishmentCause : XCallInfoResponseParser
  • Event : Socket, NetAdapter, ExtPsdContextListener_SerialTerminal, SerialTerminal
  • EventType : ObexAbstractPort
  • ExtendedObjectType : InformationElement
  • ExternalContextState : PdpContextManager
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • Feature : SimTkProfile, Feature, AudioDeviceBase, FeatureBroker
  • FeatureAttributeId : Feature
  • FeatureId : DataConnApp
  • FeatureItemContainerPropertyId : FeatureItemContainer
  • FeatureItemPropertyId : FeatureItem
  • FilterOperator : DualFilterProvider
  • FilterType : Camera
  • Flag : Keyboard
  • FlagsType : VideoDecoder
  • FlashType : Camera, CameraOptionSettingsWin
  • FontAlign : TextFormat
  • FontSize : InformationElement
  • Format : RingerAudioDevice, Time, Date, CustomRingerAudioReference, ValidityPeriodFormat, WString, TimeZone, String, DateTime, StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, RamHandler, FlashStorageDeviceImp, FatStorageDeviceImp, AudioDecoder
  • FrameCodingType : VideoEncoder
  • FrameRateType : CamWin32, VideoCamera
  • FrameType : Control, GuiObjectFactory
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • GeographicalScope : Cbs::SerialNumber
  • GroupId : DataCodingScheme
  • GroupIds : OptionalConfigBase
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • HandlerType : ExternalCommunicationHandler
  • HeaderCompression : PdpContext
  • HeaderId : ObexHeader
  • HeaderType : ObexHeader
  • HttpConnStatus : HttpHandler
  • HttpRequestMethodType : HttpRequest
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • Id : InputMapper, Message, BtBipServerNotificationMsgArg, HandlerListEntry, HandlerData, StackMsgArgument, NetAdapter, PdpContext
  • Identifier : FeatureItemContainer, InformationElement
  • IlluminationMode : Keyboard
  • ImageFormatType : CamWin32
  • ImageSizeType : CamWin32, Camera
  • Indication : SmsIndicationState
  • IndicatorAlignment : Indicator
  • IndicatorBarOrientation : IndicatorBarView
  • Info : Display
  • internalStatus : SocketTestT
  • Interworking : ProtocolIdentifier, Sms
  • IrdaSwitchOffTimeout : IrdaTransport
  • ItemPropertyId : Item, AbstractItemContainer
  • ItemStyle : AbstractItemRenderer
  • ItemType : EditorItemNode, ContextFeature
  • itemType : MenuPool
  • IteratorType : RegEncoderDecoder
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • PaddingMethod : AesCrypt
  • PanelAlignment : Desktop
  • Parameter : BtJsr82Url
  • ParameterType : VideoDecoder, AudioEncoder, AudioDecoder
  • ParamType : AtResponseParameter
  • ParentArea : DrawableObject
  • Parity : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • ParseType : GuiObjectFactory, CTResourcePack
  • PayloadType : RegEncoderDecoder
  • PeakRate : PdpContext::QualityOfService
  • PenStyle : Pen
  • PeriodData : AbstractSmsApp
  • Peripheral : Led
  • PortNumber : Iana
  • PortService : WapProfile
  • PositionHint : TabButton
  • PowerMode : Display
  • PowerOnBehavior : AlarmManager
  • Precedence : PdpContext::QualityOfService
  • PredBitmapId : AbstractPredictiveInputBox
  • PredefinedAnimationType : InformationElement
  • PredefinedFeature : AudioDeviceBase
  • PredefinedSoundDataSource : AudioReference
  • PredefinedSoundType : InformationElement
  • PredefIpAddr : IpAddr
  • PredFontId : AbstractPredictiveInputBox
  • PredMode : PredInputMapper
  • PresentationIndicator : PhoneNumber
  • PresetDate : Date
  • PresetToneType : AudioPreset, AudioPresetStore
  • Priority : GenericAudioDevice
  • PriorityLevel : Thread
  • ProblemCode : TaggedProblemCode, EnumTranslationTable
  • ProblemTag : TaggedProblemCode, EnumTranslationTable
  • ProfileConstants : WapProfile
  • ProfileType : DataConnProfile
  • ProgressBarDrawModeType : CTResourcePack
  • Property : CamWin32, Property, FeatureBroker
  • PropertyAttributeId : Property
  • PropertyId : GuiObjectFactory
  • PropertyType : CTResourcePack, CamWin32
  • Protocol : PdpContext, SysSocket
  • ProviderUpdateState : PhonebookApp
  • PsdPropertyId : DataConnApp
  • PxAddrType : WapProfile
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • RadioFmState : FmRadioApplication
  • RadioPriority : PdpContext::ActivationStatus
  • Range : MessageIdentifier
  • RasterOp : DeviceContext
  • Rate : VoiceMemoAudioDevice
  • Reason : AudioPlayerEvent, ShortMessageStatus
  • RelationType : JoinRule
  • Reliability : PdpContext::QualityOfService
  • RelTag_v1_0 : XmlParserRel
  • RelWbxmlAttName_v1_0 : WbxmlParserRel
  • RelWbxmlAttValue_v1_0 : WbxmlParserRel
  • RelWbxmlTag_v1_0 : WbxmlParserRel
  • RenderType : ThaiTextRenderer
  • RequestAcceptanceType : AudioMapiManager
  • ResourceType : CTResourcePack
  • ResponseCode : ObexObject, BtObexResponseCode
  • ResponseType : RegEncoderDecoder, AtResponse
  • Result : Camera, BtJsr82Url, ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, Sms, SioGlueWrapper, SerialTerminal
  • ResultType : BufferPoolManager, CodecDevice
  • ResWinAction : ResultWinBase
  • ReturnId : MessageBox, DialogWindow
  • RingerDevice : RingerAudioDevice
  • RingerVolume : RingerAudioDevice
  • RingTone : RingerAudioDevice
  • RtcInfo : RealTimeClock
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • ScaleType : DisplaySettings
  • ScalingMethodType : VideoChannel, Camera, VideoChannel
  • ScanResult : StorageDevice
  • ScreeningIndicator : PhoneNumber
  • SearchStopLevel : RadioAudioDevice
  • SectionAlignment : Desktop
  • SectionType : Desktop
  • SeekDirection : RadioAudioDevice
  • SeekMode : RadioAudioDevice
  • SeekOrigin : File
  • SelectedLine : XCallInfoResponseParser
  • SelectionStyle : AbstractEditor, OptionalConfigBase
  • SerialSocketEvent : SerialIoSet
  • SerPropertyId : DataConnApp
  • ServiceResult : Service
  • SetPathFlags : ObexObject
  • SettingIds : OptionalConfigBase
  • SetupState : XCallInfoResponseParser
  • ShiftState : EditBox
  • ShutdownMode : SysSocketBase, InetSocket
  • SignalStartStop : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SignalType : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • Size : IconState, HeapVector::VarPage, HeapVector::BlockPage, Size, CArray< T >, ObexBuffer, File::Attributes
  • SmsAlertType : SmsAlert
  • SmsExportType : AbstractSmsApp
  • SmsInfoBoxType : SmsInfoBox
  • SmsSendingAnimationType : AbstractSmsApp
  • SmsServiceType : AbstractSmsApp
  • SmsStorageType : AbstractSmsApp, EnumTranslationTable
  • SmsValidtyPeriodType : AbstractSmsApp
  • SocketFamily : SerialIoAdapter
  • SortMode : ChineseQuickSortProvider
  • SpeechVolume : SpeechAudioDevice, Audio
  • SsCode : InputParser
  • SsProcedure : InputParser
  • State : Control::NavigationGuidance, PdpContextManager::AttachStatus, PdpContextManager, PdpContext::ActivationStatus, PdpContext, KeyMsgGenerator::Key, FtpClient, MediaPlayer
  • Status : SocketTestT, Provider, Tpdu, ShortMessageStatus
  • StereoMode : RadioAudioDevice
  • StopCause : RtStreamingConn, AudioDeviceBase
  • StorageType : Sms
  • StretchUnit : Layouter, GridLayout
  • SvgErrorType : SvgPlayer
  • SvgEventType : SvgPlayer
  • SystemColorId : Color
  • SystemFontId : Font
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • T9FunctionCode : T9InputConfig
  • Tag : Tlv
  • TelematicDevice : ProtocolIdentifier, EnumTranslationTable
  • TestParamReportComponent : TestparamReport
  • TextAlign : TextFormat
  • TextAlignment : Locale, InformationElement
  • TextAttrValues : TextFormat
  • TextColour : InformationElement
  • TextCompression : DataCodingScheme
  • TimeFormat : FunctionalityIndicator
  • TimeoutValue : DataConnProfile
  • TitleTextType : MenuProperties
  • ToDoRecMarkLevel : ToDoRecord
  • ToDoRecProrityLevel : ToDoRecord
  • Tone : ToneAudioDevice, ThaiTextRenderer
  • ToneType : ToneAudioDevice, CustomToneAudioReference, AudioPreset
  • TraceId : InternalTracer
  • TraceMask : InternalTracer
  • TrackSelection : MediaPlayer
  • TransformationMode : DeviceContext
  • TransformationType : VideoChannel, CamWin32, VideoChannel, Camera, VideoChannel
  • TransportDisableReason : IrdaTransport
  • TwilightType : Camera
  • Type : ToDoRecord, SysSocketBase, SysSocket, NetAdapter, InetSocket, ExecutionContext, PredInputMapper, MessageBox, Control::ComponentIterator, Control::NavigationGuidance, AnimatedTextLine, VirtualDisplay, PhoneNumber, PdpContext::PacketFilter, PdpContext::Authentication, PdpContext, PinAction, MoCallAction, MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType, BaseInformationElement, Accessory, File::Attributes, AtCommand, DrmConstraint, InputMapItem, ObexHeader
  • TypeId : BtJsr82Url::Token, ObexProtocol
  • TypeOfNumber : TypeOfAddress
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • UibServiceType : UibApp
  • Unit : PackedTimePeriod
  • UplinkPathType : AudioPath
  • UrlType : BtJsr82Url
  • Usage : ShortMessageFailureCause, ProtocolIdentifier, MessageTypeIndicator
  • UsageGroup : ProtocolIdentifier
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • ValidationResult : Image
  • VibratorMode : VibratorDevice, Audio, AudioVibratorDevice
  • VibratorOffTime : Audio
  • VibratorOnTime : Audio
  • VideoAndViewfinderOrderType : VideoChannel
  • VideoParameterType : VideoChannel
  • VideoQuality : DisplaySettings
  • VmPlayMode : VoiceMemoAudioDevice
  • VoiceMsgType : SimCphsHandler
  • VrApiRc : VrHandler
  • VrCommand : VrHandler
  • VrCommandSet : VrHandler
  • VrRecognitionMode : VrHandler
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • WaitingMessage : DataCodingScheme, EnumTranslationTable
  • WaitingMessageIndication : DataCodingScheme, EnumTranslationTable
  • WapAuthMethod : WapProfile
  • WapSessionStatus : WapHandler
  • WarningLevel : Sms
  • WhiteBalanceType : Camera, CameraOptionSettingsWin
  • WindowType : CameraOptionSettingsWin
  • WrapPolicy : EditorDocument
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • XAlign : Layouter, GridLayout
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerations

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • YAlign : Layouter, GridLayout
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • A2dpFormat : StreamAudioReference
  • AacAdifOrAdtsFormat : AudioDecoder
  • AacAdtsWithOneRawDataBlockFormat : AudioDecoder
  • AacFormatAdif : CodecDevice
  • AacFormatAdts : CodecDevice
  • AacFormatEnd : CodecDevice
  • AacFormatRaw : CodecDevice
  • AacRawFormat : AudioDecoder
  • AbbreviatedNumber : TypeOfAddress
  • ABORT : SerialIoSet
  • AbsentSubscriber : SsErrorCode
  • Absolute : ValidityPeriodFormat
  • AbstractEditorClassType : GuiObjectFactory
  • AbstractGridClassType : GuiObjectFactory
  • AbstractItemContainerClassType : GuiObjectFactory
  • AbstractItemGridClassType : GuiObjectFactory
  • AbstractLineEditorClassType : GuiObjectFactory
  • AbstractMultiLineEditorClassType : GuiObjectFactory
  • AbstractPredictiveInputBoxClassType : GuiObjectFactory
  • AbstractTextObjectClassType : GuiObjectFactory
  • AccessDate : File::Attributes
  • AccessDeniedError : File
  • AccessoryBtHeadset : MiscAudioDevice
  • AccessoryCarKit : MiscAudioDevice
  • AccessoryHeadset : MiscAudioDevice
  • AccessoryNormal : MiscAudioDevice
  • AccessoryStereoPhones : MiscAudioDevice
  • AccessTime : File::Attributes
  • AcDcAdaptor : Accessory
  • Action1 : UibInboxTest
  • Action2 : UibInboxTest
  • Action3 : UibInboxTest
  • ACTION_DISABLED_MSG : TestWriter
  • ACTION_EXECUTED_MSG : TestWriter
  • ActionClassType : GuiObjectFactory
  • ActionCnt : UibInboxTest
  • ActionProp : GuiObjectFactory
  • ActivateCompletionOfCalls : CallSsAction
  • Activated : PdpContext
  • ActivatePending : PdpContextManager
  • Activation : InputParser
  • ActivationRejectedByGgsn : PdpContext
  • ActiveFrameBackground : Color
  • ActiveFrameBackgroundColor : CTResourcePack
  • ActiveFrameForeground : Color
  • ActiveFrameForegroundColor : CTResourcePack
  • ActiveMode : IconState
  • ActiveTitle : Font
  • ActiveWindowTitle : Color
  • ActualViewProp : GuiObjectFactory
  • AD1 : ThaiTextRenderer
  • AD2 : ThaiTextRenderer
  • AD3 : ThaiTextRenderer
  • Adc : InternalTracer
  • AddHeldCall : CallSsAction
  • AddressingScheme16Bit : InformationElement
  • AddressingScheme8Bit : InformationElement
  • AdjustWinTitleProp : GuiObjectFactory
  • AdpcmDspFormat : StreamAudioReference
  • Afrikaans : LanguageManager
  • AirplaneOn : StartUp
  • AlarmOn : StartUp
  • AlarmReached : RealTimeClock
  • Albanian : LanguageManager
  • AlertClassType : GuiObjectFactory
  • AlignInfoProps : GuiObjectFactory
  • AlignInfoPropsType : GuiObjectFactory
  • All : Control::ComponentIterator, Led
  • AllAsyncServices : InputParser
  • AllBarrServices : InputParser
  • AllBearerServices : InputParser
  • AllCF : InputParser
  • AllConditionalCF : InputParser
  • AllDataCircuitAsync : InputParser
  • AllDataCircuitSync : InputParser
  • AllDataServices : InputParser
  • AllGPRSBearerServices : InputParser
  • AllocationError : SvgPlayer
  • AllServices : InputParser
  • AllSsServices : InputParser
  • AllSyncServices : InputParser
  • AllTeleServices : InputParser
  • AllTeleServicesExceptSMS : InputParser
  • AllUUSServices : InputParser
  • AlphabetNotSupported : ShortMessageFailureCause
  • AlphaIdentifierTag : Tlv
  • Alphanumeric : TypeOfAddress
  • AlphanumMode : EditBox
  • AlphanumNameMode : EditBox
  • AlreadyExistsError : File
  • AlreadyOpenError : File
  • AlreadySet : SvgPlayer
  • Always : InternalTracer
  • AmrDspFormat : StreamAudioReference
  • AmrDtxEnd : CodecDevice
  • AmrDtxOff : CodecDevice
  • AmrDtxOn : CodecDevice
  • AmrFrameFormatConformance : CodecDevice
  • AmrFrameFormatEnd : CodecDevice
  • AmrFrameFormatIf1 : CodecDevice
  • AmrFrameFormatIf2 : CodecDevice
  • AmrFrameFormatMime : CodecDevice
  • AmrFrameFormatUndefined : CodecDevice
  • AndFilterOp : DualFilterProvider
  • AndRop : DeviceContext
  • Angular : CTResourcePack
  • ANIM_OUTPUT_MSG : TestWriter
  • AnimatedStyle : AbstractItemRenderer
  • AnimatedTextLineAnimType : GuiObjectFactory
  • AnimatedTextLineClassType : GuiObjectFactory
  • AnimationLoadFailureError : SvgPlayer
  • AnimSpeedProp : GuiObjectFactory
  • Anniversary : CalendarRecord
  • Ansi136 : ProtocolIdentifier
  • AntiflickerChanged : Camera
  • AntiFlickerDisabled : Camera
  • AntiFlickerHz50 : Camera
  • AntiFlickerHz60 : Camera
  • AntiFlickerNotSupported : Camera
  • AntiFlickerType : Camera, CameraOptionSettingsWin
  • Antitearing : VideoChannel
  • Apc : InternalTracer
  • App1 : InternalTracer
  • App2 : InternalTracer
  • App3 : InternalTracer
  • App4 : InternalTracer
  • APP_EXIT_MSG : TestWriter
  • APP_LOAD_MSG : TestWriter
  • APP_NAME_LENGTH : InternalTracer
  • AppBegin : InternalTracer
  • AppEnd : InternalTracer
  • Append : FfsFile, RegBlobObject, ElementList< T >, ByteBuffer, BlobObject, SmsFactory, UserData, UserDataHeader, Cbs::Filter, FfsHandler, HttpResponse, GltpAssistanceData, RamHandler, RamFileObj, FatHandler, PbRecordProvider, Provider
  • AppIdProp : GuiObjectFactory
  • APPLICATION : ExecutionContext
  • ApplicationControlError : Camera
  • AppParams : ObexHeader
  • April : Date
  • Arabic : LanguageManager, DataCodingScheme
  • Archive : SmsSettingsRecord, File::Attributes
  • Armenian : LanguageManager
  • ArrayTooShort : CodecDevice
  • Asc : InternalTracer
  • AssemblingError : Sms
  • Asynchronous : MessageHook
  • At : AtCommand
  • Ata : AtCommand
  • AtCbst : AtCommand
  • AtCeer : AtCommand
  • AtCgact : AtCommand
  • AtCgactQuery : AtCommand
  • AtChld : AtCommand
  • AtClcc : AtCommand
  • AtClip : AtCommand
  • AtClir : AtCommand
  • AtCmee : AtCommand
  • AtColp : AtCommand
  • AtCops : AtCommand
  • AtCrc : AtCommand
  • Atd : AtCommand
  • Ath : AtCommand
  • AtHandlerType : ExternalCommunicationHandler
  • AtlItemBoxClassType : GuiObjectFactory
  • AtlWindowClassType : GuiObjectFactory
  • AtomicItem : EditorItemNode
  • AttachPending : PdpContextManager
  • AtTypeInvalid : AtCommand
  • AtXcallrefuse : AtCommand
  • AtXcallstat : AtCommand
  • AtXcaoc : AtCommand
  • AtXceer : AtCommand
  • AtXprogress : AtCommand
  • AtXservice : AtCommand
  • AudioAccessoryCfgBackspeaker_NormalMic : AudioAccessoryDetails
  • AudioAccessoryCfgBluetoothHandsfree : AudioAccessoryDetails
  • AudioAccessoryCfgBluetoothHeadset : AudioAccessoryDetails
  • AudioAccessoryCfgBluetoothHeadsetRinger : AudioAccessoryDetails
  • AudioAccessoryCfgCarKit : AudioAccessoryDetails
  • AudioAccessoryCfgExtRingerBackspeaker : AudioAccessoryDetails
  • AudioAccessoryCfgExtRingerHeadset : AudioAccessoryDetails
  • AudioAccessoryCfgExtRingerStereoPhones : AudioAccessoryDetails
  • AudioAccessoryCfgHeadset : AudioAccessoryDetails
  • AudioAccessoryCfgNormal : AudioAccessoryDetails
  • AudioAccessoryCfgRecordingBackspeaker : AudioAccessoryDetails
  • AudioAccessoryCfgRecordingNormal : AudioAccessoryDetails
  • AudioAccessoryCfgStereoPhones : AudioAccessoryDetails
  • AudioAccessoryCfgTTY : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined1 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined11 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined12 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined13 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined14 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined15 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined16 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined17 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined18 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined19 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined2 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined3 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined4 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined5 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined6 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined7 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined8 : AudioAccessoryDetails
  • AudioAccessoryCfgUserDefined9 : AudioAccessoryDetails
  • AudioAndVideo : MediaPlayer
  • AudioBasedCall : XCallInfoResponseParser
  • AudioChannelBoth : RadioAudioDevice
  • AudioChannelLeft : RadioAudioDevice
  • AudioChannelRight : RadioAudioDevice
  • AudioDataTypeImelody : AudioUtility
  • AudioDataTypeMidi : AudioUtility
  • AudioDataTypeMp3 : AudioUtility
  • AudioDataTypeSmaf : AudioUtility
  • AudioDataTypeSmafPhrase : AudioUtility
  • AudioDataTypeUnknown : AudioUtility
  • AudioDeviceEndId : AudioDeviceManager
  • AudioInvalidTone : Audio
  • AudioOnly : MediaPlayer
  • AudioPathDownlink : AudioPath
  • AudioPathUplink : AudioPath
  • AudioRcAudioDriverDisabled : GenericAudioDevice
  • AudioRcDeviceAlreadyInitialized : GenericAudioDevice
  • AudioRcDeviceNotInitialized : GenericAudioDevice
  • AudioRcError : GenericAudioDevice
  • AudioRcErrorAllocateHW : GenericAudioDevice
  • AudioRcFileCloseError : GenericAudioDevice
  • AudioRcFileNotFound : GenericAudioDevice
  • AudioRcFormatNotSupported : GenericAudioDevice
  • AudioRcfunctionalityNotAvailable : GenericAudioDevice
  • AudioRcHandleNotUsed : GenericAudioDevice
  • AudioRcMimeTypeNotSupported : GenericAudioDevice
  • AudioRcMp3Info : GenericAudioDevice
  • AudioRcNoHwSupport : GenericAudioDevice
  • AudioRcOk : GenericAudioDevice
  • AudioRcParameterOutOfRange : GenericAudioDevice
  • AudioRcRadioInfo : GenericAudioDevice
  • AudioRcResourceConflict : GenericAudioDevice
  • AudioRcResourceInUse : GenericAudioDevice
  • AudioRcRingerToneError : GenericAudioDevice
  • AudioRcRingerToneFinish : GenericAudioDevice
  • AudioRcSharingViolation : GenericAudioDevice
  • AudioRcStartParamNotSet : GenericAudioDevice
  • AudioRcToneFinish : GenericAudioDevice
  • AudSamplFreqNotSupported : MediaManager
  • August : Date
  • AuthChallenge : ObexHeader
  • AuthenticatePending : PdpContextManager
  • AuthenticationFailure : PdpContext
  • AuthMethodHttpBasic : WapProfile
  • AuthMethodHttpDigest : WapProfile
  • AuthMethodWtlsSs : WapProfile
  • AuthResponse : ObexHeader
  • Auto : JapaneseTranscoder
  • AutoBalance : Camera
  • AutoCapitalization : MultiTapInputMapper
  • AutoClearEnabledProp : GuiObjectFactory
  • AutoLayoutProp : GuiObjectFactory
  • AutomaticDeletionGroup : DataCodingScheme
  • AutomaticFlash : Camera
  • AutostartProp : GuiObjectFactory
  • AutoValue : CamWin32
  • Aux : InternalTracer
  • AuxiliarySpeech : InputParser, XCallInfoResponseParser
  • AV1 : ThaiTextRenderer
  • AV2 : ThaiTextRenderer
  • AV3 : ThaiTextRenderer
  • AvailableAttributeId : Feature
  • AvrcpConnected : BtAvrcpControllerApplicationWindow
  • AvrcpConnectedAndActive : BtAvrcpControllerApplicationWindow
  • AvrcpNotConnected : BtAvrcpControllerApplicationWindow
  • AvrcpNotSelected : BtAvrcpControllerApplicationWindow
  • AvsBusy : AbstractTransport
  • AvsConflict : AbstractTransport
  • AvsDisabled : AbstractTransport
  • AvsReady : AbstractTransport
  • AwaitingFastForwardRespState : MediaPlayer
  • AwaitingInitResp : MediaRecorder, MediaPlayer
  • AwaitingPauseRespState : MediaRecorder, MediaPlayer
  • AwaitingPlayRespState : MediaPlayer
  • AwaitingRecordRespState : MediaRecorder
  • AwaitingRewindRespState : MediaPlayer
  • AwaitingStopRespState : MediaRecorder, MediaPlayer
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- j -

  • January : Date
  • Japanese : LanguageManager
  • Jis : JapaneseTranscoder
  • JointStereoChannelMode : AudioEncoder
  • JpegEncodingError : Camera
  • JpegFormat : CamWin32
  • July : Date
  • June : Date
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- k -

  • Kernel : InternalTracer
  • KEY_RECEIVED_MSG : TestWriter
  • KeyAutoRepeat : Keyboard
  • KeyAutoRepeatType : InputMapItem
  • Keyboard : OptionalConfigBase, Led
  • KeyboardCategory : AbstractDevice
  • KeyDown : Keyboard
  • KeyDownType : InputMapItem
  • KeyTone1 : KeyToneAudioDevice
  • KeyTone2 : KeyToneAudioDevice
  • KeyTone3 : KeyToneAudioDevice
  • KeyTone4 : KeyToneAudioDevice
  • KeyTone5 : KeyToneAudioDevice
  • KeyUp : Keyboard
  • KeyUpType : InputMapItem
  • Kissing : InformationElement
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- l -

  • LabelProp : GuiObjectFactory
  • LanguageDependend : InformationElement
  • LanguageGroup00 : DataCodingScheme
  • LanguageGroup01 : DataCodingScheme
  • LanguageGroup10 : DataCodingScheme
  • LanguageGroup11 : DataCodingScheme
  • LanguageSelectionGroup : DataCodingScheme
  • LanguageSelectionWithinMessageGroup : DataCodingScheme
  • LaNotAllowed : PdpContext
  • Large : InformationElement
  • LargeAnimation : InformationElement
  • LargeIconProp : GuiObjectFactory
  • LargePicture : InformationElement
  • LargeSize : IconState
  • Last : AbstractSmsViewerWin
  • LastFrameFlag : VideoDecoder
  • LastPacketInFrameFlag : VideoDecoder
  • LastSectionEntry : Desktop
  • Latin : LanguageManager
  • Latvian : LanguageManager
  • LayouterControlClassType : GuiObjectFactory
  • LcsDGpsCorrectionDataMessage : MessageIdentifier
  • LcsEOtdAssistanceDataMessage : MessageIdentifier
  • LcsGpsAlmanacAndOtherDataMessage : MessageIdentifier
  • LcsGpsEphemerisAndClockCorrectionDataMessage : MessageIdentifier
  • LeafType : RegIterator
  • LedCategory : AbstractDevice
  • Left : TextFormat, Layouter, GridLayout, Control::NavigationGuidance, AbstractGrid, Indicator, InformationElement
  • LeftAlign : EditorDocument
  • LeftJustifiedWrap : EditorDocument
  • LeftPos : TabButton
  • LeftSection : Desktop
  • LeftSoftkeyProp : GuiObjectFactory
  • LeftToRight : Locale
  • LeftToRightType : BidiManager
  • Length : ObexHeader
  • LengthOfAckNackTestParamCntArray : AckNackParamList
  • LengthOfBlerArray : BlerTrchInfoList
  • LengthOfCiTestparamArray : CiTestParamList
  • LengthOfCOverIArray : COverIList
  • LengthOfPlmnArray : EquivPlmnLists
  • LessType : StandardJoinRule
  • LetterboxScaling : Camera, VideoChannel
  • LightColor : CTResourcePack
  • LightOrigin : CTResourcePack
  • LightOriginParseType : CTResourcePack
  • LightShadow : CTResourcePack
  • LineEditorClassType : GuiObjectFactory
  • LineHeightProp : GuiObjectFactory
  • LinkedResponseUnexpected : TaggedProblemCode
  • Lithuanian : LanguageManager
  • LlcOrSndcpFailure : PdpContext
  • LlcSapi_1 : PdpContext::ActivationStatus
  • LlcSapi_11 : PdpContext::ActivationStatus
  • LlcSapi_3 : PdpContext::ActivationStatus
  • LlcSapi_5 : PdpContext::ActivationStatus
  • LlcSapi_7 : PdpContext::ActivationStatus
  • LlcSapi_9 : PdpContext::ActivationStatus
  • LlcSapi_Invalid : PdpContext::ActivationStatus
  • LlcSapi_NotAssigned : PdpContext::ActivationStatus
  • Locale : OptionalConfigBase
  • LocalTime : DateTime
  • LocationAreaWideNormal : Cbs::SerialNumber
  • LocationServicesRangeBegin : MessageIdentifier
  • LocationServicesRangeEnd : MessageIdentifier
  • Lock : SmsBasicProvider, PbRecordProvider, PbRecordHandler, AbstractLockableDevice, ThreadSafeProvider, Provider, Protector, AbstractDelegationProvider, HandlerData, Registry, ObjectTreeService, MergeProvider, JoinProvider, AppendProvider, RecordHandler, RegEncoderDecoder, SmsSocketListener
  • Locked : RegEncoderDecoder
  • LockedShiftstate : EditBox
  • Long : InternalTracer
  • LongDateDM : Date
  • LongDateDMY : Date
  • LongDateWDM : Date
  • LongDateWDMY : Date
  • LongKeyPress : Keyboard
  • LongKeyPressType : InputMapItem
  • LongType : ObexHeader
  • LoudnessAllocation : AudioEncoder
  • Low : ToDoRecord
  • LowBattery : Charger
  • LowerLeft : CTResourcePack
  • LowerRight : CTResourcePack
  • LowQuality : DisplaySettings
  • LV : ThaiTextRenderer
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- m -

  • m_nHeaderSize : UdpTestSocket, TcpTestSocket
  • Macedonian : LanguageManager
  • MaFli50Hz : CameraOptionSettingsWin
  • MaFli60Hz : CameraOptionSettingsWin
  • MaFliLast : CameraOptionSettingsWin
  • MaFliOff : CameraOptionSettingsWin
  • MaFlsAuto : CameraOptionSettingsWin
  • MaFlsLast : CameraOptionSettingsWin
  • MaFlsOff : CameraOptionSettingsWin
  • MaFlsRedEye : CameraOptionSettingsWin
  • MainMenu : PbAbstractWin
  • Malay : LanguageManager
  • Maltese : LanguageManager
  • MappingPolicyClassType : GuiObjectFactory
  • MappingPolicyProp : GuiObjectFactory
  • March : Date
  • marked : ToDoRecord
  • MarkedPropertyId : Item
  • MaskAlphaBlending : DeviceContext
  • MaWbAuto : CameraOptionSettingsWin
  • MaWbIndoor : CameraOptionSettingsWin
  • MaWbLast : CameraOptionSettingsWin
  • MaWbOutdoor : CameraOptionSettingsWin
  • MAX_DATA_LENGTH : InternalTracer
  • MAX_LEN_TARGET : BtObexServiceTable
  • MAX_PATHNAME_LENGTH : Pathname
  • MAX_SIZE : MlcNumber, ClientName, ClientId
  • MAX_STORAGE_DEVICE_ID_LENGTH : RootFileSystem
  • MaxDataElementsPerMeasId : UmtsMeasIdParam
  • MaxDecoderDelay : OptionalConfigBase
  • MaxEncoderDelay : OptionalConfigBase
  • MaxGsmBands : GsmBandList
  • MaxHeaderLength : ObexHeader
  • MaximizedProp : GuiObjectFactory
  • Maximum : AbstractSmsApp
  • MaxListSize : NeighbourCellList
  • MaxMeas : UmtsMeasEvalParam
  • MaxNumberOfCodersReached : CodecDevice
  • MaxNumberOfMptyParticipantsExceeded : SsErrorCode
  • MaxNumberOfOperationsReached : CodecDevice
  • MaxTextLengthProp : GuiObjectFactory
  • MaxTotalUmtsCells : UmtsCellList
  • MaxValueProp : GuiObjectFactory
  • May : Date
  • MC : InputParser
  • MeanRate100 : PdpContext::QualityOfService
  • MeanRate100K : PdpContext::QualityOfService
  • MeanRate10K : PdpContext::QualityOfService
  • MeanRate10M : PdpContext::QualityOfService
  • MeanRate1K : PdpContext::QualityOfService
  • MeanRate1M : PdpContext::QualityOfService
  • MeanRate200 : PdpContext::QualityOfService
  • MeanRate200K : PdpContext::QualityOfService
  • MeanRate20K : PdpContext::QualityOfService
  • MeanRate20M : PdpContext::QualityOfService
  • MeanRate2K : PdpContext::QualityOfService
  • MeanRate2M : PdpContext::QualityOfService
  • MeanRate500 : PdpContext::QualityOfService
  • MeanRate500K : PdpContext::QualityOfService
  • MeanRate50K : PdpContext::QualityOfService
  • MeanRate50M : PdpContext::QualityOfService
  • MeanRate5K : PdpContext::QualityOfService
  • MeanRate5M : PdpContext::QualityOfService
  • MeanRateBestEffort : PdpContext::QualityOfService
  • MeanRateReserved : PdpContext::QualityOfService
  • MeanRateSubscribed : PdpContext::QualityOfService
  • MeDataDownload : ProtocolIdentifier
  • MeDepersonalizationShortMessage : ProtocolIdentifier
  • MediaAvailableStatusNotification : StorageDevice
  • MediaFailureError : File
  • MediaInfoObtainedMsg : MediaManager
  • MediaMmc : VoiceMemoAudioDevice
  • MediaNotSupported : MediaManager, CodecDevice
  • MediaRam : VoiceMemoAudioDevice
  • MediaTypeDifferent : MediaManager
  • MediaTypeFfs : VoiceMemoAudioDevice
  • MediaTypeNotSupportedMsg : MediaManager
  • MEditorProp : GuiObjectFactory
  • Medium : ToDoRecord
  • MediumQuality : DisplaySettings
  • Meeting : CalendarRecord
  • Mem : InternalTracer
  • MemNotAvailableError : File
  • Memo : CalendarRecord
  • MemoryCapacityExceeded : Sms, ShortMessageFailureCause
  • MemoryError : File
  • MemoryFull : Sms
  • Menu : Menu, Font, AbstractMenuAccessor
  • MENU_ACTIVATED_MSG : TestWriter
  • MENU_CHANGED_MSG : TestWriter
  • MENU_CLOSED_MSG : TestWriter
  • MENU_OPENED_MSG : TestWriter
  • MenuDescClassType : GuiObjectFactory
  • MenuFunction : T9InputConfig
  • MenuIdProp : GuiObjectFactory
  • MenuMapClassType : GuiObjectFactory
  • MenuMapMenuDescProp : GuiObjectFactory
  • MenuMapMenuIdsProp : GuiObjectFactory
  • MenuPositionProp : GuiObjectFactory
  • MenuPropertiesClassType : GuiObjectFactory
  • MenuPropertiesProp : GuiObjectFactory
  • MenuResourceTableEntryMenuIdProp : GuiObjectFactory
  • MenuResourceTableEntryProp : GuiObjectFactory
  • MenuResourceTableEntryResourceIdProp : GuiObjectFactory
  • MenuResourceTableSizeProp : GuiObjectFactory
  • MenuResourceTableType : GuiObjectFactory
  • MenuSelection : SimTkProfile
  • MenuType : MenuProperties, GuiObjectFactory
  • MenuTypeProp : GuiObjectFactory
  • MergeOnly : MergeProvider
  • Message : Message, InternalTracer
  • MESSAGE_RECEIVED_MSG : TestWriter
  • MESSAGE_SENT_MSG : TestWriter
  • MessageBoxClassType : GuiObjectFactory
  • MessageBoxType : GuiObjectFactory
  • MessageClassNotSupported : ShortMessageFailureCause
  • MessageHandlingFacility : ProtocolIdentifier
  • MessageProp : GuiObjectFactory
  • MessageWaitingActive : DataCodingScheme
  • MessageWaitingInactive : DataCodingScheme
  • MessageWaitingInvalid : DataCodingScheme
  • METHOD_CALLED_MSG : TestWriter
  • MicGain : BtHsVolumeSettingsWin, BtHfVolumeSettingsWin
  • Middle : Layouter, GridLayout, FlowLayout, IndicatorLocation
  • MiddlePos : TabButton
  • MIDIRingerDeviceID : AudioDeviceManager
  • MinGetFragSize : ObexDataServer
  • MinSizeProp : GuiObjectFactory
  • MinuteTick : RealTimeClock
  • MinValueProp : GuiObjectFactory
  • Mirror : DeviceContext, CamWin32, VideoChannel, Camera
  • MirrorRot180 : DeviceContext
  • MirrorRot270 : DeviceContext
  • MirrorRot90 : DeviceContext
  • MirrorRotate180 : CamWin32, Camera
  • MirrorRotate180Transformation : VideoChannel
  • MirrorRotate270 : CamWin32, Camera
  • MirrorRotate270Transformation : VideoChannel
  • MirrorRotate90 : CamWin32, Camera
  • MirrorRotate90Transformation : VideoChannel
  • MirrorTransformation : VideoChannel
  • Misc : InternalTracer
  • MissingDataError : Image
  • MissingOrUnknownApn : PdpContext
  • MissingPduIE : BaseInformationElement
  • MistypedComponent : TaggedProblemCode
  • MistypedErrorParameter : TaggedProblemCode
  • MistypedProParameter : TaggedProblemCode
  • MistypedResParameter : TaggedProblemCode
  • MmCallDisconnected : CallEvent
  • MmCallReleased : CallEvent
  • MmcMedia : StreamAudioReference
  • MmfGetAudioTrackInfo : AudioDeviceBase
  • MmfMedia : StreamAudioReference
  • MmfResumeFeature : AudioDeviceBase
  • MmfSuspendFeature : AudioDeviceBase
  • Mmi : InternalTracer
  • MmiSimBacklightStateId : MmiSimServer
  • MmiSimCharId : MmiSimServer
  • MmiSimClipStateId : MmiSimServer
  • MmiSimDisplayUpdateDataId : MmiSimServer
  • MmiSimDisplayUpdateHeaderId : MmiSimServer
  • MmiSimKeyDownId : MmiSimServer
  • MmiSimKeyUpId : MmiSimServer
  • MmiSimLedStateId : MmiSimServer
  • MmiSimPenDownId : MmiSimServer
  • MmiSimPenMoveId : MmiSimServer
  • MmiSimPenUpId : MmiSimServer
  • MmiSimPowerStateId : MmiSimServer
  • MmiSimVibrationStateId : MmiSimServer
  • MmMocEstablished : CallEvent
  • MmMocInSetup : CallEvent
  • MmMocRejected : CallEvent
  • MmMtcEstablished : CallEvent
  • MmMtcIsWaiting : CallEvent
  • MobileOriginated : ShortMessageFailureCause, MessageTypeIndicator
  • MobileOriginatedCall : MmCallInfo
  • MobileShutdown : RegEncoderDecoder
  • MobileStation : PdpContext
  • MobileTerminated : ShortMessageFailureCause, MessageTypeIndicator
  • MobileTerminatedCall : MmCallInfo
  • MOC : XCallInfoResponseParser
  • MoCallDialing : XCallInfoResponseParser
  • MoCallRequested : XCallInfoResponseParser
  • MocEstablished : CallEvent
  • MocInSetup : CallEvent
  • MocRejected : CallEvent
  • MocRemoteUserAlerted : XCallInfoResponseParser
  • MocSetupRejected : XCallInfoResponseParser
  • ModalProp : GuiObjectFactory
  • ModeBluetoothHeadset : Audio
  • ModeHandsfree : Audio
  • ModeHeadset : Audio
  • ModeMono : RadioAudioDevice
  • ModeNormal : Audio
  • ModeProp : GuiObjectFactory
  • ModeStereo : RadioAudioDevice
  • ModificationCompleted : XCallInfoResponseParser
  • ModificationDate : File::Attributes
  • ModificationIndicated : XCallInfoResponseParser
  • ModificationRejected : XCallInfoResponseParser
  • ModificationStarted : XCallInfoResponseParser
  • ModificationStateNotValid : XCallInfoResponseParser
  • ModificationTime : File::Attributes
  • Monday : Date
  • Mono : CodecDevice
  • MonoChannelMode : AudioEncoder
  • Monochrome : VirtualDisplay
  • MonoStereoConfigEnd : CodecDevice
  • Monthly : CalendarRecord
  • Mp3 : MediaInfo, CodecDevice
  • MP3DeviceID : AudioDeviceManager
  • MP3DspFormat : StreamAudioReference
  • Mpeg4Aac : MediaInfo, CodecDevice
  • Mpeg4AacPlusV1 : MediaInfo, CodecDevice
  • Mpeg4AacPlusV2 : MediaInfo, CodecDevice
  • Mpeg4Sp : MediaInfo, CodecDevice
  • MsgNotCompatible : PdpContext, Sms
  • MsgTypeData : SimCphsHandler
  • MsgTypeFax : SimCphsHandler
  • MsgTypeLine1 : SimCphsHandler
  • MsgTypeLine2 : SimCphsHandler
  • MsgTypeNonExistent : Sms
  • MsgTypeNotCompatible : PdpContext
  • MsgTypeNotExistent : PdpContext
  • MsgWaitingIndDiscardGroup : DataCodingScheme
  • MsgWaitingIndication : SmsIndicationState
  • MsgWaitingIndStoreDefaultGroup : DataCodingScheme
  • MsgWaitingIndStoreUcs2Group : DataCodingScheme
  • MsIntSsError : SsErrorCode
  • MsIntSsTimeOut : SsErrorCode
  • MSP : InputParser
  • mt_data_conn_established : DataConn
  • mt_data_conn_init : DataConn
  • mt_data_conn_init_release : DataConn
  • mt_data_conn_released : DataConn
  • mt_data_conn_setup_blocked : DataConn
  • mt_data_conn_setup_failed : DataConn
  • MTC : XCallInfoResponseParser
  • MtcAccepted : XCallInfoResponseParser
  • MtcBcNegotiated : XCallInfoResponseParser
  • MtcConfirmed : XCallInfoResponseParser
  • MtcEstablished : CallEvent
  • MtcIndicated : XCallInfoResponseParser
  • MtcIsWaiting : CallEvent
  • MultiLineEditorClassType : GuiObjectFactory
  • MultiLineProp : GuiObjectFactory
  • MultiMediaEditorClassType : GuiObjectFactory
  • MultiPartyCompleted : XCallInfoResponseParser
  • MultiPartyHeldCompleted : XCallInfoResponseParser
  • MultiPartyHeldRejected : XCallInfoResponseParser
  • MultiPartyHeldStarted : XCallInfoResponseParser
  • MultipartyJoin : CallEvent
  • MultiPartyOnHold : CallEvent
  • MultiPartyRejected : XCallInfoResponseParser
  • MultiPartyReleased : CallEvent
  • MultiPartyRetrieveCompleted : XCallInfoResponseParser
  • MultiPartyRetrieved : CallEvent
  • MultiPartyRetrieveRejected : XCallInfoResponseParser
  • MultiPartyRetrieveStarted : XCallInfoResponseParser
  • MultiPartySplitCompleted : XCallInfoResponseParser
  • MultiPartySplitRejected : XCallInfoResponseParser
  • MultiPartySplitStarted : XCallInfoResponseParser
  • MultiPartySplitted : CallEvent
  • MultiPartyStarted : XCallInfoResponseParser
  • MultiTab : InputMapper
  • MultiTap : InputMapper
  • MuteDownlink : SpeechAudioDevice, Audio
  • MuteTch : Audio
  • MuteUpDownlink : SpeechAudioDevice
  • MuteUplink : SpeechAudioDevice, Audio
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- n -

  • Name : ObexHeader, InputMapper
  • NameCapitalization : MultiTapInputMapper
  • NameProv : PhonebookApp
  • NationalNumber : TypeOfAddress
  • NationalNumberingPlan : TypeOfAddress
  • NationalPagingSystem : ProtocolIdentifier
  • NationalRoamingNotAllowed : PdpContext
  • NaturalReason : AudioPlayerEvent
  • NegativeFilter : Camera
  • NegativePwCheck : SsErrorCode
  • NeighbourCells : TestparamReport
  • Network : PdpContext
  • NetworkErrBandWidthTooHigh : MediaManager
  • NetworkErrConnectFailed : MediaManager
  • NetworkErrConnErr : MediaManager
  • NetworkErrConnLostErr : MediaManager
  • NetworkErrCriticalError : MediaManager
  • NetworkErrHTTPError : MediaManager
  • NetworkErrRtpDataError : MediaManager
  • NetworkErrSdpFileOpenError : MediaManager
  • NetworkErrSdpParseError : MediaManager
  • NetworkErrUnknown : MediaManager
  • NetworkErrUnknownServError : MediaManager
  • NetworkErrUrlNotFound : MediaManager
  • NetworkErrUrlNotStreamable : MediaManager
  • NetworkFailure : PdpContext
  • NetworkMsgRtcpByeReceived : MediaManager
  • NetworkOutOfOrder : Sms
  • NetworkProvided : PhoneNumber
  • NetworkRequestPending : PdpContextManager
  • NetworkSpecificNumber : TypeOfAddress
  • NeutralType : BidiManager
  • New : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile, InternalTracer
  • NewSmsIndication : SmsIndicationState
  • NewStatRepIndication : SmsIndicationState
  • Next : VoiceMemoMenuAccessor, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, DataConnAccessor, WindowHierarchyIterator, ThemeViewIterator, Control::ComponentIterator, ScanlineAccessor, TextMenuAccessor, AbstractMenuAccessor, CompoundItemIterator, ActionMenuAccessor, AbstractSmsViewerWin
  • NextFunction : T9InputConfig
  • NO_PROVIDERS : BootControl, BootState
  • NoAnimation : ItemRendererProperties
  • NoAnswer : AtResponse
  • NoBufferFreeError : BufferPoolManager
  • NoCall : MmCallInfo
  • NoCarrier : AtResponse
  • NoClass : DataCodingScheme
  • NoConnectionId : ObexHeader
  • NoData : RegEncoderDecoder
  • NoDataCompression : PdpContext
  • NoDialtone : AtResponse
  • NoError : ImageEncoder, Image, Camera, BufferPoolManager, PdpContext, SsErrorCode, Sms, File, SvgPlayer, PngDecoder
  • NoErrorNoIconDisplay : Sms
  • NoErrorType : AudioDeviceBase
  • NoFactoryDefaultFileError : File
  • NoFilter : Camera
  • NoFrame : Control
  • NoHeaderCompression : PdpContext
  • NoId : MessageBox
  • NoIndication : SmsIndicationState
  • NoInterworkingAvailable : ShortMessageStatus
  • NoMediaError : File
  • Non : ThaiTextRenderer
  • None : PbRecordProvider, PdpContext::Authentication, Sms, Accessory, DrmConstraint, MergeProvider, JoinProvider
  • NONE : SerialIoSet
  • NonTransparent : DataCallContext
  • NonTransparentPreferred : DataCallContext
  • NoObjectId : ObexAbstractTransport
  • NoPngFormatError : PngDecoder
  • NoPowerOn : AlarmManager
  • NoProtocol : PdpContext
  • NoRepeat : CalendarRecord
  • NoResponseFromSme : ShortMessageStatus
  • Normal : TextFormat, ProtocolIdentifier, Cbs::Filter
  • normal : ChineseQuickSortProvider
  • NormalCall : XCallInfoResponseParser
  • NormalMode : IconState
  • NormalOn : StartUp
  • NormalTone : CustomToneAudioReference
  • NormalUserTone : ToneAudioDevice
  • Norwegian : LanguageManager, DataCodingScheme
  • NoScaling : Camera, VideoChannel
  • NoScSubscription : ShortMessageFailureCause
  • NoServerId : ObexServerInfo
  • NoSmsOnSim : Sms
  • NoSmsStorageCapabilityInUSim : ShortMessageFailureCause
  • NotAcceptable : BtObexResponseCode
  • NotConnected : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • NotEqualType : StandardJoinRule
  • NotFirstAndSecondFilterOp : DualFilterProvider
  • NotFirstOrSecondFilterOp : DualFilterProvider
  • NotFound : BtObexResponseCode
  • NotFoundError : File
  • NotGreaterType : StandardJoinRule
  • Notification : Led, Property, RegEncoderDecoder
  • NotificationTypeBandLimitsReached : RadioAudioDevice
  • NotificationTypeStationFound : RadioAudioDevice
  • Notify : InputMapper, BtObservableService, Registry, Zi8InputMapper, T9InputMapper, InformationElement
  • NotifyAvStateChanged : AbstractTransport
  • NotifyCanceled : Property
  • NotifyNever : Property
  • NotifyPreviewChanged : Property
  • NotifySet : Property
  • NotifyType : UibApp
  • NotifyValidateSet : Property
  • NotImplemented : BtObexResponseCode
  • NoTitle : MenuProperties
  • NotLessType : StandardJoinRule
  • NotObtainable : ShortMessageStatus
  • NoToneType : AudioPreset
  • NotOpenError : File
  • NotPresent : ValidityPeriodFormat
  • NoTransformation : DeviceContext, CamWin32, Camera, VideoChannel
  • NotScreened : PhoneNumber
  • NotSpecified : TipdBasedActiveWaitDispatcher
  • NotStarted : SocketTestT
  • NoType : PdpContext
  • November : Date
  • NrOfBits : BitField< T >
  • NsapiAlreadyUsed : PdpContext
  • NullParameter : MediaManager, CodecDevice
  • NullProtocol : PdpContext
  • NumberNotAllowed : PhoneNumber
  • NumberOfPwAttemptsViolation : SsErrorCode
  • NumberProv : PhonebookApp
  • NumberType : ContextFeature
  • Numeric : InputMapper
  • NumericMode : EditBox
  • NXorRop : DeviceContext
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- o -

  • OAbort : ObexServer
  • ObexByteOrder : ObexHeader
  • ObexError : ObexResult
  • Obj : InternalTracer
  • ObjectClass : ObexHeader
  • ObjectCreate : InternalTracer
  • ObjectDestroy : InternalTracer
  • ObjectDistributionIndicator : InformationElement
  • ObjectNotWritable : ObexResult
  • ObjectReference : GuiObjectFactory
  • ObtainerProp : GuiObjectFactory
  • OConnect : ObexServer
  • October : Date
  • ODisconnect : ObexServer
  • Off : Led, Control::NavigationGuidance
  • OffShiftstate : EditBox
  • OGet : ObexServer
  • OilpaintFilter : Camera
  • Ok : ObexResult, BtObexResponseCode, SimpleMap< TKey, TValue >, MessageBox, ExtPsdContextListener_SerialTerminal, SerialTerminal, AtResponse
  • OkCancel : MessageBox
  • OkId : MessageBox
  • Once : Animation
  • One_Day : AbstractSmsApp
  • One_hour : AbstractSmsApp
  • One_Week : AbstractSmsApp
  • OneByte : Tlv
  • OnlyOnce : AnimatedTextLine
  • OnlyOnceAnimation : ItemRendererProperties
  • ONone : ObexServer
  • OnShiftstate : EditBox
  • OpDeterminedBarring : Sms
  • OpenFileFailure : MediaManager
  • OpeningError : File
  • OpenWindowActionClassType : GuiObjectFactory
  • OperationAborted : ObexResult
  • OperationAlreadyComplete : ObexResult
  • OperationAlreadyRunning : ObexResult
  • OperationCancelledError : File
  • OperationCompleted : StreamingInfo
  • OperationCompletedSynchroneously : StreamingInfo
  • OperationErroneous : StreamingInfo
  • OperationFailed : StreamingInfo
  • OperationFailedError : File
  • OperationNotAllowedError : File
  • OperationNotCompleted : StreamingInfo
  • OperationNotPermitted : ObexResult
  • OperationNotSupported : ObexResult, StreamingInfo
  • OperationOtherState : StreamingInfo
  • OppImplServerId : ObexServerInfo
  • OPut : ObexServer
  • OrFilterOp : DualFilterProvider
  • OrientationProp : GuiObjectFactory
  • OrRop : DeviceContext
  • Oscillate : Animation
  • OSetPath : ObexServer
  • Other : CalendarRecord
  • OtherMessage : InformationElement, DataCodingScheme
  • Out : PhoneNumber
  • Outbox : SmsSettingsRecord
  • OuterBorderColor : CTResourcePack
  • OuterBorderWidth : CTResourcePack
  • OutgBarrServices : InputParser
  • OutOfMemory : ObexResult, MediaManager, CodecDevice
  • OutOfMemoryError : ImageEncoder, Image, BufferPoolManager, File, SvgPlayer, PngDecoder
  • OverpaintRop : DeviceContext
  • Overwrite : Caret
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- z -

  • Zero : DateTime
  • Zi8 : PredInputMapper, InputMapper
  • ZoomFactorMax : VideoChannel
  • ZoomFactorMin : VideoChannel
  • Zulu : LanguageManager
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- b -

  • BackgrColorProp : GuiObjectFactory
  • BackgroundcolorProp : GuiObjectFactory
  • BackgroundDim : CTResourcePack
  • BackgroundImageProp : GuiObjectFactory
  • BacklightModeAuto : Display
  • BacklightModeOff : Display
  • BacklightModeOn : Display
  • BackLightOff : BackLight
  • BackLightOn : BackLight
  • BacklightTurnedOff : Display
  • BacklightTurnedOn : Display
  • BadFileError : File
  • BadFormatError : File
  • BadlyStructuredComponent : TaggedProblemCode
  • BadMediaError : File
  • BadRequest : BtObexResponseCode
  • BAIC : InputParser
  • BAICroaming : InputParser
  • BandLimitsEuropeUs : RadioAudioDevice
  • BandLimitsJapan : RadioAudioDevice
  • BAOC : InputParser
  • BAOIC : InputParser
  • BAOICexchome : InputParser
  • Baseline : TextFormat
  • Basque : LanguageManager
  • BatteryEmpty : Charger
  • BatteryIdError : Charger
  • BD : ThaiTextRenderer
  • BdnFailed : Sms
  • BearerServiceNotProvisioned : SsErrorCode
  • BestFitScaling : Camera, VideoChannel
  • Bijective : JoinRule
  • BinaryChoiceGetInkey : SimTkProfile
  • BinDataSoundDataSource : AudioReference
  • Birthday : CalendarRecord
  • BITFIELDSIZE : BootState
  • BitPool : AudioEncoder
  • BITS_PER_UINT : HeapVector, BootState
  • BitsPerPixel16 : VirtualDisplay
  • BitsPerPixel24 : VirtualDisplay
  • BitsPerPixel32 : VirtualDisplay
  • BitsPerPixel8 : VirtualDisplay
  • Black : InformationElement
  • BlinkingAnimation : ItemRendererProperties
  • BlobFileType : RegIterator
  • BlobNodeType : RegIterator
  • BlobResponse : RegEncoderDecoder
  • Bold : TextFormat
  • BooleanNodeType : RegIterator
  • BooleanParseType : CTResourcePack
  • BooleanType : GuiObjectFactory
  • bopomofo : ChineseQuickSortProvider
  • BorderCornerMode : CTResourcePack
  • BorderMode : CTResourcePack
  • BorderModeParseType : CTResourcePack
  • BorderWidth : CTResourcePack
  • Both : PhonebookApp, MergeProvider, JoinProvider
  • Bottom : TextFormat, Layouter, GridLayout
  • BottomLeft : ContextMenu, MenuProperties
  • BottomLineGapProp : GuiObjectFactory
  • BottomRight : ContextMenu, MenuProperties
  • BottomSection : Desktop
  • Bounce : AnimatedTextLine
  • BounceAnimation : ItemRendererProperties
  • BoundsProp : GuiObjectFactory
  • bpp_state1_initial : BtBppSndFilePushReqRequest
  • bpp_state2_pushsent : BtBppSndFilePushReqRequest
  • bpp_state3_connect_ind_received_failed : BtBppSndFilePushReqRequest
  • bpp_state3_connect_ind_received_ok : BtBppSndFilePushReqRequest
  • bpp_state4_push_cfm_received_failed : BtBppSndFilePushReqRequest
  • bpp_state4_push_cfm_received_ok_final : BtBppSndFilePushReqRequest
  • bpp_state4_push_cfm_received_ok_send_more : BtBppSndFilePushReqRequest
  • bpp_state5_abort_cfm_received : BtBppSndFilePushReqRequest
  • bpp_state6_disconnect_ind_received : BtBppSndFilePushReqRequest
  • Breton : LanguageManager
  • BrightBlue : InformationElement
  • BrightCyan : InformationElement
  • BrightGreen : InformationElement
  • BrightMagenta : InformationElement
  • BrightnessChanged : Camera
  • BrightnessProperty : CamWin32
  • BrightRed : InformationElement
  • BrightYellow : InformationElement
  • BtAmwAvrcpConnect : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpDeRegister : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpDeviceSelected : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpDisconnect : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpPanelPassthrough : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpRawFrame : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpRegister : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpSubunitInfo : BtAvrcpAlertMessageWindow
  • BtAmwAvrcpUnitInfo : BtAvrcpAlertMessageWindow
  • BtAmwDunConnect : BtAlertMessageWindow
  • BtAmwDunDisconnect : BtAlertMessageWindow
  • BtAmwFaxConnect : BtAlertMessageWindow
  • BtAmwFaxDisconnect : BtAlertMessageWindow
  • BtAmwHfAudio2Hf : BtAlertMessageWindow
  • BtAmwHfAudio2Phone : BtAlertMessageWindow
  • BtAmwHfConnect : BtAlertMessageWindow
  • BtAmwHfDisconnect : BtAlertMessageWindow
  • BtAmwHsCallTransferToHeadset : BtAlertMessageWindow
  • BtAmwHsCallTransferToPhone : BtAlertMessageWindow
  • BtAmwHsConnect : BtAlertMessageWindow
  • BtAmwHsDisconnect : BtAlertMessageWindow
  • BtAmwNotCongested : BtAvrcpAlertMessageWindow
  • BtAmwPair : BtAlertMessageWindow
  • BtAmwQuerySupportedProfiles : BtAlertMessageWindow
  • BtAmwServiceVerify : BtAlertMessageWindow
  • BtAmwSetName : BtAlertMessageWindow
  • BtAmwSupportedProfile : BtAlertMessageWindow
  • BtAmwTrust : BtAlertMessageWindow
  • BtAmwUnpair : BtAlertMessageWindow
  • BtAmwUntrust : BtAlertMessageWindow
  • BtArConnectablity : BtLocalSettings
  • BtArDiscoverability : BtLocalSettings
  • BtArLocalName : BtLocalSettings
  • BtArNone : BtLocalSettings
  • BtArPairability : BtLocalSettings
  • BtArProfileActivation : BtLocalSettings
  • BtArSwitchState : BtLocalSettings
  • BtAvrcpControllerConnectRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerDisconnectRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerSelectDeviceRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerSetActiveDeviceRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerSetInactiveDeviceRequest : BtAvrcpPanelApplication
  • BtAvrcpControllerSubUnitInfoRequest : BtAvrcpPanelApplication
  • BtAvrcpOpenControllerWindow : BtAvrcpPanelApplication
  • BtAvrcpPanelFeatureCount : BtAvrcpPanelApplication
  • BtAvrcpPanelSetActiveSubUnit : BtAvrcpPanelApplication
  • BtDlwFoundDevices : BtDeviceListWindow
  • BtDlwPairedDevices : BtDeviceListWindow
  • BtErOperationFailure : BtOperationBase
  • BtErOperationResultInvalid : BtOperationBase
  • BtErUnknown : BtOperationBase
  • BtErUserBreak : BtOperationBase
  • BtRrwDeviceSearch : BtRequestRunningWindow
  • BtRrwDunDisconnect : BtRequestRunningWindow
  • BtRrwFaxDisconnect : BtRequestRunningWindow
  • BtRrwHfAudio2Hf : BtRequestRunningWindow
  • BtRrwHfAudio2Phone : BtRequestRunningWindow
  • BtRrwHfConnect : BtRequestRunningWindow
  • BtRrwHfDisconnect : BtRequestRunningWindow
  • BtRrwHsCallTransferToHeadset : BtRequestRunningWindow
  • BtRrwHsCallTransferToPhone : BtRequestRunningWindow
  • BtRrwHsConnect : BtRequestRunningWindow
  • BtRrwHsDisconnect : BtRequestRunningWindow
  • BtRrwPair : BtRequestRunningWindow
  • BtRrwQuerySupportedProfiles : BtRequestRunningWindow
  • BtRrwServiceVerify : BtRequestRunningWindow
  • BtRrwSetName : BtRequestRunningWindow
  • BtRrwTrust : BtRequestRunningWindow
  • BtRrwUnknown : BtRequestRunningWindow
  • BtRrwUnpair : BtRequestRunningWindow
  • BtRrwUntrust : BtRequestRunningWindow
  • BufferAdjustedWarning : BufferPoolManager
  • BufferAllocationError : Camera
  • BufferingComplete : MediaManager
  • BufferingCompleteState : MediaPlayer
  • BufferingProp : GuiObjectFactory
  • BufferingStart : MediaManager
  • BufferingStartState : MediaPlayer
  • BufferNotAvailableError : Camera
  • BufferNotExistentError : BufferPoolManager
  • BufferPoolNotAvailableError : BufferPoolManager
  • Bulgarian : LanguageManager
  • Busy : AtResponse
  • ButtonBackground : Color
  • ButtonBackgroundColor : CTResourcePack
  • ButtonForeground : Color
  • ButtonForegroundColor : CTResourcePack
  • BV1 : ThaiTextRenderer
  • BV2 : ThaiTextRenderer
  • Byelorussian : LanguageManager
  • ByteSeqType : ObexHeader
  • ByteType : ObexHeader
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- c -

  • c_account_len_max : DataConnProfile
  • c_addr_family_inet : SysSocketBase, SysSocket
  • c_addr_family_unspec : SysSocketBase, SysSocket
  • c_analog : CsdDataConnProfile
  • c_asot_max : GuidServiceTable
  • c_auth_tcp : Iana
  • c_auth_udp : Iana
  • c_combined_delivery : DrmInfo
  • c_conference_tcp : Iana
  • c_conference_udp : Iana
  • c_copy_buf_size : File
  • c_data_rate_14400 : CsdDataConnProfile
  • c_data_rate_19200 : CsdDataConnProfile
  • c_data_rate_2400 : CsdDataConnProfile
  • c_data_rate_28800 : CsdDataConnProfile
  • c_data_rate_4800 : CsdDataConnProfile
  • c_data_rate_9600 : CsdDataConnProfile
  • c_dataconn_profile_count : WapProfile
  • c_default_idle_timeout : DataConnProfile
  • c_default_linger_timeout : DataConnProfile
  • c_default_max_pending_requests : TcpServerSocket
  • c_display : DrmInfo
  • c_event_adapter_closed : NetAdapter
  • c_event_bearer_lost : Socket
  • c_event_conn_closed : Socket
  • c_event_conn_established : Socket
  • c_event_conn_failed : Socket
  • c_event_conn_req_pending : Socket
  • c_event_data_received : Socket, NetAdapter
  • c_event_data_sent : Socket, NetAdapter
  • c_execute : DrmInfo
  • c_ext_ctx_state_connected : PdpContextManager
  • c_ext_ctx_state_connecting : PdpContextManager
  • c_ext_ctx_state_disconnected : PdpContextManager
  • c_ext_ctx_state_disconnecting : PdpContextManager
  • c_ext_ctx_state_invalid : PdpContextManager
  • c_file_version : DataConnProfileStorage::Header
  • c_flag_add_to_trace_info : VersionInfo
  • c_flag_hide_in_engineering_mode : VersionInfo
  • c_flag_is_build_version : VersionInfo
  • c_flag_never_show_on_display : VersionInfo
  • c_forward : DrmInfo
  • c_forward_lock : DrmInfo
  • c_ftp_data_tcp : Iana
  • c_ftp_data_udp : Iana
  • c_ftp_tcp : Iana
  • c_ftp_udp : Iana
  • c_ftps_data_tcp : Iana
  • c_ftps_data_udp : Iana
  • c_ftps_tcp : Iana
  • c_ftps_udp : Iana
  • c_http_request_method_get : HttpRequest
  • c_http_request_method_post : HttpRequest
  • c_http_tcp : Iana
  • c_http_udp : Iana
  • c_https_tcp : Iana
  • c_https_udp : Iana
  • c_iana_private_ports_begin : Iana
  • c_iana_private_ports_end : Iana
  • c_imap3_tcp : Iana
  • c_imap3_udp : Iana
  • c_imap_tcp : Iana
  • c_imap_udp : Iana
  • c_imaps_tcp : Iana
  • c_imaps_udp : Iana
  • c_increment : Vector< T >
  • c_infinite_timeout : DataConnProfile
  • c_inrease_step : MessageIdentifierContainer
  • c_invalid_id : WapProfile
  • c_invalid_port_no : Iana
  • c_invalid_rec_no : SmsWStringCache
  • c_invalid_set_id : WapProfile
  • c_ipaddr_any : IpAddr
  • c_ipaddr_broadcast : IpAddr
  • c_ipaddr_loopback : IpAddr
  • c_irc_tcp : Iana
  • c_irc_udp : Iana
  • c_ircs_tcp : Iana
  • c_ircs_udp : Iana
  • c_isdn : CsdDataConnProfile
  • c_ldap_tcp : Iana
  • c_ldap_udp : Iana
  • c_max_access_point_name_len : PdpContext
  • c_max_account_len : PdpContext::Authentication
  • c_max_apoxi_no_of_message_identifiers : MessageIdentifierContainer, Cbs::Filter
  • c_max_auth_set : WapProfile
  • c_max_cbs_applications : CbsFilterList
  • c_max_cid_array_len : PdpContextManager
  • c_max_domain : WapProfile
  • c_max_guaranteed_user_data_size : SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver
  • c_max_len : PdpContext::Address
  • c_max_password_len : PdpContext::Authentication
  • c_max_phy_port_set : WapProfile
  • c_max_physical_set : WapProfile
  • c_max_port_services : WapProfile
  • c_max_port_set : WapProfile
  • c_max_profile_name_len1 : WapProfile
  • c_max_proxy_id_len : WapProfile
  • c_max_proxy_name_len : WapProfile
  • c_max_proxy_p_id_len : WapProfile
  • c_max_pwd_len : WapProfile
  • c_max_stack_no_of_data_coding_schemes : Cbs::Filter
  • c_max_stack_no_of_message_identifiers : Cbs::Filter
  • c_max_startpage_len : WapProfile
  • c_max_uris_per_table : LockTable
  • c_max_url_len1 : WapProfile
  • c_max_username_len : WapProfile
  • c_max_wap_profile_count : WapProfile
  • c_name_tcp : Iana
  • c_name_udp : Iana
  • c_nameserver_tcp : Iana
  • c_nameserver_udp : Iana
  • c_netnews_tcp : Iana
  • c_netnews_udp : Iana
  • c_nntp_tcp : Iana
  • c_nntp_udp : Iana
  • c_no_lock : DrmInfo
  • c_no_timeout : DataConnProfile
  • c_none : DrmInfo
  • c_opl_buffer_len : OplEntry
  • c_option_broadcast : SysSocketBase
  • c_option_debug : SysSocketBase
  • c_option_dont_route : SysSocketBase
  • c_option_error : SysSocketBase
  • c_option_keep_alive : SysSocketBase
  • c_option_linger : SysSocketBase
  • c_option_rcv_buf : SysSocketBase
  • c_option_reuse_addr : SysSocketBase
  • c_option_snd_buf : SysSocketBase
  • c_option_tcp_max_seg : SysSocketBase
  • c_option_tcp_no_delay : SysSocketBase
  • c_option_type : SysSocketBase
  • c_passwd_len_max : DataConnProfile
  • c_play : DrmInfo
  • c_pop3_tcp : Iana
  • c_pop3_udp : Iana
  • c_pop3s_tcp : Iana
  • c_pop3s_udp : Iana
  • c_pref_stack_size : SysSocket
  • c_print : DrmInfo
  • c_profile_type_csd : DataConnProfile
  • c_profile_type_psd : DataConnProfile
  • c_run_level_1 : SubSystemManager
  • c_run_level_3 : SubSystemManager
  • c_run_level_5 : SubSystemManager
  • c_run_level_7 : SubSystemManager
  • c_separate_delivery : DrmInfo
  • c_set_tcp : Iana
  • c_set_udp : Iana
  • c_shutdown_stop_rx : SysSocketBase, InetSocket
  • c_shutdown_stop_rx_tx : SysSocketBase, InetSocket
  • c_shutdown_stop_tx : SysSocketBase, InetSocket
  • c_sio_err__already : SerialIoAdapter
  • c_sio_err_acces : SerialIoAdapter
  • c_sio_err_addrnnotvail : SerialIoAdapter
  • c_sio_err_afnosupport : SerialIoAdapter
  • c_sio_err_again : SerialIoAdapter
  • c_sio_err_badf : SerialIoAdapter
  • c_sio_err_busy : SerialIoAdapter
  • c_sio_err_connrefused : SerialIoAdapter
  • c_sio_err_fault : SerialIoAdapter
  • c_sio_err_inprogress : SerialIoAdapter
  • c_sio_err_inval : SerialIoAdapter
  • c_sio_err_max : SerialIoAdapter
  • c_sio_err_nametoolong : SerialIoAdapter
  • c_sio_err_nfile : SerialIoAdapter
  • c_sio_err_noact : SerialIoAdapter
  • c_sio_err_nodev : SerialIoAdapter
  • c_sio_err_nomem : SerialIoAdapter
  • c_sio_err_none : SerialIoAdapter
  • c_sio_err_noopt : SerialIoAdapter
  • c_sio_err_noprotoopt : SerialIoAdapter
  • c_sio_err_nosubdev : SerialIoAdapter
  • c_sio_err_nosys : SerialIoAdapter
  • c_sio_err_notsock : SerialIoAdapter
  • c_sio_err_nscan : SerialIoAdapter
  • c_sio_err_opnotsupp : SerialIoAdapter
  • c_sio_err_protonosupport : SerialIoAdapter
  • c_sio_err_sockstate : SerialIoAdapter
  • c_sio_err_timeout : SerialIoAdapter
  • c_smtp_tcp : Iana
  • c_smtp_udp : Iana
  • c_sock_pf_bt : SerialIoAdapter
  • c_sock_pf_max : SerialIoAdapter
  • c_sock_pf_termio : SerialIoAdapter
  • c_sock_pf_undef : SerialIoAdapter
  • c_ssh_tcp : Iana
  • c_ssh_udp : Iana
  • c_state_logged_in : FtpClient
  • c_state_login_process : FtpClient
  • c_state_not_logged_in : FtpClient
  • c_state_terminated : FtpClient
  • c_table_full : NotificationArray, LockTable
  • c_table_size : NotificationArray
  • c_telnet_tcp : Iana
  • c_telnet_udp : Iana
  • c_telnets_tcp : Iana
  • c_telnets_udp : Iana
  • c_tftp_tcp : Iana
  • c_tftp_udp : Iana
  • c_tpdu_size : Sms
  • c_type_default : InetSocket
  • c_type_dgram : SysSocketBase, SysSocket, InetSocket
  • c_type_raw : SysSocketBase, SysSocket, InetSocket
  • c_type_stream : SysSocketBase, SysSocket, InetSocket
  • c_type_tcp : NetAdapter
  • c_type_udp : NetAdapter
  • c_wap_push_http_tcp : Iana
  • c_wap_push_http_udp : Iana
  • c_wap_push_https_tcp : Iana
  • c_wap_push_https_udp : Iana
  • c_wap_push_tcp : Iana
  • c_wap_push_udp : Iana
  • c_wap_pushsecure_tcp : Iana
  • c_wap_pushsecure_udp : Iana
  • c_wap_vcal_s_tcp : Iana
  • c_wap_vcal_s_udp : Iana
  • c_wap_vcal_tcp : Iana
  • c_wap_vcal_udp : Iana
  • c_wap_vcard_s_tcp : Iana
  • c_wap_vcard_s_udp : Iana
  • c_wap_vcard_tcp : Iana
  • c_wap_vcard_udp : Iana
  • c_wap_wsp_s_tcp : Iana
  • c_wap_wsp_s_udp : Iana
  • c_wap_wsp_tcp : Iana
  • c_wap_wsp_udp : Iana
  • c_wap_wsp_wtp_s_tcp : Iana
  • c_wap_wsp_wtp_s_udp : Iana
  • c_wap_wsp_wtp_tcp : Iana
  • c_wap_wsp_wtp_udp : Iana
  • c_wimd_tcp : Iana
  • c_wimd_udp : Iana
  • c_www_http_tcp : Iana
  • c_www_http_udp : Iana
  • c_www_tcp : Iana
  • c_www_udp : Iana
  • Calculator : InputMapper
  • CallActive : XCallInfoResponseParser
  • CallBarred : SsErrorCode, Sms
  • CallClearing : XCallInfoResponseParser
  • CallControlCallSetupInfo : XCallInfoResponseParser
  • CallDeflectionCompleted : XCallInfoResponseParser
  • CallDeflectionRejected : XCallInfoResponseParser
  • CallDeflectionStarted : XCallInfoResponseParser
  • CallDisconnected : CallEvent
  • CallHeldCompleted : XCallInfoResponseParser
  • CallHeldRejected : XCallInfoResponseParser
  • CallHeldStarted : XCallInfoResponseParser
  • CallInfoNotValid : XCallInfoResponseParser
  • CallIsHeld : CallEvent
  • CallModeNotValid : XCallInfoResponseParser
  • CallReleased : CallEvent
  • CallRemind : CalendarRecord
  • CallRetrieveCompleted : XCallInfoResponseParser
  • CallRetrieved : CallEvent
  • CallRetrieveRejected : XCallInfoResponseParser
  • CallRetrieveStarted : XCallInfoResponseParser
  • CallSetup : XCallInfoResponseParser
  • CallTypeNotValid : XCallInfoResponseParser
  • Calv : AtResponse
  • CameraAlreadyLockedError : Camera
  • CameraNotInitializedError : Camera
  • CameraNotReadyError : Camera
  • Cancel : ObexOppDataSinkPushServer, BtUncancelableRequest, BtServiceVerifyRequest, BtServiceRequest, BtRequest, BtDeviceSearchRequest, BtBipServerService, FileChunkOperator, VrHandler
  • CancelId : MessageBox, DialogWindow
  • CancelStatusReportRequest : CommandType
  • CANNOT_HAPPEN : StateMachine
  • CannotReplaceSm : ShortMessageFailureCause
  • CapacityExceed : Sms
  • CaptionOnLeft : AbstractEditBox
  • CaptionOnTop : AbstractEditBox
  • CaretLeft : AbstractMultiLineEditor
  • CaretLineDown : AbstractMultiLineEditor
  • CaretLineUp : AbstractMultiLineEditor
  • CaretRight : AbstractMultiLineEditor
  • Cartesian : JoinRule
  • CartesianType : StandardJoinRule
  • Catalan : LanguageManager
  • CategoryCounts : CalendarRecord
  • Cbs : Cbs, DataCodingScheme
  • CbsDataSource : SimTextString
  • CCBS : InputParser
  • CCNotPerformed : XCallInfoResponseParser
  • CCNotValid : XCallInfoResponseParser
  • CCPerformed : XCallInfoResponseParser
  • Ccwa : AtResponse
  • Ccwv : AtResponse
  • CD : InputParser
  • Cdev : AtResponse
  • Cdip : AtResponse
  • CdNotValid : XCallInfoResponseParser
  • CellChangeCnts : TestparamReport
  • CellPropsType : GuiObjectFactory
  • CellsProp : GuiObjectFactory
  • CellWideImmediate : Cbs::SerialNumber
  • CellWideNormal : Cbs::SerialNumber
  • Center : Layouter, GridLayout, Control::NavigationGuidance, Indicator, InformationElement
  • CenterBasedMetering : Camera
  • Centered : TextFormat
  • CenteredAlign : EditorDocument
  • CenteredVerticalProp : GuiObjectFactory
  • CFBusy : InputParser
  • CFNoReply : InputParser
  • CFNotReachable : InputParser
  • CFU : InputParser
  • Cgact : AtResponse
  • changed : Provider
  • ChangedMediaError : File
  • ChangePin : SsHandler, InputParser, PinAction
  • ChangePin2 : SsHandler, InputParser
  • Channel1 : RingerAudioDevice
  • Channel2 : RingerAudioDevice
  • Channel3 : RingerAudioDevice
  • Channel4 : RingerAudioDevice
  • ChannelAll : RingerAudioDevice
  • Chap : PdpContext::Authentication
  • Char : InternalTracer
  • ChargeBattery : Charger
  • ChargeEndBatteryIsFull : Charger
  • ChargeEndChargerIsDisconnected : Charger
  • ChargerCategory : AbstractDevice
  • ChargerDisabledBatteryIdError : Charger
  • ChargerDisabledVoltageError : Charger
  • ChargerOn : StartUp
  • ChargerRemoved : Charger
  • ChargingPaused : Charger
  • ChargingResumed : Charger
  • CHECKBOX_ACTIVE_MSG : TestWriter
  • CHECKBOX_SELECTED_MSG : TestWriter
  • CheckBoxControlClassType : GuiObjectFactory
  • Checkered : Brush
  • CheckPoint : InternalTracer
  • ChildOnly : MergeProvider
  • ChimesHigh : InformationElement
  • ChimesLow : InformationElement
  • Chinese : LanguageManager
  • ChordHigh : InformationElement
  • ChordLow : InformationElement
  • Ciev : AtResponse
  • CifSize : CamWin32, Camera
  • Ckev : AtResponse
  • Claps : InformationElement
  • Class0 : DataCodingScheme
  • Class1 : DataCodingScheme
  • Class2 : DataCodingScheme
  • Class3 : DataCodingScheme
  • ClassType_AudioActiveReference : AudioActiveReference
  • ClassType_AudioReference : AudioReference
  • ClassType_CombinedDeviceAudioReference : AudioReference
  • ClassType_CustomIMelodyAudioReference : AudioReference
  • ClassType_CustomRingerAudioReference : AudioReference
  • ClassType_CustomSmafMelodyAudioReference : AudioReference
  • ClassType_CustomSmafPhraseAudioReference : AudioReference
  • ClassType_CustomToneAudioReference : AudioReference
  • ClassType_End : AudioReference
  • ClassType_MP3AudioReference : AudioReference
  • ClassType_PCMAudioReference : AudioReference
  • ClassType_PresetAudioReference : AudioReference
  • ClassType_RingerAudioReference : AudioReference
  • ClassType_SimpleAudioReference : AudioReference
  • ClassType_ToneAudioReference : AudioReference
  • ClassType_VoiceMemoAudioReference : AudioReference
  • Clav : AtResponse
  • Clcc : AtResponse
  • Clear : MediaRefContainer, TextEditorDocument, TextCompoundItem, EditorDocument, CompoundItem, BtSddbServiceRecord, BtSddbDeContainer, BtDeviceList, WString, TypeOfAddress, String, SharedPtr< T_obj >, RegBlobObject, PhoneNumber, ElementList< T >, BlobObject, BitField< T >, RtStreamingBuffer, SmsContext, InputAction, CbsFilterList::CbsFilterListEntry, FunctionalityIndicator, UsimPbFillStatus, UsimPbLocReport, UsimPbGroups, UsimPbChangedField, UsimPbRefRecord, UsimPbRwRecord, Tpdu, SimSetupIdleModeTextOptions, SimSetupMenuOptions, SimSelectItemOptions, SimGetInkeyOptions, SimGetInputOptions, SimDisplayTextOptions, SimIconIdentifier, SimNextActionIdentifier, SimTextString, SimItemIdentifier, SimAlphaIdentifier, SimIconQualifier, SimAtom< T >, ShortMessageStatus, ShortMessageFailureCause, ProtocolIdentifier, ParameterIndicator, MessageTypeIndicator, MessageIdentifierContainer, MessageIdentifier, DataCodingScheme, CommandType, Cbs, Cbs::SerialNumber, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem, TpduCache, TpduHeaderInformation, TpduPhoneNumberPersist, VrHandler
  • Cleared : XCallInfoResponseParser
  • ClearingStateNotValid : XCallInfoResponseParser
  • Client : Font
  • ClientAddrTypeId : ObexAbstractTransport
  • ClientAlreadyClosed : ObexResult
  • ClientAlreadyOpen : ObexResult
  • ClientArea : DrawableObject
  • ClientBackground : Color
  • ClientBackgroundColor : CTResourcePack
  • ClientForeground : Color
  • ClientForegroundColor : CTResourcePack
  • ClientUrlType : BtJsr82Url
  • CliInvalid : XCallInfoResponseParser
  • CliNotAvailable : XCallInfoResponseParser
  • Clip : AtResponse
  • CLIP : InputParser
  • CLIR : InputParser
  • CliValid : XCallInfoResponseParser
  • CliWithheldByOriginator : XCallInfoResponseParser
  • CLOSE_REQ : SerialIoSet
  • CloseAfterTriggerProp : GuiObjectFactory
  • Closed : MmCallInfo
  • CloseWindow : ResultWinBase
  • CloseWindowActionClassType : GuiObjectFactory
  • CloudyBalance : Camera
  • CmeError : AtResponse
  • CNAP : InputParser
  • CodecCategory : AbstractDevice
  • ColCountProp : GuiObjectFactory
  • ColorParseType : CTResourcePack
  • ColorProp : GuiObjectFactory
  • ColorType : GuiObjectFactory
  • Colp : AtResponse
  • COLP : InputParser
  • COLR : InputParser
  • ColumnCountProp : GuiObjectFactory
  • ColumnPropertiesProp : GuiObjectFactory
  • Command : MessageTypeIndicator
  • CommandCannotBePerformed : ShortMessageFailureCause
  • CommandCheckLoad : AudioMapiManager
  • CommandCheckUnload : AudioMapiManager
  • CommandDeviceControl : AudioMapiManager
  • CommandEnd : AudioMapiManager
  • CommandGetContentsData : AudioMapiManager
  • CommandGetMode : AudioMapiManager
  • CommandGetPhraseList : AudioMapiManager
  • CommandInitialize : AudioMapiManager
  • CommandInvalid : AudioMapiManager
  • CommandMelodyClose : AudioMapiManager
  • CommandMelodyControl : AudioMapiManager
  • CommandMelodyLoad : AudioMapiManager
  • CommandMelodyOpen : AudioMapiManager
  • CommandMelodyOpenArgInit : AudioMapiManager
  • CommandMelodySeek : AudioMapiManager
  • CommandMelodyStandby : AudioMapiManager
  • CommandMelodyStart : AudioMapiManager
  • CommandMelodyStop : AudioMapiManager
  • CommandMelodyUnload : AudioMapiManager
  • CommandMelodyWaitReady : AudioMapiManager
  • CommandPhraseAudioClose : AudioMapiManager
  • CommandPhraseAudioControl : AudioMapiManager
  • CommandPhraseAudioLoad : AudioMapiManager
  • CommandPhraseAudioOpen : AudioMapiManager
  • CommandPhraseAudioStandby : AudioMapiManager
  • CommandPhraseAudioStart : AudioMapiManager
  • CommandPhraseAudioStop : AudioMapiManager
  • CommandPhraseAudioUnload : AudioMapiManager
  • CommandPhraseGetLength : AudioMapiManager
  • CommandPhraseGetLink : AudioMapiManager
  • CommandPhraseGetPosition : AudioMapiManager
  • CommandPhraseGetStatus : AudioMapiManager
  • CommandPhraseKill : AudioMapiManager
  • CommandPhrasePause : AudioMapiManager
  • CommandPhrasePlay : AudioMapiManager
  • CommandPhraseRemoveData : AudioMapiManager
  • CommandPhraseRestart : AudioMapiManager
  • CommandPhraseSeek : AudioMapiManager
  • CommandPhraseSetData : AudioMapiManager
  • CommandPhraseSetEvHandler : AudioMapiManager
  • CommandPhraseSetLink : AudioMapiManager
  • CommandPhraseSetPanpot : AudioMapiManager
  • CommandPhraseSetVolume : AudioMapiManager
  • CommandPhraseStop : AudioMapiManager
  • CommandRealtimeMidiClose : AudioMapiManager
  • CommandRealtimeMidiGetChVolume : AudioMapiManager
  • CommandRealtimeMidiOpen : AudioMapiManager
  • CommandRealtimeMidiSendCh : AudioMapiManager
  • CommandRealtimeMidiSendSysExMessage : AudioMapiManager
  • CommandRealtimeMidiSetApiVolume : AudioMapiManager
  • CommandRealtimeStartTimer : AudioMapiManager
  • CommandRealtimeStopTimer : AudioMapiManager
  • CommandReason : AudioPlayerEvent
  • CommandResetMode : AudioMapiManager
  • CommandSetMode : AudioMapiManager
  • CommandTerminate : AudioMapiManager
  • CommandUnsupported : ShortMessageFailureCause
  • Commit : ObexBuffer::Writer, ObexBuffer::Reader, RegEncoderDecoder, PbRecordProvider, Provider
  • CommonPropCount : DataConnApp
  • CompactWrap : EditorDocument
  • CompanionLocation : VideoCamera, CodecDevice
  • CompatibleWithEverything : AudioAccessoryDetails
  • Complete : VrHandler
  • ComponentBackgroundColor : CTResourcePack
  • ComponentClassType : GuiObjectFactory
  • ComponentForegroundColor : CTResourcePack
  • ComponentsProp : GuiObjectFactory
  • Compose : ThaiTextRenderer
  • ComposeSmsType : AbstractSmsApp
  • CompressionControl : InformationElement
  • CompressionProperty : CamWin32
  • ConcatenatedSm16Bit : InformationElement
  • ConcatenatedSm8Bit : InformationElement
  • ConcaveFilter : Camera
  • ConditionalIeError : PdpContext
  • ConfirmId : DialogWindow
  • Congestion : Sms, ShortMessageStatus
  • Connect : TcpSocket, SysSocket, PsdDataConn, ObexLayer, ObexClient, SocketPeer, IrdaObexImpl, MmiSimClient, BtObexImpl, PdpContext, ExtPsdContextListener_SerialTerminal, StreamObexImpl, SioSocketAdapter, SerialIoAdapter, SerialClientSocket, SerialTerminal, AtResponse
  • CONNECT_FAIL : SerialIoSet
  • CONNECT_REQ : SerialIoSet
  • CONNECT_SUCCESS : SerialIoSet
  • Connected : PdpContext
  • ConnectedAndBatteryFull : Charger
  • ConnectedAndCharging : Charger
  • ConnectedAndTemperatureProtection : Charger
  • ConnectedWord : VrHandler
  • ConnectionClose : RegEncoderDecoder
  • ConnectionId : ObexHeader
  • ConnectionRejectedBySme : ShortMessageStatus
  • ConnectionResponse : RegEncoderDecoder
  • ConnectPending : PdpContextManager
  • ConnectTwoCallsAndDisconnectSubscriber : CallSsAction
  • ConnMultipleIrlmpLsapSel : ObexObject
  • Cons : ThaiTextRenderer
  • ContainerType : ContextFeature
  • ContextDependantTitle : MenuProperties
  • ContextFeatureItemClassType : GuiObjectFactory
  • ContextItemProp : GuiObjectFactory
  • ContextMenuBackground : Color
  • ContextMenuBackgroundColor : CTResourcePack
  • ContextMenuClassType : GuiObjectFactory
  • ContextPropertyId : FeatureItemContainer, FeatureItem
  • Continue : BtObexResponseCode
  • ContinuedExtendedObject : InformationElement
  • ContrastChanged : Camera
  • ContrastProperty : CamWin32
  • Control : Control, VirtualDisplay, RealTimeClock, VirtualDisplay, Keyboard, Fota, Charger, VirtualDisplay, AbstractDevice, ThaiTextRenderer, DrawableObject
  • ControlClassType : GuiObjectFactory
  • ControlFrameControl : CTResourcePack
  • Controls : Control::ComponentIterator
  • CoordParam : TestparamReport
  • CornerModeParseType : CTResourcePack
  • CornerProp : GuiObjectFactory
  • CornerType : GuiObjectFactory
  • CorruptMp3File : MediaManager
  • Corsican : LanguageManager
  • CouldNotAllocateThreadletError : ImageEncoder, Image
  • Count : ObexHeader
  • CpNetworkFailure : Sms
  • Cr : AtResponse
  • CreateInterior : RegEncoderDecoder
  • CreationDate : File::Attributes
  • CreationTime : File::Attributes
  • CreatorId : ObexHeader
  • Creg : AtResponse
  • Cring : AtResponse
  • CriticalErrorMsg : MediaManager
  • Croatian : LanguageManager
  • CrssNotValid : XCallInfoResponseParser
  • CrssTransaction : XCallInfoResponseParser
  • CsdPropCount : DataConnApp
  • CsParam : TestparamReport
  • Cssi : AtResponse
  • Cssu : AtResponse
  • CtmCall : XCallInfoResponseParser
  • CtmNotValid : XCallInfoResponseParser
  • CtResourcePackClassType : GuiObjectFactory
  • Ctrl : ThaiTextRenderer
  • Ctzv : AtResponse
  • CurrentAudioPath : BtHfAudioPathWindow
  • CurrentValue : CamWin32
  • Cusd : AtResponse
  • Custom : OptionalConfigBase, InputMapper
  • CustomAnimation : ItemRendererProperties
  • CustomAttributeId : Feature
  • CustomCategory : AbstractDevice
  • CustomDisplayType : ItemRendererProperties
  • CustomPropertyId : Item
  • CustomStyle : AbstractItemRenderer
  • CutWrap : EditorDocument
  • Cuus1i : AtResponse
  • Cuus1u : AtResponse
  • Cycle : AnimatedTextLine, Animation
  • CycleAnimation : ItemRendererProperties
  • CycleHorizontalAnimation : ItemRendererProperties
  • CycleVerticalAnimation : ItemRendererProperties
  • Czech : LanguageManager, DataCodingScheme
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- d -

  • Daily : CalendarRecord
  • Danish : LanguageManager, DataCodingScheme
  • DarkBlue : InformationElement
  • DarkCyan : InformationElement
  • DarkerLightColor : CTResourcePack
  • DarkGreen : InformationElement
  • DarkGrey : InformationElement
  • DarkMagenta : InformationElement
  • DarkRed : InformationElement
  • DarkShadow : CTResourcePack
  • DarkYellow : InformationElement
  • Dashed : Pen
  • Data : StartUp::Data, InternalTracer, XCallInfoResponseParser
  • DATA_RECEIVED : SerialIoSet
  • DATA_SENT : SerialIoSet
  • DataAvailable : StreamReader, ExtPsdContextListener_SerialTerminal, SerialTerminal
  • DataCable : Accessory
  • DataCodingMsgHandlingGroup : DataCodingScheme
  • DataMissing : SsErrorCode
  • DataNotValid : RealTimeClock
  • DataNumberingPlan : TypeOfAddress
  • DataSent : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • DataSink : DataSink, RecordSettings
  • DataSinkClosedError : ImageEncoder
  • DataTrace : InternalTracer
  • Date : Date, InputMapper
  • DateChanged : RealTimeClock
  • DateEditorClassType : GuiObjectFactory
  • DateProp : GuiObjectFactory
  • DateType : GuiObjectFactory
  • Day : Date, PackedTimePeriod
  • DeactivatePending : PdpContextManager
  • Deactivation : InputParser
  • December : Date
  • DecodeBufferFct : AudioDecoder
  • DecodeFrameFct : AudioDecoder
  • DecoderInitError : PngDecoder
  • DecodingDirection : CodecDevice
  • DecodingError : PngDecoder
  • DecodingInterruptedError : Image, SvgPlayer
  • Decrease : Camera
  • Default : AlarmManager, TextFormat, GridLayout, MoCallAction, InformationElement
  • default_irda_switch_off_timeout : IrdaTransport
  • DefaultAlign : EditorDocument
  • DefaultAlphabet : DataCodingScheme
  • DefaultAudioPath : BtHfAudioPathWindow
  • DefaultCodec : MediaInfo, CodecDevice
  • DefaultFormat : CamWin32
  • DefaultFrame : Control
  • DefaultMask : InternalTracer
  • DefaultServerId : ObexServerInfo
  • DefaultSize : IconState
  • DefaultStyle : AbstractItemRenderer
  • DefaultTextFormattingIe : EditorItemNode
  • DefaultValue : CamWin32
  • DefaultViewProp : GuiObjectFactory
  • DefFragSize : ObexOppBinDataPushClient
  • DefGetFragSize : ObexDataServer
  • Defined : PdpContext
  • DelayBestEffort : PdpContext::QualityOfService
  • DelayClass1 : PdpContext::QualityOfService
  • DelayClass2 : PdpContext::QualityOfService
  • DelayClass3 : PdpContext::QualityOfService
  • DelayProp : GuiObjectFactory
  • DelayReserved : PdpContext::QualityOfService
  • DelaySubscribed : PdpContext::QualityOfService
  • DelCurrCharMode : EditBox
  • Delete : MediaRefContainer, ImageRefContainer, MediaRefContainer, FfsFile, BtSddbServiceRecord, BtSddbDeContainer, File, Registry, ObjectTreeService, LocalDataStore, FlsFile, FfsHandler, WapProfile, DrmRightsObjectFile, RootFileImp, RamHandler, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile, RegEncoderDecoder, PbRecordProvider, InternalTracer, Provider, CommandType
  • DeleteAll : PbRecordProvider, Provider
  • Deleted : ToDoRecord
  • Deliver : MessageTypeIndicator
  • DeliverReport : MessageTypeIndicator
  • DelLeftCharMode : EditBox
  • Description : ObexHeader
  • DeselectedCheckBoxBitmap : CTResourcePack
  • DeselectedCheckBoxBitmapUri : CTResourcePack
  • DeselectedCheckBoxId : Theme
  • DeselectedRadioButtonBitmap : CTResourcePack
  • DeselectedRadioButtonBitmapUri : CTResourcePack
  • DeselectedRadioButtonId : Theme
  • DestinationSmeBarred : ShortMessageFailureCause
  • DestOutOfService : Sms
  • DestroyedState : MediaRecorder, MediaPlayer
  • DetachPending : PdpContextManager
  • DEVICE_CAPABILITY_COUNT : StorageDevice
  • DeviceBuzzer : Audio
  • DeviceEarPiece : Audio
  • DeviceError : File
  • DeviceIn : Audio
  • DeviceMic : Audio
  • DeviceNone : Audio
  • DeviceOut : Audio
  • DeviceTrembler : Audio
  • Devil : InformationElement
  • Dial : VrHandler
  • Digit0 : VrHandler
  • Digit1 : VrHandler
  • Digit2 : VrHandler
  • Digit3 : VrHandler
  • Digit4 : VrHandler
  • Digit5 : VrHandler
  • Digit6 : VrHandler
  • Digit7 : VrHandler
  • Digit8 : VrHandler
  • Digit9 : VrHandler
  • DigitDialing : VrHandler
  • Digits : VrHandler
  • DimmedBacklightBrightness : OptionalConfigBase
  • Ding : InformationElement
  • Directory : File::Attributes
  • DirectorySupport : StorageDevice
  • DirSpaceNotAvailableError : File
  • Disabled : Control::NavigationGuidance, Charger
  • DisabledMode : IconState
  • DisabledProp : GuiObjectFactory
  • DISCONNECT_IND : SerialIoSet
  • Disconnected : XCallInfoResponseParser
  • DisconnectedAndBatteryFull : Charger
  • DisconnectedAndBatteryNotFull : Charger
  • DisconnectIndicated : XCallInfoResponseParser
  • DispatcherClassType : GuiObjectFactory
  • DispatcherProp : GuiObjectFactory
  • Display : BtAlertMessageWindow, BtAvrcpAlertMessageWindow, Display, OptionalConfigBase, Led
  • DisplayCategory : AbstractDevice
  • DisplayExtensionText : SimTkProfile
  • DisplayIdxProp : GuiObjectFactory
  • DisplayPhoneNumber : MoCallAction
  • DisplayResizable : SimTkProfile
  • DisplayTimeout : Display
  • Dotted : Pen
  • Down : Control::NavigationGuidance, AbstractGrid
  • DownArrowBitmapId : AbstractPredictiveInputBox
  • DownlinkCarKit : AudioPath
  • DownlinkDirection : AudioDeviceBase
  • DownlinkPathBackspeaker : AudioPath
  • DownlinkPathBackspeakerStereo : AudioPath
  • DownlinkPathEarpiece : AudioPath
  • DownlinkPathExtRingerBackspeaker : AudioPath
  • DownlinkPathExtRingerI2S1_Tx : AudioPath
  • DownlinkPathExtRingerMonoHeadset : AudioPath
  • DownlinkPathExtRingerStereoHeadset : AudioPath
  • DownlinkPathFmRadioBackspeaker : AudioPath
  • DownlinkPathFmRadioHeadset : AudioPath
  • DownlinkPathI2S1_Tx : AudioPath
  • DownlinkPathMonoHeadset : AudioPath
  • DownlinkPathNone : AudioPath
  • DownlinkPathStereoHeadset : AudioPath
  • DownlinkPathTTY : AudioPath
  • DownscaleToBounds : DisplaySettings
  • Dr : AtResponse
  • DrawableObjectClassType : GuiObjectFactory
  • DrawableObjects : Control::ComponentIterator
  • DrawBitmap : DeviceContext, CTResourcePack
  • DrawPrimitives : CTResourcePack
  • DriverCause : AudioDeviceBase
  • DriverReason : AudioPlayerEvent
  • Drm_v_1_0 : DrmRelParser
  • Drm_v_None : DrmRelParser
  • DrmDcfContentDescription : DrmDcfParser
  • DrmDcfContentName : DrmDcfParser
  • DrmDcfContentVendor : DrmDcfParser
  • DrmDcfEncryptionMethod : DrmDcfParser
  • DrmDcfIconUriHeader : DrmDcfParser
  • DrmDcfPaddingScheme : DrmDcfParser
  • DrmDcfRightsIssuer : DrmDcfParser
  • DrmDcfUnSupported : DrmDcfParser
  • DropShadowColor : CTResourcePack
  • DropShadowDistance : CTResourcePack
  • DropShadowEnabled : CTResourcePack
  • DropShadowMaxAlpha : CTResourcePack
  • DropShadowMinAlpha : CTResourcePack
  • DropShadowWidth : CTResourcePack
  • Drum : InformationElement
  • DspFormatAmr : VoiceMemoAudioDevice
  • DspFormatFullRate : VoiceMemoAudioDevice
  • DualCall : XCallInfoResponseParser
  • DualChannelMode : AudioEncoder
  • DualMono : CodecDevice
  • DualServiceCallModification : XCallInfoResponseParser
  • DualTone : CustomToneAudioReference
  • DualUserTone : ToneAudioDevice
  • DuplicateInvokeId : TaggedProblemCode
  • Dutch : LanguageManager, DataCodingScheme
  • DynamicFrame : Control
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- e -

  • E164 : WapProfile
  • EccError : File
  • ECT : InputParser
  • EctAccomplished : CallEvent
  • Editor : OptionalConfigBase
  • EightBitAlphabet : InputMapper, DataCodingScheme
  • ElectronicMail : InformationElement
  • ElementUndefined : DataCallContext
  • EMailAddress : InputMapper
  • EmailMessage : DataCodingScheme
  • EmbossFilter : Camera
  • EmergencyCall : XCallInfoResponseParser
  • EMLPP : InputParser
  • Empty : ObexBuffer, Tpdu
  • EmptyFile : MediaManager
  • Enabled : Control::NavigationGuidance
  • EnabledAttributeId : Feature
  • EnabledProp : GuiObjectFactory
  • EnabledPropertyId : Item
  • EnableStatusReportRequest : CommandType
  • EnableTransaction : Registry, RegEncoderDecoder
  • EncodeBufferFct : AudioEncoder
  • EncodeFrameFct : AudioEncoder
  • EncoderInitError : ImageEncoder
  • EncodingDirection : CodecDevice
  • EncodingError : ImageEncoder
  • EncQualityHigh : CodecDevice
  • EncQualityLow : CodecDevice
  • EncQualityMid : CodecDevice
  • End : BtDeviceList, Vector< T >, MessageIdentifierRange, DataCodingSchemeRange, Pathname, FlowLayout, IndicatorLocation
  • EndOfCodecType : MediaInfo, CodecDevice
  • EndOfColorType : CamWin32
  • EndOfDirectionType : CodecDevice
  • EndOfDirectoryError : File
  • EndOfFilterType : Camera
  • EndOfFpsType : CamWin32, VideoCamera
  • EndOfFrameCodingType : VideoEncoder
  • EndOfImageSizeType : CamWin32, Camera
  • EndOfLocationType : CodecDevice
  • EndOfParameterType : VideoDecoder, AudioEncoder, AudioDecoder
  • EndOfPduIE : BaseInformationElement
  • EndOfProperty : CamWin32
  • EndOfPropertyType : CamWin32
  • EndOfResultType : CodecDevice
  • EndUserDefineableViewsProp : GuiObjectFactory
  • English : LanguageManager, DataCodingScheme
  • Enhanced : ValidityPeriodFormat
  • EnhancedMessageType : ProtocolIdentifier
  • Enquiry : CommandType
  • EOBWBitmap : InformationElement
  • EOBWBitmapAnimation : InformationElement
  • EODataFormatDeliveryRequest : InformationElement
  • EofProcessing : MediaRecorder, MediaPlayer
  • EofReachedMsg : MediaManager
  • EofReceivedState : MediaPlayer
  • EOiMelody : InformationElement
  • EOPolyphonicMelody : InformationElement
  • EOPredefinedAnimation : InformationElement
  • EOPredefinedSound : InformationElement
  • EOSixBitGrayScale : InformationElement
  • EOSixBitGrayScaleAnimation : InformationElement
  • EOStdWVGObject : InformationElement
  • EOTwoBitGrayScale : InformationElement
  • EOTwoBitGrayScaleAnimation : InformationElement
  • EOvCalendar : InformationElement
  • EOvCard : InformationElement
  • EqualType : StandardJoinRule
  • EqUplmList : TestparamReport
  • Erasure : InputParser
  • Ermes : ProtocolIdentifier
  • ErmesNumberingPlan : TypeOfAddress
  • Error : ImageEncoder, ShortMessageFailureCause, File, StreamObexImpl, PngDecoder, VrHandler, InternalTracer, ExtPsdContextListener_SerialTerminal, SerialTerminal, AtResponse
  • ErrorAudioDriverDisabled : AudioError
  • ErrorFormatNotSupported : AudioError
  • ErrorHandleNotUsed : AudioError
  • ErrorInMs : ShortMessageFailureCause
  • ErrorInSme : ShortMessageStatus
  • ErrorMissingDspResource : AudioError
  • ErrorNoHwSupport : AudioError
  • ErrorNoPlayback : AudioError
  • ErrorNoPlaytime : AudioError
  • ErrorParameterOutOfRange : AudioError
  • ErrorPerformanceProblems : AudioError
  • ErrorProcessing : MediaRecorder, MediaPlayer
  • ErrorResourceConflict : AudioError
  • ErrorResourceInUse : AudioError
  • ErrorRingerSuspendresumeError : AudioError
  • ErrorRingerToneError : AudioError
  • ErrorSharingViolation : AudioError
  • ErrorState : Camera, MediaRecorder, MediaPlayer
  • ErrorUnknown : AudioError
  • ErrorUnknownPosition : AudioError
  • ErrorVmFFSProblems : AudioError
  • ErrorVmPerformanceProblems : AudioError
  • Esperanto : LanguageManager
  • EstCauseNotValid : XCallInfoResponseParser
  • Estonian : LanguageManager
  • Euc : JapaneseTranscoder
  • EvAvsChanged : ObexAbstractPort
  • EvAvsIsBad : ObexAbstractPort
  • EvAvsReady : ObexAbstractPort
  • EvClose : ObexAbstractPort
  • EVENT_IGNORED : StateMachine
  • EvOpComplete : ObexAbstractPort
  • EvOpen : ObexAbstractPort
  • EvOpenFailure : ObexAbstractPort
  • EvOpenSuccess : ObexAbstractPort
  • Evrc : MediaInfo, CodecDevice
  • EvReleaseComplete : ObexAbstractPort
  • EvResolveComplete : ObexAbstractPort
  • EvResolveFailure : ObexAbstractPort
  • EvResolveSuccess : ObexAbstractPort
  • ExchangeableMedia : StorageDevice
  • ExplicitCallTransferCompleted : XCallInfoResponseParser
  • ExplicitCallTransferRejected : XCallInfoResponseParser
  • ExplicitCallTransferStarted : XCallInfoResponseParser
  • ExportSendType : AbstractSmsApp
  • ExportStoreType : AbstractSmsApp
  • ExposureChanged : Camera
  • ExtendedObject : InformationElement
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- f -

  • FacilityNotSubscribed : Sms
  • FacilityNotSupported : SsErrorCode
  • FacilityRejected : Sms
  • FacsimileServices : InputParser
  • FAIL : StreamObexImpl
  • Failed : SocketTestT
  • FanFar : InformationElement
  • FastForwardApiCompletionMsg : MediaManager
  • FastForwardingState : MediaPlayer
  • FatalError : File, AtResponse
  • Fax : XCallInfoResponseParser
  • FaxMessage : InformationElement, DataCodingScheme
  • FdnFailed : Sms
  • FeatDeleteProfile : DataConnApp
  • FeatEditProfile : DataConnApp
  • FeatSaveProfile : DataConnApp
  • FeatSetDefaultProfile : DataConnApp
  • FeatureCnt : DataConnApp
  • FeatureIdProp : GuiObjectFactory
  • FeatureItemClassType : GuiObjectFactory
  • FeatureItemContainerClassType : GuiObjectFactory
  • FeatureItemContainerIdProp : GuiObjectFactory
  • FeatureItemContainerProp : GuiObjectFactory
  • FeatureKeyProp : GuiObjectFactory
  • FeatureKeyType : GuiObjectFactory
  • FeatureNotSupported : MediaManager, CodecDevice
  • FeaturePropertyId : FeatureItem
  • FeatViewDataConnList : DataConnApp
  • February : Date
  • FfsMedia : StreamAudioReference
  • FileNotFound : MediaManager
  • FileOperationErrorType : AudioDeviceBase
  • FilePathname : RecordSettings
  • FileSoundDataSource : AudioReference
  • FilmFilter : Camera
  • FilterBankBlockLength : AudioEncoder
  • FilterChanged : Camera
  • Finished : PhonebookApp
  • FinishedErr : SocketTestT
  • FinishedOK : SocketTestT
  • Finnish : LanguageManager, DataCodingScheme
  • FirmwareUpdate : ShutDown
  • First : VoiceMemoMenuAccessor, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, DataConnAccessor, TextMenuAccessor, AbstractMenuAccessor, ActionMenuAccessor, AbstractSmsViewerWin
  • FirstAndNotSecondFilterOp : DualFilterProvider
  • FirstOnly : JoinProvider
  • FirstOrNotSecondFilterOp : DualFilterProvider
  • FirstServerId : ObexServerInfo
  • FiveMinutes : PackedTimePeriod
  • Flash : Sms
  • FlashDisabled : Camera
  • FlashEnabled : Camera
  • FlashNotSupported : Camera
  • FlashPreferred : Sms
  • FlashType : Camera, CameraOptionSettingsWin
  • Flat : CTResourcePack
  • Flip : VideoChannel
  • FluorescentBalance : Camera
  • FM : InputParser
  • FmRadioRdsAlternativeFrequenciesFeature : AudioDeviceBase
  • FmRadioRdsFeature : AudioDeviceBase
  • FmRadioRdsRadioTextFeature : AudioDeviceBase
  • FmRadioRdsRawDataFeature : AudioDeviceBase
  • FmRadioRdsStationNameFeature : AudioDeviceBase
  • FmRadioRssiLevelFeature : AudioDeviceBase
  • FmRadioSeekStationFeature : AudioDeviceBase
  • FmRadioSetStationFeature : AudioDeviceBase
  • FmRadioSoundDataSource : AudioReference
  • FocusPriorityProp : GuiObjectFactory
  • FontAlignParseType : CTResourcePack
  • FontAlignProp : GuiObjectFactory, CTResourcePack
  • FontAlignType : GuiObjectFactory
  • FontProp : GuiObjectFactory
  • FontSystemFontIdType : GuiObjectFactory
  • Forbidden : BtObexResponseCode
  • ForegroundcolorProp : GuiObjectFactory
  • Format : RingerAudioDevice, Time, Date, CustomRingerAudioReference, ValidityPeriodFormat, WString, TimeZone, String, DateTime, StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, RamHandler, FlashStorageDeviceImp, FatStorageDeviceImp, AudioDecoder
  • FormatBuzzer : RingerAudioDevice, CustomRingerAudioReference
  • FormatImelody : RingerAudioDevice, CustomRingerAudioReference
  • FormatMidi : RingerAudioDevice, CustomRingerAudioReference
  • FormatNotSupportedError : ImageEncoder
  • FormatRmd : RingerAudioDevice, CustomRingerAudioReference
  • FormatSmaf : RingerAudioDevice, CustomRingerAudioReference
  • FormatSmafPhrase : CustomRingerAudioReference
  • FormatSmafPhrase11 : RingerAudioDevice
  • ForPlmnOperatorSpecificInFutureVersionsRangeBegin : MessageIdentifier
  • ForPlmnOperatorSpecificInFutureVersionsRangeEnd : MessageIdentifier
  • ForStandardizationInFutureVersionsRange1Begin : MessageIdentifier
  • ForStandardizationInFutureVersionsRange1End : MessageIdentifier
  • ForStandardizationInFutureVersionsRange2Begin : MessageIdentifier
  • ForStandardizationInFutureVersionsRange2End : MessageIdentifier
  • ForwAvailAborted : Sms
  • ForwAvailFailed : Sms
  • Fps10 : CamWin32, VideoCamera
  • Fps12 : CamWin32, VideoCamera
  • Fps15 : CamWin32, VideoCamera
  • Fps24 : CamWin32, VideoCamera
  • Fps25 : CamWin32, VideoCamera
  • Fps30 : CamWin32, VideoCamera
  • Fps3_7_5 : VideoCamera
  • Fps5 : CamWin32, VideoCamera
  • Fps7_5 : CamWin32, VideoCamera
  • FpsNotSupported : MediaManager
  • FrameArea : DrawableObject
  • FrameLayoutHintProp : GuiObjectFactory
  • FrameRateChanged : Camera
  • FrameType : Control, GuiObjectFactory
  • FrameTypeProp : GuiObjectFactory
  • FrDspFormat : StreamAudioReference
  • French : LanguageManager, DataCodingScheme
  • Friday : Date
  • FSM_INTERNAL_EVENTS : ObexAbstractPort
  • FullImageMetering : Camera
  • FullScreenPerItemProp : GuiObjectFactory
  • FullSize : MenuProperties
  • Func : InternalTracer
  • FuncStackTrace : InternalTracer
  • FunctionBegin : InternalTracer
  • FunctionEnd : InternalTracer
  • FV1 : ThaiTextRenderer
  • FV2 : ThaiTextRenderer
  • FV3 : ThaiTextRenderer
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- g -

  • GapProp : GuiObjectFactory
  • General : TaggedProblemCode
  • GeneralDataCodingGroup : DataCodingScheme
  • GeneralError : MediaManager, CodecDevice
  • GeneralErrorType : AudioDeviceBase
  • GenericFastForward : AudioDeviceBase
  • GenericGetTrackInfo : AudioDeviceBase
  • GenericRewind : AudioDeviceBase
  • German : LanguageManager, DataCodingScheme
  • Get : DataConnProfileManager, DataConnManager, ObexLayer, ObexClient, TickValue, IrdaObexImpl, WindowHierarchyIterator, Control::ComponentIterator, DeviceManager::Iterator, SoftkeyBar, BtObexImpl, TypeOfAddress, NiSharedPtr< X >, BitField< T >, FunctionalityIndicator, SimSetupIdleModeTextOptions, SimSetupMenuOptions, SimSelectItemOptions, SimGetInkeyOptions, SimGetInputOptions, SimDisplayTextOptions, SimIconQualifier, SimAtom< T >, ShortMessageStatus, ShortMessageFailureCause, ProtocolIdentifier, ParameterIndicator, MessageIdentifier, MdhDeletionCmd, SimImageDescriptor, DataCodingScheme, CommandType, Cbs::SerialNumber, MePhonebookDescription, RegIterator, Registry, ObjectTreeService, LocalDataStore, StreamObexImpl, CompoundItemIterator, RegEncoderDecoder
  • GetInteriorMetaData : RegIterator, RegEncoderDecoder
  • GetIterator : SimpleMap< TKey, TValue >, RegEncoderDecoder
  • GetLeafMetaData : RegIterator, RegEncoderDecoder
  • GetTimeFeature : AudioDeviceBase
  • GlassTileFilter : Camera
  • Global : CTResourcePack
  • Gprs : TestparamReport
  • GprsServiceNotAllowed : PdpContext
  • GpsModule : Accessory
  • GrayScaleAlphaFormat : PngEncoder::EncodingParameters
  • GrayScaleFilter : Camera
  • GrayScaleFormat : PngEncoder::EncodingParameters
  • GreaterType : StandardJoinRule
  • GreatestValueOfApplicationCategoriesFlagsType : CodecDevice
  • GreatestValueOfFlagsType : VideoDecoder
  • Greek : LanguageManager, DataCodingScheme
  • Grey : InformationElement
  • Group00 : ProtocolIdentifier
  • Group01 : ProtocolIdentifier
  • Group3Telefax : ProtocolIdentifier
  • Group4Telefax : ProtocolIdentifier
  • GsmAmrNb : MediaInfo, CodecDevice
  • GsmUmts : ProtocolIdentifier
  • Gui : InternalTracer
  • GuiEngine : OptionalConfigBase
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- h -

  • H263Bl : MediaInfo, CodecDevice
  • H264Bp : MediaInfo, CodecDevice
  • HalfHourAfter12 : PackedTimePeriod
  • HandsFreeCarKit : Accessory
  • HardHorizontalAnimation : ItemRendererProperties
  • HardVerticalAnimation : ItemRendererProperties
  • HazeFilter : Camera
  • HEADER_SIZE : GltpRequest
  • HeaderStyle : AbstractItemRenderer
  • HeadSet : HeadSet, Accessory
  • Hebrew : LanguageManager, DataCodingScheme
  • HeightProp : GuiObjectFactory
  • Hidden : File::Attributes
  • HideClippedText : OptionalConfigBase
  • High : ToDoRecord
  • HighQuality : DisplaySettings
  • Hindi : LanguageManager
  • HorizBorderAlign : Desktop
  • Horizontal : PositionIndicator
  • horizontal : IndicatorBarView
  • HorizontalProp : GuiObjectFactory
  • HorizontalScrollBehavior : OptionalConfigBase
  • HorrorFilter : Camera
  • HostByteOrder : ObexHeader
  • HostLocation : VideoCamera, CodecDevice
  • Http : ObexHeader
  • HttpConnClosed : HttpHandler
  • HttpConnError : HttpHandler
  • HttpConnOpen : HttpHandler
  • HttpConnSuspended : HttpHandler
  • Hungarian : LanguageManager, DataCodingScheme
  • HyperlinkFormatElement : InformationElement
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- i -

  • IAmAngry : InformationElement
  • IAmConfused : InformationElement
  • IAmCrying : InformationElement
  • IAmGlad : InformationElement
  • IAmIndifferent : InformationElement
  • IAmIronic : InformationElement
  • IAmLaughing : InformationElement
  • IAmSad : InformationElement
  • IAmSceptic : InformationElement
  • IAmWinking : InformationElement
  • Icelandic : LanguageManager, DataCodingScheme
  • IconAnimation : ItemRendererProperties
  • IconDisplayType : ItemRendererProperties
  • IconIdentifierTag : Tlv
  • IconProp : GuiObjectFactory
  • IconPropertyId : Item
  • IconValueMapProp : GuiObjectFactory
  • ID : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, SoundBrowserServiceMsg, AmrSound, SkipSocketTestMsg, StopSocketTestMsg, ContinueSocketTestMsg, NextSocketTestMsg, StartSocketTestMsg, OnDataRcvdMsg, LcsAppResWinMsg, LcsAppRegisterForMtlrMsg, LcsAppTransferLocMsg, ImageBrowserServiceMsg, ImageBrowserRenameImageMsg, ImageBrowserDeleteImageMsg, SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, PredefinedEmsSound, PredefinedEmsImage, EmsImage, CameraMsgStopViewfinding, CameraMsgStartViewfinding, BtIndicatorMsg, PhonebookRenumberedMsg, ProviderUpdateMsg, SyncProgressMsg, SaveEntryInPhonebookMsg, OpenPbWinMsg, JumpToRowMsg, UtcStatusMessage, AsyncUnitTestMsg, DataConnProfileInfoMsg, DataConnInfoMsg, SocketControlMsg, ObexVCardMsg, ObexTransportMsg, ObexAddrMsg, ObexTriggerMsg, ObexMsg, ObexAppMsg, LoseFocusMsg, GetFocusMsg, ContextExecuteMsg, TimerTimeoutMsg, AlarmNotificationMsg, ShutdownRequestMsg, ContextWakeupMsg, ThreadletNotificationMsg, SharedTimerMsg, AppLoseFocusMsg, AppGetFocusMsg, ServiceThreadTerminateMsg, RtcAlarmReachedMsg, RtcDateChangedMsg, RtcTimeChangedMsg, ActionExecutedMsg, ItemPropertiesChangedMsg, ExternalTimeoutMsg, PenUpMsg, PenDownMsg, InputCharMsg, LockedKeyMsg, LockedKeyDownMsg, FlipMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, PowerWakeupMsg, LanguageChangedMsg, ThemeChangedMsg, AppUpdateDisplayMsg, AppCloseMsg, AppOpenMsg, PowerOffMsg, PowerOnMsg, NoMessage, Window, TimeEditor, TimeCompoundItem, TextLine, TextCompoundItem, TextBox, TabControl, TabButton, RadioButtonControl, RadioButtonAction, PushButton, ProgressBar, PositionIndicator, PasswordEditor, Panel, NativeImage, MultiLineEditor, RedrawDisplayMsg, ItemRendererPropertiesChangedMsg, ImageEncodingProgressMsg, DeleteComponentMsg, ImageDrawingInterruptedMsg, Zi8EnteredUnknownWordMsg, Zi8AddWordMsg, Zi8NoWordFoundMsg, T9MatrixModeKeypressed, T9SymbolEntryRequestMsg, T9EnteredUnknownWordMsg, T9AddWordMsg, T9NoWordFoundMsg, AragonMsg, CloseWindowMsg, RefreshComponentMsg, ContextMenuClosedMsg, ViewfinderErrorMsg, ImageDecodingProgressMsg, InvalidateMsg, SelectionChangedMsg, FocusPreviousControlMsg, FocusNextControlMsg, MessageBox, LineEditor, ItemTree, ItemRendererProperties, ItemMenu, ItemGrid, ItemContainer, ItemBox, Item, IpAddrEditor, IpAddrCompoundItem, ImageBox, Image, GridLayout, FlowLayout, DrawableObject, DateEditor, DateCompoundItem, Control, ContextMenu, CompoundItem, Component, CheckBoxControl, CheckBoxAction, CharItem, AtomItem, AnimatedTextLine, Alert, Action, AbstractToggleAction, AbstractTextObject, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemGrid, AbstractItemContainer, AbstractGrid, AbstractEditor, AbstractButton, MmiSimServer, AudioGatiServer, RtcInfoMsg, TransportNotificationMsg, LedNotificationMsg, DisplayInfoMsg, BatteryLoadLevelMsg, ChargerInfoMsg, SsHandler, SoundItem, SmafSound, PreparedSound, MidiSound, IMelody, BtObexClientRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, BtObexClientNmaTransportDisconnect, BtObexClientNmaDataInidication, BtObexClientNmaDataBufferIndication, BtObexClientNmaHeaderIndication, BtObexClientNmaHeaderSent, BtObexServerNmaTransportDisconnect, BtObexServerNmaDataInidication, BtObexServerNmaDataBufferIndication, BtObexServerNmaHeaderIndication, BtObexServerNmaHeaderSent, BtObexServerNmaAbort, BtObexServerNmaPut, BtObexServerNmaGet, BtObexServerNmaSetPath, BtObexServerNmaDisconnect, BtObexServerNmaConnect, BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtObexClientAbortEvent, BtObexClientPutEvent, BtObexClientGetEvent, BtObexClientSetPathEvent, BtObexClientDisconnectEvent, BtObexClientConnectEvent, BtObexRegisterClientEvent, BtObexServerAbortIndicationEvent, BtObexServerPutIndicationEvent, BtObexServerGetIndicationEvent, BtObexServerSetPathIndicationEvent, BtObexServerDisconnectIndicationEvent, BtObexServerConnectIndicationEvent, BtObexRegisterServerEvent, BtObexTransportDisconnectEvent, BtObexDataIndicationEvent, BtObexDataBufferIndicationEvent, BtObexHeaderSentEvent, BtObexHeaderIndicationEvent, BtObexUnregisterEvent, BtHsRequestStateChangedMessage, BtHsNmaCallEvent, BtHsNmaLowPowerModeNotPossible, BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHsNmaAudioConnectionLost, BtHsNmaTransferAudioToPhone, BtHsNmaTransferAudioToAccessory, BtHsNmaDisconnect, BtHsNmaConnect, BtHsNotificationMessage, BtHsCmaCheckPendingAudioCallback, BtHsCmaAudioTransferOutOfCall, BtHsCmaEnterLowPowerMode, BtHsCmaAudioAsynchronous, BtHsCmaHangUp, BtHfRequestStateChangedMessage, BtHfNmaCallEvent, BtHfNmaLowPowerModeNotPossible, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain, BtHfNmaAudioConnectionLost, BtHfNmaTransferAudioToPhone, BtHfNmaTransferAudioToAccessory, BtHfNmaDisconnect, BtHfNmaConnect, BtHfNotificationMessage, BtHfCmaCheckPendingAudioCallback, BtHfCmaAtChldOneCommandReceived, BtHfCmaAudioAsynchronous, BtHfCmaMOC, BtHfCmaMTC, BtHfCmaPhoneNumberRequired, BtFaxRequestStateChangedMessage, BtFaxDisconnectMessage, BtFaxConnectMessage, BtFaxApplicationMessage, BtDunRequestStateChangedMessage, BtDunDisconnectMessage, BtDunConnectMessage, BtDunApplicationMessage, BtRequestStateChangedMessage, BtServiceMessage, BtSddbRequestStateChangedMessage, BtSddbUnregisterServiceEvent, BtSddbRegisterServiceEvent, BtRequestOperationMessage, BtCloseMessage, BtOpenMessage, BtRequestMessage, BtCancelVerifyMessage, BtServiceVerifyResultMessage, BtServiceVerifyMessage, BtPaSupportedProfileMessage, BtHfSupportedProfileMessage, BtHsSupportedProfileMessage, BtQuerySupportedProfilesMessage, BtDeviceUntrustMessage, BtDeviceTrustMessage, BtDeviceUnpairMessage, BtDevicePairMessage, BtSetRemoteDeviceNameMessage, BtCancelSearchMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtDeviceSearchMessage, BtRespondAuthorizationMessage, BtSendPasskeyMessage, BtProfileActivationMessage, BtConnectabilityMessage, BtPairabilityMessage, BtDiscoverabilityMessage, BtLocalNameMessage, BtLocalSettingsMessage, BtStateChangedMessage, BtGapAndSdapRequestMessage, BtRemoteDevicePairMessage, BtGapAndSdapNotificationMessage, BtAuthorizationRequiredMessage, BtPasskeyRequiredMessage, BtGapAndSdapRemoteRequestMessage, BtGapAndSdapApplicationMessage, BtApplicationMessage, BtBppRequestStateChangedMessage, BtBipProgressMsg, BtBipGetImagingCapabilitiesIndArg, BtBipGetLinkedAttachmentIndArg, BtBipGetLinkedThumbnailIndArg, BtBipGetImageIndArg, BtBipOpFinishedArg, BtBipGetImagePropertiesIndArg, BtBipGetImagesListIndArg, BtBipPutLinkedAttachmentCompleteArg, BtBipPutLinkedAttachmentIndArg, BtBipPutLinkedThumbnailCompleteArg, BtBipPutImageCompleteArg, BtBipAbortIndArg, BtBipDisconnectIndArg, BtBipConnectIndArg, BtAvrcpRequestStateChangedMessage, BtAvrcpNmaRawFrame, BtAvrcpNmaPanelPassThrough, BtAvrcpOperationServiceMessage, BtAvrcpNmaDisconnect, BtAvrcpNmaConnect, BtAvrcpNotificationMessage, AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStreamingSyncMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRadioDeviceNotificationMsg, AudioPlayTimeMsg, AudioMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioFmRadioRdsAlternativeFrequenciesMsg, AudioFmRadioRdsInfoMsg, AudioFmRadioRdsRadioTextMsg, AudioFmRadioRdsStationNameMsg, AudioFmRadioRdsRawDataMsg, AudioFmRadioRssiMsg, AudioFmRadioSeekMsg, AudioAccessoryConnectedMsg, AudioRecordingStoppedMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg, AudioErrorMsg, AudioDeviceStatusMsg, ValueMappingPropertyDescriptor< T_Container >, PropertyItem, PropertyDescriptor, Property, ListPropertyDescriptor, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow, AtlItemBox, TriggerKeyFeature, ProviderProxyItem, ProviderProxyContainer, IndicatorItem, FeatureItemContainer, FeatureItem, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, AtlWindow, DisabledFeatureTriggeredMsg, UpdateItemMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg, PropertyTriggerMsg, FeatureChangedMsg, UpdateContextItemMsg, CloseAllMsg, IndicatorBarUpdateMsg, UusHandler, UssdHandler, UssdBeginMsg, UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, UusQueryRejectedMsg, UusStatusMsg, GetPasswordMsg, UssdRequestResentMsg, UssdDataMsg, UssdEndMsg, UssdNotifyMsg, UssdRequestMsg, SsErrorMsg, CallBarringPasswordChangedMsg, ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, CnapInfoReceivedMsg, EctAlertingMsg, EctActiveMsg, MultiPartyCallInvokedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, CugCallMsg, HlrDataCorruptedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallIsWaitingMsg, CallRetrievedMsg, CallHeldMsg, CallForwardingActiveMsg, ClirNotSurpressedMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, CtmInfoIndMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, PbAlphaTagRequestMsg, PbEntryRequestMsg, PbSizeRequestMsg, CbsLimitMsg, SmsMessageWaitingChangedMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceAvailableMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsPortDataRecvMsg, SmsNewSocketDataMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, RatChangeModeChangedMsg, EngineeringModeControlResponseMsg, BandStatusMsg, GsmBandStateMsg, RatStateMsg, NwDiscStartIndMsg, HomezoneMsg, BandSelectionMsg, EngineeringReportMsg, UssdAnswerMsg, CcbsResultMsg, CcbsStatusMsg, CcbsRecallMsg, SsInfoMsg, SsFacilityRejectedMsg, UssdResentMsg, UssdIndicationMsg, PasswordRejectedMsg, PasswordInquiryMsg, SsErrIndicationMsg, SsRejectedMsg, SsEndMsg, SsSuccessMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, MocSetupRejectIndMsg, CallControlInfoMsg, RedialStatusMsg, DiagnosticIndMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, RedialStoppedMsg, RedialStartedMsg, CallNotifyMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfBufferCleanedMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, PowerModeIndMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, OmMultiSlotIndMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, SimTkProfileSetRejMsg, SimTkProfileSetCnfMsg, SimTkProfileGetCnfMsg, SimTkRefreshStartMsg, TermRspCnfMsg, SimTkSetupEventMsg, SimTkLanguageNotificationMsg, MptyHoldRejectedMsg, MptyOnHoldMsg, CallHoldRejectedMsg, CallOnHoldMsg, SimCallSetupRejectedMsg, SimEndTransactionMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimMenuItemSelectionFailedMsg, SimSetupMenuMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetDoneMsg, SimResetConfirmationMsg, SimRefreshResetMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, RegistrationAllowedMsg, PlmnScanFinishedMsg, RegistrationChangeMsg, RegistrationSuccessMsg, AccessoryIndMsg, SignalQualityLevelMsg, SignalStrengthLevelMsg, MinuteTickMsg, AlarmMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, LsaIdentityMsg, TimeZoneMsg, NetworkInformationMsg, SimErrorMsg, CfuStatusMsg, MptyCallReleaseMsg, CallReleaseMsg, CallAcceptMsg, ExternalPdpContextInfoMsg, GprsAttachStatusMsg, PdpContextActivationStatusMsg, ChvChangedMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg, CallEventMsg, GprsStatusMsg, SimLockStatusMsg, SimStateChangedMsg, SsMessage, SsCcbsHandler, SmsHandler, SimTkHandler, SimHandler, SigHandler, PowerHandler, PlmnHandler, NetworkHandler, MultiSlotHandler, MobileOriginatedUssdHandler, EmlppHandler, CrssHandler, ColrHandler, ColpHandler, CnapHandler, ClirHandler, ClipHandler, CbsHandler, CallWaitingHandler, CallHandler, CallForwardingHandler, CallDeflectionHandler, CallBarringHandler, BootHandler, AtcHandler, AocHandler, AccHandler, NoStackMsgArg, SsUus1QueryReqArg, SsUus1ReqArg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, SsUus1IndArg, SsUus1QueryRejArg, SsUus1QueryIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityRejArg, SsFacilityIndArg, SsBeginAccArg, SmsGetMoreMessageStatusReqArg, SmsSetMoreMessageReqArg, SmsSendReqArg, SmsConfigIndArg, SmsGetMoreMessageStatusIndArg, SmsCapacityAvailableArg, SmsCapacityExceededArg, SmsSendRejArg, SmsSendCnfArg, SmsNewStatusReportIndArg, SmsNewMessageIndArg, SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver, SimTkRefreshNewRspArg, SimTkStopSendDtmfReqArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, BrowserTermEventArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, BrowserRegisterReqArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, ExtProactiveCmdIndArg, LanguageSettingIndArg, LanguageSelectEventArg, IdleScreenAvailEventArg, UserActivityEventArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, MenuSelectionReqArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkRefreshNewReqArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, SimTkInterfaceIndArg, SimTkSendDtmfEndIndArg, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimBrowserTermResArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, TermRspCnfArg, ExtProactiveCmdCnfArg, ExtProactiveCmdReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, EndSimToolkitIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, MenuSelectionRejArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg, SimTkSsIndArg, SimTkSmsPpIndArg, SimTkCallSetupIndArg, SimModifyLockReqArg, BdnReqArg, FdnReqArg, SimMruPropertyUpdReqArg, SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadReqArg, SimODynReadReqArg, SimCmiReadReqArg, UsimFilePropertyReqArg, UsimLangUpdReqArg, UsimEstReadReqArg, UsimSmsParamUpdReqArg, UsimCardTypeReadReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimLangReadReqArg, UsimPsLociReadReqArg, UsimCsLociReadReqArg, UsimPlmnReadReqArg, UsimUstReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCfufUpdReqArg, CphsVmwfUpdReqArg, CphsOnsReadReqArg, CphsOnmReadReqArg, CphsCfufReadReqArg, CphsVmwfReadReqArg, CphsIstReadReqArg, SimFileInfoReqArg, SimSpnReadReqArg, SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg, SimGenericReqArg, SimPuctUpdReqArg, SimPuctReadReqArg, SimAcmMaxUpdReqArg, SimAcmMaxReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSstReadReqArg, SimRefreshReqArg, SimModifyLockIndArg, BdnIndArg, FdnIndArg, SimFullAccessIndArg, SimLockStatusIndArg, SimInfoIndArg, SimInitIndArg, SimMruPropertyRefreshIndArg, SimMruPropertyUpdCnfArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimUpdCnfArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimMccMncIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimGenericIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, SimRefreshIndArg, SimErrorIndArg, ControlHwDataOnlyArg, StopSignalStrengthListeningArg, StartSignalStrengthListeningArg, StopBatteryLoadListeningArg, ClientDeregistrationArg, ClientRegistrationArg, PowerDownReqArg, OmPowerUpArg, PowerDownIndArg, OmControlIndArg, PowerDownCnfArg, PlmnListReqArg, GprsClassReqArg, PlmnInfoReqArg, DetachReqArg, AttachReqArg, PrefServiceSetReqArg, PrefPlmnChangeArg, PlmnListAbortArg, GprsClassIndArg, AttachAllowedIndArg, DetachCnfArg, AttachRejArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListRejArg, PlmnListCnfArg, UsimPbReadCnfArg, UsimPbStopReqArg, UsimPbFillStatusReqArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, UsimPbSelectReqArg, UsimPbLocationReqArg, PbCountReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, PbInfoReadReqArg, UsimPbReadyIndArg, UsimPbUidRefreshIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg, UsimPbLocationIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, PbInfoReadIndArg, OmRatChangeReqArg, OmBandStatusReqArg, OmMultiSlotReqArg, OmRatChangeIndArg, OmRatChangeCnfArg, OmBandStatusCnfArg, OmMultiSlotIndArg, MnNetworkSearchModeReqArg, MnTriggerReqArg, HomezoneIndArg, BandSelectionIndArg, TestparamReportArg, MnInformationIndArg, CellInfoIndArg, ConnectionIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, ClearBlacklistReqArg, RediallingDisabledIndArg, RedialRejArg, MocSetupReqArg, ClearBlackListCnfArg, AutoCallRestrictIndArg, RedialStopIndArg, RedialSetupIndArg, RedialIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, MocSetupRejArg, EngineeringModeControlRequestArg, OmSetTermProfileReqArg, OmGetTermProfileReqArg, OmFactoryResetIndArg, BandSelectionReqArg, TestparamReqArg, ImeiReadReqArg, BootDispatchingArg, EccListIndArg, CfuDataIndArg, EngineeringModeControlResponseArg, OmSetTermProfileRejArg, OmSetTermProfileCnfArg, OmGetTermProfileCnfArg, AccessoryIndArg, ImeiReadIndArg, SignalStrengthLevelIndArg, ToStackMsg, FromStackMsg, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsConcRefNumReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsSetWaitingReqArg, MdhRemoveViewReqArg, MdhMakeViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSetStorageReqArg, MdhSmsUpdStatusReqArg, MdhSmsStatusReqArg, MdhRegistrationReqArg, MdhDeregistrationReqArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsConcRefNumIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg, MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsStorageRefreshIndArg, MdhSmsRefreshIndArg, MdhNewStatusReportIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg, IconDescReadReqArg, ImageReadReqArg, IconDescReadIndArg, ImageReadIndArg, ChargeUnitsReqArg, SetChargeUnitsArg, ChargeReqArg, SetAutoChargeArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, CallDeflectSsReqArg, CallDeflectionIndArg, CbsStopReqArg, CbsStartReqArg, CbsNewDataRejArg, CbsLimitIndArg, CbsStopCnfArg, CbsStartCnfArg, CbsStopRejArg, CbsStartRejArg, CbsNewDataIndArg, RedialQueryReqArg, RejectCallsIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, MocSetupRejIndArg, CallIndCallControlInfoArg, RedialStatusIndArg, CallSetupBySimtTkReqArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, DtmfBufferClearedIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg, AtAccessoryRegisterCnfArg, AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtPbInfoIndArg, AtPbListCnfArg, AtPbSelectCnfArg, AtAlphaTagCnfArg, AtAccessoryRegisterReqArg, AtGenericCmdReqArg, AtPbListReqArg, AtPbSelectReqArg, AtAlphaTagReqArg, RfsStorageDeviceRegistrationStatusMsg, RfsMediaAvailableStatusMsg, FileChunkOperationProgressMsg, RegNotifyMsg, VrPropertyResultIndArg, VrWarningIndArg, VrErrorIndArg, VrG2AResultIndArg, VrStoreTemplateReqArg, VrStopRecogIndArg, VrAbortEngineIndArg, VrTrainResultIndArg, VrRecogResultIndArg, VrIntrmRecResultIndArg, VrSayNameIndArg, VrLoadTemplateReqArg, VrInitCnfArg, VrParamReqArg, VrHandler, VrRecognitionFailedMsg, VrTrainingFailedMsg, VrPlaybackFinishedMsg, VrTrainingResultMsg, VrRecognitionStoppedMsg, VrTrainingAbortedMsg, VrRecognitionAbortedMsg, VrWarningMsg, VrErrorMsg, VrResultMsg, VrPromptMsg, DBItemChangedMsg, SvgImage, SvgHyperlinkSelectMsg, SvgStatusMsg, SvgDecodingFinishedMsg, HttpDisconnectMessage, HttpConnectMessage, HttpRequestMessage, HttpErrorMessage, HttpServiceMessage, FtpDisconnectMessage, FtpConnectMessage, FtpRequestMessage, FtpTransferMessage, FtpErrorMessage, FtpServiceMessage, WbmpImage, VCardItem, RichTextCompoundItem, PngImage, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditor, JpegImage, ImageItem, GifImage, GeneralCompoundItem, BoundedItem, BmpImage, AudioItem, SerialTerminalArg, MmCallReleaseMsg, MmCallAcceptMsg, MmAocChargingStatusMsg, MmCurrentCallMeterMsg, MmCurrentChargeDataMsg, MmCallNotifyMsg, MmCallInfoMsg, MmCallSetupProgressMsg, MmMocSetupAcceptMsg, MmCallDisconnectingMsg, MmCallStatusMsg, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg, SaLocationErrArg, SaMolrResultArg, CloseDataConnMsg, GltpConnStatusMsg, SendRequestMsg, SetupDataConnMsg, MeasurementDataArg, ProcessMolrMsg, ProviderChangedMsg, AbortResMsg, LocationErrMsg, LocationResMsg, LocationNotifInvokeMsg, AbortResArg, LcsMolrResultArg, LocationNotifInvokeArg, AppActionExecutedMsg, AccessorActionExtension, DrmWapPushMsg, FatFsUsbMassStorageReleaseMsg, FatFsUsbMassStorageRequestMsg, UsimPbResetedMsg, UsimPbReadyMsg, DataControlPhonebookStateMsg, DataControlEndBootMsg, DataControlBootMsg, DataControlBootProgressMsg, DataControlStartBootMsg, DataControlModificationMsg
  • Idle : PdpContextManager
  • IdleState : Camera
  • IeNonExistent : PdpContext, Sms
  • IFrame : VideoEncoder
  • IllegalDirOperationError : File
  • IllegalEquipment : SsErrorCode
  • IllegalIdError : File
  • IllegalMe : PdpContext
  • IllegalModeError : File
  • IllegalMs : PdpContext
  • IllegalSsOperation : SsErrorCode
  • IllegalSubscriber : SsErrorCode
  • IllegalTypeError : File
  • IllegalUserIdError : File
  • IllegalZoomLevel : SvgPlayer
  • IlluminationModeAuto : Keyboard
  • IlluminationModeOff : Keyboard
  • IlluminationModeOn : Keyboard
  • Ilrr : AtResponse
  • ImageBoxClassType : GuiObjectFactory
  • ImageCapturingState : Camera
  • ImageObtainerClassType : GuiObjectFactory
  • ImageUriProp : GuiObjectFactory
  • ImmediateAlphaBlending : DeviceContext
  • ImmediateDecodingFlag : VideoDecoder
  • Implicit : ProtocolIdentifier
  • In : PhoneNumber
  • InAccept : MmCallInfo
  • InactiveFrameBackground : Color
  • InactiveFrameBackgroundColor : CTResourcePack
  • InactiveFrameForeground : Color
  • InactiveFrameForegroundColor : CTResourcePack
  • InactiveTitle : Font
  • InactiveTitleBarBitmap : CTResourcePack
  • InactiveTitleBarBitmapUri : CTResourcePack
  • InactiveTitleBarHeight : CTResourcePack
  • InactiveWindowFrameControl : CTResourcePack
  • InactiveWindowTitle : Color
  • InactiveWindowTitleBarControl : CTResourcePack
  • Inbox : SmsSettingsRecord
  • InCall : MmCallInfo
  • IncandescentBalance : Camera
  • IncBarrServices : InputParser
  • IncompatibleDestination : ShortMessageStatus
  • Incomplete3gppFile : MediaManager
  • InconsistentMemTablesError : File
  • Increase : Camera
  • IndicateItemContProp : GuiObjectFactory
  • IndicatorItemClassType : GuiObjectFactory
  • Indonesian : LanguageManager
  • InitalizedState : MediaRecorder
  • InitCompletionMsg : MediaManager
  • InitializationError : Image, SvgPlayer
  • InitializedState : MediaPlayer
  • InitializingError : File
  • InitiatingRelease : TaggedProblemCode
  • Injective : JoinRule
  • InnerBorderColor : CTResourcePack
  • InPlmnOperatorAssociationsRange : MessageIdentifier
  • InPlmnOperatorSpecificForFutureVersionsRange : MessageIdentifier
  • InPlmnOperatorSpecificRange : MessageIdentifier
  • InProcess : KeyMsgGenerator::Key
  • InProgress : AudioReference, SocketTestT, Image
  • InputChar : Keyboard
  • InputCharType : InputMapItem
  • InputMapperIdProp : GuiObjectFactory
  • InputMapperIdType : GuiObjectFactory
  • InReject : MmCallInfo
  • InRelease : MmCallInfo
  • InReservedForFutureVersionsRange : MessageIdentifier
  • InSecureCellBroadcastDataDownloadRange : MessageIdentifier
  • Insert : WindowManager, TextCompoundItem, BtSddbServiceRecord, BtSddbDeContainer, BtDeviceList, WString, Vector< T >, String, SortedLinkedList< T >, LinkedListBase, SortedElementList< T >, Caret, Provider
  • InsertedItem : InputMapper
  • InsertImageType : EmsInsertPrompt
  • InsertSoundType : EmsInsertPrompt
  • InService : Led
  • InSetup : MmCallInfo
  • InsideDefaultSelectMedia : MediaPlayer
  • InsufficientRessources : PdpContext
  • Int : InternalTracer
  • IntegerNodeType : RegIterator
  • IntegerParseType : CTResourcePack
  • IntegerType : GuiObjectFactory
  • InteriorType : RegIterator
  • InternalError : File
  • InternationalNumber : TypeOfAddress
  • InternetElectronicMail : ProtocolIdentifier
  • Interrogation : InputParser
  • Interworking : ProtocolIdentifier, Sms
  • InUnsecureCellBroadcastDataDownloadRange : MessageIdentifier
  • Invalid : ResultWinBase, ObexHeader, Image, PhoneNumber, PinAction, CallSsAction, KeyMsgGenerator::Key, BaseInformationElement, WapProfile
  • Invalid3gppFile : MediaManager
  • InvalidAlphabet : DataCodingScheme
  • InvalidAudioTrack : MediaManager
  • InvalidCameraParameter : Camera
  • InvalidCause : AudioDeviceBase
  • InvalidClass : DataCodingScheme
  • InvalidCode : TaggedProblemCode
  • InvalidCommand : VrHandler
  • InvalidConnectionElement : DataCallContext
  • InvalidDst : TimeZone
  • InvalidErrorValue : ShortMessageFailureCause
  • InvalidExecutionContext : ObexResult
  • InvalidFileNameError : File
  • InvalidFormatErrorType : AudioDeviceBase
  • InvalidFrameSize : CodecDevice
  • InvalidGroup : ProtocolIdentifier, DataCodingScheme
  • InvalidHandlerType : ExternalCommunicationHandler
  • InvalidHeaderId : ObexResult
  • InvalidHeadersInRequest : ObexResult
  • InvalidId : SimItemId
  • InvalidIdentifier : InformationElement
  • InvalidInterworking : ProtocolIdentifier
  • InvalidItem : EditorItemNode
  • InvalidLanguage : DataCodingScheme
  • InvalidLanguageGroup : DataCodingScheme
  • InvalidMandatoryIe : PdpContext
  • InvalidMandatoryInfo : Sms
  • InvalidMessage : DataCodingScheme
  • InvalidMessageType : ProtocolIdentifier
  • InvalidMethod : WapProfile
  • InvalidMp3File : MediaManager
  • InvalidNumberingPlan : TypeOfAddress
  • InvalidOffset : TimeZone
  • InvalidParameter : MediaManager, CodecDevice
  • InvalidParameterInUrl : ObexResult
  • InvalidPid : ProtocolIdentifier
  • InvalidProcedure : InputParser
  • InvalidReason : AudioPlayerEvent, ShortMessageStatus
  • InvalidReferenceValue : Sms
  • InvalidRequest : RegEncoderDecoder
  • InvalidRfCommPortNumber : BtObexServerAddr
  • InvalidScope : Cbs::SerialNumber
  • InvalidService : WapProfile
  • InvalidServiceGroup : InputParser
  • InvalidSizeError : Image, Camera
  • InvalidSmeAddress : ShortMessageFailureCause
  • InvalidSoundDataSource : AudioReference
  • InvalidSsCode : InputParser
  • InvalidState : MediaManager, CodecDevice
  • InvalidStatus : ShortMessageStatus
  • InvalidStoreLocation : Sms
  • InvalidTag : TaggedProblemCode
  • InvalidTelematicDevice : ProtocolIdentifier
  • InvalidTextCompression : DataCodingScheme
  • InvalidTi : PdpContext
  • InvalidType : MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType
  • InvalidTypeOfAddress : TypeOfAddress
  • InvalidTypeOfNumber : TypeOfAddress
  • InvalidUsage : ProtocolIdentifier, MessageTypeIndicator
  • InvalidValue : ValueTextMap, ReferenceLocation
  • InvalidVideoTrack : MediaManager
  • Inverted : Cbs::Filter
  • InvertedSelection : AbstractEditor
  • InvertRop : DeviceContext
  • Invoke : TaggedProblemCode
  • IOError : File
  • IpAddrEditorClassType : GuiObjectFactory
  • IpAddress : InputMapper
  • IpAddrProp : GuiObjectFactory
  • IpAddrType : GuiObjectFactory
  • IpDynamicType : PdpContext
  • IpStaticType : PdpContext
  • IpType : PdpContext
  • IPv4 : WapProfile
  • IrComm : IrdaTransport
  • Irish : LanguageManager
  • IrLap : IrdaTransport
  • IrLmp : IrdaTransport
  • IrObex : IrdaTransport
  • IsCurrentlyDecodedError : Image
  • IsEndUserDefineableProp : GuiObjectFactory
  • IsolatedWord : VrHandler
  • IsSeparatorProp : GuiObjectFactory
  • Italian : LanguageManager, DataCodingScheme
  • Italic : TextFormat
  • ITEM_COUNT_MSG : TestWriter
  • ITEM_SELECTED_MSG : TestWriter
  • ItemBoxClassType : GuiObjectFactory
  • ItemClassType : GuiObjectFactory
  • ItemContainerClassType : GuiObjectFactory
  • ItemContainerText : MenuProperties
  • ItemContProp : GuiObjectFactory
  • ItemGridClassType : GuiObjectFactory
  • ItemIconIdentifierListTag : Tlv
  • ItemIdentifierTag : Tlv
  • ItemMenuClassType : GuiObjectFactory
  • ItemMenuWindowClassType : GuiObjectFactory
  • ItemProp : GuiObjectFactory
  • ItemPropertyId : Item, AbstractItemContainer
  • ItemRendererAnimTypeProp : GuiObjectFactory
  • ItemRendererDisplayTypeProp : GuiObjectFactory
  • ItemRendererProp : GuiObjectFactory
  • ItemRendererPropertiesAnimType : GuiObjectFactory
  • ItemRendererPropertiesClassType : GuiObjectFactory
  • ItemRendererPropertiesDisplayType : GuiObjectFactory
  • ItemRendererPropertiesType : GuiObjectFactory
  • ItemsNaiTag : Tlv
  • ItemsProp : GuiObjectFactory
  • ItemTag : Tlv
  • ItemText : MenuProperties
  • ItemTextType : ContextFeature
  • ItemTreeClassType : GuiObjectFactory
  • ItemType : EditorItemNode, ContextFeature
  • itemTypeContextFeatureItem : MenuPool
  • itemTypeFeatureItem : MenuPool
  • itemTypeFeatureItemContainer : MenuPool
  • itemTypeFixedContextFeatureItem : MenuPool
  • itemTypeNone : MenuPool
  • itemTypePropertyItem : MenuPool
  • IteratorInteriorMetaData : RegEncoderDecoder
  • IteratorLeafMetaData : RegEncoderDecoder
  • IteratorNodeType : RegEncoderDecoder
  • IteratorUri : RegEncoderDecoder
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- p -

  • Packed : FunctionalityIndicator
  • PaddingMethod2630 : AesCrypt
  • PaddingMethodNone : AesCrypt
  • PadProtocol : PdpContext
  • PageDown : AbstractGrid
  • PageUp : AbstractGrid
  • PaletteFormat : PngEncoder::EncodingParameters
  • PanelOnBottom : Desktop
  • PanelOnLeft : Desktop
  • PanelOnRight : Desktop
  • PanelOnTop : Desktop
  • Pap : PdpContext::Authentication
  • ParagraphItem : EditorItemNode
  • ParentAreaProp : GuiObjectFactory
  • ParentAreaType : GuiObjectFactory
  • ParentItemText : MenuProperties
  • ParityEven : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • ParityEvent : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • ParityMark : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • ParityNone : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • ParityOdd : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • ParitySpace : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • PartialContent : BtObexResponseCode
  • Passed : SocketTestT
  • PasswordEditorClassType : GuiObjectFactory
  • PasswordPropertyDescriptorClassType : GuiObjectFactory
  • Pause : MediaPlayer, ResultWinBase
  • PauseApiCompletionMsg : MediaManager
  • PausedState : MediaRecorder, MediaPlayer
  • PAuthenticate : BtJsr82Url
  • PAuthorize : BtJsr82Url
  • PayloadDataItem : RegEncoderDecoder
  • PayloadInteger : RegEncoderDecoder
  • PayloadIteratorObj : RegEncoderDecoder
  • PCMDeviceID : AudioDeviceManager
  • PcmDspFormat : StreamAudioReference
  • PdpContext : PdpContextManager, PdpContext, PdpContext::PacketFilter
  • PdpContext_ActivationStatus : PdpContext::ActivationStatus
  • PdpContext_Address : PdpContext::Address
  • PdpContext_Authentication : PdpContext::Authentication
  • PdpContext_PacketFilter : PdpContext::PacketFilter
  • PdpContext_QualityOfService : PdpContext::QualityOfService
  • PdpContextManager : PdpContextManager, PdpContextControl, PdpContext
  • PdpContextManager_AttachStatus : PdpContextManager::AttachStatus
  • PeakRate128K : PdpContext::QualityOfService
  • PeakRate16K : PdpContext::QualityOfService
  • PeakRate1K : PdpContext::QualityOfService
  • PeakRate256K : PdpContext::QualityOfService
  • PeakRate2K : PdpContext::QualityOfService
  • PeakRate32K : PdpContext::QualityOfService
  • PeakRate4K : PdpContext::QualityOfService
  • PeakRate64K : PdpContext::QualityOfService
  • PeakRate8K : PdpContext::QualityOfService
  • PeakRateReserved : PdpContext::QualityOfService
  • PeakRateSubscribed : PdpContext::QualityOfService
  • PEncrypt : BtJsr82Url
  • PendingIndication : SmsIndicationState
  • Percent : Layouter, GridLayout
  • PeriodCount : AbstractSmsApp
  • PermanentError : ShortMessageStatus
  • PFrame : VideoEncoder
  • PhoneNumber : PhoneNumber, InputMapper
  • PhoneNumberMode : EditBox
  • PhoneNumberType : ContextFeature
  • PIC_OUTPUT_MSG : TestWriter
  • PictureFrameFilter : Camera
  • pinyin : ChineseQuickSortProvider
  • PinyinBoxCharsId : AbstractPredictiveInputBox
  • PinyinBoxNumbersId : AbstractPredictiveInputBox
  • Pixel : Layouter, GridLayout
  • PlaceAllActiveOnHold : CallSsAction
  • PlaceAllActiveOnHoldExceptSpecificCall : CallSsAction
  • Planes2 : VirtualDisplay
  • Planes4 : VirtualDisplay
  • Planes8 : VirtualDisplay
  • PlayApiCompletionMsg : MediaManager
  • PlayingState : MediaPlayer
  • PlmnNotAllowed : PdpContext
  • PlmnOperatorAssociationsMessageBegin : MessageIdentifier
  • PlmnOperatorAssociationsMessageEnd : MessageIdentifier
  • PlmnOperatorSpecificRangeBegin : MessageIdentifier
  • PlmnOperatorSpecificRangeEnd : MessageIdentifier
  • PlmnWideNormal : Cbs::SerialNumber
  • Plus1Hour : TimeZone
  • Plus2Hours : TimeZone
  • PMaster : BtJsr82Url
  • PName : BtJsr82Url
  • PngFormat : CamWin32
  • Polish : LanguageManager, DataCodingScheme
  • PopUp : MenuProperties
  • Portuguese : LanguageManager, DataCodingScheme
  • PositionIndicatorArrowBoxControl : CTResourcePack
  • PositionIndicatorArrowHeight : CTResourcePack
  • PositionIndicatorBarControl : CTResourcePack
  • PositionIndicatorClassType : GuiObjectFactory
  • PositionIndicatorControl : CTResourcePack
  • PositionIndicatorDrawArrows : CTResourcePack
  • PositionIndicatorEnabledProp : GuiObjectFactory
  • PositionIndicatorOrientationType : GuiObjectFactory
  • PositionIndicatorWidth : CTResourcePack
  • PositionMethodError : SsErrorCode
  • PositionSeparator : OptionalConfigBase
  • PositionType : GuiObjectFactory
  • PosProp : GuiObjectFactory
  • PowerModeAuto : Display
  • PowerModeOff : Display
  • PowerModeOn : Display
  • PowerOff : ShutDown
  • PowerOn : AlarmManager
  • PowerTurnedOff : Display
  • PowerTurnedOn : Display
  • PppProtocol : PdpContext
  • PppType : PdpContext
  • PpUnspecified : Sms
  • PrecedenceHigh : PdpContext::QualityOfService
  • PrecedenceLow : PdpContext::QualityOfService
  • PrecedenceNormal : PdpContext::QualityOfService
  • PrecedenceReserved : PdpContext::QualityOfService
  • PrecedenceSubscribed : PdpContext::QualityOfService
  • PreconditionFailed : BtObexResponseCode
  • PredArabic : PredInputMapper
  • PredBpmf : PredInputMapper
  • PredefinedAnimation : InformationElement
  • PredefinedFeatureEnd : AudioDeviceBase
  • PredefinedSound : InformationElement
  • PredefinedSoundDataSourceEnd : AudioReference
  • PredEnglish : PredInputMapper
  • PredHebrew : PredInputMapper
  • Predictive : InputMapper
  • PredInputMapperPredModeType : GuiObjectFactory
  • PredInputMode : EditBox
  • PredMultiTap : PredInputMapper
  • PredNone : PredInputMapper
  • PredPinyin : PredInputMapper
  • PredSimplifiedChineseStroke : PredInputMapper
  • PredSymbol : PredInputMapper
  • PredThai : PredInputMapper
  • PredThaiMatrix : PredInputMapper
  • PredTraditionalChineseStroke : PredInputMapper
  • Preferred : Sms
  • PreferredDataCompression : PdpContext
  • PreferredHeaderCompression : PdpContext
  • PresentationAllowed : PhoneNumber
  • PresentationReserved : PhoneNumber
  • PresentationRestricted : PhoneNumber
  • PresentationUndefined : PhoneNumber
  • PresetSoundDataSource : AudioReference
  • PresetSoundToneDTMF0 : AudioPreset
  • PresetSoundToneDTMF1 : AudioPreset
  • PresetSoundToneDTMF2 : AudioPreset
  • PresetSoundToneDTMF3 : AudioPreset
  • PresetSoundToneDTMF4 : AudioPreset
  • PresetSoundToneDTMF5 : AudioPreset
  • PresetSoundToneDTMF6 : AudioPreset
  • PresetSoundToneDTMF7 : AudioPreset
  • PresetSoundToneDTMF8 : AudioPreset
  • PresetSoundToneDTMF9 : AudioPreset
  • PresetSoundToneDTMFAsterix : AudioPreset
  • PresetSoundToneDTMFHash : AudioPreset
  • PresetSoundToneInfoAlarmInCall : AudioPreset
  • PresetSoundToneInfoAutoRedial : AudioPreset
  • PresetSoundToneInfoBroadcastInCall : AudioPreset
  • PresetSoundToneInfoConnection : AudioPreset
  • PresetSoundToneInfoDeviceIn : AudioPreset
  • PresetSoundToneInfoDeviceOut : AudioPreset
  • PresetSoundToneInfoDialTone : AudioPreset
  • PresetSoundToneInfoDisconnect : AudioPreset
  • PresetSoundToneInfoError1 : AudioPreset
  • PresetSoundToneInfoError2 : AudioPreset
  • PresetSoundToneInfoFreeTone : AudioPreset
  • PresetSoundToneInfoLowBat : AudioPreset
  • PresetSoundToneInfoLowBatInCall : AudioPreset
  • PresetSoundToneInfoMinutteMinder : AudioPreset
  • PresetSoundToneInfoMsgFull : AudioPreset
  • PresetSoundToneInfoNegativeAcknowledgement : AudioPreset
  • PresetSoundToneInfoNetworkAttention : AudioPreset
  • PresetSoundToneInfoPositiveAcknowledgement : AudioPreset
  • PresetSoundToneInfoPowerOff : AudioPreset
  • PresetSoundToneInfoPowerOn : AudioPreset
  • PresetSoundToneInfoSingleBeep : AudioPreset
  • PresetSoundToneInfoSmsInCall : AudioPreset
  • PresetSoundToneInfoUssd : AudioPreset
  • PresetSoundToneKeyTone1 : AudioPreset
  • PresetSoundToneKeyTone2 : AudioPreset
  • PresetSoundToneKeyTone3 : AudioPreset
  • PresetSoundToneKeyTone4 : AudioPreset
  • PresetSoundToneKeyTone5 : AudioPreset
  • PresetSoundToneRinger1 : AudioPreset
  • PresetSoundToneSvCallWaiting : AudioPreset
  • PresetSoundToneSvCongestion : AudioPreset
  • PresetSoundToneSvErrorInfo : AudioPreset
  • PresetSoundToneSvRadioPatAck : AudioPreset
  • PresetSoundToneSvRadioPathNotAvail : AudioPreset
  • PresetSoundToneSvSubscriberBusy : AudioPreset
  • PresetSoundToneUnknown : AudioPreset
  • Prev : AbstractSmsViewerWin
  • PreviewState : MediaRecorder
  • PreviousFunction : T9InputConfig
  • PrimaryDefinePending : PdpContextManager
  • PrimaryUndefinePending : PdpContextManager
  • PrioHigh : GenericAudioDevice
  • PrioNormal : GenericAudioDevice
  • PriorityBackground1 : Thread
  • PriorityBackground2 : Thread
  • PriorityBackground3 : Thread
  • PriorityBackground4 : Thread
  • PriorityBackground5 : Thread
  • PriorityCount : ToDoRecord
  • PriorityForeground1 : Thread
  • PriorityForeground2 : Thread
  • PriorityForeground3 : Thread
  • PriorityForeground4 : Thread
  • PriorityForeground5 : Thread
  • PriorityHigh : Audio
  • PriorityLow : Audio
  • PriorityManagementCause : AudioDeviceBase
  • PriorityMedium : Audio
  • PriorityNone : Audio
  • PriorityNormal : Thread
  • PrivateNumberingPlan : TypeOfAddress
  • PrivateTransport : ObexServerDispatcher
  • ProductionTestOn : StartUp
  • ProgressBarBarControl : CTResourcePack
  • ProgressBarBitmap : CTResourcePack
  • ProgressBarClassType : GuiObjectFactory
  • ProgressBarControl : CTResourcePack
  • ProgressBarDrawingMode : CTResourcePack
  • ProgressBarDrawModeParseType : CTResourcePack
  • ProgressBarDrawPercentage : CTResourcePack
  • ProgressBarHeight : CTResourcePack
  • ProgressProp : GuiObjectFactory
  • ProgressPropertyDescriptorClassType : GuiObjectFactory
  • PropAccount : DataConnApp
  • PropApnName : DataConnApp
  • PropAuthType : DataConnApp
  • PropCallType : DataConnApp
  • PropCount : GuiObjectFactory
  • PropDataCompr : DataConnApp
  • PropDataRate : DataConnApp
  • PropertyContainerClassType : GuiObjectFactory
  • PropertyDescriptorClassType : GuiObjectFactory
  • PropertyDescriptorProp : GuiObjectFactory
  • PropertyItemClassType : GuiObjectFactory
  • PropertyItemEditorProp : GuiObjectFactory
  • PropertyItemTypeProp : GuiObjectFactory
  • PropertyListProp : GuiObjectFactory
  • PropIdleTimer : DataConnApp
  • PropInvalidId : DataConnApp
  • PropLingerTimer : DataConnApp
  • PropLocalAddr : DataConnApp
  • PropName : DataConnApp
  • PropPasswd : DataConnApp
  • PropPhoneNo : DataConnApp
  • PropPrimaryDnsServerAddress : DataConnApp
  • PropQosDelay : DataConnApp
  • PropQosMeanRate : DataConnApp
  • PropQosPeakRate : DataConnApp
  • PropQosPrecedence : DataConnApp
  • PropQosReliability : DataConnApp
  • PropQueryPasswd : DataConnApp
  • PropSecondaryDnsServerAddress : DataConnApp
  • PropSerIdleTimer : DataConnApp
  • PropSerLingerTimer : DataConnApp
  • ProtocollError : Sms
  • ProviderType : ContextFeature
  • PsdPropCount : DataConnApp
  • PsParam : TestparamReport
  • PtNoValue : AtResponseParameter
  • PtNumeric : AtResponseParameter
  • PtString : AtResponseParameter
  • PushButtonClassType : GuiObjectFactory
  • PushButtonControl : CTResourcePack
  • PushButtonHeight : CTResourcePack
  • PuzzleTileFilter : Camera
  • PwRegistrationFailure : SsErrorCode
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- q -

  • Qcelp : MediaInfo, CodecDevice
  • QcifSize : CamWin32, Camera
  • QosNotAccepted : PdpContext
  • QqcifSize : CamWin32, Camera
  • QqvgaSize : CamWin32, Camera
  • QsifSize : CamWin32, Camera
  • QualityHigh : RecordSettings
  • QualityLevel : VideoDecoder, AudioDecoder
  • QualityLow : RecordSettings
  • QualityNormal : RecordSettings
  • QualityOfServiceNotAvailable : ShortMessageStatus
  • QvgaSize : CamWin32, Camera
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- r -

  • RADIO_ACTIVE_MSG : TestWriter
  • RADIO_SELECTED_MSG : TestWriter
  • RadioButtonActionClassType : GuiObjectFactory
  • RadioButtonControlClassType : GuiObjectFactory
  • RadioButtonGroupClassType : GuiObjectFactory
  • RadioButtonGroupProp : GuiObjectFactory
  • RadioDeviceID : AudioDeviceManager
  • RadioFmOff : FmRadioApplication
  • RadioFmOn : FmRadioApplication
  • RadioFmOnMinimized : FmRadioApplication
  • RadioFmToRestart : FmRadioApplication
  • RadioPriorityLevel_1 : PdpContext::ActivationStatus
  • RadioPriorityLevel_2 : PdpContext::ActivationStatus
  • RadioPriorityLevel_3 : PdpContext::ActivationStatus
  • RadioPriorityLevel_4 : PdpContext::ActivationStatus
  • RadioPriorityLevel_Undefined : PdpContext::ActivationStatus
  • Raised : CTResourcePack
  • RaisedBorder : CTResourcePack
  • RamMedia : StreamAudioReference
  • RamSoundDataSource : AudioReference
  • RangeCountProp : GuiObjectFactory
  • RangeError : File
  • RangeMappingPolicyClassType : GuiObjectFactory
  • Rat : TestparamReport
  • Rate0 : VoiceMemoAudioDevice
  • Rate1 : VoiceMemoAudioDevice
  • Rate2 : VoiceMemoAudioDevice
  • Rate3 : VoiceMemoAudioDevice
  • Rate4 : VoiceMemoAudioDevice
  • Rate5 : VoiceMemoAudioDevice
  • Rate6 : VoiceMemoAudioDevice
  • Rate7 : VoiceMemoAudioDevice
  • RawFormat : CamWin32
  • ReactivationRequired : PdpContext
  • Read : FfsDataConnProfileStorage, UdpSocket, TcpSocket, Socket, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket, DataConnProfileStorage, SocketPeer, NonsharedBinDataDataSource, NvRamStorage, InputStream, FileInputStream, FfsFile, RomData, RamData, HeapDataSource, DataSourceBinData, DataSource, ChildBinData, BinDataDataSource, BinData, MemMap, SmsSocket, ExtPsdContextListener_SerialTerminal, UserData, FileDataSource, FileChunkOperator, FileBinData, File, RegNodeBuffer, FlsFile, FfsHandler, SvgIoWrapper, SvgImageFileWrapper, SvgGzFileWrapper, SvgFileWrapper, SioSocketAdapter, SerialSocket, SerialIoAdapter, SerialTerminalSocket, SerialTerminal, RamHandler, RamFileObj, RamFile, FatHandler, FatFile, Tpdu
  • ReadAndWriteMode : File
  • ReadCounterPending : PdpContextManager
  • ReadCountersPending : PdpContextManager
  • ReadNegotiatedDnsServerAddressPending : PdpContextManager
  • ReadOffsetExact : FileChunkOperator
  • ReadOffsetMax : FileChunkOperator
  • ReadOnly : StorageDevice, File::Attributes
  • ReadOnlyMode : File
  • ReadOnlyProp : GuiObjectFactory
  • ReadyState : MediaPlayer
  • RealTimeClockCategory : AbstractDevice
  • RecordApiCompletionMsg : MediaManager
  • RecordingState : MediaRecorder
  • RectType : GuiObjectFactory
  • RecurrenceCounts : CalendarRecord
  • RedEyeReductionFlash : Camera
  • RedirectCall : CallSsAction
  • RegError : RegEncoderDecoder
  • RegisterNewPassword : InputParser
  • RegisterNotify : Registry, RegEncoderDecoder
  • RegisterType : UibApp
  • Registration : InputParser
  • RegNoService : RegEncoderDecoder
  • RegResChildLocked : RegEncoderDecoder
  • RegResNodeAlreadyExists : RegEncoderDecoder
  • RegResNoGetOnInterior : RegEncoderDecoder
  • RegSuccess : RegEncoderDecoder
  • RegularDeactivation : PdpContext
  • Relative : FunctionalityIndicator, ValidityPeriodFormat
  • RelativeBaseYear : DateTime
  • ReleaseAllActiveAndAcceptOther : CallSsAction
  • ReleaseAllHeldOrSetUdub : CallSsAction
  • ReleaseSpecificCall : CallSsAction
  • ReliabilityClass1 : PdpContext::QualityOfService
  • ReliabilityClass2 : PdpContext::QualityOfService
  • ReliabilityClass3 : PdpContext::QualityOfService
  • ReliabilityClass4 : PdpContext::QualityOfService
  • ReliabilityClass5 : PdpContext::QualityOfService
  • ReliabilityClass6 : PdpContext::QualityOfService
  • ReliabilityReserved : PdpContext::QualityOfService
  • ReliabilitySubscribed : PdpContext::QualityOfService
  • RelTagAgreement : XmlParserRel
  • RelTagAsset : XmlParserRel
  • RelTagConstraint : XmlParserRel
  • RelTagContext : XmlParserRel
  • RelTagCount : XmlParserRel
  • RelTagDatetime : XmlParserRel
  • RelTagDisplay : XmlParserRel
  • RelTagEnd : XmlParserRel
  • RelTagExecute : XmlParserRel
  • RelTagInterval : XmlParserRel
  • RelTagKeyInfo : XmlParserRel
  • RelTagKeyValue : XmlParserRel
  • RelTagNone : XmlParserRel
  • RelTagPermission : XmlParserRel
  • RelTagPlay : XmlParserRel
  • RelTagPrint : XmlParserRel
  • RelTagRights : XmlParserRel
  • RelTagStart : XmlParserRel
  • RelTagUid : XmlParserRel
  • RelTagVersion : XmlParserRel
  • RelWbxmlAgreement : WbxmlParserRel
  • RelWbxmlAsset : WbxmlParserRel
  • RelWbxmlAttDd : WbxmlParserRel
  • RelWbxmlAttDdVal : WbxmlParserRel
  • RelWbxmlAttLang : WbxmlParserRel
  • RelWbxmlAttLangVal : WbxmlParserRel
  • RelWbxmlAttNone : WbxmlParserRel
  • RelWbxmlAttSig : WbxmlParserRel
  • RelWbxmlAttSigVal : WbxmlParserRel
  • RelWbxmlAttValNone : WbxmlParserRel
  • RelWbxmlConstraint : WbxmlParserRel
  • RelWbxmlContext : WbxmlParserRel
  • RelWbxmlCount : WbxmlParserRel
  • RelWbxmlDatetime : WbxmlParserRel
  • RelWbxmlDisplay : WbxmlParserRel
  • RelWbxmlEnd : WbxmlParserRel
  • RelWbxmlExecute : WbxmlParserRel
  • RelWbxmlInterval : WbxmlParserRel
  • RelWbxmlKeyInfo : WbxmlParserRel
  • RelWbxmlKeyValue : WbxmlParserRel
  • RelWbxmlNone : WbxmlParserRel
  • RelWbxmlPermission : WbxmlParserRel
  • RelWbxmlPlay : WbxmlParserRel
  • RelWbxmlPrint : WbxmlParserRel
  • RelWbxmlRights : WbxmlParserRel
  • RelWbxmlStart : WbxmlParserRel
  • RelWbxmlUid : WbxmlParserRel
  • RelWbxmlVersion : WbxmlParserRel
  • RemoteAbort : TipdBasedActiveWaitDispatcher
  • RemoteProcedureError : ShortMessageStatus
  • Removable : StorageDevice
  • Render : ThaiTextRenderer
  • RendererPropertiesProp : GuiObjectFactory
  • RendererPropertyId : AbstractItemContainer
  • ReplaceShortMessageType1 : ProtocolIdentifier
  • ReplaceShortMessageType2 : ProtocolIdentifier
  • ReplaceShortMessageType3 : ProtocolIdentifier
  • ReplaceShortMessageType4 : ProtocolIdentifier
  • ReplaceShortMessageType5 : ProtocolIdentifier
  • ReplaceShortMessageType6 : ProtocolIdentifier
  • ReplaceShortMessageType7 : ProtocolIdentifier
  • ReqFaciltyNonImpl : Sms
  • Request : ObexObject
  • RequestAudMapiFailure : AudioMapiManager
  • RequestedServiceOptionNotSubscribed : PdpContext
  • RequestExecuted : AudioMapiManager
  • RequestRejected : AudioMapiManager
  • RequestTimeout : AudioMapiManager
  • RequestUnexpectedCommand : AudioMapiManager
  • Reserved : InformationElement
  • ReservedAlphabet : DataCodingScheme
  • ReservedApplicationErrorBegin : ShortMessageFailureCause
  • ReservedApplicationErrorEnd : ShortMessageFailureCause
  • ReservedCodingGroup : DataCodingScheme
  • ReservedCommandErrorBegin : ShortMessageFailureCause
  • ReservedCommandErrorEnd : ShortMessageFailureCause
  • ReservedDcsErrorBegin : ShortMessageFailureCause
  • ReservedDcsErrorEnd : ShortMessageFailureCause
  • ReservedErrorValue : ShortMessageFailureCause
  • ReservedGeneralErrorBegin : ShortMessageFailureCause
  • ReservedGeneralErrorEnd : ShortMessageFailureCause
  • ReservedIdentifier : InformationElement
  • ReservedLanguage : DataCodingScheme
  • ReservedMessageType : ProtocolIdentifier
  • ReservedNumberingPlan : TypeOfAddress
  • ReservedPidErrorBegin : ShortMessageFailureCause
  • ReservedPidErrorEnd : ShortMessageFailureCause
  • ReservedReason : ShortMessageStatus
  • ReservedScErrorBegin : ShortMessageFailureCause
  • ReservedScErrorEnd : ShortMessageFailureCause
  • ReservedStatus : ShortMessageStatus
  • ReservedTelematicDevice : ProtocolIdentifier
  • ReservedTimeFormat : FunctionalityIndicator
  • ReservedTpduErrorBegin : ShortMessageFailureCause
  • ReservedTpduErrorEnd : ShortMessageFailureCause
  • ReservedType : MessageTypeIndicator, CommandType
  • ReservedTypeOfNumber : TypeOfAddress
  • ReservedUsage : ProtocolIdentifier
  • ReservedUSimErrorBegin : ShortMessageFailureCause
  • ReservedUSimErrorEnd : ShortMessageFailureCause
  • Reset : PppSetupCallBackData, ObexServerPort, StartUp::Data, EmzUtils::Queue< T >, EmzH264Decoder, EmzUtils::Queue< T >, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, Led, AbstractEditBoxModel, DateTime::Persist, StackMsgActiveWaitDispatcher, SmsFactory, PdpContextManager::AttachStatus, PdpContextManager::DataCounters, PdpContext::ActivationStatus, PdpContext::QualityOfService, PdpContext::Address, DataCallContext, UserData, UriMappingTable, Pathname, VrHandler, RamFileObj, StatusProvider, SimTkMainMenuProvider, SimSmsParamHandler, SimPduHandler, SimPbEntryCont, SimPbBaseHandler, SimCphsHandler, SimChvHandler, SimAuxHandler, SimAccessor, DataHandler, Camera
  • ResetCountersPending : PdpContextManager
  • ResourceLimitation : TaggedProblemCode
  • ResourceNotAvailable : ObexResult
  • ResourcesNotAvailable : SsErrorCode
  • ResourcesUnavailable : Sms
  • RespBadGateWay : ObexObject
  • RespBadRequest : ObexObject
  • RespConflict : ObexObject
  • RespDatabaseFull : ObexObject
  • RespDatabaseLocked : ObexObject
  • RespForbidden : ObexObject
  • RespGatewayTimeOut : ObexObject
  • RespGone : ObexObject
  • RespHttpVersionNotSupported : ObexObject
  • RespInternalServerError : ObexObject
  • RespLengthRequired : ObexObject
  • RespMethodNotAllowed : ObexObject
  • RespMovedPermanently : ObexObject
  • RespMovedTemporarily : ObexObject
  • RespMultipleChoices : ObexObject
  • RespNotAcceptable : ObexObject
  • RespNotFound : ObexObject
  • RespNotImplemented : ObexObject
  • RespNotModified : ObexObject
  • RespOk : ObexObject
  • ResponseMessage : RegEncoderDecoder
  • RespPaymentRequired : ObexObject
  • RespPreconditionFailed : ObexObject
  • RespProxyAuthenticationRequired : ObexObject
  • RespRequestedEntityTooLarge : ObexObject
  • RespRequestTimeOut : ObexObject
  • RespRequestUnsupportedMediaType : ObexObject
  • RespRequestUrlTooLarge : ObexObject
  • RespSeeOther : ObexObject
  • RespServiceUnavailable : ObexObject
  • RespUnauthorized : ObexObject
  • RespUseProxy : ObexObject
  • Restart : Timer, SystemTimer, ImageBox, StartUp, SharedTimer, SvgPlayer, ShutDown
  • ReturnCallMessage : ProtocolIdentifier
  • ReturnError : TaggedProblemCode
  • ReturnErrorUnexpected : TaggedProblemCode
  • ReturnResult : TaggedProblemCode
  • ReturnResultUnexpected : TaggedProblemCode
  • ReusedExtendedObject : InformationElement
  • RewindApiCompletionMsg : MediaManager
  • RewindingState : MediaPlayer
  • Rfc1144 : PdpContext
  • Rfc2507 : PdpContext
  • Rfc3095 : PdpContext
  • Rfc822EmailHeader : InformationElement
  • RfsMedia : StreamAudioReference
  • Rgb565ColorSpace : Image::MetaData
  • Rgb888ColorSpace : Image::MetaData
  • Rgba8888ColorSpace : Image::MetaData
  • RgbAlphaFormat : PngEncoder::EncodingParameters
  • RgbFormat : PngEncoder::EncodingParameters
  • Right : TextFormat, Layouter, GridLayout, Control::NavigationGuidance, AbstractGrid, Indicator, InformationElement
  • RightAlign : EditorDocument
  • RightPos : TabButton
  • RightSection : Desktop
  • RightSoftkeyProp : GuiObjectFactory
  • RightToLeft : Locale
  • RightToLeftType : BidiManager
  • Ring : AtResponse
  • Ringer1 : RingerAudioDevice
  • Ringer10 : RingerAudioDevice
  • Ringer11 : RingerAudioDevice
  • Ringer12 : RingerAudioDevice
  • Ringer13 : RingerAudioDevice
  • Ringer14 : RingerAudioDevice
  • Ringer15 : RingerAudioDevice
  • Ringer16 : RingerAudioDevice
  • Ringer17 : RingerAudioDevice
  • Ringer18 : RingerAudioDevice
  • Ringer19 : RingerAudioDevice
  • Ringer2 : RingerAudioDevice
  • Ringer20 : RingerAudioDevice
  • Ringer21 : RingerAudioDevice
  • Ringer22 : RingerAudioDevice
  • Ringer23 : RingerAudioDevice
  • Ringer24 : RingerAudioDevice
  • Ringer25 : RingerAudioDevice
  • Ringer26 : RingerAudioDevice
  • Ringer27 : RingerAudioDevice
  • Ringer28 : RingerAudioDevice
  • Ringer29 : RingerAudioDevice
  • Ringer3 : RingerAudioDevice
  • Ringer30 : RingerAudioDevice
  • Ringer31 : RingerAudioDevice
  • Ringer32 : RingerAudioDevice
  • Ringer33 : RingerAudioDevice
  • Ringer34 : RingerAudioDevice
  • Ringer35 : RingerAudioDevice
  • Ringer36 : RingerAudioDevice
  • Ringer37 : RingerAudioDevice
  • Ringer38 : RingerAudioDevice
  • Ringer39 : RingerAudioDevice
  • Ringer4 : RingerAudioDevice
  • Ringer40 : RingerAudioDevice
  • Ringer41 : RingerAudioDevice
  • Ringer42 : RingerAudioDevice
  • Ringer43 : RingerAudioDevice
  • Ringer44 : RingerAudioDevice
  • Ringer45 : RingerAudioDevice
  • Ringer46 : RingerAudioDevice
  • Ringer47 : RingerAudioDevice
  • Ringer48 : RingerAudioDevice
  • Ringer49 : RingerAudioDevice
  • Ringer5 : RingerAudioDevice
  • Ringer50 : RingerAudioDevice
  • Ringer6 : RingerAudioDevice
  • Ringer7 : RingerAudioDevice
  • Ringer8 : RingerAudioDevice
  • Ringer9 : RingerAudioDevice
  • RingerAlarm1 : RingerAudioDevice
  • RingerAlarm10 : RingerAudioDevice
  • RingerAlarm2 : RingerAudioDevice
  • RingerAlarm3 : RingerAudioDevice
  • RingerAlarm4 : RingerAudioDevice
  • RingerAlarm5 : RingerAudioDevice
  • RingerAlarm6 : RingerAudioDevice
  • RingerAlarm7 : RingerAudioDevice
  • RingerAlarm8 : RingerAudioDevice
  • RingerAlarm9 : RingerAudioDevice
  • RingerBroadcast1 : RingerAudioDevice
  • RingerBroadcast10 : RingerAudioDevice
  • RingerBroadcast2 : RingerAudioDevice
  • RingerBroadcast3 : RingerAudioDevice
  • RingerBroadcast4 : RingerAudioDevice
  • RingerBroadcast5 : RingerAudioDevice
  • RingerBroadcast6 : RingerAudioDevice
  • RingerBroadcast7 : RingerAudioDevice
  • RingerBroadcast8 : RingerAudioDevice
  • RingerBroadcast9 : RingerAudioDevice
  • RingerDeviceID : AudioDeviceManager
  • RingerDeviceSound : RingerAudioDevice
  • RingerDeviceSoundAndVibrator : RingerAudioDevice
  • RingerDeviceVibrator : RingerAudioDevice
  • RingerGame1 : RingerAudioDevice
  • RingerGame10 : RingerAudioDevice
  • RingerGame2 : RingerAudioDevice
  • RingerGame3 : RingerAudioDevice
  • RingerGame4 : RingerAudioDevice
  • RingerGame5 : RingerAudioDevice
  • RingerGame6 : RingerAudioDevice
  • RingerGame7 : RingerAudioDevice
  • RingerGame8 : RingerAudioDevice
  • RingerGame9 : RingerAudioDevice
  • RingerInfoConnection : RingerAudioDevice
  • RingerInfoDeviceIn : RingerAudioDevice
  • RingerInfoDeviceOut : RingerAudioDevice
  • RingerInfoError1 : RingerAudioDevice
  • RingerInfoError2 : RingerAudioDevice
  • RingerInfoLowBat : RingerAudioDevice
  • RingerInfoMsgFull : RingerAudioDevice
  • RingerInfoPowerOff : RingerAudioDevice
  • RingerInfoPowerOn : RingerAudioDevice
  • RingerMessage1 : RingerAudioDevice
  • RingerMessage10 : RingerAudioDevice
  • RingerMessage2 : RingerAudioDevice
  • RingerMessage3 : RingerAudioDevice
  • RingerMessage4 : RingerAudioDevice
  • RingerMessage5 : RingerAudioDevice
  • RingerMessage6 : RingerAudioDevice
  • RingerMessage7 : RingerAudioDevice
  • RingerMessage8 : RingerAudioDevice
  • RingerMessage9 : RingerAudioDevice
  • RingerType : AudioPreset
  • RingerVolume1 : RingerAudioDevice
  • RingerVolume2 : RingerAudioDevice
  • RingerVolume3 : RingerAudioDevice
  • RingerVolume4 : RingerAudioDevice
  • RingerVolume5 : RingerAudioDevice
  • RingerVolumeInCall : RingerAudioDevice
  • RingerVolumeOff : RingerAudioDevice
  • Romanian : LanguageManager
  • Rot180 : DeviceContext
  • Rot270 : DeviceContext
  • Rot90 : DeviceContext
  • Rotate : SvgPlayer, SvgImage, VideoChannel
  • Rotate180 : CamWin32, Camera
  • Rotate270 : CamWin32, Camera
  • Rotate90 : CamWin32, Camera
  • Rotation180Transformation : VideoChannel
  • Rotation270Transformation : VideoChannel
  • Rotation90Transformation : VideoChannel
  • Rounded : CTResourcePack
  • RoundedCornerRadius : CTResourcePack
  • RowColumnPropType : GuiObjectFactory
  • RowCountProp : GuiObjectFactory
  • RowPropertiesProp : GuiObjectFactory
  • RpAck : Sms
  • RParameterDuplicatedErr : BtJsr82Url
  • RParameterValueRangeErr : BtJsr82Url
  • RParsing : BtJsr82Url
  • RrcParam : RrcParam, TestparamReport
  • RrMode : TestparamReport
  • RrParam : RrParam, TestparamReport
  • RSecuritySettingsErr : BtJsr82Url
  • RSuccess : BtJsr82Url
  • RSyntaxErr : BtJsr82Url
  • Russian : LanguageManager, DataCodingScheme
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- s -

  • SamplingFrequencyNotSupportedMsg : MediaManager
  • Saturday : Date
  • ScaleToBounds : DisplaySettings
  • ScanInternalError : StorageDevice
  • ScanlineBufferError : Image
  • ScanNonRepairableProblemDetected : StorageDevice
  • ScanNotSupported : StorageDevice
  • ScanOk : StorageDevice
  • ScanProblemDetected : StorageDevice
  • ScanProblemRepaired : StorageDevice
  • ScanRepairableProblemDetected : StorageDevice
  • ScanRepairFailed : StorageDevice
  • ScBusy : ShortMessageFailureCause
  • ScreeningUndefined : PhoneNumber
  • ScreenSizingParameters : SimTkProfile
  • ScrollbarAlignment : OptionalConfigBase
  • ScrollbarDisplayPolicy : OptionalConfigBase
  • ScrollDelayProp : GuiObjectFactory
  • ScrollGap : OptionalConfigBase
  • ScrollGapProp : GuiObjectFactory
  • ScSystemFailure : ShortMessageFailureCause
  • SdbAutoRegister : ObexServerDispatcher
  • SearchStopLevelHigh : RadioAudioDevice
  • SearchStopLevelLow : RadioAudioDevice
  • SearchStopLevelMid : RadioAudioDevice
  • SecondaryDefinePending : PdpContextManager
  • SecondaryUndefinePending : PdpContextManager
  • SecondOnly : JoinProvider
  • Seconds : FunctionalityIndicator
  • SecureCellBroadcastDataDownloadRangeBegin : MessageIdentifier
  • SecureCellBroadcastDataDownloadRangeEnd : MessageIdentifier
  • SeekCur : File
  • SeekDirectionDown : RadioAudioDevice
  • SeekDirectionUp : RadioAudioDevice
  • SeekEnd : File
  • SeekModeAuto : RadioAudioDevice
  • SeekModeManual : RadioAudioDevice
  • SeekSet : File
  • SelectBitmapId : AbstractPredictiveInputBox
  • SelectedCheckBoxBitmap : CTResourcePack
  • SelectedCheckBoxBitmapUri : CTResourcePack
  • SelectedCheckBoxId : Theme
  • SelectedProp : GuiObjectFactory
  • SelectedPropertyId : AbstractToggleAction
  • SelectedRadioButtonBitmap : CTResourcePack
  • SelectedRadioButtonBitmapUri : CTResourcePack
  • SelectedRadioButtonId : Theme
  • SelectedStyle : AbstractItemRenderer
  • SelectionBackground : Color
  • SelectionBackgroundColor : CTResourcePack
  • SelectionBoxChineseId : AbstractPredictiveInputBox
  • SelectionBoxComponentsId : AbstractPredictiveInputBox
  • SelectionBoxIndexId : AbstractPredictiveInputBox
  • SelectionBoxSimpId : AbstractPredictiveInputBox
  • SelectionBoxTradId : AbstractPredictiveInputBox
  • SelectionForeground : Color
  • SelectionForegroundColor : CTResourcePack
  • SelectionStyle : AbstractEditor, OptionalConfigBase
  • SelLineNotValid : XCallInfoResponseParser
  • SemanticIncorrectMsg : PdpContext
  • SemantIncorrectMsg : Sms
  • SemiDashed : Pen
  • SendingAnimationType : AbstractSmsApp
  • SendInternalSmsType : AbstractSmsApp
  • SendSmsType : AbstractSmsApp
  • Sent : Tpdu
  • SentSmsrInSmsr : Tpdu
  • SentSmsrNoSmsr : Tpdu
  • SentSmsrReq : Tpdu
  • SeparatorPropertyId : Item
  • SepiaFilter : Camera
  • September : Date
  • Serbian : LanguageManager
  • SerboCroatian : LanguageManager
  • SerPropCount : DataConnApp
  • ServAls : SimCphsHandler
  • ServAoC : SimCphsHandler
  • ServBaic : SimCphsHandler
  • ServBicRoam : SimCphsHandler
  • ServBoac : SimCphsHandler
  • ServBoic : SimCphsHandler
  • ServBoicExHc : SimCphsHandler
  • ServCcbs : SimCphsHandler
  • ServCfb : SimCphsHandler
  • ServCfnrc : SimCphsHandler
  • ServCfnry : SimCphsHandler
  • ServCfu : SimCphsHandler
  • ServCliBlock : SimCphsHandler
  • ServClip : SimCphsHandler
  • ServCliSend : SimCphsHandler
  • ServCoLp : SimCphsHandler
  • ServCoLr : SimCphsHandler
  • ServCt : SimCphsHandler
  • ServCug : SimCphsHandler
  • ServCugOA : SimCphsHandler
  • ServCw : SimCphsHandler
  • ServData : SimCphsHandler
  • ServDelConf : SimCphsHandler
  • ServerAddrTypeId : ObexAbstractTransport
  • ServerAlreadyClosed : ObexResult
  • ServerAlreadyKnown : ObexResult
  • ServerAlreadyOpen : ObexResult
  • ServerUrlType : BtJsr82Url
  • ServFax : SimCphsHandler
  • ServGprs : SimCphsHandler
  • ServHold : SimCphsHandler
  • ServHscsd : SimCphsHandler
  • SERVICE_THREAD : ExecutionContext
  • ServiceCenterSpecificReason : ShortMessageStatus
  • ServiceCenterSpecificTelematicDevice : ProtocolIdentifier
  • ServiceCenterSpecificType : CommandType
  • ServiceCenterSpecificUsage : ProtocolIdentifier
  • ServiceCentreSpecificPlan : TypeOfAddress
  • ServiceOptionNotSupported : PdpContext
  • ServiceOptionTemporaryOutOfOrder : PdpContext
  • ServicePlug : Accessory
  • ServiceRejected : ShortMessageStatus
  • ServiceUnavailable : BtObexResponseCode
  • ServInfoNumbers : SimCphsHandler
  • ServingCell : TestparamReport
  • ServLanguage : SimCphsHandler
  • ServMci : SimCphsHandler
  • ServMpty : SimCphsHandler
  • ServMtplBand : SimCphsHandler
  • ServMtplSubscrPfl : SimCphsHandler
  • ServPlmnMode : SimCphsHandler
  • ServPrefCug : SimCphsHandler
  • ServProtId : SimCphsHandler
  • ServReplyPath : SimCphsHandler
  • ServResError : Service
  • ServResSuccess : Service
  • ServSmCb : SimCphsHandler
  • ServSmMo : SimCphsHandler
  • ServSmmoEmail : SimCphsHandler
  • ServSmmoPaging : SimCphsHandler
  • ServSmMt : SimCphsHandler
  • ServUserUserSig : SimCphsHandler
  • ServValPeriod : SimCphsHandler
  • ServVoiceBcstServ : SimCphsHandler
  • ServVoiceGrpCall : SimCphsHandler
  • ServVps : SimCphsHandler
  • SessionParams : ObexHeader
  • SessionSeqNum : ObexHeader
  • Set : TickValue, RomFont, Rect, Locale, Mp3AudioDevice, SoftkeyBar, BitField< T >, Fraction, CfuService, UsimLanguage, ExtLanguage, RegIterator, Registry, LocalDataStore, TpduPhoneNumberPersist, RegEncoderDecoder, KeyMsgGenerator::Key
  • SetAutomaticDnsServerNegotiationPending : PdpContextManager
  • SetCounterPending : PdpContextManager
  • SetExtn : RegEncoderDecoder
  • SetIterator : RegEncoderDecoder
  • SetMinimumQualityOfServicePending : PdpContextManager
  • SetPacketFilterPending : PdpContextManager
  • SetpBackup : ObexObject
  • SetpDontCreate : ObexObject
  • SetQualityOfServicePending : PdpContextManager
  • SetText : InfoDialog, SmsServiceMsg, TextEditorDocument, TextCompoundItem, PasswordEditor, MultiLineEditor, LineEditor, Item, AnimatedTextLine, Alert, AbstractTextObject, AbstractButton, TextList, TextListModel, RadioButtonItem, IconTextIndicator, TextIndicator, CheckBoxItem, AbstractEditBox, AbstractEditBoxModel, SubstitutedText, FeatureItem, HomezoneMsg, SsUus1ReqArg, SsUus1IndArg, GetInkeyRspArg, GetInputRspArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, HomezoneIndArg, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, T9PinyinBox, StrokeBox, SelectionBox, InputMapper
  • SetTimeFeature : AudioDeviceBase
  • SetupStateNotValid : XCallInfoResponseParser
  • SevenBitAlphabet : InputMapper
  • Shaded : Color
  • ShadedColor : CTResourcePack
  • SharedMemory : Sms
  • SharingError : File
  • ShiftFunction : T9InputConfig
  • Short : InternalTracer
  • ShortDateDM : Date
  • ShortDateDMY : Date
  • ShortDateWDM : Date
  • ShortDateWDMY : Date
  • ShortMessageServices : InputParser
  • ShortMessageType0 : ProtocolIdentifier
  • ShowParentPosition : OptionalConfigBase
  • SignalHandlerType : ExternalCommunicationHandler
  • SilentReset : ShutDown
  • Sim : Sms
  • SimIsFull : Sms
  • SimNotUsed : Sms
  • SimPreferred : Sms
  • SimStorageGetsFree : Sms
  • SingleDataCall : XCallInfoResponseParser
  • SingleFaxCall : XCallInfoResponseParser
  • SingleVoiceCall : XCallInfoResponseParser
  • SioAtBusy : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioAtComplete : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioBufferLow : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioClose : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioDataReq : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioEnoughBuffer : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioError : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioExecMode : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioExecModeKill : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioExecModeStart : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioLast : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioLineDontCare : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioLineOff : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioLineOn : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioOk : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioOpen : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioSigvalLast : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • SioTermIos : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • Size : IconState, HeapVector::VarPage, HeapVector::BlockPage, Size, CArray< T >, ObexBuffer, File::Attributes
  • Size1_3Mp : CamWin32, Camera
  • Size1Mp : CamWin32, Camera
  • Size2Mp : CamWin32, Camera
  • Size3Mp : CamWin32, Camera
  • Size96x96 : Camera
  • SizeNotSetInDocument : SvgPlayer
  • SizeType : GuiObjectFactory, Vector< T >, WbxmlVector< T >
  • Sjis : JapaneseTranscoder
  • SkActionsProp : GuiObjectFactory
  • Skipped : SocketTestT
  • Slovak : LanguageManager
  • Slovenian : LanguageManager
  • Small : InformationElement
  • SmallAnimation : InformationElement
  • SmallBuffer : MediaManager, CodecDevice
  • SmallPicture : InformationElement
  • SmallSize : IconState
  • SmartOverlay : VideoChannel
  • SmDeletedByOriginatingSme : ShortMessageStatus
  • SmDeletedByScAdministration : ShortMessageStatus
  • SmDelivered : ShortMessageStatus
  • SmDeliveredButUnableToConfirm : ShortMessageStatus
  • SmDoesNotExist : ShortMessageStatus
  • SmeBusy : ShortMessageStatus
  • SmeToSme : ProtocolIdentifier
  • SmoothScrollSteps : OptionalConfigBase
  • SmRejectedDuplicateSm : ShortMessageFailureCause
  • SmReplaced : ShortMessageStatus
  • Sms : Sms, DataCodingScheme
  • SmsAddToPhonebookErrorType : SmsInfoBox
  • SmsBoxEmpty : SmsAlert
  • SmscControl : InformationElement
  • SmsClass0Type : SmsInfoBox
  • SmsDataSource : SimTextString
  • SmsDeleteAllArchive : SmsInfoBox
  • SmsDeleteAllInbox : SmsInfoBox
  • SmsDeleteAllOutbox : SmsInfoBox
  • SmsDeleteAllReports : SmsInfoBox
  • SmsDeleteError : SmsInfoBox
  • SmsDeleteMessage : SmsInfoBox
  • SmsFlashPreferred : AbstractSmsApp
  • SmsMemoryFullType : SmsAlert
  • SmsPendingSmsType : SmsAlert
  • SmsPendingType : SmsInfoBox
  • SmsReceivedSmsType : SmsAlert
  • SmsReceivedStatRepType : SmsAlert
  • SmsRejectType : SmsInfoBox
  • SmsSendErrorStoreOptionType : SmsInfoBox
  • SmsSendErrorType : SmsInfoBox
  • SmsSendingType : SmsInfoBox
  • SmsSendType : SmsInfoBox
  • SmsSentOkType : SmsAlert
  • SmsSetupCallErrorType : SmsInfoBox
  • SmsSimFullType : SmsAlert
  • SmsSimPreferred : AbstractSmsApp
  • SmsStoredOkType : SmsAlert
  • SmsStoreErrorType : SmsInfoBox
  • SmsStoreType : SmsInfoBox
  • SmType0NotSupported : ShortMessageFailureCause
  • SmValidityPeriodExpired : ShortMessageStatus
  • SnrAllocation : AudioEncoder
  • Socket : Socket, InternalTracer
  • SoftHorizontalAnimation : ItemRendererProperties
  • SOFTKEY_PRESSED_MSG : TestWriter
  • SOFTKEY_SHOW_MSG : TestWriter
  • SoftkeyBarBackgroundBitmap : CTResourcePack
  • SoftkeyBarBackgroundBitmapUri : CTResourcePack
  • SoftkeyBarButton1Bitmap : CTResourcePack
  • SoftkeyBarButton1BitmapUri : CTResourcePack
  • SoftkeyBarButton2Bitmap : CTResourcePack
  • SoftkeyBarButton2BitmapUri : CTResourcePack
  • SoftkeyBarButtonsControl : CTResourcePack
  • SoftkeyBarButtonSpacing : CTResourcePack
  • SoftkeyBarControl : CTResourcePack
  • SoftkeyBarHeight : CTResourcePack
  • SoftkeyBarNavGuideActiveColor : CTResourcePack
  • SoftkeyBarNavGuideEnabled : CTResourcePack
  • SoftkeyBarNavGuideInactiveColor : CTResourcePack
  • Softkeys : Font
  • SoftVerticalAnimation : ItemRendererProperties
  • Solid : Pen, Brush
  • SpaceFunction : T9InputConfig
  • Spanish : LanguageManager, DataCodingScheme
  • SpeakerGain : BtHsVolumeSettingsWin, BtHfVolumeSettingsWin
  • SpecialSms : InformationElement
  • Speech : XCallInfoResponseParser
  • SpeechDeviceID : AudioDeviceManager
  • SpeechVolume1 : SpeechAudioDevice, Audio
  • SpeechVolume2 : SpeechAudioDevice, Audio
  • SpeechVolume3 : SpeechAudioDevice, Audio
  • SpeechVolume4 : SpeechAudioDevice, Audio
  • SpeechVolume5 : SpeechAudioDevice, Audio
  • SpeechVolume6 : SpeechAudioDevice, Audio
  • SpeechVolume7 : SpeechAudioDevice, Audio
  • SpeechVolume8 : SpeechAudioDevice, Audio
  • SqcifSize : CamWin32, Camera
  • SsErrorStatus : SsErrorCode
  • SsIncompatibility : SsErrorCode
  • SsNotAvailable : SsErrorCode
  • SsSubscriptionViolation : SsErrorCode
  • st_active : DataConn
  • st_check_cancel : DataConn
  • st_deactivate : DataConn
  • st_idle_timeout : DataConn
  • st_ignore_setup_req : DataConn
  • st_in_hold : DataConn
  • st_in_release : DataConn
  • st_in_setup : DataConn
  • st_in_trigger_release : DataConn
  • st_inactive : DataConn
  • st_max_states : DataConn
  • st_reactivate : DataConn
  • st_released : DataConn
  • st_set_on_cancel : DataConn
  • st_set_on_wait_for_setup : DataConn
  • st_setup_failure : DataConn
  • st_setup_success : DataConn
  • st_start_release : DataConn
  • st_start_setup : DataConn
  • STACK_TRACE_DEPTH : InternalTracer
  • StandardTime : TimeZone
  • StandbyMode : StreamAudioReference
  • Start : Timer, SystemTimer, ImageBox, AnimatedTextLine, VoiceMemoAudioDevice, VideoChannel, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice, GenericAudioDevice, AmplifierAudioDevice, StartUp, VideoChannel, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, VideoChannel, AtiMpeg4Encoder, AtiMpeg4Decoder, VideoChannel, SharedTimer, Animation, RtStreamingConn, SigHandler, CbsHandler, Server, HttpServer, FtpTransfer, FtpServer, FtpOutTransfer, FtpInTransfer, LcsTimer, LcsRepeatTimer, VideoEncoder, VideoDecoder, FlowLayout, IndicatorLocation
  • StartAnimationProp : GuiObjectFactory
  • StartDelayProp : GuiObjectFactory
  • Started : SocketTestT, PhonebookApp
  • StateAccepted : PdpContextManager::AttachStatus, PdpContext::ActivationStatus
  • StateFiveTimeT3310Expiry : PdpContextManager::AttachStatus
  • StateFiveTimeT3380Expiry : PdpContext::ActivationStatus
  • StateRejected : PdpContextManager::AttachStatus, PdpContext::ActivationStatus
  • StateUnknownCause : PdpContextManager::AttachStatus, PdpContext::ActivationStatus
  • StateUserInteruption : PdpContextManager::AttachStatus, PdpContext::ActivationStatus
  • StaticFileError : File
  • StaticFrame : Control
  • StatusDisabled : AudioDeviceBase
  • StatusEnabled : AudioDeviceBase
  • StatusReport : SmsSettingsRecord, MessageTypeIndicator
  • StepProp : GuiObjectFactory
  • Stereo : CodecDevice
  • StereoChannelMode : AudioEncoder
  • StereoHeadSet : Accessory
  • StillCameraCategory : AbstractDevice
  • StOnCommand : RtStreamingConn
  • StOnEndOfData : RtStreamingConn
  • StOnSnkError : RtStreamingConn
  • StOnSrcError : RtStreamingConn
  • StopApiCompletionMsg : MediaManager
  • StorageAppCatFlag : CodecDevice
  • StoreSmsType : AbstractSmsApp
  • StreamBegin : Stream
  • StreamCanBeRead : Stream
  • StreamCanBeReadWritten : Stream
  • StreamCanBeWritten : Stream
  • StreamCurrent : Stream
  • StreamEnd : Stream
  • StreamError : Led
  • StreamFinished : Led
  • StreamingAppCatFlag : CodecDevice
  • StreamingError : File
  • StreamSoundDataSource : AudioReference
  • StreamStopped : Led
  • StrictWhitespaceWrap : EditorDocument
  • Strikethrough : TextFormat
  • String : String, InternalTracer, WString
  • StringNodeType : RegIterator
  • StringType : GuiObjectFactory
  • stroke : ChineseQuickSortProvider
  • StrokeBoxId : AbstractPredictiveInputBox
  • SubComponentPropertyType : CTResourcePack
  • SubMenu : PbAbstractWin
  • Submit : MessageTypeIndicator
  • SubmitReport : MessageTypeIndicator
  • SubscriberNumber : TypeOfAddress
  • Success : ObexResult, BtObexResponseCode, MediaManager, CodecDevice
  • SUCCESS : StreamObexImpl
  • Sunday : Date
  • Sunken : CTResourcePack
  • SunkenBorder : CTResourcePack
  • SunlightBalance : Camera
  • Surjective : JoinRule
  • SurpressPhoneNumber : MoCallAction
  • SvgActivateEvent : SvgPlayer
  • SvgaSize : CamWin32, Camera
  • SvgClickEvent : SvgPlayer
  • SvgFocusInEvent : SvgPlayer
  • SvgFocusOutEvent : SvgPlayer
  • SvgHideHyperlinksEvent : SvgPlayer
  • SvgSelectNextHyperlinkEvent : SvgPlayer
  • SvgSelectPreviousHyperlinkEvent : SvgPlayer
  • SvgShowHyperlinksEvent : SvgPlayer
  • SvgStatusEventHandled : SvgPlayer
  • SvgUiActivateEvent : SvgPlayer
  • SvgUndefinedEvent : SvgPlayer
  • Swahili : LanguageManager
  • Swedish : LanguageManager, DataCodingScheme
  • SxgaSize : Camera
  • SymbolEntryRequestFunction : T9InputConfig
  • Synchronous : MessageHook
  • SyncModeEnabledProp : GuiObjectFactory
  • SyntaxErrorInUrl : ObexResult
  • SystemColorIdCount : Color
  • SystemColorTable : CTResourcePack
  • SystemFailure : SsErrorCode
  • SystemFontIdCount : Font
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- t -

  • T9 : PredInputMapper, InputMapper
  • TabButtonClippedWidth : OptionalConfigBase
  • TabButtonDefaultHeight : OptionalConfigBase
  • TabButtonDefaultWidth : OptionalConfigBase
  • TabButtonMaximumWidth : OptionalConfigBase
  • TabButtonMinimumWidth : OptionalConfigBase
  • TaDa : InformationElement
  • TaggedError : SsErrorCode
  • TAmbigous : BtJsr82Url::Token
  • Target : ObexHeader
  • TAsterix : BtJsr82Url::Token
  • TAuthenticate : BtJsr82Url::Token
  • TAuthorize : BtJsr82Url::Token
  • TBadInput : BtJsr82Url::Token
  • TchMode : StreamAudioReference
  • TColon : BtJsr82Url::Token
  • TComma : BtJsr82Url::Token
  • TDecNumber : BtJsr82Url::Token
  • TDeviceDetail : BtApplicationQuerySupportedProfilesRequest
  • TDeviceList : BtApplicationQuerySupportedProfilesRequest
  • TDot : BtJsr82Url::Token
  • Telematic : ProtocolIdentifier
  • TelematicInterworkingNotSupported : ShortMessageFailureCause
  • TelephoneNumberingPlan : TypeOfAddress
  • Telephony : InputParser
  • TelephonyAppCatFlag : CodecDevice
  • TeleserviceNotProvisioned : SsErrorCode
  • TeletexAnalogPstn : ProtocolIdentifier
  • TeletexCarrierUnspecified : ProtocolIdentifier
  • TeletexCspdn : ProtocolIdentifier
  • TeletexDigitalIsdn : ProtocolIdentifier
  • TeletexPspdn : ProtocolIdentifier
  • Telex : ProtocolIdentifier
  • TelexNumberingPlan : TypeOfAddress
  • TempFileCreationError : File
  • TemporaryError : ShortMessageStatus
  • TemporaryErrorStillTrying : ShortMessageStatus
  • TemporaryFailure : Sms
  • TEncrypt : BtJsr82Url::Token
  • TEndInput : BtJsr82Url::Token
  • TEqual : BtJsr82Url::Token
  • TestState : InternalTracer
  • TEXT_OUTPUT_MSG : TestWriter
  • TextAboveIconDisplayType : ItemRendererProperties
  • TextAlignParseType : CTResourcePack
  • TextAlignProp : GuiObjectFactory, CTResourcePack
  • TextAlignType : GuiObjectFactory
  • TextAndIconDisplayType : ItemRendererProperties
  • TextAttrParseType : CTResourcePack
  • TextAttrProp : GuiObjectFactory, CTResourcePack
  • TextAttrType : GuiObjectFactory
  • TextBelowIconDisplayType : ItemRendererProperties
  • TextBoxClassType : GuiObjectFactory
  • TextCompressed : DataCodingScheme
  • TextDisplayType : ItemRendererProperties
  • TextEditor : Font
  • TextFormatClassType : GuiObjectFactory
  • TextFormatProp : GuiObjectFactory, CTResourcePack
  • TextFormatting : InformationElement
  • TextIconPairCountProp : GuiObjectFactory
  • TextIconPairProp : GuiObjectFactory
  • TextIconPairType : GuiObjectFactory
  • TextItem : EditorItemNode
  • TextLineAnimTypeProp : GuiObjectFactory
  • TextLineClassType : GuiObjectFactory
  • TextOverlapsIconDisplayType : ItemRendererProperties
  • TextProp : GuiObjectFactory
  • TextPropertyId : Item
  • TextScrolling : SimTkProfile
  • TextStringTag : Tlv
  • TextUncompressed : DataCodingScheme
  • TextWrapping : SimTkProfile
  • TFalse : BtJsr82Url::Token
  • Thai : LanguageManager
  • TheDayAfterTomorrow : Date
  • TheDayBeforeYesterday : Date
  • Theme : Theme, OptionalConfigBase
  • ThemeName : CTResourcePack
  • THexNumber : BtJsr82Url::Token
  • Thirty_Days : AbstractSmsApp
  • ThreadletStoppedError : Image
  • Three_Months : AbstractSmsApp
  • Thursday : Date
  • Time : Time, InputMapper
  • TimeChanged : RealTimeClock
  • TimeEditorClassType : GuiObjectFactory
  • TimeHM : Time
  • TimeHMS : Time
  • TimeProp : GuiObjectFactory
  • TimerCause : AudioDeviceBase
  • TimerExpired : Sms
  • TimeType : GuiObjectFactory
  • TitleBarBitmap : CTResourcePack
  • TitleBarBitmapUri : CTResourcePack
  • TitleBarHeight : CTResourcePack
  • TitleProp : GuiObjectFactory
  • TLocalhost : BtJsr82Url::Token
  • TlvSource : SimTextString
  • TMaster : BtJsr82Url::Token
  • TName : BtJsr82Url::Token
  • Today : Date
  • Toggle : RadioButtonAction, CheckBoxControl, CheckBoxAction, AbstractToggleAction, Provider
  • ToggleNumericModeFunction : T9InputConfig
  • Tomorrow : Date
  • Tone : ToneAudioDevice, ThaiTextRenderer
  • ToneAlarm1 : Audio
  • ToneBroadcast1 : Audio
  • ToneBroadcast2 : Audio
  • ToneBroadcast3 : Audio
  • ToneBroadcast4 : Audio
  • ToneDeviceID : AudioDeviceManager
  • ToneDtmf0 : Audio
  • ToneDTMF0 : ToneAudioDevice
  • ToneDTMF1 : ToneAudioDevice
  • ToneDtmf1 : Audio
  • ToneDTMF2 : ToneAudioDevice
  • ToneDtmf2 : Audio
  • ToneDTMF3 : ToneAudioDevice
  • ToneDtmf3 : Audio
  • ToneDTMF4 : ToneAudioDevice
  • ToneDtmf4 : Audio
  • ToneDtmf5 : Audio
  • ToneDTMF5 : ToneAudioDevice
  • ToneDTMF6 : ToneAudioDevice
  • ToneDtmf6 : Audio
  • ToneDtmf7 : Audio
  • ToneDTMF7 : ToneAudioDevice
  • ToneDTMF8 : ToneAudioDevice
  • ToneDtmf8 : Audio
  • ToneDtmf9 : Audio
  • ToneDTMF9 : ToneAudioDevice
  • ToneDTMFAsterix : ToneAudioDevice
  • ToneDTMFHash : ToneAudioDevice
  • ToneDtmfHash : Audio
  • ToneDtmfStar : Audio
  • ToneInfoAlarm : Audio
  • ToneInfoAlarmInCall : ToneAudioDevice
  • ToneInfoAutoRedial : Audio
  • ToneInfoBroadcast : Audio
  • ToneInfoBroadcastInCall : ToneAudioDevice
  • ToneInfoConnection : ToneAudioDevice, Audio
  • ToneInfoDeviceIn : ToneAudioDevice, Audio
  • ToneInfoDeviceOut : ToneAudioDevice, Audio
  • ToneInfoDialTone : Audio
  • ToneInfoDisconnect : ToneAudioDevice, Audio
  • ToneInfoError1 : ToneAudioDevice
  • ToneInfoError2 : ToneAudioDevice
  • ToneInfoFree : Audio
  • ToneInfoFreeTone : ToneAudioDevice
  • ToneInfoLowBat : Audio
  • ToneInfoLowBatInCall : ToneAudioDevice, Audio
  • ToneInfoMinuteBeep : Audio
  • ToneInfoMinuteMinder : ToneAudioDevice
  • ToneInfoMsgFull : ToneAudioDevice, Audio
  • ToneInfoNetworkAttention : Audio
  • ToneInfoPowerOff : ToneAudioDevice, Audio
  • ToneInfoPowerOn : ToneAudioDevice, Audio
  • ToneInfoSingleBeep : ToneAudioDevice
  • ToneInfoSmsInCall : ToneAudioDevice
  • ToneInfoSmsReceived : Audio
  • ToneInfoUssd : ToneAudioDevice, Audio
  • ToneKey1 : Audio
  • ToneKey2 : Audio
  • ToneKey3 : Audio
  • ToneKey4 : Audio
  • ToneMessage1 : Audio
  • ToneMessage10 : Audio
  • ToneMessage2 : Audio
  • ToneMessage3 : Audio
  • ToneMessage4 : Audio
  • ToneMessage5 : Audio
  • ToneMessage6 : Audio
  • ToneMessage7 : Audio
  • ToneMessage8 : Audio
  • ToneMessage9 : Audio
  • ToneMessageSingleBeep : Audio
  • ToneRinging1 : Audio
  • ToneRinging10 : Audio
  • ToneRinging11 : Audio
  • ToneRinging12 : Audio
  • ToneRinging13 : Audio
  • ToneRinging14 : Audio
  • ToneRinging15 : Audio
  • ToneRinging16 : Audio
  • ToneRinging17 : Audio
  • ToneRinging18 : Audio
  • ToneRinging19 : Audio
  • ToneRinging2 : Audio
  • ToneRinging20 : Audio
  • ToneRinging21 : Audio
  • ToneRinging22 : Audio
  • ToneRinging23 : Audio
  • ToneRinging24 : Audio
  • ToneRinging25 : Audio
  • ToneRinging26 : Audio
  • ToneRinging27 : Audio
  • ToneRinging28 : Audio
  • ToneRinging29 : Audio
  • ToneRinging3 : Audio
  • ToneRinging30 : Audio
  • ToneRinging31 : Audio
  • ToneRinging32 : Audio
  • ToneRinging33 : Audio
  • ToneRinging34 : Audio
  • ToneRinging35 : Audio
  • ToneRinging36 : Audio
  • ToneRinging37 : Audio
  • ToneRinging38 : Audio
  • ToneRinging39 : Audio
  • ToneRinging4 : Audio
  • ToneRinging40 : Audio
  • ToneRinging41 : Audio
  • ToneRinging42 : Audio
  • ToneRinging43 : Audio
  • ToneRinging44 : Audio
  • ToneRinging45 : Audio
  • ToneRinging46 : Audio
  • ToneRinging47 : Audio
  • ToneRinging48 : Audio
  • ToneRinging5 : Audio
  • ToneRinging6 : Audio
  • ToneRinging7 : Audio
  • ToneRinging8 : Audio
  • ToneRinging9 : Audio
  • ToneSupervisoryCallWaiting : Audio
  • ToneSupervisoryCongestion : Audio
  • ToneSupervisoryError : Audio
  • ToneSupervisoryRadioPathAck : Audio
  • ToneSupervisoryRadioPathNotAvail : Audio
  • ToneSupervisorySubsciberBusy : Audio
  • ToneSvCallWaiting : ToneAudioDevice
  • ToneSvCongestion : ToneAudioDevice
  • ToneSvErrorInfo : ToneAudioDevice
  • ToneSvRadioPathAck : ToneAudioDevice
  • ToneSvRadioPathNotAvail : ToneAudioDevice
  • ToneSvSubscriberBusy : ToneAudioDevice
  • ToneType : ToneAudioDevice, CustomToneAudioReference, AudioPreset
  • ToneUserDefined : Audio
  • TongueHangingOut : InformationElement
  • TooManyFilesError : File
  • Top : TextFormat, Layouter, GridLayout
  • TopLeft : ContextMenu, MenuProperties
  • TopLineGapProp : GuiObjectFactory
  • TopRight : ContextMenu, MenuProperties
  • TopSection : Desktop
  • TpCmdReqNotInPhase1 : Sms
  • TpCreationOfMnrFailed : Sms
  • Tpdu : Tpdu, PhoneNumber
  • TpduDataMissing : Sms
  • TpduNotSupported : ShortMessageFailureCause
  • TpInvalidAlphabet : Sms
  • TpInvalidCmdData_Type : Sms
  • TpInvalidCmdDataLength : Sms
  • TpInvalidDestAddress : Sms
  • TpInvalidDestAddrSpecCmds : Sms
  • TpInvalidMti : Sms
  • TpInvalidScAddress : Sms
  • TpInvalidTimeStamp : Sms
  • TpInvalidUserDataLength : Sms
  • TpMissingCmdData : Sms
  • TpMissingDestAddress : Sms
  • TpMissingScAddress : Sms
  • TpMissingUserData : Sms
  • TpMissingValidityPeriod : Sms
  • TpMtConnectionLost : Sms
  • TpPendingMoSms : Sms
  • TpRdfNotInPhase1 : Sms
  • TpRpfNotInPhase1 : Sms
  • TpSrfNotInPhase1 : Sms
  • TpUdhfNotInPhase1 : Sms
  • TpUserDataTooLarge : Sms
  • TrainedCommand : VrHandler
  • TransactionCompleted : ShortMessageStatus
  • TransferRejected : Sms
  • Transparent : DataCallContext
  • TransparentPreferred : DataCallContext
  • TransparentProp : GuiObjectFactory
  • TransparentSelection : AbstractEditor
  • TransportDisableReasonAppRequest : IrdaTransport
  • TransportDisableReasonIdleTimeout : IrdaTransport
  • TransportDisableReasonNotApplicable : IrdaTransport
  • TransportDisableReasonStackError : IrdaTransport
  • TransportDisableReasonUnknown : IrdaTransport
  • TransportDisconnected : ObexResult
  • TraverseDown : RegIterator, RegEncoderDecoder
  • TraverseNext : RegIterator, RegEncoderDecoder
  • TraverseUp : RegIterator, RegEncoderDecoder
  • TripleTone : CustomToneAudioReference
  • TripleUserTone : ToneAudioDevice
  • TScheme : BtJsr82Url::Token
  • TSemicolon : BtJsr82Url::Token
  • TSlashes : BtJsr82Url::Token
  • TText : BtJsr82Url::Token
  • TTrue : BtJsr82Url::Token
  • Tuesday : Date
  • TUnknown : BtJsr82Url::Token
  • Turkish : LanguageManager, DataCodingScheme
  • Twelve_Hour : AbstractSmsApp
  • TwilightAuto : Camera
  • TwilightChanged : Camera
  • TwilightOff : Camera
  • TwilightOn : Camera
  • TwoByte : Tlv
  • Type : ToDoRecord, SysSocketBase, SysSocket, NetAdapter, InetSocket, ExecutionContext, PredInputMapper, MessageBox, Control::ComponentIterator, Control::NavigationGuidance, AnimatedTextLine, VirtualDisplay, PhoneNumber, PdpContext::PacketFilter, PdpContext::Authentication, PdpContext, PinAction, MoCallAction, MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType, BaseInformationElement, Accessory, File::Attributes, AtCommand, DrmConstraint, InputMapItem, ObexHeader
  • Type_1 : PdpContext::PacketFilter
  • Type_2 : PdpContext::PacketFilter
  • Type_3 : PdpContext::PacketFilter
  • Type_Unknown : PdpContext::PacketFilter
  • TypeCount : DrmConstraint
  • TypeDateTime : DrmConstraint
  • TypeInterval : DrmConstraint
  • TypeProp : GuiObjectFactory
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- u -

  • UChar : InternalTracer
  • Uci : ProtocolIdentifier
  • Ucs2 : SimGetInkeyOptions, SimGetInputOptions, JapaneseTranscoder
  • Ucs2Alphabet : InputMapper, DataCodingScheme
  • UCS2DisplaySupported : SimTkProfile
  • UCS2EntrySupported : SimTkProfile
  • UdhSourceIndicator : InformationElement
  • UInt : InternalTracer
  • UInt16ParseType : CTResourcePack
  • UInt16Type : GuiObjectFactory
  • UInt8ParseType : CTResourcePack
  • UInt8Type : GuiObjectFactory
  • Ukrainian : LanguageManager
  • ULong : InternalTracer
  • UmtsNeighbourCells : TestparamReport
  • UnassignedNumber : Sms
  • Unauthorised : BtObexResponseCode
  • UnblockPin : InputParser, PinAction
  • UnblockPin2 : InputParser
  • undefined : Provider
  • Undefined : PdpContext
  • UndefinedAlphabet : InputMapper
  • UndefinedError : PdpContext
  • UndefinedModification : Provider
  • UndefinedResult : Sms
  • UndefinedStatus : Tpdu
  • UndefinedTag : Tlv
  • UndefinedTitleText : MenuProperties
  • UndefinedType : ContextFeature
  • UndefinedUsage : ShortMessageFailureCause
  • Underlined : TextFormat
  • UnexpectedDataValue : SsErrorCode
  • UnexpectedError : TaggedProblemCode
  • UnexpectedLinkedOperation : TaggedProblemCode
  • UnicodeType : ObexHeader
  • UnidentifiedSubscriber : Sms
  • UninitCompletionMsg : MediaManager
  • UnInitializedState : MediaRecorder, MediaPlayer
  • UnitializedState : Camera
  • UniversalTime : DateTime
  • Unknown : InternalTracer, Accessory
  • UNKNOWN : SerialIoSet
  • UnknownAlphabet : SsErrorCode
  • UnknownClassType : GuiObjectFactory
  • UnknownCodec : MediaInfo, CodecDevice
  • UnknownError : File
  • UnknownErrorMsg : MediaManager
  • UnknownMimeType : ObexResult
  • UnknownNumberingPlan : TypeOfAddress
  • UnknownOrigin : PdpContext
  • UnknownParameterInUrl : ObexResult
  • UnknownParseType : CTResourcePack
  • UnknownPdpAddress : PdpContext
  • UnknownProp : GuiObjectFactory
  • UnknownPropertyType : CTResourcePack
  • UnknownResponse : AtResponse
  • UnknownSoundDataSource : AudioReference
  • UnknownSubscriber : SsErrorCode, Sms
  • UnknownType : GuiObjectFactory
  • UnknownTypeOfNumber : TypeOfAddress
  • UnknownUrlType : BtJsr82Url
  • Unlock : SmsBasicProvider, PbRecordProvider, PbRecordHandler, AbstractLockableDevice, ThreadSafeProvider, Provider, Protector, AbstractDelegationProvider, HandlerData, Registry, ObjectTreeService, MergeProvider, JoinProvider, AppendProvider, RecordHandler, RegEncoderDecoder
  • Unlocked : RegEncoderDecoder
  • unmarked : ToDoRecord
  • Unread : Tpdu
  • UnrecognizedComponent : TaggedProblemCode
  • UnrecognizedError : TaggedProblemCode
  • UnrecognizedErrorInvokeId : TaggedProblemCode
  • UnrecognizedInvokeId : TaggedProblemCode
  • UnrecognizedLinkedId : TaggedProblemCode
  • UnrecognizedOperation : TaggedProblemCode
  • UnsecureCellBroadcastDataDownloadRangeBegin : MessageIdentifier
  • UnsecureCellBroadcastDataDownloadRangeEnd : MessageIdentifier
  • Unsent : Tpdu
  • UnsetPacketFilterPending : PdpContextManager
  • UnspecificDirection : CodecDevice
  • Unspecified : ObexResult, BtObexResponseCode, FunctionalityIndicator
  • UnspecifiedActivationRejection : PdpContext
  • UnspecifiedAttributeId : Feature
  • UnspecifiedCommandError : ShortMessageFailureCause
  • UnspecifiedDcsError : ShortMessageFailureCause
  • UnspecifiedError : Image, ShortMessageFailureCause, SvgPlayer
  • UnspecifiedLanguage : DataCodingScheme
  • UnspecifiedPidError : ShortMessageFailureCause
  • UnspecifiedPropertyId : Item
  • UnspecifiedProtocolError : PdpContext
  • UnsupportedCameraFeature : Camera
  • UnsupportedFrameRateError : Camera
  • UnSuppotedType : RegEncoderDecoder
  • Up : Control::NavigationGuidance, AbstractGrid
  • UpArrowBitmapId : AbstractPredictiveInputBox
  • updated : Provider
  • UpdatedContent : InputMapper
  • updating : Provider
  • UpDownArrowBitmapId : AbstractPredictiveInputBox
  • UpDownlinkDirection : AudioDeviceBase
  • UplinkCarKit : AudioPath
  • UplinkDirection : AudioDeviceBase
  • UplinkPathDthfMic : AudioPath
  • UplinkPathHandsetMic : AudioPath
  • UplinkPathHeadsetMic : AudioPath
  • UplinkPathI2S1_Rx : AudioPath
  • UplinkPathI2S1InbandRx : AudioPath
  • UplinkPathNone : AudioPath
  • UplinkPathRecordingHandsetMic : AudioPath
  • UplinkPathTTY : AudioPath
  • UpperLeft : CTResourcePack
  • UpperRight : CTResourcePack
  • Url : InputMapper
  • Used : ToDoRecord
  • UserAbort : TipdBasedActiveWaitDispatcher
  • UserAbortedError : Camera
  • UserDataHeaderIE : BaseInformationElement
  • UserDefinedSound : InformationElement
  • UserPromptIndicator : InformationElement
  • UserTriggeredCapitalization : MultiTapInputMapper
  • UShort : InternalTracer
  • USimApplicationToolkitBusy : ShortMessageFailureCause
  • USimDataDownload : ProtocolIdentifier
  • USimDataDownloadError : ShortMessageFailureCause
  • USimSmsStorageFull : ShortMessageFailureCause
  • UssdBusy : SsErrorCode
  • UssdDataSource : SimTextString
  • UUSService1 : InputParser
  • UUSService2 : InputParser
  • UUSService3 : InputParser
  • UxgaSize : CamWin32, Camera
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- v -

  • V42bis : PdpContext
  • V44 : PdpContext
  • Valid : Image
  • ValueAttributeId : Property
  • ValueMappingPropertyDescriptorClassType : GuiObjectFactory
  • ValueNotUsed : InformationElement
  • ValueProp : GuiObjectFactory
  • ValuePropertyId : Item, AbstractToggleAction
  • VARIABLE_CHANGED_MSG : TestWriter
  • VariablePicture : InformationElement
  • VariableSizeFontSupport : SimTkProfile
  • VerifiedAndFailed : PhoneNumber
  • VerifiedAndPassed : PhoneNumber
  • Version : InternalTracer
  • VertBorderAlign : Desktop
  • Vertical : PositionIndicator
  • vertical : IndicatorBarView
  • VerticalCenteredProp : GuiObjectFactory
  • VeryLongKeyPress : Keyboard
  • VgaSize : CamWin32, Camera
  • Vibrator_Async_1 : VibratorDevice
  • Vibrator_Async_2 : VibratorDevice
  • Vibrator_Async_3 : VibratorDevice
  • Vibrator_Async_4 : VibratorDevice
  • Vibrator_Async_5 : VibratorDevice
  • Vibrator_Async_6 : VibratorDevice
  • Vibrator_Sync_Control : VibratorDevice
  • VibratorDeviceID : AudioDeviceManager
  • VibratorModeAsync1 : Audio, AudioVibratorDevice
  • VibratorModeAsync2 : Audio, AudioVibratorDevice
  • VibratorModeSync1 : Audio, AudioVibratorDevice
  • VibratorModeSync2 : Audio, AudioVibratorDevice
  • VibratorOffTime200ms : Audio
  • VibratorOffTime300ms : Audio
  • VibratorOffTime400ms : Audio
  • VibratorOffTime600ms : Audio
  • VibratorOffTimeOff : Audio
  • VibratorOnTime1000ms : Audio
  • VibratorOnTime400ms : Audio
  • VibratorOnTime600ms : Audio
  • VibratorOnTime800ms : Audio
  • VibratorOnTimeOn : Audio
  • VideoCameraCategory : AbstractDevice
  • VideoCapturePaused : Camera
  • VideoCaptureStarted : Camera
  • VideoCaptureStopped : Camera
  • VideoCaptureUnPaused : Camera
  • VideoCapturingHiddenState : Camera
  • VideoCapturingPausedState : Camera
  • VideoCapturingState : Camera
  • VideoEncoderBufferAllocationError : Camera
  • VideoOnly : MediaPlayer
  • VideoPlaybackOverViewfinder : VideoChannel
  • Videotex : ProtocolIdentifier
  • VidResNotSupported : MediaManager
  • Vietnamese : LanguageManager
  • ViewfinderHiddenState : Camera
  • ViewfinderHoldHiddenState : Camera
  • ViewfinderHoldState : Camera
  • ViewfinderOverVideoPlayback : VideoChannel
  • ViewfinderStarted : Camera
  • ViewfinderStopped : Camera
  • ViewfindingState : Camera
  • ViewNext : ResultWinBase
  • ViewPrevious : ResultWinBase
  • VisibleValuesCountProp : GuiObjectFactory
  • VmModePlayback : VoiceMemoAudioDevice
  • VmModeRec : VoiceMemoAudioDevice
  • VmModeStandby : VoiceMemoAudioDevice
  • VmModeTch : VoiceMemoAudioDevice
  • Voice : XCallInfoResponseParser
  • VoiceBroadcastService : InputParser
  • VoiceGroupCallService : InputParser
  • VoiceMemoDeviceID : AudioDeviceManager
  • VoiceMessage : InformationElement, DataCodingScheme
  • VoiceTelephone : ProtocolIdentifier
  • VoluntaryCause : AudioDeviceBase
  • VpfNotSupported : ShortMessageFailureCause
  • VpNotSupported : ShortMessageFailureCause
  • VrFailed : VrHandler
  • VrSuccess : VrHandler
Generated on Wed Jan 25 00:54:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- w -

  • Wait : SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, MsgQueue, ExecutionContext, AppContainer, ActiveWaitDispatcher, AbstractScheduler, AbstractAppContext, InputParser
  • WaitingForClose : SocketTestT
  • WaitingForConnect : SocketTestT
  • WaitingForConnection : Charger
  • WaitingForInit : SocketTestT
  • WaitingForRead : SocketTestT
  • WaitingForWrite : SocketTestT
  • WanUuid : ObexHeader
  • WapConnectionless : WapProfile
  • WapGroup : DataCodingScheme
  • WapSecureConnectionless : WapProfile
  • WapSecureSession : WapProfile
  • WapSession : WapProfile
  • WapSessionConnected : WapHandler
  • WapSessionSuspended : WapHandler
  • WapWtaSecureConnectionless : WapProfile
  • WapWtaSecureSession : WapProfile
  • Warning : InternalTracer
  • WarningSimIsFull : Sms
  • WaveDspFormat : StreamAudioReference
  • WearingGlasses : InformationElement
  • Wednesday : Date
  • Week : PackedTimePeriod
  • Weekly : CalendarRecord
  • White : InformationElement
  • WhiteBalanceChanged : Camera
  • WhiteBalanceType : Camera, CameraOptionSettingsWin
  • WhitespaceWrap : EditorDocument
  • Who : ObexHeader
  • WidthReductionInAMenu : SimTkProfile
  • WINDOW_CLOSED_MSG : TestWriter
  • WINDOW_OPENED_MSG : TestWriter
  • WindowClassType : GuiObjectFactory
  • WindowFrameControl : CTResourcePack
  • WindowProp : GuiObjectFactory
  • WindowTitleBarControl : CTResourcePack
  • WirelessControlMessageProtocol : InformationElement
  • Wow : InformationElement
  • Write : LcsSocket, FfsDataConnProfileStorage, UdpSocket, TcpSocket, Socket, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket, DataConnProfileStorage, SocketPeer, TraceOutputStream, OutputStream, FileOutputStream, FfsFile, DebugOutputStream, BufferedOutputStream, StringDataSink, HeapDataSink, DataSink, ExtPsdContextListener_SerialTerminal, UserData, FileDataSink, FileChunkOperator, File, RegNodeBuffer, FlsFile, FfsHandler, SioSocketAdapter, SerialSocket, SerialIoAdapter, SerialTerminalSocket, SerialTerminal, RamHandler, RamFileObj, RamFile, FatHandler, FatFile, SocketTestT
  • WriteError : File
  • WriteOffsetExact : FileChunkOperator
  • WString : WString, InternalTracer, String
  • WStringIE : BaseInformationElement
  • WStringParseType : CTResourcePack
  • WStringType : GuiObjectFactory, ContextFeature
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- x -

  • X25Protocol : PdpContext
  • X400 : ProtocolIdentifier
  • XaocService : AtResponse
  • Xcallinfo : AtResponse
  • Xcallrefuse : AtResponse
  • Xcallstat : AtResponse
  • Xcaoc : AtResponse
  • Xcccm : AtResponse
  • Xccharge : AtResponse
  • Xceer : AtResponse
  • Xcharge : AtResponse
  • XDefault : Layouter, GridLayout
  • XgaSize : CamWin32, Camera
  • Xhosa : LanguageManager
  • XorFilterOp : DualFilterProvider
  • XorRop : DeviceContext
  • Xprogress : AtResponse
  • XProp : GuiObjectFactory
  • XyDimParseType : CTResourcePack
  • XyDimType : GuiObjectFactory
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Enumerator

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- y -

  • YamahaMapiId : AudioDeviceManager
  • YDefault : Layouter, GridLayout
  • Yearly : CalendarRecord
  • YesId : MessageBox
  • YesNo : MessageBox
  • Yesterday : Date
  • YProp : GuiObjectFactory
  • YUV420 : CamWin32
  • Yuv420 : JpegEncoder::EncodingParameters
  • Yuv420ColorSpace : Image::MetaData
  • Yuv422 : JpegEncoder::EncodingParameters
  • Yuv422ColorSpace : Image::MetaData
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- _ -

  • _ApplicationTracer() : _ApplicationTracer
  • _FunctionTracer() : _FunctionTracer< mask >
  • _NullApplicationTracer() : _NullApplicationTracer
  • _NullFunctionTracer() : _NullFunctionTracer
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- j -

  • Join() : CallHdlBase
  • JoinCalls() : CrssHandler
  • JoinProvider() : JoinProvider
  • JoinProviderListener() : JoinProviderListener
  • JoinRule() : JoinRule
  • JpegEncoder() : JpegEncoder
  • JpegEncodingThreadlet() : JpegEncodingThreadlet
  • JpegImage() : JpegImage
  • JumpBack() : LexAnalyzer
  • JumpToRowMsg() : JumpToRowMsg
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- k -

  • KeepAspectRatio() : DisplaySettings
  • Key() : KeyMsgGenerator::Key, PhoneNumber
  • KeyAutoRepeatMsg() : KeyAutoRepeatMsg
  • KeyCode2IA5() : Conversion
  • KeyDownInputMapItem() : KeyDownInputMapItem
  • KeyDownMsg() : KeyDownMsg
  • KeyMapping() : KeyMapping, KeySequence
  • KeyMsgGenerator() : KeyMsgGenerator, KeyMsgGenerator::Key
  • KeySequence() : KeySequence
  • KeySequenceCandidate() : KeySequenceCandidate, KeySequence
  • KeyToneAudioDevice() : KeyToneAudioDevice
  • KeyUpInputMapItem() : KeyUpInputMapItem
  • KeyUpMsg() : KeyUpMsg
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- l -

  • L1Param() : L1Param
  • L2CapSocketAddr() : L2CapSocketAddr
  • LanguageChanged() : System
  • LanguageChangedMsg() : LanguageChangedMsg
  • LanguageProvider() : LanguageProvider
  • LanguageResetAction() : LanguageResetAction
  • LanguageSelectEventArg() : LanguageSelectEventArg
  • LanguageSettingIndArg() : LanguageSettingIndArg
  • LanguageSettingReqArg() : LanguageSettingReqArg
  • LastIndexOf() : WString, String
  • LaunchBrowser() : SimTkHandler
  • LaunchBrowserIndArg() : LaunchBrowserIndArg
  • LaunchBrowserPromptIndArg() : LaunchBrowserPromptIndArg
  • Layout() : AbstractMultiLineEditor, TextList, AbstractEditBox
  • LayoutClient() : Control
  • Layouter() : Layouter
  • LcsAppRegisterForMtlrMsg() : LcsAppRegisterForMtlrMsg
  • LcsAppResWinMsg() : LcsAppResWinMsg
  • LcsAppTransferLocMsg() : LcsAppTransferLocMsg
  • LcsMainMenuWin() : LcsMainMenuWin
  • LcsMmiQos() : LcsMmiQos
  • LcsMolrResultArg() : LcsMolrResultArg
  • LcsOptionsMenuWin() : LcsOptionsMenuWin
  • LcsProviderImplBase() : LcsProviderImplBase
  • LcsRepeatTimer() : LcsRepeatTimer
  • LcsSocket() : LcsSocket
  • LcsTimer() : LcsTimer
  • LcsWString() : LcsWString
  • LedNotificationMsg() : LedNotificationMsg
  • LessRule() : LessRule
  • LevelInfo() : ItemMenu::LevelInfo
  • LexAnalyzer() : LexAnalyzer
  • Limit() : MessageIdentifierContainer
  • LineEditor() : LineEditor
  • LinkableBase() : LinkableBase
  • LinkAccessory() : AudioPathManager, AudioDeviceManager
  • LinkDown() : PsdDataConn
  • LinkedList() : LinkedList< T >
  • LinkedListBase() : LinkedListBase
  • LinkUp() : PsdDataConn
  • Listen() : TcpServerSocket, SysSocket, SocketData, SocketPeer, SioSocketAdapter, SerialServerSocket, SerialIoAdapter
  • ListPropertyDescriptor() : ListPropertyDescriptor
  • LittleEndian16Bit() : LittleEndian16Bit
  • LittleEndian32Bit() : LittleEndian32Bit
  • Load() : SvgPlayer, SvgImage, WapProfile
  • LoadAllEntries() : SimPbBaseHandler
  • LoadCameraSettings() : CameraApp
  • LoadContainerEntry() : SimPbBaseHandler
  • LoadFirstTpdu() : CompoundTpduItem
  • LoadNextTpdu() : CompoundTpduItem
  • LoadProfileName() : WapProfile
  • LoadRecord() : NvRamDataRecordHandler, RecordHandler, DataRecordHandler
  • LoadT9Udb() : T9InputConfig
  • LoadZi8Udb() : Zi8InputConfig
  • LocationErrMsg() : LocationErrMsg
  • LocationEstimate() : LocationEstimate
  • LocationNotifInvokeArg() : LocationNotifInvokeArg
  • LocationNotifInvokeMsg() : LocationNotifInvokeMsg
  • LocationResMsg() : LocationResMsg
  • LocationResultWin() : LocationResultWin
  • LocationVerifWin() : LocationVerifWin
  • Lock() : SmsBasicProvider, PbRecordProvider, PbRecordHandler, AbstractLockableDevice, ThreadSafeProvider, Provider, Protector, AbstractDelegationProvider, HandlerData, Registry, ObjectTreeService, MergeProvider, JoinProvider, AppendProvider, RecordHandler, RegEncoderDecoder, SmsSocketListener
  • LockDataStore() : DBService
  • LockedKeyDownMsg() : LockedKeyDownMsg
  • LockedKeyMsg() : LockedKeyMsg
  • LockProvider() : LockProvider
  • LockTable() : LockTable
  • LongKeyPressMsg() : LongKeyPressMsg
  • LookupAlphaId() : SimPbBaseHandler, LookupAlphaIdExtension, DataHandler
  • LookupAlphaIdExtension() : LookupAlphaIdExtension
  • LookupPlmnEntryIndex() : StackWrapper
  • LookupPlmnName() : SimAuxHandler, DataHandler
  • LookupPlmnRow() : PlmnProvider
  • LoseFocusMsg() : LoseFocusMsg
  • LsaIdentityMsg() : LsaIdentityMsg
  • LwipPppSetConnInformation() : SysSocket
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- m -

  • MainDesktop() : MainDesktop
  • MainHandler() : MainHandler, HandlerListEntry
  • MainHandlerAccess() : MainHandlerAccess
  • MainProvider() : MainProvider
  • MakeDir() : FfsHandler, RamHandler, FatHandler
  • MakeModeNormal() : Cbs::Filter
  • MakePermanent() : File
  • MapAlphabet() : AbstractSmsApp
  • MapAndUpdateVolumes() : AudioDeviceManager
  • MapAnimation() : EmsResourceMaps
  • MapBinaryIdToClassType() : GuiObjectFactory
  • MapBinaryIdToPropertyId() : GuiObjectFactory
  • MapFont() : EmsResourceMaps
  • MapiAudioReference() : MapiAudioReference
  • MapIso639() : LanguageManager
  • MapKey_English() : EnglishT9InputMapper
  • MapKey_English_Alphabetic() : EnglishT9InputMapper
  • MapKeyToCharacter_Numbers() : EnglishT9InputMapper
  • MapLineAlignment() : EmsResourceMaps
  • MapLocalIdToUid() : DrmRightsObjectStore
  • MapMedia() : StreamAudioPlayer
  • MappingPolicy() : MappingPolicy
  • MapPropertyIdToParseType() : GuiObjectFactory
  • MapSound() : EmsResourceMaps
  • MapTextAlignment() : EmsResourceMaps
  • MapTextColor() : EmsResourceMaps
  • MapUidToLocalId() : DrmRightsObjectStore
  • MarkAcmMaxUnread() : SimAuxHandler
  • MarkAcmUnread() : SimAuxHandler
  • MarkAsInvalid() : TpduCache
  • MarkCbmirUnread() : SimAuxHandler
  • MarkCbmiUnread() : SimAuxHandler
  • MarkCcpUnread() : SimAuxHandler
  • MarkCfufUnread() : SimCphsHandler
  • MarkCphsInfoUnread() : SimCphsHandler
  • MarkCspUnread() : SimCphsHandler
  • MarkDeleted() : UibSettingsRecord, ToDoRecord, SmsSettingsRecord, CalendarRecord, PbNumberRecord, PbRecord, Record
  • MarkEccUnread() : SimAuxHandler
  • MarkImsiUnread() : SimAuxHandler
  • MarkLineInUseUnread() : SimCphsHandler
  • MarkLineLockedUnread() : SimCphsHandler
  • MarkOpNameUnread() : SimCphsHandler
  • MarkOpSNameUnread() : SimCphsHandler
  • MarkPrefExtLangUnread() : SimAuxHandler
  • MarkPrefLangUnread() : SimAuxHandler
  • MarkPrefPlmnUnread() : SimAuxHandler
  • MarkPuctUnread() : SimAuxHandler
  • MarkRecordDeleted() : DataRecordHandler
  • MarkSpnUnread() : SimAuxHandler
  • MarkSstUnread() : SimAuxHandler
  • MarkVmwfUnread() : SimCphsHandler
  • MarkWelcomeMsgUnread() : SimCphsHandler
  • Marshall() : IsrDataMarshaller
  • Mask() : BitField< T >
  • Matches() : BtDeviceFilter
  • MatchesType() : BtJsr82Url::Token
  • MatchPhoneNumbers() : PhoneNumberJoinRule
  • MatchString() : ObexUrlStrParser
  • MatchSymbol() : ObexUrlStrParser
  • Maximize() : Window, Control
  • MaxRowCount() : ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, CalendarProvider, BtHfProvider, PbRecordProvider, PbRecordHandler, PbNvRamNumberHandler, PbNvRamNameHandler, PbMergeProvider, PbFfsNumberHandler, PbFfsNameHandler, Provider, AbstractDelegationProvider, JoinProvider, AppendProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, CbmiRangeProvider, CbmiProvider
  • MaxSize() : Vector< T >
  • MbiProvider() : MbiProvider
  • MCServiceInterfaceMsg() : MCServiceInterfaceMsg
  • MdhDeleteSms() : SimAccessor
  • MdhDeregistrationCnfArg() : MdhDeregistrationCnfArg
  • MdhDeregistrationReqArg() : MdhDeregistrationReqArg
  • MdhExtendedData() : MdhExtendedData
  • MdhGetSms() : SimAccessor
  • MdhGetSmsReport() : SimAccessor
  • MdhGors() : MdhGors
  • MdhMakeView() : SimAccessor
  • MdhMakeViewCnfArg() : MdhMakeViewCnfArg
  • MdhMakeViewReqArg() : MdhMakeViewReqArg
  • MdhNewStatusReportIndArg() : MdhNewStatusReportIndArg
  • MdhRegistrationCnfArg() : MdhRegistrationCnfArg
  • MdhRegistrationReqArg() : MdhRegistrationReqArg
  • MdhRemoveViewCnfArg() : MdhRemoveViewCnfArg
  • MdhRemoveViewReqArg() : MdhRemoveViewReqArg
  • MdhRequestCsmsRefNo() : SimAccessor, DataHandler
  • MdhSetConfigCnfArg() : MdhSetConfigCnfArg
  • MdhSetConfigReqArg() : MdhSetConfigReqArg
  • MdhSetSmsExtendedData() : SimAccessor
  • MdhSetStorageCnfArg() : MdhSetStorageCnfArg
  • MdhSetStorageMedia() : SimAccessor
  • MdhSetStorageReqArg() : MdhSetStorageReqArg
  • MdhSetViewConfig() : SimAccessor
  • MdhSetWaitIndicatorArray() : MdhSetWaitIndicatorArray
  • MdhSmsConcRefNumIndArg() : MdhSmsConcRefNumIndArg
  • MdhSmsConcRefNumReqArg() : MdhSmsConcRefNumReqArg
  • MdhSmsDeletionIndArg() : MdhSmsDeletionIndArg
  • MdhSmsDeletionReqArg() : MdhSmsDeletionReqArg
  • MdhSmsExtendedDataIndArg() : MdhSmsExtendedDataIndArg
  • MdhSmsExtendedDataReqArg() : MdhSmsExtendedDataReqArg
  • MdhSmsInitFinishedIndArg() : MdhSmsInitFinishedIndArg
  • MdhSmsNewMessageIndArg() : MdhSmsNewMessageIndArg
  • MdhSmsReadIndArg() : MdhSmsReadIndArg
  • MdhSmsReadReqArg() : MdhSmsReadReqArg
  • MdhSmsRefreshIndArg() : MdhSmsRefreshIndArg
  • MdhSmsReportReadIndArg() : MdhSmsReportReadIndArg
  • MdhSmsReportReadReqArg() : MdhSmsReportReadReqArg
  • MdhSmsSetWaitingReqArg() : MdhSmsSetWaitingReqArg
  • MdhSmsStatusIndArg() : MdhSmsStatusIndArg
  • MdhSmsStatusReqArg() : MdhSmsStatusReqArg
  • MdhSmsStorageRefreshIndArg() : MdhSmsStorageRefreshIndArg
  • MdhSmsTransmitAckArg() : MdhSmsTransmitAckArg
  • MdhSmsTransmitIndArg() : MdhSmsTransmitIndArg
  • MdhSmsTransmitStartAckArg() : MdhSmsTransmitStartAckArg
  • MdhSmsTransmitStartIndArg() : MdhSmsTransmitStartIndArg
  • MdhSmsTransmitStopIndArg() : MdhSmsTransmitStopIndArg
  • MdhSmsUpdStatusIndArg() : MdhSmsUpdStatusIndArg
  • MdhSmsUpdStatusRefreshIndArg() : MdhSmsUpdStatusRefreshIndArg
  • MdhSmsUpdStatusReqArg() : MdhSmsUpdStatusReqArg
  • MdhSmsWaitingIndArg() : MdhSmsWaitingIndArg
  • MdhSmsWriteCnfArg() : MdhSmsWriteCnfArg
  • MdhSmsWriteReqArg() : MdhSmsWriteReqArg
  • MdhToSmsWorkMediaTranslation() : SimAccessor
  • MdhUpdateSms() : SimAccessor
  • MdhUpdateSmsStatus() : SimAccessor
  • MeasurementData() : MeasurementData
  • MeasurementDataArg() : MeasurementDataArg
  • Media() : StreamAudioReference, Media
  • MediaBox() : MediaBox
  • MediaBoxView() : MediaBoxView
  • MediaFilter() : MediaFilter
  • MediaFrameworkCaps() : MediaFrameworkCaps
  • MediaInfo() : MediaInfo
  • MediaManagerMsg() : MediaManagerMsg
  • MediaObtainer() : MediaObtainer, Media
  • MediaPathnameVisitor() : MediaPathnameVisitor
  • MediaRef() : MediaRef
  • MediaRefContainer() : MediaRefContainer
  • MediaRefExists() : MediaRefContainer
  • MediaRefLinkable() : MediaRefLinkable
  • MediaTrackInfo() : MediaInfo::MediaTrackInfo
  • MediaVisitor() : MediaVisitor
  • Melody() : Melody
  • MemMap() : MemMap
  • MemPool() : MemPool
  • MemPoolEntry() : MemPoolEntry
  • Menu() : Menu, Font, AbstractMenuAccessor
  • MenuAccessor() : MenuAccessor
  • MenuDesc() : MenuDesc
  • MenuDescObj() : MenuDescObj
  • MenuFileExists() : MenuPool
  • MenuIdObj() : MenuIdObj
  • MenuItem() : MenuItem
  • MenuItemSelected() : SimTkHandler
  • MenuList() : MenuList
  • MenuListView() : MenuListView
  • MenuPool() : MenuPool
  • MenuProperties() : MenuProperties
  • MenuSelectionRejArg() : MenuSelectionRejArg
  • MenuSelectionReqArg() : MenuSelectionReqArg
  • MenuTableNode() : MenuTableNode, MenuTable
  • MenuTextPtrArrayIterator() : MenuTextPtrArrayIterator
  • MenuView() : MenuView
  • MenuWindow() : MenuWindow
  • MePhonebookDescription() : MePhonebookDescription
  • MePhonebookDescriptor() : MePhonebookDescriptor
  • Merge() : TextCompoundItem, Control::NavigationGuidance, CompoundItem, CfuServiceArray, MessageIdentifierContainer, RichTextCompoundItem, GeneralCompoundItem
  • MergeDataCodingSchemeRanges() : Cbs::Filter
  • MergeFilters() : CbsFilterList
  • MergeMessageIdentifierRanges() : Cbs::Filter
  • MergeProvider() : MergeProvider
  • Message() : Message, InternalTracer
  • MessageBox() : MessageBox
  • MessageClass() : DataCodingScheme, EnumTranslationTable
  • MessageHook() : MessageHook, MessageRouter
  • MessageIdentifier() : MessageIdentifier
  • MessageIdentifierContainer() : MessageIdentifierContainer
  • MessageIdentifierPair() : MessageIdentifierContainer::MessageIdentifierPair
  • MessageIdentifierRange() : MessageIdentifierRange
  • MessageMapContainer() : MessageMapContainer< T >
  • MessageMapDispatcher() : MessageMapDispatcher
  • MessageReferrer() : MessageReferrer, Message
  • MessageResultReason() : EnumTranslationTable
  • MessageStatus() : EnumTranslationTable
  • MessageType() : DataConn, ProtocolIdentifier, InformationElement, EnumTranslationTable
  • MessageTypeIndicator() : MessageTypeIndicator, EnumTranslationTable
  • MetaData() : MetaData, Image::MetaData
  • MetaDataRecord() : MetaDataRecord
  • MexeDescriptor() : MexeDescriptor
  • MidiSound() : MidiSound
  • MimeCoder() : MimeCoder
  • MimeTypeFilter() : MimeTypeFilter
  • MinuteTickMsg() : MinuteTickMsg
  • MlcNumber() : MlcNumber
  • MmAocChargingStatusMsg() : MmAocChargingStatusMsg
  • MmCallAcceptMsg() : MmCallAcceptMsg
  • MmCallDisconnectingMsg() : MmCallDisconnectingMsg
  • MmCallDispatcher() : MmCallDispatcher
  • MmCallHandler() : MmCallHandler
  • MmCallHdl() : MmCallHdl
  • MmCallInfo() : MmCallInfo
  • MmCallInfoMsg() : MmCallInfoMsg
  • MmCallNotifyMsg() : MmCallNotifyMsg
  • MmCallReleaseMsg() : MmCallReleaseMsg
  • MmCallSerialTerminalListener() : MmCallSerialTerminalListener
  • MmCallSetupProgressMsg() : MmCallSetupProgressMsg
  • MmCallStatusMsg() : MmCallStatusMsg
  • MmCoordParam() : MmCoordParam
  • MmcsParam() : MmcsParam
  • MmCurrentCallMeterMsg() : MmCurrentCallMeterMsg
  • MmCurrentChargeDataMsg() : MmCurrentChargeDataMsg
  • MmfCreateStream() : StreamAudioReference
  • MmMocSetupAcceptMsg() : MmMocSetupAcceptMsg
  • MnInformationIndArg() : MnInformationIndArg
  • MnNetworkSearchModeReqArg() : MnNetworkSearchModeReqArg
  • MnTriggerReqArg() : MnTriggerReqArg
  • MobileOriginatedUssdHandler() : MobileOriginatedUssdHandler
  • MocAlertIndArg() : MocAlertIndArg
  • MoCallAction() : MoCallAction
  • MocSetupAccArg() : MocSetupAccArg
  • MocSetupAcceptMsg() : MocSetupAcceptMsg
  • MocSetupCnfArg() : MocSetupCnfArg
  • MocSetupRejArg() : MocSetupRejArg
  • MocSetupRejectIndMsg() : MocSetupRejectIndMsg
  • MocSetupRejIndArg() : MocSetupRejIndArg
  • MocSetupReqArg() : MocSetupReqArg
  • Model() : Model
  • Modification() : Provider::Modification
  • Modify() : FfsFile, FfsHandler
  • ModifyLock() : SimChvHandler, SimAccessor, DataHandler
  • ModifySelectedItem() : CalendarRecordsList, CalendarListWin
  • MolrInfo() : MolrInfo
  • MolrParams() : MolrParams
  • MolrProcessed() : LcsReqProcessor
  • MolrRepeatInfo() : MolrRepeatInfo
  • MonthName() : Date
  • MoreMessagesToSend() : SmsStatusReport, SmsDeliver
  • Mount() : MainHandler
  • Move() : Rect, Point, WinRect, File
  • MoveCaret() : SearchBox, TimeEditor, DateEditor, AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor
  • MoveCursor() : TimeEditBox, EditBox, DateEditBox, AbstractEditBox
  • MoveCursorToLine() : AbstractEditBox
  • MoveFile() : RootFileSystem
  • MoveNextElements() : RegDeletionBufferEntry
  • MoveSelectedIndex() : AbstractItemGrid, AbstractGrid
  • MoveSmsToArchive() : AbstractSmsApp
  • MoveToParagraph() : ParagraphCompoundItem
  • MoveUnicodeBufferAndAdjustBytes() : DataCoding
  • MoveValue() : IndexTable< T >
  • Mp3AudioDevice() : Mp3AudioDevice
  • MptyCallHdl() : MptyCallHdl
  • MptyCallReleaseMsg() : MptyCallReleaseMsg
  • MptyCnfArg() : MptyCnfArg
  • MptyHoldRejectedMsg() : MptyHoldRejectedMsg
  • MptyOnHoldMsg() : MptyOnHoldMsg
  • MsgLoop() : SimpleAppContext, AppContext, AppContainer, AbstractAppContext
  • MsgQueue() : MsgQueue, AppContainer
  • MtcAcceptArg() : MtcAcceptArg
  • MtcAcceptRejArg() : MtcAcceptRejArg
  • MtcAlertReqArg() : MtcAlertReqArg
  • MtcArrivedMsg() : MtcArrivedMsg
  • MtcConfIndArg() : MtcConfIndArg
  • MtcReadyMsg() : MtcReadyMsg
  • MtcSetupComplArg() : MtcSetupComplArg
  • MtcSetupIndArg() : MtcSetupIndArg
  • MtlrInfo() : MtlrInfo
  • MultiLineEditor() : MultiLineEditor
  • MultiMediaEditor() : MultiMediaEditor
  • MultiMediaEditorDocument() : MultiMediaEditorDocument, ParagraphCompoundItem
  • MultipartParser() : MultipartParser
  • MultiPartyCallInvokedMsg() : MultiPartyCallInvokedMsg
  • MultiSlotDispatcher() : MultiSlotDispatcher
  • MultiSlotHandler() : MultiSlotHandler
  • MultiSlotMode() : MultiSlotMode
  • MultiTapCaret() : MultiTapCaret
  • MultiTapInputMapper() : MultiTapInputMapper
  • MusicMode() : Led
  • Mute() : SpeechAudioDevice
  • MuteSpeech() : Audio
  • Mutex() : Mutex
  • MutexObtainer() : MutexObtainer
  • MyProfile() : PsdDataConn, DataConn, CsdDataConn
  • MyState() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- n -

  • NamePatternFileFilter() : NamePatternFileFilter
  • NamePatternStorageDeviceFilter() : NamePatternStorageDeviceFilter
  • Native16Bit() : Native16Bit
  • Native32Bit() : Native32Bit
  • NativeImage() : NativeImage
  • NavigateCaret() : AbstractMultiLineEditor
  • NavigationGuidance() : Control::NavigationGuidance
  • NeighbourCell() : NeighbourCell
  • NestedLevel() : InternalTracer
  • NetAdapter() : NetAdapter, NetAdapterHandler
  • NetAdapterHandler() : NetAdapterHandler
  • NetworkDispatcher() : NetworkDispatcher
  • NetworkHandler() : NetworkHandler
  • NetworkInformationMsg() : NetworkInformationMsg
  • NetworkSsErrorMsg() : NetworkSsErrorMsg
  • NetworkSsRejectedMsg() : NetworkSsRejectedMsg
  • New() : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile, InternalTracer
  • NewDataElement() : BtSddbDataElementFactory
  • NewHeader() : ObexHeaderBuilder
  • NewSim() : PhonebookApp
  • NewSint() : BtSddbDataElementFactory
  • NewUint() : BtSddbDataElementFactory
  • NewUuid() : BtSddbDataElementFactory
  • Next() : VoiceMemoMenuAccessor, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, DataConnAccessor, WindowHierarchyIterator, ThemeViewIterator, Control::ComponentIterator, ScanlineAccessor, TextMenuAccessor, AbstractMenuAccessor, CompoundItemIterator, ActionMenuAccessor, AbstractSmsViewerWin
  • NextExpiringTimer() : AppContainer
  • NextSocketTestMsg() : NextSocketTestMsg
  • NiSharedPtr() : NiSharedPtr< X >
  • NmeaUartSettings() : NmeaUartSettings
  • NoEntrySelected() : PhonebookApp
  • NoMessage() : NoMessage
  • NonCloneable() : NonCloneable
  • NonCopyable() : NonCopyable
  • NonsharedBinDataDataSource() : NonsharedBinDataDataSource
  • NoStackMsgArg() : NoStackMsgArg
  • NotEqualsRule() : NotEqualsRule
  • NotificationTableEntry() : NotificationTableEntry
  • Notify() : InputMapper, BtObservableService, Registry, Zi8InputMapper, T9InputMapper, InformationElement
  • NotifyArrival() : UibServiceImpl
  • NotifyAsyncChange() : SmsProvider
  • NotifyContextItemSwitch() : ContextManager
  • NotifyContextSwitch() : ContextManager
  • NotifyDataReady() : RtStreamingSource
  • NotifyDelete() : BrowserViewContainer, BrowserView, ImageViewListBoxModel, ImageView, ImageListBoxModel, BrowserViewContainer, BrowserView
  • NotifyError() : RtStreamingEndPoint
  • NotifyFeatureChange() : Feature
  • NotifyIndArg() : NotifyIndArg
  • NotifyMediaAvailableStatus() : StorageDevice, RootFileSystem
  • NotifyObservers() : ObservableObject
  • NotifyOnData() : SerialSocketThread
  • NotifyOnDataRecv() : SocketRxThread
  • NotifyOnReadyToSend() : SocketRxThread
  • NotifyOutputBufferReleased() : EmzH264Decoder, EmzMpeg4Decoder, EmzH264Decoder
  • NotifyPropertyChange() : Item
  • NotifyStoppedOnCause() : RtStreamingEndPoint
  • NRegStateIndArg() : NRegStateIndArg
  • NumberCount() : PhonebookApp
  • NumberIdentificationAction() : NumberIdentificationAction
  • NumberPrompt() : NumberPrompt
  • NumericInputMapper() : NumericInputMapper
  • NvRamDataRecordHandler() : NvRamDataRecordHandler
  • NwDiscStartIndMsg() : NwDiscStartIndMsg
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- o -

  • obex_channel() : emcpp_apoxi_OBEXAdapter
  • obex_implementation() : emcpp_apoxi_OBEXAdapter
  • ObexAbortRequest() : BtObexController
  • ObexAbstractPort() : ObexAbstractPort
  • ObexAbstractTransport() : ObexAbstractTransport, ObexMngr
  • ObexAddHeader() : BtObexController
  • ObexAddress() : ObexAddress
  • ObexAddrMsg() : ObexAddrMsg
  • ObexAppMsg() : ObexAppMsg
  • ObexBuffer() : ObexBuffer
  • ObexChannel() : ObexChannel
  • ObexClient() : ObexClient
  • ObexClientAddr() : ObexClientAddr
  • ObexClientDispatcher() : ObexClientDispatcher
  • ObexClientPort() : ObexClientPort, ObexClientDispatcher
  • ObexConnectRequest() : BtObexController
  • ObexDataBufferIndication() : BtObexController
  • ObexDataIndication() : BtObexController
  • ObexDataServer() : ObexDataServer
  • ObexDiscardHeaders() : BtObexController
  • ObexDisconnectRequest() : BtObexController
  • ObexDispatcher() : ObexDispatcher, ObexEventHandler
  • ObexEventHandler() : ObexEventHandler
  • ObexFtpDataServer() : ObexFtpDataServer
  • ObexFtpServer() : ObexFtpServer
  • ObexGetFreeSize() : BtObexController
  • ObexGetRequest() : BtObexController
  • ObexHeaderBuilder() : ObexHeaderBuilder, ObexHeader
  • ObexHeaderList() : ObexHeaderList, ObexHeaderList::ConstIterator, ObexHeaderBuilder, ObexHeader
  • ObexLayer() : ObexLayer, ObexMngr
  • ObexMsg() : ObexMsg
  • ObexObject() : ObexObject, ObexObjectData
  • ObexOperationId() : ObexOperationId
  • ObexOppBinDataPushClient() : ObexOppBinDataPushClient
  • ObexOppClient() : ObexOppClient
  • ObexOppClientOperation() : ObexOppClientOperation
  • ObexOppDataSinkPushServer() : ObexOppDataSinkPushServer
  • ObexOppServer() : ObexOppServer, ObexMngr
  • ObexProtocol() : ObexProtocol
  • ObexPutRequest() : BtObexController
  • ObexRegisterClientRequest() : BtObexController
  • ObexRegisterServerRequest() : BtObexController
  • ObexResult() : ObexResult
  • ObexSendResponse() : BtObexController
  • ObexServer() : ObexServer, ObexMngr
  • ObexServerAddr() : ObexServerAddr
  • ObexServerDispatcher() : ObexServerDispatcher
  • ObexServerInfo() : ObexServerInfo, ObexMngr
  • ObexServerMngr() : ObexServerMngr, ObexServerInfo
  • ObexServerPort() : ObexServerPort, ObexServerDispatcher
  • ObexServerVisitor() : ObexServerVisitor
  • ObexSetPathRequest() : BtObexController
  • ObexTransportMsg() : ObexTransportMsg
  • ObexTransportSet() : ObexTransportSet, ObexTransportSet::Iterator
  • ObexTransportWin() : ObexTransportWin
  • ObexTriggerMsg() : ObexTriggerMsg
  • ObexUnregisterClientRequest() : BtObexController
  • ObexUnregisterServerRequest() : BtObexController
  • ObexUrlStrParser() : ObexUrlStrParser
  • ObexVCardMsg() : ObexVCardMsg
  • ObjectObtainer() : ObjectObtainer, ObtainableObject
  • ObjectTreeService() : ObjectTreeService
  • ObservableObject() : ObservableObject, Observer
  • ObserveProvider() : PbAdvDataHandler, ProviderProxyItem
  • Observer() : Observer
  • Obtain() : SimpleSemaphore, Semaphore, SimpleMutex, SemObtainer, SimpleSemaphore, Semaphore, MutexObtainer, Mutex, AppMutex, DeviceContext
  • ObtainableObject() : ObtainableObject
  • ObtainBackgroundImages() : Image
  • ObtainBuffer() : ObexObject
  • ObtainDecoder() : CodecManager
  • ObtainEncoder() : CodecManager
  • ObtainItemRenderer() : GuiEngineConfig
  • ObtainMemMap() : RamData, DataSourceBinData, BinData, FileBinData
  • ObtainMimeType() : ObexHeaderList
  • ObtainMutex() : AbstractTextRenderer
  • Off() : Led, Control::NavigationGuidance
  • Ok() : ObexResult, BtObexResponseCode, SimpleMap< TKey, TValue >, MessageBox, ExtPsdContextListener_SerialTerminal, SerialTerminal, AtResponse
  • OmBandStatusCnfArg() : OmBandStatusCnfArg
  • OmBandStatusReqArg() : OmBandStatusReqArg
  • OmControlIndArg() : OmControlIndArg
  • OmFactoryResetIndArg() : OmFactoryResetIndArg
  • OmGetTermProfileCnfArg() : OmGetTermProfileCnfArg
  • OmGetTermProfileReqArg() : OmGetTermProfileReqArg
  • OmMultiSlotIndArg() : OmMultiSlotIndArg
  • OmMultiSlotIndMsg() : OmMultiSlotIndMsg
  • OmMultiSlotReqArg() : OmMultiSlotReqArg
  • OmPowerUpArg() : OmPowerUpArg
  • OmRatChangeCnfArg() : OmRatChangeCnfArg
  • OmRatChangeIndArg() : OmRatChangeIndArg
  • OmRatChangeReqArg() : OmRatChangeReqArg
  • OmSetTermProfileCnfArg() : OmSetTermProfileCnfArg
  • OmSetTermProfileRejArg() : OmSetTermProfileRejArg
  • OmSetTermProfileReqArg() : OmSetTermProfileReqArg
  • On() : Led
  • OnAbort() : ObexServerOppImpl, ObexServer, ObexOppServer, ObexLayer, ObexDataServer, ObexClientOppImpl, ObexClient, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnAbortResponse() : SaProviderImpl, GltpProviderImpl, LcsProviderImplBase, LcsProviderImpl
  • OnAccessoryInd() : AccDispatcher
  • OnActionExecuted() : VoiceMemoWin, SoundBrowserWin, SoundBrowserTestWin, SocketTestWin, SocketTestSettingsWin, SocketTestResultsWin, SocketTestProgressWin, LcsOptionsMenuWin, LcsMainMenuWin, IrdaWin, ImageBrowserTestWin, CameraSettingsWin, CameraOptionSettingsWin, PbSelectNumberWin, PbSelectNoType, PbSelectGroup, Window, MessageBox, ContextMenu, AtlWindow, AtlApplicationPlugin
  • OnActivate() : MenuAccessor, AbstractMenuAccessor
  • OnActivateCompleted() : PdpContextControl
  • OnActivateContextIndication() : PdpContextManagerControl
  • OnActivationStatusContextIndication() : PdpContextControl
  • OnActiveTabChanged() : TabControl
  • OnAddrResponse() : DnsClientTest, DnsClient
  • OnAfterPppRelease() : PppDataConn, CsdDataConn
  • OnAocInd() : AocDispatcher
  • OnAppClose() : BtHsAppPlugin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, AtlApplicationPlugin
  • OnAppGetFocus() : AtlApplicationPlugin
  • OnAppLoseFocus() : AtlApplicationPlugin
  • OnAppOpen() : BtHsAppPlugin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, AtlApplicationPlugin
  • OnAsyncEvent() : UdpTestSocket, TcpTestSocket, TcpServerTestSocket, RegTcpSocket, LcsSocket, TcpNetAdapter, UdpNetAdapter, InetSocket, HttpSocket, HttpServerSocket, FtpSocket, FtpServerSocket, FtpDataSocket, FtpDataServerSocket
  • OnAtAlphaTagReq() : AtcDispatcher
  • OnAtPbListReq() : AtcDispatcher
  • OnAtPbSelectReq() : AtcDispatcher
  • OnAttachAllowedInd() : PlmnDispatcher
  • OnAttachCnf() : PlmnDispatcher
  • OnAttachCompleted() : PdpContextManagerControl
  • OnAttachRej() : PlmnDispatcher
  • OnAttachRep() : PdpContextManagerControl
  • OnAttachStatusIndication() : PdpContextManagerControl
  • OnAuthenticateCompleted() : PsdDataConn, PdpContextControl
  • OnAuthorizationRequired() : BtApplication
  • OnAvrcpCommand() : BtAvrcpCommandInterface
  • OnAvrcpNotification() : BtAvrcpPanelApplication
  • OnAvStateChanged() : IrdaTransport, AbstractTransport
  • OnBack() : Menu
  • OnBandSelectionInd() : NetworkDispatcher
  • OnBdnInd() : SimDispatcher
  • OnBeforePppSetup() : PppDataConn, CsdDataConn
  • OnBeginOperation() : ObexServerOppImpl, ObexServer
  • OnBind() : ObexServerDispatcher, ObexFtpServer, ObexFtpDataServer, RfsObexFtpServer
  • OnBlinkTimer() : AbstractEditBox
  • OnBootDispatching() : BootDispatcher
  • OnBtActivated() : BtApplication
  • OnBufferRequested() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnBufferSwitch() : RtStreamingSource, DataSourceRtStreamingSource
  • OnCallControlIndMsg() : SsWaitDispatcher
  • OnCallEventMessage() : BtHsService, BtHfService
  • OnCallTransferToHeadset() : BtHsProfileService
  • OnCallTransferToPhone() : BtHsProfileService
  • OnCancel() : ToDoDateDialogWin, SoundBrowserWin, SoundBrowserTestWin, RenameFileDialog, BrowserSaveWin, ObexTransportWin, ServerAddressWin, SelfLocationDialog, GltpAidingDataWin, TransferLocationDialog, LocationVerifWin, ImageBrowserWin, ImageBrowserTestWin, ImageBrowserDetailWin, RenameFileDialog, BrowserSaveWin, FmRadioSelectStrongerFreq, FmRadioEditWin, CalendarMonthWin, CalendarGotoDateWin, BtHsVolumeSettingsWin, BtHfVolumeSettingsWin, BtHfFeatureListWin, BtHfAudioPathWindow, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtRequestRunningWindow, PbSelectNumberWin, PbBaseWin, PbAbstractWin, MenuWindow, DialogWindow, PropertyEditor, AtlWindow
  • OnCbsLimitInd() : CbsDispatcher
  • OnCbsNewDataInd() : CbsDispatcher
  • OnCbsStartCnf() : CbsStartDispatcher
  • OnCbsStartRej() : CbsStartDispatcher
  • OnCbsStopCnf() : CbsStopDispatcher
  • OnCbsStopRej() : CbsStopDispatcher
  • OnCellInfoInd() : NetworkDispatcher
  • OnCfuDataInd() : SimDispatcher
  • OnChangedLayout() : EditorDocument, MultiMediaEditorDocument
  • OnChangeStatus() : CheckBox
  • OnChannelClosed() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • OnChannelOpened() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • OnChannelsMatch() : ObexServerDispatcher, ObexServer, ObexClientDispatcher, ObexClient
  • OnChargeInd() : AocDispatcher
  • OnChargeUnitsInd() : AocDispatcher
  • OnChildProviderModification() : SortProvider, FindProvider, FilterProvider, AbstractDelegationProvider, MergeProvider, AppendProvider
  • OnClick() : AbstractButton
  • OnClose() : VoiceMemoRecordWin, VoiceMemoApp, UibSettingsWin, UibApp, ToDoListWin, ToDoComposeWin, SoundBrowserWin, SoundBrowserApp, SocketTestProgressWin, FfsTestDispWin, RegApp, ObexTransportWin, ServerAddressWin, LcsSettingsApp, GltpConnApp, TransferLocationDialog, LcsMainApp, IrdaWin, SavingProgressWin, ImageBrowserWin, ImageBrowserDetailWin, ImageBrowserApp, FmRadioWindow, FmRadioApplication, AbstractSmsViewerWin, AbstractSmsApp, DataConnApp, CameraViewFinderWin, CameraSettingsWin, CameraCaptureWin, CameraApp, CalendarListWin, CalendarAddRecordWin, BtApplication, BtAvrcpPanelApplication, PhonebookApp, PbAbstractWin, ObexServerDispatcher, ObexFtpServer, ObexClientOppImpl, ObexClientDispatcher, ObexClient, Application, Window, Alert, AtlItemGridWindow, AtlApplication
  • OnComplete() : ObexServerOppImpl, ObexServer, ObexProtocol
  • OnConfirm() : UibSettingsWin, ToDoPriorityDialogWin, ToDoDateDialogWin, SoundBrowserWin, RenameFileDialog, InfoDialog, BrowserSaveWin, RegAppFirstWin, ObexTransportWin, ServerAddressWin, SelfLocationDialog, GltpAidingDataWin, TransferLocationDialog, LocationVerifWin, ImageBrowserWin, RenameFileDialog, InfoDialog, BrowserSaveWin, FmRadioSelectStrongerFreq, FmRadioEditWin, DataConnOptionWin, CalendarGotoDateWin, CalendarDialogWin, BtDeviceSearchModeWindow, BtTurnOnOffWindow, BtHsVolumeSettingsWin, BtHsInbandSettingWin, BtHsConnectionSettingWin, BtHfVolumeSettingsWin, BtHfFeatureListWin, BtHfInbandSettingWin, BtHfAudioPathWindow, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtAvrcpDeviceListWin, BtAvrcpControllerDeviceListWindow, BtAvrcpControllerApplicationWindow, PbSelectNumberWin, PbBaseWin, PbAdvAddEditEntry, PbAbstractWin, DialogWindow, AtlWindow
  • OnConnect() : BtHsProfileService, BtAvrcpProfileOperationService, ObexServerOppImpl, ObexServer, ObexLayer, ObexFtpServer, ObexFtpDataServer, ObexDataServer, ObexClientOppImpl, ObexClient, AudioGatiServer, GatiServer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver, RfsObexFtpServer
  • OnConnectableMode() : BtLocalSettings
  • OnConnectActionExecuted() : BtDeviceListWindow
  • OnConnectCompleted() : PsdDataConn, PdpContextControl
  • OnConnectionInd() : NetworkDispatcher
  • OnConnectNotification() : BtHfAppPlugin
  • OnConnectRequestFinished() : BtAvrcpControllerApplicationWindow
  • OnContentConsumedEnd() : DrmAsset, DrmRightsObjectContainer, DrmRightsObject, DrmPermission, DrmConstraint
  • OnContentConsumedStart() : DrmAsset, DrmRightsObjectContainer, DrmRightsObject, DrmPermission, DrmConstraint
  • OnContextFeatureTriggered() : UibApp, LcsMainApp, AbstractSmsApp, DataConnApp, BtHsAppPlugin, BtHfAppPlugin, AtlApplicationPlugin, AtlApplication
  • OnContextSwitched() : AtlItemMenuWindow, AtlWindow
  • OnControllerMessage() : BtHsService, BtHfService
  • OnControlMsg() : UdpSocket, TcpSocket, TcpServerSocket, Socket, InetSocket, SerialSocket
  • OnCursorDown() : AbstractEditBox
  • OnCursorLeft() : AbstractEditBox
  • OnCursorRight() : AbstractEditBox
  • OnCursorUp() : AbstractEditBox
  • OnDataAvailable() : ObexOppServer, ObexOppClient, ObexFtpDataServer, ObexDataServer
  • OnDataComplete() : ObexOppDataSinkPushServer, ObexDataServer
  • OnDataProcessed() : ObexServerOppImpl, ObexServer, ObexOppServer, ObexOppClient, ObexLayer, ObexClientOppImpl, ObexClient
  • OnDataRcvdMsg() : OnDataRcvdMsg
  • OnDataReceived() : NetAdapterHandler, AudioGatiServer, GatiServer
  • OnDataRequested() : ObexFtpDataServer, ObexDataServer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnDataSent() : NetAdapterHandler
  • OnDeactivate() : MenuAccessor, AbstractMenuAccessor
  • OnDeactivateCompleted() : PsdDataConn, PdpContextControl
  • OnDeactivateIndication() : PsdDataConn, PdpContextControl
  • OnDefineCompleted() : PsdDataConn, PdpContextControl
  • OnDelete() : ObexFtpDataServer, ObexDataServer
  • OnDeleteChar() : TimeEditBox, EditBox, DateEditBox, AbstractEditBox
  • OnDeleteObject() : ObexFtpServer, RfsObexFtpServer
  • OnDeRegister() : BtAvrcpProfileRegistrationService
  • OnDetachCnf() : PlmnDispatcher
  • OnDetachCompleted() : PdpContextManagerControl
  • OnDetachIndication() : PdpContextManagerControl
  • OnDeviceListWindowClose() : BtHfProfileWindow
  • OnDeviceNameFound() : BtDeviceListWindow
  • OnDeviceSelectActionExecuted() : BtDeviceListWindow
  • OnDisconnect() : BtAvrcpProfileOperationService, ObexServerOppImpl, ObexServer, ObexLayer, ObexFtpDataServer, ObexDataServer, ObexClientOppImpl, ObexClient, AudioGatiServer, GatiServer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnDisconnected() : ObexServer, ObexFtpServer, ObexFtpDataServer, RfsObexFtpServer
  • OnDisconnectNotification() : BtHfAppPlugin
  • OnDisconnectRequestFinished() : BtAvrcpControllerApplicationWindow
  • OnDiscoverableMode() : BtLocalSettings
  • OnDisonnect() : BtHsProfileService
  • OnDisplaySms() : SmsViewerWin, AbstractSmsViewerWin, EmsViewerWin
  • OnDocumentChanged() : EmsEditorListener, EmsComposeWin
  • OnDtmfSeparator() : EditBox
  • OnDunDisconnectRequestFinished() : BtDunAppPlugin
  • OnEccListInd() : SimDispatcher
  • OnEndOfExecute() : UpdatePbThreadlet, SyncPhoneThreadlet, Threadlet
  • OnEngineeringModeControlResponse() : NetworkDispatcher
  • OnError() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnErrorNotification() : VoiceMemoApp, SoundBrowserWin
  • OnEvent() : BtObexServiceObserver, BtObexServerServiceObserver, BtObexClientServiceObserver, BtServiceObserver, BtSddbServiceObserver
  • OnExecuting() : PbProviderListener, ProviderListener, DelegationProviderListener, JoinProviderListener
  • OnExecutingListener() : SortProvider, FindProvider, FilterProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, AppendProvider
  • OnExportConfirmation() : AbstractSmsUtilityProcessor, AbstractSmsApp, EmsApp
  • OnFailure() : ObexOppClientPull, ObexOppClientPush, ObexOppClientOperation
  • OnFaxDisconnectRequestFinished() : BtFaxAppPlugin
  • OnFdnInd() : SimDispatcher
  • OnFeatureAdded() : MenuPool, FeatureBroker
  • OnFeatureChanged() : AtlItemBox
  • OnFeatureStatusChanged() : MenuPool, FeatureBroker
  • OnFeatureTriggered() : VoiceMemoApp, UibApp, ToDoApp, SoundBrowserApp, RegApp, LcsSettingsApp, LcsMainApp, ImageBrowserWin, ImageBrowserApp, FmRadioApplication, AbstractSmsApp, EmsApp, DataConnApp, CameraApp, CalendarApp, BtHsAppPlugin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, BtDeviceListWindow, BtApplication, BtAvrcpPanelApplication, AtlApplicationPlugin, AtlApplication
  • OnFilePull() : ObexFtpServer, RfsObexFtpServer
  • OnFilePullRequestCompleted() : ObexFtpServer, RfsObexFtpServer
  • OnFilePush() : ObexFtpServer, RfsObexFtpServer
  • OnFilePushRequestCompleted() : ObexFtpServer, RfsObexFtpServer
  • OnFileRequest() : HttpClient
  • OnFinished() : ProviderListener
  • OnFinishedSmsLoading() : BootControl
  • OnFocusNextControl() : TabControl, GridLayout, FlowLayout, Control
  • OnFocusPreviousControl() : TabControl, GridLayout, FlowLayout, Control
  • OnGet() : ObexServerOppImpl, ObexServer, ObexLayer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnGetComplete() : ObexFtpDataServer, ObexDataServer, ObexClientOppImpl, ObexClient
  • OnGetFocus() : UibFolderWin, UibApp, ToDoListWin, FileNameView, LcsMainMenuWin, ImageView, FileNameView, SmsViewerWin, SmsEditor, CameraViewFinderWin, CameraCaptureWin, CalendarListWin, CalendarGrid, BtAvrcpDeviceListWin, BtAvrcpControllerDeviceListWindow, BtAvrcpControllerApplicationWindow, ProvListBoxWin, PbDetails, PbBaseWin, PbAbstractWin, Application, Window, IpAddrInputMapper, InputMapper, GridLayout, DateTimeInputMapper, Control, AbstractMultiLineEditor, AbstractItemGrid, AbstractGrid, AbstractEditor, EditBox, CheckBox, AbstractEditBox, AtlItemGridWindow, AtlWindow, AbstractPredictiveInputBox
  • OnGetFolderListing() : ObexFtpServer, RfsObexFtpServer
  • OnGetHeaders() : ObexFtpDataServer, ObexDataServer
  • OnGetIncoming() : ObexFtpDataServer, ObexDataServer
  • OnGetResponse() : ObexClientOppImpl, ObexClient
  • OnGprsClassInd() : PlmnDispatcher
  • OnHeader() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnHeaderSent() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnHfNotification() : BtHfAppPlugin
  • OnHfProfileSupported() : BtQuerySupportedProfilesRequest
  • OnHfSettingsWindowClosed() : BtHfProfileWindow
  • OnHomezoneInd() : NetworkDispatcher
  • OnHsCallTransferToHeadsetRequestFinished() : BtHsAppPlugin
  • OnHsCallTransferToPhoneRequestFinished() : BtHsAppPlugin
  • OnHsConnectRequestFinished() : BtHsAppPlugin
  • OnHsDisconnectRequestFinished() : BtHsAppPlugin
  • OnHsProfileSupported() : BtQuerySupportedProfilesRequest
  • OnHttpGetRequest() : HttpClient
  • OnHttpPostRequest() : HttpClient
  • OnHttpRequest() : HttpClient, HttpApplication
  • OnIndicateIncoming() : AbstractSmsApp
  • OnInputChar() : AtlApplicationPlugin
  • OnInputMap() : CalendarMonthSelector, CalendarGrid, Control, Grid, EditBox, CheckBox, AbstractMenuList, AbstractListBox, AbstractEditBox
  • OnInputModeChanged() : ToDoComposeWin, AbstractSmsComposeWin, EmsComposeWin
  • OnItemMarked() : EmsEditor, MultiMediaEditor
  • OnItemSelected() : RadioButtonList, MenuList, CheckBoxList, AbstractMenuList
  • OnKeyAutoRepeat() : Application, GridLayout, Control, AbstractGrid, AtlApplicationPlugin
  • OnKeyDown() : SoundBrowserWin, ObexTransportWin, ImageBrowserWin, ImageBrowserDetailWin, CalendarGrid, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtAvrcpControllerApplicationWindow, PbNameEditBox, PbDetailEditBox, PbBaseWin, PbAbstractWin, Application, Window, TabControl, PredInputMapper, PhoneNumberInputMapper, NumericInputMapper, MultiTapInputMapper, IpAddrInputMapper, InputMapper, GridLayout, FlowLayout, DateTimeInputMapper, Control, CalculatorInputMapper, AbstractMultiLineEditor, AbstractLineEditor, AbstractGrid, AbstractEditor, TimeEditBox, EditBox, DateEditBox, PropertyEditor, AtlItemMenuWindow, AtlItemGridWindow, AtlWindow, AtlApplicationPlugin, MultiMediaEditor
  • OnKeyUp() : Application, InputMapper, Control, AbstractEditor, AtlApplicationPlugin, Zi8InputMapper, T9InputMapper
  • OnLanguageChanged() : AbstractSmsApp, PbAbstractWin, Application, Window, TabControl, Item, DrawableObject, Control, Component, AbstractTextObject, AbstractItemGrid, AbstractButton, SoftkeyBar, RadioButtonList, MenuList, MenuAccessor, Menu, CheckBoxList, CheckBox, AbstractMenuAccessor, FeatureItem, AtlWindow, AtlApplicationPlugin, AbstractActionMenuAccessor
  • OnLayoutClient() : VoiceMemoRecordWin, ToDoDateDialogWin, ToDoComposeWin, SoundBrowserWin, SoundBrowserTestWin, RenameFileDialog, InfoDialog, BrowserSaveWin, RegAppFirstWin, ObexTransportWin, ServerAddressWin, SelfLocationDialog, GltpAidingDataWin, TransferLocationDialog, SatteliteInfoWin, LocationResultWin, SavingProgressWin, ImageBrowserWin, ImageBrowserTestWin, ImageBrowserDetailWin, RenameFileDialog, InfoDialog, BrowserSaveWin, FmRadioWindow, FmRadioEditWin, SmsViewerWin, SmsComposeWin, EmsComposeWin, CameraViewFinderWin, CameraSettingsWin, CameraOptionSettingsWin, CalendarMonthWin, CalendarGotoDateWin, CalendarAddRecordWin, BtHsVolumeSettingsWin, BtHfVolumeSettingsWin, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, PbBaseWin, PbAdvAddEditEntry, Window, TabControl, Panel, MessageBox, GridLayout, FlowLayout, Control, AbstractMultiLineEditor, AbstractGrid, TextList, AbstractListBox, AtlLabelListWindow, Zi8PredictiveInputBox, T9PredictiveInputBox, MultiMediaEditor
  • OnLayoutFrame() : Window
  • OnLevelChange() : ItemMenu
  • OnLocalName() : BtLocalSettings
  • OnLocationError() : SaProviderImpl
  • OnLocationNotifInvoke() : LcsProviderImpl
  • OnLocationResponse() : SaProviderImpl, LcsProviderImpl
  • OnLockedKeyDown() : Application
  • OnLongKeyPress() : Application, PhoneNumberInputMapper, InputMapper, Control, AbstractEditor, AtlApplicationPlugin, Zi8InputMapper, T9PredictiveInputBox, T9InputMapper
  • OnLongKeyPress_T9() : T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper
  • OnLoseFocus() : UibApp, AbstractSmsApp, CameraViewFinderWin, CameraCaptureWin, Application, Window, IpAddrInputMapper, InputMapper, DateTimeInputMapper, Control, AbstractItemGrid, AbstractEditor, EditBox, CheckBox, AbstractEditBox, AtlItemMenuWindow, AtlWindow
  • OnMdhNewStatusReportInd() : SmsDispatcher
  • OnMdhSmsDeletion() : SimPduHandler
  • OnMdhSmsDeletionInd() : SmsDispatcher
  • OnMdhSmsInitFinishedInd() : SimDispatcher
  • OnMdhSmsNewMessageInd() : SmsDispatcher
  • OnMdhSmsRefreshInd() : SmsDispatcher
  • OnMdhSmsStorageRefreshInd() : SmsDispatcher
  • OnMdhSmsUpdStatusRefreshInd() : SmsDispatcher
  • OnMdhSmsWaitingInd() : SmsDispatcher
  • OnMeasurementResp() : GltpProviderImpl
  • OnMessage() : VoiceMemoApp, UsbApp, UibPerformanceTest, UibNotifyTest, UibMsgDisplayTest, UibInboxTest, UibFolderWin, UibApp, ToDoListWin, ToDoApp, SoundBrowserWin, SoundBrowserApp, FileNameView, SocketTestApp, RegApp, ObexApp, LcsSettingsApp, GltpConnApp, LcsMainApp, IrdaApp, SavingProgressWin, ImageView, ImageBrowserApp, FileNameView, FmRadioWindow, FmRadioApplication, AbstractSmsApp, CameraCaptureWin, CameraApp, CalendarRecordsList, BtHsVolumeSettingsWin, BtHsAppPlugin, BtHfVolumeSettingsWin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, BtPasskeyRequiredWindow, BtApplication, BtAvrcpPanelApplication, ProvListBoxWin, PhonebookApp, PbBaseWin, AdvPbApp, ServiceThread, MessageMapDispatcher, MessageHook, Dispatcher, Application, Window, TabControl, Model, ItemTree, ItemBox, ImageBox, DrawableObject, Desktop, ContextMenu, Component, Alert, AbstractItemGrid, AbstractEditor, AbstractButton, GenericAudioDevice, SoftkeyBar, SharedTimer, MenuAccessor, Menu, IndicatorBar, AtlItemMenu, AtlItemGrid, AbstractMenuAccessor, BtObexService, BtHsService, BtHfService, BtFaxService, BtDunService, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtSendPasskeyRequest, BtSddbService, BtRespondAuthorizationRequest, BtQuerySupportedProfilesRequest, BtLocalSettings, BtLocalRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtBppService, BtAvrcpService, BtAvrcpOperationService, MmfPlayer, AtlLabelListWindow, AtlItemMenuWindow, AtlItemGridWindow, AtlItemBox, AtlWindow, AtlApplicationPlugin, AtlApplication, StackMsgDispatcher, SimTkLceService, Zi8PredictiveInputBox, UsbTransport, T9PredictiveInputBox, SvgPlayer, HttpServer, FtpServer, SaProviderImpl, GltpProviderImpl, LcsProviderImpl, WapHandler, HttpHandler, SimUserDispatcher
  • OnMnInformationInd() : NetworkDispatcher
  • OnMove() : Window, ImageBox, DrawableObject, Control, Component
  • OnMoveDown() : Grid
  • OnMoveLeft() : Grid
  • OnMoveRight() : Grid
  • OnMoveUp() : Grid
  • OnNameResponse() : DnsClientTest, DnsClient
  • OnNetAdapterClosed() : NetAdapterHandler
  • OnNewStatusReportArrived() : SimPduHandler
  • OnNextItem() : TextList, AbstractListBox
  • OnNotifyMediaAvailableStatus() : StorageDevice
  • OnNRegStateInd() : PlmnDispatcher
  • OnObexAddrMsg() : ObexServerDispatcher, ObexEventHandler, ObexClientDispatcher
  • OnObexMsg() : ObexServerDispatcher, ObexEventHandler, ObexClientDispatcher
  • OnObexTransportMsg() : ObexServerDispatcher, ObexEventHandler, ObexClientDispatcher
  • OnOmBandStatusCnf() : NetworkDispatcher
  • OnOmControlInd() : PowerDispatcher
  • OnOmMultiSlotInd() : MultiSlotDispatcher
  • OnOmRatChangeCnf() : PlmnRatDispatcher
  • OnOmRatChangeInd() : PlmnDispatcher
  • OnOpen() : VoiceMemoApp, UsbApp, UibSettingsWin, UibFolderWin, UibApp, ToDoListWin, ToDoPriorityDialogWin, ToDoDateDialogWin, ToDoApp, SoundBrowserWin, SoundBrowserApp, RenameFileDialog, BrowserSaveWin, SocketTestWin, SocketTestProgressWin, SocketTestApp, FfsTestDispWin, RegAppWin, RegAppFirstWin, RegApp, ObexApp, ServerAddressWin, SelfLocationDialog, LcsSettingsApp, GltpAidingDataWin, GltpConnApp, TransferLocationDialog, LocationVerifWin, LcsOptionsMenuWin, LcsMainMenuWin, LcsMainApp, IrdaWin, IrdaApp, SavingProgressWin, ImageBrowserWin, ImageBrowserDetailWin, ImageBrowserApp, RenameFileDialog, BrowserSaveWin, FmRadioWindow, FmRadioSelectStrongerFreq, FmRadioApplication, SmsSendingConfirmDialog, SmsComposeWin, AbstractSmsApp, EmsApp, DataConnWin, DataConnApp, CameraViewFinderWin, CameraSettingsWin, CameraOptionSettingsWin, CameraCaptureWin, CameraApp, CalendarRecordsList, CalendarMonthWin, CalendarListWin, CalendarDialogWin, CalendarApp, BtDeviceSearchModeWindow, BtTurnOnOffWindow, BtHsVolumeSettingsWin, BtHsInbandSettingWin, BtHsConnectionSettingWin, BtHfVolumeSettingsWin, BtHfFeatureListWin, BtHfInbandSettingWin, BtHfAudioPathWindow, BtDeviceListWindow, BtDeviceDetailWindow, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtRequestRunningWindow, BtApplication, BtActiveDeviceWindow, BtAvrcpDeviceListWin, BtAvrcpPanelApplication, BtAvrcpControllerDeviceListWindow, BtAvrcpControllerApplicationWindow, PhonebookApp, PbSelectNumberWin, PbPhoneNumberPrompt, PbAdvAddEditEntry, PbAbstractWin, ObexClientOppImpl, ObexClientDispatcher, ObexClient, Application, Window, AtlLabelListWindow, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow, AtlWindow, AtlApplication
  • OnOpenMenu() : AtlApplication
  • OnOperationFinished() : BtDeviceListWindow
  • OnPagingTimer() : EditBox
  • OnPaint() : SocketTestWin, SocketTestProgressWin, FfsTestDispWin, SatteliteGraphWin, CameraViewFinderWin, CameraCaptureWin, Control, Alert, AbstractMultiLineEditor, AbstractItemGrid, AbstractGrid, AbstractEditor, AbstractListBox, MultiMediaEditor
  • OnPairableMode() : BtLocalSettings
  • OnPairDeviceActionExecuted() : BtDeviceListWindow
  • OnPairDeviceActionFinished() : BtDeviceListWindow
  • OnPanelPassThrough() : BtAvrcpProfileOperationService, BtAvrcpPanelApplication, BtAvrcpOperationService
  • OnPanelPassthrough() : BtAvrcpProfileOperationService
  • OnPanelPassthroughRequestFinished() : BtAvrcpControllerApplicationWindow
  • OnPaProfileSupported() : BtQuerySupportedProfilesRequest
  • OnPasskeyRequired() : BtApplication
  • OnPbWindowClosed() : PhonebookApp, AdvPbApp
  • OnPenDown() : AbstractListBox
  • OnPenUp() : AbstractMenuList
  • OnPhoneNumberRequired() : BtHfProfileWindow, BtHfProfileService
  • OnPlmnListCnf() : PlmnScanDispatcher, PlmnDispatcher
  • OnPlmnListRej() : PlmnScanDispatcher, PlmnDispatcher
  • OnPlus() : EditBox
  • OnPowerDown() : SocketSubSystem, SubSystem, ServiceThread, GenericWorkerTask, GatiManager, BtController, StackControl, SimTkLceService, KeyMsgGenerator, RegManager, UsbSubSystem, DrmSubsystem, DataControl
  • OnPowerDownCnf() : PowerDownDispatcher
  • OnPowerUp() : SocketSubSystem, SubSystem, ServiceThread, GenericWorkerTask, IrdaObexSubSystem, GatiManager, BtObexSubSystem, BtController, AudioPresetStore, StackControl, SimTkLceService, KeyMsgGenerator, RegManager, UsbSubSystem, SerialSocketSubSystem, DrmSubsystem, DataControl
  • OnPppSetup() : PppDataConn
  • OnPppStop() : PppDataConn
  • OnPreviousItem() : TextList, AbstractListBox
  • OnProfileActivation() : BtLocalSettings
  • OnPropertyNotification() : UibApp, LcsSettingsApp, IrdaApp, FmRadioApplication, AbstractSmsApp, CameraApp, BtApplication, AtlApplicationPlugin, AtlApplication
  • OnProvideFolderListingEntries() : ObexFtpServer, RfsObexFtpServer
  • OnPsdLinkDownCompleted() : PsdDataConn
  • OnPsdLinkUpCompleted() : PsdDataConn
  • OnPull() : ObexOppServer
  • OnPullComplete() : ObexOppServer, ObexOppClient
  • OnPullConfirmed() : ObexOppClient
  • OnPush() : ObexOppServer, WapHandler
  • OnPushComplete() : ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexOppBinDataPushClient
  • OnPushConfirmed() : ObexOppClient
  • OnPushIncoming() : ObexOppDataSinkPushServer
  • OnPut() : ObexServerOppImpl, ObexServer, ObexLayer, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnPutComplete() : ObexFtpDataServer, ObexDataServer, ObexClientOppImpl, ObexClient
  • OnPutHeaders() : ObexFtpDataServer, ObexDataServer
  • OnPutIncoming() : ObexFtpDataServer, ObexDataServer
  • OnPutResponse() : ObexClientOppImpl, ObexClient
  • OnQuerySupportedProfileFinished() : BtDeviceListWindow
  • OnRawFrame() : BtAvrcpProfileOperationService, BtAvrcpOperationService
  • OnReactivateIndication() : PdpContextControl
  • OnReadCounterCompleted() : PsdDataConn, PdpContextControl
  • OnReadNegotiatedDnsServerAddressCompleted() : PsdDataConn, PdpContextControl
  • OnRecordingFinished() : StreamAudioPlayer
  • OnRegister() : BtAvrcpProfileRegistrationService, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnRegisterService() : BtObexSddbServiceObserverImpl, BtSddbServiceObserver
  • OnRegStateInd() : PlmnDispatcher
  • OnRelease() : ObexServerDispatcher, ObexBuffer::Factory, AbstractButton
  • OnReleaseCompleted() : CsdDataConn, DataCallControl
  • OnReleaseResponse() : PsdDataConn
  • OnRemoteConnect() : BtHfProfileWindow
  • OnRemoteDeviceFound() : BtDeviceSearchRequest
  • OnRemoteDeviceName() : BtApplicationDeviceSearchRequest, BtDeviceSearchRequest
  • OnRemoteDeviceSetNameNotification() : BtDeviceListWindow
  • OnRemoteDisconnect() : BtHfProfileWindow
  • OnRepMolrTimeOut() : LcsReqProcessor
  • OnRequestCancel() : BtRequestRunningWindow
  • OnRequestFinished() : BtDeviceListWindow, BtDeviceDetailWindow
  • OnRequestStateChange() : BtHsProfileService, BtHfProfileService, BtFaxProfileService, BtDunProfileService, BtApplicationServiceVerifyRequest, BtApplicationDeviceSearchRequest, BtApplicationSetRemoteDeviceNameRequest, BtApplicationQuerySupportedProfilesRequest, BtApplicationDeviceUntrustRequest, BtApplicationDeviceTrustRequest, BtApplicationDeviceUnpairRequest, BtApplicationDevicePairRequest, BtApplicationRespondAuthorizationRequest, BtApplicationSendPasskeyRequest, BtAvrcpProfileOperationService, BtAvrcpProfileRegistrationService, BtObexServerServiceImpl, BtObexSddbImpl, BtObexClientServiceImpl, BtService, BtLocalRequest, BtBipServerService
  • OnResize() : Window, ItemBox, ImageBox, DrawableObject, Control, Component, AnimatedTextLine, AbstractMultiLineEditor, AbstractItemGrid, AbstractListBox
  • OnResponse() : ObexLayer, BtObexClientObserverImpl, HttpHandler
  • OnResult() : BtObexClientAddrResultNotifier, BtOperationBase
  • OnRfComChannel() : BtObexRegisterServerRequest
  • OnRollback() : DrmAsset, DrmRightsObjectContainer, DrmRightsObject, DrmPermission, DrmConstraint
  • OnSdlSignal() : DwdPlayer, MapiAudioPlayer
  • OnSearchAgainActionExecuted() : BtDeviceListWindow
  • OnSearchAgainActionFinished() : BtDeviceListWindow
  • OnSelectionChanged() : UibFolderWin, ToDoListWin, ImageViewListBoxModel, ImageListBoxModel, DataConnLbModel, BtAvrcpDeviceListWin, BtAvrcpControllerDeviceListWindow, PbProvListBox, ItemMenu, AbstractItemGrid, AbstractGrid, MenuAccessor, Menu, Grid, AbstractMenuAccessor, AbstractListBox, AtlLabelListWindow, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow
  • OnServiceVerifyRequestExecuted() : BtDeviceListWindow
  • OnServiceVerifyRequestFinished() : BtDeviceListWindow
  • OnServiceVerifyResultReceived() : BtServiceVerifyRequest
  • OnSetAutomaticDnsServerNegotiationCompleted() : PsdDataConn, PdpContextControl
  • OnSetCounterCompleted() : PsdDataConn, PdpContextControl
  • OnSetCurrentFolder() : ObexFtpServer, RfsObexFtpServer
  • OnSetDeviceNameActionExecuted() : BtDeviceListWindow
  • OnSetMinimumQualityOfServiceCompleted() : PdpContextControl
  • OnSetPacketFilterCompleted() : PsdDataConn, PdpContextControl
  • OnSetPath() : ObexServer, ObexLayer, ObexFtpDataServer, ObexDataServer, ObexClient, BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServerServiceObserver, BtObexClientServiceObserver
  • OnSetQualityOfServiceCompleted() : PsdDataConn, PdpContextControl
  • OnSetupCompleted() : CsdDataConn, DataCallControl
  • OnSetupResponse() : PsdDataConn
  • OnShiftKey() : EditBox
  • OnShortKeyUp_T9() : T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper
  • OnShowDetailsActionExecuted() : BtDeviceListWindow
  • OnShutdownRequest() : Application
  • OnSignalChange() : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueSignalListener, SioGlueSignalListener, SerialTerminal
  • OnSignalStrengthLevelInd() : SigDispatcher
  • OnSimChanged() : PhonebookApp
  • OnSimChvRefreshInd() : SimDispatcher
  • OnSimErrorInd() : SimDispatcher
  • OnSimFullAccessInd() : SimDispatcher
  • OnSimInfoInd() : SimDispatcher
  • OnSimInitInd() : SimDispatcher
  • OnSimLockStatusInd() : SimDispatcher
  • OnSimMccMncInd() : SimDispatcher
  • OnSimMruPropertyRefreshInd() : SimDispatcher
  • OnSimNotPresent() : PhonebookApp, AdvPbApp
  • OnSimPresent() : PhonebookApp, AdvPbApp
  • OnSimReady() : PhonebookApp, AdvPbApp
  • OnSimRefreshInd() : SimDispatcher
  • OnSimRemoved() : AbstractSmsApp
  • OnSimSmsReady() : AbstractSmsApp
  • OnSimStateChanged() : PhonebookApp
  • OnSmsCapacityAvailable() : SmsDispatcher
  • OnSmsCapacityExceeded() : SmsDispatcher
  • OnSmsSendCnf() : SmsSendDispatcher, SmsDispatcher
  • OnSmsSendRej() : SmsSendDispatcher, SmsDispatcher
  • OnSmsService() : AbstractSmsApp
  • OnSocketEvent() : SocketEventListener
  • OnSoftkeyPressed() : FfsTestDispWin, PbAbstractWin, RadioButtonList, CheckBox, AbstractMenuList
  • OnSoftkeyReleased() : RadioButtonList
  • OnSortingChanged() : UibApp
  • OnSsBarringInd() : SsDispatcher
  • OnSsBeginAcc() : SsWaitDispatcher, SsDispatcher
  • OnSsCauseInd() : SsDispatcher
  • OnSsCcbsReCallInd() : SsCcbsDispatcher
  • OnSsCcbsResultInd() : SsCcbsDispatcher
  • OnSsCcbsStatusInd() : SsCcbsDispatcher
  • OnSsDataInd() : SsDispatcher
  • OnSsEndInd() : SsDispatcher
  • OnSsErrInd() : SsDispatcher
  • OnSsError() : LcsProviderImpl
  • OnSsFacilityRej() : SsWaitDispatcher, SsDispatcher
  • OnSsForwardingInd() : SsDispatcher
  • OnSsForwcheckInd() : SsDispatcher
  • OnSsGetPasswordInd() : SsDispatcher
  • OnSsGetPasswordRej() : SsDispatcher
  • OnSsInterrogateInd() : SsDispatcher
  • OnSsNotifyInd() : SsDispatcher
  • OnSsPasswordInd() : SsDispatcher
  • OnSsRej() : SsDispatcher
  • OnSsRetResInd() : SsDispatcher
  • OnSsUnstructInd() : SsDispatcher
  • OnSsUssdInd() : SsDispatcher
  • OnSsUssdResentInd() : SsDispatcher
  • OnStart() : RealTimeClock, Led, DefaultDisplay, Charger, RealTimeClock, Led, Keyboard, DefaultDisplay, Charger, RealTimeClock, Led, Keyboard, DefaultDisplay, Charger, RealTimeClock, Led, Keyboard, DefaultDisplay, Charger, RealTimeClock, Led, Keyboard, DefaultDisplay, Charger, AbstractDevice
  • OnStarted() : PbProviderListener, ProviderListener, RtStreamingConn
  • OnStartup() : VoiceMemoApp, UibApp, ToDoApp, SoundBrowserApp, SocketTestApp, RegApp, LcsSettingsApp, GltpConnApp, LcsMainApp, ImageBrowserApp, FmRadioApplication, AbstractSmsApp, EmsApp, DataConnApp, CameraApp, CalendarApp, BtApplication, BtAvrcpPanelApplication, PhonebookApp, Application, AtlApplication
  • OnStateChange() : BtLocalSettings
  • OnStop() : RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, RealTimeClock, DefaultDisplay, AbstractDevice
  • OnStopNotification() : SoundBrowserWin
  • OnStopped() : RtStreamingConn
  • OnSubunitInfo() : BtAvrcpProfileOperationService
  • OnSubUnitInfoRequestFinished() : BtAvrcpControllerApplicationWindow
  • OnSupportedProfileSearch() : BtDeviceListWindow, BtDeviceDetailWindow
  • OnTerminalEvent() : ExtPsdContextListenerImpl_SerialTerminalListener, ExtPsdContextListener_SerialTerminalListener, SocketSerialTerminalListener, SerialTerminalListener, MmCallSerialTerminalListener, MmCallDispatcher
  • OnTerminalResponse() : MmCallHandler
  • OnTestparamInd() : NetworkDispatcher
  • OnThemeChanged() : Application, Window, TabControl, TabButton, RadioButtonControl, PushButton, ProgressBar, PositionIndicator, Panel, MultiLineEditor, GridLayout, FlowLayout, DrawableObject, Control, Component, CheckBoxControl, AbstractTextObject, AbstractItemGrid, AbstractGrid, TextList, SoftkeyBar, RadioButtonList, MenuList, Grid, CheckBoxList, CheckBox, Animation, AbstractListBox, AbstractEditBox, AtlWindow, AtlApplicationPlugin
  • OnTimeout() : VoiceMemoRecordWin, LcsMainApp, BtPasskeyRequiredWindow, ServiceThread, Application, Control, Alert, AbstractItemGrid, AbstractGrid, AbstractListBox, AtlApplicationPlugin
  • OnTimeOut() : SaProviderImpl, GltpProviderImpl, LcsProviderImplBase, LcsProviderImpl
  • OnTimer() : SocketTestProgressWin, SocketTestApp, FfsTestDispWin, SysDnsClient, Timer, DefaultDisplay, VibratorDevice, DefaultDisplay, SharedTriggerTimer< T >, EditBoxPagingTimer, Animation, EditBoxBlinkTimer, TriggerTimer< T >, LcsTimer, LcsRepeatTimer
  • OnToneStopped() : GenericAudioDevice
  • OnTransferAudioToAccessoryNotification() : BtHfAppPlugin
  • OnTransferAudioToPhoneNotification() : BtHfAppPlugin
  • OnTransferCallToHandsfree() : BtHfProfileWindow
  • OnTransferCallToHandsfreeFinished() : BtHfProfileWindow
  • OnTransferCallToPhone() : BtHfProfileWindow
  • OnTransferCallToPhoneFinished() : BtHfProfileWindow
  • OnTransportDisconnect() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnTransportError() : ObexProtocol
  • OnTrigger() : FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor, MenuAccessor, Menu, ActionMenuAccessor, AbstractActionMenuAccessor
  • OnTriggerNotification() : SocketTestApp, PhonebookApp
  • OnTrustDeviceActionExecuted() : BtDeviceListWindow
  • OnTrustDeviceActionFinished() : BtDeviceListWindow
  • OnUibNotifyService() : UibApp
  • OnUibRegisterService() : UibApp
  • OnUndefineCompleted() : PsdDataConn, PdpContextControl
  • OnUnitInfo() : BtAvrcpProfileOperationService
  • OnUnpairDeviceActionExecuted() : BtDeviceListWindow
  • OnUnpairDeviceActionFinished() : BtDeviceListWindow
  • OnUnregister() : BtObexServerObserverImpl, BtObexClientObserverImpl, BtObexServiceObserver
  • OnUnregisterService() : BtObexSddbServiceObserverImpl, BtSddbServiceObserver
  • OnUnsetPacketFilterCompleted() : PdpContextControl
  • OnUntrustDeviceActionExecuted() : BtDeviceListWindow
  • OnUntrustDeviceActionFinished() : BtDeviceListWindow
  • OnUpdate() : UibPerformanceTest, UibInboxTest, UibInboxProvider, UibFolderWin, ObexAbstractTransport, IndicatorPaneObject, IndicatorBar, Observer, AbstractDelegationProvider, ProviderProxyItem, ProviderProxyContainer, UsbObexTransport
  • OnUpdateContextItem() : AtlApplicationPlugin
  • OnUserActivity() : UserActivityListener
  • OnUserConnect() : BtHfProfileWindow
  • OnUserConnectFinished() : BtHfProfileWindow
  • OnUserDisconnect() : BtHfProfileWindow
  • OnUserDisconnectFinished() : BtHfProfileWindow
  • OnVeryLongKeyPress() : Application, AtlApplicationPlugin
  • OnWildcard() : EditBox
  • OnZeroReferrers() : ReferableObject
  • Open() : LocResController, FfsDataConnProfileStorage, UdpSocket, TcpSocketBase, TcpSocket, TcpServerSocket, SysSocket, InetSocket, DataConnProfileStorage, ObexServerDispatcher, ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexFtpServer, ObexClientDispatcher, ObexAbstractPort, MessageBox, VideoChannel, StillCamera, VideoCamera, VideoChannel, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoChannel, NonsharedBinDataDataSource, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, VideoChannel, StillCamera, Camera, VideoChannel, FileOutputStream, FileInputStream, FfsFile, StringDataSink, StreamWriter, StreamReader, Stream, HeapDataSource, HeapDataSink, DataSource, DataSink, BinDataDataSource, RtStreamingEndPoint, ExtPsdContextListener_SioGlueWrapper, FileDataSource, FileDataSink, File, FlsFile, FfsHandler, SerialSocket, SerialIoAdapter, SioGlueWrapper, SerialTerminalSocket, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoderRenderer, AudioDecoder, AudioCapturerEncoder, RootFileImp, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile
  • OpenAction() : ObexServerDispatcher, ObexServer, ObexClientDispatcher, ObexAbstractPort, AtiAudioPlayerRtStreamingSink, RtStreamingEndPoint, DataSourceRtStreamingSource
  • OpenChannel() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • OpenClientChannel() : ObexProtocol, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • OpenClientNetAdapter() : NetAdapterHandler
  • OpenCompleteAction() : ObexAbstractPort
  • OpenContextMenuAction() : OpenContextMenuAction
  • OpenCurrentPathWindow() : BtHfAudioPathWindow
  • OpenDatabase() : DBService
  • OpenDefaultPathWindow() : BtHfAudioPathWindow
  • OpenEditBox() : PbDetails
  • OpenFfsFile() : FfsDataConnProfileStorage
  • OpenFile() : StreamAudioReference
  • OpenHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • OpenMatrixWindow() : T9ThaiMatrixModeWindowInterface
  • OpenModal() : Window, Alert
  • OpenModeless() : EmsComposeWin, Window, Alert
  • OpenPbWinMsg() : OpenPbWinMsg
  • OpenPhonebook() : PhonebookApp
  • OpenServerNetAdapter() : NetAdapterHandler
  • OpenStreaming() : File, FlsFile, RootFileImp, RamFileImp, FlashFileImp, FatFileImp, FatFile
  • OpenWindowAction() : OpenWindowAction
  • OperationRequestResponse() : BtAvrcpOperationService
  • operator *() : MediaRefLinkable, ObexTransportSet::Iterator, ObexHeaderList::ConstIterator, BtDeviceListReverseIterator, BtDeviceListConstantReverseIterator, BtDeviceListIterator, BtDeviceListConstantIterator, Vector< T >::Iterator, SharedPtr< T_obj >, NiSharedPtr< X >, Fraction, Pathname::ReverseIterator, Pathname::Iterator, ServicePtr< T >
  • operator *=() : Fraction, SignedValue, UnsignedValue
  • operator BitmapRes() : Bitmap
  • operator bool() : SharedPtr< T_obj >
  • operator BOOLEAN() : ObexResult, BtObexResponseCode
  • operator const CHAR *() : String
  • operator const WCHAR *() : WString
  • operator delete() : WStrData, StrData
  • operator INT32() : LcsWString
  • operator new() : WStrData, StrData
  • operator T_AUTH_PPP_FRAME() : PppFrame
  • operator UINT32() : LcsWString
  • operator WCHAR() : CharItem
  • operator!=() : ObexOperationId, ObexChannel, Ticks, TextFormat, Rect, IconState, Font, Control::NavigationGuidance, Color, BtSvrDataElement, BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceAndServiceClass, BtDeviceAddress, BtDevice, WString, Vector< T >::Iterator, TimeZone, Time, String, SharedPtr< T_obj >, DateTime, Date, DataItem, ResourceID, Uri, Pathname, Pathname::ReverseIterator, Pathname::Iterator, ServicePtr< T >, Guid
  • operator()() : MenuTextPtrArrayIterator, MenuTextIterator, AnimationBmpPointerArrayIterator, AnimationBmpArrayIterator, AnimationBmpIterator, HeapArrayObject< T >, HeapObject< T >
  • operator+() : Ticks, WString, Vector< T >::Iterator, String, DateTime, Fraction, Uri
  • operator++() : ObexTransportSet::Iterator, ObexHeaderList::ConstIterator, WindowHierarchyIterator, Control::ComponentIterator, DeviceManager::Iterator, BtDeviceListReverseIterator, BtDeviceListConstantReverseIterator, BtDeviceListIterator, BtDeviceListConstantIterator, Vector< T >::Iterator, Pathname::ReverseIterator, Pathname::Iterator
  • operator+=() : Ticks, WString, String, DateTime, Fraction, Uri
  • operator-() : Ticks, Vector< T >::Iterator, DateTime, Fraction, SignedValue
  • operator--() : WindowHierarchyIterator, BtDeviceListReverseIterator, BtDeviceListConstantReverseIterator, BtDeviceListIterator, BtDeviceListConstantIterator, Vector< T >::Iterator
  • operator-=() : Ticks, DateTime, Fraction
  • operator->() : ObexTransportSet::Iterator, ObexHeaderList::ConstIterator, BtDeviceListReverseIterator, BtDeviceListConstantReverseIterator, BtDeviceListIterator, BtDeviceListConstantIterator, SharedPtr< T_obj >, NiSharedPtr< X >, ServicePtr< T >
  • operator/() : Fraction
  • operator/=() : Fraction
  • operator<() : Timer, Ticks, WString, Vector< T >::Iterator, Time, String, PhoneNumber, DateTime, Date, DataItem, ResourceID, InputActionPtr, SimItemIdentifier, SimItemId, SimAtom< T >, PlmnListEntry, Pathname::ReverseIterator, Pathname::Iterator, NotificationTableEntry, SignedValue, UnsignedValue
  • operator<<() : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, OnDataRcvdMsg, LcsWString, SmsSettingsRecord, ObexVCardMsg, TraceOutputStream, OutputStream, DebugOutputStream, WString, Time, String, PhoneNumber, IpAddr, DateTime, Date, BitField< T >, Uri, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg
  • operator<=() : Ticks, WString, Vector< T >::Iterator, Time, String, DateTime, Date, DataItem
  • operator=() : LcsWString, ObexTransportSet, ObexTransportSet::Iterator, ObexResult, ObexOperationId, ObexObject, ObexHeaderList::ConstIterator, ObexChannel, ObexBuffer, Ticks, MessageReferrer, Native32Bit, Native16Bit, LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit, IconSet, CharItem, BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtHsNotificationMessage, BtHfNotificationMessage, BtSddbServiceRecord, BtObexResponseCode, BtDeviceAndServiceClass, BtDeviceAddress, BtAvrcpOperationServiceMessage, BtAvrcpNotificationMessage, WString, Vector< T >, VCard, String, SharedPtr< T_obj >, RegBlobObject, PhoneNumber, ObjectObtainer, NiSharedPtr< X >, IndexTable< T >, SortedElementList< T >, ElementList< T >, DynamicBitVector, DataItem, ByteBuffer, BlobPtr, BlobObject, RtStreamingBuffer, AudioPath, ProviderProxyItem, PppFrame, UsimPbFillStatus, UsimPbLocReport, UsimPbGroups, UsimPbChangedField, UsimPbRefRecord, Tpdu, Tlv, SimIconIdentifier, SimNextActionIdentifier, CfuServiceArray, CfuService, EccCategory, L1Param, CiTestParamList, CiTestParam, EquivPlmnLists, RrcParam, RrParam, CellParam, NeighbourCellList, NeighbourCell, MmCoordParam, GmmParam, MmcsParam, GprsParam, AckNackParamList, AckNackTestparamCnt, AckNackCnt, COverIList, GsmBandList, Plmn, BcdPlmn, AsTestparamDatabase, UmtsNcellParamList, CellChangeCnts, RrcProcessState, UmtsCellList, UmtsNcellParam, UmtsMeasEvalParam, UmtsMeasIdParam, UmtsRrcScellParam, Uplmn, DchReport, BlerTrchInfoList, MultiSlotMode, MessageIdentifierContainer, ToStackMsg, FromStackMsg, MdhGors, MdhExtendedData, InformationElement, SimImage, SimIconDescription, SimImageDescriptor, Cbs, Cbs::Filter, BaseInformationElement, MePhonebookDescription, MePhonebookDescriptor, Uri, ServicePtr< T >, AtResponse, AtResponseParameter, LastLocationEstimate, SimPbEntry
  • operator==() : MediaRefLinkable, MediaRef, MediaRefLinkable, MediaRef, ObexOperationId, ObexChannel, Ticks, ApplicationListEntry, TextFormat, Rect, IconState, Font, Control::NavigationGuidance, Color, BtSvrDataElement, BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceAndServiceClass, BtDeviceAddress, BtDevice, WString, Vector< T >::Iterator, TimeZone, Time, String, SharedPtr< T_obj >, PhoneNumber, ProviderPtr, DateTime, Date, DataItem, BitField< T >, AudioPlayerStore::DataFormatDataSource, AudioPath, AudioActiveReference, ResourceID, InputActionPtr, Tpdu, SimItemIdentifier, SimAtom< T >, PlmnListEntry, MessageIdentifierContainer::MessageIdentifierPair, MessageIdentifierRange, MessageIdentifier, DataCodingSchemeRange, DataCodingScheme, Uri, Pathname, Pathname::ReverseIterator, Pathname::Iterator, Path, NotificationTableEntry, ServicePtr< T >, Guid, MmCallHdl, SignedValue, UnsignedValue
  • operator>() : Ticks, WString, Vector< T >::Iterator, Time, String, PhoneNumber, DateTime, Date, DataItem, ResourceID, Pathname::ReverseIterator, Pathname::Iterator, SignedValue, UnsignedValue
  • operator>=() : Ticks, WString, Vector< T >::Iterator, Time, String, DateTime, Date, DataItem
  • operator>>() : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, OnDataRcvdMsg, SmsSettingsRecord, ObexVCardMsg, InputStream, Time, PhoneNumber, IpAddr, DateTime, Date, BitField< T >, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg
  • operator[]() : WString, Vector< T >, String, SimpleMap< TKey, TValue >, IndexTable< T >, FixedPtrArray< T >, ElementList< T >, ElementListBase, ByteBuffer, CArray< T >, TextIconPairArray, CiTestParamList, EquivPlmnLists, NeighbourCellList, AckNackParamList, COverIList, GsmBandList, UmtsCellList, BlerTrchInfoList, MessageIdentifierContainer
  • OplEntry() : OplEntry
  • OptGet() : SioSocketAdapter, SerialSocket, SerialIoAdapter
  • Optimize() : MessageIdentifierContainer, Cbs::Filter
  • OptimizeAutoClear() : Control
  • OptSet() : SioSocketAdapter, SerialSocket, SerialIoAdapter
  • Origin() : Stream, PdpContext, Message
  • OutgoingCallForwardedMsg() : OutgoingCallForwardedMsg
  • OutputStream() : OutputStream
  • OverallOverwriteCheck() : HeapManager
  • OverwriteCheck() : HeapVector::VarPage, HeapVector::BlockPage
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- z -

  • Zi8AddWordMsg() : Zi8AddWordMsg
  • Zi8AlphabetBox() : Zi8AlphabetBox
  • Zi8AlphabetBoxView() : Zi8AlphabetBoxView
  • Zi8BopomofoCompare() : Zi8Wrapper
  • Zi8EnteredUnknownWordMsg() : Zi8EnteredUnknownWordMsg
  • Zi8InputMapper() : Zi8InputMapper
  • Zi8NoWordFoundMsg() : Zi8NoWordFoundMsg
  • Zi8PinyinCompare() : Zi8Wrapper
  • Zi8PredictiveInputBox() : Zi8PredictiveInputBox
  • Zi8SelectionBox() : Zi8SelectionBox
  • Zi8SelectionBoxView() : Zi8SelectionBoxView
  • Zi8StrokeBox() : Zi8StrokeBox
  • Zi8StrokeBoxView() : Zi8StrokeBoxView
  • Zi8StrokeCompare() : Zi8Wrapper
  • Zi8Wrapper() : Zi8Wrapper
  • Zoom() : MediaRecorder, MediaPlayer
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- ~ -

  • ~_FunctionTracer() : _FunctionTracer< mask >
  • ~_NullFunctionTracer() : _NullFunctionTracer
  • ~AbortResArg() : AbortResArg
  • ~AbortResMsg() : AbortResMsg
  • ~AbstractActionMenuAccessor() : AbstractActionMenuAccessor
  • ~AbstractAppContext() : AbstractAppContext
  • ~AbstractButton() : AbstractButton
  • ~AbstractDelegationProvider() : AbstractDelegationProvider
  • ~AbstractDevice() : AbstractDevice
  • ~AbstractEditBox() : AbstractEditBox
  • ~AbstractEditBoxModel() : AbstractEditBoxModel
  • ~AbstractEditBoxView() : AbstractEditBoxView
  • ~AbstractEditor() : AbstractEditor
  • ~AbstractEditorItem() : AbstractEditorItem
  • ~AbstractExternalData() : AbstractExternalData
  • ~AbstractGrid() : AbstractGrid
  • ~AbstractIMelodyParser() : AbstractIMelodyParser
  • ~AbstractItemContainer() : AbstractItemContainer
  • ~AbstractItemGrid() : AbstractItemGrid
  • ~AbstractItemRenderer() : AbstractItemRenderer
  • ~AbstractLineEditor() : AbstractLineEditor
  • ~AbstractLineEditorView() : AbstractLineEditorView
  • ~AbstractListBox() : AbstractListBox
  • ~AbstractListBoxModel() : AbstractListBoxModel
  • ~AbstractListBoxView() : AbstractListBoxView
  • ~AbstractMenuAccessor() : AbstractMenuAccessor
  • ~AbstractMenuList() : AbstractMenuList
  • ~AbstractMultiLineEditor() : AbstractMultiLineEditor
  • ~AbstractMultiLineEditorView() : AbstractMultiLineEditorView
  • ~AbstractPredictiveInputBox() : AbstractPredictiveInputBox
  • ~AbstractRenderer() : AbstractRenderer
  • ~AbstractScheduler() : AbstractScheduler
  • ~AbstractSmsApp() : AbstractSmsApp
  • ~AbstractSmsComposeWin() : AbstractSmsComposeWin
  • ~AbstractSmsViewerWin() : AbstractSmsViewerWin
  • ~AbstractTextObject() : AbstractTextObject
  • ~AbstractTextRenderer() : AbstractTextRenderer
  • ~AbstractToggleAction() : AbstractToggleAction
  • ~AcacLanguage() : AcacLanguage
  • ~AccDispatcher() : AccDispatcher
  • ~AccessorAction() : AccessorAction
  • ~AccessorActionExtension() : AccessorActionExtension
  • ~AccessoryIndMsg() : AccessoryIndMsg
  • ~AccHandler() : AccHandler
  • ~Action() : Action
  • ~ActionExecutedMsg() : ActionExecutedMsg
  • ~ActionExtension() : ActionExtension
  • ~ActionMenuAccessor() : ActionMenuAccessor
  • ~ActivationStatus() : PdpContext::ActivationStatus
  • ~ActiveWaitDispatcher() : ActiveWaitDispatcher
  • ~AdvPbAction() : AdvPbAction
  • ~AdvPbApp() : AdvPbApp
  • ~AdvPbWin() : AdvPbWin
  • ~AesCrypt() : AesCrypt
  • ~AidingData() : AidingData
  • ~AlarmManager() : AlarmManager
  • ~AlarmMsg() : AlarmMsg
  • ~AlarmNotificationMsg() : AlarmNotificationMsg
  • ~Alert() : Alert
  • ~AlphaCoding() : AlphaCoding
  • ~AmplifierAudioDevice() : AmplifierAudioDevice
  • ~AmrSound() : AmrSound
  • ~AnimatedTextLine() : AnimatedTextLine
  • ~AnimatedTextLineView() : AnimatedTextLineView
  • ~Animation() : Animation
  • ~AnimationView() : AnimationView
  • ~AocChargingStatusMsg() : AocChargingStatusMsg
  • ~AocDispatcher() : AocDispatcher
  • ~AocHandler() : AocHandler
  • ~apoxi_emcpp_OBEXAdapter() : apoxi_emcpp_OBEXAdapter
  • ~ApoxiCommandAction() : ApoxiCommandAction
  • ~ApoxiThread() : ApoxiThread
  • ~AppActionExecutedMsg() : AppActionExecutedMsg
  • ~AppCloseMsg() : AppCloseMsg
  • ~AppContainerRoutingTableEntry() : AppContainerRoutingTableEntry
  • ~AppContext() : AppContext
  • ~AppendProvider() : AppendProvider
  • ~AppGetFocusMsg() : AppGetFocusMsg
  • ~Application() : Application
  • ~ApplicationAction() : ApplicationAction
  • ~AppLoseFocusMsg() : AppLoseFocusMsg
  • ~AppMutex() : AppMutex
  • ~AppOpenMsg() : AppOpenMsg
  • ~AppUpdateDisplayMsg() : AppUpdateDisplayMsg
  • ~ArabicTextRenderer() : ArabicTextRenderer
  • ~AragonMsg() : AragonMsg
  • ~AsyncUnitTestMsg() : AsyncUnitTestMsg
  • ~AtcDispatcher() : AtcDispatcher
  • ~AtcHandler() : AtcHandler
  • ~AtCommand() : AtCommand
  • ~AtGenericCmdType() : AtGenericCmdType
  • ~AtiAudioCapturerEncoder() : AtiAudioCapturerEncoder
  • ~AtiAudioDecoderRenderer() : AtiAudioDecoderRenderer
  • ~AtiMpeg4Decoder() : AtiMpeg4Decoder
  • ~AtiMpeg4Encoder() : AtiMpeg4Encoder
  • ~AtKeyParser() : AtKeyParser
  • ~AtlApplication() : AtlApplication
  • ~AtlApplicationPlugin() : AtlApplicationPlugin
  • ~AtlItemBox() : AtlItemBox
  • ~AtlItemGrid() : AtlItemGrid
  • ~AtlItemGridWindow() : AtlItemGridWindow
  • ~AtlItemListWindow() : AtlItemListWindow
  • ~AtlItemMenu() : AtlItemMenu
  • ~AtlItemMenuWindow() : AtlItemMenuWindow
  • ~AtlItemRenderer() : AtlItemRenderer
  • ~AtlLabelListWindow() : AtlLabelListWindow
  • ~AtlWindow() : AtlWindow
  • ~AtomItem() : AtomItem
  • ~AtResponse() : AtResponse
  • ~AtResponseIterator() : AtResponseIterator
  • ~AtResponseParameter() : AtResponseParameter
  • ~AttachStatus() : PdpContextManager::AttachStatus
  • ~Audio() : Audio
  • ~AudioAccessoryConnectedMsg() : AudioAccessoryConnectedMsg
  • ~AudioAccessoryStore() : AudioAccessoryStore
  • ~AudioActiveReference() : AudioActiveReference
  • ~AudioCodecCapabilities() : CodecDevice::AudioCodecCapabilities
  • ~AudioContext() : AudioContext
  • ~AudioDeviceBase() : AudioDeviceBase
  • ~AudioDeviceManager() : AudioDeviceManager
  • ~AudioDeviceStatusMsg() : AudioDeviceStatusMsg
  • ~AudioError() : AudioError
  • ~AudioErrorMsg() : AudioErrorMsg
  • ~AudioFastForwardStartedMsg() : AudioFastForwardStartedMsg
  • ~AudioFmRadioRdsAlternativeFrequenciesMsg() : AudioFmRadioRdsAlternativeFrequenciesMsg
  • ~AudioFmRadioRdsInfoMsg() : AudioFmRadioRdsInfoMsg
  • ~AudioFmRadioRdsRadioTextMsg() : AudioFmRadioRdsRadioTextMsg
  • ~AudioFmRadioRdsRawDataMsg() : AudioFmRadioRdsRawDataMsg
  • ~AudioFmRadioRdsStationNameMsg() : AudioFmRadioRdsStationNameMsg
  • ~AudioFmRadioRssiMsg() : AudioFmRadioRssiMsg
  • ~AudioFmRadioSeekMsg() : AudioFmRadioSeekMsg
  • ~AudioGatiServer() : AudioGatiServer
  • ~AudioGetPlayPositionMsg() : AudioGetPlayPositionMsg
  • ~AudioItem() : AudioItem
  • ~AudioMsg() : AudioMsg
  • ~AudioPathManager() : AudioPathManager
  • ~AudioPlayer() : AudioPlayer
  • ~AudioPlayerStore() : AudioPlayerStore
  • ~AudioPlayTimeMsg() : AudioPlayTimeMsg
  • ~AudioPreset() : AudioPreset
  • ~AudioPresetStore() : AudioPresetStore
  • ~AudioRadioDeviceNotificationMsg() : AudioRadioDeviceNotificationMsg
  • ~AudioRecordingStoppedMsg() : AudioRecordingStoppedMsg
  • ~AudioReference() : AudioReference
  • ~AudioRestartedMsg() : AudioRestartedMsg
  • ~AudioResumedMsg() : AudioResumedMsg
  • ~AudioRewindStartedMsg() : AudioRewindStartedMsg
  • ~AudioStartedMsg() : AudioStartedMsg
  • ~AudioStoppedMsg() : AudioStoppedMsg
  • ~AudioStreamingSyncMsg() : AudioStreamingSyncMsg
  • ~AudioSuspendedMsg() : AudioSuspendedMsg
  • ~AudioUserDefinedMsg() : AudioUserDefinedMsg
  • ~AudioUtility() : AudioUtility
  • ~AudioVoiceMemoOutOfSpaceMsg() : AudioVoiceMemoOutOfSpaceMsg
  • ~Authentication() : PdpContext::Authentication
  • ~AuthProvider() : AuthProvider
  • ~AuxProvider() : AuxProvider
  • ~BackToIdleFeature() : BackToIdleFeature
  • ~BandSelectionMsg() : BandSelectionMsg
  • ~BandStatusMsg() : BandStatusMsg
  • ~BarringInfoReceivedMsg() : BarringInfoReceivedMsg
  • ~BarringSsAction() : BarringSsAction
  • ~BaseDataHandler() : BaseDataHandler
  • ~BaseInformationElement() : BaseInformationElement
  • ~BasicPackConnector() : BasicPackConnector
  • ~BasicPbWin() : BasicPbWin
  • ~BasicSmsService() : BasicSmsService
  • ~BatteryLoadLevelMsg() : BatteryLoadLevelMsg
  • ~BinData() : BinData
  • ~BinDataDataSource() : BinDataDataSource
  • ~Bitmap() : Bitmap
  • ~BitmapDc() : BitmapDc
  • ~BlackAndWhiteTheme() : BlackAndWhiteTheme
  • ~BlobObject() : BlobObject
  • ~BlobPtr() : BlobPtr
  • ~BlueSkyCheckBoxListView() : BlueSkyCheckBoxListView
  • ~BlueSkyCheckBoxView() : BlueSkyCheckBoxView
  • ~BlueSkyChineseTheme() : BlueSkyChineseTheme
  • ~BlueSkyControlFrameView() : BlueSkyControlFrameView
  • ~BlueSkyPositionIndicatorView() : BlueSkyPositionIndicatorView
  • ~BlueSkyProgressBarView() : BlueSkyProgressBarView
  • ~BlueSkyPushButtonView() : BlueSkyPushButtonView
  • ~BlueSkyRadioButtonListView() : BlueSkyRadioButtonListView
  • ~BlueSkyRadioButtonView() : BlueSkyRadioButtonView
  • ~BlueSkySoftkeyBarView() : BlueSkySoftkeyBarView
  • ~BlueSkyTextListView() : BlueSkyTextListView
  • ~BlueSkyTheme() : BlueSkyTheme
  • ~BlueSkyWindowFrameView() : BlueSkyWindowFrameView
  • ~BmpImage() : BmpImage
  • ~BooleanCondition() : BooleanCondition
  • ~BootControl() : BootControl
  • ~BootDispatcher() : BootDispatcher
  • ~BootHandler() : BootHandler
  • ~BootState() : BootState
  • ~BoundedItem() : BoundedItem
  • ~BrowserSaveWin() : BrowserSaveWin
  • ~BrowserView() : BrowserView
  • ~BrowserViewContainer() : BrowserViewContainer
  • ~BtActiveDeviceWindow() : BtActiveDeviceWindow
  • ~BtAlertMessageWindow() : BtAlertMessageWindow
  • ~BtApplication() : BtApplication
  • ~BtApplicationDevicePairRequest() : BtApplicationDevicePairRequest
  • ~BtApplicationDeviceSearchRequest() : BtApplicationDeviceSearchRequest
  • ~BtApplicationDeviceTrustRequest() : BtApplicationDeviceTrustRequest
  • ~BtApplicationDeviceUnpairRequest() : BtApplicationDeviceUnpairRequest
  • ~BtApplicationDeviceUntrustRequest() : BtApplicationDeviceUntrustRequest
  • ~BtApplicationMessage() : BtApplicationMessage
  • ~BtApplicationQuerySupportedProfilesRequest() : BtApplicationQuerySupportedProfilesRequest
  • ~BtApplicationRespondAuthorizationRequest() : BtApplicationRespondAuthorizationRequest
  • ~BtApplicationSendPasskeyRequest() : BtApplicationSendPasskeyRequest
  • ~BtApplicationServiceVerifyRequest() : BtApplicationServiceVerifyRequest
  • ~BtApplicationSetRemoteDeviceNameRequest() : BtApplicationSetRemoteDeviceNameRequest
  • ~BtAudioAccessoryService() : BtAudioAccessoryService
  • ~BtAuthorizationRequiredMessage() : BtAuthorizationRequiredMessage
  • ~BtAuthorizationRequiredWindow() : BtAuthorizationRequiredWindow
  • ~BtAvrcpAlertMessageWindow() : BtAvrcpAlertMessageWindow
  • ~BtAvrcpConnectResponse() : BtAvrcpConnectResponse
  • ~BtAvrcpControllerApplicationWindow() : BtAvrcpControllerApplicationWindow
  • ~BtAvrcpControllerDeviceListItem() : BtAvrcpControllerDeviceListItem
  • ~BtAvrcpControllerDeviceListWindow() : BtAvrcpControllerDeviceListWindow
  • ~BtAvrcpDeRegisterRequest() : BtAvrcpDeRegisterRequest
  • ~BtAvrcpDeviceListWin() : BtAvrcpDeviceListWin
  • ~BtAvrcpNmaConnect() : BtAvrcpNmaConnect
  • ~BtAvrcpNmaDisconnect() : BtAvrcpNmaDisconnect
  • ~BtAvrcpNmaPanelPassThrough() : BtAvrcpNmaPanelPassThrough
  • ~BtAvrcpNmaRawFrame() : BtAvrcpNmaRawFrame
  • ~BtAvrcpNotificationMessage() : BtAvrcpNotificationMessage
  • ~BtAvrcpOperationRequestResponse() : BtAvrcpOperationRequestResponse
  • ~BtAvrcpOperationService() : BtAvrcpOperationService
  • ~BtAvrcpOperationServiceMessage() : BtAvrcpOperationServiceMessage
  • ~BtAvrcpPanelApplication() : BtAvrcpPanelApplication
  • ~BtAvrcpPanelPassThroughParams() : BtAvrcpPanelPassThroughParams
  • ~BtAvrcpPanelPassThroughRequest() : BtAvrcpPanelPassThroughRequest
  • ~BtAvrcpPanelServiceImpl() : BtAvrcpPanelServiceImpl
  • ~BtAvrcpProfileOperationService() : BtAvrcpProfileOperationService
  • ~BtAvrcpProfileRegistrationService() : BtAvrcpProfileRegistrationService
  • ~BtAvrcpRawFrameParams() : BtAvrcpRawFrameParams
  • ~BtAvrcpRawFrameRequest() : BtAvrcpRawFrameRequest
  • ~BtAvrcpRegisterParams() : BtAvrcpRegisterParams
  • ~BtAvrcpRegisterRequest() : BtAvrcpRegisterRequest
  • ~BtAvrcpRegistrationService() : BtAvrcpRegistrationService
  • ~BtAvrcpRequest() : BtAvrcpRequest
  • ~BtAvrcpRequestStateChangedMessage() : BtAvrcpRequestStateChangedMessage
  • ~BtAvrcpService() : BtAvrcpService
  • ~BtAvrcpSubunitInfoParams() : BtAvrcpSubunitInfoParams
  • ~BtAvrcpSubunitInfoRequest() : BtAvrcpSubunitInfoRequest
  • ~BtAvrcpUnitInfoParams() : BtAvrcpUnitInfoParams
  • ~BtAvrcpUnitInfoRequest() : BtAvrcpUnitInfoRequest
  • ~BtBipAbortIndArg() : BtBipAbortIndArg
  • ~BtBipAttachmentDesc() : BtBipAttachmentDesc
  • ~BtBipAttachmentFormat() : BtBipAttachmentFormat
  • ~BtBipClientService() : BtBipClientService
  • ~BtBipConnectIndArg() : BtBipConnectIndArg
  • ~BtBipDeleteImageIndArg() : BtBipDeleteImageIndArg
  • ~BtBipDisconnectIndArg() : BtBipDisconnectIndArg
  • ~BtBipGetImageIndArg() : BtBipGetImageIndArg
  • ~BtBipGetImagePropertiesIndArg() : BtBipGetImagePropertiesIndArg
  • ~BtBipGetImagesListIndArg() : BtBipGetImagesListIndArg
  • ~BtBipGetImagingCapabilitiesIndArg() : BtBipGetImagingCapabilitiesIndArg
  • ~BtBipGetLinkedAttachmentIndArg() : BtBipGetLinkedAttachmentIndArg
  • ~BtBipGetLinkedThumbnailIndArg() : BtBipGetLinkedThumbnailIndArg
  • ~BtBipImage() : BtBipImage
  • ~BtBipImageHdl() : BtBipImageHdl
  • ~BtBipImageHdlDesc() : BtBipImageHdlDesc
  • ~BtBipImageList() : BtBipImageList
  • ~BtBipImagingCapabilities() : BtBipImagingCapabilities
  • ~BtBipMsgArg() : BtBipMsgArg
  • ~BtBipOpFinishedArg() : BtBipOpFinishedArg
  • ~BtBipProgressMsg() : BtBipProgressMsg
  • ~BtBipPutImageCompleteArg() : BtBipPutImageCompleteArg
  • ~BtBipPutImageIndArg() : BtBipPutImageIndArg
  • ~BtBipPutLinkedAttachmentCompleteArg() : BtBipPutLinkedAttachmentCompleteArg
  • ~BtBipPutLinkedAttachmentIndArg() : BtBipPutLinkedAttachmentIndArg
  • ~BtBipPutLinkedThumbnailCompleteArg() : BtBipPutLinkedThumbnailCompleteArg
  • ~BtBipPutLinkedThumbnailIndArg() : BtBipPutLinkedThumbnailIndArg
  • ~BtBipServerNotificationMsgArg() : BtBipServerNotificationMsgArg
  • ~BtBipServerService() : BtBipServerService
  • ~BtBppClientService() : BtBppClientService
  • ~BtBppController() : BtBppController
  • ~BtBppReq() : BtBppReq
  • ~BtBppRequestStateChangedMessage() : BtBppRequestStateChangedMessage
  • ~BtBppServerService() : BtBppServerService
  • ~BtBppService() : BtBppService
  • ~BtBppSndAbortReqRequest() : BtBppSndAbortReqRequest
  • ~BtBppSndFilePushReqRequest() : BtBppSndFilePushReqRequest
  • ~BtBppSndGetRefObjRspRequest() : BtBppSndGetRefObjRspRequest
  • ~BtCancelableBroadcastRequest() : BtCancelableBroadcastRequest
  • ~BtCancelableMulticastRequest() : BtCancelableMulticastRequest
  • ~BtCancelableRequest() : BtCancelableRequest
  • ~BtCancelSearchMessage() : BtCancelSearchMessage
  • ~BtCancelVerifyMessage() : BtCancelVerifyMessage
  • ~BtCloseMessage() : BtCloseMessage
  • ~BtConnectabilityMessage() : BtConnectabilityMessage
  • ~BtConnection() : BtMultiConnectionController::BtConnection
  • ~BtConnectionBasedController() : BtConnectionBasedController
  • ~BtConnectionlessController() : BtConnectionlessController
  • ~BtConnectRequest() : BtConnectRequest
  • ~BtController() : BtController
  • ~BtDevice() : BtDevice
  • ~BtDeviceAddress() : BtDeviceAddress
  • ~BtDeviceAddressGenericObject() : BtDeviceAddressGenericObject
  • ~BtDeviceAndServiceClass() : BtDeviceAndServiceClass
  • ~BtDeviceDetailWindow() : BtDeviceDetailWindow
  • ~BtDeviceFilter() : BtDeviceFilter
  • ~BtDeviceList() : BtDeviceList
  • ~BtDeviceListItem() : BtDeviceListItem
  • ~BtDeviceListNode() : BtDeviceList::BtDeviceListNode
  • ~BtDeviceListProvider() : BtDeviceListProvider
  • ~BtDeviceListWindow() : BtDeviceListWindow
  • ~BtDevicePairMessage() : BtDevicePairMessage
  • ~BtDevicePairRequest() : BtDevicePairRequest
  • ~BtDeviceSearchMessage() : BtDeviceSearchMessage
  • ~BtDeviceSearchModeWindow() : BtDeviceSearchModeWindow
  • ~BtDeviceSearchRequest() : BtDeviceSearchRequest
  • ~BtDeviceTrustMessage() : BtDeviceTrustMessage
  • ~BtDeviceTrustRequest() : BtDeviceTrustRequest
  • ~BtDeviceUnpairMessage() : BtDeviceUnpairMessage
  • ~BtDeviceUnpairRequest() : BtDeviceUnpairRequest
  • ~BtDeviceUntrustMessage() : BtDeviceUntrustMessage
  • ~BtDeviceUntrustRequest() : BtDeviceUntrustRequest
  • ~BtDisconnectRequest() : BtDisconnectRequest
  • ~BtDiscoverabilityMessage() : BtDiscoverabilityMessage
  • ~BtDunApplicationMessage() : BtDunApplicationMessage
  • ~BtDunAppPlugin() : BtDunAppPlugin
  • ~BtDunConnectMessage() : BtDunConnectMessage
  • ~BtDunDisconnectMessage() : BtDunDisconnectMessage
  • ~BtDunProfileService() : BtDunProfileService
  • ~BtDunRequestStateChangedMessage() : BtDunRequestStateChangedMessage
  • ~BtDunService() : BtDunService
  • ~BtEvent() : BtEvent
  • ~BtFaxApplicationMessage() : BtFaxApplicationMessage
  • ~BtFaxAppPlugin() : BtFaxAppPlugin
  • ~BtFaxConnectMessage() : BtFaxConnectMessage
  • ~BtFaxDisconnectMessage() : BtFaxDisconnectMessage
  • ~BtFaxProfileService() : BtFaxProfileService
  • ~BtFaxRequestStateChangedMessage() : BtFaxRequestStateChangedMessage
  • ~BtFaxService() : BtFaxService
  • ~BtGapAndSdapApplicationMessage() : BtGapAndSdapApplicationMessage
  • ~BtGapAndSdapNotificationMessage() : BtGapAndSdapNotificationMessage
  • ~BtGapAndSdapRemoteRequestMessage() : BtGapAndSdapRemoteRequestMessage
  • ~BtGapAndSdapRequestMessage() : BtGapAndSdapRequestMessage
  • ~BtHfAppPlugin() : BtHfAppPlugin
  • ~BtHfAudioPathWindow() : BtHfAudioPathWindow
  • ~BtHfCmaAtChldOneCommandReceived() : BtHfCmaAtChldOneCommandReceived
  • ~BtHfCmaAudioAsynchronous() : BtHfCmaAudioAsynchronous
  • ~BtHfCmaCheckPendingAudioCallback() : BtHfCmaCheckPendingAudioCallback
  • ~BtHfCmaMOC() : BtHfCmaMOC
  • ~BtHfCmaMTC() : BtHfCmaMTC
  • ~BtHfCmaPhoneNumberRequired() : BtHfCmaPhoneNumberRequired
  • ~BtHfFeatureListWin() : BtHfFeatureListWin
  • ~BtHfInbandSettingWin() : BtHfInbandSettingWin
  • ~BtHfNmaAudioConnectionLost() : BtHfNmaAudioConnectionLost
  • ~BtHfNmaCallEvent() : BtHfNmaCallEvent
  • ~BtHfNmaConnect() : BtHfNmaConnect
  • ~BtHfNmaDisconnect() : BtHfNmaDisconnect
  • ~BtHfNmaLowPowerModeNotPossible() : BtHfNmaLowPowerModeNotPossible
  • ~BtHfNmaMicrophoneGain() : BtHfNmaMicrophoneGain
  • ~BtHfNmaSpeakerGain() : BtHfNmaSpeakerGain
  • ~BtHfNmaTransferAudioToAccessory() : BtHfNmaTransferAudioToAccessory
  • ~BtHfNmaTransferAudioToPhone() : BtHfNmaTransferAudioToPhone
  • ~BtHfNotificationMessage() : BtHfNotificationMessage
  • ~BtHfProfileService() : BtHfProfileService
  • ~BtHfProfileWindow() : BtHfProfileWindow
  • ~BtHfProvider() : BtHfProvider
  • ~BtHfRecord() : BtHfRecord
  • ~BtHfRequestStateChangedMessage() : BtHfRequestStateChangedMessage
  • ~BtHfService() : BtHfService
  • ~BtHfSupportedProfileMessage() : BtHfSupportedProfileMessage
  • ~BtHfVolumeSettingsWin() : BtHfVolumeSettingsWin
  • ~BtHsAppPlugin() : BtHsAppPlugin
  • ~BtHsCmaAudioAsynchronous() : BtHsCmaAudioAsynchronous
  • ~BtHsCmaAudioTransferOutOfCall() : BtHsCmaAudioTransferOutOfCall
  • ~BtHsCmaCheckPendingAudioCallback() : BtHsCmaCheckPendingAudioCallback
  • ~BtHsCmaEnterLowPowerMode() : BtHsCmaEnterLowPowerMode
  • ~BtHsCmaHangUp() : BtHsCmaHangUp
  • ~BtHsConnectionSettingWin() : BtHsConnectionSettingWin
  • ~BtHsInbandSettingWin() : BtHsInbandSettingWin
  • ~BtHsNmaAudioConnectionLost() : BtHsNmaAudioConnectionLost
  • ~BtHsNmaCallEvent() : BtHsNmaCallEvent
  • ~BtHsNmaConnect() : BtHsNmaConnect
  • ~BtHsNmaDisconnect() : BtHsNmaDisconnect
  • ~BtHsNmaLowPowerModeNotPossible() : BtHsNmaLowPowerModeNotPossible
  • ~BtHsNmaMicrophoneGain() : BtHsNmaMicrophoneGain
  • ~BtHsNmaSpeakerGain() : BtHsNmaSpeakerGain
  • ~BtHsNmaTransferAudioToAccessory() : BtHsNmaTransferAudioToAccessory
  • ~BtHsNmaTransferAudioToPhone() : BtHsNmaTransferAudioToPhone
  • ~BtHsNotificationMessage() : BtHsNotificationMessage
  • ~BtHsProfileService() : BtHsProfileService
  • ~BtHsRequestStateChangedMessage() : BtHsRequestStateChangedMessage
  • ~BtHsService() : BtHsService
  • ~BtHsSupportedProfileMessage() : BtHsSupportedProfileMessage
  • ~BtHsVolumeSettingsWin() : BtHsVolumeSettingsWin
  • ~BtIndicatorMsg() : BtIndicatorMsg
  • ~BtLocalNameMessage() : BtLocalNameMessage
  • ~BtLocalRequest() : BtLocalRequest
  • ~BtLocalSettings() : BtLocalSettings
  • ~BtLocalSettingsMessage() : BtLocalSettingsMessage
  • ~BtMultiConnectionController() : BtMultiConnectionController
  • ~BtObexAbortRequest() : BtObexAbortRequest
  • ~BtObexClientAbortEvent() : BtObexClientAbortEvent
  • ~BtObexClientConnectEvent() : BtObexClientConnectEvent
  • ~BtObexClientDisconnectEvent() : BtObexClientDisconnectEvent
  • ~BtObexClientEvent() : BtObexClientEvent
  • ~BtObexClientGetEvent() : BtObexClientGetEvent
  • ~BtObexClientNmaDataBufferIndication() : BtObexClientNmaDataBufferIndication
  • ~BtObexClientNmaDataInidication() : BtObexClientNmaDataInidication
  • ~BtObexClientNmaHeaderIndication() : BtObexClientNmaHeaderIndication
  • ~BtObexClientNmaHeaderSent() : BtObexClientNmaHeaderSent
  • ~BtObexClientNmaTransportDisconnect() : BtObexClientNmaTransportDisconnect
  • ~BtObexClientNotificationMessage() : BtObexClientNotificationMessage
  • ~BtObexClientObserverImpl() : BtObexClientObserverImpl
  • ~BtObexClientOperationEvent() : BtObexClientOperationEvent
  • ~BtObexClientOperationRequest() : BtObexClientOperationRequest
  • ~BtObexClientPutEvent() : BtObexClientPutEvent
  • ~BtObexClientRequestStateChangedMessage() : BtObexClientRequestStateChangedMessage
  • ~BtObexClientService() : BtObexClientService
  • ~BtObexClientServiceImpl() : BtObexClientServiceImpl
  • ~BtObexClientServiceObserver() : BtObexClientServiceObserver
  • ~BtObexClientSetPathEvent() : BtObexClientSetPathEvent
  • ~BtObexConnection() : BtObexController::BtObexConnection
  • ~BtObexConnectRequest() : BtObexConnectRequest
  • ~BtObexController() : BtObexController
  • ~BtObexDataBufferIndicationEvent() : BtObexDataBufferIndicationEvent
  • ~BtObexDataIndicationEvent() : BtObexDataIndicationEvent
  • ~BtObexDisconnectRequest() : BtObexDisconnectRequest
  • ~BtObexEvent() : BtObexEvent
  • ~BtObexGetRequest() : BtObexGetRequest
  • ~BtObexHeaderIndicationEvent() : BtObexHeaderIndicationEvent
  • ~BtObexHeaderSentEvent() : BtObexHeaderSentEvent
  • ~BtObexImpl() : BtObexImpl
  • ~BtObexPutRequest() : BtObexPutRequest
  • ~BtObexRegisterClientEvent() : BtObexRegisterClientEvent
  • ~BtObexRegisterClientRequest() : BtObexRegisterClientRequest
  • ~BtObexRegisterServerEvent() : BtObexRegisterServerEvent
  • ~BtObexRegisterServerRequest() : BtObexRegisterServerRequest
  • ~BtObexRequest() : BtObexRequest
  • ~BtObexSddbImpl() : BtObexSddbImpl
  • ~BtObexSddbServiceObserverImpl() : BtObexSddbServiceObserverImpl
  • ~BtObexServerAbortIndicationEvent() : BtObexServerAbortIndicationEvent
  • ~BtObexServerConnectIndicationEvent() : BtObexServerConnectIndicationEvent
  • ~BtObexServerDisconnectIndicationEvent() : BtObexServerDisconnectIndicationEvent
  • ~BtObexServerEvent() : BtObexServerEvent
  • ~BtObexServerGetIndicationEvent() : BtObexServerGetIndicationEvent
  • ~BtObexServerNmaAbort() : BtObexServerNmaAbort
  • ~BtObexServerNmaConnect() : BtObexServerNmaConnect
  • ~BtObexServerNmaDataBufferIndication() : BtObexServerNmaDataBufferIndication
  • ~BtObexServerNmaDataInidication() : BtObexServerNmaDataInidication
  • ~BtObexServerNmaDisconnect() : BtObexServerNmaDisconnect
  • ~BtObexServerNmaGet() : BtObexServerNmaGet
  • ~BtObexServerNmaHeaderIndication() : BtObexServerNmaHeaderIndication
  • ~BtObexServerNmaHeaderSent() : BtObexServerNmaHeaderSent
  • ~BtObexServerNmaPut() : BtObexServerNmaPut
  • ~BtObexServerNmaSetPath() : BtObexServerNmaSetPath
  • ~BtObexServerNmaTransportDisconnect() : BtObexServerNmaTransportDisconnect
  • ~BtObexServerNotificationMessage() : BtObexServerNotificationMessage
  • ~BtObexServerObserverImpl() : BtObexServerObserverImpl
  • ~BtObexServerPutIndicationEvent() : BtObexServerPutIndicationEvent
  • ~BtObexServerRequestStateChangedMessage() : BtObexServerRequestStateChangedMessage
  • ~BtObexServerService() : BtObexServerService
  • ~BtObexServerServiceImpl() : BtObexServerServiceImpl
  • ~BtObexServerServiceObserver() : BtObexServerServiceObserver
  • ~BtObexServerSetPathIndicationEvent() : BtObexServerSetPathIndicationEvent
  • ~BtObexService() : BtObexService
  • ~BtObexServiceObserver() : BtObexServiceObserver
  • ~BtObexSetPathRequest() : BtObexSetPathRequest
  • ~BtObexTransport() : BtObexTransport
  • ~BtObexTransportDisconnectEvent() : BtObexTransportDisconnectEvent
  • ~BtObexUnregisterClientRequest() : BtObexUnregisterClientRequest
  • ~BtObexUnregisterEvent() : BtObexUnregisterEvent
  • ~BtObexUnregisterServerRequest() : BtObexUnregisterServerRequest
  • ~BtObservableService() : BtObservableService
  • ~BtOpenMessage() : BtOpenMessage
  • ~BtOperationBase() : BtOperationBase
  • ~BtOperationSelectDevice() : BtOperationSelectDevice
  • ~BtOperationSelectDeviceAndPerformServiceVerify() : BtOperationSelectDeviceAndPerformServiceVerify
  • ~BtPairabilityMessage() : BtPairabilityMessage
  • ~BtPasskeyRequiredMessage() : BtPasskeyRequiredMessage
  • ~BtPasskeyRequiredWindow() : BtPasskeyRequiredWindow
  • ~BtPaSupportedProfileMessage() : BtPaSupportedProfileMessage
  • ~BtProfileActivationMessage() : BtProfileActivationMessage
  • ~BtQuerySupportedProfilesMessage() : BtQuerySupportedProfilesMessage
  • ~BtQuerySupportedProfilesRequest() : BtQuerySupportedProfilesRequest
  • ~BtRemoteDeviceMessage() : BtRemoteDeviceMessage
  • ~BtRemoteDeviceNameMessage() : BtRemoteDeviceNameMessage
  • ~BtRemoteDevicePairMessage() : BtRemoteDevicePairMessage
  • ~BtRequest() : BtRequest
  • ~BtRequestMessage() : BtRequestMessage
  • ~BtRequestOperationMessage() : BtRequestOperationMessage
  • ~BtRequestRespondRequest() : BtRequestRespondRequest
  • ~BtRequestRunningWindow() : BtRequestRunningWindow
  • ~BtRequestStateChangedMessage() : BtRequestStateChangedMessage
  • ~BtRespondAuthorizationMessage() : BtRespondAuthorizationMessage
  • ~BtRespondAuthorizationRequest() : BtRespondAuthorizationRequest
  • ~BtSddbDataElement() : BtSddbDataElement
  • ~BtSddbDataElementFactory() : BtSddbDataElementFactory
  • ~BtSddbDeAlternative() : BtSddbDeAlternative
  • ~BtSddbDeBaseCType() : BtSddbDeBaseCType
  • ~BtSddbDeBigSintBase() : BtSddbDeBigSintBase
  • ~BtSddbDeBigUintBase() : BtSddbDeBigUintBase
  • ~BtSddbDeBoolean() : BtSddbDeBoolean
  • ~BtSddbDeByteBlockType() : BtSddbDeByteBlockType
  • ~BtSddbDeContainer() : BtSddbDeContainer
  • ~BtSddbDeNil() : BtSddbDeNil
  • ~BtSddbDeOneByteDescriptionType() : BtSddbDeOneByteDescriptionType
  • ~BtSddbDeSequence() : BtSddbDeSequence
  • ~BtSddbDeSint128() : BtSddbDeSint128
  • ~BtSddbDeSint16() : BtSddbDeSint16
  • ~BtSddbDeSint32() : BtSddbDeSint32
  • ~BtSddbDeSint64() : BtSddbDeSint64
  • ~BtSddbDeSint8() : BtSddbDeSint8
  • ~BtSddbDeSintBase() : BtSddbDeSintBase
  • ~BtSddbDeString() : BtSddbDeString
  • ~BtSddbDeUint128() : BtSddbDeUint128
  • ~BtSddbDeUint16() : BtSddbDeUint16
  • ~BtSddbDeUint32() : BtSddbDeUint32
  • ~BtSddbDeUint64() : BtSddbDeUint64
  • ~BtSddbDeUint8() : BtSddbDeUint8
  • ~BtSddbDeUintBase() : BtSddbDeUintBase
  • ~BtSddbDeUrl() : BtSddbDeUrl
  • ~BtSddbDeUuid128() : BtSddbDeUuid128
  • ~BtSddbDeUuid16() : BtSddbDeUuid16
  • ~BtSddbDeUuid32() : BtSddbDeUuid32
  • ~BtSddbDeUuidBase() : BtSddbDeUuidBase
  • ~BtSddbDeVariableLengthType() : BtSddbDeVariableLengthType
  • ~BtSddbEvent() : BtSddbEvent
  • ~BtSddbRegisterServiceEvent() : BtSddbRegisterServiceEvent
  • ~BtSddbRequestStateChangedMessage() : BtSddbRequestStateChangedMessage
  • ~BtSddbService() : BtSddbService
  • ~BtSddbServiceAttribute() : BtSddbServiceAttribute
  • ~BtSddbServiceObserver() : BtSddbServiceObserver
  • ~BtSddbServiceRecord() : BtSddbServiceRecord
  • ~BtSddbUnregisterServiceEvent() : BtSddbUnregisterServiceEvent
  • ~BtSendPasskeyMessage() : BtSendPasskeyMessage
  • ~BtSendPasskeyRequest() : BtSendPasskeyRequest
  • ~BtService() : BtService
  • ~BtServiceMessage() : BtServiceMessage
  • ~BtServiceObserver() : BtServiceObserver
  • ~BtServiceRequest() : BtServiceRequest
  • ~BtServiceVerifyMessage() : BtServiceVerifyMessage
  • ~BtServiceVerifyRequest() : BtServiceVerifyRequest
  • ~BtServiceVerifyResult() : BtServiceVerifyResult
  • ~BtServiceVerifyResultMessage() : BtServiceVerifyResultMessage
  • ~BtSetRemoteDeviceNameMessage() : BtSetRemoteDeviceNameMessage
  • ~BtSetRemoteDeviceNameRequest() : BtSetRemoteDeviceNameRequest
  • ~BtSingleConnectionController() : BtSingleConnectionController
  • ~BtStateChangedMessage() : BtStateChangedMessage
  • ~BtSvrDataElement() : BtSvrDataElement
  • ~BtSvrServiceAttribute() : BtSvrServiceAttribute
  • ~BtSvrServiceRecord() : BtSvrServiceRecord
  • ~BtTransport() : BtTransport
  • ~BtTurnOnOffWindow() : BtTurnOnOffWindow
  • ~BtUncancelablePointToPointRequest() : BtUncancelablePointToPointRequest
  • ~BtUncancelableRequest() : BtUncancelableRequest
  • ~BubbleSortProvider() : BubbleSortProvider
  • ~BufferedData() : BufferedData
  • ~BufferedOutputStream() : BufferedOutputStream
  • ~ByteBuffer() : ByteBuffer
  • ~CachingSortProvider() : CachingSortProvider
  • ~CalculatorInputMapper() : CalculatorInputMapper
  • ~CalendarAddRecordWin() : CalendarAddRecordWin
  • ~CalendarApp() : CalendarApp
  • ~CalendarGotoDateWin() : CalendarGotoDateWin
  • ~CalendarGrid() : CalendarGrid
  • ~CalendarGridView() : CalendarGridView
  • ~CalendarListWin() : CalendarListWin
  • ~CalendarMonthSelector() : CalendarMonthSelector
  • ~CalendarMonthSelectorView() : CalendarMonthSelectorView
  • ~CalendarMonthWin() : CalendarMonthWin
  • ~CalendarProvider() : CalendarProvider
  • ~CalendarRecord() : CalendarRecord
  • ~CallAcceptMsg() : CallAcceptMsg
  • ~CallBarredMsg() : CallBarredMsg
  • ~CallBarringActivatedMsg() : CallBarringActivatedMsg
  • ~CallBarringDeactivatedMsg() : CallBarringDeactivatedMsg
  • ~CallBarringHandler() : CallBarringHandler
  • ~CallBarringPasswordChangedMsg() : CallBarringPasswordChangedMsg
  • ~CallBarringStatusMsg() : CallBarringStatusMsg
  • ~CallControlIndMsg() : CallControlIndMsg
  • ~CallControlInfoMsg() : CallControlInfoMsg
  • ~CallDeflectionErrIndicationMsg() : CallDeflectionErrIndicationMsg
  • ~CallDeflectionHandler() : CallDeflectionHandler
  • ~CallDeflectionIndMsg() : CallDeflectionIndMsg
  • ~CallDeflectionRejectedMsg() : CallDeflectionRejectedMsg
  • ~CallDisconnectedMsg() : CallDisconnectedMsg
  • ~CallDisconnectingMsg() : CallDisconnectingMsg
  • ~CalledPartyAlertingMsg() : CalledPartyAlertingMsg
  • ~CallEventMsg() : CallEventMsg
  • ~CallForwardingActivatedMsg() : CallForwardingActivatedMsg
  • ~CallForwardingActiveMsg() : CallForwardingActiveMsg
  • ~CallForwardingDeactivatedMsg() : CallForwardingDeactivatedMsg
  • ~CallForwardingErasedMsg() : CallForwardingErasedMsg
  • ~CallForwardingRegisteredMsg() : CallForwardingRegisteredMsg
  • ~CallForwardingStatusMsg() : CallForwardingStatusMsg
  • ~CallHandler() : CallHandler
  • ~CallHdl() : CallHdl
  • ~CallHdlBase() : CallHdlBase
  • ~CallHeldMsg() : CallHeldMsg
  • ~CallHoldRejectedMsg() : CallHoldRejectedMsg
  • ~CallInfoMsg() : CallInfoMsg
  • ~CallIsWaitingMsg() : CallIsWaitingMsg
  • ~CallNotifyMsg() : CallNotifyMsg
  • ~CallOnHoldMsg() : CallOnHoldMsg
  • ~CallReleaseMsg() : CallReleaseMsg
  • ~CallRetrievedMsg() : CallRetrievedMsg
  • ~CallSetupProgressMsg() : CallSetupProgressMsg
  • ~CallSsAction() : CallSsAction
  • ~CallWaitingActivatedMsg() : CallWaitingActivatedMsg
  • ~CallWaitingDeactivatedMsg() : CallWaitingDeactivatedMsg
  • ~CallWaitingHandler() : CallWaitingHandler
  • ~CallWaitingStatusMsg() : CallWaitingStatusMsg
  • ~Camera() : Camera
  • ~CameraApp() : CameraApp
  • ~CameraMsgStartViewfinding() : CameraMsgStartViewfinding
  • ~CameraMsgStopViewfinding() : CameraMsgStopViewfinding
  • ~CameraOptionSettingsWin() : CameraOptionSettingsWin
  • ~CameraSettings() : CameraSettings
  • ~CameraSettingsWin() : CameraSettingsWin
  • ~CamWin32() : CamWin32
  • ~CancelAction() : CancelAction
  • ~Caret() : Caret
  • ~CbmiProvider() : CbmiProvider
  • ~CbmiRangeProvider() : CbmiRangeProvider
  • ~Cbs() : Cbs
  • ~CbsDispatcher() : CbsDispatcher
  • ~CbsFilterList() : CbsFilterList
  • ~CbsHandler() : CbsHandler
  • ~CbsLimitMsg() : CbsLimitMsg
  • ~CbsNewDataMsg() : CbsNewDataMsg
  • ~CbsNewDataRejArg() : CbsNewDataRejArg
  • ~CbsStartDispatcher() : CbsStartDispatcher
  • ~CbsStopDispatcher() : CbsStopDispatcher
  • ~CcbsRecallMsg() : CcbsRecallMsg
  • ~CcbsResultMsg() : CcbsResultMsg
  • ~CcbsStatusMsg() : CcbsStatusMsg
  • ~CellInfoMsg() : CellInfoMsg
  • ~CenteredTextIndicator() : CenteredTextIndicator
  • ~CfuStatusMsg() : CfuStatusMsg
  • ~Charger() : Charger
  • ~ChargerInfoMsg() : ChargerInfoMsg
  • ~CharItem() : CharItem
  • ~CheckBox() : CheckBox
  • ~CheckBoxAction() : CheckBoxAction
  • ~CheckBoxControl() : CheckBoxControl
  • ~CheckBoxControlView() : CheckBoxControlView
  • ~CheckBoxList() : CheckBoxList
  • ~CheckBoxListView() : CheckBoxListView
  • ~CheckBoxView() : CheckBoxView
  • ~ChildBinData() : ChildBinData
  • ~ChineseQuickSortProvider() : ChineseQuickSortProvider
  • ~ChineseT9InputMapper() : ChineseT9InputMapper
  • ~ChineseT9Wrapper() : ChineseT9Wrapper
  • ~ChvChangedMsg() : ChvChangedMsg
  • ~ChvProvider() : ChvProvider
  • ~CleanupDrawingObtainer() : Image::CleanupDrawingObtainer
  • ~ClientNetAdapter() : ClientNetAdapter
  • ~ClipStatusMsg() : ClipStatusMsg
  • ~ClirAction() : ClirAction
  • ~ClirNotSurpressedMsg() : ClirNotSurpressedMsg
  • ~ClirStatusMsg() : ClirStatusMsg
  • ~CloseAllMsg() : CloseAllMsg
  • ~CloseDataConnMsg() : CloseDataConnMsg
  • ~CloseWindowAction() : CloseWindowAction
  • ~CloseWindowMsg() : CloseWindowMsg
  • ~CmiProvider() : CmiProvider
  • ~CnapInfoReceivedMsg() : CnapInfoReceivedMsg
  • ~CnapStatusMsg() : CnapStatusMsg
  • ~CodecDevice() : CodecDevice
  • ~CodecManager() : CodecManager
  • ~ColpStatusMsg() : ColpStatusMsg
  • ~ColrStatusMsg() : ColrStatusMsg
  • ~Component() : Component
  • ~ComponentIterator() : Control::ComponentIterator
  • ~CompoundItem() : CompoundItem
  • ~CompoundItemIterator() : CompoundItemIterator
  • ~CompoundSmsItem() : CompoundSmsItem
  • ~CompoundTpduItem() : CompoundTpduItem
  • ~Condition() : Condition
  • ~ConfirmAction() : ConfirmAction
  • ~ConnectionStatusMsg() : ConnectionStatusMsg
  • ~Context() : SwitchedRleCompression::Context
  • ~ContextDescription() : ContextDescription
  • ~ContextExecuteMsg() : ContextExecuteMsg
  • ~ContextFeature() : ContextFeature
  • ~ContextFeatureHandle() : ContextFeatureHandle
  • ~ContextFeatureItem() : ContextFeatureItem
  • ~ContextFeatureTriggerMsg() : ContextFeatureTriggerMsg
  • ~ContextManager() : ContextManager
  • ~ContextMenu() : ContextMenu
  • ~ContextMenuClosedMsg() : ContextMenuClosedMsg
  • ~ContextMsg() : ContextMsg
  • ~ContextTableNode() : ContextTableNode
  • ~ContextWakeupMsg() : ContextWakeupMsg
  • ~ContinueSocketTestMsg() : ContinueSocketTestMsg
  • ~Control() : Control
  • ~ControlFrameView() : ControlFrameView
  • ~ControlMsg() : ControlMsg
  • ~CopyHandler() : CopyHandler
  • ~CountryProvider() : CountryProvider
  • ~CphsAuxProvider() : CphsAuxProvider
  • ~CphsServPflProvider() : CphsServPflProvider
  • ~CrssHandler() : CrssHandler
  • ~CsdDataConn() : CsdDataConn
  • ~CsdDataConnAccessor() : CsdDataConnAccessor
  • ~CsdDataConnProfile() : CsdDataConnProfile
  • ~CsdDataConnProvider() : CsdDataConnProvider
  • ~CTControlFrameView() : CTControlFrameView
  • ~CtmInfoIndMsg() : CtmInfoIndMsg
  • ~CTPanelView() : CTPanelView
  • ~CTPositionIndicatorView() : CTPositionIndicatorView
  • ~CTProgressBarView() : CTProgressBarView
  • ~CTPushButtonView() : CTPushButtonView
  • ~CTResourcePack() : CTResourcePack
  • ~CTWindowFrameView() : CTWindowFrameView
  • ~CugCallMsg() : CugCallMsg
  • ~CurrentCallMeterMsg() : CurrentCallMeterMsg
  • ~CurrentChargeDataMsg() : CurrentChargeDataMsg
  • ~CustomizableTheme() : CustomizableTheme
  • ~CustomRingerAudioReference() : CustomRingerAudioReference
  • ~CustomSmafPhraseAudioReference() : CustomSmafPhraseAudioReference
  • ~CustomToneAudioReference() : CustomToneAudioReference
  • ~DataCallContext() : DataCallContext
  • ~DataCallControl() : DataCallControl
  • ~DataCoding() : DataCoding
  • ~DataConn() : DataConn
  • ~DataConnAccessor() : DataConnAccessor
  • ~DataConnApp() : DataConnApp
  • ~DataConnInfoMsg() : DataConnInfoMsg
  • ~DataConnLbModel() : DataConnLbModel
  • ~DataConnOptionWin() : DataConnOptionWin
  • ~DataConnProfile() : DataConnProfile
  • ~DataConnProfileInfoMsg() : DataConnProfileInfoMsg
  • ~DataConnProvider() : DataConnProvider
  • ~DataConnTypeWin() : DataConnTypeWin
  • ~DataConnWin() : DataConnWin
  • ~DataControl() : DataControl
  • ~DataControlBootMsg() : DataControlBootMsg
  • ~DataControlBootProgressMsg() : DataControlBootProgressMsg
  • ~DataControlEndBootMsg() : DataControlEndBootMsg
  • ~DataControlModificationMsg() : DataControlModificationMsg
  • ~DataControlPhonebookStateMsg() : DataControlPhonebookStateMsg
  • ~DataControlStartBootMsg() : DataControlStartBootMsg
  • ~DataHandler() : DataHandler
  • ~DataItem() : DataItem
  • ~DataPack() : DataPack
  • ~DataSink() : DataSink
  • ~DataSource() : DataSource
  • ~DataSourceBinData() : DataSourceBinData
  • ~DateCompoundItem() : DateCompoundItem
  • ~DateEditBox() : DateEditBox
  • ~DateEditBoxView() : DateEditBoxView
  • ~DateEditor() : DateEditor
  • ~DateEditorDocument() : DateEditorDocument
  • ~DateEditorView() : DateEditorView
  • ~DateTimeInputMapper() : DateTimeInputMapper
  • ~DBItemChangedMsg() : DBItemChangedMsg
  • ~DcsLanguageFilterRule() : DcsLanguageFilterRule
  • ~DebugOutputStream() : DebugOutputStream
  • ~DecodingThreadlet() : DecodingThreadlet
  • ~DefaultCaret() : DefaultCaret
  • ~DefaultCheckBoxListView() : DefaultCheckBoxListView
  • ~DefaultCheckBoxView() : DefaultCheckBoxView
  • ~DefaultChineseTheme() : DefaultChineseTheme
  • ~DefaultControlFrameView() : DefaultControlFrameView
  • ~DefaultDisplay() : DefaultDisplay
  • ~DefaultItemRenderer() : DefaultItemRenderer
  • ~DefaultPanelView() : DefaultPanelView
  • ~DefaultPositionIndicatorView() : DefaultPositionIndicatorView
  • ~DefaultProgressBarView() : DefaultProgressBarView
  • ~DefaultPushButtonView() : DefaultPushButtonView
  • ~DefaultRadioButtonListView() : DefaultRadioButtonListView
  • ~DefaultRadioButtonView() : DefaultRadioButtonView
  • ~DefaultSoftkeyBarView() : DefaultSoftkeyBarView
  • ~DefaultTabButtonView() : DefaultTabButtonView
  • ~DefaultTabControlView() : DefaultTabControlView
  • ~DefaultTextListView() : DefaultTextListView
  • ~DefaultTheme() : DefaultTheme
  • ~DefaultWindowFrameView() : DefaultWindowFrameView
  • ~DelegationProviderListener() : DelegationProviderListener
  • ~DeleteComponentMsg() : DeleteComponentMsg
  • ~DeletedNode() : DeletedNode
  • ~DeletedNodeList() : DeletedNodeList
  • ~Desktop() : Desktop
  • ~DeviceContext() : DeviceContext
  • ~DhChannelChangeStatusResMsg() : DhChannelChangeStatusResMsg
  • ~DhChannelCloseReqMsg() : DhChannelCloseReqMsg
  • ~DhChannelDataAvailableResMsg() : DhChannelDataAvailableResMsg
  • ~DhChannelOpenReqMsg() : DhChannelOpenReqMsg
  • ~DhChannelReceiveReqMsg() : DhChannelReceiveReqMsg
  • ~DhChannelSendReqMsg() : DhChannelSendReqMsg
  • ~DiagnosticIndMsg() : DiagnosticIndMsg
  • ~DialogWindow() : DialogWindow
  • ~DirectoryIterator() : DirectoryIterator
  • ~DirtyFileHandler() : DirtyFileHandler
  • ~DisabledFeatureTriggeredMsg() : DisabledFeatureTriggeredMsg
  • ~Dispatcher() : Dispatcher
  • ~Display() : Display
  • ~DisplayDc() : DisplayDc
  • ~DisplayInfoMsg() : DisplayInfoMsg
  • ~DistinctProvider() : DistinctProvider
  • ~DistinctRule() : DistinctRule
  • ~DnsClient() : DnsClient
  • ~DnsClientTest() : DnsClientTest
  • ~DrawableObject() : DrawableObject
  • ~DrawableObjectView() : DrawableObjectView
  • ~DrmConstraint() : DrmConstraint
  • ~DrmDcfParser() : DrmDcfParser
  • ~DrmInfo() : DrmInfo
  • ~DrmMessage() : DrmMessage
  • ~DrmPermission() : DrmPermission
  • ~DrmRightsObject() : DrmRightsObject
  • ~DrmROStoreSingleton() : DrmROStoreSingleton
  • ~DrmSecurity() : DrmSecurity
  • ~DrmWapPushMsg() : DrmWapPushMsg
  • ~DtmfBufferCleanedMsg() : DtmfBufferCleanedMsg
  • ~DtmfRejectMsg() : DtmfRejectMsg
  • ~DtmfStartCnfMsg() : DtmfStartCnfMsg
  • ~DtmfStopCnfMsg() : DtmfStopCnfMsg
  • ~DualFilterProvider() : DualFilterProvider
  • ~DwdDevice() : DwdDevice
  • ~DwdPlayer() : DwdPlayer
  • ~DynamicBitVector() : DynamicBitVector
  • ~DynamicMenuPool() : DynamicMenuPool
  • ~EccProvider() : EccProvider
  • ~EctActiveMsg() : EctActiveMsg
  • ~EctAlertingMsg() : EctAlertingMsg
  • ~EditBox() : EditBox
  • ~EditBoxView() : EditBoxView
  • ~EditorDocument() : EditorDocument
  • ~EditorDocumentObtainer() : EditorDocumentObtainer
  • ~EditorItemNode() : EditorItemNode
  • ~ElementList() : ElementList< T >
  • ~ElementListBase() : ElementListBase
  • ~emcpp_apoxi_OBEXAdapter() : emcpp_apoxi_OBEXAdapter
  • ~EmlppAction() : EmlppAction
  • ~EmlppHandler() : EmlppHandler
  • ~EmlppRegisteredMsg() : EmlppRegisteredMsg
  • ~EmlppStatusMsg() : EmlppStatusMsg
  • ~EmsApp() : EmsApp
  • ~EmsComposeWin() : EmsComposeWin
  • ~EmsCreator() : EmsCreator
  • ~EmsEditor() : EmsEditor
  • ~EmsEditorListener() : EmsEditorListener
  • ~EmServThreadMsg() : EmServThreadMsg
  • ~EmsIeParser() : EmsIeParser
  • ~EmsImage() : EmsImage
  • ~EmsInsertPrompt() : EmsInsertPrompt
  • ~EmsInsertPromptListBoxModel() : EmsInsertPromptListBoxModel
  • ~EmsViewerWin() : EmsViewerWin
  • ~EmzAacDecoder() : EmzAacDecoder
  • ~EmzH264Decoder() : EmzH264Decoder
  • ~EmzMp3Decoder() : EmzMp3Decoder
  • ~EmzMpeg4Decoder() : EmzMpeg4Decoder
  • ~EmzMpeg4Encoder() : EmzMpeg4Encoder
  • ~EmzSbcEncoder() : EmzSbcEncoder
  • ~EncodingThreadlet() : EncodingThreadlet
  • ~EngineeringModeControlResponseMsg() : EngineeringModeControlResponseMsg
  • ~EngineeringReportMsg() : EngineeringReportMsg
  • ~EnglishT9InputMapper() : EnglishT9InputMapper
  • ~EngModeAction() : EngModeAction
  • ~EqualsRule() : EqualsRule
  • ~EventData() : EventData
  • ~ExecutionContext() : ExecutionContext
  • ~ExternalCommunicationHandler() : ExternalCommunicationHandler
  • ~ExternalPdpContextInfoMsg() : ExternalPdpContextInfoMsg
  • ~ExternalTimeoutMsg() : ExternalTimeoutMsg
  • ~ExtPsdContextListener_SerialTerminal() : ExtPsdContextListener_SerialTerminal
  • ~ExtPsdContextListener_SerialTerminalListener() : ExtPsdContextListener_SerialTerminalListener
  • ~ExtPsdContextListener_SioGlueSignalListener() : ExtPsdContextListener_SioGlueSignalListener
  • ~ExtPsdContextListenerImpl_SerialTerminalListener() : ExtPsdContextListenerImpl_SerialTerminalListener
  • ~FatDirectoryIteratorImp() : FatDirectoryIteratorImp
  • ~FatFile() : FatFile
  • ~FatFileImp() : FatFileImp
  • ~FatFsUsbMassStorageReleaseMsg() : FatFsUsbMassStorageReleaseMsg
  • ~FatFsUsbMassStorageRequestMsg() : FatFsUsbMassStorageRequestMsg
  • ~Feature() : Feature
  • ~FeatureBroker() : FeatureBroker
  • ~FeatureChangedMsg() : FeatureChangedMsg
  • ~FeatureHandle() : FeatureHandle
  • ~FeatureItem() : FeatureItem
  • ~FeatureItemContainer() : FeatureItemContainer
  • ~FeatureTriggerMsg() : FeatureTriggerMsg
  • ~FfsFile() : FfsFile
  • ~FfsMenu() : FfsMenu
  • ~FfsTestDispWin() : FfsTestDispWin
  • ~FfsTestMenu() : FfsTestMenu
  • ~FfsTestResultsMenu() : FfsTestResultsMenu
  • ~FfsTestResultsSubMenu() : FfsTestResultsSubMenu
  • ~FfsTests() : FfsTests
  • ~FfsTestSubMenu() : FfsTestSubMenu
  • ~FfsTestThread() : FfsTestThread
  • ~File() : File
  • ~FileBinData() : FileBinData
  • ~FileChunkOperationProgressMsg() : FileChunkOperationProgressMsg
  • ~FileDataSink() : FileDataSink
  • ~FileDataSource() : FileDataSource
  • ~FileFilter() : FileFilter
  • ~FileInputStream() : FileInputStream
  • ~FileNameListBoxModel() : FileNameListBoxModel
  • ~FileNameView() : FileNameView
  • ~FileOutputStream() : FileOutputStream
  • ~FilePack() : FilePack
  • ~FileVisitor() : FileVisitor
  • ~Filter() : Cbs::Filter
  • ~FilterProvider() : FilterProvider
  • ~FilterRule() : FilterRule
  • ~Find2Provider() : Find2Provider
  • ~FindProvider() : FindProvider
  • ~FixedPtrArray() : FixedPtrArray< T >
  • ~FlagCaretaker() : FlagCaretaker
  • ~FlashDirectoryIteratorImp() : FlashDirectoryIteratorImp
  • ~FlashFileImp() : FlashFileImp
  • ~FlashStorageDeviceImp() : FlashStorageDeviceImp
  • ~FlipMsg() : FlipMsg
  • ~FlowLayout() : FlowLayout
  • ~FlsFile() : FlsFile
  • ~FmRadioApplication() : FmRadioApplication
  • ~FmRadioEditWin() : FmRadioEditWin
  • ~FmRadioSelectStrongerFreq() : FmRadioSelectStrongerFreq
  • ~FmRadioSettingsProvider() : FmRadioSettingsProvider
  • ~FmRadioStationsProvider() : FmRadioStationsProvider
  • ~FmRadioWindow() : FmRadioWindow
  • ~FocusNextControlMsg() : FocusNextControlMsg
  • ~FocusPreviousControlMsg() : FocusPreviousControlMsg
  • ~FoggyPanelView() : FoggyPanelView
  • ~FoggyPositionIndicatorView() : FoggyPositionIndicatorView
  • ~FoggyPushButtonView() : FoggyPushButtonView
  • ~FoggySoftkeyBarView() : FoggySoftkeyBarView
  • ~FoggyTheme() : FoggyTheme
  • ~FoggyWindowFrameView() : FoggyWindowFrameView
  • ~Font() : Font
  • ~FontEntry() : FontEntry
  • ~FontPack() : FontPack
  • ~ForwardedCallIncomingMsg() : ForwardedCallIncomingMsg
  • ~ForwardingInfoReceivedMsg() : ForwardingInfoReceivedMsg
  • ~ForwardingSsAction() : ForwardingSsAction
  • ~Fota() : Fota
  • ~Fraction() : Fraction
  • ~FromStackMsg() : FromStackMsg
  • ~FtpAuthProvider() : FtpAuthProvider
  • ~FtpClient() : FtpClient
  • ~FtpConnectMessage() : FtpConnectMessage
  • ~FtpDataServerSocket() : FtpDataServerSocket
  • ~FtpDataSocket() : FtpDataSocket
  • ~FtpDisconnectMessage() : FtpDisconnectMessage
  • ~FtpErrorMessage() : FtpErrorMessage
  • ~FtpInTransfer() : FtpInTransfer
  • ~FtpOutTransfer() : FtpOutTransfer
  • ~FtpRequest() : FtpRequest
  • ~FtpRequestMessage() : FtpRequestMessage
  • ~FtpServer() : FtpServer
  • ~FtpServerConfig() : FtpServerConfig
  • ~FtpServerSocket() : FtpServerSocket
  • ~FtpServiceMessage() : FtpServiceMessage
  • ~FtpSocket() : FtpSocket
  • ~FtpTransfer() : FtpTransfer
  • ~FtpTransferMessage() : FtpTransferMessage
  • ~GatiManager() : GatiManager
  • ~GeneralCompoundItem() : GeneralCompoundItem
  • ~GenericAudioDevice() : GenericAudioDevice
  • ~GenericFeatureData() : GenericFeatureData
  • ~GenericObject() : GenericObject
  • ~GenericWorkerTask() : GenericWorkerTask
  • ~GetFocusMsg() : GetFocusMsg
  • ~GetPasswordMsg() : GetPasswordMsg
  • ~GifImage() : GifImage
  • ~GlassPane() : GlassPane
  • ~GltpAidDataRequests() : GltpAidDataRequests
  • ~GltpAidingDataWin() : GltpAidingDataWin
  • ~GltpAidingRequest() : GltpAidingRequest
  • ~GltpAssistanceData() : GltpAssistanceData
  • ~GltpConnApp() : GltpConnApp
  • ~GltpConnStatusMsg() : GltpConnStatusMsg
  • ~GltpHelloRequest() : GltpHelloRequest
  • ~GltpMsmtRequest() : GltpMsmtRequest
  • ~GltpPositionRequest() : GltpPositionRequest
  • ~GltpProviderImpl() : GltpProviderImpl
  • ~GltpRequest() : GltpRequest
  • ~GltpSignalMapTableNode() : GltpSignalMapTableNode
  • ~GprsAttachStatusMsg() : GprsAttachStatusMsg
  • ~GprsStatusMsg() : GprsStatusMsg
  • ~GreaterRule() : GreaterRule
  • ~Grid() : Grid
  • ~GridLayout() : GridLayout
  • ~GridModel() : GridModel
  • ~GridView() : GridView
  • ~GroupProvider() : GroupProvider
  • ~GsmBandStateMsg() : GsmBandStateMsg
  • ~HandlerListEntry() : HandlerListEntry
  • ~HashTable() : HashTable
  • ~HeapArrayObject() : HeapArrayObject< T >
  • ~HeapDataSink() : HeapDataSink
  • ~HeapDataSource() : HeapDataSource
  • ~HeapObject() : HeapObject< T >
  • ~HindiTextRenderer() : HindiTextRenderer
  • ~HlrDataCorruptedMsg() : HlrDataCorruptedMsg
  • ~HlrSsDataCorruptMsg() : HlrSsDataCorruptMsg
  • ~HomezoneMsg() : HomezoneMsg
  • ~HostDebugTimeStamp() : HostDebugTimeStamp
  • ~HostIniFile() : HostIniFile
  • ~HttpApplication() : HttpApplication
  • ~HttpApplicationSupplier() : HttpApplicationSupplier
  • ~HttpAuthProvider() : HttpAuthProvider
  • ~HttpClient() : HttpClient
  • ~HttpConnectMessage() : HttpConnectMessage
  • ~HttpDisconnectMessage() : HttpDisconnectMessage
  • ~HttpErrorMessage() : HttpErrorMessage
  • ~HttpHandler() : HttpHandler
  • ~HttpRequest() : HttpRequest
  • ~HttpRequestMessage() : HttpRequestMessage
  • ~HttpResponse() : HttpResponse
  • ~HttpServer() : HttpServer
  • ~HttpServerConfig() : HttpServerConfig
  • ~HttpServerSocket() : HttpServerSocket
  • ~HttpServiceMessage() : HttpServiceMessage
  • ~HttpSocket() : HttpSocket
  • ~HttpWapMgr() : HttpWapMgr
  • ~HttpWapMgrBase() : HttpWapMgrBase
  • ~HttpWapMgrPlugin() : HttpWapMgrPlugin
  • ~IconIndicator() : IconIndicator
  • ~IconSet() : IconSet
  • ~IconTextIndicator() : IconTextIndicator
  • ~IconValueIndicator() : IconValueIndicator
  • ~Image() : Image
  • ~ImageBox() : ImageBox
  • ~ImageBoxView() : ImageBoxView
  • ~ImageBrowserApp() : ImageBrowserApp
  • ~ImageBrowserDeleteImageMsg() : ImageBrowserDeleteImageMsg
  • ~ImageBrowserDetailWin() : ImageBrowserDetailWin
  • ~ImageBrowserRenameImageMsg() : ImageBrowserRenameImageMsg
  • ~ImageBrowserServiceMsg() : ImageBrowserServiceMsg
  • ~ImageBrowserTestWin() : ImageBrowserTestWin
  • ~ImageBrowserWin() : ImageBrowserWin
  • ~ImageDecoder() : ImageDecoder
  • ~ImageDecodingProgressMsg() : ImageDecodingProgressMsg
  • ~ImageDrawingInterruptedMsg() : ImageDrawingInterruptedMsg
  • ~ImageEncoder() : ImageEncoder
  • ~ImageEncodingProgressMsg() : ImageEncodingProgressMsg
  • ~ImageFileFilter() : ImageFileFilter
  • ~ImageFilter() : ImageFilter
  • ~ImageIncrementalPdcUpdater() : ImageIncrementalPdcUpdater
  • ~ImageItem() : ImageItem
  • ~ImageListBoxModel() : ImageListBoxModel
  • ~ImageMetaData() : ImageMetaData
  • ~ImageMetaDataRecord() : ImageMetaDataRecord
  • ~ImageObtainer() : ImageObtainer
  • ~ImageRef() : ImageRef
  • ~ImageRefContainer() : ImageRefContainer
  • ~ImageRefGenContainer() : ImageRefGenContainer
  • ~ImageView() : ImageView
  • ~ImageViewListBoxModel() : ImageViewListBoxModel
  • ~ImeiShowAction() : ImeiShowAction
  • ~IMelody() : IMelody
  • ~ImgObtObj() : ImgObtObj
  • ~IncomingCallForwardedMsg() : IncomingCallForwardedMsg
  • ~IncrementalPdcUpdater() : IncrementalPdcUpdater
  • ~IndexTable() : IndexTable< T >
  • ~Indicator() : Indicator
  • ~IndicatorBar() : IndicatorBar
  • ~IndicatorBarPaneObject() : IndicatorBarPaneObject
  • ~IndicatorBarUpdateMsg() : IndicatorBarUpdateMsg
  • ~IndicatorBarView() : IndicatorBarView
  • ~IndicatorDescription() : IndicatorDescription
  • ~IndicatorItem() : IndicatorItem
  • ~IndicatorLocation() : IndicatorLocation
  • ~IndicatorPaneObject() : IndicatorPaneObject
  • ~InetSocket() : InetSocket
  • ~InfoDialog() : InfoDialog
  • ~InformationElement() : InformationElement
  • ~InputAction() : InputAction
  • ~InputAnalyzer() : InputAnalyzer
  • ~InputCharMsg() : InputCharMsg
  • ~InputContext() : InputContext
  • ~InputMapper() : InputMapper
  • ~InputMapperFactory() : InputMapperFactory
  • ~InputParser() : InputParser
  • ~InputStream() : InputStream
  • ~InterrogationResultMsg() : InterrogationResultMsg
  • ~InvalidateMsg() : InvalidateMsg
  • ~IpAddrCompoundItem() : IpAddrCompoundItem
  • ~IpAddrEditor() : IpAddrEditor
  • ~IpAddrEditorDocument() : IpAddrEditorDocument
  • ~IpAddrInputMapper() : IpAddrInputMapper
  • ~IpAddrPrompt() : IpAddrPrompt
  • ~IrdaApp() : IrdaApp
  • ~IrdaObexTransport() : IrdaObexTransport
  • ~IrdaTransport() : IrdaTransport
  • ~IrdaWin() : IrdaWin
  • ~IrSocketAddr() : IrSocketAddr
  • ~IsrDataMarshaller() : IsrDataMarshaller
  • ~Item() : Item
  • ~ItemBox() : ItemBox
  • ~ItemBoxView() : ItemBoxView
  • ~ItemContainer() : ItemContainer
  • ~ItemGrid() : ItemGrid
  • ~ItemLabel() : ItemLabel
  • ~ItemLabelView() : ItemLabelView
  • ~ItemMenu() : ItemMenu
  • ~ItemObj() : ItemObj
  • ~ItemPropertiesChangedMsg() : ItemPropertiesChangedMsg
  • ~ItemRendererProperties() : ItemRendererProperties
  • ~ItemRendererPropertiesChangedMsg() : ItemRendererPropertiesChangedMsg
  • ~ItemTree() : ItemTree
  • ~Iterator() : DeviceManager::Iterator
  • ~JapaneseTextRenderer() : JapaneseTextRenderer
  • ~JapaneseTranscoder() : JapaneseTranscoder
  • ~JoinProvider() : JoinProvider
  • ~JoinProviderListener() : JoinProviderListener
  • ~JoinRule() : JoinRule
  • ~JpegEncoder() : JpegEncoder
  • ~JpegEncodingThreadlet() : JpegEncodingThreadlet
  • ~JpegImage() : JpegImage
  • ~JumpToRowMsg() : JumpToRowMsg
  • ~KeyAutoRepeatMsg() : KeyAutoRepeatMsg
  • ~Keyboard() : Keyboard
  • ~KeyDownMsg() : KeyDownMsg
  • ~KeyManager() : KeyManager
  • ~KeyMapping() : KeyMapping
  • ~KeySequence() : KeySequence
  • ~KeyToneAudioDevice() : KeyToneAudioDevice
  • ~KeyUpMsg() : KeyUpMsg
  • ~L2CapSocketAddr() : L2CapSocketAddr
  • ~LanguageChangedMsg() : LanguageChangedMsg
  • ~LanguageProvider() : LanguageProvider
  • ~LanguageResetAction() : LanguageResetAction
  • ~LcsAppRegisterForMtlrMsg() : LcsAppRegisterForMtlrMsg
  • ~LcsAppResWinMsg() : LcsAppResWinMsg
  • ~LcsAppTransferLocMsg() : LcsAppTransferLocMsg
  • ~LcsAppUtils() : LcsAppUtils
  • ~LcsCommonSignalMapTableNode() : LcsCommonSignalMapTableNode
  • ~LcsMainApp() : LcsMainApp
  • ~LcsMainMenuWin() : LcsMainMenuWin
  • ~LcsMolrResultArg() : LcsMolrResultArg
  • ~LcsOptionsMenuWin() : LcsOptionsMenuWin
  • ~LcsProvider() : LcsProvider
  • ~LcsProviderImpl() : LcsProviderImpl
  • ~LcsProviderImplBase() : LcsProviderImplBase
  • ~LcsRepeatTimer() : LcsRepeatTimer
  • ~LcsReqProcessor() : LcsReqProcessor
  • ~LcsSettingsApp() : LcsSettingsApp
  • ~LcsSettingsUtils() : LcsSettingsUtils
  • ~LcsSignalMapTableNode() : LcsSignalMapTableNode
  • ~LcsSocket() : LcsSocket
  • ~LcsTimer() : LcsTimer
  • ~LcsUtils() : LcsUtils
  • ~LcsWapIntf() : LcsWapIntf
  • ~LcsWString() : LcsWString
  • ~Led() : Led
  • ~LedNotificationMsg() : LedNotificationMsg
  • ~LessRule() : LessRule
  • ~LexAnalyzer() : LexAnalyzer
  • ~LineEditor() : LineEditor
  • ~LinkableBase() : LinkableBase
  • ~ListPropertyDescriptor() : ListPropertyDescriptor
  • ~LocationErrMsg() : LocationErrMsg
  • ~LocationNotifInvokeArg() : LocationNotifInvokeArg
  • ~LocationNotifInvokeMsg() : LocationNotifInvokeMsg
  • ~LocationResMsg() : LocationResMsg
  • ~LocationResultWin() : LocationResultWin
  • ~LocationVerifWin() : LocationVerifWin
  • ~LockedKeyDownMsg() : LockedKeyDownMsg
  • ~LockedKeyMsg() : LockedKeyMsg
  • ~LockProvider() : LockProvider
  • ~LockTable() : LockTable
  • ~LockTableList() : LockTableList
  • ~LocResController() : LocResController
  • ~LongKeyPressMsg() : LongKeyPressMsg
  • ~LookupAlphaIdExtension() : LookupAlphaIdExtension
  • ~LoseFocusMsg() : LoseFocusMsg
  • ~LsaIdentityMsg() : LsaIdentityMsg
  • ~MainHandler() : MainHandler
  • ~MainHandlerAccess() : MainHandlerAccess
  • ~MainProvider() : MainProvider
  • ~MapiAudioReference() : MapiAudioReference
  • ~MappingPolicy() : MappingPolicy
  • ~MbiProvider() : MbiProvider
  • ~MCServiceInterfaceMsg() : MCServiceInterfaceMsg
  • ~MdhGors() : MdhGors
  • ~MeasurementData() : MeasurementData
  • ~MeasurementDataArg() : MeasurementDataArg
  • ~Media() : Media
  • ~MediaBox() : MediaBox
  • ~MediaBoxView() : MediaBoxView
  • ~MediaBrowserUtils() : MediaBrowserUtils
  • ~MediaFilter() : MediaFilter
  • ~MediaInfo() : MediaInfo
  • ~MediaManagerMsg() : MediaManagerMsg
  • ~MediaObtainer() : MediaObtainer
  • ~MediaPathnameVisitor() : MediaPathnameVisitor
  • ~MediaPlayer() : MediaPlayer
  • ~MediaRecorder() : MediaRecorder
  • ~MediaRef() : MediaRef
  • ~MediaRefContainer() : MediaRefContainer
  • ~MediaVisitor() : MediaVisitor
  • ~Melody() : Melody
  • ~MemMap() : MemMap
  • ~MemPool() : MemPool
  • ~Menu() : Menu
  • ~MenuAccessor() : MenuAccessor
  • ~MenuDesc() : MenuDesc
  • ~MenuDescObj() : MenuDescObj
  • ~MenuIdObj() : MenuIdObj
  • ~MenuList() : MenuList
  • ~MenuListView() : MenuListView
  • ~MenuPool() : MenuPool
  • ~MenuProperties() : MenuProperties
  • ~MenuTableNode() : MenuTableNode
  • ~MenuView() : MenuView
  • ~MenuWindow() : MenuWindow
  • ~MergeProvider() : MergeProvider
  • ~Message() : Message
  • ~MessageBox() : MessageBox
  • ~MessageHook() : MessageHook
  • ~MessageIdentifierContainer() : MessageIdentifierContainer
  • ~MessageMapDispatcher() : MessageMapDispatcher
  • ~MessageReferrer() : MessageReferrer
  • ~MetaData() : MetaData, Image::MetaData
  • ~MetaDataRecord() : MetaDataRecord
  • ~MexeDescriptor() : MexeDescriptor
  • ~MidiSound() : MidiSound
  • ~MimeTypeFilter() : MimeTypeFilter
  • ~MinuteTickMsg() : MinuteTickMsg
  • ~MmAocChargingStatusMsg() : MmAocChargingStatusMsg
  • ~MmCallAcceptMsg() : MmCallAcceptMsg
  • ~MmCallDisconnectingMsg() : MmCallDisconnectingMsg
  • ~MmCallDispatcher() : MmCallDispatcher
  • ~MmCallHandler() : MmCallHandler
  • ~MmCallHdl() : MmCallHdl
  • ~MmCallInfo() : MmCallInfo
  • ~MmCallInfoMsg() : MmCallInfoMsg
  • ~MmCallNotifyMsg() : MmCallNotifyMsg
  • ~MmCallReleaseMsg() : MmCallReleaseMsg
  • ~MmCallSerialTerminalListener() : MmCallSerialTerminalListener
  • ~MmCallSetupProgressMsg() : MmCallSetupProgressMsg
  • ~MmCallStatusMsg() : MmCallStatusMsg
  • ~MmCurrentCallMeterMsg() : MmCurrentCallMeterMsg
  • ~MmCurrentChargeDataMsg() : MmCurrentChargeDataMsg
  • ~MmiSimClient() : MmiSimClient
  • ~MmMocSetupAcceptMsg() : MmMocSetupAcceptMsg
  • ~MobileOriginatedUssdHandler() : MobileOriginatedUssdHandler
  • ~MoCallAction() : MoCallAction
  • ~MocSetupAcceptMsg() : MocSetupAcceptMsg
  • ~MocSetupRejectIndMsg() : MocSetupRejectIndMsg
  • ~Model() : Model
  • ~MolrInfo() : MolrInfo
  • ~MolrRepeatInfo() : MolrRepeatInfo
  • ~Mp3AudioDevice() : Mp3AudioDevice
  • ~MP3AudioPlayer() : MP3AudioPlayer
  • ~MptyCallHdl() : MptyCallHdl
  • ~MptyCallReleaseMsg() : MptyCallReleaseMsg
  • ~MptyHoldRejectedMsg() : MptyHoldRejectedMsg
  • ~MptyOnHoldMsg() : MptyOnHoldMsg
  • ~MtcArrivedMsg() : MtcArrivedMsg
  • ~MtcReadyMsg() : MtcReadyMsg
  • ~MtlrInfo() : MtlrInfo
  • ~MultiLineEditor() : MultiLineEditor
  • ~MultiMediaEditor() : MultiMediaEditor
  • ~MultiMediaEditorDocument() : MultiMediaEditorDocument
  • ~MultipartParser() : MultipartParser
  • ~MultiPartyCallInvokedMsg() : MultiPartyCallInvokedMsg
  • ~MultiSlotDispatcher() : MultiSlotDispatcher
  • ~MultiSlotHandler() : MultiSlotHandler
  • ~MultiTapCaret() : MultiTapCaret
  • ~MultiTapInputMapper() : MultiTapInputMapper
  • ~Mutex() : Mutex
  • ~MutexObtainer() : MutexObtainer
  • ~NamePatternFileFilter() : NamePatternFileFilter
  • ~NamePatternStorageDeviceFilter() : NamePatternStorageDeviceFilter
  • ~NativeImage() : NativeImage
  • ~NavigationGuidance() : Control::NavigationGuidance
  • ~NetAdapterHandler() : NetAdapterHandler
  • ~NetworkDispatcher() : NetworkDispatcher
  • ~NetworkHandler() : NetworkHandler
  • ~NetworkInformationMsg() : NetworkInformationMsg
  • ~NetworkSsErrorMsg() : NetworkSsErrorMsg
  • ~NetworkSsRejectedMsg() : NetworkSsRejectedMsg
  • ~NextSocketTestMsg() : NextSocketTestMsg
  • ~NiSharedPtr() : NiSharedPtr< X >
  • ~NoMessage() : NoMessage
  • ~NonCloneable() : NonCloneable
  • ~NonCopyable() : NonCopyable
  • ~NonsharedBinDataDataSource() : NonsharedBinDataDataSource
  • ~NoStackMsgArg() : NoStackMsgArg
  • ~NotEqualsRule() : NotEqualsRule
  • ~NotificationTable() : NotificationTable
  • ~NotificationTableEntry() : NotificationTableEntry
  • ~NumberIdentificationAction() : NumberIdentificationAction
  • ~NumberPrompt() : NumberPrompt
  • ~NumericInputMapper() : NumericInputMapper
  • ~NwDiscStartIndMsg() : NwDiscStartIndMsg
  • ~ObexAbstractPort() : ObexAbstractPort
  • ~ObexAddrMsg() : ObexAddrMsg
  • ~ObexApp() : ObexApp
  • ~ObexAppMsg() : ObexAppMsg
  • ~ObexBuffer() : ObexBuffer
  • ~ObexClient() : ObexClient
  • ~ObexClientDispatcher() : ObexClientDispatcher
  • ~ObexDataServer() : ObexDataServer
  • ~ObexDispatcher() : ObexDispatcher
  • ~ObexEventHandler() : ObexEventHandler
  • ~ObexFtpDataServer() : ObexFtpDataServer
  • ~ObexFtpServer() : ObexFtpServer
  • ~ObexHeaderList() : ObexHeaderList
  • ~ObexMsg() : ObexMsg
  • ~ObexObject() : ObexObject
  • ~ObexOppBinDataPushClient() : ObexOppBinDataPushClient
  • ~ObexOppClient() : ObexOppClient
  • ~ObexOppClientOperation() : ObexOppClientOperation
  • ~ObexOppDataSinkPushServer() : ObexOppDataSinkPushServer
  • ~ObexServer() : ObexServer
  • ~ObexServerDispatcher() : ObexServerDispatcher
  • ~ObexServerInfo() : ObexServerInfo
  • ~ObexServerVisitor() : ObexServerVisitor
  • ~ObexTransportMsg() : ObexTransportMsg
  • ~ObexTransportWin() : ObexTransportWin
  • ~ObexTriggerMsg() : ObexTriggerMsg
  • ~ObexVCardMsg() : ObexVCardMsg
  • ~ObjectObtainer() : ObjectObtainer
  • ~ObjectTreeService() : ObjectTreeService
  • ~ObservableObject() : ObservableObject
  • ~Observer() : Observer
  • ~ObtainableObject() : ObtainableObject
  • ~OmControlIndArg() : OmControlIndArg
  • ~OmMultiSlotIndMsg() : OmMultiSlotIndMsg
  • ~OnDataRcvdMsg() : OnDataRcvdMsg
  • ~OpenContextMenuAction() : OpenContextMenuAction
  • ~OpenPbWinMsg() : OpenPbWinMsg
  • ~OpenWindowAction() : OpenWindowAction
  • ~OutgoingCallForwardedMsg() : OutgoingCallForwardedMsg
  • ~OutputStream() : OutputStream
  • ~PacketFilter() : PdpContext::PacketFilter
  • ~PaintDc() : PaintDc
  • ~Panel() : Panel
  • ~PanelView() : PanelView
  • ~PaneObject() : PaneObject
  • ~ParagraphCompoundItem() : ParagraphCompoundItem
  • ~ParagraphMarker() : ParagraphMarker
  • ~PasswordChangeSsAction() : PasswordChangeSsAction
  • ~PasswordEditor() : PasswordEditor
  • ~PasswordInquiryMsg() : PasswordInquiryMsg
  • ~PasswordReceivedMsg() : PasswordReceivedMsg
  • ~PasswordRejectedMsg() : PasswordRejectedMsg
  • ~Path() : Path
  • ~Pathname() : Pathname
  • ~PathProfile() : PathProfile
  • ~PbAbstractWin() : PbAbstractWin
  • ~PbAction() : PbAction
  • ~PbAdvDataHandler() : PbAdvDataHandler
  • ~PbAdvDetailAction() : PbAdvDetailAction
  • ~PbAdvDetails() : PbAdvDetails
  • ~PbAlphaTagRequestMsg() : PbAlphaTagRequestMsg
  • ~PbBaseProvider() : PbBaseProvider
  • ~PbBaseWin() : PbBaseWin
  • ~PbCopyHandler() : PbCopyHandler
  • ~PbDataHandler() : PbDataHandler
  • ~PbDetailAction() : PbDetailAction
  • ~PbDetailEditBox() : PbDetailEditBox
  • ~PbDetailListBox() : PbDetailListBox
  • ~PbDetailProvider() : PbDetailProvider
  • ~PbDetails() : PbDetails
  • ~PbEntryRequestMsg() : PbEntryRequestMsg
  • ~PbEntryShowAction() : PbEntryShowAction
  • ~PbFfsNameHandler() : PbFfsNameHandler
  • ~PbFfsNumberHandler() : PbFfsNumberHandler
  • ~PbLazySynchronizer() : PbLazySynchronizer
  • ~PbManualSynchronizer() : PbManualSynchronizer
  • ~PbMergeProvider() : PbMergeProvider
  • ~PbNameEditBox() : PbNameEditBox
  • ~PbNameFilterProvider() : PbNameFilterProvider
  • ~PbNameHandler() : PbNameHandler
  • ~PbNameNumberProvider() : PbNameNumberProvider
  • ~PbNameProvider() : PbNameProvider
  • ~PbNumberFilterProvider() : PbNumberFilterProvider
  • ~PbNumberHandler() : PbNumberHandler
  • ~PbNumberProvider() : PbNumberProvider
  • ~PbNvRamNameHandler() : PbNvRamNameHandler
  • ~PbNvRamNumberHandler() : PbNvRamNumberHandler
  • ~PbPhoneNumberPrompt() : PbPhoneNumberPrompt
  • ~PbProvColListBoxModel() : PbProvColListBoxModel
  • ~PbProviderListener() : PbProviderListener
  • ~PbProvListBox() : PbProvListBox
  • ~PbProvListBoxModel() : PbProvListBoxModel
  • ~PbRecordHandler() : PbRecordHandler
  • ~PbRecordProvider() : PbRecordProvider
  • ~PbSecuredAction() : PbSecuredAction
  • ~PbSelectGroup() : PbSelectGroup
  • ~PbSelectNoType() : PbSelectNoType
  • ~PbSelectNumberWin() : PbSelectNumberWin
  • ~PbSimProvider() : PbSimProvider
  • ~PbSizeRequestMsg() : PbSizeRequestMsg
  • ~PbSortedProvider() : PbSortedProvider
  • ~PbSynchronizer() : PbSynchronizer
  • ~PbToggleAction() : PbToggleAction
  • ~PdpContextActivationStatusMsg() : PdpContextActivationStatusMsg
  • ~PdpContextControl() : PdpContextControl
  • ~PdpContextManagerControl() : PdpContextManagerControl
  • ~PenDownMsg() : PenDownMsg
  • ~PenUpMsg() : PenUpMsg
  • ~PhonebookApp() : PhonebookApp
  • ~PhonebookRenumberedMsg() : PhonebookRenumberedMsg
  • ~PhonebookWin() : PhonebookWin
  • ~PhoneNumber() : PhoneNumber
  • ~PhoneNumberInputMapper() : PhoneNumberInputMapper
  • ~PhoneNumberJoinRule() : PhoneNumberJoinRule
  • ~PhoneNumberMatchRule() : PhoneNumberMatchRule
  • ~PhoneNumberMergeProvider() : PhoneNumberMergeProvider
  • ~PinAction() : PinAction
  • ~PlmnDispatcher() : PlmnDispatcher
  • ~PlmnHandler() : PlmnHandler
  • ~PlmnListEntry() : PlmnListEntry
  • ~PlmnProvider() : PlmnProvider
  • ~PlmnRatDispatcher() : PlmnRatDispatcher
  • ~PlmnScanDispatcher() : PlmnScanDispatcher
  • ~PlmnScanFinishedMsg() : PlmnScanFinishedMsg
  • ~PngDecoder() : PngDecoder
  • ~PngEncoder() : PngEncoder
  • ~PngEncodingThreadlet() : PngEncodingThreadlet
  • ~PngImage() : PngImage
  • ~PortHeaderInformation() : PortHeaderInformation
  • ~PositionIndicator() : PositionIndicator
  • ~PositionIndicatorView() : PositionIndicatorView
  • ~PowerDispatcher() : PowerDispatcher
  • ~PowerDownDispatcher() : PowerDownDispatcher
  • ~PowerHandler() : PowerHandler
  • ~PowerModeIndMsg() : PowerModeIndMsg
  • ~PowerOffMsg() : PowerOffMsg
  • ~PowerOnMsg() : PowerOnMsg
  • ~PowerWakeupMsg() : PowerWakeupMsg
  • ~PppDataConn() : PppDataConn
  • ~PredefinedEmsImage() : PredefinedEmsImage
  • ~PredefinedEmsSound() : PredefinedEmsSound
  • ~PredInputMapper() : PredInputMapper
  • ~PrefExtLangProvider() : PrefExtLangProvider
  • ~PrefLangProvider() : PrefLangProvider
  • ~PrefPlmnProvider() : PrefPlmnProvider
  • ~PreparedSound() : PreparedSound
  • ~PresetAudioReference() : PresetAudioReference
  • ~ProcessMolrMsg() : ProcessMolrMsg
  • ~ProcessNode() : ProcessNode
  • ~ProgressBar() : ProgressBar
  • ~ProgressBarView() : ProgressBarView
  • ~Properties() : CodecDevice::Properties
  • ~Property() : Property
  • ~PropertyDescriptor() : PropertyDescriptor
  • ~PropertyEditor() : PropertyEditor
  • ~PropertyEditorFactory() : PropertyEditorFactory
  • ~PropertyItem() : PropertyItem
  • ~PropertyTriggerMsg() : PropertyTriggerMsg
  • ~Protector() : Protector
  • ~ProvColListBoxWin() : ProvColListBoxWin
  • ~ProvDetailListBoxWin() : ProvDetailListBoxWin
  • ~Provider() : Provider
  • ~ProviderChangedMsg() : ProviderChangedMsg
  • ~ProviderListBox() : ProviderListBox
  • ~ProviderListBoxModel() : ProviderListBoxModel
  • ~ProviderListBoxView() : ProviderListBoxView
  • ~ProviderListener() : ProviderListener
  • ~ProviderProxyContainer() : ProviderProxyContainer
  • ~ProviderProxyItem() : ProviderProxyItem
  • ~ProviderPtr() : ProviderPtr
  • ~ProviderUpdateMsg() : ProviderUpdateMsg
  • ~ProvListBoxWin() : ProvListBoxWin
  • ~PsdDataConn() : PsdDataConn
  • ~PsdDataConnAccessor() : PsdDataConnAccessor
  • ~PsdDataConnProfile() : PsdDataConnProfile
  • ~PsdDataConnProvider() : PsdDataConnProvider
  • ~PushButton() : PushButton
  • ~PushButtonView() : PushButtonView
  • ~QualityOfService() : PdpContext::QualityOfService
  • ~Queue() : EmzUtils::Queue< T >
  • ~QuickSortProvider() : QuickSortProvider
  • ~RadioAudioDevice() : RadioAudioDevice
  • ~RadioButtonAction() : RadioButtonAction
  • ~RadioButtonControl() : RadioButtonControl
  • ~RadioButtonControlView() : RadioButtonControlView
  • ~RadioButtonGroup() : RadioButtonGroup
  • ~RadioButtonList() : RadioButtonList
  • ~RadioButtonListView() : RadioButtonListView
  • ~RadioButtonView() : RadioButtonView
  • ~RamData() : RamData
  • ~RamDataSink() : RamDataSink
  • ~RamDataSource() : RamDataSource
  • ~RamDirectoryIteratorImp() : RamDirectoryIteratorImp
  • ~RamFile() : RamFile
  • ~RamFileImp() : RamFileImp
  • ~RamFileNode() : RamFileNode
  • ~RamFileObj() : RamFileObj
  • ~RamFileSystem() : RamFileSystem
  • ~RamStorageDeviceImp() : RamStorageDeviceImp
  • ~RamStorageMapper() : RamStorageMapper
  • ~RangeMappingPolicy() : RangeMappingPolicy
  • ~RangeRule() : RangeRule
  • ~RatChangeModeChangedMsg() : RatChangeModeChangedMsg
  • ~RatStateMsg() : RatStateMsg
  • ~RealTimeClock() : RealTimeClock
  • ~RecordHandler() : RecordHandler
  • ~RecordSettings() : RecordSettings
  • ~RedialSetupMsg() : RedialSetupMsg
  • ~RedialStartedMsg() : RedialStartedMsg
  • ~RedialStatusMsg() : RedialStatusMsg
  • ~RedialStoppedMsg() : RedialStoppedMsg
  • ~RedialSuccessMsg() : RedialSuccessMsg
  • ~RedrawDisplayMsg() : RedrawDisplayMsg
  • ~ReferableObject() : ReferableObject
  • ~RefreshComponentMsg() : RefreshComponentMsg
  • ~RegApp() : RegApp
  • ~RegAppFirstWin() : RegAppFirstWin
  • ~RegAppWin() : RegAppWin
  • ~RegBlobObject() : RegBlobObject
  • ~RegCbNotifyMsg() : RegCbNotifyMsg
  • ~RegDeletionBufferEntry() : RegDeletionBufferEntry
  • ~RegEncoderDecoder() : RegEncoderDecoder
  • ~RegistrationAllowedMsg() : RegistrationAllowedMsg
  • ~RegistrationChangeMsg() : RegistrationChangeMsg
  • ~RegistrationSuccessMsg() : RegistrationSuccessMsg
  • ~RegistryInterface() : RegistryInterface
  • ~RegIterator() : RegIterator
  • ~RegNodeBuffer() : RegNodeBuffer
  • ~RegNotifyMsg() : RegNotifyMsg
  • ~RegTcpSocket() : RegTcpSocket
  • ~RemotePartyActionMsg() : RemotePartyActionMsg
  • ~RenameFileDialog() : RenameFileDialog
  • ~ResourceID() : ResourceID
  • ~ResultWinBase() : ResultWinBase
  • ~RfcommSocketAddr() : RfcommSocketAddr
  • ~RfsMediaAvailableStatusMsg() : RfsMediaAvailableStatusMsg
  • ~RfsObexFtpServer() : RfsObexFtpServer
  • ~RfsStorageDeviceRegistrationStatusMsg() : RfsStorageDeviceRegistrationStatusMsg
  • ~RichTextCompoundItem() : RichTextCompoundItem
  • ~RingerAudioDevice() : RingerAudioDevice
  • ~RomData() : RomData
  • ~RomFont() : RomFont
  • ~RootDirectoryIteratorImp() : RootDirectoryIteratorImp
  • ~RootFileImp() : RootFileImp
  • ~RootStorageDeviceImp() : RootStorageDeviceImp
  • ~RootStorageDeviceIterator() : RootStorageDeviceIterator
  • ~RtcAlarmReachedMsg() : RtcAlarmReachedMsg
  • ~RtcDateChangedMsg() : RtcDateChangedMsg
  • ~RtcInfoMsg() : RtcInfoMsg
  • ~RtcTimeChangedMsg() : RtcTimeChangedMsg
  • ~RtStreamingBuffer() : RtStreamingBuffer
  • ~RtStreamingConn() : RtStreamingConn
  • ~RtStreamingEndPoint() : RtStreamingEndPoint
  • ~SaLocationErrArg() : SaLocationErrArg
  • ~SaMolrResultArg() : SaMolrResultArg
  • ~SaProviderImpl() : SaProviderImpl
  • ~SaSignalMapTableNode() : SaSignalMapTableNode
  • ~SatteliteGraphWin() : SatteliteGraphWin
  • ~SatteliteInfoWin() : SatteliteInfoWin
  • ~SaveEntryInPhonebookMsg() : SaveEntryInPhonebookMsg
  • ~SaveNoAction() : SaveNoAction
  • ~SavingProgressWin() : SavingProgressWin
  • ~Scheduler() : Scheduler
  • ~ScicosMpeg4VideoDecoder() : ScicosMpeg4VideoDecoder
  • ~ScicosMpeg4VideoEncoder() : ScicosMpeg4VideoEncoder
  • ~SearchBox() : SearchBox
  • ~SelectionBox() : SelectionBox
  • ~SelectionBoxView() : SelectionBoxView
  • ~SelectionChangedMsg() : SelectionChangedMsg
  • ~SelfLocationDialog() : SelfLocationDialog
  • ~Semaphore() : Semaphore
  • ~SemObtainer() : SemObtainer
  • ~SendRequestMsg() : SendRequestMsg
  • ~SendSmsMsg() : SendSmsMsg
  • ~SerDataConnAccessor() : SerDataConnAccessor
  • ~SerDataConnProvider() : SerDataConnProvider
  • ~SerialClientSocket() : SerialClientSocket
  • ~SerialIoAdapter() : SerialIoAdapter
  • ~SerialIoSet() : SerialIoSet
  • ~SerialServerSocket() : SerialServerSocket
  • ~SerialSocket() : SerialSocket
  • ~SerialTerminal() : SerialTerminal
  • ~SerialTerminalListener() : SerialTerminalListener
  • ~SerialTerminalSocket() : SerialTerminalSocket
  • ~Server() : Server
  • ~ServerAddressWin() : ServerAddressWin
  • ~ServerClient() : ServerClient
  • ~ServerConfig() : ServerConfig
  • ~Service() : Service
  • ~ServiceThread() : ServiceThread
  • ~ServiceThreadStarter() : ServiceThreadStarter
  • ~ServiceThreadTerminateMsg() : ServiceThreadTerminateMsg
  • ~SetLanguageAction() : SetLanguageAction
  • ~SetThemeAction() : SetThemeAction
  • ~SetupDataConnMsg() : SetupDataConnMsg
  • ~SharedPtr() : SharedPtr< T_obj >
  • ~SharedTimer() : SharedTimer
  • ~SharedTimerMsg() : SharedTimerMsg
  • ~SharedTriggerTimer() : SharedTriggerTimer< T >
  • ~ShutdownRequestMsg() : ShutdownRequestMsg
  • ~SiChannelCloseInfoIndMsg() : SiChannelCloseInfoIndMsg
  • ~SiChannelOpenPromptReqMsg() : SiChannelOpenPromptReqMsg
  • ~SiChannelReceiveInfoIndMsg() : SiChannelReceiveInfoIndMsg
  • ~SiChannelSendInfoIndMsg() : SiChannelSendInfoIndMsg
  • ~SigDispatcher() : SigDispatcher
  • ~SigHandler() : SigHandler
  • ~SignalHandler() : SignalHandler
  • ~SignalQualityLevelMsg() : SignalQualityLevelMsg
  • ~SignalStrengthLevelMsg() : SignalStrengthLevelMsg
  • ~SimAccessor() : SimAccessor
  • ~SimAlphaIdentifier() : SimAlphaIdentifier
  • ~SimAuxHandler() : SimAuxHandler
  • ~SimBrowserTermResMsg() : SimBrowserTermResMsg
  • ~SimCallSetupMsg() : SimCallSetupMsg
  • ~SimCallSetupRejectedMsg() : SimCallSetupRejectedMsg
  • ~SimChvHandler() : SimChvHandler
  • ~SimCphsHandler() : SimCphsHandler
  • ~SimDispatcher() : SimDispatcher
  • ~SimDisplayTextMsg() : SimDisplayTextMsg
  • ~SimDisplayTextOptions() : SimDisplayTextOptions
  • ~SimEndTransactionMsg() : SimEndTransactionMsg
  • ~SimErrorMsg() : SimErrorMsg
  • ~SimGetInkeyMsg() : SimGetInkeyMsg
  • ~SimGetInkeyOptions() : SimGetInkeyOptions
  • ~SimGetInputMsg() : SimGetInputMsg
  • ~SimGetInputOptions() : SimGetInputOptions
  • ~SimHandler() : SimHandler
  • ~SimIconDescription() : SimIconDescription
  • ~SimIconIdentifier() : SimIconIdentifier
  • ~SimIconQualifier() : SimIconQualifier
  • ~SimImage() : SimImage
  • ~SimItemId() : SimItemId
  • ~SimItemIdentifier() : SimItemIdentifier
  • ~SimLaunchBrowserPromptReqMsg() : SimLaunchBrowserPromptReqMsg
  • ~SimLaunchBrowserReqMsg() : SimLaunchBrowserReqMsg
  • ~SimLockStatusMsg() : SimLockStatusMsg
  • ~SimMenuItemSelectionFailedMsg() : SimMenuItemSelectionFailedMsg
  • ~SimMexeCertificate() : SimMexeCertificate
  • ~SimNextActionIdentifier() : SimNextActionIdentifier
  • ~SimPbBaseHandler() : SimPbBaseHandler
  • ~SimPbEntry() : SimPbEntry
  • ~SimPbEntryCont() : SimPbEntryCont
  • ~SimPduHandler() : SimPduHandler
  • ~SimPhoneBookEntry() : SimPhoneBookEntry
  • ~SimPlayToneMsg() : SimPlayToneMsg
  • ~SimpleAppContext() : SimpleAppContext
  • ~SimpleAudioDevice() : SimpleAudioDevice
  • ~SimpleMap() : SimpleMap< TKey, TValue >
  • ~SimpleMutex() : SimpleMutex
  • ~SimpleScheduler() : SimpleScheduler
  • ~SimpleSemaphore() : SimpleSemaphore
  • ~SimpleTextRenderer() : SimpleTextRenderer
  • ~SimRefreshMsg() : SimRefreshMsg
  • ~SimRefreshResetMsg() : SimRefreshResetMsg
  • ~SimResetConfirmationMsg() : SimResetConfirmationMsg
  • ~SimResetDoneMsg() : SimResetDoneMsg
  • ~SimSelectItemMsg() : SimSelectItemMsg
  • ~SimSelectItemOptions() : SimSelectItemOptions
  • ~SimServices() : SimServices
  • ~SimSetupIdleModeTextMsg() : SimSetupIdleModeTextMsg
  • ~SimSetupIdleModeTextOptions() : SimSetupIdleModeTextOptions
  • ~SimSetupMenuMsg() : SimSetupMenuMsg
  • ~SimSetupMenuOptions() : SimSetupMenuOptions
  • ~SimSmsParameter() : SimSmsParameter
  • ~SimSmsParamHandler() : SimSmsParamHandler
  • ~SimSmsSentMsg() : SimSmsSentMsg
  • ~SimSsSentMsg() : SimSsSentMsg
  • ~SimStateChangedMsg() : SimStateChangedMsg
  • ~SimTextString() : SimTextString
  • ~SimTkHandler() : SimTkHandler
  • ~SimTkLanguageNotificationMsg() : SimTkLanguageNotificationMsg
  • ~SimTkLceService() : SimTkLceService
  • ~SimTkMainMenuProvider() : SimTkMainMenuProvider
  • ~SimTkProfileGetCnfMsg() : SimTkProfileGetCnfMsg
  • ~SimTkProfileSetCnfMsg() : SimTkProfileSetCnfMsg
  • ~SimTkProfileSetRejMsg() : SimTkProfileSetRejMsg
  • ~SimTkRefreshStartMsg() : SimTkRefreshStartMsg
  • ~SimTkRunAtCmdInfoIndMsg() : SimTkRunAtCmdInfoIndMsg
  • ~SimTkSendDtmfEndIndMsg() : SimTkSendDtmfEndIndMsg
  • ~SimTkSendDtmfIndMsg() : SimTkSendDtmfIndMsg
  • ~SimTkSetupEventMsg() : SimTkSetupEventMsg
  • ~SimUserDispatcher() : SimUserDispatcher
  • ~SingleArgHook() : SingleArgHook< T >
  • ~SioGlueSignalListener() : SioGlueSignalListener
  • ~SkipSocketTestMsg() : SkipSocketTestMsg
  • ~SmafSound() : SmafSound
  • ~SmoothScrollInfo() : AbstractGrid::SmoothScrollInfo
  • ~Sms() : Sms
  • ~SmsAlert() : SmsAlert
  • ~SmsApp() : SmsApp
  • ~SmsBasicProvider() : SmsBasicProvider
  • ~SmsClass0Provider() : SmsClass0Provider
  • ~SmsCommand() : SmsCommand
  • ~SmsComposeWin() : SmsComposeWin
  • ~SmsContext() : SmsContext
  • ~SmsControlIndMsg() : SmsControlIndMsg
  • ~SmsCountProvider() : SmsCountProvider
  • ~SmsDeliver() : SmsDeliver
  • ~SmsDispatcher() : SmsDispatcher
  • ~SmsEditor() : SmsEditor
  • ~SmsFactory() : SmsFactory
  • ~SmsFolderProvider() : SmsFolderProvider
  • ~SmsHandler() : SmsHandler
  • ~SmsIndicationState() : SmsIndicationState
  • ~SmsInfoBox() : SmsInfoBox
  • ~SmsMessageWaitingChangedMsg() : SmsMessageWaitingChangedMsg
  • ~SmsMsgWaitingProvider() : SmsMsgWaitingProvider
  • ~SmsNewMessageMsg() : SmsNewMessageMsg
  • ~SmsNewSocketDataMsg() : SmsNewSocketDataMsg
  • ~SmsNewStatusReportMsg() : SmsNewStatusReportMsg
  • ~SmsParamProvider() : SmsParamProvider
  • ~SmsPortDataRecvMsg() : SmsPortDataRecvMsg
  • ~SmsPrefStorageMediaChangedMsg() : SmsPrefStorageMediaChangedMsg
  • ~SmsProvider() : SmsProvider
  • ~SmsReadProvider() : SmsReadProvider
  • ~SmsSendConfirmMsg() : SmsSendConfirmMsg
  • ~SmsSendDispatcher() : SmsSendDispatcher
  • ~SmsSendingConfirmDialog() : SmsSendingConfirmDialog
  • ~SmsSendRejectMsg() : SmsSendRejectMsg
  • ~SmsSentProvider() : SmsSentProvider
  • ~SmsServiceDocumentMsg() : SmsServiceDocumentMsg
  • ~SmsServiceMsg() : SmsServiceMsg
  • ~SmsSettingsProvider() : SmsSettingsProvider
  • ~SmsSocket() : SmsSocket
  • ~SmsSpaceAvailableMsg() : SmsSpaceAvailableMsg
  • ~SmsSpaceExceededMsg() : SmsSpaceExceededMsg
  • ~SmsStatusReport() : SmsStatusReport
  • ~SmsSubmit() : SmsSubmit
  • ~SmsTemplateProvider() : SmsTemplateProvider
  • ~SmsTextParser() : SmsTextParser
  • ~SmsUnreadProvider() : SmsUnreadProvider
  • ~SmsUnsentProvider() : SmsUnsentProvider
  • ~SmsUtility() : SmsUtility
  • ~SmsViewerWin() : SmsViewerWin
  • ~SmsWStringCache() : SmsWStringCache
  • ~Socket() : Socket
  • ~SocketAddr() : SocketAddr
  • ~SocketControlMsg() : SocketControlMsg
  • ~SocketEventListener() : SocketEventListener
  • ~SocketHandler() : SocketHandler
  • ~SocketPeer() : SocketPeer
  • ~SocketSerialTerminalListener() : SocketSerialTerminalListener
  • ~SocketTestApp() : SocketTestApp
  • ~SocketTestMessage() : SocketTestMessage
  • ~SocketTestProgressWin() : SocketTestProgressWin
  • ~SocketTestResultsWin() : SocketTestResultsWin
  • ~SocketTestSettingsWin() : SocketTestSettingsWin
  • ~SocketTestT() : SocketTestT
  • ~SocketTestT1() : SocketTestT1
  • ~SocketTestT2() : SocketTestT2
  • ~SocketTestT3() : SocketTestT3
  • ~SocketTestT4() : SocketTestT4
  • ~SocketTestT5() : SocketTestT5
  • ~SocketTestT6() : SocketTestT6
  • ~SocketTestT7() : SocketTestT7
  • ~SocketTestT8() : SocketTestT8
  • ~SocketTestWin() : SocketTestWin
  • ~SoftkeyBar() : SoftkeyBar
  • ~SoftkeyBarView() : SoftkeyBarView
  • ~SoftkeyDesc() : SoftkeyDesc
  • ~SortProvider() : SortProvider
  • ~Sound() : Sound
  • ~SoundBrowserApp() : SoundBrowserApp
  • ~SoundBrowserServiceMsg() : SoundBrowserServiceMsg
  • ~SoundBrowserTestWin() : SoundBrowserTestWin
  • ~SoundBrowserWin() : SoundBrowserWin
  • ~SoundFileFilter() : SoundFileFilter
  • ~SoundFilter() : SoundFilter
  • ~SoundItem() : SoundItem
  • ~SoundMetaData() : SoundMetaData
  • ~SoundObtainer() : SoundObtainer
  • ~SoundRef() : SoundRef
  • ~SoundRefContainer() : SoundRefContainer
  • ~SpeechAudioDevice() : SpeechAudioDevice
  • ~SpeechSimpleAudioDevice() : SpeechSimpleAudioDevice
  • ~SsCallBarringActionImpl() : SsCallBarringActionImpl
  • ~SsCallForwardingActionImpl() : SsCallForwardingActionImpl
  • ~SsCallWaitingActionImpl() : SsCallWaitingActionImpl
  • ~SsCcbsDispatcher() : SsCcbsDispatcher
  • ~SsCcbsHandler() : SsCcbsHandler
  • ~SsClipActionImpl() : SsClipActionImpl
  • ~SsClirActionImpl() : SsClirActionImpl
  • ~SsCnapActionImpl() : SsCnapActionImpl
  • ~SsColpActionImpl() : SsColpActionImpl
  • ~SsColrActionImpl() : SsColrActionImpl
  • ~SsControlIndMsg() : SsControlIndMsg
  • ~SsDataReceivedMsg() : SsDataReceivedMsg
  • ~SsDispatcher() : SsDispatcher
  • ~SsEmlppActionImpl() : SsEmlppActionImpl
  • ~SsEndMsg() : SsEndMsg
  • ~SsErrIndicationMsg() : SsErrIndicationMsg
  • ~SsErrorMsg() : SsErrorMsg
  • ~SsFacilityRejectedMsg() : SsFacilityRejectedMsg
  • ~SsHandler() : SsHandler
  • ~SsInfoMsg() : SsInfoMsg
  • ~SsMessage() : SsMessage
  • ~SsNotificationMsg() : SsNotificationMsg
  • ~SsPasswordChangeActionImpl() : SsPasswordChangeActionImpl
  • ~SsRejectedMsg() : SsRejectedMsg
  • ~SsRequestAcceptedMsg() : SsRequestAcceptedMsg
  • ~SsRequestRejectedMsg() : SsRequestRejectedMsg
  • ~SsRequestSentMsg() : SsRequestSentMsg
  • ~SsSuccessMsg() : SsSuccessMsg
  • ~SstProvider() : SstProvider
  • ~SsUssdActionImpl() : SsUssdActionImpl
  • ~SsWaitDispatcher() : SsWaitDispatcher
  • ~StackMsgActiveWaitDispatcher() : StackMsgActiveWaitDispatcher
  • ~StackMsgDispatcher() : StackMsgDispatcher
  • ~StackSsRejectedMsg() : StackSsRejectedMsg
  • ~StandardJoinRule() : StandardJoinRule
  • ~StartSocketTestMsg() : StartSocketTestMsg
  • ~StatusDispatcher() : StatusDispatcher
  • ~StatusProvider() : StatusProvider
  • ~StillCamera() : StillCamera
  • ~StopDtmfCnfArg() : StopDtmfCnfArg
  • ~StopSocketTestMsg() : StopSocketTestMsg
  • ~StorageDevice() : StorageDevice
  • ~StorageDeviceFilter() : StorageDeviceFilter
  • ~StorageDeviceIterator() : StorageDeviceIterator
  • ~StorageDeviceVisitor() : StorageDeviceVisitor
  • ~Stream() : Stream
  • ~StreamAudioPlayer() : StreamAudioPlayer
  • ~StreamAudioReference() : StreamAudioReference
  • ~StreamingCallback() : StreamingCallback
  • ~StreamingInfo() : StreamingInfo
  • ~StreamingReadInfo() : StreamingReadInfo
  • ~StreamingWriteInfo() : StreamingWriteInfo
  • ~StreamObexImpl() : StreamObexImpl
  • ~StreamObexTransport() : StreamObexTransport
  • ~StreamReader() : StreamReader
  • ~StreamWriter() : StreamWriter
  • ~String() : String
  • ~StringDataSink() : StringDataSink
  • ~StrokeBox() : StrokeBox
  • ~StrokeBoxView() : StrokeBoxView
  • ~SubMenuAction() : SubMenuAction
  • ~SubSystem() : SubSystem
  • ~SubUnitReference() : SubUnitReference
  • ~SvgDecodingFinishedMsg() : SvgDecodingFinishedMsg
  • ~SvgFileWrapper() : SvgFileWrapper
  • ~SvgGzFileWrapper() : SvgGzFileWrapper
  • ~SvgHyperlinkSelectMsg() : SvgHyperlinkSelectMsg
  • ~SvgImage() : SvgImage
  • ~SvgImageFileWrapper() : SvgImageFileWrapper
  • ~SvgIoWrapper() : SvgIoWrapper
  • ~SvgPlayer() : SvgPlayer
  • ~SvgStatusMsg() : SvgStatusMsg
  • ~SyncMLManager() : SyncMLManager
  • ~SyncPaintDc() : SyncPaintDc
  • ~SyncPhoneThreadlet() : SyncPhoneThreadlet
  • ~SyncProgressMsg() : SyncProgressMsg
  • ~SysDnsClient() : SysDnsClient
  • ~SystemTimer() : SystemTimer
  • ~T9AddWordMsg() : T9AddWordMsg
  • ~T9EnteredUnknownWordMsg() : T9EnteredUnknownWordMsg
  • ~T9InputMapper() : T9InputMapper
  • ~T9MatrixModeKeypressed() : T9MatrixModeKeypressed
  • ~T9NoWordFoundMsg() : T9NoWordFoundMsg
  • ~T9Pack() : T9Pack
  • ~T9PinyinBox() : T9PinyinBox
  • ~T9PinyinBoxView() : T9PinyinBoxView
  • ~T9PredictiveInputBox() : T9PredictiveInputBox
  • ~T9SymbolEntryRequestMsg() : T9SymbolEntryRequestMsg
  • ~TabButton() : TabButton
  • ~TabButtonView() : TabButtonView
  • ~TabControl() : TabControl
  • ~TabControlView() : TabControlView
  • ~TcpServerTestSocket() : TcpServerTestSocket
  • ~TcpTestSocket() : TcpTestSocket
  • ~TermIos() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • ~TermRspCnfMsg() : TermRspCnfMsg
  • ~TestCheckBoxListView() : TestCheckBoxListView
  • ~TestCheckBoxView() : TestCheckBoxView
  • ~TestControlFrameView() : TestControlFrameView
  • ~TestPositionIndicatorView() : TestPositionIndicatorView
  • ~TestPushButtonView() : TestPushButtonView
  • ~TestRadioButtonListView() : TestRadioButtonListView
  • ~TestRadioButtonView() : TestRadioButtonView
  • ~TestSoftkeyBarView() : TestSoftkeyBarView
  • ~TestTheme() : TestTheme
  • ~TestWindowFrameView() : TestWindowFrameView
  • ~TextBox() : TextBox
  • ~TextBoxView() : TextBoxView
  • ~TextCompoundItem() : TextCompoundItem
  • ~TextEditorDocument() : TextEditorDocument
  • ~TextIconPairArray() : TextIconPairArray
  • ~TextIndicator() : TextIndicator
  • ~TextLine() : TextLine
  • ~TextLineView() : TextLineView
  • ~TextList() : TextList
  • ~TextListView() : TextListView
  • ~TextManager() : MultiMediaEditorDocument::TextManager
  • ~TextMenuAccessor() : TextMenuAccessor
  • ~TextPack() : TextPack
  • ~ThaiTextRenderer() : ThaiTextRenderer
  • ~Theme() : Theme
  • ~ThemeChangedMsg() : ThemeChangedMsg
  • ~ThemeViewIterator() : ThemeViewIterator
  • ~Thread() : Thread
  • ~Threadlet() : Threadlet
  • ~ThreadletNotificationMsg() : ThreadletNotificationMsg
  • ~ThreadSafeProvider() : ThreadSafeProvider
  • ~TimeCompoundItem() : TimeCompoundItem
  • ~TimeEditBox() : TimeEditBox
  • ~TimeEditBoxView() : TimeEditBoxView
  • ~TimeEditor() : TimeEditor
  • ~TimeEditorDocument() : TimeEditorDocument
  • ~TimeFeatureObject() : TimeFeatureObject
  • ~TimeoutCondition() : TimeoutCondition
  • ~Timer() : Timer
  • ~TimerTimeoutMsg() : TimerTimeoutMsg
  • ~TimeZone() : TimeZone
  • ~TimeZoneMsg() : TimeZoneMsg
  • ~TipdBasedActiveWaitDispatcher() : TipdBasedActiveWaitDispatcher
  • ~Tlv() : Tlv
  • ~ToDoApp() : ToDoApp
  • ~ToDoComposeWin() : ToDoComposeWin
  • ~ToDoDateDialogWin() : ToDoDateDialogWin
  • ~ToDoListWin() : ToDoListWin
  • ~ToDoProvider() : ToDoProvider
  • ~ToggleActionGroup() : ToggleActionGroup
  • ~ToneAudioDevice() : ToneAudioDevice
  • ~ToStackMsg() : ToStackMsg
  • ~Tpdu() : Tpdu
  • ~TpduCache() : TpduCache
  • ~TraceOutputStream() : TraceOutputStream
  • ~TransferLocationDialog() : TransferLocationDialog
  • ~TransportNotificationMsg() : TransportNotificationMsg
  • ~TriggerKeyFeature() : TriggerKeyFeature
  • ~TriggerTimer() : TriggerTimer< T >
  • ~TtyInterface() : TtyInterface
  • ~UdpTestSocket() : UdpTestSocket
  • ~UibAccessorTest() : UibAccessorTest
  • ~UibActionAccessor() : UibActionAccessor
  • ~UibApp() : UibApp
  • ~UibFolderWin() : UibFolderWin
  • ~UibInboxProvider() : UibInboxProvider
  • ~UibInboxTest() : UibInboxTest
  • ~UibListBoxModel() : UibListBoxModel
  • ~UibMsgDisplayTest() : UibMsgDisplayTest
  • ~UibNotifyMsg() : UibNotifyMsg
  • ~UibNotifyTest() : UibNotifyTest
  • ~UibPerformanceTest() : UibPerformanceTest
  • ~UibRegisterMsg() : UibRegisterMsg
  • ~UibServiceImpl() : UibServiceImpl
  • ~UibSettingsProvider() : UibSettingsProvider
  • ~UibSettingsTest() : UibSettingsTest
  • ~UibSettingsWin() : UibSettingsWin
  • ~UibSortingTest() : UibSortingTest
  • ~UibTest1() : UibTest1
  • ~UibTest2() : UibTest2
  • ~UibUpdateMsg() : UibUpdateMsg
  • ~UibUpdateThreadlet() : UibUpdateThreadlet
  • ~UndefinedSsAction() : UndefinedSsAction
  • ~UnlockAction() : UnlockAction
  • ~UpdateContextItemMsg() : UpdateContextItemMsg
  • ~UpdateItemMsg() : UpdateItemMsg
  • ~UpdatePbThreadlet() : UpdatePbThreadlet
  • ~Uri() : Uri
  • ~UriMappingTable() : UriMappingTable
  • ~UsbApp() : UsbApp
  • ~UsbObexTransport() : UsbObexTransport
  • ~UsbSubSystem() : UsbSubSystem
  • ~UserActivityListener() : UserActivityListener
  • ~UserData() : UserData
  • ~UserDispatcher() : UserDispatcher
  • ~UsimPbReadyMsg() : UsimPbReadyMsg
  • ~UsimPbResetedMsg() : UsimPbResetedMsg
  • ~UsimPbRwRecord() : UsimPbRwRecord
  • ~UssdAction() : UssdAction
  • ~UssdAnswerMsg() : UssdAnswerMsg
  • ~UssDataReceivedMsg() : UssDataReceivedMsg
  • ~UssdBeginMsg() : UssdBeginMsg
  • ~UssdControlIndMsg() : UssdControlIndMsg
  • ~UssdDataMsg() : UssdDataMsg
  • ~UssdEndMsg() : UssdEndMsg
  • ~UssdIndicationMsg() : UssdIndicationMsg
  • ~UssdNotifyMsg() : UssdNotifyMsg
  • ~UssdRequestMsg() : UssdRequestMsg
  • ~UssdRequestResentMsg() : UssdRequestResentMsg
  • ~UssdResentMsg() : UssdResentMsg
  • ~UtcStatusMessage() : UtcStatusMessage
  • ~UusErasedMsg() : UusErasedMsg
  • ~UusHandler() : UusHandler
  • ~UusNotificationMsg() : UusNotificationMsg
  • ~UusQueryRejectedMsg() : UusQueryRejectedMsg
  • ~UusRegisteredMsg() : UusRegisteredMsg
  • ~UusStatusMsg() : UusStatusMsg
  • ~ValueIndicator() : ValueIndicator
  • ~ValueMappingPropertyDescriptor() : ValueMappingPropertyDescriptor< T_Container >
  • ~ValueTextMap() : ValueTextMap
  • ~VCard() : VCard
  • ~VCardItem() : VCardItem
  • ~Vector() : Vector< T >
  • ~VeryLongKeyPressMsg() : VeryLongKeyPressMsg
  • ~VideoCamera() : VideoCamera
  • ~VideoCaptureParameters() : VideoCaptureParameters
  • ~VideoChannel() : VideoChannel
  • ~VideoCodecCapabilities() : CodecDevice::VideoCodecCapabilities
  • ~VietnameseTextRenderer() : VietnameseTextRenderer
  • ~View() : View
  • ~ViewfinderErrorMsg() : ViewfinderErrorMsg
  • ~VirtualDisplay() : VirtualDisplay
  • ~VoiceMemoApp() : VoiceMemoApp
  • ~VoiceMemoAudioDevice() : VoiceMemoAudioDevice
  • ~VoiceMemoMenuAccessor() : VoiceMemoMenuAccessor
  • ~VoiceMemoRecordWin() : VoiceMemoRecordWin
  • ~VoiceMemoWin() : VoiceMemoWin
  • ~VrAbortEngineIndArg() : VrAbortEngineIndArg
  • ~VrErrorIndArg() : VrErrorIndArg
  • ~VrErrorMsg() : VrErrorMsg
  • ~VrG2AResultIndArg() : VrG2AResultIndArg
  • ~VrHandler() : VrHandler
  • ~VrInitCnfArg() : VrInitCnfArg
  • ~VrIntrmRecResultIndArg() : VrIntrmRecResultIndArg
  • ~VrLoadTemplateReqArg() : VrLoadTemplateReqArg
  • ~VrParamReqArg() : VrParamReqArg
  • ~VrPlaybackFinishedMsg() : VrPlaybackFinishedMsg
  • ~VrPromptMsg() : VrPromptMsg
  • ~VrPropertyResultIndArg() : VrPropertyResultIndArg
  • ~VrRecognitionAbortedMsg() : VrRecognitionAbortedMsg
  • ~VrRecognitionFailedMsg() : VrRecognitionFailedMsg
  • ~VrRecognitionStoppedMsg() : VrRecognitionStoppedMsg
  • ~VrRecogResultIndArg() : VrRecogResultIndArg
  • ~VrResultMsg() : VrResultMsg
  • ~VrSayNameIndArg() : VrSayNameIndArg
  • ~VrStopRecogIndArg() : VrStopRecogIndArg
  • ~VrStoreTemplateReqArg() : VrStoreTemplateReqArg
  • ~VrTrainingAbortedMsg() : VrTrainingAbortedMsg
  • ~VrTrainingFailedMsg() : VrTrainingFailedMsg
  • ~VrTrainingResultMsg() : VrTrainingResultMsg
  • ~VrTrainResultIndArg() : VrTrainResultIndArg
  • ~VrWarningIndArg() : VrWarningIndArg
  • ~VrWarningMsg() : VrWarningMsg
  • ~WaitSsAction() : WaitSsAction
  • ~WapHandler() : WapHandler
  • ~WapProfile() : WapProfile
  • ~WapProfileMgr() : WapProfileMgr
  • ~WbmpImage() : WbmpImage
  • ~WbxmlParserRel() : WbxmlParserRel
  • ~Window() : Window
  • ~WindowFrameView() : WindowFrameView
  • ~WindowHierarchyIterator() : WindowHierarchyIterator
  • ~WString() : WString
  • ~XCallInfoResponseParser() : XCallInfoResponseParser
  • ~XMLParser() : XMLParser
  • ~XmlParserRel() : XmlParserRel
  • ~Zi8AddWordMsg() : Zi8AddWordMsg
  • ~Zi8AlphabetBox() : Zi8AlphabetBox
  • ~Zi8AlphabetBoxView() : Zi8AlphabetBoxView
  • ~Zi8EnteredUnknownWordMsg() : Zi8EnteredUnknownWordMsg
  • ~Zi8InputMapper() : Zi8InputMapper
  • ~Zi8NoWordFoundMsg() : Zi8NoWordFoundMsg
  • ~Zi8PredictiveInputBox() : Zi8PredictiveInputBox
  • ~Zi8SelectionBox() : Zi8SelectionBox
  • ~Zi8SelectionBoxView() : Zi8SelectionBoxView
  • ~Zi8StrokeBox() : Zi8StrokeBox
  • ~Zi8StrokeBoxView() : Zi8StrokeBoxView
  • ~Zi8Wrapper() : Zi8Wrapper
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- a -

  • Abort() : ObexOppClient, ObexOppBinDataPushClient, ObexLayer, ObexClientOppImpl, ObexClient, IrdaObexImpl, StartUp, BtObexImpl, StackMsgActiveWaitDispatcher, GetPasswordMsg, VrHandler, StreamObexImpl
  • AbortAddrResolution() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • AbortCalendarRecordIns() : CalendarApp
  • AbortIfEqualTipd() : TipdBasedActiveWaitDispatcher
  • AbortPasswordRequest() : CallBarringHandler
  • AbortReq() : BtBipClientService
  • AbortRequest() : BtObexClientService
  • AbortResArg() : AbortResArg
  • AbortResMsg() : AbortResMsg
  • AbortResolveAction() : ObexAbstractPort
  • AbortResolveClientAddr() : ObexAbstractTransport, IrdaObexTransport
  • AbortRsp() : BtBipServerService
  • AbortSelection() : ObexMngr, ObexClientDispatcher
  • AbortSelfLocReq() : LcsProviderImplBase, LcsProvider
  • AbstractActionMenuAccessor() : AbstractActionMenuAccessor
  • AbstractAppContext() : AbstractAppContext
  • AbstractButton() : AbstractButton
  • AbstractDelegationProvider() : AbstractDelegationProvider
  • AbstractDevice() : AbstractDevice
  • AbstractEditBox() : AbstractEditBox
  • AbstractEditBoxModel() : AbstractEditBoxModel
  • AbstractEditBoxView() : AbstractEditBoxView
  • AbstractEditor() : AbstractEditor, InputMapper
  • AbstractEditorItem() : AbstractEditorItem
  • AbstractExternalData() : AbstractExternalData
  • AbstractGrid() : AbstractGrid, AbstractGrid::SmoothScrollInfo
  • AbstractIMelodyParser() : AbstractIMelodyParser
  • AbstractItemContainer() : AbstractItemContainer
  • AbstractItemGrid() : AbstractItemGrid
  • AbstractItemRenderer() : AbstractItemRenderer
  • AbstractLineEditor() : AbstractLineEditor
  • AbstractLineEditorView() : AbstractLineEditorView
  • AbstractListBox() : AbstractListBox, AbstractListBox::SmoothScrollInfo
  • AbstractListBoxModel() : AbstractListBoxModel
  • AbstractListBoxView() : AbstractListBoxView
  • AbstractLockableDevice() : AbstractLockableDevice
  • AbstractMenuAccessor() : AbstractMenuAccessor
  • AbstractMenuList() : AbstractMenuList
  • AbstractMenuListModel() : AbstractMenuListModel< Item >
  • AbstractMultiLineEditor() : AbstractMultiLineEditor, InputMapper
  • AbstractMultiLineEditorView() : AbstractMultiLineEditorView
  • AbstractPredictiveInputBox() : AbstractPredictiveInputBox
  • AbstractRenderer() : AbstractRenderer
  • AbstractScheduler() : AbstractScheduler
  • AbstractSmsApp() : AbstractSmsApp
  • AbstractSmsComposeWin() : AbstractSmsComposeWin
  • AbstractSmsViewerWin() : AbstractSmsViewerWin
  • AbstractTextObject() : AbstractTextObject
  • AbstractTextRenderer() : AbstractTextRenderer
  • AbstractToggleAction() : AbstractToggleAction
  • AbstractTransport() : AbstractTransport
  • AcacLanguage() : AcacLanguage
  • AccDispatcher() : AccDispatcher
  • Accept() : TcpServerSocket, SysSocket, ObexServerInfo, ObexOppDataSinkPushServer, SocketPeer, PdpContext, CallHdl, StorageDeviceIterator, File, SioSocketAdapter, SerialServerSocket, SerialIoAdapter, MmCallHdl, MmCallHandler
  • AcceptCall() : BtHsService
  • AcceptCallSetup() : SimTkHandler
  • AcceptChar() : AbstractEditBox
  • AcceptConnectRequest() : ObexFtpServer
  • AcceptData() : ObexDataServer
  • AcceptDeleteObjectRequest() : ObexFtpServer
  • AcceptFilePullRequest() : ObexFtpServer
  • AcceptFilePushRequest() : ObexFtpServer
  • AcceptFolderListingRequest() : ObexFtpServer
  • AcceptMsg() : ServiceThread, ExecutionContext, Application
  • AcceptPull() : ObexServerOppImpl, ObexOppServer
  • AcceptPush() : ObexServerOppImpl, ObexOppServer
  • AcceptSetCurrentFolderRequest() : ObexFtpServer
  • AcceptsMessage() : ObexAbstractPort
  • AccessorAction() : AccessorAction
  • AccessorActionExtension() : AccessorActionExtension
  • Accessory() : MiscAudioDevice, Accessory
  • AccessoryIndArg() : AccessoryIndArg
  • AccessoryIndMsg() : AccessoryIndMsg
  • AccHandler() : AccHandler
  • AckNackCnt() : AckNackCnt
  • Acknowledge() : UssdHandler
  • AcquireChannel() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • AcquireClientChannel() : ObexProtocol, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • AcquireGlobalProvider() : MainProvider
  • AcquireServerChannel() : ObexProtocol, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • Action() : CallEvent, Action
  • ActionExecutedMsg() : ActionExecutedMsg
  • ActionExtension() : ActionExtension
  • ActionMenuAccessor() : ActionMenuAccessor
  • Activate() : StackMsgDispatcher, PdpContext, CallWaitingHandler, CallForwardingHandler, CallBarringHandler
  • ActivateBdn() : SimHandler, SimAccessor, DataHandler
  • ActivateCallBarring() : SsHandler
  • ActivateCallForwarding() : SsHandler
  • ActivateCallWaiting() : SsHandler
  • ActivateFdn() : SimHandler, SimAccessor, DataHandler
  • ActivateSmsUsage() : SimAccessor, DataHandler
  • ActivateYesNo() : SimGetInkeyOptions
  • ActivationStatus() : PdpContext::ActivationStatus
  • ActiveCallExists() : InputContext
  • ActiveWaitDispatcher() : ActiveWaitDispatcher
  • Add() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer, GlassPane, SingleArgHook< T >, Pathname, Registry, ObjectTreeService, SerialIoSet
  • AddAction() : DataConnOptionWin, TopLevelMenu, SubMenuAction, ActionMenuAccessor
  • AddAlignInfo() : FlowLayout
  • AddAllToFdn() : PhonebookApp
  • AddAppContainer() : System
  • AddAppContext() : AbstractScheduler
  • AddApplication() : AppContainerRoutingTableEntry
  • AddAttachment() : BtBipImageProperties
  • AddAttachmentFormat() : BtBipImagingCapabilities
  • AddAudioInfo() : MediaInfo
  • AddAudioPath() : AudioPathManager
  • AddAuthorizationSet() : WapProfile
  • AddBlobFileNode() : RegNodeBuffer
  • AddBlobNode() : RegNodeBuffer
  • AddBookmark() : AbstractSmsApp
  • AddBooleanNode() : RegNodeBuffer
  • AddChildProvider() : AppendProvider
  • AddClient() : Server
  • AddConstraint() : DrmPermission
  • AddControl() : Control
  • AddDataConnDescription() : DataConnApp
  • AddDataMapping() : MmfPlayer
  • AddDays() : Date
  • AddDefaultConstraints() : XmlParserRel, WbxmlParserRel
  • AddDefaultPermissions() : XmlParserRel, WbxmlParserRel
  • AddDetailMenuAction() : PhonebookWin
  • AddDevice() : DeviceManager
  • AddDispatcher() : ExecutionContext
  • AddDispatcherAction() : AppRoutingTableEntry
  • AddDrawableObject() : Control
  • AddElem() : HashTable
  • AddEntryToFdn() : PhonebookApp
  • AddExplicitCharacter() : T9InputMapper
  • AddExplicitWord() : T9InputMapper
  • AddFeature() : FeaturePool
  • AddFeatures() : FeaturePool
  • AddFileExtension() : Pathname
  • AddHeader() : ObexHeaderList, BtObexService
  • AddIcon() : IconSet
  • AddImage() : BtBipImageList
  • AddImageFormat() : BtBipImagingCapabilities
  • AddIndicator() : IndicatorBar
  • AddIntegerNode() : RegNodeBuffer
  • AddInteriorHeader() : RegNodeBuffer
  • AddInteriorNode() : RegNodeBuffer, LocalDataStore
  • AddInteriorNodeEntry() : NodeFileHandler
  • AddItem() : OpenContextMenuAction, ItemContainer, ContextMenu, AbstractItemGrid, AbstractItemContainer, TRadioButtonList< Content >, RadioButtonList, MenuList, CheckBoxList, AbstractMenuListModel< Item >, AudioPresetStore, AudioAccessoryStore, ProviderProxyContainer, FeatureItemContainer, DBService
  • AddKeySequenceFeature() : KeyMapping
  • AddLeafNode() : LocalDataStore
  • AddLockUriInTable() : LockTableList
  • AddMenuAction() : PbAbstractWin
  • AddMenuFeature() : BtHfAppPlugin
  • AddMimeType() : ObexHeaderList
  • AddNewWordToUdb() : Zi8PredictiveInputBox, Zi8InputMapper, T9PredictiveInputBox, T9InputMapper, AbstractPredictiveInputBox
  • AddNodeEntry() : NodeFileHandler
  • AddNumber() : PhonebookApp, PbManualSynchronizer, PbAdvDetails
  • AddNumberToFdn() : PhonebookApp
  • AddPbEntry() : PhonebookApp, PbManualSynchronizer
  • AddPermission() : DrmRightsObject
  • AddPhysicalPortSet() : WapProfile
  • AddPhysicalSet() : WapProfile
  • AddPlayer() : AudioPlayerStore
  • AddPortSet() : WapProfile
  • AddPostMsgHook() : MessageRouter
  • AddProfile() : DataConnProfileManager
  • AddRecord() : CalendarMonthWin, NvRamDataRecordHandler, RecordHandler, DataRecordHandler
  • AddRef() : ReferableObject
  • AddReferenceMapping() : DwdDevice
  • AddRegistration() : NotificationTable
  • Address() : PdpContext::Address
  • AddressAndMask() : PdpContext::PacketFilter::AddressAndMask
  • AddressEvent() : ObexAbstractPort::AddressEvent
  • AddRightsObject() : DrmRightsObjectStore, DrmRightsObjectContainer
  • AddRootCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • AddSimEntry() : PbManualSynchronizer
  • AddStringNode() : RegNodeBuffer
  • AddTab() : TabControl
  • AddTelNumber() : VCard
  • AddTemporaryProfile() : DataConnProfileManager
  • AddTimer() : ServiceThread, ExecutionContext, Application, AppContainer
  • AddTimeSpan() : DateTime
  • AddToDeleteBuffer() : RegDeletionBufferEntry
  • AddToList() : SerialSocketThread
  • AddToMessage() : SocketTestMessage
  • AddToReadList() : SerialIoSet
  • AddToTitlebar() : Window
  • AddToWriteList() : SerialIoSet
  • AddUri() : NotificationArray, LockTable
  • AddUserCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • AddVariant() : BtBipImageProperties
  • AddVideoInfo() : MediaInfo
  • AddView() : BrowserViewContainer
  • AddVKey() : KeyMapping
  • AddVKeyFeature() : KeyMapping
  • AddVKeyLongFeature() : KeyMapping
  • AddVKeyVeryLongFeature() : KeyMapping
  • AddWindow() : Application
  • AddWordToUdb() : Zi8Wrapper
  • AdjustBlitRect() : VirtualDisplay
  • AdjustBoundingRect() : FrameDc, DisplayDc, DeviceContext, ClientDc, BitmapDc
  • AdjustBounds() : CustomizableTheme
  • AdjustParent() : Component
  • AdjustSize() : Image
  • AdjustStrings() : DrawableObject
  • AdjustThemeDependencies() : ImageListBoxModel, DrawableObject, Grid
  • AdjustWindowTitle() : ItemMenu
  • Advance() : ObexTransportSet::Iterator, ObexHeaderList::ConstIterator, MimeCoder
  • AdvPbAction() : AdvPbAction
  • AdvPbWin() : AdvPbWin
  • AesCrypt() : AesCrypt
  • AidingData() : AidingData
  • AlarmMsg() : AlarmMsg
  • AlarmNotificationMsg() : AlarmNotificationMsg
  • Alert() : Alert
  • Alloc() : Os, Allocator< T >, MemPool, MemPoolEntry
  • Allocate() : HeapVector::VarPage, HeapVector::BlockPage, HeapManager, RegBlobObject, ByteBuffer, BlobObject
  • AllocateCaptureBuffers() : VideoCamera
  • AllocateOutputBuffers() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoder
  • AllocateSuspendSlot() : DwdPlayer
  • AllocInputMapper() : EditConfig
  • Alphabet() : InputMapper, DataCodingScheme, EnumTranslationTable
  • AlphaCoding() : AlphaCoding
  • AlphaTagSizeError() : PbManualSynchronizer
  • AmplifierAudioDevice() : AmplifierAudioDevice
  • AmrSound() : AmrSound
  • Analyze() : LanguageResetAction, ApoxiCommandAction, UssdAction, UndefinedSsAction, WaitSsAction, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, NumberIdentificationAction, ClirAction, PinAction, CallSsAction, EngModeAction, ImeiShowAction, MoCallAction, UnlockAction, PbEntryShowAction, InputAction
  • AnimatedTextLine() : AnimatedTextLine
  • AnimatedTextLineView() : AnimatedTextLineView
  • Animation() : Animation, Timer
  • AnimationBmpArrayIterator() : AnimationBmpArrayIterator
  • AnimationBmpPointerArrayIterator() : AnimationBmpPointerArrayIterator
  • AnimationModel() : AnimationModel
  • AocChargingStatus() : EnumTranslationTable
  • AocChargingStatusMsg() : AocChargingStatusMsg
  • AocDispatcher() : AocDispatcher
  • AocHandler() : AocHandler
  • AocIndArg() : AocIndArg
  • apoxi_emcpp_OBEXAdapter() : apoxi_emcpp_OBEXAdapter
  • ApoxiCommandAction() : ApoxiCommandAction
  • ApoxiThread() : ApoxiThread
  • AppActionExecutedMsg() : AppActionExecutedMsg
  • AppCloseMsg() : AppCloseMsg
  • AppContainer() : AppContainer, Timer, MsgQueue, Message, Application, AbstractScheduler
  • AppContainerRoutingTableEntry() : AppContainerRoutingTableEntry
  • AppContext() : AppContext
  • Append() : FfsFile, RegBlobObject, ElementList< T >, ByteBuffer, BlobObject, SmsFactory, UserData, UserDataHeader, Cbs::Filter, FfsHandler, HttpResponse, GltpAssistanceData, RamHandler, RamFileObj, FatHandler, PbRecordProvider, Provider
  • AppendData() : ObexHeaderBuilder
  • AppendDistinct() : ElementList< T >, MessageIdentifierContainer
  • AppendEmptyLine() : AbstractEditBoxModel
  • AppendHeader() : HttpResponse
  • AppendMePhonebookDescriptor() : MePhonebookDescription
  • AppendProvider() : AppendProvider
  • AppendRow() : ToDoProvider, DataConnProvider, CalendarProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, PbMergeProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider, AppendProvider, SmsParamProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider
  • AppendSorted() : MessageIdentifierContainer
  • AppFeatureID() : AppFeatureID
  • AppGetFocusMsg() : AppGetFocusMsg
  • Application() : Application, Timer, Control
  • ApplicationAction() : ApplicationAction
  • ApplicationListEntry() : ApplicationListEntry
  • AppLoseFocusMsg() : AppLoseFocusMsg
  • ApplyContext() : AtlItemMenuWindow, AtlItemGridWindow
  • ApplyDeviceVolume() : SpeechSimpleAudioDevice, MmfPlayer, AudioDeviceBase
  • ApplyFilter() : MediaRefContainer
  • ApplyInitialFilter() : DirectoryIterator
  • ApplyMasterVolume() : AudioDeviceBase
  • ApplyVisitorFilter() : MediaRefContainer
  • AppMutex() : AppMutex
  • AppOpenMsg() : AppOpenMsg
  • AppRoutingTableEntry() : AppRoutingTableEntry
  • AppUpdateDisplayMsg() : AppUpdateDisplayMsg
  • ArabicTextRenderer() : ArabicTextRenderer
  • AragonMsg() : AragonMsg
  • areTestsFinished() : SocketTestApp
  • Arrange() : Layouter
  • AsBoolean() : BtSvrDataElement
  • Assemble() : SmsFactory
  • Assertion() : Trap
  • Assign() : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile
  • AssignCaptureBufferPool() : EmzMpeg4Encoder
  • AssignDriveLetter() : RamFileSystem
  • AsSigned() : BtSvrDataElement
  • AsString() : BtSvrDataElement, BtDeviceAddress, BtBipImageHdl
  • AssureInitialized() : FlsFile, RamFile, FatFile
  • AssureValidCaretIndex() : AbstractEditor
  • AssureValidIndex() : AbstractEditor
  • AssureVisibleSelection() : AbstractGrid
  • AsUnsigned() : BtSvrDataElement
  • AsUuid() : BtSvrDataElement
  • AsWString() : BtSvrDataElement
  • AsyncUnitTestMsg() : AsyncUnitTestMsg
  • AtAccessoryNotificationIndArg() : AtAccessoryNotificationIndArg
  • AtAccessoryRegisterCnfArg() : AtAccessoryRegisterCnfArg
  • AtAccessoryRegisterReqArg() : AtAccessoryRegisterReqArg
  • AtAlphaTagCnfArg() : AtAlphaTagCnfArg
  • AtAlphaTagReqArg() : AtAlphaTagReqArg
  • AtcDispatcher() : AtcDispatcher
  • AtcHandler() : AtcHandler, AtcDispatcher
  • AtCommand() : AtCommand
  • AtGenericCmdIndArg() : AtGenericCmdIndArg
  • AtGenericCmdReqArg() : AtGenericCmdReqArg
  • AtGenericCmdType() : AtGenericCmdType
  • AtiAudioPlayerRtStreamingConn() : AtiAudioPlayerRtStreamingConn
  • AtiAudioPlayerRtStreamingSink() : AtiAudioPlayerRtStreamingSink
  • AtKeyParser() : AtKeyParser
  • AtlApplication() : AtlApplication
  • AtlApplicationPlugin() : AtlApplicationPlugin, AtlApplication
  • AtlItemBox() : AtlItemBox
  • AtlItemGrid() : AtlItemGrid
  • AtlItemGridWindow() : AtlItemGridWindow
  • AtlItemListWindow() : AtlItemListWindow
  • AtlItemMenu() : AtlItemMenu
  • AtlItemMenuWindow() : AtlItemMenuWindow
  • AtlItemRenderer() : AtlItemRenderer
  • AtlLabelListWindow() : AtlLabelListWindow
  • AtlWindow() : AtlWindow, ContextManager
  • AtomicIncrement() : RootStorageDeviceIterator, StorageDeviceIterator, DirectoryIterator, RootDirectoryIteratorImp, RamDirectoryIteratorImp, FlashDirectoryIteratorImp, FatDirectoryIteratorImp
  • AtomItem() : AtomItem
  • AtPbInfoIndArg() : AtPbInfoIndArg
  • AtPbListCnfArg() : AtPbListCnfArg
  • AtPbListReqArg() : AtPbListReqArg
  • AtPbSelectCnfArg() : AtPbSelectCnfArg
  • AtPbSelectReqArg() : AtPbSelectReqArg
  • AtResponse() : AtResponse
  • AtResponseIterator() : AtResponseIterator, AtResponse, AtResponseParameter
  • AtResponseParameter() : AtResponseParameter
  • Attach() : InetSocket, ObexDispatcher, MessageHook, AppContainer, BtObexServerService, BtObexClientService, BtSddbService, BtObservableService, ObservableObject, HeapArrayObject< T >, HeapObject< T >, RtStreamingSource, RtStreamingSink, RtStreamingEndPoint, RtStreamingConn, AtlApplicationPlugin, PdpContextManager, PngDecoder
  • AttachAllowedIndArg() : AttachAllowedIndArg
  • AttachAtlApplicationPlugin() : AtlApplication
  • AttachCnfArg() : AttachCnfArg
  • AttachManagerControl() : PdpContextManager
  • AttachOppServer() : ObexServerOppImpl
  • AttachRejArg() : AttachRejArg
  • AttachReqArg() : AttachReqArg
  • AttachStatus() : PdpContextManager::AttachStatus
  • AttachStorage() : DataConnProfileManager
  • Audio() : Audio
  • AudioAccessoryConnectedMsg() : AudioAccessoryConnectedMsg
  • AudioAccessoryDetails() : AudioAccessoryDetails
  • AudioAccessoryStore() : AudioAccessoryStore
  • AudioCodecCapabilities() : CodecDevice::AudioCodecCapabilities
  • AudioContext() : AudioContext
  • AudioDeviceBase() : AudioDeviceBase
  • AudioDeviceStatusMsg() : AudioDeviceStatusMsg
  • AudioErrorMsg() : AudioErrorMsg
  • AudioFastForwardStartedMsg() : AudioFastForwardStartedMsg
  • AudioFmRadioRdsAlternativeFrequenciesMsg() : AudioFmRadioRdsAlternativeFrequenciesMsg
  • AudioFmRadioRdsInfoMsg() : AudioFmRadioRdsInfoMsg
  • AudioFmRadioRdsRadioTextMsg() : AudioFmRadioRdsRadioTextMsg
  • AudioFmRadioRdsRawDataMsg() : AudioFmRadioRdsRawDataMsg
  • AudioFmRadioRdsStationNameMsg() : AudioFmRadioRdsStationNameMsg
  • AudioFmRadioRssiMsg() : AudioFmRadioRssiMsg
  • AudioFmRadioSeekMsg() : AudioFmRadioSeekMsg
  • AudioGetPlayPositionMsg() : AudioGetPlayPositionMsg
  • AudioItem() : AudioItem
  • AudioMsg() : AudioMsg
  • AudioPath() : AudioPath
  • AudioPathManager() : AudioPathManager
  • AudioPlayer() : AudioPlayer
  • AudioPlayerEvent() : AudioPlayerEvent
  • AudioPlayerStore() : AudioPlayerStore
  • AudioPlayTimeMsg() : AudioPlayTimeMsg
  • AudioPreset() : AudioPreset
  • AudioPresetStore() : AudioPresetStore
  • AudioRadioDeviceNotificationMsg() : AudioRadioDeviceNotificationMsg
  • AudioRecordingStoppedMsg() : AudioRecordingStoppedMsg
  • AudioReference() : AudioReference
  • AudioRestartedMsg() : AudioRestartedMsg
  • AudioResumedMsg() : AudioResumedMsg
  • AudioReturnSuspend() : Mp3AudioDevice
  • AudioRewindStartedMsg() : AudioRewindStartedMsg
  • AudioStartedMsg() : AudioStartedMsg
  • AudioStoppedMsg() : AudioStoppedMsg
  • AudioStreamingSyncMsg() : AudioStreamingSyncMsg
  • AudioSuspendedMsg() : AudioSuspendedMsg
  • AudioTone() : AudioTone
  • AudioToneToneType() : EnumTranslationTable
  • AudioTrackInfo() : MediaInfo::AudioTrackInfo
  • AudioUserDefinedMsg() : AudioUserDefinedMsg
  • AudioVoiceMemoOutOfSpaceMsg() : AudioVoiceMemoOutOfSpaceMsg
  • Authenticate() : PsdDataConn, PdpContext
  • Authentication() : PdpContext::Authentication
  • AuthorizeUser() : HttpAuthProvider, FtpAuthProvider, AuthProvider
  • AuthorizeUserPassword() : HttpAuthProvider, FtpAuthProvider, AuthProvider
  • AuthProvider() : AuthProvider
  • AutoCallRestrictIndArg() : AutoCallRestrictIndArg
  • AutoDeletePhone() : PbSynchronizer, PbLazySynchronizer
  • AutoDeleteSim() : PbSynchronizer, PbLazySynchronizer
  • AutoSyncPhone() : PbSynchronizer, PbLazySynchronizer
  • AutoSyncSim() : PbSynchronizer, PbLazySynchronizer
  • AuxProvider() : AuxProvider
  • Available() : InputStream, FileInputStream
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- b -

  • Back() : ItemMenu, TextMenuAccessor, MenuAccessor, Menu, AbstractMenuAccessor, BtDeviceList, Vector< T >
  • back() : WbxmlVector< T >
  • Backspace() : SmsEditor, EmsEditor, PasswordEditor, AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor, MultiMediaEditor
  • BackToIdleFeature() : BackToIdleFeature
  • BandSelection() : NetworkHandler
  • BandSelectionIndArg() : BandSelectionIndArg
  • BandSelectionMsg() : BandSelectionMsg
  • BandSelectionReqArg() : BandSelectionReqArg
  • BandStatusMsg() : BandStatusMsg
  • BarringInfoReceivedMsg() : BarringInfoReceivedMsg
  • BarringSsAction() : BarringSsAction
  • Base64Coder() : Base64Coder
  • BaseDataHandler() : BaseDataHandler
  • BaseInformationElement() : BaseInformationElement
  • BasicPackConnector() : BasicPackConnector, TextPack, FontPack, DataPack
  • BasicPbWin() : BasicPbWin
  • BasicSmsService() : BasicSmsService
  • BatteryLoadLevelMsg() : BatteryLoadLevelMsg
  • BcdNibbleToWChar() : PhoneNumber
  • BcdPlmn() : BcdPlmn
  • BdnIndArg() : BdnIndArg
  • BdnReqArg() : BdnReqArg
  • BearerDisconnectedEvent() : DataConn
  • Begin() : ObexTransportSet, ObexHeaderList, WindowHierarchyIterator, ThemeViewIterator, Control::ComponentIterator, DeviceManager::Iterator, BtDeviceList, Vector< T >, MessageIdentifierRange, DataCodingSchemeRange, Pathname, CompoundItemIterator
  • begin() : WbxmlVector< T >
  • BeginDecoding() : ImageDecoder, PngDecoder
  • BeginDrawing() : PngImage
  • BeginEncoding() : ImageEncoder, PngEncoder, JpegEncoder
  • BeginGlyphRetrieval() : ThaiTextRenderer, AbstractTextRenderer
  • BeginInternalUpdate() : ParagraphCompoundItem
  • BeginOperation() : StreamObexImpl
  • BeginProcessing() : BidiManager
  • BeginScanlineDrawing() : NativeImage, Image, WbmpImage, JpegImage, GifImage, BmpImage
  • BeginTransaction() : UssdHandler, UssdBeginMsg
  • BeginUpdate() : DeviceContext
  • BigEndian16Bit() : BigEndian16Bit
  • BigEndian32Bit() : BigEndian32Bit
  • Bind() : SysSocket, InetSocket, SocketPeer, SerialServerSocket, SerialIoAdapter, SerialClientSocket
  • BinData() : BinData, MemMap
  • BinDataDataSource() : BinDataDataSource
  • BindServerChannel() : ObexProtocol, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • BindToMimeType() : ObexOppServer, ObexOppDataSinkPushServer
  • BinSearchRow() : MergeProvider
  • BitBlit() : VirtualDisplay
  • BitField() : BitField< T >
  • Bitmap() : Bitmap
  • BitmapCount() : AnimationBmpPointerArrayIterator, AnimationBmpArrayIterator, AnimationBmpIterator
  • BitmapDc() : BitmapDc
  • BitVector() : BitVector< N >
  • BlackAndWhiteTheme() : BlackAndWhiteTheme
  • Blend() : Color
  • BlobObject() : BlobObject
  • BlobPtr() : BlobPtr
  • BlockNotification() : Item, Feature
  • BlueSkyCheckBoxListView() : BlueSkyCheckBoxListView
  • BlueSkyCheckBoxView() : BlueSkyCheckBoxView
  • BlueSkyChineseTheme() : BlueSkyChineseTheme
  • BlueSkyControlFrameView() : BlueSkyControlFrameView
  • BlueSkyPositionIndicatorView() : BlueSkyPositionIndicatorView
  • BlueSkyProgressBarView() : BlueSkyProgressBarView
  • BlueSkyPushButtonView() : BlueSkyPushButtonView
  • BlueSkyRadioButtonListView() : BlueSkyRadioButtonListView
  • BlueSkyRadioButtonView() : BlueSkyRadioButtonView
  • BlueSkyTextListView() : BlueSkyTextListView
  • BlueSkyTheme() : BlueSkyTheme
  • BlueSkyWindowFrameView() : BlueSkyWindowFrameView
  • BmpImage() : BmpImage
  • BooleanCondition() : BooleanCondition
  • BootControl() : BootControl
  • BootDispatcher() : BootDispatcher
  • BootDispatchingArg() : BootDispatchingArg
  • BootHandler() : BootHandler
  • BootState() : BootState
  • BoundedItem() : BoundedItem
  • BppSndAbortReq() : BtBppController, BtBppClientService
  • BppSndFilePush() : BtBppClientService
  • BppSndFilePushReq() : BtBppController
  • BppSndGetRefObjRsp() : BtBppServerService, BtBppController
  • Broadcast() : GatiManager
  • BrowserLaunched() : SimTkHandler
  • BrowserRegisterReqArg() : BrowserRegisterReqArg
  • BrowserSaveWin() : BrowserSaveWin
  • BrowserTermEventArg() : BrowserTermEventArg
  • BrowserTerminated() : SimTkHandler
  • BrowserView() : BrowserView
  • BrowserViewContainer() : BrowserViewContainer
  • Brush() : Brush
  • BtActiveDeviceWindow() : BtActiveDeviceWindow
  • BtAlertMessageWindow() : BtAlertMessageWindow
  • BtApplicationDevicePairRequest() : BtApplicationDevicePairRequest, BtDeviceListWindow
  • BtApplicationDeviceSearchRequest() : BtApplicationDeviceSearchRequest, BtDeviceListWindow
  • BtApplicationDeviceTrustRequest() : BtApplicationDeviceTrustRequest, BtDeviceListWindow
  • BtApplicationDeviceUnpairRequest() : BtApplicationDeviceUnpairRequest, BtDeviceListWindow
  • BtApplicationDeviceUntrustRequest() : BtApplicationDeviceUntrustRequest, BtDeviceListWindow
  • BtApplicationMessage() : BtApplicationMessage
  • BtApplicationQuerySupportedProfilesRequest() : BtApplicationQuerySupportedProfilesRequest, BtDeviceListWindow, BtDeviceDetailWindow
  • BtApplicationRespondAuthorizationRequest() : BtApplicationRespondAuthorizationRequest
  • BtApplicationSendPasskeyRequest() : BtApplicationSendPasskeyRequest
  • BtApplicationServiceVerifyRequest() : BtApplicationServiceVerifyRequest, BtDeviceListWindow
  • BtApplicationSetRemoteDeviceNameRequest() : BtApplicationSetRemoteDeviceNameRequest
  • BtAudioAccessoryService() : BtAudioAccessoryService
  • BtAuthorizationRequiredMessage() : BtAuthorizationRequiredMessage
  • BtAuthorizationRequiredWindow() : BtAuthorizationRequiredWindow
  • BtAvrcpAlertMessageWindow() : BtAvrcpAlertMessageWindow
  • BtAvrcpConnectResponse() : BtAvrcpConnectResponse
  • BtAvrcpControllerApplicationWindow() : BtAvrcpControllerApplicationWindow
  • BtAvrcpControllerDeviceListItem() : BtAvrcpControllerDeviceListItem
  • BtAvrcpControllerDeviceListWindow() : BtAvrcpControllerDeviceListWindow
  • BtAvrcpDeRegisterRequest() : BtAvrcpDeRegisterRequest
  • BtAvrcpDeviceListWin() : BtAvrcpDeviceListWin
  • BtAvrcpNmaConnect() : BtAvrcpNmaConnect
  • BtAvrcpNmaDisconnect() : BtAvrcpNmaDisconnect
  • BtAvrcpNmaPanelPassThrough() : BtAvrcpNmaPanelPassThrough
  • BtAvrcpNmaRawFrame() : BtAvrcpNmaRawFrame
  • BtAvrcpNotificationMessage() : BtAvrcpNotificationMessage
  • BtAvrcpOperationRequestResponse() : BtAvrcpOperationRequestResponse
  • BtAvrcpOperationService() : BtAvrcpOperationService, BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse, BtAvrcpConnectResponse
  • BtAvrcpOperationServiceMessage() : BtAvrcpOperationServiceMessage
  • BtAvrcpPanelPassThroughParams() : BtAvrcpPanelPassThroughParams
  • BtAvrcpPanelPassThroughRequest() : BtAvrcpPanelPassThroughRequest
  • BtAvrcpPanelServiceImpl() : BtAvrcpPanelServiceImpl
  • BtAvrcpProfileOperationService() : BtAvrcpProfileOperationService
  • BtAvrcpProfileRegistrationService() : BtAvrcpProfileRegistrationService
  • BtAvrcpRawFrameParams() : BtAvrcpRawFrameParams
  • BtAvrcpRawFrameRequest() : BtAvrcpRawFrameRequest
  • BtAvrcpRegisterParams() : BtAvrcpRegisterParams
  • BtAvrcpRegisterRequest() : BtAvrcpRegisterRequest
  • BtAvrcpRegistrationService() : BtAvrcpRegistrationService, BtAvrcpRegisterRequest, BtAvrcpDeRegisterRequest
  • BtAvrcpRequest() : BtAvrcpRequest
  • BtAvrcpRequestStateChangedMessage() : BtAvrcpRequestStateChangedMessage
  • BtAvrcpService() : BtAvrcpService, BtAvrcpRequest
  • BtAvrcpSubunitInfoParams() : BtAvrcpSubunitInfoParams
  • BtAvrcpSubunitInfoRequest() : BtAvrcpSubunitInfoRequest
  • BtAvrcpUnitInfoParams() : BtAvrcpUnitInfoParams
  • BtAvrcpUnitInfoRequest() : BtAvrcpUnitInfoRequest
  • BtBipAbortIndArg() : BtBipAbortIndArg
  • BtBipAttachmentDesc() : BtBipAttachmentDesc
  • BtBipAttachmentFormat() : BtBipAttachmentFormat
  • BtBipClientService() : BtBipClientService
  • BtBipConnectIndArg() : BtBipConnectIndArg
  • BtBipDeleteImageIndArg() : BtBipDeleteImageIndArg
  • BtBipDisconnectIndArg() : BtBipDisconnectIndArg
  • BtBipGetImageIndArg() : BtBipGetImageIndArg
  • BtBipGetImagePropertiesIndArg() : BtBipGetImagePropertiesIndArg
  • BtBipGetImagesListIndArg() : BtBipGetImagesListIndArg
  • BtBipGetImagingCapabilitiesIndArg() : BtBipGetImagingCapabilitiesIndArg
  • BtBipGetLinkedAttachmentIndArg() : BtBipGetLinkedAttachmentIndArg
  • BtBipGetLinkedThumbnailIndArg() : BtBipGetLinkedThumbnailIndArg
  • BtBipImage() : BtBipImage
  • BtBipImageHdlDesc() : BtBipImageHdlDesc
  • BtBipImageList() : BtBipImageList
  • BtBipImagingCapabilities() : BtBipImagingCapabilities
  • BtBipMsgArg() : BtBipMsgArg
  • BtBipOpFinishedArg() : BtBipOpFinishedArg
  • BtBipProgressMsg() : BtBipProgressMsg
  • BtBipPutImageCompleteArg() : BtBipPutImageCompleteArg
  • BtBipPutImageIndArg() : BtBipPutImageIndArg
  • BtBipPutLinkedAttachmentCompleteArg() : BtBipPutLinkedAttachmentCompleteArg
  • BtBipPutLinkedAttachmentIndArg() : BtBipPutLinkedAttachmentIndArg
  • BtBipPutLinkedThumbnailCompleteArg() : BtBipPutLinkedThumbnailCompleteArg
  • BtBipPutLinkedThumbnailIndArg() : BtBipPutLinkedThumbnailIndArg
  • BtBipServerNotificationMsgArg() : BtBipServerNotificationMsgArg
  • BtBipServerService() : BtBipServerService, BtBipImageHdl
  • BtBppClientService() : BtBppClientService, BtBppController
  • BtBppController() : BtBppController, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBppReq
  • BtBppReq() : BtBppReq
  • BtBppRequestStateChangedMessage() : BtBppRequestStateChangedMessage
  • BtBppServerService() : BtBppServerService, BtBppController
  • BtBppService() : BtBppService, BtBppController
  • BtBppSndAbortReqRequest() : BtBppSndAbortReqRequest, BtBppController, BtBppClientService
  • BtBppSndFilePushReqRequest() : BtBppSndFilePushReqRequest, BtBppController, BtBppClientService
  • BtBppSndGetRefObjRspRequest() : BtBppSndGetRefObjRspRequest, BtBppController
  • BtCancelableBroadcastRequest() : BtCancelableBroadcastRequest
  • BtCancelableMulticastRequest() : BtCancelableMulticastRequest
  • BtCancelableRequest() : BtCancelableRequest
  • BtCancelSearchMessage() : BtCancelSearchMessage
  • BtCancelVerifyMessage() : BtCancelVerifyMessage
  • BtCloseMessage() : BtCloseMessage
  • BtConnectabilityMessage() : BtConnectabilityMessage
  • BtConnection() : BtMultiConnectionController::BtConnection
  • BtConnectionBasedController() : BtConnectionBasedController
  • BtConnectionlessController() : BtConnectionlessController
  • BtConnectRequest() : BtConnectRequest
  • BtController() : BtController, BtServiceRequest, BtRequest
  • BtDevice() : BtDevice
  • BtDeviceAddress() : BtDeviceAddress
  • BtDeviceAddressGenericObject() : BtDeviceAddressGenericObject
  • BtDeviceAndServiceClass() : BtDeviceAndServiceClass
  • BtDeviceDetailWindow() : BtDeviceDetailWindow
  • BtDeviceFilter() : BtDeviceFilter
  • BtDeviceList() : BtDeviceList, BtDeviceListIterator, BtDeviceListConstantIterator
  • BtDeviceListBidirectionalIterator() : BtDeviceList::BtDeviceListBidirectionalIterator, BtDeviceList::BtDeviceListNode, BtDeviceList
  • BtDeviceListConstantIterator() : BtDeviceListConstantIterator, BtDeviceListConstantReverseIterator, BtDeviceList
  • BtDeviceListConstantReverseIterator() : BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceList
  • BtDeviceListItem() : BtDeviceListItem
  • BtDeviceListIterator() : BtDeviceListIterator, BtDeviceList
  • BtDeviceListNode() : BtDeviceList::BtDeviceListNode
  • BtDeviceListProvider() : BtDeviceListProvider
  • BtDeviceListReverseIterator() : BtDeviceListReverseIterator, BtDeviceList
  • BtDeviceListWindow() : BtDeviceListWindow
  • BtDevicePairMessage() : BtDevicePairMessage
  • BtDevicePairRequest() : BtDevicePairRequest
  • BtDeviceSearchMessage() : BtDeviceSearchMessage
  • BtDeviceSearchModeWindow() : BtDeviceSearchModeWindow
  • BtDeviceSearchRequest() : BtDeviceSearchRequest
  • BtDeviceTrustMessage() : BtDeviceTrustMessage
  • BtDeviceTrustRequest() : BtDeviceTrustRequest
  • BtDeviceUnpairMessage() : BtDeviceUnpairMessage
  • BtDeviceUnpairRequest() : BtDeviceUnpairRequest
  • BtDeviceUntrustMessage() : BtDeviceUntrustMessage
  • BtDeviceUntrustRequest() : BtDeviceUntrustRequest
  • BtDisconnectRequest() : BtDisconnectRequest
  • BtDiscoverabilityMessage() : BtDiscoverabilityMessage
  • BtDunApplicationMessage() : BtDunApplicationMessage
  • BtDunConnectMessage() : BtDunConnectMessage
  • BtDunDisconnectMessage() : BtDunDisconnectMessage
  • BtDunProfileService() : BtDunProfileService
  • BtDunRequestStateChangedMessage() : BtDunRequestStateChangedMessage
  • BtDunService() : BtDunService
  • BtEvent() : BtEvent
  • BtFaxApplicationMessage() : BtFaxApplicationMessage
  • BtFaxConnectMessage() : BtFaxConnectMessage
  • BtFaxDisconnectMessage() : BtFaxDisconnectMessage
  • BtFaxProfileService() : BtFaxProfileService
  • BtFaxRequestStateChangedMessage() : BtFaxRequestStateChangedMessage
  • BtFaxService() : BtFaxService
  • BtFeatureSetAvailable() : BtApplication
  • BtGapAndSdapApplicationMessage() : BtGapAndSdapApplicationMessage
  • BtGapAndSdapNotificationMessage() : BtGapAndSdapNotificationMessage
  • BtGapAndSdapRemoteRequestMessage() : BtGapAndSdapRemoteRequestMessage
  • BtGapAndSdapRequestMessage() : BtGapAndSdapRequestMessage
  • BtHfAudioPathWindow() : BtHfAudioPathWindow
  • BtHfCmaAtChldOneCommandReceived() : BtHfCmaAtChldOneCommandReceived
  • BtHfCmaAudioAsynchronous() : BtHfCmaAudioAsynchronous
  • BtHfCmaCheckPendingAudioCallback() : BtHfCmaCheckPendingAudioCallback
  • BtHfCmaMOC() : BtHfCmaMOC
  • BtHfCmaMTC() : BtHfCmaMTC
  • BtHfCmaPhoneNumberRequired() : BtHfCmaPhoneNumberRequired
  • BtHfFeatureListWin() : BtHfFeatureListWin
  • BtHfInbandSettingWin() : BtHfInbandSettingWin
  • BtHfInsertPhoneNr() : BtHfAppPlugin
  • BtHfNmaAudioConnectionLost() : BtHfNmaAudioConnectionLost
  • BtHfNmaCallEvent() : BtHfNmaCallEvent
  • BtHfNmaConnect() : BtHfNmaConnect
  • BtHfNmaDisconnect() : BtHfNmaDisconnect
  • BtHfNmaLowPowerModeNotPossible() : BtHfNmaLowPowerModeNotPossible
  • BtHfNmaMicrophoneGain() : BtHfNmaMicrophoneGain
  • BtHfNmaSpeakerGain() : BtHfNmaSpeakerGain
  • BtHfNmaTransferAudioToAccessory() : BtHfNmaTransferAudioToAccessory
  • BtHfNmaTransferAudioToPhone() : BtHfNmaTransferAudioToPhone
  • BtHfNotificationMessage() : BtHfNotificationMessage
  • BtHfProfileService() : BtHfProfileService, BtHfProfileWindow
  • BtHfProfileWindow() : BtHfProfileWindow
  • BtHfProvider() : BtHfProvider
  • BtHfRecord() : BtHfRecord
  • BtHfRequestStateChangedMessage() : BtHfRequestStateChangedMessage
  • BtHfService() : BtHfService
  • BtHfSupportedProfileMessage() : BtHfSupportedProfileMessage
  • BtHfVolumeSettingsWin() : BtHfVolumeSettingsWin
  • BtHsCmaAudioAsynchronous() : BtHsCmaAudioAsynchronous
  • BtHsCmaAudioTransferOutOfCall() : BtHsCmaAudioTransferOutOfCall
  • BtHsCmaCheckPendingAudioCallback() : BtHsCmaCheckPendingAudioCallback
  • BtHsCmaEnterLowPowerMode() : BtHsCmaEnterLowPowerMode
  • BtHsCmaHangUp() : BtHsCmaHangUp
  • BtHsConnectionSettingWin() : BtHsConnectionSettingWin
  • BtHsInbandSettingWin() : BtHsInbandSettingWin
  • BtHsNmaAudioConnectionLost() : BtHsNmaAudioConnectionLost
  • BtHsNmaCallEvent() : BtHsNmaCallEvent
  • BtHsNmaConnect() : BtHsNmaConnect
  • BtHsNmaDisconnect() : BtHsNmaDisconnect
  • BtHsNmaLowPowerModeNotPossible() : BtHsNmaLowPowerModeNotPossible
  • BtHsNmaMicrophoneGain() : BtHsNmaMicrophoneGain
  • BtHsNmaSpeakerGain() : BtHsNmaSpeakerGain
  • BtHsNmaTransferAudioToAccessory() : BtHsNmaTransferAudioToAccessory
  • BtHsNmaTransferAudioToPhone() : BtHsNmaTransferAudioToPhone
  • BtHsNotificationMessage() : BtHsNotificationMessage
  • BtHsProfileService() : BtHsProfileService
  • BtHsRequestStateChangedMessage() : BtHsRequestStateChangedMessage
  • BtHsService() : BtHsService
  • BtHsSupportedProfileMessage() : BtHsSupportedProfileMessage
  • BtHsVolumeSettingsWin() : BtHsVolumeSettingsWin
  • BtIndicatorMsg() : BtIndicatorMsg
  • BtJsr82Url() : BtJsr82Url
  • BtLocalNameMessage() : BtLocalNameMessage
  • BtLocalRequest() : BtLocalRequest
  • BtLocalSettings() : BtLocalSettings
  • BtLocalSettingsMessage() : BtLocalSettingsMessage
  • BtMultiConnectionController() : BtMultiConnectionController
  • BtObexAbortRequest() : BtObexAbortRequest, BtObexController, BtObexClientService
  • BtObexClientAbortEvent() : BtObexClientAbortEvent
  • BtObexClientAddr() : BtObexClientAddr
  • BtObexClientAddrResultNotifier() : BtObexClientAddrResultNotifier, BtObexTransport
  • BtObexClientConnectEvent() : BtObexClientConnectEvent
  • BtObexClientDisconnectEvent() : BtObexClientDisconnectEvent
  • BtObexClientEvent() : BtObexClientEvent
  • BtObexClientGetEvent() : BtObexClientGetEvent
  • BtObexClientNmaDataBufferIndication() : BtObexClientNmaDataBufferIndication
  • BtObexClientNmaDataInidication() : BtObexClientNmaDataInidication
  • BtObexClientNmaHeaderIndication() : BtObexClientNmaHeaderIndication
  • BtObexClientNmaHeaderSent() : BtObexClientNmaHeaderSent
  • BtObexClientNmaTransportDisconnect() : BtObexClientNmaTransportDisconnect
  • BtObexClientNotificationMessage() : BtObexClientNotificationMessage
  • BtObexClientObserverImpl() : BtObexClientObserverImpl, BtObexImpl
  • BtObexClientOperationEvent() : BtObexClientOperationEvent
  • BtObexClientOperationRequest() : BtObexClientOperationRequest
  • BtObexClientPutEvent() : BtObexClientPutEvent
  • BtObexClientRequestStateChangedMessage() : BtObexClientRequestStateChangedMessage
  • BtObexClientService() : BtObexClientService, BtObexController, BtObexClientServiceObserver
  • BtObexClientServiceImpl() : BtObexClientServiceImpl
  • BtObexClientServiceObserver() : BtObexClientServiceObserver
  • BtObexClientSetPathEvent() : BtObexClientSetPathEvent
  • BtObexConnection() : BtObexController::BtObexConnection
  • BtObexConnectRequest() : BtObexConnectRequest, BtObexController, BtObexClientService
  • BtObexDataBufferIndicationEvent() : BtObexDataBufferIndicationEvent
  • BtObexDataIndicationEvent() : BtObexDataIndicationEvent
  • BtObexDisconnectRequest() : BtObexDisconnectRequest, BtObexController, BtObexClientService
  • BtObexEvent() : BtObexEvent
  • BtObexGetRequest() : BtObexGetRequest, BtObexController, BtObexClientService
  • BtObexHeaderIndicationEvent() : BtObexHeaderIndicationEvent
  • BtObexHeaderSentEvent() : BtObexHeaderSentEvent
  • BtObexImpl() : BtObexImpl, BtObexServerObserverImpl, BtObexClientObserverImpl
  • BtObexPutRequest() : BtObexPutRequest, BtObexController, BtObexClientService
  • BtObexRegisterClientEvent() : BtObexRegisterClientEvent
  • BtObexRegisterClientRequest() : BtObexRegisterClientRequest, BtObexController, BtObexClientService
  • BtObexRegisterServerEvent() : BtObexRegisterServerEvent
  • BtObexRegisterServerRequest() : BtObexRegisterServerRequest, BtObexServerService, BtObexController
  • BtObexRequest() : BtObexRequest, BtObexService
  • BtObexResponseCode() : BtObexResponseCode
  • BtObexSddbImpl() : BtObexSddbImpl
  • BtObexSddbServiceObserverImpl() : BtObexSddbServiceObserverImpl, BtObexImpl
  • BtObexServerAbortIndicationEvent() : BtObexServerAbortIndicationEvent
  • BtObexServerAddr() : BtObexServerAddr
  • BtObexServerConnectIndicationEvent() : BtObexServerConnectIndicationEvent
  • BtObexServerDisconnectIndicationEvent() : BtObexServerDisconnectIndicationEvent
  • BtObexServerEvent() : BtObexServerEvent
  • BtObexServerGetIndicationEvent() : BtObexServerGetIndicationEvent
  • BtObexServerNmaAbort() : BtObexServerNmaAbort
  • BtObexServerNmaConnect() : BtObexServerNmaConnect
  • BtObexServerNmaDataBufferIndication() : BtObexServerNmaDataBufferIndication
  • BtObexServerNmaDataInidication() : BtObexServerNmaDataInidication
  • BtObexServerNmaDisconnect() : BtObexServerNmaDisconnect
  • BtObexServerNmaGet() : BtObexServerNmaGet
  • BtObexServerNmaHeaderIndication() : BtObexServerNmaHeaderIndication
  • BtObexServerNmaHeaderSent() : BtObexServerNmaHeaderSent
  • BtObexServerNmaPut() : BtObexServerNmaPut
  • BtObexServerNmaSetPath() : BtObexServerNmaSetPath
  • BtObexServerNmaTransportDisconnect() : BtObexServerNmaTransportDisconnect
  • BtObexServerNotificationMessage() : BtObexServerNotificationMessage
  • BtObexServerObserverImpl() : BtObexServerObserverImpl, BtObexServerAddr, BtObexImpl
  • BtObexServerPutIndicationEvent() : BtObexServerPutIndicationEvent
  • BtObexServerRequestStateChangedMessage() : BtObexServerRequestStateChangedMessage
  • BtObexServerService() : BtObexServerService, BtObexServerServiceObserver, BtObexController
  • BtObexServerServiceImpl() : BtObexServerServiceImpl
  • BtObexServerServiceObserver() : BtObexServerServiceObserver
  • BtObexServerSetPathIndicationEvent() : BtObexServerSetPathIndicationEvent
  • BtObexService() : BtObexService, BtObexServiceObserver, BtObexController
  • BtObexServiceObserver() : BtObexServiceObserver
  • BtObexSetClientAddrInfo() : BtObexClientAddr
  • BtObexSetPathRequest() : BtObexSetPathRequest, BtObexController, BtObexClientService
  • BtObexTransport() : BtObexTransport, BtObexServerAddr, BtObexClientAddr
  • BtObexTransportDisconnectEvent() : BtObexTransportDisconnectEvent
  • BtObexUnregisterClientRequest() : BtObexUnregisterClientRequest, BtObexController, BtObexClientService
  • BtObexUnregisterEvent() : BtObexUnregisterEvent
  • BtObexUnregisterServerRequest() : BtObexUnregisterServerRequest, BtObexServerService, BtObexController
  • BtObservableService() : BtObservableService, BtServiceObserver
  • BtOpenMessage() : BtOpenMessage
  • BtOperationBase() : BtOperationBase
  • BtOperationSelectDevice() : BtOperationSelectDevice
  • BtOperationSelectDeviceAndPerformServiceVerify() : BtOperationSelectDeviceAndPerformServiceVerify, BtServiceVerifyResult
  • BtPairabilityMessage() : BtPairabilityMessage
  • BtPasskeyRequiredMessage() : BtPasskeyRequiredMessage
  • BtPasskeyRequiredWindow() : BtPasskeyRequiredWindow
  • BtPaSupportedProfileMessage() : BtPaSupportedProfileMessage
  • BtProfileActivationMessage() : BtProfileActivationMessage
  • BtQuerySupportedProfilesMessage() : BtQuerySupportedProfilesMessage
  • BtQuerySupportedProfilesRequest() : BtQuerySupportedProfilesRequest
  • BtRemoteDeviceListOptions() : BtApplication
  • BtRemoteDeviceMessage() : BtRemoteDeviceMessage
  • BtRemoteDeviceNameMessage() : BtRemoteDeviceNameMessage
  • BtRemoteDevicePairMessage() : BtRemoteDevicePairMessage
  • BtRequest() : BtRequest
  • BtRequestMessage() : BtRequestMessage
  • BtRequestOperationMessage() : BtRequestOperationMessage
  • BtRequestRespondRequest() : BtRequestRespondRequest
  • BtRequestRunningWindow() : BtRequestRunningWindow
  • BtRequestStateChangedMessage() : BtRequestStateChangedMessage
  • BtRespondAuthorizationMessage() : BtRespondAuthorizationMessage
  • BtRespondAuthorizationRequest() : BtRespondAuthorizationRequest
  • BtSddbDataElement() : BtSddbDataElement
  • BtSddbDeAlternative() : BtSddbDeAlternative
  • BtSddbDeBaseCType() : BtSddbDeBaseCType
  • BtSddbDeBigSintBase() : BtSddbDeBigSintBase
  • BtSddbDeBigUintBase() : BtSddbDeBigUintBase
  • BtSddbDeBoolean() : BtSddbDeBoolean
  • BtSddbDeByteBlockType() : BtSddbDeByteBlockType
  • BtSddbDeContainer() : BtSddbDeContainer, BtSddbDataElement
  • BtSddbDeNil() : BtSddbDeNil
  • BtSddbDeOneByteDescriptionType() : BtSddbDeOneByteDescriptionType
  • BtSddbDeSequence() : BtSddbDeSequence
  • BtSddbDeSint128() : BtSddbDeSint128
  • BtSddbDeSint16() : BtSddbDeSint16
  • BtSddbDeSint32() : BtSddbDeSint32
  • BtSddbDeSint64() : BtSddbDeSint64
  • BtSddbDeSint8() : BtSddbDeSint8
  • BtSddbDeSintBase() : BtSddbDeSintBase
  • BtSddbDeString() : BtSddbDeString
  • BtSddbDeUint128() : BtSddbDeUint128
  • BtSddbDeUint16() : BtSddbDeUint16
  • BtSddbDeUint32() : BtSddbDeUint32
  • BtSddbDeUint64() : BtSddbDeUint64
  • BtSddbDeUint8() : BtSddbDeUint8
  • BtSddbDeUintBase() : BtSddbDeUintBase
  • BtSddbDeUrl() : BtSddbDeUrl
  • BtSddbDeUuid128() : BtSddbDeUuid128
  • BtSddbDeUuid16() : BtSddbDeUuid16
  • BtSddbDeUuid32() : BtSddbDeUuid32
  • BtSddbDeUuidBase() : BtSddbDeUuidBase
  • BtSddbDeVariableLengthType() : BtSddbDeVariableLengthType
  • BtSddbEvent() : BtSddbEvent
  • BtSddbRegisterServiceEvent() : BtSddbRegisterServiceEvent
  • BtSddbRequestStateChangedMessage() : BtSddbRequestStateChangedMessage
  • BtSddbService() : BtSddbService, BtObexSddbServiceObserverImpl, BtSddbServiceObserver
  • BtSddbServiceAttribute() : BtSddbServiceAttribute, BtSddbDataElement
  • BtSddbServiceObserver() : BtSddbServiceObserver
  • BtSddbServiceRecord() : BtSddbServiceRecord, BtSddbServiceAttribute
  • BtSddbUnregisterServiceEvent() : BtSddbUnregisterServiceEvent
  • BtSendPasskeyMessage() : BtSendPasskeyMessage
  • BtSendPasskeyRequest() : BtSendPasskeyRequest
  • BtService() : BtService
  • BtServiceMessage() : BtServiceMessage
  • BtServiceObserver() : BtServiceObserver
  • BtServiceRequest() : BtServiceRequest, BtService
  • BtServiceVerifyMessage() : BtServiceVerifyMessage
  • BtServiceVerifyRequest() : BtServiceVerifyRequest, BtServiceVerifyResult
  • BtServiceVerifyResultMessage() : BtServiceVerifyResultMessage
  • BtSetRemoteDeviceNameMessage() : BtSetRemoteDeviceNameMessage
  • BtSetRemoteDeviceNameRequest() : BtSetRemoteDeviceNameRequest
  • BtSingleConnectionController() : BtSingleConnectionController, BtDisconnectRequest, BtConnectRequest
  • BtStateChangedMessage() : BtStateChangedMessage
  • BtSvrDataElement() : BtSvrDataElement
  • BtSvrServiceAttribute() : BtSvrServiceAttribute, BtSvrDataElement
  • BtSvrServiceRecord() : BtSvrServiceRecord, BtSvrServiceAttribute
  • BtTurnOnOffWindow() : BtTurnOnOffWindow
  • BtUncancelablePointToPointRequest() : BtUncancelablePointToPointRequest
  • BtUncancelableRequest() : BtUncancelableRequest
  • BubbleSortProvider() : BubbleSortProvider
  • BufferedData() : BufferedData
  • BufferedOutputStream() : BufferedOutputStream
  • ByteBuffer() : ByteBuffer
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- c -

  • CachingSortProvider() : CachingSortProvider
  • CalcCameraScalingRate() : Camera
  • CalcFileMemOvrhd() : FfsHandler
  • CalcFreeChars() : SmsEditor
  • CalcProgress() : IncrementalPdcUpdater
  • CalculateBufferSize() : StreamAudioReference
  • CalculatePlayTime() : AudioUtility
  • CalculateUserDataSize() : UserData
  • CalculatorInputMapper() : CalculatorInputMapper
  • CalendarAddRecordWin() : CalendarAddRecordWin
  • CalendarApp() : CalendarApp
  • CalendarGotoDateWin() : CalendarGotoDateWin
  • CalendarGrid() : CalendarGrid
  • CalendarGridView() : CalendarGridView
  • CalendarListWin() : CalendarListWin
  • CalendarMonthSelector() : CalendarMonthSelector
  • CalendarMonthSelectorView() : CalendarMonthSelectorView
  • CalendarMonthWin() : CalendarMonthWin
  • CalendarProvider() : CalendarProvider
  • CalendarRecord() : CalendarRecord
  • CalendarRecordsList() : CalendarRecordsList
  • CalendarRecordsListBoxModel() : CalendarRecordsListBoxModel
  • Call() : SingleArgHook< T >
  • CallAcceptMsg() : CallAcceptMsg
  • CallApiRc() : EnumTranslationTable
  • Callback() : StreamingCallback
  • CallbackRead() : StreamingCallback
  • CallbackWrite() : StreamingCallback
  • CallBarredMsg() : CallBarredMsg
  • CallBarringActivatedMsg() : CallBarringActivatedMsg
  • CallBarringDeactivatedMsg() : CallBarringDeactivatedMsg
  • CallBarringHandler() : CallBarringHandler
  • CallBarringPasswordChangedMsg() : CallBarringPasswordChangedMsg
  • CallBarringStatusMsg() : CallBarringStatusMsg
  • CallControlIndMsg() : CallControlIndMsg
  • CallControlInfoMsg() : CallControlInfoMsg
  • CallControlSetupIndArg() : CallControlSetupIndArg
  • CallControlSsIndArg() : CallControlSsIndArg
  • CallControlUssdIndArg() : CallControlUssdIndArg
  • CallDeflectionErrIndicationMsg() : CallDeflectionErrIndicationMsg
  • CallDeflectionHandler() : CallDeflectionHandler
  • CallDeflectionIndArg() : CallDeflectionIndArg
  • CallDeflectionIndMsg() : CallDeflectionIndMsg
  • CallDeflectionRejectedMsg() : CallDeflectionRejectedMsg
  • CallDeflectSsReqArg() : CallDeflectSsReqArg
  • CallDiscIndArg() : CallDiscIndArg
  • CallDisconnectedMsg() : CallDisconnectedMsg
  • CallDisconnectingMsg() : CallDisconnectingMsg
  • CallDiscReqArg() : CallDiscReqArg
  • CalledPartyAlertingMsg() : CalledPartyAlertingMsg
  • CallErrorCause() : EnumTranslationTable
  • CallEventMsg() : CallEventMsg
  • CallForwardingActivatedMsg() : CallForwardingActivatedMsg
  • CallForwardingActiveMsg() : CallForwardingActiveMsg
  • CallForwardingDeactivatedMsg() : CallForwardingDeactivatedMsg
  • CallForwardingErasedMsg() : CallForwardingErasedMsg
  • CallForwardingHandler() : CallForwardingHandler
  • CallForwardingRegisteredMsg() : CallForwardingRegisteredMsg
  • CallForwardingStatusMsg() : CallForwardingStatusMsg
  • CallHandler() : CallHandler
  • CallHdl() : CallHdl
  • CallHdlBase() : CallHdlBase
  • CallHeldMsg() : CallHeldMsg
  • CallHoldCnfArg() : CallHoldCnfArg
  • CallHoldRejArg() : CallHoldRejArg
  • CallHoldRejectedMsg() : CallHoldRejectedMsg
  • CallIndArg() : CallIndArg
  • CallIndCallControlInfoArg() : CallIndCallControlInfoArg
  • CallInfoMsg() : CallInfoMsg
  • CallInSetupExists() : InputContext
  • CallIsWaitingMsg() : CallIsWaitingMsg
  • CallNotifyMsg() : CallNotifyMsg
  • CallOnHoldMsg() : CallOnHoldMsg
  • CallProgressIndArg() : CallProgressIndArg
  • CallRelatedSsCnfArg() : CallRelatedSsCnfArg
  • CallRelatedSsCode() : EnumTranslationTable
  • CallRelatedSsRejArg() : CallRelatedSsRejArg
  • CallRelatedSsReqArg() : CallRelatedSsReqArg
  • CallRelCnfArg() : CallRelCnfArg
  • CallReleaseMsg() : CallReleaseMsg
  • CallRelIndArg() : CallRelIndArg
  • CallRetrievedMsg() : CallRetrievedMsg
  • CallSelectedNumber() : PhonebookApp
  • CallSetupBySimtTkReqArg() : CallSetupBySimtTkReqArg
  • CallSetupProgressMsg() : CallSetupProgressMsg
  • CallSsAction() : CallSsAction
  • CallStackAdr() : InternalTracer
  • CallWaitingActivatedMsg() : CallWaitingActivatedMsg
  • CallWaitingDeactivatedMsg() : CallWaitingDeactivatedMsg
  • CallWaitingHandler() : CallWaitingHandler
  • CallWaitingStatusMsg() : CallWaitingStatusMsg
  • Camera() : Camera
  • CameraMsgStartViewfinding() : CameraMsgStartViewfinding
  • CameraMsgStopViewfinding() : CameraMsgStopViewfinding
  • CameraOptionSettingsWin() : CameraOptionSettingsWin
  • CameraSettings() : CameraSettings
  • CameraSettingsWin() : CameraSettingsWin
  • CanActivateAudioPaths() : AudioAccessoryDetails
  • CanCancelRequest() : BtRequest
  • Cancel() : ObexOppDataSinkPushServer, BtUncancelableRequest, BtServiceVerifyRequest, BtServiceRequest, BtRequest, BtDeviceSearchRequest, BtBipServerService, FileChunkOperator, VrHandler
  • CancelAction() : CancelAction
  • CancelAddNumber() : PbAdvDetails
  • CancelAllRequests() : SimAccessor
  • CancelAllSimRequests() : DataHandler
  • CancelCamera() : CameraCaptureWin
  • CancelCapture() : StillCamera
  • CancelEdit() : PbDetails
  • CancelHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • CancelOperation() : ObexServerOppImpl, ObexOppServer, File
  • CancelRedialling() : CallHdl
  • CancelRequest() : BtRequest
  • CancelSearchRequest() : BtApplicationDeviceSearchRequest
  • CancelSetup() : PppDataConn, DataConn
  • CancelSmoothScrolling() : AbstractGrid
  • CanDisplay() : FontManager
  • CanEdit() : PropertyEditor
  • CanExecuteRequest() : BtRequest
  • CanLinkAudioPath() : AudioPathManager
  • CanPlay() : StreamAudioPlayer, MmfPlayer, DwdPlayer
  • CanPlayTogetherWith() : CustomSmafPhraseAudioReference, AudioReference
  • CanResume() : StreamAudioPlayer, MmfPlayer, DwdPlayer, MapiAudioPlayer
  • CanSeek() : StreamWriter, StreamReader
  • CanSuspend() : StreamAudioPlayer, MmfPlayer, DwdPlayer, MapiAudioPlayer
  • Capacity() : Vector< T >
  • Capture() : StillCamera
  • Caret() : Caret
  • CArray() : CArray< T >
  • Cast() : BtObexClientNmaTransportDisconnect, BtObexClientNmaDataInidication, BtObexClientNmaDataBufferIndication, BtObexClientNmaHeaderIndication, BtObexClientNmaHeaderSent, BtObexServerNmaTransportDisconnect, BtObexServerNmaDataInidication, BtObexServerNmaDataBufferIndication, BtObexServerNmaHeaderIndication, BtObexServerNmaHeaderSent, BtObexServerNmaAbort, BtObexServerNmaPut, BtObexServerNmaGet, BtObexServerNmaSetPath, BtObexServerNmaDisconnect, BtObexServerNmaConnect, BtHsNmaCallEvent, BtHsNmaLowPowerModeNotPossible, BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHsNmaAudioConnectionLost, BtHsNmaTransferAudioToPhone, BtHsNmaTransferAudioToAccessory, BtHsNmaDisconnect, BtHsNmaConnect, BtHsCmaCheckPendingAudioCallback, BtHsCmaAudioTransferOutOfCall, BtHsCmaEnterLowPowerMode, BtHsCmaAudioAsynchronous, BtHsCmaHangUp, BtHfNmaCallEvent, BtHfNmaLowPowerModeNotPossible, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain, BtHfNmaAudioConnectionLost, BtHfNmaTransferAudioToPhone, BtHfNmaTransferAudioToAccessory, BtHfNmaDisconnect, BtHfNmaConnect, BtHfCmaCheckPendingAudioCallback, BtHfCmaAtChldOneCommandReceived, BtHfCmaAudioAsynchronous, BtHfCmaMOC, BtHfCmaMTC, BtHfCmaPhoneNumberRequired, BtBipGetImagingCapabilitiesIndArg, BtBipDeleteImageIndArg, BtBipGetLinkedAttachmentIndArg, BtBipGetLinkedThumbnailIndArg, BtBipGetImageIndArg, BtBipOpFinishedArg, BtBipGetImagePropertiesIndArg, BtBipGetImagesListIndArg, BtBipPutLinkedAttachmentCompleteArg, BtBipPutLinkedAttachmentIndArg, BtBipPutLinkedThumbnailCompleteArg, BtBipPutLinkedThumbnailIndArg, BtBipPutImageCompleteArg, BtBipPutImageIndArg, BtBipAbortIndArg, BtBipDisconnectIndArg, BtBipConnectIndArg, BtAvrcpNmaRawFrame, BtAvrcpNmaPanelPassThrough, BtAvrcpNmaDisconnect, BtAvrcpNmaConnect, SsUus1QueryReqArg, SsUus1ReqArg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, SsUus1IndArg, SsUus1QueryRejArg, SsUus1QueryIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityRejArg, SsFacilityIndArg, SsBeginAccArg, SmsGetMoreMessageStatusReqArg, SmsSetMoreMessageReqArg, SmsSendReqArg, SmsConfigIndArg, SmsGetMoreMessageStatusIndArg, SmsCapacityAvailableArg, SmsCapacityExceededArg, SmsSendRejArg, SmsSendCnfArg, SmsNewStatusReportIndArg, SmsNewMessageIndArg, SimTkRefreshNewRspArg, SimTkStopSendDtmfReqArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, BrowserTermEventArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, BrowserRegisterReqArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, ExtProactiveCmdIndArg, LanguageSettingIndArg, LanguageSelectEventArg, IdleScreenAvailEventArg, UserActivityEventArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, MenuSelectionReqArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkRefreshNewReqArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, SimTkInterfaceIndArg, SimTkSendDtmfEndIndArg, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimBrowserTermResArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, TermRspCnfArg, ExtProactiveCmdCnfArg, ExtProactiveCmdReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, EndSimToolkitIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, MenuSelectionRejArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg, SimTkSsIndArg, SimTkSmsPpIndArg, SimTkCallSetupIndArg, SimModifyLockReqArg, BdnReqArg, FdnReqArg, SimMruPropertyUpdReqArg, SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadReqArg, SimODynReadReqArg, SimCmiReadReqArg, UsimFilePropertyReqArg, UsimLangUpdReqArg, UsimEstReadReqArg, UsimSmsParamUpdReqArg, UsimCardTypeReadReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimLangReadReqArg, UsimPsLociReadReqArg, UsimCsLociReadReqArg, UsimPlmnReadReqArg, UsimUstReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCfufUpdReqArg, CphsVmwfUpdReqArg, CphsOnsReadReqArg, CphsOnmReadReqArg, CphsCfufReadReqArg, CphsVmwfReadReqArg, CphsIstReadReqArg, SimFileInfoReqArg, SimSpnReadReqArg, SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg, SimGenericReqArg, SimPuctUpdReqArg, SimPuctReadReqArg, SimAcmMaxUpdReqArg, SimAcmMaxReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSstReadReqArg, SimRefreshReqArg, SimModifyLockIndArg, BdnIndArg, FdnIndArg, SimFullAccessIndArg, SimLockStatusIndArg, SimInfoIndArg, SimInitIndArg, SimMruPropertyRefreshIndArg, SimMruPropertyUpdCnfArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimUpdCnfArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimMccMncIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimGenericIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, SimRefreshIndArg, SimErrorIndArg, ControlHwDataOnlyArg, StopSignalStrengthListeningArg, StartSignalStrengthListeningArg, StopBatteryLoadListeningArg, ClientDeregistrationArg, ClientRegistrationArg, PowerDownReqArg, OmPowerUpArg, PowerDownIndArg, OmControlIndArg, PowerDownCnfArg, PlmnListReqArg, GprsClassReqArg, PlmnInfoReqArg, DetachReqArg, AttachReqArg, PrefServiceSetReqArg, PrefPlmnChangeArg, PlmnListAbortArg, GprsClassIndArg, AttachAllowedIndArg, DetachCnfArg, AttachRejArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListRejArg, PlmnListCnfArg, UsimPbReadCnfArg, UsimPbStopReqArg, UsimPbFillStatusReqArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, UsimPbSelectReqArg, UsimPbLocationReqArg, PbCountReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, PbInfoReadReqArg, UsimPbReadyIndArg, UsimPbUidRefreshIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg, UsimPbLocationIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, PbInfoReadIndArg, OmRatChangeReqArg, OmBandStatusReqArg, OmMultiSlotReqArg, OmRatChangeIndArg, OmRatChangeCnfArg, OmBandStatusCnfArg, OmMultiSlotIndArg, MnNetworkSearchModeReqArg, MnTriggerReqArg, HomezoneIndArg, BandSelectionIndArg, TestparamReportArg, MnInformationIndArg, CellInfoIndArg, ConnectionIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, ClearBlacklistReqArg, RediallingDisabledIndArg, RedialRejArg, MocSetupReqArg, ClearBlackListCnfArg, AutoCallRestrictIndArg, RedialStopIndArg, RedialSetupIndArg, RedialIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, MocSetupRejArg, EngineeringModeControlRequestArg, OmSetTermProfileReqArg, OmGetTermProfileReqArg, OmFactoryResetIndArg, BandSelectionReqArg, TestparamReqArg, ImeiReadReqArg, BootDispatchingArg, EccListIndArg, CfuDataIndArg, EngineeringModeControlResponseArg, OmSetTermProfileRejArg, OmSetTermProfileCnfArg, OmGetTermProfileCnfArg, AccessoryIndArg, ImeiReadIndArg, SignalStrengthLevelIndArg, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsConcRefNumReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsSetWaitingReqArg, MdhRemoveViewReqArg, MdhMakeViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSetStorageReqArg, MdhSmsUpdStatusReqArg, MdhSmsStatusReqArg, MdhRegistrationReqArg, MdhDeregistrationReqArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsConcRefNumIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg, MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsStorageRefreshIndArg, MdhSmsRefreshIndArg, MdhNewStatusReportIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg, IconDescReadReqArg, ImageReadReqArg, IconDescReadIndArg, ImageReadIndArg, ChargeUnitsReqArg, SetChargeUnitsArg, ChargeReqArg, SetAutoChargeArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, CallDeflectSsReqArg, CallDeflectionIndArg, CbsStopReqArg, CbsStartReqArg, CbsNewDataRejArg, CbsLimitIndArg, CbsStopCnfArg, CbsStartCnfArg, CbsStopRejArg, CbsStartRejArg, CbsNewDataIndArg, RedialQueryReqArg, RejectCallsIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, MocSetupRejIndArg, CallIndCallControlInfoArg, RedialStatusIndArg, CallSetupBySimtTkReqArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, DtmfBufferClearedIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg, AtAccessoryRegisterCnfArg, AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtPbInfoIndArg, AtPbListCnfArg, AtPbSelectCnfArg, AtAlphaTagCnfArg, AtAccessoryRegisterReqArg, AtGenericCmdReqArg, AtPbListReqArg, AtPbSelectReqArg, AtAlphaTagReqArg, VrPropertyResultIndArg, VrWarningIndArg, VrErrorIndArg, VrG2AResultIndArg, VrStoreTemplateReqArg, VrStopRecogIndArg, VrAbortEngineIndArg, VrTrainResultIndArg, VrRecogResultIndArg, VrIntrmRecResultIndArg, VrSayNameIndArg, VrLoadTemplateReqArg, VrInitCnfArg, VrParamReqArg, SerialTerminalArg, SaLocationErrArg, SaMolrResultArg, MeasurementDataArg, AbortResArg, LcsMolrResultArg, LocationNotifInvokeArg
  • Category() : AbstractDevice, Message
  • cb_capture_finished() : CameraCaptureWin, CameraApp
  • cb_image_captured() : CameraCaptureWin, CameraApp
  • cb_image_encoded() : CameraCaptureWin, CameraApp
  • CbmiProvider() : CbmiProvider
  • CbmiRangeProvider() : CbmiRangeProvider
  • Cbs() : Cbs, DataCodingScheme
  • CbsDispatcher() : CbsDispatcher
  • CbsFilterList() : CbsFilterList
  • CbsHandler() : CbsHandler
  • CbsLimitIndArg() : CbsLimitIndArg
  • CbsLimitMsg() : CbsLimitMsg
  • CbsNewDataIndArg() : CbsNewDataIndArg
  • CbsNewDataMsg() : CbsNewDataMsg
  • CbsNewDataRejArg() : CbsNewDataRejArg
  • CbsStartCnfArg() : CbsStartCnfArg
  • CbsStartDispatcher() : CbsStartDispatcher
  • CbsStartRejArg() : CbsStartRejArg
  • CbsStartReqArg() : CbsStartReqArg
  • CbsStopCnfArg() : CbsStopCnfArg
  • CbsStopDispatcher() : CbsStopDispatcher
  • CbsStopRejArg() : CbsStopRejArg
  • CbsStopReqArg() : CbsStopReqArg
  • CcbsRecallMsg() : CcbsRecallMsg
  • CcbsResultMsg() : CcbsResultMsg
  • CcbsStatusMsg() : CcbsStatusMsg
  • Cell() : Cell
  • CellInfoIndArg() : CellInfoIndArg
  • CellInfoMsg() : CellInfoMsg
  • CellParam() : CellParam
  • CenteredTextIndicator() : CenteredTextIndicator
  • CfuDataIndArg() : CfuDataIndArg
  • CfuService() : CfuService
  • CfuServiceArray() : CfuServiceArray
  • CfuStatusMsg() : CfuStatusMsg
  • ChangeActiveDevice() : BtAvrcpPanelApplication
  • ChangeChv() : SimChvHandler, SimAccessor
  • ChangeColor() : Led
  • ChangeDir() : FfsHandler, RamHandler, FatHandler
  • ChangeGprsClass() : PlmnHandler
  • ChangeMenuAccessor() : Menu
  • ChangeMenuAction() : PbAbstractWin
  • ChangePassword() : CallBarringHandler
  • ChangePhoneticSelection() : ChineseT9Wrapper
  • ChangePin() : SsHandler, InputParser, PinAction
  • ChangePin2() : SsHandler, InputParser
  • ChangePreferedRatMode() : PlmnHandler
  • ChangePreferredStorageMedia() : SmsHandler, SimPduHandler, DataHandler
  • ChangePrefService() : PlmnHandler
  • ChangeRatMode() : PlmnHandler
  • ChangeRequestState() : BtObexRequest, BtRequestRespondRequest, BtRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBppReq, BtAvrcpRequest
  • ChangeRequestStateForCancel() : BtRequest
  • ChangeType() : PhoneNumber
  • characters() : WbxmlParserRel
  • CharactersHandler() : XMLParser
  • Charge() : Charger
  • ChargeIndArg() : ChargeIndArg
  • ChargeReqArg() : ChargeReqArg
  • ChargerInfoMsg() : ChargerInfoMsg
  • ChargeUnitsIndArg() : ChargeUnitsIndArg
  • ChargeUnitsReqArg() : ChargeUnitsReqArg
  • CharInputMapItem() : CharInputMapItem
  • CharItem() : CharItem
  • Check() : MimeCoder
  • CheckBox() : CheckBox
  • CheckBoxAction() : CheckBoxAction
  • CheckBoxControl() : CheckBoxControl
  • CheckBoxControlView() : CheckBoxControlView
  • CheckBoxItem() : CheckBoxItem
  • CheckBoxList() : CheckBoxList
  • CheckBoxListView() : CheckBoxListView
  • CheckBoxModel() : CheckBoxModel
  • CheckBoxView() : CheckBoxView
  • CheckCancelRequest() : DataConn
  • CheckForInterrupt() : Image, Image::CleanupDrawingObtainer
  • CheckSelector() : ClirHandler
  • CheckSpnData() : SimAuxHandler, DataHandler
  • CheckTime() : MiscAudioDevice
  • CheckTimers() : DataConn
  • CheckTransportAvailable() : ObexAbstractPort
  • ChildBinData() : ChildBinData
  • ChineseQuickSortProvider() : ChineseQuickSortProvider
  • ChineseT9InputMapper() : ChineseT9InputMapper
  • ChineseT9Wrapper() : ChineseT9Wrapper
  • Chv1DisableIndArg() : Chv1DisableIndArg
  • Chv1DisableReqArg() : Chv1DisableReqArg
  • Chv1EnableIndArg() : Chv1EnableIndArg
  • Chv1EnableReqArg() : Chv1EnableReqArg
  • ChvChangedMsg() : ChvChangedMsg
  • ChvChangeIndArg() : ChvChangeIndArg
  • ChvChangeReqArg() : ChvChangeReqArg
  • ChvNo() : EnumTranslationTable
  • ChvProvider() : ChvProvider
  • ChvRefreshIndArg() : ChvRefreshIndArg
  • ChvStatus() : EnumTranslationTable
  • ChvUnblockIndArg() : ChvUnblockIndArg
  • ChvUnblockReqArg() : ChvUnblockReqArg
  • ChvVerifyIndArg() : ChvVerifyIndArg
  • ChvVerifyReqArg() : ChvVerifyReqArg
  • CiTestParam() : CiTestParam
  • Clean() : ToDoDateDialogWin, ToDoComposeWin, SocketTestMessage
  • CleanTcpSocket() : SocketTestT2
  • CleanUdpSocket() : SocketTestT2
  • Cleanup() : PsdDataConn, PppDataConn, DataConn, CsdDataConn, ItemTree, ItemMenu, ItemBox, ImageBox, Control, ContextMenu, Component, AnimatedTextLine, AbstractItemGrid, AbstractEditor, Menu, MainHandler, HandlerListEntry, SvgPlayer, MultiMediaEditor, SimAccessor
  • CleanUp() : BackLight, RealTimeClock, BackLight, BtController, PngDecoder
  • CleanupDrawingObtainer() : Image::CleanupDrawingObtainer, Image
  • CleanupImageCache() : AbstractItemGrid
  • CleanUpRequestExecution() : BtSingleConnectionController, BtMultiConnectionController, BtConnectionlessController
  • Clear() : MediaRefContainer, TextEditorDocument, TextCompoundItem, EditorDocument, CompoundItem, BtSddbServiceRecord, BtSddbDeContainer, BtDeviceList, WString, TypeOfAddress, String, SharedPtr< T_obj >, RegBlobObject, PhoneNumber, ElementList< T >, BlobObject, BitField< T >, RtStreamingBuffer, SmsContext, InputAction, CbsFilterList::CbsFilterListEntry, FunctionalityIndicator, UsimPbFillStatus, UsimPbLocReport, UsimPbGroups, UsimPbChangedField, UsimPbRefRecord, UsimPbRwRecord, Tpdu, SimSetupIdleModeTextOptions, SimSetupMenuOptions, SimSelectItemOptions, SimGetInkeyOptions, SimGetInputOptions, SimDisplayTextOptions, SimIconIdentifier, SimNextActionIdentifier, SimTextString, SimItemIdentifier, SimAlphaIdentifier, SimIconQualifier, SimAtom< T >, ShortMessageStatus, ShortMessageFailureCause, ProtocolIdentifier, ParameterIndicator, MessageTypeIndicator, MessageIdentifierContainer, MessageIdentifier, DataCodingScheme, CommandType, Cbs, Cbs::SerialNumber, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem, TpduCache, TpduHeaderInformation, TpduPhoneNumberPersist, VrHandler
  • clear() : WbxmlVector< T >
  • ClearAfterDelay() : SimDisplayTextOptions
  • ClearAlarm() : AlarmManager, RealTimeClock
  • ClearBlacklist() : CallHdlBase, CallHandler
  • ClearBlackListCnfArg() : ClearBlackListCnfArg
  • ClearBlacklistReqArg() : ClearBlacklistReqArg
  • ClearBuffer() : Zi8Wrapper
  • ClearBufferVariables() : PbBaseProvider
  • ClearConnectedDevice() : BtSingleConnectionController
  • ClearData() : Tpdu, Cbs, SimPbEntry
  • ClearDatabase() : DBService
  • ClearDataCodingSchemeList() : Cbs::Filter
  • ClearEditor() : Zi8InputMapper
  • ClearHeaderFields() : ObexFtpDataServer
  • ClearHintBits() : IrdaTransport
  • ClearMessageIdentifierList() : Cbs::Filter
  • ClearProfile() : SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider
  • ClearRect() : DeviceContext
  • ClearRootCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ClearThreadlet() : FfsTestDispWin
  • ClearUserCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ClientCallBack() : IrdaObexTransport
  • ClientDc() : ClientDc
  • ClientDeregistrationArg() : ClientDeregistrationArg
  • ClientId() : ClientId
  • ClientInfo() : ClientInfo
  • ClientName() : ClientName
  • ClientNetAdapter() : ClientNetAdapter, NetAdapterHandler
  • ClientRegistrationArg() : ClientRegistrationArg
  • ClientSend() : SocketTestT2
  • ClipStatusMsg() : ClipStatusMsg
  • ClirAction() : ClirAction
  • ClirNotSurpressedMsg() : ClirNotSurpressedMsg
  • ClirStatusMsg() : ClirStatusMsg
  • Clone() : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, SoundBrowserServiceMsg, SkipSocketTestMsg, StopSocketTestMsg, ContinueSocketTestMsg, NextSocketTestMsg, StartSocketTestMsg, OnDataRcvdMsg, LcsAppResWinMsg, LcsAppRegisterForMtlrMsg, LcsAppTransferLocMsg, ImageBrowserServiceMsg, ImageBrowserRenameImageMsg, ImageBrowserDeleteImageMsg, SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, CameraMsgStopViewfinding, CameraMsgStartViewfinding, BtIndicatorMsg, PhonebookRenumberedMsg, ProviderUpdateMsg, SyncProgressMsg, SaveEntryInPhonebookMsg, OpenPbWinMsg, JumpToRowMsg, UtcStatusMessage, AsyncUnitTestMsg, DataConnProfileInfoMsg, DataConnInfoMsg, SocketControlMsg, DataConnProfile, ObexVCardMsg, ObexTransportMsg, ObexAddrMsg, ObexTriggerMsg, ObexMsg, ObexAppMsg, LoseFocusMsg, GetFocusMsg, ContextExecuteMsg, TimerTimeoutMsg, AlarmNotificationMsg, ShutdownRequestMsg, ContextWakeupMsg, ThreadletNotificationMsg, SharedTimerMsg, AppLoseFocusMsg, AppGetFocusMsg, ServiceThreadTerminateMsg, RtcAlarmReachedMsg, RtcDateChangedMsg, RtcTimeChangedMsg, ActionExecutedMsg, ItemPropertiesChangedMsg, ExternalTimeoutMsg, PenUpMsg, PenDownMsg, InputCharMsg, LockedKeyMsg, LockedKeyDownMsg, FlipMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, PowerWakeupMsg, LanguageChangedMsg, ThemeChangedMsg, AppUpdateDisplayMsg, AppCloseMsg, AppOpenMsg, PowerOffMsg, PowerOnMsg, NoMessage, Message, TextCompoundItem, RedrawDisplayMsg, ItemRendererPropertiesChangedMsg, ImageEncodingProgressMsg, DeleteComponentMsg, ImageDrawingInterruptedMsg, Zi8EnteredUnknownWordMsg, Zi8AddWordMsg, Zi8NoWordFoundMsg, T9MatrixModeKeypressed, T9SymbolEntryRequestMsg, T9EnteredUnknownWordMsg, T9AddWordMsg, T9NoWordFoundMsg, AragonMsg, CloseWindowMsg, RefreshComponentMsg, ContextMenuClosedMsg, ViewfinderErrorMsg, ImageDecodingProgressMsg, InvalidateMsg, SelectionChangedMsg, FocusPreviousControlMsg, FocusNextControlMsg, CompoundItem, CharItem, AtomItem, RtcInfoMsg, TransportNotificationMsg, LedNotificationMsg, DisplayInfoMsg, BatteryLoadLevelMsg, ChargerInfoMsg, SoundItem, BtObexClientRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtHsRequestStateChangedMessage, BtHsNotificationMessage, BtHfRequestStateChangedMessage, BtHfNotificationMessage, BtFaxRequestStateChangedMessage, BtFaxDisconnectMessage, BtFaxConnectMessage, BtFaxApplicationMessage, BtDunRequestStateChangedMessage, BtDunDisconnectMessage, BtDunConnectMessage, BtDunApplicationMessage, BtRequestStateChangedMessage, BtServiceMessage, BtSddbRequestStateChangedMessage, BtSddbDeAlternative, BtSddbDeSequence, BtSddbDeUrl, BtSddbDeString, BtSddbDeUuid128, BtSddbDeSint128, BtSddbDeSint64, BtSddbDeUint128, BtSddbDeUint64, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, BtSddbDeNil, BtSddbDataElement, BtRequestOperationMessage, BtCloseMessage, BtOpenMessage, BtRequestMessage, BtCancelVerifyMessage, BtServiceVerifyResultMessage, BtServiceVerifyMessage, BtPaSupportedProfileMessage, BtHfSupportedProfileMessage, BtHsSupportedProfileMessage, BtQuerySupportedProfilesMessage, BtDeviceUntrustMessage, BtDeviceTrustMessage, BtDeviceUnpairMessage, BtDevicePairMessage, BtSetRemoteDeviceNameMessage, BtCancelSearchMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtDeviceSearchMessage, BtRespondAuthorizationMessage, BtSendPasskeyMessage, BtProfileActivationMessage, BtConnectabilityMessage, BtPairabilityMessage, BtDiscoverabilityMessage, BtLocalNameMessage, BtLocalSettingsMessage, BtStateChangedMessage, BtGapAndSdapRequestMessage, BtRemoteDevicePairMessage, BtGapAndSdapNotificationMessage, BtAuthorizationRequiredMessage, BtPasskeyRequiredMessage, BtGapAndSdapRemoteRequestMessage, BtGapAndSdapApplicationMessage, BtApplicationMessage, BtBppRequestStateChangedMessage, BtBipProgressMsg, BtAvrcpRequestStateChangedMessage, BtAvrcpOperationServiceMessage, BtAvrcpNotificationMessage, RamData, BufferedData, BinData, AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStreamingSyncMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRadioDeviceNotificationMsg, AudioPlayTimeMsg, AudioMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioFmRadioRdsAlternativeFrequenciesMsg, AudioFmRadioRdsInfoMsg, AudioFmRadioRdsRadioTextMsg, AudioFmRadioRdsStationNameMsg, AudioFmRadioRdsRawDataMsg, AudioFmRadioRssiMsg, AudioFmRadioSeekMsg, AudioAccessoryConnectedMsg, AudioRecordingStoppedMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg, AudioErrorMsg, AudioDeviceStatusMsg, DisabledFeatureTriggeredMsg, UpdateItemMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg, PropertyTriggerMsg, FeatureChangedMsg, UpdateContextItemMsg, CloseAllMsg, IndicatorBarUpdateMsg, UssdBeginMsg, UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, UusQueryRejectedMsg, UusStatusMsg, GetPasswordMsg, UssdRequestResentMsg, UssdDataMsg, UssdEndMsg, UssdNotifyMsg, UssdRequestMsg, SsErrorMsg, CallBarringPasswordChangedMsg, ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, CnapInfoReceivedMsg, EctAlertingMsg, EctActiveMsg, MultiPartyCallInvokedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, CugCallMsg, HlrDataCorruptedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallIsWaitingMsg, CallRetrievedMsg, CallHeldMsg, CallForwardingActiveMsg, ClirNotSurpressedMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, CtmInfoIndMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, PbAlphaTagRequestMsg, PbEntryRequestMsg, PbSizeRequestMsg, CbsLimitMsg, SmsMessageWaitingChangedMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceAvailableMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsPortDataRecvMsg, SmsNewSocketDataMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, RatChangeModeChangedMsg, EngineeringModeControlResponseMsg, BandStatusMsg, GsmBandStateMsg, RatStateMsg, NwDiscStartIndMsg, HomezoneMsg, BandSelectionMsg, EngineeringReportMsg, UssdAnswerMsg, CcbsResultMsg, CcbsStatusMsg, CcbsRecallMsg, SsInfoMsg, SsFacilityRejectedMsg, UssdResentMsg, UssdIndicationMsg, PasswordRejectedMsg, PasswordInquiryMsg, SsErrIndicationMsg, SsRejectedMsg, SsEndMsg, SsSuccessMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, MocSetupRejectIndMsg, CallControlInfoMsg, RedialStatusMsg, DiagnosticIndMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, RedialStoppedMsg, RedialStartedMsg, CallNotifyMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfBufferCleanedMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, PowerModeIndMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, OmMultiSlotIndMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, SimTkProfileSetRejMsg, SimTkProfileSetCnfMsg, SimTkProfileGetCnfMsg, SimTkRefreshStartMsg, TermRspCnfMsg, SimTkSetupEventMsg, SimTkLanguageNotificationMsg, MptyHoldRejectedMsg, MptyOnHoldMsg, CallHoldRejectedMsg, CallOnHoldMsg, SimCallSetupRejectedMsg, SimEndTransactionMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimMenuItemSelectionFailedMsg, SimSetupMenuMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetDoneMsg, SimResetConfirmationMsg, SimRefreshResetMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, RegistrationAllowedMsg, PlmnScanFinishedMsg, RegistrationChangeMsg, RegistrationSuccessMsg, AccessoryIndMsg, SignalQualityLevelMsg, SignalStrengthLevelMsg, MinuteTickMsg, AlarmMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, LsaIdentityMsg, TimeZoneMsg, NetworkInformationMsg, SimErrorMsg, CfuStatusMsg, MptyCallReleaseMsg, CallReleaseMsg, CallAcceptMsg, ExternalPdpContextInfoMsg, GprsAttachStatusMsg, PdpContextActivationStatusMsg, ChvChangedMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg, CallEventMsg, GprsStatusMsg, SimLockStatusMsg, SimStateChangedMsg, SsMessage, ToStackMsg, FromStackMsg, RfsStorageDeviceRegistrationStatusMsg, RfsMediaAvailableStatusMsg, FileChunkOperationProgressMsg, FileBinData, RegCbNotifyMsg, RegNotifyMsg, VrRecognitionFailedMsg, VrTrainingFailedMsg, VrPlaybackFinishedMsg, VrTrainingResultMsg, VrRecognitionStoppedMsg, VrTrainingAbortedMsg, VrRecognitionAbortedMsg, VrWarningMsg, VrErrorMsg, VrResultMsg, VrPromptMsg, DBItemChangedMsg, SvgHyperlinkSelectMsg, SvgStatusMsg, SvgDecodingFinishedMsg, HttpDisconnectMessage, HttpConnectMessage, HttpRequestMessage, HttpErrorMessage, HttpServiceMessage, FtpDisconnectMessage, FtpConnectMessage, FtpRequestMessage, FtpTransferMessage, FtpErrorMessage, FtpServiceMessage, VCardItem, RichTextCompoundItem, ParagraphCompoundItem, ImageItem, GeneralCompoundItem, AudioItem, MmCallReleaseMsg, MmCallAcceptMsg, MmAocChargingStatusMsg, MmCurrentCallMeterMsg, MmCurrentChargeDataMsg, MmCallNotifyMsg, MmCallInfoMsg, MmCallSetupProgressMsg, MmMocSetupAcceptMsg, MmCallDisconnectingMsg, MmCallStatusMsg, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg, CloseDataConnMsg, GltpConnStatusMsg, SendRequestMsg, SetupDataConnMsg, ProcessMolrMsg, ProviderChangedMsg, AbortResMsg, LocationErrMsg, LocationResMsg, LocationNotifInvokeMsg, AppActionExecutedMsg, DrmWapPushMsg, FatFsUsbMassStorageReleaseMsg, FatFsUsbMassStorageRequestMsg, UsimPbResetedMsg, UsimPbReadyMsg, DataControlPhonebookStateMsg, DataControlEndBootMsg, DataControlBootMsg, DataControlBootProgressMsg, DataControlStartBootMsg, DataControlModificationMsg
  • Close() : FfsDataConnProfileStorage, SysSocket, SocketData, Socket, InetSocket, DataConnProfileStorage, ObexServerDispatcher, ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexFtpServer, ObexClientDispatcher, ObexAbstractPort, SocketPeer, Window, VideoChannel, StillCamera, VideoChannel, StillCamera, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoChannel, VideoCamera, StillCamera, NonsharedBinDataDataSource, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, VideoChannel, StillCamera, Camera, VideoChannel, FileOutputStream, FileInputStream, FfsFile, StringDataSink, StreamWriter, StreamReader, Stream, HeapDataSource, HeapDataSink, DataSource, DataSink, BinDataDataSource, RtStreamingEndPoint, ExtPsdContextListener_SioGlueWrapper, FileDataSource, FileDataSink, File, FlsFile, FfsHandler, SioSocketAdapter, SerialSocket, SerialIoAdapter, SioGlueWrapper, SerialTerminalSocket, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoderRenderer, AudioDecoder, AudioCapturerEncoder, RootFileImp, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile
  • CloseAction() : ObexServerDispatcher, ObexServer, ObexClientDispatcher, ObexAbstractPort, AtiAudioPlayerRtStreamingSink, RtStreamingEndPoint, DataSourceRtStreamingSource
  • CloseAfterTrigger() : MenuProperties
  • CloseAllMsg() : CloseAllMsg
  • CloseAllNetAdapters() : NetAdapterHandler
  • CloseChannel() : ObexServerPort, ObexProtocol, ObexClientPort, ObexAbstractPort, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • CloseCompleteAction() : ObexAbstractPort
  • CloseConnection() : ObexClientOppImpl
  • CloseDatabase() : DBService
  • CloseDataConnection() : FtpClient
  • CloseDataConnMsg() : CloseDataConnMsg
  • CloseEditbox() : PbDetails
  • CloseFile() : StreamAudioReference
  • CloseHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • CloseImmediately() : Alert
  • CloseMinimized() : FmRadioWindow
  • CloseMinimizedRadio() : FmRadioApplication
  • CloseNetAdapter() : NetAdapterHandler
  • CloseWindowAction() : CloseWindowAction
  • CloseWindowMsg() : CloseWindowMsg
  • CmiProvider() : CmiProvider
  • CnapInfoReceivedMsg() : CnapInfoReceivedMsg
  • CnapStatusMsg() : CnapStatusMsg
  • CodecDevice() : CodecDevice
  • CodedTimeStamp() : CodedTimeStamp
  • CollectPackets() : UdpTestSocket, TcpTestSocket
  • Color() : Color
  • ColorStream() : Led
  • ColpStatusMsg() : ColpStatusMsg
  • ColrStatusMsg() : ColrStatusMsg
  • ColumnCount() : PbSimProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider
  • CommandType() : CommandType
  • Commit() : ObexBuffer::Writer, ObexBuffer::Reader, RegEncoderDecoder, PbRecordProvider, Provider
  • CommitBuffer() : ObexObject
  • CommitPbInformation() : AtcHandler
  • CommitRow() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, DataConnProvider, CalendarProvider, BtHfProvider, PbRecordProvider, Provider, DistinctProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, StatusProvider, SmsProvider, SmsParamProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, CphsServPflProvider, CphsAuxProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • CommitTransaction() : Registry, DBService
  • Compare() : WString, Time, String, PhoneNumber, DateTime, Date, ArgumentDestroyEntryCompare
  • CompareTo() : WString, String
  • CompleteEvent() : ObexAbstractPort::CompleteEvent
  • Complies() : NamePatternStorageDeviceFilter, StorageDeviceFilter, SoundFileFilter, ImageFileFilter, NamePatternFileFilter, FileFilter
  • Component() : Component
  • ComponentIterator() : Control::ComponentIterator
  • ComposeSms() : BasicSmsService, AbstractSmsApp
  • CompoundItem() : CompoundItem
  • CompoundItemIterator() : CompoundItemIterator, MultiMediaEditorDocument
  • CompoundItemReferrer() : CompoundItemReferrer
  • CompoundSmsItem() : CompoundSmsItem, SimPduHandler
  • CompoundTpduItem() : CompoundTpduItem, SimPduHandler
  • CompressBlock() : SwitchedRleCompression
  • Compression() : EnumTranslationTable
  • Condition() : Condition
  • ConfigureAAC() : AtiAudioCapturerEncoder, AudioCapturerEncoder
  • ConfigureAMR() : AtiAudioCapturerEncoder, AudioCapturerEncoder
  • ConfigureMultiShot() : StillCamera
  • Confirm() : ObexOppDataSinkPushServer, SmsSocketListener
  • ConfirmAction() : ConfirmAction
  • ConfirmDtmfSending() : SimTkHandler
  • ConfirmKeyInput() : Keyboard
  • ConfirmPbAlphaTagRequest() : SimHandler, AtcHandler
  • ConfirmPbEntryRequest() : AtcHandler
  • ConfirmPbSizeRequest() : AtcHandler
  • Connect() : TcpSocket, SysSocket, PsdDataConn, ObexLayer, ObexClient, SocketPeer, IrdaObexImpl, MmiSimClient, BtObexImpl, PdpContext, ExtPsdContextListener_SerialTerminal, StreamObexImpl, SioSocketAdapter, SerialIoAdapter, SerialClientSocket, SerialTerminal, AtResponse
  • ConnectClient() : HttpServer, FtpServer
  • ConnectionIndArg() : ConnectionIndArg
  • ConnectionStatusMsg() : ConnectionStatusMsg
  • ConnectReq() : BtBipClientService
  • ConnectRequest() : BtObexClientService, BtHsService, BtHfService, BtSingleConnectionController, BtAudioAccessoryService, BtAvrcpOperationService
  • ConnectResponse() : SubUnitReference, BtBppServerService, BtAvrcpOperationService
  • ConnectRsp() : BtBipServerService
  • ConnectToPC() : RegAppWin
  • ConnectToUrl() : AbstractSmsApp
  • ConstIterator() : ObexHeaderList::ConstIterator, Vector< T >
  • Construct() : ObexBuffer::Factory, Allocator< T >
  • Contains() : ObexTransportSet, ObexHeaderList, GlassPane, MemPoolEntry, LinkedListBase
  • ContainsAction() : ActionMenuAccessor
  • ContainsControl() : Control
  • ContainsDataPack() : BasicPackConnector
  • ContainsDispatcher() : ExecutionContext
  • ContainsDrawableObject() : Control
  • ContainsFeature() : FeatureItemContainer
  • ContainsFont() : FontPackConnector
  • ContainsItem() : AbstractItemContainer
  • ContainsLanguage() : TextPackConnector
  • ContainsProperty() : SubstitutedText
  • ContainsUserInputMsg() : AppContainer
  • ContainsWindow() : Application
  • Context() : SwitchedRleCompression::Context
  • ContextDescription() : ContextDescription
  • ContextExecuteMsg() : ContextExecuteMsg
  • ContextFeature() : ContextFeature
  • ContextFeatureHandle() : ContextFeatureHandle
  • ContextFeatureItem() : ContextFeatureItem
  • ContextFeatureTriggerMsg() : ContextFeatureTriggerMsg
  • ContextMenu() : ContextMenu
  • ContextMenuClosedMsg() : ContextMenuClosedMsg
  • ContextMsg() : ContextMsg
  • ContextTableNode() : ContextTableNode, ContextTable
  • ContextWakeupMsg() : ContextWakeupMsg
  • ContinueSocketTestMsg() : ContinueSocketTestMsg
  • Control() : Control, VirtualDisplay, RealTimeClock, VirtualDisplay, Keyboard, Fota, Charger, VirtualDisplay, AbstractDevice, ThaiTextRenderer, DrawableObject
  • ControlArg() : AbstractDevice::ControlArg
  • ControlDc() : ControlDc
  • ControlFrameView() : ControlFrameView
  • ControlHwDataOnlyArg() : ControlHwDataOnlyArg
  • ControllerConnectRequest() : BtAvrcpControllerApplicationWindow
  • ControllerDisconnectRequest() : BtAvrcpControllerApplicationWindow
  • ControllerSelectDeviceRequest() : BtAvrcpControllerApplicationWindow
  • ControllerSetActiveDeviceRequest() : BtAvrcpControllerApplicationWindow
  • ControllerSetInactiveDeviceRequest() : BtAvrcpControllerApplicationWindow
  • ControllerSubUnitInfoRequest() : BtAvrcpControllerApplicationWindow
  • ControlMsg() : ControlMsg
  • Convert() : JapaneseTranscoder, GpsFixDataInt
  • Convert2AudioReturnCode() : GenericAudioDevice
  • Convert2Buffer() : SimAlphaIdentifier
  • Convert2Pdu() : Tpdu
  • Convert2SdlAlpha() : SimAlphaIdentifier
  • Convert2SdlFilter() : Cbs::Filter
  • Convert2SdlText() : SimTextString
  • Convert2UserData() : SimTextString
  • ConvertBidiLine() : ParagraphCompoundItem
  • ConvertBtApoxiOperationToMmiCommand() : BtAvrcpPanelApplication
  • ConvertDataItemToObjectData() : ObjectDataConverter
  • ConvertFfsErrorToFileError() : FlashStorageDeviceImp
  • ConvertFromHtml() : HttpSocket
  • ConvertKeyTone2INT() : KeyToneAudioDevice
  • ConvertMmiResponseToApoxiResponse() : BtAvrcpPanelApplication
  • ConvertObjectDataToDataItem() : ObjectDataConverter
  • ConvertPriority2INT() : GenericAudioDevice
  • ConvertRamErrorToFileError() : RamFileImp
  • ConvertToBcd() : LcsWString
  • ConvertToBitmap() : Image
  • ConvertToColorValue() : VirtualDisplay
  • ConvertTone2INT() : ToneAudioDevice
  • ConvertToStr() : ClientId
  • Copy() : ImageRefGenContainer, BtDeviceAddressGenericObject, BtSddbDeContainer, RegBlobObject, GenericObject, BlobPtr, BlobObject, TimeFeatureObject, GenericFeatureData, ImgObtObj, MenuIdObj, ItemObj, MenuDescObj, File, FlsFile, FfsHandler, RootFileImp, CompoundTpduItem, CompoundSmsItem
  • CopyAll() : CopyHandler
  • CopyCbsUnicodeBufferAndAdjustBytes() : DataCoding
  • CopyContentsTo() : File
  • CopyData() : FilePackConnector, Tpdu, Cbs
  • CopyFrom() : ObexBuffer::Writer
  • CopyHandler() : CopyHandler
  • CopyItem() : DBService
  • CopyPbRow() : PbCopyHandler
  • CopyRow() : CopyHandler
  • CopyTo() : ObexBuffer::Reader, InformationElement, SmsProvider, SimPduHandler
  • CopyToPb() : PhonebookApp
  • CountryProvider() : CountryProvider
  • CountSettings() : SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor
  • CphsAuxProvider() : CphsAuxProvider
  • CphsCfufReadIndArg() : CphsCfufReadIndArg
  • CphsCfufReadReqArg() : CphsCfufReadReqArg
  • CphsCfufUpdIndArg() : CphsCfufUpdIndArg
  • CphsCfufUpdReqArg() : CphsCfufUpdReqArg
  • CphsCspReadIndArg() : CphsCspReadIndArg
  • CphsCspReadReqArg() : CphsCspReadReqArg
  • CphsCspUpdIndArg() : CphsCspUpdIndArg
  • CphsCspUpdReqArg() : CphsCspUpdReqArg
  • CphsIstReadIndArg() : CphsIstReadIndArg
  • CphsIstReadReqArg() : CphsIstReadReqArg
  • CphsOnmReadIndArg() : CphsOnmReadIndArg
  • CphsOnmReadReqArg() : CphsOnmReadReqArg
  • CphsOnsReadIndArg() : CphsOnsReadIndArg
  • CphsOnsReadReqArg() : CphsOnsReadReqArg
  • CphsServPflProvider() : CphsServPflProvider
  • CphsVmwfReadIndArg() : CphsVmwfReadIndArg
  • CphsVmwfReadReqArg() : CphsVmwfReadReqArg
  • CphsVmwfUpdIndArg() : CphsVmwfUpdIndArg
  • CphsVmwfUpdReqArg() : CphsVmwfUpdReqArg
  • Create() : GuiObjectFactory, ObexOperationId, SimpleSemaphore, Semaphore, SimpleMutex, SimpleSemaphore, Semaphore, Mutex, AppMutex, FfsFile, BtObexServerAddr, BtObexClientAddr, BtObexClientAddrResultNotifier, StreamAudioReference, CustomToneAudioReference, CustomSmafPhraseAudioReference, CustomRingerAudioReference, AudioActiveReference, File, FlsFile, FfsHandler, MapiAudioReference, StreamObexImpl, SioSocketAdapter, DrmRightsObjectFile, RootFileImp, RamHandler, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile
  • CreateAccHandler() : HandlerFactory
  • CreateAocHandler() : HandlerFactory
  • CreateAppContext() : SimpleScheduler, Scheduler, AbstractScheduler
  • CreateAtcHandler() : HandlerFactory
  • CreateAudioReferenceFromBinData() : MmfPlayer, AudioDeviceManager
  • CreateAudioReferenceFromExtensionSoundDataSource() : AudioDeviceManager, MapiAudioPlayer
  • CreateAudioReferenceFromFFS() : AudioDeviceManager
  • CreateAudioReferenceFromPreset() : AudioDeviceManager
  • CreateAudioReferenceFromRamBuffer() : MP3AudioPlayer, MmfPlayer, AudioDeviceManager
  • CreateAudioReferenceFromRFS() : AudioDeviceManager
  • CreateAudioReferenceFromRfsFile() : MP3AudioPlayer, MmfPlayer
  • CreateAudioReferenceFromStream() : MP3AudioPlayer, AudioDeviceManager
  • CreateBackupFile() : BackupFileHandler
  • CreateBootHandler() : HandlerFactory
  • CreateBuffer() : StreamObexImpl
  • CreateBufferPool() : BufferPoolManager
  • CreateCallBarringHandler() : HandlerFactory
  • CreateCallControlHandler() : HandlerFactory
  • CreateCallDeflectionHandler() : HandlerFactory
  • CreateCallForwardingHandler() : HandlerFactory
  • CreateCallHandler() : HandlerFactory
  • CreateCallWaitingHandler() : HandlerFactory
  • CreateCbsHandler() : HandlerFactory
  • CreateClipHandler() : HandlerFactory
  • CreateClirHandler() : HandlerFactory
  • CreateCnapHandler() : HandlerFactory
  • CreateColpHandler() : HandlerFactory
  • CreateColrHandler() : HandlerFactory
  • CreateContainer() : DrmAsset
  • CreateContext() : PdpContextManager
  • CreateCrssHandler() : HandlerFactory
  • CreateCtResourcePack() : GuiObjectFactory
  • CreateDataConn() : DataConnProfile
  • CreateDataConnProfile() : PersistDataConnProfile
  • CreateDir() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • CreateDirectoryIterator() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp
  • CreateEditor() : AtlConfig
  • CreateEmlppHandler() : HandlerFactory
  • CreateFFS() : StreamAudioReference
  • CreateFile() : StreamAudioReference
  • CreateFileObject() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp
  • CreateGlassPane() : Desktop
  • CreateHexCodes() : DbgDump
  • CreateImage() : ImageFactory
  • CreateImageHdl() : BtBipImageHdl
  • CreateImageObject() : ImageRef
  • CreateInstance() : FfsTestThreadlet, TimeCompoundItem, TextCompoundItem, IpAddrCompoundItem, Desktop, DecodingThreadlet, DateCompoundItem, MmiSimServer, AudioGatiServer, RomData, RamData, DataSourceBinData, ChildBinData, BufferedData, InputMapperFactory, MainDesktop, FileBinData, RichTextCompoundItem, PngEncodingThreadlet, ParagraphMarker, ParagraphCompoundItem, JpegEncodingThreadlet, GeneralCompoundItem
  • CreateInteriorNode() : Registry
  • CreateInteriorNodeEntry() : NodeFileHandler
  • CreateInterrogateResultMsg() : ColrHandler, ColpHandler, CnapHandler, ClirHandler, ClipHandler
  • CreateLockTable() : LockTableList
  • CreateMediaPlayer() : MediaManager
  • CreateMediaRecorder() : MediaManager
  • CreateMediaRef() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer
  • CreateMessages() : EmsCreator
  • CreateMocVoiceHandler() : HandlerFactory
  • CreateModel() : EmsEditor, PbProvColListBox, PbDetailListBox, TimeEditor, PasswordEditor, MultiLineEditor, LineEditor, IpAddrEditor, DateEditor, Component, TimeEditBox, TextList, RadioButtonList, ProviderListBox, MenuList, Grid, EditBox, DateEditBox, CheckBoxList, CheckBox, Animation, MultiMediaEditor
  • CreateMoUssdHandler() : HandlerFactory
  • CreateMtcVoiceHandler() : HandlerFactory
  • CreateMultiSlotHandler() : HandlerFactory
  • CreateNetworkHandler() : HandlerFactory
  • CreatePanel() : Application
  • CreatePdpContext() : PsdDataConn
  • CreatePlayerInstance() : MediaBox
  • CreatePlmnHandler() : HandlerFactory
  • CreatePowerHandler() : HandlerFactory
  • CreateRam() : StreamAudioReference
  • CreateReference() : AudioPresetStore
  • CreateSection() : Desktop, MainDesktop
  • CreateSigHandler() : HandlerFactory
  • CreateSimHandler() : HandlerFactory
  • CreateSimTkHandler() : HandlerFactory
  • CreateSmsHandler() : HandlerFactory
  • CreateSsCcbsHandler() : HandlerFactory
  • CreateSsMainHandler() : HandlerFactory
  • CreateStream() : StreamAudioReference
  • CreateStreaming() : File, FlsFile, RootFileImp, RamFileImp, FlashFileImp, FatFileImp, FatFile
  • CreateTempFile() : RootFileSystem
  • CreateTemplate() : VrHandler
  • CreateUssdHandler() : HandlerFactory
  • CreateVoiceRecognition() : StreamAudioReference
  • CreateWapProfile() : WapProfileMgr
  • CrssHandler() : CrssHandler
  • CsdDataConn() : CsdDataConn
  • CsdDataConnAccessor() : CsdDataConnAccessor
  • CsdDataConnProfile() : CsdDataConnProfile, PersistDataConnProfile
  • CsdDataConnProvider() : CsdDataConnProvider
  • cstream() : XMLParser
  • CTControlFrameView() : CTControlFrameView
  • CtmInfoIndArg() : CtmInfoIndArg
  • CtmInfoIndMsg() : CtmInfoIndMsg
  • CTPanelView() : CTPanelView
  • CTPositionIndicatorView() : CTPositionIndicatorView
  • CTProgressBarView() : CTProgressBarView
  • CTPushButtonView() : CTPushButtonView
  • CTResourcePack() : CTResourcePack
  • CTWindowFrameView() : CTWindowFrameView
  • CugCallMsg() : CugCallMsg
  • CurrentCallMeterMsg() : CurrentCallMeterMsg
  • CurrentChargeDataMsg() : CurrentChargeDataMsg
  • CurrentPosition() : StreamWriter, StreamReader
  • CustomFrameBuffer() : Display::CustomFrameBuffer
  • CustomizedDataAvailable() : CTResourcePack
  • CustomRingerAudioReference() : CustomRingerAudioReference
  • CustomSmafPhraseAudioReference() : CustomSmafPhraseAudioReference
  • CustomToneAudioReference() : CustomToneAudioReference
  • CutOff() : RegBlobObject, BlobObject
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- d -

  • Data() : StartUp::Data, InternalTracer, XCallInfoResponseParser
  • DataAcceptable() : StreamWriter
  • DataAvailable() : StreamReader, ExtPsdContextListener_SerialTerminal, SerialTerminal
  • DataBufferIndication() : BtObexServerService, BtObexClientService
  • DataCallContext() : DataCallContext
  • DataCallControl() : DataCallControl
  • DataCoding() : DataCoding
  • DataCodingScheme() : DataCodingScheme
  • DataCodingSchemeExists() : ParameterIndicator
  • DataCodingSchemeRange() : DataCodingSchemeRange
  • DataConn() : DataConn, SysSocket, SocketSubSystem, SocketData
  • DataConnAccessor() : DataConnAccessor
  • DataConnDescription() : DataConnApp::DataConnDescription
  • DataConnInfoMsg() : DataConnInfoMsg
  • DataConnIsBlocked() : PsdDataConn, DataConn
  • DataConnLbModel() : DataConnLbModel
  • DataConnOptionWin() : DataConnOptionWin
  • DataConnProfile() : DataConnProfile, PsdDataConn, PersistDataConnProfile, DataConn, CsdDataConn
  • DataConnProfileInfoMsg() : DataConnProfileInfoMsg
  • DataConnProvider() : DataConnProvider
  • DataConnTypeWin() : DataConnTypeWin
  • DataConnWin() : DataConnWin
  • DataControl() : DataControl
  • DataControlBootMsg() : DataControlBootMsg
  • DataControlBootProgressMsg() : DataControlBootProgressMsg
  • DataControlEndBootMsg() : DataControlEndBootMsg
  • DataControlModificationMsg() : DataControlModificationMsg
  • DataControlPhonebookStateMsg() : DataControlPhonebookStateMsg
  • DataControlStartBootMsg() : DataControlStartBootMsg
  • DataHandler() : DataHandler
  • DataIndication() : BtObexServerService
  • DataItem() : DataItem
  • DataPack() : DataPack
  • DataProcessed() : ObexServerOppImpl, ObexServer, ObexOppServer, ObexOppClient, ObexLayer, ObexClientOppImpl, ObexClient, IrdaObexImpl, BtObexImpl, StreamReader, StreamObexImpl
  • DataReadyIndication() : BtObexClientService
  • DataRecord() : DataRecord
  • DataRecordHandler() : DataRecordHandler, DataRecord
  • DataSink() : DataSink, RecordSettings
  • DataSource() : SimTextString, DataSource
  • DataSourceBinData() : DataSourceBinData
  • DataSourceRtStreamingSource() : DataSourceRtStreamingSource
  • Date() : Date, InputMapper
  • DateCompoundItem() : DateCompoundItem
  • DateEditBox() : DateEditBox
  • DateEditBoxView() : DateEditBoxView
  • DateEditor() : DateEditor
  • DateEditorDocument() : DateEditorDocument
  • DateEditorView() : DateEditorView
  • DateFromDriverDate() : FatFileImp
  • DateTime() : DateTime
  • DateTimeInputMapper() : DateTimeInputMapper
  • DayName() : Date
  • DayOfWeek() : Date
  • DayOfYear() : Date
  • DaysInMonth() : Date
  • DaysInYear() : Date
  • DbgOut() : Os, HeapVector::VarPage, HeapVector::BlockPage, HeapManager, CfuServiceArray, SimImage, SimIconDescription, SimImageDescriptor, Cbs::Filter
  • DbgOutContext() : HeapVector::VarPage, HeapVector::BlockPage
  • DbgOutContextUsage() : HeapManager
  • DbgOutStackUsage() : Os
  • DbgTimingMeasurement() : DbgTimingMeasurement
  • DBItemChangedMsg() : DBItemChangedMsg
  • DBService() : DBService
  • DcsGroupId() : EnumTranslationTable
  • DcsLanguageFilterRule() : DcsLanguageFilterRule
  • Deactivate() : StackMsgDispatcher, PdpContext, CallWaitingHandler, CallForwardingHandler, CallBarringHandler
  • DeactivateBdn() : SimHandler, SimAccessor, DataHandler
  • DeactivateCallBarring() : SsHandler
  • DeactivateCallForwarding() : SsHandler
  • DeactivateCallWaiting() : SsHandler
  • DeactivateContext() : PsdDataConn
  • DeactivateFdn() : SimHandler, SimAccessor, DataHandler
  • DeAllocateDwd() : DwdDevice
  • DeAllocateDwdID() : DwdDevice
  • DebugOutputStream() : DebugOutputStream
  • Decode() : RegEncoderDecoder
  • DecodeAlphaField() : AlphaCoding
  • DecodeAltitude() : LcsUtils
  • DecodeAngle() : LcsUtils
  • DecodeBase64() : MimeCoding
  • DecodeBase64Data() : DrmUtils
  • DecodeBuffer() : EmzMp3Decoder, EmzAacDecoder, EmzMp3Decoder, EmzAacDecoder, AudioDecoder
  • DecodeChar() : QuotedPrintableCoder
  • DecodeEnd() : Base64Coder, QuotedPrintableCoder
  • DecodeFrame() : ScicosMpeg4VideoDecoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Decoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoDecoder, AudioDecoder
  • DecodeInnerRadius() : LcsUtils
  • DecodeLatitude() : LcsUtils
  • DecodeLocEstimate() : LcsUtils
  • DecodeLongitude() : LcsUtils
  • DecodeMessage() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • DecodeNextScanline() : PngImage, PngDecoder
  • DecodePacket() : ScicosMpeg4VideoDecoder, EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Decoder, EmzMpeg4Decoder, EmzH264Decoder, VideoDecoder
  • DecodePush() : Base64Coder, QuotedPrintableCoder
  • DecodePush6Bits() : Base64Coder
  • DecodeQuotedPrintable() : MimeCoding
  • DecodeRenderBuffer() : AtiAudioDecoderRenderer, AudioDecoderRenderer
  • DecodeSynchronously() : NativeImage, Image, SvgImage
  • DecodeUncertAltitude() : LcsUtils
  • DecodeUncertRadius() : LcsUtils
  • DecompressBlock() : SwitchedRleCompression
  • DecreasePriority() : Thread
  • DecRefCount() : WStrData, StrData, ProviderPtr
  • DecrementCell() : GridModel
  • DecrementDelBufCount() : RegDeletionBufferEntry
  • DecrementOpenFileCounter() : StorageDevice
  • DecrementRegCount() : ApplicationListEntry
  • DecryptBuffer() : AesCrypt
  • DefaultAction() : ObexAbstractPort
  • DefaultAppendRow() : PbBaseProvider
  • DefaultCaret() : DefaultCaret
  • DefaultCheckBoxListView() : DefaultCheckBoxListView
  • DefaultCheckBoxView() : DefaultCheckBoxView
  • DefaultChineseTheme() : DefaultChineseTheme
  • DefaultCommitRow() : PbBaseProvider
  • DefaultControlFrameView() : DefaultControlFrameView
  • DefaultDeleteAllRows() : PbBaseProvider
  • DefaultDeleteRow() : PbBaseProvider
  • DefaultDisplay() : DefaultDisplay
  • DefaultItemRenderer() : DefaultItemRenderer
  • DefaultPositionIndicatorView() : DefaultPositionIndicatorView
  • DefaultProgressBarView() : DefaultProgressBarView
  • DefaultPushButtonView() : DefaultPushButtonView
  • DefaultRadioButtonListView() : DefaultRadioButtonListView
  • DefaultRadioButtonView() : DefaultRadioButtonView
  • DefaultTabButtonView() : DefaultTabButtonView
  • DefaultTabControlView() : DefaultTabControlView
  • DefaultTextListView() : DefaultTextListView
  • DefaultTheme() : DefaultTheme
  • DefaultWindowFrameView() : DefaultWindowFrameView
  • Define() : PdpContext
  • DefinePdpContext() : PsdDataConn
  • DeInit() : MediaInfo::ClipInfo
  • Deinitialize() : RamHandler
  • Delegate() : RootFileImp
  • DelegationProviderListener() : DelegationProviderListener
  • Delete() : MediaRefContainer, ImageRefContainer, MediaRefContainer, FfsFile, BtSddbServiceRecord, BtSddbDeContainer, File, Registry, ObjectTreeService, LocalDataStore, FlsFile, FfsHandler, WapProfile, DrmRightsObjectFile, RootFileImp, RamHandler, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile, RegEncoderDecoder, PbRecordProvider, InternalTracer, Provider, CommandType
  • DeleteActiveWord() : T9InputMapper
  • DeleteAllData() : SimPbEntryCont
  • DeleteAllDeviceListItems() : BtAvrcpControllerApplicationWindow
  • DeleteAllEntries() : PhonebookApp
  • DeleteAllEqualNodes() : RamFileNode
  • DeleteAllExtLanguages() : SimAuxHandler
  • DeleteAllItems() : CalendarRecordsListBoxModel, CalendarRecordsList, CalendarListWin
  • DeleteAllLanguages() : SimAuxHandler
  • DeleteAllMsg() : UibApp
  • DeleteAllObjects() : SimPbEntryCont
  • DeleteAllPlmns() : SimAuxHandler
  • DeleteAllPlmnwAct() : SimAuxHandler
  • DeleteAllRecords() : RecordHandler
  • DeleteAllRows() : ToDoProvider, CalendarProvider, PbSortedProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, PbMergeProvider, Provider, FindProvider, FilterProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, AppendProvider, SmsProvider, SmsClass0Provider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, CbmiRangeProvider, CbmiProvider
  • DeleteAllSms() : SmsProvider, SimPduHandler
  • DeleteAllSubNodes() : RamFileNode
  • DeleteAt() : MediaRefContainer
  • DeleteBackupFile() : BackupFileHandler
  • DeleteBlock() : RamStorageMapper
  • DeleteBlocks() : RamStorageMapper
  • DeleteBufferPool() : BufferPoolManager
  • DeleteChar() : AbstractEditBoxModel
  • DeleteComponentMsg() : DeleteComponentMsg
  • DeleteData() : SimPbEntryCont
  • DeleteDataBlocks() : RamFileObj
  • DeleteDir() : FfsHandler
  • DeletedNode() : DeletedNode
  • DeletedNodeList() : DeletedNodeList
  • DeleteDrmRights() : DrmAsset
  • DeleteEntries() : PbRecordHandler, SimPbBaseHandler
  • DeleteEntry() : ToDoProvider, PbRecordHandler, SimPbBaseHandler
  • DeleteEqualNode() : RamFileNode
  • DeleteExtLanguage() : SimAuxHandler
  • DeleteFile() : RootFileSystem
  • DeleteImageReq() : BtBipClientService
  • DeleteImageRsp() : BtBipServerService
  • DeleteItem() : CalendarRecordsListBoxModel, DBService
  • DeleteLanguage() : SimAuxHandler
  • DeleteLater() : Component
  • DeleteLndEntry() : SimPbBaseHandler
  • DeleteLockTable() : LockTableList
  • DeleteNode() : RegNodeBuffer, RamFileSystem
  • DeletePlmn() : SimAuxHandler
  • DeletePlmnwAct() : SimAuxHandler
  • DeleteProfile() : DataConnProfileManager
  • DeletePtrObj() : FixedPtrArray< T >
  • DeleteRecord() : NvRamDataRecordHandler, RecordHandler, DataRecordHandler
  • DeleteRegistration() : NotificationTable
  • DeleteRightsObject() : DrmRightsObjectStore
  • DeleteRow() : ToDoProvider, DataConnProvider, CalendarProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, PbMergeProvider, Provider, DistinctProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, CbmiRangeProvider, CbmiProvider
  • DeleteSelectedItem() : CalendarRecordsList, CalendarListWin
  • DeleteSelectedNumber() : PhonebookApp
  • DeleteSelectedPbEntry() : PhonebookApp
  • DeleteSms() : AbstractSmsApp
  • DeleteSubNode() : RamFileNode
  • DeleteUri() : NotificationArray
  • DeleteWapProfile() : WapProfileMgr
  • Deregister() : ObexServerMngr, ObexServerInfo, GatiManager
  • DeregisterApplication() : HttpApplicationSupplier
  • DeregisterAvrcpApp() : BtAvrcpPanelServiceImpl, BtAvrcpPanelService, BtAvrcpPanelApplication
  • DeRegisterRequest() : BtAvrcpRegistrationService
  • DeselectUsimPb() : DataHandler
  • Desktop() : Desktop
  • Destroy() : GuiObjectFactory, ObexBuffer::Factory, AudioGatiServer, GatiServer, StackMsgArgDestroyTableNode, StreamObexImpl
  • DestroyAction() : ObexAbstractPort
  • DestroyImage() : ImageFactory
  • DestroyInstance() : DrmROStoreSingleton
  • DestroyMediaPlayer() : MediaManager
  • DestroyMediaRecorder() : MediaManager
  • DestroyModel() : EmsEditor, MultiMediaEditor
  • DestroyPanel() : Application
  • DestroyPlayerInstance() : MediaBox
  • DestroySelf() : StackMsgArgDestroyTableNode
  • DestroyT9() : ChineseT9Wrapper
  • Destruct() : Allocator< T >
  • Detach() : InetSocket, ObexDispatcher, MessageHook, AppContainer, BtObexServerService, BtObexClientService, BtSddbService, BtObservableService, ObservableObject, RtStreamingSource, RtStreamingSink, RtStreamingEndPoint, AtlApplicationPlugin, PlmnHandler, PlmnDispatcher, PdpContextManager
  • DetachCnfArg() : DetachCnfArg
  • DetachOppServer() : ObexServerOppImpl
  • DetachReqArg() : DetachReqArg
  • DetectChvProtection() : SimAuxHandler
  • DetectEncoding() : JapaneseTranscoder
  • DetectSimCardType() : SimAccessor
  • DeviceContext() : DeviceContext
  • DeviceSearchCancelRequest() : BtDeviceListWindow
  • DhChannelChangeStatusEventArg() : DhChannelChangeStatusEventArg
  • DhChannelChangeStatusResArg() : DhChannelChangeStatusResArg
  • DhChannelChangeStatusResMsg() : DhChannelChangeStatusResMsg
  • DhChannelCloseIndArg() : DhChannelCloseIndArg
  • DhChannelCloseReqArg() : DhChannelCloseReqArg
  • DhChannelCloseReqMsg() : DhChannelCloseReqMsg
  • DhChannelDataAvailableResArg() : DhChannelDataAvailableResArg
  • DhChannelDataAvailableResMsg() : DhChannelDataAvailableResMsg
  • DhChannelDataAvailEventArg() : DhChannelDataAvailEventArg
  • DhChannelOpenCnfArg() : DhChannelOpenCnfArg
  • DhChannelOpenRejArg() : DhChannelOpenRejArg
  • DhChannelOpenReqArg() : DhChannelOpenReqArg
  • DhChannelOpenReqMsg() : DhChannelOpenReqMsg
  • DhChannelReceiveIndArg() : DhChannelReceiveIndArg
  • DhChannelReceiveReqArg() : DhChannelReceiveReqArg
  • DhChannelReceiveReqMsg() : DhChannelReceiveReqMsg
  • DhChannelSendIndArg() : DhChannelSendIndArg
  • DhChannelSendReqArg() : DhChannelSendReqArg
  • DhChannelSendReqMsg() : DhChannelSendReqMsg
  • DiagnosticIndArg() : DiagnosticIndArg
  • DiagnosticIndMsg() : DiagnosticIndMsg
  • DigitsOnly() : SimGetInkeyOptions, SimGetInputOptions
  • DirectoryIterator() : DirectoryIterator
  • Disable() : IrdaTransport, CamWin32, SpeechSimpleAudioDevice, SimpleAudioDevice, RadioAudioDevice
  • DisableChv() : SimChvHandler
  • DisableChv1() : SimAccessor
  • DisabledFeatureTriggeredMsg() : DisabledFeatureTriggeredMsg
  • DisableGlobalActiveDuration() : Cbs::Filter
  • DisableGlobalSleepDuration() : Cbs::Filter
  • DisableLoading() : BootControl
  • DisablePin() : SimAccessor
  • DiscardHeaders() : BtObexService
  • Disconnect() : ObexLayer, ObexClientOppImpl, ObexClient, IrdaObexImpl, MmiSimClient, BtObexImpl, ExtPsdContextListener_SerialTerminal, StreamObexImpl, SerialTerminal
  • DisconnectActivePsdCalls() : MmCallHdl, MmCallHandler
  • DisconnectClient() : HttpServer, FtpServer
  • DisconnectReq() : BtBipClientService
  • DisconnectRequest() : BtObexClientService, BtHsService, BtHfService, BtFaxService, BtDunService, BtSingleConnectionController, BtAudioAccessoryService, BtAvrcpOperationService
  • DiskAbort() : FatHandler
  • DiskAssignDriveLetter() : FatHandler
  • DiskClose() : FatHandler
  • DiskFlush() : FatHandler
  • DiskFormat() : FatHandler
  • DiskGetLastDeviceError() : FatHandler
  • DiskInfo() : FatHandler
  • DiskOpen() : FatHandler
  • DiskSetDefaultDevice() : FatHandler
  • Dispatcher() : Dispatcher
  • DispatcherAction() : DispatcherAction
  • Display() : BtAlertMessageWindow, BtAvrcpAlertMessageWindow, Display, OptionalConfigBase, Led
  • DisplayDc() : DisplayDc
  • DisplayDlg() : MediaBrowserUtils
  • DisplayInfoMsg() : DisplayInfoMsg
  • DisplayMap() : LcsWapIntf
  • DisplayMemory() : PhonebookApp, AdvPbApp
  • DisplayMsg() : LcsSettingsUtils, LcsAppUtils
  • DisplayOnGlassPane() : IndicatorLocation
  • DisplaySettings() : DisplaySettings
  • DisplaySimPos() : PbDetails, PbAbstractWin
  • DisplayTextReqArg() : DisplayTextReqArg
  • DisplayTextRspArg() : DisplayTextRspArg
  • DistinctProvider() : DistinctProvider
  • DistinctRule() : DistinctRule
  • DlUarfcnInvalid() : UmtsNcellParam
  • DnsClient() : DnsClient, SysDnsClient
  • DnsClientTest() : DnsClientTest
  • DoAddNumber() : PbManualSynchronizer
  • DoDataCompr() : PsdDataConnProfile
  • DoesApply() : DrmConstraint
  • DoesSynchronousDrawing() : Application
  • DoHeaderCompr() : PsdDataConnProfile
  • DoListCmd() : FtpClient
  • Done() : ActiveWaitDispatcher
  • DoOperation() : BtDeviceListWindow
  • DoRead() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoReadStreaming() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoReadStreamingAsync() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoRelease() : PsdDataConn, PppDataConn, DataConn
  • DoRequestOperation() : BtDeviceListWindow
  • DoRetrCmd() : FtpClient
  • DoSetup() : PsdDataConn, PppDataConn, DataConn
  • DoStartPppRelease() : PppDataConn
  • DoStartPppSetup() : PppDataConn
  • DoStorCmd() : FtpClient
  • DoWrite() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoWriteStreaming() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • DoWriteStreamingAsync() : File, RootFileImp, RamFileImp, FlashFileImp, FatFileImp
  • Draw() : EmsImage, CalendarMonthSelectorView, CalendarGridView, WindowFrameView, View, TimeEditorDocument, TimeCompoundItem, TextLineView, TextEditorDocument, TextCompoundItem, TextBoxView, TabControlView, TabButtonView, RadioButtonControlView, PushButtonView, ProgressBarView, PositionIndicatorView, PanelView, NativeImage, MultiTapCaret, ItemBoxView, IpAddrCompoundItem, Image, GlassPane, PaneObject, EditorDocument, DrawableObject, DefaultCaret, DateEditorDocument, DateEditorView, DateCompoundItem, ControlFrameView, Control, CompoundItem, CheckBoxControlView, CharItem, Caret, AtomItem, AbstractRenderer, AbstractMultiLineEditorView, AbstractLineEditorView, ScanlineAccessor, TimeEditBoxView, TextMenuAccessor, SoundItem, SoftkeyBarView, RadioButtonView, MenuAccessor, MenuView, IndicatorBarPaneObject, IndicatorPaneObject, IndicatorBarView, IconValueIndicator, IconTextIndicator, TextIndicator, IconIndicator, Indicator, GridView, EditBoxView, DateEditBoxView, CheckBoxView, AnimationView, AbstractMenuAccessor, AbstractListBoxView, ItemLabelView, Zi8StrokeBoxView, Zi8SelectionBoxView, Zi8AlphabetBoxView, T9PinyinBoxView, StrokeBoxView, SelectionBoxView, SvgImage, VCardItem, RichTextCompoundItem, PngImage, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, ImageItem, GeneralCompoundItem, AudioItem, MediaBoxView
  • DrawableObject() : DrawableObject
  • DrawableObjectView() : DrawableObjectView
  • DrawArc() : DeviceContext
  • DrawBackground() : DefaultItemRenderer, AbstractItemRenderer, AtlItemRenderer
  • DrawBitmap() : DeviceContext, CTResourcePack
  • DrawCell() : GridView
  • DrawCellPostHighlighted() : GridView
  • DrawCellPreHighlighted() : GridView
  • DrawChar() : VirtualDisplay
  • DrawCheckBox() : DefaultCheckBoxView, TestCheckBoxView, DefaultCheckBoxView, BlueSkyCheckBoxView, CheckBoxView
  • DrawCheckBoxItem() : DefaultCheckBoxListView, TestCheckBoxListView, DefaultCheckBoxListView, BlueSkyCheckBoxListView, CheckBoxListView
  • DrawCircle() : DeviceContext
  • DrawClientAreaBackground() : ControlFrameView, DefaultWindowFrameView
  • DrawComponent() : CustomizableTheme
  • DrawControlFrame() : ControlFrameView, FoggyWindowFrameView, DefaultWindowFrameView, DefaultControlFrameView, CTWindowFrameView, CTControlFrameView, TestWindowFrameView, TestControlFrameView, DefaultWindowFrameView, DefaultControlFrameView, BlueSkyWindowFrameView, BlueSkyControlFrameView
  • DrawCorruptImageSign() : Image
  • DrawCursor() : AbstractEditBox, AbstractEditBoxView
  • DrawDateEditBox() : DateEditBoxView
  • DrawEditBox() : EditBoxView
  • DrawFrameComponents() : ControlFrameView
  • DrawGlyphInItalic() : AbstractTextRenderer
  • DrawGsmBitmap() : DeviceContext
  • DrawHeightScaledScanline() : PngImage
  • DrawItem() : ImageListBoxView, DefaultItemRenderer, AbstractItemRenderer, TextListView, RadioButtonListView, ProviderListBoxView, MenuListView, CheckBoxListView, AtlItemRenderer, AbstractListBoxView
  • DrawItemBorder() : ItemTree, AbstractItemGrid
  • DrawLayer() : Control
  • DrawLine() : DeviceContext
  • DrawMarkedItemSelection() : MultiMediaEditor
  • DrawMenuItem() : MenuListView
  • DrawPanel() : PanelView, FoggyPanelView, DefaultPanelView, CTPanelView
  • DrawPixel() : DeviceContext, PngImage
  • DrawPolygon() : DeviceContext
  • DrawPositionIndicator() : PositionIndicatorView, AbstractGrid, FoggyPositionIndicatorView, DefaultPositionIndicatorView, CTPositionIndicatorView, TestPositionIndicatorView, DefaultPositionIndicatorView, BlueSkyPositionIndicatorView
  • DrawProgressBar() : ProgressBarView, DefaultProgressBarView, CTProgressBarView, DefaultProgressBarView, BlueSkyProgressBarView
  • DrawPushButton() : PushButtonView, FoggyPushButtonView, DefaultPushButtonView, CTPushButtonView, TestPushButtonView, DefaultPushButtonView, BlueSkyPushButtonView
  • DrawRadioButton() : DefaultRadioButtonView, RadioButtonView, TestRadioButtonView, DefaultRadioButtonView, BlueSkyRadioButtonView
  • DrawRadioButtonItem() : DefaultRadioButtonListView, RadioButtonListView, TestRadioButtonListView, DefaultRadioButtonListView, BlueSkyRadioButtonListView
  • DrawRect() : DeviceContext
  • DrawRoundRect() : DeviceContext
  • DrawScaledPixel() : PngImage
  • DrawScanline() : NativeImage, Image, WbmpImage, PngImage, JpegImage, GifImage, BmpImage
  • DrawSelection() : AbstractEditor
  • DrawShifted() : RadioButtonView, CheckBoxView
  • DrawShiftedCheckBox() : DefaultCheckBoxView, TestCheckBoxView, DefaultCheckBoxView, BlueSkyCheckBoxView, CheckBoxView
  • DrawShiftedRadioButton() : DefaultRadioButtonView, RadioButtonView, TestRadioButtonView, DefaultRadioButtonView, BlueSkyRadioButtonView
  • DrawSoftkeyBar() : FoggySoftkeyBarView, DefaultSoftkeyBarView, SoftkeyBarView, TestSoftkeyBarView, FoggySoftkeyBarView, DefaultSoftkeyBarView, BlueSkySoftkeyBarView
  • DrawTabButton() : TabButtonView, DefaultTabButtonView
  • DrawTabControl() : TabControlView, DefaultTabControlView
  • DrawText() : ThaiTextRenderer, SimpleTextRenderer, DeviceContext, DefaultItemRenderer, ArabicTextRenderer, AbstractTextRenderer
  • DrawTextBox() : DeviceContext
  • DrawTextInvert() : DeviceContext
  • DrawTextListItem() : DefaultTextListView, TextListView, DefaultTextListView, BlueSkyTextListView
  • DrawTimeEditBox() : TimeEditBoxView
  • DrawWindowExtensions() : WindowFrameView, FoggyWindowFrameView, DefaultWindowFrameView, CTWindowFrameView, TestWindowFrameView, DefaultWindowFrameView, BlueSkyWindowFrameView
  • DrmAsset() : DrmAsset
  • DrmConstraint() : DrmConstraint
  • DrmCrypt() : DrmSecurity
  • DrmDcfParser() : DrmDcfParser
  • DrmInfo() : DrmInfo
  • DrmMessage() : DrmMessage
  • DrmPermission() : DrmPermission
  • DrmRelParser() : DrmRelParser
  • DrmRightsObject() : DrmRightsObject
  • DrmRightsObjectStore() : DrmRightsObjectStore
  • DrmROStoreSingleton() : DrmROStoreSingleton
  • DrmSecurity() : DrmSecurity
  • DrmSubsystem() : DrmSubsystem
  • DrmWapPushMsg() : DrmWapPushMsg
  • DtmfBufferCleanedMsg() : DtmfBufferCleanedMsg
  • DtmfBufferClearedIndArg() : DtmfBufferClearedIndArg
  • DtmfRejectMsg() : DtmfRejectMsg
  • DtmfStartCnfMsg() : DtmfStartCnfMsg
  • DtmfStopCnfMsg() : DtmfStopCnfMsg
  • DualFilterProvider() : DualFilterProvider
  • Dummy() : StackMsgArgDestroyTableNode
  • DummyVrEngineParams() : DummyVrEngineParams
  • Dump() : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, OnDataRcvdMsg, ObexVCardMsg, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg
  • DumpMemoryConsumptionSnapshot() : HeapManager
  • DumpMemoryContextSnapshot() : HeapManager
  • DumpTables() : SmsSocketListener
  • DwdDevice() : DwdDevice
  • DwdPlayer() : DwdPlayer, RadioAudioDevice
  • DynamicBitVector() : DynamicBitVector
  • DynamicMenuPool() : DynamicMenuPool
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- e -

  • EccCategory() : EccCategory
  • EccListIndArg() : EccListIndArg
  • EccProvider() : EccProvider
  • EctActiveMsg() : EctActiveMsg
  • EctAlertingMsg() : EctAlertingMsg
  • EctCnfArg() : EctCnfArg
  • Edit() : PropertyEditorFactory
  • EditBox() : EditBox
  • EditBoxBlinkTimer() : EditBoxBlinkTimer, AbstractEditBox
  • EditBoxPagingTimer() : EditBoxPagingTimer, EditBox
  • EditBoxView() : EditBoxView
  • EditDetail() : PbDetails
  • EditLine() : EditLine
  • EditorDocument() : EditorDocument
  • EditorDocumentObtainer() : EditorDocumentObtainer
  • EditorItemNode() : EditorItemNode
  • EditorLine() : EditorLine
  • EditProperty() : PropertyEditor
  • ElementList() : ElementList< T >
  • ElementListBase() : ElementListBase
  • emcpp_apoxi_OBEXAdapter() : emcpp_apoxi_OBEXAdapter
  • EmlppAction() : EmlppAction
  • EmlppHandler() : EmlppHandler
  • EmlppRegisteredMsg() : EmlppRegisteredMsg
  • EmlppStatusMsg() : EmlppStatusMsg
  • empty() : WbxmlVector< T >
  • Empty() : ObexBuffer, Tpdu
  • EmptyCache() : SmsSocketListener
  • EmptyRWBuffer() : SimPbBaseHandler
  • EmsComposeWin() : EmsComposeWin
  • EmsCreator() : EmsCreator
  • EmsEditor() : EmsEditor, EmsEditorListener
  • EmsEditorListener() : EmsEditorListener
  • EmServThreadMsg() : EmServThreadMsg
  • EmsIeParser() : EmsIeParser
  • EmsImage() : EmsImage
  • EmsInsertPrompt() : EmsInsertPrompt
  • EmsInsertPromptListBoxModel() : EmsInsertPromptListBoxModel
  • EmsViewerWin() : EmsViewerWin
  • Enable() : IrdaTransport, CamWin32, AbstractTransport, BtTransport, SpeechSimpleAudioDevice, SimpleAudioDevice, RadioAudioDevice, UsbTransport
  • Enable3dSound() : AudioPathManager
  • EnableBuiltinEccCodes() : DataHandler
  • EnableChv() : SimChvHandler
  • EnableChv1() : SimAccessor
  • EnableDataCompr() : PsdDataConnProfile
  • EnableDcsListFilter() : Cbs::Filter
  • EnableEcNr() : AudioAccessoryDetails
  • EnableGlobalActiveDuration() : Cbs::Filter
  • EnableGlobalSleepDuration() : Cbs::Filter
  • EnableHeaderCompr() : PsdDataConnProfile
  • EnableLoading() : BootControl
  • EnableMasterMute() : AudioDeviceManager
  • EnableMidListFilter() : Cbs::Filter
  • EnablePasswdQuery() : DataConnProfile
  • EnablePeakMemoryContextOutput() : HeapManager
  • EnablePhonebook() : PhonebookApp
  • EnablePidCheckForConcSms() : SimPduHandler, DataHandler
  • EnablePin() : SimAccessor
  • EnableProactiveDtmfTones() : SimTkHandler
  • EnableResendingSmsOverCs() : SmsHandler
  • EnableSimActions() : PhonebookApp
  • EnableTransaction() : Registry, RegEncoderDecoder
  • EnableUplinkAudioPaths() : AudioPathManager
  • EnableUsagePureUcs2Encoding() : AlphaCoding
  • Encode() : RegEncoderDecoder, ImageEncoder, PngEncoder, JpegEncoder
  • EncodeAlphaField() : AlphaCoding
  • EncodeBase64() : MimeCoding
  • EncodeBuffer() : EmzSbcEncoder, AudioEncoder
  • EncodeChar() : QuotedPrintableCoder
  • EncodeEnd() : Base64Coder, QuotedPrintableCoder
  • EncodeFrame() : ScicosMpeg4VideoEncoder, EmzMpeg4Encoder, AtiMpeg4Encoder, EmzSbcEncoder, EmzMpeg4Encoder, VideoEncoder, AudioEncoder
  • EncodePush() : Base64Coder, QuotedPrintableCoder
  • EncodeQuotedPrintable() : MimeCoding
  • EncodeSetupMsg() : RegEncoderDecoder
  • EncodeSynchronously() : ImageEncoder, PngEncoder, JpegEncoder
  • EncodeUncertRadius() : LcsUtils
  • EncodingParameters() : ImageEncoder::EncodingParameters, PngEncoder::EncodingParameters, JpegEncoder::EncodingParameters
  • EncodingThreadlet() : EncodingThreadlet, ImageEncoder
  • End() : BtDeviceList, Vector< T >, MessageIdentifierRange, DataCodingSchemeRange, Pathname, FlowLayout, IndicatorLocation
  • end() : WbxmlVector< T >
  • EndCDATAHandler() : XMLParser
  • EndDecoding() : ImageDecoder, PngDecoder
  • endDocument() : WbxmlParserRel
  • EndDocument() : XMLParser
  • EndDrawing() : PngImage
  • endElement() : WbxmlParserRel
  • EndElement() : XMLParser
  • EndEncoding() : ImageEncoder, PngEncoder, JpegEncoder
  • EndGlyphRetrieval() : AbstractTextRenderer
  • EndInternalUpdate() : ParagraphCompoundItem
  • EndOfStream() : StreamingReadInfo
  • EndOperation() : StreamObexImpl
  • EndProcessing() : BidiManager
  • EndScanlineDrawing() : NativeImage, Image, WbmpImage, JpegImage, GifImage, BmpImage
  • EndSimToolkitIndArg() : EndSimToolkitIndArg
  • EndsWith() : WString, String
  • endswith() : Uri
  • EndTransaction() : UssdHandler
  • EndUpdate() : DeviceContext
  • EngineeringModeControlRequestArg() : EngineeringModeControlRequestArg
  • EngineeringModeControlResponseArg() : EngineeringModeControlResponseArg
  • EngineeringModeControlResponseMsg() : EngineeringModeControlResponseMsg
  • EngineeringReportMsg() : EngineeringReportMsg
  • EnglishT9InputMapper() : EnglishT9InputMapper
  • EngModeAction() : EngModeAction
  • Enqueue() : AppContainer, KeyMsgGenerator
  • EnsureContext() : InetSocket
  • EnterNewEntry() : PhonebookApp
  • EnterNumber() : PbSelectNumberWin
  • Entry() : SmsWStringCache::Entry
  • EnumTransports() : ObexMngr
  • Eof() : FileOutputStream, FileInputStream
  • EqualName() : PbManualSynchronizer
  • EqualNumber() : PbManualSynchronizer
  • EqualsRule() : EqualsRule
  • Erase() : BtDeviceList, WString, Vector< T >, String, UusHandler, CallForwardingHandler
  • erase() : WbxmlVector< T >
  • EraseCursor() : AbstractEditBox
  • error() : WbxmlParserRel
  • Error() : ImageEncoder, ShortMessageFailureCause, File, StreamObexImpl, PngDecoder, VrHandler, InternalTracer, ExtPsdContextListener_SerialTerminal, SerialTerminal, AtResponse
  • ErrorHandler() : XMLParser
  • ErrorRsp() : BtBipServerService
  • EstablishDataConnection() : FtpClient
  • EvalAvsAction() : ObexAbstractPort
  • EvaluateExecutionResult() : BtObexRequest, BtRequest, BtBppReq
  • EvaluateMessageResult() : BtRequestRespondRequest, BtLocalRequest
  • Exclude() : ObexTransportSet
  • ExcludePlayer() : AudioPlayerStore
  • ExecCdupCmd() : FtpClient
  • ExecCmd() : FtpServer, FtpClient
  • ExecCwdCmd() : FtpClient
  • ExecDeleCmd() : FtpClient
  • ExecListCmd() : FtpClient
  • ExecMkdCmd() : FtpClient
  • ExecModeCmd() : FtpClient
  • ExecNoopCmd() : FtpClient
  • ExecPassCmd() : FtpClient
  • ExecPasvCmd() : FtpClient
  • ExecPortCmd() : FtpClient
  • ExecPwdCmd() : FtpClient
  • ExecQuitCmd() : FtpClient
  • ExecRetrCmd() : FtpClient
  • ExecRmdCmd() : FtpClient
  • ExecStorCmd() : FtpClient
  • ExecStruCmd() : FtpClient
  • ExecTypeCmd() : FtpClient
  • ExecUserCmd() : FtpClient
  • Execute() : SaveNoAction, CopyToPbAction, AddNumberToFdnAction, AddEntryToFdnAction, AddAllToFdnAction, DisplayMemoryAction, SyncAction, PbDelAllAction, PbDeleteAction, PbCallAction, PbCancelEditAction, PbConfirmEditAction, PbEditDetailAction, PbAddAction, PbSecuredAction, PbAction, SyncPhoneAction, SyncSimAction, SyncPhoneAllAction, SyncSimAllAction, PbSelectGroupAction, PbChangeNoTypeAction, PbDelPhonenoAction, PbCancelAddNoAction, PbConfirmAddNoAction, PbAddPhoneNoAction, Threadlet, ContextExecuteMsg, MessageMapContainer< T >, AbstractMessageMapContainer, OpenWindowAction, OpenContextMenuAction, CloseWindowAction, Action, AbstractToggleAction, ShutDown, SetThemeAction, SetLanguageAction, ConfirmAction, CancelAction, BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexSetPathRequest, BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtObexPutRequest, BtObexGetRequest, BtObexDisconnectRequest, BtObexConnectRequest, BtObexAbortRequest, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtSendPasskeyRequest, BtRespondAuthorizationRequest, BtRequest, BtQuerySupportedProfilesRequest, BtDisconnectRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtConnectRequest, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRegisterRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse, BtAvrcpDeRegisterRequest, BtAvrcpConnectResponse, PropertyItem, TriggerKeyFeature, IndicatorItem, FeatureItem, FeatureHandle, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, ContextFeatureHandle, SsEmlppActionImpl, SsUssdActionImpl, SsCnapActionImpl, SsColpActionImpl, SsColrActionImpl, SsClipActionImpl, SsClirActionImpl, SsCallWaitingActionImpl, SsCallForwardingActionImpl, SsCallBarringActionImpl, SsPasswordChangeActionImpl, UnlockAction, InputAction, StackMsgArgMapContainer< T >, AbstractStackMsgArgMapContainer, RegCbNotifyMsg, ApplicationAction
  • ExecuteFeature() : MmfPlayer, AudioDeviceBase
  • ExecuteRequest() : BtServiceRequest, BtRequest, BtLocalRequest
  • ExecuteRule() : GreaterRule, LessRule, RangeRule, NotEqualsRule, EqualsRule, FilterRule, DistinctRule, PhoneNumberMatchRule, PhoneNumberJoinRule, StandardJoinRule, JoinRule, DcsLanguageFilterRule
  • ExecuteThreadlet() : ImageEncoder
  • ExecutionCallback() : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexSetPathRequest, BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtObexPutRequest, BtObexGetRequest, BtObexDisconnectRequest, BtObexConnectRequest, BtObexAbortRequest, BtServiceRequest, BtRequest, BtLocalRequest, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest
  • ExecutionContext() : ExecutionContext, UserDispatcher
  • ExistColumn() : PbSimProvider, Provider
  • Exists() : SimpleMap< TKey, TValue >, ElementList< T >, MessageIdentifierContainer, Cbs::Filter, StorageDevice, RootFileSystem, File, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • ExistsEntry() : PbRecordHandler
  • ExistsRecord() : ToDoProvider, RecordHandler
  • Expand() : Rect
  • ExplicitCallTransfer() : CrssHandler, CallHdl
  • ExportInternalBuffer() : TextCompoundItem
  • ExtendToUuid128() : BtObexServiceTable
  • ExtensionExists() : FunctionalityIndicator, ParameterIndicator
  • ExternalCommunicationHandler() : ExternalCommunicationHandler
  • ExternalEvent() : ObexAbstractPort, StateMachine
  • ExternalPdpContextInfoMsg() : ExternalPdpContextInfoMsg
  • ExternalTimeoutMsg() : ExternalTimeoutMsg
  • ExtProactiveCmdCnfArg() : ExtProactiveCmdCnfArg
  • ExtProactiveCmdIndArg() : ExtProactiveCmdIndArg
  • ExtProactiveCmdReqArg() : ExtProactiveCmdReqArg
  • ExtPsdContextListener_SerialTerminalListener() : ExtPsdContextListener_SerialTerminalListener
  • ExtPsdContextListener_SioGlueSignalListener() : ExtPsdContextListener_SioGlueSignalListener, ExtPsdContextListener_SerialTerminal
  • ExtPsdContextListenerImpl_SerialTerminalListener() : ExtPsdContextListenerImpl_SerialTerminalListener
  • ExtractHeaderFields() : ObexFtpDataServer
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- f -

  • Factory() : ObexBuffer::Factory, ObexBuffer
  • FastForward() : MP3AudioPlayer, MmfPlayer, MediaPlayer
  • FastReverse() : MP3AudioPlayer
  • fatalError() : WbxmlParserRel
  • FatDirectoryIteratorImp() : FatDirectoryIteratorImp, FatStorageDeviceImp
  • FatFile() : FatFile, FatStorageDeviceImp
  • FatFileImp() : FatFileImp, FatStorageDeviceImp
  • FatFsUsbMassStorageReleaseMsg() : FatFsUsbMassStorageReleaseMsg
  • FatFsUsbMassStorageRequestMsg() : FatFsUsbMassStorageRequestMsg
  • FdnIndArg() : FdnIndArg
  • FdnReqArg() : FdnReqArg
  • Feature() : SimTkProfile, Feature, AudioDeviceBase, FeatureBroker
  • FeatureChangedMsg() : FeatureChangedMsg
  • FeatureHandle() : FeatureHandle
  • FeatureItem() : FeatureItem
  • FeatureItemContainer() : FeatureItemContainer
  • FeatureTriggerMsg() : FeatureTriggerMsg
  • FFindFirst() : FfsHandler
  • FFindNext() : FfsHandler
  • FfsDataConnProfileStorage() : FfsDataConnProfileStorage
  • FfsFile() : FfsFile
  • FfsMenu() : FfsMenu
  • FfsTest_T1() : FfsTests
  • FfsTest_T2() : FfsTests
  • FfsTest_T3() : FfsTests
  • FfsTest_T4() : FfsTests
  • FfsTest_T5() : FfsTests
  • FfsTest_T6() : FfsTests
  • FfsTestDispWin() : FfsTestDispWin
  • FfsTestMenu() : FfsTestMenu
  • FfsTestResultsMenu() : FfsTestResultsMenu
  • FfsTestResultsSubMenu() : FfsTestResultsSubMenu
  • FfsTests() : FfsTests
  • FfsTestSubMenu() : FfsTestSubMenu
  • FfsTestThread() : FfsTestThread
  • FifoLinkedList() : FifoLinkedList< T >
  • File() : File, StorageDevice
  • FileBinData() : FileBinData
  • FileChunkOperationProgressMsg() : FileChunkOperationProgressMsg
  • FileChunkOperator() : FileChunkOperator, File
  • FileDataSink() : FileDataSink
  • FileDataSource() : FileDataSource
  • FileExist() : FfsHandler
  • FileExists() : RamHandler, FatHandler
  • FileFilter() : FileFilter
  • FileInputStream() : FileInputStream
  • FileNameListBoxModel() : FileNameListBoxModel
  • FileNameView() : FileNameView
  • FileOutputStream() : FileOutputStream
  • FilePack() : FilePack
  • FileState() : File::FileState
  • FileVisitor() : FileVisitor
  • Fill() : MdhGors, SimImage, SimIconDescription, SimImageDescriptor
  • FillArc() : DeviceContext
  • FillCircle() : DeviceContext
  • FillHeader() : GltpRequest
  • FillIndexValues() : IndexTable< T >
  • FillPolygon() : DeviceContext
  • FillRect() : DeviceContext, VirtualDisplay
  • FillRoundRect() : DeviceContext
  • FillRWBuffer() : SimPbBaseHandler
  • FillZeroes() : IndexTable< T >
  • Filter() : BtDeviceList, Cbs::Filter
  • FilterProvider() : FilterProvider
  • FilterRule() : FilterRule
  • Finalize() : GuiObjectFactory
  • FinalizeBuffer() : StreamObexImpl
  • Find() : ObexHeaderList, BtDeviceList, RamHandler
  • Find2Provider() : Find2Provider
  • FindAudioDataOffset() : AudioUtility
  • FindConnectionByApoxiHandle() : BtMultiConnectionController
  • FindConnectionByDevice() : BtMultiConnectionController
  • FindConnectionByRequest() : BtMultiConnectionController
  • FindContext() : PdpContextManager
  • FindData() : MmfPlayer
  • FindDataConnProfiles() : SocketTestApp, RegAppWin
  • FindDone() : RamHandler, FatHandler
  • FindFirst() : FfsHandler, RamHandler, FatHandler
  • FindNext() : FfsHandler, RamHandler, FatHandler
  • FindNode() : RamFileSystem
  • FindProvider() : FindProvider
  • FindReference() : DwdDevice
  • FindRow() : PbManualSynchronizer
  • FindRowByTpduNumber() : SmsProvider, SimPduHandler
  • FindSortedRow() : SortProvider
  • FindUriFromTables() : LockTableList
  • Finish() : IncrementalPdcUpdater
  • FinishGroup() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT
  • First() : VoiceMemoMenuAccessor, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, DataConnAccessor, TextMenuAccessor, AbstractMenuAccessor, ActionMenuAccessor, AbstractSmsViewerWin
  • FixedPtrArray() : FixedPtrArray< T >
  • FlagCaretaker() : FlagCaretaker
  • FlashDeletePdu() : StackWrapper
  • FlashDirectoryIteratorImp() : FlashDirectoryIteratorImp, FlashStorageDeviceImp
  • FlashFileImp() : FlashFileImp, FlashStorageDeviceImp
  • FlashReadPdu() : StackWrapper
  • FlashStorageDeviceImp() : FlashStorageDeviceImp, FlashFileImp, FlashDirectoryIteratorImp
  • FlashWritePdu() : StackWrapper
  • FlipMsg() : FlipMsg
  • FlowLayout() : FlowLayout
  • FlsFile() : FlsFile, FlashStorageDeviceImp
  • Flush() : ScicosMpeg4VideoDecoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, TraceOutputStream, OutputStream, FileOutputStream, DebugOutputStream, BufferedOutputStream, StreamWriter, StorageDevice, RamHandler, FatStorageDeviceImp, FatHandler
  • FlushBuffers() : EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Encoder, AtiMpeg4Decoder, RegMemoryPool, VideoEncoder, VideoDecoder
  • FlushDirtyFile() : DirtyFileHandler
  • FlushMapFile() : UriMappingTable
  • FmRadioEditWin() : FmRadioEditWin
  • FmRadioSelectStrongerFreq() : FmRadioSelectStrongerFreq
  • FmRadioSettingsProvider() : FmRadioSettingsProvider
  • FmRadioSettingsRecord() : FmRadioSettingsRecord
  • FmRadioStationsProvider() : FmRadioStationsProvider
  • FmRadioStationsRecord() : FmRadioStationsRecord
  • FmRadioWindow() : FmRadioWindow
  • FmRatioSettingsRecord() : FmRadioSettingsRecord
  • Fn() : UibUpdateThreadlet, FfsTestThreadlet, UpdatePbThreadlet, SyncPhoneThreadlet, Threadlet, EncodingThreadlet, DecodingThreadlet
  • FocusNextControlMsg() : FocusNextControlMsg
  • FocusObtainer() : FocusObtainer, System
  • FocusPreviousControlMsg() : FocusPreviousControlMsg
  • FoggyPositionIndicatorView() : FoggyPositionIndicatorView
  • FoggyPushButtonView() : FoggyPushButtonView
  • FoggyTheme() : FoggyTheme
  • FoggyWindowFrameView() : FoggyWindowFrameView
  • Font() : Font
  • FontEntry() : FontEntry
  • FontPack() : FontPack
  • ForceNormalUpdateOnStartup() : SmsProvider
  • ForceWcharsTo7bitWchars() : DataCoding
  • ForgetRecordingReference() : StreamAudioPlayer
  • FormAidingRequest() : GltpAidDataRequests
  • Format() : RingerAudioDevice, Time, Date, CustomRingerAudioReference, ValidityPeriodFormat, WString, TimeZone, String, DateTime, StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, RamHandler, FlashStorageDeviceImp, FatStorageDeviceImp, AudioDecoder
  • FormatFileSystem() : RamFileSystem
  • FormatLockTableUri() : Uri
  • FormatStorage() : RamStorageMapper
  • FormatUriHeader() : Uri
  • FormMsmtRequest() : GltpAidDataRequests
  • FormPosnRequest() : GltpAidDataRequests
  • FormQos() : LcsAppUtils, LcsUtils
  • FormRequest() : GltpPositionRequest, GltpMsmtRequest, GltpAidingRequest, GltpHelloRequest
  • ForwardCommandToDriver() : MapiAudioPlayer
  • ForwardedCallIncomingMsg() : ForwardedCallIncomingMsg
  • ForwardingInfoReceivedMsg() : ForwardingInfoReceivedMsg
  • ForwardingSsAction() : ForwardingSsAction
  • ForwardSms() : AbstractSmsApp, EmsApp
  • Fraction() : Fraction
  • FrameDc() : FrameDc
  • Free() : Os, HeapVector::VarPage, HeapVector::BlockPage, HeapManager, Allocator< T >, ByteBuffer
  • FreeCaptureBuffers() : VideoCamera
  • FreeDeletionBuffer() : RegDeletionBufferEntry
  • FreeImage() : PngImage, JpegImage
  • FreeNodeBuffer() : RegMemoryPool
  • FreePng() : PngDecoder
  • FreezeViewFinder() : CamWin32
  • FromPtr() : WStrData, StrData
  • FromStackMsg() : FromStackMsg, StackMsgArgument
  • FromUtf8ToWString() : String
  • Front() : BtDeviceList, Vector< T >
  • front() : WbxmlVector< T >
  • FtpAuthProvider() : FtpAuthProvider
  • FtpClient() : FtpClient, FtpTransfer, FtpSocket, FtpServer, FtpDataSocket, FtpDataServerSocket
  • FtpConnectMessage() : FtpConnectMessage
  • FtpDataServerSocket() : FtpDataServerSocket, FtpClient
  • FtpDataSocket() : FtpDataSocket, FtpTransfer, FtpSocket, FtpOutTransfer, FtpInTransfer
  • FtpDisconnectMessage() : FtpDisconnectMessage
  • FtpErrorMessage() : FtpErrorMessage
  • FtpInTransfer() : FtpInTransfer, FtpSocket, FtpDataSocket
  • FtpOutTransfer() : FtpOutTransfer, FtpSocket, FtpDataSocket
  • FtpRequest() : FtpRequest
  • FtpRequestMessage() : FtpRequestMessage
  • FtpServer() : FtpServer, FtpTransfer, FtpSocket, FtpOutTransfer, FtpInTransfer, FtpDataSocket, FtpClient
  • FtpServerConfig() : FtpServerConfig
  • FtpServerSocket() : FtpServerSocket, FtpSocket
  • FtpServiceMessage() : FtpServiceMessage
  • FtpSocket() : FtpSocket, FtpServer
  • FtpTransfer() : FtpTransfer
  • FtpTransferMessage() : FtpTransferMessage
  • FullScreenPerItem() : ItemRendererProperties
  • FunctionalityIndicator() : FunctionalityIndicator
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- g -

  • GeneralCompoundItem() : GeneralCompoundItem
  • GenerateHandleId() : DwdDevice
  • GenerateMemoryConfig() : HeapManager
  • GenericAudioDevice() : GenericAudioDevice
  • GenericFeatureData() : GenericFeatureData
  • GenericObject() : GenericObject
  • Get() : DataConnProfileManager, DataConnManager, ObexLayer, ObexClient, TickValue, IrdaObexImpl, WindowHierarchyIterator, Control::ComponentIterator, DeviceManager::Iterator, SoftkeyBar, BtObexImpl, TypeOfAddress, NiSharedPtr< X >, BitField< T >, FunctionalityIndicator, SimSetupIdleModeTextOptions, SimSetupMenuOptions, SimSelectItemOptions, SimGetInkeyOptions, SimGetInputOptions, SimDisplayTextOptions, SimIconQualifier, SimAtom< T >, ShortMessageStatus, ShortMessageFailureCause, ProtocolIdentifier, ParameterIndicator, MessageIdentifier, MdhDeletionCmd, SimImageDescriptor, DataCodingScheme, CommandType, Cbs::SerialNumber, MePhonebookDescription, RegIterator, Registry, ObjectTreeService, LocalDataStore, StreamObexImpl, CompoundItemIterator, RegEncoderDecoder
  • GetAbortCause() : TipdBasedActiveWaitDispatcher
  • GetAbortDesc() : BtBipAbortIndArg
  • GetAborted() : BtObexClientOperationRequest
  • GetAbsBottom() : WinRect
  • GetAbsClientRect() : Control
  • GetAbsClientXPos() : Control
  • GetAbsClientYPos() : Control
  • GetAbsLeft() : WinRect
  • GetAbsoluteDateTime() : CodedTimeStamp
  • GetAbsoluteDay() : DateTime
  • GetAbsoluteDays() : TimeSpan
  • GetAbsoluteHours() : TimeSpan
  • GetAbsoluteMilliseconds() : DateTime
  • GetAbsoluteMinutes() : TimeSpan
  • GetAbsolutePath() : RfsObexFtpServer
  • GetAbsolutePathname() : HttpClient, FtpClient
  • GetAbsoluteSeconds() : TimeSpan, DateTime
  • GetAbsoluteTime() : ValidityPeriod
  • GetAbsoluteWeeks() : TimeSpan
  • GetAbsRect() : Control, WinRect
  • GetAbsRight() : WinRect
  • GetAbsTop() : WinRect
  • GetAbstractAction() : AbstractButton
  • GetAbsX() : DeviceContext
  • GetAbsXPos() : Control
  • GetAbsY() : DeviceContext
  • GetAbsYPos() : Control
  • GetAcceptAbort() : BtObexPutRequest, BtObexGetRequest, BtObexClientOperationRequest
  • GetAcceptAuthorization() : BtRespondAuthorizationRequest
  • GetAcceptPairing() : BtSendPasskeyRequest
  • GetAccessDate() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FatFileImp
  • GetAccessor() : PbAbstractWin
  • GetAccessory() : AccessoryIndMsg, AccessoryIndArg
  • GetAccessoryByCfgType() : AudioAccessoryStore
  • GetAccessoryByName() : AudioAccessoryStore
  • GetAccessoryConfigurationType() : AudioAccessoryConnectedMsg
  • GetAccessoryList() : AudioDeviceManager, AudioAccessoryStore
  • GetAccessPointId() : PdpContext
  • GetAccessPointName() : PdpContext, PdpContext::ActivationStatus
  • GetAccessTime() : File::Attributes
  • GetAccount() : DataConnProfile, PdpContext::Authentication
  • GetAccumulatedCallCcm() : MmCurrentCallMeterMsg
  • GetAccumulatedCallCharge() : MmCurrentChargeDataMsg
  • GetAcm() : SimAcmMaxUpdReqArg, SimAcmUpdReqArg, SimAcmMaxReadIndArg, SimAcmReadIndArg, SimAuxHandler, SimAccessor
  • GetAction() : UibActionAccessor, ActionExecutedMsg, ItemPropertiesChangedMsg, DispatcherAction, PushButton, AbstractButton, MenuItem, CloseAllMsg, AppActionExecutedMsg, ActionMenuAccessor, AbstractActionMenuAccessor
  • GetActionCount() : UibActionAccessor, ActionMenuAccessor
  • GetActionIndex() : UibActionAccessor, ActionMenuAccessor
  • GetActionType() : LanguageResetAction, ApoxiCommandAction, UssdAction, UndefinedSsAction, WaitSsAction, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, ColrAction, ColpAction, CnapAction, ClipAction, ClirAction, PinAction, CallSsAction, EngModeAction, ImeiShowAction, MoCallAction, UnlockAction, PbEntryShowAction, InputAction
  • GetActivationStatus() : PdpContextActivationStatusMsg, PdpContext
  • GetActiveAccessory_HighestPriority() : AudioAccessoryStore
  • GetActiveAppContainer() : System
  • GetActiveApplication() : System, AppContainer
  • GetActiveAuthorizationSet() : WapProfile
  • GetActiveBitmap() : AnimationModel
  • GetActiveCallHdl() : CallHdl
  • GetActiveDevice() : BtActiveDeviceWindow
  • GetActiveDeviceWindow() : BtApplication
  • GetActiveDuration() : Cbs::Filter
  • GetActiveExtLanguage() : SimAuxHandler, DataHandler
  • GetActiveFontIndex() : FontPackConnector, FontManager
  • GetActiveLanguage() : LanguageManager
  • GetActiveLanguageId() : TextPackConnector
  • GetActiveLanguageType() : LanguageManager
  • GetActivePhysicalPortSet() : WapProfile
  • GetActivePhysicalSet() : WapProfile
  • GetActivePortPtr() : ObexServerDispatcher, ObexClientDispatcher
  • GetActivePortSet() : WapProfile
  • GetActiveReference() : AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioRecordingStoppedMsg, AudioGetPlayPositionMsg, GenericFeatureData
  • GetActiveTab() : TabControl
  • GetActiveTheme() : ThemeManager
  • GetActiveThemeIndex() : ThemeManager
  • GetActiveView() : BrowserViewContainer
  • GetActiveWapProfileId() : WapProfileMgr
  • GetActiveWin() : PhonebookApp
  • GetActiveWord() : Zi8NoWordFoundMsg, T9NoWordFoundMsg
  • GetActualName() : AudioAccessoryDetails
  • GetAddAction() : PhonebookApp
  • GetAdditionalNames() : VCard
  • GetAdditionalOrgUnit() : VCard
  • GetAdditionalResult() : SimTkRefreshQueryResArg
  • GetAddr() : IpAddr
  • GetAddress() : ObexAbstractPort, EctActiveMsg, PdpContext, PdpContext::ActivationStatus
  • GetAddressingScheme16BitDestinationPort() : InformationElement
  • GetAddressingScheme16BitOriginatorPort() : InformationElement
  • GetAddressingScheme8BitDestinationPort() : InformationElement
  • GetAddressingScheme8BitOriginatorPort() : InformationElement
  • GetAddressType() : VCard
  • GetAddResult() : PinDisableIndArg, PinEnableIndArg
  • GetAddrPtr() : ObexAddrMsg
  • GetAdnBuffer() : UsimPbRwRecord
  • GetAdnByte() : SimInitIndArg
  • GetAdnProvider() : PbDataHandler
  • GetAdnResult() : DhChannelReceiveIndArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg
  • GetAdnTagSize() : SimPbBaseHandler
  • GetAffectedProvider() : MergeProvider
  • GetAidingData() : AidingData
  • GetAidingRequest() : GltpAidDataRequests
  • GetAlarm() : RealTimeClock
  • GetAlignInfo() : FlowLayout
  • GetAlignment() : IndicatorLocation, Indicator, DateTime
  • GetAllCallsCcm() : CurrentCallMeterMsg, ChargeUnitsIndArg
  • GetAllCallsCharge() : CurrentChargeDataMsg, ChargeIndArg
  • GetAllItems() : DBService
  • GetAllocatedSize() : RamFileObj
  • GetAllocatedSuspendSlot() : DwdPlayer
  • GetAlpha() : Color, XCallInfoResponseParser
  • GetAlphabet() : PhoneNumberInputMapper, NumericInputMapper, MultiTapInputMapper, IpAddrInputMapper, InputMapper, EditorDocument, DateTimeInputMapper, CalculatorInputMapper, DataCodingScheme, EnglishT9InputMapper, ChineseT9InputMapper
  • GetAlphaBitCount() : ColorSegmentation
  • GetAlphaBlendingMode() : DeviceContext, VirtualDisplay
  • GetAlphaId() : AtAlphaTagCnfArg
  • GetAlphaIdentifier() : SsInfoMsg, CallHdl, SsFacilityIndArg, CallIndCallControlInfoArg, AtPbListCnfArg
  • GetAlphaIdLength() : SimSmsParamHandler
  • GetAlphaLength() : PbEntryReadIndArg
  • GetAlphaMask() : Bitmap, BitmapRes
  • GetAlphaSize() : UsimSmsParamReadIndArg
  • GetAlphaTagSize() : SimPbBaseHandler, PbBaseProvider
  • GetAlphaValue() : Bitmap
  • GetAnimType() : ItemRendererProperties
  • GetAnrRecordNo() : UsimPbRefRecord
  • GetAntiFlicker() : CameraSettings
  • GetAntiFlickerMode() : Camera
  • GetAocChargingStatus() : MmAocChargingStatusMsg
  • GetAPart() : IpAddr
  • GetApduDataPtr() : ExtProactiveCmdIndArg, ExtProactiveCmdReqArg, SimGenericReqArg, SimGenericIndArg
  • GetApiDeviceAddress() : BtDeviceAddress
  • GetApiSettings() : BtConnectRequest, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest
  • GetApn() : DhChannelOpenReqArg, SiChannelOpenPromptReqArg
  • GetApnName() : PsdDataConnProfile
  • GetApoxiHandle() : BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtMultiConnectionController::BtConnection
  • GetApoxiKeyCode_Hash() : T9InputMapper
  • GetApoxiKeyCode_Menu() : T9InputMapper
  • GetApoxiKeyCode_Star() : T9InputMapper
  • GetApoxiToneID() : AudioPreset
  • GetAppContainer() : Application
  • GetAppContext() : AbstractScheduler
  • GetAppFeatureID() : FeatureHandle
  • GetAppHdl() : BtAvrcpNmaDisconnect
  • GetApplication() : PbSynchronizer, ContextMsg, ApplicationListEntry, AbstractAppContext, Control, Feature, AtlApplicationPlugin, MainHandlerAccess, HttpServer, HttpApplicationSupplier, ApplicationAction, DataControlModificationMsg
  • GetApplicationCount() : HttpApplicationSupplier
  • GetAppName() : Application
  • GetAppPtr() : ObexDispatcher, AbstractTransport, NotificationTableEntry
  • GetAppStackBase() : AppContext
  • GetAppStackSize() : AppContext
  • GetAppTemplates() : VrHandler
  • GetArchiveProvider() : AbstractSmsApp
  • GetArg() : SmsServiceDocumentMsg, SmsServiceMsg, SharedTimerMsg, BatteryLoadLevelMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, UssdIndicationMsg, SsErrIndicationMsg, SsRejectedMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, TermRspCnfMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetConfirmationMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg, ToStackMsg, FromStackMsg
  • GetArrivedProvider() : AbstractSmsApp
  • GetArrowDown() : KeyboardConfig
  • GetArrowLeft() : KeyboardConfig
  • GetArrowRight() : KeyboardConfig
  • GetArrowUp() : KeyboardConfig
  • GetAsWString() : Property
  • GetAt() : SortedElementList< T >, ElementList< T >, ElementListBase
  • GetAtMode() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • GetAttachedSerialSocket() : SerialSocketData
  • GetAttachedSocket() : SocketData
  • GetAttachmentDesc() : BtBipPutLinkedAttachmentIndArg
  • GetAttachmentList() : BtBipImageProperties
  • GetAttachStatus() : GprsAttachStatusMsg, PdpContextManager
  • GetAttributeById() : BtSddbServiceRecord
  • GetAttributeId() : BtSvrServiceAttribute, BtSddbServiceAttribute
  • GetAttributes() : File, RootFileImp, RamHandler, RamFileObj, RamFileImp, FlashFileImp, FatHandler, FatFileImp
  • GetAttributesRequested() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetAttributeValue() : BtSvrServiceAttribute, BtSddbServiceAttribute
  • GetAudioAlwaysOnAccessory() : BtAudioAccessoryService
  • GetAudioChannelId() : AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, AudioDecoderRenderer, AudioCapturerEncoder
  • GetAudioDeviceToneId() : AudioTone
  • GetAudioDeviceToneRef() : AudioTone
  • GetAudioError() : AudioErrorMsg
  • GetAudioErrorType() : AudioStoppedMsg
  • GetAudioInfo() : MediaInfo
  • GetAudioInfoCount() : MediaInfo
  • GetAudioPathType() : AudioPath
  • GetAudioPlayer() : AudioDeviceManager
  • GetAudioRef() : VoiceMemoRecordWin
  • GetAudioReference() : AudioErrorMsg, AudioActiveReference, AudioItem, MediaPlayer
  • GetAudioSourceType() : AudioPath
  • GetAudioStreamInfo() : EmzMp3Decoder, EmzAacDecoder
  • GetAudioTrackInfo() : MmfPlayer
  • GetAuthentication() : PdpAuthTable
  • GetAuthenticationMethod() : WapProfile
  • GetAuthenticationPassword() : WapProfile
  • GetAuthenticationUsername() : WapProfile
  • GetAuthProvider() : Server
  • GetAuthType() : PdpAuthTable, PsdDataConnProfile
  • GetAutorepeatDelay() : KeyboardConfig
  • GetAutorepeatInterval() : KeyboardConfig
  • GetAvailableByteCount() : StreamingReadInfo
  • GetAvailableCount() : SocketPeer
  • GetAvailableHW() : MiscAudioDevice
  • GetAvailableSuspendSlot() : DwdPlayer
  • GetAvrcpAppReference() : SubUnitReference
  • GetAvrcpOperationService() : SubUnitReference
  • GetAvState() : IrdaTransport, AbstractTransport, BtTransport, UsbTransport
  • GetBack() : EmzUtils::Queue< T >, LinkedListBase
  • GetBackgroundColor() : ItemRendererProperties, RichTextCompoundItem, MultiMediaEditor
  • GetBackgroundImage() : ItemRendererProperties
  • GetBackKey() : KeyboardConfig
  • GetBacklightMode() : DefaultDisplay, Display, DefaultDisplay
  • GetBacklog() : ServerConfig, Server
  • GetBackup() : BtObexSetPathRequest, BtObexServerSetPathIndicationEvent
  • GetBackupFileId() : UriMappingTable
  • GetBalance() : AudioReference
  • GetBandLimits() : RadioAudioDevice
  • GetBaseInformationElement() : CompoundSmsItem
  • GetBaseline() : RomFont, FontManager, FontEntry, Font
  • GetBaseRow() : Provider, AbstractDelegationProvider
  • GetBasicService() : StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg
  • GetBasicServiceList() : CallBarringStatusMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg
  • GetBasicServiceMmiCode() : InputParser, WaitSsAction, ForwardingSsAction, BarringSsAction
  • GetBasicServiceMmiCodeString() : InputParser
  • GetBatteryLoadLevel() : StatusProvider, DataHandler
  • GetBatteryVoltage() : Charger
  • GetBCD() : PhoneNumber
  • GetBCDLength() : PhoneNumber
  • GetBcdPlmn() : SimMccMncIndArg, SimAuxHandler
  • GetBcdPlmnwAct() : SimAuxHandler
  • GetBdnByte() : SimInitIndArg
  • GetBdnProvider() : PbDataHandler
  • GetBdnState() : BdnReqArg, BdnIndArg, SimAccessor
  • GetBdnTagSize() : SimPbBaseHandler
  • GetBearerDesc() : DhChannelOpenCnfArg, DhChannelOpenReqArg
  • GetBearerList() : SimLaunchBrowserReqArg
  • GetBearerType() : SiChannelOpenPromptReqArg
  • GetBehavior() : AbstractListBox
  • GetBehaviour() : GridModel
  • GetBinData() : AmrSound, EmsImage, NativeImage, Image, EncodingThreadlet, Sound, SmafSound, MidiSound, IMelody, SvgImage, WbmpImage, PngImage, JpegImage, GifImage, BmpImage, Media
  • GetBipResult() : BtBipClientService
  • GetBit() : DynamicBitVector, BitVector< N >, BitField< T >, Sms
  • GetBitmap() : Zi8InputConfig, T9InputConfig, Theme, ImageObtainer, ImageBox, AbstractButton, FoggyTheme, DefaultTheme, CustomizableTheme, VirtualDisplay, Display::CustomFrameBuffer, VirtualDisplay
  • GetBitNumber() : SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • GetBitrate() : MediaInfo::MediaTrackInfo
  • GetBits() : Bitmap, BitmapRes
  • GetBitsPerPixel() : DisplayConfig, Image, Image::MetaData
  • GetBitValue() : SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • GetBlinkRate() : EditConfig
  • GetBlitRect() : VirtualDisplay, Display::CustomFrameBuffer, VirtualDisplay
  • GetBlobFileNodePayload() : RegNodeBuffer
  • GetBlobObject() : Cbs
  • GetBlobPayload() : RegNodeBuffer
  • GetBlock() : RamStorageMapper
  • GetBlockCount() : RamFileObj
  • GetBlockDataOffSet() : DrmDcfParser
  • GetBlockInfo() : NvRamStorage
  • GetBlockNo() : HeapVector::VarPage
  • GetBlockSize() : RamStorageMapper
  • GetBlue() : ColorTable, Color
  • GetBlueBitCount() : ColorSegmentation
  • GetBmpIterator() : Animation, AnimationModel
  • GetBody() : HttpResponse, HttpRequest
  • GetBoolean() : DataItem, Property
  • GetBooleanPayload() : RegNodeBuffer
  • GetBoolOption() : InetSocket
  • GetBootControl() : DataControl
  • GetBootState() : DataControlEndBootMsg, DataControlBootMsg
  • GetBopomofoList() : ChineseT9Wrapper
  • GetBorderSize() : TabControlView
  • GetBottom() : Rect, WinRect
  • GetBottomLineGap() : ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor
  • GetBottomSize() : ControlFrameView
  • GetBoundingRect() : PaneObject, Component
  • GetBounds() : DisplaySettings
  • GetBoxType() : UibRegisterMsg
  • GetBPart() : IpAddr
  • GetBpp() : SimImage
  • GetBppSubState() : BtBppSndFilePushReqRequest
  • GetBrightness() : CameraSettings, DefaultDisplay, Display, Camera, DefaultDisplay, RecordSettings
  • GetBrightnessLimits() : Camera
  • GetBroker() : ServiceBroker
  • GetBrush() : DeviceContext
  • GetBrushColor() : DeviceContext
  • GetBrushColorValue() : DeviceContext
  • GetBrushStyle() : DeviceContext
  • GetBtAddress() : BtJsr82Url
  • GetBtapiHdl() : BtAvrcpNmaConnect
  • GetBtApoxiAvrcpSubunitInfo() : BtAvrcpPanelApplication
  • GetBtChannel() : BtJsr82Url
  • GetBtService() : BtJsr82Url
  • GetBuffer() : OnDataRcvdMsg, AtiAudioCapturerEncoder, AbstractEditBox, AbstractEditBoxModel, RomData, RamData, BufferPoolManager, StreamAudioReference, AudioFmRadioRdsRawDataMsg, CustomToneAudioReference, CustomRingerAudioReference, GltpAssistanceData, AudioCapturerEncoder
  • GetBufferByteCount() : Bitmap
  • GetBufferInfo() : AtiAudioPlayerRtStreamingSink, RtStreamingSink
  • GetBufferLength() : DataCoding
  • GetBufferPoolStatus() : BufferPoolManager
  • GetBufferSize() : AudioFmRadioRdsRawDataMsg, CustomRingerAudioReference, DhChannelOpenCnfArg, DhChannelOpenReqArg
  • GetBufferSizes() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • GetBufSize() : WStrData, StrData
  • GetBuildDate() : VersionInfo
  • GetByte() : SsStatus, SsNotification, SsErrorCode
  • GetBytesProcessed() : BtBipProgressMsg
  • GetCacheSize() : MergeProvider
  • GetCalendarAddWin() : CalendarMonthWin
  • GetCalendarListWin() : CalendarMonthWin
  • GetCalendarProvider() : CalendarApp
  • GetCalendarRecord() : CalendarRecordsListBoxModel
  • GetCall() : CallHoldRejectedMsg, CallOnHoldMsg
  • GetCallAction() : PhonebookApp
  • GetCallbackFunctionPointers() : BtController, BtConnectionlessController, BtConnectionBasedController
  • GetCallBarringFeatures() : CallBarringDeactivatedMsg, CallBarringActivatedMsg
  • GetCallBarringInfo() : SsBarringIndArg
  • GetCallBarringStatus() : SsHandler
  • GetCallClearingCause() : NwDiscStartIndMsg
  • GetCallControlResult() : SsInfoMsg, CallHdl, SsFacilityIndArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, CallIndCallControlInfoArg
  • GetCallCount() : CallHdlBase
  • GetCallDataMutex() : MainHandler
  • GetCallDirection() : XCallInfoResponseParser, MmCallInfo
  • GetCallDiscCause() : CallHoldRejArg, CallDiscReqArg, CallRelIndArg, CallDiscIndArg
  • GetCallDispatcher() : CallHandler
  • GetCallDuration() : MptyCallHdl, CallHdlBase, CallHdl, MmCallHdl
  • GetCallDurationInSecs() : MmCallDisconnectingMsg
  • GetCalledPartyNo() : RedialSetupIndArg
  • GetCalledPartyNumber() : CallControlSetupIndArg
  • GetCallErrorCause() : CallIndArg
  • GetCallEstablishedInfoAlpha() : SimTkCallSetupIndArg
  • GetCallEstablishedInfoIcon() : SimTkCallSetupIndArg
  • GetCallEstCause() : MocSetupReqArg
  • GetCallEvent() : BtHsNmaCallEvent, BtHfNmaCallEvent
  • GetCallForwardingStatus() : SsHandler
  • GetCallHandlingData() : MainHandler
  • GetCallHdl() : CtmInfoIndMsg, NwDiscStartIndMsg, CallControlInfoMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, CallNotifyMsg, MptyCallReleaseMsg, CallReleaseMsg, CallAcceptMsg
  • GetCallId() : XCallInfoResponseParser, MmCallInfo
  • GetCallIdx() : CallSsAction
  • GetCallIndex() : MptyCallHdl, CallHdlBase, CallHdl, MmCallReleaseMsg, MmCallAcceptMsg, MmAocChargingStatusMsg, MmCurrentCallMeterMsg, MmCurrentChargeDataMsg, MmCallNotifyMsg, MmCallInfoMsg, MmCallStatusMsg, MmCallInfo, MmCallHdl
  • GetCallInfoAlpha() : SimTkCallSetupIndArg
  • GetCallInfoIcon() : SimTkCallSetupIndArg
  • GetCallLine() : CallHdl, MtcSetupIndArg, MocSetupReqArg, CallIndArg
  • GetCallMode() : XCallInfoResponseParser
  • GetCallProgressInd() : CallProgressIndArg
  • GetCallRefuseDirection() : RejectCallsIndArg
  • GetCallRelatedSs() : CallRelatedSsReqArg, CallDeflectSsReqArg
  • GetCallSsActionId() : CallSsAction
  • GetCallState() : CallIndArg, MmCallInfoMsg, MmCallInfo
  • GetCallType() : CallTypeTable, CsdDataConnProfile, CallHdl, MtcSetupComplArg, MtcSetupIndArg, CallIndArg, XCallInfoResponseParser, MmCallInfoMsg, MmCallHdl
  • GetCallVolume() : AudioUtility
  • GetCallWaitingStatus() : SsHandler
  • GetCameraNightMode() : RecordSettings
  • GetCameraReference() : CameraApp
  • GetCancelableRequest() : BtRequestRunningWindow
  • GetCancelKey() : KeyboardConfig
  • GetCandCharCount() : Zi8Wrapper
  • GetCandidatesBuffer() : Zi8Wrapper
  • GetCanonicalProfileId() : DataConnProfileManager
  • GetCapabilities() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, Stream, MediaManager, MediaFrameworkCaps, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoder
  • GetCapacity() : AbstractSmsApp, ObexBuffer, ByteBuffer, RtStreamingBuffer
  • GetCapacityStatus() : Charger
  • GetCapsStatus() : Zi8PredictiveInputBox, Zi8InputMapper, T9PredictiveInputBox, AbstractPredictiveInputBox
  • GetCaption() : RadioButtonModel, CheckBoxModel, AbstractEditBox, AbstractEditBoxModel
  • GetCaptionGap() : AbstractEditBoxView
  • GetCaptionHeight() : AbstractEditBoxView
  • GetCaptionType() : AbstractEditBoxModel
  • GetCaptionWidth() : AbstractEditBoxView
  • GetCaptureTransformation() : Camera
  • GetCardType() : UsimCardTypeReadIndArg
  • GetCaret() : MultiTapInputMapper, InputMapper, AbstractEditor
  • GetCaretIndex() : AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor
  • GetCategory() : CalendarRecord, AbstractDevice
  • GetCause() : SsWaitDispatcher, StackSsRejectedMsg, SsRequestRejectedMsg, SsFacilityRejectedMsg, MocSetupRejectIndMsg, CallHoldRejectedMsg, SimCallSetupRejectedMsg, SimTkSendDtmfEndIndArg, DetachCnfArg, AttachRejArg, NRegStateIndArg, MocSetupRejIndArg, CallSetupBySimtTkReqArg, StartDtmfRejArg
  • GetCbFunction() : NotificationTableEntry
  • GetCbmi() : SimAuxHandler, SimAccessor
  • GetCbmiData() : SimCbmiUpdReqArg, SimCbmiReadIndArg
  • GetCbmiFileLength() : SimAccessor
  • GetCbmir() : SimAccessor
  • GetCbmiRange() : SimCbmirUpdReqArg, SimCbmirReadIndArg, SimAuxHandler
  • GetCbmirFileLength() : SimAccessor
  • GetCbs() : CbsNewDataIndArg
  • GetCbsFilterList() : CbsHandler, CbsDispatcher
  • GetCbsWchars() : DataCoding
  • GetCcbsAction() : SsCcbsResultIndArg
  • GetCcbsEntry() : SsCcbsReCallIndArg
  • GetCcbsStatus() : CcbsStatusMsg, SsCcbsResultIndArg, SsCcbsStatusIndArg
  • GetCcp() : SimAuxHandler
  • GetCcpData() : SimCcpUpdReqArg, SimCcpReadIndArg
  • GetCcPerformed() : XCallInfoResponseParser
  • GetCellCount() : CalendarMonthSelector, CalendarGrid, AbstractItemGrid, AbstractGrid, Menu
  • GetCellHeight() : CalendarMonthSelector, CalendarGrid, AbstractItemGrid, AbstractGrid, Menu, GridView
  • GetCellIcon() : UibListBoxModel, DataConnLbModel, CalendarRecordsListBoxModel, PbProvColListBoxModel, PbProvListBoxModel
  • GetCellId() : CellInfoIndArg
  • GetCellRect() : AbstractGrid, GridView
  • GetCellSize() : Layouter, GridLayout
  • GetCellText() : UibListBoxModel, FileNameListBoxModel, ImageViewListBoxModel, FileNameListBoxModel, EmsInsertPromptListBoxModel, DataConnLbModel, CalendarRecordsListBoxModel, PbProvListBoxModel
  • GetCellWidth() : CalendarGrid, AbstractGrid, Menu, GridView
  • GetCellXPos() : GridView
  • GetCellYPos() : GridView
  • GetCenterBounds() : Desktop
  • GetCenterXpos() : Zi8AlphabetBox
  • GetCertBuffer() : SimMexeCertificate
  • GetCertLength() : MexeDescriptor
  • GetCertOffset() : MexeDescriptor
  • GetCertSize() : SimMexeCertificate
  • GetCertType() : SimMexeCertificate, MexeDescriptor
  • GetCfuDataSource() : CfuServiceArray
  • GetCfuService() : CfuServiceArray
  • GetCfuServiceArray() : CfuStatusMsg, CfuDataIndArg, StatusProvider, DataHandler
  • GetCfuServiceCode() : CfuService
  • GetChangedState() : DhChannelChangeStatusEventArg, DhChannelDataAvailEventArg, SimMruPropertyUpdCnfArg
  • GetChannel() : ObexMsg, ObexAbstractPort, AudioReference
  • GetChannelData() : DhChannelReceiveIndArg, DhChannelSendReqArg
  • GetChannelDataLength() : DhChannelDataAvailEventArg, DhChannelReceiveReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg
  • GetChannelId() : TimeFeatureObject
  • GetChannelMode() : XCallInfoResponseParser
  • GetChannelMuteState() : RadioAudioDevice
  • GetChannelVolume() : CustomSmafPhraseAudioReference, AudioReference
  • GetChar() : CharInputMapItem, CharItem, AbstractEditBox, AbstractEditBoxModel
  • GetCharacter() : InputCharMsg
  • GetCharactersPerSegment() : SmsComposeWin
  • GetChargerMsgType() : ChargerInfoMsg
  • GetCharItem() : AbstractMultiLineEditor, MultiMediaEditor
  • GetCharset() : BtBipAttachmentDesc, BtBipAttachment, BtBipAttachmentFormat
  • GetCharType() : BidiManager
  • GetCheckBoxListView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetCheckBoxView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetChild() : MenuAccessor, AbstractActionMenuAccessor
  • GetChildFileId() : UriMappingTable
  • GetChildKeyColumnId() : MergeProvider
  • GetChildName() : Uri
  • GetChildProvider() : AbstractDelegationProvider
  • GetChildRow() : SmsFolderProvider, SmsBasicProvider, PbSimProvider, PbNameNumberProvider, PbNumberFilterProvider, PbDetailProvider, SortProvider, Provider, FindProvider, FilterProvider, DistinctProvider, AbstractDelegationProvider, MergeProvider, AppendProvider
  • GetChineseCandidate() : Zi8Wrapper
  • GetChineseKeyBufLen() : ChineseT9Wrapper
  • GetChineseMode_IsAmbiguousPhonetic() : ChineseT9Wrapper
  • GetChineseMode_IsAutoSpell() : ChineseT9Wrapper
  • GetChineseMode_IsComponents() : ChineseT9Wrapper
  • GetChineseMode_IsCUdbSearchOnly() : ChineseT9Wrapper
  • GetChineseMode_IsExplicitPhonetic() : ChineseT9Wrapper
  • GetChineseMode_IsExplicitPhoneticContinualSelection() : ChineseT9Wrapper
  • GetChineseMode_IsFuzzyPinyin() : ChineseT9Wrapper
  • GetChineseMode_IsStroke() : ChineseT9Wrapper
  • GetChineseSelectPage() : ChineseT9Wrapper
  • GetChineseSelectPageNum() : ChineseT9Wrapper
  • GetChipVersion() : BtLocalSettings
  • GetChunkSize() : File
  • GetChv() : PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvVerifyReqArg
  • GetChvAction() : ChvChangedMsg, ChvRefreshIndArg
  • GetChvAttempts() : ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg
  • GetChvData() : SimChvHandler
  • GetChvno() : ChvChangedMsg, PinDisableReqArg, PinEnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg
  • GetChvNo() : PinAction, SimFileInfoIndArg
  • GetCidx() : DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg
  • GetCipherSuiteName() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • GetClassType() : StreamAudioReference, PresetAudioReference, CustomToneAudioReference, CustomSmafPhraseAudioReference, CustomRingerAudioReference, AudioReference, AudioActiveReference, MapiAudioReference
  • GetClearAllKey() : KeyboardConfig
  • GetClearingCause() : XCallInfoResponseParser
  • GetClearingState() : XCallInfoResponseParser
  • GetClient() : MmiSimClient, ClientDeregistrationArg, ClientRegistrationArg, Server, HttpServer, FtpServer
  • GetClientAddrTypeId() : ObexAbstractTransport
  • GetClientCount() : Server
  • GetClientHeight() : Control
  • GetClientId() : LcsAppTransferLocMsg, HttpDisconnectMessage, HttpRequestMessage, FtpDisconnectMessage, FtpTransferMessage, FtpRequest
  • GetClientInfo() : LocationNotifInvokeMsg, LocationNotifInvokeArg
  • GetClientRect() : Window, GridLayout, Control
  • GetClientSecurity() : BtObexServiceTable::ServiceInfo
  • GetClientSize() : Control
  • GetClientWidth() : Control
  • GetClientXPos() : Control
  • GetClientYPos() : Control
  • GetClipInfo() : MediaInfo
  • GetClippedWidth() : TabButtonView
  • GetClipRect() : DeviceContext
  • GetClipStatus() : SsHandler
  • GetCliRestrictionOption() : ClirStatusMsg
  • GetClirMode() : CallHdl, MocSetupReqArg, MmCallHdl
  • GetClirPhoneNumber() : ClirAction
  • GetClirStatus() : SsHandler
  • GetCliValidity() : XCallInfoResponseParser
  • GetCloseCause() : SiChannelCloseInfoIndArg
  • GetCloseKey() : KeyboardConfig
  • GetClusterSize() : StorageDevice
  • GetClutBuffer() : SimImage
  • GetClutBufferLength() : SimImage
  • GetClutLocation() : SimImage
  • GetCmd() : AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtGenericCmdReqArg, HttpErrorMessage, HttpServiceMessage, FtpErrorMessage, FtpServiceMessage, FtpRequest
  • GetCmdQualifier() : DhChannelOpenReqArg
  • GetCmi() : SimAuxHandler, SimAccessor
  • GetCmiCount() : SimAccessor
  • GetCmiRecord() : SimCmiReadIndArg
  • GetCmiRecordNo() : SimPbEntry
  • GetCnapName() : CnapInfoReceivedMsg
  • GetCnfArg() : EngineeringModeControlResponseMsg
  • GetCode() : PackedTimePeriod, SsErrorCode, HttpErrorMessage, FtpErrorMessage
  • GetCodeAsByte() : TaggedProblemCode
  • GetCodedAlphaFieldLen() : AlphaCoding
  • GetCoding() : SimImage
  • GetColId() : ProviderListBoxModel
  • GetColor() : Pen, Brush, AbstractTextObject, VirtualDisplay
  • GetColorCount() : ColorTable
  • GetColorSegmentation() : DisplayConfig
  • GetColorSpace() : Image::MetaData
  • GetColorTable() : DisplayConfig, ResourceManager
  • GetColorValue() : System, Pen, Brush, VirtualDisplay
  • GetColpStatus() : SsHandler
  • GetColrStatus() : SsHandler
  • GetColTitleHeight() : GridView
  • GetColumn() : Caret, Cell
  • GetColumnCount() : CalendarMonthSelector, CalendarGrid, ItemTree, ItemRendererProperties, ItemGrid, GridLayout, AbstractGrid, MenuAccessor, Menu, AbstractMenuAccessor
  • GetColumnId() : PbSimProvider, PbProvColListBoxModel, PbProvListBoxModel, PbDetailListBoxModel, Provider
  • GetColumnInfo() : PbSimProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider
  • GetColumnInfoPerId() : PbSimProvider, Provider
  • GetCommand() : AragonMsg, VrHandler, VrResultMsg
  • GetCommandData() : SmsCommand
  • GetCommandDetails() : SimLaunchBrowserReqArg
  • GetCommandId() : ApoxiCommandAction
  • GetCommandString() : ApoxiCommandAction
  • GetCommandTemplates() : VrHandler
  • GetCommandType() : SmsContext, SmsCommand
  • GetCompanyId() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • GetCompatibilitySettings() : AudioAccessoryDetails
  • GetComplete() : MdhSmsUpdStatusReqArg
  • GetCompleteVisibleRowCount() : AbstractGrid
  • GetComponent() : DeleteComponentMsg, RefreshComponentMsg, InvalidateMsg, Control
  • GetComponentsSize() : Panel
  • GetComposeWin() : SmsEditor
  • GetCompoundItem() : EditorItemNode, TimeEditorDocument, TextEditorDocument, EditorDocument, DateEditorDocument, ParagraphCompoundItem, MultiMediaEditorDocument, CompoundItemReferrer
  • GetCompoundItemCount() : EditorDocument, ParagraphCompoundItem, MultiMediaEditorDocument
  • GetCompoundItemIndex() : ParagraphCompoundItem, MultiMediaEditorDocument
  • GetConcatenatedReferenceNoType() : SmsContext
  • GetConcatenatedSm16BitMaximumNumber() : InformationElement
  • GetConcatenatedSm16BitReferenceNumber() : InformationElement
  • GetConcatenatedSm16BitSequenceNumber() : InformationElement
  • GetConcatenatedSm8BitMaximumNumber() : InformationElement
  • GetConcatenatedSm8BitReferenceNumber() : InformationElement
  • GetConcatenatedSm8BitSequenceNumber() : InformationElement
  • GetConcatenetedStatus() : TpduHeaderInformation
  • GetConcatenetedTpduNum() : TpduHeaderInformation
  • GetConcMaxNo() : PortHeaderInformation, TpduHeaderInformation
  • GetConcRefNo() : PortHeaderInformation, TpduHeaderInformation
  • GetConcSeqNo() : PortHeaderInformation, TpduHeaderInformation
  • GetConcSmsPduMaxNo() : SimPduHandler, DataHandler
  • GetConditionTimer() : ForwardingSsAction
  • GetConfigStream() : ScicosMpeg4VideoEncoder, EmzMpeg4Encoder, AtiMpeg4Encoder, EmzMpeg4Encoder, VideoEncoder
  • GetConfigurationType() : AudioAccessoryDetails
  • GetConfigValues() : GltpProviderImpl
  • GetConfirmKey() : KeyboardConfig
  • GetConn() : RtStreamingEndPoint
  • GetConnApplication() : DataConnWin
  • GetConnectableMode() : BtLocalSettings
  • GetConnected() : AudioAccessoryDetails
  • GetConnectedAccessories() : AudioAccessoryDetails
  • GetConnectedDevice() : BtSingleConnectionController
  • GetConnectedNo() : MtcSetupIndArg, MocSetupCnfArg
  • GetConnectedToPhoneNumber() : CallHdl, MmCallHdl
  • GetConnectionElement() : DataCallContext
  • GetConnectionId() : ObexServer, ObexClient
  • GetConnectionInfo() : UsbTransport
  • GetConnectionOnlyDuringCall() : BtHsService
  • GetConnectionParameters() : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • GetConnIdHttp() : HttpHandler
  • GetConnIdWap() : WapHandler
  • GetConnState() : IrdaTransport
  • GetConnStatusHttp() : HttpWapMgr, HttpHandler
  • GetConnType() : FtpDisconnectMessage
  • GetConstraint() : DrmPermission
  • GetConstraintDefaultValue() : DrmPermission
  • GetConstraintsCount() : DrmPermission
  • GetConsumeLastKey() : KeySequenceCandidate, KeySequence
  • GetContainerId() : FeatureItemContainer
  • GetContent() : TRadioButtonItem< Content >
  • GetContentId() : DrmDcfParser
  • GetContentLeft() : AbstractMultiLineEditor
  • GetContentType() : DrmDcfParser
  • GetContext() : SocketData, ObexDispatcher, ContextMsg, AppContainer, ApoxiThread, PdpContextControl, SerialSocketData
  • GetContextControl() : PdpContextManager
  • GetContextDataItem() : UibApp, SoundBrowserApp, ImageBrowserApp, AtlApplication
  • GetContextDesc() : ContextManager
  • GetContextId() : PropertyDescriptor, AtlItemGridWindow, FeatureItemContainer, FeatureItem, ContextManager, ContextDescription, AtlWindow, AtlApplication, ExternalPdpContextInfoMsg, PdpContextActivationStatusMsg
  • GetContextItem() : ContextFeatureItem, ContextFeatureTriggerMsg, UpdateContextItemMsg
  • GetContextManagerControl() : PdpContextManager
  • GetContextMenu() : ContextMenuClosedMsg
  • GetContextState() : ExternalPdpContextInfoMsg
  • GetContextType() : ContextFeatureItem, ContextFeature
  • GetContinue() : AudioReference, MediaPlayer
  • GetContrast() : CameraSettings, DefaultDisplay, Display, Camera, DefaultDisplay, RecordSettings
  • GetContrastLimits() : Camera
  • GetControl() : ControlMsg, DeviceContext
  • GetControlFrameView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetControlInfo() : UssdNotifyMsg, UssdRequestMsg
  • GetControlInfoString() : UssdAnswerMsg
  • GetControlType() : SocketControlMsg, BtAvrcpRawFrameParams
  • GetConvertedPositions() : BidiManager
  • GetConvertedText() : BidiManager
  • GetCorner() : MenuProperties
  • GetCount() : ObexTransportSet, IndexTable< T >, FixedPtrArray< T >, DrmAsset, SimAcmReadIndArg, PbCountIndArg, MePhonebookDescription, CompoundItemReferrer, DrmRightsObjectContainer, DrmConstraint
  • GetCountConstraint() : DrmRightsObject, DrmPermission
  • GetCountry() : VCard
  • GetCountryListCc() : StackWrapper
  • GetCountryListLength() : StackWrapper
  • GetCountryListMcc() : StackWrapper
  • GetCountryListName() : StackWrapper
  • GetCPart() : IpAddr
  • GetCphsCfuf() : SimAccessor
  • GetCphsCfufArray() : CphsCfufUpdReqArg, CphsCfufReadIndArg
  • GetCphsCsp() : SimAccessor
  • GetCphsCspArray() : CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspReadIndArg
  • GetCphsIndexLevelIndicator() : SimPbEntry
  • GetCphsInfoNoTagSize() : SimPbBaseHandler
  • GetCphsIst() : SimAccessor
  • GetCphsIstArray() : CphsIstReadIndArg
  • GetCphsMBoxTagSize() : SimPbBaseHandler
  • GetCphsOnm() : SimAccessor
  • GetCphsOnmName() : CphsOnmReadIndArg
  • GetCphsOns() : SimAccessor
  • GetCphsOnsName() : CphsOnsReadIndArg
  • GetCphsPhase() : SimCphsHandler
  • GetCphsStatus() : SimPbEntry
  • GetCphsVmwf() : SimAccessor
  • GetCphsVmwfArray() : CphsVmwfUpdReqArg, CphsVmwfReadIndArg
  • GetCreate() : BtObexServerSetPathIndicationEvent
  • GetCreated() : BtBipAttachmentDesc, BtBipImage
  • GetCreateDate() : BtBipAttachment
  • GetCreatedFrom() : BtBipImageHdlDesc
  • GetCreateDirectory() : BtObexSetPathRequest
  • GetCreatedTo() : BtBipImageHdlDesc
  • GetCreateEmptyObject() : BtObexPutRequest, BtObexDataBufferIndicationEvent
  • GetCreateTrust() : BtRespondAuthorizationRequest, BtDevicePairRequest
  • GetCreationDate() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FlashFileImp, FatFileImp
  • GetCreationTime() : File::Attributes
  • GetCreationTimestamp() : RamFile, FatFile
  • GetCrss() : MptyCnfArg
  • GetCrssCode() : MtcSetupComplArg, MocSetupCnfArg
  • GetCrssState() : CallHoldRejArg, CallHoldCnfArg, XCallInfoResponseParser
  • GetCsdDialError() : DataConnInfoMsg
  • GetCsdError() : DataConnInfoMsg
  • GetCString() : WString, String
  • GetCtmStatus() : XCallInfoResponseParser
  • GetCtrlInfo() : SsUssdReqArg, SsSendReqArg
  • GetCtrlInfoString() : UssdAnswerIndArg, SsUssdIndArg, SsUnstructIndArg
  • GetCts() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetCug() : MocSetupReqArg
  • GetCugIndex() : CugCallMsg
  • GetCurApplicationID() : _ApplicationTracer, _NullApplicationTracer
  • GetCurrencySymbol() : Locale
  • GetCurrentCallCcm() : MmCurrentCallMeterMsg
  • GetCurrentCallCharge() : MmCurrentChargeDataMsg
  • GetCurrentCallMeter() : CallHdl, MmCallHdl, MmCallHandler
  • GetCurrentCallMode() : XCallInfoResponseParser
  • GetCurrentChargeData() : CallHdl, MmCallHdl, MmCallHandler
  • GetCurrentContext() : ExecutionContext
  • GetCurrentDate() : CalendarMonthWin
  • GetCurrentDir() : FfsHandler, RamHandler, FatHandler
  • GetCurrentDisplayType() : AtlItemGridWindow
  • GetCurrentFocusPriority() : System
  • GetCurrentFolder() : ObexFtpServer, ObexFtpDataServer
  • GetCurrentFrame() : MP3AudioPlayer
  • GetCurrentImage() : CamWin32
  • GetCurrentImageBufferSize() : CamWin32
  • GetCurrentIndication() : SmsIndicationState
  • GetCurrentLocalTimeZone() : DateTime
  • GetCurrentNumberOfElements() : EmzUtils::Queue< T >
  • GetCurrentSelectedDay() : CalendarGrid
  • GetCurrentSelectedPb() : UsimPbLocReport
  • GetCurrentTest() : FfsTestThreadlet, FfsTestThread
  • GetCurrentTestGroup() : SocketTestApp
  • GetCurrentTestID() : SocketTestApp
  • GetCurrentTestNr() : SocketTestApp
  • GetCurrentVideoClockTime() : EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Decoder, VideoDecoder
  • GetCursorPos() : AbstractEditBoxModel
  • GetCursorRect() : AbstractEditBoxView
  • GetCustomKey() : KeyboardConfig
  • GetData() : UibSettingsRecord, ToDoRecord, LcsSettingsUtils, LcsAppUtils, FmRadioStationsRecord, FmRadioSettingsRecord, SmsSettingsRecord, CalendarRecord, CalendarDialogWin, BtHfRecord, PbNumberRecord, PbRecord, PbNextFreeIdRecord, AragonMsg, Glyph, FilePackConnector, BtSddbDeOneByteDescriptionType, BtServiceVerifyResultMessage, WString, String, ByteBuffer, ProviderProxyItem, UssdDataMsg, PdpContext::Address, UserData, UserDataHeader, Tpdu, Sms, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, PbEntryUpdReqArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, InformationElement, Cbs, PathProfile, T9Pack, Record
  • GetDataAvailability() : SimAccessor, DataHandler
  • GetDataBaudRate() : CsdDataConnProfile
  • GetDataBits() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetDataCallContext() : CsdDataConnProfile
  • GetDataCallType() : CallIndArg
  • GetDataCodingScheme() : UssdDataMsg, UssdNotifyMsg, UssdRequestMsg, CnapInfoReceivedMsg, SmsContext, SmsNewMessageIndArg, SmsStatusReport, SmsSubmit, SmsDeliver, SimTextString, MdhSmsNewMessageIndArg, Cbs
  • GetDataCompression() : PdpContext
  • GetDataConn() : SocketData, DataConnManager
  • GetDataConnByIdx() : DataConnManager
  • GetDataConnByIdxAndType() : DataConnManager
  • GetDataConnCount() : DataConnManager
  • GetDataConnectionType() : FtpClient
  • GetDataConnId() : WapProfile
  • GetDataConnProfileId() : SocketData, InetSocket, ServerConfig, HttpServiceMessage, FtpServiceMessage
  • GetDataConnProfileType() : DataConnApp::DataConnDescription
  • GetDataControlType() : DataControlModificationMsg
  • GetDataCounters() : PsdDataConn, PdpContextManager
  • GetDataElementAtIndex() : BtSvrDataElement
  • GetDataElementDescriptor() : BtSddbDeUuid128, BtSddbDeSint128, BtSddbDeSint64, BtSddbDeUint128, BtSddbDeUint64, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, BtSddbDeNil, BtSddbDeOneByteDescriptionType
  • GetDataElementSizeDescriptor() : BtSddbDeContainer, BtSddbDeVariableLengthType
  • GetDataElementTypeDescriptor() : BtSddbDeAlternative, BtSddbDeSequence, BtSddbDeContainer, BtSddbDeUrl, BtSddbDeString, BtSddbDeVariableLengthType
  • GetDataFractionSize() : ObexObject
  • GetDataHandler() : DataControl
  • GetDataItem() : UibSettingsProvider, UibInboxProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsTemplateProvider, SmsSettingsProvider, SmsFolderProvider, SmsBasicProvider, SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider, CalendarProvider, BtHfProvider, BtDeviceListProvider, PbSimProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, PbNameNumberProvider, PbNameFilterProvider, PbNumberFilterProvider, PbDetailProvider, GroupProvider, SortProvider, Provider, FindProvider, FilterProvider, DistinctProvider, AbstractDelegationProvider, Property, MergeProvider, JoinProvider, AppendProvider, LanguageProvider, StatusProvider, SstProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, SimTkMainMenuProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PlmnProvider, PbBaseProvider, MbiProvider, LockProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CountryProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • GetDataLength() : PbEntryReadIndArg
  • GetDataPack() : BasicPackConnector
  • GetDataPtr() : BlobPtr, RtStreamingBuffer, GenericFeatureData
  • GetDataRate() : DataRateTable, CsdDataConnProfile
  • GetDataRateType() : DataRateTable
  • GetDataRead() : StreamingReadInfo
  • GetDataReceivedEventArgs() : NetAdapter::DataReceivedEventArgs, NetAdapter::EventArgs
  • GetDataRecord() : ToDoProvider, PbRecordProvider, PbRecordHandler, PbNvRamNumberHandler, PbNvRamNameHandler, PbNumberProvider, PbNumberHandler, PbNameProvider, PbNameHandler, PbFfsNumberHandler, PbFfsNameHandler
  • GetDataRecordHandler() : PbRecordHandler, PbNvRamNumberHandler, PbNvRamNameHandler, PbNumberHandler, PbNameHandler, PbFfsNumberHandler, PbFfsNameHandler
  • GetDataSentEventArgs() : NetAdapter::DataSentEventArgs, NetAdapter::EventArgs
  • GetDataSink() : EncodingThreadlet
  • GetDataSize() : BtServiceVerifyResultMessage
  • GetDataStoreUri() : SyncMLManager
  • GetDataTerminal() : MmCallInfo
  • GetDataToWrite() : StreamingWriteInfo
  • GetDataType() : DataItem
  • GetDate() : ToDoDateDialogWin, CalendarRecord, DateEditorDocument, DateEditor, DateCompoundItem, DateEditBox, DateTime, DataItem, Property
  • GetDateConstraint() : DrmRightsObject, DrmPermission
  • GetDateFormat() : Locale, DateEditorDocument, DateEditor, DateCompoundItem
  • GetDatetime() : TimeZoneMsg
  • GetDateTime() : DataItem, Property, SmsNewSocketDataMsg, MnInformationIndArg, DrmConstraint, TpduHeaderInformation
  • GetDay() : Date
  • GetDaylightSavingTime() : MnInformationIndArg
  • GetDBServiceFromURI() : SyncMLManager
  • GetDbUri() : DBItemChangedMsg
  • GetDcd() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetDcfHeader() : DrmDcfParser
  • GetDcs() : SmsNewSocketDataMsg, UssdAnswerIndArg, SsUssdIndArg, SsUnstructIndArg, GetInkeyRspArg, GetInputRspArg, TpduHeaderInformation
  • GetDecimalSeparator() : Locale
  • GetDecimalString() : Fraction
  • GetDecoderCodec() : MediaFrameworkCaps
  • GetDefaultAmplitude() : CustomToneAudioReference
  • GetDefaultChunkSize() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetDefaultClirMode() : CallHandler
  • GetDefaultCugInfo() : CallHandler
  • GetDefaultDataItem() : PbMergeProvider, PhoneNumberMergeProvider, MergeProvider
  • GetDefaultDescriptor() : Property
  • GetDefaultHeight() : Window, View, LineEditor, ItemBox, ImageBox, Component, Animation, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, T9PinyinBox, StrokeBox, SelectionBox, SvgPlayer
  • GetDefaultIcon() : IconSet
  • GetDefaultItemHeight() : AbstractListBoxView
  • GetDefaultItemId() : SelectItemReqArg
  • GetDefaultItemRendererProperties() : GuiEngineConfig
  • GetDefaultPriority() : EmlppStatusMsg, EmlppRegisteredMsg
  • GetDefaultProfile() : SmsSettingsRecord, AbstractSmsApp
  • GetDefaultServerId() : ObexServerOppImpl, ObexServer
  • GetDefaultTextString() : GetInputReqArg
  • GetDefaultWidth() : Window, View, ItemBox, ImageBox, Component, Animation, SvgPlayer
  • GetDeflectNumber() : CallDeflectSsReqArg
  • GetDefProfileId() : DataConnProfileManager
  • GetDelAllAction() : PhonebookApp
  • GetDelay() : Alert, StreamAudioReference, PdpContext::QualityOfService
  • GetDelBufCount() : RegDeletionBufferEntry
  • GetDeleteAction() : PhonebookApp
  • GetDeleteKey() : KeyboardConfig
  • GetDeleteMode() : EditBox
  • GetDeleteObect() : BtObexDataBufferIndicationEvent
  • GetDeleteObject() : BtObexPutRequest
  • GetDeletionBuffer() : RegMemoryPool
  • GetDeletionCmd() : MdhSmsDeletionReqArg, MdhSmsDeletionIndArg
  • GetDelPhonenoAction() : AdvPbApp
  • GetDenominator() : Fraction
  • GetDesc() : AtPbInfoIndArg
  • GetDescription() : CalendarRecord, CallNotifyMsg, NotifyIndArg, HttpApplication
  • GetDescriptor() : PropertyItem, PropertyEditor, IndicatorItem
  • GetDeselectedIcon() : RadioButtonAction, CheckBoxAction, AbstractToggleAction
  • GetDestinationAddress() : AbstractSmsComposeWin, SmsContext, SmsCommand, SmsSubmit
  • GetDestinationApplicationPortAddress() : SmsContext
  • GetDestinationNumber() : SmsControlIndArg
  • GetDestinationTpduStatus() : SmsUnsentProvider, SmsUnreadProvider, SmsSentProvider, SmsReadProvider, SmsProvider
  • GetDestIpAddr() : DhChannelOpenReqArg
  • GetDetailProvider() : ProvDetailListBoxWin, PbDetails, PbAdvDetails
  • GetDetailRow() : PbDetailProvider
  • GetDetailWin() : PhonebookWin, PbDetailAction, BasicPbWin, AdvPbWin, PbAdvDetailAction
  • GetDevice() : BtDeviceDetailWindow, DeviceManager, AudioContext, BtObexServerConnectIndicationEvent, BtHsNmaConnect, BtHfNmaConnect, BtFaxConnectMessage, BtDunConnectMessage, BtUncancelablePointToPointRequest, BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice, BtMultiConnectionController::BtConnection, BtDeviceList::BtDeviceListNode, AudioDeviceManager, AudioActiveReference, RootFileImp
  • GetDeviceAbstraction() : ObexAbstractTransport
  • GetDeviceAddress() : BtDeviceListWindow, BtDeviceListItem, BtDeviceListProvider, BtDeviceAddressGenericObject, BtAvrcpControllerDeviceListItem, BtObexClientAddr, BtServiceVerifyResultMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtGapAndSdapRemoteRequestMessage, BtDevice, L2CapSocketAddr, RfcommSocketAddr
  • GetDeviceAdr() : BtBipConnectIndArg
  • GetDeviceAndServiceClass() : BtRemoteDeviceMessage, BtDeviceSearchRequest, BtDeviceFilter, BtDevice
  • GetDeviceAtIndex() : BtDeviceListProvider
  • GetDeviceClass() : BtDeviceListWindow
  • GetDeviceContext() : Control
  • GetDeviceCount() : BtAvrcpControllerApplicationWindow
  • GetDeviceErrorCode() : StreamingInfo
  • GetDeviceFilter() : BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice
  • GetDeviceIcon() : BtDeviceListWindow
  • GetDeviceId() : AudioDeviceStatusMsg
  • GetDeviceID() : MmfPlayer, AudioVibratorDevice, AudioDeviceBase, MapiAudioPlayer
  • GetDeviceInfo() : SyncMLManager
  • GetDeviceList() : BtDeviceSearchRequest, BtCancelableMulticastRequest
  • GetDeviceListNode() : BtDeviceList::BtDeviceListBidirectionalIterator
  • GetDeviceListProvider() : BtDeviceListWindow
  • GetDeviceListWindow() : BtApplication
  • GetDeviceMajorClass() : BtDeviceListProvider
  • GetDeviceManual() : AbstractSmsApp
  • GetDeviceMinorClass() : BtDeviceListProvider
  • GetDeviceName() : SmsTelematicDeviceNameTable, BtDeviceListWindow, BtDeviceListProvider, BtServiceVerifyResultMessage, BtRemoteDeviceNameMessage, BtGapAndSdapRemoteRequestMessage, BtDevice
  • GetDeviceRelation() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetDeviceState() : BtDeviceFilter
  • GetDeviceStatus() : AudioDeviceStatusMsg
  • GetDeviceVolume() : AudioDeviceBase
  • GetDfId() : SimGenericReqArg, SimGenericIndArg
  • GetDfLength() : SimGenericIndArg
  • GetDfParams() : SimGenericIndArg
  • GetDiagnosticCause() : DiagnosticIndMsg, DiagnosticIndArg
  • GetDiff() : AbstractGrid::SmoothScrollInfo, AbstractListBox::SmoothScrollInfo
  • GetDirection() : FtpTransferMessage
  • GetDirectoryIterator() : RootFileSystem
  • GetDirItemInformation() : FtpClient
  • GetDirtyFlag() : DirtyFileHandler
  • GetDischargeTime() : SmsStatusReport
  • GetDisconnectingMode() : CallDisconnectedMsg, CallDisconnectingMsg
  • GetDiscoverableMode() : BtLocalSettings
  • GetDispatcher() : DispatcherAction, InvalidateMsg, Item, ContextManager, AtlWindow
  • GetDispatcherActionList() : AppRoutingTableEntry
  • GetDisplay() : System, DeviceContext, DeviceManager
  • GetDisplayCount() : DisplayConfig
  • GetDisplayedName() : MetaData
  • GetDisplayForegrWin() : WindowManager
  • GetDisplayIndex() : Control, Camera
  • GetDisplaySimPos() : PbAbstractWin
  • GetDisplayType() : ItemRendererProperties
  • GetDistinctNameProvider() : PbDataHandler, PbAdvDataHandler
  • GetDocument() : SmsViewerWin, AbstractSmsViewerWin, EmsViewerWin, AbstractEditor
  • GetDocumentDescription() : SvgPlayer
  • GetDocumentObtainer() : ToDoComposeWin, SendSmsMsg, SmsServiceDocumentMsg, SmsComposeWin, AbstractSmsComposeWin, EmsComposeWin
  • GetDocumentTitle() : SvgPlayer
  • GetDomain() : WapProfile
  • GetDownlinkPath() : AudioAccessoryDetails
  • GetDPart() : IpAddr
  • GetDpofOptions() : BtBipImagingCapabilities
  • GetDriveLetter() : RamFileSystem
  • GetDrmAsset() : DataSource, DataSink, BinData
  • GetDrmAttrib() : FlsFile, FfsHandler
  • GetDrmLocalId() : DrmAsset
  • GetDrmMimeType() : DrmRightsObject, DrmMessage
  • GetDrmRights() : DrmRightsObjectStore
  • GetDrmVersion() : DrmRelParser
  • GetDrvId() : AudioMsg
  • GetDspFormat() : StreamAudioReference
  • GetDsr() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetDstInd() : TimeZone
  • GetDtmfDispatcher() : CallHandler
  • GetDtmfSeparator() : EditConfig
  • GetDtr() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetDummy() : SimTkCallSetupIndArg
  • GetDuration() : KeyUpMsg, KeyUpInputMapItem, KeyMsgGenerator::Key, AudioTone, MediaInfo::MediaTrackInfo, Media
  • GetDuration1() : DhChannelOpenReqArg
  • GetDuration2() : DhChannelOpenReqArg
  • GetDynamic2Flag() : SimAccessor
  • GetDynamicFlag() : SimAccessor
  • GetDynamicProperties() : DBService
  • GetEcc() : SimAuxHandler
  • GetEccArray() : SimAccessor
  • GetEccCategory() : CallHdl, MocSetupReqArg, RedialSetupIndArg, MocSetupAccArg, CallIndArg, XCallInfoResponseParser, EccProvider, DataHandler
  • GetEccCount() : SimAuxHandler
  • GetEccCustomization() : DataHandler
  • GetEccNetworkArray() : EccListIndArg
  • GetEccRecord() : UsimEccReadIndArg
  • GetEditableTable() : DataConnApp::DataConnDescription
  • GetEditMode() : AbstractEditor, EditBox
  • GetEditor() : IpAddrPrompt, EmsComposeWin, IpAddrPrompt, InputMapper, Caret
  • GetEditorDocument() : EditorDocumentObtainer
  • GetEditorItem() : EditorItemNode
  • GetEepCalibrationStatus() : StatusProvider
  • GetEffectiveViewfinderRect() : Camera
  • GetEffectiveWchars() : DataCoding
  • GetEfId() : SimGenericReqArg, SimGenericIndArg
  • GetEfLength() : SimGenericIndArg
  • GetEfParams() : SimGenericIndArg
  • GetEfRefresh() : SimTkRefreshNewReqArg, SimTkRefreshQueryReqArg, SimTkRefreshReqArg
  • GetEleCount() : Zi8AlphabetBox
  • GetElem() : HashTable
  • GetElementAt() : MediaRefContainer, AtResponseInfoTable, AtCommandInfoTable
  • GetElementCount() : Zi8Wrapper, Zi8InputMapper
  • GetEmail() : PbRecord, SaveEntryInPhonebookMsg, VCard
  • GetEmailRecordNo() : UsimPbRefRecord
  • GetEmlpp() : SimAccessor
  • GetEmlppSetupCallCondition() : SimAuxHandler, DataHandler
  • GetEmlppSubscription() : SimAuxHandler, DataHandler
  • GetEmptyBytesInTx() : DhChannelSendIndArg
  • GetEmsColorCount() : EmsResourceMaps
  • GetEmsColorNames() : EmsResourceMaps
  • GetEmsColors() : EmsResourceMaps
  • GetEmsCreator() : EmsApp
  • GetEncoder() : ImageEncodingProgressMsg, EncodingThreadlet
  • GetEncoderCodec() : MediaFrameworkCaps
  • GetEncoding() : BtBipImageHdlDesc, BtBipImageDesc, BtBipImageFormat
  • GetEncodingFormat() : PngEncoder::EncodingParameters, JpegEncoder::EncodingParameters
  • GetEncodingParams() : ImageEncoder
  • GetEndDate() : DrmAsset
  • GetEntry() : PbRecordHandler, MenuTableNode, ContextTableNode, PbEntryReadIndArg, SimPbEntryCont, SimPbBaseHandler, PbBaseProvider
  • GetEntryContainer() : SimPbBaseHandler
  • GetEntryCount() : CalendarRecordsListBoxModel, CalendarRecordsList
  • GetEntryNr() : PbEntryShowAction
  • GetEonsPlmnName() : SimAuxHandler, DataHandler
  • GetEqualDirectoryNode() : RamFileNode
  • GetErrCause() : SaLocationErrArg
  • GetErrCode() : LocationErrMsg
  • GetError() : SocketData, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket, ShortMessageFailureCause, FtpTransferMessage
  • GetErrorCause() : MmCallDisconnectingMsg
  • GetErrorCode() : ObexResult, Image, SsErrorMsg, NetworkSsErrorMsg, SsRequestRejectedMsg, MptyHoldRejectedMsg, SimErrorMsg, SsErrReqArg, SimErrorIndArg, VrErrorIndArg, VrErrorMsg, SvgPlayer
  • GetErrorMessage() : StreamingInfo
  • GetErrorNumber() : SerialIoAdapter
  • GetErrorPage() : HttpClient
  • GetErrorReason() : BtOperationBase
  • GetErrorText() : SsErrorMsg
  • GetEst() : UsimEstReadIndArg
  • GetEstablishCause() : CallHdl, CallIndArg
  • GetEstCause() : RedialSetupIndArg, MocSetupAccArg, XCallInfoResponseParser
  • GetEvaluationPrecedenceIndex() : PdpContext::PacketFilter
  • GetEvent() : CallEventMsg, SerialIoSet, SerialTerminalArg
  • GetEventCode() : LcsAppResWinMsg
  • GetEventList() : SimTkSetupEventReqArg
  • GetExclusionGroup() : AudioReference
  • GetExecFn() : Action
  • GetExecutingRequest() : BtSingleConnectionController, BtConnectionlessController
  • GetExecutionContext() : MessageHook, SmsSocket, MainHandler
  • GetExistentSmsCount() : AbstractSmsApp
  • GetExistingCount() : SimPbEntryCont, SimPbBaseHandler
  • GetExitCode() : CloseWindowMsg
  • GetExpiredTime() : Ticks
  • GetExposure() : Camera
  • GetExposureLimits() : Camera
  • GetExtByFileType() : FfsMimeTypeMap
  • GetExtByMimeStr() : MimeTypeTable
  • GetExtByMimeType() : MimeTypeTable
  • GetExtData() : MdhExtendedData
  • GetExtendedAddress() : VCard
  • GetExtendedData() : MdhSmsExtendedDataReqArg, MdhSmsTransmitIndArg, MdhSmsReadIndArg, TpduHeaderInformation
  • GetExtendedObjectBuffer() : InformationElement
  • GetExtendedObjectControlDataMayBeForw() : InformationElement
  • GetExtendedObjectControlDataUserPrompt() : InformationElement
  • GetExtendedObjectLength() : InformationElement
  • GetExtendedObjectPosition() : InformationElement
  • GetExtendedObjectReferenceNumber() : InformationElement
  • GetExtendedObjectType() : InformationElement
  • GetExtension() : SubMenuAction, AccessorAction
  • GetExtensionSeparator() : Pathname
  • GetExternalCommunicator() : MessageRouter
  • GetExtLanguage() : SimTkLanguageNotificationMsg, LanguageSettingIndArg, LanguageSelectEventArg, SimTkLanguageNotificationIndArg, SimAuxHandler
  • GetExtLanguageCount() : SimAuxHandler
  • GetFamilyName() : VCard
  • GetFavicon() : HttpClient
  • GetFdnProvider() : PbDataHandler
  • GetFdnState() : FdnReqArg, FdnIndArg, SimAuxHandler, SimAccessor
  • GetFdnTagSize() : SimPbBaseHandler
  • GetFeature() : IdentifierHandler, FeaturePool, FeatureItem, FeatureBroker, KeyMapping, FeatureChangedMsg
  • GetFeatureId() : FeatureItem, Feature, SoftkeyDesc, DisabledFeatureTriggeredMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg
  • GetFeaturePool() : AtlApplication
  • GetFfsTestBase() : SocketTestApp, FfsTestDispWin
  • GetFile() : FilePack, RootFileSystem, FileChunkOperationProgressMsg, HttpResponse
  • GetFileExtension() : Pathname
  • GetFileId() : SimFileInfoReqArg, SimFileInfoIndArg, UriMappingTable, RegNodeBuffer, FfsHandler, DeletedNode
  • GetFileIndex() : UriMappingTable
  • GetFileInfo() : FfsHandler, RamHandler, FatHandler, SimAccessor
  • GetFileLength() : SimAccessor
  • GetFileName() : FilePackConnector, BtBipGetLinkedAttachmentIndArg, FfsHandler
  • GetFileNames() : FilePackConnector
  • GetFileSize() : FilePackConnector, FfsFile, SimFileInfoIndArg, FlsFile, RamFile, FatFile
  • GetFileStatus() : BdnIndArg, FdnIndArg
  • GetFileType() : FfsFile, SimFileInfoIndArg, SimRefreshIndArg, FlsFile
  • GetFileTypeByExt() : FfsMimeTypeMap
  • GetFileTypeByMimeStr() : FfsMimeTypeMap
  • GetFileTypeByMimeType() : FfsMimeTypeMap
  • GetFilter() : CameraSettings, Camera, BtBipGetImagesListIndArg, CbsFilterList, CbsStartReqArg
  • GetFilterParams() : BtBipImagingCapabilities
  • GetFinishedCommand() : TermRspCnfArg
  • GetFirst() : VersionInfo, BtSddbDeContainer, DeletedNodeList
  • GetFirstAppContainer() : System
  • GetFirstApplicationListEntry() : AppContainerRoutingTableEntry
  • GetFirstAttribute() : BtSddbServiceRecord
  • GetFirstCell() : Grid, GridModel
  • GetFirstConnection() : BtMultiConnectionController
  • GetFirstControl() : Control
  • GetFirstDrawableObject() : Control
  • GetFirstExtByMimeStr() : MimeTypeTable
  • GetFirstExtByMimeType() : MimeTypeTable
  • GetFirstFreeRecNo() : PbRecordProvider
  • GetFirstFreeSimPosition() : SimPbEntryCont
  • GetFirstIndex() : BtBipGetImagesListIndArg
  • GetFirstInformationElement() : UserDataHeader
  • GetFirstInputAction() : InputAnalyzer
  • GetFirstItem() : TRadioButtonList< Content >, RadioButtonList, MenuList, CheckBoxList, AbstractMenuListModel< Item >
  • GetFirstKey() : AtKeyParser
  • GetFirstKeyColumnId() : JoinProvider
  • GetFirstLexToken() : LexAnalyzer
  • GetFirstPageEntry() : HeapManager
  • GetFirstProperty() : DataConnApp::DataConnDescription
  • GetFirstProvider() : JoinProvider
  • GetFirstVideoFrame() : MediaPlayer
  • GetFirstVisibleColumn() : ItemMenu::LevelInfo, AbstractGrid
  • GetFirstVisibleIndex() : ItemMenu::LevelInfo, AbstractLineEditor, AbstractGrid, AbstractListBox, AbstractListBoxModel, AbstractEditBoxModel
  • GetFirstVisibleLine() : AbstractEditBoxModel
  • GetFirstVisibleLineIndex() : AbstractMultiLineEditor
  • GetFirstVisibleRow() : GridModel
  • GetFirstWindow() : Application
  • GetFixedRingerToneInfo() : RingerAudioDevice
  • GetFlag() : LockedKeyMsg, SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadIndArg, SimODynReadIndArg
  • GetFlags() : VersionInfo
  • GetFlash() : CameraSettings, Camera
  • GetFlashStoredTpduNum() : TpduHeaderInformation
  • GetFlowLabel() : PdpContext::PacketFilter
  • GetFmRadioSettingsProv() : FmRadioApplication
  • GetFmRadioStationsProv() : FmRadioApplication
  • GetFmRadioWin() : FmRadioApplication
  • GetFocusedAppContainer() : System
  • GetFocusedApplication() : System
  • GetFocusedControl() : Control
  • GetFocusedWindow() : Application
  • GetFocusMsg() : GetFocusMsg
  • GetFocusPriority() : Window
  • GetFolder() : UibRegisterMsg
  • GetFolderType() : UibFolderWin
  • GetFont() : Zi8InputConfig, T9InputConfig, FontConfig, System, TextFormat, TextEditorDocument, TextCompoundItem, MultiLineEditor, LineEditor, FontPackConnector, FontPack, FontManager, DeviceContext, AbstractTextObject, ResourceManager, MultiMediaEditor
  • GetFontAlign() : TextFormat, DeviceContext
  • GetFontCount() : FontConfig
  • GetFontFamilyName() : FontManager, FontEntry
  • GetFontId() : ThemeConfig, Theme
  • GetFontName() : FontManager
  • GetFontNames() : FontPackConnector
  • GetFonts() : FontPack
  • GetForegroundColor() : RichTextCompoundItem, MultiMediaEditor
  • GetForegroundControl() : Control
  • GetForegroundWindow() : Application, WindowManager
  • GetFormat() : TimeEditBox, DateEditBox, CustomRingerAudioReference, ValidityPeriod, ValidityPeriodFormat
  • GetFormattedName() : VCard
  • GetForwardingFeatures() : CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg
  • GetForwardingInfo() : SsForwardingIndArg
  • GetForwardPhoneNumber() : CfuService
  • GetFractionString() : Fraction
  • GetFrame() : ImageMetaData, ImageBox
  • GetFrameBuffer() : DisplayConfig
  • GetFrameCount() : Image, Image::MetaData
  • GetFrameDelay() : EmsImage, NativeImage, Image, SvgImage, WbmpImage, PngImage, JpegImage, GifImage, BmpImage
  • GetFrameHeight() : Image, GifImage
  • GetFrameRate() : VideoCamera, Media
  • GetFrameSize() : AbstractEditBoxView
  • GetFrameType() : Control
  • GetFrameView() : Window, Control
  • GetFrameWidth() : Image, GifImage
  • GetFrameXPos() : Image, GifImage
  • GetFreeBlockIndex() : RamStorageMapper
  • GetFreeConnId() : HttpWapMgr
  • GetFreeExtRecords() : SimPbBaseHandler
  • GetFreeFfsSpace() : FfsHandler
  • GetFreeRequestId() : HttpWapMgrPlugin
  • GetFreeSerialTerminal() : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • GetFreeSize() : BtObexService, RamStorageMapper
  • GetFreeSmsCount() : AbstractSmsApp
  • GetFreeSpaceByType() : FfsHandler
  • GetFreeSpaceInGlobalPool() : FfsHandler
  • GetFreeSpaceSize() : RamHandler, RamFileSystem, FatHandler
  • GetFreeVolumeSize() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetFrequencies() : AudioFmRadioRdsAlternativeFrequenciesMsg
  • GetFrequency() : AudioFmRadioSeekMsg
  • GetFront() : EmzUtils::Queue< T >, SortedLinkedList< T >, LinkedList< T >, LinkedListBase, SortedElementList< T >, ElementList< T >
  • GetFtpDataSocket() : FtpClient
  • GetFtpInTransfer() : FtpDataSocket
  • GetFtpOutTransfer() : FtpDataSocket
  • GetFtpRequest() : FtpRequestMessage
  • GetFtpSocket() : FtpDataSocket, FtpClient
  • GetFunction() : EngineeringModeControlRequestArg, EngineeringModeControlResponseArg
  • GetFunkId() : AudioMsg
  • GetGain() : BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain
  • GetGap() : ItemRendererProperties
  • GetGapToNextChar() : RomFont, FontManager, FontEntry, Font
  • GetGateway() : SimLaunchBrowserReqArg
  • GetGeneralResult() : LaunchBrowserPromptIndArg, SimTkRefreshQueryResArg
  • GetGenericObject() : DataItem, Property
  • GetGenericObjectPtr() : DataItem, Property
  • GetGenericTrackInfo() : GenericFeatureData
  • GetGenResult() : DhChannelReceiveIndArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelOpenPromptResArg
  • GetGeographicalScope() : Cbs::SerialNumber
  • GetGivenName() : VCard
  • GetGlassPane() : Desktop
  • GetGlassPanePosition() : IndicatorLocation
  • GetGlobalProvider() : MainProvider
  • GetGlobalTraceMask() : InternalTracer
  • GetGlyph() : VietnameseTextRenderer, ThaiTextRenderer, SimpleTextRenderer, RomFont, JapaneseTextRenderer, HindiTextRenderer, FontManager, FontEntry, Font, ArabicTextRenderer, AbstractTextRenderer
  • GetGlyphs() : FontManager
  • GetGlyphStartPos() : FontEntry
  • GetGors() : MdhSmsDeletionIndArg
  • GetGprsClass() : GprsClassReqArg, GprsClassIndArg
  • GetGpsFixData() : MeasurementData
  • GetGreen() : ColorTable, Color
  • GetGreenBitCount() : ColorSegmentation
  • GetGreenKey() : KeyboardConfig
  • GetGroup() : RadioButtonAction, UsimPbGroups
  • GetGroupId() : PbRecord, DataCodingScheme, TpduHeaderInformation
  • GetGroupVector() : UsimPbRwRecord
  • GetGsmBand() : GsmBandStateMsg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, StatusProvider, DataHandler
  • GetGsmBandList() : BandSelectionReqArg
  • GetGsmErrorCause() : RegistrationChangeMsg, NRegStateIndArg
  • GetGsmService() : SmsSettingsRecord, PrefServiceSetReqArg, MnInformationIndArg
  • GetGsmServiceCount() : SmsGsmServiceTextMap
  • GetGsmServiceName() : SmsGsmServiceTextMap
  • GetGsmSignal() : CallHdl, MtcSetupIndArg
  • GetGuid() : ExecutionContext, Service
  • GetHandle() : MemMap, AudioMsg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, FlsFile, FatFile
  • GetHandler() : PbRecordProvider, GetPasswordMsg, StackControl, MainHandler, HandlerListEntry, PbBaseProvider
  • GetHandlerId() : SsHandler, UusHandler, UssdHandler, SsCcbsHandler, SmsHandler, SimTkHandler, SimHandler, SigHandler, PowerHandler, PlmnHandler, NetworkHandler, MultiSlotHandler, MobileOriginatedUssdHandler, EmlppHandler, CrssHandler, ColrHandler, ColpHandler, CnapHandler, ClirHandler, ClipHandler, CbsHandler, CallWaitingHandler, CallHandler, CallForwardingHandler, CallDeflectionHandler, CallBarringHandler, BootHandler, AtcHandler, AocHandler, AccHandler, VrHandler, MmCallHandler
  • GetHandlerType() : ExternalCommunicationHandler, SignalHandler
  • GetHashValue() : PhoneNumber
  • GetHdl() : SysSocket
  • GetHead() : Pathname
  • GetHeader() : BtObexClientNmaHeaderIndication, BtObexServerNmaHeaderIndication, BtObexHeaderIndicationEvent
  • GetHeaderBuffer() : BtObexRegisterServerRequest, BtObexRegisterClientRequest
  • GetHeaderBufferSize() : BtObexRegisterServerRequest, BtObexRegisterClientRequest
  • GetHeaderCompression() : PdpContext
  • GetHeaderHeight() : TabControlView, AbstractItemGrid, AbstractGrid
  • GetHeaderItem() : AbstractItemGrid
  • GetHeaderList() : ObexObject
  • GetHeaderRect() : AbstractGrid
  • GetHeaders() : HttpResponse, HttpRequest
  • GetHeaderText() : SimPduHandler
  • GetHeadsetKey() : KeyboardConfig
  • GetHeapBase() : MemoryConfig
  • GetHeight() : DisplayConfig, ImageMetaData, Size, RomFont, Rect, ItemRendererProperties, ImageObtainer, ImageEncoder::EncodingParameters, Image, Image::MetaData, FontManager, FontEntry, Font, EditorLine, DeviceContext, Component, Bitmap, BitmapRes, VirtualDisplay, WinRect, SoundItem, SimImage, SvgPlayer, SvgImageFileWrapper, VCardItem, PngDecoder, ImageItem, BoundedItem, AudioItem, MediaInfo::VideoTrackInfo
  • GetHeldCallHdl() : CallHdl
  • GetHelloRequest() : GltpAidDataRequests
  • GetHfProfileName() : BtHfSupportedProfileMessage
  • GetHfServiceName() : BtQuerySupportedProfilesRequest
  • GetHfSupportedFeatures() : BtHfSupportedProfileMessage
  • GetHiddenInfo() : UsimPbRwRecord
  • GetHighCutControl() : RadioAudioDevice
  • GetHighLowSideLoInjection() : RadioAudioDevice
  • GetHiglightedText() : VoiceMemoMenuAccessor
  • GetHomeBcdPlmn() : DataHandler
  • GetHomePlmn() : DataHandler
  • GetHostByAddr() : SysDnsClient, DnsClient
  • GetHostByAddrAsync() : SysDnsClient, DnsClient
  • GetHostByName() : SysDnsClient, DnsClient
  • GetHostByNameAsync() : SysDnsClient, DnsClient
  • GetHostIp() : Server, HttpServer, FtpServer
  • GetHour() : TimeEditBox, TimeSpan, Time, DateTime
  • GetHsProfileName() : BtHsSupportedProfileMessage
  • GetHsServiceName() : BtQuerySupportedProfilesRequest
  • GetHttpRequest() : HttpRequestMessage
  • GetHttpSocket() : HttpClient
  • GetHttpVersion() : HttpRequest
  • GetHyperlink() : SvgHyperlinkSelectMsg
  • GetHyperlinkFormatElementAbsolutStartPosition() : InformationElement
  • GetHyperlinkFormatElementTitelLength() : InformationElement
  • GetHyperlinkFormatElementUrlLength() : InformationElement
  • GetIccId() : PbRecord
  • GetIccidString() : SimAuxHandler
  • GetIcon() : TabControl, Item, IconSet, IconValueIndicator, IconTextIndicator, IconIndicator, ValueMappingPropertyDescriptor< T_Container >, TextIconPairArray::TextIconPair, PropertyDescriptor, ListPropertyDescriptor, ProviderProxyItem, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimLaunchBrowserPromptReqArg, SetupIdleModeTextReqArg, PlayToneReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • GetIconColorTable() : GuiEngineConfig
  • GetIconColumnId() : ProviderProxyContainer
  • GetIconCount() : IconSet
  • GetIcondesc() : IconDescReadIndArg
  • GetIconId() : SimIconDescription
  • GetIconList() : SetupMenuReqArg, SelectItemReqArg
  • GetIconRect() : DefaultItemRenderer, AbstractItemRenderer, AtlItemRenderer
  • GetIconSize() : GuiEngineConfig
  • GetIconSizeState() : DefaultItemRenderer, AbstractItemRenderer
  • GetID() : PropertyEditor, TriggerKeyFeature, FeatureItemContainer, FeatureItem, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, AtlApplication
  • GetId() : AmrSound, PredefinedEmsSound, PredefinedEmsImage, EmsImage, NetAdapter, DataConnProfile, ObexHeader, TimeCompoundItem, TextCompoundItem, PhoneNumberInputMapper, NumericInputMapper, MultiTapInputMapper, IpAddrInputMapper, IpAddrCompoundItem, InputMapper, FontEntry, DateTimeInputMapper, DateCompoundItem, DataPack, CompoundItem, Component, CharItem, CalculatorInputMapper, AtomItem, AcacLanguage, AbstractEditorItem, AudioGatiServer, GenericAudioDevice, GatiServer, SoundItem, Sound, SmafSound, PreparedSound, MidiSound, IndicatorBar, Indicator, IMelody, ActionExtension, BtObexClientAbortEvent, BtObexClientPutEvent, BtObexClientGetEvent, BtObexClientSetPathEvent, BtObexClientDisconnectEvent, BtObexClientConnectEvent, BtObexRegisterClientEvent, BtObexServerAbortIndicationEvent, BtObexServerPutIndicationEvent, BtObexServerGetIndicationEvent, BtObexServerSetPathIndicationEvent, BtObexServerDisconnectIndicationEvent, BtObexServerConnectIndicationEvent, BtObexRegisterServerEvent, BtObexTransportDisconnectEvent, BtObexDataIndicationEvent, BtObexDataBufferIndicationEvent, BtObexHeaderSentEvent, BtObexHeaderIndicationEvent, BtObexUnregisterEvent, BtSddbUnregisterServiceEvent, BtSddbRegisterServiceEvent, BtEvent, ProviderPtr, InputMapperFactory, PdpContext, PdpContext::PacketFilter, SimTkTransactionId, SimIconIdentifier, SimItemIdentifier, StorageDevice, Zi8InputMapper, T9InputMapper, ServerClient, HttpClient, HttpApplication, FtpClient, VCardItem, RichTextCompoundItem, ParagraphMarker, ParagraphCompoundItem, ImageItem, GeneralCompoundItem, BoundedItem, AudioItem, AccessorActionExtension, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, DataRecord
  • GetIdentifier() : IdentifierHandler, InformationElement
  • GetIdleTimeout() : DataConnProfile
  • GetIdOfFont() : FontManager
  • GetIgnoreManagement() : AudioReference, AudioPreset
  • GetIlluminationMode() : Keyboard
  • GetImage() : ImageRef, ImageDrawingInterruptedMsg, ImageDecodingProgressMsg, ImageObtainer, EncodingThreadlet, ImageReadIndArg, SvgImageFileWrapper, ImageItem
  • GetImageBuffer() : ImageBox, Image, SimImage
  • GetImageBufferLength() : SimImage
  • GetImageBufferMax() : GuiEngineConfig
  • GetImageDesc() : BtBipGetImageIndArg, BtBipPutImageIndArg
  • GetImageDim() : BtBipImageHdlDesc, BtBipImageDesc, BtBipImageFormat
  • GetImageHandle() : BtBipGetImageIndArg
  • GetImageHdl() : BtBipImageProperties, BtBipImage, BtBipDeleteImageIndArg, BtBipGetLinkedAttachmentIndArg, BtBipGetLinkedThumbnailIndArg, BtBipGetImagePropertiesIndArg, BtBipPutLinkedAttachmentCompleteArg, BtBipPutLinkedAttachmentIndArg, BtBipPutLinkedThumbnailCompleteArg, BtBipPutLinkedThumbnailIndArg, BtBipPutImageCompleteArg, BtBipClientService
  • GetImageId() : ImageFactory
  • GetImageList() : BtBipImageList
  • GetImageName() : BtBipImageProperties, BtBipPutImageIndArg
  • GetImageObtainer() : ImageRef, ImageBox, ImageItem
  • GetImageProperties() : BtBipClientService
  • GetImagePropertiesReq() : BtBipClientService
  • GetImagePropertiesRsp() : BtBipServerService
  • GetImageRefObj() : ImageRefGenContainer
  • GetImageReq() : BtBipClientService
  • GetImageRsp() : BtBipServerService
  • GetImageSize() : CameraSettings, BtBipImageDesc
  • GetImageSizeDimensions() : Camera
  • GetImagesList() : BtBipClientService
  • GetImagesListReq() : BtBipClientService
  • GetImagesListRsp() : BtBipServerService
  • GetImagingCapabilites() : BtBipClientService
  • GetImagingCapabilitiesReq() : BtBipClientService
  • GetImagingCapabilitiesRsp() : BtBipServerService
  • GetImei() : SimAccessor
  • GetImei1() : ImeiReadIndArg
  • GetImei2() : ImeiReadIndArg
  • GetImeiString() : SimAuxHandler
  • GetImgdescriptor() : ImageReadReqArg
  • GetImgObt() : ImgObtObj
  • GetImgRequestType() : ImageReadReqArg
  • GetImmediateSearch() : BtDeviceListWindow
  • GetImmediatlyRetrieveRemoteDeviceNames() : BtDeviceSearchRequest
  • GetImsi() : SimInitIndArg
  • GetImsiBcdPlmn() : SimAuxHandler
  • GetImsiPlmn() : SimChvHandler
  • GetImsiString() : SimAuxHandler
  • GetInboxProvider() : AbstractSmsApp
  • GetInboxUnreadProvider() : AbstractSmsApp
  • GetInBufByteCount() : SysSocket, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket
  • GetInc() : AbstractGrid::SmoothScrollInfo, AbstractListBox::SmoothScrollInfo
  • GetIndex() : MetaData, MediaRefContainer, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, MetaData, MediaRefContainer, DataConnAccessor, ObexChannel, RedrawDisplayMsg, SelectionChangedMsg, Caret, DisplayInfoMsg, AbstractDevice, Animation, AnimationModel, EditLine, RangeMappingPolicy, MappingPolicy, SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg, T9Pack
  • GetIndexForValue() : MultipartParser
  • GetIndexOf() : AcacLanguage
  • GetIndexOfActiveLanguage() : TextPackConnector
  • GetIndexOfFile() : FilePackConnector
  • GetIndexOfFont() : FontManager
  • GetIndexOfLanguage() : TextPackConnector
  • GetIndexPage() : HttpClient
  • GetIndexTableIndex() : AbstractDelegationProvider
  • GetIndicator() : HomezoneMsg, PlmnInfoReqArg, AttachReqArg, HomezoneIndArg
  • GetIndicatorbarExpansion() : IndicatorBar
  • GetIndicatorBarId() : IndicatorLocation
  • GetIndicatorBarPosition() : IndicatorLocation
  • GetIndicatorDescription() : Indicator
  • GetIndicatorId() : IndicatorDescription
  • GetIndicatorLocation() : IndicatorDescription
  • GetInfo() : DisplayInfoMsg, PbInfoReadIndArg
  • GetInfoAlpha() : PlayToneReqArg
  • GetInformationElement() : BaseInformationElement
  • GetInfoText() : MetaData, ImageMetaData, MetaData
  • GetInitialPrefferedStorageMedia() : SimAccessor
  • GetInitialType() : SmsStatusReport
  • GetInitResult() : SimInitIndArg, SimAuxHandler
  • GetInkeyReqArg() : GetInkeyReqArg
  • GetInkeyRspArg() : GetInkeyRspArg
  • GetInputAction() : InputActionPtr
  • GetInputMap() : KeyboardConfig, ResourceManager
  • GetInputMapper() : AbstractEditor
  • GetInputReqArg() : GetInputReqArg
  • GetInputRspArg() : GetInputRspArg
  • GetInputTogglingKey() : KeyboardConfig
  • GetInquiryAccessCode() : BtDeviceSearchRequest
  • GetInquiryTimeOut() : BtDeviceSearchRequest
  • GetInstance() : VoiceMemoApp, UsbApp, UibApp, ToDoApp, SoundBrowserApp, MediaBrowserUtils, SocketTestApp, RegEncoderDecoder, RegAppWin, RegApp, ObexApp, LcsSettingsUtils, LcsSettingsApp, GltpConnApp, LocResController, LcsWapIntf, LcsMainApp, LcsAppUtils, IrdaApp, ImageBrowserApp, MediaBrowserUtils, FmRadioApplication, SmsUtility, SmsApp, EmsApp, DataConnApp, CameraApp, CalendarApp, BtHsAppPlugin, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, BtApplication, BtAvrcpPanelApplication, AdvPbApp, SocketSubSystem, ObexServerOppImpl, ObexMngr, ObexClientOppImpl, ObexOppClientPull, ObexOppClientPush, GenericWorkerTask, IrdaObexTransport, IrdaTransport, VietnameseTextRenderer, ThaiTextRenderer, SimpleTextRenderer, JapaneseTextRenderer, HindiTextRenderer, Desktop, BidiManager, ArabicTextRenderer, FoggyTheme, DefaultTheme, CustomizableTheme, MmiSimServer, AudioGatiServer, GatiManager, CamWin32, VibratorDevice, RtcSignalMapTableNode, LedSignalMapTableNode, DeviceManager, ChargerSignalMapTableNode, BtObexTransport, BtObexMessageArgumentsDestroyTableNode, BtObexController, BtHsMessageArgumentsDestroyTableNode, BtHfMessageArgumentsDestroyTableNode, BtTransport, BtSddbDataElementFactory, BtBppController, BtAvrcpMessageArgumentsDestroyTableNode, JapaneseTranscoder, BufferPoolManager, SpeechSimpleAudioDevice, RadioAudioDevice, MmfPlayer, AudioPresetStore, AudioPlayerStore, AudioPathManager, AudioError, AudioDeviceManager, AudioAccessoryStore, PropertyEditorFactory, FeatureBroker, KeyManager, ContextManager, PdpContextSignalMapTableNode, DataCallSignalMapTableNode, StackControl, SmsSocketSignalMapTableNode, SimTkLceService, SignalHandler, KeyMsgGenerator, CommonStackMsgMapTableNode, CommonSignalMapTableNode, CommonStackMsgArgsDestroyTableNode, RegManager, MapiAudioPlayer, VrStackMsgArgTableDestroyTableNode, UsbTransport, UsbSubSystem, SyncMLManager, HttpApplicationSupplier, HttpApplication, SerialSocketSubSystem, PngDecoder, SerialTerminalMsgArgsDestroyTableNode, MediaManager, SaStackMsgArgsDestroyTableNode, SaSignalMapTableNode, SaProviderImpl, GltpStackMsgArgsDestroyTableNode, GltpSignalMapTableNode, GltpProviderImpl, LcsUtils, LcsReqProcessor, LcsProvider, LcsCommonStackMsgArgsDestroyTableNode, LcsCommonSignalMapTableNode, LcsStackMsgArgsDestroyTableNode, LcsSignalMapTableNode, LcsProviderImpl, WapProfileMgr, HttpWapMgrPlugin, HttpWapMgr, DrmSubsystem, RamStorageMapper, RamFileSystem, LookupAlphaIdExtension
  • GetInstanceDataItem() : RegAppCommon
  • GetInstanceIteratorObj() : RegAppCommon
  • GetInstanceMobile2PC() : RegAppCommon
  • GetInstancePC2Mobile() : RegAppCommon
  • GetInstanceptr() : MediaManagerMsg
  • GetInstanceUri() : RegAppCommon
  • GetInt() : NumberPrompt
  • GetIntegerPayload() : RegNodeBuffer
  • GetIntegerValue() : AtResponseParameter
  • GetInteriorMetaData() : RegIterator, RegEncoderDecoder
  • GetInteriorPayload() : RegNodeBuffer
  • GetInternalDisplayIndex() : Control
  • GetInternalRecNo() : TpduHeaderInformation
  • GetInterrogateCcbsResult() : CcbsResultMsg, SsCcbsResultIndArg
  • GetInterval() : DateTime
  • GetIntervalConstraint() : DrmRightsObject, DrmPermission
  • GetIntervall() : DrmConstraint
  • GetInterworking() : ProtocolIdentifier
  • GetInvalidation() : SimFileInfoIndArg
  • GetInvalidHdl() : SysSocket
  • GetInvalidNetAdapterId() : NetAdapterHandler
  • GetInvalidNsapi() : SysSocket
  • GetInvokeId() : InvokeId, LocationNotifInvokeMsg
  • GetIoSetInstance() : SerialSocketThread
  • GetIpAddr() : IpAddrPrompt, InetSocketAddr, IpAddrEditorDocument, IpAddrEditor, IpAddrCompoundItem, PdpContext::Address
  • GetIpAddress() : PsdDataConn, PppDataConn, DataConn
  • GetIpSecSecurityParameterIndex() : PdpContext::PacketFilter
  • GetIPv4String() : PdpContext::Address
  • GetIsLsaIdentifierPresent() : StatusProvider, DataHandler
  • GetIsProfileActive() : BtLocalSettings
  • GetIsRegistered() : BtController
  • GetIsServer() : BtObexController::BtObexConnection
  • GetIsWin98Mode() : IrdaTransport
  • GetItalicIncrement() : AbstractTextRenderer
  • GetItem() : ImageViewListBoxModel, ImageListBoxModel, SmsTextParser, ItemPropertiesChangedMsg, ItemContainer, ItemBox, AbstractItemContainer, ItemLabel, ItemObj, FeatureItemContainer, UpdateItemMsg, GeneralCompoundItem
  • GetItemColumnIconId() : ProviderProxyItem
  • GetItemColumnTextId() : ProviderProxyItem
  • GetItemContainer() : OpenContextMenuAction, ItemTree, ItemMenu::LevelInfo, ContextMenu, AbstractItemGrid, AtlItemListWindow, MenuDesc
  • GetItemCount() : SmsTextParser, TimeEditorDocument, TimeCompoundItem, TextEditorDocument, TextCompoundItem, ItemContainer, IpAddrCompoundItem, EditorDocument, DateEditorDocument, DateCompoundItem, CompoundItem, AbstractItemContainer, AbstractEditor, AbstractListBox, AbstractListBoxModel, ValueMappingPropertyDescriptor< T_Container >, ListPropertyDescriptor, FeatureItemContainer, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem
  • GetItemData() : DBService
  • GetItemForIndex() : AbstractMenuListModel< Item >
  • GetItemHeight() : DefaultItemRenderer, AbstractItemRenderer, TextMenuAccessor, RadioButtonView, MenuAccessor, CheckBoxView, AbstractMenuAccessor, AbstractListBox
  • GetItemIcon() : FfsTestResultsMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, MenuAccessor, AbstractActionMenuAccessor
  • GetItemId() : MenuSelectionReqArg, SelectItemRspArg
  • GetItemIndex() : ItemContainer, AbstractItemContainer, FeatureItemContainer
  • GetItemList() : SetupMenuReqArg, SelectItemReqArg
  • GetItemMetaInfo() : DBService
  • GetItemRect() : ItemTree, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemGrid, AbstractEditor, AbstractListBoxView
  • GetItemScope() : TextEditorDocument, EditorDocument, MultiMediaEditorDocument
  • GetItemsNai() : SetupMenuReqArg, SelectItemReqArg
  • GetItemText() : VoiceMemoMenuAccessor, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsMenu, SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor, MenuAccessor, AbstractActionMenuAccessor
  • GetItemType() : EditorItemNode
  • GetItemUri() : DBItemChangedMsg
  • GetItemWidth() : AbstractMenuAccessor, AbstractListBox
  • GetIterator() : SimpleMap< TKey, TValue >, RegEncoderDecoder
  • GetIteratorFilter() : StorageDeviceVisitor, FileVisitor
  • GetJoinRule() : JoinProvider
  • GetJPEGQuality() : CameraSettings
  • GetJpegQuality() : StillCamera
  • GetKey() : SimpleMapElem< TKey, TValue >, PhoneNumber, Hashable, GetInkeyRspArg, StartDtmfReqArg, StartDtmfCnfArg, DrmRightsObject
  • GetKeyCode() : LockedKeyMsg, LockedKeyDownMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, KeyUpInputMapItem, KeyDownInputMapItem, PagingMapEntry, T9MatrixModeKeypressed, TriggerKeyFeature, KeyMsgGenerator::Key
  • GetKeyForFunction() : T9InputConfig
  • GetKeyId() : PbRecordProvider
  • GetKeyIdBuffer() : SimMexeCertificate, MexeDescriptor
  • GetKeyIdLength() : SimMexeCertificate, MexeDescriptor
  • GetKeyItem() : PbDetailProvider
  • GetKeyMap() : ContextManager, ContextDescription
  • GetKeyState() : Keyboard
  • GetLabel() : PropertyDescriptor, AtlLabelListWindow
  • GetLacHigh() : OplEntry
  • GetLacLow() : OplEntry
  • GetLai() : CellInfoIndArg
  • GetLangFileType() : UsimLangUpdReqArg, UsimLangReadReqArg, UsimLangReadIndArg
  • GetLanguage() : System, TextPackConnector, TextPack, Locale, UsimLangUpdReqArg, DataCodingScheme, SimAuxHandler
  • GetLanguageArray() : SimExtLangUpdReqArg, SimLangUpdReqArg, SimExtLangReadIndArg, SimLangReadIndArg
  • GetLanguageAt() : TextPackConnector
  • GetLanguageCode() : LanguageResetAction
  • GetLanguageCount() : LocaleConfig, SimAuxHandler
  • GetLanguageId() : LocaleConfig, Item, Control
  • GetLanguageList() : UsimLangReadIndArg
  • GetLanguageNames() : TextPackConnector
  • GetLanguages() : TextPackConnector
  • GetLanguageType() : LocaleConfig
  • GetLargeAnimationBuffer() : InformationElement
  • GetLargeAnimationLength() : InformationElement
  • GetLargeAnimationStartPosition() : InformationElement
  • GetLargePictureBuffer() : InformationElement
  • GetLargePictureLength() : InformationElement
  • GetLargePictureStartPosition() : InformationElement
  • GetLastAccessTimestamp() : RamFile, FatFile
  • GetLastAesError() : AesCrypt
  • GetLastBufferFilled() : BtObexDataBufferIndicationEvent
  • GetLastCcm() : StatusProvider
  • GetLastCcm2() : StatusProvider
  • GetLastCell() : Grid, GridModel
  • GetLastCompletelyVisibleRow() : GridView
  • GetLastCompleteVisibleIndex() : AbstractGrid
  • GetLastConnectedDevice() : BtHsService
  • GetLastDeletedUniqueId() : PbMergeProvider, PbAdvDataHandler, AdvPbApp
  • GetLastError() : SocketTestApp, ImageEncoder, Camera, FfsFile, StorageDevice, File, DirectoryIterator, FlsFile, PngDecoder, RootStorageDeviceImp, RootDirectoryIteratorImp, RamStorageMapper, RamHandler, RamFileSystem, RamFileObj, RamFile, FatHandler, FatFile
  • GetLastErrorCode() : CrssHandler
  • GetLastFocusedChild() : Control
  • GetLastFocusedControl() : Control
  • GetLastIteration() : SocketTestApp
  • GetLastKnownLocation() : LcsProviderImplBase, LcsProvider
  • GetLastModification() : Provider
  • GetLastNegotiatedDnsServerAddresses() : PdpContextManager
  • GetLastPanelPassThroughRequest() : BtAvrcpControllerDeviceListItem
  • GetLastSimUpdateStatus() : SimAccessor, DataHandler
  • GetLastStackDataCounters() : PdpContextManager
  • GetLastStatus() : SocketTestApp, TermRspCnfArg
  • GetLastTransaction() : DirtyFileHandler
  • GetLastUpdateTimestamp() : RamFile, FatFile
  • GetLastUsed() : MdhSmsStatusIndArg
  • GetLastVisibleIndex() : AbstractGrid, AbstractListBox, AbstractEditBoxModel
  • GetLastVisibleLine() : AbstractEditBoxModel
  • GetLastVisibleRow() : GridView
  • GetLdbId() : T9Pack
  • GetLdbIds() : T9PackConnector
  • GetLdbNumForMode() : EnglishT9InputMapper
  • GetLdbSize() : T9Pack
  • GetLeaf() : Pathname
  • GetLeafMetaData() : RegIterator, RegEncoderDecoder
  • GetLedId() : LedNotificationMsg
  • GetLeft() : Rect, WinRect
  • GetLeftGap() : RadioButtonView, CheckBoxView
  • GetLeftSize() : ControlFrameView
  • GetLeftSoftkey() : Window
  • GetLength() : EditorItemNode, EditorLine, TextListLine, EditLine, WString, WStrData, String, StrData, RomData, RamData, DynamicBitVector, DataSourceBinData, ChildBinData, ByteBuffer, BlobPtr, BinData, MemMap, KeySequence, PdpContext::Address, UserData, UserDataHeader, Tpdu, UsimEstReadIndArg, UsimLangReadIndArg, UsimPlmnReadIndArg, UsimUstReadIndArg, InformationElement, Cbs, FileBinData, MeasurementData
  • GetLevel() : ItemMenu, SignalStrengthLevelIndArg
  • GetLevelInfo() : ItemMenu
  • GetLine() : AbstractMultiLineEditor, AbstractEditBoxModel
  • GetLine2VoiceBoxNumber() : SmsSettingsRecord
  • GetLineAlignInc() : AbstractMultiLineEditor
  • GetLineAlignment() : EditorDocument, ParagraphCompoundItem, MultiMediaEditorDocument
  • GetLineCount() : AbstractMultiLineEditor
  • GetLineHeight() : TimeEditorDocument, TimeCompoundItem, TextEditorDocument, TextCompoundItem, IpAddrCompoundItem, EditorDocument, DateEditorDocument, DateCompoundItem, CompoundItem, AbstractEditBoxView, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem
  • GetLineIndex() : AbstractEditBoxModel
  • GetLineInUse() : SimCphsHandler
  • GetLineLength() : AbstractEditBoxModel
  • GetLineLocked() : SimCphsHandler
  • GetLineSelector() : HomezoneMsg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspUpdIndArg, CphsCspReadIndArg, HomezoneIndArg
  • GetLineWidth() : TimeEditorDocument, TimeCompoundItem, TextEditorDocument, TextCompoundItem, IpAddrCompoundItem, EditorDocument, DateEditorDocument, DateCompoundItem, CompoundItem, AbstractEditBox, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem
  • GetLingerOption() : SysSocket
  • GetLingerTimeout() : DataConnProfile, SocketPeer
  • GetLink() : SimSmsrUpdReqArg, SimSmsrReadIndArg, MdhNewStatusReportIndArg
  • GetLinkedAccessory() : AudioDeviceManager
  • GetLinkedAttachmentReq() : BtBipClientService
  • GetLinkedAttachmentRsp() : BtBipServerService
  • GetLinkedThumbnailReq() : BtBipClientService
  • GetLinkedThumbnailRsp() : BtBipServerService
  • GetLinkRecNo() : MdhSmsReportReadIndArg
  • GetList() : AtlItemListWindow
  • GetListBox() : ProvDetailListBoxWin, ProvColListBoxWin, ProvListBoxWin, AbstractListBoxModel
  • GetListBoxRow() : ProvListBoxWin, PbBaseWin, AdvPbWin
  • GetListIndex() : UsimLangReadReqArg
  • GetLlcSapi() : PdpContext::ActivationStatus
  • GetLndTagSize() : SimPbBaseHandler
  • GetLocal() : SysSocket, InetSocket
  • GetLocalAddr() : PsdDataConnProfile
  • GetLocalAddress() : BtLocalSettings
  • GetLocalDataSocketAddr() : FtpClient
  • GetLocalDateAndTime() : RealTimeClock
  • GetLocalDateTime() : RealTimeClock
  • GetLocalId() : DrmWapPushMsg, DrmRightsObject
  • GetLocalIpAddr() : DhChannelOpenReqArg
  • GetLocality() : VCard
  • GetLocalName() : SocketPeer, BtLocalSettings
  • GetLocalPort() : SocketPeer
  • GetLocalSettings() : BtApplication
  • GetLocalSettingsId() : BtLocalSettings
  • GetLocalState() : BtLocalSettings
  • GetLocalTimeZone() : DateTime
  • GetLocation() : MdhSmsReportReadIndArg
  • GetLocationBcdPlmn() : SimAuxHandler
  • GetLocationEstimate() : SaMolrResultArg, LocationResMsg, LcsMolrResultArg
  • GetLocationLac() : SimAuxHandler
  • GetLocationType() : LocationNotifInvokeMsg, LocationNotifInvokeArg
  • GetLocationUpdateStatus() : SimAuxHandler
  • GetLociData() : UsimCsLociReadIndArg, SimAccessor
  • GetLock() : Camera, AbstractLockableDevice
  • GetLockAction() : SimModifyLockIndArg
  • GetLockCommand() : SimModifyLockReqArg
  • GetLockResult() : SimLockStatusMsg
  • GetLockStates() : SimModifyLockReqArg, SimModifyLockIndArg, SimLockStatusIndArg
  • GetLockTable() : LockTableList
  • GetLockTableId() : LockTable
  • GetLockTableList() : LockTableList
  • GetLongFeature() : KeyMapping
  • GetLongKeyDelay() : KeyboardConfig
  • GetLowerCaseChar() : PagingMap, PagingMapEntry
  • GetLowerDestinationPort() : PdpContext::PacketFilter
  • GetLowerSourcePort() : PdpContext::PacketFilter
  • GetLsaIdentifier() : LsaIdentityMsg, MnInformationIndArg, StatusProvider, DataHandler
  • GetMainCause() : StartUp::Data
  • GetMainHandler() : MainHandlerAccess
  • GetMainProvider() : DataControl, DataHandler
  • GetMajorDeviceClass() : BtDeviceAndServiceClass
  • GetMappedColumnId() : SmsFolderProvider
  • GetMappedRow() : DistinctProvider, AbstractDelegationProvider, AppendProvider
  • GetMappingPolicy() : ValueMappingPropertyDescriptor< T_Container >
  • GetMarkDelete() : MetaData
  • GetMaskBuffer() : DisplayConfig
  • GetMasterMute() : AudioDeviceManager
  • GetMasterVolume() : AudioDeviceManager, AudioDeviceBase
  • GetMaxAcm() : SimAuxHandler, SimAccessor
  • GetMaxAdnCount() : SimPbBaseHandler
  • GetMaxAlphaLen() : MePhonebookDescriptor
  • GetMaxAlphaLength() : AtPbSelectCnfArg
  • GetMaxBdnCount() : SimPbBaseHandler
  • GetMaxBitrate() : VideoCaptureParameters
  • GetMaxCbmiCount() : SimAuxHandler
  • GetMaxCbmiRangeCount() : SimAuxHandler
  • GetMaxCcpCount() : SimAuxHandler
  • GetMaxCmiCount() : SimAuxHandler
  • GetMaxConcRefNo() : TpduHeaderInformation
  • GetMaxContentWidth() : AbstractMultiLineEditor
  • GetMaxCount() : SimPduHandler, SimPbBaseHandler
  • GetMaxCphsInfoNoCount() : SimPbBaseHandler
  • GetMaxCphsMBoxCount() : SimPbBaseHandler
  • GetMaxDataSize() : Tpdu, Cbs
  • GetMaxDuration() : VideoCaptureParameters
  • GetMaxEntitledPriority() : EmlppStatusMsg
  • GetMaxEntries() : SimPbEntryCont
  • GetMaxExtLangCount() : SimAuxHandler
  • GetMaxFdnCount() : SimPbBaseHandler
  • GetMaxFileSize() : RecordSettings
  • GetMaxFramerate() : VideoCaptureParameters
  • GetMaxImages() : BtBipGetImagesListIndArg
  • GetMaxImageSize() : BtBipImageDesc, BtBipImageFormat
  • GetMaximalFoundDevices() : BtDeviceSearchRequest
  • GetMaximumValue() : ValueIndicator
  • GetMaximumWidth() : TabButtonView
  • GetMaxInputLen() : GetInputReqArg
  • GetMaxItemCount() : TimeEditorDocument, TextEditorDocument, IpAddrEditorDocument, EditorDocument, DateEditorDocument, AbstractEditor, MultiMediaEditorDocument
  • GetMaxLangCount() : SimAuxHandler
  • GetMaxLndCount() : SimPbBaseHandler
  • GetMaxMbdnCount() : SimPbBaseHandler
  • GetMaxMbiCount() : SimAuxHandler
  • GetMaxMediaLength() : VideoCaptureParameters
  • GetMaxMessageId() : CbsLimitMsg, CbsLimitIndArg
  • GetMaxMimeTypeId() : MimeTypeTable, MimeTypeTable::Partition
  • GetMaxMsisdnCount() : SimPbBaseHandler
  • GetMaxNoOfDcsRanges() : Cbs::Filter
  • GetMaxNoOfMidRanges() : Cbs::Filter
  • GetMaxNumberOfElements() : EmzUtils::Queue< T >
  • GetMaxNumbersStored() : SimChvHandler
  • GetMaxPages() : Cbs
  • GetMaxPduSize() : SmsEditor
  • GetMaxPhonenos() : PhonebookApp, AdvPbApp
  • GetMaxPlmnCount() : SimAuxHandler
  • GetMaxRecordingDuration() : RecordSettings
  • GetMaxResolution() : VideoCaptureParameters
  • GetMaxSdnCount() : SimPbBaseHandler
  • GetMaxSmspCount() : SimSmsParamHandler
  • GetMaxTextLength() : PasswordEditor, MultiLineEditor, LineEditor, AbstractEditBox, AbstractEditBoxModel
  • GetMaxUserDataSize() : SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver
  • GetMaxUsers() : ServerConfig, Server
  • GetMaxValue() : PositionIndicator
  • GetMaxVisibleItems() : AbstractListBox, AbstractListBoxModel
  • GetMaxVisibleRows() : GridModel
  • GetMaxZoomLevel() : CamWin32
  • GetMbdnTagSize() : SimPbBaseHandler
  • GetMbi() : SimAccessor
  • GetMbiCount() : SimAccessor
  • GetMbiRecord() : SimAuxHandler
  • GetMbiRecordSize() : SimAuxHandler
  • GetMCbData() : EmServThreadMsg
  • GetMCbFnPtr() : EmServThreadMsg
  • GetMeanRate() : PdpContext::QualityOfService
  • GetMedia() : MediaObtainer
  • GetMediaAvailableStatus() : StorageDevice, FatStorageDeviceImp
  • GetMediaCodec() : MediaInfo::MediaTrackInfo
  • GetMediaFileFilter() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer
  • GetMediaMimeType() : DrmMessage
  • GetMediaName() : StorageDevice
  • GetMediaObject() : DrmMessage
  • GetMediaObjectLen() : DrmDcfParser
  • GetMediaObjectOffSet() : DrmDcfParser
  • GetMediaSink() : RecordSettings
  • GetMediaSinkType() : RecordSettings
  • GetMediaType() : StreamAudioReference
  • GetMember() : MptyCallHdl
  • GetMemberCount() : MptyCallHdl
  • GetMemMap() : BinData
  • GetMemorySize() : BtSddbServiceRecord, BtSddbServiceAttribute, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeOneByteDescriptionType, BtSddbDataElement
  • GetMemorySizeOfContainedDataElements() : BtSddbDeContainer
  • GetMemSize() : WString, String
  • GetMenu() : AtlItemMenuWindow, MenuPool, FeatureBroker
  • GetMenuAccessor() : Menu, SubMenuAction, AccessorActionExtension, AccessorAction
  • GetMenuDesc() : MenuDescObj
  • GetMenuId() : MenuIdObj, SoftkeyDesc
  • GetMenuID() : AtlItemMenuWindow
  • GetMenuPool() : AtlConfig
  • GetMenuProperties() : MenuDesc
  • GetMenuType() : AtlItemMenuWindow, MenuProperties
  • GetMePhoneBookType() : PbEntryRequestMsg, PbSizeRequestMsg, MePhonebookDescriptor, AtPbListCnfArg, AtPbSelectCnfArg, AtPbListReqArg, AtPbSelectReqArg
  • GetMergedFilter() : CbsFilterList
  • GetMergedKeyColumnId() : MergeProvider
  • GetMergedProvider() : MergeProvider
  • GetMergeRule() : MergeProvider
  • GetMessage() : SocketTestMessage, MessageReferrer
  • GetMessageClass() : DataCodingScheme, TpduHeaderInformation
  • GetMessageCode() : Cbs::SerialNumber
  • GetMessageID() : AudioUserDefinedMsg
  • GetMessageId() : MessageHook
  • GetMessageIdentifier() : CbsNewDataRejArg, Cbs
  • GetMessageNumber() : SmsContext, SmsCommand
  • GetMessageReference() : SmsCommand, SmsStatusReport, SmsSubmit
  • GetMessageRouter() : System
  • GetMessageText() : UtcStatusMessage, AsyncUnitTestMsg
  • GetMessageType() : UibApp, SmsContext, ProtocolIdentifier, TpduHeaderInformation
  • GetMessageTypeIndicator() : Tpdu
  • GetMetaData() : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, SoundRef, SoundBrowserServiceMsg, MediaRef, SkipSocketTestMsg, StopSocketTestMsg, ContinueSocketTestMsg, NextSocketTestMsg, StartSocketTestMsg, OnDataRcvdMsg, LcsAppResWinMsg, LcsAppRegisterForMtlrMsg, LcsAppTransferLocMsg, ImageRef, ImageBrowserServiceMsg, ImageBrowserRenameImageMsg, ImageBrowserDeleteImageMsg, MediaRef, SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, CameraMsgStopViewfinding, CameraMsgStartViewfinding, BtIndicatorMsg, PhonebookRenumberedMsg, ProviderUpdateMsg, SyncProgressMsg, SaveEntryInPhonebookMsg, OpenPbWinMsg, JumpToRowMsg, UtcStatusMessage, AsyncUnitTestMsg, DataConnProfileInfoMsg, DataConnInfoMsg, SocketControlMsg, ObexVCardMsg, ObexTransportMsg, ObexAddrMsg, ObexTriggerMsg, ObexMsg, ObexAppMsg, LoseFocusMsg, GetFocusMsg, ContextExecuteMsg, TimerTimeoutMsg, AlarmNotificationMsg, ShutdownRequestMsg, ContextWakeupMsg, ThreadletNotificationMsg, SharedTimerMsg, AppLoseFocusMsg, AppGetFocusMsg, ServiceThreadTerminateMsg, RtcAlarmReachedMsg, RtcDateChangedMsg, RtcTimeChangedMsg, ActionExecutedMsg, ItemPropertiesChangedMsg, ExternalTimeoutMsg, PenUpMsg, PenDownMsg, InputCharMsg, LockedKeyMsg, LockedKeyDownMsg, FlipMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, PowerWakeupMsg, LanguageChangedMsg, ThemeChangedMsg, AppUpdateDisplayMsg, AppCloseMsg, AppOpenMsg, PowerOffMsg, PowerOnMsg, NoMessage, ControlMsg, ContextMsg, Message, RedrawDisplayMsg, ItemRendererPropertiesChangedMsg, ImageEncodingProgressMsg, DeleteComponentMsg, ImageDrawingInterruptedMsg, Zi8EnteredUnknownWordMsg, Zi8AddWordMsg, Zi8NoWordFoundMsg, T9MatrixModeKeypressed, T9SymbolEntryRequestMsg, T9EnteredUnknownWordMsg, T9AddWordMsg, T9NoWordFoundMsg, AragonMsg, CloseWindowMsg, RefreshComponentMsg, ContextMenuClosedMsg, ViewfinderErrorMsg, ImageDecodingProgressMsg, InvalidateMsg, SelectionChangedMsg, FocusPreviousControlMsg, FocusNextControlMsg, ImageDecoder, Image, EncodingThreadlet, RtcInfoMsg, TransportNotificationMsg, LedNotificationMsg, DisplayInfoMsg, BatteryLoadLevelMsg, ChargerInfoMsg, BtObexClientRequestStateChangedMessage, BtObexServerRequestStateChangedMessage, BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtHsRequestStateChangedMessage, BtHsNotificationMessage, BtHfRequestStateChangedMessage, BtHfNotificationMessage, BtFaxRequestStateChangedMessage, BtFaxDisconnectMessage, BtFaxConnectMessage, BtFaxApplicationMessage, BtDunRequestStateChangedMessage, BtDunDisconnectMessage, BtDunConnectMessage, BtDunApplicationMessage, BtRequestStateChangedMessage, BtServiceMessage, BtSddbRequestStateChangedMessage, BtRequestOperationMessage, BtCloseMessage, BtOpenMessage, BtRequestMessage, BtCancelVerifyMessage, BtServiceVerifyResultMessage, BtServiceVerifyMessage, BtPaSupportedProfileMessage, BtHfSupportedProfileMessage, BtHsSupportedProfileMessage, BtQuerySupportedProfilesMessage, BtDeviceUntrustMessage, BtDeviceTrustMessage, BtDeviceUnpairMessage, BtDevicePairMessage, BtSetRemoteDeviceNameMessage, BtCancelSearchMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtDeviceSearchMessage, BtRespondAuthorizationMessage, BtSendPasskeyMessage, BtProfileActivationMessage, BtConnectabilityMessage, BtPairabilityMessage, BtDiscoverabilityMessage, BtLocalNameMessage, BtLocalSettingsMessage, BtStateChangedMessage, BtGapAndSdapRequestMessage, BtRemoteDevicePairMessage, BtGapAndSdapNotificationMessage, BtAuthorizationRequiredMessage, BtPasskeyRequiredMessage, BtGapAndSdapRemoteRequestMessage, BtGapAndSdapApplicationMessage, BtApplicationMessage, BtBppRequestStateChangedMessage, BtBipProgressMsg, BtAvrcpRequestStateChangedMessage, BtAvrcpOperationServiceMessage, BtAvrcpNotificationMessage, AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStreamingSyncMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRadioDeviceNotificationMsg, AudioPlayTimeMsg, AudioMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioFmRadioRdsAlternativeFrequenciesMsg, AudioFmRadioRdsInfoMsg, AudioFmRadioRdsRadioTextMsg, AudioFmRadioRdsStationNameMsg, AudioFmRadioRdsRawDataMsg, AudioFmRadioRssiMsg, AudioFmRadioSeekMsg, AudioAccessoryConnectedMsg, AudioRecordingStoppedMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg, AudioErrorMsg, AudioDeviceStatusMsg, DisabledFeatureTriggeredMsg, UpdateItemMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg, PropertyTriggerMsg, FeatureChangedMsg, UpdateContextItemMsg, CloseAllMsg, IndicatorBarUpdateMsg, UssdBeginMsg, UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, UusQueryRejectedMsg, UusStatusMsg, GetPasswordMsg, UssdRequestResentMsg, UssdDataMsg, UssdEndMsg, UssdNotifyMsg, UssdRequestMsg, SsErrorMsg, CallBarringPasswordChangedMsg, ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, CnapInfoReceivedMsg, EctAlertingMsg, EctActiveMsg, MultiPartyCallInvokedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, CugCallMsg, HlrDataCorruptedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallIsWaitingMsg, CallRetrievedMsg, CallHeldMsg, CallForwardingActiveMsg, ClirNotSurpressedMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, CtmInfoIndMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, PbAlphaTagRequestMsg, PbEntryRequestMsg, PbSizeRequestMsg, CbsLimitMsg, SmsMessageWaitingChangedMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceAvailableMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsPortDataRecvMsg, SmsNewSocketDataMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, RatChangeModeChangedMsg, EngineeringModeControlResponseMsg, BandStatusMsg, GsmBandStateMsg, RatStateMsg, NwDiscStartIndMsg, HomezoneMsg, BandSelectionMsg, EngineeringReportMsg, UssdAnswerMsg, CcbsResultMsg, CcbsStatusMsg, CcbsRecallMsg, SsInfoMsg, SsFacilityRejectedMsg, UssdResentMsg, UssdIndicationMsg, PasswordRejectedMsg, PasswordInquiryMsg, SsErrIndicationMsg, SsRejectedMsg, SsEndMsg, SsSuccessMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, MocSetupRejectIndMsg, CallControlInfoMsg, RedialStatusMsg, DiagnosticIndMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, RedialStoppedMsg, RedialStartedMsg, CallNotifyMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfBufferCleanedMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, PowerModeIndMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, OmMultiSlotIndMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, SimTkProfileSetRejMsg, SimTkProfileSetCnfMsg, SimTkProfileGetCnfMsg, SimTkRefreshStartMsg, TermRspCnfMsg, SimTkSetupEventMsg, SimTkLanguageNotificationMsg, MptyHoldRejectedMsg, MptyOnHoldMsg, CallHoldRejectedMsg, CallOnHoldMsg, SimCallSetupRejectedMsg, SimEndTransactionMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimMenuItemSelectionFailedMsg, SimSetupMenuMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetDoneMsg, SimResetConfirmationMsg, SimRefreshResetMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, RegistrationAllowedMsg, PlmnScanFinishedMsg, RegistrationChangeMsg, RegistrationSuccessMsg, AccessoryIndMsg, SignalQualityLevelMsg, SignalStrengthLevelMsg, MinuteTickMsg, AlarmMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, LsaIdentityMsg, TimeZoneMsg, NetworkInformationMsg, SimErrorMsg, CfuStatusMsg, MptyCallReleaseMsg, CallReleaseMsg, CallAcceptMsg, ExternalPdpContextInfoMsg, GprsAttachStatusMsg, PdpContextActivationStatusMsg, ChvChangedMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg, CallEventMsg, GprsStatusMsg, SimLockStatusMsg, SimStateChangedMsg, SsMessage, ToStackMsg, FromStackMsg, RfsStorageDeviceRegistrationStatusMsg, RfsMediaAvailableStatusMsg, FileChunkOperationProgressMsg, RegNotifyMsg, VrRecognitionFailedMsg, VrTrainingFailedMsg, VrPlaybackFinishedMsg, VrTrainingResultMsg, VrRecognitionStoppedMsg, VrTrainingAbortedMsg, VrRecognitionAbortedMsg, VrWarningMsg, VrErrorMsg, VrResultMsg, VrPromptMsg, DBItemChangedMsg, SvgHyperlinkSelectMsg, SvgStatusMsg, SvgDecodingFinishedMsg, HttpDisconnectMessage, HttpConnectMessage, HttpRequestMessage, HttpErrorMessage, HttpServiceMessage, FtpDisconnectMessage, FtpConnectMessage, FtpRequestMessage, FtpTransferMessage, FtpErrorMessage, FtpServiceMessage, MmCallReleaseMsg, MmCallAcceptMsg, MmAocChargingStatusMsg, MmCurrentCallMeterMsg, MmCurrentChargeDataMsg, MmCallNotifyMsg, MmCallInfoMsg, MmCallSetupProgressMsg, MmMocSetupAcceptMsg, MmCallDisconnectingMsg, MmCallStatusMsg, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg, CloseDataConnMsg, GltpConnStatusMsg, SendRequestMsg, SetupDataConnMsg, ProcessMolrMsg, ProviderChangedMsg, AbortResMsg, LocationErrMsg, LocationResMsg, LocationNotifInvokeMsg, AppActionExecutedMsg, DrmWapPushMsg, FatFsUsbMassStorageReleaseMsg, FatFsUsbMassStorageRequestMsg, UsimPbResetedMsg, UsimPbReadyMsg, DataControlPhonebookStateMsg, DataControlEndBootMsg, DataControlBootMsg, DataControlBootProgressMsg, DataControlStartBootMsg, DataControlModificationMsg
  • GetMetaDataCapacity() : Fota
  • GetMetaDataRecord() : SoundMetaData, MetaData, ImageMetaData, MetaData
  • GetMeteringMode() : Camera
  • GetMexeCertificateContent() : SimAccessor
  • GetMexeCertType() : SimMexeCertificate, MexeDescriptor
  • GetMexeRootPublicKeyProperty() : SimAccessor
  • GetMexeRootPublicKeyRecord() : SimAccessor
  • GetMexeSt() : SimAccessor
  • GetMHAudDevice() : EmServThreadMsg
  • GetMicrophoneGain() : BtHsService, BtHfService, BtAudioAccessoryService
  • GetMiddleGap() : RadioButtonView, CheckBoxView
  • GetMillisecond() : Time, DateTime
  • GetMimeContentType() : SvgMimeUtil
  • GetMimeStrByExt() : MimeTypeTable
  • GetMimeStrByFileType() : FfsMimeTypeMap
  • GetMimeStrByMimeType() : MimeTypeTable
  • GetMimeType() : MetaData, FilePackConnector, BtBipAttachmentDesc, BtBipAttachment, BtBipAttachmentFormat, Pathname, Path, Media
  • GetMimeTypeByExt() : MimeTypeTable
  • GetMimeTypeByFileType() : FfsMimeTypeMap
  • GetMimeTypeByMimeStr() : MimeTypeTable
  • GetMimeTypeSupportInfo() : MmfPlayer, MapiAudioPlayer
  • GetMinimalWidth() : MultiTapCaret, DefaultCaret, Caret
  • GetMinimumQualityOfService() : PdpContext
  • GetMinimumValue() : ValueIndicator
  • GetMinimumWidth() : TabButtonView
  • GetMinInputLen() : GetInputReqArg
  • GetMinMimeTypeId() : MimeTypeTable::Partition
  • GetMinorDeviceClass() : BtDeviceAndServiceClass
  • GetMinute() : TimeEditBox, TimeSpan, Time, DateTime
  • GetMinValue() : PositionIndicator
  • GetMIsAudioMuted() : EmServThreadMsg
  • GetMlcNumber() : LcsAppTransferLocMsg
  • GetMmfresult() : MediaManagerMsg
  • GetMmiName() : AbstractTransport
  • GetMocType() : MoCallAction
  • GetMode() : PredInputMapper, IconState, Caret, AudioContext, StreamAudioReference, PlmnListReqArg, PlmnInfoReqArg, AttachReqArg, AttachCnfArg, RegStateIndArg, Cbs::Filter, Zi8Wrapper, Zi8InputMapper, T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper, AbstractPredictiveInputBox
  • GetModel() : ImageView, Component
  • GetModificationDate() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FlashFileImp, FatFileImp
  • GetModificationState() : XCallInfoResponseParser
  • GetModificationTime() : File::Attributes
  • GetModificationType() : Provider
  • GetModified() : BtBipImage
  • GetModifiedFrom() : BtBipImageHdlDesc
  • GetModifiedRow() : Provider
  • GetModifiedTo() : BtBipImageHdlDesc
  • GetModifyDate() : BtBipAttachment
  • GetMolr() : LcsReqProcessor
  • GetMolrInfo() : ProcessMolrMsg
  • GetMolrParams() : MolrParams
  • GetMolrStatus() : LcsReqProcessor
  • GetMoMimeType() : DrmRightsObject
  • GetMonoStereoMode() : StreamAudioReference
  • GetMonth() : Date
  • GetMptyCallHdl() : MptyCallHdl
  • GetMptyChannelNo() : MptyCallHdl
  • GetMsgId() : SocketControlMsg, AppRoutingTableEntry
  • GetMsgType() : ObexTransportMsg, ObexMsg, ObexAppMsg, TransportNotificationMsg
  • GetMsgTypeCount() : SmsMsgTypeTextMap
  • GetMsgTypeName() : SmsMsgTypeTextMap
  • GetMsgTypeUsageCount() : SmsMsgTypeUsageTextMap
  • GetMsgTypeUsageName() : SmsMsgTypeUsageTextMap
  • GetMsgWaitingState() : SmsIndicationState
  • GetMsIsdnProvider() : PbDataHandler
  • GetMsisdnTagSize() : SimPbBaseHandler
  • GetMsmtRequest() : GltpAidDataRequests
  • GetMsrData() : MeasurementData, MeasurementDataArg
  • GetMStartStopAudio() : EmServThreadMsg
  • GetMtlr() : LcsReqProcessor
  • GetMultiModeSetResult() : MultiSlotDispatcher
  • GetMultiSlotMode() : OmMultiSlotReqArg
  • GetMute() : SpeechSimpleAudioDevice
  • GetMutex() : FfsTestDispWin, AudioDeviceBase
  • GetMyPbProvider() : ProvDetailListBoxWin, ProvColListBoxWin, PbDetails, PbBaseWin, PbAbstractWin, AdvPbWin
  • GetNai() : SimNextActionIdentifier
  • GetName() : UibMsgDisplayTest, UibAccessorTest, PhonebookApp, PbRecord, PbAdvAddEditEntry, SaveEntryInPhonebookMsg, SocketSubSystem, DataConnProfileManager::ProfileInfo, DataConnProfile, SubSystem, Thread, GenericWorkerTask, Application, IrdaObexSubSystem, Theme, RomFont, FontEntry, Font, AcacLanguage, FoggyTheme, DefaultTheme, CustomizableTheme, CTResourcePack, VoiceMemoAudioDevice, VirtualDisplay, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, MiscAudioDevice, KeyToneAudioDevice, GenericAudioDevice, GatiManager, DefaultDisplay, AmplifierAudioDevice, VideoCamera, StillCamera, VirtualDisplay, DefaultDisplay, BackLight, RealTimeClock, VirtualDisplay, DefaultDisplay, BackLight, VirtualDisplay, DefaultDisplay, BackLight, Led, Keyboard, Fota, Charger, VirtualDisplay, DefaultDisplay, AbstractDevice, Sound, PreparedSound, Melody, Audio, BtObexSubSystem, BtObexController, BtBppController, BtBipAttachmentDesc, BtBipAttachment, AudioPresetStore, AudioPreset, AudioAccessoryStore, AudioAccessoryDetails, StackControl, KeyMsgGenerator, StorageDevice, File, RegManager, UsbSubSystem, HttpApplication, SerialSocketSubSystem, DrmSubsystem, RamFileObj, SimSmsParameter, SimPbEntry, DataControl
  • GetNameForNumber() : AbstractSmsApp
  • GetNamePattern() : NamePatternFileFilter
  • GetNamePrefix() : VCard
  • GetNameProvider() : PbAdvDataHandler
  • GetNameRecNo() : PbNumberRecord
  • GetNameRowForRecNo() : PbNameProvider
  • GetNameSuffix() : VCard
  • GetNativeAddr() : IpAddr
  • GetNativeDirectoryPathname() : StorageDevice, File, RootStorageDeviceImp, RamStorageDeviceImp, RamFileObj, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetNativeEncoding() : BtBipImageProperties
  • GetNativeFilePathname() : StorageDevice, File, RootStorageDeviceImp, RamStorageDeviceImp, RamFileObj, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetNativeFormat() : BtBipImageProperties
  • GetNativeHeight() : BtBipImageProperties
  • GetNativeName() : AcacLanguage
  • GetNativeParams() : VrEngineParams, TelecaVrEngineParams, DummyVrEngineParams
  • GetNativePortNumber() : IpPortNo
  • GetNativeProperty() : StorageDevice, File, RootFileImp, FlashFileImp, FatFileImp
  • GetNativeSize() : BtBipImageProperties
  • GetNativeVolumeMax() : SpeechSimpleAudioDevice
  • GetNativeVolumeMin() : SpeechSimpleAudioDevice
  • GetNativeWidth() : BtBipImageProperties
  • GetNavigationGuidance() : Control
  • GetNetAdapter() : NetAdapterHandler
  • GetNetworkNameLong() : NetworkInformationMsg, MnInformationIndArg, StatusProvider, DataHandler
  • GetNetworkNameShort() : NetworkInformationMsg, MnInformationIndArg, StatusProvider, DataHandler
  • GetNetworkSearchMode() : MnNetworkSearchModeReqArg
  • GetNewChildRow() : AbstractDelegationProvider
  • GetNewchv() : ChvUnblockReqArg, ChvChangeReqArg
  • GetNewFilename() : RenameFileDialog
  • GetNewName() : ImageBrowserRenameImageMsg
  • GetNewPassword() : CallBarringPasswordChangedMsg, PasswordChangeSsAction
  • GetNewPassword2() : PasswordChangeSsAction
  • GetNewPath() : BrowserSaveWin, CameraCaptureWin
  • GetNewPin() : PinAction
  • GetNewPin2() : PinAction
  • GetNewPropertyValue() : PropertyEditor
  • GetNewRequestState() : BtRequestStateChangedMessage
  • GetNewSmsState() : SmsIndicationState
  • GetNewStatRepState() : SmsIndicationState
  • GetNewTipd() : UssdRequestResentMsg
  • GetNewWord() : Zi8AddWordMsg, T9AddWordMsg
  • GetNext() : VersionInfo, UserDispatcher, DrawableObject, Control, BtSddbDeContainer, BtMultiConnectionController::BtConnection, BtDeviceList::BtDeviceListNode, Linkable< T >, LinkableBase, MenuTableNode, ContextTableNode, DeletedNode
  • GetNextAttribute() : BtSddbServiceRecord
  • GetNextConnection() : BtMultiConnectionController
  • GetNextExtension() : MimeTypeTable
  • GetNextFrame() : EmsImage, NativeImage, Image, SvgImage, WbmpImage, PngImage, JpegImage, GifImage, BmpImage
  • GetNextFreeId() : FfsHandler
  • GetNextFreePosition() : SimPbBaseHandler
  • GetNextFreeTpduNo() : SimPduHandler
  • GetNextFreeUniqueId() : PbNextFreeIdRecord
  • GetNextHighDcs() : Cbs::Filter
  • GetNextHighMid() : Cbs::Filter
  • GetNextInformationElement() : UserDataHeader
  • GetNextItem() : DBService::DBItemIterator
  • GetNextItemMetaInfo() : DBService::DBItemIterator
  • GetNextKey() : AtKeyParser
  • GetNextLexToken() : LexAnalyzer
  • GetNextLocalId() : DrmRightsObjectStore
  • GetNextLockTable() : LockTable
  • GetNextLowDcs() : Cbs::Filter
  • GetNextLowMid() : Cbs::Filter
  • GetNextPageEntry() : HeapManager
  • GetNextPixelColor() : PngDecoder
  • GetNextResponse() : AtResponseIterator
  • GetNextToken() : InputParser
  • GetNoBytesReadable() : ObexBuffer::Reader
  • GetNoBytesWritable() : ObexBuffer::Writer
  • GetNodeBuffer() : RegMemoryPool
  • GetNodeBufferRawMemory() : RegNodeBuffer
  • GetNodeEntry() : NodeFileHandler
  • GetNodeIndex() : RegNodeBuffer
  • GetNodeRecord() : RegNodeBuffer
  • GetNodeRecordPtr() : RegNodeBuffer
  • GetNofFiles() : FfsHandler
  • GetNofFilesByType() : FfsHandler
  • GetNoId() : PbNumberRecord
  • GetNoImages() : SimIconDescription
  • GetNonDtmfPhoneNumber() : PhoneNumber
  • GetNoNvramSms() : MdhSmsTransmitStartIndArg
  • GetNoOfApplications() : AppContainerRoutingTableEntry
  • GetNoOfAuthorizationSets() : WapProfile
  • GetNoOfAuthorizationSetsSupported() : WapProfile
  • GetNoOfCells() : Grid, GridModel
  • GetNoOfColumns() : Grid, GridModel
  • GetNoOfDcsRanges() : Cbs::Filter
  • GetNoOfFittingChars() : AbstractEditBox
  • GetNoOfGroups() : CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspReadIndArg
  • GetNoOfIcons() : SimIconIdentifier
  • GetNoOfItems() : AbstractListBox, AbstractListBoxModel
  • GetNoOfLines() : AbstractEditBoxModel
  • GetNoOfMidRanges() : Cbs::Filter
  • GetNoOfNai() : SimNextActionIdentifier
  • GetNoOfNodes() : UriMappingTable
  • GetNoOfPages() : Cbs::Filter
  • GetNoOfPhysicalPortSets() : WapProfile
  • GetNoOfPhysicalPortSetsSupported() : WapProfile
  • GetNoOfPhysicalSets() : WapProfile
  • GetNoOfPhysicalSetsSupported() : WapProfile
  • GetNoOfPortSets() : WapProfile
  • GetNoOfPortSetsSupported() : WapProfile
  • GetNoOfRows() : Grid, GridModel
  • GetNoOfSaved() : MdhSmsWriteCnfArg
  • GetNoOfSoftkeys() : SoftkeyBar
  • GetNoOfSubunitInfoEntries() : BtAvrcpSubunitInfoParams
  • GetNoOfSubunits() : BtAvrcpRegisterParams
  • GetNoOfTpdus() : SmsFactory
  • GetNoOfVisibleLines() : AbstractEditBoxModel
  • GetNoSimSms() : MdhSmsTransmitStartIndArg
  • GetNote() : CalendarRecordsListBoxModel
  • GetNotification() : LedNotificationMsg, MdhSmsStatusIndArg
  • GetNotificationDescription() : MmCallNotifyMsg
  • GetNotificationType() : SimPbBaseHandler
  • GetNotifType() : LocationNotifInvokeMsg, LocationNotifInvokeArg
  • GetNotifySsArg() : SsNotifyIndArg
  • GetNoTypeAction() : AdvPbApp
  • GetNPI() : PhoneNumber
  • GetNrClutEntries() : SimImage
  • GetNrOfBits() : BitField< T >
  • GetNrOfOpenedTransports() : ObexServerDispatcher
  • GetNrOfParameters() : AtResponse
  • GetNsapi() : PsdDataConn, DataConn
  • GetNullStr() : WStrData, StrData
  • GetNumber() : KeyboardConfig, PagingMap, PagingMapEntry, DataItem, GenericFeatureData, Property
  • GetNumberingPlanIdentification() : TypeOfAddress
  • GetNumberOfAddresses() : VCard
  • GetNumberOfAttributes() : BtSddbServiceRecord
  • GetNumberOfAttributesRequested() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetNumberOfBytes() : BtObexClientNmaDataBufferIndication, BtObexServerNmaDataBufferIndication
  • GetNumberOfChannels() : CustomSmafPhraseAudioReference, AudioReference, MediaInfo::AudioTrackInfo
  • GetNumberOfDataElements() : BtSvrDataElement
  • GetNumberOfEntries() : DataPack, BasicPackConnector, AtResponseInfoTable, AtCommandInfoTable
  • GetNumberOfFiles() : FilePackConnector
  • GetNumberOfFonts() : FontPackConnector, FontManager
  • GetNumberOfFrequencies() : AudioFmRadioRdsAlternativeFrequenciesMsg
  • GetNumberOfInitialDecodeOperations() : ScicosMpeg4VideoDecoder, EmzH264Decoder, EmzMpeg4Decoder, EmzH264Decoder
  • GetNumberOfLanguages() : TextPackConnector
  • GetNumberOfLdbs() : T9PackConnector
  • GetNumberOfRingSignals() : BtHsService
  • GetNumberOfServiceAttributes() : BtSvrServiceRecord
  • GetNumberOfServiceRecords() : BtServiceVerifyResult
  • GetNumberOfServicesToVerify() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetNumberOfStrings() : AcacLanguage
  • GetNumberOfTones() : CustomToneAudioReference
  • GetNumberProvider() : PbAdvDataHandler
  • GetNumbersOfFrames() : AudioUtility
  • GetNumBoundaries() : MultipartParser
  • GetNumerator() : Fraction
  • GetNumGlyphs() : FontManager, FontEntry
  • GetNumOfDataStores() : SyncMLManager
  • GetNumOfNodeRecord() : RegNodeBuffer
  • GetNumOfValidDigits() : PhoneNumber
  • GetNvRamPduCount() : SimAccessor
  • GetOaPhoneNumber() : SmsNewMessageIndArg
  • GetObexHandle() : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexController::BtObexConnection
  • GetObexInstance() : BtObexTransport
  • GetObexResponseCode() : BtObexResponseCode, BtBipClientService
  • GetObexResponseCodeByte() : BtObexResponseCode
  • GetObexResult() : BtBipOpFinishedArg
  • GetObexTarget() : BtObexServiceTable::ServiceInfo
  • GetObject() : ObexMsg, ObjectObtainer
  • GetObjectHint() : ObjectObtainer
  • GetObjectId() : ObexAbstractTransport
  • GetObjectReplacementCharacter() : T9InputConfig
  • GetObjectTreeforURI() : GuidServiceTable
  • GetObtainedCount() : ObtainableObject
  • GetObtainedDocument() : EmsEditor
  • GetOffset() : ObexBuffer::Writer, ObexBuffer::Reader, AnimatedTextLine, TimeZone
  • GetOldchv() : ChvChangeReqArg
  • GetOldPassword() : PasswordChangeSsAction
  • GetOldPin() : PinAction
  • GetOldRequestState() : BtRequestStateChangedMessage
  • GetOldTipd() : UssdRequestResentMsg
  • GetOpCode() : BtAvrcpRawFrameParams
  • GetOpcode() : DBItemChangedMsg
  • GetOpenFilesCounter() : StorageDevice, RootStorageDeviceImp
  • GetOpenPbWinAction() : PhonebookApp
  • GetOperands() : BtAvrcpRawFrameParams
  • GetOperandsLength() : BtAvrcpRawFrameParams
  • GetOperation() : BtRequestOperationMessage, BtAvrcpPanelPassThroughParams
  • GetOperationCode() : StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, SsUssdReqArg, UssdAnswerIndArg, SsUssdIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg
  • GetOperationData() : BtAvrcpPanelPassThroughParams
  • GetOperationDataLength() : BtAvrcpPanelPassThroughParams
  • GetOperationId() : ObexTransportMsg, ObexMngr::SelectCommand, ObexAddrMsg, ObexMsg, StreamObexImpl
  • GetOperationService() : BtAvrcpControllerDeviceListItem
  • GetOperationState() : StreamingInfo
  • GetOperationType() : BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice, BtOperationBase
  • GetOplInfo() : SimAccessor
  • GetOplRecord() : SimAccessor
  • GetOpName() : SimCphsHandler
  • GetOpShortName() : SimCphsHandler
  • GetOption() : SysSocket
  • GetOptionKey() : KeyboardConfig
  • GetOptions() : SetupIdleModeTextReqArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • GetOpType() : DrmPermission
  • GetOrangeParam() : SimAccessor
  • GetOrangeWelcomeMsg() : SimCphsHandler
  • GetOrganizationalUnit() : VCard
  • GetOrganizationName() : VCard
  • GetOrientation() : PositionIndicator, IndicatorBar
  • GetOrig1TextInfoAlpha() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • GetOrig2TextInfoAlpha() : CallControlSetupIndArg
  • GetOriginalRow() : Provider::Modification
  • GetOriginatingAddress() : SmsDeliver
  • GetOriginatorApplicationPortAddress() : SmsContext
  • GetOriginType() : MessageTypeIndicator
  • GetOutboxProvider() : AbstractSmsApp
  • GetOutputFrame() : ScicosMpeg4VideoDecoder
  • GetOverallMemUsage() : HeapManager
  • GetOwner() : Panel
  • GetOwnerContext() : InetSocket
  • GetPackedTime() : ValidityPeriod
  • GetPacketFilter() : PsdDataConnProfile
  • GetPage() : TabControl, BtAvrcpSubunitInfoParams
  • GetPageFlag() : Zi8SelectionBox, Zi8AlphabetBox
  • GetPagingMap() : LocaleConfig, ResourceManager
  • GetPagingMapEntry() : PagingMap, AbstractEditBox
  • GetPagingTimeout() : EditConfig
  • GetPair() : SimpleMap< TKey, TValue >::Iterator
  • GetPairableMode() : BtLocalSettings
  • GetPairedDeviceCount() : BtAvrcpControllerApplicationWindow
  • GetPanel() : Application
  • GetPanelAlignment() : Desktop
  • GetPanelBounds() : Desktop
  • GetPanelPassthroughParams() : BtAvrcpNmaPanelPassThrough
  • GetPanelPassThroughParams() : BtAvrcpPanelPassThroughRequest
  • GetPanelView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme
  • GetPaProfileName() : BtPaSupportedProfileMessage
  • GetParam() : VideoChannel, EngineeringModeControlRequestArg, Accessory
  • GetParam1() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • GetParam2() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • GetParam3() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • GetParam4() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • GetParamBasicService() : CallWaitingDeactivatedMsg, CallWaitingActivatedMsg
  • GetParamConfPassword() : CallBarringPasswordChangedMsg
  • GetParameter1() : SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg
  • GetParameter2() : SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg
  • GetParameter3() : SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg
  • GetParameterAt() : AtResponse
  • GetParameterBasicService() : CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg
  • GetParameterIndicator() : SmsStatusReport
  • GetParameterPhonenumber() : CallForwardingRegisteredMsg, CallForwardingActivatedMsg
  • GetParameters() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AudioEncoder, AudioDecoder
  • GetParameterSsCode() : CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg
  • GetParameterTimeOut() : CallForwardingRegisteredMsg, CallForwardingActivatedMsg
  • GetParameterType() : AtResponseParameter
  • GetParamNewPassword() : CallBarringPasswordChangedMsg
  • GetParamOldPassword() : CallBarringPasswordChangedMsg
  • GetParams() : FtpRequest
  • GetParamSsCode() : CallBarringPasswordChangedMsg
  • GetParamValue() : BtJsr82Url
  • GetParent() : ProvDetailListBoxWin, PbProvListBox, Component, MenuAccessor
  • GetParentArea() : DrawableObject
  • GetParentCompoundItem() : EditorDocument
  • GetParentContainer() : ItemContainer, AbstractItemContainer, ProviderProxyContainer
  • GetParentNode() : RamFileNode
  • GetParentUri() : Uri
  • GetParentWindow() : Control
  • GetParity() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetParsePriority() : InputAction
  • GetParseStatus() : WbxmlParserRel
  • GetPaServiceName() : BtQuerySupportedProfilesRequest
  • GetPasswd() : DataConnProfile
  • GetPassword() : PdpContext::Authentication, BarringSsAction, SsGetPasswordRspArg, SsPasswordIndArg
  • GetPasswordMsg() : GetPasswordMsg
  • GetPath() : MetaData, StreamAudioReference, AudioPath, File, DirectoryIterator
  • GetPathControlMode() : AudioReference
  • GetPathname() : PathProfile, Path, File, DirectoryIterator, MCServiceInterfaceMsg, RamFileObj
  • GetPaths() : MediaPathnameVisitor
  • GetPause() : KeyMsgGenerator::Key
  • GetPayloadData() : PortHeaderInformation, SmsDeliver
  • GetPayloadOffset() : UserData, SmsDeliver
  • GetPayloadSize() : PortHeaderInformation, UserData, SmsDeliver, TpduHeaderInformation
  • GetPbAddType() : UsimPbUpdDataReqArg, UsimPbReadDataReqArg, UsimPbUpdDataResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg
  • GetPbAlphaTagRequestBehaviour() : AtcDispatcher
  • GetPbApplication() : PbToggleAction, PbAction, PbAbstractWin, AdvPbAction
  • GetPbChangedField() : UsimPbUpdReqArg
  • GetPbCntType() : PbCountReqArg, PbCountIndArg
  • GetPbDataControl() : PhonebookApp, AdvPbApp
  • GetPbDescriptor() : UsimPbSelectResArg
  • GetPbFillStatus() : UsimPbFillStatusResArg
  • GetPbLocation() : UsimPbSelectReqArg, UsimPbSelectResArg
  • GetPbProvider() : PhonebookApp, PbSynchronizer, PbDataHandler, PbAdvDataHandler, PbAbstractWin
  • GetPbRefRecord() : UsimPbReadAsyncIndArg, UsimPbReadResArg
  • GetPbRefType() : UsimPbUpdRefReqArg, UsimPbReadRefReqArg, UsimPbUpdRefResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • GetPbResult() : UsimPbReadyIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg
  • GetPbRwRecord() : UsimPbUpdReqArg, UsimPbReadReqArg, UsimPbReadAsyncIndArg, UsimPbReadResArg
  • GetPbSignalType() : UsimPbFillStatusResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg
  • GetPbTitle() : PbAbstractWin
  • GetPbtype() : PbEntryUpdReqArg, PbEntryReadReqArg, PbEntryReadIndArg
  • GetPduNode() : MdhSmsWriteReqArg
  • GetPeakRate() : PdpContext::QualityOfService
  • GetPeer() : SysSocket, InetSocket
  • GetPeerAddr() : HttpConnectMessage, FtpConnectMessage, FtpRequest
  • GetPeerDataSocketAddr() : FtpClient
  • GetPeerName() : SocketPeer
  • GetPeerPort() : SocketPeer
  • GetPeerSocket() : HttpConnectMessage, FtpConnectMessage
  • GetPen() : DeviceContext
  • GetPenColor() : DeviceContext
  • GetPenColorValue() : DeviceContext
  • GetPendingState() : SmsIndicationState
  • GetPenStyle() : DeviceContext
  • GetPeriodManual() : AbstractSmsApp
  • GetPermission() : DrmRightsObject
  • GetPermissionsCount() : DrmRightsObject
  • GetPersistentSize() : UibSettingsRecord, ToDoRecord, FmRadioStationsRecord, FmRadioSettingsRecord, SmsSettingsRecord, CalendarRecord, BtHfRecord, PbNumberRecord, PbRecord, PbNextFreeIdRecord, Record
  • GetPhonebook() : PhonebookApp, AdvPbApp
  • GetPhoneBookCountInfo() : SimAccessor
  • GetPhoneBookEntry() : SimAccessor
  • GetPhoneBookInfo() : SimAccessor
  • GetPhoneBookType() : SimPbBaseHandler
  • GetPhoneNo() : PbAdvAddEditEntry, SaveEntryInPhonebookMsg, RedialSetupMsg, MocSetupReqArg
  • GetPhoneNoType() : PbNumberRecord
  • GetPhoneNumber() : SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, PbNumberRecord, CsdDataConnProfile, DataItem, Property, PbAlphaTagRequestMsg, CcbsRecallMsg, MocSetupRejectIndMsg, PortHeaderInformation, ForwardingSsAction, CallSsAction, MoCallAction, CallHdl, DhChannelOpenReqArg, SiChannelOpenPromptReqArg, SimTkCallSetupIndArg, MocSetupRejIndArg, CallIndArg, AtPbListCnfArg, AtAlphaTagCnfArg, AtAlphaTagReqArg, XCallInfoResponseParser, MmCallDisconnectingMsg, MmCallHdl, TpduHeaderInformation, SimPbEntry
  • GetPhoneticCount() : ChineseT9Wrapper
  • GetPhoneticIndex() : ChineseT9Wrapper
  • GetPhoneticList() : ChineseT9Wrapper
  • GetPhonetics() : PredInputMapper, Zi8Wrapper, Zi8InputMapper, T9InputMapper, ChineseT9InputMapper
  • GetPhysicalDomain() : WapProfile
  • GetPhysicalPortNumber() : WapProfile
  • GetPhysicalPortService() : WapProfile
  • GetPhysicalProxyAddress() : WapProfile
  • GetPhysicalProxyId() : WapProfile
  • GetPid() : TpduHeaderInformation
  • GetPinCode() : BtSendPasskeyRequest
  • GetPitch() : AudioReference
  • GetPitchRange() : AudioReference
  • GetPixelColor() : DeviceContext, VirtualDisplay
  • GetPlainData() : EmsImage, IMelody
  • GetPlatformFeatureItem() : AtlConfig
  • GetPlayActive() : BtAvrcpControllerDeviceListItem
  • GetPlaybackSamples() : VrStoreTemplateReqArg
  • GetPlayer() : SvgHyperlinkSelectMsg, SvgStatusMsg, SvgDecodingFinishedMsg
  • GetPlayerInstance() : MediaBox
  • GetPlayerName() : SvgPlayer
  • GetPlayerVersion() : SvgPlayer
  • GetPlayPosition() : MmfPlayer
  • GetPlayTime() : AudioPlayTimeMsg
  • GetPlmn() : RegistrationChangeMsg, RegistrationSuccessMsg, UsimPlmnUpdReqArg, PlmnInfoReqArg, AttachReqArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListEntry
  • GetPlmnAct() : SimAuxHandler
  • GetPlmnCount() : SimAuxHandler
  • GetPlmnList() : UsimPlmnReadIndArg, SimAccessor
  • GetPlmnListCc() : StackWrapper
  • GetPlmnListCountryName() : StackWrapper
  • GetPlmnListLength() : StackWrapper
  • GetPlmnListMcc() : StackWrapper
  • GetPlmnListMnc() : StackWrapper
  • GetPlmnListName() : StackWrapper
  • GetPlmnListNetType() : StackWrapper
  • GetPlmnListShortName() : StackWrapper
  • GetPlmnScanList() : PlmnScanFinishedMsg, PlmnListCnfArg
  • GetPlmnwActFileLength() : SimAccessor
  • GetPlmnwActList() : SimAccessor
  • GetPluginName() : AtlApplicationPlugin
  • GetPnnInfo() : SimAccessor
  • GetPnnRecord() : SimAccessor
  • GetPnnRecordId() : OplEntry
  • GetPort() : DhChannelOpenReqArg, Server, HttpServer, FtpServer
  • GetPortNo() : InetSocketAddr, SmsSocket
  • GetPortNumber() : IpPortNo, WapProfile
  • GetPortService() : WapProfile
  • GetPos() : Rect, PaneObject, Component, MenuProperties, PlmnListEntry
  • GetPosIndicatorWidth() : GridView
  • GetPosition() : EditorItemNode, Indicator, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsTransmitIndArg, MediaRecorder, MediaPlayer
  • GetPositionHint() : TabButton
  • GetPositionIndicator() : GridModel, AbstractListBox
  • GetPositionIndicatorView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetPosnRequest() : GltpAidDataRequests
  • GetPostalCode() : VCard
  • GetPostOfficeAdress() : VCard
  • GetPosX() : PenUpMsg, PenDownMsg
  • GetPosY() : PenUpMsg, PenDownMsg
  • GetPowerMode() : DefaultDisplay, Display, DefaultDisplay, PowerModeIndMsg, OmPowerUpArg, OmControlIndArg, StatusProvider, DataHandler
  • GetPowerStatus() : MiscAudioDevice
  • GetPppFrame() : PdpContext
  • GetPrecedence() : PdpContext::QualityOfService
  • GetPredefinedAnimationStartPosition() : InformationElement
  • GetPredefinedAnimationType() : InformationElement
  • GetPredefinedSoundStartPosition() : InformationElement
  • GetPredefinedSoundType() : InformationElement
  • GetPredefinedType() : PredefinedEmsSound, PredefinedEmsImage
  • GetPredInputBox() : ToDoComposeWin, SmsComposeWin, AbstractSmsComposeWin, EmsComposeWin
  • GetPrefEncoding() : BtBipImagingCapabilities
  • GetPreferedRatMode() : PlmnHandler
  • GetPreferredFormat() : BtBipImagingCapabilities
  • GetPreferredStorageMedia() : SimPduHandler, SimAccessor, DataHandler
  • GetPreferredStorageType() : AbstractSmsApp
  • GetPrefExtLanguageArray() : SimAccessor
  • GetPrefExtLanguageFileLength() : SimAccessor
  • GetPrefLanguageArray() : SimAccessor
  • GetPrefLanguageFileLength() : SimAccessor
  • GetPrefMaxHeight() : BtBipImagingCapabilities
  • GetPrefMaxSize() : BtBipImagingCapabilities
  • GetPrefMaxWidth() : BtBipImagingCapabilities
  • GetPrefMimeType() : VideoCaptureParameters
  • GetPrefMinHeight() : BtBipImagingCapabilities
  • GetPrefMinWidth() : BtBipImagingCapabilities
  • GetPrefPlmnFileLength() : SimAccessor
  • GetPrefService() : PlmnHandler
  • GetPrefTransformation() : BtBipImagingCapabilities
  • GetPresentationInd() : PhoneNumber
  • GetPresentationIndicator() : CnapInfoReceivedMsg
  • GetPresetByID() : AudioPresetStore
  • GetPresetForName() : AudioPresetStore
  • GetPresetList() : AudioPresetStore
  • GetPresetName() : PresetAudioReference, AudioPresetStore
  • GetPressedIndex() : SoftkeyBar
  • GetPressedItem() : TRadioButtonList< Content >, RadioButtonList
  • GetPreview() : MultiTapCaret
  • GetPrevious() : Control, BtDeviceList::BtDeviceListNode, DeletedNode
  • GetPrimaryDnsServerAddress() : DataConnProfile, DataConn
  • GetPrimaryId() : PdpContext
  • GetPrimaryProfileId() : PsdDataConnProfile
  • GetPriority() : ToDoPriorityDialogWin, SubSystem, Thread, Application, AudioContext, BtConnectionlessController, BtConnectionBasedController, AudioReference, StackControl, EmlppAction, KeyMsgGenerator, RegManager, MediaRecorder, MediaPlayer, DrmSubsystem, DataControl
  • GetPriorityGroup() : AudioReference
  • GetProactiveCause() : SimTkRefreshNewRspArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, LaunchBrowserIndArg, SimTkRefreshQueryResArg, SetupIdleModeTextRspArg, PlayToneRspArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, TermRspCnfArg
  • GetProblemCode() : TaggedProblemCode
  • GetProblemTag() : TaggedProblemCode
  • GetProcessId() : SimTkInterfaceIndArg
  • GetProcessPtr() : StackMsgProcessor, ProcessNode
  • GetProcessSource() : GprsClassIndArg
  • GetProfile() : DataConnProvider, BtIndicatorMsg, DataConnInfoMsg, DataConnProfileManager, DataConn, BtObexService, BtHsService, BtHfService, BtFaxService, BtDunService, BtService, BtSddbService, BtCloseMessage, BtOpenMessage, BtAuthorizationRequiredMessage, BtBppService, BtAvrcpService, SimTkProfile
  • GetProfileCount() : DataConnLbModel
  • GetProfileId() : DataConnProvider, DataConnAccessor, DataConnProfileInfoMsg, WapProfile
  • GetProfileIdSet() : DataConnProfileManager
  • GetProfileInfo() : DataConnProfileManager
  • GetProfileInstance() : SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider
  • GetProfileManager() : DataConnProvider
  • GetProfileName() : DataConnProfileInfoMsg, WapProfile
  • GetProfileOffset() : FfsDataConnProfileStorage
  • GetProfileProvider() : AbstractSmsApp
  • GetProfileType() : DataConnTypeWin, DataConnProvider, DataConn
  • GetProgramIdentifier() : AudioFmRadioRdsInfoMsg
  • GetProgramType() : AudioFmRadioRdsInfoMsg
  • GetProgress() : PbSynchronizer, PbSimProvider, PbRecordHandler, SyncProgressMsg, ProgressBar, ImageEncodingProgressMsg, ImageDecodingProgressMsg, Provider, AbstractDelegationProvider, FileChunkOperationProgressMsg, JoinProvider, AppendProvider, SmsProvider, SmsClass0Provider, SimPduHandler, SimPbBaseHandler, PbBaseProvider, DataControlBootProgressMsg
  • GetProgressBarView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetProgressBox() : PhonebookApp
  • GetProgressInBytes() : ObexServer, ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexDataServer, ObexClient, BtBppClientService, BtBipServerService, BtBipClientService
  • GetProgressIndication() : MmCallSetupProgressMsg
  • GetProgressInPercent() : BtBppClientService
  • GetProgressTotalBytes() : BtBppClientService
  • GetPropCnt() : DataConnApp::DataConnDescription
  • GetProperties() : AbstractItemRenderer, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, CodecDevice
  • GetProperty() : CTResourcePack, IdentifierHandler, UsimFilePropertyIndArg, VrPropertyResultIndArg
  • GetPropertyEditorID() : PropertyItem
  • GetPropertyId() : ItemPropertiesChangedMsg, FeatureChangedMsg
  • GetPropertyItem() : PropertyEditor, PropertyTriggerMsg
  • GetPropertyRange() : CamWin32
  • GetPropertyValue() : GuiObjectFactory
  • GetProtector() : SmsDispatcher
  • GetProtocol() : ObexAbstractTransport, ObexMngr, ObexAbstractPort, IrdaObexTransport, BtObexTransport, PdpContext, UsbObexTransport, LcsProviderImplBase, ProviderChangedMsg
  • GetProtocolId() : ObexTriggerMsg, ObexChannel
  • GetProtocolIdentifier() : SmsContext, SmsNewMessageIndArg, SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver, MdhSmsNewMessageIndArg
  • GetProtocolNumberOrNextHeader() : PdpContext::PacketFilter
  • GetProvider() : UibListBoxModel, AbstractSmsViewerWin, DataConnApp::DataConnDescription, ProvListBoxWin, PbProvListBox, PbProvListBoxModel, ProviderUpdateMsg, Trap, ProviderListBoxModel, ProviderListener, MainProvider, ProviderPtr, DataItem, ProviderProxyItem, ProviderProxyContainer, ProviderChangedMsg, DataHandler
  • GetProviderData() : AbstractSmsApp
  • GetProviderEntry() : ProviderListBoxModel
  • GetProviderId() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsTemplateProvider, SmsSettingsProvider, SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider, CalendarProvider, BtHfProvider, BtDeviceListProvider, PbSimProvider, PbNumberProvider, PbNameProvider, PbNameNumberProvider, PbNameFilterProvider, PbNumberFilterProvider, GroupProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider, AppendProvider, LanguageProvider, StatusProvider, SstProvider, SmsUnsentProvider, SmsUnreadProvider, SmsSentProvider, SmsReadProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, SimTkMainMenuProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PlmnProvider, PbBaseProvider, DataControlBootProgressMsg, MbiProvider, LockProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CountryProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • GetProviderRow() : ProviderProxyItem
  • GetProvisionFileRef() : SimLaunchBrowserReqArg
  • GetProvRow() : PbProvListBoxModel, PbManualSynchronizer
  • GetProvText() : PbProvListBoxModel
  • GetProxyId() : WapProfile
  • GetProxyName() : WapProfile
  • GetProxyProviderId() : WapProfile
  • GetPsdError() : DataConnInfoMsg
  • GetPsLociData() : UsimPsLociReadIndArg
  • GetPsm() : L2CapSocketAddr
  • GetPtr() : ObexBuffer::Writer, ObexBuffer::Reader, FixedPtrArray< T >
  • GetPuct() : SimPuctUpdReqArg, SimPuctReadIndArg, SimAccessor
  • GetPuctData() : SimAuxHandler
  • GetPushButtonView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetQoS() : PdpQoSPeakRateTable, PdpQoSMeanRateTable, PdpQoSPrecedenceTable, PdpQoSDelayTable, PdpQoSReliabilityTable
  • GetQosDelay() : PsdDataConnProfile
  • GetQosMeanRate() : PsdDataConnProfile
  • GetQosPeakRate() : PsdDataConnProfile
  • GetQosPrecedence() : PsdDataConnProfile
  • GetQosReliability() : PsdDataConnProfile
  • GetQoSType() : PdpQoSPeakRateTable, PdpQoSMeanRateTable, PdpQoSPrecedenceTable, PdpQoSDelayTable, PdpQoSReliabilityTable
  • GetQualifier() : SimIconIdentifier
  • GetQuality() : SignalStrengthLevelIndArg, VrRecogResultIndArg, VrIntrmRecResultIndArg, VrResultMsg
  • GetQualityLevel() : JpegEncoder::EncodingParameters
  • GetQualityOfService() : PdpContext, PdpContext::ActivationStatus
  • GetQueryRemoteDeviceName() : BtDeviceSearchRequest
  • GetRadioAccessTechnology() : RatStateMsg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListEntry, StatusProvider, DataHandler
  • GetRadioButtonListView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetRadioButtonView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetRadioFreq() : FmRadioStationsRecord
  • GetRadioLastFreq() : FmRadioSettingsRecord
  • GetRadioLastVolume() : FmRadioSettingsRecord
  • GetRadioOn() : FmRadioApplication
  • GetRadioPriority() : PdpContext::ActivationStatus
  • GetRadioText() : AudioFmRadioRdsRadioTextMsg
  • GetRamFileObj() : RamFileNode
  • GetRasterOp() : DeviceContext
  • GetRat() : AttachReqArg
  • GetRatChangeMode() : RatChangeModeChangedMsg, OmRatChangeReqArg, OmRatChangeIndArg, StatusProvider
  • GetRate() : AudioReference
  • GetRateRange() : AudioReference
  • GetRawBCDBuffer() : PhoneNumber
  • GetRawBCDLength() : PhoneNumber
  • GetRawFrameParams() : BtAvrcpRawFrameRequest, BtAvrcpNmaRawFrame
  • GetRawMediaMimeType() : DrmMessage
  • GetRawMediaObject() : DrmMessage
  • GetRdnSelector() : EctActiveMsg
  • GetReadCount() : SimPduHandler
  • GetReader() : Stream
  • GetReadProvider() : AbstractSmsApp
  • GetReadType() : UsimFilePropertyReqArg, UsimPlmnReadReqArg, UsimUpdRejArg, UsimUpdCnfArg, UsimReadRecordRejArg, UsimReadRejArg, UsimPlmnReadIndArg
  • GetReadyTimer() : PdpContextManager::AttachStatus
  • GetReason() : SmsStatusReportTextMap, ShortMessageStatus
  • GetReceivedPackets() : UdpTestSocket, TcpTestSocket
  • GetRecipientAddress() : SmsStatusReport
  • GetRecipientPhoneNumber() : SmsNewStatusReportIndArg
  • GetRecNo() : SimCmiReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimRefreshIndArg, MdhSmsReportReadIndArg, SmsWStringCache, SmsWStringCache::Entry, SimPbEntry
  • GetRecno() : UsimLangUpdReqArg, UsimSmsParamUpdReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimSmsParamUpdIndArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, SimAcmReadIndArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, PbEntryReadIndArg, MdhSmsUpdStatusIndArg, IconDescReadReqArg
  • GetRecordData() : CalendarProvider
  • GetRecordedSize() : StreamAudioReference
  • GetRecordingDelay() : StreamAudioPlayer
  • GetRecordingReference() : StreamAudioPlayer
  • GetRecordLength() : SimFileInfoIndArg
  • GetRecordNumber() : PbEntryRequestMsg, AtPbListCnfArg, AtPbListReqArg
  • GetRecstatus() : MdhSmsUpdStatusReqArg
  • GetRect() : InvalidateMsg, WinRect
  • GetRecurrence() : CalendarRecord
  • GetRed() : ColorTable, Color
  • GetRedBitCount() : ColorSegmentation
  • GetRedKey() : KeyboardConfig
  • GetRefCount() : ProviderPtr, DrmRightsObject
  • GetReference() : AudioActiveReference
  • GetReferenceLocation() : GltpAssistanceData
  • GetReferenceNumber() : SmsSendDispatcher, SmsSendCnfArg, SmsNewStatusReportIndArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkSsIndArg, SimTkSmsPpIndArg, TpduHeaderInformation
  • GetReferenceTime() : GltpAssistanceData
  • GetRefNo() : MdhSmsConcRefNumIndArg
  • GetRefRecno() : UsimPbUpdRefReqArg, UsimPbReadRefReqArg, UsimPbUpdRefResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • GetRefreshDelay() : VideoChannel
  • GetRefreshIndicator() : SimTkRefreshQueryReqArg
  • GetRefreshType() : SimRefreshIndArg
  • GetRegion() : VCard
  • GetRegisteredBcdPlmn() : DataHandler
  • GetRegisteredDataStore() : SyncMLManager
  • GetRegisteredLac() : StatusProvider, DataHandler
  • GetRegisteredPlmn() : StatusProvider, DataHandler
  • GetRegisterParams() : BtAvrcpRegisterRequest
  • GetRejectCause() : RegistrationChangeMsg, PdpContextManager::AttachStatus, PdpContext::ActivationStatus, SsCauseIndArg, SsGetPasswordRejArg, SsFacilityRejArg, MocSetupRejArg
  • GetRejectDuplicates() : SmsContext
  • GetRelativeTime() : ValidityPeriod, CodedTimeStamp
  • GetReleaseComplete() : SsCcbsResultIndArg
  • GetReliability() : PdpContext::QualityOfService
  • GetRemainingDataLength() : DhChannelReceiveIndArg
  • GetRemainingSize() : UserData, UserDataHeader
  • GetRemoteAddr() : IrdaObexServerAddr, IrdaObexClientAddr, BtObexClientAddr
  • GetRemoteAddrPtr() : ObexClientDispatcher
  • GetRemoteDeviceInformation() : BtDevice
  • GetRemoteDeviceName() : BtSetRemoteDeviceNameRequest
  • GetRemoteRfComm() : BtObexClientAddr
  • GetRenderer() : ItemBox, ContextMenu, AbstractItemGrid, ItemLabel
  • GetRendererHint() : ItemRendererProperties
  • GetRendererProperties() : ItemContainer, AbstractItemContainer
  • GetRenderingView() : ImageListBoxModel
  • GetRepaintHint() : GridModel
  • GetRepaintRect() : Control
  • GetRepeatable() : AudioReference
  • GetRepeatCount() : Image, Image::MetaData, PreparedSound, AudioReference, MediaPlayer
  • GetReport() : UsimPbLocationIndArg, TestparamReportArg
  • GetReportArg() : EngineeringReportMsg
  • GetReqStackSize() : Threadlet
  • GetRequest() : BtObexClientService, SendRequestMsg, GltpPositionRequest, GltpMsmtRequest, GltpAidingRequest, GltpHelloRequest, GltpRequest
  • GetRequestBuffer() : StreamObexImpl
  • GetRequestedByteCount() : StreamingReadInfo
  • GetRequestedStackSize() : Thread, Application
  • GetRequestFlags() : ObexObject
  • GetRequestId() : BtRequestMessage, BtRequest
  • GetRequestMethodType() : HttpRequest
  • GetRequestParams() : HttpRequest
  • GetRequestReplyPath() : SmsContext
  • GetRequestState() : BtObexServerService, BtObexClientService, BtHsService, BtHfService, BtFaxService, BtDunService, BtService, BtSddbService, BtRequest, BtBppServerService, BtBppClientService, BtBipServerService, BtBipClientService, BtAvrcpRegistrationService, BtAvrcpOperationService
  • GetRequestStatusReport() : SmsContext
  • GetRequestTarget() : HttpRequest
  • GetRequestType() : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexSetPathRequest, BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtObexPutRequest, BtObexGetRequest, BtObexDisconnectRequest, BtObexConnectRequest, BtObexAbortRequest, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtRequestStateChangedMessage, BtSendPasskeyRequest, BtRespondAuthorizationRequest, BtRequest, BtQuerySupportedProfilesRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBipProgressMsg, BtBipOpFinishedArg, BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRegisterRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse, BtAvrcpDeRegisterRequest, BtAvrcpConnectResponse
  • GetReservedSpace() : FfsHandler
  • GetResolution() : ImageViewListBoxModel, Media
  • GetResourceNames() : SoundBrowserApp, ImageBrowserApp
  • GetResourcePack() : CustomizableTheme
  • GetResourcePackIfActive() : CustomizableTheme
  • GetResourceUri() : CTResourcePack
  • GetResponse() : BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse
  • GetResponseCode() : ObexObject, BtObexClientOperationEvent, BtObexClientOperationRequest
  • GetResponseHeaderList() : ObexDataServer
  • GetResponseString() : AtResponse
  • GetResponseType() : AtResponse
  • GetRest() : InputParser, LexAnalyzer
  • GetResult() : SmsResultTextMap, ObexAddrMsg, ObexMsg, BtObexClientNmaTransportDisconnect, BtObexClientNmaDataInidication, BtObexClientNmaDataBufferIndication, BtObexClientNmaHeaderIndication, BtObexClientNmaHeaderSent, BtObexServerNmaTransportDisconnect, BtObexServerNmaDataInidication, BtObexServerNmaDataBufferIndication, BtObexServerNmaHeaderIndication, BtObexServerNmaHeaderSent, BtObexServerNmaAbort, BtObexServerNmaPut, BtObexServerNmaGet, BtObexServerNmaSetPath, BtObexServerNmaDisconnect, BtObexServerNmaConnect, BtJsr82Url, BtHsNmaLowPowerModeNotPossible, BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHsNmaAudioConnectionLost, BtHsNmaTransferAudioToPhone, BtHsNmaTransferAudioToAccessory, BtHsNmaDisconnect, BtHsNmaConnect, BtHfNmaLowPowerModeNotPossible, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain, BtHfNmaAudioConnectionLost, BtHfNmaTransferAudioToPhone, BtHfNmaTransferAudioToAccessory, BtHfNmaDisconnect, BtHfNmaConnect, BtHfCmaPhoneNumberRequired, BtRequestMessage, BtOperationBase, BtEvent, BtApplicationMessage, BtBppClientService, BtBipClientService, SmsSendDispatcher, SsInterrogateIndArg, SmsSendRejArg, SmsSendCnfArg, ExtProactiveCmdIndArg, EngineeringModeControlResponseArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg
  • GetResultStatus() : SmsStatusReport
  • GetReturnCode() : AudioMsg
  • GetReusedExtendedObjectPosition() : InformationElement
  • GetReusedExtendedObjectReferenceNumber() : InformationElement
  • GetRfc822EmailHeaderLength() : InformationElement
  • GetRfComChannel() : BtObexServerService, BtObexRegisterServerRequest, BtObexRegisterServerEvent, BtBppServerService, BtBipServerService
  • GetRfCommChannel() : BtObexClientAddr
  • GetRfCommPortNumber() : BtObexServerAddr
  • GetRfComPort() : BtObexConnectRequest, BtObexClientService
  • GetRfu() : SimIconDescription
  • GetRgb() : ColorTable, Color
  • GetRi() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetRight() : Rect, WinRect
  • GetRightsIssuer() : DrmMessage
  • GetRightSize() : ControlFrameView
  • GetRightsObject() : DrmRightsObjectFile, DrmRightsObjectContainer, DrmRelParser
  • GetRightSoftkey() : Window
  • GetRingInterval() : BtHsService
  • GetRole() : BtAvrcpRegisterParams, BtAvrcpDeRegisterRequest
  • GetRoot() : MenuTable, ContextTable
  • GetRootDir() : ServerConfig
  • GetRootNode() : RamFileSystem
  • GetRow() : PbProvListBoxModel, PbDetailListBoxModel, Caret, Cell, Provider::Modification
  • GetRowCount() : GridLayout, AbstractGrid, RecordHandler
  • GetRowTable() : PbRecordProvider
  • GetRowTitleWidth() : GridView
  • GetRtcInfo() : RtcInfoMsg
  • GetRts() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetRunning() : FfsTestThreadlet, FfsTestThread
  • GetRunningAbortRequest() : BtObexController::BtObexConnection
  • GetRunningRequest() : BtMultiConnectionController::BtConnection
  • GetSampleDataLength() : VrStoreTemplateReqArg
  • GetSampleFreq() : MediaInfo::AudioTrackInfo
  • GetSampleRate() : StreamAudioReference
  • GetSavedText() : PbDetails, PbAdvDetails
  • GetSca() : SmsNewSocketDataMsg
  • GetScaledHeight() : Image
  • GetScaledWidth() : Image
  • GetScaleType() : DisplaySettings
  • GetScanlineAtomCount() : VirtualDisplay
  • GetScanlineDiff() : Image, GifImage, BmpImage
  • GetScanStatus() : StatusProvider, DataHandler
  • GetScNumber() : SmsControlIndArg
  • GetScreeningInd() : PhoneNumber
  • GetScrollBehavior() : GuiEngineConfig, AbstractGrid, AbstractListBox
  • GetScrollDelay() : ItemRendererProperties
  • GetScrollGap() : ItemRendererProperties
  • GetSd() : InetSocket
  • GetSddbCase() : BtObexServerAddr
  • GetSdnProvider() : PbDataHandler
  • GetSdnTagSize() : SimPbBaseHandler
  • GetSearchStopLevel() : RadioAudioDevice
  • GetSecLockStates() : SimChvHandler
  • GetSecond() : TimeEditBox, TimeSpan, Time, DateTime
  • GetSecondaryDnsServerAddress() : DataConnProfile, DataConn
  • GetSecondKeyColumnId() : JoinProvider
  • GetSecondProvider() : JoinProvider
  • GetSeconds() : ValidityPeriod
  • GetSection() : Desktop, IndicatorBar
  • GetSectionContainerBounds() : Desktop
  • GetSectorSize() : StorageDevice
  • GetSecureDateTime() : RealTimeClock
  • GetSecurity() : BtObexServerAddr, BtObexClientAddr
  • GetSecuritySettings() : BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtJsr82Url
  • GetSegmentAt() : Pathname
  • GetSegmentCount() : Pathname
  • GetSegmentName() : RamFileNode
  • GetSelectedCandidate() : Zi8Wrapper
  • GetSelectedCandidateLength() : Zi8Wrapper
  • GetSelectedCell() : Grid, GridModel
  • GetSelectedColumnId() : PbProvListBox, PbProvListBoxModel
  • GetSelectedDevice() : BtDeviceListWindow
  • GetSelectedDeviceState() : BtAvrcpControllerApplicationWindow
  • GetSelectedGroupIndex() : PbSelectGroup
  • GetSelectedIcon() : RadioButtonAction, CheckBoxAction, AbstractToggleAction
  • GetSelectedImage() : ImageViewListBoxModel, ImageListBoxModel
  • GetSelectedImageRef() : ImageBrowserWin
  • GetSelectedImageSize() : Camera
  • GetSelectedIndex() : ToDoListWin, PredInputMapper, ItemMenu::LevelInfo, AbstractGrid, MenuAccessor, AbstractListBox, AbstractListBoxModel, AtlItemGridWindow, Zi8Wrapper, Zi8SelectionBox, Zi8InputMapper, T9InputMapper, SelectionBox, ChineseT9InputMapper
  • GetSelectedIndexProperty() : AbstractGrid
  • GetSelectedItem() : ProvListBoxWin, PhonebookApp, PbAbstractWin, AbstractItemGrid, AtlItemGridWindow
  • GetSelectedLine() : SelectedLineRetriever, XCallInfoResponseParser
  • GetSelectedMediaRef() : BrowserView
  • GetSelectedMsg() : UibFolderWin
  • GetSelectedMuteChannel() : RadioAudioDevice
  • GetSelectedNoIndex() : PbDetailListBox, PbDetailListBoxModel
  • GetSelectedNoRow() : PbDetailListBox, PbDetailListBoxModel
  • GetSelectedNumber() : PbSelectNumberWin
  • GetSelectedNumberTypeIndex() : PbSelectNoType
  • GetSelectedPbRow() : PhonebookApp
  • GetSelectedProfileId() : DataConnWin, DataConnLbModel
  • GetSelectedProfileInfo() : DataConnLbModel
  • GetSelectedProvRow() : PbProvListBoxModel
  • GetSelectedRadioButtonAction() : RadioButtonGroup
  • GetSelectedRow() : ProvDetailListBoxWin, ProvListBoxWin, PhonebookApp, PbProvListBox, PbBaseWin, PbAdvDetails, PbAbstractWin, AdvPbWin, AtlItemListWindow
  • GetSelectedSms() : AbstractSmsViewerWin
  • GetSelectedSmsEmbItem() : SmsViewerWin, AbstractSmsViewerWin
  • GetSelectedSoundRef() : SoundBrowserWin
  • GetSelectedText() : PbDetailListBox
  • GetSelectedToggleAction() : ToggleActionGroup
  • GetSelectedType() : EmsInsertPrompt
  • GetSelectedUsimPb() : DataHandler
  • GetSelectedValue() : DataConnOptionWin
  • GetSelectedYPos() : PbDetailListBox
  • GetSelectGroupAction() : AdvPbApp
  • GetSelection() : PredInputMapper, AbstractEditor, Zi8InputMapper, T9InputMapper, ChineseT9InputMapper
  • GetSelectionHeight() : ItemRendererProperties, AbstractItemGrid, AbstractGrid
  • GetSelectionMode() : Grid, GridModel
  • GetSelectionStyle() : AbstractEditor
  • GetSelectKey() : KeyboardConfig
  • GetSelector() : SimAcmUpdReqArg, SimAcmReadReqArg, SimAcmUpdIndArg, SimAcmReadIndArg
  • GetSemaphore() : PdpContextManager
  • GetSempahore() : StateMachine
  • GetSendDataType() : DhChannelSendReqArg
  • GetSender() : SelectionChangedMsg
  • GetSenderID() : AudioUserDefinedMsg
  • GetSenderPhonenumber() : SmsPortDataRecvMsg, SmsNewSocketDataMsg
  • GetSenderPortNo() : SmsNewSocketDataMsg
  • GetSentCount() : SimPduHandler
  • GetSentProvider() : AbstractSmsApp
  • GetSeparator() : Pathname
  • GetSeptets() : DataCoding
  • GetSeqNr() : ObexOperationId
  • GetSequence() : BootDispatchingArg
  • GetSequenceFeature() : KeyMapping
  • GetSequenceId() : LedNotificationMsg
  • GetSerialIoSet() : SerialSocketData
  • GetSerialNumber() : CbsNewDataRejArg, Cbs
  • GetSerivceRecordHandle() : BtSddbRegisterServiceEvent
  • GetServedCallApp() : RedialSetupIndArg
  • GetServedCallApplication() : RedialSetupMsg
  • GetServerAddrTypeId() : ObexAbstractTransport
  • GetServerChannel() : RfcommSocketAddr
  • GetServerConfig() : Server
  • GetServerId() : ObexServerInfo, ObexMsg
  • GetServerSecurity() : BtObexServiceTable::ServiceInfo
  • GetService() : BtObexClientNotificationMessage, BtObexServerNotificationMessage, BtServiceRequest, BtServiceMessage, BtAvrcpOperationServiceMessage, BtAvrcpNotificationMessage, SmsSendReqArg, ServiceBroker
  • GetServiceAttributeAtIndex() : BtSvrServiceRecord
  • GetServiceAttributeById() : BtSvrServiceRecord
  • GetServiceCenter() : SendSmsMsg, AbstractSmsComposeWin
  • GetServiceCenterAddress() : SmsContext
  • GetServiceCentreAddress() : Tpdu, Sms
  • GetServiceCentreTimeStamp() : SmsStatusReport, SmsDeliver
  • GetServiceClass() : BtObexServiceTable::ServiceInfo, BtDeviceAndServiceClass
  • GetServiceGuid() : SyncMLManager
  • GetServiceInfoByTarget() : BtObexServiceTable
  • GetServiceInfoByType() : BtObexServiceTable
  • GetServiceInfoByUuid() : BtObexServiceTable
  • GetServiceName() : BtObexServiceTable::ServiceInfo, BtObexServerAddr
  • GetServiceRecordAtIndex() : BtServiceVerifyResult
  • GetServiceRecordHandle() : BtSddbService
  • GetServicesToVerify() : BtServiceVerifyRequest
  • GetServiceTable() : SimAccessor
  • GetServiceToVerify() : BtOperationSelectDeviceAndPerformServiceVerify
  • GetServiceType() : BtObexServiceTable::ServiceInfo
  • GetServiceValues() : SimAuxHandler
  • GetServiceVerifyResult() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • GetSessionId() : BtBipConnectIndArg
  • GetSessionStatusWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • GetSetting() : OptionalConfig, LocaleConfig, PsdSettingsTable, SerSettingsTable, CsdSettingsTable, DataConnCommonSettingsTable
  • GetSettingsCount() : LocaleConfig
  • GetSettingsProvider() : UibApp, AbstractSmsApp
  • GetSetupCallHdl() : CallHdl
  • GetSetupState() : XCallInfoResponseParser
  • GetSetWaitIndicatorArray() : MdhSmsSetWaitingReqArg
  • GetSharedDc() : System, DeviceManager
  • GetSharedImageBufferMax() : GuiEngineConfig
  • GetShortMessageFailureCause() : SmsSendDispatcher, SmsSendCnfArg
  • GetShortMessageStatus() : SmsNewStatusReportIndArg, TpduHeaderInformation
  • GetShowCount() : Zi8AlphabetBox
  • GetSiClientFlags() : BrowserRegisterReqArg
  • GetSignalId() : ProcessNode
  • GetSignalLevel() : AudioFmRadioRssiMsg
  • GetSignalName() : ProcessNode
  • GetSignalQualityLevel() : SignalQualityLevelMsg, StatusProvider, DataHandler
  • GetSignalQualityMax() : SignalQualityLevelMsg, SignalStrengthLevelIndArg, StatusProvider
  • GetSignalStrength() : BtRemoteDeviceMessage
  • GetSignalStrengthLevel() : SignalStrengthLevelMsg, StatusProvider, DataHandler
  • GetSignalStrengthMax() : SignalStrengthLevelMsg, SignalStrengthLevelIndArg, StatusProvider
  • GetSimAccessor() : DataControl, DataHandler
  • GetSimCallSetupOption() : CallSetupBySimtTkReqArg
  • GetSimChangedState() : SimAccessor
  • GetSimChvHandler() : DataHandler
  • GetSimClutEntry() : SimImage
  • GetSimCphsHandler() : DataHandler
  • GetSimData() : SimAccessor
  • GetSimErrorCode() : SimAuxHandler
  • GetSimFileId() : MexeDescriptor
  • GetSimFileProperty() : SimAccessor
  • GetSimIconDescription() : SimTkHandler, SimAccessor, DataHandler
  • GetSimImage() : SimTkHandler, SimAccessor, DataHandler
  • GetSimImageCodingScheme() : SimImage
  • GetSimImageDescriptor() : SimIconDescription
  • GetSimIndicator() : SimStateChangedMsg, SimAccessor
  • GetSimInfo() : SimInfoIndArg, SimAuxHandler, SimAccessor
  • GetSimLockStates() : SimAuxHandler
  • GetSimMexeCertificate() : SimAuxHandler, DataHandler
  • GetSimMexeCertificateCount() : SimAuxHandler, DataHandler
  • GetSimPduCount() : SimAccessor
  • GetSimPduHandler() : DataHandler
  • GetSimProvider() : PbSynchronizer
  • GetSimRecNo() : PbNumberRecord
  • GetSimResult() : DhChannelChangeStatusResArg, DhChannelDataAvailableResArg, SimBrowserTermResArg, XCallInfoResponseParser
  • GetSimServiceType() : SimTkSsIndArg
  • GetSimStoredTpduNum() : TpduHeaderInformation
  • GetSimTkProfile() : SimTkProfileGetCnfMsg, OmSetTermProfileReqArg, OmGetTermProfileCnfArg
  • GetSimTkProfileReq() : SimTkHandler
  • GetSimUpdateStatus() : BdnIndArg, FdnIndArg
  • GetSize() : MetaData, MediaRefContainer, SocketTestMessage, OnDataRcvdMsg, MetaData, MediaRefContainer, CallTypeTable, DataRateTable, PdpAuthTable, PdpQoSPeakRateTable, PdpQoSMeanRateTable, PdpQoSPrecedenceTable, PdpQoSDelayTable, PdpQoSReliabilityTable, ObexHeader, ObexBuffer, Rect, PositionIndicatorView, IconState, PaneObject, DataPack, Component, NonsharedBinDataDataSource, WinRect, IconValueIndicator, IconTextIndicator, CenteredTextIndicator, TextIndicator, IconIndicator, Indicator, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeUuid128, BtSddbDeSint128, BtSddbDeSint64, BtSddbDeUint128, BtSddbDeUint64, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, BtSddbDeNil, BtSddbDataElement, BtDeviceList, BtBipAttachmentDesc, BtBipAttachment, WString, Vector< T >, StringDataSink, String, SimpleMap< TKey, TValue >, LinkedListBase, IndexTable< T >, HeapDataSource, HeapDataSink, HashTable, DataSource, DataSink, BinDataDataSource, RtStreamingBuffer, TextIconPairArray, MenuTable, ContextTable, ValidityPeriod, UserData, UserDataHeader, MessageIdentifierContainer, InformationElement, FileDataSource, FileDataSink, File, File::Attributes, T9Pack, SendRequestMsg, GltpAssistanceData, GltpPositionRequest, GltpMsmtRequest, GltpAidingRequest, GltpHelloRequest, GltpRequest, RootFileImp, RamStorageMapper, RamFileObj, RamFileImp, FlashFileImp, FatFileImp
  • GetSizeOfDataPack() : BasicPackConnector
  • GetSizeOfLdb() : T9PackConnector
  • GetSizeOfRecord() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer
  • GetSkIcon() : SoftkeyDesc
  • GetSkText() : SoftkeyDesc
  • GetSleepDuration() : Cbs::Filter
  • GetSmallAnimationBuffer() : InformationElement
  • GetSmallAnimationLength() : InformationElement
  • GetSmallAnimationStartPosition() : InformationElement
  • GetSmallPictureBuffer() : InformationElement
  • GetSmallPictureLength() : InformationElement
  • GetSmallPictureStartPosition() : InformationElement
  • GetSmoothScrollInfo() : AbstractGrid, AbstractListBox
  • GetSmsApplication() : AbstractSmsViewerWin
  • GetSmsBasicProvider() : AbstractSmsApp
  • GetSmsClass0Provider() : AbstractSmsApp
  • GetSmsComposer() : SmsUtility, AbstractSmsUtilityProcessor, EmsApp
  • GetSmsDebugWString() : SimPduHandler
  • GetSmsDestinationPortNo() : PortHeaderInformation
  • GetSmsFactory() : AbstractSmsUtilityProcessor, EmsApp
  • GetSmsFilterType() : SmsUnsentProvider, SmsUnreadProvider, SmsSentProvider, SmsReadProvider, SmsProvider
  • GetSmsId() : MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSmsUpdStatusReqArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg
  • GetSmsInfoAlpha() : SimTkSmsPpIndArg
  • GetSmsInfoIcon() : SimTkSmsPpIndArg
  • GetSmsInformation() : SimPduHandler
  • GetSmsMoreMessageType() : SmsSetMoreMessageReqArg, SmsGetMoreMessageStatusIndArg
  • GetSmsOriginatorPortNo() : PortHeaderInformation
  • GetSmsParam() : SimAccessor
  • GetSmsParameter() : SimSmsParamHandler, SimSmsParameter
  • GetSmsParamFileSizes() : SimAccessor
  • GetSmsParamRecord() : UsimSmsParamUpdReqArg
  • GetSmspBuffer() : SimSmsParameter
  • GetSmsPortNo() : SmsPortDataRecvMsg, SmsNewSocketDataMsg, TpduHeaderInformation
  • GetSmsProfile() : AbstractSmsApp
  • GetSmsProvider() : AbstractSmsApp
  • GetSmsr() : SimAccessor
  • GetSmsrCount() : SimAccessor
  • GetSmsrData() : SimSmsrUpdReqArg, SimSmsrReadIndArg, MdhSmsReportReadIndArg
  • GetSmsReferenceNumber() : SmsContext
  • GetSmsrLocation() : SmsNewStatusReportIndArg, MdhNewStatusReportIndArg
  • GetSmsStatus() : SimRefreshIndArg
  • GetSmsStorageType() : TpduHeaderInformation
  • GetSmsTpdu() : SimPduHandler
  • GetSmsTpduPosition() : SimPduHandler
  • GetSmsViewer() : AbstractSmsUtilityProcessor, EmsApp
  • GetSmsWString() : SimPduHandler
  • GetSneRecordNo() : UsimPbRefRecord
  • GetSoBroadcastOption() : InetSocket
  • GetSockAddr() : IrSocketAddr, SocketAddr, L2CapSocketAddr, RfcommSocketAddr
  • GetSockAddrSize() : IrSocketAddr, SocketAddr, L2CapSocketAddr, RfcommSocketAddr
  • GetSocket() : SocketControlMsg, SmsSocketListener, MmCallInfo, MmCallHdl, MmCallHandler
  • GetSocketAddr() : HttpServiceMessage, FtpServiceMessage
  • GetSocketData() : SocketControlMsg, DataConn
  • GetSocketEventListener() : Socket
  • GetSoDebugOption() : InetSocket
  • GetSoDontRouteOption() : InetSocket
  • GetSoftkey() : KeyboardConfig, Window
  • GetSoftkeyBarHeight() : WindowFrameView
  • GetSoftkeyBarView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetSoftkeyCount() : KeyboardConfig, SoftkeyBar
  • GetSoftkeyDesc() : ContextDescription
  • GetSoftkeyFeatureItem() : SoftkeyDesc
  • GetSoKeepAliveOption() : InetSocket
  • GetSoLingerOption() : InetSocket
  • GetSoRcvBufOption() : InetSocket
  • GetSoReuseAddrOption() : InetSocket
  • GetSortByLatestFirst() : BtBipGetImagesListIndArg
  • GetSortColid() : UibApp
  • GetSortedColumnId() : Provider, AbstractDelegationProvider, AppendProvider, PbBaseProvider
  • GetSortedFolderProvider() : UibApp
  • GetSortedNumberProvider() : PbDataHandler
  • GetSortingColumnId() : SmsSettingsRecord
  • GetSortKey() : UibSettingsRecord
  • GetSortMode() : ChineseQuickSortProvider
  • GetSoSndBufOption() : InetSocket
  • GetSoTypeOption() : InetSocket
  • GetSound() : SoundItem, SoundObtainer
  • GetSoundBuffer() : SoundRef
  • GetSoundObtainer() : SoundItem
  • GetSource() : StreamAudioPlayer, SpeechSimpleAudioDevice, RadioAudioDevice, MmfPlayer, AudioVibratorDevice, MapiAudioPlayer
  • GetSourceAddressAndSubnetMask() : PdpContext::PacketFilter
  • GetSourceString() : InputAction
  • GetSpaceInfo() : EmsCreator
  • GetSpaceKeyCode() : T9InputMapper
  • GetSpaceSize() : RamFileSystem
  • GetSpdiData() : SimAccessor
  • GetSpdiInfo() : SimAccessor
  • GetSpeakerGain() : BtHsService, BtHfService, BtAudioAccessoryService
  • GetSpecialSmsMessageCount() : InformationElement
  • GetSpecialSmsMessageIndicationType() : InformationElement
  • GetSpecialSmsMessageType() : InformationElement
  • GetSpeed() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetSpn() : SimAccessor
  • GetSpnData() : SimAuxHandler
  • GetSpnStruct() : SimSpnReadIndArg
  • GetSrPos() : MdhNewStatusReportIndArg
  • GetSrStatus() : MdhNewStatusReportIndArg
  • GetSsCode() : UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, UusStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallForwardingActiveMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, SsRequestRejectedMsg, SsRequestAcceptedMsg, SsRequestSentMsg, InputParser, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, ColrAction, ColpAction, CnapAction, ClipAction, NumberIdentificationAction, CallHdl
  • GetSSCodeString() : InputParser
  • GetSsControlSeq() : SsRequestAcceptedMsg, SsRequestSentMsg
  • GetSsData() : SsDataIndArg
  • GetSsErrorCode() : SsErrIndArg
  • GetSsInfoAlpha() : SimTkSsIndArg
  • GetSsInfoIcon() : SimTkSsIndArg
  • GetSsOpeartionCode() : UssdAnswerMsg
  • GetSsOperationCode() : SsNotifyIndArg
  • GetSsProcedure() : InputParser, WaitSsAction, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, NumberIdentificationAction, ClirAction
  • GetSSProcedureString() : InputParser
  • GetSsSequence() : SsInfoMsg, SsFacilityIndArg
  • GetSsStatus() : ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallForwardingStatusMsg, CallBarredMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg
  • GetSst() : SimSstReadIndArg
  • GetSstCount() : SimAuxHandler
  • GetStackState() : BtStateChangedMessage
  • GetStartAddress() : UserData, UserDataHeader
  • GetStartDate() : DrmAsset
  • GetStartDelay() : ItemRendererProperties
  • GetStartFrame() : MP3AudioReference
  • GetStartIndex() : EditorLine, TextListLine, CompoundItemReferrer
  • GetStartpage() : WapProfile
  • GetStartpagePassword() : WapProfile
  • GetStartpageUsername() : WapProfile
  • GetStartPos() : SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg
  • GetStartPosition() : AudioReference
  • GetStartRecno() : UsimPbUpdReqArg
  • GetStartTime() : MptyCallHdl, CallHdlBase, CallHdl, MmCallHdl
  • GetStartupData() : StartUp
  • GetState() : ProviderUpdateMsg, DataConn, Control::NavigationGuidance, Camera, RadioButtonModel, BtHsService, BtHfService, BtAvrcpPanelPassThroughParams, PdpContextManager, PdpContextManager::AttachStatus, PdpContext, PdpContext::ActivationStatus, FtpClient, MmCallStatusMsg, MediaRecorder, MediaPlayer
  • GetStateMap() : StateMachine
  • GetStaticProperties() : DBService
  • GetStationInfo() : RadioAudioDevice
  • GetStationName() : AudioFmRadioRdsStationNameMsg
  • GetStats() : HeapVector::VarPage, HeapVector::BlockPage
  • GetStatus() : SmsStatusReportTextMap, BtDeviceListProvider, PbSortedProvider, PbSimProvider, PbNameFilterProvider, PbNumberFilterProvider, BackLight, Charger, Provider, SettingsProvider, AocChargingStatusMsg, RegistrationChangeMsg, ChvChangedMsg, ExtPsdContextListener_SioGlueWrapper, Tpdu, SimInitIndArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, ShortMessageStatus, DetachCnfArg, NRegStateIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, ImeiReadIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsRefreshIndArg, AocIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, AtAccessoryRegisterCnfArg, AtGenericCmdIndArg, AtPbListCnfArg, AtPbSelectCnfArg, SvgStatusMsg, SioGlueWrapper, MeasurementData, GltpConnStatusMsg, SmsClass0Provider, TpduHeaderInformation, PlmnProvider, CountryProvider, CmiProvider, ChvProvider
  • GetStatusCount() : SmsConcatStatusTextMap, SmsStatusTextMap
  • GetStatusInfo() : PredInputMapper, Zi8InputMapper, T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper
  • GetStatusLine() : HttpResponse
  • GetStatusName() : SmsConcatStatusTextMap, SmsStatusTextMap
  • GetStatusReportProvider() : AbstractSmsApp
  • GetStatusString() : CallHdlBase
  • GetStep() : AnimatedTextLine, IconValueIndicator, ValueIndicator
  • GetStereoMode() : RadioAudioDevice
  • GetStkCallSetupNo() : CallSetupBySimtTkReqArg
  • GetStopBits() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • GetStopCause() : AudioStoppedMsg
  • GetStorage() : NvRamStorage
  • GetStorageDevice() : StorageDeviceIterator, RootFileSystem, File
  • GetStorageDeviceCount() : RootFileSystem
  • GetStorageDeviceId() : StorageDeviceIterator, RfsStorageDeviceRegistrationStatusMsg, RfsMediaAvailableStatusMsg, PathProfile, Path, File, RootFileImp, RamFileImp, FlashFileImp, FatFsUsbMassStorageReleaseMsg, FatFsUsbMassStorageRequestMsg, FatFileImp
  • GetStorageDeviceIterator() : RootFileSystem
  • GetStorageLocation() : SmsSettingsRecord
  • GetStorageMediaPrimitive() : SimPduHandler
  • GetStoragePosition() : SmsNewStatusReportIndArg, SmsNewMessageIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsRefreshIndArg
  • GetStorageType() : SmsNewStatusReportIndArg, SmsNewMessageIndArg, MdhSmsNewMessageIndArg
  • GetStorageTypeCount() : SmsStorageTypeTextMap
  • GetStorageTypeName() : SmsStorageTypeTextMap
  • GetStorMedia() : MdhSetStorageReqArg
  • GetStreamObexImpl() : StreamObexTransport
  • GetStreamSize() : Tlv
  • GetStreet() : VCard
  • GetString() : LanguageManager, StringDataSink, PhoneNumber, DataItem, Property
  • GetStringCount() : LocaleConfig
  • GetStringPayload() : RegNodeBuffer
  • GetStringValue() : AtResponseParameter
  • GetStrippedFileName() : Pathname
  • GetStroke() : Zi8InputConfig, T9InputConfig
  • GetStrokeBuffer() : ChineseT9Wrapper
  • GetStrokes() : PredInputMapper, Zi8Wrapper, Zi8InputMapper, T9InputMapper, ChineseT9InputMapper
  • GetStyle() : Pen, Brush
  • GetStyleSheet() : HttpClient
  • GetSubAddr() : DhChannelOpenReqArg, SiChannelOpenPromptReqArg
  • GetSubAddress() : EctActiveMsg, SimTkCallSetupIndArg
  • GetSubDirectoryNode() : RamFileNode
  • GetSubState() : BtBppClientService
  • GetSubstitutedText() : SubstitutedText
  • GetSubSystemName() : VersionInfo
  • GetSubunitId() : BtAvrcpRawFrameParams
  • GetSubunitInfo() : BtAvrcpOperationService
  • GetSubunitInfoEntries() : BtAvrcpSubunitInfoParams
  • GetSubunitInfoParams() : BtAvrcpSubunitInfoRequest
  • GetSubunitInfos() : BtAvrcpRegisterParams
  • GetSubunitType() : BtAvrcpRawFrameParams
  • GetSuccess() : SoundBrowserWin, RenameFileDialog, BrowserSaveWin, ImageBrowserWin, RenameFileDialog, BrowserSaveWin
  • GetSuccessfullIterations() : SocketTestApp
  • GetSupportedAttachmentFormatList() : BtBipImagingCapabilities
  • GetSupportedBandList() : BandStatusMsg, OmBandStatusCnfArg
  • GetSupportedCategories() : BtAvrcpRegisterParams
  • GetSupportedDecoderCodecsCount() : MediaFrameworkCaps
  • GetSupportedEncoderCodecsCount() : MediaFrameworkCaps
  • GetSupportedFeatures() : BtHfService, BtQuerySupportedProfilesRequest
  • GetSupportedFrameRates() : CamWin32, VideoCamera
  • GetSupportedImageFormatList() : BtBipImagingCapabilities
  • GetSupportedImageSizes() : CamWin32, VideoCamera, StillCamera, Camera
  • GetSupportedSensorImageSizes() : CamWin32
  • GetSymbol() : T9InputConfig
  • GetSymbolCandidates() : Zi8InputConfig
  • GetSymbolCandidatesLength() : Zi8InputConfig
  • GetSymbolPages() : T9InputConfig
  • GetSymbolRows() : T9InputConfig
  • GetSynchronizer() : PhonebookApp, AdvPbApp
  • GetSysErr() : SysSocket
  • GetSysError() : SysSocket
  • GetSystemColor() : Theme, TestTheme, FoggyTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetSystemColorTable() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, DefaultTheme
  • GetSystemFontId() : TestTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetSystemSemaphore() : System
  • GetT3310Expiries() : PdpContextManager::AttachStatus
  • GetT3380Expiries() : PdpContext::ActivationStatus
  • GetT9BufferSize() : T9InputConfig
  • GetT9UdbSize() : T9InputConfig
  • GetT9Wrapper() : T9InputMapper, EnglishT9InputMapper, ChineseT9InputMapper
  • GetTabButtonView() : Theme, FoggyTheme, DefaultTheme
  • GetTabControlView() : Theme, FoggyTheme, DefaultTheme
  • GetTabCount() : TabControl
  • GetTable() : UriMappingTable, NotificationTable
  • GetTag() : Tlv
  • GetTagAsByte() : TaggedProblemCode
  • GetTaggedProblemCode() : NetworkSsRejectedMsg, SsRejReqArg, SsRejArg
  • GetTagSize() : SimPbBaseHandler, PbBaseProvider
  • GetTarget() : ObexServer
  • GetTargetDevice() : BtHfProfileWindow, BtAvrcpControllerDeviceListItem, BtObexConnectRequest, BtService, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest
  • GetTcpMaxSetOption() : TcpSocketBase
  • GetTcpNoDelayOption() : TcpSocketBase
  • GetTelematicDevice() : ProtocolIdentifier
  • GetTelNumber() : VCard
  • GetTelNumberCount() : VCard
  • GetTelNumberType() : VCard
  • GetTemplateCount() : SmsTemplateTextMap
  • GetTemplateData() : VrG2AResultIndArg, VrStoreTemplateReqArg
  • GetTemplateDataLength() : VrG2AResultIndArg, VrStoreTemplateReqArg
  • GetTemplateId() : VrRecogResultIndArg, VrIntrmRecResultIndArg, VrLoadTemplateReqArg, VrPlaybackFinishedMsg, VrTrainingResultMsg, VrResultMsg
  • GetTemplateProvider() : AbstractSmsApp
  • GetTemplateText() : SmsTemplateTextMap
  • GetTemplateTitle() : SmsTemplateTextMap
  • GetTempo() : AudioReference
  • GetTemporaryLocalTimeZone() : DateTime
  • GetTemporaryProfileIdSet() : DataConnProfileManager
  • GetTermCause() : BrowserTermEventArg
  • GetTerminal() : SerialTerminalSocket, SerialTerminalArg
  • GetTests() : SocketTestApp
  • GetText() : SmsServiceMsg, TextPackConnector, TextEditorDocument, TextCompoundItem, TabControl, PasswordEditor, MultiLineEditor, LineEditor, Item, Alert, AcacLanguage, AbstractTextObject, AbstractButton, TextList, TextListModel, RadioButtonItem, IconTextIndicator, TextIndicator, CheckBoxItem, AbstractEditBox, AbstractEditBoxModel, ValueMappingPropertyDescriptor< T_Container >, TextIconPairArray::TextIconPair, SubstitutedText, PropertyDescriptor, ListPropertyDescriptor, ProviderProxyItem, FeatureItem, EnumTextMap, UusRegisteredMsg, UusNotificationMsg, HomezoneMsg, SsUus1ReqArg, SsUus1IndArg, SmsStatusReport, SmsSubmit, SmsDeliver, GetInkeyRspArg, GetInputRspArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimTextString, SimItemIdentifier, SimAlphaIdentifier, HomezoneIndArg, Cbs, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, ValueTextMap, T9PinyinBox, StrokeBox, SelectionBox, SmsWStringCache::Entry
  • GetTextAlign() : TextFormat, DeviceContext
  • GetTextAlignment() : Locale
  • GetTextAttr() : TextFormat, TextCompoundItem, DeviceContext, RichTextCompoundItem, MultiMediaEditor
  • GetTextColor() : ItemRendererProperties
  • GetTextColumnId() : ProviderProxyContainer
  • GetTextCompression() : DataCodingScheme
  • GetTextCount() : ValueMappingPropertyDescriptor< T_Container >
  • GetTextData() : UserData
  • GetTextDataLength() : UserData
  • GetTextFormat() : ItemRendererProperties, DeviceContext, Alert, AbstractTextObject
  • GetTextFormattingBackgroundColour() : InformationElement
  • GetTextFormattingColour() : InformationElement
  • GetTextFormattingElement() : EditorItemNode
  • GetTextFormattingFontSize() : InformationElement
  • GetTextFormattingForegroundColour() : InformationElement
  • GetTextFormattingLength() : InformationElement
  • GetTextFormattingMode() : InformationElement
  • GetTextFormattingStartPosition() : InformationElement
  • GetTextFormattingTextAlignment() : InformationElement
  • GetTextForMsgType() : UibPerformanceTest
  • GetTextGap() : AnimatedTextLine
  • GetTextInfoAlpha() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • GetTextLength() : AbstractEditBoxModel, SimPbEntryCont
  • GetTextList() : UusStatusMsg, SsUus1QueryIndArg
  • GetTextListView() : TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetTextRenderer() : GuiEngineConfig
  • GetTextSize() : DeviceContext
  • GetTextString() : SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, SimLaunchBrowserPromptReqArg, SetupIdleModeTextReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • GetTextWidth() : ThaiTextRenderer, SimpleTextRenderer, Font, ArabicTextRenderer, AbstractTextRenderer
  • GetThaiFontHints() : FontConfig
  • GetTheme() : ThemeConfig, System
  • GetThemeCount() : ThemeConfig
  • GetThemeId() : System
  • GetThisCallCcm() : CurrentCallMeterMsg, ChargeUnitsIndArg
  • GetThisCallCharge() : CurrentChargeDataMsg, ChargeIndArg
  • GetThousandSeparator() : Locale
  • GetThreadData() : Thread
  • GetThreadId() : Thread
  • GetThreadlet() : FfsTestDispWin, ThreadletNotificationMsg
  • GetThresholdPercentage() : StartSignalStrengthListeningArg
  • GetTicks() : Os, SvgDecodingFinishedMsg
  • GetTid() : SimSetupMenuMsg, SmsSendRejArg, SmsSendCnfArg, SimTkRefreshNewRspArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkRefreshNewReqArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg
  • GetTime() : CalendarRecord, TimeEditorDocument, TimeEditor, TimeCompoundItem, TimeEditBox, DateTime, DataItem, Property
  • GetTimeFormat() : Locale, FunctionalityIndicator
  • GetTimeout() : Timer, SystemTimer, AudioReference
  • GetTimePosition() : SvgPlayer
  • GetTimer() : TimerTimeoutMsg, ExternalTimeoutMsg, AbstractGrid::SmoothScrollInfo, AbstractListBox::SmoothScrollInfo, SmsConfigIndArg
  • GetTimes() : PackedTimePeriod
  • GetTimeSpan() : PackedTimePeriod
  • GetTimeStamp() : HostDebugTimeStamp, TimeFeatureObject, MdhSmsTransmitIndArg, MdhSmsRefreshIndArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, DBItemChangedMsg
  • GetTimestamp() : FfsFile, FlsFile
  • GetTimeZone() : ValidityPeriod, CodedTimeStamp, MnInformationIndArg, StatusProvider, DataHandler
  • GetTiPd() : SaMolrResultArg, LcsMolrResultArg, LocationNotifInvokeArg
  • GetTipd() : SsWaitDispatcher, TipdBasedActiveWaitDispatcher, UssdBeginMsg, GetPasswordMsg, UssdDataMsg, UssdEndMsg, UssdNotifyMsg, UssdRequestMsg, SsErrorMsg, CallBarringPasswordChangedMsg, ClirStatusMsg, CnapStatusMsg, ColrStatusMsg, ColpStatusMsg, ClipStatusMsg, CallBarringStatusMsg, CallBarringDeactivatedMsg, CallBarringActivatedMsg, CallForwardingErasedMsg, CallForwardingRegisteredMsg, CallForwardingStatusMsg, CallForwardingDeactivatedMsg, CallForwardingActivatedMsg, CnapInfoReceivedMsg, EctAlertingMsg, EctActiveMsg, MultiPartyCallInvokedMsg, IncomingCallForwardedMsg, OutgoingCallForwardedMsg, CugCallMsg, HlrDataCorruptedMsg, ForwardedCallIncomingMsg, CallBarredMsg, CallIsWaitingMsg, CallRetrievedMsg, CallHeldMsg, CallForwardingActiveMsg, ClirNotSurpressedMsg, StackSsRejectedMsg, NetworkSsRejectedMsg, NetworkSsErrorMsg, EmlppStatusMsg, EmlppRegisteredMsg, CallWaitingStatusMsg, CallWaitingDeactivatedMsg, CallWaitingActivatedMsg, SsRequestAcceptedMsg, UssdAnswerMsg, SsInfoMsg, DiagnosticIndMsg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityIndArg, SsBeginAccArg, SimTkSsIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, RedialSetupIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, ChargeUnitsReqArg, ChargeReqArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, CallDeflectSsReqArg, CallDeflectionIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, CallIndCallControlInfoArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg, XCallInfoResponseParser
  • GetTitle() : Window, MenuAccessor, VCard, PropertyDescriptor
  • GetTitleAlpha() : SetupMenuReqArg, SelectItemReqArg
  • GetTitleHeight() : WindowFrameView
  • GetTitleIcon() : SetupMenuReqArg, SelectItemReqArg
  • GetTitleText() : SatteliteInfoWin, SatteliteGraphWin, LocationResultWin
  • GetTitleTextFormat() : WindowFrameView
  • GetTitleTextType() : MenuProperties
  • GetToDoApplication() : ToDoComposeWin
  • GetTON() : PhoneNumber
  • GetTone() : AudioReference, PlayToneReqArg
  • GetToneCount() : AbstractIMelodyParser
  • GetToneData() : Melody, IMelody
  • GetToneID() : PresetAudioReference, AudioPreset
  • GetToneId() : PreparedSound
  • GetToneMode() : Zi8Wrapper
  • GetToneType() : CustomToneAudioReference, AudioPreset, AudioTone
  • GetTONNPI() : PhoneNumber
  • GetTop() : Rect, WinRect
  • GetTopLineGap() : ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor
  • GetTopSize() : ControlFrameView
  • GetTotalEntries() : MePhonebookDescriptor, AtPbSelectCnfArg
  • GetTotalIterations() : SocketTestApp
  • GetTotalPlayTime() : MmfPlayer, AudioReference
  • GetTotalSpace() : FfsHandler
  • GetTotalSpaceSize() : RamHandler
  • GetTotalVolumeSize() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetTpData() : Tpdu
  • GetTpdu() : SmsInfoBox, SmsFactory, SmsSendReqArg, MdhSmsTransmitIndArg, MdhSmsNewMessageIndArg, MdhNewStatusReportIndArg, TpduCache, CompoundTpduItem
  • GetTpduConc() : MdhSmsReadIndArg
  • GetTpduCount() : SimPduHandler
  • GetTpduCountType() : SimPduHandler
  • GetTpLength() : Tpdu
  • GetTpOffset() : Tpdu
  • GetTraceInfo() : ObexAbstractPort
  • GetTrackId() : MediaInfo::MediaTrackInfo
  • GetTrackInfo() : MmfPlayer
  • GetTransactionId() : UriMappingTable
  • GetTransferBuffer() : DisplayConfig
  • GetTransformation() : CameraSettings, ImageBox, BtBipImageDesc, BtBipImageFormat
  • GetTranslationTable() : LocaleConfig
  • GetTransmitCause() : MdhSmsTransmitStartIndArg
  • GetTransparentColor() : NativeImage, Image, Bitmap, BitmapRes, SvgImage, WbmpImage, PngImage, PngDecoder, GifImage, BmpImage
  • GetTranspLayer() : DhChannelOpenReqArg
  • GetTransport() : ObexMngr, ObexAddress, ObexAbstractPort, StreamObexImpl
  • GetTransportDisableReason() : IrdaTransport
  • GetTransportId() : ObexTransportMsg, ObexChannel, ObexAddress
  • GetTransportMutex() : BtObexImpl
  • GetTransportOperId() : ObexAbstractPort
  • GetTree() : RamFileSystem
  • GetTriggeredMessage() : InputMap, Control
  • GetTrust() : WapProfile
  • GetTstFile() : SimAccessor
  • GetTtyMode() : TtyInterface
  • GetTtySpeed() : TtyInterface
  • GetTwilight() : CameraSettings
  • GetTwilightMode() : Camera
  • GetType() : ToDoRecord, BtDeviceListWindow, DataConnProfileInfoMsg, DataConnInfoMsg, NetAdapter, DataConnProfileManager::ProfileInfo, DataConnProfile, ObexHeader, ServiceThread, ExecutionContext, Application, PredInputMapper, AnimatedTextLine, VirtualDisplay, BtSvrDataElement, BtSddbDeAlternative, BtSddbDeSequence, BtSddbDeUrl, BtSddbDeString, BtSddbDeUuid128, BtSddbDeBigSintBase, BtSddbDeBigUintBase, BtSddbDeBoolean, BtSddbDeUuidBase, BtSddbDeSintBase, BtSddbDeUintBase, BtSddbDeNil, BtSddbDataElement, Provider::Modification, PhoneNumber, AudioRadioDeviceNotificationMsg, UusErasedMsg, UusRegisteredMsg, UusNotificationMsg, PdpContext, PdpContext::PacketFilter, PdpContext::Authentication, PinAction, SsUus1ReqArg, SsUus1IndArg, Sms, SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg, MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType, BaseInformationElement, Accessory, Zi8InputMapper, T9InputMapper, XCallInfoResponseParser, AtCommand, MCServiceInterfaceMsg, MediaManagerMsg, DrmConstraint, PhoneNumberJoinRule, StandardJoinRule, JoinRule
  • GetTypeId() : ImageRefGenContainer, BtDeviceAddressGenericObject, ObexProtocol, ObexDispatcher, ObexServerAddr, ObexClientAddr, ObexAddress, BtJsr82Url::Token, RegBlobObject, GenericObject, BlobPtr, BlobObject, TimeFeatureObject, GenericFeatureData, ImgObtObj, MenuIdObj, ItemObj, MenuDescObj, CompoundTpduItem, CompoundSmsItem
  • GetTypeOfNumber() : TypeOfAddress
  • GetTypeOfServiceMaskOrTrafficClassMask() : PdpContext::PacketFilter
  • GetTypeOfServiceOrTrafficClass() : PdpContext::PacketFilter
  • GetUid() : DrmAsset, UsimPbRwRecord, UsimPbUpdResArg, DrmRightsObject, DrmMessage
  • GetUInt() : NumberPrompt
  • GetUint32FromUint8Array() : AudioUtility
  • GetUnblockchv() : ChvUnblockReqArg
  • GetUnblockPin() : PinAction
  • GetUnicodeStringToGsm7DefaultStringLength() : DataCoding
  • GetUniqueId() : PbNumberRecord
  • GetUniqueString() : PbManualSynchronizer
  • GetUnit() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams, PackedTimePeriod
  • GetUnitId() : GltpRequest
  • GetUnitInfo() : BtAvrcpOperationService
  • GetUnitInfoParams() : BtAvrcpUnitInfoRequest
  • GetUnitType() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • GetUnreadCount() : SimPduHandler
  • GetUnreadProvider() : AbstractSmsApp
  • GetUnsentCount() : SimPduHandler
  • GetUnsentProvider() : AbstractSmsApp
  • GetUpdateAction() : UsimLangUpdReqArg, UsimPlmnUpdReqArg
  • GetUpdatedItem() : PbDetails, PbAdvDetails
  • GetUpdateNumber() : Cbs::SerialNumber
  • GetUpdatePath() : AudioAccessoryDetails
  • GetUplinkPath() : AudioAccessoryDetails
  • GetUpperCaseChar() : PagingMapEntry
  • GetUpperDestinationPort() : PdpContext::PacketFilter
  • GetUpperSourcePort() : PdpContext::PacketFilter
  • GetUri() : RegNodeBuffer, NotificationTableEntry, LockTable, RegNotifyMsg
  • GetUriDepth() : Uri
  • GetUriHeader() : Uri
  • GetUrl() : SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg
  • GetUrlScheme() : ObexAbstractTransport
  • GetUrlStr() : ObexServerDispatcher
  • GetUrlType() : BtJsr82Url
  • GetUsage() : ProtocolIdentifier, MessageTypeIndicator
  • GetUsbTransport() : UsbSubSystem
  • GetUsedBandList() : BandStatusMsg, OmBandStatusCnfArg
  • GetUsedEntries() : AtPbSelectCnfArg
  • GetUsedSize() : RamStorageMapper
  • GetUsedSpace() : FfsHandler
  • GetUsedSpaceByType() : FfsHandler
  • GetUsedSpaceInGlobalPool() : FfsHandler
  • GetUsedSpaceSize() : RamHandler, RamFileSystem
  • GetUsedVolumeSize() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • GetUseInbandRinging() : BtAudioAccessoryService
  • GetUseMessageInterface() : BtObservableService
  • GetUser() : FtpClient
  • GetUserData() : SmsStatusReport, SmsSubmit, SmsDeliver
  • GetUserDataHeader() : UserData
  • GetUserDefinedSoundBuffer() : InformationElement
  • GetUserDefinedSoundLength() : InformationElement
  • GetUserDefinedSoundStartPosition() : InformationElement
  • GetUserHome() : FtpAuthProvider
  • GetUserId() : BtController, BtConnectionlessController, BtConnectionBasedController, FlsFile
  • GetUserInput() : CallControlUssdIndArg, CallControlSsIndArg, SimTkSsIndArg
  • GetUserInputLanguage() : CallControlUssdIndArg, CallControlSsIndArg, SimTkSsIndArg
  • GetUserLogin() : DhChannelOpenReqArg
  • GetUserPassword() : DhChannelOpenReqArg
  • GetUserPromptIndicatorNumberCorrespondingObjects() : InformationElement
  • GetUsimFileProperty() : SimAccessor
  • GetUsimPbLocReport() : DataHandler
  • GetUsimPbResult() : UsimPbReadyMsg
  • GetUst() : UsimUstReadIndArg
  • GetUtilityProcessor() : AbstractSmsApp
  • GetValidityPeriod() : DrmAsset, SmsContext, SmsSubmit
  • GetValidityPeriodFormat() : SmsSubmit
  • GetValLen() : Tlv
  • GetValPtr() : Tlv
  • GetValue() : RadioButtonControl, PositionIndicator, Color, CheckBoxControl, AbstractToggleAction, RadioButtonItem, ValueIndicator, BtJsr82Url::Token, BtSddbDeVariableLengthType, BtSddbDeByteBlockType, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, SimpleMap< TKey, TValue >, SimpleMapElem< TKey, TValue >, IndexTable< T >, ValueMappingPropertyDescriptor< T_Container >, RangeMappingPolicy, MappingPolicy, ListPropertyDescriptor, EccCategory
  • GetValuePointer() : BtSvrDataElement
  • GetValueSize() : BtSvrDataElement
  • GetVariablePictureBuffer() : InformationElement
  • GetVariablePictureHorizontalDimension() : InformationElement
  • GetVariablePictureLength() : InformationElement
  • GetVariablePictureStartPosition() : InformationElement
  • GetVariablePictureVerticalDimension() : InformationElement
  • GetVariantList() : BtBipImageProperties
  • GetVCard() : ObexVCardMsg, VCardItem
  • GetVersion() : Registry, DrmDcfParser
  • GetVersionString() : VersionInfo
  • GetVeryLongFeature() : KeyMapping
  • GetVeryLongKeyDelay() : KeyboardConfig
  • GetVideoChannel() : DefaultDisplay, Display, DefaultDisplay
  • GetVideoCodec() : RecordSettings
  • GetVideoInfo() : MediaInfo
  • GetVideoInfoCount() : MediaInfo
  • GetVideoQuality() : RecordSettings
  • GetView() : ThemeViewIterator, Component, TimeEditBox, IndicatorBar, EditBox, DateEditBox, AbstractEditBox, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg
  • GetViewConfig() : MdhSetConfigReqArg
  • GetViewCount() : BrowserViewContainer
  • GetViewHdl() : MdhRemoveViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSmsUpdStatusReqArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSmsUpdStatusIndArg, MdhRegistrationCnfArg
  • GetViewScalingMethod() : Camera
  • GetVisibleItemCount() : AbstractLineEditor
  • GetVisibleLineCount() : AbstractMultiLineEditor
  • GetVisibleRowCount() : AbstractGrid
  • GetVisibleValuesCount() : PositionIndicator
  • GetVKey() : KeyMapping
  • GetVoiceBoxNumber() : SmsSettingsRecord
  • GetVolume() : AudioContext, AudioReference, AudioDeviceBase, AudioActiveReference, AudioAccessoryDetails
  • GetVolume_Specific() : AudioDeviceBase
  • GetVolumeSet() : AudioReference, AudioActiveReference
  • GetWaitIndicatorArray() : MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg
  • GetWaitingMessage() : DataCodingScheme
  • GetWaitingMessageIndication() : DataCodingScheme
  • GetWapProfile() : WapProfileMgr
  • GetWapProfileInfo() : WapProfileMgr
  • GetWarningCode() : VrWarningIndArg, VrWarningMsg
  • GetWarningLevel() : SmsCapacityExceededArg
  • GetWCharForBcdCode() : PhoneNumber
  • GetWchars() : DataCoding
  • GetWhiteBalance() : Camera
  • GetWidth() : DisplayConfig, ImageMetaData, Size, Rect, ImageObtainer, ImageEncoder::EncodingParameters, Image, Image::MetaData, Glyph, DeviceContext, Component, Bitmap, BitmapRes, VirtualDisplay, WinRect, SoundItem, SimImage, SvgPlayer, SvgImageFileWrapper, VCardItem, PngDecoder, ImageItem, BoundedItem, AudioItem, MediaInfo::VideoTrackInfo
  • GetWildcard() : EditConfig
  • GetWin() : OpenPbWinMsg
  • GetWindow() : CloseWindowMsg, WinMenuItem
  • GetWindowContextId() : AtlItemGridWindow
  • GetWindowFrameView() : Theme, FoggyTheme, DefaultTheme, CustomizableTheme, TestTheme, FoggyTheme, DefaultTheme, DefaultChineseTheme, BlueSkyTheme, BlueSkyChineseTheme, BlackAndWhiteTheme
  • GetWindowProvider() : PhonebookApp
  • GetWindowTitle() : ContextDescription
  • GetWirelessControlMessageProtocolBuffer() : InformationElement
  • GetWirelessControlMessageProtocolLength() : InformationElement
  • GetWord() : Zi8EnteredUnknownWordMsg, T9EnteredUnknownWordMsg
  • GetWorkMedia() : MdhSmsTransmitIndArg, MdhSmsStorageRefreshIndArg
  • GetWrapPolicy() : AbstractMultiLineEditor
  • GetWrapPositions() : AbstractTextRenderer
  • GetWriteByteCount() : StreamingWriteInfo
  • GetWriter() : Stream
  • GetWrittenByteCount() : StreamingWriteInfo
  • GetWspVersion() : WapProfile
  • GetWString() : Time, Provider, PhoneNumber, Date, DataItem, Property, UsimLanguage, ExtLanguage, BaseInformationElement, SmsWStringCache, PbBaseProvider
  • GetWStringCashPos() : TpduHeaderInformation
  • GetWwwDir() : HttpServerConfig, HttpServer
  • GetX() : Point
  • GetXPos() : Rect, Component
  • GetY() : Point
  • GetYear() : Date
  • GetYearYY() : Date
  • GetYearYYYY() : Date
  • GetYPos() : Rect, Component
  • GetZoom() : CameraSettings, Camera
  • GetZoomLevelCount() : Camera
  • GifImage() : GifImage
  • GlassPane() : GlassPane
  • GltpAidDataRequests() : GltpAidDataRequests
  • GltpAidingDataWin() : GltpAidingDataWin
  • GltpAidingRequest() : GltpAidingRequest
  • GltpAssistanceData() : GltpAssistanceData
  • GltpConnStatusMsg() : GltpConnStatusMsg
  • GltpHelloRequest() : GltpHelloRequest
  • GltpMsmtRequest() : GltpMsmtRequest
  • GltpPositionRequest() : GltpPositionRequest
  • GltpRequest() : GltpRequest
  • GmmParam() : GmmParam
  • GotoDay() : CalendarMonthWin
  • GoToSms() : AbstractSmsViewerWin
  • GoToSmsEmbItems() : SmsViewerWin, AbstractSmsViewerWin
  • GprsAttachStatusMsg() : GprsAttachStatusMsg
  • GprsClassIndArg() : GprsClassIndArg
  • GprsClassReqArg() : GprsClassReqArg
  • GprsParam() : GprsParam
  • GprsStatusMsg() : GprsStatusMsg
  • GpsToUtcTime() : LcsUtils
  • GrabFocus() : System, Application, AppContainer, Control
  • GreaterRule() : GreaterRule
  • Grid() : Grid
  • GridLayout() : GridLayout
  • GridModel() : GridModel
  • GridView() : GridView
  • GroupProvider() : GroupProvider
  • Gsm7DefaultStringToUnicodeString() : DataCoding
  • GsmBandStateMsg() : GsmBandStateMsg
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- h -

  • handle_response() : apoxi_emcpp_OBEXAdapter
  • HandleAbort() : StreamObexImpl
  • HandleAudReturnCode() : DwdDevice
  • HandleByteStream() : RegAppWin
  • HandleConnect() : StreamObexImpl
  • HandleConnectionRequest() : ObexFtpDataServer
  • HandleDeleteObjectRequest() : ObexFtpDataServer
  • HandleDisconnect() : StreamObexImpl
  • HandleDispatcherList() : ExecutionContext
  • HandleEnglishKeyEvent() : Zi8Wrapper
  • HandleFilePullRequest() : ObexFtpDataServer
  • HandleFilePushRequest() : ObexFtpDataServer
  • HandleFolderListingRequest() : ObexFtpDataServer
  • HandleGet() : StreamObexImpl
  • HandleMessage() : KeyManager
  • HandleMsg() : ServiceThread, ExecutionContext, Application
  • HandleOnAsyncEvent() : ClientNetAdapter
  • HandlePinYinKeyEvent() : Zi8Wrapper
  • HandleProvideFolderListingEntriesFinished() : ObexFtpDataServer
  • HandleProvideFolderListingEntry() : ObexFtpDataServer
  • HandlePut() : StreamObexImpl
  • HandleRadioAudioNotification() : FmRadioWindow
  • HandleRequest() : HttpServer, FtpServer
  • HandlerId() : EnumTranslationTable
  • HandlerListEntry() : HandlerListEntry
  • HandleSetCurrentFolderRequest() : ObexFtpDataServer
  • HandleSetPath() : StreamObexImpl
  • HandleStrokeKeyEvent() : Zi8Wrapper
  • HandleToneKeyEvent() : Zi8Wrapper
  • HandleTransportDisconnect() : StreamObexImpl
  • HandleWinEvent() : LocResController
  • HandOver() : UdpSocket, TcpSocket, TcpServerSocket, InetSocket
  • HangUp() : ObexServerDispatcher
  • HasActiveLanguageChanged() : LanguageManager
  • HasAlphaChannel() : Image, SvgImage, PngImage
  • HasAnyChildLocked() : LockTableList, LockTable
  • HasAudio() : StreamAudioReference
  • HasCandidate() : Zi8Wrapper, Zi8InputMapper
  • HasChineseCandidate() : Zi8Wrapper
  • HasClirOverrideCategory() : PhoneNumber
  • HasCphsNetworkSpecificIndicator() : SimPbEntry
  • HasCphsPremiumServiceIndicator() : SimPbEntry
  • HasData() : SimPbEntry
  • HasDefaultSize() : Window
  • HasDtmf() : PhoneNumber
  • HasEntireLacRange() : OplEntry
  • HasExtension() : Pathname
  • HasFocus() : Application, AppContainer, Control
  • Hash() : HashTable
  • Hashable() : Hashable
  • HasHeader() : AbstractItemGrid, AbstractGrid
  • HashTable() : HashTable
  • HasIcon() : Item
  • HasKeyAtPos() : KeySequence
  • HasLeaf() : Pathname
  • HasMoreInformationElements() : UserDataHeader
  • HasMoreResponses() : AtResponseIterator
  • HasMultipleRefs() : WStrData, StrData
  • HasNativeAlphaChannel() : PngDecoder
  • HasNativeImageData() : Bitmap, BitmapRes
  • HasNext() : ScanlineAccessor, DBService::DBItemIterator
  • HasNextCandidates() : Zi8Wrapper
  • HasNextPage() : Zi8Wrapper, Zi8InputMapper
  • HasNotification() : Property
  • HasOnly7bitChars() : DataCoding
  • HasParam() : SimUserDispatcher
  • HasParamAttribute() : SimUserDispatcher
  • HasPbGrown() : PbSynchronizer
  • HasPendingData() : IsrDataManager
  • HasPnnRecordId() : OplEntry
  • HasPorts() : SmsSocketListener
  • HasPrevCandidates() : Zi8Wrapper
  • HasPrevPage() : Zi8Wrapper, Zi8InputMapper
  • HasProvider() : MainProvider
  • HasRemoteVolumeControl() : BtQuerySupportedProfilesRequest
  • HasSelection() : AbstractEditor
  • HasSmsPortNo() : PortHeaderInformation
  • HasValidGzHeader() : SvgGzFileWrapper
  • HasWrongStatus() : TpduHeaderInformation
  • HasWrongSyntax() : InputAction
  • Header() : DataConnProfileStorage::Header
  • HeaderExists() : UserData
  • HeadSet() : HeadSet, Accessory
  • HeapArrayObject() : HeapArrayObject< T >
  • HeapDataSink() : HeapDataSink
  • HeapDataSource() : HeapDataSource, HeapDataSink
  • HeapManager() : HeapManager
  • HeapObject() : HeapObject< T >
  • HeldCallExists() : InputContext
  • HelpAvailable() : SimSetupMenuOptions, SimSelectItemOptions, SimGetInkeyOptions, SimGetInputOptions
  • HexCharToUInt8() : HttpSocket
  • HideUserInput() : SimGetInputOptions
  • HideViewfinder() : Camera
  • HighPriority() : SimDisplayTextOptions
  • HindiTextRenderer() : HindiTextRenderer
  • HlrDataCorruptedMsg() : HlrDataCorruptedMsg
  • HlrSsDataCorruptMsg() : HlrSsDataCorruptMsg
  • Hold() : MptyCallHdl, CrssHandler, CallHdl
  • HomezoneIndArg() : HomezoneIndArg
  • HomezoneMsg() : HomezoneMsg
  • HostDebugTimeStamp() : HostDebugTimeStamp
  • HostFatFsDeviceDescriptor() : HostFatFsDeviceDescriptor
  • HostIniFile() : HostIniFile
  • HttpApplication() : HttpApplication
  • HttpAuthProvider() : HttpAuthProvider
  • HttpClient() : HttpClient, HttpSocket, HttpServer, HttpApplicationSupplier, HttpApplication
  • HttpConnectMessage() : HttpConnectMessage
  • HttpDisconnectMessage() : HttpDisconnectMessage
  • HttpErrorMessage() : HttpErrorMessage
  • HttpHandler() : HttpHandler, HttpWapMgr
  • HttpRequest() : HttpRequest
  • HttpRequestMessage() : HttpRequestMessage
  • HttpResponse() : HttpResponse
  • HttpServer() : HttpServer, HttpSocket, HttpRequest, HttpClient, HttpApplicationSupplier, HttpApplication
  • HttpServerConfig() : HttpServerConfig
  • HttpServerSocket() : HttpServerSocket, HttpServer
  • HttpServiceMessage() : HttpServiceMessage
  • HttpSocket() : HttpSocket, HttpServer, HttpRequest
  • HttpWapMgrBase() : HttpWapMgrBase
  • HugeAlloc() : Os
  • HugeAllocate() : HeapVector::VarPage, HeapManager
  • HugeFree() : Os, HeapVector::VarPage, HeapManager
  • HugeRealloc() : Os
  • HugeReAllocate() : HeapVector::VarPage, HeapManager
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- i -

  • IA52KeyCode() : Conversion
  • IconDescReadIndArg() : IconDescReadIndArg
  • IconDescReadReqArg() : IconDescReadReqArg
  • IconIndicator() : IconIndicator
  • IconSet() : IconSet
  • IconState() : IconState
  • IconTextIndicator() : IconTextIndicator
  • IconValueIndicator() : IconValueIndicator
  • Id() : InputMapper, Message, BtBipServerNotificationMsgArg, HandlerListEntry, HandlerData, StackMsgArgument, NetAdapter, PdpContext
  • IdleScreenAvailEventArg() : IdleScreenAvailEventArg
  • IFX_MAPI() : AudioMapiManager
  • ignorableWhitespace() : WbxmlParserRel
  • IgnoreDuplicates() : Cbs::Filter
  • IgnoreUnavailableFeatures() : FeatureItemContainer
  • Image() : Image
  • ImageBox() : ImageBox
  • ImageBrowserDeleteImageMsg() : ImageBrowserDeleteImageMsg
  • ImageBrowserDetailWin() : ImageBrowserDetailWin
  • ImageBrowserRenameImageMsg() : ImageBrowserRenameImageMsg
  • ImageBrowserServiceMsg() : ImageBrowserServiceMsg
  • ImageBrowserTestWin() : ImageBrowserTestWin
  • ImageBrowserWin() : ImageBrowserWin
  • ImageDecoder() : ImageDecoder
  • ImageDecodingProgressMsg() : ImageDecodingProgressMsg
  • ImageDrawingInterruptedMsg() : ImageDrawingInterruptedMsg
  • ImageEncoder() : ImageEncoder
  • ImageEncodingProgressMsg() : ImageEncodingProgressMsg
  • ImageFileFilter() : ImageFileFilter
  • ImageFilter() : ImageFilter
  • ImageIncrementalPdcUpdater() : ImageIncrementalPdcUpdater
  • ImageItem() : ImageItem
  • ImageListBoxModel() : ImageListBoxModel
  • ImageListBoxView() : ImageListBoxView
  • ImageMetaData() : ImageMetaData
  • ImageMetaDataRecord() : ImageMetaDataRecord
  • ImageObtainer() : ImageObtainer
  • ImageReadIndArg() : ImageReadIndArg
  • ImageReadReqArg() : ImageReadReqArg
  • ImageRef() : ImageRef
  • ImageRefContainer() : ImageRefContainer
  • ImageRefGenContainer() : ImageRefGenContainer
  • ImageView() : ImageView
  • ImageViewListBoxModel() : ImageViewListBoxModel
  • ImeiReadIndArg() : ImeiReadIndArg
  • ImeiReadReqArg() : ImeiReadReqArg
  • ImeiShowAction() : ImeiShowAction
  • IMelody() : IMelody
  • ImgObtObj() : ImgObtObj
  • Include() : ObexTransportSet
  • IncomingCallForwardedMsg() : IncomingCallForwardedMsg
  • IncreasePriority() : Thread
  • IncRefCount() : WStrData, StrData, ProviderPtr
  • Increment() : SimpleMap< TKey, TValue >::Iterator, StorageDeviceIterator, DirectoryIterator, RootDirectoryIteratorImp
  • IncrementalPdcUpdater() : IncrementalPdcUpdater
  • IncrementCell() : GridModel
  • IncrementDelBufCount() : RegDeletionBufferEntry
  • IncrementOpenFileCounter() : StorageDevice
  • IncrementRefCount() : DrmAsset
  • IncrementRegCount() : ApplicationListEntry
  • IndexOf() : WString, String
  • IndexTable() : IndexTable< T >
  • IndicateAlphaMaskUpdate() : Display
  • IndicateItemContainer() : ItemRendererProperties
  • IndicateSelectionChanged() : AbstractListBox
  • Indicator() : Indicator
  • IndicatorBar() : IndicatorBar
  • IndicatorBarPaneObject() : IndicatorBarPaneObject
  • IndicatorBarUpdateMsg() : IndicatorBarUpdateMsg
  • IndicatorBarView() : IndicatorBarView, IndicatorBar
  • IndicatorDescription() : IndicatorDescription
  • IndicatorItem() : IndicatorItem
  • IndicatorLocation() : IndicatorLocation
  • IndicatorPaneObject() : IndicatorPaneObject
  • InetSocket() : InetSocket, SocketSubSystem, SocketData
  • InetSocketAddr() : InetSocketAddr
  • Infinite() : Ticks
  • InfoDialog() : InfoDialog
  • InformationElement() : InformationElement
  • Init() : VoiceMemoWin, VoiceMemoRecordWin, VoiceMemoMenuAccessor, UsbApp, UibUpdateThreadlet, UibTest2, UibTest1, UibSortingTest, UibSettingsTest, UibPerformanceTest, UibNotifyTest, UibMsgDisplayTest, UibInboxTest, UibAccessorTest, UibSettingsWin, UibSettingsProvider, UibServiceImpl, UibListBoxModel, UibFolderWin, ToDoProvider, ToDoListWin, ToDoPriorityDialogWin, ToDoDateDialogWin, ToDoComposeWin, SoundBrowserWin, SoundBrowserTestWin, RenameFileDialog, MetaData, MediaRefContainer, InfoDialog, FileNameView, FileNameListBoxModel, BrowserViewContainer, BrowserView, BrowserSaveWin, AmrSound, SocketTestWin, SocketTestSettingsWin, SocketTestResultsWin, SocketTestProgressWin, SocketTestApp, IpAddrPrompt, FfsTestResultsMenu, FfsTestResultsSubMenu, FfsTestMenu, FfsTestSubMenu, FfsTestDispWin, FfsMenu, RegAppWin, RegAppFirstWin, RegApp, ObexTransportWin, ObexApp, ServerAddressWin, SelfLocationDialog, GltpAidingDataWin, LcsSocket, TransferLocationDialog, SatteliteInfoWin, SatteliteGraphWin, ResultWinBase, LocResController, LocationVerifWin, LocationResultWin, LcsOptionsMenuWin, LcsMainMenuWin, IrdaWin, SavingProgressWin, ImageViewListBoxModel, ImageView, ImageListBoxView, ImageMetaData, ImageListBoxModel, ImageBrowserWin, ImageBrowserTestWin, ImageBrowserDetailWin, RenameFileDialog, MetaData, MediaRefContainer, InfoDialog, FileNameView, FileNameListBoxModel, BrowserViewContainer, BrowserView, BrowserSaveWin, FmRadioWindow, FmRadioStationsProvider, FmRadioSettingsProvider, FmRadioSelectStrongerFreq, FmRadioEditWin, SmsViewerWin, SmsUtility, SmsTemplateProvider, SmsSettingsProvider, SmsSendingConfirmDialog, SmsFolderProvider, SmsEditor, SmsComposeWin, SmsBasicProvider, SmsInfoBox, SmsAlert, AbstractSmsViewerWin, AbstractSmsComposeWin, EmsViewerWin, EmsInsertPrompt, EmsInsertPromptListBoxModel, EmsEditor, EmsComposeWin, NumberPrompt, IpAddrPrompt, DataConnWin, DataConnLbModel, DataConnTypeWin, DataConnOptionWin, SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor, CameraViewFinderWin, CameraSettingsWin, CameraSettings, CameraOptionSettingsWin, CameraCaptureWin, CalendarRecordsListBoxModel, CalendarRecordsList, CalendarRecord, CalendarProvider, CalendarMonthWin, CalendarMonthSelector, CalendarListWin, CalendarGrid, CalendarGotoDateWin, CalendarDialogWin, CalendarAddRecordWin, BtDeviceSearchModeWindow, BtTurnOnOffWindow, BtHsVolumeSettingsWin, BtHsInbandSettingWin, BtHsConnectionSettingWin, BtHsAppPlugin, BtHfVolumeSettingsWin, BtHfProvider, BtHfProfileWindow, BtHfFeatureListWin, BtHfInbandSettingWin, BtHfAudioPathWindow, BtHfAppPlugin, BtFaxAppPlugin, BtDunAppPlugin, BtDeviceListWindow, BtDeviceDetailWindow, BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtRequestRunningWindow, BtAlertMessageWindow, BtActiveDeviceWindow, BtAvrcpPanelServiceImpl, BtAvrcpDeviceListWin, BtAvrcpControllerDeviceListWindow, BtAvrcpControllerApplicationWindow, BtAvrcpAlertMessageWindow, UpdatePbThreadlet, SyncPhoneThreadlet, ProvDetailListBoxWin, ProvColListBoxWin, PhonebookWin, PbSynchronizer, PbSimProvider, PbSelectNumberWin, PbSelectNoType, PbSelectGroup, PbRecordProvider, PbRecordHandler, PbProvColListBox, PbProvListBox, PbProvColListBoxModel, PbPhoneNumberPrompt, PbNvRamNumberHandler, PbNvRamNameHandler, PbNumberProvider, PbNameProvider, PbNameNumberProvider, PbNameHandler, PbNameEditBox, PbMergeProvider, PbManualSynchronizer, PbFfsNumberHandler, PbFfsNameHandler, PbDetails, PbDetailListBox, PbDetailListBoxModel, PbNumberFilterProvider, PbDetailProvider, PbDataHandler, PbBaseWin, SearchBox, PbAdvDetails, PbAdvDataHandler, PbAdvAddEditEntry, PbDetailAction, PbToggleAction, PbAction, PbAbstractWin, GroupProvider, PbCopyHandler, CopyHandler, BasicPbWin, AdvPbWin, PbAdvDetailAction, AdvPbAction, SysSocket, SysDnsClient, SysSocket, SocketRxThread, SocketHandler, DnsClient, DataConn, ObexAbstractTransport, ObexServerDispatcher, ObexServer, ObexOppServer, ObexOppDataSinkPushServer, ObexOppClient, ObexObject, ObexFtpServer, ObexFtpDataServer, ObexDispatcher, ObexDataServer, ObexClientDispatcher, Timer, System, Trap, SystemTimer, Trap, SystemTimer, IsrDataManager, InternalTracer, MessageRouter, MessageMapDispatcher, MessageMapContainer< T >, ExternalCommunicationHandler, TimeoutCondition, BooleanCondition, ActiveWaitDispatcher, Window, ToggleActionGroup, TimeEditorDocument, TimeEditor, TextPackConnector, TextLine, TextLineView, TextFormat, TextEditorDocument, TextBox, TabControl, TabButton, RadioButtonGroup, RadioButtonControl, RadioButtonAction, PushButton, ProgressBar, PositionIndicator, PasswordEditor, OpenWindowAction, OpenContextMenuAction, NativeImage, MultiLineEditor, Model, MessageBox, LineEditor, ItemTree, ItemMenu, ItemGrid, ItemContainer, ItemBox, Item, IpAddrEditorDocument, IpAddrEditor, ImageBox, IncrementalPdcUpdater, GridLayout, PaneObject, FontPackConnector, FlowLayout, FilePackConnector, DrawableObject, DisplayDc, DeviceContext, DateEditorDocument, DateEditor, ControlDc, Control, Component, CloseWindowAction, CheckBoxControl, CheckBoxAction, BitmapDc, BasicPackConnector, AnimatedTextLine, Alert, Action, AbstractToggleAction, AbstractTextObject, AbstractMultiLineEditor, AbstractLineEditor, AbstractLineEditorView, AbstractItemGrid, AbstractItemContainer, AbstractGrid, AbstractEditor, AbstractButton, VoiceMemoAudioDevice, VirtualDisplay, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice, GenericAudioDevice, CamWin32, AmplifierAudioDevice, VirtualDisplay, BackLight, VirtualDisplay, EmzUtils::Queue< T >, BackLight, VirtualDisplay, EmzUtils::Queue< T >, BackLight, VirtualDisplay, WinRect, WinMenuItem, TimeEditBox, TextMenuAccessor, TextList, SoftkeyBar, SmafSound, SharedTriggerTimer< T >, SharedTimer, SetThemeAction, SetLanguageAction, RadioButtonList, ProviderListBox, ProviderListBoxModel, PreparedSound, NvRamDataRecordHandler, MidiSound, MenuTextPtrArrayIterator, MenuList, MenuItem, MenuAccessor, Menu, Melody, IndicatorBarPaneObject, IndicatorPaneObject, IndicatorDescription, IndicatorBar, Indicator, IMelody, Grid, GridModel, EditBox, Audio, DateEditBox, ConfirmAction, CheckBoxList, CheckBox, CancelAction, AtlItemGrid, Animation, AnimationBmpPointerArrayIterator, AnimationBmpArrayIterator, AbstractMenuListModel< Item >, AbstractMenuAccessor, AbstractListBoxView, AbstractListBox, AbstractListBoxModel, AbstractEditBox, AbstractEditBoxModel, BtObexTransport, BtHsService, BtHfService, BtController, BtConnectionlessController, BtConnectionBasedController, BtAvrcpService, TriggerTimer< T >, ThreadSafeProvider, SortProvider, QuickSortProvider, Protector, MainProvider, FindProvider, Find2Provider, FilterRule, FilterProvider, DrmInfo, DistinctProvider, CachingSortProvider, BubbleSortProvider, AbstractDelegationProvider, ValueMappingPropertyDescriptor< T_Container >, TextIconPairArray, SubstitutedText, PropertyItem, PropertyEditor, PropertyDescriptor, Property, PhoneNumberMatchRule, InputMapperFactory, ItemLabel, AtlLabelListWindow, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow, AtlItemBox, TriggerKeyFeature, ProviderProxyItem, ProviderProxyContainer, IndicatorItem, FeatureItemContainer, FeatureItem, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, MenuDesc, ContextDescription, AtlWindow, AtlApplicationPlugin, SsEmlppActionImpl, SsUssdActionImpl, SsCnapActionImpl, SsColpActionImpl, SsColrActionImpl, SsClipActionImpl, SsClirActionImpl, SsCallWaitingActionImpl, SsCallForwardingActionImpl, SsCallBarringActionImpl, SsPasswordChangeActionImpl, StackMsgDispatcher, StackMsgActiveWaitDispatcher, SmsSocket, SmsFactory, PdpContextManager, MainHandler, InputAnalyzer, HandlerListEntry, ExtPsdContextListener_SioGlueSignalListener, DataCallHdl, CbsFilterList::CbsFilterListEntry, UserData, UserDataHeader, StackMsgArgMapContainer< T >, StackInterface, Sms, StackTranslator, StackMsgProcessor, SignalHandler, ProcessNode, PlmnListEntry, Plmn, BcdPlmn, UriMappingTable, Pathname, RegNodeBuffer, RegMemoryPool, RegDeletionBufferEntry, DirtyFileHandler, Zi8Wrapper, Zi8StrokeBox, Zi8StrokeBoxView, Zi8SelectionBox, Zi8SelectionBoxView, Zi8PredictiveInputBox, Zi8AlphabetBox, Zi8AlphabetBoxView, UsbObexTransport, T9PredictiveInputBox, T9PinyinBox, T9PinyinBoxView, T9PackConnector, StrokeBox, StrokeBoxView, SelectionBox, SelectionBoxView, ChineseT9Wrapper, SvgPlayer, SvgImage, StreamObexTransport, StreamObexImpl, SioSocketAdapter, ServicePtr< T >, Server, HttpServer, HttpApplication, FtpServer, SerialSocketThread, SerialIoSet, RfsObexFtpServer, WbmpImage, PngImage, MultiMediaEditor, JpegImage, GifImage, BmpImage, SioGlueSignalListener, MediaInfo::ClipInfo, MediaBox, SaProviderImpl, GltpProviderImpl, LcsTimer, LcsRepeatTimer, LcsProviderImplBase, LcsProviderImpl, WapProfileMgr, TopLevelMenu, SubMenuAction, ApplicationAction, ActionMenuAccessor, AccessorAction, AbstractActionMenuAccessor, AbstractPredictiveInputBox, PhoneNumberMergeProvider, MergeProvider, StandardJoinRule, JoinProvider, DualFilterProvider, AppendProvider, RecordHandler, SimServices, SstProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SimPduHandler, TpduHeaderInformation, SmsWStringCache, SimPbBaseHandler, SimAccessor, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, LockProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, BaseDataHandler, AuxProvider
  • InitAvrcpOperationService() : SubUnitReference
  • InitChvData() : SimChvHandler
  • InitContext() : SwitchedRleCompression
  • InitData() : Tpdu
  • InitDataOffset() : StreamAudioReference
  • InitDecoderLib() : PngDecoder
  • InitEmsColors() : EmsResourceMaps
  • InitFile() : PbNumberHandler
  • InitFrom() : IpAddr
  • InitGetTotalPlayTimeWaitCondition() : AudioReference
  • Initialize() : HeapVector::VarPage, HeapVector::BlockPage, HeapManager, RamHandler, SimPbBaseHandler
  • InitializeKey() : DrmSecurity
  • Initiate() : ObexOppClientPull, ObexOppClientPush, ObexOppClientOperation
  • InitiateCall() : AbstractSmsApp
  • InitiateFirmwareUpdate() : Fota
  • InitIndexTable() : MergeProvider
  • InitLanguage() : System
  • InitMenus() : MenuPool
  • InitMexe() : SimAuxHandler, DataHandler
  • InitMruDynflags() : SimCphsHandler
  • InitPixelColorAccess() : PngDecoder
  • InitPlugins() : AtlApplicationPluginStartup
  • InitProperties() : CTResourcePack
  • InitRecord() : PbRecordProvider, PbNumberProvider, PbNameProvider
  • InitResponse() : ObexDataServer
  • InitRightsObjectMapTable() : DrmRightsObjectStore
  • InitSmsCommand() : SmsFactory
  • InitSmsSubmit() : SmsFactory
  • InitSmsTransmit() : SimPduHandler
  • InitSocket() : RegAppWin
  • InitSpeech() : Audio
  • InitVr() : VrHandler
  • Inkey() : SimTkHandler
  • InProgress() : AudioReference, SocketTestT, Image
  • Input() : SimTkHandler
  • InputAction() : InputAction
  • InputActionList() : InputActionList
  • InputActionPtr() : InputActionPtr
  • InputAnalyzer() : InputAnalyzer
  • InputCharMsg() : InputCharMsg
  • InputContext() : InputContext
  • InputMapItem() : InputMapItem
  • InputMapper() : InputMapper
  • InputMapperFactory() : InputMapperFactory
  • InputParser() : InputParser
  • InputStream() : InputStream
  • Insert() : WindowManager, TextCompoundItem, BtSddbServiceRecord, BtSddbDeContainer, BtDeviceList, WString, Vector< T >, String, SortedLinkedList< T >, LinkedListBase, SortedElementList< T >, Caret, Provider
  • insert() : WbxmlVector< T >
  • InsertAction() : UibActionAccessor, ActionMenuAccessor
  • InsertBlobRecord() : UriMappingTable
  • InsertChar() : AbstractEditBox, AbstractEditBoxModel
  • InsertCompoundItem() : EmsEditor, EditorDocument, AbstractEditor, ParagraphCompoundItem, MultiMediaEditorDocument
  • InsertCompoundItemBeforeItem() : EditorDocument, AbstractEditor, ParagraphCompoundItem, MultiMediaEditorDocument
  • InsertConnection() : BtMultiConnectionController
  • InsertEqualNode() : RamFileNode
  • InsertExtLanguage() : SimAuxHandler
  • InsertImage() : EmsComposeWin
  • InsertItem() : SmsEditor, EmsEditor, TimeEditorDocument, TextEditorDocument, TextCompoundItem, PasswordEditor, ItemContainer, EditorDocument, DateEditorDocument, CompoundItem, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemContainer, AbstractEditor, ProviderProxyContainer, FeatureItemContainer, ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor, GeneralCompoundItem
  • InsertKeyFrame() : EmzMpeg4Encoder, AtiMpeg4Encoder, VideoEncoder
  • InsertLanguage() : SimAuxHandler
  • InsertNode() : RamFileSystem
  • InsertPlmn() : SimAuxHandler
  • InsertPlmnwAct() : SimAuxHandler
  • InsertRow() : SortProvider, Provider, FilterProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider
  • InsertSound() : EmsComposeWin
  • InsertSubNode() : RamFileNode
  • InsertTab() : TabControl
  • InsertText() : SmsComposeWin, AbstractSmsComposeWin, MultiMediaEditorDocument::TextManager
  • InsertURIRecord() : UriMappingTable
  • Instance() : DrmROStoreSingleton
  • InternalEvent() : StateMachine
  • InternalTracer() : InternalTracer
  • InterrogateClip() : SsHandler
  • InterrogateClir() : SsHandler
  • InterrogateColp() : SsHandler
  • InterrogateColr() : SsHandler
  • InterrogationResultMsg() : InterrogationResultMsg
  • InterruptScan() : PlmnHandler
  • Intersect() : Rect
  • Intersects() : DynamicBitVector
  • Invalidate() : CalendarGrid, ObexOperationId, ObexChannel, PaneObject, DrawableObject, Control, FeatureItemContainer, MptyCallHdl, CallHdlBase, CallHdl, MmCallInfo, MmCallHdl
  • InvalidateClient() : Control
  • InvalidateCursor() : AbstractEditBox
  • InvalidateIcon() : ProviderProxyItem
  • InvalidateMsg() : InvalidateMsg
  • InvalidateSelectedItem() : AbstractListBox
  • InvalidateSockets() : DataConn
  • InvalidateText() : AbstractEditBox, ProviderProxyItem
  • InvalidText() : ValueTextMap
  • InvalidValue() : ValueTextMap, ReferenceLocation
  • InvertCursor() : AbstractEditBox
  • InvertRect() : DeviceContext
  • InvokeAt() : SocketSubSystem, SubSystem, GenericWorkerTask, IrdaObexSubSystem, GatiManager, BtObexSubSystem, BtController, AudioPresetStore, StackControl, KeyMsgGenerator, RegManager, UsbSubSystem, SerialSocketSubSystem, DrmSubsystem, DataControl
  • InvokeId() : InvokeId
  • InvokePhonebook() : PhonebookApp
  • IoCtl() : SerialSocket, SerialIoAdapter
  • IpAddr() : IpAddr
  • IpAddrCompoundItem() : IpAddrCompoundItem
  • IpAddrEditor() : IpAddrEditor
  • IpAddrEditorDocument() : IpAddrEditorDocument
  • IpAddrInputMapper() : IpAddrInputMapper
  • IpAddrPrompt() : IpAddrPrompt
  • IpPortNo() : IpPortNo
  • IrdaObexClientAddr() : IrdaObexClientAddr
  • IrdaObexImpl() : IrdaObexImpl
  • IrdaObexServerAddr() : IrdaObexServerAddr
  • IrdaObexTransport() : IrdaObexTransport
  • IrdaTransport() : IrdaTransport
  • IrdaWin() : IrdaWin
  • IrSocketAddr() : IrSocketAddr
  • Is3aExisting() : TypeOfAddress
  • IsAborted() : StackMsgActiveWaitDispatcher
  • IsAbsolute() : ValidityPeriod
  • IsAccept() : SetupEventCnfArg
  • IsAcceptable() : ObexServerDispatcher
  • IsAcceptPermitted() : CallHdl, MmCallHdl
  • IsAccessBurstTypeInvalid() : GprsParam
  • IsAccessControlClassInvalid() : CellParam
  • IsAccessGranted() : HttpAuthProvider, FtpAuthProvider, AuthProvider
  • IsAccThrInvalid() : GprsParam
  • IsAckBlocksInvalid() : AckNackCnt
  • IsActivated() : RejectCallsIndArg
  • IsActivateReporting() : SetChargeUnitsArg, SetAutoChargeArg
  • IsActivationBitSet() : SsStatus
  • IsActive() : DataConn, ObexServerDispatcher, Timer, SystemTimer, WindowFrameView, TabButton, BidiManager, AudioAccessoryDetails, SmsSocket, PdpContext, MptyCallHdl, CallHdlBase, CallHdl, MmCallHdl
  • IsActiveOperation() : ObexServer, ObexOppServer
  • IsActiveOppClient() : ObexClientOppImpl
  • IsActiveOppServer() : ObexServerOppImpl
  • IsAddData() : UsimSmsParamExtIndArg, UsimSmsParamReadIndArg
  • IsAddressAllocatedDynamically() : PdpContext
  • IsAdnReadWritableIfFdnActive() : SimAccessor, DataHandler
  • IsAidingStale() : GltpAssistanceData
  • IsAlarmDay() : CalendarApp
  • IsAllocatedDynamically() : DataConnApp::DataConnDescription
  • IsAllowed() : MimeTypeFilter, SoundFilter, ImageFilter, MediaFilter, MimeTypeFilter, SoundFilter, ImageFilter, MediaFilter, RegistrationAllowedMsg, AttachAllowedIndArg, DrmRightsObjectContainer, DrmRightsObject, DrmPermission
  • IsAlphaBlendingEnabled() : Bitmap, BitmapRes
  • IsAlphaMaskEnabled() : WindowManager
  • IsAmbulance() : EccCategory
  • IsApplUsimPbExisting() : UsimPbLocReport
  • IsArchive() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FlashFileImp, FatFileImp, FatFile
  • IsArfcnDedInvalid() : CellParam
  • IsArfcnInvalid() : CellParam, NeighbourCell
  • IsArg() : SsSuccessMsg
  • IsAscendingOrder() : SmsSettingsRecord
  • IsAsynchronous() : MessageHook
  • IsAtEnd() : ObexUrlStrParser
  • IsAttachAllowed() : PlmnDispatcher
  • IsAttached() : MessageHook, ObservableObject, GprsStatusMsg, PdpContextManager, HeadSet
  • IsAttachedToProperty() : FeatureItem
  • IsAudioConnected() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • IsAudioEnabled() : VideoCaptureParameters
  • IsAudioSwitchPath() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • IsAuthenticated() : PdpContext
  • IsAuthorityCert() : SimMexeCertificate, MexeDescriptor
  • IsAutoCallSetup() : MocSetupReqArg
  • IsAutoClearEnabled() : Control
  • IsAutoLayoutEnabled() : Control
  • IsAutoRegistered() : ObexServerAddr
  • IsAutoStopped() : AudioStoppedMsg
  • IsAutoStorageEnabled() : SmsSettingsRecord
  • IsAvailable() : FeatureItemContainer, Feature, BootState
  • IsAvsReady() : ObexAbstractPort
  • IsBackgrDrawingEnabled() : MenuView, AbstractListBoxView
  • IsBacklightOn() : DefaultDisplay, Display, DefaultDisplay
  • IsBackup() : BtObexServerNmaSetPath
  • IsBatteryLow() : Charger
  • IsBcdPlmnMatching() : StackWrapper, OplEntry
  • IsBdnActivated() : SimAccessor, DataHandler
  • IsBdnEnabled() : DataControlPhonebookStateMsg
  • IsBdnReadWritableIfBdnNotActive() : SimAccessor, DataHandler
  • IsBinaryByExt() : MimeTypeTable
  • IsBinaryByFileType() : FfsMimeTypeMap
  • IsBinaryByMimeStr() : MimeTypeTable
  • IsBlinking() : DefaultCaret
  • IsBlobFile() : UriMappingTable
  • IsBlocking() : SysSocket, Socket, InetSocket, Threadlet, SerialSocket, SerialTerminalSocket
  • IsBlockUsed() : RamStorageMapper
  • IsBold() : InformationElement
  • IsBoundTo() : ObexAbstractPort
  • IsBoundToChannel() : ObexServerDispatcher, ObexOppServer
  • IsBoundToMimeType() : ObexOppServer
  • IsBoundToServerId() : ObexServer, ObexOppServer
  • IsBoundToTarget() : ObexServer
  • IsBrowserOpen() : LcsWapIntf
  • IsBsicBccInvalid() : CellParam
  • IsBsicInvalid() : CellParam, NeighbourCell
  • IsBsicNccInvalid() : CellParam
  • IsBsPaMfrmsInvalid() : CellParam
  • IsBufferAvailable() : ImageBox
  • IsBufferingAllowed() : Image, SvgImage
  • IsBufferingEnabled() : ImageBox
  • IsBusy() : GenericWorkerTask
  • IsC1Invalid() : CellParam, NeighbourCell
  • IsC2Invalid() : CellParam, NeighbourCell
  • IsC2ValidParamsInvalid() : CellParam
  • IsC31Invalid() : NeighbourCell, GprsParam
  • IsC32Invalid() : NeighbourCell, GprsParam
  • IsCacheFilling() : UsimPbSelectReqArg
  • IsCallActive() : AudioPathManager
  • IsCallbackActive() : DefaultDisplay, Display, DefaultDisplay
  • IsCallControlPerformed() : SsInfoMsg, CallHdl, SsFacilityIndArg, CallIndCallControlInfoArg
  • IsCallFwdUncondActive() : SimCphsHandler
  • IsCancelable() : BtUncancelableRequest, BtServiceRequest, BtRequest, BtCancelableRequest
  • IsCanceled() : PbSynchronizer
  • IsCancelled() : DataConn
  • IsCapabilitySupported() : StorageDevice
  • IsCaretAlwaysVisible() : AbstractEditor
  • IsCause() : StartUp::Data
  • IsCellBarAccessInvalid() : CellParam
  • IsCellBarQualifyInvalid() : CellParam
  • IsCellChangeCntInvalid() : CellParam
  • IsCellIdentityInvalid() : UmtsRrcScellParam
  • IsCellIdInvalid() : CellParam, NeighbourCell
  • IsCellReselectHystInvalid() : GprsParam
  • IsCellReselectionReasonInvalid() : RrParam
  • IsCellReselectOffsetInvalid() : CellParam
  • IsChannelModeInvalid() : CellParam
  • IsChannelReleaseReasonInvalid() : RrParam
  • IsChannelTypeInvalid() : CellParam
  • IsChargerInserted() : Charger
  • IsChild() : Control
  • IsCingularActive() : InputContext
  • IsCingularNetworkSelectionMenuControlSupportEnabled() : SimCphsHandler, DataHandler
  • IsCingularSimInserted() : DataHandler
  • IsClearTextModeEnabled() : PasswordEditor
  • IsClient() : ObexChannel
  • IsColumnTitled() : Grid, GridModel
  • IsCombinedDelivered() : DrmInfo
  • IsComplete() : ObexHeaderBuilder
  • IsComponent() : GuiObjectFactory, Zi8Wrapper
  • IsComponentSupported() : TestparamReport
  • IsComprehensionRequired() : Tlv
  • IsCompressed() : NativeImage, Bitmap, BitmapRes
  • IsConcateneted() : PortHeaderInformation, TpduHeaderInformation
  • IsConfirmed() : PbAbstractWin, BandSelectionMsg, BandSelectionIndArg
  • IsConnected() : BtIndicatorMsg, DataConn, ObexServer, ObexClientPort, BtObexClientService, BtHsService, BtHfService, BtFaxService, BtDunService, BtDevice, BtAudioAccessoryService, BtBppClientService, BtBipClientService, BtAvrcpOperationService, AudioAccessoryConnectedMsg, ExtPsdContextListener_SerialTerminal, ConnectionIndArg, SerialTerminal
  • IsConnectionLost() : UtcStatusMessage
  • IsConstraintAvailable() : DrmRightsObject
  • IsContentValid() : InputMapper
  • IsControllerConnected() : BtAvrcpControllerDeviceListItem
  • IsCopyrighted() : NativeImage, Image, Bitmap, BitmapRes, Melody
  • IsCphsPresent() : SimCphsHandler
  • IsCphsServAccessible() : SimCphsHandler
  • IsCpichEcn0Invalid() : UmtsNcellParam, UmtsRrcScellParam
  • IsCpichRscpInvalid() : UmtsNcellParam, UmtsRrcScellParam
  • IsCpichScInvalid() : UmtsNcellParam
  • IsCreate() : BtObexServerNmaSetPath
  • IsCreateEmpty() : BtObexClientNmaDataBufferIndication, BtObexServerNmaDataBufferIndication
  • IsCrSupported() : TextEditorDocument
  • IsCspPlmnModeBitSet() : SimCphsHandler, DataHandler
  • IsCtm() : CtmInfoIndMsg, SimTkCallSetupAccArg, MtcSetupIndArg, MocSetupReqArg, CtmInfoIndArg, CallIndArg
  • IsCurrentDir() : RamHandler
  • IsCurrentlyDecoded() : Image
  • IsCursorVisible() : AbstractEditBox, AbstractEditBoxModel
  • IsDataAcceptable() : StreamWriter
  • IsDataAvailable() : StreamReader
  • IsDataConnEstablished() : InetSocket
  • IsDataConnRegistered() : DataConnManager
  • IsDateTimePresent() : MnInformationIndArg
  • IsDateTimeValid() : TpduHeaderInformation
  • IsDaylightSavingTimePresent() : MnInformationIndArg
  • IsDcsListFilterEnabled() : Cbs::Filter
  • IsDecoderCodecSupported() : MediaFrameworkCaps
  • IsDecoding() : ImageBox, SvgPlayer
  • IsDecodingFinished() : ImageBox, SvgPlayer
  • IsDefined() : File::Attributes
  • IsDeleteObject() : BtObexClientNmaDataBufferIndication, BtObexServerNmaDataBufferIndication
  • IsDeletePossible() : LockTableList, LockTable
  • IsDestinationPortRangePresent() : PdpContext::PacketFilter
  • IsDeviceConnected() : BtSingleConnectionController, BtMultiConnectionController, BtConnectionBasedController
  • IsDeviceRegistered() : RfsStorageDeviceRegistrationStatusMsg
  • IsDfIdFlag() : SimGenericReqArg
  • IsDirectory() : StorageDevice, RootFileSystem, File, File::Attributes, FfsHandler, RootStorageDeviceImp, RamStorageDeviceImp, RamHandler, RamFileObj, FlashStorageDeviceImp, FatStorageDeviceImp, FatHandler
  • IsDisable() : RediallingDisabledIndArg
  • IsDisabled() : Control
  • IsDisconnected() : DataConn
  • IsDisplayable() : DrmInfo
  • IsDispMapAllowed() : LcsWapIntf
  • IsDlUarfcnInvalid() : UmtsRrcScellParam
  • IsDocumentPanable() : SvgPlayer
  • IsDocumentZoomable() : SvgPlayer
  • IsDpofOptionSupported() : BtBipImagingCapabilities
  • IsDrmMedia() : MediaRef
  • IsDrmOpValid() : DrmRightsObjectContainer
  • IsDrxMaxInvalid() : GprsParam
  • IsDscInvalid() : CellParam
  • IsDscPchInvalid() : L1Param
  • IsDscPpchInvalid() : L1Param
  • IsDstIndInvalid() : TimeZone
  • IsDtxUsedInvalid() : CellParam
  • IsEccCode() : EccProvider, DataHandler
  • IsEcNrActive() : AudioAccessoryDetails
  • IsEditableAfterLastItem() : EditorDocument, MultiMediaEditorDocument
  • IsEfIdFlag() : SimGenericReqArg
  • IsEmoInvalid() : GprsParam
  • IsEmpty() : ObexTransportSet, Ticks, ApplicationListEntry, Rect, IndicatorBar, BtDeviceList, WString, Vector< T >, String, RegBlobObject, PhoneNumber, LinkedListBase, ByteBuffer, BlobObject, ResourceID, CbsFilterList, CiTestParamList, EquivPlmnLists, NeighbourCellList, AckNackParamList, COverIList, BlerTrchInfoList, MdhGors
  • IsEmptyRow() : PhonebookApp
  • IsEnabled() : DataConnAccessor, ItemContainer, Item, GlassPane, AbstractButton, Audio, AbstractMenuAccessor, SimpleAudioDevice, FeatureItem, Feature, AtAccessoryRegisterReqArg, AbstractActionMenuAccessor
  • IsEnablePassword() : DhChannelOpenReqArg
  • IsEnciphered() : ConnectionIndArg
  • IsEncoderCodecSupported() : MediaFrameworkCaps
  • IsEncoding() : ImageEncoder
  • IsEndOfData() : ObexObject, RtStreamingBuffer
  • IsEndReached() : UsimPlmnReadIndArg
  • IsEqual() : ImageRefGenContainer, BtDeviceAddressGenericObject, Item, AbstractToggleAction, Cell, RegBlobObject, GenericObject, DataItem, BlobPtr, BlobObject, BitField< T >, TimeFeatureObject, GenericFeatureData, ImgObtObj, TriggerKeyFeature, ProviderProxyItem, MenuIdObj, ItemObj, FeatureItemContainer, FeatureItem, Feature, ContextFeature, BackToIdleFeature, MenuDescObj, Plmn, BcdPlmn, TpduPhoneNumberPersist, CompoundTpduItem, CompoundSmsItem
  • IsEqualSignal() : ProcessNode
  • IsEqualTipd() : TipdBasedActiveWaitDispatcher
  • IsEqualTo() : BtObexServiceTable::ServiceInfo, ByteBuffer
  • IsError() : ObexResult, BtObexResponseCode
  • IsEstCauseChanged() : MocSetupAcceptMsg, MmMocSetupAcceptMsg
  • IsEventIdInvalid() : UmtsMeasIdParam
  • IsExclusive() : HandlerData
  • IsExecutable() : DrmInfo
  • IsExecuting() : PbSecuredAction
  • IsExecutionPossible() : LanguageResetAction, ApoxiCommandAction, UssdAction, UndefinedSsAction, WaitSsAction, ForwardingSsAction, PasswordChangeSsAction, EmlppAction, BarringSsAction, NumberIdentificationAction, ClirAction, PinAction, CallSsAction, EngModeAction, ImeiShowAction, MoCallAction, UnlockAction, PbEntryShowAction, InputAction
  • IsExplicitCallTransferPermitted() : CallHdl
  • IsFastSmsLoadingSupported() : StackInterface
  • IsFdnActivated() : SimAccessor, DataHandler
  • IsFdnEnabled() : DataControlPhonebookStateMsg
  • IsFeatureSupported() : MmfPlayer, AudioDeviceBase
  • IsFilePackAvailable() : FilePackConnector
  • IsFilterSupported() : BtBipImagingCapabilities
  • IsFinal() : BtObexResponseCode, AtGenericCmdIndArg
  • IsFinished() : BtObexResponseCode, KeySequenceCandidate
  • IsFireBrigade() : EccCategory
  • IsFirstCell() : GridModel
  • IsFixedContext() : ContextFeatureItem
  • IsFlag() : UsimEstReadIndArg, UsimUstReadIndArg
  • IsFlipOpen() : FlipMsg, MnTriggerReqArg
  • IsFlowLabelPresent() : PdpContext::PacketFilter
  • IsFocusMsgProcessingBlocked() : MsgQueue
  • IsFocusPassingEnabled() : AbstractListBox
  • IsFontPackAvailable() : FontPackConnector
  • IsForbidden() : PlmnListEntry
  • IsForwardable() : DrmInfo
  • IsForwardedToCallingSubscriber() : SsNotification
  • IsForwardedToForwardedToSubscriber() : SsNotification
  • IsForwardedToForwardingSubscriber() : SsNotification
  • IsForwardLocked() : DrmInfo
  • IsFreePage() : HeapVector::VarPage, HeapVector::BlockPage
  • IsFullRefreshed() : SimEfRefresh
  • IsFullsized() : PositionIndicator
  • IsFullTraversingEnabled() : Image, GifImage, BmpImage
  • IsGlobalUsimPbExisting() : UsimPbLocReport
  • IsGprsAvailable() : AbstractSmsApp, CellInfoIndArg
  • IsGprsClassInvalid() : MmCoordParam
  • IsGprsFdnActivationCodePresent() : DataHandler
  • IsGprsSupported() : GprsParam
  • IsGreater() : Cell, DataItem
  • IsGreaterEqual() : DataItem
  • IsGroupDeletionNotificationSupported() : StackInterface
  • IsGsmBandInvalid() : MmCoordParam
  • IsHeaderEnabled() : TabControl
  • IsHeld() : MptyCallHdl, CallHdlBase, CallHdl
  • IsHfServiceSupported() : BtQuerySupportedProfilesRequest
  • IsHidden() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • IsHoldPermitted() : MptyCallHdl, CallHdlBase, CallHdl
  • IsHorizontal() : AbstractGrid::SmoothScrollInfo
  • IsHsHasRemoteVolumeControl() : BtHsSupportedProfileMessage
  • IsHsServiceSupported() : BtQuerySupportedProfilesRequest
  • IsIlluminationOn() : Keyboard
  • IsImageInitialized() : ImageRef
  • IsImmediateResponse() : DisplayTextReqArg
  • IsInactive() : DataConn
  • IsInCall() : BtHsService, BtHfService, BtAudioAccessoryService
  • IsInContext() : ExecutionContext
  • IsInDatabase() : MediaRefContainer
  • IsIndex() : Cbs, Cbs::SerialNumber
  • IsIndexVisible() : AbstractEditBoxModel
  • IsIndicatorFullsized() : GridModel
  • IsInForeground() : DeviceContext, Control
  • IsInfoRequested() : MenuSelectionReqArg
  • IsInHold() : DataConn
  • IsInitialized() : System, GenericAudioDevice, Protector, FlsFile, RamFile, FatFile
  • IsInOnlineMode() : MmCallInfo, MmCallHandler
  • IsInputValid() : TimeEditBox, DateEditBox, AbstractEditBox, AbstractEditBoxModel
  • IsInRange() : Provider, DataItem
  • IsInRelease() : DataConn
  • IsInRom() : MemoryConfig
  • IsInSeconds() : ValidityPeriod
  • IsInSetup() : DataConn, CallHdl, MmCallHdl
  • IsInside() : Rect, Point
  • IsInstanceOf() : Window, TimeEditor, TimeCompoundItem, TextLine, TextCompoundItem, TextBox, TabControl, TabButton, RadioButtonControl, RadioButtonAction, PushButton, ProgressBar, PositionIndicator, PasswordEditor, Panel, NativeImage, MultiLineEditor, MessageBox, LineEditor, ItemTree, ItemRendererProperties, ItemMenu, ItemGrid, ItemContainer, ItemBox, Item, IpAddrEditor, IpAddrCompoundItem, ImageBox, Image, GridLayout, FlowLayout, DrawableObject, DateEditor, DateCompoundItem, Control, ContextMenu, CompoundItem, Component, CheckBoxControl, CheckBoxAction, CharItem, AtomItem, AnimatedTextLine, Alert, Action, AbstractToggleAction, AbstractTextObject, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemGrid, AbstractItemContainer, AbstractGrid, AbstractEditorItem, AbstractEditor, AbstractButton, SoundItem, ActionExtension, ValueMappingPropertyDescriptor< T_Container >, PropertyItem, PropertyDescriptor, Property, ListPropertyDescriptor, AtlItemMenuWindow, AtlItemListWindow, AtlItemGridWindow, TriggerKeyFeature, ProviderProxyItem, ProviderProxyContainer, IndicatorItem, FeatureItemContainer, FeatureItem, Feature, ContextFeatureItem, ContextFeature, BackToIdleFeature, AtlWindow, SvgImage, WbmpImage, VCardItem, RichTextCompoundItem, PngImage, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditor, JpegImage, ImageItem, GifImage, GeneralCompoundItem, BoundedItem, BmpImage, AudioItem, AccessorActionExtension
  • IsInstanceValid() : Socket
  • IsInState() : ObexAbstractPort
  • IsInterlaced() : PngDecoder
  • IsInternalUpdate() : ParagraphCompoundItem
  • IsInUse() : SocketData, SmsSocketListener, SerialSocketData
  • IsInvalid() : IpAddrEditorDocument, PhoneNumber, ProviderProxyItem, ValidityPeriod, SimItemIdentifier, SimItemId, SimAtom< T >, ProtocolIdentifier, Plmn, BcdPlmn, MessageTypeIndicator, DataCodingScheme
  • IsInValidContext() : ObexDispatcher
  • IsIpSecSecurityParameterIndexPresent() : PdpContext::PacketFilter
  • IsIPv4() : PdpContext::Address
  • IsItalic() : InformationElement
  • IsJoinPermitted() : CallHdlBase
  • IsKnown() : BtDevice
  • IsLacInvalid() : CellParam, NeighbourCell, UmtsRrcScellParam
  • IsLanguageSupported() : Zi8Wrapper, ChineseT9Wrapper
  • IsLastCell() : GridModel
  • IsLastResult() : VrResultMsg
  • IsLater() : DateTime::Persist
  • IsLeapYear() : Date
  • IsLess() : Cell, DataItem, PhoneNumberMergeProvider, MergeProvider
  • IsLessEqual() : DataItem
  • IsLineBreak() : Os
  • IsLingerEnabled() : SocketPeer
  • IsListening() : ObexServerPort
  • IsLoadingAllowed() : BootControl
  • IsLocalIdValid() : DrmRightsObjectStore
  • IsLocked() : Keyboard, Display, HandlerData
  • IsLsaIdentifierPresent() : LsaIdentityMsg, MnInformationIndArg
  • IsMarineGuard() : EccCategory
  • IsMarked() : Item
  • IsMatchedByUrl() : ObexAbstractTransport
  • IsMatching() : PhoneNumber, Cbs::Filter
  • IsMaximized() : Control
  • IsMccInvalid() : CellParam, NeighbourCell
  • IsMeasIdInvalid() : UmtsMeasIdParam
  • IsMediaPresent() : RfsMediaAvailableStatusMsg
  • IsMenuInitialized() : FeatureBroker
  • IsMessageForMe() : HttpWapMgrPlugin, HttpWapMgrBase
  • IsMessageRegistered() : AppContainer
  • IsMidListFilterEnabled() : Cbs::Filter
  • IsMirrored() : AbstractGrid::SmoothScrollInfo
  • IsMmCall() : MmCallHandler
  • IsMncInvalid() : CellParam, NeighbourCell
  • IsMobileNetworkStarted() : PowerHandler
  • IsMobileOriginated() : CallHdl, Tpdu, MmCallHdl, MmCallHandler
  • IsMobileTerminated() : CallHdl, Tpdu, MmCallHdl, MmCallHandler
  • IsMocSetupPermitted() : InputContext
  • IsModeSupported() : PredInputMapper, Zi8InputMapper, EnglishT9InputMapper, ChineseT9InputMapper, AbstractPredictiveInputBox
  • IsMono() : HeadSet
  • IsMountainRescue() : EccCategory
  • IsMounted() : MainHandler
  • IsMptyMember() : CallHdl
  • IsMsTxPowerMaxCchInvalid() : CellParam
  • IsMultiKeyMode() : Keyboard
  • IsMultiLine() : ItemRendererProperties
  • IsMute() : AudioContext
  • IsNackBlocksInvalid() : AckNackCnt
  • IsNameAvailable() : StackMsgMapTableEntry, SignalMapTableEntry
  • IsNcoInvalid() : GprsParam
  • IsNetworkNameLongAddCi() : NetworkInformationMsg, MnInformationIndArg
  • IsNetworkNameShortAddCi() : NetworkInformationMsg, MnInformationIndArg
  • IsNetworkOpModeInvalid() : GprsParam
  • IsNoBlocksInvalid() : CiTestParam
  • IsNodeExisting() : NodeFileHandler
  • IsNoRfChansInvalid() : CellParam
  • IsNormalUsage() : ProtocolIdentifier
  • IsNotEqual() : DataItem
  • IsNotificationBlocked() : Item, Feature
  • IsNullStr() : WStrData, StrData
  • IsNumeric() : WString, String
  • IsObtained() : SemObtainer, MutexObtainer
  • IsOffsetInvalid() : TimeZone
  • IsOfInterest() : CbsFilterList
  • IsOfmToBeActivated() : SimAuxHandler
  • IsOfType() : BtJsr82Url::Token
  • IsOk() : ObexResult, BtObexResponseCode
  • IsOnSim() : PbNumberRecord
  • IsOpen() : Socket, InetSocket, Window, Control, VideoChannel, NonsharedBinDataDataSource, VideoChannel, FileOutputStream, FileInputStream, StringDataSink, HeapDataSource, HeapDataSink, DataSource, DataSink, BinDataDataSource, FileDataSource, FileDataSink, File, FlsFile, SerialSocket, SerialTerminalSocket, RootFileImp, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • IsOpenInMode() : File
  • IsOperationActive() : StreamObexImpl
  • IsOperationCompleted() : StreamingInfo
  • IsOperationCompletedSynchroneously() : StreamingInfo
  • IsOperationErroneous() : StreamingInfo
  • IsOperationFailed() : StreamingInfo
  • IsP1Invalid() : UmtsMeasEvalParam
  • IsP2Invalid() : UmtsMeasEvalParam
  • IsPacked() : ValidityPeriod, GetInputRspArg
  • IsPaging() : AbstractEditBoxModel
  • IsPaired() : BtDevice
  • IsPanelEnabled() : Desktop
  • IsParentWindowOpen() : Control
  • IsPartlyConcSmsStateChangeable() : SimPduHandler, DataHandler
  • IsPaServiceSupported() : BtQuerySupportedProfilesRequest
  • IsPasswordMode() : AbstractEditBoxModel
  • IsPathActive() : AudioPathManager
  • IsPbAvailable() : PhonebookApp, AdvPbApp
  • IsPbcchPresent() : GprsParam
  • IsPduDeleted() : MdhGors
  • IsPenaltyTimeInvalid() : CellParam
  • IsPhoneNumberTextDefaultData() : SmsBasicProvider, PhoneNumberMergeProvider
  • IsPhysicalPushEnabled() : WapProfile
  • IsPlayable() : DrmInfo
  • IsPlayOnceEnabled() : ImageBox
  • IsPlmnInvalid() : CellParam, NeighbourCell
  • IsPlmnSearchActive() : NRegStateIndArg
  • IsPlmnwactPresent() : SimAuxHandler
  • IsPng() : PngDecoder
  • IsPolice() : EccCategory
  • IsPortPtrValid() : ObexServerDispatcher
  • IsPositionIndicatorEnabled() : AbstractMultiLineEditor
  • IsPositionIndicatorLeftAligned() : AbstractMultiLineEditor, AbstractGrid
  • IsPositionIndicatorShown() : AbstractGrid, AbstractListBox
  • IsPowerOn() : DefaultDisplay, Display, DefaultDisplay
  • IsPredInputEnabled() : SmsSettingsRecord
  • IsPresentationAllowed() : PhoneNumber
  • IsPressed() : AbstractButton, RadioButtonItem
  • IsPreviewShown() : ImageBox
  • IsPreviousFrameBuffering() : Image
  • IsPrintable() : DrmInfo
  • IsProfileWriteable() : WapProfile
  • IsProgressMsgEnabled() : Image
  • IsProtocolNumberOrNextHeaderPresent() : PdpContext::PacketFilter
  • IsProvisionBitSet() : SsStatus
  • IsPScInvalid() : UmtsRrcScellParam
  • IsPsdCallActive() : MmCallHdl, MmCallHandler
  • IsPsi1RepeatPeriodInvalid() : GprsParam
  • IsPsiCountHrInvalid() : GprsParam
  • IsPsiCountLrInvalid() : GprsParam
  • IsPushEnabled() : WapProfile
  • IsQualityValid() : SignalStrengthLevelIndArg
  • IsQuiescentBitSet() : SsStatus
  • IsRacInvalid() : GprsParam, UmtsRrcScellParam
  • IsRankingValueInvalid() : NeighbourCell, UmtsNcellParam, UmtsRrcScellParam
  • IsRankPosInvalid() : NeighbourCell, UmtsNcellParam
  • IsRatChangePossible() : PlmnHandler, PlmnDispatcher
  • IsrDataContainer() : IsrDataContainer< Data, c_queue_size >
  • IsrDataMarshaller() : IsrDataMarshaller, IsrDataManager
  • IsReadOnly() : PhonebookWin, PbAbstractWin, DataConnProfileManager::ProfileInfo, DataConnProfile, AbstractEditor, File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • IsReady() : StorageDevice, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp, SimPbEntryCont
  • IsReadyForSendingSms() : AbstractSmsApp
  • IsRecordDeleted() : UibSettingsRecord, ToDoRecord, SmsSettingsRecord, CalendarRecord, PbNumberRecord, PbRecord, Record, DataRecordHandler
  • IsRecording() : StreamAudioPlayer
  • IsRedialStatus() : RedialStatusMsg, RedialStatusIndArg
  • IsRefreshed() : SimEfRefresh
  • IsRefreshPossible() : SimTkRefreshCnfReqArg, SimTkResetCnfReqArg
  • IsRegistered() : LookupAlphaIdExtension
  • IsRegistrationAllowed() : PlmnHandler
  • IsRegistrationBitSet() : SsStatus
  • IsRegStateInvalid() : MmCoordParam
  • IsRejected() : PlmnScanFinishedMsg
  • IsRelative() : ValidityPeriod
  • IsReleaseComplete() : SsUssdIndArg, SsCauseIndArg, SsErrIndArg, SsRejArg, SsRetResIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg
  • IsReloadInProgress() : SimPduHandler
  • IsReplyPathRequested() : SmsSettingsRecord
  • IsReqSent() : LcsAppUtils
  • IsRequestForMe() : ObexServerOppImpl, ObexServer
  • IsRequestGranted() : FatFsUsbMassStorageRequestMsg
  • IsRequestReplyPath() : AbstractSmsApp
  • IsRequestStatusReport() : AbstractSmsApp
  • IsRestricted() : AutoCallRestrictIndArg
  • IsResult() : PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg
  • IsRetranslateEnabled() : Item
  • IsRetrievePermitted() : MptyCallHdl, CallHdlBase, CallHdl
  • IsRightToLeftItem() : TextEditorDocument, EditorDocument, MultiMediaEditorDocument
  • IsRinging() : BtHsService, BtHfService, BtAudioAccessoryService
  • IsRllInvalid() : L1Param, CellParam
  • IsRoot() : MenuAccessor, AbstractMenuAccessor, Pathname
  • IsRowFiltered() : FilterProvider, DualFilterProvider
  • IsRowTitled() : Grid, GridModel
  • IsrPushData() : IsrDataContainer< Data, c_queue_size >
  • IsRTCStartUpEvent() : RealTimeClock
  • IsRunning() : UpdatePbThreadlet, SyncPhoneThreadlet, Application, AppContainer, AbstractAppContext, Server, FtpTransfer
  • IsRxlevAccessMinInvalid() : CellParam
  • IsRxlevFullInvalid() : CellParam
  • IsRxlevInvalid() : NeighbourCell
  • IsRxlevServInvalid() : CellParam
  • IsRxlevSubInvalid() : CellParam
  • IsRxqualFullInvalid() : CellParam
  • IsRxqualInvalid() : L1Param
  • IsRxqualSubInvalid() : CellParam
  • IsSame() : MptyCallHdl, CallHdl
  • IsSameType() : GenericObject
  • IsScanActive() : RegistrationChangeMsg
  • IsScanInProgress() : PlmnHandler
  • IsScoPathStatus() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • IsSecondary() : PdpContext
  • IsSecureClockValid() : RealTimeClock
  • IsSelectableCell() : GridModel
  • IsSelected() : RadioButtonControl, CheckBoxControl, AbstractToggleAction, CheckBoxItem, CheckBox, CheckBoxModel
  • IsSelector() : AbstractGrid::SmoothScrollInfo, AbstractListBox::SmoothScrollInfo
  • IsSelfExplanatory() : SimIconQualifier
  • IsSendingConfirmationEnabled() : SmsSettingsRecord
  • IsSendingSmsConfirmed() : AbstractSmsApp
  • IsSendPreviewMandatory() : SmsSettingsRecord
  • IsSeparateDelivered() : DrmInfo
  • IsSeparator() : TimeEditorDocument, Item, IpAddrEditorDocument, DateEditorDocument
  • IsServer() : ObexChannel
  • IsServerService() : BtObexService, BtObexServerService, BtObexClientService, BtBppService, BtBppServerService, BtBppClientService, BtBipServerService, BtBipClientService
  • IsServiceActivated() : SimCphsHandler
  • IsServiceAllocated() : SimCphsHandler
  • IsServiceAvailable() : AbstractSmsApp
  • IsServiceStateInvalid() : GmmParam, MmcsParam
  • IsServiceSupported() : ServiceBroker
  • IsSet() : BitField< T >
  • IsSetupPermitted() : CallHdl, MmCallHdl
  • IsShallTransmit() : MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg
  • IsShortMessageFailure() : SmsSendCnfArg
  • IsShutdownAllowed() : Application
  • IsShuttingDown() : ObexServerDispatcher
  • IsSi13Present() : GprsParam
  • IsSignalNameAvailable() : ProcessNode
  • IsSilentReset() : StartUp::Data
  • IsSimAccessAllowed() : SimPbBaseHandler, SimAccessor, DataHandler, BaseDataHandler
  • IsSimPbExisting() : UsimPbLocReport
  • IsSimPresent() : SimAccessor, DataHandler, BaseDataHandler
  • IsSimRefreshPossible() : SimAuxHandler, DataHandler
  • IsSimResetPossible() : SimAuxHandler, DataHandler
  • IsSimServiceEnabled() : SimServices, DataHandler
  • IsSimtkRelated() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • IsSingleShot() : ValidityPeriod, FunctionalityIndicator
  • IsSingleSrrPerSmsEnabled() : SmsContext
  • IsSmsComposeEnabled() : AbstractSmsApp
  • IsSmsFilterTypeMatch() : SimPduHandler
  • IsSortAsc() : UibSettingsRecord
  • IsSourceAddressAndSubnetMaskPresent() : PdpContext::PacketFilter
  • IsSourcePortRangePresent() : PdpContext::PacketFilter
  • IsSpaceLeftOnStorageMedia() : SimPduHandler
  • IsSplitPermitted() : MptyCallHdl
  • IsSplitPgCycle() : GprsParam
  • IsSsPending() : SsHandler
  • IsStandaloneCharacter() : VietnameseTextRenderer, ThaiTextRenderer, TextCompoundItem, AbstractTextRenderer
  • IsStandaloneItem() : AbstractMultiLineEditor, AbstractEditor
  • IsStartDtmfToneGenerationPermitted() : CallHdl
  • IsStarted() : AnimatedTextLine
  • IsStartOfSequence() : KeySequence
  • IsStateInvalid() : RrParam, MmCoordParam, GmmParam, MmcsParam
  • IsStatusReportEnabled() : SmsSettingsRecord
  • IsStatusReportOnIdleScreen() : SmsSettingsRecord
  • IsStereo() : AudioFmRadioRssiMsg
  • IsStopEncodingRequested() : ImageEncoder
  • IsStorable() : PhoneNumber
  • IsStorableMocPhoneNumber() : InputAnalyzer
  • IsStrikethrough() : InformationElement
  • IsSubstitutionNeeded() : SubstitutedText
  • IsSubSystemInitialized() : SimPduHandler
  • IsSuccess() : AudioFmRadioSeekMsg, OmMultiSlotIndMsg, OmMultiSlotIndArg
  • IsSuccessResponse() : ObexObject
  • IsSumCOverIInvalid() : CiTestParam
  • IsSupported() : VrHandler
  • IsSwapPermitted() : CallHdlBase
  • IsSwitch() : PagingMapEntry
  • IsSynchronized() : PbSynchronizer
  • IsSynchronizing() : PbSynchronizer
  • IsSyncModeEnabled() : Item
  • IsSyncSoftkeysEnabled() : Window
  • IsSystem() : RamFileObj
  • IsT3192Invalid() : GprsParam
  • IsT3212Invalid() : CellParam
  • IsT9PackAvailable() : T9PackConnector
  • IsTabbing() : MultiTapCaret
  • IsTabEnabled() : TabControl
  • IsTelematicDevice() : ProtocolIdentifier
  • IsTemporary() : DataConnProfileManager::ProfileInfo, File
  • IsTemporaryProfile() : DataConnProfileInfoMsg
  • IsTemporaryProfileId() : DataConnProfileManager
  • IsTerminatingResponse() : AtCommand
  • IsTest() : TestparamReqArg
  • IsText() : MimeCoder
  • IsTextByExt() : MimeTypeTable
  • IsTextByFileType() : FfsMimeTypeMap
  • IsTextByMimeStr() : MimeTypeTable
  • IsTextEditorDocument() : T9InputMapper
  • IsTextPackAvailable() : TextPackConnector
  • IsTimerExpired() : TimeoutCondition
  • IsTimerInvalid() : MmCoordParam, GmmParam, MmcsParam
  • IsTimeZonePresent() : MnInformationIndArg
  • IsTimingAdvanceInvalid() : L1Param, CellParam
  • IsTitleAnimated() : Window
  • IsTmpOffsetInvalid() : CellParam
  • IsTrafficAnnouncementSet() : AudioFmRadioRdsStationNameMsg
  • IsTrafficProgramSet() : AudioFmRadioRdsInfoMsg
  • IsTransparent() : Window, NativeImage, ItemRendererProperties, Image, Bitmap, BitmapRes, SvgImage, WbmpImage, PngImage, PngDecoder, GifImage
  • IsTremblerOn() : Audio
  • IsTrue() : BooleanCondition, Condition
  • IsTrusted() : BtDevice
  • IsTwinViewfinderEnabled() : Camera
  • IsTxPowerLevelInvalid() : L1Param, CellParam
  • IsTypeOfServiceAndMaskOrTrafficClassAndMaskPresent() : PdpContext::PacketFilter
  • IsUlUarfcnInvalid() : UmtsRrcScellParam
  • IsUnderlined() : InformationElement
  • IsUnique() : ObexChannel
  • IsUnlockingAllowedKeyBased() : SimChvHandler
  • IsUnlockingAllowedOnStartup() : SimChvHandler
  • IsUnlockingAllowedPerMenu() : SimChvHandler
  • IsUpdated() : MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, BootState
  • IsUpdateStatusInvalid() : GmmParam, MmcsParam
  • IsUpdating() : Provider
  • IsUpDownPermitted() : AbstractMultiLineEditor
  • IsUrlValid() : BtJsr82Url
  • IsUsbChargingEnabled() : Charger
  • IsUsed() : UsimPbGroups
  • IsUsimInserted() : SimAccessor, DataHandler, BaseDataHandler
  • IsValid() : PbNumberRecord, PbRecord, SysSocket, ObexTransportSet::Iterator, ObexOperationId, ObexObject, ObexHeaderList::ConstIterator, ObexHeader, ObexChannel, ObexBuffer, PagingMapEntry, Bitmap, StartUp::Data, BtObexServiceTable::ServiceInfo, BtSvrServiceRecord, BtSvrServiceAttribute, BtSvrDataElement, BtServiceVerifyResult, BtSddbServiceRecord, BtSddbServiceAttribute, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeByteBlockType, BtSddbDeBaseCType, BtSddbDataElement, SimpleMap< TKey, TValue >::Iterator, NiSharedPtr< X >, Date, RtStreamingBuffer, Fraction, SmsContext, PdpContext::Address, MptyCallHdl, CallHdlBase, CallHdl, UserDataHeader, Tpdu, SimAlphaIdentifier, ParameterIndicator, MessageIdentifierRange, InformationElement, DataCodingSchemeRange, BaseInformationElement, RootStorageDeviceIterator, StorageDeviceIterator, Pathname, DirectoryIterator, MmCallHdl, ClientId, TpduHeaderInformation, SimMexeCertificate, MexeDescriptor
  • IsValidAddress() : HeapManager
  • IsValidContext() : ObexServerOppImpl, ObexServerDispatcher, ObexEventHandler, ObexClientOppImpl, ObexClientDispatcher
  • IsValidHugeAddress() : HeapManager
  • IsValidPortPtr() : ObexClientDispatcher
  • IsValidSequence() : KeySequenceCandidate
  • IsVerticalCentered() : TextBox, ItemRendererProperties
  • IsVibratorOn() : VibratorDevice, Audio, AudioVibratorDevice
  • IsVisible() : DrawableObject, Caret, Indicator
  • IsVoiceMsgWaiting() : SimCphsHandler
  • IsVolume() : RamFileObj
  • IsWCharToGsm7Possible() : DataCoding
  • IsWhiteSpace() : Os
  • IsWritable() : ObexObject
  • IsWStringDataCached() : Provider, AbstractDelegationProvider, PbBaseProvider
  • IsZero() : DateTime::Persist, Date
  • Item() : Item
  • ItemBox() : ItemBox
  • ItemBoxView() : ItemBoxView
  • ItemContainer() : ItemContainer
  • ItemCount() : MenuTextPtrArrayIterator, MenuTextIterator
  • ItemGrid() : ItemGrid
  • ItemLabel() : ItemLabel
  • ItemLabelView() : ItemLabelView
  • ItemMenu() : ItemMenu
  • ItemObj() : ItemObj
  • ItemPropertiesChangedMsg() : ItemPropertiesChangedMsg
  • ItemRendererProperties() : ItemRendererProperties
  • ItemRendererPropertiesChangedMsg() : ItemRendererPropertiesChangedMsg
  • ItemSelected() : SimTkHandler
  • ItemTree() : ItemTree
  • Iterate() : ObexServerMngr
  • Iterator() : ObexTransportSet::Iterator, DeviceManager::Iterator, Vector< T >::Iterator, SimpleMap< TKey, TValue >::Iterator, Pathname::Iterator, DeviceManager, Vector< T >, SimpleMap< TKey, TValue >
Generated on Wed Jan 25 00:54:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- p -

  • PackedTimePeriod() : PackedTimePeriod
  • PacketFilter() : PdpContext::PacketFilter
  • PackUserInput() : SimGetInputOptions
  • PackWcharsToSeptets() : DataCoding
  • PaintDc() : PaintDc
  • Pan() : SvgPlayer, SvgImage
  • Panel() : Panel
  • PanelPassthroughRequest() : BtAvrcpOperationService
  • PanelView() : PanelView
  • PaneObject() : PaneObject
  • ParagraphCompoundItem() : ParagraphCompoundItem
  • ParagraphMarker() : ParagraphMarker
  • ParameterIndicator() : ParameterIndicator
  • Parse() : EmsIeParser, AbstractIMelodyParser, XMLParser, MultipartParser, XmlParserRel, DrmRelParser
  • ParseDateString() : XmlParserRel
  • ParseInterval() : XmlParserRel
  • ParseNumber() : InputAction
  • ParseTarget() : ObexUrlStrParser
  • ParseWbxmlRel() : DrmRelParser
  • ParseXmlRel() : DrmRelParser
  • Partition() : MimeTypeTable::Partition, MimeTypeTable
  • PassBackFocusMsg() : MsgQueue
  • PasswordChangeSsAction() : PasswordChangeSsAction
  • PasswordEditor() : PasswordEditor
  • PasswordInquiryMsg() : PasswordInquiryMsg
  • PasswordReceivedMsg() : PasswordReceivedMsg
  • PasswordRejectedMsg() : PasswordRejectedMsg
  • Path() : Path, PathProfile
  • Pathname() : Pathname, Pathname::ReverseIterator, Pathname::Iterator
  • PathProfile() : PathProfile
  • Pause() : MediaPlayer, ResultWinBase
  • PauseRecord() : VoiceMemoWin, VoiceMemoRecordWin, MediaRecorder
  • PauseRecording() : VoiceMemoApp
  • PauseVideoCapture() : VideoCamera
  • PbAbstractWin() : PbAbstractWin, PhonebookApp
  • PbAction() : PbAction
  • PbAdvAddEditEntry() : PbAdvAddEditEntry
  • PbAdvDataHandler() : PbAdvDataHandler
  • PbAdvDetailAction() : PbAdvDetailAction
  • PbAdvDetails() : PbAdvDetails
  • PbAlphaTagRequestMsg() : PbAlphaTagRequestMsg
  • PbBaseProvider() : PbBaseProvider
  • PbBaseWin() : PbBaseWin
  • PbCopyHandler() : PbCopyHandler
  • PbCountIndArg() : PbCountIndArg
  • PbCountReqArg() : PbCountReqArg
  • PbDataHandler() : PbDataHandler
  • PbDetailAction() : PbDetailAction
  • PbDetailEditBox() : PbDetailEditBox
  • PbDetailListBox() : PbDetailListBox
  • PbDetailListBoxModel() : PbDetailListBoxModel
  • PbDetailProvider() : PbDetailProvider
  • PbDetails() : PbDetails
  • PbEntryReadIndArg() : PbEntryReadIndArg
  • PbEntryReadReqArg() : PbEntryReadReqArg
  • PbEntryRequestMsg() : PbEntryRequestMsg
  • PbEntryShowAction() : PbEntryShowAction
  • PbEntryUpdIndArg() : PbEntryUpdIndArg
  • PbEntryUpdReqArg() : PbEntryUpdReqArg
  • PbFfsNameHandler() : PbFfsNameHandler
  • PbFfsNumberHandler() : PbFfsNumberHandler
  • PbInfoReadIndArg() : PbInfoReadIndArg
  • PbInfoReadReqArg() : PbInfoReadReqArg
  • PbLazySynchronizer() : PbLazySynchronizer
  • PbManualSynchronizer() : PbManualSynchronizer
  • PbMergeProvider() : PbMergeProvider
  • PbNameEditBox() : PbNameEditBox
  • PbNameFilterProvider() : PbNameFilterProvider
  • PbNameHandler() : PbNameHandler
  • PbNameNumberProvider() : PbNameNumberProvider
  • PbNameProvider() : PbNameProvider
  • PbNextFreeIdRecord() : PbNextFreeIdRecord
  • PbNumberFilterProvider() : PbNumberFilterProvider
  • PbNumberHandler() : PbNumberHandler
  • PbNumberProvider() : PbNumberProvider
  • PbNumberRecord() : PbNumberRecord
  • PbNvRamNameHandler() : PbNvRamNameHandler
  • PbNvRamNumberHandler() : PbNvRamNumberHandler
  • PbPhoneNumberPrompt() : PbPhoneNumberPrompt
  • PbProvColListBoxModel() : PbProvColListBoxModel
  • PbProviderListener() : PbProviderListener
  • PbProvListBox() : PbProvListBox
  • PbProvListBoxModel() : PbProvListBoxModel
  • PbRecord() : PbRecord
  • PbRecordHandler() : PbRecordHandler
  • PbRecordProvider() : PbRecordProvider
  • PbSecuredAction() : PbSecuredAction
  • PbSelectGroup() : PbSelectGroup
  • PbSelectNoType() : PbSelectNoType
  • PbSelectNumberWin() : PbSelectNumberWin
  • PbSimProvider() : PbSimProvider
  • PbSizeRequestMsg() : PbSizeRequestMsg
  • PbSortedProvider() : PbSortedProvider
  • PbSynchronizer() : PbSynchronizer
  • PbToggleAction() : PbToggleAction
  • PdpContextActivationStatusMsg() : PdpContextActivationStatusMsg
  • PdpContextControl() : PdpContextControl
  • PdpContextErrorCause() : EnumTranslationTable
  • PdpContextManagerControl() : PdpContextManagerControl
  • PdpContextManagerState() : EnumTranslationTable
  • PdpContextOrigin() : EnumTranslationTable
  • PdpContextState() : EnumTranslationTable
  • Peek() : FileInputStream, RegBlobObject, BlobObject
  • Pen() : Pen
  • PenDownMsg() : PenDownMsg
  • PenUpMsg() : PenUpMsg
  • PerformConnectControllerCall() : BtConnectRequest
  • PerformDisconnectControllerCall() : BtDisconnectRequest
  • PerformExecutionCallback() : BtController
  • Persist() : PathProfile::Persist, IpAddr
  • PersistDataConnProfile() : PersistDataConnProfile, DataConnProfile
  • PhonebookApp() : PhonebookApp
  • PhonebookRenumberedMsg() : PhonebookRenumberedMsg
  • PhonebookWin() : PhonebookWin
  • PhoneNumber() : PhoneNumber, InputMapper
  • PhoneNumberInputMapper() : PhoneNumberInputMapper
  • PhoneNumberJoinRule() : PhoneNumberJoinRule
  • PhoneNumberMatchRule() : PhoneNumberMatchRule
  • PhoneNumberMergeProvider() : PhoneNumberMergeProvider
  • PidInterworking() : EnumTranslationTable
  • PIHandler() : XMLParser
  • PinAction() : PinAction
  • PinDisableIndArg() : PinDisableIndArg
  • PinDisableReqArg() : PinDisableReqArg
  • PinEnableIndArg() : PinEnableIndArg
  • PinEnableReqArg() : PinEnableReqArg
  • PlanesMode() : DisplayConfig
  • Play() : SoundItem, Sound, PreparedSound, Melody, MP3AudioPlayer, MmfPlayer, AudioDeviceManager, MapiAudioPlayer, SvgPlayer, MediaPlayer
  • Play_Allocate() : DwdDevice, AudioVibratorDevice, MapiAudioPlayer
  • Play_Allocate_DWD() : DwdDevice
  • PlaySelectedSound() : SoundBrowserWin
  • PlaySound() : AudioContext
  • PlayTemplate() : VrHandler
  • PlayToneReqArg() : PlayToneReqArg
  • PlayToneRspArg() : PlayToneRspArg
  • Plmn() : Plmn
  • PlmnDispatcher() : PlmnDispatcher
  • PlmnHandler() : PlmnHandler
  • PlmnInfoReqArg() : PlmnInfoReqArg
  • PlmnListAbortArg() : PlmnListAbortArg
  • PlmnListCnfArg() : PlmnListCnfArg
  • PlmnListEntry() : PlmnListEntry
  • PlmnListRejArg() : PlmnListRejArg
  • PlmnListReqArg() : PlmnListReqArg
  • PlmnProvider() : PlmnProvider
  • PlmnRatDispatcher() : PlmnRatDispatcher
  • PlmnScanDispatcher() : PlmnScanDispatcher
  • PlmnScanFinishedMsg() : PlmnScanFinishedMsg
  • PngDecoder() : PngDecoder
  • PngEncoder() : PngEncoder
  • PngEncodingThreadlet() : PngEncodingThreadlet
  • PngImage() : PngImage
  • PngLibraryFreeFunction() : PngDecoder
  • PngLibraryMallocFunction() : PngDecoder
  • PngLibraryReadFunction() : PngDecoder
  • PnnEntry() : PnnEntry
  • Point() : Point
  • Poke() : RegBlobObject, BlobObject
  • Pop() : FifoLinkedList< T >
  • PopAll() : EmzUtils::Queue< T >
  • PopBack() : EmzUtils::Queue< T >, BtDeviceList, Vector< T >, LinkedListBase, TextIconPairArray, DeletedNodeList
  • PopFront() : EmzUtils::Queue< T >, BtDeviceList, LinkedListBase
  • PortHeaderInformation() : PortHeaderInformation
  • PositionIndicator() : PositionIndicator
  • PositionIndicatorView() : PositionIndicatorView
  • Post() : MessageRouter, Message, Application
  • PostAbortResponse() : LcsCommonSignalProcessor
  • PostAcmMaxReadInd() : CommonSignalProcessor
  • PostAcmMaxUpdInd() : CommonSignalProcessor
  • PostAcmReadInd() : CommonSignalProcessor
  • PostAcmUpdInd() : CommonSignalProcessor
  • PostAocInd() : CommonSignalProcessor
  • PostAtAccessoryRegisterReq() : CommonSignalProcessor
  • PostAtAlphaTagReq() : CommonSignalProcessor
  • PostAtGenericCmdReq() : CommonSignalProcessor
  • PostAtKeyReq() : CommonSignalProcessor
  • PostAtPbListReq() : CommonSignalProcessor
  • PostAtPbSelectReq() : CommonSignalProcessor
  • PostAttachAllowedInd() : CommonSignalProcessor
  • PostAttachCnf() : CommonSignalProcessor
  • PostAttachRej() : CommonSignalProcessor
  • PostAudDriverRsp() : CommonSignalProcessor
  • PostAudioUserDefinedMessage() : AudioDeviceManager
  • PostAutoCallRestrictInd() : CommonSignalProcessor
  • PostBandCnf() : CommonSignalProcessor
  • PostBandRej() : CommonSignalProcessor
  • PostBatteryLoadLevelInd() : ChargerSignalProcessor
  • PostBdnInd() : CommonSignalProcessor
  • PostBrowserTermRes() : CommonSignalProcessor
  • PostCallControlSetupInd() : CommonSignalProcessor
  • PostCallControlSsInd() : CommonSignalProcessor
  • PostCallControlUssdInd() : CommonSignalProcessor
  • PostCallDeflectionInd() : CommonSignalProcessor
  • PostCallDiscInd() : CommonSignalProcessor
  • PostCallHoldCnf() : CommonSignalProcessor
  • PostCallHoldRej() : CommonSignalProcessor
  • PostCallProgressInd() : CommonSignalProcessor
  • PostCallRelatedSsCnf() : CommonSignalProcessor
  • PostCallRelatedSsRej() : CommonSignalProcessor
  • PostCallRelCnf() : CommonSignalProcessor
  • PostCallRelInd() : CommonSignalProcessor
  • PostCbmiReadInd() : CommonSignalProcessor
  • PostCbmirReadInd() : CommonSignalProcessor
  • PostCbmirUpdInd() : CommonSignalProcessor
  • PostCbmiUpdInd() : CommonSignalProcessor
  • PostCbsLimitInd() : CommonSignalProcessor
  • PostCbsNewDataInd() : CommonSignalProcessor
  • PostCbsStartCnf() : CommonSignalProcessor
  • PostCbsStartRej() : CommonSignalProcessor
  • PostCbsStopCnf() : CommonSignalProcessor
  • PostCbsStopRej() : CommonSignalProcessor
  • PostCcpReadInd() : CommonSignalProcessor
  • PostCcpUpdInd() : CommonSignalProcessor
  • PostCellInfoInd() : CommonSignalProcessor
  • PostCfuDataInd() : CommonSignalProcessor
  • PostChargeInd() : CommonSignalProcessor
  • PostChargeUnitsInd() : CommonSignalProcessor
  • PostChargingBatteryInd() : ChargerSignalProcessor
  • PostChargingPausedInd() : ChargerSignalProcessor
  • PostChargingResumedInd() : ChargerSignalProcessor
  • PostChv1DisableInd() : CommonSignalProcessor
  • PostChv1EnableInd() : CommonSignalProcessor
  • PostChvChangeInd() : CommonSignalProcessor
  • PostChvRefreshInd() : CommonSignalProcessor
  • PostChvUnblockInd() : CommonSignalProcessor
  • PostChvVerifyInd() : CommonSignalProcessor
  • PostClearBlacklistCnf() : CommonSignalProcessor
  • PostCmiReadInd() : CommonSignalProcessor
  • PostConnectionInd() : CommonSignalProcessor
  • PostCphsCfufReadInd() : CommonSignalProcessor
  • PostCphsCfufUpdInd() : CommonSignalProcessor
  • PostCphsCspReadInd() : CommonSignalProcessor
  • PostCphsCspUpdInd() : CommonSignalProcessor
  • PostCphsIstReadInd() : CommonSignalProcessor
  • PostCphsOnmReadInd() : CommonSignalProcessor
  • PostCphsOnsReadInd() : CommonSignalProcessor
  • PostCphsVmwfReadInd() : CommonSignalProcessor
  • PostCphsVmwfUpdInd() : CommonSignalProcessor
  • PostDataConnControlMsg() : DataConn
  • PostDetachCnf() : CommonSignalProcessor
  • PostDiagnosticInd() : CommonSignalProcessor
  • PostDisplayTextReq() : CommonSignalProcessor
  • PostDtmfBufferClearedInd() : CommonSignalProcessor
  • PostEccListInd() : CommonSignalProcessor
  • PostEctCnf() : CommonSignalProcessor
  • PostEmptyBatteryInd() : ChargerSignalProcessor
  • PostEndSimToolkitInd() : CommonSignalProcessor
  • PostEngineeringModeControlResponse() : CommonSignalProcessor
  • PostExtProactiveCmdInd() : CommonSignalProcessor
  • PostFdnInd() : CommonSignalProcessor
  • PostFocusTransferMsg() : MessageRouter
  • PostFromStackMsg() : StackMsgProcessor
  • PostGetInkeyReq() : CommonSignalProcessor
  • PostGetInputReq() : CommonSignalProcessor
  • PostGetTermProfileCnfInd() : CommonSignalProcessor
  • PostGprsClassInd() : CommonSignalProcessor
  • PostHomezoneInd() : CommonSignalProcessor
  • PostIconDescReadInd() : CommonSignalProcessor
  • PostImageReadInd() : CommonSignalProcessor
  • PostImeiReadInd() : CommonSignalProcessor
  • PostInfoMsg() : PsdDataConn, DataConn, CsdDataConn
  • PostIpdsReleaseCnf() : DataCallSignalProcessor
  • PostIpdsReleaseInd() : DataCallSignalProcessor
  • PostIpdsSetupCnf() : DataCallSignalProcessor
  • PostIpdsSetupRej() : DataCallSignalProcessor
  • PostItemChangedMsg() : SyncMLManager
  • PostKbdtControl() : CommonSignalProcessor
  • PostKeyMsg() : Keyboard
  • PostLanguageNotificationInd() : CommonSignalProcessor
  • PostLanguageSettingReq() : CommonSignalProcessor
  • PostLaunchBrowserPromptReq() : CommonSignalProcessor
  • PostLaunchBrowserReq() : CommonSignalProcessor
  • PostLedStreamStatus() : LedSignalProcessor
  • PostLocationError() : SaSignalProcessor
  • PostLowBatteryInd() : ChargerSignalProcessor
  • PostMdhDeregistrationCnf() : CommonSignalProcessor
  • PostMdhMakeViewCnf() : CommonSignalProcessor
  • PostMdhNewMessageInd() : CommonSignalProcessor
  • PostMdhNewStatusReportInd() : CommonSignalProcessor
  • PostMdhRegistrationCnf() : CommonSignalProcessor
  • PostMdhRemoveViewCnf() : CommonSignalProcessor
  • PostMdhSetConfigCnf() : CommonSignalProcessor
  • PostMdhSetStorageCnf() : CommonSignalProcessor
  • PostMdhSmsConcRefNumInd() : CommonSignalProcessor
  • PostMdhSmsDeletionInd() : CommonSignalProcessor
  • PostMdhSmsExtendedDataInd() : CommonSignalProcessor
  • PostMdhSmsInitFinishedInd() : CommonSignalProcessor
  • PostMdhSmsReadInd() : CommonSignalProcessor
  • PostMdhSmsRefreshInd() : CommonSignalProcessor
  • PostMdhSmsReportReadInd() : CommonSignalProcessor
  • PostMdhSmsStatusInd() : CommonSignalProcessor
  • PostMdhSmsStorageRefreshInd() : CommonSignalProcessor
  • PostMdhSmsTransmitInd() : CommonSignalProcessor
  • PostMdhSmsTransmitStartInd() : CommonSignalProcessor
  • PostMdhSmsTransmitStopInd() : CommonSignalProcessor
  • PostMdhSmsUpdStatusInd() : CommonSignalProcessor
  • PostMdhSmsUpdStatusRefreshInd() : CommonSignalProcessor
  • PostMdhSmsWaitingInd() : CommonSignalProcessor
  • PostMdhSmsWriteCnf() : CommonSignalProcessor
  • PostMeasurementData() : GltpSignalProcessor
  • PostMenuSelectionRej() : CommonSignalProcessor
  • PostMessage() : ExternalCommunicationHandler, SignalMapTable, SignalHandler
  • PostMinuteTickInd() : RtcSignalProcessor
  • PostMnInformationInd() : CommonSignalProcessor
  • PostMocAlertInd() : CommonSignalProcessor
  • PostMocSetupAcc() : CommonSignalProcessor
  • PostMocSetupCnf() : CommonSignalProcessor
  • PostMocSetupRej() : CommonSignalProcessor
  • PostMolrResult() : SaSignalProcessor, LcsSignalProcessor
  • PostMptyCnf() : CommonSignalProcessor
  • PostMsg() : MainHandler
  • PostMtcAcceptRej() : CommonSignalProcessor
  • PostMtcConfInd() : CommonSignalProcessor
  • PostMtcSetupCompl() : CommonSignalProcessor
  • PostMtcSetupInd() : CommonSignalProcessor
  • PostMtlrIndReceived() : LcsSignalProcessor
  • PostNotification() : DataControl
  • PostNotifyInd() : CommonSignalProcessor
  • PostNRegStateInd() : CommonSignalProcessor
  • PostODyn2ReadInd() : CommonSignalProcessor
  • PostODyn2UpdInd() : CommonSignalProcessor
  • PostODynReadInd() : CommonSignalProcessor
  • PostODynUpdInd() : CommonSignalProcessor
  • PostOmBandStatusCnf() : CommonSignalProcessor
  • PostOmControlInd() : CommonSignalProcessor
  • PostOmMultiSlotCnf() : CommonSignalProcessor
  • PostOmMultiSlotRej() : CommonSignalProcessor
  • PostOmRatChangeCnf() : CommonSignalProcessor
  • PostOmRatChangeInd() : CommonSignalProcessor
  • PostPbCountInd() : CommonSignalProcessor
  • PostPbEntryReadInd() : CommonSignalProcessor
  • PostPbEntryUpdInd() : CommonSignalProcessor
  • PostPbInfoReadInd() : CommonSignalProcessor
  • PostPinDisableInd() : CommonSignalProcessor
  • PostPinEnableInd() : CommonSignalProcessor
  • PostPlayToneReq() : CommonSignalProcessor
  • PostPlmnListCnf() : CommonSignalProcessor
  • PostPlmnListRej() : CommonSignalProcessor
  • PostPowerDownCnf() : CommonSignalProcessor
  • PostPowerDownInd() : CommonSignalProcessor
  • PostPrefExtLangReadInd() : CommonSignalProcessor
  • PostPrefExtLangUpdInd() : CommonSignalProcessor
  • PostPrefLangReadInd() : CommonSignalProcessor
  • PostPrefLangUpdInd() : CommonSignalProcessor
  • PostPuctReadInd() : CommonSignalProcessor
  • PostPuctUpdInd() : CommonSignalProcessor
  • PostRedialInd() : CommonSignalProcessor
  • PostRedialQueryInd() : CommonSignalProcessor
  • PostRedialSetupInd() : CommonSignalProcessor
  • PostRedialStatusInd() : CommonSignalProcessor
  • PostRedialStopInd() : CommonSignalProcessor
  • PostRegStateInd() : CommonSignalProcessor
  • PostRemoveChargerInd() : ChargerSignalProcessor
  • PostResponse() : ObexDataServer
  • PostRtcEventInd() : RtcSignalProcessor
  • PostRtcNotValidInd() : RtcSignalProcessor
  • PostSelectItemReq() : CommonSignalProcessor
  • PostSetTermProfileCnfInd() : CommonSignalProcessor
  • PostSetTermProfileRejInd() : CommonSignalProcessor
  • PostSetupEventReq() : CommonSignalProcessor
  • PostSetupIdleModeTextReq() : CommonSignalProcessor
  • PostSetupMenuReq() : CommonSignalProcessor
  • PostSignalStrengthLevelInd() : CommonSignalProcessor
  • PostSimErrorInd() : CommonSignalProcessor
  • PostSimFileInfoInd() : CommonSignalProcessor
  • PostSimFullAccessInd() : CommonSignalProcessor
  • PostSimGenericInd() : CommonSignalProcessor
  • PostSimInfoInd() : CommonSignalProcessor
  • PostSimInitInd() : CommonSignalProcessor
  • PostSimLockStatusInd() : CommonSignalProcessor
  • PostSimMccMncInd() : CommonSignalProcessor
  • PostSimModifyLockInd() : CommonSignalProcessor
  • PostSimMruPropertyRefreshInd() : CommonSignalProcessor
  • PostSimMruPropertyUpdCnf() : CommonSignalProcessor
  • PostSimRefreshInd() : CommonSignalProcessor
  • PostSimTkCallSetupInd() : CommonSignalProcessor
  • PostSimTkInterfaceInd() : CommonSignalProcessor
  • PostSimTkRefreshCnfReq() : CommonSignalProcessor
  • PostSimTkRefreshNewReq() : CommonSignalProcessor
  • PostSimTkRefreshQueryReq() : CommonSignalProcessor
  • PostSimTkRefreshReq() : CommonSignalProcessor
  • PostSimTkRefreshResetReq() : CommonSignalProcessor
  • PostSimTkResetCnf() : CommonSignalProcessor
  • PostSimTkResetCnfReq() : CommonSignalProcessor
  • PostSimTkRunAtCmdInfoInd() : CommonSignalProcessor
  • PostSimTkSendDtmfEndInd() : CommonSignalProcessor
  • PostSimTkSendDtmfInd() : CommonSignalProcessor
  • PostSimTkSmsPpInd() : CommonSignalProcessor
  • PostSimTkSsInd() : CommonSignalProcessor
  • PostSmsCapacityAvailable() : CommonSignalProcessor
  • PostSmsCapacityExceeded() : CommonSignalProcessor
  • PostSmsControlInd() : CommonSignalProcessor
  • PostSmsGetMoreMessageStatusInd() : CommonSignalProcessor
  • PostSmsrReadInd() : CommonSignalProcessor
  • PostSmsrUpdInd() : CommonSignalProcessor
  • PostSmsSendCnf() : CommonSignalProcessor
  • PostSmsSendRej() : CommonSignalProcessor
  • PostSocketControlMsg() : DataConn
  • PostSpnReadInd() : CommonSignalProcessor
  • PostSsBarringInd() : CommonSignalProcessor
  • PostSsBeginAcc() : CommonSignalProcessor
  • PostSsCauseInd() : CommonSignalProcessor
  • PostSsCcbsReCallInd() : CommonSignalProcessor
  • PostSsCcbsResultInd() : CommonSignalProcessor
  • PostSsCcbsStatusInd() : CommonSignalProcessor
  • PostSsClientRej() : CommonSignalProcessor
  • PostSsDataInd() : CommonSignalProcessor
  • PostSsEndInd() : CommonSignalProcessor
  • PostSsErrInd() : CommonSignalProcessor
  • PostSsFacilityRej() : CommonSignalProcessor
  • PostSsForwardingInd() : CommonSignalProcessor
  • PostSsForwcheckInd() : CommonSignalProcessor
  • PostSsGetPasswordInd() : CommonSignalProcessor
  • PostSsGetPasswordRej() : CommonSignalProcessor
  • PostSsInterrogateInd() : CommonSignalProcessor
  • PostSsNotifyInd() : CommonSignalProcessor
  • PostSsPasswordInd() : CommonSignalProcessor
  • PostSsRej() : CommonSignalProcessor
  • PostSsRetResInd() : CommonSignalProcessor
  • PostSstReadInd() : CommonSignalProcessor
  • PostSsUnstructInd() : CommonSignalProcessor
  • PostSsUssdInd() : CommonSignalProcessor
  • PostSsUssdResentInd() : CommonSignalProcessor
  • PostStartDtmfCnf() : CommonSignalProcessor
  • PostStartDtmfRej() : CommonSignalProcessor
  • PostStopChargingBatteryInd() : ChargerSignalProcessor
  • PostStopDtmfCnf() : CommonSignalProcessor
  • PostTermRspCnf() : CommonSignalProcessor
  • PostTestparamInd() : CommonSignalProcessor
  • PostToStackMsg() : MainHandler
  • PostUrrcSignalStrengthLevelInd() : CommonSignalProcessor
  • Power() : LcsUtils
  • PowerDispatcher() : PowerDispatcher
  • PowerDown() : ShutDown, PowerHandler
  • PowerDownCnfArg() : PowerDownCnfArg
  • PowerDownDispatcher() : PowerDownDispatcher
  • PowerDownIndArg() : PowerDownIndArg
  • PowerDownReqArg() : PowerDownReqArg
  • PowerHandler() : PowerHandler
  • PowerModeIndMsg() : PowerModeIndMsg
  • PowerOffMsg() : PowerOffMsg
  • PowerOnMsg() : PowerOnMsg
  • PowerUp() : PowerHandler
  • PowerWakeupMsg() : PowerWakeupMsg
  • PppDataConn() : PppDataConn, SysSocket
  • PppFrame() : PppFrame
  • PreAlloc() : WString, String, ByteBuffer
  • PredefinedEmsImage() : PredefinedEmsImage
  • PredefinedEmsSound() : PredefinedEmsSound
  • PredInputMapper() : PredInputMapper
  • PrefExtLangProvider() : PrefExtLangProvider
  • PrefLangProvider() : PrefLangProvider
  • PrefPlmnChangeArg() : PrefPlmnChangeArg
  • PrefPlmnProvider() : PrefPlmnProvider
  • PrefServiceSetReqArg() : PrefServiceSetReqArg
  • PreparedSound() : PreparedSound
  • PrepareRename() : File
  • PrepareRequestExecution() : BtSingleConnectionController, BtMultiConnectionController, BtConnectionlessController
  • PresentationAsNavigationOptions() : SimSelectItemOptions
  • PresentationTypeAvailable() : SimSelectItemOptions
  • PresetAudioReference() : PresetAudioReference
  • Previous() : WindowHierarchyIterator
  • PrioritizePlayer() : AudioPlayerStore
  • private_implementation() : emcpp_apoxi_OBEXAdapter, apoxi_emcpp_OBEXAdapter
  • ProblemCode() : TaggedProblemCode, EnumTranslationTable
  • ProblemTag() : TaggedProblemCode, EnumTranslationTable
  • ProcessAbortReq() : LcsCommonMsgProcessor
  • ProcessAcmMaxReadReq() : CommonStackMsgProcessor
  • ProcessAcmMaxUpdReq() : CommonStackMsgProcessor
  • ProcessAcmReadReq() : CommonStackMsgProcessor
  • ProcessAcmUpdReq() : CommonStackMsgProcessor
  • ProcessAtAccessoryNotificationInd() : CommonStackMsgProcessor
  • ProcessAtAccessoryRegisterCnf() : CommonStackMsgProcessor
  • ProcessAtAlphaTagCnf() : CommonStackMsgProcessor
  • ProcessAtGenericCmdInd() : CommonStackMsgProcessor
  • ProcessAtPbInfoInd() : CommonStackMsgProcessor
  • ProcessAtPbListCnf() : CommonStackMsgProcessor
  • ProcessAtPbSelectCnf() : CommonStackMsgProcessor
  • ProcessAttachReq() : CommonStackMsgProcessor
  • ProcessBandSelectionReq() : CommonStackMsgProcessor
  • ProcessBdnReq() : CommonStackMsgProcessor
  • ProcessBrowserRegisterReq() : CommonStackMsgProcessor
  • ProcessBrowserTermEvent() : CommonStackMsgProcessor
  • ProcessCallDeflectRequest() : CallDeflectionHandler
  • ProcessCallDeflectSsReq() : CommonStackMsgProcessor
  • ProcessCallDiscReq() : CommonStackMsgProcessor
  • ProcessCallRelatedSsReq() : CommonStackMsgProcessor
  • ProcessCbmiReadReq() : CommonStackMsgProcessor
  • ProcessCbmirReadReq() : CommonStackMsgProcessor
  • ProcessCbmirUpdReq() : CommonStackMsgProcessor
  • ProcessCbmiUpdReq() : CommonStackMsgProcessor
  • ProcessCbsNewDataRej() : CommonStackMsgProcessor
  • ProcessCbsStartReq() : CommonStackMsgProcessor
  • ProcessCbsStopReq() : CommonStackMsgProcessor
  • ProcessCcpReadReq() : CommonStackMsgProcessor
  • ProcessCcpUpdReq() : CommonStackMsgProcessor
  • ProcessChargeReq() : CommonStackMsgProcessor
  • ProcessChargeUnitsReq() : CommonStackMsgProcessor
  • ProcessChv1DisableReq() : CommonStackMsgProcessor
  • ProcessChv1EnableReq() : CommonStackMsgProcessor
  • ProcessChvChangeReq() : CommonStackMsgProcessor
  • ProcessChvUnblockReq() : CommonStackMsgProcessor
  • ProcessChvVerifyReq() : CommonStackMsgProcessor
  • ProcessClearBlacklistReq() : CommonStackMsgProcessor
  • ProcessClientDeregistration() : CommonStackMsgProcessor
  • ProcessClientRegistration() : CommonStackMsgProcessor
  • ProcessCmiReadReq() : CommonStackMsgProcessor
  • ProcessControlHwDataOnlyReq() : CommonStackMsgProcessor
  • ProcessCphsCfufReadReq() : CommonStackMsgProcessor
  • ProcessCphsCfufUpdReq() : CommonStackMsgProcessor
  • ProcessCphsCspReadReq() : CommonStackMsgProcessor
  • ProcessCphsCspUpdReq() : CommonStackMsgProcessor
  • ProcessCphsIstReadReq() : CommonStackMsgProcessor
  • ProcessCphsOnmReadReq() : CommonStackMsgProcessor
  • ProcessCphsOnsReadReq() : CommonStackMsgProcessor
  • ProcessCphsVmwfReadReq() : CommonStackMsgProcessor
  • ProcessCphsVmwfUpdReq() : CommonStackMsgProcessor
  • ProcessDetachReq() : CommonStackMsgProcessor
  • ProcessDhChannelChangeStatusEvent() : CommonStackMsgProcessor
  • ProcessDhChannelCloseInd() : CommonStackMsgProcessor
  • ProcessDhChannelDataAvailEvent() : CommonStackMsgProcessor
  • ProcessDhChannelOpenCnf() : CommonStackMsgProcessor
  • ProcessDhChannelOpenRej() : CommonStackMsgProcessor
  • ProcessDhChannelReceiveInd() : CommonStackMsgProcessor
  • ProcessDhChannelSendInd() : CommonStackMsgProcessor
  • ProcessDisplayTextRsp() : CommonStackMsgProcessor
  • ProcessDispMapDecision() : LcsAppUtils
  • ProcessDrmMessage() : DrmMessage
  • ProcessEngineeringModeControlRequest() : CommonStackMsgProcessor
  • ProcessExtProactiveCmdCnf() : CommonStackMsgProcessor
  • ProcessExtProactiveCmdReq() : CommonStackMsgProcessor
  • ProcessFdnReq() : CommonStackMsgProcessor
  • ProcessGetInkeyRsp() : CommonStackMsgProcessor
  • ProcessGetInputRsp() : CommonStackMsgProcessor
  • ProcessGprsClassReq() : CommonStackMsgProcessor
  • ProcessIconDescReadReq() : CommonStackMsgProcessor
  • ProcessIdleScreenAvailEvent() : CommonStackMsgProcessor
  • ProcessImageReadReq() : CommonStackMsgProcessor
  • ProcessImeiReadReq() : CommonStackMsgProcessor
  • processingInstruction() : WbxmlParserRel
  • ProcessIsrData() : IsrDataManager
  • ProcessLanguageSelectEvent() : CommonStackMsgProcessor
  • ProcessLanguageSettingInd() : CommonStackMsgProcessor
  • ProcessLaunchBrowserInd() : CommonStackMsgProcessor
  • ProcessLaunchBrowserPromptInd() : CommonStackMsgProcessor
  • ProcessLocationError() : LcsAppUtils
  • ProcessMdhDeregistrationReq() : CommonStackMsgProcessor
  • ProcessMdhMakeViewReq() : CommonStackMsgProcessor
  • ProcessMdhRegistrationReq() : CommonStackMsgProcessor
  • ProcessMdhRemoveViewReq() : CommonStackMsgProcessor
  • ProcessMdhSetConfigReq() : CommonStackMsgProcessor
  • ProcessMdhSetStorageReq() : CommonStackMsgProcessor
  • ProcessMdhSmsConcRefNumReq() : CommonStackMsgProcessor
  • ProcessMdhSmsDeletionReq() : CommonStackMsgProcessor
  • ProcessMdhSmsExtendedDataReq() : CommonStackMsgProcessor
  • ProcessMdhSmsReadReq() : CommonStackMsgProcessor
  • ProcessMdhSmsReportReadReq() : CommonStackMsgProcessor
  • ProcessMdhSmsSetWaitingReq() : CommonStackMsgProcessor
  • ProcessMdhSmsStatusReq() : CommonStackMsgProcessor
  • ProcessMdhSmsTransmitAck() : CommonStackMsgProcessor
  • ProcessMdhSmsTransmitStartAck() : CommonStackMsgProcessor
  • ProcessMdhSmsUpdStatusReq() : CommonStackMsgProcessor
  • ProcessMdhSmsWriteReq() : CommonStackMsgProcessor
  • ProcessMeasurementDataReq() : GltpMsgProcessor
  • ProcessMenuSelectionReq() : CommonStackMsgProcessor
  • ProcessMnAttachStatusInd() : PdpContextSignalProcessor
  • ProcessMnNetworkSearchModeReq() : CommonStackMsgProcessor
  • ProcessMnTriggerReq() : CommonStackMsgProcessor
  • ProcessMocSetupReq() : CommonStackMsgProcessor
  • ProcessMolrMsg() : ProcessMolrMsg
  • ProcessMolrReq() : SaMsgProcessor, LcsMsgProcessor
  • ProcessMtcAccept() : CommonStackMsgProcessor
  • ProcessMtcAlertReq() : CommonStackMsgProcessor
  • ProcessNode() : ProcessNode
  • ProcessODyn2ReadReq() : CommonStackMsgProcessor
  • ProcessODyn2UpdReq() : CommonStackMsgProcessor
  • ProcessODynReadReq() : CommonStackMsgProcessor
  • ProcessODynUpdReq() : CommonStackMsgProcessor
  • ProcessOmBandStatusReq() : CommonStackMsgProcessor
  • ProcessOmFactoryResetInd() : CommonStackMsgProcessor
  • ProcessOmGetTermProfileReq() : CommonStackMsgProcessor
  • ProcessOmMultiSlotReq() : CommonStackMsgProcessor
  • ProcessOmPowerUp() : CommonStackMsgProcessor
  • ProcessOmRatChangeReq() : CommonStackMsgProcessor
  • ProcessOmSetTermProfileReq() : CommonStackMsgProcessor
  • ProcessPbCountReq() : CommonStackMsgProcessor
  • ProcessPbEntryReadReq() : CommonStackMsgProcessor
  • ProcessPbEntryUpdReq() : CommonStackMsgProcessor
  • ProcessPbInfoReadReq() : CommonStackMsgProcessor
  • ProcessPchActCompleteInd() : PdpContextSignalProcessor
  • ProcessPchActFailedInd() : PdpContextSignalProcessor
  • ProcessPchActivateCnf() : PdpContextSignalProcessor
  • ProcessPchActivateInd() : PdpContextSignalProcessor
  • ProcessPchActivateRej() : PdpContextSignalProcessor
  • ProcessPchActivateStatusInd() : PdpContextSignalProcessor
  • ProcessPchAttachCnf() : PdpContextSignalProcessor
  • ProcessPchAttachRej() : PdpContextSignalProcessor
  • ProcessPchAttachRep() : PdpContextSignalProcessor
  • ProcessPchAuthCnf() : PdpContextSignalProcessor
  • ProcessPchAuthRej() : PdpContextSignalProcessor
  • ProcessPchCgdsContCnf() : PdpContextSignalProcessor
  • ProcessPchCgdsContRej() : PdpContextSignalProcessor
  • ProcessPchCgTftCnf() : PdpContextSignalProcessor
  • ProcessPchCgTftRej() : PdpContextSignalProcessor
  • ProcessPchDataStateCnf() : PdpContextSignalProcessor
  • ProcessPchDataStateRej() : PdpContextSignalProcessor
  • ProcessPchDeactivateCnf() : PdpContextSignalProcessor
  • ProcessPchDeactivateInd() : PdpContextSignalProcessor
  • ProcessPchDefContCnf() : PdpContextSignalProcessor
  • ProcessPchDefContRej() : PdpContextSignalProcessor
  • ProcessPchDetachCnf() : PdpContextSignalProcessor
  • ProcessPchDetachInd() : PdpContextSignalProcessor
  • ProcessPchPppActCnf() : PdpContextSignalProcessor
  • ProcessPchReactivateInd() : PdpContextSignalProcessor
  • ProcessPchReadCntInd() : PdpContextSignalProcessor
  • ProcessPchReadCntRej() : PdpContextSignalProcessor
  • ProcessPchReadDnsCnf() : PdpContextSignalProcessor
  • ProcessPchReadDnsRej() : PdpContextSignalProcessor
  • ProcessPchSetCntCnf() : PdpContextSignalProcessor
  • ProcessPchSetCntRej() : PdpContextSignalProcessor
  • ProcessPchSetDnsCnf() : PdpContextSignalProcessor
  • ProcessPchSetDnsRej() : PdpContextSignalProcessor
  • ProcessPchSetQosCnf() : PdpContextSignalProcessor
  • ProcessPchSetQosMinCnf() : PdpContextSignalProcessor
  • ProcessPchSetQosMinRej() : PdpContextSignalProcessor
  • ProcessPchSetQosRej() : PdpContextSignalProcessor
  • ProcessPinDisableReq() : CommonStackMsgProcessor
  • ProcessPinEnableReq() : CommonStackMsgProcessor
  • ProcessPlayToneRsp() : CommonStackMsgProcessor
  • ProcessPlmnInfoReq() : CommonStackMsgProcessor
  • ProcessPlmnListAbort() : CommonStackMsgProcessor
  • ProcessPlmnListReq() : CommonStackMsgProcessor
  • ProcessPowerDownReq() : CommonStackMsgProcessor
  • ProcessPrefExtLangReadReq() : CommonStackMsgProcessor
  • ProcessPrefExtLangUpdReq() : CommonStackMsgProcessor
  • ProcessPrefLangReadReq() : CommonStackMsgProcessor
  • ProcessPrefLangUpdReq() : CommonStackMsgProcessor
  • ProcessPrefPlmnChange() : CommonStackMsgProcessor
  • ProcessPrefServiceSetReq() : CommonStackMsgProcessor
  • ProcessPuctReadReq() : CommonStackMsgProcessor
  • ProcessPuctUpdReq() : CommonStackMsgProcessor
  • ProcessRedialingQueryReq() : CommonStackMsgProcessor
  • ProcessRediallingDisabledInd() : CommonStackMsgProcessor
  • ProcessRedialRej() : CommonStackMsgProcessor
  • ProcessReferenceTimeReq() : GltpMsgProcessor
  • ProcessRefLocReq() : GltpMsgProcessor
  • ProcessRejectCallsInd() : CommonStackMsgProcessor
  • ProcessRightsMessage() : DrmMessage
  • ProcessSelectItemRsp() : CommonStackMsgProcessor
  • ProcessSelfLocation() : LcsAppUtils
  • ProcessSetAutoCharge() : CommonStackMsgProcessor
  • ProcessSetChargeUnits() : CommonStackMsgProcessor
  • ProcessSetupEventCnf() : CommonStackMsgProcessor
  • ProcessSetupIdleModeTextRsp() : CommonStackMsgProcessor
  • ProcessSetupMenuRsp() : CommonStackMsgProcessor
  • ProcessSiChannelCloseInfoRes() : CommonStackMsgProcessor
  • ProcessSiChannelCloseReq() : CommonStackMsgProcessor
  • ProcessSiChannelOpenPromptRes() : CommonStackMsgProcessor
  • ProcessSiChannelReceiveInfoRes() : CommonStackMsgProcessor
  • ProcessSiChannelSendInfoRes() : CommonStackMsgProcessor
  • ProcessSimFileInfoReq() : CommonStackMsgProcessor
  • ProcessSimGenericReq() : CommonStackMsgProcessor
  • ProcessSimModifyLockReq() : CommonStackMsgProcessor
  • ProcessSimMruPropertyUpdReq() : CommonStackMsgProcessor
  • ProcessSimTkCallSetupAcc() : CommonStackMsgProcessor
  • ProcessSimTkCallSetupRej() : CommonStackMsgProcessor
  • ProcessSimTkRefreshCnfInd() : CommonStackMsgProcessor
  • ProcessSimTkRefreshNewRsp() : CommonStackMsgProcessor
  • ProcessSimTkRefreshQueryRes() : CommonStackMsgProcessor
  • ProcessSimTkRefreshResetRsp() : CommonStackMsgProcessor
  • ProcessSimTkRefreshRsp() : CommonStackMsgProcessor
  • ProcessSimTkResetCnfInd() : CommonStackMsgProcessor
  • ProcessSimTkRunAtCmdInfoRes() : CommonStackMsgProcessor
  • ProcessSimTkSendDtmfCnf() : CommonStackMsgProcessor
  • ProcessSimTkSmsPpRsp() : CommonStackMsgProcessor
  • ProcessSimTkSsRsp() : CommonStackMsgProcessor
  • ProcessSimTkStopSendDtmfReq() : CommonStackMsgProcessor
  • ProcessSmsConfigIndArg() : CommonStackMsgProcessor
  • ProcessSmsGetMoreMessageStatusReq() : CommonStackMsgProcessor
  • ProcessSmsrReadReq() : CommonStackMsgProcessor
  • ProcessSmsrUpdReq() : CommonStackMsgProcessor
  • ProcessSmsSendReq() : CommonStackMsgProcessor
  • ProcessSmsSetMoreMessageReq() : CommonStackMsgProcessor
  • ProcessSpnReadReq() : CommonStackMsgProcessor
  • ProcessSsCcbsInvoke() : CommonStackMsgProcessor
  • ProcessSsCcbsReCallRequest() : CommonStackMsgProcessor
  • ProcessSsCcbsReject() : CommonStackMsgProcessor
  • ProcessSsErrReq() : CommonStackMsgProcessor
  • ProcessSsGetPasswordRsp() : CommonStackMsgProcessor
  • ProcessSsRejReq() : CommonStackMsgProcessor
  • ProcessSsSendEndReq() : CommonStackMsgProcessor
  • ProcessSsSendReq() : CommonStackMsgProcessor
  • ProcessSstReadReq() : CommonStackMsgProcessor
  • ProcessSsUssdReq() : CommonStackMsgProcessor
  • ProcessStackMsgArgument() : UusHandler, UssdHandler, MobileOriginatedUssdHandler, CallForwardingHandler
  • ProcessStartDtmfReq() : CommonStackMsgProcessor
  • ProcessStartSignalStrengthListening() : CommonStackMsgProcessor
  • ProcessStopBatteryLoadListening() : CommonStackMsgProcessor
  • ProcessStopDtmfReq() : CommonStackMsgProcessor
  • ProcessStopSignalStrengthListening() : CommonStackMsgProcessor
  • ProcessTestparamReq() : CommonStackMsgProcessor
  • ProcessTransferLocation() : LcsAppUtils
  • ProcessUserActivityEvent() : CommonStackMsgProcessor
  • ProcessVerifResp() : LcsMsgProcessor
  • ProgressBar() : ProgressBar
  • ProgressBarView() : ProgressBarView
  • ProgressFtpInTransfer() : FtpDataSocket
  • ProgressFtpOutTransfer() : FtpDataSocket
  • PropagateUserActivity() : AtlApplication
  • Properties() : CodecDevice::Properties
  • Property() : CamWin32, Property, FeatureBroker
  • PropertyDescriptor() : PropertyDescriptor
  • PropertyEditor() : PropertyEditor
  • PropertyItem() : PropertyItem
  • PropertyTriggerMsg() : PropertyTriggerMsg
  • Protector() : Protector
  • ProtocolIdentifier() : ProtocolIdentifier
  • ProtocolIdentifierExists() : ParameterIndicator
  • ProvColListBoxWin() : ProvColListBoxWin
  • ProvDetailListBoxWin() : ProvDetailListBoxWin
  • ProvideData() : ObexServerOppImpl, ObexOppServer, ObexOppClient, ObexDataServer, ObexClientOppImpl
  • ProvideFolderListingEntriesFinished() : ObexFtpServer
  • ProvideFolderListingEntry() : ObexFtpServer
  • Provider() : Provider
  • ProviderChangedMsg() : ProviderChangedMsg
  • ProviderListBox() : ProviderListBox
  • ProviderListBoxModel() : ProviderListBoxModel
  • ProviderListBoxView() : ProviderListBoxView
  • ProviderListener() : ProviderListener
  • ProviderProxyContainer() : ProviderProxyContainer
  • ProviderProxyItem() : ProviderProxyItem
  • ProviderPtr() : ProviderPtr
  • ProviderUpdateMsg() : ProviderUpdateMsg
  • ProvListBoxWin() : ProvListBoxWin
  • ProvShowsEmptyRows() : PhonebookApp
  • PsdDataConn() : PsdDataConn, SysSocket
  • PsdDataConnAccessor() : PsdDataConnAccessor
  • PsdDataConnProfile() : PsdDataConnProfile, PersistDataConnProfile
  • PsdDataConnProvider() : PsdDataConnProvider
  • PsdLinkInit() : SysSocket
  • PsdLinkStop() : SysSocket
  • PsdLinkUp() : SysSocket
  • Pull() : ObexOppClient, ObexClientOppImpl
  • Push() : ObexOppClient, ObexOppBinDataPushClient, ObexClientOppImpl, MsgQueue, FifoLinkedList< T >, SimPhoneBookEntry, AtGenericCmdType
  • push_back() : WbxmlVector< T >
  • PushBack() : EmzUtils::Queue< T >, BtDeviceList, Vector< T >, LinkedListBase, TextIconPairArray, DeletedNodeList
  • PushButton() : PushButton
  • PushButtonView() : PushButtonView
  • PushFocusMsg() : MsgQueue
  • PushFront() : EmzUtils::Queue< T >, BtDeviceList, LinkedListBase
  • Put() : ObexLayer, ObexClient, IrdaObexImpl, BtObexImpl, StreamObexImpl, SmsWStringCache
  • PutAddressingScheme16Bit() : InformationElement
  • PutAddressingScheme8Bit() : InformationElement
  • PutConcatenatedSm16Bit() : InformationElement
  • PutConcatenatedSm8Bit() : InformationElement
  • PutContinuedExtendedObject() : InformationElement
  • PutData() : SimPbEntryCont
  • PutEmsRelativeStartPosition() : InformationElement
  • PutExtendedObject() : InformationElement
  • PutFilter() : CbsFilterList
  • PutImageReq() : BtBipClientService
  • PutImageRsp() : BtBipServerService
  • PutLargeAnimation() : InformationElement
  • PutLargePicture() : InformationElement
  • PutLinkedAttachmentReq() : BtBipClientService
  • PutLinkedAttachmentRsp() : BtBipServerService
  • PutLinkedThumbnailReq() : BtBipClientService
  • PutLinkedThumbnailRsp() : BtBipServerService
  • PutPredefinedAnimation() : InformationElement
  • PutPredefinedSound() : InformationElement
  • PutRequest() : BtObexClientService
  • PutReusedExtendedObject() : InformationElement
  • PutSmallAnimation() : InformationElement
  • PutSmallPicture() : InformationElement
  • PutTextFormatting() : InformationElement
  • PutToForeground() : Control
  • PutUserDefinedSound() : InformationElement
  • PutValue() : ObexHeader
  • PutVariablePicture() : InformationElement
  • PxLogicalCharacs() : WapProfile::PxLogicalCharacs
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- q -

  • QualityOfService() : PdpContext::QualityOfService
  • QueryForPasswd() : DataConnProfile
  • QueryRects() : VideoChannel
  • QuerySmsMoreMessageType() : SmsHandler, SimAccessor
  • Queue() : EmzUtils::Queue< T >
  • QuickSort() : QuickSortProvider, ChineseQuickSortProvider
  • QuickSortDataItems() : MergeProvider
  • QuickSortNumber() : QuickSortProvider
  • QuickSortProvider() : QuickSortProvider
  • QuickSortWString() : QuickSortProvider
  • QuotedPrintableCoder() : QuotedPrintableCoder
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- r -

  • RadioButtonAction() : RadioButtonAction
  • RadioButtonControl() : RadioButtonControl
  • RadioButtonControlView() : RadioButtonControlView
  • RadioButtonGroup() : RadioButtonGroup
  • RadioButtonItem() : RadioButtonItem
  • RadioButtonList() : RadioButtonList
  • RadioButtonListView() : RadioButtonListView
  • RadioButtonModel() : RadioButtonModel
  • RadioButtonView() : RadioButtonView
  • RamData() : RamData
  • RamDataSink() : RamDataSink
  • RamDataSource() : RamDataSource, RamDataSink
  • RamDirectoryIteratorImp() : RamDirectoryIteratorImp
  • RamFile() : RamFile
  • RamFileImp() : RamFileImp
  • RamFileNode() : RamFileNode
  • RamFileObj() : RamFileObj, RamStorageMapper
  • RamStorageDeviceImp() : RamStorageDeviceImp, RamFileImp, RamDirectoryIteratorImp
  • Random() : SocketTestT
  • RangeMappingPolicy() : RangeMappingPolicy
  • RangeRule() : RangeRule
  • RatChangeModeChangedMsg() : RatChangeModeChangedMsg
  • RatStateMsg() : RatStateMsg
  • RawFrameRequest() : BtAvrcpOperationService
  • RBegin() : BtDeviceList, Vector< T >
  • rbegin() : WbxmlVector< T >
  • ReactivateBacklight() : DefaultDisplay, Display, DefaultDisplay
  • ReactivateIllumination() : Keyboard
  • ReactivatePower() : DefaultDisplay, Display, DefaultDisplay
  • Read() : FfsDataConnProfileStorage, UdpSocket, TcpSocket, Socket, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket, DataConnProfileStorage, SocketPeer, NonsharedBinDataDataSource, NvRamStorage, InputStream, FileInputStream, FfsFile, RomData, RamData, HeapDataSource, DataSourceBinData, DataSource, ChildBinData, BinDataDataSource, BinData, MemMap, SmsSocket, ExtPsdContextListener_SerialTerminal, UserData, FileDataSource, FileChunkOperator, FileBinData, File, RegNodeBuffer, FlsFile, FfsHandler, SvgIoWrapper, SvgImageFileWrapper, SvgGzFileWrapper, SvgFileWrapper, SioSocketAdapter, SerialSocket, SerialIoAdapter, SerialTerminalSocket, SerialTerminal, RamHandler, RamFileObj, RamFile, FatHandler, FatFile, Tpdu
  • ReadBlock() : RamStorageMapper
  • ReadBlocks() : RamStorageMapper
  • ReadBool() : HostIniFile
  • ReadBuffer() : VCard
  • ReadCounter() : PdpContext
  • ReadCur() : File
  • ReadData() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • Reader() : ObexBuffer::Reader, ObexBuffer
  • ReadFrom() : DrmInfo, Path
  • ReadFromMemory() : BtSddbServiceRecord, BtSddbServiceAttribute, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeOneByteDescriptionType, BtSddbDataElement
  • ReadInteger() : HostIniFile
  • ReadLastMnCause() : CallHdlBase
  • ReadLdbData() : T9PackConnector
  • ReadMetaData() : Fota
  • ReadNegotiatedDnsServerAddress() : PsdDataConn, PdpContext
  • ReadPayloadData() : UserData
  • ReadProperties() : CTResourcePack
  • ReadRightsObject() : DrmRightsObjectFile
  • ReadRingToneInfoFromFfs() : RingerAudioDevice
  • ReadROHeaderInfo() : DrmRightsObjectFile
  • ReadRootCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ReadSmsProfile() : SmsContext
  • ReadStreaming() : File, FlsFile, FatHandler, FatFile
  • ReadStreamingAsync() : File, FlsFile, FatHandler, FatFile
  • ReadString() : HostIniFile
  • ReadUserCertificate() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ReadVCard() : VCardParser
  • Realloc() : Os
  • Reallocate() : RegBlobObject, ByteBuffer, BlobObject
  • ReAllocate() : HeapVector::VarPage, HeapVector::BlockPage, HeapManager
  • ReallocateData() : Tpdu, Cbs
  • ReceiveEngineeringModeReport() : NetworkHandler
  • Reciprocal() : Fraction
  • ReconstructRecordingWaitCondition() : StreamAudioPlayer
  • Record() : VoiceMemoWin, VoiceMemoRecordWin, StreamAudioPlayer, Record
  • RecordHandler() : RecordHandler
  • RecordSettings() : RecordSettings
  • Rect() : Rect
  • Recv() : SysSocket
  • RecvFrom() : SysSocket
  • RedialIndArg() : RedialIndArg
  • RediallingDisabledIndArg() : RediallingDisabledIndArg
  • RedialQueryReqArg() : RedialQueryReqArg
  • RedialRejArg() : RedialRejArg
  • RedialSetupIndArg() : RedialSetupIndArg
  • RedialSetupMsg() : RedialSetupMsg
  • RedialStartedMsg() : RedialStartedMsg
  • RedialStatusIndArg() : RedialStatusIndArg
  • RedialStatusMsg() : RedialStatusMsg
  • RedialStopIndArg() : RedialStopIndArg
  • RedialStoppedMsg() : RedialStoppedMsg
  • RedialSuccessMsg() : RedialSuccessMsg
  • RedrawDisplayMsg() : RedrawDisplayMsg
  • RedrawStatusLine() : CameraViewFinderWin
  • Ref() : SharedPtr< T_obj >
  • RefCount() : ReferableObject
  • ReferableObject() : ReferableObject
  • ReferenceLocation() : ReferenceLocation
  • ReferenceTime() : ReferenceTime
  • Refresh() : MediaRefContainer, ProvDetailListBoxWin, ProvListBoxWin, Window, TabControl, TabButton, RadioButtonControl, PushButton, ItemTree, ItemMenu, ItemBox, ImageBox, DateEditor, Control, ContextMenu, Component, CheckBoxControl, AnimatedTextLine, AbstractMultiLineEditor, AbstractItemGrid, AbstractGrid, AbstractEditor, VirtualDisplay, DefaultDisplay, VirtualDisplay, DefaultDisplay, VirtualDisplay, DefaultDisplay, VirtualDisplay, DefaultDisplay, Display, VirtualDisplay, DefaultDisplay, TextList, RadioButtonList, MenuList, Menu, Grid, CheckBoxList, CheckBox, AbstractListBox, AbstractEditBox, BtDeviceList, AtlItemBox, ProcessNode, MultiMediaEditor, SimSmsParamHandler, SimPduHandler, SimPbBaseHandler
  • RefreshChvData() : SimChvHandler
  • RefreshComponentMsg() : RefreshComponentMsg
  • RefreshData() : SimSmsParamHandler, SimPduHandler, SimPbBaseHandler, DataHandler
  • RefreshDataSimTk() : DataHandler
  • RefreshImageCache() : AbstractItemGrid
  • RefreshPhoneticList() : ChineseT9Wrapper
  • RefreshScreen() : SocketTestProgressWin, FfsTestDispWin
  • RefreshSimMruProperty() : DataHandler
  • RefreshStatusData() : SimPduHandler
  • RefreshViewFinder() : CameraViewFinderWin
  • RegApp() : RegApp
  • RegAppFirstWin() : RegAppFirstWin
  • RegAppWin() : RegAppWin
  • RegBlobObject() : RegBlobObject
  • RegCbNotifyMsg() : RegCbNotifyMsg
  • RegCommitTransaction() : LocalDataStore
  • RegDeletionBufferEntry() : RegDeletionBufferEntry
  • RegGetDataSize() : RegBlobObject
  • RegGetMimeType() : RegBlobObject
  • RegGetMimeTypeSize() : RegBlobObject
  • RegGetSize() : RegBlobObject
  • RegInterface() : RegistryInterface
  • Register() : UibServiceImpl, ObexAbstractTransport, ObexServerMngr, ObexServerInfo, MessageMapContainer< T >, AbstractMessageMapContainer, AlarmManager, GatiManager, BtController, UusHandler, SmsSocketListener, PlmnHandler, PlmnDispatcher, PdpContextManager, EmlppHandler, CallForwardingHandler, StorageDevice, LookupAlphaIdExtension
  • RegisterApplication() : FeatureBroker, HttpApplicationSupplier
  • RegisterAvrcpApp() : BtAvrcpPanelServiceImpl, BtAvrcpPanelService, BtAvrcpPanelApplication
  • RegisterBipServer() : BtBipServerService
  • RegisterBrowser() : SimTkHandler
  • RegisterCallbackFunctions() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoderRenderer, AudioDecoder, AudioCapturerEncoder
  • RegisterConnApp() : GltpProviderImpl
  • RegisterDataConn() : DataConnManager
  • RegisterDataStore() : SyncMLManager
  • RegisterDecoder() : CodecManager
  • RegisterDispatcher() : BtLocalRequest
  • RegisterEncoder() : CodecManager
  • RegisterForMtlr() : LcsProviderImplBase, LcsProvider
  • RegisterFrameCapturedCB() : CamWin32
  • RegisterGetBufferCB() : CamWin32
  • RegisterGlobalProvider() : MainProvider
  • RegisterHfMessages() : BtHfAppPlugin
  • RegisterInputAction() : InputActionList
  • RegisterMessage() : ServiceThread, ExecutionContext, Application, AppContainer
  • RegisterMessages() : UserDispatcher, MessageMapDispatcher, BtObexService, BtHsService, BtHfService, BtFaxService, BtDunService, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtSendPasskeyRequest, BtSddbService, BtRespondAuthorizationRequest, BtQuerySupportedProfilesRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtBppService, BtBipServerService, BtBipClientService, BtAvrcpService, BtAvrcpOperationService
  • RegisterNewPw() : SsHandler
  • RegisterNotify() : Registry, RegEncoderDecoder
  • RegisterObexApp() : ObexMngr
  • RegisterPanelToApoxiAvrcp() : BtAvrcpPanelApplication
  • RegisterParser() : IMelody
  • RegisterRejectCause() : EnumTranslationTable
  • RegisterRemoteObjectTree() : Registry
  • RegisterRequest() : BtObexService, BtObexServerService, BtObexClientService, BtBppServerService, BtAvrcpRegistrationService
  • RegisterService() : ServiceBroker
  • RegisterServiceCallback() : BtSddbService
  • RegisterServiceRecordRequest() : BtSddbService
  • RegisterSignalListener() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • RegisterStatus() : EnumTranslationTable
  • RegisterStorageDevice() : RootFileSystem
  • RegisterSyncMLApplication() : SyncMLManager
  • RegisterTransaction() : MobileOriginatedUssdHandler
  • RegisterTransportApp() : AbstractTransport
  • RegisterUserActivityListener() : AtlApplication
  • RegisterUtility() : AbstractSmsApp
  • RegisterWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • RegistrationAllowedMsg() : RegistrationAllowedMsg
  • RegistrationChangeMsg() : RegistrationChangeMsg
  • RegistrationSuccessMsg() : RegistrationSuccessMsg
  • RegistryInterface() : RegistryInterface
  • RegIterator() : RegIterator, Registry
  • RegManager() : RegManager, Registry
  • RegNodeBuffer() : RegNodeBuffer
  • RegNotifyMsg() : RegNotifyMsg
  • RegSetMimeType() : RegBlobObject
  • RegStateIndArg() : RegStateIndArg
  • RegTcpSocket() : RegTcpSocket
  • ReInit() : MediaInfo
  • Reinterpret() : DateEditorDocument
  • Reject() : PdpContext, CallHdl, MmCallHdl, MmCallHandler
  • RejectAllMoc() : CallHdlBase, CallHandler
  • RejectAllMtc() : CallHdlBase, CallHandler, MmCallHdl, MmCallHandler
  • RejectCallSetup() : SimTkHandler
  • RejectCallsIndArg() : RejectCallsIndArg
  • RejectConnectRequest() : ObexFtpServer
  • RejectDeleteObjectRequest() : ObexFtpServer
  • RejectDuplicates() : SmsSubmit
  • RejectFilePullRequest() : ObexFtpServer
  • RejectFilePushRequest() : ObexFtpServer
  • RejectFolderListingRequest() : ObexFtpServer
  • RejectSetCurrentFolderRequest() : ObexFtpServer
  • RejectUssdRequest() : SsHandler
  • RelaySms() : AbstractSmsUtilityProcessor, AbstractSmsComposeWin, AbstractSmsApp, EmsComposeWin
  • Release() : SocketHandler, DataConn, ObexObject, ObexBuffer, SimpleSemaphore, Semaphore, SimpleMutex, SemObtainer, SimpleSemaphore, Semaphore, MutexObtainer, Mutex, AppMutex, WindowHierarchyIterator, DeviceContext, Desktop, GenericAudioDevice, ReferableObject, NiSharedPtr< X >, MemPool, MemPoolEntry, RtStreamingBuffer, MptyCallHdl, DataCallHdl, CallHdlBase, CallHdl, CallHandler, DBService::DBItemIterator, ServiceBroker, MmCallHdl, MmCallHandler
  • ReleaseAction() : ObexAbstractPort
  • ReleaseActiveCall() : CrssHandler
  • ReleaseAddress() : ObexAbstractPort
  • ReleaseAllActiveCalls() : CrssHandler, CallHdlBase
  • ReleaseAllHeldCalls() : CrssHandler, CallHdlBase
  • ReleaseBuffer() : BufferPoolManager
  • ReleaseCall() : BtHsService
  • ReleaseCaptureBuffer() : VideoCamera
  • ReleaseChannel() : ObexProtocol, ObexAbstractPort, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • ReleaseConfigStreamBuffer() : EmzMpeg4Encoder, AtiMpeg4Encoder, VideoEncoder
  • ReleaseConnId() : HttpWapMgr
  • ReleaseDataCall() : CsdDataConn
  • ReleaseDataConn() : SocketData
  • ReleaseDecoder() : CodecManager
  • ReleasedEvent() : DataConn
  • ReleaseEncoder() : CodecManager
  • ReleaseGlobalProvider() : MainProvider
  • ReleaseImage() : ImageRef
  • ReleaseInstance() : FfsTestThreadlet, LcsSettingsUtils, LocResController, LcsWapIntf, LcsAppUtils, Threadlet, EncodingThreadlet, DecodingThreadlet, CompoundItem, BufferedData, BinData, HttpApplicationSupplier, HttpApplication, PngDecoder, SaSignalMapTableNode, SaProviderImpl, GltpSignalMapTableNode, GltpProviderImpl, LcsUtils, LcsReqProcessor, LcsCommonSignalMapTableNode, LcsSignalMapTableNode, LcsProviderImpl
  • ReleaseItemRenderer() : GuiEngineConfig
  • ReleaseMemMap() : RamData, DataSourceBinData, BinData, FileBinData
  • ReleaseMpty() : CrssHandler
  • ReleaseMutex() : AbstractTextRenderer
  • ReleaseOperands() : BtAvrcpRawFrameParams
  • ReleaseOperationData() : BtAvrcpPanelPassThroughParams
  • ReleaseOutputBuffer() : ScicosMpeg4VideoDecoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Encoder, AtiMpeg4Decoder, EmzMpeg4Decoder, EmzH264Decoder, VideoEncoder, VideoDecoder
  • ReleaseParams() : BtAvrcpRegisterRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest
  • ReleasePPP() : PppDataConn
  • ReleaseRequestId() : HttpWapMgrPlugin
  • ReleaseSemaphore() : AtiAudioPlayerRtStreamingSink
  • ReleaseSerialTerminal() : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • ReleaseSpeech() : Audio
  • ReleaseSubunitInfos() : BtAvrcpRegisterParams
  • ReleaseSuspendSlot() : DwdPlayer
  • ReleaseThumbnail() : ImageRef
  • ReloadNewMsgTpdu() : SimPduHandler, DataHandler
  • ReloadTpdu() : SimPduHandler, DataHandler
  • RememberRepliedTpdu() : AbstractSmsApp
  • RemotePartyActionMsg() : RemotePartyActionMsg
  • Remove() : WindowManager, TextCompoundItem, GlassPane, BtDeviceList, SingleArgHook< T >, SimpleMap< TKey, TValue >, LinkedListBase, FifoLinkedList< T >, ElementList< T >, StackMsgMapTableNode, SignalMapTableNode, MessageIdentifierContainer, Cbs::Filter, SerialIoSet
  • RemoveAccessor() : UibActionAccessor
  • RemoveAction() : UibActionAccessor, ActionMenuAccessor
  • RemoveAlignInfo() : FlowLayout
  • RemoveAll() : SimpleMap< TKey, TValue >
  • RemoveAllActions() : UibActionAccessor, ActionMenuAccessor
  • RemoveAllAudioPaths() : AudioPathManager
  • RemoveAllIcons() : IconSet
  • RemoveAllIndicators() : IndicatorBar
  • RemoveAllItems() : ItemContainer, AbstractItemContainer, RadioButtonList, MenuList, CheckBoxList, AbstractMenuListModel< Item >, ProviderProxyContainer, FeatureItemContainer
  • RemoveAllPaneObjects() : GlassPane
  • RemoveAllTemplates() : VrHandler
  • RemoveAppContainer() : System
  • RemoveAppContext() : AbstractScheduler
  • RemoveApplication() : AppContainerRoutingTableEntry
  • RemoveAudioPath() : AudioPathManager
  • RemoveAuthorizationSet() : WapProfile
  • RemoveBackupFiles() : UriMappingTable
  • RemoveBlobFileRecord() : UriMappingTable
  • RemoveChildProvider() : AppendProvider
  • RemoveCompoundItem() : EmsEditor, EditorDocument, AbstractEditor, ParagraphCompoundItem, MultiMediaEditorDocument
  • RemoveConnection() : BtMultiConnectionController
  • RemoveControl() : Control
  • RemoveDataMapping() : MmfPlayer
  • RemoveDevice() : DeviceManager
  • RemoveDir() : RamHandler, FatHandler
  • RemoveDispatcher() : ExecutionContext, BtBppService
  • RemoveDrawableObject() : Control
  • RemoveElem() : HashTable
  • RemoveEmptyLines() : AbstractEditBoxModel
  • RemoveFileExtension() : Pathname
  • RemoveFilter() : CbsFilterList
  • RemoveFormattingCodes() : BidiManager
  • RemoveFromList() : SerialSocketThread
  • RemoveFromReadList() : SerialIoSet
  • RemoveFromTitlebar() : Window
  • RemoveFromWriteList() : SerialIoSet
  • RemoveHead() : Pathname
  • RemoveIndicator() : IndicatorBar
  • RemoveInteriorNodeEntry() : NodeFileHandler
  • RemoveItem() : SmsEditor, EmsEditor, TimeEditorDocument, TextEditorDocument, TextCompoundItem, PasswordEditor, ItemContainer, EditorDocument, DateEditorDocument, CompoundItem, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemContainer, AbstractEditor, RadioButtonList, MenuList, CheckBoxList, AbstractMenuListModel< Item >, ProviderProxyContainer, FeatureItemContainer, ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor, GeneralCompoundItem
  • RemoveLeaf() : Pathname
  • RemoveLockUriInTable() : LockTableList
  • RemoveMenuFeature() : BtHfAppPlugin
  • RemoveMolr() : LcsReqProcessor
  • RemoveNodeEntry() : NodeFileHandler
  • RemovePhysicalPortSet() : WapProfile
  • RemovePhysicalSet() : WapProfile
  • RemovePortSet() : WapProfile
  • RemovePostMsgHook() : MessageRouter
  • RemoveReferenceMapping() : DwdDevice
  • RemoveTab() : TabControl
  • RemoveTemplate() : VrHandler
  • RemoveTimer() : ServiceThread, ExecutionContext, Application, AppContainer
  • RemoveTrailingSeparators() : Pathname
  • RemoveUri() : LockTable
  • RemoveURIRecord() : UriMappingTable
  • RemoveView() : BrowserViewContainer
  • RemoveWindow() : Application
  • Rename() : MediaRefContainer, ImageRefContainer, MediaRefContainer, FfsFile, File, FlsFile, FfsHandler, RootFileImp, RamHandler, RamFileImp, RamFile, FlashFileImp, FatHandler, FatFileImp, FatFile
  • RenameFileDialog() : RenameFileDialog
  • rend() : WbxmlVector< T >
  • REnd() : BtDeviceList, Vector< T >
  • RenderFrame() : VideoChannel
  • Replace() : TextCompoundItem, WString, String, Registry, ObjectTreeService, LocalDataStore
  • ReplaceChar() : AbstractEditBox, AbstractEditBoxModel
  • ReplaceFileId() : UriMappingTable
  • ReplaceItem() : EmsEditor, TimeEditorDocument, TextEditorDocument, TextCompoundItem, PasswordEditor, EditorDocument, DateEditorDocument, CompoundItem, AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor, ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor, GeneralCompoundItem
  • ReplaceNodeEntry() : NodeFileHandler
  • ReplaceWithNewWord() : Zi8InputMapper
  • Reply() : UssdHandler
  • ReplyMessage() : FtpSocket, FtpClient
  • ReplyPathExists() : SmsDeliver, TpduHeaderInformation
  • ReplySms() : AbstractSmsApp, EmsApp
  • ReportChargeUnits() : AocHandler
  • ReportCurrentCallMeter() : CallHdlBase, MmCallHdl, MmCallHandler
  • ReportCurrentCharge() : CallHdlBase, AocHandler, MmCallHdl, MmCallHandler
  • RepositionImage() : ImageBrowserDetailWin
  • RequestBandConfig() : NetworkHandler
  • RequestChargeUnits() : AocHandler
  • RequestCurrentCharge() : AocHandler
  • RequestExists() : LcsReqProcessor
  • RequestGetHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • RequestHeadHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • RequestOnStartup() : BootHandler, BootControl
  • RequestPostDataHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • RequestPostHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • RequestRead() : StreamReader
  • RequestRedialStatus() : CallHandler
  • RequestReplyPath() : SmsSubmit
  • RequestReport() : SmsCommand, SmsSubmit
  • RequestStateChangeCallback() : BtObexService, BtFaxService, BtDunService, BtService, BtSddbService, BtBppService, BtBipClientService, BtAvrcpRegistrationService, BtAvrcpOperationService
  • RequestStatus() : UusHandler, EmlppHandler, ColrHandler, ColpHandler, CnapHandler, ClirHandler, ClipHandler, CallWaitingHandler, CallForwardingHandler, CallBarringHandler
  • RequestWrite() : StreamWriter
  • Reschedule() : SimpleScheduler, Scheduler, AbstractScheduler
  • Reserve() : WString, Vector< T >, String, ByteBuffer
  • reserve() : WbxmlVector< T >
  • Reset() : PppSetupCallBackData, ObexServerPort, StartUp::Data, EmzUtils::Queue< T >, EmzH264Decoder, EmzUtils::Queue< T >, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, Led, AbstractEditBoxModel, DateTime::Persist, StackMsgActiveWaitDispatcher, SmsFactory, PdpContextManager::AttachStatus, PdpContextManager::DataCounters, PdpContext::ActivationStatus, PdpContext::QualityOfService, PdpContext::Address, DataCallContext, UserData, UriMappingTable, Pathname, VrHandler, RamFileObj, StatusProvider, SimTkMainMenuProvider, SimSmsParamHandler, SimPduHandler, SimPbEntryCont, SimPbBaseHandler, SimCphsHandler, SimChvHandler, SimAuxHandler, SimAccessor, DataHandler, Camera
  • ResetCounter() : SmsEditor
  • ResetData() : SimPbEntry
  • ResetDataConnIdleTimer() : SocketData, InetSocket
  • ResetDataCounters() : PdpContextManager
  • ResetDeletionBuffer() : RegDeletionBufferEntry
  • ResetFileId() : RegNodeBuffer
  • ResetIdleTimer() : DataConn
  • ResetModification() : Provider
  • ResetRefCount() : WStrData, StrData
  • ResetRequestState() : BtRequest
  • ResetToFactoryDefaults() : DataConnProfileStorage, DataConnProfileManager
  • ResetTransformation() : SvgImage
  • Resize() : IndexTable< T >, FixedPtrArray< T >, File, FlsFile, RootFileImp, RamHandler, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile, TpduCache
  • resize() : WbxmlVector< T >
  • ResizeData() : Tpdu, Cbs
  • ResizeIndexTable() : SortProvider
  • resolveAttributeName() : WbxmlRelHandler
  • resolveAttributeValue() : WbxmlRelHandler
  • ResolveClientAddr() : ObexAbstractTransport, IrdaObexTransport, BtObexTransport, UsbObexTransport
  • ResolveCompleteAction() : ObexAbstractPort
  • ResolveServerAddr() : ObexAbstractTransport, IrdaObexTransport, BtObexTransport, UsbObexTransport
  • resolveTagName() : WbxmlRelHandler
  • ResourceID() : ResourceID
  • Restart() : Timer, SystemTimer, ImageBox, StartUp, SharedTimer, SvgPlayer, ShutDown
  • RestartHf() : MiscAudioDevice
  • RestartViewfinder() : Camera
  • RestoreFactorySettings() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, BtHfProvider, SettingsProvider
  • RestoreSoftkeys() : PbAbstractWin
  • ResultWinBase() : ResultWinBase
  • Resume() : Timer, Thread, Mp3AudioDevice, SharedTimer, AudioActiveReference
  • ResumeHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • ResumeRecord() : VoiceMemoWin, VoiceMemoRecordWin, MediaRecorder
  • ResumeRecording() : VoiceMemoApp
  • ResumeSuspended() : MP3AudioPlayer, MmfPlayer
  • ResumeWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • ReTranslate() : LanguageManager
  • Retrieve() : MptyCallHdl, CrssHandler, CallHdl
  • RetrieveCbmi() : SimAuxHandler
  • RetrieveCbmiRanges() : SimAuxHandler
  • RetrieveCcp() : SimAuxHandler
  • RetrieveCingularTst() : SimCphsHandler
  • RetrieveCmi() : SimAuxHandler
  • RetrieveCspData() : SimCphsHandler
  • RetrieveEccList() : SimAuxHandler
  • RetrieveEonsData() : SimAuxHandler
  • RetrieveExtLanguageList() : SimAuxHandler
  • RetrieveLanguageList() : SimAuxHandler
  • RetrieveLociData() : SimAuxHandler
  • RetrieveMbi() : SimAuxHandler
  • RetrieveMtlr() : LcsReqProcessor
  • RetrievePlmnList() : SimAuxHandler
  • RetrievePlmnwactList() : SimAuxHandler
  • RetrieveSmsServiceParameter() : SimSmsParamHandler
  • RetrieveSst() : SimAuxHandler
  • RetrieveUsimSmsServiceParameter() : SimSmsParamHandler
  • ReturnObexAddress() : ObexAbstractTransport
  • ReturnReport() : SmsDeliver
  • ReturnResponse() : ObexServer, ObexLayer, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • ReturnResponseBuffer() : StreamObexImpl
  • ReverseBegin() : Pathname
  • ReverseEnd() : Pathname
  • ReverseIterator() : Pathname::ReverseIterator, Vector< T >
  • Rewind() : MmfPlayer, MediaPlayer
  • RfcommSocketAddr() : RfcommSocketAddr
  • RfsMediaAvailableStatusMsg() : RfsMediaAvailableStatusMsg
  • RfsObexFtpServer() : RfsObexFtpServer
  • RfsStorageDeviceRegistrationStatusMsg() : RfsStorageDeviceRegistrationStatusMsg
  • RichTextCompoundItem() : RichTextCompoundItem
  • RingerAudioDevice() : RingerAudioDevice
  • RingRequest() : BtHsService
  • Rollback() : DBService
  • RollBackTransaction() : BackupFileHandler
  • RomData() : RomData
  • RomFont() : RomFont
  • RootDirectoryIteratorImp() : RootDirectoryIteratorImp
  • RootFileImp() : RootFileImp, File
  • RootStorageDeviceImp() : RootStorageDeviceImp, RootFileImp
  • RootStorageDeviceIterator() : RootStorageDeviceIterator
  • Rotate() : SvgPlayer, SvgImage, VideoChannel
  • RouteData() : ExternalCommunicationHandler, SignalHandler
  • RouteMessage() : Dispatcher, Application, Control, AtlApplication, Zi8PredictiveInputBox, T9PredictiveInputBox
  • RowCount() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, SmsTemplateProvider, SmsSettingsProvider, DataConnProvider, CalendarProvider, BtDeviceListProvider, PbRecordProvider, PbRecordHandler, PbNumberFilterProvider, PbDetailProvider, GroupProvider, Provider, FindProvider, FilterProvider, AbstractDelegationProvider, SettingsProvider, JoinProvider, AppendProvider, LanguageProvider, StatusProvider, SstProvider, SmsUnsentProvider, SmsUnreadProvider, SmsSentProvider, SmsReadProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, SimTkMainMenuProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PlmnProvider, PbBaseProvider, MbiProvider, LockProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CountryProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • RrcParam() : RrcParam, TestparamReport
  • RrParam() : RrParam, TestparamReport
  • RtcAlarmReachedMsg() : RtcAlarmReachedMsg
  • RtcDateChangedMsg() : RtcDateChangedMsg
  • RtcInfoMsg() : RtcInfoMsg
  • RtcTimeChangedMsg() : RtcTimeChangedMsg
  • RtStreamingBuffer() : RtStreamingBuffer
  • RtStreamingConn() : RtStreamingConn, RtStreamingSource, RtStreamingSink
  • RtStreamingEndPoint() : RtStreamingEndPoint, RtStreamingConn
  • RtStreamingSink() : RtStreamingSink, RtStreamingConn
  • RtStreamingSource() : RtStreamingSource, RtStreamingConn
  • Run() : UibTest2, UibTest1, UibSortingTest, UibSettingsTest, UibPerformanceTest, UibNotifyTest, UibMsgDisplayTest, UibInboxTest, UibAccessorTest, ServiceThread, Thread, AppContainer
  • RunAtCommandResponse() : SimTkHandler
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- s -

  • SaLocationErrArg() : SaLocationErrArg
  • SaMolrResultArg() : SaMolrResultArg
  • SatelliteInfo() : SatelliteInfo
  • SatteliteGraphWin() : SatteliteGraphWin
  • SatteliteInfoWin() : SatteliteInfoWin
  • Save() : WapProfile, RamDataSink
  • SaveCalendarRecord() : CalendarApp
  • SaveEdit() : PbDetails
  • SaveEntryInPhonebook() : PhonebookApp
  • SaveEntryInPhonebookMsg() : SaveEntryInPhonebookMsg
  • SaveFrequency() : FmRadioWindow
  • SaveFrom() : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile
  • SaveImage() : ImageBrowserApp
  • SaveMedia() : MediaRefContainer
  • SaveNoAction() : SaveNoAction
  • SaveNumberInPhonebook() : PhonebookApp
  • SavePhoneNo() : PbPhoneNumberPrompt
  • SaveProfile() : DataConnProfileManager
  • SaveSound() : SoundBrowserApp
  • SaveT9Udb() : T9InputConfig
  • SaveTo() : PsdDataConnProfile, DataConnProfile, CsdDataConnProfile
  • SaveWapProfile() : WapProfileMgr
  • SaveZi8Udb() : Zi8InputConfig
  • SavingProgressWin() : SavingProgressWin
  • Scan() : SmsTextParser, WString, String, PlmnHandler
  • ScanAsciiString() : ObexUrlStrParser
  • ScanDisk() : StorageDevice
  • ScanlineAccessor() : ScanlineAccessor
  • ScanOctetString() : ObexUrlStrParser
  • Scheduler() : Scheduler
  • Scroll() : DeviceContext, VirtualDisplay
  • ScrollText() : DefaultItemRenderer, AbstractItemRenderer
  • SearchBackupFileId() : UriMappingTable
  • SearchBox() : SearchBox
  • SearchDataItems() : DBService
  • SearchFileId() : UriMappingTable
  • SearchForFiles() : MediaRefContainer
  • SearchRow() : PhonebookApp
  • SearchUri() : NotificationArray, LockTable
  • SecLockResult() : EnumTranslationTable
  • Seek() : Mp3AudioDevice, StreamWriter, StreamReader, File, FatHandler
  • SeekStation() : RadioAudioDevice
  • Select() : SerialIoSet
  • SelectComponent() : Zi8Wrapper
  • SelectEmailAddress() : PhonebookApp, AdvPbApp
  • SelectGroup() : AdvPbApp
  • SelectImage() : ImageBrowserApp
  • SelectionBox() : SelectionBox
  • SelectionBoxView() : SelectionBoxView
  • SelectionByUsingSoftkey() : SimSetupMenuOptions, SimSelectItemOptions
  • SelectionChangedMsg() : SelectionChangedMsg
  • SelectItemReqArg() : SelectItemReqArg
  • SelectItemRspArg() : SelectItemRspArg
  • SelectMediaTracks() : MediaPlayer
  • SelectMuteChannel() : RadioAudioDevice
  • SelectNoType() : AdvPbApp
  • SelectPhoneNumber() : PhonebookApp
  • SelectPhoneticChineseWord() : ChineseT9Wrapper
  • SelectRow() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, DataConnProvider, CalendarProvider, BtHfProvider, PbRecordProvider, Provider, AbstractDelegationProvider, MergeProvider, JoinProvider, SmsParamProvider, PrefPlmnProvider, PbBaseProvider, MbiProvider
  • SelectSimPos() : PhonebookApp
  • SelectSound() : SoundBrowserApp
  • SelectStrokeChineseWord() : ChineseT9Wrapper
  • SelectTransport() : ObexMngr
  • SelectUsimPb() : DataHandler
  • SelfLocationDialog() : SelfLocationDialog
  • SelfLocationReq() : LcsProviderImplBase, LcsProvider
  • Semaphore() : Semaphore, Ticks
  • SemObtainer() : SemObtainer
  • Send() : SysSocket, ClientNetAdapter, NetAdapterHandler, SmsFactory
  • SendAbortReq() : LcsAppUtils
  • SendAlertInd() : CallHdl
  • SendAsMms() : MediaRef
  • SendCcbsInvoke() : SsCcbsHandler
  • SendCcbsReCallRequest() : SsCcbsHandler
  • SendCcbsReject() : SsCcbsHandler
  • SendControlString() : SsHandler
  • SendData() : AudioGatiServer, GatiManager
  • SendDataControlBootProgressMsg() : BootControl
  • SendDetectedError() : SsHandler
  • SendEmail() : AbstractSmsApp
  • SendEndReq() : LcsProviderImpl
  • SendEngineeringModeControlRequest() : NetworkHandler
  • SendError() : UssdHandler
  • SendFinalReport() : SocketTestT4, SocketTestT3
  • SendIdleScreenAvailEvent() : SimTkHandler
  • SendImpl() : SmsUtility, AbstractSmsUtilityProcessor, EmsApp
  • SendInterruptedMsg() : ImageIncrementalPdcUpdater, IncrementalPdcUpdater
  • SendLanguageSelectEvent() : SimTkHandler
  • SendMsg() : SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, AbstractScheduler, AbstractAppContext
  • SendNmeaData() : LcsProviderImplBase
  • SendNotification() : PropertyEditor, NotificationArray
  • SendNotificationsToApps() : NotificationTable
  • SendPassword() : GetPasswordMsg, CallBarringHandler
  • SendPasswordResponse() : SsHandler
  • SendPowerDownNotification() : SubSystemManager
  • SendPowerUpNotification() : SubSystemManager
  • SendProactiveCommand() : SimAccessor
  • SendProactiveCommandConfirmation() : SimAccessor
  • SendProgressMsg() : ImageIncrementalPdcUpdater, IncrementalPdcUpdater
  • SendRegisterNotification() : RegAppWin
  • SendRejection() : UssdHandler
  • SendRequestMsg() : SendRequestMsg
  • SendResponse() : BtObexServerService, HttpSocket
  • SendSelf() : Dispatcher
  • SendSetUpMsgToPC() : RegAppWin
  • SendSignal() : StackMsgMapTable
  • SendSimTkRefreshRsp() : SimTkHandler
  • SendSms() : BasicSmsService, AbstractSmsApp, SmsHandler
  • SendSmsMsg() : SendSmsMsg
  • SendTo() : SysSocket
  • SendToManyRecipient() : EmsApp
  • SendUserActivityEvent() : SimTkHandler
  • SendUssdRequest() : MobileOriginatedUssdHandler
  • SendUssdReturnResult() : SsHandler
  • SendVerificationResult() : LcsProviderImplBase, LcsProvider, LcsProviderImpl
  • SerDataConnAccessor() : SerDataConnAccessor
  • SerDataConnProvider() : SerDataConnProvider
  • SerialClientSocket() : SerialClientSocket, SerialSocketSubSystem, SerialSocketData
  • SerialIoAdapter() : SerialIoAdapter, SerialSocket
  • SerialIoSet() : SerialIoSet, SerialSocket, SerialIoAdapter
  • SerialNumber() : Cbs::SerialNumber
  • SerialServerSocket() : SerialServerSocket, SerialSocketSubSystem, SerialSocketData, SerialClientSocket
  • SerialSocket() : SerialSocket, SerialSocketSubSystem, SerialSocketData, SerialIoAdapter
  • SerialSocketDataLock() : SerialSocketDataLock, SerialSocketSubSystem
  • SerialSocketSubSystem() : SerialSocketSubSystem, SerialSocketData
  • SerialSocketThread() : SerialSocketThread, SerialSocketSubSystem
  • SerialTerminalArg() : SerialTerminalArg
  • SerialTerminalListener() : SerialTerminalListener
  • SerialTerminalSocket() : SerialTerminalSocket
  • Server() : Server, ServerClient
  • ServerAddressWin() : ServerAddressWin
  • ServerCallBack() : IrdaObexTransport
  • ServerClient() : ServerClient
  • ServerConfig() : ServerConfig
  • ServerRead() : SocketTestT2
  • Service() : Service, ServiceBroker
  • ServiceGroup() : EnumTranslationTable
  • ServiceInfo() : BtObexServiceTable::ServiceInfo
  • ServicePtr() : ServicePtr< T >
  • ServiceReady() : PhonebookApp, AdvPbApp
  • ServiceThread() : ServiceThread, Timer, System, MsgQueue
  • ServiceThreadStarter() : ServiceThreadStarter
  • ServiceThreadTerminateMsg() : ServiceThreadTerminateMsg
  • Set() : TickValue, RomFont, Rect, Locale, Mp3AudioDevice, SoftkeyBar, BitField< T >, Fraction, CfuService, UsimLanguage, ExtLanguage, RegIterator, Registry, LocalDataStore, TpduPhoneNumberPersist, RegEncoderDecoder, KeyMsgGenerator::Key
  • Set3aExists() : TypeOfAddress
  • Set3aNotExists() : TypeOfAddress
  • SetAborted() : BtObexClientOperationRequest
  • SetAbsoluteDateTime() : CodedTimeStamp
  • SetAbsoluteDays() : TimeSpan
  • SetAbsoluteHours() : TimeSpan
  • SetAbsoluteMinutes() : TimeSpan
  • SetAbsoluteSeconds() : TimeSpan
  • SetAbsoluteWeeks() : TimeSpan
  • SetAbsolutTime() : ValidityPeriod
  • SetAbstractAction() : AbstractButton
  • SetAbsX() : DeviceContext
  • SetAbsY() : DeviceContext
  • SetAccept() : SetupEventCnfArg
  • SetAcceptAuthorization() : BtRespondAuthorizationRequest
  • SetAcceptPairing() : BtSendPasskeyRequest
  • SetAccessDate() : File::Attributes
  • SetAccessor() : UibActionAccessor
  • SetAccessory() : MiscAudioDevice, AccessoryIndMsg, AccessoryIndArg
  • SetAccessoryConfigurationType() : AudioAccessoryConnectedMsg
  • SetAccessPointName() : PdpContext::ActivationStatus
  • SetAccessTime() : File::Attributes
  • SetAccount() : DataConnProfile, PdpContext::Authentication
  • SetAcm() : SimAcmMaxUpdReqArg, SimAcmUpdReqArg, SimAcmMaxReadIndArg, SimAcmReadIndArg
  • SetAction() : PushButton, AbstractButton, MenuItem, CloseAllMsg, ActionMenuAccessor
  • SetActivated() : RejectCallsIndArg
  • SetActivateReporting() : SetChargeUnitsArg, SetAutoChargeArg
  • SetActivationStatus() : PdpContextActivationStatusMsg
  • SetActive() : ObexServerDispatcher, TabButton, BidiManager, SocketSerialTerminalListener
  • SetActiveAuthorizationSet() : WapProfile
  • SetActiveDevice() : BtActiveDeviceWindow
  • SetActiveDuration() : Cbs::Filter
  • SetActiveExtLanguage() : SimTkHandler, SimAuxHandler, DataHandler
  • SetActiveFont() : FontPackConnector, FontManager
  • SetActiveLanguage() : TextPackConnector, LanguageManager
  • SetActiveLanguageByIndex() : TextPackConnector
  • SetActiveLanguageType() : LanguageManager
  • SetActiveLdb() : T9PackConnector
  • SetActivePhysicalPortSet() : WapProfile
  • SetActivePhysicalSet() : WapProfile
  • SetActivePortSet() : WapProfile
  • SetActiveReference() : AudioVoiceMemoOutOfSpaceMsg, AudioSuspendedMsg, AudioStoppedMsg, AudioStartedMsg, AudioResumedMsg, AudioRestartedMsg, AudioRewindStartedMsg, AudioFastForwardStartedMsg, AudioRecordingStoppedMsg, AudioGetPlayPositionMsg, GenericFeatureData
  • SetActiveTab() : TabControl
  • SetActiveTheme() : ThemeManager
  • SetActiveView() : BrowserViewContainer
  • SetActiveWapProfile() : WapProfileMgr
  • SetActiveWin() : PhonebookApp
  • SetActiveWord() : Zi8NoWordFoundMsg, T9NoWordFoundMsg
  • SetActualName() : AudioAccessoryDetails
  • SetAddData() : UsimSmsParamExtIndArg, UsimSmsParamReadIndArg
  • SetAdditionalNames() : VCard
  • SetAdditionalOrgUnit() : VCard
  • SetAdditionalResult() : SimTkRefreshQueryResArg
  • SetAddr() : IpAddr
  • SetAddress() : ObexAbstractPort, PdpContext::ActivationStatus
  • SetAddressText() : SmsSendingConfirmDialog
  • SetAddressType() : VCard
  • SetAddResult() : PinDisableIndArg, PinEnableIndArg
  • SetAdjustWindowTitle() : ItemMenu
  • SetAdnByte() : SimInitIndArg
  • SetAdnChanged() : UsimPbChangedField
  • SetAdnReadWritableState() : SimAccessor
  • SetAdnResult() : DhChannelReceiveIndArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg
  • SetAidingStale() : GltpAssistanceData
  • SetAlarm() : AlarmManager, RealTimeClock
  • SetAlignment() : IndicatorLocation, Indicator
  • SetAllCallsCcm() : CurrentCallMeterMsg, ChargeUnitsIndArg
  • SetAllCallsCharge() : CurrentChargeDataMsg, ChargeIndArg
  • SetAllowed() : RegistrationAllowedMsg, AttachAllowedIndArg
  • SetAlpha() : Color
  • SetAlphabet() : EditorDocument, DataCodingScheme
  • SetAlphaBlendingEnabled() : Bitmap
  • SetAlphaBlendingMode() : DeviceContext, VirtualDisplay
  • SetAlphaId() : AtAlphaTagCnfArg
  • SetAlphaIdentifier() : SsInfoMsg, SsFacilityIndArg, CallIndCallControlInfoArg, AtPbListCnfArg
  • SetAlphaLength() : PbEntryReadIndArg
  • SetAlphaMask() : Bitmap
  • SetAlphaMaskEnabled() : WindowManager
  • SetAlphaSize() : UsimSmsParamReadIndArg
  • SetAlphaValue() : Bitmap
  • SetAnimType() : ItemRendererProperties
  • SetAntiFlicker() : CameraSettings
  • SetAntiFlickerMode() : Camera
  • SetAPart() : IpAddr
  • SetApduDataPtr() : ExtProactiveCmdIndArg, ExtProactiveCmdReqArg, SimGenericReqArg, SimGenericIndArg
  • SetApiDeviceAddress() : BtDeviceAddress
  • SetApn() : DhChannelOpenReqArg, SiChannelOpenPromptReqArg
  • SetApnName() : PsdDataConnProfile
  • SetApoxiHandle() : BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtMultiConnectionController::BtConnection
  • SetAppContainer() : Application
  • SetApplication() : ContextMsg, Feature, DataControlModificationMsg
  • SetAppName() : Application
  • SetAppPtr() : NotificationTableEntry
  • SetArchive() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, FlashFileImp, FatFileImp, FatFile
  • SetArg() : SmsServiceDocumentMsg, SmsServiceMsg, BatteryLoadLevelMsg, CallDeflectionRejectedMsg, CallDeflectionErrIndicationMsg, CallDeflectionIndMsg, SmsPrefStorageMediaChangedMsg, CbsNewDataMsg, SmsSpaceExceededMsg, SmsSendRejectMsg, SmsSendConfirmMsg, SmsNewStatusReportMsg, SmsNewMessageMsg, CellInfoMsg, UssdIndicationMsg, SsErrIndicationMsg, SsRejectedMsg, SsSuccessMsg, HlrSsDataCorruptMsg, UssDataReceivedMsg, PasswordReceivedMsg, InterrogationResultMsg, SsNotificationMsg, SsDataReceivedMsg, BarringInfoReceivedMsg, ForwardingInfoReceivedMsg, ConnectionStatusMsg, RemotePartyActionMsg, DtmfRejectMsg, DtmfStopCnfMsg, DtmfStartCnfMsg, CallInfoMsg, CallDisconnectedMsg, CallDisconnectingMsg, CallSetupProgressMsg, MtcReadyMsg, MtcArrivedMsg, CalledPartyAlertingMsg, MocSetupAcceptMsg, SimTkSendDtmfEndIndMsg, SimTkSendDtmfIndMsg, SimTkRunAtCmdInfoIndMsg, DhChannelChangeStatusResMsg, DhChannelReceiveReqMsg, DhChannelDataAvailableResMsg, DhChannelSendReqMsg, DhChannelCloseReqMsg, DhChannelOpenReqMsg, SimBrowserTermResMsg, SimLaunchBrowserPromptReqMsg, SimLaunchBrowserReqMsg, TermRspCnfMsg, SimSetupIdleModeTextMsg, SimPlayToneMsg, SimSelectItemMsg, SimGetInkeyMsg, SimGetInputMsg, SimDisplayTextMsg, SimResetConfirmationMsg, SimRefreshMsg, SimSsSentMsg, SimSmsSentMsg, SimCallSetupMsg, SiChannelReceiveInfoIndMsg, SiChannelSendInfoIndMsg, SiChannelCloseInfoIndMsg, SiChannelOpenPromptReqMsg, SmsControlIndMsg, UssdControlIndMsg, SsControlIndMsg, CallControlIndMsg
  • SetAssociatedAudioCh() : EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Decoder, VideoDecoder
  • SetAssociatedCandidates() : Zi8Wrapper
  • SetAtMode() : ExtPsdContextListener_SerialTerminal, ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper, SerialTerminal
  • SetAttached() : GprsStatusMsg, HeadSet
  • SetAttachmentFormat() : BtBipAttachment
  • SetAttachStatus() : GprsAttachStatusMsg
  • SetAttributeId() : BtSddbServiceAttribute
  • SetAttributes() : RamHandler, RamFileObj, FatHandler
  • SetAttributesRequested() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • SetAttributeValue() : BtSddbServiceAttribute
  • SetAudioAlwaysOnAccessory() : BtAudioAccessoryService
  • SetAudioCodec() : RecordSettings
  • SetAudioConnected() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • SetAudioError() : AudioErrorMsg
  • SetAudioErrorType() : AudioStoppedMsg
  • SetAudioMode() : Audio, AudioContext
  • SetAudioReference() : AudioErrorMsg
  • SetAudioSwitchPath() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • SetAuthenticationMethod() : WapProfile
  • SetAuthenticationPassword() : WapProfile
  • SetAuthenticationUsername() : WapProfile
  • SetAuthProvider() : Server
  • SetAuthType() : PsdDataConnProfile
  • SetAutoCallSetup() : MocSetupReqArg
  • SetAutoChargeArg() : SetAutoChargeArg
  • SetAutoClearEnabled() : Control
  • SetAutoLayoutEnabled() : Control
  • SetAutomaticDnsServerNegotiation() : PsdDataConn, PdpContext
  • SetAutoStopped() : AudioStoppedMsg
  • SetAutoStoreEnabled() : SmsSettingsRecord
  • SetAvailable() : Feature, BootState
  • SetAvailableByteCount() : StreamingReadInfo
  • SetAvrcpOperationService() : SubUnitReference
  • SetBackgroundColor() : ItemRendererProperties, RichTextCompoundItem, MultiMediaEditorDocument::TextManager, MultiMediaEditor
  • SetBackgroundImage() : ItemRendererProperties, Image
  • SetBacklightMode() : DefaultDisplay, Display, DefaultDisplay
  • SetBacklightState() : MmiSimServer, MmiSimClient
  • SetBacklightTimeout() : DefaultDisplay, Display, DefaultDisplay
  • SetBacklog() : ServerConfig, Server
  • SetBackup() : BtObexSetPathRequest
  • SetBackupFileId() : UriMappingTable
  • SetBalance() : AudioReference
  • SetBalanceLevel() : MediaPlayer
  • SetBandLimits() : RadioAudioDevice
  • SetBaseURL() : SvgPlayer
  • SetBassLevel() : MediaPlayer
  • SetBatteryLoadLevel() : StatusProvider, DataHandler
  • SetBcdPlmn() : SimMccMncIndArg
  • SetBdnByte() : SimInitIndArg
  • SetBdnEnabled() : DataControlPhonebookStateMsg
  • SetBdnReadWritableState() : SimAccessor
  • SetBdnState() : BdnReqArg, BdnIndArg, SimAccessor
  • SetBearerDesc() : DhChannelOpenCnfArg, DhChannelOpenReqArg
  • SetBearerList() : SimLaunchBrowserReqArg
  • SetBearerType() : SiChannelOpenPromptReqArg
  • SetBehavior() : AbstractListBox
  • SetBehaviour() : GridModel
  • SetBit() : DynamicBitVector, BitVector< N >, BitField< T >, Sms
  • SetBitmap() : ImageBox, AbstractButton
  • SetBitNumber() : SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • SetBits() : Bitmap
  • SetBitsPerPixel() : Image, Image::MetaData
  • SetBitValue() : SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • SetBlitRect() : VirtualDisplay
  • SetBlobFileNode() : RegNodeBuffer
  • SetBlobNode() : RegNodeBuffer
  • SetBlocking() : SysSocket, Socket, InetSocket, SerialSocket, SerialTerminalSocket
  • SetBlockingEnabled() : SocketPeer
  • SetBlockingScan() : PlmnDispatcher
  • SetBlockingSend() : SmsDispatcher
  • SetBlue() : Color
  • SetBmpIterator() : Animation, AnimationModel
  • SetBody() : HttpRequest
  • SetBoolean() : DataItem, Property
  • SetBooleanNode() : RegNodeBuffer
  • SetBoolOption() : InetSocket
  • SetBootState() : DataControlEndBootMsg, DataControlBootMsg
  • SetBottom() : Rect, WinRect
  • SetBottomLineGap() : ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor
  • SetBottomSize() : ControlFrameView
  • SetBoundingRect() : PaneObject, Component
  • SetBoxType() : UibRegisterMsg
  • SetBPart() : IpAddr
  • SetBpmfMode() : Zi8Wrapper
  • SetBpmfSpellingMode() : Zi8Wrapper
  • SetBppResult() : BtBppReq
  • SetBppSubState() : BtBppSndFilePushReqRequest
  • SetBrightness() : CameraSettings, DefaultDisplay, Display, Camera, DefaultDisplay
  • SetBrowserOpen() : LcsWapIntf
  • SetBrush() : DeviceContext
  • SetBrushColor() : DeviceContext
  • SetBrushColorHsv() : DeviceContext
  • SetBrushColorRgb() : DeviceContext
  • SetBrushColorValue() : DeviceContext
  • SetBrushStyle() : DeviceContext
  • SetBtapiHandle() : BtAvrcpConnectResponse
  • SetBuffer() : AbstractEditBox, AbstractEditBoxModel, BtBppSndFilePushReqRequest
  • SetBufferingEnabled() : ImageBox
  • SetBufferSize() : DhChannelOpenCnfArg, DhChannelOpenReqArg
  • SetBufSize() : WStrData, StrData
  • SetCacheFilling() : UsimPbSelectReqArg
  • SetCall() : CallHoldRejectedMsg, CallOnHoldMsg
  • SetCallbackActive() : DefaultDisplay, Display, DefaultDisplay
  • SetCallBarringInfo() : SsBarringIndArg
  • SetCallClearingCause() : NwDiscStartIndMsg
  • SetCallControlPerformed() : SsInfoMsg, SsFacilityIndArg, CallIndCallControlInfoArg
  • SetCallControlResult() : SsInfoMsg, SsFacilityIndArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, CallIndCallControlInfoArg
  • SetCallDirection() : MmCallInfo
  • SetCallDiscCause() : CallHoldRejArg, CallDiscReqArg, CallRelIndArg, CallDiscIndArg
  • SetCalledPartyNo() : RedialSetupIndArg
  • SetCalledPartyNumber() : CallControlSetupIndArg
  • SetCallErrorCause() : CallIndArg
  • SetCallEstablishedInfoAlpha() : SimTkCallSetupIndArg
  • SetCallEstablishedInfoIcon() : SimTkCallSetupIndArg
  • SetCallEstCause() : MocSetupReqArg
  • SetCallFwdUncondActive() : SimCphsHandler
  • SetCallHdl() : CtmInfoIndMsg, NwDiscStartIndMsg, CurrentChargeDataMsg, CurrentCallMeterMsg, AocChargingStatusMsg, RedialSuccessMsg, RedialSetupMsg, CallNotifyMsg
  • SetCallId() : MmCallInfo
  • SetCallIndex() : MmCallInfo
  • SetCallInfoAlpha() : SimTkCallSetupIndArg
  • SetCallInfoIcon() : SimTkCallSetupIndArg
  • SetCallLine() : MtcSetupIndArg, MocSetupReqArg, CallIndArg
  • SetCallProgressInd() : CallProgressIndArg
  • SetCallRefuseDirection() : RejectCallsIndArg
  • SetCallRelatedSs() : CallRelatedSsReqArg, CallDeflectSsReqArg
  • SetCallState() : CallIndArg, MmCallInfo
  • SetCallType() : CsdDataConnProfile, MtcSetupComplArg, MtcSetupIndArg, CallIndArg
  • SetCameraMirroring() : MediaRecorder
  • SetCameraNightMode() : MediaRecorder
  • SetCancelableRequest() : BtRequestRunningWindow
  • SetCanceled() : PbSynchronizer
  • SetCandidateSelection() : Zi8Wrapper
  • SetCanSelect() : BtDeviceListWindow
  • SetCapsStatus() : Zi8Wrapper
  • SetCaption() : RadioButtonModel, CheckBoxModel, AbstractEditBox, AbstractEditBoxModel
  • SetCaptionType() : AbstractEditBoxModel
  • SetCaptureImageSize() : VideoCamera, StillCamera, Camera
  • SetCardType() : UsimCardTypeReadIndArg
  • SetCaretAlwaysVisible() : AbstractEditor
  • SetCaretIndex() : AbstractEditor
  • SetCategory() : CalendarRecord, CalendarAddRecordWin
  • SetCause() : StartUp::Data, SsFacilityRejectedMsg, CallHoldRejectedMsg, SimCallSetupRejectedMsg, SimTkSendDtmfEndIndArg, DetachCnfArg, AttachRejArg, NRegStateIndArg, MocSetupRejIndArg, CallSetupBySimtTkReqArg, StartDtmfRejArg
  • SetCbFunction() : NotificationTableEntry
  • SetCbmiData() : SimCbmiUpdReqArg, SimCbmiReadIndArg
  • SetCbmiRange() : SimCbmirUpdReqArg, SimCbmirReadIndArg
  • SetCbs() : CbsNewDataIndArg
  • SetCcbsAction() : SsCcbsResultIndArg
  • SetCcbsEntry() : SsCcbsReCallIndArg
  • SetCcbsStatus() : CcbsStatusMsg, SsCcbsResultIndArg, SsCcbsStatusIndArg
  • SetCcpData() : SimCcpUpdReqArg, SimCcpReadIndArg
  • SetCellHeight() : GridView
  • SetCellId() : CellInfoIndArg, StatusProvider, DataHandler
  • SetCellProperties() : GridLayout
  • SetCellWidth() : GridView
  • SetCenter() : Desktop
  • SetCfuServiceArray() : CfuDataIndArg, StatusProvider, DataHandler
  • SetChangedState() : DhChannelChangeStatusEventArg, DhChannelDataAvailEventArg, SimMruPropertyUpdCnfArg
  • SetChannel() : AudioReference
  • SetChannelData() : DhChannelReceiveIndArg, DhChannelSendReqArg
  • SetChannelDataLength() : DhChannelDataAvailEventArg, DhChannelReceiveReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg
  • SetChannelId() : TimeFeatureObject
  • SetChannelVolume() : CustomSmafPhraseAudioReference, AudioReference, AudioActiveReference
  • SetChar() : CharInputMapItem
  • SetCharacter() : InputCharMsg
  • SetChargeUnitsArg() : SetChargeUnitsArg
  • SetCharset() : BtBipAttachmentDesc, BtBipAttachment, BtBipAttachmentFormat
  • SetChildListener() : PbProviderListener
  • SetChildProvider() : AbstractDelegationProvider, JoinProviderListener
  • SetChineseSelection() : Zi8Wrapper
  • SetChunkSize() : File
  • SetChv() : PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvVerifyReqArg
  • SetChvAction() : ChvChangedMsg, ChvRefreshIndArg
  • SetChvAttempts() : ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg
  • SetChvno() : ChvChangedMsg, PinDisableReqArg, PinEnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg
  • SetChvNo() : SimFileInfoIndArg
  • SetCidx() : DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg
  • SetCingularActive() : InputContext
  • SetClearTextModeEnabled() : PasswordEditor
  • SetClient() : ClientDeregistrationArg, ClientRegistrationArg
  • SetClientId() : HttpSocket, FtpSocket, FtpDataSocket
  • SetClipInfo() : MediaInfo
  • SetClippedWidth() : TabButtonView
  • SetClipRect() : DeviceContext
  • SetClipState() : MmiSimServer
  • SetClirMode() : MocSetupReqArg
  • SetCloseAfterTrigger() : MenuProperties
  • SetCloseCause() : SiChannelCloseInfoIndArg
  • SetCmd() : AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtGenericCmdReqArg
  • SetCmdQualifier() : DhChannelOpenReqArg
  • SetCmiRecord() : SimCmiReadIndArg
  • SetCnfArg() : EngineeringModeControlResponseMsg
  • SetCode() : SsErrorCode
  • SetCodec() : EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder, CodecDevice
  • SetColId() : ProviderListBoxModel
  • SetColor() : Pen, Brush, AbstractTextObject, VirtualDisplay
  • SetColorFormat() : CamWin32
  • SetColorHsv() : Pen, Brush
  • SetColorModeEnabled() : CamWin32
  • SetColorRgb() : Pen, Brush
  • SetColorSpace() : Image::MetaData
  • SetColorValue() : Pen, Brush, VirtualDisplay
  • SetColTitleHeight() : GridView
  • SetColumn() : DefaultCaret, Caret, Cell
  • SetColumnCount() : ItemRendererProperties, ItemGrid, MenuAccessor
  • SetColumnId() : PbProvColListBox, PbProvColListBoxModel
  • SetColumnInfoTable() : Provider
  • SetColumnProperty() : GridLayout
  • SetColumnTitled() : Grid, GridModel
  • SetCommandDetails() : SimLaunchBrowserReqArg
  • SetCommandExecutedCondition() : MapiAudioPlayer
  • SetCommandParameter() : SmsContext
  • SetCommandType() : SmsContext, SmsCommand
  • SetCompanyId() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • SetComplete() : MdhSmsUpdStatusReqArg
  • SetCompoundItem() : EditorItemNode, CompoundItemReferrer
  • SetConcatenatedReferenceNoType() : SmsContext
  • SetConcatenatedSmMaximumNumber() : InformationElement
  • SetConcatenatedSmReferenceNumber() : InformationElement
  • SetConcatenatedSmSequenceNumber() : InformationElement
  • SetConcatenetedStatus() : TpduHeaderInformation
  • SetConcatenetedTpduNum() : TpduHeaderInformation
  • SetConcSmsPduMaxNo() : SimPduHandler, DataHandler
  • SetConfig() : EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AtiMpeg4Encoder, AtiMpeg4Decoder, VideoEncoder, VideoDecoder, AudioEncoder, AudioDecoder
  • SetConfirmed() : BandSelectionMsg, BandSelectionIndArg
  • SetConn() : RtStreamingEndPoint
  • SetConnectableMode() : BtLocalSettings
  • SetConnected() : AudioAccessoryConnectedMsg, AudioAccessoryDetails, ConnectionIndArg
  • SetConnectedDevice() : BtSingleConnectionController
  • SetConnectedNo() : MtcSetupIndArg, MocSetupCnfArg
  • SetConnectedOld() : AudioAccessoryDetails
  • SetConnectionElement() : DataCallContext
  • SetConnectionLost() : UtcStatusMessage
  • SetConnectionOnlyDuringCall() : BtHsService
  • SetConstraintDefaultValue() : DrmPermission
  • SetConsumedCount() : DrmConstraint
  • SetContainerId() : FeatureItemContainer
  • SetContent() : TRadioButtonItem< Content >
  • SetContext() : ContextMsg
  • SetContextId() : FeatureItemContainer, FeatureItem, AtlWindow, PdpContextActivationStatusMsg
  • SetContextItem() : ContextFeatureItem, ContextFeatureTriggerMsg
  • SetContextType() : ContextFeature
  • SetContinue() : AudioReference, MediaPlayer
  • SetContrast() : CameraSettings, DefaultDisplay, Display, Camera, DefaultDisplay
  • SetControl() : ControlMsg, DeviceContext
  • SetControlInfoString() : UssdAnswerMsg
  • SetControlType() : SocketControlMsg, BtAvrcpRawFrameParams
  • SetCopyright() : Melody
  • SetCorner() : MenuProperties
  • SetCount() : SimAcmReadIndArg, PbCountIndArg, DrmConstraint
  • SetCounter() : PdpContext
  • SetCounterText() : SmsComposeWin
  • SetCountry() : VCard
  • SetCPart() : IpAddr
  • SetCphsCfufArray() : CphsCfufUpdReqArg, CphsCfufReadIndArg
  • SetCphsCspArray() : CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspReadIndArg
  • SetCphsIstArray() : CphsIstReadIndArg
  • SetCphsOnmName() : CphsOnmReadIndArg
  • SetCphsOnsName() : CphsOnsReadIndArg
  • SetCphsServAccessible() : SimCphsHandler
  • SetCphsVmwfArray() : CphsVmwfUpdReqArg, CphsVmwfReadIndArg
  • SetCreateDate() : BtBipAttachmentDesc, BtBipAttachment
  • SetCreatedDate() : BtBipImage
  • SetCreatedFrom() : BtBipImageHdlDesc
  • SetCreateDirectory() : BtObexSetPathRequest
  • SetCreatedTo() : BtBipImageHdlDesc
  • SetCreateEmptyObject() : BtObexPutRequest
  • SetCreateTrust() : BtRespondAuthorizationRequest, BtDevicePairRequest
  • SetCreationDate() : File::Attributes
  • SetCreationTime() : File::Attributes
  • SetCropRect() : VideoChannel
  • SetCrss() : MptyCnfArg
  • SetCrssCode() : MtcSetupComplArg, MocSetupCnfArg
  • SetCrssState() : CallHoldRejArg, CallHoldCnfArg
  • SetCrSupported() : TextEditorDocument
  • SetCtm() : CtmInfoIndMsg, SimTkCallSetupAccArg, MtcSetupIndArg, MocSetupReqArg, CtmInfoIndArg, CallIndArg
  • SetCtrlInfo() : SsUssdReqArg, SsSendReqArg
  • SetCtrlInfoString() : UssdAnswerIndArg, SsUssdIndArg, SsUnstructIndArg
  • SetCts() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetCug() : MocSetupReqArg
  • SetCurrencySymbol() : Locale
  • SetCurrentDate() : CalendarMonthWin
  • SetCurrentIndication() : SmsIndicationState
  • SetCurrentPath() : RenameFileDialog
  • SetCurrentRecordIdx() : CalendarApp
  • SetCurrentSelectedDay() : CalendarGrid
  • SetCursorMode() : AbstractEditBox
  • SetCursorPos() : AbstractEditBox, AbstractEditBoxModel
  • SetCursorVisible() : AbstractEditBoxModel
  • SetCustomFrameBufferRect() : DefaultDisplay, Display
  • SetData() : UibSettingsRecord, ToDoRecord, LocationVerifWin, FmRadioStationsRecord, FmRadioSettingsRecord, SmsSettingsRecord, CalendarRecord, CalendarDialogWin, CalendarAddRecordWin, BtHfRecord, PbNumberRecord, PbRecord, PbNextFreeIdRecord, BtSddbDeOneByteDescriptionType, BtServiceVerifyResultMessage, ProviderProxyItem, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, PbEntryUpdReqArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, PathProfile, Record, SmsWStringCache, SmsWStringCache::Entry, SimPbEntry
  • SetDataBits() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetDataBuffer() : Tpdu
  • SetDataCallContext() : CsdDataConnProfile
  • SetDataCallType() : CallIndArg
  • SetDataCodingScheme() : SmsContext, SmsNewMessageIndArg, SmsSubmit, MdhSmsNewMessageIndArg
  • SetDataCodingSchemeExists() : ParameterIndicator
  • SetDataConnectionType() : FtpClient
  • SetDataConnId() : WapProfile
  • SetDataConnProfileId() : SocketData, InetSocket, ServerConfig
  • SetDataConnResult() : GltpProviderImpl
  • SetDataControlType() : DataControlModificationMsg
  • SetDataCounters() : PsdDataConn
  • SetDataItem() : UibSettingsProvider, ToDoProvider, FmRadioStationsProvider, FmRadioSettingsProvider, SmsSettingsProvider, SerDataConnProvider, PsdDataConnProvider, DataConnProvider, CsdDataConnProvider, CalendarProvider, BtHfProvider, PbRecordProvider, PbNumberProvider, PbNameProvider, Provider, DistinctProvider, AbstractDelegationProvider, Property, MergeProvider, JoinProvider, StatusProvider, SmsProvider, SmsParamProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, CphsServPflProvider, CphsAuxProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • SetDataLength() : PbEntryReadIndArg
  • SetDataPtr() : GenericFeatureData
  • SetDataRate() : CsdDataConnProfile
  • SetDataRead() : StreamingReadInfo
  • SetDataSize() : BtServiceVerifyResultMessage
  • SetDataToWrite() : StreamingWriteInfo
  • SetDataType() : DataItem
  • SetDate() : ToDoDateDialogWin, CalendarRecord, CalendarAddRecordWin, DateEditorDocument, DateEditor, DateCompoundItem, DateEditBox, DateTime, DataItem, Property
  • SetDateDisplay() : ToDoComposeWin
  • SetDateFormat() : Locale, DateEditorDocument, DateEditor, DateCompoundItem
  • SetDateIsValid() : CalendarProvider
  • SetDatetime() : TimeZoneMsg
  • SetDateTime() : DateTime, DataItem, Property, SmsNewSocketDataMsg, MnInformationIndArg, TpduHeaderInformation
  • SetDateTimePresent() : MnInformationIndArg
  • SetDay() : Date
  • SetDaylightSavingTime() : MnInformationIndArg
  • SetDaylightSavingTimePresent() : MnInformationIndArg
  • SetDbPath() : MediaRefContainer
  • SetDcd() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetDcs() : SmsNewSocketDataMsg, UssdAnswerIndArg, SsUssdIndArg, SsUnstructIndArg, GetInkeyRspArg, GetInputRspArg
  • SetDecimalSeparator() : Locale
  • SetDecimalString() : Fraction
  • SetDefault() : UibSettingsRecord, FmRadioSettingsRecord, SmsSettingsRecord
  • SetDefaultClirMode() : CallHandler
  • SetDefaultColorHint() : TextCompoundItem
  • SetDefaultCugInfo() : CallHandler
  • SetDefaultDescriptor() : Property
  • SetDefaultHeight() : View
  • SetDefaultIcon() : IconSet
  • SetDefaultItemHeight() : AbstractListBoxView
  • SetDefaultItemId() : SelectItemReqArg
  • SetDefaultPowerOnBehavior() : AlarmManager
  • SetDefaultProfile() : SmsSettingsRecord
  • SetDefaultProgressBarHeight() : CTProgressBarView
  • SetDefaultPushButtonHeight() : CTPushButtonView
  • SetDefaultSize() : Window, AtlWindow
  • SetDefaultSizeProperty() : Window
  • SetDefaultTextString() : GetInputReqArg
  • SetDefaultWidth() : View
  • SetDeflectNumber() : CallDeflectSsReqArg
  • SetDefProfileId() : DataConnProfileManager
  • SetDelay() : Alert, PdpContext::QualityOfService
  • SetDeleteMode() : EditBox
  • SetDeleteObject() : BtObexPutRequest
  • SetDeletionCmd() : MdhSmsDeletionReqArg, MdhSmsDeletionIndArg
  • SetDenominator() : Fraction
  • SetDesc() : AtPbInfoIndArg
  • SetDescription() : CalendarRecord, CallNotifyMsg, NotifyIndArg
  • SetDescriptor() : PropertyItem, PropertyEditor, IndicatorItem
  • SetDestinationAddress() : AbstractSmsComposeWin, SmsContext, SmsCommand, SmsSubmit
  • SetDestinationApplicationPortAddress() : SmsContext
  • SetDestinationNumber() : SmsControlIndArg
  • SetDestIpAddr() : DhChannelOpenReqArg
  • SetDetailColumns() : ProvDetailListBoxWin, PbDetailListBox, PbDetailListBoxModel
  • SetDetailRow() : PbDetailProvider
  • SetDevice() : BtDeviceDetailWindow, BtFaxConnectMessage, BtDunConnectMessage, BtUncancelablePointToPointRequest, BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice, BtMultiConnectionController::BtConnection, BtDeviceList::BtDeviceListNode, AudioActiveReference
  • SetDeviceAddress() : BtServiceVerifyResultMessage, BtRemoteDeviceNameMessage, BtRemoteDeviceMessage, BtGapAndSdapRemoteRequestMessage
  • SetDeviceAndServiceClass() : BtRemoteDeviceMessage, BtDeviceSearchRequest, BtDeviceFilter
  • SetDeviceCapability() : StorageDevice
  • SetDeviceErrorCode() : StreamingInfo
  • SetDeviceFilter() : BtOperationSelectDeviceAndPerformServiceVerify, BtOperationSelectDevice
  • SetDeviceId() : AudioDeviceStatusMsg
  • SetDeviceList() : BtDeviceListProvider, BtCancelableMulticastRequest
  • SetDeviceListNode() : BtDeviceList::BtDeviceListBidirectionalIterator
  • SetDeviceName() : BtServiceVerifyResultMessage, BtRemoteDeviceNameMessage, BtGapAndSdapRemoteRequestMessage
  • SetDeviceRelation() : BtServiceVerifyRequest
  • SetDeviceReleation() : BtOperationSelectDeviceAndPerformServiceVerify
  • SetDeviceState() : BtDeviceFilter
  • SetDeviceStatus() : AudioDeviceStatusMsg
  • SetDeviceVolume() : AudioDeviceBase
  • SetDfId() : SimGenericReqArg, SimGenericIndArg
  • SetDfIdFlag() : SimGenericReqArg
  • SetDfLength() : SimGenericIndArg
  • SetDfParams() : SimGenericIndArg
  • SetDiagnosticCause() : DiagnosticIndArg
  • SetDimensions() : CTWindowFrameView, CTControlFrameView
  • SetDirectory() : File::Attributes, RamFileObj
  • SetDirtyFlag() : DirtyFileHandler
  • SetDisable() : RediallingDisabledIndArg
  • SetDisabled() : Control
  • SetDisconnectingMode() : CallDisconnectedMsg, CallDisconnectingMsg
  • SetDiscoverableMode() : BtLocalSettings
  • SetDispatcher() : Item, BtBppService, AtlWindow
  • SetDisplay() : DeviceContext
  • SetDisplayAndRecordSettings() : MediaRecorder
  • SetDisplayedName() : MetaData
  • SetDisplayIndex() : Control
  • SetDisplayLocation() : MediaPlayer
  • SetDisplaySettings() : MediaRecorder, MediaPlayer
  • SetDisplaySimPos() : PhonebookWin, PbAbstractWin
  • SetDisplayType() : ItemRendererProperties
  • SetDispMapAllowed() : LcsWapIntf
  • SetDocument() : SmsViewerWin, AbstractSmsViewerWin, EmsViewerWin
  • setDocumentLocator() : WbxmlParserRel
  • SetDocumentObtainer() : ToDoComposeWin, SmsComposeWin, AbstractSmsComposeWin, EmsComposeWin
  • SetDomain() : WapProfile
  • SetDPart() : IpAddr
  • SetDpofOptions() : BtBipImagingCapabilities
  • SetDrmAttrib() : FlsFile, FfsHandler
  • SetDrmDcfMessage() : DrmDcfParser
  • SetDrmLocalId() : DrmMessage
  • SetDrmVersion() : DrmRelParser
  • SetDrvId() : AudioMsg
  • SetDsr() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetDstInd() : TimeZone
  • SetDummy() : SimTkCallSetupIndArg
  • SetDuration() : KeyUpMsg, KeyUpInputMapItem
  • SetDuration1() : DhChannelOpenReqArg
  • SetDuration2() : DhChannelOpenReqArg
  • SetDynamicConfig() : EmzMpeg4Encoder, AtiMpeg4Encoder, VideoEncoder
  • SetEccCategory() : MocSetupReqArg, RedialSetupIndArg, MocSetupAccArg, CallIndArg
  • SetEccNetworkArray() : EccListIndArg, EccProvider, DataHandler
  • SetEccRecord() : UsimEccReadIndArg
  • SetEditBox() : EditBoxPagingTimer, EditBoxBlinkTimer
  • SetEditEnable() : AbstractSmsApp
  • SetEditMode() : AbstractEditor, EditBox
  • SetEditor() : MultiTapInputMapper, IpAddrInputMapper, InputMapper, DateTimeInputMapper, Zi8InputMapper, T9InputMapper
  • SetEditorItem() : EditorItemNode
  • SetEditorListener() : EmsEditor
  • SetEfId() : SimGenericReqArg, SimGenericIndArg
  • SetEfIdFlag() : SimGenericReqArg
  • SetEfLength() : SimGenericIndArg
  • SetEfParams() : SimGenericIndArg
  • SetEfRefresh() : SimTkRefreshNewReqArg, SimTkRefreshQueryReqArg, SimTkRefreshReqArg
  • SetEleCount() : Zi8AlphabetBox
  • SetEmail() : PbRecord, SaveEntryInPhonebookMsg, VCard
  • SetEmpty() : Ticks, Rect
  • SetEmptyBytesInTx() : DhChannelSendIndArg
  • SetEmptyNumberText() : PhoneNumber, SmsProvider, SimPduHandler
  • SetEnabled() : Item, GlassPane, AbstractButton, FeatureItem, Feature, AtAccessoryRegisterReqArg
  • SetEnabledProperty() : Item
  • SetEnablePassword() : DhChannelOpenReqArg
  • SetEnciphered() : ConnectionIndArg
  • SetEncoding() : BtBipImageHdlDesc, BtBipImageDesc, BtBipImageFormat
  • SetEncodingFormat() : PngEncoder::EncodingParameters, JpegEncoder::EncodingParameters
  • SetEncodingParams() : ImageEncoder
  • SetEndDate() : DrmConstraint
  • SetEndOfData() : ObexObject, RtStreamingBuffer
  • SetEndOfStream() : StreamingReadInfo
  • SetEndReached() : UsimPlmnReadIndArg
  • SetEntry() : PbEntryReadIndArg
  • SetEntryContainer() : SimPbBaseHandler
  • SetErr() : PngDecoder
  • SetError() : SocketData, InetSocket, ShortMessageFailureCause
  • SetErrorCode() : Image, MptyHoldRejectedMsg, SimErrorMsg, SsErrReqArg, SimErrorIndArg
  • SetErrorInfo() : SmsInfoBox
  • SetErrorMessage() : StreamingInfo
  • SetErrorReason() : BtOperationBase
  • SetEst() : UsimEstReadIndArg
  • SetEstablishCause() : CallIndArg
  • SetEstCause() : RedialSetupIndArg, MocSetupAccArg
  • SetEstCauseChanged() : MocSetupAcceptMsg
  • SetEvent() : CallEventMsg, SvgPlayer, SerialTerminalArg
  • SetEventList() : SimTkSetupEventReqArg
  • SetExclusionGroup() : AudioReference
  • SetExecFn() : Action
  • SetExposure() : Camera
  • SetExtData() : MdhExtendedData
  • SetExtendedAddress() : VCard
  • SetExtendedData() : MdhSmsExtendedDataReqArg, MdhSmsTransmitIndArg, MdhSmsReadIndArg
  • SetExtension() : ParameterIndicator
  • SetExtensionExists() : FunctionalityIndicator
  • SetExtLanguage() : SimTkLanguageNotificationMsg, LanguageSettingIndArg, LanguageSelectEventArg, SimTkLanguageNotificationIndArg
  • SetFalse() : BitField< T >
  • SetFamilyName() : VCard
  • SetFdnEnabled() : DataControlPhonebookStateMsg
  • SetFdnState() : FdnReqArg, FdnIndArg, SimAccessor
  • SetFeature() : FeatureItem, SimTkProfile
  • SetFeatureId() : SoftkeyDesc, DisabledFeatureTriggeredMsg, ContextFeatureTriggerMsg, FeatureTriggerMsg
  • SetFile() : HttpResponse
  • SetFileExtension() : Pathname
  • SetFileId() : SimFileInfoReqArg, SimFileInfoIndArg, DeletedNode
  • SetFileSize() : SimFileInfoIndArg
  • SetFileStatus() : BdnIndArg, FdnIndArg
  • SetFileType() : SimFileInfoIndArg, SimRefreshIndArg
  • SetFilter() : CameraSettings, Camera, CbsStartReqArg
  • SetFilterColumn() : FilterProvider, DistinctProvider
  • SetFilterParamters() : BtBipImagingCapabilities
  • SetFilterRule() : FilterProvider
  • SetFinal() : AtGenericCmdIndArg
  • SetFinishedCommand() : TermRspCnfArg
  • SetFirstCell() : Grid, GridModel
  • SetFirstConsumedInterval() : DrmConstraint
  • SetFirstVisibleColumn() : AbstractGrid
  • SetFirstVisibleIndex() : AbstractLineEditor, AbstractGrid, AbstractListBox, AbstractListBoxModel
  • SetFirstVisibleLine() : AbstractEditBoxModel
  • SetFirstVisibleLineIndex() : AbstractMultiLineEditor, MultiMediaEditor
  • SetFirstVisibleRow() : GridModel
  • SetFlag() : SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadIndArg, SimODynReadIndArg, UsimEstReadIndArg, UsimUstReadIndArg
  • SetFlagState() : SmsIndicationState
  • SetFlash() : CameraSettings, Camera
  • SetFocusMsgProcessingBlocked() : MsgQueue
  • SetFocusPassingEnabled() : AbstractListBox
  • SetFocusPriority() : Window
  • SetFolder() : UibRegisterMsg
  • SetFolderType() : UibSettingsWin, UibFolderWin
  • SetFont() : TextFormat, TextEditorDocument, TextCompoundItem, MultiLineEditor, LineEditor, DeviceContext, AnimatedTextLine, AbstractTextObject, MultiMediaEditorDocument::TextManager, MultiMediaEditor
  • SetFontAlign() : TextFormat, DeviceContext
  • SetFontId() : Theme
  • SetForceUpdate() : MergeProvider
  • SetForegroundColor() : RichTextCompoundItem, MultiMediaEditorDocument::TextManager, MultiMediaEditor
  • SetFormat() : TimeEditBox, DateEditBox, ValidityPeriodFormat
  • SetFormattedName() : VCard
  • SetForwardingInfo() : SsForwardingIndArg
  • SetFractionString() : Fraction
  • SetFrame() : ImageMetaData
  • SetFrameCount() : Image, Image::MetaData
  • SetFrameDelay() : NativeImage
  • SetFrameRate() : CamWin32, VideoCamera
  • SetFrameRect() : VideoChannel
  • SetFrameType() : Control
  • SetFrequency() : FmRadioWindow
  • SetFriendlyName() : BtBipImageProperties
  • SetFtpDataSocket() : FtpClient
  • SetFtpInTransfer() : FtpDataSocket
  • SetFtpOutTransfer() : FtpDataSocket
  • SetFtpSocket() : FtpDataSocket, FtpClient
  • SetFullScreenPerItem() : ItemRendererProperties
  • SetFunction() : EngineeringModeControlRequestArg, EngineeringModeControlResponseArg
  • SetFunkId() : AudioMsg
  • SetGap() : ItemRendererProperties
  • SetGateway() : SimLaunchBrowserReqArg
  • SetGeneralResult() : LaunchBrowserPromptIndArg, SimTkRefreshQueryResArg
  • SetGenericObject() : DataItem, Property
  • SetGenericTrackInfo() : GenericFeatureData
  • SetGenResult() : DhChannelReceiveIndArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelOpenPromptResArg
  • SetGeographicalScope() : Cbs::SerialNumber
  • SetGetFragSize() : ObexDataServer
  • SetGetTotalPlayTimeWaitCondition() : AudioReference
  • SetGivenName() : VCard
  • SetGlassPanePosition() : IndicatorLocation
  • SetGlobalTraceMask() : InternalTracer
  • SetGors() : MdhSmsDeletionIndArg
  • SetGprsAttached() : StatusProvider, DataHandler
  • SetGprsAvailable() : CellInfoIndArg
  • SetGprsClass() : GprsClassReqArg, GprsClassIndArg, StatusProvider, DataHandler
  • SetGprsClassChangeOrigin() : StatusProvider, DataHandler
  • SetGpsFixData() : LocationResultWin
  • SetGraphData() : SatteliteGraphWin
  • SetGreen() : Color
  • SetGroup() : RadioButtonControl, RadioButtonAction, UsimPbGroups
  • SetGroupId() : PbRecord, DataCodingScheme
  • SetGroupsChanged() : UsimPbChangedField
  • SetGsmBand() : GsmBandStateMsg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, StatusProvider, DataHandler
  • SetGsmBandList() : BandSelectionReqArg
  • SetGsmErrorCause() : RegistrationChangeMsg, NRegStateIndArg
  • SetGsmService() : SmsSettingsRecord, MnInformationIndArg
  • SetGsmSignal() : MtcSetupIndArg
  • SetHandle() : AudioMsg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • SetHandler() : Trap
  • SetHeaderBuffer() : BtObexRegisterServerRequest, BtObexRegisterClientRequest
  • SetHeaderEnabled() : TabControl
  • SetHeaderItem() : AbstractItemGrid
  • SetHeight() : ImageMetaData, Size, Rect, ItemRendererProperties, ImageEncoder::EncodingParameters, Image, Image::MetaData, EditorLine, DeviceContext, Component, Bitmap, WinRect, Grid, SvgPlayer
  • SetHfProfileName() : BtHfSupportedProfileMessage
  • SetHfSupportedFeatures() : BtHfSupportedProfileMessage
  • SetHidden() : File, File::Attributes, RootFileImp, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • SetHiddenInfoChanged() : UsimPbChangedField
  • SetHighCutControl() : RadioAudioDevice
  • SetHighlighted() : AnimatedTextLine
  • SetHighLowSideLoInjection() : RadioAudioDevice
  • SetHintBits() : IrdaTransport
  • SetHour() : Time, DateTime
  • SetHsHasRemoteVolumeControl() : BtHsSupportedProfileMessage
  • SetHsProfileName() : BtHsSupportedProfileMessage
  • SetHsv() : Color
  • SetHttpSocket() : HttpClient
  • SetIccId() : PbRecord
  • SetIcon() : Item, IconTextIndicator, IconIndicator, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimLaunchBrowserPromptReqArg, SetupIdleModeTextReqArg, PlayToneReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • SetIconColumnId() : ProviderProxyContainer
  • SetIcondesc() : IconDescReadIndArg
  • SetIconList() : SetupMenuReqArg, SelectItemReqArg
  • SetIconProperty() : Item
  • SetIcons() : IconValueIndicator
  • SetID() : ResourceID
  • SetId() : Component
  • SetIdentifier() : InformationElement
  • SetIdle() : ObexServerDispatcher
  • SetIdleTimeout() : DataConnProfile
  • SetIgnoreManagement() : AudioReference
  • SetIlluminationMode() : Keyboard
  • SetIlluminationTimeout() : Keyboard
  • SetImage() : ImageRef, ImageReadIndArg
  • SetImageChanged() : ImageListBoxModel
  • SetImageDim() : BtBipImageHdlDesc, BtBipImageDesc, BtBipImageFormat
  • SetImageFilter() : ImageBrowserWin
  • SetImageHandle() : BtBipImageProperties
  • SetImageHdl() : BtBipImage
  • SetImageObtainer() : ImageBox
  • SetImageRefObj() : ImageRefGenContainer
  • SetImageSize() : CameraSettings, CamWin32, BtBipImageDesc
  • SetImei1() : ImeiReadIndArg
  • SetImei2() : ImeiReadIndArg
  • SetImgdescriptor() : ImageReadReqArg
  • SetImgObt() : ImgObtObj
  • SetImgRequestType() : ImageReadReqArg
  • SetImmediateResponse() : DisplayTextReqArg
  • SetImmediateSearch() : BtDeviceListWindow
  • SetImmediatlyRerieveRemoteDeviceNames() : BtDeviceSearchRequest
  • SetImsi() : SimInitIndArg, SimAuxHandler
  • SetImsiPlmn() : SimChvHandler
  • SetIndex() : MetaData, Animation, AnimationModel, EditLine, BtObexServerObserverImpl, BtObexSddbServiceObserverImpl, SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg
  • SetIndicateItemContainer() : ItemRendererProperties
  • SetIndicator() : HomezoneMsg, PlmnInfoReqArg, AttachReqArg, HomezoneIndArg, MdhSetWaitIndicatorArray
  • SetIndicatorbarExpansion() : IndicatorBar
  • SetIndicatorBarId() : IndicatorLocation
  • SetIndicatorBarPosition() : IndicatorLocation
  • SetIndicatorDescription() : Indicator
  • SetIndicatorId() : IndicatorDescription
  • SetIndicatorLocation() : IndicatorDescription
  • SetIndicatorVisible() : BtApplication
  • SetInfo() : PbInfoReadIndArg
  • SetInfoAlpha() : PlayToneReqArg
  • SetInfoRequested() : MenuSelectionReqArg
  • SetInitialPrefferedStorageMedia() : SimAccessor, DataHandler
  • SetInitResult() : SimInitIndArg, SimAuxHandler
  • SetInputMapper() : AbstractEditor
  • SetInputValid() : AbstractEditBox, AbstractEditBoxModel
  • SetInquiryAccessCode() : BtDeviceSearchRequest
  • SetInquiryTimeOut() : BtDeviceSearchRequest
  • SetInstanceptr() : MediaManagerMsg
  • SetInt() : NumberPrompt
  • SetIntegerNode() : RegNodeBuffer
  • SetInteriorNode() : RegNodeBuffer
  • SetInternalDisplayIndex() : Control
  • SetInternalRecNo() : TpduHeaderInformation
  • SetInterrogateCcbsResult() : CcbsResultMsg, SsCcbsResultIndArg
  • SetInterval() : DrmConstraint
  • SetInterworking() : ProtocolIdentifier
  • SetInvalid() : ProviderProxyItem, Plmn, BcdPlmn
  • SetInvalidation() : SimFileInfoIndArg
  • SetInvalidNumberText() : PhoneNumber
  • SetIpAddr() : IpAddrPrompt, InetSocketAddr, IpAddrEditorDocument, IpAddrEditor, IpAddrCompoundItem
  • SetIrdaHwTimeout() : IrdaTransport
  • SetIsLsaIdentifierPresent() : StatusProvider, DataHandler
  • SetIsOnSim() : PbNumberRecord
  • SetIsProfileActive() : BtLocalSettings
  • SetIsRegistered() : BtController
  • SetIsServer() : BtObexController::BtObexConnection
  • SetIsWin98Mode() : IrdaTransport
  • SetItem() : ItemLabel, ItemObj
  • SetItemColumnIds() : ProviderProxyItem
  • SetItemContainer() : AbstractItemGrid, AtlItemListWindow
  • SetItemCount() : AbstractListBox, AbstractListBoxModel
  • SetItemHeight() : RadioButtonView, MenuAccessor, CheckBoxView, AbstractListBox
  • SetItemId() : MenuSelectionReqArg, SelectItemRspArg
  • SetItemList() : SetupMenuReqArg, SelectItemReqArg
  • SetItemsNai() : SetupMenuReqArg, SelectItemReqArg
  • SetItemType() : EditorItemNode
  • SetJPEGQuality() : CameraSettings
  • SetJpegQuality() : StillCamera
  • SetKey() : GetInkeyRspArg, StartDtmfReqArg, StartDtmfCnfArg, DrmRightsObject, AesCrypt
  • SetKeyCode() : LockedKeyDownMsg, KeyAutoRepeatMsg, VeryLongKeyPressMsg, LongKeyPressMsg, KeyUpMsg, KeyDownMsg, KeyUpInputMapItem, KeyDownInputMapItem, T9MatrixModeKeypressed, TriggerKeyFeature
  • SetKeyItem() : PbDetailProvider
  • SetLabel() : PropertyDescriptor, AtlLabelListWindow
  • SetLai() : CellInfoIndArg, StatusProvider, DataHandler
  • SetLangFileType() : UsimLangUpdReqArg, UsimLangReadReqArg, UsimLangReadIndArg
  • SetLanguage() : System, Locale, UsimLangUpdReqArg, DataCodingScheme
  • SetLanguageAction() : SetLanguageAction
  • SetLanguageArray() : SimExtLangUpdReqArg, SimLangUpdReqArg, SimExtLangReadIndArg, SimLangReadIndArg
  • SetLanguageId() : Item
  • SetLanguageList() : UsimLangReadIndArg
  • SetLastCcm() : StatusProvider, DataHandler
  • SetLastCcm2() : StatusProvider, DataHandler
  • SetLastCell() : Grid, GridModel
  • SetLastConnectedDevice() : BtHsService
  • SetLastError() : ImageEncoder
  • SetLastFocusedChild() : Control
  • SetLastFocusedControl() : Control
  • SetLastModification() : Provider
  • SetLastPanelPassThroughRequest() : BtAvrcpControllerDeviceListItem
  • SetLastStatus() : TermRspCnfArg
  • SetLastTransaction() : DirtyFileHandler
  • SetLastUsed() : MdhSmsStatusIndArg
  • SetLedState() : MmiSimServer, MmiSimClient
  • SetLeft() : Rect, WinRect
  • SetLeftGap() : RadioButtonView, CheckBoxView
  • SetLeftSize() : ControlFrameView
  • SetLeftSoftkey() : Window
  • SetLength() : EditorItemNode, EditorLine, TextListLine, EditLine, WStrData, StrData, ByteBuffer, UserData, UserDataHeader, UsimEstReadIndArg, UsimLangReadIndArg, UsimPlmnReadIndArg, UsimUstReadIndArg
  • SetLevel() : SignalStrengthLevelIndArg
  • SetLine2VoiceBoxNumber() : SmsSettingsRecord
  • SetLineAlignment() : ParagraphCompoundItem, MultiMediaEditorDocument
  • SetLineHeight() : TextEditorDocument, MultiLineEditor
  • SetLineIndex() : AbstractEditBoxModel
  • SetLineInUse() : SimCphsHandler
  • SetLineLength() : AbstractEditBoxModel
  • SetLineLocked() : SimCphsHandler
  • SetLineSelector() : HomezoneMsg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspUpdIndArg, CphsCspReadIndArg, HomezoneIndArg
  • SetLinger() : SocketPeer
  • SetLingerOption() : SysSocket
  • SetLingerTimeout() : DataConnProfile
  • SetLink() : SimSmsrUpdReqArg, SimSmsrReadIndArg, MdhNewStatusReportIndArg
  • SetLinkRecNo() : MdhSmsReportReadIndArg
  • SetListBox() : AbstractListBoxModel
  • SetListener() : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • SetListIndex() : UsimLangReadReqArg
  • SetLlcSapi() : PdpContext::ActivationStatus
  • SetLocalAddr() : PsdDataConnProfile
  • SetLocalDataSocketAddr() : FtpClient
  • SetLocalDate() : RealTimeClock
  • SetLocalDateTime() : RealTimeClock
  • SetLocalDrmId() : DrmAsset
  • SetLocalId() : DrmWapPushMsg, DrmRightsObject
  • SetLocalIpAddr() : DhChannelOpenReqArg
  • SetLocality() : VCard
  • SetLocalName() : BtLocalSettings
  • SetLocalTime() : RealTimeClock
  • SetLocalTimeZone() : DateTime
  • SetLocation() : MdhSmsReportReadIndArg
  • SetLocationEstimate() : LocationResultWin
  • SetLociData() : UsimCsLociReadIndArg
  • SetLockAction() : SimModifyLockIndArg
  • SetLockCommand() : SimModifyLockReqArg
  • SetLocked() : Keyboard, Display
  • SetLockResult() : SimLockStatusMsg
  • SetLockStates() : SimModifyLockReqArg, SimModifyLockIndArg, SimLockStatusIndArg
  • SetLockTableId() : LockTable
  • SetLsaIdentifier() : LsaIdentityMsg, MnInformationIndArg, StatusProvider, DataHandler
  • SetLsaIdentifierPresent() : LsaIdentityMsg, MnInformationIndArg
  • SetMajorDeviceClass() : BtDeviceAndServiceClass
  • SetMarkDelete() : MetaData
  • SetMarked() : Item
  • SetMasterVolume() : AudioDeviceManager, AudioDeviceBase
  • SetMaxAlphaLength() : AtPbSelectCnfArg
  • SetMaxAlphaTagSize() : PbNameEditBox, PbAdvAddEditEntry
  • SetMaxConcRefNo() : StatusProvider, DataHandler
  • SetMaxFileSize() : RecordSettings
  • SetMaxImageSize() : BtBipImageDesc, BtBipImageFormat
  • SetMaximalFoundDevice() : BtDeviceSearchRequest
  • SetMaximumWidth() : TabButtonView
  • SetMaxInputLen() : GetInputReqArg
  • SetMaxItemCount() : TextEditorDocument
  • SetMaxMessageId() : CbsLimitMsg, CbsLimitIndArg
  • SetMaxNoOfPduCache() : SimPduHandler, DataHandler
  • SetMaxRecognitionTime() : VrEngineParams, TelecaVrEngineParams, DummyVrEngineParams
  • SetMaxRecordingDuration() : RecordSettings
  • SetMaxSilenceTime() : VrEngineParams, TelecaVrEngineParams, DummyVrEngineParams
  • SetMaxTextLength() : PasswordEditor, MultiLineEditor, LineEditor, AbstractEditBox, AbstractEditBoxModel
  • SetMaxUsers() : ServerConfig, Server
  • SetMaxValue() : PositionIndicator
  • SetMaxVisibleItems() : AbstractListBoxModel
  • SetMaxVisibleRows() : GridModel
  • SetMCbData() : EmServThreadMsg
  • SetMCbFnPtr() : EmServThreadMsg
  • SetMdhWaitingIndicatorArray() : SmsMsgWaitingProvider, DataHandler
  • SetMeanRate() : PdpContext::QualityOfService
  • SetMediaName() : StorageDevice
  • SetMediaSink() : RecordSettings
  • SetMediaSinkType() : RecordSettings
  • SetMenuAccessor() : AccessorActionExtension
  • SetMenuDesc() : MenuDescObj
  • SetMenuId() : SoftkeyDesc
  • SetMenuID() : AtlItemMenuWindow, MenuIdObj
  • SetMenuType() : MenuProperties
  • SetMePhoneBookType() : PbEntryRequestMsg, PbSizeRequestMsg, AtPbListCnfArg, AtPbSelectCnfArg, AtPbListReqArg, AtPbSelectReqArg
  • SetMergedProvider() : MergeProvider
  • SetMergeRule() : MergeProvider
  • SetMessageClass() : DataCodingScheme
  • SetMessageCode() : Cbs::SerialNumber
  • SetMessageID() : AudioUserDefinedMsg
  • SetMessageIdentifier() : CbsNewDataRejArg
  • SetMessageNumber() : SmsContext, SmsCommand
  • SetMessageReference() : SmsCommand, SmsSubmit
  • SetMessageText() : UtcStatusMessage, AsyncUnitTestMsg
  • SetMessageType() : SmsContext, ProtocolIdentifier
  • SetMessageWaitIndicators() : SmsHandler
  • SetMetaData() : SoundRef, MediaRef, ImageRef, MediaRef, Image
  • SetMeteringMode() : Camera
  • SetMHAudDevice() : EmServThreadMsg
  • SetMicrophoneGainRequest() : BtHsService, BtHfService, BtAudioAccessoryService
  • SetMiddleGap() : RadioButtonView, CheckBoxView
  • SetMillisecond() : Time, DateTime
  • SetMimeType() : MimeTypeFilter, BtBipAttachmentDesc, BtBipAttachment, BtBipAttachmentFormat, DrmRightsObject
  • SetMinimumQualityOfService() : PdpContext
  • SetMinimumWidth() : TabButtonView
  • SetMinInputLen() : GetInputReqArg
  • SetMinorDeviceClass() : BtDeviceAndServiceClass
  • SetMinute() : Time, DateTime
  • SetMinValue() : PositionIndicator
  • SetMIsAudioMuted() : EmServThreadMsg
  • SetMmfresult() : MediaManagerMsg
  • SetMnRediallingEnabled() : CallHandler
  • SetMode() : PredInputMapper, IconState, Caret, PlmnListReqArg, PlmnInfoReqArg, AttachReqArg, AttachCnfArg, RegStateIndArg, Cbs::Filter, Zi8PredictiveInputBox, Zi8InputMapper, T9PredictiveInputBox, EnglishT9InputMapper, ChineseT9InputMapper, FtpDataSocket, AbstractPredictiveInputBox
  • SetMode_Bopomofo() : ChineseT9Wrapper
  • SetMode_PinYin() : ChineseT9Wrapper
  • SetMode_SimplifiedChineseStroke() : ChineseT9Wrapper
  • SetMode_T9_Latin() : T9InputMapper
  • SetMode_TraditionalChineseStroke() : ChineseT9Wrapper
  • SetModel() : Component
  • SetModificationDate() : File::Attributes
  • SetModificationTime() : File::Attributes
  • SetModificationType() : Provider
  • SetModifiedDate() : BtBipImage
  • SetModifiedFrom() : BtBipImageHdlDesc
  • SetModifiedRow() : Provider
  • SetModifiedTo() : BtBipImageHdlDesc
  • SetModifyDate() : BtBipAttachment
  • SetMoMimeType() : DrmRightsObject
  • SetMonoStereoMode() : StreamAudioReference
  • SetMonth() : Date
  • SetMsgWaitingState() : SmsIndicationState
  • SetMStartStopAudio() : EmServThreadMsg
  • SetMultiKeyMode() : Keyboard
  • SetMultiLine() : ItemRendererProperties
  • SetMultiSlot() : MultiSlotHandler
  • SetMultiSlotMode() : OmMultiSlotReqArg
  • SetMute() : Audio, AudioContext, SpeechSimpleAudioDevice, RadioAudioDevice, AudioDeviceBase, MediaRecorder
  • SetMutex() : FfsTestThread
  • SetName() : PbRecord, PbAdvAddEditEntry, SaveEntryInPhonebookMsg, DataConnProfile, Thread, Application, PreparedSound, Melody, BtBipAttachmentDesc, BtBipAttachment
  • SetNamePrefix() : VCard
  • SetNameRecNo() : PbNumberRecord
  • SetNameSuffix() : VCard
  • SetNativeDim() : BtBipImageProperties
  • SetNativeEncoding() : BtBipImageProperties
  • SetNativeFormat() : BtBipImageProperties
  • SetNativeProperty() : StorageDevice, File, RootFileImp, FlashFileImp
  • SetNativeSize() : BtBipImageProperties
  • SetNavigationGuidance() : Control
  • SetNegation() : FilterProvider
  • SetNetworkNameLong() : NetworkInformationMsg, MnInformationIndArg, StatusProvider, DataHandler
  • SetNetworkNameLongAddCi() : NetworkInformationMsg, MnInformationIndArg
  • SetNetworkNameShort() : NetworkInformationMsg, MnInformationIndArg, StatusProvider, DataHandler
  • SetNetworkNameShortAddCi() : NetworkInformationMsg, MnInformationIndArg
  • SetNetworkSearchMode() : NetworkHandler
  • SetNewchv() : ChvUnblockReqArg, ChvChangeReqArg
  • SetNewCurrentIndication() : SmsIndicationState
  • SetNewRequestState() : BtRequestStateChangedMessage
  • SetNewSmsState() : SmsIndicationState
  • SetNewStatRepState() : SmsIndicationState
  • SetNewWord() : Zi8AddWordMsg, T9AddWordMsg
  • SetNext() : UserDispatcher, DrawableObject, Control, BtMultiConnectionController::BtConnection, BtDeviceList::BtDeviceListNode, LinkableBase, DeletedNode
  • SetNextFreeUniqueId() : PbNextFreeIdRecord
  • SetNextLockTable() : LockTable
  • SetNickname() : IrdaTransport
  • SetNmeaUartSettings() : LcsProviderImplBase, LcsProvider
  • SetNoId() : PbNumberRecord
  • SetNoNvramSms() : MdhSmsTransmitStartIndArg
  • SetNoOfColumns() : Grid, GridModel
  • SetNoOfGroups() : CphsCspUpdReqArg, CphsCspReadReqArg, CphsCspReadIndArg
  • SetNoOfItems() : AbstractListBox, AbstractListBoxModel
  • SetNoOfPages() : Cbs::Filter
  • SetNoOfRows() : Grid, GridModel
  • SetNoOfSaved() : MdhSmsWriteCnfArg
  • SetNoOfSubunitInfoEntries() : BtAvrcpSubunitInfoParams
  • SetNoOfVisibleLines() : AbstractEditBoxModel
  • SetNoSimSms() : MdhSmsTransmitStartIndArg
  • SetNoteDisplay() : ToDoComposeWin
  • SetNotification() : MdhSmsStatusIndArg
  • SetNotifySsArg() : SsNotifyIndArg
  • SetNsapi() : SysSocket
  • SetNumber() : DataItem, GenericFeatureData, Property
  • SetNumberingPlanIdentification() : TypeOfAddress
  • SetNumberNotAvailableText() : PhoneNumber
  • SetNumberOfCharsAcrossDisplay() : SimTkProfile
  • SetNumberOfCharsSupportedInDisplay() : SimTkProfile
  • SetNumberOfRingSignals() : BtHsService
  • SetNumberOfTones() : CustomToneAudioReference
  • SetNumerator() : Fraction
  • SetNumOfNodeRecord() : RegNodeBuffer
  • SetNvRamStorageInfo() : NvRamStorage
  • SetOaPhoneNumber() : SmsNewMessageIndArg
  • SetObexHandle() : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexController::BtObexConnection
  • SetObexResult() : BtBppReq
  • SetObjectDescription() : BtBppSndFilePushReqRequest
  • SetObjectName() : BtBppSndFilePushReqRequest
  • SetObjectTreeURI() : GuidServiceTable
  • SetObjectType() : BtBppSndFilePushReqRequest
  • SetObtainedDocument() : EmsEditor
  • SetOffset() : TimeZone
  • SetOldchv() : ChvChangeReqArg
  • SetOldRequestState() : BtRequestStateChangedMessage
  • SetOnlineMode() : MmCallInfo
  • SetOperands() : BtAvrcpRawFrameParams
  • SetOperandsLength() : BtAvrcpRawFrameParams
  • SetOperation() : BtRequestOperationMessage, BtAvrcpPanelPassThroughParams
  • SetOperationCode() : SsUssdReqArg, UssdAnswerIndArg, SsUssdIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg
  • SetOperationData() : BtAvrcpPanelPassThroughParams
  • SetOperationDataLength() : BtAvrcpPanelPassThroughParams
  • SetOperationService() : BtAvrcpControllerDeviceListItem
  • SetOperationState() : StreamingInfo
  • SetOption() : SysSocket
  • SetOptions() : SetupIdleModeTextReqArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • SetOpType() : DrmPermission
  • SetOrganizationalUnit() : VCard
  • SetOrganizationName() : VCard
  • SetOrientation() : PositionIndicator
  • SetOrig1TextInfoAlpha() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • SetOrig2TextInfoAlpha() : CallControlSetupIndArg
  • SetOriginalRow() : Provider::Modification
  • SetOriginatorApplicationPortAddress() : SmsContext
  • SetOutputFrame() : ScicosMpeg4VideoDecoder
  • SetOwner() : Panel
  • SetPacked() : GetInputRspArg
  • SetPackedTime() : ValidityPeriod
  • SetPacketFilter() : PsdDataConnProfile, PsdDataConn, PdpContext
  • SetPage() : BtAvrcpSubunitInfoParams
  • SetPageFlag() : Zi8SelectionBox, Zi8AlphabetBox
  • SetPaging() : AbstractEditBoxModel
  • SetPairableMode() : BtLocalSettings
  • SetPanelAlignment() : Desktop
  • SetPanelEnabled() : Desktop
  • SetPanelPassThroughParams() : BtAvrcpPanelPassThroughRequest
  • SetPaProfileName() : BtPaSupportedProfileMessage
  • SetParam() : VideoChannel, EngineeringModeControlRequestArg, Accessory
  • SetParam1() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • SetParam2() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • SetParam3() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • SetParam4() : AudioMsg, AudioUserDefinedMsg, AudioGetPlayPositionMsg
  • SetParameter() : PbNameFilterProvider, PbMergeProvider, PbNumberFilterProvider, Provider, FilterProvider, AbstractDelegationProvider, MergeProvider, JoinProvider, DualFilterProvider, AppendProvider
  • SetParameters() : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder, AudioEncoder, AudioDecoder
  • SetParent() : DrawableObject, Control, Component
  • SetParentArea() : DrawableObject
  • SetParentContainer() : ItemContainer, AbstractItemContainer, ProviderProxyContainer
  • SetParentWindow() : AtlItemMenuWindow
  • SetParity() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetPartlyConcSmsStateChangeable() : SimPduHandler, DataHandler
  • SetPasswd() : DataConnProfile
  • SetPassword() : PdpContext::Authentication, SsGetPasswordRspArg, SsPasswordIndArg
  • SetPasswordMode() : AbstractEditBox, AbstractEditBoxModel
  • SetPath() : MetaData, ObexLayer, ObexClient, IrdaObexImpl, BtObexImpl, StreamObexImpl
  • SetPathControlMode() : AudioReference
  • SetPathname() : PathProfile, MCServiceInterfaceMsg, RamFileObj
  • SetPathRequest() : BtObexClientService
  • SetPbAddType() : UsimPbUpdDataReqArg, UsimPbReadDataReqArg, UsimPbUpdDataResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg
  • SetPbAlphaTagRequestBehaviour() : SimHandler, AtcHandler
  • SetPbChangedField() : UsimPbUpdReqArg
  • SetPbCntType() : PbCountReqArg, PbCountIndArg
  • SetPbDescriptor() : UsimPbSelectResArg
  • SetPbFillStatus() : UsimPbFillStatusResArg
  • SetPbHasGrown() : PbSynchronizer
  • SetPbLocation() : UsimPbSelectReqArg, UsimPbSelectResArg
  • SetPbProvider() : PbAbstractWin
  • SetPbRecordRequestBehaviour() : AtcHandler
  • SetPbRefRecord() : UsimPbReadAsyncIndArg, UsimPbReadResArg
  • SetPbRefType() : UsimPbUpdRefReqArg, UsimPbReadRefReqArg, UsimPbUpdRefResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • SetPbResult() : UsimPbReadyIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg
  • SetPbRwRecord() : UsimPbUpdReqArg, UsimPbReadReqArg, UsimPbReadAsyncIndArg, UsimPbReadResArg
  • SetPbSignalType() : UsimPbFillStatusResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg
  • SetPbTitle() : PbAbstractWin
  • SetPbtype() : PbEntryUpdReqArg, PbEntryReadReqArg, PbEntryReadIndArg
  • SetPduNode() : MdhSmsWriteReqArg
  • SetPeakRate() : PdpContext::QualityOfService
  • SetPeer() : UdpSocket
  • SetPeerDataSocketAddr() : FtpClient
  • SetPen() : DeviceContext
  • SetPenColor() : DeviceContext
  • SetPenColorHsv() : DeviceContext
  • SetPenColorRgb() : DeviceContext
  • SetPenColorValue() : DeviceContext
  • SetPendingDataFlag() : IsrDataManager
  • SetPendingState() : SmsIndicationState
  • SetPenStyle() : DeviceContext
  • SetPhoneNo() : PbAdvAddEditEntry, SaveEntryInPhonebookMsg, RedialSetupMsg, MocSetupReqArg
  • SetPhoneNoType() : PbNumberRecord
  • SetPhoneNumber() : SendSmsMsg, SmsServiceDocumentMsg, SmsServiceMsg, PbNumberRecord, CsdDataConnProfile, DataItem, Property, PbAlphaTagRequestMsg, CcbsRecallMsg, DhChannelOpenReqArg, SiChannelOpenPromptReqArg, SimTkCallSetupIndArg, MocSetupRejIndArg, CallIndArg, AtPbListCnfArg, AtAlphaTagCnfArg, AtAlphaTagReqArg
  • SetPhysicalDomain() : WapProfile
  • SetPhysicalPortNumber() : WapProfile
  • SetPhysicalPortService() : WapProfile
  • SetPhysicalProxyAddress() : WapProfile
  • SetPhysicalProxyId() : WapProfile
  • SetPhysicalPushEnabled() : WapProfile
  • SetPinCode() : BtSendPasskeyRequest
  • SetPinYinMode() : Zi8Wrapper
  • SetPinyinSpellingMode() : Zi8Wrapper
  • SetPitch() : AudioReference
  • SetPixel() : VirtualDisplay
  • SetPlayActive() : BtAvrcpControllerDeviceListItem
  • SetPlaybackAndViewfinderOrder() : VideoChannel
  • SetPlaybackContrast() : MediaPlayer
  • SetPlaybackRect() : VideoChannel
  • SetPlaybackVideoQuality() : MediaPlayer
  • SetPlayTime() : AudioPlayTimeMsg
  • SetPlmn() : RegistrationChangeMsg, RegistrationSuccessMsg, UsimPlmnUpdReqArg, PlmnInfoReqArg, AttachReqArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg
  • SetPlmnList() : UsimPlmnReadIndArg
  • SetPlmnScanList() : PlmnScanFinishedMsg, PlmnListCnfArg
  • SetPlmnSearchActive() : NRegStateIndArg
  • SetPluginName() : AtlApplicationPlugin
  • SetPort() : DhChannelOpenReqArg
  • SetPortNo() : InetSocketAddr
  • SetPortNumber() : WapProfile
  • SetPortService() : WapProfile
  • SetPos() : Rect, PaneObject, Component, MenuProperties
  • SetPosIndicatorWidth() : GridView
  • SetPosIndSize() : CTPositionIndicatorView
  • SetPosition() : EditorItemNode, Indicator, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsTransmitIndArg, MediaPlayer
  • SetPositionHint() : TabButton
  • SetPositionIndicatorEnabled() : AbstractMultiLineEditor
  • SetPostalCode() : VCard
  • SetPostOfficeAddress() : VCard
  • SetPosX() : PenUpMsg, PenDownMsg
  • SetPosY() : PenUpMsg, PenDownMsg
  • SetPowerMode() : DefaultDisplay, Display, DefaultDisplay, PowerModeIndMsg, OmPowerUpArg, OmControlIndArg, StatusProvider, DataHandler
  • SetPowerState() : MmiSimServer
  • SetPowerTimeout() : DefaultDisplay, Display, DefaultDisplay
  • SetPrecedence() : PdpContext::QualityOfService
  • SetPreconditions() : UibNotifyTest, UibMsgDisplayTest, UibAccessorTest
  • SetPredInputEnabled() : SmsSettingsRecord
  • SetPreferredFormat() : BtBipImagingCapabilities
  • SetPreferredStorageType() : AbstractSmsApp
  • SetPressed() : RadioButtonItem
  • SetPressedIndex() : SoftkeyBar
  • SetPressedItem() : TRadioButtonList< Content >, RadioButtonList
  • SetPrevConsumedCount() : DrmConstraint
  • SetPrevFirstConsumedInterval() : DrmConstraint
  • SetPreview() : MultiTapCaret
  • SetPrevious() : BtDeviceList::BtDeviceListNode, DeletedNode
  • SetPreviousFrameBuffering() : Image
  • SetPrimaryDnsServerAddress() : DataConnProfile, DataConn
  • SetPrimaryProfileId() : PsdDataConnProfile
  • SetPriority() : ToDoPriorityDialogWin, Thread, Application, AudioContext, AudioReference, MediaRecorder, MediaPlayer
  • SetPriorityGroup() : AudioReference
  • SetProactiveCause() : SimTkRefreshNewRspArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, LaunchBrowserIndArg, SimTkRefreshQueryResArg, SetupIdleModeTextRspArg, PlayToneRspArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, TermRspCnfArg
  • SetProblemCode() : TaggedProblemCode
  • SetProcessId() : SimTkInterfaceIndArg
  • SetProcessSource() : GprsClassIndArg
  • SetProfile() : BtAuthorizationRequiredWindow, DataConnInfoMsg, BtCloseMessage, BtOpenMessage, BtAuthorizationRequiredMessage
  • SetProfileId() : DataConnProfileInfoMsg, WapProfile
  • SetProfileName() : DataConnProfileInfoMsg, WapProfile
  • SetProfileWriteable() : WapProfile
  • SetProgress() : SyncProgressMsg, ProgressBar, AbstractDelegationProvider, JoinProvider, DataControlBootProgressMsg
  • SetProgressMsgEnabled() : Image
  • SetProperties() : AbstractItemRenderer
  • SetProperty() : Window, ToggleActionGroup, TimeEditor, TextLine, TextFormat, TextBox, TabControl, TabButton, RadioButtonGroup, RadioButtonControl, RadioButtonAction, PushButton, ProgressBar, PositionIndicator, PasswordEditor, OpenWindowAction, OpenContextMenuAction, MultiLineEditor, MessageBox, LineEditor, ItemTree, ItemRendererProperties, ItemMenu, ItemGrid, ItemContainer, ItemBox, Item, IpAddrEditor, ImageObtainer, ImageBox, IconSet, GridLayout, FlowLayout, DrawableObject, DateEditor, Control, ContextMenu, Component, CloseWindowAction, CheckBoxControl, CheckBoxAction, AnimatedTextLine, Alert, Action, AbstractToggleAction, AbstractTextObject, AbstractMultiLineEditor, AbstractLineEditor, AbstractItemGrid, AbstractItemContainer, AbstractGrid, AbstractEditor, AbstractButton, CTResourcePack, CamWin32, ValueMappingPropertyDescriptor< T_Container >, PropertyItem, PropertyDescriptor, RangeMappingPolicy, MappingPolicy, ListPropertyDescriptor, IndicatorItem, FeatureItemContainer, FeatureItem, ContextFeatureItem, MenuProperties, MenuDesc, AtlWindow, UsimFilePropertyIndArg, MultiMediaEditor
  • SetPropertyEditorID() : PropertyItem
  • SetPropertyItem() : PropertyEditor, PropertyTriggerMsg
  • SetProrityDisplay() : ToDoComposeWin
  • SetProtocol() : LcsProvider
  • SetProtocolIdentifier() : SmsContext, SmsNewMessageIndArg, SmsCommand, SmsSubmit, SmsDeliver, MdhSmsNewMessageIndArg
  • SetProtocolIdentifierExists() : ParameterIndicator
  • SetProvider() : UibUpdateThreadlet, UibListBoxModel, SmsBasicProvider, ProvDetailListBoxWin, ProvListBoxWin, PbProvListBox, PbProvListBoxModel, PbDetailProvider, ProviderUpdateMsg, ProviderListBoxModel, DataItem, Property, ProviderProxyItem, ProviderProxyContainer
  • SetProviderId() : AppendProvider, DataControlBootProgressMsg
  • SetProviderRow() : ProviderProxyItem
  • SetProvisionFileRef() : SimLaunchBrowserReqArg
  • SetProxyId() : WapProfile
  • SetProxyName() : WapProfile
  • SetProxyProviderId() : WapProfile
  • SetPsLociData() : UsimPsLociReadIndArg
  • SetPtr() : FixedPtrArray< T >
  • SetPuct() : SimPuctUpdReqArg, SimPuctReadIndArg
  • SetPushEnabled() : WapProfile
  • SetQosDelay() : PsdDataConnProfile
  • SetQosMeanRate() : PsdDataConnProfile
  • SetQosPeakRate() : PsdDataConnProfile
  • SetQosPrecedence() : PsdDataConnProfile
  • SetQosReliability() : PsdDataConnProfile
  • SetQuality() : SignalStrengthLevelIndArg
  • SetQualityLevel() : JpegEncoder::EncodingParameters
  • SetQualityOfService() : PsdDataConn, PdpContext, PdpContext::ActivationStatus
  • SetQualityValid() : SignalStrengthLevelIndArg
  • SetQueryRemoteDeviceName() : BtDeviceSearchRequest
  • SetRadioAccessTechnology() : RatStateMsg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, StatusProvider, DataHandler
  • SetRadioFreq() : FmRadioStationsRecord
  • SetRadioLastFreq() : FmRadioSettingsRecord
  • SetRadioLastVolume() : FmRadioSettingsRecord
  • SetRadioOn() : FmRadioApplication
  • SetRadioPriority() : PdpContext::ActivationStatus
  • SetRamFileObj() : RamFileNode
  • SetRange() : PositionIndicator, ValueIndicator
  • SetRangeCount() : RangeMappingPolicy
  • SetRasterOp() : DeviceContext
  • SetRat() : AttachReqArg
  • SetRatChangeMode() : RatChangeModeChangedMsg, OmRatChangeIndArg, StatusProvider, DataHandler
  • SetRate() : AudioReference
  • SetRawFrameParams() : BtAvrcpRawFrameRequest
  • SetRead() : MdhDeletionCmd
  • SetReadEventNotification() : InetSocket
  • SetReadOnly() : DataConnProfile, MultiLineEditor, AbstractEditor, File, File::Attributes, MultiMediaEditor, RootFileImp, RamFileObj, RamFileImp, RamFile, FlashFileImp, FatFileImp, FatFile
  • SetReadOnlyMode() : ToDoComposeWin
  • SetReadType() : UsimFilePropertyReqArg, UsimPlmnReadReqArg, UsimUpdRejArg, UsimUpdCnfArg, UsimReadRecordRejArg, UsimReadRejArg, UsimPlmnReadIndArg
  • SetReady() : SimPbEntryCont
  • SetReadyTimer() : PdpContextManager::AttachStatus
  • SetReason() : ShortMessageStatus
  • SetRecipientPhoneNumber() : SmsNewStatusReportIndArg
  • SetRecno() : UsimLangUpdReqArg, UsimSmsParamUpdReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimSmsParamUpdIndArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, SimAcmReadIndArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, PbEntryReadIndArg, MdhSmsUpdStatusIndArg, IconDescReadReqArg
  • SetRecNo() : SimCmiReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimRefreshIndArg, MdhSmsReportReadIndArg
  • SetRecognitionMode() : VrEngineParams, TelecaVrEngineParams, DummyVrEngineParams
  • SetRecordedSize() : StreamAudioReference
  • SetRecordingDelay() : StreamAudioPlayer
  • SetRecordingRate() : StreamAudioReference
  • SetRecordingWaitCondition() : StreamAudioPlayer
  • SetRecordLength() : SimFileInfoIndArg
  • SetRecordNumber() : PbEntryRequestMsg, AtPbListCnfArg, AtPbListReqArg
  • SetRecordSettings() : MediaRecorder
  • SetRecordTableValue() : RecordHandler
  • SetRecstatus() : MdhSmsUpdStatusReqArg
  • SetRecurrence() : CalendarRecord, CalendarAddRecordWin
  • SetRed() : Color
  • SetRediallingEnable() : CallHdlBase
  • SetRedialStatus() : RedialStatusIndArg
  • SetRefCount() : DrmRightsObject
  • SetReference() : AudioActiveReference
  • SetReferenceLocation() : GltpAssistanceData
  • SetReferenceNumber() : SmsSendCnfArg, SmsNewStatusReportIndArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkSsIndArg, SimTkSmsPpIndArg
  • SetReferenceTime() : GltpAssistanceData
  • SetRefNo() : MdhSmsConcRefNumIndArg
  • SetRefRecno() : UsimPbUpdRefReqArg, UsimPbReadRefReqArg, UsimPbUpdRefResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg
  • SetRefreshIndicator() : SimTkRefreshQueryReqArg
  • SetRefreshPossible() : SimTkRefreshCnfReqArg, SimTkResetCnfReqArg
  • SetRefreshType() : SimRefreshIndArg
  • SetRegion() : VCard
  • SetRegisteredPlmn() : StatusProvider, DataHandler
  • SetRegisterMode() : StatusProvider, DataHandler
  • SetRegisterParams() : BtAvrcpRegisterRequest
  • SetRegisterRejectCause() : StatusProvider, DataHandler
  • SetRegisterStatus() : StatusProvider, DataHandler
  • SetRejectCause() : RegistrationChangeMsg, PdpContextManager::AttachStatus, PdpContext::ActivationStatus, SsCauseIndArg, SsGetPasswordRejArg, SsFacilityRejArg, MocSetupRejArg
  • SetRejectDuplicates() : SmsContext, SmsSubmit
  • SetRejected() : PlmnScanFinishedMsg
  • SetRelativeTime() : ValidityPeriod, CodedTimeStamp
  • SetReleaseComplete() : SsCcbsResultIndArg, SsUssdIndArg, SsCauseIndArg, SsErrIndArg, SsRejArg, SsRetResIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg
  • SetReliability() : PdpContext::QualityOfService
  • SetRemainingDataLength() : DhChannelReceiveIndArg
  • SetRemoteDeviceAddress() : BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow
  • SetRemoteDeviceName() : BtAuthorizationRequiredWindow, BtPasskeyRequiredWindow, BtSetRemoteDeviceNameRequest
  • SetRenderer() : ItemBox, ContextMenu, AbstractItemGrid, ItemLabel
  • SetRendererHint() : ItemRendererProperties
  • SetRendererProperties() : ItemContainer, AbstractItemContainer
  • SetRepaintHint() : GridModel
  • SetRepeatCount() : Image, Image::MetaData, PreparedSound, AudioReference, MediaPlayer
  • SetReplyPathExists() : SmsDeliver
  • SetReplyPathRequested() : SmsSettingsRecord
  • SetReport() : UsimPbLocationIndArg, TestparamReportArg
  • SetReportArg() : EngineeringReportMsg
  • SetReqSent() : LcsAppUtils
  • SetRequestedByteCount() : StreamingReadInfo
  • SetRequestedStackSize() : Thread, Application
  • SetRequestFlags() : ObexObject
  • SetRequestId() : BtRequestMessage
  • SetRequestReplyPath() : SmsContext, SmsSubmit
  • SetRequestReport() : SmsCommand, SmsSubmit
  • SetRequestState() : BtServiceRequest, BtRequest, BtLocalRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBppReq
  • SetRequestStatusReport() : SmsContext
  • SetRequestType() : BtRequestStateChangedMessage, BtAvrcpOperationRequestResponse
  • SetResourcePack() : CustomizableTheme
  • SetResourceUri() : CTResourcePack
  • SetResponse() : BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest
  • SetResponseCode() : ObexObject, BtObexClientOperationRequest
  • SetResponseType() : BtAvrcpOperationRequestResponse, AtResponse
  • SetRestricted() : AutoCallRestrictIndArg
  • SetRestrictedNumberText() : PhoneNumber
  • SetResult() : BtHfCmaPhoneNumberRequired, BtRequestMessage, BtOperationBase, BtApplicationMessage, SsInterrogateIndArg, SmsSendRejArg, SmsSendCnfArg, ExtProactiveCmdIndArg, EngineeringModeControlResponseArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg
  • SetRetranslateEnabled() : Item
  • SetReturnCode() : AudioMsg
  • SetRfCommPortNumber() : BtObexServerAddr
  • SetRfComPort() : BtObexConnectRequest, BtObexClientService
  • SetRgb() : Color
  • SetRi() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetRight() : Rect, WinRect
  • SetRightSize() : ControlFrameView
  • SetRightSoftkey() : Window
  • SetRingInterval() : BtHsService
  • SetRole() : BtAvrcpRegisterParams, BtAvrcpDeRegisterRequest
  • SetRootDir() : ServerConfig
  • SetRootFileType() : RegNodeBuffer
  • SetRow() : ProvDetailListBoxWin, DefaultCaret, Caret, Cell, Provider::Modification
  • SetRowProperty() : GridLayout
  • SetRowTitled() : Grid, GridModel
  • SetRowTitleWidth() : GridView
  • SetRtcEventCallbackFn() : RtcSignalProcessor
  • SetRunning() : FfsTestThreadlet, FfsTestThread, FtpTransfer
  • SetRunningAbortRequest() : BtObexController::BtObexConnection
  • SetRunningRequest() : BtMultiConnectionController::BtConnection
  • SetSampleRate() : StreamAudioReference
  • SetSatelliteData() : SatteliteInfoWin
  • SetSca() : SmsNewSocketDataMsg
  • SetScanActive() : RegistrationChangeMsg
  • SetScanStatus() : StatusProvider, DataHandler
  • SetScNumber() : SmsControlIndArg
  • SetScoPathStatus() : BtHsCmaAudioAsynchronous, BtHfCmaAudioAsynchronous
  • SetScrollDelay() : ItemRendererProperties
  • SetScrollGap() : ItemRendererProperties
  • SetScStrokeMode() : Zi8Wrapper
  • SetSddbCase() : BtObexServerAddr
  • SetSearchStopLevel() : RadioAudioDevice
  • SetSecLockStates() : SimChvHandler, DataHandler
  • SetSecond() : Time, DateTime
  • SetSecondaryDnsServerAddress() : DataConnProfile, DataConn
  • SetSecondFilterColumn() : DualFilterProvider
  • SetSecondFilterRule() : DualFilterProvider
  • SetSeconds() : ValidityPeriod
  • SetSecurity() : BtObexServerAddr
  • SetSecuritySettings() : BtObexRegisterServerRequest, BtObexRegisterClientRequest
  • SetSegmentCount() : SmsSendingConfirmDialog
  • SetSegmentName() : RamFileNode
  • SetSelected() : RadioButtonControl, RadioButtonAction, CheckBoxControl, CheckBoxAction, AbstractToggleAction, CheckBoxItem, CheckBox, CheckBoxModel
  • SetSelectedCell() : Grid, GridModel
  • SetSelectedGroupIndex() : PbSelectGroup
  • SetSelectedIndex() : AbstractItemGrid, AbstractGrid, MenuAccessor, AbstractListBox, AbstractListBoxModel, AtlItemGridWindow, Zi8SelectionBox, SelectionBox
  • SetSelectedNoIndex() : PbDetailListBox, PbDetailListBoxModel
  • SetSelectedNumberTypeIndex() : PbSelectNoType
  • SetSelectedRadioButton() : DataConnOptionWin
  • SetSelectedRadioButtonAction() : RadioButtonGroup
  • SetSelectedRow() : ProvListBoxWin, PbProvListBox, PbProvListBoxModel, PbAbstractWin, AtlItemListWindow
  • SetSelectedSms() : AbstractSmsViewerWin
  • SetSelectedToggleAction() : ToggleActionGroup
  • SetSelection() : AbstractEditor
  • SetSelectionHeight() : ItemRendererProperties
  • SetSelectionMode() : Grid, GridModel
  • SetSelectionStyle() : AbstractEditor
  • SetSelector() : SimAcmUpdReqArg, SimAcmReadReqArg, SimAcmUpdIndArg, SimAcmReadIndArg
  • SetSendDataType() : DhChannelSendReqArg
  • SetSenderID() : AudioUserDefinedMsg
  • SetSenderPhonenumber() : SmsPortDataRecvMsg, SmsNewSocketDataMsg
  • SetSenderPortNo() : SmsNewSocketDataMsg
  • SetSendingConfirmationEnabled() : SmsSettingsRecord
  • SetSendingResult() : SmsHandler, SmsFactory
  • SetSendPreviewMandatory() : SmsSettingsRecord
  • SetSensorImageSize() : CamWin32
  • SetSent() : MdhDeletionCmd
  • SetSeparator() : Item
  • SetSequence() : BootDispatchingArg
  • SetSerialIoSet() : SerialSocketData
  • SetSerialNumber() : CbsNewDataRejArg
  • SetServedCallApp() : RedialSetupIndArg
  • SetServedCallApplication() : RedialSetupMsg
  • SetServerConfig() : Server
  • SetServerDefaultParam() : BtObexServerAddr
  • SetServerTargetString() : BtObexServerAddr
  • SetServerUuid128() : BtObexServerAddr
  • SetService() : BtServiceMessage, SmsSendReqArg
  • SetServiceCenter() : SendSmsMsg, AbstractSmsComposeWin
  • SetServiceCenterAddress() : SmsContext
  • SetServiceCentreAddress() : Tpdu, Sms
  • SetServiceClass() : BtDeviceAndServiceClass
  • SetServicesToVerify() : BtServiceVerifyRequest, BtOperationSelectDeviceAndPerformServiceVerify
  • SetServiceVerifyResult() : BtOperationSelectDeviceAndPerformServiceVerify
  • SetSettingModeTextline() : CameraViewFinderWin
  • SetSetWaitIndicatorArray() : MdhSmsSetWaitingReqArg
  • SetShallTransmit() : MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg
  • SetShortMessageFailure() : SmsSendCnfArg
  • SetShortMessageFailureCause() : SmsSendCnfArg
  • SetShortMessageStatus() : SmsNewStatusReportIndArg
  • SetShutdownAllowed() : Application
  • SetSiClientFlags() : BrowserRegisterReqArg
  • SetSignalQualityLevel() : SignalQualityLevelMsg, StatusProvider, DataHandler
  • SetSignalQualityMax() : SignalQualityLevelMsg, SignalStrengthLevelIndArg, StatusProvider, DataHandler
  • SetSignalStrength() : BtRemoteDeviceMessage
  • SetSignalStrengthLevel() : SignalStrengthLevelMsg, StatusProvider, DataHandler
  • SetSignalStrengthMax() : SignalStrengthLevelMsg, SignalStrengthLevelIndArg, StatusProvider, DataHandler
  • SetSilentReset() : StartUp::Data
  • SetSimAccess() : DataHandler
  • SetSimCallSetupOption() : CallSetupBySimtTkReqArg
  • SetSimData() : SimAccessor
  • SetSimErrorCode() : SimAuxHandler, DataHandler
  • SetSimFlashStoredTpduNum() : TpduHeaderInformation
  • SetSimIndicator() : SimStateChangedMsg, SimAccessor
  • SetSimInfo() : SimInfoIndArg, SimAccessor, DataHandler
  • SetSimInitInfo() : DataHandler
  • SetSimLockStates() : DataHandler
  • SetSimLockStatus() : SimAuxHandler
  • SetSimRecNo() : PbNumberRecord
  • SetSimRefreshPossible() : SimTkHandler, SimAuxHandler, DataHandler
  • SetSimResetPossible() : SimTkHandler, SimAuxHandler, DataHandler
  • SetSimResult() : DhChannelChangeStatusResArg, DhChannelDataAvailableResArg, SimBrowserTermResArg
  • SetSimServiceType() : SimTkSsIndArg
  • SetSimTkMainMenu() : SimTkMainMenuProvider, DataHandler
  • SetSimTkProfile() : SimTkProfileGetCnfMsg, OmSetTermProfileReqArg, OmGetTermProfileCnfArg
  • SetSimtkRelated() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • SetSimUpdateStatus() : BdnIndArg, FdnIndArg
  • SetSingleShot() : FunctionalityIndicator
  • SetSingleSrrPerSmsEnabled() : SmsContext
  • SetSize() : MetaData, Rect, PositionIndicatorView, IconState, PaneObject, Component, WinRect, Grid, BtBipAttachmentDesc, BtBipAttachment, RtStreamingBuffer, File::Attributes
  • SetSkIcon() : SoftkeyDesc
  • SetSkText() : SoftkeyDesc
  • SetSleepDuration() : Cbs::Filter
  • SetSleepMode() : RealTimeClock
  • SetSmsAlertType() : SmsAlert
  • SetSmsComposeEnabled() : AbstractSmsApp
  • SetSmsExtendedData() : SimPduHandler
  • SetSmsHeaderCacheParams() : SimPduHandler, DataHandler
  • SetSmsId() : MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSmsUpdStatusReqArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg
  • SetSmsInfoAlpha() : SimTkSmsPpIndArg
  • SetSmsInfoBoxType() : SmsInfoBox
  • SetSmsInfoIcon() : SimTkSmsPpIndArg
  • SetSmsMoreMessageType() : SmsHandler, SmsSetMoreMessageReqArg, SmsGetMoreMessageStatusIndArg
  • SetSmsParameter() : SimSmsParamHandler, SimSmsParameter
  • SetSmsParamRecord() : UsimSmsParamUpdReqArg
  • SetSmsPortNo() : SmsPortDataRecvMsg, SmsNewSocketDataMsg
  • SetSmsr() : MdhDeletionCmd
  • SetSmsrData() : SimSmsrUpdReqArg, SimSmsrReadIndArg, MdhSmsReportReadIndArg
  • SetSmsReferenceNumber() : SmsContext
  • SetSmsrLocation() : SmsNewStatusReportIndArg, MdhNewStatusReportIndArg
  • SetSmsStatus() : SimRefreshIndArg, SimPduHandler
  • SetSmsStorageType() : TpduHeaderInformation
  • SetSoBroadcastOption() : InetSocket
  • SetSocketData() : SocketControlMsg
  • SetSocketEventListener() : Socket, SerialTerminalSocket
  • SetSocketExecutionContext() : SocketSerialTerminalListener
  • SetSoDebugOption() : InetSocket
  • SetSoDontRouteOption() : InetSocket
  • SetSoftkey() : Window, AtlWindow
  • SetSoftkeyBarHeight() : WindowFrameView
  • SetSoftkeyDesc() : ContextDescription
  • SetSoKeepAliveOption() : InetSocket
  • SetSoLingerOption() : InetSocket
  • SetSoRcvBufOption() : InetSocket
  • SetSoReuseAddrOption() : InetSocket
  • SetSortAsc() : UibSettingsRecord
  • SetSortColumn() : SortProvider
  • SetSorting() : SmsSettingsRecord
  • SetSortKey() : UibSettingsRecord
  • SetSortMode() : ChineseQuickSortProvider
  • SetSortOrder() : SortProvider
  • SetSoSndBufOption() : InetSocket
  • SetSoundFilter() : SoundBrowserWin
  • SetSpeakerGainRequest() : BtHsService, BtHfService, BtAudioAccessoryService
  • SetSpeed() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetSpnStruct() : SimSpnReadIndArg
  • SetSrPos() : MdhNewStatusReportIndArg
  • SetSrStatus() : MdhNewStatusReportIndArg
  • SetSsData() : SsDataIndArg
  • SetSsErrorCode() : SsErrIndArg
  • SetSsInfoAlpha() : SimTkSsIndArg
  • SetSsInfoIcon() : SimTkSsIndArg
  • SetSsOpeartionCode() : UssdAnswerMsg
  • SetSsOperationCode() : SsNotifyIndArg
  • SetSsSequence() : SsInfoMsg, SsFacilityIndArg
  • SetSst() : SimSstReadIndArg
  • SetStackState() : BtStateChangedMessage
  • SetStartDate() : DrmConstraint
  • SetStartDelay() : ItemRendererProperties
  • SetStartFrame() : MP3AudioReference
  • SetStartIndex() : EditorLine, TextListLine, CompoundItemReferrer
  • SetStartpage() : WapProfile
  • SetStartpagePassword() : WapProfile
  • SetStartpageUsername() : WapProfile
  • SetStartParam() : VoiceMemoAudioDevice, ToneAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice
  • SetStartPos() : SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg
  • SetStartPosition() : AudioReference
  • SetStartRecno() : UsimPbUpdReqArg
  • SetState() : ProviderUpdateMsg, Control::NavigationGuidance, Camera, RadioButtonModel, BtAvrcpPanelPassThroughParams, PdpContextManager::AttachStatus, PdpContext::ActivationStatus, FtpClient
  • SetStation() : RadioAudioDevice
  • SetStatus() : LocResController, LcsOptionsMenuWin, LcsMainMenuWin, Provider, SimpleAudioDevice, AocChargingStatusMsg, RegistrationChangeMsg, ChvChangedMsg, ExtPsdContextListener_SioGlueWrapper, Tpdu, SimInitIndArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, ShortMessageStatus, DetachCnfArg, NRegStateIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, ImeiReadIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsRefreshIndArg, AocIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, AtAccessoryRegisterCnfArg, AtGenericCmdIndArg, AtPbListCnfArg, AtPbSelectCnfArg, SioGlueWrapper, TpduCache, TpduHeaderInformation
  • SetStatusChanged() : SmsBasicProvider
  • SetStatusLine() : HttpResponse
  • SetStatusReportEnabled() : SmsSettingsRecord
  • SetStatusReportOnIdleScreen() : SmsSettingsRecord
  • SetStereoMode() : RadioAudioDevice
  • SetStkCallSetupNo() : CallSetupBySimtTkReqArg
  • SetStopBits() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • SetStopCallback() : MapiAudioPlayer, AudioMapiManager
  • SetStopCause() : AudioStoppedMsg
  • SetStorageDeviceId() : PathProfile
  • SetStorageLocation() : SmsSettingsRecord
  • SetStoragePosition() : SmsNewStatusReportIndArg, SmsNewMessageIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsRefreshIndArg
  • SetStorageType() : SmsNewStatusReportIndArg, SmsNewMessageIndArg, MdhSmsNewMessageIndArg
  • SetStorMedia() : MdhSetStorageReqArg
  • SetStreet() : VCard
  • SetString() : DataItem, Property
  • SetStringDeviceAddress() : BtDeviceAddress
  • SetStringNode() : RegNodeBuffer
  • SetStructure() : FtpDataSocket
  • SetStyle() : Pen, Brush
  • SetSubAddr() : DhChannelOpenReqArg, SiChannelOpenPromptReqArg
  • SetSubAddress() : SimTkCallSetupIndArg
  • SetSubmitParameter() : SmsContext
  • SetSubunitId() : BtAvrcpRawFrameParams
  • SetSubunitInfoEntries() : BtAvrcpSubunitInfoParams
  • SetSubunitInfoParams() : BtAvrcpSubunitInfoRequest
  • SetSubunitInfos() : BtAvrcpRegisterParams
  • SetSubunitType() : BtAvrcpRawFrameParams
  • SetSuccess() : OmMultiSlotIndMsg, OmMultiSlotIndArg
  • SetSupportedBandList() : BandStatusMsg, OmBandStatusCnfArg
  • SetSupportedCategories() : BtAvrcpRegisterParams
  • SetSynchronized() : PbSynchronizer
  • SetSynchronizing() : PbSynchronizer
  • SetSyncModeEnabled() : Item
  • SetSyncSoftkeysEnabled() : Window
  • SetSystem() : RamFileObj
  • SetSystemColor() : Theme
  • SetT3310Expiries() : PdpContextManager::AttachStatus
  • SetT3380Expiries() : PdpContext::ActivationStatus
  • SetTabbing() : MultiTapCaret
  • SetTabEnabled() : TabControl
  • SetTaggedProblemCode() : SsRejReqArg, SsRejArg
  • SetTargetDevice() : BtHfProfileWindow, BtAvrcpControllerDeviceListItem, BtObexConnectRequest, BtHsService, BtHfService, BtService, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest
  • SetTargetPath() : BrowserSaveWin
  • SetTcpMaxSetOption() : TcpSocketBase
  • SetTcpNoDelayOption() : TcpSocketBase
  • SetTcStrokeMode() : Zi8Wrapper
  • SetTelematicDevice() : ProtocolIdentifier
  • SetTelematicDeviceText() : SmsSendingConfirmDialog
  • SetTelNumber() : VCard
  • SetTelNumberType() : VCard
  • SetTempo() : AudioReference
  • SetTemporary() : File
  • SetTemporaryLocalTimeZone() : DateTime
  • SetTemporaryProfile() : DataConnProfileInfoMsg
  • SetTermCause() : BrowserTermEventArg
  • SetTerminal() : SerialTerminalSocket, SerialTerminalArg
  • SetTest() : TestparamReqArg
  • SetText() : InfoDialog, SmsServiceMsg, TextEditorDocument, TextCompoundItem, PasswordEditor, MultiLineEditor, LineEditor, Item, AnimatedTextLine, Alert, AbstractTextObject, AbstractButton, TextList, TextListModel, RadioButtonItem, IconTextIndicator, TextIndicator, CheckBoxItem, AbstractEditBox, AbstractEditBoxModel, SubstitutedText, FeatureItem, HomezoneMsg, SsUus1ReqArg, SsUus1IndArg, GetInkeyRspArg, GetInputRspArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, HomezoneIndArg, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, T9PinyinBox, StrokeBox, SelectionBox, InputMapper
  • SetTextAlign() : TextFormat, DeviceContext
  • SetTextAlignment() : Locale
  • SetTextAttr() : TextFormat, DeviceContext, RichTextCompoundItem, MultiMediaEditorDocument::TextManager, MultiMediaEditor
  • SetTextColor() : ItemRendererProperties
  • SetTextColumnId() : ProviderProxyContainer
  • SetTextCompression() : DataCodingScheme
  • SetTextFormat() : ItemRendererProperties, DeviceContext, AnimatedTextLine, Alert, AbstractTextObject
  • SetTextFormatting() : EditorItemNode
  • SetTextIconPair() : TextIconPairArray
  • SetTextInfoAlpha() : CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg
  • SetTextLength() : AbstractEditBoxModel, SimPbEntryCont
  • SetTextList() : SsUus1QueryIndArg
  • SetTextProperty() : Item
  • SetTextString() : SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, SimLaunchBrowserPromptReqArg, SetupIdleModeTextReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg
  • SetThaiMatrixModeWindow() : T9PredictiveInputBox
  • SetTheme() : System
  • SetThemeAction() : SetThemeAction
  • SetThisCallCcm() : CurrentCallMeterMsg, ChargeUnitsIndArg
  • SetThisCallCharge() : CurrentChargeDataMsg, ChargeIndArg
  • SetThousandSeparator() : Locale
  • SetThreadData() : Thread
  • SetThresholdPercentage() : StartSignalStrengthListeningArg
  • SetTid() : SimSetupMenuMsg, SmsSendRejArg, SmsSendCnfArg, SimTkRefreshNewRspArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkRefreshNewReqArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg
  • SetTime() : LocationVerifWin, LcsOptionsMenuWin, LcsMainMenuWin, CalendarRecord, TimeEditorDocument, TimeEditor, TimeCompoundItem, TimeEditBox, DateTime, DataItem, Property
  • SetTimeFormat() : Locale, FunctionalityIndicator
  • SetTimeout() : Timer, SystemTimer, AudioReference
  • SetTimePosition() : SvgPlayer
  • SetTimer() : TimerTimeoutMsg, ExternalTimeoutMsg, SmsConfigIndArg
  • SetTimeStamp() : TimeFeatureObject, MdhSmsTransmitIndArg, MdhSmsRefreshIndArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg
  • SetTimeZone() : TimeZone, CodedTimeStamp, MnInformationIndArg, StatusProvider, DataHandler
  • SetTimeZonePresent() : MnInformationIndArg
  • SetTipd() : TipdBasedActiveWaitDispatcher, UssdAnswerMsg, SsInfoMsg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityIndArg, SsBeginAccArg, SimTkSsIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, RedialSetupIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, ChargeUnitsReqArg, ChargeReqArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, CallDeflectSsReqArg, CallDeflectionIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, CallIndCallControlInfoArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg
  • SetTitle() : Window, MenuAccessor, VCard, PropertyDescriptor, AtlWindow
  • SetTitleAlpha() : SetupMenuReqArg, SelectItemReqArg
  • SetTitleHeight() : WindowFrameView
  • SetTitleIcon() : SetupMenuReqArg, SelectItemReqArg
  • SetTitleText() : AbstractSmsViewerWin
  • SetTitleTextFormat() : WindowFrameView
  • SetTitleTextType() : MenuProperties
  • SetTone() : AudioReference, PlayToneReqArg
  • SetToneId() : PreparedSound
  • SetToneID() : PresetAudioReference
  • SetToneMode() : Zi8Wrapper
  • SetToneType() : CustomToneAudioReference
  • SetTop() : Rect, WinRect
  • SetTopLineGap() : ParagraphCompoundItem, MultiMediaEditorDocument, MultiMediaEditor
  • SetTopSize() : ControlFrameView
  • SetTotalEntries() : AtPbSelectCnfArg
  • SetTpdu() : SmsSendReqArg, MdhSmsTransmitIndArg, MdhSmsNewMessageIndArg, MdhNewStatusReportIndArg
  • SetTpduConc() : MdhSmsReadIndArg
  • SetTpduInformation() : TpduHeaderInformation
  • SetTransactionId() : UriMappingTable
  • SetTransformation() : ImageBrowserDetailWin, CameraSettings, ImageBox, CamWin32, BtBipImageDesc, BtBipImageFormat
  • SetTransmitCause() : MdhSmsTransmitStartIndArg
  • SetTransparent() : Window, ItemRendererProperties, Bitmap
  • SetTransparentColor() : Bitmap
  • SetTranspLayer() : DhChannelOpenReqArg
  • SetTrebleLevel() : MediaPlayer
  • SetTrue() : BooleanCondition, BitField< T >
  • SetTrust() : WapProfile
  • SetTtyMode() : TtyInterface
  • SetTtySpeed() : TtyInterface
  • SetTwilight() : CameraSettings
  • SetTwilightMode() : Camera
  • SetTwilightModeEnabled() : CamWin32
  • SetTwinViewfinderEnabled() : Camera
  • SetType() : ToDoRecord, CalendarRecordsListBoxModel, CalendarRecordsList, CalendarListWin, BtDeviceListWindow, BtRequestRunningWindow, DataConnProfileInfoMsg, DataConnInfoMsg, Provider::Modification, PdpContext::Authentication, SsUus1ReqArg, SsUus1IndArg, SimMruPropertyUpdReqArg, SimMruPropertyRefreshIndArg, MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType, Accessory, FtpDataSocket, MCServiceInterfaceMsg, MediaManagerMsg, DrmConstraint
  • SetTypeOfNumber() : TypeOfAddress
  • SetUibContextId() : UibFolderWin
  • SetUid() : UsimPbUpdResArg, DrmRightsObject
  • SetUInt() : NumberPrompt
  • SetUnblockchv() : ChvUnblockReqArg
  • SetUniqueId() : PbNumberRecord
  • SetUnit() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • SetUnitId() : GltpAidDataRequests
  • SetUnitInfoParams() : BtAvrcpUnitInfoRequest
  • SetUnitType() : BtAvrcpUnitInfoParams, BtAvrcpRegisterParams
  • SetUnknown() : MdhDeletionCmd
  • SetUnread() : MdhDeletionCmd
  • SetUnsent() : MdhDeletionCmd
  • Setup() : DataConn, DataCallHdl, CallHdl, MmCallHdl, MmCallHandler, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp
  • SetupAndRedial() : CallHdl
  • SetupContext() : DataConn
  • SetupDataConn() : SocketData, InetSocket
  • SetupDataConnMsg() : SetupDataConnMsg
  • SetUpdateAction() : UsimLangUpdReqArg, UsimPlmnUpdReqArg
  • SetUpdated() : MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, BootState
  • SetUpdateNumber() : Cbs::SerialNumber
  • SetUpdateOnClose() : AbstractSmsViewerWin
  • SetUpDownPermitted() : AbstractMultiLineEditor
  • SetupDrawingMode() : PngImage
  • SetupEventCnfArg() : SetupEventCnfArg
  • SetupFailedEvent() : DataConn
  • SetupIdleModeTextDone() : SimTkHandler
  • SetupIdleModeTextReqArg() : SetupIdleModeTextReqArg
  • SetupIdleModeTextRspArg() : SetupIdleModeTextRspArg
  • SetupMediaObject() : SoundRefContainer, MediaRefContainer, ImageRefContainer, MediaRefContainer
  • SetupMenuDone() : SimTkHandler
  • SetupMenuReqArg() : SetupMenuReqArg
  • SetupMenuRspArg() : SetupMenuRspArg
  • SetupSucceededEvent() : DataConn
  • SetUri() : RegNodeBuffer, NotificationTableEntry
  • SetUrl() : SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg
  • SetUsage() : ProtocolIdentifier, MessageTypeIndicator
  • SetUsbCharging() : Charger
  • SetUsedBandList() : BandStatusMsg, OmBandStatusCnfArg
  • SetUsedEntries() : AtPbSelectCnfArg
  • SetUseInbandRinging() : BtHfService, BtAudioAccessoryService
  • SetUseMessageInterface() : BtObservableService
  • SetUserDataExists() : ParameterIndicator
  • SetUserDataHeaderExists() : SmsCommand, SmsSubmit
  • SetUserId() : FlsFile
  • SetUserInput() : CallControlUssdIndArg, CallControlSsIndArg, SimTkSsIndArg
  • SetUserInputLanguage() : CallControlUssdIndArg, CallControlSsIndArg, SimTkSsIndArg
  • SetUserLogin() : DhChannelOpenReqArg
  • SetUserPassword() : DhChannelOpenReqArg
  • SetUseStaticFonts() : FontManager
  • SetUsimPbResult() : UsimPbReadyMsg
  • SetUst() : UsimUstReadIndArg
  • SetValid() : PbNumberRecord, PbRecord, SimAlphaIdentifier, ParameterIndicator
  • SetValidityPeriod() : SmsSendingConfirmDialog, SmsContext, SmsSubmit
  • SetValidityPeriodFormat() : SmsSubmit
  • SetValue() : ObexHeaderBuilder, RadioButtonControl, PositionIndicator, Color, CheckBoxControl, AbstractToggleAction, RadioButtonItem, ValueIndicator, BtSddbDeVariableLengthType, BtSddbDeByteBlockType, BtSddbDeBoolean, BtSddbDeUuid32, BtSddbDeUuid16, BtSddbDeSint32, BtSddbDeSint16, BtSddbDeSint8, BtSddbDeUint32, BtSddbDeUint16, BtSddbDeUint8, IndexTable< T >, EccCategory
  • SetVerticalCentered() : TextBox, ItemRendererProperties
  • SetVibrationState() : MmiSimServer, MmiSimClient
  • SetVideoClockTime() : EmzMpeg4Decoder, EmzH264Decoder, AtiMpeg4Decoder, VideoDecoder
  • SetVideoCodec() : RecordSettings
  • SetVideoSize() : VideoChannel
  • SetView() : Component, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg
  • SetViewConfig() : MdhSetConfigReqArg
  • SetViewFinder() : CamWin32
  • SetViewfinderRect() : VideoCamera, Camera
  • SetViewFinderRectToNewFormat() : CameraViewFinderWin
  • SetViewHdl() : MdhRemoveViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSmsUpdStatusReqArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSmsUpdStatusIndArg, MdhRegistrationCnfArg
  • SetViewportSize() : SvgImage
  • SetViewScalingMethod() : Camera
  • SetVisible() : DrawableObject, DefaultCaret, Caret, Indicator
  • SetVisibleValuesCount() : PositionIndicator
  • SetVmic() : MiscAudioDevice
  • SetVoiceBoxNumber() : SmsSettingsRecord
  • SetVoiceMsgWaiting() : SimCphsHandler
  • SetVolume() : SpeechAudioDevice, RingerAudioDevice, Audio, AudioContext, AudioReference, AudioDeviceBase, AudioActiveReference, AudioAccessoryDetails, RamFileObj
  • SetVolume_Implementation() : DwdPlayer
  • SetVolumeLevel() : MediaPlayer
  • SetVolumeSpeech() : Audio
  • SetWaitIndicatorArray() : MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg
  • SetWaitingBoxVisible() : AbstractSmsApp
  • SetWaitingMessage() : DataCodingScheme
  • SetWaitingMessageIndication() : DataCodingScheme
  • SetWapPushReceived() : WapHandler
  • SetWarningLevel() : SmsCapacityExceededArg
  • SetWCharForBcdCode() : PhoneNumber
  • SetWhiteBalance() : CameraSettings, Camera
  • SetWidth() : ImageMetaData, Size, Rect, ImageEncoder::EncodingParameters, Image, Image::MetaData, DeviceContext, Component, Bitmap, WinRect, Grid, SvgPlayer
  • SetWin() : OpenPbWinMsg
  • SetWindow() : CalendarRecordsList, CalendarListWin, OpenWindowAction, CloseWindowAction
  • SetWindowTitle() : ContextDescription
  • SetWord() : Zi8EnteredUnknownWordMsg, T9EnteredUnknownWordMsg
  • SetWorkMedia() : MdhSmsTransmitIndArg, MdhSmsStorageRefreshIndArg
  • SetWrapPolicy() : AbstractMultiLineEditor
  • SetWriteByteCount() : StreamingWriteInfo
  • SetWrittenByteCount() : StreamingWriteInfo
  • SetWrongStatus() : TpduHeaderInformation
  • SetWspVersion() : WapProfile
  • SetWString() : DataItem, Property
  • SetWStringCashPos() : TpduHeaderInformation
  • SetWwwDir() : HttpServerConfig
  • SetX() : Point
  • SetXPos() : Rect, Component
  • SetY() : Point
  • SetYear() : Date
  • SetYPos() : Rect, Component
  • SetZi8EnglishMode() : Zi8Wrapper
  • SetZi8GermanMode() : Zi8Wrapper
  • SetZi8SymbolMode() : Zi8Wrapper
  • SetZoom() : CameraSettings, VideoCamera, Camera
  • SetZoomLevel() : CamWin32, SvgPlayer, SvgImage
  • ShallExecuteImmediatly() : LanguageResetAction, PinAction, EngModeAction, ImeiShowAction, PbEntryShowAction, InputAction
  • ShallRejectDuplicates() : SmsContext
  • ShallRequestReplyPath() : SmsContext
  • ShallRequestStatusReport() : SmsContext
  • ShallStoreMessage() : InformationElement
  • SharedPtr() : SharedPtr< T_obj >
  • SharedTimer() : SharedTimer
  • SharedTimerMsg() : SharedTimerMsg
  • SharedTriggerTimer() : SharedTriggerTimer< T >
  • ShiftIndexTableDown() : AbstractDelegationProvider
  • ShiftIndexTableUp() : AbstractDelegationProvider
  • ShiftIndexTableValues() : AbstractDelegationProvider
  • ShortDayName() : Date
  • ShortMessageFailureCause() : ShortMessageFailureCause
  • ShortMessageFailureExists() : SmsSendDispatcher
  • ShortMessageStatus() : ShortMessageStatus
  • ShortMonthName() : Date
  • ShowArrivedSms() : AbstractSmsApp
  • ShowHint() : MultiTapCaret, Caret
  • ShowSms() : AbstractSmsApp
  • ShowViewfinder() : Camera
  • ShowWaitingBox() : UibApp
  • ShrinkString() : PbManualSynchronizer
  • ShutDown() : System, AbstractScheduler, GatiManager, System, Fota, DeviceManager, PowerHandler
  • Shutdown() : SysSocket, SocketRxThread, InetSocket, DnsClient, StorageDevice, SerialSocketThread, DataHandler
  • ShutdownRequestMsg() : ShutdownRequestMsg
  • SiChannelCloseInfoIndArg() : SiChannelCloseInfoIndArg
  • SiChannelCloseInfoIndMsg() : SiChannelCloseInfoIndMsg
  • SiChannelCloseInfoResArg() : SiChannelCloseInfoResArg
  • SiChannelCloseReqArg() : SiChannelCloseReqArg
  • SiChannelOpenPromptReqArg() : SiChannelOpenPromptReqArg
  • SiChannelOpenPromptReqMsg() : SiChannelOpenPromptReqMsg
  • SiChannelOpenPromptResArg() : SiChannelOpenPromptResArg
  • SiChannelReceiveInfoIndArg() : SiChannelReceiveInfoIndArg
  • SiChannelReceiveInfoIndMsg() : SiChannelReceiveInfoIndMsg
  • SiChannelReceiveInfoResArg() : SiChannelReceiveInfoResArg
  • SiChannelSendInfoIndArg() : SiChannelSendInfoIndArg
  • SiChannelSendInfoIndMsg() : SiChannelSendInfoIndMsg
  • SiChannelSendInfoResArg() : SiChannelSendInfoResArg
  • SigDispatcher() : SigDispatcher
  • SigHandler() : SigHandler
  • SignalMapTableNode() : SignalMapTableNode, SignalMapTable
  • SignalQualityLevelMsg() : SignalQualityLevelMsg
  • SignalSelect() : SerialIoSet
  • SignalStrengthLevelIndArg() : SignalStrengthLevelIndArg
  • SignalStrengthLevelMsg() : SignalStrengthLevelMsg
  • SimAccessor() : SimAccessor, DataHandler
  • SimAcmMaxReadIndArg() : SimAcmMaxReadIndArg
  • SimAcmMaxReadReqArg() : SimAcmMaxReadReqArg
  • SimAcmMaxUpdIndArg() : SimAcmMaxUpdIndArg
  • SimAcmMaxUpdReqArg() : SimAcmMaxUpdReqArg
  • SimAcmReadIndArg() : SimAcmReadIndArg
  • SimAcmReadReqArg() : SimAcmReadReqArg
  • SimAcmUpdIndArg() : SimAcmUpdIndArg
  • SimAcmUpdReqArg() : SimAcmUpdReqArg
  • SimAlphaIdentifier() : SimAlphaIdentifier
  • SimApduData() : SimApduData
  • SimAtom() : SimAtom< T >
  • SimAuxHandler() : SimAuxHandler
  • SimBrowserTermResArg() : SimBrowserTermResArg
  • SimBrowserTermResMsg() : SimBrowserTermResMsg
  • SimCallSetupMsg() : SimCallSetupMsg
  • SimCallSetupRejectedMsg() : SimCallSetupRejectedMsg
  • SimCbmiReadIndArg() : SimCbmiReadIndArg
  • SimCbmiReadReqArg() : SimCbmiReadReqArg
  • SimCbmirReadIndArg() : SimCbmirReadIndArg
  • SimCbmirReadReqArg() : SimCbmirReadReqArg
  • SimCbmirUpdIndArg() : SimCbmirUpdIndArg
  • SimCbmirUpdReqArg() : SimCbmirUpdReqArg
  • SimCbmiUpdIndArg() : SimCbmiUpdIndArg
  • SimCbmiUpdReqArg() : SimCbmiUpdReqArg
  • SimCcpReadIndArg() : SimCcpReadIndArg
  • SimCcpReadReqArg() : SimCcpReadReqArg
  • SimCcpUpdIndArg() : SimCcpUpdIndArg
  • SimCcpUpdReqArg() : SimCcpUpdReqArg
  • SimChvHandler() : SimChvHandler
  • SimClutEntry() : SimClutEntry
  • SimCmiReadIndArg() : SimCmiReadIndArg
  • SimCmiReadReqArg() : SimCmiReadReqArg
  • SimCphsHandler() : SimCphsHandler
  • SimDispatcher() : SimDispatcher
  • SimDisplayTextMsg() : SimDisplayTextMsg
  • SimDisplayTextOptions() : SimDisplayTextOptions
  • SimEndTransactionMsg() : SimEndTransactionMsg
  • SimErrorIndArg() : SimErrorIndArg
  • SimErrorMsg() : SimErrorMsg
  • SimExtLangReadIndArg() : SimExtLangReadIndArg
  • SimExtLangReadReqArg() : SimExtLangReadReqArg
  • SimExtLangUpdIndArg() : SimExtLangUpdIndArg
  • SimExtLangUpdReqArg() : SimExtLangUpdReqArg
  • SimFileInfoIndArg() : SimFileInfoIndArg
  • SimFileInfoReqArg() : SimFileInfoReqArg
  • SimFullAccessIndArg() : SimFullAccessIndArg
  • SimGenericIndArg() : SimGenericIndArg
  • SimGenericReqArg() : SimGenericReqArg
  • SimGetInkeyMsg() : SimGetInkeyMsg
  • SimGetInkeyOptions() : SimGetInkeyOptions
  • SimGetInputMsg() : SimGetInputMsg
  • SimGetInputOptions() : SimGetInputOptions
  • SimHandler() : SimHandler, SimDispatcher
  • SimIconDescription() : SimIconDescription
  • SimIconIdentifier() : SimIconIdentifier
  • SimIconQualifier() : SimIconQualifier
  • SimImage() : SimImage
  • SimImageDescriptor() : SimImageDescriptor
  • SimIndicator() : EnumTranslationTable
  • SimInfoIndArg() : SimInfoIndArg
  • SimInitIndArg() : SimInitIndArg
  • SimItemId() : SimItemId
  • SimItemIdentifier() : SimItemIdentifier
  • SimLangReadIndArg() : SimLangReadIndArg
  • SimLangReadReqArg() : SimLangReadReqArg
  • SimLangUpdIndArg() : SimLangUpdIndArg
  • SimLangUpdReqArg() : SimLangUpdReqArg
  • SimLaunchBrowserPromptReqArg() : SimLaunchBrowserPromptReqArg
  • SimLaunchBrowserPromptReqMsg() : SimLaunchBrowserPromptReqMsg
  • SimLaunchBrowserReqArg() : SimLaunchBrowserReqArg
  • SimLaunchBrowserReqMsg() : SimLaunchBrowserReqMsg
  • SimLockStatusIndArg() : SimLockStatusIndArg
  • SimLockStatusMsg() : SimLockStatusMsg
  • SimMccMncIndArg() : SimMccMncIndArg
  • SimMenuItemSelectionFailedMsg() : SimMenuItemSelectionFailedMsg
  • SimMexeCertificate() : SimMexeCertificate
  • SimModifyLockIndArg() : SimModifyLockIndArg
  • SimModifyLockReqArg() : SimModifyLockReqArg
  • SimMruPropertyRefreshIndArg() : SimMruPropertyRefreshIndArg
  • SimMruPropertyUpdCnfArg() : SimMruPropertyUpdCnfArg
  • SimMruPropertyUpdReqArg() : SimMruPropertyUpdReqArg
  • SimNextActionIdentifier() : SimNextActionIdentifier
  • SimODyn2ReadIndArg() : SimODyn2ReadIndArg
  • SimODyn2ReadReqArg() : SimODyn2ReadReqArg
  • SimODyn2UpdIndArg() : SimODyn2UpdIndArg
  • SimODyn2UpdReqArg() : SimODyn2UpdReqArg
  • SimODynReadIndArg() : SimODynReadIndArg
  • SimODynReadReqArg() : SimODynReadReqArg
  • SimODynUpdIndArg() : SimODynUpdIndArg
  • SimODynUpdReqArg() : SimODynUpdReqArg
  • SimPbBaseHandler() : SimPbBaseHandler
  • SimPbEntry() : SimPbEntry
  • SimPbEntryCont() : SimPbEntryCont
  • SimPduHandler() : SimPduHandler, DataHandler
  • SimPhoneBookEntry() : SimPhoneBookEntry
  • SimPlayToneMsg() : SimPlayToneMsg
  • SimpleAppContext() : SimpleAppContext
  • SimpleAudioDevice() : SimpleAudioDevice
  • SimpleMap() : SimpleMap< TKey, TValue >
  • SimpleMapElem() : SimpleMapElem< TKey, TValue >
  • SimpleMutex() : SimpleMutex
  • SimpleScheduler() : SimpleScheduler
  • SimpleSemaphore() : SimpleSemaphore
  • SimpleTextRenderer() : SimpleTextRenderer
  • Simplify() : Fraction
  • SimPuctReadIndArg() : SimPuctReadIndArg
  • SimPuctReadReqArg() : SimPuctReadReqArg
  • SimPuctUpdIndArg() : SimPuctUpdIndArg
  • SimPuctUpdReqArg() : SimPuctUpdReqArg
  • SimRefreshIndArg() : SimRefreshIndArg
  • SimRefreshMsg() : SimRefreshMsg
  • SimRefreshReqArg() : SimRefreshReqArg
  • SimRefreshResetMsg() : SimRefreshResetMsg
  • SimResetConfirmationMsg() : SimResetConfirmationMsg
  • SimResetDoneMsg() : SimResetDoneMsg
  • SimSelectItemMsg() : SimSelectItemMsg
  • SimSelectItemOptions() : SimSelectItemOptions
  • SimServices() : SimServices
  • SimSetupIdleModeTextMsg() : SimSetupIdleModeTextMsg
  • SimSetupIdleModeTextOptions() : SimSetupIdleModeTextOptions
  • SimSetupMenuMsg() : SimSetupMenuMsg
  • SimSetupMenuOptions() : SimSetupMenuOptions
  • SimSmsParameter() : SimSmsParameter
  • SimSmsParamHandler() : SimSmsParamHandler
  • SimSmsrReadIndArg() : SimSmsrReadIndArg
  • SimSmsrReadReqArg() : SimSmsrReadReqArg
  • SimSmsrUpdIndArg() : SimSmsrUpdIndArg
  • SimSmsrUpdReqArg() : SimSmsrUpdReqArg
  • SimSmsSentMsg() : SimSmsSentMsg
  • SimSpnReadIndArg() : SimSpnReadIndArg
  • SimSpnReadReqArg() : SimSpnReadReqArg
  • SimSsSentMsg() : SimSsSentMsg
  • SimSstReadIndArg() : SimSstReadIndArg
  • SimSstReadReqArg() : SimSstReadReqArg
  • SimStateChangedMsg() : SimStateChangedMsg
  • SimTextString() : SimTextString
  • SimTkCallSetupAccArg() : SimTkCallSetupAccArg
  • SimTkCallSetupIndArg() : SimTkCallSetupIndArg
  • SimTkCallSetupRejArg() : SimTkCallSetupRejArg
  • SimTkHandler() : SimTkHandler
  • SimTkInterfaceIndArg() : SimTkInterfaceIndArg
  • SimTkLanguageNotificationIndArg() : SimTkLanguageNotificationIndArg
  • SimTkLanguageNotificationMsg() : SimTkLanguageNotificationMsg
  • SimTkMainMenuProvider() : SimTkMainMenuProvider
  • SimTkProfile() : SimTkProfile
  • SimTkProfileFactoryReset() : SimTkHandler
  • SimTkProfileGetCnfMsg() : SimTkProfileGetCnfMsg
  • SimTkProfileSetCnfMsg() : SimTkProfileSetCnfMsg
  • SimTkProfileSetRejMsg() : SimTkProfileSetRejMsg
  • SimTkRefreshCnfIndArg() : SimTkRefreshCnfIndArg
  • SimTkRefreshCnfReqArg() : SimTkRefreshCnfReqArg
  • SimTkRefreshNewReqArg() : SimTkRefreshNewReqArg
  • SimTkRefreshNewRspArg() : SimTkRefreshNewRspArg
  • SimTkRefreshQueryReqArg() : SimTkRefreshQueryReqArg
  • SimTkRefreshQueryResArg() : SimTkRefreshQueryResArg
  • SimTkRefreshReqArg() : SimTkRefreshReqArg
  • SimTkRefreshResetReqArg() : SimTkRefreshResetReqArg
  • SimTkRefreshResetRspArg() : SimTkRefreshResetRspArg
  • SimTkRefreshRspArg() : SimTkRefreshRspArg
  • SimTkRefreshStartMsg() : SimTkRefreshStartMsg
  • SimTkResetCnfArg() : SimTkResetCnfArg
  • SimTkResetCnfIndArg() : SimTkResetCnfIndArg
  • SimTkResetCnfReqArg() : SimTkResetCnfReqArg
  • SimTkRunAtCmdInfoIndArg() : SimTkRunAtCmdInfoIndArg
  • SimTkRunAtCmdInfoIndMsg() : SimTkRunAtCmdInfoIndMsg
  • SimTkRunAtCmdInfoResArg() : SimTkRunAtCmdInfoResArg
  • SimTkSendDtmfCnfArg() : SimTkSendDtmfCnfArg
  • SimTkSendDtmfEndIndArg() : SimTkSendDtmfEndIndArg
  • SimTkSendDtmfEndIndMsg() : SimTkSendDtmfEndIndMsg
  • SimTkSendDtmfIndArg() : SimTkSendDtmfIndArg
  • SimTkSendDtmfIndMsg() : SimTkSendDtmfIndMsg
  • SimTkSetupEventMsg() : SimTkSetupEventMsg
  • SimTkSetupEventReqArg() : SimTkSetupEventReqArg
  • SimTkSmsPpIndArg() : SimTkSmsPpIndArg
  • SimTkSmsPpRspArg() : SimTkSmsPpRspArg
  • SimTkSsIndArg() : SimTkSsIndArg
  • SimTkSsRspArg() : SimTkSsRspArg
  • SimTkStopSendDtmfReqArg() : SimTkStopSendDtmfReqArg
  • SimTkTransactionId() : SimTkTransactionId
  • SimUserDispatcher() : SimUserDispatcher, SimAccessor
  • SingleArgHook() : SingleArgHook< T >
  • sio_glue_handler() : ExtPsdContextListener_SioGlueSignalListener, SioGlueSignalListener
  • SioGlueSignalListener() : SioGlueSignalListener, SerialTerminal
  • size() : WbxmlVector< T >, tagCustFileData, tagLdbData, tagCPGlyph, tagFont, tagLanguage, tagDataPackHeader, tagCustomizationPack, NvRamBlockInfo, BtObexHeader, RomDataRes, RegIterator::LeafMetaData, FfsFileInfo, ffs_file_info_type
  • Size() : IconState, HeapVector::VarPage, HeapVector::BlockPage, Size, CArray< T >, ObexBuffer, File::Attributes
  • SkipCurrentTest() : SocketTestApp
  • SkipFrames() : ScicosMpeg4VideoDecoder
  • SkipSocketTestMsg() : SkipSocketTestMsg
  • Sleep() : Os
  • SmafSound() : SmafSound
  • SmartDrawPixel() : PngImage
  • SmartDrawScanline() : PngImage
  • SmoothScrollInfo() : AbstractGrid::SmoothScrollInfo
  • Sms() : Sms, DataCodingScheme
  • SmsAlert() : SmsAlert
  • SmsBasicProvider() : SmsBasicProvider
  • SmsCapacityAvailableArg() : SmsCapacityAvailableArg
  • SmsCapacityExceededArg() : SmsCapacityExceededArg
  • SmsClass0Provider() : SmsClass0Provider
  • SmsCommand() : SmsCommand
  • SmsComposeWin() : SmsComposeWin
  • SmsConfigIndArg() : SmsConfigIndArg
  • SmsContext() : SmsContext
  • SmsControlIndArg() : SmsControlIndArg
  • SmsControlIndMsg() : SmsControlIndMsg
  • SmsCountProvider() : SmsCountProvider
  • SmsDeliver() : SmsDeliver
  • SmsDispatcher() : SmsDispatcher
  • SmsEditor() : SmsEditor
  • SmsFactory() : SmsFactory, SmsCommand, SmsSubmit
  • SmsFolderProvider() : SmsFolderProvider
  • SmsGetMoreMessageStatusIndArg() : SmsGetMoreMessageStatusIndArg
  • SmsGetMoreMessageStatusReqArg() : SmsGetMoreMessageStatusReqArg
  • SmsHandler() : SmsHandler
  • SmsIndicationState() : SmsIndicationState
  • SmsInfoBox() : SmsInfoBox
  • SmsMessageWaitingChangedMsg() : SmsMessageWaitingChangedMsg
  • SmsMsgWaitingProvider() : SmsMsgWaitingProvider
  • SmsNewMessageIndArg() : SmsNewMessageIndArg
  • SmsNewMessageMsg() : SmsNewMessageMsg
  • SmsNewSocketDataMsg() : SmsNewSocketDataMsg
  • SmsNewStatusReportIndArg() : SmsNewStatusReportIndArg
  • SmsNewStatusReportMsg() : SmsNewStatusReportMsg
  • SmsParamProvider() : SmsParamProvider
  • SmsPortDataRecvMsg() : SmsPortDataRecvMsg
  • SmsPrefStorageMediaChangedMsg() : SmsPrefStorageMediaChangedMsg
  • SmsProvider() : SmsProvider
  • SmsReadProvider() : SmsReadProvider
  • SmsResult() : EnumTranslationTable
  • SmsSendCnfArg() : SmsSendCnfArg
  • SmsSendConfirmMsg() : SmsSendConfirmMsg
  • SmsSendDispatcher() : SmsSendDispatcher
  • SmsSendingConfirmDialog() : SmsSendingConfirmDialog
  • SmsSendRejArg() : SmsSendRejArg
  • SmsSendRejectMsg() : SmsSendRejectMsg
  • SmsSendReqArg() : SmsSendReqArg
  • SmsSentProvider() : SmsSentProvider
  • SmsServiceDocumentMsg() : SmsServiceDocumentMsg
  • SmsServiceMsg() : SmsServiceMsg
  • SmsSetMoreMessageReqArg() : SmsSetMoreMessageReqArg
  • SmsSettingsProvider() : SmsSettingsProvider
  • SmsSettingsRecord() : SmsSettingsRecord
  • SmsSetupResponse() : SimTkHandler
  • SmsSocket() : SmsSocket, SmsSocketListener
  • SmsSpaceAvailableMsg() : SmsSpaceAvailableMsg
  • SmsSpaceExceededMsg() : SmsSpaceExceededMsg
  • SmsStatusReport() : SmsStatusReport
  • SmsStorageType() : AbstractSmsApp, EnumTranslationTable
  • SmsSubmit() : SmsSubmit
  • SmsTemplateProvider() : SmsTemplateProvider
  • SmsToMdhWorkMediaTranslation() : SimAccessor
  • SmsUnreadProvider() : SmsUnreadProvider
  • SmsUnsentProvider() : SmsUnsentProvider
  • SmsUtility() : SmsUtility
  • SmsViewerWin() : SmsViewerWin
  • SmsWarningLevel() : EnumTranslationTable
  • SmsWStringCache() : SmsWStringCache
  • Socket() : Socket, InternalTracer
  • SocketAddr() : SocketAddr
  • SocketControlMsg() : SocketControlMsg
  • SocketDataLock() : SocketDataLock, SocketSubSystem
  • SocketEventListener() : SocketEventListener
  • SocketHandler() : SocketHandler, Socket, InetSocket
  • SocketPeer() : SocketPeer
  • SocketRxThread() : SocketRxThread, SysSocket, SocketSubSystem, DataConnManager
  • SocketSerialTerminalListener() : SocketSerialTerminalListener
  • SocketSubSystem() : SocketSubSystem, SocketData
  • SocketTestMessage() : SocketTestMessage
  • SocketTestProgressWin() : SocketTestProgressWin
  • SocketTestResultsWin() : SocketTestResultsWin
  • SocketTestSettingsWin() : SocketTestSettingsWin
  • SocketTestT() : SocketTestT
  • SocketTestT1() : SocketTestT1
  • SocketTestT2() : SocketTestT2
  • SocketTestT3() : SocketTestT3
  • SocketTestT4() : SocketTestT4
  • SocketTestT5() : SocketTestT5
  • SocketTestT6() : SocketTestT6
  • SocketTestT7() : SocketTestT7
  • SocketTestT8() : SocketTestT8
  • SocketTestWin() : SocketTestWin
  • SoftkeyBar() : SoftkeyBar
  • SoftkeyBarView() : SoftkeyBarView
  • SoftkeyDesc() : SoftkeyDesc
  • SortCompare() : ChineseQuickSortProvider
  • SortedElementList() : SortedElementList< T >
  • SortProvider() : SortProvider
  • Sound() : Sound
  • SoundBrowserServiceMsg() : SoundBrowserServiceMsg
  • SoundBrowserTestWin() : SoundBrowserTestWin
  • SoundBrowserWin() : SoundBrowserWin
  • SoundFileFilter() : SoundFileFilter
  • SoundFilter() : SoundFilter
  • SoundItem() : SoundItem
  • SoundMetaData() : SoundMetaData
  • SoundObtainer() : SoundObtainer
  • SoundRef() : SoundRef
  • SoundRefContainer() : SoundRefContainer
  • SpeechAudioDevice() : SpeechAudioDevice
  • Split() : TextCompoundItem, CompoundItem, MptyCallHdl, File, RichTextCompoundItem, ParagraphCompoundItem, GeneralCompoundItem, RootFileImp
  • SplitMpty() : CrssHandler
  • SsBarringIndArg() : SsBarringIndArg
  • SsBaseHandlerReturnCode() : EnumTranslationTable
  • SsBeginAccArg() : SsBeginAccArg
  • SsCallBarringActionImpl() : SsCallBarringActionImpl
  • SsCallForwardingActionImpl() : SsCallForwardingActionImpl
  • SsCallWaitingActionImpl() : SsCallWaitingActionImpl
  • SsCauseIndArg() : SsCauseIndArg
  • SsCcbsDispatcher() : SsCcbsDispatcher
  • SsCcbsHandler() : SsCcbsHandler
  • SsCcbsInvokeArg() : SsCcbsInvokeArg
  • SsCcbsReCallIndArg() : SsCcbsReCallIndArg
  • SsCcbsReCallRequestArg() : SsCcbsReCallRequestArg
  • SsCcbsRejectArg() : SsCcbsRejectArg
  • SsCcbsResultIndArg() : SsCcbsResultIndArg
  • SsCcbsStatusIndArg() : SsCcbsStatusIndArg
  • SsClientRejArg() : SsClientRejArg
  • SsClipActionImpl() : SsClipActionImpl
  • SsClirActionImpl() : SsClirActionImpl
  • SsCnapActionImpl() : SsCnapActionImpl
  • SsColpActionImpl() : SsColpActionImpl
  • SsColrActionImpl() : SsColrActionImpl
  • SsControlIndMsg() : SsControlIndMsg
  • SsDataIndArg() : SsDataIndArg
  • SsDataReceivedMsg() : SsDataReceivedMsg
  • SsDispatcher() : SsDispatcher
  • SsEmlppActionImpl() : SsEmlppActionImpl
  • SsEndIndArg() : SsEndIndArg
  • SsEndMsg() : SsEndMsg
  • SsErrIndArg() : SsErrIndArg
  • SsErrIndicationMsg() : SsErrIndicationMsg
  • SsErrorCode() : SsErrorCode, EnumTranslationTable
  • SsErrorMsg() : SsErrorMsg
  • SsErrReqArg() : SsErrReqArg
  • SsFacilityIndArg() : SsFacilityIndArg
  • SsFacilityRejArg() : SsFacilityRejArg
  • SsFacilityRejectedMsg() : SsFacilityRejectedMsg
  • SsForwardingIndArg() : SsForwardingIndArg
  • SsForwcheckIndArg() : SsForwcheckIndArg
  • SsGetPasswordIndArg() : SsGetPasswordIndArg
  • SsGetPasswordRejArg() : SsGetPasswordRejArg
  • SsGetPasswordRspArg() : SsGetPasswordRspArg
  • SsHandler() : SsHandler
  • SsInfoMsg() : SsInfoMsg
  • SsInterrogateIndArg() : SsInterrogateIndArg
  • SsMessage() : SsMessage
  • SsNotification() : SsNotification
  • SsNotificationMsg() : SsNotificationMsg
  • SsNotifyIndArg() : SsNotifyIndArg
  • SsOperationCode() : EnumTranslationTable
  • SsPasswordChangeActionImpl() : SsPasswordChangeActionImpl
  • SsPasswordIndArg() : SsPasswordIndArg
  • SsRejArg() : SsRejArg
  • SsRejectedMsg() : SsRejectedMsg
  • SsRejReqArg() : SsRejReqArg
  • SsRequestAcceptedMsg() : SsRequestAcceptedMsg
  • SsRequestRejectedMsg() : SsRequestRejectedMsg
  • SsRequestSentMsg() : SsRequestSentMsg
  • SsRetResIndArg() : SsRetResIndArg
  • SsSendEndReqArg() : SsSendEndReqArg
  • SsSendReqArg() : SsSendReqArg
  • SsSetupResponse() : SimTkHandler
  • SsStatus() : SsStatus
  • SsSuccessMsg() : SsSuccessMsg
  • SstProvider() : SstProvider
  • SsUnstructIndArg() : SsUnstructIndArg
  • SsUssdActionImpl() : SsUssdActionImpl
  • SsUssdIndArg() : SsUssdIndArg
  • SsUssdReqArg() : SsUssdReqArg
  • SsUssdResentIndArg() : SsUssdResentIndArg
  • SsUus1IndArg() : SsUus1IndArg
  • SsUus1QueryIndArg() : SsUus1QueryIndArg
  • SsUus1QueryRejArg() : SsUus1QueryRejArg
  • SsUus1QueryReqArg() : SsUus1QueryReqArg
  • SsUus1ReqArg() : SsUus1ReqArg
  • SsWaitDispatcher() : SsWaitDispatcher
  • StackAlloc() : Os
  • StackControl() : StackControl
  • StackFree() : Os
  • StackMsgActiveWaitDispatcher() : StackMsgActiveWaitDispatcher
  • StackMsgArgDestroyTableNode() : StackMsgArgDestroyTableNode, StackMsgArgument
  • StackMsgArgMapContainer() : StackMsgArgMapContainer< T >
  • StackMsgArgument() : StackMsgArgument, NoStackMsgArg, StackMsgArgDestroyTableNode
  • StackMsgDispatcher() : StackMsgDispatcher
  • StackMsgMapTableNode() : StackMsgMapTableNode, StackMsgMapTable
  • StackSsRejectedMsg() : StackSsRejectedMsg
  • StackTrace() : _FunctionTracer< mask >, _NullFunctionTracer
  • StandardJoinRule() : StandardJoinRule
  • Start() : Timer, SystemTimer, ImageBox, AnimatedTextLine, VoiceMemoAudioDevice, VideoChannel, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice, GenericAudioDevice, AmplifierAudioDevice, StartUp, VideoChannel, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, VideoChannel, AtiMpeg4Encoder, AtiMpeg4Decoder, VideoChannel, SharedTimer, Animation, RtStreamingConn, SigHandler, CbsHandler, Server, HttpServer, FtpTransfer, FtpServer, FtpOutTransfer, FtpInTransfer, LcsTimer, LcsRepeatTimer, VideoEncoder, VideoDecoder, FlowLayout, IndicatorLocation
  • StartAction() : AtiAudioPlayerRtStreamingSink, RtStreamingSource, RtStreamingSink, DataSourceRtStreamingSource
  • StartAddrResolution() : ObexServerPort, ObexClientPort, ObexAbstractPort
  • StartAirplaneMode() : PowerHandler
  • StartBatteryLoadListening() : Charger
  • StartCDATAHandler() : XMLParser
  • startDocument() : WbxmlParserRel
  • StartDocument() : XMLParser
  • StartDtmfCnfArg() : StartDtmfCnfArg
  • StartDtmfRejArg() : StartDtmfRejArg
  • StartDtmfReqArg() : StartDtmfReqArg
  • StartDtmfToneGeneration() : MptyCallHdl, CallHdlBase, CallHdl, CallHandler
  • startElement() : WbxmlParserRel
  • StartElement() : XMLParser
  • StartIteration() : CompoundSmsItem
  • StartLoading() : BootControl
  • StartMobileNetwork() : PowerHandler
  • StartOperation() : ObexClientOppImpl, ObexAbstractPort
  • StartParam() : ToneAudioDevice::StartParam, RingerAudioDevice::StartParam, KeyToneAudioDevice::StartParam
  • StartPreview() : MediaRecorder
  • StartRecognition() : VrHandler
  • StartRecord() : MediaRecorder
  • StartRecording() : VoiceMemoApp, AudioDeviceManager, VrHandler
  • StartResolveAction() : ObexAbstractPort
  • StartSelection() : ObexMngr, AbstractEditor
  • StartSignalStrengthListeningArg() : StartSignalStrengthListeningArg
  • StartSilentReset() : PowerHandler
  • StartSocketTestMsg() : StartSocketTestMsg
  • StartStop() : ImageBrowserDetailWin
  • StartsWith() : WString, String
  • startswith() : Uri
  • StartSymbol() : ObexUrlStrParser
  • StartTests() : SocketTestApp
  • StartTextFormatting() : EmsEditor
  • StartTextScrolling() : DefaultItemRenderer, AbstractItemRenderer, AtlItemRenderer
  • StartTimeoutTimer() : SocketTestApp
  • StartTone() : Audio
  • StartTraining() : VrHandler
  • StartTransaction() : DBService
  • StartUp() : SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, AbstractScheduler, AbstractAppContext, GatiManager, System, ServiceThread, MessageRouter, DeviceManager
  • Startup() : SmsSocketListener, MainHandler, VrHandler, DataHandler
  • StartVibrator() : VibratorDevice, Audio, AudioVibratorDevice
  • StartVideoCapture() : CamWin32, VideoCamera
  • StartViewfinder() : VideoCamera, Camera
  • StartViewFinder() : CamWin32
  • StartWaitingAnimation() : PhonebookApp
  • StateMachine() : StateMachine
  • StatusDispatcher() : StatusDispatcher
  • StatusProvider() : StatusProvider
  • StillCamera() : StillCamera
  • Stop() : Timer, ServiceThread, SystemTimer, DbgTimingMeasurement, AbstractAppContext, ImageBox, AnimatedTextLine, VoiceMemoAudioDevice, VideoChannel, ToneAudioDevice, SpeechAudioDevice, RingerAudioDevice, Mp3AudioDevice, KeyToneAudioDevice, GenericAudioDevice, AmplifierAudioDevice, VideoChannel, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzH264Decoder, VideoChannel, AtiMpeg4Encoder, AtiMpeg4Decoder, VideoChannel, SharedTimer, RtStreamingConn, MP3AudioPlayer, MmfPlayer, AudioActiveReference, SigHandler, CbsHandler, MapiAudioPlayer, SvgPlayer, Server, HttpServer, FtpServer, MediaPlayer, VideoEncoder, VideoDecoder
  • StopAction() : AtiAudioPlayerRtStreamingSink, RtStreamingSource, RtStreamingSink, RtStreamingConn, DataSourceRtStreamingSource
  • StopAllSounds() : AudioDeviceManager
  • StopBatteryLoadListening() : Charger
  • StopBatteryLoadListeningArg() : StopBatteryLoadListeningArg
  • StopCallbackHaveBeenSet() : MapiAudioPlayer
  • StopDecoding() : Image
  • StopDtmfCnfArg() : StopDtmfCnfArg
  • StopDtmfReqArg() : StopDtmfReqArg
  • StopDtmfSending() : SimTkHandler
  • StopDtmfToneGeneration() : MptyCallHdl, CallHdlBase, CallHdl, CallHandler
  • StopEncoding() : ImageEncoder
  • StopMobileNetwork() : PowerHandler
  • StopNotifications() : SocketRxThread, SerialSocketThread
  • StopOnCause() : AtiAudioPlayerRtStreamingSink, RtStreamingSink
  • StopPreview() : MediaRecorder
  • StopRecognition() : VrHandler
  • StopRecord() : VoiceMemoWin, VoiceMemoRecordWin, StreamAudioPlayer, MediaRecorder
  • StopRecording() : VoiceMemoApp, AudioDeviceManager
  • StopRingRequest() : BtHsService
  • StopSelection() : AbstractEditor
  • StopSignalStrengthListeningArg() : StopSignalStrengthListeningArg
  • StopSocketTestMsg() : StopSocketTestMsg
  • StopSound() : SoundBrowserWin, AudioContext
  • StopSuspend_Implementation() : StreamAudioPlayer
  • StopSuspended() : MP3AudioPlayer, MmfPlayer
  • StopTests() : SocketTestApp
  • StopTextScrolling() : DefaultItemRenderer, AbstractItemRenderer, AtlItemRenderer
  • StopTimeoutTimer() : SocketTestApp
  • StopTone() : Audio
  • StopVibrator() : VibratorDevice, Audio, AudioVibratorDevice
  • StopVideoCapture() : CamWin32, VideoCamera
  • StopViewfinder() : VideoCamera, Camera
  • StopViewFinder() : CamWin32
  • StopWaitingAnimation() : PhonebookApp
  • StorageDevice() : StorageDevice, RootFileSystem
  • StorageDeviceFilter() : StorageDeviceFilter
  • StorageDeviceIterator() : StorageDeviceIterator, RootFileSystem
  • StorageDeviceVisitor() : StorageDeviceVisitor
  • StorageIsAttached() : DataConnProfileManager
  • Store() : NvRamStorage, SmsFactory
  • StoreAppointment() : CalendarAddRecordWin
  • StoreConfigValues() : GltpProviderImpl
  • StoreData() : LcsSettingsUtils, LcsAppUtils
  • StoreEmailInPhonebook() : AbstractSmsApp
  • StoreImpl() : AbstractSmsUtilityProcessor, EmsApp
  • StoreInPhonebook() : AbstractSmsApp
  • StoreMolr() : LcsReqProcessor
  • StoreMtlr() : LcsReqProcessor
  • StoreRecord() : NvRamDataRecordHandler, RecordHandler, DataRecordHandler
  • StoreSentSms() : AbstractSmsApp
  • StoreSms() : BasicSmsService, AbstractSmsApp, SmsHandler
  • StoreSmsTransmit() : SimPduHandler
  • StoreTpdu() : SimPduHandler, DataHandler
  • StrCopy() : WString, String
  • Stream() : Stream
  • StreamAudioPlayer() : StreamAudioPlayer, StreamAudioReference
  • StreamAudioReference() : StreamAudioReference
  • StreamingCallback() : StreamingCallback, File
  • StreamingDriverReadCallback() : FlsFile, FatFile
  • StreamingDriverWriteCallback() : FlsFile, FatFile
  • StreamingInfo() : StreamingInfo
  • StreamingReadInfo() : StreamingReadInfo
  • StreamingWriteInfo() : StreamingWriteInfo
  • StreamObexImpl() : StreamObexImpl
  • StreamObexTransport() : StreamObexTransport
  • StreamReader() : StreamReader
  • StreamWriter() : StreamWriter
  • StretchXGrid() : Layouter
  • StretchYGrid() : Layouter
  • String() : String, InternalTracer, WString
  • StringDataSink() : StringDataSink
  • StripRelXml() : DrmMessage
  • StrokeBox() : StrokeBox
  • StrokeBoxView() : StrokeBoxView
  • SubFree() : HeapVector::VarPage
  • SubMenuAction() : SubMenuAction
  • SubmitResponse() : ObexFtpDataServer
  • Subscribe() : StackControl, SmsSocketListener
  • SubscribeAudioMessageCallback() : AudioDeviceManager
  • SubstitutedText() : SubstitutedText
  • Substring() : WString, String
  • SubSystem() : SubSystem, SubSystemManager
  • SubTimeSpan() : DateTime
  • SubunitInfoRequest() : BtAvrcpOperationService
  • SubUnitReference() : SubUnitReference
  • Succeded() : CbsStopDispatcher, CbsStartDispatcher
  • SupportsStyle() : FontManager, FontEntry
  • SupportsTextAttr() : RomFont, FontEntry, Font
  • SupportsUnicodeRange() : FontManager, FontEntry
  • Suspend() : Thread, MP3AudioPlayer, MmfPlayer, AudioActiveReference
  • SuspendAllPlayingSounds() : AudioDeviceManager
  • SuspendHttp() : HttpWapMgrPlugin, HttpWapMgrBase, HttpWapMgr, HttpHandler
  • SuspendWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • SvgDecodingFinishedMsg() : SvgDecodingFinishedMsg
  • SvgFileWrapper() : SvgFileWrapper
  • SvgGzFileWrapper() : SvgGzFileWrapper
  • SvgHyperlinkSelectMsg() : SvgHyperlinkSelectMsg
  • SvgImage() : SvgImage
  • SvgImageFileWrapper() : SvgImageFileWrapper
  • SvgPlayer() : SvgPlayer
  • SvgStatusMsg() : SvgStatusMsg
  • SwallowKey() : KeyManager
  • Swap() : WString, String, ByteBuffer, CallHdlBase
  • SwapCalls() : CrssHandler
  • SwapValues() : IndexTable< T >
  • Switch() : BackLight
  • SwitchBuffer() : RtStreamingSink
  • SwitchDisplaySimPos() : PhonebookApp
  • SwitchItemContainer() : AbstractItemGrid
  • SwitchOff() : FmRadioWindow
  • SwitchReadStatus() : AbstractSmsViewerWin, AbstractSmsApp
  • SwitchToEditboxMenu() : PbDetails
  • Synchronize() : PhonebookApp, PbSynchronizer
  • SynchronizeBuffers() : DefaultDisplay
  • SynchronizeBuffers_ApoxiToT9() : T9InputMapper
  • SynchronizeBuffers_T9ToApoxi() : T9InputMapper
  • SyncPaintDc() : SyncPaintDc
  • SyncPhone() : PbSynchronizer, PbManualSynchronizer, PbLazySynchronizer, AdvPbApp
  • SyncPhoneAll() : PbSynchronizer, AdvPbApp
  • SyncPhoneOne() : PbSynchronizer
  • SyncPhoneThreadlet() : SyncPhoneThreadlet
  • SyncProgressMsg() : SyncProgressMsg
  • SyncSim() : PbSynchronizer, PbManualSynchronizer, PbLazySynchronizer, AdvPbApp
  • SyncSimAll() : PbSynchronizer, AdvPbApp
  • SyncSimOne() : PbSynchronizer
  • SyncSucceeded() : SyncPhoneThreadlet
  • SysDnsClient() : SysDnsClient, DnsClient
  • SysSocket() : SysSocket, SocketSubSystem, Ticks
  • SystemTimer() : SystemTimer
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- t -

  • T9AddWordMsg() : T9AddWordMsg
  • T9EnteredUnknownWordMsg() : T9EnteredUnknownWordMsg
  • T9InputMapper() : T9InputMapper
  • T9MatrixModeKeypressed() : T9MatrixModeKeypressed
  • T9NoWordFoundMsg() : T9NoWordFoundMsg
  • T9Pack() : T9Pack
  • T9PinyinBox() : T9PinyinBox
  • T9PinyinBoxView() : T9PinyinBoxView
  • T9PredictiveInputBox() : T9PredictiveInputBox
  • T9SymbolEntryRequestMsg() : T9SymbolEntryRequestMsg
  • TabButton() : TabButton
  • TabButtonView() : TabButtonView
  • TabControl() : TabControl
  • TabControlView() : TabControlView
  • TaggedProblemCode() : TaggedProblemCode
  • TcpNetAdapter() : TcpNetAdapter
  • TcpServerTestSocket() : TcpServerTestSocket
  • TcpSocket() : TcpSocket, SocketData
  • TcpTestSocket() : TcpTestSocket
  • TeardownContext() : DataConn
  • TelecaVrEngineParams() : TelecaVrEngineParams
  • TelematicDevice() : ProtocolIdentifier, EnumTranslationTable
  • Tell() : File
  • Terminate() : Thread, Server, HttpServer, HttpApplication, FtpServer
  • TerminateExtPsdContext() : ExtPsdContextListenerImpl_SerialTerminalListener
  • TerminateSupplementaryService() : SsHandler
  • TerminateUssdTransaction() : MobileOriginatedUssdHandler
  • TermIos() : ExtPsdContextListener_SioGlueWrapper::TermIos, SioGlueWrapper::TermIos
  • TermRspCnfArg() : TermRspCnfArg
  • TermRspCnfMsg() : TermRspCnfMsg
  • TestA() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT2, SocketTestT1, SocketTestT
  • TestAA() : SocketTestT4
  • TestABCD() : SocketTestT3
  • TestAddEntryPerf() : UibPerformanceTest
  • TestB() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT2, SocketTestT1, SocketTestT
  • TestBCD() : SocketTestT4
  • TestC() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT
  • TestCheckBoxListView() : TestCheckBoxListView
  • TestCheckBoxView() : TestCheckBoxView
  • TestControlFrameView() : TestControlFrameView
  • TestD() : SocketTestT8, SocketTestT7, SocketTestT6, SocketTestT5, SocketTestT4, SocketTestT3, SocketTestT
  • TestDeleteEntryPerf() : UibPerformanceTest
  • TestE() : SocketTestT5, SocketTestT3, SocketTestT
  • TestF() : SocketTestT
  • TestFor() : SerialIoSet
  • TestG() : SocketTestT
  • TestGetAction() : UibAccessorTest
  • TestGetActionCount() : UibAccessorTest
  • TestGetActionIndex() : UibAccessorTest
  • TestH() : SocketTestT
  • TestI() : SocketTestT
  • TestInsertAction() : UibAccessorTest
  • TestparamReportArg() : TestparamReportArg
  • TestparamReqArg() : TestparamReqArg
  • TestPositionIndicatorView() : TestPositionIndicatorView
  • TestPredefinedSettings() : UibSettingsTest
  • TestPushButtonView() : TestPushButtonView
  • TestRadioButtonListView() : TestRadioButtonListView
  • TestRadioButtonView() : TestRadioButtonView
  • TestRemoveAccessor() : UibAccessorTest
  • TestRemoveAction() : UibAccessorTest
  • TestRemoveAllActions() : UibAccessorTest
  • TestSetAccessor() : UibAccessorTest
  • TestSettingsDisplay() : UibSettingsTest
  • TestSettingsModification() : UibSettingsTest
  • TestSettingsProvider() : UibSettingsTest
  • TestTheme() : TestTheme
  • TestUpdateTime() : UibPerformanceTest
  • TestWindowFrameView() : TestWindowFrameView
  • TextBox() : TextBox
  • TextCompoundItem() : TextCompoundItem
  • TextDisplayed() : SimTkHandler
  • TextEditorDocument() : TextEditorDocument
  • TextFormat() : TextFormat
  • TextIconPairArray() : TextIconPairArray
  • TextIndicator() : TextIndicator
  • TextLine() : TextLine
  • TextLineView() : TextLineView
  • TextList() : TextList
  • TextListLine() : TextListLine
  • TextListModel() : TextListModel
  • TextListView() : TextListView
  • TextManager() : MultiMediaEditorDocument::TextManager
  • TextMenuAccessor() : TextMenuAccessor
  • TextPack() : TextPack
  • ThaiTextRenderer() : ThaiTextRenderer
  • Theme() : Theme, OptionalConfigBase
  • ThemeChangedMsg() : ThemeChangedMsg
  • ThemeViewIterator() : ThemeViewIterator
  • Thread() : Thread
  • ThreadFn() : FfsTestThread, Thread, GenericWorkerTask, AppContainer, EmzMpeg4EncoderThread, EmzMpeg4DecoderThread, EmzMp3DecoderThread, EmzH264DecoderThread, EmzAacDecoderThread, EmzSbcEncoderThread, EmzMpeg4EncoderThread, EmzMpeg4DecoderThread, EmzMp3DecoderThread, EmzH264DecoderThread, EmzAacDecoderThread
  • Threadlet() : Threadlet, GenericWorkerTask
  • ThreadletNotificationMsg() : ThreadletNotificationMsg
  • ThreadSafeProvider() : ThreadSafeProvider
  • ThrPopData() : IsrDataContainer< Data, c_queue_size >
  • Ticks() : Ticks
  • TickValue() : TickValue
  • Time() : Time, InputMapper
  • TimeCompoundItem() : TimeCompoundItem
  • TimeEditBox() : TimeEditBox
  • TimeEditBoxView() : TimeEditBoxView
  • TimeEditor() : TimeEditor
  • TimeEditorDocument() : TimeEditorDocument
  • TimeExpired() : IncrementalPdcUpdater
  • TimeFeatureObject() : TimeFeatureObject
  • TimeoutCondition() : TimeoutCondition
  • Timer() : Timer, Ticks, ExecutionContext, AppContainer
  • TimerTimeoutMsg() : TimerTimeoutMsg
  • TimeSpan() : TimeSpan
  • TimeZone() : TimeZone
  • TimeZoneMsg() : TimeZoneMsg
  • TipdBasedActiveWaitDispatcher() : TipdBasedActiveWaitDispatcher
  • Tlv() : Tlv
  • ToByte() : ObexHeader
  • ToByteBuffer() : ObexHeader
  • ToCStr() : ObexHeader
  • ToDoComposeWin() : ToDoComposeWin
  • ToDoDateDialogWin() : ToDoDateDialogWin
  • ToDoListWin() : ToDoListWin
  • ToDoProvider() : ToDoProvider
  • ToDoRecord() : ToDoRecord
  • Toggle() : RadioButtonAction, CheckBoxControl, CheckBoxAction, AbstractToggleAction, Provider
  • ToggleActionGroup() : ToggleActionGroup
  • ToggleComponentEntryMode() : ChineseT9Wrapper
  • ToggleRow() : Provider, AbstractDelegationProvider, MergeProvider, JoinProvider, SmsProvider, SmsClass0Provider
  • ToggleSelection() : IrdaWin
  • ToggleView() : BrowserViewContainer
  • ToLong() : ObexHeader
  • ToLower() : WString, String
  • ToneAudioDevice() : ToneAudioDevice
  • TonePlayed() : SimTkHandler
  • TopLevelMenu() : TopLevelMenu
  • ToPtr() : WStrData, StrData
  • ToSdl() : ProactiveCauseMapper
  • ToSdlExt() : ProactiveCauseMapper
  • ToStackMsg() : ToStackMsg, StackMsgArgument
  • ToString() : ObexHeader, ObexAddress, IrdaObexServerAddr, IrdaObexClientAddr, BtObexServerAddr, BtObexClientAddr, WString, ResourceID, UsbObexServerAddr, AtCommand
  • ToUpper() : WString, String
  • ToUserSpace() : SvgImage
  • ToUtf8String() : WString
  • ToViewportSpace() : SvgImage
  • ToWString() : ObexHeader, String, Pathname
  • Tpdu() : Tpdu, PhoneNumber
  • TpduCache() : TpduCache, SimPduHandler
  • TpduStatus() : EnumTranslationTable
  • TraceAppAttach() : InternalTracer
  • TraceAppDetach() : InternalTracer
  • TraceAttach() : _ApplicationTracer, _NullApplicationTracer
  • TraceBuffer() : InternalTracer
  • TraceCheckPoint() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceData() : InternalTracer
  • TraceDelete() : InternalTracer, _FunctionTracer< mask >, _NullFunctionTracer
  • TraceDetach() : _ApplicationTracer, _NullApplicationTracer
  • TraceError() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceFuncBegin() : InternalTracer
  • TraceFuncCheckPoint() : InternalTracer
  • TraceFuncEnd() : InternalTracer
  • TraceFuncStackTrace() : InternalTracer
  • TraceMessage() : InternalTracer, _FunctionTracer< mask >, _NullFunctionTracer, _NullApplicationTracer
  • TraceMiscData() : InternalTracer
  • TraceNew() : InternalTracer, _FunctionTracer< mask >, _NullFunctionTracer
  • TraceObj() : InternalTracer
  • TraceObjectCreate() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceObjectDestroy() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceOutputStream() : TraceOutputStream
  • TraceTestState() : InternalTracer, _FunctionTracer< mask >, _NullFunctionTracer
  • TraceVariable() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceVersion() : _FunctionTracer< mask >, _NullFunctionTracer
  • TraceWarning() : _FunctionTracer< mask >, _NullFunctionTracer
  • TrackPathToRoot() : RamFileNode
  • TRadioButtonItem() : TRadioButtonItem< Content >
  • TransferAudioToAccessoryRequest() : BtHsService, BtHfService, BtAudioAccessoryService
  • TransferAudioToPhoneRequest() : BtHsService, BtHfService, BtAudioAccessoryService
  • TransferFocus() : Application, AppContainer
  • TransferLocationDialog() : TransferLocationDialog
  • TransferLocationReq() : SaProviderImpl, GltpProviderImpl, LcsProviderImplBase, LcsProvider, LcsProviderImpl
  • TransformBcdPlmnToPlmn() : StackWrapper
  • TransformPlmnToBcdPlmn() : StackWrapper
  • TransformToReversedByteBuffer() : PhoneNumber
  • TransformToWCharBuffer() : PhoneNumber
  • Translate() : LanguageManager
  • TranslateOpenMode() : RamFileImp, FatFileImp
  • TransportEvent() : UsbTransport
  • TransportNotificationMsg() : TransportNotificationMsg
  • TraverseDown() : RegIterator, RegEncoderDecoder
  • TraverseNext() : RegIterator, RegEncoderDecoder
  • TraverseUp() : RegIterator, RegEncoderDecoder
  • Trigger() : ItemTree, ItemMenu, AbstractButton, TextMenuAccessor, SoftkeyBar, MenuAccessor, Menu, AbstractMenuAccessor, AbstractActionMenuAccessor
  • TriggerFeatureItemUpdate() : AtlApplication
  • TriggerIsrDataProcessing() : MsgQueue, AppContainer
  • TriggerKeyFeature() : TriggerKeyFeature
  • TriggerMenuItem() : AtlItemMenuWindow
  • TriggerTimer() : TriggerTimer< T >
  • Trim() : SmsCommand, SmsSubmit
  • Truncate() : FfsHandler, RamHandler, FatHandler
  • TruncateUri() : Uri
  • TtyInterface() : TtyInterface
  • TtySupported() : TtyInterface
  • TurnOff() : BtLocalSettings
  • TurnOn() : BtLocalSettings
  • TurnVolume() : AudioAccessoryDetails
  • Type() : ToDoRecord, SysSocketBase, SysSocket, NetAdapter, InetSocket, ExecutionContext, PredInputMapper, MessageBox, Control::ComponentIterator, Control::NavigationGuidance, AnimatedTextLine, VirtualDisplay, PhoneNumber, PdpContext::PacketFilter, PdpContext::Authentication, PdpContext, PinAction, MoCallAction, MessageTypeIndicator, MessageIdentifier, DataCodingScheme, CommandType, BaseInformationElement, Accessory, File::Attributes, AtCommand, DrmConstraint, InputMapItem, ObexHeader
  • TypeOfAddress() : TypeOfAddress
  • TypeOfId() : ObexHeader
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- u -

  • Ucs2() : SimGetInkeyOptions, SimGetInputOptions, JapaneseTranscoder
  • UdpNetAdapter() : UdpNetAdapter
  • UdpTestSocket() : UdpTestSocket
  • UibAccessorTest() : UibAccessorTest
  • UibActionAccessor() : UibActionAccessor
  • UibFolderWin() : UibFolderWin
  • UibInboxProvider() : UibInboxProvider
  • UibInboxTest() : UibInboxTest
  • UibListBoxModel() : UibListBoxModel
  • UibMsgDisplayTest() : UibMsgDisplayTest
  • UibNotifyMsg() : UibNotifyMsg
  • UibNotifyTest() : UibNotifyTest
  • UibPerformanceTest() : UibPerformanceTest
  • UibRegisterMsg() : UibRegisterMsg
  • UibServiceImpl() : UibServiceImpl
  • UibSettingsProvider() : UibSettingsProvider
  • UibSettingsRecord() : UibSettingsRecord
  • UibSettingsTest() : UibSettingsTest
  • UibSettingsWin() : UibSettingsWin
  • UibSortingTest() : UibSortingTest
  • UibTest1() : UibTest1
  • UibTest2() : UibTest2
  • UibUpdateMsg() : UibUpdateMsg
  • UibUpdateThreadlet() : UibUpdateThreadlet
  • UmtsMeasEvalParam() : UmtsMeasEvalParam
  • UmtsMeasIdParam() : UmtsMeasIdParam
  • UmtsNcellParam() : UmtsNcellParam
  • UmtsRrcScellParam() : UmtsRrcScellParam
  • UnavailableFeaturesIgnored() : FeatureItemContainer
  • UnbindMimeType() : ObexOppServer, ObexOppDataSinkPushServer
  • UnbindStack() : IrdaObexTransport
  • UnblockChv() : SimChvHandler, SimAccessor
  • Undefine() : PdpContext
  • UndefineContext() : PsdDataConn
  • UndefinedSsAction() : UndefinedSsAction
  • UnicodeStringToGsm7DefaultString() : DataCoding
  • Union() : Rect
  • Unique() : NiSharedPtr< X >
  • UnitInfoRequest() : BtAvrcpOperationService
  • Unlock() : SmsBasicProvider, PbRecordProvider, PbRecordHandler, AbstractLockableDevice, ThreadSafeProvider, Provider, Protector, AbstractDelegationProvider, HandlerData, Registry, ObjectTreeService, MergeProvider, JoinProvider, AppendProvider, RecordHandler, RegEncoderDecoder
  • UnlockAction() : UnlockAction
  • UnlockDataStore() : DBService
  • Unmount() : MainHandler
  • UnpackCbsSeptetsToWchars() : DataCoding
  • UnpackSeptetsToWchars() : DataCoding
  • UnPauseVideoCapture() : VideoCamera
  • Unref() : SharedPtr< T_obj >
  • Unregister() : MessageMapContainer< T >, AbstractMessageMapContainer, BtController, SmsSocketListener, LookupAlphaIdExtension
  • UnregisterCallback() : BtObexService
  • UnregisterDataConn() : DataConnManager
  • UnregisterDecoder() : CodecManager
  • UnregisterDispatcher() : BtLocalRequest
  • UnregisterEncoder() : CodecManager
  • UnregisterGlobalProvider() : MainProvider
  • UnregisterHfMessages() : BtHfAppPlugin
  • UnregisterMessage() : ServiceThread, ExecutionContext, Application, AppContainer
  • UnregisterMessages() : UserDispatcher, MessageMapDispatcher, BtObexService, BtHsService, BtHfService, BtFaxService, BtDunService, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtSendPasskeyRequest, BtSddbService, BtRespondAuthorizationRequest, BtQuerySupportedProfilesRequest, BtDeviceUntrustRequest, BtDeviceUnpairRequest, BtDeviceTrustRequest, BtDeviceSearchRequest, BtDevicePairRequest, BtBppService, BtBipServerService, BtBipClientService, BtAvrcpService, BtAvrcpOperationService
  • UnregisterNotify() : Registry
  • UnregisterPanelToApoxiAvrcp() : BtAvrcpPanelApplication
  • UnregisterRequest() : BtObexService, BtObexServerService, BtObexClientService, BtBppServerService
  • UnregisterService() : ServiceBroker
  • UnregisterServiceCallback() : BtSddbService
  • UnregisterServiceRecordRequest() : BtObexSddbImpl, BtSddbService
  • UnRegisterSignalListener() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • UnregisterStorageDevice() : RootFileSystem
  • UnregisterUserActivityListener() : AtlApplication
  • UnregisterWap() : HttpWapMgrPlugin, WapHandler, HttpWapMgrBase, HttpWapMgr
  • UnsetPacketFilter() : PsdDataConnProfile, PdpContext
  • Unsubscribe() : StackControl, SmsSocketListener
  • UnsubscribeAudioMessageCallback() : AudioDeviceManager
  • UnzipBinData() : Unzipper
  • UnzipFfs() : Unzipper
  • Unzoom() : MediaRecorder, MediaPlayer
  • Update() : UibListBoxModel, UibFolderWin, BrowserViewContainer, ImageListBoxModel, BrowserViewContainer, FmRadioStationsProvider, SmsSettingsProvider, AbstractSmsApp, DataConnWin, DataConnLbModel, SerDataConnAccessor, PsdDataConnAccessor, CsdDataConnAccessor, DataConnAccessor, CalendarMonthWin, PhonebookWin, PbSynchronizer, PbSortedProvider, PbRecordProvider, PbProvListBox, PbNumberProvider, PbNameProvider, PbNameFilterProvider, PbMergeProvider, PbManualSynchronizer, PbNumberFilterProvider, PbDetailProvider, View, Theme, TabControlView, RadioButtonControlView, IncrementalPdcUpdater, FrameDc, ControlDc, CheckBoxControlView, AbstractMultiLineEditor, AbstractLineEditor, AbstractEditor, FoggyWindowFrameView, FoggyTheme, FoggyPushButtonView, FoggyPanelView, DefaultWindowFrameView, DefaultTheme, DefaultTextListView, DefaultRadioButtonView, DefaultRadioButtonListView, DefaultPushButtonView, DefaultProgressBarView, DefaultPanelView, DefaultControlFrameView, DefaultCheckBoxView, DefaultCheckBoxListView, CustomizableTheme, CTPushButtonView, CTProgressBarView, CTPanelView, ProviderListBox, FoggyTheme, DefaultWindowFrameView, DefaultTheme, DefaultTextListView, DefaultRadioButtonView, DefaultRadioButtonListView, DefaultPushButtonView, DefaultProgressBarView, DefaultControlFrameView, DefaultCheckBoxView, DefaultCheckBoxListView, DefaultChineseTheme, SortProvider, RegBlobObject, QuickSortProvider, Provider, FindProvider, Find2Provider, FilterProvider, DistinctProvider, ChineseQuickSortProvider, CachingSortProvider, BubbleSortProvider, BlobObject, AbstractDelegationProvider, SettingsProvider, PropertyItem, IndicatorItem, FeatureItem, InputContext, MultiMediaEditor, DrmRightsObjectFile, MergeProvider, JoinProvider, AppendProvider, SstProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SmsClass0Provider, SimTkMainMenuProvider, SimPduHandler, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PbBaseProvider, MbiProvider, EccProvider, CphsServPflProvider, CphsAuxProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • UpdateAbsPos() : DeviceContext
  • UpdateAbsRect() : WinRect
  • UpdateAcm() : SimAuxHandler, SimAccessor
  • UpdateAlarmList() : CalendarApp
  • UpdateAudioPaths() : AudioPathManager
  • UpdateBidiBuffer() : ParagraphCompoundItem
  • UpdateCbmi() : SimAuxHandler, SimAccessor
  • UpdateCbmir() : SimAccessor
  • UpdateCbmiRange() : SimAuxHandler
  • UpdateCcp() : SimAuxHandler
  • UpdateChildProvider() : AbstractDelegationProvider
  • UpdateChvData() : SimChvHandler
  • UpdateConfiguration() : AudioAccessoryDetails
  • UpdateConnectOptions() : BtDeviceListWindow
  • UpdateConnectProfileSelectedWindow() : BtDeviceListWindow
  • UpdateContext() : BtAvrcpPanelApplication
  • UpdateContextItem() : AtlApplication
  • UpdateContextItemMsg() : UpdateContextItemMsg
  • UpdateControllerDeviceListFeaturesAvailable() : BtAvrcpPanelApplication
  • UpdateControllerFeaturesAvailable() : BtAvrcpPanelApplication
  • UpdateCphsCfuf() : SimAccessor
  • UpdateCphsCsp() : SimAccessor
  • UpdateCphsVmwf() : SimAccessor
  • UpdateData() : ValidityPeriod, ValidityPeriodFormat, CodedTimeStamp
  • UpdateDeviceList() : BtDeviceListWindow
  • UpdateDisplay() : Application, DeviceContext, MmiSimServer, MmiSimClient
  • UpdateDisplayedSms() : AbstractSmsViewerWin
  • UpdateDocumentAlphabet() : AbstractEditor
  • UpdateDrawableObjects() : Zi8PredictiveInputBox, T9PredictiveInputBox, AbstractPredictiveInputBox
  • UpdateDynamic2Flag() : SimAccessor
  • UpdateDynamicFlag() : SimAccessor
  • UpdateEnabledActions() : DataConnWin, ProvDetailListBoxWin, PhonebookWin, PhonebookApp, PbAbstractWin, AdvPbApp
  • UpdateEntry() : PbRecordHandler, SimPbBaseHandler
  • UpdateExpireTime() : KeyMapping
  • UpdateExtLanguage() : SimAuxHandler
  • UpdateFolderProvider() : UibApp
  • UpdateIndexTable() : SortProvider, MergeProvider
  • UpdateItem() : SoundBrowserApp, AbstractSmsApp, DataConnApp, PbManualSynchronizer, AtlApplicationPlugin, AtlApplication, DBService
  • UpdateItemCount() : Menu
  • UpdateItemMsg() : UpdateItemMsg
  • UpdateLanguage() : SimAuxHandler
  • UpdateList() : BtDeviceListWindow
  • UpdateLockInformation() : DataHandler
  • UpdateMaxAcm() : SimAuxHandler, SimAccessor
  • UpdateMbi() : SimAccessor
  • UpdateMbiRecord() : SimAuxHandler
  • UpdateModification() : Provider
  • UpdateMruProperty() : SimAccessor
  • UpdateMultiMediaEditorDocument() : T9InputMapper
  • UpdateNavigationGuidance() : AbstractGrid, TextList
  • UpdateNoOfItems() : PbProvListBoxModel, PbDetailListBoxModel, ProviderListBoxModel
  • UpdateOptionMenu() : BtDeviceListWindow
  • UpdateOrangeParam() : SimAccessor
  • UpdatePbEntry() : PhonebookApp
  • UpdatePbs() : PhonebookApp
  • UpdatePbThreadlet() : UpdatePbThreadlet
  • UpdatePhoneBookEntry() : SimAccessor
  • UpdatePlmn() : SimAuxHandler
  • UpdatePlmnList() : SimAccessor
  • UpdatePlmnwAct() : SimAuxHandler
  • UpdatePlmnwActList() : SimAccessor
  • UpdatePositionIndicator() : AbstractGrid, AbstractListBox
  • UpdatePrefExtLanguageArray() : SimAccessor
  • UpdatePrefLanguageArray() : SimAccessor
  • UpdateProfile() : DataConnProfileManager
  • UpdateProvider() : ToDoListWin, PbDataHandler, PbAdvDataHandler
  • UpdatePuct() : SimAccessor
  • UpdatePuctData() : SimAuxHandler
  • UpdateRadioDisplay() : FmRadioWindow
  • UpdateReferenceVolume() : AudioDeviceBase
  • UpdateRightsObject() : DrmRightsObjectStore
  • UpdateRow() : CalendarRecordsListBoxModel
  • UpdateSettings() : AbstractSmsApp
  • UpdateSimTkProfileReq() : SimTkHandler
  • UpdatesMainDisplay() : IncrementalPdcUpdater
  • UpdateSmsParam() : SimAccessor
  • UpdateSmsr() : SimAccessor
  • UpdateSmsServiceParameter() : SimSmsParamHandler
  • UpdateSoftkeys() : ContextManager
  • UpdateSortedProvider() : PbDataHandler
  • UpdateStartIndices() : ParagraphCompoundItem
  • UpdateTestInfo() : FfsTestThread
  • UpdateTextEditorDocument() : T9InputMapper
  • UpdateThemes() : ThemeManager
  • UpdateTitle() : LocResController, ProvDetailListBoxWin
  • UpdateTransmit() : SimPduHandler
  • UpdateView() : CalendarRecordsList
  • UpdateVoiceMailboxNumbers() : AbstractSmsApp
  • UpdateWin() : ProvDetailListBoxWin, ProvListBoxWin, PbAbstractWin
  • Uplmn() : Uplmn
  • Uri() : Uri
  • UsbObexServerAddr() : UsbObexServerAddr
  • UsbObexTransport() : UsbObexTransport
  • UsbTransport() : UsbTransport
  • UseAccessory() : AudioAccessoryStore
  • UserActivityEventArg() : UserActivityEventArg
  • UserActivityListener() : UserActivityListener
  • UserData() : UserData
  • UserDataExists() : ParameterIndicator
  • UserDataHeader() : UserDataHeader
  • UserDataHeaderExists() : SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver
  • UserDispatcher() : UserDispatcher
  • UsesIconSet() : Item
  • UsesSecondaryPdpContext() : PsdDataConnProfile
  • UseStaticFonts() : FontManager
  • UsimCardTypeReadIndArg() : UsimCardTypeReadIndArg
  • UsimCardTypeReadReqArg() : UsimCardTypeReadReqArg
  • UsimCsLociReadIndArg() : UsimCsLociReadIndArg
  • UsimCsLociReadReqArg() : UsimCsLociReadReqArg
  • UsimEccReadIndArg() : UsimEccReadIndArg
  • UsimEccReadReqArg() : UsimEccReadReqArg
  • UsimEstReadIndArg() : UsimEstReadIndArg
  • UsimEstReadReqArg() : UsimEstReadReqArg
  • UsimFilePropertyIndArg() : UsimFilePropertyIndArg
  • UsimFilePropertyReqArg() : UsimFilePropertyReqArg
  • UsimLangReadIndArg() : UsimLangReadIndArg
  • UsimLangReadReqArg() : UsimLangReadReqArg
  • UsimLangUpdIndArg() : UsimLangUpdIndArg
  • UsimLangUpdReqArg() : UsimLangUpdReqArg
  • UsimPbChangedField() : UsimPbChangedField
  • UsimPbFillStatus() : UsimPbFillStatus
  • UsimPbFillStatusReqArg() : UsimPbFillStatusReqArg
  • UsimPbFillStatusResArg() : UsimPbFillStatusResArg
  • UsimPbGroups() : UsimPbGroups
  • UsimPbLocationIndArg() : UsimPbLocationIndArg
  • UsimPbLocationReqArg() : UsimPbLocationReqArg
  • UsimPbLocReport() : UsimPbLocReport
  • UsimPbReadAsyncIndArg() : UsimPbReadAsyncIndArg
  • UsimPbReadCnfArg() : UsimPbReadCnfArg
  • UsimPbReadDataAsyncIndArg() : UsimPbReadDataAsyncIndArg
  • UsimPbReadDataReqArg() : UsimPbReadDataReqArg
  • UsimPbReadDataResArg() : UsimPbReadDataResArg
  • UsimPbReadRefAsyncIndArg() : UsimPbReadRefAsyncIndArg
  • UsimPbReadRefReqArg() : UsimPbReadRefReqArg
  • UsimPbReadRefResArg() : UsimPbReadRefResArg
  • UsimPbReadReqArg() : UsimPbReadReqArg
  • UsimPbReadResArg() : UsimPbReadResArg
  • UsimPbReadyIndArg() : UsimPbReadyIndArg
  • UsimPbReadyMsg() : UsimPbReadyMsg
  • UsimPbRefRecord() : UsimPbRefRecord
  • UsimPbResetedMsg() : UsimPbResetedMsg
  • UsimPbRwRecord() : UsimPbRwRecord
  • UsimPbSelectReqArg() : UsimPbSelectReqArg
  • UsimPbSelectResArg() : UsimPbSelectResArg
  • UsimPbStopReqArg() : UsimPbStopReqArg
  • UsimPbStopResArg() : UsimPbStopResArg
  • UsimPbUidRefreshIndArg() : UsimPbUidRefreshIndArg
  • UsimPbUpdDataReqArg() : UsimPbUpdDataReqArg
  • UsimPbUpdDataResArg() : UsimPbUpdDataResArg
  • UsimPbUpdRefReqArg() : UsimPbUpdRefReqArg
  • UsimPbUpdRefResArg() : UsimPbUpdRefResArg
  • UsimPbUpdReqArg() : UsimPbUpdReqArg
  • UsimPbUpdResArg() : UsimPbUpdResArg
  • UsimPlmnReadIndArg() : UsimPlmnReadIndArg
  • UsimPlmnReadReqArg() : UsimPlmnReadReqArg
  • UsimPlmnUpdIndArg() : UsimPlmnUpdIndArg
  • UsimPlmnUpdReqArg() : UsimPlmnUpdReqArg
  • UsimPsLociReadIndArg() : UsimPsLociReadIndArg
  • UsimPsLociReadReqArg() : UsimPsLociReadReqArg
  • UsimReadRecordRejArg() : UsimReadRecordRejArg
  • UsimReadRejArg() : UsimReadRejArg
  • UsimSelect() : SimAccessor
  • UsimSmsParamExtIndArg() : UsimSmsParamExtIndArg
  • UsimSmsParamReadIndArg() : UsimSmsParamReadIndArg
  • UsimSmsParamReadReqArg() : UsimSmsParamReadReqArg
  • UsimSmsParamUpdIndArg() : UsimSmsParamUpdIndArg
  • UsimSmsParamUpdReqArg() : UsimSmsParamUpdReqArg
  • UsimUpdCnfArg() : UsimUpdCnfArg
  • UsimUpdRejArg() : UsimUpdRejArg
  • UsimUstReadIndArg() : UsimUstReadIndArg
  • UsimUstReadReqArg() : UsimUstReadReqArg
  • UssdAction() : UssdAction
  • UssdAnswerIndArg() : UssdAnswerIndArg
  • UssdAnswerMsg() : UssdAnswerMsg
  • UssDataReceivedMsg() : UssDataReceivedMsg
  • UssdBeginMsg() : UssdBeginMsg, UssdHandler
  • UssdControlIndMsg() : UssdControlIndMsg
  • UssdDataMsg() : UssdDataMsg
  • UssdEndMsg() : UssdEndMsg
  • UssdHandler() : UssdHandler
  • UssdIndicationMsg() : UssdIndicationMsg
  • UssdNotifyMsg() : UssdNotifyMsg
  • UssdRequestMsg() : UssdRequestMsg
  • UssdRequestResentMsg() : UssdRequestResentMsg
  • UssdResentMsg() : UssdResentMsg
  • UtcStatusMessage() : UtcStatusMessage
  • UusErasedMsg() : UusErasedMsg
  • UusHandler() : UusHandler
  • UusNotificationMsg() : UusNotificationMsg
  • UusQueryRejectedMsg() : UusQueryRejectedMsg
  • UusRegisteredMsg() : UusRegisteredMsg
  • UusStatusMsg() : UusStatusMsg
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- v -

  • Validate() : Image
  • ValidateAsset() : DrmAsset
  • ValidateAudioData() : AudioUtility
  • ValidateFileName() : MediaBrowserUtils
  • ValidateProtocolIdentifier() : AbstractSmsApp
  • ValidateServiceCenterAddress() : AbstractSmsApp
  • ValidateUri() : Uri
  • ValidateValidityPeriod() : AbstractSmsApp
  • ValidityPeriod() : ValidityPeriod
  • ValidityPeriodFormat() : ValidityPeriodFormat, EnumTranslationTable
  • ValueIndicator() : ValueIndicator
  • ValueMappingPropertyDescriptor() : ValueMappingPropertyDescriptor< T_Container >
  • ValueTextMap() : ValueTextMap
  • VCard() : VCard
  • VCardItem() : VCardItem
  • Vector() : Vector< T >
  • Verbose() : InetSocketAddr, IpAddr
  • VerifyChv() : SimChvHandler, SimAccessor
  • VersionInfo() : VersionInfo
  • VeryLongKeyPressMsg() : VeryLongKeyPressMsg
  • VFormat() : WString, String
  • VideoCamera() : VideoCamera
  • VideoCaptureParameters() : VideoCaptureParameters
  • VideoChannel() : VideoChannel, DefaultDisplay
  • VideoCodecCapabilities() : CodecDevice::VideoCodecCapabilities
  • VideoTrackInfo() : MediaInfo::VideoTrackInfo
  • VietnameseTextRenderer() : VietnameseTextRenderer
  • View() : View
  • ViewAll() : CalendarMonthWin
  • ViewFinder_CB() : CamWin32
  • ViewfinderErrorMsg() : ViewfinderErrorMsg
  • ViewSelectedDay() : CalendarMonthWin
  • VirtualDisplay() : VirtualDisplay
  • Visit() : MediaPathnameVisitor, MediaVisitor, MediaPathnameVisitor, MediaVisitor, StorageDeviceVisitor, FileVisitor
  • VisitDirectories() : FileVisitor
  • VisitObexServer() : ObexServerVisitor
  • VisitOppServer() : ObexServerVisitor
  • VoiceMemoAudioDevice() : VoiceMemoAudioDevice
  • VoiceMemoMenuAccessor() : VoiceMemoMenuAccessor
  • VoiceMemoRecordWin() : VoiceMemoRecordWin
  • VoiceMemoWin() : VoiceMemoWin
  • VrAbortEngineIndArg() : VrAbortEngineIndArg
  • VrErrorIndArg() : VrErrorIndArg
  • VrErrorMsg() : VrErrorMsg
  • VrG2AResultIndArg() : VrG2AResultIndArg
  • VrHandler() : VrHandler
  • VrInitCnfArg() : VrInitCnfArg
  • VrIntrmRecResultIndArg() : VrIntrmRecResultIndArg
  • VrLoadTemplateReqArg() : VrLoadTemplateReqArg
  • VrParamReqArg() : VrParamReqArg
  • VrPlaybackFinishedMsg() : VrPlaybackFinishedMsg
  • VrPromptMsg() : VrPromptMsg
  • VrPropertyResultIndArg() : VrPropertyResultIndArg
  • VrRecognitionAbortedMsg() : VrRecognitionAbortedMsg
  • VrRecognitionFailedMsg() : VrRecognitionFailedMsg
  • VrRecognitionStoppedMsg() : VrRecognitionStoppedMsg
  • VrRecogResultIndArg() : VrRecogResultIndArg
  • VrResultMsg() : VrResultMsg
  • VrSayNameIndArg() : VrSayNameIndArg
  • VrStopRecogIndArg() : VrStopRecogIndArg
  • VrStoreTemplateReqArg() : VrStoreTemplateReqArg
  • VrTrainingAbortedMsg() : VrTrainingAbortedMsg
  • VrTrainingFailedMsg() : VrTrainingFailedMsg
  • VrTrainingResultMsg() : VrTrainingResultMsg
  • VrTrainResultIndArg() : VrTrainResultIndArg
  • VrWarningIndArg() : VrWarningIndArg
  • VrWarningMsg() : VrWarningMsg
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- w -

  • Wait() : SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, MsgQueue, ExecutionContext, AppContainer, ActiveWaitDispatcher, AbstractScheduler, AbstractAppContext, InputParser
  • WaitForDataRecv() : InetSocket
  • WaitForDataSent() : InetSocket
  • WaitForSetup() : DataConn
  • WaitingMessage() : DataCodingScheme, EnumTranslationTable
  • WaitingMessageIndication() : DataCodingScheme, EnumTranslationTable
  • WaitSsAction() : WaitSsAction
  • WaitUntilDecodingIsFinished() : Image
  • Wakeup() : SocketRxThread, SerialSocketThread
  • WapHandler() : WapHandler, HttpWapMgr
  • WapProfile() : WapProfile
  • warning() : WbxmlParserRel
  • WasApplUsimPbLastUsed() : UsimPbLocReport
  • WasChanged() : UsimPbGroups
  • WasChangedToMoc() : SsWaitDispatcher
  • WasGlobalUsimPbLastUsed() : UsimPbLocReport
  • WasRejected() : SsWaitDispatcher
  • WasSimChanged() : DataHandler
  • WasSimPbLastUsed() : UsimPbLocReport
  • WbmpImage() : WbmpImage
  • WbxmlParserRel() : WbxmlParserRel, DrmRelParser
  • WbxmlVector() : WbxmlVector< T >
  • WCharToBcdNibble() : PhoneNumber
  • WeekOfYear() : Date
  • WildCharHandler() : AbstractSmsApp
  • Window() : Window, Control
  • WindowFrameView() : WindowFrameView
  • WindowHierarchyIterator() : WindowHierarchyIterator, WindowManager
  • WinMenuItem() : WinMenuItem
  • WinRect() : WinRect
  • WrapLine() : TimeEditorDocument, TimeCompoundItem, ThaiTextRenderer, TextEditorDocument, TextCompoundItem, SimpleTextRenderer, JapaneseTextRenderer, IpAddrCompoundItem, EditorDocument, DateEditorDocument, DateCompoundItem, CompoundItem, ArabicTextRenderer, AbstractTextRenderer, ParagraphMarker, ParagraphCompoundItem, MultiMediaEditorDocument, GeneralCompoundItem
  • Write() : LcsSocket, FfsDataConnProfileStorage, UdpSocket, TcpSocket, Socket, TcpNetAdapter, UdpNetAdapter, ClientNetAdapter, InetSocket, DataConnProfileStorage, SocketPeer, TraceOutputStream, OutputStream, FileOutputStream, FfsFile, DebugOutputStream, BufferedOutputStream, StringDataSink, HeapDataSink, DataSink, ExtPsdContextListener_SerialTerminal, UserData, FileDataSink, FileChunkOperator, File, RegNodeBuffer, FlsFile, FfsHandler, SioSocketAdapter, SerialSocket, SerialIoAdapter, SerialTerminalSocket, SerialTerminal, RamHandler, RamFileObj, RamFile, FatHandler, FatFile, SocketTestT
  • WriteBlock() : RamStorageMapper
  • WriteBlocks() : RamStorageMapper
  • WriteBool() : HostIniFile
  • WriteBuffer() : VCard
  • WriteCoverageBuffer() : TestWriter
  • WriteCur() : File
  • WriteData() : ExtPsdContextListener_SioGlueWrapper, SioGlueWrapper
  • WriteDefaultRingToneInfo2Ffs() : RingerAudioDevice
  • WriteInteger() : HostIniFile
  • WriteMetaData() : Fota
  • WritePayloadData() : UserData
  • Writer() : ObexBuffer::Writer, ObexBuffer
  • WriteRightsObject() : DrmRightsObjectFile
  • WriteRingToneInfo2Ffs() : RingerAudioDevice
  • WriteState() : TestWriter
  • WriteStreaming() : File, FlsFile, FatHandler, FatFile
  • WriteStreamingAsync() : File, FlsFile, FatHandler, FatFile
  • WriteString() : HostIniFile
  • WriteTo() : DrmInfo, Path
  • WriteToMemory() : BtSddbServiceRecord, BtSddbServiceAttribute, BtSddbDeContainer, BtSddbDeVariableLengthType, BtSddbDeOneByteDescriptionType, BtSddbDataElement
  • WriteTpdu() : CompoundTpduItem
  • WriteVCard() : VCardWriter
  • WString() : WString, InternalTracer, String
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- x -

  • XCallInfoResponseParser() : XCallInfoResponseParser
  • XML_Characters_Handler() : XMLParser, XmlParserRel
  • XML_End_Handler() : XMLParser, XmlParserRel
  • XML_EndCData_Handler() : XMLParser, XmlParserRel
  • XML_EndElement_Handler() : XMLParser, XmlParserRel
  • XML_Error_Handler() : XMLParser, XmlParserRel
  • XML_PI_Handler() : XMLParser, XmlParserRel
  • XML_Start_Handler() : XMLParser, XmlParserRel
  • XML_StartCData_Handler() : XMLParser, XmlParserRel
  • XML_StartElement_Handler() : XMLParser, XmlParserRel
  • XMLParser() : XMLParser
  • XmlParserRel() : XmlParserRel, DrmRelParser
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~

- y -

  • Yield() : Thread
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- a -

  • AbstractEditor : AbstractEditor, InputMapper
  • AbstractGrid : AbstractGrid, AbstractGrid::SmoothScrollInfo
  • AbstractListBox : AbstractListBox, AbstractListBox::SmoothScrollInfo
  • AbstractMultiLineEditor : AbstractMultiLineEditor, InputMapper
  • AlarmManager : StartUp
  • Animation : Animation, Timer
  • AppContainer : AppContainer, Timer, MsgQueue, Message, Application, AbstractScheduler
  • Application : Application, Timer, Control
  • AtcHandler : AtcHandler, AtcDispatcher
  • AtiAudioPlayer : AtiAudioPlayerRtStreamingSink
  • AtiAudioPlayerSinkThread : AtiAudioPlayerRtStreamingSink
  • AtiCodecsLib : AtiMpeg4Encoder, AtiMpeg4Decoder, AtiAudioDecoderRenderer, AtiAudioCapturerEncoder
  • AtlApplicationPlugin : AtlApplicationPlugin, AtlApplication
  • AtlWindow : AtlWindow, ContextManager
  • AudioActiveReference : MmfPlayer
  • AudioMapiManager : MapiAudioPlayer
  • AudioPriorityManager : StreamAudioReference, AudioReference
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- k -

  • KeyManager : KeyMapping, AtlApplication
  • KeyMapping : KeyMapping, KeySequence
  • KeyMsgGenerator : KeyMsgGenerator, KeyMsgGenerator::Key
  • KeySequenceCandidate : KeySequenceCandidate, KeySequence
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- l -

  • LcsCommonStackMsgArgsDestroyTableNode : AbortResArg
  • LcsStackMsgArgsDestroyTableNode : LcsMolrResultArg, LocationNotifInvokeArg
  • LoadingFinishedCondition : SvgPlayer
  • Lock : SmsBasicProvider, PbRecordProvider, PbRecordHandler, AbstractLockableDevice, ThreadSafeProvider, Provider, Protector, AbstractDelegationProvider, HandlerData, Registry, ObjectTreeService, MergeProvider, JoinProvider, AppendProvider, RecordHandler, RegEncoderDecoder, SmsSocketListener
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- m -

  • MainHandler : MainHandler, HandlerListEntry
  • MapiAudioPlayer : MapiAudioReference
  • MediaManager : MediaRecorder, MediaPlayer
  • MediaObtainer : MediaObtainer, Media
  • MediaRecorder : RecordSettings
  • Menu : Menu, Font, AbstractMenuAccessor
  • MenuTable : MenuTableNode
  • MenuTableNode : MenuTableNode, MenuTable
  • MessageHook : MessageHook, MessageRouter
  • MessageHookNotificationMsg : MessageHook
  • MessageHookReferrer : MessageHook
  • MessageQueueEmptyCondition : SimAccessor
  • MessageReceivedCondition : SimAccessor
  • MessageReferrer : MessageReferrer, Message
  • MessageRouter : System, MessageHook, Message, ExecutionContext
  • MessageSendableCondition : SimAccessor
  • MessageStartCondition : SimAccessor
  • MimeTypeTable : MimeTypeTable::Partition
  • MP3AudioPlayer : StreamAudioReference
  • MsgQueue : MsgQueue, AppContainer
  • MultiMediaEditorDocument : MultiMediaEditorDocument, ParagraphCompoundItem
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- n -

  • NativeImageDecoder : NativeImage
  • NetAdapter : NetAdapter, NetAdapterHandler
  • NiSharedPtr< DataConn > : PsdDataConn, DataConn, CsdDataConn
  • NotificationArray : Registry
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- o -

  • ObexAbstractTransport : ObexAbstractTransport, ObexMngr
  • ObexClientOppImpl : ObexOppClient
  • ObexClientPort : ObexClientPort, ObexClientDispatcher
  • ObexDispatcher : ObexDispatcher, ObexEventHandler
  • ObexHeaderBuilder : ObexHeaderBuilder, ObexHeader
  • ObexHeaderList : ObexHeaderList, ObexHeaderList::ConstIterator, ObexHeaderBuilder, ObexHeader
  • ObexLayer : ObexLayer, ObexMngr
  • ObexObject : ObexObject, ObexObjectData
  • ObexObjectData : ObexHeaderList
  • ObexOppClientPull : ObexOppClient
  • ObexOppClientPush : ObexOppClient
  • ObexOppServer : ObexOppServer, ObexMngr
  • ObexOppServerTest : ObexMngr
  • ObexServer : ObexServer, ObexMngr
  • ObexServerInfo : ObexServerInfo, ObexMngr
  • ObexServerMngr : ObexServerMngr, ObexServerInfo
  • ObexServerOppImpl : ObexOppServer
  • ObexServerPort : ObexServerPort, ObexServerDispatcher
  • ObexTransportSet : ObexTransportSet, ObexTransportSet::Iterator
  • ObjectObtainer : ObjectObtainer, ObtainableObject
  • ObservableObject : ObservableObject, Observer
  • operator!= : ObexOperationId, ObexChannel, Ticks, TextFormat, Rect, IconState, Font, Control::NavigationGuidance, Color, BtSvrDataElement, BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceAndServiceClass, BtDeviceAddress, BtDevice, WString, Vector< T >::Iterator, TimeZone, Time, String, SharedPtr< T_obj >, DateTime, Date, DataItem, ResourceID, Uri, Pathname, Pathname::ReverseIterator, Pathname::Iterator, ServicePtr< T >, Guid
  • operator< : Timer, Ticks, WString, Vector< T >::Iterator, Time, String, PhoneNumber, DateTime, Date, DataItem, ResourceID, InputActionPtr, SimItemIdentifier, SimItemId, SimAtom< T >, PlmnListEntry, Pathname::ReverseIterator, Pathname::Iterator, NotificationTableEntry, SignedValue, UnsignedValue
  • operator<< : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, OnDataRcvdMsg, LcsWString, SmsSettingsRecord, ObexVCardMsg, TraceOutputStream, OutputStream, DebugOutputStream, WString, Time, String, PhoneNumber, IpAddr, DateTime, Date, BitField< T >, Uri, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg
  • operator== : MediaRefLinkable, MediaRef, MediaRefLinkable, MediaRef, ObexOperationId, ObexChannel, Ticks, ApplicationListEntry, TextFormat, Rect, IconState, Font, Control::NavigationGuidance, Color, BtSvrDataElement, BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceAndServiceClass, BtDeviceAddress, BtDevice, WString, Vector< T >::Iterator, TimeZone, Time, String, SharedPtr< T_obj >, PhoneNumber, ProviderPtr, DateTime, Date, DataItem, BitField< T >, AudioPlayerStore::DataFormatDataSource, AudioPath, AudioActiveReference, ResourceID, InputActionPtr, Tpdu, SimItemIdentifier, SimAtom< T >, PlmnListEntry, MessageIdentifierContainer::MessageIdentifierPair, MessageIdentifierRange, MessageIdentifier, DataCodingSchemeRange, DataCodingScheme, Uri, Pathname, Pathname::ReverseIterator, Pathname::Iterator, Path, NotificationTableEntry, ServicePtr< T >, Guid, MmCallHdl, SignedValue, UnsignedValue
  • operator> : Ticks, WString, Vector< T >::Iterator, Time, String, PhoneNumber, DateTime, Date, DataItem, ResourceID, Pathname::ReverseIterator, Pathname::Iterator, SignedValue, UnsignedValue
  • operator>> : UibUpdateMsg, UibNotifyMsg, UibRegisterMsg, OnDataRcvdMsg, SmsSettingsRecord, ObexVCardMsg, InputStream, Time, PhoneNumber, IpAddr, DateTime, Date, BitField< T >, MCServiceInterfaceMsg, MediaManagerMsg, EmServThreadMsg
  • OperConfirm : ObexDataServer
  • OperGetData : ObexDataServer
  • OperGetRequest : ObexDataServer
  • OperPutData : ObexDataServer
  • OperPutRequest : ObexDataServer
  • OppDispatcher : ObexOppClient
  • Os : SocketSubSystem, System, Ticks, Thread, GenericWorkerTask, AbstractScheduler, SerialSocketSubSystem
  • Os::DbgOutStackUsage : AppContainer
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- b -

  • BaseHandler : StackMsgDispatcher
  • BasicPackConnector : BasicPackConnector, TextPack, FontPack, DataPack
  • BinData : BinData, MemMap
  • BtApplicationDevicePairRequest : BtApplicationDevicePairRequest, BtDeviceListWindow
  • BtApplicationDeviceSearchRequest : BtApplicationDeviceSearchRequest, BtDeviceListWindow
  • BtApplicationDeviceTrustRequest : BtApplicationDeviceTrustRequest, BtDeviceListWindow
  • BtApplicationDeviceUnpairRequest : BtApplicationDeviceUnpairRequest, BtDeviceListWindow
  • BtApplicationDeviceUntrustRequest : BtApplicationDeviceUntrustRequest, BtDeviceListWindow
  • BtApplicationQuerySupportedProfilesRequest : BtApplicationQuerySupportedProfilesRequest, BtDeviceListWindow, BtDeviceDetailWindow
  • BtApplicationServiceVerifyRequest : BtApplicationServiceVerifyRequest, BtDeviceListWindow
  • BtAvrcpMessageArgumentsDestroyTableNode : BtAvrcpNmaRawFrame, BtAvrcpNmaPanelPassThrough, BtAvrcpNmaDisconnect, BtAvrcpNmaConnect
  • BtAvrcpOperationController : BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationService, BtAvrcpOperationRequestResponse, BtAvrcpConnectResponse
  • BtAvrcpOperationService : BtAvrcpOperationService, BtAvrcpUnitInfoRequest, BtAvrcpSubunitInfoRequest, BtAvrcpRawFrameRequest, BtAvrcpPanelPassThroughRequest, BtAvrcpOperationRequestResponse, BtAvrcpConnectResponse
  • BtAvrcpRegistrationController : BtAvrcpRegisterRequest, BtAvrcpDeRegisterRequest
  • BtAvrcpRegistrationService : BtAvrcpRegistrationService, BtAvrcpRegisterRequest, BtAvrcpDeRegisterRequest
  • BtAvrcpService : BtAvrcpService, BtAvrcpRequest
  • BtBipConnectReq : BtBipClientService
  • BtBipController : BtBipImageHdl, BtBipServerService
  • BtBipDataConverter : BtBipImageHdl
  • BtBipDeleteImageReq : BtBipImageHdl
  • BtBipGetImagePropertiesReq : BtBipImageHdl
  • BtBipGetImageReq : BtBipImageHdl
  • BtBipGetLinkedAttachmentReq : BtBipImageHdl
  • BtBipGetLinkedThumbnailReq : BtBipImageHdl
  • BtBipMecelXmlConverter : BtBipImageHdl
  • BtBipPutAttachReq : BtBipImageHdl
  • BtBipPutImageReq : BtBipImageHdl
  • BtBipPutThumbReq : BtBipImageHdl
  • BtBipServerService : BtBipServerService, BtBipImageHdl
  • BtBppClientService : BtBppClientService, BtBppController
  • BtBppController : BtBppController, BtBppSndGetRefObjRspRequest, BtBppSndFilePushReqRequest, BtBppSndAbortReqRequest, BtBppReq
  • BtBppServerService : BtBppServerService, BtBppController
  • BtBppService : BtBppService, BtBppController
  • BtBppSndAbortReqRequest : BtBppSndAbortReqRequest, BtBppController, BtBppClientService
  • BtBppSndFilePushReqRequest : BtBppSndFilePushReqRequest, BtBppController, BtBppClientService
  • BtBppSndGetRefObjRspRequest : BtBppSndGetRefObjRspRequest, BtBppController
  • BtController : BtController, BtServiceRequest, BtRequest
  • BtDeviceList : BtDeviceList, BtDeviceListIterator, BtDeviceListConstantIterator
  • BtDeviceListBidirectionalIterator : BtDeviceList::BtDeviceListBidirectionalIterator, BtDeviceList::BtDeviceListNode, BtDeviceList
  • BtDeviceListConstantIterator : BtDeviceListConstantIterator, BtDeviceListConstantReverseIterator, BtDeviceList
  • BtDeviceListConstantReverseIterator : BtDeviceListConstantReverseIterator, BtDeviceListConstantIterator, BtDeviceList
  • BtDeviceListIterator : BtDeviceListIterator, BtDeviceList
  • BtDeviceListReverseIteator : BtDeviceListIterator
  • BtDeviceListReverseIterator : BtDeviceListReverseIterator, BtDeviceList
  • BtGapAndSdapController : BtTransport, BtSetRemoteDeviceNameRequest, BtServiceVerifyRequest, BtLocalSettings, BtDeviceSearchRequest, BtDevicePairRequest, BtDeviceList, BtDevice, BtController, BtConnectionlessController, BtConnectionBasedController
  • BtHfMessageArgumentsDestroyTableNode : BtHfNmaCallEvent, BtHfNmaLowPowerModeNotPossible, BtHfNmaSpeakerGain, BtHfNmaMicrophoneGain, BtHfNmaAudioConnectionLost, BtHfNmaTransferAudioToPhone, BtHfNmaTransferAudioToAccessory, BtHfNmaDisconnect, BtHfNmaConnect, BtHfCmaCheckPendingAudioCallback, BtHfCmaAtChldOneCommandReceived, BtHfCmaAudioAsynchronous, BtHfCmaMOC, BtHfCmaMTC, BtHfCmaPhoneNumberRequired
  • BtHfProfileService : BtHfProfileService, BtHfProfileWindow
  • BtHsMessageArgumentsDestroyTableNode : BtHsNmaCallEvent, BtHsNmaLowPowerModeNotPossible, BtHsNmaSpeakerGain, BtHsNmaMicrophoneGain, BtHsNmaAudioConnectionLost, BtHsNmaTransferAudioToPhone, BtHsNmaTransferAudioToAccessory, BtHsNmaDisconnect, BtHsNmaConnect, BtHsCmaCheckPendingAudioCallback, BtHsCmaAudioTransferOutOfCall, BtHsCmaEnterLowPowerMode, BtHsCmaAudioAsynchronous, BtHsCmaHangUp
  • BtHsRequest : BtHsService
  • BtHsRingRequest : BtHsService
  • BtObexAbortRequest : BtObexAbortRequest, BtObexController, BtObexClientService
  • BtObexClientAddrResultNotifier : BtObexClientAddrResultNotifier, BtObexTransport
  • BtObexClientConnection : BtObexImpl
  • BtObexClientObserverImpl : BtObexClientObserverImpl, BtObexImpl
  • BtObexClientService : BtObexClientService, BtObexController, BtObexClientServiceObserver
  • BtObexConnectRequest : BtObexConnectRequest, BtObexController, BtObexClientService
  • BtObexController : BtObexUnregisterServerRequest, BtObexUnregisterClientRequest, BtObexSetPathRequest, BtObexService, BtObexServerService, BtObexRequest, BtObexRegisterServerRequest, BtObexRegisterClientRequest, BtObexPutRequest, BtObexGetRequest, BtObexDisconnectRequest, BtObexConnectRequest, BtObexClientOperationRequest, BtObexAbortRequest
  • BtObexDisconnectRequest : BtObexDisconnectRequest, BtObexController, BtObexClientService
  • BtObexGetRequest : BtObexGetRequest, BtObexController, BtObexClientService
  • BtObexImpl : BtObexImpl, BtObexServerObserverImpl, BtObexClientObserverImpl
  • BtObexMessageArgumentsDestroyTableNode : BtObexClientNmaTransportDisconnect, BtObexClientNmaDataInidication, BtObexClientNmaDataBufferIndication, BtObexClientNmaHeaderIndication, BtObexClientNmaHeaderSent, BtObexServerNmaTransportDisconnect, BtObexServerNmaDataInidication, BtObexServerNmaDataBufferIndication, BtObexServerNmaHeaderIndication, BtObexServerNmaHeaderSent, BtObexServerNmaAbort, BtObexServerNmaPut, BtObexServerNmaGet, BtObexServerNmaSetPath, BtObexServerNmaDisconnect, BtObexServerNmaConnect
  • BtObexPutRequest : BtObexPutRequest, BtObexController, BtObexClientService
  • BtObexRegisterClientRequest : BtObexRegisterClientRequest, BtObexController, BtObexClientService
  • BtObexRegisterServerRequest : BtObexRegisterServerRequest, BtObexServerService, BtObexController
  • BtObexRequest : BtObexRequest, BtObexService
  • BtObexSddbServiceObserverImpl : BtObexSddbServiceObserverImpl, BtObexImpl
  • BtObexSendResponseRequest : BtObexController
  • BtObexServerConnection : BtObexImpl
  • BtObexServerObserverImpl : BtObexServerObserverImpl, BtObexServerAddr, BtObexImpl
  • BtObexServerService : BtObexServerService, BtObexServerServiceObserver, BtObexController
  • BtObexService : BtObexService, BtObexServiceObserver, BtObexController
  • BtObexServiceTable : BtObexServiceTable::ServiceInfo
  • BtObexSetPathRequest : BtObexSetPathRequest, BtObexController, BtObexClientService
  • BtObexTransport : BtObexTransport, BtObexServerAddr, BtObexClientAddr
  • BtObexUnregisterClientRequest : BtObexUnregisterClientRequest, BtObexController, BtObexClientService
  • BtObexUnregisterServerRequest : BtObexUnregisterServerRequest, BtObexServerService, BtObexController
  • BtObservableService : BtObservableService, BtServiceObserver
  • BtOperationSelectDeviceAndPerformServiceVerify : BtOperationSelectDeviceAndPerformServiceVerify, BtServiceVerifyResult
  • BtSddbDeContainer : BtSddbDeContainer, BtSddbDataElement
  • BtSddbRegisterServiceRecordRequest : BtSddbService
  • BtSddbService : BtSddbService, BtObexSddbServiceObserverImpl, BtSddbServiceObserver
  • BtSddbServiceAttribute : BtSddbServiceAttribute, BtSddbDataElement
  • BtSddbServiceRecord : BtSddbServiceRecord, BtSddbServiceAttribute
  • BtSddbUnregisterServiceRecordRequest : BtSddbService
  • BtServiceDiscoveryDatabase : BtSddbServiceRecord
  • BtServiceRequest : BtServiceRequest, BtService
  • BtServiceVerifyRequest : BtServiceVerifyRequest, BtServiceVerifyResult
  • BtServiceVerifyResult : BtSvrServiceRecord
  • BtSingleConnectionController : BtSingleConnectionController, BtDisconnectRequest, BtConnectRequest
  • BtSvrServiceAttribute : BtSvrServiceAttribute, BtSvrDataElement
  • BtSvrServiceRecord : BtSvrServiceRecord, BtSvrServiceAttribute
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- c -

  • CameraConfig : VideoCamera, StillCamera
  • CleanupDrawingObtainer : Image::CleanupDrawingObtainer, Image
  • ClientAppContext : IrdaObexImpl
  • ClientHandler : MmiSimServer
  • ClientNetAdapter : ClientNetAdapter, NetAdapterHandler
  • CodecConfig : ScicosCodecIfLib, AtiCodecsLib, EmzCodecsLib, CodecManager
  • CodecManager : AtiAudioDecoderRenderer, VideoEncoder, VideoDecoder, CodecDevice, AudioEncoder, AudioDecoderRenderer, AudioDecoder, AudioCapturerEncoder
  • CommonSignalProcessor : ShutDown
  • CommonStackMsgArgsDestroyTableNode : SsUus1QueryReqArg, SsUus1ReqArg, SsCcbsReCallRequestArg, SsCcbsRejectArg, SsCcbsInvokeArg, SsUssdReqArg, SsRejReqArg, SsErrReqArg, SsGetPasswordRspArg, SsSendEndReqArg, SsSendReqArg, SsCcbsResultIndArg, SsCcbsStatusIndArg, SsCcbsReCallIndArg, SsUus1IndArg, SsUus1QueryRejArg, SsUus1QueryIndArg, UssdAnswerIndArg, SsUssdResentIndArg, SsUssdIndArg, SsCauseIndArg, SsGetPasswordRejArg, SsGetPasswordIndArg, SsErrIndArg, SsClientRejArg, SsRejArg, SsEndIndArg, SsRetResIndArg, SsForwcheckIndArg, SsUnstructIndArg, SsPasswordIndArg, SsInterrogateIndArg, SsNotifyIndArg, SsDataIndArg, SsBarringIndArg, SsForwardingIndArg, SsFacilityRejArg, SsFacilityIndArg, SsBeginAccArg, SmsGetMoreMessageStatusReqArg, SmsSetMoreMessageReqArg, SmsSendReqArg, SmsConfigIndArg, SmsGetMoreMessageStatusIndArg, SmsCapacityAvailableArg, SmsCapacityExceededArg, SmsSendRejArg, SmsSendCnfArg, SmsNewStatusReportIndArg, SmsNewMessageIndArg, SimTkRefreshNewRspArg, SimTkStopSendDtmfReqArg, SimTkSendDtmfCnfArg, SimTkRunAtCmdInfoResArg, DhChannelChangeStatusEventArg, DhChannelReceiveIndArg, DhChannelDataAvailEventArg, DhChannelSendIndArg, DhChannelCloseIndArg, DhChannelOpenRejArg, DhChannelOpenCnfArg, SiChannelReceiveInfoResArg, SiChannelSendInfoResArg, SiChannelCloseInfoResArg, SiChannelCloseReqArg, SiChannelOpenPromptResArg, BrowserTermEventArg, LaunchBrowserIndArg, LaunchBrowserPromptIndArg, BrowserRegisterReqArg, SimTkRefreshCnfIndArg, SimTkRefreshQueryResArg, ExtProactiveCmdIndArg, LanguageSettingIndArg, LanguageSelectEventArg, IdleScreenAvailEventArg, UserActivityEventArg, SetupEventCnfArg, SetupIdleModeTextRspArg, PlayToneRspArg, MenuSelectionReqArg, SetupMenuRspArg, SelectItemRspArg, GetInkeyRspArg, GetInputRspArg, DisplayTextRspArg, SimTkResetCnfIndArg, SimTkRefreshResetRspArg, SimTkRefreshRspArg, SimTkCallSetupRejArg, SimTkCallSetupAccArg, SimTkSsRspArg, SimTkSmsPpRspArg, SimTkRefreshNewReqArg, CallControlUssdIndArg, CallControlSsIndArg, CallControlSetupIndArg, SmsControlIndArg, SimTkInterfaceIndArg, SimTkSendDtmfEndIndArg, SimTkSendDtmfIndArg, SimTkRunAtCmdInfoIndArg, DhChannelChangeStatusResArg, DhChannelReceiveReqArg, DhChannelDataAvailableResArg, DhChannelSendReqArg, DhChannelCloseReqArg, DhChannelOpenReqArg, SiChannelReceiveInfoIndArg, SiChannelSendInfoIndArg, SiChannelCloseInfoIndArg, SiChannelOpenPromptReqArg, SimBrowserTermResArg, SimLaunchBrowserReqArg, SimLaunchBrowserPromptReqArg, SimTkRefreshCnfReqArg, SimTkRefreshQueryReqArg, TermRspCnfArg, ExtProactiveCmdCnfArg, ExtProactiveCmdReqArg, LanguageSettingReqArg, SimTkSetupEventReqArg, SimTkLanguageNotificationIndArg, EndSimToolkitIndArg, SetupIdleModeTextReqArg, PlayToneReqArg, MenuSelectionRejArg, SetupMenuReqArg, SelectItemReqArg, GetInkeyReqArg, GetInputReqArg, DisplayTextReqArg, SimTkResetCnfArg, SimTkResetCnfReqArg, SimTkRefreshResetReqArg, SimTkRefreshReqArg, SimTkSsIndArg, SimTkSmsPpIndArg, SimTkCallSetupIndArg, SimModifyLockReqArg, BdnReqArg, FdnReqArg, SimMruPropertyUpdReqArg, SimODyn2UpdReqArg, SimODynUpdReqArg, SimODyn2ReadReqArg, SimODynReadReqArg, SimCmiReadReqArg, UsimFilePropertyReqArg, UsimLangUpdReqArg, UsimEstReadReqArg, UsimSmsParamUpdReqArg, UsimCardTypeReadReqArg, UsimPlmnUpdReqArg, UsimSmsParamReadReqArg, UsimEccReadReqArg, UsimLangReadReqArg, UsimPsLociReadReqArg, UsimCsLociReadReqArg, UsimPlmnReadReqArg, UsimUstReadReqArg, SimSmsrUpdReqArg, SimSmsrReadReqArg, SimCcpUpdReqArg, SimCcpReadReqArg, SimCbmirUpdReqArg, SimCbmiUpdReqArg, SimCbmirReadReqArg, SimCbmiReadReqArg, CphsCspUpdReqArg, CphsCspReadReqArg, CphsCfufUpdReqArg, CphsVmwfUpdReqArg, CphsOnsReadReqArg, CphsOnmReadReqArg, CphsCfufReadReqArg, CphsVmwfReadReqArg, CphsIstReadReqArg, SimFileInfoReqArg, SimSpnReadReqArg, SimExtLangUpdReqArg, SimExtLangReadReqArg, SimLangUpdReqArg, SimLangReadReqArg, SimGenericReqArg, SimPuctUpdReqArg, SimPuctReadReqArg, SimAcmMaxUpdReqArg, SimAcmMaxReadReqArg, SimAcmUpdReqArg, SimAcmReadReqArg, SimSstReadReqArg, SimRefreshReqArg, SimModifyLockIndArg, BdnIndArg, FdnIndArg, SimFullAccessIndArg, SimLockStatusIndArg, SimInfoIndArg, SimInitIndArg, SimMruPropertyRefreshIndArg, SimMruPropertyUpdCnfArg, SimODyn2UpdIndArg, SimODynUpdIndArg, SimODyn2ReadIndArg, SimODynReadIndArg, SimCmiReadIndArg, UsimFilePropertyIndArg, UsimLangUpdIndArg, UsimEstReadIndArg, UsimSmsParamUpdIndArg, UsimCardTypeReadIndArg, UsimPlmnUpdIndArg, UsimUpdRejArg, UsimUpdCnfArg, UsimSmsParamExtIndArg, UsimSmsParamReadIndArg, UsimReadRecordRejArg, UsimEccReadIndArg, UsimLangReadIndArg, UsimPsLociReadIndArg, UsimCsLociReadIndArg, UsimReadRejArg, UsimPlmnReadIndArg, UsimUstReadIndArg, SimMccMncIndArg, SimSmsrUpdIndArg, SimSmsrReadIndArg, SimCcpUpdIndArg, SimCcpReadIndArg, SimCbmirUpdIndArg, SimCbmiUpdIndArg, SimCbmirReadIndArg, SimCbmiReadIndArg, CphsCspUpdIndArg, CphsCspReadIndArg, CphsCfufUpdIndArg, CphsVmwfUpdIndArg, CphsOnsReadIndArg, CphsOnmReadIndArg, CphsCfufReadIndArg, CphsVmwfReadIndArg, CphsIstReadIndArg, SimFileInfoIndArg, SimSpnReadIndArg, SimExtLangUpdIndArg, SimExtLangReadIndArg, SimLangUpdIndArg, SimLangReadIndArg, SimGenericIndArg, SimPuctUpdIndArg, SimPuctReadIndArg, SimAcmMaxUpdIndArg, SimAcmMaxReadIndArg, SimAcmUpdIndArg, SimAcmReadIndArg, SimSstReadIndArg, SimRefreshIndArg, SimErrorIndArg, ControlHwDataOnlyArg, StopSignalStrengthListeningArg, StartSignalStrengthListeningArg, StopBatteryLoadListeningArg, ClientDeregistrationArg, ClientRegistrationArg, PowerDownReqArg, OmPowerUpArg, PowerDownIndArg, OmControlIndArg, PowerDownCnfArg, PlmnListReqArg, GprsClassReqArg, PlmnInfoReqArg, DetachReqArg, AttachReqArg, PrefServiceSetReqArg, PrefPlmnChangeArg, PlmnListAbortArg, GprsClassIndArg, AttachAllowedIndArg, DetachCnfArg, AttachRejArg, AttachCnfArg, RegStateIndArg, NRegStateIndArg, PlmnListRejArg, PlmnListCnfArg, UsimPbReadCnfArg, UsimPbStopReqArg, UsimPbFillStatusReqArg, UsimPbUpdDataReqArg, UsimPbUpdRefReqArg, UsimPbUpdReqArg, UsimPbReadDataReqArg, UsimPbReadRefReqArg, UsimPbReadReqArg, UsimPbSelectReqArg, UsimPbLocationReqArg, PbCountReqArg, PbEntryUpdReqArg, PbEntryReadReqArg, PbInfoReadReqArg, UsimPbReadyIndArg, UsimPbUidRefreshIndArg, UsimPbStopResArg, UsimPbFillStatusResArg, UsimPbUpdDataResArg, UsimPbUpdRefResArg, UsimPbUpdResArg, UsimPbReadDataAsyncIndArg, UsimPbReadDataResArg, UsimPbReadRefAsyncIndArg, UsimPbReadRefResArg, UsimPbReadAsyncIndArg, UsimPbReadResArg, UsimPbSelectResArg, UsimPbLocationIndArg, PbCountIndArg, PbEntryUpdIndArg, PbEntryReadIndArg, PbInfoReadIndArg, OmRatChangeReqArg, OmBandStatusReqArg, OmMultiSlotReqArg, OmRatChangeIndArg, OmRatChangeCnfArg, OmBandStatusCnfArg, OmMultiSlotIndArg, MnNetworkSearchModeReqArg, MnTriggerReqArg, HomezoneIndArg, BandSelectionIndArg, TestparamReportArg, MnInformationIndArg, CellInfoIndArg, ConnectionIndArg, MtcAlertReqArg, MtcAcceptArg, MtcAcceptRejArg, MtcSetupComplArg, MtcSetupIndArg, MtcConfIndArg, ClearBlacklistReqArg, RediallingDisabledIndArg, RedialRejArg, MocSetupReqArg, ClearBlackListCnfArg, AutoCallRestrictIndArg, RedialStopIndArg, RedialSetupIndArg, RedialIndArg, MocSetupCnfArg, MocAlertIndArg, MocSetupAccArg, MocSetupRejArg, EngineeringModeControlRequestArg, OmSetTermProfileReqArg, OmGetTermProfileReqArg, OmFactoryResetIndArg, BandSelectionReqArg, TestparamReqArg, ImeiReadReqArg, BootDispatchingArg, EccListIndArg, CfuDataIndArg, EngineeringModeControlResponseArg, OmSetTermProfileRejArg, OmSetTermProfileCnfArg, OmGetTermProfileCnfArg, AccessoryIndArg, ImeiReadIndArg, SignalStrengthLevelIndArg, MdhSmsExtendedDataReqArg, MdhSmsDeletionReqArg, MdhSmsConcRefNumReqArg, MdhSmsReportReadReqArg, MdhSmsTransmitAckArg, MdhSmsTransmitStartAckArg, MdhSmsSetWaitingReqArg, MdhRemoveViewReqArg, MdhMakeViewReqArg, MdhSetConfigReqArg, MdhSmsWriteReqArg, MdhSmsReadReqArg, MdhSetStorageReqArg, MdhSmsUpdStatusReqArg, MdhSmsStatusReqArg, MdhRegistrationReqArg, MdhDeregistrationReqArg, MdhSmsExtendedDataIndArg, MdhSmsDeletionIndArg, MdhSmsConcRefNumIndArg, MdhSmsReportReadIndArg, MdhSmsTransmitStopIndArg, MdhSmsTransmitIndArg, MdhSmsTransmitStartIndArg, MdhSmsWaitingIndArg, MdhSmsInitFinishedIndArg, MdhSmsNewMessageIndArg, MdhSmsUpdStatusRefreshIndArg, MdhSmsStorageRefreshIndArg, MdhSmsRefreshIndArg, MdhNewStatusReportIndArg, MdhRemoveViewCnfArg, MdhMakeViewCnfArg, MdhSetConfigCnfArg, MdhSmsWriteCnfArg, MdhSmsReadIndArg, MdhSetStorageCnfArg, MdhSmsUpdStatusIndArg, MdhSmsStatusIndArg, MdhRegistrationCnfArg, MdhDeregistrationCnfArg, IconDescReadReqArg, ImageReadReqArg, IconDescReadIndArg, ImageReadIndArg, ChargeUnitsReqArg, SetChargeUnitsArg, ChargeReqArg, SetAutoChargeArg, CallRelatedSsReqArg, ChargeUnitsIndArg, ChargeIndArg, AocIndArg, EctCnfArg, MptyCnfArg, CallHoldRejArg, CallHoldCnfArg, CallRelatedSsRejArg, CallRelatedSsCnfArg, PinDisableReqArg, PinEnableReqArg, Chv1DisableReqArg, Chv1EnableReqArg, ChvUnblockReqArg, ChvChangeReqArg, ChvVerifyReqArg, PinDisableIndArg, PinEnableIndArg, ChvRefreshIndArg, Chv1DisableIndArg, Chv1EnableIndArg, ChvUnblockIndArg, ChvChangeIndArg, ChvVerifyIndArg, CallDeflectSsReqArg, CallDeflectionIndArg, CbsStopReqArg, CbsStartReqArg, CbsNewDataRejArg, CbsLimitIndArg, CbsStopCnfArg, CbsStartCnfArg, CbsStopRejArg, CbsStartRejArg, CbsNewDataIndArg, RedialQueryReqArg, RejectCallsIndArg, StopDtmfReqArg, StartDtmfReqArg, CallDiscReqArg, MocSetupRejIndArg, CallIndCallControlInfoArg, RedialStatusIndArg, CallSetupBySimtTkReqArg, CtmInfoIndArg, DiagnosticIndArg, CallRelIndArg, CallRelCnfArg, NotifyIndArg, DtmfBufferClearedIndArg, StartDtmfRejArg, StopDtmfCnfArg, StartDtmfCnfArg, CallIndArg, CallDiscIndArg, CallProgressIndArg, AtAccessoryRegisterCnfArg, AtAccessoryNotificationIndArg, AtGenericCmdIndArg, AtPbInfoIndArg, AtPbListCnfArg, AtPbSelectCnfArg, AtAlphaTagCnfArg, AtAccessoryRegisterReqArg, AtGenericCmdReqArg, AtPbListReqArg, AtPbSelectReqArg, AtAlphaTagReqArg
  • CompoundItemIterator : CompoundItemIterator, MultiMediaEditorDocument
  • CompoundSmsItem : CompoundSmsItem, SimPduHandler
  • CompoundTpduItem : CompoundTpduItem, SimPduHandler
  • ContextManager : AtlConfig
  • ContextTable : ContextTableNode
  • ContextTableNode : ContextTableNode, ContextTable
  • Control : Control, VirtualDisplay, RealTimeClock, VirtualDisplay, Keyboard, Fota, Charger, VirtualDisplay, AbstractDevice, ThaiTextRenderer, DrawableObject
  • Control::AbsInvalidate : Application
  • Control::PutToForeground : Application
  • CsdDataConnProfile : CsdDataConnProfile, PersistDataConnProfile
  • CTResourceParser : CTResourcePack
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- d -

  • DataCallSignalProcessor : DataCallHdl
  • DataConn : DataConn, SysSocket, SocketSubSystem, SocketData
  • DataConnCtrlCbs : DataConn
  • DataConnManager : SysSocket, DataConnProfile, DataConn
  • DataConnProfile : DataConnProfile, PsdDataConn, PersistDataConnProfile, DataConn, CsdDataConn
  • DataConnProfileManager : PersistDataConnProfile, DataConnProfileManager::ProfileInfo, DataConnProfile
  • DataRecordHandler : DataRecordHandler, DataRecord
  • DeviceContext::EndUpdate : Application
  • DeviceManager : AbstractDevice
  • DnsClient : DnsClient, SysDnsClient
  • DupeChecker : ObexOppServer
  • DwdPlayer : DwdPlayer, RadioAudioDevice
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- e -

  • EditBoxBlinkTimer : EditBoxBlinkTimer, AbstractEditBox
  • EditBoxPagingTimer : EditBoxPagingTimer, EditBox
  • EmApoxiMediaInfo : MediaInfo
  • EmApoxiRecordSettings : RecordSettings
  • EmsEditor : EmsEditor, EmsEditorListener
  • EmzAacDecoder : EmzAacDecoderThread
  • EmzAacDecoderThread : EmzAacDecoder
  • EmzCodecsLib : EmzSbcEncoder, EmzMpeg4Encoder, EmzMpeg4Decoder, EmzMp3Decoder, EmzH264Decoder, EmzAacDecoder
  • EmzH264Decoder : EmzH264DecoderThread
  • EmzH264DecoderThread : EmzH264Decoder
  • EmzMp3Decoder : EmzMp3DecoderThread
  • EmzMp3DecoderThread : EmzMp3Decoder
  • EmzMpeg4Decoder : EmzMpeg4DecoderThread
  • EmzMpeg4DecoderThread : EmzMpeg4Decoder
  • EmzMpeg4Encoder : EmzMpeg4EncoderThread
  • EmzMpeg4EncoderThread : EmzMpeg4Encoder
  • EmzSbcEncoder : EmzSbcEncoderThread
  • EmzSbcEncoderThread : EmzSbcEncoder
  • EncodingThreadlet : EncodingThreadlet, ImageEncoder
  • ExecutionContext : ExecutionContext, UserDispatcher
  • ExtPsdContextListener_SioGlueSignalListener : ExtPsdContextListener_SioGlueSignalListener, ExtPsdContextListener_SerialTerminal
  • ExtPsdContextListener_SioGlueWrapper : ExtPsdContextListener_SioGlueWrapper::TermIos, ExtPsdContextListener_SioGlueWrapper::SioCommId
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- f -

  • Factory : ObexBuffer::Factory, ObexBuffer
  • FatDirectoryIteratorImp : FatDirectoryIteratorImp, FatStorageDeviceImp
  • FatFile : FatFile, FatStorageDeviceImp
  • FatFileImp : FatFileImp, FatStorageDeviceImp
  • FatStorageDeviceImp : FatFileImp, FatDirectoryIteratorImp
  • FatStorageDeviceImpInternals : FatStorageDeviceImp
  • Feature : SimTkProfile, Feature, AudioDeviceBase, FeatureBroker
  • FeatureListener : AtlItemBox
  • File : File, StorageDevice
  • FileChunkOperator : FileChunkOperator, File
  • FlashDirectoryIteratorImp : FlashDirectoryIteratorImp, FlashStorageDeviceImp
  • FlashFileImp : FlashFileImp, FlashStorageDeviceImp
  • FlashStorageDeviceImp : FlashStorageDeviceImp, FlashFileImp, FlashDirectoryIteratorImp
  • FlsFile : FlsFile, FlashStorageDeviceImp
  • FocusObtainer : FocusObtainer, System
  • FromStackMsg : FromStackMsg, StackMsgArgument
  • FsmEngine : ObexAbstractPort
  • FtpClient : FtpClient, FtpTransfer, FtpSocket, FtpServer, FtpDataSocket, FtpDataServerSocket
  • FtpDataServerSocket : FtpDataServerSocket, FtpClient
  • FtpDataSocket : FtpDataSocket, FtpTransfer, FtpSocket, FtpOutTransfer, FtpInTransfer
  • FtpInTransfer : FtpInTransfer, FtpSocket, FtpDataSocket
  • FtpOutTransfer : FtpOutTransfer, FtpSocket, FtpDataSocket
  • FtpServer : FtpServer, FtpTransfer, FtpSocket, FtpOutTransfer, FtpInTransfer, FtpDataSocket, FtpClient
  • FtpServerSocket : FtpServerSocket, FtpSocket
  • FtpSocket : FtpSocket, FtpServer
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- g -

  • GatiManagerInternals : GatiManager
  • GenericWorkerTask : Threadlet
  • GifDecoder : GifImage
  • GltpStackMsgArgsDestroyTableNode : MeasurementDataArg
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- h -

  • HeadSet : HeadSet, Accessory
  • HeapDataSource : HeapDataSource, HeapDataSink
  • HeapVector : HeapManager
  • HttpClient : HttpClient, HttpSocket, HttpServer, HttpApplicationSupplier, HttpApplication
  • HttpHandler : HttpHandler, HttpWapMgr
  • HttpServer : HttpServer, HttpSocket, HttpRequest, HttpClient, HttpApplicationSupplier, HttpApplication
  • HttpServerSocket : HttpServerSocket, HttpServer
  • HttpSocket : HttpSocket, HttpServer, HttpRequest
  • HttpWapMgr : HttpWapMgrPlugin
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- i -

  • ImageBoxView : ImageBox
  • ImageBrowserApp : MediaRefContainer
  • IndicatorBarView : IndicatorBarView, IndicatorBar
  • InetSocket : InetSocket, SocketSubSystem, SocketData
  • IsrDataManager : IsrDataMarshaller
  • IsrDataMarshaller : IsrDataMarshaller, IsrDataManager
  • Iterator : ObexTransportSet::Iterator, DeviceManager::Iterator, Vector< T >::Iterator, SimpleMap< TKey, TValue >::Iterator, Pathname::Iterator, DeviceManager, Vector< T >, SimpleMap< TKey, TValue >
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- p -

  • Partition : MimeTypeTable::Partition, MimeTypeTable
  • Path : Path, PathProfile
  • Pathname : Pathname, Pathname::ReverseIterator, Pathname::Iterator
  • PbAbstractWin : PbAbstractWin, PhonebookApp
  • PCMAudioPlayer : StreamAudioReference
  • PdpContext : PdpContextManager, PdpContext, PdpContext::PacketFilter
  • PdpContextManager : PdpContextManager, PdpContextControl, PdpContext
  • PdpContextSignalProcessor : PdpContextManager, PdpContext
  • PersistDataConnProfile : PersistDataConnProfile, DataConnProfile
  • PppDataConn : PppDataConn, SysSocket
  • Property : CamWin32, Property, FeatureBroker
  • PsdDataConn : PsdDataConn, SysSocket
  • PsdDataConnCtrlCbs : PsdDataConn
  • PsdDataConnProfile : PsdDataConnProfile, PersistDataConnProfile
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- r -

  • RamDataSource : RamDataSource, RamDataSink
  • RamFileObj : RamFileObj, RamStorageMapper
  • RamFileSystem : RamFileNode
  • RamStorageDeviceImp : RamStorageDeviceImp, RamFileImp, RamDirectoryIteratorImp
  • Reader : ObexBuffer::Reader, ObexBuffer
  • RegIterator : RegIterator, Registry
  • RegManager : RegManager, Registry
  • RingerAudioPlayer : AudioReference
  • RootFileImp : RootFileImp, File
  • RootFileSystem : RootStorageDeviceIterator, StorageDeviceIterator, StorageDevice, File, RootStorageDeviceImp, RamStorageDeviceImp, FlashStorageDeviceImp, FatStorageDeviceImp
  • RootStorageDeviceImp : RootStorageDeviceImp, RootFileImp
  • RtStreamingConn : RtStreamingConn, RtStreamingSource, RtStreamingSink
  • RtStreamingEndPoint : RtStreamingEndPoint, RtStreamingConn
  • RtStreamingSink : RtStreamingSink, RtStreamingConn
  • RtStreamingSource : RtStreamingSource, RtStreamingConn
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- s -

  • SaStackMsgArgsDestroyTableNode : SaLocationErrArg, SaMolrResultArg
  • Scanner : BtJsr82Url::Token, BtJsr82Url
  • ScicosCodecIfLib : ScicosMpeg4VideoEncoder, ScicosMpeg4VideoDecoder
  • Semaphore : Semaphore, Ticks
  • SerialClientSocket : SerialClientSocket, SerialSocketSubSystem, SerialSocketData
  • SerialIoAdapter : SerialIoAdapter, SerialSocket
  • SerialIoSet : SerialIoSet, SerialSocket, SerialIoAdapter
  • SerialServerSocket : SerialServerSocket, SerialSocketSubSystem, SerialSocketData, SerialClientSocket
  • SerialSocket : SerialSocket, SerialSocketSubSystem, SerialSocketData, SerialIoAdapter
  • SerialSocketData : SocketData
  • SerialSocketDataLock : SerialSocketDataLock, SerialSocketSubSystem
  • SerialSocketSubSystem : SerialSocketSubSystem, SerialSocketData
  • SerialSocketThread : SerialSocketThread, SerialSocketSubSystem
  • SerialTerminalMsgArgsDestroyTableNode : SerialTerminalArg
  • Server : Server, ServerClient
  • ServerAppContext : IrdaObexImpl
  • Service : Service, ServiceBroker
  • ServiceBrokerDestructor : ServiceBroker
  • ServiceThread : ServiceThread, Timer, System, MsgQueue
  • ShutDown : System, AbstractScheduler, GatiManager, System, Fota, DeviceManager, PowerHandler
  • SignalMapTable : SignalMapTableNode
  • SignalMapTableNode : SignalMapTableNode, SignalMapTable
  • SimAccessor : SimAccessor, DataHandler
  • SimHandler : SimHandler, SimDispatcher
  • SimPduHandler : SimPduHandler, DataHandler
  • SimpleMap< TKey, TValue > : SimpleMap< TKey, TValue >::Iterator, SimpleMapElem< TKey, TValue >
  • SimUserDispatcher : SimUserDispatcher, SimAccessor
  • SioGlueSignalListener : SioGlueSignalListener, SerialTerminal
  • SioGlueWrapper : SioGlueWrapper::TermIos, SioGlueWrapper::SioCommId
  • SioSocketAdapter::SerialClientSockEventListener : SioSocketAdapter
  • SioSocketAdapter::SerialServerSockEventListener : SioSocketAdapter
  • SmsFactory : SmsFactory, SmsCommand, SmsSubmit
  • SmsLoadingFinishedCondition : BootControl
  • SmsSocket : SmsSocket, SmsSocketListener
  • SmsSocketListener : SmsSocket
  • SmsSocketSignalMapTableNode : SmsSocketListener
  • SocketDataLock : SocketDataLock, SocketSubSystem
  • SocketHandler : SocketHandler, Socket, InetSocket
  • SocketRxThread : SocketRxThread, SysSocket, SocketSubSystem, DataConnManager
  • SocketSubSystem : SocketSubSystem, SocketData
  • SoundBrowserApp : MediaRefContainer
  • SsStackMsgArgument : StackMsgArgument
  • StackMsgArgDestroyTableNode : StackMsgArgDestroyTableNode, StackMsgArgument
  • StackMsgArgument : StackMsgArgument, NoStackMsgArg, StackMsgArgDestroyTableNode
  • StackMsgMapTable : StackMsgMapTableNode
  • StackMsgMapTableNode : StackMsgMapTableNode, StackMsgMapTable
  • StartUp : SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, AbstractScheduler, AbstractAppContext, GatiManager, System, ServiceThread, MessageRouter, DeviceManager
  • StartUp::Restart : Application
  • StorageDevice : StorageDevice, RootFileSystem
  • StorageDeviceIterator : StorageDeviceIterator, RootFileSystem
  • StreamAudioPlayer : StreamAudioPlayer, StreamAudioReference
  • String : String, InternalTracer, WString
  • SubSystem : SubSystem, SubSystemManager
  • SubSystemManager : SubSystem
  • SvgPlayerView : SvgPlayer
  • SvgThreadlet : SvgPlayer
  • SwitchedRleCompression : SwitchedRleCompression::Context
  • SysDnsClient : SysDnsClient, DnsClient
  • SysSocket : SysSocket, SocketSubSystem, Ticks
  • System : FocusObtainer, AppContainer
  • SystemTimerInternals : SystemTimer
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- t -

  • TcpServerSocket : SocketSubSystem, SocketData, InetSocket, FtpDataServerSocket
  • TcpSocket : TcpSocket, SocketData
  • Threadlet : Threadlet, GenericWorkerTask
  • Timer : Timer, Ticks, ExecutionContext, AppContainer
  • Token : BtJsr82Url
  • ToneAudioPlayer : AudioReference
  • ToStackMsg : ToStackMsg, StackMsgArgument
  • TpduCache : TpduCache, SimPduHandler
  • TransportManager : ObexMngr
  • TriggerTimer< AbstractItemGrid > : AbstractItemGrid
  • TriggerTimer< AnimatedTextLine > : AnimatedTextLine
  • TriggerTimer< DefaultCaret > : DefaultCaret
  • TriggerTimer< FfsTestDispWin > : FfsTestDispWin
  • TriggerTimer< ImageBox > : ImageBox
  • TriggerTimer< ItemBox > : ItemBox
  • TriggerTimer< MultiTapInputMapper > : MultiTapInputMapper
  • TriggerTimer< SocketTestApp > : SocketTestApp
  • TriggerTimer< SocketTestProgressWin > : SocketTestProgressWin
  • TriggerTimer< SvgPlayer > : SvgPlayer
  • TriggerTimer< TimeoutCondition > : TimeoutCondition
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- u -

  • UdpSocket : SocketData
  • UsimPlmnListDispatcher : SimAccessor
  • UsimSmsParamDispatcher : SimAccessor
  • UssdBeginMsg : UssdBeginMsg, UssdHandler
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- v -

  • VCardParser : VCard
  • VCardWriter : VCard
  • Vector< T > : Vector< T >::Iterator
  • VideoChannel : VideoChannel, DefaultDisplay
  • VoiceMemoAudioPlayer : StreamAudioReference
  • VrStackMsgArgTableDestroyTableNode : VrPropertyResultIndArg, VrWarningIndArg, VrErrorIndArg, VrG2AResultIndArg, VrStoreTemplateReqArg, VrStopRecogIndArg, VrAbortEngineIndArg, VrTrainResultIndArg, VrRecogResultIndArg, VrIntrmRecResultIndArg, VrSayNameIndArg, VrLoadTemplateReqArg, VrInitCnfArg, VrParamReqArg
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- w -

  • WapHandler : WapHandler, HttpWapMgr
  • WapProfileMgr : WapProfile
  • WbxmlParserRel : WbxmlParserRel, DrmRelParser
  • Window : Window, Control
  • WindowHierarchyIterator : WindowHierarchyIterator, WindowManager
  • WorkerTaskObtainer : GenericWorkerTask
  • Writer : ObexBuffer::Writer, ObexBuffer
  • WString : WString, InternalTracer, String
Generated on Wed Jan 25 00:54:35 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Related Functions

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- x -

  • XmlParserRel : XmlParserRel, DrmRelParser
Generated on Wed Jan 25 00:54:36 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Typedefs

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v

- a -

  • AcceptCb : SioSocketAdapter
  • AccessoryList : AudioDeviceManager, AudioAccessoryStore
  • AdrType : VCard
  • AllocateFunction : HeapVector
  • AudioChannelId : CodecDevice
  • AudResource : DwdDevice
  • AudReturnCode : AudioVibratorDevice, AudioError
  • AuthType : PsdDataConnProfile

- b -

  • BalanceLevel : AudioReference
  • Base : IpAddrPrompt, SerDataConnProvider, PsdDataConnProvider, NumberPrompt, IpAddrPrompt, DataConnWin, DataConnTypeWin, DataConnProvider, DataConnOptionWin, CsdDataConnProvider, CalendarProvider, PhonebookWin, PbSortedProvider, PbSimProvider, PbSelectNumberWin, PbRecordProvider, PbNumberProvider, PbNameProvider, PbNameNumberProvider, PbNameFilterProvider, PbBaseWin, PbCallAction, GroupProvider, BasicPbWin, ObexServerPort, ObexServerDispatcher, ObexServer, ObexObjectData, ObexClientPort, ObexClientDispatcher, ObexClient, ObexServerAddr, ObexClientAddr, ObexAddress, SimpleAppContext, SimpleScheduler, AppContext, Scheduler, AppContext, Scheduler, CharInputMapItem, KeyUpInputMapItem, KeyDownInputMapItem, IrdaObexTransport, IrdaObexServerAddr, IrdaObexClientAddr, IrdaTransport, TextPack, ProgressBar, FontPack, AbstractTransport, TRadioButtonItem< Content >, RadioButtonModel, IconValueIndicator, Grid, TestSoftkeyBarView, TestRadioButtonView, TestCheckBoxView, BlueSkySoftkeyBarView, BlueSkyRadioButtonView, BlueSkyPushButtonView, BlueSkyCheckBoxView, EditBox, EditBoxPagingTimer, CheckBoxModel, Animation, AnimationView, EditBoxBlinkTimer, AbstractEditBoxModel, SortProvider, RegBlobObject, QuickSortProvider, FindProvider, Find2Provider, GreaterRule, LessRule, RangeRule, NotEqualsRule, EqualsRule, FilterProvider, DistinctProvider, DistinctRule, DateTime, ChineseQuickSortProvider, CachingSortProvider, BubbleSortProvider, BlobPtr, BlobObject, AbstractDelegationProvider, StreamAudioPlayer, ImgObtObj, FeatureItemContainer, ContextFeatureItem, PowerHandler, ExtPsdContextListenerImpl_SerialTerminalListener, SmsCommand, SmsStatusReport, SmsSubmit, SmsDeliver, SimItemId, Zi8StrokeBox, Zi8SelectionBox, Zi8AlphabetBox, WbxmlVector< T >, T9PinyinBox, StrokeBox, SelectionBox, SocketSerialTerminalListener, SerialTerminalSocket, MmCallSerialTerminalListener, MolrRepeatInfo, StatusProvider, SstProvider, SmsMsgWaitingProvider, SmsCountProvider, SmsProvider, SmsParamProvider, SimTkMainMenuProvider, PrefPlmnProvider, PrefLangProvider, PrefExtLangProvider, PlmnProvider, PbBaseProvider, MbiProvider, LockProvider, EccProvider, DataControl, DataHandler, CphsServPflProvider, CphsAuxProvider, CountryProvider, CmiProvider, ChvProvider, CbmiRangeProvider, CbmiProvider, AuxProvider
  • BitmapPtr : ImageBox, Image
  • BitmapResArray : IconValueIndicator
  • BootSequenceState : SubSystemManager, SubSystem
  • BtBipAttachmentFormatList : BtBipImagingCapabilities
  • BtBipAttachmentList : BtBipImageProperties
  • BtBipImageFormatList : BtBipImagingCapabilities
  • BtBipVariantList : BtBipImageProperties
  • BufferByteType : StreamAudioReference
  • BufferType : StreamAudioReference
  • BufPtr : BinData

- c -

  • CacheArray : SmsWStringCache
  • CallbackFn : ContextExecuteMsg
  • CallBackFn : SystemTimer
  • Cb_FrameCaptured : VideoCamera
  • Cb_ImageEncoded : ImageEncoder
  • Cb_NotifyCaptureBufferStatus : VideoCamera
  • Cb_VideoCapturePaused : VideoCamera
  • Cb_VideoCaptureStopped : VideoCamera
  • CbCaptureFinished : StillCamera
  • CbFrameDecoded : VideoDecoder, AudioDecoder
  • CbFrameEncoded : AudioEncoder
  • CbImageCaptured : StillCamera
  • CbImageEncoded : StillCamera
  • CbInBufferFree : VideoDecoder
  • CBitmapResPtr : AnimationBmpPointerArrayIterator
  • CbReady : AudioDecoderRenderer, AudioCapturerEncoder
  • CbResult : VideoChannel, CodecDevice
  • CbResultAndTimeInfo : CodecDevice
  • CbVideoFrameEncoded : VideoEncoder
  • CbVideoFrameRendered : VideoChannel
  • ChannelNumber : AudioReference
  • ClientPortPtr : ObexClientDispatcher
  • ConnectedAccessoriesType : AudioAccessoryDetails
  • ConstBufferType : StreamAudioReference
  • ConstDataPtr : ObexBuffer
  • ConstIterator : ObexHeaderList::ConstIterator, Vector< T >
  • ConstReference : Vector< T >
  • ConstReverseIterator : Vector< T >
  • ContextId : HeapVector

- d -

  • DataConnCtrlCb : DataConn
  • DataPtr : ObexBuffer
  • DataUnits : PdpContext
  • DbgOutContextFunction : HeapVector
  • DbgOutFunction : HeapVector
  • DefaultAmplitude : CustomToneAudioReference
  • DifferenceType : Vector< T >, WbxmlVector< T >
  • DwdHandleType : DwdDevice
  • DwdIDType : DwdDevice

- e -

  • ElemType : CArray< T >
  • enumConstants : T9InputMapper
  • ExecFn : Action

- f -

  • Feature : SimTkProfile, Feature, AudioDeviceBase, FeatureBroker
  • FeaturePoolF : FeaturePool
  • FolderListingEntryProperties : ObexFtpServer
  • FolderListingEntryProps : ObexFtpDataServer
  • FreeFunction : HeapVector

- g -

  • GetAudioBufferFunction : StreamAudioReference
  • GetStatsFunction : HeapVector

- h -

  • HookFn : SingleArgHook< T >

- i -

  • Id : InputMapper, Message, BtBipServerNotificationMsgArg, HandlerListEntry, HandlerData, StackMsgArgument, NetAdapter, PdpContext
  • ImageList : BtBipImageList
  • IndicatorPosition : Indicator
  • InitializeFunction : HeapVector
  • IrdaParams : SioSocketAdapter
  • IsFreePageFunction : HeapVector
  • iterator : WbxmlVector< T >

- k -

  • Key : KeyMsgGenerator::Key, PhoneNumber

- l -

  • LwipPppConnSetupDone : SysSocket

- m -

  • Mobile2PCMsg : RegEncoderDecoder
  • MonoStereoType : StreamAudioReference

- n -

  • NetAdapterHandlerCallback : NetAdapterHandler
  • NetAdapterPtr : NetAdapterHandler
  • NsApi : PdpContext

- o -

  • ObjectId : ObexAbstractTransport
  • ObserverPtr : ObservableObject
  • Offset : ObexBuffer
  • OnAudioMessageCallback : AudioDeviceManager
  • OptionType : SysSocketBase, InetSocket
  • OverwriteCheckFunction : HeapVector

- p -

  • Pair : SimpleMap< TKey, TValue >
  • ParameterLimits : Camera
  • ParamPairList : HttpRequest
  • PC2MobileMsg : RegEncoderDecoder
  • Persist : PathProfile::Persist, IpAddr
  • PostMsgHook : MessageRouter
  • PostMsgHookFn : MessageRouter
  • PresetList : AudioPresetStore
  • PresetToneType : AudioPreset, AudioPresetStore
  • PriorityGroupType : AudioReference
  • PriorityType : AudioReference
  • Protocol : PdpContext, SysSocket
  • PtrT : FixedPtrArray< T >

- q -

  • QosDelay : PsdDataConnProfile
  • QosMeanRate : PsdDataConnProfile
  • QosPeakRate : PsdDataConnProfile
  • QosPrecedence : PsdDataConnProfile
  • QosReliability : PsdDataConnProfile

- r -

  • ReAllocateFunction : HeapVector
  • Reference : Vector< T >
  • Response : RegEncoderDecoder
  • reverse_iterator : WbxmlVector< T >
  • ReverseIterator : Pathname::ReverseIterator, Vector< T >
  • RtcEventCallbackFn : RtcSignalProcessor

- s -

  • SampleRateType : StreamAudioReference
  • ServerPortPtr : ObexServerDispatcher
  • ServiceList : ServiceBroker
  • ServiceType : BtObexServiceTable
  • SetUpMsg : RegEncoderDecoder
  • SimpleCb : SioSocketAdapter
  • Size : IconState, HeapVector::VarPage, HeapVector::BlockPage, Size, CArray< T >, ObexBuffer, File::Attributes
  • SizeFunction : HeapVector
  • SizeType : GuiObjectFactory, Vector< T >, WbxmlVector< T >
  • SocketHdl : SysSocket
  • SocketId : SioSocketAdapter
  • SoundDataSource : AudioReference
  • SourceType : AudioDeviceManager
  • StreamingCallback : StreamingCallback, File
  • SuspendSlotType : DwdPlayer

- t -

  • t9_language : T9InputMapper
  • TelType : VCard
  • TextAttr : TextFormat
  • ThisType : Allocator< T >
  • TimestampMSec : CodecDevice
  • ToneID : PresetAudioReference, AudioPresetStore, AudioPreset
  • ToneLevel : AudioReference
  • TypeId : BtJsr82Url::Token, ObexProtocol

- u -

  • Uint8BufPtr : BinData
  • UriAndPayload : RegEncoderDecoder

- v -

  • ValueType : Vector< T >
  • VolumeLevel : AudioReference, AudioDeviceBase, AudioActiveReference
Generated on Wed Jan 25 00:54:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • A : T_PB_CLIENT_FLAGS, T_PB_REF_FILE_FILL_STATUS, T_PB_REF_FILE_FILL_STATUS_A, T_PB_UNIQUE_FILE_FILL_STATUS, T_PB_GROUPING, T_PB_REFERENCE, T_PB_GROUP_NUMBER, T_PB_FILE_A, T_PB_UNIQUE_FILE, T_PB_FILE_IN_SLICE, ChannelDataArray, LsaIdentifierArray, TimeZoneAndTime
  • a : T_PB_REF_FILE
  • aas : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • acc_burst_type : GprsParam
  • acc_thr : GprsParam
  • acceptance_outcome : AudioMapiManager::RequestOutcomeType
  • access_control_class : CellParam
  • ack_blocks : AckNackCnt
  • ack_nack_testparam_cnt_array : AckNackParamList
  • action : CallEvent, SecLockCommand
  • add_info : SimInfo
  • address : Subaddress
  • adn : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • adn_core : T_PB_RECORD, T_PB_CHANGED_FIELD
  • adn_size : PhoneBookInfo
  • adn_tagsize : PhoneBookInfo
  • alphaid : UsimEccRecord, CmiRecord
  • alphaidlength : CmiRecord
  • always_editable : DataConnApp::EditableSettingTable
  • amplifier : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • anr : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • anr_ref : T_PB_REF_RECORD
  • apdu : SimApduData
  • app : StartUp::Table, AtlApplicationPluginStartup::Table
  • app_cont_idx : StartUp::Table
  • app_menu_id : SoftkeyDescTableEntry
  • appId : InternalTracer::TraceHeader
  • application_id : MenuPool::FeatureItemContainerContentTableEntry
  • archive_ascending_order : SmsSettingsRecord::Persist
  • archive_sorting_colid : SmsSettingsRecord::Persist
  • arfcn : CellParam, NeighbourCell
  • arfcn_ded : CellParam
  • arg_id : StackMsgArgMap< T >
  • args : MmiSimMsg
  • array : TestWriter
  • array_size : NvRamBlockInfo
  • as_error_code : RrcParam, AsTestparamDatabase
  • AtResponseIterator : AtResponseIterator, AtResponse, AtResponseParameter
  • attempts_left : ChvData
  • attribute : BtAttributeId
  • attribute_range : BtAttributeId
  • audio_at_phone : BtHfRecord::Persist
  • audio_vm_mode : VoiceMemoAudioDevice::StartParam
  • autostore : SmsSettingsRecord::Persist
  • available : Subaddress
Generated on Wed Jan 25 00:54:31 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- j -

  • jar_bin_data : JarBinDataStatusInfo, BinDataInReadStatusInfo
  • jar_file_handle : JarFileStatusInfo, FileInReadStatusInfo
  • jar_file_id : JarFileStatusInfo
  • jar_file_name : JarFileStatusInfo, FileInReadStatusInfo
  • jb : JmpBuf
  • jb_std : JmpBuf
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • key : DtmfStartCnfArg
  • key_code : KeymapTableEntry
  • key_tone : KeyToneAudioDevice::StartParam
  • keycode : PagingMapEntry
  • keymap : ContextTableEntry
  • keymap_type : KeymapTableEntry
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • l1_data : RrcParam
  • l_type : T_PB_FILE_DESC
  • label : HomezoneText
  • lac : CellParam, NeighbourCell, Lai, UmtsRrcScellParam
  • lang_id : Locale::LocaleData
  • lang_name : LanguageCodeTableEntry
  • language : tagTextPack
  • last_used : T_PB_STATE
  • lastused : SmsStatus
  • latency_ms : RtStreamingEndPoint::BufferInfo
  • lc_fw_vers : BtChipBmscr
  • ldb_id : tagLdbData
  • ldb_size : tagLdbData
  • len_rec : T_PB_FILE_DESC
  • length : Led::Stream, BtObexServiceTable::ObexTarget, ChannelData_s, SiText_s, TAlphaIdentifier_s, TSiUrl_s, UsimEccRecord, SimApduData, EccArray, SmsParamRecord, CiTestParamList, EquivPlmnLists, AckNackParamList, COverIList, BlerTrchInfoList, LsaIdentifier, HomezoneText
  • level : MdhWaitIndicator
  • levels : BidiManager::ParagraphContext
  • limited_service : RrParam, AsTestparamDatabase, UmtsRrcScellParam
  • line2_voicebox_number : SmsSettingsRecord::Persist
  • line_no : SerialIoAdapter::SioErrorDesc
  • lm_fw_vers : BtChipBmscr
  • lnd_size : PhoneBookInfo
  • lnd_tagsize : PhoneBookInfo
  • local_id : FfsDrmAttrib, ffs_drm_attrib_type
  • lock_cause : SecLockStates
  • lock_dcp_sup : SecLockDescriptor
  • lock_order : SecLockDescriptor
  • lock_owner_id : LockTableEntry
  • lock_result : SecLockStates, SecLockDescriptor
  • lock_retrial_count : SecLockDescriptor
  • lock_retrial_method : SecLockDescriptor
  • lock_status : SecLockDescriptor
  • lock_time : SecLockDescriptor
  • lock_type : SecLockDescriptor
  • locked_object_uri : LockTableEntry
  • locks : SecLockStates
  • longFileName : HostIterStatType, FatFindData, dstat
  • low : CbmiRange
  • lowercase : PagingMapEntry
  • lsa_id : LsaIdentifier
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • m_a : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit
  • m_above_level_y_offset : ThaiTextRenderer::ThaiFontHint
  • m_abstract_view : Component
  • m_accessory : AudioDeviceManager
  • m_accessory_id : AudioAccessoryDetails
  • m_accessory_list : AudioAccessoryStore
  • m_account : DataConnProfile::Persist
  • m_active : VibratorDevice, AudioAccessoryDetails
  • m_active_ref : MmfPlayer::MediaPlayerInstanceData, AudioVibratorDevice
  • m_active_reference : SimpleAudioDevice
  • m_actual_height : CodecDevice::VideoDecoderParameters, CodecDevice::VideoEncoderParameters, CodecDevice::VideoStreamInfo
  • m_actual_name : AudioAccessoryDetails
  • m_actual_width : CodecDevice::VideoDecoderParameters, CodecDevice::VideoEncoderParameters, CodecDevice::VideoStreamInfo
  • m_add_word_to_dict_win : AbstractPredictiveInputBox
  • m_additional_info : RegEncoderDecoder::Response
  • m_addr_msg : ObexAbstractPort::AddressEvent
  • m_address : PdpContext::PacketFilter::AddressAndMask
  • m_addressOut : UdpTestSocket
  • m_adn_maxrecs : SimPbBaseHandler
  • m_adn_tagsize : SimPbBaseHandler
  • m_album : GenericFeatureData::GenericTrackInfo
  • m_alloc_fct : HeapVector::FctTable
  • m_allocations : HeapVector::Stats
  • m_alpha_bit_count : ColorSegmentation
  • m_altitude : ReferenceLocation, LcsPointAltitudeUncertEllipsoid
  • m_anchor : LinkedListBase
  • m_anim : EmsResourceMaps::AnimNode
  • m_apn : PsdDataConnProfile::Persist
  • m_apoxi_tone_id : AudioPreset
  • m_app : SocketTestApp, AbstractAppContext, Feature, AtlApplicationPlugin, CbsFilterList::CbsFilterListEntry, MolrInfo
  • m_app_id : AppFeatureID
  • m_appcntxt_list : AbstractScheduler
  • m_appDescription : HttpApplication
  • m_appId : HttpApplication
  • m_application_categories : CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_application_category : CodecDevice::VideoEncoderParameters
  • m_appList : HttpApplicationSupplier
  • m_appName : HttpApplication
  • m_array_of_supported_codecs : CodecDevice::Properties, CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_arrow_next : CameraViewFinderWin
  • m_arrow_prev : CameraViewFinderWin
  • m_artist : GenericFeatureData::GenericTrackInfo
  • m_audio_codec : CodecDevice::AudioDecoderParameters
  • m_auth_pwd : WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
  • m_auth_set_id : WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
  • m_auth_type : PsdDataConnProfile::Bit
  • m_auth_user_name : WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
  • m_author : GenericFeatureData::GenericTrackInfo
  • m_authProvider : Server
  • m_auto_release : GenericAudioDevice
  • m_azimuth : SatelliteInfo
  • m_b : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit
  • m_background_color : PngDecoder
  • m_background_specified : PngDecoder
  • m_backlog : ServerConfig, Server
  • m_backup_file_id : InteriorNodeRecord
  • m_base : HeapVector::Page
  • m_base_huge : HeapVector::VarPage
  • m_baud_rate : NmeaUartSettings
  • m_bcd_number : PhoneNumber
  • m_bdn_maxrecs : SimPbBaseHandler
  • m_bdn_tagsize : SimPbBaseHandler
  • m_begin : MessageIdentifierContainer::MessageIdentifierPair
  • m_bin_data : NonsharedBinDataDataSource, BinDataDataSource, MmfPlayer::MediaPlayerInstanceData
  • m_bin_data_provided : MmfPlayer::MediaPlayerInstanceData
  • m_bit : PsdDataConnProfile::Persist, DataConnProfile::Persist, CsdDataConnProfile::Persist
  • m_bit_allocation_method : CodecDevice::AudioEncoderParameters
  • m_bit_depth : PngDecoder
  • m_bit_pool : CodecDevice::AudioEncoderParameters
  • m_bit_rate : VideoEncoder::VideoEncoderDynParameters, CodecDevice::VideoEncoderParameters
  • m_bitfield : TpduHeaderInformation
  • m_bitrate : MediaInfo::MediaTrackInfo
  • m_bits : PbNumberRecord::Persist, PbRecord::Persist, HeapVector::BlockPage, BitmapRes, SvgImage
  • m_bkgd_blue : PngDecoder
  • m_bkgd_green : PngDecoder
  • m_bkgd_red : PngDecoder
  • m_block_len : CodecDevice::AudioEncoderParameters
  • m_block_size : BlockData
  • m_blockcounter : HeapVector::BlockPage
  • m_blocksize : HeapVector::Page
  • m_blue_bit_count : ColorSegmentation
  • m_bmps : SmsSendingAnimation
  • m_body : HttpResponse, HttpRequest
  • m_boolean : AbstractDevice::ControlArg
  • m_bottom : Rect
  • m_bound_num : MultiPartData
  • m_bReportSent : SocketTestTests::TestGroupInfo
  • m_brightness_level : Camera
  • m_bTestEnabled : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_buf_size : DataSourceRtStreamingSource
  • m_buffer : NetAdapter::DataReceivedEventArgs, StreamAudioReference, CustomRingerAudioReference, CodecDevice::AudioIOBuffer, OplEntry
  • m_buffer_left : MimeCoder
  • m_buffer_len : CodecDevice::AudioIOBuffer
  • m_buffer_length : MimeCoder
  • m_buffer_ptr : MimeCoder
  • m_buffer_size : StreamAudioReference, CustomRingerAudioReference
  • m_buffers : AtiAudioPlayerRtStreamingSink
  • m_bufsize : WStrData, StrData
  • m_build_date : VersionInfo::Data
  • m_c : LittleEndian32Bit, BigEndian32Bit
  • m_cache_pos : TpduHeaderInformation
  • m_call_type : CsdDataConnProfile::Bit
  • m_cam_win32 : Camera
  • m_camera : CameraCaptureWin
  • m_camera_capture_canceling : CameraCaptureWin
  • m_cancel_editbox_action : PbDetails
  • m_caption_gap : AbstractEditBoxView
  • m_caption_height : AbstractEditBoxView
  • m_caption_width : AbstractEditBoxView
  • m_capture_image_size : Camera
  • m_caret : InputMapper
  • m_case_sensitive : NamePatternFileFilter
  • m_category : EccNetworkElement
  • m_cb_stop : MapiAudioPlayer
  • m_channel : TimeFeatureObject
  • m_channel_mode : CodecDevice::AudioEncoderParameters
  • m_channelVolume : CustomSmafPhraseAudioReference
  • m_char : CharInputMapEntry
  • m_char_ptr : AbstractDevice::ControlArg
  • m_child_key_id : MergeProvider
  • m_chunk_operator : File::FileState
  • m_chunk_size : File::FileState
  • m_client : IncrementalPdcUpdater
  • m_client_discovery_poll_repeat_counter : IrdaObexTransport
  • m_client_id : ClientInfo, ClientId, MolrInfo
  • m_client_name : ClientInfo, ClientName
  • m_clientId : ServerClient, FtpTransfer, FtpDataSocket
  • m_clients : Server
  • m_clienttimer : IrdaObexTransport
  • m_clock_support : CodecDevice::VideoDecoderInfo
  • m_codec_type : MediaInfo::MediaTrackInfo, CodecDevice::AudioStreamInfo
  • m_coding_group : TpduHeaderInformation
  • m_color_count : ColorTable
  • m_color_type : PngDecoder
  • m_column : FindProvider
  • m_columnid : SortProvider
  • m_columninfo : Provider
  • m_combined_device : CodecDevice::Properties
  • m_command_type : AtCommandData, AtCommandMetaInfo
  • m_comment : GenericFeatureData::GenericTrackInfo
  • m_commit_cmi_no : PbBaseProvider
  • m_commit_phonenumber : PbBaseProvider
  • m_commit_string : PbBaseProvider
  • m_compat_setting : AudioAccessoryDetails
  • m_composer : IMelodyData, GenericFeatureData::GenericTrackInfo
  • m_conc_max_no : TpduHeaderInformation
  • m_conc_num : TpduHeaderInformation
  • m_conc_ref_no : TpduHeaderInformation
  • m_conc_seq_no : TpduHeaderInformation
  • m_concateneted_status : TpduHeaderInformation
  • m_confidence : LcsArc, LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse
  • m_confirm_edit_action : PbDetails
  • m_conn_id_free_Slot : HttpWapMgr
  • m_connect_cnf_cb : SioSocketAdapter::SioSocketCallbacks
  • m_connect_ind_cb : SioSocketAdapter::SioSocketCallbacks
  • m_connected : HttpSocket
  • m_connection_list_mutex : BtMultiConnectionController
  • m_cons_offsets : ThaiTextRenderer::ThaiFontHint
  • m_cont : AbstractScheduler
  • m_content : DrmMediaObject
  • m_content_len : MultiPartData, DrmMediaObject
  • m_content_offset : MultiPartData
  • m_content_type : DrmMediaObject
  • m_context : Timer
  • m_context_active : PsdDataConn
  • m_context_defined : PsdDataConn
  • m_context_id : PropertyDescriptor
  • m_contrast_level : Camera
  • m_copyright : GenericFeatureData::GenericTrackInfo
  • m_cphs_infono_maxrecs : SimPbBaseHandler
  • m_cphs_infono_tagsize : SimPbBaseHandler
  • m_cphs_mbox_maxrecs : SimPbBaseHandler
  • m_cphs_mbox_tagsize : SimPbBaseHandler
  • m_CsdDownloadSettings : SocketTestT5
  • m_ct_cap : SyncMLDataStoreProps
  • m_ct_cap_count : SyncMLDataStoreProps
  • m_ct_type : SyncMLCTCap, SyncMLCTTypeVerCT
  • m_cur_buffer_returned : DataSourceRtStreamingSource
  • m_cur_dev_pathname : RootDirectoryIteratorImp
  • m_cur_device : RootDirectoryIteratorImp
  • m_cur_device_id : StorageDeviceIterator
  • m_cur_dir_itor : RootDirectoryIteratorImp
  • m_cur_file_offset : DataSourceRtStreamingSource
  • m_cur_file_pos : File::FileState
  • m_cur_path : DirectoryIterator
  • m_cur_src : DataSourceRtStreamingSource
  • m_current : HeapVector::Stats
  • m_current_calendar_record : CalendarProvider
  • m_current_camera_idx : CameraCaptureWin
  • m_current_virtual_size : HeapVector::HeapTableEntry
  • m_currentState : StateMachine
  • m_d : LittleEndian32Bit, BigEndian32Bit
  • m_da : SimSmsParameter::Record
  • m_data : ToDoRecord, FmRadioStationsRecord, FmRadioSettingsRecord, SmsSettingsRecord, CalendarRecord, BtHfRecord, PbNumberRecord, PbRecord, Glyph, DataPack, BtSddbDeOneByteDescriptionType, BlobPtr, SimPhoneBookEntry, SvgImage, PngImage, PngDecoder, JpegImage, TpduPhoneNumberPersist
  • m_data1 : ResultWinBase, DateTime::Persist
  • m_data2 : ResultWinBase, DateTime::Persist
  • m_data3 : ResultWinBase, DateTime::Persist
  • m_data4 : ResultWinBase
  • m_data_available_ind_cb : SioSocketAdapter::SioSocketCallbacks
  • m_data_bits : NmeaUartSettings
  • m_data_compr : PsdDataConnProfile::Bit
  • m_data_idx : PngDecoder
  • m_data_in_buffer : FtpDataSocket
  • m_data_len : NetAdapter::DataReceivedEventArgs, NetAdapter::DataSentEventArgs
  • m_data_offset : StreamAudioReference
  • m_data_out_buffer : FtpDataSocket
  • m_data_owned : CustomRingerAudioReference
  • m_data_ptr : AtGenericCmdType
  • m_data_rate : CsdDataConnProfile::Bit
  • m_data_sent : ClientNetAdapter
  • m_data_source : DataSourceBinData
  • m_data_type : SyncMLCTValueDef
  • m_dataConnProfileId : ServerConfig
  • m_dataitem : RegEncoderDecoder::Payload
  • m_date_is_valid : CalendarProvider
  • m_datetime : TpduHeaderInformation
  • m_day : DateTime::Persist, Date, Date::Persist, UtcTime
  • m_dbgout_context_fct : HeapVector::FctTable
  • m_dbgout_fct : HeapVector::FctTable
  • m_dc_err : CsdDataConn
  • m_dch_err : CsdDataConn
  • m_dcs : SimSmsParameter::Record, TpduHeaderInformation
  • m_decoder : SvgImage
  • m_def_profile : DataConnProfileStorage::Header
  • m_delay : StreamAudioPlayer
  • m_delete_record : CalendarProvider
  • m_delta : SvgImage
  • m_description : GenericFeatureData::GenericTrackInfo
  • m_descriptor : Property
  • m_detail_listbox : PbDetails
  • m_dev_itor : RootDirectoryIteratorImp
  • m_device : HostFatFsDeviceDescriptor
  • m_device_id : HostFatFsDeviceDescriptor
  • m_device_list_node : BtDeviceList::BtDeviceListBidirectionalIterator
  • m_device_vibrator : AudioDeviceManager
  • m_diacritics_offsets : ThaiTextRenderer::ThaiFontHint
  • m_dir_itor_ptr : RfsObexFtpServer
  • m_dir_pathname : DirectoryIterator
  • m_direction : CodecDevice::Properties
  • m_dirty_flag : RegDirtyFile
  • m_disconnect_ind_cb : SioSocketAdapter::SioSocketCallbacks
  • m_disconnect_on_complete : FtpTransfer
  • m_display_name : SyncMLDataStoreProps, SyncMLCTValueDef
  • m_domain : WapProfile::PxLogicalCharacs
  • m_downlinkPath : AudioAccessoryDetails
  • m_drm_asset : DataSource, DataSink
  • m_duration : KeyUpInputMapEntry, GenericFeatureData::GenericTrackInfo, MediaInfo::MediaTrackInfo
  • m_dwd_handle : DwdDevice
  • m_ecnr_state : AudioDeviceManager
  • m_edit_detail_action : PbDetails
  • m_editbox : PbDetails
  • m_editor : AbstractPredictiveInputBox
  • m_elem : MediaRefLinkable
  • m_elements : EccNetworkArray
  • m_elevation : SatelliteInfo
  • m_email : PbRecord::Persist
  • m_enable_ecnr : AudioAccessoryDetails
  • m_enabled : SimpleAudioDevice
  • m_end : HeapVector::Page, MessageIdentifierContainer::MessageIdentifierPair
  • m_end_block_num : BlockData
  • m_end_huge : HeapVector::VarPage
  • m_endianess : RegEncoderDecoder::SetUpMsg
  • m_error_code : AudioPlayerEvent
  • m_exist_da : SimSmsParameter::Record
  • m_exist_dcs : SimSmsParameter::Record
  • m_exist_name : SimSmsParameter::Record
  • m_exist_protid : SimSmsParameter::Record
  • m_exist_sca : SimSmsParameter::Record
  • m_exist_vp : SimSmsParameter::Record
  • m_exponent : SignedValue, UnsignedValue
  • m_exposure_level : Camera
  • m_ext_height : CodecDevice::VideoStreamInfo
  • m_ext_punc_win : AbstractPredictiveInputBox
  • m_ext_width : CodecDevice::VideoStreamInfo
  • m_extended_data : TpduHeaderInformation
  • m_fct_table : HeapVector::Page
  • m_fdn_maxrecs : SimPbBaseHandler
  • m_fdn_tagsize : SimPbBaseHandler
  • m_feature : FeatureItem
  • m_feature_id : Feature, AppFeatureID
  • m_featureID : FeatureHandle
  • m_field : UsimPbChangedField
  • m_file : FfsDataConnProfileStorage, FileDataSource, FileDataSink, FileBinData, HttpResponse, FtpTransfer
  • m_file_handle : StreamAudioReference
  • m_file_header : RegNodeFileHeader, RegDirtyFile
  • m_file_id : InteriorNodeRecord, Transaction
  • m_File_Sink_Array : CameraCaptureWin
  • m_file_type : RegFileHeader
  • m_filesize : UsimFileProperty, FtpTransfer
  • m_filetype : UsimFileProperty
  • m_fill_semaphore : DataSourceRtStreamingSource
  • m_filter : CbsFilterList::CbsFilterListEntry, StorageDeviceVisitor, StorageDeviceIterator, FileVisitor, DirectoryIterator
  • m_filter_dirs : SoundFileFilter, ImageFileFilter, NamePatternFileFilter
  • m_FindRow : FindProvider
  • m_fix_data : LocationEstimate
  • m_flag : InteriorNodeRecord
  • m_flags : VersionInfo::Data, BitmapRes
  • m_flash : Camera
  • m_flash_stored : TpduHeaderInformation
  • m_flow_control : NmeaUartSettings
  • m_font : AbstractTextRenderer
  • m_format : IMelodyData, StreamAudioReference, CustomRingerAudioReference, SyncMLItemMetaInfo, CodecDevice::AudioDecoderParameters
  • m_frame : ImageMetaDataRecord
  • m_frame_count : EmsResourceMaps::AnimNode
  • m_frame_rate_denominator : VideoEncoder::VideoEncoderDynParameters, CodecDevice::VideoEncoderParameters, CodecDevice::VideoStreamInfo
  • m_frame_rate_numerator : VideoEncoder::VideoEncoderDynParameters, CodecDevice::VideoEncoderParameters, CodecDevice::VideoStreamInfo
  • m_frame_size : AbstractEditBoxView
  • m_frames : SvgImage
  • m_free : DataConnProfileStorage::Header, HeapVector::VarPage, HeapVector::BlockPage
  • m_free_chars : EmsCreator::SpaceInfo
  • m_free_fct : HeapVector::FctTable
  • m_free_id : SyncMLDynamicProps
  • m_free_mem : SyncMLDynamicProps
  • m_frees : HeapVector::Stats
  • m_frequency : RadioAudioDevice::StationInfo
  • m_ftpInTransfer : FtpDataSocket
  • m_ftpOutTransfer : FtpDataSocket
  • m_ftpSocket : FtpTransfer, FtpDataSocket
  • m_genre : GenericFeatureData::GenericTrackInfo
  • m_getstats_fct : HeapVector::FctTable
  • m_glyph_count : GlyphIndexTab
  • m_glyph_tab : GlyphIndexTab
  • m_gps_tow : GpsFixDataInt, ReferenceTime, GpsFixData
  • m_gps_week : GpsFixDataInt, ReferenceTime, GpsFixData
  • m_green_bit_count : ColorSegmentation
  • m_groups : UsimPbGroups
  • m_handle : AudioPlayerEvent
  • m_handler : CalendarProvider, NetAdapter, PbBaseProvider
  • m_has_audio : StreamAudioReference
  • m_has_native_alpha_channel : PngDecoder
  • m_hdop : GpsFixDataInt, GpsFixData
  • m_header : MultiPartData, DrmDcfHeader
  • m_header_compr : PsdDataConnProfile::Bit
  • m_headers : HttpResponse, HttpRequest
  • m_heap_id : HeapVector::HeapTableEntry
  • m_height : ImageMetaDataRecord, BitmapRes, PngDecoder
  • m_high : HeapVector::Page
  • m_horiz_accuracy : LcsMmiQos, LcsQos
  • m_hour : Time::Persist, DateTime::Persist, UtcTime
  • m_http_plugin : HttpWapMgr
  • m_http_wap_plugin : HttpWapMgrPlugin
  • m_httpVersion : HttpRequest
  • m_huge_mem : PngDecoder
  • m_hw_handle : GenericAudioDevice
  • m_icon : TextIconPairArray::TextIconPair
  • m_id : NetAdapter, DataConnProfile::Bit, BtObexSddbServiceObserverImpl, HandlerData, CodecDevice::AudioChannel
  • m_Id : PathProfile::Persist
  • m_idle_timeout : DataConnProfile::Bit
  • m_ignore_management : AudioPreset
  • m_image_size : Camera
  • m_in_buf_max_len : CodecDevice::VideoEncoderInfo
  • m_included_angle : LcsArc
  • m_index : MetaDataRecord
  • m_info_ptr : PngDecoder
  • m_init_fct : HeapVector::FctTable
  • m_initial_size : FileDataSink
  • m_inner_radius : LcsArc
  • m_input_map_control_id : InputMapEntry
  • m_input_map_id : InputMapEntry
  • m_input_sampling_frequency : CodecDevice::AudioEncoderParameters
  • m_Instance : AudioDeviceManager
  • m_instance : VibratorDevice, AudioPresetStore, AudioPlayerStore, AudioAccessoryStore
  • m_int16 : AbstractDevice::ControlArg
  • m_int32 : AbstractDevice::ControlArg
  • m_int8 : AbstractDevice::ControlArg
  • m_int_ref_no : TpduHeaderInformation
  • m_int_time : SatelliteInfo
  • m_interface_address : PppSetupCallBackData
  • m_interior_meta_data : RegEncoderDecoder::IteratorObjResult
  • m_interior_node_record : RegUriMapFile
  • m_interlace_type : PngDecoder
  • m_invoke_id : MtlrInfo, MolrRepeatInfo
  • m_ipGatewayAddr : SocketTestApp::menuItems
  • m_ipv4_address_and_mask : PdpContext::PacketFilter::AddressAndMask
  • m_ipv6_address_and_mask : PdpContext::PacketFilter::AddressAndMask
  • m_is_concateneted : TpduHeaderInformation
  • m_is_exclusive : HandlerData
  • m_is_in_use : ExtPsdContextListener_SerialTerminal, SerialTerminal
  • m_is_interlaced : PngImage
  • m_is_open : NonsharedBinDataDataSource, BinDataDataSource
  • m_is_registered_mutex : BtRequest
  • m_is_text : MimeCoder
  • m_is_transparent : PngDecoder
  • m_is_valid : DrmRightsMapTableEntry
  • m_isfree_fct : HeapVector::FctTable
  • m_ishuge : HeapVector::Page
  • m_iter_nodetype : RegEncoderDecoder::IteratorObjResult
  • m_iterator_obj : RegEncoderDecoder::IteratorObjResult
  • m_iterator_res_obj : RegEncoderDecoder::Payload
  • m_iterator_type : RegEncoderDecoder::IteratorObjResult
  • m_job_id_client : IrConnection
  • m_jpeg_image : CameraCaptureWin
  • m_key_code : KeyUpInputMapEntry, KeyDownInputMapEntry
  • m_label : PropertyDescriptor
  • m_label1 : ResultWinBase
  • m_label2 : ResultWinBase
  • m_label3 : ResultWinBase
  • m_label4 : ResultWinBase
  • m_last_buffer : CodecDevice::AudioIOBuffer
  • m_last_commited_transaction : RegDirtyFile
  • m_last_error : Camera, StorageDevice, File::FileState, DirectoryIterator, PngDecoder
  • m_last_id : DataConnProfileStorage::Header
  • m_last_loc_est : LcsProviderImplBase
  • m_last_unscaled_height_idx : PngImage
  • m_last_unscaled_width_idx : PngImage
  • m_latitude : ReferenceLocation, LcsPoint
  • m_lcs_qos : MolrInfo
  • m_lcs_timer : MtlrInfo
  • m_leaf_meta_data : RegEncoderDecoder::IteratorObjResult
  • m_left : Rect
  • m_left_offset : CodecDevice::VideoStreamInfo
  • m_len : WStrData, StrData
  • m_length : HeapVector::VarPage, BlobPtr, SimPhoneBookEntry, AtGenericCmdType
  • m_length_of_header_length_field : CodecDevice::VideoDecoderParameters
  • m_length_of_length_field : CodecDevice::VideoDecoderParameters
  • m_level : RadioAudioDevice::StationInfo
  • m_line_height : AbstractEditBoxView
  • m_line_length : MimeCoder
  • m_lines : TextListModel
  • m_linger_timeout : DataConnProfile::Bit
  • m_list_phy_port : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_list_port : WapProfile::PxLogicalCharacs
  • m_list_pxauthinfo : WapProfile::PxLogicalCharacs
  • m_list_pxphysical : WapProfile::PxLogicalCharacs
  • m_lnd_maxrecs : SimPbBaseHandler
  • m_lnd_tagsize : SimPbBaseHandler
  • m_lo_chula_y_offset : ThaiTextRenderer::ThaiFontHint
  • m_loc_error : GpsFixDataInt, GpsFixData
  • m_local : PsdDataConnProfile::Persist
  • m_local_id : DrmRightsMapTableEntry
  • m_location : CodecDevice::VideoEncoderInfo, CodecDevice::VideoDecoderInfo
  • m_location_info : UsimPbLocReport
  • m_location_method : MolrInfo
  • m_lock_id : RegEncoderDecoder::PC2MobileMsg::msg, RegAppWin
  • m_locked_by : HandlerData
  • m_lockinfo : RegEncoderDecoder::Payload
  • m_longci : PnnEntry
  • m_longitude : ReferenceLocation, LcsPoint
  • m_longname : PnnEntry
  • m_low : HeapVector::Page
  • m_low_byte : GlyphHeader
  • m_lru_count : RegMemoryBuffer
  • m_lst : LocationEstimate
  • m_mai_tho_toplevel_x_offset : ThaiTextRenderer::ThaiFontHint
  • m_mantissa : SignedValue, UnsignedValue
  • m_map_entry : CharInputMapEntry, KeyUpInputMapEntry, KeyDownInputMapEntry, InputMap
  • m_map_file_header : RegUriMapFile
  • m_mark : SyncMLItemMetaInfo
  • m_mark_delete : MetaDataRecord
  • m_master_mute : AudioDeviceManager
  • m_master_volume : AudioDeviceManager
  • m_max_bit_rate : CodecDevice::VideoDecoderParameters, CodecDevice::VideoCodecCapabilities, CodecDevice::VideoStreamInfo
  • m_max_blob_size : RegEncoderDecoder::SetUpMsg
  • m_max_cache_depth : MergeProvider
  • m_max_conc_ref_no : TpduHeaderInformation
  • m_max_delay : IncrementalPdcUpdater
  • m_max_frame_rate_denominator : CodecDevice::VideoCodecCapabilities
  • m_max_frame_rate_numerator : CodecDevice::VideoCodecCapabilities
  • m_max_guid_size : SyncMLDataStoreProps
  • m_max_height : CodecDevice::VideoCodecCapabilities
  • m_max_id : SyncMLDataStoreProps
  • m_max_mem : SyncMLDataStoreProps
  • m_max_message_size : RegEncoderDecoder::SetUpMsg
  • m_max_progress : MergeProvider
  • m_max_quality_level : CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_max_subunit_id : BtAvrcpSubunitInfoEntry
  • m_max_virtual_size : HeapVector::HeapTableEntry
  • m_max_width : CodecDevice::VideoCodecCapabilities
  • m_maxUsers : ServerConfig, Server
  • m_mbdn_maxrecs : SimPbBaseHandler
  • m_mbdn_tagsize : SimPbBaseHandler
  • m_media_player : MmfPlayer::MediaPlayerInstanceData
  • m_media_type : StreamAudioReference
  • m_memory : HeapVector::VarPage, HeapVector::BlockPage
  • m_merge_key_id : MergeProvider
  • m_merge_needed : MergeProvider
  • m_merge_provider : MergeProvider
  • m_merge_rule : MergeProvider
  • m_merged_rows : MergeProvider
  • m_metering_mode : Camera
  • m_microsec : GpsFixDataInt, GpsFixData
  • m_milli_sec : UtcTime
  • m_mime_to_source_to_players : AudioPlayerStore
  • m_min : UtcTime
  • m_min_bit_rate : CodecDevice::VideoCodecCapabilities
  • m_min_frame_rate_denominator : CodecDevice::VideoCodecCapabilities
  • m_min_frame_rate_numerator : CodecDevice::VideoCodecCapabilities
  • m_min_height : CodecDevice::VideoCodecCapabilities
  • m_min_progress : MergeProvider
  • m_min_quality_level : CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_min_width : CodecDevice::VideoCodecCapabilities
  • m_minute : Time::Persist, DateTime::Persist
  • m_mirrored : ImageBrowserApp
  • m_mlc_number : MlcNumber, MolrInfo
  • m_mode : StreamAudioReference, FtpDataSocket
  • m_molr_timer : LcsProviderImplBase
  • m_molr_type : MolrInfo
  • m_mono_stereo_mode : StreamAudioReference
  • m_month : DateTime::Persist, Date, Date::Persist, UtcTime
  • m_mpghead : Mp3Param
  • m_msg_class : TpduHeaderInformation
  • m_msg_id : RegEncoderDecoder::Mobile2PCMsg
  • m_msg_status : TpduHeaderInformation
  • m_msg_type : TpduHeaderInformation
  • m_msisdn_maxrecs : SimPbBaseHandler
  • m_msisdn_tagsize : SimPbBaseHandler
  • m_mtlr_app : LcsProviderImplBase
  • m_mute : AudioDeviceBase
  • m_N : HeapVector::Page
  • m_name : PbRecord::Persist, DataConnProfile::Persist, HeapVector::HeapTableEntry, IMelodyData, AudioPreset, RegNodeRecord, HeaderData, DrmDcfHeaderData, SimSmsParameter::Record
  • m_name_pattern : NamePatternStorageDeviceFilter, NamePatternFileFilter
  • m_name_recno : PbNumberRecord::Persist
  • m_nCSDid : SocketTestApp
  • m_nCurrentSocket : SocketTestT4
  • m_nDataSize : DownloadSettings
  • m_nDownloadTime : DownloadSettings
  • m_nErrorCode : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nGatewayPort : SocketTestApp::menuItems
  • m_nInternalStatus : SocketTestTests::TestGroupInfo
  • m_nIterationsDone : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nIterationsSuccessfull : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nIterationsTotal : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nlenIn : SocketTestT4
  • m_nMaxTCPPacketSize : SocketTestApp::menuItems
  • m_nMaxTCPSockets : SocketTestApp::menuItems
  • m_nMaxUDPPacketSize : SocketTestApp::menuItems
  • m_nMaxUDPSockets : SocketTestApp::menuItems
  • m_nMessageBody : TcpTestSocket
  • m_nMessagePos : TcpTestSocket
  • m_nMessageSize : UdpTestSocket, TcpTestSocket
  • m_nNrOfSubtests : SocketTestTests::TestGroupInfo
  • m_nNumberOfPackets : SocketTestT4, SocketTestT3
  • m_nNumberOfSockets : SocketTestT4, SocketTestT3
  • m_no_of_buffers : DataSourceRtStreamingSource
  • m_no_of_tones : CustomToneAudioReference
  • m_node_buffer : RegMemoryBuffer
  • m_node_count : RegFileHeader
  • m_node_name : InteriorNodeRecord
  • m_node_type : RegEncoderDecoder::RegIteratorNodeType
  • m_normalized_time : SvgImage
  • m_notif_type : MtlrInfo
  • m_notification_rule : Property
  • m_nPacketsCollected : UdpTestSocket, TcpTestSocket
  • m_nPacketSize : DownloadSettings
  • m_nPacketsReceived : UdpTestSocket, TcpTestSocket
  • m_nPSDid : SocketTestApp
  • m_nSERid : SocketTestApp
  • m_nServerDelay : DownloadSettings
  • m_nStartNumber : SocketTestT4
  • m_nStatus : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_nTestID : UdpTestSocket, TcpTestSocket
  • m_nTimeout : SocketTestApp::menuItems
  • m_null_str : WStrData, StrData
  • m_null_strbuf : WStrData, StrData
  • m_num_of_channels : CodecDevice::AudioStreamInfo
  • m_num_of_subbands : CodecDevice::AudioEncoderParameters
  • m_num_of_supported_codecs : CodecDevice::Properties, CodecDevice::AudioCodecCapabilities, CodecDevice::VideoCodecCapabilities
  • m_num_sats : GpsFixDataInt, GpsFixData
  • m_number : EccNetworkArray, EccNetworkElement
  • m_number_input_mode : PredInputMapper
  • m_number_of_params : AtCommandData
  • m_nWaitingForPackets : UdpTestSocket, TcpTestSocket
  • m_nWaitingForSockets : SocketTestT4
  • m_offset : GlyphHeader, NonsharedBinDataDataSource, BinDataDataSource, FtpTransfer
  • m_offset_angle : LcsArc
  • m_offset_node_payload : RegNodeRecord
  • m_on : VibratorDevice
  • m_on_off : SysSocketBase::LingerSetting
  • m_open_mode : File::FileState
  • m_order : SortProvider
  • m_orientation_angle : LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse
  • m_original_artist : GenericFeatureData::GenericTrackInfo
  • m_out_frame_length : CodecDevice::VideoStreamInfo
  • m_overflows : HeapVector::Stats
  • m_overhead : HeapVector::Stats
  • m_overwrite_existing_file : FileDataSink
  • m_overwritecheck_fct : HeapVector::FctTable
  • m_p_album : MediaInfo::ClipInfo
  • m_p_artist : MediaInfo::ClipInfo
  • m_p_author : MediaInfo::ClipInfo
  • m_p_comment : MediaInfo::ClipInfo
  • m_p_composer : MediaInfo::ClipInfo
  • m_p_copyright : MediaInfo::ClipInfo
  • m_p_description : MediaInfo::ClipInfo
  • m_p_duration : MediaInfo::ClipInfo
  • m_p_genre : MediaInfo::ClipInfo
  • m_p_original_artist : MediaInfo::ClipInfo
  • m_p_rating : MediaInfo::ClipInfo
  • m_p_song_name : MediaInfo::ClipInfo
  • m_p_title : MediaInfo::ClipInfo
  • m_p_track : MediaInfo::ClipInfo
  • m_p_url : MediaInfo::ClipInfo
  • m_p_year : MediaInfo::ClipInfo
  • m_page : HeapVector::Page
  • m_palette : ColorTable
  • m_param : SyncMLCTProp
  • m_param_count : SyncMLCTProp
  • m_param_name : SyncMLCTParam
  • m_parameters : AtCommandData
  • m_parent_file_id : InteriorNodeRecord
  • m_parity : NmeaUartSettings
  • m_passwd : DataConnProfile::Persist
  • m_passwd_query : DataConnProfile::Bit
  • m_path : MediaRefContainer, StreamAudioReference
  • m_paths_active : AudioAccessoryDetails
  • m_payload : RegEncoderDecoder::UriAndPayload, RegEncoderDecoder::Response
  • m_payload_bits : RegNodeRecord
  • m_payload_size : TpduHeaderInformation
  • m_payload_type : RegNodeRecord
  • m_pbinfo_initialized : SimPbBaseHandler
  • m_pcamera_app : CameraCaptureWin
  • m_pdp_context : PsdDataConn
  • m_pdp_error : PsdDataConn
  • m_pdu_count : EmsCreator::SpaceInfo
  • m_peak : HeapVector::Stats
  • m_PeriodTime : VibratorDevice
  • m_permissions : DrmInfoPersistStructure
  • m_persist : PhoneNumber::Persist
  • m_phnr : TpduHeaderInformation
  • m_phone_no : CsdDataConnProfile::Persist
  • m_phoneno_persist : PbNumberRecord::Persist
  • m_phy_domain : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_phy_proxy_id : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_phy_push_enabled : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_physical_set_id : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_playback_state : AudioPlayerEvent
  • m_player : AudioPlayerEvent
  • m_player_time_offset : SvgImage
  • m_plmn : UsimPlmn
  • m_plugin_name : AtlApplicationPlugin
  • m_pme : PagingMap
  • m_pMessage : SocketTestT4
  • m_png_ptr : PngDecoder
  • m_pobj : SharedPtr< T_obj >
  • m_point : LocationEstimate, LcsArc, LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse, LcsPointUncertCircle
  • m_port : WapProfile::PxLogicalCharacs::PxPortCharacs
  • m_port_service : WapProfile::PxLogicalCharacs::PxPortCharacs
  • m_port_set_id : WapProfile::PxLogicalCharacs::PxPortCharacs
  • m_ppp_callback : SysSocketBase
  • m_ppp_callback_data : SysSocketBase
  • m_ppp_callback_data_setup : SysSocketBase
  • m_ppp_callback_dc : SysSocketBase
  • m_ppTcpSocket : SocketTestT4
  • m_precision : ReferenceTime
  • m_prefered_alloc_wstring_size : SimPbBaseHandler
  • m_preset_list : AudioPresetStore
  • m_previous_zoom_level : SvgImage
  • m_primary_dns : DataConnProfile::Persist
  • m_primary_dns_server_address : PppSetupCallBackData
  • m_process_ptr : StackMsgProcessor
  • m_processor_type : RegEncoderDecoder::SetUpMsg
  • m_prof_id : WapProfileMgr::WapProfileInfo
  • m_prof_name : WapProfileMgr::WapProfileInfo
  • m_profile_id : DataConnProfileStorage::Header
  • m_profile_rec_size : DataConnProfileStorage::Header
  • m_profileId : SocketTestT4, SocketTestT3
  • m_prop : SyncMLCTCap
  • m_prop_count : SyncMLCTCap
  • m_prop_name : SyncMLCTProp
  • m_properties : IMelodyData
  • m_protid : SimSmsParameter::Record, TpduHeaderInformation
  • m_protocol_version : RegEncoderDecoder::SetUpMsg
  • m_provid : PbBaseProvider
  • m_provider : MtlrInfo, MolrInfo
  • m_proxy_addr : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_proxy_auth_type : WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
  • m_proxy_id : WapProfile::PxLogicalCharacs
  • m_proxy_name : WapProfile::PxLogicalCharacs
  • m_proxy_p_id : WapProfile::PxLogicalCharacs
  • m_proxy_trusted : WapProfile::PxLogicalCharacs
  • m_psd_linked_up : PsdDataConn
  • m_PsdDownloadSettings : SocketTestT3
  • m_pt_alt_ellipsoid : LocationEstimate
  • m_pt_arc : LocationEstimate
  • m_pt_uncert_circle : LocationEstimate
  • m_pt_uncert_ellipse : LocationEstimate
  • m_pTcpInSocket : SocketTestT4
  • m_pTcpOutSocket : SocketTestT4
  • m_pTcpReportSocket : SocketTestT4
  • m_pTcpServerSocket : SocketTestT4
  • m_push_enabled : WapProfile::PxLogicalCharacs
  • m_qos_delay : PsdDataConnProfile::Bit
  • m_qos_mean_rate : PsdDataConnProfile::Bit
  • m_qos_peak_rate : PsdDataConnProfile::Bit
  • m_qos_precedence : PsdDataConnProfile::Bit
  • m_qos_reliability : PsdDataConnProfile::Bit
  • m_quality_level : CodecDevice::AudioDecoderParameters, CodecDevice::VideoDecoderParameters, CodecDevice::VideoEncoderParameters
  • m_rat : UsimPlmn
  • m_rating : GenericFeatureData::GenericTrackInfo
  • m_read_event_notification : InetSocket
  • m_read_fdset : SerialIoSet
  • m_readchv : UsimFileProperty
  • m_readonly : DataConnProfile::Bit
  • m_readwritebuffer : SimPbBaseHandler
  • m_readwritebuffersize : SimPbBaseHandler
  • m_realloc_fct : HeapVector::FctTable
  • m_reason : AudioPlayerEvent
  • m_rec_max_count : DataConnProfileStorage::Header
  • m_record : UsimPbRefRecord, UsimPbRwRecord
  • m_record_length : DataRecordHandler
  • m_recordcount : UsimFileProperty
  • m_recording_wait_condition : StreamAudioPlayer
  • m_recordsize : UsimFileProperty
  • m_rect : Camera
  • m_recv_buffer : ClientNetAdapter
  • m_recv_from : NetAdapter::DataReceivedEventArgs
  • m_red_bit_count : ColorSegmentation
  • m_refcount : WStrData, StrData
  • m_refno : TpduHeaderInformation
  • m_regiterator : RegistryInterface
  • m_rem_appcntxt_list : AbstractScheduler
  • m_rep_timer : MolrRepeatInfo
  • m_repeat_interval : MolrInfo
  • m_reply_path_exists : TpduHeaderInformation
  • m_request_id_free_Slot : HttpWapMgrPlugin
  • m_requestMethod : HttpRequest
  • m_requestParams : HttpRequest
  • m_requestTarget : HttpRequest
  • m_res_type : RegEncoderDecoder::PC2MobileMsg::msg, RegEncoderDecoder::Response
  • m_resource_path_profile : MetaDataRecord
  • m_response : RegEncoderDecoder::Mobile2PCMsg::msg
  • m_response_type : AtResponseMetaInfo
  • m_result_win1 : RegAppFirstWin
  • m_reversed : ImageBrowserApp
  • m_right : Rect
  • m_ro_file_paths : DrmRightsMapTableEntry
  • m_root_path : RfsObexFtpServer
  • m_rootDir : ServerConfig
  • m_row_count : CalendarProvider
  • m_rsp_time_cat : LcsMmiQos, LcsQos
  • m_rule : FindProvider
  • m_rule2item : FilterRule
  • m_ruleitem : FilterRule
  • m_running : AbstractAppContext, Server, FtpTransfer
  • m_rx : SyncMLDataStoreProps
  • m_rx_count : SyncMLDataStoreProps
  • m_rx_pref : SyncMLDataStoreProps
  • m_sample_rate : StreamAudioReference
  • m_sampling_frequency : CodecDevice::AudioStreamInfo
  • m_sat_id : SatelliteInfo
  • m_sat_info : GpsFixDataInt, GpsFixData
  • m_sca : SimSmsParameter::Record
  • m_scaled_bottom_edge_cutted : PngImage
  • m_scaled_height : PngImage
  • m_scaled_right_edge_cutted : PngImage
  • m_scaled_width : PngImage
  • m_scaling_height : PngImage
  • m_scaling_width : PngImage
  • m_scanline : PngDecoder
  • m_scanline_idx : PngDecoder
  • m_scheduler : AbstractAppContext
  • m_sd : InetSocket, SerialSocket
  • m_sdn_maxrecs : SimPbBaseHandler
  • m_sdn_tagsize : SimPbBaseHandler
  • m_sec : UtcTime
  • m_second : Time::Persist, DateTime::Persist
  • m_secondary_dns : DataConnProfile::Persist
  • m_secondary_dns_server_address : PppSetupCallBackData
  • m_selectid : SerialIoSet
  • m_semi_major_axis : LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse
  • m_semi_minor_axis : LcsPointAltitudeUncertEllipsoid, LcsPointUncertEllipse
  • m_send_buffer : ClientNetAdapter
  • m_send_buffer_offset : ClientNetAdapter
  • m_send_buffer_size : ClientNetAdapter
  • m_send_continue_msg : UdpTestSocket, TcpTestSocket
  • m_send_error_message : AudioPlayerEvent
  • m_send_progress_messages : File::FileState
  • m_send_sem : ClientNetAdapter
  • m_sender_name : RadioAudioDevice::StationInfo
  • m_serialio : SerialSocket
  • m_server : ServerClient, HttpSocket, FtpSocket, FtpDataSocket
  • m_serverConfig : Server
  • m_session_received : PdpContextManager::DataCounters
  • m_session_sent : PdpContextManager::DataCounters
  • m_set : UsimPbGroups
  • m_set_frame_idx : SvgImage
  • m_settings : SocketTestApp
  • m_shared_mem : SyncMLDataStoreProps
  • m_shifted_pixel_height : PngImage
  • m_shifted_pixel_width : PngImage
  • m_shiftval : HeapVector::VarPage
  • m_shortci : PnnEntry
  • m_shortname : PnnEntry
  • m_sig_strength : SatelliteInfo
  • m_sim_handler : BaseDataHandler
  • m_sim_pdu_handler : SmsMsgWaitingProvider, SmsCountProvider, SmsProvider
  • m_sim_recno : PbNumberRecord::Persist
  • m_sim_stored : TpduHeaderInformation
  • m_sink : RamDataSource
  • m_size : MetaDataRecord, InputMap, SyncMLCTValueDef, SyncMLItemMetaInfo
  • m_size_fct : HeapVector::FctTable
  • m_sizevector : HeapVector::VarPage, HeapVector::BlockPage
  • m_sms_port_no : TpduHeaderInformation
  • m_sms_type : Sms
  • m_snr : SatelliteInfo
  • m_socket_connected : RegAppWin
  • m_song_name : GenericFeatureData::GenericTrackInfo
  • m_sortbuffer : QuickSortProvider
  • m_sorted_table : MergeProvider
  • m_SortedRows : SortProvider
  • m_source : CfuServiceArray
  • m_source_ref : SyncMLDataStoreProps
  • m_sourcestring : InputAction
  • m_sPathname : PathProfile::Persist
  • m_specific_resp_cnt : AtCommandMetaInfo
  • m_specific_responses : AtCommandMetaInfo
  • m_speed : GpsFixDataInt, GpsFixData
  • m_speed_valid : GpsFixDataInt, GpsFixData
  • m_start_block_num : BlockData
  • m_startpage : HeapVector::HeapTableEntry, WapProfile::PxLogicalCharacs
  • m_startpage_pwd : WapProfile::PxLogicalCharacs
  • m_startpage_user_name : WapProfile::PxLogicalCharacs
  • m_state : BtRequest
  • m_status : Provider, UsimPbFillStatus, TpduHeaderInformation
  • m_status_string : CallHdlBase
  • m_statusLine : HttpResponse
  • m_stereo_mode : RadioAudioDevice::StationInfo
  • m_stop_bits : NmeaUartSettings
  • m_stop_requested_by_conn : DataSourceRtStreamingSource
  • m_storagetype : TpduHeaderInformation
  • m_str_presentation : AtResponseMetaInfo, AtCommandMetaInfo
  • m_stream_type : CodecDevice::VideoStreamInfo
  • m_structure : FtpDataSocket
  • m_subnet : PdpContext::PacketFilter::AddressAndMask
  • m_substituted_text : FeatureItem
  • m_subsys_name : VersionInfo::Data
  • m_subunit_type : BtAvrcpSubunitInfoEntry
  • m_support_large_objects : SyncMLDataStoreProps
  • m_svg_bitmap : SvgImage
  • m_svg_height : SvgImage
  • m_svg_width : SvgImage
  • m_sync_cap : SyncMLDataStoreProps
  • m_sync_type_count : SyncMLDataStoreProps
  • m_syntaxerror : InputAction
  • m_temporary : File::FileState
  • m_text : TextIconPairArray::TextIconPair
  • m_text_attr : AbstractTextRenderer
  • m_text_start : AbstractTextRenderer
  • m_textline_settingmode : CameraViewFinderWin
  • m_tho_than_diacritic_lines : ThaiTextRenderer::ThaiFontHint
  • m_ti_pd : MtlrInfo
  • m_ticks : UdpTestSocket, SvgImage
  • m_time : TimeFeatureObject, CodecDevice::AudioIOBuffer
  • m_time_stamp : LastLocationEstimate
  • m_time_tag_delta : GpsFixDataInt, GpsFixData
  • m_timeout : SysSocketBase::LingerSetting
  • m_timer_resolution : CodecDevice::VideoEncoderParameters
  • m_title : GenericFeatureData::GenericTrackInfo, PropertyDescriptor
  • m_to_nap_id : WapProfile::PxLogicalCharacs::PxPhysicalCharacs
  • m_tone_data : IMelodyData, CustomToneAudioReference
  • m_tone_id : PresetAudioReference, AudioPreset
  • m_tone_type : CustomToneAudioReference, AudioPreset
  • m_top : Rect
  • m_top_level_y_offset : ThaiTextRenderer::ThaiFontHint
  • m_top_offset : CodecDevice::VideoStreamInfo
  • m_total_play_time_1 : AudioReference::TotalPlayTimeContainer
  • m_total_play_time_2 : AudioReference::TotalPlayTimeContainer
  • m_total_play_time_3 : AudioReference::TotalPlayTimeContainer
  • m_total_play_time_4 : AudioReference::TotalPlayTimeContainer
  • m_total_received : PdpContextManager::DataCounters
  • m_total_sent : PdpContextManager::DataCounters
  • m_tp_data : Sms
  • m_tpdu : Sms
  • m_track : GenericFeatureData::GenericTrackInfo
  • m_track_id : MediaInfo::MediaTrackInfo
  • m_tracked : SatelliteInfo
  • m_trans : SvgImage
  • m_transaction_id : InteriorNodeRecord, Transaction
  • m_transparent_color : BitmapRes, PngDecoder
  • m_tree_level : InteriorNodeRecord
  • m_trns_blue : PngDecoder
  • m_trns_green : PngDecoder
  • m_trns_red : PngDecoder
  • m_tx : SyncMLDataStoreProps
  • m_tx_count : SyncMLDataStoreProps
  • m_tx_pref : SyncMLDataStoreProps
  • m_type : RegEncoderDecoder::Payload, NetAdapter, DataConnProfile::Bit, PhoneNumber, DataItem, SyncMLItemMetaInfo, FtpDataSocket
  • m_type_name : AudioAccessoryDetails
  • m_uid : DrmRightsMapTableEntry
  • m_uint16 : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit, AbstractDevice::ControlArg
  • m_uint16_ar : LittleEndian32Bit, BigEndian32Bit
  • m_uint32 : LittleEndian32Bit, BigEndian32Bit, AbstractDevice::ControlArg
  • m_uint8 : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit, AbstractDevice::ControlArg
  • m_uint8_ar : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit
  • m_unblock_focus_messages : AbstractScheduler
  • m_uncert_altitude : LcsPointAltitudeUncertEllipsoid
  • m_uncert_radius : LcsArc, LcsPointUncertCircle
  • m_unique_id : PbNumberRecord::Persist
  • m_unit_id : GltpRequest
  • m_update_path : AudioAccessoryDetails
  • m_update_threadlet : PhonebookApp
  • m_updatechv : UsimFileProperty
  • m_uplinkPath : AudioAccessoryDetails
  • m_uri : RegEncoderDecoder::PC2MobileMsg::msg, RegEncoderDecoder::Mobile2PCMsg::msg, RegEncoderDecoder::UriAndPayload, RegEncoderDecoder::IteratorObjResult, RegEncoderDecoder::RegIteratorNodeType, RegNodeFileHeader
  • m_uri_payload : RegEncoderDecoder::PC2MobileMsg::msg
  • m_url : GenericFeatureData::GenericTrackInfo
  • m_usb_conn_info : UsbTransport
  • m_val : LittleEndian32Bit, LittleEndian16Bit, BigEndian32Bit, BigEndian16Bit, CfuServiceArray
  • m_val_enum : SyncMLCTValueDef
  • m_value : BtSddbDeVariableLengthType, Property, HeaderData, DrmDcfHeaderData
  • m_value_def : SyncMLCTProp, SyncMLCTParam
  • m_value_def_count : SyncMLCTProp, SyncMLCTParam
  • m_ver_ct : SyncMLCTTypeVerCT
  • m_version : DataConnProfileStorage::Header, IMelodyData, RegFileHeader, SyncMLItemMetaInfo
  • m_version_string : VersionInfo::Data
  • m_vert_accuracy : LcsMmiQos, LcsQos
  • m_view : RadioButtonListView, CheckBoxListView
  • m_view_image_transformation : Camera
  • m_virtual_heap_id : HeapVector::HeapTableEntry
  • m_void_ptr : AbstractDevice::ControlArg
  • m_vp : SimSmsParameter::Record
  • m_wait_msgbox : SocketTestApp
  • m_wchar_ptr : AbstractDevice::ControlArg
  • m_white_balance : Camera
  • m_width : ImageMetaDataRecord, GlyphHeader, Glyph, BitmapRes, PngDecoder
  • m_write_cnf_cb : SioSocketAdapter::SioSocketCallbacks
  • m_write_fdset : SerialIoSet
  • m_wrong_status : TpduHeaderInformation
  • m_wsName : SocketTestTests::TestGroupInfo, FfsTestBase::FfsTestInfo
  • m_wsp_version : WapProfile::PxLogicalCharacs
  • m_wstr_settingmode : CameraViewFinderWin
  • m_wwwDir : HttpServerConfig
  • m_x_origin : PngImage
  • m_y_origin : PngImage
  • m_year : DateTime::Persist, Date, Date::Persist, GenericFeatureData::GenericTrackInfo, UtcTime
  • m_yo_ying_diacritic_lines : ThaiTextRenderer::ThaiFontHint
  • m_zoom_level : Camera
  • mapi_return_value : AudioMapiManager::RequestOutcomeType
  • markLevel : ToDoRecord::Persist
  • max : Camera::ParameterLimits
  • max_entitled_priority : CliRestrictionInfo
  • max_height : BtBipImageFormat::ImageDim
  • max_width : BtBipImageFormat::ImageDim
  • mbdn_size : PhoneBookInfo
  • mbdn_tagsize : PhoneBookInfo
  • mcc : CellParam, NeighbourCell, Plmn, BcdPlmn, Uplmn
  • meas_bler : DchReport, BlerTrchInfo
  • meas_id : UmtsMeasIdParam
  • meas_sir : DchReport
  • media : Mp3Param, VmParam, PcmParam
  • media_present : FsRegistrationInfo, fs_registered_info_type
  • media_type : VoiceMemoAudioDevice::StartParam
  • memory_alloc_failure : SvgImage
  • menu_id : MenuPool::MenuTableEntry
  • menu_properties : MenuPool::MenuTableEntry
  • millisec : RealTimeClock::DateAndTime
  • mime_str : MimeTypeTableEntry
  • mime_type : tagCustFileData, MimeTypeTableEntry, AudioPlayerStore::DataFormatDataSource, FfsDrmAttrib, ffs_drm_attrib_type, FfsMimeTypeMapEntry, Media::Parameters
  • mimetype : RomDataRes
  • min : Camera::ParameterLimits, FfsTimeRecord, ffs_time_record_type
  • min_height : BtBipImageFormat::ImageDim
  • min_width : BtBipImageFormat::ImageDim
  • minute : RealTimeClock::DateAndTime
  • mix_factor : ToneAudioDevice::StartParam, KeyToneAudioDevice::StartParam
  • mmi_configuration : SecLockStates
  • mnc : CellParam, NeighbourCell, Plmn, BcdPlmn, Uplmn
  • mode : PcmParam
  • month : RealTimeClock::DateAndTime, FfsTimeRecord, ffs_time_record_type
  • month_name : Date
  • mp3_player : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • mpg_br : Mp3Header
  • mpg_freq : Mp3Header
  • mpg_layer : Mp3Header
  • mpg_pad_bit : Mp3Header
  • mpg_ver : Mp3Header
  • mpty_indicator : NotifySsArg
  • ms_tx_power_max_cch : CellParam
  • msg : RegEncoderDecoder::PC2MobileMsg, RegEncoderDecoder::Mobile2PCMsg
  • msg_class : MsgMetaData
  • msg_id : RegEncoderDecoder::PC2MobileMsg, MsgMetaData, MessageMap< T >
  • msg_origin : MsgMetaData
  • msisdn_size : PhoneBookInfo
  • msisdn_tagsize : PhoneBookInfo
  • multi_slot_class : MultiSlotMode
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • nack_blocks : AckNackCnt
  • name : GroupProvider::GroupRec, FontRes, tagFont, tagLanguage, RingerAudioDevice::RingerToneInfo, ServiceProviderStruct, StackMsgMapTableEntry, SignalMapTableEntry, HttpRequest::ParamPair
  • name_indicator : NotifySsArg
  • name_indicator_present : NameIndicator
  • name_string : CallingName
  • native_name : tagLanguage
  • nco : GprsParam
  • neighbour_cells : TestparamReport, NeighbourCellList
  • nestedLevel : InternalTracer::TraceHeader
  • net_op_mode : GprsParam
  • network : SimLockStates
  • newpwd : SecLockCommand
  • next : TpduNode, TpduConc
  • no : ChvData
  • no_ack_nack_blocks : GprsParam
  • no_active_set_cells : UmtsNcellParamList
  • no_blocks : CiTestParam
  • no_id : PbNumberRecord::Persist
  • no_locks : SecLockStates
  • no_rf_chans : CellParam
  • no_rfiles : SecLockStates
  • no_umts_cells : UmtsNcellParamList
  • no_virtual_active_set_cells : UmtsNcellParamList
  • nof_crc_err : BlerTrchInfo
  • nof_entity : T_PB_REF_FILE
  • nof_group : T_PB_DESCRIPTOR
  • nof_rec : T_PB_FILE_DESC
  • nof_repeats : Audio::ToneData
  • nof_slice : T_PB_DESCRIPTOR
  • nof_tones : Audio::ToneData
  • nom : TestparamReport
  • noreply_timer : ForwardingFeature
  • normal_glyph_index_tab : FontRes
  • note : ToDoRecord::Persist
  • notification : SmsStatus
  • notification_func : FsRegistrationInfo, fs_registered_info_type
  • notify_arg : SsNotificationArg
  • nr_of_cells : NeighbourCellList
  • num_file : JarFileStatusInfo, JarBinDataStatusInfo
  • num_glyphs : tagFont
  • number : PagingMapEntry
  • number_entry : JarFileGlobalInfo_s
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • obex_target : BtObexServiceTable::Entry
  • offset_central_dir : JarFileStatusInfo, JarBinDataStatusInfo
  • offset_curfile : FileInfoInternal_s
  • offset_local_extrafield : FileInReadStatusInfo, BinDataInReadStatusInfo
  • offset_table : tagFont, tagLanguage
  • oldpwd : SecLockCommand
  • on_time : Led::Frame
  • OnArg : StackMsgArgMap< T >
  • oos_cnt : RrcParam
  • operation_code : UssDataArg, PasswordReceivedArg, InterrogationResultArg, SsNotificationArg, SsDataReceivedArg, BarringInfoReceivedArg, ForwardingInfoReceivedArg
  • option : CliRestrictionInfo
  • options : ForwardingFeature
  • out_of_service : AsTestparamDatabase, UmtsRrcScellParam
  • outbox_ascending_order : SmsSettingsRecord::Persist
  • outbox_sorting_colid : SmsSettingsRecord::Persist
  • override_category : SsData
  • owner : Vector< T >::Iterator
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • barring_info : BarringInfoReceivedArg
  • base_level : BidiManager::ParagraphContext
  • baseline : FontRes, tagFont
  • basic_serv_group_list : SsData, InterrogateSsResult
  • basic_serv_group_list_size : InterrogateSsResult
  • basic_service : CallBarringFeature, ForwardingFeature
  • bdn_size : PhoneBookInfo
  • bdn_tagsize : PhoneBookInfo
  • bearer_type : SiBearerDesc_s
  • beat : IMelodyData
  • bit_rate : PcmParam
  • block_index : RamBlockData
  • blue : Palette, Led::Color, SimClutEntry
  • bmscr : BtChipVersion
  • bmu : BtChipVersion
  • bold_glyph_index_tab : FontRes
  • bold_index : tagFont
  • br_number : SiBearerList_s
  • bs_pa_mfrms : CellParam
  • bsic : CellParam, NeighbourCell
  • bsic_bcc : CellParam
  • bsic_ncc : CellParam
  • buf : _JUMP_BUFFER
  • buff : BtBppSndFilePushReqRequest
  • buff_used_bytes : BtBppSndFilePushReqRequest
  • buffer : RingerAudioDevice::StartParam, BtObexHeader
  • buffer_size : RingerAudioDevice::StartParam, Mp3Param, VmParam, PcmParam, RtStreamingEndPoint::BufferInfo
  • buffers : DataSourceRtStreamingSource
  • byte_before_the_zipfile : JarFileStatusInfo, FileInReadStatusInfo, JarBinDataStatusInfo, BinDataInReadStatusInfo
  • byte_sequence : BtObexHeader
  • byte_value : BtObexHeader
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • c1 : CellParam, NeighbourCell
  • c2 : CellParam, NeighbourCell
  • c2_valid_params : CellParam
  • c31 : NeighbourCell, GprsParam
  • c32 : NeighbourCell, GprsParam
  • c_any_url : ObexMngr
  • c_decoder : PngDecoder
  • c_global_errno : SerialIoAdapter::SioErrorDesc
  • c_over_i : GprsParam
  • c_over_i_array : COverIList
  • c_pixel_channels : PngDecoder
  • c_result : ObexAbstractPort::CompleteEvent
  • c_sem : PngDecoder
  • c_sem_created : PngDecoder
  • c_shift : PngImage
  • c_sio_errno : SerialIoAdapter::SioErrorDesc
  • c_sms_sending_anim_img_cnt : SmsSendingAnimation
  • c_sms_sending_anim_speed : SmsSendingAnimation
  • c_t9_symbol_pages : T9InputConfig
  • c_t9_symbol_rows : T9InputConfig
  • c_theme_name : CustomizableTheme
  • c_time_feature_object_id : TimeFeatureObject
  • c_unlimited : Image
  • call : CallSetupProgressArg, DtmfRejectArg, DtmfStartCnfArg, CallInfoArg, CallDisconnectingArg
  • call_duration : CallDisconnectingArg
  • call_hold_indicator : NotifySsArg
  • call_index : CallEvent
  • call_wait_indicator : NotifySsArg
  • calling_name : NameIndicator
  • category : CalendarRecord::Persist, UsimEccRecord
  • cause : DtmfRejectArg, CallDisconnectingArg, MdhResult
  • ccbs_entry : CcbsList
  • ccbs_idx : CcbsEntry
  • ccbs_list : InterrogateCcbsResult
  • ccbs_que_length : InterrogateCcbsResult
  • ccp1 : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • cell_bar_access : CellParam
  • cell_bar_qualify : CellParam
  • cell_change_cnt : CellParam
  • cell_change_cnts : TestparamReport
  • cell_change_ind : AsTestparamDatabase
  • cell_id : CellParam, NeighbourCell
  • cell_identity : UmtsRrcScellParam
  • cell_reselect_offset : CellParam
  • cell_reselection_reason : RrParam
  • cell_type : UmtsNcellParam
  • central_pos : JarFileStatusInfo, JarBinDataStatusInfo
  • changed_indication : SimInfo
  • changed_state : SimInfo
  • channel : RingerAudioDevice::StartParam
  • channel_mode : CellParam
  • channel_release_reason : RrParam
  • channel_type : CellParam
  • channel_volume : RingerAudioDevice::StartParam
  • charge_value : AocChargeData
  • childcount : RegIterator::InteriorMetaData
  • chip_type : BtChipVersion, BtChipBmu, BtChipBmscr
  • chn_rel_cause : RrcParam, AsTestparamDatabase
  • chv1_status : SimInfo
  • chv1AttemptsLeft : ChvAttemptsStruct
  • chv1UnblAttemptsLeft : ChvAttemptsStruct
  • chv2_status : SimInfo
  • chv2AttemptsLeft : ChvAttemptsStruct
  • chv2UnblAttemptsLeft : ChvAttemptsStruct
  • chv_attempts : SimInfo
  • ci_param : L1Param
  • ci_testparam_array : CiTestParamList
  • cipher_on : CellParam, AsTestparamDatabase, UmtsRrcScellParam
  • cli_restriction_info : InterrogateSsResult
  • cli_restriction_option : SsData
  • client : BtObexServiceTable::Security
  • client_arg : FsRegistrationInfo, fs_registered_info_type
  • clir_supp_rejected : NotifySsArg
  • cmd_number : T_STK_TRANSACTION_ID
  • cmi : CmiRecord
  • cname_selector : CallingName
  • code : EnumTextTableEntry
  • codeAdr : InternalTracer::TraceHeader
  • colid : ColumnInfo
  • color : Led::Frame
  • command_code : AudioMapiManager::MapiCommandType
  • compressed : BitmapRes
  • compressed_size : FileInfo_s
  • compression_method : FileInReadStatusInfo, BinDataInReadStatusInfo, FileInfo_s
  • container_content_table_entry : MenuPool::FeatureItemContainerTableEntry
  • container_id : MenuPool::FeatureItemContainerTableEntry
  • container_table_entry : MenuPool::FeatureItemContainerContentTableEntry, MenuPool::MenuTableEntry
  • context_id : MenuPool::FeatureItemContainerTableEntry, MenuPool::FeatureItemContainerContentTableEntry, ContextTableEntry
  • coord_param : TestparamReport
  • copyright : RingerAudioDevice::RingerToneInfo
  • copyrighted : BitmapRes
  • corporate : SimLockStates
  • count : BidiManager::ParagraphContext, MdhSetWaitIndicator, MdhWaitIndicator
  • cphs_infono_size : PhoneBookInfo
  • cphs_infono_tagsize : PhoneBookInfo
  • cphs_mbox_size : PhoneBookInfo
  • cphs_mbox_tagsize : PhoneBookInfo
  • cpich_ecn0 : UmtsNcellParam, UmtsRrcScellParam
  • cpich_rscp : UmtsNcellParam, UmtsRrcScellParam
  • cpich_sc : UmtsNcellParam
  • cr_cnt : CellChangeCnts
  • cr_cnt_at : CellChangeCnts
  • cr_hyst : GprsParam
  • cr_success : MmCellChangeCnts
  • crc : FileInfo_s
  • crc32 : FileInReadStatusInfo, BinDataInReadStatusInfo
  • crc32_wait : FileInReadStatusInfo, BinDataInReadStatusInfo
  • CreateHandler : HandlerData
  • cs_param : TestparamReport
  • cug_index : NotifySsArg
  • cur_file_info : JarFileStatusInfo, JarBinDataStatusInfo
  • cur_file_info_internal : JarFileStatusInfo, JarBinDataStatusInfo
  • currency_symbol : Locale::LocaleData
  • current : Vector< T >::Iterator
  • current_file_ok : JarFileStatusInfo, JarBinDataStatusInfo
  • current_loc : T_PB_LOC_REPORT
  • cust_file : tagFilePackData
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • data : tagCustFileData, tagLdbData, tagCPGlyph, tagTranslationTable, BtObexServiceTable::ObexTarget, RomDataRes, SsDataReceivedArg, ChannelData_s, SiIpAddress_s, MsapPackedData_s, SiProvFileRef_s, SiBearerDesc_s, SiBearerList_s, TAlphaIdentifier_s, TSiUrl_s, SsGroupList, CallBarringFeatureList, ForwardingFeatureList, RegObjectData
  • data1 : Guid
  • data2 : Guid
  • data3 : Guid
  • data4 : Guid
  • data_coding_scheme : SiText_s, CallingName
  • data_elements : UmtsMeasIdParam
  • data_pack : tagCustomizationPack
  • data_pack_count : tagCustomizationPack
  • data_pack_data : tagDataPackHeader
  • data_pack_id : tagDataPackHeader
  • data_table : tagGlyphData
  • dataformat : RegObjectData
  • datasize : RegObjectData
  • datatype : RegObjectData
  • date : CalendarRecord::Persist, DateStr, FfsTimeRecord, ffs_time_record_type, datestr
  • dates : Locale::LocaleData
  • datum : MenuPool::FeatureItemContainerContentTableEntry
  • day : RealTimeClock::DateAndTime
  • day_name : Date
  • days_in_month : Date
  • dcs : UssDataArg
  • dcs_lang_code : LanguageCodeTableEntry
  • decimal_separator : Locale::LocaleData
  • def : Camera::ParameterLimits
  • default_priority : SsData, CliRestrictionInfo
  • deleted : PbNumberRecord::Persist, PbRecord::Persist
  • description : CalendarRecord::Persist
  • dest_pos : BidiManager::ParagraphContext
  • dest_text : BidiManager::ParagraphContext
  • destroy_func : ArgumentDestroyEntry
  • device : RingerAudioDevice::StartParam, FsRegistrationInfo, fs_registered_info_type
  • device_id : HostIterStatType
  • dir_id : FfsRefType, ffs_ref_type
  • disk_num_start : FileInfo_s
  • dl_blocks : AckNackTestparamCnt
  • dl_uarfcn : UmtsNcellParam, UmtsRrcScellParam
  • dosDate : FileInfo_s
  • drive_letter : FsRegistrationInfo, fs_registered_info_type
  • driveno : FatFindData, dstat
  • drm_attrib : FfsFileInfo, ffs_file_info_type
  • drx_max : GprsParam
  • dsc : CellParam
  • dsc_pch : L1Param
  • dsc_ppch : L1Param
  • dsp_format : VoiceMemoAudioDevice::StartParam
  • dsplcond : ServiceProviderStruct
  • dtx_used : CellParam
  • dur : Audio::SingleTone
  • duration : ToneAudioDevice::UserTone, RingerAudioDevice::RingerToneInfo, Media::Parameters
  • dword_value : BtObexHeader
  • dynamic : FfsFileInfo, ffs_file_info_type
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • e164_number : WapProfile::Ipv4E164
  • ecc : UsimEccRecord
  • ect_callstate : EctIndicator
  • ect_indicator : NotifySsArg
  • email : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • email_ref : T_PB_REF_RECORD
  • emo : GprsParam
  • enabled : StartUp::Table
  • entry_count : tagDataPackHeader
  • eq_plmn_list : TestparamReport
  • event : RrcProcessState
  • event_id : UmtsMeasIdParam
  • exist : T_PB_STATE
  • exists : TSiIconID_s
  • exponent : AocChargeData
  • ext1 : T_PB_FILL_STATUS
  • ext_pref_language : SimInfo
  • external_fa : FileInfo_s
  • ExtPsdContextListener_SioGlueWrapper : ExtPsdContextListener_SioGlueWrapper::TermIos, ExtPsdContextListener_SioGlueWrapper::SioCommId
  • extra_bytes : RegEncoderDecoder
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • fading_color : Led::StreamField
  • family_name : tagFontFamily
  • fattribute : HostFileStatType, HostIterStatType, RamFileInfo, FatFindData, FatFileInfo, fs_stat, dstat
  • fdate : HostIterStatType, FatFindData, dstat
  • fdn_size : PhoneBookInfo
  • fdn_tagsize : PhoneBookInfo
  • feature_handle : KeymapTableEntry
  • feature_id : MenuPool::FeatureItemContainerContentTableEntry, SoftkeyDescTableEntry
  • feature_list : CallBarringInfo, ForwardingInfo
  • feature_list_size : CallBarringInfo, ForwardingInfo
  • fext : HostIterStatType, FatFindData, dstat
  • ffs_type : FfsMimeTypeMapEntry
  • file_ext_substr_list : MimeTypeTableEntry
  • file_handle : VoiceMemoAudioDevice::StartParam, Mp3Param, VmParam, PcmParam
  • file_handle_size : VoiceMemoAudioDevice::StartParam
  • file_id : FfsRefType, ffs_ref_type
  • file_name : tagCustFileData, SerialIoAdapter::SioErrorDesc
  • file_number : SiProvFileRef_s
  • file_size : tagCustFileData
  • filehandle : HostIterStatType
  • filter : MdhViewConfig
  • finding_dirs : FfsRefType, ffs_ref_type
  • first_frame : SvgImage
  • flag : FileInfo_s
  • flags : SmsSettingsRecord::Persist
  • FliType : CameraOptionSettingsWin
  • FlsType : CameraOptionSettingsWin
  • fname : HostIterStatType, FatFindData, dstat
  • font : tagFontPack
  • font_family : tagFont
  • format : RingerAudioDevice::StartParam, VmParam, PcmParam
  • forward_feature_list : InterrogateSsResult
  • forward_feature_list_size : InterrogateSsResult
  • forward_to_number : InterrogateSsResult, ForwardingFeature
  • forwarding_info : ForwardingInfoReceivedArg
  • frame : Led::StreamField
  • frame_rate_denominator : Media::Parameters
  • frame_rate_numerator : Media::Parameters
  • freq : Audio::SingleTone
  • frequency : ToneAudioDevice::UserTone
  • from : BidiManager::ParagraphContext
  • fsize : HostIterStatType, FatFindData, dstat
  • ftime : HostIterStatType, FatFindData, dstat
  • full_refresh : SimEfRefresh
  • func : MessageMap< T >
  • fw_build : BtChipBmu
  • fw_patch : BtChipBmu
  • fw_revision : BtChipBmu
  • fw_varinat : BtChipBmu
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • g_globalMask : InternalTracer
  • gap_to_next_char : FontRes, tagFont
  • gas : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • gi : JarFileStatusInfo, JarBinDataStatusInfo
  • gmt_bias : RealTimeClock::DateAndTime
  • gprs : TestparamReport
  • gprs_class : MmCoordParam
  • gprs_sup : GprsParam
  • green : Palette, Led::Color, SimClutEntry
  • group_id : PbRecord::Persist
  • grouping : T_PB_RECORD, T_PB_CHANGED_FIELD
  • gsm_band : MmCoordParam
  • gsm_bands : GsmBandList
  • gsm_lang_code : LanguageCodeTableEntry
  • gsm_service : SmsSettingsRecord::Persist
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • handle : Mp3Param, VmParam, PcmParam, T_PB_FILE_DESC
  • has_native_img_data : BitmapRes
  • hcs_used : UmtsRrcScellParam
  • hdl : SharedMemHdl, Task
  • header : tagCustomizationPack
  • header_id : BtObexHeader
  • header_type : BtObexHeader
  • height : FontRes, tagFont
  • hidden_key_supported : T_PB_DESCRIPTOR
  • high : CbmiRange
  • high_mobility : UmtsRrcScellParam
  • hour : RealTimeClock::DateAndTime, FfsTimeRecord, ffs_time_record_type
  • hw_platform : BtChipBmu
  • hw_revision : BtChipBmu
  • hw_variant : BtChipBmu
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • icc_id : PbRecord::Persist
  • iccid : SimInfo
  • icon_id : MenuPool::FeatureItemContainerTableEntry, MenuPool::FeatureItemContainerContentTableEntry, SoftkeyDescTableEntry
  • id : GroupProvider::GroupRec, InternalTracer::TraceHeader, tagFont, tagLanguage, MmiSimMsg, NvRamBlockInfo, BtAttributeId, ArgumentDestroyEntry, TSiIconID_s, StackMsgMapTableEntry, SignalMapTableEntry
  • id_offset : Mp3Param
  • identifier_valid : TAlphaIdentifier_s
  • idle_subscriber_no : CcbsEntry
  • idxPos : SmsTextEntry
  • in_use : EmlppPriority
  • inbox_ascending_order : SmsSettingsRecord::Persist
  • inbox_sorting_colid : SmsSettingsRecord::Persist
  • ind : SsGroup
  • index : CugDescriptor
  • index_table : tagFont
  • indication : FsRegistrationInfo, fs_registered_info_type
  • info : MmfPlayer::MediaPlayerInstanceData
  • internal_fa : FileInfo_s
  • interval : AudioToneDuration
  • invalid_glyph : FontRes
  • ip_type : SiIpAddress_s
  • ipv4_address : WapProfile::Ipv4E164
  • ir_bind_was_succesful : IrConnection
  • ir_cr_attempt : MmCellChangeCnts
  • ir_cr_cnt_at : CellChangeCnts
  • ir_cr_cnt_su : CellChangeCnts
  • ir_cr_success : MmCellChangeCnts
  • ir_discoverreq_in_progress : IrdaObexTransport
  • ir_ho_attempt : MmCellChangeCnts
  • ir_ho_success : MmCellChangeCnts
  • ir_hocc_cnt_at : CellChangeCnts
  • ir_hocc_cnt_su : CellChangeCnts
  • irconnections : IrdaObexTransport
  • is_binary : MimeTypeTableEntry
  • is_loading : SvgImage
  • is_on_sim : PbNumberRecord::Persist
  • iso_2ltr_code : LanguageCodeTableEntry
  • iso_3ltr_code : LanguageCodeTableEntry
  • italic_bold_glyph_index_tab : FontRes
  • italic_glyph_index_tab : FontRes
  • italic_index : tagFont
  • item_type : MenuPool::FeatureItemContainerContentTableEntry
  • iterations : Led::Stream, Led::Frame
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • p1 : UmtsMeasEvalParam
  • p2 : UmtsMeasEvalParam
  • p_sc : UmtsRrcScellParam
  • padding : tagCustFileData, tagLdbData, tagFontFamily, tagLanguage, tagDataPackHeader, tagCustomizationPack, RamFileInfo, FatFileInfo, fs_stat
  • padding2 : tagFont
  • padding3 : tagFont
  • Param1 : RingerAudioDevice::StartParam, SimLaunchBrowserPromptReq_s
  • Param2 : RingerAudioDevice::StartParam, SimLaunchBrowserPromptReq_s
  • Param3 : RingerAudioDevice::StartParam, SimLaunchBrowserPromptReq_s
  • parm1 : AudioMapiManager::MapiCommandType
  • parm2 : AudioMapiManager::MapiCommandType
  • parm3 : AudioMapiManager::MapiCommandType
  • parm4 : AudioMapiManager::MapiCommandType
  • parm5 : AudioMapiManager::MapiCommandType
  • parm6 : AudioMapiManager::MapiCommandType
  • parm7 : AudioMapiManager::MapiCommandType
  • password : PasswordReceivedArg
  • path : RingerAudioDevice::StartParam, HostIterStatType, FatFindData, dstat
  • patternName : HostIterStatType
  • payload_obj : RegEncoderDecoder::Payload
  • pbc_hidden_info : T_PB_RECORD, T_PB_CHANGED_FIELD
  • pbcch_present : GprsParam
  • pdu : TpduNode, TpduConc
  • pdu_no : TpduConc
  • penalty_time : CellParam
  • pext : FatFindData, dstat
  • pfile_in_zip_read : JarFileStatusInfo, JarBinDataStatusInfo
  • phone_no : CallDisconnectingArg
  • phone_number : Rdn
  • phoneno_type : PbNumberRecord::Persist
  • play_count : ToneAudioDevice::StartParam, RingerAudioDevice::StartParam
  • plmn : CellParam, NeighbourCell, Lai
  • plmn_array : EquivPlmnLists, BlerTrchInfoList
  • plmn_id : UmtsRrcScellParam
  • plongFileName : FatFindData, dstat
  • plugin : AtlApplicationPluginStartup::Table
  • pmom : FatFindData, dstat
  • pname : FatFindData, dstat
  • pNext : comm_user_cert, comm_root_cert
  • pobj : FatFindData, dstat
  • pos : MdhWaitIndicator
  • pos_in_central_dir : JarFileStatusInfo, JarBinDataStatusInfo
  • pos_in_zipfile : FileInReadStatusInfo, BinDataInReadStatusInfo
  • pos_local_extrafield : FileInReadStatusInfo, BinDataInReadStatusInfo
  • post_message_func : SignalMapTableEntry
  • power_saving_mode : RrcParam, AsTestparamDatabase
  • pred_input : SmsSettingsRecord::Persist
  • pref_language : SimInfo
  • present : SsGroup
  • prev : TpduConc
  • prev_readpos : XMLParser
  • preview_mandatory : SmsSettingsRecord::Persist
  • priority : ServiceThreadStarter::StartParam
  • priorityLevel : ToDoRecord::Persist
  • private_idx : MsapPackedData_s
  • process_state : RrcProcessState
  • profile : SmsSettingsRecord::Persist
  • progress_ind : CallSetupProgressArg
  • PROP_DRM_ATTRIB : FlashFileImp
  • PROP_NATIVEHANDLE : FlashFileImp, FatFileImp
  • PROP_USERID : FlashFileImp
  • property_editor_id : MenuPool::FeatureItemContainerContentTableEntry
  • ps_param : TestparamReport
  • ps_transfer : RrcParam, AsTestparamDatabase
  • psContent : comm_root_cert
  • psi1_repeat : GprsParam
  • psi_count_hr : GprsParam
  • psi_count_lr : GprsParam
  • psKey : comm_user_cert
  • pStateFunc : StateStruct
  • psUserCert : comm_user_cert
  • pszContentType : comm_user_cert, comm_root_cert
  • pszPassword : comm_user_cert
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- q -

  • qualifier : TSiIconID_s
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • rac : GprsParam, UmtsRrcScellParam
  • radio : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • radio_freq : FmRadioStationsRecord::Persist
  • radio_last_freq : FmRadioSettingsRecord::Persist
  • radio_last_volume : FmRadioSettingsRecord::Persist
  • range : BtAttributeId
  • rank_pos : NeighbourCell, UmtsNcellParam
  • ranking_status : NeighbourCell, UmtsNcellParam
  • ranking_value : NeighbourCell, UmtsNcellParam, UmtsRrcScellParam
  • rat : TestparamReport
  • rate : VoiceMemoAudioDevice::StartParam, VmParam
  • rdn : EctIndicator
  • read_buffer : FileInReadStatusInfo, BinDataInReadStatusInfo
  • ready_connected : GmmParam
  • recurrence : CalendarRecord::Persist
  • red : Palette, Led::Color, SimClutEntry
  • refresh : SimEfRefreshTable
  • refresh_info : T_PB_RECORD
  • reg_state : MmCoordParam
  • removable : FsRegistrationInfo, fs_registered_info_type
  • render_properties : MenuPool::FeatureItemContainerTableEntry
  • reply_path : SmsSettingsRecord::Persist
  • reserved : FfsFileInfo, ffs_file_info_type
  • reset_em : AsTestparamDatabase
  • reset_mm_cnt : CellChangeCnts
  • resolution : Media::Parameters
  • rest_read_compressed : FileInReadStatusInfo, BinDataInReadStatusInfo
  • rest_read_uncompressed : FileInReadStatusInfo, BinDataInReadStatusInfo
  • result : InterrogationResultArg, MsapPackedData_s
  • ring_tone : RingerAudioDevice::StartParam
  • ring_tone_id : RingerAudioDevice::RingerToneInfo
  • ringer : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • rll : L1Param, CellParam
  • rooturi : GuidUriTable
  • rr_mode : TestparamReport
  • rr_param : TestparamReport
  • rrc_param : TestparamReport
  • rrc_state : RrcParam
  • rrcbp_state : RrcParam, AsTestparamDatabase
  • rrcdc_state : RrcParam, AsTestparamDatabase
  • rrcm_state : RrcParam, AsTestparamDatabase
  • run_level : ServiceThreadStarter::StartParam
  • running_version : tagCustomizationPack
  • rxlev : NeighbourCell
  • rxlev_access_min : CellParam
  • rxlev_full : CellParam
  • rxlev_serv : CellParam
  • rxlev_sub : CellParam
  • rxqual : L1Param
  • rxqual_full : CellParam
  • rxqual_sub : CellParam
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • s_coding_scheme_type : SimImageDescriptor
  • s_extension_separator : Pathname
  • s_file_id_high : SimImageDescriptor
  • s_file_id_low : SimImageDescriptor
  • s_file_instance_length_high : SimImageDescriptor
  • s_file_instance_length_low : SimImageDescriptor
  • s_file_instance_offset_high : SimImageDescriptor
  • s_file_instance_offset_low : SimImageDescriptor
  • s_height : SimImageDescriptor
  • s_instance : HttpApplication
  • s_instance_cnt : ServerClient, RamDataSink
  • s_root_pathname : Pathname
  • s_separator : Pathname
  • s_width : SimImageDescriptor
  • sample_rate : PcmParam
  • sc : CallBarringInfo, ForwardingInfo
  • sdn_size : PhoneBookInfo
  • sdn_tagsize : PhoneBookInfo
  • second : RealTimeClock::DateAndTime
  • selected_cug : CugDescriptor
  • selector : InterrogateSsResult, Rdn
  • send_signal_func : StackMsgMapTableEntry
  • sending_confirmation : SmsSettingsRecord::Persist
  • SerialIoSet : SerialIoSet, SerialSocket, SerialIoAdapter
  • SerialServerSocket : SerialServerSocket, SerialSocketSubSystem, SerialSocketData, SerialClientSocket
  • SerialSocket : SerialSocket, SerialSocketSubSystem, SerialSocketData, SerialIoAdapter
  • serif : tagFontFamily
  • serv_group : CcbsEntry
  • server : BtObexServiceTable::Security
  • service_class : BtObexServiceTable::Entry
  • service_name : BtObexServiceTable::Entry
  • service_ses : BtObexServiceTable::Entry
  • service_state : GmmParam, MmcsParam
  • service_type : BtObexServiceTable::Entry
  • serviceptr : GuidUriTable
  • serving_cell : TestparamReport
  • setting : MdhWaitIndicator
  • short_day_name : Date
  • short_month_name : Date
  • si13_present : GprsParam
  • sim : T_PB_LOC_REPORT, SimLockStates
  • sim_indicator : SimInfo
  • sim_phase : SimInfo
  • sim_type : SimInfo
  • SioGlueWrapper : SioGlueWrapper::TermIos, SioGlueWrapper::SioCommId
  • size : WbxmlVector< T >, tagCustFileData, tagLdbData, tagCPGlyph, tagFont, tagLanguage, tagDataPackHeader, tagCustomizationPack, NvRamBlockInfo, BtObexHeader, RomDataRes, RegIterator::LeafMetaData, FfsFileInfo, ffs_file_info_type
  • size_central_dir : JarFileStatusInfo, JarBinDataStatusInfo
  • size_comment : JarFileGlobalInfo_s
  • size_file_comment : FileInfo_s
  • size_file_extra : FileInfo_s
  • size_filename : FileInfo_s
  • size_local_extrafield : FileInReadStatusInfo, BinDataInReadStatusInfo
  • smstype : MdhWaitIndicator
  • sne : T_PB_FILL_STATUS, T_PB_DESCRIPTOR
  • sne_ref : T_PB_REF_RECORD
  • softkey_descriptions : ContextTableEntry
  • sort : MdhViewConfig
  • source : AudioPlayerStore::DataFormatDataSource
  • sp : SimLockStates
  • speech : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • split_pg_cycle : GprsParam
  • ss_code : SsData, NotifySsArg
  • ss_notification : NotifySsArg
  • ss_status : InterrogateCcbsResult, SsData, InterrogateSsResult, CliRestrictionInfo, CallBarringFeature, ForwardingFeature, NotifySsArg
  • st_accesstime : HostFileStatType
  • st_atime : RamFileInfo, FatFileInfo, fs_stat
  • st_blksize : RamFileInfo, FatFileInfo, fs_stat
  • st_blocks : RamFileInfo, FatFileInfo, fs_stat
  • st_creationtime : HostFileStatType
  • st_ctime : RamFileInfo, FatFileInfo, fs_stat
  • st_dev : FatFileInfo, fs_stat
  • st_deviceId : HostFileStatType
  • st_ino : FatFileInfo, fs_stat
  • st_inode : HostFileStatType
  • st_mode : HostFileStatType, FatFileInfo, fs_stat
  • st_modificationtime : HostFileStatType
  • st_mtime : RamFileInfo, FatFileInfo, fs_stat
  • st_nlink : HostFileStatType, FatFileInfo, fs_stat
  • st_rdev : HostFileStatType, FatFileInfo, fs_stat
  • st_size : HostFileStatType, RamFileInfo, FatFileInfo, fs_stat
  • stack : ServiceThreadStarter::StartParam
  • stacksize : ServiceThreadStarter::StartParam, StartUp::Table
  • start_frame : Mp3Param
  • state : CallInfoArg, RrParam, MmCoordParam, GmmParam, MmcsParam
  • statrep_ascending_order : SmsSettingsRecord::Persist
  • statrep_on_idlescreen : SmsSettingsRecord::Persist
  • statrep_sorting_colid : SmsSettingsRecord::Persist
  • status : ChvData, MdhResult
  • status_report : SmsSettingsRecord::Persist
  • storage : MdhViewConfig
  • storage_location : SmsSettingsRecord::Persist
  • strbuf : XMLParser
  • stream : FileInReadStatusInfo, BinDataInReadStatusInfo
  • stream_field : Led::Stream
  • stream_initialised : FileInReadStatusInfo, BinDataInReadStatusInfo
  • string_count : tagLanguage
  • style : IMelodyData
  • subaddress : CcbsEntry, Rdn
  • sum_c_over_i : CiTestParam
  • suppress_oa : CugDescriptor
  • sync_supported : T_PB_DESCRIPTOR
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • t3192 : GprsParam
  • t3212 : CellParam
  • t9_pack : tagT9Pack
  • t_byte : MmiSimMsgArg
  • t_char : MmiSimMsgArg
  • t_int : MmiSimMsgArg
  • t_int16 : MmiSimMsgArg
  • t_int32 : MmiSimMsgArg
  • t_int8 : MmiSimMsgArg
  • t_uchar : MmiSimMsgArg
  • t_uint : MmiSimMsgArg
  • t_uint32 : MmiSimMsgArg
  • t_void : MmiSimMsgArg
  • t_wchar : MmiSimMsgArg
  • t_xydim : MmiSimMsgArg
  • table : SimEfRefresh
  • table_count : tagFont
  • target_sir : DchReport
  • text : SmsTextEntry, MenuPool::FeatureItemContainerTableEntry, MenuPool::FeatureItemContainerContentTableEntry, EnumTextTableEntry, SoftkeyDescTableEntry, SiText_s, UusText, ValueTextMap::Table
  • text_align : Locale::LocaleData
  • text_ptr : BtJsr82Url::Token::Keyword
  • thousand_separator : Locale::LocaleData
  • threedigitmnc : Plmn
  • time : CalendarRecord::Persist, DateStr, datestr
  • time_interval : SiDuration_s
  • time_units : SiDuration_s
  • timer : MmCoordParam, GmmParam, MmcsParam
  • times : Locale::LocaleData
  • timestamp : FfsFileInfo, ffs_file_info_type
  • timing_advance : L1Param, CellParam
  • title : ContextTableEntry
  • tmp_offset : CellParam
  • to_key_code : KeymapTableEntry
  • toDoListDateTime : ToDoRecord::Persist
  • tone : ToneAudioDevice::StartParam
  • tone_count : ToneAudioDevice::StartParam
  • tone_generator : MiscAudioDevice::AvailableHW
  • tone_type : ToneAudioDevice::StartParam
  • tones : Audio::ToneData
  • tot_nof_blocks : BlerTrchInfo
  • total_time : Led::Frame
  • tracediag : SecLockStates
  • transac_flag : LockTableEntry
  • transaction_id : T_STK_TRANSACTION_ID
  • transparent : BitmapRes
  • trch_id : BlerTrchInfo
  • ts : InternalTracer::TraceHeader, InternalTracer::TsStruct
  • tx_power_level : L1Param, CellParam
  • tx_pwr : RrcParam
  • type : ToDoRecord::Persist, SmsTextEntry, DataConnApp::EditableSettingTable, PbNumberRecord::Persist, PbRecord::Persist, BtUUID, ColumnInfo, CallInfoArg, UusText, SecLockCommand, RegIterator::LeafMetaData, FfsFileInfo, ffs_file_info_type, WapProfile::Ipv4E164
  • type_id : BtJsr82Url::Token::Keyword
  • types : BidiManager::ParagraphContext
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • uiCertLen : comm_user_cert
  • uid : T_PB_RECORD
  • uiKeyLen : comm_user_cert
  • uiLength : comm_root_cert
  • ul_blocks : AckNackTestparamCnt
  • ul_meas_cnt : RrcParam, AsTestparamDatabase
  • ul_uarfcn : UmtsRrcScellParam
  • umts_meas_eval_param : RrcParam
  • umts_meas_id_params : UmtsMeasEvalParam
  • umts_ncell_param : TestparamReport
  • umts_ncell_param_list : UmtsNcellParamList
  • umts_neighbour_cells : UmtsCellList
  • umts_scell : RrcParam
  • unblocking_attempts_left : ChvData
  • uncompressed_size : FileInfo_s
  • unicode_string : BtObexHeader
  • units : AudioToneDuration
  • update : MdhSetWaitIndicator, MdhWaitIndicator
  • update_status : GmmParam, MmcsParam
  • uppercase : PagingMapEntry
  • use_param : RingerAudioDevice::StartParam
  • use_tone : ToneAudioDevice::StartParam
  • used_bytes : RamBlockData
  • user_tone : ToneAudioDevice::StartParam
  • usim_appl : T_PB_LOC_REPORT
  • usim_global : T_PB_LOC_REPORT
  • uss_data : UssDataArg
  • UTone : ToneAudioDevice::StartParam
  • uuid : BtUUID
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • val : SiIpAddressArray, SiTextArray, TMsapPackedDataArray, SiProvFileRefArray, SiBearerDescArray, SiBearerListArray, TAlphaIdentifierArray, SiUrlArray, SimSubAddress, SimEventList, AddInfo, CurrencyCode, UsimLanguageList, UsimLanguage, PsLociData, UsimEst, UsimUst, CphsCspArray, CphsOnsName, CphsOnmName, CphsCfufArray, CphsVmwfArray, CphsIstArray, SimEfOrangeParam, SimEfParameters, SimDfParameters, SimApdu, SmsrData, SimData, EccNetworkNumber, EccArray, CcpData, SimServiceTable, Imei, Imsi, Puct, Acm, IccId, ExtLanguageArray, ExtLanguage, LanguageArray, CbmiData, LociData, SmsParamRecord, UsimPlmnList, MdhDeletionCmd, MdhExtendedData, MdhSetWaitIndicatorArray, MdhWaitIndicatorArray, SecLocks, SecMmiConfigData, SecLockCode
  • valid : PbNumberRecord::Persist, PbRecord::Persist
  • value : GridLayout::LayouterProperties, BtObexHeader, EmlppPriority, SsGroup, ValueTextMap::Table, HttpRequest::ParamPair
  • version : tagCustomizationPack, FileInfo_s
  • version_needed : FileInfo_s
  • vibrator : MiscAudioDevice::PowerStatus
  • vm_mode : VmParam
  • vm_play : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • vm_rec : MiscAudioDevice::AvailableHW, MiscAudioDevice::PowerStatus
  • voicebox_number : SmsSettingsRecord::Persist
  • volume : IMelodyData
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • WbType : CameraOptionSettingsWin
  • width : tagCPGlyph
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • x_scale : S_SvgFixPointTrans
  • x_shear : S_SvgFixPointTrans
  • x_trans : S_SvgFixPointTrans
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • y_scale : S_SvgFixPointTrans
  • y_shear : S_SvgFixPointTrans
  • y_trans : S_SvgFixPointTrans
  • year : RealTimeClock::DateAndTime, FfsTimeRecord, ffs_time_record_type
Generated on Wed Jan 25 00:54:32 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Namespace Index

  • Namespace List
  • Namespace Members

APOXI Namespace List

Here is a list of all namespaces with brief descriptions:
AtiUtils
Generated on Wed Jan 25 02:31:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AtiUtils Namespace Reference

  • Namespace List
  • Namespace Members

AtiUtils Namespace Reference
[Devices]

Functions

tGciAudioBitrate | ConvertAACToGCIFormat (CodecDevice::EncQualityConfig input)
tGciAudioAmrBitrateConfig | ConvertAMRToGCIFormat (CodecDevice::EncQualityConfig input)
CodecDevice::TimestampMSec | ConvertFromGCIFormat (tGciAudioTimestampMSec input)
BOOLEAN | ConvertFromGCIFormat (tGciBoolean input)
UINT8 * | ConvertFromGCIFormat (UINT32 *input)
CodecDevice::AudioChannel | ConvertFromGCIFormat (tGciAudioHandle input)
CodecDevice::ResultType | ConvertFromGCIFormat (tGciResult input)
tGciAudioTimestampMSec | ConvertToGCIFormat (CodecDevice::TimestampMSec input)
tGciBoolean | ConvertToGCIFormat (BOOLEAN input)
UINT32 * | ConvertToGCIFormat (const UINT8 *input)
tGciAudioFormat | ConvertToGCIFormat (CodecDevice::CodecType codec)
tGciAudioMonoStereoConfiguration | ConvertToGCIFormat (CodecDevice::MonoSteroConfig input)
tGciAudioSamplingFreqHz | ConvertToGCIFormat (UINT16 input)
tGciAudioAacFormat | ConvertToGCIFormat (CodecDevice::AacFormat input)
tGciAudioAmrDtxConfig | ConvertToGCIFormat (CodecDevice::AmrDtxConfig input)
tGciAudioAmrInterfaceFormatConfig | ConvertToGCIFormat (CodecDevice::AmrIfFormat input)
tGciAudioHandle | ConvertToGCIFormat (CodecDevice::AudioChannel input)

Detailed Description

Audio Capturer and Encoder interface for the ATI W2x82 multimedia companion chip.

Generated on Wed Jan 25 02:31:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Module Index

APOXI Modules

Here is a list of all modules:
  • ADC
    • Provider
    • Middle Layer
  • HTTPWAPIF
  • Add Ons
    • AuxExtensions
    • CodecManager
    • Digital Rights Management
    • GuiInputExtensions
    • GUI Menu Accessors
    • MediaFramework
    • MultiMedia
    • Services
    • Svg
    • T9
    • Translation
    • Voice Recognition
  • GUI
    • Components
      • Editors
      • Sms
    • Obsolete GUI classes
    • Editors
    • Items
    • Sms
  • SerialSocket
  • Socket
  • Audio
  • Afs
    • Root File System
      • FAT filesystem support
      • Flash File System support
      • RAM File System support
      • Virtual Root File System support
  • APC
  • APOXI Defines
    • Internal Defines
      • Feature Defines
      • Environmental Defines
    • Optional Defines
      • Switch Defines
      • Compatibility Defines
      • Configuration Defines
      • Temporary Defines
    • Currently Undocumented Defines (interim section)
  • APOXI Features
    • Currently Undocumented Features (interim section)
  • Apoxi
  • APOXI File Systems
  • APOXI Stack Control
  • Auxiliary
  • Bluetooth
  • IRDA
  • Kernel
    • Operating System
  • OBEX
  • SupplementaryServiceActions
  • APOXI Template Layer
  • GuiExtensions
    • GuiExtensionMenuAccessors
  • Config
  • UnitTestCaseManager
  • UnitTestManager
  • UnitTestRepositoryManager
  • UnitTest
  • UnitTestDataManager
  • UnitTestResultManager
  • AdvPhonebook
    • AdvPhonebookActions
    • AdvPhonebookProvider
  • Phonebook
    • Synchronization
  • CallSettings
  • BtHfPlugin
  • CalendarListWin
  • CallRecords
  • DataConn
  • Dataconn
  • EMS
  • SMS
  • ExtractSmsTextPlugin
  • ImageBrowserCommon
  • ImageBrowser
  • IrdaApp
  • ObexApp
  • SoundBrowser
  • ToDoListWin
  • Settings
  • UnifiedInbox
  • UnifiedInobx
  • UsbApp
  • VoiceMemoApp
  • VoiceMemo
  • SERVER
  • FTPSERVER
  • HTTPSERVER
  • Asc
  • OBEX
Generated on Wed Jan 25 02:31:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ADC

ADC

Collaboration diagram for ADC:

Modules

Provider
Middle Layer

Data Structures

class | BootControl
class | BootState
class | DataControl
class | DataHandler
class | LookupAlphaIdExtension
class | SimAccessor
class | SimUserDispatcher

Enumerations

enum | BootNotification { BootNoRequest, BootFinishedNotification, BootLoadNotification, BootNotAvailable }
enum | DataAvailability { DataAccessible, DataNotPresent, DataAccessUndefined }
enum DataControlType {
SimAdnPhonebook, SimFdnPhonebook, SimMsisdnPhonebook, SimLndPhonebook,
SimCphsMBoxPhonebook, SimCphsInfoNoPhonebook, SimSdnPhonebook, SimBdnPhonebook,
SimMbdnPhonebook, SimSmsParameters, SimSms, SimPreferedLanguages,
SimPreferedExtLanguages, SimPreferedPlmns, SimPuct, SimAcm,
SimAcmMax, SimSst, SimImsi, SimSpn,
SimEcc, SimCphsInfo, SimCphsOpName, SimCphsOpShortName,
SimCphsCsp, SimCbmi, SimCbmiRange, SimCcp,
UsimPhonebook, DynamicAlsFlags, SimAll
}

Variables

const INT | c_acm_rec_size = 3
const INT | c_ccp_rec_size = 14
const SimFileId | c_df_cingular_id = 0x7f66
const SimFileId | c_df_graphics_id = 0x5F50
const SimFileId | c_df_gsm_id = 0x7F20
const SimFileId | c_df_mexe_id = 0x5F3C
const SimFileId | c_df_mf_id = 0x3F00
const SimFileId | c_df_orange_id = 0x7f40
const SimFileId | c_df_telecom_id = 0x7F10
const INT | c_ecc_rec_size = 3
const SimFileId | c_ef_acm_id = 0x6F39
const SimFileId | c_ef_acmmax_id = 0x6F37
const SimFileId | c_ef_ad_id = 0x6FAD
const SimFileId | c_ef_adn_id = 0x6F3A
const SimFileId | c_ef_arpk_id = 0x4F42
const SimFileId | c_ef_bdn_id = 0x6F4D
const SimFileId | c_ef_call_fwrd_id = 0x6F13
const SimFileId | c_ef_cbmi_id = 0x6F45
const SimFileId | c_ef_cbmid_id = 0x6F48
const SimFileId | c_ef_cbmir_id = 0x6F50
const SimFileId | c_ef_ccp_id = 0x6F3D
const SimFileId | c_ef_cfis_id = 0x6FCB
const SimFileId | c_ef_cmi_id = 0x6F58
const SimFileId | c_ef_cphs_info_no_id = 0x6F19
const SimFileId | c_ef_cphsinfo_id = 0x6F16
const SimFileId | c_ef_cust_serv_id = 0x6F15
const SimFileId | c_ef_dynamic2_id = 0x6f92
const SimFileId | c_ef_dynamic_id = 0x6f9F
const SimFileId | c_ef_ecc_id = 0x6FB7
const SimFileId | c_ef_elp_id = 0x2F05
const SimFileId | c_ef_emlpp_id = 0x6FB5
const SimFileId | c_ef_ext1_id = 0x6F4A
const SimFileId | c_ef_ext2_id = 0x6F4B
const SimFileId | c_ef_ext3_id = 0x6F4C
const SimFileId | c_ef_ext4_id = 0x6F4E
const SimFileId | c_ef_ext6_id = 0x6FC8
const SimFileId | c_ef_ext7_id = 0x6FCC
const SimFileId | c_ef_fdn_id = 0x6F3B
const SimFileId | c_ef_img_id = 0x4F20
const SimFileId | c_ef_imsi_id = 0x6F07
const SimFileId | c_ef_lnd_id = 0x6F44
const SimFileId | c_ef_loci_id = 0x6F7E
const SimFileId | c_ef_lp_id = 0x6F05
const SimFileId | c_ef_mbdn_id = 0x6FC7
const SimFileId | c_ef_mbi_id = 0x6Fc9
const SimFileId | c_ef_mbox_no_id = 0x6F17
const SimFileId | c_ef_mexest_id = 0x4F40
const SimFileId | c_ef_msisdn_id = 0x6F40
const SimFileId | c_ef_opl_id = 0x6FC6
const SimFileId | c_ef_opn_str_srt_id = 0x6F18
const SimFileId | c_ef_opname_str_id = 0x6F14
const SimFileId | c_ef_orpk_id = 0x4F41
const SimFileId | c_ef_param_id = 0x6f9B
const SimFileId | c_ef_plmnsel_id = 0x6F30
const SimFileId | c_ef_plmnselwact_id = 0x6F60
const SimFileId | c_ef_pnn_id = 0x6FC5
const SimFileId | c_ef_puct_id = 0x6F41
const SimFileId | c_ef_sdn_id = 0x6F49
const SimFileId | c_ef_sms_id = 0x6F3C
const SimFileId | c_ef_smsp_id = 0x6F42
const SimFileId | c_ef_smsr_id = 0x6F47
const SimFileId | c_ef_smss_id = 0x6F43
const SimFileId | c_ef_spdi_id = 0x6FCD
const SimFileId | c_ef_spn_id = 0x6F46
const SimFileId | c_ef_sst_id = 0x6F38
const SimFileId | c_ef_tprpk_id = 0x4F43
const SimFileId | c_ef_tst_id = 0x6FD2
const SimFileId | c_ef_vbs_id = 0x6FB3
const SimFileId | c_ef_vbss_id = 0x6FB4
const SimFileId | c_ef_vgcs_id = 0x6FB1
const SimFileId | c_ef_vgcss_id = 0x6FB2
const SimFileId | c_ef_vmsg_wtng_id = 0x6F11
const INT | c_maxpending_messages = 8
const INT | c_plmn_rec_size = 3
const INT | c_puct_rec_size = 5
const INT | c_timeout_seconds = 30
const INT | c_tst_file_size = 8

Enumeration Type Documentation

enum BootNotification

BootNotification defines the enumeration value for the BootHandler in Asc

Enumerator:
BootNoRequest
BootFinishedNotification
BootLoadNotification
BootNotAvailable

enum DataAvailability

DataAvailability is an enum which defines if an ADC provider can access data from the Sim if necessary.

Enumerator:
DataAccessible | Data is generally present on the Sim or present in ADC.
DataNotPresent | Data cannot be accessed because it is not present on the Sim.
DataAccessUndefined | Data access is not defined, because the Sim is not present or ready.

enum DataControlType

DataControlType defines the enumeration value for the DataControlModificationMsg sent by the ADC when data was changed

Enumerator:
SimAdnPhonebook
SimFdnPhonebook
SimMsisdnPhonebook
SimLndPhonebook
SimCphsMBoxPhonebook
SimCphsInfoNoPhonebook
SimSdnPhonebook
SimBdnPhonebook
SimMbdnPhonebook
SimSmsParameters
SimSms
SimPreferedLanguages
SimPreferedExtLanguages
SimPreferedPlmns
SimPuct
SimAcm
SimAcmMax
SimSst
SimImsi
SimSpn
SimEcc
SimCphsInfo
SimCphsOpName
SimCphsOpShortName
SimCphsCsp
SimCbmi
SimCbmiRange
SimCcp
UsimPhonebook
DynamicAlsFlags
SimAll complete Sim was reseted

Variable Documentation

const INT c_acm_rec_size = 3

const INT c_ccp_rec_size = 14

const SimFileId c_df_cingular_id = 0x7f66

const SimFileId c_df_graphics_id = 0x5F50

const SimFileId c_df_gsm_id = 0x7F20

const SimFileId c_df_mexe_id = 0x5F3C

const SimFileId c_df_mf_id = 0x3F00

const SimFileId c_df_orange_id = 0x7f40

const SimFileId c_df_telecom_id = 0x7F10

const INT c_ecc_rec_size = 3

const SimFileId c_ef_acm_id = 0x6F39

const SimFileId c_ef_acmmax_id = 0x6F37

const SimFileId c_ef_ad_id = 0x6FAD

const SimFileId c_ef_adn_id = 0x6F3A

const SimFileId c_ef_arpk_id = 0x4F42

const SimFileId c_ef_bdn_id = 0x6F4D

const SimFileId c_ef_call_fwrd_id = 0x6F13

const SimFileId c_ef_cbmi_id = 0x6F45

const SimFileId c_ef_cbmid_id = 0x6F48

const SimFileId c_ef_cbmir_id = 0x6F50

const SimFileId c_ef_ccp_id = 0x6F3D

const SimFileId c_ef_cfis_id = 0x6FCB

const SimFileId c_ef_cmi_id = 0x6F58

const SimFileId c_ef_cphs_info_no_id = 0x6F19

const SimFileId c_ef_cphsinfo_id = 0x6F16

const SimFileId c_ef_cust_serv_id = 0x6F15

const SimFileId c_ef_dynamic2_id = 0x6f92

const SimFileId c_ef_dynamic_id = 0x6f9F

const SimFileId c_ef_ecc_id = 0x6FB7

const SimFileId c_ef_elp_id = 0x2F05

const SimFileId c_ef_emlpp_id = 0x6FB5

const SimFileId c_ef_ext1_id = 0x6F4A

const SimFileId c_ef_ext2_id = 0x6F4B

const SimFileId c_ef_ext3_id = 0x6F4C

const SimFileId c_ef_ext4_id = 0x6F4E

const SimFileId c_ef_ext6_id = 0x6FC8

const SimFileId c_ef_ext7_id = 0x6FCC

const SimFileId c_ef_fdn_id = 0x6F3B

const SimFileId c_ef_img_id = 0x4F20

const SimFileId c_ef_imsi_id = 0x6F07

const SimFileId c_ef_lnd_id = 0x6F44

const SimFileId c_ef_loci_id = 0x6F7E

const SimFileId c_ef_lp_id = 0x6F05

const SimFileId c_ef_mbdn_id = 0x6FC7

const SimFileId c_ef_mbi_id = 0x6Fc9

const SimFileId c_ef_mbox_no_id = 0x6F17

const SimFileId c_ef_mexest_id = 0x4F40

const SimFileId c_ef_msisdn_id = 0x6F40

const SimFileId c_ef_opl_id = 0x6FC6

const SimFileId c_ef_opn_str_srt_id = 0x6F18

const SimFileId c_ef_opname_str_id = 0x6F14

const SimFileId c_ef_orpk_id = 0x4F41

const SimFileId c_ef_param_id = 0x6f9B

const SimFileId c_ef_plmnsel_id = 0x6F30

const SimFileId c_ef_plmnselwact_id = 0x6F60

const SimFileId c_ef_pnn_id = 0x6FC5

const SimFileId c_ef_puct_id = 0x6F41

const SimFileId c_ef_sdn_id = 0x6F49

const SimFileId c_ef_sms_id = 0x6F3C

const SimFileId c_ef_smsp_id = 0x6F42

const SimFileId c_ef_smsr_id = 0x6F47

const SimFileId c_ef_smss_id = 0x6F43

const SimFileId c_ef_spdi_id = 0x6FCD

const SimFileId c_ef_spn_id = 0x6F46

const SimFileId c_ef_sst_id = 0x6F38

const SimFileId c_ef_tprpk_id = 0x4F43

const SimFileId c_ef_tst_id = 0x6FD2

const SimFileId c_ef_vbs_id = 0x6FB3

const SimFileId c_ef_vbss_id = 0x6FB4

const SimFileId c_ef_vgcs_id = 0x6FB1

const SimFileId c_ef_vgcss_id = 0x6FB2

const SimFileId c_ef_vmsg_wtng_id = 0x6F11

const INT c_maxpending_messages = 8

const INT c_plmn_rec_size = 3

const INT c_puct_rec_size = 5

const INT c_timeout_seconds = 30

const INT c_tst_file_size = 8

Generated on Wed Jan 25 02:25:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Provider

Provider
[ADC]

Collaboration diagram for Provider:

Data Structures

class | AuxProvider
class | CbmiProvider
class | CbmiRangeProvider
class | ChvProvider
class | CmiProvider
class | CountryProvider
class | CphsAuxProvider
class | CphsServPflProvider
class | EccCustomization
class | EccProvider
class | LockProvider
class | MbiProvider
class | PbBaseProvider
class | PlmnProvider
class | PrefExtLangProvider
class | PrefLangProvider
class | PrefPlmnProvider
class | SimServices
class | SimTkMainMenuProvider
class | SmsClass0Provider
class | SmsCountProvider
class | SmsMsgWaitingProvider
class | SmsParamProvider
class | SmsProvider
class | SmsReadProvider
class | SmsSentProvider
class | SmsUnreadProvider
class | SmsUnsentProvider
class | SstProvider
class | StatusProvider

Enumerations

enum | EstTableIndexes { c_est_fdn = 1, c_est_bdn = 2, c_est_apn_acl = 3 }
enum SimServiceId {
SimServiceChv1Disable, SimServiceAdn, SimServiceFdn, SimServiceBdn,
SimServiceMsisdn, SimServiceLnd, SimServiceSms, SimServiceAoc,
SimServicePrefPlmn, SimServicePlmnwAct, SimServiceSmsParameter, SimServiceSdn,
SimServiceCbmi, SimServiceCbmiRanges, SimServiceSpn, SimServiceImages,
SimServiceMexe, SimServicePnn, SimServiceOpl, SimServiceMbdn,
SimServiceMwis, SimServiceCfis, SimServiceSpdi, SimServiceInvalid
}
enum SstTableIndexes {
c_sst_chv1_disable_function = 1, c_sst_adn = 2, c_sst_fdn = 3, c_sst_sms = 4,
c_sst_aoc = 5, c_sst_ccp = 6, c_sst_plmn_sel = 7, c_sst_msisdn = 9,
c_sst_ext1 = 10, c_sst_ext2 = 11, c_sst_sms_parameters = 12, c_sst_lnd = 13,
c_sst_cbmi = 14, c_sst_gil1 = 15, c_sst_gil2 = 16, c_sst_spn = 17,
c_sst_sdn = 18, c_sst_ext3 = 19, c_sst_vgcs_gil = 21, c_sst_vbs_gil = 22,
c_sst_emlpp = 23, c_sst_emlpp_answer = 24, c_sst_dwld_sms_cb = 25, c_sst_dwld_sms_pp = 26,
c_sst_menu_selection = 27, c_sst_call_control = 28, c_sst_proactive_sim = 29, c_sst_cbmi_ranges = 30,
c_sst_bdn = 31, c_sst_ext4 = 32, c_sst_depers_control_keys = 33, c_sst_coop_network_list = 34,
c_sst_sms_reports = 35, c_sst_networkind_alerting = 36, c_sst_mo_sm_sim = 37, c_sst_gprs = 38,
c_sst_image = 39, c_sst_solsa = 40, c_sst_ussd_in_callcontrol = 41, c_sst_run_at_command = 42,
c_sst_plmn_sel_access_tech = 43, c_sst_oplmn_sel_access_tech = 44, c_sst_hplmn_access_tech = 45, c_sst_cpbcch_info = 46,
c_sst_investigation_scan = 47, c_sst_eccp = 48, c_sst_mexe = 49, c_sst_pnn = 51,
c_sst_opl = 52, c_sst_mbdn = 53, c_sst_mwis = 54, c_sst_cfis = 55,
c_sst_spdi = 56, c_sst_mms = 57, c_sst_ext8 = 58, c_sst_mms_user_con_params = 59
}
enum UstTableIndexes {
c_ust_local_pb = 1, c_ust_fdn_pb = 2, c_ust_ext2 = 3, c_ust_sdn_pb = 4,
c_ust_ext3 = 5, c_ust_bdn_pb = 6, c_ust_ext4 = 7, c_ust_out_call_info = 8,
c_ust_in_call_info = 9, c_ust_sms = 10, c_ust_smsr = 11, c_ust_smsp = 12,
c_ust_aoc = 13, c_ust_ccp = 14, c_ust_cbmi = 15, c_ust_cbmir = 16,
c_ust_gid_level1 = 17, c_ust_gid_level2 = 18, c_ust_spn = 19, c_ust_plmnwact = 20,
c_ust_msisdn = 21, c_ust_image = 22, c_ust_notused = 23, c_ust_emlpp = 24,
c_ust_auto_emlpp = 25, c_ust_rfu = 26, c_ust_gsm_access = 27, c_ust_datadownload_smspp = 28,
c_ust_datadownload_smscb = 29, c_ust_callcontrol_usim = 30, c_ust_mosmscontrol_usim = 31, c_ust_runat_command = 32,
c_ust_set_to_1 = 33, c_ust_est = 34, c_ust_acl = 35, c_ust_dck = 36,
c_ust_coop_network_list = 37, c_ust_gsm_security_context = 38, c_ust_cpbcch_info = 39, c_ust_inv_scan = 40,
c_ust_mexe = 41, c_ust_opcont_plmnwact = 42, c_ust_hplmnwact = 43, c_ust_ext5 = 44,
c_ust_plmn_networkname = 45, c_ust_op_plmnlist = 46, c_ust_mbdn = 47, c_ust_mwis = 48,
c_ust_cfis = 49, c_ust_res = 50, c_ust_spdi = 51, c_ust_mms = 52,
c_ust_ext8 = 53, c_ust_callcontrol_gprs_usim = 54, c_ust_mms_ucp = 55, c_ust_nia = 56,
c_ust_vgcs = 57, c_ust_vbs = 58, c_ust_pseudonym = 59, c_ust_user_plmn_sel_wlan_access = 60,
c_ust_operator_plmn_sel_wlan_access = 61, c_ust_user_wsid_list = 62, c_ust_operator_wsid_list = 63, c_ust_vgcs_security = 64,
c_ust_vbs_security = 65, c_ust_wlan_reauthentication = 66, c_ust_mms_storage = 67, c_ust_generic_bootstrapping = 68,
c_ust_mbms_security = 69, c_ust_datadownload_ussd_appl = 70, c_ust_equivalent_hplmn = 71
}

Variables

const INT | c_max_customizable_codes = 1

Enumeration Type Documentation

enum EstTableIndexes

Enumerator:
c_est_fdn
c_est_bdn
c_est_apn_acl

enum SimServiceId

SimServiceId defines an enumeration for a certain service on SIM or USIM.

Enumerator:
SimServiceChv1Disable | Chv1 disabling functionality (SST=1,UST=undef).
SimServiceAdn | ADN phonebook (SST=2,UST=1).
SimServiceFdn | FDN phonebook (SST=3,UST=2 and EST=1).
SimServiceBdn | BDN phonebook (SST=31,UST=6 and EST=2).
SimServiceMsisdn | MSISDN phonebook (SST=9,UST=21).
SimServiceLnd | LND phonebook, (SST=13).
SimServiceSms | SMS (SST=4,UST=10).
SimServiceAoc | Advice of Charge (SST=5,UST=13).
SimServicePrefPlmn | Plmn Selector (SST=7).
SimServicePlmnwAct | Plmn Selector (SST=43,UST=7).
SimServiceSmsParameter | Sms Parameters (SST=12,UST=12).
SimServiceSdn | SDN phonebook (SST=18,UST=4).
SimServiceCbmi | CBMI (SST=14,UST=15).
SimServiceCbmiRanges | CBMI-Ranges (SST=30,UST=16).
SimServiceSpn | Service Provider Name (SST=17,UST=19).
SimServiceImages | Images (SST=39,UST=22).
SimServiceMexe | Mexe (SST=49,UST=41).
SimServicePnn | Plmn Network Name (SST=51,UST=45).
SimServiceOpl | Operator Plmn List (SST=52,UST=46).
SimServiceMbdn | Mailbox Dialing Numbers (SST=53,UST=47).
SimServiceMwis | Mailbox Waiting Indication Status (SST=54,UST=48).
SimServiceCfis | Call Forwarding Indication Status (SST=55,UST=49).
SimServiceSpdi | Service Provider Display Infomation (SST=56,UST=51).
SimServiceInvalid | Last entry invalid.

enum SstTableIndexes

SstTableIndexes defines the row values which can be used to retrieve values from Sstprovider.

Enumerator:
c_sst_chv1_disable_function
c_sst_adn
c_sst_fdn
c_sst_sms
c_sst_aoc
c_sst_ccp
c_sst_plmn_sel
c_sst_msisdn
c_sst_ext1
c_sst_ext2
c_sst_sms_parameters
c_sst_lnd
c_sst_cbmi
c_sst_gil1
c_sst_gil2
c_sst_spn
c_sst_sdn
c_sst_ext3
c_sst_vgcs_gil
c_sst_vbs_gil
c_sst_emlpp
c_sst_emlpp_answer
c_sst_dwld_sms_cb
c_sst_dwld_sms_pp
c_sst_menu_selection
c_sst_call_control
c_sst_proactive_sim
c_sst_cbmi_ranges
c_sst_bdn
c_sst_ext4
c_sst_depers_control_keys
c_sst_coop_network_list
c_sst_sms_reports
c_sst_networkind_alerting
c_sst_mo_sm_sim
c_sst_gprs
c_sst_image
c_sst_solsa
c_sst_ussd_in_callcontrol
c_sst_run_at_command
c_sst_plmn_sel_access_tech
c_sst_oplmn_sel_access_tech
c_sst_hplmn_access_tech
c_sst_cpbcch_info
c_sst_investigation_scan
c_sst_eccp
c_sst_mexe
c_sst_pnn
c_sst_opl
c_sst_mbdn
c_sst_mwis
c_sst_cfis
c_sst_spdi
c_sst_mms
c_sst_ext8
c_sst_mms_user_con_params

enum UstTableIndexes

UstTableIndexes defines the row values which can be used to retrieve values from Ustprovider.

Enumerator:
c_ust_local_pb
c_ust_fdn_pb
c_ust_ext2
c_ust_sdn_pb
c_ust_ext3
c_ust_bdn_pb
c_ust_ext4
c_ust_out_call_info
c_ust_in_call_info
c_ust_sms
c_ust_smsr
c_ust_smsp
c_ust_aoc
c_ust_ccp
c_ust_cbmi
c_ust_cbmir
c_ust_gid_level1
c_ust_gid_level2
c_ust_spn
c_ust_plmnwact
c_ust_msisdn
c_ust_image
c_ust_notused
c_ust_emlpp
c_ust_auto_emlpp
c_ust_rfu
c_ust_gsm_access
c_ust_datadownload_smspp
c_ust_datadownload_smscb
c_ust_callcontrol_usim
c_ust_mosmscontrol_usim
c_ust_runat_command
c_ust_set_to_1
c_ust_est
c_ust_acl
c_ust_dck
c_ust_coop_network_list
c_ust_gsm_security_context
c_ust_cpbcch_info
c_ust_inv_scan
c_ust_mexe
c_ust_opcont_plmnwact
c_ust_hplmnwact
c_ust_ext5
c_ust_plmn_networkname
c_ust_op_plmnlist
c_ust_mbdn
c_ust_mwis
c_ust_cfis
c_ust_res
c_ust_spdi
c_ust_mms
c_ust_ext8
c_ust_callcontrol_gprs_usim
c_ust_mms_ucp
c_ust_nia
c_ust_vgcs
c_ust_vbs
c_ust_pseudonym
c_ust_user_plmn_sel_wlan_access
c_ust_operator_plmn_sel_wlan_access
c_ust_user_wsid_list
c_ust_operator_wsid_list
c_ust_vgcs_security
c_ust_vbs_security
c_ust_wlan_reauthentication
c_ust_mms_storage
c_ust_generic_bootstrapping
c_ust_mbms_security
c_ust_datadownload_ussd_appl
c_ust_equivalent_hplmn

Variable Documentation

const INT c_max_customizable_codes = 1

EccProvider is the provider to retrieve the ECC entries from the sim (GSM 11.11 V8.2.0 10.3.27). An instance of this class is part of the the Apoxi Data Control. A pointer to this provider can be retrieved from the main provider via the id:

c_ecc_provider_id

Following column id is defined: c_ecc_id WStringType: returns the number of the emergency call code as string. c_ecc_category_id NumberType: returns the category byte. The wrapper class EccCategory can be used to allow access to the category bits. c_ecc_source_id NumberType: returns the source from where the ECC was retrieved. This value shall be casted to the enumeration EccSource. c_ecc_phonenumber_id PhoneNumberType: returns the ecc code as an phonenumber object. c_ecc_sim_network_cnt_id NumberType: returns the number of ecc codes on SIM and Network, row value 0 shall be used.

for UMTS additional: c_ecc_alpha_id WStringType: returns the alpha identifier.

NOTE: Please do not instantiate this class.

Generated on Wed Jan 25 02:24:34 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Middle Layer

Middle Layer
[ADC]

Collaboration diagram for Middle Layer:

Data Structures

class | BaseDataHandler
class | CompoundSmsItem
class | CompoundTpduItem
class | MexeDescriptor
class | OplEntry
class | PnnEntry
class | SimAuxHandler
struct | SimAuxHandler::ExtLanguageBuffer
class | SimChvHandler
class | SimCphsHandler
class | SimMexeCertificate
class | SimPbBaseHandler
class | SimPbEntry
class | SimPbEntryCont
class | SimPduHandler
class | SimSmsParameter
class | SimSmsParamHandler
class | SmsWStringCache
class | TpduCache
struct | TpduHeaderInformation
struct | TpduPhoneNumberPersist

Enumerations

enum | ConcatenetedStatus { NormalSms = 0, ConcatenetedSms = 1, PartlyConcatenetedSms = 2, InvalidSms = 3 }
enum | MexeCertType { OperatorRootPublicKey, AdministratorRootPublicKey, ThirdPartyRootPublicKey }
MexeCertType describes the different types of cerificates stored in the DF-Mexe directory. More...
enum | SmsDeleteStatus { SmsDeleteRead = 0x01, SmsDeleteUnread = 0x02, SmsDeleteSent = 0x04, SmsDeleteUnsent = 0x08 }
enum SmsFilterType {
AllSmsFilterType = 0, UnreadSmsFilterType = 1, ReadSmsFilterType = 2, UnsentSmsFilterType = 3,
SentSmsFilterType = 4
}
enum TpduCountType {
SimTpdus = 0, NvramTpdus = 1, SmsReportTpdus = 2, OverallTpdus = 3,
NoOfCountTypes = 4
}

Functions

BOOLEAN | SimAuxHandler::CheckSpnData (const Plmn &regplmn, BOOLEAN &showregplmn, BOOLEAN &showspnname, WString &spnname, BOOLEAN use_spn_display_condition)
BOOLEAN | SimAuxHandler::DeleteAllExtLanguages (INT instance_nr)
BOOLEAN | SimAuxHandler::DeleteAllLanguages ()
BOOLEAN | SimAuxHandler::DeleteAllPlmns ()
BOOLEAN | SimAuxHandler::DeleteAllPlmnwAct ()
BOOLEAN | SimAuxHandler::DeleteExtLanguage (INT idx, INT instance_nr)
BOOLEAN | SimAuxHandler::DeleteLanguage (INT idx)
BOOLEAN | SimAuxHandler::DeletePlmn (INT idx)
BOOLEAN | SimAuxHandler::DeletePlmnwAct (INT idx)
BOOLEAN | SimAuxHandler::DetectChvProtection (UINT16 fileid, ChvNo &chvno)
INT | FindFirstByte (const UINT8 *address, INT size, UINT8 eos)
BOOLEAN | SimAuxHandler::GetAcm (UINT32 &value, AcmSelector selector=Acm1)
WString | SimAuxHandler::GetActiveExtLanguage () const
BcdPlmn | SimAuxHandler::GetBcdPlmn (INT idx) const
BcdPlmn | SimAuxHandler::GetBcdPlmnwAct (INT idx) const
BOOLEAN | SimAuxHandler::GetCbmi (UINT idx, UINT16 &cbmi)
BOOLEAN | SimAuxHandler::GetCbmiRange (UINT idx, UINT16 &rangehigh, UINT16 &rangelow)
BOOLEAN | SimAuxHandler::GetCcp (UINT idx, CcpData &data)
const UINT8 * | SimMexeCertificate::GetCertBuffer () const
return the pointer to the certificate payload
UINT16 | MexeDescriptor::GetCertLength () const
UINT16 | MexeDescriptor::GetCertOffset () const
UINT16 | SimMexeCertificate::GetCertSize () const
returns the size of the certificate payload
UINT | SimMexeCertificate::GetCertType () const
returns the type of the certificate: 0=WTLS, 1=X509, 2=X9.68, other values means reserved
UINT | MexeDescriptor::GetCertType () const
BOOLEAN | SimAuxHandler::GetCmi (UINT idx, WString &alphaid, UINT8 &cmi)
BOOLEAN | SimAuxHandler::GetEcc (UINT idx, WString &eccstr)
UINT8 | SimAuxHandler::GetEccCount () const
BOOLEAN | SimAuxHandler::GetEmlppSetupCallCondition (EmlppPriorityLevel idx, BOOLEAN &condition)
BOOLEAN | SimAuxHandler::GetEmlppSubscription (EmlppPriorityLevel idx, BOOLEAN &subscribed)
BOOLEAN | SimAuxHandler::GetEonsPlmnName (const BcdPlmn &checkplmn, UINT16 lac, WString &longname, WString &shortname)
WString | SimAuxHandler::GetExtLanguage (INT idx, INT instance_nr) const
UINT8 | SimAuxHandler::GetExtLanguageCount (INT instance_nr) const
BOOLEAN | SimAuxHandler::GetFdnState () const
BOOLEAN | SimAuxHandler::GetIccidString (WString &iccid) const
BOOLEAN | SimAuxHandler::GetImeiString (WString &imei)
BcdPlmn | SimAuxHandler::GetImsiBcdPlmn () const
BOOLEAN | SimAuxHandler::GetImsiString (WString &imsi) const
SimInitResult | SimAuxHandler::GetInitResult () const
UINT8 * | SimMexeCertificate::GetKeyIdBuffer () const
returns the buffer which contains the key id
UINT8 * | MexeDescriptor::GetKeyIdBuffer () const
UINT8 | SimMexeCertificate::GetKeyIdLength () const
returns length of key id
UINT8 | MexeDescriptor::GetKeyIdLength () const
UINT16 | OplEntry::GetLacHigh () const
UINT16 | OplEntry::GetLacLow () const
Language | SimAuxHandler::GetLanguage (INT idx) const
UINT8 | SimAuxHandler::GetLanguageCount () const
BOOLEAN | SimAuxHandler::GetLocationBcdPlmn (BcdPlmn &plmn)
BOOLEAN | SimAuxHandler::GetLocationLac (UINT16 &lac)
BOOLEAN | SimAuxHandler::GetLocationUpdateStatus (LocationUpdateStatus &status)
BOOLEAN | SimAuxHandler::GetMaxAcm (UINT32 &value)
UINT8 | SimAuxHandler::GetMaxCbmiCount () const
UINT8 | SimAuxHandler::GetMaxCbmiRangeCount () const
UINT8 | SimAuxHandler::GetMaxCcpCount () const
UINT8 | SimAuxHandler::GetMaxCmiCount () const
UINT8 | SimAuxHandler::GetMaxExtLangCount (INT instance_nr) const
UINT8 | SimAuxHandler::GetMaxLangCount () const
UINT8 | SimAuxHandler::GetMaxMbiCount () const
UINT8 | SimAuxHandler::GetMaxPlmnCount () const
BOOLEAN | SimAuxHandler::GetMbiRecord (UINT idx, UINT8 *buffer)
UINT8 | SimAuxHandler::GetMbiRecordSize () const
MexeCertType | SimMexeCertificate::GetMexeCertType () const
returns the type of the certificate where it is residing on SIM/USIM: ORPK,ARPK,TPRPK
MexeCertType | MexeDescriptor::GetMexeCertType () const
UINT16 | SimAuxHandler::GetPlmnAct (INT idx) const
UINT8 | SimAuxHandler::GetPlmnCount () const
INT | OplEntry::GetPnnRecordId ()
BOOLEAN | SimAuxHandler::GetPuctData (WString &currencycode, UINT &eppu, INT &exponent)
BOOLEAN | SimAuxHandler::GetServiceValues (UINT idx, BOOLEAN &allocated, BOOLEAN &activated)
BOOLEAN | SimAuxHandler::GetSimErrorCode (SimErrorCode &errorcode) const
SimFileId | MexeDescriptor::GetSimFileId () const
BOOLEAN | SimAuxHandler::GetSimInfo (SimInfo &siminfo) const
BOOLEAN | SimAuxHandler::GetSimLockStates (SimLockStates &lockstates) const
SimMexeCertificate * | SimAuxHandler::GetSimMexeCertificate (UINT idx)
UINT | SimAuxHandler::GetSimMexeCertificateCount () const
BOOLEAN | SimAuxHandler::GetSpnData (WString &spnstr, BOOLEAN &condition)
UINT8 | SimAuxHandler::GetSstCount () const
BOOLEAN | OplEntry::HasEntireLacRange () const
BOOLEAN | OplEntry::HasPnnRecordId () const
BOOLEAN | SimAuxHandler::InitMexe ()
BOOLEAN | SimAuxHandler::InsertExtLanguage (INT idx, const WString &language, INT instance_nr)
BOOLEAN | SimAuxHandler::InsertLanguage (INT idx, Language language)
BOOLEAN | SimAuxHandler::InsertPlmn (INT idx, BcdPlmn plmn)
BOOLEAN | SimAuxHandler::InsertPlmnwAct (INT idx, BcdPlmn plmn, UINT16 rat)
BOOLEAN | SimMexeCertificate::IsAuthorityCert () const
returns if the certificate identify an authority as defined in the descriptor
BOOLEAN | MexeDescriptor::IsAuthorityCert () const
BOOLEAN | OplEntry::IsBcdPlmnMatching (BcdPlmn checkplmn) const
BOOLEAN | SimAuxHandler::IsOfmToBeActivated ()
BOOLEAN | SimAuxHandler::IsPlmnwactPresent ()
BOOLEAN | SimAuxHandler::IsSimRefreshPossible () const
BOOLEAN | SimAuxHandler::IsSimResetPossible () const
BOOLEAN | SimMexeCertificate::IsValid () const
returns if the certificate is valid as defined in the parameter indicator of the descriptor
BOOLEAN | MexeDescriptor::IsValid () const
BOOLEAN | SimAuxHandler::LookupPlmnName (const Plmn &plmn, WString &longname, WString &shortname, NetType &nettype, WString &countryname)
void | SimAuxHandler::MarkAcmMaxUnread ()
void | SimAuxHandler::MarkAcmUnread ()
void | SimAuxHandler::MarkCbmirUnread ()
void | SimAuxHandler::MarkCbmiUnread ()
void | SimAuxHandler::MarkCcpUnread ()
void | SimAuxHandler::MarkEccUnread ()
void | SimAuxHandler::MarkImsiUnread ()
void | SimAuxHandler::MarkPrefExtLangUnread ()
void | SimAuxHandler::MarkPrefLangUnread ()
void | SimAuxHandler::MarkPrefPlmnUnread ()
void | SimAuxHandler::MarkPuctUnread ()
void | SimAuxHandler::MarkSpnUnread ()
void | SimAuxHandler::MarkSstUnread ()
OplEntry::OplEntry (const UINT8 *buffer)
void | SimAuxHandler::Reset ()
BOOLEAN | SimAuxHandler::RetrieveCbmi ()
BOOLEAN | SimAuxHandler::RetrieveCbmiRanges ()
BOOLEAN | SimAuxHandler::RetrieveCcp ()
BOOLEAN | SimAuxHandler::RetrieveCmi ()
BOOLEAN | SimAuxHandler::RetrieveEccList ()
BOOLEAN | SimAuxHandler::RetrieveEonsData (BOOLEAN pnnenabled, BOOLEAN oplenabled)
BOOLEAN | SimAuxHandler::RetrieveExtLanguageList (INT instance_nr)
BOOLEAN | SimAuxHandler::RetrieveLanguageList ()
BOOLEAN | SimAuxHandler::RetrieveLociData (LociData &locidata)
BOOLEAN | SimAuxHandler::RetrieveMbi ()
BOOLEAN | SimAuxHandler::RetrievePlmnList ()
BOOLEAN | SimAuxHandler::RetrievePlmnwactList ()
BOOLEAN | SimAuxHandler::RetrieveSst ()
void | SimAuxHandler::SetActiveExtLanguage (const WString &language)
void | SimAuxHandler::SetImsi (const Imsi &imsi)
void | SimAuxHandler::SetInitResult (const SimInitResult &initresult)
void | SimAuxHandler::SetSimErrorCode (const SimErrorCode errorcode)
void | SimAuxHandler::SetSimLockStatus (const SimLockStates &lockstates)
void | SimAuxHandler::SetSimRefreshPossible (BOOLEAN refreshable)
void | SimAuxHandler::SetSimResetPossible (BOOLEAN resetable)
SimAuxHandler::SimAuxHandler ()
BOOLEAN | SimAuxHandler::UpdateAcm (UINT32 value, AcmSelector selector=Acm1)
BOOLEAN | SimAuxHandler::UpdateCbmi (UINT idx, UINT16 cbmi)
BOOLEAN | SimAuxHandler::UpdateCbmiRange (UINT idx, UINT16 rangehigh, UINT16 rangelow)
BOOLEAN | SimAuxHandler::UpdateCcp (UINT idx, const CcpData &data)
BOOLEAN | SimAuxHandler::UpdateExtLanguage (INT idx, const WString &language, INT instance_nr)
BOOLEAN | SimAuxHandler::UpdateLanguage (INT idx, Language language)
BOOLEAN | SimAuxHandler::UpdateMaxAcm (UINT32 value)
BOOLEAN | SimAuxHandler::UpdateMbiRecord (UINT idx, const UINT8 *buffer)
BOOLEAN | SimAuxHandler::UpdatePlmn (INT idx, BcdPlmn plmn)
BOOLEAN | SimAuxHandler::UpdatePlmnwAct (INT idx, BcdPlmn plmn, UINT16 rat)
BOOLEAN | SimAuxHandler::UpdatePuctData (const WString &currencycode, UINT eppu, INT exponent)
MexeDescriptor::~MexeDescriptor ()
virtual | SimAuxHandler::~SimAuxHandler ()
SimMexeCertificate::~SimMexeCertificate ()
destructor only deleted the payload certbuffer, descriptor must be held by APOXI

Variables

const INT | c_attempts_left_undefined = 0xff
const GenericTypeId | c_compound_sms_item_type = c_apoxi_base_gentypes + 2
const GenericTypeId | c_compound_tpdu_item_type = c_apoxi_base_gentypes + 3
const INT | c_cphs_sst_count = c_cphs_sst_len*4
const INT | c_cphs_sst_len = 2
const UINT8 | c_default_max_pdu_per_sms = 255
const INT | c_invalid_position = -2
const INT | c_max_cbmi = 30
const INT | c_max_cbmir = 30
const INT | c_max_ccp = 5
const INT | c_max_cmi_records = 10
const INT | c_max_ecc_records = 10
const INT | c_max_ext_lang_buffer_size = c_max_extlanguages*2
const INT | c_max_extlanguages = 30
const INT | c_max_lang_buffer_size = c_max_languages*1
const INT | c_max_languages = 30
const INT | c_max_mbi_record_length = 5
const UINT16 | c_max_nvram_pdus = DR_MAX_NVRAM_SMS
const UINT16 | c_max_pdus = c_max_sim_pdus + c_max_nvram_pdus + c_max_smsr_pdus
const INT | c_max_plmn_buffer_size = c_max_plmns*3
const INT | c_max_plmns = 50
const INT16 | c_max_reloadable_pdus = 30
const UINT16 | c_max_sim_pdus = DR_MAX_SUPPORTED_SIM_SMS
const INT | c_max_smsparameters = 10
const UINT16 | c_max_smsr_in_ram = 5
const UINT16 | c_max_smsr_length = 40
const UINT16 | c_max_smsr_pdus = 20
const UINT16 | c_max_table1 = c_max_pdus/2
const UINT16 | c_max_table2 = c_max_pdus - c_max_table1
const INT | c_op_srt_name_file_len = 10
const INT | c_size_smsparameters = 28
const INT | c_smsp_rw_buffer_len = c_max_smsparam_entry_len
const SimPbEntry *const | c_unread_entry = (SimPbEntry *)-1
UINT8 | OplEntry::m_buffer [c_opl_buffer_len]
UINT8 | SimAuxHandler::ExtLanguageBuffer::m_ext_lang_count
ExtLanguage SimAuxHandler::ExtLanguageBuffer::m_ext_lang_list [c_max_extlanguages]
UINT8 | SimAuxHandler::ExtLanguageBuffer::m_ext_lang_max_count
BOOLEAN | PnnEntry::m_longci
WString PnnEntry::m_longname
BOOLEAN | PnnEntry::m_shortci
WString PnnEntry::m_shortname

Enumeration Type Documentation

enum ConcatenetedStatus

Enumerator:
NormalSms
ConcatenetedSms
PartlyConcatenetedSms
InvalidSms

enum MexeCertType

MexeCertType describes the different types of cerificates stored in the DF-Mexe directory.

Enumerator:
OperatorRootPublicKey
AdministratorRootPublicKey
ThirdPartyRootPublicKey

enum SmsDeleteStatus

Enumerator:
SmsDeleteRead
SmsDeleteUnread
SmsDeleteSent
SmsDeleteUnsent

enum SmsFilterType

Enumerator:
AllSmsFilterType
UnreadSmsFilterType
ReadSmsFilterType
UnsentSmsFilterType
SentSmsFilterType

enum TpduCountType

Enumerator:
SimTpdus
NvramTpdus
SmsReportTpdus
OverallTpdus
NoOfCountTypes

Function Documentation

BOOLEAN SimAuxHandler::CheckSpnData | ( | const Plmn & | regplmn,
 |  | BOOLEAN & | showregplmn,
 |  | BOOLEAN & | showspnname,
 |  | WString & | spnname,
 |  | BOOLEAN | use_spn_display_condition
 | ) | [inherited]

BOOLEAN SimAuxHandler::DeleteAllExtLanguages ( INT instance_nr ) [inherited]

BOOLEAN SimAuxHandler::DeleteAllLanguages ( ) [inherited]

BOOLEAN SimAuxHandler::DeleteAllPlmns ( ) [inherited]

BOOLEAN SimAuxHandler::DeleteAllPlmnwAct ( ) [inherited]

BOOLEAN SimAuxHandler::DeleteExtLanguage | ( | INT | idx,
 |  | INT | instance_nr
 | ) | [inherited]

BOOLEAN SimAuxHandler::DeleteLanguage ( INT idx ) [inherited]

BOOLEAN SimAuxHandler::DeletePlmn ( INT idx ) [inherited]

BOOLEAN SimAuxHandler::DeletePlmnwAct ( INT idx ) [inherited]

BOOLEAN SimAuxHandler::DetectChvProtection | ( | UINT16 | fileid,
 |  | ChvNo & | chvno
 | ) | [inherited]

INT FindFirstByte | ( | const UINT8 * | address,
 |  | INT | size,
 |  | UINT8 | eos
 | ) |

BOOLEAN SimAuxHandler::GetAcm | ( | UINT32 & | value,
 |  | AcmSelector | selector = Acm1
 | ) | [inherited]

WString SimAuxHandler::GetActiveExtLanguage ( ) const [inherited]

BcdPlmn SimAuxHandler::GetBcdPlmn ( INT idx ) const [inherited]

BcdPlmn SimAuxHandler::GetBcdPlmnwAct ( INT idx ) const [inherited]

BOOLEAN SimAuxHandler::GetCbmi | ( | UINT | idx,
 |  | UINT16 & | cbmi
 | ) | [inherited]

BOOLEAN SimAuxHandler::GetCbmiRange | ( | UINT | idx,
 |  | UINT16 & | rangehigh,
 |  | UINT16 & | rangelow
 | ) | [inherited]

BOOLEAN SimAuxHandler::GetCcp | ( | UINT | idx,
 |  | CcpData & | data
 | ) | [inherited]

const UINT8* SimMexeCertificate::GetCertBuffer ( ) const [inline, inherited]

return the pointer to the certificate payload

UINT16 MexeDescriptor::GetCertLength ( ) const [inline, inherited]

UINT16 MexeDescriptor::GetCertOffset ( ) const [inline, inherited]

UINT16 SimMexeCertificate::GetCertSize ( ) const [inline, inherited]

returns the size of the certificate payload

UINT SimMexeCertificate::GetCertType ( ) const [inline, inherited]

returns the type of the certificate: 0=WTLS, 1=X509, 2=X9.68, other values means reserved

UINT MexeDescriptor::GetCertType ( ) const [inline, inherited]

BOOLEAN SimAuxHandler::GetCmi | ( | UINT | idx,
 |  | WString & | alphaid,
 |  | UINT8 & | cmi
 | ) | [inherited]

BOOLEAN SimAuxHandler::GetEcc | ( | UINT | idx,
 |  | WString & | eccstr
 | ) | [inherited]

UINT8 SimAuxHandler::GetEccCount ( ) const [inherited]

BOOLEAN SimAuxHandler::GetEmlppSetupCallCondition | ( | EmlppPriorityLevel | idx,
 |  | BOOLEAN & | condition
 | ) | [inherited]

BOOLEAN SimAuxHandler::GetEmlppSubscription | ( | EmlppPriorityLevel | idx,
 |  | BOOLEAN & | subscribed
 | ) | [inherited]

BOOLEAN SimAuxHandler::GetEonsPlmnName | ( | const BcdPlmn & | checkplmn,
 |  | UINT16 | lac,
 |  | WString & | longname,
 |  | WString & | shortname
 | ) | [inherited]

WString SimAuxHandler::GetExtLanguage | ( | INT | idx,
 |  | INT | instance_nr
 | ) | const [inherited]

UINT8 SimAuxHandler::GetExtLanguageCount ( INT instance_nr ) const [inherited]

BOOLEAN SimAuxHandler::GetFdnState ( ) const [inherited]

BOOLEAN SimAuxHandler::GetIccidString ( WString & iccid ) const [inherited]

BOOLEAN SimAuxHandler::GetImeiString ( WString & imei ) [inherited]

BcdPlmn SimAuxHandler::GetImsiBcdPlmn ( ) const [inherited]

BOOLEAN SimAuxHandler::GetImsiString ( WString & imsi ) const [inherited]

SimInitResult SimAuxHandler::GetInitResult ( ) const [inherited]

UINT8* SimMexeCertificate::GetKeyIdBuffer ( ) const [inline, inherited]

returns the buffer which contains the key id

UINT8* MexeDescriptor::GetKeyIdBuffer ( ) const [inline, inherited]

UINT8 SimMexeCertificate::GetKeyIdLength ( ) const [inline, inherited]

returns length of key id

UINT8 MexeDescriptor::GetKeyIdLength ( ) const [inline, inherited]

UINT16 OplEntry::GetLacHigh ( ) const [inline, inherited]

UINT16 OplEntry::GetLacLow ( ) const [inline, inherited]

Language SimAuxHandler::GetLanguage ( INT idx ) const [inherited]

UINT8 SimAuxHandler::GetLanguageCount ( ) const [inherited]

BOOLEAN SimAuxHandler::GetLocationBcdPlmn ( BcdPlmn & plmn ) [inherited]

BOOLEAN SimAuxHandler::GetLocationLac ( UINT16 & lac ) [inherited]

BOOLEAN SimAuxHandler::GetLocationUpdateStatus ( LocationUpdateStatus & status ) [inherited]

BOOLEAN SimAuxHandler::GetMaxAcm ( UINT32 & value ) [inherited]

UINT8 SimAuxHandler::GetMaxCbmiCount ( ) const [inherited]

UINT8 SimAuxHandler::GetMaxCbmiRangeCount ( ) const [inherited]

UINT8 SimAuxHandler::GetMaxCcpCount ( ) const [inherited]

UINT8 SimAuxHandler::GetMaxCmiCount ( ) const [inherited]

UINT8 SimAuxHandler::GetMaxExtLangCount ( INT instance_nr ) const [inherited]

UINT8 SimAuxHandler::GetMaxLangCount ( ) const [inherited]

UINT8 SimAuxHandler::GetMaxMbiCount ( ) const [inherited]

UINT8 SimAuxHandler::GetMaxPlmnCount ( ) const [inherited]

BOOLEAN SimAuxHandler::GetMbiRecord | ( | UINT | idx,
 |  | UINT8 * | buffer
 | ) | [inherited]

UINT8 SimAuxHandler::GetMbiRecordSize ( ) const [inherited]

MexeCertType SimMexeCertificate::GetMexeCertType ( ) const [inline, inherited]

returns the type of the certificate where it is residing on SIM/USIM: ORPK,ARPK,TPRPK

MexeCertType MexeDescriptor::GetMexeCertType ( ) const [inline, inherited]

UINT16 SimAuxHandler::GetPlmnAct ( INT idx ) const [inherited]

UINT8 SimAuxHandler::GetPlmnCount ( ) const [inherited]

INT OplEntry::GetPnnRecordId ( ) [inline, inherited]

BOOLEAN SimAuxHandler::GetPuctData | ( | WString & | currencycode,
 |  | UINT & | eppu,
 |  | INT & | exponent
 | ) | [inherited]

BOOLEAN SimAuxHandler::GetServiceValues | ( | UINT | idx,
 |  | BOOLEAN & | allocated,
 |  | BOOLEAN & | activated
 | ) | [inherited]

BOOLEAN SimAuxHandler::GetSimErrorCode ( SimErrorCode & errorcode ) const [inherited]

SimFileId MexeDescriptor::GetSimFileId ( ) const [inline, inherited]

BOOLEAN SimAuxHandler::GetSimInfo ( SimInfo & siminfo ) const [inherited]

BOOLEAN SimAuxHandler::GetSimLockStates ( SimLockStates & lockstates ) const [inherited]

SimMexeCertificate * SimAuxHandler::GetSimMexeCertificate ( UINT idx ) [inherited]

UINT SimAuxHandler::GetSimMexeCertificateCount ( ) const [inline, inherited]

BOOLEAN SimAuxHandler::GetSpnData | ( | WString & | spnstr,
 |  | BOOLEAN & | condition
 | ) | [inherited]

UINT8 SimAuxHandler::GetSstCount ( ) const [inherited]

BOOLEAN OplEntry::HasEntireLacRange ( ) const [inline, inherited]

BOOLEAN OplEntry::HasPnnRecordId ( ) const [inline, inherited]

BOOLEAN SimAuxHandler::InitMexe ( ) [inherited]

BOOLEAN SimAuxHandler::InsertExtLanguage | ( | INT | idx,
 |  | const WString & | language,
 |  | INT | instance_nr
 | ) | [inherited]

BOOLEAN SimAuxHandler::InsertLanguage | ( | INT | idx,
 |  | Language | language
 | ) | [inherited]

BOOLEAN SimAuxHandler::InsertPlmn | ( | INT | idx,
 |  | BcdPlmn | plmn
 | ) | [inherited]

BOOLEAN SimAuxHandler::InsertPlmnwAct | ( | INT | idx,
 |  | BcdPlmn | plmn,
 |  | UINT16 | rat
 | ) | [inherited]

BOOLEAN SimMexeCertificate::IsAuthorityCert ( ) const [inline, inherited]

returns if the certificate identify an authority as defined in the descriptor

BOOLEAN MexeDescriptor::IsAuthorityCert ( ) const [inline, inherited]

BOOLEAN OplEntry::IsBcdPlmnMatching ( BcdPlmn checkplmn ) const [inline, inherited]

BOOLEAN SimAuxHandler::IsOfmToBeActivated ( ) [inherited]

BOOLEAN SimAuxHandler::IsPlmnwactPresent ( ) [inline, inherited]

BOOLEAN SimAuxHandler::IsSimRefreshPossible ( ) const [inherited]

BOOLEAN SimAuxHandler::IsSimResetPossible ( ) const [inherited]

BOOLEAN SimMexeCertificate::IsValid ( ) const [inline, inherited]

returns if the certificate is valid as defined in the parameter indicator of the descriptor

BOOLEAN MexeDescriptor::IsValid ( ) const [inline, inherited]

BOOLEAN SimAuxHandler::LookupPlmnName | ( | const Plmn & | plmn,
 |  | WString & | longname,
 |  | WString & | shortname,
 |  | NetType & | nettype,
 |  | WString & | countryname
 | ) | [inherited]

void SimAuxHandler::MarkAcmMaxUnread ( ) [inline, inherited]

void SimAuxHandler::MarkAcmUnread ( ) [inline, inherited]

void SimAuxHandler::MarkCbmirUnread ( ) [inline, inherited]

void SimAuxHandler::MarkCbmiUnread ( ) [inline, inherited]

void SimAuxHandler::MarkCcpUnread ( ) [inline, inherited]

void SimAuxHandler::MarkEccUnread ( ) [inline, inherited]

void SimAuxHandler::MarkImsiUnread ( ) [inline, inherited]

void SimAuxHandler::MarkPrefExtLangUnread ( ) [inline, inherited]

void SimAuxHandler::MarkPrefLangUnread ( ) [inline, inherited]

void SimAuxHandler::MarkPrefPlmnUnread ( ) [inline, inherited]

void SimAuxHandler::MarkPuctUnread ( ) [inline, inherited]

void SimAuxHandler::MarkSpnUnread ( ) [inline, inherited]

void SimAuxHandler::MarkSstUnread ( ) [inline, inherited]

OplEntry::OplEntry ( const UINT8 * buffer ) [inline, inherited]

void SimAuxHandler::Reset ( ) [inherited]

BOOLEAN SimAuxHandler::RetrieveCbmi ( ) [inherited]

BOOLEAN SimAuxHandler::RetrieveCbmiRanges ( ) [inherited]

BOOLEAN SimAuxHandler::RetrieveCcp ( ) [inherited]

BOOLEAN SimAuxHandler::RetrieveCmi ( ) [inherited]

BOOLEAN SimAuxHandler::RetrieveEccList ( ) [inherited]

BOOLEAN SimAuxHandler::RetrieveEonsData | ( | BOOLEAN | pnnenabled,
 |  | BOOLEAN | oplenabled
 | ) | [inherited]

BOOLEAN SimAuxHandler::RetrieveExtLanguageList ( INT instance_nr ) [inherited]

BOOLEAN SimAuxHandler::RetrieveLanguageList ( ) [inherited]

BOOLEAN SimAuxHandler::RetrieveLociData ( LociData & locidata ) [inherited]

BOOLEAN SimAuxHandler::RetrieveMbi ( ) [inherited]

BOOLEAN SimAuxHandler::RetrievePlmnList ( ) [inherited]

BOOLEAN SimAuxHandler::RetrievePlmnwactList ( ) [inherited]

BOOLEAN SimAuxHandler::RetrieveSst ( ) [inherited]

void SimAuxHandler::SetActiveExtLanguage ( const WString & language ) [inherited]

void SimAuxHandler::SetImsi ( const Imsi & imsi ) [inherited]

void SimAuxHandler::SetInitResult ( const SimInitResult & initresult ) [inherited]

void SimAuxHandler::SetSimErrorCode ( const SimErrorCode errorcode ) [inherited]

void SimAuxHandler::SetSimLockStatus ( const SimLockStates & lockstates ) [inherited]

void SimAuxHandler::SetSimRefreshPossible ( BOOLEAN refreshable ) [inherited]

void SimAuxHandler::SetSimResetPossible ( BOOLEAN resetable ) [inherited]

SimAuxHandler::SimAuxHandler ( ) [inherited]

BOOLEAN SimAuxHandler::UpdateAcm | ( | UINT32 | value,
 |  | AcmSelector | selector = Acm1
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdateCbmi | ( | UINT | idx,
 |  | UINT16 | cbmi
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdateCbmiRange | ( | UINT | idx,
 |  | UINT16 | rangehigh,
 |  | UINT16 | rangelow
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdateCcp | ( | UINT | idx,
 |  | const CcpData & | data
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdateExtLanguage | ( | INT | idx,
 |  | const WString & | language,
 |  | INT | instance_nr
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdateLanguage | ( | INT | idx,
 |  | Language | language
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdateMaxAcm ( UINT32 value ) [inherited]

BOOLEAN SimAuxHandler::UpdateMbiRecord | ( | UINT | idx,
 |  | const UINT8 * | buffer
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdatePlmn | ( | INT | idx,
 |  | BcdPlmn | plmn
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdatePlmnwAct | ( | INT | idx,
 |  | BcdPlmn | plmn,
 |  | UINT16 | rat
 | ) | [inherited]

BOOLEAN SimAuxHandler::UpdatePuctData | ( | const WString & | currencycode,
 |  | UINT | eppu,
 |  | INT | exponent
 | ) | [inherited]

MexeDescriptor::~MexeDescriptor ( ) [inline, inherited]

SimAuxHandler::~SimAuxHandler ( ) [virtual, inherited]

SimMexeCertificate::~SimMexeCertificate ( ) [inline, inherited]

destructor only deleted the payload certbuffer, descriptor must be held by APOXI

Variable Documentation

const INT c_attempts_left_undefined = 0xff

em>SimChvHandler is the class which allows verifying and changing Pins.

const GenericTypeId c_compound_sms_item_type = c_apoxi_base_gentypes + 2

em>CompoundSmsItem is an class which objects will be returned by the smsproviders and represents an non- or conacteneted ems. Iterating over the object allows retrieveing information elements and strings conatined in the esms.

const GenericTypeId c_compound_tpdu_item_type = c_apoxi_base_gentypes + 3

const INT c_cphs_sst_count = c_cphs_sst_len*4

const INT c_cphs_sst_len = 2

const UINT8 c_default_max_pdu_per_sms = 255

const INT c_invalid_position = -2

const INT c_max_cbmi = 30

const INT c_max_cbmir = 30

const INT c_max_ccp = 5

const INT c_max_cmi_records = 10

const INT c_max_ecc_records = 10

const INT c_max_ext_lang_buffer_size = c_max_extlanguages*2

const INT c_max_extlanguages = 30

const INT c_max_lang_buffer_size = c_max_languages*1

const INT c_max_languages = 30

const INT c_max_mbi_record_length = 5

const UINT16 c_max_nvram_pdus = DR_MAX_NVRAM_SMS

const UINT16 c_max_pdus = c_max_sim_pdus + c_max_nvram_pdus + c_max_smsr_pdus

const INT c_max_plmn_buffer_size = c_max_plmns*3

const INT c_max_plmns = 50

const INT16 c_max_reloadable_pdus = 30

const UINT16 c_max_sim_pdus = DR_MAX_SUPPORTED_SIM_SMS

const INT c_max_smsparameters = 10

const UINT16 c_max_smsr_in_ram = 5

const UINT16 c_max_smsr_length = 40

const UINT16 c_max_smsr_pdus = 20

const UINT16 c_max_table1 = c_max_pdus/2

const UINT16 c_max_table2 = c_max_pdus - c_max_table1

const INT c_op_srt_name_file_len = 10

const INT c_size_smsparameters = 28

const INT c_smsp_rw_buffer_len = c_max_smsparam_entry_len

const SimPbEntry* const c_unread_entry = (SimPbEntry *)-1

UINT8 OplEntry::m_buffer[c_opl_buffer_len] [inherited]

UINT8 SimAuxHandler::ExtLanguageBuffer::m_ext_lang_count [inherited]

ExtLanguage SimAuxHandler::ExtLanguageBuffer::m_ext_lang_list[c_max_extlanguages] [inherited]

UINT8 SimAuxHandler::ExtLanguageBuffer::m_ext_lang_max_count [inherited]

BOOLEAN PnnEntry::m_longci [inherited]

WString PnnEntry::m_longname [inherited]

BOOLEAN PnnEntry::m_shortci [inherited]

WString PnnEntry::m_shortname [inherited]

Generated on Wed Jan 25 02:25:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HTTPWAPIF

HTTPWAPIF

Data Structures

struct | comm_root_cert
struct | comm_user_cert
class | HttpHandler
class | HttpWapMgr
class | HttpWapMgrBase
class | HttpWapMgrPlugin
class | WapHandler
class | WapProfile
class | WapProfileMgr

Defines

#define | APOXI_MAX_CONN_LIMIT 100
#define | MAXREQUESTLIMIT 100

Typedefs

typedef comm_root_cert | COMM_ROOT_CERT
typedef comm_user_cert | COMM_USER_CERT
typedef UINT8 | WapProfileId

Define Documentation

#define APOXI_MAX_CONN_LIMIT 100

This interface defines the functionality of an HTTP manager:

  • opening an HTTP connection,
  • initiating HTTP GET, HEAD and POST requests,
  • closing an HTTP connection,
  • querying the status of the HTTP connection. There is no function available for querying the status of individual requests, since this can only be done in a sensible manner by the appli- cation itself. There also are no functions for registering/unregistering an application, since HttpHandler objects are automatically registered for HttpResponseMsg messages through the implementation of the OnMessage function.

This interface also defines the functionality of a WAP manager:

  • registering for WAP push messages,
  • unregistering for WAP push messages,
  • suspending and resuming the WAP connection (=session),
  • querying the status of the WAP connection (=session).

Since the function calls lead to asynchronous calls on communication stacks, the return values of the functions indicate the success of the functions and generally not of the success of the events in the communication stack or beyond.

#define MAXREQUESTLIMIT 100

Typedef Documentation

typedef struct comm_root_cert COMM_ROOT_CERT

typedef struct comm_user_cert COMM_USER_CERT

typedef UINT8 WapProfileId

Generated on Wed Jan 25 02:25:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Add Ons

Add Ons

Collaboration diagram for Add Ons:

Modules

AuxExtensions
CodecManager
Digital Rights Management
GuiInputExtensions
GUI Menu Accessors
MediaFramework
MultiMedia
Services
Svg
T9
Translation
Voice Recognition
Generated on Wed Jan 25 02:25:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AuxExtensions

AuxExtensions
[Add Ons]

Collaboration diagram for AuxExtensions:

Data Structures

class | AppendProvider
class | DualFilterProvider
class | JoinProvider
class | JoinProviderListener
class | JoinRule
class | MergeProvider
class | PhoneNumberJoinRule
class | PhoneNumberMergeProvider
class | StandardJoinRule
StandardJoinRule is a paramaterizable rule for standard relations More...

Functions

virtual BOOLEAN | AppendProvider::AddChildProvider (Provider *provider)
em>RemoveChildProvider from the Vector<Provider*> of the AppendProvider
AppendProvider::AppendProvider ()
Constructor.
virtual BOOLEAN | AppendProvider::AppendRow ()
em>DeleteAllRows of the AppendProvider
virtual BOOLEAN | AppendProvider::DeleteAllRows (ProviderListener *listener=0)
em>AddChildProvider to the Vector<Provider*> of the AppendProvider
virtual BOOLEAN | AppendProvider::GetChildRow (INT &childrow, INT row)
virtual BOOLEAN | AppendProvider::GetDataItem (INT columnid, INT row, DataItem &item)
em>GetChildRow returns GetMappedRow
virtual BOOLEAN | AppendProvider::GetMappedRow (INT &mappedrow, INT row)
virtual INT | AppendProvider::GetProgress ()
GetProgress of the ProviderListener
virtual INT | AppendProvider::GetProviderId () const
Returns the ProviderId.
virtual INT | AppendProvider::GetSortedColumnId () const
void | AppendProvider::Init ()
virtual BOOLEAN | AppendProvider::Lock ()
Lock locks the child-provider.
virtual INT | AppendProvider::MaxRowCount ()
Returns the RowCount of the AppendProvider.
virtual void | AppendProvider::OnChildProviderModification (Provider *provider, const Provider::Modification &modification)
virtual void | AppendProvider::OnExecutingListener (Provider *provider=0)
virtual BOOLEAN | AppendProvider::RemoveChildProvider (Provider *provider)
virtual INT | AppendProvider::RowCount ()
Returns the RowCount of the AppendProvider.
virtual BOOLEAN | AppendProvider::SetParameter (const DataItem &item)
void | AppendProvider::SetProviderId (INT provider_id)
SetProviderId of AppendProvider.
virtual BOOLEAN | AppendProvider::Unlock ()
Unlock unlocks the child-provider.
virtual BOOLEAN | AppendProvider::Update (ProviderListener *listener=0)
virtual | AppendProvider::~AppendProvider ()
Destructor.

Variables

const INT | c_first_provider_id = 6203
const INT | c_first_provider_row_id = 6201
const INT | c_key_column_id = 6200
const INT | c_merged_provider_id = 6216
const INT | c_merged_row_id = 6215
const INT | c_second_provider_id = 6204
const INT | c_second_provider_row_id = 6202

Function Documentation

BOOLEAN AppendProvider::AddChildProvider ( Provider * provider ) [virtual, inherited]

em>RemoveChildProvider from the Vector<Provider*> of the AppendProvider

AppendProvider::AppendProvider ( ) [inherited]

Constructor.

BOOLEAN AppendProvider::AppendRow ( ) [virtual, inherited]

em>DeleteAllRows of the AppendProvider

Return FALSE. Appending of a row is not supported in AppendProvider.

Returns:
FALSE

Reimplemented from AbstractDelegationProvider.

BOOLEAN AppendProvider::DeleteAllRows ( ProviderListener * listener = 0 ) [virtual, inherited]

em>AddChildProvider to the Vector<Provider*> of the AppendProvider

Reimplemented from AbstractDelegationProvider.

BOOLEAN AppendProvider::GetChildRow | ( | INT & | childrow,
 |  | INT | row
 | ) | [virtual, inherited]

GetChildRow returns the effective row of the child-provider.

Implements AbstractDelegationProvider.

BOOLEAN AppendProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual, inherited]

em>GetChildRow returns GetMappedRow

Returns the DataItem from a specific row and columnid

Parameters:
columnid
row
DataItem

Implements AbstractDelegationProvider.

Reimplemented in UibInboxProvider.

BOOLEAN AppendProvider::GetMappedRow | ( | INT & | mappedrow,
 |  | INT | row
 | ) | [protected, virtual, inherited]

Mappes a given row within range of AppendProvider to the row of the ChildProvider. SetChildProvider is used to declare the concrete child provider for this row.

Reimplemented from AbstractDelegationProvider.

INT AppendProvider::GetProgress ( ) [virtual, inherited]

GetProgress of the ProviderListener

Reimplemented from AbstractDelegationProvider.

INT AppendProvider::GetProviderId ( ) const [virtual, inherited]

Returns the ProviderId.

Reimplemented from AbstractDelegationProvider.

INT AppendProvider::GetSortedColumnId ( ) const [virtual, inherited]

GetSortedColumnId of the ChildProvider if AppendProvider contains only one ChildProvider, otherwise returns FALSE

Reimplemented from AbstractDelegationProvider.

void AppendProvider::Init ( ) [inherited]

BOOLEAN AppendProvider::Lock ( ) [virtual, inherited]

Lock locks the child-provider.

Reimplemented from AbstractDelegationProvider.

INT AppendProvider::MaxRowCount ( ) [virtual, inherited]

Returns the RowCount of the AppendProvider.

Reimplemented from AbstractDelegationProvider.

void AppendProvider::OnChildProviderModification | ( | Provider * | provider,
 |  | const Provider::Modification & | modification
 | ) | [protected, virtual, inherited]

OnChildProviderModification calculates the row that corresponds to the changed row of the childprovider, sets the last modification accordingly and calls NotifyObservers

Reimplemented from AbstractDelegationProvider.

void AppendProvider::OnExecutingListener ( Provider * provider = 0 ) [virtual, inherited]

Called by DelegationProviderListener to modify the progress value. The current version reflects the progress value of the specified provider, or if it is 0, the progress value of the child-provider.

Reimplemented from AbstractDelegationProvider.

BOOLEAN AppendProvider::RemoveChildProvider ( Provider * provider ) [virtual, inherited]

INT AppendProvider::RowCount ( ) [virtual, inherited]

Returns the RowCount of the AppendProvider.

Reimplemented from AbstractDelegationProvider.

BOOLEAN AppendProvider::SetParameter ( const DataItem & item ) [virtual, inherited]

GetColumnInfoPerId reflects GetColumnInfoPerId of the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

void AppendProvider::SetProviderId ( INT provider_id ) [inline, inherited]

SetProviderId of AppendProvider.

BOOLEAN AppendProvider::Unlock ( ) [virtual, inherited]

Unlock unlocks the child-provider.

Reimplemented from AbstractDelegationProvider.

BOOLEAN AppendProvider::Update ( ProviderListener * listener = 0 ) [virtual, inherited]

Update updates the child-provider. Returns FALSE if no child-provider was set.

Reimplemented from AbstractDelegationProvider.

AppendProvider::~AppendProvider ( ) [virtual, inherited]

Destructor.

Variable Documentation

const INT c_first_provider_id = 6203

const INT c_first_provider_row_id = 6201

const INT c_key_column_id = 6200

const INT c_merged_provider_id = 6216

const INT c_merged_row_id = 6215

const INT c_second_provider_id = 6204

const INT c_second_provider_row_id = 6202

Generated on Wed Jan 25 02:25:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CodecManager

CodecManager
[Add Ons]

Collaboration diagram for CodecManager:

Data Structures

class | AtiAudioCapturerEncoder
class | AudioCapturerEncoder
class | AudioDecoder
class | AudioDecoderRenderer
class | AudioEncoder
class | CodecDevice
class | CodecManager
class | VideoDecoder
class | VideoEncoder

Variables

const tGciAudioVolume | GciVolume = 100

Variable Documentation

const tGciAudioVolume GciVolume = 100

Generated on Wed Jan 25 02:25:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Digital Rights Management

Digital Rights Management
[Add Ons]

Collaboration diagram for Digital Rights Management:

Data Structures

struct | BlockData
class | DrmConstraint
struct | DrmMediaObject
class | DrmMessage
class | DrmPermission
class | DrmRelParser
struct | DrmRightsMapTableEntry
class | DrmRightsObject
class | DrmRightsObjectContainer
class | DrmRightsObjectFile
class | DrmRightsObjectStore
class | DrmROStoreSingleton
class | DrmSubsystem
class | DrmUtils
struct | HeaderData
struct | MultiPartData
class | MultipartParser
class | XmlParserRel

Defines

#define | dprintf(x)
This flag will enable the debug prints and testing code fo the host.
#define | DRM_FL_LOCAL_ID APOXI_DRM_RIGHTS_OBJECT_MAX+1
#define | DRM_RIGHTS_OP_NOT_FOUND 3
#define | DRM_RIGHTS_UPDATE_REQUIRED 2
#define | DRM_RO_FILE_PREFIX "adrm"
#define | MULTIPART_COMMENT ';'
#define | MULTIPART_CR '\r'
#define | MULTIPART_ERROR_CONTENT_PARSING -7
#define | MULTIPART_ERROR_FILE_FORMAT -11
#define | MULTIPART_ERROR_HEADER_PARSING -8
#define | MULTIPART_ERROR_INVALID_BOUNDARY -4
#define | MULTIPART_ERROR_INVALID_END -3
#define | MULTIPART_ERROR_INVALID_INPUT -5
#define | MULTIPART_ERROR_INVALID_START -2
#define | MULTIPART_ERROR_INVALID_VALUE -6
#define | MULTIPART_ERROR_NO_HEADER -9
#define | MULTIPART_ERROR_NO_MEMORY -12
#define | MULTIPART_ERROR_REACHED_EOF -10
#define | MULTIPART_ERROR_UNKNOWN -1
#define | MULTIPART_ERROR_VALUE_NOT_FOUND -13
#define | MULTIPART_LF '\n'
#define | MULTIPART_SPACE ' '
#define | MULTIPART_SUCCESS 0
Multipart parsing Error codes.
#define | MULTIPART_TAB '\t'
#define | SKIP_SPACE(b, l) while(*b == MULTIPART_SPACE || *b == MULTIPART_TAB) { b++; l--; }
#define | STR_CONTENT_ENCODING "Content-Transfer-Encoding"
#define | STR_CONTENT_ID "Content-ID"
#define | STR_CONTENT_TYPE "Content-type"
Header names bieng filled inthe vector.
#define | STR_DESCRIPTION "Content-Description"
#define | STR_DISPOSITION "Content-Disposition"

Typedefs

typedef DrmROStoreSingleton | DrmROStore

Enumerations

enum | correction_type { ct_none, ct_negative, ct_positive }
enum date_type {
dt_none, gyear, gmonth, gday,
thour, tmin, tsec, tdiffhour,
tdiffmin
}
enum | DrmXmlFormat { DrmRightsXml, DrmRightsWbxml, DrmRightsNone }
XML Data Type. More...

Functions

void | XmlParserRel::AddDefaultConstraints (DrmPermission *perm)
Default constraints create a Forward Lock object.
void | XmlParserRel::AddDefaultPermissions ()
Default permissions create a Forward Lock object.
s32 | XmlParserRel::Parse ()
static UINT32 | XmlParserRel::ParseDateString (String &date_data, INT &parse_err)
static UINT32 | XmlParserRel::ParseInterval (String &validity_data, INT &parse_err)
virtual s32 | XmlParserRel::XML_Characters_Handler (void *UserData, CHAR *Chars, s32 cbsize)
virtual s32 | XmlParserRel::XML_End_Handler (void *UserData)
virtual s32 | XmlParserRel::XML_EndCData_Handler (void *UserData)
virtual s32 | XmlParserRel::XML_EndElement_Handler (void *UserData, CHAR *uri, CHAR *localname, CHAR *qName)
virtual s32 | XmlParserRel::XML_Error_Handler (INT ErrorCode, INT ErrorLine)
virtual s32 | XmlParserRel::XML_PI_Handler (void *UserData, CHAR *Target, CHAR *Data)
virtual s32 | XmlParserRel::XML_Start_Handler (void *UserData)
virtual s32 | XmlParserRel::XML_StartCData_Handler (void *UserData)
virtual s32 | XmlParserRel::XML_StartElement_Handler (void *UserData, CHAR *uri, CHAR *localname, CHAR *qName, LPVECTOR atts)
XmlParserRel::XmlParserRel (CHAR *s, DrmRelParser &rh)
virtual | XmlParserRel::~XmlParserRel ()

Define Documentation

#define dprintf ( x )

This flag will enable the debug prints and testing code fo the host.

#define DRM_FL_LOCAL_ID APOXI_DRM_RIGHTS_OBJECT_MAX+1

#define DRM_RIGHTS_OP_NOT_FOUND 3

#define DRM_RIGHTS_UPDATE_REQUIRED 2

#define DRM_RO_FILE_PREFIX "adrm"

#define MULTIPART_COMMENT ';'

#define MULTIPART_CR '\r'

#define MULTIPART_ERROR_CONTENT_PARSING -7

#define MULTIPART_ERROR_FILE_FORMAT -11

#define MULTIPART_ERROR_HEADER_PARSING -8

#define MULTIPART_ERROR_INVALID_BOUNDARY -4

#define MULTIPART_ERROR_INVALID_END -3

#define MULTIPART_ERROR_INVALID_INPUT -5

#define MULTIPART_ERROR_INVALID_START -2

#define MULTIPART_ERROR_INVALID_VALUE -6

#define MULTIPART_ERROR_NO_HEADER -9

#define MULTIPART_ERROR_NO_MEMORY -12

#define MULTIPART_ERROR_REACHED_EOF -10

#define MULTIPART_ERROR_UNKNOWN -1

#define MULTIPART_ERROR_VALUE_NOT_FOUND -13

#define MULTIPART_LF '\n'

#define MULTIPART_SPACE ' '

#define MULTIPART_SUCCESS 0

Multipart parsing Error codes.

#define MULTIPART_TAB '\t'

#define SKIP_SPACE | ( | b,
 |  | l | ) | while(*b == MULTIPART_SPACE || *b == MULTIPART_TAB) { b++; l--; }

#define STR_CONTENT_ENCODING "Content-Transfer-Encoding"

#define STR_CONTENT_ID "Content-ID"

#define STR_CONTENT_TYPE "Content-type"

Header names bieng filled inthe vector.

#define STR_DESCRIPTION "Content-Description"

#define STR_DISPOSITION "Content-Disposition"

Typedef Documentation

typedef DrmROStoreSingleton DrmROStore

Enumeration Type Documentation

enum correction_type

Enumerator:
ct_none
ct_negative
ct_positive

enum date_type

Enumerator:
dt_none
gyear
gmonth
gday
thour
tmin
tsec
tdiffhour
tdiffmin

enum DrmXmlFormat

XML Data Type.

Enumerator:
DrmRightsXml
DrmRightsWbxml
DrmRightsNone

Function Documentation

void XmlParserRel::AddDefaultConstraints ( DrmPermission * perm ) [inherited]

Default constraints create a Forward Lock object.

void XmlParserRel::AddDefaultPermissions ( ) [inherited]

Default permissions create a Forward Lock object.

s32 XmlParserRel::Parse ( ) [inline, inherited]

Reimplemented from XMLParser.

UINT32 XmlParserRel::ParseDateString | ( | String & | date_data,
 |  | INT & | parse_err
 | ) | [static, inherited]

UINT32 XmlParserRel::ParseInterval | ( | String & | validity_data,
 |  | INT & | parse_err
 | ) | [static, inherited]

s32 XmlParserRel::XML_Characters_Handler | ( | void * | UserData,
 |  | CHAR * | Chars,
 |  | s32 | cbsize
 | ) | [virtual, inherited]

s32 XmlParserRel::XML_End_Handler ( void * UserData ) [virtual, inherited]

Reimplemented from XMLParser.

s32 XmlParserRel::XML_EndCData_Handler ( void * UserData ) [virtual, inherited]

Reimplemented from XMLParser.

s32 XmlParserRel::XML_EndElement_Handler | ( | void * | UserData,
 |  | CHAR * | uri,
 |  | CHAR * | localname,
 |  | CHAR * | qName
 | ) | [virtual, inherited]

s32 XmlParserRel::XML_Error_Handler | ( | INT | ErrorCode,
 |  | INT | ErrorLine
 | ) | [virtual, inherited]

s32 XmlParserRel::XML_PI_Handler | ( | void * | UserData,
 |  | CHAR * | Target,
 |  | CHAR * | Data
 | ) | [virtual, inherited]

s32 XmlParserRel::XML_Start_Handler ( void * UserData ) [virtual, inherited]

Reimplemented from XMLParser.

s32 XmlParserRel::XML_StartCData_Handler ( void * UserData ) [virtual, inherited]

Reimplemented from XMLParser.

s32 XmlParserRel::XML_StartElement_Handler | ( | void * | UserData,
 |  | CHAR * | uri,
 |  | CHAR * | localname,
 |  | CHAR * | qName,
 |  | LPVECTOR | atts
 | ) | [virtual, inherited]

XmlParserRel::XmlParserRel | ( | CHAR * | s,
 |  | DrmRelParser & | rh
 | ) | [inline, inherited]

XmlParserRel::~XmlParserRel ( ) [virtual, inherited]

Generated on Wed Jan 25 02:25:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiInputExtensions

GuiInputExtensions
[Add Ons]

Collaboration diagram for GuiInputExtensions:

Data Structures

class | AbstractPredictiveInputBox
class | SelectionBox
class | SelectionBoxView
class | StrokeBox
class | StrokeBoxView
class | T9PinyinBox
class | T9PinyinBoxView
class | T9PredictiveInputBox
class | Zi8PredictiveInputBox
Generated on Wed Jan 25 02:25:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GUI Menu Accessors

GUI Menu Accessors
[Add Ons]

Collaboration diagram for GUI Menu Accessors:

Data Structures

class | AbstractActionMenuAccessor
class | AccessorAction
class | AccessorActionExtension
class | ActionMenuAccessor
class | ApplicationAction
class | SubMenuAction
class | TopLevelMenu
Generated on Wed Jan 25 02:25:42 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MediaFramework

MediaFramework
[Add Ons]

Collaboration diagram for MediaFramework:

Data Structures

class | DisplaySettings
class | MediaFrameworkCaps
class | MediaInfo
class | MediaManager
class | MediaPlayer
class | MediaRecorder
class | RecordSettings
Generated on Wed Jan 25 02:25:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: MultiMedia

MultiMedia
[Add Ons]

Collaboration diagram for MultiMedia:

Data Structures

class | AmrSound
Class to handle and decode MIDI sounds. More...
class | AudioItem
struct | BinDataInReadStatusInfo
class | BmpImage
class | BoundedItem
class | CompoundItemIterator
class | CompoundItemReferrer
struct | FileInfo_s
struct | FileInfoInternal_s
struct | FileInReadStatusInfo
class | GeneralCompoundItem
Represents a simple container for Bounded-Editor-Items. More...
class | GifImage
class | ImageItem
struct | JarBinDataStatusInfo
struct | JarFileGlobalInfo_s
struct | JarFileStatusInfo
class | JpegEncoder
class | JpegImage
Class to contain, decompress and draw a JPEG compatible image. More...
class | MultiMediaEditor
class | MultiMediaEditorDocument
class | ParagraphCompoundItem
class | ParagraphMarker
Represents the marker at the end of each Paragraph. More...
class | PngDecoder
Class for decoding PNG images. More...
class | PngEncoder
class | PngEncodingThreadlet
class | PngImage
Class to contain, decompress and draw a PNG compatible image. More...
class | RichTextCompoundItem
class | Unzipper
class | VCardItem
class | WbmpImage

Defines

#define | APOXI_UNZIP_BUFSIZE (256)
#define | BUFREADCOMMENT (0x400)
#define | c_max_level_count 4
#define | MAX_UINT16 65535
#define | SIZECENTRALDIRITEM (0x2e)
#define | SIZEZIPLOCALHEADER (0x1e)
#define | UNZ_BADZIPFILE (-103)
#define | UNZ_CRCERROR (-105)
#define | UNZ_END_OF_LIST_OF_FILE (-100)
#define | UNZ_EOF (0)
#define | UNZ_ERRNO (Z_ERRNO)
#define | UNZ_INTERNALERROR (-104)
#define | UNZ_MAXFILENAMEINZIP (256)
#define | UNZ_OK (0)
#define | UNZ_PARAMERROR (-102)

Typedefs

typedef FileInfo_s | FileInfo
typedef FileInfoInternal_s | FileInfoInternal
typedef UINT8 | JarExtractId
typedef JarFileGlobalInfo_s | JarFileGlobalInfo

Functions

INT16 | CloseBinData (JarBinDataStatusInfo *jar_bindata_status_info)
INT16 | CloseCurrentFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo)
INT16 | CloseCurrentFileFfs (JarFileStatusInfo *jarFileStatusInfo)
INT16 | CloseFfs (JarFileStatusInfo *jar_file_status_info)
INT16 | GetCurrentFileInfoBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo, FileInfo *pfile_info, CHAR *file_name, UINT16 name_size, void *extra_field, UINT16 extra_size, CHAR *file_comment, UINT16 comment_size)
INT16 | GetCurrentFileInfoFfs (JarFileStatusInfo *jar_file_status_info, FileInfo *pfile_info, CHAR *file_name, UINT16 name_size, void *extra_field, UINT16 extra_size, CHAR *file_comment, UINT16 comment_size)
void | JVMa_getFileFromJar (JarExtractId extractionId, BinData *bin_data, const CHAR *fileName)
void | JVMa_getFileFromJar (JarExtractId extractionId, const char *jarFileName, const char *fileName)
void | JVMa_getFileFromJar (JarExtractId extractionId, UINT32 jarFileId, const char *fileName)
INT16 | LocateFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo, const CHAR *szFileName)
INT16 | LocateFileFfs (JarFileStatusInfo *jarFileStatusInfo, const CHAR *szFileName)
INT16 | OpenBinData (JarBinDataStatusInfo *jar_bindata_status_info)
INT16 | OpenCurrentFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo)
INT16 | OpenCurrentFileFfs (JarFileStatusInfo *jarFileStatusInfo)
INT16 | OpenFfs (UINT16 jar_file_id, JarFileStatusInfo *jarFileStatusInfo)
INT16 | OpenFfs (const CHAR *jar_file_name, JarFileStatusInfo *jarFileStatusInfo)
INT16 | ReadCurrentFileBinData (JarBinDataStatusInfo *jar_bin_data_statusinfo, void *buf, UINT16 len)
INT16 | ReadCurrentFileFfs (JarFileStatusInfo *jarFileStatusInfo, void *buf, UINT16 len)

Define Documentation

#define APOXI_UNZIP_BUFSIZE (256)

#define BUFREADCOMMENT (0x400)

#define c_max_level_count 4

#define MAX_UINT16 65535

#define SIZECENTRALDIRITEM (0x2e)

#define SIZEZIPLOCALHEADER (0x1e)

#define UNZ_BADZIPFILE (-103)

#define UNZ_CRCERROR (-105)

#define UNZ_END_OF_LIST_OF_FILE (-100)

#define UNZ_EOF (0)

#define UNZ_ERRNO (Z_ERRNO)

#define UNZ_INTERNALERROR (-104)

#define UNZ_MAXFILENAMEINZIP (256)

#define UNZ_OK (0)

#define UNZ_PARAMERROR (-102)

Typedef Documentation

typedef struct FileInfo_s FileInfo

typedef struct FileInfoInternal_s FileInfoInternal

typedef UINT8 JarExtractId

typedef struct JarFileGlobalInfo_s JarFileGlobalInfo

Function Documentation

INT16 CloseBinData ( JarBinDataStatusInfo * jar_bindata_status_info )

INT16 CloseCurrentFileBinData ( JarBinDataStatusInfo * jar_bin_data_statusinfo )

INT16 CloseCurrentFileFfs ( JarFileStatusInfo * jarFileStatusInfo )

INT16 CloseFfs ( JarFileStatusInfo * jar_file_status_info )

INT16 GetCurrentFileInfoBinData | ( | JarBinDataStatusInfo * | jar_bin_data_statusinfo,
 |  | FileInfo * | pfile_info,
 |  | CHAR * | file_name,
 |  | UINT16 | name_size,
 |  | void * | extra_field,
 |  | UINT16 | extra_size,
 |  | CHAR * | file_comment,
 |  | UINT16 | comment_size
 | ) |

INT16 GetCurrentFileInfoFfs | ( | JarFileStatusInfo * | jar_file_status_info,
 |  | FileInfo * | pfile_info,
 |  | CHAR * | file_name,
 |  | UINT16 | name_size,
 |  | void * | extra_field,
 |  | UINT16 | extra_size,
 |  | CHAR * | file_comment,
 |  | UINT16 | comment_size
 | ) |

void JVMa_getFileFromJar | ( | JarExtractId | extractionId,
 |  | BinData * | bin_data,
 |  | const CHAR * | fileName
 | ) |

void JVMa_getFileFromJar | ( | JarExtractId | extractionId,
 |  | const char * | jarFileName,
 |  | const char * | fileName
 | ) |

void JVMa_getFileFromJar | ( | JarExtractId | extractionId,
 |  | UINT32 | jarFileId,
 |  | const char * | fileName
 | ) |

INT16 LocateFileBinData | ( | JarBinDataStatusInfo * | jar_bin_data_statusinfo,
 |  | const CHAR * | szFileName
 | ) |

INT16 LocateFileFfs | ( | JarFileStatusInfo * | jarFileStatusInfo,
 |  | const CHAR * | szFileName
 | ) |

INT16 OpenBinData ( JarBinDataStatusInfo * jar_bindata_status_info )

INT16 OpenCurrentFileBinData ( JarBinDataStatusInfo * jar_bin_data_statusinfo )

INT16 OpenCurrentFileFfs ( JarFileStatusInfo * jarFileStatusInfo )

INT16 OpenFfs | ( | UINT16 | jar_file_id,
 |  | JarFileStatusInfo * | jarFileStatusInfo
 | ) |

INT16 OpenFfs | ( | const CHAR * | jar_file_name,
 |  | JarFileStatusInfo * | jarFileStatusInfo
 | ) |

INT16 ReadCurrentFileBinData | ( | JarBinDataStatusInfo * | jar_bin_data_statusinfo,
 |  | void * | buf,
 |  | UINT16 | len
 | ) |

INT16 ReadCurrentFileFfs | ( | JarFileStatusInfo * | jarFileStatusInfo,
 |  | void * | buf,
 |  | UINT16 | len
 | ) |

Generated on Wed Jan 25 02:25:49 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Services

Services
[Add Ons]

Collaboration diagram for Services:

Data Structures

class | Guid
class | Service
class | ServiceBroker
class | ServicePtr< T >

Defines

#define | DefGuid_NoGuid {0x0, 0x0, 0x0, {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}}

Typedefs

typedef Service::ServiceResult | ServiceResult

Variables

const INT | c_broker_table_size = 10
const Guid | Guid_NoGuid

Define Documentation

#define DefGuid_NoGuid {0x0, 0x0, 0x0, {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}}

Typedef Documentation

typedef Service::ServiceResult ServiceResult

Variable Documentation

const INT c_broker_table_size = 10

const Guid Guid_NoGuid

Generated on Wed Jan 25 02:26:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Svg

Svg
[Add Ons]

Collaboration diagram for Svg:

Data Structures

struct | S_SvgFixPointTrans
class | SvgFileWrapper
class | SvgGzFileWrapper
class | SvgImage
class | SvgImageFileWrapper
class | SvgIoWrapper
class | SvgMimeUtil
class | SvgPlayer

Defines

#define | SVG_ASSERT(COND)
#define | SVG_DBG_OUT(SECTION, DATA)
#define | SVG_DBG_SECTION_CALLBACK 0x00000002
#define | SVG_DBG_SECTION_DECODER 0x00000001
#define | SVG_DBG_SECTION_FILEWRAPPER 0x00000010
#define | SVG_DBG_SECTION_FIXPOINT 0x00000200
#define | SVG_DBG_SECTION_GZ 0x00000400
#define | SVG_DBG_SECTION_IMAGE 0x00000008
#define | SVG_DBG_SECTION_MEMORY 0x00000020
#define | SVG_DBG_SECTION_MEMORY_PROF 0x00000040
#define | SVG_DBG_SECTION_MIME 0x00000080
#define | SVG_DBG_SECTION_PLAYER 0x00000004
#define | SVG_DBG_SECTION_SYSFONTS 0x00000800
#define | SVG_DBG_SECTION_TEST 0x00000100
#define | SVG_DBG_SECTIONS_USE_ALL 0
#define | SVG_DBG_USED_SECTIONS (SVG_DBG_SECTION_TEST | SVG_DBG_SECTION_IMAGE | SVG_DBG_SECTION_DECODER | SVG_DBG_SECTION_CALLBACK | SVG_DBG_SECTION_MEMORY_PROF)
#define | SVG_FP_FP_TO_INT(V) ((V) >> 16)
#define | SVG_FP_INT_TO_FP(V) ((V) << 16)
#define | SVG_FP_TRANS_GET_X_SCALE(T) ((T)->x_scale)
#define | SVG_FP_TRANS_GET_X_SHEAR(T) ((T)->x_shear)
#define | SVG_FP_TRANS_GET_X_TRANS(T) ((T)->x_trans)
#define | SVG_FP_TRANS_GET_Y_SCALE(T) ((T)->y_scale)
#define | SVG_FP_TRANS_GET_Y_SHEAR(T) ((T)->y_shear)
#define | SVG_FP_TRANS_GET_Y_TRANS(T) ((T)->y_trans)
#define | SVG_FP_TRANS_SET_X_SCALE(T, V) (((T)->x_scale) = (V));
#define | SVG_FP_TRANS_SET_X_SHEAR(T, V) (((T)->x_shear) = (V));
#define | SVG_FP_TRANS_SET_X_TRANS(T, V) (((T)->x_trans) = (V));
#define | SVG_FP_TRANS_SET_Y_SCALE(T, V) (((T)->y_scale) = (V));
#define | SVG_FP_TRANS_SET_Y_SHEAR(T, V) (((T)->y_shear) = (V));
#define | SVG_FP_TRANS_SET_Y_TRANS(T, V) (((T)->y_trans) = (V));
#define | SVG_GZ_INPUT_BUFFER_SIZE 1024
#define | SVG_MIME_CONTENT_TYPE_IMAGE 0x80
#define | SVG_MIME_CONTENT_TYPE_IMAGE_GIF 0x83
#define | SVG_MIME_CONTENT_TYPE_IMAGE_JPEG 0x81
#define | SVG_MIME_CONTENT_TYPE_IMAGE_PNG 0x82
#define | SVG_MIME_CONTENT_TYPE_IMAGE_SVG 0x85
#define | SVG_MIME_CONTENT_TYPE_IMAGE_WBMP 0x84
#define | SVG_MIME_CONTENT_TYPE_IS_IMAGE(CT) ((CT) & SVG_MIME_CONTENT_TYPE_IMAGE)
#define | SVG_MIME_CONTENT_TYPE_NA 0
#define | SVG_PRINT_IMAGE_ERROR(ERROR_CODE)
#define | SvgFixPoint_Scalar_Add(A, B) ((A) + (B))
#define | SvgFixPoint_Scalar_Sub(A, B) ((A) - (B))
#define | SVGIMAGE_DEFAULT_HEIGHT 128
#define | SVGIMAGE_DEFAULT_WIDTH 128

Typedefs

typedef INT32 | SvgFixPoint
typedef S_SvgFixPointTrans | SvgFixPointTrans

Functions

SvgFixPoint | SvgFixPoint_Scalar_Mul (const SvgFixPoint a, const SvgFixPoint b)
void | SvgFixPoint_Scalar_Print (SvgFixPoint a)
void | SvgFixPoint_Transform_Init (SvgFixPointTrans *a)
void | SvgFixPoint_Transform_Print (SvgFixPointTrans *a)
void | SvgFixPoint_Transform_Rotate (SvgFixPointTrans *a, const SvgFixPoint angle, const SvgFixPoint x_center, const SvgFixPoint y_center)
void | SvgFixPoint_Transform_Scale (SvgFixPointTrans *a, const SvgFixPoint scale_factor, const SvgFixPoint x_center, const SvgFixPoint y_center)
void | SvgFixPoint_Transform_Translate (SvgFixPointTrans *a, const SvgFixPoint x_trans, const SvgFixPoint y_trans)
void | SvgFixPoint_Transform_XY_Scale (SvgFixPointTrans *a, const SvgFixPoint xs, const SvgFixPoint ys, const SvgFixPoint x_center, const SvgFixPoint y_center)

Define Documentation

#define SVG_ASSERT ( COND )

Value:

if(!(COND)){ \
        DBG_OUT((0, "ASSERTION \"" #COND "\" FAILED AT: \"%s:%d\"\n", __FILE__, __LINE__)); \
    }

#define SVG_DBG_OUT | ( | SECTION,
 |  | DATA | )

Value:

if((SECTION & SVG_DBG_USED_SECTIONS) || SVG_DBG_SECTIONS_USE_ALL){ \
        DBG_OUT(DATA); \
    }

#define SVG_DBG_SECTION_CALLBACK 0x00000002

#define SVG_DBG_SECTION_DECODER 0x00000001

#define SVG_DBG_SECTION_FILEWRAPPER 0x00000010

#define SVG_DBG_SECTION_FIXPOINT 0x00000200

#define SVG_DBG_SECTION_GZ 0x00000400

#define SVG_DBG_SECTION_IMAGE 0x00000008

#define SVG_DBG_SECTION_MEMORY 0x00000020

#define SVG_DBG_SECTION_MEMORY_PROF 0x00000040

#define SVG_DBG_SECTION_MIME 0x00000080

#define SVG_DBG_SECTION_PLAYER 0x00000004

#define SVG_DBG_SECTION_SYSFONTS 0x00000800

#define SVG_DBG_SECTION_TEST 0x00000100

#define SVG_DBG_SECTIONS_USE_ALL 0

#define SVG_DBG_USED_SECTIONS (SVG_DBG_SECTION_TEST | SVG_DBG_SECTION_IMAGE | SVG_DBG_SECTION_DECODER | SVG_DBG_SECTION_CALLBACK | SVG_DBG_SECTION_MEMORY_PROF)

#define SVG_FP_FP_TO_INT ( V ) ((V) >> 16)

#define SVG_FP_INT_TO_FP ( V ) ((V) << 16)

#define SVG_FP_TRANS_GET_X_SCALE ( T ) ((T)->x_scale)

#define SVG_FP_TRANS_GET_X_SHEAR ( T ) ((T)->x_shear)

#define SVG_FP_TRANS_GET_X_TRANS ( T ) ((T)->x_trans)

#define SVG_FP_TRANS_GET_Y_SCALE ( T ) ((T)->y_scale)

#define SVG_FP_TRANS_GET_Y_SHEAR ( T ) ((T)->y_shear)

#define SVG_FP_TRANS_GET_Y_TRANS ( T ) ((T)->y_trans)

#define SVG_FP_TRANS_SET_X_SCALE | ( | T,
 |  | V | ) | (((T)->x_scale) = (V));

#define SVG_FP_TRANS_SET_X_SHEAR | ( | T,
 |  | V | ) | (((T)->x_shear) = (V));

#define SVG_FP_TRANS_SET_X_TRANS | ( | T,
 |  | V | ) | (((T)->x_trans) = (V));

#define SVG_FP_TRANS_SET_Y_SCALE | ( | T,
 |  | V | ) | (((T)->y_scale) = (V));

#define SVG_FP_TRANS_SET_Y_SHEAR | ( | T,
 |  | V | ) | (((T)->y_shear) = (V));

#define SVG_FP_TRANS_SET_Y_TRANS | ( | T,
 |  | V | ) | (((T)->y_trans) = (V));

#define SVG_GZ_INPUT_BUFFER_SIZE 1024

This is the size of the internal read buffer, we need to copy from the internal BinData object m_bin_data to a buffer that zlib can use. Any reasonable size should do, expect values < 1.

#define SVG_MIME_CONTENT_TYPE_IMAGE 0x80

#define SVG_MIME_CONTENT_TYPE_IMAGE_GIF 0x83

#define SVG_MIME_CONTENT_TYPE_IMAGE_JPEG 0x81

#define SVG_MIME_CONTENT_TYPE_IMAGE_PNG 0x82

#define SVG_MIME_CONTENT_TYPE_IMAGE_SVG 0x85

#define SVG_MIME_CONTENT_TYPE_IMAGE_WBMP 0x84

#define SVG_MIME_CONTENT_TYPE_IS_IMAGE ( CT ) ((CT) & SVG_MIME_CONTENT_TYPE_IMAGE)

#define SVG_MIME_CONTENT_TYPE_NA 0

#define SVG_PRINT_IMAGE_ERROR ( ERROR_CODE )

#define SvgFixPoint_Scalar_Add | ( | A,
 |  | B | ) | ((A) + (B))

#define SvgFixPoint_Scalar_Sub | ( | A,
 |  | B | ) | ((A) - (B))

#define SVGIMAGE_DEFAULT_HEIGHT 128

#define SVGIMAGE_DEFAULT_WIDTH 128

Typedef Documentation

typedef INT32 SvgFixPoint

typedef struct S_SvgFixPointTrans SvgFixPointTrans

Function Documentation

SvgFixPoint SvgFixPoint_Scalar_Mul | ( | const SvgFixPoint | a,
 |  | const SvgFixPoint | b
 | ) |

void SvgFixPoint_Scalar_Print ( SvgFixPoint a )

void SvgFixPoint_Transform_Init ( SvgFixPointTrans * a )

void SvgFixPoint_Transform_Print ( SvgFixPointTrans * a )

void SvgFixPoint_Transform_Rotate | ( | SvgFixPointTrans * | a,
 |  | const SvgFixPoint | angle,
 |  | const SvgFixPoint | x_center,
 |  | const SvgFixPoint | y_center
 | ) |

void SvgFixPoint_Transform_Scale | ( | SvgFixPointTrans * | a,
 |  | const SvgFixPoint | scale_factor,
 |  | const SvgFixPoint | x_center,
 |  | const SvgFixPoint | y_center
 | ) |

void SvgFixPoint_Transform_Translate | ( | SvgFixPointTrans * | a,
 |  | const SvgFixPoint | x_trans,
 |  | const SvgFixPoint | y_trans
 | ) |

void SvgFixPoint_Transform_XY_Scale | ( | SvgFixPointTrans * | a,
 |  | const SvgFixPoint | xs,
 |  | const SvgFixPoint | ys,
 |  | const SvgFixPoint | x_center,
 |  | const SvgFixPoint | y_center
 | ) |

Generated on Wed Jan 25 02:26:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: T9

T9
[Add Ons]

Collaboration diagram for T9:

Data Structures

class T9InputMapper
Generated on Wed Jan 25 02:26:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Translation

Translation
[Add Ons]

Collaboration diagram for Translation:

Data Structures

class | EnumTranslationTable
class | ValueTextMap

Defines

#define | EnumTr(enum_translation_table, enum_value) ValueTextMap(EnumTranslationTable::enum_translation_table()).GetText(enum_value)

Define Documentation

#define EnumTr | ( | enum_translation_table,
 |  | enum_value | ) | ValueTextMap(EnumTranslationTable::enum_translation_table()).GetText(enum_value)

Generated on Wed Jan 25 02:26:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Voice Recognition

Voice Recognition
[Add Ons]

Collaboration diagram for Voice Recognition:

Data Structures

class | VrHandler
Interface for Apoxi VR usage. More...

Enumerations

enum | { VrHandler::ID = VrHandlerId }
enum | VrHandler::VrApiRc { VrHandler::VrSuccess, VrHandler::VrFailed }
Return codes for methods of this class. More...
enum VrHandler::VrCommand {
VrHandler::Digit0, VrHandler::Digit1, VrHandler::Digit2, VrHandler::Digit3,
VrHandler::Digit4, VrHandler::Digit5, VrHandler::Digit6, VrHandler::Digit7,
VrHandler::Digit8, VrHandler::Digit9, VrHandler::Dial, VrHandler::Cancel,
VrHandler::Clear, VrHandler::TrainedCommand, VrHandler::InvalidCommand
}
Predefined VR commands. More...
enum | VrHandler::VrCommandSet { VrHandler::Digits, VrHandler::DigitDialing, VrHandler::Complete }
Sets of predefined commands. More...
enum | VrHandler::VrRecognitionMode { VrHandler::IsolatedWord, VrHandler::ConnectedWord }
Recognition modes. More...

Functions

VrApiRc | VrHandler::Abort (BOOLEAN send_message)
VrApiRc | VrHandler::Abort ()
Abort currently ongoing training or recognition process. This method does a hard abort of any ongoing process.
void | VrHandler::CreateTemplate (const WString &client_name, const WString &text)
Create template based on a given string using G2A. With G2A speaker independent templates can be created out of a given text. This text must be between 3 and 40 characters long.
void | VrHandler::Error (VrErrorCode error_code)
VrApiRc | VrHandler::GetAppTemplates (const WString &client_name, Vector< UINT16 > &template_ids)
Return templates of a client, client_name acts as key The ids of the templates belonging to the given client are added to the given vector. The vector must be initialised. It may contain ids before. Template ids are just added to the vector, the vector must be initialised before.
VrCommand | VrHandler::GetCommand (UINT16 template_id)
Return the command behind a predefined template id.
VrApiRc | VrHandler::GetCommandTemplates (VrCommandSet set, Vector< UINT16 > &template_ids)
Return templates for a set of fixed commands.
virtual HandlerId | VrHandler::GetHandlerId () const
Returns the handler's identifier as specified in the anonymous enumeration.
VrApiRc | VrHandler::InitVr ()
Initialize Voice Recognition.
BOOLEAN | VrHandler::IsSupported (VrProperty property)
Check if current VR engine supports a function. This method checks if the used VR engine supports a certain function or not.
VrApiRc | VrHandler::PlayTemplate (UINT16 template_id)
Playback trained template.
VrApiRc | VrHandler::RemoveAllTemplates (const WString &client_name)
Delete all templates belonging to a client.
VrApiRc | VrHandler::RemoveTemplate (const WString &client_name, UINT16 template_id)
Remove template.
void | VrHandler::Reset ()
void | VrHandler::StartRecognition (const Vector< UINT16 > &id_set, VrRecognitionMode mode=ConnectedWord, UINT16 max_time=700, UINT32 max_silence=80)
Start recognition for a set of templates Kicks off an actual recognition process.
void | VrHandler::StartRecording ()
Starts recording for training or recognition after prompt. Starts voice recording for the currently ongoing recognition or training process. This method has to be called by the client after prompting the user to start speaking is done.
void | VrHandler::StartTraining (const WString &client_name)
Start training for a user defined command.
static BOOLEAN | VrHandler::Startup ()
Called by Stack Control on system startup to do some init stuff.
VrApiRc | VrHandler::StopRecognition ()
Stop repeated mode recognition after prompt request, feature not yet finished Stops currently ongoing recognition process. This method can be called by a client whilst an recognition process to stop it (e.g. if the received results are sufficent).
VrHandler::VrHandler ()
Creates a new handler instance. This constructor creates a new instance of VrHandler. The VR module is initialized if not done before.
virtual | VrHandler::~VrHandler ()
Destructs an handler instance, nothing happening (in VR point of view).

Detailed Description

Module Voice Recognition (VR) is Apoxi's API layer which provides access to voice recognition funcionality of underlying voice recognition engines. This API is meant to be independent of the used voice recognition engine.

Clarification of terms

Some terms used in this documentation should be clarified before to avoid missunderstanding.
  • Client: any software that uses this VR interfaces, most probably applications in MMI
  • Template, VR Template: Data that is used by the VR engine for recognition. Clients work with VR templates only in terms of using their unique ids.

Purpose and design goals

  • VR engine independent access to VR engines
  • Easy start of training and recognition processes
  • Easy handling of used VR template data, clients should not have to bother with the data itself

Concepts

  • Use of single handler to trigger recognition or training
    • class VrHandler
  • Results deliverd using messages
    • various message classes

Using voice recognition

The use of VR is actually quite easy. First of all, the concept of VR template must be explained.

VR templates

Each VR template represents one word VR is able to recognize. There are two classes of templates:

  • Predefined templates which are used for speaker independent recognition (e.g. digit dialing).
  • Trained templates which are created by either vocal training or by using G2A. Templates trained by vocal training are speaker dependent, G2A templates are speaker independent. Any trained template is always related to the client which started the training.

Each template has an unique id. The client has to work with this ids only. In no case, the client has to deal with the binary template data, the various templates consist of. All issues according storing or loading this data is done by the Apoxi VR layer. Nevertheless, the client has to know what should happen when a certain template has been recognized. Apoxi VR only provides the id of the recognized templates. The actions to be taken (e.g. dialing a number) have to be executed by the client. For predefined commands Apoxi VR is able to tell which command is behind an id. For trained commands, the client has to have this information by itself.

Doing a recognition

A recognition is always done for a set of templates, never on all existing templates, since that would cause useless performance problems. For example, for an phonebook client it makes no sense, that single digits are recognized. It only needs one of the names of it's entries to be recognized. So before a recognition can be done, the client has to tell VR, which templates should included in the recognition process. This is done by providing a set of template ids.The set of templates is built either by the client it self (out of a local database) or provided by Apoxi VR (for predefined templates).

Before the actual recognition can start, some initialization of the VR engine has to be done by Apoxi VR (the client has to do nothing for that). As soon as the VR engine is ready to start the actual recognition, the client receives a VrPromptMsg. This indicates that the client should prompt the user, that (s)he should start speaking. After prompting is complete (e.g. a beep sound has been played), the client indicates to Apoxi VR that recording of the voice can be started.

While recognition is active (and the user is speaking) results might already be received by the client. The id of each recognized template is sent to the client with a VrResultMsg. The last result is indicated by a flag in this message. The last result also indicates the end of the recognition process.

Training a speaker dependent template

If a client has the need for recognition of commands not covered by the predefined templates, a new one can be recorded. When a client starts a training, it receives an VrPromptMsg as soon as the VR engine is ready to record. Then the client has to indicate to the user, that he/she should start speaking. When this prompting is completed the client indicates to Apoxi VR that recording of the voice can be started.

If everything went ok for training, the client receives a VrTrainingResultMsg containing the id of the newly created template. The client is now responsible for keeping the information what semantics is represented by this command's id (e.g. a phonebook application has to store which entry this id belongs to).

The G2A feature

Some voice recognition engines support a feature called G2A. This enables an application to build an template for recognition from a string. E.g. if a WAP page contains a link and the link is represented by a word like "News", the WAP application could turn "News" into a speaker independent training and let the user navigate using voice recognition.

Like at training of spoken templates, the result id is delivered to the client in an VrTrainingResultMsg. The client again is responsible for keeping track of the semantics of the template. Also the client should be aware, that no longer needed templates are discarded, otherwise the system could get overflown by unused templates.

Managing existing templates

AX VR supports a pile of managing functions to manipulate the set of templates in the system.

Retrieve all templates of a client Delete templates of a client Retrieve sets of predefined template ids for several tasks Translate a predefined template into a command Playback trained templates

Retrieving template sets

To make use of predefined templates, the client doesn't have to know which ids belong to predefined commands. The client simple retrieves a set of ids of predefined commands from AX VR for a special purpose. For now a set of predefined ids for digit dialing can be retrieved. This might be subject of extension in the future. The set contains all ids of templates necessary for the given purpose. E.g. digit dialing contains the numbers '0'-'9', Dial, Cancel and Delete.

To translate the results of the recognition (which will be one or more ids) back into the command which has to be executed, AX VR provides a function that maps the id of a predefined template to commands.

Deleting templates

Templates of a client can be deleted all at once or seperately. To avoid conflicts, the name of the client has to be given for deleting. This should avoid, a client accidentally deleting templates of other clients.

Playback

For speaker dependent templats, also the PCM data recorded at training is stored in the system. This PCM data can be played at any time.

Enumeration Type Documentation

anonymous enum [inherited]

Enumerator defining the handler's identifier.

See also:
HandlerId
Enumerator:
ID

enum VrHandler::VrApiRc [inherited]

Return codes for methods of this class.

Enumerator:
VrSuccess
VrFailed

enum VrHandler::VrCommand [inherited]

Predefined VR commands.

Enumerator:
Digit0
Digit1
Digit2
Digit3
Digit4
Digit5
Digit6
Digit7
Digit8
Digit9
Dial
Cancel
Clear
TrainedCommand
InvalidCommand

enum VrHandler::VrCommandSet [inherited]

Sets of predefined commands.

Several sets of template ids for predefined commands are there:

  • Digits: digits 0-9
  • DigitDialing: digits 0-9, Dial, Cancel, Clear
  • Complete: all known predefined commands (currently the same as DigitDialing)
Enumerator:
Digits
DigitDialing
Complete

enum VrHandler::VrRecognitionMode [inherited]

Recognition modes.

Currently two recognition modes are supported

  • IsolatedWord: only one template out of the given set is recognized
  • ConnectedWord: one or more templates are recognized as the user speaks
Enumerator:
IsolatedWord
ConnectedWord

Function Documentation

VrHandler::VrApiRc VrHandler::Abort ( BOOLEAN send_message ) [protected, inherited]

VrHandler::VrApiRc VrHandler::Abort ( ) [inherited]

Abort currently ongoing training or recognition process. This method does a hard abort of any ongoing process.

Returns:
VrSuccess if operation was successful, error code otherwise

void VrHandler::CreateTemplate | ( | const WString & | client_name,
 |  | const WString & | text
 | ) | [inherited]

Create template based on a given string using G2A. With G2A speaker independent templates can be created out of a given text. This text must be between 3 and 40 characters long.

Parameters:
client_name | String representing the client
text | Source for VR template (min 3 chars, max 40 chars)

void VrHandler::Error ( VrErrorCode error_code ) [protected, inherited]

VrHandler::VrApiRc VrHandler::GetAppTemplates | ( | const WString & | client_name,
 |  | Vector< UINT16 > & | template_ids
 | ) | [inherited]

Return templates of a client, client_name acts as key The ids of the templates belonging to the given client are added to the given vector. The vector must be initialised. It may contain ids before. Template ids are just added to the vector, the vector must be initialised before.

Parameters:
client_name | String representing the client
template_ids | Initialised vector to hold the ids
Returns:
VrSuccess if operation was successful, error code otherwise

VrHandler::VrCommand VrHandler::GetCommand ( UINT16 template_id ) [inherited]

Return the command behind a predefined template id.

Parameters:
template_id Template id to be resolved to predefined command
Returns:
VrCommand represented by template_id, TrainedCommand if id of trained command InvalidCommand for invalid ids

VrHandler::VrApiRc VrHandler::GetCommandTemplates | ( | VrCommandSet | set,
 |  | Vector< UINT16 > & | template_ids
 | ) | [inherited]

Return templates for a set of fixed commands.

This returns a set of template ID's for a set of commands. There may be (and usually is) more than one template for a command. If there are are speaker dependent templates for the command, they are also included, regardless of which application has trained the template

Parameters:
set | VrCommandSet which shall be put into the vector
template_ids | Initialised vector to hold the ids
Returns:
VrSuccess if operation was successful, error code otherwise

HandlerId VrHandler::GetHandlerId ( ) const [virtual, inherited]

Returns the handler's identifier as specified in the anonymous enumeration.

Returns:
VrHandlerId

VrHandler::VrApiRc VrHandler::InitVr ( ) [inherited]

Initialize Voice Recognition.

This initializes the Voice Recognition. Basic parameters are set at the VR engine.

BOOLEAN VrHandler::IsSupported ( VrProperty property ) [inherited]

Check if current VR engine supports a function. This method checks if the used VR engine supports a certain function or not.

Parameters:
property Property which availability should be checked
Returns:
TRUE if property is supported

VrHandler::VrApiRc VrHandler::PlayTemplate ( UINT16 template_id ) [inherited]

Playback trained template.

If the template id belongs to a not-trained template (i.e. there is no PCM data stored) for the template, an error will be produced.

The playback is done asynchronous. This method only triggers playback. The end of playback is indicated by a VrPlaybackFinishedMsg sent to the client. This message contains the id of the template that was played.

Parameters:
template_id Id of template to be played.
Returns:
VrSuccess if operation was successful, error code otherwise

VrHandler::VrApiRc VrHandler::RemoveAllTemplates ( const WString & client_name ) [inherited]

Delete all templates belonging to a client.

All templates of a client are removed and the according files are erased.

Parameters:
client_name String representing the client
Returns:
VrSuccess if operation was successful, error code otherwise

VrHandler::VrApiRc VrHandler::RemoveTemplate | ( | const WString & | client_name,
 |  | UINT16 | template_id
 | ) | [inherited]

Remove template.

The template is only removed if the template belongs to the given client. Removal of templates of other clients shall be prevented with this restriction. All files belonging to the template are erased.

Parameters:
client_name | String representing the client
template_id | Id of template to remove
Returns:
VrSuccess if operation was successful, error code otherwise

void VrHandler::Reset ( ) [protected, inherited]

void VrHandler::StartRecognition | ( | const Vector< UINT16 > & | id_set,
 |  | VrRecognitionMode | mode = ConnectedWord,
 |  | UINT16 | max_time = 700,
 |  | UINT32 | max_silence = 80
 | ) | [inherited]

Start recognition for a set of templates Kicks off an actual recognition process.

Parameters:
id_set | Vector containing the ids of the templates for the recognition
mode | Recognition mode for this recognition process
max_time | Max. time in ms the recognition (i.e. the part where voice is actually recorded) should last. After this time the recognition is finished even if the user continues speaking.
max_silence | Max. length of a speaking pause in ms the user may take. If the user stops speaking longer than max_silence, recognition is finished.

void VrHandler::StartRecording ( ) [inherited]

Starts recording for training or recognition after prompt. Starts voice recording for the currently ongoing recognition or training process. This method has to be called by the client after prompting the user to start speaking is done.

void VrHandler::StartTraining ( const WString & client_name ) [inherited]

Start training for a user defined command.

After the engine is ready for recording, a VrPromptMsg is sent to the client, who triggered the training. The client has to call StartRecording() when prompting to the user is done. The result id is delivered using a VrTrainingResultMsg and it is added to the store of templates of the given client.

Parameters:
client_name String representing the client
Returns:
VrSuccess if operation was successful, error code otherwise

BOOLEAN VrHandler::Startup ( ) [static, inherited]

Called by Stack Control on system startup to do some init stuff.

VrHandler::VrApiRc VrHandler::StopRecognition ( ) [inherited]

Stop repeated mode recognition after prompt request, feature not yet finished Stops currently ongoing recognition process. This method can be called by a client whilst an recognition process to stop it (e.g. if the received results are sufficent).

Returns:
VrSuccess if operation was successful, error code otherwise

VrHandler::VrHandler ( ) [inherited]

Creates a new handler instance. This constructor creates a new instance of VrHandler. The VR module is initialized if not done before.

VrHandler::~VrHandler ( ) [virtual, inherited]

Destructs an handler instance, nothing happening (in VR point of view).

Generated on Wed Jan 25 02:26:54 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GUI

GUI

Collaboration diagram for GUI:

Modules

Components
Obsolete GUI classes
Editors
Items
Sms

Data Structures

class | AbstractItemRenderer
class | AbstractRenderer
class | AbstractTextRenderer
class | ArabicTextRenderer
class | BidiManager
class | Bitmap
class | BitmapDc
Device-context for a Bitmap. More...
struct | BitmapRes
class | Brush
class | ClientDc
class | Color
struct | ColorSegmentation
struct | ColorTable
class | ControlDc
class | ControlFrameView
class | DecodingThreadlet
class | DefaultItemRenderer
class | Desktop
class | DeviceContext
class | DisplayDc
DeviceContext that encompasses the complete display. More...
class | EncodingThreadlet
class | FlowLayout
struct | FlowLayout::AlignInfo
class | Font
struct | FontRes
class | FrameDc
Device context used for drawing the frame of a control. More...
class | GlassPane
struct | Glyph
struct | GlyphHeader
struct | GlyphIndexTab
class | HindiTextRenderer
class | IconSet
class | IconState
class | Image
class | ImageDecoder
class | ImageEncoder
class | ImageFactory
class | ImageIncrementalPdcUpdater
class | ImageObtainer
class | IncrementalPdcUpdater
class | ItemRendererProperties
class | JapaneseTextRenderer
class | JpegEncodingThreadlet
class | LanguageManager
class | Layouter
class | Locale
class | Model
class | NativeImage
class | OptionalConfigBase
class | PaintDc
struct | Palette
class | Panel
class | PanelView
Describes the view of a panel. More...
class | PaneObject
class | Pen
class | Point
Combines the x- and y-coordinate. More...
class | Rect
class | RomFont
class | SimpleTextRenderer
class | Size
class | SyncPaintDc
class | TextFormat
class | ThaiTextRenderer
class | Theme
class | ThemeManager
The theme-manager is able to switch between different themes. More...
class | ThemeViewIterator
class | VietnameseTextRenderer
class | View
class | WindowFrameView
class | WindowHierarchyIterator
class | WindowManager

Defines

#define | APOXI_MAX_LANGUAGE_COUNT 16
#define | Behavior ScrollBehavior
#define | GET_16BPP_COLOR_VALUE(red, green, blue) ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)))
#define | GlyphHeaderPtr GlyphHeader FONT_HUGE*
#define | GlyphIndexTabPtr GlyphIndexTab FONT_HUGE*
#define | GlyphPtr Glyph FONT_HUGE*
#define | GlyphTab struct { GlyphHeader* m_glyph_header; UINT8* m_data; }

Typedefs

typedef Brush::BrushStyle | BrushStyle
typedef UINT16 | ColorValue
typedef TextFormat::FontAlign | FontAlign
typedef Pen::PenStyle | PenStyle
typedef DeviceContext::RasterOp | RasterOp
typedef ColorValue | SystemColor
typedef Color::SystemColorId | SystemColorId
typedef Font::SystemFontId | SystemFontId
typedef TextFormat::TextAlign | TextAlign
typedef TextFormat::TextAttr | TextAttr

Enumerations

enum | { FlowLayout::ID = 38 }
enum | FlowLayout::Alignment { FlowLayout::Start = 0, FlowLayout::Middle = 1, FlowLayout::End = 2 }
enum | ScrollBehavior { DefaultBehavior, BlockScrollBehavior, RotateBehavior, EndlessLoopBehavior }

Functions

void | FlowLayout::AddAlignInfo (Component &comp, Alignment align)
const WCHAR * | AmbiguousTr (const WCHAR *text, INT ambiguous_hint)
FlowLayout::FlowLayout (Control *parent, BOOLEAN horizontal=TRUE)
FlowLayout::FlowLayout ()
BOOLEAN | FlowLayout::GetAlignInfo (const Component &comp, Alignment &align) const
void | FlowLayout::Init (Control *parent, BOOLEAN horizontal=TRUE)
virtual BOOLEAN | FlowLayout::IsInstanceOf (INT id) const
virtual void | FlowLayout::OnFocusNextControl ()
virtual void | FlowLayout::OnFocusPreviousControl ()
virtual BOOLEAN | FlowLayout::OnKeyDown (KeyCode key_code)
virtual void | FlowLayout::OnLayoutClient ()
virtual void | FlowLayout::OnThemeChanged ()
BOOLEAN | FlowLayout::RemoveAlignInfo (const Component &comp)
BOOLEAN | FlowLayout::SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
const WCHAR * | Tr (const WCHAR *text)
virtual | FlowLayout::~FlowLayout ()

Variables

Alignment | FlowLayout::AlignInfo::align

Define Documentation

#define APOXI_MAX_LANGUAGE_COUNT 16

#define Behavior ScrollBehavior

#define GET_16BPP_COLOR_VALUE | ( | red,
 |  | green,
 |  | blue | ) | ((ColorValue)((((red) >> 3U) << 11U) | (((green) >> 2U) << 5U) | ((blue) >> 3U)))

#define GlyphHeaderPtr GlyphHeader FONT_HUGE*

#define GlyphIndexTabPtr GlyphIndexTab FONT_HUGE*

#define GlyphPtr Glyph FONT_HUGE*

#define GlyphTab struct { GlyphHeader* m_glyph_header; UINT8* m_data; }

Typedef Documentation

typedef Brush::BrushStyle BrushStyle

typedef UINT16 ColorValue

typedef TextFormat::FontAlign FontAlign

typedef Pen::PenStyle PenStyle

typedef DeviceContext::RasterOp RasterOp

typedef ColorValue SystemColor

typedef Color::SystemColorId SystemColorId

typedef Font::SystemFontId SystemFontId

typedef TextFormat::TextAlign TextAlign

typedef TextFormat::TextAttr TextAttr

Enumeration Type Documentation

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from Control.

enum FlowLayout::Alignment [inherited]

Describes the alignment of a component inside the horizontal or vertical flow layout control.

Enumerator:
Start | The component is aligned on the left (top) of a horizontal (vertical) flow layout control.
Middle | The component is aligned in the middle of a flow layout control.
End | The component is aligned on the right (bottom) of a horizontal (vertical) flow layout control.

enum ScrollBehavior

Defines the the scrollbehavior of menus, trees and grids when changing the selection.

See also:
ItemMenu

ItemTree

ItemGrid

Enumerator:
DefaultBehavior | A line-by-line scrolling will be done if the selection reachs the top or bottom of the visible area. If the selection reaches the begin or end of all items, no scrolling is done. The scroll gap defined in OptionalConfig::GetSetting is respected.
BlockScrollBehavior | Same behavior as the DefaultBehavior, but if the top or bottom of the visible area has been reached, the items are not scrolled line-by-line but per page.
RotateBehavior | Same behavior as the DefaultBehavior, but if the selection reaches the begin or end of all items, the selection will be rotated to the other end of the list. The scroll gap defined in OptionalConfig::GetSetting is respected.
EndlessLoopBehavior | The items will be treated like a ring buffer: if the last item is selected, the next visible item is the first item. If the scroll gap defined in OptionalConfig::GetSetting is -1, the selection will always stay at the vertical center of the visible area.

Function Documentation

void FlowLayout::AddAlignInfo | ( | Component & | comp,
 |  | Alignment | align
 | ) | [inherited]

Adds alignment information for a component. If no alignment information is given each component is aligned with 'Start' as default alignment. The components are aligned in the same order as the alignment information has been added.

Parameters:
comp | Component for which the alignment information is given.
align | Alignment property.

const WCHAR* AmbiguousTr | ( | const WCHAR * | text,
 |  | INT | ambiguous_hint
 | ) |

Translates the text text and returns the corresponding text dependend on the current set language. If no language-table is provided, text itself is returned. Use this method instead of Tr(), when the text has different translations in different contexts and provide an index by ambiguous_hint.

Parameters:
text | Pointer to the text which should be translated.
ambiguous_hint | It is possible that one text may have different translations in different contexts. ambiguous_hint indicates the index of the context starting with zero. The default value is -1, which means that there is a 1 to 1 relation between the text and it's translations.
Returns:
Pointer to translated text.
See also:
LanguageMangager::Tr

FlowLayout::FlowLayout | ( | Control * | parent,
 |  | BOOLEAN | horizontal = TRUE
 | ) | [inherited]

Parameters:
parent | Parent control, where the flow layout control is embedded.
horizontal | If set to TRUE the flow of the layout is aligned horizontally, otherwise vertically.

FlowLayout::FlowLayout ( ) [inherited]

If the default constructor is used, the parameters have to be provided by using the method Init.

BOOLEAN FlowLayout::GetAlignInfo | ( | const Component & | comp,
 |  | Alignment & | align
 | ) | const [inherited]

Returns the alignment information for a given component.

Parameters:
comp | Component for which the alignment information should be getted.
align | Output parameter which contains the alignment information. The parameter is only valid if TRUE has been returned.
Returns:
TRUE if the alignment information was available.

void FlowLayout::Init | ( | Control * | parent,
 |  | BOOLEAN | horizontal = TRUE
 | ) | [inherited]

Parameters:
parent | Parent control, where the flow layout control is embedded.
horizontal | If set to TRUE the flow of the layout is aligned horizontally, otherwise vertically.

BOOLEAN FlowLayout::IsInstanceOf ( INT id ) const [virtual, inherited]

See also:
Component::IsInstanceOf

Reimplemented from Control.

void FlowLayout::OnFocusNextControl ( ) [protected, virtual, inherited]

See also:
Control::OnFocusPreviousControl

Reimplemented from Control.

void FlowLayout::OnFocusPreviousControl ( ) [protected, virtual, inherited]

See also:
Control::OnFocusPreviousControl

Reimplemented from Control.

BOOLEAN FlowLayout::OnKeyDown ( KeyCode key_code ) [protected, virtual, inherited]

See also:
Control::OnKeyDon

Reimplemented from Control.

void FlowLayout::OnLayoutClient ( ) [protected, virtual, inherited]

See also:
Control::OnLayoutClient

Reimplemented from Control.

void FlowLayout::OnThemeChanged ( ) [protected, virtual, inherited]

See also:
Component::OnThemeChanged

Reimplemented from Control.

BOOLEAN FlowLayout::RemoveAlignInfo ( const Component & comp ) [inherited]

Removes the alignment information for the given component. If the component has no alignment information, it is aligned with 'Start' as default alignment.

Parameters:
comp Component for which the alignment information should be removed.
Returns:
TRUE if removing has been successful. FALSE is returned if the no alignment information could be found for the given component.

BOOLEAN FlowLayout::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) | [inherited]

Used by Aragon to fill the properties by reading out a resource file. It should not be necessary for the application developer to invoke this method in a direct manner.

Reimplemented from Control.

const WCHAR* Tr ( const WCHAR * text )

Translates the text text and returns the corresponding text dependend on the current set language. If no language-table is provided, text itself is returned. Because this method is used very often and has no semantics to the code, the short name Tr was choosen instead of Translate.

Parameters:
text Pointer to the text which should be translated.
Returns:
Pointer to translated text.
See also:
LanguageMangager::Tr

FlowLayout::~FlowLayout ( ) [virtual, inherited]

Variable Documentation

Alignment FlowLayout::AlignInfo::align [inherited]

Generated on Wed Jan 25 02:25:56 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Components

Components
[GUI]

Collaboration diagram for Components:

Modules

Editors
Sms

Data Structures

class | AbstractButton
class | AbstractGrid
Simple grid functionality for arranging items on the screen in rows and columns. More...
class | AbstractItemGrid
class | AbstractTextObject
class | Alert
class | AnimatedTextLine
class | AnimatedTextLineView
class | AtlItemBox
class | CalendarGrid
class | CalendarGridView
class | CheckBoxControl
class | CheckBoxControlView
Describes the view of a checkbox-control. More...
class | Component
class | ContextMenu
class | Control
class | DrawableObject
class | DrawableObjectView
class | GridLayout
struct | GridLayout::Cell
struct | GridLayout::LayouterProperties
class | ImageBox
class | ImageBoxView
class | ItemBox
class | ItemBoxView
class | ItemGrid
class | ItemMenu
class | ItemTree
class | MessageBox
class | PositionIndicator
class | PositionIndicatorView
class | ProgressBar
class | ProgressBarView
class | PushButton
class | PushButtonView
Describes the view of a pushbutton. More...
class | RadioButtonControl
class | RadioButtonControlView
Describes the view of a radiobutton-control. More...
class | TabButton
class | TabButtonView
Describes the view of a TabButton. More...
class | TabControl
class | TabControlView
class | TextBox
class | TextBoxView
class | TextLine
class | TextLineView
View object which draws a textline. More...
class | Window

Defines

#define | APOXI_MAX_SOFTKEY_COUNT 2
#define | no_cols 8
#define | no_rows 7

Typedefs

typedef Control::FrameType | FrameType

Enumerations

enum | { GridLayout::ID = 15 }
enum | GridLayout::StretchUnit { GridLayout::Default, GridLayout::Percent, GridLayout::Pixel }
enum | GridLayout::XAlign { GridLayout::XDefault, GridLayout::Left, GridLayout::Center, GridLayout::Right }
Specifies the x-alignment of a component inside a cell. More...
enum | GridLayout::YAlign { GridLayout::YDefault, GridLayout::Top, GridLayout::Middle, GridLayout::Bottom }
Specifies the y-alignment of a component inside a cell. More...

Functions

Size | GridLayout::GetCellSize (INT row, INT column) const
virtual Rect | GridLayout::GetClientRect () const
INT | GridLayout::GetColumnCount () const
INT | GridLayout::GetRowCount () const
GridLayout::GridLayout (Control *parent, INT row_count, INT col_count=1, Size min_size=Size(-1,-1))
GridLayout::GridLayout ()
void | GridLayout::Init (Control *parent, INT row_count, INT col_count=1, Size min_size=Size(-1,-1))
virtual BOOLEAN | GridLayout::IsInstanceOf (INT id) const
virtual void | GridLayout::OnFocusNextControl ()
virtual void | GridLayout::OnFocusPreviousControl ()
virtual void | GridLayout::OnGetFocus ()
virtual BOOLEAN | GridLayout::OnKeyAutoRepeat (KeyCode key_code)
virtual BOOLEAN | GridLayout::OnKeyDown (KeyCode key_code)
virtual void | GridLayout::OnLayoutClient ()
virtual void | GridLayout::OnThemeChanged ()
void | GridLayout::SetCellProperties (INT row, INT col, Component *component, XAlign x_align=XDefault, YAlign y_align=YDefault)
void | GridLayout::SetColumnProperty (INT col, StretchUnit stretch_unit, INT value=0)
BOOLEAN | GridLayout::SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id)
void | GridLayout::SetRowProperty (INT row, StretchUnit stretch_unit, INT value=0)
virtual | GridLayout::~GridLayout ()

Variables

INT | GridLayout::LayouterProperties::value
XAlign | GridLayout::Cell::x_align
YAlign | GridLayout::Cell::y_align

Define Documentation

#define APOXI_MAX_SOFTKEY_COUNT 2

#define no_cols 8

#define no_rows 7

Typedef Documentation

typedef Control::FrameType FrameType

Enumeration Type Documentation

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from Control.

enum GridLayout::StretchUnit [inherited]

Specifies, whether the stretching-parameters for the columns or rows should be interpreted in percent or as pixels.

Enumerator:
Default
Percent | Percent.
Pixel | Pixel.

enum GridLayout::XAlign [inherited]

Specifies the x-alignment of a component inside a cell.

Enumerator:
XDefault | Use default-alignment (= Center).
Left | Align on the left side of the cell.
Center | Align centered inside the cell.
Right | Align on the right side of the cell.

enum GridLayout::YAlign [inherited]

Specifies the y-alignment of a component inside a cell.

Enumerator:
YDefault | Use default-alignment (= Middle).
Top | Align on the top of the cell.
Middle | Align in the middle of the cell.
Bottom | Align on the bottom of the cell.

Function Documentation

Size GridLayout::GetCellSize | ( | INT | row,
 |  | INT | column
 | ) | const [inherited]

Returns:
the width and height of the cell at position row/column

Rect GridLayout::GetClientRect ( ) const [virtual, inherited]

See also:
Control::GetClientRect

Reimplemented from Control.

INT GridLayout::GetColumnCount ( ) const [inline, inherited]

Returns:
the number of columns

INT GridLayout::GetRowCount ( ) const [inline, inherited]

Returns:
the number of rows

GridLayout::GridLayout | ( | Control * | parent,
 |  | INT | row_count,
 |  | INT | col_count = 1,
 |  | Size | min_size = Size(-1,-1)
 | ) | [inherited]

Parameters:
parent | Parent control, where the grid layout control is embedded.
row_count | Number of rows of the grid.
col_count | Number of columns of the grid.
min_size | Minimum size of the grid. If -1 is used for the width/height, the width/height of the client area will be used and no minimum is given. If available area is smaller than the minimum area, the layouter control automatically adds a vertical and/or horizontal position indicator so that the content can be scrolled.

GridLayout::GridLayout ( ) [inherited]

If the default constructor is used, the parameters have to be provided by using the method Init.

void GridLayout::Init | ( | Control * | parent,
 |  | INT | row_count,
 |  | INT | col_count = 1,
 |  | Size | min_size = Size(-1,-1)
 | ) | [inherited]

Parameters:
parent | Parent control, where the grid layout control is embedded.
row_count | Number of rows of the grid.
col_count | Number of columns of the grid.
min_size | Minimum size of the grid. If -1 is used for the width/height, the width/height of the client area will be used and no minimum is given. If available area is smaller than the minimum area, the layouter control automatically adds a vertical and/or horizontal position indicator so that the content can be scrolled.

BOOLEAN GridLayout::IsInstanceOf ( INT id ) const [virtual, inherited]

See also:
Component::IsInstanceOf

Reimplemented from Control.

void GridLayout::OnFocusNextControl ( ) [protected, virtual, inherited]

See also:
Control::OnFocusPreviousControl

Reimplemented from Control.

void GridLayout::OnFocusPreviousControl ( ) [protected, virtual, inherited]

See also:
Control::OnFocusPreviousControl

Reimplemented from Control.

void GridLayout::OnGetFocus ( ) [protected, virtual, inherited]

See also:
Control::OnGetFocus

Reimplemented from Control.

BOOLEAN GridLayout::OnKeyAutoRepeat ( KeyCode key_code ) [protected, virtual, inherited]

See also:
Control::OnKeyAutoRepeat

Reimplemented from Control.

BOOLEAN GridLayout::OnKeyDown ( KeyCode key_code ) [protected, virtual, inherited]

See also:
Control::OnKeyDown

Reimplemented from Control.

void GridLayout::OnLayoutClient ( ) [protected, virtual, inherited]

See also:
Control::OnLayoutClient

Reimplemented from Control.

void GridLayout::OnThemeChanged ( ) [protected, virtual, inherited]

See also:
Component::OnThemeChanged

Reimplemented from Control.

void GridLayout::SetCellProperties | ( | INT | row,
 |  | INT | col,
 |  | Component * | component,
 |  | XAlign | x_align = XDefault,
 |  | YAlign | y_align = YDefault
 | ) | [inherited]

Sets a component into the specified cell with the given alignment

Parameters:
row | Row number of the cell
col | Column number of the cell
component | Component which should be aligned
x_align | Horizontal alignment of component within cell
y_align | Vertical alignment of component within cell

void GridLayout::SetColumnProperty | ( | INT | col,
 |  | StretchUnit | stretch_unit,
 |  | INT | value = 0
 | ) | [inherited]

Sets the property of the selected column

Parameters:
col | Number of column whose properties should be changed
stretch_unit | Determines whether the stretching value is given in Pixels of Percent
value | Value for stretching

BOOLEAN GridLayout::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id
 | ) | [inherited]

Used by Aragon to fill the properties by reading out a resource file. It should not be necessary for the application developer to invoke this method in a direct manner.

Reimplemented from Control.

void GridLayout::SetRowProperty | ( | INT | row,
 |  | StretchUnit | stretch_unit,
 |  | INT | value = 0
 | ) | [inherited]

Sets the property of the selected row

Parameters:
row | Number of row whose properties should be changed
stretch_unit | Determines whether the stretching value is given in Pixels of Percent
value | Value for stretching

GridLayout::~GridLayout ( ) [virtual, inherited]

Variable Documentation

INT GridLayout::LayouterProperties::value [inherited]

XAlign GridLayout::Cell::x_align [inherited]

YAlign GridLayout::Cell::y_align [inherited]

Generated on Wed Jan 25 02:29:50 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Editors

Editors
[GUI, Components]

Collaboration diagram for Editors:

Data Structures

class | AbstractEditor
Abstract base class for all editors. More...
class | AbstractEditorItem
class | AbstractLineEditor
class | AbstractLineEditorView
class | AbstractMultiLineEditor
Abstract base class for all multiline editors. More...
class | AbstractMultiLineEditorView
View which shows the content of a multiline editor. More...
class | AtomItem
class | CalculatorInputMapper
Manages the input of numbers and a decimal point. More...
class | Caret
class | CharItem
Editor-Item which contains a wide-character. More...
class | CompoundItem
class | DateCompoundItem
Contains a date. More...
class | DateEditor
class | DateEditorDocument
A Date-Editor-Document contains a Date-Compound-Item. More...
class | DateEditorView
class | DateTimeInputMapper
class | DefaultCaret
class | EditorDocument
class | EditorDocumentObtainer
class | EditorLine
class | InputMapper
class | IpAddrCompoundItem
Contains a date. More...
class | IpAddrEditor
class | IpAddrEditorDocument
A IpAddr-Editor-Document contains a IpAddr-Compound-Item. More...
class | IpAddrInputMapper
Manages the input of a ip adress. More...
class | LineEditor
class | MultiLineEditor
class | MultiTapCaret
Caret specialized for multi-tab input-mode. More...
class | MultiTapInputMapper
class | NumericInputMapper
class | PasswordEditor
class | PhoneNumberInputMapper
class | PredInputMapper
Abstract base class for predictive input-mappers. More...
class | TextCompoundItem
Contains a variable number of wide-characters. More...
class | TextEditorDocument
class | TimeCompoundItem
Contains a time. More...
class | TimeEditor
class | TimeEditorDocument
A Time-Editor-Document contains a Time-Compound-Item. More...

Typedefs

typedef EditorDocument::LineAlignment | LineAlignment
typedef InputMapper::NotificationType | NotificationType
typedef EditorDocument::WrapPolicy | WrapPolicy

Typedef Documentation

typedef EditorDocument::LineAlignment LineAlignment

typedef InputMapper::NotificationType NotificationType

typedef EditorDocument::WrapPolicy WrapPolicy

Generated on Wed Jan 25 02:30:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Sms

Sms
[GUI, Components]

Collaboration diagram for Sms:

Data Structures

class SmsEditor
Generated on Wed Jan 25 02:30:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Obsolete GUI classes

Obsolete GUI classes
[GUI]

Collaboration diagram for Obsolete GUI classes:

Data Structures

class | AbstractIMelodyParser
class | AbstractListBox
class | AbstractListBoxModel
Obsolete, as the class AbstractListBox has been replaced by the class ItemGrid. More...
class | AbstractListBoxView
class | AbstractMenuAccessor
class | ActionExtension
class | AudioContext
class | CancelAction
class | ConfirmAction
class | DialogWindow
class | IMelody
struct | IMelodyData
Holds parsed IMelody data. More...
class | Melody
class | Menu
class | MenuAccessor
class | MenuTextIterator
class | MenuTextPtrArrayIterator
class | MenuView
class | MidiSound
class | PreparedSound
class | SetLanguageAction
class | SetThemeAction
class | SmafSound
class | SoftkeyBar
class | SoftkeyBarView
Describes the view of a Softkey-Bar. More...
class | Sound
class | SoundItem
class | SoundObtainer
class | TextList
class | TextListLine
class | TextListModel
Describes the model of a textlist. More...
class | TextListView
Describes the view of a textlist. More...
class | TextMenuAccessor

Defines

#define | APOXI_MAX_SOFTKEY_COUNT 2

Typedefs

typedef Vector< TextListLine > | TLLVector

Functions

virtual void | AbstractMenuAccessor::Back (Menu *menu)=0
virtual void | AbstractMenuAccessor::Draw (DeviceContext *dc, const Rect &draw_rect, BOOLEAN highlighted)=0
virtual BOOLEAN | AbstractMenuAccessor::First ()=0
virtual INT | AbstractMenuAccessor::GetColumnCount () const
virtual XYDIM | AbstractMenuAccessor::GetItemHeight () const =0
virtual XYDIM | AbstractMenuAccessor::GetItemWidth () const
void | AbstractMenuAccessor::Init ()
virtual BOOLEAN | AbstractMenuAccessor::IsEnabled ()
virtual BOOLEAN | AbstractMenuAccessor::IsRoot ()
virtual BOOLEAN | AbstractMenuAccessor::Next ()=0
virtual void | AbstractMenuAccessor::OnActivate (Menu *menu, AbstractMenuAccessor *parent_accessor)
This method will be called every time the MenuAccessor will be activated (after changing a menu level).
virtual void | AbstractMenuAccessor::OnDeactivate (Menu *menu)
This method will be called every time the MenuAccessor will be deactivated (before changing a menu level).
virtual void | AbstractMenuAccessor::OnLanguageChanged ()
virtual BOOLEAN | AbstractMenuAccessor::OnMessage (const Message &msg)
virtual void | AbstractMenuAccessor::OnSelectionChanged (INT selected_idx)
This method will be called every time the selection of the menu changes.
virtual void | AbstractMenuAccessor::Trigger (Menu *menu)=0
virtual | AbstractMenuAccessor::~AbstractMenuAccessor ()

Define Documentation

#define APOXI_MAX_SOFTKEY_COUNT 2

Typedef Documentation

typedef Vector<TextListLine> TLLVector

Function Documentation

virtual void AbstractMenuAccessor::Back ( Menu * menu ) [pure virtual, inherited]

Implemented in MenuAccessor, and TextMenuAccessor.

virtual void AbstractMenuAccessor::Draw | ( | DeviceContext * | dc,
 |  | const Rect & | draw_rect,
 |  | BOOLEAN | highlighted
 | ) | [pure virtual, inherited]

Draws the menu item.

Parameters:
dc | Pointer to the device context for drawing.
draw_rect | Rectangle which describes the area where to draw the menu item.
highlighted | TRUE, if the menu item to be drawn is the currently selected one.

Implemented in MenuAccessor, and TextMenuAccessor.

virtual BOOLEAN AbstractMenuAccessor::First ( ) [pure virtual, inherited]

Sets the MenuAccessor to have access to the first menu item. This will not change the index of the selected item!

Returns:
FALSE, if there is no first menu item.

Implemented in ActionMenuAccessor, and TextMenuAccessor.

INT AbstractMenuAccessor::GetColumnCount ( ) const [virtual, inherited]

Returns:
Number of columns.

Reimplemented in MenuAccessor.

virtual XYDIM AbstractMenuAccessor::GetItemHeight ( ) const [pure virtual, inherited]

Returns:
Defines the height of all menu items.

Implemented in MenuAccessor, and TextMenuAccessor.

XYDIM AbstractMenuAccessor::GetItemWidth ( ) const [virtual, inherited]

Returns:
Defines the width of all menu items. -1 automatically sets the cell width depending on the number of columns.

void AbstractMenuAccessor::Init ( ) [inherited]

BOOLEAN AbstractMenuAccessor::IsEnabled ( ) [virtual, inherited]

Determines whether or not this menuAccessor can be triggered.

Returns:
TRUE.

Reimplemented in AbstractActionMenuAccessor.

BOOLEAN AbstractMenuAccessor::IsRoot ( ) [virtual, inherited]

Returns TRUE, if the current state of the menu-accessors represents a root-menu. Per default TRUE is returned.

Reimplemented in MenuAccessor.

virtual BOOLEAN AbstractMenuAccessor::Next ( ) [pure virtual, inherited]

Sets the MenuAccessor to the next menu item. This will not change the index of the selected item!

Returns:
FALSE, if there is no next menu item.

Implemented in ActionMenuAccessor, and TextMenuAccessor.

void AbstractMenuAccessor::OnActivate | ( | Menu * | menu,
 |  | AbstractMenuAccessor * | parent_accessor
 | ) | [protected, virtual, inherited]

This method will be called every time the MenuAccessor will be activated (after changing a menu level).

Reimplemented in MenuAccessor.

void AbstractMenuAccessor::OnDeactivate ( Menu * menu ) [protected, virtual, inherited]

This method will be called every time the MenuAccessor will be deactivated (before changing a menu level).

Reimplemented in MenuAccessor.

void AbstractMenuAccessor::OnLanguageChanged ( ) [protected, virtual, inherited]

This method will be called every time the language changes. Overwrite this method to retranslate the text of the menu items.

Reimplemented in AbstractActionMenuAccessor, and MenuAccessor.

BOOLEAN AbstractMenuAccessor::OnMessage ( const Message & msg ) [protected, virtual, inherited]

See also:
Dispatcher::OnMessage

Implements Dispatcher.

Reimplemented in MenuAccessor.

void AbstractMenuAccessor::OnSelectionChanged ( INT selected_idx ) [protected, virtual, inherited]

This method will be called every time the selection of the menu changes.

Reimplemented in MenuAccessor.

virtual void AbstractMenuAccessor::Trigger ( Menu * menu ) [pure virtual, inherited]

Implemented in AbstractActionMenuAccessor, MenuAccessor, and TextMenuAccessor.

AbstractMenuAccessor::~AbstractMenuAccessor ( ) [virtual, inherited]

Generated on Wed Jan 25 02:30:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Items

Items
[GUI]

Collaboration diagram for Items:

Data Structures

class | AbstractToggleAction
class | Action
class | CheckBoxAction
class | CloseWindowAction
class | Item
class | ItemContainer
class | OpenContextMenuAction
class | OpenWindowAction
class | RadioButtonAction
class | RadioButtonGroup
Handles deselection of radiobutton-actions. More...
class | ToggleActionGroup
Handles unique selection of abstract toggle actions. More...

Typedefs

typedef ResourceID | MenuID

Typedef Documentation

typedef ResourceID MenuID

Generated on Wed Jan 25 02:29:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SerialSocket

SerialSocket

Data Structures

class | SerialIoAdapter
struct | SerialIoAdapter::SioErrorDesc
class | SerialIoSet
Maintains fd set for the socket operations. More...
class | SerialSocketThread

Defines

#define | SIO_SIGNAL_DATA_SENT SIO_SIGNAL_LAST_BIT_SENT
#define | SIO_USE_SOCKET_CONCEPT 1

Enumerations

enum SerialIoAdapter::ErrorCode {
SerialIoAdapter::c_sio_err_none = SIO_ERR_NONE, SerialIoAdapter::c_sio_err_acces = SIO_ERR_ACCES, SerialIoAdapter::c_sio_err_addrnnotvail = SIO_ERR_ADDRNOTAVAIL, SerialIoAdapter::c_sio_err_afnosupport = SIO_ERR_AFNOSUPPORT,
SerialIoAdapter::c_sio_err_again = SIO_ERR_AGAIN, SerialIoAdapter::c_sio_err__already = SIO_ERR_ALREADY, SerialIoAdapter::c_sio_err_badf = SIO_ERR_BADF, SerialIoAdapter::c_sio_err_busy = SIO_ERR_BUSY,
SerialIoAdapter::c_sio_err_connrefused = SIO_ERR_CONNREFUSED, SerialIoAdapter::c_sio_err_fault = SIO_ERR_FAULT, SerialIoAdapter::c_sio_err_inprogress = SIO_ERR_INPROGRESS, SerialIoAdapter::c_sio_err_inval = SIO_ERR_INVAL,
SerialIoAdapter::c_sio_err_nametoolong = SIO_ERR_NAMETOOLONG, SerialIoAdapter::c_sio_err_nfile = SIO_ERR_NFILE, SerialIoAdapter::c_sio_err_noact = SIO_ERR_NOACT, SerialIoAdapter::c_sio_err_nodev = SIO_ERR_NODEV,
SerialIoAdapter::c_sio_err_nomem = SIO_ERR_NOMEM, SerialIoAdapter::c_sio_err_noopt = SIO_ERR_NOOPT, SerialIoAdapter::c_sio_err_noprotoopt = SIO_ERR_NOPROTOOPT, SerialIoAdapter::c_sio_err_nosubdev = SIO_ERR_NOSUBDEV,
SerialIoAdapter::c_sio_err_nosys = SIO_ERR_NOSYS, SerialIoAdapter::c_sio_err_notsock = SIO_ERR_NOTSOCK, SerialIoAdapter::c_sio_err_nscan = SIO_ERR_NSCAN, SerialIoAdapter::c_sio_err_opnotsupp = SIO_ERR_OPNOTSUPP,
SerialIoAdapter::c_sio_err_protonosupport = SIO_ERR_PROTONOSUPPORT, SerialIoAdapter::c_sio_err_sockstate = SIO_ERR_SOCKSTATE, SerialIoAdapter::c_sio_err_timeout = SIO_ERR_TIMEDOUT, SerialIoAdapter::c_sio_err_max = SIO_ERR_MAX
}
enum SerialIoSet::SerialSocketEvent {
SerialIoSet::NONE, SerialIoSet::ABORT, SerialIoSet::CLOSE_REQ, SerialIoSet::CONNECT_REQ,
SerialIoSet::CONNECT_SUCCESS, SerialIoSet::CONNECT_FAIL, SerialIoSet::DATA_RECEIVED, SerialIoSet::DATA_SENT,
SerialIoSet::DISCONNECT_IND, SerialIoSet::UNKNOWN
}
enum | SerialIoAdapter::SocketFamily { SerialIoAdapter::c_sock_pf_undef = 0, SerialIoAdapter::c_sock_pf_termio, SerialIoAdapter::c_sock_pf_bt, SerialIoAdapter::c_sock_pf_max }

Functions

INT | SerialIoAdapter::Accept (SerialSocket &clientSock, SocketAddr &sock_addr)
BOOLEAN | SerialIoSet::Add (const SerialSocketData *s)
INT | SerialIoSet::AddToReadList (const SerialSocketData *sockdata)
INT | SerialIoSet::AddToWriteList (const SerialSocketData *sockdata)
INT | SerialIoAdapter::Bind (SocketAddr &sock_addr)
INT | SerialIoAdapter::Close ()
INT | SerialIoAdapter::Connect (SocketAddr &serv_addr)
INT | SerialIoAdapter::GetErrorNumber (SioErrorDesc &errorinfo)
SerialSocketEvent | SerialIoSet::GetEvent (const SerialSocketData *sockdata) const
BOOLEAN | SerialIoSet::Init ()
INT | SerialIoAdapter::IoCtl (INT requestcode, INT argument)
INT | SerialIoAdapter::Listen (INT backlog)
INT | SerialIoAdapter::Open (SocketFamily fam, INT protocol)
INT | SerialIoAdapter::OptGet (INT optname, void *optval, INT &optlen)
INT | SerialIoAdapter::OptSet (INT optname, void *optval, INT optlen)
INT | SerialIoAdapter::Read (void *buf, LONG length)
BOOLEAN | SerialIoSet::Remove (const SerialSocketData *s)
INT | SerialIoSet::RemoveFromReadList (const SerialSocketData *sockdata)
INT | SerialIoSet::RemoveFromWriteList (const SerialSocketData *sockdata)
INT | SerialIoSet::Select (const Ticks *t_timeout)
SerialIoAdapter::SerialIoAdapter ()
BOOLEAN | SerialIoSet::SignalSelect ()
BOOLEAN | SerialIoSet::TestFor (const SerialSocketData *sockdata) const
INT | SerialIoAdapter::Write (const void *buf, LONG count)
SerialIoAdapter::~SerialIoAdapter ()
SerialIoSet::~SerialIoSet ()

Variables

ErrorCode SerialIoAdapter::SioErrorDesc::c_global_errno
CHAR * | SerialIoAdapter::SioErrorDesc::file_name
LONG | SerialIoAdapter::SioErrorDesc::line_no
fd_set_t | SerialIoSet::m_read_fdset
INT | SerialIoSet::m_selectid
fd_set_t | SerialIoSet::m_write_fdset
friend | SerialIoAdapter::SerialIoSet

Define Documentation

#define SIO_SIGNAL_DATA_SENT SIO_SIGNAL_LAST_BIT_SENT

#define SIO_USE_SOCKET_CONCEPT 1

Enumeration Type Documentation

enum SerialIoAdapter::ErrorCode [inherited]

Enumerator:
c_sio_err_none
c_sio_err_acces
c_sio_err_addrnnotvail
c_sio_err_afnosupport
c_sio_err_again
c_sio_err__already
c_sio_err_badf
c_sio_err_busy
c_sio_err_connrefused
c_sio_err_fault
c_sio_err_inprogress
c_sio_err_inval
c_sio_err_nametoolong
c_sio_err_nfile
c_sio_err_noact
c_sio_err_nodev
c_sio_err_nomem
c_sio_err_noopt
c_sio_err_noprotoopt
c_sio_err_nosubdev
c_sio_err_nosys
c_sio_err_notsock
c_sio_err_nscan
c_sio_err_opnotsupp
c_sio_err_protonosupport
c_sio_err_sockstate
c_sio_err_timeout
c_sio_err_max

enum SerialIoSet::SerialSocketEvent [inherited]

Enumerator:
NONE
ABORT
CLOSE_REQ
CONNECT_REQ
CONNECT_SUCCESS
CONNECT_FAIL
DATA_RECEIVED
DATA_SENT
DISCONNECT_IND
UNKNOWN

enum SerialIoAdapter::SocketFamily [inherited]

Enumerator:
c_sock_pf_undef
c_sock_pf_termio
c_sock_pf_bt
c_sock_pf_max

Function Documentation

INT SerialIoAdapter::Accept | ( | SerialSocket & | clientSock,
 |  | SocketAddr & | sock_addr
 | ) | [inherited]

Please refer to sock_accept in sio_sock.h

Parameters:
clientSock | client socket that will be used for communication after accepting the connection
sock_addr | Reference to a SocketAddr object. This will contain remote device parameters on successful connection
Returns:
0 on success and -1 on failure.

BOOLEAN SerialIoSet::Add ( const SerialSocketData * s ) [inline, inherited]

Adds socket's fd to the read and write fd set.

Returns:
TRUE if successful, FALSE otherwise.

INT SerialIoSet::AddToReadList ( const SerialSocketData * sockdata ) [inherited]

Adds socket's fd to the read set.

Returns:
TRUE if successful, FALSE otherwise.

INT SerialIoSet::AddToWriteList ( const SerialSocketData * sockdata ) [inherited]

Adds socket's fd to the write set.

Returns:
TRUE if successful, FALSE otherwise.

INT SerialIoAdapter::Bind ( SocketAddr & sock_addr ) [inherited]

Reads data from the socket.

Parameters:
sock_addr Reference to a SocketAddr object.
Returns:
0 on success and -1 on failure.

INT SerialIoAdapter::Close ( ) [inherited]

Closes the socket connection with the device so that it can no longer be used for communication.

Returns:
0 on success and -1 on failure.

INT SerialIoAdapter::Connect ( SocketAddr & serv_addr ) [inherited]

Reads data from the socket.

Parameters:
serv_addr Reference to a SocketAddr object.
Returns:
0 on success and -1 on failure.

INT SerialIoAdapter::GetErrorNumber ( SioErrorDesc & errorinfo ) [inherited]

Get the Last Error Code. If wrap_sio_err_desc_s is 0 then the global error no is returned.

Parameters:
errorinfo pointer to wrap_sio_err_desc_s object.
Returns:
0 on success and -1 on failure.

SerialIoSet::SerialSocketEvent SerialIoSet::GetEvent ( const SerialSocketData * sockdata ) const [inherited]

Returns the reason for the wakeup of select.

Returns:
SerialSocketEvent.
See also:
SerialIoSet::SerialSocketEvent.

BOOLEAN SerialIoSet::Init ( ) [inherited]

INT SerialIoAdapter::IoCtl | ( | INT | requestcode,
 |  | INT | argument
 | ) | [inherited]

INT SerialIoAdapter::Listen ( INT backlog ) [inherited]

Listens for connections on socket.

Returns:
0 on success and -1 on failure.

INT SerialIoAdapter::Open | ( | SocketFamily | fam,
 |  | INT | protocol
 | ) | [inherited]

Please refer to sock_create in sio_sock.h

Parameters:
fam | specifies the socket family.
protocol | specifies the protocol to be used. Refer BtProtocol in BtSocketAddr.
Returns:
0 on success and -1 on failure.

INT SerialIoAdapter::OptGet | ( | INT | optname,
 |  | void * | optval,
 |  | INT & | optlen
 | ) | [inherited]

Retrieves the option value.

Parameters:
optname | option name to retrive value
optval | pointer to the option value
optlen | pointer to the option value length
Returns:
0 on success and -1 on failure.

INT SerialIoAdapter::OptSet | ( | INT | optname,
 |  | void * | optval,
 |  | INT | optlen
 | ) | [inherited]

Sets the option value.

Parameters:
optname | option name to set value
optval | pointer to the option value
optlen | pointer to the option value length
Returns:
Number of bytes written or -1 on failure.

INT SerialIoAdapter::Read | ( | void * | buf,
 |  | LONG | length
 | ) | [inherited]

Reads data from the socket.

Parameters:
buf | Pointer to read buffer.
length | Length of read buffer.
Returns:
Number of bytes read or -1 on failure.

BOOLEAN SerialIoSet::Remove ( const SerialSocketData * s ) [inline, inherited]

Removes socket's fd from the read and write fd set.

Returns:
TRUE if successful, FALSE otherwise.

INT SerialIoSet::RemoveFromReadList ( const SerialSocketData * sockdata ) [inherited]

Removes socket's fd from the read set.

Returns:
TRUE if successful, FALSE otherwise.

INT SerialIoSet::RemoveFromWriteList ( const SerialSocketData * sockdata ) [inherited]

Removes socket's fd from the write set.

Returns:
TRUE if successful, FALSE otherwise.

INT SerialIoSet::Select ( const Ticks * t_timeout ) [inherited]

Waits for activation on read and write fd set.

Returns:
number of fds changed.

SerialIoAdapter::SerialIoAdapter ( ) [inherited]

BOOLEAN SerialIoSet::SignalSelect ( ) [inherited]

Wakes up a waiting select.

Returns:
TRUE if successful, FALSE otherwise.

BOOLEAN SerialIoSet::TestFor ( const SerialSocketData * sockdata ) const [inherited]

Tests if the socket's fd is part of the read/ write fd set.

Returns:
TRUE if successful, FALSE otherwise.

INT SerialIoAdapter::Write | ( | const void * | buf,
 |  | LONG | count
 | ) | [inherited]

Reads data from the socket.

Parameters:
buf | Pointer to read buffer.
count | no of bytes to be written.
Returns:
Number of bytes written or -1 on failure.

SerialIoAdapter::~SerialIoAdapter ( ) [inherited]

SerialIoSet::~SerialIoSet ( ) [inherited]

Variable Documentation

ErrorCode SerialIoAdapter::SioErrorDesc::c_global_errno [inherited]

CHAR* SerialIoAdapter::SioErrorDesc::file_name [inherited]

LONG SerialIoAdapter::SioErrorDesc::line_no [inherited]

fd_set_t SerialIoSet::m_read_fdset [inherited]

INT SerialIoSet::m_selectid [inherited]

fd_set_t SerialIoSet::m_write_fdset [inherited]

friend SerialIoAdapter::SerialIoSet [inherited]

Generated on Wed Jan 25 02:26:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Socket

Socket

Data Structures

class | CsdDataConn
class | CsdDataConnProfile
class | DataConn
class | DataConnManager
class | DataConnProfile
class | DataConnProfileManager
class | DataConnProfileStorage
class | DnsClient
class | DnsClientTest
class | InetSocket
class | InetSocketAddr
class | PersistDataConnProfile
struct | PppCallBackData
Types needed for lwIP PPP connections. More...
class | PppDataConn
struct | PppSetupCallBackData
class | PsdDataConn
class | PsdDataConnProfile
class | SerialSocketData
class | SerialSocketDataLock
class | SerialSocketSubSystem
class | Socket
class | SocketData
class | SocketDataLock
class | SocketEventListener
class | SocketHandler
class | SocketRxThread
class | SocketSubSystem
class | SysDnsClient
class | SysDnsClient
class | SysSocket
class | SysSocket
class | SysSocketBase
Base SysSocket. More...
class | TcpServerSocket
class | TcpSocket
class | TcpSocketBase
class | UdpSocket

Defines

#define | APOXI_APN_NAME_LEN_MAX 99
#define | APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX 25
#define | APOXI_BEARER_PROFILE_NAME_LEN_MAX 20
#define | APOXI_BEARER_PROFILE_PASSWD_LEN_MAX 15
#define | APOXI_DATA_CONN_PROFILE_COUNT 5
#define | APOXI_DATA_CONN_TEMP_PROFILE_COUNT 15
#define | APOXI_HOST_NAME_LEN_MAX 64
#define | APOXI_MAX_INET_SOCKET_COUNT 16
#define | APOXI_SOCKET_SYSTEM_WIN32
#define | SocketTrace(x)

Typedefs

typedef UINT8 | DataConnProfileId
typedef DataConnProfileId | DataConnProfileIdSet [c_data_conn_profile_count]
typedef NiSharedPtr< DataConnProfile > | DataConnProfilePtr
typedef NiSharedPtr< DataConn > | DataConnPtr
typedef NiSharedPtr< DataConn > | DataConnPtr
typedef NiSharedPtr< DataConn > | DataConnPtr
typedef DataConnProfileId | DataConnTempProfileIdSet [c_data_conn_temp_profile_count]
typedef NiSharedPtr< PdpContext::PacketFilter > | PdpPacketFilterPtr
typedef void(* | PppCallback )(INT error, PppDataConn &dc, const PppCallBackData *data)
typedef void(* | PsdIfCallback )(INT error, void *client_arg)

Enumerations

enum DataConnInfoMsgType {
c_csd_data_conn_init, c_csd_data_conn_established, c_csd_data_conn_setup_failed, c_csd_data_conn_init_release,
c_csd_data_conn_released, c_csd_data_conn_setup_blocked, c_psd_data_conn_init, c_psd_data_conn_established,
c_psd_data_conn_setup_failed, c_psd_data_conn_init_release, c_psd_data_conn_released, c_psd_data_conn_setup_blocked,
c_ser_data_conn_init, c_ser_data_conn_established, c_ser_data_conn_setup_failed, c_ser_data_conn_init_release,
c_ser_data_conn_released, c_ser_data_conn_setup_blocked
}
enum | DataConnProfileInfoMsgType { c_data_conn_profile_created, c_data_conn_profile_changed, c_data_conn_profile_deleted, c_data_conn_profile_set_as_default }
enum SocketControlMsgType {
c_scmt_rx_data_arrived, c_scmt_tx_data_ready, c_scmt_ppp_setup_err, c_scmt_ppp_setup,
c_scmt_ppp_stop_err, c_scmt_ppp_stop, c_scmt_csd_setup_err, c_scmt_csd_datacall_setup,
c_scmt_csd_datacall_setup_success, c_scmt_csd_datacall_setup_fail, c_scmt_csd_datacall_release, c_scmt_csd_lost,
c_scmt_psd_setup_err, c_scmt_psd_ctx_defined, c_scmt_psd_ctx_undefined, c_scmt_psd_ctx_dns_neg_set,
c_scmt_psd_ctx_packet_filter_set, c_scmt_psd_ctx_authenticated, c_scmt_psd_ctx_qos_set, c_scmt_psd_ctx_deactivated,
c_scmt_psd_ctx_connected, c_scmt_psd_ctx_neg_dns_read, c_scmt_psd_ctx_link_up, c_scmt_psd_ctx_link_down,
c_scmt_psd_lost, c_scmt_data_conn_established, c_scmt_idle_timeout, c_scmt_init_context_err,
c_scmt_data_conn_cancelled, c_scmt_control_data_available, c_scmt_undefined
}
enum SocketError {
c_socket_no_error = 0, c_socket_unknown_error = 1, c_socket_no_bearer = 2, c_socket_bearer_busy = 3,
c_socket_bearer_not_supported = 4, c_socket_fatal_system_error = 5, c_socket_wrong_execution_context = 6, c_socket_subsystem_not_init = 7,
c_socket_no_data_conn_profile = 8, c_socket_conn_setup_failed = 9, c_socket_conn_in_release = 10, c_socket_conn_in_setup = 11,
c_socket_conn_blocked = 12, c_socket_conn_perform_setup = 13, c_socket_conn_timed_out = 14, c_socket_conn_lost = 15,
c_socket_wait_for_send_unblocked = 16, c_socket_wait_for_recv_unblocked = 17, c_socket_ebadf = 100, c_socket_eintr = 101,
c_socket_einval = 102, c_socket_enotsock = 103, c_socket_eopnotsupp = 104, c_socket_ewouldblock = 105,
c_socket_eaddrnotavail = 106, c_socket_eacces = 107, c_socket_eisconn = 108, c_socket_etimedout = 109,
c_socket_econnrefused = 110, c_socket_enetunreach = 111, c_socket_eaddrinuse = 112, c_socket_ealready = 113,
c_socket_einprogress = 114, c_socket_enotconn = 115, c_socket_emsgsize = 116, c_socket_enobufs = 117,
c_socket_enoprotoopt = 118, c_socket_emfile = 119, c_socket_econnreset = 120, c_socket_ehostunreach = 121,
c_socket_econnaborted = 122, c_socket_efault = 123, c_socket_edestaddrreq = 124, c_socket_eprototype = 125,
c_socket_eprotonosupport = 126, c_socket_esocktnosupport = 127, c_socket_epfnosupport = 128, c_socket_eafnosupport = 129,
c_socket_enetdown = 130, c_socket_enetreset = 131, c_socket_eshutdown = 132, c_socket_ehostdown = 133
}

Variables

const UINT | c_apn_name_len_max = APOXI_APN_NAME_LEN_MAX
const UINT | c_data_conn_profile_count = APOXI_DATA_CONN_PROFILE_COUNT
const UINT | c_data_conn_temp_profile_count = APOXI_DATA_CONN_TEMP_PROFILE_COUNT
const DataConnProfileId | c_default_data_conn_profile_id = c_invalid_data_conn_profile_id
const UINT | c_host_name_len_max = APOXI_HOST_NAME_LEN_MAX
const DataConnProfileId | c_invalid_data_conn_profile_id = 0
const DataConnProfileId | c_max_data_conn_profile_id = (1 << (sizeof(DataConnProfileId) * 8 - 1)) - 1
const UINT | c_max_inet_socket_count = APOXI_MAX_INET_SOCKET_COUNT

Define Documentation

#define APOXI_APN_NAME_LEN_MAX 99

#define APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX 25

#define APOXI_BEARER_PROFILE_NAME_LEN_MAX 20

#define APOXI_BEARER_PROFILE_PASSWD_LEN_MAX 15

#define APOXI_DATA_CONN_PROFILE_COUNT 5

#define APOXI_DATA_CONN_TEMP_PROFILE_COUNT 15

#define APOXI_HOST_NAME_LEN_MAX 64

#define APOXI_MAX_INET_SOCKET_COUNT 16

#define APOXI_SOCKET_SYSTEM_WIN32

#define SocketTrace ( x )

Typedef Documentation

typedef UINT8 DataConnProfileId

DataConnProfileId is the type of a data connection identifier. A DataConnProfileId is a unique value assigned to a specific DataConnProfile at creation time. It is very unlikely that two profiles will be assigned the same identifier.

typedef DataConnProfileId DataConnProfileIdSet[c_data_conn_profile_count]

DataConnProfileIdSet is a set of data connection profile identifiers.

typedef NiSharedPtr<DataConnProfile> DataConnProfilePtr

typedef NiSharedPtr<DataConn> DataConnPtr

typedef NiSharedPtr<DataConn> DataConnPtr

typedef NiSharedPtr<DataConn> DataConnPtr

typedef DataConnProfileId DataConnTempProfileIdSet[c_data_conn_temp_profile_count]

DataConnTempProfileIdSet is a set of temporary data connection profile identifiers.

typedef NiSharedPtr<PdpContext::PacketFilter> PdpPacketFilterPtr

typedef void(* PppCallback)(INT error, PppDataConn &dc, const PppCallBackData *data)

typedef void(* PsdIfCallback)(INT error, void *client_arg)

Enumeration Type Documentation

enum DataConnInfoMsgType

DataConnInfoMsgType defines the informational code in DataConnInfoMsg.

Enumerator:
c_csd_data_conn_init
c_csd_data_conn_established
c_csd_data_conn_setup_failed
c_csd_data_conn_init_release
c_csd_data_conn_released
c_csd_data_conn_setup_blocked
c_psd_data_conn_init
c_psd_data_conn_established
c_psd_data_conn_setup_failed
c_psd_data_conn_init_release
c_psd_data_conn_released
c_psd_data_conn_setup_blocked
c_ser_data_conn_init
c_ser_data_conn_established
c_ser_data_conn_setup_failed
c_ser_data_conn_init_release
c_ser_data_conn_released
c_ser_data_conn_setup_blocked

enum DataConnProfileInfoMsgType

DataConnProfileInfoMsgType defines the informational code in DataConnProfileInfoMsg.

Enumerator:
c_data_conn_profile_created
c_data_conn_profile_changed
c_data_conn_profile_deleted
c_data_conn_profile_set_as_default

enum SocketControlMsgType

SocketControlMsgType specifies the control code for SocketControlMsg.

Enumerator:
c_scmt_rx_data_arrived | Data can be read from socket.
c_scmt_tx_data_ready | Socket is ready to send data.
c_scmt_ppp_setup_err | PPP setup error.
c_scmt_ppp_setup | PPP setup done.
c_scmt_ppp_stop_err | PPP stop error.
c_scmt_ppp_stop | PPP stop done.
c_scmt_csd_setup_err | CSD setup error.
c_scmt_csd_datacall_setup | CSD data call setup.
c_scmt_csd_datacall_setup_success | CSD data call setup success.
c_scmt_csd_datacall_setup_fail | CSD data call setup failed.
c_scmt_csd_datacall_release | CSD data call has been released.
c_scmt_csd_lost | CSD lost.
c_scmt_psd_setup_err | PSD setup error.
c_scmt_psd_ctx_defined | PDP context defined.
c_scmt_psd_ctx_undefined | PDP context undefined.
c_scmt_psd_ctx_dns_neg_set | PDP context DNS negotiation set.
c_scmt_psd_ctx_packet_filter_set | PDP context packet filter set.
c_scmt_psd_ctx_authenticated | PDP context authentication data set.
c_scmt_psd_ctx_qos_set | PDP context quality of service data set.
c_scmt_psd_ctx_deactivated | PDP context deactivated.
c_scmt_psd_ctx_connected | PDP context connected.
c_scmt_psd_ctx_neg_dns_read | PDP context negotiated DNS read.
c_scmt_psd_ctx_link_up | PDP context link up.
c_scmt_psd_ctx_link_down | PDP context link down.
c_scmt_psd_lost | PDP context lost.
c_scmt_data_conn_established | Data connection setup completed.
c_scmt_idle_timeout | Data connection lost due to idle timeout.
c_scmt_init_context_err | Problem initializing context.
c_scmt_data_conn_cancelled | Data connection was cancelled.
c_scmt_control_data_available | Only for testing purposes.
c_scmt_undefined | TerminalSocket control data is available.

enum SocketError

SocketError defines APOXI socket specific error codes and standard BSD socket error codes. For further details about BSD socket error codes please refer to the Berkeley socket documentation.

Enumerator:
c_socket_no_error No error.

-- APOXI specific socket error codes --.
c_socket_unknown_error | Unknown error of system sockets.
c_socket_no_bearer | No bearer for data connection available.
c_socket_bearer_busy | Requested bearer is busy with a differing data connection.
c_socket_bearer_not_supported | Requested bearer is not supported.
c_socket_fatal_system_error | Fatal system error, i.e. something is completely messed up.
c_socket_wrong_execution_context | Request done by a differing execution context.
c_socket_subsystem_not_init | Socket subsystem is not initialized yet.
c_socket_no_data_conn_profile | Specified data connection profile not found.
c_socket_conn_setup_failed | Data connection setup failed.
c_socket_conn_in_release | Data connection setup failed as previous connection has not yet finished release.
c_socket_conn_in_setup | Data connection is getting set up right now.
c_socket_conn_blocked | Data connection is blocked.
c_socket_conn_perform_setup | Data connection has to be setup by this socket.
c_socket_conn_timed_out | Data connection timed out.
c_socket_conn_lost | Data connection lost.
c_socket_wait_for_send_unblocked | Waiting for the send control message was unblocked.
c_socket_wait_for_recv_unblocked Waiting for the receive control message was unblocked.

-- BSD specific socket error codes --.
c_socket_ebadf | Bad socket file descriptor.
c_socket_eintr Interrupted function call.
A blocking operation was interrupted.
c_socket_einval Invalid argument passed.
Some invalid argument was supplied (for example, specifying an invalid level to the setsockopt function). In some instances, it also refers to the current state of the socket, for instance, calling accept on a socket that is not listening.
c_socket_enotsock Socket operation on nonsocket.
An operation was attempted on something that is not a socket or on an invalid (i.e. not open) socket.
c_socket_eopnotsupp Operation not supported.
The attempted operation is not supported for the type of object referenced.
c_socket_ewouldblock Resource temporarily unavailable.
This error is returned from operations on nonblocking sockets that cannot be completed immediately. It is a nonfatal error, and the operation should be retried later.
c_socket_eaddrnotavail Cannot assign requested address.
The requested address is not valid in its context. This normally results from an attempt to bind to an address that is not valid for the local machine.
c_socket_eacces Permission denied.
An attempt was made to access a socket in a way forbidden by its access permissions. An example is using a broadcast address for sendto without broadcast permission being set using setsockopt(SO_BROADCAST).
c_socket_eisconn Socket is already connected.
A connect request was made on an already-connected socket. Some implementations also return this error if sendto is called on a connected SOCK_DGRAM socket (for SOCK_STREAM sockets, the to parameter in sendto is ignored) although other implementations treat this as a legal occurrence.
c_socket_etimedout Connection timed out.
A connect or send request failed because the connected party did not properly respond after a period of time. The timeout period is dependent on the communication protocol.
c_socket_econnrefused Connection refused.
No connection could be made because the target machine actively refused it. This usually results from trying to connect to a service that is inactive on the foreign host.
c_socket_enetunreach Network is unreachable.
A socket operation was attempted to an unreachable network.
c_socket_eaddrinuse Address already in use.
Only one usage of each socket address (protocol/IP address/port) is permitted.
c_socket_ealready Operation already in progress.
An operation was attempted on a non-blocking object that already had an operation in progress.
c_socket_einprogress Operation now in progress.
An operation that takes a long time to complete (such as a) was attempted on a non-blocking socket.
c_socket_enotconn Socket is not connected.
A request to send or receive data was disallowed because the socket is not connected and (when sending on a datagram socket) no address was supplied.
c_socket_emsgsize Message too long.
A message sent on a socket was larger than the internal message buffer or some other network limit.
c_socket_enobufs No buffer space available.
An operation on a socket or pipe was not performed because the system lacked sufficient buffer space or because a queue was full.
c_socket_enoprotoopt Bad protocol option.
An unknown, invalid or unsupported option or level was specified in a getsockopt or setsockopt call.
c_socket_emfile Too many open sockets.
Too many open sockets. Each implementation may have a maximum number of socket handles available, either globally, per process, or per thread.
c_socket_econnreset Connection reset by peer.
A connection was forcibly closed by a peer. This normally results from a loss of the connection on the remote socket due to a timeout or a reboot.
c_socket_ehostunreach No route to host.
A socket operation was attempted to an unreachable host.
c_socket_econnaborted Software caused connection abort.
A connection abort was caused internal to your host machine. The software caused a connection abort because there is no space on the socket's queue and the socket cannot receive further connections.
c_socket_efault Bad address.
The system detected an invalid address in attempting to use an argument of a call.
c_socket_edestaddrreq Destination address required.
A required address was omitted from an operation on a socket.
c_socket_eprototype Protocol wrong type for socket.
A protocol was specified that does not support the semantics of the socket type requested. For example, you cannot use the internet UDP protocol with type SOCK_STREAM.
c_socket_eprotonosupport Protocol not supported.
The protocol has not been configured into the system, or no implementation for it exists.
c_socket_esocktnosupport Socket type not supported.
The support for the socket type has not been configured into the system or no implementation for it exists.
c_socket_epfnosupport Protocol family not supported.
The protocol family has not been configured into the system or no implementation for it exists.
c_socket_eafnosupport Address family not supported by protocol family.
An address incompatible with the requested protocol was used. For example, you shouldn't necessarily expect to be able to use NS addresses with ARPA Internet protocols.
c_socket_enetdown Network is down.
A socket operation encountered a dead network.
c_socket_enetreset Network dropped connection on reset.
The host you were connected to crashed and rebooted.
c_socket_eshutdown Cannot send after socket shutdown.
A request to send data was disallowed because the socket had already been shut down.
c_socket_ehostdown Host is down.
A socket operation failed because the destination host was down. A socket operation encountered a dead host. Networking activity on the local host has not been initiated.

Variable Documentation

const UINT c_apn_name_len_max = APOXI_APN_NAME_LEN_MAX

c_apn_name_len_max specifies the maximum length of a APN name in GPRS Data Connection profile.

const UINT c_data_conn_profile_count = APOXI_DATA_CONN_PROFILE_COUNT

c_data_conn_profile_count specifies the maximum number of DataConnProfiles APOXI can handle

const UINT c_data_conn_temp_profile_count = APOXI_DATA_CONN_TEMP_PROFILE_COUNT

c_data_conn_temp_profile_count specifies the maximum number of temporary DataConnProfiles APOXI can handle

const DataConnProfileId c_default_data_conn_profile_id = c_invalid_data_conn_profile_id

c_invalid_data_conn_profile_id is a placeholder for id of default DataConnProfile

const UINT c_host_name_len_max = APOXI_HOST_NAME_LEN_MAX

c_host_name_len_max specifies the maximum length of a host name in APOXI

const DataConnProfileId c_invalid_data_conn_profile_id = 0

c_invalid_data_conn_profile_id defines invalid value of a DataConnProfileId

const DataConnProfileId c_max_data_conn_profile_id = (1 << (sizeof(DataConnProfileId) * 8 - 1)) - 1

c_max_data_conn_profile_id defines the upper bound ID a non-temporary data connection profile can get. The range of data connection profile IDs is shared between persistent and temporary data connection profiles, and one value is defined as the invalid data connection profile ID (see c_invalid_data_conn_profile_id).

The whole range is splitted like that: + 0 : the invalid data connection profile ID + 1 .. 127 : range for persistent data connection profile IDs + 128 .. 255 : range for temporary data connection profile IDs

const UINT c_max_inet_socket_count = APOXI_MAX_INET_SOCKET_COUNT

c_max_inet_socket_count specifies the maximum number of InetSockets in parallel.

Generated on Wed Jan 25 02:26:28 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Audio

Audio

Data Structures

class | AudioAccessoryDetails
class | AudioAccessoryStore
class | AudioActiveReference
class | AudioDeviceBase
class | AudioDeviceManager
class | AudioError
class | AudioPath
class | AudioPathManager
class | AudioPlayer
struct | AudioPlayerEvent
class | AudioPlayerStore
class | AudioPreset
class | AudioPresetStore
class | AudioReference
class | AudioUtility
class | AudioVibratorDevice
class | CustomRingerAudioReference
class | CustomSmafPhraseAudioReference
class | CustomToneAudioReference
class | DwdDevice
class | DwdPlayer
class | GenericFeatureData
struct | GenericFeatureData::GenericTrackInfo
This structure is used for setting/getting the track information of a sound. More...
class | MapiAudioPlayer
class | MmfPlayer
class | MP3AudioPlayer
class | MP3AudioReference
class | NonCopyable
class | PresetAudioReference
class | RadioAudioDevice
APOXI interface to FM Radio device. More...
class | SimpleAudioDevice
class | SpeechSimpleAudioDevice
class | StreamAudioPlayer
class | StreamAudioReference
class | TimeFeatureObject

Functions

virtual BOOLEAN | MapiAudioPlayer::CanResume (const AudioActiveReference &active_reference) const
virtual BOOLEAN | MapiAudioPlayer::CanSuspend (const AudioActiveReference &active_reference) const
virtual GenericObject * | GenericFeatureData::Copy () const
Creates a copy of the object itself.
virtual SharedPtr< AudioReference > | MapiAudioPlayer::CreateAudioReferenceFromExtensionSoundDataSource (MimeType mime_type, AudioReference::SoundDataSource sound_data_source)
virtual AudioMapiManager::RequestOutcomeType | MapiAudioPlayer::ForwardCommandToDriver (AudioMapiManager::MapiCommandType &command)
GenericFeatureData::GenericFeatureData (const GenericFeatureData &)
const AudioActiveReference * | GenericFeatureData::GetActiveReference () const
Should be used by audio devices to identify the sound the feature has to be executed for.
void * | GenericFeatureData::GetDataPtr () const
Should be used to retrieve any kind of data.
virtual UINT16 | MapiAudioPlayer::GetDeviceID () const
Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).
const GenericFeatureData::GenericTrackInfo * | GenericFeatureData::GetGenericTrackInfo () const
Should be used be the caller of the feature to get the track information.
static MapiAudioPlayer * | MapiAudioPlayer::GetInstance ()
virtual Vector< MimeTypeSupportInfo > | MapiAudioPlayer::GetMimeTypeSupportInfo () const
UINT32 | GenericFeatureData::GetNumber () const
Should be used to retrieve numbers.
virtual AudioPlayer::AudioSourceType | MapiAudioPlayer::GetSource () const
virtual GenericTypeId | GenericFeatureData::GetTypeId ()
Returns the identity of the class.
virtual BOOLEAN | GenericFeatureData::IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself.
virtual BOOLEAN | MapiAudioPlayer::OnSdlSignal (UINT16 func_id, UINT8 handle, UINT16 drv_id, INT8 return_code, UINT32 param1, UINT32 param2, UINT32 param3, UINT32 param4)
virtual void | MapiAudioPlayer::Play (AudioActiveReference &active_reference)
virtual BOOLEAN | MapiAudioPlayer::Play_Allocate (AudioActiveReference &playing_ref)
void | GenericFeatureData::SetActiveReference (const AudioActiveReference *active_ref)
Should be used by the caller to identify the sound the feature has to be executed for.
static void | MapiAudioPlayer::SetCommandExecutedCondition (UINT32 parm1, UINT32 parm2)
void | GenericFeatureData::SetDataPtr (void *data)
Should be used to pass any kind of data.
void | GenericFeatureData::SetGenericTrackInfo (const GenericFeatureData::GenericTrackInfo &track_info)
Should be used by audio devices which provide track information of sounds.
void | GenericFeatureData::SetNumber (UINT32 data)
Should be used to pass numbers.
void | MapiAudioPlayer::SetStopCallback (BOOLEAN(*cb_stop)(const AudioActiveReference &active_ref))
virtual void | MapiAudioPlayer::Stop (AudioActiveReference &active_reference)
BOOLEAN | MapiAudioPlayer::StopCallbackHaveBeenSet () const
virtual | GenericFeatureData::~GenericFeatureData ()
Destructor of the abstract class GenericObject.

Variables

const WCHAR * | c_free_tone
const UINT8 | c_max_slots = 5
const WCHAR * | c_single_beep
const WCHAR * | c_tone_supervisory_call_waiting
const WCHAR * | c_tone_supervisory_subsciber_busy
WString GenericFeatureData::GenericTrackInfo::m_album
WString GenericFeatureData::GenericTrackInfo::m_artist
WString GenericFeatureData::GenericTrackInfo::m_author
BOOLEAN(* | MapiAudioPlayer::m_cb_stop )(const AudioActiveReference &active_ref)
WString GenericFeatureData::GenericTrackInfo::m_comment
WString GenericFeatureData::GenericTrackInfo::m_composer
WString GenericFeatureData::GenericTrackInfo::m_copyright
WString GenericFeatureData::GenericTrackInfo::m_description
WString GenericFeatureData::GenericTrackInfo::m_duration
WString GenericFeatureData::GenericTrackInfo::m_genre
WString GenericFeatureData::GenericTrackInfo::m_original_artist
WString GenericFeatureData::GenericTrackInfo::m_rating
WString GenericFeatureData::GenericTrackInfo::m_song_name
WString GenericFeatureData::GenericTrackInfo::m_track
WString GenericFeatureData::GenericTrackInfo::m_url
WString GenericFeatureData::GenericTrackInfo::m_year

Function Documentation

BOOLEAN MapiAudioPlayer::CanResume ( const AudioActiveReference & active_reference ) const [virtual, inherited]

Reimplemented from DwdPlayer.

BOOLEAN MapiAudioPlayer::CanSuspend ( const AudioActiveReference & active_reference ) const [virtual, inherited]

Reimplemented from DwdPlayer.

GenericObject * GenericFeatureData::Copy ( ) const [virtual, inherited]

Creates a copy of the object itself.

Implements GenericObject.

SharedPtr< AudioReference > MapiAudioPlayer::CreateAudioReferenceFromExtensionSoundDataSource | ( | MimeType | mime_type,
 |  | AudioReference::SoundDataSource | sound_data_source
 | ) | [virtual, inherited]

AudioMapiManager::RequestOutcomeType MapiAudioPlayer::ForwardCommandToDriver ( AudioMapiManager::MapiCommandType & command ) [protected, virtual, inherited]

GenericFeatureData::GenericFeatureData ( const GenericFeatureData & ) [inherited]

const AudioActiveReference * GenericFeatureData::GetActiveReference ( ) const [inherited]

Should be used by audio devices to identify the sound the feature has to be executed for.

void * GenericFeatureData::GetDataPtr ( ) const [inherited]

Should be used to retrieve any kind of data.

UINT16 MapiAudioPlayer::GetDeviceID ( ) const [virtual, inherited]

Get the unique device ID used whenever the resource is allocated (not used in casse of speech device since the allocation is done by MN process).

Implements AudioDeviceBase.

const GenericFeatureData::GenericTrackInfo * GenericFeatureData::GetGenericTrackInfo ( ) const [inherited]

Should be used be the caller of the feature to get the track information.

MapiAudioPlayer * MapiAudioPlayer::GetInstance ( ) [static, inherited]

Vector< AudioPlayer::MimeTypeSupportInfo > MapiAudioPlayer::GetMimeTypeSupportInfo ( ) const [virtual, inherited]

This function may not be called directly by code outside of APOXI.

UINT32 GenericFeatureData::GetNumber ( ) const [inherited]

Should be used to retrieve numbers.

AudioPlayer::AudioSourceType MapiAudioPlayer::GetSource ( ) const [virtual, inherited]

GenericTypeId GenericFeatureData::GetTypeId ( ) [virtual, inherited]

Returns the identity of the class.

Implements GenericObject.

BOOLEAN GenericFeatureData::IsEqual ( GenericObject * object ) [virtual, inherited]

Compares the object parameter with the object instance itself.

Implements GenericObject.

BOOLEAN MapiAudioPlayer::OnSdlSignal | ( | UINT16 | func_id,
 |  | UINT8 | handle,
 |  | UINT16 | drv_id,
 |  | INT8 | return_code,
 |  | UINT32 | param1,
 |  | UINT32 | param2,
 |  | UINT32 | param3,
 |  | UINT32 | param4
 | ) | [protected, virtual, inherited]

Reimplemented from DwdPlayer.

void MapiAudioPlayer::Play ( AudioActiveReference & active_reference ) [virtual, inherited]

BOOLEAN MapiAudioPlayer::Play_Allocate ( AudioActiveReference & playing_ref ) [protected, virtual, inherited]

Implements DwdDevice.

void GenericFeatureData::SetActiveReference ( const AudioActiveReference * active_ref ) [inherited]

Should be used by the caller to identify the sound the feature has to be executed for.

void MapiAudioPlayer::SetCommandExecutedCondition | ( | UINT32 | parm1,
 |  | UINT32 | parm2
 | ) | [static, protected, inherited]

void GenericFeatureData::SetDataPtr ( void * data ) [inherited]

Should be used to pass any kind of data.

void GenericFeatureData::SetGenericTrackInfo ( const GenericFeatureData::GenericTrackInfo & track_info ) [inherited]

Should be used by audio devices which provide track information of sounds.

void GenericFeatureData::SetNumber ( UINT32 data ) [inherited]

Should be used to pass numbers.

void MapiAudioPlayer::SetStopCallback ( BOOLEAN(*)(const AudioActiveReference &active_ref) cb_stop ) [inherited]

void MapiAudioPlayer::Stop ( AudioActiveReference & active_reference ) [virtual, inherited]

BOOLEAN MapiAudioPlayer::StopCallbackHaveBeenSet ( ) const [protected, inherited]

GenericFeatureData::~GenericFeatureData ( ) [virtual, inherited]

Destructor of the abstract class GenericObject.

Variable Documentation

const WCHAR* c_free_tone

const UINT8 c_max_slots = 5

const WCHAR* c_single_beep

const WCHAR* c_tone_supervisory_call_waiting

const WCHAR* c_tone_supervisory_subsciber_busy

WString GenericFeatureData::GenericTrackInfo::m_album [inherited]

WString GenericFeatureData::GenericTrackInfo::m_artist [inherited]

WString GenericFeatureData::GenericTrackInfo::m_author [inherited]

BOOLEAN(* MapiAudioPlayer::m_cb_stop)(const AudioActiveReference &active_ref) [protected, inherited]

WString GenericFeatureData::GenericTrackInfo::m_comment [inherited]

WString GenericFeatureData::GenericTrackInfo::m_composer [inherited]

WString GenericFeatureData::GenericTrackInfo::m_copyright [inherited]

WString GenericFeatureData::GenericTrackInfo::m_description [inherited]

WString GenericFeatureData::GenericTrackInfo::m_duration [inherited]

WString GenericFeatureData::GenericTrackInfo::m_genre [inherited]

WString GenericFeatureData::GenericTrackInfo::m_original_artist [inherited]

WString GenericFeatureData::GenericTrackInfo::m_rating [inherited]

WString GenericFeatureData::GenericTrackInfo::m_song_name [inherited]

WString GenericFeatureData::GenericTrackInfo::m_track [inherited]

WString GenericFeatureData::GenericTrackInfo::m_url [inherited]

WString GenericFeatureData::GenericTrackInfo::m_year [inherited]

Generated on Wed Jan 25 02:26:58 2006 for APOXI by doxygen 1.4.6-NO


APOXI: APOXI File Systems

APOXI File Systems

Generated on Wed Jan 25 02:27:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Root File System

Root File System
[Afs]

Collaboration diagram for Root File System:

Modules

FAT filesystem support
Flash File System support
RAM File System support
Virtual Root File System support

Data Structures

class | DirectoryIterator
Client interface and base class for directory iterators. More...
class | File
Client interface and base class for files. More...
class | FileBinData
class | FileChunkOperator
class | FileDataSink
class | FileDataSource
class | FileFilter
Base class for file filters. More...
class | FileVisitor
Base class for file visitors. More...
class | ImageFileFilter
File filter filtering image files More...
class | NamePatternFileFilter
File filter filtering files by a name pattern More...
class | NamePatternStorageDeviceFilter
Storage device filter filtering storage devices by a name pattern. More...
class | Path
Path identifying a file throughout the system. More...
class | Pathname
Pathname identifying a file relative to a storage device. More...
class | PathProfile
Utility class to persist a path. More...
class | RootFileSystem
Client interface for root file system access. More...
class | RootStorageDeviceIterator
Device iterator implementation for virtual root storage device. More...
class | SoundFileFilter
File filter filtering sound files More...
class | StorageDevice
Client interface and base class for storage devices. More...
class | StorageDeviceFilter
Base class for storage device filters. More...
class | StorageDeviceIterator
Storage device iterator. More...
class | StorageDeviceVisitor
Base class for storage device visitors. More...

Defines

#define | APOXI_MAX_NET_FILENAME_LENGTH 255
#define | APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH 3
#define | APOXI_MAX_PATHNAME_LENGTH

Typedefs

typedef NiSharedPtr< DirectoryIterator > | DirectoryIteratorPtr
Smart-pointer controlling a DirectoryIterator object.
typedef NiSharedPtr< FileDataSink > | FileDataSinkPtr
Smart-pointer controlling a FileDataSink object.
typedef NiSharedPtr< FileDataSource > | FileDataSourcePtr
Smart-pointer controlling a FileDataSource object.
typedef NiSharedPtr< FileFilter > | FileFilterPtr
Smart-pointer controlling a FileFilter object.
typedef NiSharedPtr< FileFilter > | FileFilterPtr
typedef NiSharedPtr< File > | FilePtr
Smart-pointer controlling a File object.
typedef NiSharedPtr< File > | FilePtr
Smart-pointer controlling a File object.
typedef NiSharedPtr< File > | FilePtr
Smart-pointer controlling a File object.
typedef NiSharedPtr< File > | FilePtr
Smart-pointer controlling a File object.
typedef NiSharedPtr< RootStorageDeviceIterator > | RootStorageDeviceIteratorPtr
Smart-pointer controlling a RootStorageDeviceIterator object.
typedef NiSharedPtr< StorageDeviceFilter > | StorageDeviceFilterPtr
typedef NiSharedPtr< StorageDeviceFilter > | StorageDeviceFilterPtr
Smart-pointer controlling a StorageDeviceFilter object.
typedef NiSharedPtr< StorageDeviceIterator > | StorageDeviceIteratorPtr
Smart-pointer controlling a StorageDeviceIterator object.
typedef NiSharedPtr< StorageDevice > | StorageDevicePtr
typedef NiSharedPtr< StorageDevice > | StorageDevicePtr
typedef NiSharedPtr< StorageDevice > | StorageDevicePtr
Smart-pointer controlling a StorageDevice object.

Detailed Description

Module Root File System (RFS) is APOXI's API layer which provides unified file and directory access to data stored on any kind of storage device.

Purpose and design goals

  • Unified file and directory access on any storage device available on the mobile station
  • Locate files and directories via paths
  • Provide iterators to easily traverse the files of a directory
  • Allow filtering of files while traversing
  • Support visitor pattern to be prepared for future needs
  • Unicode interface for internationalization
  • Support for plug & play storage devices
  • Save with respect to memory leaks
  • Extensible for new storage devices without any change in existing code

Concepts

  • Central controller
    • class RootFileSystem (only static members)
  • Storage devices
    • abstract class StorageDevice
  • Paths, pathnames, and persistable path profiles
    • classes Path, Pathname, and PathProfile
  • Files and directories
    • abstract class File
  • Directory iterators with file filters
    • abstract class DirectoryIterator and class FileFilter
  • Storage device iterators with storage device filters
    • classes StorageDeviceIterator and StorageDeviceFilter
  • File visitors
    • abstract class FileVisitor
  • Storage device visitors
    • abstract class StorageDeviceVisitor

Class hierarchy overview

The following four images give an overview of the root file system's class hierarchy. Please notice the following meaning of colors and line styles:
  • line styles
    • solid boxes: existing classes
    • dashed boxes: possible extensions
  • colors
    • yellow: classes which are used by clients of the RFS
      • strong yellow: concrete classes
      • light yellow: abstract classes
    • blue: classes which are not used by the clients of the RFS, these are pure implementation classes

The core classes:

The path related classes:

The directory and file access related classes:

The storage device access related classes:

How to add storage devices

As already stated the root file system is designed to be easily extended for new storage devices. Actually, to add support for a new storage device the APOXI code doesn't have to be changed at all. This section gives an overview on what to do in general to add support for a new storage device to the root file system.

To integrate a new storage device into the root file system the following basic steps have to be done:

  • find a unique short name for the storage device,
  • implement the three classes StorageDevice, File, and DirectoryIterator, and
  • register the storage device at a proper moment to the root file system.

Storage device short name

Storage devices are identified by a short name which is at most three significant characters in length. E.g., the flash storage device is identified by short name ffs and the virtual root storage device is identified by short name rfs.

It is a basic requirement of the root file system that each storage device has its unique short name for proper functionality. If not, the storage devices having the same name can't be registered to the root file system at the same time. Registering is handled with first-come-first-served policy, the first storage device with a short name not yet registered is registered successfully but registering the second one with the same name will fail.

If, for example, you would like to add a USB storage device to the root file system then usb would be a proper short name since it is not used yet and really a good mnemonic for this kind of storage device.

Write implementation classes

As you can see in the core classes hierarchy chart above there exist the three abstract classes
  • StorageDevice,
  • File, and
  • DirectoryIterator.

For integrating a new storage device into the root file system you have to implement these three classes according to the specifics of the new storage device. The documentation of these three abstract base classes provides detailed information on how to derive implementation classes thereof. There are naming conventions for storage device implementation classes, they are described there, too.

The absolute minimum is to implement the pure virtual methods, however, many other methods are declared virtual to allow overriding them in case, too. The methods of the derived class have to interact with the very basic storage device driver API which is provided for the storage device hardware.

For example, the flash storage device is integrated to the root file system with only the classes

  • FlashStorageDeviceImp,
  • FlashFileImp, and
  • FlashDirectoryIteratorImp.

These three classes also serve as an example and reference for how to properly integrate some storage device into the root file system.

There is another storage device implemented already, the root storage device, which is actually a virtual storage device that provides a virtual root directory / and holds all currently registered storage devices as its subdirectories. The subdirectories of the root are to be interpreted as device directories and have the short name of the respective storage device. The root storage device is implemented using the classes

  • RootStorageDeviceImp,
  • RootFileImp, and
  • RootDirectoryIteratorImp.

In the core classes hierarchy chart above there are also drawn in dashed lines the classes

  • UsbStorageDeviceImp,
  • UsbFileImp, and
  • UsbDirectoryIteratorImp.

These classes don't exist yet, but they show where a new USB storage device would be hooked into the root file system framework.

Register the storage device

Before a storage device can be accessed via the root file system it has to be registered to it. So the last step for integrating a storage device into the root file system is the registration of it to the root file system at runtime. By registration the storage device gets hooked into the root file system framework and from then on is accessible via its storage device short name until it gets unregistered again. We have to distinguish two kinds of storage devices which influence the time of registration:
  • permanent storage devices and
  • plug & play storage devices.

Registering permanent storage devices

Permanent storage devices are always available to the mobile station, they are built-in devices which can't be removed. Permanent storage devices shall be registered at system startup. Some proper code location has to be found where to do that.

Registering plug & play storage devices

Plug & play storage devices can be added to the system and removed from the system at runtime. This means whenever a storage device is plugged in then it has to be registered to the root file system and as soon as it gets plugged out it has to be deregistered from the root file system.

Define Documentation

#define APOXI_MAX_NET_FILENAME_LENGTH 255

Defines the maximal length of a filename supported by the RFS. This length does not include the space for the terminating 0 character. The define defaults to 255 (complying with the MS FAT32 File System Specification), however, it can be overridden on compile time via an overriding command line define.

#define APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH 3

Defines the maximal length of a storage device Id string supported by the RFS. This length does not include the space for the terminating 0 character. The define defaults to 3, however, it can be overridden on compile time via an overriding command line define.

#define APOXI_MAX_PATHNAME_LENGTH

Value:

(                             \
        1 /* The starting separator. */ +                           \
        APOXI_MAX_NET_FILENAME_LENGTH + /* The filename itself. */  \
        1 /* The terminating \c 0 character. */                     \
        )
Defines the maximal pathname length including the terminating 0 character.

Typedef Documentation

typedef NiSharedPtr<DirectoryIterator> DirectoryIteratorPtr

Smart-pointer controlling a DirectoryIterator object.

typedef NiSharedPtr<FileDataSink> FileDataSinkPtr

Smart-pointer controlling a FileDataSink object.

typedef NiSharedPtr<FileDataSource> FileDataSourcePtr

Smart-pointer controlling a FileDataSource object.

typedef NiSharedPtr<FileFilter> FileFilterPtr

Smart-pointer controlling a FileFilter object.

typedef NiSharedPtr<FileFilter> FileFilterPtr

typedef NiSharedPtr<File> FilePtr

Smart-pointer controlling a File object.

typedef NiSharedPtr<File> FilePtr

Smart-pointer controlling a File object.

typedef NiSharedPtr<File> FilePtr

Smart-pointer controlling a File object.

typedef NiSharedPtr<File> FilePtr

Smart-pointer controlling a File object.

typedef NiSharedPtr<RootStorageDeviceIterator> RootStorageDeviceIteratorPtr

Smart-pointer controlling a RootStorageDeviceIterator object.

typedef NiSharedPtr<StorageDeviceFilter> StorageDeviceFilterPtr

typedef NiSharedPtr<StorageDeviceFilter> StorageDeviceFilterPtr

Smart-pointer controlling a StorageDeviceFilter object.

typedef NiSharedPtr<StorageDeviceIterator> StorageDeviceIteratorPtr

Smart-pointer controlling a StorageDeviceIterator object.

typedef NiSharedPtr<StorageDevice> StorageDevicePtr

typedef NiSharedPtr<StorageDevice> StorageDevicePtr

typedef NiSharedPtr<StorageDevice> StorageDevicePtr

Smart-pointer controlling a StorageDevice object.

Generated on Wed Jan 25 02:27:07 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FAT filesystem support

FAT filesystem support
[Root File System]

Collaboration diagram for FAT filesystem support:

Data Structures

class | FatDirectoryIteratorImp
Directory iterator implementation for FAT storage device. More...
class | FatFile
class | FatFileImp
File implementation for FAT filesystem (FAT) storage devices More...
struct | FatFileInfo
struct | FatFindData
class | FatHandler
class | FatStorageDeviceImp
Storage device implementation for FAT storage devices. More...
struct | FsRegistrationInfo

Defines

#define | FatAccessFlagAppend FS_APPEND
#define | FatAccessFlagBinary FS_BINARY
#define | FatAccessFlagCreate FS_CREAT
#define | FatAccessFlagExcl FS_EXCL
#define | FatAccessFlagNoShareAny FS_NOSHAREANY
#define | FatAccessFlagNoShareWrite FS_NOSHAREWRITE
#define | FatAccessFlagRdOnly FS_RDONLY
#define | FatAccessFlagRdWr FS_RDWR
#define | FatAccessFlagText FS_TEXT
#define | FatAccessFlagTrunc FS_TRUNC
#define | FatAccessFlagWrOnly FS_WRONLY
#define | FatSeekBegin FS_SEEK_SET
#define | FatSeekCurrent FS_SEEK_CUR
#define | FatSeekEnd FS_SEEK_END

Typedefs

typedef fs_fd_type | FatHandle
typedef DATESTR | FatTimeRecord

Enumerations

enum FatError {
FatErrorFailure = FS_FAILURE, FatErrorSuccess = FS_SUCCESS, FatErrorOperationNotPossible = FS_ERR_OPERATION_NOT_POSSIBLE, FatErrorUserIdError = FS_ERR_USER_ID_ERROR,
FatErrorBadFormat = FS_ERR_BAD_FORMAT, FatErrorNoCard = FS_ERR_NO_MEDIA, FatErrorBadCard = FS_ERR_BAD_MEDIA, FatChangedCard = FS_ERR_MEDIA_CHANGED,
FatErrorCardFailure = FS_ERR_MEDIA_FAILURE, FatErrorIdError = FS_ERR_ID_ERROR, FatErrorEccError = FS_ERR_ECC_ERROR, FatErrorNotExist = FS_ERR_NOENT,
FatErrorBadFileDescriptor = FS_ERR_BADF, FatErrorAccessDenied = FS_ERR_ACCES, FatErrorFileAlreadyExist = FS_ERR_EXIST, FatErrorUnknown = FS_ERR_FAULT,
FatErrorIO = FS_ERR_IO, FatErrorNegativeFilePointer = FS_ERR_INVAL, FatErrorTooManyFileOpen = FS_ERR_MFILE, FatErrorNoSpace = FS_ERR_NOSPC,
FatErrorShare = FS_ERR_SHARE, FatErrorNoDisk = FS_ERR_DEVICE
}
enum FatFileAttribute {
FatFileAttrRdOnly = ARDONLY, FatFileAttrHidden = AHIDDEN, FatFileAttrSystem = ASYSTEM, FatFileAttrVolume = AVOLUME,
FatFileAttrDirectory = ADIRENT, FatFileAttrArchive = ARCHIVE, FatFileAttrNormal = ANORMAL, FatFileAttrChicagoExt = CHICAGO_EXT
}
enum | FatOpenMode { FatReadOnlyMode = FS_IREAD, FatReadAndWriteMode = FS_IREAD | FS_IWRITE }
enum | FsDeviceType { FsMmcSdDev = FS_MMCSD_DEV, FsNandDev = FS_FTL_DEVICE1, FsFatFfsDev = FS_FFS_DEVICE }

Variables

const UINT | c_max_fat_filename_len = FS_MAXPATH
const UINT | c_max_fat_max_no_open_files = FS_MAX_NO_OPEN_FILES

Define Documentation

#define FatAccessFlagAppend FS_APPEND

#define FatAccessFlagBinary FS_BINARY

#define FatAccessFlagCreate FS_CREAT

#define FatAccessFlagExcl FS_EXCL

#define FatAccessFlagNoShareAny FS_NOSHAREANY

#define FatAccessFlagNoShareWrite FS_NOSHAREWRITE

#define FatAccessFlagRdOnly FS_RDONLY

#define FatAccessFlagRdWr FS_RDWR

#define FatAccessFlagText FS_TEXT

#define FatAccessFlagTrunc FS_TRUNC

#define FatAccessFlagWrOnly FS_WRONLY

#define FatSeekBegin FS_SEEK_SET

#define FatSeekCurrent FS_SEEK_CUR

#define FatSeekEnd FS_SEEK_END

Typedef Documentation

typedef fs_fd_type FatHandle

typedef DATESTR FatTimeRecord

Enumeration Type Documentation

enum FatError

Enumerator:
FatErrorFailure
FatErrorSuccess
FatErrorOperationNotPossible
FatErrorUserIdError
FatErrorBadFormat
FatErrorNoCard
FatErrorBadCard
FatChangedCard
FatErrorCardFailure
FatErrorIdError
FatErrorEccError
FatErrorNotExist
FatErrorBadFileDescriptor
FatErrorAccessDenied
FatErrorFileAlreadyExist
FatErrorUnknown
FatErrorIO
FatErrorNegativeFilePointer
FatErrorTooManyFileOpen
FatErrorNoSpace
FatErrorShare
FatErrorNoDisk

enum FatFileAttribute

Enumerator:
FatFileAttrRdOnly
FatFileAttrHidden
FatFileAttrSystem
FatFileAttrVolume
FatFileAttrDirectory
FatFileAttrArchive
FatFileAttrNormal
FatFileAttrChicagoExt

enum FatOpenMode

Enumerator:
FatReadOnlyMode
FatReadAndWriteMode

enum FsDeviceType

Enumerator:
FsMmcSdDev
FsNandDev
FsFatFfsDev

Variable Documentation

const UINT c_max_fat_filename_len = FS_MAXPATH

const UINT c_max_fat_max_no_open_files = FS_MAX_NO_OPEN_FILES

Generated on Wed Jan 25 02:25:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Flash File System support

Flash File System support
[Root File System]

Collaboration diagram for Flash File System support:

Data Structures

struct | FfsDrmAttrib
FfsDrmAttrib contains the digital rights management attribute. More...
struct | FfsFileInfo
class | FfsHandler
class | FfsMimeTypeMap
struct | FfsMimeTypeMapEntry
struct | FfsRefType
struct | FfsTimeRecord
FfsTimeRecord is updated after every modification of a file. More...
class | FlashDirectoryIteratorImp
Directory iterator implementation for flash storage device. More...
class | FlashFileImp
File implementation for flash file system (FFS) storage device More...
class | FlashStorageDeviceImp
Storage device implementation for flash storage device. More...
class | FlsFile

Defines

#define | ExtFfsFileType(type_name) ((FfsFileType)FFS_FILETYPE_##type_name)
#define | ExtFfsPit(pit_name) ((FfsPit)FFS_##pit_name)
#define | ExtFfsUserType(type_name) ((FfsUserType)FFS_##type_name)

Typedefs

typedef word | FfsFileId
typedef ffs_handle_type | FfsHandle

Enumerations

enum FfsError {
FfsErrorFalse = FFS_FALSE, FfsErrorTrue = FFS_TRUE, FfsErrorSuccess = FFS_SUCCESS, FfsErrorInitializing = FFS_INITIALIZING,
FfsErrorAlreadyOpen = FFS_ALREADY_OPEN, FfsErrorNotOpen = FFS_NOT_OPEN, FfsErrorFileNotFound = FFS_FILE_NOT_FOUND, FfsErrorFileAlreadyCreated = FFS_EXISTS,
FfsErrorIllegalId = FFS_ILLIGAL_ID, FfsErrorIllegalFileHandle = FFS_ILLIGAL_FILE_HANDLE, FfsErrorIllegalType = FFS_ILLIGAL_TYPE, FfsErrorIllegalMode = FFS_ILLIGAL_MODE,
FfsErrorFileRangeError = FFS_FILE_RANGE_ERROR, FfsErrorNotPossible = FFS_OPERATION_NOT_POSSIBLE, FfsErrorWriteError = FFS_WRITE_ERROR, FfsErrorUserIdError = FFS_USER_ID_ERROR,
FfsErrorIntFatalError = FFS_INTERNAL_FATAL_ERROR, FfsErrorMemoryResError = FFS_MEMORY_RES_ERROR, FfsErrorMaxNrOfFilesExcceeded = FFS_MAX_NOF_FILES_EXCEEDED, FfsErrorReqMemNotAvailable = FFS_REQUESTED_MEM_NOT_AVAILABLE,
FfsErrorInvalidFilename = FFS_INVALID_NAME, FfsErrorStreamingNotEnabled = FFS_STREAMING_NOT_ENABLED, FfsErrorOpNotAllowedOnStatFile = FFS_OPERATION_NOT_ALLOWED_ON_STATIC_FILE, FfsErrorMemTablesInconsistent = FFS_MEM_TABLES_INCONSISTENCY,
FfsErrorNoFactoryDefaultFile = FFS_NOT_A_FACTORY_DEFAULT_FILE, FfsErrorReqMemTempNotAvailable = FFS_REQUESTED_MEM_TEMP_NOT_AVAILABLE
}
enum FfsFileType {
FfsFileTypeGeneric = FFS_GENERIC_FILETYPE, FfsFileTypeApoxiSetting = FFS_FILETYPE_APOXI_SETTING, FfsFileTypeAvi = FFS_FILETYPE_AVI, FfsFileTypeBmp = FFS_FILETYPE_BMP,
FfsFileTypeGif = FFS_FILETYPE_GIF, FfsFileTypeHtm = FFS_FILETYPE_HTM, FfsFileTypeHtml = FFS_FILETYPE_HTML, FfsFileTypeIcs = FFS_FILETYPE_ICS,
FfsFileTypeJad = FFS_FILETYPE_JAD, FfsFileTypeJar = FFS_FILETYPE_JAR, FfsFileTypeJrs = FFS_FILETYPE_JRS, FfsFileTypeJpg = FFS_FILETYPE_JPG,
FfsFileTypeJpe = FFS_FILETYPE_JPE, FfsFileTypeJpeg = FFS_FILETYPE_JPEG, FfsFileTypeMidi = FFS_FILETYPE_MIDI, FfsFileTypeMmf = FFS_FILETYPE_MMF,
FfsFileTypeMmiSetting = FFS_FILETYPE_MMI_SETTING, FfsFileTypeMov = FFS_FILETYPE_MOV, FfsFileTypeMp3 = FFS_FILETYPE_MP3, FfsFileTypeMpga = FFS_FILETYPE_MPGA,
FfsFileTypeMpe = FFS_FILETYPE_MPE, FfsFileTypeMpeg = FFS_FILETYPE_MPEG, FfsFileTypeMpg = FFS_FILETYPE_MPG, FfsFileTypePng = FFS_FILETYPE_PNG,
FfsFileTypeTif = FFS_FILETYPE_TIF, FfsFileTypeTxt = FFS_FILETYPE_TXT, FfsFileTypeVcf = FFS_FILETYPE_VCF, FfsFileTypeWapSetting = FFS_FILETYPE_WAP_SETTING,
FfsFileTypeWav = FFS_FILETYPE_WAV, FfsFileTypeWbmp = FFS_FILETYPE_WBMP, FfsFileTypeWml = FFS_FILETYPE_WML, FfsFileTypeWmls = FFS_FILETYPE_WMLS,
FfsFileTypeXhtml = FFS_FILETYPE_XHTML, FfsFileTypeXml = FFS_FILETYPE_XML, FfsFileTypeAim = FFS_FILETYPE_AIM, FfsFileTypeAan = FFS_FILETYPE_AAN,
FfsFileTypeIMelody = FFS_FILETYPE_IMELODY, FfsFileTypeAmr = FFS_FILETYPE_AMR, FfsFileTypeFr = FFS_FILETYPE_FR, FfsFileTypeMmfPhrase = FFS_FILETYPE_MMF_PHRASE,
FfsFileTypeBrowserCache = FFS_FILETYPE_BROWSER_CACHE, FfsFileTypeBrowserDatabase = FFS_FILETYPE_BROWSER_DATBASE, FfsFileTypeSecurityCertificates = FFS_FILETYPE_SECURITY_CERTIFICATES, FfsFileTypePushMessages = FFS_FILETYPE_PUSH_MESSAGES,
FfsFileTypeJamBackup = FFS_FILETYPE_JAM_BACKUP, FfsFileTypeJamDefault = FFS_FILETYPE_JAM_DEFAULT, FfsFileTypeMmsStorage = FFS_FILETYPE_MMS_STORAGE, FfsFileTypeMmsReports = FFS_FILETYPE_MMS_REPORTS,
FfsFileTypeMmsNotification = FFS_FILETYPE_MMS_NOTIFICATION, FfsFileTypeMmsBackup = FFS_FILETYPE_MMS_BACKUP, FfsFileTypeMmsTest = FFS_FILETYPE_MMS_TEST, FfsFileTypeMmsAppReport = FFS_FILETYPE_MMS_APP_REPORT,
FfsFileTypeMmt = FFS_FILETYPE_MMT, FfsFileTypeMyStuff = FFS_FILETYPE_MYSTUFF, FfsFileTypeSms = FFS_FILETYPE_SMS, FfsFileTypeMmsPre = FFS_FILETYPE_MMS_PRE,
FfsFileTypeSettings = FFS_FILETYPE_SETTINGS, FfsFileTypeEmsBmp = FFS_FILETYPE_EMS_BMP, FfsFileTypeSaf = FFS_FILETYPE_SAF, FfsFileTypeSpf = FFS_FILETYPE_SPF,
FfsFileTypeDrmRo = FFS_FILETYPE_DRM_RO, FfsFileTypeRegistry = FFS_FILETYPE_REGISTRY, FfsFileType3gp = FFS_FILETYPE_3GP, FfsFileTypeSvg = FFS_FILETYPE_SVG,
FfsFileTypeSvgz = FFS_FILETYPE_SVGZ, FfsFileTypeMms = FFS_FILETYPE_MMS, FfsFileTypeDrm = FFS_FILETYPE_DRM, FfsFileTypeFrame = FFS_FILETYPE_FRAME,
FfsFileTypeAac = FFS_FILETYPE_AAC, FfsFileTypeM4a = FFS_FILETYPE_M4A, FfsNofFileTypes = FFS_NOF_FILETYPES, FfsFileTypeGarbage = FFS_FILETYPE_GARBAGE,
FfsFileTypeAll = FFS_ALL_FILETYPES
}
enum | FfsOpenMode { FfsOpenModeRead = FFS_FILE_OPEN_READ, FfsOpenModeAppend = FFS_FILE_OPEN_APPEND, FfsOpenModeModify = FFS_FILE_OPEN_MODIFY, FfsOpenModeReadStr = FFS_FILE_OPEN_READ_STREAMING }
enum | FfsPit { FfsNofResId = FFS_NOF_RES_ID }
enum FfsUserType {
FfsUserTypeDwdIo = FFS_DWDIO, FfsUserTypeMp3 = FFS_MP3, FfsUserTypeVr = FFS_VR, FfsUserTypeSms = FFS_SMS,
FfsUserTypeAudio = FFS_AUDIO, FfsUserTypeMmi = FFS_MMI, FfsUserTypeMms = FFS_MMS, FfsUserTypeJava = FFS_JAVA,
FfsUserTypeWap = FFS_WAP, FfsUserTypeAppCon01 = FFS_APCON01, FfsUserTypeAppCon02 = FFS_APCON02, FfsUserTypeAppCon03 = FFS_APCON03,
FfsUserTypeAppCon04 = FFS_APCON04, FfsUserTypeAppCon05 = FFS_APCON05, FfsUserTypeAppCon06 = FFS_APCON06, FfsUserTypeAppCon07 = FFS_APCON07,
FfsUserTypeAppCon08 = FFS_APCON08, FfsUserTypeAppCon09 = FFS_APCON09, FfsUserTypeAppCon10 = FFS_APCON10, FfsUserTypeAppCon11 = FFS_APCON11,
FfsUserTypeAppCon12 = FFS_APCON12, FfsUserTypeAppCon13 = FFS_APCON13, FfsUserTypeAppCon14 = FFS_APCON14, FfsUserTypeAppCon15 = FFS_APCON15,
FfsUserTypeAtc = FFS_ATC, FfsNofUsers = FFS_NOF_USERS
}

Variables

const UINT | c_ffs_block_header_size = 3
const UINT32 | c_ffs_streaming = FFS_STREAMING
const UINT | c_max_filename_len = FFS_MAX_SOF_FILENAME
const UINT32 | c_max_total_ffs_memory
const FfsFileInfo | EmptyFfsFileInfo
EmptyFfsFileInfo should be used for initializing an FfsFileInfo.

Define Documentation

#define ExtFfsFileType ( type_name ) ((FfsFileType)FFS_FILETYPE_##type_name)

This macro allows the client to use project specific file types which are defined at FFS driver level but not mapped to the APOXI FfsFileType enumeration. E.g., if the FFS driver defines a project specific file type named FFS_FILETYPE_MY_FILETYPE_1 then you are able to use it all the same by applying the macro ExtFfsFileType(MY_FILETYPE_1). For supporting it on host you have to define the client specific file type to a unique integral value not yet used as an FFS file type value once before applying the macro since it is not defined in the FFS host simulator.

For managing the project specific file types we recommend generating a dedicated header file which resides in some project specific configuration folder. In this header file all the project specific file types can be centrally defined as defines or constants which use the naming scheme of the APOXI FfsFileType enumeration, e.g.

        #if defined(APOXI_RTOS_WIN32)
            // This has to be a unique integral value not yet used as an FFS
            // file type value.
            #define FFS_FILETYPE_MY_FILETYPE_1 (FfsFileTypeAll + 1)
        #endif

        #define FfsFileTypeMyFiletype1 ExtFfsFileType(MY_FILETYPE_1)

or

        #if defined(APOXI_RTOS_WIN32)
            // This has to be a unique integral value not yet used as an FFS
            // file type value.
            #define FFS_FILETYPE_MY_FILETYPE_1 (FfsFileTypeAll + 1)
        #endif

        const FfsFileType FfsFileTypeMyFiletype1 =
            ExtFfsFileType(MY_FILETYPE_1);

Each file using those project specific file types shall include this header file and is then able to specify the file type as if it was one of the APOXI defined file types, e.g. FfsFileTypeMyFiletype1 for the example given above.

#define ExtFfsPit ( pit_name ) ((FfsPit)FFS_##pit_name)

This macro allows the client to use project specific PITs which are defined at FFS driver level but not mapped to the APOXI FfsPit enumeration. E.g., if the FFS driver defines a project specific PIT named FFS_PIT_MY_PIT_1 then you are able to use it all the same by applying the macro ExtFfsPit(FFS_PIT_MY_PIT_1). For supporting it on host you have to define the client specific PIT to a unique integral value not yet used as a PIT value once before applying the macro since it is not defined in the FFS host simulator. This value has to be lower than FfsNofResId.

For managing the project specific PITs we recommend generating a dedicated header file which resides in some project specific configuration folder. In this header file all the project specific PITs can be centrally defined as defines or constants which use the naming scheme of the APOXI FfsPit enumeration, e.g.

        #if defined(APOXI_RTOS_WIN32)
            // This has to be a unique integral value not yet used as an FFS
            // PIT value. This value has to be lower than FfsNofResId.
            #define FFS_PIT_MY_PIT_1 (FfsNofResId - 1)
        #endif

        #define FfsPitMyPit1 ExtFfsPit(PIT_MY_PIT_1)

or

        #if defined(APOXI_RTOS_WIN32)
            // This has to be a unique integral value not yet used as an FFS
            // PIT value. This value has to be lower than FfsNofResId.
            #define FFS_PIT_MY_PIT_1 (FfsNofResId - 1)
        #endif

        const FfsPit FfsPitMyPit1 = ExtFfsPit(PIT_MY_PIT_1);

Each file using those project specific PITs shall include this header file and is then able to specify the PIT as if it was one of the APOXI defined PITs, e.g. FfsPitMyPit1 for the example given above.

#define ExtFfsUserType ( type_name ) ((FfsUserType)FFS_##type_name)

This macro allows the client to use project specific user types which are defined at FFS driver level but not mapped to the APOXI FfsUserType enumeration. E.g., if the FFS driver defines a project specific user type named FFS_MY_USER_1 then you are able to use it all the same on target by applying the macro ExtFfsUserType(MY_USER_1). For supporting it on host you have to define the client specific user type to a unique integral value not yet used as an FFS user type value once before applying the macro since it is not defined in the FFS host simulator.

For managing the project specific user types we recommend generating a dedicated header file which resides in some project specific configuration folder. In this header file all the project specific user types shall be centrally defined as defines or constants which use the naming scheme of the APOXI FfsUserType enumeration, e.g.

        #if defined(APOXI_RTOS_WIN32)
            // This has to be a unique integral value not yet used as an FFS
            // user type value.
            #define FFS_MY_USER_1 (FfsGarbageCollector + 1)
        #endif

        #define FfsUserTypeMyUser1 ExtFfsUserType(MY_USER_1)

or

        #if defined(APOXI_RTOS_WIN32)
            // This has to be a unique integral value not yet used as an FFS
            // user type value.
            #define FFS_MY_USER_1 (FfsGarbageCollector + 1)
        #endif

        const FfsUserType FfsUserTypeMyUser1 = ExtFfsUserType(MY_USER_1);

Each file using those project specific file types shall include this header file and is then able to specify the user type as if it was one of the APOXI defined user types, e.g. FfsUserTypeMyUser1 for the example given above.

Typedef Documentation

typedef word FfsFileId

Type of a file ID.

typedef ffs_handle_type FfsHandle

FfsHandle controls the access to files. It is also responsible to prevent more processes to operate on a file simultaneously. When calling the FfsHandler::Create() or FfsHandler::Open() methods, a new file handle is created.

Enumeration Type Documentation

enum FfsError

FfsError defines the enumeration values for the result of an FFS operation.

Enumerator:
FfsErrorFalse
FfsErrorTrue
FfsErrorSuccess
FfsErrorInitializing
FfsErrorAlreadyOpen
FfsErrorNotOpen
FfsErrorFileNotFound
FfsErrorFileAlreadyCreated
FfsErrorIllegalId
FfsErrorIllegalFileHandle
FfsErrorIllegalType
FfsErrorIllegalMode
FfsErrorFileRangeError
FfsErrorNotPossible
FfsErrorWriteError
FfsErrorUserIdError
FfsErrorIntFatalError
FfsErrorMemoryResError
FfsErrorMaxNrOfFilesExcceeded
FfsErrorReqMemNotAvailable
FfsErrorInvalidFilename
FfsErrorStreamingNotEnabled
FfsErrorOpNotAllowedOnStatFile
FfsErrorMemTablesInconsistent
FfsErrorNoFactoryDefaultFile
FfsErrorReqMemTempNotAvailable

enum FfsFileType

FfsFileType defines the enumeration values for the currently supported filetypes in the FFS. For every filetype not listed here, the filetype FfsFileTypeGeneric should be used. The FFS then allocates memory from the global pool.

Enumerator:
FfsFileTypeGeneric | For files with no specific type, or for temp-files.
FfsFileTypeApoxiSetting
FfsFileTypeAvi
FfsFileTypeBmp
FfsFileTypeGif
FfsFileTypeHtm
FfsFileTypeHtml
FfsFileTypeIcs | vCalendar file
FfsFileTypeJad | java application descriptor
FfsFileTypeJar | java archive
FfsFileTypeJrs | java record store
FfsFileTypeJpg
FfsFileTypeJpe
FfsFileTypeJpeg
FfsFileTypeMidi
FfsFileTypeMmf | polytone melodies
FfsFileTypeMmiSetting
FfsFileTypeMov
FfsFileTypeMp3
FfsFileTypeMpga
FfsFileTypeMpe
FfsFileTypeMpeg
FfsFileTypeMpg
FfsFileTypePng
FfsFileTypeTif
FfsFileTypeTxt
FfsFileTypeVcf | vCard file
FfsFileTypeWapSetting
FfsFileTypeWav
FfsFileTypeWbmp | wireless bitmap
FfsFileTypeWml
FfsFileTypeWmls | WML script.
FfsFileTypeXhtml
FfsFileTypeXml
FfsFileTypeAim | Apoxi native image.
FfsFileTypeAan | Apoxi animation format.
FfsFileTypeIMelody
FfsFileTypeAmr
FfsFileTypeFr
FfsFileTypeMmfPhrase
FfsFileTypeBrowserCache
FfsFileTypeBrowserDatabase
FfsFileTypeSecurityCertificates
FfsFileTypePushMessages
FfsFileTypeJamBackup
FfsFileTypeJamDefault
FfsFileTypeMmsStorage
FfsFileTypeMmsReports
FfsFileTypeMmsNotification
FfsFileTypeMmsBackup
FfsFileTypeMmsTest
FfsFileTypeMmsAppReport
FfsFileTypeMmt
FfsFileTypeMyStuff
FfsFileTypeSms
FfsFileTypeMmsPre
FfsFileTypeSettings
FfsFileTypeEmsBmp
FfsFileTypeSaf
FfsFileTypeSpf
FfsFileTypeDrmRo
FfsFileTypeRegistry
FfsFileType3gp
FfsFileTypeSvg
FfsFileTypeSvgz
FfsFileTypeMms
FfsFileTypeDrm
FfsFileTypeFrame
FfsFileTypeAac
FfsFileTypeM4a
FfsNofFileTypes | All new file types have to be inserted above this line.
FfsFileTypeGarbage | Special filetype for internal garbage collector only.
FfsFileTypeAll | This should only be used for certain search operations.

enum FfsOpenMode

FfsOpenMode defines the enumeration values for the different open-modes. There is no possibility to open a file in write-mode, since a file is implicitly open in write-mode only after creation. After the file is closed once, the only possible methods to change the content of a file are via FfsOpenModeModify or FfsOpenModeAppend.

Enumerator:
FfsOpenModeRead
FfsOpenModeAppend
FfsOpenModeModify
FfsOpenModeReadStr

enum FfsPit

PIT (Pre-assigned ID Table) enumeration: In the PIT it's possible to reserve some file-IDs at compile-time. These IDs can be used for files that are downloaded during production.

Enumerator:
FfsNofResId

enum FfsUserType

FfsUserType defines the enumeration values for the different users which can access the FFS. The FFS internally considers them as priority.

Enumerator:
FfsUserTypeDwdIo
FfsUserTypeMp3
FfsUserTypeVr
FfsUserTypeSms
FfsUserTypeAudio
FfsUserTypeMmi
FfsUserTypeMms
FfsUserTypeJava
FfsUserTypeWap
FfsUserTypeAppCon01
FfsUserTypeAppCon02
FfsUserTypeAppCon03
FfsUserTypeAppCon04
FfsUserTypeAppCon05
FfsUserTypeAppCon06
FfsUserTypeAppCon07
FfsUserTypeAppCon08
FfsUserTypeAppCon09
FfsUserTypeAppCon10
FfsUserTypeAppCon11
FfsUserTypeAppCon12
FfsUserTypeAppCon13
FfsUserTypeAppCon14
FfsUserTypeAppCon15
FfsUserTypeAtc Used when communicating with the outside world (PC DLL or EasyGSM).
FfsNofUsers

Variable Documentation

const UINT c_ffs_block_header_size = 3

const UINT32 c_ffs_streaming = FFS_STREAMING

const UINT c_max_filename_len = FFS_MAX_SOF_FILENAME

c_max_filename_len defines the maximum length of a filename in the FFS. This value is configurable in the file ffs_def.h via define FFS_MAX_SOF_FILENAME.

const UINT32 c_max_total_ffs_memory

Initial value:

    ((FFS_BLOCK_SIZE - c_ffs_block_header_size * 2) / FFS_SECTOR_SIZE) *
    FFS_SECTOR_SIZE * (FFS_NOF_DYNAMIC_BLOCKS - 1)

const FfsFileInfo EmptyFfsFileInfo

Initial value:

    { FfsFileTypeAll, 0, { 0, 0, 0, 0, 0 }, 0, 0, 0

    }
EmptyFfsFileInfo should be used for initializing an FfsFileInfo.

Generated on Wed Jan 25 02:25:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: RAM File System support

RAM File System support
[Root File System]

Collaboration diagram for RAM File System support:

Data Structures

struct | RamBlockData
class | RamDataSink
class | RamDataSource
class | RamDirectoryIteratorImp
class | RamFile
class | RamFileImp
File implementation for random access memory (RAM) storage device More...
struct | RamFileInfo
class | RamFileNode
class | RamFileObj
class | RamFileSystem
class | RamHandler
class | RamStorageDeviceImp
Storage device implementation for RAM storage device. More...
class | RamStorageMapper

Defines

#define | APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE 0x0400
#define | DBG_OUT_RANGE_AFSRAM_ALWAYS 35600
#define | DBG_OUT_RANGE_AFSRAM_ERROR 35602
#define | DBG_OUT_RANGE_AFSRAM_SUCCESS 35601
#define | DBG_OUT_RANGE_AFSRAM_UNITTEST 35603

Typedefs

typedef NiSharedPtr< RamDataSink > | RamDataSinkPtr
Smart-pointer controlling a RamDataSink object.
typedef NiSharedPtr< RamDataSink > | RamDataSinkPtr
Smart-pointer controlling a RamDataSink object.
typedef NiSharedPtr< RamDataSource > | RamDataSourcePtr
Smart-pointer controlling a RamDataSource object.
typedef NiSharedPtr< RamFile > | RamFilePtr
typedef RamFileNode * | RamHandle

Enumerations

enum RamError {
RamErrorSuccess = 0, RamErrorOperationNotPossible = 3, RamErrorNotExist = 2, RamErrorBadFileDescriptor = 9,
RamErrorFileAlreadyExist = 17, RamErrorAccessDenied = 13, RamErrorNegativeFilePointer = 22, RamErrorNoSpace = 28,
RamErrorShare = 30
}
enum RamFileAttribute {
RamFileAttrRdOnly = 0x01, RamFileAttrHidden = 0x02, RamFileAttrSystem = 0x04, RamFileAttrVolume = 0x08,
RamFileAttrDirectory = 0x10, RamFileAttrArchive = 0x20, RamFileAttrNormal = 0x40, RamFileAttrAll = 0xFF
}
enum | RamOpenMode { RamOpenModeRead = 0x0000200, RamOpenModeWrite = 0x0000400 }

Variables

const UINT16 | c_ram_storage_default_block_size = APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE

Define Documentation

#define APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE 0x0400

#define DBG_OUT_RANGE_AFSRAM_ALWAYS 35600

#define DBG_OUT_RANGE_AFSRAM_ERROR 35602

#define DBG_OUT_RANGE_AFSRAM_SUCCESS 35601

#define DBG_OUT_RANGE_AFSRAM_UNITTEST 35603

Typedef Documentation

typedef NiSharedPtr<RamDataSink> RamDataSinkPtr

Smart-pointer controlling a RamDataSink object.

typedef NiSharedPtr<RamDataSink> RamDataSinkPtr

Smart-pointer controlling a RamDataSink object.

typedef NiSharedPtr<RamDataSource> RamDataSourcePtr

Smart-pointer controlling a RamDataSource object.

typedef NiSharedPtr<RamFile> RamFilePtr

typedef RamFileNode* RamHandle

Enumeration Type Documentation

enum RamError

Enumerator:
RamErrorSuccess
RamErrorOperationNotPossible
RamErrorNotExist
RamErrorBadFileDescriptor
RamErrorFileAlreadyExist
RamErrorAccessDenied
RamErrorNegativeFilePointer
RamErrorNoSpace
RamErrorShare

enum RamFileAttribute

Enumerator:
RamFileAttrRdOnly
RamFileAttrHidden
RamFileAttrSystem
RamFileAttrVolume
RamFileAttrDirectory
RamFileAttrArchive
RamFileAttrNormal
RamFileAttrAll

enum RamOpenMode

Enumerator:
RamOpenModeRead
RamOpenModeWrite

Variable Documentation

const UINT16 c_ram_storage_default_block_size = APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE

Generated on Wed Jan 25 02:25:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Virtual Root File System support

Virtual Root File System support
[Root File System]

Collaboration diagram for Virtual Root File System support:

Data Structures

class | RootDirectoryIteratorImp
Directory iterator implementation for root storage device. More...
class | RootFileImp
File implementation for virtual root storage device More...
class | RootStorageDeviceImp
Storage device implementation for virtual root storage device. More...
Generated on Wed Jan 25 02:25:30 2006 for APOXI by doxygen 1.4.6-NO


APOXI: APC

APC

Data Structures

class | AtKeyParser
class | CommonSignalMapTableNode
class | CommonSignalProcessor
class | CommonStackMsgMapTableNode
class | CommonStackMsgProcessor
class | KeyMsgGenerator
class | ProcessNode
ProcessNode maintains the global SDL process pointer. More...
class | SignalHandler
class | SignalMapTable
struct | SignalMapTableEntry
class | SignalMapTableNode
class | SimClutEntry
class | SimIconDescription
class | SimImage
class | SimImageDescriptor
class | StackMsgMapTable
struct | StackMsgMapTableEntry
class | StackMsgMapTableNode
class | StackMsgProcessor
class | StackTranslator

Typedefs

typedef ApoxiSdlProcessPtrType | ProcessPtr
typedef ApoxiSdlSignalIdType | SdlSignalId
typedef ApoxiSdlSignalNameType | SdlSignalName
typedef CHAR * | StackMsgArgName

Enumerations

enum | SimImageCodingScheme { SimBasicImageCoding = 0x11, SimColorImageCoding = 0x21 }
enum | SimImageRequestType { SimImageHeader = 0, SimImageHeaderBody = 1, SimImageHeaderBodyClut = 2, SimImageHeaderClut = 3 }

Functions

void | TestAtKeyParser ()

Typedef Documentation

typedef ApoxiSdlProcessPtrType ProcessPtr

typedef ApoxiSdlSignalIdType SdlSignalId

typedef ApoxiSdlSignalNameType SdlSignalName

typedef CHAR* StackMsgArgName

Enumeration Type Documentation

enum SimImageCodingScheme

Enumerator:
SimBasicImageCoding
SimColorImageCoding

enum SimImageRequestType

Enumerator:
SimImageHeader
SimImageHeaderBody
SimImageHeaderBodyClut
SimImageHeaderClut

Function Documentation

void TestAtKeyParser ( )

Generated on Wed Jan 25 02:27:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: APOXI Defines

APOXI Defines

Collaboration diagram for APOXI Defines:

Compiler defines which are used to configure the source code. More...

Modules

Internal Defines
Optional Defines
Currently Undocumented Defines (interim section)

Detailed Description

Compiler defines which are used to configure the source code.

Defines, respectively compiler defines, are not used to modify the build-process, but they have impact on the source-code directly. Defines can be related to the features, system environment, but they can also stand of their own.

Naming conventions and usage instructions:

  • All APOXI defines must start with APOXI_.
  • Feature names must be clear and unambiguous.
  • All APOXI defines are only allowed to be used in the scope of APOXI source code.
  • All APOXI defines must be documented and regularly updated in the file apoxi.defines.
  • If a new feature is introduced and this feature is managed by one major feature define, then the postfix SUPPORT must be used as functionality description, like APOXI_<feature>_SUPPORT.
  • If an existing source-code (e.g. interface …) must be disabled for any reason an optional define must be created, with the syntax APOXI_DISABLE_<functionality>.
  • Configuration defines must always have a default value set in the source code, which is used if no value is set from outside.
  • Temporary defines must regularly be checked if they are outdated. Outdated defines have to be removed.
  • All defines must follow the naming convention described for each define type.
Generated on Wed Jan 25 02:27:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Internal Defines

Internal Defines
[APOXI Defines]

Collaboration diagram for Internal Defines:

Modules

Feature Defines
Compiler defines which are internally enabled via APOXI makefiles. The feature defines comprise all the defines, which are set via an APOXI feature.
Environmental Defines
The environmental defines are enabled internally due to the settings build environment.
Generated on Wed Jan 25 02:27:08 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Feature Defines

Feature Defines
[Internal Defines]

Collaboration diagram for Feature Defines:

Compiler defines which are internally enabled via APOXI makefiles. The feature defines comprise all the defines, which are set via an APOXI feature. More...

Defines

#define | APOXI_3D_AMPLIFIER_SUPPORT
Adds the themes 'Foggy Theme' and 'Customizable Theme'.
#define | APOXI_ADDITIONAL_THEMES_SUPPORT
Adds the themes 'Foggy Theme' and 'Customizable Theme'.
#define | APOXI_ARAGON_SUPPORT
Enables support for ARAGON.
#define | APOXI_AT_MMI_INTERWORKING_CALL
Call interworking with other clients.
#define | APOXI_AT_MMI_INTERWORKING_SIMTK
SIMTK interworking with other clients.
#define | APOXI_AT_MMI_INTERWORKING_SS
SS interworking with other clients.
#define | APOXI_AT_MMI_INTERWORKING_USSD
USSD interworking with other clients.
#define | APOXI_ATL_SUPPORT
Enables support for ATL.
#define | APOXI_BT_A2DP_SUPPORT
Bluetooth Advanced Audio Distribution Profile
#define | APOXI_CAMERA_MPE_COMPAT
Backwards compat define for MPE camera features
#define | APOXI_CAMERA_SUPPORT
Enables the support for the still camera and video camera device.
#define | APOXI_CAMERA_TWINVIEWFINDER_SUPPORT
TwinViewfinder
#define | APOXI_CTM
Activate TTY.
#define | APOXI_DUAL_DISPLAY_SUPPORT
Enables dual display support for the default DisplayConfig class.
#define | APOXI_EXTERNAL_PCH_CONTROL_SUPPORT
Enables external PCH control support.
#define | APOXI_FACTORY_CUSTOMIZATION_SUPPORT
Allows to use factory customized packs for languages and T9 dictionaries.
#define | APOXI_FM_RADIO_SUPPORT
FM radio support
#define | APOXI_FOTA_SUPPORT
Firmware update Over The Air
#define | APOXI_LIB_ADDON_MMCALL
Multimedia Call Handling API
#define | APOXI_MP3_SUPPORT
MP3 support having codec available in the firmware
#define | APOXI_MULTIMEDIA_SUPPORT
Enables the addon multimedia, which contains image decoders and a multimedia editor.
#define | APOXI_PNG_ENCODER_SUPPORT
Enables the PNG encoder.
#define | APOXI_SECURECLOCK_SUPPORT
Secure Clock
#define | APOXI_SVG_SUPPORT
Enables support for scalable vector graphics.
#define | APOXI_T9_SUPPORT
Enables the predictive text engine T9.
#define | APOXI_UNITTEST
Enables APOXI Unittest framework
#define | APOXI_UNITTEST_NO_FILENAMES
Disables output of filenames, where a unittest failed.
#define | APOXI_UNITTEST_NO_MESSAGE
Disables extensive console output while unittest run.
#define | APOXI_UNITTEST_TCPIP
Enable TCP/IP connections for controlling unit tests.
#define | APOXI_UUS_SUPPORT
Enables UUS support
#define | APOXI_VIDEO_SUPPORT
Enables video support for the display device.
#define | APOXI_YAMAHA_MAPI_SUPPORT
Yamaha Mapi
#define | APOXI_YAMAHA_RINGER_SUPPORT
Enables the YAMAHA audio player.
#define | APOXI_ZI8_SUPPORT
Enables the predictive text engine eZi text.

Detailed Description

Compiler defines which are internally enabled via APOXI makefiles. The feature defines comprise all the defines, which are set via an APOXI feature.

These types of defines are only activated via APOXI features. They must not be declared explicitly, because they are enabled simply by adding the Corresponding features to the project configuration. Internally these features must be linked to the according feature. The feature developer is in charge of preparing this link.

In the common build environment (CBE) this link is enabled in the file cbe_apoxi_makeoptions.mk, located in the directory ${GLOBALPATH}/lnz_apoxi/Apoxi.

Naming convention for new created feature defines:

APOXI_<feature>[_<functionality>], where

  • <feature> is the name of the Corresponding features.
  • <functionality> is any description of a detailed feature functionality (e.g. if the whole feature is covered by one define, then the keyword SUPPORT must be used).

Define Documentation

#define APOXI_3D_AMPLIFIER_SUPPORT

Adds the themes 'Foggy Theme' and 'Customizable Theme'.

This feature enables the 3D enhanced stereo support.

Corresponding features:

  • FEAT_3D_AMPLIFIER

#define APOXI_ADDITIONAL_THEMES_SUPPORT

Adds the themes 'Foggy Theme' and 'Customizable Theme'.

Adds the themes 'Foggy Theme' and 'Customizable Theme' to the already available 'Default Theme'.

Corresponding features:

  • ADDITIONAL_THEMES

#define APOXI_ARAGON_SUPPORT

Enables support for ARAGON.

When user interface design by the host system is desired, this feature must be enabled, otherwise GUI component properties can not be read out of the FFS.

Corresponding features:

  • ARAGON

#define APOXI_AT_MMI_INTERWORKING_CALL

Call interworking with other clients.

If APOXI is not the only client for the stack it is necessary to have some interworking with other clients. Normally ATC is the second client which is the case if bluetooth is activated. In this case this define activates the interworking for call handling and call related supplementary services.

Corresponding features:

  • AT_MMI_INTERWORKING

#define APOXI_AT_MMI_INTERWORKING_SIMTK

SIMTK interworking with other clients.

If APOXI is not the only client for the stack it is necessary to have some interworking with other clients. Normally ATC is the second client which is the case if bluetooth is activated. In this case this define activates the interworking for SIMTK(Sim Toolkit).

Corresponding features:

  • AT_MMI_INTERWORKING

#define APOXI_AT_MMI_INTERWORKING_SS

SS interworking with other clients.

If APOXI is not the only client for the stack it is necessary to have some interworking with other clients. Normally ATC is the second client which is the case if bluetooth is activated. In this case this define activates the interworking for SS(Supplementary Service).

Corresponding features:

  • AT_MMI_INTERWORKING

#define APOXI_AT_MMI_INTERWORKING_USSD

USSD interworking with other clients.

If APOXI is not the only client for the stack it is necessary to have some interworking with other clients. Normally ATC is the second client which is the case if bluetooth is activated. In this case this define activates the interworking for USSD(Unstructured Supplementary Service Structure).

Corresponding features:

  • AT_MMI_INTERWORKING

#define APOXI_ATL_SUPPORT

Enables support for ATL.

This feature must be enabled if ATL classes are used. ATL support is required by ARAGON.
Corresponding features:

  • ATL

#define APOXI_BT_A2DP_SUPPORT

Bluetooth Advanced Audio Distribution Profile

A2DP is a Bluetooth profile that allows the sending of high quality audio data to a remote device (Sink). This feature enables functionality in APOXI Bluetooth, APOXI Audio and the BTAPI stack.

Corresponding features::

  • FEAT_BT_A2DP

Enabled backward compatibility:

  • obsoleted define cleared out: APOXI_BLUETOOTH_A2DP_SUPPORT

#define APOXI_CAMERA_MPE_COMPAT

Backwards compat define for MPE camera features

Enable this define, if there are problems with MPE camera functionality. E.g. WhiteBalance, Metering and Exposure may not be available in the MPE driver.

Corresponding features:

  • CAMERA

#define APOXI_CAMERA_SUPPORT

Enables the support for the still camera and video camera device.

Enables the support for the still camera and video camera device. If the support is enabled, the CameraConfig must be available, which also instantiates the devices for camera and video.

Corresponding features:

  • CAMERA

#define APOXI_CAMERA_TWINVIEWFINDER_SUPPORT

TwinViewfinder

This defines enables Twinviewfinder support for Camera. This may be only supported on special customer projects and is NOT available on the MPE platform itself. By defaul, this define is NOT enabled.

Corresponding features:

  • CAMERA

#define APOXI_CTM

Activate TTY.

For dumb and deaf people it is not possible to use common phones. With a additional device to the phone it is possible to visualize speech on a screen and typed text is translated to speech. This must be supported by the provider because the translation from speech to text and vice versa must be done there. With this feature the support for TTY is activated in APOXI. CTM ... Cordless Telephone/Terminal Mobility

Corresponding features:

  • TTY

#define APOXI_DUAL_DISPLAY_SUPPORT

Enables dual display support for the default DisplayConfig class.

Enables dual display support for the default DisplayConfig class, so that the customization for dual display support is more easy. The define itself is not used by APOXI itself and only meant for allow to turn on the feature DUAL_DISPLAY without touching the class DisplayConfig.

Corresponding features:

  • DUAL_DISPLAY

#define APOXI_EXTERNAL_PCH_CONTROL_SUPPORT

Enables external PCH control support.

Enables support to monitor and control external GPRS data connections (used via AT terminals). The MMI can listen to the ExternalPdpContextInfoMsg message to be informed when the user sets up or terminates a GPRS data connection via AT. Furthermore it is also possible to force the termination of an external GPRS data connection via MMI.

Corresponding features:

  • FEAT_EXTERNAL_PCH_CONTROL

#define APOXI_FACTORY_CUSTOMIZATION_SUPPORT

Allows to use factory customized packs for languages and T9 dictionaries.

Allows to use factory customized packs for languages and T9 dictionaries.

Corresponding features:

  • INTERNATIONALIZATION

Enabled backward compatibility:

  • obsoleted define: APOXI_INTERNATIONALIZATION
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_FM_RADIO_SUPPORT

FM radio support

Support of the FM Radio device including capabilities such as station search or RDS

Corresponding features:

  • FMRADIO

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: APOXI_FM_RADIO_NOT_SUPPORTED
  • obsoleted define cleared out: N/A

#define APOXI_FOTA_SUPPORT

Firmware update Over The Air

This feature enables Firmware update over the air in APOXI. For detailed description see class Fota.

Corresponding features:

  • FEAT_FOTA

#define APOXI_LIB_ADDON_MMCALL

Multimedia Call Handling API

This feature enables APOXI Multimedia Call Hanlding. It provides an interface equivalent to the Voice Call Handling for setting up a MM MOC, accepting or rejecting a MM MTC, for releasing a MM call and provides access to the data stored in the CallHandlingData object of MainHandler.

Corresponding features:

  • FEAT_MMCALL

#define APOXI_MP3_SUPPORT

MP3 support having codec available in the firmware

This feature should be enabled whenever the FW provides MP3 codec. This feature should not be defined when the decoding is done in MMFr (ex. MPE)

Corresponding features:

  • MP3

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_MULTIMEDIA_SUPPORT

Enables the addon multimedia, which contains image decoders and a multimedia editor.

Enables the addon multimedia. The addon contains image decoders for PNG, JPEG, PNG, WBMP, BMP and a multimedia editor.

Corresponding features:

  • MULTIMEDIA

#define APOXI_PNG_ENCODER_SUPPORT

Enables the PNG encoder.

Enables the APOXI support for PNG encoding.

Corresponding features:

  • PNG_ENCODER

#define APOXI_SECURECLOCK_SUPPORT

Secure Clock

Enables additional interfaces in class RealTimeClock to access secure clock information. See RealTimeClock::GetSecureDateTime and RealTimeClock::IsSecureClockValid.

Corresponding features:

  • FEAT_SECURECLOCK

#define APOXI_SVG_SUPPORT

Enables support for scalable vector graphics.

Enables support for scalable vector graphics.

Corresponding features:

  • SVG

#define APOXI_T9_SUPPORT

Enables the predictive text engine T9.

Enables the predictive text engine T9.

Corresponding features:

  • T9

Enabled backward compatibility:

  • obsoleted define: APOXI_INCLUDE_T9
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_UNITTEST

Enables APOXI Unittest framework

Enables the APOXI Unittest framework.

Corresponding features:

  • UNITTEST

Define dependencies:

  • APOXI_UNITTEST_TCPIP is automatically set if feature SOCKET is enabled.
  • APOXI_UNITTEST_NO_MESSAGE is automatically set if feature DEBUG_INFO is not enabled.
  • APOXI_UNITTEST_NO_FILENAMES is automatically set if feature DEBUG_INFO is not enabled.

#define APOXI_UNITTEST_NO_FILENAMES

Disables output of filenames, where a unittest failed.

This define deactivates the output of filenames for failed unit tests. It is automatically set, when the feature DEBUG_INFO is not enabled.

Corresponding features:

  • UNITTEST
  • DEBUG_INFO

Define dependencies:

  • APOXI_UNITTEST mandatory

#define APOXI_UNITTEST_NO_MESSAGE

Disables extensive console output while unittest run.

This define deactivates the output of information about the unittest runs on the console. It is automatically set, when the feature DEBUG_INFO is not enabled.

Corresponding features:

  • UNITTEST
  • DEBUG_INFO

Define dependencies:

  • APOXI_UNITTEST mandatory

#define APOXI_UNITTEST_TCPIP

Enable TCP/IP connections for controlling unit tests.

This define activates the possibility to run unit tests from an host application on the phone over a socket connection. It is automatically set, when the feature SOCKET is enabled.

Corresponding features:

  • UNITTEST
  • SOCKET

Define dependencies:

  • APOXI_UNITTEST mandatory

#define APOXI_UUS_SUPPORT

Enables UUS support

Enables APOXI UUS support. Currently only UUS1 implicit is supported.

Corresponding features:

  • UUS

#define APOXI_VIDEO_SUPPORT

Enables video support for the display device.

Enables video support for the display device. Usually the class VideoChannel from Devices must be adapted to the hardware configuration.

Corresponding features:

  • MULTIMEDIA

#define APOXI_YAMAHA_MAPI_SUPPORT

Yamaha Mapi

The Yamaha MA3 and MA5 chips can be controlled directly through the Yamaha Music API (a set of C-functions wrapping the lower-level Yamaha sound middleware).

Corresponding feature:

  • YAMAHA_MAPI

#define APOXI_YAMAHA_RINGER_SUPPORT

Enables the YAMAHA audio player.

Enables the playback of MIDI, SMAF audio formats on MAx YAMAHA IC

Corresponding features:

  • EXTERNAL_RINGER

#define APOXI_ZI8_SUPPORT

Enables the predictive text engine eZi text.

Enables the predictive text engine eZi text.

Corresponding features:

  • ZI8

Enabled backward compatibility:

  • obsoleted define: APOXI_INCLUDE_ZI8
  • obsoleted define cleared out: APOXI_3.0.0

Generated on Wed Jan 25 02:27:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Environmental Defines

Environmental Defines
[Internal Defines]

Collaboration diagram for Environmental Defines:

The environmental defines are enabled internally due to the settings build environment. More...

Defines

#define | APOXI_3GPP_REL_4_5
Stack interface define to support 3GPP Release 4/5
#define | APOXI_3GPP_REL_99
Stack interface define to support 3GPP Release 99
#define | APOXI_BIG_ENDIAN
Define for Big Endian support.
#define | APOXI_COMPILER_ADS
Compiler define for ARM Developer Suite (ADS) compiler
#define | APOXI_COMPILER_C166
Compiler define for Tasking C166 compiler
#define | APOXI_COMPILER_MSVC
Compiler define for Microsoft Visual C/C++ (MSVC) compiler
#define | APOXI_COMPILER_RVCT
Compiler define for RealView Compilation Tools (RVCT) compiler
#define | APOXI_ICC_SIM
Define for support of the ICC SIM
#define | APOXI_ICC_USIM
Define for support of the ICC USIM
#define | APOXI_LITTLE_ENDIAN
Define for Little Endian support.
#define | APOXI_PLATFORM_BP30
Platform define for BP30
#define | APOXI_PLATFORM_MP1U
Platform define for MP1U
#define | APOXI_PLATFORM_MPE
Platform define for MP-E
#define | APOXI_PLATFORM_MPEU
Platform define for MP-EU
#define | APOXI_RAT_DUAL
Define for support of the dual mode RAT
#define | APOXI_RAT_GSM
Define for support of the single mode RAT GSM
#define | APOXI_RAT_UMTS
Define for support of the single mode RAT GSM
#define | APOXI_RTOS_LINUX
(Real time) operating system define for Linux
#define | APOXI_RTOS_NUC32
(Real time) operating system define for Nucleus 32bit
#define | APOXI_RTOS_OSE166
(Real time) operating system define for OSE166
#define | APOXI_RTOS_WIN32
(Real time) operating system define for Windows 32bit
#define | APOXI_TARGETSYSTEM_HOST
Host build environment define
#define | APOXI_TARGETSYSTEM_HW
Target build environment define

Detailed Description

The environmental defines are enabled internally due to the settings build environment.

The environmental defines are internally created within the make process based on the configuration of the system build environment and must not be declared explicitly. The system build environment includes for example operating system, protocol stack interface, compiler, platform, build mode, target system, and so on. Once the setup is done it should not be changed. Only for reasons of migration to a new system environment adaptations in the mapping of the system build variables to the environmental defines have to be done.

In CBE this setup is established whether in the file apoxi_makeoptions.mk or in the file cbe_apoxi_makeoptions.mk located in the directory ${GLOBALPATH}/lnz_apoxi/Apoxi.

The platform integrator has to care to setup the system build environment (e.g. via ${GLOBALPATH}/system-build/make/project.config.default) accordingly.

Naming convention for new created environmental defines:

APOXI_<system_environment_group>_<system_environment>, where

  • <system_environment_group> defines the type of the system environment, like RTOS, COMPILER, PLATFORM, BUILDMODE, etc.
  • <system_environment> describes a specific element of the system environment, like (in case of <system_environment_group> == RTOS) WIN32, NUC32, LINUX, and so on.

Define Documentation

#define APOXI_3GPP_REL_4_5

Stack interface define to support 3GPP Release 4/5

This define is enabled to achieve compliance to the protocol stack interface for 3GPP Release 4 and Release 5 builds and is used for protocol stack specific implementation in APOXI.

The define is set dependent to the environment variable ${PLATFORM} (e.g. set via project.config.default).

#define APOXI_3GPP_REL_99

Stack interface define to support 3GPP Release 99

This define is enabled to achieve compliance to the protocol stack interface for 3GPP Release 99 builds and is used for protocol stack specific implementation in APOXI.

The define is set dependent to the environment variable ${PLATFORM} (e.g. set via project.config.default).

#define APOXI_BIG_ENDIAN

Define for Big Endian support.

Depending on the computing system the byte order in which multi byte numbers are stored has to be defined.

See also:
APOXI_LITTLE_ENDIAN

#define APOXI_COMPILER_ADS

Compiler define for ARM Developer Suite (ADS) compiler

This define is enabled, when ADS compiler is used. It can be used to cover the code in APOXI, which is specific to the ADS compiler, to handle compiler restrictions or features.

The define is enabled by and based on the environment variable ${COMPILER} (e.g. set via project.config.default).

#define APOXI_COMPILER_C166

Compiler define for Tasking C166 compiler

This define is enabled, when C166 compiler is used. It can be used to cover the code in APOXI, which is specific to the C166 compiler, to handle compiler restrictions or features.

The define is enabled by and based on the environment variable ${COMPILER} (e.g. set via project.config.default).

#define APOXI_COMPILER_MSVC

Compiler define for Microsoft Visual C/C++ (MSVC) compiler

This define is enabled, when MSVC compiler is used. It can be used to cover the code in APOXI, which is specific to the MSVC compiler, to handle compiler restrictions or features.

The define is enabled by and based on the environment variable ${COMPILER} (e.g. set via project.config.default).

#define APOXI_COMPILER_RVCT

Compiler define for RealView Compilation Tools (RVCT) compiler

This define is enabled, when RVCT compiler is used. It can be used to cover the code in APOXI, which is specific to the RVCT compiler, to handle compiler restrictions or features.

The define is enabled by and based on the environment variable ${COMPILER} (e.g. set via project.config.default).

#define APOXI_ICC_SIM

Define for support of the ICC SIM

This define is enabled to support the functionality of integrated circuit card SIM (subscriber identity module) and is used for ICC implementation in APOXI.

The define is set dependent to the environment variable ${PLATFORM} (e.g. set via project.config.default).

#define APOXI_ICC_USIM

Define for support of the ICC USIM

This define is enabled to support the functionality of integrated circuit card USIM (universal subscriber identity module) and is used for ICC implementation in APOXI.

The define is set dependent to the environment variable ${PLATFORM} (e.g. set via project.config.default).

#define APOXI_LITTLE_ENDIAN

Define for Little Endian support.

Depending on the computing system the byte order in which multi byte numbers are stored has to be defined.

See also:
APOXI_BIG_ENDIAN

#define APOXI_PLATFORM_BP30

Platform define for BP30

This define is enabled for every build for the platform BP30 and is used for platform specific implementation in APOXI.

The define is enabled by and based on the environment variable ${PLATFORM} (e.g. set via project.config.default).

Enabled backward compatibility:

  • obsoleted define: APOXI_PROJ_BP30
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_PLATFORM_MP1U

Platform define for MP1U

This define is enabled for every build for the platform MP1U and is used for platform specific implementation in APOXI.

The define is enabled by and based on the environment variable ${PLATFORM} (e.g. set via project.config.default).

Enabled backward compatibility:

  • obsoleted define: APOXI_PROJ_SGOLD
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_PLATFORM_MPE

Platform define for MP-E

This define is enabled for every build for the platform MP-E and is used for platform specific implementation in APOXI.

The define is enabled by and based on the environment variable ${PLATFORM} (e.g. set via project.config.default).

Enabled backward compatibility:

  • obsoleted define: APOXI_PROJ_MPE
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_PLATFORM_MPEU

Platform define for MP-EU

This define is enabled for every build for the platform MP-EU and is used for platform specific implementation in APOXI.

The define is enabled by and based on the environment variable ${PLATFORM} (e.g. set via project.config.default).

#define APOXI_RAT_DUAL

Define for support of the dual mode RAT

This define is enabled to support the dual mode (GSM & UMTS) radio technology features provided by the according stack and is used for dual mode specific implementation in APOXI.

The define is set dependent to the environment variables ${PLATFORM} and ${STACK} (e.g. set via project.config.default).

#define APOXI_RAT_GSM

Define for support of the single mode RAT GSM

This define is enabled to support the single mode radio technology features of GSM (Global System for Mobile communications) provided by the according stack and is used for GSM single mode RAT specific implementation in APOXI.

The define is set dependent to the environment variables ${PLATFORM} and ${STACK} (e.g. set via project.config.default).

#define APOXI_RAT_UMTS

Define for support of the single mode RAT GSM

This define is enabled to support the single mode radio technology features of UMTS (Universal Mobile Telecommunications System) provided by the according stack and is used for UMTS single mode RAT specific implementation in APOXI.

The define is set dependent to the environment variables ${PLATFORM} and ${STACK} (e.g. set via project.config.default).

#define APOXI_RTOS_LINUX

(Real time) operating system define for Linux

This define is enabled for every build on the operating system Linux and is used for OS specific implementation in APOXI. This operating system is used for host simulation and target integration.

The define is enabled by and based on the environment variable ${PLATFORMOS} (e.g. set via project.config.default).

#define APOXI_RTOS_NUC32

(Real time) operating system define for Nucleus 32bit

This define is enabled for every build on the 32bit real time operating system of Nucleus and is used for OS specific implementation in APOXI. This operating system is used only for target integration.

The define is enabled by and based on the environment variable ${PLATFORMOS} (e.g. set via project.config.default).

#define APOXI_RTOS_OSE166

(Real time) operating system define for OSE166

This define is enabled for every build on the 16bit real time operating system OSE166 and is used for OS specific implementation in APOXI. This operating system is used only for target integration.

The define is enabled by and based on the environment variable ${PLATFORMOS} (e.g. set via project.config.default).

#define APOXI_RTOS_WIN32

(Real time) operating system define for Windows 32bit

This define is enabled for every build on the 32bit operating system of Windows and is used for OS specific implementation in APOXI. This operating system is used only for host simulation.

The define is enabled by and based on the environment variable ${PLATFORMOS} (e.g. set via project.config.default).

#define APOXI_TARGETSYSTEM_HOST

Host build environment define

This define is active for every host build and is used host simulation specific implementation.

The define is enabled by and based on the environment variable ${TARGETSYSTEM} (e.g. set via project.config.default).

Enabled backward compatibility:

  • obsoleted define: APOXI_HOST_BUILD
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_TARGETSYSTEM_HW

Target build environment define

This define is active for every target (HW) build and is used target build specific implementation.

The define is enabled by and based on the environment variable ${TARGETSYSTEM} (e.g. set via project.config.default).

Enabled backward compatibility:

  • obsoleted define: APOXI_TARGET_BUILD
  • obsoleted define cleared out: APOXI_3.0.0

Generated on Wed Jan 25 02:27:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Optional Defines

Optional Defines
[APOXI Defines]

Collaboration diagram for Optional Defines:

Modules

Switch Defines
Compiler defines which are used to tune APOXI framework to project needs. The switch defines are used to enable/disable the various "little" APOXI functionalities.
Compatibility Defines
Defines to establish backward compatibility in source code
Configuration Defines
The configuration defines are used to change default settings.
Temporary Defines
The temporary defines should only be introduced for compatibility reasons.
Generated on Wed Jan 25 02:27:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Switch Defines

Switch Defines
[Optional Defines]

Collaboration diagram for Switch Defines:

Compiler defines which are used to tune APOXI framework to project needs. The switch defines are used to enable/disable the various "little" APOXI functionalities. More...

Defines

#define | APOXI_CBS_LIMITATION_MSG
Enables support of the MN_SMS_CB_MESSAGE_ID_LIMIT_IND signal Enables the support of the MN_SMS_CB_MESSAGE_ID_LIMIT_IND signal which indicates the maximum ranges of possible message IDs. This value is then posted via the message CbsLimitMsg.
#define | APOXI_DEBUG_IMAGE_DECODING
Decreases the performance of image decoding to relieve debugging.
#define | APOXI_DISABLE_ENLARGED_GRID_SELECTION
Disables the possibility of having an enlarged grid selection.
#define | APOXI_DISABLE_FILTERED_SMS_PROVIDERS
Disables certain SmsProviders via define.
#define | APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING
Disables the recursive QuickSort algorithm of the QuickSortProvider.
#define | APOXI_DISABLE_SOFTKEYBAR
Disables the obsolete softkey bar.
#define | APOXI_DISABLE_TAB_CONTROL
Disables the tab control.
#define | APOXI_DISPLAY_16BPP
Must be defined if the display is organized as 16 bits per pixel.
#define | APOXI_DISPLAY_24BPP
Must be defined if the display is organized as 24 bits per pixel.
#define | APOXI_DISPLAY_32BPP
Must be defined if the display is organized as 24 bits per pixel.
#define | APOXI_DISPLAY_8BPP
#define | APOXI_DISPLAY_FORMAT_BIG_ENDIAN
Must be defined if the pixels of the display are organized in big endian.
#define | APOXI_DISPLAY_PLANES
Must be set if the display is organized in planes format or is monochrome.
#define | APOXI_EM_CONTROL_ENABLED
Engineering mode control
#define | APOXI_ENABLE_ADVANCED_TRANSLATION
Enables the advanced translation format.
#define | APOXI_ENABLE_ALPHA_BLENDING
Enables the alpha blending for drawing operations.
#define | APOXI_ENABLE_ANIMATED_TITLE
Enables support for animated titles inside a window.
#define | APOXI_ENABLE_ARC_DRAWING
Enables the drawing of Arcs.
#define | APOXI_ENABLE_C166_APOXIGUI_RAMCODE
Enables the execution of some gif decoding routines in internal RAM (for C166-based chipsets only)
#define | APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE
Enables the execution of display device code in internal RAM (for C166-based chip sets only)
#define | APOXI_ENABLE_C166_GIFDECODER_RAMCODE
Enables the execution of some gif decoding routines in internal RAM (for C166-based chipsets only)
#define | APOXI_ENABLE_C166_HUGEBITMAP_DRAW
Enables the draw of huge bitmaps (>64kbyes of data, for C166-based chip sets only)
#define | APOXI_ENABLE_C166_RECT_RAMCODE
Enables the execution of Rect class methods (Rect.cpp) in internal RAM (for C166-based chip sets only)
#define | APOXI_ENABLE_CBS_ACTIVE_TIMER_INTERFACE
Support of the active timer value of stack
#define | APOXI_ENABLE_CIRCLE_DRAWING
Enables the drawing of circles.
#define | APOXI_ENABLE_CONC_SMS_SCA_CHECK
Enables checking of the SCA in case of Concatenated SMS Enables checking of the SCA in case of Concatenated SMS, this means if the define is set also the SCA of a SMS will be used for checking if a TPDU belongs to a concatenated SMS.
#define | APOXI_ENABLE_DBG_OUT
Enables the output of debugging information.
#define | APOXI_ENABLE_DIAGONAL_LINE_DRAWING
Enables the drawing of diagonal lines.
#define | APOXI_ENABLE_ECC_CUSTOMIZATION
Support of the ECC code customization
#define | APOXI_ENABLE_GSM_BITMAP_DRAWING
Enables the drawing of GSM bitmaps.
#define | APOXI_ENABLE_JAPANESE_TRANSCODER
Enables the Japanese transcoder, which allows to convert text stored in the UCS-2 format to and from SJIS, JIS or EUC.
#define | APOXI_ENABLE_ME_PHONEBOOK_REQUEST
Support of the ATC ME phonebook requests
#define | APOXI_ENABLE_MOC_CALL_RESTRICTION
Enables MOC call restriction.
#define | APOXI_ENABLE_POLYGON_DRAWING
Enables the drawing of polygons.
#define | APOXI_ENABLE_POSITION_PREVIEW
Enables the preview of the menu position inside the title bar of a window.
#define | APOXI_ENABLE_R2L_TEST
Treats A - Z as right to left characters.
#define | APOXI_ENABLE_RUNTIME_CONFIGURATION
Runtime configuration (e.g. via AT commands)
#define | APOXI_ENABLE_SDL_SIGNAL_SIGNATURE_CHECK
SDL signal signature check
#define | APOXI_ENABLE_SMOOTH_SCROLLING
Enables a smooth scrolling for menus and lists.
#define | APOXI_ENABLE_STACK_CHECK
Enables checking the system stack inside APOXI application containers.
#define | APOXI_ENABLE_SVG_FONT_SERIALIZATION
Enables engine mode for doing font serialization.
#define | APOXI_ENABLE_SVG_SYSTEM_FONTS
Enables support for system fonts in SVG engine.
#define | APOXI_ENABLE_TIMING_MEASUREMENTS
Enables the usage of class DbgTimingMeasurement.
#define | APOXI_ENABLE_TRAP_INFO_SCREEN
Redirects trap output to main display
#define | APOXI_ENABLE_USIM_PHONEBOOK
Enables the support of the USIM phonebook
#define | APOXI_GDD_2_0_INTERFACE
If set, the APOXI display device will use the GDD 2.0 interface.
#define | APOXI_HEAP_CONTEXT_USAGE
shall not be set manually Adds a context vector per page which contains a context id of the object which is allocated, this is necessary for identification to which context an object belongs. Take into account that additional memory is used to held this context information.
#define | APOXI_HEAP_DISABLE_64K_ALIGNMENT
Disables the address alignment to 64 K addresses
#define | APOXI_HEAP_LENGTH_VECTOR
shall not be set manually
#define | APOXI_HEAP_MEM_ACCESS_CHECK
Enables checking wrong frees (double called) and memory overwrites Enables checking wrong frees (double called) and memory overwrites. Take into account that enabling this define will have impact on memory consumption and runtime. It is set automatically under Win32. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf
#define | APOXI_HEAP_MEM_ALLOC_TRACE
Enables trace output of each allocate and free call Enables trace output of each allocate and free call, shall be used only under Win32 because very much trace output is done.
#define | APOXI_HEAP_MEM_ASSERT_ON_FAILED_ALLOC
Enables throwing an assertion when no memory can be allocated Enables throwing an assertion when no memory can be allocated.
#define | APOXI_HEAP_MEM_CONTEXT_TRACE
Enables collecting information about allocation done by Apps/Threads Enables collecting information about allocation done by Apps/Threads. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf
#define | APOXI_HEAP_MEM_DETECT_CONFIG
Enables the detection of a suitable memory configuration For detailed description please refer to the document: UserGuide_MemoryManagement.pdf
#define | APOXI_HEAP_MEM_POOL_TRACE
Enables collecting information of memory pages Enables collecting information of memory pages and allow tracing out a visual view of all memory pages on the trace interface. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf
#define | APOXI_HEAP_NAME_USAGE
shall not be set manually Adds a character array per page which will be used for certain debug outputs. Take into account that additional memory is used to held this context information.
#define | APOXI_HEAP_STATS_USAGE
shall not be set manually Adds a statistics structure per page which will be used for certain debug outputs. Take into account that additional memory is used to held this context information.
#define | APOXI_LED_NEW_INTERFACE
Enables new multi-color LED interface
#define | APOXI_MEMORY_WIN32_REDIRECT_HUGEALLOCATION
Enables Redirection of HugeAllocations to Allocations under Win32 Redirects HugeAllocations to Allocations under Win32.
#define | APOXI_SIMTK_TRANSACTIONID_SUPPORT
Enables support of Sim toolkit transaction Ids of GFS20 and GFS21 Enables support of Sim toolkit transaction Ids of GFS20 and GFS21, for older stacks this shall not be set.
#define | APOXI_SMS_NEW_PROVIDERS
New SMS Providers
#define | APOXI_SMS_NOWAIT_ON_RELOAD
Prevent from active wait during reload of TPDUs
#define | APOXI_SUPPORT_CSMSREFNOREQ
Enables support of retrieving the concatenated SMS reference number Enables support of retrieving the concatenated SMS reference number of GFS 20 and GFS 21, for older stacks this shall not be set.
#define | APOXI_SUPPORT_MOSMS_TIMESTAMP
Enables support of retrieving time stamps of MOSMS Enables support of retrieving time stamps of MOSMS of GFS 20 and GFS 21, for older stacks this shall not be set.
#define | APOXI_SUPPORT_NETWORK_ECC_LIST
Enables support of ECC network list Enables support of retrieving ECCs over the air GFS 20 and GFS 21, for older stacks this shall not be set.
#define | APOXI_SUPPORT_NORMAL_SMS_LOADING
Disables the fast loading feature of the DR process and APOXI Disables the fast loading feature of the DR process and APOXI. This shall be only set for testing purposes.
#define | APOXI_SUPPORT_SMS_DELETION_CMD
Enables support of the bulk deletion signal of DR-process Enables support of the bulk deletion signal of DR-process of GFS20 and GFS 21, for older stacks this shall not be set.
#define | APOXI_SUPPORT_SMS_DELETION_CMD_GORS
Support +CMGD command to delete several SMS at once
#define | APOXI_SUPPORT_SMS_NEWMSG_PAYLOAD
Enables support of the TPDU payload of incoming SMS signal of DR-process Enables support of the TPDU payload of incoming SMS signal of DR-process of GFS20 and GFS 21, for older stacks this shall not be set. This allows processing the new arrived TPDU without reloading the TPDU from SIM or Flash.

Variables

def APOXI_DISPLAY_8BPP brief<
i > Must be defined if the
display is organized as bits
per pixel</i > Must be defined
if the display is organized
as bits per pixel If more
than one display is supported
and both displays have a different
bits per pixel 		setting

Detailed Description

Compiler defines which are used to tune APOXI framework to project needs. The switch defines are used to enable/disable the various "little" APOXI functionalities.

Optional defines are a kind of "little" features, often used for changing the behavior or adding - respectively enabling - simple options to a functionality (e.g. animated window titles).

Additionally it is possible to use the optional defines to disable an existing functionality or interface. In this case the name of these defines differ in their infix. In general it is a better approach to use a positive formulation, like to enable functionality, than to disable something. Please take care about that, every time you create a new define!

Naming convention for new created optional defines:

APOXI_ENABLE_<functionality>, where

  • <functionality> describes the functionality, which is enabled/activated.

APOXI_DISABLE_<functionality>, where

  • <functionality> describes the existing functionality, which is disabled/removed.

Define Documentation

#define APOXI_CBS_LIMITATION_MSG

Enables support of the MN_SMS_CB_MESSAGE_ID_LIMIT_IND signal Enables the support of the MN_SMS_CB_MESSAGE_ID_LIMIT_IND signal which indicates the maximum ranges of possible message IDs. This value is then posted via the message CbsLimitMsg.

#define APOXI_DEBUG_IMAGE_DECODING

Decreases the performance of image decoding to relieve debugging.

Decreases the performance of image decoding to relieve debugging. Setting this define is useful on the host environment to simulate a very slow hardware.

#define APOXI_DISABLE_ENLARGED_GRID_SELECTION

Disables the possibility of having an enlarged grid selection.

Disables the possibility of having an enlarged grid selection. Per default when having an item grid the selected items have the same size as the non-selected items. It is possible to define a larger selection height by the item renderer properties. In the case of an item grid this means that the selected item overlaps other items. If this is not required, it is recommended to define APOXI_DISABLE_ENLARGED_GRID_SELECTION to reduce the code size.

#define APOXI_DISABLE_FILTERED_SMS_PROVIDERS

Disables certain SmsProviders via define.

Introduced this new define in order to turn off code and according RAM consumption for the filtered SmsProviders (read/unread/sent/unsent) and leave the SmsProvider still available. The IDs for the disabled providers are still available (ProvIds).

#define APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING

Disables the recursive QuickSort algorithm of the QuickSortProvider.

Activates the non-recursive QuickSort algorithm of the QuickSortProvider. Should be defined if there is a high risk of callstack overflow when sorting a large number of rows.

#define APOXI_DISABLE_SOFTKEYBAR

Disables the obsolete softkey bar.

Disables the obsolete softkey bar (see Window::GetSoftkeyBar). Per default the softkey bar is already defined as obsolete with APOXI-1.8.0. Setting this define is only required if the define APOXI_COMPAT_1_8_0 is required but no softkey bar support is wanted.

#define APOXI_DISABLE_TAB_CONTROL

Disables the tab control.

Disables the tab control. If is recommended to disable the tab control if the MMI does not use it, as it reduces the code size.

#define APOXI_DISPLAY_16BPP

Must be defined if the display is organized as 16 bits per pixel.

Must be defined if the display is organized as 16 bits per pixel. If more than one display is supported and both displays have a different bits per pixel setting, a custom display device must be implemented.

#define APOXI_DISPLAY_24BPP

Must be defined if the display is organized as 24 bits per pixel.

Must be defined if the display is organized as 24 bits per pixel. If more than one display is supported and both displays have a different bits per pixel setting, a custom display device must be implemented.

#define APOXI_DISPLAY_32BPP

Must be defined if the display is organized as 24 bits per pixel.

Must be defined if the display is organized as 32 bits per pixel. If more than one display is supported and both displays have a different bits per pixel setting, a custom display device must be implemented.

#define APOXI_DISPLAY_8BPP

#define APOXI_DISPLAY_FORMAT_BIG_ENDIAN

Must be defined if the pixels of the display are organized in big endian.

Must be defined if the pixels of the display are organized in big endian. If this define is not set, it is automatically assumed that the pixels are organized in little endian. Note that it is required to regenerate all APOXI bitmaps with the resource compiler if the endian format is changed.

#define APOXI_DISPLAY_PLANES

Must be set if the display is organized in planes format or is monochrome.

Must be set if the display is organized in planes format or is monochrome. If more than one display is used and both displays have a different color organization, a custom display device must be implemented.

#define APOXI_EM_CONTROL_ENABLED

Engineering mode control

This features enables the functionality of controlling the engineering-mode behavior in several ways. F.e. it is possible to lock to the current cell or a 3G to 2G handover can be triggered. The control-setting has influence to the data received with a EngineeringModeReport.

#define APOXI_ENABLE_ADVANCED_TRANSLATION

Enables the advanced translation format.

Enables the advanced translation format, which increases the performance for the LanguageManager::ReTranslate operations. Also the ROM demand for the language table itself will be decreased. It is required to regenerate the language table with the APOXI Language Tool to benefit from the advanced format. Currently the advanced format does not work on EGold platforms.

#define APOXI_ENABLE_ALPHA_BLENDING

Enables the alpha blending for drawing operations.

Enables the alpha blending for drawing operations. It is also required to enable alpha blending if an overlay of the display channel and video channel is required.

#define APOXI_ENABLE_ANIMATED_TITLE

Enables support for animated titles inside a window.

Enables support for animated titles inside a window. As soon as the text of the title does not fit into the available width of the window, the scrolling is started.

Enabled backward compatibility:

  • obsoleted define: APOXI_ANIM_TITLE_SUPPORT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_ARC_DRAWING

Enables the drawing of Arcs.

Enables the drawing of Arcs when using the methods DeviceContext::DrawArc and DeviceContext::FillArc.

Corresponding features:

  • MULTIMEDIA

Enabled backward compatibility:

  • obsoleted define: APOXI_DC_ARC_SUPPORT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_C166_APOXIGUI_RAMCODE

Enables the execution of some gif decoding routines in internal RAM (for C166-based chipsets only)

The following routines: Color::Color Color::SetValue Color::GetValue Color::SetRgb Color::GetRgb Image::Draw are executed in internal RAM (APOXI_RAMCODE class) with 0ws access.

See APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE for details on execution of code in RAM.

#define APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE

Enables the execution of display device code in internal RAM (for C166-based chip sets only)

If this define is set, any piece of code between the following pragma directives if defined(APOXI_RTOS_OSE166) && defined(APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE) pragma class PR=APOXI_RAMCODE endif { code } if defined(APOXI_RTOS_OSE166) && defined(APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE) pragma default_attributes endif

is executed in the internal RAM of C166 MC. If the APOXI_RAMCODE data class is not defined in the linking option file (*.ilo), the pragma takes no effect.

#define APOXI_ENABLE_C166_GIFDECODER_RAMCODE

Enables the execution of some gif decoding routines in internal RAM (for C166-based chipsets only)

The following routines: GifDecoder::DecompressLine GifDecoder::DecompressInput GifDecoder::BufferedInput are executed in internal RAM (APOXI_RAMCODE class) with 0ws access. Enabling also APOXI_ENABLE_C166_APOXIGUI_RAMCODE, time to decode a gif is decreased for 25-30%

See APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE for details on execution of code in RAM.

#define APOXI_ENABLE_C166_HUGEBITMAP_DRAW

Enables the draw of huge bitmaps (>64kbyes of data, for C166-based chip sets only)

This define has to be used when GDI_HUGE type is defined as _shuge but the APOXI Gui has to support drawing of images larger than 64kbytes. Typically GDI_HUGE=_shuge when physical display buffer is less than 64kbytes (e.g. 128x160 16bit display). Nevertheless images can be drawn also to a custom buffer larger than 64kbytes (e.g. when zooming option or full image display is implemented in MMI). In this case drawing fails if APOXI_ENABLE_C166_HUGEBITMAP_DRAW is not defined.

#define APOXI_ENABLE_C166_RECT_RAMCODE

Enables the execution of Rect class methods (Rect.cpp) in internal RAM (for C166-based chip sets only)

If this define is set, any piece of code between the following pragma directives if defined(APOXI_RTOS_OSE166) && defined(APOXI_ENABLE_C166_RECT_RAMCODE) pragma class PR=APOXI_RAMCODE endif { code } if defined(APOXI_RTOS_OSE166) && defined(APOXI_ENABLE_C166_RECT_RAMCODE) pragma default_attributes endif is executed in the internal RAM of C166 MC. If the APOXI_RAMCODE data class is not defined in the linking option file (*.ilo), the pragma takes no effect.

Enabled backward compatibility:

  • obsoleted define: RECT_RAMCODE
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_CBS_ACTIVE_TIMER_INTERFACE

Support of the active timer value of stack

This define enables setting the active timer value parameter which is supported by newer stacks.

#define APOXI_ENABLE_CIRCLE_DRAWING

Enables the drawing of circles.

Enables the drawing of circles when using the methods DeviceContext::DrawCircle and DeviceContext::FillCircle.

Corresponding features:

  • MULTIMEDIA

Enabled backward compatibility:

  • obsoleted define: APOXI_DC_CIRCLE_SUPPORT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_CONC_SMS_SCA_CHECK

Enables checking of the SCA in case of Concatenated SMS Enables checking of the SCA in case of Concatenated SMS, this means if the define is set also the SCA of a SMS will be used for checking if a TPDU belongs to a concatenated SMS.

#define APOXI_ENABLE_DBG_OUT

Enables the output of debugging information.

If this define is set, all debugging info implementation using macro DBG_OUT is enabled.

Enabled backward compatibility:

  • obsoleted define: APOXI_DBG_OUT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_DIAGONAL_LINE_DRAWING

Enables the drawing of diagonal lines.

Enables the drawing of diagonal lines when using the method DeviceContext::DrawLine.

Corresponding features:

  • MULTIMEDIA

Enabled backward compatibility:

  • obsoleted define: APOXI_DC_DIAG_LINE_SUPPORT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_ECC_CUSTOMIZATION

Support of the ECC code customization

This define enables the interface for customization of the ECC codes which is supported by newer stacks.

#define APOXI_ENABLE_GSM_BITMAP_DRAWING

Enables the drawing of GSM bitmaps.

Enables the drawing of GSM bitmaps when using the method DeviceContext::DrawGsmBitmap.

Corresponding features:

  • MULTIMEDIA

Enabled backward compatibility:

  • obsoleted define: APOXI_DC_GSM_BITMAP_SUPPORT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_JAPANESE_TRANSCODER

Enables the Japanese transcoder, which allows to convert text stored in the UCS-2 format to and from SJIS, JIS or EUC.

Enables the Japanese transcoder, which allows to convert text stored in the UCS-2 format to and from SJIS, JIS or EUC. The Japanese transcoder is located inside Auxiliary and is represented by the class JapaneseTranscoder.

#define APOXI_ENABLE_ME_PHONEBOOK_REQUEST

Support of the ATC ME phonebook requests

This define enables the interface which allow processing ATC requests for ME phonebook entries reading implemented in newer stacks.

#define APOXI_ENABLE_MOC_CALL_RESTRICTION

Enables MOC call restriction.

Sometimes it is necessary to restrict the MOC-setup by other clients then APOXI. If a customer-MMI wants to restrict MOC's because of any reason this can be done by calling just a function in APOXI.

#define APOXI_ENABLE_POLYGON_DRAWING

Enables the drawing of polygons.

Enables the drawing of polygons when using the methods DeviceContext::DrawPolygon and DeviceContext::FillPolygon.

Corresponding features:

  • MULTIMEDIA

Define dependencies:

  • APOXI_DC_POLYGON_MAX_EDGES
  • APOXI_DC_POLYGON_MAX_EDGES_ON_STACK

Enabled backward compatibility:

  • obsoleted define: APOXI_DC_POLYGON_SUPPORT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_POSITION_PREVIEW

Enables the preview of the menu position inside the title bar of a window.

Enables the preview of the menu position inside the title bar of a window. The currently selected icon is shown left from the menu title, the currently shortcut hint is shown right to the menu title. It is possible to customize the the look of the position preview by adjusting the class OptionalConfig (located in the directory 'Config' of the project). For further details have a look at the documentation for the class OptionalConfigBase, where the setting IDs 'ShowParentPosition' and 'PositionSeparator' are explained.

Define dependencies:

  • APOXI_ENABLE_ANIMATED_TITLE

#define APOXI_ENABLE_R2L_TEST

Treats A - Z as right to left characters.

Treats A - Z as right to left characters. Useful for testing the bidirectional text engine without the need to generate e. g. Arabic glyphs.

Enabled backward compatibility:

  • obsoleted define: APOXI_ARABIC_TEST
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_RUNTIME_CONFIGURATION

Runtime configuration (e.g. via AT commands)

See also:
RuntimeConfigurator

#define APOXI_ENABLE_SDL_SIGNAL_SIGNATURE_CHECK

SDL signal signature check

This define asserts that signal-type and signal-size of SDL signal sent to APOXI are equal. It is just for checking if a SDL signal signature is valid or not.

Enabled backward compatibility:

  • obsoleted define: APOXI_SIGNAL_COMPARE
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_SMOOTH_SCROLLING

Enables a smooth scrolling for menus and lists.

Enables a smooth scrolling for menus and lists. It is only recommended to turn on this feature on a fast hardware, as it requires a lot of performance.

Enabled backward compatibility:

  • obsoleted define: APOXI_SMOOTH_SCROLLING_SUPPORT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_STACK_CHECK

Enables checking the system stack inside APOXI application containers.

If this define is set, APOXI invokes to checks the system stack (and in OSE166 also the user stack). Each application has a configured stack size and using a special fill pattern on top of each stack, APOXI is able to detect critical stack overflows or memory overwrites.

#define APOXI_ENABLE_SVG_FONT_SERIALIZATION

Enables engine mode for doing font serialization.

This configuration define is only required if a serialized font should be produced using SVG engine. This has to be done only once.

Enabled backward compatibility:

  • obsoleted define: APOXI_SVG_FONT_SERIALIZATION
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_SVG_SYSTEM_FONTS

Enables support for system fonts in SVG engine.

Enables the usage of the internal APOXI font renderer in the svg engine. Only useful in combination with feature SVG

Enabled backward compatibility:

  • obsoleted define: APOXI_SVG_SYSTEM_FONT
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_ENABLE_TIMING_MEASUREMENTS

Enables the usage of class DbgTimingMeasurement.

If this define is set, class DbgTimingMeasurement will be enabled to measure time periods and sending the result via DBG_OUT.

See also:
DbgTimingMeasurement

#define APOXI_ENABLE_TRAP_INFO_SCREEN

Redirects trap output to main display

If APOXI runs into an assertion the trap data is redirected to the main display.

Enabled backward compatibility:

  • obsoleted define: APOXI_CRASH_TO_SCREEN_OUTPUT
  • obsoleted define cleared out: 3.0

#define APOXI_ENABLE_USIM_PHONEBOOK

Enables the support of the USIM phonebook

Enables the support of the USIM phonebook and its interface inside APOXI. A UMTS stack with present PB process is required for compiling and operating the USIM phonebook.

#define APOXI_GDD_2_0_INTERFACE

If set, the APOXI display device will use the GDD 2.0 interface.

If set, the APOXI display device will use the GDD 2.0 interface instead of the outdated 1.0 interface.

#define APOXI_HEAP_CONTEXT_USAGE

shall not be set manually Adds a context vector per page which contains a context id of the object which is allocated, this is necessary for identification to which context an object belongs. Take into account that additional memory is used to held this context information.

#define APOXI_HEAP_DISABLE_64K_ALIGNMENT

Disables the address alignment to 64 K addresses

This define shall be used for 32 bit processors like on ARM based platforms.

It will disable the following mechanism: On C166 platforms it is necessary when using HugeAllocation methods, so that blocks which are smaller then 64 K shall be also cast-able to SHUGE addresses which can address a maximum of 64 K, so that the pointer arithmetics are also working fine. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf

#define APOXI_HEAP_LENGTH_VECTOR

shall not be set manually

Adds a length vector per page which contains the real length of the object which is allocated, this is necessary for overwrite checks and additional statistics. Take into account that additional memory is used to held length information.

#define APOXI_HEAP_MEM_ACCESS_CHECK

Enables checking wrong frees (double called) and memory overwrites Enables checking wrong frees (double called) and memory overwrites. Take into account that enabling this define will have impact on memory consumption and runtime. It is set automatically under Win32. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf

#define APOXI_HEAP_MEM_ALLOC_TRACE

Enables trace output of each allocate and free call Enables trace output of each allocate and free call, shall be used only under Win32 because very much trace output is done.

#define APOXI_HEAP_MEM_ASSERT_ON_FAILED_ALLOC

Enables throwing an assertion when no memory can be allocated Enables throwing an assertion when no memory can be allocated.

#define APOXI_HEAP_MEM_CONTEXT_TRACE

Enables collecting information about allocation done by Apps/Threads Enables collecting information about allocation done by Apps/Threads. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf

#define APOXI_HEAP_MEM_DETECT_CONFIG

Enables the detection of a suitable memory configuration For detailed description please refer to the document: UserGuide_MemoryManagement.pdf

#define APOXI_HEAP_MEM_POOL_TRACE

Enables collecting information of memory pages Enables collecting information of memory pages and allow tracing out a visual view of all memory pages on the trace interface. For detailed description please refer to the document: UserGuide_MemoryManagement.pdf

#define APOXI_HEAP_NAME_USAGE

shall not be set manually Adds a character array per page which will be used for certain debug outputs. Take into account that additional memory is used to held this context information.

#define APOXI_HEAP_STATS_USAGE

shall not be set manually Adds a statistics structure per page which will be used for certain debug outputs. Take into account that additional memory is used to held this context information.

#define APOXI_LED_NEW_INTERFACE

Enables new multi-color LED interface

LED driver provides two type of interfaces. This define has to be set to align the APOXI LED device interface with the driver interface. The define on driver side is named LED_MULTICOLOR_NEW_INTERFACE. If this define is not set, the old interface is enabled.

Define dependencies:

  • LED_MULTICOLOR_NEW_INTERFACE

#define APOXI_MEMORY_WIN32_REDIRECT_HUGEALLOCATION

Enables Redirection of HugeAllocations to Allocations under Win32 Redirects HugeAllocations to Allocations under Win32.

#define APOXI_SIMTK_TRANSACTIONID_SUPPORT

Enables support of Sim toolkit transaction Ids of GFS20 and GFS21 Enables support of Sim toolkit transaction Ids of GFS20 and GFS21, for older stacks this shall not be set.

#define APOXI_SMS_NEW_PROVIDERS

New SMS Providers

The new SMS providers are offering a fast sorting functionality that lists the newest SMS first place. By setting this define the old providers (Read/Unread/Sent/Unsent) get obsolete, as a result it isn't possible to use the old and new providers simultaneously. The following providers are available:

  • Inbox Provider: holds read/unread SMS
  • Outbox Provider: holds sent SMS
  • Archive Provider: holds unsent SMS
  • Status Report Provider: holds read/unread status reports
  • Unread Provider: holds unread SMS (incl. status reports)
  • Count Provider: delivers detailed count information (capacity/occupied/free) for both all items held by the providers above and in relation to the storage media (FLASH, SIM).

#define APOXI_SMS_NOWAIT_ON_RELOAD

Prevent from active wait during reload of TPDUs

Only storage media flash is affected. This mechanism can be switched off by setting this define. The interrupt is basically used to avoid blocking other processes which may result in crashing the system.

#define APOXI_SUPPORT_CSMSREFNOREQ

Enables support of retrieving the concatenated SMS reference number Enables support of retrieving the concatenated SMS reference number of GFS 20 and GFS 21, for older stacks this shall not be set.

#define APOXI_SUPPORT_MOSMS_TIMESTAMP

Enables support of retrieving time stamps of MOSMS Enables support of retrieving time stamps of MOSMS of GFS 20 and GFS 21, for older stacks this shall not be set.

#define APOXI_SUPPORT_NETWORK_ECC_LIST

Enables support of ECC network list Enables support of retrieving ECCs over the air GFS 20 and GFS 21, for older stacks this shall not be set.

#define APOXI_SUPPORT_NORMAL_SMS_LOADING

Disables the fast loading feature of the DR process and APOXI Disables the fast loading feature of the DR process and APOXI. This shall be only set for testing purposes.

#define APOXI_SUPPORT_SMS_DELETION_CMD

Enables support of the bulk deletion signal of DR-process Enables support of the bulk deletion signal of DR-process of GFS20 and GFS 21, for older stacks this shall not be set.

#define APOXI_SUPPORT_SMS_DELETION_CMD_GORS

Support +CMGD command to delete several SMS at once

This define enables the support of the AT command +CMGD. In TS 27.005, the command is specified with an optional <delflag> parameter that would control deletion of several SMS with one command. To support this also the define APOXI_SUPPORT_SMS_DELETION_CMD must be set.

#define APOXI_SUPPORT_SMS_NEWMSG_PAYLOAD

Enables support of the TPDU payload of incoming SMS signal of DR-process Enables support of the TPDU payload of incoming SMS signal of DR-process of GFS20 and GFS 21, for older stacks this shall not be set. This allows processing the new arrived TPDU without reloading the TPDU from SIM or Flash.

Variable Documentation

def APOXI_DISPLAY_8BPP brief<i> Must be defined if the display is organized as bits per pixel</i> Must be defined if the display is organized as bits per pixel If more than one display is supported and both displays have a different bits per pixel setting

Generated on Wed Jan 25 02:27:23 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Compatibility Defines

Compatibility Defines
[Optional Defines]

Collaboration diagram for Compatibility Defines:

Defines to establish backward compatibility in source code More...

Defines

#define | APOXI_COMPAT_1_11_0
Compatibility define for APOXI_1.11.0
#define | APOXI_COMPAT_1_12_0
Compatibility define for APOXI_1.12.0
#define | APOXI_COMPAT_1_13_0
Compatibility define for APOXI_1.13.0
#define | APOXI_COMPAT_1_7_0
Compatibility define for APOXI_1.7.0
#define | APOXI_COMPAT_1_8_0
Compatibility define for APOXI_1.8.0
#define | APOXI_COMPAT_1_9_0
Compatibility define for APOXI_1.9.0
#define | APOXI_COMPAT_2_0_0
Compatibility define for APOXI_2.0.0
#define | APOXI_COMPAT_2_1_0
Compatibility define for APOXI_2.1.0
#define | APOXI_COMPAT_2_2_0
Compatibility define for APOXI_2.2.0
#define | APOXI_COMPAT_2_3_0
Compatibility define for APOXI_2.3.0
#define | APOXI_COMPAT_2_4_0
Compatibility define for APOXI_2.4.0
#define | APOXI_COMPAT_2_6_0
Compatibility define for APOXI_2.6.0
#define | APOXI_COMPAT_2_7_0
Compatibility define for APOXI_2.7.0
#define | APOXI_COMPAT_2_8_0
Compatibility define for APOXI_2.8.0
#define | APOXI_COMPAT_2_9_0
Compatibility define for APOXI_2.9.0

Detailed Description

Defines to establish backward compatibility in source code

Per default classes or methods in APOXI which have been marked as obsolete are disabled to reduce the code size. If applications still use obsolete classes, the COMPAT defines allow to stay backward compatible by turning on the obsolete methods.

Additionally when using one compatibility define it is recommended to use all succeeding compatibility defines, because of the dependencies that may arise with the reanimated code.

Example: If the version APOXI_1.13.0 is used and the applications require some methods from APOXI_1.12.0 which have been marked as obsolete in APOXI_1.13.0 the define APOXI_COMPAT_1_12_0 must be set. If a higher version than APOXI_1.13.0 is used (e. g. APOXI_2.2.0) also the missing COMPAT-defines between must be enabled. This means for APOXI_2.2.0 that the defines APOXI_COMPAT_1_13_0, APOXI_COMPAT_2_0_0 and APOXI_COMPAT_2_1_0 must be enabled additionally to APOXI_COMPAT_1_12_0. This is because the obsolete methods from APOXI_1.12.0 might require the obsolete methods from APOXI_1.13.0, APOXI_2.0.0 or APOXI_2.1.0.

Note: Enabling compatibility defines should only be a temporary situation in a project. It must be the goal to every application to run without the usage of obsoleted code.

Define Documentation

#define APOXI_COMPAT_1_11_0

Compatibility define for APOXI_1.11.0

This define enables backward compatibility to the version APOXI_1.11.0. All the functionality of APOXI_1.11.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_1_12_0
  • APOXI_COMPAT_1_13_0
  • APOXI_COMPAT_2_0_0
  • APOXI_COMPAT_2_1_0
  • APOXI_COMPAT_2_2_0
  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_1_12_0

Compatibility define for APOXI_1.12.0

This define enables backward compatibility to the version APOXI_1.12.0. All the functionality of APOXI_1.12.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_1_13_0
  • APOXI_COMPAT_2_0_0
  • APOXI_COMPAT_2_1_0
  • APOXI_COMPAT_2_2_0
  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_1_13_0

Compatibility define for APOXI_1.13.0

This define enables backward compatibility to the version APOXI_1.13.0. All the functionality of APOXI_1.13.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_0_0
  • APOXI_COMPAT_2_1_0
  • APOXI_COMPAT_2_2_0
  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_1_7_0

Compatibility define for APOXI_1.7.0

This define enables backward compatibility to the version APOXI_1.7.0. All the functionality of APOXI_1.7.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_1_8_0
  • APOXI_COMPAT_1_9_0
  • APOXI_COMPAT_1_11_0
  • APOXI_COMPAT_1_12_0
  • APOXI_COMPAT_1_13_0
  • APOXI_COMPAT_2_0_0
  • APOXI_COMPAT_2_1_0
  • APOXI_COMPAT_2_2_0
  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_1_8_0

Compatibility define for APOXI_1.8.0

This define enables backward compatibility to the version APOXI_1.8.0. All the functionality of APOXI_1.8.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_1_9_0
  • APOXI_COMPAT_1_11_0
  • APOXI_COMPAT_1_12_0
  • APOXI_COMPAT_1_13_0
  • APOXI_COMPAT_2_0_0
  • APOXI_COMPAT_2_1_0
  • APOXI_COMPAT_2_2_0
  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_1_9_0

Compatibility define for APOXI_1.9.0

This define enables backward compatibility to the version APOXI_1.9.0. All the functionality of APOXI_1.9.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_1_11_0
  • APOXI_COMPAT_1_12_0
  • APOXI_COMPAT_1_13_0
  • APOXI_COMPAT_2_0_0
  • APOXI_COMPAT_2_1_0
  • APOXI_COMPAT_2_2_0
  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_0_0

Compatibility define for APOXI_2.0.0

This define enables backward compatibility to the version APOXI_2.0.0. All the functionality of APOXI_2.0.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_1_0
  • APOXI_COMPAT_2_2_0
  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_1_0

Compatibility define for APOXI_2.1.0

This define enables backward compatibility to the version APOXI_2.1.0. All the functionality of APOXI_2.1.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_2_0
  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_2_0

Compatibility define for APOXI_2.2.0

This define enables backward compatibility to the version APOXI_2.2.0. All the functionality of APOXI_2.2.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_3_0
  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_3_0

Compatibility define for APOXI_2.3.0

This define enables backward compatibility to the version APOXI_2.3.0. All the functionality of APOXI_2.3.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_4_0
  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_4_0

Compatibility define for APOXI_2.4.0

This define enables backward compatibility to the version APOXI_2.4.0. All the functionality of APOXI_2.4.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_6_0
  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_6_0

Compatibility define for APOXI_2.6.0

This define enables backward compatibility to the version APOXI_2.6.0. All the functionality of APOXI_2.6.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_7_0
  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_7_0

Compatibility define for APOXI_2.7.0

This define enables backward compatibility to the version APOXI_2.6.0. All the functionality of APOXI_2.6.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_8_0
  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_8_0

Compatibility define for APOXI_2.8.0

This define enables backward compatibility to the version APOXI_2.8.0. All the functionality of APOXI_2.8.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

  • APOXI_COMPAT_2_9_0

#define APOXI_COMPAT_2_9_0

Compatibility define for APOXI_2.9.0

This define enables backward compatibility to the version APOXI_2.9.0. All the functionality of APOXI_2.9.0 which is supposed to be obsolete in the subsequent versions are reactivated by using this COMPAT define.

Define dependencies:

Generated on Wed Jan 25 02:27:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Configuration Defines

Configuration Defines
[Optional Defines]

Collaboration diagram for Configuration Defines:

The configuration defines are used to change default settings. More...

Defines

#define | APOXI_ALARMMANAGER_MAX_ENTRIES
Maximum number of different ExecutionContext's (Applications) which accesses AlarmManger
#define | APOXI_ARAGON_MAX_BUFFER_SIZE
Describes the buffer size for the communication with the ARAGON Tool.
#define | APOXI_CACHED_POLYGON_EDGES_MAX
Defines the maximum numbers of edges a polygon may have on the stack.
#define | APOXI_CBS_DEFAULT_ACTIVE_TIMER
Default value of the active timer value for the CBS subsystem
#define | APOXI_CBS_DEFAULT_SLEEP_TIMER
Default value of the sleep timer value for the CBS subsystem
#define | APOXI_CONFIG_DBG_OUT_RANGE_ARRAY
Defines the amount of possible DBG_OUT Id Ranges on target.
#define | APOXI_HEAP_MEM_CONTEXT_TRACE_MAX_CTX
Number of maximum contexts which can be traced if APOXI_HEAP_MEM_CONTEXT_TRACE is set
#define | APOXI_MAX_DISPLAY_COUNT
Defines the maximum number of displays APOXI can handle at the same time.
#define | APOXI_MAX_LANGUAGE_COUNT
Defines the maximum number of languages APOXI can handle at the same time.
#define | APOXI_MAX_SOFTKEY_COUNT
Defines the maximum number of softkeys.
#define | APOXI_MSG_QUEUE_KEY_ENTRY_LIMIT
Limitation for queued key entries
#define | APOXI_MSG_QUEUE_YIELD_COUNTER
Counter for Yield calls in MsgQueue
#define | APOXI_MSG_QUEUE_YIELD_PERIOD
Time period for Yield calls in MsgQueue
#define | APOXI_PHONENUMBER_MATCH_DEFAULT_DEPTH
Default number of digits which shall be used for matching method
#define | APOXI_POLYGON_EDGES_MAX
Defines the maximum numbers of edges a polygon may have.
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND
Defines timer impreciseness to optimize power consumption.
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE
Defines timer impreciseness to optimize power consumption.
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND
Defines timer impreciseness to optimize power consumption.
#define | APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT
Timeout for closing applications during shut-down.
#define | APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL
Interval for shutdown device for checking applications.
#define | APOXI_SMSSOCKET_MAX_CACHED_TPDUS
Defines the maximum number of Tpdus which shall be cached by a SmsSocket Defines the maximum number of Tpdus which shall be cached by a SmsSocket for an application, which has been registered. The default value is set to 12.
#define | APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS
Defines the maximum number of applications which can register for a SmsSocket Defines the maximum number of applications which can register for a SmsSocket which then shall be notified in case a PushSms arrives. The default value is set to 2.
#define | APOXI_THREAD_PRIORITY_NORMAL
Default priority level for APOXI tasks

Detailed Description

The configuration defines are used to change default settings.

Configuration defines can transport values down to the source code to configure corresponding values (e.g. message queue size). All these defines used for configuration issues must have a default value, which is set in the source code in case the define is not set from outside.

Naming convention for new created configuration defines:

APOXI_CONFIG_<functionality>, where

  • <parameter> describes the parameter, which is customized.

Define Documentation

#define APOXI_ALARMMANAGER_MAX_ENTRIES

Maximum number of different ExecutionContext's (Applications) which accesses AlarmManger

AlarmManager has to store data for each registered ExecutionContext. The amount of possible registrations is limited by this define. Default value is 10.

#define APOXI_ARAGON_MAX_BUFFER_SIZE

Describes the buffer size for the communication with the ARAGON Tool.

Describes the buffer size for the communication with the ARAGON Tool. Per default a value of 200000 is used.

#define APOXI_CACHED_POLYGON_EDGES_MAX

Defines the maximum numbers of edges a polygon may have on the stack.

Defines the maximum numbers of edges a polygon may have on the stack. If nothing is set, a default value of 10 is used.

Define dependencies:

  • APOXI_ENABLE_POLYGON_DRAWING

Enabled backward compatibility:

  • obsoleted define: APOXI_DC_POLYGON_MAX_EDGES_ON_STACK
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_CBS_DEFAULT_ACTIVE_TIMER

Default value of the active timer value for the CBS subsystem

For certain projects this timer value can be changed by default, unit are seconds. Default values are for all OSes is 0.

#define APOXI_CBS_DEFAULT_SLEEP_TIMER

Default value of the sleep timer value for the CBS subsystem

For certain projects this timer value can be changed by default, unit are seconds. Default values are for all OSes is 0.

#define APOXI_CONFIG_DBG_OUT_RANGE_ARRAY

Defines the amount of possible DBG_OUT Id Ranges on target.

On host simulation DBG_OUT messages are filtered using file DbgOutRange.txt in APOXI_TEMP folder. Multiple ranges can be defined. On target there is the possibility to filter DBG_OUT messages during runtime using AT command
at+xapoxi="dbgout range_idx id_from id_to"
The possible values for parameter range_idx is 0..APOXI_CONFIG_DBG_OUT_RANGE_ARRAY-1, default value for APOXI_CONFIG_DBG_OUT_RANGE_ARRAY is 5

See also:
RuntimeConfigurator

Define dependencies:
  • APOXI_ENABLE_RUNTIME_CONFIGURATION

#define APOXI_HEAP_MEM_CONTEXT_TRACE_MAX_CTX

Number of maximum contexts which can be traced if APOXI_HEAP_MEM_CONTEXT_TRACE is set

This define allows changing the default number of apps/threads which can be traced if the define APOXI_HEAP_MEM_CONTEXT_TRACE is set, Default value is 50 .

#define APOXI_MAX_DISPLAY_COUNT

Defines the maximum number of displays APOXI can handle at the same time.

Defines the maximum number of displays APOXI can handle at the same time. Per default the maximum number is set to 2.

#define APOXI_MAX_LANGUAGE_COUNT

Defines the maximum number of languages APOXI can handle at the same time.

Defines the maximum number of languages APOXI can handle at the same time. Per default the maximum number is set to 16.

#define APOXI_MAX_SOFTKEY_COUNT

Defines the maximum number of softkeys.

Defines the maximum number of softkeys. Per default the maximum number is set to 2.

#define APOXI_MSG_QUEUE_KEY_ENTRY_LIMIT

Limitation for queued key entries

The define is used to configure the limitation for key entries in the focus message queue. If the limit is reached in the message queue, all additional events coming from the keyboard driver are no longer queued (discarded). If the define is not set, then there is no limitation (default behavior).

Applicable range for APOXI_MSG_QUEUE_KEY_ENTRY_LIMIT is 1..n.

#define APOXI_MSG_QUEUE_YIELD_COUNTER

Counter for Yield calls in MsgQueue

If this define is set to any value (1..n) the message queue is calling Thread::Yield() after the defined amount of messages taken out of the queue. This enables the system to switch to another waiting thread with the same priority. If for example the define is set to 10, each AppContainer enables to switch to another AppContainer after every 10th handled message.

If APOXI_COMPAT_2_0_0 is not set, this define is obsolete and replaced by APOXI_MSG_QUEUE_YIELD_PERIOD.

Define dependencies:

  • APOXI_COMPAT_2_0_0

#define APOXI_MSG_QUEUE_YIELD_PERIOD

Time period for Yield calls in MsgQueue

If an AppContainer is permanently busy with handling messages, after this period of time (in ms) it calls Thread::Yield(). This enables the system to switch to another waiting Thread with the same priority. The default value is 100 (ms).

Define dependencies:

  • APOXI_COMPAT_2_0_0

#define APOXI_PHONENUMBER_MATCH_DEFAULT_DEPTH

Default number of digits which shall be used for matching method

This define allows changing the default number of digits which shall be used for the matching method used inside the PhoneNumber class. Default value is 6 which means that the last 6 digits are used, if they are equal then the phonenumber matches.

#define APOXI_POLYGON_EDGES_MAX

Defines the maximum numbers of edges a polygon may have.

Defines the maximum numbers of edges a polygon may have. If nothing is set, a default value of 50 is used.

Corresponding features:

  • MULTIMEDIA

Define dependencies:

  • APOXI_ENABLE_POLYGON_DRAWING

Enabled backward compatibility:

  • obsoleted define: APOXI_DC_POLYGON_MAX_EDGES
  • obsoleted define cleared out: APOXI_3.0.0

#define APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND

Defines timer impreciseness to optimize power consumption.

Impreciseness for APOXI timers can be configured by setting this define. For example if set to 10, a timer with timeout value 1000 ms is allowed to expire earliest after 990 ms. This makes it possible for hardware drivers to align the processor wake up and reduce power consumption.

Define dependencies:

  • APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE

#define APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE

Defines timer impreciseness to optimize power consumption.

Impreciseness for APOXI timers can be configured by setting this define. For example if set to 20, a timer with timeout value 1000 ms is allowed to expire earliest after 990 ms and latest after 1010 ms. This makes it possible for hardware drivers to align the processor wake up and reduce power consumption.
If APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE is set, additional settings for APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND and APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND are getting obsolete.

Define dependencies:

  • APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND

#define APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND

Defines timer impreciseness to optimize power consumption.

Impreciseness for APOXI timers can be configured by setting this define. For example if set to 10, a timer with timeout value 1000 ms is allowed to expire latest after 1010 ms. This makes it possible for hardware drivers to align the processor wake up and reduce power consumption.

Define dependencies:

  • APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE

#define APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT

Timeout for closing applications during shut-down.

If shutting down takes too long, APOXI will power off the phone without waiting any longer for applications to close. The default value is 20 (seconds).

#define APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL

Interval for shutdown device for checking applications.

During the shutdown process APOXI is periodically checking if all applications are closing and AppContainers are terminating correctly. This define is to configure the interval for this checks. The default value is 500 (ms).

#define APOXI_SMSSOCKET_MAX_CACHED_TPDUS

Defines the maximum number of Tpdus which shall be cached by a SmsSocket Defines the maximum number of Tpdus which shall be cached by a SmsSocket for an application, which has been registered. The default value is set to 12.

#define APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS

Defines the maximum number of applications which can register for a SmsSocket Defines the maximum number of applications which can register for a SmsSocket which then shall be notified in case a PushSms arrives. The default value is set to 2.

#define APOXI_THREAD_PRIORITY_NORMAL

Default priority level for APOXI tasks

APOXI provides predefined priority levels for task configuration. PriorityNormal is set to a OS dependent value, which can be changed. Default values are:

  • WIN32: THREAD_PRIORITY_NORMAL (see VC++ documentation)
  • OSE166: 20
  • NUC32: 100

See also:
Thread::PriorityLevel

Generated on Wed Jan 25 02:27:25 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Temporary Defines

Temporary Defines
[Optional Defines]

Collaboration diagram for Temporary Defines:

The temporary defines should only be introduced for compatibility reasons. More...

Defines

#define | APOXI_ADC_CCP_CODE
Temporary test code for CCP access
#define | APOXI_ADC_SIMTK_PROACTIVE_CODE
Temporary code for Simtk simulation triggering
#define | APOXI_CINGULAR_INPUT_TEST
shall not be set manually
#define | APOXI_HEAP_TEST
shall not be set manually

Detailed Description

The temporary defines should only be introduced for compatibility reasons.

Temporary defines are especially of use to provide compatibility to the lower interface of APOXI, like protocol stack, driver, etc. The responsible developer must care to remove temporary defines he has created when there is no need any more.

These defines are important to system integration work, which must be aware of the compatibility of the various project module layers. For example if more protocol stack versions have different interfaces due to misaligned release dates, a temporary define has to be created to be able to build with both protocol stack versions.

Temporary defines have to be enabled also via the project configuration file. The project integrator has to be aware of enabling the correct defines.

In CBE again this is done in the file project.config.default, located in the ${GLOBALPATH}/system-build/make directory, using the environment variable SYSTEM_DEFS.

Naming convention for new created temporary defines:

APOXI_TEMP_<functionality>, where

  • <functionality> describes the functionality, which is activated.

Define Documentation

#define APOXI_ADC_CCP_CODE

Temporary test code for CCP access

Temporary test code for CCP access

#define APOXI_ADC_SIMTK_PROACTIVE_CODE

Temporary code for Simtk simulation triggering

Temporary code for Simtk simulation triggering

#define APOXI_CINGULAR_INPUT_TEST

shall not be set manually

#define APOXI_HEAP_TEST

shall not be set manually

Generated on Wed Jan 25 02:27:26 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Currently Undocumented Defines (interim section)

Currently Undocumented Defines (interim section)
[APOXI Defines]

Collaboration diagram for Currently Undocumented Defines (interim section):

Defines

#define | APOXI_APN_NAME_LEN_MAX
Brief description
#define | APOXI_APPLICATION_TRACER_MAX_APPS
Brief description
#define | APOXI_AT_KEY_PARSER_TEST
Brief description
#define | APOXI_AT_MMI_INTERWORKING_REJECT
Brief description
#define | APOXI_AUX_CHINESEQUICKSORT_DEBUG
Brief description
#define | APOXI_AUX_QUICKSORT_DEBUG
Brief description
#define | APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX
Brief description
#define | APOXI_BEARER_PROFILE_NAME_LEN_MAX
Brief description
#define | APOXI_BEARER_PROFILE_PASSWD_LEN_MAX
Brief description
#define | APOXI_BLUETOOTH
Brief description
#define | APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY
Default security settings for OBEX client connections over Bluetooth
#define | APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY
Default security settings for OBEX services over Bluetooth
#define | APOXI_BYTEBUFFER_TEST_SUITE
Brief description
#define | APOXI_CAMERA_WIN32
Brief description
#define | APOXI_CRASH_DEBUG
Brief description
#define | APOXI_DATA_CONN_PROFILE_COUNT
Brief description
#define | APOXI_DATA_CONN_TEMP_PROFILE_COUNT
Brief description
#define | APOXI_DISABLE_CPP_CASTS
Brief description
#define | APOXI_DR_SMSR_SCA_BUG_NOT_FIXED
Brief description
#define | APOXI_ENABLE_OBSOLETE_STRING_INTERFACE
Brief description
#define | APOXI_ENABLE_OBSOLETE_WSTRING_INTERFACE
Brief description
#define | APOXI_ENALBE_NEW_STARTUP_INTERFACE
Brief description
#define | APOXI_FFS_EXTENDED_DEBUG
Brief description
#define | APOXI_FFS_USER_MAPPING
Brief description
#define | APOXI_GDD_INTERFACE
Brief description
#define | APOXI_GTL_DIF
Brief description
#define | APOXI_GTL_EBU
Brief description
#define | APOXI_HEAP_LOG
Brief description
#define | APOXI_HOST_NAME_LEN_MAX
Brief description
#define | APOXI_HOST_USE_DUMMY_PCH
Brief description
#define | APOXI_HOST_USE_PCH_SIGNALS
Brief description
#define | APOXI_IANA_ALL_PORT_NUMBERS
Brief description
#define | APOXI_INCLUDE_DRM
Brief description
#define | APOXI_LETTERCLASSE_SUPPORT
Brief description
#define | APOXI_LIB_ADDON_AFSFAT
Enables support for FAT devices
#define | APOXI_LIB_ADDON_AFSFFS
Brief description
#define | APOXI_LIB_ADDON_AFSRAM
Brief description
#define | APOXI_LIB_ADDON_AFSRFS
Brief description
#define | APOXI_LIB_ADDON_VR
Brief description
#define | APOXI_LIB_BLUETOOTH
Brief description
#define | APOXI_LIB_IRDA
Brief description
#define | APOXI_LIB_OBEX
Brief description
#define | APOXI_MAX_INET_SOCKET_COUNT
Brief description
#define | APOXI_MEM_TRACE
Brief description
#define | APOXI_MMCI_SUPPORT
Brief description
#define | APOXI_NO_MSG_BROADCAST_ON_STARTUP
Brief description
#define | APOXI_NOSTREAMING
Brief description
#define | APOXI_OBEX_MAX_NO_SELECTIONS
Maximum number of concurrently running transport address selection procedures
#define | APOXI_OBEX_MAX_NO_TRANSPORTS
Maximum number of transport protocols supported by APOXI OBEX
#define | APOXI_PHONENUMBER_TEST_SUITE
Brief description
#define | APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE
Brief description
#define | APOXI_REG_LARGE_BLOB_SIZE
Brief description
#define | APOXI_REG_MAP_FILE_RECORDS_MAX
Brief description
#define | APOXI_REG_MAX_ASOT
Brief description
#define | APOXI_REG_MAX_MIME_TYPE_LEN
Brief description
#define | APOXI_REG_MAX_POOL_BUFFERS
Brief description
#define | APOXI_REG_MAX_URIS_IN_TABLE
Brief description
#define | APOXI_REG_NODE_FILE_SIZE_MAX
Brief description
#define | APOXI_REG_NODE_NAME_SIZE_MAX
Brief description
#define | APOXI_REG_SMALL_BLOB_SIZE_MAX
Brief description
#define | APOXI_REG_URI_SIZE_MAX
Brief description
#define | APOXI_REG_VERSION
Brief description
#define | APOXI_REGISTERED_TABLE_SIZE
Brief description
#define | APOXI_REGISTRY_TEST
Brief description
#define | APOXI_RTOS_DUMMY
Brief description
#define | APOXI_RTOS_NUC16
Brief description
#define | APOXI_RTOS_NUC16S
Brief description
#define | APOXI_RTOS_NUC16U
Brief description
#define | APOXI_RTOS_POCKETPC
Brief description
#define | APOXI_RTOS_SIM166
Brief description
#define | APOXI_SCICOS_MM_CHIP_SUPPORT
Brief description
#define | APOXI_SDMMCSPI_SUPPORT
Brief description
#define | APOXI_SEMAPHORE_M_FIRST_SWE
Brief description
#define | APOXI_SER_DATACONN_SUPPORT
Brief description
#define | APOXI_SOCKET_ENSURE_CONTEXT
Brief description
#define | APOXI_SOCKET_EXTENDED_TRACE
Brief description
#define | APOXI_SOCKET_OPERATION_LOCK
Brief description
#define | APOXI_SOCKET_PARANOIA
Brief description
#define | APOXI_SOCKET_SYSTEM_BSD
Brief description
#define | APOXI_SOCKET_SYSTEM_DUMMY
Brief description
#define | APOXI_SOCKET_SYSTEM_LWIP
Brief description
#define | APOXI_SOCKET_SYSTEM_USNET
Brief description
#define | APOXI_SOCKET_SYSTEM_WIN32
Brief description
#define | APOXI_STRING_EXTENDED_DEBUG
Brief description
#define | APOXI_STRING_TEST_SUITE
Brief description
#define | APOXI_SYNC_RELEASE
Brief description
#define | APOXI_SYSTEM_STACK_SWAPPING
Brief description
#define | APOXI_TESTING
Brief description
#define | APOXI_TRACE
Brief description
#define | APOXI_TRACE_DISABLED
Brief description
#define | APOXI_TRACE_LEVEL_2
Brief description
#define | APOXI_TRACE_LEVEL_3
Brief description
#define | APOXI_TRACE_MEM
Brief description
#define | APOXI_TRACE_SOCKETS
Brief description
#define | APOXI_UNITTEST_MMI
Brief description
#define | APOXI_UNITTEST_NO_TESTNAMES
Brief description
#define | APOXI_UNITTEST_STATIC_REPOSITORY
Brief description
#define | APOXI_UNITTEST_TRACE
Brief description
#define | APOXI_VIBRATOR_SUPPORT
Brief description
#define | APOXI_WAP_STACK
Brief description
#define | APOXI_WCATTR_NULL_DEF
Brief description
#define | APOXI_WSTRING_EXTENDED_DEBUG
Brief description
#define | APOXI_WSTRING_TEST_SUITE
Brief description
#define | APOXI_ZLIB_USE_STACK_MEM_FUNCS
Brief description
#define | FEAT_BT_BPP

#define | FEAT_SIOSOCKETADAPTER
Define for Low Level SIO Sockets access over Serial Sockets
#define | SIMTK_LETTERCLASS_E
SIM Toolkit Letter Class E

Define Documentation

#define APOXI_APN_NAME_LEN_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_APPLICATION_TRACER_MAX_APPS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_AT_KEY_PARSER_TEST

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_AT_MMI_INTERWORKING_REJECT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_AUX_CHINESEQUICKSORT_DEBUG

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_AUX_QUICKSORT_DEBUG

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_BEARER_PROFILE_NAME_LEN_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_BEARER_PROFILE_PASSWD_LEN_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_BLUETOOTH

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY

Default security settings for OBEX client connections over Bluetooth

Detailed description When an OBEX client connection is opened and no security settings are explicitly specified, this constant defines the default security level.

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY

Default security settings for OBEX services over Bluetooth

Detailed description When an OBEX server is opened and no security settings are explicitly specified, and when the service has no special security defaults, this constant defines the default security level.

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_BYTEBUFFER_TEST_SUITE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_CAMERA_WIN32

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_CRASH_DEBUG

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_DATA_CONN_PROFILE_COUNT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_DATA_CONN_TEMP_PROFILE_COUNT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_DISABLE_CPP_CASTS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_DR_SMSR_SCA_BUG_NOT_FIXED

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_ENABLE_OBSOLETE_STRING_INTERFACE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_ENABLE_OBSOLETE_WSTRING_INTERFACE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_ENALBE_NEW_STARTUP_INTERFACE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_FFS_EXTENDED_DEBUG

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_FFS_USER_MAPPING

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_GDD_INTERFACE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_GTL_DIF

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_GTL_EBU

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_HEAP_LOG

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_HOST_NAME_LEN_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_HOST_USE_DUMMY_PCH

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_HOST_USE_PCH_SIGNALS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_IANA_ALL_PORT_NUMBERS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_INCLUDE_DRM

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LETTERCLASSE_SUPPORT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LIB_ADDON_AFSFAT

Enables support for FAT devices

Detailed description To support different FAT devices, these define has to be set. On target, the RootFileSystem afterwards registers the available FAT devices automatically.

Corresponding features:

  • AFSFAT

Define dependencies:

  • APOXI_SDMMCSPI_SUPPORT
  • APOXI_MMCI_SUPPORT (one of these both - depends on HW)

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LIB_ADDON_AFSFFS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LIB_ADDON_AFSRAM

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LIB_ADDON_AFSRFS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LIB_ADDON_VR

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LIB_BLUETOOTH

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LIB_IRDA

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_LIB_OBEX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_MAX_INET_SOCKET_COUNT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_MEM_TRACE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_MMCI_SUPPORT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_NO_MSG_BROADCAST_ON_STARTUP

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_NOSTREAMING

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_OBEX_MAX_NO_SELECTIONS

Maximum number of concurrently running transport address selection procedures

Detailed description When an OBEX client connection is requested without a transport protocol being specified as part of the client address (wildcard address starting with *://), MMI is notified asynchronously to select a transport. When this procedure is invoked in a reentrant way, APOXI OBEX queues the requests and notifies them one after another. This constant specified the queue size and therefore the maximum reentrancy level.

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_OBEX_MAX_NO_TRANSPORTS

Maximum number of transport protocols supported by APOXI OBEX

Detailed description This constant specifies the size of the transport table and therefore the maximum number of transport implementations which can register themselves with APOXI OBEX.

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_PHONENUMBER_TEST_SUITE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_LARGE_BLOB_SIZE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_MAP_FILE_RECORDS_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_MAX_ASOT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_MAX_MIME_TYPE_LEN

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_MAX_POOL_BUFFERS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_MAX_URIS_IN_TABLE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_NODE_FILE_SIZE_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_NODE_NAME_SIZE_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_SMALL_BLOB_SIZE_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_URI_SIZE_MAX

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REG_VERSION

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REGISTERED_TABLE_SIZE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_REGISTRY_TEST

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_RTOS_DUMMY

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_RTOS_NUC16

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_RTOS_NUC16S

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_RTOS_NUC16U

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_RTOS_POCKETPC

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_RTOS_SIM166

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SCICOS_MM_CHIP_SUPPORT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SDMMCSPI_SUPPORT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SEMAPHORE_M_FIRST_SWE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SER_DATACONN_SUPPORT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_ENSURE_CONTEXT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_EXTENDED_TRACE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_OPERATION_LOCK

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_PARANOIA

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_SYSTEM_BSD

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_SYSTEM_DUMMY

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_SYSTEM_LWIP

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_SYSTEM_USNET

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SOCKET_SYSTEM_WIN32

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_STRING_EXTENDED_DEBUG

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_STRING_TEST_SUITE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SYNC_RELEASE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_SYSTEM_STACK_SWAPPING

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_TESTING

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_TRACE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_TRACE_DISABLED

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_TRACE_LEVEL_2

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_TRACE_LEVEL_3

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_TRACE_MEM

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_TRACE_SOCKETS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_UNITTEST_MMI

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_UNITTEST_NO_TESTNAMES

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_UNITTEST_STATIC_REPOSITORY

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_UNITTEST_TRACE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_VIBRATOR_SUPPORT

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_WAP_STACK

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_WCATTR_NULL_DEF

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_WSTRING_EXTENDED_DEBUG

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_WSTRING_TEST_SUITE

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define APOXI_ZLIB_USE_STACK_MEM_FUNCS

Brief description

Detailed description

Corresponding features:

  • N/A

Define dependencies:

  • N/A

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

#define FEAT_BT_BPP

Detailed description Bluetooth: Basic Printing Profile (sender role) to connect to another BPP device (printer role) to print out. In Apoxi only the sender role of BPP is implemented. The following objects are printable, well formatted (printer device dependent): XHTML, VCARD, VCALENDER, JPEG, GIF, etc...

Activated defines:

  • FEAT_BT_BPP
  • APOXI_LIB_FEAT_BT_BPP

Feature dependencies:

  • BLUETOOTH

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: BLUETOOTH_BPP

#define FEAT_SIOSOCKETADAPTER

Define for Low Level SIO Sockets access over Serial Sockets

Enable this define, if Low Level SIO Sockets access over Serial Sockets are needed.

Corresponding features:

  • FEAT_SERIALSOCKET

#define SIMTK_LETTERCLASS_E

SIM Toolkit Letter Class E

Detailed description SIM Toolit Letter Class E defines access of SIM applications to internet resources using TCP or UDP sockets. The user should be asked / informed about outgoing transaction operations.

Activated defines:

  • SIMTK_LETTERCLASS_E
  • APOXI_LETTERCLASSE_SUPPORT

Feature dependencies:

  • SOCKET

Enabled backward compatibility:

  • obsoleted define: N/A
  • obsoleted define cleared out: N/A

Generated on Wed Jan 25 02:27:33 2006 for APOXI by doxygen 1.4.6-NO


APOXI: APOXI Features

APOXI Features

Collaboration diagram for APOXI Features:

A modular functionality which can be applied to the framework. More...

Modules

Currently Undocumented Features (interim section)

Defines

#define | ADDITIONAL_THEMES
Adds the themes 'Foggy Theme' and 'Customizable Theme'.
#define | AFSFAT
APOXI filesystem AFSFAT
#define | AFSFFS
APOXI FlashFileSystem
#define | AFSRAM
APOXI file system AFSRAM
#define | AFSRFS
APOXI RootFileSystem
#define | ARAGON
ARAGON is used to build a phone MMI with the ARAGON IDE on a host computer.
#define | AT_MMI_INTERWORKING
Interworking between APOXI and other stack-clients.
#define | ATI
The feature ATI mainly covers the new generic companion interface (GCI) adressing video codecs, audio codecs and graphics device driver interfaces for ATI W2x82 companion
#define | ATL
ATL - Application Template Library
#define | CAMERA
Enables the support for the still camera and video camera device.
#define | CODEC_MAN
Allows to use codec manager for MMFr
#define | DEBUG_INFO
Activate debug trace output and crash debug output
#define | DRM
Allows protection of content using digital rights technology (incl. aes, xmlparser, wbxml)
#define | DUAL_DISPLAY
Enables dual display support for the default DisplayConfig class.
#define | EMZ_CODECS
Allows to use SW audio and video codecs from Emuzed
#define | EXTERNAL_RINGER
Enable the YAMAHA player support
#define | FAT_FS
Activates FAT file system support on driver layer
#define | FEAT_BT_A2DP
Activate Bluetooth Advanced Audio Distribution Profile
#define | FEAT_BT_AVRCP
Activate Bluetooth Audio Video Remote Control Profile
#define | FEAT_BT_BIP
Bluetooth Basic Imaging Profile
#define | FEAT_BT_BPP
Bluetooth Basic Printing Profile
#define | FEAT_BTSOCKET
Bluetooth specific address class
#define | FEAT_EXTERNAL_PCH_CONTROL
External PCH Control
#define | FEAT_FOTA
Firmware update Over The Air
#define | FEAT_MMCALL
Multimedia Call Handling API
#define | FEAT_SECURECLOCK
Secure Clock
#define | FEAT_SERIALSOCKET
Generic Serial Socket Interface
#define | FEAT_SIOSOCKETADAPTER
Define for Low Level SIO Sockets access over Serial Sockets
#define | FFS
Activates flash file system (FFS) on driver layer
#define | FMRADIO
FM radio support
#define | FTPSERVER
Allows to create, start and use an FTP server in APOXI.
#define | GDD
use graphics device driver (GDD)
#define | GTL
GTL
#define | HTTPSERVER
Allows to create, start and use an HTTP server in APOXI.
#define | HTTPWAPINTERFACE
HTTP/WAP and profile management interface
#define | INTERNATIONALIZATION
Allows to use factory customized packs for languages and T9 dictionaries.
#define | IRDA
IrDA (in case of combination with OBEX, the IrDA/Obex transport is also activated
#define | LCS
location based services using AGPS technology
#define | MENU_ACCESSORS
Obsolete feature, which enables menu accessor support for GUI.
#define | MM_CHIP_SCICOS
Support for SciCOS companion chip
#define | MMCI
Activates multi media card (MMC) on egold, sgold, or sgold2
#define | MP3
MP3 support having codec available in the firmware
#define | MULTIMEDIA
Multimedia addons (incl. libpng & zlib)
#define | OBEX
OBEX - OBject EXchange protocol support
#define | OBEXFTP_RFS
Obex-FTP server for APOXI Root File System (RFS)
#define | PNG_ENCODER
Enables PNG encoder
#define | SDMMCSPI
Activates multi media card (MMC) and SD-card on sgoldlite
#define | SERVER
Generic server interface.
#define | SIMTK_LETTERCLASS_E
SIM Toolkit Letter Class E
#define | SVG
Enables support for SVG
#define | T9
Predictive input T9
#define | TESTING
Enabling APOXI Tester instrumentations
#define | TTY
TTY, TeleTYpewriter
#define | UNITTEST
Unittest Framework
#define | UUS
User-to-User Signaling (UUS)
#define | VIB
Vibrator support
#define | VOICERECOGNITION
Voice Recognition
#define | YAMAHA_MAPI
Yamaha Mapi
#define | ZI8
Predictive input ZI8

Detailed Description

A modular functionality which can be applied to the framework.

Features are options to the whole project build, which may also have impact to more than one component like driver, protocol stack, APOXI, MMI, applications. Additionally features can control the build process, as they are processed in various makefiles.

Naming conventions and usage instructions:

  • Feature strings do not contain any APOXI pre-/in-/postfix, but must contain the prefix FEAT_. The syntax therefore is: FEAT_<feature>, where <feature> is the name of the corresponding feature.
  • Feature names must be clear and unambiguous.
  • Alternative or group features must be documented in a common prefix (e.g. FEAT_AFSFFS, FEAT_AFSMMC).
  • If a feature is spanning over more than one component (RefMMI, APOXI, protocol stack, ...) and impacts APOXI, then in must be documented in the file apoxi.features.
  • All features used in APOXI must be documented and regularly updated in the file apoxi.features.
  • Before a feature is allowed to be used it must be announced via UTP ticket against the product CBE_KEYWORDVALUES. After confirmation of the feature name by CBE CCB the feature is ready to use for APOXI. (A detailed process description can be found in http://goto.infineon.com/CN-intranet-public/Develop_Environment/Common_Build_Environment/SW_Instruction_Comp_Define_01_00.doc)

Define Documentation

#define ADDITIONAL_THEMES

Adds the themes 'Foggy Theme' and 'Customizable Theme'.

Adds the themes 'Foggy Theme' and 'Customizable Theme' to the already available 'Default Theme'.

Activated defines:

  • APOXI_ADDITIONAL_THEMES_SUPPORT

#define AFSFAT

APOXI filesystem AFSFAT

Detailed description Activates the FAT filesystem. This activation has to be done for supporting FAT devices like MMC or NAND.

On host the FAT devices have to be activated seperately. On target the recognized FAT devices will register them on their own.

Feature dependencies:

  • FAT_FS

#define AFSFFS

APOXI FlashFileSystem

Detailed description Activates the Apoxi FlashFileSystem, which is the default filesystem, where currently all configuration files (e.g. for Aragon) are saved.

Feature dependencies:

  • FFS

#define AFSRAM

APOXI file system AFSRAM

Detailed description Activates the Apoxi RAM file system which stores data in a virtual directory hierarchy in memory.

#define AFSRFS

APOXI RootFileSystem

Detailed description Activates the abstract RootFileSystem. The RootFileSystem is a default interface to access all Apoxi filesystems. It coordinates the access to the concrete implementations (e.g. FlashFileSystem, FAT filesystem).

The concrete filesystem implementations (e.g. FlashFileSystem) can be used without the Rootfilesystem too, but it is recommended to use the abstract class for all filesystem accesses.

#define ARAGON

ARAGON is used to build a phone MMI with the ARAGON IDE on a host computer.

ARAGON is an APOXI feature that can be used to define a phone's complete MMI via configuration files built with the ARAGON IDE. The resulting configuration files are read from the FFS.

Activated defines:

  • APOXI_ARAGON_SUPPORT

Feature dependencies:

  • ADDITIONAL_THEMES As Aragon is also used to read customized themes from configuration files, the feature ADDITIONAL_THEMES must also be enabled so that the CustomizableTheme is built.

#define AT_MMI_INTERWORKING

Interworking between APOXI and other stack-clients.

If APOXI is not the only client for the stack it is necessary to have some interworking with other clients. Normaly ATC is the second client which is the the case if bluetooth is activated. In this case this feature activates the interworking.

Activated defines:

  • APOXI_AT_MMI_INTERWORKING_CALL
  • APOXI_AT_MMI_INTERWORKING_SIMTK
  • APOXI_AT_MMI_INTERWORKING_SS
  • APOXI_AT_MMI_INTERWORKING_USSD

#define ATI

The feature ATI mainly covers the new generic companion interface (GCI) adressing video codecs, audio codecs and graphics device driver interfaces for ATI W2x82 companion

This GCI driver is available for target and for a special ALIHOST environment. In this special ALIHOST configuration the PC is extended by a PCI card from ATI with an companion daughter board, LCD panel and camera. This "ALIHOST PCI" build uses a GCI driver for WIN32 OS. For this purpose the corresponding threads have to be started at system startup for ALIHOST. This is the main impact on APOXI. In case of target SW, GCI runs in NucleusPlus threads to adress ATI W2x82 companion.

Activated defines:

  • APOXI_ATI_SUPPORT=yes APOXI_DEFS += \ APOXI_ATI_SUPPORT \ APOXI_GDD_INTERFACE \ APOXI_GDD_2_0_INTERFACE \ APOXI_ATIW2282_SUPPORT ifeq '${TARGETSYSTEM}' 'HW' APOXI_DEFS += ATI_CONFIG_TARGET_VENUS_HW endif ifeq '${TARGETSYSTEM}' 'ALIHOST' APOXI_DEFS += ALIHOST_ATI_PCI endif

Feature dependencies:

  • N/A

#define ATL

ATL - Application Template Library

ATL provides a framework on top of APOXI that allows easy customization of the menu structure, of context dependent key behaviour and softkey assignments.

Activated defines:

  • APOXI_ATL_SUPPORT

#define CAMERA

Enables the support for the still camera and video camera device.

Enables the support for the still camera and video camera device. If the support is enabled, the CameraConfig must be available, which also instantiates the devices for camera and video.

Activated defines:

  • APOXI_CAMERA_SUPPORT

Feature dependencies:

  • N/A

#define CODEC_MAN

Allows to use codec manager for MMFr

Codec manager administrates video and audio codecs (decoders and encoders) in Apoxi. It provides methods to access a specific de-/encoder. It is used by Multimedia Framework (MMFr).

Activated defines:

  • APOXI_CODEC_MAN_SUPPORT

Feature dependencies:

  • N/A

#define DEBUG_INFO

Activate debug trace output and crash debug output

This feature enables the APOXI trace debug outputs (done via DBG_OUT macro) and additionally activates various crash recovery information, like memory check, stacksize checks ...

Attention: When activating this feature trace outputs are added without respect to the buildmode environment variable ${BUILDMODE}. That means if a build is done with ${BUILDMODE}=RELEASE and this feature is enabled, the trace debug outputs are still part of the build. This has a special focus with codesize reduction issues.

Activated defines:

  • _DEBUG
  • APOXI_HEAP_MEM_ACCESS_CHECK
  • APOXI_ENABLE_STACK_CHECK

#define DRM

Allows protection of content using digital rights technology (incl. aes, xmlparser, wbxml)

Detailed description Stores & manages the digital rights in the mobile for protection of content (e.g., wallpapers, screensavers, ringtones, etc) obtained from a content provider's URL. There are 3 mechanisms in DRM V1.0: Forward lock - Content is not allowed to be forwarded (i.e., using local connectivity, MMS, etc) by the user & default max rights is appled to the content (e.g., a very high count of using the content & a large validity period of usage) Combined delivery - The content & digital rights are bundled in one downloaded message Separate delivery - The content is obtained first & the rights arrive later via a WAP Push message

The content file has an additional attribute 'DRM bit' to indicate that it's a DRM-protected object. The applications, e.g., ImageBrowser & SoundBrowser, check this attribute for any content file & invoke the DRM module to take care of the applicable rights.

DRM uses the AES module internally to decrypt the separate delivery content file. The WbxmlParser is used to parse the rights (in binary XML format) pertaining to the separate delivery content. The XmlParser is used to parse the rights (in plain text XML format) embedded within the combined delivery object.

Activated defines: APOXI_INCLUDE_DRM APOXI_LIB_ADDON_AES APOXI_LIB_ADDON_DRM APOXI_LIB_ADDON_WBXML APOXI_LIB_ADDON_XMLPARSER

Feature dependencies: AFSFFS

#define DUAL_DISPLAY

Enables dual display support for the default DisplayConfig class.

Enables dual display support for the default DisplayConfig class, so that the customization for dual display support is more easy. The define itself is not used by APOXI itself and only meant for allow to turn on the feature DUAL_DISPLAY without touching the class DisplayConfig.

Activated defines:

  • APOXI_DUAL_DISPLAY_SUPPORT

Feature dependencies:

  • N/A

#define EMZ_CODECS

Allows to use SW audio and video codecs from Emuzed

Allows to use Software audio and video codecs (decoders and encoders) from Emuzed. They are accessible via codec manager.

Activated defines:

  • APOXI_EMZ_CODECS_SUPPORT

Feature dependencies:

  • CODEC_MAN is mandatory in order to access the SW codecs from Emuzed.

#define EXTERNAL_RINGER

Enable the YAMAHA player support

APOXI support for MIDI, SMAF on YAMAHA MXx IC

Activated defines:

  • APOXI_YAMAHA_RINGER_SUPPORT

#define FAT_FS

Activates FAT file system support on driver layer

Detailed description Activates the FAT filesystem support on driver layer. For Apoxi a seperate feature define "AFSFAT" has to be defined.

#define FEAT_BT_A2DP

Activate Bluetooth Advanced Audio Distribution Profile

A2DP is a Bluetooth profile that allows the sending of high quality audio data to a remote device (Sink). This feature enables functionality in APOXI Bluetooth, APOXI Audio and the BTAPI stack.

Activated defines:

  • APOXI_LIB_FEAT_BT_A2DP

Feature dependencies:

  • BLUETOOTH mandatory

#define FEAT_BT_AVRCP

Activate Bluetooth Audio Video Remote Control Profile

AVRCP is used to implement Audio/Video Remote control functionality. Two roles can be implemented - the controller role, which enables the mobile phone user to control other AVRCP enabled devices (play, stop, fast forward, etc.) and the target role, which allows the user to control media applications implemented in the phone to be controlled by AVRCP controller.

Activated defines:

  • APOXI_LIB_BT_AVRCP

Feature dependencies:

  • BLUETOOTH mandatory

#define FEAT_BT_BIP

Bluetooth Basic Imaging Profile

This feature enables APOXI Bluetooth BIP. Currently BT BIP Image Push and Image Pull in initiator and responder role are supported.

Activated defines:

  • APOXI_LIB_BLUETOOTH_BIP

Feature dependencies:

  • BLUETOOTH mandatory

#define FEAT_BT_BPP

Bluetooth Basic Printing Profile

Detailed description Bluetooth: Basic Printing Profile (sender role) to connect to another BPP device (printer role) to print out. In Apoxi only the sender role of BPP is implemented. The following objects are printable, well formatted (printer device dependent): XHTML, VCARD, VCALENDER, JPEG, GIF, etc...

Activated defines:

  • FEAT_BT_BPP
  • APOXI_LIB_FEAT_BT_BPP

Feature dependencies:

  • BLUETOOTH

#define FEAT_BTSOCKET

Bluetooth specific address class

This gives the Bluetooth (RFCOMM and L2CAP) specific address implementations.

Activated defines:

  • APOXI_LIB_ADDON_BTSOCKET

#define FEAT_EXTERNAL_PCH_CONTROL

External PCH Control

This feature enables the monitoring and control of external GPRS data connections (used via AT terminals). If the feature is activated the MMI can listen to the ExternalPdpContextInfoMsg message to be informed when the user sets up or terminates a GPRS data connection via AT. Furthermore it is also possible to force the termination of an external GPRS data connection via MMI.

Activated defines:

  • APOXI_EXTERNAL_PCH_CONTROL_SUPPORT

Feature dependencies:

  • N/A

#define FEAT_FOTA

Firmware update Over The Air

This feature enables Firmware update over the air in APOXI. For detailed description see class Fota.

Activated defines:

  • APOXI_FOTA_SUPPORT

Feature dependencies:

  • N/A

#define FEAT_MMCALL

Multimedia Call Handling API

This feature enables APOXI Multimedia Call Hanlding. It provides an interface equivalent to the Voice Call Handling for setting up a MM MOC, accepting or rejecting a MM MTC, for releasing a MM call and provides access to the data stored in the CallHandlingData object of MainHandler.

Activated defines:

  • APOXI_LIB_ADDON_MMCALL

#define FEAT_SECURECLOCK

Secure Clock

Enables additional interfaces in class RealTimeClock to access secure clock information. See RealTimeClock::GetSecureDateTime and RealTimeClock::IsSecureClockValid.

Activated defines:

  • APOXI_SECURECLOCK_SUPPORT

Feature dependencies: N/A

#define FEAT_SERIALSOCKET

Generic Serial Socket Interface

This feature gives the apoxi serial socket interface to communicate with different underlying transport protocals like RFCOMM, L2CAP, etc.

Activated defines:

  • APOXI_LIB_ADDON_SERIALSOCKET

#define FEAT_SIOSOCKETADAPTER

Define for Low Level SIO Sockets access over Serial Sockets

Detailed description Enable this define, if Low Level SIO Sockets access over Serial Sockets are needed.

Activated defines:

  • #
  • #

Feature dependencies:

  • FEAT_SERIALSOCKET

#define FFS

Activates flash file system (FFS) on driver layer

Activates the Apoxi FlashFileSystem on driver layer. The FFS is the default filesystem, where currently all configuration files (e.g. for Aragon) are saved. The corresponding define to activate the Apoxi support for the FlashFileSystem is "AFSFFS".

#define FMRADIO

FM radio support

Support of the FM Radio device including capabilities such as station search or RDS

Activated defines:

  • APOXI_FM_RADIO_SUPPORT

Feature dependencies:

  • N/A

#define FTPSERVER

Allows to create, start and use an FTP server in APOXI.

Implementation of the Server interface for the file transfer protocol (as specified in RFC 959). It creates a home directory in AFSFFS (or AFSRAM if available).

Feature dependencies:

  • AFSFFS is needed to create the home directory of the FTP server in FFS (if AFSRAM is not available).
  • AFSRAM is optional if the home directory of the server should be located in the virtual RAM drive (otherwise in FFS).
  • AFSRFS is needed as the FtpServer must have access to the files in the root file system.
  • SERVER is mandatory as FtpServer is a implementation of the generic Server interface.

#define GDD

use graphics device driver (GDD)

Feature, which enables support for GDD. Usually this feature is always set and must not be unset, unless an own driver I/F for display and camera is used

Activated defines:

  • APOXI_GDD_INTERFACE

Feature dependencies:

  • N/A

#define GTL

GTL

This feature enables GTL support. In combination with feature GTL_EBU and GTL_DIF, it allows to select the type of display interface, either serial or parallel.

Activated defines:

  • N/A

Feature dependencies:

  • GTL_EBU
  • GTL_DIF

#define HTTPSERVER

Allows to create, start and use an HTTP server in APOXI.

Implementation of the Server interface for the hypertext transfer protocol (as specified in RFC 2616). It creates a home directory in AFSFFS, where files can be stored (e.g. via FtpServer or PhoneTool) for public access. Additionally the index page of the server shows a list of available web applications including a brief description.

Feature dependencies:

  • AFSFFS is needed to create the home directory of the FTP server in FFS (if AFSRAM is not available).
  • AFSRFS is needed as the HttpServer must have access to files (e.g. style sheets, images) in the root file system.
  • SERVER is mandatory as HttpServer is a implementation of the generic Server interface.

#define HTTPWAPINTERFACE

HTTP/WAP and profile management interface

Detailed description HTTP/WAP and profile management interface that 3rd party WAP s/w has to adhere to.

Activated defines: APOXI_LIB_ADDON_HTTPWAPINTERFACE \ APOXI_WAP_STACK

Feature dependencies:

  • N/A

#define INTERNATIONALIZATION

Allows to use factory customized packs for languages and T9 dictionaries.

Allows to use factory customized packs for languages and T9 dictionaries.

Activated defines:

  • APOXI_FACTORY_CUSTOMIZATION_SUPPORT

Feature dependencies:

  • N/A

#define IRDA

IrDA (in case of combination with OBEX, the IrDA/Obex transport is also activated

IrDA utilizes the infra red devices onboard. It is used for modem functionality and can also serve as transport layer for OBEX. In case of presence of OBEX, the IrDA/Obex transport layer also gets compiled into a separate library. APP_IRDA is not an APOXI define, but an coexisting MMI define, to include an application, which takes over the IrDA-hardware on/off switching.

Activated defines:

  • FEATURE+=IRDA
  • APPLICATIONS+=APP_IRDA

Feature dependencies:

  • N/A

#define LCS

location based services using AGPS technology

Detailed description Location Services (LCS) module offers API to develop powerful location based services applications. The following functionality is currently supported:

  • Self-location -> User can obtain his location
  • Transfer-location -> User can transfer his location to a specified Lcs client
  • MT-LR -> User is notified in case someone is trying to locate him & is prompted for approval
  • NMEA data transfer -> User's location information is converted to NMEA format & transmitted via a serial cable to say, another device or a PC

AGPS technology is used to fulfil the above functionality. The required protocol handling is done either via GLTP (proprietary Global Locate protocol) or 3GPP procedures. The user can also choose stand-alone mode wherein AGPS is switched to conventional GPS without establishing a connection to the n/w.

Activated defines: LCS_3GPP LCS_GLTP LCS_STAND_ALONE LCS_LANDMARK APOXI_LIB_ADDON_LCS

Feature dependencies: GPS SOCKET AFSFFS

#define MENU_ACCESSORS

Obsolete feature, which enables menu accessor support for GUI.

Obsolete feature, which enables the menu accessor support for GUI. Menu accessors have been replaced by the item concept since APOXI and Reference MMI 2.0. It is planned that this feature will be removed in APOXI-3.0, as it is not used by any customer yet.

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define MM_CHIP_SCICOS

Support for SciCOS companion chip

Enables the transparent mode of SciCOS (in a platform supporting the SciCOS companion chip). The SciCOS chip is disabled and only the path to the LCD is switched.

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define MMCI

Activates multi media card (MMC) on egold, sgold, or sgold2

Detailed description This feature activates the multi media card (MMC) support on driver layer. For Apoxi no additional define is needed, because the different FAT devices (MMC is one of those) register themselves automatically. The only precondition is that the FAT filesystem is activated. This happens by two feature defines AFSFAT (Apoxi layer) and FAT_FS (driver layer)

Feature dependencies:

  • FAT_FS
  • AFSFAT

#define MP3

MP3 support having codec available in the firmware

This feature should be enabled whenever the FW provides MP3 codec. This feature should not be defined when the decoding is done in MMFr (ex. MPE)

Activated defines:

  • APOXI_MP3_SUPPORT

Feature dependencies:

  • N/A

#define MULTIMEDIA

Multimedia addons (incl. libpng & zlib)

This feature enables multimedia support for APOXI including Jpeg en/decoding, GIF, PNG, BMP and WBMP decoding.

Activated defines:

  • APOXI_MULTIMEDIA_SUPPORT
  • APOXI_VIDEO_SUPPORT
  • APOXI_ENABLE_ALPHA_BLENDING
  • APOXI_ENABLE_ANIMATED_TITLE
  • APOXI_ENABLE_ARC_DRAWING
  • APOXI_ENABLE_CIRCLE_DRAWING
  • APOXI_ENABLE_DIAGONAL_LINE_DRAWING
  • APOXI_ENABLE_POLYGON_DRAWING

#define OBEX

OBEX - OBject EXchange protocol support

Detailed description

This feature enables a multi-transport OBEX interface which supports both client- and server applications. Furthermore the OPP (Object Push Profile) profile is implemented based on plain OBEX. At least one implementation of the internal transport interface (called Transport Adapter) must be available as well (pls. see list below).

Activated defines:

  • N/A

Feature dependencies:

  • IRDA optional
  • BLUETOOTH optional
  • USB optional

#define OBEXFTP_RFS

Obex-FTP server for APOXI Root File System (RFS)

This feature enables the Obex-FTP server implemenation for the APOXI Root File System (RFS). This ready-to-use server implemenation may be used by an application to provide the user an Obex-FTP server to gain access to the RFS through all available transport layers like Bluetooth, IRDA, USB, etc.

Feature dependencies:

  • OBEX mandatory
  • AFSRFS mandatory

#define PNG_ENCODER

Enables PNG encoder

This feature enables PNG encoder support for APOXI.

Feature dependencies:

  • MULTIMEDIA mandatory

Activated defines:

  • APOXI_PNG_ENCODER_SUPPORT

#define SDMMCSPI

Activates multi media card (MMC) and SD-card on sgoldlite

Detailed description This feature activates the multi media card (MMC) support on driver layer. For Apoxi no additional define is needed, because the different FAT devices (MMC is one of those) register themselves automatically. The only precondition is that the FAT filesystem is activated. This happens by two feature defines AFSFAT (Apoxi layer) and FAT_FS (driver layer).

Feature dependencies:

  • FAT_FS
  • AFSFAT

#define SERVER

Generic server interface.

Abstract interface for TCP based servers.

#define SIMTK_LETTERCLASS_E

SIM Toolkit Letter Class E

Detailed description SIM Toolit Letter Class E defines access of SIM applications to internet resources using TCP or UDP sockets. The user should be asked / informed about outgoing transaction operations.

Activated defines:

  • SIMTK_LETTERCLASS_E
  • APOXI_LETTERCLASSE_SUPPORT

Feature dependencies:

  • N/A

#define SVG

Enables support for SVG

Enables support for scalable vector graphics.

Activated defines:

  • APOXI_SVG_SUPPORT

Feature dependencies:

  • MULTIMEDIA mandatory

#define T9

Predictive input T9

Enables the support for predictive input method T9.

Activated defines:

  • APOXI_T9_SUPPORT

#define TESTING

Enabling APOXI Tester instrumentations

This features activated the instrumentations for automated testing using APOXI Tester.

Activated defines:

  • APOXI_TESTING

Feature dependencies:

  • DEBUG must be activate

#define TTY

TTY, TeleTYpewriter

For dumb and deaf people it is not possible to use common phones. With a additional device to the phone it is possible to visualize speech on a screen and typed text is translated to speech. This must be supported by the provider because the translation from speech to text and vice versa must be done there. With this feature the support for TTY is activated in APOXI.

Activated defines:

  • APOXI_CTM

#define UNITTEST

Unittest Framework

This featuer enables the APXOI Unittest framework

Activated defines:

  • APOXI_UNITTEST
  • APOXI_UNITTEST_TCPIP if feature SOCKET is activated
  • APOXI_UNITTEST_NO_MESSAGE if feature DEBUG_INFO is not activated
  • APOXI_UNITTEST_NO_FILENAMES if feature DEBUG_INFO is not activated

Feature dependencies:

  • SOCKET activates the remote TCPIP unit-testing functionality
  • DEBUG_INFO adds unittest extended debug output

#define UUS

User-to-User Signaling (UUS)

Enables User-to-User Signaling in APOXI. Currently only UUS1 implicit is supported.

Activated defines:

  • APOXI_UUS_SUPPORT

#define VIB

Vibrator support

Detailed description

Activated defines:

  • APOXI_VIBRATOR_SUPPORT

Feature dependencies:

  • N/A

#define VOICERECOGNITION

Voice Recognition

Enables the Voice Recognition interface in APOXI. Currently there is no VR support in stack/driver layer, so the APOXI interfaces are not yet thoroughly tested.

#define YAMAHA_MAPI

Yamaha Mapi

The Yamaha MA3 and MA5 chips can be controlled directly through the Yamaha Music API (a set of C-functions wrapping the lower-level Yamaha sound middleware) if you enable this feature.

Activated defines:

  • APOXI_YAMAHA_MAPI_SUPPORT

Feature dependencies:

  • N/A

#define ZI8

Predictive input ZI8

APOXI support for Zi8 predictive input.

Activated defines:

  • APOXI_ZI8_SUPPORT

Generated on Wed Jan 25 02:27:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Currently Undocumented Features (interim section)

Currently Undocumented Features (interim section)
[APOXI Features]

Collaboration diagram for Currently Undocumented Features (interim section):

Defines

#define | AUD_MASTER_VOLUME_CONCEPT

#define | BLUETOOTH
bluetooth
#define | MEDIAFRAMEWORK
mediaframework
#define | MSFS

#define | POWER_SAVING_RELEASE

#define | SER_DATACONN_SUPPORT
serial data connection support
#define | SOCKET
IP socket module
#define | SYNCML
SyncML
#define | USB
USB support

Define Documentation

#define AUD_MASTER_VOLUME_CONCEPT

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define BLUETOOTH

bluetooth

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define MEDIAFRAMEWORK

mediaframework

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define MSFS

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define POWER_SAVING_RELEASE

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define SER_DATACONN_SUPPORT

serial data connection support

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define SOCKET

IP socket module

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define SYNCML

SyncML

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

#define USB

USB support

Detailed description

Activated defines:

  • N/A

Feature dependencies:

  • N/A

Generated on Wed Jan 25 02:27:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Apoxi

Apoxi

Generated on Wed Jan 25 02:27:39 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Asc

Asc

Generated on Wed Jan 25 02:30:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Auxiliary

Auxiliary

Data Structures

class | BinData
class | BitVector< N >
class | BlobObject
class | BlobPtr
class | BufferedData
class | CachingSortProvider
class | CArray< T >
class | ChildBinData
struct | ColumnInfo
class | DataItem
class | DataSink
class | DataSource
class | Date
Date is used to represent a single date. More...
class | DateTime
class | DrmAsset
class | DrmInfo
struct | DrmInfoPersistStructure
class | ElementList< T >
class | ElementListBase
class | EqualsRule
EqualsRule checks whether data item equal to rule item More...
class | FifoLinkedList< T >
class | FilterProvider
class | FilterRule
class | Find2Provider
class | FindProvider
class | GreaterRule
IsGreaterRule checks whether data item is larger than the rule item More...
class | Hashable
class | HashTable
class | HeapArrayObject< T >
class | HeapObject< T >
class | HostDebugTimeStamp
class | HostIniFile
class | Iana
class | IpAddr
class | IpPortNo
class | JapaneseTranscoder
class | LessRule
RangeRule checks whether data item is less than the rule item More...
class | Linkable< T >
class | LinkableBase
class | LinkedList< T >
class | LinkedListBase
class | MemMap
class | MemPool
class | MemPoolEntry
class | MimeTypeTable
User-extendable MIME type registry. More...
struct | MimeTypeTableEntry
MIME type description record. More...
class | NonCloneable
class | NotEqualsRule
NotEqualsRule checks whether data item is not equal to rule item More...
class | ObjectObtainer
class | ObservableObject
class | Observer
class | ObtainableObject
Base class for objects, that can be controled by an ObjectObtainer. More...
class | PhoneNumber
PhoneNumber implements bcd coded phone numbers regarding to GSM 04.08. More...
class | Protector
class | Provider
class | RamData
class | RangeRule
RangeRule checks whether data item is between rule item and rule2item More...
class | ReferableObject
class | SimpleMap< TKey, TValue >
class | SimpleMapElem< TKey, TValue >
class | SingleArgHook< T >
class | SortedElementList< T >
class | SortedLinkedList< T >
class | SortedLinkedListBase
class | SortProvider
struct | StrData
class | Stream
class | StreamingCallback
class | StreamingInfo
class | StreamingReadInfo
class | StreamingWriteInfo
class | StreamReader
class | StreamWriter
class | String
class | SwitchedRleCompression
class | ThreadSafeProvider
class | Time
class | TimeSpan
class | TimeZone
class | TriggerTimer< T >
class | Vector< T >
struct | WStrData
class | WString

Defines

#define | APOXI_ADD_MIME_TYPE_DEFS(class_name, tab_name) const MimeTypeTableEntry class_name##::##tab_name[] =
Adds a MIME type definition record to a MIME type extension table.
#define | APOXI_COUNTOF(array) ( sizeof(array) / sizeof(array[0]) )
Compute number of array elements.
#define | APOXI_DCL_MIME_TYPE_DEFS(tab_name)
Declares a mime type extension.
#define | APOXI_DEF_MIME_TYPE(mime_type, mime_str, is_binary, file_ext_substr_list) { mime_type, is_binary, mime_str, file_ext_substr_list }
#define | APOXI_END_MIME_TYPE_DEFS(class_name, tab_name)
#define | APOXI_MIME_EXT(fileext) fileext "\0"
Constructs a file extension list element from a given string.
#define | APOXI_MIME_STR(mimestr) mimestr "\0"
Constructs a MIME string list element from a given string.
#define | APOXI_PHONENUMBER_TEST_SUITE
#define | APOXI_STRING_TEST_SUITE
#define | APOXI_UNICODE_EOF (WCHAR)0xffff
#define | APOXI_WSTRING_TEST_SUITE
#define | ApoxiMakeCountryCode(a, b) ((((UINT) a) << 8U) | ((UINT) b))
#define | ASSERT(cond) Trap::Assertion(cond, __FILE__, __LINE__);
#define | ASSERT_ALWAYS(cond) Trap::Assertion(cond, __FILE__, __LINE__);
#define | ASSERT_DEBUG(cond)
#define | ASSERT_DEBUG_HOST(cond)
#define | ASSERT_DEBUG_INFO(cond, text)
#define | ASSERT_INFO ASSERT_DEBUG_INFO
#define | DBG_OUT(args)
#define | DBG_OUT_STACK_USAGE()
#define | DefObjectReferrer(Name, RefClass)
#define | DefThreadSafeReferableObject(Name, SemClass)
#define | DRM_KEY_SIZE 16
128 bit key for AES
#define | DRM_RO_DEBUG
#define | LOC(x)
#define | LOC_W(x)
#define | max(a, b) (((a) > (b)) ? (a) : (b))
#define | MAX_COUNT INT_MAX
#define | MAX_DATE UINT_MAX
#define | MAX_INTERVAL UINT_MAX
#define | min(a, b) (((a) < (b)) ? (a) : (b))
#define | MIN_DATE 0
#define | SaveDelete(p) { delete (p); (p) = 0; }
#define | UTF8_COMPUTE(Char, Mask, Len)
#define | UTF8_GET(Result, Chars, Count, Mask, Len)

Typedefs

typedef INT(* | CompareFunction )(void **, void **)
typedef void *(* | CreateFunction )(const void *)
typedef NiSharedPtr< DataSink > | DataSinkPtr
Smart-pointer controlling a DataSink object.
typedef NiSharedPtr< DataSource > | DataSourcePtr
Smart-pointer controlling a DataSource object.
typedef Date::Format | DateFormat
DateFormat type is identical to the Format type inside the time class.
typedef void(* | DeleteFunction )(const void *)
typedef UINT8 | DrmKey [DRM_KEY_SIZE]
typedef INT16 | DrmLocalId
Device local id of rights object. Avoids memory intensive handling of DrmUid.
typedef String | DrmUid
UID according to OMA DRM.
typedef UINT16 | HashKey
typedef INT | MimeType
Defines the type of MIME type identifiers.
typedef INT32 | Number
typedef Time::Format | TimeFormat
TimeFormat type is identical to the Format type inside the time class.

Enumerations

enum ApoxiMimeTypeId {
c_mime_unknown, c_mime_app_j2me_archieve, c_mime_app_j2me_jrs, c_mime_app_mmf,
c_mime_audio_amr, c_mime_audio_imelody, c_mime_audio_midi, c_mime_audio_mpeg,
c_mime_audio_wav, c_mime_drm_ro, c_mime_drm_message, c_mime_drm_textual,
c_mime_drm_encoded, c_mime_drm_content, c_mime_image_bmp, c_mime_image_ems,
c_mime_image_gif, c_mime_image_jpeg, c_mime_image_png, c_mime_image_tiff,
c_mime_image_wbmp, c_mime_text_calendar, c_mime_text_html, c_mime_text_j2me_appdesc,
c_mime_text_plain, c_mime_text_vcard, c_mime_text_wml, c_mime_text_wmlscript,
c_mime_text_xhtml, c_mime_text_xml, c_mime_video_mpeg, c_mime_video_msvideo,
c_mime_video_quicktime, c_mime_video_3gpp, c_mime_audio_3gpp, c_mime_image_svg,
c_mime_image_svgz, c_mime_app_spf, c_mime_apoxi_settings, c_mime_audio_aac,
c_mime_audio_m4a, c_mime_audio_mobile_xmf, c_mime_app_sdp, c_mime_user_offset
}
enum | BCDConversionNibble { DtmfValue = 0xC, WildcardValue = 0xD, ExpansionValue = 0xE }
enum CountryCodes {
CountryAF = ApoxiMakeCountryCode(A,F), CountryAL = ApoxiMakeCountryCode(A,L), CountryDZ = ApoxiMakeCountryCode(D,Z), CountryAS = ApoxiMakeCountryCode(A,S),
CountryAD = ApoxiMakeCountryCode(A,D), CountryAO = ApoxiMakeCountryCode(A,O), CountryAI = ApoxiMakeCountryCode(A,I), CountryAQ = ApoxiMakeCountryCode(A,Q),
CountryAG = ApoxiMakeCountryCode(A,G), CountryAR = ApoxiMakeCountryCode(A,R), CountryAM = ApoxiMakeCountryCode(A,M), CountryAW = ApoxiMakeCountryCode(A,W),
CountryAU = ApoxiMakeCountryCode(A,U), CountryAT = ApoxiMakeCountryCode(A,T), CountryAZ = ApoxiMakeCountryCode(A,Z), CountryBS = ApoxiMakeCountryCode(B,S),
CountryBH = ApoxiMakeCountryCode(B,H), CountryBD = ApoxiMakeCountryCode(B,D), CountryBB = ApoxiMakeCountryCode(B,B), CountryBY = ApoxiMakeCountryCode(B,Y),
CountryBE = ApoxiMakeCountryCode(B,E), CountryBZ = ApoxiMakeCountryCode(B,Z), CountryBJ = ApoxiMakeCountryCode(B,J), CountryBM = ApoxiMakeCountryCode(B,M),
CountryBT = ApoxiMakeCountryCode(B,T), CountryBO = ApoxiMakeCountryCode(B,O), CountryBA = ApoxiMakeCountryCode(B,A), CountryBW = ApoxiMakeCountryCode(B,W),
CountryBV = ApoxiMakeCountryCode(B,V), CountryBR = ApoxiMakeCountryCode(B,R), CountryIO = ApoxiMakeCountryCode(I,O), CountryBN = ApoxiMakeCountryCode(B,N),
CountryBG = ApoxiMakeCountryCode(B,G), CountryBF = ApoxiMakeCountryCode(B,F), CountryBI = ApoxiMakeCountryCode(B,I), CountryKH = ApoxiMakeCountryCode(K,H),
CountryCM = ApoxiMakeCountryCode(C,M), CountryCA = ApoxiMakeCountryCode(C,A), CountryCV = ApoxiMakeCountryCode(C,V), CountryKY = ApoxiMakeCountryCode(K,Y),
CountryCF = ApoxiMakeCountryCode(C,F), CountryTD = ApoxiMakeCountryCode(T,D), CountryCL = ApoxiMakeCountryCode(C,L), CountryCN = ApoxiMakeCountryCode(C,N),
CountryCX = ApoxiMakeCountryCode(C,X), CountryCC = ApoxiMakeCountryCode(C,C), CountryCO = ApoxiMakeCountryCode(C,O), CountryKM = ApoxiMakeCountryCode(K,M),
CountryCG = ApoxiMakeCountryCode(C,G), CountryCK = ApoxiMakeCountryCode(C,K), CountryCR = ApoxiMakeCountryCode(C,R), CountryCI = ApoxiMakeCountryCode(C,I),
CountryHR = ApoxiMakeCountryCode(H,R), CountryCU = ApoxiMakeCountryCode(C,U), CountryCY = ApoxiMakeCountryCode(C,Y), CountryCZ = ApoxiMakeCountryCode(C,Z),
CountryDK = ApoxiMakeCountryCode(D,K), CountryDJ = ApoxiMakeCountryCode(D,J), CountryDM = ApoxiMakeCountryCode(D,M), CountryDO = ApoxiMakeCountryCode(D,O),
CountryTP = ApoxiMakeCountryCode(T,P), CountryEC = ApoxiMakeCountryCode(E,C), CountryEG = ApoxiMakeCountryCode(E,G), CountrySV = ApoxiMakeCountryCode(S,V),
CountryGQ = ApoxiMakeCountryCode(G,Q), CountryER = ApoxiMakeCountryCode(E,R), CountryEE = ApoxiMakeCountryCode(E,E), CountryET = ApoxiMakeCountryCode(E,T),
CountryFK = ApoxiMakeCountryCode(F,K), CountryFO = ApoxiMakeCountryCode(F,O), CountryFJ = ApoxiMakeCountryCode(F,J), CountryFI = ApoxiMakeCountryCode(F,I),
CountryFR = ApoxiMakeCountryCode(F,R), CountryFX = ApoxiMakeCountryCode(F,X), CountryGF = ApoxiMakeCountryCode(G,F), CountryPF = ApoxiMakeCountryCode(P,F),
CountryTF = ApoxiMakeCountryCode(T,F), CountryGA = ApoxiMakeCountryCode(G,A), CountryGM = ApoxiMakeCountryCode(G,M), CountryGE = ApoxiMakeCountryCode(G,E),
CountryDE = ApoxiMakeCountryCode(D,E), CountryGH = ApoxiMakeCountryCode(G,H), CountryGI = ApoxiMakeCountryCode(G,I), CountryGR = ApoxiMakeCountryCode(G,R),
CountryGL = ApoxiMakeCountryCode(G,L), CountryGD = ApoxiMakeCountryCode(G,D), CountryGP = ApoxiMakeCountryCode(G,P), CountryGU = ApoxiMakeCountryCode(G,U),
CountryGT = ApoxiMakeCountryCode(G,T), CountryGN = ApoxiMakeCountryCode(G,N), CountryGW = ApoxiMakeCountryCode(G,W), CountryGY = ApoxiMakeCountryCode(G,Y),
CountryHT = ApoxiMakeCountryCode(H,T), CountryHM = ApoxiMakeCountryCode(H,M), CountryHN = ApoxiMakeCountryCode(H,N), CountryHK = ApoxiMakeCountryCode(H,K),
CountryHU = ApoxiMakeCountryCode(H,U), CountryIS = ApoxiMakeCountryCode(I,S), CountryIN = ApoxiMakeCountryCode(I,N), CountryID = ApoxiMakeCountryCode(I,D),
CountryIR = ApoxiMakeCountryCode(I,R), CountryIQ = ApoxiMakeCountryCode(I,Q), CountryIE = ApoxiMakeCountryCode(I,E), CountryIL = ApoxiMakeCountryCode(I,L),
CountryIT = ApoxiMakeCountryCode(I,T), CountryJM = ApoxiMakeCountryCode(J,M), CountryJP = ApoxiMakeCountryCode(J,P), CountryJO = ApoxiMakeCountryCode(J,O),
CountryKZ = ApoxiMakeCountryCode(K,Z), CountryKE = ApoxiMakeCountryCode(K,E), CountryKI = ApoxiMakeCountryCode(K,I), CountryKP = ApoxiMakeCountryCode(K,P),
CountryKR = ApoxiMakeCountryCode(K,R), CountryKW = ApoxiMakeCountryCode(K,W), CountryKG = ApoxiMakeCountryCode(K,G), CountryLA = ApoxiMakeCountryCode(L,A),
CountryLV = ApoxiMakeCountryCode(L,V), CountryLB = ApoxiMakeCountryCode(L,B), CountryLS = ApoxiMakeCountryCode(L,S), CountryLR = ApoxiMakeCountryCode(L,R),
CountryLY = ApoxiMakeCountryCode(L,Y), CountryLI = ApoxiMakeCountryCode(L,I), CountryLT = ApoxiMakeCountryCode(L,T), CountryLU = ApoxiMakeCountryCode(L,U),
CountryMO = ApoxiMakeCountryCode(M,O), CountryMK = ApoxiMakeCountryCode(M,K), CountryMG = ApoxiMakeCountryCode(M,G), CountryMW = ApoxiMakeCountryCode(M,W),
CountryMY = ApoxiMakeCountryCode(M,Y), CountryMV = ApoxiMakeCountryCode(M,V), CountryML = ApoxiMakeCountryCode(M,L), CountryMT = ApoxiMakeCountryCode(M,T),
CountryMH = ApoxiMakeCountryCode(M,H), CountryMQ = ApoxiMakeCountryCode(M,Q), CountryMR = ApoxiMakeCountryCode(M,R), CountryMU = ApoxiMakeCountryCode(M,U),
CountryYT = ApoxiMakeCountryCode(Y,T), CountryMX = ApoxiMakeCountryCode(M,X), CountryFM = ApoxiMakeCountryCode(F,M), CountryMD = ApoxiMakeCountryCode(M,D),
CountryMC = ApoxiMakeCountryCode(M,C), CountryMN = ApoxiMakeCountryCode(M,N), CountryMS = ApoxiMakeCountryCode(M,S), CountryMA = ApoxiMakeCountryCode(M,A),
CountryMZ = ApoxiMakeCountryCode(M,Z), CountryMM = ApoxiMakeCountryCode(M,M), CountryNA = ApoxiMakeCountryCode(N,A), CountryNR = ApoxiMakeCountryCode(N,R),
CountryNP = ApoxiMakeCountryCode(N,P), CountryNL = ApoxiMakeCountryCode(N,L), CountryAN = ApoxiMakeCountryCode(A,N), CountryNC = ApoxiMakeCountryCode(N,C),
CountryNZ = ApoxiMakeCountryCode(N,Z), CountryNI = ApoxiMakeCountryCode(N,I), CountryNE = ApoxiMakeCountryCode(N,E), CountryNG = ApoxiMakeCountryCode(N,G),
CountryNU = ApoxiMakeCountryCode(N,U), CountryNF = ApoxiMakeCountryCode(N,F), CountryMP = ApoxiMakeCountryCode(M,P), CountryNO = ApoxiMakeCountryCode(N,O),
CountryOM = ApoxiMakeCountryCode(O,M), CountryPK = ApoxiMakeCountryCode(P,K), CountryPW = ApoxiMakeCountryCode(P,W), CountryPA = ApoxiMakeCountryCode(P,A),
CountryPG = ApoxiMakeCountryCode(P,G), CountryPY = ApoxiMakeCountryCode(P,Y), CountryPE = ApoxiMakeCountryCode(P,E), CountryPH = ApoxiMakeCountryCode(P,H),
CountryPN = ApoxiMakeCountryCode(P,N), CountryPL = ApoxiMakeCountryCode(P,L), CountryPT = ApoxiMakeCountryCode(P,T), CountryPR = ApoxiMakeCountryCode(P,R),
CountryQA = ApoxiMakeCountryCode(Q,A), CountryRE = ApoxiMakeCountryCode(R,E), CountryRO = ApoxiMakeCountryCode(R,O), CountryRU = ApoxiMakeCountryCode(R,U),
CountryRW = ApoxiMakeCountryCode(R,W), CountryKN = ApoxiMakeCountryCode(K,N), CountryLC = ApoxiMakeCountryCode(L,C), CountryVC = ApoxiMakeCountryCode(V,C),
CountryWS = ApoxiMakeCountryCode(W,S), CountrySM = ApoxiMakeCountryCode(S,M), CountryST = ApoxiMakeCountryCode(S,T), CountrySA = ApoxiMakeCountryCode(S,A),
CountrySN = ApoxiMakeCountryCode(S,N), CountrySC = ApoxiMakeCountryCode(S,C), CountrySL = ApoxiMakeCountryCode(S,L), CountrySG = ApoxiMakeCountryCode(S,G),
CountrySK = ApoxiMakeCountryCode(S,K), CountrySI = ApoxiMakeCountryCode(S,I), CountrySB = ApoxiMakeCountryCode(S,B), CountrySO = ApoxiMakeCountryCode(S,O),
CountryZA = ApoxiMakeCountryCode(Z,A), CountryGS = ApoxiMakeCountryCode(G,S), CountryES = ApoxiMakeCountryCode(E,S), CountryLK = ApoxiMakeCountryCode(L,K),
CountrySH = ApoxiMakeCountryCode(S,H), CountryPM = ApoxiMakeCountryCode(P,M), CountrySD = ApoxiMakeCountryCode(S,D), CountrySR = ApoxiMakeCountryCode(S,R),
CountrySJ = ApoxiMakeCountryCode(S,J), CountrySZ = ApoxiMakeCountryCode(S,Z), CountrySE = ApoxiMakeCountryCode(S,E), CountryCH = ApoxiMakeCountryCode(C,H),
CountrySY = ApoxiMakeCountryCode(S,Y), CountryTW = ApoxiMakeCountryCode(T,W), CountryTJ = ApoxiMakeCountryCode(T,J), CountryTZ = ApoxiMakeCountryCode(T,Z),
CountryTH = ApoxiMakeCountryCode(T,H), CountryTG = ApoxiMakeCountryCode(T,G), CountryTK = ApoxiMakeCountryCode(T,K), CountryTO = ApoxiMakeCountryCode(T,O),
CountryTT = ApoxiMakeCountryCode(T,T), CountryTN = ApoxiMakeCountryCode(T,N), CountryTR = ApoxiMakeCountryCode(T,R), CountryTM = ApoxiMakeCountryCode(T,M),
CountryTC = ApoxiMakeCountryCode(T,C), CountryTV = ApoxiMakeCountryCode(T,V), CountryUG = ApoxiMakeCountryCode(U,G), CountryUA = ApoxiMakeCountryCode(U,A),
CountryAE = ApoxiMakeCountryCode(A,E), CountryGB = ApoxiMakeCountryCode(G,B), CountryUS = ApoxiMakeCountryCode(U,S), CountryUM = ApoxiMakeCountryCode(U,M),
CountryUY = ApoxiMakeCountryCode(U,Y), CountryUZ = ApoxiMakeCountryCode(U,Z), CountryVU = ApoxiMakeCountryCode(V,U), CountryVA = ApoxiMakeCountryCode(V,A),
CountryVE = ApoxiMakeCountryCode(V,E), CountryVN = ApoxiMakeCountryCode(V,N), CountryVG = ApoxiMakeCountryCode(V,G), CountryVI = ApoxiMakeCountryCode(V,I),
CountryWF = ApoxiMakeCountryCode(W,F), CountryEH = ApoxiMakeCountryCode(E,H), CountryYE = ApoxiMakeCountryCode(Y,E), CountryYU = ApoxiMakeCountryCode(Y,U),
CountryZR = ApoxiMakeCountryCode(Z,R), CountryZM = ApoxiMakeCountryCode(Z,M), CountryZW = ApoxiMakeCountryCode(Z,W), CountryInvalid = ApoxiMakeCountryCode(0,0)
}
enum DataType {
UndefinedType = 0, NumberType = 1, WStringType = 2, StringType = 3,
PhoneNumberType = 4, ProviderType = 5, DateType = 6, TimeType = 7,
DateTimeType = 8, GenericType = 9, BooleanType = 10
}
Allowed types of DataItem DataItem. More...
enum DrmConstraintDefValues {
DrmAllDefault = 0, DrmDatetimeDefault, DrmStartDefault, DrmEndDefault,
DrmNoDefault
}
Used to store kind of constraints for a permission. This enumeration is used internally in DRM. More...
enum DrmMimeType {
DrmNone = 0, DrmForwardLock = 1, DrmCombinedDelivery = 2, DrmDcf = 3,
DrmRoXml = 4, DrmRoWbxml = 5, DrmForwardLockDcf = 6
}
Drm Mime Types. More...
enum DrmOperation {
DrmOpPlay = 0, DrmOpDisplay = 1, DrmOpExecute = 2, DrmOpPrint = 3,
DrmOpRewind = 4, DrmOpCount
}
enum DrmStatus {
DrmSuccess = 0, DrmDefaultConstraints, DrmInvalidOperation = -101, DrmInvalidLocalId,
DrmInvalidAsset, DrmCorruptMessage, DrmInvalidXmlFormat, DrmInvalidContainer,
DrmAesDecryptionFail, DrmNoRightsAvailable, DrmInvalidParams, DrmUnknown
}
Status of the Drm operation. More...
enum WCBType {
WCBTypeL, WCBTypeLRE, WCBTypeLRO, WCBTypeR,
WCBTypeAL, WCBTypeRLE, WCBTypeRLO, WCBTypePDF,
WCBTypeEN, WCBTypeES, WCBTypeET, WCBTypeAN,
WCBTypeCS, WCBTypeNSM, WCBTypeBN, WCBTypeB,
WCBTypeS, WCBTypeWS, WCBTypeON
}
enum WCType {
WCTypeLu, WCTypeLl, WCTypeLt, WCTypeLm,
WCTypeLo, WCTypeMn, WCTypeMc, WCTypeMe,
WCTypeNd, WCTypeNl, WCTypeNo, WCTypePc,
WCTypePd, WCTypePs, WCTypePe, WCTypePi,
WCTypePf, WCTypePo, WCTypeSm, WCTypeSc,
WCTypeSk, WCTypeSo, WCTypeZs, WCTypeZl,
WCTypeZp, WCTypeCc, WCTypeCf, WCTypeCs,
WCTypeCo, WCTypeCn
}

Functions

void | ElementList::Append (T *entry)
Appends a copy of entry to the linked list.
BOOLEAN | ElementList::AppendDistinct (T *entry)
template<class Collection, class Key, class Pred>
INT | BinarySearch (const Collection &arr, const Key &key, const Pred &pred, INT *insert)
template<class Collection, class Key, class Pred>
INT | BinarySearch (const Collection &arr, const Key &key, const Pred &pred)
template<class Collection, class Key, class Pred>
INT | BinarySearch (const Collection &arr, const Key &key)
CHAR | CharToLower (CHAR ch)
CHAR | CharToUpper (CHAR ch)
void | ElementList::Clear ()
Clears the whole list and frees the memory of its elements.
BOOLEAN | DataItemTestSuite ()
ElementList::ElementList (const ElementList< T > &list)
ElementList::ElementList ()
void | Vector::Erase (const Iterator &first, const Iterator &last)
void | Vector::Erase (const Iterator &pos)
BOOLEAN | SimpleMap::Exists (const TKey &key) const
Tells if a key already exists.
BOOLEAN | ElementList::Exists (T *entry) const
Iterator | SimpleMap::GetIterator () const
Returns an iterator for the simple map.
UINT | SimpleMap::GetSize () const
Returns the actual number of key-value pairs.
BOOLEAN | SimpleMap::GetValue (const TKey &key, TValue &value) const
WCHAR * | HexToWStr (UINT8 value, WCHAR *s)
void | TriggerTimer::Init (T *t, UINT32 timeout, BOOLEAN autotimer=FALSE)
void | Vector::Insert (const Iterator &pos, SizeType n, ConstReference x)
void | Vector::Insert (const Iterator &pos, ConstReference x)
void | SortedLinkedList::Insert (T *elem)
void | SortedElementList::Insert (T *entry)
WCHAR * | Int32ToWStr (INT32 value, WCHAR *s)
WCHAR * | IntToWStr (INT value, WCHAR *s)
INT | IsWbDigit (WCHAR c)
INT | IsWdDigit (WCHAR c)
INT | IsWminusSign (WCHAR c)
INT | IsWoDigit (WCHAR c)
INT | IsWplusSign (WCHAR c)
INT | IsWsign (WCHAR c)
INT | IsWwhiteSpace (WCHAR c)
INT | IsWxDigit (WCHAR c)
virtual void | TriggerTimer::OnTimer ()
Vector< T > & | Vector::operator= (const Vector< T > &from)
SortedElementList & | SortedElementList::operator= (const SortedElementList< T > &list)
ElementList & | ElementList::operator= (const ElementList< T > &list)
const TValue & | SimpleMap::operator[] (const TKey &key) const
TValue & | SimpleMap::operator[] (const TKey &key)
void | PhoneNumberTest ()
void | Vector::PopBack ()
void | Vector::PushBack (ConstReference x)
BOOLEAN | SimpleMap::Remove (const TKey &key)
INT | ElementList::Remove (T *entry)
Returns the number of removed (matching) entries.
void | SimpleMap::RemoveAll ()
Removes all entries.
void | Vector::Reserve (SizeType n)
SimpleMap::SimpleMap ()
Constructs a simple map.
SortedElementList::SortedElementList (const SortedElementList< T > &list)
SortedElementList::SortedElementList ()
void | StringTest ()
void | strprintf (CHAR *buffer, INT bufSize, const CHAR *format, va_list args,...)
INT | StrPrintf (CHAR *str, INT strSize, const CHAR *fmt,...)
void | strprintf (CHAR *buffer, const CHAR *format, va_list args,...)
INT | StrPrintf (CHAR *str, const CHAR *fmt,...)
WCHAR * | StrToWStr (WCHAR *dest, const CHAR *src)
TriggerTimer::TriggerTimer (T *t, UINT32 timeout, BOOLEAN autotimer=FALSE)
TriggerTimer::TriggerTimer ()
WCHAR * | UInt32ToWStr (UINT32 value, WCHAR *s)
WCHAR * | UIntToWStr (UINT value, WCHAR *s)
INT | UnicodeFromUtf8 (WCHAR *unicode, const CHAR *utf8)
CHAR * | UnicodeGetUtf8 (const CHAR *p, WCHAR *result)
INT | UnicodeIndexToOffset (const CHAR *src, INT index)
CHAR * | UnicodeLastUtf8 (const CHAR *p)
CHAR * | UnicodeNextUtf8 (const CHAR *p)
INT | UnicodeOffsetToIndex (const CHAR *src, INT offset)
CHAR * | UnicodePreviousUtf8 (const CHAR *start, const CHAR *p)
INT | UnicodePutUtf8 (WCHAR c, CHAR *outbuf)
INT | UnicodeStrcmp (const WCHAR *str1, const WCHAR *str2)
UINT | UnicodeStringWidth (const CHAR *p)
UINT | UnicodeStrlen (const WCHAR *unicode, INT max)
INT | UnicodeStrncmp (const WCHAR *str1, const WCHAR *str2, INT n)
CHAR * | UnicodeStrncpy (CHAR *dest, const CHAR *src, UINT n)
WCHAR * | UnicodeStrstr (const WCHAR *str, const WCHAR *sub)
INT | UnicodeToUtf8 (CHAR *utf8, const WCHAR *unicode)
CHAR * | UnicodeUtf8Strchr (const CHAR *p, WCHAR c)
UINT | UnicodeUtf8Strlen (const CHAR *p, INT max)
INT | UnicodeUtf8Validate (const CHAR *str, INT max_len, const CHAR **end)
template<class T>
void | Unused (const T &t)
INT | Utf8FromUnicode (CHAR *utf8, const WCHAR *unicode)
INT | Utf8ToUnicode (WCHAR *unicode, const CHAR *utf8)
Vector::Vector (SizeType n)
Vector::Vector (SizeType n, ConstReference value)
INT | WbDigitValue (WCHAR c)
WCHAR * | WCharStrToLower (WCHAR *wc)
WCHAR * | WCharStrToUpper (WCHAR *wc)
WCHAR | WCharToLower (WCHAR wc)
WCHAR | WCharToUpper (WCHAR wc)
INT | WdDigitValue (WCHAR c)
WCHAR | WDecompose (WCHAR wc)
BOOLEAN | WIsComposed (WCHAR wc)
BOOLEAN | WIsUnicode (void)
WCHAR | WminusSign (void)
INT | WoDigitValue (WCHAR c)
WCHAR * | WStrCat (WCHAR *dest, const WCHAR *src)
UINT | WStrChr (const WCHAR *s, UINT size, const WCHAR c)
INT | WStrCmp (const WCHAR *s1, const WCHAR *s2)
WCHAR * | WStrCpy (WCHAR *dest, const WCHAR *src)
void | WStringTest ()
UINT | WStrLen (const WCHAR *s)
WCHAR * | WStrnCat (WCHAR *dest, const WCHAR *src, UINT maxlen)
INT | WStrnCmp (const WCHAR *s1, const WCHAR *s2, UINT maxlen)
WCHAR * | WStrnCpy (WCHAR *dest, const WCHAR *src, UINT maxlen)
INT | WStrPrintD (WCHAR *dest, INT value)
void | wstrprintf (WCHAR *buffer, const WCHAR *format, va_list args,...)
void | wstrprintf (WCHAR *buffer, INT maxBufChars, const WCHAR *format, va_list args,...)
INT | WStrPrintf (WCHAR *s, const WCHAR *format,...)
INT | WStrPrintf (WCHAR *s, INT maxStrChars, const WCHAR *format,...)
UINT | WStrrChr (const WCHAR *send, UINT size, const WCHAR c)
UINT | WStrrStr (const WCHAR *s1end, UINT size, const WCHAR *s2)
UINT | WStrrStrn (const WCHAR *s1end, UINT size, const WCHAR *s2, UINT s2size)
INT | wstrscanf (const WCHAR *str, const WCHAR *format, va_list args,...)
INT | WStrScanf (const WCHAR *s, const WCHAR *format,...)
UINT | WStrStr (const WCHAR *s1, UINT size, const WCHAR *s2)
UINT | WStrStrn (const WCHAR *s1, UINT size, const WCHAR *s2, UINT s2size)
INT | WStrToInt (const WCHAR *s)
INT32 | WStrToInt32 (const WCHAR *s)
CHAR * | WStrToStr (CHAR *dest, const WCHAR *src)
WCType | WType (WCHAR wc)
WCHAR | WxDigit (INT digit, INT xstyle)
INT | WxDigitValue (WCHAR c)
INT | WXStrCmp (const WCHAR *s1, const WCHAR *s2, BOOLEAN ignore_case=TRUE, BOOLEAN locale_sensitive=TRUE)
virtual | ElementList::~ElementList ()
virtual | SimpleMap::~SimpleMap ()
Destructs a simple map.
virtual | TriggerTimer::~TriggerTimer ()
Vector::~Vector ()
Destructor.

Variables

const INT | c_append_row = -1
const GenericTypeId | c_blobobject_type = c_apoxi_base_gentypes + 2
const GenericTypeId | c_blobptr_type = c_apoxi_base_gentypes + 1
const INT | c_default_depth = 6
const DrmLocalId | c_drm_invalid_local_id = 0
c_drm_invalid_local_id denotes a illegal local ID of an asset.
const INT | c_invalid_colid = -3
const UINT8 | c_invalid_nibble = 0xFF
const INT | c_max_bcd_number_size = 0x18
const UINT8 | c_max_nibble_range = 0x18
const INT | c_max_telnr_size = (c_max_bcd_number_size - 4) * 2
const INT | c_no_row = -2
const DrmLocalId | DefaultLocalId = APOXI_DRM_RIGHTS_OBJECT_MAX + 1
Default Local Id for Forward Lock.
const INT | string_max_buffer_size = 256
const INT | wstring_max_buffer_size = 256

Define Documentation

#define APOXI_ADD_MIME_TYPE_DEFS | ( | class_name,
 |  | tab_name | ) | const MimeTypeTableEntry class_name##::##tab_name[] =

Adds a MIME type definition record to a MIME type extension table.

Parameters:
class_name | Name of the class with contains the declaration of the MIME type extension.
tab_name | Name of the MIME type extension declaration within the class (argument to APOXI_DCL_MIME_TYPE_DEFS() ).

#define APOXI_COUNTOF ( array ) ( sizeof(array) / sizeof(array[0]) )

Compute number of array elements.

#define APOXI_DCL_MIME_TYPE_DEFS ( tab_name )

Value:

static const MimeTypeTableEntry     tab_name[]; \
    static MimeTypeTable::Partition     tab_name##_part
Declares a mime type extension.

Use this macro to declare a mimetype extension table. The macro must be used in the scope of a class. Any class, whether instantiable or not, is suitable for this purpose as long as it can be insured that the linker does not entirely discard the class.

Usage: class MyClass { public: Whatever you like

private: APOXI_DCL_MIME_TYPE_DEFS(my_mime_types);

Parameters:
tab_name  Name of the member to be used for the MIME type extension.

#define APOXI_DEF_MIME_TYPE | ( | mime_type,
 |  | mime_str,
 |  | is_binary,
 |  | file_ext_substr_list | ) | { mime_type, is_binary, mime_str, file_ext_substr_list }

#define APOXI_END_MIME_TYPE_DEFS | ( | class_name,
 |  | tab_name | )

Value:

; \
    MimeTypeTable::Partition \
        class_name##::##tab_name##_part( class_name##::##tab_name, \
                                         APOXI_COUNTOF(class_name##::##tab_name) );

#define APOXI_MIME_EXT ( fileext ) fileext "\0"

Constructs a file extension list element from a given string.

Use this macro to add a file extension to the file extension list of a MIME type entry. It will add an additional '' to separate the substrings from each other.

#define APOXI_MIME_STR ( mimestr ) mimestr "\0"

Constructs a MIME string list element from a given string.

Use this macro to add a MIME string to the MIME string list of a MIME type entry. It will add an additional '' to separate the substrings from each other.

#define APOXI_PHONENUMBER_TEST_SUITE

#define APOXI_STRING_TEST_SUITE

#define APOXI_UNICODE_EOF (WCHAR)0xffff

#define APOXI_WSTRING_TEST_SUITE

#define ApoxiMakeCountryCode | ( | a,
 |  | b | ) | ((((UINT) a) << 8U) | ((UINT) b))

#define ASSERT ( cond ) Trap::Assertion(cond, __FILE__, __LINE__);

#define ASSERT_ALWAYS ( cond ) Trap::Assertion(cond, __FILE__, __LINE__);

#define ASSERT_DEBUG ( cond )

#define ASSERT_DEBUG_HOST ( cond )

#define ASSERT_DEBUG_INFO | ( | cond,
 |  | text | )

#define ASSERT_INFO ASSERT_DEBUG_INFO

#define DBG_OUT ( args )

#define DBG_OUT_STACK_USAGE ( )

#define DefObjectReferrer | ( | Name,
 |  | RefClass | )

#define DefThreadSafeReferableObject | ( | Name,
 |  | SemClass | )

Value:

class Name : public ReferableObject {       \
        public:                                             \
            typedef ReferableObject Base;       \
                                                            \
            Name(INT refcount = 0) : Base(refcount) {       \
            }                                           \
                                                            \
            virtual INT RefCount() const {                  \
                SemObtainer semob(&SemClass::m_sem);    \
                return Base::RefCount();                    \
            }                                           \
                                                            \
            virtual void AddRef() const {                           \
                SemObtainer semob(&SemClass::m_sem);    \
                Base::AddRef();                             \
            }                                           \
                                                            \
            virtual void Release() const {                      \
                SemObtainer semob(&SemClass::m_sem);    \
                Base::Release();                            \
            }                                           \
    }

#define DRM_KEY_SIZE 16

128 bit key for AES

#define DRM_RO_DEBUG

#define LOC ( x )

#define LOC_W ( x )

#define max | ( | a,
 |  | b | ) | (((a) > (b)) ? (a) : (b))

#define MAX_COUNT INT_MAX

#define MAX_DATE UINT_MAX

#define MAX_INTERVAL UINT_MAX

#define min | ( | a,
 |  | b | ) | (((a) < (b)) ? (a) : (b))

#define MIN_DATE 0

#define SaveDelete ( p ) { delete (p); (p) = 0; }

#define UTF8_COMPUTE | ( | Char,
 |  | Mask,
 |  | Len | )

Value:

if (Char < 128)       { Len = 1;  Mask = 0x7f; }                            \
  else if ((Char & 0xe0) == 0xc0)                                             \
    { Len = 2; Mask = 0x1f; }                                                 \
  else if ((Char & 0xf0) == 0xe0)                                             \
    { Len = 3; Mask = 0x0f; }                                                 \
  else if ((Char & 0xf8) == 0xf0)                                             \
    { Len = 4; Mask = 0x07; }                                                 \
  else if ((Char & 0xfc) == 0xf8)                                             \
    { Len = 5; Mask = 0x03; }                                                 \
  else if ((Char & 0xfe) == 0xfc)                                             \
    { Len = 6; Mask = 0x01; }                                                 \
  else                                                                        \
    Len = -1;

#define UTF8_GET | ( | Result,
 |  | Chars,
 |  | Count,
 |  | Mask,
 |  | Len | )

Value:

(Result) = (Chars)[0] & (Mask);                                             \
  for ((Count) = 1; (Count) < (Len); ++(Count))                               \
    {                                                                         \
      if (((Chars)[(Count)] & 0xc0) != 0x80)                                  \
        {                                                                     \
          (Result) = -1;                                                      \
          break;                                                              \
    }                                                                     \
      (Result) <<= 6;                                                         \
      (Result) |= ((Chars)[(Count)] & 0x3f);                                  \
}

Typedef Documentation

typedef INT(* CompareFunction)(void **, void **)

typedef void*(* CreateFunction)(const void *)

typedef NiSharedPtr<DataSink> DataSinkPtr

Smart-pointer controlling a DataSink object.

typedef NiSharedPtr<DataSource> DataSourcePtr

Smart-pointer controlling a DataSource object.

typedef Date::Format DateFormat

DateFormat type is identical to the Format type inside the time class.

typedef void(* DeleteFunction)(const void *)

typedef UINT8 DrmKey[DRM_KEY_SIZE]

typedef INT16 DrmLocalId

Device local id of rights object. Avoids memory intensive handling of DrmUid.

typedef String DrmUid

UID according to OMA DRM.

typedef UINT16 HashKey

typedef INT MimeType

Defines the type of MIME type identifiers.

Since MimeType identifiers are defined by APOXI and can be defined by application SW too, it is no longer possible to use a single enumeration for this type.

See also:
ApoxiMimeTypeId

typedef INT32 Number

typedef Time::Format TimeFormat

TimeFormat type is identical to the Format type inside the time class.

Enumeration Type Documentation

enum ApoxiMimeTypeId

Enumeration ApoxiMimeTypeId defines the values of the currently supported MIME types as known by APOXI. The MIME types are managed by MimeTypeTable.

Users wishing to add custom MIME type entries should define their own enumeration using c_mime_user_offset as offset to avoid collision with APOXI.

Example: enum CustomMimeTypeId { c_mime_custom_type_1 = c_mime_user_offset, c_mime_custom_type_2 };

Enumerator:
c_mime_unknown | Indicates the MIME type is not known by APOXI.
c_mime_app_j2me_archieve
c_mime_app_j2me_jrs
c_mime_app_mmf
c_mime_audio_amr
c_mime_audio_imelody
c_mime_audio_midi
c_mime_audio_mpeg
c_mime_audio_wav
c_mime_drm_ro
c_mime_drm_message
c_mime_drm_textual
c_mime_drm_encoded
c_mime_drm_content
c_mime_image_bmp
c_mime_image_ems
c_mime_image_gif
c_mime_image_jpeg
c_mime_image_png
c_mime_image_tiff
c_mime_image_wbmp
c_mime_text_calendar
c_mime_text_html
c_mime_text_j2me_appdesc
c_mime_text_plain
c_mime_text_vcard
c_mime_text_wml
c_mime_text_wmlscript
c_mime_text_xhtml
c_mime_text_xml
c_mime_video_mpeg
c_mime_video_msvideo
c_mime_video_quicktime
c_mime_video_3gpp
c_mime_audio_3gpp
c_mime_image_svg
c_mime_image_svgz
c_mime_app_spf
c_mime_apoxi_settings
c_mime_audio_aac
c_mime_audio_m4a
c_mime_audio_mobile_xmf
c_mime_app_sdp
c_mime_user_offset | Intended for use as an offset for project-specific extensions Must be the last entry !

enum BCDConversionNibble

Enumeration types for the digit values which are changeable within the GSM 04.08 standard. Default characters for the DtmfValue are '', for the WildcardValue '?' and for the ExpansionValue '+' .

Enumerator:
DtmfValue
WildcardValue
ExpansionValue

enum CountryCodes

Enumerator:
CountryAF
CountryAL
CountryDZ
CountryAS
CountryAD
CountryAO
CountryAI
CountryAQ
CountryAG
CountryAR
CountryAM
CountryAW
CountryAU
CountryAT
CountryAZ
CountryBS
CountryBH
CountryBD
CountryBB
CountryBY
CountryBE
CountryBZ
CountryBJ
CountryBM
CountryBT
CountryBO
CountryBA
CountryBW
CountryBV
CountryBR
CountryIO
CountryBN
CountryBG
CountryBF
CountryBI
CountryKH
CountryCM
CountryCA
CountryCV
CountryKY
CountryCF
CountryTD
CountryCL
CountryCN
CountryCX
CountryCC
CountryCO
CountryKM
CountryCG
CountryCK
CountryCR
CountryCI
CountryHR
CountryCU
CountryCY
CountryCZ
CountryDK
CountryDJ
CountryDM
CountryDO
CountryTP
CountryEC
CountryEG
CountrySV
CountryGQ
CountryER
CountryEE
CountryET
CountryFK
CountryFO
CountryFJ
CountryFI
CountryFR
CountryFX
CountryGF
CountryPF
CountryTF
CountryGA
CountryGM
CountryGE
CountryDE
CountryGH
CountryGI
CountryGR
CountryGL
CountryGD
CountryGP
CountryGU
CountryGT
CountryGN
CountryGW
CountryGY
CountryHT
CountryHM
CountryHN
CountryHK
CountryHU
CountryIS
CountryIN
CountryID
CountryIR
CountryIQ
CountryIE
CountryIL
CountryIT
CountryJM
CountryJP
CountryJO
CountryKZ
CountryKE
CountryKI
CountryKP
CountryKR
CountryKW
CountryKG
CountryLA
CountryLV
CountryLB
CountryLS
CountryLR
CountryLY
CountryLI
CountryLT
CountryLU
CountryMO
CountryMK
CountryMG
CountryMW
CountryMY
CountryMV
CountryML
CountryMT
CountryMH
CountryMQ
CountryMR
CountryMU
CountryYT
CountryMX
CountryFM
CountryMD
CountryMC
CountryMN
CountryMS
CountryMA
CountryMZ
CountryMM
CountryNA
CountryNR
CountryNP
CountryNL
CountryAN
CountryNC
CountryNZ
CountryNI
CountryNE
CountryNG
CountryNU
CountryNF
CountryMP
CountryNO
CountryOM
CountryPK
CountryPW
CountryPA
CountryPG
CountryPY
CountryPE
CountryPH
CountryPN
CountryPL
CountryPT
CountryPR
CountryQA
CountryRE
CountryRO
CountryRU
CountryRW
CountryKN
CountryLC
CountryVC
CountryWS
CountrySM
CountryST
CountrySA
CountrySN
CountrySC
CountrySL
CountrySG
CountrySK
CountrySI
CountrySB
CountrySO
CountryZA
CountryGS
CountryES
CountryLK
CountrySH
CountryPM
CountrySD
CountrySR
CountrySJ
CountrySZ
CountrySE
CountryCH
CountrySY
CountryTW
CountryTJ
CountryTZ
CountryTH
CountryTG
CountryTK
CountryTO
CountryTT
CountryTN
CountryTR
CountryTM
CountryTC
CountryTV
CountryUG
CountryUA
CountryAE
CountryGB
CountryUS
CountryUM
CountryUY
CountryUZ
CountryVU
CountryVA
CountryVE
CountryVN
CountryVG
CountryVI
CountryWF
CountryEH
CountryYE
CountryYU
CountryZR
CountryZM
CountryZW
CountryInvalid

enum DataType

Allowed types of DataItem DataItem.

Enumerator:
UndefinedType | Dataitem contains no data.
NumberType | Dataitem contains a 32 bit signed Integer.
WStringType | Dataitem contains a WString object.
StringType | Dataitem contains a String object.
PhoneNumberType | Dataitem contains a PhoneNumber object.
ProviderType | Dataitem contains a pointer to a Provider object.
DateType | Dataitem contains a Date object.
TimeType | Dataitem contains a Time object.
DateTimeType | Dataitem contains a DateTime object.
GenericType | Dataitem contains a Generic object.
BooleanType | Dataitem contains a Boolean value.

enum DrmConstraintDefValues

Used to store kind of constraints for a permission. This enumeration is used internally in DRM.

Enumerator:
DrmAllDefault | to indicate no constraints in Rights XML
DrmDatetimeDefault | to indicate empty datetime tag in Rights XML
DrmStartDefault | to indicate no start tag for datetime in Rights XML
DrmEndDefault | to indicate no end tag for datetime in Rights XML
DrmNoDefault

enum DrmMimeType

Drm Mime Types.

Enumerator:
DrmNone | DrmNone is moved to top, this is done as part of fix for sms00048467.
DrmForwardLock | DRM Forward Lock.
DrmCombinedDelivery | DRM Combined Delivery.
DrmDcf | DRM Dcf for SD.
DrmRoXml | DRM Rights Object XML.
DrmRoWbxml | DRM Rights Object WBXML.
DrmForwardLockDcf | DCF object forward locked.

enum DrmOperation

DrmOperation enumerates operations defined by OMA DRM

Note : Rewind is not defined by DRM Rights object for v1.0, but by DRM configuration (Operator specifics)

Enumerator:
DrmOpPlay | DRM Play operation / permission.
DrmOpDisplay | DRM Display operation / permission.
DrmOpExecute | DRM Execute operation / permission.
DrmOpPrint | DRM Print operation / permission.
DrmOpRewind | DRM Rewind operation / permission.
DrmOpCount

enum DrmStatus

Status of the Drm operation.

Enumerator:
DrmSuccess
DrmDefaultConstraints
DrmInvalidOperation
DrmInvalidLocalId
DrmInvalidAsset
DrmCorruptMessage
DrmInvalidXmlFormat
DrmInvalidContainer
DrmAesDecryptionFail
DrmNoRightsAvailable
DrmInvalidParams
DrmUnknown

enum WCBType

Enumerator:
WCBTypeL
WCBTypeLRE
WCBTypeLRO
WCBTypeR
WCBTypeAL
WCBTypeRLE
WCBTypeRLO
WCBTypePDF
WCBTypeEN
WCBTypeES
WCBTypeET
WCBTypeAN
WCBTypeCS
WCBTypeNSM
WCBTypeBN
WCBTypeB
WCBTypeS
WCBTypeWS
WCBTypeON

enum WCType

Enumerator:
WCTypeLu
WCTypeLl
WCTypeLt
WCTypeLm
WCTypeLo
WCTypeMn
WCTypeMc
WCTypeMe
WCTypeNd
WCTypeNl
WCTypeNo
WCTypePc
WCTypePd
WCTypePs
WCTypePe
WCTypePi
WCTypePf
WCTypePo
WCTypeSm
WCTypeSc
WCTypeSk
WCTypeSo
WCTypeZs
WCTypeZl
WCTypeZp
WCTypeCc
WCTypeCf
WCTypeCs
WCTypeCo
WCTypeCn

Function Documentation

template<class T>
void ElementList< T >::Append ( T * entry ) [inherited]

Appends a copy of entry to the linked list.

template<class T>
BOOLEAN ElementList< T >::AppendDistinct ( T * entry ) [inherited]

template<class Collection, class Key, class Pred>
INT BinarySearch | ( | const Collection & | arr,
 |  | const Key & | key,
 |  | const Pred & | pred,
 |  | INT * | insert
 | ) | [inline]

template<class Collection, class Key, class Pred>
INT BinarySearch | ( | const Collection & | arr,
 |  | const Key & | key,
 |  | const Pred & | pred
 | ) | [inline]

template<class Collection, class Key, class Pred>
INT BinarySearch | ( | const Collection & | arr,
 |  | const Key & | key
 | ) | [inline]

CHAR CharToLower ( CHAR ch ) [inline]

CHAR CharToUpper ( CHAR ch ) [inline]

template<class T>
void ElementList< T >::Clear ( ) [inherited]

Clears the whole list and frees the memory of its elements.

BOOLEAN DataItemTestSuite ( )

template<class T>
ElementList< T >::ElementList ( const ElementList< T > & list ) [inherited]

template<class T>
ElementList< T >::ElementList ( ) [inherited]

template<typename T>
void Vector< T >::Erase | ( | const Iterator & | first,
 |  | const Iterator & | last
 | ) | [inherited]

template<typename T>
void Vector< T >::Erase ( const Iterator & pos ) [inherited]

template<class TKey, class TValue>
BOOLEAN SimpleMap< TKey, TValue >::Exists ( const TKey & key ) const [inherited]

Tells if a key already exists.

template<class T>
BOOLEAN ElementList< T >::Exists ( T * entry ) const [inherited]

template<class TKey, class TValue>
SimpleMap< TKey, TValue >::Iterator SimpleMap< TKey, TValue >::GetIterator ( ) const [inherited]

Returns an iterator for the simple map.

template<class TKey, class TValue>
UINT SimpleMap< TKey, TValue >::GetSize ( ) const [inherited]

Returns the actual number of key-value pairs.

template<class TKey, class TValue>
BOOLEAN SimpleMap< TKey, TValue >::GetValue | ( | const TKey & | key,
 |  | TValue & | value
 | ) | const [inherited]

Gets the value for the passed key. If the key does not exist then simply FALSE is returned, else TRUE. The difference to getting a value for a key using the non-const subscript operator is, that if the key does not exist, a default initialized pair would be added to the map. Method GetValue() does not change the map data at all. Calling this method also affects method Ok(). The return value of this method and the return value of a subsequent call to Ok() are the same.

WCHAR* HexToWStr | ( | UINT8 | value,
 |  | WCHAR * | s
 | ) |

template<class T>
void TriggerTimer< T >::Init | ( | T * | t,
 |  | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) | [inherited]

template<typename T>
void Vector< T >::Insert | ( | const Iterator & | pos,
 |  | SizeType | n,
 |  | ConstReference | x
 | ) | [inherited]

template<typename T>
void Vector< T >::Insert | ( | const Iterator & | pos,
 |  | ConstReference | x
 | ) | [inherited]

template<class T>
void SortedLinkedList< T >::Insert ( T * elem ) [inherited]

template<class T>
void SortedElementList< T >::Insert ( T * entry ) [inherited]

WCHAR* Int32ToWStr | ( | INT32 | value,
 |  | WCHAR * | s
 | ) |

WCHAR* IntToWStr | ( | INT | value,
 |  | WCHAR * | s
 | ) |

INT IsWbDigit ( WCHAR c )

INT IsWdDigit ( WCHAR c )

INT IsWminusSign ( WCHAR c )

INT IsWoDigit ( WCHAR c )

INT IsWplusSign ( WCHAR c )

INT IsWsign ( WCHAR c )

INT IsWwhiteSpace ( WCHAR c )

INT IsWxDigit ( WCHAR c )

template<class T>
void TriggerTimer< T >::OnTimer ( ) [protected, virtual, inherited]

Is called, if the timout-value of the timer expired. In the default implementation of this method the message TimerTimeoutMsg is sent.

Reimplemented from Timer.

template<typename T>
Vector< T > & Vector< T >::operator= ( const Vector< T > & from ) [inherited]

template<class T>
SortedElementList< T > & SortedElementList< T >::operator= ( const SortedElementList< T > & list ) [inherited]

template<class T>
ElementList< T > & ElementList< T >::operator= ( const ElementList< T > & list ) [inherited]

template<class TKey, class TValue>
const TValue & SimpleMap< TKey, TValue >::operator[] ( const TKey & key ) const [inherited]

The const subscript operator accesses the value for key. If the key does not exist yet, an internal error flag is set which can be checked using method Ok().

template<class TKey, class TValue>
TValue & SimpleMap< TKey, TValue >::operator[] ( const TKey & key ) [inherited]

The non-const subscript operator accesses the value for key. If the key does not exist yet, a default initialized entry with that key is first created and then returned. If an out of memory error occurs, an internal error flag is set which can be checked using method Ok().

void PhoneNumberTest ( )

template<typename T>
void Vector< T >::PopBack ( ) [inherited]

template<typename T>
void Vector< T >::PushBack ( ConstReference x ) [inherited]

template<class TKey, class TValue>
BOOLEAN SimpleMap< TKey, TValue >::Remove ( const TKey & key ) [inherited]

Removes the entry at key and tells if the removal was successful. The removal fails if key is not part of the map.

template<class T>
INT ElementList< T >::Remove ( T * entry ) [inherited]

Returns the number of removed (matching) entries.

template<class TKey, class TValue>
void SimpleMap< TKey, TValue >::RemoveAll ( ) [inherited]

Removes all entries.

template<typename T>
void Vector< T >::Reserve ( SizeType n ) [inherited]

template<class TKey, class TValue>
SimpleMap< TKey, TValue >::SimpleMap ( ) [inherited]

Constructs a simple map.

template<class T>
SortedElementList< T >::SortedElementList ( const SortedElementList< T > & list ) [inherited]

template<class T>
SortedElementList< T >::SortedElementList ( ) [inherited]

void StringTest ( )

void strprintf | ( | CHAR * | buffer,
 |  | INT | bufSize,
 |  | const CHAR * | format,
 |  | va_list | args,
 |  |  | ...
 | ) |

INT StrPrintf | ( | CHAR * | str,
 |  | INT | strSize,
 |  | const CHAR * | fmt,
 |  |  | ...
 | ) |

void strprintf | ( | CHAR * | buffer,
 |  | const CHAR * | format,
 |  | va_list | args,
 |  |  | ...
 | ) |

INT StrPrintf | ( | CHAR * | str,
 |  | const CHAR * | fmt,
 |  |  | ...
 | ) |

WCHAR* StrToWStr | ( | WCHAR * | dest,
 |  | const CHAR * | src
 | ) |

template<class T>
TriggerTimer< T >::TriggerTimer | ( | T * | t,
 |  | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) | [inherited]

template<class T>
TriggerTimer< T >::TriggerTimer ( ) [inherited]

WCHAR* UInt32ToWStr | ( | UINT32 | value,
 |  | WCHAR * | s
 | ) |

WCHAR* UIntToWStr | ( | UINT | value,
 |  | WCHAR * | s
 | ) |

INT UnicodeFromUtf8 | ( | WCHAR * | unicode,
 |  | const CHAR * | utf8
 | ) |

CHAR* UnicodeGetUtf8 | ( | const CHAR * | p,
 |  | WCHAR * | result
 | ) |

INT UnicodeIndexToOffset | ( | const CHAR * | src,
 |  | INT | index
 | ) |

CHAR* UnicodeLastUtf8 ( const CHAR * p )

CHAR* UnicodeNextUtf8 ( const CHAR * p )

INT UnicodeOffsetToIndex | ( | const CHAR * | src,
 |  | INT | offset
 | ) |

CHAR* UnicodePreviousUtf8 | ( | const CHAR * | start,
 |  | const CHAR * | p
 | ) |

INT UnicodePutUtf8 | ( | WCHAR | c,
 |  | CHAR * | outbuf
 | ) |

INT UnicodeStrcmp | ( | const WCHAR * | str1,
 |  | const WCHAR * | str2
 | ) |

UINT UnicodeStringWidth ( const CHAR * p )

UINT UnicodeStrlen | ( | const WCHAR * | unicode,
 |  | INT | max
 | ) |

INT UnicodeStrncmp | ( | const WCHAR * | str1,
 |  | const WCHAR * | str2,
 |  | INT | n
 | ) |

CHAR* UnicodeStrncpy | ( | CHAR * | dest,
 |  | const CHAR * | src,
 |  | UINT | n
 | ) |

WCHAR* UnicodeStrstr | ( | const WCHAR * | str,
 |  | const WCHAR * | sub
 | ) |

INT UnicodeToUtf8 | ( | CHAR * | utf8,
 |  | const WCHAR * | unicode
 | ) |

CHAR* UnicodeUtf8Strchr | ( | const CHAR * | p,
 |  | WCHAR | c
 | ) |

UINT UnicodeUtf8Strlen | ( | const CHAR * | p,
 |  | INT | max
 | ) |

INT UnicodeUtf8Validate | ( | const CHAR * | str,
 |  | INT | max_len,
 |  | const CHAR ** | end
 | ) |

template<class T>
void Unused ( const T & t ) [inline]

INT Utf8FromUnicode | ( | CHAR * | utf8,
 |  | const WCHAR * | unicode
 | ) |

INT Utf8ToUnicode | ( | WCHAR * | unicode,
 |  | const CHAR * | utf8
 | ) |

template<typename T>
Vector< T >::Vector ( SizeType n ) [inherited]

Constructor.

Parameters:
n n elements initialized with T() will be pre-allocated in vector.

template<typename T>
Vector< T >::Vector | ( | SizeType | n,
 |  | ConstReference | value
 | ) | [inherited]

Constructor.

Parameters:
n | n elements will be pre-allocated in vector.
value | Pre-allocated elements will be initialized to value.

INT WbDigitValue ( WCHAR c )

WCHAR* WCharStrToLower ( WCHAR * wc )

WCHAR* WCharStrToUpper ( WCHAR * wc )

WCHAR WCharToLower ( WCHAR wc )

WCHAR WCharToUpper ( WCHAR wc )

INT WdDigitValue ( WCHAR c )

WCHAR WDecompose ( WCHAR wc )

BOOLEAN WIsComposed ( WCHAR wc )

BOOLEAN WIsUnicode ( void )

WCHAR WminusSign ( void )

INT WoDigitValue ( WCHAR c )

WCHAR* WStrCat | ( | WCHAR * | dest,
 |  | const WCHAR * | src
 | ) |

UINT WStrChr | ( | const WCHAR * | s,
 |  | UINT | size,
 |  | const WCHAR | c
 | ) |

INT WStrCmp | ( | const WCHAR * | s1,
 |  | const WCHAR * | s2
 | ) |

WCHAR* WStrCpy | ( | WCHAR * | dest,
 |  | const WCHAR * | src
 | ) |

void WStringTest ( )

UINT WStrLen ( const WCHAR * s )

WCHAR* WStrnCat | ( | WCHAR * | dest,
 |  | const WCHAR * | src,
 |  | UINT | maxlen
 | ) |

INT WStrnCmp | ( | const WCHAR * | s1,
 |  | const WCHAR * | s2,
 |  | UINT | maxlen
 | ) |

WCHAR* WStrnCpy | ( | WCHAR * | dest,
 |  | const WCHAR * | src,
 |  | UINT | maxlen
 | ) |

INT WStrPrintD | ( | WCHAR * | dest,
 |  | INT | value
 | ) |

void wstrprintf | ( | WCHAR * | buffer,
 |  | const WCHAR * | format,
 |  | va_list | args,
 |  |  | ...
 | ) |

void wstrprintf | ( | WCHAR * | buffer,
 |  | INT | maxBufChars,
 |  | const WCHAR * | format,
 |  | va_list | args,
 |  |  | ...
 | ) |

INT WStrPrintf | ( | WCHAR * | s,
 |  | const WCHAR * | format,
 |  |  | ...
 | ) |

INT WStrPrintf | ( | WCHAR * | s,
 |  | INT | maxStrChars,
 |  | const WCHAR * | format,
 |  |  | ...
 | ) |

UINT WStrrChr | ( | const WCHAR * | send,
 |  | UINT | size,
 |  | const WCHAR | c
 | ) |

UINT WStrrStr | ( | const WCHAR * | s1end,
 |  | UINT | size,
 |  | const WCHAR * | s2
 | ) |

UINT WStrrStrn | ( | const WCHAR * | s1end,
 |  | UINT | size,
 |  | const WCHAR * | s2,
 |  | UINT | s2size
 | ) |

INT wstrscanf | ( | const WCHAR * | str,
 |  | const WCHAR * | format,
 |  | va_list | args,
 |  |  | ...
 | ) |

INT WStrScanf | ( | const WCHAR * | s,
 |  | const WCHAR * | format,
 |  |  | ...
 | ) |

UINT WStrStr | ( | const WCHAR * | s1,
 |  | UINT | size,
 |  | const WCHAR * | s2
 | ) |

UINT WStrStrn | ( | const WCHAR * | s1,
 |  | UINT | size,
 |  | const WCHAR * | s2,
 |  | UINT | s2size
 | ) |

INT WStrToInt ( const WCHAR * s )

INT32 WStrToInt32 ( const WCHAR * s )

CHAR* WStrToStr | ( | CHAR * | dest,
 |  | const WCHAR * | src
 | ) |

WCType WType ( WCHAR wc )

WCHAR WxDigit | ( | INT | digit,
 |  | INT | xstyle
 | ) |

INT WxDigitValue ( WCHAR c )

INT WXStrCmp | ( | const WCHAR * | s1,
 |  | const WCHAR * | s2,
 |  | BOOLEAN | ignore_case = TRUE,
 |  | BOOLEAN | locale_sensitive = TRUE
 | ) |

template<class T>
ElementList< T >::~ElementList ( ) [virtual, inherited]

template<class TKey, class TValue>
SimpleMap< TKey, TValue >::~SimpleMap ( ) [virtual, inherited]

Destructs a simple map.

template<class T>
TriggerTimer< T >::~TriggerTimer ( ) [virtual, inherited]

template<typename T>
Vector< T >::~Vector ( ) [inherited]

Destructor.

Variable Documentation

const INT c_append_row = -1

const GenericTypeId c_blobobject_type = c_apoxi_base_gentypes + 2

const GenericTypeId c_blobptr_type = c_apoxi_base_gentypes + 1

const INT c_default_depth = 6

const DrmLocalId c_drm_invalid_local_id = 0

c_drm_invalid_local_id denotes a illegal local ID of an asset.

const INT c_invalid_colid = -3

const UINT8 c_invalid_nibble = 0xFF

const INT c_max_bcd_number_size = 0x18

const UINT8 c_max_nibble_range = 0x18

const INT c_max_telnr_size = (c_max_bcd_number_size - 4) * 2

const INT c_no_row = -2

const DrmLocalId DefaultLocalId = APOXI_DRM_RIGHTS_OBJECT_MAX + 1

Default Local Id for Forward Lock.

const INT string_max_buffer_size = 256

Size for the format buffer in the methods "String::Format(const WCHAR * format,...)" and "String::VFormat(const WCHAR * format, va_list args)"em>String implements string handling which consists of single byte characters (CHAR) terminated by a zero character. A String object itself contains a pointer to the character array. When manipulating and copying the string object the character array is also allocated and copied.

const INT wstring_max_buffer_size = 256

Size for the format buffer in the methods "WString::Format(const WCHAR * format,...)" and "WString::VFormat(const WCHAR * format, va_list args)"em>WString implements string handling which consists of wide characters (WCHAR) terminated by a zero ch. A WString object itself contains a pointer to the wide ch array. When manipulating and copying the WString object the ch array is also allocated and copied.

Generated on Wed Jan 25 02:28:43 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Bluetooth

Bluetooth

Data Structures

struct | BtAttributeId
class | BtAudioAccessoryService
class | BtAvrcpConnectResponse
class | BtAvrcpDeRegisterRequest
class | BtAvrcpNotificationMessage
class | BtAvrcpOperationRequestResponse
class | BtAvrcpOperationService
class | BtAvrcpOperationServiceMessage
class | BtAvrcpPanelPassThroughParams
class | BtAvrcpPanelPassThroughRequest
class | BtAvrcpRawFrameParams
class | BtAvrcpRawFrameRequest
class | BtAvrcpRegisterParams
class | BtAvrcpRegisterRequest
class | BtAvrcpRegistrationService
class | BtAvrcpRequest
class | BtAvrcpService
struct | BtAvrcpSubunitInfoEntry
class | BtAvrcpSubunitInfoParams
class | BtAvrcpSubunitInfoRequest
class | BtAvrcpUnitInfoParams
class | BtAvrcpUnitInfoRequest
class | BtBipAttachment
An attachment. More...
class | BtBipAttachmentDesc
Attachment descriptor. More...
class | BtBipAttachmentFormat
Format of an attachment. More...
class | BtBipClientService
class | BtBipImage
An image. More...
class | BtBipImageDesc
Image Desc. More...
class | BtBipImageFormat
Image format. More...
class | BtBipImageHdl
class | BtBipImageHdlDesc
Image Handle Desc. More...
class | BtBipImageList
List of images. More...
class | BtBipImageProperties
Image properties. More...
class | BtBipImagingCapabilities
Imaging Capabilities. More...
class | BtBipServerService
BIP Server Service (imaging responder). More...
class | BtBppClientService
class | BtBppController
class | BtBppReq
class | BtBppServerService
class | BtBppService
Base class for BIP service classes. More...
class | BtBppSndAbortReqRequest
class | BtBppSndFilePushReqRequest
class | BtBppSndGetRefObjRspRequest
class | BtCancelableBroadcastRequest
class | BtCancelableMulticastRequest
class | BtCancelableRequest
struct | BtChipBmscr
struct | BtChipBmu
union | BtChipVersion
class | BtConnectionBasedController
class | BtConnectionlessController
class | BtConnectRequest
class | BtController
class | BtDevice
class | BtDeviceAddress
class | BtDeviceAndServiceClass
class | BtDeviceFilter
class | BtDeviceList
class | BtDeviceListConstantIterator
class | BtDeviceListConstantReverseIterator
class | BtDeviceListIterator
class | BtDeviceListReverseIterator
class | BtDevicePairRequest
class | BtDeviceSearchRequest
class | BtDeviceTrustRequest
class | BtDeviceUnpairRequest
class | BtDeviceUntrustRequest
class | BtDisconnectRequest
class | BtDunAppPlugin
class | BtDunService
class | BtEvent
class | BtFaxAppPlugin
class | BtFaxService
class | BtHfNotificationMessage
class | BtHfService
class | BtHsAppPlugin
class | BtHsNotificationMessage
class | BtHsService
class | BtJsr82Url
class | BtLocalRequest
class | BtLocalSettings
class | BtMultiConnectionController
class | BtObexAbortRequest
class | BtObexClientAbortEvent
class | BtObexClientConnectEvent
class | BtObexClientDisconnectEvent
class | BtObexClientEvent
class | BtObexClientGetEvent
class | BtObexClientNotificationMessage
class | BtObexClientOperationEvent
class | BtObexClientOperationRequest
class | BtObexClientPutEvent
class | BtObexClientService
class | BtObexClientServiceObserver
class | BtObexClientSetPathEvent
class | BtObexConnectRequest
class | BtObexController
class | BtObexDataBufferIndicationEvent
class | BtObexDataIndicationEvent
class | BtObexDisconnectRequest
class | BtObexEvent
class | BtObexGetRequest
struct | BtObexHeader
class | BtObexHeaderIndicationEvent
class | BtObexHeaderSentEvent
class | BtObexPutRequest
class | BtObexRegisterClientEvent
class | BtObexRegisterClientRequest
class | BtObexRegisterServerEvent
class | BtObexRegisterServerRequest
class | BtObexRequest
class | BtObexServerAbortIndicationEvent
class | BtObexServerConnectIndicationEvent
class | BtObexServerDisconnectIndicationEvent
class | BtObexServerEvent
class | BtObexServerGetIndicationEvent
class | BtObexServerNotificationMessage
class | BtObexServerPutIndicationEvent
class | BtObexServerService
class | BtObexServerServiceObserver
class | BtObexServerSetPathIndicationEvent
class | BtObexService
class | BtObexServiceObserver
class | BtObexServiceTable
class | BtObexSetPathRequest
class | BtObexSubSystem
class | BtObexTransport
class | BtObexTransportDisconnectEvent
class | BtObexUnregisterClientRequest
class | BtObexUnregisterEvent
class | BtObexUnregisterServerRequest
class | BtObservableService
class | BtOperationBase
class | BtOperationSelectDevice
class | BtOperationSelectDeviceAndPerformServiceVerify
class | BtQuerySupportedProfilesRequest
class | BtRequest
class | BtRequestRespondRequest
class | BtRespondAuthorizationRequest
class | BtSddbDataElement
class | BtSddbDataElementFactory
class | BtSddbDeAlternative
class | BtSddbDeBaseCType
class | BtSddbDeBigSintBase
class | BtSddbDeBigUintBase
class | BtSddbDeBoolean
class | BtSddbDeByteBlockType
class | BtSddbDeContainer
class | BtSddbDeNil
class | BtSddbDeOneByteDescriptionType
class | BtSddbDeSequence
class | BtSddbDeSint128
class | BtSddbDeSint16
class | BtSddbDeSint32
class | BtSddbDeSint64
class | BtSddbDeSint8
class | BtSddbDeSintBase
class | BtSddbDeString
class | BtSddbDeUint128
class | BtSddbDeUint16
class | BtSddbDeUint32
class | BtSddbDeUint64
class | BtSddbDeUint8
class | BtSddbDeUintBase
class | BtSddbDeUrl
class | BtSddbDeUuid128
class | BtSddbDeUuid16
class | BtSddbDeUuid32
class | BtSddbDeUuidBase
class | BtSddbDeVariableLengthType
class | BtSddbEvent
class | BtSddbRegisterServiceEvent
class | BtSddbService
class | BtSddbServiceAttribute
class | BtSddbServiceObserver
class | BtSddbServiceRecord
class | BtSddbUnregisterServiceEvent
class | BtSendPasskeyRequest
class | BtService
class | BtServiceObserver
class | BtServiceRequest
class | BtServiceVerifyRequest
class | BtServiceVerifyResult
class | BtSetRemoteDeviceNameRequest
class | BtSingleConnectionController
class | BtSvrDataElement
class | BtSvrServiceAttribute
class | BtSvrServiceRecord
class | BtTransport
class | BtUncancelablePointToPointRequest
class | BtUncancelableRequest
struct | BtUUID
class | StringDataSink

Defines

#define | APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY BtSesNoSecurity
Default APOXI Bluetooth OBEX client security settings.
#define | APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY BtSesAuthorization
Default APOXI Bluetooth OBEX server security settings.
#define | BIP_IMG_HDL_SIZE 8
#define | BT_AA_INVALID_VOLUME_LEVEL 0xFF
#define | BT_MDC_AUDIO_VIDEO 0x04
#define | BT_MDC_COMPUTER 0x01
#define | BT_MDC_IMAGING 0x06
#define | BT_MDC_LAN 0x03
#define | BT_MDC_MASK 0x1F
#define | BT_MDC_PERIPHERAL 0x05
#define | BT_MDC_PHONE 0x02
#define | BT_MDC_SHIFT 8
#define | BT_MDC_UNCATEGORIZED 0x1F
#define | BT_MSC_AUDIO 0x100
#define | BT_MSC_CAPTURING 0x040
#define | BT_MSC_INFORMATION 0x400
#define | BT_MSC_MASK 0x7FF
#define | BT_MSC_NETWORK 0x010
#define | BT_MSC_OBJECT_TRANSFER 0x080
#define | BT_MSC_POSITIONING 0x008
#define | BT_MSC_RENDERING 0x020
#define | BT_MSC_SHIFT 13
#define | BT_MSC_TELEPHONY 0x200
#define | BT_SDC_01_TO_17_UTILIZED 0x08
#define | BT_SDC_17_TO_33_UTILIZED 0x10
#define | BT_SDC_33_TO_50_UTILIZED 0x18
#define | BT_SDC_50_TO_67_UTILIZED 0x20
#define | BT_SDC_67_TO_83_UTILIZED 0x28
#define | BT_SDC_83_TO_99_UTILIZED 0x30
#define | BT_SDC_CAMCORDER 0x0D
#define | BT_SDC_CAMERA 0x08
#define | BT_SDC_CAR_AUDIO 0x08
#define | BT_SDC_CARD_READER 0x18
#define | BT_SDC_CELLULAR 0x01
#define | BT_SDC_COMBO_KEYBOARD_POINTING_DEVICE 0x03
#define | BT_SDC_COMMON_ISDN_ACCESS 0x05
#define | BT_SDC_CORDLESS 0x02
#define | BT_SDC_DESKTOP_WORKSTATION 0x01
#define | BT_SDC_DIGITIZER_TABLET 0x14
#define | BT_SDC_DISPLAY 0x04
#define | BT_SDC_GAMEPAD 0x08
#define | BT_SDC_GAMING_TOY 0x12
#define | BT_SDC_HAEDPHONES 0x06
#define | BT_SDC_HANDHELD_PC_PDA 0x04
#define | BT_SDC_HANDS_FREE 0x02
#define | BT_SDC_HEADSET 0x01
#define | BT_SDC_HIFI_AUDIO 0x0A
#define | BT_SDC_JOYSTICK 0x04
#define | BT_SDC_KEYBOARD 0x01
#define | BT_SDC_LAPTOP 0x03
#define | BT_SDC_LOUDSPEAKER 0x05
#define | BT_SDC_MASK 0x3F
#define | BT_SDC_MICROPHONE 0x04
#define | BT_SDC_NO_SERVICE 0x38
#define | BT_SDC_PALM_SIZED_PS_PDA 0x05
#define | BT_SDC_POINTING_DEVICE 0x02
#define | BT_SDC_PORTABLE_AUDIO 0x07
#define | BT_SDC_PRINTER 0x20
#define | BT_SDC_REMOTE_CONTROL 0x0C
#define | BT_SDC_SCANNER 0x10
#define | BT_SDC_SENSING_DEVICE 0x10
#define | BT_SDC_SERVER_CLASS_COMPUTER 0x02
#define | BT_SDC_SET_TOP_BOX 0x09
#define | BT_SDC_SHIFT 2
#define | BT_SDC_SMART_PHONE 0x03
#define | BT_SDC_VCR 0x0B
#define | BT_SDC_VIDEO_CAMERA 0x0C
#define | BT_SDC_VIDEO_CONFERENCING 0x10
#define | BT_SDC_VIDEO_DISPLAY_AND_LOUDSPEAKER 0x0F
#define | BT_SDC_VIDEO_MONITOR 0x0E
#define | BT_SDC_WEARABLE_COMPUTER 0x06
#define | BT_SDC_WIRED_MODEM_OR_VOICE_GATEWAY 0x04

Typedefs

typedef NiSharedPtr< BtBipAttachmentDesc > | BtBipAttachmentDescPtr
typedef Vector< BtBipAttachmentFormatPtr > | BtBipImagingCapabilities::BtBipAttachmentFormatList
typedef NiSharedPtr< BtBipAttachmentFormat > | BtBipAttachmentFormatPtr
typedef Vector< BtBipAttachmentPtr > | BtBipImageProperties::BtBipAttachmentList
typedef NiSharedPtr< BtBipAttachment > | BtBipAttachmentPtr
typedef NiSharedPtr< BtBipImageDesc > | BtBipImageDescPtr
typedef NiSharedPtr< BtBipImageFormat > | BtBipImageFormatPtr
typedef NiSharedPtr< BtBipImageHdlDesc > | BtBipImageHdlDescPtr
typedef NiSharedPtr< BtBipImageHdl > | BtBipImageHdlPtr
typedef NiSharedPtr< BtBipImageList > | BtBipImageListPtr
typedef NiSharedPtr< BtBipImageProperties > | BtBipImagePropertiesPtr
typedef NiSharedPtr< BtBipImage > | BtBipImagePtr
typedef NiSharedPtr< BtBipImagingCapabilities > | BtBipImagingCapabilitiesPtr
typedef SharedPtr< BtOperationBase > | BtOperationPtr

Enumerations

enum | { BtObexServerNotificationMessage::ID = 10106 }
enum | { BtHsNotificationMessage::ID = 10104 }
enum | { BtHfNotificationMessage::ID = 10105 }
enum | { BtAvrcpOperationServiceMessage::ID = 10451 }
enum | { BtAvrcpNotificationMessage::ID = 10450 }
enum | { BtObexClientNotificationMessage::ID = 10107 }
enum | BppBuffSize { e_bpp_buff_size = 2048 }
enum BppObjectTypeEnum {
e_bpp_snd_media_xhtml_print, e_bpp_snd_media_basic_text, e_bpp_snd_media_vcard, e_bpp_snd_media_vcalendar,
e_bpp_snd_media_icalendar, e_bpp_snd_media_vmessage, e_bpp_snd_media_post_script, e_bpp_snd_media_pcl,
e_bpp_snd_media_pdf, e_bpp_snd_media_jpeg, e_bpp_snd_media_gif
}
enum | BtAvrcpCategory { BtAcCategory1 = BTAPI_AVRCP_CATEGORY_1, BtAcCategory2 = BTAPI_AVRCP_CATEGORY_2, BtAcCategory3 = BTAPI_AVRCP_CATEGORY_3, BtAcCategory4 = BTAPI_AVRCP_CATEGORY_4 }
enum | BtAvrcpCommand { BtAcConnect, BtAcDisconnect, BtAcNotCongested }
General commands to be sent to the target. More...
enum BtAvrcpControlType {
BtActControl = BTAPI_AVRCP_CTYPE_CONTROL, BtActStatus = BTAPI_AVRCP_CTYPE_STATUS, BtActSpecificInquiry = BTAPI_AVRCP_CTYPE_SPECIFIC_INQUIRY, BtActNotify = BTAPI_AVRCP_CTYPE_NOTIFY,
BtActGeneralInquiry = BTAPI_AVRCP_CTYPE_GENERAL_INQUIRY
}
State the type of the operation. More...
enum | BtAvrcpOpcode { BtAocUnitInfo = BTAPI_AVRCP_OPCODE_UNIT_INFO, BtAocSubunitInfo = BTAPI_AVRCP_OPCODE_SUBUNIT_INFO, BtAocVendorDependent = BTAPI_AVRCP_OPCODE_VENDOR_DEPENDENT, BtAocPanelPassThrough = BTAPI_AVRCP_OPCODE_PANEL_PASS_THROUGH }
Operational code. More...
enum BtAvrcpOperation {
BtAoSelect = BTAPI_AVRCP_OP_SELECT, BtAoUp = BTAPI_AVRCP_OP_UP, BtAoDown = BTAPI_AVRCP_OP_DOWN, BtAoLeft = BTAPI_AVRCP_OP_LEFT,
BtAoRight = BTAPI_AVRCP_OP_RIGHT, BtAoRightUp = BTAPI_AVRCP_OP_RIGHT_UP, BtAoRightDown = BTAPI_AVRCP_OP_RIGHT_DOWN, BtAoLeftUp = BTAPI_AVRCP_OP_LEFT_UP,
BtApLeftDown = BTAPI_AVRCP_OP_LEFT_DOWN, BtAoRootMenu = BTAPI_AVRCP_OP_ROOT_MENU, BtAoSetupMenu = BTAPI_AVRCP_OP_SETUP_MENU, BtAoContentsMenu = BTAPI_AVRCP_OP_CONTENTS_MENU,
BtAoFavouriteMenu = BTAPI_AVRCP_OP_FAVORITE_MENU, BtAoExit = BTAPI_AVRCP_OP_EXIT, BtAo0 = BTAPI_AVRCP_OP_0, BtAo1 = BTAPI_AVRCP_OP_1,
BtAo2 = BTAPI_AVRCP_OP_2, BtAo3 = BTAPI_AVRCP_OP_3, BtAo4 = BTAPI_AVRCP_OP_4, BtAo5 = BTAPI_AVRCP_OP_5,
BtAo6 = BTAPI_AVRCP_OP_6, BtAo7 = BTAPI_AVRCP_OP_7, BtAo8 = BTAPI_AVRCP_OP_8, BtAo9 = BTAPI_AVRCP_OP_9,
BtAoDot = BTAPI_AVRCP_OP_DOT, BtAoEnter = BTAPI_AVRCP_OP_ENTER, BtAoClear = BTAPI_AVRCP_OP_CLEAR, BtAoChannelUp = BTAPI_AVRCP_OP_CHANNEL_UP,
BtAoChannelDown = BTAPI_AVRCP_OP_CHANNEL_DOWN, BtAoPrevChannel = BTAPI_AVRCP_OP_PREVIOUS_CHANNEL, BtAoSoundSelect = BTAPI_AVRCP_OP_SOUND_SELECT, BtAoInputSelect = BTAPI_AVRCP_OP_INPUT_SELECT,
BtAoDisplayInfo = BTAPI_AVRCP_OP_DISPLAY_INFORMATION, BtAoHelp = BTAPI_AVRCP_OP_HELP, BtAoPageUp = BTAPI_AVRCP_OP_PAGE_UP, BtAoPageDown = BTAPI_AVRCP_OP_PAGE_DOWN,
BtAoPower = BTAPI_AVRCP_OP_POWER, BtAoVolumeUp = BTAPI_AVRCP_OP_VOLUME_UP, BtAoVolumeDown = BTAPI_AVRCP_OP_VOLUME_DOWN, BtAoMute = BTAPI_AVRCP_OP_MUTE,
BtAoPlay = BTAPI_AVRCP_OP_PLAY, BtAoStop = BTAPI_AVRCP_OP_STOP, BtAoPause = BTAPI_AVRCP_OP_PAUSE, BtAoRecord = BTAPI_AVRCP_OP_RECORD,
BtAoRewind = BTAPI_AVRCP_OP_REWIND, BtAoFastForward = BTAPI_AVRCP_OP_FAST_FORWARD, BtAoEject = BTAPI_AVRCP_OP_EJECT, BtAoForward = BTAPI_AVRCP_OP_FORWARD,
BtAoBackward = BTAPI_AVRCP_OP_BACKWARD, BtAoAngle = BTAPI_AVRCP_OP_ANGLE, BtAoSubpicture = BTAPI_AVRCP_OP_SUBPICTURE, BtAoF1 = BTAPI_AVRCP_OP_F1,
BtAoF2 = BTAPI_AVRCP_OP_F2, BtAoF3 = BTAPI_AVRCP_OP_F3, BtAoF4 = BTAPI_AVRCP_OP_F4, BtAoF5 = BTAPI_AVRCP_OP_F5,
BaAoVendorUnique = BTAPI_AVRCP_OP_VENDOR_UNIQUE, BtAoNotDefined = BTAPI_AVRCP_OPERATION_NOT_DEFINED
}
enum BtAvrcpResponseType {
BtArNotImplemented = BTAPI_AVRCP_RESPONSE_NOT_IMPLEMENTED, BtArAccepted = BTAPI_AVRCP_RESPONSE_ACCEPTED, BtArRejected = BTAPI_AVRCP_RESPONSE_REJECTED, BtArInTransition = BTAPI_AVRCP_RESPONSE_IN_TRANSITION,
BtArImplementedStable = BTAPI_AVRCP_RESPONSE_IMPLEMENTED_STABLE, BtArResponseChanged = BTAPI_AVRCP_RESPONSE_CHANGED, BtArInterim = BTAPI_AVRCP_RESPONSE_INTERIM, BtArNotDefined = 99
}
enum | BtAvrcpRole { BtAroleController = BTAPI_AVRCP_CONTROLLER, BtAroleTarget = BTAPI_AVRCP_TARGET }
enum | BtAvrcpStateFlag { BtAsfButtonPress = BTAPI_AVRCP_BUTTON_PRESS, BtAsfButtonRelease = BTAPI_AVRCP_BUTTON_RELEASE }
Stateflag for button states (pressed, released). More...
enum BtAvrcpSubunitType {
BtAstMonitor = BTAPI_AVRCP_SUBUNIT_MONITOR, BtAstAudio = BTAPI_AVRCP_SUBUNIT_AUDIO, BtAstPrinter = BTAPI_AVRCP_SUBUNIT_PRINTER, BtAstDisc = BTAPI_AVRCP_SUBUNIT_DISC,
BtAstTapeRecPlayer = BTAPI_AVRCP_SUBUNIT_TAPE_RECORDER_PLAYER, BtAstTuner = BTAPI_AVRCP_SUBUNIT_TUNER, BtAstCa = BTAPI_AVRCP_SUBUNIT_CA, BtAstCamera = BTAPI_AVRCP_SUBUNIT_CAMERA,
BtAstPanel = BTAPI_AVRCP_SUBUNIT_PANEL, BtAstBulletinBoard = BTAPI_AVRCP_SUBUNIT_BULLETIN_BOARD, BtAstCameraStorage = BTAPI_AVRCP_SUBUNIT_CAMERA_STORAGE, BtAstVendorUnique = BTAPI_AVRCP_SUBUNIT_VENDOR_UNIQUE,
BtAstUnit = BTAPI_AVRCP_SUBUNIT_UNIT
}
Describes the type of a subunit which is implemented. More...
enum BtBipEncoding {
BtBipJpeg, BtBipGif, BtBipWBmp, BtBipPng,
BtBipJpeg2000, BtBipBmp, BtBipInvalidEncoding
}
Image encoding type. More...
enum BtBipResult {
BipOk, BipContinue, BipPartialContent, BipCallError,
BipObexFailed, BipSdapFailed, BipPadaptFailed
}
Result of BIP operation. More...
enum | BtBipSessionId { BipImagePush, BipImagePull, BipInvalidSessionId }
Type of session. More...
enum BtBipTransformation {
BtBipNone = 0, BtBipStretch = 1, BtBipCrop = 2, BtBipFill = 3,
BtBipInvalidTransformation = 4
}
Transformation type. More...
enum BtBppObexResult {
BppObexOk, BppObexContinue, BppObexPartialContent, BppObexBadRequest,
BppObexNotImplemented, BppObexForbidden, BppObexUnauthorised, BppObexPreconditionFailed,
BppObexNotFound, BppObexNotAcceptable, BppObexServiceUnavailable, BppObexUndefined
}
Result of OBEX operation used for BPP operation. More...
enum BtBppResult {
BppOk, BppContinue, BppObexFailed, BppSdapFailed,
BppPadaptFailed, BppObexHeaderFailed, BppCallError, BppUnauthenticated
}
enum | BtChipType { BtCtBmscr = BTAPI_BT_HW_BMSCR, BtCtBmu = BTAPI_BT_HW_BMU }
Hardware types. More...
enum | BtConnectableMode { BtCmNonConnectable = BTAPI_NON_CONNECTABLE, BtCmConnectable = BTAPI_CONNECTABLE }
Enumeration for modes of connectability. More...
enum BtDataElementType {
BtDetNil = BTAPI_NIL, BtDetUint = BTAPI_SDAP_UINT, BtDetSint = BTAPI_SDAP_SINT, BtDetUuid = BTAPI_SDAP_UUID,
BtDetString = BTAPI_SDAP_STRING, BtDetBool = BTAPI_SDAP_BOOL, BtDetSequence = BTAPI_SDAP_DATA_SEQ, BtDetEnumeration = BTAPI_SDAP_DATA_ALT,
BtDetUrl = BTAPI_SDAP_URL
}
Enumeration of possible tyes of data elements. More...
enum | BtDeviceRelation { BtDrNone = BTAPI_NO_RELATION, BtDrTrusted = BTAPI_TRUSTED, BtDrConnected = BTAPI_CONNECTED, BtDrTrustedAndConnected = BTAPI_TRUSTED_AND_CONNECTED }
enum | BtDeviceState { BtDsKnown, BtDsPaired, BtDsTrusted, BtDsConnected }
enum | BtDiscoverableMode { BtDmNonDiscoverable = BTAPI_NON_DISCOVERABLE, BtDmGeneralDiscoverable = BTAPI_GENERAL_DISCOVERABLE, BtDmLimitedDiscoverable = BTAPI_LIMITED_DISCOVERABLE }
Enumeration for modes of discoverability. More...
enum | BtOperationBase::BtErrorReason { BtOperationBase::BtErUnknown, BtOperationBase::BtErUserBreak, BtOperationBase::BtErOperationResultInvalid, BtOperationBase::BtErOperationFailure }
enum | BtHfCallEvent { BtHfCe }
enum | BtHfCallLocation { BtHfClNoCall, BtHfClCallOnPhone, BtHfClCallOnAccessory }
enum | BtHfState { BtHfsNotConnected, BtHfsConnected, BtHfsAvailableForAudio, BtHfsAudioActive }
enum | BtHsCallEvent { BtHsCeCallOnPhone, BtHsCeCallOnHeadset, BtHsCeHangUp, BtHsCeCallRelease }
enum | BtHsCallLocation { BtHsClNoCall, BtHsClCallOnPhone, BtHsClCallOnAccessory }
enum | BtHsState { BtHssNotConnected, BtHssConnected, BtHssAvailableForAudio, BtHssAudioActive }
enum | BtInquiryAccessCode { BtIacGlobal = BTAPI_GIAC, BtIacLocal = BTAPI_LIAC }
Types for inquiry settings. More...
enum BtObexErrorCode {
BtOecHandleUnknown = ObexHandleUnknown, BtOecOperationNotAllowed = ObexOperationNotAllowed, BtOecBusy = ObexBusy, BtOecNotConnected = ObexNotConnected,
BtOecConnected = ObexConnected
}
enum | BtObexHeaderType { BtOhtUnicodeString = 0x00, BtOhtByteSequence = 0x40, BtOhtByteValue = 0x80, BtOhtDWordValue = 0xC0 }
enum BtObexOperationCode {
BtOocConnect = BTAPI_GOEP_CONNECT, BtOocSetPath = BTAPI_GOEP_SETPATH, BtOocGet = BTAPI_GOEP_GET, BtOocPut = BTAPI_GOEP_PUT,
BtOocAbort = BTAPI_GOEP_ABORT, BtOocDisconnect = BTAPI_GOEP_DISCONNECT
}
enum | BtOperationType { BtOpPerformServiceVerify, BtOpSelectDevice, BtOpSelectDeviceAndPerformServiceVerify }
enum | BtPairableMode { BtPmNonPairable = BTAPI_NON_PAIRABLE, BtPmPairable = BTAPI_PAIRABLE }
Enumeration for modes of pairability. More...
enum BtProfile {
BtProfileUnknown = -1, BtProfileGapAndSdap, BtProfileDun = BTAPI_DUN, BtProfileHs = BTAPI_HS,
BtProfileHf = BTAPI_HF, BtProfileOpp = BTAPI_OPP, BtProfileFtp = BTAPI_FTP, BtProfileObex = BTAPI_OBEX,
BtProfileSap = BTAPI_SAP, BtProfileFax = BTAPI_FAX, BtProfileA2dp = BTAPI_A2DP, BtProfileAad = BtProfileA2dp,
BtProfilePap = BTAPI_PAP, BtProfileAvrcp = BTAPI_AVRCP, BtProfileBip = BTAPI_BIP, BtProfileBpp = BTAPI_BPP
}
enum BtRequestState {
BtRqsUnknown = -1, BtRqsInitialized, BtRqsAccepted, BtRqsRejected,
BtRqsAcceptedCancelation, BtRqsExecuting, BtRqsIgnored, BtRqsExecutingCancelation,
BtRqsFinishedOk, BtRqsFinishedFailure
}
Current state of execution for BtRequest classes. More...
enum BtRequestType {
BtRqtUnknown, BtRqtDevicePair, BtRqtDeviceUnpair, BtRqtDeviceTrust,
BtRqtDeviceUntrust, BtRqtSetRemoteDeviceName, BtRqtQuerySupportedProfiles, BtRqtSendPasskey,
BtRqtRespondAuthorization, BtRqtDeviceSearch, BtRqtServiceVerify, BtRqtSddbRegisterServiceRecord,
BtRqtSddbUnregisterServiceRecord, BtRqtDunDisconnect, BtRqtFaxDisconnect, BtRqtHsConnect,
BtRqtHsDisconnect, BtRqtHsRing, BtRqtHsStopRing, BtRqtHsHangUp,
BtRqtHsTransferAudioToPhone, BtRqtHsTransferAudioToAccessory, BtRqtHsSetMicrophoneGain, BtRqtHsSetSpeakerGain,
BtRqtHfConnect, BtRqtHfDisconnect, BtRqtHfTransferAudioToPhone, BtRqtHfTransferAudioToAccessory,
BtRqtHfSetMicrophoneGain, BtRqtHfSetSpeakerGain, BtRqtObexRegisterServer, BtRqtObexUnregisterServer,
BtRqtObexSendResponse, BtRqtObexRegisterClient, BtRqtObexUnregisterClient, BtRqtObexConnect,
BtRqtObexDisconnect, BtRqtObexSetPath, BtRqtObexGet, BtRqtObexPut,
BtRqtObexAbort, BtRqtAvrcpConnect, BtRqtAvrcpConnectRsp, BtRqtAvrcpDisconnect,
BtRqtAvrcpRegister, BtRqtAvrcpDeRegister, BtRqtAvrcpUnitInfo, BtRqtAvrcpPanelPassThrough,
BtRqtAvrcpRawFrame, BtRqtAvrcpSubunitInfo, BtRqtAvrcpPanelPassThroughRsp, BtRqtAvrcpRawFrameRsp,
BtRqtBppSndFilePushReq, BtRqtBppSndGetRefObjRsp, BtRqtBppSndAbortReq, BtRqtBppSndAuthenticationReqRes,
BtRqtBipConnect, BtRqtBipDisconnect, BtRqtBipAbort, BtRqtBipPutImage,
BtRqtBipPutLinkedThumbnail, BtRqtBipPutLinkedAttachment, BtRqtBipGetImagesList, BtRqtBipGetImage,
BtRqtBipGetLinkedThumbnail, BtRqtBipGetLinkedAttachment, BtRqtBipGetImageProperties, BtRqtBipDeleteImage,
BtRqtBipGetImagingCapabilities
}
Quasi RTTI for BtRequest classes. More...
enum BtResultCode {
BtRcAccepted = 2, BtRcPending = 3, BtRcOk = 0, BtRcRejected = -1,
BtRcIgnored = -2, BtRcError = -3, BtRcUnknown = -128
}
Result codes for Bluetooth stack operations. More...
enum BtSecuritySettings {
BtSesNoSecurity = BTAPI_NO_SECURITY, BtSesAuthentication = BTAPI_AUTHENTICATION, BtSesAuthenticationEncryption = BTAPI_AUTHENTICATION_ENCRYPTION, BtSesAuthenticationAuthorization = BTAPI_AUTHENTICATION_AUTHORISATION,
BtSesAuthenticationEncryptionAuthorization = BTAPI_AUTHENTICATION_ENCRYPTION_AUTHORISATION, BtSesAlwaysAuthenticatedTrustedDevices = BTAPI_ALWAYS_AUTHENTICATED_TRUSTED_DEVICES, BtSesAuthorizationAlwaysAuthenticatedTrustedDevices = BTAPI_AUTHORISATION_ALWAYS_AUTHENTICATED_TRUSTED_DEVICES, BtSesAuthorization = BTAPI_AUTHORISATION
}
enum BtStackState {
BtSsNotInitialized = BTAPI_STACK_NOT_INITIALIZED, BtSsInitialized = BTAPI_STACK_INITIALIZED, BtSsOn = BTAPI_STACK_ON, BtSsOff = BTAPI_STACK_OFF,
BtSsError = BTAPI_STACK_ERROR, BtSsNoState
}
Current state of Bluetooth stack. More...
enum | BtUuidType { BtUuid16 = BTAPI_UUID_16, BtUuid32 = BTAPI_UUID_32, BtUuid128 = BTAPI_UUID_128 }
Types for UUID witdthes. More...

Functions

void | BtBipImageProperties::AddAttachment (ApoxiMimeTypeId mime_type, const String &charset, const String &name, UINT32 size, const DateTime &created, const DateTime &modified)
void | BtBipImageProperties::AddAttachment (const BtBipAttachmentPtr &attach)
void | BtBipImagingCapabilities::AddAttachmentFormat (ApoxiMimeTypeId mime_type, const String &charset)
void | BtBipImagingCapabilities::AddAttachmentFormat (const BtBipAttachmentFormatPtr &format)
void | BtBipImageList::AddImage (const BtBipImageHdlPtr &handle, const DateTime &created, const DateTime &modified)
void | BtBipImageList::AddImage (const BtBipImagePtr &image)
void | BtBipImagingCapabilities::AddImageFormat (BtBipEncoding, UINT16 res_x, UINT16 res_y, UINT32 max_size)
void | BtBipImagingCapabilities::AddImageFormat (const BtBipImageFormatPtr &format)
void | BtBipImageProperties::AddVariant (BtBipEncoding encoding, UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height, UINT32 max_size, BtBipTransformation transformation)
void | BtBipImageProperties::AddVariant (BtBipEncoding encoding, UINT16 min_width, UINT16 max_width, UINT16 max_height, UINT32 max_size, BtBipTransformation transformation)
void | BtBipImageProperties::AddVariant (BtBipEncoding encoding, UINT16 width, UINT16 height, UINT32 max_size, BtBipTransformation transformation)
void | BtBipImageProperties::AddVariant (const BtBipImageFormatPtr &fmt)
String BtBipImageHdl::AsString ()
BtAvrcpNotificationMessage::BtAvrcpNotificationMessage (const BtAvrcpNotificationMessage &message)
Constructor.
BtAvrcpNotificationMessage::BtAvrcpNotificationMessage (BtAvrcpOperationService *service, StackMsgArgument *argument=0)
Constructor.
BtAvrcpNotificationMessage::BtAvrcpNotificationMessage (StackMsgArgument *argument=0)
Constructor.
BtAvrcpOperationServiceMessage::BtAvrcpOperationServiceMessage (const BtAvrcpOperationServiceMessage &message)
Constructor.
BtAvrcpOperationServiceMessage::BtAvrcpOperationServiceMessage (BtAvrcpOperationService *service, StackMsgArgument *argument=0)
Constructor.
BtAvrcpOperationServiceMessage::BtAvrcpOperationServiceMessage (StackMsgArgument *argument=0)
Constructor.
BtBipImageList::BtBipImageList ()
BtBipImagingCapabilities::BtBipImagingCapabilities ()
BtHfNotificationMessage::BtHfNotificationMessage (const BtHfNotificationMessage &message)
Constructor.
BtHfNotificationMessage::BtHfNotificationMessage (StackMsgArgument *argument=0)
Constructor.
BtHsNotificationMessage::BtHsNotificationMessage (const BtHsNotificationMessage &message)
Constructor.
BtHsNotificationMessage::BtHsNotificationMessage (StackMsgArgument *argument=0)
Constructor.
BtObexClientNotificationMessage::BtObexClientNotificationMessage (const BtObexClientNotificationMessage &message)
Constructor.
BtObexClientNotificationMessage::BtObexClientNotificationMessage (BtObexClientService *service, StackMsgArgument *argument=0)
Constructor.
BtObexServerNotificationMessage::BtObexServerNotificationMessage (const BtObexServerNotificationMessage &message)
Constructor.
BtObexServerNotificationMessage::BtObexServerNotificationMessage (BtObexServerService *service, StackMsgArgument *argument=0)
Constructor.
BtOperationBase::BtOperationBase ()
Constructor.
BtOperationSelectDevice::BtOperationSelectDevice (const BtDeviceFilter &device_filter=BtDeviceFilter())
Constructor.
BtOperationSelectDeviceAndPerformServiceVerify::BtOperationSelectDeviceAndPerformServiceVerify ()
Constructor.
virtual Message * | BtObexClientNotificationMessage::Clone () const
virtual Message * | BtObexServerNotificationMessage::Clone () const
virtual Message * | BtHsNotificationMessage::Clone () const
virtual Message * | BtHfNotificationMessage::Clone () const
virtual Message * | BtAvrcpOperationServiceMessage::Clone () const
virtual Message * | BtAvrcpNotificationMessage::Clone () const
BOOLEAN | ConvertUtf8ToWString (const CHAR *utf_char_pointer, WString &w_string)
Convert UTF-8 character array to WString object.
static void | BtBipImageHdl::CreateImageHdl (UINT32 id, BtBipImageHdlPtr &hdl_ptr)
Create a new image handle, unique between two reboots.
void | ExtendUuidTo128Bit (const BtUUID &uuid_base, BtUUID &uuid_128)
const BtBipAttachmentList & | BtBipImageProperties::GetAttachmentList () const
const BtAttributeId * | BtOperationSelectDeviceAndPerformServiceVerify::GetAttributesRequested () const
const String & | BtBipAttachmentDesc::GetCharset () const
const String & | BtBipAttachment::GetCharset ()
const String & | BtBipAttachmentFormat::GetCharset () const
const DateTime & | BtBipAttachmentDesc::GetCreated () const
const DateTime & | BtBipImage::GetCreated () const
const DateTime & | BtBipAttachment::GetCreateDate ()
const DateTime & | BtBipImageHdlDesc::GetCreatedFrom () const
const DateTime & | BtBipImageHdlDesc::GetCreatedTo () const
const BtDevice & | BtOperationSelectDeviceAndPerformServiceVerify::GetDevice () const
const BtDevice & | BtOperationSelectDevice::GetDevice () const
const BtDeviceFilter & | BtOperationSelectDeviceAndPerformServiceVerify::GetDeviceFilter () const
const BtDeviceFilter & | BtOperationSelectDevice::GetDeviceFilter () const
BtDeviceRelation | BtOperationSelectDeviceAndPerformServiceVerify::GetDeviceRelation () const
UINT8 | BtBipImagingCapabilities::GetDpofOptions () const
BtBipEncoding | BtBipImageHdlDesc::GetEncoding () const
BtBipEncoding | BtBipImageDesc::GetEncoding () const
BtBipEncoding | BtBipImageFormat::GetEncoding () const
BtErrorReason | BtOperationBase::GetErrorReason () const
UINT8 | BtBipImagingCapabilities::GetFilterParams () const
const BtBipImageFormat::ImageDim & | BtBipImageHdlDesc::GetImageDim () const
void | BtBipImageHdlDesc::GetImageDim (BtBipImageFormat::ImageDim &dim) const
const BtBipImageFormat::ImageDim & | BtBipImageDesc::GetImageDim () const
void | BtBipImageDesc::GetImageDim (BtBipImageFormat::ImageDim &dim) const
const ImageDim & | BtBipImageFormat::GetImageDim () const
void | BtBipImageFormat::GetImageDim (ImageDim &dim) const
Gets a variable dimension with fixed aspect ratio.
const BtBipImageHdlPtr & | BtBipImageProperties::GetImageHdl () const
const BtBipImageHdlPtr & | BtBipImage::GetImageHdl () const
const ImageList & | BtBipImageList::GetImageList () const
const String & | BtBipImageProperties::GetImageName () const
UINT32 | BtBipImageDesc::GetImageSize () const
UINT32 | BtBipImageDesc::GetMaxImageSize () const
UINT32 | BtBipImageFormat::GetMaxImageSize () const
Gets maximum image size in bytes.
virtual const MsgMetaData & | BtObexClientNotificationMessage::GetMetaData () const
virtual const MsgMetaData & | BtObexServerNotificationMessage::GetMetaData () const
virtual const MsgMetaData & | BtHsNotificationMessage::GetMetaData () const
virtual const MsgMetaData & | BtHfNotificationMessage::GetMetaData () const
virtual const MsgMetaData & | BtAvrcpOperationServiceMessage::GetMetaData () const
virtual const MsgMetaData & | BtAvrcpNotificationMessage::GetMetaData () const
ApoxiMimeTypeId | BtBipAttachmentDesc::GetMimeType () const
ApoxiMimeTypeId BtBipAttachment::GetMimeType ()
ApoxiMimeTypeId | BtBipAttachmentFormat::GetMimeType () const
const DateTime & | BtBipImage::GetModified () const
const DateTime & | BtBipImageHdlDesc::GetModifiedFrom () const
const DateTime & | BtBipImageHdlDesc::GetModifiedTo () const
const DateTime & | BtBipAttachment::GetModifyDate ()
const String & | BtBipAttachmentDesc::GetName () const
const String & | BtBipAttachment::GetName ()
BtBipEncoding | BtBipImageProperties::GetNativeEncoding () const
const BtBipImageFormat & | BtBipImageProperties::GetNativeFormat () const
UINT16 | BtBipImageProperties::GetNativeHeight () const
UINT32 | BtBipImageProperties::GetNativeSize () const
UINT16 | BtBipImageProperties::GetNativeWidth () const
UINT8 | BtOperationSelectDeviceAndPerformServiceVerify::GetNumberOfAttributesRequested () const
UINT8 | BtOperationSelectDeviceAndPerformServiceVerify::GetNumberOfServicesToVerify () const
virtual BtOperationType | BtOperationSelectDeviceAndPerformServiceVerify::GetOperationType () const
virtual BtOperationType | BtOperationSelectDevice::GetOperationType () const
virtual BtOperationType | BtOperationBase::GetOperationType () const =0
BtBipEncoding | BtBipImagingCapabilities::GetPrefEncoding () const
const BtBipImageFormat & | BtBipImagingCapabilities::GetPreferredFormat () const
UINT16 | BtBipImagingCapabilities::GetPrefMaxHeight () const
UINT32 | BtBipImagingCapabilities::GetPrefMaxSize () const
UINT16 | BtBipImagingCapabilities::GetPrefMaxWidth () const
UINT16 | BtBipImagingCapabilities::GetPrefMinHeight () const
UINT16 | BtBipImagingCapabilities::GetPrefMinWidth () const
UINT16 | BtBipImagingCapabilities::GetPrefTransformation () const
BtResultCode | BtOperationBase::GetResult () const
BtObexClientService * | BtObexClientNotificationMessage::GetService () const
BtObexServerService * | BtObexServerNotificationMessage::GetService () const
BtAvrcpOperationService * | BtAvrcpOperationServiceMessage::GetService () const
BtAvrcpOperationService * | BtAvrcpNotificationMessage::GetService () const
const BtUUID * | BtOperationSelectDeviceAndPerformServiceVerify::GetServiceToVerify () const
const BtServiceVerifyResult & | BtOperationSelectDeviceAndPerformServiceVerify::GetServiceVerifyResult () const
UINT32 | BtBipAttachmentDesc::GetSize () const
UINT32 | BtBipAttachment::GetSize ()
const BtBipAttachmentFormatList & | BtBipImagingCapabilities::GetSupportedAttachmentFormatList () const
const BtBipImageFormatList & | BtBipImagingCapabilities::GetSupportedImageFormatList () const
BtBipTransformation | BtBipImageDesc::GetTransformation () const
BtBipTransformation | BtBipImageFormat::GetTransformation () const
Get transformation.
const BtBipVariantList & | BtBipImageProperties::GetVariantList () const
BOOLEAN | BtBipImagingCapabilities::IsDpofOptionSupported (UINT8 dpof_options) const
BOOLEAN | BtBipImagingCapabilities::IsFilterSupported (UINT8 filter) const
virtual void | BtOperationBase::OnResult (BtResultCode result)=0
BOOLEAN | operator!= (const BtObexServiceTable::ServiceInfo &lhs, const BtObexServiceTable::ServiceInfo &rhs)
BOOLEAN | operator!= (const BtUUID &left_value, const BtUUID &right_value)
BOOLEAN | operator!= (const BtSvrDataElement &left_value, const BtSvrDataElement &right_value)
virtual BtObexClientNotificationMessage & | BtObexClientNotificationMessage::operator= (const BtObexClientNotificationMessage &message)
virtual FromStackMsg & | BtObexClientNotificationMessage::operator= (const FromStackMsg &message)
virtual BtObexServerNotificationMessage & | BtObexServerNotificationMessage::operator= (const BtObexServerNotificationMessage &message)
virtual FromStackMsg & | BtObexServerNotificationMessage::operator= (const FromStackMsg &message)
virtual BtHsNotificationMessage & | BtHsNotificationMessage::operator= (const BtHsNotificationMessage &message)
virtual FromStackMsg & | BtHsNotificationMessage::operator= (const FromStackMsg &message)
virtual BtHfNotificationMessage & | BtHfNotificationMessage::operator= (const BtHfNotificationMessage &message)
virtual FromStackMsg & | BtHfNotificationMessage::operator= (const FromStackMsg &message)
virtual BtAvrcpOperationServiceMessage & | BtAvrcpOperationServiceMessage::operator= (const BtAvrcpOperationServiceMessage &message)
virtual FromStackMsg & | BtAvrcpOperationServiceMessage::operator= (const FromStackMsg &message)
virtual BtAvrcpNotificationMessage & | BtAvrcpNotificationMessage::operator= (const BtAvrcpNotificationMessage &message)
virtual FromStackMsg & | BtAvrcpNotificationMessage::operator= (const FromStackMsg &message)
BOOLEAN | operator== (const BtObexServiceTable::ServiceInfo &lhs, const BtObexServiceTable::ServiceInfo &rhs)
BOOLEAN | operator== (const BtUUID &left_value, const BtUUID &right_value)
BOOLEAN | operator== (const BtSvrDataElement &left_value, const BtSvrDataElement &right_value)
BOOLEAN | BtOperationSelectDeviceAndPerformServiceVerify::SetAttributesRequested (const BtAttributeId *attributes_requested, UINT8 number_of_attributes_requested)
void | BtBipAttachmentDesc::SetCharset (const String &charset)
void | BtBipAttachment::SetCharset (const String &charset)
void | BtBipAttachmentFormat::SetCharset (const String &charset)
void | BtBipAttachmentDesc::SetCreateDate (const DateTime &date)
void | BtBipAttachment::SetCreateDate (const DateTime &date)
void | BtBipImage::SetCreatedDate (const DateTime &created)
void | BtBipImageHdlDesc::SetCreatedFrom (const DateTime &from)
void | BtBipImageHdlDesc::SetCreatedFrom (UINT16 year, UINT16 month, UINT16 day, UINT16 hour=0, UINT16 minute=0, UINT16 second=0)
void | BtBipImageHdlDesc::SetCreatedTo (const DateTime &to)
void | BtBipImageHdlDesc::SetCreatedTo (UINT16 year, UINT16 month, UINT16 day, UINT16 hour=23, UINT16 minut=59, UINT16 second=59)
void | BtOperationSelectDeviceAndPerformServiceVerify::SetDevice (const BtDevice &device)
void | BtOperationSelectDevice::SetDevice (const BtDevice &device)
void | BtOperationSelectDeviceAndPerformServiceVerify::SetDeviceFilter (const BtDeviceFilter &device_filter)
void | BtOperationSelectDevice::SetDeviceFilter (const BtDeviceFilter &device_filter)
void | BtOperationSelectDeviceAndPerformServiceVerify::SetDeviceReleation (BtDeviceRelation device_relation)
void | BtBipImagingCapabilities::SetDpofOptions (UINT8 dpof_options)
void | BtBipImageHdlDesc::SetEncoding (BtBipEncoding encoding)
void | BtBipImageFormat::SetEncoding (BtBipEncoding encoding)
void | BtOperationBase::SetErrorReason (BtErrorReason error_reason)
void | BtBipImagingCapabilities::SetFilterParamters (UINT8 filter_params)
void | BtBipImageProperties::SetFriendlyName (const String &name)
void | BtBipImageHdlDesc::SetImageDim (UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height)
void | BtBipImageHdlDesc::SetImageDim (UINT16 min_width, UINT16 max_width, UINT16 max_height)
void | BtBipImageHdlDesc::SetImageDim (UINT16 width, UINT16 height)
void | BtBipImageDesc::SetImageDim (UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height)
void | BtBipImageDesc::SetImageDim (UINT16 min_width, UINT16 max_width, UINT16 max_height)
void | BtBipImageDesc::SetImageDim (UINT16 width, UINT16 height)
void | BtBipImageFormat::SetImageDim (UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height)
Sets fully variable dimension without respect to the aspect ratio.
void | BtBipImageFormat::SetImageDim (UINT16 min_width, UINT16 max_width, UINT16 max_height)
Sets a variable dimension with fixed aspect ratio.
void | BtBipImageFormat::SetImageDim (UINT16 width, UINT16 height)
Sets a fixed dimension of an image.
void | BtBipImageProperties::SetImageHandle (const BtBipImageHdlPtr &hdl)
void | BtBipImage::SetImageHdl (const BtBipImageHdlPtr &hdl)
void | BtBipImageDesc::SetImageSize (UINT32 size)
void | BtBipImageDesc::SetMaxImageSize (UINT32 max_size)
void | BtBipImageFormat::SetMaxImageSize (UINT32 max_size)
Sets maximum image size in bytes.
void | BtBipAttachmentDesc::SetMimeType (ApoxiMimeTypeId mime_type)
void | BtBipAttachment::SetMimeType (ApoxiMimeTypeId mime_type)
void | BtBipAttachmentFormat::SetMimeType (ApoxiMimeTypeId mime_type)
void | BtBipImage::SetModifiedDate (const DateTime &modified)
void | BtBipImageHdlDesc::SetModifiedFrom (const DateTime &from)
void | BtBipImageHdlDesc::SetModifiedFrom (UINT16 year, UINT16 month, UINT16 day, UINT16 hour, UINT16 minute, UINT16 second)
void | BtBipImageHdlDesc::SetModifiedTo (const DateTime &to)
void | BtBipImageHdlDesc::SetModifiedTo (UINT16 year, UINT16 month, UINT16 day, UINT16 hour, UINT16 minute, UINT16 second)
void | BtBipAttachment::SetModifyDate (const DateTime &date)
void | BtBipAttachmentDesc::SetName (const String &name)
void | BtBipAttachment::SetName (const String &name)
void | BtBipImageProperties::SetNativeDim (UINT16 width, UINT16 height)
void | BtBipImageProperties::SetNativeEncoding (BtBipEncoding encoding)
void | BtBipImageProperties::SetNativeFormat (const BtBipImageFormat &fmt)
void | BtBipImageProperties::SetNativeSize (UINT32 size)
void | BtBipImagingCapabilities::SetPreferredFormat (BtBipEncoding encoding, UINT16 min_width, UINT16 min_height, UINT16 max_width, UINT16 max_height, BtBipTransformation transformation, UINT32 max_size)
Set a range for the preferred image size with no resize to the aspect ratio.
void | BtBipImagingCapabilities::SetPreferredFormat (BtBipEncoding encoding, UINT16 min_width, UINT16 max_width, UINT16 max_height, BtBipTransformation transformation, UINT32 max_size)
Set a range for the preferred image size with fixed aspect ration.
void | BtBipImagingCapabilities::SetPreferredFormat (BtBipEncoding encoding, UINT16 width, UINT16 height, BtBipTransformation transformation, UINT32 max_size)
Set a fixed preferred image size.
void | BtBipImagingCapabilities::SetPreferredFormat (const BtBipImageFormat &format)
void | BtOperationBase::SetResult (BtResultCode result, BtErrorReason error_reason=BtErUnknown)
BOOLEAN | BtOperationSelectDeviceAndPerformServiceVerify::SetServicesToVerify (const BtUUID *services_to_verify, UINT8 number_of_services_to_verify)
BOOLEAN | BtOperationSelectDeviceAndPerformServiceVerify::SetServiceVerifyResult (const BtServiceVerifyResult &service_verify_result)
void | BtBipAttachmentDesc::SetSize (UINT32 size)
void | BtBipAttachment::SetSize (UINT32 size)
void | BtBipImageDesc::SetTransformation (BtBipTransformation transformation)
void | BtBipImageFormat::SetTransformation (BtBipTransformation transformation)
BtProfile | ToProfile (btapi_profile_t profile)
Convert stack profile type to APOXI profile type.
BtResultCode | ToResultCode (btapi_result_t result)
Convert stack result code to APOXI result code.
virtual | BtAvrcpNotificationMessage::~BtAvrcpNotificationMessage ()
Destructor.
virtual | BtAvrcpOperationServiceMessage::~BtAvrcpOperationServiceMessage ()
Destructor.
BtBipAttachmentDesc::~BtBipAttachmentDesc ()
BtBipAttachmentFormat::~BtBipAttachmentFormat ()
virtual | BtBipImage::~BtBipImage ()
virtual | BtBipImageHdlDesc::~BtBipImageHdlDesc ()
virtual | BtBipImageList::~BtBipImageList ()
BtBipImagingCapabilities::~BtBipImagingCapabilities ()
virtual | BtHfNotificationMessage::~BtHfNotificationMessage ()
Destructor.
virtual | BtHsNotificationMessage::~BtHsNotificationMessage ()
Destructor.
virtual | BtObexClientNotificationMessage::~BtObexClientNotificationMessage ()
Destructor.
virtual | BtObexServerNotificationMessage::~BtObexServerNotificationMessage ()
Destructor.
virtual | BtOperationBase::~BtOperationBase ()
Destructor.
virtual | BtOperationSelectDevice::~BtOperationSelectDevice ()
Destructor.
virtual | BtOperationSelectDeviceAndPerformServiceVerify::~BtOperationSelectDeviceAndPerformServiceVerify ()
Destructor.

Variables

const BtDeviceAddress | bt_c_empty_device_address
bt_c_empty_device_address represents an invalid device address
const BtDeviceList | bt_c_empty_device_list
const BtDevice | bt_c_unknown_device
const UINT16 | c_bip_client_read_buf_size
BIP Client Service (image initiator).
const int | c_bip_invalid_res
Result of OBEX operation used for BIP operation.
const UINT32 | c_bip_max_image_hdl
UINT8 | BtAvrcpSubunitInfoEntry::m_max_subunit_id
UINT16 | BtBipImageFormat::ImageDim::max_height
UINT16 | BtBipImageFormat::ImageDim::max_width
UINT16 | BtBipImageFormat::ImageDim::min_height

Define Documentation

#define APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY BtSesNoSecurity

Default APOXI Bluetooth OBEX client security settings.

#define APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY BtSesAuthorization

Default APOXI Bluetooth OBEX server security settings.

#define BIP_IMG_HDL_SIZE 8

#define BT_AA_INVALID_VOLUME_LEVEL 0xFF

#define BT_MDC_AUDIO_VIDEO 0x04

#define BT_MDC_COMPUTER 0x01

#define BT_MDC_IMAGING 0x06

#define BT_MDC_LAN 0x03

#define BT_MDC_MASK 0x1F

#define BT_MDC_PERIPHERAL 0x05

#define BT_MDC_PHONE 0x02

#define BT_MDC_SHIFT 8

#define BT_MDC_UNCATEGORIZED 0x1F

#define BT_MSC_AUDIO 0x100

#define BT_MSC_CAPTURING 0x040

#define BT_MSC_INFORMATION 0x400

#define BT_MSC_MASK 0x7FF

#define BT_MSC_NETWORK 0x010

#define BT_MSC_OBJECT_TRANSFER 0x080

#define BT_MSC_POSITIONING 0x008

#define BT_MSC_RENDERING 0x020

#define BT_MSC_SHIFT 13

#define BT_MSC_TELEPHONY 0x200

#define BT_SDC_01_TO_17_UTILIZED 0x08

#define BT_SDC_17_TO_33_UTILIZED 0x10

#define BT_SDC_33_TO_50_UTILIZED 0x18

#define BT_SDC_50_TO_67_UTILIZED 0x20

#define BT_SDC_67_TO_83_UTILIZED 0x28

#define BT_SDC_83_TO_99_UTILIZED 0x30

#define BT_SDC_CAMCORDER 0x0D

#define BT_SDC_CAMERA 0x08

#define BT_SDC_CAR_AUDIO 0x08

#define BT_SDC_CARD_READER 0x18

#define BT_SDC_CELLULAR 0x01

#define BT_SDC_COMBO_KEYBOARD_POINTING_DEVICE 0x03

#define BT_SDC_COMMON_ISDN_ACCESS 0x05

#define BT_SDC_CORDLESS 0x02

#define BT_SDC_DESKTOP_WORKSTATION 0x01

#define BT_SDC_DIGITIZER_TABLET 0x14

#define BT_SDC_DISPLAY 0x04

#define BT_SDC_GAMEPAD 0x08

#define BT_SDC_GAMING_TOY 0x12

#define BT_SDC_HAEDPHONES 0x06

#define BT_SDC_HANDHELD_PC_PDA 0x04

#define BT_SDC_HANDS_FREE 0x02

#define BT_SDC_HEADSET 0x01

#define BT_SDC_HIFI_AUDIO 0x0A

#define BT_SDC_JOYSTICK 0x04

#define BT_SDC_KEYBOARD 0x01

#define BT_SDC_LAPTOP 0x03

#define BT_SDC_LOUDSPEAKER 0x05

#define BT_SDC_MASK 0x3F

#define BT_SDC_MICROPHONE 0x04

#define BT_SDC_NO_SERVICE 0x38

#define BT_SDC_PALM_SIZED_PS_PDA 0x05

#define BT_SDC_POINTING_DEVICE 0x02

#define BT_SDC_PORTABLE_AUDIO 0x07

#define BT_SDC_PRINTER 0x20

#define BT_SDC_REMOTE_CONTROL 0x0C

#define BT_SDC_SCANNER 0x10

#define BT_SDC_SENSING_DEVICE 0x10

#define BT_SDC_SERVER_CLASS_COMPUTER 0x02

#define BT_SDC_SET_TOP_BOX 0x09

#define BT_SDC_SHIFT 2

#define BT_SDC_SMART_PHONE 0x03

#define BT_SDC_VCR 0x0B

#define BT_SDC_VIDEO_CAMERA 0x0C

#define BT_SDC_VIDEO_CONFERENCING 0x10

#define BT_SDC_VIDEO_DISPLAY_AND_LOUDSPEAKER 0x0F

#define BT_SDC_VIDEO_MONITOR 0x0E

#define BT_SDC_WEARABLE_COMPUTER 0x06

#define BT_SDC_WIRED_MODEM_OR_VOICE_GATEWAY 0x04

Typedef Documentation

typedef NiSharedPtr<BtBipAttachmentDesc> BtBipAttachmentDescPtr

typedef Vector<BtBipAttachmentFormatPtr> BtBipImagingCapabilities::BtBipAttachmentFormatList [inherited]

typedef NiSharedPtr<BtBipAttachmentFormat> BtBipAttachmentFormatPtr

typedef Vector<BtBipAttachmentPtr> BtBipImageProperties::BtBipAttachmentList [inherited]

typedef NiSharedPtr<BtBipAttachment> BtBipAttachmentPtr

typedef NiSharedPtr<BtBipImageDesc> BtBipImageDescPtr

typedef NiSharedPtr<BtBipImageFormat> BtBipImageFormatPtr

typedef NiSharedPtr<BtBipImageHdlDesc> BtBipImageHdlDescPtr

typedef NiSharedPtr<BtBipImageHdl> BtBipImageHdlPtr

typedef NiSharedPtr<BtBipImageList> BtBipImageListPtr

typedef NiSharedPtr<BtBipImageProperties> BtBipImagePropertiesPtr

typedef NiSharedPtr<BtBipImage> BtBipImagePtr

typedef NiSharedPtr<BtBipImagingCapabilities> BtBipImagingCapabilitiesPtr

typedef SharedPtr<BtOperationBase> BtOperationPtr

Enumeration Type Documentation

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from FromStackMsg.

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from FromStackMsg.

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from FromStackMsg.

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from FromStackMsg.

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from FromStackMsg.

anonymous enum [inherited]

Enumerator:
ID

enum BppBuffSize

Enumerator:
e_bpp_buff_size

enum BppObjectTypeEnum

Enumerator:
e_bpp_snd_media_xhtml_print
e_bpp_snd_media_basic_text
e_bpp_snd_media_vcard
e_bpp_snd_media_vcalendar
e_bpp_snd_media_icalendar
e_bpp_snd_media_vmessage
e_bpp_snd_media_post_script
e_bpp_snd_media_pcl
e_bpp_snd_media_pdf
e_bpp_snd_media_jpeg
e_bpp_snd_media_gif

enum BtAvrcpCategory

Categories which define the operational set to be implemented to fulfill the AVRCP standard. If eg. a target device implements Cat1 it has to support at least the commands "play (BtAoPlay)" and "stop BtAoStop".

Enumerator:
BtAcCategory1
BtAcCategory2
BtAcCategory3
BtAcCategory4

enum BtAvrcpCommand

General commands to be sent to the target.

Enumerator:
BtAcConnect
BtAcDisconnect
BtAcNotCongested

enum BtAvrcpControlType

State the type of the operation.

Enumerator:
BtActControl
BtActStatus
BtActSpecificInquiry
BtActNotify
BtActGeneralInquiry

enum BtAvrcpOpcode

Operational code.

Enumerator:
BtAocUnitInfo
BtAocSubunitInfo
BtAocVendorDependent
BtAocPanelPassThrough

enum BtAvrcpOperation

Operations which are defined by the AVRCP standard. In case an operation is not implemented this has to be stated as an BtAvrcpResponse::BtArNotImplemented in the response function-call.

Enumerator:
BtAoSelect
BtAoUp
BtAoDown
BtAoLeft
BtAoRight
BtAoRightUp
BtAoRightDown
BtAoLeftUp
BtApLeftDown
BtAoRootMenu
BtAoSetupMenu
BtAoContentsMenu
BtAoFavouriteMenu
BtAoExit
BtAo0
BtAo1
BtAo2
BtAo3
BtAo4
BtAo5
BtAo6
BtAo7
BtAo8
BtAo9
BtAoDot
BtAoEnter
BtAoClear
BtAoChannelUp
BtAoChannelDown
BtAoPrevChannel
BtAoSoundSelect
BtAoInputSelect
BtAoDisplayInfo
BtAoHelp
BtAoPageUp
BtAoPageDown
BtAoPower
BtAoVolumeUp
BtAoVolumeDown
BtAoMute
BtAoPlay
BtAoStop
BtAoPause
BtAoRecord
BtAoRewind
BtAoFastForward
BtAoEject
BtAoForward
BtAoBackward
BtAoAngle
BtAoSubpicture
BtAoF1
BtAoF2
BtAoF3
BtAoF4
BtAoF5
BaAoVendorUnique
BtAoNotDefined

enum BtAvrcpResponseType

Response codes which have to be sent by a target application as a resonse to PanelPassThrough and RawFramecommands.

Enumerator:
BtArNotImplemented
BtArAccepted
BtArRejected
BtArInTransition
BtArImplementedStable
BtArResponseChanged
BtArInterim
BtArNotDefined

enum BtAvrcpRole

Enumerator:
BtAroleController
BtAroleTarget

enum BtAvrcpStateFlag

Stateflag for button states (pressed, released).

Enumerator:
BtAsfButtonPress
BtAsfButtonRelease

enum BtAvrcpSubunitType

Describes the type of a subunit which is implemented.

Enumerator:
BtAstMonitor
BtAstAudio
BtAstPrinter
BtAstDisc
BtAstTapeRecPlayer
BtAstTuner
BtAstCa
BtAstCamera
BtAstPanel
BtAstBulletinBoard
BtAstCameraStorage
BtAstVendorUnique
BtAstUnit

enum BtBipEncoding

Image encoding type.

Enumerator:
BtBipJpeg
BtBipGif
BtBipWBmp
BtBipPng
BtBipJpeg2000
BtBipBmp
BtBipInvalidEncoding

enum BtBipResult

Result of BIP operation.

Enumerator:
BipOk
BipContinue
BipPartialContent
BipCallError
BipObexFailed
BipSdapFailed
BipPadaptFailed

enum BtBipSessionId

Type of session.

Enumerator:
BipImagePush
BipImagePull
BipInvalidSessionId

enum BtBipTransformation

Transformation type.

Enumerator:
BtBipNone
BtBipStretch
BtBipCrop
BtBipFill
BtBipInvalidTransformation

enum BtBppObexResult

Result of OBEX operation used for BPP operation.

Enumerator:
BppObexOk
BppObexContinue
BppObexPartialContent
BppObexBadRequest
BppObexNotImplemented
BppObexForbidden
BppObexUnauthorised
BppObexPreconditionFailed
BppObexNotFound
BppObexNotAcceptable
BppObexServiceUnavailable
BppObexUndefined

enum BtBppResult

Enumerator:
BppOk
BppContinue
BppObexFailed
BppSdapFailed
BppPadaptFailed
BppObexHeaderFailed
BppCallError
BppUnauthenticated

enum BtChipType

Hardware types.

Enumerator:
BtCtBmscr
BtCtBmu

enum BtConnectableMode

Enumeration for modes of connectability.

Enumerator:
BtCmNonConnectable | non connectable mode
BtCmConnectable | generall connectable mode

enum BtDataElementType

Enumeration of possible tyes of data elements.

Enumerator:
BtDetNil
BtDetUint | unsigned integer
BtDetSint | signed integer
BtDetUuid | unique identifier
BtDetString | string
BtDetBool | boolean
BtDetSequence | data element sequence
BtDetEnumeration | enumeration
BtDetUrl | unique resource locator

enum BtDeviceRelation

Enumerator:
BtDrNone | No filtering at all.
BtDrTrusted | Only trusted devices remain.
BtDrConnected | Only connected devices remain.
BtDrTrustedAndConnected | Only both trusted and connected devices remain.

enum BtDeviceState

BtDeviceState describes the state of a remote BT-Device, as it is known to the local BT-Device

Enumerator:
BtDsKnown | remote device is only known
BtDsPaired | remote device is paried
BtDsTrusted | remote device is paired and trusted
BtDsConnected | remoted device is connected

enum BtDiscoverableMode

Enumeration for modes of discoverability.

Enumerator:
BtDmNonDiscoverable | non discoverable mode
BtDmGeneralDiscoverable | general discoverable mode
BtDmLimitedDiscoverable | limited discoverable mode

enum BtOperationBase::BtErrorReason [inherited]

Enumerator:
BtErUnknown
BtErUserBreak
BtErOperationResultInvalid
BtErOperationFailure

enum BtHfCallEvent

Enumerator:
BtHfCe

enum BtHfCallLocation

Enumerator:
BtHfClNoCall
BtHfClCallOnPhone
BtHfClCallOnAccessory

enum BtHfState

Enumerator:
BtHfsNotConnected
BtHfsConnected
BtHfsAvailableForAudio
BtHfsAudioActive

enum BtHsCallEvent

Enumerator:
BtHsCeCallOnPhone
BtHsCeCallOnHeadset
BtHsCeHangUp
BtHsCeCallRelease

enum BtHsCallLocation

Enumerator:
BtHsClNoCall
BtHsClCallOnPhone
BtHsClCallOnAccessory

enum BtHsState

Enumerator:
BtHssNotConnected
BtHssConnected
BtHssAvailableForAudio
BtHssAudioActive

enum BtInquiryAccessCode

Types for inquiry settings.

Enumerator:
BtIacGlobal | gloabal inquiry access code
BtIacLocal | local inquiry access code

enum BtObexErrorCode

Enumerator:
BtOecHandleUnknown
BtOecOperationNotAllowed
BtOecBusy
BtOecNotConnected
BtOecConnected

enum BtObexHeaderType

Enumerator:
BtOhtUnicodeString
BtOhtByteSequence
BtOhtByteValue
BtOhtDWordValue

enum BtObexOperationCode

Enumerator:
BtOocConnect
BtOocSetPath
BtOocGet
BtOocPut
BtOocAbort
BtOocDisconnect

enum BtOperationType

Enumerator:
BtOpPerformServiceVerify
BtOpSelectDevice
BtOpSelectDeviceAndPerformServiceVerify

enum BtPairableMode

Enumeration for modes of pairability.

Enumerator:
BtPmNonPairable | non pairable mode
BtPmPairable | pairable mode

enum BtProfile

BtProfile defines the enumeration value for every supported profile in the BT stack.

Enumerator:
BtProfileUnknown | Unknow profile.
BtProfileGapAndSdap | Generic Access Profile & Service Discovery Application Profile.
BtProfileDun | Dial-up Networking profile.
BtProfileHs | Headset profile.
BtProfileHf | Handsfree profile.
BtProfileOpp | Object Push profile.
BtProfileFtp | File transfer profile.
BtProfileObex | Generic Object Exchange profile.
BtProfileSap | Sim access profile.
BtProfileFax | FAX profile.
BtProfileA2dp | Advanced Audio distribution profile.
BtProfileAad
BtProfilePap | Phone access profile.
BtProfileAvrcp | Audio Video Remote Control Profile (AVRCP).
BtProfileBip | Basic Imaging Profile.
BtProfileBpp | Basic Printing Profile.

enum BtRequestState

Current state of execution for BtRequest classes.

During its lifetime a request passes through various states of execution. BtRequestState is an enumeration type describing these stages of execution.

Enumerator:
BtRqsUnknown
BtRqsInitialized | request is constructed and initialized
BtRqsAccepted | request is accepted by the Bluetooth Stack
BtRqsRejected
BtRqsAcceptedCancelation
BtRqsExecuting | request is in execution by the Bluetooth Stack
BtRqsIgnored
BtRqsExecutingCancelation
BtRqsFinishedOk | request is finished successfully
BtRqsFinishedFailure | request is finished but an error occured

enum BtRequestType

Quasi RTTI for BtRequest classes.

Bluetooth operations going over the air have a common base class to enable polymorphism. If this paradigm is used sometimes an information about the real runtime type is needed. Not compiles that are used to compile APOXI support RTTI, so a rudimentary runtime type information is implemented via this enumeration type.

Enumerator:
BtRqtUnknown | request type is unknown
BtRqtDevicePair | request is a BtDevicePairRequest
BtRqtDeviceUnpair | request is a <me>BtDeviceUnpairRequest
BtRqtDeviceTrust
BtRqtDeviceUntrust
BtRqtSetRemoteDeviceName
BtRqtQuerySupportedProfiles
BtRqtSendPasskey
BtRqtRespondAuthorization
BtRqtDeviceSearch
BtRqtServiceVerify
BtRqtSddbRegisterServiceRecord
BtRqtSddbUnregisterServiceRecord
BtRqtDunDisconnect
BtRqtFaxDisconnect
BtRqtHsConnect
BtRqtHsDisconnect
BtRqtHsRing
BtRqtHsStopRing
BtRqtHsHangUp
BtRqtHsTransferAudioToPhone
BtRqtHsTransferAudioToAccessory
BtRqtHsSetMicrophoneGain
BtRqtHsSetSpeakerGain
BtRqtHfConnect
BtRqtHfDisconnect
BtRqtHfTransferAudioToPhone
BtRqtHfTransferAudioToAccessory
BtRqtHfSetMicrophoneGain
BtRqtHfSetSpeakerGain
BtRqtObexRegisterServer
BtRqtObexUnregisterServer
BtRqtObexSendResponse
BtRqtObexRegisterClient
BtRqtObexUnregisterClient
BtRqtObexConnect
BtRqtObexDisconnect
BtRqtObexSetPath
BtRqtObexGet
BtRqtObexPut
BtRqtObexAbort
BtRqtAvrcpConnect
BtRqtAvrcpConnectRsp
BtRqtAvrcpDisconnect
BtRqtAvrcpRegister
BtRqtAvrcpDeRegister
BtRqtAvrcpUnitInfo
BtRqtAvrcpPanelPassThrough
BtRqtAvrcpRawFrame
BtRqtAvrcpSubunitInfo
BtRqtAvrcpPanelPassThroughRsp
BtRqtAvrcpRawFrameRsp
BtRqtBppSndFilePushReq
BtRqtBppSndGetRefObjRsp
BtRqtBppSndAbortReq
BtRqtBppSndAuthenticationReqRes
BtRqtBipConnect
BtRqtBipDisconnect
BtRqtBipAbort
BtRqtBipPutImage
BtRqtBipPutLinkedThumbnail
BtRqtBipPutLinkedAttachment
BtRqtBipGetImagesList
BtRqtBipGetImage
BtRqtBipGetLinkedThumbnail
BtRqtBipGetLinkedAttachment
BtRqtBipGetImageProperties
BtRqtBipDeleteImage
BtRqtBipGetImagingCapabilities

enum BtResultCode

Result codes for Bluetooth stack operations.

When the Bluetooth C-API receives a operation for execution, it returns a value that describes state of the submitted operation. BtResult is an enumeration type that describes this state.
This state is found in two places. On the one side it is the return code of member functions, on the ohter hand it is found in the additional data that is embedded in the various result messages sent back from the Bluetooth stack to APOXI. The possible return values of the various member functions also depend on the kind of execution: Synchronous or asynchonous.

Enumerator:
BtRcAccepted
BtRcPending
BtRcOk
BtRcRejected
BtRcIgnored
BtRcError
BtRcUnknown

enum BtSecuritySettings

Enumerator:
BtSesNoSecurity
BtSesAuthentication
BtSesAuthenticationEncryption
BtSesAuthenticationAuthorization
BtSesAuthenticationEncryptionAuthorization
BtSesAlwaysAuthenticatedTrustedDevices
BtSesAuthorizationAlwaysAuthenticatedTrustedDevices
BtSesAuthorization

enum BtStackState

Current state of Bluetooth stack.

Enumerator:
BtSsNotInitialized
BtSsInitialized
BtSsOn
BtSsOff
BtSsError
BtSsNoState

enum BtUuidType

Types for UUID witdthes.

Enumerator:
BtUuid16 | 16 Bit UUID
BtUuid32 | 32 Bit UUID
BtUuid128 | 128 Bit UUID

Function Documentation

void BtBipImageProperties::AddAttachment | ( | ApoxiMimeTypeId | mime_type,
 |  | const String & | charset,
 |  | const String & | name,
 |  | UINT32 | size,
 |  | const DateTime & | created,
 |  | const DateTime & | modified
 | ) | [inherited]

void BtBipImageProperties::AddAttachment ( const BtBipAttachmentPtr & attach ) [inline, inherited]

void BtBipImagingCapabilities::AddAttachmentFormat | ( | ApoxiMimeTypeId | mime_type,
 |  | const String & | charset
 | ) | [inherited]

void BtBipImagingCapabilities::AddAttachmentFormat ( const BtBipAttachmentFormatPtr & format ) [inline, inherited]

void BtBipImageList::AddImage | ( | const BtBipImageHdlPtr & | handle,
 |  | const DateTime & | created,
 |  | const DateTime & | modified
 | ) | [inherited]

void BtBipImageList::AddImage ( const BtBipImagePtr & image ) [inherited]

void BtBipImagingCapabilities::AddImageFormat | ( | BtBipEncoding | ,
 |  | UINT16 | res_x,
 |  | UINT16 | res_y,
 |  | UINT32 | max_size
 | ) | [inherited]

void BtBipImagingCapabilities::AddImageFormat ( const BtBipImageFormatPtr & format ) [inline, inherited]

void BtBipImageProperties::AddVariant | ( | BtBipEncoding | encoding,
 |  | UINT16 | min_width,
 |  | UINT16 | min_height,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height,
 |  | UINT32 | max_size,
 |  | BtBipTransformation | transformation
 | ) | [inherited]

void BtBipImageProperties::AddVariant | ( | BtBipEncoding | encoding,
 |  | UINT16 | min_width,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height,
 |  | UINT32 | max_size,
 |  | BtBipTransformation | transformation
 | ) | [inherited]

void BtBipImageProperties::AddVariant | ( | BtBipEncoding | encoding,
 |  | UINT16 | width,
 |  | UINT16 | height,
 |  | UINT32 | max_size,
 |  | BtBipTransformation | transformation
 | ) | [inherited]

void BtBipImageProperties::AddVariant ( const BtBipImageFormatPtr & fmt ) [inline, inherited]

String BtBipImageHdl::AsString ( ) [inline, inherited]

BtAvrcpNotificationMessage::BtAvrcpNotificationMessage ( const BtAvrcpNotificationMessage & message ) [inherited]

Constructor.

BtAvrcpNotificationMessage::BtAvrcpNotificationMessage | ( | BtAvrcpOperationService * | service,
 |  | StackMsgArgument * | argument = 0
 | ) | [inherited]

Constructor.

BtAvrcpNotificationMessage::BtAvrcpNotificationMessage ( StackMsgArgument * argument = 0 ) [inherited]

Constructor.

BtAvrcpOperationServiceMessage::BtAvrcpOperationServiceMessage ( const BtAvrcpOperationServiceMessage & message ) [inherited]

Constructor.

BtAvrcpOperationServiceMessage::BtAvrcpOperationServiceMessage | ( | BtAvrcpOperationService * | service,
 |  | StackMsgArgument * | argument = 0
 | ) | [inherited]

Constructor.

BtAvrcpOperationServiceMessage::BtAvrcpOperationServiceMessage ( StackMsgArgument * argument = 0 ) [inherited]

Constructor.

BtBipImageList::BtBipImageList ( ) [inherited]

BtBipImagingCapabilities::BtBipImagingCapabilities ( ) [inherited]

BtHfNotificationMessage::BtHfNotificationMessage ( const BtHfNotificationMessage & message ) [inherited]

Constructor.

BtHfNotificationMessage::BtHfNotificationMessage ( StackMsgArgument * argument = 0 ) [inherited]

Constructor.

BtHsNotificationMessage::BtHsNotificationMessage ( const BtHsNotificationMessage & message ) [inherited]

Constructor.

BtHsNotificationMessage::BtHsNotificationMessage ( StackMsgArgument * argument = 0 ) [inherited]

Constructor.

BtObexClientNotificationMessage::BtObexClientNotificationMessage ( const BtObexClientNotificationMessage & message ) [inherited]

Constructor.

BtObexClientNotificationMessage::BtObexClientNotificationMessage | ( | BtObexClientService * | service,
 |  | StackMsgArgument * | argument = 0
 | ) | [inherited]

Constructor.

BtObexServerNotificationMessage::BtObexServerNotificationMessage ( const BtObexServerNotificationMessage & message ) [inherited]

Constructor.

BtObexServerNotificationMessage::BtObexServerNotificationMessage | ( | BtObexServerService * | service,
 |  | StackMsgArgument * | argument = 0
 | ) | [inherited]

Constructor.

BtOperationBase::BtOperationBase ( ) [inherited]

Constructor.

BtOperationSelectDevice::BtOperationSelectDevice ( const BtDeviceFilter & device_filter = BtDeviceFilter() ) [inherited]

Constructor.

BtOperationSelectDeviceAndPerformServiceVerify::BtOperationSelectDeviceAndPerformServiceVerify ( ) [inherited]

Constructor.

Message * BtObexClientNotificationMessage::Clone ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

Message * BtObexServerNotificationMessage::Clone ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

Message * BtHsNotificationMessage::Clone ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

Message * BtHfNotificationMessage::Clone ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

Message * BtAvrcpOperationServiceMessage::Clone ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

Message * BtAvrcpNotificationMessage::Clone ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

BOOLEAN ConvertUtf8ToWString | ( | const CHAR * | utf_char_pointer,
 |  | WString & | w_string
 | ) |

Convert UTF-8 character array to WString object.

The character coding for Bluetooth is UTF-8. This means that all strings are transmitted in the UTF-8 character set. To enable APOXI, which works with unicode strings, a normal string treatment this functions performs a conversion from an UTF-8 character array to an Unicode WString.

Parameters:
utf_char_pointer | Pointer to a CHAR containing the UTF-8 coded character array that should be converted.
w_string | A reference to a WString, where to store the converted character array.
Returns:
TRUE: The conversion worked and w_string can be used.
FALSE: The conversion failed, do not use the w_string returned.

void BtBipImageHdl::CreateImageHdl | ( | UINT32 | id,
 |  | BtBipImageHdlPtr & | hdl_ptr
 | ) | [static, inherited]

Create a new image handle, unique between two reboots.

Parameters:
hdl_ptr Shared pointer to BtBipImageHdl, filled with the new handle
Returns:
FALSE if no new handle could be created (most likely all 9999998 available handles have been used)

void ExtendUuidTo128Bit | ( | const BtUUID & | uuid_base,
 |  | BtUUID & | uuid_128
 | ) |

const BtBipAttachmentList& BtBipImageProperties::GetAttachmentList ( ) const [inline, inherited]

const BtAttributeId * BtOperationSelectDeviceAndPerformServiceVerify::GetAttributesRequested ( ) const [inherited]

const String& BtBipAttachmentDesc::GetCharset ( ) const [inline, inherited]

const String& BtBipAttachment::GetCharset ( ) [inline, inherited]

const String& BtBipAttachmentFormat::GetCharset ( ) const [inline, inherited]

const DateTime& BtBipAttachmentDesc::GetCreated ( ) const [inline, inherited]

const DateTime& BtBipImage::GetCreated ( ) const [inline, inherited]

const DateTime& BtBipAttachment::GetCreateDate ( ) [inline, inherited]

const DateTime& BtBipImageHdlDesc::GetCreatedFrom ( ) const [inline, inherited]

const DateTime& BtBipImageHdlDesc::GetCreatedTo ( ) const [inline, inherited]

const BtDevice & BtOperationSelectDeviceAndPerformServiceVerify::GetDevice ( ) const [inherited]

const BtDevice & BtOperationSelectDevice::GetDevice ( ) const [inherited]

const BtDeviceFilter & BtOperationSelectDeviceAndPerformServiceVerify::GetDeviceFilter ( ) const [inherited]

const BtDeviceFilter & BtOperationSelectDevice::GetDeviceFilter ( ) const [inherited]

BtDeviceRelation BtOperationSelectDeviceAndPerformServiceVerify::GetDeviceRelation ( ) const [inherited]

UINT8 BtBipImagingCapabilities::GetDpofOptions ( ) const [inline, inherited]

BtBipEncoding BtBipImageHdlDesc::GetEncoding ( ) const [inline, inherited]

BtBipEncoding BtBipImageDesc::GetEncoding ( ) const [inline, inherited]

BtBipEncoding BtBipImageFormat::GetEncoding ( ) const [inline, inherited]

BtOperationBase::BtErrorReason BtOperationBase::GetErrorReason ( ) const [inherited]

UINT8 BtBipImagingCapabilities::GetFilterParams ( ) const [inline, inherited]

const BtBipImageFormat::ImageDim& BtBipImageHdlDesc::GetImageDim ( ) const [inline, inherited]

void BtBipImageHdlDesc::GetImageDim ( BtBipImageFormat::ImageDim & dim ) const [inline, inherited]

const BtBipImageFormat::ImageDim& BtBipImageDesc::GetImageDim ( ) const [inline, inherited]

void BtBipImageDesc::GetImageDim ( BtBipImageFormat::ImageDim & dim ) const [inline, inherited]

const ImageDim& BtBipImageFormat::GetImageDim ( ) const [inline, inherited]

void BtBipImageFormat::GetImageDim ( ImageDim & dim ) const [inline, inherited]

Gets a variable dimension with fixed aspect ratio.

const BtBipImageHdlPtr& BtBipImageProperties::GetImageHdl ( ) const [inline, inherited]

const BtBipImageHdlPtr& BtBipImage::GetImageHdl ( ) const [inline, inherited]

const ImageList& BtBipImageList::GetImageList ( ) const [inline, inherited]

const String& BtBipImageProperties::GetImageName ( ) const [inline, inherited]

UINT32 BtBipImageDesc::GetImageSize ( ) const [inline, inherited]

UINT32 BtBipImageDesc::GetMaxImageSize ( ) const [inline, inherited]

UINT32 BtBipImageFormat::GetMaxImageSize ( ) const [inline, inherited]

Gets maximum image size in bytes.

const MsgMetaData & BtObexClientNotificationMessage::GetMetaData ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

const MsgMetaData & BtObexServerNotificationMessage::GetMetaData ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

const MsgMetaData & BtHsNotificationMessage::GetMetaData ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

const MsgMetaData & BtHfNotificationMessage::GetMetaData ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

const MsgMetaData & BtAvrcpOperationServiceMessage::GetMetaData ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

const MsgMetaData & BtAvrcpNotificationMessage::GetMetaData ( ) const [virtual, inherited]

Reimplemented from FromStackMsg.

ApoxiMimeTypeId BtBipAttachmentDesc::GetMimeType ( ) const [inline, inherited]

ApoxiMimeTypeId BtBipAttachment::GetMimeType ( ) [inline, inherited]

ApoxiMimeTypeId BtBipAttachmentFormat::GetMimeType ( ) const [inline, inherited]

const DateTime& BtBipImage::GetModified ( ) const [inline, inherited]

const DateTime& BtBipImageHdlDesc::GetModifiedFrom ( ) const [inline, inherited]

const DateTime& BtBipImageHdlDesc::GetModifiedTo ( ) const [inline, inherited]

const DateTime& BtBipAttachment::GetModifyDate ( ) [inline, inherited]

const String& BtBipAttachmentDesc::GetName ( ) const [inline, inherited]

const String& BtBipAttachment::GetName ( ) [inline, inherited]

BtBipEncoding BtBipImageProperties::GetNativeEncoding ( ) const [inline, inherited]

const BtBipImageFormat& BtBipImageProperties::GetNativeFormat ( ) const [inline, inherited]

UINT16 BtBipImageProperties::GetNativeHeight ( ) const [inline, inherited]

UINT32 BtBipImageProperties::GetNativeSize ( ) const [inline, inherited]

UINT16 BtBipImageProperties::GetNativeWidth ( ) const [inline, inherited]

UINT8 BtOperationSelectDeviceAndPerformServiceVerify::GetNumberOfAttributesRequested ( ) const [inherited]

UINT8 BtOperationSelectDeviceAndPerformServiceVerify::GetNumberOfServicesToVerify ( ) const [inherited]

BtOperationType BtOperationSelectDeviceAndPerformServiceVerify::GetOperationType ( ) const [virtual, inherited]

Implements BtOperationBase.

BtOperationType BtOperationSelectDevice::GetOperationType ( ) const [virtual, inherited]

Implements BtOperationBase.

virtual BtOperationType BtOperationBase::GetOperationType ( ) const [pure virtual, inherited]

Implemented in BtOperationSelectDevice, and BtOperationSelectDeviceAndPerformServiceVerify.

BtBipEncoding BtBipImagingCapabilities::GetPrefEncoding ( ) const [inline, inherited]

const BtBipImageFormat& BtBipImagingCapabilities::GetPreferredFormat ( ) const [inline, inherited]

UINT16 BtBipImagingCapabilities::GetPrefMaxHeight ( ) const [inline, inherited]

UINT32 BtBipImagingCapabilities::GetPrefMaxSize ( ) const [inline, inherited]

UINT16 BtBipImagingCapabilities::GetPrefMaxWidth ( ) const [inline, inherited]

UINT16 BtBipImagingCapabilities::GetPrefMinHeight ( ) const [inline, inherited]

UINT16 BtBipImagingCapabilities::GetPrefMinWidth ( ) const [inline, inherited]

UINT16 BtBipImagingCapabilities::GetPrefTransformation ( ) const [inline, inherited]

BtResultCode BtOperationBase::GetResult ( ) const [inherited]

BtObexClientService * BtObexClientNotificationMessage::GetService ( ) const [inherited]

BtObexServerService * BtObexServerNotificationMessage::GetService ( ) const [inherited]

BtAvrcpOperationService * BtAvrcpOperationServiceMessage::GetService ( ) const [inherited]

BtAvrcpOperationService * BtAvrcpNotificationMessage::GetService ( ) const [inherited]

const BtUUID * BtOperationSelectDeviceAndPerformServiceVerify::GetServiceToVerify ( ) const [inherited]

const BtServiceVerifyResult & BtOperationSelectDeviceAndPerformServiceVerify::GetServiceVerifyResult ( ) const [inherited]

UINT32 BtBipAttachmentDesc::GetSize ( ) const [inline, inherited]

UINT32 BtBipAttachment::GetSize ( ) [inline, inherited]

const BtBipAttachmentFormatList& BtBipImagingCapabilities::GetSupportedAttachmentFormatList ( ) const [inline, inherited]

const BtBipImageFormatList& BtBipImagingCapabilities::GetSupportedImageFormatList ( ) const [inline, inherited]

BtBipTransformation BtBipImageDesc::GetTransformation ( ) const [inline, inherited]

BtBipTransformation BtBipImageFormat::GetTransformation ( ) const [inline, inherited]

Get transformation.

const BtBipVariantList& BtBipImageProperties::GetVariantList ( ) const [inline, inherited]

BOOLEAN BtBipImagingCapabilities::IsDpofOptionSupported ( UINT8 dpof_options ) const [inline, inherited]

BOOLEAN BtBipImagingCapabilities::IsFilterSupported ( UINT8 filter ) const [inline, inherited]

virtual void BtOperationBase::OnResult ( BtResultCode result ) [protected, pure virtual, inherited]

Implemented in BtObexClientAddrResultNotifier.

BOOLEAN operator!= | ( | const BtObexServiceTable::ServiceInfo & | lhs,
 |  | const BtObexServiceTable::ServiceInfo & | rhs
 | ) | [inline]

BOOLEAN operator!= | ( | const BtUUID & | left_value,
 |  | const BtUUID & | right_value
 | ) |

BOOLEAN operator!= | ( | const BtSvrDataElement & | left_value,
 |  | const BtSvrDataElement & | right_value
 | ) |

BtObexClientNotificationMessage & BtObexClientNotificationMessage::operator= ( const BtObexClientNotificationMessage & message ) [virtual, inherited]

FromStackMsg & BtObexClientNotificationMessage::operator= ( const FromStackMsg & message ) [virtual, inherited]

Reimplemented from FromStackMsg.

BtObexServerNotificationMessage & BtObexServerNotificationMessage::operator= ( const BtObexServerNotificationMessage & message ) [virtual, inherited]

FromStackMsg & BtObexServerNotificationMessage::operator= ( const FromStackMsg & message ) [virtual, inherited]

Reimplemented from FromStackMsg.

BtHsNotificationMessage & BtHsNotificationMessage::operator= ( const BtHsNotificationMessage & message ) [virtual, inherited]

FromStackMsg & BtHsNotificationMessage::operator= ( const FromStackMsg & message ) [virtual, inherited]

Reimplemented from FromStackMsg.

BtHfNotificationMessage & BtHfNotificationMessage::operator= ( const BtHfNotificationMessage & message ) [virtual, inherited]

FromStackMsg & BtHfNotificationMessage::operator= ( const FromStackMsg & message ) [virtual, inherited]

Reimplemented from FromStackMsg.

BtAvrcpOperationServiceMessage & BtAvrcpOperationServiceMessage::operator= ( const BtAvrcpOperationServiceMessage & message ) [virtual, inherited]

FromStackMsg & BtAvrcpOperationServiceMessage::operator= ( const FromStackMsg & message ) [virtual, inherited]

Reimplemented from FromStackMsg.

BtAvrcpNotificationMessage & BtAvrcpNotificationMessage::operator= ( const BtAvrcpNotificationMessage & message ) [virtual, inherited]

FromStackMsg & BtAvrcpNotificationMessage::operator= ( const FromStackMsg & message ) [virtual, inherited]

Reimplemented from FromStackMsg.

BOOLEAN operator== | ( | const BtObexServiceTable::ServiceInfo & | lhs,
 |  | const BtObexServiceTable::ServiceInfo & | rhs
 | ) | [inline]

BOOLEAN operator== | ( | const BtUUID & | left_value,
 |  | const BtUUID & | right_value
 | ) |

BOOLEAN operator== | ( | const BtSvrDataElement & | left_value,
 |  | const BtSvrDataElement & | right_value
 | ) |

BOOLEAN BtOperationSelectDeviceAndPerformServiceVerify::SetAttributesRequested | ( | const BtAttributeId * | attributes_requested,
 |  | UINT8 | number_of_attributes_requested
 | ) | [inherited]

void BtBipAttachmentDesc::SetCharset ( const String & charset ) [inline, inherited]

void BtBipAttachment::SetCharset ( const String & charset ) [inline, inherited]

void BtBipAttachmentFormat::SetCharset ( const String & charset ) [inline, inherited]

void BtBipAttachmentDesc::SetCreateDate ( const DateTime & date ) [inline, inherited]

void BtBipAttachment::SetCreateDate ( const DateTime & date ) [inline, inherited]

void BtBipImage::SetCreatedDate ( const DateTime & created ) [inline, inherited]

void BtBipImageHdlDesc::SetCreatedFrom ( const DateTime & from ) [inline, inherited]

void BtBipImageHdlDesc::SetCreatedFrom | ( | UINT16 | year,
 |  | UINT16 | month,
 |  | UINT16 | day,
 |  | UINT16 | hour = 0,
 |  | UINT16 | minute = 0,
 |  | UINT16 | second = 0
 | ) | [inherited]

void BtBipImageHdlDesc::SetCreatedTo ( const DateTime & to ) [inline, inherited]

void BtBipImageHdlDesc::SetCreatedTo | ( | UINT16 | year,
 |  | UINT16 | month,
 |  | UINT16 | day,
 |  | UINT16 | hour = 23,
 |  | UINT16 | minut = 59,
 |  | UINT16 | second = 59
 | ) | [inherited]

void BtOperationSelectDeviceAndPerformServiceVerify::SetDevice ( const BtDevice & device ) [inherited]

void BtOperationSelectDevice::SetDevice ( const BtDevice & device ) [inherited]

void BtOperationSelectDeviceAndPerformServiceVerify::SetDeviceFilter ( const BtDeviceFilter & device_filter ) [inherited]

void BtOperationSelectDevice::SetDeviceFilter ( const BtDeviceFilter & device_filter ) [inherited]

void BtOperationSelectDeviceAndPerformServiceVerify::SetDeviceReleation ( BtDeviceRelation device_relation ) [inherited]

void BtBipImagingCapabilities::SetDpofOptions ( UINT8 dpof_options ) [inline, inherited]

void BtBipImageHdlDesc::SetEncoding ( BtBipEncoding encoding ) [inline, inherited]

void BtBipImageFormat::SetEncoding ( BtBipEncoding encoding ) [inline, inherited]

void BtOperationBase::SetErrorReason ( BtErrorReason error_reason ) [inherited]

void BtBipImagingCapabilities::SetFilterParamters ( UINT8 filter_params ) [inline, inherited]

void BtBipImageProperties::SetFriendlyName ( const String & name ) [inline, inherited]

void BtBipImageHdlDesc::SetImageDim | ( | UINT16 | min_width,
 |  | UINT16 | min_height,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height
 | ) | [inline, inherited]

void BtBipImageHdlDesc::SetImageDim | ( | UINT16 | min_width,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height
 | ) | [inline, inherited]

void BtBipImageHdlDesc::SetImageDim | ( | UINT16 | width,
 |  | UINT16 | height
 | ) | [inline, inherited]

void BtBipImageDesc::SetImageDim | ( | UINT16 | min_width,
 |  | UINT16 | min_height,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height
 | ) | [inline, inherited]

void BtBipImageDesc::SetImageDim | ( | UINT16 | min_width,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height
 | ) | [inline, inherited]

void BtBipImageDesc::SetImageDim | ( | UINT16 | width,
 |  | UINT16 | height
 | ) | [inline, inherited]

void BtBipImageFormat::SetImageDim | ( | UINT16 | min_width,
 |  | UINT16 | min_height,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height
 | ) | [inherited]

Sets fully variable dimension without respect to the aspect ratio.

void BtBipImageFormat::SetImageDim | ( | UINT16 | min_width,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height
 | ) | [inherited]

Sets a variable dimension with fixed aspect ratio.

void BtBipImageFormat::SetImageDim | ( | UINT16 | width,
 |  | UINT16 | height
 | ) | [inherited]

Sets a fixed dimension of an image.

void BtBipImageProperties::SetImageHandle ( const BtBipImageHdlPtr & hdl ) [inline, inherited]

void BtBipImage::SetImageHdl ( const BtBipImageHdlPtr & hdl ) [inline, inherited]

void BtBipImageDesc::SetImageSize ( UINT32 size ) [inline, inherited]

void BtBipImageDesc::SetMaxImageSize ( UINT32 max_size ) [inline, inherited]

void BtBipImageFormat::SetMaxImageSize ( UINT32 max_size ) [inline, inherited]

Sets maximum image size in bytes.

void BtBipAttachmentDesc::SetMimeType ( ApoxiMimeTypeId mime_type ) [inline, inherited]

void BtBipAttachment::SetMimeType ( ApoxiMimeTypeId mime_type ) [inline, inherited]

void BtBipAttachmentFormat::SetMimeType ( ApoxiMimeTypeId mime_type ) [inline, inherited]

void BtBipImage::SetModifiedDate ( const DateTime & modified ) [inline, inherited]

void BtBipImageHdlDesc::SetModifiedFrom ( const DateTime & from ) [inline, inherited]

void BtBipImageHdlDesc::SetModifiedFrom | ( | UINT16 | year,
 |  | UINT16 | month,
 |  | UINT16 | day,
 |  | UINT16 | hour,
 |  | UINT16 | minute,
 |  | UINT16 | second
 | ) | [inherited]

void BtBipImageHdlDesc::SetModifiedTo ( const DateTime & to ) [inline, inherited]

void BtBipImageHdlDesc::SetModifiedTo | ( | UINT16 | year,
 |  | UINT16 | month,
 |  | UINT16 | day,
 |  | UINT16 | hour,
 |  | UINT16 | minute,
 |  | UINT16 | second
 | ) | [inherited]

void BtBipAttachment::SetModifyDate ( const DateTime & date ) [inline, inherited]

void BtBipAttachmentDesc::SetName ( const String & name ) [inline, inherited]

void BtBipAttachment::SetName ( const String & name ) [inline, inherited]

void BtBipImageProperties::SetNativeDim | ( | UINT16 | width,
 |  | UINT16 | height
 | ) | [inline, inherited]

void BtBipImageProperties::SetNativeEncoding ( BtBipEncoding encoding ) [inline, inherited]

void BtBipImageProperties::SetNativeFormat ( const BtBipImageFormat & fmt ) [inline, inherited]

void BtBipImageProperties::SetNativeSize ( UINT32 size ) [inline, inherited]

void BtBipImagingCapabilities::SetPreferredFormat | ( | BtBipEncoding | encoding,
 |  | UINT16 | min_width,
 |  | UINT16 | min_height,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height,
 |  | BtBipTransformation | transformation,
 |  | UINT32 | max_size
 | ) | [inherited]

Set a range for the preferred image size with no resize to the aspect ratio.

void BtBipImagingCapabilities::SetPreferredFormat | ( | BtBipEncoding | encoding,
 |  | UINT16 | min_width,
 |  | UINT16 | max_width,
 |  | UINT16 | max_height,
 |  | BtBipTransformation | transformation,
 |  | UINT32 | max_size
 | ) | [inherited]

Set a range for the preferred image size with fixed aspect ration.

void BtBipImagingCapabilities::SetPreferredFormat | ( | BtBipEncoding | encoding,
 |  | UINT16 | width,
 |  | UINT16 | height,
 |  | BtBipTransformation | transformation,
 |  | UINT32 | max_size
 | ) | [inherited]

Set a fixed preferred image size.

void BtBipImagingCapabilities::SetPreferredFormat ( const BtBipImageFormat & format ) [inline, inherited]

void BtOperationBase::SetResult | ( | BtResultCode | result,
 |  | BtErrorReason | error_reason = BtErUnknown
 | ) | [inherited]

BOOLEAN BtOperationSelectDeviceAndPerformServiceVerify::SetServicesToVerify | ( | const BtUUID * | services_to_verify,
 |  | UINT8 | number_of_services_to_verify
 | ) | [inherited]

BOOLEAN BtOperationSelectDeviceAndPerformServiceVerify::SetServiceVerifyResult ( const BtServiceVerifyResult & service_verify_result ) [inherited]

void BtBipAttachmentDesc::SetSize ( UINT32 size ) [inline, inherited]

void BtBipAttachment::SetSize ( UINT32 size ) [inline, inherited]

void BtBipImageDesc::SetTransformation ( BtBipTransformation transformation ) [inline, inherited]

void BtBipImageFormat::SetTransformation ( BtBipTransformation transformation ) [inline, inherited]

BtProfile ToProfile ( btapi_profile_t profile )

Convert stack profile type to APOXI profile type.

Some parameters to stack functions also as paramters to stack callback functions contain the type of profile. To and From the stack there is the C-API related type btapi_profile_t required. In APOXI the type BtProfile is used. The function ToProfile performs the task of converting the stack type to the APOXI type.

Parameters:
profile

BtResultCode ToResultCode ( btapi_result_t result )

Convert stack result code to APOXI result code.

The result parameter of the stack callback functions is the stack defined C-API type btapi_result_t. To enable further processing this result code must be converted to the APOXI defined type BtResultCode. This task is performed by ToResultCode. result A btapi_result_t containing the C-API result code, that should be converted to the APOXI result code.

Returns:
A BtResultCode containing the APOXI representation of the passed in C-API result code.

BtAvrcpNotificationMessage::~BtAvrcpNotificationMessage ( ) [virtual, inherited]

Destructor.

BtAvrcpOperationServiceMessage::~BtAvrcpOperationServiceMessage ( ) [virtual, inherited]

Destructor.

BtBipAttachmentDesc::~BtBipAttachmentDesc ( ) [inherited]

BtBipAttachmentFormat::~BtBipAttachmentFormat ( ) [inherited]

BtBipImage::~BtBipImage ( ) [virtual, inherited]

BtBipImageHdlDesc::~BtBipImageHdlDesc ( ) [virtual, inherited]

BtBipImageList::~BtBipImageList ( ) [virtual, inherited]

BtBipImagingCapabilities::~BtBipImagingCapabilities ( ) [inherited]

BtHfNotificationMessage::~BtHfNotificationMessage ( ) [virtual, inherited]

Destructor.

BtHsNotificationMessage::~BtHsNotificationMessage ( ) [virtual, inherited]

Destructor.

BtObexClientNotificationMessage::~BtObexClientNotificationMessage ( ) [virtual, inherited]

Destructor.

BtObexServerNotificationMessage::~BtObexServerNotificationMessage ( ) [virtual, inherited]

Destructor.

BtOperationBase::~BtOperationBase ( ) [virtual, inherited]

Destructor.

BtOperationSelectDevice::~BtOperationSelectDevice ( ) [virtual, inherited]

Destructor.

BtOperationSelectDeviceAndPerformServiceVerify::~BtOperationSelectDeviceAndPerformServiceVerify ( ) [virtual, inherited]

Destructor.

Variable Documentation

const BtDeviceAddress bt_c_empty_device_address

bt_c_empty_device_address represents an invalid device address

const BtDeviceList bt_c_empty_device_list

const BtDevice bt_c_unknown_device

const UINT16 c_bip_client_read_buf_size

BIP Client Service (image initiator).

This class provides all functionality to act as an imaging initiator for BIP. Currently the scenarios of Image Push and Image Pull are supported. Pls. see also the Bluetooth specification for the Basic Imaging Profile. User of this class have to override the OnRequestStateChanged() method. This method is called, whenever a request changes its state. If the request is finished, the result data can be retrieved using the according getter methods.

const int c_bip_invalid_res

Result of OBEX operation used for BIP operation.

const UINT32 c_bip_max_image_hdl

UINT8 BtAvrcpSubunitInfoEntry::m_max_subunit_id [inherited]

UINT16 BtBipImageFormat::ImageDim::max_height [inherited]

UINT16 BtBipImageFormat::ImageDim::max_width [inherited]

UINT16 BtBipImageFormat::ImageDim::min_height [inherited]

Generated on Wed Jan 25 02:29:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IRDA

IRDA

Generated on Wed Jan 25 02:29:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Kernel

Kernel

Collaboration diagram for Kernel:

Modules

Operating System

Data Structures

class | _ApplicationTracer
class | _FunctionTracer< mask >
class | _NullApplicationTracer
class | _NullFunctionTracer
class | AbstractAppContext
class | AbstractExternalData
class | AbstractMessageMapContainer
class | AbstractScheduler
class | ActiveWaitDispatcher
class | AlarmManager
class | Allocator< T >
class | ApoxiThread
class | AppContainer
class | AppContainerRoutingTableEntry
class | Application
class | ApplicationListEntry
class | AppRoutingTableEntry
class | BooleanCondition
class | BufferedOutputStream
struct | CharInputMapEntry
class | CharInputMapItem
class | Condition
class | ContextMsg
class | ControlMsg
class | DebugOutputStream
class | Dispatcher
class | DispatcherAction
class | FileInputStream
class | FileOutputStream
class | FocusObtainer
class | GenericWorkerTask
class | HeapManager
class | HeapVector
struct | InputMap
struct | InputMapEntry
class | InputMapItem
class | InputStream
struct | KeyDownInputMapEntry
class | KeyDownInputMapItem
struct | KeyUpInputMapEntry
class | KeyUpInputMapItem
class | Message
class | MessageHook
struct | MessageMap< T >
class | MessageMapContainer< T >
class | MessageMapDispatcher
class | MessageReferrer
class | MessageRouter
struct | MsgMetaData
class | MsgQueue
class | OutputStream
class | ServiceThread
Class ServiceThread is used to implement services, i.e. tasks which perform permanent background activity like network services. A service thread does not need any graphical user interface but needs to run as an own thread. It only always awakes from idle when it receives a message or when a timer expires. To handle the message overwrite method OnMessage(). For an automated start-up and shut-down of the service thread use class ServiceThreadStarter. More...
class | ServiceThreadStarter
class | SharedTimer
class | SharedTriggerTimer< T >
class | SimpleAppContext
class | SimpleScheduler
class | SubSystem
class | SubSystemManager
class | SyncPhoneThreadlet
class | System
class | Threadlet
class | TimeoutCondition
class | Timer
class | TraceOutputStream
class | UibUpdateThreadlet
class | UserDispatcher
class | VersionInfo

Defines

#define | APOXI_ALARMMANAGER_MAX_ENTRIES 10
#define | APOXI_APPLICATION_TRACER_MAX_APPS 50
#define | APOXI_HEAP_LENGTH_VECTOR
#define | APOXI_HEAP_MEM_ACCESS_CHECK
#define | APOXI_HEAP_MEM_ALLOCS_PER_SIZE
#define | APOXI_HEAP_MEM_DETECT_CONFIG
#define | APOXI_HEAP_NAME(name)
#define | APOXI_HEAP_NAME_PTR(name)
#define | APOXI_TRACE
#define | ApoxiDefVersionInfo(subsys, ver, flags)
#define | ApoxiUseVersionInfo(subsys)
#define | BLOCK_HEAP_CONTEXT_VECTOR(name, size, high)
#define | BLOCK_HEAP_PAGE(name, size, low, high)
#define | BLOCK_HEAP_SIZE_VECTOR(name, size, high) static UINT16 m_size_vector_##name[(size / high)+1];
#define | GET_HEAP_TABLE() & m_heap_table[0];
#define | HEAP_BYTES_PER_UINT sizeof(UINT)
#define | HEAP_CONTEXT_VECTOR_PTR(name)
#define | HEAP_ENTRY(heapname, id)
#define | HEAP_SIZE_VECTOR_PTR(name) m_size_vector_##name,
#define | HEAP_STAT_STRUCT_VALUES
#define | HEAP_TABLE_BEGIN() static HeapVector::HeapTableEntry m_heap_table[] = {
#define | HEAP_TABLE_END { 0, 0 } };
#define | HUGE_HEAP_PAGE(name, size, blocksize, low, high)
#define | NO_CHECK_BYTES 4
#define | PAGE_ENTRY(name) (HeapVector::Page*)& name,
#define | PAGE_TABLE_BEGIN(heapname) static HeapVector::Page * m_pages_##heapname[] = {
#define | PAGE_TABLE_END 0 };
#define | VAR_HEAP_CONTEXT_VECTOR(name, size, blocksize)
#define | VAR_HEAP_PAGE(name, size, blocksize, low, high)
#define | VAR_HEAP_SIZE_VECTOR(name, size, blocksize) static UINT32 m_size_vector_##name[(size / blocksize)+1];
#define | VIRTUAL_HEAP_ENTRY(heapname, id, virtid, size)

Typedefs

typedef _FunctionTracer< InternalTracer::Adc > | AdcTracer
typedef _NullFunctionTracer | AdcTracerLevel2
typedef _NullFunctionTracer | AdcTracerLevel3
typedef _FunctionTracer< InternalTracer::Apc > | ApcTracer
typedef _NullFunctionTracer | ApcTracerLevel2
typedef _NullFunctionTracer | ApcTracerLevel3
typedef void(* | ApoxiNewHandlerFn )()
typedef _FunctionTracer< InternalTracer::App1 > | App1Tracer
typedef _NullFunctionTracer | App1TracerLevel2
typedef _NullFunctionTracer | App1TracerLevel3
typedef _FunctionTracer< InternalTracer::App2 > | App2Tracer
typedef _NullFunctionTracer | App2TracerLevel2
typedef _NullFunctionTracer | App2TracerLevel3
typedef _FunctionTracer< InternalTracer::App3 > | App3Tracer
typedef _NullFunctionTracer | App3TracerLevel2
typedef _NullFunctionTracer | App3TracerLevel3
typedef _FunctionTracer< InternalTracer::App4 > | App4Tracer
typedef _NullFunctionTracer | App4TracerLevel2
typedef _NullFunctionTracer | App4TracerLevel3
typedef HashTable | AppContainerRoutingTable
typedef ElementList< ApplicationListEntry > | AppElemList
typedef ContextMsg | ApplicationMsg
For backwards compatibility only.
typedef LinkedList< AppRoutingTableEntry > | AppRoutingTable
typedef _ApplicationTracer | AppTracer
typedef _FunctionTracer< InternalTracer::Asc > | AscTracer
typedef _NullFunctionTracer | AscTracerLevel2
typedef _NullFunctionTracer | AscTracerLevel3
typedef _FunctionTracer< InternalTracer::Aux > | AuxTracer
typedef _NullFunctionTracer | AuxTracerLevel2
typedef _NullFunctionTracer | AuxTracerLevel3
typedef LinkedList< DispatcherAction > | DispatcherActionList
typedef LinkedList< DispatcherAction > | DispatcherActionList
typedef _FunctionTracer< InternalTracer::Gui > | GuiTracer
typedef _NullFunctionTracer | GuiTracerLevel2
typedef _NullFunctionTracer | GuiTracerLevel3
typedef _FunctionTracer< InternalTracer::Kernel > | KernelTracer
typedef _NullFunctionTracer | KernelTracerLevel2
typedef _NullFunctionTracer | KernelTracerLevel3
typedef InputMapItem::MapItemType | MapItemType
typedef _FunctionTracer< InternalTracer::Mmi > | MmiTracer
typedef _NullFunctionTracer | MmiTracerLevel2
typedef _NullFunctionTracer | MmiTracerLevel3
typedef UINT16 | MsgCategory
typedef UINT16 | MsgId
typedef void(* | NewHandlerFn )()
typedef _FunctionTracer< InternalTracer::Socket > | SocketTracer
typedef _NullFunctionTracer | SocketTracerLevel2
typedef _NullFunctionTracer | SocketTracerLevel3
typedef SortedLinkedList<
Timer > 		TimerList
typedef _FunctionTracer< InternalTracer::Always > | Tracer

Enumerations

enum | MsgOrigin { externalMsg, internalMsg }

Functions

template<class DestClassPointer>
void | CastMsg (DestClassPointer &dest_msg, const Message *src_msg)
void | SharedTriggerTimer::Init (T *t, UINT32 timeout, BOOLEAN autotimer=FALSE)
virtual void | SharedTriggerTimer::OnTimer ()
void | operator delete (void *, void *)
void | operator delete (void *p)
void * | operator new (size_t, void *p)
void * | operator new (size_t size)
SharedTriggerTimer::SharedTriggerTimer (T *t, UINT32 timeout, BOOLEAN autotimer=FALSE)
SharedTriggerTimer::SharedTriggerTimer ()
size_t | strlen (const char *string)
void | TestHeaps ()
template<class T>
void | TraceDataHelper (InternalTracer::TraceMask mask, const void *linkreg, T *obj)
virtual | SharedTriggerTimer::~SharedTriggerTimer ()

Variables

ApoxiNewHandlerFn ApoxiNewHandler
const InputMapControlId | c_abstract_menu_list_imid = 5
const INT | c_alarm_manager_max_entries = APOXI_ALARMMANAGER_MAX_ENTRIES
const InputMapId | c_Cancel_imid = 4
const InputMapControlId | c_check_box_imid = 2
const InputMapControlId | c_check_box_list_imid = 7
const InputMapId | c_CheckBoxChangeStatus_imid = 40
const InputMapId | c_Confirm_imid = 3
const InputMapControlId | c_control_imid = 1
const InputMapControlId | c_edit_box_imid = 4
const InputMapId | c_EditBoxCursorDown_imid = 13
const InputMapId | c_EditBoxCursorLeft_imid = 11
const InputMapId | c_EditBoxCursorRight_imid = 10
const InputMapId | c_EditBoxCursorUp_imid = 12
const InputMapId | c_EditBoxDeleteCharacter_imid = 14
const InputMapId | c_EditBoxDtmfSeparator_imid = 50
const InputMapId | c_EditBoxPlus_imid = 51
const InputMapId | c_EditBoxShiftKey_imid = 15
const InputMapId | c_EditBoxWildcard_imid = 52
const InputMapId | c_FocusNextControl_imid = 1
const InputMapId | c_FocusPreviousControl_imid = 2
const InputMapControlId | c_grid_imid = 10
const InputMapId | c_GridMoveDown_imid = 63
const InputMapId | c_GridMoveLeft_imid = 60
const InputMapId | c_GridMoveRight_imid = 61
const InputMapId | c_GridMoveUp_imid = 62
const HeapVector::ContextId | c_invalid_context_id = ~0
const InputMapControlId | c_list_box_imid = 3
const InputMapId | c_ListBoxNextItem_imid = 21
const InputMapId | c_ListBoxPreviousItem_imid = 20
const InputMapId | c_MenuItemSelected_imid = 30
const InputMapControlId | c_push_button_imid = 9
const InputMapId | c_PushButtonClick_imid = 70
const InputMapId | c_PushButtonRelease_imid = 71
const InputMapControlId | c_radio_button_imid = 6
const InputMapControlId | c_radio_button_list_imid = 8
const InputMapId | c_RadioButtonNextItem_imid = 81
const InputMapId | c_RadioButtonPreviousItem_imid = 80
const HeapVector::FctTable | g_fcts_block_page
const HeapVector::FctTable | g_fcts_huge_page
const HeapVector::FctTable | g_fcts_var_page
const MsgCategory | MC_APP = MC_CONTEXT
const MsgCategory | MC_AT = 0x0080U
const MsgCategory | MC_BROADCAST = 0x0100U
const MsgCategory | MC_CONTEXT = 0x0002U
const MsgCategory | MC_CONTROL = 0x0004U
const MsgCategory | MC_FOCUS = 0x0008U
const MsgCategory | MC_IPC = 0x0020U
const MsgCategory | MC_NOT_VALID = 0U
const MsgCategory | MC_SIGNAL = 0x0040U
const MsgCategory | MC_STACK_CONTROL = 0x0010U
const MsgCategory | MC_SYSTEM = 0x0001U
const MsgCategory | MC_WIN = MC_CONTROL
NewHandlerFn NewHandler

Define Documentation

#define APOXI_ALARMMANAGER_MAX_ENTRIES 10

#define APOXI_APPLICATION_TRACER_MAX_APPS 50

#define APOXI_HEAP_LENGTH_VECTOR

#define APOXI_HEAP_MEM_ACCESS_CHECK

#define APOXI_HEAP_MEM_ALLOCS_PER_SIZE

#define APOXI_HEAP_MEM_DETECT_CONFIG

#define APOXI_HEAP_NAME ( name )

#define APOXI_HEAP_NAME_PTR ( name )

#define APOXI_TRACE

Three trace levels can be defined at compile time: APOXI_TRACE: Tracing is enabled, no Level 2 and 3 trace; enabled by default APOXI_TRACE_LEVEL_2: Tracer-Classes and Level2-Classes generate output APOXI_TRACE_LEVEL_3: Tracer-Classes, Level2- and Level3-Classes generate output

APOXI_TRACE_MEM: Only memory allocation and deallocation is traced

On default tracing level 1 is enabled (APOXI_TRACE). The switch APOXI_TRACE_DISABLED will disable tracing when set.

#define ApoxiDefVersionInfo | ( | subsys,
 |  | ver,
 |  | flags | )

Value:

static const VersionInfo::Data g_##subsys##_version_data = { (flags), #subsys, ver, __DATE__ " " __TIME__ }; \
    VersionInfo g_##subsys##_version_obj(&g_##subsys##_version_data) \
ApoxiDefVersionInfo defines a VersionInfo. Example: ApoxiDefVersionInfo(JavaVM, "1.5.2", VersionInfo::c_flag_hide_in_engineering_mode | VersionInfo::c_flag_add_to_trace_info); Use this Macro only in CPP files.

#define ApoxiUseVersionInfo ( subsys )

Value:

extern VersionInfo g_##subsys##_version_obj; \
    VersionInfo*  g_##subsys##_prt =& g_##subsys##_version_obj;
ApoxiUseVersionInfo creates a reference to a VersionInfo-Object. For each VersionInfo created with ApoxiDefVersionInfo this macro has to be placed in a CPP file which contains used code. This is necessary to have the Linker include it into the project

#define BLOCK_HEAP_CONTEXT_VECTOR | ( | name,
 |  | size,
 |  | high | )

#define BLOCK_HEAP_PAGE | ( | name,
 |  | size,
 |  | low,
 |  | high | )

Value:

const UINT c_add_bytes_##name = ((size / high)+1) * NO_CHECK_BYTES;     \
static UINT m_mem_##name[(size+c_add_bytes_##name)/HEAP_BYTES_PER_UINT];\
static UINT m_bits_##name[(size / high / HeapVector::BITS_PER_UINT)+1]; \
APOXI_HEAP_NAME(name)                                                   \
BLOCK_HEAP_SIZE_VECTOR(name, size, high)                                \
BLOCK_HEAP_CONTEXT_VECTOR(name, size, high)                             \
static HeapVector::BlockPage m_page_##name = {                          \
    (UINT8 *)&m_mem_##name[0],                                          \
    m_bits_##name,                                                      \
    0,                                                                  \
    HEAP_SIZE_VECTOR_PTR(name)                                          \
    HEAP_CONTEXT_VECTOR_PTR(name)                                       \
    TRUE                                                                \
    HEAP_STAT_STRUCT_VALUES                                             \
};                                                                      \
static const HeapVector::Page name = {                                  \
    FALSE,                                                              \
    APOXI_HEAP_NAME_PTR(name)                                           \
    high,                                                               \
    low,                                                                \
    high,                                                               \
    (UINT8 *)&m_mem_##name[0],                                          \
    ((UINT8 *)&m_mem_##name[0])+size+c_add_bytes_##name,                \
    size / high,                                                        \
    &g_fcts_block_page,                                                 \
    (HeapVector::Page*)&m_page_##name                                   \
};

#define BLOCK_HEAP_SIZE_VECTOR | ( | name,
 |  | size,
 |  | high | ) | static UINT16 m_size_vector_##name[(size / high)+1];

#define GET_HEAP_TABLE ( ) & m_heap_table[0];

#define HEAP_BYTES_PER_UINT sizeof(UINT)

#define HEAP_CONTEXT_VECTOR_PTR ( name )

#define HEAP_ENTRY | ( | heapname,
 |  | id | )

Value:

{                                       \
    (HeapVector::Page**)(HeapVector::Page*)& m_pages_##heapname[0],     \
    id,                                                                 \
    id,                                                                 \
    0,                                                                  \
    0,                                                                  \
    #heapname                                                           \
},

#define HEAP_SIZE_VECTOR_PTR ( name ) m_size_vector_##name,

#define HEAP_STAT_STRUCT_VALUES

#define HEAP_TABLE_BEGIN ( ) static HeapVector::HeapTableEntry m_heap_table[] = {

#define HEAP_TABLE_END { 0, 0 } };

#define HUGE_HEAP_PAGE | ( | name,
 |  | size,
 |  | blocksize,
 |  | low,
 |  | high | )

Value:

static UINT HUGE m_mem_##name[((size+blocksize)/HEAP_BYTES_PER_UINT)];  \
static UINT16 m_length_##name[(size/blocksize)+1];                      \
APOXI_HEAP_NAME(name)                                                   \
VAR_HEAP_SIZE_VECTOR(name, size, blocksize)                             \
VAR_HEAP_CONTEXT_VECTOR(name, size, blocksize)                          \
static HeapVector::VarPage m_page_##name = {                            \
    0,                                                                  \
    (UINT8 HUGE *)&m_mem_##name[0],                                     \
    ((UINT8 HUGE *)&m_mem_##name[0])+size,                              \
    m_length_##name,                                                    \
    0,                                                                  \
    HEAP_SIZE_VECTOR_PTR(name)                                          \
    HEAP_CONTEXT_VECTOR_PTR(name)                                       \
    TRUE                                                                \
    HEAP_STAT_STRUCT_VALUES                                             \
};                                                                      \
static const HeapVector::Page name = {                                  \
    TRUE,                                                               \
    APOXI_HEAP_NAME_PTR(name)                                           \
    blocksize,                                                          \
    low,                                                                \
    high,                                                               \
    0,                                                                  \
    0,                                                                  \
    size / blocksize,                                                   \
    &g_fcts_huge_page,                                                  \
    (HeapVector::Page*)&m_page_##name                                   \
};

#define NO_CHECK_BYTES 4

#define PAGE_ENTRY ( name ) (HeapVector::Page*)& name,

#define PAGE_TABLE_BEGIN ( heapname ) static HeapVector::Page * m_pages_##heapname[] = {

#define PAGE_TABLE_END 0 };

#define VAR_HEAP_CONTEXT_VECTOR | ( | name,
 |  | size,
 |  | blocksize | )

#define VAR_HEAP_PAGE | ( | name,
 |  | size,
 |  | blocksize,
 |  | low,
 |  | high | )

Value:

static UINT   m_mem_##name[(size/HEAP_BYTES_PER_UINT)];                 \
static UINT16 m_length_##name[(size / blocksize)+1];                    \
APOXI_HEAP_NAME(name)                                                   \
VAR_HEAP_SIZE_VECTOR(name, size, blocksize)                             \
VAR_HEAP_CONTEXT_VECTOR(name, size, blocksize)                          \
static HeapVector::VarPage m_page_##name = {                            \
    (UINT8 *)&m_mem_##name[0],                                          \
    0,                                                                  \
    0,                                                                  \
    m_length_##name,                                                    \
    0,                                                                  \
    HEAP_SIZE_VECTOR_PTR(name)                                          \
    HEAP_CONTEXT_VECTOR_PTR(name)                                       \
    TRUE                                                                \
    HEAP_STAT_STRUCT_VALUES                                             \
};                                                                      \
static const HeapVector::Page name = {                                  \
    FALSE,                                                              \
    APOXI_HEAP_NAME_PTR(name)                                           \
    blocksize,                                                          \
    low,                                                                \
    high,                                                               \
    (UINT8 *)&m_mem_##name[0],                                          \
    ((UINT8 *)&m_mem_##name[0])+size,                                   \
    size / blocksize,                                                   \
    &g_fcts_var_page,                                                   \
    (HeapVector::Page*)&m_page_##name                                   \
};

#define VAR_HEAP_SIZE_VECTOR | ( | name,
 |  | size,
 |  | blocksize | ) | static UINT32 m_size_vector_##name[(size / blocksize)+1];

#define VIRTUAL_HEAP_ENTRY | ( | heapname,
 |  | id,
 |  | virtid,
 |  | size | )

Value:

{               \
    (HeapVector::Page**)(HeapVector::Page*)& m_pages_##heapname[0],     \
    id,                                                                 \
    virtid,                                                             \
    size,                                                               \
    0,                                                                  \
    #heapname                                                           \
},

Typedef Documentation

typedef _FunctionTracer<InternalTracer::Adc> AdcTracer

typedef _NullFunctionTracer AdcTracerLevel2

typedef _NullFunctionTracer AdcTracerLevel3

typedef _FunctionTracer<InternalTracer::Apc> ApcTracer

typedef _NullFunctionTracer ApcTracerLevel2

typedef _NullFunctionTracer ApcTracerLevel3

typedef void(* ApoxiNewHandlerFn)()

typedef _FunctionTracer<InternalTracer::App1> App1Tracer

typedef _NullFunctionTracer App1TracerLevel2

typedef _NullFunctionTracer App1TracerLevel3

typedef _FunctionTracer<InternalTracer::App2> App2Tracer

typedef _NullFunctionTracer App2TracerLevel2

typedef _NullFunctionTracer App2TracerLevel3

typedef _FunctionTracer<InternalTracer::App3> App3Tracer

typedef _NullFunctionTracer App3TracerLevel2

typedef _NullFunctionTracer App3TracerLevel3

typedef _FunctionTracer<InternalTracer::App4> App4Tracer

typedef _NullFunctionTracer App4TracerLevel2

typedef _NullFunctionTracer App4TracerLevel3

typedef HashTable AppContainerRoutingTable

typedef ElementList<ApplicationListEntry> AppElemList

typedef ContextMsg ApplicationMsg

For backwards compatibility only.

typedef LinkedList<AppRoutingTableEntry> AppRoutingTable

typedef _ApplicationTracer AppTracer

typedef _FunctionTracer<InternalTracer::Asc> AscTracer

typedef _NullFunctionTracer AscTracerLevel2

typedef _NullFunctionTracer AscTracerLevel3

typedef _FunctionTracer<InternalTracer::Aux> AuxTracer

typedef _NullFunctionTracer AuxTracerLevel2

typedef _NullFunctionTracer AuxTracerLevel3

typedef LinkedList<DispatcherAction> DispatcherActionList

typedef LinkedList<DispatcherAction> DispatcherActionList

typedef _FunctionTracer<InternalTracer::Gui> GuiTracer

typedef _NullFunctionTracer GuiTracerLevel2

typedef _NullFunctionTracer GuiTracerLevel3

typedef _FunctionTracer<InternalTracer::Kernel> KernelTracer

typedef _NullFunctionTracer KernelTracerLevel2

typedef _NullFunctionTracer KernelTracerLevel3

typedef InputMapItem::MapItemType MapItemType

typedef _FunctionTracer<InternalTracer::Mmi> MmiTracer

typedef _NullFunctionTracer MmiTracerLevel2

typedef _NullFunctionTracer MmiTracerLevel3

typedef UINT16 MsgCategory

Defines the category for message routing.

typedef UINT16 MsgId

Unique ID for each message.

typedef void(* NewHandlerFn)()

typedef _FunctionTracer<InternalTracer::Socket> SocketTracer

typedef _NullFunctionTracer SocketTracerLevel2

typedef _NullFunctionTracer SocketTracerLevel3

typedef SortedLinkedList<Timer> TimerList

typedef _FunctionTracer<InternalTracer::Always> Tracer

Enumeration Type Documentation

enum MsgOrigin

Enumerator:
externalMsg
internalMsg

Function Documentation

template<class DestClassPointer>
void CastMsg | ( | DestClassPointer & | dest_msg,
 |  | const Message * | src_msg
 | ) | [inline]

Function template CastMsg is used to downcast a pointer to a Message class to a pointer to some Message derived class. It supports casting of both pointers to non-const and pointers to const messages. Note, a pointer to a const Message will automatically be casted to a pointer to a non-const Message derived class in case it is needed! Hence, this function template is not const correct.

template<class T>
void SharedTriggerTimer< T >::Init | ( | T * | t,
 |  | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) | [inherited]

template<class T>
void SharedTriggerTimer< T >::OnTimer ( ) [protected, virtual, inherited]

Is called, if the timout-value of the timer expired. In the default implementation of this method the message TimerTimeoutMsg is sent.

Reimplemented from Timer.

void operator delete | ( | void * | ,
 |  | void * |
 | ) | [inline]

placement operator delete. This placement operator is used by the standard allocator Allocator<T>.

void operator delete ( void * p ) [inline]

void* operator new | ( | size_t | ,
 |  | void * | p
 | ) | [inline]

placement operator new. This placement operator is used by the standard allocator Allocator<T>.

void* operator new ( size_t size ) [inline]

template<class T>
SharedTriggerTimer< T >::SharedTriggerTimer | ( | T * | t,
 |  | UINT32 | timeout,
 |  | BOOLEAN | autotimer = FALSE
 | ) | [inherited]

template<class T>
SharedTriggerTimer< T >::SharedTriggerTimer ( ) [inherited]

size_t strlen ( const char * string )

void TestHeaps ( )

template<class T>
void TraceDataHelper | ( | InternalTracer::TraceMask | mask,
 |  | const void * | linkreg,
 |  | T * | obj
 | ) |

template<class T>
SharedTriggerTimer< T >::~SharedTriggerTimer ( ) [virtual, inherited]

Variable Documentation

ApoxiNewHandlerFn ApoxiNewHandler

const InputMapControlId c_abstract_menu_list_imid = 5

const INT c_alarm_manager_max_entries = APOXI_ALARMMANAGER_MAX_ENTRIES

const InputMapId c_Cancel_imid = 4

const InputMapControlId c_check_box_imid = 2

const InputMapControlId c_check_box_list_imid = 7

const InputMapId c_CheckBoxChangeStatus_imid = 40

const InputMapId c_Confirm_imid = 3

const InputMapControlId c_control_imid = 1

const InputMapControlId c_edit_box_imid = 4

const InputMapId c_EditBoxCursorDown_imid = 13

const InputMapId c_EditBoxCursorLeft_imid = 11

const InputMapId c_EditBoxCursorRight_imid = 10

const InputMapId c_EditBoxCursorUp_imid = 12

const InputMapId c_EditBoxDeleteCharacter_imid = 14

const InputMapId c_EditBoxDtmfSeparator_imid = 50

const InputMapId c_EditBoxPlus_imid = 51

const InputMapId c_EditBoxShiftKey_imid = 15

const InputMapId c_EditBoxWildcard_imid = 52

const InputMapId c_FocusNextControl_imid = 1

const InputMapId c_FocusPreviousControl_imid = 2

const InputMapControlId c_grid_imid = 10

const InputMapId c_GridMoveDown_imid = 63

const InputMapId c_GridMoveLeft_imid = 60

const InputMapId c_GridMoveRight_imid = 61

const InputMapId c_GridMoveUp_imid = 62

const HeapVector::ContextId c_invalid_context_id = ~0

const InputMapControlId c_list_box_imid = 3

const InputMapId c_ListBoxNextItem_imid = 21

const InputMapId c_ListBoxPreviousItem_imid = 20

const InputMapId c_MenuItemSelected_imid = 30

const InputMapControlId c_push_button_imid = 9

const InputMapId c_PushButtonClick_imid = 70

const InputMapId c_PushButtonRelease_imid = 71

const InputMapControlId c_radio_button_imid = 6

const InputMapControlId c_radio_button_list_imid = 8

const InputMapId c_RadioButtonNextItem_imid = 81

const InputMapId c_RadioButtonPreviousItem_imid = 80

const HeapVector::FctTable g_fcts_block_page

const HeapVector::FctTable g_fcts_huge_page

const HeapVector::FctTable g_fcts_var_page

const MsgCategory MC_APP = MC_CONTEXT

Obsolete - use MC_CONTEXT instead

See also:
Message

const MsgCategory MC_AT = 0x0080U

message for AT - commandos

const MsgCategory MC_BROADCAST = 0x0100U

See also:
Message

const MsgCategory MC_CONTEXT = 0x0002U

See also:
Message

const MsgCategory MC_CONTROL = 0x0004U

See also:
Message

const MsgCategory MC_FOCUS = 0x0008U

See also:
Message

const MsgCategory MC_IPC = 0x0020U

for communication between applications, containers and signal-handler, same functionality as

See also:
MC_SYSTEM

const MsgCategory MC_NOT_VALID = 0U

const MsgCategory MC_SIGNAL = 0x0040U

messages which are sent to protocol stack via signal-handler (only to be used in ADC & ASC)

const MsgCategory MC_STACK_CONTROL = 0x0010U

Obsolete - For asynchronous messages, which are sent from ASC to applications (acknowledgments, ...) - use MC_IPC instead

See also:
Message

const MsgCategory MC_SYSTEM = 0x0001U

See also:
Message

const MsgCategory MC_WIN = MC_CONTROL

Obsolete - use MC_CONTROL instead

See also:
Message

NewHandlerFn NewHandler

Generated on Wed Jan 25 02:29:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Operating System

Operating System
[Kernel]

Collaboration diagram for Operating System:

Data Structures

class | AppContext
class | AppMutex
class | InternalTracer
union | JmpBuf
class | Mutex
class | MutexObtainer
class | Os
class | Scheduler
class | Semaphore
class | SemObtainer
class | SimpleMutex
class | SimpleSemaphore
class | SystemTimer
class | TestWriter
class | Thread
class | Ticks
Ticks is a convertion class between OS specific tick values and milliseconds. More...
class | TickValue
class | Trap

Defines

#define | APOXI_CONFIG_DBG_OUT_RANGE_ARRAY 5
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND 0
#define | APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND 0
#define | APOXI_THREAD_PRIORITY_NORMAL 0
#define | c_max_thread_name_length 8
#define | DECLARE_CLASS(id) enum CLASS_ID { ID = (id) }; static CLASS_ID GetID() { CLASS_ID _id = ID; return _id; }
#define | WRITE_STATE(args)
#define | WRITESTATE(eventId, value)

Typedefs

typedef UINT32 | StackAtom
typedef UINT32 | ThreadId

Variables

const UINT32 | c_apoxi_powersaving_timer_alignment_lower_bound = APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND
const UINT32 | c_apoxi_powersaving_timer_alignment_upper_bound = APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND

Define Documentation

#define APOXI_CONFIG_DBG_OUT_RANGE_ARRAY 5

#define APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND 0

#define APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND 0

#define APOXI_THREAD_PRIORITY_NORMAL 0

#define c_max_thread_name_length 8

#define DECLARE_CLASS ( id ) enum CLASS_ID { ID = (id) }; static CLASS_ID GetID() { CLASS_ID _id = ID; return _id; }

this macro has to be placed inside a class declaration. It defines the class id which is necessary to distinguish the type of the class

#define WRITE_STATE ( args )

macro used for state output

#define WRITESTATE | ( | eventId,
 |  | value | )

deprecated macro, use WRITE_STATE instead

Typedef Documentation

typedef UINT32 StackAtom

typedef UINT32 ThreadId

Variable Documentation

const UINT32 c_apoxi_powersaving_timer_alignment_lower_bound = APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND

const UINT32 c_apoxi_powersaving_timer_alignment_upper_bound = APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND

Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: OBEX

OBEX

Data Structures

class | ObexAbstractPort
Internal base class for OBEX transport interfaces. More...
class | ObexAbstractTransport
Internal abstract interface base class for OBEX transports. More...
class | ObexAddress
Base class for client- and server address information. More...
class | ObexBuffer
Provides exclusive access to a buffer holding BODY data. More...
class | ObexChannel
Internal association class used to address an OBEX transport channel. More...
class | ObexClient
Base class for OBEX clients within applications. More...
class | ObexClientAddr
Base class for client address information classes. More...
class | ObexClientDispatcher
Internal abstraction of a client OBEX transport connection. More...
class | ObexClientOppImpl
Internal client implementation of the OPP profile. More...
class | ObexClientPort
Internal implementation class for OBEX transport interfaces. More...
class | ObexDataServer
OBEX server which uses the BinData and DataSink interfaces for transferring data. More...
class | ObexDispatcher
Internal OBEX message dispatcher. More...
class | ObexEventHandler
Internal interface for handling OBEX protocol events. More...
class | ObexFtpDataServer
Internal implementation class which handles the OBEX FTP logic used by the class ObexFtpServer. More...
class | ObexFtpServer
OBEX FTP server which offers an abstract interface to be implemented for a specific file system. More...
class | ObexHeader
Represents an OBEX header. More...
class | ObexHeaderBuilder
Helps to assemble an OBEX header from several chunks of data. More...
class | ObexHeaderList
Managing list of OBEX headers. More...
class | ObexLayer
Internal interface base class for direct access to the OBEX layer. More...
class | ObexMngr
OBEX Manager. Singleton. Facade to global APOXI OBEX functionality. More...
class | ObexObject
Handle class which provides access to OBEX protocol data. More...
class | ObexObjectData
Internal body class for OBEX objects. More...
class | ObexOperationId
Internal association class for requests and responses related to an operation. More...
class | ObexOppBinDataPushClient
Reads data from a BinData instance and pushes it towards a remote OPP server. More...
class | ObexOppClient
Base class for OPP clients within applications. More...
class | ObexOppClientOperation
Internal abstraction of an OPP client operation. More...
class | ObexOppClientPull
Internal implementation of an OPP PULL operation.. More...
class | ObexOppClientPush
Internal implementation of an OPP PUSH operation.. More...
class | ObexOppDataSinkPushServer
Receives data pushed in by a remote OPP client and saves it to a to a DataSink instance. More...
class | ObexOppServer
Base class for OPP servers within applications. More...
class | ObexProtocol
Internal interface base class for protocol layer abstractions. More...
class | ObexResult
Indicates success or failure of OBEX API functions and operations. More...
class | ObexServer
Internal base class for OBEX servers within applications. More...
class | ObexServerAddr
Base class for server address information classes. More...
class | ObexServerDispatcher
Internal abstraction of an OBEX server at transport level. More...
class | ObexServerInfo
Internal interface used to register OBEX servers with the Server Registry. More...
class | ObexServerMngr
Internal implementation of an OBEX Server Registry. More...
class | ObexServerOppImpl
Internal server implementation of the OPP profile. More...
class | ObexServerPort
Internal implementation class for OBEX transport interfaces. More...
class | ObexServerVisitor
Internal interface used to scan the OBEX Server Registry. More...
class | ObexTransportSet
Set representing multiple transport media to be used with APOXI OBEX. More...
class | ObexUrlStrParser
Internal utility class used to parse an OBEX URL. More...

Defines

#define | APOXI_OBEX_DBG_OUT 40222
Constant for enabling DBG_OUT tracing within APOXI OBEX.
#define | APOXI_OBEX_FTP_DBG 36003
#define | APOXI_OBEX_MAX_NO_SELECTIONS 2
Maximum number of transport selection procedures running concurrently.
#define | APOXI_OBEX_MAX_NO_TRANSPORTS 3
Maximum number of transport implementations to be used with OBEX.
#define | APOXI_OBEX_OPP_DBG 36002

Typedefs

typedef SharedPtr< ObexAddress > | ObexAddrPtr
Smartpointer used to manage ObexAddress instances.
typedef UINT8 | ObexAddrTypeId
This type id uniquely identifies a polymorphic class derived from either ObexClientAddr or ObexServerAddr.
typedef UINT8 | ObexServerId
Uniquely identifies an OBEX service endpoint.
typedef UINT8 | ObexTransportId
Transport Identifier uniquely identifies an ObexTransport implementation that has registered with ObexMngr.

Enumerations

enum | ObexAppMsgType { ObexAppMsgTransportSelectionReq }
Message opcodes for ObexMsg. More...
enum ObexMsgType {
ObexMsgResult, ObexMsgBuffer, ObexMsgResponse, ObexMsgPut,
ObexMsgGet, ObexMsgConnect, ObexMsgDisconnect, ObexMsgSetPath,
ObexMsgAbort
}
Message opcodes for ObexMsg. More...
enum | ObexProtocolId { ObexPrIdObex, ObexPrIdOpp }
Protocol Identifier definitions for classes derived from ObexProtocol. More...
enum | ObexTransportMsgType { ObexTrAvStateChanged, ObexTrEnableRejected, ObexTrSelectionResult }
Message opcodes for ObexTransportMsg. More...

Functions

ObexResult | ObexOppDataSinkPushServer::Accept (DataSink *obj_sink_ptr, UINT32 max_obj_size=0xFFFFFFFFul)
Accepts an incoming PUSH operation.
ObexResult ObexFtpServer::AcceptConnectRequest ()
Used to accept an incoming CONNECT request.
ObexResult ObexFtpServer::AcceptDeleteObjectRequest ()
Used to accept an incoming object delete request.
ObexResult | ObexFtpServer::AcceptFilePullRequest (DataSourcePtr data_src_ptr)
Used to accept an incoming file pull request.
ObexResult | ObexFtpServer::AcceptFilePushRequest (DataSinkPtr data_sink_ptr, UINT32 max_size=0xFFFFFFFFul)
Used to accept an incoming file push request.
ObexResult ObexFtpServer::AcceptFolderListingRequest ()
Used to accept an incoming folder listing request.
ObexResult ObexFtpServer::AcceptSetCurrentFolderRequest ()
Used to accept an incoming current-folder change request.
Iterator | ObexTransportSet::Begin ()
Returns an iterator which refers to the first element of the set.
ConstIterator | ObexHeaderList::Begin () const
Returns an iterator which points to the first header of the list.
ObexResult | ObexOppDataSinkPushServer::BindToMimeType (MimeType mime_type)
Binds the server to an additional mime type.
ObexResult | ObexOppDataSinkPushServer::Cancel (ObexObject::ResponseCode resp_code, const WString &resp_desc=L"")
Rejects an incoming PUSH operation or cancels an already ongoing one.
ObexResult ObexOppDataSinkPushServer::Close ()
Closes the OPP server. Closes the OPP server to client requests.
ObexResult ObexFtpServer::Close ()
Deactivates the server and releases its bindings.
ObexResult ObexOppDataSinkPushServer::Confirm ()
Confirms that the client operation has been successfully performed.
ObexHeaderList::ConstIterator::ConstIterator (const ConstIterator &from)
Copy constructor.
ObexHeaderList::ConstIterator::ConstIterator ()
Default constructor. Constructs the invalid iterator.
BOOLEAN | ObexTransportSet::Contains (ObexTransportId id) const
Tells whether the set contains the id 'id' or not.
BOOLEAN | ObexHeaderList::Contains (ObexHeader::HeaderId id) const
Tells if the list contains at least one header whose header Id equals the given one.
BOOLEAN | ObexHeaderList::Contains (ObexHeader::HeaderId id, ConstIterator from) const
Tells if the list contains at least one header whose header Id equals the given one.
static ObexOperationId | ObexOperationId::Create ()
Returns a valid, hopefully unique ObexOperationId.
void | ObexBuffer::Empty ()
Makes a valid non-empty buffer appear empty again.
ObexTransportSet | ObexMngr::EnumTransports (const String &filter_url=c_any_url) const
Enumerates available transports.
void | ObexTransportSet::Exclude (const ObexTransportSet &xs)
Removes transports from the set which are contained in a second set.
void | ObexAbstractPort::ExternalEvent (EventType ev_type, ObtainableObject *ev_data_ptr)
ConstIterator | ObexHeaderList::Find (ObexHeader::HeaderId id) const
Find first header whose header Id equals the given one.
const ObexAddrPtr & | ObexAbstractPort::GetAddress ()
Application * | ObexDispatcher::GetAppPtr () const
Return the application associated with the dispatcher. Deprecated - use GetContext().
Size | ObexBuffer::GetCapacity () const
Returns the maximum data site which can be stored in the buffer.
const ObexChannel & | ObexAbstractPort::GetChannel () const
Returns the ObexChannel associated with the port.
ObexAddrTypeId | ObexAbstractTransport::GetClientAddrTypeId () const
Returns the type identifier of a client address.
UINT32 | ObexServer::GetConnectionId () const
Returns the Connection Id of the current connection.
UINT32 | ObexClient::GetConnectionId () const
Returns the connection id of a directed connection.
ExecutionContext & | ObexDispatcher::GetContext () const
Returns the execution context of the dispatcher.
const WString & | ObexFtpServer::GetCurrentFolder () const
Returns the current folder of the server.
AbstractTransport & | ObexAbstractTransport::GetDeviceAbstraction () const
Returns the associated transport device abstraction.
ErrorCode | ObexResult::GetErrorCode () const
Returns the error code, or in case of no error, Success.
UINT8 | ObexHeader::GetId () const
Returns the header id.
UINT16 | ObexChannel::GetIndex () const
Returns the index specified at construction time.
UINT8 | ObexServerDispatcher::GetNrOfOpenedTransports () const
Returns the number of transports opened by Open().
ObjectId | ObexAbstractTransport::GetObjectId () const
Return the unique object id of the transport.
Size | ObexBuffer::Writer::GetOffset () const
Returns the buffer offset where data is written next.
Size | ObexBuffer::Reader::GetOffset () const
Returns the buffer offset where data will be read next.
const ObexOperationId & | ObexMngr::SelectCommand::GetOperationId () const
Returns the ObexOperationId of the request.
UINT32 | ObexOppDataSinkPushServer::GetProgressInBytes () const
Returns the cumulative progress in transferring data.
UINT32 | ObexClient::GetProgressInBytes () const
Returns the cumulative progress in transferring data.
ObexProtocol & ObexAbstractPort::GetProtocol ()
Returns the ObexProtocol associated with the port.
ObexProtocolId | ObexChannel::GetProtocolId () const
Returns the type of the associated protocol implementation.
DataPtr | ObexBuffer::Writer::GetPtr () const
Returns the pointer to the place where data can be written to.
DataPtr | ObexBuffer::Reader::GetPtr () const
Returns the pointer to the data which can be read.
UINT16 | ObexOperationId::GetSeqNr () const
Returns the sequence number of the operation.
ObexAddrTypeId | ObexAbstractTransport::GetServerAddrTypeId () const
Returns the type identifier of a server address.
ObexServerId | ObexServerInfo::GetServerId () const
Size | ObexBuffer::GetSize () const
Returns the size of the data block.
const ByteBuffer & | ObexServer::GetTarget () const
Returns the target associated with a particular server instance.
ObexAbstractTransport & ObexAbstractPort::GetTransport ()
ObexTransportId | ObexChannel::GetTransportId () const
Returns the object id of the associated transport implementation.
ObexTransportId | ObexAddress::GetTransportId () const
Returns the id of the transport associated with the address.
const ObexOperationId & | ObexAbstractPort::GetTransportOperId () const
HeaderType | ObexHeader::GetType () const
Returns the header type.
TypeId | ObexProtocol::GetTypeId () const
Returns the protocol type identifier.
ObexProtocolId | ObexDispatcher::GetTypeId () const
const CHAR * | ObexAbstractTransport::GetUrlScheme () const
Returns the URL scheme (name that preceedes ://).
const String & | ObexServerDispatcher::GetUrlStr () const
Returns the OBEX URL string which was passed to Open().
void | ObexTransportSet::Include (const ObexTransportSet &xs)
Includes another transport set into the current one.
ObexResult | ObexObject::Init (ObexBuffer &source_buffer)
Initializes an ObexObject producing a valid request object.
void | ObexOperationId::Invalidate ()
Marks the ObexOperationId as invalid.
void | ObexChannel::Invalidate ()
Invalidate channel. Initialize the channel as if it had just beed default-constructed.
BOOLEAN | ObexServerDispatcher::IsActive (const ServerPortPtr &port_ptr) const
Tells whether a port is currently active.
BOOLEAN | ObexServerDispatcher::IsActive () const
Tells whether any port is currently active.
BOOLEAN | ObexAbstractPort::IsBoundTo (const ObexChannel &ch) const
Tells whether the port is bound to the passed channel.
BOOLEAN | ObexChannel::IsClient () const
Tells if the channel is associated with a client.
BOOLEAN | ObexServer::IsConnected () const
Tells whether the server has accepted an OBEX CONNECT.
BOOLEAN | ObexClientPort::IsConnected () const
Tells whether the port is connected.
BOOLEAN | ObexTransportSet::IsEmpty () const
Tells whether the set contains any element(s).
BOOLEAN | ObexResult::IsError () const
Tells whether this result indicates an error.
BOOLEAN | ObexAbstractPort::IsInState (const FsmEngine::StateInfo &state) const
BOOLEAN | ObexServerPort::IsListening () const
Tells whether the port is listening to incoming connection requests.
BOOLEAN | ObexResult::IsOk () const
Tells whether this result indicates success.
BOOLEAN | ObexMngr::SelectCommand::IsPending () const
Tells whether the request is scheduled for execution.
static BOOLEAN | ObexServerDispatcher::IsPortPtrValid (const ServerPortPtr &port_ptr)
Tells whether the passed pointer is valid or not.
BOOLEAN | ObexChannel::IsServer () const
Tells if the channel is associated with a server.
BOOLEAN | ObexServerDispatcher::IsShuttingDown () const
Tells whether the server is currently being shut down.
BOOLEAN | ObexObject::IsSuccessResponse () const
Tells whether the object represents a SUCCESS response.
BOOLEAN | ObexChannel::IsUnique () const
Tells if the channel uniquely identifies an OBEX connection.
BOOLEAN | ObexTransportSet::Iterator::IsValid () const
Tells whether the iterator is valid.
BOOLEAN | ObexOperationId::IsValid () const
Tells whether the Operation Id is valid.
BOOLEAN | ObexObject::IsValid () const
Tells whether the object may be accessed.
BOOLEAN | ObexHeaderList::ConstIterator::IsValid () const
Tells whether the iterator is valid.
BOOLEAN | ObexHeader::IsValid () const
Tells whether the header carries a valid value.
BOOLEAN | ObexChannel::IsValid () const
Tells if the connection is valid.
BOOLEAN | ObexBuffer::IsValid () const
Tells whether the buffer refers to a data block.
static BOOLEAN | ObexClientDispatcher::IsValidPortPtr (const ClientPortPtr &port_ptr)
ObexTransportSet::Iterator::Iterator (const Iterator &from)
Copy constructor.
ObexTransportSet::Iterator::Iterator ()
Default constructor.
ObexChannel::ObexChannel (const ObexChannel &)
Copy constructor.
ObexChannel::ObexChannel ()
Default constructor. Constructs an invalid 'empty' channel.
ObexOperationId::ObexOperationId (const ObexOperationId &from)
Copy constructor.
ObexOperationId::ObexOperationId ()
Default constructor. Constructs an invalid ObexOperationId.
ObexResult::ObexResult (const ObexResult &from)
Copy constructor.
ObexResult::ObexResult (ErrorCode e=Unspecified)
Constructor and default constructor.
ObexTransportSet::ObexTransportSet (const ObexTransportSet &from)
Copy constructor.
static ObexResult | ObexResult::Ok ()
Constructs an ObexResult object that indicates success.
ObexResult ObexOppDataSinkPushServer::Open ()
Opens the OPP server for client requests.
ObexResult | ObexFtpServer::Open (const String &obex_addr_url, UINT8 open_flags=0)
Activates the server and binds its address to one or more transport channels.
ObexResult ObexFtpServer::Open ()
Activates the server and binds it to the default OBEX FTP address and to all available transport channels, also creates automatically a Service Discovery Database entry by using 'SdbAutoRegister' as open flag.
const ObexHeader & | ObexHeaderList::ConstIterator::operator * () const
Access currently denoted header by reference.
ObexResult::operator BOOLEAN () const
Conversion operator to BOOLEAN.
BOOLEAN | operator!= (const ObexOperationId &lhs, const ObexOperationId &rhs)
BOOLEAN | operator!= (const ObexChannel &lhs, const ObexChannel &rhs)
Iterator & | ObexTransportSet::Iterator::operator++ ()
ConstIterator & | ObexHeaderList::ConstIterator::operator++ ()
const ObexHeader * | ObexHeaderList::ConstIterator::operator-> () const
Access currently denoted header by pointer.
ObexTransportSet & | ObexTransportSet::operator= (const ObexTransportSet &from)
Assignment operator.
Iterator & | ObexTransportSet::Iterator::operator= (const Iterator &from)
Assignment operator.
ObexResult & | ObexResult::operator= (const ObexResult &from)
Assigmnent operator.
ObexOperationId & | ObexOperationId::operator= (const ObexOperationId &from)
Assignment operator.
ConstIterator & | ObexHeaderList::ConstIterator::operator= (const ConstIterator &from)
Assigment operator.
ObexChannel & | ObexChannel::operator= (const ObexChannel &)
Assignment operator.
BOOLEAN | operator== (const ObexOperationId &lhs, const ObexOperationId &rhs)
BOOLEAN | operator== (const ObexChannel &lhs, const ObexChannel &rhs)
ObexResult ObexFtpServer::ProvideFolderListingEntriesFinished ()
Indicates the server that all folder listing entries are provided.
ObexResult | ObexFtpServer::ProvideFolderListingEntry (BOOLEAN isFolder, const String &name, const FolderListingEntryProperties &properties)
Provides a folder listing entry to the server.
ObexResult | ObexFtpServer::RejectConnectRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming CONNECT request.
ObexResult | ObexFtpServer::RejectDeleteObjectRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming object delete request.
ObexResult | ObexFtpServer::RejectFilePullRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming file pull request.
ObexResult | ObexFtpServer::RejectFilePushRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming file push request.
ObexResult | ObexFtpServer::RejectFolderListingRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming folder listing request.
ObexResult | ObexFtpServer::RejectSetCurrentFolderRequest (ObexObject::ResponseCode resp_code=ObexObject::RespForbidden)
Used to reject an incoming current-folder change request.
void | ObexBuffer::Release ()
Release memory allocated by constructor and initialize object to virgin state.
void | ObexAbstractPort::ReleaseAddress ()
void | ObexAbstractPort::SetAddress (const ObexAddrPtr &addr_ptr)
static HeaderType | ObexHeader::TypeOfId (INT id)
Tells the type associated with a header id.
ObexResult | ObexOppDataSinkPushServer::UnbindMimeType (MimeType mime_type)
Unbinds the server from a mime type.

Detailed Description

Module OBEX is APOXI's API layer which enables applications to access and provide services based on the OBject EXchange Protocol OBEX.

Purpose and design goals

  • Provide a common application interface for sending and receiving objects via OBEX over different transport media, for example IrDA, Bluetooth and USB

  • Specify transport media and optional parameters using an URL-like string format derived from JSR-82 connection strings

  • Allow streaming of object data when sending and receiving

  • Facilitate adding of new transport protocols without having to change APOXI OBEX or even application code (apart from address strings)

  • Provide decoupling of application- and transport stack execution contexts

Concepts

The following paragraphs describe some general ideas which affect multiple classes and are therefore hard to explain from within class documentation.

OBEX URL's

OBEX URL's are passed as parameters to the Open() method of servers and clients. They are used to specify the transport protocol, the type of service offered by a server or requested by a client and optional transport-specific parameter such as Bluetooth security settings.

The following grammar of the OBEX URL is given in BNF:

  • 'literal'
    Literal (constant)

  • <production>
    Production (syntax expression).

  • [ <optional-part> ]
    Optional part.

  • { <repetitive-part> }
    Indicates <repetitive-part> may occur multiple times.

  • <alt1> | <alt2>
    Alternatives: May be alt1 or alt2 but not both.

  • <seq1> <seq2>
    Sequence: seq1 occurs first, then seq2.

  • <production> ':=' ... ;
    Defines the production <production>.

The overall structure is defined as following:

    <obex-url> := <scheme> '://' [ <jsr-82-address> ] [ <obex-parameters> ] ;

    <scheme> := '*'
             |  <registered_transport_scheme>
             ;

Comment: <registered_transport_scheme> includes the return values of ObexAbstractTransport::GetUrlScheme() called on each transport instance registered with the ObexMngr singleton. The <jsr-82-address> is specified in the Java document and might be supported only partly, but the partial implementation must be compliant with the full syntax given in the JSR-82 specification.

The wildcard character '*' has a different meaning for client- and server addresses:

  • A wildcard server address will cause the server to bind all available transport protocols.

  • A wildcard client address will trigger a Transport Address Selection procedure asking the user to interactively select a transport protocol.

    <obex-parameters> := '{' <obex-parameter-list> '}' ;

    <obex-parameter-list> := <obex-parameter-assignment> { ',' <obex-parameter-assignment>  } ;

    <obex-parameter-assignment> := <obex-parameter-name> '=' <obex-parameter-value> ;

    <obex-parameter-name> := 'TARGET' ;

Comment: TARGET is a binary string which might be specified in ASCII or hex notation. It is used to register an OBEX server for a specific service addressed by the TARGET header and facilitates multiple OBEX serverss to share a single transport connection (OBEX multiplexing). When no TARGET header is specified, an associated server becomes the default OBEX server.

    <obex-parameter-value> := <obex-hex-string>
                           |  <obex-ascii-string>
                           ;

    <obex-hex-string> := 'H'{ <hex-digits-or-dash> }
                      ;

Comment: A hex string starts with 'H'. The following string literals may contain only an even number of hex digits and, optionally, dashes (only for readability, ignored by parser). Each two hex digits are converted into an octet, where the leftmost digit is the most significant nibble and the rightmost the least significant nibble.

Example:H'01-02-03-04' will be converted into 0x01, 0x02, 0x03, 0x04

    <obex-ascii-string> := ''' <any-char-but '''> '''

Comment: An ASCII string may contain any printable character but '''.

Example: 'SYNCML-SYNC'

Currently there is only one parameter which can occur in the list, but in the future it might be necessary to introduce new parameter types. In this case, the parameter assignments would be separated by commas: {TARGET=SYNCML-SYNC, NEW_PARAMETER=TRUE}. A comma indicates more parameter assignments are expected, so a parameter list defining a single parameter looks like this: {TARGET='SYNCML-SYNC'}.

OBEX Application

The OBEX application is a specialized MMI application which implements user interaction when a Transport Address Selection procedure must be performed.This can only happen when wildcard OBEX URL's like "*://" are used when opening a client connection and more than one Transport Adapter is available within the system. For more detailed information, please refer to the documentation of class ObexMngr.

Transport Adapters

Transport Adapters perform the adaptation between the generic transport interface of APOXI OBEX and the arbitrary interface of the individual transport protocol stacks. Therefore for each transport protocol stack to be used with APOXI OBEX a Transport Adapter must be implemented.

Transport Adapters register themselves with the central singleton class ObexMngr under a protocol name or 'scheme' and are then assigned a system-wide unique id of type ObexTransportId.

A Transport Adapter must at least implement the following interfaces:

  • ObexAbstractTransport Provides access to the protocol (OBEX) implementation by means of the method ObexAbstractTransport::GetProtocol(), which should return a pointer to the OBEX implementation for this transport. This is an instance of a class implementing the ObexLayer interface. Futhermore this class has to take care of address resolution, which means parsing of OBEX URL strings (possibly using the helper class ObexUrlParser) and constructing instances of address objects (pls. see paragraph below). These activities might involve asynchronous procedures like maintaining a Service Discovery Database in case of a server and Device Discovery / Service Discovery in case of a client.

  • ObexServerAddr and ObexClientAddr Represent server- and client addresses which have been constructed by the associated transport. The derives classes might contain transport- specific information like Bluetooth UUID's, RFCOMM ports and addresses or an IrDA device address and LSAP number. The base class supports run-time typing to facilitate save downcasting of addresses within a Transport Adapter implementation.

  • ObexLayer Contains the glue logic in between APOXI OBEX and the underlying transport stack. Public abstract methods must be implemented to forward outbound client requests and server responses to the protocol stack for sending, while received events must be forwarded towards APOXI by calling protected 'OnEventHasOccured()' methods.

  • AbstractTransport Represents the state of the hardware used by the transport protocol, for example an IrDA subsystem wich might be switched on and off at runtime. Must provide a method to poll the current state AbstractTransport::GetAvState()) and call AbstractTransport::OnAvStateChanged() each time the state changes. Other objects, for example ObexAbstractTransport then become observers of this class and will be notified when state changes occur.

Define Documentation

#define APOXI_OBEX_DBG_OUT 40222

Constant for enabling DBG_OUT tracing within APOXI OBEX.

#define APOXI_OBEX_FTP_DBG 36003

#define APOXI_OBEX_MAX_NO_SELECTIONS 2

Maximum number of transport selection procedures running concurrently.

#define APOXI_OBEX_MAX_NO_TRANSPORTS 3

Maximum number of transport implementations to be used with OBEX.

#define APOXI_OBEX_OPP_DBG 36002

Typedef Documentation

typedef SharedPtr< ObexAddress > ObexAddrPtr

Smartpointer used to manage ObexAddress instances.

This is an intrusive reference-counted shared pointer. The object instance to be managed by the pointer must be allocated with new and will be deleted automatically after the last referrer has passed away.

typedef UINT8 ObexAddrTypeId

This type id uniquely identifies a polymorphic class derived from either ObexClientAddr or ObexServerAddr.

typedef UINT8 ObexServerId

Uniquely identifies an OBEX service endpoint.

Used to represent the result of dispatching incoming server requests.

typedef UINT8 ObexTransportId

Transport Identifier uniquely identifies an ObexTransport implementation that has registered with ObexMngr.

Enumeration Type Documentation

enum ObexAppMsgType

Message opcodes for ObexMsg.

Enumerator:
ObexAppMsgTransportSelectionReq Requests that the OBEX Application performs the Transport Address Selection procedure

enum ObexMsgType

Message opcodes for ObexMsg.

Enumerator:
ObexMsgResult | Operation result.
ObexMsgBuffer | Data buffer available.
ObexMsgResponse | OBEX response.
ObexMsgPut | OBEX request : PUT.
ObexMsgGet | OBEX request : GET.
ObexMsgConnect | OBEX request : CONNECT.
ObexMsgDisconnect | OBEX request : DISCONNECT.
ObexMsgSetPath | OBEX request : SETPATH.
ObexMsgAbort | OBEX request : ABORT.

enum ObexProtocolId

Protocol Identifier definitions for classes derived from ObexProtocol.

Enumerator:
ObexPrIdObex | OBEX - OBject EXchange Protocol.
ObexPrIdOpp | OPP - Object Push Pull.

enum ObexTransportMsgType

Message opcodes for ObexTransportMsg.

Enumerator:
ObexTrAvStateChanged | Indicates that the availability state has changed. Call GetAvState() on the transport to obtain the new state.
ObexTrEnableRejected | Indicates that a call to Enable() on the transport has failed. The transport state was left unaffected.
ObexTrSelectionResult Indicates completion of a Transport Address Selection procedure.

In case of successful transport selection the transport id identifies the selected transport, the operation id identifies the procedure. In case of error it is set to ObexAbstractTransport::NoTransportId.

Function Documentation

ObexResult ObexOppDataSinkPushServer::Accept | ( | DataSink * | obj_sink_ptr,
 |  | UINT32 | max_obj_size = 0xFFFFFFFFul
 | ) | [inline, inherited]

Accepts an incoming PUSH operation.

Parameters:
obj_sink_ptr | Pointer to an instance of a class derived from APOXI DataSink.
max_obj_size | Maximum size of an object to be accepted. Default is maximum OBEX object size (4G -1)!
Returns:
Evaluates to 'TRUE' when the incoming operation could be accepted, 'FALSE' otherwise.

ObexResult ObexFtpServer::AcceptConnectRequest ( ) [inline, inherited]

Used to accept an incoming CONNECT request.

Returns:
ObexResult which evaluates to 'TRUE' when the current accept-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::AcceptDeleteObjectRequest ( ) [inline, inherited]

Used to accept an incoming object delete request.

Returns:
ObexResult which evaluates to 'TRUE' when the current accept-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::AcceptFilePullRequest ( DataSourcePtr data_src_ptr ) [inline, inherited]

Used to accept an incoming file pull request.

Parameters:
data_src_ptr Smart pointer to an instance of a class derived from APOXI DataSource the requested file data will be read from.
Returns:
ObexResult which evaluates to 'TRUE' when the current accept-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::AcceptFilePushRequest | ( | DataSinkPtr | data_sink_ptr,
 |  | UINT32 | max_size = 0xFFFFFFFFul
 | ) | [inline, inherited]

Used to accept an incoming file push request.

Parameters:
data_sink_ptr | Smart pointer to an instance of a class derived from APOXI DataSink the incoming file data will be written to.
max_size | If set to a value greater than 0, this specifies the maximum amount of bytes which are written to the given data sink. Default is maximum OBEX object size (4G -1)!
Returns:
ObexResult which evaluates to 'TRUE' when the current accept-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::AcceptFolderListingRequest ( ) [inline, inherited]

Used to accept an incoming folder listing request.

Returns:
ObexResult which evaluates to 'TRUE' when the current accept-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::AcceptSetCurrentFolderRequest ( ) [inline, inherited]

Used to accept an incoming current-folder change request.

Returns:
ObexResult which evaluates to 'TRUE' when the current accept-response was scheduled for sending, 'FALSE' otherwise.

ObexTransportSet::Iterator ObexTransportSet::Begin ( ) [inline, inherited]

Returns an iterator which refers to the first element of the set.

ObexHeaderList::ConstIterator ObexHeaderList::Begin ( ) const [inline, inherited]

Returns an iterator which points to the first header of the list.

If the list is empty, the invalid iterator is returned !

ObexResult ObexOppDataSinkPushServer::BindToMimeType ( MimeType mime_type ) [inline, inherited]

Binds the server to an additional mime type.

When the same type of processing is desired for several different mimetypes (for example, saving images to the filesystem) it is more convenient and also resource - saving to bind the same server to multiple mime types than running a seperate server instance for each mime type. This can be accomplished by calling BindToMimeType() on the server for each of the additional MIME types to be handled.

Caution: The server should be in closed state when calling this method. Each mime type may be registered by only one server.

Parameters:
mime_type MIME type identifier.
Returns:
ObexResult which evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented from ObexOppServer.

ObexResult ObexOppDataSinkPushServer::Cancel | ( | ObexObject::ResponseCode | resp_code,
 |  | const WString & | resp_desc = L""
 | ) | [inline, inherited]

Rejects an incoming PUSH operation or cancels an already ongoing one.

See also:
OnDataComplete().
Parameters:
resp_code | OBEX response (error) code.
resp_desc | Textual description of the error (optional), for example 'Object too large'.

ObexResult ObexOppDataSinkPushServer::Close ( ) [inline, inherited]

Closes the OPP server. Closes the OPP server to client requests.

Returns:
Evaluates to 'TRUE' in case of success, 'FALSE' otherwise.

Reimplemented from ObexOppServer.

ObexResult ObexFtpServer::Close ( ) [inline, inherited]

Deactivates the server and releases its bindings.

After the Close() operation has been completed, the server will no longer accept incoming requests.

ObexResult ObexOppDataSinkPushServer::Confirm ( ) [inline, inherited]

Confirms that the client operation has been successfully performed.

See also:
OnDataComplete().

ObexHeaderList::ConstIterator::ConstIterator ( const ConstIterator & from ) [inline, inherited]

Copy constructor.

ObexHeaderList::ConstIterator::ConstIterator ( ) [inline, inherited]

Default constructor. Constructs the invalid iterator.

BOOLEAN ObexTransportSet::Contains ( ObexTransportId id ) const [inline, inherited]

Tells whether the set contains the id 'id' or not.

BOOLEAN ObexHeaderList::Contains ( ObexHeader::HeaderId id ) const [inline, inherited]

Tells if the list contains at least one header whose header Id equals the given one.

Parameters:
id Header Id to look for.
Returns:
TRUE if a header was found, FALSE otherwise.

BOOLEAN ObexHeaderList::Contains | ( | ObexHeader::HeaderId | id,
 |  | ConstIterator | from
 | ) | const [inline, inherited]

Tells if the list contains at least one header whose header Id equals the given one.

Parameters:
id | Header Id to look for.
from | Position in the list where to start searching.
Returns:
TRUE if a header was found, FALSE otherwise.

ObexOperationId ObexOperationId::Create ( ) [inline, static, inherited]

Returns a valid, hopefully unique ObexOperationId.

void ObexBuffer::Empty ( ) [inline, inherited]

Makes a valid non-empty buffer appear empty again.

ObexTransportSet ObexMngr::EnumTransports ( const String & filter_url = c_any_url ) const [inline, inherited]

Enumerates available transports.

See also:
TransportMngr::Enum()

void ObexTransportSet::Exclude ( const ObexTransportSet & xs ) [inline, inherited]

Removes transports from the set which are contained in a second set.

Parameters:
xs Transport set containing the transports to be removed from the current one.

void ObexAbstractPort::ExternalEvent | ( | EventType | ev_type,
 |  | ObtainableObject * | ev_data_ptr
 | ) | [inline, protected, inherited]

ObexHeaderList::ConstIterator ObexHeaderList::Find ( ObexHeader::HeaderId id ) const [inline, inherited]

Find first header whose header Id equals the given one.

Parameters:
id | Header Id of the OBEX header to be retrieved.
from | Position in the list where to start searching.
Returns:
Iterator referring to the corresponding header if one was found, invalid iterator otherwise.

const ObexAddrPtr & ObexAbstractPort::GetAddress ( ) [inline, protected, inherited]

Application * ObexDispatcher::GetAppPtr ( ) const [inline, inherited]

Return the application associated with the dispatcher. Deprecated - use GetContext().

ObexBuffer::Size ObexBuffer::GetCapacity ( ) const [inline, inherited]

Returns the maximum data site which can be stored in the buffer.

const ObexChannel & ObexAbstractPort::GetChannel ( ) const [inline, inherited]

Returns the ObexChannel associated with the port.

ObexAddrTypeId ObexAbstractTransport::GetClientAddrTypeId ( ) const [inline, inherited]

Returns the type identifier of a client address.

By comparing the return value to that of GetTypeId() called on an ObexClientAddr object, it can be determined if the address was produced by this transport. This is helpful if downcasting to a special ObexClientAddr derivative is desired.

Returns:
Type identifier of an ObexClientAddrInfo object created by this transport.

UINT32 ObexServer::GetConnectionId ( ) const [inline, inherited]

Returns the Connection Id of the current connection.

A Connection Id is automatically assigned when a CONNECT to the server's target is accepted.

Returns:
OBEX Connection Id when assigned, ObexHeader::NoConnectionId otherwise.

UINT32 ObexClient::GetConnectionId ( ) const [inline, inherited]

Returns the connection id of a directed connection.

Returns:
Connection Id when directed connection was established, ObexHeader::NoConnectionId otherwise.

ExecutionContext & ObexDispatcher::GetContext ( ) const [inline, inherited]

Returns the execution context of the dispatcher.

const WString & ObexFtpServer::GetCurrentFolder ( ) const [inline, inherited]

Returns the current folder of the server.

This methods returns the current folder of the server.

Returns:
The current folder (absolute, e.g. "/UserData/MyMusic/"). If there is no client connected, "/" (i.e. root folder) will be returned.

AbstractTransport & ObexAbstractTransport::GetDeviceAbstraction ( ) const [inline, inherited]

Returns the associated transport device abstraction.

ObexResult::ErrorCode ObexResult::GetErrorCode ( ) const [inline, inherited]

Returns the error code, or in case of no error, Success.

UINT8 ObexHeader::GetId ( ) const [inline, inherited]

Returns the header id.

UINT16 ObexChannel::GetIndex ( ) const [inline, inherited]

Returns the index specified at construction time.

UINT8 ObexServerDispatcher::GetNrOfOpenedTransports ( ) const [inline, inherited]

Returns the number of transports opened by Open().

Returns:
Number of transports which have been opened by Open() or '0' when the server is closed. Please note that a transport which has been opened is not necessarily bound because it might be temporarily unavailable or disabled.

ObexAbstractTransport::ObjectId ObexAbstractTransport::GetObjectId ( ) const [inline, inherited]

Return the unique object id of the transport.

ObexBuffer::Size ObexBuffer::Writer::GetOffset ( ) const [inline, inherited]

Returns the buffer offset where data is written next.

ObexBuffer::Size ObexBuffer::Reader::GetOffset ( ) const [inline, inherited]

Returns the buffer offset where data will be read next.

const ObexOperationId & ObexMngr::SelectCommand::GetOperationId ( ) const [inline, inherited]

Returns the ObexOperationId of the request.

UINT32 ObexOppDataSinkPushServer::GetProgressInBytes ( ) const [inline, inherited]

Returns the cumulative progress in transferring data.

This method returns the amount of data already transferred for a pending PUSH (inbound data) or PULL (outbound data) operation. The final value is preserved even beyond completion of that operation, hence it is reset to '0' when a new operation is accepted.

Reimplemented from ObexOppServer.

UINT32 ObexClient::GetProgressInBytes ( ) const [inline, inherited]

Returns the cumulative progress in transferring data.

This method returns the amount of data already transferred for a pending PUT (outbound data) or GET (inbound data) operation. The final value is preserved even beyond completion of that operation, hence it is reset to '0' when a new operation is initiated.

ObexProtocol & ObexAbstractPort::GetProtocol ( ) [inline, inherited]

Returns the ObexProtocol associated with the port.

ObexProtocolId ObexChannel::GetProtocolId ( ) const [inline, inherited]

Returns the type of the associated protocol implementation.

ObexBuffer::DataPtr ObexBuffer::Writer::GetPtr ( ) const [inline, inherited]

Returns the pointer to the place where data can be written to.

ObexBuffer::DataPtr ObexBuffer::Reader::GetPtr ( ) const [inline, inherited]

Returns the pointer to the data which can be read.

UINT16 ObexOperationId::GetSeqNr ( ) const [inline, inherited]

Returns the sequence number of the operation.

Useful for tracing with DBG_OUT etc. only. Never store the returned value in a member or static variable. Store instances of ObexOperationId instead.

ObexAddrTypeId ObexAbstractTransport::GetServerAddrTypeId ( ) const [inline, inherited]

Returns the type identifier of a server address.

By comparing the return value to that of GetTypeId() called on an ObexServerAddr object, it can be determined if the address was produced by this transport. This is helpful if downcasting to a special ObexServerAddr derivative is desired.

Returns:
Type identifier of an ObexServerAddr object created by this transport.

ObexServerId ObexServerInfo::GetServerId ( ) const [inline, inherited]

ObexBuffer::Size ObexBuffer::GetSize ( ) const [inline, inherited]

Returns the size of the data block.

const ByteBuffer & ObexServer::GetTarget ( ) const [inline, inherited]

Returns the target associated with a particular server instance.

ObexAbstractTransport & ObexAbstractPort::GetTransport ( ) [inline, protected, inherited]

ObexTransportId ObexChannel::GetTransportId ( ) const [inline, inherited]

Returns the object id of the associated transport implementation.

ObexTransportId ObexAddress::GetTransportId ( ) const [inline, inherited]

Returns the id of the transport associated with the address.

const ObexOperationId & ObexAbstractPort::GetTransportOperId ( ) const [inline, protected, inherited]

ObexHeader::HeaderType ObexHeader::GetType ( ) const [inline, inherited]

Returns the header type.

ObexProtocol::TypeId ObexProtocol::GetTypeId ( ) const [inline, inherited]

Returns the protocol type identifier.

ObexProtocolId ObexDispatcher::GetTypeId ( ) const [inline, inherited]

const CHAR * ObexAbstractTransport::GetUrlScheme ( ) const [inline, inherited]

Returns the URL scheme (name that preceedes ://).

const String & ObexServerDispatcher::GetUrlStr ( ) const [inline, protected, inherited]

Returns the OBEX URL string which was passed to Open().

void ObexTransportSet::Include ( const ObexTransportSet & xs ) [inline, inherited]

Includes another transport set into the current one.

Parameters:
xs Transport set to be included into the set.

ObexResult ObexObject::Init ( ObexBuffer & source_buffer ) [inline, inherited]

Initializes an ObexObject producing a valid request object.

If the object is the only referrer of the internally managed data, it is reinitialized. This is cheaper than overwriting it with a freshly created one because a dynamic memory allocation is saved. If multiple or no referrers exist, a new ObexObjectData object is allocated. After a successful call to Init(), the freshly initialized object is referenced only once and therefore writable.

Parameters:
source_buffer ObexBuffer to construct ObexObject instance from, this will take ownership of the data buffer and render 'source_buffer' invalid.

void ObexOperationId::Invalidate ( ) [inline, inherited]

Marks the ObexOperationId as invalid.

This method should be called on the ObexOperationId of a pending operation when the completion of the operation has been indicated.

void ObexChannel::Invalidate ( ) [inline, inherited]

Invalidate channel. Initialize the channel as if it had just beed default-constructed.

BOOLEAN ObexServerDispatcher::IsActive ( const ServerPortPtr & port_ptr ) const [inline, protected, inherited]

Tells whether a port is currently active.

Returns:
'TRUE' when port referenced by 'port_ptr' is currently active serving a remote client, 'FALSE' otherwise.

BOOLEAN ObexServerDispatcher::IsActive ( ) const [inline, protected, inherited]

Tells whether any port is currently active.

Returns:
'TRUE' when one of the ports is currently active serving a remote client, 'FALSE' otherwise.

BOOLEAN ObexAbstractPort::IsBoundTo ( const ObexChannel & ch ) const [inline, inherited]

Tells whether the port is bound to the passed channel.

BOOLEAN ObexChannel::IsClient ( ) const [inline, inherited]

Tells if the channel is associated with a client.

Returns:
'TRUE' when the channel is associated with a client, 'FALSE' otherwise (server).

BOOLEAN ObexServer::IsConnected ( ) const [inline, inherited]

Tells whether the server has accepted an OBEX CONNECT.

BOOLEAN ObexClientPort::IsConnected ( ) const [inline, inherited]

Tells whether the port is connected.

BOOLEAN ObexTransportSet::IsEmpty ( ) const [inline, inherited]

Tells whether the set contains any element(s).

Note: Calling IsEmpty() is more efficient than using GetCount(), yet semantically equivalent to (GetCount() > 0).

Returns:
'TRUE' when the set contains atg least one element, 'FALSE' otherwise.

BOOLEAN ObexResult::IsError ( ) const [inline, inherited]

Tells whether this result indicates an error.

BOOLEAN ObexAbstractPort::IsInState ( const FsmEngine::StateInfo & state ) const [inline, protected, inherited]

BOOLEAN ObexServerPort::IsListening ( ) const [inline, inherited]

Tells whether the port is listening to incoming connection requests.

BOOLEAN ObexResult::IsOk ( ) const [inline, inherited]

Tells whether this result indicates success.

BOOLEAN ObexMngr::SelectCommand::IsPending ( ) const [inline, inherited]

Tells whether the request is scheduled for execution.

BOOLEAN ObexServerDispatcher::IsPortPtrValid ( const ServerPortPtr & port_ptr ) [inline, static, protected, inherited]

Tells whether the passed pointer is valid or not.

BOOLEAN ObexChannel::IsServer ( ) const [inline, inherited]

Tells if the channel is associated with a server.

Returns:
'TRUE' when the channel is associated with a server, 'FALSE' otherwise (client).

BOOLEAN ObexServerDispatcher::IsShuttingDown ( ) const [inline, protected, inherited]

Tells whether the server is currently being shut down.

Returns:
'TRUE' when the server is currently being shut down after Close() was called, 'FALSE' otherwise.

BOOLEAN ObexObject::IsSuccessResponse ( ) const [inline, inherited]

Tells whether the object represents a SUCCESS response.

BOOLEAN ObexChannel::IsUnique ( ) const [inline, inherited]

Tells if the channel uniquely identifies an OBEX connection.

Returns:
'TRUE' when the channel uniquely identifies a connection (transport-layer multiplexing), 'FALSE' when the channel might be shared by multipe OBEX connections.

BOOLEAN ObexTransportSet::Iterator::IsValid ( ) const [inline, inherited]

Tells whether the iterator is valid.

Caution:Only valid iterators may be dereferenced or modified. Violators are subject to punishment by assertion. When in doubt, check IsValid() first.

BOOLEAN ObexOperationId::IsValid ( ) const [inline, inherited]

Tells whether the Operation Id is valid.

This usually indicates that the operation referred to is still ongoing.

BOOLEAN ObexObject::IsValid ( ) const [inline, inherited]

Tells whether the object may be accessed.

BOOLEAN ObexHeaderList::ConstIterator::IsValid ( ) const [inline, inherited]

Tells whether the iterator is valid.

Caution:Only valid iterators may be dereferenced or modified. Violators are subject to punishment by assertion.

BOOLEAN ObexHeader::IsValid ( ) const [inline, inherited]

Tells whether the header carries a valid value.

BOOLEAN ObexChannel::IsValid ( ) const [inline, inherited]

Tells if the connection is valid.

BOOLEAN ObexBuffer::IsValid ( ) const [inline, inherited]

Tells whether the buffer refers to a data block.

BOOLEAN ObexClientDispatcher::IsValidPortPtr ( const ClientPortPtr & port_ptr ) [inline, static, protected, inherited]

ObexTransportSet::Iterator::Iterator ( const Iterator & from ) [inline, inherited]

Copy constructor.

ObexTransportSet::Iterator::Iterator ( ) [inline, inherited]

Default constructor.

ObexChannel::ObexChannel ( const ObexChannel & ) [inline, inherited]

Copy constructor.

ObexChannel::ObexChannel ( ) [inline, inherited]

Default constructor. Constructs an invalid 'empty' channel.

ObexOperationId::ObexOperationId ( const ObexOperationId & from ) [inline, inherited]

Copy constructor.

ObexOperationId::ObexOperationId ( ) [inline, inherited]

Default constructor. Constructs an invalid ObexOperationId.

ObexResult::ObexResult ( const ObexResult & from ) [inline, inherited]

Copy constructor.

ObexResult::ObexResult ( ErrorCode e = Unspecified ) [inline, inherited]

Constructor and default constructor.

Attention: The default-constructed object indicates an error !

ObexTransportSet::ObexTransportSet ( const ObexTransportSet & from ) [inline, inherited]

Copy constructor.

ObexResult ObexResult::Ok ( ) [inline, static, inherited]

Constructs an ObexResult object that indicates success.

ObexResult ObexOppDataSinkPushServer::Open ( ) [inline, inherited]

Opens the OPP server for client requests.

Returns:
ObexResult which evaluates to 'TRUE' is case of success, 'FALSE' otherwise.

Reimplemented from ObexOppServer.

ObexResult ObexFtpServer::Open | ( | const String & | obex_addr_url,
 |  | UINT8 | open_flags = 0
 | ) | [inline, inherited]

Activates the server and binds its address to one or more transport channels.

Open() must be called on the server in order to resolve the specified address in URL format and bind it to one or more transport channels. For each transport channel bound OnBind() is called once.

Parameters:
obex_addr_url | OBEX address in URL format including Target.
open_flags | Flags used to customize server behavior.
See also:
OpenFlags

ObexResult ObexFtpServer::Open ( ) [inline, inherited]

Activates the server and binds it to the default OBEX FTP address and to all available transport channels, also creates automatically a Service Discovery Database entry by using 'SdbAutoRegister' as open flag.

const ObexHeader & ObexHeaderList::ConstIterator::operator * ( ) const [inline, inherited]

Access currently denoted header by reference.

See also:
IsValid()

ObexResult::operator BOOLEAN ( ) const [inline, inherited]

Conversion operator to BOOLEAN.

Returns 'TRUE' if the result indicates success, 'FALSE' if the object represents an error code.

BOOLEAN operator!= | ( | const ObexOperationId & | lhs,
 |  | const ObexOperationId & | rhs
 | ) |

BOOLEAN operator!= | ( | const ObexChannel & | lhs,
 |  | const ObexChannel & | rhs
 | ) |

ObexTransportSet::Iterator & ObexTransportSet::Iterator::operator++ ( ) [inline, inherited]

Increment operator. Only the prefix form is implemented as the postfix form would be slower due to the copying involved.

See also:
IsValid()

ObexHeaderList::ConstIterator & ObexHeaderList::ConstIterator::operator++ ( ) [inline, inherited]

Increment operator. Only the prefix form is implemented as the postfix form would be slower due to the copying involved.

See also:
IsValid()

const ObexHeader * ObexHeaderList::ConstIterator::operator-> ( ) const [inline, inherited]

Access currently denoted header by pointer.

See also:
IsValid()

ObexTransportSet & ObexTransportSet::operator= ( const ObexTransportSet & from ) [inline, inherited]

Assignment operator.

ObexTransportSet::Iterator & ObexTransportSet::Iterator::operator= ( const Iterator & from ) [inline, inherited]

Assignment operator.

ObexResult & ObexResult::operator= ( const ObexResult & from ) [inline, inherited]

Assigmnent operator.

ObexOperationId & ObexOperationId::operator= ( const ObexOperationId & from ) [inline, inherited]

Assignment operator.

ObexHeaderList::ConstIterator & ObexHeaderList::ConstIterator::operator= ( const ConstIterator & from ) [inline, inherited]

Assigment operator.

ObexChannel & ObexChannel::operator= ( const ObexChannel & ) [inline, inherited]

Assignment operator.

BOOLEAN operator== | ( | const ObexOperationId & | lhs,
 |  | const ObexOperationId & | rhs
 | ) |

BOOLEAN operator== | ( | const ObexChannel & | lhs,
 |  | const ObexChannel & | rhs
 | ) |

ObexResult ObexFtpServer::ProvideFolderListingEntriesFinished ( ) [inline, inherited]

Indicates the server that all folder listing entries are provided.

When all folder listing entries have been passed to the server by calling ProvideFolderListingEntry(...) for each entry, this method has to be invoked to continue the ongoing operation. This method indicates the server that all entires have been provided and thus the data transfer to the client can take place now.

Returns:
ObexResult which evaluates to 'TRUE' when the folder listing was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::ProvideFolderListingEntry | ( | BOOLEAN | isFolder,
 |  | const String & | name,
 |  | const FolderListingEntryProperties & | properties
 | ) | [inline, inherited]

Provides a folder listing entry to the server.

After OnProvideFolderListingEntries(...) has been invoked by the server to indicate that it is now ready to receive folder listing entries, this method has to be used to provide all entries of the current folder. The method has to be called for each entry, passing entry type, name and additional properties (if there are some). When all entries have been passed to the server the ongoing operation has to be continued by invoking ProvideFolderListingEntriesFinished(). This indicates the server that all entries have been provided and thus the data transfer to the client can take place now.

Parameters:
isFolder | Specifies if the current entry is a file or folder entry. If the flag is set to 'TRUE', the entry will be handled as folder entry, if set to 'FALSE' the entry will be handled as file entry.
name | The name of the entry (mandatory for Obex FTP).
properties | All additional and optional Obex FTP attributes of the entry may be passed here, like the object size, access attributes, timestamps, etc.
Returns:
ObexResult which evaluates to 'TRUE' when the provided entry could be processed successfully and was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::RejectConnectRequest ( ObexObject::ResponseCode resp_code = ObexObject::RespForbidden ) [inline, inherited]

Used to reject an incoming CONNECT request.

Parameters:
resp_code The OBEX reject-response code which will be sent to the client. Please note that an assertion will be raised if 'RespOk' is passed as response code, because this would indicate success (use AcceptConnectRequest() instead).
Returns:
ObexResult which evaluates to 'TRUE' when the current reject-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::RejectDeleteObjectRequest ( ObexObject::ResponseCode resp_code = ObexObject::RespForbidden ) [inline, inherited]

Used to reject an incoming object delete request.

Parameters:
resp_code The OBEX reject-response code which will be sent to the client. Please note that an assertion will be raised if 'RespOk' is passed as response code, because this would indicate success (use AcceptSetCurrentFolderRequest() instead).
Returns:
ObexResult which evaluates to 'TRUE' when the current reject-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::RejectFilePullRequest ( ObexObject::ResponseCode resp_code = ObexObject::RespForbidden ) [inline, inherited]

Used to reject an incoming file pull request.

Parameters:
resp_code The OBEX reject-response code which will be sent to the client. Please note that an assertion will be raised if 'RespOk' is passed as response code, because this would indicate success (use AcceptFilePullRequest() instead).
Returns:
ObexResult which evaluates to 'TRUE' when the current reject-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::RejectFilePushRequest ( ObexObject::ResponseCode resp_code = ObexObject::RespForbidden ) [inline, inherited]

Used to reject an incoming file push request.

Parameters:
resp_code The OBEX reject-response code which will be sent to the client. Please note that an assertion will be raised if 'RespOk' is passed as response code, because this would indicate success (use AcceptFilePushRequest() instead).
Returns:
ObexResult which evaluates to 'TRUE' when the current reject-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::RejectFolderListingRequest ( ObexObject::ResponseCode resp_code = ObexObject::RespForbidden ) [inline, inherited]

Used to reject an incoming folder listing request.

Parameters:
resp_code The OBEX reject-response code which will be sent to the client. Please note that an assertion will be raised if 'RespOk' is passed as response code, because this would indicate success (use AcceptFolderListingRequest() instead).
Returns:
ObexResult which evaluates to 'TRUE' when the current reject-response was scheduled for sending, 'FALSE' otherwise.

ObexResult ObexFtpServer::RejectSetCurrentFolderRequest ( ObexObject::ResponseCode resp_code = ObexObject::RespForbidden ) [inline, inherited]

Used to reject an incoming current-folder change request.

Parameters:
resp_code The OBEX reject-response code which will be sent to the client. Please note that an assertion will be raised if 'RespOk' is passed as response code, because this would indicate success (use AcceptSetCurrentFolderRequest() instead).
Returns:
ObexResult which evaluates to 'TRUE' when the current reject-response was scheduled for sending, 'FALSE' otherwise.

void ObexBuffer::Release ( ) [inline, inherited]

Release memory allocated by constructor and initialize object to virgin state.

Don't call this on buffers allocated by a user buffer factory.

void ObexAbstractPort::ReleaseAddress ( ) [inline, protected, inherited]

void ObexAbstractPort::SetAddress ( const ObexAddrPtr & addr_ptr ) [inline, protected, inherited]

ObexHeader::HeaderType ObexHeader::TypeOfId ( INT id ) [inline, static, inherited]

Tells the type associated with a header id.

ObexResult ObexOppDataSinkPushServer::UnbindMimeType ( MimeType mime_type ) [inline, inherited]

Unbinds the server from a mime type.

Calling UnbindMimeType() removes the binding to the specified mimetype to the server.

Caveats: The server should be in closed state when calling this method.

Parameters:
type_info MIME type identifier.
Returns:
ObexResult which evaluates to 'TRUE' is case of success, 'FALSE' otherwise.

Reimplemented from ObexOppServer.

Generated on Wed Jan 25 02:31:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SupplementaryServiceActions

SupplementaryServiceActions

Data Structures

class | SelectedLineRetriever
class | SsCallBarringActionImpl
class | SsCallForwardingActionImpl
class | SsCallWaitingActionImpl
class | SsClipActionImpl
class | SsClirActionImpl
class | SsCnapActionImpl
class | SsColpActionImpl
class | SsColrActionImpl
class | SsEmlppActionImpl
class | SsPasswordChangeActionImpl
class | SsUssdActionImpl
Generated on Wed Jan 25 02:29:44 2006 for APOXI by doxygen 1.4.6-NO


APOXI: APOXI Template Layer

APOXI Template Layer

Data Structures

class | AtlApplication
Baseclass for a ReferenceMmi Application. More...
class | AtlApplicationPlugin
class | AtlItemGrid
class | AtlItemGridWindow
class | AtlItemListWindow
class | AtlItemMenu
class | AtlItemMenuWindow
class | AtlItemRenderer
class | AtlLabelListWindow
class | AtlWindow
class | BackToIdleFeature
Platform feature "BackToIdleScreen". More...
class | CenteredTextIndicator
Indicator that displays a text width maximized width. More...
class | ContextDescription
class | ContextFeature
Special feature, which requires a context item as feature invocation argument. More...
class | ContextFeatureHandle
class | ContextFeatureItem
class | ContextManager
This singleton handles context switches and applies context descriptions to new contexts. More...
class | ContextTable
class | ContextTableNode
class | DynamicMenuPool
class | EnumTextMap
struct | EnumTextTableEntry
class | Feature
Represents pure functionality, will be wrapped by a feature item. More...
class | FeatureBroker
class | FeatureHandle
class | FeatureItem
class | FeatureItemContainer
class | FeaturePool
class | Fraction
class | IconIndicator
Indicator that displays an icon. More...
class | IconTextIndicator
Indicator that displays an icon and text. More...
struct | IconValueIndicator
Indicator that displays icon assigned for iterator values. More...
class | IdentifierHandler
class | ImgObtObj
class | Indicator
Base class of indicators to be used in IndicatorBars. More...
class | IndicatorBar
class | IndicatorBarPaneObject
class | IndicatorBarView
class | IndicatorDescription
class | IndicatorItem
class | IndicatorLocation
class | IndicatorPaneObject
class | InputMapperFactory
class | ItemLabel
DrawableObject, which shows text. More...
class | ItemLabelView
class | ItemObj
class | KeyManager
class | KeyMapping
class | KeySequence
class | KeySequenceCandidate
class | ListPropertyDescriptor
class | MainDesktop
Default desktop which displays indicators inside the desktop sections. More...
class | MappingPolicy
class | MenuDesc
class | MenuDescObj
class | MenuIdObj
class | MenuPool
class | MenuProperties
class | MenuTable
class | MenuTableNode
class | PhoneNumberMatchRule
PhoneNumberMatchRule: Compares two PhoneNumbers by using the PhoneNumber::IsMatching method. More...
class | Property
class | PropertyDescriptor
class | PropertyEditor
Interface for property editors. More...
class | PropertyEditorFactory
Singleton class for handling property editors. More...
class | PropertyItem
Encapsulates a property. The PropertyItem can be used for GUI controls. More...
class | ProviderProxyContainer
class | ProviderProxyItem
class | RangeMappingPolicy
class | ResourceID
class | SettingsProvider
class | SoftkeyDesc
class | SubstitutedText
class | TextIconPairArray
class | TextIndicator
Indicator that displays an text. More...
class | TriggerKeyFeature
This features posts a key down message with a given key code. It can be used to send key events from a menu item, since this feature can be used in a menu. More...
class | UserActivityListener
class | ValueIndicator
Indicator that has several qualities. More...
class | ValueMappingPropertyDescriptor< T_Container >

Typedefs

typedef EnumTextTableEntry | EnumTextTable []
typedef ValueMappingPropertyDescriptor<
TextIconPairArray > 		StaticValueMappingPropertyDescriptor

Enumerations

enum | { ValueMappingPropertyDescriptor::ID = 3 }
enum | { FeatureItem::ID = 100 }
enum | { ContextFeature::ID = 2 }
enum ContextFeature::ContextType {
ContextFeature::WStringType, ContextFeature::NumberType, ContextFeature::ItemTextType, ContextFeature::PhoneNumberType,
ContextFeature::ItemType, ContextFeature::ProviderType, ContextFeature::ContainerType, ContextFeature::UndefinedType
}
enum | Feature::FeatureAttributeId { Feature::UnspecifiedAttributeId = -1, Feature::AvailableAttributeId = 0, Feature::EnabledAttributeId = 1, Feature::CustomAttributeId = 99 }
enum | FeatureItemContainer::FeatureItemContainerPropertyId { FeatureItemContainer::ContextPropertyId = 5 }
enum | FeatureItem::FeatureItemPropertyId { FeatureItem::FeaturePropertyId = 5, FeatureItem::ContextPropertyId = 6 }
enum | FeatureItemContainer::Identifier { FeatureItemContainer::ID = 106 }

Functions

virtual BOOLEAN | FeatureItemContainer::AddItem (Item *item)
void | Feature::BlockNotification (BOOLEAN block)
BOOLEAN | FeatureItemContainer::ContainsFeature (Feature *feature)
ContextFeature::ContextFeature (AtlApplication *app, const FeatureID &id)
ContextFeature::ContextFeature ()
virtual GenericObject * | MenuDescObj::Copy () const
Creates a copy of the object itself.
virtual InputMapper * | InputMapperFactory::CreateInstance ()=0
virtual BOOLEAN | FeatureItem::Execute ()
virtual BOOLEAN | Feature::Execute ()
virtual BOOLEAN | ContextFeature::Execute (const DataItem &data_item)
virtual BOOLEAN | ContextFeature::Execute ()
Feature::Feature (AtlApplication *app, const FeatureID &id)
Feature::Feature ()
FeatureItem::FeatureItem (Feature *feature, const WString &text, const ImageObtainer &icon)
FeatureItem::FeatureItem (Feature *feature, const WString &text)
FeatureItem::FeatureItem (Feature *feature)
FeatureItem::FeatureItem ()
FeatureItemContainer::FeatureItemContainer (FeatureItemContainerID container_id, BOOLEAN ignore_unavailable_features=TRUE)
FeatureItemContainer::FeatureItemContainer (BOOLEAN ignore_unavailable_features=TRUE)
AtlApplication * | Feature::GetApplication () const
BOOLEAN | KeySequenceCandidate::GetConsumeLastKey () const
BOOLEAN | KeySequence::GetConsumeLastKey () const
FeatureItemContainerID | FeatureItemContainer::GetContainerId () const
const ContextID & | FeatureItemContainer::GetContextId () const
const ContextID & | FeatureItem::GetContextId () const
ContextType | ContextFeature::GetContextType () const
const Feature * | FeatureItem::GetFeature () const
Feature * FeatureItem::GetFeature ()
FeatureID | FeatureItem::GetFeatureId () const
const FeatureID & | Feature::GetFeatureId () const
virtual ImageObtainer | ValueMappingPropertyDescriptor::GetIcon (INT index) const
virtual ImageObtainer | ValueMappingPropertyDescriptor::GetIcon (const DataItem &value) const
Obsolete method.
virtual ImageObtainer | ValueMappingPropertyDescriptor::GetIcon (const Property *property) const
ImageObtainer | TextIconPairArray::TextIconPair::GetIcon () const
virtual INT | InputMapperFactory::GetId () const =0
virtual INT | FeatureItemContainer::GetID () const
virtual INT | FeatureItem::GetID () const
virtual INT | Feature::GetID () const
virtual INT | ContextFeature::GetID () const
virtual Item * | FeatureItemContainer::GetItem (INT index) const
virtual INT | ValueMappingPropertyDescriptor::GetItemCount () const
virtual INT | FeatureItemContainer::GetItemCount () const
Returns the number of items of the item-grid.
virtual INT | FeatureItemContainer::GetItemIndex (const Item &item) const
INT | KeySequence::GetLength () const
const MappingPolicy * | ValueMappingPropertyDescriptor::GetMappingPolicy () const
const MenuDesc & | MenuDescObj::GetMenuDesc ()
INT | TextIconPairArray::GetSize () const
virtual WString | ValueMappingPropertyDescriptor::GetText (INT index) const
virtual WString | ValueMappingPropertyDescriptor::GetText (const DataItem &value) const
Obsolete method.
virtual WString | ValueMappingPropertyDescriptor::GetText (const Property *property) const
virtual const WString & | FeatureItem::GetText () const
INT | ValueMappingPropertyDescriptor::GetTextCount () const
Obsolete - use ValueMappingPropertyDescriptor::GetItemCount() instead.
virtual GenericTypeId | MenuDescObj::GetTypeId ()
Returns the identity of the class.
virtual DataItem | ValueMappingPropertyDescriptor::GetValue (INT index) const
BOOLEAN | KeySequence::HasKeyAtPos (const KeyCode &key_code, INT pos) const
void | FeatureItemContainer::IgnoreUnavailableFeatures (BOOLEAN flag)
virtual void | ValueMappingPropertyDescriptor::Init (const WString &title, const T_Container &pairs, const MappingPolicy *policy=0)
virtual void | ValueMappingPropertyDescriptor::Init (const WCHAR *title, const T_Container &pairs, const MappingPolicy *policy=0)
virtual void | ValueMappingPropertyDescriptor::Init (const T_Container &pairs, const MappingPolicy *policy=0, const CHAR *context_id=0)
virtual void | TextIconPairArray::Init (const TextIconPair *pair, INT size)
virtual void | InputMapperFactory::Init ()=0
void | FeatureItemContainer::Init (FeatureItemContainerID container_id, const WString &text, BOOLEAN ignore_unavailable_features=TRUE)
void | FeatureItemContainer::Init (FeatureItemContainerID container_id, BOOLEAN ignore_unavailable_features=TRUE)
void | FeatureItem::Init (Feature *feature, const WString &text, const ImageObtainer &icon)
void | FeatureItem::Init (Feature *feature, const WString &text)
void | FeatureItem::Init (Feature *feature=0)
void | Feature::Init (AtlApplication *app, const FeatureID &id, BOOLEAN available, BOOLEAN enabled)
void | Feature::Init (AtlApplication *app, const FeatureID &id)
void | ContextFeature::Init (AtlApplication *app, const FeatureID &id, ContextType contextType=ItemType)
virtual BOOLEAN | FeatureItemContainer::InsertItem (INT index, Item *item)
void | FeatureItemContainer::Invalidate ()
BOOLEAN | FeatureItem::IsAttachedToProperty (Property *property) const
BOOLEAN | FeatureItemContainer::IsAvailable () const
BOOLEAN | Feature::IsAvailable () const
BOOLEAN | ResourceID::IsEmpty () const
virtual BOOLEAN | FeatureItem::IsEnabled () const
BOOLEAN | Feature::IsEnabled () const
virtual BOOLEAN | FeatureItemContainer::IsEqual (const Item &item) const
The item is identical to this feature item container, it if has the same type and the same container_id.
virtual BOOLEAN | FeatureItem::IsEqual (const Item &item) const
virtual BOOLEAN | Feature::IsEqual (const Feature &feature) const
virtual BOOLEAN | ContextFeature::IsEqual (const Feature &feature) const
virtual BOOLEAN | MenuDescObj::IsEqual (GenericObject *object)
Compares the object parameter with the object instance itself.
BOOLEAN | KeySequenceCandidate::IsFinished () const
virtual BOOLEAN | ValueMappingPropertyDescriptor::IsInstanceOf (const INT id) const
virtual BOOLEAN | FeatureItemContainer::IsInstanceOf (INT id) const
virtual BOOLEAN | FeatureItem::IsInstanceOf (INT id) const
virtual BOOLEAN | Feature::IsInstanceOf (INT id) const
virtual BOOLEAN | ContextFeature::IsInstanceOf (INT id) const
BOOLEAN | Feature::IsNotificationBlocked () const
BOOLEAN | KeySequence::IsStartOfSequence (const KeyCode &key) const
BOOLEAN | KeySequenceCandidate::IsValidSequence (const KeyCode &key)
KeySequence::KeySequence (const KeyCode *keys, INT length, BOOLEAN consume_last_key)
KeySequenceCandidate::KeySequenceCandidate (const KeySequenceCandidate &candidate)
void | Feature::NotifyFeatureChange (INT property_id=UnspecifiedAttributeId)
virtual void | FeatureItem::OnLanguageChanged ()
BOOLEAN | operator!= (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator< (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator== (const ResourceID &lhs, const ResourceID &rhs)
BOOLEAN | operator> (const ResourceID &lhs, const ResourceID &rhs)
const TextIconPair * | TextIconPairArray::operator[] (INT index) const
void | TextIconPairArray::PopBack ()
void | TextIconPairArray::PushBack (TextIconPair pair)
virtual BOOLEAN | FeatureItemContainer::RemoveAllItems ()
virtual BOOLEAN | FeatureItemContainer::RemoveItem (INT index)
ResourceID::ResourceID (const CHAR *id)
ResourceID::ResourceID (const String &resourceID)
void | Feature::SetApplication (AtlApplication *app)
void | Feature::SetAvailable (BOOLEAN available)
Notifies both FeatureBroker and the focused control about this state change.
void | FeatureItemContainer::SetContainerId (FeatureItemContainerID container_id)
void | FeatureItemContainer::SetContextId (const CHAR *id)
void | FeatureItemContainer::SetContextId (const ContextID &id)
void | FeatureItem::SetContextId (const CHAR *id)
void | FeatureItem::SetContextId (const ContextID &id)
void | ContextFeature::SetContextType (ContextType type)
virtual void | FeatureItem::SetEnabled (BOOLEAN enabled)
void | Feature::SetEnabled (BOOLEAN enabled)
Notifies both FeatureBroker and the focused control about this state change.
void | FeatureItem::SetFeature (Feature *feature)
void | ResourceID::SetID (const String &id)
void | MenuDescObj::SetMenuDesc (const MenuDesc &menu_desc)
BOOLEAN | ValueMappingPropertyDescriptor::SetProperty (ResourceParser &parser, GuiObjectFactory::PropertyId property_id)
BOOLEAN | FeatureItemContainer::SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
BOOLEAN | FeatureItem::SetProperty (ResourceParser &parser, const GuiObjectFactory::PropertyId prop_id, UINT16 object_id)
virtual void | FeatureItem::SetText (const WString &text)
void | TextIconPairArray::SetTextIconPair (const TextIconPair *pair, INT size)
TextIconPairArray::TextIconPairArray (const TextIconPair *pair, INT size)
TextIconPairArray::TextIconPairArray ()
default constructor
const String & | ResourceID::ToString () const
BOOLEAN | FeatureItemContainer::UnavailableFeaturesIgnored () const
Returns TRUE if unavailable features are ignored, FALSE otherwise.
virtual void | FeatureItem::Update ()
Updates the text of the FeatureItem.
ValueMappingPropertyDescriptor::ValueMappingPropertyDescriptor (const WString &title, const T_Container &pairs, const MappingPolicy *policy=0)
ValueMappingPropertyDescriptor::ValueMappingPropertyDescriptor (const WCHAR *title, const T_Container &pairs, const MappingPolicy *policy=0)
ValueMappingPropertyDescriptor::ValueMappingPropertyDescriptor (const T_Container &pairs, const MappingPolicy *policy=0, const CHAR *context_id=0)
ValueMappingPropertyDescriptor::ValueMappingPropertyDescriptor ()
virtual | ContextFeature::~ContextFeature ()
virtual | Feature::~Feature ()
virtual | FeatureItem::~FeatureItem ()
virtual | FeatureItemContainer::~FeatureItemContainer ()
virtual | InputMapperFactory::~InputMapperFactory ()
KeySequence::~KeySequence ()
virtual | MenuDescObj::~MenuDescObj ()
ResourceID::~ResourceID ()
virtual | TextIconPairArray::~TextIconPairArray ()
destructor
virtual | ValueMappingPropertyDescriptor::~ValueMappingPropertyDescriptor ()
destructor

Variables

const GenericTypeId | c_img_obt_type = c_user_base_gentypes + 4802
const GenericTypeId | c_item_ptr_type = c_user_base_gentypes + 4801
const GenericTypeId | c_menu_desc_ptr_type = c_user_base_gentypes + 4800
const GenericTypeId | c_menu_id_ptr_type = c_user_base_gentypes + 4800
AtlApplication * Feature::m_app
Feature * FeatureItem::m_feature
FeatureID Feature::m_feature_id
const BitmapRes * | TextIconPairArray::TextIconPair::m_icon
SubstitutedText FeatureItem::m_substituted_text
const WCHAR * | TextIconPairArray::TextIconPair::m_text

Typedef Documentation

typedef EnumTextTableEntry EnumTextTable[]

typedef ValueMappingPropertyDescriptor<TextIconPairArray> StaticValueMappingPropertyDescriptor

Enumeration Type Documentation

template<class T_Container>
anonymous enum [inherited]

Enumerator:
ID

Reimplemented from ListPropertyDescriptor.

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from Action.

anonymous enum [inherited]

Enumerator:
ID

Reimplemented from Feature.

enum ContextFeature::ContextType [inherited]

Enumerator:
WStringType
NumberType
ItemTextType
PhoneNumberType
ItemType
ProviderType
ContainerType
UndefinedType

enum Feature::FeatureAttributeId [inherited]

When an attribute (property) of a feature has been changed, the message FeatureChangedMsg will be send. The message contains a property-index, which indicates the attribute property or attribute-group. The attribute-indices 0 to 99 are reserved for APOXI. Additional defined ids:

  • 2: Property::ValueAttributeId
Enumerator:
UnspecifiedAttributeId Not every property must have its own id. In this case UnspecifiedPropertyId may be used.
AvailableAttributeId
EnabledAttributeId
CustomAttributeId

enum FeatureItemContainer::FeatureItemContainerPropertyId [inherited]

Additional property context id for the feature item container

See also:
Item
Enumerator:
ContextPropertyId

enum FeatureItem::FeatureItemPropertyId [inherited]

Additional properties for the FeatureItem: feature id and context id

See also:
Item
Enumerator:
FeaturePropertyId
ContextPropertyId

enum FeatureItemContainer::Identifier [inherited]

Enumerator:
ID

Function Documentation

BOOLEAN FeatureItemContainer::AddItem ( Item * item ) [virtual, inherited]

Adds the item item after the already added items. NotifyPropertyChanged(ItemPropertyId) should be invoked if the operation has been successful.

Reimplemented from ItemContainer.

void Feature::BlockNotification ( BOOLEAN block ) [inline, inherited]

If block is TRUE, sending of FeatureChangedMsg in case of a state change is blocked. This might be useful when the feature-providing application needs to update the state of a set of features, whereby notification should be supressed. Per default the notification is not blocked.

BOOLEAN FeatureItemContainer::ContainsFeature ( Feature * feature ) [inherited]

Parameters:
feature feature to search for
Returns:
if the feature is found in the feature item container (no recursive search), TRUE is returned

ContextFeature::ContextFeature | ( | AtlApplication * | app,
 |  | const FeatureID & | id
 | ) | [inherited]

ContextFeature::ContextFeature ( ) [inherited]

GenericObject * MenuDescObj::Copy ( ) const [virtual, inherited]

Creates a copy of the object itself.

Implements GenericObject.

virtual InputMapper* InputMapperFactory::CreateInstance ( ) [pure virtual, inherited]

BOOLEAN FeatureItem::Execute ( ) [virtual, inherited]

Returns:
Return value of the executed feature.
See also:
Feature

Reimplemented from Action.

Reimplemented in ContextFeatureItem, IndicatorItem, and PropertyItem.

BOOLEAN Feature::Execute ( ) [virtual, inherited]

Returns:
TRUE, if the feature is enabled and available, and the FeatureTriggerMsg has been posted

Reimplemented in BackToIdleFeature, ContextFeature, and TriggerKeyFeature.

BOOLEAN ContextFeature::Execute ( const DataItem & data_item ) [virtual, inherited]

Parameters:
data_item Context item as feature invocation argument
Returns:
TRUE, if the feature is enabled, available, and there is an application assigned

BOOLEAN ContextFeature::Execute ( ) [virtual, inherited]

Returns:
TRUE, if the feature is enabled and available, and the FeatureTriggerMsg has been posted

Reimplemented from Feature.

Feature::Feature | ( | AtlApplication * | app,
 |  | const FeatureID & | id
 | ) | [inherited]

Feature::Feature ( ) [inherited]

FeatureItem::FeatureItem | ( | Feature * | feature,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon
 | ) | [inherited]

Parameters:
feature | feature, which will be wrapped
text | text of feature item
icon | icon of feature item

FeatureItem::FeatureItem | ( | Feature * | feature,
 |  | const WString & | text
 | ) | [inherited]

Parameters:
feature | feature, which will be wrapped
text | text of feature item

FeatureItem::FeatureItem ( Feature * feature ) [inherited]

Parameters:
feature feature, which will be wrapped

FeatureItem::FeatureItem ( ) [inherited]

If the default constructor is used, the parameters have to be provided by using the method Init.

FeatureItemContainer::FeatureItemContainer | ( | FeatureItemContainerID | container_id,
 |  | BOOLEAN | ignore_unavailable_features = TRUE
 | ) | [inherited]

Parameters:
container_id | id of feature item container
ignore_unavailable_features | defines, if unavailable features should be ignored or not

FeatureItemContainer::FeatureItemContainer ( BOOLEAN ignore_unavailable_features = TRUE ) [inherited]

Constructor

Parameters:
ignore_unavailable_features defines, if unavailable features should be ignored or not

AtlApplication* Feature::GetApplication ( ) const [inline, inherited]

Returns:
Feature-providing application

BOOLEAN KeySequenceCandidate::GetConsumeLastKey ( ) const [inherited]

BOOLEAN KeySequence::GetConsumeLastKey ( ) const [inherited]

FeatureItemContainerID FeatureItemContainer::GetContainerId ( ) const [inline, inherited]

Returns:
returns the container id

const ContextID& FeatureItemContainer::GetContextId ( ) const [inline, inherited]

Returns:
returns the context id of the feature item container

const ContextID& FeatureItem::GetContextId ( ) const [inline, inherited]

Returns:
returns the context id of the feature item

ContextType ContextFeature::GetContextType ( ) const [inline, inherited]

const Feature* FeatureItem::GetFeature ( ) const [inline, inherited]

Returns:
Feature, which is wrapped by the FeatureItem

Feature* FeatureItem::GetFeature ( ) [inline, inherited]

Returns:
Feature, which is wrapped by the FeatureItem

FeatureID FeatureItem::GetFeatureId ( ) const [inline, inherited]

Returns:
FeatureId of the wrapped feature

const FeatureID& Feature::GetFeatureId ( ) const [inline, inherited]

template<class T_Container>
ImageObtainer ValueMappingPropertyDescriptor< T_Container >::GetIcon ( INT index ) const [virtual, inherited]

Parameters:
value the index of the icon in the MappingPolicy that should be returned
Returns:
the n-th icon in the MappingPolicy.

Implements ListPropertyDescriptor.

template<class T_Container>
ImageObtainer ValueMappingPropertyDescriptor< T_Container >::GetIcon ( const DataItem & value ) const [virtual, inherited]

Obsolete method.

Reimplemented from PropertyDescriptor.

template<class T_Container>
ImageObtainer ValueMappingPropertyDescriptor< T_Container >::GetIcon ( const Property * property ) const [virtual, inherited]

Parameters:
property property, the icon of which should be retrieved
Returns:
the icon for the given property's value.

Reimplemented from PropertyDescriptor.

ImageObtainer TextIconPairArray::TextIconPair::GetIcon ( ) const [inherited]

virtual INT InputMapperFactory::GetId ( ) const [pure virtual, inherited]

INT FeatureItemContainer::GetID ( ) const [virtual, inherited]

Returns:
returns the runtime type id of FeatureItemContainer

INT FeatureItem::GetID ( ) const [virtual, inherited]

Returns:
returns the runtime type id of FeatureItemContainer

Reimplemented in ContextFeatureItem.

INT Feature::GetID ( ) const [virtual, inherited]

Reimplemented in BackToIdleFeature, ContextFeature, and TriggerKeyFeature.

INT ContextFeature::GetID ( ) const [virtual, inherited]

Reimplemented from Feature.

Item * FeatureItemContainer::GetItem ( INT index ) const [virtual, inherited]

Returns the item of the index index.

Reimplemented from ItemContainer.

template<class T_Container>
virtual INT ValueMappingPropertyDescriptor< T_Container >::GetItemCount ( ) const [inline, virtual, inherited]

Returns the number of text icon pairs, which are used to map a property's value to text and/or icon.

Returns:
number of text icon pairs.

Reimplemented from ListPropertyDescriptor.

INT FeatureItemContainer::GetItemCount ( ) const [virtual, inherited]

Returns the number of items of the item-grid.

Reimplemented from ItemContainer.

INT FeatureItemContainer::GetItemIndex ( const Item & item ) const [virtual, inherited]

Returns the index of the item item. If the item is not part of the item-grid, -1 is returned.

Reimplemented from ItemContainer.

INT KeySequence::GetLength ( ) const [inherited]

template<class T_Container>
const MappingPolicy* ValueMappingPropertyDescriptor< T_Container >::GetMappingPolicy ( ) const [inline, inherited]

Returns the MappingPolicy, which defines the mapping of a property's value to an index in the container of text and icon pairs. This method is obsolete and should not be used any more.

Returns:
MappingPolicy.

const MenuDesc& MenuDescObj::GetMenuDesc ( ) [inline, inherited]

INT TextIconPairArray::GetSize ( ) const [inline, inherited]

Returns:
the size of the container.

template<class T_Container>
WString ValueMappingPropertyDescriptor< T_Container >::GetText ( INT index ) const [virtual, inherited]

Parameters:
value the index of the text in the MappingPolicy that should be returned
Returns:
the n-th text in the MappingPolicy.

Implements ListPropertyDescriptor.

template<class T_Container>
WString ValueMappingPropertyDescriptor< T_Container >::GetText ( const DataItem & value ) const [virtual, inherited]

Obsolete method.

Reimplemented from PropertyDescriptor.

template<class T_Container>
WString ValueMappingPropertyDescriptor< T_Container >::GetText ( const Property * property ) const [virtual, inherited]

Parameters:
property property, the text of which should be retrieved
Returns:
the text for the given property's value.

Reimplemented from PropertyDescriptor.

const WString & FeatureItem::GetText ( ) const [virtual, inherited]

Returns:
text of the FeatureItem

Reimplemented from Item.

template<class T_Container>
INT ValueMappingPropertyDescriptor< T_Container >::GetTextCount ( ) const [inline, inherited]

Obsolete - use ValueMappingPropertyDescriptor::GetItemCount() instead.

GenericTypeId MenuDescObj::GetTypeId ( ) [virtual, inherited]

Returns the identity of the class.

Implements GenericObject.

template<class T_Container>
DataItem ValueMappingPropertyDescriptor< T_Container >::GetValue ( INT index ) const [virtual, inherited]

Parameters:
index the matching value to the index index should be returned
Returns:
A Property's value matching the given index in the ValueMappingPropertyDescriptor's TextIconPair

Reimplemented from ListPropertyDescriptor.

BOOLEAN KeySequence::HasKeyAtPos | ( | const KeyCode & | key_code,
 |  | INT | pos
 | ) | const [inherited]

void FeatureItemContainer::IgnoreUnavailableFeatures ( BOOLEAN flag ) [inline, inherited]

Parameters:
flag defines if unavailable feature should be ignored or not. If set to TRUE only avalaible features will be counted and are retrievable. Per default unavailable features are ignored

template<class T_Container>
void ValueMappingPropertyDescriptor< T_Container >::Init | ( | const WString & | title,
 |  | const T_Container & | pairs,
 |  | const MappingPolicy * | policy = 0
 | ) | [virtual, inherited]

Initialize and set paramters.

Parameters:
title | title of the PropertyEditor
pairs | Container of text and icon pairs, which will be used to display a property's value.
policy | MappingPolicy, which defines the mapping of a property's value to an index in the container of text and icon pairs.

template<class T_Container>
void ValueMappingPropertyDescriptor< T_Container >::Init | ( | const WCHAR * | title,
 |  | const T_Container & | pairs,
 |  | const MappingPolicy * | policy = 0
 | ) | [virtual, inherited]

Initialize and set paramters.

Parameters:
title | title of the PropertyEditor
pairs | Container of text and icon pairs, which will be used to display a property's value.
policy | MappingPolicy, which defines the mapping of a property's value to an index in the container of text and icon pairs.

template<class T_Container>
void ValueMappingPropertyDescriptor< T_Container >::Init | ( | const T_Container & | pairs,
 |  | const MappingPolicy * | policy = 0,
 |  | const CHAR * | context_id = 0
 | ) | [virtual, inherited]

Initialize and set paramters.

Parameters:
pairs | Container of text and icon pairs, which will be used to display a property's value.
policy | MappingPolicy, which defines the mapping of a property's value to an index in the container of text and icon pairs.

void TextIconPairArray::Init | ( | const TextIconPair * | pair,
 |  | INT | size
 | ) | [virtual, inherited]

Initialize and set paramters.

Parameters:
pair | array of TextIconPairs to be contained
size | the number of entries of array pair.

virtual void InputMapperFactory::Init ( ) [pure virtual, inherited]

void FeatureItemContainer::Init | ( | FeatureItemContainerID | container_id,
 |  | const WString & | text,
 |  | BOOLEAN | ignore_unavailable_features = TRUE
 | ) | [inherited]

Parameters:
container_id | container id of feature item container
text | text of feature item container
ignore_unavailable_features | defines, if unavailable features should be ignored or not

void FeatureItemContainer::Init | ( | FeatureItemContainerID | container_id,
 |  | BOOLEAN | ignore_unavailable_features = TRUE
 | ) | [inherited]

Parameters:
container_id | id of feature item container
ignore_unavailable_features | defines, if unavailable features should be ignored or not

void FeatureItem::Init | ( | Feature * | feature,
 |  | const WString & | text,
 |  | const ImageObtainer & | icon
 | ) | [inherited]

Parameters:
feature | feature, which will be wrapped
text | text of feature item
icon | icon of feature item

void FeatureItem::Init | ( | Feature * | feature,
 |  | const WString & | text
 | ) | [inherited]

Parameters:
feature | feature, which will be wrapped
text | text of feature item

void FeatureItem::Init ( Feature * feature = 0 ) [inherited]

Parameters:
feature feature, which will be wrapped

void Feature::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | BOOLEAN | available,
 |  | BOOLEAN | enabled
 | ) | [inherited]

void Feature::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id
 | ) | [inherited]

Reimplemented in Property.

void ContextFeature::Init | ( | AtlApplication * | app,
 |  | const FeatureID & | id,
 |  | ContextType | contextType = ItemType
 | ) | [inherited]

BOOLEAN FeatureItemContainer::InsertItem | ( | INT | index,
 |  | Item * | item
 | ) | [virtual, inherited]

Inserts the item item at the index index NotifyPropertyChanged(ItemPropertyId) should be invoked if the operation has been successful.

Reimplemented from ItemContainer.

void FeatureItemContainer::Invalidate ( ) [inherited]

See also:
Control

BOOLEAN FeatureItem::IsAttachedToProperty ( Property * property ) const [inherited]

Returns:
Returns TRUE if either the referenced Feature equals the property or the text of the FeatureItem is attached to a property value

BOOLEAN FeatureItemContainer::IsAvailable ( ) const [inherited]

Returns:
if any wrapped feature in the feature item container is available, this method returns TRUE, otherwise FALSE

BOOLEAN Feature::IsAvailable ( ) const [inline, inherited]

Returns TRUE, if the feature is available. Per default TRUE is returned.

BOOLEAN ResourceID::IsEmpty ( ) const [inline, inherited]

BOOLEAN FeatureItem::IsEnabled ( ) const [virtual, inherited]

See also:
Feature

Reimplemented from Item.

BOOLEAN Feature::IsEnabled ( ) const [inline, inherited]

Returns TRUE, if the feature is enabled. Per default TRUE is returned.

BOOLEAN FeatureItemContainer::IsEqual ( const Item & item ) const [virtual, inherited]

The item is identical to this feature item container, it if has the same type and the same container_id.

Reimplemented from Item.

BOOLEAN FeatureItem::IsEqual ( const Item & item ) const [virtual, inherited]

Returns:
TRUE, if class type and wrapped features are identical
See also:
Item

Reimplemented from Item.

BOOLEAN Feature::IsEqual ( const Feature & feature ) const [virtual, inherited]

Reimplemented in BackToIdleFeature, ContextFeature, and TriggerKeyFeature.

BOOLEAN ContextFeature::IsEqual ( const Feature & feature ) const [virtual, inherited]

Reimplemented from Feature.

BOOLEAN MenuDescObj::IsEqual ( GenericObject * object ) [virtual, inherited]

Compares the object parameter with the object instance itself.

Implements GenericObject.

BOOLEAN KeySequenceCandidate::IsFinished ( ) const [inherited]

template<class T_Container>
BOOLEAN ValueMappingPropertyDescriptor< T_Container >::IsInstanceOf ( const INT id ) const [virtual, inherited]

Returns TRUE, if the ValueMappingPropertyDescriptor is an instance of the class with the ID id. The IDs from 0 to 999 are reserved for APOXI.

Parameters:
id the id to be queried.

Reimplemented from ListPropertyDescriptor.

BOOLEAN FeatureItemContainer::IsInstanceOf ( INT id ) const [virtual, inherited]

See also:
Item

Reimplemented from ItemContainer.

BOOLEAN FeatureItem::IsInstanceOf ( INT id ) const [virtual, inherited]

See also:
Item

Reimplemented from Action.

Reimplemented in ContextFeatureItem, IndicatorItem, and PropertyItem.

BOOLEAN Feature::IsInstanceOf ( INT id ) const [virtual, inherited]

See also:
Item

Reimplemented in BackToIdleFeature, ContextFeature, TriggerKeyFeature, and Property.

BOOLEAN ContextFeature::IsInstanceOf ( INT id ) const [virtual, inherited]

See also:
Item

Reimplemented from Feature.

BOOLEAN Feature::IsNotificationBlocked ( ) const [inline, inherited]

Returns TRUE, if notification of feature state changes will be blocked. Per default FALSE is returned.

BOOLEAN KeySequence::IsStartOfSequence ( const KeyCode & key ) const [protected, inherited]

BOOLEAN KeySequenceCandidate::IsValidSequence ( const KeyCode & key ) [inherited]

KeySequence::KeySequence | ( | const KeyCode * | keys,
 |  | INT | length,
 |  | BOOLEAN | consume_last_key
 | ) | [inherited]

KeySequenceCandidate::KeySequenceCandidate ( const KeySequenceCandidate & candidate ) [inherited]

void Feature::NotifyFeatureChange ( INT property_id = UnspecifiedAttributeId ) [protected, inherited]

Sends the message FeatureChangedMsg. When adding properties to a derived class, this method should be invoked in the Set-method of the property, if the value is different from the current set value.

void FeatureItem::OnLanguageChanged ( ) [virtual, inherited]

See also:
Control

Reimplemented from Item.

BOOLEAN operator!= | ( | const ResourceID & | lhs,
 |  | const ResourceID & | rhs
 | ) | [inline]

BOOLEAN operator< | ( | const ResourceID & | lhs,
 |  | const ResourceID & | rhs
 | ) | [inline]

BOOLEAN operator== | ( | const ResourceID & | lhs,
 |  | const ResourceID & | rhs
 | ) | [inline]

BOOLEAN operator> | ( | const ResourceID & | lhs,
 |  | const ResourceID & | rhs
 | ) | [inline]

const TextIconPair* TextIconPairArray::operator[] ( INT index ) const [inline, inherited]

[] operator for array like access of the container's data

Parameters:
index the index of the TextIconPair to be returned
Returns:
the TextIconPair on a certain index.

void TextIconPairArray::PopBack ( ) [inline, inherited]

Vector like interface with empty implementation. Note that the TextIconPair*, which is held by this class is const and therefore cannot extended or decreased later.

void TextIconPairArray::PushBack ( TextIconPair pair ) [inline, inherited]

Vector like interface with empty implementation. Note that the TextIconPair*, which is held by this class is const and therefore cannot extended or decreased later.

BOOLEAN FeatureItemContainer::RemoveAllItems ( ) [virtual, inherited]

Removes all items. NotifyPropertyChanged(ItemPropertyId) should be invoked if the operation has been successful.

Reimplemented from ItemContainer.

BOOLEAN FeatureItemContainer::RemoveItem ( INT index ) [virtual, inherited]

Removes the item item at the index index. NotifyPropertyChanged(ItemPropertyId) should be invoked if the operation has been successful.

Reimplemented from ItemContainer.

ResourceID::ResourceID ( const CHAR * id ) [inherited]

ResourceID::ResourceID ( const String & resourceID ) [inherited]

void Feature::SetApplication ( AtlApplication * app ) [inline, inherited]

Parameters:
app Feature-providing application

void Feature::SetAvailable ( BOOLEAN available ) [inherited]

Notifies both FeatureBroker and the focused control about this state change.

void FeatureItemContainer::SetContainerId ( FeatureItemContainerID container_id ) [inline, inherited]

Parameters:
id id of the feature item container

void FeatureItemContainer::SetContextId ( const CHAR * id ) [inherited]

Parameters:
id context id of feature item container

void FeatureItemContainer::SetContextId ( const ContextID & id ) [inherited]

Parameters:
id context id of feature item container

void FeatureItem::SetContextId ( const CHAR * id ) [inherited]

Parameters:
context id of feature item

void FeatureItem::SetContextId ( const ContextID & id ) [inherited]

Parameters:
context id of feature item

void ContextFeature::SetContextType ( ContextType type ) [inline, inherited]

void FeatureItem::SetEnabled ( BOOLEAN enabled ) [virtual, inherited]

See also:
Feature

Reimplemented from Item.

void Feature::SetEnabled ( BOOLEAN enabled ) [inherited]

Notifies both FeatureBroker and the focused control about this state change.

void FeatureItem::SetFeature ( Feature * feature ) [inherited]

Parameters:
feature feature, which is wrapped by the FeatureItem

void ResourceID::SetID ( const String & id ) [inherited]

void MenuDescObj::SetMenuDesc ( const MenuDesc & menu_desc ) [inline, inherited]

template<class T_Container>
BOOLEAN ValueMappingPropertyDescriptor< T_Container >::SetProperty | ( | ResourceParser & | parser,
 |  | GuiObjectFactory::PropertyId | property_id
 | ) | [inherited]

Sets the parameters for objects generated by the GuiObjectFactory and Aragon.

Parameters:
parser | parser which parses the aragon file
property-id | id of the object's parameter to be set.

Reimplemented from ListPropertyDescriptor.

BOOLEAN FeatureItemContainer::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) | [inherited]

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from ItemContainer.

BOOLEAN FeatureItem::SetProperty | ( | ResourceParser & | parser,
 |  | const GuiObjectFactory::PropertyId | prop_id,
 |  | UINT16 | object_id
 | ) | [inherited]

Initializes the instance by reading out a resource file generated by ARAGON. This method may not be invoked by the MMI in a direct manner and might be changed in future releases.

Reimplemented from Action.

Reimplemented in ContextFeatureItem, IndicatorItem, and PropertyItem.

void FeatureItem::SetText ( const WString & text ) [virtual, inherited]

Parameters:
Text,which may contain placeholder for property values.
See also:
SubstitutedText

Reimplemented from Item.

void TextIconPairArray::SetTextIconPair | ( | const TextIconPair * | pair,
 |  | INT | size
 | ) | [inherited]

Set an array of text and icon pairs.

Parameters:
pair | array of TextIconPairs to be contained
size | the number of entries of array pair.

TextIconPairArray::TextIconPairArray | ( | const TextIconPair * | pair,
 |  | INT | size
 | ) | [inherited]

Parameters:
pair | array of TextIconPairs to be contained
size | the number of entries of array pair.

TextIconPairArray::TextIconPairArray ( ) [inherited]

default constructor

const String& ResourceID::ToString ( ) const [inline, inherited]

BOOLEAN FeatureItemContainer::UnavailableFeaturesIgnored ( ) const [inline, inherited]

Returns TRUE if unavailable features are ignored, FALSE otherwise.

void FeatureItem::Update ( ) [virtual, inherited]

Updates the text of the FeatureItem.

Reimplemented in IndicatorItem, and PropertyItem.

template<class T_Container>
ValueMappingPropertyDescriptor< T_Container >::ValueMappingPropertyDescriptor | ( | const WString & | title,
 |  | const T_Container & | pairs,
 |  | const MappingPolicy * | policy = 0
 | ) | [inherited]

Parameters:
title | title of the PropertyEditor
pairs | Container of text and icon pairs, which will be used to display a property's value.
policy | MappingPolicy, which defines the mapping of a property's value to an index in the container of text and icon pairs.

template<class T_Container>
ValueMappingPropertyDescriptor< T_Container >::ValueMappingPropertyDescriptor | ( | const WCHAR * | title,
 |  | const T_Container & | pairs,
 |  | const MappingPolicy * | policy = 0
 | ) | [inherited]

Parameters:
title | title of the PropertyEditor
pairs | Container of text and icon pairs, which will be used to display a property's value.
policy | MappingPolicy, which defines the mapping of a property's value to an index in the container of text and icon pairs.

template<class T_Container>
ValueMappingPropertyDescriptor< T_Container >::ValueMappingPropertyDescriptor | ( | const T_Container & | pairs,
 |  | const MappingPolicy * | policy = 0,
 |  | const CHAR * | context_id = 0
 | ) | [inherited]

Parameters:
pairs | Container of text and icon pairs, which will be used to display a property's value.
policy | MappingPolicy, which defines the mapping of a property's value to an index in the container of text and icon pairs.
context_id | ContextID of the PropertyDescriptor configures title, softkeys and keymapping of PropertyEditor.

template<class T_Container>
ValueMappingPropertyDescriptor< T_Container >::ValueMappingPropertyDescriptor ( ) [inline, inherited]

If the default constructor is used, the parameters have to be provided by calling Init. When using Aragon, the parameters are set in SetProperty.

ContextFeature::~ContextFeature ( ) [virtual, inherited]

Feature::~Feature ( ) [virtual, inherited]

FeatureItem::~FeatureItem ( ) [virtual, inherited]

FeatureItemContainer::~FeatureItemContainer ( ) [virtual, inherited]

InputMapperFactory::~InputMapperFactory ( ) [virtual, inherited]

KeySequence::~KeySequence ( ) [inherited]

MenuDescObj::~MenuDescObj ( ) [virtual, inherited]

ResourceID::~ResourceID ( ) [inherited]

TextIconPairArray::~TextIconPairArray ( ) [virtual, inherited]

destructor

template<class T_Container>
ValueMappingPropertyDescriptor< T_Container >::~ValueMappingPropertyDescriptor ( ) [virtual, inherited]

destructor

Variable Documentation

const GenericTypeId c_img_obt_type = c_user_base_gentypes + 4802

const GenericTypeId c_item_ptr_type = c_user_base_gentypes + 4801

const GenericTypeId c_menu_desc_ptr_type = c_user_base_gentypes + 4800

const GenericTypeId c_menu_id_ptr_type = c_user_base_gentypes + 4800

AtlApplication* Feature::m_app [protected, inherited]

Feature* FeatureItem::m_feature [protected, inherited]

FeatureID Feature::m_feature_id [protected, inherited]

const BitmapRes* TextIconPairArray::TextIconPair::m_icon [inherited]

SubstitutedText FeatureItem::m_substituted_text [protected, inherited]

const WCHAR* TextIconPairArray::TextIconPair::m_text [inherited]

Generated on Wed Jan 25 02:30:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiExtensions

GuiExtensions

Collaboration diagram for GuiExtensions:

Modules

GuiExtensionMenuAccessors

Typedefs

typedef ResourceID IndicatorID

Typedef Documentation

typedef ResourceID IndicatorID

Generated on Wed Jan 25 02:30:02 2006 for APOXI by doxygen 1.4.6-NO


APOXI: GuiExtensionMenuAccessors

GuiExtensionMenuAccessors
[GuiExtensions]

Collaboration diagram for GuiExtensionMenuAccessors:

Data Structures

class UibActionAccessor
Generated on Wed Jan 25 02:30:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Config

Config

Data Structures

class | AtiCodecsLib
class | AtlConfig
class | DisplayConfig
class | EditConfig
class | EmzCodecsLib
class | EmzCodecsLib
class | FontConfig
class | GuiEngineConfig
class | GuiObjectFactory
class | KeyboardConfig
class | LocaleConfig
class | MemoryConfig
class | OptionalConfig
class | ScicosCodecIfLib
class | T9InputConfig
class | ThemeConfig
class | Zi8InputConfig

Typedefs

typedef Vector< InputMapperFactory * > | InputMapperVector

Typedef Documentation

typedef Vector<InputMapperFactory*> InputMapperVector

Generated on Wed Jan 25 02:30:06 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTestCaseManager

UnitTestCaseManager

Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTestManager

UnitTestManager

Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTestRepositoryManager

UnitTestRepositoryManager

Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTest

UnitTest

Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTestDataManager

UnitTestDataManager

Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnitTestResultManager

UnitTestResultManager

Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AdvPhonebook

AdvPhonebook

Collaboration diagram for AdvPhonebook:

Modules

AdvPhonebookActions
AdvPhonebookProvider

Data Structures

class | AdvPbApp
class | AdvPbWin
class | GroupProvider
class | PbAdvDetails
class | PbManualSynchronizer
class | PbSelectGroup
class | PbSelectNoType
class | UpdatePbThreadlet

Defines

#define | MAX_GROUP_COUNT 10

Variables

const INT | c_max_groups = 10

Define Documentation

#define MAX_GROUP_COUNT 10

Variable Documentation

const INT c_max_groups = 10

Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AdvPhonebookActions

AdvPhonebookActions
[AdvPhonebook]

Collaboration diagram for AdvPhonebookActions:

Data Structures

class | AdvPbAction
class | PbAddPhoneNoAction
class | PbAdvDetailAction
class | PbCancelAddNoAction
class | PbChangeNoTypeAction
class | PbConfirmAddNoAction
class | PbDelPhonenoAction
class | PbSelectGroupAction
class | SyncPhoneAction
class | SyncPhoneAllAction
class | SyncSimAction
class | SyncSimAllAction
Generated on Wed Jan 25 02:30:09 2006 for APOXI by doxygen 1.4.6-NO


APOXI: AdvPhonebookProvider

AdvPhonebookProvider
[AdvPhonebook]

Collaboration diagram for AdvPhonebookProvider:

Data Structures

class | PbAdvDataHandler
class | PbFfsNameHandler
class | PbFfsNumberHandler
class | PbMergeProvider
class | PbNameProvider
class | PbNextFreeIdRecord
class | PbNumberProvider
class | PbNumberRecord
class | PbRecord
class | PbRecordHandler
class | PbRecordProvider

Variables

const UINT32 | c_max_unique_id = 0xFFFFFFFF

Variable Documentation

const UINT32 c_max_unique_id = 0xFFFFFFFF

Generated on Wed Jan 25 02:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Phonebook

Phonebook

Collaboration diagram for Phonebook:

Modules

Synchronization

Data Structures

class | AddAllToFdnAction
class | AddEntryToFdnAction
class | AddNumberToFdnAction
class | BasicPbWin
class | CopyHandler
class | CopyToPbAction
class | DisplayMemoryAction
class | PbAbstractWin
class | PbAction
class | PbAddAction
class | PbAdvAddEditEntry
class | PbBaseWin
class | PbCallAction
class | PbCancelEditAction
class | PbConfirmEditAction
class | PbCopyHandler
class | PbDataHandler
class | PbDelAllAction
class | PbDeleteAction
class | PbDetailAction
class | PbDetailEditBox
class | PbDetailListBox
class | PbDetailListBoxModel
class | PbDetailProvider
class | PbDetails
class | PbEditDetailAction
class | PbLazySynchronizer
class | PbNameEditBox
class | PbNameFilterProvider
class | PbNameNumberProvider
class | PbNumberFilterProvider
class | PbPhoneNumberPrompt
class | PbProvColListBox
class | PbProvColListBoxModel
class | PbProviderListener
class | PbProvListBox
class | PbProvListBoxModel
class | PbSecuredAction
class | PbSelectNumberWin
class | PbSimProvider
class | PbSortedProvider
class | PbSynchronizer
class | PbToggleAction
class | PhonebookApp
class | PhonebookWin
class | ProvColListBoxWin
class | ProvDetailListBoxWin
class | ProvListBoxWin
class | SaveNoAction
class | SearchBox
class | SyncAction

Variables

const INT | c_email_id = 2205
const INT | c_grp_prov_id = 2204
const INT | c_icc_id_id = 2206
const INT | c_last_deleted_unique_id = 2216
const INT | c_name_key_id = 2201
const INT | c_name_prov_id = 2214
const INT | c_new_recno_id = 2202
const INT | c_no_id_id = 2210
const INT | c_no_prov_id = 2203
const INT | c_on_sim_id = 2213
const INT | c_phoneno_type_id = 2211
const INT | c_recno_id = 2200
const INT | c_sim_recno_id = 2212
const INT | c_unique_id = 2215

Variable Documentation

const INT c_email_id = 2205

const INT c_grp_prov_id = 2204

const INT c_icc_id_id = 2206

const INT c_last_deleted_unique_id = 2216

const INT c_name_key_id = 2201

const INT c_name_prov_id = 2214

const INT c_new_recno_id = 2202

const INT c_no_id_id = 2210

const INT c_no_prov_id = 2203

const INT c_on_sim_id = 2213

const INT c_phoneno_type_id = 2211

const INT c_recno_id = 2200

const INT c_sim_recno_id = 2212

const INT c_unique_id = 2215

Generated on Wed Jan 25 02:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Synchronization

Synchronization
[Phonebook]

Collaboration diagram for Synchronization:

Data Structures

class CsdDataConnProvider
Generated on Wed Jan 25 02:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallSettings

CallSettings

Data Structures

class BtHfRecord
Generated on Wed Jan 25 02:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: BtHfPlugin

BtHfPlugin

Generated on Wed Jan 25 02:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CalendarListWin

CalendarListWin

Data Structures

class | CalendarListWin
This class declares a new kind of window derived from class MmiItemListWindow. More...
class | CalendarListWin
This class declares a new kind of window derived from class MmiItemListWindow. More...
Generated on Wed Jan 25 02:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: CallRecords

CallRecords

Data Structures

class CalendarRecordsList
Generated on Wed Jan 25 02:30:11 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Dataconn

Dataconn

Data Structures

class | PsdDataConnProvider
class | SerDataConnProvider
Generated on Wed Jan 25 02:30:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: EMS

EMS

Data Structures

class | EditorItemNode
class | EmsComposeWin
class | EmsCreator
class | EmsEditor
class | EmsEditorListener
class | EmsIeParser
class | EmsImage
class | EmsInsertPrompt
class | EmsInsertPromptListBoxModel
class | EmsResourceMaps
class | EmsViewerWin
class | PredefinedEmsImage
class | PredefinedEmsSound

Defines

#define | COLOR_COUNT 16

Define Documentation

#define COLOR_COUNT 16

Generated on Wed Jan 25 02:30:13 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ExtractSmsTextPlugin

ExtractSmsTextPlugin

Data Structures

struct | SmsTextEntry
class | SmsTextParser

Enumerations

enum | SmsTextItemType { SmsTextItemType_PhoneNumber, SmsTextItemType_Url, SmsTextItemType_Email }

Enumeration Type Documentation

enum SmsTextItemType

Enumerator:
SmsTextItemType_PhoneNumber
SmsTextItemType_Url
SmsTextItemType_Email

Generated on Wed Jan 25 02:30:14 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowserCommon

ImageBrowserCommon

Data Structures

class | BrowserSaveWin
class | BrowserSaveWin
class | BrowserView
class | BrowserView
class | BrowserViewContainer
class | BrowserViewContainer
class | FileNameListBoxModel
Model for showing filenames stored in a MediaRefContainer. More...
class | FileNameListBoxModel
Model for showing filenames stored in a MediaRefContainer. More...
class | FileNameView
View for showing filenames by the use of a FileNameListBoxModel. More...
class | FileNameView
View for showing filenames by the use of a FileNameListBoxModel. More...
class | ImageFilter
Base class for filters concerning image references. More...
class | ImageFilter
Base class for filters concerning image references. More...
class | InfoDialog
Dialog showing some information only. More...
class | InfoDialog
Dialog showing some information only. More...
class | MediaBrowserUtils
Utility class for SB and IB. More...
class | MediaBrowserUtils
Utility class for SB and IB. More...
class | MediaFilter
Base class for filter that can be used by the image or sound browser. More...
class | MediaFilter
Base class for filter that can be used by the image or sound browser. More...
class | MediaPathnameVisitor
class | MediaPathnameVisitor
class | MediaRef
class | MediaRef
class | MediaRefContainer
class | MediaRefContainer
struct | MediaRefLinkable
The Linkable wrapping a MediaRef smart pointer. More...
struct | MediaRefLinkable
The Linkable wrapping a MediaRef smart pointer. More...
class | MediaVisitor
class | MediaVisitor
class | MetaData
class | MetaData
struct | MetaDataRecord
struct | MetaDataRecord
class | MimeTypeFilter
class | MimeTypeFilter
class | RenameFileDialog
Dialog for renaming a file with the media browser. More...
class | RenameFileDialog
Dialog for renaming a file with the media browser. More...
class | SoundFilter
Base class for filters concerning sound references. More...
class | SoundFilter
Base class for filters concerning sound references. More...

Typedefs

typedef NiSharedPtr< File > | FilePtr
typedef NiSharedPtr< File > | FilePtr
typedef NiSharedPtr< MediaRef > | MediaRefPtr
typedef NiSharedPtr< MediaRef > | MediaRefPtr

Typedef Documentation

typedef NiSharedPtr<File> FilePtr

typedef NiSharedPtr<File> FilePtr

typedef NiSharedPtr<MediaRef> MediaRefPtr

typedef NiSharedPtr<MediaRef> MediaRefPtr

Generated on Wed Jan 25 02:30:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ImageBrowser

ImageBrowser

Data Structures

class | ImageBrowserApp
class | ImageBrowserDetailWin
class | ImageBrowserTestWin
class | ImageBrowserWin
class | ImageListBoxModel
Base class of a model for showing images. More...
class | ImageListBoxView
class | ImageMetaData
struct | ImageMetaDataRecord
class | ImageRef
class | ImageView
class | ImageViewListBoxModel
Class to serve as a model for the ImageView. More...
class | SavingProgressWin

Defines

#define | IMAGE_ITEM_HEIGHT 36

Variables

UINT8 | devil [devil_size]
const UINT | devil_size = 61
UINT8 | g_drm_cd_j1k_data [1936]
UINT8 | g_drm_cd_res2_data [2716]
UINT8 | g_drm_fl_res2_data [2363]
UINT8 HUGE | gif_image [gif_image_size]
const UINT HUGE | gif_image_size = 1851
UINT8 HUGE | jpeg_image [jpeg_image_size]
const UINT HUGE | jpeg_image_size = 16035
UINT8 | kissing [kissing_size]
const UINT | kissing_size = 61
UINT8 HUGE | png_image [png_image_size]
const UINT HUGE | png_image_size = 978
UINT8 | wow [wow_size]
const UINT | wow_size = 64

Define Documentation

#define IMAGE_ITEM_HEIGHT 36

Variable Documentation

UINT8 devil[devil_size]

const UINT devil_size = 61

UINT8 g_drm_cd_j1k_data[1936]

UINT8 g_drm_cd_res2_data[2716]

UINT8 g_drm_fl_res2_data[2363]

UINT8 HUGE gif_image[gif_image_size]

const UINT HUGE gif_image_size = 1851

UINT8 HUGE jpeg_image[jpeg_image_size]

const UINT HUGE jpeg_image_size = 16035

UINT8 kissing[kissing_size]

const UINT kissing_size = 61

UINT8 HUGE png_image[png_image_size]

const UINT HUGE png_image_size = 978

UINT8 wow[wow_size]

const UINT wow_size = 64

Generated on Wed Jan 25 02:30:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: IrdaApp

IrdaApp

Data Structures

class | IrdaApp
class | IrdaWin
Generated on Wed Jan 25 02:30:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ObexApp

ObexApp

Data Structures

class | ObexApp
class | ObexTransportWin

Functions

void | ObexTransportWin::Init ()
To Initialize actions and action accessors.
ObexTransportWin::ObexTransportWin ()
Constructor.
virtual BOOLEAN | ObexTransportWin::OnCancel ()
virtual void | ObexTransportWin::OnClose ()
virtual BOOLEAN | ObexTransportWin::OnConfirm ()
BOOLEAN | ObexTransportWin::OnKeyDown (KeyCode key_code)
virtual void | ObexTransportWin::OnLayoutClient ()
virtual | ObexTransportWin::~ObexTransportWin ()
Destructor.

Function Documentation

void ObexTransportWin::Init ( ) [inherited]

To Initialize actions and action accessors.

ObexTransportWin::ObexTransportWin ( ) [inherited]

Constructor.

BOOLEAN ObexTransportWin::OnCancel ( ) [protected, virtual, inherited]

void ObexTransportWin::OnClose ( ) [protected, virtual, inherited]

BOOLEAN ObexTransportWin::OnConfirm ( ) [protected, virtual, inherited]

BOOLEAN ObexTransportWin::OnKeyDown ( KeyCode key_code ) [protected, inherited]

void ObexTransportWin::OnLayoutClient ( ) [protected, virtual, inherited]

ObexTransportWin::~ObexTransportWin ( ) [virtual, inherited]

Destructor.

Generated on Wed Jan 25 02:30:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SoundBrowser

SoundBrowser

Data Structures

class | SoundBrowserApp
class | SoundBrowserTestWin
class | SoundBrowserWin
class | SoundMetaData
struct | SoundMetaDataRecord
class | SoundRef
class | SoundRefContainer

Variables

UINT8 | knockyourhead [knockyourhead_size]
const UINT | knockyourhead_size = 353
UINT8 | mambo [mambo_size]
const UINT | mambo_size = 128
UINT8 | withoutme [withoutme_size]
const UINT | withoutme_size = 296

Variable Documentation

UINT8 knockyourhead[knockyourhead_size]

const UINT knockyourhead_size = 353

UINT8 mambo[mambo_size]

const UINT mambo_size = 128

UINT8 withoutme[withoutme_size]

const UINT withoutme_size = 296

Generated on Wed Jan 25 02:30:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: ToDoListWin

ToDoListWin

Data Structures

class | ToDoListWin
This class declares a new kind of window derived from class MmiItemListWindow. More...
class | ToDoListWin
This class declares a new kind of window derived from class MmiItemListWindow. More...
Generated on Wed Jan 25 02:30:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Settings

Settings

Data Structures

class | ToDoRecord

Variables

const Date | c_invalid_date (99, 99, 9999)
const INT | c_note_max_length = 160

Variable Documentation

const Date c_invalid_date(99, 99, 9999)

const INT c_note_max_length = 160

Generated on Wed Jan 25 02:30:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnifiedInbox

UnifiedInbox

Data Structures

class | UibAccessorTest
class | UibApp
class | UibFolderWin
class | UibInboxProvider
class | UibListBoxModel
class | UibServiceImpl
class | UibSettingsProvider
class | UibSettingsWin

Enumerations

enum | UibApp::UibServiceType { UibApp::RegisterType, UibApp::NotifyType }

Functions

virtual BOOLEAN | UibSettingsProvider::CommitRow (INT row)
Commit updates done in a row.
void | UibApp::DeleteAllMsg (UibConfig::UibFolderTypes folder_type)
Deletes all rows of a specific folder.
virtual const BitmapRes * | UibListBoxModel::GetCellIcon (INT index, BOOLEAN highlighted)
virtual const WCHAR * | UibListBoxModel::GetCellText (INT index, BOOLEAN highlighted)
virtual DataItem | UibApp::GetContextDataItem (ContextFeature *feature)
virtual BOOLEAN | UibSettingsProvider::GetDataItem (INT columnid, INT row, DataItem &item)
GetDataItem reads data items
UibConfig::UibFolderTypes | UibFolderWin::GetFolderType () const
static UibApp * | UibApp::GetInstance ()
one instance of the class
INT | UibApp::GetMessageType (INT index)
const WCHAR * | UibAccessorTest::GetName ()
Returns the name of the Test Case.
Provider * UibListBoxModel::GetProvider ()
virtual INT | UibSettingsProvider::GetProviderId () const
Returns the provider id.
INT | UibFolderWin::GetSelectedMsg ()
Returns the selected index of the message.
Provider * UibApp::GetSettingsProvider ()
INT | UibApp::GetSortColid (UibConfig::UibFolderTypes folder_type)
the id of the column to sort
SortProvider * | UibApp::GetSortedFolderProvider (UibConfig::UibFolderTypes folder_type)
void | UibAccessorTest::Init (MmiUnitTestSuite *suite, BOOLEAN proceed_on_failed=TRUE)
Initalizes TestUibData wiht name and MmiUnitTestSuite.
void | UibSettingsWin::Init (Provider *settings_provider)
void | UibSettingsProvider::Init ()
void | UibServiceImpl::Init (Application *app)
void | UibListBoxModel::Init (DrawableObjectListBox *list_box, Provider *provider)
Initialize the UibListBoxModel with DrawableObjectListBox and UibInboxWin.
void | UibFolderWin::Init (UibApp *uib_app, UibConfig::UibFolderTypes folder_type, AbstractItemContainer *item_cont)
virtual ServiceResult | UibServiceImpl::NotifyArrival () const
virtual void | UibSettingsWin::OnClose ()
virtual void | UibApp::OnClose ()
virtual BOOLEAN | UibSettingsWin::OnConfirm ()
virtual BOOLEAN | UibApp::OnContextFeatureTriggered (const FeatureID &feature_id, const DataItem &context_item)
virtual BOOLEAN | UibApp::OnFeatureTriggered (const FeatureID &feature_id)
virtual void | UibFolderWin::OnGetFocus ()
virtual void | UibApp::OnGetFocus ()
virtual void | UibApp::OnLoseFocus ()
virtual BOOLEAN | UibFolderWin::OnMessage (const Message &msg)
virtual BOOLEAN | UibApp::OnMessage (const Message &msg)
virtual void | UibSettingsWin::OnOpen ()
virtual void | UibFolderWin::OnOpen ()
virtual void | UibApp::OnOpen ()
virtual BOOLEAN | UibApp::OnPropertyNotification (const Property::Notification notification, const Property *property, const DataItem &value)
virtual void | UibFolderWin::OnSelectionChanged ()
Notifies Context Manager about selection change events.
void | UibApp::OnSortingChanged (UibConfig::UibFolderTypes folder_type)
virtual void | UibApp::OnStartup ()
virtual void | UibApp::OnUibNotifyService ()
virtual void | UibApp::OnUibRegisterService (UINT8 box_type, Provider *provider)
virtual void | UibFolderWin::OnUpdate (ObservableObject *obs_obj)
virtual ServiceResult | UibServiceImpl::Register (UINT8 box_type, Provider *folder) const
virtual void | UibSettingsProvider::RestoreFactorySettings ()
Sets all Provider settings back to default.
virtual INT | UibSettingsProvider::RowCount ()
RowCount returns the number of rows.
virtual TestResult | UibAccessorTest::Run ()
Implement the Test Case.
virtual BOOLEAN | UibSettingsProvider::SelectRow (INT row)
Select the row and copy data into internal buffer.
virtual BOOLEAN | UibSettingsProvider::SetDataItem (const DataItem &item, INT columnid)
void | UibSettingsWin::SetFolderType (UibConfig::UibFolderTypes folder_type)
void | UibFolderWin::SetFolderType (UibConfig::UibFolderTypes folder_type)
void | UibAccessorTest::SetPreconditions ()
void | UibListBoxModel::SetProvider (Provider *provider)
void | UibFolderWin::SetUibContextId ()
void | UibApp::ShowWaitingBox (BOOLEAN flag)
void | UibAccessorTest::TestGetAction ()
void | UibAccessorTest::TestGetActionCount ()
void | UibAccessorTest::TestGetActionIndex (const Action &action)
void | UibAccessorTest::TestInsertAction (INT index)
void | UibAccessorTest::TestRemoveAccessor ()
void | UibAccessorTest::TestRemoveAction (INT index)
void | UibAccessorTest::TestRemoveAllActions ()
void | UibAccessorTest::TestSetAccessor (ActionAccessor *accessor)
UibAccessorTest::UibAccessorTest (MmiUnitTestSuite *suite, BOOLEAN proceed_on_failed=TRUE)
UibAccessorTest::UibAccessorTest ()
Constructor.
UibFolderWin::UibFolderWin ()
Constructor.
UibListBoxModel::UibListBoxModel ()
Constructor.
UibServiceImpl::UibServiceImpl ()
UibSettingsProvider::UibSettingsProvider ()
Constructor.
UibSettingsWin::UibSettingsWin (Provider *settings_provider=0)
UibSettingsWin.
virtual void | UibListBoxModel::Update (INT item_count=-1)
void | UibFolderWin::Update ()
void | UibApp::UpdateFolderProvider (UibConfig::UibFolderTypes folder_type)
virtual | UibAccessorTest::~UibAccessorTest ()
Destructor.
virtual | UibApp::~UibApp ()
Destructor.
virtual | UibFolderWin::~UibFolderWin ()
Destructor.
virtual | UibListBoxModel::~UibListBoxModel ()
Destructor.
virtual | UibSettingsProvider::~UibSettingsProvider ()
Destructor.
virtual | UibSettingsWin::~UibSettingsWin ()
Destructor.

Detailed Description

A_INCLUDED

Enumeration Type Documentation

enum UibApp::UibServiceType [inherited]

Enumerator:
RegisterType
NotifyType

Function Documentation

BOOLEAN UibSettingsProvider::CommitRow ( INT row ) [virtual, inherited]

Commit updates done in a row.

Reimplemented from Provider.

void UibApp::DeleteAllMsg ( UibConfig::UibFolderTypes folder_type ) [inherited]

Deletes all rows of a specific folder.

const BitmapRes * UibListBoxModel::GetCellIcon | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual, inherited]

Returns BitmapRes* for the message icon on the rendered index. GetProvider() form UibApp returns the Provider, GetDataItem the DataItem on the rendered index

const WCHAR * UibListBoxModel::GetCellText | ( | INT | index,
 |  | BOOLEAN | highlighted
 | ) | [virtual, inherited]

Returns WString* for the message text on the rendered index. GetProvider() form UibApp returns the Provider, GetDataItem the DataItem on the rendered index

DataItem UibApp::GetContextDataItem ( ContextFeature * feature ) [virtual, inherited]

BOOLEAN UibSettingsProvider::GetDataItem | ( | INT | columnid,
 |  | INT | row,
 |  | DataItem & | item
 | ) | [virtual, inherited]

GetDataItem reads data items

Implements Provider.

UibConfig::UibFolderTypes UibFolderWin::GetFolderType ( ) const [inline, inherited]

UibApp * UibApp::GetInstance ( ) [static, inherited]

one instance of the class

INT UibApp::GetMessageType ( INT index ) [inherited]

const WCHAR* UibAccessorTest::GetName ( ) [inline, inherited]

Returns the name of the Test Case.

Provider* UibListBoxModel::GetProvider ( ) [inline, inherited]

INT UibSettingsProvider::GetProviderId ( ) const [virtual, inherited]

Returns the provider id.

Implements Provider.

INT UibFolderWin::GetSelectedMsg ( ) [inherited]

Returns the selected index of the message.

Provider* UibApp::GetSettingsProvider ( ) [inline, inherited]

INT UibApp::GetSortColid ( UibConfig::UibFolderTypes folder_type ) [inherited]

the id of the column to sort

SortProvider * UibApp::GetSortedFolderProvider ( UibConfig::UibFolderTypes folder_type ) [inherited]

Handles the indication of an incoming msg dependent on the message type

Parameters:
UibMessageTypes

void UibAccessorTest::Init | ( | MmiUnitTestSuite * | suite,
 |  | BOOLEAN | proceed_on_failed = TRUE
 | ) | [inherited]

Initalizes TestUibData wiht name and MmiUnitTestSuite.

void UibSettingsWin::Init ( Provider * settings_provider ) [inherited]

Initialize UibSettingsWin with UibApp. m_checkbox_action, m_sort_type_buttona and m_sort_date_button are initialized with Dispatcher and text. Dispatcher of those actions is UibSettingsWin (this).Add the RadioButtonActions to a RadioButtonGroup guarantee that only one RadioButton can be selected.

void UibSettingsProvider::Init ( ) [inherited]

void UibServiceImpl::Init ( Application * app ) [inherited]

void UibListBoxModel::Init | ( | DrawableObjectListBox * | list_box,
 |  | Provider * | provider
 | ) | [inherited]

Initialize the UibListBoxModel with DrawableObjectListBox and UibInboxWin.

void UibFolderWin::Init | ( | UibApp * | uib_app,
 |  | UibConfig::UibFolderTypes | folder_type,
 |  | AbstractItemContainer * | item_cont
 | ) | [inherited]

Initialize the UibFolderWin with the appendent application and the text of the window. Sets the Softkeys of the Window (ActionAccessor and cancel action)

ServiceResult UibServiceImpl::NotifyArrival ( ) const [virtual, inherited]

Notifies the Unified Inbox that a new message has arrived in one of the hosted messaging application. This leads to an indication on the idle screen and Provider update.

void UibSettingsWin::OnClose ( ) [protected, virtual, inherited]

void UibApp::OnClose ( ) [protected, virtual, inherited]

BOOLEAN UibSettingsWin::OnConfirm ( ) [protected, virtual, inherited]

BOOLEAN UibApp::OnContextFeatureTriggered | ( | const FeatureID & | feature_id,
 |  | const DataItem & | context_item
 | ) | [protected, virtual, inherited]

BOOLEAN UibApp::OnFeatureTriggered ( const FeatureID & feature_id ) [protected, virtual, inherited]

void UibFolderWin::OnGetFocus ( ) [protected, virtual, inherited]

When getting the focus, the correct context id has to be set. This can be the context of the selected FeatureItem, the context of the current FeatureItemContainer or the context of the window.

Reimplemented from AtlItemGridWindow.

void UibApp::OnGetFocus ( ) [protected, virtual, inherited]

void UibApp::OnLoseFocus ( ) [protected, virtual, inherited]

BOOLEAN UibFolderWin::OnMessage ( const Message & msg ) [protected, virtual, inherited]

See also:
Dispatcher::OnMessage

Reimplemented from AtlItemGridWindow.

BOOLEAN UibApp::OnMessage ( const Message & msg ) [protected, virtual, inherited]

void UibSettingsWin::OnOpen ( ) [protected, virtual, inherited]

void UibFolderWin::OnOpen ( ) [protected, virtual, inherited]

See also:
Control::OnOpen

Reimplemented from AtlItemListWindow.

void UibApp::OnOpen ( ) [protected, virtual, inherited]

BOOLEAN UibApp::OnPropertyNotification | ( | const Property::Notification | notification,
 |  | const Property * | property,
 |  | const DataItem & | value
 | ) | [protected, virtual, inherited]

void UibFolderWin::OnSelectionChanged ( ) [protected, virtual, inherited]

Notifies Context Manager about selection change events.

Reimplemented from AtlItemListWindow.

void UibApp::OnSortingChanged ( UibConfig::UibFolderTypes folder_type ) [inherited]

void UibApp::OnStartup ( ) [protected, virtual, inherited]

void UibApp::OnUibNotifyService ( ) [protected, virtual, inherited]

void UibApp::OnUibRegisterService | ( | UINT8 | box_type,
 |  | Provider * | provider
 | ) | [protected, virtual, inherited]

void UibFolderWin::OnUpdate ( ObservableObject * obs_obj ) [protected, virtual, inherited]

Is invoked when the state of the Observable-Object obs_obj has been changed. To get invoked by the Observable-Object the Observer must attach itself by ObservableObject::Attach(this).

Reimplemented from Observer.

ServiceResult UibServiceImpl::Register | ( | UINT8 | box_type,
 |  | Provider * | folder
 | ) | const [virtual, inherited]

Registers an application that exports a message folder in "folder". The box_type indicates the type of message folder. For the Unified Inbox only the box_type Inbox should be exported.

void UibSettingsProvider::RestoreFactorySettings ( ) [virtual, inherited]

Sets all Provider settings back to default.

Implements SettingsProvider.

INT UibSettingsProvider::RowCount ( ) [virtual, inherited]

RowCount returns the number of rows.

Reimplemented from SettingsProvider.

TestResult UibAccessorTest::Run ( ) [virtual, inherited]

Implement the Test Case.

BOOLEAN UibSettingsProvider::SelectRow ( INT row ) [virtual, inherited]

Select the row and copy data into internal buffer.

Reimplemented from Provider.

BOOLEAN UibSettingsProvider::SetDataItem | ( | const DataItem & | item,
 |  | INT | columnid
 | ) | [virtual, inherited]

Reimplemented from Provider.

void UibSettingsWin::SetFolderType ( UibConfig::UibFolderTypes folder_type ) [inline, inherited]

void UibFolderWin::SetFolderType ( UibConfig::UibFolderTypes folder_type ) [inherited]

void UibAccessorTest::SetPreconditions ( ) [protected, inherited]

void UibListBoxModel::SetProvider ( Provider * provider ) [inline, inherited]

void UibFolderWin::SetUibContextId ( ) [inherited]

void UibApp::ShowWaitingBox ( BOOLEAN flag ) [inherited]

void UibAccessorTest::TestGetAction ( ) [protected, inherited]

void UibAccessorTest::TestGetActionCount ( ) [protected, inherited]

void UibAccessorTest::TestGetActionIndex ( const Action & action ) [protected, inherited]

void UibAccessorTest::TestInsertAction ( INT index ) [protected, inherited]

void UibAccessorTest::TestRemoveAccessor ( ) [protected, inherited]

void UibAccessorTest::TestRemoveAction ( INT index ) [protected, inherited]

void UibAccessorTest::TestRemoveAllActions ( ) [protected, inherited]

void UibAccessorTest::TestSetAccessor ( ActionAccessor * accessor ) [protected, inherited]

UibAccessorTest::UibAccessorTest | ( | MmiUnitTestSuite * | suite,
 |  | BOOLEAN | proceed_on_failed = TRUE
 | ) | [inherited]

UibAccessorTest::UibAccessorTest ( ) [inherited]

Constructor.

UibFolderWin::UibFolderWin ( ) [inherited]

Constructor.

UibListBoxModel::UibListBoxModel ( ) [inherited]

Constructor.

UibServiceImpl::UibServiceImpl ( ) [inherited]

UibSettingsProvider::UibSettingsProvider ( ) [inherited]

Constructor.

UibSettingsWin::UibSettingsWin ( Provider * settings_provider = 0 ) [inherited]

UibSettingsWin.

void UibListBoxModel::Update ( INT item_count = -1 ) [virtual, inherited]

void UibFolderWin::Update ( ) [inherited]

void UibApp::UpdateFolderProvider ( UibConfig::UibFolderTypes folder_type ) [inherited]

UibAccessorTest::~UibAccessorTest ( ) [virtual, inherited]

Destructor.

UibApp::~UibApp ( ) [virtual, inherited]

Destructor.

UibFolderWin::~UibFolderWin ( ) [virtual, inherited]

Destructor.

UibListBoxModel::~UibListBoxModel ( ) [virtual, inherited]

Destructor.

UibSettingsProvider::~UibSettingsProvider ( ) [virtual, inherited]

Destructor.

UibSettingsWin::~UibSettingsWin ( ) [virtual, inherited]

Destructor.

Generated on Wed Jan 25 02:30:38 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UnifiedInobx

UnifiedInobx

Data Structures

class | UibMsgDisplayTest

Functions

const WCHAR * | UibMsgDisplayTest::GetName ()
Returns the name of the Test Case.
void | UibMsgDisplayTest::Init (MmiUnitTestSuite *suite, BOOLEAN proceed_on_failed=TRUE)
Initalizes TestUibData wiht name and MmiUnitTestSuite.
virtual BOOLEAN | UibMsgDisplayTest::OnMessage (const Message &msg)
virtual TestResult | UibMsgDisplayTest::Run ()
Implement the Test Case.
void | UibMsgDisplayTest::SetPreconditions ()
UibMsgDisplayTest::UibMsgDisplayTest (MmiUnitTestSuite *suite, BOOLEAN proceed_on_failed=TRUE)
UibMsgDisplayTest::UibMsgDisplayTest ()
Constructor.
virtual | UibMsgDisplayTest::~UibMsgDisplayTest ()
Destructor.

Detailed Description

A_INCLUDED

Function Documentation

const WCHAR* UibMsgDisplayTest::GetName ( ) [inline, inherited]

Returns the name of the Test Case.

void UibMsgDisplayTest::Init | ( | MmiUnitTestSuite * | suite,
 |  | BOOLEAN | proceed_on_failed = TRUE
 | ) | [inherited]

Initalizes TestUibData wiht name and MmiUnitTestSuite.

BOOLEAN UibMsgDisplayTest::OnMessage ( const Message & msg ) [protected, virtual, inherited]

TestResult UibMsgDisplayTest::Run ( ) [virtual, inherited]

Implement the Test Case.

void UibMsgDisplayTest::SetPreconditions ( ) [protected, inherited]

UibMsgDisplayTest::UibMsgDisplayTest | ( | MmiUnitTestSuite * | suite,
 |  | BOOLEAN | proceed_on_failed = TRUE
 | ) | [inherited]

UibMsgDisplayTest::UibMsgDisplayTest ( ) [inherited]

Constructor.

UibMsgDisplayTest::~UibMsgDisplayTest ( ) [virtual, inherited]

Destructor.

Generated on Wed Jan 25 02:30:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: UsbApp

UsbApp

Data Structures

class UsbApp
Generated on Wed Jan 25 02:30:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VoiceMemoApp

VoiceMemoApp

Data Structures

class | VoiceMemoApp
class | VoiceMemoMenuAccessor
class | VoiceMemoRecordWin
class | VoiceMemoWin
Generated on Wed Jan 25 02:30:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: VoiceMemo

VoiceMemo

Generated on Wed Jan 25 02:30:40 2006 for APOXI by doxygen 1.4.6-NO


APOXI: SERVER

SERVER

Data Structures

class | AuthProvider
class | Server
class | ServerClient
class | ServerConfig

Defines

#define | APOXI_SERVER_DEFAULT_BACKLOG 15
#define | APOXI_SERVER_DEFAULT_MAX_USERS 5
#define | SERVER_DBG_OUT_RANGE 35900

Typedefs

typedef NiSharedPtr< AuthProvider > | AuthProviderPtr
Smart-pointer controlling a AuthProvider object.
typedef NiSharedPtr< ServerClient > | ServerClientPtr
Smart-pointer controlling a ServerClient object.
typedef NiSharedPtr< ServerConfig > | ServerConfigPtr
Smart-pointer controlling a ServerConfig object.
typedef NiSharedPtr< Server > | ServerPtr
Smart-pointer controlling a Server object.

Define Documentation

#define APOXI_SERVER_DEFAULT_BACKLOG 15

#define APOXI_SERVER_DEFAULT_MAX_USERS 5

#define SERVER_DBG_OUT_RANGE 35900

Typedef Documentation

typedef NiSharedPtr<AuthProvider> AuthProviderPtr

Smart-pointer controlling a AuthProvider object.

typedef NiSharedPtr<ServerClient> ServerClientPtr

Smart-pointer controlling a ServerClient object.

typedef NiSharedPtr<ServerConfig> ServerConfigPtr

Smart-pointer controlling a ServerConfig object.

typedef NiSharedPtr<Server> ServerPtr

Smart-pointer controlling a Server object.

Generated on Wed Jan 25 02:30:41 2006 for APOXI by doxygen 1.4.6-NO


APOXI: FTPSERVER

FTPSERVER

Data Structures

class | FtpAuthProvider
class | FtpClient
class | FtpDataServerSocket
class | FtpDataSocket
class | FtpInTransfer
class | FtpOutTransfer
class | FtpRequest
class | FtpServer
class | FtpServerConfig
class | FtpServerSocket
class | FtpSocket
class | FtpTransfer

Defines

#define | APOXI_FTPSERVER_REQUEST_LENGTH 1024
#define | FTPSERVER_DBG_OUT_RANGE 35910
#define | FTPSERVER_DBG_OUT_RANGE_CMD 35912
#define | FTPSERVER_DBG_OUT_RANGE_EXTENDED 35911
#define | FTPSERVER_DBG_OUT_RANGE_REPLY 35913

Typedefs

typedef NiSharedPtr< FtpAuthProvider > | FtpAuthProviderPtr
Smart-pointer controlling a FtpAuthProvider object.
typedef NiSharedPtr< FtpClient > | FtpClientPtr
Smart-pointer controlling a FtpClient object.
typedef NiSharedPtr< FtpDataServerSocket > | FtpDataServerSocketPtr
Smart-pointer controlling a FtpDataServerSocket object.
typedef NiSharedPtr< FtpDataSocket > | FtpDataSocketPtr
Smart-pointer controlling a FtpDataSocket object.
typedef NiSharedPtr< FtpInTransfer > | FtpInTransferPtr
Smart-pointer controlling a FtpInTransfer object.
typedef NiSharedPtr< FtpOutTransfer > | FtpOutTransferPtr
Smart-pointer controlling a FtpOutTransfer object.
typedef NiSharedPtr< FtpServerConfig > | FtpServerConfigPtr
Smart-pointer controlling a FtpServerConfig object.
typedef NiSharedPtr< FtpServer > | FtpServerPtr
Smart-pointer controlling a FtpServer object.
typedef NiSharedPtr< FtpServerSocket > | FtpServerSocketPtr
Smart-pointer controlling a FtpServerSocket object.
typedef NiSharedPtr< FtpSocket > | FtpSocketPtr
Smart-pointer controlling a FtpSocket object.
typedef NiSharedPtr< FtpTransfer > | FtpTransferPtr
Smart-pointer controlling a FtpTransfer object.

Enumerations

enum | FtpConnectionType { c_ftp_conn_type_control, c_ftp_conn_type_data }
enum | FtpDataConnectionType { c_ftp_data_conn_type_active, c_ftp_data_conn_type_passive }
enum | FtpServiceCommand { c_ftp_service_command_init, c_ftp_service_command_terminate, c_ftp_service_command_start, c_ftp_service_command_stop }
enum | FtpServiceCommandError { c_ftp_service_command_error_success, c_ftp_service_command_error_failed }
enum | FtpTransferDirection { c_ftp_transfer_direction_in, c_ftp_transfer_direction_out }
enum FtpTransferError {
c_ftp_transfer_error_created, c_ftp_transfer_error_started, c_ftp_transfer_error_progress, c_ftp_transfer_error_not_running,
c_ftp_transfer_error_aborted, c_ftp_transfer_error_failed, c_ftp_transfer_error_complete
}
enum | FtpTransferMode { c_ftp_transfer_mode_stream, c_ftp_transfer_mode_block, c_ftp_transfer_mode_compressed }
enum | FtpTransferStructure { c_ftp_transfer_structure_file, c_ftp_transfer_structure_record }
enum | FtpTransferType { c_ftp_transfer_type_ascii, c_ftp_transfer_type_image }

Define Documentation

#define APOXI_FTPSERVER_REQUEST_LENGTH 1024

#define FTPSERVER_DBG_OUT_RANGE 35910

#define FTPSERVER_DBG_OUT_RANGE_CMD 35912

#define FTPSERVER_DBG_OUT_RANGE_EXTENDED 35911

#define FTPSERVER_DBG_OUT_RANGE_REPLY 35913

Typedef Documentation

typedef NiSharedPtr<FtpAuthProvider> FtpAuthProviderPtr

Smart-pointer controlling a FtpAuthProvider object.

typedef NiSharedPtr<FtpClient> FtpClientPtr

Smart-pointer controlling a FtpClient object.

typedef NiSharedPtr<FtpDataServerSocket> FtpDataServerSocketPtr

Smart-pointer controlling a FtpDataServerSocket object.

typedef NiSharedPtr<FtpDataSocket> FtpDataSocketPtr

Smart-pointer controlling a FtpDataSocket object.

typedef NiSharedPtr<FtpInTransfer> FtpInTransferPtr

Smart-pointer controlling a FtpInTransfer object.

typedef NiSharedPtr<FtpOutTransfer> FtpOutTransferPtr

Smart-pointer controlling a FtpOutTransfer object.

typedef NiSharedPtr<FtpServerConfig> FtpServerConfigPtr

Smart-pointer controlling a FtpServerConfig object.

typedef NiSharedPtr<FtpServer> FtpServerPtr

Smart-pointer controlling a FtpServer object.

typedef NiSharedPtr<FtpServerSocket> FtpServerSocketPtr

Smart-pointer controlling a FtpServerSocket object.

typedef NiSharedPtr<FtpSocket> FtpSocketPtr

Smart-pointer controlling a FtpSocket object.

typedef NiSharedPtr<FtpTransfer> FtpTransferPtr

Smart-pointer controlling a FtpTransfer object.

Enumeration Type Documentation

enum FtpConnectionType

Enumerator:
c_ftp_conn_type_control
c_ftp_conn_type_data

enum FtpDataConnectionType

Enumerator:
c_ftp_data_conn_type_active
c_ftp_data_conn_type_passive

enum FtpServiceCommand

Enumerator:
c_ftp_service_command_init
c_ftp_service_command_terminate
c_ftp_service_command_start
c_ftp_service_command_stop

enum FtpServiceCommandError

Enumerator:
c_ftp_service_command_error_success
c_ftp_service_command_error_failed

enum FtpTransferDirection

Enumerator:
c_ftp_transfer_direction_in
c_ftp_transfer_direction_out

enum FtpTransferError

Enumerator:
c_ftp_transfer_error_created
c_ftp_transfer_error_started
c_ftp_transfer_error_progress
c_ftp_transfer_error_not_running
c_ftp_transfer_error_aborted
c_ftp_transfer_error_failed
c_ftp_transfer_error_complete

enum FtpTransferMode

Enumerator:
c_ftp_transfer_mode_stream
c_ftp_transfer_mode_block
c_ftp_transfer_mode_compressed

enum FtpTransferStructure

Enumerator:
c_ftp_transfer_structure_file
c_ftp_transfer_structure_record

enum FtpTransferType

Enumerator:
c_ftp_transfer_type_ascii
c_ftp_transfer_type_image

Generated on Wed Jan 25 02:30:46 2006 for APOXI by doxygen 1.4.6-NO


APOXI: HTTPSERVER

HTTPSERVER

Data Structures

class | HttpApplication
class | HttpApplicationSupplier
class | HttpAuthProvider
class | HttpClient
class | HttpRequest
class | HttpResponse
class | HttpServer
class | HttpServerConfig
class | HttpServerSocket
class | HttpSocket

Defines

#define | APOXI_HTTPSERVER_DEFAULT_BACKLOG 15
#define | APOXI_HTTPSERVER_DEFAULT_MAX_USERS 5
#define | HTTPSERVER_ASCII_AMP 38
#define | HTTPSERVER_ASCII_CR 13
#define | HTTPSERVER_ASCII_DOT 46
#define | HTTPSERVER_ASCII_EQU 61
#define | HTTPSERVER_ASCII_LF 10
#define | HTTPSERVER_ASCII_PER 37
#define | HTTPSERVER_ASCII_PL 43
#define | HTTPSERVER_ASCII_QM 63
#define | HTTPSERVER_ASCII_SL 47
#define | HTTPSERVER_ASCII_SP 32
#define | HTTPSERVER_DBG_OUT_RANGE 35920

Typedefs

typedef NiSharedPtr< HttpAuthProvider > | HttpAuthProviderPtr
Smart-pointer controlling a HttpAuthProvider object.
typedef NiSharedPtr< HttpClient > | HttpClientPtr
Smart-pointer controlling a HttpClient object.
typedef Vector< String > | HttpRequestHeaders
typedef Vector< String > | HttpResponseHeaders
typedef NiSharedPtr< HttpServerConfig > | HttpServerConfigPtr
Smart-pointer controlling a HttpServerConfig object.
typedef NiSharedPtr< HttpServer > | HttpServerPtr
Smart-pointer controlling a HttpServer object.
typedef NiSharedPtr< HttpServerSocket > | HttpServerSocketPtr
Smart-pointer controlling a HttpServerSocket object.
typedef NiSharedPtr< HttpSocket > | HttpSocketPtr
Smart-pointer controlling a HttpSocket object.

Enumerations

enum | HttpResponseCode { c_http_response_code_200, c_http_response_code_400, c_http_response_code_404 }
enum | HttpServiceCommand { c_http_service_command_init, c_http_service_command_terminate, c_http_service_command_start, c_http_service_command_stop }
enum | HttpServiceCommandError { c_http_service_command_error_success, c_http_service_command_error_failed }

Define Documentation

#define APOXI_HTTPSERVER_DEFAULT_BACKLOG 15

#define APOXI_HTTPSERVER_DEFAULT_MAX_USERS 5

#define HTTPSERVER_ASCII_AMP 38

#define HTTPSERVER_ASCII_CR 13

#define HTTPSERVER_ASCII_DOT 46

#define HTTPSERVER_ASCII_EQU 61

#define HTTPSERVER_ASCII_LF 10

#define HTTPSERVER_ASCII_PER 37

#define HTTPSERVER_ASCII_PL 43

#define HTTPSERVER_ASCII_QM 63

#define HTTPSERVER_ASCII_SL 47

#define HTTPSERVER_ASCII_SP 32

#define HTTPSERVER_DBG_OUT_RANGE 35920

Typedef Documentation

typedef NiSharedPtr<HttpAuthProvider> HttpAuthProviderPtr

Smart-pointer controlling a HttpAuthProvider object.

typedef NiSharedPtr<HttpClient> HttpClientPtr

Smart-pointer controlling a HttpClient object.

typedef Vector<String> HttpRequestHeaders

typedef Vector<String> HttpResponseHeaders

typedef NiSharedPtr<HttpServerConfig> HttpServerConfigPtr

Smart-pointer controlling a HttpServerConfig object.

typedef NiSharedPtr<HttpServer> HttpServerPtr

Smart-pointer controlling a HttpServer object.

typedef NiSharedPtr<HttpServerSocket> HttpServerSocketPtr

Smart-pointer controlling a HttpServerSocket object.

typedef NiSharedPtr<HttpSocket> HttpSocketPtr

Smart-pointer controlling a HttpSocket object.

Enumeration Type Documentation

enum HttpResponseCode

Enumerator:
c_http_response_code_200
c_http_response_code_400
c_http_response_code_404

enum HttpServiceCommand

Enumerator:
c_http_service_command_init
c_http_service_command_terminate
c_http_service_command_start
c_http_service_command_stop

enum HttpServiceCommandError

Enumerator:
c_http_service_command_error_success
c_http_service_command_error_failed

Generated on Wed Jan 25 02:30:51 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • __Colid : ProvIds.hpp
  • _Adc_BlobObject_hpp : BlobObject.hpp
  • _Adc_BlobPtr_hpp : BlobPtr.hpp
  • _Adc_BubbleSortProvider_hpp : BubbleSortProvider.hpp
  • _Adc_DataItem_hpp : DataItem.hpp
  • _Adc_FilterProvider_hpp : FilterProvider.hpp
  • _Adc_FilterRule_hpp : FilterRule.hpp
  • _Adc_Find2Provider_hpp : Find2Provider.hpp
  • _Adc_FindProvider_hpp : FindProvider.hpp
  • _Adc_FixedPtrArray_hpp : FixedPtrArray.hpp
  • _Adc_GenericObject_hpp : GenericObject.hpp
  • _Adc_IndexTable_hpp : IndexTable.hpp
  • _Adc_PhoneNumber_hpp : PhoneNumber.hpp
  • _Adc_Provider_hpp : Provider.hpp
  • _Adc_ProviderListener_hpp : ProviderListener.hpp
  • _Adc_QuickSortProvider_hpp : QuickSortProvider.hpp
  • _Adc_RegBlobObject_hpp : RegBlobObject.hpp
  • _Adc_SortProvider_hpp : SortProvider.hpp
  • _Apoxi_AuxExtensions_DualFilterProvider_hpp : DualFilterProvider.hpp
  • _Apoxi_HashTable_hpp : HashTable.hpp
  • _APOXI_Latin_Defines_h : Latin.hpp
  • _APOXI_String_hpp : String.hpp
  • _APOXI_WCAttr_h : WCattr.hpp
  • _APOXI_WCAttr_Tbl_hpp : WCattr_tbl.hpp
  • _APOXI_WString_hpp : WString.hpp
  • _APOXI_WStrutil_h : WStrUtil.hpp
  • _Asc_InputAction_hpp : InputAction.hpp
  • _Asc_InputAnalyzer_hpp : InputAnalyzer.hpp
  • _Asc_InputParser_hpp : InputParser.hpp
  • _Auxiliary_AbstractDelegationProvider_hpp : AbstractDelegationProvider.hpp
  • _EmApoxi_Audio_State : EmApoxiAudioDeviceImpl.cpp
  • _Mmi_UibAccessorTest_hpp : UibAccessorTest.hpp
  • _MmiSimProtocol_h : MmiSimProtocol.hpp
  • _MSVC_CONST_FLAW : DBService.hpp
  • _pp : parsifal.cpp
  • _SLEEP : FfsTestBase.hpp
  • _WIN32_WINDOWS : WinInc.hpp
  • _WIN32_WINNT : WinInc.hpp
Generated on Wed Jan 25 02:31:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- j -

  • JarExtractId : Unzipper.hpp, Unzipper.cpp
  • JarFileGlobalInfo : Unzip.hpp
  • JoinCallsRejected : Types.hpp
  • jpeg_free_large() : jmemnobs_APOXI.cpp
  • jpeg_free_small() : jmemnobs_APOXI.cpp
  • jpeg_get_large() : jmemnobs_APOXI.cpp
  • jpeg_get_small() : jmemnobs_APOXI.cpp
  • jpeg_image : SampleImages.hpp, SampleImages.cpp
  • jpeg_image_size : SampleImages.hpp
  • JPEG_INTERNALS : jmemnobs_APOXI.cpp
  • jpeg_mem_available() : jmemnobs_APOXI.cpp
  • jpeg_mem_init() : jmemnobs_APOXI.cpp
  • jpeg_mem_term() : jmemnobs_APOXI.cpp
  • jpeg_open_backing_store() : jmemnobs_APOXI.cpp
  • JPEG_PIXEL_CHANNELS : JpegDecoder.cpp
  • JVMa_getFileFromJar() : Unzipper.hpp, Unzipper.cpp
  • JVMc_getFileFromJarResponse() : Unzipper.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- k -

  • KBYTE : SocketTestDefines.hpp
  • Kernel_AbstractExternalData_hpp : AbstractExternalData.hpp
  • Kernel_Grid_hpp : Grid.hpp
  • Kernel_Lib_hpp : Lib.hpp
  • Kernel_Message_hpp : Message.hpp
  • Kernel_MsgCategory_hpp : MsgCategory.hpp
  • Kernel_MsgTypes_hpp : MsgTypes.hpp
  • KernelTracer : Trace.hpp
  • KernelTracerLevel2 : Trace.hpp
  • KernelTracerLevel3 : Trace.hpp
  • KEY_FLIP_CLOSE : MiscSignalProcessor.cpp
  • KEY_FLIP_OPEN : MiscSignalProcessor.cpp
  • KEY_RELEASE : MiscSignalProcessor.cpp
  • key_tone_1_data : Audio.cpp
  • key_tone_2_data : Audio.cpp
  • key_tone_3_data : Audio.cpp
  • key_tone_4_data : Audio.cpp
  • KeyDownComparePred : InputMap.cpp
  • KeyDownMapSearcher : InputMap.cpp
  • keymapNone : ContextDescriptionTypes.hpp
  • KeymapType : ContextDescriptionTypes.hpp
  • keymapVKey : ContextDescriptionTypes.hpp
  • keymapVKeyFeature : ContextDescriptionTypes.hpp
  • keymapVKeyLongFeature : ContextDescriptionTypes.hpp
  • keymapVKeyVeryLongFeature : ContextDescriptionTypes.hpp
  • KeyToneAudioDevice_hpp : KeyToneAudioDevice.hpp
  • KeyToneRpt : SignalTypes.hpp
  • KeyUpComparePred : InputMap.cpp
  • KeyUpMapSearcher : InputMap.cpp
  • kissing : SampleImages.hpp, SampleImages.cpp
  • kissing_size : SampleImages.hpp
  • knockyourhead : SampleIMelodies.hpp, SampleIMelodies.cpp
  • knockyourhead_size : SampleIMelodies.hpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • L2_l1_fail : NetworkTypes.hpp
  • L2CA_RXMTU_GET : BtSocketAddr.hpp
  • L2CA_RXMTU_SET : BtSocketAddr.hpp
  • L2CA_TXMTU_GET : BtSocketAddr.hpp
  • L2CA_TXMTU_SET : BtSocketAddr.hpp
  • L2Manuf : PdpTypes.hpp
  • L2None : PdpTypes.hpp
  • L2Null : PdpTypes.hpp
  • L2Pad : PdpTypes.hpp
  • L2Ppp : PdpTypes.hpp
  • L2Protocol : PdpTypes.hpp
  • L2R : ArabicTextRenderer.cpp
  • L2X25 : PdpTypes.hpp
  • Lac : NetworkTypes.hpp
  • Language : SignalTypes.hpp
  • LanguageData : AcacTypes.hpp
  • LanguageResetActionType : InputAction.hpp
  • LaNotAllowed : SignalTypes.hpp
  • Latin1ToUtf8() : parsifal.cpp
  • LaunchBrowserBearerUnavailable : SimTkTypes.hpp
  • LaunchBrowserBrowserUnavailable : SimTkTypes.hpp
  • LaunchBrowserError : SimTkTypes.hpp
  • LaunchBrowserMeUnableToReadProvisioningData : SimTkTypes.hpp
  • LCS : apoxi.features
  • lcs_delay_tolerant : LcsTypes.hpp
  • Lcs_LcsAppMsgTypes_hpp : LcsAppMsgTypes.hpp
  • lcs_low_delay : LcsTypes.hpp
  • LcsCost : LcsTypes.hpp
  • LcsDataMissing : LcsTypes.hpp
  • LcsErrorCode : LcsTypes.hpp
  • LcsFacilityNotSupported : LcsTypes.hpp
  • LcsGltpConnSetupFailure : LcsTypes.hpp
  • LcsGltpInvalidData : LcsTypes.hpp
  • LcsGltpMolrInProgress : LcsTypes.hpp
  • LcsGltpSendFailure : LcsTypes.hpp
  • LcsGltpTimeOut : LcsTypes.hpp
  • LcsInternalError : LcsTypes.hpp
  • LcsInvalidInvokation : LcsTypes.hpp
  • LcsNoError : LcsTypes.hpp
  • LcsNotificationType : LcsTypes.hpp
  • LcsPosMethodFailure : LcsTypes.hpp
  • LcsProviderNotAvailable : LcsTypes.hpp
  • LcsShapeType : LcsTypes.hpp
  • LcsSsSubscriptionViolation : LcsTypes.hpp
  • LcsSystemFailure : LcsTypes.hpp
  • LcsTimeOut : LcsTypes.hpp
  • LcsTimerType : LcsTimer.hpp
  • LcsTransports_GLTP_GltpAppMsgTypes_hpp : GltpAppMsgTypes.hpp
  • LcsTransportType : LcsTypes.hpp
  • LcsUnexpectedDataValue : LcsTypes.hpp
  • left : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • left_atom : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • left_atom_idx : BitBlit_Planes.cpp
  • left_clip : BitBlit_Planes.cpp
  • left_clip_inc : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • left_mask : ScrollVertical_Planes.cpp, FillRect_Planes.cpp
  • left_mask_1 : BitBlit_Planes.cpp
  • left_mask_2 : BitBlit_Planes.cpp
  • len : VCard.cpp
  • LexToken : InputParser.hpp
  • LimitedService : NetworkTypes.hpp
  • Line1 : SignalTypes.hpp
  • Line2 : SignalTypes.hpp
  • line_inc : ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, FillRect_16Bpp.cpp, DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp, ScrollVertical_16Bpp.cpp, DrawChar_16Bpp.cpp
  • LineAlignment : EditorDocument.hpp
  • LinearFixedFile : SignalTypes.hpp
  • LineSelector : SignalTypes.hpp
  • Link_abortion : NetworkTypes.hpp
  • Link_estab_fail : NetworkTypes.hpp
  • LndEfPos : SimTkTypes.hpp
  • LndOverflow : SignalTypes.hpp
  • LndPhoneBook : SignalTypes.hpp
  • LndPhoneBookCnt : SignalTypes.hpp
  • LOC : Macros.hpp
  • LOC_W : Macros.hpp
  • LOCAL_BUFFER_SIZE : BtObexImpl.hpp
  • LocateFileBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • LocateFileFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • location_estimate : LcsTypes.hpp
  • LocationMethod : LcsDecls.hpp
  • LocationType : LcsTypes.hpp
  • LocationUpdate : SignalTypes.hpp
  • LocationUpdateStatus : SignalTypes.hpp
  • LociLocAreaNotAllowed : SignalTypes.hpp
  • LociNotUpdated : SignalTypes.hpp
  • LociPlmnNotAllowed : SignalTypes.hpp
  • LociReserved : SignalTypes.hpp
  • LociUpdated : SignalTypes.hpp
  • LOCK_PDP_CONTEXT_HANDLER : PdpContextManager.hpp
  • LOCK_STATE_MACHINE : StateMachine.hpp
  • LockStatus : SimLockTypes.hpp
  • LONG : WinInc.hpp, NucInc.hpp
  • Low : LcsTypes.hpp
  • LowBattToneRpt : SignalTypes.hpp
  • LpEfPos : SimTkTypes.hpp
  • LST_Arc : LcsTypes.hpp
  • LST_NoLocation : LcsTypes.hpp
  • LST_Point : LcsTypes.hpp
  • LST_PointAltitudeUncertEllipsoid : LcsTypes.hpp
  • LST_PointUncertCircle : LcsTypes.hpp
  • LST_PointUncertEllipse : LcsTypes.hpp
  • LToW() : WStrUtil.cpp
  • LZ_BITS : GifDecoder.cpp
  • LZ_MAX_CODE : GifDecoder.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • m_currpos : MdhSignalProcessor.cpp
  • m_lastpos : MdhSignalProcessor.cpp
  • m_lastrange : MdhSignalProcessor.cpp
  • m_process_ptr : MdhSignalProcessor.cpp
  • m_rangestart : MdhSignalProcessor.cpp
  • m_smscount : MdhSignalProcessor.cpp
  • m_timer : MdhSignalProcessor.cpp
  • m_view : MdhSignalProcessor.cpp
  • MacFailure : SignalTypes.hpp
  • main() : UdpServer.cpp
  • Main_Desktop_hpp : MainDesktop.hpp
  • MainHandlerList : MainHandler.hpp
  • MAKE_BYTE_AVAIL : GifDecoder.cpp, BmpDecoder.cpp
  • MakeFree() : HeapVector.cpp
  • MakeOccupied() : HeapVector.cpp
  • mambo : SampleIMelodies.hpp, SampleIMelodies.cpp
  • mambo_size : SampleIMelodies.hpp
  • Manual : NetworkTypes.hpp
  • MapFindData() : HostCoreFsSim.cpp
  • MapItemType : InputMap.hpp
  • mask : SetPixel_Planes.cpp
  • MASK_3_WAY_CALL : BtHfProfileWindows.cpp
  • MASK_CLI_PRESENTATION : BtHfProfileWindows.cpp
  • mask_dest : ScrollHorizontal_Planes.cpp
  • MASK_EC_NR : BtHfProfileWindows.cpp
  • MASK_REMOTE_VOLUME_CTRL : BtHfProfileWindows.cpp
  • mask_src : ScrollHorizontal_Planes.cpp
  • MASK_VOICE_REC : BtHfProfileWindows.cpp
  • max : Macros.hpp
  • MAX : Wsprintf.cpp, StrPrintf.cpp
  • MAX_ARRAY_CHECK_INDEX : StillCamera.cpp
  • MAX_BANANA_HEIGHT : StillCamera.cpp
  • MAX_BANANA_WIDTH : StillCamera.cpp
  • MAX_BT_AVAILABLE_CHANNELS : BtObexImpl.hpp
  • MAX_BT_CLIENT_CHANNELS : BtObexImpl.hpp
  • MAX_BT_SERVER_CHANNELS : BtObexImpl.hpp
  • MAX_BUFFER_INFO_INDEX : StillCamera.hpp
  • max_calendar_description_len : CalendarRecord.hpp
  • MAX_CAND_BUFF_SIZE : Zi8Wrapper.hpp
  • MAX_COUNT : DrmCore.hpp
  • MAX_DATE : DrmCore.hpp
  • MAX_ELEM_BUFF_SIZE : Zi8Wrapper.hpp
  • MAX_EXPONENT : LcsUtils.cpp
  • MAX_FILE_NAME_LENGTH : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • MAX_GROUP_COUNT : PbSelectGroup.hpp
  • MAX_INDEX_FILE_SINK_ARRAY : CameraCaptureWin.hpp, CameraApp.hpp
  • MAX_INQUIRY_TIMEOUT : BtDeviceSearchRequest.cpp
  • MAX_INTERVAL : DrmCore.hpp
  • MAX_K_VALUE : LcsUtils.hpp
  • MAX_LCD_SCREEN_FORMATS : Camera.cpp
  • MAX_LENGTH_OF_BANANA_DATA_REAL : StillCamera.cpp
  • MAX_NO_OPEN_FILES : HostCoreFsSim.hpp
  • MAX_NUM_CANDIDATES : Zi8Wrapper.hpp
  • MAX_NUM_CHINESE_CANDIDATES : Zi8Wrapper.hpp
  • MAX_POOL_COUNT : BufferPoolManager.hpp
  • MAX_SATS : LcsTypes.hpp
  • MAX_SIGNAL_LEVEL : MiscSignalProcessor.cpp
  • MAX_SIGNAL_QUALITY : MiscSignalProcessor.cpp
  • MAX_STROKE_COUNT : Zi8StrokeBox.hpp
  • MAX_TRANSPORTS : LcsTypes.hpp
  • MAX_UINT16 : Unzip.hpp
  • MAX_VOLUME_LEVEL : BtHsVolumeSettingsWin.hpp, BtHfVolumeSettingsWin.hpp
  • MAX_WORD_LENGTH_SIZE : Zi8Wrapper.hpp
  • MAX_ZOOM_LEVELS : Camera.cpp
  • MaxCallCountExceeded : Types.hpp
  • MaxHandlerId : HandlerId.hpp
  • Maximum() : Types.hpp
  • MaxMptyMemberCountExceeded : Types.hpp
  • MaxNoType : PbTypes.hpp
  • MAXREQUESTLIMIT : HttpWapMgrPlugin.hpp
  • MAXSHMEMSIZE : HostAudioDriver.hpp
  • MaxValueReached : SignalTypes.hpp
  • MbdnPhoneBook : SignalTypes.hpp
  • MbdnPhoneBookCnt : SignalTypes.hpp
  • MbPhoneBook : AtcTypes.hpp
  • Mc : SignalTypes.hpp
  • MC_APP : MsgCategory.hpp
  • MC_AT : MsgCategory.hpp
  • MC_BROADCAST : MsgCategory.hpp
  • MC_CONTEXT : MsgCategory.hpp
  • MC_CONTROL : MsgCategory.hpp
  • MC_FOCUS : MsgCategory.hpp
  • MC_IPC : MsgCategory.hpp
  • MC_NOT_VALID : MsgCategory.hpp
  • MC_SIGNAL : MsgCategory.hpp
  • MC_STACK_CONTROL : MsgCategory.hpp
  • MC_SYSTEM : MsgCategory.hpp
  • MC_WIN : MsgCategory.hpp
  • Mcc : NetworkTypes.hpp
  • McPhoneBook : AtcTypes.hpp
  • MdhApplicationError : MdhTypes.hpp
  • MdhCause : MdhTypes.hpp
  • MdhEmailMessage : MdhTypes.hpp
  • MdhErrClientWasNotRegistered : MdhTypes.hpp
  • MdhErrFilterIsNotSupported : MdhTypes.hpp
  • MdhErrIndexNotCreated : MdhTypes.hpp
  • MdhErrMaxClients : MdhTypes.hpp
  • MdhErrMaxViews : MdhTypes.hpp
  • MdhErrNoEntriesFound : MdhTypes.hpp
  • MdhErrNotEnoughMemory : MdhTypes.hpp
  • MdhError : MdhTypes.hpp
  • MdhErrOutOfRange : MdhTypes.hpp
  • MdhErrOutOfView : MdhTypes.hpp
  • MdhErrParameters : MdhTypes.hpp
  • MdhErrSmsrLinkNotFound : MdhTypes.hpp
  • MdhErrSmsrNotAvailable : MdhTypes.hpp
  • MdhErrStorageMedia : MdhTypes.hpp
  • MdhErrViewNotAvailable : MdhTypes.hpp
  • MdhFaxMessage : MdhTypes.hpp
  • MdhFilter : MdhTypes.hpp
  • MdhFilterAll : MdhTypes.hpp
  • MdhFilterAllDisplay : MdhTypes.hpp
  • MdhFilterEmailWaiting : MdhTypes.hpp
  • MdhFilterFaxWaiting : MdhTypes.hpp
  • MdhFilterFree : MdhTypes.hpp
  • MdhFilterInbox : MdhTypes.hpp
  • MdhFilterOtherMsgWaiting : MdhTypes.hpp
  • MdhFilterOutbox : MdhTypes.hpp
  • MdhFilterRead : MdhTypes.hpp
  • MdhFilterSent : MdhTypes.hpp
  • MdhFilterToBeRead : MdhTypes.hpp
  • MdhFilterToBeSent : MdhTypes.hpp
  • MdhFilterUnknown : MdhTypes.hpp
  • MdhFilterUsed : MdhTypes.hpp
  • MdhFilterVoiceMsgWaiting : MdhTypes.hpp
  • MdhFirstReached : MdhTypes.hpp
  • MdhInitExtendedData : MdhTypes.hpp
  • MdhInitTimeStamp : MdhTypes.hpp
  • MdhLastReached : MdhTypes.hpp
  • MdhNoCause : MdhTypes.hpp
  • MdhNofMdhWaitTypes : MdhTypes.hpp
  • MdhNoMedia : MdhTypes.hpp
  • MdhNoSmsrEf : MdhTypes.hpp
  • MdhNothingFound : MdhTypes.hpp
  • MdhNothingToProcess : MdhTypes.hpp
  • MdhOnlyNvram : MdhTypes.hpp
  • MdhOnlySim : MdhTypes.hpp
  • MdhOtherMessage : MdhTypes.hpp
  • MdhPrefferedNvram : MdhTypes.hpp
  • MdhPrefferedSim : MdhTypes.hpp
  • MdhRamBuffer : MdhTypes.hpp
  • MdhRejLastView : MdhTypes.hpp
  • MdhRejMemoryExceeded : MdhTypes.hpp
  • MdhRejSimIsFull : MdhTypes.hpp
  • MdhRejSimIsNotInView : MdhTypes.hpp
  • MdhRejSimNoSms : MdhTypes.hpp
  • MdhRejStartupInProgress : MdhTypes.hpp
  • MdhSharedMem : MdhTypes.hpp
  • MdhSharedMemory : MdhTypes.hpp
  • MdhSmBoot : MdhTypes.hpp
  • MdhSmSimReset : MdhTypes.hpp
  • MdhSmSimtkRefresh : MdhTypes.hpp
  • MdhSmsrEf : MdhTypes.hpp
  • MdhSmsrLocation : MdhTypes.hpp
  • MdhSmsrNone : MdhTypes.hpp
  • MdhSmsrNotSaved : MdhTypes.hpp
  • MdhSmStorageSimIsFree : MdhTypes.hpp
  • MdhSmUnknown : MdhTypes.hpp
  • MdhSortByDate : MdhTypes.hpp
  • MdhSortByPosition : MdhTypes.hpp
  • MdhSorting : MdhTypes.hpp
  • MdhStatus : MdhTypes.hpp
  • MdhSuccessful : MdhTypes.hpp
  • MdhTimeStamp : MdhTypes.hpp
  • MdhTransmitCause : MdhTypes.hpp
  • MdhUndefined : MdhTypes.hpp
  • MdhViewHdl : MdhTypes.hpp
  • MdhVoiceMail2Message : MdhTypes.hpp
  • MdhVoiceMailMessage : MdhTypes.hpp
  • MdhWaitIndicatorLevel : MdhTypes.hpp
  • MdhWaitIndicatorSetting : MdhTypes.hpp
  • MdhWaitIndicatorSmsType : MdhTypes.hpp
  • MdhWaitLevel1 : MdhTypes.hpp
  • MdhWaitLevel2 : MdhTypes.hpp
  • MdhWaitLevel3 : MdhTypes.hpp
  • MdhWaitLevelClient : MdhTypes.hpp
  • MdhWaitLevelCphs : MdhTypes.hpp
  • MdhWaitNoLevel : MdhTypes.hpp
  • MdhWaitSetActive : MdhTypes.hpp
  • MdhWaitSetInactive : MdhTypes.hpp
  • MdhWaitSetUnknown : MdhTypes.hpp
  • MdhWaitSmsDiscard : MdhTypes.hpp
  • MdhWaitSmsStore : MdhTypes.hpp
  • MdhWaitSmsUnknown : MdhTypes.hpp
  • MdhWaitType : MdhTypes.hpp
  • MdhWarnMemoryExceeded : MdhTypes.hpp
  • MdhWarnSmStorageSimIsFull : MdhTypes.hpp
  • MdhWorkMedia : MdhTypes.hpp
  • MdPhoneBook : AtcTypes.hpp
  • MeasurementDataSent : GltpTypes.hpp
  • MeCurrentlyUnableAccessControlClassBar : SimTkTypes.hpp
  • MeCurrentlyUnableBusyOnSendDtmfCommand : SimTkTypes.hpp
  • MeCurrentlyUnableBusyOnSsTransaction : SimTkTypes.hpp
  • MeCurrentlyUnableBusyOnUssdTransaction : SimTkTypes.hpp
  • MeCurrentlyUnableNoService : SimTkTypes.hpp
  • MeCurrentlyUnableNotInSpeechCall : SimTkTypes.hpp
  • MeCurrentlyUnableRadioResourceNotGranted : SimTkTypes.hpp
  • MEDIAFRAMEWORK : apoxi.features
  • MediaManager_hpp : MediaManager.hpp
  • MediaPlayer_hpp : MediaPlayer.hpp
  • MediaRecorder_hpp : MediaRecorder.hpp
  • MediaRecorderImpl_hpp : MediaRecorderImpl.hpp
  • MediaRefPtr : MediaRefContainer.hpp
  • MEM_POOL : BufferPoolManager.hpp
  • memcpy() : InternalTracer.cpp
  • MemoryError : SignalTypes.hpp
  • MemoryExceeded : SignalTypes.hpp
  • MENU_ACCESSORS : apoxi.features
  • Menu_Resource_Table_hpp : MenuResourceTable.hpp
  • MenuAccessors_MsgTypes_hpp : MsgTypes.hpp
  • MenuID : MenuID.hpp
  • MenuID_hpp : MenuID.hpp
  • MenuListModel : MenuList.hpp
  • MenuResourceTable : MenuResourceTable.hpp
  • MePbInvalidIndex : AtcTypes.hpp
  • MePbNotPresent : AtcTypes.hpp
  • MePbSuccessfull : AtcTypes.hpp
  • MePbUnsuccessfull : AtcTypes.hpp
  • MePhoneBook : AtcTypes.hpp
  • MePhoneBookStatus : AtcTypes.hpp
  • MePhoneBookType : AtcTypes.hpp
  • message_tone_10_data : Audio.cpp
  • message_tone_1_data : Audio.cpp
  • message_tone_2_data : Audio.cpp
  • message_tone_3_data : Audio.cpp
  • message_tone_4_data : Audio.cpp
  • message_tone_5_data : Audio.cpp
  • message_tone_6_data : Audio.cpp
  • message_tone_7_data : Audio.cpp
  • message_tone_8_data : Audio.cpp
  • message_tone_9_data : Audio.cpp
  • message_tone_single_beep_data : Audio.cpp
  • MexeCertType : SimAuxHandler.hpp
  • middle_mask_1 : BitBlit_Planes.cpp
  • middle_mask_2 : BitBlit_Planes.cpp
  • MimeType : MimeTypeTable.hpp
  • MimeTypeTable_hpp : MimeTypeTable.hpp
  • MimeTypeTableUtils_hpp : MimeTypeTableUtils.hpp
  • min : Macros.hpp
  • MIN_DATE : DrmCore.hpp
  • min_distance : ConvertToColorValue_Planes.cpp
  • MIN_VOLUME_LEVEL : BtHsVolumeSettingsWin.hpp, BtHfVolumeSettingsWin.hpp
  • MIN_ZOOM_LEVELS : Camera.cpp
  • Minimum() : Types.hpp
  • MiscAudioDevice_hpp : MiscAudioDevice.hpp
  • MM_CHIP_SCICOS : apoxi.features
  • MmCall : SignalTypes.hpp
  • MmCallDisconnected : MmTypes.hpp
  • MmCallDisconnectedByNetwork : MmTypes.hpp
  • MmCallDisconnectedByUser : MmTypes.hpp
  • MmCallDisconnecting : MmTypes.hpp
  • MmCallDisconnectingByNetwork : MmTypes.hpp
  • MmCallDisconnectingByUser : MmTypes.hpp
  • MmCallMessages_hpp__ST_1136454671281 : MmCallMessages.hpp
  • MmCallOnHold : MmTypes.hpp
  • MmCallProgressIndication : MmTypes.hpp
  • MmCallReleased : MmTypes.hpp
  • MmCallState : MmTypes.hpp
  • MMCI : apoxi.features
  • Mmi_AbstractSmsApp_hpp : AbstractSmsApp.hpp
  • Mmi_AbstractSmsComposeWin_hpp : AbstractSmsComposeWin.hpp
  • Mmi_AbstractSmsUtilityProcessor_hpp : AbstractSmsUtiltyProcessor.hpp
  • Mmi_AbstractSmsViewerWin_hpp : AbstractSmsViewerWin.hpp
  • Mmi_AdvPbAction_hpp : AdvPbAction.hpp
  • Mmi_AdvPbApp_hpp : AdvPbApp.hpp
  • Mmi_AdvPbWin_hpp : AdvPbWin.hpp
  • Mmi_BasicPbWin_hpp : BasicPbWin.hpp
  • Mmi_BtAvrcpPreComp_hpp : BtAvrcpPreComp.hpp
  • Mmi_BtDunAppPlugin_hpp : BtDunAppPlugin.hpp
  • Mmi_BtFaxAppPlugin_hpp : BtFaxAppPlugin.hpp
  • Mmi_BtHfAudioPathWin_hpp : BtHfAudioPathWindow.hpp
  • Mmi_BtHfPluginPreComp_hpp : PreComp.hpp
  • Mmi_BtHfProvider_hpp : BtHfProvider.hpp
  • Mmi_BtHfRecord_hpp : BtHfRecord.hpp
  • Mmi_BtHfVolumeSettingsWin_hpp : BtHfVolumeSettingsWin.hpp
  • Mmi_BtHsAppPlugin_hpp : BtHsAppPlugin.hpp
  • Mmi_BtHsVolumeSettingsWin_hpp : BtHsVolumeSettingsWin.hpp
  • Mmi_CalendarListWin_hpp : CalendarListWin.hpp
  • Mmi_CalendarRecordsList_hpp : CalendarRecordsList.hpp
  • Mmi_CalendarRecordsListBox_hpp : CalendarRecordsListBox.hpp
  • Mmi_CameraApp_hpp : CameraApp.hpp
  • Mmi_CameraCaptureWin_hpp : CameraCaptureWin.hpp
  • Mmi_CameraSettings_hpp : CameraSettings.hpp
  • Mmi_CameraViewFinderWin_hpp : CameraViewFinderWin.hpp
  • Mmi_CopyHandler_hpp : CopyHandler.hpp
  • Mmi_CsdDataConnProvider_hpp : CsdDataConnProvider.hpp
  • Mmi_DataConnApp_hpp : DataConnApp.hpp
  • Mmi_DataConnProvider_hpp : DataConnProvider.hpp
  • Mmi_DataConnTextMaps_hpp : DataConnTextMaps.hpp
  • Mmi_DistinctProvider_hpp : DistinctProvider.hpp
  • Mmi_Dynamic_MenuPool_hpp : DynamicMenuPool.hpp
  • Mmi_EmsApp_hpp : EmsApp.hpp
  • Mmi_EmsComposeWin_hpp : EmsComposeWin.hpp
  • Mmi_EmsViewerWin_hpp : EmsViewerWin.hpp
  • Mmi_EnumTextMap_hpp : EnumTextMap.hpp
  • Mmi_FmRadioApp_hpp : FmRadioApplication.hpp
  • Mmi_FmRadioSettingsProvider_hpp : FmRadioSettingsProvider.hpp
  • Mmi_FmRadioSettingsRecord_hpp : FmRadioSettingsRecord.hpp
  • Mmi_FmRadioStationsProvider_hpp : FmRadioStationsProvider.hpp
  • Mmi_FmRadioStationsRecord_hpp : FmRadioStationsRecord.hpp
  • Mmi_GltpAidingDataWin_hpp : AidingDataWin.hpp
  • Mmi_GltpConnApp_hpp : GltpConnApp.hpp
  • Mmi_GroupProvider_hpp : GroupProvider.hpp
  • Mmi_IndicatorBar_hpp : IndicatorBar.hpp
  • Mmi_IrdaApp_hpp : IrdaApp.hpp
  • Mmi_IrdaWin_hpp : IrdaWin.hpp
  • Mmi_LcsAppUtils_hpp : LcsAppUtils.hpp
  • Mmi_LcsFeatType_hpp : LcsFeatTypes.hpp
  • Mmi_LcsMainApp_hpp : LcsMainApp.hpp
  • Mmi_LcsMainMenuWin_hpp : LcsMainMenuWin.hpp
  • Mmi_LcsOptionsMenuWin_hpp : LcsOptionsMenuWin.hpp
  • Mmi_LcsRegUri_hpp : LcsRegUri.hpp
  • Mmi_LcsSettingsApp_hpp : LcsSettingsApp.hpp
  • Mmi_LcsSettingsUtils_hpp : LcsSettingsUtils.hpp
  • Mmi_LcsSocket_hpp : LcsSocket.hpp
  • Mmi_LcsWapIntf_hpp : LcsWapIntf.hpp
  • Mmi_LcsWString_hpp : LcsWString.hpp
  • Mmi_LocationResultWin_hpp : LocationResultWin.hpp
  • Mmi_LocationVerifWin_hpp : LocationVerifWin.hpp
  • Mmi_LocResController_hpp : LocResController.hpp
  • Mmi_ObexApp_hpp : ObexApp.hpp
  • Mmi_ObexTransportWin_hpp : ObexTransportWin.hpp
  • Mmi_PbAbstractWin_hpp : PbAbstractWin.hpp
  • Mmi_PbAction_hpp : PbAction.hpp
  • Mmi_PbAdvAddEditEntry_hpp : PbAdvAddEditEntry.hpp
  • Mmi_PbAdvDataHandler_hpp : PbAdvDataHandler.hpp
  • Mmi_PbAdvDetails_hpp : PbAdvDetails.hpp
  • Mmi_PbBaseWin_hpp : PbBaseWin.hpp
  • Mmi_PbConfig_hpp : PbConfig.hpp
  • Mmi_PbDataHandler_hpp : PbDataHandler.hpp
  • Mmi_PbDetail_ListBox_hpp : PbDetailListBox.hpp
  • Mmi_PbDetailFilterProvider_hpp : PbDetailFilterProvider.hpp
  • Mmi_PbDetails_hpp : PbDetails.hpp
  • Mmi_PbFfsNameHandler_hpp : PbFfsNameHandler.hpp
  • Mmi_PbFfsNumberHandler_hpp : PbFfsNumberHandler.hpp
  • Mmi_PbLazySynchronizer_hpp : PbLazySynchronizer.hpp
  • Mmi_PbManualSynchronizer_hpp : PbManualSynchronizer.hpp
  • Mmi_PbMergeProvider_hpp : PbMergeProvider.hpp
  • Mmi_PbNameEditBox_hpp : PbNameEditBox.hpp
  • Mmi_PbNameFilterProvider_hpp : PbNameFilterProvider.hpp
  • Mmi_PbNameHandler_hpp : PbNameHandler.hpp
  • Mmi_PbNameNumberProvider_hpp : PbNameNumberProvider.hpp
  • Mmi_PbNameProvider_hpp : PbNameProvider.hpp
  • Mmi_PbNextFreeIdRecord_hpp : PbNextFreeIdRecord.hpp
  • Mmi_PbNumberHandler_hpp : PbNumberHandler.hpp
  • Mmi_PbNumberProvider_hpp : PbNumberProvider.hpp
  • Mmi_PbNvRamNameHandler_hpp : PbNvRamNameHandler.hpp
  • Mmi_PbNvRamNumberHandler_hpp : PbNvRamNumberHandler.hpp
  • Mmi_PbPhoneNumberPrompt_hpp : PbPhoneNumberPrompt.hpp
  • Mmi_PbProvider_hpp : PbProviderListener.hpp
  • Mmi_PbProvIds_hpp : PbProvIds.hpp
  • Mmi_PbProvListBox_hpp : PbProvListBox.hpp
  • Mmi_PbRecord_hpp : PbRecord.hpp
  • Mmi_PbRecordHandler_hpp : PbRecordHandler.hpp
  • Mmi_PbRecordProvider_hpp : PbRecordProvider.hpp
  • Mmi_PbSelectNumberWin_hpp : PbSelectNumberWin.hpp
  • Mmi_PbSimProvider_hpp : PbSimProvider.hpp
  • Mmi_PbSortedProvider_hpp : PbSortedProvider.hpp
  • Mmi_PbSynchronizer_hpp : PbSynchronizer.hpp
  • Mmi_PbTypes_hpp : PbTypes.hpp
  • Mmi_PhonebookApp_hpp : PhonebookApp.hpp
  • Mmi_PhoneNumberMatchRule_hpp : PhoneNumberMatchRule.hpp
  • Mmi_ProvListBoxWin_hpp : ProvListBoxWin.hpp
  • Mmi_PsdDataConnProvider_hpp : PsdDataConnProvider.hpp
  • Mmi_RegApp_hpp : RegApp.hpp
  • Mmi_RegAppCommon_hpp : RegAppCommon.hpp
  • Mmi_RegAppFirstWin_hpp : RegAppFirstWin.hpp
  • Mmi_RegAppWin_hpp : RegAppWin.hpp
  • Mmi_RegEncoderDecoder_hpp : RegEncoderDecoder.hpp
  • Mmi_ResultWinBase_hpp : ResultWinBase.hpp
  • Mmi_SatteliteGraphWin_hpp : SatteliteGraphWin.hpp
  • Mmi_SatteliteInfoWin_hpp : SatteliteInfoWin.hpp
  • Mmi_SavingProgressWin_hpp : SavingProgressWin.hpp
  • Mmi_SelfLocationDialogWin_hpp : SelfLocationDialogWin.hpp
  • Mmi_SerDataConnProvider_hpp : SerDataConnProvider.hpp
  • Mmi_ServerAddressWin_hpp : ServerAddressWin.hpp
  • Mmi_SettingsProvider_hpp : SettingsProvider.hpp
  • Mmi_SmsAlerts_hpp : SmsAlerts.hpp
  • Mmi_SmsApp_hpp : SmsApp.hpp
  • Mmi_SmsBasicProvider_hpp : SmsBasicProvider.hpp
  • Mmi_SmsComposeWin_hpp : SmsComposeWin.hpp
  • Mmi_SmsEditor_hpp : SmsEditor.hpp
  • Mmi_SmsFolderProvider_hpp : SmsFolderProvider.hpp
  • Mmi_SmsIndicationState_hpp : SmsIndicationState.hpp
  • Mmi_SmsSendingConfirmDialog_hpp : SmsSendingConfirmDialog.hpp
  • Mmi_SmsService_hpp : SmsService.hpp
  • Mmi_SmsSettingsProvider_hpp : SmsSettingsProvider.hpp
  • Mmi_SmsSettingsRecord_hpp : SmsSettingsRecord.hpp
  • Mmi_SmsTemplateProvider_hpp : SmsTemplateProvider.hpp
  • Mmi_SmsTextMaps_hpp : SmsTextMaps.hpp
  • Mmi_SmsTextParser_hpp : SmsTextParser.hpp
  • Mmi_SmsUtility_hpp : SmsUtility.hpp
  • Mmi_SmsViewerWin_hpp : SmsViewerWin.hpp
  • Mmi_SyncPhoneThreadlet_hpp : SyncPhoneThreadlet.hpp
  • Mmi_ToDoListWin_hpp : ToDoListWin.hpp
  • Mmi_ToDoProvider_hpp : ToDoProvider.hpp
  • Mmi_ToDoRecord_hpp : ToDoRecord.hpp
  • Mmi_TransferLocationDialogWin_hpp : TransferLocationDialogWin.hpp
  • Mmi_UibSettingsRecord_hpp : UibSettingsRecord.hpp
  • Mmi_UpdatePbThreadlet_hpp : UpdatePbThreadlet.hpp
  • Mmi_UsbApp_hpp : UsbApp.hpp
  • Mmi_VoiceMemoApp_hpp : VoiceMemoApp.hpp
  • Mmi_VoiceMemoMenuAccessor_hpp : VoiceMemoMenuAccessor.hpp
  • Mmi_VoiceMemoPreComp_hpp : VoiceMemoPreComp.hpp
  • Mmi_VoiceMemoRecordWin_hpp : VoiceMemoRecordWin.hpp
  • Mmi_VoiceMemoWin_hpp : VoiceMemoWin.hpp
  • MmiClient : SignalTypes.hpp
  • MmiNotRegistered : SignalTypes.hpp
  • MmiSendGddViewfinderEnabled() : SocketTestVersion.cpp, ApbVersion.cpp
  • MMISIM_ENV_VAR_DISABLE : MmiSimProtocol.hpp
  • MMISIM_ENV_VAR_HOST : MmiSimProtocol.hpp
  • MMISIM_ENV_VAR_PORT : MmiSimProtocol.hpp
  • MMISIM_LOCALHOST : MmiSimProtocol.hpp
  • MMISIM_MASK_ALT : MmiSimProtocol.hpp
  • MMISIM_MASK_CTRL : MmiSimProtocol.hpp
  • MMISIM_MASK_NONE : MmiSimProtocol.hpp
  • MMISIM_MASK_SHIFT : MmiSimProtocol.hpp
  • MMISIM_PORT : MmiSimProtocol.hpp
  • MMISIM_PORT_RANGE : MmiSimProtocol.hpp
  • MmiSimBacklightStateId : MmiSimProtocol.hpp
  • MmiSimCharId : MmiSimProtocol.hpp
  • MmiSimDisplayUpdateDataId : MmiSimProtocol.hpp
  • MmiSimDisplayUpdateHeaderId : MmiSimProtocol.hpp
  • MmiSimKeyDownId : MmiSimProtocol.hpp
  • MmiSimKeyUpId : MmiSimProtocol.hpp
  • MmiSimLedStateId : MmiSimProtocol.hpp
  • MmiSimMsgId : MmiSimProtocol.hpp
  • MmiSimPenDownId : MmiSimProtocol.hpp
  • MmiSimPenMoveId : MmiSimProtocol.hpp
  • MmiSimPenUpId : MmiSimProtocol.hpp
  • MmiSimVibrationStateId : MmiSimProtocol.hpp
  • MmiSubUnitType : BtAvrcpPanelService.hpp
  • MmiTracer : Trace.hpp
  • MmiTracerLevel2 : Trace.hpp
  • MmiTracerLevel3 : Trace.hpp
  • MmMocInSetup : MmTypes.hpp
  • MmMocSetupAccept : MmTypes.hpp
  • MmRrcCellBarred : NetworkTypes.hpp
  • MmRrcCongestion : NetworkTypes.hpp
  • MmRrcConnEstablished : NetworkTypes.hpp
  • MmRrcConnRelease : NetworkTypes.hpp
  • MmRrcDirectedSigconnReEstablishment : NetworkTypes.hpp
  • MmRrcInterratHandover : NetworkTypes.hpp
  • MmRrcnactive : NetworkTypes.hpp
  • MmRrcNoCause : NetworkTypes.hpp
  • MmRrcNormalEvent : NetworkTypes.hpp
  • MmRrcPreEmtiveRelease : NetworkTypes.hpp
  • MmRrcReEstablishmentReject : NetworkTypes.hpp
  • MmRrcUserInactivity : NetworkTypes.hpp
  • MmRrReason : NetworkTypes.hpp
  • Mnc : NetworkTypes.hpp
  • MnCause : SignalTypes.hpp
  • Mobil : PbTypes.hpp
  • MocActive : SignalTypes.hpp
  • MocAlerted : SignalTypes.hpp
  • MoCallActionType : InputAction.hpp
  • MocAsCallSetup : SignalTypes.hpp
  • MocChangedToSupplementaryService : Types.hpp
  • MocChangedToUssd : Types.hpp
  • MocSetup : SignalTypes.hpp
  • MocSetupRejMissingAcmInfoInd : SignalTypes.hpp
  • MocStarted : SignalTypes.hpp
  • MocVoiceHandlerId : HandlerId.hpp
  • MolrStatus : LcsReqProcessor.hpp
  • MolrTimer : LcsTimer.hpp
  • MolrType : LcsTypes.hpp
  • Monitored : NetworkTypes.hpp
  • MonReselServCellNotSuitable : NetworkTypes.hpp
  • months_to_days() : RealTimeClock.cpp
  • MoUssdHandlerId : HandlerId.hpp
  • MovedDownRepaintHint : Grid.hpp
  • MovedLeftRepaintHint : Grid.hpp
  • MovedRightRepaintHint : Grid.hpp
  • MovedUpRepaintHint : Grid.hpp
  • MP3 : apoxi.features
  • Mp3AudioDevice_hpp : Mp3AudioDevice.hpp
  • MP3BLOCKSIZE : HostAudioDriver.cpp
  • Mp3PlayCallBack : HostAudioDriver.hpp
  • Mp3RetCode : HostAudioDriver.hpp
  • MpartySplitStarted : SignalTypes.hpp
  • MpegLayer : HostAudioDriver.cpp
  • MpegV1Freq : HostAudioDriver.cpp
  • MpegV1L3Br : HostAudioDriver.cpp
  • MpegV2Freq : HostAudioDriver.cpp
  • MpegV2L3Br : HostAudioDriver.cpp
  • MpegVersion : HostAudioDriver.cpp
  • MptyCallDetected : Types.hpp
  • MptyCallRequired : Types.hpp
  • MptyHeldRejected : SignalTypes.hpp
  • MptyHeldStarted : SignalTypes.hpp
  • MptyIsActive : SignalTypes.hpp
  • MptyIsHeld : SignalTypes.hpp
  • MptyIsRetrieved : SignalTypes.hpp
  • MptyIsSplitted : SignalTypes.hpp
  • MptyRejected : SignalTypes.hpp
  • MptyRetrievedStarted : SignalTypes.hpp
  • MptyRetrieveRejected : SignalTypes.hpp
  • MptySplitRejected : SignalTypes.hpp
  • MptyStarted : SignalTypes.hpp
  • ms_assisted_eotd : LcsDecls.hpp
  • ms_based_eotd : LcsDecls.hpp
  • MsAccessClassBarred : SignalTypes.hpp
  • msap_retrieve_brsf() : BtHfService.cpp, BtHfController.cpp
  • MsapPackedData : SimTkTypes.hpp
  • MscNotReachable : SignalTypes.hpp
  • MsFailureUnspecified : SignalTypes.hpp
  • MSFS : apoxi.features
  • MsgAlertRpt : SignalTypes.hpp
  • MsgCategory : MsgCategory.hpp
  • MsgClass : MsgClass.hpp
  • MsgId : MsgCategory.hpp
  • MsgNotCompatible : SignalTypes.hpp
  • MsgOrigin : MsgCategory.hpp
  • MsgTypes_hpp__ST_1092996111155 : MsgTypes.hpp
  • MsgTypes_hpp__ST_1122019187332 : MsgTypes.hpp
  • MsgtypNotCompatible : SignalTypes.hpp
  • MsgtypNotExists : SignalTypes.hpp
  • MsIdentUnknown : SignalTypes.hpp
  • MsisdnEfPos : SimTkTypes.hpp
  • MsisdnPhoneBook : SignalTypes.hpp
  • MsisdnPhoneBookCnt : SignalTypes.hpp
  • MsNoResource : SignalTypes.hpp
  • MsNoService : SignalTypes.hpp
  • Msp : SignalTypes.hpp
  • MsPhoneBook : AtcTypes.hpp
  • MsServiceBusy : SignalTypes.hpp
  • MSUAudio : BtAvrcpPanelService.hpp
  • MSUBtAstUnit : BtAvrcpPanelService.hpp
  • MSUBulletinBoard : BtAvrcpPanelService.hpp
  • MSUCa : BtAvrcpPanelService.hpp
  • MSUCamera : BtAvrcpPanelService.hpp
  • MSUCameraStorage : BtAvrcpPanelService.hpp
  • MSUDisc : BtAvrcpPanelService.hpp
  • MSUMonitor : BtAvrcpPanelService.hpp
  • MSUPanel : BtAvrcpPanelService.hpp
  • MSUPrinter : BtAvrcpPanelService.hpp
  • MSUTapeRecPlayer : BtAvrcpPanelService.hpp
  • MSUTuner : BtAvrcpPanelService.hpp
  • MSUVendorUnique : BtAvrcpPanelService.hpp
  • MtcAccepted : SignalTypes.hpp
  • MtcActive : SignalTypes.hpp
  • MtcArrived : MmTypes.hpp
  • MtcAsCallSetup : SignalTypes.hpp
  • MtcBcNegotiated : SignalTypes.hpp
  • MtcConfirmed : SignalTypes.hpp
  • MtcReady : MmTypes.hpp
  • MtcRejected : SignalTypes.hpp
  • MtcSetup : SignalTypes.hpp
  • MtcStarted : SignalTypes.hpp
  • MtcVoiceHandlerId : HandlerId.hpp
  • MtlrTimer : LcsTimer.hpp
  • MULTIMEDIA : apoxi.features
  • MultiMedia_AbstractIMelodyParser_hpp : AbstractIMelodyParser.hpp
  • MultiMedia_AmrSound_hpp : AmrSound.hpp
  • MultiMedia_AudioContext_hpp : AudioContext.hpp
  • MultiMedia_IMelody_hpp : IMelody.hpp
  • MultiMedia_Melody_hpp : Melody.hpp
  • MultiMedia_MidiSound_hpp : MidiSound.hpp
  • MultiMedia_PreparedSound_hpp : PreparedSound.hpp
  • MultiMedia_SmafSound_hpp : SmafSound.hpp
  • MULTIPART_COMMENT : MultipartParser.hpp
  • MULTIPART_CR : MultipartParser.hpp
  • MULTIPART_ERROR_CONTENT_PARSING : MultipartParser.hpp
  • MULTIPART_ERROR_FILE_FORMAT : MultipartParser.hpp
  • MULTIPART_ERROR_HEADER_PARSING : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_BOUNDARY : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_END : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_INPUT : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_START : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_VALUE : MultipartParser.hpp
  • MULTIPART_ERROR_NO_HEADER : MultipartParser.hpp
  • MULTIPART_ERROR_NO_MEMORY : MultipartParser.hpp
  • MULTIPART_ERROR_REACHED_EOF : MultipartParser.hpp
  • MULTIPART_ERROR_UNKNOWN : MultipartParser.hpp
  • MULTIPART_ERROR_VALUE_NOT_FOUND : MultipartParser.hpp
  • MULTIPART_LF : MultipartParser.hpp
  • MULTIPART_SPACE : MultipartParser.hpp
  • MULTIPART_SUCCESS : MultipartParser.hpp
  • MULTIPART_TAB : MultipartParser.hpp
  • MultiParty : SignalTypes.hpp
  • MultipleCardCommandsError : SimTkTypes.hpp
  • MultipleCardCommandsErrorCApduFormatError : SimTkTypes.hpp
  • MultipleCardCommandsErrorCardPoweredOff : SimTkTypes.hpp
  • MultipleCardCommandsErrorCardReaderBusy : SimTkTypes.hpp
  • MultipleCardCommandsErrorCardReaderRemovedOrNotPresent : SimTkTypes.hpp
  • MultipleCardCommandsErrorCardRemovedOrNotPresent : SimTkTypes.hpp
  • MultipleCardCommandsErrorMuteCard : SimTkTypes.hpp
  • MultipleCardCommandsErrorProtocolNotSupported : SimTkTypes.hpp
  • MultipleCardCommandsErrorSpecifiedReaderNotValid : SimTkTypes.hpp
  • MultipleCardCommandsErrorTransmissionError : SimTkTypes.hpp
  • MULTIPLIKATOR : StillCamera.cpp
  • MultiSlotCapability : NetworkTypes.hpp
  • MultiSlotHandlerId : HandlerId.hpp
  • MultiTabInputMapper : MultiTabInputMapper.hpp
  • MutexObtainer_hpp : MutexObtainer.hpp
  • MyDataConnProfileStorage : MyDataConnProfileStorage.hpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • n_delta : BitBlit_Planes.cpp
  • n_left_mask_1 : BitBlit_Planes.cpp
  • n_left_mask_2 : BitBlit_Planes.cpp
  • n_right_mask_1 : BitBlit_Planes.cpp
  • n_right_mask_2 : BitBlit_Planes.cpp
  • Nai : Tlv.hpp
  • NAI_HEADER_SIZE : NativeImage.cpp
  • NAI_META_DATA_SIZE : NativeImage.cpp
  • NaiCloseChannel : Tlv.hpp
  • NaiDisplayText : Tlv.hpp
  • NaiEndOfProactiveSession : Tlv.hpp
  • NaiGetChannelStatus : Tlv.hpp
  • NaiGetInkey : Tlv.hpp
  • NaiGetInput : Tlv.hpp
  • NaiGetReaderStatus : Tlv.hpp
  • NaiInvalid : Tlv.hpp
  • NaiLaunchBrowser : Tlv.hpp
  • NaiOpenChannel : Tlv.hpp
  • NaiPerformCardApdu : Tlv.hpp
  • NaiPlayTone : Tlv.hpp
  • NaiPowerOffCard : Tlv.hpp
  • NaiPowerOnCard : Tlv.hpp
  • NaiProvideLocalInformation : Tlv.hpp
  • NaiReceiveData : Tlv.hpp
  • NaiSelectItem : Tlv.hpp
  • NaiSendData : Tlv.hpp
  • NaiSendShortMessage : Tlv.hpp
  • NaiSendSs : Tlv.hpp
  • NaiSendUssd : Tlv.hpp
  • NaiSetupCall : Tlv.hpp
  • NaiSetupIdleModeText : Tlv.hpp
  • NaiSetupMenu : Tlv.hpp
  • name : VCard.cpp
  • NamePresentationAllowed : SignalTypes.hpp
  • NamePresentationRestricted : SignalTypes.hpp
  • NameUnavailable : SignalTypes.hpp
  • Native16BitBase : MachType.hpp
  • native2percent() : audio_private.hpp, audio_private.cpp
  • Native32BitBase : MachType.hpp
  • NatRoamingNotAllowed : SignalTypes.hpp
  • ndelta : DrawChar_Planes.cpp
  • Needed : SignalTypes.hpp
  • NegativeAckTone : SignalTypes.hpp
  • NET_INITIALIZED : LwipSysSocket.cpp
  • NET_PPP_IN_USE : LwipSysSocket.cpp
  • NET_PPP_STOP : LwipSysSocket.cpp
  • NET_SOCKET_TYPE_SMS : SimTkTypes.hpp
  • NET_SOCKET_TYPE_TCP : SimTkTypes.hpp
  • NET_SOCKET_TYPE_UDP : SimTkTypes.hpp
  • NetType : NetworkTypes.hpp
  • NetworkCurrentlyUnableToProcessCommand : SimTkTypes.hpp
  • NetWorkDisconnection : Types.hpp
  • NetworkFailure : SignalTypes.hpp
  • NetworkHandlerId : HandlerId.hpp
  • NetworkOpMode : NetworkTypes.hpp
  • NetworkOutOfOrder : SignalTypes.hpp
  • NetworkSearchMode : NetworkTypes.hpp
  • Nev : SignalTypes.hpp
  • new_file_name : FfsTests.cpp
  • NEW_HEIGHT_JPEG : StillCamera.cpp
  • NEW_JPEG_QUALITY : StillCamera.cpp
  • NEW_WIDTH_JPEG : StillCamera.cpp
  • NewHandler : Allocator.hpp
  • NewHandlerFn : Allocator.hpp
  • NiaEfPos : SimTkTypes.hpp
  • NMAX : RingBuffer.cpp
  • No_carrier : NetworkTypes.hpp
  • No_cause : NetworkTypes.hpp
  • No_cell : NetworkTypes.hpp
  • NO_CHECK_BYTES : HeapVector.hpp
  • no_cols : CalendarGrid.hpp
  • NO_FRAME_RATE_SUB : StillCamera.cpp
  • NO_MEMBER_TEMPLATES : NiSharedPtr.hpp
  • NO_OF_PICTURE_FOR_SINGLE_SHOT : StillCamera.cpp
  • NO_OF_PICTURES_EMPTY : StillCamera.cpp
  • no_rows : CalendarGrid.hpp
  • NO_SUCH_CODE : GifDecoder.cpp
  • NoAoc : SignalTypes.hpp
  • NoAppropriateDtmfEntry : SignalTypes.hpp
  • NoCallError : SignalTypes.hpp
  • NoCard : SignalTypes.hpp
  • NoCircuitAvailable : SignalTypes.hpp
  • NoClient : SignalTypes.hpp
  • NoCug : SignalTypes.hpp
  • NoCugSelected : SignalTypes.hpp
  • NoDataCall : SignalTypes.hpp
  • NoError : Types.hpp
  • NoGprsCell : NetworkTypes.hpp
  • NoHighlightningBehaviour : Grid.hpp
  • None : LcsTypes.hpp
  • NoNetwork : Types.hpp
  • NonExistent : LcsReqProcessor.hpp
  • NonSelectedUserClearing : SignalTypes.hpp
  • NoOfCountTypes : SimPduHandler.hpp
  • NoOperation : SignalTypes.hpp
  • NoPdpContextActive : SignalTypes.hpp
  • NoProgress : SignalTypes.hpp
  • NoRepaintHint : Grid.hpp
  • NoResponse : SimTkTypes.hpp
  • NoResponseFromUser : LcsDecls.hpp
  • NormalCallClear : SignalTypes.hpp
  • NormalOnMode : SignalTypes.hpp
  • NormalSearchMode : NetworkTypes.hpp
  • NormalService : NetworkTypes.hpp
  • NormalServiceRequired : Types.hpp
  • NormalSim : SignalTypes.hpp
  • NormalSms : SimPduHandler.hpp
  • NormalSpecialSim : SignalTypes.hpp
  • NormalUnspecified : SignalTypes.hpp
  • NoRoute : SignalTypes.hpp
  • NoSelectionBehaviour : Grid.hpp
  • NoService : NetworkTypes.hpp
  • NoSimKeyboardAllowed() : SimChvHandler.cpp
  • NoSimMenuAllowed() : SimChvHandler.cpp
  • NoSsCode : SignalTypes.hpp
  • NoSuitableCellsInLa : SignalTypes.hpp
  • NOT_AVAILALBE : BtAvrcpControllerApplicationWindows.cpp
  • NOT_USEABLE : Camera.cpp
  • NotActivated : SignalTypes.hpp
  • NotAvailable : SignalTypes.hpp
  • NoTextNoIcon : NetworkTypes.hpp
  • NoTextWithIcon : NetworkTypes.hpp
  • NotificationDescription : SignalTypes.hpp
  • NotificationType : InputMapper.hpp
  • Notify : LcsTypes.hpp
  • NotInSpeechCall : SignalTypes.hpp
  • NotMeasured : NetworkTypes.hpp
  • NotNeeded : SignalTypes.hpp
  • NotSpecified : Types.hpp
  • NotSpeech : SignalTypes.hpp
  • NotSupported : Types.hpp
  • NoType : PbTypes.hpp
  • NoUserResponding : SignalTypes.hpp
  • NULL_VALUE : Zi8Wrapper.hpp
  • Number : DataItem.hpp
  • NumberChanged : SignalTypes.hpp
  • NumberOfEfPos : SimTkTypes.hpp
  • NumberType : DataItem.hpp
  • NVRAM_IN_FILE : NvRam.cpp
  • NvRamGetWin32FilePath() : NvRam.cpp
  • NvRamOpenEmuFile() : NvRam.cpp
  • NvRamRead() : NvRam.hpp, NvRam.cpp
  • NvramTpdus : SimPduHandler.hpp
  • NvRamWrite() : NvRam.hpp, NvRam.cpp
  • NwFailureUnspecified : SignalTypes.hpp
  • NwOpMode1 : NetworkTypes.hpp
  • NwOpMode2 : NetworkTypes.hpp
  • NwOpMode3 : NetworkTypes.hpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- o -

  • OBEX : apoxi.features
  • OBEX_BUFFER_MAX_SIZE : BtObexImpl.hpp
  • OBEX_HANDLE_MSG : ObexDispatcher.cpp
  • OBEX_HEADER_SIZE : BtObexImpl.hpp
  • Obex_ObexAppMsg_hpp : ObexAppMsg.hpp
  • Obex_ObexMessages_hpp : ObexMessages.hpp
  • Obex_ObexTransportMsg_hpp : ObexTransportMsg.hpp
  • Obex_ObexVCardMsg_hpp : ObexVCardMsg.hpp
  • ObexAddrPtr : ObexAddrPtr.hpp
  • ObexAddrTypeId : ObexTypes.hpp
  • ObexAppMsgTransportSelectionReq : ObexTypes.hpp
  • ObexAppMsgType : ObexTypes.hpp
  • ObexAppVersion_hpp : ObexAppVersion.hpp
  • OBEXFTP_RFS : apoxi.features
  • ObexMsgAbort : ObexTypes.hpp
  • ObexMsgBuffer : ObexTypes.hpp
  • ObexMsgConnect : ObexTypes.hpp
  • ObexMsgDisconnect : ObexTypes.hpp
  • ObexMsgGet : ObexTypes.hpp
  • ObexMsgPut : ObexTypes.hpp
  • ObexMsgResponse : ObexTypes.hpp
  • ObexMsgResult : ObexTypes.hpp
  • ObexMsgSetPath : ObexTypes.hpp
  • ObexMsgType : ObexTypes.hpp
  • ObexPrIdObex : ObexTypes.hpp
  • ObexPrIdOpp : ObexTypes.hpp
  • ObexProtocolId : ObexTypes.hpp
  • ObexServerId : ObexTypes.hpp
  • ObexTransportId : ObexTypes.hpp
  • ObexTransportMsgType : ObexTypes.hpp
  • ObexTrAvStateChanged : ObexTypes.hpp
  • ObexTrEnableRejected : ObexTypes.hpp
  • ObexTrSelectionResult : ObexTypes.hpp
  • OBEXVERSION : ObexAppVersion.hpp
  • ODyn2EfPos : SimTkTypes.hpp
  • ODynEfPos : SimTkTypes.hpp
  • OffHookToneOn : SignalTypes.hpp
  • Office : PbTypes.hpp
  • OJcEfPos : SimTkTypes.hpp
  • OneStopBit : LcsTypes.hpp
  • OneWaySyncFromClient : DBService.hpp
  • OneWaySyncFromServer : DBService.hpp
  • Ongoing : LcsReqProcessor.hpp
  • ONLINE_RENDER_FILE_VERSION : ResourceManager.cpp
  • OnlyError : SignalTypes.hpp
  • OnlyRestrictedDigital : SignalTypes.hpp
  • OnMinuteTickCheck() : RealTimeClock.cpp
  • OnRequestStateChange() : BtBipServerService.cpp
  • OnTime() : RealTimeClock.cpp
  • OnTimer() : MdhSignalProcessor.cpp
  • OParamEfPos : SimTkTypes.hpp
  • OpenBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • OpenCurrentFileBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • OpenCurrentFileFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • OpenDownlink() : TchInterface.cpp
  • OpenErr : FfsTestError.hpp
  • OpenFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • OpenTch() : TchInterface.cpp
  • OpenUplink() : TchInterface.cpp
  • operator delete() : Allocator.hpp
  • operator new() : Allocator.hpp
  • operator!=() : ObexOperationId.hpp, ObexChannel.hpp, BtObexServiceTable.hpp, BtUtility.hpp, BtUtility.cpp, BtSvrDataElement.hpp, BtSvrDataElement.cpp, NiSharedPtr.hpp, ByteBuffer.hpp, ResourceID.hpp
  • operator<() : ResourceID.hpp
  • operator<<() : UibMsgTypes.cpp, GltpAppMsgTypes.cpp, SmsSettingsRecord.cpp, ObexVCardMsg.cpp, MsgTypes.cpp, EmServThreadMsg.cpp
  • operator==() : ObexOperationId.hpp, ObexChannel.hpp, BtObexServiceTable.hpp, BtUtility.hpp, BtUtility.cpp, BtSvrDataElement.hpp, BtSvrDataElement.cpp, NiSharedPtr.hpp, ByteBuffer.hpp, ResourceID.hpp, RfsTemplates.cpp
  • operator>() : ResourceID.hpp
  • operator>>() : UibMsgTypes.cpp, GltpAppMsgTypes.cpp, SmsSettingsRecord.cpp, ObexVCardMsg.cpp, EditBox.hpp, EditBox.cpp, MsgTypes.cpp, EmServThreadMsg.cpp
  • OperatorBarring : SignalTypes.hpp
  • OperatorRootPublicKey : SimAuxHandler.hpp
  • OplmnWactEfPos : SimTkTypes.hpp
  • OSct2EfPos : SimTkTypes.hpp
  • Other : SignalTypes.hpp
  • OutgCallsBarredWithCug : SignalTypes.hpp
  • OutgoingRefuseDirection : SignalTypes.hpp
  • OutofMemory : SignalTypes.hpp
  • OUTPUT_BUF_SIZE : PngEncoder.cpp, JpegEncoder.cpp
  • OverallTpdus : SimPduHandler.hpp
  • OverrideCategory : SignalTypes.hpp
  • OverrideDisabled : SignalTypes.hpp
  • OverrideEnabled : SignalTypes.hpp
  • overwrite_text_sample : FfsTests.cpp
  • OZon1EfPos : SimTkTypes.hpp
  • OZon2EfPos : SimTkTypes.hpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- z -

  • ZI8 : apoxi.features
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • A_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • AaemEfPos : SimTkTypes.hpp
  • Abnormal_release : NetworkTypes.hpp
  • Abs() : Fraction.cpp
  • Absolute() : Types.hpp
  • ACAngle : BtAvrcpCommandInterface.hpp
  • acb : FillRect_Planes.cpp
  • acb_brushstyle : FillRect_Planes.cpp
  • ACBackward : BtAvrcpCommandInterface.hpp
  • AcceptConfirmation : MmTypes.hpp
  • Access_not_allowed : NetworkTypes.hpp
  • AccessInformationDiscarded : SignalTypes.hpp
  • AccHandlerId : HandlerId.hpp
  • ACClear : BtAvrcpCommandInterface.hpp
  • ACDisplayInformation : BtAvrcpCommandInterface.hpp
  • ACDot : BtAvrcpCommandInterface.hpp
  • ACEject : BtAvrcpCommandInterface.hpp
  • ACEnter : BtAvrcpCommandInterface.hpp
  • ACF1 : BtAvrcpCommandInterface.hpp
  • ACF2 : BtAvrcpCommandInterface.hpp
  • ACF3 : BtAvrcpCommandInterface.hpp
  • ACF4 : BtAvrcpCommandInterface.hpp
  • ACF5 : BtAvrcpCommandInterface.hpp
  • ACFastForward : BtAvrcpCommandInterface.hpp
  • ACForward : BtAvrcpCommandInterface.hpp
  • ACHelp : BtAvrcpCommandInterface.hpp
  • ACInputSelect : BtAvrcpCommandInterface.hpp
  • ACKey0 : BtAvrcpCommandInterface.hpp
  • ACKey1 : BtAvrcpCommandInterface.hpp
  • ACKey2 : BtAvrcpCommandInterface.hpp
  • ACKey3 : BtAvrcpCommandInterface.hpp
  • ACKey4 : BtAvrcpCommandInterface.hpp
  • ACKey5 : BtAvrcpCommandInterface.hpp
  • ACKey6 : BtAvrcpCommandInterface.hpp
  • ACKey7 : BtAvrcpCommandInterface.hpp
  • ACKey8 : BtAvrcpCommandInterface.hpp
  • ACKey9 : BtAvrcpCommandInterface.hpp
  • Acm1 : SignalTypes.hpp
  • Acm2 : SignalTypes.hpp
  • AcmEfPos : SimTkTypes.hpp
  • AcmGreaterOrEqualToAcmmax : SignalTypes.hpp
  • AcmMaxEfPos : SimTkTypes.hpp
  • AcmSelector : SignalTypes.hpp
  • ACNotDefined : BtAvrcpCommandInterface.hpp
  • ACPause : BtAvrcpCommandInterface.hpp
  • ACPlay : BtAvrcpCommandInterface.hpp
  • ACPower : BtAvrcpCommandInterface.hpp
  • ACRecord : BtAvrcpCommandInterface.hpp
  • ACRewind : BtAvrcpCommandInterface.hpp
  • ACSoundSelect : BtAvrcpCommandInterface.hpp
  • ACStop : BtAvrcpCommandInterface.hpp
  • ACSubpicture : BtAvrcpCommandInterface.hpp
  • Action : WinInc.hpp
  • ActionInContradictionWithTheCurrentTimerState : SimTkTypes.hpp
  • ActionPropertiesChangedMsg : MsgTypes.hpp
  • ActivateCCBS : SignalTypes.hpp
  • ActiveCallDetected : Types.hpp
  • ActiveCallRequired : Types.hpp
  • ActiveClientGone : SignalTypes.hpp
  • ActiveMptyRequired : Types.hpp
  • ActiveSet : NetworkTypes.hpp
  • Adc_AlphaCoding_hpp : AlphaCoding.hpp
  • Adc_AuxProvider_hpp : AuxProvider.hpp
  • Adc_BaseDataHandler_hpp : BaseDataHandler.hpp
  • Adc_CbmiProvider_hpp : CbmiProvider.hpp
  • Adc_CbmiRangeProvider_hpp : CbmiRangeProvider.hpp
  • Adc_ChvProvider_hpp : ChvProvider.hpp
  • Adc_CmiProvider_hpp : CmiProvider.hpp
  • Adc_CompoundSmsItem_hpp : CompoundSmsItem.hpp
  • Adc_CountryProvider_hpp : CountryProvider.hpp
  • Adc_CphsAuxProvider_hpp : CphsAuxProvider.hpp
  • Adc_CphsServPflProvider_hpp : CphsServPflProvider.hpp
  • Adc_DataHandler_hpp : DataHandler.hpp
  • Adc_EccProvider_hpp : EccProvider.hpp
  • Adc_FfsFile_hpp : FfsFile.hpp
  • Adc_FfsHandler_hpp : FfsHandler.hpp
  • Adc_Lib_hpp : Lib.hpp
  • Adc_LockProvider_hpp : LockProvider.hpp
  • Adc_MbiProvider_hpp : MbiProvider.hpp
  • Adc_MsgTypes_hpp : MsgTypes.hpp
  • Adc_PbBaseProvider_hpp : PbBaseProvider.hpp
  • Adc_PlmnProvider_hpp : PlmnProvider.hpp
  • Adc_PrefExtLangProvider_hpp : PrefExtLangProvider.hpp
  • Adc_PrefLangProvider_hpp : PrefLangProvider.hpp
  • Adc_PrefPlmnProvider_hpp : PrefPlmnProvider.hpp
  • Adc_ProvIds_hpp : ProvIds.hpp
  • Adc_SimAccessor_hpp : SimAccessor.hpp
  • Adc_SimAuxHandler_hpp : SimAuxHandler.hpp
  • Adc_SimChvHandler_hpp : SimChvHandler.hpp
  • Adc_SimCphsHandler_hpp : SimCphsHandler.hpp
  • Adc_SimPbBaseHandler_hpp : SimPbBaseHandler.hpp
  • Adc_SimPbEntry_hpp : SimPbEntry.hpp
  • Adc_SimPbEntryCont_hpp : SimPbEntryCont.hpp
  • Adc_SimPduHandler_hpp : SimPduHandler.hpp
  • Adc_SimSmsParamHandler_hpp : SimSmsParamHandler.hpp
  • Adc_SimTkCommands_hpp : SimTkCommands.hpp
  • Adc_SimTkMainMenuProvider_hpp : SimTkMainMenuProvider.hpp
  • Adc_SmsArchiveProvider_hpp : SmsBaseArchiveProvider.hpp
  • Adc_SmsBaseUnreadProvider_hpp : SmsBaseUnreadProvider.hpp
  • Adc_SmsClass0Provider_hpp : SmsClass0Provider.hpp
  • Adc_SmsInboxProvider_hpp : SmsBaseInboxProvider.hpp
  • Adc_SmsInfoelements_hpp : SmsInfoElements.hpp
  • Adc_SmsOutboxProvider_hpp : SmsBaseOutboxProvider.hpp
  • Adc_SmsParamProvider_hpp : SmsParamProvider.hpp
  • Adc_SmsProvider_hpp : SmsProvider.hpp
  • Adc_SmsReadProvider_hpp : SmsReadProvider.hpp
  • Adc_SmsSentProvider_hpp : SmsSentProvider.hpp
  • Adc_SmsStatusReportProvider_hpp : SmsBaseStatusReportProvider.hpp
  • Adc_SmsUnreadProvider_hpp : SmsUnreadProvider.hpp
  • Adc_SmsUnsentProvider_hpp : SmsUnsentProvider.hpp
  • Adc_SstProvider_hpp : SstProvider.hpp
  • Adc_StatusProvider_hpp : StatusProvider.hpp
  • Adc_Types_hpp : Types.hpp
  • Adc_UsimPbAcessor_hpp : UsimPbAccessor.hpp
  • Adc_UsimPbAddData_hpp : UsimPbAddData.hpp
  • Adc_UsimPbCommit_hpp : UsimPbCommit.hpp
  • Adc_UsimPbEntry_hpp : UsimPbEntry.hpp
  • Adc_UsimPbEntryCont_hpp : UsimPbEntryCont.hpp
  • Adc_UsimPbHandler_hpp : UsimPbHandler.hpp
  • Adc_UsimPbPropertyProvider_hpp : UsimPbPropertyProvider.hpp
  • Adc_UsimPbProvider_hpp : UsimPbProvider.hpp
  • Adc_UsimPbXasProvider_hpp : UsimPbXasProvider.hpp
  • AdcTracer : Trace.hpp
  • AdcTracerLevel2 : Trace.hpp
  • AdcTracerLevel3 : Trace.hpp
  • ADDITIONAL_THEMES : apoxi.features
  • AddOn_MmCall_Types_hpp : MmTypes.hpp
  • AddOns_AuxExtensions_ObjectObtainer_hpp : ObjectObtainer.hpp
  • AddOns_Lcs_3GPP_LcsArgs_hpp : LcsArgs.hpp
  • AddOns_Lcs_3GPP_LcsMsgProcessor_hpp : LcsMsgProcessor.hpp
  • AddOns_Lcs_3GPP_LcsProviderImpl_hpp : LcsProviderImpl.hpp
  • AddOns_Lcs_3GPP_LcsSignalMapTable_hpp : LcsSignalMapTableNode.hpp
  • AddOns_Lcs_3GPP_LcsSignalProcessor_hpp : LcsSignalProcessor.hpp
  • AddOns_Lcs_3GPP_LcsStackMsgArgs_hpp : LcsStackMsgArgs.hpp
  • AddOns_Lcs_Common_LcsCommonArgs_hpp : LcsCommonArgs.hpp
  • AddOns_Lcs_Common_LcsCommonMsgProcessor_hpp : LcsCommonMsgProcessor.hpp
  • AddOns_Lcs_Common_LcsCommonMsgTypes_hpp : LcsCommonMsgTypes.hpp
  • AddOns_Lcs_Common_LcsCommonSignalMapTableNode_hpp : LcsCommonSignalMapTableNode.hpp
  • AddOns_Lcs_Common_LcsCommonSignalProcessor_hpp : LcsCommonSignalProcessor.hpp
  • AddOns_Lcs_Common_LcsCommonStackMsgArgs_hpp : LcsCommonStackMsgArgs.hpp
  • AddOns_Lcs_Common_LcsDecls_hpp : LcsDecls.hpp
  • AddOns_Lcs_Common_LcsProvider_hpp : LcsProvider.hpp
  • AddOns_Lcs_Common_LcsProviderImplBase_hpp : LcsProviderImplBase.hpp
  • AddOns_Lcs_Common_LcsRepeatTimer_hpp : LcsRepeatTimer.hpp
  • AddOns_Lcs_Common_LcsReqProcessor_hpp : LcsReqProcessor.hpp
  • AddOns_Lcs_Common_LcsTimer_hpp : LcsTimer.hpp
  • AddOns_Lcs_Common_LcsTypes_hpp : LcsTypes.hpp
  • AddOns_Lcs_Common_LcsUtils_hpp : LcsUtils.hpp
  • AddOns_Lcs_GLTP_AidDataRequests_hpp : AidDataRequests.hpp
  • AddOns_Lcs_GLTP_AssistanceData_hpp : AssistanceData.hpp
  • AddOns_Lcs_GLTP_GltpArgs_hpp : GltpArgs.hpp
  • AddOns_Lcs_GLTP_GltpMsgTypes_hpp : GltpMsgTypes.hpp
  • AddOns_Lcs_GLTP_GltpProviderImpl_hpp : GltpProviderImpl.hpp
  • AddOns_Lcs_GLTP_GltpSignalMapTable_hpp : GltpSignalMapTableNode.hpp
  • AddOns_Lcs_GLTP_GltpSignalProcessor_hpp : GltpSignalProcessor.hpp
  • AddOns_Lcs_GLTP_GltpStackMsgArgs_hpp : GltpStackMsgArgs.hpp
  • AddOns_Lcs_GLTP_GltpTypes_hpp : GltpTypes.hpp
  • AddOns_Lcs_GLTP_MsgProcessor_hpp : GltpMsgProcessor.hpp
  • AddOns_Lcs_StandAlone_SaArgs_hpp : SaArgs.hpp
  • AddOns_Lcs_StandAlone_SaMsgProcessor_hpp : SaMsgProcessor.hpp
  • AddOns_Lcs_StandAlone_SaProviderImpl_hpp : SaProviderImpl.hpp
  • AddOns_Lcs_StandAlone_SaSignalMapTable_hpp : SaSignalMapTableNode.hpp
  • AddOns_Lcs_StandAlone_SaSignalProcessor_hpp : SaSignalProcessor.hpp
  • AddOns_Lcs_StandAlone_SaStackMsgArgs_hpp : SaStackMsgArgs.hpp
  • AddOns_Lib_hpp : Lib.hpp
  • AddOns_MmCall_SerialTerminalArg_hpp : SerialTerminalArg.hpp
  • AddOns_MmCall_SerialTerminalMsgArgs_hpp : SerialTerminalMsgArgs.hpp
  • AddOns_MultiMedia_Sound_hpp : Sound.hpp
  • AddOns_Server_FtpServer_MsgTypes_hpp : MsgTypes.hpp
  • AddOns_Server_HttpServer_MsgTypes_hpp : MsgTypes.hpp
  • AddOns_StreamObexImpl_hpp : StreamObexImpl.hpp
  • AddOns_Svg_MsgTypes_hpp : MsgTypes.hpp
  • AddOns_Translation_EnumTranslationTable_hpp : EnumTranslationTable.hpp
  • AddOns_Translation_Lib_hpp : Lib.hpp
  • AddOns_Translation_ValueTextMap_hpp : ValueTextMap.hpp
  • AddOns_Usb_UsbObexAddress_hpp : UsbObexServerAddress.hpp
  • AddOns_Usb_UsbSubSystem_hpp : UsbSubSystem.hpp
  • AddOns_Usb_UsbTransport_hpp : UsbTransport.hpp
  • AddOns_VoiceRecognition_DummyVrEngineParams_hpp : DummyVrEngineParams.hpp
  • AddOns_VoiceRecognition_TelecaVrEngineParams_hpp : TelecaVrEngineParams.hpp
  • AddOns_VoiceRecognition_VrConfig_hpp : VrConfig.hpp
  • AddOns_VoiceRecognition_VrData_hpp : VrData.hpp
  • AddOns_VoiceRecognition_VrEngineParams_hpp : VrEngineParams.hpp
  • AddOns_VoiceRecognition_VrHandler_hpp : VrHandler.hpp
  • AddOns_VoiceRecognition_VrHostController_hpp : VrHostController.hpp
  • AddOns_VoiceRecognition_VrStackMsgArgs_hpp : VrStackMsgArgs.hpp
  • AddOns_VoiceRecognition_VrStackMsgArgTable_hpp : VrStackMsgArgTable.hpp
  • AddOns_VoiceRecognition_VrTypes_hpp : VrTypes.hpp
  • ADIRENT : FatSim.hpp
  • AdjustToneRpt : SignalTypes.hpp
  • ADLER_JUPITER : FfsTestBase.hpp
  • Adm : SignalTypes.hpp
  • AdministratorRootPublicKey : SimAuxHandler.hpp
  • AdnEfPos : SimTkTypes.hpp
  • AdnPhoneBook : SignalTypes.hpp
  • AdnPhoneBookCnt : SignalTypes.hpp
  • AesCryptInterface_hpp : AesCryptInterface.hpp
  • AesError : AesCryptInterface.hpp
  • AesErrorNone : AesCryptInterface.hpp
  • AesGeneralError : AesCryptInterface.hpp
  • AesInvalidBlockWindow : AesCryptInterface.hpp
  • AesNoKey : AesCryptInterface.hpp
  • Afs_AfsMsgTypes_hpp : AfsMsgTypes.hpp
  • AFSFAT : apoxi.features
  • AFSFFS : apoxi.features
  • AFSRAM : apoxi.features
  • AFSRFS : apoxi.features
  • AHIDDEN : FatSim.hpp
  • AID_DATA_FNAME : GltpProviderImpl.cpp
  • AidingAckReceived : GltpTypes.hpp
  • AirplaneMode : SignalTypes.hpp
  • AlarmToneRpt : SignalTypes.hpp
  • Alerting : SignalTypes.hpp
  • AlertingOff : SignalTypes.hpp
  • AllAlternateSpeechDataCda : SignalTypes.hpp
  • AllAlternateSpeechDataCds : SignalTypes.hpp
  • AllAsynchronousServices : SignalTypes.hpp
  • AllBearerServices : SignalTypes.hpp
  • AllCallRestrictionsSs : SignalTypes.hpp
  • AllCondForwardingSs : SignalTypes.hpp
  • AllDataCdaServices : SignalTypes.hpp
  • AllDataCdsServices : SignalTypes.hpp
  • AllDataCircuitAsynchronous : SignalTypes.hpp
  • AllDataCircuitSynchronous : SignalTypes.hpp
  • AllDataPdsServices : SignalTypes.hpp
  • AllDataTeleservices : SignalTypes.hpp
  • AllFacsimileTransmissionServices : SignalTypes.hpp
  • AllForwardingSs : SignalTypes.hpp
  • AllGPRSBearerServices : SignalTypes.hpp
  • AllPadAccessCaServices : SignalTypes.hpp
  • AllPlmnSpecificBs : SignalTypes.hpp
  • AllPlmnSpecificTs : SignalTypes.hpp
  • AllServices : SignalTypes.hpp
  • AllShortMessageServices : SignalTypes.hpp
  • AllSmsFilterType : SimPduHandler.hpp
  • AllSpeechFollByDataCda : SignalTypes.hpp
  • AllSpeechFollByDataCds : SignalTypes.hpp
  • AllSpeechTransmissionServices : SignalTypes.hpp
  • AllSsServices : SignalTypes.hpp
  • AllSynchronousServices : SignalTypes.hpp
  • AllTeleservices : SignalTypes.hpp
  • AllTeleservicesExceptSms : SignalTypes.hpp
  • AllUusServices : SignalTypes.hpp
  • AllVoiceGroupCallServices : SignalTypes.hpp
  • Alw : SignalTypes.hpp
  • AmbiguousTr() : LanguageManager.hpp, LanguageManager.cpp
  • AmplifierAudioDevice_hpp : AmplifierAudioDevice.hpp
  • AMR_FILEPLAY_FRAMENUM : HostAudioDriver.hpp
  • AMR_FILEREC_FRAMENUM : HostAudioDriver.hpp
  • AMR_SM_WORDS : HostAudioDriver.hpp
  • AmrPlayCallBack : HostAudioDriver.hpp
  • AmrRecCallBack : HostAudioDriver.hpp
  • ANORMAL : FatSim.hpp
  • AnswerToneOn : SignalTypes.hpp
  • Aocc : SignalTypes.hpp
  • AocCharging : SignalTypes.hpp
  • AocChargingStatus : SignalTypes.hpp
  • AocHandlerId : HandlerId.hpp
  • Aoci : SignalTypes.hpp
  • AocInformation : SignalTypes.hpp
  • AocRefresh : SignalTypes.hpp
  • APBVERSION : ApbVersion.hpp
  • ApbVersion_hpp : ApbVersion.hpp
  • Apc_Accessory_hpp : Accessory.hpp
  • Apc_AtcStackMsgArgs_hpp : AtcStackMsgArgs.hpp
  • Apc_AtcTypes_hpp : AtcTypes.hpp
  • Apc_AudioErrorMsg_hpp : AudioErrorMsg.hpp
  • Apc_AudioMsg_hpp : AudioMsg.hpp
  • Apc_AudioStoppedMsg_hpp : AudioStoppedMsg.hpp
  • Apc_AudioSuspendedMsg_hpp : AudioSuspendedMsg.hpp
  • Apc_AudioTypes_hpp : AudioTypes.hpp
  • Apc_AudioVoiceMemoOutOfSpaceMsg_hpp : AudioVoiceMemoOutOfSpaceMsg.hpp
  • Apc_BaseInformationElement_hpp : BaseInformationElement.hpp
  • Apc_CallMiscStackMsgArgs_hpp : CallMiscStackMsgArgs.hpp
  • Apc_Cbs_hpp : Cbs.hpp
  • Apc_CbsStackMsgArgs_hpp : CbsStackMsgArgs.hpp
  • Apc_CdStackMsgArgs_hpp : CdStackMsgArgs.hpp
  • Apc_ChvStackMsgArgs_hpp : ChvStackMsgArgs.hpp
  • Apc_CommandType_hpp : CommandType.hpp
  • Apc_Common_Conversion_hpp : Conversion.hpp
  • Apc_CommonStackMsgArgs_hpp : CommonStackMsgArgs.hpp
  • Apc_CrssStackMsgArgs_hpp : CrssStackMsgArgs.hpp
  • Apc_DataCoding_hpp : DataCoding.hpp
  • Apc_DataCodingScheme_hpp : DataCodingScheme.hpp
  • Apc_Gprs_PdpTypes_hpp : PdpTypes.hpp
  • Apc_Gprs_SimLockTypes_hpp : SimLockTypes.hpp
  • Apc_Gprs_SimMiscTypes_hpp : SimMiscTypes.hpp
  • Apc_Gsm97_MdhTypes_hpp : MdhTypes.hpp
  • Apc_ImageData_hpp : ImageData.hpp
  • Apc_ImageStackMsgArgs_hpp : ImageStackMsgArgs.hpp
  • Apc_InformationElement_hpp : InformationElement.hpp
  • Apc_KeyMsgGenerator_hpp : KeyMsgGenerator.hpp
  • Apc_Lib_hpp : Lib.hpp
  • Apc_LockTypes_hpp : LockTypes.hpp
  • Apc_MdhSmsStackMsgArgs_hpp : MdhSmsStackMsgArgs.hpp
  • Apc_MessageIdentifier_hpp : MessageIdentifier.hpp
  • Apc_MessageTypeIndicator_hpp : MessageTypeIndicator.hpp
  • Apc_MiscStackMsgArgs_hpp : MiscStackMsgArgs.hpp
  • Apc_MocStackMsgArgs_hpp : MocStackMsgArgs.hpp
  • Apc_MtcStackMsgArgs_hpp : MtcStackMsgArgs.hpp
  • Apc_NetworkStackMsgArgs_hpp : NetworkStackMsgArgs.hpp
  • Apc_NetworkTypes_hpp : NetworkTypes.hpp
  • Apc_OmStackMsgArgs_hpp : OmStackMsgArgs.hpp
  • Apc_ParameterIndicator_hpp : ParameterIndicator.hpp
  • Apc_PhoneBookStackMsgArgs_hpp : PhoneBookStackMsgArgs.hpp
  • Apc_PlmnScanList_hpp : PlmnScanList.hpp
  • Apc_PlmnStackMsgArgs_hpp : PlmnStackMsgArgs.hpp
  • Apc_PowerStackMsgArgs_hpp : PowerStackMsgArgs.hpp
  • Apc_ProtocolIdentifier_hpp : ProtocolIdentifier.hpp
  • Apc_ShortMessageFailureCause_hpp : ShortMessageFailureCause.hpp
  • Apc_ShortMessageStatus_hpp : ShortMessageStatus.hpp
  • Apc_SignalHandler_AtKeyParser_hpp : AtKeyParser.hpp
  • Apc_SignalHandler_CommonSignalMapTable_hpp : CommonSignalMapTableNode.hpp
  • Apc_SignalHandler_CommonSignalProcessor_hpp : CommonSignalProcessor.hpp
  • Apc_SignalHandler_CommonStackMsgMapTable_hpp : CommonStackMsgMapTableNode.hpp
  • Apc_SignalHandler_CommonStackMsgProcessor_hpp : CommonStackMsgProcessor.hpp
  • Apc_SignalHandler_Lib_hpp : Lib.hpp
  • Apc_SignalHandler_ProcessNode_hpp : ProcessNode.hpp
  • Apc_SignalHandler_SignalHandler_hpp : SignalHandler.hpp
  • Apc_SignalHandler_SignalMapTable_hpp : SignalMapTable.hpp
  • Apc_SignalHandler_SignalMapTableEntry_hpp : SignalMapTableEntry.hpp
  • Apc_SignalHandler_SignalMapTableNode_hpp : SignalMapTableNode.hpp
  • Apc_SignalHandler_StackMsgMapTable_hpp : StackMsgMapTable.hpp
  • Apc_SignalHandler_StackMsgMapTableEntry_hpp : StackMsgMapTableEntry.hpp
  • Apc_SignalHandler_StackMsgMapTableNode_hpp : StackMsgMapTableNode.hpp
  • Apc_SignalHandler_StackMsgProcessor_hpp : StackMsgProcessor.hpp
  • Apc_SignalHandler_StackTranslator_hpp : StackTranslator.hpp
  • Apc_SignalTypes_hpp : SignalTypes.hpp
  • Apc_SimDataTypes_hpp : SimDataTypes.hpp
  • Apc_SimMiscStackMsgArgs_hpp : SimMiscStackMsgArgs.hpp
  • Apc_SimTkStackMsgArgs_hpp : SimTkStackMsgArgs.hpp
  • Apc_SimTkTypes_hpp : SimTkTypes.hpp
  • Apc_Sms_hpp : Sms.hpp
  • Apc_SmsStackMsgArgs_hpp : SmsStackMsgArgs.hpp
  • Apc_SsErrorCode_hpp : SsErrorCode.hpp
  • Apc_SsNotification_hpp : SsNotification.hpp
  • Apc_SsStackMsgArgs_hpp : SsStackMsgArgs.hpp
  • Apc_SsStatus_hpp : SsStatus.hpp
  • Apc_StackInterface_hpp : StackInterface.hpp
  • Apc_StackMsgArgument_hpp : StackMsgArgument.hpp
  • Apc_StackWrapper_hpp : StackWrapper.hpp
  • Apc_StreamOperators_hpp : StreamOperators.hpp
  • Apc_TaggedProblemCode_hpp : TaggedProblemCode.hpp
  • Apc_Tlv_hpp : Tlv.hpp
  • Apc_Tpdu_hpp : Tpdu.hpp
  • Apc_UserData_hpp : UserData.hpp
  • Apc_UsimPbTypes_hpp : UsimPbTypes.hpp
  • Apc_ValidityPeriod_hpp : ValidityPeriod.hpp
  • ApcTracer : Trace.hpp
  • ApcTracerLevel2 : Trace.hpp
  • ApcTracerLevel3 : Trace.hpp
  • APOXI_3D_AMPLIFIER_SUPPORT : apoxi.defines
  • APOXI_3GPP_REL_4_5 : apoxi.defines
  • APOXI_3GPP_REL_99 : apoxi.defines
  • Apoxi_AbstractActionMenuAccessor_hpp : AbstractActionMenuAccessor.hpp
  • Apoxi_AbstractButton_hpp : AbstractButton.hpp
  • Apoxi_AbstractDevice_hpp : AbstractDevice.hpp
  • Apoxi_AbstractEditBox_hpp : AbstractEditBox.hpp
  • Apoxi_AbstractEditor_hpp : AbstractEditor.hpp
  • Apoxi_AbstractEditorItem_hpp : AbstractEditorItem.hpp
  • Apoxi_AbstractGrid_hpp : AbstractGrid.hpp
  • Apoxi_AbstractItemContainer_hpp : AbstractItemContainer.hpp
  • Apoxi_AbstractItemGrid_hpp : AbstractItemGrid.hpp
  • Apoxi_AbstractItemRenderer_hpp : AbstractItemRenderer.hpp
  • Apoxi_AbstractLineEditor_hpp : AbstractLineEditor.hpp
  • Apoxi_AbstractListBox_hpp : AbstractListBox.hpp
  • Apoxi_AbstractLockableDevice_hpp : AbstractLockableDevice.hpp
  • Apoxi_AbstractMenuAccessor_hpp : AbstractMenuAccessor.hpp
  • Apoxi_AbstractMenuList_hpp : AbstractMenuList.hpp
  • Apoxi_AbstractMultiLineEditor_hpp : AbstractMultiLineEditor.hpp
  • Apoxi_AbstractPredictiveInputBox_hpp : AbstractPredictiveInputBox.hpp
  • Apoxi_AbstractRenderer_hpp : AbstractRenderer.hpp
  • Apoxi_AbstractScheduler_hpp : AbstractScheduler.hpp
  • Apoxi_AbstractTextObject_hpp : AbstractTextObject.hpp
  • Apoxi_AbstractTextRenderer_hpp : AbstractTextRenderer.hpp
  • Apoxi_AbstractToggleAction_hpp : AbstractToggleAction.hpp
  • Apoxi_AbstractTransport_hpp : AbstractTransport.hpp
  • Apoxi_AcacLanguage_hpp : AcacLanguage.hpp
  • Apoxi_AcacTypes_hpp : AcacTypes.hpp
  • Apoxi_AccessorAction_hpp : AccessorAction.hpp
  • Apoxi_AccessorActionExtension_hpp : AccessorActionExtension.hpp
  • Apoxi_Action_hpp : Action.hpp
  • Apoxi_ActionExtension_hpp : ActionExtension.hpp
  • Apoxi_ActionMenuAccessor_hpp : ActionMenuAccessor.hpp
  • Apoxi_ActiveWaitDispatcher_hpp : ActiveWaitDispatcher.hpp
  • APOXI_ADC_CCP_CODE : apoxi.defines
  • APOXI_ADC_SIMTK_PROACTIVE_CODE : apoxi.defines
  • Apoxi_AdcExtensions_DataRecord_hpp : DataRecord.hpp
  • Apoxi_AdcExtensions_DataRecordHandler_hpp : DataRecordHandler.hpp
  • Apoxi_AdcExtensions_DcsLanguageFilterRule_hpp : DcsLanguageFilterRule.hpp
  • Apoxi_AdcExtensions_LanguageCodeRes_hpp : LanguageCodeRes.hpp
  • Apoxi_AdcExtensions_LanguageProvider_hpp : LanguageProvider.hpp
  • Apoxi_AdcExtensions_NvRam_hpp : NvRam.hpp
  • Apoxi_AdcExtensions_NvRamDataRecordHandler_hpp : NvRamDataRecordHandler.hpp
  • Apoxi_AdcExtensions_NvRamStorage_hpp : NvRamStorage.hpp
  • Apoxi_AdcExtensions_ProviderIds_hpp : ProviderIds.hpp
  • Apoxi_AdcExtensions_Record_hpp : Record.hpp
  • Apoxi_AdcExtensions_RecordHandler_hpp : RecordHandler.hpp
  • APOXI_ADD_MIME_TYPE_DEFS : MimeTypeTable.cpp, MimeTypeTableUtils.hpp
  • APOXI_ADDITIONAL_THEMES_SUPPORT : apoxi.defines
  • Apoxi_AddOns_MmCallHdl_hpp : MmCallHdl.hpp
  • Apoxi_AddOns_Server_AuthProvider_hpp : AuthProvider.hpp
  • Apoxi_AddOns_Server_FtpAuthProvider_hpp : FtpAuthProvider.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpClient_hpp : FtpClient.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpDataServerSocket_hpp : FtpDataServerSocket.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpDataSocket_hpp : FtpDataSocket.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpInTransfer_hpp : FtpInTransfer.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpOutTransfer_hpp : FtpOutTransfer.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpRequest_hpp : FtpRequest.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpServer_hpp : FtpServer.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpServerSocket_hpp : FtpServerSocket.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpSocket_hpp : FtpSocket.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpTransfer_hpp : FtpTransfer.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpTypes_hpp : FtpTypes.hpp
  • Apoxi_AddOns_Server_FtpServerConfig_hpp : FtpServerConfig.hpp
  • Apoxi_AddOns_Server_HttpAuthProvider_hpp : HttpAuthProvider.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpApplication_hpp : HttpApplication.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpApplicationSupplier_hpp : HttpApplicationSupplier.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpClient_hpp : HttpClient.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpRequest_hpp : HttpRequest.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpResponse_hpp : HttpResponse.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpServer_hpp : HttpServer.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpServerSocket_hpp : HttpServerSocket.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpSocket_hpp : HttpSocket.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpTypes_hpp : HttpTypes.hpp
  • Apoxi_AddOns_Server_HttpServerConfig_hpp : HttpServerConfig.hpp
  • Apoxi_AddOns_Server_Server_hpp : Server.hpp
  • Apoxi_AddOns_Server_ServerClient_hpp : ServerClient.hpp
  • Apoxi_AddOns_Server_ServerConfig_hpp : ServerConfig.hpp
  • Apoxi_AlarmManager_hpp : AlarmManager.hpp
  • APOXI_ALARMMANAGER_MAX_ENTRIES : AlarmManager.hpp, apoxi.defines
  • Apoxi_Alert_hpp : Alert.hpp
  • Apoxi_Allocator_hpp : Allocator.hpp
  • Apoxi_AnimatedTextLine_hpp : AnimatedTextLine.hpp
  • Apoxi_Animation_hpp : Animation.hpp
  • APOXI_APN_NAME_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • Apoxi_ApoxiThread_hpp : ApoxiThread.hpp
  • Apoxi_AppContainer_hpp : AppContainer.hpp
  • Apoxi_AppContainerRoutingTable_hpp : AppContainerRoutingTable.hpp
  • Apoxi_Application_hpp : Application.hpp
  • APOXI_APPLICATION_TRACER_MAX_APPS : ApplicationTracer.hpp, apoxi.defines
  • Apoxi_ApplicationAction_hpp : ApplicationAction.hpp
  • Apoxi_AppMutex_hpp : AppMutex.hpp
  • Apoxi_AppRoutingTable_hpp : AppRoutingTable.hpp
  • Apoxi_ArabicTextRenderer_hpp : ArabicTextRenderer.hpp
  • APOXI_ARAGON_MAX_BUFFER_SIZE : apoxi.defines
  • APOXI_ARAGON_SUPPORT : apoxi.defines
  • Apoxi_AragonServer_hpp : AragonServer.hpp
  • APOXI_AT_KEY_PARSER_TEST : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_CALL : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_REJECT : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_SIMTK : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_SS : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_USSD : apoxi.defines
  • Apoxi_AtBaseManager_hpp : AtBaseManager.hpp
  • Apoxi_AtCommand_hpp : AtCommand.hpp
  • Apoxi_AtiAudioPlayerRtStreamingConn_hpp : AtiAudioPlayerRtStreamingConn.hpp
  • Apoxi_AtiAudioPlayerRtStreamingSink_hpp : AtiAudioPlayerRtStreamingSink.hpp
  • APOXI_ATL_SUPPORT : apoxi.defines
  • Apoxi_AtlItemBox_hpp : AtlItemBox.hpp
  • Apoxi_AtManager_hpp : AtManager.hpp
  • Apoxi_AtomItem_hpp : AtomItem.hpp
  • Apoxi_AtResponse_hpp : AtResponse.hpp
  • Apoxi_AtResponseIterator_hpp : AtResponseIterator.hpp
  • Apoxi_Audio_AudioDeviceStatusMsg_hpp : AudioDeviceStatusMsg.hpp
  • Apoxi_Audio_AudioErrorMsg_hpp : AudioErrorMsg.hpp
  • Apoxi_Audio_AudioGetPlayPositionMsg_hpp : AudioGetPlayPositionMsg.hpp
  • Apoxi_Audio_AudioMessages_hpp : AudioMessages.hpp
  • Apoxi_Audio_AudioMsg_hpp : AudioMsg.hpp
  • Apoxi_Audio_AudioRadioDeviceNotificationMsg_hpp : AudioRadioDeviceNotificationMsg.hpp
  • Apoxi_Audio_AudioRestartedMsg_hpp : AudioRestartedMsg.hpp
  • Apoxi_Audio_AudioResumedMsg_hpp : AudioResumedMsg.hpp
  • Apoxi_Audio_AudioStartedMsg_hpp : AudioStartedMsg.hpp
  • Apoxi_Audio_AudioStoppedMsg_hpp : AudioStoppedMsg.hpp
  • Apoxi_Audio_AudioStreamingSyncMsg_hpp : AudioStreamingSyncMsg.hpp
  • Apoxi_Audio_AudioSuspendedMsg_hpp : AudioSuspendedMsg.hpp
  • Apoxi_Audio_AudioVoiceMemoOutOfSpaceMsg_hpp : AudioVoiceMemoOutOfSpaceMsg.hpp
  • Apoxi_Audio_hpp : Audio.hpp
  • Apoxi_AudioAccessoryStore_hpp : AudioAccessoryStore.hpp
  • Apoxi_AudioActiveReference_hpp : AudioActiveReference.hpp
  • Apoxi_AudioCapturerEncoder_hpp : AudioCapturerEncoder.hpp
  • Apoxi_AudioDecoder_hpp : AudioDecoder.hpp
  • Apoxi_AudioDecoderRenderer_hpp : AudioDecoderRenderer.hpp
  • Apoxi_AudioDeviceBase_hpp : AudioDeviceBase.hpp
  • Apoxi_AudioDeviceManager_hpp : AudioDeviceManager.hpp
  • Apoxi_AudioEncoder_hpp : AudioEncoder.hpp
  • Apoxi_AudioItem_hpp : AudioItem.hpp
  • Apoxi_AudioMapiManager_hpp : AudioMapiManager.hpp
  • Apoxi_AudioNewAPI_AtiAudioPlayer_hpp : AtiAudioPlayer.hpp
  • Apoxi_AudioNewAPI_AudioAccessoryDetails_hpp : AudioAccessoryDetails.hpp
  • Apoxi_AudioNewAPI_AudioError_hpp : AudioError.hpp
  • Apoxi_AudioNewAPI_AudioPath_hpp : AudioPath.hpp
  • Apoxi_AudioNewAPI_AudioPathManager_hpp : AudioPathManager.hpp
  • Apoxi_AudioNewAPI_AudioPreset_hpp : AudioPreset.hpp
  • Apoxi_AudioNewAPI_AudioPresetStore_hpp : AudioPresetStore.hpp
  • Apoxi_AudioNewAPI_AudioSuspendedDetails_hpp : AudioSuspendedDetails.hpp
  • Apoxi_AudioNewAPI_AudioUtility_hpp : AudioUtility.hpp
  • Apoxi_AudioNewAPI_AudioVibratorDevice_hpp : AudioVibratorDevice.hpp
  • Apoxi_AudioNewAPI_CombinedDeviceAudioReference_hpp : CombinedDeviceAudioReference.hpp
  • Apoxi_AudioNewAPI_CustomIMelodyAudioReference_hpp : CustomIMelodyAudioReference.hpp
  • Apoxi_AudioNewAPI_CustomRingerAudioReference_hpp : CustomRingerAudioReference.hpp
  • Apoxi_AudioNewAPI_CustomSmafPhraseAudioReference_hpp : CustomSmafPhraseAudioReference.hpp
  • Apoxi_AudioNewAPI_CustomToneAudioReference_hpp : CustomToneAudioReference.hpp
  • Apoxi_AudioNewAPI_MP3AudioPlayer_hpp : Mp3AudioPlayer.hpp
  • Apoxi_AudioNewAPI_MP3AudioReference_hpp : Mp3AudioReference.hpp
  • Apoxi_AudioNewAPI_PCMAudioPlayer_hpp : PcmAudioPlayer.hpp
  • Apoxi_AudioNewAPI_PCMAudioReference_hpp : PcmAudioReference.hpp
  • Apoxi_AudioNewAPI_PresetAudioReference_hpp : PresetAudioReference.hpp
  • Apoxi_AudioNewAPI_RadioAudioDevice_hpp : RadioAudioDevice.hpp
  • Apoxi_AudioNewAPI_RingerAudioInternalMIDIPlayer_hpp : RingerAudioInternalMidiPlayer.hpp
  • Apoxi_AudioNewAPI_RingerAudioReference_hpp : RingerAudioReference.hpp
  • Apoxi_AudioNewAPI_SimpleAudioDevice_hpp : SimpleAudioDevice.hpp
  • Apoxi_AudioNewAPI_SimpleAudioReference_hpp : SimpleAudioReference.hpp
  • Apoxi_AudioNewAPI_SpeechSimpleAudioDevice_hpp : SpeechSimpleAudioDevice.hpp
  • Apoxi_AudioNewAPI_StreamAudioPlayer_hpp : StreamAudioPlayer.hpp
  • Apoxi_AudioNewAPI_StreamAudioReference_hpp : StreamAudioReference.hpp
  • Apoxi_AudioNewAPI_ToneAudioPlayer_hpp : ToneAudioPlayer.hpp
  • Apoxi_AudioNewAPI_ToneAudioReference_hpp : ToneAudioReference.hpp
  • Apoxi_AudioNewAPI_VoiceMemoAudioPlayer_hpp : VoiceMemoAudioPlayer.hpp
  • Apoxi_AudioNewAPI_VoiceMemoAudioReference_hpp : VoiceMemoAudioReference.hpp
  • Apoxi_AudioPlayer_hpp : AudioPlayer.hpp
  • Apoxi_AudioPlayerEvent_hpp : AudioPlayerEvent.hpp
  • Apoxi_AudioPlayerStore_hpp : AudioPlayerStore.hpp
  • Apoxi_AudioPriorityManager_hpp : AudioPriorityManager.hpp
  • Apoxi_AudioPrivate_hpp : audio_private.hpp
  • Apoxi_AudioReference_hpp : AudioReference.hpp
  • APOXI_AUX_CHINESEQUICKSORT_DEBUG : apoxi.defines
  • APOXI_AUX_QUICKSORT_DEBUG : apoxi.defines
  • Apoxi_AuxExtensions_AppendProvider_hpp : AppendProvider.hpp
  • Apoxi_AuxExtensions_JoinJoinRule_hpp : JoinRule.hpp
  • Apoxi_AuxExtensions_JoinProvider_hpp : JoinProvider.hpp
  • Apoxi_AuxExtensions_MergeProvider_hpp : MergeProvider.hpp
  • Apoxi_AuxExtensions_PhoneNumberMergeProvider_hpp : PhoneNumberMergeProvider.hpp
  • Apoxi_AuxExtensions_ProviderIds_hpp : ProviderIds.hpp
  • Apoxi_BackLight_hpp : BackLight.hpp
  • Apoxi_BackupFileHandler_hpp : BackupFileHandler.hpp
  • Apoxi_BasicPackConnector_hpp : BasicPackConnector.hpp
  • APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • APOXI_BEARER_PROFILE_NAME_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • APOXI_BEARER_PROFILE_PASSWD_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • Apoxi_BidiManager_hpp : BidiManager.hpp
  • APOXI_BIG_ENDIAN : apoxi.defines
  • Apoxi_BinarySearch_hpp : BinarySearch.hpp
  • Apoxi_Bitmap_hpp : Bitmap.hpp
  • Apoxi_BitmapDc_hpp : BitmapDc.hpp
  • Apoxi_BitVector_hpp : BitVector.hpp
  • Apoxi_BlackAndWhiteTheme_hpp : BlackAndWhiteTheme.hpp
  • Apoxi_BlueSkyCheckBoxListView_hpp : BlueSkyCheckBoxListView.hpp
  • Apoxi_BlueSkyCheckBoxView_hpp : BlueSkyCheckBoxView.hpp
  • Apoxi_BlueSkyChineseTheme_hpp : BlueSkyChineseTheme.hpp
  • Apoxi_BlueSkyControlFrameView_hpp : BlueSkyControlFrameView.hpp
  • Apoxi_BlueSkyPositionIndicatorView_hpp : BlueSkyPositionIndicatorView.hpp
  • Apoxi_BlueSkyProgressBarView_hpp : BlueSkyProgressBarView.hpp
  • Apoxi_BlueSkyPushButtonView_hpp : BlueSkyPushButtonView.hpp
  • Apoxi_BlueSkyRadioButtonListView_hpp : BlueSkyRadioButtonListView.hpp
  • Apoxi_BlueSkyRadioButtonView_hpp : BlueSkyRadioButtonView.hpp
  • Apoxi_BlueSkySoftkeyBarView_hpp : BlueSkySoftkeyBarView.hpp
  • Apoxi_BlueSkyTextListView_hpp : BlueSkyTextListView.hpp
  • Apoxi_BlueSkyTheme_hpp : BlueSkyTheme.hpp
  • Apoxi_BlueSkyWindowFrameView_hpp : BlueSkyWindowFrameView.hpp
  • APOXI_BLUETOOTH : apoxi.defines
  • Apoxi_BmpDecoder_hpp : BmpDecoder.hpp
  • Apoxi_BmpImage_hpp : BmpImage.hpp
  • Apoxi_BoundedItem_hpp : BoundedItem.hpp
  • Apoxi_BrowserView_hpp : BrowserView.hpp
  • Apoxi_BrowserViewContainer_hpp : BrowserViewContainer.hpp
  • Apoxi_Brush_hpp : Brush.hpp
  • APOXI_BT_A2DP_SUPPORT : apoxi.defines
  • APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY : BtObexServiceTable.hpp, apoxi.defines
  • APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY : BtObexServiceTable.hpp, apoxi.defines
  • Apoxi_BtObexClientAddrResultNotifier_hpp : BtObexClientAddrResultNotifier.hpp
  • Apoxi_BtObexClientObserverImpl_hpp : BtObexClientObserverImpl.hpp
  • Apoxi_BtObexClientServiceImpl_hpp : BtObexClientServiceImpl.hpp
  • Apoxi_BtObexImpl_hpp : BtObexImpl.hpp
  • Apoxi_BtObexImplAddress_hpp : BtObexImplAddress.hpp
  • Apoxi_BtObexResponseCode_hpp : BtObexResponseCode.hpp
  • Apoxi_BtObexSddbImpl_hpp : BtObexSddbImpl.hpp
  • Apoxi_BtObexServerObserverImpl_hpp : BtObexServerObserverImpl.hpp
  • Apoxi_BtObexServerServiceImpl_hpp : BtObexServerServiceImpl.hpp
  • Apoxi_BtObexServiceTable_hpp : BtObexServiceTable.hpp
  • Apoxi_BtSddbServiceObserverImpl_hpp : BtObexSddbServiceObserverImpl.hpp
  • Apoxi_BufferedOutputStream_hpp : BufferedOutputStream.hpp
  • Apoxi_BufferPoolManager_hpp : BufferPoolManager.hpp
  • APOXI_BYTEBUFFER_TEST_SUITE : ByteBuffer.hpp, apoxi.defines
  • APOXI_CACHED_POLYGON_EDGES_MAX : DeviceContext.cpp, apoxi.defines
  • Apoxi_CalculatorInputMapper_hpp : CalculatorInputMapper.hpp
  • Apoxi_CalendarGrid_hpp : CalendarGrid.hpp
  • Apoxi_CallInfoParser_hpp : XCallInfoResponseParser.hpp
  • Apoxi_Camera_hpp : Camera.hpp
  • APOXI_CAMERA_MPE_COMPAT : apoxi.defines
  • APOXI_CAMERA_SUPPORT : apoxi.defines
  • APOXI_CAMERA_TWINVIEWFINDER_SUPPORT : Camera.hpp, apoxi.defines
  • APOXI_CAMERA_WIN32 : apoxi.defines
  • Apoxi_CancelAction_hpp : CancelAction.hpp
  • Apoxi_Caret_hpp : Caret.hpp
  • APOXI_CBS_DEFAULT_ACTIVE_TIMER : apoxi.defines
  • APOXI_CBS_DEFAULT_SLEEP_TIMER : apoxi.defines
  • APOXI_CBS_LIMITATION_MSG : apoxi.defines
  • Apoxi_CharItem_hpp : CharItem.hpp
  • Apoxi_CheckBox_hpp : CheckBox.hpp
  • Apoxi_CheckBoxAction_hpp : CheckBoxAction.hpp
  • Apoxi_CheckBoxControl_hpp : CheckBoxControl.hpp
  • Apoxi_CheckBoxItem_hpp : CheckBoxItem.hpp
  • Apoxi_CheckBoxList_hpp : CheckBoxList.hpp
  • Apoxi_ChineseT9InputMapper_hpp : ChineseT9InputMapper.hpp
  • APOXI_CINGULAR_INPUT_TEST : apoxi.defines
  • Apoxi_ClientDc_hpp : ClientDc.hpp
  • Apoxi_CloseWindowAction_hpp : CloseWindowAction.hpp
  • Apoxi_CodecDevice_hpp : CodecDevice.hpp
  • Apoxi_CodecManager_hpp : CodecManager.hpp
  • Apoxi_Color_hpp : Color.hpp
  • APOXI_COLOR_VALUE_BITCOUNT : Color.cpp
  • Apoxi_ColorSegmentation_hpp : ColorSegmentation.hpp
  • Apoxi_ColorTable_hpp : ColorTable.hpp
  • APOXI_COMPAT_1_11_0 : apoxi.defines
  • APOXI_COMPAT_1_12_0 : apoxi.defines
  • APOXI_COMPAT_1_13_0 : apoxi.defines
  • APOXI_COMPAT_1_7_0 : apoxi.defines
  • APOXI_COMPAT_1_8_0 : apoxi.defines
  • APOXI_COMPAT_1_9_0 : apoxi.defines
  • APOXI_COMPAT_2_0_0 : apoxi.defines
  • APOXI_COMPAT_2_1_0 : apoxi.defines
  • APOXI_COMPAT_2_2_0 : apoxi.defines
  • APOXI_COMPAT_2_3_0 : apoxi.defines
  • APOXI_COMPAT_2_4_0 : apoxi.defines
  • APOXI_COMPAT_2_6_0 : apoxi.defines
  • APOXI_COMPAT_2_7_0 : apoxi.defines
  • APOXI_COMPAT_2_8_0 : apoxi.defines
  • APOXI_COMPAT_2_9_0 : apoxi.defines
  • APOXI_COMPILER_ADS : apoxi.defines
  • APOXI_COMPILER_C166 : apoxi.defines
  • APOXI_COMPILER_MSVC : apoxi.defines
  • APOXI_COMPILER_RVCT : apoxi.defines
  • Apoxi_Component_hpp : Component.hpp
  • Apoxi_CompoundItem_hpp : CompoundItem.hpp
  • Apoxi_CompoundItemReferrer_hpp : CompoundItemReferrer.hpp
  • Apoxi_Condition_hpp : Condition.hpp
  • APOXI_CONFIG_DBG_OUT_RANGE_ARRAY : OsClass.hpp, apoxi.defines
  • APOXI_CONFIG_MAX_MM_CALLS : MmCallHandler.hpp
  • Apoxi_ConfirmAction_hpp : ConfirmAction.hpp
  • Apoxi_ContextMenu_hpp : ContextMenu.hpp
  • Apoxi_Control_hpp : Control.hpp
  • Apoxi_ControlDc_hpp : ControlDc.hpp
  • Apoxi_ControlFrameView_hpp : ControlFrameView.hpp
  • APOXI_COUNTOF : MimeTypeTableUtils.hpp
  • Apoxi_CountryCodes_hpp : CountryCodes.hpp
  • APOXI_CRASH_DEBUG : apoxi.defines
  • Apoxi_CsdDataConn_hpp : CsdDataConn.hpp
  • Apoxi_CsdDataConnProfile_hpp : CsdDataConnProfile.hpp
  • Apoxi_CTControlFrameView_hpp : CTControlFrameView.hpp
  • APOXI_CTM : apoxi.defines
  • Apoxi_CTPanelView_hpp : CTPanelView.hpp
  • Apoxi_CTPositionIndicatorView_hpp : CTPositionIndicatorView.hpp
  • Apoxi_CTProgressBarView_hpp : CTProgressBarView.hpp
  • Apoxi_CTPushButtonView_hpp : CTPushButtonView.hpp
  • Apoxi_CTResourcePack_hpp : CTResourcePack.hpp
  • Apoxi_CTResourceParser_hpp : CTResourceParser.hpp
  • Apoxi_CTTheme_hpp : CustomizableTheme.hpp
  • Apoxi_CTWindowFrameView_hpp : CTWindowFrameView.hpp
  • APOXI_DATA_CONN_PROFILE_COUNT : SocketTypes.hpp, apoxi.defines
  • APOXI_DATA_CONN_PROFILE_FFS_FILE_ID : MyDataConnProfileStorage.hpp
  • APOXI_DATA_CONN_PROFILE_FFS_USER_TYPE : MyDataConnProfileStorage.hpp
  • APOXI_DATA_CONN_TEMP_PROFILE_COUNT : SocketTypes.hpp, apoxi.defines
  • Apoxi_DataConn_hpp : DataConn.hpp
  • Apoxi_DataConnManager_hpp : DataConnManager.hpp
  • Apoxi_DataConnOptionWin_hpp : DataConnOptionWin.hpp
  • Apoxi_DataConnProfile_hpp : DataConnProfile.hpp
  • Apoxi_DataConnProfileManager_hpp : DataConnProfileManager.hpp
  • Apoxi_DataConnProfileStorage_hpp : DataConnProfileStorage.hpp
  • Apoxi_DataConnTypeWin_hpp : DataConnTypeWin.hpp
  • Apoxi_DataConnWin_hpp : DataConnWin.hpp
  • Apoxi_DataPack_hpp : DataPack.hpp
  • Apoxi_DataSourceRtStreamingSource_hpp : DataSourceRtStreamingSource.hpp
  • Apoxi_Date_h : Date.hpp
  • Apoxi_DateCompoundItem_hpp : DateCompoundItem.hpp
  • Apoxi_DateEditBox_hpp : DateEditBox.hpp
  • Apoxi_DateEditor_hpp : DateEditor.hpp
  • Apoxi_DateEditorDocument_hpp : DateEditorDocument.hpp
  • Apoxi_DateTime_h : DateTime.hpp
  • Apoxi_DateTimeInputMapper_hpp : DateTimeInputMapper.hpp
  • Apoxi_DBService_hpp : DBService.hpp
  • APOXI_DCL_MIME_TYPE_DEFS : MimeTypeTableUtils.hpp
  • APOXI_DEBUG_IMAGE_DECODING : apoxi.defines
  • Apoxi_DebugOutputStream_hpp : DebugOutputStream.hpp
  • Apoxi_DecodingThreadlet_hpp : DecodingThreadlet.hpp
  • APOXI_DEF_MIME_TYPE : MimeTypeTableUtils.hpp
  • Apoxi_DefaultCaret_hpp : DefaultCaret.hpp
  • Apoxi_DefaultCheckBoxListView_hpp : DefaultCheckBoxListView.hpp
  • Apoxi_DefaultCheckBoxView_hpp : DefaultCheckBoxView.hpp
  • Apoxi_DefaultChineseTheme_hpp : DefaultChineseTheme.hpp
  • Apoxi_DefaultControlFrameView_hpp : DefaultControlFrameView.hpp
  • Apoxi_DefaultDisplay_hpp : DefaultDisplay.hpp
  • Apoxi_DefaultItemRenderer_hpp : DefaultItemRenderer.hpp
  • Apoxi_DefaultPanelView_hpp : DefaultPanelView.hpp
  • Apoxi_DefaultPositionIndicatorView_hpp : DefaultPositionIndicatorView.hpp
  • Apoxi_DefaultProgressBarView_hpp : DefaultProgressBarView.hpp
  • Apoxi_DefaultPushButtonView_hpp : DefaultPushButtonView.hpp
  • Apoxi_DefaultRadioButtonListView_hpp : DefaultRadioButtonListView.hpp
  • Apoxi_DefaultRadioButtonView_hpp : DefaultRadioButtonView.hpp
  • Apoxi_DefaultSoftkeyBarView_hpp : DefaultSoftkeyBarView.hpp
  • Apoxi_DefaultTabButtonView_hpp : DefaultTabButtonView.hpp
  • Apoxi_DefaultTabControlView_hpp : DefaultTabControlView.hpp
  • Apoxi_DefaultTextListView_hpp : DefaultTextListView.hpp
  • Apoxi_DefaultTheme_hpp : DefaultTheme.hpp
  • Apoxi_DefaultWindowFrameView_hpp : DefaultWindowFrameView.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationRejectedByGgsn : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_11 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_5 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_7 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_9 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_Invalid : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_NotAssigned : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_2 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_4 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_Undefined : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateAccepted : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateFiveTimeT3380Expiry : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateRejected : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUnknownCause : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUserInteruption : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Address_c_max_len : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_account_len : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_password_len : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Chap : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_None : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Pap : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_AuthenticationFailure : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_c_max_access_point_name_len : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ConditionalIeError : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_GprsServiceNotAllowed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IeNonExistent : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMe : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMs : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InsufficientRessources : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidMandatoryIe : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidTi : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpDynamicType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpStaticType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LaNotAllowed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LlcOrSndcpFailure : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ManufProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MissingOrUnknownApn : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MobileStation : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgNotCompatible : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotCompatible : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotExistent : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NationalRoamingNotAllowed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Network : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NetworkFailure : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoError : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NsapiAlreadyUsed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NullProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_OspihType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_2 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_Unknown : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PadProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PlmnNotAllowed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QosNotAccepted : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayBestEffort : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass2 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelaySubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateBestEffort : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateSubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate128K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate16K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate1K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate256K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate2K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate32K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate4K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate64K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate8K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateSubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceHigh : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceLow : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceNormal : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceSubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass2 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass4 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass5 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass6 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilitySubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ReactivationRequired : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RegularDeactivation : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RequestedServiceOptionNotSubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_SemanticIncorrectMsg : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionNotSupported : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionTemporaryOutOfOrder : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UndefinedError : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownOrigin : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownPdpAddress : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedActivationRejection : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedProtocolError : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Protocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Type : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateAccepted : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateFiveTimeT3310Expiry : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateRejected : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUnknownCause : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUserInteruption : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_c_max_cid_array_len : ValueMap.hpp
  • Apoxi_DeletedNode_hpp : DeletedNode.hpp
  • Apoxi_Desktop_hpp : Desktop.hpp
  • Apoxi_Device_hpp : Device.hpp
  • Apoxi_DeviceContext_hpp : DeviceContext.hpp
  • Apoxi_Devices_AudioMsgProcessor_hpp : AudioMsgProcessor.hpp
  • Apoxi_Devices_AudioPlayTimeMsg_hpp : AudioPlayTimeMsg.hpp
  • Apoxi_Devices_Bp30_Charger_hpp : Charger.hpp
  • Apoxi_Devices_BP30_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Bp30_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Bp30_Led_hpp : Led.hpp
  • Apoxi_Devices_Bp30_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_BP30_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_Devices_Camera_hpp : Camera.hpp
  • Apoxi_Devices_Charger_hpp : Charger.hpp
  • Apoxi_Devices_ChargerSignalMapTableNode_hpp : ChargerSignalMapTableNode.hpp
  • Apoxi_Devices_ChargerSignalProcessor_hpp : ChargerSignalProcessor.hpp
  • Apoxi_Devices_DeviceManager_hpp : DeviceManager.hpp
  • Apoxi_Devices_Display_hpp : Display.hpp
  • Apoxi_Devices_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Led_hpp : Led.hpp
  • Apoxi_Devices_LedSignalMapTableNode_hpp : LedSignalMapTableNode.hpp
  • Apoxi_Devices_LedSignalProcessor_hpp : LedSignalProcessor.hpp
  • Apoxi_Devices_Mpe_Charger_hpp : Charger.hpp
  • Apoxi_Devices_MPE_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Mpe_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Mpe_Led_hpp : Led.hpp
  • Apoxi_Devices_Mpe_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_MPE_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_Devices_MPEU_BackLight_hpp : BackLight.hpp
  • Apoxi_Devices_Mpeu_Charger_hpp : Charger.hpp
  • Apoxi_Devices_MPEU_DefaultDisplay_hpp : DefaultDisplay.hpp
  • Apoxi_Devices_MPEU_Extensions_AtiW2282_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_Devices_MPEU_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Mpeu_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Mpeu_Led_hpp : Led.hpp
  • Apoxi_Devices_Mpeu_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_MPEU_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_Devices_MPEU_VirtualDisplay_hpp : VirtualDisplay.hpp
  • Apoxi_Devices_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_RtcSignalMapTableNode_hpp : RtcSignalMapTableNode.hpp
  • Apoxi_Devices_RtcSignalProcessor_hpp : RtcSignalProcessor.hpp
  • Apoxi_Devices_SGold_Charger_hpp : Charger.hpp
  • Apoxi_Devices_SGold_Fota_hpp : Fota.hpp
  • Apoxi_Devices_SGold_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_SGold_Led_hpp : Led.hpp
  • Apoxi_Devices_SGold_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_StillCamera_hpp : StillCamera.hpp
  • Apoxi_Devices_TransportNotificationMsg_hpp : TransportNotificationMsg.hpp
  • Apoxi_Devices_VideoCamera_hpp : VideoCamera.hpp
  • Apoxi_Devices_VirtualDisplay_hpp : VirtualDisplay.hpp
  • Apoxi_Devices_Win32_Camera_hpp : Camera.hpp
  • Apoxi_Devices_Win32_Charger_hpp : Charger.hpp
  • Apoxi_Devices_Win32_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Win32_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Win32_Led_hpp : Led.hpp
  • Apoxi_Devices_Win32_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_DialogWindow_hpp : DialogWindow.hpp
  • Apoxi_DirectoryIterator_hpp : DirectoryIterator.hpp
  • Apoxi_DirtyFileHandler_hpp : DirtyFileHandler.hpp
  • APOXI_DISABLE_CPP_CASTS : apoxi.defines
  • APOXI_DISABLE_ENLARGED_GRID_SELECTION : apoxi.defines
  • APOXI_DISABLE_FILTERED_SMS_PROVIDERS : apoxi.defines
  • APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING : apoxi.defines
  • APOXI_DISABLE_SOFTKEYBAR : apoxi.defines
  • APOXI_DISABLE_TAB_CONTROL : apoxi.defines
  • Apoxi_Dispatcher_hpp : Dispatcher.hpp
  • Apoxi_DispatcherAction_hpp : DispatcherAction.hpp
  • APOXI_DISPLAY_16BPP : apoxi.defines
  • APOXI_DISPLAY_24BPP : apoxi.defines
  • APOXI_DISPLAY_32BPP : apoxi.defines
  • APOXI_DISPLAY_8BPP : apoxi.defines
  • APOXI_DISPLAY_FORMAT_BIG_ENDIAN : apoxi.defines
  • APOXI_DISPLAY_PLANES : apoxi.defines
  • Apoxi_DisplayConfig_hpp : DisplayConfig.hpp
  • Apoxi_DisplayDc_hpp : DisplayDc.hpp
  • Apoxi_DisplaySettings_hpp : DisplaySettings.hpp
  • Apoxi_DnsClient_hpp : DnsClient.hpp
  • Apoxi_DnsClientTest_hpp : DnsClientTest.hpp
  • APOXI_DR_SMSR_SCA_BUG_NOT_FIXED : apoxi.defines
  • Apoxi_DrawableObject_hpp : DrawableObject.hpp
  • Apoxi_Drm_Asset_hpp : DrmAsset.hpp
  • Apoxi_Drm_hpp : Drm.hpp
  • Apoxi_Drm_Message_hpp : DrmMessage.hpp
  • Apoxi_DrmDcfParser_hpp : DrmDcfParser.hpp
  • Apoxi_DrmInfo_hpp : DrmInfo.hpp
  • Apoxi_DrmRelParser_hpp : DrmRelparser.hpp
  • Apoxi_DrmRelWbxml_hpp : DrmRelWbxml.hpp
  • Apoxi_DrmRights_hpp : DrmRights.hpp
  • Apoxi_DrmRightsStore_hpp : DrmRightsStore.hpp
  • Apoxi_DrmSecurity_hpp : DrmSecurity.hpp
  • Apoxi_DrmSubsystem_hpp : DrmSubsystem.hpp
  • Apoxi_DrmUtils_hpp : DrmUtils.hpp
  • Apoxi_DrmXmlRelParser_hpp : DrmRelXml.hpp
  • APOXI_DUAL_DISPLAY_SUPPORT : apoxi.defines
  • Apoxi_DwdDevice_hpp : DwdDevice.hpp
  • Apoxi_DwdPlayer_hpp : DwdPlayer.hpp
  • Apoxi_DynamicBitVector_hpp : DynamicBitVector.hpp
  • Apoxi_EditBox_hpp : EditBox.hpp
  • Apoxi_EditConfig_hpp : EditConfig.hpp
  • Apoxi_EditorDocument_hpp : EditorDocument.hpp
  • Apoxi_EditorLine_hpp : EditorLine.hpp
  • APOXI_EM_CONTROL_ENABLED : apoxi.defines
  • Apoxi_EmzAacDecoder_hpp : EmzAacDecoder.hpp
  • Apoxi_EmzMp3Decoder_hpp : EmzMp3Decoder.hpp
  • Apoxi_EmzSbcEncoder_hpp : EmzSbcEncoder.hpp
  • APOXI_ENABLE_ADVANCED_TRANSLATION : apoxi.defines
  • APOXI_ENABLE_ALPHA_BLENDING : apoxi.defines
  • APOXI_ENABLE_ANIMATED_TITLE : apoxi.defines
  • APOXI_ENABLE_ARC_DRAWING : apoxi.defines
  • APOXI_ENABLE_C166_APOXIGUI_RAMCODE : apoxi.defines
  • APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE : apoxi.defines
  • APOXI_ENABLE_C166_GIFDECODER_RAMCODE : apoxi.defines
  • APOXI_ENABLE_C166_HUGEBITMAP_DRAW : apoxi.defines
  • APOXI_ENABLE_C166_RECT_RAMCODE : apoxi.defines
  • APOXI_ENABLE_CBS_ACTIVE_TIMER_INTERFACE : apoxi.defines
  • APOXI_ENABLE_CIRCLE_DRAWING : apoxi.defines
  • APOXI_ENABLE_CONC_SMS_SCA_CHECK : apoxi.defines
  • APOXI_ENABLE_DBG_OUT : apoxi.defines
  • APOXI_ENABLE_DIAGONAL_LINE_DRAWING : apoxi.defines
  • APOXI_ENABLE_ECC_CUSTOMIZATION : apoxi.defines
  • APOXI_ENABLE_GSM_BITMAP_DRAWING : apoxi.defines
  • APOXI_ENABLE_JAPANESE_TRANSCODER : apoxi.defines
  • APOXI_ENABLE_ME_PHONEBOOK_REQUEST : apoxi.defines
  • APOXI_ENABLE_MOC_CALL_RESTRICTION : apoxi.defines
  • APOXI_ENABLE_OBSOLETE_STRING_INTERFACE : apoxi.defines
  • APOXI_ENABLE_OBSOLETE_WSTRING_INTERFACE : apoxi.defines
  • APOXI_ENABLE_POLYGON_DRAWING : apoxi.defines
  • APOXI_ENABLE_POSITION_PREVIEW : apoxi.defines
  • APOXI_ENABLE_R2L_TEST : apoxi.defines
  • APOXI_ENABLE_RUNTIME_CONFIGURATION : apoxi.defines
  • APOXI_ENABLE_SDL_SIGNAL_SIGNATURE_CHECK : apoxi.defines
  • APOXI_ENABLE_SMOOTH_SCROLLING : apoxi.defines
  • APOXI_ENABLE_STACK_CHECK : apoxi.defines
  • APOXI_ENABLE_SVG_FONT_SERIALIZATION : apoxi.defines
  • APOXI_ENABLE_SVG_SYSTEM_FONTS : apoxi.defines
  • APOXI_ENABLE_TIMING_MEASUREMENTS : apoxi.defines
  • APOXI_ENABLE_TRAP_INFO_SCREEN : apoxi.defines
  • APOXI_ENABLE_USIM_PHONEBOOK : apoxi.defines
  • APOXI_ENALBE_NEW_STARTUP_INTERFACE : apoxi.defines
  • Apoxi_EncodingThreadlet_hpp : EncodingThreadlet.hpp
  • APOXI_END_MIME_TYPE_DEFS : MimeTypeTable.cpp, MimeTypeTableUtils.hpp
  • Apoxi_EnglishT9InputMapper_hpp : EnglishT9InputMapper.hpp
  • Apoxi_EventData_hpp : EventData.hpp
  • Apoxi_ExecutionContext_hpp : ExecutionContext.hpp
  • APOXI_EXTERNAL_PCH_CONTROL_SUPPORT : apoxi.defines
  • Apoxi_ExternalPsdContextListener_hpp : ExternalPsdContextListener.hpp
  • APOXI_FACTORY_CUSTOMIZATION_SUPPORT : apoxi.defines
  • Apoxi_FatDirectoryIteratorImp_hpp : FatDirectoryIteratorImp.hpp
  • Apoxi_FatFile_hpp : FatFile.hpp
  • Apoxi_FatFileImp_hpp : FatFileImp.hpp
  • Apoxi_FatSim_hpp : FatSim.hpp
  • Apoxi_FatStorageDeviceImp_hpp : FatStorageDeviceImp.hpp
  • Apoxi_FatTypes_hpp : FatTypes.hpp
  • APOXI_FFS_EXTENDED_DEBUG : apoxi.defines
  • APOXI_FFS_USER_MAPPING : apoxi.defines
  • Apoxi_FfsTypes_hpp : FfsTypes.hpp
  • Apoxi_FifoLinkedList_hpp : FifoLinkedList.hpp
  • Apoxi_File_hpp : File.hpp
  • Apoxi_FileBinData_hpp : FileBinData.hpp
  • Apoxi_FileChunkOperator_hpp : FileChunkOperator.hpp
  • Apoxi_FileDataSink_hpp : FileDataSink.hpp
  • Apoxi_FileDataSource_hpp : FileDataSource.hpp
  • Apoxi_FileFilter_hpp : FileFilter.hpp
  • Apoxi_FileInputStream_hpp : FileInputStream.hpp
  • Apoxi_FileNameListBoxModel_hpp : FileNameListBoxModel.hpp
  • Apoxi_FileNameView_hpp : FileNameView.hpp
  • Apoxi_FileOutputStream_hpp : FileOutputStream.hpp
  • Apoxi_FilePack_hpp : FilePack.hpp
  • Apoxi_FilePackConnector_hpp : FilePackConnector.hpp
  • Apoxi_FileVisitor_hpp : FileVisitor.hpp
  • Apoxi_FlashDirectoryIteratorImp_hpp : FlashDirectoryIteratorImp.hpp
  • Apoxi_FlashFileImp_hpp : FlashFileImp.hpp
  • Apoxi_FlashStorageDeviceImp_hpp : FlashStorageDeviceImp.hpp
  • Apoxi_FlowLayout_hpp : FlowLayout.hpp
  • Apoxi_FlsFile_hpp : FlsFile.hpp
  • APOXI_FM_RADIO_SUPPORT : apoxi.defines
  • Apoxi_FmRadioAudioPlayer_hpp : FmRadioAudioPlayer.hpp
  • Apoxi_FoggyPanelView_hpp : FoggyPanelView.hpp
  • Apoxi_FoggyPositionIndicatorView_hpp : FoggyPositionIndicatorView.hpp
  • Apoxi_FoggyPushButtonView_hpp : FoggyPushButtonView.hpp
  • Apoxi_FoggySoftkeyBarView_hpp : FoggySoftkeyBarView.hpp
  • Apoxi_FoggyTheme_hpp : FoggyTheme.hpp
  • Apoxi_FoggyWindowFrameView_hpp : FoggyWindowFrameView.hpp
  • Apoxi_Font_hpp : Font.hpp
  • Apoxi_FontConfig_hpp : FontConfig.hpp
  • Apoxi_FontEntry_hpp : FontEntry.hpp
  • Apoxi_FontManager_hpp : FontManager.hpp
  • Apoxi_FontPack_hpp : FontPack.hpp
  • Apoxi_FontPackConnector_hpp : FontPackConnector.hpp
  • Apoxi_fonts_hpp : fonts.hpp
  • APOXI_FOTA_SUPPORT : apoxi.defines
  • Apoxi_Fraction_hpp : Fraction.hpp
  • Apoxi_FrameDc_hpp : FrameDc.hpp
  • Apoxi_FsmEngine_hpp : FsmEngine.hpp
  • APOXI_FTPSERVER_REQUEST_LENGTH : FtpTypes.hpp
  • Apoxi_GatiManager_hpp : GatiManager.hpp
  • Apoxi_GatiServer_hpp : GatiServer.hpp
  • APOXI_GDD_2_0_INTERFACE : apoxi.defines
  • APOXI_GDD_INTERFACE : apoxi.defines
  • Apoxi_GeneralCompoundItem_hpp : GeneralCompoundItem.hpp
  • Apoxi_GenericFeatureData_hpp : GenericFeatureData.hpp
  • Apoxi_GenericWorkerTask_hpp : GenericWorkerTask.hpp
  • Apoxi_GifDecoder_hpp : GifDecoder.hpp
  • Apoxi_GifImage_hpp : GifImage.hpp
  • Apoxi_GlassPane_hpp : GlassPane.hpp
  • Apoxi_GridLayout_hpp : GridLayout.hpp
  • APOXI_GTL_DIF : apoxi.defines
  • APOXI_GTL_EBU : apoxi.defines
  • Apoxi_GuidServiceTable_hpp : GuidServiceTable.hpp
  • Apoxi_GuiEngineConfig_hpp : GuiEngineConfig.hpp
  • Apoxi_GuiObjectDescr_hpp : GuiObjectDescr.hpp
  • Apoxi_GuiObjectFactory_hpp : GuiObjectFactory.hpp
  • Apoxi_GuiObjectIterator_hpp : GuiObjectIterator.hpp
  • Apoxi_GuiPropertyIdIterator_hpp : GuiPropertyIdIterator.hpp
  • Apoxi_GuiPropertyIterator_hpp : GuiPropertyIterator.hpp
  • APOXI_HEAP_CONTEXT_USAGE : apoxi.defines
  • APOXI_HEAP_DISABLE_64K_ALIGNMENT : apoxi.defines
  • APOXI_HEAP_LENGTH_VECTOR : HeapVector.hpp, apoxi.defines
  • APOXI_HEAP_LOG : apoxi.defines
  • APOXI_HEAP_MEM_ACCESS_CHECK : HeapVector.hpp, apoxi.defines
  • APOXI_HEAP_MEM_ALLOC_TRACE : apoxi.defines
  • APOXI_HEAP_MEM_ALLOCS_PER_SIZE : HeapVector.hpp
  • APOXI_HEAP_MEM_ASSERT_ON_FAILED_ALLOC : apoxi.defines
  • APOXI_HEAP_MEM_CONTEXT_TRACE : apoxi.defines
  • APOXI_HEAP_MEM_CONTEXT_TRACE_MAX_CTX : apoxi.defines
  • APOXI_HEAP_MEM_DETECT_CONFIG : HeapVector.hpp, apoxi.defines
  • APOXI_HEAP_MEM_POOL_TRACE : apoxi.defines
  • APOXI_HEAP_NAME : HeapVector.hpp
  • APOXI_HEAP_NAME_PTR : HeapVector.hpp
  • APOXI_HEAP_NAME_USAGE : apoxi.defines
  • APOXI_HEAP_STATS_USAGE : apoxi.defines
  • APOXI_HEAP_TEST : HeapManager.cpp, apoxi.defines
  • Apoxi_HeapDataSink_hpp : HeapDataSink.hpp
  • Apoxi_HeapManager_hpp : HeapManager.hpp
  • Apoxi_HeapObject_hpp : HeapObject.hpp
  • Apoxi_HeapVector_hpp : HeapVector.hpp
  • Apoxi_HindiTextRenderer_hpp : HindiTextRenderer.hpp
  • Apoxi_HookedMessageReferrerList_hpp : HookedMessageReferrerList.hpp
  • APOXI_HOST_NAME_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • APOXI_HOST_USE_DUMMY_PCH : apoxi.defines
  • APOXI_HOST_USE_PCH_SIGNALS : apoxi.defines
  • Apoxi_HostAudioDriver_hpp : HostAudioDriver.hpp
  • Apoxi_HostAudioGatiServer_hpp : HostAudioGatiServer.hpp
  • Apoxi_HostCoreFsSim_hpp : HostCoreFsSim.hpp
  • Apoxi_HostDebugTimeStamp_hpp : HostDebugTimeStamp.hpp
  • Apoxi_HostIniFile_hpp : HostIniFile.hpp
  • APOXI_HTTPSERVER_DEFAULT_BACKLOG : HttpTypes.hpp
  • APOXI_HTTPSERVER_DEFAULT_MAX_USERS : HttpTypes.hpp
  • APOXI_IANA_ALL_PORT_NUMBERS : apoxi.defines
  • Apoxi_Iana_hpp : Iana.hpp
  • APOXI_ICC_SIM : apoxi.defines
  • APOXI_ICC_USIM : apoxi.defines
  • Apoxi_IconSet_hpp : IconSet.hpp
  • Apoxi_IconState_hpp : IconState.hpp
  • Apoxi_Image_hpp : Image.hpp
  • Apoxi_ImageBox_hpp : ImageBox.hpp
  • Apoxi_ImageBrowserApp_hpp : ImageBrowserApp.hpp
  • Apoxi_ImageBrowserDetailWin_hpp : ImageBrowserDetailWin.hpp
  • Apoxi_ImageBrowserTestWin_hpp : ImageBrowserTestWin.hpp
  • Apoxi_ImageBrowserWin_hpp : ImageBrowserWin.hpp
  • Apoxi_ImageDecoder_hpp : ImageDecoder.hpp
  • Apoxi_ImageEncoder_hpp : ImageEncoder.hpp
  • Apoxi_ImageFactory_hpp : ImageFactory.hpp
  • Apoxi_ImageItem_hpp : ImageItem.hpp
  • Apoxi_ImageListBoxModel_hpp : ImageListBoxModel.hpp
  • Apoxi_ImageMetaData_hpp : ImageMetaData.hpp
  • Apoxi_ImageObtainer_hpp : ImageObtainer.hpp
  • Apoxi_ImageRef_hpp : ImageRef.hpp
  • Apoxi_ImageRefContainer_hpp : ImageRefContainer.hpp
  • Apoxi_ImageRefGenContainer_hpp : ImageRefGenContainer.hpp
  • Apoxi_ImageView_hpp : ImageView.hpp
  • Apoxi_ImageViewListBoxModel_hpp : ImageViewListBoxModel.hpp
  • Apoxi_ImgBrowserSaveWin_hpp : BrowserSaveWin.hpp
  • APOXI_INCLUDE_DRM : apoxi.defines
  • Apoxi_InetSocket_hpp : InetSocket.hpp
  • Apoxi_InetSocketAddr_hpp : InetSocketAddr.hpp
  • Apoxi_InfoDialog_hpp : InfoDialog.hpp
  • Apoxi_InputMap_hpp : InputMap.hpp
  • Apoxi_InputMapper_hpp : InputMapper.hpp
  • Apoxi_InputStream_hpp : InputStream.hpp
  • Apoxi_IpAddr_hpp : IpAddr.hpp
  • Apoxi_IpAddrCompoundItem_hpp : IpAddrCompoundItem.hpp
  • Apoxi_IpAddrEditor_hpp : IpAddrEditor.hpp
  • Apoxi_IpAddrEditorDocument_hpp : IpAddrEditorDocument.hpp
  • Apoxi_IpAddrInputMapper_hpp : IpAddrInputMapper.hpp
  • Apoxi_IpAddrPrompt_hpp : IpAddrPrompt.hpp
  • Apoxi_IpPortNo_hpp : IpPortNo.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ASCII : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_1 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_2 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_3 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_4 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_5 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_6 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_7 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_8 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_9 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_UNICODE : IrdaTypes.hpp
  • APOXI_IRDA_HINT_COMPUTER : IrdaTypes.hpp
  • APOXI_IRDA_HINT_EXT : IrdaTypes.hpp
  • APOXI_IRDA_HINT_FAX : IrdaTypes.hpp
  • APOXI_IRDA_HINT_FILE : IrdaTypes.hpp
  • APOXI_IRDA_HINT_HTTP : IrdaTypes.hpp
  • APOXI_IRDA_HINT_IRCOMM : IrdaTypes.hpp
  • APOXI_IRDA_HINT_LAN : IrdaTypes.hpp
  • APOXI_IRDA_HINT_MESSAGE : IrdaTypes.hpp
  • APOXI_IRDA_HINT_MODEM : IrdaTypes.hpp
  • APOXI_IRDA_HINT_OBEX : IrdaTypes.hpp
  • APOXI_IRDA_HINT_PDA : IrdaTypes.hpp
  • APOXI_IRDA_HINT_PNP : IrdaTypes.hpp
  • APOXI_IRDA_HINT_PRINTER : IrdaTypes.hpp
  • APOXI_IRDA_HINT_TELEPHONY : IrdaTypes.hpp
  • APOXI_IRDA_OBEX_HEADER_BUFF_SIZE : IrdaObexImpl.hpp
  • APOXI_IRDA_OBEX_MAX_CHANNELS : IrdaObexImpl.hpp
  • APOXI_IRDA_OFFSET_HINT_COMPUTER : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_FAX : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_FILE : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_HTTP : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_IRCOMM : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_LAN : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_MESSAGE : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_MODEM : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_OBEX : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_PDA : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_PNP : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_PRINTER : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_TELEPHONY : IrdaTypes.hpp
  • Apoxi_IrdaObexAddress_hpp : IrdaObexAddr.hpp
  • Apoxi_IrdaObexImpl_hpp : IrdaObexImpl.hpp
  • Apoxi_IrdaObexTransport_hpp : IrdaObexTransport.hpp
  • Apoxi_IrdaTransport_hpp : IrdaTransport.hpp
  • Apoxi_IrdaTypes_hpp : IrdaTypes.hpp
  • Apoxi_IsrDataContainer_hpp : IsrDataContainer.hpp
  • Apoxi_IsrDataManager_hpp : IsrDataManager.hpp
  • Apoxi_IsrDataMarshaller_hpp : IsrDataMarshaller.hpp
  • Apoxi_Item_hpp : Item.hpp
  • Apoxi_ItemBox_hpp : ItemBox.hpp
  • Apoxi_ItemContainer_hpp : ItemContainer.hpp
  • Apoxi_ItemGrid_hpp : ItemGrid.hpp
  • Apoxi_ItemMenu_hpp : ItemMenu.hpp
  • Apoxi_ItemRendererProperties_hpp : ItemRendererProperties.hpp
  • Apoxi_ItemTree_hpp : ItemTree.hpp
  • Apoxi_JapaneseTextRenderer_hpp : JapaneseTextRenderer.hpp
  • Apoxi_JapaneseTranscoder_hpp : JapaneseTranscoder.hpp
  • Apoxi_JpegDecoder_hpp : JpegDecoder.hpp
  • Apoxi_JpegEncoder_hpp : JpegEncoder.hpp
  • Apoxi_JpegEncodingThreadlet_hpp : JpegEncodingThreadlet.hpp
  • Apoxi_JpegImage_hpp : JpegImage.hpp
  • Apoxi_KeyboardConfig_hpp : KeyboardConfig.hpp
  • Apoxi_LanguageManager_hpp : LanguageManager.hpp
  • Apoxi_Layouter_hpp : Layouter.hpp
  • APOXI_LED_NEW_INTERFACE : apoxi.defines
  • APOXI_LETTERCLASSE_SUPPORT : apoxi.defines
  • APOXI_LIB_ADDON_AFSFAT : apoxi.defines
  • APOXI_LIB_ADDON_AFSFFS : apoxi.defines
  • APOXI_LIB_ADDON_AFSRAM : apoxi.defines
  • APOXI_LIB_ADDON_AFSRFS : apoxi.defines
  • APOXI_LIB_ADDON_MMCALL : apoxi.defines
  • APOXI_LIB_ADDON_VR : apoxi.defines
  • APOXI_LIB_BLUETOOTH : apoxi.defines
  • APOXI_LIB_IRDA : apoxi.defines
  • APOXI_LIB_OBEX : apoxi.defines
  • Apoxi_LineEditor_hpp : LineEditor.hpp
  • Apoxi_Linkable_hpp : Linkable.hpp
  • Apoxi_LinkedList_hpp : LinkedList.hpp
  • APOXI_LITTLE_ENDIAN : MachType.hpp, apoxi.defines
  • Apoxi_LocalDataStore_hpp : LocalDataStore.hpp
  • Apoxi_Locale_hpp : Locale.hpp
  • Apoxi_LocaleConfig_hpp : LocaleConfig.hpp
  • Apoxi_LockTable_hpp : LockTable.hpp
  • Apoxi_LockTableList_hpp : LockTableList.hpp
  • Apoxi_Lwip_SysDnsClient_hpp : LwipSysDnsClient.hpp
  • Apoxi_Lwip_SysSocket_hpp : LwipSysSocket.hpp
  • Apoxi_MachType_hpp : MachType.hpp
  • Apoxi_Macros_hpp : Macros.hpp
  • Apoxi_MapiAudioPlayer_hpp : MapiAudioPlayer.hpp
  • Apoxi_MapiAudioReference_hpp : MapiAudioReference.hpp
  • APOXI_MAX_CONN_LIMIT : HttpWapMgr.hpp
  • APOXI_MAX_DISPLAY_COUNT : DeviceManager.hpp, apoxi.defines
  • APOXI_MAX_INET_SOCKET_COUNT : SocketTypes.hpp, apoxi.defines
  • APOXI_MAX_LANGUAGE_COUNT : LanguageManager.hpp, apoxi.defines
  • APOXI_MAX_NET_FILENAME_LENGTH : RfsConfig.hpp
  • APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH : RfsConfig.hpp
  • APOXI_MAX_PATHNAME_LENGTH : RfsConfig.hpp
  • APOXI_MAX_RESPONSE_LEN : AragonServer.cpp
  • APOXI_MAX_SOFTKEY_COUNT : Window.hpp, SoftkeyBar.hpp, apoxi.defines
  • APOXI_MAX_THAI_BUFFER_LENGTH : ThaiTextRenderer.cpp
  • Apoxi_Media_hpp : Media.hpp
  • Apoxi_MediaBrowserUtils_hpp : MediaBrowserUtils.hpp
  • Apoxi_MediaFilter_hpp : MediaFilter.hpp
  • Apoxi_MediaFrameworkCaps_hpp : MediaFrameworkCaps.hpp
  • Apoxi_MediaInfo_hpp : MediaInfo.hpp
  • Apoxi_MediaObtainer_hpp : MediaObtainer.hpp
  • Apoxi_MediaRef_hpp : MediaRef.hpp
  • Apoxi_MediaRefContainer_hpp : MediaRefContainer.hpp
  • Apoxi_MediaVisitor_hpp : MediaVisitor.hpp
  • APOXI_MEM_TRACE : apoxi.defines
  • APOXI_MEMORY_WIN32_REDIRECT_HUGEALLOCATION : apoxi.defines
  • Apoxi_MemoryConfig_hpp : MemoryConfig.hpp
  • Apoxi_MemPool_hpp : MemPool.hpp
  • Apoxi_MemPool_tpl : MemPool.cpp
  • Apoxi_Menu_hpp : Menu.hpp
  • Apoxi_MenuAccessor_hpp : MenuAccessor.hpp
  • Apoxi_MenuItem_hpp : MenuItem.hpp
  • Apoxi_MenuList_hpp : MenuList.hpp
  • Apoxi_MenuTextIterator_hpp : MenuTextIterator.hpp
  • Apoxi_MenuTextPtrArrayIterator_hpp : MenuTextPtrArrayIterator.hpp
  • Apoxi_MenuWindow_hpp : MenuWindow.hpp
  • Apoxi_MessageBox_hpp : MessageBox.hpp
  • Apoxi_MessageHook_hpp : MessageHook.hpp
  • Apoxi_MessageHookList_hpp : MessageHookList.hpp
  • Apoxi_MessageHookNotificationMsg_hpp : MessageHookNotificationMsg.hpp
  • Apoxi_MessageMap_hpp : MessageMap.hpp
  • Apoxi_MessageMapDispatcher_hpp : MessageMapDispatcher.hpp
  • Apoxi_MessageReferrer_hpp : MessageReferrer.hpp
  • Apoxi_MessageRouter_hpp : MessageRouter.hpp
  • Apoxi_MetaData_hpp : MetaData.hpp
  • APOXI_MIME_EXT : MimeTypeTableUtils.hpp
  • APOXI_MIME_LINE_WIDTH : MimeCoding.hpp
  • APOXI_MIME_STR : MimeTypeTableUtils.hpp
  • APOXI_MIME_TEST_LEN : MimeCoding.cpp
  • Apoxi_MmCallDispatcher_hpp : MmCallDispatcher.hpp
  • Apoxi_MmCallHandler_hpp : MmCallHandler.hpp
  • Apoxi_MmCallInfo_hpp : MmCallInfo.hpp
  • Apoxi_MmCallSerialTerminalListener_hpp : MmCallSerialTerminalListener.hpp
  • APOXI_MMCI_SUPPORT : apoxi.defines
  • Apoxi_MmfPlayer_hpp : MmfPlayer.hpp
  • Apoxi_MmiSimClient_hpp : MmiSimClient.hpp
  • Apoxi_MmiSimServer_hpp : MmiSimServer.hpp
  • Apoxi_Model_hpp : Model.hpp
  • APOXI_MP3_SUPPORT : apoxi.defines
  • APOXI_MSG_QUEUE_KEY_ENTRY_LIMIT : apoxi.defines
  • APOXI_MSG_QUEUE_YIELD_COUNTER : apoxi.defines
  • APOXI_MSG_QUEUE_YIELD_PERIOD : MsgQueue.cpp, apoxi.defines
  • Apoxi_MsgQueue_hpp : MsgQueue.hpp
  • Apoxi_MultiLineEditor_hpp : MultiLineEditor.hpp
  • APOXI_MULTIMEDIA_SUPPORT : apoxi.defines
  • Apoxi_MultiMediaEditor_hpp : MultiMediaEditor.hpp
  • Apoxi_MultiMediaEditorDocument_hpp : MultiMediaEditorDocument.hpp
  • Apoxi_Multipart_Mime_hpp : MultipartParser.hpp
  • Apoxi_MultiTapCaret_hpp : MultiTapCaret.hpp
  • Apoxi_MultiTapInputMapper_hpp : MultiTapInputMapper.hpp
  • Apoxi_Mutex_hpp : Mutex.hpp
  • Apoxi_MyDataConnProfileStorage_hpp : MyDataConnProfileStorage.hpp
  • Apoxi_NativeImage_hpp : NativeImage.hpp
  • Apoxi_NetAdapterHandler_hpp : NetAdapterHandler.hpp
  • APOXI_NEVER_TIMEOUT : Nuc32.hpp
  • Apoxi_NewAPI_VibratorDevice_hpp : VibratorDevice.hpp
  • Apoxi_NiSharedPtr_hpp : NiSharedPtr.hpp
  • APOXI_NO_MSG_BROADCAST_ON_STARTUP : apoxi.defines
  • Apoxi_NodeFileHandler_hpp : NodeFileHandler.hpp
  • Apoxi_NonCloneable_hpp : NonCloneable.hpp
  • APOXI_NOSTREAMING : apoxi.defines
  • Apoxi_NotificationTable_hpp : NotificationTable.hpp
  • Apoxi_Nuc32_hpp : Nuc32.hpp
  • Apoxi_Nuc32_Thread_hpp : Thread.hpp
  • Apoxi_NumberPrompt_hpp : NumberPrompt.hpp
  • Apoxi_NumericInputMapper_hpp : NumericInputMapper.hpp
  • APOXI_OBEX_DATA_SERVER_STATE : ObexDataServer.cpp
  • APOXI_OBEX_DBG_OUT : ObexConfig.hpp
  • APOXI_OBEX_FTP_DBG : ObexConfig.hpp
  • APOXI_OBEX_MAX_NO_SELECTIONS : ObexConfig.hpp, apoxi.defines
  • APOXI_OBEX_MAX_NO_TRANSPORTS : ObexConfig.hpp, apoxi.defines
  • APOXI_OBEX_OPP_DBG : ObexConfig.hpp
  • Apoxi_ObexAbstractPort_hpp : ObexAbstractPort.hpp
  • Apoxi_ObexAddress_hpp : ObexAddress.hpp
  • Apoxi_ObexAddrPtr_hpp : ObexAddrPtr.hpp
  • Apoxi_ObexBuffer_hpp : ObexBuffer.hpp
  • Apoxi_ObexChannel_hpp : ObexChannel.hpp
  • Apoxi_ObexClient_hpp : ObexClient.hpp
  • Apoxi_ObexClientDispatcher_hpp : ObexClientDispatcher.hpp
  • Apoxi_ObexClientOppImpl_hpp : ObexClientOppImpl.hpp
  • Apoxi_ObexClientPort_hpp : ObexClientPort.hpp
  • Apoxi_ObexConfig_hpp : ObexConfig.hpp
  • Apoxi_ObexDataServer_hpp : ObexDataServer.hpp
  • Apoxi_ObexDispatcher_hpp : ObexDispatcher.hpp
  • Apoxi_ObexFtpDataServer_hpp : ObexFtpDataServer.hpp
  • Apoxi_ObexFtpServer_hpp : ObexFtpServer.hpp
  • Apoxi_ObexHeader_hpp : ObexHeader.hpp
  • Apoxi_ObexHeaderBuilder_hpp : ObexHeaderBuilder.hpp
  • Apoxi_ObexHeaderList_hpp : ObexHeaderList.hpp
  • Apoxi_ObexLayer_hpp : ObexLayer.hpp
  • Apoxi_ObexMngr_hpp : ObexMngr.hpp
  • Apoxi_ObexObject_hpp : ObexObject.hpp
  • Apoxi_ObexObjectData_hpp : ObexObjectData.hpp
  • Apoxi_ObexOperationId_hpp : ObexOperationId.hpp
  • Apoxi_ObexOppBinDataPushClient_hpp : ObexOppBinDataPushClient.hpp
  • Apoxi_ObexOppClient_hpp : ObexOppClient.hpp
  • Apoxi_ObexOppDataSinkPushServer_hpp : ObexOppDataSinkPushServer.hpp
  • Apoxi_ObexOppLayer_hpp : ObexOppLayer.hpp
  • Apoxi_ObexOppServer_hpp : ObexOppServer.hpp
  • Apoxi_ObexProtocol_hpp : ObexProtocol.hpp
  • Apoxi_ObexResult_hpp : ObexResult.hpp
  • Apoxi_ObexServer_hpp : ObexServer.hpp
  • Apoxi_ObexServerDispatcher_hpp : ObexServerDispatcher.hpp
  • Apoxi_ObexServerInfo_hpp : ObexServerInfo.hpp
  • Apoxi_ObexServerMngr_hpp : ObexServerMngr.hpp
  • Apoxi_ObexServerOppImpl_hpp : ObexServerOppImpl.hpp
  • Apoxi_ObexServerPort_hpp : ObexServerPort.hpp
  • Apoxi_ObexServerVisitor_hpp : ObexServerVisitor.hpp
  • Apoxi_ObexTransport_hpp : ObexTransport.hpp
  • Apoxi_ObexTransportSet_hpp : ObexTransportSet.hpp
  • Apoxi_ObexTypes_hpp : ObexTypes.hpp
  • Apoxi_ObexUrlParser_hpp : ObexUrlParser.hpp
  • Apoxi_ObjectDataConverter_hpp : ObjectDataConverter.hpp
  • Apoxi_ObjectReferrer_hpp : ObjectReferrer.hpp
  • Apoxi_ObjectTreeService_hpp : ObjectTreeService.hpp
  • Apoxi_ObservableObject_hpp : ObservableObject.hpp
  • Apoxi_Observer_hpp : Observer.hpp
  • Apoxi_OpenContextMenuAction_hpp : OpenContextMenuAction.hpp
  • Apoxi_OpenWindowAction_hpp : OpenWindowAction.hpp
  • Apoxi_OptionalConfig_hpp : OptionalConfig.hpp
  • Apoxi_OptionalConfigBase_hpp : OptionalConfigBase.hpp
  • Apoxi_Os_hpp : Os.hpp
  • Apoxi_Os_NucInc_hpp : NucInc.hpp
  • Apoxi_Os_OsStrLib_hpp : OsStrLib.hpp
  • Apoxi_Os_Scheduler_hpp : Scheduler.hpp
  • Apoxi_Os_Semaphore_hpp : Semaphore.hpp
  • Apoxi_Os_SimpleSemaphore_hpp : SimpleSemaphore.hpp
  • Apoxi_Os_SocketPeer_hpp : SocketPeer.hpp
  • Apoxi_Os_SystemTimer_hpp : SystemTimer.hpp
  • Apoxi_Os_Thread_hpp : Thread.hpp
  • Apoxi_Os_Ticks_hpp : Ticks.hpp
  • Apoxi_Os_Trap_hpp : Trap.hpp
  • Apoxi_Os_Win32_DnsClient_hpp : DummyDnsClient.hpp
  • Apoxi_Os_WinInc_hpp : WinInc.hpp
  • Apoxi_OsClass_hpp : OsClass.hpp
  • Apoxi_OutputStream_hpp : OutputStream.hpp
  • Apoxi_PagingMap_hpp : PagingMap.hpp
  • Apoxi_PaintDc_hpp : PaintDc.hpp
  • Apoxi_Panel_hpp : Panel.hpp
  • Apoxi_ParagraphCompoundItem_hpp : ParagraphCompoundItem.hpp
  • Apoxi_ParagraphMarker_hpp : ParagraphMarker.hpp
  • Apoxi_PasswordEditor_hpp : PasswordEditor.hpp
  • Apoxi_Path_hpp : Path.hpp
  • Apoxi_Pathname_hpp : Pathname.hpp
  • Apoxi_PathProfile_hpp : PathProfile.hpp
  • Apoxi_Pen_hpp : Pen.hpp
  • Apoxi_PersistDataConnProfile_hpp : PersistDataConnProfile.hpp
  • APOXI_PHONENUMBER_MATCH_DEFAULT_DEPTH : apoxi.defines
  • APOXI_PHONENUMBER_TEST_SUITE : PhoneNumber.hpp, apoxi.defines
  • Apoxi_PhoneNumberInputMapper_hpp : PhoneNumberInputMapper.hpp
  • APOXI_PLATFORM_BP30 : apoxi.defines
  • APOXI_PLATFORM_MP1U : apoxi.defines
  • APOXI_PLATFORM_MPE : apoxi.defines
  • APOXI_PLATFORM_MPEU : apoxi.defines
  • APOXI_PNG_ENCODER_SUPPORT : apoxi.defines
  • Apoxi_PngDecoder_hpp : PngDecoder.hpp
  • Apoxi_PngEncoder_hpp : PngEncoder.hpp
  • Apoxi_PngEncodingThreadlet_hpp : PngEncodingThreadlet.hpp
  • Apoxi_PngImage_hpp : PngImage.hpp
  • Apoxi_Point_hpp : Point.hpp
  • APOXI_POLYGON_EDGES_MAX : DeviceContext.cpp, apoxi.defines
  • Apoxi_PositionIndicator_hpp : PositionIndicator.hpp
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND : Os.hpp, apoxi.defines
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE : apoxi.defines
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND : Os.hpp, apoxi.defines
  • Apoxi_PppDataConn_hpp : PppDataConn.hpp
  • Apoxi_PredInputMapper_hpp : PredInputMapper.hpp
  • apoxi_process_signal() : SignalHandler.cpp
  • Apoxi_ProgressBar_hpp : ProgressBar.hpp
  • Apoxi_Protector_hpp : Protector.hpp
  • Apoxi_ProviderListBox_hpp : ProviderListBox.hpp
  • Apoxi_PsdDataConn_hpp : PsdDataConn.hpp
  • Apoxi_PsdDataConnProfile_hpp : PsdDataConnProfile.hpp
  • Apoxi_PushButton_hpp : PushButton.hpp
  • Apoxi_RadioButton_hpp : RadioButton.hpp
  • Apoxi_RadioButtonAction_hpp : RadioButtonAction.hpp
  • Apoxi_RadioButtonControl_hpp : RadioButtonControl.hpp
  • Apoxi_RadioButtonGroup_hpp : RadioButtonGroup.hpp
  • Apoxi_RadioButtonItem_hpp : RadioButtonItem.hpp
  • Apoxi_RadioButtonList_hpp : RadioButtonList.hpp
  • APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE : apoxi.defines, RamTypes.hpp
  • Apoxi_RamDataSink_hpp : RamDataSink.hpp
  • Apoxi_RamDataSource_hpp : RamDataSource.hpp
  • Apoxi_RamDirectoryIteratorImp_hpp : RamDirectoryIteratorImp.hpp
  • Apoxi_RamFileImp_hpp : RamFileImp.hpp
  • Apoxi_RamStorageDeviceImp_hpp : RamStorageDeviceImp.hpp
  • APOXI_RAT_DUAL : apoxi.defines
  • APOXI_RAT_GSM : apoxi.defines
  • APOXI_RAT_UMTS : apoxi.defines
  • Apoxi_RecordSettings_hpp : RecordSettings.hpp
  • Apoxi_Rect_hpp : Rect.hpp
  • APOXI_REG_INVALID_FILE_ID : RegDefines.hpp
  • APOXI_REG_INVALID_LOCKID : RegistryTypes.hpp
  • APOXI_REG_INVALID_TRANSACTION_ID : RegDefines.hpp
  • APOXI_REG_LARGE_BLOB_SIZE : apoxi.defines, RegDefines.hpp
  • APOXI_REG_MAP_FILE_RECORDS_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_MAX_ASOT : apoxi.defines, GuidServiceTable.hpp
  • APOXI_REG_MAX_MIME_TYPE_LEN : RegBlobObject.hpp, apoxi.defines
  • APOXI_REG_MAX_POOL_BUFFERS : apoxi.defines, RegDefines.hpp
  • APOXI_REG_MAX_RECURSION_DEPTH : RegDefines.hpp
  • APOXI_REG_MAX_URIS_IN_TABLE : apoxi.defines, LockTable.hpp
  • APOXI_REG_NODE_FILE_SIZE_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_NODE_NAME_SIZE_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_SMALL_BLOB_SIZE_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_URI_SIZE_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_VERSION : apoxi.defines, Registry.cpp
  • Apoxi_RegDefines_hpp : RegDefines.hpp
  • Apoxi_RegDeleteBuffer_hpp : RegDeleteBuffer.hpp
  • APOXI_REGISTERED_TABLE_SIZE : apoxi.defines, NotificationTable.hpp
  • Apoxi_Registry_hpp : Registry.hpp
  • APOXI_REGISTRY_TEST : apoxi.defines
  • APOXI_REGISTRY_VERSION : RegDefines.hpp
  • Apoxi_RegistryTypes_hpp : RegistryTypes.hpp
  • Apoxi_RegIterator_hpp : RegIterator.hpp
  • Apoxi_RegManager_hpp : RegManager.hpp
  • Apoxi_RegMemoryPool_hpp : RegMemoryPool.hpp
  • Apoxi_RegNodeFile_hpp : RegNodeFile.hpp
  • Apoxi_RenameDialog_hpp : RenameFileDialog.hpp
  • Apoxi_ResourceManager_hpp : ResourceManager.hpp
  • Apoxi_ResourceParser_hpp : ResourceParser.hpp
  • Apoxi_ResourceReader_hpp : ResourceReader.hpp
  • Apoxi_RfsConfig_hpp : RfsConfig.hpp
  • Apoxi_RichTextCompoundItem_hpp : RichTextCompoundItem.hpp
  • Apoxi_RingBuffer_hpp : RingBuffer.hpp
  • APOXI_RINGER_DEVICE_PRESENT : audio_private.hpp
  • Apoxi_RingerAudioPlayer_hpp : RingerAudioPlayer.hpp
  • Apoxi_RomFont_hpp : RomFont.hpp
  • Apoxi_RootDirectoryIteratorImp_hpp : RootDirectoryIteratorImp.hpp
  • Apoxi_RootFileImp_hpp : RootFileImp.hpp
  • Apoxi_RootFileSystem_hpp : RootFileSystem.hpp
  • Apoxi_RootStorageDeviceImp_hpp : RootStorageDeviceImp.hpp
  • APOXI_RTOS_DUMMY : apoxi.defines
  • APOXI_RTOS_LINUX : apoxi.defines
  • APOXI_RTOS_NUC16 : apoxi.defines
  • APOXI_RTOS_NUC16S : apoxi.defines
  • APOXI_RTOS_NUC16U : apoxi.defines
  • APOXI_RTOS_NUC32 : apoxi.defines
  • APOXI_RTOS_OSE166 : apoxi.defines
  • APOXI_RTOS_POCKETPC : apoxi.defines
  • APOXI_RTOS_SIM166 : apoxi.defines
  • APOXI_RTOS_WIN32 : apoxi.defines
  • Apoxi_RtStreamingBuffer_hpp : RtStreamingBuffer.hpp
  • Apoxi_RtStreamingConn_hpp : RtStreamingConn.hpp
  • Apoxi_RtStreamingEndPoint_hpp : RtStreamingEndPoint.hpp
  • Apoxi_RtStreamingSink_hpp : RtStreamingSink.hpp
  • Apoxi_RtStreamingSource_hpp : RtStreamingSource.hpp
  • Apoxi_RuntimeConfigurator_hpp : RuntimeConfigurator.hpp
  • Apoxi_SampleImages_hpp : SampleImages.hpp
  • Apoxi_SampleIMelodies_hpp : SampleIMelodies.hpp
  • Apoxi_Scheduler_hpp : Scheduler.hpp
  • APOXI_SCICOS_MM_CHIP_SUPPORT : apoxi.defines
  • Apoxi_ScrollBehavior_hpp : ScrollBehavior.hpp
  • APOXI_SDMMCSPI_SUPPORT : apoxi.defines
  • APOXI_SECURECLOCK_SUPPORT : apoxi.defines
  • Apoxi_SelectionBox_hpp : SelectionBox.hpp
  • Apoxi_Semaphore_cpp : Semaphore.cpp
  • Apoxi_Semaphore_hpp : Semaphore.hpp
  • APOXI_SEMAPHORE_M_FIRST_SWE : apoxi.defines
  • Apoxi_SemObtainer_hpp : SemObtainer.hpp
  • APOXI_SER_DATACONN_SUPPORT : apoxi.defines
  • Apoxi_SerialSocketData_hpp : SerialSocketData.hpp
  • Apoxi_SerialSocketSubSystem_hpp : SerialSocketSubSystem.hpp
  • Apoxi_SerialSocketThread_hpp : SerialSocketThread.hpp
  • Apoxi_SerialTerminal_hpp : SerialTerminal.hpp
  • Apoxi_SerialTerminalListener_hpp : SerialTerminalListener.hpp
  • Apoxi_SerialTerminalSocket_hpp : SerialTerminalSocket.hpp
  • APOXI_SERVER_DEFAULT_BACKLOG : Server.hpp
  • APOXI_SERVER_DEFAULT_MAX_USERS : Server.hpp
  • Apoxi_ServiceThread_hpp : ServiceThread.hpp
  • Apoxi_ServiceThreadStarter_hpp : ServiceThreadStarter.hpp
  • Apoxi_SetLanguageAction_hpp : SetLanguageAction.hpp
  • Apoxi_SetThemeAction_hpp : SetThemeAction.hpp
  • Apoxi_SharedPtr_hpp : SharedPtr.hpp
  • Apoxi_SharedTimer_hpp : SharedTimer.hpp
  • APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT : ShutDown.cpp, apoxi.defines
  • APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL : ShutDown.cpp, apoxi.defines
  • Apoxi_ShutDown_hpp : ShutDown.hpp
  • Apoxi_SimpleMap_hpp : SimpleMap.hpp
  • Apoxi_SimpleMutex_hpp : SimpleMutex.hpp
  • Apoxi_SimpleScheduler_hpp : SimpleScheduler.hpp
  • Apoxi_SimpleSemaphore_cpp : SimpleSemaphore.cpp
  • Apoxi_SimpleSemaphore_hpp : SimpleSemaphore.hpp
  • Apoxi_SimpleTextRenderer_hpp : SimpleTextRenderer.hpp
  • APOXI_SIMTK_TRANSACTIONID_SUPPORT : apoxi.defines
  • Apoxi_SimTkLceService_hpp : SimTkLceService.hpp
  • Apoxi_SingleArgHook_hpp : SingleArgHook.hpp
  • Apoxi_SioGlueSignalListener_hpp : SioGlueSignalListener.hpp
  • Apoxi_SioGlueWrapper_hpp : SioGlueWrapper.hpp
  • Apoxi_SioSocketAdapter_hpp : SioSocketAdapter.hpp
  • APOXI_SIZE_16_KILO_BYTE : RegDefines.hpp
  • Apoxi_Size_hpp : Size.hpp
  • APOXI_SMS_NEW_PROVIDERS : apoxi.defines
  • APOXI_SMS_NOWAIT_ON_RELOAD : apoxi.defines
  • APOXI_SMSSOCKET_MAX_CACHED_TPDUS : SmsSocketListener.hpp, apoxi.defines
  • APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS : SmsSocketListener.hpp, apoxi.defines
  • Apoxi_Socket_DnsClientTypes_hpp : DnsClientTypes.hpp
  • APOXI_SOCKET_ENSURE_CONTEXT : apoxi.defines
  • APOXI_SOCKET_EXTENDED_TRACE : apoxi.defines
  • Apoxi_Socket_hpp : Socket.hpp
  • APOXI_SOCKET_OPERATION_LOCK : apoxi.defines
  • APOXI_SOCKET_PARANOIA : apoxi.defines
  • APOXI_SOCKET_SYSTEM_BSD : apoxi.defines
  • APOXI_SOCKET_SYSTEM_DUMMY : apoxi.defines
  • APOXI_SOCKET_SYSTEM_LWIP : apoxi.defines
  • APOXI_SOCKET_SYSTEM_USNET : apoxi.defines
  • APOXI_SOCKET_SYSTEM_WIN32 : SysSocket.hpp, apoxi.defines
  • Apoxi_SocketData_hpp : SocketData.hpp
  • Apoxi_SocketDataLock_hpp : SocketDataLock.hpp, SerialSocketDataLock.hpp
  • Apoxi_SocketHandler_hpp : SocketHandler.hpp
  • Apoxi_SocketRxThread_hpp : SocketRxThread.hpp
  • Apoxi_SocketSerialTerminalListener_hpp : SocketSerialTerminalListener.hpp
  • Apoxi_SocketSubSystem_hpp : SocketSubSystem.hpp
  • Apoxi_SocketTypes_hpp : SocketTypes.hpp
  • Apoxi_SoftkeyBar_hpp : SoftkeyBar.hpp
  • Apoxi_SoundBrowserApp_hpp : SoundBrowserApp.hpp
  • Apoxi_SoundBrowserTestWin_hpp : SoundBrowserTestWin.hpp
  • Apoxi_SoundBrowserWin_hpp : SoundBrowserWin.hpp
  • Apoxi_SoundItem_hpp : SoundItem.hpp
  • Apoxi_SoundMetaData_hpp : SoundMetaData.hpp
  • Apoxi_SoundRef_hpp : SoundRef.hpp
  • Apoxi_SoundRefContainer_hpp : SoundRefContainer.hpp
  • apoxi_stack_init_val : Thread.cpp, Nuc32.cpp
  • Apoxi_startup() : SignalHandler.cpp
  • Apoxi_StartUp_hpp : StartUp.hpp
  • Apoxi_StateMachine_hpp : StateMachine.hpp
  • Apoxi_StillCamera_hpp : StillCamera.hpp
  • Apoxi_StorageDevice_hpp : StorageDevice.hpp
  • Apoxi_StorageDeviceFilter_hpp : StorageDeviceFilter.hpp
  • Apoxi_StorageDeviceIterator_hpp : StorageDeviceIterator.hpp
  • Apoxi_StorageDeviceVisitor_hpp : StorageDeviceVisitor.hpp
  • Apoxi_Stream_hpp : Stream.hpp
  • Apoxi_StreamingCallback_hpp : StreamingCallback.hpp
  • Apoxi_StreamingInfo_hpp : StreamingInfo.hpp
  • Apoxi_StreamingReadInfo_hpp : StreamingReadInfo.hpp
  • Apoxi_StreamingWriteInfo_hpp : StreamingWriteInfo.hpp
  • Apoxi_StreamObexTransport_hpp : StreamObexTransport.hpp
  • Apoxi_StreamReader_hpp : StreamReader.hpp
  • Apoxi_StreamWriter_hpp : StreamWriter.hpp
  • APOXI_STRING_EXTENDED_DEBUG : apoxi.defines
  • APOXI_STRING_TEST_SUITE : String.hpp, apoxi.defines
  • APOXI_StringUtil_h : StrUtil.hpp
  • Apoxi_StrokeBox_hpp : StrokeBox.hpp
  • Apoxi_SubMenuAction_hpp : SubMenuAction.hpp
  • Apoxi_SubSystem_hpp : SubSystem.hpp
  • Apoxi_SubSystemManager_hpp : SubSystemManager.hpp
  • APOXI_SUPPORT_CSMSREFNOREQ : apoxi.defines
  • APOXI_SUPPORT_MOSMS_TIMESTAMP : apoxi.defines
  • APOXI_SUPPORT_NETWORK_ECC_LIST : apoxi.defines
  • APOXI_SUPPORT_NORMAL_SMS_LOADING : apoxi.defines
  • APOXI_SUPPORT_SMS_DELETION_CMD : apoxi.defines
  • APOXI_SUPPORT_SMS_DELETION_CMD_GORS : apoxi.defines
  • APOXI_SUPPORT_SMS_NEWMSG_PAYLOAD : apoxi.defines
  • APOXI_SVG_FONT_SIZE : fonts.hpp
  • APOXI_SVG_SUPPORT : apoxi.defines
  • Apoxi_SvgConfig_hpp : SvgConfig.hpp
  • Apoxi_SvgDecoder_hpp : SvgDecoder.hpp
  • Apoxi_SvgFileWrapper_hpp : SvgFileWrapper.hpp
  • Apoxi_SvgFixPoint_hpp : SvgFixPoint.hpp
  • Apoxi_SvgGZFileWrapper_hpp : SvgGzFileWrapper.hpp
  • Apoxi_SvgImage_hpp : SvgImage.hpp
  • Apoxi_SvgImageFileWrapper_hpp : SvgImageFileWrapper.hpp
  • Apoxi_SvgIOWrapper_hpp : SvgIoWrapper.hpp
  • Apoxi_SvgPlayer_hpp : SvgPlayer.hpp
  • Apoxi_SvgPlayerDebug_hpp : SvgDebug.hpp
  • Apoxi_SvgPlayerMIMEUtil_hpp : SvgMimeUtil.hpp
  • Apoxi_SwitchedRleCompression_hpp : SwitchedRleCompression.hpp
  • APOXI_SYNC_RELEASE : apoxi.defines
  • Apoxi_SyncMLManager_hpp : SyncMLManager.hpp
  • Apoxi_SyncPaintDc_hpp : SyncPaintDc.hpp
  • Apoxi_Sys_BsdSysSocket_hpp : UsnetSysSocket.hpp, BsdSysSocket.hpp
  • Apoxi_Sys_Dummy_SysSocket_hpp : DummySysSocket.hpp
  • Apoxi_SysSock_hpp : SysSocket.hpp
  • Apoxi_SysSocketBase_hpp : SysSocketBase.hpp
  • Apoxi_System_hpp : System.hpp
  • APOXI_SYSTEM_STACK_SWAPPING : apoxi.defines
  • Apoxi_SystemTimer_hpp : SystemTimer.hpp
  • APOXI_T9_SUPPORT : apoxi.defines
  • Apoxi_T9InputConfig_hpp : T9InputConfig.hpp
  • Apoxi_T9InputMapper_hpp : T9InputMapper.hpp
  • Apoxi_T9Pack_hpp : T9Pack.hpp
  • Apoxi_T9PackConnector_hpp : T9PackConnector.hpp
  • Apoxi_T9PinyinBox_hpp : T9PinyinBox.hpp
  • Apoxi_T9PredictiveInputBox_hpp : T9PredictiveInputBox.hpp
  • Apoxi_TabButton_hpp : TabButton.hpp
  • Apoxi_TabControl_hpp : TabControl.hpp
  • APOXI_TARGETSYSTEM_HOST : apoxi.defines
  • APOXI_TARGETSYSTEM_HW : apoxi.defines
  • Apoxi_TcpServerSocket_hpp : TcpServerSocket.hpp
  • Apoxi_TcpSocket_hpp : TcpSocket.hpp
  • Apoxi_TcpSocketBase_hpp : TcpSocketBase.hpp
  • Apoxi_TestCheckBoxListView_hpp : TestCheckBoxListView.hpp
  • Apoxi_TestCheckBoxView_hpp : TestCheckBoxView.hpp
  • Apoxi_TestControlFrameView_hpp : TestControlFrameView.hpp
  • APOXI_TESTING : apoxi.defines
  • Apoxi_TestPositionIndicatorView_hpp : TestPositionIndicatorView.hpp
  • Apoxi_TestPushButtonView_hpp : TestPushButtonView.hpp
  • Apoxi_TestRadioButtonListView_hpp : TestRadioButtonListView.hpp
  • Apoxi_TestRadioButtonView_hpp : TestRadioButtonView.hpp
  • Apoxi_TestSoftkeyBarView_hpp : TestSoftkeyBarView.hpp
  • Apoxi_TestTheme_hpp : TestTheme.hpp
  • Apoxi_TestWindowFrameView_hpp : TestWindowFrameView.hpp
  • Apoxi_TestWriter_hpp : TestWriter.hpp
  • Apoxi_TextBox_hpp : TextBox.hpp
  • Apoxi_TextCompoundItem_hpp : TextCompoundItem.hpp
  • Apoxi_TextEditorDocument_hpp : TextEditorDocument.hpp
  • Apoxi_TextFormat_hpp : TextFormat.hpp
  • Apoxi_TextIconPairArray_hpp : TextIconPairArray.hpp
  • Apoxi_TextLine_hpp : TextLine.hpp
  • Apoxi_TextList_hpp : TextList.hpp
  • Apoxi_TextMenuAccessor_hpp : TextMenuAccessor.hpp
  • Apoxi_TextPack_hpp : TextPack.hpp
  • Apoxi_TextPackConnector_hpp : TextPackConnector.hpp
  • Apoxi_ThaiTextRenderer_hpp : ThaiTextRenderer.hpp
  • Apoxi_Theme_hpp : Theme.hpp
  • Apoxi_ThemeConfig_hpp : ThemeConfig.hpp
  • Apoxi_ThemeManager_hpp : ThemeManager.hpp
  • Apoxi_Thread_hpp : Thread.hpp
  • APOXI_THREAD_PRIORITY_NORMAL : Thread.hpp, apoxi.defines
  • Apoxi_Threadlet_hpp : Threadlet.hpp
  • Apoxi_ThreadSafeProvider_hpp : ThreadSafeProvider.hpp
  • Apoxi_Ticks_hpp : Ticks.hpp
  • Apoxi_TickValue_hpp : TickValue.hpp
  • Apoxi_Time_hpp : Time.hpp
  • Apoxi_TimeCompoundItem_hpp : TimeCompoundItem.hpp
  • Apoxi_TimeEditBox_hpp : TimeEditBox.hpp
  • Apoxi_TimeEditor_hpp : TimeEditor.hpp
  • Apoxi_TimeEditorDocument_hpp : TimeEditorDocument.hpp
  • Apoxi_TimeFeatureObject_hpp : TimeFeatureObject.hpp
  • Apoxi_Timer_hpp : Timer.hpp
  • Apoxi_TimeSpan_h : TimeSpan.hpp
  • Apoxi_TimeZone_hpp : TimeZone.hpp
  • Apoxi_ToggleActionGroup_hpp : ToggleActionGroup.hpp
  • Apoxi_TopLevelMenu_hpp : TopLevelMenu.hpp
  • APOXI_TRACE : Trace.hpp, apoxi.defines
  • APOXI_TRACE_DISABLED : apoxi.defines
  • APOXI_TRACE_LEVEL_2 : apoxi.defines
  • APOXI_TRACE_LEVEL_3 : apoxi.defines
  • APOXI_TRACE_MEM : apoxi.defines
  • APOXI_TRACE_SOCKETS : apoxi.defines
  • Apoxi_TraceOutputStream_hpp : TraceOutputStream.hpp
  • Apoxi_Trap_hpp : Trap.hpp
  • Apoxi_TriggerTimer_hpp : TriggerTimer.hpp
  • Apoxi_Types_hpp : Types.hpp
  • Apoxi_UdpSocket_hpp : UdpSocket.hpp
  • APOXI_UNICODE_EOF : Unicode.hpp
  • APOXI_UNITTEST : apoxi.defines
  • Apoxi_UnitTest_hpp : UnitTest.hpp
  • APOXI_UNITTEST_MMI : apoxi.defines
  • APOXI_UNITTEST_NO_FILENAMES : apoxi.defines
  • APOXI_UNITTEST_NO_MESSAGE : apoxi.defines
  • APOXI_UNITTEST_NO_TESTNAMES : apoxi.defines
  • APOXI_UNITTEST_STATIC_REPOSITORY : apoxi.defines
  • APOXI_UNITTEST_TCPIP : apoxi.defines
  • APOXI_UNITTEST_TRACE : apoxi.defines
  • Apoxi_UnitTestAutoRepository_hpp : UnitTestAutoRepository.hpp
  • Apoxi_UnitTestCase_hpp : UnitTestCase.hpp
  • Apoxi_UnitTestCaseAsync_hpp : AsyncUnitTestCase.hpp
  • Apoxi_UnitTestCommunicator_hpp : UnitTestCommunicator.hpp
  • Apoxi_UnitTestData_hpp : UnitTestData.hpp
  • Apoxi_UnitTestDecorator_hpp : Decorator.hpp
  • Apoxi_UnitTestRepository_hpp : UnitTestRepository.hpp
  • Apoxi_UnitTestResult_hpp : UnitTestResult.hpp
  • Apoxi_UnitTestRunner_hpp : UnitTestRunner.hpp
  • Apoxi_UnitTestStaticRepository_hpp : UnitTestStaticRepository.hpp
  • Apoxi_UnitTestSuite_hpp : UnitTestSuite.hpp
  • APOXI_UNZIP_BUFSIZE : Unzip.hpp
  • Apoxi_Unzip_hpp : Unzip.hpp
  • Apoxi_UnzipBinData_hpp : UnzipBinData.hpp
  • Apoxi_Unzipper_hpp : Unzipper.hpp
  • Apoxi_Uri_hpp : Uri.hpp
  • Apoxi_UriMappingTable_hpp : UriMappingTable.hpp
  • Apoxi_UsbObexTransport_hpp : UsbObexTransport.hpp
  • Apoxi_UserDispatcher_hpp : UserDispatcher.hpp
  • APOXI_UUS_SUPPORT : apoxi.defines
  • Apoxi_ValueMappingPropertyDescriptor_hpp : ValueMappingPropertyDescriptor.hpp
  • APOXI_VCARD_ADDRESS_MAX : VCard.hpp
  • APOXI_VCARD_ADR : VCard.cpp
  • APOXI_VCARD_ADR_COUNT : VCard.hpp
  • APOXI_VCARD_ADR_COUNTRY : VCard.hpp
  • APOXI_VCARD_ADR_EXTENDED : VCard.hpp
  • APOXI_VCARD_ADR_LOCALITY : VCard.hpp
  • APOXI_VCARD_ADR_POSTALCODE : VCard.hpp
  • APOXI_VCARD_ADR_POSTOFFICE : VCard.hpp
  • APOXI_VCARD_ADR_REGION : VCard.hpp
  • APOXI_VCARD_ADR_STREET : VCard.hpp
  • APOXI_VCARD_BEGIN : VCard.cpp
  • APOXI_VCARD_EMAIL : VCard.cpp
  • APOXI_VCARD_END : VCard.cpp
  • APOXI_VCARD_FN : VCard.cpp
  • APOXI_VCARD_N : VCard.cpp
  • APOXI_VCARD_NAME_ADD : VCard.hpp
  • APOXI_VCARD_NAME_COUNT : VCard.hpp
  • APOXI_VCARD_NAME_FAMILY : VCard.hpp
  • APOXI_VCARD_NAME_GIVEN : VCard.hpp
  • APOXI_VCARD_NAME_PREFIX : VCard.hpp
  • APOXI_VCARD_NAME_SUFFIX : VCard.hpp
  • APOXI_VCARD_ORG : VCard.cpp
  • APOXI_VCARD_ORG_ADDUNIT : VCard.hpp
  • APOXI_VCARD_ORG_MAX : VCard.hpp
  • APOXI_VCARD_ORG_NAME : VCard.hpp
  • APOXI_VCARD_ORG_UNIT : VCard.hpp
  • APOXI_VCARD_TEL : VCard.cpp
  • APOXI_VCARD_TITLE : VCard.cpp
  • APOXI_VCARD_TYPE_ADR_DEFAULT : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_DOM : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_HOME : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_INTL : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_PARCEL : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_POSTAL : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_WORK : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_BBS : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_CAR : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_CELL : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_DEFAULT : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_FAX : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_HOME : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_ISDN : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_MODEM : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_MSG : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_PAGER : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_PREF : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_VIDEO : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_VOICE : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_WORK : VCard.hpp
  • APOXI_VCARD_VERSION : VCard.cpp
  • APOXI_VCARD_X : VCard.cpp
  • Apoxi_VCardItem_hpp : VCardItem.hpp
  • Apoxi_Vector_hpp : Vector.hpp
  • APOXI_VIBRATOR_SUPPORT : apoxi.defines
  • APOXI_VIDEO_SUPPORT : apoxi.defines
  • Apoxi_VideoCamera_hpp : VideoCamera.hpp
  • Apoxi_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_VideoDecoder_hpp : VideoDecoder.hpp
  • Apoxi_VideoEncoder_hpp : VideoEncoder.hpp
  • Apoxi_VietnameseTextRenderer_hpp : VietnameseTextRenderer.hpp
  • Apoxi_View_hpp : View.hpp
  • Apoxi_VirtualDisplay_hpp : VirtualDisplay.hpp
  • APOXI_WAP_STACK : apoxi.defines
  • Apoxi_WbmpDecoder_hpp : WbmpDecoder.hpp
  • Apoxi_WbmpImage_hpp : WbmpImage.hpp
  • Apoxi_Wbxml_Vector_hpp : WbxmlVector.hpp
  • APOXI_WCATTR_NULL_DEF : apoxi.defines
  • Apoxi_WildcardStrncmp_hpp : WildcardStrncmp.hpp
  • Apoxi_Win32_hpp : Win32.hpp
  • Apoxi_Win32_SysDnsClient_hpp : Win32SysDnsClient.hpp
  • Apoxi_Win32_SysSocket_hpp : Win32SysSocket.hpp
  • Apoxi_Window_hpp : Window.hpp
  • Apoxi_WindowFrameView_hpp : WindowFrameView.hpp
  • Apoxi_WindowManager_hpp : WindowManager.hpp
  • Apoxi_WinMenuItem_hpp : WinMenuItem.hpp
  • Apoxi_WinRect_hpp : WinRect.hpp
  • APOXI_WSTRING_EXTENDED_DEBUG : apoxi.defines
  • APOXI_WSTRING_TEST_SUITE : WString.hpp, apoxi.defines
  • APOXI_YAMAHA_MAPI_SUPPORT : apoxi.defines
  • APOXI_YAMAHA_RINGER_SUPPORT : apoxi.defines
  • APOXI_ZI8_SUPPORT : apoxi.defines
  • Apoxi_Zi8AlphabetBox_hpp : Zi8AlphabetBox.hpp
  • Apoxi_Zi8InputConfig_hpp : Zi8InputConfig.hpp
  • Apoxi_Zi8InputMapper_hpp : Zi8InputMapper.hpp
  • Apoxi_Zi8PredictiveInputBox_hpp : Zi8PredictiveInputBox.hpp
  • Apoxi_Zi8SelectionBox_hpp : Zi8SelectionBox.hpp
  • Apoxi_Zi8StrokeBox_hpp : Zi8StrokeBox.hpp
  • APOXI_ZLIB_USE_STACK_MEM_FUNCS : apoxi.defines
  • ApoxiAlloc() : Os.cpp
  • ApoxiAllocEx() : Os.cpp
  • ApoxiApp_FfsMenu_hpp : FfsMenu.hpp
  • ApoxiApp_FfsTestBase_hpp : FfsTestBase.hpp
  • ApoxiApp_FfsTestDispWin_hpp : FfsTestDispWin.hpp
  • ApoxiApp_FfsTestError_hpp : FfsTestError.hpp
  • ApoxiApp_FfsTestMenu_hpp : FfsTestMenu.hpp
  • ApoxiApp_FfsTestResultsMenu_hpp : FfsTestResultsMenu.hpp
  • ApoxiApp_FfsTests_hpp : FfsTests.hpp
  • ApoxiApp_FfsTestThread_hpp : FfsTestThread.hpp
  • ApoxiApp_FfsTestThreadlet_hpp : FfsTestThreadlet.hpp
  • ApoxiApp_SocketTestApp_hpp : SocketTestApp.hpp
  • ApoxiApp_SocketTestDefines_hpp : SocketTestDefines.hpp
  • ApoxiApp_SocketTestProgressWin_hpp : SocketTestProgressWin.hpp
  • ApoxiApp_SocketTestResultsWin_hpp : SocketTestResultsWin.hpp
  • ApoxiaPP_SocketTestSettingsWin_hpp : SocketTestSettingsWin.hpp
  • ApoxiApp_SocketTestT1_hpp : SocketTestT1.hpp
  • ApoxiApp_SocketTestT2_hpp : SocketTestT2.hpp
  • ApoxiApp_SocketTestT3_hpp : SocketTestT3.hpp
  • ApoxiApp_SocketTestT4_hpp : SocketTestT4.hpp
  • ApoxiApp_SocketTestT5_hpp : SocketTestT5.hpp
  • ApoxiApp_SocketTestT6_hpp : SocketTestT6.hpp
  • ApoxiApp_SocketTestT7_hpp : SocketTestT7.hpp
  • ApoxiApp_SocketTestT8_hpp : SocketTestT8.hpp
  • ApoxiApp_SocketTestT_hpp : SocketTestT.hpp
  • ApoxiApp_SocketTestTests_hpp : SocketTestTests.hpp
  • ApoxiApp_SocketTestWin_hpp : SocketTestWin.hpp
  • ApoxiApp_TcpServerTestSocket_hpp : TcpServerTestSocket.hpp
  • ApoxiApp_TcpTestSocket_hpp : TcpTestSocket.hpp
  • ApoxiApp_UdpTestSocket_hpp : UdpTestSocket.hpp
  • ApoxiBDigitValue() : StrPrintf.cpp
  • ApoxiBigEndian16BitConstant : MachType.hpp
  • ApoxiBigEndian32BitConstant : MachType.hpp
  • ApoxiCommandActionType : InputAction.hpp
  • ApoxiDDigitValue() : StrPrintf.cpp
  • ApoxiDefineEntity : ValueMap.hpp
  • ApoxiDefineScopeEntity : ValueMap.hpp
  • ApoxiDefVersionInfo : VoiceMemoVersion.cpp, UsbVersion.cpp, UibVersion.cpp, SoundBrowserVersion.cpp, SocketTestVersion.cpp, ObexAppVersion.cpp, IrdaAppVersion.cpp, ImgbrVersion.cpp, FmRadioVersion.cpp, EmsVersion.cpp, DataConnVersion.cpp, ApbVersion.cpp, ApoxiKernelVersion.cpp, ApoxiGuiVersion.cpp, ApoxiAuxiliaryVersion.cpp, ApoxiAscVersion.cpp, ApoxiApcSignalHandlerVersion.cpp, ApoxiApcVersion.cpp, ApoxiAfsVersion.cpp, ApoxiVoiceRecognitionVersion.cpp, ApoxiHttpServerVersion.cpp, ApoxiFtpServerVersion.cpp, ApoxiServerVersion.cpp, MediaFrameworkVersion.cpp, ApoxiAfsRfsVersion.cpp, ApoxiAfsRamVersion.cpp, ApoxiAfsFfsVersion.cpp, ApoxiAfsFatVersion.cpp, ApoxiAdcVersion.cpp, VersionInfo.hpp
  • ApoxiFree() : Os.cpp
  • ApoxiHugeAlloc() : Os.cpp
  • ApoxiHugeAllocEx() : Os.cpp
  • ApoxiHugeFree() : Os.cpp
  • ApoxiHugeRealloc() : Os.cpp
  • ApoxiLib_hpp : ApoxiVersion.hpp, ApoxiLib.hpp
  • ApoxiLittleEndian16BitConstant : MachType.hpp
  • ApoxiLIttleEndian32BitConstant : MachType.hpp
  • ApoxiMakeCountryCode : CountryCodes.hpp
  • ApoxiMimeTypeId : MimeTypeTable.hpp
  • ApoxiNewHandler : Allocator.hpp, Allocator.cpp
  • ApoxiNewHandlerFn : Allocator.hpp
  • ApoxiODigitValue() : StrPrintf.cpp
  • ApoxiRb_DataConnAccessor_hpp : DataConnAccessor.hpp
  • ApoxiRealloc() : Os.cpp
  • ApoxiSendDisplayUpdateFinished() : DefaultDisplay.cpp
  • ApoxiSendDisplayUpdateFinished_dummy() : DefaultDisplay.cpp
  • ApoxiSendGddViewfinderError() : Camera.cpp
  • ApoxiStackAlloc() : Os.cpp
  • ApoxiStackFree() : Os.cpp
  • ApoxiSwap16Bit : MachType.hpp
  • ApoxiSwap32Bit : MachType.hpp
  • ApoxiUseVersionInfo : VoiceMemoApp.cpp, UsbApp.cpp, UibApp.cpp, SoundBrowserApp.cpp, ObexApp.cpp, IrdaApp.cpp, ImageBrowserApp.cpp, FmRadioApplication.cpp, EmsApp.cpp, DataConnApp.cpp, Application.cpp, Window.cpp, String.cpp, MainHandler.cpp, ProcessNode.cpp, MessageImpl.cpp, MediaManager.cpp, DataHandler.cpp, VersionInfo.hpp
  • APOXIVERSION : ApoxiVersion.hpp
  • ApoxiVersionInfo_hpp : VersionInfo.hpp
  • ApoxiXDigitValue() : StrPrintf.cpp
  • App1Tracer : Trace.hpp
  • App1TracerLevel2 : Trace.hpp
  • App1TracerLevel3 : Trace.hpp
  • App2Tracer : Trace.hpp
  • App2TracerLevel2 : Trace.hpp
  • App2TracerLevel3 : Trace.hpp
  • App3Tracer : Trace.hpp
  • App3TracerLevel2 : Trace.hpp
  • App3TracerLevel3 : Trace.hpp
  • App4Tracer : Trace.hpp
  • App4TracerLevel2 : Trace.hpp
  • App4TracerLevel3 : Trace.hpp
  • AppContainerRoutingTable : AppContainerRoutingTable.hpp
  • AppData : SignalTypes.hpp
  • AppDual : SignalTypes.hpp
  • AppElemList : AppContainerRoutingTable.hpp
  • append_text_sample : FfsTests.cpp
  • AppendErr : FfsTestError.hpp
  • APPLICATION_TRACER_HPP : ApplicationTracer.hpp
  • ApplicationError : SignalTypes.hpp
  • ApplicationID : ApplicationID.hpp
  • ApplicationID_hpp : ApplicationID.hpp
  • ApplicationMsg : Message.hpp
  • Applications_AdvPbMsgTypes_hpp : AdvPbMsgTypes.hpp
  • AppRoutingTable : AppRoutingTable.hpp
  • ApprovalSim : SignalTypes.hpp
  • ApprovalSpecialSim : SignalTypes.hpp
  • AppSpeech : SignalTypes.hpp
  • AppStkSpeech : SignalTypes.hpp
  • AppTracer : Trace.hpp
  • AppUnknown : SignalTypes.hpp
  • ARAccepted : BtAvrcpCommandInterface.hpp
  • ARAGON : apoxi.features
  • ARCHIVE : FatSim.hpp
  • ARDONLY : FatSim.hpp
  • ARImplementedStable : BtAvrcpCommandInterface.hpp
  • ARInterim : BtAvrcpCommandInterface.hpp
  • ARInTransition : BtAvrcpCommandInterface.hpp
  • ARNotImplemented : BtAvrcpCommandInterface.hpp
  • ARRejected : BtAvrcpCommandInterface.hpp
  • ARResponseChanged : BtAvrcpCommandInterface.hpp
  • Asc_AccDispatcher_hpp : AccDispatcher.hpp
  • Asc_AccHandler_hpp : AccHandler.hpp
  • Asc_AdcInterface_hpp : AdcInterface.hpp
  • Asc_AocDispatcher_hpp : AocDispatcher.hpp
  • Asc_AocHandler_hpp : AocHandler.hpp
  • Asc_AtcDispatcher_hpp : AtcDispatcher.hpp
  • Asc_AtcHandler_hpp : AtcHandler.hpp
  • Asc_BattHandler_hpp : BattHandler.hpp
  • Asc_BootDispatcher_hpp : BootDispatcher.hpp
  • Asc_BootHandler_hpp : BootHandler.hpp
  • Asc_CallBarringHandler_hpp : CallBarringHandler.hpp
  • Asc_CallControlHandler_hpp : CallControlHandler.hpp
  • Asc_CallDeflectionHandler_hpp : CallDeflectionHandler.hpp
  • Asc_CallForwardingHandler_hpp : CallForwardingHandler.hpp
  • Asc_CallHandler_hpp : CallHandler.hpp
  • Asc_CallHandlingData_hpp : CallHandlingData.hpp
  • Asc_CallHdl_hpp : CallHdl.hpp
  • Asc_CallHdlBase_hpp : CallHdlBase.hpp
  • Asc_CallWaitingHandler_hpp : CallWaitingHandler.hpp
  • Asc_CbsDispatcher_hpp : CbsDispatcher.hpp
  • Asc_CbsFilterList_hpp : CbsFilterList.hpp
  • Asc_CbsHandler_hpp : CbsHandler.hpp
  • Asc_CbsStartDispatcher_hpp : CbsStartDispatcher.hpp
  • Asc_CbsStopDispatcher_hpp : CbsStopDispatcher.hpp
  • Asc_ChrHandler_hpp : ChrHandler.hpp
  • Asc_ClipHandler_hpp : ClipHandler.hpp
  • Asc_ClirHandler_hpp : ClirHandler.hpp
  • Asc_CnapHandler_hpp : CnapHandler.hpp
  • Asc_ColpHandler_hpp : ColpHandler.hpp
  • Asc_ColrHandler_hpp : ColrHandler.hpp
  • Asc_CrssHandler_hpp : CrssHandler.hpp
  • Asc_DataCall_DataCallContext_hpp : DataCallContext.hpp
  • Asc_DataCall_DataCallHdl_hpp : DataCallHdl.hpp
  • Asc_DataCall_DataCallTypes_hpp : DataCallTypes.hpp
  • Asc_DataCall_hpp : DataCall.hpp
  • Asc_EmlppHandler_hpp : EmlppHandler.hpp
  • Asc_Gprs_PlmnDispatcher_gprs_hpp : PlmnDispatcher.hpp
  • Asc_Gprs_PlmnScanDispatcher_gprs_hpp : PlmnScanDispatcher.hpp
  • Asc_HandlerData_hpp : HandlerData.hpp
  • Asc_HandlerFactory_hpp : HandlerFactory.hpp
  • Asc_HandlerId_hpp : HandlerId.hpp
  • Asc_HandlerList_hpp : HandlerList.hpp
  • Asc_Host_DataCallSignalProcessor_hpp : DataCallSignalProcessor.hpp
  • Asc_Host_ValueMap_hpp : ValueMap.hpp
  • Asc_InputParserTranslator_hpp : InputParserTranslator.hpp
  • Asc_Lib_hpp : Lib.hpp
  • Asc_MainHandler_hpp : MainHandler.hpp
  • Asc_MainHandlerAccess_hpp : MainHandlerAccess.hpp
  • Asc_MobileOriginatedUssdHandler_hpp : MobileOriginatedUssdHandler.hpp
  • Asc_MocVoiceHandler_hpp : MocVoiceHandler.hpp
  • Asc_MptyCallHdl_hpp : MptyCallHdl.hpp
  • Asc_MsgArgs_hpp : MsgArgs.hpp
  • Asc_MtcVoiceHandler_hpp : MtcVoiceHandler.hpp
  • Asc_MultiSlotDispatcher_hpp : MultiSlotDispatcher.hpp
  • Asc_MultiSlotHandler_hpp : MultiSlotHandler.hpp
  • Asc_NetworkDispatcher_hpp : NetworkDispatcher.hpp
  • Asc_NetworkHandler_hpp : NetworkHandler.hpp
  • Asc_PdpContext_hpp : PdpContext.hpp
  • Asc_PdpContextControl_hpp : PdpContextControl.hpp
  • Asc_PdpContextManager_hpp : PdpContextManager.hpp
  • Asc_PdpContextManagerControl_hpp : PdpContextManagerControl.hpp
  • Asc_PlmnHandler_hpp : PlmnHandler.hpp
  • Asc_PlmnRatDispatcher_hpp : PlmnRatDispatcher.hpp
  • Asc_PortHeaderInformation_hpp : PortHeaderInformation.hpp
  • Asc_PowerDispatcher_hpp : PowerDispatcher.hpp
  • Asc_PowerDownDispatcher_hpp : PowerDownDispatcher.hpp
  • Asc_PowerHandler_hpp : PowerHandler.hpp
  • Asc_PppFrame_hpp : PppFrame.hpp
  • Asc_RtcHandler_hpp : RtcHandler.hpp
  • Asc_SigDispatcher_hpp : SigDispatcher.hpp
  • Asc_SigHandler_hpp : SigHandler.hpp
  • Asc_SimDispatcher_hpp : SimDispatcher.hpp
  • Asc_SimHandler_hpp : SimHandler.hpp
  • Asc_SimTkHandler_hpp : SimTkHandler.hpp
  • Asc_SmsContext_hpp : SmsContext.hpp
  • Asc_SmsDispatcher_hpp : SmsDispatcher.hpp
  • Asc_SmsFactory_hpp : SmsFactory.hpp
  • Asc_SmsHandler_hpp : SmsHandler.hpp
  • Asc_SmsSendDispatcher_hpp : SmsSendDispatcher.hpp
  • Asc_SmsSendProtector_hpp : SmsSendProtector.hpp
  • Asc_SmsSocket_hpp : SmsSocket.hpp
  • Asc_SmsSocketListener_hpp : SmsSocketListener.hpp
  • Asc_SmsSocketSignalMapTable_hpp : SmsSocketSignalMapTableNode.hpp
  • Asc_SsBaseHandler_hpp : SsBaseHandler.hpp
  • Asc_SsCcbsDispatcher_hpp : SsCcbsDispatcher.hpp
  • Asc_SsCcbsHandler_hpp : SsCcbsHandler.hpp
  • Asc_SsClHandler_hpp : SsClHandler.hpp
  • Asc_SsDispatcher_hpp : SsDispatcher.hpp
  • Asc_SsHandler_hpp : SsHandler.hpp
  • Asc_SsMainHandler_hpp : SsMainHandler.hpp
  • Asc_SsMessage_hpp : SsMessage.hpp
  • Asc_SsStackMsgArgument_hpp : SsStackMsgArgument.hpp
  • Asc_SsWaitDispatcher_hpp : SsWaitDispatcher.hpp
  • Asc_StackControl_hpp : StackControl.hpp
  • Asc_StackIndicationMsgTypes_hpp : StackIndicationMsgTypes.hpp
  • Asc_StackMsgActiveWaitDispatcher_hpp : StackMsgActiveWaitDispatcher.hpp
  • Asc_StackMsgDispatcher_hpp : StackMsgDispatcher.hpp
  • Asc_StatusDispatcher_hpp : StatusDispatcher.hpp
  • Asc_SupplementaryServiceAction_hpp : SupplementaryServiceAction.hpp
  • Asc_Target_DataCallSignalMapTable_hpp : DataCallSignalMapTableNode.hpp
  • Asc_Target_DataCallSignalProcessor_hpp : DataCallSignalProcessor.hpp
  • Asc_Target_Gprs_AudioSignalMapTable_hpp : AudioSignalMapTableNode.hpp
  • Asc_Target_PdpContextSignalMapTable_hpp : PdpContextSignalMapTableNode.hpp
  • Asc_Target_PdpContextSignalProcessor_hpp : PdpContextSignalProcessor.hpp
  • Asc_Target_TypeDef_hpp : ValueMap.hpp
  • Asc_TipdBasedActiveWaitDispatcher_hpp : TipdBasedActiveWaitDispatcher.hpp
  • Asc_TtyInterface_hpp : TtyInterface.hpp
  • Asc_Types_hpp : Types.hpp
  • Asc_UssdHandler_hpp : UssdHandler.hpp
  • Asc_UusHandler_hpp : UusHandler.hpp
  • Asc_ValueMap_hpp : ValueMap.hpp
  • AscDataCallControl : DataCallControl.hpp
  • AscTracer : Trace.hpp
  • AscTracerLevel2 : Trace.hpp
  • AscTracerLevel3 : Trace.hpp
  • ASSERT : Macros.hpp
  • ASSERT_ALWAYS : Macros.hpp
  • ASSERT_DEBUG : Macros.hpp
  • ASSERT_DEBUG_HOST : SetPixel_16Bpp.cpp, FillRect_Planes.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_Planes.cpp, BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp, Macros.hpp
  • ASSERT_DEBUG_INFO : Macros.hpp
  • ASSERT_INFO : Macros.hpp
  • assistance_data : LcsTypes.hpp
  • assisted_gps : LcsDecls.hpp
  • ASYSTEM : FatSim.hpp
  • AT_MMI_INTERWORKING : apoxi.features
  • AtcClient : SignalTypes.hpp
  • AtcFclassNotSpeech : SignalTypes.hpp
  • AtcHandlerId : HandlerId.hpp
  • ATI : apoxi.features
  • AtiAudioCapturerEncoder_hpp : AtiAudioCapturerEncoder.hpp
  • AtiAudioDecoderRenderer_hpp : AtiAudioDecoderRenderer.hpp
  • AtiCodecsLib_hpp : AtiCodecsLib.hpp
  • AtiConfig_hpp : AtiConfig.hpp
  • AtiMpeg4Decoder_hpp : AtiMpeg4Decoder.hpp
  • AtiMpeg4Encoder_hpp : AtiMpeg4Encoder.hpp
  • AtiUtils_hpp : AtiUtils.hpp
  • ATL : apoxi.features
  • Atl_AtlApplication_hpp : AtlApplication.hpp
  • Atl_AtlConfig_hpp : AtlConfig.hpp
  • Atl_AtlItemGrid_hpp : AtlItemGrid.hpp
  • Atl_AtlItemMenu_hpp : AtlItemMenu.hpp
  • Atl_AtlItemRenderer_hpp : AtlItemRenderer.hpp
  • Atl_AtlMsgTypes_hpp : AtlMsgTypes.hpp
  • Atl_AtlPropertyEditor_hpp : AtlPropertyEditor.hpp
  • Atl_AtlWindow_hpp : AtlWindow.hpp
  • Atl_Context_ContextDescription_hpp : ContextDescription.hpp
  • Atl_Context_ContextFeatureHandle_hpp : ContextFeatureHandle.hpp
  • Atl_Context_ContextManager_hpp : ContextManager.hpp
  • Atl_Context_ContextTable_hpp : ContextTable.hpp
  • Atl_Context_ContextTableNode_hpp : ContextTableNode.hpp
  • Atl_Context_KeyManager_hpp : KeyManager.hpp
  • Atl_Context_KeyMapping_hpp : KeyMapping.hpp
  • Atl_Context_KeySequence_hpp : KeySequence.hpp
  • Atl_Context_MenuDesc_hpp : MenuDesc.hpp
  • Atl_Context_MenuDescObj_hpp : MenuDescObj.hpp
  • Atl_Context_MenuProperties_hpp : MenuProperties.hpp
  • Atl_Context_SoftkeyDesc_hpp : SoftkeyDesc.hpp
  • Atl_Features_AppFeatureID_hpp : AppFeatureID.hpp
  • Atl_Features_FeatureBroker_hpp : FeatureBroker.hpp
  • Atl_Features_FeatureHandle_hpp : FeatureHandle.hpp
  • Atl_Features_FeaturePool_hpp : FeaturePool.hpp
  • Atl_Features_ItemObj_hpp : ItemObj.hpp
  • Atl_Features_MenuIdObj_hpp : MenuIdObj.hpp
  • Atl_Gui_AtlItemGridWindow_hpp : AtlItemGridWindow.hpp
  • Atl_Gui_AtlItemListWindow_hpp : AtlItemListWindow.hpp
  • Atl_Gui_AtlItemMenuWindow_hpp : AtlItemMenuWindow.hpp
  • Atl_Gui_AtlLabelListWindow_hpp : AtlLabelListWindow.hpp
  • Atl_Gui_ImgObtObj_hpp : ImgObtObj.hpp
  • Atl_Gui_Indicator_Description_hpp : IndicatorDescription.hpp
  • Atl_Gui_Indicator_hpp : Indicator.hpp
  • Atl_Gui_IndicatorBarID_hpp : IndicatorBarID.hpp
  • Atl_Gui_IndicatorID_hpp : IndicatorID.hpp
  • Atl_Gui_IndicatorPaneObject_hpp : IndicatorPaneObject.hpp
  • Atl_Gui_ItemLabel_hpp : ItemLabel.hpp
  • Atl_IdentifierHandler_hpp : IdentifierHandler.hpp
  • Atl_MenuPool_hpp : MenuPool.hpp
  • Atl_MenuTable_hpp : MenuTable.hpp
  • Atl_MenuTableNode_hpp : MenuTableNode.hpp
  • Atl_PropertyEditor_hpp : PropertyEditor.hpp
  • Atl_PropertyEditorFactory_hpp : PropertyEditorFactory.hpp
  • AtlApplicationPlugin_hpp : AtlApplicationPlugin.hpp
  • AtlApplicationPluginStartup_hpp : AtlApplicationPluginStartup.hpp
  • AtlPropertyEditor : AtlPropertyEditor.hpp
  • AtNotRegistered : NetworkTypes.hpp
  • ATOM_ALL_BITS : Ddrv.cpp
  • atom_bit : SetPixel_Planes.cpp, GetPixelColor_Planes.cpp
  • atom_brushstyle_bits : FillRect_Planes.cpp
  • ATOM_LEFT_BIT : Ddrv.cpp
  • AtomBit() : Ddrv.cpp
  • AtomLeftBits() : Ddrv.cpp
  • AtomRightBits() : Ddrv.cpp
  • atoms_per_scanline : DrawChar_Planes.cpp, DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp
  • AtomShift() : Ddrv.cpp
  • AtStatusBusy : AtcTypes.hpp
  • AtStatusCommitSignal : AtcTypes.hpp
  • AtStatusError : AtcTypes.hpp
  • AtStatusNoAnswer : AtcTypes.hpp
  • AtStatusNoCarrier : AtcTypes.hpp
  • AtStatusSignalNotExpected : AtcTypes.hpp
  • AtStatusSignalNotHandled : AtcTypes.hpp
  • AtStatusSuccess : AtcTypes.hpp
  • AtStatusSuccessNoOutput : AtcTypes.hpp
  • AtStatusType : AtcTypes.hpp
  • AtStatusUnsolicitedResult : AtcTypes.hpp
  • ATTENUM : parsifal.cpp
  • AttrGetCase() : WCattr.cpp
  • AttrGetCaseFlags() : WCattr.cpp
  • AttrGetCompFlags() : WCattr.cpp
  • AttrGetDecomp() : WCattr.cpp
  • AttrGetIdx() : WCattr.cpp
  • AttrGetType() : WCattr.cpp
  • AUD_add_downlinkpath() : aud_drv.cpp
  • AUD_add_uplinkpath() : aud_drv.cpp
  • AUD_allocate_resource() : aud_drv.cpp
  • AUD_amp_disable() : aud_drv.cpp
  • AUD_amp_enable() : aud_drv.cpp
  • AUD_DBG_NR : AudioDef.hpp
  • AUD_DBG_OUT : AudioDef.hpp
  • aud_drv_check_timeout() : aud_drv.cpp
  • aud_drv_restart_hf() : aud_drv.cpp
  • aud_drv_tst_buzzer_melody() : aud_drv.cpp
  • aud_drv_tst_buzzer_tone() : aud_drv.cpp
  • aud_drv_tst_buzzer_tune() : aud_drv.cpp
  • aud_drv_tst_dsp_parm_ready() : aud_drv.cpp
  • aud_drv_tst_external_devices() : aud_drv.cpp
  • aud_drv_tst_read_dsp_audio_parms() : aud_drv.cpp
  • aud_drv_tst_set_audio_parm() : aud_drv.cpp
  • aud_drv_tst_start_testing_poly_tone_chip() : aud_drv.cpp
  • aud_drv_tst_stop_testing_poly_tone_chip() : aud_drv.cpp
  • AUD_get_downlnk_parallel_path_configuration() : aud_drv.cpp
  • AUD_get_uplink_parallel_path_configuration() : aud_drv.cpp
  • AUD_info_driver_status() : aud_drv.cpp
  • AUD_info_hw_available() : aud_drv.cpp
  • AUD_init() : aud_drv.cpp
  • AUD_mapi() : aud_drv.cpp
  • AUD_MASTER_VOLUME_CONCEPT : apoxi.features
  • AUD_misc_set_accessory() : aud_drv.cpp
  • AUD_misc_set_vmic() : aud_drv.cpp
  • AUD_mp3_backward() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_mp3_fastforward() : HostAudioDriver.cpp, aud_drv.cpp
  • Aud_mp3_get_buffer_function() : aud_drv.cpp
  • Aud_mp3_get_current_frame() : HostAudioDriver.cpp
  • AUD_mp3_get_play_position() : HostAudioDriver.cpp
  • AUD_mp3_get_total_playtime() : HostAudioDriver.cpp
  • AUD_mp3_pause() : aud_drv.cpp
  • AUD_mp3_resume() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_mp3_seek() : aud_drv.cpp
  • AUD_mp3_set() : aud_drv.cpp
  • Aud_mp3_set_getbuffer_function() : HostAudioDriver.cpp
  • AUD_mp3_set_play_position() : HostAudioDriver.cpp
  • AUD_mp3_set_volume() : aud_drv.cpp
  • AUD_mp3_start() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_mp3_stop() : HostAudioDriver.cpp
  • AUD_mp3_stop_suspend() : HostAudioDriver.cpp
  • AUD_mp3_suspend() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_mute_master() : aud_drv.cpp
  • AUD_mute_resource() : aud_drv.cpp
  • AUD_pcm_intern_get_play_position() : aud_drv.cpp
  • AUD_pcm_intern_get_total_playtime() : aud_drv.cpp
  • AUD_pcm_intern_getbuffer_function() : HostAudioDriver.cpp
  • AUD_pcm_intern_resume() : aud_drv.cpp
  • AUD_pcm_intern_set_play_position() : aud_drv.cpp
  • AUD_pcm_intern_start_playback() : HostAudioDriver.cpp
  • AUD_pcm_intern_start_recording() : HostAudioDriver.cpp
  • AUD_pcm_intern_stop_playback() : HostAudioDriver.cpp
  • AUD_pcm_intern_stop_recording() : HostAudioDriver.cpp
  • AUD_pcm_intern_suspend() : aud_drv.cpp
  • AUD_radio_disable() : aud_drv.cpp
  • AUD_radio_enable() : aud_drv.cpp
  • AUD_radio_rds_subscribe() : aud_drv.cpp
  • AUD_radio_rssi_subscribe() : aud_drv.cpp
  • AUD_radio_set_station() : aud_drv.cpp
  • aud_rc_ram_buffer_used : StreamAudioPlayer.cpp
  • aud_rc_recording_finish : StreamAudioPlayer.cpp
  • aud_rc_user_message : AudioDeviceManager.cpp
  • AUD_release_resource() : aud_drv.cpp
  • AUD_remove_downlinkpath() : aud_drv.cpp
  • AUD_remove_uplinkpath() : aud_drv.cpp
  • AUD_ringer_get_playposition() : aud_drv.cpp
  • AUD_ringer_get_total_playtime() : aud_drv.cpp
  • AUD_ringer_resume() : aud_drv.cpp
  • AUD_ringer_set_channel_volume() : aud_drv.cpp
  • AUD_ringer_set_playposition() : aud_drv.cpp
  • AUD_ringer_set_volume() : aud_drv.cpp
  • AUD_ringer_start() : aud_drv.cpp
  • AUD_ringer_start_user_tone() : aud_drv.cpp
  • AUD_ringer_stop() : aud_drv.cpp
  • AUD_ringer_stop_suspend() : aud_drv.cpp
  • AUD_ringer_suspend() : aud_drv.cpp
  • AUD_set_EC_NR() : aud_drv.cpp
  • AUD_set_master_volume() : aud_drv.cpp
  • AUD_set_resource_volume() : aud_drv.cpp
  • AUD_set_volume() : aud_drv.cpp
  • AUD_speech_disable() : aud_drv.cpp
  • AUD_speech_enable() : aud_drv.cpp
  • AUD_speech_mute() : aud_drv.cpp
  • AUD_speech_set_volume() : aud_drv.cpp
  • aud_tone_alarm_1_data : Audio.cpp
  • AUD_tone_get_play_position() : aud_drv.cpp
  • AUD_tone_get_total_playtime() : aud_drv.cpp
  • AUD_tone_resume() : aud_drv.cpp
  • AUD_tone_set_play_position() : aud_drv.cpp
  • AUD_tone_start() : aud_drv.cpp
  • AUD_tone_start_user_tone() : aud_drv.cpp
  • AUD_tone_stop() : aud_drv.cpp
  • AUD_tone_suspend() : aud_drv.cpp
  • AUD_tst_set_dai() : aud_drv.cpp
  • AUD_vibrator_start() : aud_drv.cpp
  • AUD_vibrator_stop() : aud_drv.cpp
  • AUD_vm_get_play_position() : aud_drv.cpp
  • AUD_vm_get_total_playtime() : aud_drv.cpp
  • AUD_vm_resume() : aud_drv.cpp
  • AUD_vm_set_play_position() : aud_drv.cpp
  • AUD_vm_start_playback() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_vm_start_recording() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_vm_stop_playback() : HostAudioDriver.cpp
  • AUD_vm_stop_recording() : HostAudioDriver.cpp
  • AUD_vm_suspend() : aud_drv.cpp
  • Aud_vms_set_getbuffer_function() : HostAudioDriver.cpp
  • AudCmd : HostAudioDriver.hpp
  • AUDIO_DBG_CRIT : AudioPriorityManager.cpp
  • AUDIO_DBG_EVT : AudioPriorityManager.cpp
  • AUDIO_DBG_PM_LOGIC : AudioPriorityManager.cpp
  • AUDIO_DEVICE : BtAvrcpControllerApplicationWindows.cpp
  • AudioDef_hpp : AudioDef.hpp
  • AudioDevice : SignalTypes.hpp
  • AudioGetMutex() : audio_private.hpp, audio_private.cpp
  • AudioPmAutomaticResume() : AudioPriorityManager.cpp
  • AudioToneType : SignalTypes.hpp
  • AuthProviderPtr : AuthProvider.hpp
  • AuthType : DataConnTextMaps.hpp
  • Automatic : NetworkTypes.hpp
  • AutomaticFacsimileGroup3 : SignalTypes.hpp
  • Auxiliary_BinData_hpp : BinData.hpp
  • Auxiliary_BinDataDataSource_hpp : BinDataDataSource.hpp
  • Auxiliary_BinDataOwner_hpp : BinDataOwner.hpp
  • Auxiliary_BitField_hpp : BitField.hpp
  • Auxiliary_BufferedData_hpp : BufferedData.hpp
  • Auxiliary_ByteBuffer_hpp : ByteBuffer.hpp
  • Auxiliary_CachingSortProvider_hpp : CachingSortProvider.hpp
  • Auxiliary_ChildBinData_hpp : ChildBinData.hpp
  • Auxiliary_ChineseQuickSortProvider_hpp : ChineseQuickSortProvider.hpp
  • Auxiliary_DataSink_hpp : DataSink.hpp
  • Auxiliary_DataSource_hpp : DataSource.hpp
  • Auxiliary_DataSourceBinData_hpp : DataSourceBinData.hpp
  • Auxiliary_DbgDataDump_hpp : DbgDump.hpp
  • Auxiliary_ElementList_hpp : ElementList.hpp
  • Auxiliary_HeapDataSource_hpp : HeapDataSource.hpp
  • Auxiliary_ImageObtainerDataSource_hpp : ImageObtainerDataSource.hpp
  • Auxiliary_Lib_hpp : Lib.hpp
  • Auxiliary_MainProvider_hpp : MainProvider.hpp
  • Auxiliary_Map_hpp : Map.hpp
  • Auxiliary_MessageFactory_hpp : MessageFactory.hpp
  • Auxiliary_NonsharedBinDataDataSource_hpp : NonsharedBinDataDataSource.hpp
  • Auxiliary_RamData_hpp : RamData.hpp
  • Auxiliary_RomData_hpp : RomData.hpp
  • Auxiliary_TypeOfAddress_hpp : TypeOfAddress.hpp
  • Auxiliary_Unicode_hpp : Unicode.hpp
  • AuxiliarySpeech : SignalTypes.hpp
  • AuxTracer : Trace.hpp
  • AuxTracerLevel2 : Trace.hpp
  • AuxTracerLevel3 : Trace.hpp
  • AVOLUME : FatSim.hpp
  • AvrcpCommand : BtAvrcpCommandInterface.hpp
  • AvrcpResponse : BtAvrcpCommandInterface.hpp
Generated on Wed Jan 25 02:31:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • B00000001 : DrawChar_16Bpp.cpp
  • B00000010 : DrawChar_16Bpp.cpp
  • B00000100 : DrawChar_16Bpp.cpp
  • B00001000 : DrawChar_16Bpp.cpp
  • B00010000 : DrawChar_16Bpp.cpp
  • B00100000 : DrawChar_16Bpp.cpp
  • B01000000 : DrawChar_16Bpp.cpp
  • B10000000 : DrawChar_16Bpp.cpp
  • BaAoVendorUnique : BtTypes.hpp
  • BackToIdleFeature_hpp : BackToIdleFeature.hpp
  • BackwardMove : SimTkTypes.hpp
  • Baic : SignalTypes.hpp
  • Baoc : SignalTypes.hpp
  • BarringOfIncomingCalls : SignalTypes.hpp
  • BarringOfOutgoingCalls : SignalTypes.hpp
  • BarringSsActionType : InputAction.hpp
  • Base : ExtndServiceThreadForNetwork.cpp
  • BASE_10 : LcsUtils.cpp
  • BatteryLoadLevel : SignalTypes.hpp
  • BcdByteToInt() : ValidityPeriod.hpp
  • BCDConversionNibble : PhoneNumber.hpp
  • BcdMcc : NetworkTypes.hpp
  • BcdMnc : NetworkTypes.hpp
  • BdnEfPos : SimTkTypes.hpp
  • BdnFailed : SignalTypes.hpp
  • BdnNotPossible : NetworkTypes.hpp
  • BdnOff : NetworkTypes.hpp
  • BdnOn : NetworkTypes.hpp
  • BdnPhoneBook : SignalTypes.hpp
  • BdnPhoneBookCnt : SignalTypes.hpp
  • BdnState : NetworkTypes.hpp
  • BdPhoneBook : AtcTypes.hpp
  • BearerCapabilityNotAllowed : SignalTypes.hpp
  • BearerCapabilityNotAvailable : SignalTypes.hpp
  • BearerChange : SignalTypes.hpp
  • BearerIndependentProtocolError : SimTkTypes.hpp
  • BearerIndependentProtocolErrorChannelClosed : SimTkTypes.hpp
  • BearerIndependentProtocolErrorChannelIdentifierNotValid : SimTkTypes.hpp
  • BearerIndependentProtocolErrorNoChannelAvailable : SimTkTypes.hpp
  • BearerIndependentProtocolErrorRequestedBufferSizeNotAvailable : SimTkTypes.hpp
  • BearerService : SignalTypes.hpp
  • BearerServiceNotImplemented : SignalTypes.hpp
  • BEGIN_STATE_MAP : StateMachine.hpp
  • BEGIN_TRANSITION_MAP : StateMachine.hpp
  • Behavior : ScrollBehavior.hpp
  • Behaviour : Grid.hpp
  • Between() : Types.hpp
  • BicRoam : SignalTypes.hpp
  • BinarySearch() : BinarySearch.hpp
  • BIP_IMG_HDL_SIZE : BtBipTypes.hpp
  • BipCallError : BtBipTypes.hpp
  • BipContinue : BtBipTypes.hpp
  • BipImagePull : BtBipTypes.hpp
  • BipImagePush : BtBipTypes.hpp
  • BipInvalidSessionId : BtBipTypes.hpp
  • BipObexFailed : BtBipTypes.hpp
  • BipOk : BtBipTypes.hpp
  • BipPadaptFailed : BtBipTypes.hpp
  • BipPartialContent : BtBipTypes.hpp
  • BipPutImageRsp_hpp : BtBipPutImageRsp.hpp
  • BipSdapFailed : BtBipTypes.hpp
  • BitField16 : BitField.hpp
  • BitField32 : BitField.hpp
  • BitField8 : BitField.hpp
  • bitmap : SetPixel_Planes.cpp, ScrollVertical_Planes.cpp, ScrollHorizontal_Planes.cpp, FillRect_Planes.cpp
  • BITS_PRO_BYTE : StillCamera.cpp
  • BITS_PRO_JPEG_PIXEL : StillCamera.cpp
  • black_and_white_theme : BlackAndWhiteTheme.hpp, BlackAndWhiteTheme.cpp
  • BlacklistFullNoAutoCallAttempts : SignalTypes.hpp
  • BLOCK_HEAP_CONTEXT_VECTOR : HeapVector.hpp
  • BLOCK_HEAP_PAGE : HeapVector.hpp
  • BLOCK_HEAP_SIZE_VECTOR : HeapVector.hpp
  • Blocked : SignalTypes.hpp
  • BlockPageTest() : HeapManager.cpp
  • BLOCKS_PER_LINE_TRACE : HeapVector.cpp
  • BlockScrollBehavior : ScrollBehavior.hpp
  • BlockScrollBehaviour : Grid.hpp
  • blue_exp_2 : ConvertToColorValue_Planes.cpp
  • blue_sky_chinese_theme : BlueSkyChineseTheme.hpp, BlueSkyChineseTheme.cpp
  • blue_sky_theme : BlueSkyTheme.hpp, BlueSkyTheme.cpp
  • BLUETOOTH : apoxi.features
  • Bluetooth_AVRCP_BtAvrcpNotificationMessageArgument_hpp : BtAvrcpNotificationMessageArgument.hpp
  • Bluetooth_AVRCP_BtAvrcpOperationServiceMessageArgument_hpp : BtAvrcpOperationServiceMessageArgument.hpp
  • Bluetooth_BIP_BtBipServerNotificationMsgArg_hpp : BtBipNotificationMsgArg.hpp
  • Bluetooth_BtApplicationMessage_hpp : BtApplicationMessage.hpp
  • Bluetooth_BtAvrcpMessageArguments_hpp : BtAvrcpMessageArguments.hpp
  • Bluetooth_BtAvrcpServiceMessage_hpp : BtAvrcpServiceMessage.hpp
  • Bluetooth_BtBipMsgArg_hpp : BtBipMsgArg.hpp
  • Bluetooth_BtBipServiceMsg_hpp : BtBipServiceMsg.hpp
  • Bluetooth_BtBppServiceMessage_hpp : BtBppServiceMessage.hpp
  • Bluetooth_BtDunApplicationMessage_hpp : BtDunApplicationMessage.hpp
  • Bluetooth_BtDunServiceMessage_hpp : BtDunServiceMessage.hpp
  • Bluetooth_BtFaxApplicationMessage_hpp : BtFaxApplicationMessage.hpp
  • Bluetooth_BtFaxServiceMessage_hpp : BtFaxServiceMessage.hpp
  • Bluetooth_BtGapAndSdapApplicationMessage_hpp : BtGapAndSdapApplicationMessage.hpp
  • Bluetooth_BtGapAndSdapRequestMessage_hpp : BtGapAndSdapRequestMessage.hpp
  • Bluetooth_BtHfMessageArguments_hpp : BtHfMessageArguments.hpp
  • Bluetooth_BtHfServiceMessage_hpp : BtHfServiceMessage.hpp
  • Bluetooth_BtHsMessageArguments_hpp : BtHsMessageArguments.hpp
  • Bluetooth_BtHsServiceMessage_hpp : BtHsServiceMessage.hpp
  • Bluetooth_BtObexMessageArguments_hpp : BtObexMessageArguments.hpp
  • Bluetooth_BtObexServiceMessage_hpp : BtObexServiceMessage.hpp
  • Bluetooth_BtRequestMessage_hpp : BtRequestMessage.hpp
  • Bluetooth_BtRequestOperationMessage_hpp : BtRequestOperationMessage.hpp
  • Bluetooth_BtSddbServiceMessage_hpp : BtSddbServiceMessage.hpp
  • Bluetooth_BtServiceMessage_hpp : BtServiceMessage.hpp
  • Bluetooth_Dun_Lib_hpp : Lib.hpp
  • Bluetooth_Fax_Lib_hpp : Lib.hpp
  • Bluetooth_HF_BtHfControllerMessageArgument_hpp : BtHfControllerMessageArgument.hpp
  • Bluetooth_HF_BtHfNotificationMessageArgument_hpp : BtHfNotificationMessageArgument.hpp
  • Bluetooth_Hf_Lib_hpp : Lib.hpp
  • Bluetooth_HS_BtHsControllerMessageArgument_hpp : BtHsControllerMessageArgument.hpp
  • Bluetooth_HS_BtHsNotificationMessageArgument_hpp : BtHsNotificationMessageArgument.hpp
  • Bluetooth_Hs_Lib_hpp : Lib.hpp
  • Bluetooth_Lib_hpp : Lib.hpp
  • Bluetooth_OBEX_BtObexNotificationMessageArgument_hpp : BtObexNotificationMessageArgument.hpp
  • Bluetooth_Obex_Lib_hpp : Lib.hpp
  • BMP_BITFIELD : BmpDecoder.cpp
  • BMP_FILE_HEADER_SIZE : BmpDecoder.cpp
  • BMP_INFO_HEADER_SIZE : BmpDecoder.cpp
  • BMP_RGB : BmpDecoder.cpp
  • BMP_RLE4 : BmpDecoder.cpp
  • BMP_RLE8 : BmpDecoder.cpp
  • bmp_width : BitBlit_16Bpp.cpp
  • Boic : SignalTypes.hpp
  • BoicExHc : SignalTypes.hpp
  • BOOL : FfsSim.hpp, FatSim.hpp
  • BOOLEAN : WinInc.hpp, NucInc.hpp
  • BooleanType : DataItem.hpp
  • BootFinishedNotification : Types.hpp
  • BootHandlerId : HandlerId.hpp
  • BootLoadNotification : Types.hpp
  • BootNoRequest : Types.hpp
  • BootNotAvailable : Types.hpp
  • BootNotification : Types.hpp
  • bottom : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • BottomReachedRepaintHint : Grid.hpp
  • BppBuffSize : BtBppTypes.hpp
  • BppCallError : BtBppTypes.hpp
  • BppContinue : BtBppTypes.hpp
  • BppObexBadRequest : BtBppTypes.hpp
  • BppObexContinue : BtBppTypes.hpp
  • BppObexFailed : BtBppTypes.hpp
  • BppObexForbidden : BtBppTypes.hpp
  • BppObexHeaderFailed : BtBppTypes.hpp
  • BppObexNotAcceptable : BtBppTypes.hpp
  • BppObexNotFound : BtBppTypes.hpp
  • BppObexNotImplemented : BtBppTypes.hpp
  • BppObexOk : BtBppTypes.hpp
  • BppObexPartialContent : BtBppTypes.hpp
  • BppObexPreconditionFailed : BtBppTypes.hpp
  • BppObexServiceUnavailable : BtBppTypes.hpp
  • BppObexUnauthorised : BtBppTypes.hpp
  • BppObexUndefined : BtBppTypes.hpp
  • BppObjectTypeEnum : BtBppTypes.hpp
  • BppOk : BtBppTypes.hpp
  • BppPadaptFailed : BtBppTypes.hpp
  • BppSdapFailed : BtBppTypes.hpp
  • BppUnauthenticated : BtBppTypes.hpp
  • broadcast_tone_1_data : Audio.cpp
  • broadcast_tone_2_data : Audio.cpp
  • broadcast_tone_3_data : Audio.cpp
  • broadcast_tone_4_data : Audio.cpp
  • BrushStyle : Brush.hpp
  • BT_AA_INVALID_VOLUME_LEVEL : BtAudioAccessoryService.hpp
  • Bt_Application_hpp : BtApplication.hpp
  • bt_c_empty_device_address : BtDeviceAddress.hpp, BtDeviceAddress.cpp
  • bt_c_empty_device_list : BtDeviceList.hpp
  • bt_c_unknown_device : BtDevice.hpp, BtDevice.cpp
  • Bt_Constants_hpp : BtConstants.hpp
  • bt_device_address_generic_object_type_id : BtDeviceListsWindows.cpp
  • bt_device_list_address_column_id : BtDeviceListsWindows.cpp
  • bt_device_list_device_major_class_column_id : BtDeviceListsWindows.cpp
  • bt_device_list_device_minor_class_column_id : BtDeviceListsWindows.cpp
  • bt_device_list_name_column_id : BtDeviceListsWindows.cpp
  • bt_device_list_provider_id : BtDeviceListsWindows.cpp
  • Bt_Hf_Types_hpp : BtTypes.hpp
  • Bt_Hs_Types_hpp : BtTypes.hpp
  • BT_MDC_AUDIO_VIDEO : BtConstants.hpp
  • BT_MDC_COMPUTER : BtConstants.hpp
  • BT_MDC_IMAGING : BtConstants.hpp
  • BT_MDC_LAN : BtConstants.hpp
  • BT_MDC_MASK : BtConstants.hpp
  • BT_MDC_PERIPHERAL : BtConstants.hpp
  • BT_MDC_PHONE : BtConstants.hpp
  • BT_MDC_SHIFT : BtConstants.hpp
  • BT_MDC_UNCATEGORIZED : BtConstants.hpp
  • BT_MSC_AUDIO : BtConstants.hpp
  • BT_MSC_CAPTURING : BtConstants.hpp
  • BT_MSC_INFORMATION : BtConstants.hpp
  • BT_MSC_MASK : BtConstants.hpp
  • BT_MSC_NETWORK : BtConstants.hpp
  • BT_MSC_OBJECT_TRANSFER : BtConstants.hpp
  • BT_MSC_POSITIONING : BtConstants.hpp
  • BT_MSC_RENDERING : BtConstants.hpp
  • BT_MSC_SHIFT : BtConstants.hpp
  • BT_MSC_TELEPHONY : BtConstants.hpp
  • BT_OBEX_DEBUG_OUT : BtObexImpl.hpp
  • Bt_Obex_Types_hpp : BtTypes.hpp
  • BT_SDC_01_TO_17_UTILIZED : BtConstants.hpp
  • BT_SDC_17_TO_33_UTILIZED : BtConstants.hpp
  • BT_SDC_33_TO_50_UTILIZED : BtConstants.hpp
  • BT_SDC_50_TO_67_UTILIZED : BtConstants.hpp
  • BT_SDC_67_TO_83_UTILIZED : BtConstants.hpp
  • BT_SDC_83_TO_99_UTILIZED : BtConstants.hpp
  • BT_SDC_CAMCORDER : BtConstants.hpp
  • BT_SDC_CAMERA : BtConstants.hpp
  • BT_SDC_CAR_AUDIO : BtConstants.hpp
  • BT_SDC_CARD_READER : BtConstants.hpp
  • BT_SDC_CELLULAR : BtConstants.hpp
  • BT_SDC_COMBO_KEYBOARD_POINTING_DEVICE : BtConstants.hpp
  • BT_SDC_COMMON_ISDN_ACCESS : BtConstants.hpp
  • BT_SDC_CORDLESS : BtConstants.hpp
  • BT_SDC_DESKTOP_WORKSTATION : BtConstants.hpp
  • BT_SDC_DIGITIZER_TABLET : BtConstants.hpp
  • BT_SDC_DISPLAY : BtConstants.hpp
  • BT_SDC_GAMEPAD : BtConstants.hpp
  • BT_SDC_GAMING_TOY : BtConstants.hpp
  • BT_SDC_HAEDPHONES : BtConstants.hpp
  • BT_SDC_HANDHELD_PC_PDA : BtConstants.hpp
  • BT_SDC_HANDS_FREE : BtConstants.hpp
  • BT_SDC_HEADSET : BtConstants.hpp
  • BT_SDC_HIFI_AUDIO : BtConstants.hpp
  • BT_SDC_JOYSTICK : BtConstants.hpp
  • BT_SDC_KEYBOARD : BtConstants.hpp
  • BT_SDC_LAPTOP : BtConstants.hpp
  • BT_SDC_LOUDSPEAKER : BtConstants.hpp
  • BT_SDC_MASK : BtConstants.hpp
  • BT_SDC_MICROPHONE : BtConstants.hpp
  • BT_SDC_NO_SERVICE : BtConstants.hpp
  • BT_SDC_PALM_SIZED_PS_PDA : BtConstants.hpp
  • BT_SDC_POINTING_DEVICE : BtConstants.hpp
  • BT_SDC_PORTABLE_AUDIO : BtConstants.hpp
  • BT_SDC_PRINTER : BtConstants.hpp
  • BT_SDC_REMOTE_CONTROL : BtConstants.hpp
  • BT_SDC_SCANNER : BtConstants.hpp
  • BT_SDC_SENSING_DEVICE : BtConstants.hpp
  • BT_SDC_SERVER_CLASS_COMPUTER : BtConstants.hpp
  • BT_SDC_SET_TOP_BOX : BtConstants.hpp
  • BT_SDC_SHIFT : BtConstants.hpp
  • BT_SDC_SMART_PHONE : BtConstants.hpp
  • BT_SDC_VCR : BtConstants.hpp
  • BT_SDC_VIDEO_CAMERA : BtConstants.hpp
  • BT_SDC_VIDEO_CONFERENCING : BtConstants.hpp
  • BT_SDC_VIDEO_DISPLAY_AND_LOUDSPEAKER : BtConstants.hpp
  • BT_SDC_VIDEO_MONITOR : BtConstants.hpp
  • BT_SDC_WEARABLE_COMPUTER : BtConstants.hpp
  • BT_SDC_WIRED_MODEM_OR_VOICE_GATEWAY : BtConstants.hpp
  • BT_SDDB_BOOLEAN_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_DESCRIPTOR_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_NIL_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT128_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT16_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT32_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT64_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT8_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SIZE16_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SIZE32_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SIZE8_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT128_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT16_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT32_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT64_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT8_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UUID128_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UUID16_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UUID32_SIZE : BtSddbDataElements.cpp
  • Bt_Types_hpp : BtTypes.hpp
  • BtAcCategory1 : BtTypes.hpp
  • BtAcCategory2 : BtTypes.hpp
  • BtAcCategory3 : BtTypes.hpp
  • BtAcCategory4 : BtTypes.hpp
  • BtAcConnect : BtTypes.hpp
  • BtAcDisconnect : BtTypes.hpp
  • BtAcNotCongested : BtTypes.hpp
  • BtActControl : BtTypes.hpp
  • BtActGeneralInquiry : BtTypes.hpp
  • BtActiveDeviceWindow_hpp : BtActiveDeviceWindow.hpp
  • BtActNotify : BtTypes.hpp
  • BtActSpecificInquiry : BtTypes.hpp
  • BtActStatus : BtTypes.hpp
  • BtAo0 : BtTypes.hpp
  • BtAo1 : BtTypes.hpp
  • BtAo2 : BtTypes.hpp
  • BtAo3 : BtTypes.hpp
  • BtAo4 : BtTypes.hpp
  • BtAo5 : BtTypes.hpp
  • BtAo6 : BtTypes.hpp
  • BtAo7 : BtTypes.hpp
  • BtAo8 : BtTypes.hpp
  • BtAo9 : BtTypes.hpp
  • BtAoAngle : BtTypes.hpp
  • BtAoBackward : BtTypes.hpp
  • BtAoChannelDown : BtTypes.hpp
  • BtAoChannelUp : BtTypes.hpp
  • BtAoClear : BtTypes.hpp
  • BtAoContentsMenu : BtTypes.hpp
  • BtAocPanelPassThrough : BtTypes.hpp
  • BtAocSubunitInfo : BtTypes.hpp
  • BtAocUnitInfo : BtTypes.hpp
  • BtAocVendorDependent : BtTypes.hpp
  • BtAoDisplayInfo : BtTypes.hpp
  • BtAoDot : BtTypes.hpp
  • BtAoDown : BtTypes.hpp
  • BtAoEject : BtTypes.hpp
  • BtAoEnter : BtTypes.hpp
  • BtAoExit : BtTypes.hpp
  • BtAoF1 : BtTypes.hpp
  • BtAoF2 : BtTypes.hpp
  • BtAoF3 : BtTypes.hpp
  • BtAoF4 : BtTypes.hpp
  • BtAoF5 : BtTypes.hpp
  • BtAoFastForward : BtTypes.hpp
  • BtAoFavouriteMenu : BtTypes.hpp
  • BtAoForward : BtTypes.hpp
  • BtAoHelp : BtTypes.hpp
  • BtAoInputSelect : BtTypes.hpp
  • BtAoLeft : BtTypes.hpp
  • BtAoLeftUp : BtTypes.hpp
  • BtAoMute : BtTypes.hpp
  • BtAoNotDefined : BtTypes.hpp
  • BtAoPageDown : BtTypes.hpp
  • BtAoPageUp : BtTypes.hpp
  • BtAoPause : BtTypes.hpp
  • BtAoPlay : BtTypes.hpp
  • BtAoPower : BtTypes.hpp
  • BtAoPrevChannel : BtTypes.hpp
  • BtAoRecord : BtTypes.hpp
  • BtAoRewind : BtTypes.hpp
  • BtAoRight : BtTypes.hpp
  • BtAoRightDown : BtTypes.hpp
  • BtAoRightUp : BtTypes.hpp
  • BtAoRootMenu : BtTypes.hpp
  • BtAoSelect : BtTypes.hpp
  • BtAoSetupMenu : BtTypes.hpp
  • BtAoSoundSelect : BtTypes.hpp
  • BtAoStop : BtTypes.hpp
  • BtAoSubpicture : BtTypes.hpp
  • BtAoUp : BtTypes.hpp
  • BtAoVolumeDown : BtTypes.hpp
  • BtAoVolumeUp : BtTypes.hpp
  • BtApLeftDown : BtTypes.hpp
  • BtApplication_BtMsgTypes_hpp : BtMsgTypes.hpp
  • BtApplicationRequests_hpp : BtApplicationRequests.hpp
  • BtApplicationWindows_hpp : BtApplicationWindows.hpp
  • BtArAccepted : BtTypes.hpp
  • BtArImplementedStable : BtTypes.hpp
  • BtArInterim : BtTypes.hpp
  • BtArInTransition : BtTypes.hpp
  • BtArNotDefined : BtTypes.hpp
  • BtArNotImplemented : BtTypes.hpp
  • BtAroleController : BtTypes.hpp
  • BtAroleTarget : BtTypes.hpp
  • BtArRejected : BtTypes.hpp
  • BtArResponseChanged : BtTypes.hpp
  • BtAsfButtonPress : BtTypes.hpp
  • BtAsfButtonRelease : BtTypes.hpp
  • BtAstAudio : BtTypes.hpp
  • BtAstBulletinBoard : BtTypes.hpp
  • BtAstCa : BtTypes.hpp
  • BtAstCamera : BtTypes.hpp
  • BtAstCameraStorage : BtTypes.hpp
  • BtAstDisc : BtTypes.hpp
  • BtAstMonitor : BtTypes.hpp
  • BtAstPanel : BtTypes.hpp
  • BtAstPrinter : BtTypes.hpp
  • BtAstTapeRecPlayer : BtTypes.hpp
  • BtAstTuner : BtTypes.hpp
  • BtAstUnit : BtTypes.hpp
  • BtAstVendorUnique : BtTypes.hpp
  • BtAudioAccessoryService_hpp : BtAudioAccessoryService.hpp
  • BtAvrcpAlertMessageWindow_hpp : BtAvrcpAlertMessageWindow.hpp
  • BtAvrcpCategory : BtTypes.hpp
  • BtAvrcpCommand : BtTypes.hpp
  • BtAvrcpCommandInterface_hpp : BtAvrcpCommandInterface.hpp
  • BtAvrcpConnectRequest_hpp : BtAvrcpConnectRequest.hpp
  • BtAvrcpConnectResponse_hpp : BtAvrcpConnectResponse.hpp
  • BtAvrcpControllerApplicationWindow_hpp : BtAvrcpControllerApplicationWindows.hpp
  • BtAvrcpControllerDeviceListWindow_hpp : BtAvrcpControllerDeviceListWindow.hpp
  • BtAvrcpControlType : BtTypes.hpp
  • BtAvrcpDeRegisterRequest_hpp : BtAvrcpDeRegisterRequest.hpp
  • BtAvrcpDisconnectRequest_hpp : BtAvrcpDisconnectRequest.hpp
  • BtAvrcpNotificationMessage_hpp : BtAvrcpNotificationMessage.hpp
  • BtAvrcpOpcode : BtTypes.hpp
  • BtAvrcpOperation : BtTypes.hpp
  • BtAvrcpOperationController_hpp : BtAvrcpOperationController.hpp
  • BtAvrcpOperationRequestResponse_hpp : BtAvrcpOperationRequestResponse.hpp
  • BtAvrcpOperationService_hpp : BtAvrcpOperationService.hpp
  • BtAvrcpOperationServiceMessage_hpp : BtAvrcpOperationServiceMessage.hpp
  • BtAvrcpPanelApplication_hpp : BtAvrcpPanelApplication.hpp
  • BtAvrcpPanelApplicationWindows_hpp : BtAvrcpPanelApplicationWindows.hpp
  • BtAvrcpPanelPassThroughParams_hpp : BtAvrcpPanelPassThroughParams.hpp
  • BtAvrcpPanelPassThroughRequest_hpp : BtAvrcpPanelPassThroughRequest.hpp
  • BtAvrcpPanelProfileService_hpp : BtAvrcpProfileService.hpp
  • BtAvrcpPanelService_hpp : BtAvrcpPanelService.hpp
  • BtAvrcpPanelServiceImpl_hpp : BtAvrcpPanelServiceImpl.hpp
  • BtAvrcpRawFrameParams_hpp : BtAvrcpRawFrameParams.hpp
  • BtAvrcpRawFrameRequest_hpp : BtAvrcpRawFrameRequest.hpp
  • BtAvrcpRegisterParams_hpp : BtAvrcpRegisterParams.hpp
  • BtAvrcpRegisterRequest_hpp : BtAvrcpRegisterRequest.hpp
  • BtAvrcpRegistrationController_hpp : BtAvrcpRegistrationController.hpp
  • BtAvrcpRegistrationService_hpp : BtAvrcpRegistrationService.hpp
  • BtAvrcpRequest_hpp : BtAvrcpRequest.hpp
  • BtAvrcpResponseType : BtTypes.hpp
  • BtAvrcpRole : BtTypes.hpp
  • BtAvrcpService_hpp : BtAvrcpService.hpp
  • BtAvrcpStateFlag : BtTypes.hpp
  • BtAvrcpSubunitInfoParams_hpp : BtAvrcpSubunitInfoParams.hpp
  • BtAvrcpSubunitInfoRequest_hpp : BtAvrcpSubunitInfoRequest.hpp
  • BtAvrcpSubunitType : BtTypes.hpp
  • BtAvrcpTypes_hpp : BtTypes.hpp
  • BtAvrcpUnitInfoParams_hpp : BtAvrcpUnitInfoParams.hpp
  • BtAvrcpUnitInfoRequest_hpp : BtAvrcpUnitInfoRequest.hpp
  • BtBipAbortReq_hpp : BtBipAbortReq.hpp
  • BtBipAttachmentDescPtr : BtBipTypes.hpp
  • BtBipAttachmentFormatPtr : BtBipTypes.hpp
  • BtBipAttachmentPtr : BtBipTypes.hpp
  • BtBipBmp : BtBipTypes.hpp
  • BtBipClientService_hpp : BtBipClientService.hpp
  • BtBipConnectReq_hpp : BtBipConnectReq.hpp
  • BtBipController_hpp : BtBipController.hpp
  • BtBipCrop : BtBipTypes.hpp
  • BtBipDataConverter_hpp : BtBipDataConverter.hpp
  • BtBipDeleteImageReq_hpp : BtBipDeleteImageReq.hpp
  • BtBipDisconnectReq_hpp : BtBipDisconnectReq.hpp
  • BtBipEncoding : BtBipTypes.hpp
  • BtBipFill : BtBipTypes.hpp
  • BtBipGetImagePropertiesReq_hpp : BtBipGetImagePropertiesReq.hpp
  • BtBipGetImagePropertiesRsp_hpp : BtBipGetImagePropertiesRsp.hpp
  • BtBipGetImageReq_hpp : BtBipGetImageReq.hpp
  • BtBipGetImageRsp_hpp : BtBipGetImageRsp.hpp
  • BtBipGetImagesListReq_hpp : BtBipGetImagesListReq.hpp
  • BtBipGetImagesListRsp_hpp : BtBipGetImagesListRsp.hpp
  • BtBipGetImagingCapabilitiesReq_hpp : BtBipGetImagingCapabilitiesReq.hpp
  • BtBipGetImagingCapabilitiesRsp_hpp : BtBipGetImagingCapabilitiesRsp.hpp
  • BtBipGetLinkedAttachmentReq_hpp : BtBipGetLinkedAttachmentReq.hpp
  • BtBipGetLinkedAttachmentRsp_hpp : BtBipGetLinkedAttachmentRsp.hpp
  • BtBipGetLinkedThumbnailReq_hpp : BtBipGetLinkedThumbnailReq.hpp
  • BtBipGetLinkedThumbnailRsp_hpp : BtBipGetLinkedThumbnailRsp.hpp
  • BtBipGetReq_hpp : BtBipGetReq.hpp
  • BtBipGetRsp_hpp : BtBipGetRsp.hpp
  • BtBipGif : BtBipTypes.hpp
  • BtBipImageDescPtr : BtBipTypes.hpp
  • BtBipImageFormatPtr : BtBipTypes.hpp
  • BtBipImageHdlDescPtr : BtBipTypes.hpp
  • BtBipImageHdlPtr : BtBipTypes.hpp
  • BtBipImageListPtr : BtBipTypes.hpp
  • BtBipImagePropertiesPtr : BtBipTypes.hpp
  • BtBipImagePtr : BtBipTypes.hpp
  • BtBipImagingCapabilitiesPtr : BtBipTypes.hpp
  • BtBipInvalidEncoding : BtBipTypes.hpp
  • BtBipInvalidTransformation : BtBipTypes.hpp
  • BtBipJpeg : BtBipTypes.hpp
  • BtBipJpeg2000 : BtBipTypes.hpp
  • BtBipMecelXMLConverter_hpp : BtBipMecelXmlConverter.hpp
  • BtBipMsgArgPtr : BtBipMsgArg.hpp
  • BtBipNone : BtBipTypes.hpp
  • BtBipPng : BtBipTypes.hpp
  • BtBipPutAttachReq_hpp : BtBipPutAttachReq.hpp
  • BtBipPutAttachRsp_hpp : BtBipPutAttachRsp.hpp
  • BtBipPutImageReq_hpp : BtBipPutImageReq.hpp
  • BtBipPutReq_hpp : BtBipPutReq.hpp
  • BtBipPutRsp_hpp : BtBipPutRsp.hpp
  • BtBipPutThumbReq_hpp : BtBipPutThumbReq.hpp
  • BtBipPutThumbRsp_hpp : BtBipPutThumbRsp.hpp
  • BtBipRequest_hpp : BtBipReq.hpp
  • BtBipResult : BtBipTypes.hpp
  • BtBipServerNotificationMsg_hpp : BtBipNotificationMsg.hpp
  • BtBipServerNotificationMsgArgPtr : BtBipNotificationMsgArg.hpp
  • BtBipServerService_hpp : BtBipServerService.hpp
  • BtBipService_hpp : BtBipService.hpp
  • BtBipSessionId : BtBipTypes.hpp
  • BtBipStretch : BtBipTypes.hpp
  • BtBipTransformation : BtBipTypes.hpp
  • BtBipTypes_hpp : BtBipTypes.hpp
  • BtBipWBmp : BtBipTypes.hpp
  • BtBppClientService_hpp : BtBppClientService.hpp
  • BtBppController_hpp : BtBppController.hpp
  • BtBppObexResult : BtBppTypes.hpp
  • BtBppRequest_hpp : BtBppReq.hpp
  • BtBppResult : BtBppTypes.hpp
  • BtBppServerService_hpp : BtBppServerService.hpp
  • BtBppService_hpp : BtBppService.hpp
  • BtBppSndAbortReqRequest_hpp : BtBppSndAbortReqRequest.hpp
  • BtBppSndFilePushReqRequest_hpp : BtBppSndFilePushReqRequest.hpp
  • BtBppSndGetRefObjRspRequest_hpp : BtBppSndGetRefObjRspRequest.hpp
  • BtBppTestData_hpp : BtBppTestData.hpp
  • BtBppTypes_hpp : BtBppTypes.hpp
  • BtCancelableBroadcastRequest_hpp : BtCancelableBroadcastRequest.hpp
  • BtCancelableMulticastRequest_hpp : BtCancelableMulticastRequest.hpp
  • BtCancelableRequest_hpp : BtCancelableRequest.hpp
  • BtChipType : BtTypes.hpp
  • BtCmConnectable : BtTypes.hpp
  • BtCmNonConnectable : BtTypes.hpp
  • BtConnectableMode : BtTypes.hpp
  • BtConnectionBasedController_hpp : BtConnectionBasedController.hpp
  • BtConnectionlessController_hpp : BtConnectionlessController.hpp
  • BtConnectRequest_hpp : BtConnectRequest.hpp
  • BtController_hpp : BtController.hpp
  • BtCtBmscr : BtTypes.hpp
  • BtCtBmu : BtTypes.hpp
  • BtDataElementType : BtTypes.hpp
  • BtDatatElements_hpp : BtSvrDataElement.hpp
  • BtDetBool : BtTypes.hpp
  • BtDetEnumeration : BtTypes.hpp
  • BtDetNil : BtTypes.hpp
  • BtDetSequence : BtTypes.hpp
  • BtDetSint : BtTypes.hpp
  • BtDetString : BtTypes.hpp
  • BtDetUint : BtTypes.hpp
  • BtDetUrl : BtTypes.hpp
  • BtDetUuid : BtTypes.hpp
  • BtDevice_hpp : BtDevice.hpp
  • BtDeviceAddress_hpp : BtDeviceAddress.hpp
  • BtDeviceAndServiceClass_hpp : BtDeviceAndServiceClass.hpp
  • BtDeviceDetailWindow_hpp : BtDeviceDetailWindow.hpp
  • BtDeviceFilter_hpp : BtDeviceFilter.hpp
  • BtDeviceList_hpp : BtDeviceList.hpp
  • BtDeviceListIterator_hpp : BtDeviceListIterator.hpp
  • BtDeviceListReverseIterator_hpp : BtDeviceListReverseIterator.hpp
  • BtDeviceListsWindows_hpp : BtDeviceListsWindows.hpp
  • BtDevicePairRequest_hpp : BtDevicePairRequest.hpp
  • BtDeviceRelation : BtTypes.hpp
  • BtDeviceSearchRequest_hpp : BtDeviceSearchRequest.hpp
  • BtDeviceState : BtTypes.hpp
  • BtDeviceTrustRequest_hpp : BtDeviceTrustRequest.hpp
  • BtDeviceUnpairRequest_hpp : BtDeviceUnpairRequest.hpp
  • BtDeviceUntrustRequest_hpp : BtDeviceUntrustRequest.hpp
  • BtDisconnectRequest_hpp : BtDisconnectRequest.hpp
  • BtDiscoverableMode : BtTypes.hpp
  • BtDmGeneralDiscoverable : BtTypes.hpp
  • BtDmLimitedDiscoverable : BtTypes.hpp
  • BtDmNonDiscoverable : BtTypes.hpp
  • BtDrConnected : BtTypes.hpp
  • BtDrNone : BtTypes.hpp
  • BtDrTrusted : BtTypes.hpp
  • BtDrTrustedAndConnected : BtTypes.hpp
  • BtDsConnected : BtTypes.hpp
  • BtDsKnown : BtTypes.hpp
  • BtDsPaired : BtTypes.hpp
  • BtDsTrusted : BtTypes.hpp
  • BtDunController_hpp : BtDunController.hpp
  • BtDunDisconnectRequest_hpp : BtDunDisconnectRequest.hpp
  • BtDunProfileService_hpp : BtDunProfileService.hpp
  • BtDunService_hpp : BtDunService.hpp
  • BtEvent_hpp : BtEvent.hpp
  • BtFaxController_hpp : BtFaxController.hpp
  • BtFaxDisconnectRequest_hpp : BtFaxDisconnectRequest.hpp
  • BtFaxProfileService_hpp : BtFaxProfileService.hpp
  • BtFaxService_hpp : BtFaxService.hpp
  • BtGapAndSdapController_hpp : BtGapAndSdapController.hpp
  • BTHF_AUDIO_2_HF : BtHfAppPlugin.hpp
  • BTHF_AUDIO_2_PHONE : BtHfAppPlugin.hpp
  • BtHfAppPlugin_hpp : BtHfAppPlugin.hpp
  • BtHfCallEvent : BtTypes.hpp
  • BtHfCallLocation : BtTypes.hpp
  • BtHfCe : BtTypes.hpp
  • BtHfClCallOnAccessory : BtTypes.hpp
  • BtHfClCallOnPhone : BtTypes.hpp
  • BtHfClNoCall : BtTypes.hpp
  • BtHfColIds : BtHfProvider.hpp
  • BtHfConnectRequest_hpp : BtHfConnectRequest.hpp
  • BtHfController_hpp : BtHfController.hpp
  • BtHfControllerMessage_hpp : BtHfControllerMessage.hpp
  • BtHfDisonnectRequest_hpp : BtHfDisconnectRequest.hpp
  • BtHfInbandSettingWin_hpp : BtHfInbandSettingWin.hpp
  • BtHfNotificationMessage_hpp : BtHfNotificationMessage.hpp
  • BtHfProfileService_hpp : BtHfProfileService.hpp
  • BtHfProfileWindows_hpp : BtHfProfileWindows.hpp
  • BtHfRequest_hpp : BtHfRequest.hpp
  • BtHfsAudioActive : BtTypes.hpp
  • BtHfsAvailableForAudio : BtTypes.hpp
  • BtHfsConnected : BtTypes.hpp
  • BtHfService_hpp : BtHfService.hpp
  • BtHfSetMicrophoneGainRequest_hpp : BtHfSetMicrophoneGainRequest.hpp
  • BtHfSetSpeakerGainRequest_hpp : BtHfSetSpeakerGainRequest.hpp
  • BtHfsNotConnected : BtTypes.hpp
  • BtHfState : BtTypes.hpp
  • BtHfTransferAudioToAccessoryRequest_hpp : BtHfTransferAudioToAccessoryRequest.hpp
  • BtHfTransferAudioToPhoneRequest_hpp : BtHfTransferAudioToPhoneRequest.hpp
  • BtHsCallEvent : BtTypes.hpp
  • BtHsCallLocation : BtTypes.hpp
  • BtHsCeCallOnHeadset : BtTypes.hpp
  • BtHsCeCallOnPhone : BtTypes.hpp
  • BtHsCeCallRelease : BtTypes.hpp
  • BtHsCeHangUp : BtTypes.hpp
  • BtHsClCallOnAccessory : BtTypes.hpp
  • BtHsClCallOnPhone : BtTypes.hpp
  • BtHsClNoCall : BtTypes.hpp
  • BtHsConnectionSettingWin_hpp : BtHsConnectionSettingWin.hpp
  • BtHsConnectRequest_hpp : BtHsConnectRequest.hpp
  • BtHsController_hpp : BtHsController.hpp
  • BtHsControllerMessage_hpp : BtHsControllerMessage.hpp
  • BtHsDisconnectRequest_hpp : BtHsDisconnectRequest.hpp
  • BtHsInbandSettingWin_hpp : BtHsInbandSettingWin.hpp
  • BtHsNotificationMessage_hpp : BtHsNotificationMessage.hpp
  • BtHsProfileService_hpp : BtHsProfileService.hpp
  • BtHsRequest_hpp : BtHsRequest.hpp
  • BtHsRingRequest_hpp : BtHsRingRequest.hpp
  • BtHssAudioActive : BtTypes.hpp
  • BtHssAvailableForAudio : BtTypes.hpp
  • BtHssConnected : BtTypes.hpp
  • BtHsService_hpp : BtHsService.hpp
  • BtHsSetMicrophoneGainRequest_hpp : BtHsSetMicrophoneGainRequest.hpp
  • BtHsSetSpeakerGainRequest_hpp : BtHsSetSpeakerGainRequest.hpp
  • BtHssNotConnected : BtTypes.hpp
  • BtHsState : BtTypes.hpp
  • BtHsStopRingRequest_hpp : BtHsStopRingRequest.hpp
  • BtHsTransferAudioToAccessoryRequest_hpp : BtHsTransferAudioToAccessoryRequest.hpp
  • BtHsTransferAudioToPhoneRequest_hpp : BtHsTransferAudioToPhoneRequest.hpp
  • BtIacGlobal : BtTypes.hpp
  • BtIacLocal : BtTypes.hpp
  • BtInquiryAccessCode : BtTypes.hpp
  • BtJsr82Url_hpp : BtJsr82Url.hpp
  • BtLocalRequest_hpp : BtLocalRequest.hpp
  • BtLocalSettings_hpp : BtLocalSettings.hpp
  • BtMultiConnectionController_hpp : BtMultiConnectionController.hpp
  • BtObexAbortRequest_hpp : BtObexAbortRequest.hpp
  • BtObexClientOperationRequest_hpp : BtObexClientOperationRequest.hpp
  • BtObexClientService_hpp : BtObexClientService.hpp
  • BtObexClientServiceObserver_hpp : BtObexClientServiceObserver.hpp
  • BtObexConnectRequest_hpp : BtObexConnectRequest.hpp
  • BtObexController_hpp : BtObexController.hpp
  • BtObexDisconnectRequest_hpp : BtObexDisconnectRequest.hpp
  • BtObexErrorCode : BtTypes.hpp
  • BtObexEvent_hpp : BtObexEvent.hpp
  • BtObexGetRequest_hpp : BtObexGetRequest.hpp
  • BtObexHeaderType : BtTypes.hpp
  • BtObexOperationCode : BtTypes.hpp
  • BtObexPutRequest_hpp : BtObexPutRequest.hpp
  • BtObexRegisterClientRequest_hpp : BtObexRegisterClientRequest.hpp
  • BtObexRegisterServerRequest_hpp : BtObexRegisterServerRequest.hpp
  • BtObexRequest_hpp : BtObexRequest.hpp
  • BtObexServerNotificationMessage_hpp : BtObexNotificationMessage.hpp
  • BtObexServerService_hpp : BtObexServerService.hpp
  • BtObexServerServiceObserver_hpp : BtObexServerServiceObserver.hpp
  • BtObexService_hpp : BtObexService.hpp
  • BtObexServiceObserver_hpp : BtObexServiceObserver.hpp
  • BtObexSetPathRequest_hpp : BtObexSetPathRequest.hpp
  • BtObexTransport_hpp : BtObexTransport.hpp
  • BtObexUnregisterClientRequest_hpp : BtObexUnregisterClientRequest.hpp
  • BtObexUnregisterServerRequest_hpp : BtObexUnregisterServerRequest.hpp
  • BtObservableService_hpp : BtObservableService.hpp
  • BtOecBusy : BtTypes.hpp
  • BtOecConnected : BtTypes.hpp
  • BtOecHandleUnknown : BtTypes.hpp
  • BtOecNotConnected : BtTypes.hpp
  • BtOecOperationNotAllowed : BtTypes.hpp
  • BtOhtByteSequence : BtTypes.hpp
  • BtOhtByteValue : BtTypes.hpp
  • BtOhtDWordValue : BtTypes.hpp
  • BtOhtUnicodeString : BtTypes.hpp
  • BtOocAbort : BtTypes.hpp
  • BtOocConnect : BtTypes.hpp
  • BtOocDisconnect : BtTypes.hpp
  • BtOocGet : BtTypes.hpp
  • BtOocPut : BtTypes.hpp
  • BtOocSetPath : BtTypes.hpp
  • BtOperationBase_hpp : BtOperationBase.hpp
  • BtOperationPtr : BtOperationBase.hpp
  • BtOperationSelectDevice_hpp : BtOperationSelectDevice.hpp
  • BtOperationSelectDeviceAndPerformServiceVerify_hpp : BtOperationSelectDeviceAndPerformServiceVerify.hpp
  • BtOperationType : BtTypes.hpp
  • BtOpPerformServiceVerify : BtTypes.hpp
  • BtOpSelectDevice : BtTypes.hpp
  • BtOpSelectDeviceAndPerformServiceVerify : BtTypes.hpp
  • BtPairableMode : BtTypes.hpp
  • BtPmNonPairable : BtTypes.hpp
  • BtPmPairable : BtTypes.hpp
  • BtProfile : BtTypes.hpp
  • BtProfileA2dp : BtTypes.hpp
  • BtProfileAad : BtTypes.hpp
  • BtProfileAvrcp : BtTypes.hpp
  • BtProfileBip : BtTypes.hpp
  • BtProfileBpp : BtTypes.hpp
  • BtProfileDun : BtTypes.hpp
  • BtProfileFax : BtTypes.hpp
  • BtProfileFtp : BtTypes.hpp
  • BtProfileGapAndSdap : BtTypes.hpp
  • BtProfileHf : BtTypes.hpp
  • BtProfileHs : BtTypes.hpp
  • BtProfileObex : BtTypes.hpp
  • BtProfileOpp : BtTypes.hpp
  • BtProfilePap : BtTypes.hpp
  • BtProfileSap : BtTypes.hpp
  • BtProfileUnknown : BtTypes.hpp
  • BtProtocol : BtSocketAddr.hpp
  • BtQuerySupportedProfilesRequest_hpp : BtQuerySupportedProfilesRequest.hpp
  • BtRcAccepted : BtTypes.hpp
  • BtRcError : BtTypes.hpp
  • BtRcIgnored : BtTypes.hpp
  • BtRcOk : BtTypes.hpp
  • BtRcPending : BtTypes.hpp
  • BtRcRejected : BtTypes.hpp
  • BtRcUnknown : BtTypes.hpp
  • BtRequest_hpp : BtRequest.hpp
  • BtRequestRespondRequest_hpp : BtRequestRespondRequest.hpp
  • BtRequestState : BtTypes.hpp
  • BtRequestType : BtTypes.hpp
  • BtRespondAuthorizationRequest_hpp : BtRespondAuthorizationRequest.hpp
  • BtResultCode : BtTypes.hpp
  • BtRqsAccepted : BtTypes.hpp
  • BtRqsAcceptedCancelation : BtTypes.hpp
  • BtRqsExecuting : BtTypes.hpp
  • BtRqsExecutingCancelation : BtTypes.hpp
  • BtRqsFinishedFailure : BtTypes.hpp
  • BtRqsFinishedOk : BtTypes.hpp
  • BtRqsIgnored : BtTypes.hpp
  • BtRqsInitialized : BtTypes.hpp
  • BtRqsRejected : BtTypes.hpp
  • BtRqsUnknown : BtTypes.hpp
  • BtRqtAvrcpConnect : BtTypes.hpp
  • BtRqtAvrcpConnectRsp : BtTypes.hpp
  • BtRqtAvrcpDeRegister : BtTypes.hpp
  • BtRqtAvrcpDisconnect : BtTypes.hpp
  • BtRqtAvrcpPanelPassThrough : BtTypes.hpp
  • BtRqtAvrcpPanelPassThroughRsp : BtTypes.hpp
  • BtRqtAvrcpRawFrame : BtTypes.hpp
  • BtRqtAvrcpRawFrameRsp : BtTypes.hpp
  • BtRqtAvrcpRegister : BtTypes.hpp
  • BtRqtAvrcpSubunitInfo : BtTypes.hpp
  • BtRqtAvrcpUnitInfo : BtTypes.hpp
  • BtRqtBipAbort : BtTypes.hpp
  • BtRqtBipConnect : BtTypes.hpp
  • BtRqtBipDeleteImage : BtTypes.hpp
  • BtRqtBipDisconnect : BtTypes.hpp
  • BtRqtBipGetImage : BtTypes.hpp
  • BtRqtBipGetImageProperties : BtTypes.hpp
  • BtRqtBipGetImagesList : BtTypes.hpp
  • BtRqtBipGetImagingCapabilities : BtTypes.hpp
  • BtRqtBipGetLinkedAttachment : BtTypes.hpp
  • BtRqtBipGetLinkedThumbnail : BtTypes.hpp
  • BtRqtBipPutImage : BtTypes.hpp
  • BtRqtBipPutLinkedAttachment : BtTypes.hpp
  • BtRqtBipPutLinkedThumbnail : BtTypes.hpp
  • BtRqtBppSndAbortReq : BtTypes.hpp
  • BtRqtBppSndAuthenticationReqRes : BtTypes.hpp
  • BtRqtBppSndFilePushReq : BtTypes.hpp
  • BtRqtBppSndGetRefObjRsp : BtTypes.hpp
  • BtRqtDevicePair : BtTypes.hpp
  • BtRqtDeviceSearch : BtTypes.hpp
  • BtRqtDeviceTrust : BtTypes.hpp
  • BtRqtDeviceUnpair : BtTypes.hpp
  • BtRqtDeviceUntrust : BtTypes.hpp
  • BtRqtDunDisconnect : BtTypes.hpp
  • BtRqtFaxDisconnect : BtTypes.hpp
  • BtRqtHfConnect : BtTypes.hpp
  • BtRqtHfDisconnect : BtTypes.hpp
  • BtRqtHfSetMicrophoneGain : BtTypes.hpp
  • BtRqtHfSetSpeakerGain : BtTypes.hpp
  • BtRqtHfTransferAudioToAccessory : BtTypes.hpp
  • BtRqtHfTransferAudioToPhone : BtTypes.hpp
  • BtRqtHsConnect : BtTypes.hpp
  • BtRqtHsDisconnect : BtTypes.hpp
  • BtRqtHsHangUp : BtTypes.hpp
  • BtRqtHsRing : BtTypes.hpp
  • BtRqtHsSetMicrophoneGain : BtTypes.hpp
  • BtRqtHsSetSpeakerGain : BtTypes.hpp
  • BtRqtHsStopRing : BtTypes.hpp
  • BtRqtHsTransferAudioToAccessory : BtTypes.hpp
  • BtRqtHsTransferAudioToPhone : BtTypes.hpp
  • BtRqtObexAbort : BtTypes.hpp
  • BtRqtObexConnect : BtTypes.hpp
  • BtRqtObexDisconnect : BtTypes.hpp
  • BtRqtObexGet : BtTypes.hpp
  • BtRqtObexPut : BtTypes.hpp
  • BtRqtObexRegisterClient : BtTypes.hpp
  • BtRqtObexRegisterServer : BtTypes.hpp
  • BtRqtObexSendResponse : BtTypes.hpp
  • BtRqtObexSetPath : BtTypes.hpp
  • BtRqtObexUnregisterClient : BtTypes.hpp
  • BtRqtObexUnregisterServer : BtTypes.hpp
  • BtRqtQuerySupportedProfiles : BtTypes.hpp
  • BtRqtRespondAuthorization : BtTypes.hpp
  • BtRqtSddbRegisterServiceRecord : BtTypes.hpp
  • BtRqtSddbUnregisterServiceRecord : BtTypes.hpp
  • BtRqtSendPasskey : BtTypes.hpp
  • BtRqtServiceVerify : BtTypes.hpp
  • BtRqtSetRemoteDeviceName : BtTypes.hpp
  • BtRqtUnknown : BtTypes.hpp
  • BtSddbDataElements_hpp : BtSddbDataElements.hpp
  • BtSddbEvent_hpp : BtSddbEvent.hpp
  • BtSddbRegisterServiceRecordRequest_hpp : BtSddbRegisterServiceRecordRequest.hpp
  • BtSddbRequest_hpp : BtSddbRequest.hpp
  • BtSddbService_hpp : BtSddbService.hpp
  • BtSddbServiceAttribute_hpp : BtSddbServiceAttribute.hpp
  • BtSddbServiceObserver_hpp : BtSddbServiceObserver.hpp
  • BtSddbServiceRecord_hpp : BtSddbServiceRecord.hpp
  • BtSddbUnregisterServiceRecordRequest_hpp : BtSddbUnregisterServiceRecordRequest.hpp
  • BtSecuritySettings : BtTypes.hpp
  • BtSendPasskeyRequest_hpp : BtSendPasskeyRequest.hpp
  • BtService_hpp : BtService.hpp
  • BtServiceDiscoveryDatabase_hpp : BtServiceDiscoveryDatabase.hpp
  • BtServiceObserver_hpp : BtServiceObserver.hpp
  • BtServiceRequest_hpp : BtServiceRequest.hpp
  • BtServiceVerifyRequest_hpp : BtServiceVerifyRequest.hpp
  • BtServiceVerifyResult_hpp : BtServiceVerifyResult.hpp
  • BtSesAlwaysAuthenticatedTrustedDevices : BtTypes.hpp
  • BtSesAuthentication : BtTypes.hpp
  • BtSesAuthenticationAuthorization : BtTypes.hpp
  • BtSesAuthenticationEncryption : BtTypes.hpp
  • BtSesAuthenticationEncryptionAuthorization : BtTypes.hpp
  • BtSesAuthorization : BtTypes.hpp
  • BtSesAuthorizationAlwaysAuthenticatedTrustedDevices : BtTypes.hpp
  • BtSesNoSecurity : BtTypes.hpp
  • BtSetRemoteDeviceNameRequest_hpp : BtSetRemoteDeviceNameRequest.hpp
  • BtSettingsDisplayInfoWindow_hpp : BtLocalSettingsWindows.hpp
  • BtSingleConnectionController_hpp : BtSingleConnectionController.hpp
  • BtSsError : BtTypes.hpp
  • BtSsInitialized : BtTypes.hpp
  • BtSsNoState : BtTypes.hpp
  • BtSsNotInitialized : BtTypes.hpp
  • BtSsOff : BtTypes.hpp
  • BtSsOn : BtTypes.hpp
  • BtStackState : BtTypes.hpp
  • BtSvrServiceAttribute_hpp : BtSvrServiceAttribute.hpp
  • BtSvrServiceRecord_hpp : BtSvrServiceRecord.hpp
  • BtTransport_hpp : BtTransport.hpp
  • BtUncancelablePointToPointRequest_hpp : BtUncancelablePointToPointRequest.hpp
  • BtUncancelableRequest_hpp : BtUncancelableRequest.hpp
  • BtUtil_hpp : BtUtility.hpp
  • BtUuid128 : BtTypes.hpp
  • BtUuid16 : BtTypes.hpp
  • BtUuid32 : BtTypes.hpp
  • BtUuidType : BtTypes.hpp
  • BUF_MAX : TestWriter.cpp
  • BUFFER_SIZE : RegAppWin.cpp
  • BufferedIStream_Free() : bistream.cpp
  • BufferedIStream_Init() : bistream.cpp
  • BufferedIStream_Peek() : bistream.cpp
  • BufferedIStream_Read() : bistream.cpp
  • BufferedIStream_ToString() : bistream.cpp
  • BUFFERPOOLMANAGER_BUFFER_ADMIN_SIZE : BufferPoolManager.cpp
  • BUFREADCOMMENT : Unzip.hpp
  • BuildMparty : SignalTypes.hpp
  • BusyOnCall : SimTkTypes.hpp
  • BusyToneOn : SignalTypes.hpp
  • byte : FfsSim.hpp
  • BYTE : NucInc.hpp
  • byte_count : FillRect_16Bpp.cpp
  • ByteBufferAccessOperatorTest() : ByteBuffer.cpp
  • ByteBufferAssignmentOperators() : ByteBuffer.cpp
  • ByteBufferConstructorTest() : ByteBuffer.cpp
  • ByteBufferMiscMethodsTest() : ByteBuffer.cpp
  • ByteBufferTest() : ByteBuffer.hpp, ByteBuffer.cpp
  • BYTEST_PRO_JPEG_PIXEL : StillCamera.cpp
  • BYTEST_PRO_PIXEL : StillCamera.cpp
Generated on Wed Jan 25 02:31:15 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • c_2_letter_iso639_code_id : ProviderIds.hpp
  • c_3_letter_iso639_code_id : ProviderIds.hpp
  • c_aas_id : ProvIds.hpp
  • c_aas_id_end : ProvIds.hpp
  • c_aas_max_rec_id : ProvIds.hpp
  • c_aas_size_id : ProvIds.hpp
  • c_abstract_menu_list_imid : InputMap.hpp
  • c_access_technology_id : ProvIds.hpp
  • c_acm2_id : ProvIds.hpp
  • c_acm_chv_id : ProvIds.hpp
  • c_acm_id : ProvIds.hpp
  • c_acm_rec_size : SimAccessor.hpp
  • c_acmmax_chv_id : ProvIds.hpp
  • c_acmmax_id : ProvIds.hpp
  • c_act_supported_id : ProvIds.hpp
  • c_add_name_id : ProvIds.hpp
  • c_add_name_id_end : ProvIds.hpp
  • c_add_name_size_id : ProvIds.hpp
  • c_adn_provider_id : ProvIds.hpp
  • c_alarm_manager_max_entries : AlarmManager.hpp
  • c_alphatagsize_id : ProvIds.hpp
  • c_anr_id : ProvIds.hpp
  • c_anr_id_end : ProvIds.hpp
  • c_apn_name_len_max : SocketTypes.hpp
  • c_apoxi_base_gentypes : GenericObject.hpp
  • c_apoxi_powersaving_timer_alignment_lower_bound : Os.hpp
  • c_apoxi_powersaving_timer_alignment_upper_bound : Os.hpp
  • c_append_row : Provider.hpp
  • c_ati_codec_max_num_of_mpeg4_dec_inst : AtiMpeg4Decoder.hpp
  • c_ati_codec_mpeg4_dec_out_buf_def_count : AtiMpeg4Decoder.cpp
  • c_ati_codec_mpeg4_dec_out_buf_max_count : AtiMpeg4Decoder.cpp
  • c_ati_codec_mpeg4_dec_out_buf_min_count : AtiMpeg4Decoder.cpp
  • c_ati_codec_mpeg4_enc_out_buf_def_count : AtiMpeg4Encoder.cpp
  • c_ati_codec_mpeg4_enc_out_buf_max_count : AtiMpeg4Encoder.cpp
  • c_ati_codec_mpeg4_enc_out_buf_min_count : AtiMpeg4Encoder.cpp
  • c_ati_codecs_max_num_of_mpeg4_enc_inst : AtiMpeg4Encoder.hpp
  • c_attempts_left_id : ProvIds.hpp
  • c_attempts_left_undefined : SimChvHandler.hpp
  • c_aux_provider_id : ProvIds.hpp
  • c_battery_load_id : ProvIds.hpp
  • c_bdn_provider_id : ProvIds.hpp
  • c_bip_client_put_packet_size : BtBipPutReq.cpp, BtBipPutImageRsp.cpp
  • c_bip_client_read_buf_size : BtBipClientService.hpp, BtBipClientService.cpp
  • c_bip_convert_buf_size : BtBipMecelXmlConverter.cpp
  • c_bip_invalid_res : BtBipTypes.hpp, BtBipTypes.cpp
  • c_bip_max_image_hdl : BtBipTypes.hpp, BtBipTypes.cpp
  • c_bip_server_read_buf_size : BtBipServerService.cpp
  • c_black_and_white_system_color_table : BlackAndWhiteTheme.cpp
  • c_black_and_white_system_font_table : BlackAndWhiteTheme.cpp
  • c_blobobject_type : BlobObject.hpp
  • c_blobptr_type : BlobPtr.hpp
  • c_blue_sky_chinese_system_font_table : BlueSkyChineseTheme.cpp
  • c_blue_sky_system_color_table : BlueSkyTheme.cpp, BlueSkyChineseTheme.cpp
  • c_blue_sky_system_font_table : BlueSkyTheme.cpp
  • c_broker_table_size : ServiceBroker.hpp
  • c_bt_protocol_l2cap : BtSocketAddr.hpp
  • c_bt_protocol_rfcomm : BtSocketAddr.hpp
  • c_bytes_per_pixel_of_rawdata : VideoCamera.cpp
  • c_cal_category_id : CalendarProvider.hpp
  • c_cal_date_id : CalendarProvider.hpp
  • c_cal_description_id : CalendarProvider.hpp
  • c_cal_recurrence_id : CalendarProvider.hpp
  • c_cal_text_for_list_item_id : CalendarProvider.hpp
  • c_cal_time_id : CalendarProvider.hpp
  • c_call_fwd_data_id : ProvIds.hpp
  • c_call_fwd_fax_id : ProvIds.hpp
  • c_call_fwd_line1_id : ProvIds.hpp
  • c_call_fwd_line2_id : ProvIds.hpp
  • c_Cancel_imid : InputMap.hpp
  • c_cause_id : ProvIds.hpp
  • c_cbmi_id : ProvIds.hpp
  • c_cbmi_provider_id : ProvIds.hpp
  • c_cbmi_range_high_id : ProvIds.hpp
  • c_cbmi_range_low_id : ProvIds.hpp
  • c_cbmi_range_provider_id : ProvIds.hpp
  • c_cbs_default_active_timer : Cbs.hpp
  • c_cbs_default_sleep_timer : Cbs.hpp
  • c_cc_id : ProvIds.hpp
  • c_ccp_rec_size : SimAccessor.hpp
  • c_cellid_id : ProvIds.hpp
  • c_check_box_imid : InputMap.hpp
  • c_check_box_list_imid : InputMap.hpp
  • c_CheckBoxChangeStatus_imid : InputMap.hpp
  • c_chv_padding_char : ChvStackMsgArgs.hpp
  • c_chv_provider_id : ProvIds.hpp
  • c_clir_mode_id : ProvIds.hpp
  • c_cmi_alpha_id : ProvIds.hpp
  • c_cmi_id : ProvIds.hpp
  • c_cmi_provider_id : ProvIds.hpp
  • c_cmi_record_id : ProvIds.hpp
  • c_common_setting_editable : DataConnApp.cpp
  • c_compound_sms_item_type : CompoundSmsItem.hpp
  • c_compound_tpdu_item_type : CompoundSmsItem.hpp
  • c_Confirm_imid : InputMap.hpp
  • c_control_imid : InputMap.hpp
  • c_corporate_lockstate_id : ProvIds.hpp
  • c_country_provider_id : ProvIds.hpp
  • c_country_shortname_id : ProvIds.hpp
  • c_cphs_aux_provider_id : ProvIds.hpp
  • c_cphs_costumer_prof_provider_id : ProvIds.hpp
  • c_cphs_infono_provider_id : ProvIds.hpp
  • c_cphs_is_present_id : ProvIds.hpp
  • c_cphs_mbox_provider_id : ProvIds.hpp
  • c_cphs_phase_id : ProvIds.hpp
  • c_cphs_sst_count : SimCphsHandler.hpp
  • c_cphs_sst_len : SimCphsHandler.hpp
  • c_cr : TextEditorDocument.cpp
  • c_crossover_win_id : LocResController.cpp
  • c_csd_data_conn_established : SocketTypes.hpp
  • c_csd_data_conn_init : SocketTypes.hpp
  • c_csd_data_conn_init_release : SocketTypes.hpp
  • c_csd_data_conn_released : SocketTypes.hpp
  • c_csd_data_conn_setup_blocked : SocketTypes.hpp
  • c_csd_data_conn_setup_failed : SocketTypes.hpp
  • c_csd_setting_editable : DataConnApp.cpp
  • c_csms_pid_check_enabled : SimPduHandler.cpp
  • c_csp_activated_id : ProvIds.hpp
  • c_csp_allocated_id : ProvIds.hpp
  • c_currency_code_id : ProvIds.hpp
  • c_currency_eppu_id : ProvIds.hpp
  • c_currency_exp_id : ProvIds.hpp
  • c_data_coding_scheme_id : ProvIds.hpp
  • c_data_conn_profile_changed : SocketTypes.hpp
  • c_data_conn_profile_count : SocketTypes.hpp
  • c_data_conn_profile_created : SocketTypes.hpp
  • c_data_conn_profile_deleted : SocketTypes.hpp
  • c_data_conn_profile_set_as_default : SocketTypes.hpp
  • c_data_conn_temp_profile_count : SocketTypes.hpp
  • c_dataconn_display_text_id : DataConnProvider.hpp
  • c_dataconn_icon_id : DataConnProvider.hpp
  • c_dataconn_is_readonly_id : DataConnProvider.hpp
  • c_dataconn_next_free_row_id : DataConnProvider.hpp
  • c_dataconn_profile_count_id : DataConnProvider.hpp
  • c_dataconn_profile_id : DataConnProvider.hpp
  • c_dataconn_profile_type_id : DataConnProvider.hpp
  • c_dcs_language_code_id : ProviderIds.hpp
  • c_default_audiopath_id : BtHfProvider.hpp
  • c_default_chinese_system_color_table : DefaultChineseTheme.cpp
  • c_default_chinese_system_font_table : DefaultChineseTheme.cpp
  • c_default_csms_state_changeable : SimPduHandler.cpp
  • c_default_data_conn_profile_id : SocketTypes.hpp
  • c_default_depth : PhoneNumber.hpp
  • c_default_max_pdu_per_sms : SimPduHandler.hpp
  • c_default_system_color_table : DefaultTheme.cpp
  • c_default_tpdu_cache_size : SimPduHandler.cpp
  • c_destination_address_id : ProvIds.hpp
  • c_df_cingular_id : SimAccessor.hpp
  • c_df_graphics_id : SimAccessor.hpp
  • c_df_gsm_id : SimAccessor.hpp
  • c_df_mexe_id : SimAccessor.hpp
  • c_df_mf_id : SimAccessor.hpp
  • c_df_orange_id : SimAccessor.hpp
  • c_df_telecom_id : SimAccessor.hpp
  • c_drm_invalid_local_id : DrmCore.hpp
  • c_dummy : ProvIds.hpp
  • c_ecc_alpha_id : ProvIds.hpp
  • c_ecc_category_id : ProvIds.hpp
  • c_ecc_id : ProvIds.hpp
  • c_ecc_phonenumber_id : ProvIds.hpp
  • c_ecc_provider_id : ProvIds.hpp
  • c_ecc_rec_size : SimAccessor.hpp
  • c_ecc_sim_network_cnt_id : ProvIds.hpp
  • c_ecc_source_id : ProvIds.hpp
  • c_edit_box_imid : InputMap.hpp
  • c_EditBoxCursorDown_imid : InputMap.hpp
  • c_EditBoxCursorLeft_imid : InputMap.hpp
  • c_EditBoxCursorRight_imid : InputMap.hpp
  • c_EditBoxCursorUp_imid : InputMap.hpp
  • c_EditBoxDeleteCharacter_imid : InputMap.hpp
  • c_EditBoxDtmfSeparator_imid : InputMap.hpp
  • c_EditBoxPlus_imid : InputMap.hpp
  • c_EditBoxShiftKey_imid : InputMap.hpp
  • c_EditBoxWildcard_imid : InputMap.hpp
  • c_eep_calibration_status_id : ProvIds.hpp
  • c_ef_acm_id : SimAccessor.hpp
  • c_ef_acmmax_id : SimAccessor.hpp
  • c_ef_ad_id : SimAccessor.hpp
  • c_ef_adn_id : SimAccessor.hpp
  • c_ef_arpk_id : SimAccessor.hpp
  • c_ef_bdn_id : SimAccessor.hpp
  • c_ef_call_fwrd_id : SimAccessor.hpp
  • c_ef_cbmi_id : SimAccessor.hpp
  • c_ef_cbmid_id : SimAccessor.hpp
  • c_ef_cbmir_id : SimAccessor.hpp
  • c_ef_ccp_id : SimAccessor.hpp
  • c_ef_cfis_id : SimAccessor.hpp
  • c_ef_cmi_id : SimAccessor.hpp
  • c_ef_cphs_info_no_id : SimAccessor.hpp
  • c_ef_cphsinfo_id : SimAccessor.hpp
  • c_ef_cust_serv_id : SimAccessor.hpp
  • c_ef_dynamic2_id : SimAccessor.hpp
  • c_ef_dynamic_id : SimAccessor.hpp
  • c_ef_ecc_id : SimAccessor.hpp
  • c_ef_elp_id : SimAccessor.hpp
  • c_ef_emlpp_id : SimAccessor.hpp
  • c_ef_ext1_id : SimAccessor.hpp
  • c_ef_ext2_id : SimAccessor.hpp
  • c_ef_ext3_id : SimAccessor.hpp
  • c_ef_ext4_id : SimAccessor.hpp
  • c_ef_ext6_id : SimAccessor.hpp
  • c_ef_ext7_id : SimAccessor.hpp
  • c_ef_fdn_id : SimAccessor.hpp
  • c_ef_img_id : SimAccessor.hpp
  • c_ef_imsi_id : SimAccessor.hpp
  • c_ef_lnd_id : SimAccessor.hpp
  • c_ef_loci_id : SimAccessor.hpp
  • c_ef_lp_id : SimAccessor.hpp
  • c_ef_mbdn_id : SimAccessor.hpp
  • c_ef_mbi_id : SimAccessor.hpp
  • c_ef_mbox_no_id : SimAccessor.hpp
  • c_ef_mexest_id : SimAccessor.hpp
  • c_ef_msisdn_id : SimAccessor.hpp
  • c_ef_opl_id : SimAccessor.hpp
  • c_ef_opn_str_srt_id : SimAccessor.hpp
  • c_ef_opname_str_id : SimAccessor.hpp
  • c_ef_orpk_id : SimAccessor.hpp
  • c_ef_param_id : SimAccessor.hpp
  • c_ef_plmnsel_id : SimAccessor.hpp
  • c_ef_plmnselwact_id : SimAccessor.hpp
  • c_ef_pnn_id : SimAccessor.hpp
  • c_ef_puct_id : SimAccessor.hpp
  • c_ef_sdn_id : SimAccessor.hpp
  • c_ef_sms_id : SimAccessor.hpp
  • c_ef_smsp_id : SimAccessor.hpp
  • c_ef_smsr_id : SimAccessor.hpp
  • c_ef_smss_id : SimAccessor.hpp
  • c_ef_spdi_id : SimAccessor.hpp
  • c_ef_spn_id : SimAccessor.hpp
  • c_ef_sst_id : SimAccessor.hpp
  • c_ef_tprpk_id : SimAccessor.hpp
  • c_ef_tst_id : SimAccessor.hpp
  • c_ef_vbs_id : SimAccessor.hpp
  • c_ef_vbss_id : SimAccessor.hpp
  • c_ef_vgcs_id : SimAccessor.hpp
  • c_ef_vgcss_id : SimAccessor.hpp
  • c_ef_vmsg_wtng_id : SimAccessor.hpp
  • c_email_adr_id : ProvIds.hpp
  • c_email_adr_id_end : ProvIds.hpp
  • c_email_adr_size_id : ProvIds.hpp
  • c_email_id : PbProvIds.hpp
  • c_emergency_list_length : EccProvider.cpp
  • c_emergency_list_length_sim : EccProvider.cpp
  • c_empty_internal_refno : SimPduHandler.cpp
  • c_empty_reload_entry : SimPduHandler.cpp
  • c_empty_string : PbConfig.hpp
  • c_emz_codec_aac_dec_multi_frame_out_buf_max_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_multi_frame_out_buf_max_len : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_multi_frame_out_buf_min_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_op_queue_max_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_single_frame_out_buf_max_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_single_frame_out_buf_min_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_thread_prio : EmzAacDecoderThread.cpp
  • c_emz_codec_aac_dec_thread_stacksize : EmzAacDecoderThread.cpp
  • c_emz_codec_h264_dec_op_queue_max_count : EmzH264Decoder.cpp
  • c_emz_codec_h264_dec_out_buf_max_count : EmzH264Decoder.cpp
  • c_emz_codec_h264_dec_out_buf_min_count : EmzH264Decoder.cpp
  • c_emz_codec_h264_dec_thread_prio : EmzH264DecoderThread.cpp
  • c_emz_codec_h264_dec_thread_stacksize : EmzH264DecoderThread.cpp
  • c_emz_codec_max_num_of_aac_dec_inst : EmzAacDecoder.hpp
  • c_emz_codec_max_num_of_h264_dec_inst : EmzH264Decoder.hpp
  • c_emz_codec_max_num_of_mp3_dec_inst : EmzMp3Decoder.hpp
  • c_emz_codec_max_num_of_mpeg4_dec_inst : EmzMpeg4Decoder.hpp
  • c_emz_codec_max_num_of_sbc_enc_inst : EmzSbcEncoder.hpp
  • c_emz_codec_mp3_dec_multi_frame_out_buf_max_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_multi_frame_out_buf_max_len : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_multi_frame_out_buf_min_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_op_queue_max_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_single_frame_out_buf_max_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_single_frame_out_buf_min_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_thread_prio : EmzMp3DecoderThread.cpp
  • c_emz_codec_mp3_dec_thread_stacksize : EmzMp3DecoderThread.cpp
  • c_emz_codec_mpeg4_dec_op_queue_max_count : EmzMpeg4Decoder.cpp
  • c_emz_codec_mpeg4_dec_out_buf_max_count : EmzMpeg4Decoder.cpp
  • c_emz_codec_mpeg4_dec_out_buf_min_count : EmzMpeg4Decoder.cpp
  • c_emz_codec_mpeg4_dec_thread_prio : EmzMpeg4DecoderThread.cpp
  • c_emz_codec_mpeg4_dec_thread_stacksize : EmzMpeg4DecoderThread.cpp
  • c_emz_codec_mpeg4_enc_op_queue_max_count : EmzMpeg4Encoder.cpp
  • c_emz_codec_mpeg4_enc_out_buf_max_count : EmzMpeg4Encoder.cpp
  • c_emz_codec_mpeg4_enc_out_buf_min_count : EmzMpeg4Encoder.cpp
  • c_emz_codec_mpeg4_enc_thread_prio : EmzMpeg4EncoderThread.cpp
  • c_emz_codec_mpeg4_enc_thread_stacksize : EmzMpeg4EncoderThread.cpp
  • c_emz_codec_sbc_enc_multi_frame_out_buf_max_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_multi_frame_out_buf_max_len : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_multi_frame_out_buf_min_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_op_queue_max_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_single_frame_out_buf_max_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_single_frame_out_buf_min_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_thread_prio : EmzSbcEncoderThread.cpp
  • c_emz_codec_sbc_enc_thread_stacksize : EmzSbcEncoderThread.cpp
  • c_emz_codecs_max_num_of_mpeg4_enc_inst : EmzMpeg4Encoder.hpp
  • c_end_provider_range : ProvIds.hpp
  • c_est_apn_acl : SstProvider.hpp
  • c_est_bdn : SstProvider.hpp
  • c_est_fdn : SstProvider.hpp
  • c_est_provider_id : ProvIds.hpp
  • c_ext_lang_pref_id : ProvIds.hpp
  • c_fdn_provider_id : ProvIds.hpp
  • c_fdn_state_id : ProvIds.hpp
  • c_ff_svr_addr : ServerAddressWin.cpp
  • c_ffs_block_header_size : FfsTypes.hpp
  • c_ffs_streaming : FfsTypes.hpp
  • c_filebrowser_for_voicememo : VoiceMemoRecordWin.cpp
  • c_first_provider_id : ProviderIds.hpp
  • c_first_provider_row_id : ProviderIds.hpp
  • c_first_rec_id : ProvIds.hpp
  • c_fix_data_title_text : LocationResultWin.cpp
  • c_FocusNextControl_imid : InputMap.hpp
  • c_FocusPreviousControl_imid : InputMap.hpp
  • c_foggy_system_color : FoggyTheme.cpp
  • c_foggy_system_color_table : FoggyTheme.cpp
  • c_free_tone : AudioPresetStore.hpp, AudioPresetStore.cpp
  • c_freeextrecords_id : ProvIds.hpp
  • c_fsize_data_conn_profiles : MyDataConnProfileStorage.hpp
  • c_ftp_conn_type_control : FtpTypes.hpp
  • c_ftp_conn_type_data : FtpTypes.hpp
  • c_ftp_data_conn_type_active : FtpTypes.hpp
  • c_ftp_data_conn_type_passive : FtpTypes.hpp
  • c_ftp_service_command_error_failed : FtpTypes.hpp
  • c_ftp_service_command_error_success : FtpTypes.hpp
  • c_ftp_service_command_init : FtpTypes.hpp
  • c_ftp_service_command_start : FtpTypes.hpp
  • c_ftp_service_command_stop : FtpTypes.hpp
  • c_ftp_service_command_terminate : FtpTypes.hpp
  • c_ftp_transfer_direction_in : FtpTypes.hpp
  • c_ftp_transfer_direction_out : FtpTypes.hpp
  • c_ftp_transfer_error_aborted : FtpTypes.hpp
  • c_ftp_transfer_error_complete : FtpTypes.hpp
  • c_ftp_transfer_error_created : FtpTypes.hpp
  • c_ftp_transfer_error_failed : FtpTypes.hpp
  • c_ftp_transfer_error_not_running : FtpTypes.hpp
  • c_ftp_transfer_error_progress : FtpTypes.hpp
  • c_ftp_transfer_error_started : FtpTypes.hpp
  • c_ftp_transfer_mode_block : FtpTypes.hpp
  • c_ftp_transfer_mode_compressed : FtpTypes.hpp
  • c_ftp_transfer_mode_stream : FtpTypes.hpp
  • c_ftp_transfer_structure_file : FtpTypes.hpp
  • c_ftp_transfer_structure_record : FtpTypes.hpp
  • c_ftp_transfer_type_ascii : FtpTypes.hpp
  • c_ftp_transfer_type_image : FtpTypes.hpp
  • c_full_name_ie : SimAuxHandler.cpp
  • c_gas_max_rec_id : ProvIds.hpp
  • c_gas_size_id : ProvIds.hpp
  • c_gati_manager_connections_max : GatiManager.hpp
  • c_gati_manager_database_max : GatiManager.hpp
  • c_gati_manager_port : GatiManager.hpp
  • c_gl_aid_svr_addr : ServerAddressWin.cpp
  • c_gltp_mode_value : AidingDataWin.cpp
  • c_gprs_attached_id : ProvIds.hpp
  • c_gprs_available_id : ProvIds.hpp
  • c_gprs_class_change_origin_id : ProvIds.hpp
  • c_gprs_class_id : ProvIds.hpp
  • c_grid_imid : InputMap.hpp
  • c_GridMoveDown_imid : InputMap.hpp
  • c_GridMoveLeft_imid : InputMap.hpp
  • c_GridMoveRight_imid : InputMap.hpp
  • c_GridMoveUp_imid : InputMap.hpp
  • c_group_id : ProvIds.hpp
  • c_group_id_end : ProvIds.hpp
  • c_grp_prov_id : PbProvIds.hpp
  • c_gsm_band_id : ProvIds.hpp
  • c_gsm_code_id : ProviderIds.hpp
  • c_heapid : HeapManager.cpp
  • c_hidden_info_id : ProvIds.hpp
  • c_hiddenkey_supported_id : ProvIds.hpp
  • c_host_name_len_max : SocketTypes.hpp
  • c_http_response_code_200 : HttpTypes.hpp
  • c_http_response_code_400 : HttpTypes.hpp
  • c_http_response_code_404 : HttpTypes.hpp
  • c_http_service_command_error_failed : HttpTypes.hpp
  • c_http_service_command_error_success : HttpTypes.hpp
  • c_http_service_command_init : HttpTypes.hpp
  • c_http_service_command_start : HttpTypes.hpp
  • c_http_service_command_stop : HttpTypes.hpp
  • c_http_service_command_terminate : HttpTypes.hpp
  • c_icc_id : ProvIds.hpp
  • c_icc_id_id : PbProvIds.hpp
  • c_icon_id : ProvIds.hpp
  • c_icon_isselfexp_id : ProvIds.hpp
  • c_image_ref_ptr_type : ImageRefGenContainer.hpp
  • c_imei_id : ProvIds.hpp
  • c_img_obt_type : ImgObtObj.hpp
  • c_imsi_id : ProvIds.hpp
  • c_index_level_id : ProvIds.hpp
  • c_infnrs_activated_id : ProvIds.hpp
  • c_infnrs_allocated_id : ProvIds.hpp
  • c_insert_width : DefaultCaret.cpp
  • c_invalid_call_id : MmTypes.hpp
  • c_invalid_colid : Provider.hpp
  • c_invalid_context_id : HeapVector.hpp
  • c_invalid_data_conn_profile_id : SocketTypes.hpp
  • c_invalid_date : ToDoRecord.hpp
  • c_invalid_nibble : PhoneNumber.hpp
  • c_invalid_parsed_number : InputAction.hpp
  • c_invalid_position : SimPbEntryCont.hpp
  • C_IR_CONNECTIONS_MAX_NUM : IrdaObexTransport.hpp
  • c_is_free_add_name_id : ProvIds.hpp
  • c_is_free_anr_id : ProvIds.hpp
  • c_is_free_email_adr_id : ProvIds.hpp
  • c_is_free_ext_id : ProvIds.hpp
  • c_it_buffer_size : AtResponseIterator.hpp
  • c_it_read_size : AtResponseIterator.hpp
  • c_item_id : ProvIds.hpp
  • c_item_ptr_type : ItemObj.hpp
  • c_item_string_id : ProvIds.hpp
  • c_key_column_id : ProviderIds.hpp
  • c_lai_lac_id : ProvIds.hpp
  • c_lai_mcc_id : ProvIds.hpp
  • c_lai_mnc_id : ProvIds.hpp
  • c_lang_pref_id : ProvIds.hpp
  • c_language_code_table : LanguageCodeRes.hpp, LanguageCodeRes.cpp
  • c_language_name_id : ProviderIds.hpp
  • c_language_provider_id : ProviderIds.hpp
  • c_language_table_entry_count : LanguageCodeRes.hpp, LanguageCodeRes.cpp
  • c_large_animation_size : InformationElement.hpp
  • c_large_picture_size : InformationElement.hpp
  • c_last_ccm2_id : ProvIds.hpp
  • c_last_ccm_id : ProvIds.hpp
  • c_last_deleted_unique_id : PbProvIds.hpp
  • c_last_rec_id : ProvIds.hpp
  • c_latitude_value : AidingDataWin.cpp
  • c_level_max : BidiManager.cpp
  • c_lf : TextEditorDocument.cpp, ParagraphCompoundItem.cpp
  • c_line_in_use_id : ProvIds.hpp
  • c_line_is_locked_id : ProvIds.hpp
  • c_list_box_imid : InputMap.hpp
  • c_ListBoxNextItem_imid : InputMap.hpp
  • c_ListBoxPreviousItem_imid : InputMap.hpp
  • c_lnd_provider_id : ProvIds.hpp
  • c_loc_res_title_text : LocationResultWin.cpp
  • c_loci_lac_id : ProvIds.hpp
  • c_loci_mcc_id : ProvIds.hpp
  • c_loci_mnc_id : ProvIds.hpp
  • c_loci_mnc_threedigits_id : ProvIds.hpp
  • c_loci_update_status_id : ProvIds.hpp
  • c_lock_dcp_sup_id : ProvIds.hpp
  • c_lock_order_id : ProvIds.hpp
  • c_lock_provider_id : ProvIds.hpp
  • c_lock_result_id : ProvIds.hpp
  • c_lock_retrial_count_id : ProvIds.hpp
  • c_lock_retrial_method_id : ProvIds.hpp
  • c_lock_status_id : ProvIds.hpp
  • c_lock_time_id : ProvIds.hpp
  • c_lock_type_id : ProvIds.hpp
  • c_longitude_value : AidingDataWin.cpp
  • c_ls : BidiManager.cpp
  • c_mark_unmark_icon_table : ToDoProvider.cpp
  • c_max_add_name_columns_id : ProvIds.hpp
  • c_max_allowed_time_for_uib_update : UibPerformanceTest.cpp
  • c_max_anr_columns_id : ProvIds.hpp
  • c_max_at_cmd_params : AtCommand.hpp
  • c_max_at_req_alpha_id_size : AtcTypes.hpp
  • c_max_at_resp_params : AtResponse.hpp
  • c_max_bcd_number_size : PhoneNumber.hpp
  • c_max_calls : Types.hpp
  • c_max_cbmi : SimAuxHandler.hpp
  • c_max_cbmir : SimAuxHandler.hpp
  • c_max_ccp : SimAuxHandler.hpp
  • c_max_channels : Types.hpp
  • c_max_char_visible_in_listbox_todolist : ToDoProvider.hpp
  • c_max_chvs : SignalTypes.hpp
  • c_max_cmi_alpha_id_size : SignalTypes.hpp
  • c_max_cmi_records : SimAuxHandler.hpp
  • c_max_cname_string_len : SignalTypes.hpp
  • c_max_customizable_codes : EccProvider.hpp
  • c_max_data_conn_profile_id : SocketTypes.hpp
  • c_max_ecc_network_elements : SignalTypes.hpp
  • c_max_ecc_network_number_length : SignalTypes.hpp
  • c_max_ecc_records : SimAuxHandler.hpp
  • c_max_email_adr_columns_id : ProvIds.hpp
  • c_max_email_len : PbConfig.hpp
  • c_max_ext_lang_buffer_size : SimAuxHandler.hpp
  • c_max_extlanguages : SimAuxHandler.hpp
  • c_max_fat_filename_len : FatTypes.hpp
  • c_max_fat_max_no_open_files : FatTypes.hpp
  • c_max_filename_len : FfsTypes.hpp
  • c_max_group_columns_id : ProvIds.hpp
  • c_max_groups : GroupProvider.hpp
  • c_max_inet_socket_count : SocketTypes.hpp
  • c_max_ip_str_len : IpAddr.cpp
  • c_max_lang_buffer_size : SimAuxHandler.hpp
  • c_max_languages : SimAuxHandler.hpp
  • c_max_level_count : MultiMediaEditorDocument.hpp
  • c_max_loc_win_id : LocResController.cpp
  • c_max_mbi_record_length : SimAuxHandler.hpp
  • c_max_mem_ptr : HeapManager.cpp
  • c_max_mpty_members : Types.hpp
  • c_max_name_len : PbConfig.hpp
  • c_max_nibble_range : PhoneNumber.hpp
  • c_max_no_basic_service_groups : SignalTypes.hpp
  • c_max_no_sec_locks : LockTypes.hpp
  • c_max_nvram_pdus : SimPduHandler.hpp
  • c_max_pb_name_entries : PbConfig.hpp
  • c_max_pb_number_entries : PbConfig.hpp
  • c_max_pdus : SimPduHandler.hpp
  • c_max_phonebook_descriptors : AtcTypes.hpp
  • c_max_phonebook_entry_len : SignalTypes.hpp
  • c_max_phonenos : PbConfig.hpp
  • c_max_plmn_buffer_size : SimAuxHandler.hpp
  • c_max_plmns : SimAuxHandler.hpp
  • c_max_rb_size : CalendarDialogWin.hpp
  • c_max_rec_id : ProvIds.hpp
  • c_max_reloadable_pdus : SimPduHandler.hpp
  • c_max_serial_terminals : ExternalPsdContextListener.hpp, SerialTerminal.hpp
  • c_max_sim_pdus : SimPduHandler.hpp
  • c_max_size_telephone_nr : SignalTypes.hpp
  • c_max_size_ussd_string : SignalTypes.hpp
  • c_max_slots : DwdPlayer.hpp
  • c_max_smsparam_entry_len : SignalTypes.hpp
  • c_max_smsparameters : SimSmsParamHandler.hpp
  • c_max_smsr_in_ram : SimPduHandler.hpp
  • c_max_smsr_length : SimPduHandler.hpp
  • c_max_smsr_pdus : SimPduHandler.hpp
  • c_max_specific_at_resp_params : AtCommand.hpp
  • c_max_sst_services : SignalTypes.hpp
  • c_max_table1 : SimPduHandler.hpp
  • c_max_table2 : SimPduHandler.hpp
  • c_max_telnr_size : PhoneNumber.hpp
  • c_max_thread_name_length : Thread.hpp
  • c_max_total_ffs_memory : FfsTypes.hpp
  • c_max_unique_id : PbMergeProvider.hpp
  • c_max_uus1_out_buffer_len : SignalTypes.hpp
  • c_maxno_usim_langs : SignalTypes.hpp
  • c_maxno_usim_plmns : NetworkTypes.hpp
  • c_maxpending_messages : SimAccessor.hpp
  • c_mbdn_provider_id : ProvIds.hpp
  • c_mbi_provider_id : ProvIds.hpp
  • c_mboxnrs_activated_id : ProvIds.hpp
  • c_mboxnrs_allocated_id : ProvIds.hpp
  • c_mcc_id : ProvIds.hpp
  • c_mdh_max_ext_data : MdhTypes.hpp
  • c_mdni_electronic_mail_id : ProvIds.hpp
  • c_mdni_fax_id : ProvIds.hpp
  • c_mdni_other_id : ProvIds.hpp
  • c_mdni_videomail_id : ProvIds.hpp
  • c_mdni_voicemail_id : ProvIds.hpp
  • c_menu_desc_ptr_type : MenuDescObj.hpp
  • c_menu_id_ptr_type : MenuIdObj.hpp
  • c_MenuItemSelected_imid : InputMap.hpp
  • c_merged_provider_id : ProviderIds.hpp
  • c_merged_row_id : ProviderIds.hpp
  • c_mime_apoxi_settings : MimeTypeTable.hpp
  • c_mime_app_j2me_archieve : MimeTypeTable.hpp
  • c_mime_app_j2me_jrs : MimeTypeTable.hpp
  • c_mime_app_mmf : MimeTypeTable.hpp
  • c_mime_app_sdp : MimeTypeTable.hpp
  • c_mime_app_spf : MimeTypeTable.hpp
  • c_mime_audio_3gpp : MimeTypeTable.hpp
  • c_mime_audio_aac : MimeTypeTable.hpp
  • c_mime_audio_amr : MimeTypeTable.hpp
  • c_mime_audio_imelody : MimeTypeTable.hpp
  • c_mime_audio_m4a : MimeTypeTable.hpp
  • c_mime_audio_midi : MimeTypeTable.hpp
  • c_mime_audio_mobile_xmf : MimeTypeTable.hpp
  • c_mime_audio_mpeg : MimeTypeTable.hpp
  • c_mime_audio_wav : MimeTypeTable.hpp
  • c_mime_drm_content : MimeTypeTable.hpp
  • c_mime_drm_encoded : MimeTypeTable.hpp
  • c_mime_drm_message : MimeTypeTable.hpp
  • c_mime_drm_ro : MimeTypeTable.hpp
  • c_mime_drm_textual : MimeTypeTable.hpp
  • c_mime_image_bmp : MimeTypeTable.hpp
  • c_mime_image_ems : MimeTypeTable.hpp
  • c_mime_image_gif : MimeTypeTable.hpp
  • c_mime_image_jpeg : MimeTypeTable.hpp
  • c_mime_image_png : MimeTypeTable.hpp
  • c_mime_image_svg : MimeTypeTable.hpp
  • c_mime_image_svgz : MimeTypeTable.hpp
  • c_mime_image_tiff : MimeTypeTable.hpp
  • c_mime_image_wbmp : MimeTypeTable.hpp
  • c_mime_text_calendar : MimeTypeTable.hpp
  • c_mime_text_html : MimeTypeTable.hpp
  • c_mime_text_j2me_appdesc : MimeTypeTable.hpp
  • c_mime_text_plain : MimeTypeTable.hpp
  • c_mime_text_vcard : MimeTypeTable.hpp
  • c_mime_text_wml : MimeTypeTable.hpp
  • c_mime_text_wmlscript : MimeTypeTable.hpp
  • c_mime_text_xhtml : MimeTypeTable.hpp
  • c_mime_text_xml : MimeTypeTable.hpp
  • c_mime_unknown : MimeTypeTable.hpp
  • c_mime_user_offset : MimeTypeTable.hpp
  • c_mime_video_3gpp : MimeTypeTable.hpp
  • c_mime_video_mpeg : MimeTypeTable.hpp
  • c_mime_video_msvideo : MimeTypeTable.hpp
  • c_mime_video_quicktime : MimeTypeTable.hpp
  • c_mm_call_terminal_data_bits : MmCallHandler.hpp
  • c_mm_call_terminal_speed : MmCallHandler.hpp
  • c_mm_call_terminal_stop_bits : MmCallHandler.hpp
  • c_mnc_id : ProvIds.hpp
  • c_mnc_threedigits_id : ProvIds.hpp
  • c_mode_id : ProvIds.hpp
  • c_mp_high_max : MergeProvider.cpp
  • c_mp_low_max : MergeProvider.cpp
  • c_mp_merge_max : MergeProvider.cpp
  • c_mpty_indication : Types.hpp
  • c_msg_count_id : ProvIds.hpp
  • c_msg_ind_level_id : ProvIds.hpp
  • c_msg_ind_setting_id : ProvIds.hpp
  • c_msg_ind_sms_type_id : ProvIds.hpp
  • c_msg_position_id : ProvIds.hpp
  • c_msg_queue_yield_period : MsgQueue.cpp
  • c_msg_update_id : ProvIds.hpp
  • c_msg_wait_ind_data_id : ProvIds.hpp
  • c_msg_wait_ind_fax_id : ProvIds.hpp
  • c_msg_wait_ind_line1_id : ProvIds.hpp
  • c_msg_wait_ind_line2_id : ProvIds.hpp
  • c_msg_waiting_priority : SmsIndicationState.hpp
  • c_msisdn_provider_id : ProvIds.hpp
  • c_mtc_mask : SignalTypes.hpp
  • c_mutex_timeout : Types.hpp
  • c_name_id : ProvIds.hpp
  • c_name_key_id : PbProvIds.hpp
  • c_name_prov_id : PbProvIds.hpp
  • c_network_lockstate_id : ProvIds.hpp
  • c_network_name_long_id : ProvIds.hpp
  • c_network_name_short_id : ProvIds.hpp
  • c_networktype_id : ProvIds.hpp
  • c_new_recno_id : PbProvIds.hpp
  • c_new_sms_priority : SmsIndicationState.hpp
  • c_new_status_report_priority : SmsIndicationState.hpp
  • c_next_action_id : ProvIds.hpp
  • c_nextfreeposition_id : ProvIds.hpp
  • c_no_aas_record_value : UsimPbTypes.hpp
  • c_no_data_record_id : DataRecord.hpp
  • c_no_files : ProvIds.hpp
  • c_no_group_value : UsimPbTypes.hpp
  • c_no_id : ProvIds.hpp
  • c_no_id_id : PbProvIds.hpp
  • c_no_locks_id : ProvIds.hpp
  • c_no_of_extlanguages_array : SignalTypes.hpp
  • c_no_of_languages_array : SignalTypes.hpp
  • c_no_prov_id : PbProvIds.hpp
  • c_no_row : Provider.hpp
  • c_no_tipd : SignalTypes.hpp
  • c_no_tonepairs : AudioTypes.cpp
  • c_note_max_length : ToDoRecord.hpp
  • c_null_call_index : Types.hpp
  • c_null_channel_no : Types.hpp
  • c_null_tipd : SignalTypes.hpp
  • c_nw_spec_id : ProvIds.hpp
  • c_offset_dcs : SimSmsParamHandler.cpp
  • c_offset_dest_address : SimSmsParamHandler.cpp
  • c_offset_protocol_id : SimSmsParamHandler.cpp
  • c_offset_sc_address : SimSmsParamHandler.cpp
  • c_offset_vp : SimSmsParamHandler.cpp
  • c_ofm_to_be_activated_id : ProvIds.hpp
  • c_on_sim_id : PbProvIds.hpp
  • c_op_srt_name_file_len : SimCphsHandler.hpp
  • c_operator_name_id : ProvIds.hpp
  • c_operator_shortname_id : ProvIds.hpp
  • c_opname_activated_id : ProvIds.hpp
  • c_opname_allocated_id : ProvIds.hpp
  • c_options_id : ProvIds.hpp
  • c_orange_welcome_msg_id : ProvIds.hpp
  • c_overwrite_width : DefaultCaret.cpp
  • c_password_len : SignalTypes.hpp
  • c_pb_client_autoload_flag : UsimPbTypes.hpp
  • c_pb_max_file_type_per_record : UsimPbTypes.hpp
  • c_pb_max_groups : UsimPbTypes.hpp
  • c_pb_max_slices : UsimPbTypes.hpp
  • c_pending_priority : SmsIndicationState.hpp
  • c_phone_no_id : ProvIds.hpp
  • c_phoneno_type_id : PbProvIds.hpp
  • c_plmn_name_id : ProvIds.hpp
  • c_plmn_provider_id : ProvIds.hpp
  • c_plmn_rec_size : SimAccessor.hpp
  • c_plmn_shortname_id : ProvIds.hpp
  • c_pref_service_id : ProvIds.hpp
  • c_prefextlang2_provider_id : ProvIds.hpp
  • c_prefextlang_provider_id : ProvIds.hpp
  • c_preflang_provider_id : ProvIds.hpp
  • c_prefplmn_provider_id : ProvIds.hpp
  • c_premium_serv_id : ProvIds.hpp
  • c_preview_count : MultiTapCaret.cpp
  • c_protocol_identifier_id : ProvIds.hpp
  • c_psd_data_conn_established : SocketTypes.hpp
  • c_psd_data_conn_init : SocketTypes.hpp
  • c_psd_data_conn_init_release : SocketTypes.hpp
  • c_psd_data_conn_released : SocketTypes.hpp
  • c_psd_data_conn_setup_blocked : SocketTypes.hpp
  • c_psd_data_conn_setup_failed : SocketTypes.hpp
  • c_psd_menu_item_count : DataConnAccessor.hpp
  • c_psd_setting_editable : DataConnApp.cpp
  • c_puct_chv_id : ProvIds.hpp
  • c_puct_rec_size : SimAccessor.hpp
  • c_push_button_imid : InputMap.hpp
  • c_PushButtonClick_imid : InputMap.hpp
  • c_PushButtonRelease_imid : InputMap.hpp
  • c_radio_button_imid : InputMap.hpp
  • c_radio_button_list_imid : InputMap.hpp
  • c_radio_freq : FmRadioStationsProvider.hpp
  • c_radio_last_freq : FmRadioSettingsProvider.hpp
  • c_radio_last_volume : FmRadioSettingsProvider.hpp
  • c_radio_stat_text : FmRadioStationsProvider.hpp
  • c_RadioButtonNextItem_imid : InputMap.hpp
  • c_RadioButtonPreviousItem_imid : InputMap.hpp
  • c_ram_storage_default_block_size : RamTypes.hpp
  • c_rat_change_mode_id : ProvIds.hpp
  • c_rat_id : ProvIds.hpp
  • c_recno_id : PbProvIds.hpp
  • c_redialing_active_id : ProvIds.hpp
  • c_regblobobject_type : RegBlobObject.hpp
  • c_reject_cause_id : ProvIds.hpp
  • c_rep_interval_value : AidingDataWin.cpp
  • c_result_id : ProvIds.hpp
  • c_sat_graph_title_text : SatteliteGraphWin.cpp
  • c_sat_info_title_text : SatteliteInfoWin.cpp
  • c_scicos_codec_if_max_num_of_vid_dec_inst : ScicosMpeg4VideoDecoder.hpp
  • c_scicos_codec_if_max_num_of_vid_enc_inst : ScicosMpeg4VideoEncoder.hpp
  • c_scmt_control_data_available : SocketTypes.hpp
  • c_scmt_csd_datacall_release : SocketTypes.hpp
  • c_scmt_csd_datacall_setup : SocketTypes.hpp
  • c_scmt_csd_datacall_setup_fail : SocketTypes.hpp
  • c_scmt_csd_datacall_setup_success : SocketTypes.hpp
  • c_scmt_csd_lost : SocketTypes.hpp
  • c_scmt_csd_setup_err : SocketTypes.hpp
  • c_scmt_data_conn_cancelled : SocketTypes.hpp
  • c_scmt_data_conn_established : SocketTypes.hpp
  • c_scmt_idle_timeout : SocketTypes.hpp
  • c_scmt_init_context_err : SocketTypes.hpp
  • c_scmt_ppp_setup : SocketTypes.hpp
  • c_scmt_ppp_setup_err : SocketTypes.hpp
  • c_scmt_ppp_stop : SocketTypes.hpp
  • c_scmt_ppp_stop_err : SocketTypes.hpp
  • c_scmt_psd_ctx_authenticated : SocketTypes.hpp
  • c_scmt_psd_ctx_connected : SocketTypes.hpp
  • c_scmt_psd_ctx_deactivated : SocketTypes.hpp
  • c_scmt_psd_ctx_defined : SocketTypes.hpp
  • c_scmt_psd_ctx_dns_neg_set : SocketTypes.hpp
  • c_scmt_psd_ctx_link_down : SocketTypes.hpp
  • c_scmt_psd_ctx_link_up : SocketTypes.hpp
  • c_scmt_psd_ctx_neg_dns_read : SocketTypes.hpp
  • c_scmt_psd_ctx_packet_filter_set : SocketTypes.hpp
  • c_scmt_psd_ctx_qos_set : SocketTypes.hpp
  • c_scmt_psd_ctx_undefined : SocketTypes.hpp
  • c_scmt_psd_lost : SocketTypes.hpp
  • c_scmt_psd_setup_err : SocketTypes.hpp
  • c_scmt_rx_data_arrived : SocketTypes.hpp
  • c_scmt_tx_data_ready : SocketTypes.hpp
  • c_scmt_undefined : SocketTypes.hpp
  • c_sdn_provider_id : ProvIds.hpp
  • c_second_provider_id : ProviderIds.hpp
  • c_second_provider_row_id : ProviderIds.hpp
  • c_sem_obtain_timeout : Types.hpp
  • c_ser_data_conn_established : SocketTypes.hpp
  • c_ser_data_conn_init : SocketTypes.hpp
  • c_ser_data_conn_init_release : SocketTypes.hpp
  • c_ser_data_conn_released : SocketTypes.hpp
  • c_ser_data_conn_setup_blocked : SocketTypes.hpp
  • c_ser_data_conn_setup_failed : SocketTypes.hpp
  • c_ser_menu_item_count : DataConnAccessor.hpp
  • c_serv_als_id : ProvIds.hpp
  • c_serv_aoc_id : ProvIds.hpp
  • c_serv_baic_id : ProvIds.hpp
  • c_serv_bic_roam_id : ProvIds.hpp
  • c_serv_boac_id : ProvIds.hpp
  • c_serv_boic_exhc_id : ProvIds.hpp
  • c_serv_boic_id : ProvIds.hpp
  • c_serv_ccbs_id : ProvIds.hpp
  • c_serv_cfb_id : ProvIds.hpp
  • c_serv_cfnrc_id : ProvIds.hpp
  • c_serv_cfnry_id : ProvIds.hpp
  • c_serv_cfu_id : ProvIds.hpp
  • c_serv_cli_block_id : ProvIds.hpp
  • c_serv_cli_send_id : ProvIds.hpp
  • c_serv_clip_id : ProvIds.hpp
  • c_serv_co_lp_id : ProvIds.hpp
  • c_serv_co_lr_id : ProvIds.hpp
  • c_serv_ct_id : ProvIds.hpp
  • c_serv_cug_id : ProvIds.hpp
  • c_serv_cug_oa_id : ProvIds.hpp
  • c_serv_cw_id : ProvIds.hpp
  • c_serv_data_id : ProvIds.hpp
  • c_serv_del_conf_id : ProvIds.hpp
  • c_serv_fax_id : ProvIds.hpp
  • c_serv_gprs_id : ProvIds.hpp
  • c_serv_hold_id : ProvIds.hpp
  • c_serv_hscsd_id : ProvIds.hpp
  • c_serv_info_numbers_id : ProvIds.hpp
  • c_serv_language_id : ProvIds.hpp
  • c_serv_mci_id : ProvIds.hpp
  • c_serv_mpty_id : ProvIds.hpp
  • c_serv_mtpl_band_id : ProvIds.hpp
  • c_serv_mtpl_subs_pfl_id : ProvIds.hpp
  • c_serv_plmn_mode_id : ProvIds.hpp
  • c_serv_pref_cug_id : ProvIds.hpp
  • c_serv_protid_id : ProvIds.hpp
  • c_serv_repl_path_id : ProvIds.hpp
  • c_serv_sm_cb_id : ProvIds.hpp
  • c_serv_sm_mo_id : ProvIds.hpp
  • c_serv_sm_mt_id : ProvIds.hpp
  • c_serv_smmo_email_id : ProvIds.hpp
  • c_serv_smmo_paging_id : ProvIds.hpp
  • c_serv_usr_usr_sig_id : ProvIds.hpp
  • c_serv_val_per_id : ProvIds.hpp
  • c_serv_vgrp_call_id : ProvIds.hpp
  • c_serv_voice_bcst_serv_id : ProvIds.hpp
  • c_serv_vps_id : ProvIds.hpp
  • c_server_get_packet_size : BtBipGetRsp.cpp
  • c_service_activated_id : ProvIds.hpp
  • c_service_allocated_id : ProvIds.hpp
  • c_service_available_id : ProvIds.hpp
  • c_service_center_address_id : ProvIds.hpp
  • c_short_name_ie : SimAuxHandler.cpp
  • c_show_satellite_graph : LocResController.cpp
  • c_shutdown_app_close_timeout : ShutDown.cpp
  • c_shutdown_check_applications_interval : ShutDown.cpp
  • c_signal_quality_id : ProvIds.hpp
  • c_signal_quality_max_id : ProvIds.hpp
  • c_signal_strength_id : ProvIds.hpp
  • c_signal_strength_max_id : ProvIds.hpp
  • c_sim_errorcode_id : ProvIds.hpp
  • c_sim_ind_id : ProvIds.hpp
  • c_sim_init_result_id : ProvIds.hpp
  • c_sim_lockstate_id : ProvIds.hpp
  • c_sim_memory_error : SignalTypes.hpp
  • c_sim_phase_id : ProvIds.hpp
  • c_sim_recno_id : PbProvIds.hpp
  • c_sim_secret_code_locked_error : SignalTypes.hpp
  • c_sim_security_error : SignalTypes.hpp
  • c_sim_type_id : ProvIds.hpp
  • c_simpos_id : ProvIds.hpp
  • c_simtk_mainmenu_provider_id : ProvIds.hpp
  • c_single_beep : AudioPresetStore.hpp, AudioPresetStore.cpp
  • c_size_of_orange_param : SignalTypes.hpp
  • c_size_smsparameters : SimSmsParamHandler.hpp
  • c_sizeof_extlanguagearray : SignalTypes.hpp
  • c_sizeof_languagearray : SignalTypes.hpp
  • c_slice_id : ProvIds.hpp
  • c_small_animation_size : InformationElement.hpp
  • c_small_picture_size : InformationElement.hpp
  • c_sms_alpha_id : ProvIds.hpp
  • c_sms_base_archive_provider_id : ProvIds.hpp
  • c_sms_base_inbox_provider_id : ProvIds.hpp
  • c_sms_base_outbox_provider_id : ProvIds.hpp
  • c_sms_base_statusreport_provider_id : ProvIds.hpp
  • c_sms_base_unread_provider_id : ProvIds.hpp
  • c_sms_class0_provider_id : ProvIds.hpp
  • c_sms_coding_group_id : ProvIds.hpp
  • c_sms_compound_sms_id : ProvIds.hpp
  • c_sms_compound_tpdu_id : ProvIds.hpp
  • c_sms_conc_max_no_id : ProvIds.hpp
  • c_sms_conc_ref_no_id : ProvIds.hpp
  • c_sms_conc_seq_no_id : ProvIds.hpp
  • c_sms_conc_status_id : ProvIds.hpp
  • c_sms_conc_tpdu_num_id : ProvIds.hpp
  • c_sms_count_provider_id : ProvIds.hpp
  • c_sms_date_id : ProvIds.hpp
  • c_sms_datetime_id : ProvIds.hpp
  • c_sms_dcs_id : ProvIds.hpp
  • c_sms_debugstring_id : ProvIds.hpp
  • c_sms_extended_data_id : ProvIds.hpp
  • c_sms_free_pdu_id : ProvIds.hpp
  • c_sms_header_text_id : ProvIds.hpp
  • c_sms_message_provider_id : ProvIds.hpp
  • c_sms_message_status_id : ProvIds.hpp
  • c_sms_msg_class_id : ProvIds.hpp
  • c_sms_msg_type_id : ProvIds.hpp
  • c_sms_no_pdu_flash_id : ProvIds.hpp
  • c_sms_no_pdu_sim_id : ProvIds.hpp
  • c_sms_param_name_id : ProvIds.hpp
  • c_sms_parameter_provider_id : ProvIds.hpp
  • c_sms_pdu_data_id : ProvIds.hpp
  • c_sms_phonenumber_id : ProvIds.hpp
  • c_sms_pos_id : ProvIds.hpp
  • c_sms_protid_id : ProvIds.hpp
  • c_sms_provider_id : ProvIds.hpp
  • c_sms_read_count_id : ProvIds.hpp
  • c_sms_read_provider_id : ProvIds.hpp
  • c_sms_recno_id : ProvIds.hpp
  • c_sms_refno_id : ProvIds.hpp
  • c_sms_reply_path_flag_id : ProvIds.hpp
  • c_sms_sca_id : ProvIds.hpp
  • c_sms_sent_count_id : ProvIds.hpp
  • c_sms_sent_provider_id : ProvIds.hpp
  • c_sms_status_id : ProvIds.hpp
  • c_sms_storage_media_id : ProvIds.hpp
  • c_sms_string_id : ProvIds.hpp
  • c_sms_sum_id : ProvIds.hpp
  • c_sms_time_id : ProvIds.hpp
  • c_sms_time_out : MdhSignalProcessor.cpp
  • c_sms_tpdu_capacity_id : ProvIds.hpp
  • c_sms_tpdu_empty_id : ProvIds.hpp
  • c_sms_tpdu_occupied_id : ProvIds.hpp
  • c_sms_unread_count_id : ProvIds.hpp
  • c_sms_unread_provider_id : ProvIds.hpp
  • c_sms_unsent_count_id : ProvIds.hpp
  • c_sms_unsent_provider_id : ProvIds.hpp
  • c_smsp_alpha_id_len_id : ProvIds.hpp
  • c_smsp_rw_buffer_len : SimSmsParamHandler.hpp
  • c_smsr_no_link : SimPduHandler.cpp
  • c_socket_bearer_busy : SocketTypes.hpp
  • c_socket_bearer_not_supported : SocketTypes.hpp
  • c_socket_conn_blocked : SocketTypes.hpp
  • c_socket_conn_in_release : SocketTypes.hpp
  • c_socket_conn_in_setup : SocketTypes.hpp
  • c_socket_conn_lost : SocketTypes.hpp
  • c_socket_conn_perform_setup : SocketTypes.hpp
  • c_socket_conn_setup_failed : SocketTypes.hpp
  • c_socket_conn_timed_out : SocketTypes.hpp
  • c_socket_eacces : SocketTypes.hpp
  • c_socket_eaddrinuse : SocketTypes.hpp
  • c_socket_eaddrnotavail : SocketTypes.hpp
  • c_socket_eafnosupport : SocketTypes.hpp
  • c_socket_ealready : SocketTypes.hpp
  • c_socket_ebadf : SocketTypes.hpp
  • c_socket_econnaborted : SocketTypes.hpp
  • c_socket_econnrefused : SocketTypes.hpp
  • c_socket_econnreset : SocketTypes.hpp
  • c_socket_edestaddrreq : SocketTypes.hpp
  • c_socket_efault : SocketTypes.hpp
  • c_socket_ehostdown : SocketTypes.hpp
  • c_socket_ehostunreach : SocketTypes.hpp
  • c_socket_einprogress : SocketTypes.hpp
  • c_socket_eintr : SocketTypes.hpp
  • c_socket_einval : SocketTypes.hpp
  • c_socket_eisconn : SocketTypes.hpp
  • c_socket_emfile : SocketTypes.hpp
  • c_socket_emsgsize : SocketTypes.hpp
  • c_socket_enetdown : SocketTypes.hpp
  • c_socket_enetreset : SocketTypes.hpp
  • c_socket_enetunreach : SocketTypes.hpp
  • c_socket_enobufs : SocketTypes.hpp
  • c_socket_enoprotoopt : SocketTypes.hpp
  • c_socket_enotconn : SocketTypes.hpp
  • c_socket_enotsock : SocketTypes.hpp
  • c_socket_eopnotsupp : SocketTypes.hpp
  • c_socket_epfnosupport : SocketTypes.hpp
  • c_socket_eprotonosupport : SocketTypes.hpp
  • c_socket_eprototype : SocketTypes.hpp
  • c_socket_eshutdown : SocketTypes.hpp
  • c_socket_esocktnosupport : SocketTypes.hpp
  • c_socket_etimedout : SocketTypes.hpp
  • c_socket_ewouldblock : SocketTypes.hpp
  • c_socket_fatal_system_error : SocketTypes.hpp
  • c_socket_no_bearer : SocketTypes.hpp
  • c_socket_no_data_conn_profile : SocketTypes.hpp
  • c_socket_no_error : SocketTypes.hpp
  • c_socket_subsystem_not_init : SocketTypes.hpp
  • c_socket_unknown_error : SocketTypes.hpp
  • c_socket_wait_for_recv_unblocked : SocketTypes.hpp
  • c_socket_wait_for_send_unblocked : SocketTypes.hpp
  • c_socket_wrong_execution_context : SocketTypes.hpp
  • c_sp_lockstate_id : ProvIds.hpp
  • c_spn_display_condition_id : ProvIds.hpp
  • c_spn_id : ProvIds.hpp
  • c_sst_activated_id : ProvIds.hpp
  • c_sst_adn : SstProvider.hpp
  • c_sst_allocated_id : ProvIds.hpp
  • c_sst_aoc : SstProvider.hpp
  • c_sst_bdn : SstProvider.hpp
  • c_sst_call_control : SstProvider.hpp
  • c_sst_cbmi : SstProvider.hpp
  • c_sst_cbmi_ranges : SstProvider.hpp
  • c_sst_ccp : SstProvider.hpp
  • c_sst_cfis : SstProvider.hpp
  • c_sst_chv1_disable_function : SstProvider.hpp
  • c_sst_coop_network_list : SstProvider.hpp
  • c_sst_cpbcch_info : SstProvider.hpp
  • c_sst_depers_control_keys : SstProvider.hpp
  • c_sst_dwld_sms_cb : SstProvider.hpp
  • c_sst_dwld_sms_pp : SstProvider.hpp
  • c_sst_eccp : SstProvider.hpp
  • c_sst_emlpp : SstProvider.hpp
  • c_sst_emlpp_answer : SstProvider.hpp
  • c_sst_ext1 : SstProvider.hpp
  • c_sst_ext2 : SstProvider.hpp
  • c_sst_ext3 : SstProvider.hpp
  • c_sst_ext4 : SstProvider.hpp
  • c_sst_ext8 : SstProvider.hpp
  • c_sst_fdn : SstProvider.hpp
  • c_sst_gil1 : SstProvider.hpp
  • c_sst_gil2 : SstProvider.hpp
  • c_sst_gprs : SstProvider.hpp
  • c_sst_hplmn_access_tech : SstProvider.hpp
  • c_sst_image : SstProvider.hpp
  • c_sst_investigation_scan : SstProvider.hpp
  • c_sst_lnd : SstProvider.hpp
  • c_sst_mbdn : SstProvider.hpp
  • c_sst_menu_selection : SstProvider.hpp
  • c_sst_mexe : SstProvider.hpp
  • c_sst_mms : SstProvider.hpp
  • c_sst_mms_user_con_params : SstProvider.hpp
  • c_sst_mo_sm_sim : SstProvider.hpp
  • c_sst_msisdn : SstProvider.hpp
  • c_sst_mwis : SstProvider.hpp
  • c_sst_networkind_alerting : SstProvider.hpp
  • c_sst_opl : SstProvider.hpp
  • c_sst_oplmn_sel_access_tech : SstProvider.hpp
  • c_sst_plmn_sel : SstProvider.hpp
  • c_sst_plmn_sel_access_tech : SstProvider.hpp
  • c_sst_pnn : SstProvider.hpp
  • c_sst_proactive_sim : SstProvider.hpp
  • c_sst_provider_id : ProvIds.hpp
  • c_sst_run_at_command : SstProvider.hpp
  • c_sst_sdn : SstProvider.hpp
  • c_sst_sms : SstProvider.hpp
  • c_sst_sms_parameters : SstProvider.hpp
  • c_sst_sms_reports : SstProvider.hpp
  • c_sst_solsa : SstProvider.hpp
  • c_sst_spdi : SstProvider.hpp
  • c_sst_spn : SstProvider.hpp
  • c_sst_ussd_in_callcontrol : SstProvider.hpp
  • c_sst_vbs_gil : SstProvider.hpp
  • c_sst_vgcs_gil : SstProvider.hpp
  • c_stack_magic_start : Scheduler.cpp
  • c_start_provider_range : ProvIds.hpp
  • c_state_id : ProvIds.hpp
  • c_status_provider_id : ProvIds.hpp
  • c_succ_16bit_conc_sms_ref_no : ProvIds.hpp
  • c_sync_supported_id : ProvIds.hpp
  • c_syncml_database_max : SyncMLManager.hpp
  • c_system_color : DefaultTheme.cpp, DefaultChineseTheme.cpp
  • c_t9_key_buf_len : ChineseT9Wrapper.cpp
  • c_t9_selectpage_buf_len : ChineseT9Wrapper.cpp
  • c_tagsize_id : ProvIds.hpp
  • c_test_system_color_table : TestTheme.cpp
  • c_test_system_font_table : TestTheme.cpp
  • c_timeout_seconds : SimAccessor.hpp
  • c_title_icon_id : ProvIds.hpp
  • c_title_icon_isselfexp_id : ProvIds.hpp
  • c_title_id : ProvIds.hpp
  • c_tlv_len_byte_mask : Tlv.hpp
  • c_tlv_two_byte_len_sign : Tlv.hpp
  • c_tone_supervisory_call_waiting : AudioPresetStore.hpp, AudioPresetStore.cpp
  • c_tone_supervisory_subsciber_busy : AudioPresetStore.hpp, AudioPresetStore.cpp
  • c_total_rec_id : ProvIds.hpp
  • c_trap_system_stack_log_size : Trap.cpp
  • c_tst_file_size : SimAccessor.hpp
  • c_tz_dst_id : ProvIds.hpp
  • c_tz_offset_id : ProvIds.hpp
  • c_uid_id : ProvIds.hpp
  • c_unblocking_attempts_left_id : ProvIds.hpp
  • c_undefined_pdu_pos : MdhTypes.hpp
  • c_undefined_view_handle : MdhTypes.hpp
  • c_unique_id : PbProvIds.hpp
  • c_unit_id_value : AidingDataWin.cpp
  • c_unlock_keybased : ProvIds.hpp
  • c_unlock_menubased : ProvIds.hpp
  • c_unlock_startup : ProvIds.hpp
  • c_unread_entry : SimPbEntry.hpp
  • c_user_base_gentypes : GenericObject.hpp
  • c_usimpb_addnumberstring_provider_id : ProvIds.hpp
  • c_usimpb_groupname_provider_id : ProvIds.hpp
  • c_usimpb_property_provider_id : ProvIds.hpp
  • c_usimpb_provider_id : ProvIds.hpp
  • c_ust_acl : SstProvider.hpp
  • c_ust_aoc : SstProvider.hpp
  • c_ust_auto_emlpp : SstProvider.hpp
  • c_ust_bdn_pb : SstProvider.hpp
  • c_ust_callcontrol_gprs_usim : SstProvider.hpp
  • c_ust_callcontrol_usim : SstProvider.hpp
  • c_ust_cbmi : SstProvider.hpp
  • c_ust_cbmir : SstProvider.hpp
  • c_ust_ccp : SstProvider.hpp
  • c_ust_cfis : SstProvider.hpp
  • c_ust_coop_network_list : SstProvider.hpp
  • c_ust_cpbcch_info : SstProvider.hpp
  • c_ust_datadownload_smscb : SstProvider.hpp
  • c_ust_datadownload_smspp : SstProvider.hpp
  • c_ust_datadownload_ussd_appl : SstProvider.hpp
  • c_ust_dck : SstProvider.hpp
  • c_ust_emlpp : SstProvider.hpp
  • c_ust_equivalent_hplmn : SstProvider.hpp
  • c_ust_est : SstProvider.hpp
  • c_ust_ext2 : SstProvider.hpp
  • c_ust_ext3 : SstProvider.hpp
  • c_ust_ext4 : SstProvider.hpp
  • c_ust_ext5 : SstProvider.hpp
  • c_ust_ext8 : SstProvider.hpp
  • c_ust_fdn_pb : SstProvider.hpp
  • c_ust_generic_bootstrapping : SstProvider.hpp
  • c_ust_gid_level1 : SstProvider.hpp
  • c_ust_gid_level2 : SstProvider.hpp
  • c_ust_gsm_access : SstProvider.hpp
  • c_ust_gsm_security_context : SstProvider.hpp
  • c_ust_hplmnwact : SstProvider.hpp
  • c_ust_image : SstProvider.hpp
  • c_ust_in_call_info : SstProvider.hpp
  • c_ust_inv_scan : SstProvider.hpp
  • c_ust_local_pb : SstProvider.hpp
  • c_ust_mbdn : SstProvider.hpp
  • c_ust_mbms_security : SstProvider.hpp
  • c_ust_mexe : SstProvider.hpp
  • c_ust_mms : SstProvider.hpp
  • c_ust_mms_storage : SstProvider.hpp
  • c_ust_mms_ucp : SstProvider.hpp
  • c_ust_mosmscontrol_usim : SstProvider.hpp
  • c_ust_msisdn : SstProvider.hpp
  • c_ust_mwis : SstProvider.hpp
  • c_ust_nia : SstProvider.hpp
  • c_ust_notused : SstProvider.hpp
  • c_ust_op_plmnlist : SstProvider.hpp
  • c_ust_opcont_plmnwact : SstProvider.hpp
  • c_ust_operator_plmn_sel_wlan_access : SstProvider.hpp
  • c_ust_operator_wsid_list : SstProvider.hpp
  • c_ust_out_call_info : SstProvider.hpp
  • c_ust_plmn_networkname : SstProvider.hpp
  • c_ust_plmnwact : SstProvider.hpp
  • c_ust_provider_id : ProvIds.hpp
  • c_ust_pseudonym : SstProvider.hpp
  • c_ust_res : SstProvider.hpp
  • c_ust_rfu : SstProvider.hpp
  • c_ust_runat_command : SstProvider.hpp
  • c_ust_sdn_pb : SstProvider.hpp
  • c_ust_set_to_1 : SstProvider.hpp
  • c_ust_sms : SstProvider.hpp
  • c_ust_smsp : SstProvider.hpp
  • c_ust_smsr : SstProvider.hpp
  • c_ust_spdi : SstProvider.hpp
  • c_ust_spn : SstProvider.hpp
  • c_ust_user_plmn_sel_wlan_access : SstProvider.hpp
  • c_ust_user_wsid_list : SstProvider.hpp
  • c_ust_vbs : SstProvider.hpp
  • c_ust_vbs_security : SstProvider.hpp
  • c_ust_vgcs : SstProvider.hpp
  • c_ust_vgcs_security : SstProvider.hpp
  • c_ust_wlan_reauthentication : SstProvider.hpp
  • c_validity_period_id : ProvIds.hpp
  • c_wai_svr_addr : ServerAddressWin.cpp
  • c_wait_sms_range : MdhSignalProcessor.cpp
  • CalendarAddRecordWin_hpp : CalendarAddRecordWin.hpp
  • CalendarApp_hpp : CalendarApp.hpp
  • CalendarDialogWin_hpp : CalendarDialogWin.hpp
  • CalendarGotoDateWin_hpp : CalendarGotoDateWin.hpp
  • CalendarMonthSelector_hpp : CalendarMonthSelector.hpp
  • CalendarMonthWin_hpp : CalendarMonthWin.hpp
  • CalendarProvider_hpp : CalendarProvider.hpp
  • CalendarRecord_hpp : CalendarRecord.hpp
  • CalendarRecordColumnId : CalendarProvider.hpp
  • CallAcceptForbidden : Types.hpp
  • CallActive : SignalTypes.hpp
  • CallApiRc : Types.hpp
  • CallbackMethod : PdpContextManager.host.cpp, PdpContext.host.cpp
  • CallBarringHandlerId : HandlerId.hpp
  • CallChangedToSs : SignalTypes.hpp
  • CallChangedToUssd : SignalTypes.hpp
  • CallControlHandlerId : HandlerId.hpp
  • CallControlMoSmsControlPermanentProblem : SimTkTypes.hpp
  • CallControlMoSmsControlPermanentProblemActionNotAllowed : SimTkTypes.hpp
  • CallControlMoSmsControlPermanentProblemTypeOfRequestChanged : SimTkTypes.hpp
  • CallDataLocked : Types.hpp
  • CallDeflectionHandlerId : HandlerId.hpp
  • CallDeflectionRejected : SignalTypes.hpp
  • CallDeflectionStarted : SignalTypes.hpp
  • CallDisconnected : Types.hpp
  • CallDiscReq : SignalTypes.hpp
  • CalledPartyAlerting : MmTypes.hpp
  • CalledPartyBlacklisted : SignalTypes.hpp
  • CalledSubscriberBusy : SignalTypes.hpp
  • CallErrorCause : SignalTypes.hpp
  • CallEstCause : SignalTypes.hpp
  • CallForwardingHandlerId : HandlerId.hpp
  • CallHandlerId : HandlerId.hpp
  • CallHeld : SignalTypes.hpp
  • CallHeldRejected : SignalTypes.hpp
  • CallHeldStarted : SignalTypes.hpp
  • CallIndex : Types.hpp
  • CallIsCleared : SignalTypes.hpp
  • CallIsDeflected : SignalTypes.hpp
  • CallIsDisconnected : SignalTypes.hpp
  • CallIsHeld : SignalTypes.hpp
  • CallIsRetrieved : SignalTypes.hpp
  • CallModifyCompleted : SignalTypes.hpp
  • CallModifyIndicated : SignalTypes.hpp
  • CallModifyRejected : SignalTypes.hpp
  • CallModifyStarted : SignalTypes.hpp
  • CallNotIdentified : SignalTypes.hpp
  • CallNotMptyMember : Types.hpp
  • CallOnHold : SignalTypes.hpp
  • CallProgressInd : SignalTypes.hpp
  • CallReEst : SignalTypes.hpp
  • CallRefuseDirection : SignalTypes.hpp
  • CallRejected : SignalTypes.hpp
  • CallRelatedSs : SignalTypes.hpp
  • CallRelatedSsCode : SignalTypes.hpp
  • CallRelatedSsState : SignalTypes.hpp
  • CallRetrieved : SignalTypes.hpp
  • CallRetrieveRejected : SignalTypes.hpp
  • CallRetrieveStarted : SignalTypes.hpp
  • CallSetupRejected : Types.hpp
  • CallSsActionType : InputAction.hpp
  • CallState : SignalTypes.hpp
  • CallType : SignalTypes.hpp
  • CallWaitingHandlerId : HandlerId.hpp
  • CallWaitingTone : SignalTypes.hpp
  • CallWaitToneOn : SignalTypes.hpp
  • CAMERA : apoxi.features
  • CAMERA_VIEW_FINDER_TITLE : CameraViewFinderWin.cpp
  • CameraOptionSettingsWin_hpp : CameraOptionSettingsWin.hpp
  • CameraSettingsWin_hpp : CameraSettingsWin.hpp
  • CamWin32_hpp : CamWin32.hpp
  • CAND_PAGE_INCR : Zi8Wrapper.hpp
  • CannotReplaceSms : SignalTypes.hpp
  • CastMsg() : Message.hpp
  • cb : FillRect_Planes.cpp
  • Cb_function_ptr : NotificationTable.hpp
  • CbmiEfPos : SimTkTypes.hpp
  • CbmirEfPos : SimTkTypes.hpp
  • CbplaybackRenderFrame() : EmApoxiVideoRenderer.cpp
  • CbsHandlerId : HandlerId.hpp
  • CcAllowed : SignalTypes.hpp
  • CcAllowedModified : SignalTypes.hpp
  • CcbsAction : SignalTypes.hpp
  • CcbsAllowed : SignalTypes.hpp
  • CcbsNotAllowed : SignalTypes.hpp
  • CcbsPossible : SignalTypes.hpp
  • CcbsStatus : SignalTypes.hpp
  • CcNotAllowed : SignalTypes.hpp
  • CcpEfPos : SimTkTypes.hpp
  • CcpRefresh : SignalTypes.hpp
  • CcSimError : SignalTypes.hpp
  • CcToolkitBusy : SignalTypes.hpp
  • Cd : SignalTypes.hpp
  • CdPhoneBook : AtcTypes.hpp
  • CellBarred : NetworkTypes.hpp
  • CellId : NetworkTypes.hpp
  • CellSuitable : NetworkTypes.hpp
  • CellTestSim : SignalTypes.hpp
  • Cfb : SignalTypes.hpp
  • CfisPhoneBookCnt : SignalTypes.hpp
  • Cfnrc : SignalTypes.hpp
  • Cfnry : SignalTypes.hpp
  • Cfu : SignalTypes.hpp
  • CfuActivated : SignalTypes.hpp
  • CfuArrayAccessMaxLines : SignalTypes.hpp
  • CfuArrayIndex : SignalTypes.hpp
  • CfuData : SignalTypes.hpp
  • CfuDataSource : SignalTypes.hpp
  • CfuDataSourceCfis : SignalTypes.hpp
  • CfuDataSourceCphs : SignalTypes.hpp
  • CfuDataSourceInvalid : SignalTypes.hpp
  • CfuDataSourceNetwork : SignalTypes.hpp
  • CfuDataSourceNvram : SignalTypes.hpp
  • CfuDeactivated : SignalTypes.hpp
  • CfuFax : SignalTypes.hpp
  • CfuInvalid : SignalTypes.hpp
  • CfuServiceCode : SignalTypes.hpp
  • CfuTelephony : SignalTypes.hpp
  • CfuTelephonyLine2 : SignalTypes.hpp
  • CHANGE_CURRENT_AUDIO_PATH : BtHfAppPlugin.hpp
  • ChannelData : SimTkTypes.hpp
  • ChannelNo : Types.hpp
  • ChannelUnacceptable : SignalTypes.hpp
  • CHAR : WinInc.hpp, NucInc.hpp
  • CharComparePred : InputMap.cpp
  • ChargeEndBatteryFull : SignalTypes.hpp
  • ChargeEndChargerDisconnected : SignalTypes.hpp
  • ChargeEndReason : SignalTypes.hpp
  • ChargerOnlyMode : SignalTypes.hpp
  • ChargeShutdownBatteryEmpty : SignalTypes.hpp
  • ChargeShutdownBatteryIdError : SignalTypes.hpp
  • ChargeShutdownReason : SignalTypes.hpp
  • CharMapSearcher : InputMap.cpp
  • CharToLower() : StrUtil.hpp
  • CharToUpper() : StrUtil.hpp
  • CheckBoxListModel : CheckBoxList.hpp
  • CheckComputeUsage() : HeapVector.cpp
  • checked_bmp : BlueSkyRadioButtonView.cpp
  • CheckRange() : Win32.cpp
  • CHICAGO_EXT : FatSim.hpp
  • CHINESE_CAND_PAGE_INCR : Zi8Wrapper.hpp
  • Chn_realase : NetworkTypes.hpp
  • Chv1 : SignalTypes.hpp
  • Chv1Disable : SignalTypes.hpp
  • Chv1Enable : SignalTypes.hpp
  • Chv2 : SignalTypes.hpp
  • ChvAction : SignalTypes.hpp
  • ChvAttempts : SignalTypes.hpp
  • ChvChange : SignalTypes.hpp
  • ChvNo : SignalTypes.hpp
  • ChvStatus : SignalTypes.hpp
  • ChvUnblock : SignalTypes.hpp
  • ChvVerify : SignalTypes.hpp
  • CifSize_INDEX : Camera.cpp
  • CircuitSwitched : NetworkTypes.hpp
  • CircuitSwitchedPreferred : NetworkTypes.hpp
  • CLEANUP_ATTS : parsifal.cpp
  • CLEANUP_ATTS_fn() : parsifal.cpp
  • ClearCause : Types.hpp
  • ClearToneRpt : SignalTypes.hpp
  • Client : SignalTypes.hpp
  • ClientFlagConfirmedRefresh : SimTkTypes.hpp
  • ClientFlagLocationStatusReport : SimTkTypes.hpp
  • ClientFlagMccOnStartInd : SimTkTypes.hpp
  • ClientNotRegistered : SignalTypes.hpp
  • ClientRejected : SignalTypes.hpp
  • ClientTemporaryBarred : SignalTypes.hpp
  • Clip : SignalTypes.hpp
  • clip_left_border : BitBlit_Planes.cpp
  • clip_right_border : BitBlit_Planes.cpp
  • ClipActionType : InputAction.hpp
  • ClipHandlerId : HandlerId.hpp
  • Clir : SignalTypes.hpp
  • ClirActionType : InputAction.hpp
  • CliRestrictionOption : SignalTypes.hpp
  • ClirHandlerId : HandlerId.hpp
  • ClirMode : SignalTypes.hpp
  • ClirNotSubscribed : SignalTypes.hpp
  • CLOSE_TEXT_SOFTKEY : CameraCaptureWin.cpp
  • CloseBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • CloseCurrentFileBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • CloseCurrentFileFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • CloseDownlink() : TchInterface.cpp
  • CloseErr : FfsTestError.hpp
  • CloseFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • CloseTch() : TchInterface.cpp
  • CloseUplink() : TchInterface.cpp
  • CMAX : RingBuffer.cpp
  • CmiEfPos : SimTkTypes.hpp
  • cmpbcdbuffer() : PhoneNumber.cpp
  • CnameChoice : SignalTypes.hpp
  • CnameVoidChoice : SignalTypes.hpp
  • Cnap : SignalTypes.hpp
  • CnapActionType : InputAction.hpp
  • CnapHandlerId : HandlerId.hpp
  • CODEC_MAN : apoxi.features
  • col_bits : FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_16Bpp.cpp
  • col_idx : ConvertToColorValue_Planes.cpp
  • col_inc : ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • col_table : ConvertToColorValue_Planes.cpp
  • col_val : SetPixel_Planes.cpp, DrawChar_Planes.cpp
  • Color() : GetPixelColor_Planes.cpp, GetPixelColor_8Bpp.cpp, GetPixelColor_32Bpp.cpp, GetPixelColor_24Bpp.cpp, GetPixelColor_16Bpp.cpp
  • color_cont : ConvertToColorValue_Planes.cpp
  • COLOR_COUNT : EmsResourceMaps.hpp
  • color_value : GetPixelColor_Planes.cpp, GetPixelColor_8Bpp.cpp, GetPixelColor_32Bpp.cpp, GetPixelColor_24Bpp.cpp, GetPixelColor_16Bpp.cpp, ConvertToColorValue_Bpp.cpp
  • ColorValue : Color.hpp
  • Colp : SignalTypes.hpp
  • ColpActionType : InputAction.hpp
  • ColpHandlerId : HandlerId.hpp
  • Colr : SignalTypes.hpp
  • ColrActionType : InputAction.hpp
  • ColrHandlerId : HandlerId.hpp
  • COMM_ROOT_CERT : HttpWapMgrBase.hpp
  • COMM_USER_CERT : HttpWapMgrBase.hpp
  • CommandBeyondCapability : SimTkTypes.hpp
  • CommandDataNotUnderstoodByMe : SimTkTypes.hpp
  • CommandNumberNotKnownByMe : SimTkTypes.hpp
  • CommandPerformedSuccessfullyLimitedService : SimTkTypes.hpp
  • CommandPerformedWithButModifiedByCallControlBySim : SimTkTypes.hpp
  • CommandPerformedWithMissingInformation : SimTkTypes.hpp
  • CommandPerformedWithModification : SimTkTypes.hpp
  • CommandPerformedWithPartialComprehension : SimTkTypes.hpp
  • CommandTypeNotUnderstoodByMe : SimTkTypes.hpp
  • Common_ImageBrowserMsgTypes_hpp : ImageBrowserMsgTypes.hpp
  • Common_MsgTypes_hpp : MsgTypes.hpp
  • Common_NetworkServiceThreadMsgTypes_hpp : NetworkServiceThreadMsgTypes.hpp
  • Common_SoundBrowserMsgTypes_hpp : SoundBrowserMsgTypes.hpp
  • COMPANY_ID_IFIN_AP : BtAvrcpPanelApplication.cpp
  • CompareFunction : DataItem.hpp
  • Compat_Lib_hpp : Lib.hpp
  • ConcatenetedSms : SimPduHandler.hpp
  • ConcatenetedStatus : SimPduHandler.hpp
  • ConditionalIeError : SignalTypes.hpp
  • ConfirmToneOn : SignalTypes.hpp
  • ConfPasswordMismatch : Types.hpp
  • Congestion : SignalTypes.hpp
  • CongestionTone : SignalTypes.hpp
  • CongestionToneOn : SignalTypes.hpp
  • ConIeErr : SignalTypes.hpp
  • CONNECT_DEVICE : BtHfAppPlugin.hpp
  • ConnectedWordRecognition : VrTypes.hpp
  • ConnectionError : GltpTypes.hpp
  • ConnectionReqSent : GltpTypes.hpp
  • ConnectType : FatSim.hpp
  • CONTENT_DESCRIPTION_STR : DrmDcfParser.hpp
  • CONTENT_NAME_STR : DrmDcfParser.hpp
  • CONTENT_VENDOR_STR : DrmDcfParser.hpp
  • ContextDescriptionTypes_hpp : ContextDescriptionTypes.hpp
  • ContextFeature_hpp : ContextFeature.hpp
  • ContextFeatureItem_hpp : ContextFeatureItem.hpp
  • ContextID : ContextID.hpp
  • ContextID_hpp : ContextID.hpp
  • ConvertAACToGCIFormat() : AtiUtils.cpp
  • ConvertAMRToGCIFormat() : AtiUtils.cpp
  • ConvertFromGCIFormat() : AtiUtils.cpp
  • ConvertToGCIFormat() : AtiUtils.cpp
  • ConvertUtf8ToWString() : BtUtility.hpp, BtUtility.cpp
  • copy_text_sample : FfsTests.cpp
  • copybcdbuffer() : PhoneNumber.cpp
  • correction_type : DrmRelXml.hpp
  • CorrectSimKeyboardAllowed() : SimChvHandler.cpp
  • CorrectSimMenuAllowed() : SimChvHandler.cpp
  • CountryAD : CountryCodes.hpp
  • CountryAE : CountryCodes.hpp
  • CountryAF : CountryCodes.hpp
  • CountryAG : CountryCodes.hpp
  • CountryAI : CountryCodes.hpp
  • CountryAL : CountryCodes.hpp
  • CountryAM : CountryCodes.hpp
  • CountryAN : CountryCodes.hpp
  • CountryAO : CountryCodes.hpp
  • CountryAQ : CountryCodes.hpp
  • CountryAR : CountryCodes.hpp
  • CountryAS : CountryCodes.hpp
  • CountryAT : CountryCodes.hpp
  • CountryAU : CountryCodes.hpp
  • CountryAW : CountryCodes.hpp
  • CountryAZ : CountryCodes.hpp
  • CountryBA : CountryCodes.hpp
  • CountryBB : CountryCodes.hpp
  • CountryBD : CountryCodes.hpp
  • CountryBE : CountryCodes.hpp
  • CountryBF : CountryCodes.hpp
  • CountryBG : CountryCodes.hpp
  • CountryBH : CountryCodes.hpp
  • CountryBI : CountryCodes.hpp
  • CountryBJ : CountryCodes.hpp
  • CountryBM : CountryCodes.hpp
  • CountryBN : CountryCodes.hpp
  • CountryBO : CountryCodes.hpp
  • CountryBR : CountryCodes.hpp
  • CountryBS : CountryCodes.hpp
  • CountryBT : CountryCodes.hpp
  • CountryBV : CountryCodes.hpp
  • CountryBW : CountryCodes.hpp
  • CountryBY : CountryCodes.hpp
  • CountryBZ : CountryCodes.hpp
  • CountryCA : CountryCodes.hpp
  • CountryCC : CountryCodes.hpp
  • CountryCF : CountryCodes.hpp
  • CountryCG : CountryCodes.hpp
  • CountryCH : CountryCodes.hpp
  • CountryCI : CountryCodes.hpp
  • CountryCK : CountryCodes.hpp
  • CountryCL : CountryCodes.hpp
  • CountryCM : CountryCodes.hpp
  • CountryCN : CountryCodes.hpp
  • CountryCO : CountryCodes.hpp
  • CountryCodes : CountryCodes.hpp
  • CountryCR : CountryCodes.hpp
  • CountryCU : CountryCodes.hpp
  • CountryCV : CountryCodes.hpp
  • CountryCX : CountryCodes.hpp
  • CountryCY : CountryCodes.hpp
  • CountryCZ : CountryCodes.hpp
  • CountryDE : CountryCodes.hpp
  • CountryDJ : CountryCodes.hpp
  • CountryDK : CountryCodes.hpp
  • CountryDM : CountryCodes.hpp
  • CountryDO : CountryCodes.hpp
  • CountryDZ : CountryCodes.hpp
  • CountryEC : CountryCodes.hpp
  • CountryEE : CountryCodes.hpp
  • CountryEG : CountryCodes.hpp
  • CountryEH : CountryCodes.hpp
  • CountryER : CountryCodes.hpp
  • CountryES : CountryCodes.hpp
  • CountryET : CountryCodes.hpp
  • CountryFI : CountryCodes.hpp
  • CountryFJ : CountryCodes.hpp
  • CountryFK : CountryCodes.hpp
  • CountryFM : CountryCodes.hpp
  • CountryFO : CountryCodes.hpp
  • CountryFR : CountryCodes.hpp
  • CountryFX : CountryCodes.hpp
  • CountryGA : CountryCodes.hpp
  • CountryGB : CountryCodes.hpp
  • CountryGD : CountryCodes.hpp
  • CountryGE : CountryCodes.hpp
  • CountryGF : CountryCodes.hpp
  • CountryGH : CountryCodes.hpp
  • CountryGI : CountryCodes.hpp
  • CountryGL : CountryCodes.hpp
  • CountryGM : CountryCodes.hpp
  • CountryGN : CountryCodes.hpp
  • CountryGP : CountryCodes.hpp
  • CountryGQ : CountryCodes.hpp
  • CountryGR : CountryCodes.hpp
  • CountryGS : CountryCodes.hpp
  • CountryGT : CountryCodes.hpp
  • CountryGU : CountryCodes.hpp
  • CountryGW : CountryCodes.hpp
  • CountryGY : CountryCodes.hpp
  • CountryHK : CountryCodes.hpp
  • CountryHM : CountryCodes.hpp
  • CountryHN : CountryCodes.hpp
  • CountryHR : CountryCodes.hpp
  • CountryHT : CountryCodes.hpp
  • CountryHU : CountryCodes.hpp
  • CountryID : CountryCodes.hpp
  • CountryIE : CountryCodes.hpp
  • CountryIL : CountryCodes.hpp
  • CountryIN : CountryCodes.hpp
  • CountryInvalid : CountryCodes.hpp
  • CountryIO : CountryCodes.hpp
  • CountryIQ : CountryCodes.hpp
  • CountryIR : CountryCodes.hpp
  • CountryIS : CountryCodes.hpp
  • CountryIT : CountryCodes.hpp
  • CountryJM : CountryCodes.hpp
  • CountryJO : CountryCodes.hpp
  • CountryJP : CountryCodes.hpp
  • CountryKE : CountryCodes.hpp
  • CountryKG : CountryCodes.hpp
  • CountryKH : CountryCodes.hpp
  • CountryKI : CountryCodes.hpp
  • CountryKM : CountryCodes.hpp
  • CountryKN : CountryCodes.hpp
  • CountryKP : CountryCodes.hpp
  • CountryKR : CountryCodes.hpp
  • CountryKW : CountryCodes.hpp
  • CountryKY : CountryCodes.hpp
  • CountryKZ : CountryCodes.hpp
  • CountryLA : CountryCodes.hpp
  • CountryLB : CountryCodes.hpp
  • CountryLC : CountryCodes.hpp
  • CountryLI : CountryCodes.hpp
  • CountryLK : CountryCodes.hpp
  • CountryLR : CountryCodes.hpp
  • CountryLS : CountryCodes.hpp
  • CountryLT : CountryCodes.hpp
  • CountryLU : CountryCodes.hpp
  • CountryLV : CountryCodes.hpp
  • CountryLY : CountryCodes.hpp
  • CountryMA : CountryCodes.hpp
  • CountryMC : CountryCodes.hpp
  • CountryMD : CountryCodes.hpp
  • CountryMG : CountryCodes.hpp
  • CountryMH : CountryCodes.hpp
  • CountryMK : CountryCodes.hpp
  • CountryML : CountryCodes.hpp
  • CountryMM : CountryCodes.hpp
  • CountryMN : CountryCodes.hpp
  • CountryMO : CountryCodes.hpp
  • CountryMP : CountryCodes.hpp
  • CountryMQ : CountryCodes.hpp
  • CountryMR : CountryCodes.hpp
  • CountryMS : CountryCodes.hpp
  • CountryMT : CountryCodes.hpp
  • CountryMU : CountryCodes.hpp
  • CountryMV : CountryCodes.hpp
  • CountryMW : CountryCodes.hpp
  • CountryMX : CountryCodes.hpp
  • CountryMY : CountryCodes.hpp
  • CountryMZ : CountryCodes.hpp
  • CountryNA : CountryCodes.hpp
  • CountryNC : CountryCodes.hpp
  • CountryNE : CountryCodes.hpp
  • CountryNF : CountryCodes.hpp
  • CountryNG : CountryCodes.hpp
  • CountryNI : CountryCodes.hpp
  • CountryNL : CountryCodes.hpp
  • CountryNO : CountryCodes.hpp
  • CountryNP : CountryCodes.hpp
  • CountryNR : CountryCodes.hpp
  • CountryNU : CountryCodes.hpp
  • CountryNZ : CountryCodes.hpp
  • CountryOM : CountryCodes.hpp
  • CountryPA : CountryCodes.hpp
  • CountryPE : CountryCodes.hpp
  • CountryPF : CountryCodes.hpp
  • CountryPG : CountryCodes.hpp
  • CountryPH : CountryCodes.hpp
  • CountryPK : CountryCodes.hpp
  • CountryPL : CountryCodes.hpp
  • CountryPM : CountryCodes.hpp
  • CountryPN : CountryCodes.hpp
  • CountryPR : CountryCodes.hpp
  • CountryPT : CountryCodes.hpp
  • CountryPW : CountryCodes.hpp
  • CountryPY : CountryCodes.hpp
  • CountryQA : CountryCodes.hpp
  • CountryRE : CountryCodes.hpp
  • CountryRO : CountryCodes.hpp
  • CountryRU : CountryCodes.hpp
  • CountryRW : CountryCodes.hpp
  • CountrySA : CountryCodes.hpp
  • CountrySB : CountryCodes.hpp
  • CountrySC : CountryCodes.hpp
  • CountrySD : CountryCodes.hpp
  • CountrySE : CountryCodes.hpp
  • CountrySG : CountryCodes.hpp
  • CountrySH : CountryCodes.hpp
  • CountrySI : CountryCodes.hpp
  • CountrySJ : CountryCodes.hpp
  • CountrySK : CountryCodes.hpp
  • CountrySL : CountryCodes.hpp
  • CountrySM : CountryCodes.hpp
  • CountrySN : CountryCodes.hpp
  • CountrySO : CountryCodes.hpp
  • CountrySR : CountryCodes.hpp
  • CountryST : CountryCodes.hpp
  • CountrySV : CountryCodes.hpp
  • CountrySY : CountryCodes.hpp
  • CountrySZ : CountryCodes.hpp
  • CountryTC : CountryCodes.hpp
  • CountryTD : CountryCodes.hpp
  • CountryTF : CountryCodes.hpp
  • CountryTG : CountryCodes.hpp
  • CountryTH : CountryCodes.hpp
  • CountryTJ : CountryCodes.hpp
  • CountryTK : CountryCodes.hpp
  • CountryTM : CountryCodes.hpp
  • CountryTN : CountryCodes.hpp
  • CountryTO : CountryCodes.hpp
  • CountryTP : CountryCodes.hpp
  • CountryTR : CountryCodes.hpp
  • CountryTT : CountryCodes.hpp
  • CountryTV : CountryCodes.hpp
  • CountryTW : CountryCodes.hpp
  • CountryTZ : CountryCodes.hpp
  • CountryUA : CountryCodes.hpp
  • CountryUG : CountryCodes.hpp
  • CountryUM : CountryCodes.hpp
  • CountryUS : CountryCodes.hpp
  • CountryUY : CountryCodes.hpp
  • CountryUZ : CountryCodes.hpp
  • CountryVA : CountryCodes.hpp
  • CountryVC : CountryCodes.hpp
  • CountryVE : CountryCodes.hpp
  • CountryVG : CountryCodes.hpp
  • CountryVI : CountryCodes.hpp
  • CountryVN : CountryCodes.hpp
  • CountryVU : CountryCodes.hpp
  • CountryWF : CountryCodes.hpp
  • CountryWS : CountryCodes.hpp
  • CountryYE : CountryCodes.hpp
  • CountryYT : CountryCodes.hpp
  • CountryYU : CountryCodes.hpp
  • CountryZA : CountryCodes.hpp
  • CountryZM : CountryCodes.hpp
  • CountryZR : CountryCodes.hpp
  • CountryZW : CountryCodes.hpp
  • CpbcchEfPos : SimTkTypes.hpp
  • CPGlyph : AcacTypes.hpp
  • CphsAcm2EfPos : SimTkTypes.hpp
  • CphsCfufEfPos : SimTkTypes.hpp
  • CphsCsp2EfPos : SimTkTypes.hpp
  • CphsCspEfPos : SimTkTypes.hpp
  • CphsInfoNoPhoneBook : SignalTypes.hpp
  • CphsInfoNoPhoneBookCnt : SignalTypes.hpp
  • CphsInfumEfPos : SimTkTypes.hpp
  • CphsIstEfPos : SimTkTypes.hpp
  • CphsMboxEfPos : SimTkTypes.hpp
  • CphsMBoxPhoneBook : SignalTypes.hpp
  • CphsMBoxPhoneBookCnt : SignalTypes.hpp
  • CphsOnmEfPos : SimTkTypes.hpp
  • CphsOnsEfPos : SimTkTypes.hpp
  • CphsSrvstEfPos : SimTkTypes.hpp
  • CphsVmwfEfPos : SimTkTypes.hpp
  • CreateErr : FfsTestError.hpp
  • CreateFunction : DataItem.hpp
  • CRERR_BAD_FORMAT : FatSim.hpp
  • CRERR_BAD_MEDIA : FatSim.hpp
  • CRERR_ECC_ERROR : FatSim.hpp
  • CRERR_ID_ERROR : FatSim.hpp
  • CRERR_MEDIA_CHANGED : FatSim.hpp
  • CRERR_MEDIA_FAILURE : FatSim.hpp
  • CRERR_NO_MEDIA : FatSim.hpp
  • CriticalSection : Win32.hpp
  • CrssHandlerId : HandlerId.hpp
  • CsdDataNt : SignalTypes.hpp
  • CsdDataT : SignalTypes.hpp
  • CsdFax : SignalTypes.hpp
  • CsdMultimedia : SignalTypes.hpp
  • CsdNone : SignalTypes.hpp
  • CsdVoice : SignalTypes.hpp
  • CsdWap : SignalTypes.hpp
  • CsPhoneBook : AtcTypes.hpp
  • ct_negative : DrmRelXml.hpp
  • ct_none : DrmRelXml.hpp
  • ct_positive : DrmRelXml.hpp
  • Cug : SignalTypes.hpp
  • CugCallFailure : SignalTypes.hpp
  • CugIndex : SignalTypes.hpp
  • CugIndexIncompatible : SignalTypes.hpp
  • CugSelector : SignalTypes.hpp
  • CurrentLocation : LcsTypes.hpp
  • CurrentlyUnable : SimTkTypes.hpp
  • CurrentOrLastKnownLocation : LcsTypes.hpp
  • CustFileData : AcacTypes.hpp
  • CustomizationPackData : AcacTypes.hpp
  • Cw : SignalTypes.hpp
  • CyclicFile : SignalTypes.hpp
Generated on Wed Jan 25 02:31:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • Data : SignalTypes.hpp
  • data : DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp
  • DataAccessible : SimAccessor.hpp
  • DataAccessUndefined : SimAccessor.hpp
  • DataAvailability : SimAccessor.hpp
  • DataCall : SignalTypes.hpp
  • DataCallActive : SignalTypes.hpp
  • DataCallDetected : Types.hpp
  • DataCallRequired : Types.hpp
  • DataCallType : SignalTypes.hpp
  • DataCda1200_75Bps : SignalTypes.hpp
  • DataCda1200Bps : SignalTypes.hpp
  • DataCda2400_Bps : SignalTypes.hpp
  • DataCda300Bps : SignalTypes.hpp
  • DataCda4800_Bps : SignalTypes.hpp
  • DataCda9600_Bps : SignalTypes.hpp
  • DataCds1200Bps : SignalTypes.hpp
  • DataCds2400Bps : SignalTypes.hpp
  • DataCds4800Bps : SignalTypes.hpp
  • DataCds9600Bps : SignalTypes.hpp
  • DataConnColids : DataConnProvider.hpp
  • DataConnInfoMsgType : SocketTypes.hpp
  • DataConnProfileId : SocketTypes.hpp
  • DataConnProfileIdSet : SocketTypes.hpp
  • DataConnProfileInfoMsgType : SocketTypes.hpp
  • DataConnProfilePtr : DataConnProfile.hpp
  • DataConnProfileType : DataConnApp.hpp
  • DataConnPropertyType : DataConnApp.hpp
  • DataConnPtr : Win32SysDnsClient.hpp, LwipSysDnsClient.hpp, DataConnProfile.hpp
  • DataConnTempProfileIdSet : SocketTypes.hpp
  • DATACONNVERSION : DataConnVersion.hpp
  • DataConnVersion_hpp : DataConnVersion.hpp
  • DataControlType : Types.hpp
  • DataItemTestSuite() : DataItem.hpp, DataItem.cpp
  • DataNotInitialized : SignalTypes.hpp
  • DataNotPresent : SimAccessor.hpp
  • DataPackHeaderData : AcacTypes.hpp
  • DataPackId : AcacTypes.hpp
  • DataPds2400Bps : SignalTypes.hpp
  • DataPds4800Bps : SignalTypes.hpp
  • DataPds9600Bps : SignalTypes.hpp
  • DataRecordId : DataRecord.hpp
  • DataSinkPtr : DataSink.hpp
  • DataSourcePtr : DataSourceBinData.hpp, DataSource.hpp
  • DataType : DataItem.hpp
  • date_type : DrmRelXml.hpp
  • DateFormat : Date.hpp
  • DATESTR : FatSim.hpp
  • DateTimeType : DataItem.hpp
  • DateType : DataItem.hpp
  • DBG_DUMP : DbgDump.hpp
  • DBG_OUT : Macros.hpp
  • DBG_OUT_CONFIGURATOR_IS_IN_RANGE : Win32.cpp, Nuc32.cpp
  • DBG_OUT_RANGE_AFSRAM_ALWAYS : RamTypes.hpp
  • DBG_OUT_RANGE_AFSRAM_ERROR : RamTypes.hpp
  • DBG_OUT_RANGE_AFSRAM_SUCCESS : RamTypes.hpp
  • DBG_OUT_RANGE_AFSRAM_UNITTEST : RamTypes.hpp
  • DBG_OUT_STACK_USAGE : Macros.hpp
  • DBG_STATE : BtObexService.cpp, BtObexServerService.cpp, BtObexController.cpp, BtObexClientService.cpp, BtHsService.cpp, BtHsController.cpp, BtHfService.cpp, BtHfController.cpp, BtAvrcpRegistrationController.cpp, BtAvrcpOperationController.cpp
  • DBG_STATE_STATIC : BtHsController.cpp, BtHfController.cpp, BtAvrcpRegistrationController.cpp, BtAvrcpOperationController.cpp
  • DcError : SignalTypes.hpp
  • DCF_SKIP_SPACE : DrmDcfParser.hpp
  • DCF_VALIDATE_DATA_SIZE : DrmDcfParser.hpp
  • DcPhoneBook : AtcTypes.hpp
  • Dcs : LcsTypes.hpp
  • DDRV_ATOM_BIT_COUNT : Ddrv.cpp
  • DDrvAtom : Ddrv.cpp
  • DDrvColorBits16 : Ddrv.cpp
  • DDrvColorBits16Ptr : Ddrv.cpp
  • DDrvColorBits32 : Ddrv.cpp
  • DDrvColorBits32Ptr : Ddrv.cpp
  • DDrvColorBits8 : Ddrv.cpp
  • DDrvColorBits8Ptr : Ddrv.cpp
  • DDrvDimToAtomBitIdx() : Ddrv.cpp
  • DDrvDimToAtomIdx : Ddrv.cpp
  • DDrvGetScanlineInc() : Ddrv.cpp
  • DEACTIVATE_SET_CAPTURE_IMAGE_FORMAT : VideoCamera.cpp
  • DEBUG : SerialSocket.hpp
  • DEBUG_CAMERA_CAPTURE_WIN_CPP : CameraCaptureWin.cpp
  • DEBUG_CAMERA_CAPTURE_WIN_CPP_FILE : CameraCaptureWin.cpp
  • DEBUG_CAMERA_CPP : Camera.cpp
  • DEBUG_CAMERA_SETTINGS_WIN_CPP : CameraSettingsWin.cpp
  • DEBUG_CAMERA_SETTINGS_WIN_CPP_FILE : CameraSettingsWin.cpp
  • DEBUG_DEVICE_CAMERA_CPP_FILE : Camera.cpp
  • DEBUG_DEVICE_STILL_CAMERA : StillCamera.cpp
  • DEBUG_DEVICE_STILL_CAMERA_CPP_FILE : StillCamera.cpp
  • DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE : VideoCamera.cpp
  • DEBUG_INFO : apoxi.features
  • DEBUG_STILL_CAMERA_CPP : StillCamera.cpp
  • DEBUG_STILL_CAMERA_CPP_CB : StillCamera.cpp
  • DEBUG_VIDEOCAMERA_CPP : VideoCamera.cpp
  • DECLARE_CLASS : InternalTracer.hpp
  • DEFAULT_AUDIO_PATH : BtHfAppPlugin.hpp
  • default_chinese_theme : DefaultChineseTheme.hpp, DefaultChineseTheme.cpp
  • DEFAULT_STEP_SIZE : Camera.cpp
  • default_theme : DefaultTheme.hpp, DefaultTheme.cpp
  • DEFAULT_VIEWFINDER_FRAMERATE : Camera.cpp
  • DefaultBehavior : ScrollBehavior.hpp
  • DefaultBehaviour : Grid.hpp
  • DefaultLocalId : DrmCore.hpp
  • DefaultMultiSlotCapability : NetworkTypes.hpp
  • DefaultTone : SignalTypes.hpp
  • DefaultZoomLevelCifSize_INDEX : Camera.cpp
  • DefaultZoomLevelQcifSize_INDEX : Camera.cpp
  • DefaultZoomLevelQqcifSize_INDEX : Camera.cpp
  • DefaultZoomLevelQqvgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelQsifSize_INDEX : Camera.cpp
  • DefaultZoomLevelQvgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelSize1_3Mp_INDEX : Camera.cpp
  • DefaultZoomLevelSize1Mp_INDEX : Camera.cpp
  • DefaultZoomLevelSize2Mp_INDEX : Camera.cpp
  • DefaultZoomLevelSize3Mp_INDEX : Camera.cpp
  • DefaultZoomLevelSqcifSize_INDEX : Camera.cpp
  • DefaultZoomLevelSvgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelUxgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelVgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelXgaSize_INDEX : Camera.cpp
  • DefGuid_NoGuid : Service.hpp
  • DefObjectReferrer : ObjectReferrer.hpp
  • DefThreadSafeReferableObject : ObjectReferrer.hpp
  • DeleteAllPlmnAction : SignalTypes.hpp
  • DeleteDirRecursive() : HostCoreFsSim.cpp
  • DeleteFunction : DataItem.hpp
  • DeletePlmnAction : SignalTypes.hpp
  • delta : DrawChar_Planes.cpp, BitBlit_Planes.cpp
  • DerivedApoxiThread_hpp : DerivedApoxiThread.hpp
  • DerivedApoxiTimer_hpp : DerivedApoxiTimer.hpp
  • dest_atom : ScrollHorizontal_Planes.cpp, BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp
  • dest_bmp : BitBlit_Planes.cpp
  • dest_col_start_atom : ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • dest_end_x : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • dest_end_y : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • dest_inc : DrawChar_Planes.cpp
  • dest_line_inc : BitBlit_Planes.cpp
  • dest_line_start_atom : ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp
  • dest_plane_inc : BitBlit_Planes.cpp
  • dest_root : DrawChar_Planes.cpp
  • dest_scanline_inc : BitBlit_Planes.cpp
  • dest_x : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • dest_y : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • DestinationOutOfOrder : SignalTypes.hpp
  • Detected : NetworkTypes.hpp
  • DetectShiftValue() : HeapVector.cpp
  • DEVICE_ADDRESS_CAPTION : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_CONECTED_CAPTION : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_NAME_CAPTION : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_PLAYING_CAPTION : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_SUPPORTED_FEATURES : BtHfProfileWindows.cpp
  • DEVICE_TEXT_NO : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_TEXT_NO_ACTIVE_DEVICE : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_TEXT_NO_PAIRED_DEVICE : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_TEXT_YES : BtAvrcpControllerApplicationWindows.cpp
  • DeviceBuzzer : SignalTypes.hpp
  • DeviceMap : FatStorageDeviceImp.cpp
  • DeviceRingBuzzerVibrator : SignalTypes.hpp
  • Devices_ChargerMsgTypes_hpp : ChargerMsgTypes.hpp
  • Devices_DisplayMsgTypes_hpp : DisplayMsgTypes.hpp
  • Devices_LedMsgTypes_hpp : LedMsgTypes.hpp
  • Devices_RtcMsgTypes_hpp : RtcMsgTypes.hpp
  • DeviceSpeaker : SignalTypes.hpp
  • DeviceVibrator : SignalTypes.hpp
  • devil : SampleImages.hpp, SampleImages.cpp
  • devil_size : SampleImages.hpp
  • DiagnosticCause : SignalTypes.hpp
  • DialTone : SignalTypes.hpp
  • DialToneOn : SignalTypes.hpp
  • dir_id_type : FfsSim.hpp
  • DirectoryIteratorPtr : RootFileSystem.hpp
  • DISCONNECT_DEVICE : BtHfAppPlugin.hpp
  • DisconnectDueToSimtkSetup : SignalTypes.hpp
  • DisconnectingMode : Types.hpp
  • DispatcherActionList : DispatcherAction.hpp, AppRoutingTable.hpp
  • DISPLAY_DEFAULT_HEIGHT : MediaBox.cpp
  • DISPLAY_DEFAULT_WIDTH : MediaBox.cpp
  • DISPLAY_XOFFSET : MediaBox.cpp
  • DISPLAY_YOFFSET : MediaBox.cpp
  • DisplayPhoneNumber : SignalTypes.hpp
  • DIVISOR : StillCamera.cpp
  • DlSc : NetworkTypes.hpp
  • Dmr_DMObjectData : RegistryTypes.hpp
  • DNS_WAIT_TIME_100MS : Win32SysDnsClient.cpp, LwipSysDnsClient.cpp
  • DontCare : SignalTypes.hpp
  • DP_C_LDOUBLE : Wsprintf.cpp, StrPrintf.cpp
  • DP_C_LONG : Wsprintf.cpp, StrPrintf.cpp
  • DP_C_SHORT : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_MINUS : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_NUM : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_PLUS : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_SPACE : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_UNSIGNED : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_UP : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_ZERO : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_BCK : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_CONV : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_DEFAULT : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_DONE : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_DOT : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_FLAGS : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_HEX : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_MAX : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_MIN : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_MOD : Wsprintf.cpp, StrPrintf.cpp
  • dprintf : MultipartParser.hpp
  • DRM : apoxi.features
  • DRM_DAY_SECONDS : DrmRelXml.cpp
  • DRM_DCF_ERROR : DrmDcfParser.hpp
  • DRM_DCF_INVALID_BLOCK : DrmDcfParser.hpp
  • DRM_FL_LOCAL_ID : DrmRightsStore.hpp
  • DRM_HOURS_SECONDS : DrmRelXml.cpp
  • DRM_KEY_SIZE : DrmCore.hpp
  • DRM_MINUTES_SECONDS : DrmRelXml.cpp
  • DRM_MONTH_SECONDS : DrmRelXml.cpp
  • DRM_RIGHTS_OP_NOT_FOUND : DrmRights.hpp
  • DRM_RIGHTS_UPDATE_REQUIRED : DrmRights.hpp
  • DRM_RO_DEBUG : DrmCore.hpp
  • DRM_RO_FILE_PREFIX : DrmRightsStore.hpp
  • DRM_SECURITY_KEY_LEN : DrmSecurity.hpp
  • DRM_SECURITY_MAGIC_NUMBER : DrmSecurity.hpp
  • DRM_YEAR_SECONDS : DrmRelXml.cpp
  • DrmAesDecryptionFail : DrmCore.hpp
  • DrmAllDefault : DrmCore.hpp
  • DrmCombinedDelivery : DrmCore.hpp
  • DrmConstraintDefValues : DrmCore.hpp
  • DrmCore_hpp : DrmCore.hpp
  • DrmCorruptMessage : DrmCore.hpp
  • DrmDatetimeDefault : DrmCore.hpp
  • DrmDcf : DrmCore.hpp
  • DrmDefaultConstraints : DrmCore.hpp
  • DrmEndDefault : DrmCore.hpp
  • DrmForwardLock : DrmCore.hpp
  • DrmForwardLockDcf : DrmCore.hpp
  • DrmInvalidAsset : DrmCore.hpp
  • DrmInvalidContainer : DrmCore.hpp
  • DrmInvalidLocalId : DrmCore.hpp
  • DrmInvalidOperation : DrmCore.hpp
  • DrmInvalidParams : DrmCore.hpp
  • DrmInvalidXmlFormat : DrmCore.hpp
  • DrmKey : DrmCore.hpp
  • DrmLocalId : DrmCore.hpp
  • DrmMimeType : DrmCore.hpp
  • DrmNoDefault : DrmCore.hpp
  • DrmNone : DrmCore.hpp
  • DrmNoRightsAvailable : DrmCore.hpp
  • DrmOpCount : DrmCore.hpp
  • DrmOpDisplay : DrmCore.hpp
  • DrmOperation : DrmCore.hpp
  • DrmOpExecute : DrmCore.hpp
  • DrmOpPlay : DrmCore.hpp
  • DrmOpPrint : DrmCore.hpp
  • DrmOpRewind : DrmCore.hpp
  • DrmRightsNone : DrmRelparser.hpp
  • DrmRightsWbxml : DrmRelparser.hpp
  • DrmRightsXml : DrmRelparser.hpp
  • DrmROStore : DrmRightsStore.hpp
  • DrmRoWbxml : DrmCore.hpp
  • DrmRoXml : DrmCore.hpp
  • DrmStartDefault : DrmCore.hpp
  • DrmStatus : DrmCore.hpp
  • DrmSuccess : DrmCore.hpp
  • DrmUid : DrmCore.hpp
  • DrmUnknown : DrmCore.hpp
  • DrmWapPushMsg_hpp__ST_1101449473226 : DrmWapPushMsg.hpp
  • DrmXmlFormat : DrmRelparser.hpp
  • DSTAT : FatSim.hpp
  • dt_none : DrmRelXml.hpp
  • dtmf_tone_0_data : Audio.cpp
  • dtmf_tone_1_data : Audio.cpp
  • dtmf_tone_2_data : Audio.cpp
  • dtmf_tone_3_data : Audio.cpp
  • dtmf_tone_4_data : Audio.cpp
  • dtmf_tone_5_data : Audio.cpp
  • dtmf_tone_6_data : Audio.cpp
  • dtmf_tone_7_data : Audio.cpp
  • dtmf_tone_8_data : Audio.cpp
  • dtmf_tone_9_data : Audio.cpp
  • dtmf_tone_hash_data : Audio.cpp
  • dtmf_tone_star_data : Audio.cpp
  • DtmfRejCallHeldOrMparty : SignalTypes.hpp
  • DtmfRejDataTransmission : SignalTypes.hpp
  • DtmfRejDuringMocSetup : SignalTypes.hpp
  • DtmfRejectedDueToSupTimerExpiry : SignalTypes.hpp
  • DtmfRejectedNoTchAvailable : SignalTypes.hpp
  • DtmfValue : PhoneNumber.hpp
  • DUAL_DISPLAY : apoxi.features
  • DualServiceCallActive : SignalTypes.hpp
  • dx_atom : ScrollHorizontal_Planes.cpp
  • DynamicAlsFlags : Types.hpp
Generated on Wed Jan 25 02:31:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • e_bpp_buff_size : BtBppTypes.hpp
  • e_bpp_snd_media_basic_text : BtBppTypes.hpp
  • e_bpp_snd_media_gif : BtBppTypes.hpp
  • e_bpp_snd_media_icalendar : BtBppTypes.hpp
  • e_bpp_snd_media_jpeg : BtBppTypes.hpp
  • e_bpp_snd_media_pcl : BtBppTypes.hpp
  • e_bpp_snd_media_pdf : BtBppTypes.hpp
  • e_bpp_snd_media_post_script : BtBppTypes.hpp
  • e_bpp_snd_media_vcalendar : BtBppTypes.hpp
  • e_bpp_snd_media_vcard : BtBppTypes.hpp
  • e_bpp_snd_media_vmessage : BtBppTypes.hpp
  • e_bpp_snd_media_xhtml_print : BtBppTypes.hpp
  • EaadCreate() : EmApoxiAudioDeviceImpl.cpp
  • EaadDeInit() : EmApoxiAudioDeviceImpl.cpp
  • EaadDestroy() : EmApoxiAudioDeviceImpl.cpp
  • EaadDummyCreate() : EmApoxiAudioDeviceImpl.cpp
  • EaadDummyDestroy() : EmApoxiAudioDeviceImpl.cpp
  • EaadGetNumChannels() : EmApoxiAudioUtils.cpp
  • EaadGetPlaybackSampleRate() : EmApoxiAudioUtils.cpp
  • EaadGetProperty() : EmApoxiAudioDeviceImpl.cpp
  • EaadGetRecordSamplingRate() : EmApoxiAudioUtils.cpp
  • EaadInit() : EmApoxiAudioDeviceImpl.cpp
  • EaadResume() : EmApoxiAudioDeviceImpl.cpp
  • EaadSetProperty() : EmApoxiAudioDeviceImpl.cpp
  • EaadStartPlayBack() : EmApoxiAudioDeviceImpl.cpp
  • EaadStartRecording() : EmApoxiAudioDeviceImpl.cpp
  • EaadStopPlayBack() : EmApoxiAudioDeviceImpl.cpp
  • EaadStopRecording() : EmApoxiAudioDeviceImpl.cpp
  • EaadSuspend() : EmApoxiAudioDeviceImpl.cpp
  • EccEfPos : SimTkTypes.hpp
  • EccpEfPos : SimTkTypes.hpp
  • EccpRefresh : SignalTypes.hpp
  • EccSource : SignalTypes.hpp
  • EccSourceBuiltin : SignalTypes.hpp
  • EccSourceCustomized : SignalTypes.hpp
  • EccSourceNetwork : SignalTypes.hpp
  • EccSourceSim : SignalTypes.hpp
  • Ect : SignalTypes.hpp
  • EctActive : SignalTypes.hpp
  • EctAlerting : SignalTypes.hpp
  • EctCallState : SignalTypes.hpp
  • EctRejected : SignalTypes.hpp
  • EctStarted : SignalTypes.hpp
  • EctVoidCallState : SignalTypes.hpp
  • EditBoxShiftState : EditBox.hpp
  • EDNSC_ERR : DnsClientTypes.hpp
  • EDNSC_OK : DnsClientTypes.hpp
  • eFfsTestErr : FfsTestError.hpp
  • EFOApoxiLayer_hpp : EFOApoxiLayer.hpp
  • EFOBinData_hpp : EFOBinData.hpp
  • EFODataSink_hpp : EFODataSink.hpp
  • ElementaryFilePos : SimTkTypes.hpp
  • ElpEfPos : SimTkTypes.hpp
  • EMAPOXI_DBG_ALLOC_LOG : EmApoxiAllocLogs.hpp
  • EMAPOXI_DBG_FREE_LOG : EmApoxiAllocLogs.hpp
  • EmApoxiAudioDecoderhpp : EmApoxiAudioDecoder.hpp
  • EmApoxiAudioDefines_hpp : EmApoxiAudioDefines.hpp
  • EmApoxiAudioDeviceImpl_hpp : EmApoxiAudioDeviceImpl.hpp
  • EmApoxiAudioStateIdle : EmApoxiAudioDeviceImpl.cpp
  • EmApoxiAudioStatePaused : EmApoxiAudioDeviceImpl.cpp
  • EmApoxiAudioStatePlaying : EmApoxiAudioDeviceImpl.cpp
  • EmApoxiAudioUtils_hpp : EmApoxiAudioUtils.hpp
  • EmApoxiBinData_hpp : EmApoxiBinData.hpp
  • EmApoxiCodecManagerhpp : EmApoxiCodecManager.hpp
  • EmApoxiCodecUtilshpp : EmApoxiCodecUtils.hpp
  • EmApoxiDataConnManager_hpp : EmApoxiDataConnManager.hpp
  • EmApoxiDataConnProfileManager_hpp : EmApoxiDataConnProfileManager.hpp
  • EmApoxiDataSink_hpp : EmApoxiDataSink.hpp
  • EmApoxiDataTypes_hpp : EmApoxiDataTypes.hpp
  • EmApoxiDELETE_ARRAY : MediaInfo.cpp, EmApoxiMediaInfo.cpp
  • EmApoxiDisplaySettings_hpp : EmApoxiDisplaySettings.hpp
  • EmApoxiDnsClient_hpp : EmApoxiDnsClient.hpp
  • EmApoxiFFS_get_raw_free_space_in_global_pool() : EmApoxiOs.cpp
  • EmApoxiFile_hpp : EmApoxiFile.hpp
  • EmApoxiInetSocketAddr_hpp : EmApoxiInetSocketAddr.hpp
  • EmApoxiInterface_hpp : EmApoxiInterface.hpp
  • EmApoxiIpAddr_hpp : EmApoxiIpAddr.hpp
  • EmApoxiIpPortNo_hpp : EmApoxiIpPortNo.hpp
  • EmApoxiMediaInfo_hpp : EmApoxiMediaInfo.hpp
  • EmApoxiMimeTypeTable_hpp : EmApoxiMimeTypeTable.hpp
  • EmApoxiMsgDispatcher_hpp : EmApoxiMsgDispatcher.hpp
  • EmApoxiMutex_hpp : EmApoxiMutex.hpp
  • EmApoxiMutexObtainer_hpp : EmApoxiMutexObtainer.hpp
  • EmApoxiOs_hpp : EmApoxiOs.hpp
  • EmApoxiPlayerEnum_hpp : EmApoxiPlayerEnum.hpp
  • EmApoxiPostMessageToServiceThread() : EmApoxiMsgDispatcher.cpp
  • EmApoxiRecorderEnum_hpp : EmApoxiRecorderEnum.hpp
  • EmApoxiRecordSettings_hpp : EmApoxiRecordSettings.hpp
  • EmApoxiSemaphore_hpp : EmApoxiSemaphore.hpp
  • EmApoxiServiceThread_hpp : EmApoxiServiceThread.hpp
  • EmApoxiSocketHandler_hpp : EmApoxiSocketHandler.hpp
  • EmApoxiTcpSocket_hpp : EmApoxiTcpSocket.hpp
  • EmApoxiThread_hpp : EmApoxiThread.hpp
  • EmApoxiTicks_hpp : EmApoxiTicks.hpp
  • EmApoxiTimer_hpp : EmApoxiTimer.hpp
  • EmApoxiTranslate() : EmApoxiVideoUtils.cpp
  • EmApoxiUdpSocket_hpp : EmApoxiUdpSocket.hpp
  • EmApoxiUtilities_hpp : EmApoxiUtilities.hpp
  • EmApoxiVideoCaptureExp_hpp : EmApoxiVideoCaptureExp.hpp
  • EmApoxiVideoDecoderhpp : EmApoxiVideoDecoder.hpp
  • EmApoxiVideoDefines_hpp : EmApoxiVideoDefines.hpp
  • EmApoxiVideoEncoderhpp : EmApoxiVideoEncoder.hpp
  • EmApoxiVideoRenderer : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererCreate() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererDelete() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererDisable() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererEnable() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererExp_hpp : EmApoxiVideoRendererExp.hpp
  • EmApoxiVideoRendererRenderFrame() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererSetImageFormat() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererSetLCDParams() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererSetRectangle() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoUtils_hpp : EmApoxiVideoUtils.hpp
  • EMAXPATH : FfsSim.cpp
  • EmCellType : NetworkTypes.hpp
  • EmcFailed : NetworkTypes.hpp
  • EmcLockSCell : NetworkTypes.hpp
  • EmControlRetValue : NetworkTypes.hpp
  • EMCPP_OBEX_CLIENT : apoxi_emcpp_OBEXAdapter.hpp
  • EMCPP_OBEX_SERVER : apoxi_emcpp_OBEXAdapter.hpp
  • EmcSuccess : NetworkTypes.hpp
  • EmcTrigger3g2gHandover : NetworkTypes.hpp
  • EmcUnlockSCell : NetworkTypes.hpp
  • EmcUnsuported : NetworkTypes.hpp
  • EmergencyCall : SignalTypes.hpp
  • EmergencyCalls : SignalTypes.hpp
  • EmEventType : NetworkTypes.hpp
  • Emlpp : SignalTypes.hpp
  • EmlppActionType : InputAction.hpp
  • EmlppEfPos : SimTkTypes.hpp
  • EmlppHandlerId : HandlerId.hpp
  • EmlppPriorityLevel : SignalTypes.hpp
  • EmlppPriorityLevel0 : SignalTypes.hpp
  • EmlppPriorityLevel1 : SignalTypes.hpp
  • EmlppPriorityLevel2 : SignalTypes.hpp
  • EmlppPriorityLevel3 : SignalTypes.hpp
  • EmlppPriorityLevel4 : SignalTypes.hpp
  • EmlppPriorityLevelA : SignalTypes.hpp
  • EmlppPriorityLevelB : SignalTypes.hpp
  • EmlppPriorityLevelVoid : SignalTypes.hpp
  • EmptyFfsFileInfo : FfsTypes.hpp
  • EmRankingStatus : NetworkTypes.hpp
  • Ems_EmsCreator_hpp : EmsCreator.hpp
  • Ems_EmsEditor_hpp : EmsEditor.hpp
  • Ems_EmsEditorListener_hpp : EmsEditorListener.hpp
  • Ems_EmsIeParser_hpp : EmsIeParser.hpp
  • Ems_EmsImage_hpp : EmsImage.hpp
  • Ems_EmsInsertPrompt_hpp : EmsInsertPrompt.hpp
  • Ems_EmsResourceMaps_hpp : EmsResourceMaps.hpp
  • Ems_PredefinedEmsImage_hpp : PredefinedEmsImage.hpp
  • Ems_PredefinedEmsSound_hpp : PredefinedEmsSound.hpp
  • EmServThreadMsg_hpp__ST_1128926169290 : EmServThreadMsg.hpp
  • EMSVERSION : EmsVersion.hpp
  • EmsVersion_hpp : EmsVersion.hpp
  • EMZ_CODECS : apoxi.features
  • emz_free() : EmzCodecsLib.cpp
  • emz_malloc() : EmzCodecsLib.cpp
  • emz_realloc() : EmzCodecsLib.cpp
  • EmzAacDecoderThread_hpp : EmzAacDecoderThread.hpp
  • EmzCodecsLib_hpp : EmzCodecsLib.hpp
  • EmzH264Decoder_hpp : EmzH264Decoder.hpp
  • EmzH264DecoderThread_hpp : EmzH264DecoderThread.hpp
  • EmzMp3DecoderThread_hpp : EmzMp3DecoderThread.hpp
  • EmzMpeg4Decoder_hpp : EmzMpeg4Decoder.hpp
  • EmzMpeg4DecoderThread_hpp : EmzMpeg4DecoderThread.hpp
  • EmzMpeg4Encoder_hpp : EmzMpeg4Encoder.hpp
  • EmzMpeg4EncoderThread_hpp : EmzMpeg4EncoderThread.hpp
  • EmzSbcEncoderThread_hpp : EmzSbcEncoderThread.hpp
  • EmzUtils_hpp : EmzUtils.hpp
  • ENABLE_ONLY_THE_TEST_APPLICATION : CameraSettingsWin.cpp
  • EncodeIStreamBuffer() : parsifal.cpp
  • ENCRYPTION_METHOD_STR : DrmDcfParser.hpp
  • end_atom_idx : BitBlit_Planes.cpp
  • END_STATE_MAP : StateMachine.hpp
  • END_TRANSITION_MAP : StateMachine.hpp
  • end_y : BitBlit_Planes.cpp
  • EndlessLoopBehavior : ScrollBehavior.hpp
  • EngineeringModeControl : NetworkTypes.hpp
  • EngModeActionType : InputAction.hpp
  • enlarge_memory() : utils.cpp
  • EntryId : AcacTypes.hpp
  • EnumTextTable : EnumTextMap.hpp
  • EnumTr : EnumTranslationTable.hpp
  • EOS : Wsscanf.cpp
  • EosToken : InputParser.hpp
  • ErrMapEntry : Win32SysSocket.cpp, UsnetSysSocket.cpp, LwipSysSocket.cpp, BsdSysSocket.cpp
  • ErrorCode : SocketTestDefines.hpp
  • ErrorTone : SignalTypes.hpp
  • ErrorToneRpt : SignalTypes.hpp
  • EstTableIndexes : SstProvider.hpp
  • ExpansionValue : PhoneNumber.hpp
  • ExplicitCallTransfer : SignalTypes.hpp
  • Ext1EfPos : SimTkTypes.hpp
  • Ext1PhoneBookCnt : SignalTypes.hpp
  • Ext2EfPos : SimTkTypes.hpp
  • Ext2PhoneBookCnt : SignalTypes.hpp
  • Ext3EfPos : SimTkTypes.hpp
  • Ext4EfPos : SimTkTypes.hpp
  • Ext4PhoneBookCnt : SignalTypes.hpp
  • Ext6PhoneBookCnt : SignalTypes.hpp
  • Ext7PhoneBookCnt : SignalTypes.hpp
  • ExtendedDbgCode : WString.cpp, String.cpp
  • ExtendUuidTo128Bit() : BtUtility.hpp, BtUtility.cpp
  • EXTERNAL_RINGER : apoxi.features
  • externalMsg : MsgCategory.hpp
  • ExtFfsFileType : FfsTypes.hpp
  • ExtFfsPit : FfsTypes.hpp
  • ExtFfsUserType : FfsTypes.hpp
  • ExtIndicator : SignalTypes.hpp
  • ExtndDnsClient_hpp : ExtndDnsClient.hpp
  • ExtndTcpSocket_hpp : ExtndTcpSocket.hpp
  • EZD_DEFAULT_AUDIO_CODEC : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_AUDIO_QUALITY : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_BRIGHTNESS : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CAMERA_DEV_ID : RecordSettings.cpp
  • EZD_DEFAULT_CAMERA_DEVICE_ID : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CAMERA_HEIGHT : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CAMERA_NIGHT_MODE : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CAMERA_WIDTH : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CONTRAST : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_DURATION : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_FILE_SIZE : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_FRAMERATE : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_SINK_TYPE : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_VIDEO_CODEC : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_VIDEO_QUALITY : EmApoxiRecordSettings.cpp
Generated on Wed Jan 25 02:31:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • F_HAS_LOWER_AND_UPPER_CASE : WCattr.cpp
  • F_HAS_LOWER_CASE : WCattr.cpp
  • F_HAS_UPPER_CASE : WCattr.cpp
  • F_IS_COMPOSED : WCattr.cpp
  • F_LONG : Wsscanf.cpp
  • F_SIGNALLOW : Wsscanf.cpp
  • F_SUPPRESS : Wsscanf.cpp
  • FacilityNotImplemented : SignalTypes.hpp
  • FacilityNotSubscribed : SignalTypes.hpp
  • FacilityRejected : SignalTypes.hpp
  • FacsimileCall : SignalTypes.hpp
  • FacsimileGroup3AndAlterSpeech : SignalTypes.hpp
  • FacsimileGroup4 : SignalTypes.hpp
  • FALSE : Types.hpp
  • FastSearchMode : NetworkTypes.hpp
  • FAT_FS : apoxi.features
  • FatAccessFlagAppend : FatTypes.hpp
  • FatAccessFlagBinary : FatTypes.hpp
  • FatAccessFlagCreate : FatTypes.hpp
  • FatAccessFlagExcl : FatTypes.hpp
  • FatAccessFlagNoShareAny : FatTypes.hpp
  • FatAccessFlagNoShareWrite : FatTypes.hpp
  • FatAccessFlagRdOnly : FatTypes.hpp
  • FatAccessFlagRdWr : FatTypes.hpp
  • FatAccessFlagText : FatTypes.hpp
  • FatAccessFlagTrunc : FatTypes.hpp
  • FatAccessFlagWrOnly : FatTypes.hpp
  • FatChangedCard : FatTypes.hpp
  • FatError : FatTypes.hpp
  • FatErrorAccessDenied : FatTypes.hpp
  • FatErrorBadCard : FatTypes.hpp
  • FatErrorBadFileDescriptor : FatTypes.hpp
  • FatErrorBadFormat : FatTypes.hpp
  • FatErrorCardFailure : FatTypes.hpp
  • FatErrorEccError : FatTypes.hpp
  • FatErrorFailure : FatTypes.hpp
  • FatErrorFileAlreadyExist : FatTypes.hpp
  • FatErrorIdError : FatTypes.hpp
  • FatErrorIO : FatTypes.hpp
  • FatErrorNegativeFilePointer : FatTypes.hpp
  • FatErrorNoCard : FatTypes.hpp
  • FatErrorNoDisk : FatTypes.hpp
  • FatErrorNoSpace : FatTypes.hpp
  • FatErrorNotExist : FatTypes.hpp
  • FatErrorOperationNotPossible : FatTypes.hpp
  • FatErrorShare : FatTypes.hpp
  • FatErrorSuccess : FatTypes.hpp
  • FatErrorTooManyFileOpen : FatTypes.hpp
  • FatErrorUnknown : FatTypes.hpp
  • FatErrorUserIdError : FatTypes.hpp
  • FatFileAttrArchive : FatTypes.hpp
  • FatFileAttrChicagoExt : FatTypes.hpp
  • FatFileAttrDirectory : FatTypes.hpp
  • FatFileAttrHidden : FatTypes.hpp
  • FatFileAttribute : FatTypes.hpp
  • FatFileAttrNormal : FatTypes.hpp
  • FatFileAttrRdOnly : FatTypes.hpp
  • FatFileAttrSystem : FatTypes.hpp
  • FatFileAttrVolume : FatTypes.hpp
  • FatFsMsgTypes_hpp__ST_1128347975150 : FatFsMsgTypes.hpp
  • FatHandle : FatTypes.hpp
  • FatOpenMode : FatTypes.hpp
  • FatReadAndWriteMode : FatTypes.hpp
  • FatReadOnlyMode : FatTypes.hpp
  • FatSeekBegin : FatTypes.hpp
  • FatSeekCurrent : FatTypes.hpp
  • FatSeekEnd : FatTypes.hpp
  • FatTimeRecord : FatTypes.hpp
  • Fax : PbTypes.hpp
  • Fdd : NetworkTypes.hpp
  • FdnEfPos : SimTkTypes.hpp
  • FdnFailed : SignalTypes.hpp
  • FdnNotPossible : NetworkTypes.hpp
  • FdnOff : NetworkTypes.hpp
  • FdnOn : NetworkTypes.hpp
  • FdnPhoneBook : SignalTypes.hpp
  • FdnPhoneBookCnt : SignalTypes.hpp
  • FdnState : NetworkTypes.hpp
  • FEAT_BT_A2DP : apoxi.features
  • FEAT_BT_AVRCP : apoxi.features
  • FEAT_BT_BIP : apoxi.features
  • FEAT_BT_BPP : apoxi.features, apoxi.defines
  • FEAT_BTSOCKET : apoxi.features
  • FEAT_EXTERNAL_PCH_CONTROL : apoxi.features
  • FEAT_FOTA : apoxi.features
  • FEAT_MMCALL : apoxi.features
  • FEAT_SECURECLOCK : apoxi.features
  • FEAT_SERIALSOCKET : apoxi.features
  • FEAT_SIOSOCKETADAPTER : apoxi.features, apoxi.defines
  • FEATURE_AVAILABLE_NO : BtHfProfileWindows.cpp
  • FEATURE_AVAILABLE_YES : BtHfProfileWindows.cpp
  • FEATURE_CLI_PRESENTATION : BtHfProfileWindows.cpp
  • FEATURE_EC_NR : BtHfProfileWindows.cpp
  • FEATURE_HF_INBAND_RINGING : BtHfService.cpp
  • FEATURE_HF_VOICE_TAG : BtHfController.cpp
  • Feature_hpp : Feature.hpp
  • FEATURE_REMOTE_VOLUME_CTRL : BtHfProfileWindows.cpp
  • FEATURE_THREE_WAY_CALL : BtHfProfileWindows.cpp
  • FEATURE_VOICE_REC : BtHfProfileWindows.cpp
  • FeatureID : FeatureID.hpp
  • FeatureID_hpp : FeatureID.hpp
  • FeatureItem_hpp : FeatureItem.hpp
  • FeatureItemContainer_hpp : FeatureItemContainer.hpp
  • FeatureItemContainerID : FeatureItemContainerID.hpp
  • FeatureItemContainerID_hpp : FeatureItemContainerID.hpp
  • FeatureType : LcsFeatTypes.hpp
  • FFS : apoxi.features
  • FFS_ALL_FILETYPES : FfsSim.hpp
  • FFS_ALREADY_OPEN : FfsSim.hpp
  • FFS_APCON01 : FfsSim.hpp
  • FFS_APCON02 : FfsSim.hpp
  • FFS_APCON03 : FfsSim.hpp
  • FFS_APCON04 : FfsSim.hpp
  • FFS_APCON05 : FfsSim.hpp
  • FFS_APCON06 : FfsSim.hpp
  • FFS_APCON07 : FfsSim.hpp
  • FFS_APCON08 : FfsSim.hpp
  • FFS_APCON09 : FfsSim.hpp
  • FFS_APCON10 : FfsSim.hpp
  • FFS_APCON11 : FfsSim.hpp
  • FFS_APCON12 : FfsSim.hpp
  • FFS_APCON13 : FfsSim.hpp
  • FFS_APCON14 : FfsSim.hpp
  • FFS_APCON15 : FfsSim.hpp
  • FFS_append() : FfsSim.hpp, FfsSim.cpp
  • FFS_append_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_ATC : FfsSim.hpp
  • FFS_AUDIO : FfsSim.hpp
  • FFS_BLOCK_SIZE : FfsSim.hpp
  • FFS_calculate_file_overhead() : FfsSim.hpp, FfsSim.cpp
  • ffs_callback_type : FfsSim.hpp
  • FFS_close() : FfsSim.hpp, FfsSim.cpp
  • FFS_close_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_copy() : FfsSim.hpp, FfsSim.cpp
  • FFS_copy_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_create() : FfsSim.hpp, FfsSim.cpp
  • FFS_create_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_deactivate() : FfsSim.hpp, FfsSim.cpp
  • FFS_delete() : FfsSim.hpp, FfsSim.cpp
  • FFS_delete_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_DIR_SPACE_NOT_AVAILABLE : FfsSim.hpp
  • FFS_DWDIO : FfsSim.hpp
  • ffs_error_code_type : FfsSim.hpp
  • FFS_EXISTS : FfsSim.hpp
  • FFS_FALSE : FfsSim.hpp
  • FFS_FILE_ALREADY_CREATED : FfsSim.hpp
  • FFS_file_exists() : FfsSim.hpp, FfsSim.cpp
  • FFS_file_exists_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_FILE_NOT_FOUND : FfsSim.hpp
  • FFS_FILE_OPEN_APPEND : FfsSim.hpp
  • FFS_FILE_OPEN_MODIFY : FfsSim.hpp
  • FFS_FILE_OPEN_READ : FfsSim.hpp
  • FFS_FILE_OPEN_READ_STREAMING : FfsSim.hpp
  • FFS_FILE_RANGE_ERROR : FfsSim.hpp
  • FFS_FILETYPE_3GP : FfsSim.hpp
  • FFS_FILETYPE_AAC : FfsSim.hpp
  • FFS_FILETYPE_AAN : FfsSim.hpp
  • FFS_FILETYPE_AIM : FfsSim.hpp
  • FFS_FILETYPE_AMR : FfsSim.hpp
  • FFS_FILETYPE_APOXI_SETTING : FfsSim.hpp
  • FFS_FILETYPE_AVI : FfsSim.hpp
  • FFS_FILETYPE_BMP : FfsSim.hpp
  • FFS_FILETYPE_BROWSER_CACHE : FfsSim.hpp
  • FFS_FILETYPE_BROWSER_DATBASE : FfsSim.hpp
  • FFS_FILETYPE_DRM : FfsSim.hpp
  • FFS_FILETYPE_DRM_RO : FfsSim.hpp
  • FFS_FILETYPE_EMS_BMP : FfsSim.hpp
  • FFS_FILETYPE_FR : FfsSim.hpp
  • FFS_FILETYPE_FRAME : FfsSim.hpp
  • FFS_FILETYPE_GARBAGE : FfsSim.hpp
  • FFS_FILETYPE_GIF : FfsSim.hpp
  • FFS_FILETYPE_HTM : FfsSim.hpp
  • FFS_FILETYPE_HTML : FfsSim.hpp
  • FFS_FILETYPE_ICS : FfsSim.hpp
  • FFS_FILETYPE_IMELODY : FfsSim.hpp
  • FFS_FILETYPE_JAD : FfsSim.hpp
  • FFS_FILETYPE_JAM_BACKUP : FfsSim.hpp
  • FFS_FILETYPE_JAM_DEFAULT : FfsSim.hpp
  • FFS_FILETYPE_JAR : FfsSim.hpp
  • FFS_FILETYPE_JPE : FfsSim.hpp
  • FFS_FILETYPE_JPEG : FfsSim.hpp
  • FFS_FILETYPE_JPG : FfsSim.hpp
  • FFS_FILETYPE_JRS : FfsSim.hpp
  • FFS_FILETYPE_M4A : FfsSim.hpp
  • FFS_FILETYPE_MIDI : FfsSim.hpp
  • FFS_FILETYPE_MMF : FfsSim.hpp
  • FFS_FILETYPE_MMF_PHRASE : FfsSim.hpp
  • FFS_FILETYPE_MMI_SETTING : FfsSim.hpp
  • FFS_FILETYPE_MMS : FfsSim.hpp
  • FFS_FILETYPE_MMS_APP_REPORT : FfsSim.hpp
  • FFS_FILETYPE_MMS_BACKUP : FfsSim.hpp
  • FFS_FILETYPE_MMS_NOTIFICATION : FfsSim.hpp
  • FFS_FILETYPE_MMS_PRE : FfsSim.hpp
  • FFS_FILETYPE_MMS_REPORTS : FfsSim.hpp
  • FFS_FILETYPE_MMS_STORAGE : FfsSim.hpp
  • FFS_FILETYPE_MMS_TEST : FfsSim.hpp
  • FFS_FILETYPE_MMT : FfsSim.hpp
  • FFS_FILETYPE_MOV : FfsSim.hpp
  • FFS_FILETYPE_MP3 : FfsSim.hpp
  • FFS_FILETYPE_MPE : FfsSim.hpp
  • FFS_FILETYPE_MPEG : FfsSim.hpp
  • FFS_FILETYPE_MPG : FfsSim.hpp
  • FFS_FILETYPE_MPGA : FfsSim.hpp
  • FFS_FILETYPE_MYSTUFF : FfsSim.hpp
  • FFS_FILETYPE_PNG : FfsSim.hpp
  • FFS_FILETYPE_PUSH_MESSAGES : FfsSim.hpp
  • FFS_FILETYPE_REGISTRY : FfsSim.hpp
  • FFS_FILETYPE_SAF : FfsSim.hpp
  • FFS_FILETYPE_SECURITY_CERTIFICATES : FfsSim.hpp
  • FFS_FILETYPE_SETTINGS : FfsSim.hpp
  • FFS_FILETYPE_SMS : FfsSim.hpp
  • FFS_FILETYPE_SMS_POOL_SIZE_PHYSICAL : FfsSim.hpp
  • FFS_FILETYPE_SPF : FfsSim.hpp
  • FFS_FILETYPE_SVG : FfsSim.hpp
  • FFS_FILETYPE_SVGZ : FfsSim.hpp
  • FFS_FILETYPE_TIF : FfsSim.hpp
  • FFS_FILETYPE_TXT : FfsSim.hpp
  • ffs_filetype_type : FfsSim.hpp
  • FFS_FILETYPE_VCF : FfsSim.hpp
  • FFS_FILETYPE_WAP_SETTING : FfsSim.hpp
  • FFS_FILETYPE_WAV : FfsSim.hpp
  • FFS_FILETYPE_WBMP : FfsSim.hpp
  • FFS_FILETYPE_WML : FfsSim.hpp
  • FFS_FILETYPE_WMLS : FfsSim.hpp
  • FFS_FILETYPE_XHTML : FfsSim.hpp
  • FFS_FILETYPE_XML : FfsSim.hpp
  • FFS_findfirst() : FfsSim.hpp, FfsSim.cpp
  • FFS_findfirst_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_findnext() : FfsSim.hpp, FfsSim.cpp
  • FFS_findnext_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_GENERIC_FILETYPE : FfsSim.hpp
  • FFS_get_file_id() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_file_info() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_file_info_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_file_name() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_free_space() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_free_space_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_free_space_in_global_pool() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_next_free_id() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_nof_files() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_nof_files_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_raw_free_space_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_raw_free_space_in_global_pool() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_reserved_space_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_reserved_space_in_global_pool() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_used_space() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_used_space_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_used_space_in_global_pool() : FfsSim.hpp, FfsSim.cpp
  • ffs_handle_type : FfsSim.hpp
  • FFS_ILLIGAL_DIR_OPERATION : FfsSim.hpp
  • FFS_ILLIGAL_FILE_HANDLE : FfsSim.hpp
  • FFS_ILLIGAL_ID : FfsSim.hpp
  • FFS_ILLIGAL_MODE : FfsSim.hpp
  • FFS_ILLIGAL_TYPE : FfsSim.hpp
  • FFS_initialize() : FfsSim.hpp, FfsSim.cpp
  • FFS_INITIALIZING : FfsSim.hpp
  • FFS_INTERNAL : FfsSim.hpp
  • FFS_INTERNAL_FATAL_ERROR : FfsSim.hpp
  • FFS_INVALID_FILENAME : FfsSim.hpp
  • FFS_INVALID_NAME : FfsSim.hpp
  • FFS_JAVA : FfsSim.hpp
  • FFS_MAX_FILESIZE : FfsSim.hpp
  • FFS_MAX_NOF_FILES_EXCEEDED : FfsSim.hpp
  • FFS_MAX_SOF_DIR_NAME : FfsSim.hpp
  • FFS_MAX_SOF_FILENAME : FfsSim.hpp
  • FFS_MEM_TABLES_INCONSISTENCY : FfsSim.hpp
  • ffs_memory_pool_reservations : FfsSim.hpp
  • FFS_MEMORY_RES_ERROR : FfsSim.hpp
  • FFS_MMI : FfsSim.hpp
  • FFS_MMS : FfsSim.hpp
  • FFS_modify() : FfsSim.hpp, FfsSim.cpp
  • FFS_modify_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_MP3 : FfsSim.hpp
  • FFS_NOF_DYNAMIC_BLOCKS : FfsSim.hpp
  • FFS_NOF_FILETYPES : FfsSim.hpp
  • FFS_NOF_RES_ID : FfsSim.hpp
  • FFS_NOF_USERS : FfsSim.hpp
  • FFS_NOT_A_FACTORY_DEFAULT_FILE : FfsSim.hpp
  • FFS_NOT_OPEN : FfsSim.hpp
  • FFS_open() : FfsSim.hpp, FfsSim.cpp
  • ffs_open_file_mode_type : FfsSim.hpp
  • FFS_open_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_OPERATION_NOT_ALLOWED_ON_STATIC_FILE : FfsSim.hpp
  • FFS_OPERATION_NOT_POSSIBLE : FfsSim.hpp
  • ffs_pit : FfsSim.hpp
  • FFS_read() : FfsSim.hpp, FfsSim.cpp
  • FFS_read_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_ready() : FfsSim.hpp, FfsSim.cpp
  • FFS_rename() : FfsSim.hpp, FfsSim.cpp
  • FFS_rename_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_REQUESTED_MEM_NOT_AVAILABLE : FfsSim.hpp
  • FFS_REQUESTED_MEM_TEMP_NOT_AVAILABLE : FfsSim.hpp
  • FFS_SECTOR_SIZE : FfsSim.hpp
  • FFS_set_drm_attrib() : FfsSim.hpp, FfsSim.cpp
  • FFS_set_drm_attrib_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_SIM_hpp : FfsSim.hpp
  • FFS_SMS : FfsSim.hpp
  • FFS_STREAMING : FfsSim.hpp
  • FFS_STREAMING_NOT_ENABLED : FfsSim.hpp
  • FFS_SUCCESS : FfsSim.hpp
  • FFS_TRUE : FfsSim.hpp
  • FFS_truncate() : FfsSim.hpp, FfsSim.cpp
  • FFS_truncate_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_USER_ID_ERROR : FfsSim.hpp
  • ffs_user_type : FfsSim.hpp
  • FFS_VR : FfsSim.hpp
  • FFS_WAP : FfsSim.hpp
  • FFS_write() : FfsSim.hpp, FfsSim.cpp
  • FFS_WRITE_ERROR : FfsSim.hpp
  • FFS_write_fn() : FfsSim.hpp, FfsSim.cpp
  • FfsDelete() : FfsSim.cpp
  • FfsDeleteFileErr : FfsTestError.hpp
  • FfsError : FfsTypes.hpp
  • ffsError : FfsTestError.hpp
  • FfsErrorAlreadyOpen : FfsTypes.hpp
  • FfsErrorFalse : FfsTypes.hpp
  • FfsErrorFileAlreadyCreated : FfsTypes.hpp
  • FfsErrorFileNotFound : FfsTypes.hpp
  • FfsErrorFileRangeError : FfsTypes.hpp
  • FfsErrorIllegalFileHandle : FfsTypes.hpp
  • FfsErrorIllegalId : FfsTypes.hpp
  • FfsErrorIllegalMode : FfsTypes.hpp
  • FfsErrorIllegalType : FfsTypes.hpp
  • FfsErrorInitializing : FfsTypes.hpp
  • FfsErrorIntFatalError : FfsTypes.hpp
  • FfsErrorInvalidFilename : FfsTypes.hpp
  • FfsErrorMaxNrOfFilesExcceeded : FfsTypes.hpp
  • FfsErrorMemoryResError : FfsTypes.hpp
  • FfsErrorMemTablesInconsistent : FfsTypes.hpp
  • FfsErrorNoFactoryDefaultFile : FfsTypes.hpp
  • FfsErrorNotOpen : FfsTypes.hpp
  • FfsErrorNotPossible : FfsTypes.hpp
  • FfsErrorOpNotAllowedOnStatFile : FfsTypes.hpp
  • FfsErrorReqMemNotAvailable : FfsTypes.hpp
  • FfsErrorReqMemTempNotAvailable : FfsTypes.hpp
  • FfsErrorStreamingNotEnabled : FfsTypes.hpp
  • FfsErrorSuccess : FfsTypes.hpp
  • FfsErrorTrue : FfsTypes.hpp
  • FfsErrorUserIdError : FfsTypes.hpp
  • FfsErrorWriteError : FfsTypes.hpp
  • FfsFileId : FfsTypes.hpp
  • FfsFileType : FfsTypes.hpp
  • FfsFileType3gp : FfsTypes.hpp
  • FfsFileTypeAac : FfsTypes.hpp
  • FfsFileTypeAan : FfsTypes.hpp
  • FfsFileTypeAim : FfsTypes.hpp
  • FfsFileTypeAll : FfsTypes.hpp
  • FfsFileTypeAmr : FfsTypes.hpp
  • FfsFileTypeApoxiSetting : FfsTypes.hpp
  • FfsFileTypeAvi : FfsTypes.hpp
  • FfsFileTypeBmp : FfsTypes.hpp
  • FfsFileTypeBrowserCache : FfsTypes.hpp
  • FfsFileTypeBrowserDatabase : FfsTypes.hpp
  • FfsFileTypeDrm : FfsTypes.hpp
  • FfsFileTypeDrmRo : FfsTypes.hpp
  • FfsFileTypeEmsBmp : FfsTypes.hpp
  • FfsFileTypeFr : FfsTypes.hpp
  • FfsFileTypeFrame : FfsTypes.hpp
  • FfsFileTypeGarbage : FfsTypes.hpp
  • FfsFileTypeGeneric : FfsTypes.hpp
  • FfsFileTypeGif : FfsTypes.hpp
  • FfsFileTypeHtm : FfsTypes.hpp
  • FfsFileTypeHtml : FfsTypes.hpp
  • FfsFileTypeIcs : FfsTypes.hpp
  • FfsFileTypeIMelody : FfsTypes.hpp
  • FfsFileTypeJad : FfsTypes.hpp
  • FfsFileTypeJamBackup : FfsTypes.hpp
  • FfsFileTypeJamDefault : FfsTypes.hpp
  • FfsFileTypeJar : FfsTypes.hpp
  • FfsFileTypeJpe : FfsTypes.hpp
  • FfsFileTypeJpeg : FfsTypes.hpp
  • FfsFileTypeJpg : FfsTypes.hpp
  • FfsFileTypeJrs : FfsTypes.hpp
  • FfsFileTypeM4a : FfsTypes.hpp
  • FfsFileTypeMidi : FfsTypes.hpp
  • FfsFileTypeMmf : FfsTypes.hpp
  • FfsFileTypeMmfPhrase : FfsTypes.hpp
  • FfsFileTypeMmiSetting : FfsTypes.hpp
  • FfsFileTypeMms : FfsTypes.hpp
  • FfsFileTypeMmsAppReport : FfsTypes.hpp
  • FfsFileTypeMmsBackup : FfsTypes.hpp
  • FfsFileTypeMmsNotification : FfsTypes.hpp
  • FfsFileTypeMmsPre : FfsTypes.hpp
  • FfsFileTypeMmsReports : FfsTypes.hpp
  • FfsFileTypeMmsStorage : FfsTypes.hpp
  • FfsFileTypeMmsTest : FfsTypes.hpp
  • FfsFileTypeMmt : FfsTypes.hpp
  • FfsFileTypeMov : FfsTypes.hpp
  • FfsFileTypeMp3 : FfsTypes.hpp
  • FfsFileTypeMpe : FfsTypes.hpp
  • FfsFileTypeMpeg : FfsTypes.hpp
  • FfsFileTypeMpg : FfsTypes.hpp
  • FfsFileTypeMpga : FfsTypes.hpp
  • FfsFileTypeMyStuff : FfsTypes.hpp
  • FfsFileTypePng : FfsTypes.hpp
  • FfsFileTypePushMessages : FfsTypes.hpp
  • FfsFileTypeRegistry : FfsTypes.hpp
  • FfsFileTypeSaf : FfsTypes.hpp
  • FfsFileTypeSecurityCertificates : FfsTypes.hpp
  • FfsFileTypeSettings : FfsTypes.hpp
  • FfsFileTypeSms : FfsTypes.hpp
  • FfsFileTypeSpf : FfsTypes.hpp
  • FfsFileTypeSvg : FfsTypes.hpp
  • FfsFileTypeSvgz : FfsTypes.hpp
  • FfsFileTypeTif : FfsTypes.hpp
  • FfsFileTypeTxt : FfsTypes.hpp
  • FfsFileTypeVcf : FfsTypes.hpp
  • FfsFileTypeWapSetting : FfsTypes.hpp
  • FfsFileTypeWav : FfsTypes.hpp
  • FfsFileTypeWbmp : FfsTypes.hpp
  • FfsFileTypeWml : FfsTypes.hpp
  • FfsFileTypeWmls : FfsTypes.hpp
  • FfsFileTypeXhtml : FfsTypes.hpp
  • FfsFileTypeXml : FfsTypes.hpp
  • FfsHandle : FfsTypes.hpp
  • FfsMemAllocErr : FfsTestError.hpp
  • FfsMimeTypeMap_hpp : FfsMimeTypeMap.hpp
  • FfsNofFileTypes : FfsTypes.hpp
  • FfsNofResId : FfsTypes.hpp
  • FfsNofUsers : FfsTypes.hpp
  • FfsOpenMode : FfsTypes.hpp
  • FfsOpenModeAppend : FfsTypes.hpp
  • FfsOpenModeModify : FfsTypes.hpp
  • FfsOpenModeRead : FfsTypes.hpp
  • FfsOpenModeReadStr : FfsTypes.hpp
  • FfsPit : FfsTypes.hpp
  • FfsSetDrmAttrib() : FfsSim.cpp
  • FfsTestOK : FfsTestError.hpp
  • FfsUserType : FfsTypes.hpp
  • FfsUserTypeAppCon01 : FfsTypes.hpp
  • FfsUserTypeAppCon02 : FfsTypes.hpp
  • FfsUserTypeAppCon03 : FfsTypes.hpp
  • FfsUserTypeAppCon04 : FfsTypes.hpp
  • FfsUserTypeAppCon05 : FfsTypes.hpp
  • FfsUserTypeAppCon06 : FfsTypes.hpp
  • FfsUserTypeAppCon07 : FfsTypes.hpp
  • FfsUserTypeAppCon08 : FfsTypes.hpp
  • FfsUserTypeAppCon09 : FfsTypes.hpp
  • FfsUserTypeAppCon10 : FfsTypes.hpp
  • FfsUserTypeAppCon11 : FfsTypes.hpp
  • FfsUserTypeAppCon12 : FfsTypes.hpp
  • FfsUserTypeAppCon13 : FfsTypes.hpp
  • FfsUserTypeAppCon14 : FfsTypes.hpp
  • FfsUserTypeAppCon15 : FfsTypes.hpp
  • FfsUserTypeAtc : FfsTypes.hpp
  • FfsUserTypeAudio : FfsTypes.hpp
  • FfsUserTypeDwdIo : FfsTypes.hpp
  • FfsUserTypeJava : FfsTypes.hpp
  • FfsUserTypeMmi : FfsTypes.hpp
  • FfsUserTypeMms : FfsTypes.hpp
  • FfsUserTypeMp3 : FfsTypes.hpp
  • FfsUserTypeSms : FfsTypes.hpp
  • FfsUserTypeVr : FfsTypes.hpp
  • FfsUserTypeWap : FfsTypes.hpp
  • file_name : FfsTests.cpp
  • FileCopyErr : FfsTestError.hpp
  • FileDataClose() : EmApoxiFile.cpp
  • FileDataGetSize() : EmApoxiFile.cpp
  • FileDataOpen() : EmApoxiFile.cpp
  • FileDataRead() : EmApoxiFile.cpp
  • FileDataSinkPtr : FileDataSink.hpp
  • FileDataSourcePtr : FileDataSource.hpp
  • FileDataWrite() : EmApoxiFile.cpp
  • FileFilterPtr : RootFileSystem.hpp, FileVisitor.hpp
  • FileInfo : Unzip.hpp
  • FileInfoInternal : Unzip.hpp
  • FILEPACK_ID : AcacTypes.hpp
  • FilePackData : AcacTypes.hpp
  • FilePtr : MediaRefContainer.hpp, RootFileSystem.hpp, FileDataSource.hpp, FileDataSink.hpp, FileBinData.hpp
  • FileRefresh : SignalTypes.hpp
  • FileRenameErr : FfsTestError.hpp
  • FileSizeErr : FfsTestError.hpp
  • FINAL_REPORT : SocketTestT.hpp
  • FindFirstByte() : SimAuxHandler.hpp, SimAuxHandler.cpp
  • FindNotUsedHandlePos() : HostCoreFsSim.cpp
  • FindSSString() : PhoneNumber.cpp
  • FIRST_CODE : GifDecoder.cpp
  • FLAG : RegEncoderDecoder.hpp
  • flag : VCard.cpp
  • FlagsIsSet : Wsscanf.cpp
  • FlagsSet : Wsscanf.cpp
  • FLUSH_OUTPUT : GifDecoder.cpp
  • Fm : SignalTypes.hpp
  • FMRADIO : apoxi.features
  • FmRadio_SelectStrongerFreq_hpp : FmRadioSelectStrongerFreq.hpp
  • FmRadioEditWin_hpp : FmRadioEditWin.hpp
  • FmRadioSettingsColIds : FmRadioSettingsProvider.hpp
  • FmRadioStationsColIds : FmRadioStationsProvider.hpp
  • FMRADIOVERSION : FmRadioVersion.hpp
  • FmRadioVersion_hpp : FmRadioVersion.hpp
  • foggy_theme : FoggyTheme.hpp, FoggyTheme.cpp
  • FontAlign : TextFormat.hpp
  • FontData : AcacTypes.hpp
  • FontFamily : AcacTypes.hpp
  • FONTPACK_ID : AcacTypes.hpp
  • FontPackData : AcacTypes.hpp
  • for() : ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp, ConvertToColorValue_Planes.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • ForAllPlanes : SetPixel_Planes.cpp, ScrollHorizontal_Planes.cpp, GetPixelColor_Planes.cpp, FillRect_Planes.cpp, DrawChar_Planes.cpp, BitBlit_Planes.cpp, Ddrv.cpp
  • format : Audio.cpp
  • ForwardingSsActionType : InputAction.hpp
  • FrameType : Control.hpp
  • FREQUENCY_BEGIN : FmRadioAudioPlayer.cpp
  • FriendFinder : LcsFeatTypes.hpp
  • FS_APPEND : FatSim.hpp
  • FS_assign_driveletter() : FatSim.hpp, FatSim.cpp
  • FS_BINARY : FatSim.hpp
  • FS_close() : FatSim.hpp, FatSim.cpp
  • FS_CREAT : FatSim.hpp
  • FS_deactivate() : FatSim.hpp, FatSim.cpp
  • FS_delete() : FatSim.hpp, FatSim.cpp
  • FS_device_notify() : FatSim.hpp, FatSim.cpp
  • fs_device_type : FatSim.hpp
  • FS_diskabort() : FatSim.hpp, FatSim.cpp
  • FS_diskclose() : FatSim.hpp, FatSim.cpp
  • FS_diskflush() : FatSim.hpp, FatSim.cpp
  • FS_diskinfo() : FatSim.hpp, FatSim.cpp
  • FS_diskopen() : FatSim.hpp, FatSim.cpp
  • fs_dstat_type : FatSim.hpp
  • FS_ERR_ACCES : FatSim.hpp
  • FS_ERR_BAD_FORMAT : FatSim.hpp
  • FS_ERR_BAD_MEDIA : FatSim.hpp
  • FS_ERR_BADF : FatSim.hpp
  • FS_ERR_DEVICE : FatSim.hpp
  • FS_ERR_ECC_ERROR : FatSim.hpp
  • FS_ERR_EXIST : FatSim.hpp
  • FS_ERR_FAULT : FatSim.hpp
  • FS_ERR_ID_ERROR : FatSim.hpp
  • FS_ERR_INVAL : FatSim.hpp
  • FS_ERR_IO : FatSim.hpp
  • FS_ERR_MEDIA_CHANGED : FatSim.hpp
  • FS_ERR_MEDIA_FAILURE : FatSim.hpp
  • FS_ERR_MFILE : FatSim.hpp
  • FS_ERR_NO_MEDIA : FatSim.hpp
  • FS_ERR_NOENT : FatSim.hpp
  • FS_ERR_NOSPC : FatSim.hpp
  • FS_ERR_OPERATION_NOT_POSSIBLE : FatSim.hpp
  • FS_ERR_SHARE : FatSim.hpp
  • FS_ERR_USER_ID_ERROR : FatSim.hpp
  • FS_EXCL : FatSim.hpp
  • FS_FAILURE : FatSim.hpp
  • fs_fd_type : FatSim.hpp
  • FS_FFS_DEVICE : FatSim.hpp
  • FS_finddone() : FatSim.hpp, FatSim.cpp
  • FS_findfirst() : FatSim.hpp, FatSim.cpp
  • FS_findnext() : FatSim.hpp, FatSim.cpp
  • FS_flush() : FatSim.hpp, FatSim.cpp
  • FS_format() : FatSim.hpp, FatSim.cpp
  • FS_free() : FatSim.hpp, FatSim.cpp
  • FS_FTL_DEVICE1 : FatSim.hpp
  • FS_get_attributes() : FatSim.hpp, FatSim.cpp
  • FS_get_default_device() : FatSim.hpp, FatSim.cpp
  • FS_get_file_length_streaming() : FatSim.hpp, FatSim.cpp
  • FS_get_file_pos_streaming() : FatSim.hpp, FatSim.cpp
  • FS_get_last_device_error() : FatSim.hpp, FatSim.cpp
  • FS_get_last_error() : FatSim.hpp, FatSim.cpp
  • FS_get_registered_devices() : FatSim.hpp, FatSim.cpp
  • FS_getcwd() : FatSim.hpp, FatSim.cpp
  • FS_init_rtos() : FatSim.hpp, FatSim.cpp
  • FS_INVALID_FILEHANDLE : FatSim.hpp
  • FS_IREAD : FatSim.hpp
  • FS_isdir() : FatSim.hpp, FatSim.cpp
  • FS_IWRITE : FatSim.hpp
  • FS_MAX_NO_OPEN_FILES : FatSim.hpp
  • FS_MAXPATH : FatSim.hpp
  • FS_mkdir() : FatSim.hpp, FatSim.cpp
  • FS_MMCSD_DEV : FatSim.hpp
  • FS_MS_AssignStatusNotificationFunction() : FatSim.hpp
  • FS_MS_connect : FatSim.hpp
  • FS_MS_disconnect : FatSim.hpp
  • FS_MS_StatusNotificationFunction_type : FatSim.hpp
  • FS_NOF_DEVICES : FatSim.hpp
  • FS_NOSHAREANY : FatSim.hpp
  • FS_NOSHAREWRITE : FatSim.hpp
  • FS_open() : FatSim.hpp, FatSim.cpp
  • FS_RDONLY : FatSim.hpp
  • FS_RDWR : FatSim.hpp
  • FS_read() : FatSim.hpp, FatSim.cpp
  • FS_read_max() : FatSim.hpp, FatSim.cpp
  • FS_read_streaming() : FatSim.hpp, FatSim.cpp
  • FS_register_media_status_notification() : FatSim.hpp, FatSim.cpp
  • FS_rename() : FatSim.hpp, FatSim.cpp
  • FS_rmdir() : FatSim.hpp, FatSim.cpp
  • FS_seek() : FatSim.hpp, FatSim.cpp
  • FS_SEEK_CUR : FatSim.hpp
  • FS_SEEK_END : FatSim.hpp
  • FS_SEEK_SET : FatSim.hpp
  • FS_set_attributes() : FatSim.hpp, FatSim.cpp
  • FS_set_default_device() : FatSim.hpp, FatSim.cpp
  • FS_set_file_pos_streaming() : FatSim.hpp, FatSim.cpp
  • FS_setcwd() : FatSim.hpp, FatSim.cpp
  • FS_stat() : FatSim.hpp, FatSim.cpp
  • fs_stat_type : FatSim.hpp
  • FS_SUCCESS : FatSim.hpp
  • FS_TEST_DEVICE1 : FatSim.hpp
  • FS_TEST_DEVICE2 : FatSim.hpp
  • FS_TEST_DEVICE3 : FatSim.hpp
  • FS_TEXT : FatSim.hpp
  • FS_TRUNC : FatSim.hpp
  • FS_truncate() : FatSim.hpp, FatSim.cpp
  • FS_write() : FatSim.hpp, FatSim.cpp
  • FS_write_streaming() : FatSim.hpp, FatSim.cpp
  • FS_WRONLY : FatSim.hpp
  • FsDeviceType : FatTypes.hpp
  • FsFatFfsDev : FatTypes.hpp
  • FSM_DEFINE_STATE() : ObexServerPort.cpp, ObexClientPort.cpp, ObexAbstractPort.cpp
  • FSM_STATE_ELSE() : ObexServerPort.cpp, ObexClientPort.cpp, ObexAbstractPort.cpp
  • FsMmcSdDev : FatTypes.hpp
  • FsNandDev : FatTypes.hpp
  • FtpAuthProviderPtr : FtpAuthProvider.hpp
  • FtpClientPtr : FtpClient.hpp
  • FtpConnectionType : FtpTypes.hpp
  • FtpDataConnectionType : FtpTypes.hpp
  • FtpDataServerSocketPtr : FtpDataServerSocket.hpp
  • FtpDataSocketPtr : FtpDataSocket.hpp
  • FtpInTransferPtr : FtpInTransfer.hpp
  • FtpOutTransferPtr : FtpOutTransfer.hpp
  • FTPSERVER : apoxi.features
  • FTPSERVER_DBG_OUT_RANGE : FtpTypes.hpp
  • FTPSERVER_DBG_OUT_RANGE_CMD : FtpTypes.hpp
  • FTPSERVER_DBG_OUT_RANGE_EXTENDED : FtpTypes.hpp
  • FTPSERVER_DBG_OUT_RANGE_REPLY : FtpTypes.hpp
  • FtpServerConfigPtr : FtpServerConfig.hpp
  • FtpServerPtr : FtpServer.hpp
  • FtpServerSocketPtr : FtpServerSocket.hpp
  • FtpServiceCommand : FtpTypes.hpp
  • FtpServiceCommandError : FtpTypes.hpp
  • FtpSocketPtr : FtpSocket.hpp
  • FtpTransferDirection : FtpTypes.hpp
  • FtpTransferError : FtpTypes.hpp
  • FtpTransferMode : FtpTypes.hpp
  • FtpTransferPtr : FtpTransfer.hpp
  • FtpTransferStructure : FtpTypes.hpp
  • FtpTransferType : FtpTypes.hpp
  • FullTchNeeded : SignalTypes.hpp
  • FUNCTION_TRACER_HPP : FunctionTracer.hpp
Generated on Wed Jan 25 02:31:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • G2ATraining : VrTypes.hpp
  • g_alarm_day : RealTimeClock.cpp
  • g_alarm_hour : RealTimeClock.cpp
  • g_alarm_minute : RealTimeClock.cpp
  • g_alarm_month : RealTimeClock.cpp
  • g_alarm_second : RealTimeClock.cpp
  • g_alarm_year : RealTimeClock.cpp
  • g_audio_callback : HostAudioDriver.cpp
  • g_AudioMutex : audio_private.cpp
  • g_check : HostAudioDriver.cpp
  • g_data_ptr : HostAudioDriver.cpp
  • g_defaultlookup : DataHandler.cpp
  • g_drm_cd_j1k_data : SampleImages.hpp, SampleImages.cpp
  • g_drm_cd_res2_data : SampleImages.hpp, SampleImages.cpp
  • g_drm_fl_res2_data : SampleImages.hpp, SampleImages.cpp
  • g_drv_id : HostAudioGatiServer.cpp, aud_drv.cpp
  • g_echo_mode : UdpServer.cpp
  • g_fcts_block_page : HeapVector.hpp, HeapVector.cpp
  • g_fcts_huge_page : HeapVector.hpp, HeapVector.cpp
  • g_fcts_var_page : HeapVector.hpp, HeapVector.cpp
  • g_handle : HostAudioGatiServer.cpp, HostAudioDriver.cpp
  • g_hevent : HostAudioDriver.cpp
  • g_hmap_file : HostAudioGatiServer.cpp, HostAudioDriver.cpp
  • g_local_addr : UdpServer.cpp
  • g_mail_editor : PhonebookApp.cpp, PbAdvAddEditEntry.cpp
  • g_mail_text : PhonebookApp.cpp, PbAdvAddEditEntry.cpp
  • g_mp3param : HostAudioDriver.cpp
  • g_mute : Audio.cpp
  • g_notifn_size : HostAudioDriver.cpp
  • g_offset_day : RealTimeClock.cpp
  • g_offset_hour : RealTimeClock.cpp
  • g_offset_minute : RealTimeClock.cpp
  • g_offset_month : RealTimeClock.cpp
  • g_offset_second : RealTimeClock.cpp
  • g_offset_year : RealTimeClock.cpp
  • g_pbuf : HostAudioGatiServer.cpp, HostAudioDriver.cpp
  • g_pcmparam : HostAudioDriver.cpp
  • g_priority : aud_drv.cpp, Audio.cpp
  • g_random_packets : UdpServer.cpp
  • g_recorded_size : HostAudioGatiServer.cpp, HostAudioDriver.cpp
  • g_rem_rec_len : HostAudioDriver.cpp
  • g_started : Audio.cpp
  • g_tone_data : Audio.cpp
  • g_tones : Audio.cpp
  • g_trace_socket : InternalTracer.cpp
  • g_tracing_initialized : InternalTracer.cpp
  • g_user_data : HostAudioDriver.cpp
  • g_vmparam : HostAudioDriver.cpp
  • GATIMANAGER_CONNECTIONS_MAX : GatiManager.hpp
  • GATIMANAGER_DATABASE_MAX : GatiManager.hpp
  • GATIMANAGER_PORT : GatiManager.hpp
  • GATIMANAGER_PORT_VAR : GatiManager.hpp
  • GciVolume : AtiConfig.hpp
  • gday : DrmRelXml.hpp
  • GDD : apoxi.features
  • GDD_LCD_UPDATE_CALLBACK : DefaultDisplay.cpp
  • GDDCameraFrameRate() : EmApoxiVideoUtils.cpp
  • GDDCameraImageFormatType() : EmApoxiVideoUtils.cpp
  • GDDVideoDataFormatType() : EmApoxiVideoUtils.cpp
  • GeneralBeep : SignalTypes.hpp
  • GenericAudioDevice_hpp : GenericAudioDevice.hpp
  • GenericType : DataItem.hpp
  • GenericTypeId : GenericObject.hpp
  • GenResultCode : SimTkTypes.hpp
  • GET_16BPP_COLOR_VALUE : Image.hpp
  • GET_HEAP_TABLE : HeapVector.hpp
  • get_ringbuffer() : RingBuffer.hpp, RingBuffer.cpp
  • get_sw_version() : SocketTestVersion.hpp, SocketTestVersion.cpp, ApbVersion.hpp, ApbVersion.cpp
  • get_sw_version_text() : SocketTestVersion.hpp, SocketTestVersion.cpp, ApbVersion.hpp, ApbVersion.cpp
  • GetAvailableHW() : MiscAudioDevice.cpp
  • GetBlockCount() : HeapVector.cpp
  • GetClirSetting() : AdcInterface.hpp, AdcInterface.cpp
  • GetContrastLimits() : Camera.cpp
  • GetCugSetting() : AdcInterface.hpp, AdcInterface.cpp
  • GetCurrentContext() : InternalTracer.cpp
  • GetCurrentFileInfoBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • GetCurrentFileInfoFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • GetDeviceId() : FatSim.cpp
  • GetEccWString() : EccProvider.cpp
  • GetGcd() : Fraction.cpp
  • GetGenericStatus() : SimAccessor.cpp
  • GetMp3Head() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • GetNvRamSize() : NvRam.hpp, NvRam.cpp
  • GetNvRamStartAddress() : NvRam.hpp, NvRam.cpp
  • GetOpenFilePos() : HostCoreFsSim.cpp
  • GetPlaybackState() : AudioPriorityManager.cpp
  • GetPowerStatus() : MiscAudioDevice.cpp
  • getrawbcdlength() : PhoneNumber.cpp
  • GetRawTpduStatus() : Tpdu.hpp
  • GetRegistrationState() : AdcInterface.hpp, AdcInterface.cpp
  • GetSimIconDescription() : SimTkHandler.cpp
  • GetSimImage() : SimTkHandler.cpp
  • GetSimRegistrationMask() : PowerHandler.cpp
  • GetStoredCameraBuffer() : CameraCaptureWin.cpp, StillCamera.cpp
  • GetStringLen() : OsStrLib.hpp, OsStrLib.cpp
  • GetSurvivorRef() : AudioPriorityManager.cpp
  • GetUsimPbAddTypeName() : UsimPbTypes.hpp, UsimPbTypes.cpp
  • GetUsimPbLinkTypeName() : UsimPbTypes.hpp, UsimPbTypes.cpp
  • GetUsimPbRefTypeName() : UsimPbTypes.hpp, UsimPbTypes.cpp
  • GetWStringLen() : OsStrLib.hpp, OsStrLib.cpp
  • GIF_APP_EXT : GifDecoder.cpp
  • GIF_COLOR_TABLE_SIZE : GifDecoder.cpp
  • GIF_COMMENT_EXT : GifDecoder.cpp
  • GIF_EXTENSION : GifDecoder.cpp
  • GIF_GCE_SIZE : GifDecoder.cpp
  • GIF_GRAPHIC_EXT : GifDecoder.cpp
  • GIF_HEADER_SIZE : GifDecoder.cpp
  • GIF_ID_SIZE : GifDecoder.cpp
  • gif_image : SampleImages.hpp, SampleImages.cpp
  • GIF_IMAGE_DESC : GifDecoder.cpp
  • gif_image_size : SampleImages.hpp
  • GIF_LSD_SIZE : GifDecoder.cpp
  • GIF_TEXT_EXT : GifDecoder.cpp
  • GIF_TRAILER : GifDecoder.cpp
  • GLOBAL : LwipSysSocket.cpp, WinInc.hpp, Thread.cpp, Nuc32.cpp
  • GLTP : LcsTypes.hpp
  • GltpConnStatus : GltpTypes.hpp
  • GlyphData : AcacTypes.hpp
  • GlyphHeaderPtr : Font.hpp
  • GlyphIndexTabPtr : Font.hpp
  • GlyphPtr : Font.hpp
  • GlyphTab : Font.hpp
  • gmonth : DrmRelXml.hpp
  • GPP : LcsTypes.hpp
  • GprsClass : NetworkTypes.hpp
  • GprsClassA : NetworkTypes.hpp
  • GprsClassB : NetworkTypes.hpp
  • GprsClassC : NetworkTypes.hpp
  • GprsClassCc : NetworkTypes.hpp
  • GprsClassCg : NetworkTypes.hpp
  • GprsGsmNotAllowed : SignalTypes.hpp
  • GprsNoClass : NetworkTypes.hpp
  • GprsNotAllowed : SignalTypes.hpp
  • GprsPlmnNotAllowed : SignalTypes.hpp
  • GpsReceiver : LcsFeatTypes.hpp
  • gr_Action_in_contradiction_with_current_timer : SimTkTypes.hpp
  • gr_Backward_move_requested_by_user : SimTkTypes.hpp
  • gr_Bearer_independent_protocol_error : SimTkTypes.hpp
  • gr_Command_beyond_ME_capabilities : SimTkTypes.hpp
  • gr_Command_data_not_understood_by_ME : SimTkTypes.hpp
  • gr_Command_number_not_known_by_ME : SimTkTypes.hpp
  • gr_Command_performed_but_modified_by_SIM : SimTkTypes.hpp
  • gr_Command_performed_successfully : SimTkTypes.hpp
  • gr_Command_performed_successfully_but_icon_not_disp : SimTkTypes.hpp
  • gr_Command_performed_successfully_but_limited_service : SimTkTypes.hpp
  • gr_Command_performed_with_missing_information : SimTkTypes.hpp
  • gr_Command_performed_with_modification : SimTkTypes.hpp
  • gr_Command_performed_with_partial_comprehension : SimTkTypes.hpp
  • gr_Command_type_not_understood_by_ME : SimTkTypes.hpp
  • gr_Error_required_values_missing : SimTkTypes.hpp
  • gr_Help_information_required_by_user : SimTkTypes.hpp
  • gr_Interaction_with_SIM_permanent_problem : SimTkTypes.hpp
  • gr_Interaction_with_SIM_temporary_problem : SimTkTypes.hpp
  • gr_Launch_browser_generic_error : SimTkTypes.hpp
  • gr_ME_currently_unable : SimTkTypes.hpp
  • gr_MultipleCard_error : SimTkTypes.hpp
  • gr_Network_currently_unable : SimTkTypes.hpp
  • gr_No_response_from_user : SimTkTypes.hpp
  • gr_Proactive_SIM_Session_terminated_by_user : SimTkTypes.hpp
  • gr_Refresh_performed_with_add_EFs_read : SimTkTypes.hpp
  • gr_SMS_rp_error : SimTkTypes.hpp
  • gr_SS_return_error : SimTkTypes.hpp
  • gr_ss_transaction_terminated_by_user : SimTkTypes.hpp
  • gr_User_cleared_call_before_network_release : SimTkTypes.hpp
  • gr_User_did_not_accept_proactive_command : SimTkTypes.hpp
  • gr_USSD_error : SimTkTypes.hpp
  • GraphicsDfPos : SimTkTypes.hpp
  • green_exp_2 : ConvertToColorValue_Planes.cpp
  • Gsm : NetworkTypes.hpp
  • Gsm1800 : NetworkTypes.hpp
  • Gsm1800_1900 : NetworkTypes.hpp
  • Gsm1900 : NetworkTypes.hpp
  • Gsm900 : NetworkTypes.hpp
  • Gsm900_1800 : NetworkTypes.hpp
  • Gsm900_1800_1900 : NetworkTypes.hpp
  • Gsm900_1900 : NetworkTypes.hpp
  • GsmAuthUnacceptable : SignalTypes.hpp
  • GsmBand : NetworkTypes.hpp
  • GsmBand1800 : NetworkTypes.hpp
  • GsmBand1900 : NetworkTypes.hpp
  • GsmBand450 : NetworkTypes.hpp
  • GsmBand480 : NetworkTypes.hpp
  • GsmBand850 : NetworkTypes.hpp
  • GsmBand900 : NetworkTypes.hpp
  • GsmBand900E : NetworkTypes.hpp
  • GsmBand900P : NetworkTypes.hpp
  • GsmBand900R : NetworkTypes.hpp
  • GsmErrorCause : SignalTypes.hpp
  • GsmInternalCodingAt : DataCoding.hpp
  • GsmMultiband : NetworkTypes.hpp
  • GsmNoCause : SignalTypes.hpp
  • GsmService : NetworkTypes.hpp
  • GsmSignal : SignalTypes.hpp
  • GsmSignalQualityMax : SignalTypes.hpp
  • GsmSignalStrengthMax : SignalTypes.hpp
  • GTL : apoxi.features
  • Gui_Lib_hpp : Lib.hpp
  • Guid_NoGuid : Service.hpp, Service.cpp
  • GuiExtensions_InputMapperFactory_hpp : InputMapperFactory.hpp
  • GuiTracer : Trace.hpp
  • GuiTracerLevel2 : Trace.hpp
  • GuiTracerLevel3 : Trace.hpp
  • gyear : DrmRelXml.hpp
Generated on Wed Jan 25 02:31:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- h -

  • HalfTchData : SignalTypes.hpp
  • HalfTchSpeech : SignalTypes.hpp
  • HandlerId : HandlerId.hpp
  • HandlerList : HandlerList.hpp
  • Handover : NetworkTypes.hpp
  • HARDWARE_ENCODER_IS_USED : StillCamera.cpp
  • HashKey : HashTable.hpp
  • HashTable_Create() : hash.cpp
  • HashTable_Destroy() : hash.cpp
  • HashTable_Enumerate() : hash.cpp
  • HashTable_Insert() : hash.cpp
  • HashTable_Lookup() : hash.cpp
  • HashTable_Remove() : hash.cpp
  • HashToken : InputParser.hpp
  • HcsCriteriaPrio : NetworkTypes.hpp
  • HcsHValue : NetworkTypes.hpp
  • hdl : Audio.cpp
  • HEAP_BYTES_PER_UINT : HeapVector.hpp
  • HEAP_CONTEXT_VECTOR_PTR : HeapVector.hpp
  • HEAP_DATASINK_CLOSED : HeapDataSink.cpp
  • HEAP_DATASINK_INIT : HeapDataSink.cpp
  • HEAP_DATASINK_OPENED : HeapDataSink.cpp
  • HEAP_ENTRY : HeapVector.hpp
  • HEAP_SIZE_VECTOR_PTR : HeapVector.hpp
  • HEAP_STAT_STRUCT_VALUES : HeapVector.hpp
  • HEAP_TABLE_BEGIN : HeapVector.hpp
  • HEAP_TABLE_END : HeapVector.hpp
  • HeapDataSinkPtr : HeapDataSource.hpp, HeapDataSink.hpp
  • HeapDataSourcePtr : HeapDataSource.hpp
  • HeldCallDetected : Types.hpp
  • HeldCallRequired : Types.hpp
  • HelloAckRxed : GltpTypes.hpp
  • HelpInfo : SimTkTypes.hpp
  • HexToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • HF_DEVICE_FEATURES : BtHfAppPlugin.hpp
  • HF_INBAND_SETTING : BtHfAppPlugin.hpp
  • HF_SETTINGS : BtHfProfileWindows.cpp
  • High : LcsTypes.hpp
  • Hold : SignalTypes.hpp
  • HoldActiveCall : SignalTypes.hpp
  • HoldIndicator : SignalTypes.hpp
  • HoldMparty : SignalTypes.hpp
  • HoldRequestRejected : Types.hpp
  • Home : PbTypes.hpp
  • HomezoneIndicator : NetworkTypes.hpp
  • Horizontal : Grid.hpp
  • HostDirectoryIteratorMap : FatSim.cpp
  • HostFatFsDeviceDescMap : FatSim.hpp
  • HostFatFsDeviceDescMapPtr : FatSim.hpp
  • HostFfsIterMap : FfsSim.cpp
  • HostInitFatFsStorageDevices() : FatSim.hpp, FatSim.cpp
  • Hplmn_search_fail : NetworkTypes.hpp
  • HplmnWact : SimTkTypes.hpp
  • HttpAuthProviderPtr : HttpAuthProvider.hpp
  • HttpClientPtr : HttpClient.hpp
  • HttpRequestHeaders : HttpRequest.hpp
  • HttpResponseCode : HttpTypes.hpp
  • HttpResponseHeaders : HttpResponse.hpp
  • HTTPSERVER : apoxi.features
  • HTTPSERVER_ASCII_AMP : HttpTypes.hpp
  • HTTPSERVER_ASCII_CR : HttpTypes.hpp
  • HTTPSERVER_ASCII_DOT : HttpTypes.hpp
  • HTTPSERVER_ASCII_EQU : HttpTypes.hpp
  • HTTPSERVER_ASCII_LF : HttpTypes.hpp
  • HTTPSERVER_ASCII_PER : HttpTypes.hpp
  • HTTPSERVER_ASCII_PL : HttpTypes.hpp
  • HTTPSERVER_ASCII_QM : HttpTypes.hpp
  • HTTPSERVER_ASCII_SL : HttpTypes.hpp
  • HTTPSERVER_ASCII_SP : HttpTypes.hpp
  • HTTPSERVER_DBG_OUT_RANGE : HttpTypes.hpp
  • HttpServerConfigPtr : HttpServerConfig.hpp
  • HttpServerPtr : HttpServer.hpp
  • HttpServerSocketPtr : HttpServerSocket.hpp
  • HttpServiceCommand : HttpTypes.hpp
  • HttpServiceCommandError : HttpTypes.hpp
  • HttpSocketPtr : HttpSocket.hpp
  • HTTPWAPINTERFACE : apoxi.features
  • huge : aud_drv.cpp, FatSim.hpp
  • HUGE_HEAP_PAGE : HeapVector.hpp
  • HugeVarPageTest() : HeapManager.cpp
  • HWTRC_APOXI_END : InternalTracer.cpp
  • HWTRC_APOXI_START : InternalTracer.cpp
  • HWTRC_ESCAPE : InternalTracer.cpp
  • HWTRC_INTRO_CHAR : InternalTracer.cpp
  • hwtrc_putchars() : InternalTracer.cpp
  • hwtrc_send_apoxi_msg() : InternalTracer.cpp
Generated on Wed Jan 25 02:31:16 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • i : SetPixel_Planes.cpp, ScrollVertical_Planes.cpp, GetPixelColor_Planes.cpp, FillRect_Planes.cpp, DrawChar_Planes.cpp, BitBlit_Planes.cpp
  • I1_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • I2_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • i_atom : SetPixel_Planes.cpp, GetPixelColor_Planes.cpp
  • i_bit : SetPixel_Planes.cpp, GetPixelColor_Planes.cpp
  • i_dest : ScrollHorizontal_Planes.cpp
  • i_left : FillRect_Planes.cpp
  • i_right : ScrollVertical_Planes.cpp, FillRect_Planes.cpp
  • i_src : ScrollHorizontal_Planes.cpp
  • i_start_dest : ScrollHorizontal_Planes.cpp
  • i_start_src : ScrollHorizontal_Planes.cpp
  • i_stodest_atom : ScrollHorizontal_Planes.cpp
  • i_stosrc_atom : ScrollHorizontal_Planes.cpp
  • ICON_URI_STR : DrmDcfParser.hpp
  • IeMissing : SignalTypes.hpp
  • if() : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_Planes.cpp, FillRect_16Bpp.cpp, BitBlit_Planes.cpp, BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp
  • IllegalMe : SignalTypes.hpp
  • IllegalMs : SignalTypes.hpp
  • IMAGE_BUFFER_NOT_USED : StillCamera.cpp
  • IMAGE_CAPTURED_OK : StillCamera.hpp
  • IMAGE_ENCODED_OK : StillCamera.hpp
  • IMAGE_ITEM_HEIGHT : ImageView.hpp
  • ImeiNotAccepted : SignalTypes.hpp
  • ImeiShowActionType : InputAction.hpp
  • IMGBRVERSION : ImgbrVersion.hpp
  • ImgbrVersion_hpp : ImgbrVersion.hpp
  • Imm_ass_reject : NetworkTypes.hpp
  • ImpDetached : SignalTypes.hpp
  • ImsiEfPos : SimTkTypes.hpp
  • ImsiUnknownInHlr : SignalTypes.hpp
  • ImsiUnknownInVlr : SignalTypes.hpp
  • InBandTonesAvailable : SignalTypes.hpp
  • InBandTonesNotAvailable : SignalTypes.hpp
  • IncomingCallsBarredInCug : SignalTypes.hpp
  • IncommingRefuseDirection : SignalTypes.hpp
  • IncompatibleDestination : SignalTypes.hpp
  • InContradictionWithChvStatus : SignalTypes.hpp
  • index : VCard.cpp
  • IndicatorBarID : IndicatorBarID.hpp
  • IndicatorID : IndicatorID.hpp
  • IndicatorItem_hpp : ValueItem.hpp
  • InfElemNotExists : SignalTypes.hpp
  • info_tone_connection_data : Audio.cpp
  • info_tone_device_in_data : Audio.cpp
  • info_tone_device_out_data : Audio.cpp
  • info_tone_disconnect_data : Audio.cpp
  • info_tone_free_data : Audio.cpp
  • info_tone_low_bat_data : Audio.cpp
  • info_tone_msg_full_data : Audio.cpp
  • info_tone_power_off_data : Audio.cpp
  • info_tone_power_on_data : Audio.cpp
  • info_tone_ussd_data : Audio.cpp
  • InfoElementTestSuite() : InformationElement.hpp, InformationElement.cpp
  • InitialLocation : LcsTypes.hpp
  • InitShmemEvent() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • INPUT_BUF_SIZE : Zi8Wrapper.hpp, JpegDecoder.cpp
  • INPUT_BYTE : GifDecoder.cpp, BmpDecoder.cpp
  • InputActionType : InputAction.hpp
  • InputAnalyzerTest() : InputAction.hpp, InputAction.cpp
  • InputMapperVector : EditConfig.hpp
  • InsertPlmnAction : SignalTypes.hpp
  • INSTRUMENT_NO : TestWriter.cpp
  • INT : WinInc.hpp, NucInc.hpp
  • INT16 : WinInc.hpp, NucInc.hpp
  • INT32 : WinInc.hpp, NucInc.hpp
  • Int32ToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • INT8 : WinInc.hpp, NucInc.hpp
  • InteractionWithCallControlBySimTemporaryProblem : SimTkTypes.hpp
  • InterceptToneon : SignalTypes.hpp
  • Internal_change_dir() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_close() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_copy() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_delete() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_exists() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_filename_to_full_path() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_finddone() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_findfirst() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_findnext() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_format_device() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_get_attributes() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_get_cwd() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_get_file_info() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_get_test_path() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_is_dir() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_make_dir() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_open() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_read() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_remove_dir() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_rename() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_seek() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_set_attributes() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • INTERNAL_TRACER_HPP : InternalTracer.hpp
  • Internal_truncate() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_write() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • InternalCallStackAdr() : InternalTracer.cpp
  • internalMsg : MsgCategory.hpp
  • INTERNATIONALIZATION : apoxi.features
  • InterrogateSsChoice : SignalTypes.hpp
  • Interworking : SignalTypes.hpp
  • IntToBcdByte() : ValidityPeriod.hpp
  • IntToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • INVALID_GLYPH_UNICODE : AcacTypes.hpp
  • INVALID_PCFD : FatSim.hpp
  • Invalid_plmn : NetworkTypes.hpp
  • Invalid_reg_state : NetworkTypes.hpp
  • InvalidAcm : SignalTypes.hpp
  • InvalidActionType : InputAction.hpp
  • InvalidAlsLine : SignalTypes.hpp
  • InvalidBasicService : Types.hpp
  • InvalidBcdMcc : NetworkTypes.hpp
  • InvalidBcdMnc : NetworkTypes.hpp
  • InvalidBcdPlmn : NetworkTypes.hpp
  • InvalidCallIndex : Types.hpp
  • InvalidCallRelatedSs : SignalTypes.hpp
  • InvalidCallRelatedSsState : SignalTypes.hpp
  • InvalidCcpData : SignalTypes.hpp
  • InvalidCellId : NetworkTypes.hpp
  • InvalidChargingStatus : SignalTypes.hpp
  • InvalidEccArray : SignalTypes.hpp
  • InvalidEntry : HostAudioDriver.hpp
  • InvalidExtLanguage : SignalTypes.hpp
  • InvalidExtLanguageVal : SignalTypes.hpp
  • InvalidGprsClass : NetworkTypes.hpp
  • InvalidGsmBand : NetworkTypes.hpp
  • InvalidGsmService : NetworkTypes.hpp
  • InvalidImei : SignalTypes.hpp
  • InvalidLac : NetworkTypes.hpp
  • InvalidLanguage : SignalTypes.hpp
  • InvalidLine : SignalTypes.hpp
  • InvalidMandatoryInformation : SignalTypes.hpp
  • InvalidMcc : NetworkTypes.hpp
  • InvalidMmiServiceGroup : Types.hpp
  • InvalidMmRrReason : NetworkTypes.hpp
  • InvalidMnc : NetworkTypes.hpp
  • InvalidMptyMemberCount : Types.hpp
  • InvalidNumberFormat : SignalTypes.hpp
  • InvalidOpMode : NetworkTypes.hpp
  • InvalidParam : SignalTypes.hpp
  • InvalidPhoneBook : AtcTypes.hpp
  • InvalidPhoneBookCnt : SignalTypes.hpp
  • InvalidPhoneNumber : Types.hpp
  • InvalidPlmn : NetworkTypes.hpp
  • InvalidPriority : Types.hpp
  • InvalidProperty : VrTypes.hpp
  • InvalidPuct : SignalTypes.hpp
  • InvalidRatChangeMode : NetworkTypes.hpp
  • InvalidSearchMode : NetworkTypes.hpp
  • InvalidServiceCode : Types.hpp
  • InvalidSignalQualityLevel : SignalTypes.hpp
  • InvalidSignalStrengthLevel : SignalTypes.hpp
  • InvalidSimServiceTable : SignalTypes.hpp
  • InvalidSms : SimPduHandler.hpp
  • InvalidSmsPortNo : InformationElement.hpp
  • InvalidSpn : SignalTypes.hpp
  • InvalidTi : SignalTypes.hpp
  • InvalidTimeOut : Types.hpp
  • InvalidTimer : LcsTimer.hpp
  • InvalidTipd : Types.hpp
  • InvalidToken : InputParser.hpp
  • InvalidTransitNetwork : SignalTypes.hpp
  • InvManIe : SignalTypes.hpp
  • InvokeCallDeflection : SignalTypes.hpp
  • InvScanEfPos : SimTkTypes.hpp
  • IRDA : apoxi.features
  • IRDA_DBG_OUT : IrdaObexImpl.cpp
  • IrdaAppVersion_hpp : IrdaAppVersion.hpp
  • IRDAVERSION : IrdaAppVersion.hpp
  • Is7BitChar() : AlphaCoding.cpp
  • IsBDigit() : StrPrintf.cpp
  • IsDDigit() : StrPrintf.cpp
  • IsDownlinkConnected() : TchInterface.cpp
  • IsEct : SignalTypes.hpp
  • ISFATAL : parsifal.cpp
  • IsFree() : HeapVector.cpp
  • ISILLchar : parsifal.cpp
  • IsInFieldRange : Wsscanf.cpp
  • isleap() : RealTimeClock.cpp
  • ISMAPCH : parsifal.cpp
  • IsMinusSign() : StrPrintf.cpp
  • ISNULLSTR : parsifal.cpp
  • IsOdd : BidiManager.cpp
  • IsODigit() : StrPrintf.cpp
  • IsolatedWordRecognition : VrTypes.hpp
  • IsPlusSign() : StrPrintf.cpp
  • ISQNAME : parsifal.cpp
  • ISQUOTE : parsifal.cpp
  • IsRedialingActive() : AdcInterface.hpp, AdcInterface.cpp
  • IsRightToLeftCharacter : BidiManager.cpp
  • IsSign() : StrPrintf.cpp
  • IsSimMemoryError() : SignalTypes.hpp
  • IsSimSecretCodeLockedError() : SignalTypes.hpp
  • IsSimSecurityError() : SignalTypes.hpp
  • IsSimTechnicalProblemWithNoDiagnosticError() : SignalTypes.hpp
  • isspace : parsifal.cpp
  • IsTchConnected() : TchInterface.cpp
  • IsTpduSentStatus() : Tpdu.hpp
  • IsUnused() : HeapVector.cpp
  • IsUplinkConnected() : TchInterface.cpp
  • IsValidCriteria() : SimPduHandler.cpp
  • IsWbDigit() : WStrUtil.hpp, WStrUtil.cpp
  • IsWdDigit() : WStrUtil.hpp, WStrUtil.cpp
  • IsWhiteSpace() : StrPrintf.cpp
  • ISWHITESPACE : parsifal.cpp
  • IsWminusSign() : WStrUtil.hpp, WStrUtil.cpp
  • IsWoDigit() : WStrUtil.hpp, WStrUtil.cpp
  • IsWplusSign() : WStrUtil.hpp, WStrUtil.cpp
  • IsWsign() : WStrUtil.hpp, WStrUtil.cpp
  • IsWwhiteSpace() : WStrUtil.hpp, WStrUtil.cpp
  • IsWxDigit() : WStrUtil.hpp, WStrUtil.cpp
  • IsXDigit() : StrPrintf.cpp
  • ISXMLNSPREFIX : parsifal.cpp
  • ISXMLPREFIX : parsifal.cpp
  • IToW() : WStrUtil.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • p : SetPixel_8Bpp.cpp, SetPixel_32Bpp.cpp, SetPixel_24Bpp.cpp, SetPixel_16Bpp.cpp, ScrollHorizontal_Planes.cpp, GetPixelColor_8Bpp.cpp, GetPixelColor_32Bpp.cpp, GetPixelColor_24Bpp.cpp, GetPixelColor_16Bpp.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, FillRect_16Bpp.cpp, DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp, FillRect_16Bpp.cpp, DrawChar_16Bpp.cpp
  • PacketSwitched : NetworkTypes.hpp
  • PacketSwitchedPreferred : NetworkTypes.hpp
  • PadAccessCa1200_75Bps : SignalTypes.hpp
  • PadAccessCa1200Bps : SignalTypes.hpp
  • PadAccessCa2400Bps : SignalTypes.hpp
  • PadAccessCa300Bps : SignalTypes.hpp
  • PadAccessCa4800Bps : SignalTypes.hpp
  • PadAccessCa9600Bps : SignalTypes.hpp
  • PADDING_STR : DrmDcfParser.hpp
  • PAGE_ENTRY : HeapVector.hpp
  • PAGE_TABLE_BEGIN : HeapVector.hpp
  • PAGE_TABLE_END : HeapVector.hpp
  • ParityEven : LcsTypes.hpp
  • ParityNone : LcsTypes.hpp
  • ParityOdd : LcsTypes.hpp
  • PartlyConcatenetedSms : SimPduHandler.hpp
  • PasswordChangeSsActionType : InputAction.hpp
  • PB_AAS_DATA : UsimPbTypes.hpp
  • PB_ANR_REF : UsimPbTypes.hpp
  • PB_APPL : UsimPbTypes.hpp
  • PB_BUFFER_IS_NULL : UsimPbTypes.hpp
  • PB_BUFFER_TO_SMALL : UsimPbTypes.hpp
  • PB_CCP1_DATA : UsimPbTypes.hpp
  • PB_CLIENT_FLAG_AUTOLOAD : UsimPbTypes.hpp
  • PB_DATA_TYPE_MISMATCH : UsimPbTypes.hpp
  • PB_EMAIL_REF : UsimPbTypes.hpp
  • PB_EXT1_DATA : UsimPbTypes.hpp
  • PB_GAS_DATA : UsimPbTypes.hpp
  • PB_GLOBAL : UsimPbTypes.hpp
  • PB_INDICATION : UsimPbTypes.hpp
  • PB_LINK_TYPE_1 : UsimPbTypes.hpp
  • PB_LINK_TYPE_2 : UsimPbTypes.hpp
  • PB_LINK_TYPE_3 : UsimPbTypes.hpp
  • PB_MAX_FILE_TYPE_ENTITY : UsimPbTypes.hpp
  • PB_MAX_GROUP : UsimPbTypes.hpp
  • PB_MAX_SLICE : UsimPbTypes.hpp
  • PB_NO_FREE_RECORD : UsimPbTypes.hpp
  • PB_NOT_EXIST : UsimPbTypes.hpp
  • PB_NOT_LOADED : UsimPbTypes.hpp
  • PB_NOT_LOCATED : UsimPbTypes.hpp
  • PB_NOT_SEL : UsimPbTypes.hpp
  • PB_NOT_SELECTED : UsimPbTypes.hpp
  • PB_REF_REFRESH : UsimPbTypes.hpp
  • PB_REFRESH : UsimPbTypes.hpp
  • PB_RESPONSE : UsimPbTypes.hpp
  • PB_RESULT : UsimPbTypes.hpp
  • PB_SIM : UsimPbTypes.hpp
  • PB_SKIPPED : UsimPbTypes.hpp
  • PB_SNE_REF : UsimPbTypes.hpp
  • PB_SUCCESSFUL : UsimPbTypes.hpp
  • PB_SUCCESSFUL_UID : UsimPbTypes.hpp
  • PB_TECHNICAL_PROBLEM : UsimPbTypes.hpp
  • PB_TO_FEW_FREE_EXT : UsimPbTypes.hpp
  • PB_WRONG_DATA_TYPE : UsimPbTypes.hpp
  • PB_WRONG_HANDLE : UsimPbTypes.hpp
  • PB_WRONG_LOCATION : UsimPbTypes.hpp
  • PB_WRONG_REC_NUMBER : UsimPbTypes.hpp
  • PB_WRONG_REF_REC : UsimPbTypes.hpp
  • PB_WRONG_STRUCTURE : UsimPbTypes.hpp
  • PbEntryShowActionType : InputAction.hpp
  • PbRequestAutomatic : SignalTypes.hpp
  • PbRequestBehaviour : SignalTypes.hpp
  • PbRequestEmpty : SignalTypes.hpp
  • PbRequestMMI : SignalTypes.hpp
  • PCFD : FatSim.hpp
  • PchClient : PdpTypes.hpp
  • PchMs : PdpTypes.hpp
  • PchNw : PdpTypes.hpp
  • PchOrigin : PdpTypes.hpp
  • PCM_FILEPLAY_FRAMENUM : HostAudioDriver.hpp
  • PCM_FILEREC_FRAMENUM : HostAudioDriver.hpp
  • PcmPlayCallBack : HostAudioDriver.hpp
  • PcmRecCallBack : HostAudioDriver.hpp
  • PcmRetCode : HostAudioDriver.hpp
  • PdpAddress : PdpTypes.hpp
  • PdpArray : PdpTypes.hpp
  • PdpAttachState : PdpTypes.hpp
  • PdpAuthentification : PdpTypes.hpp
  • PdpCid : PdpTypes.hpp
  • PdpCidArray : PdpTypes.hpp
  • PdpCidStatArray : PdpTypes.hpp
  • PdpContextData : PdpTypes.hpp
  • PdpIpDynamicType : PdpTypes.hpp
  • PdpIpStaticType : PdpTypes.hpp
  • PdpIpType : PdpTypes.hpp
  • PdpNoType : PdpTypes.hpp
  • PdpOspihType : PdpTypes.hpp
  • PdpPacketFilterPtr : PsdDataConnProfile.hpp
  • PdpPppType : PdpTypes.hpp
  • PdpQos : PdpTypes.hpp
  • PdpQosArray : PdpTypes.hpp
  • PdpType : PdpTypes.hpp
  • PdpX25Type : PdpTypes.hpp
  • PEACCES : FatSim.hpp
  • PEBADF : FatSim.hpp
  • PEDEVICE : FatSim.hpp
  • PEEXIST : FatSim.hpp
  • PEFAULT : FatSim.hpp
  • PEINVAL : FatSim.hpp
  • PEIO : FatSim.hpp
  • PEMFILE : FatSim.hpp
  • Pending : LcsReqProcessor.hpp
  • PendingSimtkSetup : SignalTypes.hpp
  • PENOENT : FatSim.hpp
  • PENOSPC : FatSim.hpp
  • PenStyle : Pen.hpp
  • percent2native() : audio_private.hpp, audio_private.cpp
  • Permanent : SignalTypes.hpp
  • PermissionDenied : LcsDecls.hpp
  • PermissionGranted : LcsDecls.hpp
  • PESHARE : FatSim.hpp
  • PESUCCESS : FatSim.hpp
  • PhaseEfPos : SimTkTypes.hpp
  • PHONE_NUMBER_RESET : PhoneNumber.cpp
  • PhoneBookCntType : SignalTypes.hpp
  • PhoneBookRefresh : SignalTypes.hpp
  • PhoneBookType : SignalTypes.hpp
  • PhonebookWin_hpp : PhonebookWin.hpp
  • PhoneNoType : PbTypes.hpp
  • PhoneNumberAssignmentTest() : PhoneNumber.cpp
  • PhoneNumberConstructorTest() : PhoneNumber.cpp
  • PhoneNumberPersistentTest() : PhoneNumber.cpp
  • PhoneNumberTest() : PhoneNumber.hpp, PhoneNumber.cpp
  • PhoneNumberType : DataItem.hpp
  • PinActionType : InputAction.hpp
  • PlayAmr : HostAudioDriver.hpp
  • PlayAmrCallback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayAmrStreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • Playback_Finish : HostAudioDriver.hpp
  • Playback_Stopped : HostAudioDriver.hpp
  • PlayDtmf() : Audio.cpp
  • PlayerData : MediaPlayer.cpp
  • PlayMp3 : HostAudioDriver.hpp
  • PlayMp3Callback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayMp3StreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayPcm : HostAudioDriver.hpp
  • PlayPcmCallback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayPcmStreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayTone() : Audio.cpp
  • PlmnEfPos : SimTkTypes.hpp
  • PlmnForbidden : NetworkTypes.hpp
  • PlmnForbiddenIndicator : NetworkTypes.hpp
  • PlmnHandlerId : HandlerId.hpp
  • PlmnIndicator : NetworkTypes.hpp
  • PlmnListScan : NetworkTypes.hpp
  • PlmnNotAllowed : SignalTypes.hpp
  • PlmnNotForbidden : NetworkTypes.hpp
  • PlmnNotProvided : NetworkTypes.hpp
  • PlmnPlacementIndicator : NetworkTypes.hpp
  • PlmnProvided : NetworkTypes.hpp
  • PlmnRefresh : SignalTypes.hpp
  • PlmnScanList : PlmnScanList.hpp
  • PlmnScanMode : NetworkTypes.hpp
  • PlmnScanOff : NetworkTypes.hpp
  • PlmnSpecificBs1 : SignalTypes.hpp
  • PlmnSpecificBs2 : SignalTypes.hpp
  • PlmnSpecificBs3 : SignalTypes.hpp
  • PlmnSpecificBs4 : SignalTypes.hpp
  • PlmnSpecificBs5 : SignalTypes.hpp
  • PlmnSpecificBs6 : SignalTypes.hpp
  • PlmnSpecificBs7 : SignalTypes.hpp
  • PlmnSpecificBs8 : SignalTypes.hpp
  • PlmnSpecificBs9 : SignalTypes.hpp
  • PlmnSpecificBsA : SignalTypes.hpp
  • PlmnSpecificBsB : SignalTypes.hpp
  • PlmnSpecificBsC : SignalTypes.hpp
  • PlmnSpecificBsD : SignalTypes.hpp
  • PlmnSpecificBsE : SignalTypes.hpp
  • PlmnSpecificBsF : SignalTypes.hpp
  • PlmnSpecificTs1 : SignalTypes.hpp
  • PlmnSpecificTs2 : SignalTypes.hpp
  • PlmnSpecificTs3 : SignalTypes.hpp
  • PlmnSpecificTs4 : SignalTypes.hpp
  • PlmnSpecificTs5 : SignalTypes.hpp
  • PlmnSpecificTs6 : SignalTypes.hpp
  • PlmnSpecificTs7 : SignalTypes.hpp
  • PlmnSpecificTs8 : SignalTypes.hpp
  • PlmnSpecificTs9 : SignalTypes.hpp
  • PlmnSpecificTsA : SignalTypes.hpp
  • PlmnSpecificTsB : SignalTypes.hpp
  • PlmnSpecificTsC : SignalTypes.hpp
  • PlmnSpecificTsD : SignalTypes.hpp
  • PlmnSpecificTsE : SignalTypes.hpp
  • PlmnSpecificTsF : SignalTypes.hpp
  • PlmnUpdateType : SignalTypes.hpp
  • PlmnWactEfPos : SimTkTypes.hpp
  • PNG_ENCODER : apoxi.features
  • png_image : SampleImages.hpp, SampleImages.cpp
  • png_image_size : SampleImages.hpp
  • PNG_SIGNATURE_SIZE : PngDecoder.cpp
  • PO_APPEND : FatSim.hpp
  • PO_BINARY : FatSim.hpp
  • PO_CREAT : FatSim.hpp
  • PO_EXCL : FatSim.hpp
  • PO_NOSHAREANY : FatSim.hpp
  • PO_NOSHAREWRITE : FatSim.hpp
  • PO_RDONLY : FatSim.hpp
  • PO_RDWR : FatSim.hpp
  • PO_TEXT : FatSim.hpp
  • PO_TRUNC : FatSim.hpp
  • PO_WRONLY : FatSim.hpp
  • PositionDataReceived : GltpTypes.hpp
  • PositiveAckTone : SignalTypes.hpp
  • PostMtcConfIndArg() : CallMiscSignalProcessor.cpp
  • PostMtcSetupIndArg() : CallMiscSignalProcessor.cpp
  • POWER_SAVING_RELEASE : apoxi.features
  • PowerHandlerId : HandlerId.hpp
  • PowerMode : SignalTypes.hpp
  • PowerOffMode : SignalTypes.hpp
  • PowerSavingMode : NetworkTypes.hpp
  • PowerSavingMode1 : NetworkTypes.hpp
  • PppCallback : SysSocketBase.hpp
  • PreferedCug : SignalTypes.hpp
  • PresentationRestricted : SignalTypes.hpp
  • ProactiveCause : SimTkTypes.hpp
  • ProactiveSimApplTerminatedByUser : SignalTypes.hpp
  • ProcessId : SignalTypes.hpp
  • ProcessPtr : SignalMapTableEntry.hpp
  • ProcessSource : NetworkTypes.hpp
  • PropertyEditorID : PropertyEditorID.hpp
  • PropertyEditorID_hpp : PropertyEditorID.hpp
  • PropertyID : PropertyID.hpp
  • PropertyID_hpp : PropertyID.hpp
  • ProtErrUnspecified : SignalTypes.hpp
  • ProtocolError : SignalTypes.hpp
  • ProviderId : ProvIds.hpp
  • ProviderProxyContainer_hpp : ProviderProxyContainer.hpp
  • ProviderProxyItem_hpp : ProviderProxyItem.hpp
  • ProviderPtrList : MainProvider.hpp
  • ProviderType : DataItem.hpp
  • PS_IREAD : FatSim.hpp
  • PS_IWRITE : FatSim.hpp
  • PsAtc : NetworkTypes.hpp
  • PsdIfCallback : SysSocketBase.hpp
  • PSEEK_CUR : FatSim.hpp
  • PSEEK_END : FatSim.hpp
  • PSEEK_SET : FatSim.hpp
  • PsInvalid : NetworkTypes.hpp
  • PsMmi : NetworkTypes.hpp
  • PsNet : NetworkTypes.hpp
  • PsOm : NetworkTypes.hpp
  • ptEAADevice : EmApoxiAudioDeviceImpl.cpp
  • ptr_GetAudioBufferFunction : aud_drv.cpp
  • PtstMode : SignalTypes.hpp
  • publicIdNull : WbxmlParser.cpp
  • PuctEfPos : SimTkTypes.hpp
  • put_ringbuffer() : RingBuffer.hpp, RingBuffer.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- q -

  • QcifSize_INDEX : Camera.cpp
  • QoS : DataConnTextMaps.hpp
  • Qos : PdpTypes.hpp
  • QqcifSize_INDEX : Camera.cpp
  • QqvgaSize_INDEX : Camera.cpp
  • QsifSize_INDEX : Camera.cpp
  • QualityUnavailable : SignalTypes.hpp
  • QvgaSize_INDEX : Camera.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • R2L : ArabicTextRenderer.cpp
  • Ra_fail : NetworkTypes.hpp
  • RadioAccessTechnology : NetworkTypes.hpp
  • RadioButtonListModel : RadioButtonList.hpp
  • RadioPathAck : SignalTypes.hpp
  • RadioPathNotAvail : SignalTypes.hpp
  • RAISE_2_23 : LcsUtils.cpp
  • RamDataSinkPtr : RamDataSource.hpp, RamDataSink.hpp
  • RamDataSourcePtr : RamDataSource.hpp
  • RamError : RamTypes.hpp
  • RamErrorAccessDenied : RamTypes.hpp
  • RamErrorBadFileDescriptor : RamTypes.hpp
  • RamErrorFileAlreadyExist : RamTypes.hpp
  • RamErrorNegativeFilePointer : RamTypes.hpp
  • RamErrorNoSpace : RamTypes.hpp
  • RamErrorNotExist : RamTypes.hpp
  • RamErrorOperationNotPossible : RamTypes.hpp
  • RamErrorShare : RamTypes.hpp
  • RamErrorSuccess : RamTypes.hpp
  • RamFileAttrAll : RamTypes.hpp
  • RamFileAttrArchive : RamTypes.hpp
  • RamFileAttrDirectory : RamTypes.hpp
  • RamFileAttrHidden : RamTypes.hpp
  • RamFileAttribute : RamTypes.hpp
  • RamFileAttrNormal : RamTypes.hpp
  • RamFileAttrRdOnly : RamTypes.hpp
  • RamFileAttrSystem : RamTypes.hpp
  • RamFileAttrVolume : RamTypes.hpp
  • RamFilePtr : RamFile.hpp
  • RamHandle : RamFileNode.hpp
  • RamOpenMode : RamTypes.hpp
  • RamOpenModeRead : RamTypes.hpp
  • RamOpenModeWrite : RamTypes.hpp
  • RandomHugeFragVarPageTest() : HeapManager.cpp
  • RandomHugeVarPageTest() : HeapManager.cpp
  • RandomVarPageTest() : HeapManager.cpp
  • RasterOp : DeviceContext.hpp
  • Rat : NetworkTypes.hpp
  • RatChangeMode : NetworkTypes.hpp
  • RatChangeModeDual : NetworkTypes.hpp
  • RatChangeModeGsm : NetworkTypes.hpp
  • RatChangeModeUmts : NetworkTypes.hpp
  • RatGsm : NetworkTypes.hpp
  • RatNotAvailable : NetworkTypes.hpp
  • RatUmts : NetworkTypes.hpp
  • RcPhoneBook : AtcTypes.hpp
  • RdnChoice : SignalTypes.hpp
  • RdnNumberNotAvailable : SignalTypes.hpp
  • RdnPresentationAllowedAddr : SignalTypes.hpp
  • RdnPresentationRestrictAddr : SignalTypes.hpp
  • RdnPresentationRestricted : SignalTypes.hpp
  • RdnVoidChoice : SignalTypes.hpp
  • RdPhoneBook : AtcTypes.hpp
  • RDS_VALIDATE_LIMIT : FmRadioAudioPlayer.cpp
  • ReadCurrentFileBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • ReadCurrentFileFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • ReadErr : FfsTestError.hpp
  • ReadSmsFilterType : SimPduHandler.hpp
  • RecAmrCallback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • RecAmrStreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • ReceivedOnAnyAlerting : SignalTypes.hpp
  • ReceivedOnAnyConnect : SignalTypes.hpp
  • ReceivedOnAnyDisconnect : SignalTypes.hpp
  • ReceivedOnAnyRelease : SignalTypes.hpp
  • ReceivedOnAnyReleaseComplete : SignalTypes.hpp
  • ReceivedOnAnySetup : SignalTypes.hpp
  • ReceivedOnProgress : SignalTypes.hpp
  • RecordAmr : HostAudioDriver.hpp
  • RecordFileSpec() : HostCoreFsSim.cpp
  • Recording_Finish : HostAudioDriver.hpp
  • RecordPcm : HostAudioDriver.hpp
  • RecoveryOnTimerExpiry : SignalTypes.hpp
  • RecPcmCallback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • RecPcmStreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • red_exp_2 : ConvertToColorValue_Planes.cpp
  • ReferenceError : SignalTypes.hpp
  • RefreshPerformedWithAdditionalEFsRead : SimTkTypes.hpp
  • RefreshSyncFromClient : DBService.hpp
  • RefreshSyncFromServer : DBService.hpp
  • RegBackupHeader : RegMemoryPool.hpp
  • RegBlobFileNode : RegNodeFile.hpp
  • RegBlobNode : RegNodeFile.hpp
  • RegBooleanNode : RegNodeFile.hpp
  • RegChangeType : RegistryTypes.hpp
  • RegChangeTypeAdd : RegistryTypes.hpp
  • RegChangeTypeDelete : RegistryTypes.hpp
  • RegChangeTypeReplace : RegistryTypes.hpp
  • RegChangeTypeSftDel : RegistryTypes.hpp
  • RegChangeTypeUnknown : RegistryTypes.hpp
  • RegDataFormat : RegistryTypes.hpp
  • RegDataFormatB64 : RegistryTypes.hpp
  • RegDataFormatBool : RegistryTypes.hpp
  • RegDataFormatChar : RegistryTypes.hpp
  • RegDataFormatInt : RegistryTypes.hpp
  • RegDataFormatNode : RegistryTypes.hpp
  • RegDataFormatNull : RegistryTypes.hpp
  • RegDataFormatXml : RegistryTypes.hpp
  • RegDeletionBuffer : RegMemoryPool.hpp
  • RegFileType : RegDefines.hpp
  • RegFileTypeBackup : RegDefines.hpp
  • RegFileTypeBlob : RegDefines.hpp
  • RegFileTypeDirty : RegDefines.hpp
  • RegFileTypeMap : RegDefines.hpp
  • RegFileTypeNode : RegDefines.hpp
  • RegFileTypeRootFile : RegDefines.hpp
  • RegIntegerNode : RegNodeFile.hpp
  • RegInteriorNode : RegNodeFile.hpp
  • REGISTER_GATI_SERVER : MmiSimServer.cpp, HostAudioGatiServer.cpp, AragonServer.cpp, GatiManager.hpp
  • RegisterMode : NetworkTypes.hpp
  • RegisterModeUnavailable : NetworkTypes.hpp
  • RegisterRejectCause : NetworkTypes.hpp
  • RegisterStatus : NetworkTypes.hpp
  • RegistrationFailure : NetworkTypes.hpp
  • RegistrationMode : SignalTypes.hpp
  • RegNoNode : RegNodeFile.hpp
  • RegPayloadType : RegNodeFile.hpp
  • RegResChildLocked : RegistryTypes.hpp
  • RegResError : RegistryTypes.hpp
  • RegResInsufficientBuffer : RegistryTypes.hpp
  • RegResLocked : RegistryTypes.hpp
  • RegResNoData : RegistryTypes.hpp
  • RegResNodeAlreadyExists : RegistryTypes.hpp
  • RegResNoGetOnInterior : RegistryTypes.hpp
  • RegResNoService : RegistryTypes.hpp
  • RegResSuccess : RegistryTypes.hpp
  • RegResTypeNotSupported : RegistryTypes.hpp
  • RegResult : RegistryTypes.hpp
  • RegResUnlocked : RegistryTypes.hpp
  • Regst_cs_connection : NetworkTypes.hpp
  • Regst_indep_registration : NetworkTypes.hpp
  • Regst_plmn_selection : NetworkTypes.hpp
  • Regst_ps_suspended : NetworkTypes.hpp
  • Regst_search_for_network : NetworkTypes.hpp
  • Regst_user_attach_pending : NetworkTypes.hpp
  • Regst_user_detach_pending : NetworkTypes.hpp
  • RegState : NetworkTypes.hpp
  • RegStringNode : RegNodeFile.hpp
  • RejByCallControl : SignalTypes.hpp
  • RejectCall : Types.hpp
  • Rejected : SignalTypes.hpp
  • RelAllActiveCalls : SignalTypes.hpp
  • RelAllHeldCalls : SignalTypes.hpp
  • ReleaseComplete : SignalTypes.hpp
  • RelSpecificActiveCall : SignalTypes.hpp
  • RELTags_v1_0 : DrmRelXml.cpp
  • REMOTE_VOLUME_SETTING : BtHfAppPlugin.hpp
  • RemoteHold : MsgArgs.hpp
  • RemoteMbuild : MsgArgs.hpp
  • RemotePartyActionArg : MsgArgs.hpp
  • RemoteRetrieve : MsgArgs.hpp
  • rename_text_sample : FfsTests.cpp
  • RepaintHint : Grid.hpp
  • REPORT : SocketTestT.hpp
  • ReportErrorAndReturn : Wsscanf.cpp
  • ReportingTimer : NetworkTypes.hpp
  • ReqeustedCircuitNotAvailable : SignalTypes.hpp
  • ReqServNotDescr : SignalTypes.hpp
  • RequiredValuesAreMissing : SimTkTypes.hpp
  • ReselAbnormalResel : NetworkTypes.hpp
  • ReselBetterC2C32 : NetworkTypes.hpp
  • ReselC1LessNull : NetworkTypes.hpp
  • ReselCallReestTimeout : NetworkTypes.hpp
  • ReselCellChangeOrder : NetworkTypes.hpp
  • ReselDownlinkFail : NetworkTypes.hpp
  • ReselNotOccurred : NetworkTypes.hpp
  • ReselPlmnChange : NetworkTypes.hpp
  • ReselRaFailure : NetworkTypes.hpp
  • ReselSiReceiptFailure : NetworkTypes.hpp
  • RESET_PICTURE_COUNTER : StillCamera.cpp
  • ResetStateFunc : PdpContextManager.host.cpp
  • ResourceID_hpp : ResourceID.hpp
  • RESPONSE : SocketTestT.hpp
  • RESPONSE_TRACE : PsdDataConn.cpp
  • ResponseToStatusEnquiry : SignalTypes.hpp
  • RespTimeCategory : LcsTypes.hpp
  • RessourcesUnavailable : SignalTypes.hpp
  • RestrictedOperation : SignalTypes.hpp
  • RetrieveCall : SignalTypes.hpp
  • RetrieveClock() : InternalTracer.cpp
  • RetrieveMparty : SignalTypes.hpp
  • RetrieveRequestRejected : Types.hpp
  • RetryOnNewCellBeg : SignalTypes.hpp
  • RetryOnNewCellEnd : SignalTypes.hpp
  • return() : ConvertToColorValue_Planes.cpp
  • RFS_CHUNK_ATOM_SIZE : File.cpp
  • RFS_FAT_CHUNK_SIZE : FatStorageDeviceImp.cpp
  • RFS_FFS_CHUNK_SIZE : FlashStorageDeviceImp.cpp
  • RFS_RAM_CHUNK_SIZE : RamStorageDeviceImp.cpp
  • RFS_RFS_CHUNK_SIZE : RootStorageDeviceImp.cpp
  • RfsMsgTypes_hpp__ST_1128347704782 : RfsMsgTypes.hpp
  • RfsObexFtpServer_hpp : RfsObexFtpServer.hpp
  • RfsObexFtpTrace : RfsObexFtpServer.cpp
  • Rfu : SignalTypes.hpp
  • right : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • right_clip : BitBlit_Planes.cpp
  • right_clip_inc : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • RIGHT_ISSUER_STR : DrmDcfParser.hpp
  • right_mask : ScrollVertical_Planes.cpp, FillRect_Planes.cpp
  • right_mask_1 : BitBlit_Planes.cpp
  • right_mask_2 : BitBlit_Planes.cpp
  • RingBackToneOn : SignalTypes.hpp
  • ringer_tone_infos : RingerAudioDevice.cpp
  • RingerAudioDevice_hpp : RingerAudioDevice.hpp
  • ringing_tone_10_data : Audio.cpp
  • ringing_tone_11_data : Audio.cpp
  • ringing_tone_12_data : Audio.cpp
  • ringing_tone_13_data : Audio.cpp
  • ringing_tone_14_data : Audio.cpp
  • ringing_tone_15_data : Audio.cpp
  • ringing_tone_16_data : Audio.cpp
  • ringing_tone_17_data : Audio.cpp
  • ringing_tone_18_data : Audio.cpp
  • ringing_tone_19_data : Audio.cpp
  • ringing_tone_1_data : Audio.cpp
  • ringing_tone_20_data : Audio.cpp
  • ringing_tone_21_data : Audio.cpp
  • ringing_tone_22_data : Audio.cpp
  • ringing_tone_23_data : Audio.cpp
  • ringing_tone_24_data : Audio.cpp
  • ringing_tone_25_data : Audio.cpp
  • ringing_tone_26_data : Audio.cpp
  • ringing_tone_27_data : Audio.cpp
  • ringing_tone_28_data : Audio.cpp
  • ringing_tone_29_data : Audio.cpp
  • ringing_tone_2_data : Audio.cpp
  • ringing_tone_30_data : Audio.cpp
  • ringing_tone_31_data : Audio.cpp
  • ringing_tone_32_data : Audio.cpp
  • ringing_tone_33_data : Audio.cpp
  • ringing_tone_34_data : Audio.cpp
  • ringing_tone_35_data : Audio.cpp
  • ringing_tone_36_data : Audio.cpp
  • ringing_tone_37_data : Audio.cpp
  • ringing_tone_38_data : Audio.cpp
  • ringing_tone_39_data : Audio.cpp
  • ringing_tone_3_data : Audio.cpp
  • ringing_tone_40_data : Audio.cpp
  • ringing_tone_41_data : Audio.cpp
  • ringing_tone_42_data : Audio.cpp
  • ringing_tone_43_data : Audio.cpp
  • ringing_tone_44_data : Audio.cpp
  • ringing_tone_45_data : Audio.cpp
  • ringing_tone_46_data : Audio.cpp
  • ringing_tone_47_data : Audio.cpp
  • ringing_tone_48_data : Audio.cpp
  • ringing_tone_4_data : Audio.cpp
  • ringing_tone_5_data : Audio.cpp
  • ringing_tone_6_data : Audio.cpp
  • ringing_tone_7_data : Audio.cpp
  • ringing_tone_8_data : Audio.cpp
  • ringing_tone_9_data : Audio.cpp
  • RingingTone : SignalTypes.hpp
  • RingToneRpt : SignalTypes.hpp
  • RLE_COMMAND : BmpDecoder.cpp
  • RLE_DELTA : BmpDecoder.cpp
  • RLE_ENDOFBITMAP : BmpDecoder.cpp
  • RLE_ENDOFLINE : BmpDecoder.cpp
  • RomDataRes_hpp : RomDataRes.hpp
  • RootStorageDeviceIteratorPtr : StorageDeviceIterator.hpp
  • RotateBehavior : ScrollBehavior.hpp
  • RotateBehaviour : Grid.hpp
  • RrcAttachNotAllowed : NetworkTypes.hpp
  • RrcAttachTempBarred : NetworkTypes.hpp
  • RrcAuthFailure : NetworkTypes.hpp
  • RrcDetached : NetworkTypes.hpp
  • RrcDisabled : NetworkTypes.hpp
  • RrCellReselReason : NetworkTypes.hpp
  • RrcForbLai : NetworkTypes.hpp
  • RrcForbPlmn : NetworkTypes.hpp
  • RrcInternalFailure : NetworkTypes.hpp
  • RrcInvalidParameter : NetworkTypes.hpp
  • RrcInvalidSim : NetworkTypes.hpp
  • RrcNoCarrier : NetworkTypes.hpp
  • RrcNoCause : NetworkTypes.hpp
  • RrcNoCell : NetworkTypes.hpp
  • RrcNotRegistered : NetworkTypes.hpp
  • RrcNRegReq : NetworkTypes.hpp
  • RrcPlmnSearch : NetworkTypes.hpp
  • RrcPlmnSearchEnded : NetworkTypes.hpp
  • RrcPowerDown : NetworkTypes.hpp
  • RrcRejByNetwork : NetworkTypes.hpp
  • RrMode : NetworkTypes.hpp
  • RrModeGsm : NetworkTypes.hpp
  • RrModeUmts : NetworkTypes.hpp
  • rt : parsifal.cpp
  • RTC_OnEvent() : RealTimeClock.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • s_continue_msgs_handled : SocketTestApp.cpp
  • s_continue_msgs_sent : UdpTestSocket.cpp, TcpTestSocket.cpp, TcpServerTestSocket.cpp, SocketTestApp.cpp
  • SAFE_FREESTR : parsifal.cpp
  • SaveDelete : Macros.hpp
  • saxStringNull : WbxmlParser.cpp
  • ScActivate : SignalTypes.hpp
  • scalar_to_ymd() : RealTimeClock.cpp
  • scanline_inc : BitBlit_16Bpp.cpp
  • scanline_width : FillRect_16Bpp.cpp
  • ScBuildMpty : SignalTypes.hpp
  • ScDeactivate : SignalTypes.hpp
  • ScErase : SignalTypes.hpp
  • ScExplicitCt : SignalTypes.hpp
  • ScForwardChargeAdvice : SignalTypes.hpp
  • ScForwardCheckIndication : SignalTypes.hpp
  • ScForwardCugInfo : SignalTypes.hpp
  • ScGetPassword : SignalTypes.hpp
  • ScicosCodecIfLib_hpp : ScicosCodecIfLib.hpp
  • ScicosMpeg4VideoDecoder_hpp : ScicosMpeg4VideoDecoder.hpp
  • ScicosMpeg4VideoEncoder_hpp : ScicosMpeg4VideoEncoder.hpp
  • ScInterrogate : SignalTypes.hpp
  • ScNotify : SignalTypes.hpp
  • ScProcessUssd : SignalTypes.hpp
  • ScProcessUssdRequest : SignalTypes.hpp
  • ScreenBusy : SimTkTypes.hpp
  • ScRegister : SignalTypes.hpp
  • ScRegisterPassword : SignalTypes.hpp
  • ScRetrieveMpty : SignalTypes.hpp
  • ScrollBehavior : ScrollBehavior.hpp
  • ScScHoldMpty : SignalTypes.hpp
  • ScSetupUusText : SignalTypes.hpp
  • ScSplitMpty : SignalTypes.hpp
  • ScUssdNotify : SignalTypes.hpp
  • ScUssdRequest : SignalTypes.hpp
  • SdlBoolean : SignalTypes.hpp
  • SdlByte : SignalTypes.hpp
  • SdlCharacter : SignalTypes.hpp
  • SdlFalse : SignalTypes.hpp
  • SdlInteger : SignalTypes.hpp
  • SdlSignalId : SignalMapTableEntry.hpp
  • SdlSignalName : SignalMapTableEntry.hpp
  • SdlTrue : SignalTypes.hpp
  • SdlUlong : SignalTypes.hpp
  • SdlWord : SignalTypes.hpp
  • SDMMCSPI : apoxi.features
  • SdnEfPos : SimTkTypes.hpp
  • SdnPhoneBook : SignalTypes.hpp
  • SdnPhoneBookCnt : SignalTypes.hpp
  • SdPhoneBook : AtcTypes.hpp
  • SecAtLock : LockTypes.hpp
  • SecChangePwdLock : LockTypes.hpp
  • SecContinueOperation : LockTypes.hpp
  • SecControlKeyError : LockTypes.hpp
  • SecCorporateLock : LockTypes.hpp
  • SecDepersSmsLock : LockTypes.hpp
  • SecGetProfileLock : LockTypes.hpp
  • SecImeiInvalid : LockTypes.hpp
  • SecLockAction : LockTypes.hpp
  • SecLockActive : LockTypes.hpp
  • SecLockArmed : LockTypes.hpp
  • SecLockAutoActivated : LockTypes.hpp
  • SecLockBlocked : LockTypes.hpp
  • SecLockCause : LockTypes.hpp
  • SecLockDeactive : LockTypes.hpp
  • SecLockDisabled : LockTypes.hpp
  • SecLockError : LockTypes.hpp
  • SecLockInvalid : LockTypes.hpp
  • SecLockLastState : LockTypes.hpp
  • SecLockLocked : LockTypes.hpp
  • SecLockPermanentActive : LockTypes.hpp
  • SecLockResult : LockTypes.hpp
  • SecLockStatus : LockTypes.hpp
  • SecLockType : LockTypes.hpp
  • SecLockUnlocked : LockTypes.hpp
  • SecNetworkLock : LockTypes.hpp
  • SecNetworkSubsetLock : LockTypes.hpp
  • SecNofLock : LockTypes.hpp
  • SecNofTypes : LockTypes.hpp
  • SecNoFurtherOperation : LockTypes.hpp
  • SecNoMoreTrials : LockTypes.hpp
  • SecondCallMissing : Types.hpp
  • SecPersCodeError : LockTypes.hpp
  • SecPfLock : LockTypes.hpp
  • SecProfileUpdate : LockTypes.hpp
  • SecRefreshLock : LockTypes.hpp
  • SecSimLock : LockTypes.hpp
  • SecSpLock : LockTypes.hpp
  • SecStartupLock : LockTypes.hpp
  • SecStorageError : LockTypes.hpp
  • SecSucceded : LockTypes.hpp
  • SecUnauthorisized : LockTypes.hpp
  • SecUnknownResult : LockTypes.hpp
  • SecUnlockAction : LockTypes.hpp
  • SecurityError : SignalTypes.hpp
  • SecVerificationNeeded : LockTypes.hpp
  • SEEKWS : parsifal.cpp
  • SelectionMode : Grid.hpp
  • SemanticsIncorrect : SignalTypes.hpp
  • sEmApoxiAudioDecoderFrameDecodedCb() : EmApoxiAudioDecoder.cpp
  • sEmApoxiInBufFreeCb() : EmApoxiVideoDecoder.cpp
  • sEmApoxiVideoDecoderFrameDecodedCb() : EmApoxiVideoDecoder.cpp
  • sEmApoxiVideoEncoderFrameEncodedCb() : EmApoxiVideoEncoder.cpp
  • SemIncorrMsg : SignalTypes.hpp
  • SEND_TCP : SocketTestT.hpp
  • SEND_UDP : SocketTestT.hpp
  • SendMessageToDispatcherToApp() : EmApoxiMsgDispatcher.cpp
  • SendOnAlerting : SignalTypes.hpp
  • SendOnAny : SignalTypes.hpp
  • SendOnConnect : SignalTypes.hpp
  • SendOnDisconnect : SignalTypes.hpp
  • SendOnRelease : SignalTypes.hpp
  • SendOnReleaseComplete : SignalTypes.hpp
  • SendOnSetup : SignalTypes.hpp
  • SendPowerUpArgs() : PowerHandler.cpp
  • SendTchStatusUpdateToMn() : TchInterface.cpp
  • SentSmsFilterType : SimPduHandler.hpp
  • SER_DATACONN_SUPPORT : apoxi.features
  • SerialClientSocketPtr : SioSocketAdapter.hpp
  • SerialServerSocketPtr : SioSocketAdapter.hpp
  • ServedCallApplication : SignalTypes.hpp
  • SERVER : apoxi.features
  • SERVER_DBG_OUT_RANGE : Server.hpp
  • ServerAlertedSync : DBService.hpp
  • ServerClientPtr : ServerClient.hpp
  • ServerConfigPtr : ServerConfig.hpp
  • ServerPtr : Server.hpp
  • ServiceCardSim : SignalTypes.hpp
  • ServiceDetached : NetworkTypes.hpp
  • ServiceDisabled : NetworkTypes.hpp
  • ServiceGroup : SignalTypes.hpp
  • ServiceNotAvailable : SignalTypes.hpp
  • ServiceNotImplemented : SignalTypes.hpp
  • ServiceNotSupported : SignalTypes.hpp
  • ServiceResult : Service.hpp
  • Services_Service_hpp : Service.hpp
  • Services_ServiceBroker_hpp : ServiceBroker.hpp
  • ServiceTempOutOfOrder : SignalTypes.hpp
  • ServiceThreadExtn_hpp : ExtndServiceThreadForNetwork.hpp
  • SET_G_TONE_DATA : aud_drv.cpp
  • SetPlaybackState() : AudioPriorityManager.cpp
  • setting : apoxi.defines
  • SetUnused() : HeapVector.cpp
  • SetupCallDetected : Types.hpp
  • SetupConfirmation : MmTypes.hpp
  • SetUsed() : HeapVector.cpp
  • SharedMem : Win32.hpp
  • ShortMessageMoPp : SignalTypes.hpp
  • ShortMessageMtPp : SignalTypes.hpp
  • SiBearerCsd : SimTkTypes.hpp
  • SiBearerDefault : SimTkTypes.hpp
  • SiBearerDesc : SimTkTypes.hpp
  • SiBearerGprs : SimTkTypes.hpp
  • SiBearerList : SimTkTypes.hpp
  • SiBearerType : SimTkTypes.hpp
  • SiBearerUndef : SimTkTypes.hpp
  • SiChannelChanged1 : SimTkTypes.hpp
  • SiChannelChanged2 : SimTkTypes.hpp
  • SiChannelChanged3 : SimTkTypes.hpp
  • SiChannelChanged4 : SimTkTypes.hpp
  • SiChannelChangedNoInfo : SimTkTypes.hpp
  • SiChannelChangedState : SimTkTypes.hpp
  • SiChannelChangedToDropped : SimTkTypes.hpp
  • SiChannelCloseCause : SimTkTypes.hpp
  • SiChannelClosedBySat : SimTkTypes.hpp
  • SiChannelClosedByUser : SimTkTypes.hpp
  • SiChannelCloseRej : SimTkTypes.hpp
  • SiChannelCloseUndef : SimTkTypes.hpp
  • SiClientFlags : SimTkTypes.hpp
  • SiDtmfType : SignalTypes.hpp
  • SiDuration : SimTkTypes.hpp
  • SigHandlerId : HandlerId.hpp
  • Sign() : Types.hpp
  • SignalQualityLevel : SignalTypes.hpp
  • SignalQualityMax : SignalTypes.hpp
  • SignalStrengthLevel : SignalTypes.hpp
  • SignalStrengthMax : SignalTypes.hpp
  • SiIpAddress : SimTkTypes.hpp
  • SilentResetMode : SignalTypes.hpp
  • Sim2G : SignalTypes.hpp
  • Sim3G : SignalTypes.hpp
  • SimAcm : Types.hpp
  • SimAcmMax : Types.hpp
  • SimAdnPhonebook : Types.hpp
  • SimAll : Types.hpp
  • SimApplicationErrorP1P2 : SignalTypes.hpp
  • SimApplicationErrorP3 : SignalTypes.hpp
  • SimBasicImageCoding : ImageData.hpp
  • SimBdnPhonebook : Types.hpp
  • SimCallControlResult : SignalTypes.hpp
  • SimCardType : SignalTypes.hpp
  • SimCbmi : Types.hpp
  • SimCbmiRange : Types.hpp
  • SimCcp : Types.hpp
  • SimChangedState : SimMiscTypes.hpp
  • SimColorImageCoding : ImageData.hpp
  • SimContradictInvalidState : SignalTypes.hpp
  • SimContradictWithChvState : SignalTypes.hpp
  • SimCphsCsp : Types.hpp
  • SimCphsInfo : Types.hpp
  • SimCphsInfoNoPhonebook : Types.hpp
  • SimCphsMBoxPhonebook : Types.hpp
  • SimCphsOpName : Types.hpp
  • SimCphsOpShortName : Types.hpp
  • SimDummy : SimDataTypes.hpp
  • SimEcc : Types.hpp
  • SimError : SignalTypes.hpp
  • SimErrorCode : SignalTypes.hpp
  • SimExtMemoryExceeded : SignalTypes.hpp
  • SimFdnPhonebook : Types.hpp
  • SimFileId : SignalTypes.hpp
  • SimFileType : SignalTypes.hpp
  • SimFullAccess : SignalTypes.hpp
  • SimHandlerId : HandlerId.hpp
  • SimIconId : SimDataTypes.hpp
  • SimImageCodingScheme : ImageData.hpp
  • SimImageHeader : ImageData.hpp
  • SimImageHeaderBody : ImageData.hpp
  • SimImageHeaderBodyClut : ImageData.hpp
  • SimImageHeaderClut : ImageData.hpp
  • SimImageRequestType : ImageData.hpp
  • SimImsi : Types.hpp
  • SimInconsistentCmd : SignalTypes.hpp
  • SimIndicator : SignalTypes.hpp
  • SimInitResult : SignalTypes.hpp
  • SimInvalidAddress : SignalTypes.hpp
  • SimItemIdentifierList : SimDataTypes.hpp
  • SimKey : SimTkTypes.hpp
  • SimKeyInvalid : SimTkTypes.hpp
  • SimKeyNo : SimTkTypes.hpp
  • SimKeyYes : SimTkTypes.hpp
  • SimLaunchBrowserPromptReq : SimTkTypes.hpp
  • SimLndPhonebook : Types.hpp
  • SimLocked : SimLockTypes.hpp
  • SimMbdnPhonebook : Types.hpp
  • SimMemRetrySuccess : SignalTypes.hpp
  • SimMsisdnPhonebook : Types.hpp
  • SimNoAttemptLeft : SignalTypes.hpp
  • SimNoChvInitialized : SignalTypes.hpp
  • SimNoEfChoosen : SignalTypes.hpp
  • SimNotPresent : SignalTypes.hpp
  • SimNotSet : SignalTypes.hpp
  • SimPhase : SignalTypes.hpp
  • SimPreferedExtLanguages : Types.hpp
  • SimPreferedLanguages : Types.hpp
  • SimPreferedPlmns : Types.hpp
  • SimPresent : SignalTypes.hpp
  • SimPuct : Types.hpp
  • SimReady : SignalTypes.hpp
  • SimReadyForRegistration : SignalTypes.hpp
  • SimReferenceNumber : SimDataTypes.hpp
  • SimRefreshType : SignalTypes.hpp
  • SimSdnPhonebook : Types.hpp
  • SimServiceAdn : SstProvider.hpp
  • SimServiceAoc : SstProvider.hpp
  • SimServiceBdn : SstProvider.hpp
  • SimServiceCbmi : SstProvider.hpp
  • SimServiceCbmiRanges : SstProvider.hpp
  • SimServiceCfis : SstProvider.hpp
  • SimServiceChv1Disable : SstProvider.hpp
  • SimServiceFdn : SstProvider.hpp
  • SimServiceId : SstProvider.hpp
  • SimServiceImages : SstProvider.hpp
  • SimServiceInvalid : SstProvider.hpp
  • SimServiceLnd : SstProvider.hpp
  • SimServiceMbdn : SstProvider.hpp
  • SimServiceMexe : SstProvider.hpp
  • SimServiceMsisdn : SstProvider.hpp
  • SimServiceMwis : SstProvider.hpp
  • SimServiceOpl : SstProvider.hpp
  • SimServicePlmnwAct : SstProvider.hpp
  • SimServicePnn : SstProvider.hpp
  • SimServicePrefPlmn : SstProvider.hpp
  • SimServiceSdn : SstProvider.hpp
  • SimServiceSms : SstProvider.hpp
  • SimServiceSmsParameter : SstProvider.hpp
  • SimServiceSpdi : SstProvider.hpp
  • SimServiceSpn : SstProvider.hpp
  • SimSms : Types.hpp
  • SimSmsParameters : Types.hpp
  • SimSmsReady : SignalTypes.hpp
  • SimSpn : Types.hpp
  • SimSst : Types.hpp
  • SimSsType : SignalTypes.hpp
  • SimStatusCondition : Tlv.hpp
  • SimStatusFailure : SignalTypes.hpp
  • SimSuccessBeyondEnd : SignalTypes.hpp
  • SimTechnicalProblem : SignalTypes.hpp
  • SIMTK_LETTERCLASS_E : apoxi.features, apoxi.defines
  • SimtkCallConnected : SignalTypes.hpp
  • SimtkCallConnectedNoIconDisplay : SignalTypes.hpp
  • SimTkHandlerId : HandlerId.hpp
  • SimTkLceHandlerId : HandlerId.hpp
  • SimtkSetSignalParam1 : SimTkTypes.hpp
  • SimtkSetSignalParam10 : SimTkTypes.hpp
  • SimtkSetSignalParam11 : SimTkTypes.hpp
  • SimtkSetSignalParam2 : SimTkTypes.hpp
  • SimtkSetSignalParam3 : SimTkTypes.hpp
  • SimtkSetSignalParam4 : SimTkTypes.hpp
  • SimtkSetSignalParam5 : SimTkTypes.hpp
  • SimtkSetSignalParam6 : SimTkTypes.hpp
  • SimtkSetSignalParam7 : SimTkTypes.hpp
  • SimtkSetSignalParam8 : SimTkTypes.hpp
  • SimtkSetSignalParam9 : SimTkTypes.hpp
  • SimtkSetSignalTid : SimTkTypes.hpp
  • SimtkSetupModeNotSupported : SignalTypes.hpp
  • SimtkSetupRejByUser : SignalTypes.hpp
  • SimtkSetupRejMissingAcmInfoInd : SignalTypes.hpp
  • SimtkSetupRejPendingSimtkSetup : SignalTypes.hpp
  • SimtkSetupRejTimeOut : SignalTypes.hpp
  • SimtkSignalParam1 : SimTkTypes.hpp
  • SimtkSignalParam10 : SimTkTypes.hpp
  • SimtkSignalParam11 : SimTkTypes.hpp
  • SimtkSignalParam2 : SimTkTypes.hpp
  • SimtkSignalParam3 : SimTkTypes.hpp
  • SimtkSignalParam4 : SimTkTypes.hpp
  • SimtkSignalParam5 : SimTkTypes.hpp
  • SimtkSignalParam6 : SimTkTypes.hpp
  • SimtkSignalParam7 : SimTkTypes.hpp
  • SimtkSignalParam8 : SimTkTypes.hpp
  • SimtkSignalParam9 : SimTkTypes.hpp
  • SimtkSignalTid : SimTkTypes.hpp
  • SimtkSimReset : SignalTypes.hpp
  • SimTkSuccessful : SimTkTypes.hpp
  • SimToolkitBusy : SignalTypes.hpp
  • SimToolkitCallSetupFailed : Types.hpp
  • SimToolkitResponeError : SignalTypes.hpp
  • SimTpdus : SimPduHandler.hpp
  • SimType : SignalTypes.hpp
  • SimulResetMode : SignalTypes.hpp
  • SimUnblocked : SignalTypes.hpp
  • SimUnknownInstruction : SignalTypes.hpp
  • SimUnlocked : SimLockTypes.hpp
  • SimUpdateStatus : SignalTypes.hpp
  • SimWrongInstructionClass : SignalTypes.hpp
  • SiNoSsType : SignalTypes.hpp
  • SIO_SIGNAL_DATA_SENT : SerialIoAdapter.hpp
  • SIO_USE_SOCKET_CONCEPT : SerialIoAdapter.hpp
  • SiProvFileRef : SimTkTypes.hpp
  • SiSendDataImmediately : SimTkTypes.hpp
  • SiSendDataStoreInBuffer : SimTkTypes.hpp
  • SiSendDataType : SimTkTypes.hpp
  • SiSsType : SignalTypes.hpp
  • SiText : SimTkTypes.hpp
  • SiTransportLayer : SimTkTypes.hpp
  • SiTrLayerRaw : SimTkTypes.hpp
  • SiTrLayerTcp : SimTkTypes.hpp
  • SiTrLayerUdp : SimTkTypes.hpp
  • SiUnknownError : SignalTypes.hpp
  • SiUssdType : SignalTypes.hpp
  • SiUssdTypeEarlyUsage : SignalTypes.hpp
  • Size1_3Mp_INDEX : Camera.cpp
  • Size1Mp_INDEX : Camera.cpp
  • Size2Mp_INDEX : Camera.cpp
  • Size3Mp_INDEX : Camera.cpp
  • SIZECENTRALDIRITEM : Unzip.hpp
  • SIZEZIPLOCALHEADER : Unzip.hpp
  • SKIP_BYTES : GifDecoder.cpp
  • SKIP_SPACE : MultipartParser.hpp
  • slong : FatSim.hpp
  • SlowTwoWaySync : DBService.hpp
  • Sms_SmsMsgTypes_hpp : SmsMsgTypes.hpp
  • SmsBox : SmsSettingsRecord.hpp
  • SmsDeleteRead : SimPduHandler.hpp
  • SmsDeleteSent : SimPduHandler.hpp
  • SmsDeleteStatus : SimPduHandler.hpp
  • SmsDeleteUnread : SimPduHandler.hpp
  • SmsDeleteUnsent : SimPduHandler.hpp
  • SmsDisableMoreMessages : SignalTypes.hpp
  • SmsEfPos : SimTkTypes.hpp
  • SmsEnableMoreMessages : SignalTypes.hpp
  • SmsEnableMoreMessagesUntilTimerExpiry : SignalTypes.hpp
  • SmsFilterType : SimPduHandler.hpp
  • SmsHandlerId : HandlerId.hpp
  • SmsMoreMessageType : SignalTypes.hpp
  • SmsParameterRefresh : SignalTypes.hpp
  • SmspEfPos : SimTkTypes.hpp
  • SmsPortNo : InformationElement.hpp
  • SmsReferenceNumber : SimDataTypes.hpp
  • SmsrEfPos : SimTkTypes.hpp
  • SmsRefresh : SignalTypes.hpp
  • SmsReportTpdus : SimPduHandler.hpp
  • SmsRpError : SimTkTypes.hpp
  • SmssEfPos : SimTkTypes.hpp
  • SmsTextItemType : SmsTextParser.hpp
  • SmsTextItemType_Email : SmsTextParser.hpp
  • SmsTextItemType_PhoneNumber : SmsTextParser.hpp
  • SmsTextItemType_Url : SmsTextParser.hpp
  • SmsUndefinedMoreMessages : SignalTypes.hpp
  • SNDBRVERSION : SoundBrowserVersion.hpp
  • SOCKET : apoxi.features
  • SocketControlMsgType : SocketTypes.hpp
  • SocketError : SocketTypes.hpp
  • SocketMsg_hpp__ST_1044273316690 : SocketMsg.hpp
  • SocketTestMsgTypes_hpp__ST_1092045237546 : SocketTestMsgTypes.hpp
  • SocketTestVersion_hpp : SocketTestVersion.hpp
  • SocketTrace : SocketTypes.hpp
  • SocketTracer : Trace.hpp
  • SocketTracerLevel2 : Trace.hpp
  • SocketTracerLevel3 : Trace.hpp
  • SOCKETVERSION : SocketTestVersion.hpp
  • SoundBrowserVersion_hpp : SoundBrowserVersion.hpp
  • SpeakerAdaption : VrTypes.hpp
  • SpeakerDependentTraining : VrTypes.hpp
  • Speech : SignalTypes.hpp
  • SpeechAudioDevice_hpp : SpeechAudioDevice.hpp
  • SpeechCallActive : SignalTypes.hpp
  • SpeechCallRequired : Types.hpp
  • SpeechMtcAccepted : SignalTypes.hpp
  • SpeechTonesAvailable : SignalTypes.hpp
  • SpeechTonesNotAvailable : SignalTypes.hpp
  • SplitMparty : SignalTypes.hpp
  • SpnEfPos : SimTkTypes.hpp
  • SqcifSize_INDEX : Camera.cpp
  • src : ScrollHorizontal_Planes.cpp
  • src_atom : ScrollHorizontal_Planes.cpp
  • src_data : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • src_line_inc : BitBlit_Planes.cpp
  • src_mask : DrawChar_Planes.cpp, BitBlit_Planes.cpp
  • src_plane_inc : BitBlit_Planes.cpp
  • src_scanline_inc : BitBlit_Planes.cpp
  • SsApiRc : Types.hpp
  • SsBaseHandlerId : HandlerId.hpp
  • SsBasicServiceGroupListInterrogate : SignalTypes.hpp
  • SsCcbsHandlerId : HandlerId.hpp
  • SscDataDownloadResponse : Tlv.hpp
  • SscIncorrectParameterP1_P2 : Tlv.hpp
  • SscIncorrectParameterP3 : Tlv.hpp
  • SsCliRestrictInfoInterrogate : SignalTypes.hpp
  • SscMemoryManagementResponse : Tlv.hpp
  • SscNormalEnding : Tlv.hpp
  • SscNormalEndingExtra : Tlv.hpp
  • SsCode : SignalTypes.hpp
  • SscOtherResponse : Tlv.hpp
  • SscPostponedResponse : Tlv.hpp
  • SscReferencingManagementResponse : Tlv.hpp
  • SscSecurityManagementResponse : Tlv.hpp
  • SscTechnicalProblem : Tlv.hpp
  • SscUnknownInstruction : Tlv.hpp
  • SscWrongInstruction : Tlv.hpp
  • SsDataLocked : Types.hpp
  • SsForwardToNoInterrogate : SignalTypes.hpp
  • SsForwwardFeatureListInterrogate : SignalTypes.hpp
  • SsHandlerId : HandlerId.hpp
  • sshort : FatSim.hpp
  • SsInd : SignalTypes.hpp
  • SsMainHandlerId : HandlerId.hpp
  • SsOperationCode : SignalTypes.hpp
  • SsReturnError : SimTkTypes.hpp
  • SsStatusInterrogate : SignalTypes.hpp
  • SstEfPos : SimTkTypes.hpp
  • SstTableIndexes : SstProvider.hpp
  • SsVoidInterrogate : SignalTypes.hpp
  • ST_ERR_ALLOCATION : SocketTestDefines.hpp
  • ST_ERR_CLOSE : SocketTestDefines.hpp
  • ST_ERR_NOT_ALL_PACKETS_RECEIVED : SocketTestDefines.hpp
  • ST_ERR_SERVER_SOCK_LISTEN : SocketTestDefines.hpp
  • ST_ERR_SET_DATACONN_PROFILE_ID : SocketTestDefines.hpp
  • ST_ERR_SOCKALLOC : SocketTestDefines.hpp
  • ST_ERR_USERINTERRUPT : SocketTestDefines.hpp
  • ST_ERR_WRITESOCK_CONTEXT : SocketTestDefines.hpp
  • ST_ERR_WRITESOCK_UNKNOWN : SocketTestDefines.hpp
  • ST_ERR_WRONGDATA : SocketTestDefines.hpp
  • StackAtom : Scheduler.hpp
  • StackMsgArgId : StackMsgArgument.hpp
  • StackMsgArgName : StackMsgMapTableEntry.hpp
  • stand_alone : LcsTypes.hpp
  • STAND_ALONE : LcsTypes.hpp
  • start_atom_idx : BitBlit_Planes.cpp
  • start_y : BitBlit_Planes.cpp
  • StarToken : InputParser.hpp
  • STAT : FatSim.hpp
  • STATE_MAP_ENTRY : StateMachine.hpp
  • StateFunc : StateMachine.hpp
  • StaticValueMappingPropertyDescriptor : ValueMappingPropertyDescriptor.hpp
  • STDENTITIES : parsifal.cpp
  • StillCameraTestCode : CameraCaptureWin.cpp, StillCamera.cpp
  • stkInit() : stk.cpp
  • stkPop() : stk.cpp
  • stkPush() : stk.cpp
  • STOP_ALL : SocketTestT.hpp
  • STOP_TCP : SocketTestT.hpp
  • STOP_UDP : SocketTestT.hpp
  • StopMp3 : HostAudioDriver.hpp
  • STOPPED_BY_GDD_PROBLEM : StillCamera.hpp
  • STOPPED_BY_NO_BUFFER_FOUND : StillCamera.hpp
  • STOPPED_BY_USER_CANCEL : StillCamera.hpp
  • STOPPED_NORMALLY : StillCamera.hpp
  • StopPlayAmr : HostAudioDriver.hpp
  • StopPlayPcm : HostAudioDriver.hpp
  • StopRecAmr : HostAudioDriver.hpp
  • StopRecPcm : HostAudioDriver.hpp
  • StopRetCode : HostAudioDriver.hpp
  • StorageDeviceFilterPtr : StorageDeviceVisitor.hpp, RootFileSystem.hpp
  • StorageDeviceIteratorPtr : RootFileSystem.hpp
  • StorageDevicePtr : StorageDeviceVisitor.hpp, StorageDeviceFilter.hpp, RootFileSystem.hpp
  • STR_CONTENT_ENCODING : MultipartParser.hpp
  • STR_CONTENT_ID : MultipartParser.hpp
  • STR_CONTENT_TYPE : MultipartParser.hpp
  • STR_DESCRIPTION : MultipartParser.hpp
  • STR_DISPOSITION : MultipartParser.hpp
  • strcat : HostCoreFsSim.cpp
  • strcpy : HostCoreFsSim.cpp
  • StreamingCallback() : File.cpp
  • string_max_buffer_size : String.hpp
  • StringCmpErr : FfsTestError.hpp
  • StringDataSink_hpp : StringDataSink.hpp
  • StringTest() : String.hpp
  • StringToken : InputParser.hpp
  • StringType : DataItem.hpp
  • strlen() : FunctionTracer.hpp
  • strprintf() : StrUtil.hpp, StrPrintf.cpp
  • StrPrintf() : StrUtil.hpp, StrPrintf.cpp
  • StrToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • SUB_UNIT_INFO : BtAvrcpControllerApplicationWindows.cpp
  • SubscriberBusy : Types.hpp
  • Success : Types.hpp
  • SuccessfulButIconNotDisplayed : SimTkTypes.hpp
  • Successfull : SignalTypes.hpp
  • SuccessInvalidExt : SignalTypes.hpp
  • supervisory_tone_call_waiting_data : Audio.cpp
  • supervisory_tone_congestion_data : Audio.cpp
  • supervisory_tone_error_data : Audio.cpp
  • supervisory_tone_radio_path_ack_data : Audio.cpp
  • supervisory_tone_radio_path_not_avail_data : Audio.cpp
  • supervisory_tone_subscriber_busy_data : Audio.cpp
  • SupplementaryServiceChangedToMoc : Types.hpp
  • SupplementaryServiceChangedToSs : Types.hpp
  • SupplementaryServiceChangedToUssd : Types.hpp
  • SupplementaryServiceDenied : Types.hpp
  • SupplementaryServiceFailed : Types.hpp
  • SupplementaryServiceNotPending : Types.hpp
  • SupplementaryServiceNotSupported : Types.hpp
  • SupplementaryServicePending : Types.hpp
  • SuppressPhoneNumber : SignalTypes.hpp
  • SValue : NetworkTypes.hpp
  • SVG : apoxi.features
  • SVG_ABS : SvgImage.cpp
  • SVG_ANTI_ALIAS_LEVEL : SvgConfig.hpp
  • SVG_ASSERT : SvgDebug.hpp
  • SVG_BYTES_PER_PIXEL : SvgConfig.hpp
  • SVG_DBG_OUT : SvgDebug.hpp
  • SVG_DBG_SECTION_CALLBACK : SvgDebug.hpp
  • SVG_DBG_SECTION_DECODER : SvgDebug.hpp
  • SVG_DBG_SECTION_FILEWRAPPER : SvgDebug.hpp
  • SVG_DBG_SECTION_FIXPOINT : SvgDebug.hpp
  • SVG_DBG_SECTION_GZ : SvgDebug.hpp
  • SVG_DBG_SECTION_IMAGE : SvgDebug.hpp
  • SVG_DBG_SECTION_MEMORY : SvgDebug.hpp
  • SVG_DBG_SECTION_MEMORY_PROF : SvgDebug.hpp
  • SVG_DBG_SECTION_MIME : SvgDebug.hpp
  • SVG_DBG_SECTION_PLAYER : SvgDebug.hpp
  • SVG_DBG_SECTION_SYSFONTS : SvgDebug.hpp
  • SVG_DBG_SECTION_TEST : SvgDebug.hpp
  • SVG_DBG_SECTIONS_USE_ALL : SvgDebug.hpp
  • SVG_DBG_USED_SECTIONS : SvgDebug.hpp
  • SVG_DEBUG : SvgConfig.hpp
  • SVG_FILE_FONTS : SvgDecoder.cpp
  • SVG_FILE_SVG_DOCUMENT : SvgDecoder.cpp
  • SVG_FONT_ANTI_ALIAS_LEVEL : SvgConfig.hpp
  • SVG_FONT_RESOURCE_FFS : SvgConfig.hpp
  • SVG_FONT_RESOURCE_FFS_FILENAME : SvgConfig.hpp
  • SVG_FONT_RESOURCE_INLINE : SvgConfig.hpp
  • SVG_FONT_RESOURCE_INLINE_FILENAME : SvgConfig.hpp
  • SVG_FONT_USE_SYSTEM_FONT : SvgConfig.hpp
  • SVG_FP_CONST_0 : SvgFixPoint.cpp
  • SVG_FP_CONST_1 : SvgFixPoint.cpp
  • SVG_FP_CONST_90 : SvgFixPoint.cpp
  • SVG_FP_ENTRIES_PER_DEG : SvgFixPoint.cpp
  • SVG_FP_FIRST_QUADRANT : SvgFixPoint.cpp
  • SVG_FP_FP_TO_INT : SvgFixPoint.hpp
  • SVG_FP_INT_TO_FP : SvgFixPoint.hpp
  • SVG_FP_ONE_REVOLUTION : SvgFixPoint.cpp
  • SVG_FP_SECOND_QUADRANT : SvgFixPoint.cpp
  • SVG_FP_THIRD_QUADRANT : SvgFixPoint.cpp
  • SVG_FP_TRANS_GET_X_SCALE : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_X_SHEAR : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_X_TRANS : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_Y_SCALE : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_Y_SHEAR : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_Y_TRANS : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_X_SCALE : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_X_SHEAR : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_X_TRANS : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_Y_SCALE : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_Y_SHEAR : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_Y_TRANS : SvgFixPoint.hpp
  • SVG_GZ_FLAGS_COMMENT : SvgGzFileWrapper.cpp
  • SVG_GZ_FLAGS_CRC16 : SvgGzFileWrapper.cpp
  • SVG_GZ_FLAGS_EXTRA : SvgGzFileWrapper.cpp
  • SVG_GZ_FLAGS_ORIG_NAME : SvgGzFileWrapper.cpp
  • SVG_GZ_INPUT_BUFFER_SIZE : SvgGzFileWrapper.hpp
  • SVG_GZ_MAGIC_1 : SvgGzFileWrapper.cpp
  • SVG_GZ_MAGIC_2 : SvgGzFileWrapper.cpp
  • SVG_GZ_MINIMAL_HEADER_LENGTH : SvgGzFileWrapper.cpp
  • SVG_GZ_RESERVED : SvgGzFileWrapper.cpp
  • SVG_GZ_Z_DEFLATED : SvgGzFileWrapper.cpp
  • SVG_IMAGE_FRAMES_PER_SECOND : SvgImage.cpp
  • SVG_IMAGE_HEURISTIC_PAUSE : SvgImage.cpp
  • SVG_LARGEST_IMAGE_SIZE : SvgConfig.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_GIF : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_JPEG : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_PNG : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_SVG : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_WBMP : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IS_IMAGE : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_NA : SvgMimeUtil.hpp
  • SVG_NUMBER_OF_ZOOMLEVELS : SvgConfig.hpp
  • SVG_PLAYER_DEFAULT_HEIGHT : SvgConfig.hpp
  • SVG_PLAYER_DEFAULT_WIDTH : SvgConfig.hpp
  • SVG_PRINT_IMAGE_ERROR : SvgDebug.hpp
  • SVG_SMALLEST_PREFERED_MEM_CHUNK_SIZE : SvgConfig.hpp
  • SVG_VIRTUAL_HEAP : SvgConfig.hpp
  • SvgaSize_INDEX : Camera.cpp
  • SvgFixPoint : SvgFixPoint.hpp
  • SvgFixPoint_Bounded_Cos : SvgFixPoint.cpp
  • SvgFixPoint_Scalar_Add : SvgFixPoint.hpp
  • SvgFixPoint_Scalar_Mul() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Scalar_Print() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Scalar_Sub : SvgFixPoint.hpp
  • SvgFixPoint_Transform_Init() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_Print() : SvgFixPoint.hpp
  • SvgFixPoint_Transform_Rotate() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_Scale() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_Translate() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_XY_Scale() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPointTrans : SvgFixPoint.hpp
  • SvgFontConfig : SvgDecoder.cpp
  • SVGFONTCONFIG_GET_FONT_ATTR : SvgDecoder.cpp
  • SVGFONTCONFIG_GET_FONT_INDEX : SvgDecoder.cpp
  • SVGFONTCONFIG_SET_FONT_ATTR : SvgDecoder.cpp
  • SVGFONTCONFIG_SET_FONT_INDEX : SvgDecoder.cpp
  • SVGIMAGE_DEFAULT_HEIGHT : SvgImage.hpp
  • SVGIMAGE_DEFAULT_WIDTH : SvgImage.hpp
  • SwapBytes() : SimAuxHandler.cpp
  • SwapRequestRejected : Types.hpp
  • SwitchCongestion : SignalTypes.hpp
  • SynchFailure : SignalTypes.hpp
  • SYNCML : apoxi.features
  • SYNCML_DATABASE_MAX : SyncMLManager.hpp
  • SyncML_MsgTypes_hpp : MsgTypes.hpp
  • SyncMLChangeType : SyncMLManager.hpp
  • SyncMLItemAdded : SyncMLManager.hpp
  • SyncMLItemDeleted : SyncMLManager.hpp
  • SyncMLItemDeletedAll : SyncMLManager.hpp
  • SyncMLItemModified : SyncMLManager.hpp
  • SyncMLSyncType : DBService.hpp
  • SystemColor : Color.hpp
  • SystemColorId : Color.hpp
  • SystemFontId : Font.hpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • T9 : apoxi.features
  • T9HandleRequest() : T9Wrapper.cpp
  • T9HandleRequest_Chinese() : ChineseT9Wrapper.hpp, ChineseT9Wrapper.cpp
  • T9LdbData : AcacTypes.hpp
  • T9PACK_ID : AcacTypes.hpp
  • T9PackData : AcacTypes.hpp
  • T9ReadLdbData_Chinese() : ChineseT9Wrapper.cpp
  • T9ThaiMatrixModeWindowInterface_hpp : T9ThaiMatrixModeWindowInterface.hpp
  • T_PB_DATA : UsimPbTypes.hpp
  • T_PB_LINK_TYPE : UsimPbTypes.hpp
  • T_PB_LOCATION : UsimPbTypes.hpp
  • T_PB_REF : UsimPbTypes.hpp
  • T_PB_SIGNAL_TYPE : UsimPbTypes.hpp
  • TAlphaIdentifier : SimTkTypes.hpp
  • Task : Nuc32.hpp
  • tCallbackFnPtr : EmServThreadMsg.hpp
  • tdiffhour : DrmRelXml.hpp
  • tdiffmin : DrmRelXml.hpp
  • tEAADevice : EmApoxiAudioDeviceImpl.cpp
  • TeleAndBearerServices : SignalTypes.hpp
  • Telephony : SignalTypes.hpp
  • TeleService : SignalTypes.hpp
  • tEmApoxiAudioState : EmApoxiAudioDeviceImpl.cpp
  • TempForbiddenCallAttempt : SignalTypes.hpp
  • TempForbiddenCallAttemptLimitedServe : SignalTypes.hpp
  • TempForbiddenCallAttemptNoService : SignalTypes.hpp
  • TEMPORARY_USED : StillCamera.cpp
  • TemporaryDefaultAllowed : SignalTypes.hpp
  • TemporaryDefaultRestricted : SignalTypes.hpp
  • TemporaryFailure : SignalTypes.hpp
  • TerminateByUser : SimTkTypes.hpp
  • Test_PbSelectGroup_hpp : PbSelectGroup.hpp
  • Test_PbSelectNoType_hpp : PbSelectNoType.hpp
  • test_theme : TestTheme.hpp, TestTheme.cpp
  • TestAtKeyParser() : AtKeyParser.hpp, AtKeyParser.cpp
  • TestBit() : Types.hpp
  • TESTEN_DEBUG : StillCamera.cpp
  • TestHeaps() : HeapManager.hpp, HeapManager.cpp
  • TESTING : apoxi.features
  • testMessageType : SocketTestT.hpp
  • TestMimeCoding() : MimeCoding.cpp
  • TextAlign : TextFormat.hpp
  • TextAttr : TextFormat.hpp
  • TEXTPACK_ID : AcacTypes.hpp
  • TEXTPACK_KEYLANG_INDEX : AcacTypes.hpp
  • TextPackData : AcacTypes.hpp
  • ThirdGeneration : NetworkTypes.hpp
  • ThirdPartyRootPublicKey : SimAuxHandler.hpp
  • thour : DrmRelXml.hpp
  • THREAD_DATA_SEM_OBTAIN : Thread.cpp
  • THREAD_DATA_SEM_RELEASE : Thread.cpp
  • ThreadDataIndex : Win32.hpp
  • ThreadId : Thread.hpp
  • ThreadName : Win32.hpp, Nuc32.hpp
  • ThreadPriority : Win32.hpp, Nuc32.hpp
  • TI_PD : LcsTypes.hpp
  • TimeFormat : Time.hpp
  • timer_id : RealTimeClock.cpp
  • TIMER_SEM_INFINITE : Semaphore.cpp
  • TimerList : Timer.hpp
  • TimeType : DataItem.hpp
  • Tipd : SignalTypes.hpp
  • TLLVector : TextList.hpp
  • TlvAtom : Tlv.hpp
  • tmin : DrmRelXml.hpp
  • Toc : Tlv.hpp
  • TocCloseChannel : Tlv.hpp
  • TocDisplayText : Tlv.hpp
  • TocEndOfProactiveSession : Tlv.hpp
  • TocGetChannelStatus : Tlv.hpp
  • TocGetInkey : Tlv.hpp
  • TocGetInput : Tlv.hpp
  • TocGetReaderStatus : Tlv.hpp
  • TocInvalid : Tlv.hpp
  • TocLanguageNotification : Tlv.hpp
  • TocLaunchBrowser : Tlv.hpp
  • TocMoreTime : Tlv.hpp
  • TocOpenChannel : Tlv.hpp
  • TocPerformCardApdu : Tlv.hpp
  • TocPlayTone : Tlv.hpp
  • TocPollingOff : Tlv.hpp
  • TocPollIntervall : Tlv.hpp
  • TocPowerOffCard : Tlv.hpp
  • TocPowerOnCard : Tlv.hpp
  • TocProvideLocalInformation : Tlv.hpp
  • TocReceiveData : Tlv.hpp
  • TocRefresh : Tlv.hpp
  • TocRunAtCommand : Tlv.hpp
  • TocSelectItem : Tlv.hpp
  • TocSendData : Tlv.hpp
  • TocSendDtmf : Tlv.hpp
  • TocSendShortMessage : Tlv.hpp
  • TocSendSs : Tlv.hpp
  • TocSendUssd : Tlv.hpp
  • TocSetupCall : Tlv.hpp
  • TocSetUpEventList : Tlv.hpp
  • TocSetupIdleModeText : Tlv.hpp
  • TocSetupMenu : Tlv.hpp
  • TocTimerManagement : Tlv.hpp
  • ToDoApp_hpp : ToDoApp.hpp
  • ToDoComposeWin_hpp : ToDoComposeWin.hpp
  • ToDoDialogWin_hpp : ToDoDialogWin.hpp
  • TOK_END_CDATA : parsifal.cpp
  • TOK_END_COMMENT : parsifal.cpp
  • TOK_END_DTD : parsifal.cpp
  • TOK_END_PI : parsifal.cpp
  • TOK_GT : parsifal.cpp
  • TOK_LT : parsifal.cpp
  • TOK_XMLNS : parsifal.cpp
  • ToneAudioDevice_hpp : ToneAudioDevice.hpp
  • TonesOff : SignalTypes.hpp
  • top : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • TopReachedRepaintHint : Grid.hpp
  • ToProfile() : BtUtility.hpp, BtUtility.cpp
  • ToResultCode() : BtUtility.hpp, BtUtility.cpp
  • TpduCountType : SimPduHandler.hpp
  • Tr() : LanguageManager.hpp, LanguageManager.cpp
  • TRACE1LN : VideoCamera.cpp
  • TRACE2LN : VideoCamera.cpp
  • TRACE3LN : VideoCamera.cpp
  • TRACE4LN : VideoCamera.cpp
  • TRACE_APOXI_AUDIO_CRITICAL_SECTION : AudioPriorityManager.cpp
  • TRACE_APOXI_AUDIO_EVENT_HANDLING : AudioPriorityManager.cpp
  • TRACE_APOXI_AUDIO_PM_LOGIC : AudioPriorityManager.cpp
  • TRACE_HOST_NAME : InternalTracer.cpp
  • TRACE_HPP : Trace.hpp
  • TRACE_PORT : InternalTracer.cpp
  • TraceDataHelper() : FunctionTracer.hpp
  • TRACELN : VideoCamera.cpp
  • Tracer : Trace.hpp
  • TransactionFailed : SignalTypes.hpp
  • TranscationNotSupported : SignalTypes.hpp
  • TransformRatToUsimAct() : NetworkTypes.hpp
  • TransformUsimActToRat() : NetworkTypes.hpp
  • TRANSITION_MAP_ENTRY : StateMachine.hpp
  • TranslateAacFormatType() : EmApoxiCodecUtils.cpp
  • TranslateApplicationCategoriesFlagsType() : EmApoxiCodecUtils.cpp
  • TranslateAudioDecoderDecodingFctType() : EmApoxiCodecUtils.cpp
  • TranslateAudioDecoderParameterType() : EmApoxiCodecUtils.cpp
  • TranslateCodecResultType() : EmApoxiCodecUtils.cpp
  • TranslateCodecType() : EmApoxiCodecUtils.cpp
  • TranslateLocationType() : EmApoxiCodecUtils.cpp
  • TranslateMimeType() : EmApoxiMimeTypeTable.cpp
  • TranslateMmfModeType() : EmApoxiUtilities.cpp
  • TranslatePlayerState() : EmApoxiUtilities.cpp
  • TranslateRecorderState() : EmApoxiUtilities.cpp
  • TranslateVideoDecoderFlagsType() : EmApoxiCodecUtils.cpp
  • TranslateVideoDecoderParameterType() : EmApoxiCodecUtils.cpp
  • TranslateVideoEncoderCodingType() : EmApoxiCodecUtils.cpp
  • TranslateVideoEncoderParameterType() : EmApoxiCodecUtils.cpp
  • TranslationTable : AcacTypes.hpp
  • TransparentFile : SignalTypes.hpp
  • TrapCB : Trap.hpp
  • TriggerKeyFeature_hpp : TriggerKeyFeature.hpp
  • TRUE : Types.hpp
  • tsec : DrmRelXml.hpp
  • TSiIconID : SimTkTypes.hpp
  • TSiUrl : SimTkTypes.hpp
  • TTY : apoxi.features
  • Tty45_5 : Types.hpp
  • Tty50_0 : Types.hpp
  • TtyAuto : Types.hpp
  • TtyHco : Types.hpp
  • TtyMode : Types.hpp
  • TtyModeUnknown : Types.hpp
  • TtyOff : Types.hpp
  • TtySpeed : Types.hpp
  • TtySpeedUnknown : Types.hpp
  • TtyVco : Types.hpp
  • TwoStopBits : LcsTypes.hpp
  • TwoWaySync : DBService.hpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • Uarfcn : NetworkTypes.hpp
  • UartBaudRate : LcsTypes.hpp
  • UartDataBits : LcsTypes.hpp
  • UartFlowControl : LcsTypes.hpp
  • UartParity : LcsTypes.hpp
  • UartStopBits : LcsTypes.hpp
  • Ubd115200 : LcsTypes.hpp
  • Ubd19200 : LcsTypes.hpp
  • Ubd230400 : LcsTypes.hpp
  • Ubd2400 : LcsTypes.hpp
  • Ubd38400 : LcsTypes.hpp
  • Ubd460800 : LcsTypes.hpp
  • Ubd4800 : LcsTypes.hpp
  • Ubd57600 : LcsTypes.hpp
  • Ubd921600 : LcsTypes.hpp
  • Ubd9600 : LcsTypes.hpp
  • ubyte : FatSim.hpp
  • UcAbortByUser : NetworkTypes.hpp
  • UcAttachService : NetworkTypes.hpp
  • UcDetachService : NetworkTypes.hpp
  • UcDisableService : NetworkTypes.hpp
  • UcEnableService : NetworkTypes.hpp
  • UCHAR : InternalTracer.cpp, WinInc.hpp
  • UcInvalidSim : NetworkTypes.hpp
  • UcNotAllowed : NetworkTypes.hpp
  • UcNotPossible : NetworkTypes.hpp
  • UcPowerDown : NetworkTypes.hpp
  • UcUserReselection : NetworkTypes.hpp
  • UdbEight : LcsTypes.hpp
  • UdbFive : LcsTypes.hpp
  • UdbSeven : LcsTypes.hpp
  • UdbSix : LcsTypes.hpp
  • UdpSocketExtn_hpp : ExtndUdpSocket.hpp
  • UfcHardware : LcsTypes.hpp
  • UfcNone : LcsTypes.hpp
  • UfcXonXoff : LcsTypes.hpp
  • UibInboxTest_hpp : UibInboxTest.hpp
  • UibNotifyTest_hpp : UibNotifyTest.hpp
  • UibPerformanceTest_hpp : UibPerformanceTest.hpp
  • UibSettingsProvider_hpp : UibSettingsProvider.hpp
  • UibSettingsTest_hpp : UibSettingsTest.hpp
  • UibSortingTest_hpp : UibSortingTest.hpp
  • UibUpdateThreadlet_hpp : UibUpdateThreadlet.hpp
  • UIBVERSION : UibVersion.hpp
  • UibVersion_hpp : UibVersion.hpp
  • UINT : WinInc.hpp, NucInc.hpp
  • UINT16 : WinInc.hpp, NucInc.hpp
  • UINT32 : WinInc.hpp, NucInc.hpp
  • UInt32ToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • UINT8 : WinInc.hpp, NucInc.hpp
  • UIntToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • ulong : FfsSim.hpp, FatSim.hpp
  • ULONG : WinInc.hpp
  • UmtsCell : NetworkTypes.hpp
  • UmtsNotRanked : NetworkTypes.hpp
  • UmtsRanked : NetworkTypes.hpp
  • UmtsSignalQualityMax : SignalTypes.hpp
  • UmtsSignalStrengthMax : SignalTypes.hpp
  • UnassignedNumber : SignalTypes.hpp
  • UnblockingBlocked : SignalTypes.hpp
  • Undefined : SignalTypes.hpp
  • UndefinedCallEstCause : SignalTypes.hpp
  • UndefinedOperation : SignalTypes.hpp
  • UndefinedRefreshType : SignalTypes.hpp
  • UndefinedSsActionType : InputAction.hpp
  • UndefinedType : DataItem.hpp
  • UnexpectedIe : SignalTypes.hpp
  • UnexpectedMsgType : SignalTypes.hpp
  • UnexpectedResult : Types.hpp
  • UnicodeFromUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeGetUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeIndexToOffset() : Unicode.hpp, Unicode.cpp
  • UnicodeLastUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeNextUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeOffsetToIndex() : Unicode.hpp, Unicode.cpp
  • UnicodePreviousUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodePutUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeStrcmp() : Unicode.hpp, Unicode.cpp
  • UnicodeStringWidth() : Unicode.hpp, Unicode.cpp
  • UnicodeStrlen() : Unicode.hpp, Unicode.cpp
  • UnicodeStrncmp() : Unicode.hpp, Unicode.cpp
  • UnicodeStrncpy() : Unicode.hpp, Unicode.cpp
  • UnicodeStrstr() : Unicode.hpp, Unicode.cpp
  • UnicodeToUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeUtf8Strchr() : Unicode.hpp, Unicode.cpp
  • UnicodeUtf8Strlen() : Unicode.hpp, Unicode.cpp
  • UnicodeUtf8Validate() : Unicode.hpp, Unicode.cpp
  • UnifiedInbox_UibActionAccessor_hpp : UibActionAccessor.hpp
  • UnifiedInbox_UibApp_hpp : UibApp.hpp
  • UnifiedInbox_UibFolderWin_hpp : UibFolderWin.hpp
  • UnifiedInbox_UibInboxProvider_hpp : UibInboxProvider.hpp
  • UnifiedInbox_UibListBoxModel_hpp : UibListBoxModel.hpp
  • UnifiedInbox_UibMsgTypes_hpp : UibMsgTypes.hpp
  • UnifiedInbox_UibServiceImpl_hpp : UibServiceImpl.hpp
  • UnifiedInbox_UibSettingsWin_hpp : UibSettingsWin.hpp
  • UnifiedInbox_UibTestControl_hpp : UibTestControl.hpp
  • UnifiedInobx_UibMsgDisplayTest_hpp : UibMsgDisplayTest.hpp
  • UNITTEST : apoxi.features
  • UnitTest_MsgTypes_hpp : MsgTypes.hpp
  • UnitTestMacros_hpp : UnitTestMacros.hpp
  • UnknowMsgType1 : SignalTypes.hpp
  • UnknownCugIndex : SignalTypes.hpp
  • UnknownDiagnosticCause : SignalTypes.hpp
  • UnknownErrorCause : SignalTypes.hpp
  • UnknownMsgType2 : SignalTypes.hpp
  • UnknownSerivceGroup : SignalTypes.hpp
  • UnkownServiceInd : SignalTypes.hpp
  • UnkownSsCode : SignalTypes.hpp
  • UNLOCK_PDP_CONTEXT_HANDLER : PdpContextManager.hpp
  • UnlockActionType : InputAction.hpp
  • UnlockedDbgOut() : HeapManager.cpp
  • UnreadSmsFilterType : SimPduHandler.hpp
  • UnrestrictedOperation : SignalTypes.hpp
  • UnsentSmsFilterType : SimPduHandler.hpp
  • UnspecifedRc : Types.hpp
  • Unsuccessfull : SignalTypes.hpp
  • Unused() : Macros.hpp
  • UNZ_BADZIPFILE : Unzip.hpp
  • UNZ_CRCERROR : Unzip.hpp
  • UNZ_END_OF_LIST_OF_FILE : Unzip.hpp
  • UNZ_EOF : Unzip.hpp
  • UNZ_ERRNO : Unzip.hpp
  • UNZ_INTERNALERROR : Unzip.hpp
  • UNZ_MAXFILENAMEINZIP : Unzip.hpp
  • UNZ_OK : Unzip.hpp
  • UNZ_PARAMERROR : Unzip.hpp
  • UrrcParamReq : NetworkTypes.hpp
  • UrrcTestCountReq : NetworkTypes.hpp
  • USB : apoxi.features
  • USBVERSION : UsbVersion.hpp
  • UsbVersion_hpp : UsbVersion.hpp
  • UserAlertingNoAnser : SignalTypes.hpp
  • UserBusy : SignalTypes.hpp
  • UserCause : NetworkTypes.hpp
  • UserClearedDownCallBeforeConnectionOrNetworkRelease : SimTkTypes.hpp
  • UserDefinedActionType : InputAction.hpp
  • UserDidNotAcceptCallSetupRequest : SimTkTypes.hpp
  • UserDisconnetion : Types.hpp
  • UserNotInCug : SignalTypes.hpp
  • UserResumed : SignalTypes.hpp
  • UserSuspended : SignalTypes.hpp
  • ushort : FatSim.hpp
  • USIMAP_ALPHA_LEN : SignalTypes.hpp
  • USIMAP_LANG_LIST_LEN : SignalTypes.hpp
  • USIMAP_PLMN_LIST_LEN : NetworkTypes.hpp
  • USIMAP_SERVICE_TABLE_LEN : SignalTypes.hpp
  • UsimLangDefault : SignalTypes.hpp
  • UsimLangFileType : SignalTypes.hpp
  • UsimPbAas : UsimPbTypes.hpp
  • UsimPbAddType : UsimPbTypes.hpp
  • UsimPbAnr : UsimPbTypes.hpp
  • UsimPbApplication : UsimPbTypes.hpp
  • UsimPbBufferIsNull : UsimPbTypes.hpp
  • UsimPbBufferTooSmall : UsimPbTypes.hpp
  • UsimPbCcp1 : UsimPbTypes.hpp
  • UsimPbDataTypeMismatch : UsimPbTypes.hpp
  • UsimPbEmail : UsimPbTypes.hpp
  • UsimPbExt1 : UsimPbTypes.hpp
  • UsimPbGas : UsimPbTypes.hpp
  • UsimPbGlobal : UsimPbTypes.hpp
  • UsimPbIndication : UsimPbTypes.hpp
  • UsimPbInvalidAdd : UsimPbTypes.hpp
  • UsimPbInvalidRef : UsimPbTypes.hpp
  • UsimPbLinkType : UsimPbTypes.hpp
  • UsimPbLocation : UsimPbTypes.hpp
  • UsimPbNoFreeRecord : UsimPbTypes.hpp
  • UsimPbNotExisting : UsimPbTypes.hpp
  • UsimPbNotLoaded : UsimPbTypes.hpp
  • UsimPbNotLocated : UsimPbTypes.hpp
  • UsimPbNotSel : UsimPbTypes.hpp
  • UsimPbNotSelected : UsimPbTypes.hpp
  • UsimPbRefRefresh : UsimPbTypes.hpp
  • UsimPbRefresh : UsimPbTypes.hpp
  • UsimPbRefType : UsimPbTypes.hpp
  • UsimPbResponse : UsimPbTypes.hpp
  • UsimPbResult : UsimPbTypes.hpp
  • UsimPbSignalType : UsimPbTypes.hpp
  • UsimPbSim : UsimPbTypes.hpp
  • UsimPbSkipped : UsimPbTypes.hpp
  • UsimPbSne : UsimPbTypes.hpp
  • UsimPbSuccessful : UsimPbTypes.hpp
  • UsimPbSuccessfulUid : UsimPbTypes.hpp
  • UsimPbTechnicalProblem : UsimPbTypes.hpp
  • UsimPbTooFewExtRecs : UsimPbTypes.hpp
  • UsimPbType1 : UsimPbTypes.hpp
  • UsimPbType2 : UsimPbTypes.hpp
  • UsimPbType3 : UsimPbTypes.hpp
  • UsimPbUndefined : UsimPbTypes.hpp
  • UsimPbWrongDataType : UsimPbTypes.hpp
  • UsimPbWrongHandle : UsimPbTypes.hpp
  • UsimPbWrongLocation : UsimPbTypes.hpp
  • UsimPbWrongRecNumber : UsimPbTypes.hpp
  • UsimPbWrongRefRecord : UsimPbTypes.hpp
  • UsimPbWrongStructure : UsimPbTypes.hpp
  • UsimPhonebook : Types.hpp
  • UsimReadNull : SignalTypes.hpp
  • UsimReadType : SignalTypes.hpp
  • UsimUpdateAction : SignalTypes.hpp
  • UsimUpdateInsert : SignalTypes.hpp
  • Ussd : SignalTypes.hpp
  • UssdActionType : InputAction.hpp
  • UssdHandlerId : HandlerId.hpp
  • UssdOrSsTransactionTerminatedByUser : SimTkTypes.hpp
  • UssdReturnError : SimTkTypes.hpp
  • UssdTransactionError : Types.hpp
  • UstTableIndexes : SstProvider.hpp
  • UTF8_2charS : parsifal.cpp
  • UTF8_3charS : parsifal.cpp
  • UTF8_4charS : parsifal.cpp
  • UTF8_COMPUTE : Unicode.hpp
  • UTF8_GET : Unicode.hpp
  • Utf8FromUnicode() : Unicode.hpp, Unicode.cpp
  • Utf8ToUnicode() : Unicode.hpp, Unicode.cpp
  • Utf8Validator() : parsifal.cpp
  • UTTcpSocket_hpp : UTTcpSocket.hpp
  • UUS : apoxi.features
  • UusInTextType : SignalTypes.hpp
  • UusOutTextType : SignalTypes.hpp
  • UusService1 : SignalTypes.hpp
  • UusService2 : SignalTypes.hpp
  • UusService3 : SignalTypes.hpp
  • UxgaSize_INDEX : Camera.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • ValueItem : ValueItem.hpp
  • VAR_HEAP_CONTEXT_VECTOR : HeapVector.hpp
  • VAR_HEAP_PAGE : HeapVector.hpp
  • VAR_HEAP_SIZE_VECTOR : HeapVector.hpp
  • VarPageTest() : HeapManager.cpp
  • VbsEfPos : SimTkTypes.hpp
  • VbssEfPos : SimTkTypes.hpp
  • Vector_Append() : vector.cpp
  • Vector_Create() : vector.cpp
  • Vector_Free() : vector.cpp
  • Vector_Resize() : vector.cpp
  • VerificationResponse : LcsDecls.hpp
  • Verified : SignalTypes.hpp
  • VerifyLocAllowedNoResp : LcsTypes.hpp
  • VerifyLocNotAllowedNoResp : LcsTypes.hpp
  • Vertical : Grid.hpp
  • VgaSize_INDEX : Camera.cpp
  • VgcsEfPos : SimTkTypes.hpp
  • VgcssEfPos : SimTkTypes.hpp
  • VIB : apoxi.features
  • VIB_init() : vib_drv.cpp
  • VIB_pause() : vib_drv.cpp
  • VIB_start() : vib_drv.cpp
  • VIB_status() : vib_drv.cpp
  • VIB_stop() : vib_drv.cpp
  • VIDEO_ENCODER_MAX_CONFIG_STREAM_SIZE : AtiMpeg4Encoder.cpp
  • VideoCaptureParameters_hpp : VideoCaptureParameters.hpp
  • ViHzCache1EfPos : SimTkTypes.hpp
  • ViHzCache2EfPos : SimTkTypes.hpp
  • ViHzCache3EfPos : SimTkTypes.hpp
  • ViHzCache4EfPos : SimTkTypes.hpp
  • ViHzParamEfPos : SimTkTypes.hpp
  • VIRTUAL_HEAP_ENTRY : HeapVector.hpp
  • VirtualActiveSet : NetworkTypes.hpp
  • VmRetCode : HostAudioDriver.hpp
  • VoiceBroadcastService : SignalTypes.hpp
  • VoiceGroupCallService : SignalTypes.hpp
  • VoiceMemoAudioDevice_hpp : VoiceMemoAudioDevice.hpp
  • VOICERECOGNITION : apoxi.features
  • VoiceRecognition_MsgTypes_hpp : MsgTypes.hpp
  • VOICEVERSION : VoiceMemoVersion.hpp
  • VoiceVersion_hpp : VoiceMemoVersion.hpp
  • VoidAction : MsgArgs.hpp
  • VoidCallIndex : Types.hpp
  • VoidCallType : SignalTypes.hpp
  • VoidCause : SignalTypes.hpp
  • VoidCliRestriction : SignalTypes.hpp
  • VoidDiagnostic : SignalTypes.hpp
  • VoidHoldInd : SignalTypes.hpp
  • VoidOverride : SignalTypes.hpp
  • VoidSsCode : SignalTypes.hpp
  • Volume : SignalTypes.hpp
  • VOLUME_STEPS : FmRadioWindow.hpp
  • VrAudioError : VrTypes.hpp
  • VrBufferOvervlow : VrTypes.hpp
  • VrBusy : VrTypes.hpp
  • VrErrorCode : VrTypes.hpp
  • VrG2AEmptyBufferError : VrTypes.hpp
  • VrG2AExecutionError : VrTypes.hpp
  • VrG2AInitMemoryError : VrTypes.hpp
  • VrG2AParamRangeError : VrTypes.hpp
  • VrInitTimeout : VrTypes.hpp
  • VrInputTruncated : VrTypes.hpp
  • VrInvalidRecogParam : VrTypes.hpp
  • VrInvalidTrainParam : VrTypes.hpp
  • VrLoadTemplateError : VrTypes.hpp
  • VrNoTemplate : VrTypes.hpp
  • VrProperty : VrTypes.hpp
  • VrRecogAbort : VrTypes.hpp
  • VrRecogBuffer : VrTypes.hpp
  • VrRecogMemoryError : VrTypes.hpp
  • VrRecogPromptTimeout : VrTypes.hpp
  • VrRefExceed : VrTypes.hpp
  • VrSequenceError : VrTypes.hpp
  • VrStoreTemplateError : VrTypes.hpp
  • VrStoreTimeout : VrTypes.hpp
  • VrTemplateResponseTimeout : VrTypes.hpp
  • VrTrainAbort : VrTypes.hpp
  • VrTrainMemoryError : VrTypes.hpp
  • VrTrainPromptTimeOut : VrTypes.hpp
  • VrUndiffTemplate : VrTypes.hpp
  • VrWarningCode : VrTypes.hpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- w -

  • W_LATIN_AMPERSAND : Latin.hpp
  • W_LATIN_APOSTROPHE : Latin.hpp
  • W_LATIN_ASTERISK : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_A : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_B : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_C : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_D : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_E : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_F : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_G : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_H : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_I : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_J : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_K : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_L : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_M : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_N : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_O : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_P : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_Q : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_R : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_S : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_T : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_U : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_V : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_W : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_X : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_Y : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_Z : Latin.hpp
  • W_LATIN_CIRCUMFLEX_ACCENT : Latin.hpp
  • W_LATIN_COLON : Latin.hpp
  • W_LATIN_COMMA : Latin.hpp
  • W_LATIN_COMMERCIAL_AT : Latin.hpp
  • W_LATIN_CR : Latin.hpp
  • W_LATIN_DIGIT_EIGHT : Latin.hpp
  • W_LATIN_DIGIT_FIVE : Latin.hpp
  • W_LATIN_DIGIT_FOUR : Latin.hpp
  • W_LATIN_DIGIT_NINE : Latin.hpp
  • W_LATIN_DIGIT_ONE : Latin.hpp
  • W_LATIN_DIGIT_SEVEN : Latin.hpp
  • W_LATIN_DIGIT_SIX : Latin.hpp
  • W_LATIN_DIGIT_THREE : Latin.hpp
  • W_LATIN_DIGIT_TWO : Latin.hpp
  • W_LATIN_DIGIT_ZERO : Latin.hpp
  • W_LATIN_DOLLAR_SIGN : Latin.hpp
  • W_LATIN_EQUALS_SIGN : Latin.hpp
  • W_LATIN_EXCLAMATION_MARK : Latin.hpp
  • W_LATIN_FF : Latin.hpp
  • W_LATIN_FULL_STOP : Latin.hpp
  • W_LATIN_GRAVE_ACCENT : Latin.hpp
  • W_LATIN_GREATER_THAN_SIGN : Latin.hpp
  • W_LATIN_HT : Latin.hpp
  • W_LATIN_HYPHEN_MINUS : Latin.hpp
  • W_LATIN_LEFT_CURLY_BRACKET : Latin.hpp
  • W_LATIN_LEFT_PARENTHESIS : Latin.hpp
  • W_LATIN_LEFT_SQUARE_BRACKET : Latin.hpp
  • W_LATIN_LESS_THAN_SIGN : Latin.hpp
  • W_LATIN_LF : Latin.hpp
  • W_LATIN_LOW_LINE : Latin.hpp
  • W_LATIN_NUMBER_SIGN : Latin.hpp
  • W_LATIN_PERCENT_SIGN : Latin.hpp
  • W_LATIN_PLUS_SIGN : Latin.hpp
  • W_LATIN_QUESTION_MARK : Latin.hpp
  • W_LATIN_QUOTATION_MARK : Latin.hpp
  • W_LATIN_REVERSE_SOLIDUS : Latin.hpp
  • W_LATIN_RIGHT_CURLY_BRACKET : Latin.hpp
  • W_LATIN_RIGHT_PARENTHESIS : Latin.hpp
  • W_LATIN_RIGHT_SQUARE_BRACKET : Latin.hpp
  • W_LATIN_SEMICOLON : Latin.hpp
  • W_LATIN_SMALL_LETTER_A : Latin.hpp
  • W_LATIN_SMALL_LETTER_B : Latin.hpp
  • W_LATIN_SMALL_LETTER_C : Latin.hpp
  • W_LATIN_SMALL_LETTER_D : Latin.hpp
  • W_LATIN_SMALL_LETTER_E : Latin.hpp
  • W_LATIN_SMALL_LETTER_F : Latin.hpp
  • W_LATIN_SMALL_LETTER_G : Latin.hpp
  • W_LATIN_SMALL_LETTER_H : Latin.hpp
  • W_LATIN_SMALL_LETTER_I : Latin.hpp
  • W_LATIN_SMALL_LETTER_J : Latin.hpp
  • W_LATIN_SMALL_LETTER_K : Latin.hpp
  • W_LATIN_SMALL_LETTER_L : Latin.hpp
  • W_LATIN_SMALL_LETTER_M : Latin.hpp
  • W_LATIN_SMALL_LETTER_N : Latin.hpp
  • W_LATIN_SMALL_LETTER_O : Latin.hpp
  • W_LATIN_SMALL_LETTER_P : Latin.hpp
  • W_LATIN_SMALL_LETTER_Q : Latin.hpp
  • W_LATIN_SMALL_LETTER_R : Latin.hpp
  • W_LATIN_SMALL_LETTER_S : Latin.hpp
  • W_LATIN_SMALL_LETTER_T : Latin.hpp
  • W_LATIN_SMALL_LETTER_U : Latin.hpp
  • W_LATIN_SMALL_LETTER_V : Latin.hpp
  • W_LATIN_SMALL_LETTER_W : Latin.hpp
  • W_LATIN_SMALL_LETTER_X : Latin.hpp
  • W_LATIN_SMALL_LETTER_Y : Latin.hpp
  • W_LATIN_SMALL_LETTER_Z : Latin.hpp
  • W_LATIN_SOLIDUS : Latin.hpp
  • W_LATIN_SPACE : Latin.hpp
  • W_LATIN_TILDE : Latin.hpp
  • W_LATIN_VERTICAL_LINE : Latin.hpp
  • W_LATIN_VT : Latin.hpp
  • W_LATIN_ZERO : Wsprintf.cpp, StrPrintf.cpp
  • WaitSsActionType : InputAction.hpp
  • WAP : LcsTypes.hpp
  • WapHandler_hpp : WapHandler.hpp
  • WapProfile_hpp : WapProfile.hpp
  • WapProfileId : WapProfile.hpp
  • WapProfileMgr_hpp : WapProfileMgr.hpp
  • wav : Audio.cpp
  • Wav : aud_drv.cpp
  • wav_out : Audio.cpp
  • WbDigitValue() : WStrUtil.hpp, WStrUtil.cpp
  • WC_CAN_NULL_PTR : WildcardStrncmp.hpp
  • WC_CAN_TOO_SHORT : WildcardStrncmp.hpp
  • WC_MATCH : WildcardStrncmp.hpp
  • WC_MISMATCH : WildcardStrncmp.hpp
  • WC_PAT_NULL_PTR : WildcardStrncmp.hpp
  • WC_PAT_TOO_SHORT : WildcardStrncmp.hpp
  • WC_QUES : WildcardStrncmp.hpp
  • WC_STAR : WildcardStrncmp.hpp
  • wc_strncmp() : WildcardStrncmp.hpp, WildcardStrncmp.cpp
  • wc_strncmp< CHAR >() : WildcardStrncmp.cpp, AuxiliaryTemplates.cpp
  • wc_strncmp< WCHAR >() : WildcardStrncmp.cpp, AuxiliaryTemplates.cpp
  • WCBType : WCattr.hpp
  • WCBTypeAL : WCattr.hpp
  • WCBTypeAN : WCattr.hpp
  • WCBTypeB : WCattr.hpp
  • WCBTypeBN : WCattr.hpp
  • WCBTypeCS : WCattr.hpp
  • WCBTypeEN : WCattr.hpp
  • WCBTypeES : WCattr.hpp
  • WCBTypeET : WCattr.hpp
  • WCBTypeL : WCattr.hpp
  • WCBTypeLRE : WCattr.hpp
  • WCBTypeLRO : WCattr.hpp
  • WCBTypeNSM : WCattr.hpp
  • WCBTypeON : WCattr.hpp
  • WCBTypePDF : WCattr.hpp
  • WCBTypeR : WCattr.hpp
  • WCBTypeRLE : WCattr.hpp
  • WCBTypeRLO : WCattr.hpp
  • WCBTypeS : WCattr.hpp
  • WCBTypeWS : WCattr.hpp
  • WCHAR : WinInc.hpp, NucInc.hpp
  • WCharStrToLower() : WStrUtil.hpp, WStrUtil.cpp
  • WCharStrToUpper() : WStrUtil.hpp, WStrUtil.cpp
  • WCharToLower() : WStrUtil.hpp, WCattr.cpp
  • WCharToUpper() : WStrUtil.hpp, WCattr.cpp
  • WCType : WCattr.hpp
  • WCTypeCc : WCattr.hpp
  • WCTypeCf : WCattr.hpp
  • WCTypeCn : WCattr.hpp
  • WCTypeCo : WCattr.hpp
  • WCTypeCs : WCattr.hpp
  • WCTypeLl : WCattr.hpp
  • WCTypeLm : WCattr.hpp
  • WCTypeLo : WCattr.hpp
  • WCTypeLt : WCattr.hpp
  • WCTypeLu : WCattr.hpp
  • WCTypeMc : WCattr.hpp
  • WCTypeMe : WCattr.hpp
  • WCTypeMn : WCattr.hpp
  • WCTypeNd : WCattr.hpp
  • WCTypeNl : WCattr.hpp
  • WCTypeNo : WCattr.hpp
  • WCTypePc : WCattr.hpp
  • WCTypePd : WCattr.hpp
  • WCTypePe : WCattr.hpp
  • WCTypePf : WCattr.hpp
  • WCTypePi : WCattr.hpp
  • WCTypePo : WCattr.hpp
  • WCTypePs : WCattr.hpp
  • WCTypeSc : WCattr.hpp
  • WCTypeSk : WCattr.hpp
  • WCTypeSm : WCattr.hpp
  • WCTypeSo : WCattr.hpp
  • WCTypeZl : WCattr.hpp
  • WCTypeZp : WCattr.hpp
  • WCTypeZs : WCattr.hpp
  • WdDigitValue() : WStrUtil.hpp, WStrUtil.cpp
  • WDecompose() : WCattr.hpp, WCattr.cpp
  • WhereAmI : LcsFeatTypes.hpp
  • while() : DrawChar_16Bpp.cpp
  • WildcardValue : PhoneNumber.hpp
  • WIN32_DeleteFile : WinInc.hpp
  • WIN32_MessageBox : WinInc.hpp
  • WIN32_MoveFile : WinInc.hpp
  • WIsComposed() : WCattr.hpp, WCattr.cpp
  • WIsUnicode() : WCattr.hpp, WCattr.cpp
  • withoutme : SampleIMelodies.hpp, SampleIMelodies.cpp
  • withoutme_size : SampleIMelodies.hpp
  • WithTextNoIcon : NetworkTypes.hpp
  • WithTextWithIcon : NetworkTypes.hpp
  • WminusSign() : WStrUtil.hpp, WStrUtil.cpp
  • WoDigitValue() : WStrUtil.hpp, WStrUtil.cpp
  • word : FfsSim.hpp
  • wow : SampleImages.hpp, SampleImages.cpp
  • wow_size : SampleImages.hpp
  • WrapPolicy : EditorDocument.hpp
  • WRITE_STATE : TestWriter.hpp
  • write_text_sample : FfsTests.cpp
  • WriteErr : FfsTestError.hpp
  • WRITESTATE : TestWriter.hpp
  • WrongPlmn : NetworkTypes.hpp
  • WrongSimKeyboardAllowed() : SimChvHandler.cpp
  • WrongSimStartupAllowed() : SimChvHandler.cpp
  • WStrCat() : WStrUtil.hpp, WStrUtil.cpp
  • WStrChr() : WStrUtil.hpp, WStrUtil.cpp
  • WStrCmp() : WStrUtil.hpp, WStrUtil.cpp
  • WStrCpy() : WStrUtil.hpp, WStrUtil.cpp
  • wstring_max_buffer_size : WString.hpp
  • WStringAccessOperatorTest() : WString.cpp
  • WStringAccessTest() : WString.cpp
  • WStringAssignmentOperators() : WString.cpp
  • WStringCompareOperatorTest() : WString.cpp
  • WStringConstructorTest() : WString.cpp
  • WStringFindTest() : WString.cpp
  • WStringFormatTest() : WString.cpp
  • WStringManipulationTest() : WString.cpp
  • WStringStreamOperators() : WString.cpp
  • WStringTest() : WString.hpp, WString.cpp
  • WStringType : DataItem.hpp
  • WStrLen() : WStrUtil.hpp, WStrUtil.cpp
  • WStrnCat() : WStrUtil.hpp, WStrUtil.cpp
  • WStrnCmp() : WStrUtil.hpp, WStrUtil.cpp
  • WStrnCpy() : WStrUtil.hpp, WStrUtil.cpp
  • WStrPrINTD() : WStrUtil.cpp
  • WStrPrintD() : WStrUtil.hpp
  • wstrprintf() : WStrUtil.hpp, Wsprintf.cpp
  • WStrPrintf() : WStrUtil.hpp, Wsprintf.cpp
  • WStrrChr() : WStrUtil.hpp, WStrUtil.cpp
  • WStrrStr() : WStrUtil.hpp, WStrUtil.cpp
  • WStrrStrn() : WStrUtil.hpp, WStrUtil.cpp
  • wstrscanf() : WStrUtil.hpp, Wsscanf.cpp
  • WStrScanf() : WStrUtil.hpp, Wsscanf.cpp
  • WStrStr() : WStrUtil.hpp, WStrUtil.cpp
  • WStrStrn() : WStrUtil.hpp, WStrUtil.cpp
  • WStrToInt() : WStrUtil.hpp, WStrUtil.cpp
  • WStrToInt32() : WStrUtil.hpp, WStrUtil.cpp
  • WStrToStr() : WStrUtil.hpp, WStrUtil.cpp
  • WType() : WCattr.hpp, WCattr.cpp
  • WxDigit() : WStrUtil.hpp, WStrUtil.cpp
  • WxDigitValue() : WStrUtil.hpp, WStrUtil.cpp
  • WXStrCmp() : WStrUtil.hpp, WStrUtil.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- x -

  • x_start : ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • x_start_dest : ScrollHorizontal_Planes.cpp
  • x_stop : ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • x_stop_dest : ScrollHorizontal_Planes.cpp
  • XaocCharging : MmTypes.hpp
  • XaocInformation : MmTypes.hpp
  • XaocServiceState : MmTypes.hpp
  • XCallStat : MmTypes.hpp
  • XCallStatActive : MmTypes.hpp
  • XCallStatDialling : MmTypes.hpp
  • XCallStatDisconnected : MmTypes.hpp
  • XCallStatHold : MmTypes.hpp
  • XCallStatMOAlerting : MmTypes.hpp
  • XCallStatMtRinging : MmTypes.hpp
  • XCallStatMtWaiting : MmTypes.hpp
  • XgaSize_INDEX : Camera.cpp
  • xlen : ScrollVertical_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp
  • xml_MemAlloc() : utils.cpp
  • xml_MemFree() : utils.cpp
  • xml_strdup() : utils.cpp
  • XMLParser_GetNamedItem() : parsifal.cpp
  • XMLParser_MiniCreate() : parsifal.cpp
  • XMLParser_MiniFree() : parsifal.cpp
  • XMLParser_Parse() : parsifal.cpp
  • XnoAoc : MmTypes.hpp
  • XSTEP : ImageBrowserDetailWin.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- y -

  • y : ScrollHorizontal_Planes.cpp, FillRect_Planes.cpp
  • y_start : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp
  • y_stop : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp
  • YAMAHA_MAPI : apoxi.features
  • years_to_days() : RealTimeClock.cpp
  • ylen : ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp
  • ymd_to_scalar() : RealTimeClock.cpp
  • YSTEP : ImageBrowserDetailWin.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- _ -

  • _Adc_BlobObject_hpp : BlobObject.hpp
  • _Adc_BlobPtr_hpp : BlobPtr.hpp
  • _Adc_BubbleSortProvider_hpp : BubbleSortProvider.hpp
  • _Adc_DataItem_hpp : DataItem.hpp
  • _Adc_FilterProvider_hpp : FilterProvider.hpp
  • _Adc_FilterRule_hpp : FilterRule.hpp
  • _Adc_Find2Provider_hpp : Find2Provider.hpp
  • _Adc_FindProvider_hpp : FindProvider.hpp
  • _Adc_FixedPtrArray_hpp : FixedPtrArray.hpp
  • _Adc_GenericObject_hpp : GenericObject.hpp
  • _Adc_IndexTable_hpp : IndexTable.hpp
  • _Adc_PhoneNumber_hpp : PhoneNumber.hpp
  • _Adc_Provider_hpp : Provider.hpp
  • _Adc_ProviderListener_hpp : ProviderListener.hpp
  • _Adc_QuickSortProvider_hpp : QuickSortProvider.hpp
  • _Adc_RegBlobObject_hpp : RegBlobObject.hpp
  • _Adc_SortProvider_hpp : SortProvider.hpp
  • _Apoxi_AuxExtensions_DualFilterProvider_hpp : DualFilterProvider.hpp
  • _Apoxi_HashTable_hpp : HashTable.hpp
  • _APOXI_Latin_Defines_h : Latin.hpp
  • _APOXI_String_hpp : String.hpp
  • _APOXI_WCAttr_h : WCattr.hpp
  • _APOXI_WCAttr_Tbl_hpp : WCattr_tbl.hpp
  • _APOXI_WString_hpp : WString.hpp
  • _APOXI_WStrutil_h : WStrUtil.hpp
  • _Asc_InputAction_hpp : InputAction.hpp
  • _Asc_InputAnalyzer_hpp : InputAnalyzer.hpp
  • _Asc_InputParser_hpp : InputParser.hpp
  • _Auxiliary_AbstractDelegationProvider_hpp : AbstractDelegationProvider.hpp
  • _Mmi_UibAccessorTest_hpp : UibAccessorTest.hpp
  • _MmiSimProtocol_h : MmiSimProtocol.hpp
  • _MSVC_CONST_FLAW : DBService.hpp
  • _pp : parsifal.cpp
  • _SLEEP : FfsTestBase.hpp
  • _WIN32_WINDOWS : WinInc.hpp
  • _WIN32_WINNT : WinInc.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- j -

  • JPEG_INTERNALS : jmemnobs_APOXI.cpp
  • JPEG_PIXEL_CHANNELS : JpegDecoder.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- k -

  • KBYTE : SocketTestDefines.hpp
  • Kernel_AbstractExternalData_hpp : AbstractExternalData.hpp
  • Kernel_Grid_hpp : Grid.hpp
  • Kernel_Lib_hpp : Lib.hpp
  • Kernel_Message_hpp : Message.hpp
  • Kernel_MsgCategory_hpp : MsgCategory.hpp
  • Kernel_MsgTypes_hpp : MsgTypes.hpp
  • KEY_FLIP_CLOSE : MiscSignalProcessor.cpp
  • KEY_FLIP_OPEN : MiscSignalProcessor.cpp
  • KEY_RELEASE : MiscSignalProcessor.cpp
  • KeyToneAudioDevice_hpp : KeyToneAudioDevice.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- l -

  • L2CA_RXMTU_GET : BtSocketAddr.hpp
  • L2CA_RXMTU_SET : BtSocketAddr.hpp
  • L2CA_TXMTU_GET : BtSocketAddr.hpp
  • L2CA_TXMTU_SET : BtSocketAddr.hpp
  • L2R : ArabicTextRenderer.cpp
  • LCS : apoxi.features
  • Lcs_LcsAppMsgTypes_hpp : LcsAppMsgTypes.hpp
  • LcsTransports_GLTP_GltpAppMsgTypes_hpp : GltpAppMsgTypes.hpp
  • LOC : Macros.hpp
  • LOC_W : Macros.hpp
  • LOCAL_BUFFER_SIZE : BtObexImpl.hpp
  • LOCK_PDP_CONTEXT_HANDLER : PdpContextManager.hpp
  • LOCK_STATE_MACHINE : StateMachine.hpp
  • LONG : WinInc.hpp, NucInc.hpp
  • LZ_BITS : GifDecoder.cpp
  • LZ_MAX_CODE : GifDecoder.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- m -

  • Main_Desktop_hpp : MainDesktop.hpp
  • MAKE_BYTE_AVAIL : GifDecoder.cpp, BmpDecoder.cpp
  • MASK_3_WAY_CALL : BtHfProfileWindows.cpp
  • MASK_CLI_PRESENTATION : BtHfProfileWindows.cpp
  • MASK_EC_NR : BtHfProfileWindows.cpp
  • MASK_REMOTE_VOLUME_CTRL : BtHfProfileWindows.cpp
  • MASK_VOICE_REC : BtHfProfileWindows.cpp
  • max : Macros.hpp
  • MAX : Wsprintf.cpp, StrPrintf.cpp
  • MAX_ARRAY_CHECK_INDEX : StillCamera.cpp
  • MAX_BANANA_HEIGHT : StillCamera.cpp
  • MAX_BANANA_WIDTH : StillCamera.cpp
  • MAX_BT_AVAILABLE_CHANNELS : BtObexImpl.hpp
  • MAX_BT_CLIENT_CHANNELS : BtObexImpl.hpp
  • MAX_BT_SERVER_CHANNELS : BtObexImpl.hpp
  • MAX_BUFFER_INFO_INDEX : StillCamera.hpp
  • MAX_CAND_BUFF_SIZE : Zi8Wrapper.hpp
  • MAX_COUNT : DrmCore.hpp
  • MAX_DATE : DrmCore.hpp
  • MAX_ELEM_BUFF_SIZE : Zi8Wrapper.hpp
  • MAX_FILE_NAME_LENGTH : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • MAX_GROUP_COUNT : PbSelectGroup.hpp
  • MAX_INDEX_FILE_SINK_ARRAY : CameraCaptureWin.hpp, CameraApp.hpp
  • MAX_INQUIRY_TIMEOUT : BtDeviceSearchRequest.cpp
  • MAX_INTERVAL : DrmCore.hpp
  • MAX_LCD_SCREEN_FORMATS : Camera.cpp
  • MAX_LENGTH_OF_BANANA_DATA_REAL : StillCamera.cpp
  • MAX_NO_OPEN_FILES : HostCoreFsSim.hpp
  • MAX_NUM_CANDIDATES : Zi8Wrapper.hpp
  • MAX_NUM_CHINESE_CANDIDATES : Zi8Wrapper.hpp
  • MAX_POOL_COUNT : BufferPoolManager.hpp
  • MAX_SIGNAL_LEVEL : MiscSignalProcessor.cpp
  • MAX_SIGNAL_QUALITY : MiscSignalProcessor.cpp
  • MAX_STROKE_COUNT : Zi8StrokeBox.hpp
  • MAX_UINT16 : Unzip.hpp
  • MAX_VOLUME_LEVEL : BtHsVolumeSettingsWin.hpp, BtHfVolumeSettingsWin.hpp
  • MAX_WORD_LENGTH_SIZE : Zi8Wrapper.hpp
  • MAX_ZOOM_LEVELS : Camera.cpp
  • MAXREQUESTLIMIT : HttpWapMgrPlugin.hpp
  • MAXSHMEMSIZE : HostAudioDriver.hpp
  • MdhInitExtendedData : MdhTypes.hpp
  • MEDIAFRAMEWORK : apoxi.features
  • MediaManager_hpp : MediaManager.hpp
  • MediaPlayer_hpp : MediaPlayer.hpp
  • MediaRecorder_hpp : MediaRecorder.hpp
  • MediaRecorderImpl_hpp : MediaRecorderImpl.hpp
  • MEM_POOL : BufferPoolManager.hpp
  • MENU_ACCESSORS : apoxi.features
  • Menu_Resource_Table_hpp : MenuResourceTable.hpp
  • MenuAccessors_MsgTypes_hpp : MsgTypes.hpp
  • MenuID_hpp : MenuID.hpp
  • MimeTypeTable_hpp : MimeTypeTable.hpp
  • MimeTypeTableUtils_hpp : MimeTypeTableUtils.hpp
  • min : Macros.hpp
  • MIN_DATE : DrmCore.hpp
  • MIN_VOLUME_LEVEL : BtHsVolumeSettingsWin.hpp, BtHfVolumeSettingsWin.hpp
  • MIN_ZOOM_LEVELS : Camera.cpp
  • MiscAudioDevice_hpp : MiscAudioDevice.hpp
  • MM_CHIP_SCICOS : apoxi.features
  • MmCallMessages_hpp__ST_1136454671281 : MmCallMessages.hpp
  • MMCI : apoxi.features
  • Mmi_AbstractSmsApp_hpp : AbstractSmsApp.hpp
  • Mmi_AbstractSmsComposeWin_hpp : AbstractSmsComposeWin.hpp
  • Mmi_AbstractSmsUtilityProcessor_hpp : AbstractSmsUtiltyProcessor.hpp
  • Mmi_AbstractSmsViewerWin_hpp : AbstractSmsViewerWin.hpp
  • Mmi_AdvPbAction_hpp : AdvPbAction.hpp
  • Mmi_AdvPbApp_hpp : AdvPbApp.hpp
  • Mmi_AdvPbWin_hpp : AdvPbWin.hpp
  • Mmi_BasicPbWin_hpp : BasicPbWin.hpp
  • Mmi_BtAvrcpPreComp_hpp : BtAvrcpPreComp.hpp
  • Mmi_BtDunAppPlugin_hpp : BtDunAppPlugin.hpp
  • Mmi_BtFaxAppPlugin_hpp : BtFaxAppPlugin.hpp
  • Mmi_BtHfAudioPathWin_hpp : BtHfAudioPathWindow.hpp
  • Mmi_BtHfPluginPreComp_hpp : PreComp.hpp
  • Mmi_BtHfProvider_hpp : BtHfProvider.hpp
  • Mmi_BtHfRecord_hpp : BtHfRecord.hpp
  • Mmi_BtHfVolumeSettingsWin_hpp : BtHfVolumeSettingsWin.hpp
  • Mmi_BtHsAppPlugin_hpp : BtHsAppPlugin.hpp
  • Mmi_BtHsVolumeSettingsWin_hpp : BtHsVolumeSettingsWin.hpp
  • Mmi_CalendarListWin_hpp : CalendarListWin.hpp
  • Mmi_CalendarRecordsList_hpp : CalendarRecordsList.hpp
  • Mmi_CalendarRecordsListBox_hpp : CalendarRecordsListBox.hpp
  • Mmi_CameraApp_hpp : CameraApp.hpp
  • Mmi_CameraCaptureWin_hpp : CameraCaptureWin.hpp
  • Mmi_CameraSettings_hpp : CameraSettings.hpp
  • Mmi_CameraViewFinderWin_hpp : CameraViewFinderWin.hpp
  • Mmi_CopyHandler_hpp : CopyHandler.hpp
  • Mmi_CsdDataConnProvider_hpp : CsdDataConnProvider.hpp
  • Mmi_DataConnApp_hpp : DataConnApp.hpp
  • Mmi_DataConnProvider_hpp : DataConnProvider.hpp
  • Mmi_DataConnTextMaps_hpp : DataConnTextMaps.hpp
  • Mmi_DistinctProvider_hpp : DistinctProvider.hpp
  • Mmi_Dynamic_MenuPool_hpp : DynamicMenuPool.hpp
  • Mmi_EmsApp_hpp : EmsApp.hpp
  • Mmi_EmsComposeWin_hpp : EmsComposeWin.hpp
  • Mmi_EmsViewerWin_hpp : EmsViewerWin.hpp
  • Mmi_EnumTextMap_hpp : EnumTextMap.hpp
  • Mmi_FmRadioApp_hpp : FmRadioApplication.hpp
  • Mmi_FmRadioSettingsProvider_hpp : FmRadioSettingsProvider.hpp
  • Mmi_FmRadioSettingsRecord_hpp : FmRadioSettingsRecord.hpp
  • Mmi_FmRadioStationsProvider_hpp : FmRadioStationsProvider.hpp
  • Mmi_FmRadioStationsRecord_hpp : FmRadioStationsRecord.hpp
  • Mmi_GltpAidingDataWin_hpp : AidingDataWin.hpp
  • Mmi_GltpConnApp_hpp : GltpConnApp.hpp
  • Mmi_GroupProvider_hpp : GroupProvider.hpp
  • Mmi_IndicatorBar_hpp : IndicatorBar.hpp
  • Mmi_IrdaApp_hpp : IrdaApp.hpp
  • Mmi_IrdaWin_hpp : IrdaWin.hpp
  • Mmi_LcsAppUtils_hpp : LcsAppUtils.hpp
  • Mmi_LcsFeatType_hpp : LcsFeatTypes.hpp
  • Mmi_LcsMainApp_hpp : LcsMainApp.hpp
  • Mmi_LcsMainMenuWin_hpp : LcsMainMenuWin.hpp
  • Mmi_LcsOptionsMenuWin_hpp : LcsOptionsMenuWin.hpp
  • Mmi_LcsRegUri_hpp : LcsRegUri.hpp
  • Mmi_LcsSettingsApp_hpp : LcsSettingsApp.hpp
  • Mmi_LcsSettingsUtils_hpp : LcsSettingsUtils.hpp
  • Mmi_LcsSocket_hpp : LcsSocket.hpp
  • Mmi_LcsWapIntf_hpp : LcsWapIntf.hpp
  • Mmi_LcsWString_hpp : LcsWString.hpp
  • Mmi_LocationResultWin_hpp : LocationResultWin.hpp
  • Mmi_LocationVerifWin_hpp : LocationVerifWin.hpp
  • Mmi_LocResController_hpp : LocResController.hpp
  • Mmi_ObexApp_hpp : ObexApp.hpp
  • Mmi_ObexTransportWin_hpp : ObexTransportWin.hpp
  • Mmi_PbAbstractWin_hpp : PbAbstractWin.hpp
  • Mmi_PbAction_hpp : PbAction.hpp
  • Mmi_PbAdvAddEditEntry_hpp : PbAdvAddEditEntry.hpp
  • Mmi_PbAdvDataHandler_hpp : PbAdvDataHandler.hpp
  • Mmi_PbAdvDetails_hpp : PbAdvDetails.hpp
  • Mmi_PbBaseWin_hpp : PbBaseWin.hpp
  • Mmi_PbConfig_hpp : PbConfig.hpp
  • Mmi_PbDataHandler_hpp : PbDataHandler.hpp
  • Mmi_PbDetail_ListBox_hpp : PbDetailListBox.hpp
  • Mmi_PbDetailFilterProvider_hpp : PbDetailFilterProvider.hpp
  • Mmi_PbDetails_hpp : PbDetails.hpp
  • Mmi_PbFfsNameHandler_hpp : PbFfsNameHandler.hpp
  • Mmi_PbFfsNumberHandler_hpp : PbFfsNumberHandler.hpp
  • Mmi_PbLazySynchronizer_hpp : PbLazySynchronizer.hpp
  • Mmi_PbManualSynchronizer_hpp : PbManualSynchronizer.hpp
  • Mmi_PbMergeProvider_hpp : PbMergeProvider.hpp
  • Mmi_PbNameEditBox_hpp : PbNameEditBox.hpp
  • Mmi_PbNameFilterProvider_hpp : PbNameFilterProvider.hpp
  • Mmi_PbNameHandler_hpp : PbNameHandler.hpp
  • Mmi_PbNameNumberProvider_hpp : PbNameNumberProvider.hpp
  • Mmi_PbNameProvider_hpp : PbNameProvider.hpp
  • Mmi_PbNextFreeIdRecord_hpp : PbNextFreeIdRecord.hpp
  • Mmi_PbNumberHandler_hpp : PbNumberHandler.hpp
  • Mmi_PbNumberProvider_hpp : PbNumberProvider.hpp
  • Mmi_PbNvRamNameHandler_hpp : PbNvRamNameHandler.hpp
  • Mmi_PbNvRamNumberHandler_hpp : PbNvRamNumberHandler.hpp
  • Mmi_PbPhoneNumberPrompt_hpp : PbPhoneNumberPrompt.hpp
  • Mmi_PbProvider_hpp : PbProviderListener.hpp
  • Mmi_PbProvIds_hpp : PbProvIds.hpp
  • Mmi_PbProvListBox_hpp : PbProvListBox.hpp
  • Mmi_PbRecord_hpp : PbRecord.hpp
  • Mmi_PbRecordHandler_hpp : PbRecordHandler.hpp
  • Mmi_PbRecordProvider_hpp : PbRecordProvider.hpp
  • Mmi_PbSelectNumberWin_hpp : PbSelectNumberWin.hpp
  • Mmi_PbSimProvider_hpp : PbSimProvider.hpp
  • Mmi_PbSortedProvider_hpp : PbSortedProvider.hpp
  • Mmi_PbSynchronizer_hpp : PbSynchronizer.hpp
  • Mmi_PbTypes_hpp : PbTypes.hpp
  • Mmi_PhonebookApp_hpp : PhonebookApp.hpp
  • Mmi_PhoneNumberMatchRule_hpp : PhoneNumberMatchRule.hpp
  • Mmi_ProvListBoxWin_hpp : ProvListBoxWin.hpp
  • Mmi_PsdDataConnProvider_hpp : PsdDataConnProvider.hpp
  • Mmi_RegApp_hpp : RegApp.hpp
  • Mmi_RegAppCommon_hpp : RegAppCommon.hpp
  • Mmi_RegAppFirstWin_hpp : RegAppFirstWin.hpp
  • Mmi_RegAppWin_hpp : RegAppWin.hpp
  • Mmi_RegEncoderDecoder_hpp : RegEncoderDecoder.hpp
  • Mmi_ResultWinBase_hpp : ResultWinBase.hpp
  • Mmi_SatteliteGraphWin_hpp : SatteliteGraphWin.hpp
  • Mmi_SatteliteInfoWin_hpp : SatteliteInfoWin.hpp
  • Mmi_SavingProgressWin_hpp : SavingProgressWin.hpp
  • Mmi_SelfLocationDialogWin_hpp : SelfLocationDialogWin.hpp
  • Mmi_SerDataConnProvider_hpp : SerDataConnProvider.hpp
  • Mmi_ServerAddressWin_hpp : ServerAddressWin.hpp
  • Mmi_SettingsProvider_hpp : SettingsProvider.hpp
  • Mmi_SmsAlerts_hpp : SmsAlerts.hpp
  • Mmi_SmsApp_hpp : SmsApp.hpp
  • Mmi_SmsBasicProvider_hpp : SmsBasicProvider.hpp
  • Mmi_SmsComposeWin_hpp : SmsComposeWin.hpp
  • Mmi_SmsEditor_hpp : SmsEditor.hpp
  • Mmi_SmsFolderProvider_hpp : SmsFolderProvider.hpp
  • Mmi_SmsIndicationState_hpp : SmsIndicationState.hpp
  • Mmi_SmsSendingConfirmDialog_hpp : SmsSendingConfirmDialog.hpp
  • Mmi_SmsService_hpp : SmsService.hpp
  • Mmi_SmsSettingsProvider_hpp : SmsSettingsProvider.hpp
  • Mmi_SmsSettingsRecord_hpp : SmsSettingsRecord.hpp
  • Mmi_SmsTemplateProvider_hpp : SmsTemplateProvider.hpp
  • Mmi_SmsTextMaps_hpp : SmsTextMaps.hpp
  • Mmi_SmsTextParser_hpp : SmsTextParser.hpp
  • Mmi_SmsUtility_hpp : SmsUtility.hpp
  • Mmi_SmsViewerWin_hpp : SmsViewerWin.hpp
  • Mmi_SyncPhoneThreadlet_hpp : SyncPhoneThreadlet.hpp
  • Mmi_ToDoListWin_hpp : ToDoListWin.hpp
  • Mmi_ToDoProvider_hpp : ToDoProvider.hpp
  • Mmi_ToDoRecord_hpp : ToDoRecord.hpp
  • Mmi_TransferLocationDialogWin_hpp : TransferLocationDialogWin.hpp
  • Mmi_UibSettingsRecord_hpp : UibSettingsRecord.hpp
  • Mmi_UpdatePbThreadlet_hpp : UpdatePbThreadlet.hpp
  • Mmi_UsbApp_hpp : UsbApp.hpp
  • Mmi_VoiceMemoApp_hpp : VoiceMemoApp.hpp
  • Mmi_VoiceMemoMenuAccessor_hpp : VoiceMemoMenuAccessor.hpp
  • Mmi_VoiceMemoPreComp_hpp : VoiceMemoPreComp.hpp
  • Mmi_VoiceMemoRecordWin_hpp : VoiceMemoRecordWin.hpp
  • Mmi_VoiceMemoWin_hpp : VoiceMemoWin.hpp
  • MMISIM_ENV_VAR_DISABLE : MmiSimProtocol.hpp
  • MMISIM_ENV_VAR_HOST : MmiSimProtocol.hpp
  • MMISIM_ENV_VAR_PORT : MmiSimProtocol.hpp
  • MMISIM_LOCALHOST : MmiSimProtocol.hpp
  • MMISIM_MASK_ALT : MmiSimProtocol.hpp
  • MMISIM_MASK_CTRL : MmiSimProtocol.hpp
  • MMISIM_MASK_NONE : MmiSimProtocol.hpp
  • MMISIM_MASK_SHIFT : MmiSimProtocol.hpp
  • MMISIM_PORT : MmiSimProtocol.hpp
  • MMISIM_PORT_RANGE : MmiSimProtocol.hpp
  • MP3 : apoxi.features
  • Mp3AudioDevice_hpp : Mp3AudioDevice.hpp
  • MP3BLOCKSIZE : HostAudioDriver.cpp
  • MSFS : apoxi.features
  • MsgClass : MsgClass.hpp
  • MsgTypes_hpp__ST_1092996111155 : MsgTypes.hpp
  • MsgTypes_hpp__ST_1122019187332 : MsgTypes.hpp
  • MULTIMEDIA : apoxi.features
  • MultiMedia_AbstractIMelodyParser_hpp : AbstractIMelodyParser.hpp
  • MultiMedia_AmrSound_hpp : AmrSound.hpp
  • MultiMedia_AudioContext_hpp : AudioContext.hpp
  • MultiMedia_IMelody_hpp : IMelody.hpp
  • MultiMedia_Melody_hpp : Melody.hpp
  • MultiMedia_MidiSound_hpp : MidiSound.hpp
  • MultiMedia_PreparedSound_hpp : PreparedSound.hpp
  • MultiMedia_SmafSound_hpp : SmafSound.hpp
  • MULTIPART_COMMENT : MultipartParser.hpp
  • MULTIPART_CR : MultipartParser.hpp
  • MULTIPART_ERROR_CONTENT_PARSING : MultipartParser.hpp
  • MULTIPART_ERROR_FILE_FORMAT : MultipartParser.hpp
  • MULTIPART_ERROR_HEADER_PARSING : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_BOUNDARY : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_END : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_INPUT : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_START : MultipartParser.hpp
  • MULTIPART_ERROR_INVALID_VALUE : MultipartParser.hpp
  • MULTIPART_ERROR_NO_HEADER : MultipartParser.hpp
  • MULTIPART_ERROR_NO_MEMORY : MultipartParser.hpp
  • MULTIPART_ERROR_REACHED_EOF : MultipartParser.hpp
  • MULTIPART_ERROR_UNKNOWN : MultipartParser.hpp
  • MULTIPART_ERROR_VALUE_NOT_FOUND : MultipartParser.hpp
  • MULTIPART_LF : MultipartParser.hpp
  • MULTIPART_SPACE : MultipartParser.hpp
  • MULTIPART_SUCCESS : MultipartParser.hpp
  • MULTIPART_TAB : MultipartParser.hpp
  • MULTIPLIKATOR : StillCamera.cpp
  • MultiTabInputMapper : MultiTabInputMapper.hpp
  • MutexObtainer_hpp : MutexObtainer.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- n -

  • NAI_HEADER_SIZE : NativeImage.cpp
  • NAI_META_DATA_SIZE : NativeImage.cpp
  • NET_INITIALIZED : LwipSysSocket.cpp
  • NET_PPP_IN_USE : LwipSysSocket.cpp
  • NET_PPP_STOP : LwipSysSocket.cpp
  • NET_SOCKET_TYPE_SMS : SimTkTypes.hpp
  • NET_SOCKET_TYPE_TCP : SimTkTypes.hpp
  • NET_SOCKET_TYPE_UDP : SimTkTypes.hpp
  • NEW_HEIGHT_JPEG : StillCamera.cpp
  • NEW_JPEG_QUALITY : StillCamera.cpp
  • NEW_WIDTH_JPEG : StillCamera.cpp
  • NMAX : RingBuffer.cpp
  • NO_CHECK_BYTES : HeapVector.hpp
  • no_cols : CalendarGrid.hpp
  • NO_FRAME_RATE_SUB : StillCamera.cpp
  • NO_MEMBER_TEMPLATES : NiSharedPtr.hpp
  • NO_OF_PICTURE_FOR_SINGLE_SHOT : StillCamera.cpp
  • NO_OF_PICTURES_EMPTY : StillCamera.cpp
  • no_rows : CalendarGrid.hpp
  • NO_SUCH_CODE : GifDecoder.cpp
  • NOT_AVAILALBE : BtAvrcpControllerApplicationWindows.cpp
  • NOT_USEABLE : Camera.cpp
  • NULL_VALUE : Zi8Wrapper.hpp
  • NVRAM_IN_FILE : NvRam.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- o -

  • OBEX : apoxi.features
  • OBEX_BUFFER_MAX_SIZE : BtObexImpl.hpp
  • OBEX_HANDLE_MSG : ObexDispatcher.cpp
  • OBEX_HEADER_SIZE : BtObexImpl.hpp
  • Obex_ObexAppMsg_hpp : ObexAppMsg.hpp
  • Obex_ObexMessages_hpp : ObexMessages.hpp
  • Obex_ObexTransportMsg_hpp : ObexTransportMsg.hpp
  • Obex_ObexVCardMsg_hpp : ObexVCardMsg.hpp
  • ObexAppVersion_hpp : ObexAppVersion.hpp
  • OBEXFTP_RFS : apoxi.features
  • OBEXVERSION : ObexAppVersion.hpp
  • ONLINE_RENDER_FILE_VERSION : ResourceManager.cpp
  • OUTPUT_BUF_SIZE : PngEncoder.cpp, JpegEncoder.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- z -

  • ZI8 : apoxi.features
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • A_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • Action : WinInc.hpp
  • Adc_AlphaCoding_hpp : AlphaCoding.hpp
  • Adc_AuxProvider_hpp : AuxProvider.hpp
  • Adc_BaseDataHandler_hpp : BaseDataHandler.hpp
  • Adc_CbmiProvider_hpp : CbmiProvider.hpp
  • Adc_CbmiRangeProvider_hpp : CbmiRangeProvider.hpp
  • Adc_ChvProvider_hpp : ChvProvider.hpp
  • Adc_CmiProvider_hpp : CmiProvider.hpp
  • Adc_CompoundSmsItem_hpp : CompoundSmsItem.hpp
  • Adc_CountryProvider_hpp : CountryProvider.hpp
  • Adc_CphsAuxProvider_hpp : CphsAuxProvider.hpp
  • Adc_CphsServPflProvider_hpp : CphsServPflProvider.hpp
  • Adc_DataHandler_hpp : DataHandler.hpp
  • Adc_EccProvider_hpp : EccProvider.hpp
  • Adc_FfsFile_hpp : FfsFile.hpp
  • Adc_FfsHandler_hpp : FfsHandler.hpp
  • Adc_Lib_hpp : Lib.hpp
  • Adc_LockProvider_hpp : LockProvider.hpp
  • Adc_MbiProvider_hpp : MbiProvider.hpp
  • Adc_MsgTypes_hpp : MsgTypes.hpp
  • Adc_PbBaseProvider_hpp : PbBaseProvider.hpp
  • Adc_PlmnProvider_hpp : PlmnProvider.hpp
  • Adc_PrefExtLangProvider_hpp : PrefExtLangProvider.hpp
  • Adc_PrefLangProvider_hpp : PrefLangProvider.hpp
  • Adc_PrefPlmnProvider_hpp : PrefPlmnProvider.hpp
  • Adc_ProvIds_hpp : ProvIds.hpp
  • Adc_SimAccessor_hpp : SimAccessor.hpp
  • Adc_SimAuxHandler_hpp : SimAuxHandler.hpp
  • Adc_SimChvHandler_hpp : SimChvHandler.hpp
  • Adc_SimCphsHandler_hpp : SimCphsHandler.hpp
  • Adc_SimPbBaseHandler_hpp : SimPbBaseHandler.hpp
  • Adc_SimPbEntry_hpp : SimPbEntry.hpp
  • Adc_SimPbEntryCont_hpp : SimPbEntryCont.hpp
  • Adc_SimPduHandler_hpp : SimPduHandler.hpp
  • Adc_SimSmsParamHandler_hpp : SimSmsParamHandler.hpp
  • Adc_SimTkCommands_hpp : SimTkCommands.hpp
  • Adc_SimTkMainMenuProvider_hpp : SimTkMainMenuProvider.hpp
  • Adc_SmsArchiveProvider_hpp : SmsBaseArchiveProvider.hpp
  • Adc_SmsBaseUnreadProvider_hpp : SmsBaseUnreadProvider.hpp
  • Adc_SmsClass0Provider_hpp : SmsClass0Provider.hpp
  • Adc_SmsInboxProvider_hpp : SmsBaseInboxProvider.hpp
  • Adc_SmsInfoelements_hpp : SmsInfoElements.hpp
  • Adc_SmsOutboxProvider_hpp : SmsBaseOutboxProvider.hpp
  • Adc_SmsParamProvider_hpp : SmsParamProvider.hpp
  • Adc_SmsProvider_hpp : SmsProvider.hpp
  • Adc_SmsReadProvider_hpp : SmsReadProvider.hpp
  • Adc_SmsSentProvider_hpp : SmsSentProvider.hpp
  • Adc_SmsStatusReportProvider_hpp : SmsBaseStatusReportProvider.hpp
  • Adc_SmsUnreadProvider_hpp : SmsUnreadProvider.hpp
  • Adc_SmsUnsentProvider_hpp : SmsUnsentProvider.hpp
  • Adc_SstProvider_hpp : SstProvider.hpp
  • Adc_StatusProvider_hpp : StatusProvider.hpp
  • Adc_Types_hpp : Types.hpp
  • Adc_UsimPbAcessor_hpp : UsimPbAccessor.hpp
  • Adc_UsimPbAddData_hpp : UsimPbAddData.hpp
  • Adc_UsimPbCommit_hpp : UsimPbCommit.hpp
  • Adc_UsimPbEntry_hpp : UsimPbEntry.hpp
  • Adc_UsimPbEntryCont_hpp : UsimPbEntryCont.hpp
  • Adc_UsimPbHandler_hpp : UsimPbHandler.hpp
  • Adc_UsimPbPropertyProvider_hpp : UsimPbPropertyProvider.hpp
  • Adc_UsimPbProvider_hpp : UsimPbProvider.hpp
  • Adc_UsimPbXasProvider_hpp : UsimPbXasProvider.hpp
  • ADDITIONAL_THEMES : apoxi.features
  • AddOn_MmCall_Types_hpp : MmTypes.hpp
  • AddOns_AuxExtensions_ObjectObtainer_hpp : ObjectObtainer.hpp
  • AddOns_Lcs_3GPP_LcsArgs_hpp : LcsArgs.hpp
  • AddOns_Lcs_3GPP_LcsMsgProcessor_hpp : LcsMsgProcessor.hpp
  • AddOns_Lcs_3GPP_LcsProviderImpl_hpp : LcsProviderImpl.hpp
  • AddOns_Lcs_3GPP_LcsSignalMapTable_hpp : LcsSignalMapTableNode.hpp
  • AddOns_Lcs_3GPP_LcsSignalProcessor_hpp : LcsSignalProcessor.hpp
  • AddOns_Lcs_3GPP_LcsStackMsgArgs_hpp : LcsStackMsgArgs.hpp
  • AddOns_Lcs_Common_LcsCommonArgs_hpp : LcsCommonArgs.hpp
  • AddOns_Lcs_Common_LcsCommonMsgProcessor_hpp : LcsCommonMsgProcessor.hpp
  • AddOns_Lcs_Common_LcsCommonMsgTypes_hpp : LcsCommonMsgTypes.hpp
  • AddOns_Lcs_Common_LcsCommonSignalMapTableNode_hpp : LcsCommonSignalMapTableNode.hpp
  • AddOns_Lcs_Common_LcsCommonSignalProcessor_hpp : LcsCommonSignalProcessor.hpp
  • AddOns_Lcs_Common_LcsCommonStackMsgArgs_hpp : LcsCommonStackMsgArgs.hpp
  • AddOns_Lcs_Common_LcsDecls_hpp : LcsDecls.hpp
  • AddOns_Lcs_Common_LcsProvider_hpp : LcsProvider.hpp
  • AddOns_Lcs_Common_LcsProviderImplBase_hpp : LcsProviderImplBase.hpp
  • AddOns_Lcs_Common_LcsRepeatTimer_hpp : LcsRepeatTimer.hpp
  • AddOns_Lcs_Common_LcsReqProcessor_hpp : LcsReqProcessor.hpp
  • AddOns_Lcs_Common_LcsTimer_hpp : LcsTimer.hpp
  • AddOns_Lcs_Common_LcsTypes_hpp : LcsTypes.hpp
  • AddOns_Lcs_Common_LcsUtils_hpp : LcsUtils.hpp
  • AddOns_Lcs_GLTP_AidDataRequests_hpp : AidDataRequests.hpp
  • AddOns_Lcs_GLTP_AssistanceData_hpp : AssistanceData.hpp
  • AddOns_Lcs_GLTP_GltpArgs_hpp : GltpArgs.hpp
  • AddOns_Lcs_GLTP_GltpMsgTypes_hpp : GltpMsgTypes.hpp
  • AddOns_Lcs_GLTP_GltpProviderImpl_hpp : GltpProviderImpl.hpp
  • AddOns_Lcs_GLTP_GltpSignalMapTable_hpp : GltpSignalMapTableNode.hpp
  • AddOns_Lcs_GLTP_GltpSignalProcessor_hpp : GltpSignalProcessor.hpp
  • AddOns_Lcs_GLTP_GltpStackMsgArgs_hpp : GltpStackMsgArgs.hpp
  • AddOns_Lcs_GLTP_GltpTypes_hpp : GltpTypes.hpp
  • AddOns_Lcs_GLTP_MsgProcessor_hpp : GltpMsgProcessor.hpp
  • AddOns_Lcs_StandAlone_SaArgs_hpp : SaArgs.hpp
  • AddOns_Lcs_StandAlone_SaMsgProcessor_hpp : SaMsgProcessor.hpp
  • AddOns_Lcs_StandAlone_SaProviderImpl_hpp : SaProviderImpl.hpp
  • AddOns_Lcs_StandAlone_SaSignalMapTable_hpp : SaSignalMapTableNode.hpp
  • AddOns_Lcs_StandAlone_SaSignalProcessor_hpp : SaSignalProcessor.hpp
  • AddOns_Lcs_StandAlone_SaStackMsgArgs_hpp : SaStackMsgArgs.hpp
  • AddOns_Lib_hpp : Lib.hpp
  • AddOns_MmCall_SerialTerminalArg_hpp : SerialTerminalArg.hpp
  • AddOns_MmCall_SerialTerminalMsgArgs_hpp : SerialTerminalMsgArgs.hpp
  • AddOns_MultiMedia_Sound_hpp : Sound.hpp
  • AddOns_Server_FtpServer_MsgTypes_hpp : MsgTypes.hpp
  • AddOns_Server_HttpServer_MsgTypes_hpp : MsgTypes.hpp
  • AddOns_StreamObexImpl_hpp : StreamObexImpl.hpp
  • AddOns_Svg_MsgTypes_hpp : MsgTypes.hpp
  • AddOns_Translation_EnumTranslationTable_hpp : EnumTranslationTable.hpp
  • AddOns_Translation_Lib_hpp : Lib.hpp
  • AddOns_Translation_ValueTextMap_hpp : ValueTextMap.hpp
  • AddOns_Usb_UsbObexAddress_hpp : UsbObexServerAddress.hpp
  • AddOns_Usb_UsbSubSystem_hpp : UsbSubSystem.hpp
  • AddOns_Usb_UsbTransport_hpp : UsbTransport.hpp
  • AddOns_VoiceRecognition_DummyVrEngineParams_hpp : DummyVrEngineParams.hpp
  • AddOns_VoiceRecognition_TelecaVrEngineParams_hpp : TelecaVrEngineParams.hpp
  • AddOns_VoiceRecognition_VrConfig_hpp : VrConfig.hpp
  • AddOns_VoiceRecognition_VrData_hpp : VrData.hpp
  • AddOns_VoiceRecognition_VrEngineParams_hpp : VrEngineParams.hpp
  • AddOns_VoiceRecognition_VrHandler_hpp : VrHandler.hpp
  • AddOns_VoiceRecognition_VrHostController_hpp : VrHostController.hpp
  • AddOns_VoiceRecognition_VrStackMsgArgs_hpp : VrStackMsgArgs.hpp
  • AddOns_VoiceRecognition_VrStackMsgArgTable_hpp : VrStackMsgArgTable.hpp
  • AddOns_VoiceRecognition_VrTypes_hpp : VrTypes.hpp
  • ADIRENT : FatSim.hpp
  • ADLER_JUPITER : FfsTestBase.hpp
  • AesCryptInterface_hpp : AesCryptInterface.hpp
  • Afs_AfsMsgTypes_hpp : AfsMsgTypes.hpp
  • AFSFAT : apoxi.features
  • AFSFFS : apoxi.features
  • AFSRAM : apoxi.features
  • AFSRFS : apoxi.features
  • AHIDDEN : FatSim.hpp
  • AmplifierAudioDevice_hpp : AmplifierAudioDevice.hpp
  • AMR_FILEPLAY_FRAMENUM : HostAudioDriver.hpp
  • AMR_FILEREC_FRAMENUM : HostAudioDriver.hpp
  • ANORMAL : FatSim.hpp
  • APBVERSION : ApbVersion.hpp
  • ApbVersion_hpp : ApbVersion.hpp
  • Apc_Accessory_hpp : Accessory.hpp
  • Apc_AtcStackMsgArgs_hpp : AtcStackMsgArgs.hpp
  • Apc_AtcTypes_hpp : AtcTypes.hpp
  • Apc_AudioErrorMsg_hpp : AudioErrorMsg.hpp
  • Apc_AudioMsg_hpp : AudioMsg.hpp
  • Apc_AudioStoppedMsg_hpp : AudioStoppedMsg.hpp
  • Apc_AudioSuspendedMsg_hpp : AudioSuspendedMsg.hpp
  • Apc_AudioTypes_hpp : AudioTypes.hpp
  • Apc_AudioVoiceMemoOutOfSpaceMsg_hpp : AudioVoiceMemoOutOfSpaceMsg.hpp
  • Apc_BaseInformationElement_hpp : BaseInformationElement.hpp
  • Apc_CallMiscStackMsgArgs_hpp : CallMiscStackMsgArgs.hpp
  • Apc_Cbs_hpp : Cbs.hpp
  • Apc_CbsStackMsgArgs_hpp : CbsStackMsgArgs.hpp
  • Apc_CdStackMsgArgs_hpp : CdStackMsgArgs.hpp
  • Apc_ChvStackMsgArgs_hpp : ChvStackMsgArgs.hpp
  • Apc_CommandType_hpp : CommandType.hpp
  • Apc_Common_Conversion_hpp : Conversion.hpp
  • Apc_CommonStackMsgArgs_hpp : CommonStackMsgArgs.hpp
  • Apc_CrssStackMsgArgs_hpp : CrssStackMsgArgs.hpp
  • Apc_DataCoding_hpp : DataCoding.hpp
  • Apc_DataCodingScheme_hpp : DataCodingScheme.hpp
  • Apc_Gprs_PdpTypes_hpp : PdpTypes.hpp
  • Apc_Gprs_SimLockTypes_hpp : SimLockTypes.hpp
  • Apc_Gprs_SimMiscTypes_hpp : SimMiscTypes.hpp
  • Apc_Gsm97_MdhTypes_hpp : MdhTypes.hpp
  • Apc_ImageData_hpp : ImageData.hpp
  • Apc_ImageStackMsgArgs_hpp : ImageStackMsgArgs.hpp
  • Apc_InformationElement_hpp : InformationElement.hpp
  • Apc_KeyMsgGenerator_hpp : KeyMsgGenerator.hpp
  • Apc_Lib_hpp : Lib.hpp
  • Apc_LockTypes_hpp : LockTypes.hpp
  • Apc_MdhSmsStackMsgArgs_hpp : MdhSmsStackMsgArgs.hpp
  • Apc_MessageIdentifier_hpp : MessageIdentifier.hpp
  • Apc_MessageTypeIndicator_hpp : MessageTypeIndicator.hpp
  • Apc_MiscStackMsgArgs_hpp : MiscStackMsgArgs.hpp
  • Apc_MocStackMsgArgs_hpp : MocStackMsgArgs.hpp
  • Apc_MtcStackMsgArgs_hpp : MtcStackMsgArgs.hpp
  • Apc_NetworkStackMsgArgs_hpp : NetworkStackMsgArgs.hpp
  • Apc_NetworkTypes_hpp : NetworkTypes.hpp
  • Apc_OmStackMsgArgs_hpp : OmStackMsgArgs.hpp
  • Apc_ParameterIndicator_hpp : ParameterIndicator.hpp
  • Apc_PhoneBookStackMsgArgs_hpp : PhoneBookStackMsgArgs.hpp
  • Apc_PlmnScanList_hpp : PlmnScanList.hpp
  • Apc_PlmnStackMsgArgs_hpp : PlmnStackMsgArgs.hpp
  • Apc_PowerStackMsgArgs_hpp : PowerStackMsgArgs.hpp
  • Apc_ProtocolIdentifier_hpp : ProtocolIdentifier.hpp
  • Apc_ShortMessageFailureCause_hpp : ShortMessageFailureCause.hpp
  • Apc_ShortMessageStatus_hpp : ShortMessageStatus.hpp
  • Apc_SignalHandler_AtKeyParser_hpp : AtKeyParser.hpp
  • Apc_SignalHandler_CommonSignalMapTable_hpp : CommonSignalMapTableNode.hpp
  • Apc_SignalHandler_CommonSignalProcessor_hpp : CommonSignalProcessor.hpp
  • Apc_SignalHandler_CommonStackMsgMapTable_hpp : CommonStackMsgMapTableNode.hpp
  • Apc_SignalHandler_CommonStackMsgProcessor_hpp : CommonStackMsgProcessor.hpp
  • Apc_SignalHandler_Lib_hpp : Lib.hpp
  • Apc_SignalHandler_ProcessNode_hpp : ProcessNode.hpp
  • Apc_SignalHandler_SignalHandler_hpp : SignalHandler.hpp
  • Apc_SignalHandler_SignalMapTable_hpp : SignalMapTable.hpp
  • Apc_SignalHandler_SignalMapTableEntry_hpp : SignalMapTableEntry.hpp
  • Apc_SignalHandler_SignalMapTableNode_hpp : SignalMapTableNode.hpp
  • Apc_SignalHandler_StackMsgMapTable_hpp : StackMsgMapTable.hpp
  • Apc_SignalHandler_StackMsgMapTableEntry_hpp : StackMsgMapTableEntry.hpp
  • Apc_SignalHandler_StackMsgMapTableNode_hpp : StackMsgMapTableNode.hpp
  • Apc_SignalHandler_StackMsgProcessor_hpp : StackMsgProcessor.hpp
  • Apc_SignalHandler_StackTranslator_hpp : StackTranslator.hpp
  • Apc_SignalTypes_hpp : SignalTypes.hpp
  • Apc_SimDataTypes_hpp : SimDataTypes.hpp
  • Apc_SimMiscStackMsgArgs_hpp : SimMiscStackMsgArgs.hpp
  • Apc_SimTkStackMsgArgs_hpp : SimTkStackMsgArgs.hpp
  • Apc_SimTkTypes_hpp : SimTkTypes.hpp
  • Apc_Sms_hpp : Sms.hpp
  • Apc_SmsStackMsgArgs_hpp : SmsStackMsgArgs.hpp
  • Apc_SsErrorCode_hpp : SsErrorCode.hpp
  • Apc_SsNotification_hpp : SsNotification.hpp
  • Apc_SsStackMsgArgs_hpp : SsStackMsgArgs.hpp
  • Apc_SsStatus_hpp : SsStatus.hpp
  • Apc_StackInterface_hpp : StackInterface.hpp
  • Apc_StackMsgArgument_hpp : StackMsgArgument.hpp
  • Apc_StackWrapper_hpp : StackWrapper.hpp
  • Apc_StreamOperators_hpp : StreamOperators.hpp
  • Apc_TaggedProblemCode_hpp : TaggedProblemCode.hpp
  • Apc_Tlv_hpp : Tlv.hpp
  • Apc_Tpdu_hpp : Tpdu.hpp
  • Apc_UserData_hpp : UserData.hpp
  • Apc_UsimPbTypes_hpp : UsimPbTypes.hpp
  • Apc_ValidityPeriod_hpp : ValidityPeriod.hpp
  • APOXI_3D_AMPLIFIER_SUPPORT : apoxi.defines
  • APOXI_3GPP_REL_4_5 : apoxi.defines
  • APOXI_3GPP_REL_99 : apoxi.defines
  • Apoxi_AbstractActionMenuAccessor_hpp : AbstractActionMenuAccessor.hpp
  • Apoxi_AbstractButton_hpp : AbstractButton.hpp
  • Apoxi_AbstractDevice_hpp : AbstractDevice.hpp
  • Apoxi_AbstractEditBox_hpp : AbstractEditBox.hpp
  • Apoxi_AbstractEditor_hpp : AbstractEditor.hpp
  • Apoxi_AbstractEditorItem_hpp : AbstractEditorItem.hpp
  • Apoxi_AbstractGrid_hpp : AbstractGrid.hpp
  • Apoxi_AbstractItemContainer_hpp : AbstractItemContainer.hpp
  • Apoxi_AbstractItemGrid_hpp : AbstractItemGrid.hpp
  • Apoxi_AbstractItemRenderer_hpp : AbstractItemRenderer.hpp
  • Apoxi_AbstractLineEditor_hpp : AbstractLineEditor.hpp
  • Apoxi_AbstractListBox_hpp : AbstractListBox.hpp
  • Apoxi_AbstractLockableDevice_hpp : AbstractLockableDevice.hpp
  • Apoxi_AbstractMenuAccessor_hpp : AbstractMenuAccessor.hpp
  • Apoxi_AbstractMenuList_hpp : AbstractMenuList.hpp
  • Apoxi_AbstractMultiLineEditor_hpp : AbstractMultiLineEditor.hpp
  • Apoxi_AbstractPredictiveInputBox_hpp : AbstractPredictiveInputBox.hpp
  • Apoxi_AbstractRenderer_hpp : AbstractRenderer.hpp
  • Apoxi_AbstractScheduler_hpp : AbstractScheduler.hpp
  • Apoxi_AbstractTextObject_hpp : AbstractTextObject.hpp
  • Apoxi_AbstractTextRenderer_hpp : AbstractTextRenderer.hpp
  • Apoxi_AbstractToggleAction_hpp : AbstractToggleAction.hpp
  • Apoxi_AbstractTransport_hpp : AbstractTransport.hpp
  • Apoxi_AcacLanguage_hpp : AcacLanguage.hpp
  • Apoxi_AcacTypes_hpp : AcacTypes.hpp
  • Apoxi_AccessorAction_hpp : AccessorAction.hpp
  • Apoxi_AccessorActionExtension_hpp : AccessorActionExtension.hpp
  • Apoxi_Action_hpp : Action.hpp
  • Apoxi_ActionExtension_hpp : ActionExtension.hpp
  • Apoxi_ActionMenuAccessor_hpp : ActionMenuAccessor.hpp
  • Apoxi_ActiveWaitDispatcher_hpp : ActiveWaitDispatcher.hpp
  • APOXI_ADC_CCP_CODE : apoxi.defines
  • APOXI_ADC_SIMTK_PROACTIVE_CODE : apoxi.defines
  • Apoxi_AdcExtensions_DataRecord_hpp : DataRecord.hpp
  • Apoxi_AdcExtensions_DataRecordHandler_hpp : DataRecordHandler.hpp
  • Apoxi_AdcExtensions_DcsLanguageFilterRule_hpp : DcsLanguageFilterRule.hpp
  • Apoxi_AdcExtensions_LanguageCodeRes_hpp : LanguageCodeRes.hpp
  • Apoxi_AdcExtensions_LanguageProvider_hpp : LanguageProvider.hpp
  • Apoxi_AdcExtensions_NvRam_hpp : NvRam.hpp
  • Apoxi_AdcExtensions_NvRamDataRecordHandler_hpp : NvRamDataRecordHandler.hpp
  • Apoxi_AdcExtensions_NvRamStorage_hpp : NvRamStorage.hpp
  • Apoxi_AdcExtensions_ProviderIds_hpp : ProviderIds.hpp
  • Apoxi_AdcExtensions_Record_hpp : Record.hpp
  • Apoxi_AdcExtensions_RecordHandler_hpp : RecordHandler.hpp
  • APOXI_ADD_MIME_TYPE_DEFS : MimeTypeTable.cpp, MimeTypeTableUtils.hpp
  • APOXI_ADDITIONAL_THEMES_SUPPORT : apoxi.defines
  • Apoxi_AddOns_MmCallHdl_hpp : MmCallHdl.hpp
  • Apoxi_AddOns_Server_AuthProvider_hpp : AuthProvider.hpp
  • Apoxi_AddOns_Server_FtpAuthProvider_hpp : FtpAuthProvider.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpClient_hpp : FtpClient.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpDataServerSocket_hpp : FtpDataServerSocket.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpDataSocket_hpp : FtpDataSocket.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpInTransfer_hpp : FtpInTransfer.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpOutTransfer_hpp : FtpOutTransfer.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpRequest_hpp : FtpRequest.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpServer_hpp : FtpServer.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpServerSocket_hpp : FtpServerSocket.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpSocket_hpp : FtpSocket.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpTransfer_hpp : FtpTransfer.hpp
  • Apoxi_AddOns_Server_FtpServer_FtpTypes_hpp : FtpTypes.hpp
  • Apoxi_AddOns_Server_FtpServerConfig_hpp : FtpServerConfig.hpp
  • Apoxi_AddOns_Server_HttpAuthProvider_hpp : HttpAuthProvider.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpApplication_hpp : HttpApplication.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpApplicationSupplier_hpp : HttpApplicationSupplier.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpClient_hpp : HttpClient.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpRequest_hpp : HttpRequest.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpResponse_hpp : HttpResponse.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpServer_hpp : HttpServer.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpServerSocket_hpp : HttpServerSocket.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpSocket_hpp : HttpSocket.hpp
  • Apoxi_AddOns_Server_HttpServer_HttpTypes_hpp : HttpTypes.hpp
  • Apoxi_AddOns_Server_HttpServerConfig_hpp : HttpServerConfig.hpp
  • Apoxi_AddOns_Server_Server_hpp : Server.hpp
  • Apoxi_AddOns_Server_ServerClient_hpp : ServerClient.hpp
  • Apoxi_AddOns_Server_ServerConfig_hpp : ServerConfig.hpp
  • Apoxi_AlarmManager_hpp : AlarmManager.hpp
  • APOXI_ALARMMANAGER_MAX_ENTRIES : AlarmManager.hpp, apoxi.defines
  • Apoxi_Alert_hpp : Alert.hpp
  • Apoxi_Allocator_hpp : Allocator.hpp
  • Apoxi_AnimatedTextLine_hpp : AnimatedTextLine.hpp
  • Apoxi_Animation_hpp : Animation.hpp
  • APOXI_APN_NAME_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • Apoxi_ApoxiThread_hpp : ApoxiThread.hpp
  • Apoxi_AppContainer_hpp : AppContainer.hpp
  • Apoxi_AppContainerRoutingTable_hpp : AppContainerRoutingTable.hpp
  • Apoxi_Application_hpp : Application.hpp
  • APOXI_APPLICATION_TRACER_MAX_APPS : ApplicationTracer.hpp, apoxi.defines
  • Apoxi_ApplicationAction_hpp : ApplicationAction.hpp
  • Apoxi_AppMutex_hpp : AppMutex.hpp
  • Apoxi_AppRoutingTable_hpp : AppRoutingTable.hpp
  • Apoxi_ArabicTextRenderer_hpp : ArabicTextRenderer.hpp
  • APOXI_ARAGON_MAX_BUFFER_SIZE : apoxi.defines
  • APOXI_ARAGON_SUPPORT : apoxi.defines
  • Apoxi_AragonServer_hpp : AragonServer.hpp
  • APOXI_AT_KEY_PARSER_TEST : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_CALL : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_REJECT : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_SIMTK : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_SS : apoxi.defines
  • APOXI_AT_MMI_INTERWORKING_USSD : apoxi.defines
  • Apoxi_AtBaseManager_hpp : AtBaseManager.hpp
  • Apoxi_AtCommand_hpp : AtCommand.hpp
  • Apoxi_AtiAudioPlayerRtStreamingConn_hpp : AtiAudioPlayerRtStreamingConn.hpp
  • Apoxi_AtiAudioPlayerRtStreamingSink_hpp : AtiAudioPlayerRtStreamingSink.hpp
  • APOXI_ATL_SUPPORT : apoxi.defines
  • Apoxi_AtlItemBox_hpp : AtlItemBox.hpp
  • Apoxi_AtManager_hpp : AtManager.hpp
  • Apoxi_AtomItem_hpp : AtomItem.hpp
  • Apoxi_AtResponse_hpp : AtResponse.hpp
  • Apoxi_AtResponseIterator_hpp : AtResponseIterator.hpp
  • Apoxi_Audio_AudioDeviceStatusMsg_hpp : AudioDeviceStatusMsg.hpp
  • Apoxi_Audio_AudioErrorMsg_hpp : AudioErrorMsg.hpp
  • Apoxi_Audio_AudioGetPlayPositionMsg_hpp : AudioGetPlayPositionMsg.hpp
  • Apoxi_Audio_AudioMessages_hpp : AudioMessages.hpp
  • Apoxi_Audio_AudioMsg_hpp : AudioMsg.hpp
  • Apoxi_Audio_AudioRadioDeviceNotificationMsg_hpp : AudioRadioDeviceNotificationMsg.hpp
  • Apoxi_Audio_AudioRestartedMsg_hpp : AudioRestartedMsg.hpp
  • Apoxi_Audio_AudioResumedMsg_hpp : AudioResumedMsg.hpp
  • Apoxi_Audio_AudioStartedMsg_hpp : AudioStartedMsg.hpp
  • Apoxi_Audio_AudioStoppedMsg_hpp : AudioStoppedMsg.hpp
  • Apoxi_Audio_AudioStreamingSyncMsg_hpp : AudioStreamingSyncMsg.hpp
  • Apoxi_Audio_AudioSuspendedMsg_hpp : AudioSuspendedMsg.hpp
  • Apoxi_Audio_AudioVoiceMemoOutOfSpaceMsg_hpp : AudioVoiceMemoOutOfSpaceMsg.hpp
  • Apoxi_Audio_hpp : Audio.hpp
  • Apoxi_AudioAccessoryStore_hpp : AudioAccessoryStore.hpp
  • Apoxi_AudioActiveReference_hpp : AudioActiveReference.hpp
  • Apoxi_AudioCapturerEncoder_hpp : AudioCapturerEncoder.hpp
  • Apoxi_AudioDecoder_hpp : AudioDecoder.hpp
  • Apoxi_AudioDecoderRenderer_hpp : AudioDecoderRenderer.hpp
  • Apoxi_AudioDeviceBase_hpp : AudioDeviceBase.hpp
  • Apoxi_AudioDeviceManager_hpp : AudioDeviceManager.hpp
  • Apoxi_AudioEncoder_hpp : AudioEncoder.hpp
  • Apoxi_AudioItem_hpp : AudioItem.hpp
  • Apoxi_AudioMapiManager_hpp : AudioMapiManager.hpp
  • Apoxi_AudioNewAPI_AtiAudioPlayer_hpp : AtiAudioPlayer.hpp
  • Apoxi_AudioNewAPI_AudioAccessoryDetails_hpp : AudioAccessoryDetails.hpp
  • Apoxi_AudioNewAPI_AudioError_hpp : AudioError.hpp
  • Apoxi_AudioNewAPI_AudioPath_hpp : AudioPath.hpp
  • Apoxi_AudioNewAPI_AudioPathManager_hpp : AudioPathManager.hpp
  • Apoxi_AudioNewAPI_AudioPreset_hpp : AudioPreset.hpp
  • Apoxi_AudioNewAPI_AudioPresetStore_hpp : AudioPresetStore.hpp
  • Apoxi_AudioNewAPI_AudioSuspendedDetails_hpp : AudioSuspendedDetails.hpp
  • Apoxi_AudioNewAPI_AudioUtility_hpp : AudioUtility.hpp
  • Apoxi_AudioNewAPI_AudioVibratorDevice_hpp : AudioVibratorDevice.hpp
  • Apoxi_AudioNewAPI_CombinedDeviceAudioReference_hpp : CombinedDeviceAudioReference.hpp
  • Apoxi_AudioNewAPI_CustomIMelodyAudioReference_hpp : CustomIMelodyAudioReference.hpp
  • Apoxi_AudioNewAPI_CustomRingerAudioReference_hpp : CustomRingerAudioReference.hpp
  • Apoxi_AudioNewAPI_CustomSmafPhraseAudioReference_hpp : CustomSmafPhraseAudioReference.hpp
  • Apoxi_AudioNewAPI_CustomToneAudioReference_hpp : CustomToneAudioReference.hpp
  • Apoxi_AudioNewAPI_MP3AudioPlayer_hpp : Mp3AudioPlayer.hpp
  • Apoxi_AudioNewAPI_MP3AudioReference_hpp : Mp3AudioReference.hpp
  • Apoxi_AudioNewAPI_PCMAudioPlayer_hpp : PcmAudioPlayer.hpp
  • Apoxi_AudioNewAPI_PCMAudioReference_hpp : PcmAudioReference.hpp
  • Apoxi_AudioNewAPI_PresetAudioReference_hpp : PresetAudioReference.hpp
  • Apoxi_AudioNewAPI_RadioAudioDevice_hpp : RadioAudioDevice.hpp
  • Apoxi_AudioNewAPI_RingerAudioInternalMIDIPlayer_hpp : RingerAudioInternalMidiPlayer.hpp
  • Apoxi_AudioNewAPI_RingerAudioReference_hpp : RingerAudioReference.hpp
  • Apoxi_AudioNewAPI_SimpleAudioDevice_hpp : SimpleAudioDevice.hpp
  • Apoxi_AudioNewAPI_SimpleAudioReference_hpp : SimpleAudioReference.hpp
  • Apoxi_AudioNewAPI_SpeechSimpleAudioDevice_hpp : SpeechSimpleAudioDevice.hpp
  • Apoxi_AudioNewAPI_StreamAudioPlayer_hpp : StreamAudioPlayer.hpp
  • Apoxi_AudioNewAPI_StreamAudioReference_hpp : StreamAudioReference.hpp
  • Apoxi_AudioNewAPI_ToneAudioPlayer_hpp : ToneAudioPlayer.hpp
  • Apoxi_AudioNewAPI_ToneAudioReference_hpp : ToneAudioReference.hpp
  • Apoxi_AudioNewAPI_VoiceMemoAudioPlayer_hpp : VoiceMemoAudioPlayer.hpp
  • Apoxi_AudioNewAPI_VoiceMemoAudioReference_hpp : VoiceMemoAudioReference.hpp
  • Apoxi_AudioPlayer_hpp : AudioPlayer.hpp
  • Apoxi_AudioPlayerEvent_hpp : AudioPlayerEvent.hpp
  • Apoxi_AudioPlayerStore_hpp : AudioPlayerStore.hpp
  • Apoxi_AudioPriorityManager_hpp : AudioPriorityManager.hpp
  • Apoxi_AudioPrivate_hpp : audio_private.hpp
  • Apoxi_AudioReference_hpp : AudioReference.hpp
  • APOXI_AUX_CHINESEQUICKSORT_DEBUG : apoxi.defines
  • APOXI_AUX_QUICKSORT_DEBUG : apoxi.defines
  • Apoxi_AuxExtensions_AppendProvider_hpp : AppendProvider.hpp
  • Apoxi_AuxExtensions_JoinJoinRule_hpp : JoinRule.hpp
  • Apoxi_AuxExtensions_JoinProvider_hpp : JoinProvider.hpp
  • Apoxi_AuxExtensions_MergeProvider_hpp : MergeProvider.hpp
  • Apoxi_AuxExtensions_PhoneNumberMergeProvider_hpp : PhoneNumberMergeProvider.hpp
  • Apoxi_AuxExtensions_ProviderIds_hpp : ProviderIds.hpp
  • Apoxi_BackLight_hpp : BackLight.hpp
  • Apoxi_BackupFileHandler_hpp : BackupFileHandler.hpp
  • Apoxi_BasicPackConnector_hpp : BasicPackConnector.hpp
  • APOXI_BEARER_PROFILE_ACCOUNT_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • APOXI_BEARER_PROFILE_NAME_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • APOXI_BEARER_PROFILE_PASSWD_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • Apoxi_BidiManager_hpp : BidiManager.hpp
  • APOXI_BIG_ENDIAN : apoxi.defines
  • Apoxi_BinarySearch_hpp : BinarySearch.hpp
  • Apoxi_Bitmap_hpp : Bitmap.hpp
  • Apoxi_BitmapDc_hpp : BitmapDc.hpp
  • Apoxi_BitVector_hpp : BitVector.hpp
  • Apoxi_BlackAndWhiteTheme_hpp : BlackAndWhiteTheme.hpp
  • Apoxi_BlueSkyCheckBoxListView_hpp : BlueSkyCheckBoxListView.hpp
  • Apoxi_BlueSkyCheckBoxView_hpp : BlueSkyCheckBoxView.hpp
  • Apoxi_BlueSkyChineseTheme_hpp : BlueSkyChineseTheme.hpp
  • Apoxi_BlueSkyControlFrameView_hpp : BlueSkyControlFrameView.hpp
  • Apoxi_BlueSkyPositionIndicatorView_hpp : BlueSkyPositionIndicatorView.hpp
  • Apoxi_BlueSkyProgressBarView_hpp : BlueSkyProgressBarView.hpp
  • Apoxi_BlueSkyPushButtonView_hpp : BlueSkyPushButtonView.hpp
  • Apoxi_BlueSkyRadioButtonListView_hpp : BlueSkyRadioButtonListView.hpp
  • Apoxi_BlueSkyRadioButtonView_hpp : BlueSkyRadioButtonView.hpp
  • Apoxi_BlueSkySoftkeyBarView_hpp : BlueSkySoftkeyBarView.hpp
  • Apoxi_BlueSkyTextListView_hpp : BlueSkyTextListView.hpp
  • Apoxi_BlueSkyTheme_hpp : BlueSkyTheme.hpp
  • Apoxi_BlueSkyWindowFrameView_hpp : BlueSkyWindowFrameView.hpp
  • APOXI_BLUETOOTH : apoxi.defines
  • Apoxi_BmpDecoder_hpp : BmpDecoder.hpp
  • Apoxi_BmpImage_hpp : BmpImage.hpp
  • Apoxi_BoundedItem_hpp : BoundedItem.hpp
  • Apoxi_BrowserView_hpp : BrowserView.hpp
  • Apoxi_BrowserViewContainer_hpp : BrowserViewContainer.hpp
  • Apoxi_Brush_hpp : Brush.hpp
  • APOXI_BT_A2DP_SUPPORT : apoxi.defines
  • APOXI_BT_OBEX_SYSTEM_CLIENT_SECURITY : BtObexServiceTable.hpp, apoxi.defines
  • APOXI_BT_OBEX_SYSTEM_SERVER_SECURITY : BtObexServiceTable.hpp, apoxi.defines
  • Apoxi_BtObexClientAddrResultNotifier_hpp : BtObexClientAddrResultNotifier.hpp
  • Apoxi_BtObexClientObserverImpl_hpp : BtObexClientObserverImpl.hpp
  • Apoxi_BtObexClientServiceImpl_hpp : BtObexClientServiceImpl.hpp
  • Apoxi_BtObexImpl_hpp : BtObexImpl.hpp
  • Apoxi_BtObexImplAddress_hpp : BtObexImplAddress.hpp
  • Apoxi_BtObexResponseCode_hpp : BtObexResponseCode.hpp
  • Apoxi_BtObexSddbImpl_hpp : BtObexSddbImpl.hpp
  • Apoxi_BtObexServerObserverImpl_hpp : BtObexServerObserverImpl.hpp
  • Apoxi_BtObexServerServiceImpl_hpp : BtObexServerServiceImpl.hpp
  • Apoxi_BtObexServiceTable_hpp : BtObexServiceTable.hpp
  • Apoxi_BtSddbServiceObserverImpl_hpp : BtObexSddbServiceObserverImpl.hpp
  • Apoxi_BufferedOutputStream_hpp : BufferedOutputStream.hpp
  • Apoxi_BufferPoolManager_hpp : BufferPoolManager.hpp
  • APOXI_BYTEBUFFER_TEST_SUITE : ByteBuffer.hpp, apoxi.defines
  • APOXI_CACHED_POLYGON_EDGES_MAX : DeviceContext.cpp, apoxi.defines
  • Apoxi_CalculatorInputMapper_hpp : CalculatorInputMapper.hpp
  • Apoxi_CalendarGrid_hpp : CalendarGrid.hpp
  • Apoxi_CallInfoParser_hpp : XCallInfoResponseParser.hpp
  • Apoxi_Camera_hpp : Camera.hpp
  • APOXI_CAMERA_MPE_COMPAT : apoxi.defines
  • APOXI_CAMERA_SUPPORT : apoxi.defines
  • APOXI_CAMERA_TWINVIEWFINDER_SUPPORT : Camera.hpp, apoxi.defines
  • APOXI_CAMERA_WIN32 : apoxi.defines
  • Apoxi_CancelAction_hpp : CancelAction.hpp
  • Apoxi_Caret_hpp : Caret.hpp
  • APOXI_CBS_DEFAULT_ACTIVE_TIMER : apoxi.defines
  • APOXI_CBS_DEFAULT_SLEEP_TIMER : apoxi.defines
  • APOXI_CBS_LIMITATION_MSG : apoxi.defines
  • Apoxi_CharItem_hpp : CharItem.hpp
  • Apoxi_CheckBox_hpp : CheckBox.hpp
  • Apoxi_CheckBoxAction_hpp : CheckBoxAction.hpp
  • Apoxi_CheckBoxControl_hpp : CheckBoxControl.hpp
  • Apoxi_CheckBoxItem_hpp : CheckBoxItem.hpp
  • Apoxi_CheckBoxList_hpp : CheckBoxList.hpp
  • Apoxi_ChineseT9InputMapper_hpp : ChineseT9InputMapper.hpp
  • APOXI_CINGULAR_INPUT_TEST : apoxi.defines
  • Apoxi_ClientDc_hpp : ClientDc.hpp
  • Apoxi_CloseWindowAction_hpp : CloseWindowAction.hpp
  • Apoxi_CodecDevice_hpp : CodecDevice.hpp
  • Apoxi_CodecManager_hpp : CodecManager.hpp
  • Apoxi_Color_hpp : Color.hpp
  • APOXI_COLOR_VALUE_BITCOUNT : Color.cpp
  • Apoxi_ColorSegmentation_hpp : ColorSegmentation.hpp
  • Apoxi_ColorTable_hpp : ColorTable.hpp
  • APOXI_COMPAT_1_11_0 : apoxi.defines
  • APOXI_COMPAT_1_12_0 : apoxi.defines
  • APOXI_COMPAT_1_13_0 : apoxi.defines
  • APOXI_COMPAT_1_7_0 : apoxi.defines
  • APOXI_COMPAT_1_8_0 : apoxi.defines
  • APOXI_COMPAT_1_9_0 : apoxi.defines
  • APOXI_COMPAT_2_0_0 : apoxi.defines
  • APOXI_COMPAT_2_1_0 : apoxi.defines
  • APOXI_COMPAT_2_2_0 : apoxi.defines
  • APOXI_COMPAT_2_3_0 : apoxi.defines
  • APOXI_COMPAT_2_4_0 : apoxi.defines
  • APOXI_COMPAT_2_6_0 : apoxi.defines
  • APOXI_COMPAT_2_7_0 : apoxi.defines
  • APOXI_COMPAT_2_8_0 : apoxi.defines
  • APOXI_COMPAT_2_9_0 : apoxi.defines
  • APOXI_COMPILER_ADS : apoxi.defines
  • APOXI_COMPILER_C166 : apoxi.defines
  • APOXI_COMPILER_MSVC : apoxi.defines
  • APOXI_COMPILER_RVCT : apoxi.defines
  • Apoxi_Component_hpp : Component.hpp
  • Apoxi_CompoundItem_hpp : CompoundItem.hpp
  • Apoxi_CompoundItemReferrer_hpp : CompoundItemReferrer.hpp
  • Apoxi_Condition_hpp : Condition.hpp
  • APOXI_CONFIG_DBG_OUT_RANGE_ARRAY : OsClass.hpp, apoxi.defines
  • APOXI_CONFIG_MAX_MM_CALLS : MmCallHandler.hpp
  • Apoxi_ConfirmAction_hpp : ConfirmAction.hpp
  • Apoxi_ContextMenu_hpp : ContextMenu.hpp
  • Apoxi_Control_hpp : Control.hpp
  • Apoxi_ControlDc_hpp : ControlDc.hpp
  • Apoxi_ControlFrameView_hpp : ControlFrameView.hpp
  • APOXI_COUNTOF : MimeTypeTableUtils.hpp
  • Apoxi_CountryCodes_hpp : CountryCodes.hpp
  • APOXI_CRASH_DEBUG : apoxi.defines
  • Apoxi_CsdDataConn_hpp : CsdDataConn.hpp
  • Apoxi_CsdDataConnProfile_hpp : CsdDataConnProfile.hpp
  • Apoxi_CTControlFrameView_hpp : CTControlFrameView.hpp
  • APOXI_CTM : apoxi.defines
  • Apoxi_CTPanelView_hpp : CTPanelView.hpp
  • Apoxi_CTPositionIndicatorView_hpp : CTPositionIndicatorView.hpp
  • Apoxi_CTProgressBarView_hpp : CTProgressBarView.hpp
  • Apoxi_CTPushButtonView_hpp : CTPushButtonView.hpp
  • Apoxi_CTResourcePack_hpp : CTResourcePack.hpp
  • Apoxi_CTResourceParser_hpp : CTResourceParser.hpp
  • Apoxi_CTTheme_hpp : CustomizableTheme.hpp
  • Apoxi_CTWindowFrameView_hpp : CTWindowFrameView.hpp
  • APOXI_DATA_CONN_PROFILE_COUNT : SocketTypes.hpp, apoxi.defines
  • APOXI_DATA_CONN_PROFILE_FFS_FILE_ID : MyDataConnProfileStorage.hpp
  • APOXI_DATA_CONN_PROFILE_FFS_USER_TYPE : MyDataConnProfileStorage.hpp
  • APOXI_DATA_CONN_TEMP_PROFILE_COUNT : SocketTypes.hpp, apoxi.defines
  • Apoxi_DataConn_hpp : DataConn.hpp
  • Apoxi_DataConnManager_hpp : DataConnManager.hpp
  • Apoxi_DataConnOptionWin_hpp : DataConnOptionWin.hpp
  • Apoxi_DataConnProfile_hpp : DataConnProfile.hpp
  • Apoxi_DataConnProfileManager_hpp : DataConnProfileManager.hpp
  • Apoxi_DataConnProfileStorage_hpp : DataConnProfileStorage.hpp
  • Apoxi_DataConnTypeWin_hpp : DataConnTypeWin.hpp
  • Apoxi_DataConnWin_hpp : DataConnWin.hpp
  • Apoxi_DataPack_hpp : DataPack.hpp
  • Apoxi_DataSourceRtStreamingSource_hpp : DataSourceRtStreamingSource.hpp
  • Apoxi_Date_h : Date.hpp
  • Apoxi_DateCompoundItem_hpp : DateCompoundItem.hpp
  • Apoxi_DateEditBox_hpp : DateEditBox.hpp
  • Apoxi_DateEditor_hpp : DateEditor.hpp
  • Apoxi_DateEditorDocument_hpp : DateEditorDocument.hpp
  • Apoxi_DateTime_h : DateTime.hpp
  • Apoxi_DateTimeInputMapper_hpp : DateTimeInputMapper.hpp
  • Apoxi_DBService_hpp : DBService.hpp
  • APOXI_DCL_MIME_TYPE_DEFS : MimeTypeTableUtils.hpp
  • APOXI_DEBUG_IMAGE_DECODING : apoxi.defines
  • Apoxi_DebugOutputStream_hpp : DebugOutputStream.hpp
  • Apoxi_DecodingThreadlet_hpp : DecodingThreadlet.hpp
  • APOXI_DEF_MIME_TYPE : MimeTypeTableUtils.hpp
  • Apoxi_DefaultCaret_hpp : DefaultCaret.hpp
  • Apoxi_DefaultCheckBoxListView_hpp : DefaultCheckBoxListView.hpp
  • Apoxi_DefaultCheckBoxView_hpp : DefaultCheckBoxView.hpp
  • Apoxi_DefaultChineseTheme_hpp : DefaultChineseTheme.hpp
  • Apoxi_DefaultControlFrameView_hpp : DefaultControlFrameView.hpp
  • Apoxi_DefaultDisplay_hpp : DefaultDisplay.hpp
  • Apoxi_DefaultItemRenderer_hpp : DefaultItemRenderer.hpp
  • Apoxi_DefaultPanelView_hpp : DefaultPanelView.hpp
  • Apoxi_DefaultPositionIndicatorView_hpp : DefaultPositionIndicatorView.hpp
  • Apoxi_DefaultProgressBarView_hpp : DefaultProgressBarView.hpp
  • Apoxi_DefaultPushButtonView_hpp : DefaultPushButtonView.hpp
  • Apoxi_DefaultRadioButtonListView_hpp : DefaultRadioButtonListView.hpp
  • Apoxi_DefaultRadioButtonView_hpp : DefaultRadioButtonView.hpp
  • Apoxi_DefaultSoftkeyBarView_hpp : DefaultSoftkeyBarView.hpp
  • Apoxi_DefaultTabButtonView_hpp : DefaultTabButtonView.hpp
  • Apoxi_DefaultTabControlView_hpp : DefaultTabControlView.hpp
  • Apoxi_DefaultTextListView_hpp : DefaultTextListView.hpp
  • Apoxi_DefaultTheme_hpp : DefaultTheme.hpp
  • Apoxi_DefaultWindowFrameView_hpp : DefaultWindowFrameView.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationRejectedByGgsn : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_11 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_5 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_7 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_9 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_Invalid : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_LlcSapi_NotAssigned : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_2 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_4 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_RadioPriorityLevel_Undefined : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateAccepted : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateFiveTimeT3380Expiry : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateRejected : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUnknownCause : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ActivationStatus_StateUserInteruption : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Address_c_max_len : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_account_len : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_c_max_password_len : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Chap : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_None : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Authentication_Pap : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_AuthenticationFailure : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_c_max_access_point_name_len : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ConditionalIeError : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_GprsServiceNotAllowed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IeNonExistent : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMe : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IllegalMs : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InsufficientRessources : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidMandatoryIe : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_InvalidTi : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpDynamicType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpStaticType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_IpType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LaNotAllowed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_LlcOrSndcpFailure : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ManufProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MissingOrUnknownApn : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MobileStation : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgNotCompatible : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotCompatible : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_MsgTypeNotExistent : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NationalRoamingNotAllowed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_Network : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NetworkFailure : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoError : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NoType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NsapiAlreadyUsed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_NullProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_OspihType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_2 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PacketFilter_Type_Unknown : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PadProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PlmnNotAllowed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppProtocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_PppType : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QosNotAccepted : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayBestEffort : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass2 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayClass3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelayReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_DelaySubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate100K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate10M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate1M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate200K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate20M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate2M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate500K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate50M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRate5M : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateBestEffort : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_MeanRateSubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate128K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate16K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate1K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate256K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate2K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate32K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate4K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate64K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRate8K : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PeakRateSubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceHigh : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceLow : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceNormal : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_PrecedenceSubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass1 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass2 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass3 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass4 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass5 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityClass6 : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilityReserved : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_QualityOfService_ReliabilitySubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ReactivationRequired : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RegularDeactivation : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_RequestedServiceOptionNotSubscribed : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_SemanticIncorrectMsg : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionNotSupported : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_ServiceOptionTemporaryOutOfOrder : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UndefinedError : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownOrigin : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnknownPdpAddress : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedActivationRejection : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_UnspecifiedProtocolError : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Protocol : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContext_X25Type : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateAccepted : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateFiveTimeT3310Expiry : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateRejected : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUnknownCause : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_AttachStatus_StateUserInteruption : ValueMap.hpp
  • APOXI_DEFINE_SCOPE_ENTITY_PdpContextManager_c_max_cid_array_len : ValueMap.hpp
  • Apoxi_DeletedNode_hpp : DeletedNode.hpp
  • Apoxi_Desktop_hpp : Desktop.hpp
  • Apoxi_Device_hpp : Device.hpp
  • Apoxi_DeviceContext_hpp : DeviceContext.hpp
  • Apoxi_Devices_AudioMsgProcessor_hpp : AudioMsgProcessor.hpp
  • Apoxi_Devices_AudioPlayTimeMsg_hpp : AudioPlayTimeMsg.hpp
  • Apoxi_Devices_Bp30_Charger_hpp : Charger.hpp
  • Apoxi_Devices_BP30_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Bp30_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Bp30_Led_hpp : Led.hpp
  • Apoxi_Devices_Bp30_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_BP30_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_Devices_Camera_hpp : Camera.hpp
  • Apoxi_Devices_Charger_hpp : Charger.hpp
  • Apoxi_Devices_ChargerSignalMapTableNode_hpp : ChargerSignalMapTableNode.hpp
  • Apoxi_Devices_ChargerSignalProcessor_hpp : ChargerSignalProcessor.hpp
  • Apoxi_Devices_DeviceManager_hpp : DeviceManager.hpp
  • Apoxi_Devices_Display_hpp : Display.hpp
  • Apoxi_Devices_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Led_hpp : Led.hpp
  • Apoxi_Devices_LedSignalMapTableNode_hpp : LedSignalMapTableNode.hpp
  • Apoxi_Devices_LedSignalProcessor_hpp : LedSignalProcessor.hpp
  • Apoxi_Devices_Mpe_Charger_hpp : Charger.hpp
  • Apoxi_Devices_MPE_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Mpe_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Mpe_Led_hpp : Led.hpp
  • Apoxi_Devices_Mpe_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_MPE_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_Devices_MPEU_BackLight_hpp : BackLight.hpp
  • Apoxi_Devices_Mpeu_Charger_hpp : Charger.hpp
  • Apoxi_Devices_MPEU_DefaultDisplay_hpp : DefaultDisplay.hpp
  • Apoxi_Devices_MPEU_Extensions_AtiW2282_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_Devices_MPEU_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Mpeu_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Mpeu_Led_hpp : Led.hpp
  • Apoxi_Devices_Mpeu_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_MPEU_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_Devices_MPEU_VirtualDisplay_hpp : VirtualDisplay.hpp
  • Apoxi_Devices_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_RtcSignalMapTableNode_hpp : RtcSignalMapTableNode.hpp
  • Apoxi_Devices_RtcSignalProcessor_hpp : RtcSignalProcessor.hpp
  • Apoxi_Devices_SGold_Charger_hpp : Charger.hpp
  • Apoxi_Devices_SGold_Fota_hpp : Fota.hpp
  • Apoxi_Devices_SGold_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_SGold_Led_hpp : Led.hpp
  • Apoxi_Devices_SGold_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_Devices_StillCamera_hpp : StillCamera.hpp
  • Apoxi_Devices_TransportNotificationMsg_hpp : TransportNotificationMsg.hpp
  • Apoxi_Devices_VideoCamera_hpp : VideoCamera.hpp
  • Apoxi_Devices_VirtualDisplay_hpp : VirtualDisplay.hpp
  • Apoxi_Devices_Win32_Camera_hpp : Camera.hpp
  • Apoxi_Devices_Win32_Charger_hpp : Charger.hpp
  • Apoxi_Devices_Win32_Fota_hpp : Fota.hpp
  • Apoxi_Devices_Win32_Keyboard_hpp : Keyboard.hpp
  • Apoxi_Devices_Win32_Led_hpp : Led.hpp
  • Apoxi_Devices_Win32_RealTimeClock_hpp : RealTimeClock.hpp
  • Apoxi_DialogWindow_hpp : DialogWindow.hpp
  • Apoxi_DirectoryIterator_hpp : DirectoryIterator.hpp
  • Apoxi_DirtyFileHandler_hpp : DirtyFileHandler.hpp
  • APOXI_DISABLE_CPP_CASTS : apoxi.defines
  • APOXI_DISABLE_ENLARGED_GRID_SELECTION : apoxi.defines
  • APOXI_DISABLE_FILTERED_SMS_PROVIDERS : apoxi.defines
  • APOXI_DISABLE_RECURSIVE_PROVIDER_SORTING : apoxi.defines
  • APOXI_DISABLE_SOFTKEYBAR : apoxi.defines
  • APOXI_DISABLE_TAB_CONTROL : apoxi.defines
  • Apoxi_Dispatcher_hpp : Dispatcher.hpp
  • Apoxi_DispatcherAction_hpp : DispatcherAction.hpp
  • APOXI_DISPLAY_16BPP : apoxi.defines
  • APOXI_DISPLAY_24BPP : apoxi.defines
  • APOXI_DISPLAY_32BPP : apoxi.defines
  • APOXI_DISPLAY_8BPP : apoxi.defines
  • APOXI_DISPLAY_FORMAT_BIG_ENDIAN : apoxi.defines
  • APOXI_DISPLAY_PLANES : apoxi.defines
  • Apoxi_DisplayConfig_hpp : DisplayConfig.hpp
  • Apoxi_DisplayDc_hpp : DisplayDc.hpp
  • Apoxi_DisplaySettings_hpp : DisplaySettings.hpp
  • Apoxi_DnsClient_hpp : DnsClient.hpp
  • Apoxi_DnsClientTest_hpp : DnsClientTest.hpp
  • APOXI_DR_SMSR_SCA_BUG_NOT_FIXED : apoxi.defines
  • Apoxi_DrawableObject_hpp : DrawableObject.hpp
  • Apoxi_Drm_Asset_hpp : DrmAsset.hpp
  • Apoxi_Drm_hpp : Drm.hpp
  • Apoxi_Drm_Message_hpp : DrmMessage.hpp
  • Apoxi_DrmDcfParser_hpp : DrmDcfParser.hpp
  • Apoxi_DrmInfo_hpp : DrmInfo.hpp
  • Apoxi_DrmRelParser_hpp : DrmRelparser.hpp
  • Apoxi_DrmRelWbxml_hpp : DrmRelWbxml.hpp
  • Apoxi_DrmRights_hpp : DrmRights.hpp
  • Apoxi_DrmRightsStore_hpp : DrmRightsStore.hpp
  • Apoxi_DrmSecurity_hpp : DrmSecurity.hpp
  • Apoxi_DrmSubsystem_hpp : DrmSubsystem.hpp
  • Apoxi_DrmUtils_hpp : DrmUtils.hpp
  • Apoxi_DrmXmlRelParser_hpp : DrmRelXml.hpp
  • APOXI_DUAL_DISPLAY_SUPPORT : apoxi.defines
  • Apoxi_DwdDevice_hpp : DwdDevice.hpp
  • Apoxi_DwdPlayer_hpp : DwdPlayer.hpp
  • Apoxi_DynamicBitVector_hpp : DynamicBitVector.hpp
  • Apoxi_EditBox_hpp : EditBox.hpp
  • Apoxi_EditConfig_hpp : EditConfig.hpp
  • Apoxi_EditorDocument_hpp : EditorDocument.hpp
  • Apoxi_EditorLine_hpp : EditorLine.hpp
  • APOXI_EM_CONTROL_ENABLED : apoxi.defines
  • Apoxi_EmzAacDecoder_hpp : EmzAacDecoder.hpp
  • Apoxi_EmzMp3Decoder_hpp : EmzMp3Decoder.hpp
  • Apoxi_EmzSbcEncoder_hpp : EmzSbcEncoder.hpp
  • APOXI_ENABLE_ADVANCED_TRANSLATION : apoxi.defines
  • APOXI_ENABLE_ALPHA_BLENDING : apoxi.defines
  • APOXI_ENABLE_ANIMATED_TITLE : apoxi.defines
  • APOXI_ENABLE_ARC_DRAWING : apoxi.defines
  • APOXI_ENABLE_C166_APOXIGUI_RAMCODE : apoxi.defines
  • APOXI_ENABLE_C166_DISPLAY_SHAREDMETHODS_RAMCODE : apoxi.defines
  • APOXI_ENABLE_C166_GIFDECODER_RAMCODE : apoxi.defines
  • APOXI_ENABLE_C166_HUGEBITMAP_DRAW : apoxi.defines
  • APOXI_ENABLE_C166_RECT_RAMCODE : apoxi.defines
  • APOXI_ENABLE_CBS_ACTIVE_TIMER_INTERFACE : apoxi.defines
  • APOXI_ENABLE_CIRCLE_DRAWING : apoxi.defines
  • APOXI_ENABLE_CONC_SMS_SCA_CHECK : apoxi.defines
  • APOXI_ENABLE_DBG_OUT : apoxi.defines
  • APOXI_ENABLE_DIAGONAL_LINE_DRAWING : apoxi.defines
  • APOXI_ENABLE_ECC_CUSTOMIZATION : apoxi.defines
  • APOXI_ENABLE_GSM_BITMAP_DRAWING : apoxi.defines
  • APOXI_ENABLE_JAPANESE_TRANSCODER : apoxi.defines
  • APOXI_ENABLE_ME_PHONEBOOK_REQUEST : apoxi.defines
  • APOXI_ENABLE_MOC_CALL_RESTRICTION : apoxi.defines
  • APOXI_ENABLE_OBSOLETE_STRING_INTERFACE : apoxi.defines
  • APOXI_ENABLE_OBSOLETE_WSTRING_INTERFACE : apoxi.defines
  • APOXI_ENABLE_POLYGON_DRAWING : apoxi.defines
  • APOXI_ENABLE_POSITION_PREVIEW : apoxi.defines
  • APOXI_ENABLE_R2L_TEST : apoxi.defines
  • APOXI_ENABLE_RUNTIME_CONFIGURATION : apoxi.defines
  • APOXI_ENABLE_SDL_SIGNAL_SIGNATURE_CHECK : apoxi.defines
  • APOXI_ENABLE_SMOOTH_SCROLLING : apoxi.defines
  • APOXI_ENABLE_STACK_CHECK : apoxi.defines
  • APOXI_ENABLE_SVG_FONT_SERIALIZATION : apoxi.defines
  • APOXI_ENABLE_SVG_SYSTEM_FONTS : apoxi.defines
  • APOXI_ENABLE_TIMING_MEASUREMENTS : apoxi.defines
  • APOXI_ENABLE_TRAP_INFO_SCREEN : apoxi.defines
  • APOXI_ENABLE_USIM_PHONEBOOK : apoxi.defines
  • APOXI_ENALBE_NEW_STARTUP_INTERFACE : apoxi.defines
  • Apoxi_EncodingThreadlet_hpp : EncodingThreadlet.hpp
  • APOXI_END_MIME_TYPE_DEFS : MimeTypeTable.cpp, MimeTypeTableUtils.hpp
  • Apoxi_EnglishT9InputMapper_hpp : EnglishT9InputMapper.hpp
  • Apoxi_EventData_hpp : EventData.hpp
  • Apoxi_ExecutionContext_hpp : ExecutionContext.hpp
  • APOXI_EXTERNAL_PCH_CONTROL_SUPPORT : apoxi.defines
  • Apoxi_ExternalPsdContextListener_hpp : ExternalPsdContextListener.hpp
  • APOXI_FACTORY_CUSTOMIZATION_SUPPORT : apoxi.defines
  • Apoxi_FatDirectoryIteratorImp_hpp : FatDirectoryIteratorImp.hpp
  • Apoxi_FatFile_hpp : FatFile.hpp
  • Apoxi_FatFileImp_hpp : FatFileImp.hpp
  • Apoxi_FatSim_hpp : FatSim.hpp
  • Apoxi_FatStorageDeviceImp_hpp : FatStorageDeviceImp.hpp
  • Apoxi_FatTypes_hpp : FatTypes.hpp
  • APOXI_FFS_EXTENDED_DEBUG : apoxi.defines
  • APOXI_FFS_USER_MAPPING : apoxi.defines
  • Apoxi_FfsTypes_hpp : FfsTypes.hpp
  • Apoxi_FifoLinkedList_hpp : FifoLinkedList.hpp
  • Apoxi_File_hpp : File.hpp
  • Apoxi_FileBinData_hpp : FileBinData.hpp
  • Apoxi_FileChunkOperator_hpp : FileChunkOperator.hpp
  • Apoxi_FileDataSink_hpp : FileDataSink.hpp
  • Apoxi_FileDataSource_hpp : FileDataSource.hpp
  • Apoxi_FileFilter_hpp : FileFilter.hpp
  • Apoxi_FileInputStream_hpp : FileInputStream.hpp
  • Apoxi_FileNameListBoxModel_hpp : FileNameListBoxModel.hpp
  • Apoxi_FileNameView_hpp : FileNameView.hpp
  • Apoxi_FileOutputStream_hpp : FileOutputStream.hpp
  • Apoxi_FilePack_hpp : FilePack.hpp
  • Apoxi_FilePackConnector_hpp : FilePackConnector.hpp
  • Apoxi_FileVisitor_hpp : FileVisitor.hpp
  • Apoxi_FlashDirectoryIteratorImp_hpp : FlashDirectoryIteratorImp.hpp
  • Apoxi_FlashFileImp_hpp : FlashFileImp.hpp
  • Apoxi_FlashStorageDeviceImp_hpp : FlashStorageDeviceImp.hpp
  • Apoxi_FlowLayout_hpp : FlowLayout.hpp
  • Apoxi_FlsFile_hpp : FlsFile.hpp
  • APOXI_FM_RADIO_SUPPORT : apoxi.defines
  • Apoxi_FmRadioAudioPlayer_hpp : FmRadioAudioPlayer.hpp
  • Apoxi_FoggyPanelView_hpp : FoggyPanelView.hpp
  • Apoxi_FoggyPositionIndicatorView_hpp : FoggyPositionIndicatorView.hpp
  • Apoxi_FoggyPushButtonView_hpp : FoggyPushButtonView.hpp
  • Apoxi_FoggySoftkeyBarView_hpp : FoggySoftkeyBarView.hpp
  • Apoxi_FoggyTheme_hpp : FoggyTheme.hpp
  • Apoxi_FoggyWindowFrameView_hpp : FoggyWindowFrameView.hpp
  • Apoxi_Font_hpp : Font.hpp
  • Apoxi_FontConfig_hpp : FontConfig.hpp
  • Apoxi_FontEntry_hpp : FontEntry.hpp
  • Apoxi_FontManager_hpp : FontManager.hpp
  • Apoxi_FontPack_hpp : FontPack.hpp
  • Apoxi_FontPackConnector_hpp : FontPackConnector.hpp
  • Apoxi_fonts_hpp : fonts.hpp
  • APOXI_FOTA_SUPPORT : apoxi.defines
  • Apoxi_Fraction_hpp : Fraction.hpp
  • Apoxi_FrameDc_hpp : FrameDc.hpp
  • Apoxi_FsmEngine_hpp : FsmEngine.hpp
  • APOXI_FTPSERVER_REQUEST_LENGTH : FtpTypes.hpp
  • Apoxi_GatiManager_hpp : GatiManager.hpp
  • Apoxi_GatiServer_hpp : GatiServer.hpp
  • APOXI_GDD_2_0_INTERFACE : apoxi.defines
  • APOXI_GDD_INTERFACE : apoxi.defines
  • Apoxi_GeneralCompoundItem_hpp : GeneralCompoundItem.hpp
  • Apoxi_GenericFeatureData_hpp : GenericFeatureData.hpp
  • Apoxi_GenericWorkerTask_hpp : GenericWorkerTask.hpp
  • Apoxi_GifDecoder_hpp : GifDecoder.hpp
  • Apoxi_GifImage_hpp : GifImage.hpp
  • Apoxi_GlassPane_hpp : GlassPane.hpp
  • Apoxi_GridLayout_hpp : GridLayout.hpp
  • APOXI_GTL_DIF : apoxi.defines
  • APOXI_GTL_EBU : apoxi.defines
  • Apoxi_GuidServiceTable_hpp : GuidServiceTable.hpp
  • Apoxi_GuiEngineConfig_hpp : GuiEngineConfig.hpp
  • Apoxi_GuiObjectDescr_hpp : GuiObjectDescr.hpp
  • Apoxi_GuiObjectFactory_hpp : GuiObjectFactory.hpp
  • Apoxi_GuiObjectIterator_hpp : GuiObjectIterator.hpp
  • Apoxi_GuiPropertyIdIterator_hpp : GuiPropertyIdIterator.hpp
  • Apoxi_GuiPropertyIterator_hpp : GuiPropertyIterator.hpp
  • APOXI_HEAP_CONTEXT_USAGE : apoxi.defines
  • APOXI_HEAP_DISABLE_64K_ALIGNMENT : apoxi.defines
  • APOXI_HEAP_LENGTH_VECTOR : HeapVector.hpp, apoxi.defines
  • APOXI_HEAP_LOG : apoxi.defines
  • APOXI_HEAP_MEM_ACCESS_CHECK : HeapVector.hpp, apoxi.defines
  • APOXI_HEAP_MEM_ALLOC_TRACE : apoxi.defines
  • APOXI_HEAP_MEM_ALLOCS_PER_SIZE : HeapVector.hpp
  • APOXI_HEAP_MEM_ASSERT_ON_FAILED_ALLOC : apoxi.defines
  • APOXI_HEAP_MEM_CONTEXT_TRACE : apoxi.defines
  • APOXI_HEAP_MEM_CONTEXT_TRACE_MAX_CTX : apoxi.defines
  • APOXI_HEAP_MEM_DETECT_CONFIG : HeapVector.hpp, apoxi.defines
  • APOXI_HEAP_MEM_POOL_TRACE : apoxi.defines
  • APOXI_HEAP_NAME : HeapVector.hpp
  • APOXI_HEAP_NAME_PTR : HeapVector.hpp
  • APOXI_HEAP_NAME_USAGE : apoxi.defines
  • APOXI_HEAP_STATS_USAGE : apoxi.defines
  • APOXI_HEAP_TEST : HeapManager.cpp, apoxi.defines
  • Apoxi_HeapDataSink_hpp : HeapDataSink.hpp
  • Apoxi_HeapManager_hpp : HeapManager.hpp
  • Apoxi_HeapObject_hpp : HeapObject.hpp
  • Apoxi_HeapVector_hpp : HeapVector.hpp
  • Apoxi_HindiTextRenderer_hpp : HindiTextRenderer.hpp
  • Apoxi_HookedMessageReferrerList_hpp : HookedMessageReferrerList.hpp
  • APOXI_HOST_NAME_LEN_MAX : SocketTypes.hpp, apoxi.defines
  • APOXI_HOST_USE_DUMMY_PCH : apoxi.defines
  • APOXI_HOST_USE_PCH_SIGNALS : apoxi.defines
  • Apoxi_HostAudioDriver_hpp : HostAudioDriver.hpp
  • Apoxi_HostAudioGatiServer_hpp : HostAudioGatiServer.hpp
  • Apoxi_HostCoreFsSim_hpp : HostCoreFsSim.hpp
  • Apoxi_HostDebugTimeStamp_hpp : HostDebugTimeStamp.hpp
  • Apoxi_HostIniFile_hpp : HostIniFile.hpp
  • APOXI_HTTPSERVER_DEFAULT_BACKLOG : HttpTypes.hpp
  • APOXI_HTTPSERVER_DEFAULT_MAX_USERS : HttpTypes.hpp
  • APOXI_IANA_ALL_PORT_NUMBERS : apoxi.defines
  • Apoxi_Iana_hpp : Iana.hpp
  • APOXI_ICC_SIM : apoxi.defines
  • APOXI_ICC_USIM : apoxi.defines
  • Apoxi_IconSet_hpp : IconSet.hpp
  • Apoxi_IconState_hpp : IconState.hpp
  • Apoxi_Image_hpp : Image.hpp
  • Apoxi_ImageBox_hpp : ImageBox.hpp
  • Apoxi_ImageBrowserApp_hpp : ImageBrowserApp.hpp
  • Apoxi_ImageBrowserDetailWin_hpp : ImageBrowserDetailWin.hpp
  • Apoxi_ImageBrowserTestWin_hpp : ImageBrowserTestWin.hpp
  • Apoxi_ImageBrowserWin_hpp : ImageBrowserWin.hpp
  • Apoxi_ImageDecoder_hpp : ImageDecoder.hpp
  • Apoxi_ImageEncoder_hpp : ImageEncoder.hpp
  • Apoxi_ImageFactory_hpp : ImageFactory.hpp
  • Apoxi_ImageItem_hpp : ImageItem.hpp
  • Apoxi_ImageListBoxModel_hpp : ImageListBoxModel.hpp
  • Apoxi_ImageMetaData_hpp : ImageMetaData.hpp
  • Apoxi_ImageObtainer_hpp : ImageObtainer.hpp
  • Apoxi_ImageRef_hpp : ImageRef.hpp
  • Apoxi_ImageRefContainer_hpp : ImageRefContainer.hpp
  • Apoxi_ImageRefGenContainer_hpp : ImageRefGenContainer.hpp
  • Apoxi_ImageView_hpp : ImageView.hpp
  • Apoxi_ImageViewListBoxModel_hpp : ImageViewListBoxModel.hpp
  • Apoxi_ImgBrowserSaveWin_hpp : BrowserSaveWin.hpp
  • APOXI_INCLUDE_DRM : apoxi.defines
  • Apoxi_InetSocket_hpp : InetSocket.hpp
  • Apoxi_InetSocketAddr_hpp : InetSocketAddr.hpp
  • Apoxi_InfoDialog_hpp : InfoDialog.hpp
  • Apoxi_InputMap_hpp : InputMap.hpp
  • Apoxi_InputMapper_hpp : InputMapper.hpp
  • Apoxi_InputStream_hpp : InputStream.hpp
  • Apoxi_IpAddr_hpp : IpAddr.hpp
  • Apoxi_IpAddrCompoundItem_hpp : IpAddrCompoundItem.hpp
  • Apoxi_IpAddrEditor_hpp : IpAddrEditor.hpp
  • Apoxi_IpAddrEditorDocument_hpp : IpAddrEditorDocument.hpp
  • Apoxi_IpAddrInputMapper_hpp : IpAddrInputMapper.hpp
  • Apoxi_IpAddrPrompt_hpp : IpAddrPrompt.hpp
  • Apoxi_IpPortNo_hpp : IpPortNo.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ASCII : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_1 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_2 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_3 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_4 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_5 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_6 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_7 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_8 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_ISO_8859_9 : IrdaTypes.hpp
  • APOXI_IRDA_CHAR_SET_CODE_UNICODE : IrdaTypes.hpp
  • APOXI_IRDA_HINT_COMPUTER : IrdaTypes.hpp
  • APOXI_IRDA_HINT_EXT : IrdaTypes.hpp
  • APOXI_IRDA_HINT_FAX : IrdaTypes.hpp
  • APOXI_IRDA_HINT_FILE : IrdaTypes.hpp
  • APOXI_IRDA_HINT_HTTP : IrdaTypes.hpp
  • APOXI_IRDA_HINT_IRCOMM : IrdaTypes.hpp
  • APOXI_IRDA_HINT_LAN : IrdaTypes.hpp
  • APOXI_IRDA_HINT_MESSAGE : IrdaTypes.hpp
  • APOXI_IRDA_HINT_MODEM : IrdaTypes.hpp
  • APOXI_IRDA_HINT_OBEX : IrdaTypes.hpp
  • APOXI_IRDA_HINT_PDA : IrdaTypes.hpp
  • APOXI_IRDA_HINT_PNP : IrdaTypes.hpp
  • APOXI_IRDA_HINT_PRINTER : IrdaTypes.hpp
  • APOXI_IRDA_HINT_TELEPHONY : IrdaTypes.hpp
  • APOXI_IRDA_OBEX_HEADER_BUFF_SIZE : IrdaObexImpl.hpp
  • APOXI_IRDA_OBEX_MAX_CHANNELS : IrdaObexImpl.hpp
  • APOXI_IRDA_OFFSET_HINT_COMPUTER : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_FAX : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_FILE : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_HTTP : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_IRCOMM : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_LAN : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_MESSAGE : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_MODEM : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_OBEX : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_PDA : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_PNP : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_PRINTER : IrdaTypes.hpp
  • APOXI_IRDA_OFFSET_HINT_TELEPHONY : IrdaTypes.hpp
  • Apoxi_IrdaObexAddress_hpp : IrdaObexAddr.hpp
  • Apoxi_IrdaObexImpl_hpp : IrdaObexImpl.hpp
  • Apoxi_IrdaObexTransport_hpp : IrdaObexTransport.hpp
  • Apoxi_IrdaTransport_hpp : IrdaTransport.hpp
  • Apoxi_IrdaTypes_hpp : IrdaTypes.hpp
  • Apoxi_IsrDataContainer_hpp : IsrDataContainer.hpp
  • Apoxi_IsrDataManager_hpp : IsrDataManager.hpp
  • Apoxi_IsrDataMarshaller_hpp : IsrDataMarshaller.hpp
  • Apoxi_Item_hpp : Item.hpp
  • Apoxi_ItemBox_hpp : ItemBox.hpp
  • Apoxi_ItemContainer_hpp : ItemContainer.hpp
  • Apoxi_ItemGrid_hpp : ItemGrid.hpp
  • Apoxi_ItemMenu_hpp : ItemMenu.hpp
  • Apoxi_ItemRendererProperties_hpp : ItemRendererProperties.hpp
  • Apoxi_ItemTree_hpp : ItemTree.hpp
  • Apoxi_JapaneseTextRenderer_hpp : JapaneseTextRenderer.hpp
  • Apoxi_JapaneseTranscoder_hpp : JapaneseTranscoder.hpp
  • Apoxi_JpegDecoder_hpp : JpegDecoder.hpp
  • Apoxi_JpegEncoder_hpp : JpegEncoder.hpp
  • Apoxi_JpegEncodingThreadlet_hpp : JpegEncodingThreadlet.hpp
  • Apoxi_JpegImage_hpp : JpegImage.hpp
  • Apoxi_KeyboardConfig_hpp : KeyboardConfig.hpp
  • Apoxi_LanguageManager_hpp : LanguageManager.hpp
  • Apoxi_Layouter_hpp : Layouter.hpp
  • APOXI_LED_NEW_INTERFACE : apoxi.defines
  • APOXI_LETTERCLASSE_SUPPORT : apoxi.defines
  • APOXI_LIB_ADDON_AFSFAT : apoxi.defines
  • APOXI_LIB_ADDON_AFSFFS : apoxi.defines
  • APOXI_LIB_ADDON_AFSRAM : apoxi.defines
  • APOXI_LIB_ADDON_AFSRFS : apoxi.defines
  • APOXI_LIB_ADDON_MMCALL : apoxi.defines
  • APOXI_LIB_ADDON_VR : apoxi.defines
  • APOXI_LIB_BLUETOOTH : apoxi.defines
  • APOXI_LIB_IRDA : apoxi.defines
  • APOXI_LIB_OBEX : apoxi.defines
  • Apoxi_LineEditor_hpp : LineEditor.hpp
  • Apoxi_Linkable_hpp : Linkable.hpp
  • Apoxi_LinkedList_hpp : LinkedList.hpp
  • APOXI_LITTLE_ENDIAN : MachType.hpp, apoxi.defines
  • Apoxi_LocalDataStore_hpp : LocalDataStore.hpp
  • Apoxi_Locale_hpp : Locale.hpp
  • Apoxi_LocaleConfig_hpp : LocaleConfig.hpp
  • Apoxi_LockTable_hpp : LockTable.hpp
  • Apoxi_LockTableList_hpp : LockTableList.hpp
  • Apoxi_Lwip_SysDnsClient_hpp : LwipSysDnsClient.hpp
  • Apoxi_Lwip_SysSocket_hpp : LwipSysSocket.hpp
  • Apoxi_MachType_hpp : MachType.hpp
  • Apoxi_Macros_hpp : Macros.hpp
  • Apoxi_MapiAudioPlayer_hpp : MapiAudioPlayer.hpp
  • Apoxi_MapiAudioReference_hpp : MapiAudioReference.hpp
  • APOXI_MAX_CONN_LIMIT : HttpWapMgr.hpp
  • APOXI_MAX_DISPLAY_COUNT : DeviceManager.hpp, apoxi.defines
  • APOXI_MAX_INET_SOCKET_COUNT : SocketTypes.hpp, apoxi.defines
  • APOXI_MAX_LANGUAGE_COUNT : LanguageManager.hpp, apoxi.defines
  • APOXI_MAX_NET_FILENAME_LENGTH : RfsConfig.hpp
  • APOXI_MAX_NET_STORAGE_DEVICE_ID_LENGTH : RfsConfig.hpp
  • APOXI_MAX_PATHNAME_LENGTH : RfsConfig.hpp
  • APOXI_MAX_RESPONSE_LEN : AragonServer.cpp
  • APOXI_MAX_SOFTKEY_COUNT : Window.hpp, SoftkeyBar.hpp, apoxi.defines
  • APOXI_MAX_THAI_BUFFER_LENGTH : ThaiTextRenderer.cpp
  • Apoxi_Media_hpp : Media.hpp
  • Apoxi_MediaBrowserUtils_hpp : MediaBrowserUtils.hpp
  • Apoxi_MediaFilter_hpp : MediaFilter.hpp
  • Apoxi_MediaFrameworkCaps_hpp : MediaFrameworkCaps.hpp
  • Apoxi_MediaInfo_hpp : MediaInfo.hpp
  • Apoxi_MediaObtainer_hpp : MediaObtainer.hpp
  • Apoxi_MediaRef_hpp : MediaRef.hpp
  • Apoxi_MediaRefContainer_hpp : MediaRefContainer.hpp
  • Apoxi_MediaVisitor_hpp : MediaVisitor.hpp
  • APOXI_MEM_TRACE : apoxi.defines
  • APOXI_MEMORY_WIN32_REDIRECT_HUGEALLOCATION : apoxi.defines
  • Apoxi_MemoryConfig_hpp : MemoryConfig.hpp
  • Apoxi_MemPool_hpp : MemPool.hpp
  • Apoxi_MemPool_tpl : MemPool.cpp
  • Apoxi_Menu_hpp : Menu.hpp
  • Apoxi_MenuAccessor_hpp : MenuAccessor.hpp
  • Apoxi_MenuItem_hpp : MenuItem.hpp
  • Apoxi_MenuList_hpp : MenuList.hpp
  • Apoxi_MenuTextIterator_hpp : MenuTextIterator.hpp
  • Apoxi_MenuTextPtrArrayIterator_hpp : MenuTextPtrArrayIterator.hpp
  • Apoxi_MenuWindow_hpp : MenuWindow.hpp
  • Apoxi_MessageBox_hpp : MessageBox.hpp
  • Apoxi_MessageHook_hpp : MessageHook.hpp
  • Apoxi_MessageHookList_hpp : MessageHookList.hpp
  • Apoxi_MessageHookNotificationMsg_hpp : MessageHookNotificationMsg.hpp
  • Apoxi_MessageMap_hpp : MessageMap.hpp
  • Apoxi_MessageMapDispatcher_hpp : MessageMapDispatcher.hpp
  • Apoxi_MessageReferrer_hpp : MessageReferrer.hpp
  • Apoxi_MessageRouter_hpp : MessageRouter.hpp
  • Apoxi_MetaData_hpp : MetaData.hpp
  • APOXI_MIME_EXT : MimeTypeTableUtils.hpp
  • APOXI_MIME_LINE_WIDTH : MimeCoding.hpp
  • APOXI_MIME_STR : MimeTypeTableUtils.hpp
  • APOXI_MIME_TEST_LEN : MimeCoding.cpp
  • Apoxi_MmCallDispatcher_hpp : MmCallDispatcher.hpp
  • Apoxi_MmCallHandler_hpp : MmCallHandler.hpp
  • Apoxi_MmCallInfo_hpp : MmCallInfo.hpp
  • Apoxi_MmCallSerialTerminalListener_hpp : MmCallSerialTerminalListener.hpp
  • APOXI_MMCI_SUPPORT : apoxi.defines
  • Apoxi_MmfPlayer_hpp : MmfPlayer.hpp
  • Apoxi_MmiSimClient_hpp : MmiSimClient.hpp
  • Apoxi_MmiSimServer_hpp : MmiSimServer.hpp
  • Apoxi_Model_hpp : Model.hpp
  • APOXI_MP3_SUPPORT : apoxi.defines
  • APOXI_MSG_QUEUE_KEY_ENTRY_LIMIT : apoxi.defines
  • APOXI_MSG_QUEUE_YIELD_COUNTER : apoxi.defines
  • APOXI_MSG_QUEUE_YIELD_PERIOD : MsgQueue.cpp, apoxi.defines
  • Apoxi_MsgQueue_hpp : MsgQueue.hpp
  • Apoxi_MultiLineEditor_hpp : MultiLineEditor.hpp
  • APOXI_MULTIMEDIA_SUPPORT : apoxi.defines
  • Apoxi_MultiMediaEditor_hpp : MultiMediaEditor.hpp
  • Apoxi_MultiMediaEditorDocument_hpp : MultiMediaEditorDocument.hpp
  • Apoxi_Multipart_Mime_hpp : MultipartParser.hpp
  • Apoxi_MultiTapCaret_hpp : MultiTapCaret.hpp
  • Apoxi_MultiTapInputMapper_hpp : MultiTapInputMapper.hpp
  • Apoxi_Mutex_hpp : Mutex.hpp
  • Apoxi_MyDataConnProfileStorage_hpp : MyDataConnProfileStorage.hpp
  • Apoxi_NativeImage_hpp : NativeImage.hpp
  • Apoxi_NetAdapterHandler_hpp : NetAdapterHandler.hpp
  • APOXI_NEVER_TIMEOUT : Nuc32.hpp
  • Apoxi_NewAPI_VibratorDevice_hpp : VibratorDevice.hpp
  • Apoxi_NiSharedPtr_hpp : NiSharedPtr.hpp
  • APOXI_NO_MSG_BROADCAST_ON_STARTUP : apoxi.defines
  • Apoxi_NodeFileHandler_hpp : NodeFileHandler.hpp
  • Apoxi_NonCloneable_hpp : NonCloneable.hpp
  • APOXI_NOSTREAMING : apoxi.defines
  • Apoxi_NotificationTable_hpp : NotificationTable.hpp
  • Apoxi_Nuc32_hpp : Nuc32.hpp
  • Apoxi_Nuc32_Thread_hpp : Thread.hpp
  • Apoxi_NumberPrompt_hpp : NumberPrompt.hpp
  • Apoxi_NumericInputMapper_hpp : NumericInputMapper.hpp
  • APOXI_OBEX_DATA_SERVER_STATE : ObexDataServer.cpp
  • APOXI_OBEX_DBG_OUT : ObexConfig.hpp
  • APOXI_OBEX_FTP_DBG : ObexConfig.hpp
  • APOXI_OBEX_MAX_NO_SELECTIONS : ObexConfig.hpp, apoxi.defines
  • APOXI_OBEX_MAX_NO_TRANSPORTS : ObexConfig.hpp, apoxi.defines
  • APOXI_OBEX_OPP_DBG : ObexConfig.hpp
  • Apoxi_ObexAbstractPort_hpp : ObexAbstractPort.hpp
  • Apoxi_ObexAddress_hpp : ObexAddress.hpp
  • Apoxi_ObexAddrPtr_hpp : ObexAddrPtr.hpp
  • Apoxi_ObexBuffer_hpp : ObexBuffer.hpp
  • Apoxi_ObexChannel_hpp : ObexChannel.hpp
  • Apoxi_ObexClient_hpp : ObexClient.hpp
  • Apoxi_ObexClientDispatcher_hpp : ObexClientDispatcher.hpp
  • Apoxi_ObexClientOppImpl_hpp : ObexClientOppImpl.hpp
  • Apoxi_ObexClientPort_hpp : ObexClientPort.hpp
  • Apoxi_ObexConfig_hpp : ObexConfig.hpp
  • Apoxi_ObexDataServer_hpp : ObexDataServer.hpp
  • Apoxi_ObexDispatcher_hpp : ObexDispatcher.hpp
  • Apoxi_ObexFtpDataServer_hpp : ObexFtpDataServer.hpp
  • Apoxi_ObexFtpServer_hpp : ObexFtpServer.hpp
  • Apoxi_ObexHeader_hpp : ObexHeader.hpp
  • Apoxi_ObexHeaderBuilder_hpp : ObexHeaderBuilder.hpp
  • Apoxi_ObexHeaderList_hpp : ObexHeaderList.hpp
  • Apoxi_ObexLayer_hpp : ObexLayer.hpp
  • Apoxi_ObexMngr_hpp : ObexMngr.hpp
  • Apoxi_ObexObject_hpp : ObexObject.hpp
  • Apoxi_ObexObjectData_hpp : ObexObjectData.hpp
  • Apoxi_ObexOperationId_hpp : ObexOperationId.hpp
  • Apoxi_ObexOppBinDataPushClient_hpp : ObexOppBinDataPushClient.hpp
  • Apoxi_ObexOppClient_hpp : ObexOppClient.hpp
  • Apoxi_ObexOppDataSinkPushServer_hpp : ObexOppDataSinkPushServer.hpp
  • Apoxi_ObexOppLayer_hpp : ObexOppLayer.hpp
  • Apoxi_ObexOppServer_hpp : ObexOppServer.hpp
  • Apoxi_ObexProtocol_hpp : ObexProtocol.hpp
  • Apoxi_ObexResult_hpp : ObexResult.hpp
  • Apoxi_ObexServer_hpp : ObexServer.hpp
  • Apoxi_ObexServerDispatcher_hpp : ObexServerDispatcher.hpp
  • Apoxi_ObexServerInfo_hpp : ObexServerInfo.hpp
  • Apoxi_ObexServerMngr_hpp : ObexServerMngr.hpp
  • Apoxi_ObexServerOppImpl_hpp : ObexServerOppImpl.hpp
  • Apoxi_ObexServerPort_hpp : ObexServerPort.hpp
  • Apoxi_ObexServerVisitor_hpp : ObexServerVisitor.hpp
  • Apoxi_ObexTransport_hpp : ObexTransport.hpp
  • Apoxi_ObexTransportSet_hpp : ObexTransportSet.hpp
  • Apoxi_ObexTypes_hpp : ObexTypes.hpp
  • Apoxi_ObexUrlParser_hpp : ObexUrlParser.hpp
  • Apoxi_ObjectDataConverter_hpp : ObjectDataConverter.hpp
  • Apoxi_ObjectReferrer_hpp : ObjectReferrer.hpp
  • Apoxi_ObjectTreeService_hpp : ObjectTreeService.hpp
  • Apoxi_ObservableObject_hpp : ObservableObject.hpp
  • Apoxi_Observer_hpp : Observer.hpp
  • Apoxi_OpenContextMenuAction_hpp : OpenContextMenuAction.hpp
  • Apoxi_OpenWindowAction_hpp : OpenWindowAction.hpp
  • Apoxi_OptionalConfig_hpp : OptionalConfig.hpp
  • Apoxi_OptionalConfigBase_hpp : OptionalConfigBase.hpp
  • Apoxi_Os_hpp : Os.hpp
  • Apoxi_Os_NucInc_hpp : NucInc.hpp
  • Apoxi_Os_OsStrLib_hpp : OsStrLib.hpp
  • Apoxi_Os_Scheduler_hpp : Scheduler.hpp
  • Apoxi_Os_Semaphore_hpp : Semaphore.hpp
  • Apoxi_Os_SimpleSemaphore_hpp : SimpleSemaphore.hpp
  • Apoxi_Os_SocketPeer_hpp : SocketPeer.hpp
  • Apoxi_Os_SystemTimer_hpp : SystemTimer.hpp
  • Apoxi_Os_Thread_hpp : Thread.hpp
  • Apoxi_Os_Ticks_hpp : Ticks.hpp
  • Apoxi_Os_Trap_hpp : Trap.hpp
  • Apoxi_Os_Win32_DnsClient_hpp : DummyDnsClient.hpp
  • Apoxi_Os_WinInc_hpp : WinInc.hpp
  • Apoxi_OsClass_hpp : OsClass.hpp
  • Apoxi_OutputStream_hpp : OutputStream.hpp
  • Apoxi_PagingMap_hpp : PagingMap.hpp
  • Apoxi_PaintDc_hpp : PaintDc.hpp
  • Apoxi_Panel_hpp : Panel.hpp
  • Apoxi_ParagraphCompoundItem_hpp : ParagraphCompoundItem.hpp
  • Apoxi_ParagraphMarker_hpp : ParagraphMarker.hpp
  • Apoxi_PasswordEditor_hpp : PasswordEditor.hpp
  • Apoxi_Path_hpp : Path.hpp
  • Apoxi_Pathname_hpp : Pathname.hpp
  • Apoxi_PathProfile_hpp : PathProfile.hpp
  • Apoxi_Pen_hpp : Pen.hpp
  • Apoxi_PersistDataConnProfile_hpp : PersistDataConnProfile.hpp
  • APOXI_PHONENUMBER_MATCH_DEFAULT_DEPTH : apoxi.defines
  • APOXI_PHONENUMBER_TEST_SUITE : PhoneNumber.hpp, apoxi.defines
  • Apoxi_PhoneNumberInputMapper_hpp : PhoneNumberInputMapper.hpp
  • APOXI_PLATFORM_BP30 : apoxi.defines
  • APOXI_PLATFORM_MP1U : apoxi.defines
  • APOXI_PLATFORM_MPE : apoxi.defines
  • APOXI_PLATFORM_MPEU : apoxi.defines
  • APOXI_PNG_ENCODER_SUPPORT : apoxi.defines
  • Apoxi_PngDecoder_hpp : PngDecoder.hpp
  • Apoxi_PngEncoder_hpp : PngEncoder.hpp
  • Apoxi_PngEncodingThreadlet_hpp : PngEncodingThreadlet.hpp
  • Apoxi_PngImage_hpp : PngImage.hpp
  • Apoxi_Point_hpp : Point.hpp
  • APOXI_POLYGON_EDGES_MAX : DeviceContext.cpp, apoxi.defines
  • Apoxi_PositionIndicator_hpp : PositionIndicator.hpp
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_LOWER_BOUND : Os.hpp, apoxi.defines
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_RANGE : apoxi.defines
  • APOXI_POWERSAVING_TIMER_ALIGNMENT_UPPER_BOUND : Os.hpp, apoxi.defines
  • Apoxi_PppDataConn_hpp : PppDataConn.hpp
  • Apoxi_PredInputMapper_hpp : PredInputMapper.hpp
  • Apoxi_ProgressBar_hpp : ProgressBar.hpp
  • Apoxi_Protector_hpp : Protector.hpp
  • Apoxi_ProviderListBox_hpp : ProviderListBox.hpp
  • Apoxi_PsdDataConn_hpp : PsdDataConn.hpp
  • Apoxi_PsdDataConnProfile_hpp : PsdDataConnProfile.hpp
  • Apoxi_PushButton_hpp : PushButton.hpp
  • Apoxi_RadioButton_hpp : RadioButton.hpp
  • Apoxi_RadioButtonAction_hpp : RadioButtonAction.hpp
  • Apoxi_RadioButtonControl_hpp : RadioButtonControl.hpp
  • Apoxi_RadioButtonGroup_hpp : RadioButtonGroup.hpp
  • Apoxi_RadioButtonItem_hpp : RadioButtonItem.hpp
  • Apoxi_RadioButtonList_hpp : RadioButtonList.hpp
  • APOXI_RAM_STORAGE_DEFAULT_BLOCK_SIZE : apoxi.defines, RamTypes.hpp
  • Apoxi_RamDataSink_hpp : RamDataSink.hpp
  • Apoxi_RamDataSource_hpp : RamDataSource.hpp
  • Apoxi_RamDirectoryIteratorImp_hpp : RamDirectoryIteratorImp.hpp
  • Apoxi_RamFileImp_hpp : RamFileImp.hpp
  • Apoxi_RamStorageDeviceImp_hpp : RamStorageDeviceImp.hpp
  • APOXI_RAT_DUAL : apoxi.defines
  • APOXI_RAT_GSM : apoxi.defines
  • APOXI_RAT_UMTS : apoxi.defines
  • Apoxi_RecordSettings_hpp : RecordSettings.hpp
  • Apoxi_Rect_hpp : Rect.hpp
  • APOXI_REG_INVALID_FILE_ID : RegDefines.hpp
  • APOXI_REG_INVALID_LOCKID : RegistryTypes.hpp
  • APOXI_REG_INVALID_TRANSACTION_ID : RegDefines.hpp
  • APOXI_REG_LARGE_BLOB_SIZE : apoxi.defines, RegDefines.hpp
  • APOXI_REG_MAP_FILE_RECORDS_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_MAX_ASOT : apoxi.defines, GuidServiceTable.hpp
  • APOXI_REG_MAX_MIME_TYPE_LEN : RegBlobObject.hpp, apoxi.defines
  • APOXI_REG_MAX_POOL_BUFFERS : apoxi.defines, RegDefines.hpp
  • APOXI_REG_MAX_RECURSION_DEPTH : RegDefines.hpp
  • APOXI_REG_MAX_URIS_IN_TABLE : apoxi.defines, LockTable.hpp
  • APOXI_REG_NODE_FILE_SIZE_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_NODE_NAME_SIZE_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_SMALL_BLOB_SIZE_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_URI_SIZE_MAX : apoxi.defines, RegDefines.hpp
  • APOXI_REG_VERSION : apoxi.defines, Registry.cpp
  • Apoxi_RegDefines_hpp : RegDefines.hpp
  • Apoxi_RegDeleteBuffer_hpp : RegDeleteBuffer.hpp
  • APOXI_REGISTERED_TABLE_SIZE : apoxi.defines, NotificationTable.hpp
  • Apoxi_Registry_hpp : Registry.hpp
  • APOXI_REGISTRY_TEST : apoxi.defines
  • APOXI_REGISTRY_VERSION : RegDefines.hpp
  • Apoxi_RegistryTypes_hpp : RegistryTypes.hpp
  • Apoxi_RegIterator_hpp : RegIterator.hpp
  • Apoxi_RegManager_hpp : RegManager.hpp
  • Apoxi_RegMemoryPool_hpp : RegMemoryPool.hpp
  • Apoxi_RegNodeFile_hpp : RegNodeFile.hpp
  • Apoxi_RenameDialog_hpp : RenameFileDialog.hpp
  • Apoxi_ResourceManager_hpp : ResourceManager.hpp
  • Apoxi_ResourceParser_hpp : ResourceParser.hpp
  • Apoxi_ResourceReader_hpp : ResourceReader.hpp
  • Apoxi_RfsConfig_hpp : RfsConfig.hpp
  • Apoxi_RichTextCompoundItem_hpp : RichTextCompoundItem.hpp
  • Apoxi_RingBuffer_hpp : RingBuffer.hpp
  • APOXI_RINGER_DEVICE_PRESENT : audio_private.hpp
  • Apoxi_RingerAudioPlayer_hpp : RingerAudioPlayer.hpp
  • Apoxi_RomFont_hpp : RomFont.hpp
  • Apoxi_RootDirectoryIteratorImp_hpp : RootDirectoryIteratorImp.hpp
  • Apoxi_RootFileImp_hpp : RootFileImp.hpp
  • Apoxi_RootFileSystem_hpp : RootFileSystem.hpp
  • Apoxi_RootStorageDeviceImp_hpp : RootStorageDeviceImp.hpp
  • APOXI_RTOS_DUMMY : apoxi.defines
  • APOXI_RTOS_LINUX : apoxi.defines
  • APOXI_RTOS_NUC16 : apoxi.defines
  • APOXI_RTOS_NUC16S : apoxi.defines
  • APOXI_RTOS_NUC16U : apoxi.defines
  • APOXI_RTOS_NUC32 : apoxi.defines
  • APOXI_RTOS_OSE166 : apoxi.defines
  • APOXI_RTOS_POCKETPC : apoxi.defines
  • APOXI_RTOS_SIM166 : apoxi.defines
  • APOXI_RTOS_WIN32 : apoxi.defines
  • Apoxi_RtStreamingBuffer_hpp : RtStreamingBuffer.hpp
  • Apoxi_RtStreamingConn_hpp : RtStreamingConn.hpp
  • Apoxi_RtStreamingEndPoint_hpp : RtStreamingEndPoint.hpp
  • Apoxi_RtStreamingSink_hpp : RtStreamingSink.hpp
  • Apoxi_RtStreamingSource_hpp : RtStreamingSource.hpp
  • Apoxi_RuntimeConfigurator_hpp : RuntimeConfigurator.hpp
  • Apoxi_SampleImages_hpp : SampleImages.hpp
  • Apoxi_SampleIMelodies_hpp : SampleIMelodies.hpp
  • Apoxi_Scheduler_hpp : Scheduler.hpp
  • APOXI_SCICOS_MM_CHIP_SUPPORT : apoxi.defines
  • Apoxi_ScrollBehavior_hpp : ScrollBehavior.hpp
  • APOXI_SDMMCSPI_SUPPORT : apoxi.defines
  • APOXI_SECURECLOCK_SUPPORT : apoxi.defines
  • Apoxi_SelectionBox_hpp : SelectionBox.hpp
  • Apoxi_Semaphore_cpp : Semaphore.cpp
  • Apoxi_Semaphore_hpp : Semaphore.hpp
  • APOXI_SEMAPHORE_M_FIRST_SWE : apoxi.defines
  • Apoxi_SemObtainer_hpp : SemObtainer.hpp
  • APOXI_SER_DATACONN_SUPPORT : apoxi.defines
  • Apoxi_SerialSocketData_hpp : SerialSocketData.hpp
  • Apoxi_SerialSocketSubSystem_hpp : SerialSocketSubSystem.hpp
  • Apoxi_SerialSocketThread_hpp : SerialSocketThread.hpp
  • Apoxi_SerialTerminal_hpp : SerialTerminal.hpp
  • Apoxi_SerialTerminalListener_hpp : SerialTerminalListener.hpp
  • Apoxi_SerialTerminalSocket_hpp : SerialTerminalSocket.hpp
  • APOXI_SERVER_DEFAULT_BACKLOG : Server.hpp
  • APOXI_SERVER_DEFAULT_MAX_USERS : Server.hpp
  • Apoxi_ServiceThread_hpp : ServiceThread.hpp
  • Apoxi_ServiceThreadStarter_hpp : ServiceThreadStarter.hpp
  • Apoxi_SetLanguageAction_hpp : SetLanguageAction.hpp
  • Apoxi_SetThemeAction_hpp : SetThemeAction.hpp
  • Apoxi_SharedPtr_hpp : SharedPtr.hpp
  • Apoxi_SharedTimer_hpp : SharedTimer.hpp
  • APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT : ShutDown.cpp, apoxi.defines
  • APOXI_SHUTDOWN_CHECK_APPLICATIONS_INTERVAL : ShutDown.cpp, apoxi.defines
  • Apoxi_ShutDown_hpp : ShutDown.hpp
  • Apoxi_SimpleMap_hpp : SimpleMap.hpp
  • Apoxi_SimpleMutex_hpp : SimpleMutex.hpp
  • Apoxi_SimpleScheduler_hpp : SimpleScheduler.hpp
  • Apoxi_SimpleSemaphore_cpp : SimpleSemaphore.cpp
  • Apoxi_SimpleSemaphore_hpp : SimpleSemaphore.hpp
  • Apoxi_SimpleTextRenderer_hpp : SimpleTextRenderer.hpp
  • APOXI_SIMTK_TRANSACTIONID_SUPPORT : apoxi.defines
  • Apoxi_SimTkLceService_hpp : SimTkLceService.hpp
  • Apoxi_SingleArgHook_hpp : SingleArgHook.hpp
  • Apoxi_SioGlueSignalListener_hpp : SioGlueSignalListener.hpp
  • Apoxi_SioGlueWrapper_hpp : SioGlueWrapper.hpp
  • Apoxi_SioSocketAdapter_hpp : SioSocketAdapter.hpp
  • APOXI_SIZE_16_KILO_BYTE : RegDefines.hpp
  • Apoxi_Size_hpp : Size.hpp
  • APOXI_SMS_NEW_PROVIDERS : apoxi.defines
  • APOXI_SMS_NOWAIT_ON_RELOAD : apoxi.defines
  • APOXI_SMSSOCKET_MAX_CACHED_TPDUS : SmsSocketListener.hpp, apoxi.defines
  • APOXI_SMSSOCKET_MAX_SUBSCRIBED_APPS : SmsSocketListener.hpp, apoxi.defines
  • Apoxi_Socket_DnsClientTypes_hpp : DnsClientTypes.hpp
  • APOXI_SOCKET_ENSURE_CONTEXT : apoxi.defines
  • APOXI_SOCKET_EXTENDED_TRACE : apoxi.defines
  • Apoxi_Socket_hpp : Socket.hpp
  • APOXI_SOCKET_OPERATION_LOCK : apoxi.defines
  • APOXI_SOCKET_PARANOIA : apoxi.defines
  • APOXI_SOCKET_SYSTEM_BSD : apoxi.defines
  • APOXI_SOCKET_SYSTEM_DUMMY : apoxi.defines
  • APOXI_SOCKET_SYSTEM_LWIP : apoxi.defines
  • APOXI_SOCKET_SYSTEM_USNET : apoxi.defines
  • APOXI_SOCKET_SYSTEM_WIN32 : SysSocket.hpp, apoxi.defines
  • Apoxi_SocketData_hpp : SocketData.hpp
  • Apoxi_SocketDataLock_hpp : SocketDataLock.hpp, SerialSocketDataLock.hpp
  • Apoxi_SocketHandler_hpp : SocketHandler.hpp
  • Apoxi_SocketRxThread_hpp : SocketRxThread.hpp
  • Apoxi_SocketSerialTerminalListener_hpp : SocketSerialTerminalListener.hpp
  • Apoxi_SocketSubSystem_hpp : SocketSubSystem.hpp
  • Apoxi_SocketTypes_hpp : SocketTypes.hpp
  • Apoxi_SoftkeyBar_hpp : SoftkeyBar.hpp
  • Apoxi_SoundBrowserApp_hpp : SoundBrowserApp.hpp
  • Apoxi_SoundBrowserTestWin_hpp : SoundBrowserTestWin.hpp
  • Apoxi_SoundBrowserWin_hpp : SoundBrowserWin.hpp
  • Apoxi_SoundItem_hpp : SoundItem.hpp
  • Apoxi_SoundMetaData_hpp : SoundMetaData.hpp
  • Apoxi_SoundRef_hpp : SoundRef.hpp
  • Apoxi_SoundRefContainer_hpp : SoundRefContainer.hpp
  • Apoxi_StartUp_hpp : StartUp.hpp
  • Apoxi_StateMachine_hpp : StateMachine.hpp
  • Apoxi_StillCamera_hpp : StillCamera.hpp
  • Apoxi_StorageDevice_hpp : StorageDevice.hpp
  • Apoxi_StorageDeviceFilter_hpp : StorageDeviceFilter.hpp
  • Apoxi_StorageDeviceIterator_hpp : StorageDeviceIterator.hpp
  • Apoxi_StorageDeviceVisitor_hpp : StorageDeviceVisitor.hpp
  • Apoxi_Stream_hpp : Stream.hpp
  • Apoxi_StreamingCallback_hpp : StreamingCallback.hpp
  • Apoxi_StreamingInfo_hpp : StreamingInfo.hpp
  • Apoxi_StreamingReadInfo_hpp : StreamingReadInfo.hpp
  • Apoxi_StreamingWriteInfo_hpp : StreamingWriteInfo.hpp
  • Apoxi_StreamObexTransport_hpp : StreamObexTransport.hpp
  • Apoxi_StreamReader_hpp : StreamReader.hpp
  • Apoxi_StreamWriter_hpp : StreamWriter.hpp
  • APOXI_STRING_EXTENDED_DEBUG : apoxi.defines
  • APOXI_STRING_TEST_SUITE : String.hpp, apoxi.defines
  • APOXI_StringUtil_h : StrUtil.hpp
  • Apoxi_StrokeBox_hpp : StrokeBox.hpp
  • Apoxi_SubMenuAction_hpp : SubMenuAction.hpp
  • Apoxi_SubSystem_hpp : SubSystem.hpp
  • Apoxi_SubSystemManager_hpp : SubSystemManager.hpp
  • APOXI_SUPPORT_CSMSREFNOREQ : apoxi.defines
  • APOXI_SUPPORT_MOSMS_TIMESTAMP : apoxi.defines
  • APOXI_SUPPORT_NETWORK_ECC_LIST : apoxi.defines
  • APOXI_SUPPORT_NORMAL_SMS_LOADING : apoxi.defines
  • APOXI_SUPPORT_SMS_DELETION_CMD : apoxi.defines
  • APOXI_SUPPORT_SMS_DELETION_CMD_GORS : apoxi.defines
  • APOXI_SUPPORT_SMS_NEWMSG_PAYLOAD : apoxi.defines
  • APOXI_SVG_FONT_SIZE : fonts.hpp
  • APOXI_SVG_SUPPORT : apoxi.defines
  • Apoxi_SvgConfig_hpp : SvgConfig.hpp
  • Apoxi_SvgDecoder_hpp : SvgDecoder.hpp
  • Apoxi_SvgFileWrapper_hpp : SvgFileWrapper.hpp
  • Apoxi_SvgFixPoint_hpp : SvgFixPoint.hpp
  • Apoxi_SvgGZFileWrapper_hpp : SvgGzFileWrapper.hpp
  • Apoxi_SvgImage_hpp : SvgImage.hpp
  • Apoxi_SvgImageFileWrapper_hpp : SvgImageFileWrapper.hpp
  • Apoxi_SvgIOWrapper_hpp : SvgIoWrapper.hpp
  • Apoxi_SvgPlayer_hpp : SvgPlayer.hpp
  • Apoxi_SvgPlayerDebug_hpp : SvgDebug.hpp
  • Apoxi_SvgPlayerMIMEUtil_hpp : SvgMimeUtil.hpp
  • Apoxi_SwitchedRleCompression_hpp : SwitchedRleCompression.hpp
  • APOXI_SYNC_RELEASE : apoxi.defines
  • Apoxi_SyncMLManager_hpp : SyncMLManager.hpp
  • Apoxi_SyncPaintDc_hpp : SyncPaintDc.hpp
  • Apoxi_Sys_BsdSysSocket_hpp : UsnetSysSocket.hpp, BsdSysSocket.hpp
  • Apoxi_Sys_Dummy_SysSocket_hpp : DummySysSocket.hpp
  • Apoxi_SysSock_hpp : SysSocket.hpp
  • Apoxi_SysSocketBase_hpp : SysSocketBase.hpp
  • Apoxi_System_hpp : System.hpp
  • APOXI_SYSTEM_STACK_SWAPPING : apoxi.defines
  • Apoxi_SystemTimer_hpp : SystemTimer.hpp
  • APOXI_T9_SUPPORT : apoxi.defines
  • Apoxi_T9InputConfig_hpp : T9InputConfig.hpp
  • Apoxi_T9InputMapper_hpp : T9InputMapper.hpp
  • Apoxi_T9Pack_hpp : T9Pack.hpp
  • Apoxi_T9PackConnector_hpp : T9PackConnector.hpp
  • Apoxi_T9PinyinBox_hpp : T9PinyinBox.hpp
  • Apoxi_T9PredictiveInputBox_hpp : T9PredictiveInputBox.hpp
  • Apoxi_TabButton_hpp : TabButton.hpp
  • Apoxi_TabControl_hpp : TabControl.hpp
  • APOXI_TARGETSYSTEM_HOST : apoxi.defines
  • APOXI_TARGETSYSTEM_HW : apoxi.defines
  • Apoxi_TcpServerSocket_hpp : TcpServerSocket.hpp
  • Apoxi_TcpSocket_hpp : TcpSocket.hpp
  • Apoxi_TcpSocketBase_hpp : TcpSocketBase.hpp
  • Apoxi_TestCheckBoxListView_hpp : TestCheckBoxListView.hpp
  • Apoxi_TestCheckBoxView_hpp : TestCheckBoxView.hpp
  • Apoxi_TestControlFrameView_hpp : TestControlFrameView.hpp
  • APOXI_TESTING : apoxi.defines
  • Apoxi_TestPositionIndicatorView_hpp : TestPositionIndicatorView.hpp
  • Apoxi_TestPushButtonView_hpp : TestPushButtonView.hpp
  • Apoxi_TestRadioButtonListView_hpp : TestRadioButtonListView.hpp
  • Apoxi_TestRadioButtonView_hpp : TestRadioButtonView.hpp
  • Apoxi_TestSoftkeyBarView_hpp : TestSoftkeyBarView.hpp
  • Apoxi_TestTheme_hpp : TestTheme.hpp
  • Apoxi_TestWindowFrameView_hpp : TestWindowFrameView.hpp
  • Apoxi_TestWriter_hpp : TestWriter.hpp
  • Apoxi_TextBox_hpp : TextBox.hpp
  • Apoxi_TextCompoundItem_hpp : TextCompoundItem.hpp
  • Apoxi_TextEditorDocument_hpp : TextEditorDocument.hpp
  • Apoxi_TextFormat_hpp : TextFormat.hpp
  • Apoxi_TextIconPairArray_hpp : TextIconPairArray.hpp
  • Apoxi_TextLine_hpp : TextLine.hpp
  • Apoxi_TextList_hpp : TextList.hpp
  • Apoxi_TextMenuAccessor_hpp : TextMenuAccessor.hpp
  • Apoxi_TextPack_hpp : TextPack.hpp
  • Apoxi_TextPackConnector_hpp : TextPackConnector.hpp
  • Apoxi_ThaiTextRenderer_hpp : ThaiTextRenderer.hpp
  • Apoxi_Theme_hpp : Theme.hpp
  • Apoxi_ThemeConfig_hpp : ThemeConfig.hpp
  • Apoxi_ThemeManager_hpp : ThemeManager.hpp
  • Apoxi_Thread_hpp : Thread.hpp
  • APOXI_THREAD_PRIORITY_NORMAL : Thread.hpp, apoxi.defines
  • Apoxi_Threadlet_hpp : Threadlet.hpp
  • Apoxi_ThreadSafeProvider_hpp : ThreadSafeProvider.hpp
  • Apoxi_Ticks_hpp : Ticks.hpp
  • Apoxi_TickValue_hpp : TickValue.hpp
  • Apoxi_Time_hpp : Time.hpp
  • Apoxi_TimeCompoundItem_hpp : TimeCompoundItem.hpp
  • Apoxi_TimeEditBox_hpp : TimeEditBox.hpp
  • Apoxi_TimeEditor_hpp : TimeEditor.hpp
  • Apoxi_TimeEditorDocument_hpp : TimeEditorDocument.hpp
  • Apoxi_TimeFeatureObject_hpp : TimeFeatureObject.hpp
  • Apoxi_Timer_hpp : Timer.hpp
  • Apoxi_TimeSpan_h : TimeSpan.hpp
  • Apoxi_TimeZone_hpp : TimeZone.hpp
  • Apoxi_ToggleActionGroup_hpp : ToggleActionGroup.hpp
  • Apoxi_TopLevelMenu_hpp : TopLevelMenu.hpp
  • APOXI_TRACE : Trace.hpp, apoxi.defines
  • APOXI_TRACE_DISABLED : apoxi.defines
  • APOXI_TRACE_LEVEL_2 : apoxi.defines
  • APOXI_TRACE_LEVEL_3 : apoxi.defines
  • APOXI_TRACE_MEM : apoxi.defines
  • APOXI_TRACE_SOCKETS : apoxi.defines
  • Apoxi_TraceOutputStream_hpp : TraceOutputStream.hpp
  • Apoxi_Trap_hpp : Trap.hpp
  • Apoxi_TriggerTimer_hpp : TriggerTimer.hpp
  • Apoxi_Types_hpp : Types.hpp
  • Apoxi_UdpSocket_hpp : UdpSocket.hpp
  • APOXI_UNICODE_EOF : Unicode.hpp
  • APOXI_UNITTEST : apoxi.defines
  • Apoxi_UnitTest_hpp : UnitTest.hpp
  • APOXI_UNITTEST_MMI : apoxi.defines
  • APOXI_UNITTEST_NO_FILENAMES : apoxi.defines
  • APOXI_UNITTEST_NO_MESSAGE : apoxi.defines
  • APOXI_UNITTEST_NO_TESTNAMES : apoxi.defines
  • APOXI_UNITTEST_STATIC_REPOSITORY : apoxi.defines
  • APOXI_UNITTEST_TCPIP : apoxi.defines
  • APOXI_UNITTEST_TRACE : apoxi.defines
  • Apoxi_UnitTestAutoRepository_hpp : UnitTestAutoRepository.hpp
  • Apoxi_UnitTestCase_hpp : UnitTestCase.hpp
  • Apoxi_UnitTestCaseAsync_hpp : AsyncUnitTestCase.hpp
  • Apoxi_UnitTestCommunicator_hpp : UnitTestCommunicator.hpp
  • Apoxi_UnitTestData_hpp : UnitTestData.hpp
  • Apoxi_UnitTestDecorator_hpp : Decorator.hpp
  • Apoxi_UnitTestRepository_hpp : UnitTestRepository.hpp
  • Apoxi_UnitTestResult_hpp : UnitTestResult.hpp
  • Apoxi_UnitTestRunner_hpp : UnitTestRunner.hpp
  • Apoxi_UnitTestStaticRepository_hpp : UnitTestStaticRepository.hpp
  • Apoxi_UnitTestSuite_hpp : UnitTestSuite.hpp
  • APOXI_UNZIP_BUFSIZE : Unzip.hpp
  • Apoxi_Unzip_hpp : Unzip.hpp
  • Apoxi_UnzipBinData_hpp : UnzipBinData.hpp
  • Apoxi_Unzipper_hpp : Unzipper.hpp
  • Apoxi_Uri_hpp : Uri.hpp
  • Apoxi_UriMappingTable_hpp : UriMappingTable.hpp
  • Apoxi_UsbObexTransport_hpp : UsbObexTransport.hpp
  • Apoxi_UserDispatcher_hpp : UserDispatcher.hpp
  • APOXI_UUS_SUPPORT : apoxi.defines
  • Apoxi_ValueMappingPropertyDescriptor_hpp : ValueMappingPropertyDescriptor.hpp
  • APOXI_VCARD_ADDRESS_MAX : VCard.hpp
  • APOXI_VCARD_ADR : VCard.cpp
  • APOXI_VCARD_ADR_COUNT : VCard.hpp
  • APOXI_VCARD_ADR_COUNTRY : VCard.hpp
  • APOXI_VCARD_ADR_EXTENDED : VCard.hpp
  • APOXI_VCARD_ADR_LOCALITY : VCard.hpp
  • APOXI_VCARD_ADR_POSTALCODE : VCard.hpp
  • APOXI_VCARD_ADR_POSTOFFICE : VCard.hpp
  • APOXI_VCARD_ADR_REGION : VCard.hpp
  • APOXI_VCARD_ADR_STREET : VCard.hpp
  • APOXI_VCARD_BEGIN : VCard.cpp
  • APOXI_VCARD_EMAIL : VCard.cpp
  • APOXI_VCARD_END : VCard.cpp
  • APOXI_VCARD_FN : VCard.cpp
  • APOXI_VCARD_N : VCard.cpp
  • APOXI_VCARD_NAME_ADD : VCard.hpp
  • APOXI_VCARD_NAME_COUNT : VCard.hpp
  • APOXI_VCARD_NAME_FAMILY : VCard.hpp
  • APOXI_VCARD_NAME_GIVEN : VCard.hpp
  • APOXI_VCARD_NAME_PREFIX : VCard.hpp
  • APOXI_VCARD_NAME_SUFFIX : VCard.hpp
  • APOXI_VCARD_ORG : VCard.cpp
  • APOXI_VCARD_ORG_ADDUNIT : VCard.hpp
  • APOXI_VCARD_ORG_MAX : VCard.hpp
  • APOXI_VCARD_ORG_NAME : VCard.hpp
  • APOXI_VCARD_ORG_UNIT : VCard.hpp
  • APOXI_VCARD_TEL : VCard.cpp
  • APOXI_VCARD_TITLE : VCard.cpp
  • APOXI_VCARD_TYPE_ADR_DEFAULT : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_DOM : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_HOME : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_INTL : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_PARCEL : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_POSTAL : VCard.hpp
  • APOXI_VCARD_TYPE_ADR_WORK : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_BBS : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_CAR : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_CELL : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_DEFAULT : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_FAX : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_HOME : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_ISDN : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_MODEM : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_MSG : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_PAGER : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_PREF : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_VIDEO : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_VOICE : VCard.hpp
  • APOXI_VCARD_TYPE_TEL_WORK : VCard.hpp
  • APOXI_VCARD_VERSION : VCard.cpp
  • APOXI_VCARD_X : VCard.cpp
  • Apoxi_VCardItem_hpp : VCardItem.hpp
  • Apoxi_Vector_hpp : Vector.hpp
  • APOXI_VIBRATOR_SUPPORT : apoxi.defines
  • APOXI_VIDEO_SUPPORT : apoxi.defines
  • Apoxi_VideoCamera_hpp : VideoCamera.hpp
  • Apoxi_VideoChannel_hpp : VideoChannel.hpp
  • Apoxi_VideoDecoder_hpp : VideoDecoder.hpp
  • Apoxi_VideoEncoder_hpp : VideoEncoder.hpp
  • Apoxi_VietnameseTextRenderer_hpp : VietnameseTextRenderer.hpp
  • Apoxi_View_hpp : View.hpp
  • Apoxi_VirtualDisplay_hpp : VirtualDisplay.hpp
  • APOXI_WAP_STACK : apoxi.defines
  • Apoxi_WbmpDecoder_hpp : WbmpDecoder.hpp
  • Apoxi_WbmpImage_hpp : WbmpImage.hpp
  • Apoxi_Wbxml_Vector_hpp : WbxmlVector.hpp
  • APOXI_WCATTR_NULL_DEF : apoxi.defines
  • Apoxi_WildcardStrncmp_hpp : WildcardStrncmp.hpp
  • Apoxi_Win32_hpp : Win32.hpp
  • Apoxi_Win32_SysDnsClient_hpp : Win32SysDnsClient.hpp
  • Apoxi_Win32_SysSocket_hpp : Win32SysSocket.hpp
  • Apoxi_Window_hpp : Window.hpp
  • Apoxi_WindowFrameView_hpp : WindowFrameView.hpp
  • Apoxi_WindowManager_hpp : WindowManager.hpp
  • Apoxi_WinMenuItem_hpp : WinMenuItem.hpp
  • Apoxi_WinRect_hpp : WinRect.hpp
  • APOXI_WSTRING_EXTENDED_DEBUG : apoxi.defines
  • APOXI_WSTRING_TEST_SUITE : WString.hpp, apoxi.defines
  • APOXI_YAMAHA_MAPI_SUPPORT : apoxi.defines
  • APOXI_YAMAHA_RINGER_SUPPORT : apoxi.defines
  • APOXI_ZI8_SUPPORT : apoxi.defines
  • Apoxi_Zi8AlphabetBox_hpp : Zi8AlphabetBox.hpp
  • Apoxi_Zi8InputConfig_hpp : Zi8InputConfig.hpp
  • Apoxi_Zi8InputMapper_hpp : Zi8InputMapper.hpp
  • Apoxi_Zi8PredictiveInputBox_hpp : Zi8PredictiveInputBox.hpp
  • Apoxi_Zi8SelectionBox_hpp : Zi8SelectionBox.hpp
  • Apoxi_Zi8StrokeBox_hpp : Zi8StrokeBox.hpp
  • APOXI_ZLIB_USE_STACK_MEM_FUNCS : apoxi.defines
  • ApoxiApp_FfsMenu_hpp : FfsMenu.hpp
  • ApoxiApp_FfsTestBase_hpp : FfsTestBase.hpp
  • ApoxiApp_FfsTestDispWin_hpp : FfsTestDispWin.hpp
  • ApoxiApp_FfsTestError_hpp : FfsTestError.hpp
  • ApoxiApp_FfsTestMenu_hpp : FfsTestMenu.hpp
  • ApoxiApp_FfsTestResultsMenu_hpp : FfsTestResultsMenu.hpp
  • ApoxiApp_FfsTests_hpp : FfsTests.hpp
  • ApoxiApp_FfsTestThread_hpp : FfsTestThread.hpp
  • ApoxiApp_FfsTestThreadlet_hpp : FfsTestThreadlet.hpp
  • ApoxiApp_SocketTestApp_hpp : SocketTestApp.hpp
  • ApoxiApp_SocketTestDefines_hpp : SocketTestDefines.hpp
  • ApoxiApp_SocketTestProgressWin_hpp : SocketTestProgressWin.hpp
  • ApoxiApp_SocketTestResultsWin_hpp : SocketTestResultsWin.hpp
  • ApoxiaPP_SocketTestSettingsWin_hpp : SocketTestSettingsWin.hpp
  • ApoxiApp_SocketTestT1_hpp : SocketTestT1.hpp
  • ApoxiApp_SocketTestT2_hpp : SocketTestT2.hpp
  • ApoxiApp_SocketTestT3_hpp : SocketTestT3.hpp
  • ApoxiApp_SocketTestT4_hpp : SocketTestT4.hpp
  • ApoxiApp_SocketTestT5_hpp : SocketTestT5.hpp
  • ApoxiApp_SocketTestT6_hpp : SocketTestT6.hpp
  • ApoxiApp_SocketTestT7_hpp : SocketTestT7.hpp
  • ApoxiApp_SocketTestT8_hpp : SocketTestT8.hpp
  • ApoxiApp_SocketTestT_hpp : SocketTestT.hpp
  • ApoxiApp_SocketTestTests_hpp : SocketTestTests.hpp
  • ApoxiApp_SocketTestWin_hpp : SocketTestWin.hpp
  • ApoxiApp_TcpServerTestSocket_hpp : TcpServerTestSocket.hpp
  • ApoxiApp_TcpTestSocket_hpp : TcpTestSocket.hpp
  • ApoxiApp_UdpTestSocket_hpp : UdpTestSocket.hpp
  • ApoxiBigEndian16BitConstant : MachType.hpp
  • ApoxiBigEndian32BitConstant : MachType.hpp
  • ApoxiDefineEntity : ValueMap.hpp
  • ApoxiDefineScopeEntity : ValueMap.hpp
  • ApoxiDefVersionInfo : VoiceMemoVersion.cpp, UsbVersion.cpp, UibVersion.cpp, SoundBrowserVersion.cpp, SocketTestVersion.cpp, ObexAppVersion.cpp, IrdaAppVersion.cpp, ImgbrVersion.cpp, FmRadioVersion.cpp, EmsVersion.cpp, DataConnVersion.cpp, ApbVersion.cpp, ApoxiKernelVersion.cpp, ApoxiGuiVersion.cpp, ApoxiAuxiliaryVersion.cpp, ApoxiAscVersion.cpp, ApoxiApcSignalHandlerVersion.cpp, ApoxiApcVersion.cpp, ApoxiAfsVersion.cpp, ApoxiVoiceRecognitionVersion.cpp, ApoxiHttpServerVersion.cpp, ApoxiFtpServerVersion.cpp, ApoxiServerVersion.cpp, MediaFrameworkVersion.cpp, ApoxiAfsRfsVersion.cpp, ApoxiAfsRamVersion.cpp, ApoxiAfsFfsVersion.cpp, ApoxiAfsFatVersion.cpp, ApoxiAdcVersion.cpp, VersionInfo.hpp
  • ApoxiLib_hpp : ApoxiVersion.hpp, ApoxiLib.hpp
  • ApoxiLittleEndian16BitConstant : MachType.hpp
  • ApoxiLIttleEndian32BitConstant : MachType.hpp
  • ApoxiMakeCountryCode : CountryCodes.hpp
  • ApoxiRb_DataConnAccessor_hpp : DataConnAccessor.hpp
  • ApoxiSwap16Bit : MachType.hpp
  • ApoxiSwap32Bit : MachType.hpp
  • ApoxiUseVersionInfo : VoiceMemoApp.cpp, UsbApp.cpp, UibApp.cpp, SoundBrowserApp.cpp, ObexApp.cpp, IrdaApp.cpp, ImageBrowserApp.cpp, FmRadioApplication.cpp, EmsApp.cpp, DataConnApp.cpp, Application.cpp, Window.cpp, String.cpp, MainHandler.cpp, ProcessNode.cpp, MessageImpl.cpp, MediaManager.cpp, DataHandler.cpp, VersionInfo.hpp
  • APOXIVERSION : ApoxiVersion.hpp
  • ApoxiVersionInfo_hpp : VersionInfo.hpp
  • APPLICATION_TRACER_HPP : ApplicationTracer.hpp
  • ApplicationID_hpp : ApplicationID.hpp
  • Applications_AdvPbMsgTypes_hpp : AdvPbMsgTypes.hpp
  • ARAGON : apoxi.features
  • ARCHIVE : FatSim.hpp
  • ARDONLY : FatSim.hpp
  • Asc_AccDispatcher_hpp : AccDispatcher.hpp
  • Asc_AccHandler_hpp : AccHandler.hpp
  • Asc_AdcInterface_hpp : AdcInterface.hpp
  • Asc_AocDispatcher_hpp : AocDispatcher.hpp
  • Asc_AocHandler_hpp : AocHandler.hpp
  • Asc_AtcDispatcher_hpp : AtcDispatcher.hpp
  • Asc_AtcHandler_hpp : AtcHandler.hpp
  • Asc_BattHandler_hpp : BattHandler.hpp
  • Asc_BootDispatcher_hpp : BootDispatcher.hpp
  • Asc_BootHandler_hpp : BootHandler.hpp
  • Asc_CallBarringHandler_hpp : CallBarringHandler.hpp
  • Asc_CallControlHandler_hpp : CallControlHandler.hpp
  • Asc_CallDeflectionHandler_hpp : CallDeflectionHandler.hpp
  • Asc_CallForwardingHandler_hpp : CallForwardingHandler.hpp
  • Asc_CallHandler_hpp : CallHandler.hpp
  • Asc_CallHandlingData_hpp : CallHandlingData.hpp
  • Asc_CallHdl_hpp : CallHdl.hpp
  • Asc_CallHdlBase_hpp : CallHdlBase.hpp
  • Asc_CallWaitingHandler_hpp : CallWaitingHandler.hpp
  • Asc_CbsDispatcher_hpp : CbsDispatcher.hpp
  • Asc_CbsFilterList_hpp : CbsFilterList.hpp
  • Asc_CbsHandler_hpp : CbsHandler.hpp
  • Asc_CbsStartDispatcher_hpp : CbsStartDispatcher.hpp
  • Asc_CbsStopDispatcher_hpp : CbsStopDispatcher.hpp
  • Asc_ChrHandler_hpp : ChrHandler.hpp
  • Asc_ClipHandler_hpp : ClipHandler.hpp
  • Asc_ClirHandler_hpp : ClirHandler.hpp
  • Asc_CnapHandler_hpp : CnapHandler.hpp
  • Asc_ColpHandler_hpp : ColpHandler.hpp
  • Asc_ColrHandler_hpp : ColrHandler.hpp
  • Asc_CrssHandler_hpp : CrssHandler.hpp
  • Asc_DataCall_DataCallContext_hpp : DataCallContext.hpp
  • Asc_DataCall_DataCallHdl_hpp : DataCallHdl.hpp
  • Asc_DataCall_DataCallTypes_hpp : DataCallTypes.hpp
  • Asc_DataCall_hpp : DataCall.hpp
  • Asc_EmlppHandler_hpp : EmlppHandler.hpp
  • Asc_Gprs_PlmnDispatcher_gprs_hpp : PlmnDispatcher.hpp
  • Asc_Gprs_PlmnScanDispatcher_gprs_hpp : PlmnScanDispatcher.hpp
  • Asc_HandlerData_hpp : HandlerData.hpp
  • Asc_HandlerFactory_hpp : HandlerFactory.hpp
  • Asc_HandlerId_hpp : HandlerId.hpp
  • Asc_HandlerList_hpp : HandlerList.hpp
  • Asc_Host_DataCallSignalProcessor_hpp : DataCallSignalProcessor.hpp
  • Asc_Host_ValueMap_hpp : ValueMap.hpp
  • Asc_InputParserTranslator_hpp : InputParserTranslator.hpp
  • Asc_Lib_hpp : Lib.hpp
  • Asc_MainHandler_hpp : MainHandler.hpp
  • Asc_MainHandlerAccess_hpp : MainHandlerAccess.hpp
  • Asc_MobileOriginatedUssdHandler_hpp : MobileOriginatedUssdHandler.hpp
  • Asc_MocVoiceHandler_hpp : MocVoiceHandler.hpp
  • Asc_MptyCallHdl_hpp : MptyCallHdl.hpp
  • Asc_MsgArgs_hpp : MsgArgs.hpp
  • Asc_MtcVoiceHandler_hpp : MtcVoiceHandler.hpp
  • Asc_MultiSlotDispatcher_hpp : MultiSlotDispatcher.hpp
  • Asc_MultiSlotHandler_hpp : MultiSlotHandler.hpp
  • Asc_NetworkDispatcher_hpp : NetworkDispatcher.hpp
  • Asc_NetworkHandler_hpp : NetworkHandler.hpp
  • Asc_PdpContext_hpp : PdpContext.hpp
  • Asc_PdpContextControl_hpp : PdpContextControl.hpp
  • Asc_PdpContextManager_hpp : PdpContextManager.hpp
  • Asc_PdpContextManagerControl_hpp : PdpContextManagerControl.hpp
  • Asc_PlmnHandler_hpp : PlmnHandler.hpp
  • Asc_PlmnRatDispatcher_hpp : PlmnRatDispatcher.hpp
  • Asc_PortHeaderInformation_hpp : PortHeaderInformation.hpp
  • Asc_PowerDispatcher_hpp : PowerDispatcher.hpp
  • Asc_PowerDownDispatcher_hpp : PowerDownDispatcher.hpp
  • Asc_PowerHandler_hpp : PowerHandler.hpp
  • Asc_PppFrame_hpp : PppFrame.hpp
  • Asc_RtcHandler_hpp : RtcHandler.hpp
  • Asc_SigDispatcher_hpp : SigDispatcher.hpp
  • Asc_SigHandler_hpp : SigHandler.hpp
  • Asc_SimDispatcher_hpp : SimDispatcher.hpp
  • Asc_SimHandler_hpp : SimHandler.hpp
  • Asc_SimTkHandler_hpp : SimTkHandler.hpp
  • Asc_SmsContext_hpp : SmsContext.hpp
  • Asc_SmsDispatcher_hpp : SmsDispatcher.hpp
  • Asc_SmsFactory_hpp : SmsFactory.hpp
  • Asc_SmsHandler_hpp : SmsHandler.hpp
  • Asc_SmsSendDispatcher_hpp : SmsSendDispatcher.hpp
  • Asc_SmsSendProtector_hpp : SmsSendProtector.hpp
  • Asc_SmsSocket_hpp : SmsSocket.hpp
  • Asc_SmsSocketListener_hpp : SmsSocketListener.hpp
  • Asc_SmsSocketSignalMapTable_hpp : SmsSocketSignalMapTableNode.hpp
  • Asc_SsBaseHandler_hpp : SsBaseHandler.hpp
  • Asc_SsCcbsDispatcher_hpp : SsCcbsDispatcher.hpp
  • Asc_SsCcbsHandler_hpp : SsCcbsHandler.hpp
  • Asc_SsClHandler_hpp : SsClHandler.hpp
  • Asc_SsDispatcher_hpp : SsDispatcher.hpp
  • Asc_SsHandler_hpp : SsHandler.hpp
  • Asc_SsMainHandler_hpp : SsMainHandler.hpp
  • Asc_SsMessage_hpp : SsMessage.hpp
  • Asc_SsStackMsgArgument_hpp : SsStackMsgArgument.hpp
  • Asc_SsWaitDispatcher_hpp : SsWaitDispatcher.hpp
  • Asc_StackControl_hpp : StackControl.hpp
  • Asc_StackIndicationMsgTypes_hpp : StackIndicationMsgTypes.hpp
  • Asc_StackMsgActiveWaitDispatcher_hpp : StackMsgActiveWaitDispatcher.hpp
  • Asc_StackMsgDispatcher_hpp : StackMsgDispatcher.hpp
  • Asc_StatusDispatcher_hpp : StatusDispatcher.hpp
  • Asc_SupplementaryServiceAction_hpp : SupplementaryServiceAction.hpp
  • Asc_Target_DataCallSignalMapTable_hpp : DataCallSignalMapTableNode.hpp
  • Asc_Target_DataCallSignalProcessor_hpp : DataCallSignalProcessor.hpp
  • Asc_Target_Gprs_AudioSignalMapTable_hpp : AudioSignalMapTableNode.hpp
  • Asc_Target_PdpContextSignalMapTable_hpp : PdpContextSignalMapTableNode.hpp
  • Asc_Target_PdpContextSignalProcessor_hpp : PdpContextSignalProcessor.hpp
  • Asc_Target_TypeDef_hpp : ValueMap.hpp
  • Asc_TipdBasedActiveWaitDispatcher_hpp : TipdBasedActiveWaitDispatcher.hpp
  • Asc_TtyInterface_hpp : TtyInterface.hpp
  • Asc_Types_hpp : Types.hpp
  • Asc_UssdHandler_hpp : UssdHandler.hpp
  • Asc_UusHandler_hpp : UusHandler.hpp
  • Asc_ValueMap_hpp : ValueMap.hpp
  • AscDataCallControl : DataCallControl.hpp
  • ASSERT : Macros.hpp
  • ASSERT_ALWAYS : Macros.hpp
  • ASSERT_DEBUG : Macros.hpp
  • ASSERT_DEBUG_HOST : SetPixel_16Bpp.cpp, FillRect_Planes.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_Planes.cpp, BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp, Macros.hpp
  • ASSERT_DEBUG_INFO : Macros.hpp
  • ASSERT_INFO : Macros.hpp
  • ASYSTEM : FatSim.hpp
  • AT_MMI_INTERWORKING : apoxi.features
  • ATI : apoxi.features
  • AtiAudioCapturerEncoder_hpp : AtiAudioCapturerEncoder.hpp
  • AtiAudioDecoderRenderer_hpp : AtiAudioDecoderRenderer.hpp
  • AtiCodecsLib_hpp : AtiCodecsLib.hpp
  • AtiConfig_hpp : AtiConfig.hpp
  • AtiMpeg4Decoder_hpp : AtiMpeg4Decoder.hpp
  • AtiMpeg4Encoder_hpp : AtiMpeg4Encoder.hpp
  • AtiUtils_hpp : AtiUtils.hpp
  • ATL : apoxi.features
  • Atl_AtlApplication_hpp : AtlApplication.hpp
  • Atl_AtlConfig_hpp : AtlConfig.hpp
  • Atl_AtlItemGrid_hpp : AtlItemGrid.hpp
  • Atl_AtlItemMenu_hpp : AtlItemMenu.hpp
  • Atl_AtlItemRenderer_hpp : AtlItemRenderer.hpp
  • Atl_AtlMsgTypes_hpp : AtlMsgTypes.hpp
  • Atl_AtlPropertyEditor_hpp : AtlPropertyEditor.hpp
  • Atl_AtlWindow_hpp : AtlWindow.hpp
  • Atl_Context_ContextDescription_hpp : ContextDescription.hpp
  • Atl_Context_ContextFeatureHandle_hpp : ContextFeatureHandle.hpp
  • Atl_Context_ContextManager_hpp : ContextManager.hpp
  • Atl_Context_ContextTable_hpp : ContextTable.hpp
  • Atl_Context_ContextTableNode_hpp : ContextTableNode.hpp
  • Atl_Context_KeyManager_hpp : KeyManager.hpp
  • Atl_Context_KeyMapping_hpp : KeyMapping.hpp
  • Atl_Context_KeySequence_hpp : KeySequence.hpp
  • Atl_Context_MenuDesc_hpp : MenuDesc.hpp
  • Atl_Context_MenuDescObj_hpp : MenuDescObj.hpp
  • Atl_Context_MenuProperties_hpp : MenuProperties.hpp
  • Atl_Context_SoftkeyDesc_hpp : SoftkeyDesc.hpp
  • Atl_Features_AppFeatureID_hpp : AppFeatureID.hpp
  • Atl_Features_FeatureBroker_hpp : FeatureBroker.hpp
  • Atl_Features_FeatureHandle_hpp : FeatureHandle.hpp
  • Atl_Features_FeaturePool_hpp : FeaturePool.hpp
  • Atl_Features_ItemObj_hpp : ItemObj.hpp
  • Atl_Features_MenuIdObj_hpp : MenuIdObj.hpp
  • Atl_Gui_AtlItemGridWindow_hpp : AtlItemGridWindow.hpp
  • Atl_Gui_AtlItemListWindow_hpp : AtlItemListWindow.hpp
  • Atl_Gui_AtlItemMenuWindow_hpp : AtlItemMenuWindow.hpp
  • Atl_Gui_AtlLabelListWindow_hpp : AtlLabelListWindow.hpp
  • Atl_Gui_ImgObtObj_hpp : ImgObtObj.hpp
  • Atl_Gui_Indicator_Description_hpp : IndicatorDescription.hpp
  • Atl_Gui_Indicator_hpp : Indicator.hpp
  • Atl_Gui_IndicatorBarID_hpp : IndicatorBarID.hpp
  • Atl_Gui_IndicatorID_hpp : IndicatorID.hpp
  • Atl_Gui_IndicatorPaneObject_hpp : IndicatorPaneObject.hpp
  • Atl_Gui_ItemLabel_hpp : ItemLabel.hpp
  • Atl_IdentifierHandler_hpp : IdentifierHandler.hpp
  • Atl_MenuPool_hpp : MenuPool.hpp
  • Atl_MenuTable_hpp : MenuTable.hpp
  • Atl_MenuTableNode_hpp : MenuTableNode.hpp
  • Atl_PropertyEditor_hpp : PropertyEditor.hpp
  • Atl_PropertyEditorFactory_hpp : PropertyEditorFactory.hpp
  • AtlApplicationPlugin_hpp : AtlApplicationPlugin.hpp
  • AtlApplicationPluginStartup_hpp : AtlApplicationPluginStartup.hpp
  • ATOM_ALL_BITS : Ddrv.cpp
  • ATOM_LEFT_BIT : Ddrv.cpp
  • ATTENUM : parsifal.cpp
  • AUD_DBG_NR : AudioDef.hpp
  • AUD_DBG_OUT : AudioDef.hpp
  • AUD_MASTER_VOLUME_CONCEPT : apoxi.features
  • aud_rc_ram_buffer_used : StreamAudioPlayer.cpp
  • aud_rc_recording_finish : StreamAudioPlayer.cpp
  • aud_rc_user_message : AudioDeviceManager.cpp
  • AUDIO_DBG_CRIT : AudioPriorityManager.cpp
  • AUDIO_DBG_EVT : AudioPriorityManager.cpp
  • AUDIO_DBG_PM_LOGIC : AudioPriorityManager.cpp
  • AUDIO_DEVICE : BtAvrcpControllerApplicationWindows.cpp
  • AudioDef_hpp : AudioDef.hpp
  • Auxiliary_BinData_hpp : BinData.hpp
  • Auxiliary_BinDataDataSource_hpp : BinDataDataSource.hpp
  • Auxiliary_BinDataOwner_hpp : BinDataOwner.hpp
  • Auxiliary_BitField_hpp : BitField.hpp
  • Auxiliary_BufferedData_hpp : BufferedData.hpp
  • Auxiliary_ByteBuffer_hpp : ByteBuffer.hpp
  • Auxiliary_CachingSortProvider_hpp : CachingSortProvider.hpp
  • Auxiliary_ChildBinData_hpp : ChildBinData.hpp
  • Auxiliary_ChineseQuickSortProvider_hpp : ChineseQuickSortProvider.hpp
  • Auxiliary_DataSink_hpp : DataSink.hpp
  • Auxiliary_DataSource_hpp : DataSource.hpp
  • Auxiliary_DataSourceBinData_hpp : DataSourceBinData.hpp
  • Auxiliary_DbgDataDump_hpp : DbgDump.hpp
  • Auxiliary_ElementList_hpp : ElementList.hpp
  • Auxiliary_HeapDataSource_hpp : HeapDataSource.hpp
  • Auxiliary_ImageObtainerDataSource_hpp : ImageObtainerDataSource.hpp
  • Auxiliary_Lib_hpp : Lib.hpp
  • Auxiliary_MainProvider_hpp : MainProvider.hpp
  • Auxiliary_Map_hpp : Map.hpp
  • Auxiliary_MessageFactory_hpp : MessageFactory.hpp
  • Auxiliary_NonsharedBinDataDataSource_hpp : NonsharedBinDataDataSource.hpp
  • Auxiliary_RamData_hpp : RamData.hpp
  • Auxiliary_RomData_hpp : RomData.hpp
  • Auxiliary_TypeOfAddress_hpp : TypeOfAddress.hpp
  • Auxiliary_Unicode_hpp : Unicode.hpp
  • AVOLUME : FatSim.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- b -

  • B00000001 : DrawChar_16Bpp.cpp
  • B00000010 : DrawChar_16Bpp.cpp
  • B00000100 : DrawChar_16Bpp.cpp
  • B00001000 : DrawChar_16Bpp.cpp
  • B00010000 : DrawChar_16Bpp.cpp
  • B00100000 : DrawChar_16Bpp.cpp
  • B01000000 : DrawChar_16Bpp.cpp
  • B10000000 : DrawChar_16Bpp.cpp
  • BackToIdleFeature_hpp : BackToIdleFeature.hpp
  • Base : ExtndServiceThreadForNetwork.cpp
  • BEGIN_STATE_MAP : StateMachine.hpp
  • BEGIN_TRANSITION_MAP : StateMachine.hpp
  • Behavior : ScrollBehavior.hpp
  • BIP_IMG_HDL_SIZE : BtBipTypes.hpp
  • BipPutImageRsp_hpp : BtBipPutImageRsp.hpp
  • BITS_PRO_BYTE : StillCamera.cpp
  • BITS_PRO_JPEG_PIXEL : StillCamera.cpp
  • BLOCK_HEAP_CONTEXT_VECTOR : HeapVector.hpp
  • BLOCK_HEAP_PAGE : HeapVector.hpp
  • BLOCK_HEAP_SIZE_VECTOR : HeapVector.hpp
  • BLOCKS_PER_LINE_TRACE : HeapVector.cpp
  • BLUETOOTH : apoxi.features
  • Bluetooth_AVRCP_BtAvrcpNotificationMessageArgument_hpp : BtAvrcpNotificationMessageArgument.hpp
  • Bluetooth_AVRCP_BtAvrcpOperationServiceMessageArgument_hpp : BtAvrcpOperationServiceMessageArgument.hpp
  • Bluetooth_BIP_BtBipServerNotificationMsgArg_hpp : BtBipNotificationMsgArg.hpp
  • Bluetooth_BtApplicationMessage_hpp : BtApplicationMessage.hpp
  • Bluetooth_BtAvrcpMessageArguments_hpp : BtAvrcpMessageArguments.hpp
  • Bluetooth_BtAvrcpServiceMessage_hpp : BtAvrcpServiceMessage.hpp
  • Bluetooth_BtBipMsgArg_hpp : BtBipMsgArg.hpp
  • Bluetooth_BtBipServiceMsg_hpp : BtBipServiceMsg.hpp
  • Bluetooth_BtBppServiceMessage_hpp : BtBppServiceMessage.hpp
  • Bluetooth_BtDunApplicationMessage_hpp : BtDunApplicationMessage.hpp
  • Bluetooth_BtDunServiceMessage_hpp : BtDunServiceMessage.hpp
  • Bluetooth_BtFaxApplicationMessage_hpp : BtFaxApplicationMessage.hpp
  • Bluetooth_BtFaxServiceMessage_hpp : BtFaxServiceMessage.hpp
  • Bluetooth_BtGapAndSdapApplicationMessage_hpp : BtGapAndSdapApplicationMessage.hpp
  • Bluetooth_BtGapAndSdapRequestMessage_hpp : BtGapAndSdapRequestMessage.hpp
  • Bluetooth_BtHfMessageArguments_hpp : BtHfMessageArguments.hpp
  • Bluetooth_BtHfServiceMessage_hpp : BtHfServiceMessage.hpp
  • Bluetooth_BtHsMessageArguments_hpp : BtHsMessageArguments.hpp
  • Bluetooth_BtHsServiceMessage_hpp : BtHsServiceMessage.hpp
  • Bluetooth_BtObexMessageArguments_hpp : BtObexMessageArguments.hpp
  • Bluetooth_BtObexServiceMessage_hpp : BtObexServiceMessage.hpp
  • Bluetooth_BtRequestMessage_hpp : BtRequestMessage.hpp
  • Bluetooth_BtRequestOperationMessage_hpp : BtRequestOperationMessage.hpp
  • Bluetooth_BtSddbServiceMessage_hpp : BtSddbServiceMessage.hpp
  • Bluetooth_BtServiceMessage_hpp : BtServiceMessage.hpp
  • Bluetooth_Dun_Lib_hpp : Lib.hpp
  • Bluetooth_Fax_Lib_hpp : Lib.hpp
  • Bluetooth_HF_BtHfControllerMessageArgument_hpp : BtHfControllerMessageArgument.hpp
  • Bluetooth_HF_BtHfNotificationMessageArgument_hpp : BtHfNotificationMessageArgument.hpp
  • Bluetooth_Hf_Lib_hpp : Lib.hpp
  • Bluetooth_HS_BtHsControllerMessageArgument_hpp : BtHsControllerMessageArgument.hpp
  • Bluetooth_HS_BtHsNotificationMessageArgument_hpp : BtHsNotificationMessageArgument.hpp
  • Bluetooth_Hs_Lib_hpp : Lib.hpp
  • Bluetooth_Lib_hpp : Lib.hpp
  • Bluetooth_OBEX_BtObexNotificationMessageArgument_hpp : BtObexNotificationMessageArgument.hpp
  • Bluetooth_Obex_Lib_hpp : Lib.hpp
  • BMP_BITFIELD : BmpDecoder.cpp
  • BMP_FILE_HEADER_SIZE : BmpDecoder.cpp
  • BMP_INFO_HEADER_SIZE : BmpDecoder.cpp
  • BMP_RGB : BmpDecoder.cpp
  • BMP_RLE4 : BmpDecoder.cpp
  • BMP_RLE8 : BmpDecoder.cpp
  • BOOLEAN : WinInc.hpp, NucInc.hpp
  • BT_AA_INVALID_VOLUME_LEVEL : BtAudioAccessoryService.hpp
  • Bt_Application_hpp : BtApplication.hpp
  • Bt_Constants_hpp : BtConstants.hpp
  • Bt_Hf_Types_hpp : BtTypes.hpp
  • Bt_Hs_Types_hpp : BtTypes.hpp
  • BT_MDC_AUDIO_VIDEO : BtConstants.hpp
  • BT_MDC_COMPUTER : BtConstants.hpp
  • BT_MDC_IMAGING : BtConstants.hpp
  • BT_MDC_LAN : BtConstants.hpp
  • BT_MDC_MASK : BtConstants.hpp
  • BT_MDC_PERIPHERAL : BtConstants.hpp
  • BT_MDC_PHONE : BtConstants.hpp
  • BT_MDC_SHIFT : BtConstants.hpp
  • BT_MDC_UNCATEGORIZED : BtConstants.hpp
  • BT_MSC_AUDIO : BtConstants.hpp
  • BT_MSC_CAPTURING : BtConstants.hpp
  • BT_MSC_INFORMATION : BtConstants.hpp
  • BT_MSC_MASK : BtConstants.hpp
  • BT_MSC_NETWORK : BtConstants.hpp
  • BT_MSC_OBJECT_TRANSFER : BtConstants.hpp
  • BT_MSC_POSITIONING : BtConstants.hpp
  • BT_MSC_RENDERING : BtConstants.hpp
  • BT_MSC_SHIFT : BtConstants.hpp
  • BT_MSC_TELEPHONY : BtConstants.hpp
  • BT_OBEX_DEBUG_OUT : BtObexImpl.hpp
  • Bt_Obex_Types_hpp : BtTypes.hpp
  • BT_SDC_01_TO_17_UTILIZED : BtConstants.hpp
  • BT_SDC_17_TO_33_UTILIZED : BtConstants.hpp
  • BT_SDC_33_TO_50_UTILIZED : BtConstants.hpp
  • BT_SDC_50_TO_67_UTILIZED : BtConstants.hpp
  • BT_SDC_67_TO_83_UTILIZED : BtConstants.hpp
  • BT_SDC_83_TO_99_UTILIZED : BtConstants.hpp
  • BT_SDC_CAMCORDER : BtConstants.hpp
  • BT_SDC_CAMERA : BtConstants.hpp
  • BT_SDC_CAR_AUDIO : BtConstants.hpp
  • BT_SDC_CARD_READER : BtConstants.hpp
  • BT_SDC_CELLULAR : BtConstants.hpp
  • BT_SDC_COMBO_KEYBOARD_POINTING_DEVICE : BtConstants.hpp
  • BT_SDC_COMMON_ISDN_ACCESS : BtConstants.hpp
  • BT_SDC_CORDLESS : BtConstants.hpp
  • BT_SDC_DESKTOP_WORKSTATION : BtConstants.hpp
  • BT_SDC_DIGITIZER_TABLET : BtConstants.hpp
  • BT_SDC_DISPLAY : BtConstants.hpp
  • BT_SDC_GAMEPAD : BtConstants.hpp
  • BT_SDC_GAMING_TOY : BtConstants.hpp
  • BT_SDC_HAEDPHONES : BtConstants.hpp
  • BT_SDC_HANDHELD_PC_PDA : BtConstants.hpp
  • BT_SDC_HANDS_FREE : BtConstants.hpp
  • BT_SDC_HEADSET : BtConstants.hpp
  • BT_SDC_HIFI_AUDIO : BtConstants.hpp
  • BT_SDC_JOYSTICK : BtConstants.hpp
  • BT_SDC_KEYBOARD : BtConstants.hpp
  • BT_SDC_LAPTOP : BtConstants.hpp
  • BT_SDC_LOUDSPEAKER : BtConstants.hpp
  • BT_SDC_MASK : BtConstants.hpp
  • BT_SDC_MICROPHONE : BtConstants.hpp
  • BT_SDC_NO_SERVICE : BtConstants.hpp
  • BT_SDC_PALM_SIZED_PS_PDA : BtConstants.hpp
  • BT_SDC_POINTING_DEVICE : BtConstants.hpp
  • BT_SDC_PORTABLE_AUDIO : BtConstants.hpp
  • BT_SDC_PRINTER : BtConstants.hpp
  • BT_SDC_REMOTE_CONTROL : BtConstants.hpp
  • BT_SDC_SCANNER : BtConstants.hpp
  • BT_SDC_SENSING_DEVICE : BtConstants.hpp
  • BT_SDC_SERVER_CLASS_COMPUTER : BtConstants.hpp
  • BT_SDC_SET_TOP_BOX : BtConstants.hpp
  • BT_SDC_SHIFT : BtConstants.hpp
  • BT_SDC_SMART_PHONE : BtConstants.hpp
  • BT_SDC_VCR : BtConstants.hpp
  • BT_SDC_VIDEO_CAMERA : BtConstants.hpp
  • BT_SDC_VIDEO_CONFERENCING : BtConstants.hpp
  • BT_SDC_VIDEO_DISPLAY_AND_LOUDSPEAKER : BtConstants.hpp
  • BT_SDC_VIDEO_MONITOR : BtConstants.hpp
  • BT_SDC_WEARABLE_COMPUTER : BtConstants.hpp
  • BT_SDC_WIRED_MODEM_OR_VOICE_GATEWAY : BtConstants.hpp
  • BT_SDDB_BOOLEAN_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_DESCRIPTOR_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_NIL_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT128_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT16_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT32_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT64_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SINT8_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SIZE16_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SIZE32_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_SIZE8_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT128_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT16_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT32_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT64_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UINT8_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UUID128_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UUID16_SIZE : BtSddbDataElements.cpp
  • BT_SDDB_UUID32_SIZE : BtSddbDataElements.cpp
  • Bt_Types_hpp : BtTypes.hpp
  • BtActiveDeviceWindow_hpp : BtActiveDeviceWindow.hpp
  • BtApplication_BtMsgTypes_hpp : BtMsgTypes.hpp
  • BtApplicationRequests_hpp : BtApplicationRequests.hpp
  • BtApplicationWindows_hpp : BtApplicationWindows.hpp
  • BtAudioAccessoryService_hpp : BtAudioAccessoryService.hpp
  • BtAvrcpAlertMessageWindow_hpp : BtAvrcpAlertMessageWindow.hpp
  • BtAvrcpCommandInterface_hpp : BtAvrcpCommandInterface.hpp
  • BtAvrcpConnectRequest_hpp : BtAvrcpConnectRequest.hpp
  • BtAvrcpConnectResponse_hpp : BtAvrcpConnectResponse.hpp
  • BtAvrcpControllerApplicationWindow_hpp : BtAvrcpControllerApplicationWindows.hpp
  • BtAvrcpControllerDeviceListWindow_hpp : BtAvrcpControllerDeviceListWindow.hpp
  • BtAvrcpDeRegisterRequest_hpp : BtAvrcpDeRegisterRequest.hpp
  • BtAvrcpDisconnectRequest_hpp : BtAvrcpDisconnectRequest.hpp
  • BtAvrcpNotificationMessage_hpp : BtAvrcpNotificationMessage.hpp
  • BtAvrcpOperationController_hpp : BtAvrcpOperationController.hpp
  • BtAvrcpOperationRequestResponse_hpp : BtAvrcpOperationRequestResponse.hpp
  • BtAvrcpOperationService_hpp : BtAvrcpOperationService.hpp
  • BtAvrcpOperationServiceMessage_hpp : BtAvrcpOperationServiceMessage.hpp
  • BtAvrcpPanelApplication_hpp : BtAvrcpPanelApplication.hpp
  • BtAvrcpPanelApplicationWindows_hpp : BtAvrcpPanelApplicationWindows.hpp
  • BtAvrcpPanelPassThroughParams_hpp : BtAvrcpPanelPassThroughParams.hpp
  • BtAvrcpPanelPassThroughRequest_hpp : BtAvrcpPanelPassThroughRequest.hpp
  • BtAvrcpPanelProfileService_hpp : BtAvrcpProfileService.hpp
  • BtAvrcpPanelService_hpp : BtAvrcpPanelService.hpp
  • BtAvrcpPanelServiceImpl_hpp : BtAvrcpPanelServiceImpl.hpp
  • BtAvrcpRawFrameParams_hpp : BtAvrcpRawFrameParams.hpp
  • BtAvrcpRawFrameRequest_hpp : BtAvrcpRawFrameRequest.hpp
  • BtAvrcpRegisterParams_hpp : BtAvrcpRegisterParams.hpp
  • BtAvrcpRegisterRequest_hpp : BtAvrcpRegisterRequest.hpp
  • BtAvrcpRegistrationController_hpp : BtAvrcpRegistrationController.hpp
  • BtAvrcpRegistrationService_hpp : BtAvrcpRegistrationService.hpp
  • BtAvrcpRequest_hpp : BtAvrcpRequest.hpp
  • BtAvrcpService_hpp : BtAvrcpService.hpp
  • BtAvrcpSubunitInfoParams_hpp : BtAvrcpSubunitInfoParams.hpp
  • BtAvrcpSubunitInfoRequest_hpp : BtAvrcpSubunitInfoRequest.hpp
  • BtAvrcpTypes_hpp : BtTypes.hpp
  • BtAvrcpUnitInfoParams_hpp : BtAvrcpUnitInfoParams.hpp
  • BtAvrcpUnitInfoRequest_hpp : BtAvrcpUnitInfoRequest.hpp
  • BtBipAbortReq_hpp : BtBipAbortReq.hpp
  • BtBipClientService_hpp : BtBipClientService.hpp
  • BtBipConnectReq_hpp : BtBipConnectReq.hpp
  • BtBipController_hpp : BtBipController.hpp
  • BtBipDataConverter_hpp : BtBipDataConverter.hpp
  • BtBipDeleteImageReq_hpp : BtBipDeleteImageReq.hpp
  • BtBipDisconnectReq_hpp : BtBipDisconnectReq.hpp
  • BtBipGetImagePropertiesReq_hpp : BtBipGetImagePropertiesReq.hpp
  • BtBipGetImagePropertiesRsp_hpp : BtBipGetImagePropertiesRsp.hpp
  • BtBipGetImageReq_hpp : BtBipGetImageReq.hpp
  • BtBipGetImageRsp_hpp : BtBipGetImageRsp.hpp
  • BtBipGetImagesListReq_hpp : BtBipGetImagesListReq.hpp
  • BtBipGetImagesListRsp_hpp : BtBipGetImagesListRsp.hpp
  • BtBipGetImagingCapabilitiesReq_hpp : BtBipGetImagingCapabilitiesReq.hpp
  • BtBipGetImagingCapabilitiesRsp_hpp : BtBipGetImagingCapabilitiesRsp.hpp
  • BtBipGetLinkedAttachmentReq_hpp : BtBipGetLinkedAttachmentReq.hpp
  • BtBipGetLinkedAttachmentRsp_hpp : BtBipGetLinkedAttachmentRsp.hpp
  • BtBipGetLinkedThumbnailReq_hpp : BtBipGetLinkedThumbnailReq.hpp
  • BtBipGetLinkedThumbnailRsp_hpp : BtBipGetLinkedThumbnailRsp.hpp
  • BtBipGetReq_hpp : BtBipGetReq.hpp
  • BtBipGetRsp_hpp : BtBipGetRsp.hpp
  • BtBipMecelXMLConverter_hpp : BtBipMecelXmlConverter.hpp
  • BtBipPutAttachReq_hpp : BtBipPutAttachReq.hpp
  • BtBipPutAttachRsp_hpp : BtBipPutAttachRsp.hpp
  • BtBipPutImageReq_hpp : BtBipPutImageReq.hpp
  • BtBipPutReq_hpp : BtBipPutReq.hpp
  • BtBipPutRsp_hpp : BtBipPutRsp.hpp
  • BtBipPutThumbReq_hpp : BtBipPutThumbReq.hpp
  • BtBipPutThumbRsp_hpp : BtBipPutThumbRsp.hpp
  • BtBipRequest_hpp : BtBipReq.hpp
  • BtBipServerNotificationMsg_hpp : BtBipNotificationMsg.hpp
  • BtBipServerService_hpp : BtBipServerService.hpp
  • BtBipService_hpp : BtBipService.hpp
  • BtBipTypes_hpp : BtBipTypes.hpp
  • BtBppClientService_hpp : BtBppClientService.hpp
  • BtBppController_hpp : BtBppController.hpp
  • BtBppRequest_hpp : BtBppReq.hpp
  • BtBppServerService_hpp : BtBppServerService.hpp
  • BtBppService_hpp : BtBppService.hpp
  • BtBppSndAbortReqRequest_hpp : BtBppSndAbortReqRequest.hpp
  • BtBppSndFilePushReqRequest_hpp : BtBppSndFilePushReqRequest.hpp
  • BtBppSndGetRefObjRspRequest_hpp : BtBppSndGetRefObjRspRequest.hpp
  • BtBppTestData_hpp : BtBppTestData.hpp
  • BtBppTypes_hpp : BtBppTypes.hpp
  • BtCancelableBroadcastRequest_hpp : BtCancelableBroadcastRequest.hpp
  • BtCancelableMulticastRequest_hpp : BtCancelableMulticastRequest.hpp
  • BtCancelableRequest_hpp : BtCancelableRequest.hpp
  • BtConnectionBasedController_hpp : BtConnectionBasedController.hpp
  • BtConnectionlessController_hpp : BtConnectionlessController.hpp
  • BtConnectRequest_hpp : BtConnectRequest.hpp
  • BtController_hpp : BtController.hpp
  • BtDatatElements_hpp : BtSvrDataElement.hpp
  • BtDevice_hpp : BtDevice.hpp
  • BtDeviceAddress_hpp : BtDeviceAddress.hpp
  • BtDeviceAndServiceClass_hpp : BtDeviceAndServiceClass.hpp
  • BtDeviceDetailWindow_hpp : BtDeviceDetailWindow.hpp
  • BtDeviceFilter_hpp : BtDeviceFilter.hpp
  • BtDeviceList_hpp : BtDeviceList.hpp
  • BtDeviceListIterator_hpp : BtDeviceListIterator.hpp
  • BtDeviceListReverseIterator_hpp : BtDeviceListReverseIterator.hpp
  • BtDeviceListsWindows_hpp : BtDeviceListsWindows.hpp
  • BtDevicePairRequest_hpp : BtDevicePairRequest.hpp
  • BtDeviceSearchRequest_hpp : BtDeviceSearchRequest.hpp
  • BtDeviceTrustRequest_hpp : BtDeviceTrustRequest.hpp
  • BtDeviceUnpairRequest_hpp : BtDeviceUnpairRequest.hpp
  • BtDeviceUntrustRequest_hpp : BtDeviceUntrustRequest.hpp
  • BtDisconnectRequest_hpp : BtDisconnectRequest.hpp
  • BtDunController_hpp : BtDunController.hpp
  • BtDunDisconnectRequest_hpp : BtDunDisconnectRequest.hpp
  • BtDunProfileService_hpp : BtDunProfileService.hpp
  • BtDunService_hpp : BtDunService.hpp
  • BtEvent_hpp : BtEvent.hpp
  • BtFaxController_hpp : BtFaxController.hpp
  • BtFaxDisconnectRequest_hpp : BtFaxDisconnectRequest.hpp
  • BtFaxProfileService_hpp : BtFaxProfileService.hpp
  • BtFaxService_hpp : BtFaxService.hpp
  • BtGapAndSdapController_hpp : BtGapAndSdapController.hpp
  • BTHF_AUDIO_2_HF : BtHfAppPlugin.hpp
  • BTHF_AUDIO_2_PHONE : BtHfAppPlugin.hpp
  • BtHfAppPlugin_hpp : BtHfAppPlugin.hpp
  • BtHfConnectRequest_hpp : BtHfConnectRequest.hpp
  • BtHfController_hpp : BtHfController.hpp
  • BtHfControllerMessage_hpp : BtHfControllerMessage.hpp
  • BtHfDisonnectRequest_hpp : BtHfDisconnectRequest.hpp
  • BtHfInbandSettingWin_hpp : BtHfInbandSettingWin.hpp
  • BtHfNotificationMessage_hpp : BtHfNotificationMessage.hpp
  • BtHfProfileService_hpp : BtHfProfileService.hpp
  • BtHfProfileWindows_hpp : BtHfProfileWindows.hpp
  • BtHfRequest_hpp : BtHfRequest.hpp
  • BtHfService_hpp : BtHfService.hpp
  • BtHfSetMicrophoneGainRequest_hpp : BtHfSetMicrophoneGainRequest.hpp
  • BtHfSetSpeakerGainRequest_hpp : BtHfSetSpeakerGainRequest.hpp
  • BtHfTransferAudioToAccessoryRequest_hpp : BtHfTransferAudioToAccessoryRequest.hpp
  • BtHfTransferAudioToPhoneRequest_hpp : BtHfTransferAudioToPhoneRequest.hpp
  • BtHsConnectionSettingWin_hpp : BtHsConnectionSettingWin.hpp
  • BtHsConnectRequest_hpp : BtHsConnectRequest.hpp
  • BtHsController_hpp : BtHsController.hpp
  • BtHsControllerMessage_hpp : BtHsControllerMessage.hpp
  • BtHsDisconnectRequest_hpp : BtHsDisconnectRequest.hpp
  • BtHsInbandSettingWin_hpp : BtHsInbandSettingWin.hpp
  • BtHsNotificationMessage_hpp : BtHsNotificationMessage.hpp
  • BtHsProfileService_hpp : BtHsProfileService.hpp
  • BtHsRequest_hpp : BtHsRequest.hpp
  • BtHsRingRequest_hpp : BtHsRingRequest.hpp
  • BtHsService_hpp : BtHsService.hpp
  • BtHsSetMicrophoneGainRequest_hpp : BtHsSetMicrophoneGainRequest.hpp
  • BtHsSetSpeakerGainRequest_hpp : BtHsSetSpeakerGainRequest.hpp
  • BtHsStopRingRequest_hpp : BtHsStopRingRequest.hpp
  • BtHsTransferAudioToAccessoryRequest_hpp : BtHsTransferAudioToAccessoryRequest.hpp
  • BtHsTransferAudioToPhoneRequest_hpp : BtHsTransferAudioToPhoneRequest.hpp
  • BtJsr82Url_hpp : BtJsr82Url.hpp
  • BtLocalRequest_hpp : BtLocalRequest.hpp
  • BtLocalSettings_hpp : BtLocalSettings.hpp
  • BtMultiConnectionController_hpp : BtMultiConnectionController.hpp
  • BtObexAbortRequest_hpp : BtObexAbortRequest.hpp
  • BtObexClientOperationRequest_hpp : BtObexClientOperationRequest.hpp
  • BtObexClientService_hpp : BtObexClientService.hpp
  • BtObexClientServiceObserver_hpp : BtObexClientServiceObserver.hpp
  • BtObexConnectRequest_hpp : BtObexConnectRequest.hpp
  • BtObexController_hpp : BtObexController.hpp
  • BtObexDisconnectRequest_hpp : BtObexDisconnectRequest.hpp
  • BtObexEvent_hpp : BtObexEvent.hpp
  • BtObexGetRequest_hpp : BtObexGetRequest.hpp
  • BtObexPutRequest_hpp : BtObexPutRequest.hpp
  • BtObexRegisterClientRequest_hpp : BtObexRegisterClientRequest.hpp
  • BtObexRegisterServerRequest_hpp : BtObexRegisterServerRequest.hpp
  • BtObexRequest_hpp : BtObexRequest.hpp
  • BtObexServerNotificationMessage_hpp : BtObexNotificationMessage.hpp
  • BtObexServerService_hpp : BtObexServerService.hpp
  • BtObexServerServiceObserver_hpp : BtObexServerServiceObserver.hpp
  • BtObexService_hpp : BtObexService.hpp
  • BtObexServiceObserver_hpp : BtObexServiceObserver.hpp
  • BtObexSetPathRequest_hpp : BtObexSetPathRequest.hpp
  • BtObexTransport_hpp : BtObexTransport.hpp
  • BtObexUnregisterClientRequest_hpp : BtObexUnregisterClientRequest.hpp
  • BtObexUnregisterServerRequest_hpp : BtObexUnregisterServerRequest.hpp
  • BtObservableService_hpp : BtObservableService.hpp
  • BtOperationBase_hpp : BtOperationBase.hpp
  • BtOperationSelectDevice_hpp : BtOperationSelectDevice.hpp
  • BtOperationSelectDeviceAndPerformServiceVerify_hpp : BtOperationSelectDeviceAndPerformServiceVerify.hpp
  • BtQuerySupportedProfilesRequest_hpp : BtQuerySupportedProfilesRequest.hpp
  • BtRequest_hpp : BtRequest.hpp
  • BtRequestRespondRequest_hpp : BtRequestRespondRequest.hpp
  • BtRespondAuthorizationRequest_hpp : BtRespondAuthorizationRequest.hpp
  • BtSddbDataElements_hpp : BtSddbDataElements.hpp
  • BtSddbEvent_hpp : BtSddbEvent.hpp
  • BtSddbRegisterServiceRecordRequest_hpp : BtSddbRegisterServiceRecordRequest.hpp
  • BtSddbRequest_hpp : BtSddbRequest.hpp
  • BtSddbService_hpp : BtSddbService.hpp
  • BtSddbServiceAttribute_hpp : BtSddbServiceAttribute.hpp
  • BtSddbServiceObserver_hpp : BtSddbServiceObserver.hpp
  • BtSddbServiceRecord_hpp : BtSddbServiceRecord.hpp
  • BtSddbUnregisterServiceRecordRequest_hpp : BtSddbUnregisterServiceRecordRequest.hpp
  • BtSendPasskeyRequest_hpp : BtSendPasskeyRequest.hpp
  • BtService_hpp : BtService.hpp
  • BtServiceDiscoveryDatabase_hpp : BtServiceDiscoveryDatabase.hpp
  • BtServiceObserver_hpp : BtServiceObserver.hpp
  • BtServiceRequest_hpp : BtServiceRequest.hpp
  • BtServiceVerifyRequest_hpp : BtServiceVerifyRequest.hpp
  • BtServiceVerifyResult_hpp : BtServiceVerifyResult.hpp
  • BtSetRemoteDeviceNameRequest_hpp : BtSetRemoteDeviceNameRequest.hpp
  • BtSettingsDisplayInfoWindow_hpp : BtLocalSettingsWindows.hpp
  • BtSingleConnectionController_hpp : BtSingleConnectionController.hpp
  • BtSvrServiceAttribute_hpp : BtSvrServiceAttribute.hpp
  • BtSvrServiceRecord_hpp : BtSvrServiceRecord.hpp
  • BtTransport_hpp : BtTransport.hpp
  • BtUncancelablePointToPointRequest_hpp : BtUncancelablePointToPointRequest.hpp
  • BtUncancelableRequest_hpp : BtUncancelableRequest.hpp
  • BtUtil_hpp : BtUtility.hpp
  • BUF_MAX : TestWriter.cpp
  • BUFFERPOOLMANAGER_BUFFER_ADMIN_SIZE : BufferPoolManager.cpp
  • BUFREADCOMMENT : Unzip.hpp
  • BYTE : NucInc.hpp
  • BYTEST_PRO_JPEG_PIXEL : StillCamera.cpp
  • BYTEST_PRO_PIXEL : StillCamera.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- c -

  • C_IR_CONNECTIONS_MAX_NUM : IrdaObexTransport.hpp
  • c_max_level_count : MultiMediaEditorDocument.hpp
  • c_max_thread_name_length : Thread.hpp
  • CalendarAddRecordWin_hpp : CalendarAddRecordWin.hpp
  • CalendarApp_hpp : CalendarApp.hpp
  • CalendarDialogWin_hpp : CalendarDialogWin.hpp
  • CalendarGotoDateWin_hpp : CalendarGotoDateWin.hpp
  • CalendarMonthSelector_hpp : CalendarMonthSelector.hpp
  • CalendarMonthWin_hpp : CalendarMonthWin.hpp
  • CalendarProvider_hpp : CalendarProvider.hpp
  • CalendarRecord_hpp : CalendarRecord.hpp
  • CAMERA : apoxi.features
  • CAMERA_VIEW_FINDER_TITLE : CameraViewFinderWin.cpp
  • CameraOptionSettingsWin_hpp : CameraOptionSettingsWin.hpp
  • CameraSettingsWin_hpp : CameraSettingsWin.hpp
  • CamWin32_hpp : CamWin32.hpp
  • CAND_PAGE_INCR : Zi8Wrapper.hpp
  • CHANGE_CURRENT_AUDIO_PATH : BtHfAppPlugin.hpp
  • CHAR : WinInc.hpp, NucInc.hpp
  • CHICAGO_EXT : FatSim.hpp
  • CHINESE_CAND_PAGE_INCR : Zi8Wrapper.hpp
  • CifSize_INDEX : Camera.cpp
  • CLEANUP_ATTS : parsifal.cpp
  • CLOSE_TEXT_SOFTKEY : CameraCaptureWin.cpp
  • CMAX : RingBuffer.cpp
  • CODEC_MAN : apoxi.features
  • COLOR_COUNT : EmsResourceMaps.hpp
  • Common_ImageBrowserMsgTypes_hpp : ImageBrowserMsgTypes.hpp
  • Common_MsgTypes_hpp : MsgTypes.hpp
  • Common_NetworkServiceThreadMsgTypes_hpp : NetworkServiceThreadMsgTypes.hpp
  • Common_SoundBrowserMsgTypes_hpp : SoundBrowserMsgTypes.hpp
  • COMPANY_ID_IFIN_AP : BtAvrcpPanelApplication.cpp
  • Compat_Lib_hpp : Lib.hpp
  • CONNECT_DEVICE : BtHfAppPlugin.hpp
  • CONTENT_DESCRIPTION_STR : DrmDcfParser.hpp
  • CONTENT_NAME_STR : DrmDcfParser.hpp
  • CONTENT_VENDOR_STR : DrmDcfParser.hpp
  • ContextDescriptionTypes_hpp : ContextDescriptionTypes.hpp
  • ContextFeature_hpp : ContextFeature.hpp
  • ContextFeatureItem_hpp : ContextFeatureItem.hpp
  • ContextID_hpp : ContextID.hpp
  • CRERR_BAD_FORMAT : FatSim.hpp
  • CRERR_BAD_MEDIA : FatSim.hpp
  • CRERR_ECC_ERROR : FatSim.hpp
  • CRERR_ID_ERROR : FatSim.hpp
  • CRERR_MEDIA_CHANGED : FatSim.hpp
  • CRERR_MEDIA_FAILURE : FatSim.hpp
  • CRERR_NO_MEDIA : FatSim.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- d -

  • DATACONNVERSION : DataConnVersion.hpp
  • DataConnVersion_hpp : DataConnVersion.hpp
  • DBG_DUMP : DbgDump.hpp
  • DBG_OUT : Macros.hpp
  • DBG_OUT_CONFIGURATOR_IS_IN_RANGE : Win32.cpp, Nuc32.cpp
  • DBG_OUT_RANGE_AFSRAM_ALWAYS : RamTypes.hpp
  • DBG_OUT_RANGE_AFSRAM_ERROR : RamTypes.hpp
  • DBG_OUT_RANGE_AFSRAM_SUCCESS : RamTypes.hpp
  • DBG_OUT_RANGE_AFSRAM_UNITTEST : RamTypes.hpp
  • DBG_OUT_STACK_USAGE : Macros.hpp
  • DBG_STATE : BtObexService.cpp, BtObexServerService.cpp, BtObexController.cpp, BtObexClientService.cpp, BtHsService.cpp, BtHsController.cpp, BtHfService.cpp, BtHfController.cpp, BtAvrcpRegistrationController.cpp, BtAvrcpOperationController.cpp
  • DBG_STATE_STATIC : BtHsController.cpp, BtHfController.cpp, BtAvrcpRegistrationController.cpp, BtAvrcpOperationController.cpp
  • DCF_SKIP_SPACE : DrmDcfParser.hpp
  • DCF_VALIDATE_DATA_SIZE : DrmDcfParser.hpp
  • DDRV_ATOM_BIT_COUNT : Ddrv.cpp
  • DDrvColorBits16Ptr : Ddrv.cpp
  • DDrvColorBits32Ptr : Ddrv.cpp
  • DDrvColorBits8Ptr : Ddrv.cpp
  • DDrvDimToAtomIdx : Ddrv.cpp
  • DEACTIVATE_SET_CAPTURE_IMAGE_FORMAT : VideoCamera.cpp
  • DEBUG : SerialSocket.hpp
  • DEBUG_CAMERA_CAPTURE_WIN_CPP : CameraCaptureWin.cpp
  • DEBUG_CAMERA_CAPTURE_WIN_CPP_FILE : CameraCaptureWin.cpp
  • DEBUG_CAMERA_CPP : Camera.cpp
  • DEBUG_CAMERA_SETTINGS_WIN_CPP : CameraSettingsWin.cpp
  • DEBUG_CAMERA_SETTINGS_WIN_CPP_FILE : CameraSettingsWin.cpp
  • DEBUG_DEVICE_CAMERA_CPP_FILE : Camera.cpp
  • DEBUG_DEVICE_STILL_CAMERA : StillCamera.cpp
  • DEBUG_DEVICE_STILL_CAMERA_CPP_FILE : StillCamera.cpp
  • DEBUG_DEVICE_VIDEOCAMERA_CPP_FILE : VideoCamera.cpp
  • DEBUG_INFO : apoxi.features
  • DEBUG_STILL_CAMERA_CPP : StillCamera.cpp
  • DEBUG_STILL_CAMERA_CPP_CB : StillCamera.cpp
  • DEBUG_VIDEOCAMERA_CPP : VideoCamera.cpp
  • DECLARE_CLASS : InternalTracer.hpp
  • DEFAULT_AUDIO_PATH : BtHfAppPlugin.hpp
  • DEFAULT_STEP_SIZE : Camera.cpp
  • DefaultZoomLevelCifSize_INDEX : Camera.cpp
  • DefaultZoomLevelQcifSize_INDEX : Camera.cpp
  • DefaultZoomLevelQqcifSize_INDEX : Camera.cpp
  • DefaultZoomLevelQqvgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelQsifSize_INDEX : Camera.cpp
  • DefaultZoomLevelQvgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelSize1_3Mp_INDEX : Camera.cpp
  • DefaultZoomLevelSize1Mp_INDEX : Camera.cpp
  • DefaultZoomLevelSize2Mp_INDEX : Camera.cpp
  • DefaultZoomLevelSize3Mp_INDEX : Camera.cpp
  • DefaultZoomLevelSqcifSize_INDEX : Camera.cpp
  • DefaultZoomLevelSvgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelUxgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelVgaSize_INDEX : Camera.cpp
  • DefaultZoomLevelXgaSize_INDEX : Camera.cpp
  • DefGuid_NoGuid : Service.hpp
  • DefObjectReferrer : ObjectReferrer.hpp
  • DefThreadSafeReferableObject : ObjectReferrer.hpp
  • DerivedApoxiThread_hpp : DerivedApoxiThread.hpp
  • DerivedApoxiTimer_hpp : DerivedApoxiTimer.hpp
  • DEVICE_ADDRESS_CAPTION : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_CONECTED_CAPTION : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_NAME_CAPTION : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_PLAYING_CAPTION : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_SUPPORTED_FEATURES : BtHfProfileWindows.cpp
  • DEVICE_TEXT_NO : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_TEXT_NO_ACTIVE_DEVICE : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_TEXT_NO_PAIRED_DEVICE : BtAvrcpControllerApplicationWindows.cpp
  • DEVICE_TEXT_YES : BtAvrcpControllerApplicationWindows.cpp
  • Devices_ChargerMsgTypes_hpp : ChargerMsgTypes.hpp
  • Devices_DisplayMsgTypes_hpp : DisplayMsgTypes.hpp
  • Devices_LedMsgTypes_hpp : LedMsgTypes.hpp
  • Devices_RtcMsgTypes_hpp : RtcMsgTypes.hpp
  • DISCONNECT_DEVICE : BtHfAppPlugin.hpp
  • DISPLAY_DEFAULT_HEIGHT : MediaBox.cpp
  • DISPLAY_DEFAULT_WIDTH : MediaBox.cpp
  • DISPLAY_XOFFSET : MediaBox.cpp
  • DISPLAY_YOFFSET : MediaBox.cpp
  • DIVISOR : StillCamera.cpp
  • DNS_WAIT_TIME_100MS : Win32SysDnsClient.cpp, LwipSysDnsClient.cpp
  • DP_C_LDOUBLE : Wsprintf.cpp, StrPrintf.cpp
  • DP_C_LONG : Wsprintf.cpp, StrPrintf.cpp
  • DP_C_SHORT : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_MINUS : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_NUM : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_PLUS : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_SPACE : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_UNSIGNED : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_UP : Wsprintf.cpp, StrPrintf.cpp
  • DP_F_ZERO : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_BCK : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_CONV : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_DEFAULT : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_DONE : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_DOT : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_FLAGS : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_HEX : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_MAX : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_MIN : Wsprintf.cpp, StrPrintf.cpp
  • DP_S_MOD : Wsprintf.cpp, StrPrintf.cpp
  • dprintf : MultipartParser.hpp
  • DRM : apoxi.features
  • DRM_DAY_SECONDS : DrmRelXml.cpp
  • DRM_DCF_ERROR : DrmDcfParser.hpp
  • DRM_DCF_INVALID_BLOCK : DrmDcfParser.hpp
  • DRM_FL_LOCAL_ID : DrmRightsStore.hpp
  • DRM_HOURS_SECONDS : DrmRelXml.cpp
  • DRM_KEY_SIZE : DrmCore.hpp
  • DRM_MINUTES_SECONDS : DrmRelXml.cpp
  • DRM_MONTH_SECONDS : DrmRelXml.cpp
  • DRM_RIGHTS_OP_NOT_FOUND : DrmRights.hpp
  • DRM_RIGHTS_UPDATE_REQUIRED : DrmRights.hpp
  • DRM_RO_DEBUG : DrmCore.hpp
  • DRM_RO_FILE_PREFIX : DrmRightsStore.hpp
  • DRM_SECURITY_KEY_LEN : DrmSecurity.hpp
  • DRM_SECURITY_MAGIC_NUMBER : DrmSecurity.hpp
  • DRM_YEAR_SECONDS : DrmRelXml.cpp
  • DrmCore_hpp : DrmCore.hpp
  • DrmWapPushMsg_hpp__ST_1101449473226 : DrmWapPushMsg.hpp
  • DUAL_DISPLAY : apoxi.features
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- e -

  • EDNSC_ERR : DnsClientTypes.hpp
  • EDNSC_OK : DnsClientTypes.hpp
  • EFOApoxiLayer_hpp : EFOApoxiLayer.hpp
  • EFOBinData_hpp : EFOBinData.hpp
  • EFODataSink_hpp : EFODataSink.hpp
  • EMAPOXI_DBG_ALLOC_LOG : EmApoxiAllocLogs.hpp
  • EMAPOXI_DBG_FREE_LOG : EmApoxiAllocLogs.hpp
  • EmApoxiAudioDecoderhpp : EmApoxiAudioDecoder.hpp
  • EmApoxiAudioDefines_hpp : EmApoxiAudioDefines.hpp
  • EmApoxiAudioDeviceImpl_hpp : EmApoxiAudioDeviceImpl.hpp
  • EmApoxiAudioUtils_hpp : EmApoxiAudioUtils.hpp
  • EmApoxiBinData_hpp : EmApoxiBinData.hpp
  • EmApoxiCodecManagerhpp : EmApoxiCodecManager.hpp
  • EmApoxiCodecUtilshpp : EmApoxiCodecUtils.hpp
  • EmApoxiDataConnManager_hpp : EmApoxiDataConnManager.hpp
  • EmApoxiDataConnProfileManager_hpp : EmApoxiDataConnProfileManager.hpp
  • EmApoxiDataSink_hpp : EmApoxiDataSink.hpp
  • EmApoxiDataTypes_hpp : EmApoxiDataTypes.hpp
  • EmApoxiDELETE_ARRAY : MediaInfo.cpp, EmApoxiMediaInfo.cpp
  • EmApoxiDisplaySettings_hpp : EmApoxiDisplaySettings.hpp
  • EmApoxiDnsClient_hpp : EmApoxiDnsClient.hpp
  • EmApoxiFile_hpp : EmApoxiFile.hpp
  • EmApoxiInetSocketAddr_hpp : EmApoxiInetSocketAddr.hpp
  • EmApoxiInterface_hpp : EmApoxiInterface.hpp
  • EmApoxiIpAddr_hpp : EmApoxiIpAddr.hpp
  • EmApoxiIpPortNo_hpp : EmApoxiIpPortNo.hpp
  • EmApoxiMediaInfo_hpp : EmApoxiMediaInfo.hpp
  • EmApoxiMimeTypeTable_hpp : EmApoxiMimeTypeTable.hpp
  • EmApoxiMsgDispatcher_hpp : EmApoxiMsgDispatcher.hpp
  • EmApoxiMutex_hpp : EmApoxiMutex.hpp
  • EmApoxiMutexObtainer_hpp : EmApoxiMutexObtainer.hpp
  • EmApoxiOs_hpp : EmApoxiOs.hpp
  • EmApoxiPlayerEnum_hpp : EmApoxiPlayerEnum.hpp
  • EmApoxiRecorderEnum_hpp : EmApoxiRecorderEnum.hpp
  • EmApoxiRecordSettings_hpp : EmApoxiRecordSettings.hpp
  • EmApoxiSemaphore_hpp : EmApoxiSemaphore.hpp
  • EmApoxiServiceThread_hpp : EmApoxiServiceThread.hpp
  • EmApoxiSocketHandler_hpp : EmApoxiSocketHandler.hpp
  • EmApoxiTcpSocket_hpp : EmApoxiTcpSocket.hpp
  • EmApoxiThread_hpp : EmApoxiThread.hpp
  • EmApoxiTicks_hpp : EmApoxiTicks.hpp
  • EmApoxiTimer_hpp : EmApoxiTimer.hpp
  • EmApoxiUdpSocket_hpp : EmApoxiUdpSocket.hpp
  • EmApoxiUtilities_hpp : EmApoxiUtilities.hpp
  • EmApoxiVideoCaptureExp_hpp : EmApoxiVideoCaptureExp.hpp
  • EmApoxiVideoDecoderhpp : EmApoxiVideoDecoder.hpp
  • EmApoxiVideoDefines_hpp : EmApoxiVideoDefines.hpp
  • EmApoxiVideoEncoderhpp : EmApoxiVideoEncoder.hpp
  • EmApoxiVideoRendererExp_hpp : EmApoxiVideoRendererExp.hpp
  • EmApoxiVideoUtils_hpp : EmApoxiVideoUtils.hpp
  • EMAXPATH : FfsSim.cpp
  • EMCPP_OBEX_CLIENT : apoxi_emcpp_OBEXAdapter.hpp
  • EMCPP_OBEX_SERVER : apoxi_emcpp_OBEXAdapter.hpp
  • Ems_EmsCreator_hpp : EmsCreator.hpp
  • Ems_EmsEditor_hpp : EmsEditor.hpp
  • Ems_EmsEditorListener_hpp : EmsEditorListener.hpp
  • Ems_EmsIeParser_hpp : EmsIeParser.hpp
  • Ems_EmsImage_hpp : EmsImage.hpp
  • Ems_EmsInsertPrompt_hpp : EmsInsertPrompt.hpp
  • Ems_EmsResourceMaps_hpp : EmsResourceMaps.hpp
  • Ems_PredefinedEmsImage_hpp : PredefinedEmsImage.hpp
  • Ems_PredefinedEmsSound_hpp : PredefinedEmsSound.hpp
  • EmServThreadMsg_hpp__ST_1128926169290 : EmServThreadMsg.hpp
  • EMSVERSION : EmsVersion.hpp
  • EmsVersion_hpp : EmsVersion.hpp
  • EMZ_CODECS : apoxi.features
  • EmzAacDecoderThread_hpp : EmzAacDecoderThread.hpp
  • EmzCodecsLib_hpp : EmzCodecsLib.hpp
  • EmzH264Decoder_hpp : EmzH264Decoder.hpp
  • EmzH264DecoderThread_hpp : EmzH264DecoderThread.hpp
  • EmzMp3DecoderThread_hpp : EmzMp3DecoderThread.hpp
  • EmzMpeg4Decoder_hpp : EmzMpeg4Decoder.hpp
  • EmzMpeg4DecoderThread_hpp : EmzMpeg4DecoderThread.hpp
  • EmzMpeg4Encoder_hpp : EmzMpeg4Encoder.hpp
  • EmzMpeg4EncoderThread_hpp : EmzMpeg4EncoderThread.hpp
  • EmzSbcEncoderThread_hpp : EmzSbcEncoderThread.hpp
  • EmzUtils_hpp : EmzUtils.hpp
  • ENABLE_ONLY_THE_TEST_APPLICATION : CameraSettingsWin.cpp
  • ENCRYPTION_METHOD_STR : DrmDcfParser.hpp
  • END_STATE_MAP : StateMachine.hpp
  • END_TRANSITION_MAP : StateMachine.hpp
  • EnumTr : EnumTranslationTable.hpp
  • EOS : Wsscanf.cpp
  • ErrMapEntry : Win32SysSocket.cpp, UsnetSysSocket.cpp, LwipSysSocket.cpp, BsdSysSocket.cpp
  • ExtendedDbgCode : WString.cpp, String.cpp
  • EXTERNAL_RINGER : apoxi.features
  • ExtFfsFileType : FfsTypes.hpp
  • ExtFfsPit : FfsTypes.hpp
  • ExtFfsUserType : FfsTypes.hpp
  • ExtndDnsClient_hpp : ExtndDnsClient.hpp
  • ExtndTcpSocket_hpp : ExtndTcpSocket.hpp
  • EZD_DEFAULT_AUDIO_CODEC : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_AUDIO_QUALITY : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_BRIGHTNESS : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CAMERA_DEV_ID : RecordSettings.cpp
  • EZD_DEFAULT_CAMERA_DEVICE_ID : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CAMERA_HEIGHT : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CAMERA_NIGHT_MODE : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CAMERA_WIDTH : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_CONTRAST : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_DURATION : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_FILE_SIZE : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_FRAMERATE : RecordSettings.cpp, EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_SINK_TYPE : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_VIDEO_CODEC : EmApoxiRecordSettings.cpp
  • EZD_DEFAULT_VIDEO_QUALITY : EmApoxiRecordSettings.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- f -

  • F_HAS_LOWER_AND_UPPER_CASE : WCattr.cpp
  • F_HAS_LOWER_CASE : WCattr.cpp
  • F_HAS_UPPER_CASE : WCattr.cpp
  • F_IS_COMPOSED : WCattr.cpp
  • F_LONG : Wsscanf.cpp
  • F_SIGNALLOW : Wsscanf.cpp
  • F_SUPPRESS : Wsscanf.cpp
  • FAT_FS : apoxi.features
  • FatAccessFlagAppend : FatTypes.hpp
  • FatAccessFlagBinary : FatTypes.hpp
  • FatAccessFlagCreate : FatTypes.hpp
  • FatAccessFlagExcl : FatTypes.hpp
  • FatAccessFlagNoShareAny : FatTypes.hpp
  • FatAccessFlagNoShareWrite : FatTypes.hpp
  • FatAccessFlagRdOnly : FatTypes.hpp
  • FatAccessFlagRdWr : FatTypes.hpp
  • FatAccessFlagText : FatTypes.hpp
  • FatAccessFlagTrunc : FatTypes.hpp
  • FatAccessFlagWrOnly : FatTypes.hpp
  • FatFsMsgTypes_hpp__ST_1128347975150 : FatFsMsgTypes.hpp
  • FatSeekBegin : FatTypes.hpp
  • FatSeekCurrent : FatTypes.hpp
  • FatSeekEnd : FatTypes.hpp
  • FEAT_BT_A2DP : apoxi.features
  • FEAT_BT_AVRCP : apoxi.features
  • FEAT_BT_BIP : apoxi.features
  • FEAT_BT_BPP : apoxi.features, apoxi.defines
  • FEAT_BTSOCKET : apoxi.features
  • FEAT_EXTERNAL_PCH_CONTROL : apoxi.features
  • FEAT_FOTA : apoxi.features
  • FEAT_MMCALL : apoxi.features
  • FEAT_SECURECLOCK : apoxi.features
  • FEAT_SERIALSOCKET : apoxi.features
  • FEAT_SIOSOCKETADAPTER : apoxi.features, apoxi.defines
  • FEATURE_AVAILABLE_NO : BtHfProfileWindows.cpp
  • FEATURE_AVAILABLE_YES : BtHfProfileWindows.cpp
  • FEATURE_CLI_PRESENTATION : BtHfProfileWindows.cpp
  • FEATURE_EC_NR : BtHfProfileWindows.cpp
  • FEATURE_HF_INBAND_RINGING : BtHfService.cpp
  • FEATURE_HF_VOICE_TAG : BtHfController.cpp
  • Feature_hpp : Feature.hpp
  • FEATURE_REMOTE_VOLUME_CTRL : BtHfProfileWindows.cpp
  • FEATURE_THREE_WAY_CALL : BtHfProfileWindows.cpp
  • FEATURE_VOICE_REC : BtHfProfileWindows.cpp
  • FeatureID_hpp : FeatureID.hpp
  • FeatureItem_hpp : FeatureItem.hpp
  • FeatureItemContainer_hpp : FeatureItemContainer.hpp
  • FeatureItemContainerID_hpp : FeatureItemContainerID.hpp
  • FFS : apoxi.features
  • FFS_BLOCK_SIZE : FfsSim.hpp
  • ffs_callback_type : FfsSim.hpp
  • FFS_FILE_ALREADY_CREATED : FfsSim.hpp
  • FFS_FILETYPE_SMS_POOL_SIZE_PHYSICAL : FfsSim.hpp
  • FFS_INVALID_FILENAME : FfsSim.hpp
  • FFS_MAX_FILESIZE : FfsSim.hpp
  • FFS_MAX_SOF_DIR_NAME : FfsSim.hpp
  • FFS_MAX_SOF_FILENAME : FfsSim.hpp
  • FFS_NOF_DYNAMIC_BLOCKS : FfsSim.hpp
  • FFS_SECTOR_SIZE : FfsSim.hpp
  • FFS_SIM_hpp : FfsSim.hpp
  • FFS_STREAMING : FfsSim.hpp
  • FfsMimeTypeMap_hpp : FfsMimeTypeMap.hpp
  • FILEPACK_ID : AcacTypes.hpp
  • FIRST_CODE : GifDecoder.cpp
  • FlagsIsSet : Wsscanf.cpp
  • FlagsSet : Wsscanf.cpp
  • FLUSH_OUTPUT : GifDecoder.cpp
  • FMRADIO : apoxi.features
  • FmRadio_SelectStrongerFreq_hpp : FmRadioSelectStrongerFreq.hpp
  • FmRadioEditWin_hpp : FmRadioEditWin.hpp
  • FMRADIOVERSION : FmRadioVersion.hpp
  • FmRadioVersion_hpp : FmRadioVersion.hpp
  • FONTPACK_ID : AcacTypes.hpp
  • ForAllPlanes : SetPixel_Planes.cpp, ScrollHorizontal_Planes.cpp, GetPixelColor_Planes.cpp, FillRect_Planes.cpp, DrawChar_Planes.cpp, BitBlit_Planes.cpp, Ddrv.cpp
  • FREQUENCY_BEGIN : FmRadioAudioPlayer.cpp
  • FS_APPEND : FatSim.hpp
  • FS_BINARY : FatSim.hpp
  • FS_CREAT : FatSim.hpp
  • FS_ERR_ACCES : FatSim.hpp
  • FS_ERR_BAD_FORMAT : FatSim.hpp
  • FS_ERR_BAD_MEDIA : FatSim.hpp
  • FS_ERR_BADF : FatSim.hpp
  • FS_ERR_DEVICE : FatSim.hpp
  • FS_ERR_ECC_ERROR : FatSim.hpp
  • FS_ERR_EXIST : FatSim.hpp
  • FS_ERR_FAULT : FatSim.hpp
  • FS_ERR_ID_ERROR : FatSim.hpp
  • FS_ERR_INVAL : FatSim.hpp
  • FS_ERR_IO : FatSim.hpp
  • FS_ERR_MEDIA_CHANGED : FatSim.hpp
  • FS_ERR_MEDIA_FAILURE : FatSim.hpp
  • FS_ERR_MFILE : FatSim.hpp
  • FS_ERR_NO_MEDIA : FatSim.hpp
  • FS_ERR_NOENT : FatSim.hpp
  • FS_ERR_NOSPC : FatSim.hpp
  • FS_ERR_OPERATION_NOT_POSSIBLE : FatSim.hpp
  • FS_ERR_SHARE : FatSim.hpp
  • FS_ERR_USER_ID_ERROR : FatSim.hpp
  • FS_EXCL : FatSim.hpp
  • FS_FAILURE : FatSim.hpp
  • FS_INVALID_FILEHANDLE : FatSim.hpp
  • FS_IREAD : FatSim.hpp
  • FS_IWRITE : FatSim.hpp
  • FS_MAX_NO_OPEN_FILES : FatSim.hpp
  • FS_MAXPATH : FatSim.hpp
  • FS_NOF_DEVICES : FatSim.hpp
  • FS_NOSHAREANY : FatSim.hpp
  • FS_NOSHAREWRITE : FatSim.hpp
  • FS_RDONLY : FatSim.hpp
  • FS_RDWR : FatSim.hpp
  • FS_SEEK_CUR : FatSim.hpp
  • FS_SEEK_END : FatSim.hpp
  • FS_SEEK_SET : FatSim.hpp
  • FS_SUCCESS : FatSim.hpp
  • FS_TEXT : FatSim.hpp
  • FS_TRUNC : FatSim.hpp
  • FS_WRONLY : FatSim.hpp
  • FTPSERVER : apoxi.features
  • FTPSERVER_DBG_OUT_RANGE : FtpTypes.hpp
  • FTPSERVER_DBG_OUT_RANGE_CMD : FtpTypes.hpp
  • FTPSERVER_DBG_OUT_RANGE_EXTENDED : FtpTypes.hpp
  • FTPSERVER_DBG_OUT_RANGE_REPLY : FtpTypes.hpp
  • FUNCTION_TRACER_HPP : FunctionTracer.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- g -

  • GATIMANAGER_CONNECTIONS_MAX : GatiManager.hpp
  • GATIMANAGER_DATABASE_MAX : GatiManager.hpp
  • GATIMANAGER_PORT : GatiManager.hpp
  • GATIMANAGER_PORT_VAR : GatiManager.hpp
  • GDD : apoxi.features
  • GDD_LCD_UPDATE_CALLBACK : DefaultDisplay.cpp
  • GenericAudioDevice_hpp : GenericAudioDevice.hpp
  • GET_16BPP_COLOR_VALUE : Image.hpp
  • GET_HEAP_TABLE : HeapVector.hpp
  • GIF_APP_EXT : GifDecoder.cpp
  • GIF_COLOR_TABLE_SIZE : GifDecoder.cpp
  • GIF_COMMENT_EXT : GifDecoder.cpp
  • GIF_EXTENSION : GifDecoder.cpp
  • GIF_GCE_SIZE : GifDecoder.cpp
  • GIF_GRAPHIC_EXT : GifDecoder.cpp
  • GIF_HEADER_SIZE : GifDecoder.cpp
  • GIF_ID_SIZE : GifDecoder.cpp
  • GIF_IMAGE_DESC : GifDecoder.cpp
  • GIF_LSD_SIZE : GifDecoder.cpp
  • GIF_TEXT_EXT : GifDecoder.cpp
  • GIF_TRAILER : GifDecoder.cpp
  • GLOBAL : LwipSysSocket.cpp, WinInc.hpp, Thread.cpp, Nuc32.cpp
  • GlyphHeaderPtr : Font.hpp
  • GlyphIndexTabPtr : Font.hpp
  • GlyphPtr : Font.hpp
  • GlyphTab : Font.hpp
  • GsmInternalCodingAt : DataCoding.hpp
  • GTL : apoxi.features
  • Gui_Lib_hpp : Lib.hpp
  • GuiExtensions_InputMapperFactory_hpp : InputMapperFactory.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- h -

  • HARDWARE_ENCODER_IS_USED : StillCamera.cpp
  • HEAP_BYTES_PER_UINT : HeapVector.hpp
  • HEAP_CONTEXT_VECTOR_PTR : HeapVector.hpp
  • HEAP_DATASINK_CLOSED : HeapDataSink.cpp
  • HEAP_DATASINK_INIT : HeapDataSink.cpp
  • HEAP_DATASINK_OPENED : HeapDataSink.cpp
  • HEAP_ENTRY : HeapVector.hpp
  • HEAP_SIZE_VECTOR_PTR : HeapVector.hpp
  • HEAP_STAT_STRUCT_VALUES : HeapVector.hpp
  • HEAP_TABLE_BEGIN : HeapVector.hpp
  • HEAP_TABLE_END : HeapVector.hpp
  • HF_DEVICE_FEATURES : BtHfAppPlugin.hpp
  • HF_INBAND_SETTING : BtHfAppPlugin.hpp
  • HF_SETTINGS : BtHfProfileWindows.cpp
  • HTTPSERVER : apoxi.features
  • HTTPSERVER_ASCII_AMP : HttpTypes.hpp
  • HTTPSERVER_ASCII_CR : HttpTypes.hpp
  • HTTPSERVER_ASCII_DOT : HttpTypes.hpp
  • HTTPSERVER_ASCII_EQU : HttpTypes.hpp
  • HTTPSERVER_ASCII_LF : HttpTypes.hpp
  • HTTPSERVER_ASCII_PER : HttpTypes.hpp
  • HTTPSERVER_ASCII_PL : HttpTypes.hpp
  • HTTPSERVER_ASCII_QM : HttpTypes.hpp
  • HTTPSERVER_ASCII_SL : HttpTypes.hpp
  • HTTPSERVER_ASCII_SP : HttpTypes.hpp
  • HTTPSERVER_DBG_OUT_RANGE : HttpTypes.hpp
  • HTTPWAPINTERFACE : apoxi.features
  • huge : aud_drv.cpp, FatSim.hpp
  • HUGE_HEAP_PAGE : HeapVector.hpp
  • HWTRC_APOXI_END : InternalTracer.cpp
  • HWTRC_APOXI_START : InternalTracer.cpp
  • HWTRC_ESCAPE : InternalTracer.cpp
  • HWTRC_INTRO_CHAR : InternalTracer.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- i -

  • I1_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • I2_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • ICON_URI_STR : DrmDcfParser.hpp
  • IMAGE_BUFFER_NOT_USED : StillCamera.cpp
  • IMAGE_CAPTURED_OK : StillCamera.hpp
  • IMAGE_ENCODED_OK : StillCamera.hpp
  • IMAGE_ITEM_HEIGHT : ImageView.hpp
  • IMGBRVERSION : ImgbrVersion.hpp
  • ImgbrVersion_hpp : ImgbrVersion.hpp
  • IndicatorItem_hpp : ValueItem.hpp
  • INPUT_BUF_SIZE : Zi8Wrapper.hpp, JpegDecoder.cpp
  • INPUT_BYTE : GifDecoder.cpp, BmpDecoder.cpp
  • INSTRUMENT_NO : TestWriter.cpp
  • INT : WinInc.hpp, NucInc.hpp
  • INT16 : WinInc.hpp, NucInc.hpp
  • INT32 : WinInc.hpp, NucInc.hpp
  • INT8 : WinInc.hpp, NucInc.hpp
  • INTERNAL_TRACER_HPP : InternalTracer.hpp
  • INTERNATIONALIZATION : apoxi.features
  • INVALID_GLYPH_UNICODE : AcacTypes.hpp
  • INVALID_PCFD : FatSim.hpp
  • InvalidBcdPlmn : NetworkTypes.hpp
  • InvalidPlmn : NetworkTypes.hpp
  • IRDA : apoxi.features
  • IRDA_DBG_OUT : IrdaObexImpl.cpp
  • IrdaAppVersion_hpp : IrdaAppVersion.hpp
  • IRDAVERSION : IrdaAppVersion.hpp
  • ISFATAL : parsifal.cpp
  • ISILLchar : parsifal.cpp
  • IsInFieldRange : Wsscanf.cpp
  • ISMAPCH : parsifal.cpp
  • ISNULLSTR : parsifal.cpp
  • IsOdd : BidiManager.cpp
  • ISQNAME : parsifal.cpp
  • ISQUOTE : parsifal.cpp
  • IsRightToLeftCharacter : BidiManager.cpp
  • isspace : parsifal.cpp
  • ISWHITESPACE : parsifal.cpp
  • ISXMLNSPREFIX : parsifal.cpp
  • ISXMLPREFIX : parsifal.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- p -

  • PADDING_STR : DrmDcfParser.hpp
  • PAGE_ENTRY : HeapVector.hpp
  • PAGE_TABLE_BEGIN : HeapVector.hpp
  • PAGE_TABLE_END : HeapVector.hpp
  • PB_AAS_DATA : UsimPbTypes.hpp
  • PB_ANR_REF : UsimPbTypes.hpp
  • PB_APPL : UsimPbTypes.hpp
  • PB_BUFFER_IS_NULL : UsimPbTypes.hpp
  • PB_BUFFER_TO_SMALL : UsimPbTypes.hpp
  • PB_CCP1_DATA : UsimPbTypes.hpp
  • PB_CLIENT_FLAG_AUTOLOAD : UsimPbTypes.hpp
  • PB_DATA_TYPE_MISMATCH : UsimPbTypes.hpp
  • PB_EMAIL_REF : UsimPbTypes.hpp
  • PB_EXT1_DATA : UsimPbTypes.hpp
  • PB_GAS_DATA : UsimPbTypes.hpp
  • PB_GLOBAL : UsimPbTypes.hpp
  • PB_INDICATION : UsimPbTypes.hpp
  • PB_LINK_TYPE_1 : UsimPbTypes.hpp
  • PB_LINK_TYPE_2 : UsimPbTypes.hpp
  • PB_LINK_TYPE_3 : UsimPbTypes.hpp
  • PB_MAX_FILE_TYPE_ENTITY : UsimPbTypes.hpp
  • PB_MAX_GROUP : UsimPbTypes.hpp
  • PB_MAX_SLICE : UsimPbTypes.hpp
  • PB_NO_FREE_RECORD : UsimPbTypes.hpp
  • PB_NOT_EXIST : UsimPbTypes.hpp
  • PB_NOT_LOADED : UsimPbTypes.hpp
  • PB_NOT_LOCATED : UsimPbTypes.hpp
  • PB_NOT_SEL : UsimPbTypes.hpp
  • PB_NOT_SELECTED : UsimPbTypes.hpp
  • PB_REF_REFRESH : UsimPbTypes.hpp
  • PB_REFRESH : UsimPbTypes.hpp
  • PB_RESPONSE : UsimPbTypes.hpp
  • PB_SIM : UsimPbTypes.hpp
  • PB_SKIPPED : UsimPbTypes.hpp
  • PB_SNE_REF : UsimPbTypes.hpp
  • PB_SUCCESSFUL : UsimPbTypes.hpp
  • PB_SUCCESSFUL_UID : UsimPbTypes.hpp
  • PB_TECHNICAL_PROBLEM : UsimPbTypes.hpp
  • PB_TO_FEW_FREE_EXT : UsimPbTypes.hpp
  • PB_WRONG_DATA_TYPE : UsimPbTypes.hpp
  • PB_WRONG_HANDLE : UsimPbTypes.hpp
  • PB_WRONG_LOCATION : UsimPbTypes.hpp
  • PB_WRONG_REC_NUMBER : UsimPbTypes.hpp
  • PB_WRONG_REF_REC : UsimPbTypes.hpp
  • PB_WRONG_STRUCTURE : UsimPbTypes.hpp
  • PCFD : FatSim.hpp
  • PCM_FILEPLAY_FRAMENUM : HostAudioDriver.hpp
  • PCM_FILEREC_FRAMENUM : HostAudioDriver.hpp
  • PEACCES : FatSim.hpp
  • PEBADF : FatSim.hpp
  • PEDEVICE : FatSim.hpp
  • PEEXIST : FatSim.hpp
  • PEFAULT : FatSim.hpp
  • PEINVAL : FatSim.hpp
  • PEIO : FatSim.hpp
  • PEMFILE : FatSim.hpp
  • PENOENT : FatSim.hpp
  • PENOSPC : FatSim.hpp
  • PESHARE : FatSim.hpp
  • PESUCCESS : FatSim.hpp
  • PHONE_NUMBER_RESET : PhoneNumber.cpp
  • PhonebookWin_hpp : PhonebookWin.hpp
  • PNG_ENCODER : apoxi.features
  • PNG_SIGNATURE_SIZE : PngDecoder.cpp
  • PO_APPEND : FatSim.hpp
  • PO_BINARY : FatSim.hpp
  • PO_CREAT : FatSim.hpp
  • PO_EXCL : FatSim.hpp
  • PO_NOSHAREANY : FatSim.hpp
  • PO_NOSHAREWRITE : FatSim.hpp
  • PO_RDONLY : FatSim.hpp
  • PO_RDWR : FatSim.hpp
  • PO_TEXT : FatSim.hpp
  • PO_TRUNC : FatSim.hpp
  • PO_WRONLY : FatSim.hpp
  • POWER_SAVING_RELEASE : apoxi.features
  • PropertyEditorID_hpp : PropertyEditorID.hpp
  • PropertyID_hpp : PropertyID.hpp
  • ProviderProxyContainer_hpp : ProviderProxyContainer.hpp
  • ProviderProxyItem_hpp : ProviderProxyItem.hpp
  • PS_IREAD : FatSim.hpp
  • PS_IWRITE : FatSim.hpp
  • PSEEK_CUR : FatSim.hpp
  • PSEEK_END : FatSim.hpp
  • PSEEK_SET : FatSim.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- q -

  • QcifSize_INDEX : Camera.cpp
  • QqcifSize_INDEX : Camera.cpp
  • QqvgaSize_INDEX : Camera.cpp
  • QsifSize_INDEX : Camera.cpp
  • QvgaSize_INDEX : Camera.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- r -

  • R2L : ArabicTextRenderer.cpp
  • RDS_VALIDATE_LIMIT : FmRadioAudioPlayer.cpp
  • REGISTER_GATI_SERVER : MmiSimServer.cpp, HostAudioGatiServer.cpp, AragonServer.cpp, GatiManager.hpp
  • REMOTE_VOLUME_SETTING : BtHfAppPlugin.hpp
  • ReportErrorAndReturn : Wsscanf.cpp
  • RESET_PICTURE_COUNTER : StillCamera.cpp
  • ResourceID_hpp : ResourceID.hpp
  • RESPONSE_TRACE : PsdDataConn.cpp
  • RFS_CHUNK_ATOM_SIZE : File.cpp
  • RFS_FAT_CHUNK_SIZE : FatStorageDeviceImp.cpp
  • RFS_FFS_CHUNK_SIZE : FlashStorageDeviceImp.cpp
  • RFS_RAM_CHUNK_SIZE : RamStorageDeviceImp.cpp
  • RFS_RFS_CHUNK_SIZE : RootStorageDeviceImp.cpp
  • RfsMsgTypes_hpp__ST_1128347704782 : RfsMsgTypes.hpp
  • RfsObexFtpServer_hpp : RfsObexFtpServer.hpp
  • RfsObexFtpTrace : RfsObexFtpServer.cpp
  • RIGHT_ISSUER_STR : DrmDcfParser.hpp
  • RingerAudioDevice_hpp : RingerAudioDevice.hpp
  • RLE_COMMAND : BmpDecoder.cpp
  • RLE_DELTA : BmpDecoder.cpp
  • RLE_ENDOFBITMAP : BmpDecoder.cpp
  • RLE_ENDOFLINE : BmpDecoder.cpp
  • RomDataRes_hpp : RomDataRes.hpp
  • rt : parsifal.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- s -

  • SAFE_FREESTR : parsifal.cpp
  • SaveDelete : Macros.hpp
  • ScicosCodecIfLib_hpp : ScicosCodecIfLib.hpp
  • ScicosMpeg4VideoDecoder_hpp : ScicosMpeg4VideoDecoder.hpp
  • ScicosMpeg4VideoEncoder_hpp : ScicosMpeg4VideoEncoder.hpp
  • SDMMCSPI : apoxi.features
  • SEEKWS : parsifal.cpp
  • SER_DATACONN_SUPPORT : apoxi.features
  • SERVER : apoxi.features
  • SERVER_DBG_OUT_RANGE : Server.hpp
  • Services_Service_hpp : Service.hpp
  • Services_ServiceBroker_hpp : ServiceBroker.hpp
  • ServiceThreadExtn_hpp : ExtndServiceThreadForNetwork.hpp
  • SET_G_TONE_DATA : aud_drv.cpp
  • SIMTK_LETTERCLASS_E : apoxi.features, apoxi.defines
  • SimtkSetSignalParam1 : SimTkTypes.hpp
  • SimtkSetSignalParam10 : SimTkTypes.hpp
  • SimtkSetSignalParam11 : SimTkTypes.hpp
  • SimtkSetSignalParam2 : SimTkTypes.hpp
  • SimtkSetSignalParam3 : SimTkTypes.hpp
  • SimtkSetSignalParam4 : SimTkTypes.hpp
  • SimtkSetSignalParam5 : SimTkTypes.hpp
  • SimtkSetSignalParam6 : SimTkTypes.hpp
  • SimtkSetSignalParam7 : SimTkTypes.hpp
  • SimtkSetSignalParam8 : SimTkTypes.hpp
  • SimtkSetSignalParam9 : SimTkTypes.hpp
  • SimtkSetSignalTid : SimTkTypes.hpp
  • SimtkSignalParam1 : SimTkTypes.hpp
  • SimtkSignalParam10 : SimTkTypes.hpp
  • SimtkSignalParam11 : SimTkTypes.hpp
  • SimtkSignalParam2 : SimTkTypes.hpp
  • SimtkSignalParam3 : SimTkTypes.hpp
  • SimtkSignalParam4 : SimTkTypes.hpp
  • SimtkSignalParam5 : SimTkTypes.hpp
  • SimtkSignalParam6 : SimTkTypes.hpp
  • SimtkSignalParam7 : SimTkTypes.hpp
  • SimtkSignalParam8 : SimTkTypes.hpp
  • SimtkSignalParam9 : SimTkTypes.hpp
  • SimtkSignalTid : SimTkTypes.hpp
  • SIO_SIGNAL_DATA_SENT : SerialIoAdapter.hpp
  • SIO_USE_SOCKET_CONCEPT : SerialIoAdapter.hpp
  • Size1_3Mp_INDEX : Camera.cpp
  • Size1Mp_INDEX : Camera.cpp
  • Size2Mp_INDEX : Camera.cpp
  • Size3Mp_INDEX : Camera.cpp
  • SIZECENTRALDIRITEM : Unzip.hpp
  • SIZEZIPLOCALHEADER : Unzip.hpp
  • SKIP_BYTES : GifDecoder.cpp
  • SKIP_SPACE : MultipartParser.hpp
  • Sms_SmsMsgTypes_hpp : SmsMsgTypes.hpp
  • SNDBRVERSION : SoundBrowserVersion.hpp
  • SOCKET : apoxi.features
  • SocketMsg_hpp__ST_1044273316690 : SocketMsg.hpp
  • SocketTestMsgTypes_hpp__ST_1092045237546 : SocketTestMsgTypes.hpp
  • SocketTestVersion_hpp : SocketTestVersion.hpp
  • SocketTrace : SocketTypes.hpp
  • SOCKETVERSION : SocketTestVersion.hpp
  • SoundBrowserVersion_hpp : SoundBrowserVersion.hpp
  • SpeechAudioDevice_hpp : SpeechAudioDevice.hpp
  • SqcifSize_INDEX : Camera.cpp
  • STATE_MAP_ENTRY : StateMachine.hpp
  • StillCameraTestCode : CameraCaptureWin.cpp, StillCamera.cpp
  • STOPPED_BY_GDD_PROBLEM : StillCamera.hpp
  • STOPPED_BY_NO_BUFFER_FOUND : StillCamera.hpp
  • STOPPED_BY_USER_CANCEL : StillCamera.hpp
  • STOPPED_NORMALLY : StillCamera.hpp
  • STR_CONTENT_ENCODING : MultipartParser.hpp
  • STR_CONTENT_ID : MultipartParser.hpp
  • STR_CONTENT_TYPE : MultipartParser.hpp
  • STR_DESCRIPTION : MultipartParser.hpp
  • STR_DISPOSITION : MultipartParser.hpp
  • strcat : HostCoreFsSim.cpp
  • strcpy : HostCoreFsSim.cpp
  • StringDataSink_hpp : StringDataSink.hpp
  • SUB_UNIT_INFO : BtAvrcpControllerApplicationWindows.cpp
  • SVG : apoxi.features
  • SVG_ABS : SvgImage.cpp
  • SVG_ANTI_ALIAS_LEVEL : SvgConfig.hpp
  • SVG_ASSERT : SvgDebug.hpp
  • SVG_BYTES_PER_PIXEL : SvgConfig.hpp
  • SVG_DBG_OUT : SvgDebug.hpp
  • SVG_DBG_SECTION_CALLBACK : SvgDebug.hpp
  • SVG_DBG_SECTION_DECODER : SvgDebug.hpp
  • SVG_DBG_SECTION_FILEWRAPPER : SvgDebug.hpp
  • SVG_DBG_SECTION_FIXPOINT : SvgDebug.hpp
  • SVG_DBG_SECTION_GZ : SvgDebug.hpp
  • SVG_DBG_SECTION_IMAGE : SvgDebug.hpp
  • SVG_DBG_SECTION_MEMORY : SvgDebug.hpp
  • SVG_DBG_SECTION_MEMORY_PROF : SvgDebug.hpp
  • SVG_DBG_SECTION_MIME : SvgDebug.hpp
  • SVG_DBG_SECTION_PLAYER : SvgDebug.hpp
  • SVG_DBG_SECTION_SYSFONTS : SvgDebug.hpp
  • SVG_DBG_SECTION_TEST : SvgDebug.hpp
  • SVG_DBG_SECTIONS_USE_ALL : SvgDebug.hpp
  • SVG_DBG_USED_SECTIONS : SvgDebug.hpp
  • SVG_DEBUG : SvgConfig.hpp
  • SVG_FILE_FONTS : SvgDecoder.cpp
  • SVG_FILE_SVG_DOCUMENT : SvgDecoder.cpp
  • SVG_FONT_ANTI_ALIAS_LEVEL : SvgConfig.hpp
  • SVG_FONT_RESOURCE_FFS : SvgConfig.hpp
  • SVG_FONT_RESOURCE_FFS_FILENAME : SvgConfig.hpp
  • SVG_FONT_RESOURCE_INLINE : SvgConfig.hpp
  • SVG_FONT_RESOURCE_INLINE_FILENAME : SvgConfig.hpp
  • SVG_FONT_USE_SYSTEM_FONT : SvgConfig.hpp
  • SVG_FP_CONST_0 : SvgFixPoint.cpp
  • SVG_FP_CONST_1 : SvgFixPoint.cpp
  • SVG_FP_CONST_90 : SvgFixPoint.cpp
  • SVG_FP_ENTRIES_PER_DEG : SvgFixPoint.cpp
  • SVG_FP_FIRST_QUADRANT : SvgFixPoint.cpp
  • SVG_FP_FP_TO_INT : SvgFixPoint.hpp
  • SVG_FP_INT_TO_FP : SvgFixPoint.hpp
  • SVG_FP_ONE_REVOLUTION : SvgFixPoint.cpp
  • SVG_FP_SECOND_QUADRANT : SvgFixPoint.cpp
  • SVG_FP_THIRD_QUADRANT : SvgFixPoint.cpp
  • SVG_FP_TRANS_GET_X_SCALE : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_X_SHEAR : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_X_TRANS : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_Y_SCALE : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_Y_SHEAR : SvgFixPoint.hpp
  • SVG_FP_TRANS_GET_Y_TRANS : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_X_SCALE : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_X_SHEAR : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_X_TRANS : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_Y_SCALE : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_Y_SHEAR : SvgFixPoint.hpp
  • SVG_FP_TRANS_SET_Y_TRANS : SvgFixPoint.hpp
  • SVG_GZ_FLAGS_COMMENT : SvgGzFileWrapper.cpp
  • SVG_GZ_FLAGS_CRC16 : SvgGzFileWrapper.cpp
  • SVG_GZ_FLAGS_EXTRA : SvgGzFileWrapper.cpp
  • SVG_GZ_FLAGS_ORIG_NAME : SvgGzFileWrapper.cpp
  • SVG_GZ_INPUT_BUFFER_SIZE : SvgGzFileWrapper.hpp
  • SVG_GZ_MAGIC_1 : SvgGzFileWrapper.cpp
  • SVG_GZ_MAGIC_2 : SvgGzFileWrapper.cpp
  • SVG_GZ_MINIMAL_HEADER_LENGTH : SvgGzFileWrapper.cpp
  • SVG_GZ_RESERVED : SvgGzFileWrapper.cpp
  • SVG_GZ_Z_DEFLATED : SvgGzFileWrapper.cpp
  • SVG_IMAGE_FRAMES_PER_SECOND : SvgImage.cpp
  • SVG_IMAGE_HEURISTIC_PAUSE : SvgImage.cpp
  • SVG_LARGEST_IMAGE_SIZE : SvgConfig.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_GIF : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_JPEG : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_PNG : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_SVG : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IMAGE_WBMP : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_IS_IMAGE : SvgMimeUtil.hpp
  • SVG_MIME_CONTENT_TYPE_NA : SvgMimeUtil.hpp
  • SVG_NUMBER_OF_ZOOMLEVELS : SvgConfig.hpp
  • SVG_PLAYER_DEFAULT_HEIGHT : SvgConfig.hpp
  • SVG_PLAYER_DEFAULT_WIDTH : SvgConfig.hpp
  • SVG_PRINT_IMAGE_ERROR : SvgDebug.hpp
  • SVG_SMALLEST_PREFERED_MEM_CHUNK_SIZE : SvgConfig.hpp
  • SVG_VIRTUAL_HEAP : SvgConfig.hpp
  • SvgaSize_INDEX : Camera.cpp
  • SvgFixPoint_Bounded_Cos : SvgFixPoint.cpp
  • SvgFixPoint_Scalar_Add : SvgFixPoint.hpp
  • SvgFixPoint_Scalar_Sub : SvgFixPoint.hpp
  • SvgFontConfig : SvgDecoder.cpp
  • SVGFONTCONFIG_GET_FONT_ATTR : SvgDecoder.cpp
  • SVGFONTCONFIG_GET_FONT_INDEX : SvgDecoder.cpp
  • SVGFONTCONFIG_SET_FONT_ATTR : SvgDecoder.cpp
  • SVGFONTCONFIG_SET_FONT_INDEX : SvgDecoder.cpp
  • SVGIMAGE_DEFAULT_HEIGHT : SvgImage.hpp
  • SVGIMAGE_DEFAULT_WIDTH : SvgImage.hpp
  • SYNCML : apoxi.features
  • SYNCML_DATABASE_MAX : SyncMLManager.hpp
  • SyncML_MsgTypes_hpp : MsgTypes.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- t -

  • T9 : apoxi.features
  • T9PACK_ID : AcacTypes.hpp
  • T9ThaiMatrixModeWindowInterface_hpp : T9ThaiMatrixModeWindowInterface.hpp
  • TEMPORARY_USED : StillCamera.cpp
  • Test_PbSelectGroup_hpp : PbSelectGroup.hpp
  • Test_PbSelectNoType_hpp : PbSelectNoType.hpp
  • TESTEN_DEBUG : StillCamera.cpp
  • TESTING : apoxi.features
  • TEXTPACK_ID : AcacTypes.hpp
  • TEXTPACK_KEYLANG_INDEX : AcacTypes.hpp
  • THREAD_DATA_SEM_OBTAIN : Thread.cpp
  • THREAD_DATA_SEM_RELEASE : Thread.cpp
  • TIMER_SEM_INFINITE : Semaphore.cpp
  • ToDoApp_hpp : ToDoApp.hpp
  • ToDoComposeWin_hpp : ToDoComposeWin.hpp
  • ToDoDialogWin_hpp : ToDoDialogWin.hpp
  • TOK_END_CDATA : parsifal.cpp
  • TOK_END_COMMENT : parsifal.cpp
  • TOK_END_DTD : parsifal.cpp
  • TOK_END_PI : parsifal.cpp
  • TOK_GT : parsifal.cpp
  • TOK_LT : parsifal.cpp
  • TOK_XMLNS : parsifal.cpp
  • ToneAudioDevice_hpp : ToneAudioDevice.hpp
  • TRACE1LN : VideoCamera.cpp
  • TRACE2LN : VideoCamera.cpp
  • TRACE3LN : VideoCamera.cpp
  • TRACE4LN : VideoCamera.cpp
  • TRACE_APOXI_AUDIO_CRITICAL_SECTION : AudioPriorityManager.cpp
  • TRACE_APOXI_AUDIO_EVENT_HANDLING : AudioPriorityManager.cpp
  • TRACE_APOXI_AUDIO_PM_LOGIC : AudioPriorityManager.cpp
  • TRACE_HOST_NAME : InternalTracer.cpp
  • TRACE_HPP : Trace.hpp
  • TRACE_PORT : InternalTracer.cpp
  • TRACELN : VideoCamera.cpp
  • TRANSITION_MAP_ENTRY : StateMachine.hpp
  • TriggerKeyFeature_hpp : TriggerKeyFeature.hpp
  • TTY : apoxi.features
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- u -

  • UCHAR : InternalTracer.cpp, WinInc.hpp
  • UdpSocketExtn_hpp : ExtndUdpSocket.hpp
  • UibInboxTest_hpp : UibInboxTest.hpp
  • UibNotifyTest_hpp : UibNotifyTest.hpp
  • UibPerformanceTest_hpp : UibPerformanceTest.hpp
  • UibSettingsProvider_hpp : UibSettingsProvider.hpp
  • UibSettingsTest_hpp : UibSettingsTest.hpp
  • UibSortingTest_hpp : UibSortingTest.hpp
  • UibUpdateThreadlet_hpp : UibUpdateThreadlet.hpp
  • UIBVERSION : UibVersion.hpp
  • UibVersion_hpp : UibVersion.hpp
  • UINT : WinInc.hpp, NucInc.hpp
  • UINT16 : WinInc.hpp, NucInc.hpp
  • UINT32 : WinInc.hpp, NucInc.hpp
  • UINT8 : WinInc.hpp, NucInc.hpp
  • ULONG : WinInc.hpp
  • UnifiedInbox_UibActionAccessor_hpp : UibActionAccessor.hpp
  • UnifiedInbox_UibApp_hpp : UibApp.hpp
  • UnifiedInbox_UibFolderWin_hpp : UibFolderWin.hpp
  • UnifiedInbox_UibInboxProvider_hpp : UibInboxProvider.hpp
  • UnifiedInbox_UibListBoxModel_hpp : UibListBoxModel.hpp
  • UnifiedInbox_UibMsgTypes_hpp : UibMsgTypes.hpp
  • UnifiedInbox_UibServiceImpl_hpp : UibServiceImpl.hpp
  • UnifiedInbox_UibSettingsWin_hpp : UibSettingsWin.hpp
  • UnifiedInbox_UibTestControl_hpp : UibTestControl.hpp
  • UnifiedInobx_UibMsgDisplayTest_hpp : UibMsgDisplayTest.hpp
  • UNITTEST : apoxi.features
  • UnitTest_MsgTypes_hpp : MsgTypes.hpp
  • UnitTestMacros_hpp : UnitTestMacros.hpp
  • UNLOCK_PDP_CONTEXT_HANDLER : PdpContextManager.hpp
  • UNZ_BADZIPFILE : Unzip.hpp
  • UNZ_CRCERROR : Unzip.hpp
  • UNZ_END_OF_LIST_OF_FILE : Unzip.hpp
  • UNZ_EOF : Unzip.hpp
  • UNZ_ERRNO : Unzip.hpp
  • UNZ_INTERNALERROR : Unzip.hpp
  • UNZ_MAXFILENAMEINZIP : Unzip.hpp
  • UNZ_OK : Unzip.hpp
  • UNZ_PARAMERROR : Unzip.hpp
  • USB : apoxi.features
  • USBVERSION : UsbVersion.hpp
  • UsbVersion_hpp : UsbVersion.hpp
  • USIMAP_ALPHA_LEN : SignalTypes.hpp
  • USIMAP_LANG_LIST_LEN : SignalTypes.hpp
  • USIMAP_PLMN_LIST_LEN : NetworkTypes.hpp
  • USIMAP_SERVICE_TABLE_LEN : SignalTypes.hpp
  • UTF8_COMPUTE : Unicode.hpp
  • UTF8_GET : Unicode.hpp
  • UTTcpSocket_hpp : UTTcpSocket.hpp
  • UUS : apoxi.features
  • UxgaSize_INDEX : Camera.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- v -

  • VAR_HEAP_CONTEXT_VECTOR : HeapVector.hpp
  • VAR_HEAP_PAGE : HeapVector.hpp
  • VAR_HEAP_SIZE_VECTOR : HeapVector.hpp
  • VgaSize_INDEX : Camera.cpp
  • VIB : apoxi.features
  • VIDEO_ENCODER_MAX_CONFIG_STREAM_SIZE : AtiMpeg4Encoder.cpp
  • VideoCaptureParameters_hpp : VideoCaptureParameters.hpp
  • VIRTUAL_HEAP_ENTRY : HeapVector.hpp
  • VoiceMemoAudioDevice_hpp : VoiceMemoAudioDevice.hpp
  • VOICERECOGNITION : apoxi.features
  • VoiceRecognition_MsgTypes_hpp : MsgTypes.hpp
  • VOICEVERSION : VoiceMemoVersion.hpp
  • VoiceVersion_hpp : VoiceMemoVersion.hpp
  • VOLUME_STEPS : FmRadioWindow.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- w -

  • W_LATIN_AMPERSAND : Latin.hpp
  • W_LATIN_APOSTROPHE : Latin.hpp
  • W_LATIN_ASTERISK : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_A : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_B : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_C : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_D : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_E : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_F : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_G : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_H : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_I : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_J : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_K : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_L : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_M : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_N : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_O : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_P : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_Q : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_R : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_S : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_T : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_U : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_V : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_W : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_X : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_Y : Latin.hpp
  • W_LATIN_CAPITAL_LETTER_Z : Latin.hpp
  • W_LATIN_CIRCUMFLEX_ACCENT : Latin.hpp
  • W_LATIN_COLON : Latin.hpp
  • W_LATIN_COMMA : Latin.hpp
  • W_LATIN_COMMERCIAL_AT : Latin.hpp
  • W_LATIN_CR : Latin.hpp
  • W_LATIN_DIGIT_EIGHT : Latin.hpp
  • W_LATIN_DIGIT_FIVE : Latin.hpp
  • W_LATIN_DIGIT_FOUR : Latin.hpp
  • W_LATIN_DIGIT_NINE : Latin.hpp
  • W_LATIN_DIGIT_ONE : Latin.hpp
  • W_LATIN_DIGIT_SEVEN : Latin.hpp
  • W_LATIN_DIGIT_SIX : Latin.hpp
  • W_LATIN_DIGIT_THREE : Latin.hpp
  • W_LATIN_DIGIT_TWO : Latin.hpp
  • W_LATIN_DIGIT_ZERO : Latin.hpp
  • W_LATIN_DOLLAR_SIGN : Latin.hpp
  • W_LATIN_EQUALS_SIGN : Latin.hpp
  • W_LATIN_EXCLAMATION_MARK : Latin.hpp
  • W_LATIN_FF : Latin.hpp
  • W_LATIN_FULL_STOP : Latin.hpp
  • W_LATIN_GRAVE_ACCENT : Latin.hpp
  • W_LATIN_GREATER_THAN_SIGN : Latin.hpp
  • W_LATIN_HT : Latin.hpp
  • W_LATIN_HYPHEN_MINUS : Latin.hpp
  • W_LATIN_LEFT_CURLY_BRACKET : Latin.hpp
  • W_LATIN_LEFT_PARENTHESIS : Latin.hpp
  • W_LATIN_LEFT_SQUARE_BRACKET : Latin.hpp
  • W_LATIN_LESS_THAN_SIGN : Latin.hpp
  • W_LATIN_LF : Latin.hpp
  • W_LATIN_LOW_LINE : Latin.hpp
  • W_LATIN_NUMBER_SIGN : Latin.hpp
  • W_LATIN_PERCENT_SIGN : Latin.hpp
  • W_LATIN_PLUS_SIGN : Latin.hpp
  • W_LATIN_QUESTION_MARK : Latin.hpp
  • W_LATIN_QUOTATION_MARK : Latin.hpp
  • W_LATIN_REVERSE_SOLIDUS : Latin.hpp
  • W_LATIN_RIGHT_CURLY_BRACKET : Latin.hpp
  • W_LATIN_RIGHT_PARENTHESIS : Latin.hpp
  • W_LATIN_RIGHT_SQUARE_BRACKET : Latin.hpp
  • W_LATIN_SEMICOLON : Latin.hpp
  • W_LATIN_SMALL_LETTER_A : Latin.hpp
  • W_LATIN_SMALL_LETTER_B : Latin.hpp
  • W_LATIN_SMALL_LETTER_C : Latin.hpp
  • W_LATIN_SMALL_LETTER_D : Latin.hpp
  • W_LATIN_SMALL_LETTER_E : Latin.hpp
  • W_LATIN_SMALL_LETTER_F : Latin.hpp
  • W_LATIN_SMALL_LETTER_G : Latin.hpp
  • W_LATIN_SMALL_LETTER_H : Latin.hpp
  • W_LATIN_SMALL_LETTER_I : Latin.hpp
  • W_LATIN_SMALL_LETTER_J : Latin.hpp
  • W_LATIN_SMALL_LETTER_K : Latin.hpp
  • W_LATIN_SMALL_LETTER_L : Latin.hpp
  • W_LATIN_SMALL_LETTER_M : Latin.hpp
  • W_LATIN_SMALL_LETTER_N : Latin.hpp
  • W_LATIN_SMALL_LETTER_O : Latin.hpp
  • W_LATIN_SMALL_LETTER_P : Latin.hpp
  • W_LATIN_SMALL_LETTER_Q : Latin.hpp
  • W_LATIN_SMALL_LETTER_R : Latin.hpp
  • W_LATIN_SMALL_LETTER_S : Latin.hpp
  • W_LATIN_SMALL_LETTER_T : Latin.hpp
  • W_LATIN_SMALL_LETTER_U : Latin.hpp
  • W_LATIN_SMALL_LETTER_V : Latin.hpp
  • W_LATIN_SMALL_LETTER_W : Latin.hpp
  • W_LATIN_SMALL_LETTER_X : Latin.hpp
  • W_LATIN_SMALL_LETTER_Y : Latin.hpp
  • W_LATIN_SMALL_LETTER_Z : Latin.hpp
  • W_LATIN_SOLIDUS : Latin.hpp
  • W_LATIN_SPACE : Latin.hpp
  • W_LATIN_TILDE : Latin.hpp
  • W_LATIN_VERTICAL_LINE : Latin.hpp
  • W_LATIN_VT : Latin.hpp
  • W_LATIN_ZERO : Wsprintf.cpp, StrPrintf.cpp
  • WapHandler_hpp : WapHandler.hpp
  • WapProfile_hpp : WapProfile.hpp
  • WapProfileMgr_hpp : WapProfileMgr.hpp
  • WC_QUES : WildcardStrncmp.hpp
  • WC_STAR : WildcardStrncmp.hpp
  • WCHAR : WinInc.hpp, NucInc.hpp
  • WIN32_DeleteFile : WinInc.hpp
  • WIN32_MessageBox : WinInc.hpp
  • WIN32_MoveFile : WinInc.hpp
  • WRITE_STATE : TestWriter.hpp
  • WRITESTATE : TestWriter.hpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- x -

  • XgaSize_INDEX : Camera.cpp
  • XSTEP : ImageBrowserDetailWin.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- y -

  • YAMAHA_MAPI : apoxi.features
  • YSTEP : ImageBrowserDetailWin.cpp
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- _ -

  • __Colid : ProvIds.hpp
  • _EmApoxi_Audio_State : EmApoxiAudioDeviceImpl.cpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- k -

  • KeymapType : ContextDescriptionTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- l -

  • L2Protocol : PdpTypes.hpp
  • LcsCost : LcsTypes.hpp
  • LcsErrorCode : LcsTypes.hpp
  • LcsNotificationType : LcsTypes.hpp
  • LcsShapeType : LcsTypes.hpp
  • LcsTimerType : LcsTimer.hpp
  • LcsTransportType : LcsTypes.hpp
  • LexToken : InputParser.hpp
  • LineSelector : SignalTypes.hpp
  • LocationMethod : LcsDecls.hpp
  • LocationType : LcsTypes.hpp
  • LocationUpdateStatus : SignalTypes.hpp
  • LockStatus : SimLockTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- m -

  • MdhCause : MdhTypes.hpp
  • MdhFilter : MdhTypes.hpp
  • MdhSmsrLocation : MdhTypes.hpp
  • MdhSorting : MdhTypes.hpp
  • MdhStatus : MdhTypes.hpp
  • MdhTransmitCause : MdhTypes.hpp
  • MdhWaitIndicatorLevel : MdhTypes.hpp
  • MdhWaitIndicatorSetting : MdhTypes.hpp
  • MdhWaitIndicatorSmsType : MdhTypes.hpp
  • MdhWaitType : MdhTypes.hpp
  • MdhWorkMedia : MdhTypes.hpp
  • MePhoneBookStatus : AtcTypes.hpp
  • MePhoneBookType : AtcTypes.hpp
  • MexeCertType : SimAuxHandler.hpp
  • MmCallState : MmTypes.hpp
  • MmiSimMsgId : MmiSimProtocol.hpp
  • MmiSubUnitType : BtAvrcpPanelService.hpp
  • MmRrReason : NetworkTypes.hpp
  • MolrStatus : LcsReqProcessor.hpp
  • MolrType : LcsTypes.hpp
  • MsgOrigin : MsgCategory.hpp
  • MultiSlotCapability : NetworkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- n -

  • Nai : Tlv.hpp
  • NetType : NetworkTypes.hpp
  • NetworkOpMode : NetworkTypes.hpp
  • NetworkSearchMode : NetworkTypes.hpp
  • NotificationDescription : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- o -

  • ObexAppMsgType : ObexTypes.hpp
  • ObexMsgType : ObexTypes.hpp
  • ObexProtocolId : ObexTypes.hpp
  • ObexTransportMsgType : ObexTypes.hpp
  • OverrideCategory : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- a -

  • AcmSelector : SignalTypes.hpp
  • AesError : AesCryptInterface.hpp
  • AocChargingStatus : SignalTypes.hpp
  • ApoxiMimeTypeId : MimeTypeTable.hpp
  • AtStatusType : AtcTypes.hpp
  • AudCmd : HostAudioDriver.hpp
  • AudioDevice : SignalTypes.hpp
  • AudioToneType : SignalTypes.hpp
  • AvrcpCommand : BtAvrcpCommandInterface.hpp
  • AvrcpResponse : BtAvrcpCommandInterface.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- b -

  • BCDConversionNibble : PhoneNumber.hpp
  • BdnState : NetworkTypes.hpp
  • BootNotification : Types.hpp
  • BppBuffSize : BtBppTypes.hpp
  • BppObjectTypeEnum : BtBppTypes.hpp
  • BtAvrcpCategory : BtTypes.hpp
  • BtAvrcpCommand : BtTypes.hpp
  • BtAvrcpControlType : BtTypes.hpp
  • BtAvrcpOpcode : BtTypes.hpp
  • BtAvrcpOperation : BtTypes.hpp
  • BtAvrcpResponseType : BtTypes.hpp
  • BtAvrcpRole : BtTypes.hpp
  • BtAvrcpStateFlag : BtTypes.hpp
  • BtAvrcpSubunitType : BtTypes.hpp
  • BtBipEncoding : BtBipTypes.hpp
  • BtBipResult : BtBipTypes.hpp
  • BtBipSessionId : BtBipTypes.hpp
  • BtBipTransformation : BtBipTypes.hpp
  • BtBppObexResult : BtBppTypes.hpp
  • BtBppResult : BtBppTypes.hpp
  • BtChipType : BtTypes.hpp
  • BtConnectableMode : BtTypes.hpp
  • BtDataElementType : BtTypes.hpp
  • BtDeviceRelation : BtTypes.hpp
  • BtDeviceState : BtTypes.hpp
  • BtDiscoverableMode : BtTypes.hpp
  • BtHfCallEvent : BtTypes.hpp
  • BtHfCallLocation : BtTypes.hpp
  • BtHfColIds : BtHfProvider.hpp
  • BtHfState : BtTypes.hpp
  • BtHsCallEvent : BtTypes.hpp
  • BtHsCallLocation : BtTypes.hpp
  • BtHsState : BtTypes.hpp
  • BtInquiryAccessCode : BtTypes.hpp
  • BtObexErrorCode : BtTypes.hpp
  • BtObexHeaderType : BtTypes.hpp
  • BtObexOperationCode : BtTypes.hpp
  • BtOperationType : BtTypes.hpp
  • BtPairableMode : BtTypes.hpp
  • BtProfile : BtTypes.hpp
  • BtProtocol : BtSocketAddr.hpp
  • BtRequestState : BtTypes.hpp
  • BtRequestType : BtTypes.hpp
  • BtResultCode : BtTypes.hpp
  • BtSecuritySettings : BtTypes.hpp
  • BtStackState : BtTypes.hpp
  • BtUuidType : BtTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- c -

  • CalendarRecordColumnId : CalendarProvider.hpp
  • CallApiRc : Types.hpp
  • CallErrorCause : SignalTypes.hpp
  • CallEstCause : SignalTypes.hpp
  • CallProgressInd : SignalTypes.hpp
  • CallRefuseDirection : SignalTypes.hpp
  • CallRelatedSs : SignalTypes.hpp
  • CallRelatedSsCode : SignalTypes.hpp
  • CallRelatedSsState : SignalTypes.hpp
  • CallState : SignalTypes.hpp
  • CallType : SignalTypes.hpp
  • CfuArrayIndex : SignalTypes.hpp
  • CfuDataSource : SignalTypes.hpp
  • CfuServiceCode : SignalTypes.hpp
  • ChargeEndReason : SignalTypes.hpp
  • ChargeShutdownReason : SignalTypes.hpp
  • ChvAction : SignalTypes.hpp
  • ChvNo : SignalTypes.hpp
  • ChvStatus : SignalTypes.hpp
  • ClearCause : Types.hpp
  • Client : SignalTypes.hpp
  • CliRestrictionOption : SignalTypes.hpp
  • ClirMode : SignalTypes.hpp
  • CnameChoice : SignalTypes.hpp
  • ConcatenetedStatus : SimPduHandler.hpp
  • ConnectType : FatSim.hpp
  • correction_type : DrmRelXml.hpp
  • CountryCodes : CountryCodes.hpp
  • CugSelector : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- d -

  • DataAvailability : SimAccessor.hpp
  • DataCallType : SignalTypes.hpp
  • DataConnColids : DataConnProvider.hpp
  • DataConnInfoMsgType : SocketTypes.hpp
  • DataConnProfileInfoMsgType : SocketTypes.hpp
  • DataControlType : Types.hpp
  • DataType : DataItem.hpp
  • date_type : DrmRelXml.hpp
  • DiagnosticCause : SignalTypes.hpp
  • DisconnectingMode : Types.hpp
  • DrmConstraintDefValues : DrmCore.hpp
  • DrmMimeType : DrmCore.hpp
  • DrmOperation : DrmCore.hpp
  • DrmStatus : DrmCore.hpp
  • DrmXmlFormat : DrmRelparser.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- e -

  • EccSource : SignalTypes.hpp
  • EctCallState : SignalTypes.hpp
  • eFfsTestErr : FfsTestError.hpp
  • ElementaryFilePos : SimTkTypes.hpp
  • EmCellType : NetworkTypes.hpp
  • EmControlRetValue : NetworkTypes.hpp
  • EmEventType : NetworkTypes.hpp
  • EmlppPriorityLevel : SignalTypes.hpp
  • EmRankingStatus : NetworkTypes.hpp
  • EngineeringModeControl : NetworkTypes.hpp
  • ErrorCode : SocketTestDefines.hpp
  • EstTableIndexes : SstProvider.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- f -

  • FatError : FatTypes.hpp
  • FatFileAttribute : FatTypes.hpp
  • FatOpenMode : FatTypes.hpp
  • FdnState : NetworkTypes.hpp
  • FeatureType : LcsFeatTypes.hpp
  • ffs_error_code_type : FfsSim.hpp
  • ffs_filetype_type : FfsSim.hpp
  • ffs_open_file_mode_type : FfsSim.hpp
  • ffs_pit : FfsSim.hpp
  • ffs_user_type : FfsSim.hpp
  • FfsError : FfsTypes.hpp
  • FfsFileType : FfsTypes.hpp
  • FfsOpenMode : FfsTypes.hpp
  • FfsPit : FfsTypes.hpp
  • FfsUserType : FfsTypes.hpp
  • FmRadioSettingsColIds : FmRadioSettingsProvider.hpp
  • FmRadioStationsColIds : FmRadioStationsProvider.hpp
  • fs_device_type : FatSim.hpp
  • FsDeviceType : FatTypes.hpp
  • FtpConnectionType : FtpTypes.hpp
  • FtpDataConnectionType : FtpTypes.hpp
  • FtpServiceCommand : FtpTypes.hpp
  • FtpServiceCommandError : FtpTypes.hpp
  • FtpTransferDirection : FtpTypes.hpp
  • FtpTransferError : FtpTypes.hpp
  • FtpTransferMode : FtpTypes.hpp
  • FtpTransferStructure : FtpTypes.hpp
  • FtpTransferType : FtpTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- g -

  • GenResultCode : SimTkTypes.hpp
  • GltpConnStatus : GltpTypes.hpp
  • GprsClass : NetworkTypes.hpp
  • GsmBand : NetworkTypes.hpp
  • GsmErrorCause : SignalTypes.hpp
  • GsmService : NetworkTypes.hpp
  • GsmSignal : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- h -

  • HandlerId : HandlerId.hpp
  • HoldIndicator : SignalTypes.hpp
  • HomezoneIndicator : NetworkTypes.hpp
  • HttpResponseCode : HttpTypes.hpp
  • HttpServiceCommand : HttpTypes.hpp
  • HttpServiceCommandError : HttpTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- i -

  • InputActionType : InputAction.hpp
  • InterrogateSsChoice : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- p -

  • PbRequestBehaviour : SignalTypes.hpp
  • PchOrigin : PdpTypes.hpp
  • PdpType : PdpTypes.hpp
  • PhoneBookCntType : SignalTypes.hpp
  • PhoneBookType : SignalTypes.hpp
  • PhoneNoType : PbTypes.hpp
  • PlmnForbiddenIndicator : NetworkTypes.hpp
  • PlmnIndicator : NetworkTypes.hpp
  • PlmnScanMode : NetworkTypes.hpp
  • PlmnUpdateType : SignalTypes.hpp
  • PowerMode : SignalTypes.hpp
  • PowerSavingMode : NetworkTypes.hpp
  • ProactiveCause : SimTkTypes.hpp
  • ProcessSource : NetworkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- r -

  • RadioAccessTechnology : NetworkTypes.hpp
  • RamError : RamTypes.hpp
  • RamFileAttribute : RamTypes.hpp
  • RamOpenMode : RamTypes.hpp
  • Rat : NetworkTypes.hpp
  • RatChangeMode : NetworkTypes.hpp
  • RdnChoice : SignalTypes.hpp
  • RegChangeType : RegistryTypes.hpp
  • RegDataFormat : RegistryTypes.hpp
  • RegFileType : RegDefines.hpp
  • RegisterMode : NetworkTypes.hpp
  • RegisterRejectCause : NetworkTypes.hpp
  • RegisterStatus : NetworkTypes.hpp
  • RegPayloadType : RegNodeFile.hpp
  • RegResult : RegistryTypes.hpp
  • RegState : NetworkTypes.hpp
  • RemotePartyActionArg : MsgArgs.hpp
  • RepaintHint : Grid.hpp
  • RespTimeCategory : LcsTypes.hpp
  • RrCellReselReason : NetworkTypes.hpp
  • RrMode : NetworkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- s -

  • ScrollBehavior : ScrollBehavior.hpp
  • SecLockAction : LockTypes.hpp
  • SecLockCause : LockTypes.hpp
  • SecLockResult : LockTypes.hpp
  • SecLockStatus : LockTypes.hpp
  • SecLockType : LockTypes.hpp
  • SelectionMode : Grid.hpp
  • ServedCallApplication : SignalTypes.hpp
  • ServiceGroup : SignalTypes.hpp
  • SiBearerType : SimTkTypes.hpp
  • SiChannelChangedState : SimTkTypes.hpp
  • SiChannelCloseCause : SimTkTypes.hpp
  • SiClientFlags : SimTkTypes.hpp
  • SignalQualityMax : SignalTypes.hpp
  • SignalStrengthMax : SignalTypes.hpp
  • SimCallControlResult : SignalTypes.hpp
  • SimCardType : SignalTypes.hpp
  • SimFileType : SignalTypes.hpp
  • SimImageCodingScheme : ImageData.hpp
  • SimImageRequestType : ImageData.hpp
  • SimIndicator : SignalTypes.hpp
  • SimInitResult : SignalTypes.hpp
  • SimKey : SimTkTypes.hpp
  • SimRefreshType : SignalTypes.hpp
  • SimServiceId : SstProvider.hpp
  • SimSsType : SignalTypes.hpp
  • SimStatusCondition : Tlv.hpp
  • SimType : SignalTypes.hpp
  • SimUpdateStatus : SignalTypes.hpp
  • SiSendDataType : SimTkTypes.hpp
  • SiTransportLayer : SimTkTypes.hpp
  • SmsDeleteStatus : SimPduHandler.hpp
  • SmsFilterType : SimPduHandler.hpp
  • SmsMoreMessageType : SignalTypes.hpp
  • SmsTextItemType : SmsTextParser.hpp
  • SocketControlMsgType : SocketTypes.hpp
  • SocketError : SocketTypes.hpp
  • SsApiRc : Types.hpp
  • SsInd : SignalTypes.hpp
  • SsOperationCode : SignalTypes.hpp
  • SstTableIndexes : SstProvider.hpp
  • StopRetCode : HostAudioDriver.hpp
  • SyncMLChangeType : SyncMLManager.hpp
  • SyncMLSyncType : DBService.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- t -

  • testMessageType : SocketTestT.hpp
  • Toc : Tlv.hpp
  • TpduCountType : SimPduHandler.hpp
  • TtyMode : Types.hpp
  • TtySpeed : Types.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- u -

  • UartBaudRate : LcsTypes.hpp
  • UartDataBits : LcsTypes.hpp
  • UartFlowControl : LcsTypes.hpp
  • UartParity : LcsTypes.hpp
  • UartStopBits : LcsTypes.hpp
  • UserCause : NetworkTypes.hpp
  • UsimLangFileType : SignalTypes.hpp
  • UsimPbAddType : UsimPbTypes.hpp
  • UsimPbLinkType : UsimPbTypes.hpp
  • UsimPbLocation : UsimPbTypes.hpp
  • UsimPbRefType : UsimPbTypes.hpp
  • UsimPbResult : UsimPbTypes.hpp
  • UsimPbSignalType : UsimPbTypes.hpp
  • UsimReadType : SignalTypes.hpp
  • UsimUpdateAction : SignalTypes.hpp
  • UstTableIndexes : SstProvider.hpp
  • UusInTextType : SignalTypes.hpp
  • UusOutTextType : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- v -

  • VerificationResponse : LcsDecls.hpp
  • VrErrorCode : VrTypes.hpp
  • VrProperty : VrTypes.hpp
  • VrWarningCode : VrTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- w -

  • WCBType : WCattr.hpp
  • WCType : WCattr.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- x -

  • XaocServiceState : MmTypes.hpp
  • XCallStat : MmTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- a -

  • AaemEfPos : SimTkTypes.hpp
  • Abnormal_release : NetworkTypes.hpp
  • ACAngle : BtAvrcpCommandInterface.hpp
  • ACBackward : BtAvrcpCommandInterface.hpp
  • AcceptConfirmation : MmTypes.hpp
  • Access_not_allowed : NetworkTypes.hpp
  • AccessInformationDiscarded : SignalTypes.hpp
  • AccHandlerId : HandlerId.hpp
  • ACClear : BtAvrcpCommandInterface.hpp
  • ACDisplayInformation : BtAvrcpCommandInterface.hpp
  • ACDot : BtAvrcpCommandInterface.hpp
  • ACEject : BtAvrcpCommandInterface.hpp
  • ACEnter : BtAvrcpCommandInterface.hpp
  • ACF1 : BtAvrcpCommandInterface.hpp
  • ACF2 : BtAvrcpCommandInterface.hpp
  • ACF3 : BtAvrcpCommandInterface.hpp
  • ACF4 : BtAvrcpCommandInterface.hpp
  • ACF5 : BtAvrcpCommandInterface.hpp
  • ACFastForward : BtAvrcpCommandInterface.hpp
  • ACForward : BtAvrcpCommandInterface.hpp
  • ACHelp : BtAvrcpCommandInterface.hpp
  • ACInputSelect : BtAvrcpCommandInterface.hpp
  • ACKey0 : BtAvrcpCommandInterface.hpp
  • ACKey1 : BtAvrcpCommandInterface.hpp
  • ACKey2 : BtAvrcpCommandInterface.hpp
  • ACKey3 : BtAvrcpCommandInterface.hpp
  • ACKey4 : BtAvrcpCommandInterface.hpp
  • ACKey5 : BtAvrcpCommandInterface.hpp
  • ACKey6 : BtAvrcpCommandInterface.hpp
  • ACKey7 : BtAvrcpCommandInterface.hpp
  • ACKey8 : BtAvrcpCommandInterface.hpp
  • ACKey9 : BtAvrcpCommandInterface.hpp
  • Acm1 : SignalTypes.hpp
  • Acm2 : SignalTypes.hpp
  • AcmEfPos : SimTkTypes.hpp
  • AcmGreaterOrEqualToAcmmax : SignalTypes.hpp
  • AcmMaxEfPos : SimTkTypes.hpp
  • ACNotDefined : BtAvrcpCommandInterface.hpp
  • ACPause : BtAvrcpCommandInterface.hpp
  • ACPlay : BtAvrcpCommandInterface.hpp
  • ACPower : BtAvrcpCommandInterface.hpp
  • ACRecord : BtAvrcpCommandInterface.hpp
  • ACRewind : BtAvrcpCommandInterface.hpp
  • ACSoundSelect : BtAvrcpCommandInterface.hpp
  • ACStop : BtAvrcpCommandInterface.hpp
  • ACSubpicture : BtAvrcpCommandInterface.hpp
  • ActionInContradictionWithTheCurrentTimerState : SimTkTypes.hpp
  • ActivateCCBS : SignalTypes.hpp
  • ActiveCallDetected : Types.hpp
  • ActiveCallRequired : Types.hpp
  • ActiveClientGone : SignalTypes.hpp
  • ActiveMptyRequired : Types.hpp
  • ActiveSet : NetworkTypes.hpp
  • Adm : SignalTypes.hpp
  • AdministratorRootPublicKey : SimAuxHandler.hpp
  • AdnEfPos : SimTkTypes.hpp
  • AdnPhoneBook : SignalTypes.hpp
  • AdnPhoneBookCnt : SignalTypes.hpp
  • AesErrorNone : AesCryptInterface.hpp
  • AesGeneralError : AesCryptInterface.hpp
  • AesInvalidBlockWindow : AesCryptInterface.hpp
  • AesNoKey : AesCryptInterface.hpp
  • AidingAckReceived : GltpTypes.hpp
  • AirplaneMode : SignalTypes.hpp
  • Alerting : SignalTypes.hpp
  • AlertingOff : SignalTypes.hpp
  • AllAlternateSpeechDataCda : SignalTypes.hpp
  • AllAlternateSpeechDataCds : SignalTypes.hpp
  • AllAsynchronousServices : SignalTypes.hpp
  • AllBearerServices : SignalTypes.hpp
  • AllCallRestrictionsSs : SignalTypes.hpp
  • AllCondForwardingSs : SignalTypes.hpp
  • AllDataCdaServices : SignalTypes.hpp
  • AllDataCdsServices : SignalTypes.hpp
  • AllDataCircuitAsynchronous : SignalTypes.hpp
  • AllDataCircuitSynchronous : SignalTypes.hpp
  • AllDataPdsServices : SignalTypes.hpp
  • AllDataTeleservices : SignalTypes.hpp
  • AllFacsimileTransmissionServices : SignalTypes.hpp
  • AllForwardingSs : SignalTypes.hpp
  • AllGPRSBearerServices : SignalTypes.hpp
  • AllPadAccessCaServices : SignalTypes.hpp
  • AllPlmnSpecificBs : SignalTypes.hpp
  • AllPlmnSpecificTs : SignalTypes.hpp
  • AllServices : SignalTypes.hpp
  • AllShortMessageServices : SignalTypes.hpp
  • AllSmsFilterType : SimPduHandler.hpp
  • AllSpeechFollByDataCda : SignalTypes.hpp
  • AllSpeechFollByDataCds : SignalTypes.hpp
  • AllSpeechTransmissionServices : SignalTypes.hpp
  • AllSsServices : SignalTypes.hpp
  • AllSynchronousServices : SignalTypes.hpp
  • AllTeleservices : SignalTypes.hpp
  • AllTeleservicesExceptSms : SignalTypes.hpp
  • AllUusServices : SignalTypes.hpp
  • AllVoiceGroupCallServices : SignalTypes.hpp
  • Alw : SignalTypes.hpp
  • AmrPlayCallBack : HostAudioDriver.hpp
  • AmrRecCallBack : HostAudioDriver.hpp
  • AnswerToneOn : SignalTypes.hpp
  • Aocc : SignalTypes.hpp
  • AocCharging : SignalTypes.hpp
  • AocHandlerId : HandlerId.hpp
  • Aoci : SignalTypes.hpp
  • AocInformation : SignalTypes.hpp
  • AocRefresh : SignalTypes.hpp
  • ApoxiCommandActionType : InputAction.hpp
  • AppData : SignalTypes.hpp
  • AppDual : SignalTypes.hpp
  • AppendErr : FfsTestError.hpp
  • ApplicationError : SignalTypes.hpp
  • ApprovalSim : SignalTypes.hpp
  • ApprovalSpecialSim : SignalTypes.hpp
  • AppSpeech : SignalTypes.hpp
  • AppStkSpeech : SignalTypes.hpp
  • AppUnknown : SignalTypes.hpp
  • ARAccepted : BtAvrcpCommandInterface.hpp
  • ARImplementedStable : BtAvrcpCommandInterface.hpp
  • ARInterim : BtAvrcpCommandInterface.hpp
  • ARInTransition : BtAvrcpCommandInterface.hpp
  • ARNotImplemented : BtAvrcpCommandInterface.hpp
  • ARRejected : BtAvrcpCommandInterface.hpp
  • ARResponseChanged : BtAvrcpCommandInterface.hpp
  • assistance_data : LcsTypes.hpp
  • assisted_gps : LcsDecls.hpp
  • AtcClient : SignalTypes.hpp
  • AtcFclassNotSpeech : SignalTypes.hpp
  • AtcHandlerId : HandlerId.hpp
  • AtNotRegistered : NetworkTypes.hpp
  • AtStatusBusy : AtcTypes.hpp
  • AtStatusCommitSignal : AtcTypes.hpp
  • AtStatusError : AtcTypes.hpp
  • AtStatusNoAnswer : AtcTypes.hpp
  • AtStatusNoCarrier : AtcTypes.hpp
  • AtStatusSignalNotExpected : AtcTypes.hpp
  • AtStatusSignalNotHandled : AtcTypes.hpp
  • AtStatusSuccess : AtcTypes.hpp
  • AtStatusSuccessNoOutput : AtcTypes.hpp
  • AtStatusUnsolicitedResult : AtcTypes.hpp
  • Automatic : NetworkTypes.hpp
  • AutomaticFacsimileGroup3 : SignalTypes.hpp
  • AuxiliarySpeech : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- j -

  • JoinCallsRejected : Types.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- k -

  • keymapNone : ContextDescriptionTypes.hpp
  • keymapVKey : ContextDescriptionTypes.hpp
  • keymapVKeyFeature : ContextDescriptionTypes.hpp
  • keymapVKeyLongFeature : ContextDescriptionTypes.hpp
  • keymapVKeyVeryLongFeature : ContextDescriptionTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- l -

  • L2_l1_fail : NetworkTypes.hpp
  • L2Manuf : PdpTypes.hpp
  • L2None : PdpTypes.hpp
  • L2Null : PdpTypes.hpp
  • L2Pad : PdpTypes.hpp
  • L2Ppp : PdpTypes.hpp
  • L2X25 : PdpTypes.hpp
  • LanguageResetActionType : InputAction.hpp
  • LaNotAllowed : SignalTypes.hpp
  • LaunchBrowserBearerUnavailable : SimTkTypes.hpp
  • LaunchBrowserBrowserUnavailable : SimTkTypes.hpp
  • LaunchBrowserError : SimTkTypes.hpp
  • LaunchBrowserMeUnableToReadProvisioningData : SimTkTypes.hpp
  • lcs_delay_tolerant : LcsTypes.hpp
  • lcs_low_delay : LcsTypes.hpp
  • LcsDataMissing : LcsTypes.hpp
  • LcsFacilityNotSupported : LcsTypes.hpp
  • LcsGltpConnSetupFailure : LcsTypes.hpp
  • LcsGltpInvalidData : LcsTypes.hpp
  • LcsGltpMolrInProgress : LcsTypes.hpp
  • LcsGltpSendFailure : LcsTypes.hpp
  • LcsGltpTimeOut : LcsTypes.hpp
  • LcsInternalError : LcsTypes.hpp
  • LcsInvalidInvokation : LcsTypes.hpp
  • LcsNoError : LcsTypes.hpp
  • LcsPosMethodFailure : LcsTypes.hpp
  • LcsProviderNotAvailable : LcsTypes.hpp
  • LcsSsSubscriptionViolation : LcsTypes.hpp
  • LcsSystemFailure : LcsTypes.hpp
  • LcsTimeOut : LcsTypes.hpp
  • LcsUnexpectedDataValue : LcsTypes.hpp
  • LimitedService : NetworkTypes.hpp
  • Line1 : SignalTypes.hpp
  • Line2 : SignalTypes.hpp
  • LinearFixedFile : SignalTypes.hpp
  • Link_abortion : NetworkTypes.hpp
  • Link_estab_fail : NetworkTypes.hpp
  • LndEfPos : SimTkTypes.hpp
  • LndOverflow : SignalTypes.hpp
  • LndPhoneBook : SignalTypes.hpp
  • LndPhoneBookCnt : SignalTypes.hpp
  • location_estimate : LcsTypes.hpp
  • LocationUpdate : SignalTypes.hpp
  • LociLocAreaNotAllowed : SignalTypes.hpp
  • LociNotUpdated : SignalTypes.hpp
  • LociPlmnNotAllowed : SignalTypes.hpp
  • LociReserved : SignalTypes.hpp
  • LociUpdated : SignalTypes.hpp
  • Low : LcsTypes.hpp
  • LpEfPos : SimTkTypes.hpp
  • LST_Arc : LcsTypes.hpp
  • LST_NoLocation : LcsTypes.hpp
  • LST_Point : LcsTypes.hpp
  • LST_PointAltitudeUncertEllipsoid : LcsTypes.hpp
  • LST_PointUncertCircle : LcsTypes.hpp
  • LST_PointUncertEllipse : LcsTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- m -

  • MacFailure : SignalTypes.hpp
  • Manual : NetworkTypes.hpp
  • MAX_TRANSPORTS : LcsTypes.hpp
  • MaxCallCountExceeded : Types.hpp
  • MaxHandlerId : HandlerId.hpp
  • MaxMptyMemberCountExceeded : Types.hpp
  • MaxNoType : PbTypes.hpp
  • MaxValueReached : SignalTypes.hpp
  • MbdnPhoneBook : SignalTypes.hpp
  • MbdnPhoneBookCnt : SignalTypes.hpp
  • MbPhoneBook : AtcTypes.hpp
  • Mc : SignalTypes.hpp
  • McPhoneBook : AtcTypes.hpp
  • MdhApplicationError : MdhTypes.hpp
  • MdhEmailMessage : MdhTypes.hpp
  • MdhErrClientWasNotRegistered : MdhTypes.hpp
  • MdhErrFilterIsNotSupported : MdhTypes.hpp
  • MdhErrIndexNotCreated : MdhTypes.hpp
  • MdhErrMaxClients : MdhTypes.hpp
  • MdhErrMaxViews : MdhTypes.hpp
  • MdhErrNoEntriesFound : MdhTypes.hpp
  • MdhErrNotEnoughMemory : MdhTypes.hpp
  • MdhError : MdhTypes.hpp
  • MdhErrOutOfRange : MdhTypes.hpp
  • MdhErrOutOfView : MdhTypes.hpp
  • MdhErrParameters : MdhTypes.hpp
  • MdhErrSmsrLinkNotFound : MdhTypes.hpp
  • MdhErrSmsrNotAvailable : MdhTypes.hpp
  • MdhErrStorageMedia : MdhTypes.hpp
  • MdhErrViewNotAvailable : MdhTypes.hpp
  • MdhFaxMessage : MdhTypes.hpp
  • MdhFilterAll : MdhTypes.hpp
  • MdhFilterAllDisplay : MdhTypes.hpp
  • MdhFilterEmailWaiting : MdhTypes.hpp
  • MdhFilterFaxWaiting : MdhTypes.hpp
  • MdhFilterFree : MdhTypes.hpp
  • MdhFilterInbox : MdhTypes.hpp
  • MdhFilterOtherMsgWaiting : MdhTypes.hpp
  • MdhFilterOutbox : MdhTypes.hpp
  • MdhFilterRead : MdhTypes.hpp
  • MdhFilterSent : MdhTypes.hpp
  • MdhFilterToBeRead : MdhTypes.hpp
  • MdhFilterToBeSent : MdhTypes.hpp
  • MdhFilterUnknown : MdhTypes.hpp
  • MdhFilterUsed : MdhTypes.hpp
  • MdhFilterVoiceMsgWaiting : MdhTypes.hpp
  • MdhFirstReached : MdhTypes.hpp
  • MdhLastReached : MdhTypes.hpp
  • MdhNoCause : MdhTypes.hpp
  • MdhNofMdhWaitTypes : MdhTypes.hpp
  • MdhNoMedia : MdhTypes.hpp
  • MdhNoSmsrEf : MdhTypes.hpp
  • MdhNothingFound : MdhTypes.hpp
  • MdhNothingToProcess : MdhTypes.hpp
  • MdhOnlyNvram : MdhTypes.hpp
  • MdhOnlySim : MdhTypes.hpp
  • MdhOtherMessage : MdhTypes.hpp
  • MdhPrefferedNvram : MdhTypes.hpp
  • MdhPrefferedSim : MdhTypes.hpp
  • MdhRamBuffer : MdhTypes.hpp
  • MdhRejLastView : MdhTypes.hpp
  • MdhRejMemoryExceeded : MdhTypes.hpp
  • MdhRejSimIsFull : MdhTypes.hpp
  • MdhRejSimIsNotInView : MdhTypes.hpp
  • MdhRejSimNoSms : MdhTypes.hpp
  • MdhRejStartupInProgress : MdhTypes.hpp
  • MdhSharedMem : MdhTypes.hpp
  • MdhSharedMemory : MdhTypes.hpp
  • MdhSmBoot : MdhTypes.hpp
  • MdhSmSimReset : MdhTypes.hpp
  • MdhSmSimtkRefresh : MdhTypes.hpp
  • MdhSmsrEf : MdhTypes.hpp
  • MdhSmsrNone : MdhTypes.hpp
  • MdhSmsrNotSaved : MdhTypes.hpp
  • MdhSmStorageSimIsFree : MdhTypes.hpp
  • MdhSmUnknown : MdhTypes.hpp
  • MdhSortByDate : MdhTypes.hpp
  • MdhSortByPosition : MdhTypes.hpp
  • MdhSuccessful : MdhTypes.hpp
  • MdhUndefined : MdhTypes.hpp
  • MdhVoiceMail2Message : MdhTypes.hpp
  • MdhVoiceMailMessage : MdhTypes.hpp
  • MdhWaitLevel1 : MdhTypes.hpp
  • MdhWaitLevel2 : MdhTypes.hpp
  • MdhWaitLevel3 : MdhTypes.hpp
  • MdhWaitLevelClient : MdhTypes.hpp
  • MdhWaitLevelCphs : MdhTypes.hpp
  • MdhWaitNoLevel : MdhTypes.hpp
  • MdhWaitSetActive : MdhTypes.hpp
  • MdhWaitSetInactive : MdhTypes.hpp
  • MdhWaitSetUnknown : MdhTypes.hpp
  • MdhWaitSmsDiscard : MdhTypes.hpp
  • MdhWaitSmsStore : MdhTypes.hpp
  • MdhWaitSmsUnknown : MdhTypes.hpp
  • MdhWarnMemoryExceeded : MdhTypes.hpp
  • MdhWarnSmStorageSimIsFull : MdhTypes.hpp
  • MdPhoneBook : AtcTypes.hpp
  • MeasurementDataSent : GltpTypes.hpp
  • MeCurrentlyUnableAccessControlClassBar : SimTkTypes.hpp
  • MeCurrentlyUnableBusyOnSendDtmfCommand : SimTkTypes.hpp
  • MeCurrentlyUnableBusyOnSsTransaction : SimTkTypes.hpp
  • MeCurrentlyUnableBusyOnUssdTransaction : SimTkTypes.hpp
  • MeCurrentlyUnableNoService : SimTkTypes.hpp
  • MeCurrentlyUnableNotInSpeechCall : SimTkTypes.hpp
  • MeCurrentlyUnableRadioResourceNotGranted : SimTkTypes.hpp
  • MemoryError : SignalTypes.hpp
  • MemoryExceeded : SignalTypes.hpp
  • MePbInvalidIndex : AtcTypes.hpp
  • MePbNotPresent : AtcTypes.hpp
  • MePbSuccessfull : AtcTypes.hpp
  • MePbUnsuccessfull : AtcTypes.hpp
  • MePhoneBook : AtcTypes.hpp
  • MmCall : SignalTypes.hpp
  • MmCallDisconnected : MmTypes.hpp
  • MmCallDisconnectedByNetwork : MmTypes.hpp
  • MmCallDisconnectedByUser : MmTypes.hpp
  • MmCallDisconnecting : MmTypes.hpp
  • MmCallDisconnectingByNetwork : MmTypes.hpp
  • MmCallDisconnectingByUser : MmTypes.hpp
  • MmCallOnHold : MmTypes.hpp
  • MmCallProgressIndication : MmTypes.hpp
  • MmCallReleased : MmTypes.hpp
  • MmiClient : SignalTypes.hpp
  • MmiNotRegistered : SignalTypes.hpp
  • MmiSimBacklightStateId : MmiSimProtocol.hpp
  • MmiSimCharId : MmiSimProtocol.hpp
  • MmiSimDisplayUpdateDataId : MmiSimProtocol.hpp
  • MmiSimDisplayUpdateHeaderId : MmiSimProtocol.hpp
  • MmiSimKeyDownId : MmiSimProtocol.hpp
  • MmiSimKeyUpId : MmiSimProtocol.hpp
  • MmiSimLedStateId : MmiSimProtocol.hpp
  • MmiSimPenDownId : MmiSimProtocol.hpp
  • MmiSimPenMoveId : MmiSimProtocol.hpp
  • MmiSimPenUpId : MmiSimProtocol.hpp
  • MmiSimVibrationStateId : MmiSimProtocol.hpp
  • MmMocInSetup : MmTypes.hpp
  • MmMocSetupAccept : MmTypes.hpp
  • MmRrcCellBarred : NetworkTypes.hpp
  • MmRrcCongestion : NetworkTypes.hpp
  • MmRrcConnEstablished : NetworkTypes.hpp
  • MmRrcConnRelease : NetworkTypes.hpp
  • MmRrcDirectedSigconnReEstablishment : NetworkTypes.hpp
  • MmRrcInterratHandover : NetworkTypes.hpp
  • MmRrcnactive : NetworkTypes.hpp
  • MmRrcNoCause : NetworkTypes.hpp
  • MmRrcNormalEvent : NetworkTypes.hpp
  • MmRrcPreEmtiveRelease : NetworkTypes.hpp
  • MmRrcReEstablishmentReject : NetworkTypes.hpp
  • MmRrcUserInactivity : NetworkTypes.hpp
  • Mobil : PbTypes.hpp
  • MocActive : SignalTypes.hpp
  • MocAlerted : SignalTypes.hpp
  • MoCallActionType : InputAction.hpp
  • MocAsCallSetup : SignalTypes.hpp
  • MocChangedToSupplementaryService : Types.hpp
  • MocChangedToUssd : Types.hpp
  • MocSetup : SignalTypes.hpp
  • MocSetupRejMissingAcmInfoInd : SignalTypes.hpp
  • MocStarted : SignalTypes.hpp
  • MocVoiceHandlerId : HandlerId.hpp
  • MolrTimer : LcsTimer.hpp
  • Monitored : NetworkTypes.hpp
  • MonReselServCellNotSuitable : NetworkTypes.hpp
  • MoUssdHandlerId : HandlerId.hpp
  • MovedDownRepaintHint : Grid.hpp
  • MovedLeftRepaintHint : Grid.hpp
  • MovedRightRepaintHint : Grid.hpp
  • MovedUpRepaintHint : Grid.hpp
  • Mp3PlayCallBack : HostAudioDriver.hpp
  • Mp3RetCode : HostAudioDriver.hpp
  • MpartySplitStarted : SignalTypes.hpp
  • MptyCallDetected : Types.hpp
  • MptyCallRequired : Types.hpp
  • MptyHeldRejected : SignalTypes.hpp
  • MptyHeldStarted : SignalTypes.hpp
  • MptyIsActive : SignalTypes.hpp
  • MptyIsHeld : SignalTypes.hpp
  • MptyIsRetrieved : SignalTypes.hpp
  • MptyIsSplitted : SignalTypes.hpp
  • MptyRejected : SignalTypes.hpp
  • MptyRetrievedStarted : SignalTypes.hpp
  • MptyRetrieveRejected : SignalTypes.hpp
  • MptySplitRejected : SignalTypes.hpp
  • MptyStarted : SignalTypes.hpp
  • ms_assisted_eotd : LcsDecls.hpp
  • ms_based_eotd : LcsDecls.hpp
  • MsAccessClassBarred : SignalTypes.hpp
  • MscNotReachable : SignalTypes.hpp
  • MsFailureUnspecified : SignalTypes.hpp
  • MsgNotCompatible : SignalTypes.hpp
  • MsgtypNotCompatible : SignalTypes.hpp
  • MsgtypNotExists : SignalTypes.hpp
  • MsIdentUnknown : SignalTypes.hpp
  • MsisdnEfPos : SimTkTypes.hpp
  • MsisdnPhoneBook : SignalTypes.hpp
  • MsisdnPhoneBookCnt : SignalTypes.hpp
  • MsNoResource : SignalTypes.hpp
  • MsNoService : SignalTypes.hpp
  • Msp : SignalTypes.hpp
  • MsPhoneBook : AtcTypes.hpp
  • MsServiceBusy : SignalTypes.hpp
  • MSUAudio : BtAvrcpPanelService.hpp
  • MSUBtAstUnit : BtAvrcpPanelService.hpp
  • MSUBulletinBoard : BtAvrcpPanelService.hpp
  • MSUCa : BtAvrcpPanelService.hpp
  • MSUCamera : BtAvrcpPanelService.hpp
  • MSUCameraStorage : BtAvrcpPanelService.hpp
  • MSUDisc : BtAvrcpPanelService.hpp
  • MSUMonitor : BtAvrcpPanelService.hpp
  • MSUPanel : BtAvrcpPanelService.hpp
  • MSUPrinter : BtAvrcpPanelService.hpp
  • MSUTapeRecPlayer : BtAvrcpPanelService.hpp
  • MSUTuner : BtAvrcpPanelService.hpp
  • MSUVendorUnique : BtAvrcpPanelService.hpp
  • MtcAccepted : SignalTypes.hpp
  • MtcActive : SignalTypes.hpp
  • MtcArrived : MmTypes.hpp
  • MtcAsCallSetup : SignalTypes.hpp
  • MtcBcNegotiated : SignalTypes.hpp
  • MtcConfirmed : SignalTypes.hpp
  • MtcReady : MmTypes.hpp
  • MtcRejected : SignalTypes.hpp
  • MtcSetup : SignalTypes.hpp
  • MtcStarted : SignalTypes.hpp
  • MtcVoiceHandlerId : HandlerId.hpp
  • MtlrTimer : LcsTimer.hpp
  • MultiParty : SignalTypes.hpp
  • MultipleCardCommandsError : SimTkTypes.hpp
  • MultipleCardCommandsErrorCApduFormatError : SimTkTypes.hpp
  • MultipleCardCommandsErrorCardPoweredOff : SimTkTypes.hpp
  • MultipleCardCommandsErrorCardReaderBusy : SimTkTypes.hpp
  • MultipleCardCommandsErrorCardReaderRemovedOrNotPresent : SimTkTypes.hpp
  • MultipleCardCommandsErrorCardRemovedOrNotPresent : SimTkTypes.hpp
  • MultipleCardCommandsErrorMuteCard : SimTkTypes.hpp
  • MultipleCardCommandsErrorProtocolNotSupported : SimTkTypes.hpp
  • MultipleCardCommandsErrorSpecifiedReaderNotValid : SimTkTypes.hpp
  • MultipleCardCommandsErrorTransmissionError : SimTkTypes.hpp
  • MultiSlotHandlerId : HandlerId.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- n -

  • NaiCloseChannel : Tlv.hpp
  • NaiDisplayText : Tlv.hpp
  • NaiEndOfProactiveSession : Tlv.hpp
  • NaiGetChannelStatus : Tlv.hpp
  • NaiGetInkey : Tlv.hpp
  • NaiGetInput : Tlv.hpp
  • NaiGetReaderStatus : Tlv.hpp
  • NaiInvalid : Tlv.hpp
  • NaiLaunchBrowser : Tlv.hpp
  • NaiOpenChannel : Tlv.hpp
  • NaiPerformCardApdu : Tlv.hpp
  • NaiPlayTone : Tlv.hpp
  • NaiPowerOffCard : Tlv.hpp
  • NaiPowerOnCard : Tlv.hpp
  • NaiProvideLocalInformation : Tlv.hpp
  • NaiReceiveData : Tlv.hpp
  • NaiSelectItem : Tlv.hpp
  • NaiSendData : Tlv.hpp
  • NaiSendShortMessage : Tlv.hpp
  • NaiSendSs : Tlv.hpp
  • NaiSendUssd : Tlv.hpp
  • NaiSetupCall : Tlv.hpp
  • NaiSetupIdleModeText : Tlv.hpp
  • NaiSetupMenu : Tlv.hpp
  • NamePresentationAllowed : SignalTypes.hpp
  • NamePresentationRestricted : SignalTypes.hpp
  • NameUnavailable : SignalTypes.hpp
  • NatRoamingNotAllowed : SignalTypes.hpp
  • Needed : SignalTypes.hpp
  • NegativeAckTone : SignalTypes.hpp
  • NetworkCurrentlyUnableToProcessCommand : SimTkTypes.hpp
  • NetWorkDisconnection : Types.hpp
  • NetworkFailure : SignalTypes.hpp
  • NetworkHandlerId : HandlerId.hpp
  • NetworkOutOfOrder : SignalTypes.hpp
  • Nev : SignalTypes.hpp
  • NiaEfPos : SimTkTypes.hpp
  • No_carrier : NetworkTypes.hpp
  • No_cause : NetworkTypes.hpp
  • No_cell : NetworkTypes.hpp
  • NoAoc : SignalTypes.hpp
  • NoAppropriateDtmfEntry : SignalTypes.hpp
  • NoCallError : SignalTypes.hpp
  • NoCard : SignalTypes.hpp
  • NoCircuitAvailable : SignalTypes.hpp
  • NoClient : SignalTypes.hpp
  • NoCug : SignalTypes.hpp
  • NoCugSelected : SignalTypes.hpp
  • NoDataCall : SignalTypes.hpp
  • NoError : Types.hpp
  • NoGprsCell : NetworkTypes.hpp
  • NoHighlightningBehaviour : Grid.hpp
  • None : LcsTypes.hpp
  • NoNetwork : Types.hpp
  • NonExistent : LcsReqProcessor.hpp
  • NonSelectedUserClearing : SignalTypes.hpp
  • NoOfCountTypes : SimPduHandler.hpp
  • NoOperation : SignalTypes.hpp
  • NoPdpContextActive : SignalTypes.hpp
  • NoProgress : SignalTypes.hpp
  • NoRepaintHint : Grid.hpp
  • NoResponse : SimTkTypes.hpp
  • NoResponseFromUser : LcsDecls.hpp
  • NormalCallClear : SignalTypes.hpp
  • NormalOnMode : SignalTypes.hpp
  • NormalSearchMode : NetworkTypes.hpp
  • NormalService : NetworkTypes.hpp
  • NormalServiceRequired : Types.hpp
  • NormalSim : SignalTypes.hpp
  • NormalSms : SimPduHandler.hpp
  • NormalSpecialSim : SignalTypes.hpp
  • NormalUnspecified : SignalTypes.hpp
  • NoRoute : SignalTypes.hpp
  • NoSelectionBehaviour : Grid.hpp
  • NoService : NetworkTypes.hpp
  • NoSsCode : SignalTypes.hpp
  • NoSuitableCellsInLa : SignalTypes.hpp
  • NotActivated : SignalTypes.hpp
  • NotAvailable : SignalTypes.hpp
  • NoTextNoIcon : NetworkTypes.hpp
  • NoTextWithIcon : NetworkTypes.hpp
  • Notify : LcsTypes.hpp
  • NotInSpeechCall : SignalTypes.hpp
  • NotMeasured : NetworkTypes.hpp
  • NotNeeded : SignalTypes.hpp
  • NotSpecified : Types.hpp
  • NotSpeech : SignalTypes.hpp
  • NotSupported : Types.hpp
  • NoType : PbTypes.hpp
  • NoUserResponding : SignalTypes.hpp
  • NumberChanged : SignalTypes.hpp
  • NumberOfEfPos : SimTkTypes.hpp
  • NumberType : DataItem.hpp
  • NvramTpdus : SimPduHandler.hpp
  • NwFailureUnspecified : SignalTypes.hpp
  • NwOpMode1 : NetworkTypes.hpp
  • NwOpMode2 : NetworkTypes.hpp
  • NwOpMode3 : NetworkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- o -

  • ObexAppMsgTransportSelectionReq : ObexTypes.hpp
  • ObexMsgAbort : ObexTypes.hpp
  • ObexMsgBuffer : ObexTypes.hpp
  • ObexMsgConnect : ObexTypes.hpp
  • ObexMsgDisconnect : ObexTypes.hpp
  • ObexMsgGet : ObexTypes.hpp
  • ObexMsgPut : ObexTypes.hpp
  • ObexMsgResponse : ObexTypes.hpp
  • ObexMsgResult : ObexTypes.hpp
  • ObexMsgSetPath : ObexTypes.hpp
  • ObexPrIdObex : ObexTypes.hpp
  • ObexPrIdOpp : ObexTypes.hpp
  • ObexTrAvStateChanged : ObexTypes.hpp
  • ObexTrEnableRejected : ObexTypes.hpp
  • ObexTrSelectionResult : ObexTypes.hpp
  • ODyn2EfPos : SimTkTypes.hpp
  • ODynEfPos : SimTkTypes.hpp
  • OffHookToneOn : SignalTypes.hpp
  • Office : PbTypes.hpp
  • OJcEfPos : SimTkTypes.hpp
  • OneStopBit : LcsTypes.hpp
  • OneWaySyncFromClient : DBService.hpp
  • OneWaySyncFromServer : DBService.hpp
  • Ongoing : LcsReqProcessor.hpp
  • OnlyError : SignalTypes.hpp
  • OnlyRestrictedDigital : SignalTypes.hpp
  • OParamEfPos : SimTkTypes.hpp
  • OpenErr : FfsTestError.hpp
  • OperatorBarring : SignalTypes.hpp
  • OperatorRootPublicKey : SimAuxHandler.hpp
  • OplmnWactEfPos : SimTkTypes.hpp
  • OSct2EfPos : SimTkTypes.hpp
  • Other : SignalTypes.hpp
  • OutgCallsBarredWithCug : SignalTypes.hpp
  • OutgoingRefuseDirection : SignalTypes.hpp
  • OutofMemory : SignalTypes.hpp
  • OverallTpdus : SimPduHandler.hpp
  • OverrideDisabled : SignalTypes.hpp
  • OverrideEnabled : SignalTypes.hpp
  • OZon1EfPos : SimTkTypes.hpp
  • OZon2EfPos : SimTkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- b -

  • BaAoVendorUnique : BtTypes.hpp
  • BackwardMove : SimTkTypes.hpp
  • Baic : SignalTypes.hpp
  • Baoc : SignalTypes.hpp
  • BarringOfIncomingCalls : SignalTypes.hpp
  • BarringOfOutgoingCalls : SignalTypes.hpp
  • BarringSsActionType : InputAction.hpp
  • BdnEfPos : SimTkTypes.hpp
  • BdnFailed : SignalTypes.hpp
  • BdnNotPossible : NetworkTypes.hpp
  • BdnOff : NetworkTypes.hpp
  • BdnOn : NetworkTypes.hpp
  • BdnPhoneBook : SignalTypes.hpp
  • BdnPhoneBookCnt : SignalTypes.hpp
  • BdPhoneBook : AtcTypes.hpp
  • BearerCapabilityNotAllowed : SignalTypes.hpp
  • BearerCapabilityNotAvailable : SignalTypes.hpp
  • BearerChange : SignalTypes.hpp
  • BearerIndependentProtocolError : SimTkTypes.hpp
  • BearerIndependentProtocolErrorChannelClosed : SimTkTypes.hpp
  • BearerIndependentProtocolErrorChannelIdentifierNotValid : SimTkTypes.hpp
  • BearerIndependentProtocolErrorNoChannelAvailable : SimTkTypes.hpp
  • BearerIndependentProtocolErrorRequestedBufferSizeNotAvailable : SimTkTypes.hpp
  • BearerService : SignalTypes.hpp
  • BearerServiceNotImplemented : SignalTypes.hpp
  • BicRoam : SignalTypes.hpp
  • BipCallError : BtBipTypes.hpp
  • BipContinue : BtBipTypes.hpp
  • BipImagePull : BtBipTypes.hpp
  • BipImagePush : BtBipTypes.hpp
  • BipInvalidSessionId : BtBipTypes.hpp
  • BipObexFailed : BtBipTypes.hpp
  • BipOk : BtBipTypes.hpp
  • BipPadaptFailed : BtBipTypes.hpp
  • BipPartialContent : BtBipTypes.hpp
  • BipSdapFailed : BtBipTypes.hpp
  • BlacklistFullNoAutoCallAttempts : SignalTypes.hpp
  • Blocked : SignalTypes.hpp
  • BlockScrollBehavior : ScrollBehavior.hpp
  • BlockScrollBehaviour : Grid.hpp
  • Boic : SignalTypes.hpp
  • BoicExHc : SignalTypes.hpp
  • BooleanType : DataItem.hpp
  • BootFinishedNotification : Types.hpp
  • BootHandlerId : HandlerId.hpp
  • BootLoadNotification : Types.hpp
  • BootNoRequest : Types.hpp
  • BootNotAvailable : Types.hpp
  • BottomReachedRepaintHint : Grid.hpp
  • BppCallError : BtBppTypes.hpp
  • BppContinue : BtBppTypes.hpp
  • BppObexBadRequest : BtBppTypes.hpp
  • BppObexContinue : BtBppTypes.hpp
  • BppObexFailed : BtBppTypes.hpp
  • BppObexForbidden : BtBppTypes.hpp
  • BppObexHeaderFailed : BtBppTypes.hpp
  • BppObexNotAcceptable : BtBppTypes.hpp
  • BppObexNotFound : BtBppTypes.hpp
  • BppObexNotImplemented : BtBppTypes.hpp
  • BppObexOk : BtBppTypes.hpp
  • BppObexPartialContent : BtBppTypes.hpp
  • BppObexPreconditionFailed : BtBppTypes.hpp
  • BppObexServiceUnavailable : BtBppTypes.hpp
  • BppObexUnauthorised : BtBppTypes.hpp
  • BppObexUndefined : BtBppTypes.hpp
  • BppOk : BtBppTypes.hpp
  • BppPadaptFailed : BtBppTypes.hpp
  • BppSdapFailed : BtBppTypes.hpp
  • BppUnauthenticated : BtBppTypes.hpp
  • BtAcCategory1 : BtTypes.hpp
  • BtAcCategory2 : BtTypes.hpp
  • BtAcCategory3 : BtTypes.hpp
  • BtAcCategory4 : BtTypes.hpp
  • BtAcConnect : BtTypes.hpp
  • BtAcDisconnect : BtTypes.hpp
  • BtAcNotCongested : BtTypes.hpp
  • BtActControl : BtTypes.hpp
  • BtActGeneralInquiry : BtTypes.hpp
  • BtActNotify : BtTypes.hpp
  • BtActSpecificInquiry : BtTypes.hpp
  • BtActStatus : BtTypes.hpp
  • BtAo0 : BtTypes.hpp
  • BtAo1 : BtTypes.hpp
  • BtAo2 : BtTypes.hpp
  • BtAo3 : BtTypes.hpp
  • BtAo4 : BtTypes.hpp
  • BtAo5 : BtTypes.hpp
  • BtAo6 : BtTypes.hpp
  • BtAo7 : BtTypes.hpp
  • BtAo8 : BtTypes.hpp
  • BtAo9 : BtTypes.hpp
  • BtAoAngle : BtTypes.hpp
  • BtAoBackward : BtTypes.hpp
  • BtAoChannelDown : BtTypes.hpp
  • BtAoChannelUp : BtTypes.hpp
  • BtAoClear : BtTypes.hpp
  • BtAoContentsMenu : BtTypes.hpp
  • BtAocPanelPassThrough : BtTypes.hpp
  • BtAocSubunitInfo : BtTypes.hpp
  • BtAocUnitInfo : BtTypes.hpp
  • BtAocVendorDependent : BtTypes.hpp
  • BtAoDisplayInfo : BtTypes.hpp
  • BtAoDot : BtTypes.hpp
  • BtAoDown : BtTypes.hpp
  • BtAoEject : BtTypes.hpp
  • BtAoEnter : BtTypes.hpp
  • BtAoExit : BtTypes.hpp
  • BtAoF1 : BtTypes.hpp
  • BtAoF2 : BtTypes.hpp
  • BtAoF3 : BtTypes.hpp
  • BtAoF4 : BtTypes.hpp
  • BtAoF5 : BtTypes.hpp
  • BtAoFastForward : BtTypes.hpp
  • BtAoFavouriteMenu : BtTypes.hpp
  • BtAoForward : BtTypes.hpp
  • BtAoHelp : BtTypes.hpp
  • BtAoInputSelect : BtTypes.hpp
  • BtAoLeft : BtTypes.hpp
  • BtAoLeftUp : BtTypes.hpp
  • BtAoMute : BtTypes.hpp
  • BtAoNotDefined : BtTypes.hpp
  • BtAoPageDown : BtTypes.hpp
  • BtAoPageUp : BtTypes.hpp
  • BtAoPause : BtTypes.hpp
  • BtAoPlay : BtTypes.hpp
  • BtAoPower : BtTypes.hpp
  • BtAoPrevChannel : BtTypes.hpp
  • BtAoRecord : BtTypes.hpp
  • BtAoRewind : BtTypes.hpp
  • BtAoRight : BtTypes.hpp
  • BtAoRightDown : BtTypes.hpp
  • BtAoRightUp : BtTypes.hpp
  • BtAoRootMenu : BtTypes.hpp
  • BtAoSelect : BtTypes.hpp
  • BtAoSetupMenu : BtTypes.hpp
  • BtAoSoundSelect : BtTypes.hpp
  • BtAoStop : BtTypes.hpp
  • BtAoSubpicture : BtTypes.hpp
  • BtAoUp : BtTypes.hpp
  • BtAoVolumeDown : BtTypes.hpp
  • BtAoVolumeUp : BtTypes.hpp
  • BtApLeftDown : BtTypes.hpp
  • BtArAccepted : BtTypes.hpp
  • BtArImplementedStable : BtTypes.hpp
  • BtArInterim : BtTypes.hpp
  • BtArInTransition : BtTypes.hpp
  • BtArNotDefined : BtTypes.hpp
  • BtArNotImplemented : BtTypes.hpp
  • BtAroleController : BtTypes.hpp
  • BtAroleTarget : BtTypes.hpp
  • BtArRejected : BtTypes.hpp
  • BtArResponseChanged : BtTypes.hpp
  • BtAsfButtonPress : BtTypes.hpp
  • BtAsfButtonRelease : BtTypes.hpp
  • BtAstAudio : BtTypes.hpp
  • BtAstBulletinBoard : BtTypes.hpp
  • BtAstCa : BtTypes.hpp
  • BtAstCamera : BtTypes.hpp
  • BtAstCameraStorage : BtTypes.hpp
  • BtAstDisc : BtTypes.hpp
  • BtAstMonitor : BtTypes.hpp
  • BtAstPanel : BtTypes.hpp
  • BtAstPrinter : BtTypes.hpp
  • BtAstTapeRecPlayer : BtTypes.hpp
  • BtAstTuner : BtTypes.hpp
  • BtAstUnit : BtTypes.hpp
  • BtAstVendorUnique : BtTypes.hpp
  • BtBipBmp : BtBipTypes.hpp
  • BtBipCrop : BtBipTypes.hpp
  • BtBipFill : BtBipTypes.hpp
  • BtBipGif : BtBipTypes.hpp
  • BtBipInvalidEncoding : BtBipTypes.hpp
  • BtBipInvalidTransformation : BtBipTypes.hpp
  • BtBipJpeg : BtBipTypes.hpp
  • BtBipJpeg2000 : BtBipTypes.hpp
  • BtBipNone : BtBipTypes.hpp
  • BtBipPng : BtBipTypes.hpp
  • BtBipStretch : BtBipTypes.hpp
  • BtBipWBmp : BtBipTypes.hpp
  • BtCmConnectable : BtTypes.hpp
  • BtCmNonConnectable : BtTypes.hpp
  • BtCtBmscr : BtTypes.hpp
  • BtCtBmu : BtTypes.hpp
  • BtDetBool : BtTypes.hpp
  • BtDetEnumeration : BtTypes.hpp
  • BtDetNil : BtTypes.hpp
  • BtDetSequence : BtTypes.hpp
  • BtDetSint : BtTypes.hpp
  • BtDetString : BtTypes.hpp
  • BtDetUint : BtTypes.hpp
  • BtDetUrl : BtTypes.hpp
  • BtDetUuid : BtTypes.hpp
  • BtDmGeneralDiscoverable : BtTypes.hpp
  • BtDmLimitedDiscoverable : BtTypes.hpp
  • BtDmNonDiscoverable : BtTypes.hpp
  • BtDrConnected : BtTypes.hpp
  • BtDrNone : BtTypes.hpp
  • BtDrTrusted : BtTypes.hpp
  • BtDrTrustedAndConnected : BtTypes.hpp
  • BtDsConnected : BtTypes.hpp
  • BtDsKnown : BtTypes.hpp
  • BtDsPaired : BtTypes.hpp
  • BtDsTrusted : BtTypes.hpp
  • BtHfCe : BtTypes.hpp
  • BtHfClCallOnAccessory : BtTypes.hpp
  • BtHfClCallOnPhone : BtTypes.hpp
  • BtHfClNoCall : BtTypes.hpp
  • BtHfsAudioActive : BtTypes.hpp
  • BtHfsAvailableForAudio : BtTypes.hpp
  • BtHfsConnected : BtTypes.hpp
  • BtHfsNotConnected : BtTypes.hpp
  • BtHsCeCallOnHeadset : BtTypes.hpp
  • BtHsCeCallOnPhone : BtTypes.hpp
  • BtHsCeCallRelease : BtTypes.hpp
  • BtHsCeHangUp : BtTypes.hpp
  • BtHsClCallOnAccessory : BtTypes.hpp
  • BtHsClCallOnPhone : BtTypes.hpp
  • BtHsClNoCall : BtTypes.hpp
  • BtHssAudioActive : BtTypes.hpp
  • BtHssAvailableForAudio : BtTypes.hpp
  • BtHssConnected : BtTypes.hpp
  • BtHssNotConnected : BtTypes.hpp
  • BtIacGlobal : BtTypes.hpp
  • BtIacLocal : BtTypes.hpp
  • BtOecBusy : BtTypes.hpp
  • BtOecConnected : BtTypes.hpp
  • BtOecHandleUnknown : BtTypes.hpp
  • BtOecNotConnected : BtTypes.hpp
  • BtOecOperationNotAllowed : BtTypes.hpp
  • BtOhtByteSequence : BtTypes.hpp
  • BtOhtByteValue : BtTypes.hpp
  • BtOhtDWordValue : BtTypes.hpp
  • BtOhtUnicodeString : BtTypes.hpp
  • BtOocAbort : BtTypes.hpp
  • BtOocConnect : BtTypes.hpp
  • BtOocDisconnect : BtTypes.hpp
  • BtOocGet : BtTypes.hpp
  • BtOocPut : BtTypes.hpp
  • BtOocSetPath : BtTypes.hpp
  • BtOpPerformServiceVerify : BtTypes.hpp
  • BtOpSelectDevice : BtTypes.hpp
  • BtOpSelectDeviceAndPerformServiceVerify : BtTypes.hpp
  • BtPmNonPairable : BtTypes.hpp
  • BtPmPairable : BtTypes.hpp
  • BtProfileA2dp : BtTypes.hpp
  • BtProfileAad : BtTypes.hpp
  • BtProfileAvrcp : BtTypes.hpp
  • BtProfileBip : BtTypes.hpp
  • BtProfileBpp : BtTypes.hpp
  • BtProfileDun : BtTypes.hpp
  • BtProfileFax : BtTypes.hpp
  • BtProfileFtp : BtTypes.hpp
  • BtProfileGapAndSdap : BtTypes.hpp
  • BtProfileHf : BtTypes.hpp
  • BtProfileHs : BtTypes.hpp
  • BtProfileObex : BtTypes.hpp
  • BtProfileOpp : BtTypes.hpp
  • BtProfilePap : BtTypes.hpp
  • BtProfileSap : BtTypes.hpp
  • BtProfileUnknown : BtTypes.hpp
  • BtRcAccepted : BtTypes.hpp
  • BtRcError : BtTypes.hpp
  • BtRcIgnored : BtTypes.hpp
  • BtRcOk : BtTypes.hpp
  • BtRcPending : BtTypes.hpp
  • BtRcRejected : BtTypes.hpp
  • BtRcUnknown : BtTypes.hpp
  • BtRqsAccepted : BtTypes.hpp
  • BtRqsAcceptedCancelation : BtTypes.hpp
  • BtRqsExecuting : BtTypes.hpp
  • BtRqsExecutingCancelation : BtTypes.hpp
  • BtRqsFinishedFailure : BtTypes.hpp
  • BtRqsFinishedOk : BtTypes.hpp
  • BtRqsIgnored : BtTypes.hpp
  • BtRqsInitialized : BtTypes.hpp
  • BtRqsRejected : BtTypes.hpp
  • BtRqsUnknown : BtTypes.hpp
  • BtRqtAvrcpConnect : BtTypes.hpp
  • BtRqtAvrcpConnectRsp : BtTypes.hpp
  • BtRqtAvrcpDeRegister : BtTypes.hpp
  • BtRqtAvrcpDisconnect : BtTypes.hpp
  • BtRqtAvrcpPanelPassThrough : BtTypes.hpp
  • BtRqtAvrcpPanelPassThroughRsp : BtTypes.hpp
  • BtRqtAvrcpRawFrame : BtTypes.hpp
  • BtRqtAvrcpRawFrameRsp : BtTypes.hpp
  • BtRqtAvrcpRegister : BtTypes.hpp
  • BtRqtAvrcpSubunitInfo : BtTypes.hpp
  • BtRqtAvrcpUnitInfo : BtTypes.hpp
  • BtRqtBipAbort : BtTypes.hpp
  • BtRqtBipConnect : BtTypes.hpp
  • BtRqtBipDeleteImage : BtTypes.hpp
  • BtRqtBipDisconnect : BtTypes.hpp
  • BtRqtBipGetImage : BtTypes.hpp
  • BtRqtBipGetImageProperties : BtTypes.hpp
  • BtRqtBipGetImagesList : BtTypes.hpp
  • BtRqtBipGetImagingCapabilities : BtTypes.hpp
  • BtRqtBipGetLinkedAttachment : BtTypes.hpp
  • BtRqtBipGetLinkedThumbnail : BtTypes.hpp
  • BtRqtBipPutImage : BtTypes.hpp
  • BtRqtBipPutLinkedAttachment : BtTypes.hpp
  • BtRqtBipPutLinkedThumbnail : BtTypes.hpp
  • BtRqtBppSndAbortReq : BtTypes.hpp
  • BtRqtBppSndAuthenticationReqRes : BtTypes.hpp
  • BtRqtBppSndFilePushReq : BtTypes.hpp
  • BtRqtBppSndGetRefObjRsp : BtTypes.hpp
  • BtRqtDevicePair : BtTypes.hpp
  • BtRqtDeviceSearch : BtTypes.hpp
  • BtRqtDeviceTrust : BtTypes.hpp
  • BtRqtDeviceUnpair : BtTypes.hpp
  • BtRqtDeviceUntrust : BtTypes.hpp
  • BtRqtDunDisconnect : BtTypes.hpp
  • BtRqtFaxDisconnect : BtTypes.hpp
  • BtRqtHfConnect : BtTypes.hpp
  • BtRqtHfDisconnect : BtTypes.hpp
  • BtRqtHfSetMicrophoneGain : BtTypes.hpp
  • BtRqtHfSetSpeakerGain : BtTypes.hpp
  • BtRqtHfTransferAudioToAccessory : BtTypes.hpp
  • BtRqtHfTransferAudioToPhone : BtTypes.hpp
  • BtRqtHsConnect : BtTypes.hpp
  • BtRqtHsDisconnect : BtTypes.hpp
  • BtRqtHsHangUp : BtTypes.hpp
  • BtRqtHsRing : BtTypes.hpp
  • BtRqtHsSetMicrophoneGain : BtTypes.hpp
  • BtRqtHsSetSpeakerGain : BtTypes.hpp
  • BtRqtHsStopRing : BtTypes.hpp
  • BtRqtHsTransferAudioToAccessory : BtTypes.hpp
  • BtRqtHsTransferAudioToPhone : BtTypes.hpp
  • BtRqtObexAbort : BtTypes.hpp
  • BtRqtObexConnect : BtTypes.hpp
  • BtRqtObexDisconnect : BtTypes.hpp
  • BtRqtObexGet : BtTypes.hpp
  • BtRqtObexPut : BtTypes.hpp
  • BtRqtObexRegisterClient : BtTypes.hpp
  • BtRqtObexRegisterServer : BtTypes.hpp
  • BtRqtObexSendResponse : BtTypes.hpp
  • BtRqtObexSetPath : BtTypes.hpp
  • BtRqtObexUnregisterClient : BtTypes.hpp
  • BtRqtObexUnregisterServer : BtTypes.hpp
  • BtRqtQuerySupportedProfiles : BtTypes.hpp
  • BtRqtRespondAuthorization : BtTypes.hpp
  • BtRqtSddbRegisterServiceRecord : BtTypes.hpp
  • BtRqtSddbUnregisterServiceRecord : BtTypes.hpp
  • BtRqtSendPasskey : BtTypes.hpp
  • BtRqtServiceVerify : BtTypes.hpp
  • BtRqtSetRemoteDeviceName : BtTypes.hpp
  • BtRqtUnknown : BtTypes.hpp
  • BtSesAlwaysAuthenticatedTrustedDevices : BtTypes.hpp
  • BtSesAuthentication : BtTypes.hpp
  • BtSesAuthenticationAuthorization : BtTypes.hpp
  • BtSesAuthenticationEncryption : BtTypes.hpp
  • BtSesAuthenticationEncryptionAuthorization : BtTypes.hpp
  • BtSesAuthorization : BtTypes.hpp
  • BtSesAuthorizationAlwaysAuthenticatedTrustedDevices : BtTypes.hpp
  • BtSesNoSecurity : BtTypes.hpp
  • BtSsError : BtTypes.hpp
  • BtSsInitialized : BtTypes.hpp
  • BtSsNoState : BtTypes.hpp
  • BtSsNotInitialized : BtTypes.hpp
  • BtSsOff : BtTypes.hpp
  • BtSsOn : BtTypes.hpp
  • BtUuid128 : BtTypes.hpp
  • BtUuid16 : BtTypes.hpp
  • BtUuid32 : BtTypes.hpp
  • BuildMparty : SignalTypes.hpp
  • BusyOnCall : SimTkTypes.hpp
  • BusyToneOn : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- c -

  • c_aas_id : ProvIds.hpp
  • c_aas_id_end : ProvIds.hpp
  • c_aas_max_rec_id : ProvIds.hpp
  • c_aas_size_id : ProvIds.hpp
  • c_access_technology_id : ProvIds.hpp
  • c_acm2_id : ProvIds.hpp
  • c_acm_chv_id : ProvIds.hpp
  • c_acm_id : ProvIds.hpp
  • c_acmmax_chv_id : ProvIds.hpp
  • c_acmmax_id : ProvIds.hpp
  • c_act_supported_id : ProvIds.hpp
  • c_add_name_id : ProvIds.hpp
  • c_add_name_id_end : ProvIds.hpp
  • c_add_name_size_id : ProvIds.hpp
  • c_adn_provider_id : ProvIds.hpp
  • c_alphatagsize_id : ProvIds.hpp
  • c_anr_id : ProvIds.hpp
  • c_anr_id_end : ProvIds.hpp
  • c_attempts_left_id : ProvIds.hpp
  • c_aux_provider_id : ProvIds.hpp
  • c_battery_load_id : ProvIds.hpp
  • c_bdn_provider_id : ProvIds.hpp
  • c_bt_protocol_l2cap : BtSocketAddr.hpp
  • c_bt_protocol_rfcomm : BtSocketAddr.hpp
  • c_cal_category_id : CalendarProvider.hpp
  • c_cal_date_id : CalendarProvider.hpp
  • c_cal_description_id : CalendarProvider.hpp
  • c_cal_recurrence_id : CalendarProvider.hpp
  • c_cal_text_for_list_item_id : CalendarProvider.hpp
  • c_cal_time_id : CalendarProvider.hpp
  • c_call_fwd_data_id : ProvIds.hpp
  • c_call_fwd_fax_id : ProvIds.hpp
  • c_call_fwd_line1_id : ProvIds.hpp
  • c_call_fwd_line2_id : ProvIds.hpp
  • c_cause_id : ProvIds.hpp
  • c_cbmi_id : ProvIds.hpp
  • c_cbmi_provider_id : ProvIds.hpp
  • c_cbmi_range_high_id : ProvIds.hpp
  • c_cbmi_range_low_id : ProvIds.hpp
  • c_cbmi_range_provider_id : ProvIds.hpp
  • c_cc_id : ProvIds.hpp
  • c_cellid_id : ProvIds.hpp
  • c_chv_provider_id : ProvIds.hpp
  • c_clir_mode_id : ProvIds.hpp
  • c_cmi_alpha_id : ProvIds.hpp
  • c_cmi_id : ProvIds.hpp
  • c_cmi_provider_id : ProvIds.hpp
  • c_cmi_record_id : ProvIds.hpp
  • c_corporate_lockstate_id : ProvIds.hpp
  • c_country_provider_id : ProvIds.hpp
  • c_country_shortname_id : ProvIds.hpp
  • c_cphs_aux_provider_id : ProvIds.hpp
  • c_cphs_costumer_prof_provider_id : ProvIds.hpp
  • c_cphs_infono_provider_id : ProvIds.hpp
  • c_cphs_is_present_id : ProvIds.hpp
  • c_cphs_mbox_provider_id : ProvIds.hpp
  • c_cphs_phase_id : ProvIds.hpp
  • c_csd_data_conn_established : SocketTypes.hpp
  • c_csd_data_conn_init : SocketTypes.hpp
  • c_csd_data_conn_init_release : SocketTypes.hpp
  • c_csd_data_conn_released : SocketTypes.hpp
  • c_csd_data_conn_setup_blocked : SocketTypes.hpp
  • c_csd_data_conn_setup_failed : SocketTypes.hpp
  • c_csp_activated_id : ProvIds.hpp
  • c_csp_allocated_id : ProvIds.hpp
  • c_currency_code_id : ProvIds.hpp
  • c_currency_eppu_id : ProvIds.hpp
  • c_currency_exp_id : ProvIds.hpp
  • c_data_coding_scheme_id : ProvIds.hpp
  • c_data_conn_profile_changed : SocketTypes.hpp
  • c_data_conn_profile_created : SocketTypes.hpp
  • c_data_conn_profile_deleted : SocketTypes.hpp
  • c_data_conn_profile_set_as_default : SocketTypes.hpp
  • c_dataconn_display_text_id : DataConnProvider.hpp
  • c_dataconn_icon_id : DataConnProvider.hpp
  • c_dataconn_is_readonly_id : DataConnProvider.hpp
  • c_dataconn_next_free_row_id : DataConnProvider.hpp
  • c_dataconn_profile_count_id : DataConnProvider.hpp
  • c_dataconn_profile_id : DataConnProvider.hpp
  • c_dataconn_profile_type_id : DataConnProvider.hpp
  • c_default_audiopath_id : BtHfProvider.hpp
  • c_destination_address_id : ProvIds.hpp
  • c_dummy : ProvIds.hpp
  • c_ecc_alpha_id : ProvIds.hpp
  • c_ecc_category_id : ProvIds.hpp
  • c_ecc_id : ProvIds.hpp
  • c_ecc_phonenumber_id : ProvIds.hpp
  • c_ecc_provider_id : ProvIds.hpp
  • c_ecc_sim_network_cnt_id : ProvIds.hpp
  • c_ecc_source_id : ProvIds.hpp
  • c_eep_calibration_status_id : ProvIds.hpp
  • c_email_adr_id : ProvIds.hpp
  • c_email_adr_id_end : ProvIds.hpp
  • c_email_adr_size_id : ProvIds.hpp
  • c_end_provider_range : ProvIds.hpp
  • c_est_apn_acl : SstProvider.hpp
  • c_est_bdn : SstProvider.hpp
  • c_est_fdn : SstProvider.hpp
  • c_est_provider_id : ProvIds.hpp
  • c_ext_lang_pref_id : ProvIds.hpp
  • c_fdn_provider_id : ProvIds.hpp
  • c_fdn_state_id : ProvIds.hpp
  • c_first_rec_id : ProvIds.hpp
  • c_freeextrecords_id : ProvIds.hpp
  • c_ftp_conn_type_control : FtpTypes.hpp
  • c_ftp_conn_type_data : FtpTypes.hpp
  • c_ftp_data_conn_type_active : FtpTypes.hpp
  • c_ftp_data_conn_type_passive : FtpTypes.hpp
  • c_ftp_service_command_error_failed : FtpTypes.hpp
  • c_ftp_service_command_error_success : FtpTypes.hpp
  • c_ftp_service_command_init : FtpTypes.hpp
  • c_ftp_service_command_start : FtpTypes.hpp
  • c_ftp_service_command_stop : FtpTypes.hpp
  • c_ftp_service_command_terminate : FtpTypes.hpp
  • c_ftp_transfer_direction_in : FtpTypes.hpp
  • c_ftp_transfer_direction_out : FtpTypes.hpp
  • c_ftp_transfer_error_aborted : FtpTypes.hpp
  • c_ftp_transfer_error_complete : FtpTypes.hpp
  • c_ftp_transfer_error_created : FtpTypes.hpp
  • c_ftp_transfer_error_failed : FtpTypes.hpp
  • c_ftp_transfer_error_not_running : FtpTypes.hpp
  • c_ftp_transfer_error_progress : FtpTypes.hpp
  • c_ftp_transfer_error_started : FtpTypes.hpp
  • c_ftp_transfer_mode_block : FtpTypes.hpp
  • c_ftp_transfer_mode_compressed : FtpTypes.hpp
  • c_ftp_transfer_mode_stream : FtpTypes.hpp
  • c_ftp_transfer_structure_file : FtpTypes.hpp
  • c_ftp_transfer_structure_record : FtpTypes.hpp
  • c_ftp_transfer_type_ascii : FtpTypes.hpp
  • c_ftp_transfer_type_image : FtpTypes.hpp
  • c_gas_max_rec_id : ProvIds.hpp
  • c_gas_size_id : ProvIds.hpp
  • c_gprs_attached_id : ProvIds.hpp
  • c_gprs_available_id : ProvIds.hpp
  • c_gprs_class_change_origin_id : ProvIds.hpp
  • c_gprs_class_id : ProvIds.hpp
  • c_group_id : ProvIds.hpp
  • c_group_id_end : ProvIds.hpp
  • c_gsm_band_id : ProvIds.hpp
  • c_hidden_info_id : ProvIds.hpp
  • c_hiddenkey_supported_id : ProvIds.hpp
  • c_http_response_code_200 : HttpTypes.hpp
  • c_http_response_code_400 : HttpTypes.hpp
  • c_http_response_code_404 : HttpTypes.hpp
  • c_http_service_command_error_failed : HttpTypes.hpp
  • c_http_service_command_error_success : HttpTypes.hpp
  • c_http_service_command_init : HttpTypes.hpp
  • c_http_service_command_start : HttpTypes.hpp
  • c_http_service_command_stop : HttpTypes.hpp
  • c_http_service_command_terminate : HttpTypes.hpp
  • c_icc_id : ProvIds.hpp
  • c_icon_id : ProvIds.hpp
  • c_icon_isselfexp_id : ProvIds.hpp
  • c_imei_id : ProvIds.hpp
  • c_imsi_id : ProvIds.hpp
  • c_index_level_id : ProvIds.hpp
  • c_infnrs_activated_id : ProvIds.hpp
  • c_infnrs_allocated_id : ProvIds.hpp
  • c_is_free_add_name_id : ProvIds.hpp
  • c_is_free_anr_id : ProvIds.hpp
  • c_is_free_email_adr_id : ProvIds.hpp
  • c_is_free_ext_id : ProvIds.hpp
  • c_item_id : ProvIds.hpp
  • c_item_string_id : ProvIds.hpp
  • c_lai_lac_id : ProvIds.hpp
  • c_lai_mcc_id : ProvIds.hpp
  • c_lai_mnc_id : ProvIds.hpp
  • c_lang_pref_id : ProvIds.hpp
  • c_last_ccm2_id : ProvIds.hpp
  • c_last_ccm_id : ProvIds.hpp
  • c_last_rec_id : ProvIds.hpp
  • c_line_in_use_id : ProvIds.hpp
  • c_line_is_locked_id : ProvIds.hpp
  • c_lnd_provider_id : ProvIds.hpp
  • c_loci_lac_id : ProvIds.hpp
  • c_loci_mcc_id : ProvIds.hpp
  • c_loci_mnc_id : ProvIds.hpp
  • c_loci_mnc_threedigits_id : ProvIds.hpp
  • c_loci_update_status_id : ProvIds.hpp
  • c_lock_dcp_sup_id : ProvIds.hpp
  • c_lock_order_id : ProvIds.hpp
  • c_lock_provider_id : ProvIds.hpp
  • c_lock_result_id : ProvIds.hpp
  • c_lock_retrial_count_id : ProvIds.hpp
  • c_lock_retrial_method_id : ProvIds.hpp
  • c_lock_status_id : ProvIds.hpp
  • c_lock_time_id : ProvIds.hpp
  • c_lock_type_id : ProvIds.hpp
  • c_max_add_name_columns_id : ProvIds.hpp
  • c_max_anr_columns_id : ProvIds.hpp
  • c_max_email_adr_columns_id : ProvIds.hpp
  • c_max_group_columns_id : ProvIds.hpp
  • c_max_rec_id : ProvIds.hpp
  • c_mbdn_provider_id : ProvIds.hpp
  • c_mbi_provider_id : ProvIds.hpp
  • c_mboxnrs_activated_id : ProvIds.hpp
  • c_mboxnrs_allocated_id : ProvIds.hpp
  • c_mcc_id : ProvIds.hpp
  • c_mdni_electronic_mail_id : ProvIds.hpp
  • c_mdni_fax_id : ProvIds.hpp
  • c_mdni_other_id : ProvIds.hpp
  • c_mdni_videomail_id : ProvIds.hpp
  • c_mdni_voicemail_id : ProvIds.hpp
  • c_mime_apoxi_settings : MimeTypeTable.hpp
  • c_mime_app_j2me_archieve : MimeTypeTable.hpp
  • c_mime_app_j2me_jrs : MimeTypeTable.hpp
  • c_mime_app_mmf : MimeTypeTable.hpp
  • c_mime_app_sdp : MimeTypeTable.hpp
  • c_mime_app_spf : MimeTypeTable.hpp
  • c_mime_audio_3gpp : MimeTypeTable.hpp
  • c_mime_audio_aac : MimeTypeTable.hpp
  • c_mime_audio_amr : MimeTypeTable.hpp
  • c_mime_audio_imelody : MimeTypeTable.hpp
  • c_mime_audio_m4a : MimeTypeTable.hpp
  • c_mime_audio_midi : MimeTypeTable.hpp
  • c_mime_audio_mobile_xmf : MimeTypeTable.hpp
  • c_mime_audio_mpeg : MimeTypeTable.hpp
  • c_mime_audio_wav : MimeTypeTable.hpp
  • c_mime_drm_content : MimeTypeTable.hpp
  • c_mime_drm_encoded : MimeTypeTable.hpp
  • c_mime_drm_message : MimeTypeTable.hpp
  • c_mime_drm_ro : MimeTypeTable.hpp
  • c_mime_drm_textual : MimeTypeTable.hpp
  • c_mime_image_bmp : MimeTypeTable.hpp
  • c_mime_image_ems : MimeTypeTable.hpp
  • c_mime_image_gif : MimeTypeTable.hpp
  • c_mime_image_jpeg : MimeTypeTable.hpp
  • c_mime_image_png : MimeTypeTable.hpp
  • c_mime_image_svg : MimeTypeTable.hpp
  • c_mime_image_svgz : MimeTypeTable.hpp
  • c_mime_image_tiff : MimeTypeTable.hpp
  • c_mime_image_wbmp : MimeTypeTable.hpp
  • c_mime_text_calendar : MimeTypeTable.hpp
  • c_mime_text_html : MimeTypeTable.hpp
  • c_mime_text_j2me_appdesc : MimeTypeTable.hpp
  • c_mime_text_plain : MimeTypeTable.hpp
  • c_mime_text_vcard : MimeTypeTable.hpp
  • c_mime_text_wml : MimeTypeTable.hpp
  • c_mime_text_wmlscript : MimeTypeTable.hpp
  • c_mime_text_xhtml : MimeTypeTable.hpp
  • c_mime_text_xml : MimeTypeTable.hpp
  • c_mime_unknown : MimeTypeTable.hpp
  • c_mime_user_offset : MimeTypeTable.hpp
  • c_mime_video_3gpp : MimeTypeTable.hpp
  • c_mime_video_mpeg : MimeTypeTable.hpp
  • c_mime_video_msvideo : MimeTypeTable.hpp
  • c_mime_video_quicktime : MimeTypeTable.hpp
  • c_mnc_id : ProvIds.hpp
  • c_mnc_threedigits_id : ProvIds.hpp
  • c_mode_id : ProvIds.hpp
  • c_msg_count_id : ProvIds.hpp
  • c_msg_ind_level_id : ProvIds.hpp
  • c_msg_ind_setting_id : ProvIds.hpp
  • c_msg_ind_sms_type_id : ProvIds.hpp
  • c_msg_position_id : ProvIds.hpp
  • c_msg_update_id : ProvIds.hpp
  • c_msg_wait_ind_data_id : ProvIds.hpp
  • c_msg_wait_ind_fax_id : ProvIds.hpp
  • c_msg_wait_ind_line1_id : ProvIds.hpp
  • c_msg_wait_ind_line2_id : ProvIds.hpp
  • c_msisdn_provider_id : ProvIds.hpp
  • c_name_id : ProvIds.hpp
  • c_network_lockstate_id : ProvIds.hpp
  • c_network_name_long_id : ProvIds.hpp
  • c_network_name_short_id : ProvIds.hpp
  • c_networktype_id : ProvIds.hpp
  • c_next_action_id : ProvIds.hpp
  • c_nextfreeposition_id : ProvIds.hpp
  • c_no_files : ProvIds.hpp
  • c_no_id : ProvIds.hpp
  • c_no_locks_id : ProvIds.hpp
  • c_nw_spec_id : ProvIds.hpp
  • c_ofm_to_be_activated_id : ProvIds.hpp
  • c_operator_name_id : ProvIds.hpp
  • c_operator_shortname_id : ProvIds.hpp
  • c_opname_activated_id : ProvIds.hpp
  • c_opname_allocated_id : ProvIds.hpp
  • c_options_id : ProvIds.hpp
  • c_orange_welcome_msg_id : ProvIds.hpp
  • c_phone_no_id : ProvIds.hpp
  • c_plmn_name_id : ProvIds.hpp
  • c_plmn_provider_id : ProvIds.hpp
  • c_plmn_shortname_id : ProvIds.hpp
  • c_pref_service_id : ProvIds.hpp
  • c_prefextlang2_provider_id : ProvIds.hpp
  • c_prefextlang_provider_id : ProvIds.hpp
  • c_preflang_provider_id : ProvIds.hpp
  • c_prefplmn_provider_id : ProvIds.hpp
  • c_premium_serv_id : ProvIds.hpp
  • c_protocol_identifier_id : ProvIds.hpp
  • c_psd_data_conn_established : SocketTypes.hpp
  • c_psd_data_conn_init : SocketTypes.hpp
  • c_psd_data_conn_init_release : SocketTypes.hpp
  • c_psd_data_conn_released : SocketTypes.hpp
  • c_psd_data_conn_setup_blocked : SocketTypes.hpp
  • c_psd_data_conn_setup_failed : SocketTypes.hpp
  • c_puct_chv_id : ProvIds.hpp
  • c_radio_freq : FmRadioStationsProvider.hpp
  • c_radio_last_freq : FmRadioSettingsProvider.hpp
  • c_radio_last_volume : FmRadioSettingsProvider.hpp
  • c_radio_stat_text : FmRadioStationsProvider.hpp
  • c_rat_change_mode_id : ProvIds.hpp
  • c_rat_id : ProvIds.hpp
  • c_redialing_active_id : ProvIds.hpp
  • c_reject_cause_id : ProvIds.hpp
  • c_result_id : ProvIds.hpp
  • c_scmt_control_data_available : SocketTypes.hpp
  • c_scmt_csd_datacall_release : SocketTypes.hpp
  • c_scmt_csd_datacall_setup : SocketTypes.hpp
  • c_scmt_csd_datacall_setup_fail : SocketTypes.hpp
  • c_scmt_csd_datacall_setup_success : SocketTypes.hpp
  • c_scmt_csd_lost : SocketTypes.hpp
  • c_scmt_csd_setup_err : SocketTypes.hpp
  • c_scmt_data_conn_cancelled : SocketTypes.hpp
  • c_scmt_data_conn_established : SocketTypes.hpp
  • c_scmt_idle_timeout : SocketTypes.hpp
  • c_scmt_init_context_err : SocketTypes.hpp
  • c_scmt_ppp_setup : SocketTypes.hpp
  • c_scmt_ppp_setup_err : SocketTypes.hpp
  • c_scmt_ppp_stop : SocketTypes.hpp
  • c_scmt_ppp_stop_err : SocketTypes.hpp
  • c_scmt_psd_ctx_authenticated : SocketTypes.hpp
  • c_scmt_psd_ctx_connected : SocketTypes.hpp
  • c_scmt_psd_ctx_deactivated : SocketTypes.hpp
  • c_scmt_psd_ctx_defined : SocketTypes.hpp
  • c_scmt_psd_ctx_dns_neg_set : SocketTypes.hpp
  • c_scmt_psd_ctx_link_down : SocketTypes.hpp
  • c_scmt_psd_ctx_link_up : SocketTypes.hpp
  • c_scmt_psd_ctx_neg_dns_read : SocketTypes.hpp
  • c_scmt_psd_ctx_packet_filter_set : SocketTypes.hpp
  • c_scmt_psd_ctx_qos_set : SocketTypes.hpp
  • c_scmt_psd_ctx_undefined : SocketTypes.hpp
  • c_scmt_psd_lost : SocketTypes.hpp
  • c_scmt_psd_setup_err : SocketTypes.hpp
  • c_scmt_rx_data_arrived : SocketTypes.hpp
  • c_scmt_tx_data_ready : SocketTypes.hpp
  • c_scmt_undefined : SocketTypes.hpp
  • c_sdn_provider_id : ProvIds.hpp
  • c_ser_data_conn_established : SocketTypes.hpp
  • c_ser_data_conn_init : SocketTypes.hpp
  • c_ser_data_conn_init_release : SocketTypes.hpp
  • c_ser_data_conn_released : SocketTypes.hpp
  • c_ser_data_conn_setup_blocked : SocketTypes.hpp
  • c_ser_data_conn_setup_failed : SocketTypes.hpp
  • c_serv_als_id : ProvIds.hpp
  • c_serv_aoc_id : ProvIds.hpp
  • c_serv_baic_id : ProvIds.hpp
  • c_serv_bic_roam_id : ProvIds.hpp
  • c_serv_boac_id : ProvIds.hpp
  • c_serv_boic_exhc_id : ProvIds.hpp
  • c_serv_boic_id : ProvIds.hpp
  • c_serv_ccbs_id : ProvIds.hpp
  • c_serv_cfb_id : ProvIds.hpp
  • c_serv_cfnrc_id : ProvIds.hpp
  • c_serv_cfnry_id : ProvIds.hpp
  • c_serv_cfu_id : ProvIds.hpp
  • c_serv_cli_block_id : ProvIds.hpp
  • c_serv_cli_send_id : ProvIds.hpp
  • c_serv_clip_id : ProvIds.hpp
  • c_serv_co_lp_id : ProvIds.hpp
  • c_serv_co_lr_id : ProvIds.hpp
  • c_serv_ct_id : ProvIds.hpp
  • c_serv_cug_id : ProvIds.hpp
  • c_serv_cug_oa_id : ProvIds.hpp
  • c_serv_cw_id : ProvIds.hpp
  • c_serv_data_id : ProvIds.hpp
  • c_serv_del_conf_id : ProvIds.hpp
  • c_serv_fax_id : ProvIds.hpp
  • c_serv_gprs_id : ProvIds.hpp
  • c_serv_hold_id : ProvIds.hpp
  • c_serv_hscsd_id : ProvIds.hpp
  • c_serv_info_numbers_id : ProvIds.hpp
  • c_serv_language_id : ProvIds.hpp
  • c_serv_mci_id : ProvIds.hpp
  • c_serv_mpty_id : ProvIds.hpp
  • c_serv_mtpl_band_id : ProvIds.hpp
  • c_serv_mtpl_subs_pfl_id : ProvIds.hpp
  • c_serv_plmn_mode_id : ProvIds.hpp
  • c_serv_pref_cug_id : ProvIds.hpp
  • c_serv_protid_id : ProvIds.hpp
  • c_serv_repl_path_id : ProvIds.hpp
  • c_serv_sm_cb_id : ProvIds.hpp
  • c_serv_sm_mo_id : ProvIds.hpp
  • c_serv_sm_mt_id : ProvIds.hpp
  • c_serv_smmo_email_id : ProvIds.hpp
  • c_serv_smmo_paging_id : ProvIds.hpp
  • c_serv_usr_usr_sig_id : ProvIds.hpp
  • c_serv_val_per_id : ProvIds.hpp
  • c_serv_vgrp_call_id : ProvIds.hpp
  • c_serv_voice_bcst_serv_id : ProvIds.hpp
  • c_serv_vps_id : ProvIds.hpp
  • c_service_activated_id : ProvIds.hpp
  • c_service_allocated_id : ProvIds.hpp
  • c_service_available_id : ProvIds.hpp
  • c_service_center_address_id : ProvIds.hpp
  • c_signal_quality_id : ProvIds.hpp
  • c_signal_quality_max_id : ProvIds.hpp
  • c_signal_strength_id : ProvIds.hpp
  • c_signal_strength_max_id : ProvIds.hpp
  • c_sim_errorcode_id : ProvIds.hpp
  • c_sim_ind_id : ProvIds.hpp
  • c_sim_init_result_id : ProvIds.hpp
  • c_sim_lockstate_id : ProvIds.hpp
  • c_sim_phase_id : ProvIds.hpp
  • c_sim_type_id : ProvIds.hpp
  • c_simpos_id : ProvIds.hpp
  • c_simtk_mainmenu_provider_id : ProvIds.hpp
  • c_slice_id : ProvIds.hpp
  • c_sms_alpha_id : ProvIds.hpp
  • c_sms_base_archive_provider_id : ProvIds.hpp
  • c_sms_base_inbox_provider_id : ProvIds.hpp
  • c_sms_base_outbox_provider_id : ProvIds.hpp
  • c_sms_base_statusreport_provider_id : ProvIds.hpp
  • c_sms_base_unread_provider_id : ProvIds.hpp
  • c_sms_class0_provider_id : ProvIds.hpp
  • c_sms_coding_group_id : ProvIds.hpp
  • c_sms_compound_sms_id : ProvIds.hpp
  • c_sms_compound_tpdu_id : ProvIds.hpp
  • c_sms_conc_max_no_id : ProvIds.hpp
  • c_sms_conc_ref_no_id : ProvIds.hpp
  • c_sms_conc_seq_no_id : ProvIds.hpp
  • c_sms_conc_status_id : ProvIds.hpp
  • c_sms_conc_tpdu_num_id : ProvIds.hpp
  • c_sms_count_provider_id : ProvIds.hpp
  • c_sms_date_id : ProvIds.hpp
  • c_sms_datetime_id : ProvIds.hpp
  • c_sms_dcs_id : ProvIds.hpp
  • c_sms_debugstring_id : ProvIds.hpp
  • c_sms_extended_data_id : ProvIds.hpp
  • c_sms_free_pdu_id : ProvIds.hpp
  • c_sms_header_text_id : ProvIds.hpp
  • c_sms_message_provider_id : ProvIds.hpp
  • c_sms_message_status_id : ProvIds.hpp
  • c_sms_msg_class_id : ProvIds.hpp
  • c_sms_msg_type_id : ProvIds.hpp
  • c_sms_no_pdu_flash_id : ProvIds.hpp
  • c_sms_no_pdu_sim_id : ProvIds.hpp
  • c_sms_param_name_id : ProvIds.hpp
  • c_sms_parameter_provider_id : ProvIds.hpp
  • c_sms_pdu_data_id : ProvIds.hpp
  • c_sms_phonenumber_id : ProvIds.hpp
  • c_sms_pos_id : ProvIds.hpp
  • c_sms_protid_id : ProvIds.hpp
  • c_sms_provider_id : ProvIds.hpp
  • c_sms_read_count_id : ProvIds.hpp
  • c_sms_read_provider_id : ProvIds.hpp
  • c_sms_recno_id : ProvIds.hpp
  • c_sms_refno_id : ProvIds.hpp
  • c_sms_reply_path_flag_id : ProvIds.hpp
  • c_sms_sca_id : ProvIds.hpp
  • c_sms_sent_count_id : ProvIds.hpp
  • c_sms_sent_provider_id : ProvIds.hpp
  • c_sms_status_id : ProvIds.hpp
  • c_sms_storage_media_id : ProvIds.hpp
  • c_sms_string_id : ProvIds.hpp
  • c_sms_sum_id : ProvIds.hpp
  • c_sms_time_id : ProvIds.hpp
  • c_sms_tpdu_capacity_id : ProvIds.hpp
  • c_sms_tpdu_empty_id : ProvIds.hpp
  • c_sms_tpdu_occupied_id : ProvIds.hpp
  • c_sms_unread_count_id : ProvIds.hpp
  • c_sms_unread_provider_id : ProvIds.hpp
  • c_sms_unsent_count_id : ProvIds.hpp
  • c_sms_unsent_provider_id : ProvIds.hpp
  • c_smsp_alpha_id_len_id : ProvIds.hpp
  • c_socket_bearer_busy : SocketTypes.hpp
  • c_socket_bearer_not_supported : SocketTypes.hpp
  • c_socket_conn_blocked : SocketTypes.hpp
  • c_socket_conn_in_release : SocketTypes.hpp
  • c_socket_conn_in_setup : SocketTypes.hpp
  • c_socket_conn_lost : SocketTypes.hpp
  • c_socket_conn_perform_setup : SocketTypes.hpp
  • c_socket_conn_setup_failed : SocketTypes.hpp
  • c_socket_conn_timed_out : SocketTypes.hpp
  • c_socket_eacces : SocketTypes.hpp
  • c_socket_eaddrinuse : SocketTypes.hpp
  • c_socket_eaddrnotavail : SocketTypes.hpp
  • c_socket_eafnosupport : SocketTypes.hpp
  • c_socket_ealready : SocketTypes.hpp
  • c_socket_ebadf : SocketTypes.hpp
  • c_socket_econnaborted : SocketTypes.hpp
  • c_socket_econnrefused : SocketTypes.hpp
  • c_socket_econnreset : SocketTypes.hpp
  • c_socket_edestaddrreq : SocketTypes.hpp
  • c_socket_efault : SocketTypes.hpp
  • c_socket_ehostdown : SocketTypes.hpp
  • c_socket_ehostunreach : SocketTypes.hpp
  • c_socket_einprogress : SocketTypes.hpp
  • c_socket_eintr : SocketTypes.hpp
  • c_socket_einval : SocketTypes.hpp
  • c_socket_eisconn : SocketTypes.hpp
  • c_socket_emfile : SocketTypes.hpp
  • c_socket_emsgsize : SocketTypes.hpp
  • c_socket_enetdown : SocketTypes.hpp
  • c_socket_enetreset : SocketTypes.hpp
  • c_socket_enetunreach : SocketTypes.hpp
  • c_socket_enobufs : SocketTypes.hpp
  • c_socket_enoprotoopt : SocketTypes.hpp
  • c_socket_enotconn : SocketTypes.hpp
  • c_socket_enotsock : SocketTypes.hpp
  • c_socket_eopnotsupp : SocketTypes.hpp
  • c_socket_epfnosupport : SocketTypes.hpp
  • c_socket_eprotonosupport : SocketTypes.hpp
  • c_socket_eprototype : SocketTypes.hpp
  • c_socket_eshutdown : SocketTypes.hpp
  • c_socket_esocktnosupport : SocketTypes.hpp
  • c_socket_etimedout : SocketTypes.hpp
  • c_socket_ewouldblock : SocketTypes.hpp
  • c_socket_fatal_system_error : SocketTypes.hpp
  • c_socket_no_bearer : SocketTypes.hpp
  • c_socket_no_data_conn_profile : SocketTypes.hpp
  • c_socket_no_error : SocketTypes.hpp
  • c_socket_subsystem_not_init : SocketTypes.hpp
  • c_socket_unknown_error : SocketTypes.hpp
  • c_socket_wait_for_recv_unblocked : SocketTypes.hpp
  • c_socket_wait_for_send_unblocked : SocketTypes.hpp
  • c_socket_wrong_execution_context : SocketTypes.hpp
  • c_sp_lockstate_id : ProvIds.hpp
  • c_spn_display_condition_id : ProvIds.hpp
  • c_spn_id : ProvIds.hpp
  • c_sst_activated_id : ProvIds.hpp
  • c_sst_adn : SstProvider.hpp
  • c_sst_allocated_id : ProvIds.hpp
  • c_sst_aoc : SstProvider.hpp
  • c_sst_bdn : SstProvider.hpp
  • c_sst_call_control : SstProvider.hpp
  • c_sst_cbmi : SstProvider.hpp
  • c_sst_cbmi_ranges : SstProvider.hpp
  • c_sst_ccp : SstProvider.hpp
  • c_sst_cfis : SstProvider.hpp
  • c_sst_chv1_disable_function : SstProvider.hpp
  • c_sst_coop_network_list : SstProvider.hpp
  • c_sst_cpbcch_info : SstProvider.hpp
  • c_sst_depers_control_keys : SstProvider.hpp
  • c_sst_dwld_sms_cb : SstProvider.hpp
  • c_sst_dwld_sms_pp : SstProvider.hpp
  • c_sst_eccp : SstProvider.hpp
  • c_sst_emlpp : SstProvider.hpp
  • c_sst_emlpp_answer : SstProvider.hpp
  • c_sst_ext1 : SstProvider.hpp
  • c_sst_ext2 : SstProvider.hpp
  • c_sst_ext3 : SstProvider.hpp
  • c_sst_ext4 : SstProvider.hpp
  • c_sst_ext8 : SstProvider.hpp
  • c_sst_fdn : SstProvider.hpp
  • c_sst_gil1 : SstProvider.hpp
  • c_sst_gil2 : SstProvider.hpp
  • c_sst_gprs : SstProvider.hpp
  • c_sst_hplmn_access_tech : SstProvider.hpp
  • c_sst_image : SstProvider.hpp
  • c_sst_investigation_scan : SstProvider.hpp
  • c_sst_lnd : SstProvider.hpp
  • c_sst_mbdn : SstProvider.hpp
  • c_sst_menu_selection : SstProvider.hpp
  • c_sst_mexe : SstProvider.hpp
  • c_sst_mms : SstProvider.hpp
  • c_sst_mms_user_con_params : SstProvider.hpp
  • c_sst_mo_sm_sim : SstProvider.hpp
  • c_sst_msisdn : SstProvider.hpp
  • c_sst_mwis : SstProvider.hpp
  • c_sst_networkind_alerting : SstProvider.hpp
  • c_sst_opl : SstProvider.hpp
  • c_sst_oplmn_sel_access_tech : SstProvider.hpp
  • c_sst_plmn_sel : SstProvider.hpp
  • c_sst_plmn_sel_access_tech : SstProvider.hpp
  • c_sst_pnn : SstProvider.hpp
  • c_sst_proactive_sim : SstProvider.hpp
  • c_sst_provider_id : ProvIds.hpp
  • c_sst_run_at_command : SstProvider.hpp
  • c_sst_sdn : SstProvider.hpp
  • c_sst_sms : SstProvider.hpp
  • c_sst_sms_parameters : SstProvider.hpp
  • c_sst_sms_reports : SstProvider.hpp
  • c_sst_solsa : SstProvider.hpp
  • c_sst_spdi : SstProvider.hpp
  • c_sst_spn : SstProvider.hpp
  • c_sst_ussd_in_callcontrol : SstProvider.hpp
  • c_sst_vbs_gil : SstProvider.hpp
  • c_sst_vgcs_gil : SstProvider.hpp
  • c_start_provider_range : ProvIds.hpp
  • c_state_id : ProvIds.hpp
  • c_status_provider_id : ProvIds.hpp
  • c_succ_16bit_conc_sms_ref_no : ProvIds.hpp
  • c_sync_supported_id : ProvIds.hpp
  • c_tagsize_id : ProvIds.hpp
  • c_title_icon_id : ProvIds.hpp
  • c_title_icon_isselfexp_id : ProvIds.hpp
  • c_title_id : ProvIds.hpp
  • c_total_rec_id : ProvIds.hpp
  • c_tz_dst_id : ProvIds.hpp
  • c_tz_offset_id : ProvIds.hpp
  • c_uid_id : ProvIds.hpp
  • c_unblocking_attempts_left_id : ProvIds.hpp
  • c_unlock_keybased : ProvIds.hpp
  • c_unlock_menubased : ProvIds.hpp
  • c_unlock_startup : ProvIds.hpp
  • c_usimpb_addnumberstring_provider_id : ProvIds.hpp
  • c_usimpb_groupname_provider_id : ProvIds.hpp
  • c_usimpb_property_provider_id : ProvIds.hpp
  • c_usimpb_provider_id : ProvIds.hpp
  • c_ust_acl : SstProvider.hpp
  • c_ust_aoc : SstProvider.hpp
  • c_ust_auto_emlpp : SstProvider.hpp
  • c_ust_bdn_pb : SstProvider.hpp
  • c_ust_callcontrol_gprs_usim : SstProvider.hpp
  • c_ust_callcontrol_usim : SstProvider.hpp
  • c_ust_cbmi : SstProvider.hpp
  • c_ust_cbmir : SstProvider.hpp
  • c_ust_ccp : SstProvider.hpp
  • c_ust_cfis : SstProvider.hpp
  • c_ust_coop_network_list : SstProvider.hpp
  • c_ust_cpbcch_info : SstProvider.hpp
  • c_ust_datadownload_smscb : SstProvider.hpp
  • c_ust_datadownload_smspp : SstProvider.hpp
  • c_ust_datadownload_ussd_appl : SstProvider.hpp
  • c_ust_dck : SstProvider.hpp
  • c_ust_emlpp : SstProvider.hpp
  • c_ust_equivalent_hplmn : SstProvider.hpp
  • c_ust_est : SstProvider.hpp
  • c_ust_ext2 : SstProvider.hpp
  • c_ust_ext3 : SstProvider.hpp
  • c_ust_ext4 : SstProvider.hpp
  • c_ust_ext5 : SstProvider.hpp
  • c_ust_ext8 : SstProvider.hpp
  • c_ust_fdn_pb : SstProvider.hpp
  • c_ust_generic_bootstrapping : SstProvider.hpp
  • c_ust_gid_level1 : SstProvider.hpp
  • c_ust_gid_level2 : SstProvider.hpp
  • c_ust_gsm_access : SstProvider.hpp
  • c_ust_gsm_security_context : SstProvider.hpp
  • c_ust_hplmnwact : SstProvider.hpp
  • c_ust_image : SstProvider.hpp
  • c_ust_in_call_info : SstProvider.hpp
  • c_ust_inv_scan : SstProvider.hpp
  • c_ust_local_pb : SstProvider.hpp
  • c_ust_mbdn : SstProvider.hpp
  • c_ust_mbms_security : SstProvider.hpp
  • c_ust_mexe : SstProvider.hpp
  • c_ust_mms : SstProvider.hpp
  • c_ust_mms_storage : SstProvider.hpp
  • c_ust_mms_ucp : SstProvider.hpp
  • c_ust_mosmscontrol_usim : SstProvider.hpp
  • c_ust_msisdn : SstProvider.hpp
  • c_ust_mwis : SstProvider.hpp
  • c_ust_nia : SstProvider.hpp
  • c_ust_notused : SstProvider.hpp
  • c_ust_op_plmnlist : SstProvider.hpp
  • c_ust_opcont_plmnwact : SstProvider.hpp
  • c_ust_operator_plmn_sel_wlan_access : SstProvider.hpp
  • c_ust_operator_wsid_list : SstProvider.hpp
  • c_ust_out_call_info : SstProvider.hpp
  • c_ust_plmn_networkname : SstProvider.hpp
  • c_ust_plmnwact : SstProvider.hpp
  • c_ust_provider_id : ProvIds.hpp
  • c_ust_pseudonym : SstProvider.hpp
  • c_ust_res : SstProvider.hpp
  • c_ust_rfu : SstProvider.hpp
  • c_ust_runat_command : SstProvider.hpp
  • c_ust_sdn_pb : SstProvider.hpp
  • c_ust_set_to_1 : SstProvider.hpp
  • c_ust_sms : SstProvider.hpp
  • c_ust_smsp : SstProvider.hpp
  • c_ust_smsr : SstProvider.hpp
  • c_ust_spdi : SstProvider.hpp
  • c_ust_spn : SstProvider.hpp
  • c_ust_user_plmn_sel_wlan_access : SstProvider.hpp
  • c_ust_user_wsid_list : SstProvider.hpp
  • c_ust_vbs : SstProvider.hpp
  • c_ust_vbs_security : SstProvider.hpp
  • c_ust_vgcs : SstProvider.hpp
  • c_ust_vgcs_security : SstProvider.hpp
  • c_ust_wlan_reauthentication : SstProvider.hpp
  • c_validity_period_id : ProvIds.hpp
  • CallAcceptForbidden : Types.hpp
  • CallActive : SignalTypes.hpp
  • CallBarringHandlerId : HandlerId.hpp
  • CallChangedToSs : SignalTypes.hpp
  • CallChangedToUssd : SignalTypes.hpp
  • CallControlHandlerId : HandlerId.hpp
  • CallControlMoSmsControlPermanentProblem : SimTkTypes.hpp
  • CallControlMoSmsControlPermanentProblemActionNotAllowed : SimTkTypes.hpp
  • CallControlMoSmsControlPermanentProblemTypeOfRequestChanged : SimTkTypes.hpp
  • CallDataLocked : Types.hpp
  • CallDeflectionHandlerId : HandlerId.hpp
  • CallDeflectionRejected : SignalTypes.hpp
  • CallDeflectionStarted : SignalTypes.hpp
  • CallDisconnected : Types.hpp
  • CallDiscReq : SignalTypes.hpp
  • CalledPartyAlerting : MmTypes.hpp
  • CalledPartyBlacklisted : SignalTypes.hpp
  • CalledSubscriberBusy : SignalTypes.hpp
  • CallForwardingHandlerId : HandlerId.hpp
  • CallHandlerId : HandlerId.hpp
  • CallHeld : SignalTypes.hpp
  • CallHeldRejected : SignalTypes.hpp
  • CallHeldStarted : SignalTypes.hpp
  • CallIsCleared : SignalTypes.hpp
  • CallIsDeflected : SignalTypes.hpp
  • CallIsDisconnected : SignalTypes.hpp
  • CallIsHeld : SignalTypes.hpp
  • CallIsRetrieved : SignalTypes.hpp
  • CallModifyCompleted : SignalTypes.hpp
  • CallModifyIndicated : SignalTypes.hpp
  • CallModifyRejected : SignalTypes.hpp
  • CallModifyStarted : SignalTypes.hpp
  • CallNotIdentified : SignalTypes.hpp
  • CallNotMptyMember : Types.hpp
  • CallOnHold : SignalTypes.hpp
  • CallReEst : SignalTypes.hpp
  • CallRejected : SignalTypes.hpp
  • CallRetrieved : SignalTypes.hpp
  • CallRetrieveRejected : SignalTypes.hpp
  • CallRetrieveStarted : SignalTypes.hpp
  • CallSetupRejected : Types.hpp
  • CallSsActionType : InputAction.hpp
  • CallWaitingHandlerId : HandlerId.hpp
  • CallWaitingTone : SignalTypes.hpp
  • CallWaitToneOn : SignalTypes.hpp
  • CannotReplaceSms : SignalTypes.hpp
  • CbmiEfPos : SimTkTypes.hpp
  • CbmirEfPos : SimTkTypes.hpp
  • CbsHandlerId : HandlerId.hpp
  • CcAllowed : SignalTypes.hpp
  • CcAllowedModified : SignalTypes.hpp
  • CcbsAllowed : SignalTypes.hpp
  • CcbsNotAllowed : SignalTypes.hpp
  • CcbsPossible : SignalTypes.hpp
  • CcNotAllowed : SignalTypes.hpp
  • CcpEfPos : SimTkTypes.hpp
  • CcpRefresh : SignalTypes.hpp
  • CcSimError : SignalTypes.hpp
  • CcToolkitBusy : SignalTypes.hpp
  • Cd : SignalTypes.hpp
  • CdPhoneBook : AtcTypes.hpp
  • CellBarred : NetworkTypes.hpp
  • CellSuitable : NetworkTypes.hpp
  • CellTestSim : SignalTypes.hpp
  • Cfb : SignalTypes.hpp
  • CfisPhoneBookCnt : SignalTypes.hpp
  • Cfnrc : SignalTypes.hpp
  • Cfnry : SignalTypes.hpp
  • Cfu : SignalTypes.hpp
  • CfuActivated : SignalTypes.hpp
  • CfuArrayAccessMaxLines : SignalTypes.hpp
  • CfuData : SignalTypes.hpp
  • CfuDataSourceCfis : SignalTypes.hpp
  • CfuDataSourceCphs : SignalTypes.hpp
  • CfuDataSourceInvalid : SignalTypes.hpp
  • CfuDataSourceNetwork : SignalTypes.hpp
  • CfuDataSourceNvram : SignalTypes.hpp
  • CfuDeactivated : SignalTypes.hpp
  • CfuFax : SignalTypes.hpp
  • CfuInvalid : SignalTypes.hpp
  • CfuTelephony : SignalTypes.hpp
  • CfuTelephonyLine2 : SignalTypes.hpp
  • ChannelUnacceptable : SignalTypes.hpp
  • ChargeEndBatteryFull : SignalTypes.hpp
  • ChargeEndChargerDisconnected : SignalTypes.hpp
  • ChargerOnlyMode : SignalTypes.hpp
  • ChargeShutdownBatteryEmpty : SignalTypes.hpp
  • ChargeShutdownBatteryIdError : SignalTypes.hpp
  • Chn_realase : NetworkTypes.hpp
  • Chv1 : SignalTypes.hpp
  • Chv1Disable : SignalTypes.hpp
  • Chv1Enable : SignalTypes.hpp
  • Chv2 : SignalTypes.hpp
  • ChvChange : SignalTypes.hpp
  • ChvUnblock : SignalTypes.hpp
  • ChvVerify : SignalTypes.hpp
  • CircuitSwitched : NetworkTypes.hpp
  • CircuitSwitchedPreferred : NetworkTypes.hpp
  • ClientFlagConfirmedRefresh : SimTkTypes.hpp
  • ClientFlagLocationStatusReport : SimTkTypes.hpp
  • ClientFlagMccOnStartInd : SimTkTypes.hpp
  • ClientNotRegistered : SignalTypes.hpp
  • ClientRejected : SignalTypes.hpp
  • ClientTemporaryBarred : SignalTypes.hpp
  • Clip : SignalTypes.hpp
  • ClipActionType : InputAction.hpp
  • ClipHandlerId : HandlerId.hpp
  • Clir : SignalTypes.hpp
  • ClirActionType : InputAction.hpp
  • ClirHandlerId : HandlerId.hpp
  • ClirNotSubscribed : SignalTypes.hpp
  • CloseErr : FfsTestError.hpp
  • CmiEfPos : SimTkTypes.hpp
  • CnameVoidChoice : SignalTypes.hpp
  • Cnap : SignalTypes.hpp
  • CnapActionType : InputAction.hpp
  • CnapHandlerId : HandlerId.hpp
  • Colp : SignalTypes.hpp
  • ColpActionType : InputAction.hpp
  • ColpHandlerId : HandlerId.hpp
  • Colr : SignalTypes.hpp
  • ColrActionType : InputAction.hpp
  • ColrHandlerId : HandlerId.hpp
  • CommandBeyondCapability : SimTkTypes.hpp
  • CommandDataNotUnderstoodByMe : SimTkTypes.hpp
  • CommandNumberNotKnownByMe : SimTkTypes.hpp
  • CommandPerformedSuccessfullyLimitedService : SimTkTypes.hpp
  • CommandPerformedWithButModifiedByCallControlBySim : SimTkTypes.hpp
  • CommandPerformedWithMissingInformation : SimTkTypes.hpp
  • CommandPerformedWithModification : SimTkTypes.hpp
  • CommandPerformedWithPartialComprehension : SimTkTypes.hpp
  • CommandTypeNotUnderstoodByMe : SimTkTypes.hpp
  • ConcatenetedSms : SimPduHandler.hpp
  • ConditionalIeError : SignalTypes.hpp
  • ConfirmToneOn : SignalTypes.hpp
  • ConfPasswordMismatch : Types.hpp
  • Congestion : SignalTypes.hpp
  • CongestionTone : SignalTypes.hpp
  • CongestionToneOn : SignalTypes.hpp
  • ConIeErr : SignalTypes.hpp
  • ConnectedWordRecognition : VrTypes.hpp
  • ConnectionError : GltpTypes.hpp
  • ConnectionReqSent : GltpTypes.hpp
  • CountryAD : CountryCodes.hpp
  • CountryAE : CountryCodes.hpp
  • CountryAF : CountryCodes.hpp
  • CountryAG : CountryCodes.hpp
  • CountryAI : CountryCodes.hpp
  • CountryAL : CountryCodes.hpp
  • CountryAM : CountryCodes.hpp
  • CountryAN : CountryCodes.hpp
  • CountryAO : CountryCodes.hpp
  • CountryAQ : CountryCodes.hpp
  • CountryAR : CountryCodes.hpp
  • CountryAS : CountryCodes.hpp
  • CountryAT : CountryCodes.hpp
  • CountryAU : CountryCodes.hpp
  • CountryAW : CountryCodes.hpp
  • CountryAZ : CountryCodes.hpp
  • CountryBA : CountryCodes.hpp
  • CountryBB : CountryCodes.hpp
  • CountryBD : CountryCodes.hpp
  • CountryBE : CountryCodes.hpp
  • CountryBF : CountryCodes.hpp
  • CountryBG : CountryCodes.hpp
  • CountryBH : CountryCodes.hpp
  • CountryBI : CountryCodes.hpp
  • CountryBJ : CountryCodes.hpp
  • CountryBM : CountryCodes.hpp
  • CountryBN : CountryCodes.hpp
  • CountryBO : CountryCodes.hpp
  • CountryBR : CountryCodes.hpp
  • CountryBS : CountryCodes.hpp
  • CountryBT : CountryCodes.hpp
  • CountryBV : CountryCodes.hpp
  • CountryBW : CountryCodes.hpp
  • CountryBY : CountryCodes.hpp
  • CountryBZ : CountryCodes.hpp
  • CountryCA : CountryCodes.hpp
  • CountryCC : CountryCodes.hpp
  • CountryCF : CountryCodes.hpp
  • CountryCG : CountryCodes.hpp
  • CountryCH : CountryCodes.hpp
  • CountryCI : CountryCodes.hpp
  • CountryCK : CountryCodes.hpp
  • CountryCL : CountryCodes.hpp
  • CountryCM : CountryCodes.hpp
  • CountryCN : CountryCodes.hpp
  • CountryCO : CountryCodes.hpp
  • CountryCR : CountryCodes.hpp
  • CountryCU : CountryCodes.hpp
  • CountryCV : CountryCodes.hpp
  • CountryCX : CountryCodes.hpp
  • CountryCY : CountryCodes.hpp
  • CountryCZ : CountryCodes.hpp
  • CountryDE : CountryCodes.hpp
  • CountryDJ : CountryCodes.hpp
  • CountryDK : CountryCodes.hpp
  • CountryDM : CountryCodes.hpp
  • CountryDO : CountryCodes.hpp
  • CountryDZ : CountryCodes.hpp
  • CountryEC : CountryCodes.hpp
  • CountryEE : CountryCodes.hpp
  • CountryEG : CountryCodes.hpp
  • CountryEH : CountryCodes.hpp
  • CountryER : CountryCodes.hpp
  • CountryES : CountryCodes.hpp
  • CountryET : CountryCodes.hpp
  • CountryFI : CountryCodes.hpp
  • CountryFJ : CountryCodes.hpp
  • CountryFK : CountryCodes.hpp
  • CountryFM : CountryCodes.hpp
  • CountryFO : CountryCodes.hpp
  • CountryFR : CountryCodes.hpp
  • CountryFX : CountryCodes.hpp
  • CountryGA : CountryCodes.hpp
  • CountryGB : CountryCodes.hpp
  • CountryGD : CountryCodes.hpp
  • CountryGE : CountryCodes.hpp
  • CountryGF : CountryCodes.hpp
  • CountryGH : CountryCodes.hpp
  • CountryGI : CountryCodes.hpp
  • CountryGL : CountryCodes.hpp
  • CountryGM : CountryCodes.hpp
  • CountryGN : CountryCodes.hpp
  • CountryGP : CountryCodes.hpp
  • CountryGQ : CountryCodes.hpp
  • CountryGR : CountryCodes.hpp
  • CountryGS : CountryCodes.hpp
  • CountryGT : CountryCodes.hpp
  • CountryGU : CountryCodes.hpp
  • CountryGW : CountryCodes.hpp
  • CountryGY : CountryCodes.hpp
  • CountryHK : CountryCodes.hpp
  • CountryHM : CountryCodes.hpp
  • CountryHN : CountryCodes.hpp
  • CountryHR : CountryCodes.hpp
  • CountryHT : CountryCodes.hpp
  • CountryHU : CountryCodes.hpp
  • CountryID : CountryCodes.hpp
  • CountryIE : CountryCodes.hpp
  • CountryIL : CountryCodes.hpp
  • CountryIN : CountryCodes.hpp
  • CountryInvalid : CountryCodes.hpp
  • CountryIO : CountryCodes.hpp
  • CountryIQ : CountryCodes.hpp
  • CountryIR : CountryCodes.hpp
  • CountryIS : CountryCodes.hpp
  • CountryIT : CountryCodes.hpp
  • CountryJM : CountryCodes.hpp
  • CountryJO : CountryCodes.hpp
  • CountryJP : CountryCodes.hpp
  • CountryKE : CountryCodes.hpp
  • CountryKG : CountryCodes.hpp
  • CountryKH : CountryCodes.hpp
  • CountryKI : CountryCodes.hpp
  • CountryKM : CountryCodes.hpp
  • CountryKN : CountryCodes.hpp
  • CountryKP : CountryCodes.hpp
  • CountryKR : CountryCodes.hpp
  • CountryKW : CountryCodes.hpp
  • CountryKY : CountryCodes.hpp
  • CountryKZ : CountryCodes.hpp
  • CountryLA : CountryCodes.hpp
  • CountryLB : CountryCodes.hpp
  • CountryLC : CountryCodes.hpp
  • CountryLI : CountryCodes.hpp
  • CountryLK : CountryCodes.hpp
  • CountryLR : CountryCodes.hpp
  • CountryLS : CountryCodes.hpp
  • CountryLT : CountryCodes.hpp
  • CountryLU : CountryCodes.hpp
  • CountryLV : CountryCodes.hpp
  • CountryLY : CountryCodes.hpp
  • CountryMA : CountryCodes.hpp
  • CountryMC : CountryCodes.hpp
  • CountryMD : CountryCodes.hpp
  • CountryMG : CountryCodes.hpp
  • CountryMH : CountryCodes.hpp
  • CountryMK : CountryCodes.hpp
  • CountryML : CountryCodes.hpp
  • CountryMM : CountryCodes.hpp
  • CountryMN : CountryCodes.hpp
  • CountryMO : CountryCodes.hpp
  • CountryMP : CountryCodes.hpp
  • CountryMQ : CountryCodes.hpp
  • CountryMR : CountryCodes.hpp
  • CountryMS : CountryCodes.hpp
  • CountryMT : CountryCodes.hpp
  • CountryMU : CountryCodes.hpp
  • CountryMV : CountryCodes.hpp
  • CountryMW : CountryCodes.hpp
  • CountryMX : CountryCodes.hpp
  • CountryMY : CountryCodes.hpp
  • CountryMZ : CountryCodes.hpp
  • CountryNA : CountryCodes.hpp
  • CountryNC : CountryCodes.hpp
  • CountryNE : CountryCodes.hpp
  • CountryNF : CountryCodes.hpp
  • CountryNG : CountryCodes.hpp
  • CountryNI : CountryCodes.hpp
  • CountryNL : CountryCodes.hpp
  • CountryNO : CountryCodes.hpp
  • CountryNP : CountryCodes.hpp
  • CountryNR : CountryCodes.hpp
  • CountryNU : CountryCodes.hpp
  • CountryNZ : CountryCodes.hpp
  • CountryOM : CountryCodes.hpp
  • CountryPA : CountryCodes.hpp
  • CountryPE : CountryCodes.hpp
  • CountryPF : CountryCodes.hpp
  • CountryPG : CountryCodes.hpp
  • CountryPH : CountryCodes.hpp
  • CountryPK : CountryCodes.hpp
  • CountryPL : CountryCodes.hpp
  • CountryPM : CountryCodes.hpp
  • CountryPN : CountryCodes.hpp
  • CountryPR : CountryCodes.hpp
  • CountryPT : CountryCodes.hpp
  • CountryPW : CountryCodes.hpp
  • CountryPY : CountryCodes.hpp
  • CountryQA : CountryCodes.hpp
  • CountryRE : CountryCodes.hpp
  • CountryRO : CountryCodes.hpp
  • CountryRU : CountryCodes.hpp
  • CountryRW : CountryCodes.hpp
  • CountrySA : CountryCodes.hpp
  • CountrySB : CountryCodes.hpp
  • CountrySC : CountryCodes.hpp
  • CountrySD : CountryCodes.hpp
  • CountrySE : CountryCodes.hpp
  • CountrySG : CountryCodes.hpp
  • CountrySH : CountryCodes.hpp
  • CountrySI : CountryCodes.hpp
  • CountrySJ : CountryCodes.hpp
  • CountrySK : CountryCodes.hpp
  • CountrySL : CountryCodes.hpp
  • CountrySM : CountryCodes.hpp
  • CountrySN : CountryCodes.hpp
  • CountrySO : CountryCodes.hpp
  • CountrySR : CountryCodes.hpp
  • CountryST : CountryCodes.hpp
  • CountrySV : CountryCodes.hpp
  • CountrySY : CountryCodes.hpp
  • CountrySZ : CountryCodes.hpp
  • CountryTC : CountryCodes.hpp
  • CountryTD : CountryCodes.hpp
  • CountryTF : CountryCodes.hpp
  • CountryTG : CountryCodes.hpp
  • CountryTH : CountryCodes.hpp
  • CountryTJ : CountryCodes.hpp
  • CountryTK : CountryCodes.hpp
  • CountryTM : CountryCodes.hpp
  • CountryTN : CountryCodes.hpp
  • CountryTO : CountryCodes.hpp
  • CountryTP : CountryCodes.hpp
  • CountryTR : CountryCodes.hpp
  • CountryTT : CountryCodes.hpp
  • CountryTV : CountryCodes.hpp
  • CountryTW : CountryCodes.hpp
  • CountryTZ : CountryCodes.hpp
  • CountryUA : CountryCodes.hpp
  • CountryUG : CountryCodes.hpp
  • CountryUM : CountryCodes.hpp
  • CountryUS : CountryCodes.hpp
  • CountryUY : CountryCodes.hpp
  • CountryUZ : CountryCodes.hpp
  • CountryVA : CountryCodes.hpp
  • CountryVC : CountryCodes.hpp
  • CountryVE : CountryCodes.hpp
  • CountryVG : CountryCodes.hpp
  • CountryVI : CountryCodes.hpp
  • CountryVN : CountryCodes.hpp
  • CountryVU : CountryCodes.hpp
  • CountryWF : CountryCodes.hpp
  • CountryWS : CountryCodes.hpp
  • CountryYE : CountryCodes.hpp
  • CountryYT : CountryCodes.hpp
  • CountryYU : CountryCodes.hpp
  • CountryZA : CountryCodes.hpp
  • CountryZM : CountryCodes.hpp
  • CountryZR : CountryCodes.hpp
  • CountryZW : CountryCodes.hpp
  • CpbcchEfPos : SimTkTypes.hpp
  • CphsAcm2EfPos : SimTkTypes.hpp
  • CphsCfufEfPos : SimTkTypes.hpp
  • CphsCsp2EfPos : SimTkTypes.hpp
  • CphsCspEfPos : SimTkTypes.hpp
  • CphsInfoNoPhoneBook : SignalTypes.hpp
  • CphsInfoNoPhoneBookCnt : SignalTypes.hpp
  • CphsInfumEfPos : SimTkTypes.hpp
  • CphsIstEfPos : SimTkTypes.hpp
  • CphsMboxEfPos : SimTkTypes.hpp
  • CphsMBoxPhoneBook : SignalTypes.hpp
  • CphsMBoxPhoneBookCnt : SignalTypes.hpp
  • CphsOnmEfPos : SimTkTypes.hpp
  • CphsOnsEfPos : SimTkTypes.hpp
  • CphsSrvstEfPos : SimTkTypes.hpp
  • CphsVmwfEfPos : SimTkTypes.hpp
  • CreateErr : FfsTestError.hpp
  • CrssHandlerId : HandlerId.hpp
  • CsdDataNt : SignalTypes.hpp
  • CsdDataT : SignalTypes.hpp
  • CsdFax : SignalTypes.hpp
  • CsdMultimedia : SignalTypes.hpp
  • CsdNone : SignalTypes.hpp
  • CsdVoice : SignalTypes.hpp
  • CsdWap : SignalTypes.hpp
  • CsPhoneBook : AtcTypes.hpp
  • ct_negative : DrmRelXml.hpp
  • ct_none : DrmRelXml.hpp
  • ct_positive : DrmRelXml.hpp
  • Cug : SignalTypes.hpp
  • CugCallFailure : SignalTypes.hpp
  • CugIndex : SignalTypes.hpp
  • CugIndexIncompatible : SignalTypes.hpp
  • CurrentLocation : LcsTypes.hpp
  • CurrentlyUnable : SimTkTypes.hpp
  • CurrentOrLastKnownLocation : LcsTypes.hpp
  • Cw : SignalTypes.hpp
  • CyclicFile : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- d -

  • Data : SignalTypes.hpp
  • DataAccessible : SimAccessor.hpp
  • DataAccessUndefined : SimAccessor.hpp
  • DataCall : SignalTypes.hpp
  • DataCallActive : SignalTypes.hpp
  • DataCallDetected : Types.hpp
  • DataCallRequired : Types.hpp
  • DataCda1200_75Bps : SignalTypes.hpp
  • DataCda1200Bps : SignalTypes.hpp
  • DataCda2400_Bps : SignalTypes.hpp
  • DataCda300Bps : SignalTypes.hpp
  • DataCda4800_Bps : SignalTypes.hpp
  • DataCda9600_Bps : SignalTypes.hpp
  • DataCds1200Bps : SignalTypes.hpp
  • DataCds2400Bps : SignalTypes.hpp
  • DataCds4800Bps : SignalTypes.hpp
  • DataCds9600Bps : SignalTypes.hpp
  • DataNotInitialized : SignalTypes.hpp
  • DataNotPresent : SimAccessor.hpp
  • DataPds2400Bps : SignalTypes.hpp
  • DataPds4800Bps : SignalTypes.hpp
  • DataPds9600Bps : SignalTypes.hpp
  • DateTimeType : DataItem.hpp
  • DateType : DataItem.hpp
  • DcPhoneBook : AtcTypes.hpp
  • DefaultBehavior : ScrollBehavior.hpp
  • DefaultBehaviour : Grid.hpp
  • DefaultMultiSlotCapability : NetworkTypes.hpp
  • DefaultTone : SignalTypes.hpp
  • DeleteAllPlmnAction : SignalTypes.hpp
  • DeletePlmnAction : SignalTypes.hpp
  • DestinationOutOfOrder : SignalTypes.hpp
  • Detected : NetworkTypes.hpp
  • DeviceBuzzer : SignalTypes.hpp
  • DeviceRingBuzzerVibrator : SignalTypes.hpp
  • DeviceSpeaker : SignalTypes.hpp
  • DeviceVibrator : SignalTypes.hpp
  • DialTone : SignalTypes.hpp
  • DialToneOn : SignalTypes.hpp
  • DisconnectDueToSimtkSetup : SignalTypes.hpp
  • DisplayPhoneNumber : SignalTypes.hpp
  • DontCare : SignalTypes.hpp
  • DrmAesDecryptionFail : DrmCore.hpp
  • DrmAllDefault : DrmCore.hpp
  • DrmCombinedDelivery : DrmCore.hpp
  • DrmCorruptMessage : DrmCore.hpp
  • DrmDatetimeDefault : DrmCore.hpp
  • DrmDcf : DrmCore.hpp
  • DrmDefaultConstraints : DrmCore.hpp
  • DrmEndDefault : DrmCore.hpp
  • DrmForwardLock : DrmCore.hpp
  • DrmForwardLockDcf : DrmCore.hpp
  • DrmInvalidAsset : DrmCore.hpp
  • DrmInvalidContainer : DrmCore.hpp
  • DrmInvalidLocalId : DrmCore.hpp
  • DrmInvalidOperation : DrmCore.hpp
  • DrmInvalidParams : DrmCore.hpp
  • DrmInvalidXmlFormat : DrmCore.hpp
  • DrmNoDefault : DrmCore.hpp
  • DrmNone : DrmCore.hpp
  • DrmNoRightsAvailable : DrmCore.hpp
  • DrmOpCount : DrmCore.hpp
  • DrmOpDisplay : DrmCore.hpp
  • DrmOpExecute : DrmCore.hpp
  • DrmOpPlay : DrmCore.hpp
  • DrmOpPrint : DrmCore.hpp
  • DrmOpRewind : DrmCore.hpp
  • DrmRightsNone : DrmRelparser.hpp
  • DrmRightsWbxml : DrmRelparser.hpp
  • DrmRightsXml : DrmRelparser.hpp
  • DrmRoWbxml : DrmCore.hpp
  • DrmRoXml : DrmCore.hpp
  • DrmStartDefault : DrmCore.hpp
  • DrmSuccess : DrmCore.hpp
  • DrmUnknown : DrmCore.hpp
  • dt_none : DrmRelXml.hpp
  • DtmfRejCallHeldOrMparty : SignalTypes.hpp
  • DtmfRejDataTransmission : SignalTypes.hpp
  • DtmfRejDuringMocSetup : SignalTypes.hpp
  • DtmfRejectedDueToSupTimerExpiry : SignalTypes.hpp
  • DtmfRejectedNoTchAvailable : SignalTypes.hpp
  • DtmfValue : PhoneNumber.hpp
  • DualServiceCallActive : SignalTypes.hpp
  • DynamicAlsFlags : Types.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- e -

  • e_bpp_buff_size : BtBppTypes.hpp
  • e_bpp_snd_media_basic_text : BtBppTypes.hpp
  • e_bpp_snd_media_gif : BtBppTypes.hpp
  • e_bpp_snd_media_icalendar : BtBppTypes.hpp
  • e_bpp_snd_media_jpeg : BtBppTypes.hpp
  • e_bpp_snd_media_pcl : BtBppTypes.hpp
  • e_bpp_snd_media_pdf : BtBppTypes.hpp
  • e_bpp_snd_media_post_script : BtBppTypes.hpp
  • e_bpp_snd_media_vcalendar : BtBppTypes.hpp
  • e_bpp_snd_media_vcard : BtBppTypes.hpp
  • e_bpp_snd_media_vmessage : BtBppTypes.hpp
  • e_bpp_snd_media_xhtml_print : BtBppTypes.hpp
  • EccEfPos : SimTkTypes.hpp
  • EccpEfPos : SimTkTypes.hpp
  • EccpRefresh : SignalTypes.hpp
  • EccSourceBuiltin : SignalTypes.hpp
  • EccSourceCustomized : SignalTypes.hpp
  • EccSourceNetwork : SignalTypes.hpp
  • EccSourceSim : SignalTypes.hpp
  • Ect : SignalTypes.hpp
  • EctActive : SignalTypes.hpp
  • EctAlerting : SignalTypes.hpp
  • EctRejected : SignalTypes.hpp
  • EctStarted : SignalTypes.hpp
  • EctVoidCallState : SignalTypes.hpp
  • ElpEfPos : SimTkTypes.hpp
  • EmApoxiAudioStateIdle : EmApoxiAudioDeviceImpl.cpp
  • EmApoxiAudioStatePaused : EmApoxiAudioDeviceImpl.cpp
  • EmApoxiAudioStatePlaying : EmApoxiAudioDeviceImpl.cpp
  • EmcFailed : NetworkTypes.hpp
  • EmcLockSCell : NetworkTypes.hpp
  • EmcSuccess : NetworkTypes.hpp
  • EmcTrigger3g2gHandover : NetworkTypes.hpp
  • EmcUnlockSCell : NetworkTypes.hpp
  • EmcUnsuported : NetworkTypes.hpp
  • EmergencyCall : SignalTypes.hpp
  • EmergencyCalls : SignalTypes.hpp
  • Emlpp : SignalTypes.hpp
  • EmlppActionType : InputAction.hpp
  • EmlppEfPos : SimTkTypes.hpp
  • EmlppHandlerId : HandlerId.hpp
  • EmlppPriorityLevel0 : SignalTypes.hpp
  • EmlppPriorityLevel1 : SignalTypes.hpp
  • EmlppPriorityLevel2 : SignalTypes.hpp
  • EmlppPriorityLevel3 : SignalTypes.hpp
  • EmlppPriorityLevel4 : SignalTypes.hpp
  • EmlppPriorityLevelA : SignalTypes.hpp
  • EmlppPriorityLevelB : SignalTypes.hpp
  • EmlppPriorityLevelVoid : SignalTypes.hpp
  • EndlessLoopBehavior : ScrollBehavior.hpp
  • EngModeActionType : InputAction.hpp
  • EosToken : InputParser.hpp
  • ErrorTone : SignalTypes.hpp
  • ExpansionValue : PhoneNumber.hpp
  • ExplicitCallTransfer : SignalTypes.hpp
  • Ext1EfPos : SimTkTypes.hpp
  • Ext1PhoneBookCnt : SignalTypes.hpp
  • Ext2EfPos : SimTkTypes.hpp
  • Ext2PhoneBookCnt : SignalTypes.hpp
  • Ext3EfPos : SimTkTypes.hpp
  • Ext4EfPos : SimTkTypes.hpp
  • Ext4PhoneBookCnt : SignalTypes.hpp
  • Ext6PhoneBookCnt : SignalTypes.hpp
  • Ext7PhoneBookCnt : SignalTypes.hpp
  • externalMsg : MsgCategory.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- f -

  • FacilityNotImplemented : SignalTypes.hpp
  • FacilityNotSubscribed : SignalTypes.hpp
  • FacilityRejected : SignalTypes.hpp
  • FacsimileCall : SignalTypes.hpp
  • FacsimileGroup3AndAlterSpeech : SignalTypes.hpp
  • FacsimileGroup4 : SignalTypes.hpp
  • FastSearchMode : NetworkTypes.hpp
  • FatChangedCard : FatTypes.hpp
  • FatErrorAccessDenied : FatTypes.hpp
  • FatErrorBadCard : FatTypes.hpp
  • FatErrorBadFileDescriptor : FatTypes.hpp
  • FatErrorBadFormat : FatTypes.hpp
  • FatErrorCardFailure : FatTypes.hpp
  • FatErrorEccError : FatTypes.hpp
  • FatErrorFailure : FatTypes.hpp
  • FatErrorFileAlreadyExist : FatTypes.hpp
  • FatErrorIdError : FatTypes.hpp
  • FatErrorIO : FatTypes.hpp
  • FatErrorNegativeFilePointer : FatTypes.hpp
  • FatErrorNoCard : FatTypes.hpp
  • FatErrorNoDisk : FatTypes.hpp
  • FatErrorNoSpace : FatTypes.hpp
  • FatErrorNotExist : FatTypes.hpp
  • FatErrorOperationNotPossible : FatTypes.hpp
  • FatErrorShare : FatTypes.hpp
  • FatErrorSuccess : FatTypes.hpp
  • FatErrorTooManyFileOpen : FatTypes.hpp
  • FatErrorUnknown : FatTypes.hpp
  • FatErrorUserIdError : FatTypes.hpp
  • FatFileAttrArchive : FatTypes.hpp
  • FatFileAttrChicagoExt : FatTypes.hpp
  • FatFileAttrDirectory : FatTypes.hpp
  • FatFileAttrHidden : FatTypes.hpp
  • FatFileAttrNormal : FatTypes.hpp
  • FatFileAttrRdOnly : FatTypes.hpp
  • FatFileAttrSystem : FatTypes.hpp
  • FatFileAttrVolume : FatTypes.hpp
  • FatReadAndWriteMode : FatTypes.hpp
  • FatReadOnlyMode : FatTypes.hpp
  • Fax : PbTypes.hpp
  • Fdd : NetworkTypes.hpp
  • FdnEfPos : SimTkTypes.hpp
  • FdnFailed : SignalTypes.hpp
  • FdnNotPossible : NetworkTypes.hpp
  • FdnOff : NetworkTypes.hpp
  • FdnOn : NetworkTypes.hpp
  • FdnPhoneBook : SignalTypes.hpp
  • FdnPhoneBookCnt : SignalTypes.hpp
  • FFS_ALL_FILETYPES : FfsSim.hpp
  • FFS_ALREADY_OPEN : FfsSim.hpp
  • FFS_APCON01 : FfsSim.hpp
  • FFS_APCON02 : FfsSim.hpp
  • FFS_APCON03 : FfsSim.hpp
  • FFS_APCON04 : FfsSim.hpp
  • FFS_APCON05 : FfsSim.hpp
  • FFS_APCON06 : FfsSim.hpp
  • FFS_APCON07 : FfsSim.hpp
  • FFS_APCON08 : FfsSim.hpp
  • FFS_APCON09 : FfsSim.hpp
  • FFS_APCON10 : FfsSim.hpp
  • FFS_APCON11 : FfsSim.hpp
  • FFS_APCON12 : FfsSim.hpp
  • FFS_APCON13 : FfsSim.hpp
  • FFS_APCON14 : FfsSim.hpp
  • FFS_APCON15 : FfsSim.hpp
  • FFS_ATC : FfsSim.hpp
  • FFS_AUDIO : FfsSim.hpp
  • FFS_DIR_SPACE_NOT_AVAILABLE : FfsSim.hpp
  • FFS_DWDIO : FfsSim.hpp
  • FFS_EXISTS : FfsSim.hpp
  • FFS_FALSE : FfsSim.hpp
  • FFS_FILE_NOT_FOUND : FfsSim.hpp
  • FFS_FILE_OPEN_APPEND : FfsSim.hpp
  • FFS_FILE_OPEN_MODIFY : FfsSim.hpp
  • FFS_FILE_OPEN_READ : FfsSim.hpp
  • FFS_FILE_OPEN_READ_STREAMING : FfsSim.hpp
  • FFS_FILE_RANGE_ERROR : FfsSim.hpp
  • FFS_FILETYPE_3GP : FfsSim.hpp
  • FFS_FILETYPE_AAC : FfsSim.hpp
  • FFS_FILETYPE_AAN : FfsSim.hpp
  • FFS_FILETYPE_AIM : FfsSim.hpp
  • FFS_FILETYPE_AMR : FfsSim.hpp
  • FFS_FILETYPE_APOXI_SETTING : FfsSim.hpp
  • FFS_FILETYPE_AVI : FfsSim.hpp
  • FFS_FILETYPE_BMP : FfsSim.hpp
  • FFS_FILETYPE_BROWSER_CACHE : FfsSim.hpp
  • FFS_FILETYPE_BROWSER_DATBASE : FfsSim.hpp
  • FFS_FILETYPE_DRM : FfsSim.hpp
  • FFS_FILETYPE_DRM_RO : FfsSim.hpp
  • FFS_FILETYPE_EMS_BMP : FfsSim.hpp
  • FFS_FILETYPE_FR : FfsSim.hpp
  • FFS_FILETYPE_FRAME : FfsSim.hpp
  • FFS_FILETYPE_GARBAGE : FfsSim.hpp
  • FFS_FILETYPE_GIF : FfsSim.hpp
  • FFS_FILETYPE_HTM : FfsSim.hpp
  • FFS_FILETYPE_HTML : FfsSim.hpp
  • FFS_FILETYPE_ICS : FfsSim.hpp
  • FFS_FILETYPE_IMELODY : FfsSim.hpp
  • FFS_FILETYPE_JAD : FfsSim.hpp
  • FFS_FILETYPE_JAM_BACKUP : FfsSim.hpp
  • FFS_FILETYPE_JAM_DEFAULT : FfsSim.hpp
  • FFS_FILETYPE_JAR : FfsSim.hpp
  • FFS_FILETYPE_JPE : FfsSim.hpp
  • FFS_FILETYPE_JPEG : FfsSim.hpp
  • FFS_FILETYPE_JPG : FfsSim.hpp
  • FFS_FILETYPE_JRS : FfsSim.hpp
  • FFS_FILETYPE_M4A : FfsSim.hpp
  • FFS_FILETYPE_MIDI : FfsSim.hpp
  • FFS_FILETYPE_MMF : FfsSim.hpp
  • FFS_FILETYPE_MMF_PHRASE : FfsSim.hpp
  • FFS_FILETYPE_MMI_SETTING : FfsSim.hpp
  • FFS_FILETYPE_MMS : FfsSim.hpp
  • FFS_FILETYPE_MMS_APP_REPORT : FfsSim.hpp
  • FFS_FILETYPE_MMS_BACKUP : FfsSim.hpp
  • FFS_FILETYPE_MMS_NOTIFICATION : FfsSim.hpp
  • FFS_FILETYPE_MMS_PRE : FfsSim.hpp
  • FFS_FILETYPE_MMS_REPORTS : FfsSim.hpp
  • FFS_FILETYPE_MMS_STORAGE : FfsSim.hpp
  • FFS_FILETYPE_MMS_TEST : FfsSim.hpp
  • FFS_FILETYPE_MMT : FfsSim.hpp
  • FFS_FILETYPE_MOV : FfsSim.hpp
  • FFS_FILETYPE_MP3 : FfsSim.hpp
  • FFS_FILETYPE_MPE : FfsSim.hpp
  • FFS_FILETYPE_MPEG : FfsSim.hpp
  • FFS_FILETYPE_MPG : FfsSim.hpp
  • FFS_FILETYPE_MPGA : FfsSim.hpp
  • FFS_FILETYPE_MYSTUFF : FfsSim.hpp
  • FFS_FILETYPE_PNG : FfsSim.hpp
  • FFS_FILETYPE_PUSH_MESSAGES : FfsSim.hpp
  • FFS_FILETYPE_REGISTRY : FfsSim.hpp
  • FFS_FILETYPE_SAF : FfsSim.hpp
  • FFS_FILETYPE_SECURITY_CERTIFICATES : FfsSim.hpp
  • FFS_FILETYPE_SETTINGS : FfsSim.hpp
  • FFS_FILETYPE_SMS : FfsSim.hpp
  • FFS_FILETYPE_SPF : FfsSim.hpp
  • FFS_FILETYPE_SVG : FfsSim.hpp
  • FFS_FILETYPE_SVGZ : FfsSim.hpp
  • FFS_FILETYPE_TIF : FfsSim.hpp
  • FFS_FILETYPE_TXT : FfsSim.hpp
  • FFS_FILETYPE_VCF : FfsSim.hpp
  • FFS_FILETYPE_WAP_SETTING : FfsSim.hpp
  • FFS_FILETYPE_WAV : FfsSim.hpp
  • FFS_FILETYPE_WBMP : FfsSim.hpp
  • FFS_FILETYPE_WML : FfsSim.hpp
  • FFS_FILETYPE_WMLS : FfsSim.hpp
  • FFS_FILETYPE_XHTML : FfsSim.hpp
  • FFS_FILETYPE_XML : FfsSim.hpp
  • FFS_GENERIC_FILETYPE : FfsSim.hpp
  • FFS_ILLIGAL_DIR_OPERATION : FfsSim.hpp
  • FFS_ILLIGAL_FILE_HANDLE : FfsSim.hpp
  • FFS_ILLIGAL_ID : FfsSim.hpp
  • FFS_ILLIGAL_MODE : FfsSim.hpp
  • FFS_ILLIGAL_TYPE : FfsSim.hpp
  • FFS_INITIALIZING : FfsSim.hpp
  • FFS_INTERNAL : FfsSim.hpp
  • FFS_INTERNAL_FATAL_ERROR : FfsSim.hpp
  • FFS_INVALID_NAME : FfsSim.hpp
  • FFS_JAVA : FfsSim.hpp
  • FFS_MAX_NOF_FILES_EXCEEDED : FfsSim.hpp
  • FFS_MEM_TABLES_INCONSISTENCY : FfsSim.hpp
  • FFS_MEMORY_RES_ERROR : FfsSim.hpp
  • FFS_MMI : FfsSim.hpp
  • FFS_MMS : FfsSim.hpp
  • FFS_MP3 : FfsSim.hpp
  • FFS_NOF_FILETYPES : FfsSim.hpp
  • FFS_NOF_RES_ID : FfsSim.hpp
  • FFS_NOF_USERS : FfsSim.hpp
  • FFS_NOT_A_FACTORY_DEFAULT_FILE : FfsSim.hpp
  • FFS_NOT_OPEN : FfsSim.hpp
  • FFS_OPERATION_NOT_ALLOWED_ON_STATIC_FILE : FfsSim.hpp
  • FFS_OPERATION_NOT_POSSIBLE : FfsSim.hpp
  • FFS_REQUESTED_MEM_NOT_AVAILABLE : FfsSim.hpp
  • FFS_REQUESTED_MEM_TEMP_NOT_AVAILABLE : FfsSim.hpp
  • FFS_SMS : FfsSim.hpp
  • FFS_STREAMING_NOT_ENABLED : FfsSim.hpp
  • FFS_SUCCESS : FfsSim.hpp
  • FFS_TRUE : FfsSim.hpp
  • FFS_USER_ID_ERROR : FfsSim.hpp
  • FFS_VR : FfsSim.hpp
  • FFS_WAP : FfsSim.hpp
  • FFS_WRITE_ERROR : FfsSim.hpp
  • FfsDeleteFileErr : FfsTestError.hpp
  • FfsErrorAlreadyOpen : FfsTypes.hpp
  • FfsErrorFalse : FfsTypes.hpp
  • FfsErrorFileAlreadyCreated : FfsTypes.hpp
  • FfsErrorFileNotFound : FfsTypes.hpp
  • FfsErrorFileRangeError : FfsTypes.hpp
  • FfsErrorIllegalFileHandle : FfsTypes.hpp
  • FfsErrorIllegalId : FfsTypes.hpp
  • FfsErrorIllegalMode : FfsTypes.hpp
  • FfsErrorIllegalType : FfsTypes.hpp
  • FfsErrorInitializing : FfsTypes.hpp
  • FfsErrorIntFatalError : FfsTypes.hpp
  • FfsErrorInvalidFilename : FfsTypes.hpp
  • FfsErrorMaxNrOfFilesExcceeded : FfsTypes.hpp
  • FfsErrorMemoryResError : FfsTypes.hpp
  • FfsErrorMemTablesInconsistent : FfsTypes.hpp
  • FfsErrorNoFactoryDefaultFile : FfsTypes.hpp
  • FfsErrorNotOpen : FfsTypes.hpp
  • FfsErrorNotPossible : FfsTypes.hpp
  • FfsErrorOpNotAllowedOnStatFile : FfsTypes.hpp
  • FfsErrorReqMemNotAvailable : FfsTypes.hpp
  • FfsErrorReqMemTempNotAvailable : FfsTypes.hpp
  • FfsErrorStreamingNotEnabled : FfsTypes.hpp
  • FfsErrorSuccess : FfsTypes.hpp
  • FfsErrorTrue : FfsTypes.hpp
  • FfsErrorUserIdError : FfsTypes.hpp
  • FfsErrorWriteError : FfsTypes.hpp
  • FfsFileType3gp : FfsTypes.hpp
  • FfsFileTypeAac : FfsTypes.hpp
  • FfsFileTypeAan : FfsTypes.hpp
  • FfsFileTypeAim : FfsTypes.hpp
  • FfsFileTypeAll : FfsTypes.hpp
  • FfsFileTypeAmr : FfsTypes.hpp
  • FfsFileTypeApoxiSetting : FfsTypes.hpp
  • FfsFileTypeAvi : FfsTypes.hpp
  • FfsFileTypeBmp : FfsTypes.hpp
  • FfsFileTypeBrowserCache : FfsTypes.hpp
  • FfsFileTypeBrowserDatabase : FfsTypes.hpp
  • FfsFileTypeDrm : FfsTypes.hpp
  • FfsFileTypeDrmRo : FfsTypes.hpp
  • FfsFileTypeEmsBmp : FfsTypes.hpp
  • FfsFileTypeFr : FfsTypes.hpp
  • FfsFileTypeFrame : FfsTypes.hpp
  • FfsFileTypeGarbage : FfsTypes.hpp
  • FfsFileTypeGeneric : FfsTypes.hpp
  • FfsFileTypeGif : FfsTypes.hpp
  • FfsFileTypeHtm : FfsTypes.hpp
  • FfsFileTypeHtml : FfsTypes.hpp
  • FfsFileTypeIcs : FfsTypes.hpp
  • FfsFileTypeIMelody : FfsTypes.hpp
  • FfsFileTypeJad : FfsTypes.hpp
  • FfsFileTypeJamBackup : FfsTypes.hpp
  • FfsFileTypeJamDefault : FfsTypes.hpp
  • FfsFileTypeJar : FfsTypes.hpp
  • FfsFileTypeJpe : FfsTypes.hpp
  • FfsFileTypeJpeg : FfsTypes.hpp
  • FfsFileTypeJpg : FfsTypes.hpp
  • FfsFileTypeJrs : FfsTypes.hpp
  • FfsFileTypeM4a : FfsTypes.hpp
  • FfsFileTypeMidi : FfsTypes.hpp
  • FfsFileTypeMmf : FfsTypes.hpp
  • FfsFileTypeMmfPhrase : FfsTypes.hpp
  • FfsFileTypeMmiSetting : FfsTypes.hpp
  • FfsFileTypeMms : FfsTypes.hpp
  • FfsFileTypeMmsAppReport : FfsTypes.hpp
  • FfsFileTypeMmsBackup : FfsTypes.hpp
  • FfsFileTypeMmsNotification : FfsTypes.hpp
  • FfsFileTypeMmsPre : FfsTypes.hpp
  • FfsFileTypeMmsReports : FfsTypes.hpp
  • FfsFileTypeMmsStorage : FfsTypes.hpp
  • FfsFileTypeMmsTest : FfsTypes.hpp
  • FfsFileTypeMmt : FfsTypes.hpp
  • FfsFileTypeMov : FfsTypes.hpp
  • FfsFileTypeMp3 : FfsTypes.hpp
  • FfsFileTypeMpe : FfsTypes.hpp
  • FfsFileTypeMpeg : FfsTypes.hpp
  • FfsFileTypeMpg : FfsTypes.hpp
  • FfsFileTypeMpga : FfsTypes.hpp
  • FfsFileTypeMyStuff : FfsTypes.hpp
  • FfsFileTypePng : FfsTypes.hpp
  • FfsFileTypePushMessages : FfsTypes.hpp
  • FfsFileTypeRegistry : FfsTypes.hpp
  • FfsFileTypeSaf : FfsTypes.hpp
  • FfsFileTypeSecurityCertificates : FfsTypes.hpp
  • FfsFileTypeSettings : FfsTypes.hpp
  • FfsFileTypeSms : FfsTypes.hpp
  • FfsFileTypeSpf : FfsTypes.hpp
  • FfsFileTypeSvg : FfsTypes.hpp
  • FfsFileTypeSvgz : FfsTypes.hpp
  • FfsFileTypeTif : FfsTypes.hpp
  • FfsFileTypeTxt : FfsTypes.hpp
  • FfsFileTypeVcf : FfsTypes.hpp
  • FfsFileTypeWapSetting : FfsTypes.hpp
  • FfsFileTypeWav : FfsTypes.hpp
  • FfsFileTypeWbmp : FfsTypes.hpp
  • FfsFileTypeWml : FfsTypes.hpp
  • FfsFileTypeWmls : FfsTypes.hpp
  • FfsFileTypeXhtml : FfsTypes.hpp
  • FfsFileTypeXml : FfsTypes.hpp
  • FfsMemAllocErr : FfsTestError.hpp
  • FfsNofFileTypes : FfsTypes.hpp
  • FfsNofResId : FfsTypes.hpp
  • FfsNofUsers : FfsTypes.hpp
  • FfsOpenModeAppend : FfsTypes.hpp
  • FfsOpenModeModify : FfsTypes.hpp
  • FfsOpenModeRead : FfsTypes.hpp
  • FfsOpenModeReadStr : FfsTypes.hpp
  • FfsTestOK : FfsTestError.hpp
  • FfsUserTypeAppCon01 : FfsTypes.hpp
  • FfsUserTypeAppCon02 : FfsTypes.hpp
  • FfsUserTypeAppCon03 : FfsTypes.hpp
  • FfsUserTypeAppCon04 : FfsTypes.hpp
  • FfsUserTypeAppCon05 : FfsTypes.hpp
  • FfsUserTypeAppCon06 : FfsTypes.hpp
  • FfsUserTypeAppCon07 : FfsTypes.hpp
  • FfsUserTypeAppCon08 : FfsTypes.hpp
  • FfsUserTypeAppCon09 : FfsTypes.hpp
  • FfsUserTypeAppCon10 : FfsTypes.hpp
  • FfsUserTypeAppCon11 : FfsTypes.hpp
  • FfsUserTypeAppCon12 : FfsTypes.hpp
  • FfsUserTypeAppCon13 : FfsTypes.hpp
  • FfsUserTypeAppCon14 : FfsTypes.hpp
  • FfsUserTypeAppCon15 : FfsTypes.hpp
  • FfsUserTypeAtc : FfsTypes.hpp
  • FfsUserTypeAudio : FfsTypes.hpp
  • FfsUserTypeDwdIo : FfsTypes.hpp
  • FfsUserTypeJava : FfsTypes.hpp
  • FfsUserTypeMmi : FfsTypes.hpp
  • FfsUserTypeMms : FfsTypes.hpp
  • FfsUserTypeMp3 : FfsTypes.hpp
  • FfsUserTypeSms : FfsTypes.hpp
  • FfsUserTypeVr : FfsTypes.hpp
  • FfsUserTypeWap : FfsTypes.hpp
  • FileCopyErr : FfsTestError.hpp
  • FileRefresh : SignalTypes.hpp
  • FileRenameErr : FfsTestError.hpp
  • FileSizeErr : FfsTestError.hpp
  • FINAL_REPORT : SocketTestT.hpp
  • Fm : SignalTypes.hpp
  • ForwardingSsActionType : InputAction.hpp
  • FriendFinder : LcsFeatTypes.hpp
  • FS_FFS_DEVICE : FatSim.hpp
  • FS_FTL_DEVICE1 : FatSim.hpp
  • FS_MMCSD_DEV : FatSim.hpp
  • FS_MS_connect : FatSim.hpp
  • FS_MS_disconnect : FatSim.hpp
  • FS_TEST_DEVICE1 : FatSim.hpp
  • FS_TEST_DEVICE2 : FatSim.hpp
  • FS_TEST_DEVICE3 : FatSim.hpp
  • FsFatFfsDev : FatTypes.hpp
  • FsMmcSdDev : FatTypes.hpp
  • FsNandDev : FatTypes.hpp
  • FullTchNeeded : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- g -

  • G2ATraining : VrTypes.hpp
  • gday : DrmRelXml.hpp
  • GeneralBeep : SignalTypes.hpp
  • GenericType : DataItem.hpp
  • GLTP : LcsTypes.hpp
  • gmonth : DrmRelXml.hpp
  • GPP : LcsTypes.hpp
  • GprsClassA : NetworkTypes.hpp
  • GprsClassB : NetworkTypes.hpp
  • GprsClassC : NetworkTypes.hpp
  • GprsClassCc : NetworkTypes.hpp
  • GprsClassCg : NetworkTypes.hpp
  • GprsGsmNotAllowed : SignalTypes.hpp
  • GprsNoClass : NetworkTypes.hpp
  • GprsNotAllowed : SignalTypes.hpp
  • GprsPlmnNotAllowed : SignalTypes.hpp
  • GpsReceiver : LcsFeatTypes.hpp
  • gr_Action_in_contradiction_with_current_timer : SimTkTypes.hpp
  • gr_Backward_move_requested_by_user : SimTkTypes.hpp
  • gr_Bearer_independent_protocol_error : SimTkTypes.hpp
  • gr_Command_beyond_ME_capabilities : SimTkTypes.hpp
  • gr_Command_data_not_understood_by_ME : SimTkTypes.hpp
  • gr_Command_number_not_known_by_ME : SimTkTypes.hpp
  • gr_Command_performed_but_modified_by_SIM : SimTkTypes.hpp
  • gr_Command_performed_successfully : SimTkTypes.hpp
  • gr_Command_performed_successfully_but_icon_not_disp : SimTkTypes.hpp
  • gr_Command_performed_successfully_but_limited_service : SimTkTypes.hpp
  • gr_Command_performed_with_missing_information : SimTkTypes.hpp
  • gr_Command_performed_with_modification : SimTkTypes.hpp
  • gr_Command_performed_with_partial_comprehension : SimTkTypes.hpp
  • gr_Command_type_not_understood_by_ME : SimTkTypes.hpp
  • gr_Error_required_values_missing : SimTkTypes.hpp
  • gr_Help_information_required_by_user : SimTkTypes.hpp
  • gr_Interaction_with_SIM_permanent_problem : SimTkTypes.hpp
  • gr_Interaction_with_SIM_temporary_problem : SimTkTypes.hpp
  • gr_Launch_browser_generic_error : SimTkTypes.hpp
  • gr_ME_currently_unable : SimTkTypes.hpp
  • gr_MultipleCard_error : SimTkTypes.hpp
  • gr_Network_currently_unable : SimTkTypes.hpp
  • gr_No_response_from_user : SimTkTypes.hpp
  • gr_Proactive_SIM_Session_terminated_by_user : SimTkTypes.hpp
  • gr_Refresh_performed_with_add_EFs_read : SimTkTypes.hpp
  • gr_SMS_rp_error : SimTkTypes.hpp
  • gr_SS_return_error : SimTkTypes.hpp
  • gr_ss_transaction_terminated_by_user : SimTkTypes.hpp
  • gr_User_cleared_call_before_network_release : SimTkTypes.hpp
  • gr_User_did_not_accept_proactive_command : SimTkTypes.hpp
  • gr_USSD_error : SimTkTypes.hpp
  • GraphicsDfPos : SimTkTypes.hpp
  • Gsm : NetworkTypes.hpp
  • Gsm1800 : NetworkTypes.hpp
  • Gsm1800_1900 : NetworkTypes.hpp
  • Gsm1900 : NetworkTypes.hpp
  • Gsm900 : NetworkTypes.hpp
  • Gsm900_1800 : NetworkTypes.hpp
  • Gsm900_1800_1900 : NetworkTypes.hpp
  • Gsm900_1900 : NetworkTypes.hpp
  • GsmAuthUnacceptable : SignalTypes.hpp
  • GsmBand1800 : NetworkTypes.hpp
  • GsmBand1900 : NetworkTypes.hpp
  • GsmBand450 : NetworkTypes.hpp
  • GsmBand480 : NetworkTypes.hpp
  • GsmBand850 : NetworkTypes.hpp
  • GsmBand900 : NetworkTypes.hpp
  • GsmBand900E : NetworkTypes.hpp
  • GsmBand900P : NetworkTypes.hpp
  • GsmBand900R : NetworkTypes.hpp
  • GsmMultiband : NetworkTypes.hpp
  • GsmNoCause : SignalTypes.hpp
  • GsmSignalQualityMax : SignalTypes.hpp
  • GsmSignalStrengthMax : SignalTypes.hpp
  • gyear : DrmRelXml.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- h -

  • HalfTchData : SignalTypes.hpp
  • HalfTchSpeech : SignalTypes.hpp
  • Handover : NetworkTypes.hpp
  • HashToken : InputParser.hpp
  • HcsCriteriaPrio : NetworkTypes.hpp
  • HcsHValue : NetworkTypes.hpp
  • HeldCallDetected : Types.hpp
  • HeldCallRequired : Types.hpp
  • HelloAckRxed : GltpTypes.hpp
  • HelpInfo : SimTkTypes.hpp
  • High : LcsTypes.hpp
  • Hold : SignalTypes.hpp
  • HoldActiveCall : SignalTypes.hpp
  • HoldMparty : SignalTypes.hpp
  • HoldRequestRejected : Types.hpp
  • Home : PbTypes.hpp
  • Horizontal : Grid.hpp
  • Hplmn_search_fail : NetworkTypes.hpp
  • HplmnWact : SimTkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- i -

  • IeMissing : SignalTypes.hpp
  • IllegalMe : SignalTypes.hpp
  • IllegalMs : SignalTypes.hpp
  • ImeiNotAccepted : SignalTypes.hpp
  • ImeiShowActionType : InputAction.hpp
  • Imm_ass_reject : NetworkTypes.hpp
  • ImpDetached : SignalTypes.hpp
  • ImsiEfPos : SimTkTypes.hpp
  • ImsiUnknownInHlr : SignalTypes.hpp
  • ImsiUnknownInVlr : SignalTypes.hpp
  • InBandTonesAvailable : SignalTypes.hpp
  • InBandTonesNotAvailable : SignalTypes.hpp
  • IncomingCallsBarredInCug : SignalTypes.hpp
  • IncommingRefuseDirection : SignalTypes.hpp
  • IncompatibleDestination : SignalTypes.hpp
  • InContradictionWithChvStatus : SignalTypes.hpp
  • InfElemNotExists : SignalTypes.hpp
  • InitialLocation : LcsTypes.hpp
  • InsertPlmnAction : SignalTypes.hpp
  • InteractionWithCallControlBySimTemporaryProblem : SimTkTypes.hpp
  • InterceptToneon : SignalTypes.hpp
  • internalMsg : MsgCategory.hpp
  • Interworking : SignalTypes.hpp
  • Invalid_plmn : NetworkTypes.hpp
  • Invalid_reg_state : NetworkTypes.hpp
  • InvalidActionType : InputAction.hpp
  • InvalidAlsLine : SignalTypes.hpp
  • InvalidBasicService : Types.hpp
  • InvalidCallIndex : Types.hpp
  • InvalidCallRelatedSs : SignalTypes.hpp
  • InvalidCallRelatedSsState : SignalTypes.hpp
  • InvalidChargingStatus : SignalTypes.hpp
  • InvalidEntry : HostAudioDriver.hpp
  • InvalidGprsClass : NetworkTypes.hpp
  • InvalidGsmBand : NetworkTypes.hpp
  • InvalidGsmService : NetworkTypes.hpp
  • InvalidLine : SignalTypes.hpp
  • InvalidMandatoryInformation : SignalTypes.hpp
  • InvalidMmiServiceGroup : Types.hpp
  • InvalidMmRrReason : NetworkTypes.hpp
  • InvalidMptyMemberCount : Types.hpp
  • InvalidNumberFormat : SignalTypes.hpp
  • InvalidOpMode : NetworkTypes.hpp
  • InvalidParam : SignalTypes.hpp
  • InvalidPhoneBook : AtcTypes.hpp
  • InvalidPhoneBookCnt : SignalTypes.hpp
  • InvalidPhoneNumber : Types.hpp
  • InvalidPriority : Types.hpp
  • InvalidProperty : VrTypes.hpp
  • InvalidRatChangeMode : NetworkTypes.hpp
  • InvalidSearchMode : NetworkTypes.hpp
  • InvalidServiceCode : Types.hpp
  • InvalidSms : SimPduHandler.hpp
  • InvalidSmsPortNo : InformationElement.hpp
  • InvalidTi : SignalTypes.hpp
  • InvalidTimeOut : Types.hpp
  • InvalidTimer : LcsTimer.hpp
  • InvalidTipd : Types.hpp
  • InvalidToken : InputParser.hpp
  • InvalidTransitNetwork : SignalTypes.hpp
  • InvManIe : SignalTypes.hpp
  • InvokeCallDeflection : SignalTypes.hpp
  • InvScanEfPos : SimTkTypes.hpp
  • IsEct : SignalTypes.hpp
  • IsolatedWordRecognition : VrTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- p -

  • PacketSwitched : NetworkTypes.hpp
  • PacketSwitchedPreferred : NetworkTypes.hpp
  • PadAccessCa1200_75Bps : SignalTypes.hpp
  • PadAccessCa1200Bps : SignalTypes.hpp
  • PadAccessCa2400Bps : SignalTypes.hpp
  • PadAccessCa300Bps : SignalTypes.hpp
  • PadAccessCa4800Bps : SignalTypes.hpp
  • PadAccessCa9600Bps : SignalTypes.hpp
  • ParityEven : LcsTypes.hpp
  • ParityNone : LcsTypes.hpp
  • ParityOdd : LcsTypes.hpp
  • PartlyConcatenetedSms : SimPduHandler.hpp
  • PasswordChangeSsActionType : InputAction.hpp
  • PbEntryShowActionType : InputAction.hpp
  • PbRequestAutomatic : SignalTypes.hpp
  • PbRequestEmpty : SignalTypes.hpp
  • PbRequestMMI : SignalTypes.hpp
  • PchMs : PdpTypes.hpp
  • PchNw : PdpTypes.hpp
  • PcmPlayCallBack : HostAudioDriver.hpp
  • PcmRecCallBack : HostAudioDriver.hpp
  • PcmRetCode : HostAudioDriver.hpp
  • PdpIpDynamicType : PdpTypes.hpp
  • PdpIpStaticType : PdpTypes.hpp
  • PdpIpType : PdpTypes.hpp
  • PdpNoType : PdpTypes.hpp
  • PdpOspihType : PdpTypes.hpp
  • PdpPppType : PdpTypes.hpp
  • PdpX25Type : PdpTypes.hpp
  • Pending : LcsReqProcessor.hpp
  • PendingSimtkSetup : SignalTypes.hpp
  • Permanent : SignalTypes.hpp
  • PermissionDenied : LcsDecls.hpp
  • PermissionGranted : LcsDecls.hpp
  • PhaseEfPos : SimTkTypes.hpp
  • PhoneBookRefresh : SignalTypes.hpp
  • PhoneNumberType : DataItem.hpp
  • PinActionType : InputAction.hpp
  • PlayAmr : HostAudioDriver.hpp
  • Playback_Finish : HostAudioDriver.hpp
  • Playback_Stopped : HostAudioDriver.hpp
  • PlayMp3 : HostAudioDriver.hpp
  • PlayPcm : HostAudioDriver.hpp
  • PlmnEfPos : SimTkTypes.hpp
  • PlmnForbidden : NetworkTypes.hpp
  • PlmnHandlerId : HandlerId.hpp
  • PlmnListScan : NetworkTypes.hpp
  • PlmnNotAllowed : SignalTypes.hpp
  • PlmnNotForbidden : NetworkTypes.hpp
  • PlmnNotProvided : NetworkTypes.hpp
  • PlmnProvided : NetworkTypes.hpp
  • PlmnRefresh : SignalTypes.hpp
  • PlmnScanOff : NetworkTypes.hpp
  • PlmnSpecificBs1 : SignalTypes.hpp
  • PlmnSpecificBs2 : SignalTypes.hpp
  • PlmnSpecificBs3 : SignalTypes.hpp
  • PlmnSpecificBs4 : SignalTypes.hpp
  • PlmnSpecificBs5 : SignalTypes.hpp
  • PlmnSpecificBs6 : SignalTypes.hpp
  • PlmnSpecificBs7 : SignalTypes.hpp
  • PlmnSpecificBs8 : SignalTypes.hpp
  • PlmnSpecificBs9 : SignalTypes.hpp
  • PlmnSpecificBsA : SignalTypes.hpp
  • PlmnSpecificBsB : SignalTypes.hpp
  • PlmnSpecificBsC : SignalTypes.hpp
  • PlmnSpecificBsD : SignalTypes.hpp
  • PlmnSpecificBsE : SignalTypes.hpp
  • PlmnSpecificBsF : SignalTypes.hpp
  • PlmnSpecificTs1 : SignalTypes.hpp
  • PlmnSpecificTs2 : SignalTypes.hpp
  • PlmnSpecificTs3 : SignalTypes.hpp
  • PlmnSpecificTs4 : SignalTypes.hpp
  • PlmnSpecificTs5 : SignalTypes.hpp
  • PlmnSpecificTs6 : SignalTypes.hpp
  • PlmnSpecificTs7 : SignalTypes.hpp
  • PlmnSpecificTs8 : SignalTypes.hpp
  • PlmnSpecificTs9 : SignalTypes.hpp
  • PlmnSpecificTsA : SignalTypes.hpp
  • PlmnSpecificTsB : SignalTypes.hpp
  • PlmnSpecificTsC : SignalTypes.hpp
  • PlmnSpecificTsD : SignalTypes.hpp
  • PlmnSpecificTsE : SignalTypes.hpp
  • PlmnSpecificTsF : SignalTypes.hpp
  • PlmnWactEfPos : SimTkTypes.hpp
  • PositionDataReceived : GltpTypes.hpp
  • PositiveAckTone : SignalTypes.hpp
  • PowerHandlerId : HandlerId.hpp
  • PowerOffMode : SignalTypes.hpp
  • PowerSavingMode1 : NetworkTypes.hpp
  • PreferedCug : SignalTypes.hpp
  • PresentationRestricted : SignalTypes.hpp
  • ProactiveSimApplTerminatedByUser : SignalTypes.hpp
  • ProtErrUnspecified : SignalTypes.hpp
  • ProtocolError : SignalTypes.hpp
  • ProviderType : DataItem.hpp
  • PsAtc : NetworkTypes.hpp
  • PsInvalid : NetworkTypes.hpp
  • PsMmi : NetworkTypes.hpp
  • PsNet : NetworkTypes.hpp
  • PsOm : NetworkTypes.hpp
  • PtstMode : SignalTypes.hpp
  • PuctEfPos : SimTkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- q -

  • QualityUnavailable : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- r -

  • Ra_fail : NetworkTypes.hpp
  • RadioPathAck : SignalTypes.hpp
  • RadioPathNotAvail : SignalTypes.hpp
  • RamErrorAccessDenied : RamTypes.hpp
  • RamErrorBadFileDescriptor : RamTypes.hpp
  • RamErrorFileAlreadyExist : RamTypes.hpp
  • RamErrorNegativeFilePointer : RamTypes.hpp
  • RamErrorNoSpace : RamTypes.hpp
  • RamErrorNotExist : RamTypes.hpp
  • RamErrorOperationNotPossible : RamTypes.hpp
  • RamErrorShare : RamTypes.hpp
  • RamErrorSuccess : RamTypes.hpp
  • RamFileAttrAll : RamTypes.hpp
  • RamFileAttrArchive : RamTypes.hpp
  • RamFileAttrDirectory : RamTypes.hpp
  • RamFileAttrHidden : RamTypes.hpp
  • RamFileAttrNormal : RamTypes.hpp
  • RamFileAttrRdOnly : RamTypes.hpp
  • RamFileAttrSystem : RamTypes.hpp
  • RamFileAttrVolume : RamTypes.hpp
  • RamOpenModeRead : RamTypes.hpp
  • RamOpenModeWrite : RamTypes.hpp
  • RatChangeModeDual : NetworkTypes.hpp
  • RatChangeModeGsm : NetworkTypes.hpp
  • RatChangeModeUmts : NetworkTypes.hpp
  • RatGsm : NetworkTypes.hpp
  • RatNotAvailable : NetworkTypes.hpp
  • RatUmts : NetworkTypes.hpp
  • RcPhoneBook : AtcTypes.hpp
  • RdnNumberNotAvailable : SignalTypes.hpp
  • RdnPresentationAllowedAddr : SignalTypes.hpp
  • RdnPresentationRestrictAddr : SignalTypes.hpp
  • RdnPresentationRestricted : SignalTypes.hpp
  • RdnVoidChoice : SignalTypes.hpp
  • RdPhoneBook : AtcTypes.hpp
  • ReadErr : FfsTestError.hpp
  • ReadSmsFilterType : SimPduHandler.hpp
  • ReceivedOnAnyAlerting : SignalTypes.hpp
  • ReceivedOnAnyConnect : SignalTypes.hpp
  • ReceivedOnAnyDisconnect : SignalTypes.hpp
  • ReceivedOnAnyRelease : SignalTypes.hpp
  • ReceivedOnAnyReleaseComplete : SignalTypes.hpp
  • ReceivedOnAnySetup : SignalTypes.hpp
  • ReceivedOnProgress : SignalTypes.hpp
  • RecordAmr : HostAudioDriver.hpp
  • Recording_Finish : HostAudioDriver.hpp
  • RecordPcm : HostAudioDriver.hpp
  • RecoveryOnTimerExpiry : SignalTypes.hpp
  • ReferenceError : SignalTypes.hpp
  • RefreshPerformedWithAdditionalEFsRead : SimTkTypes.hpp
  • RefreshSyncFromClient : DBService.hpp
  • RefreshSyncFromServer : DBService.hpp
  • RegBlobFileNode : RegNodeFile.hpp
  • RegBlobNode : RegNodeFile.hpp
  • RegBooleanNode : RegNodeFile.hpp
  • RegChangeTypeAdd : RegistryTypes.hpp
  • RegChangeTypeDelete : RegistryTypes.hpp
  • RegChangeTypeReplace : RegistryTypes.hpp
  • RegChangeTypeSftDel : RegistryTypes.hpp
  • RegChangeTypeUnknown : RegistryTypes.hpp
  • RegDataFormatB64 : RegistryTypes.hpp
  • RegDataFormatBool : RegistryTypes.hpp
  • RegDataFormatChar : RegistryTypes.hpp
  • RegDataFormatInt : RegistryTypes.hpp
  • RegDataFormatNode : RegistryTypes.hpp
  • RegDataFormatNull : RegistryTypes.hpp
  • RegDataFormatXml : RegistryTypes.hpp
  • RegFileTypeBackup : RegDefines.hpp
  • RegFileTypeBlob : RegDefines.hpp
  • RegFileTypeDirty : RegDefines.hpp
  • RegFileTypeMap : RegDefines.hpp
  • RegFileTypeNode : RegDefines.hpp
  • RegFileTypeRootFile : RegDefines.hpp
  • RegIntegerNode : RegNodeFile.hpp
  • RegInteriorNode : RegNodeFile.hpp
  • RegisterModeUnavailable : NetworkTypes.hpp
  • RegistrationFailure : NetworkTypes.hpp
  • RegistrationMode : SignalTypes.hpp
  • RegNoNode : RegNodeFile.hpp
  • RegResChildLocked : RegistryTypes.hpp
  • RegResError : RegistryTypes.hpp
  • RegResInsufficientBuffer : RegistryTypes.hpp
  • RegResLocked : RegistryTypes.hpp
  • RegResNoData : RegistryTypes.hpp
  • RegResNodeAlreadyExists : RegistryTypes.hpp
  • RegResNoGetOnInterior : RegistryTypes.hpp
  • RegResNoService : RegistryTypes.hpp
  • RegResSuccess : RegistryTypes.hpp
  • RegResTypeNotSupported : RegistryTypes.hpp
  • RegResUnlocked : RegistryTypes.hpp
  • Regst_cs_connection : NetworkTypes.hpp
  • Regst_indep_registration : NetworkTypes.hpp
  • Regst_plmn_selection : NetworkTypes.hpp
  • Regst_ps_suspended : NetworkTypes.hpp
  • Regst_search_for_network : NetworkTypes.hpp
  • Regst_user_attach_pending : NetworkTypes.hpp
  • Regst_user_detach_pending : NetworkTypes.hpp
  • RegStringNode : RegNodeFile.hpp
  • RejByCallControl : SignalTypes.hpp
  • RejectCall : Types.hpp
  • Rejected : SignalTypes.hpp
  • RelAllActiveCalls : SignalTypes.hpp
  • RelAllHeldCalls : SignalTypes.hpp
  • RelSpecificActiveCall : SignalTypes.hpp
  • RemoteHold : MsgArgs.hpp
  • RemoteMbuild : MsgArgs.hpp
  • RemoteRetrieve : MsgArgs.hpp
  • REPORT : SocketTestT.hpp
  • ReportingTimer : NetworkTypes.hpp
  • ReqeustedCircuitNotAvailable : SignalTypes.hpp
  • ReqServNotDescr : SignalTypes.hpp
  • RequiredValuesAreMissing : SimTkTypes.hpp
  • ReselAbnormalResel : NetworkTypes.hpp
  • ReselBetterC2C32 : NetworkTypes.hpp
  • ReselC1LessNull : NetworkTypes.hpp
  • ReselCallReestTimeout : NetworkTypes.hpp
  • ReselCellChangeOrder : NetworkTypes.hpp
  • ReselDownlinkFail : NetworkTypes.hpp
  • ReselNotOccurred : NetworkTypes.hpp
  • ReselPlmnChange : NetworkTypes.hpp
  • ReselRaFailure : NetworkTypes.hpp
  • ReselSiReceiptFailure : NetworkTypes.hpp
  • RESPONSE : SocketTestT.hpp
  • ResponseToStatusEnquiry : SignalTypes.hpp
  • RessourcesUnavailable : SignalTypes.hpp
  • RestrictedOperation : SignalTypes.hpp
  • RetrieveCall : SignalTypes.hpp
  • RetrieveMparty : SignalTypes.hpp
  • RetrieveRequestRejected : Types.hpp
  • RetryOnNewCellBeg : SignalTypes.hpp
  • RetryOnNewCellEnd : SignalTypes.hpp
  • Rfu : SignalTypes.hpp
  • RingBackToneOn : SignalTypes.hpp
  • RingingTone : SignalTypes.hpp
  • RotateBehavior : ScrollBehavior.hpp
  • RotateBehaviour : Grid.hpp
  • RrcAttachNotAllowed : NetworkTypes.hpp
  • RrcAttachTempBarred : NetworkTypes.hpp
  • RrcAuthFailure : NetworkTypes.hpp
  • RrcDetached : NetworkTypes.hpp
  • RrcDisabled : NetworkTypes.hpp
  • RrcForbLai : NetworkTypes.hpp
  • RrcForbPlmn : NetworkTypes.hpp
  • RrcInternalFailure : NetworkTypes.hpp
  • RrcInvalidParameter : NetworkTypes.hpp
  • RrcInvalidSim : NetworkTypes.hpp
  • RrcNoCarrier : NetworkTypes.hpp
  • RrcNoCause : NetworkTypes.hpp
  • RrcNoCell : NetworkTypes.hpp
  • RrcNotRegistered : NetworkTypes.hpp
  • RrcNRegReq : NetworkTypes.hpp
  • RrcPlmnSearch : NetworkTypes.hpp
  • RrcPlmnSearchEnded : NetworkTypes.hpp
  • RrcPowerDown : NetworkTypes.hpp
  • RrcRejByNetwork : NetworkTypes.hpp
  • RrModeGsm : NetworkTypes.hpp
  • RrModeUmts : NetworkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- s -

  • ScActivate : SignalTypes.hpp
  • ScBuildMpty : SignalTypes.hpp
  • ScDeactivate : SignalTypes.hpp
  • ScErase : SignalTypes.hpp
  • ScExplicitCt : SignalTypes.hpp
  • ScForwardChargeAdvice : SignalTypes.hpp
  • ScForwardCheckIndication : SignalTypes.hpp
  • ScForwardCugInfo : SignalTypes.hpp
  • ScGetPassword : SignalTypes.hpp
  • ScInterrogate : SignalTypes.hpp
  • ScNotify : SignalTypes.hpp
  • ScProcessUssd : SignalTypes.hpp
  • ScProcessUssdRequest : SignalTypes.hpp
  • ScreenBusy : SimTkTypes.hpp
  • ScRegister : SignalTypes.hpp
  • ScRegisterPassword : SignalTypes.hpp
  • ScRetrieveMpty : SignalTypes.hpp
  • ScScHoldMpty : SignalTypes.hpp
  • ScSetupUusText : SignalTypes.hpp
  • ScSplitMpty : SignalTypes.hpp
  • ScUssdNotify : SignalTypes.hpp
  • ScUssdRequest : SignalTypes.hpp
  • SdnEfPos : SimTkTypes.hpp
  • SdnPhoneBook : SignalTypes.hpp
  • SdnPhoneBookCnt : SignalTypes.hpp
  • SdPhoneBook : AtcTypes.hpp
  • SecAtLock : LockTypes.hpp
  • SecChangePwdLock : LockTypes.hpp
  • SecContinueOperation : LockTypes.hpp
  • SecControlKeyError : LockTypes.hpp
  • SecCorporateLock : LockTypes.hpp
  • SecDepersSmsLock : LockTypes.hpp
  • SecGetProfileLock : LockTypes.hpp
  • SecImeiInvalid : LockTypes.hpp
  • SecLockActive : LockTypes.hpp
  • SecLockArmed : LockTypes.hpp
  • SecLockAutoActivated : LockTypes.hpp
  • SecLockBlocked : LockTypes.hpp
  • SecLockDeactive : LockTypes.hpp
  • SecLockDisabled : LockTypes.hpp
  • SecLockError : LockTypes.hpp
  • SecLockInvalid : LockTypes.hpp
  • SecLockLastState : LockTypes.hpp
  • SecLockLocked : LockTypes.hpp
  • SecLockPermanentActive : LockTypes.hpp
  • SecLockUnlocked : LockTypes.hpp
  • SecNetworkLock : LockTypes.hpp
  • SecNetworkSubsetLock : LockTypes.hpp
  • SecNofLock : LockTypes.hpp
  • SecNofTypes : LockTypes.hpp
  • SecNoFurtherOperation : LockTypes.hpp
  • SecNoMoreTrials : LockTypes.hpp
  • SecondCallMissing : Types.hpp
  • SecPersCodeError : LockTypes.hpp
  • SecPfLock : LockTypes.hpp
  • SecProfileUpdate : LockTypes.hpp
  • SecRefreshLock : LockTypes.hpp
  • SecSimLock : LockTypes.hpp
  • SecSpLock : LockTypes.hpp
  • SecStartupLock : LockTypes.hpp
  • SecStorageError : LockTypes.hpp
  • SecSucceded : LockTypes.hpp
  • SecUnauthorisized : LockTypes.hpp
  • SecUnknownResult : LockTypes.hpp
  • SecUnlockAction : LockTypes.hpp
  • SecurityError : SignalTypes.hpp
  • SecVerificationNeeded : LockTypes.hpp
  • SemanticsIncorrect : SignalTypes.hpp
  • SemIncorrMsg : SignalTypes.hpp
  • SEND_TCP : SocketTestT.hpp
  • SEND_UDP : SocketTestT.hpp
  • SendOnAlerting : SignalTypes.hpp
  • SendOnAny : SignalTypes.hpp
  • SendOnConnect : SignalTypes.hpp
  • SendOnDisconnect : SignalTypes.hpp
  • SendOnRelease : SignalTypes.hpp
  • SendOnReleaseComplete : SignalTypes.hpp
  • SendOnSetup : SignalTypes.hpp
  • SentSmsFilterType : SimPduHandler.hpp
  • ServerAlertedSync : DBService.hpp
  • ServiceCardSim : SignalTypes.hpp
  • ServiceDetached : NetworkTypes.hpp
  • ServiceDisabled : NetworkTypes.hpp
  • ServiceNotAvailable : SignalTypes.hpp
  • ServiceNotImplemented : SignalTypes.hpp
  • ServiceNotSupported : SignalTypes.hpp
  • ServiceTempOutOfOrder : SignalTypes.hpp
  • SetupCallDetected : Types.hpp
  • SetupConfirmation : MmTypes.hpp
  • ShortMessageMoPp : SignalTypes.hpp
  • ShortMessageMtPp : SignalTypes.hpp
  • SiBearerCsd : SimTkTypes.hpp
  • SiBearerDefault : SimTkTypes.hpp
  • SiBearerGprs : SimTkTypes.hpp
  • SiBearerUndef : SimTkTypes.hpp
  • SiChannelChanged1 : SimTkTypes.hpp
  • SiChannelChanged2 : SimTkTypes.hpp
  • SiChannelChanged3 : SimTkTypes.hpp
  • SiChannelChanged4 : SimTkTypes.hpp
  • SiChannelChangedNoInfo : SimTkTypes.hpp
  • SiChannelChangedToDropped : SimTkTypes.hpp
  • SiChannelClosedBySat : SimTkTypes.hpp
  • SiChannelClosedByUser : SimTkTypes.hpp
  • SiChannelCloseRej : SimTkTypes.hpp
  • SiChannelCloseUndef : SimTkTypes.hpp
  • SiDtmfType : SignalTypes.hpp
  • SigHandlerId : HandlerId.hpp
  • SilentResetMode : SignalTypes.hpp
  • Sim2G : SignalTypes.hpp
  • Sim3G : SignalTypes.hpp
  • SimAcm : Types.hpp
  • SimAcmMax : Types.hpp
  • SimAdnPhonebook : Types.hpp
  • SimAll : Types.hpp
  • SimApplicationErrorP1P2 : SignalTypes.hpp
  • SimApplicationErrorP3 : SignalTypes.hpp
  • SimBasicImageCoding : ImageData.hpp
  • SimBdnPhonebook : Types.hpp
  • SimCbmi : Types.hpp
  • SimCbmiRange : Types.hpp
  • SimCcp : Types.hpp
  • SimColorImageCoding : ImageData.hpp
  • SimContradictInvalidState : SignalTypes.hpp
  • SimContradictWithChvState : SignalTypes.hpp
  • SimCphsCsp : Types.hpp
  • SimCphsInfo : Types.hpp
  • SimCphsInfoNoPhonebook : Types.hpp
  • SimCphsMBoxPhonebook : Types.hpp
  • SimCphsOpName : Types.hpp
  • SimCphsOpShortName : Types.hpp
  • SimEcc : Types.hpp
  • SimError : SignalTypes.hpp
  • SimExtMemoryExceeded : SignalTypes.hpp
  • SimFdnPhonebook : Types.hpp
  • SimFullAccess : SignalTypes.hpp
  • SimHandlerId : HandlerId.hpp
  • SimImageHeader : ImageData.hpp
  • SimImageHeaderBody : ImageData.hpp
  • SimImageHeaderBodyClut : ImageData.hpp
  • SimImageHeaderClut : ImageData.hpp
  • SimImsi : Types.hpp
  • SimInconsistentCmd : SignalTypes.hpp
  • SimInvalidAddress : SignalTypes.hpp
  • SimKeyInvalid : SimTkTypes.hpp
  • SimKeyNo : SimTkTypes.hpp
  • SimKeyYes : SimTkTypes.hpp
  • SimLndPhonebook : Types.hpp
  • SimLocked : SimLockTypes.hpp
  • SimMbdnPhonebook : Types.hpp
  • SimMemRetrySuccess : SignalTypes.hpp
  • SimMsisdnPhonebook : Types.hpp
  • SimNoAttemptLeft : SignalTypes.hpp
  • SimNoChvInitialized : SignalTypes.hpp
  • SimNoEfChoosen : SignalTypes.hpp
  • SimNotPresent : SignalTypes.hpp
  • SimNotSet : SignalTypes.hpp
  • SimPreferedExtLanguages : Types.hpp
  • SimPreferedLanguages : Types.hpp
  • SimPreferedPlmns : Types.hpp
  • SimPresent : SignalTypes.hpp
  • SimPuct : Types.hpp
  • SimReady : SignalTypes.hpp
  • SimReadyForRegistration : SignalTypes.hpp
  • SimSdnPhonebook : Types.hpp
  • SimServiceAdn : SstProvider.hpp
  • SimServiceAoc : SstProvider.hpp
  • SimServiceBdn : SstProvider.hpp
  • SimServiceCbmi : SstProvider.hpp
  • SimServiceCbmiRanges : SstProvider.hpp
  • SimServiceCfis : SstProvider.hpp
  • SimServiceChv1Disable : SstProvider.hpp
  • SimServiceFdn : SstProvider.hpp
  • SimServiceImages : SstProvider.hpp
  • SimServiceInvalid : SstProvider.hpp
  • SimServiceLnd : SstProvider.hpp
  • SimServiceMbdn : SstProvider.hpp
  • SimServiceMexe : SstProvider.hpp
  • SimServiceMsisdn : SstProvider.hpp
  • SimServiceMwis : SstProvider.hpp
  • SimServiceOpl : SstProvider.hpp
  • SimServicePlmnwAct : SstProvider.hpp
  • SimServicePnn : SstProvider.hpp
  • SimServicePrefPlmn : SstProvider.hpp
  • SimServiceSdn : SstProvider.hpp
  • SimServiceSms : SstProvider.hpp
  • SimServiceSmsParameter : SstProvider.hpp
  • SimServiceSpdi : SstProvider.hpp
  • SimServiceSpn : SstProvider.hpp
  • SimSms : Types.hpp
  • SimSmsParameters : Types.hpp
  • SimSmsReady : SignalTypes.hpp
  • SimSpn : Types.hpp
  • SimSst : Types.hpp
  • SimStatusFailure : SignalTypes.hpp
  • SimSuccessBeyondEnd : SignalTypes.hpp
  • SimTechnicalProblem : SignalTypes.hpp
  • SimtkCallConnected : SignalTypes.hpp
  • SimtkCallConnectedNoIconDisplay : SignalTypes.hpp
  • SimTkHandlerId : HandlerId.hpp
  • SimTkLceHandlerId : HandlerId.hpp
  • SimtkSetupModeNotSupported : SignalTypes.hpp
  • SimtkSetupRejByUser : SignalTypes.hpp
  • SimtkSetupRejMissingAcmInfoInd : SignalTypes.hpp
  • SimtkSetupRejPendingSimtkSetup : SignalTypes.hpp
  • SimtkSetupRejTimeOut : SignalTypes.hpp
  • SimtkSimReset : SignalTypes.hpp
  • SimTkSuccessful : SimTkTypes.hpp
  • SimToolkitBusy : SignalTypes.hpp
  • SimToolkitCallSetupFailed : Types.hpp
  • SimToolkitResponeError : SignalTypes.hpp
  • SimTpdus : SimPduHandler.hpp
  • SimulResetMode : SignalTypes.hpp
  • SimUnblocked : SignalTypes.hpp
  • SimUnknownInstruction : SignalTypes.hpp
  • SimUnlocked : SimLockTypes.hpp
  • SimWrongInstructionClass : SignalTypes.hpp
  • SiNoSsType : SignalTypes.hpp
  • SiSendDataImmediately : SimTkTypes.hpp
  • SiSendDataStoreInBuffer : SimTkTypes.hpp
  • SiSsType : SignalTypes.hpp
  • SiTrLayerRaw : SimTkTypes.hpp
  • SiTrLayerTcp : SimTkTypes.hpp
  • SiTrLayerUdp : SimTkTypes.hpp
  • SiUnknownError : SignalTypes.hpp
  • SiUssdType : SignalTypes.hpp
  • SiUssdTypeEarlyUsage : SignalTypes.hpp
  • SlowTwoWaySync : DBService.hpp
  • SmsDeleteRead : SimPduHandler.hpp
  • SmsDeleteSent : SimPduHandler.hpp
  • SmsDeleteUnread : SimPduHandler.hpp
  • SmsDeleteUnsent : SimPduHandler.hpp
  • SmsDisableMoreMessages : SignalTypes.hpp
  • SmsEfPos : SimTkTypes.hpp
  • SmsEnableMoreMessages : SignalTypes.hpp
  • SmsEnableMoreMessagesUntilTimerExpiry : SignalTypes.hpp
  • SmsHandlerId : HandlerId.hpp
  • SmsParameterRefresh : SignalTypes.hpp
  • SmspEfPos : SimTkTypes.hpp
  • SmsrEfPos : SimTkTypes.hpp
  • SmsRefresh : SignalTypes.hpp
  • SmsReportTpdus : SimPduHandler.hpp
  • SmsRpError : SimTkTypes.hpp
  • SmssEfPos : SimTkTypes.hpp
  • SmsTextItemType_Email : SmsTextParser.hpp
  • SmsTextItemType_PhoneNumber : SmsTextParser.hpp
  • SmsTextItemType_Url : SmsTextParser.hpp
  • SmsUndefinedMoreMessages : SignalTypes.hpp
  • SpeakerAdaption : VrTypes.hpp
  • SpeakerDependentTraining : VrTypes.hpp
  • Speech : SignalTypes.hpp
  • SpeechCallActive : SignalTypes.hpp
  • SpeechCallRequired : Types.hpp
  • SpeechMtcAccepted : SignalTypes.hpp
  • SpeechTonesAvailable : SignalTypes.hpp
  • SpeechTonesNotAvailable : SignalTypes.hpp
  • SplitMparty : SignalTypes.hpp
  • SpnEfPos : SimTkTypes.hpp
  • SsBaseHandlerId : HandlerId.hpp
  • SsBasicServiceGroupListInterrogate : SignalTypes.hpp
  • SsCcbsHandlerId : HandlerId.hpp
  • SscDataDownloadResponse : Tlv.hpp
  • SscIncorrectParameterP1_P2 : Tlv.hpp
  • SscIncorrectParameterP3 : Tlv.hpp
  • SsCliRestrictInfoInterrogate : SignalTypes.hpp
  • SscMemoryManagementResponse : Tlv.hpp
  • SscNormalEnding : Tlv.hpp
  • SscNormalEndingExtra : Tlv.hpp
  • SscOtherResponse : Tlv.hpp
  • SscPostponedResponse : Tlv.hpp
  • SscReferencingManagementResponse : Tlv.hpp
  • SscSecurityManagementResponse : Tlv.hpp
  • SscTechnicalProblem : Tlv.hpp
  • SscUnknownInstruction : Tlv.hpp
  • SscWrongInstruction : Tlv.hpp
  • SsDataLocked : Types.hpp
  • SsForwardToNoInterrogate : SignalTypes.hpp
  • SsForwwardFeatureListInterrogate : SignalTypes.hpp
  • SsHandlerId : HandlerId.hpp
  • SsMainHandlerId : HandlerId.hpp
  • SsReturnError : SimTkTypes.hpp
  • SsStatusInterrogate : SignalTypes.hpp
  • SstEfPos : SimTkTypes.hpp
  • SsVoidInterrogate : SignalTypes.hpp
  • ST_ERR_ALLOCATION : SocketTestDefines.hpp
  • ST_ERR_CLOSE : SocketTestDefines.hpp
  • ST_ERR_NOT_ALL_PACKETS_RECEIVED : SocketTestDefines.hpp
  • ST_ERR_SERVER_SOCK_LISTEN : SocketTestDefines.hpp
  • ST_ERR_SET_DATACONN_PROFILE_ID : SocketTestDefines.hpp
  • ST_ERR_SOCKALLOC : SocketTestDefines.hpp
  • ST_ERR_USERINTERRUPT : SocketTestDefines.hpp
  • ST_ERR_WRITESOCK_CONTEXT : SocketTestDefines.hpp
  • ST_ERR_WRITESOCK_UNKNOWN : SocketTestDefines.hpp
  • ST_ERR_WRONGDATA : SocketTestDefines.hpp
  • stand_alone : LcsTypes.hpp
  • STAND_ALONE : LcsTypes.hpp
  • StarToken : InputParser.hpp
  • STOP_ALL : SocketTestT.hpp
  • STOP_TCP : SocketTestT.hpp
  • STOP_UDP : SocketTestT.hpp
  • StopMp3 : HostAudioDriver.hpp
  • StopPlayAmr : HostAudioDriver.hpp
  • StopPlayPcm : HostAudioDriver.hpp
  • StopRecAmr : HostAudioDriver.hpp
  • StopRecPcm : HostAudioDriver.hpp
  • StringCmpErr : FfsTestError.hpp
  • StringToken : InputParser.hpp
  • StringType : DataItem.hpp
  • SubscriberBusy : Types.hpp
  • Success : Types.hpp
  • SuccessfulButIconNotDisplayed : SimTkTypes.hpp
  • Successfull : SignalTypes.hpp
  • SuccessInvalidExt : SignalTypes.hpp
  • SupplementaryServiceChangedToMoc : Types.hpp
  • SupplementaryServiceChangedToSs : Types.hpp
  • SupplementaryServiceChangedToUssd : Types.hpp
  • SupplementaryServiceDenied : Types.hpp
  • SupplementaryServiceFailed : Types.hpp
  • SupplementaryServiceNotPending : Types.hpp
  • SupplementaryServiceNotSupported : Types.hpp
  • SupplementaryServicePending : Types.hpp
  • SuppressPhoneNumber : SignalTypes.hpp
  • SValue : NetworkTypes.hpp
  • SwapRequestRejected : Types.hpp
  • SwitchCongestion : SignalTypes.hpp
  • SynchFailure : SignalTypes.hpp
  • SyncMLItemAdded : SyncMLManager.hpp
  • SyncMLItemDeleted : SyncMLManager.hpp
  • SyncMLItemDeletedAll : SyncMLManager.hpp
  • SyncMLItemModified : SyncMLManager.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- t -

  • tdiffhour : DrmRelXml.hpp
  • tdiffmin : DrmRelXml.hpp
  • TeleAndBearerServices : SignalTypes.hpp
  • Telephony : SignalTypes.hpp
  • TeleService : SignalTypes.hpp
  • TempForbiddenCallAttempt : SignalTypes.hpp
  • TempForbiddenCallAttemptLimitedServe : SignalTypes.hpp
  • TempForbiddenCallAttemptNoService : SignalTypes.hpp
  • TemporaryDefaultAllowed : SignalTypes.hpp
  • TemporaryDefaultRestricted : SignalTypes.hpp
  • TemporaryFailure : SignalTypes.hpp
  • TerminateByUser : SimTkTypes.hpp
  • ThirdGeneration : NetworkTypes.hpp
  • ThirdPartyRootPublicKey : SimAuxHandler.hpp
  • thour : DrmRelXml.hpp
  • TimeType : DataItem.hpp
  • tmin : DrmRelXml.hpp
  • TocCloseChannel : Tlv.hpp
  • TocDisplayText : Tlv.hpp
  • TocEndOfProactiveSession : Tlv.hpp
  • TocGetChannelStatus : Tlv.hpp
  • TocGetInkey : Tlv.hpp
  • TocGetInput : Tlv.hpp
  • TocGetReaderStatus : Tlv.hpp
  • TocInvalid : Tlv.hpp
  • TocLanguageNotification : Tlv.hpp
  • TocLaunchBrowser : Tlv.hpp
  • TocMoreTime : Tlv.hpp
  • TocOpenChannel : Tlv.hpp
  • TocPerformCardApdu : Tlv.hpp
  • TocPlayTone : Tlv.hpp
  • TocPollingOff : Tlv.hpp
  • TocPollIntervall : Tlv.hpp
  • TocPowerOffCard : Tlv.hpp
  • TocPowerOnCard : Tlv.hpp
  • TocProvideLocalInformation : Tlv.hpp
  • TocReceiveData : Tlv.hpp
  • TocRefresh : Tlv.hpp
  • TocRunAtCommand : Tlv.hpp
  • TocSelectItem : Tlv.hpp
  • TocSendData : Tlv.hpp
  • TocSendDtmf : Tlv.hpp
  • TocSendShortMessage : Tlv.hpp
  • TocSendSs : Tlv.hpp
  • TocSendUssd : Tlv.hpp
  • TocSetupCall : Tlv.hpp
  • TocSetUpEventList : Tlv.hpp
  • TocSetupIdleModeText : Tlv.hpp
  • TocSetupMenu : Tlv.hpp
  • TocTimerManagement : Tlv.hpp
  • TonesOff : SignalTypes.hpp
  • TopReachedRepaintHint : Grid.hpp
  • TransactionFailed : SignalTypes.hpp
  • TranscationNotSupported : SignalTypes.hpp
  • TransparentFile : SignalTypes.hpp
  • tsec : DrmRelXml.hpp
  • Tty45_5 : Types.hpp
  • Tty50_0 : Types.hpp
  • TtyAuto : Types.hpp
  • TtyHco : Types.hpp
  • TtyModeUnknown : Types.hpp
  • TtyOff : Types.hpp
  • TtySpeedUnknown : Types.hpp
  • TtyVco : Types.hpp
  • TwoStopBits : LcsTypes.hpp
  • TwoWaySync : DBService.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- u -

  • Ubd115200 : LcsTypes.hpp
  • Ubd19200 : LcsTypes.hpp
  • Ubd230400 : LcsTypes.hpp
  • Ubd2400 : LcsTypes.hpp
  • Ubd38400 : LcsTypes.hpp
  • Ubd460800 : LcsTypes.hpp
  • Ubd4800 : LcsTypes.hpp
  • Ubd57600 : LcsTypes.hpp
  • Ubd921600 : LcsTypes.hpp
  • Ubd9600 : LcsTypes.hpp
  • UcAbortByUser : NetworkTypes.hpp
  • UcAttachService : NetworkTypes.hpp
  • UcDetachService : NetworkTypes.hpp
  • UcDisableService : NetworkTypes.hpp
  • UcEnableService : NetworkTypes.hpp
  • UcInvalidSim : NetworkTypes.hpp
  • UcNotAllowed : NetworkTypes.hpp
  • UcNotPossible : NetworkTypes.hpp
  • UcPowerDown : NetworkTypes.hpp
  • UcUserReselection : NetworkTypes.hpp
  • UdbEight : LcsTypes.hpp
  • UdbFive : LcsTypes.hpp
  • UdbSeven : LcsTypes.hpp
  • UdbSix : LcsTypes.hpp
  • UfcHardware : LcsTypes.hpp
  • UfcNone : LcsTypes.hpp
  • UfcXonXoff : LcsTypes.hpp
  • UmtsCell : NetworkTypes.hpp
  • UmtsNotRanked : NetworkTypes.hpp
  • UmtsRanked : NetworkTypes.hpp
  • UmtsSignalQualityMax : SignalTypes.hpp
  • UmtsSignalStrengthMax : SignalTypes.hpp
  • UnassignedNumber : SignalTypes.hpp
  • UnblockingBlocked : SignalTypes.hpp
  • Undefined : SignalTypes.hpp
  • UndefinedCallEstCause : SignalTypes.hpp
  • UndefinedOperation : SignalTypes.hpp
  • UndefinedRefreshType : SignalTypes.hpp
  • UndefinedSsActionType : InputAction.hpp
  • UndefinedType : DataItem.hpp
  • UnexpectedIe : SignalTypes.hpp
  • UnexpectedMsgType : SignalTypes.hpp
  • UnexpectedResult : Types.hpp
  • UnknowMsgType1 : SignalTypes.hpp
  • UnknownCugIndex : SignalTypes.hpp
  • UnknownDiagnosticCause : SignalTypes.hpp
  • UnknownErrorCause : SignalTypes.hpp
  • UnknownMsgType2 : SignalTypes.hpp
  • UnknownSerivceGroup : SignalTypes.hpp
  • UnkownServiceInd : SignalTypes.hpp
  • UnkownSsCode : SignalTypes.hpp
  • UnlockActionType : InputAction.hpp
  • UnreadSmsFilterType : SimPduHandler.hpp
  • UnrestrictedOperation : SignalTypes.hpp
  • UnsentSmsFilterType : SimPduHandler.hpp
  • UnspecifedRc : Types.hpp
  • Unsuccessfull : SignalTypes.hpp
  • UrrcParamReq : NetworkTypes.hpp
  • UrrcTestCountReq : NetworkTypes.hpp
  • UserAlertingNoAnser : SignalTypes.hpp
  • UserBusy : SignalTypes.hpp
  • UserClearedDownCallBeforeConnectionOrNetworkRelease : SimTkTypes.hpp
  • UserDefinedActionType : InputAction.hpp
  • UserDidNotAcceptCallSetupRequest : SimTkTypes.hpp
  • UserDisconnetion : Types.hpp
  • UserNotInCug : SignalTypes.hpp
  • UserResumed : SignalTypes.hpp
  • UserSuspended : SignalTypes.hpp
  • UsimLangDefault : SignalTypes.hpp
  • UsimPbAas : UsimPbTypes.hpp
  • UsimPbAnr : UsimPbTypes.hpp
  • UsimPbApplication : UsimPbTypes.hpp
  • UsimPbBufferIsNull : UsimPbTypes.hpp
  • UsimPbBufferTooSmall : UsimPbTypes.hpp
  • UsimPbCcp1 : UsimPbTypes.hpp
  • UsimPbDataTypeMismatch : UsimPbTypes.hpp
  • UsimPbEmail : UsimPbTypes.hpp
  • UsimPbExt1 : UsimPbTypes.hpp
  • UsimPbGas : UsimPbTypes.hpp
  • UsimPbGlobal : UsimPbTypes.hpp
  • UsimPbIndication : UsimPbTypes.hpp
  • UsimPbInvalidAdd : UsimPbTypes.hpp
  • UsimPbInvalidRef : UsimPbTypes.hpp
  • UsimPbNoFreeRecord : UsimPbTypes.hpp
  • UsimPbNotExisting : UsimPbTypes.hpp
  • UsimPbNotLoaded : UsimPbTypes.hpp
  • UsimPbNotLocated : UsimPbTypes.hpp
  • UsimPbNotSel : UsimPbTypes.hpp
  • UsimPbNotSelected : UsimPbTypes.hpp
  • UsimPbRefRefresh : UsimPbTypes.hpp
  • UsimPbRefresh : UsimPbTypes.hpp
  • UsimPbResponse : UsimPbTypes.hpp
  • UsimPbSim : UsimPbTypes.hpp
  • UsimPbSkipped : UsimPbTypes.hpp
  • UsimPbSne : UsimPbTypes.hpp
  • UsimPbSuccessful : UsimPbTypes.hpp
  • UsimPbSuccessfulUid : UsimPbTypes.hpp
  • UsimPbTechnicalProblem : UsimPbTypes.hpp
  • UsimPbTooFewExtRecs : UsimPbTypes.hpp
  • UsimPbType1 : UsimPbTypes.hpp
  • UsimPbType2 : UsimPbTypes.hpp
  • UsimPbType3 : UsimPbTypes.hpp
  • UsimPbUndefined : UsimPbTypes.hpp
  • UsimPbWrongDataType : UsimPbTypes.hpp
  • UsimPbWrongHandle : UsimPbTypes.hpp
  • UsimPbWrongLocation : UsimPbTypes.hpp
  • UsimPbWrongRecNumber : UsimPbTypes.hpp
  • UsimPbWrongRefRecord : UsimPbTypes.hpp
  • UsimPbWrongStructure : UsimPbTypes.hpp
  • UsimPhonebook : Types.hpp
  • UsimReadNull : SignalTypes.hpp
  • UsimUpdateInsert : SignalTypes.hpp
  • Ussd : SignalTypes.hpp
  • UssdActionType : InputAction.hpp
  • UssdHandlerId : HandlerId.hpp
  • UssdOrSsTransactionTerminatedByUser : SimTkTypes.hpp
  • UssdReturnError : SimTkTypes.hpp
  • UssdTransactionError : Types.hpp
  • UTF8_2charS : parsifal.cpp
  • UTF8_3charS : parsifal.cpp
  • UTF8_4charS : parsifal.cpp
  • UusService1 : SignalTypes.hpp
  • UusService2 : SignalTypes.hpp
  • UusService3 : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- v -

  • VbsEfPos : SimTkTypes.hpp
  • VbssEfPos : SimTkTypes.hpp
  • Verified : SignalTypes.hpp
  • VerifyLocAllowedNoResp : LcsTypes.hpp
  • VerifyLocNotAllowedNoResp : LcsTypes.hpp
  • Vertical : Grid.hpp
  • VgcsEfPos : SimTkTypes.hpp
  • VgcssEfPos : SimTkTypes.hpp
  • ViHzCache1EfPos : SimTkTypes.hpp
  • ViHzCache2EfPos : SimTkTypes.hpp
  • ViHzCache3EfPos : SimTkTypes.hpp
  • ViHzCache4EfPos : SimTkTypes.hpp
  • ViHzParamEfPos : SimTkTypes.hpp
  • VirtualActiveSet : NetworkTypes.hpp
  • VmRetCode : HostAudioDriver.hpp
  • VoiceBroadcastService : SignalTypes.hpp
  • VoiceGroupCallService : SignalTypes.hpp
  • VoidAction : MsgArgs.hpp
  • VoidCallIndex : Types.hpp
  • VoidCallType : SignalTypes.hpp
  • VoidCause : SignalTypes.hpp
  • VoidCliRestriction : SignalTypes.hpp
  • VoidDiagnostic : SignalTypes.hpp
  • VoidHoldInd : SignalTypes.hpp
  • VoidOverride : SignalTypes.hpp
  • VoidSsCode : SignalTypes.hpp
  • VrAudioError : VrTypes.hpp
  • VrBufferOvervlow : VrTypes.hpp
  • VrBusy : VrTypes.hpp
  • VrG2AEmptyBufferError : VrTypes.hpp
  • VrG2AExecutionError : VrTypes.hpp
  • VrG2AInitMemoryError : VrTypes.hpp
  • VrG2AParamRangeError : VrTypes.hpp
  • VrInitTimeout : VrTypes.hpp
  • VrInputTruncated : VrTypes.hpp
  • VrInvalidRecogParam : VrTypes.hpp
  • VrInvalidTrainParam : VrTypes.hpp
  • VrLoadTemplateError : VrTypes.hpp
  • VrNoTemplate : VrTypes.hpp
  • VrRecogAbort : VrTypes.hpp
  • VrRecogBuffer : VrTypes.hpp
  • VrRecogMemoryError : VrTypes.hpp
  • VrRecogPromptTimeout : VrTypes.hpp
  • VrRefExceed : VrTypes.hpp
  • VrSequenceError : VrTypes.hpp
  • VrStoreTemplateError : VrTypes.hpp
  • VrStoreTimeout : VrTypes.hpp
  • VrTemplateResponseTimeout : VrTypes.hpp
  • VrTrainAbort : VrTypes.hpp
  • VrTrainMemoryError : VrTypes.hpp
  • VrTrainPromptTimeOut : VrTypes.hpp
  • VrUndiffTemplate : VrTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- w -

  • WaitSsActionType : InputAction.hpp
  • WAP : LcsTypes.hpp
  • WC_CAN_NULL_PTR : WildcardStrncmp.hpp
  • WC_CAN_TOO_SHORT : WildcardStrncmp.hpp
  • WC_MATCH : WildcardStrncmp.hpp
  • WC_MISMATCH : WildcardStrncmp.hpp
  • WC_PAT_NULL_PTR : WildcardStrncmp.hpp
  • WC_PAT_TOO_SHORT : WildcardStrncmp.hpp
  • WCBTypeAL : WCattr.hpp
  • WCBTypeAN : WCattr.hpp
  • WCBTypeB : WCattr.hpp
  • WCBTypeBN : WCattr.hpp
  • WCBTypeCS : WCattr.hpp
  • WCBTypeEN : WCattr.hpp
  • WCBTypeES : WCattr.hpp
  • WCBTypeET : WCattr.hpp
  • WCBTypeL : WCattr.hpp
  • WCBTypeLRE : WCattr.hpp
  • WCBTypeLRO : WCattr.hpp
  • WCBTypeNSM : WCattr.hpp
  • WCBTypeON : WCattr.hpp
  • WCBTypePDF : WCattr.hpp
  • WCBTypeR : WCattr.hpp
  • WCBTypeRLE : WCattr.hpp
  • WCBTypeRLO : WCattr.hpp
  • WCBTypeS : WCattr.hpp
  • WCBTypeWS : WCattr.hpp
  • WCTypeCc : WCattr.hpp
  • WCTypeCf : WCattr.hpp
  • WCTypeCn : WCattr.hpp
  • WCTypeCo : WCattr.hpp
  • WCTypeCs : WCattr.hpp
  • WCTypeLl : WCattr.hpp
  • WCTypeLm : WCattr.hpp
  • WCTypeLo : WCattr.hpp
  • WCTypeLt : WCattr.hpp
  • WCTypeLu : WCattr.hpp
  • WCTypeMc : WCattr.hpp
  • WCTypeMe : WCattr.hpp
  • WCTypeMn : WCattr.hpp
  • WCTypeNd : WCattr.hpp
  • WCTypeNl : WCattr.hpp
  • WCTypeNo : WCattr.hpp
  • WCTypePc : WCattr.hpp
  • WCTypePd : WCattr.hpp
  • WCTypePe : WCattr.hpp
  • WCTypePf : WCattr.hpp
  • WCTypePi : WCattr.hpp
  • WCTypePo : WCattr.hpp
  • WCTypePs : WCattr.hpp
  • WCTypeSc : WCattr.hpp
  • WCTypeSk : WCattr.hpp
  • WCTypeSm : WCattr.hpp
  • WCTypeSo : WCattr.hpp
  • WCTypeZl : WCattr.hpp
  • WCTypeZp : WCattr.hpp
  • WCTypeZs : WCattr.hpp
  • WhereAmI : LcsFeatTypes.hpp
  • WildcardValue : PhoneNumber.hpp
  • WithTextNoIcon : NetworkTypes.hpp
  • WithTextWithIcon : NetworkTypes.hpp
  • WriteErr : FfsTestError.hpp
  • WrongPlmn : NetworkTypes.hpp
  • WStringType : DataItem.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- x -

  • XaocCharging : MmTypes.hpp
  • XaocInformation : MmTypes.hpp
  • XCallStatActive : MmTypes.hpp
  • XCallStatDialling : MmTypes.hpp
  • XCallStatDisconnected : MmTypes.hpp
  • XCallStatHold : MmTypes.hpp
  • XCallStatMOAlerting : MmTypes.hpp
  • XCallStatMtRinging : MmTypes.hpp
  • XCallStatMtWaiting : MmTypes.hpp
  • XnoAoc : MmTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • Abs() : Fraction.cpp
  • Absolute() : Types.hpp
  • AmbiguousTr() : LanguageManager.hpp, LanguageManager.cpp
  • APOXI_ADD_MIME_TYPE_DEFS() : MimeTypeTable.cpp, MimeTypeTableUtils.hpp
  • APOXI_END_MIME_TYPE_DEFS() : MimeTypeTable.cpp, MimeTypeTableUtils.hpp
  • APOXI_OBEX_DATA_SERVER_STATE() : ObexDataServer.cpp
  • apoxi_process_signal() : SignalHandler.cpp
  • Apoxi_startup() : SignalHandler.cpp
  • ApoxiAlloc() : Os.cpp
  • ApoxiAllocEx() : Os.cpp
  • ApoxiBDigitValue() : StrPrintf.cpp
  • ApoxiDDigitValue() : StrPrintf.cpp
  • ApoxiDefVersionInfo() : VoiceMemoVersion.cpp, UsbVersion.cpp, UibVersion.cpp, SoundBrowserVersion.cpp, SocketTestVersion.cpp, ObexAppVersion.cpp, IrdaAppVersion.cpp, ImgbrVersion.cpp, FmRadioVersion.cpp, EmsVersion.cpp, DataConnVersion.cpp, ApbVersion.cpp, ApoxiKernelVersion.cpp, ApoxiGuiVersion.cpp, ApoxiAuxiliaryVersion.cpp, ApoxiAscVersion.cpp, ApoxiApcSignalHandlerVersion.cpp, ApoxiApcVersion.cpp, ApoxiAfsVersion.cpp, ApoxiVoiceRecognitionVersion.cpp, ApoxiHttpServerVersion.cpp, ApoxiFtpServerVersion.cpp, ApoxiServerVersion.cpp, MediaFrameworkVersion.cpp, ApoxiAfsRfsVersion.cpp, ApoxiAfsRamVersion.cpp, ApoxiAfsFfsVersion.cpp, ApoxiAfsFatVersion.cpp, ApoxiAdcVersion.cpp, VersionInfo.hpp
  • ApoxiFree() : Os.cpp
  • ApoxiHugeAlloc() : Os.cpp
  • ApoxiHugeAllocEx() : Os.cpp
  • ApoxiHugeFree() : Os.cpp
  • ApoxiHugeRealloc() : Os.cpp
  • ApoxiODigitValue() : StrPrintf.cpp
  • ApoxiRealloc() : Os.cpp
  • ApoxiSendDisplayUpdateFinished() : DefaultDisplay.cpp
  • ApoxiSendDisplayUpdateFinished_dummy() : DefaultDisplay.cpp
  • ApoxiSendGddViewfinderError() : Camera.cpp
  • ApoxiStackAlloc() : Os.cpp
  • ApoxiStackFree() : Os.cpp
  • ApoxiUseVersionInfo() : VoiceMemoApp.cpp, UsbApp.cpp, UibApp.cpp, SoundBrowserApp.cpp, ObexApp.cpp, IrdaApp.cpp, ImageBrowserApp.cpp, FmRadioApplication.cpp, EmsApp.cpp, DataConnApp.cpp, Application.cpp, Window.cpp, String.cpp, MainHandler.cpp, ProcessNode.cpp, MessageImpl.cpp, MediaManager.cpp, DataHandler.cpp, VersionInfo.hpp
  • ApoxiXDigitValue() : StrPrintf.cpp
  • ASSERT_DEBUG_HOST() : SetPixel_16Bpp.cpp, FillRect_Planes.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_Planes.cpp, BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp, Macros.hpp
  • AtomBit() : Ddrv.cpp
  • AtomLeftBits() : Ddrv.cpp
  • AtomRightBits() : Ddrv.cpp
  • AtomShift() : Ddrv.cpp
  • AttrGetCase() : WCattr.cpp
  • AttrGetCaseFlags() : WCattr.cpp
  • AttrGetCompFlags() : WCattr.cpp
  • AttrGetDecomp() : WCattr.cpp
  • AttrGetIdx() : WCattr.cpp
  • AttrGetType() : WCattr.cpp
  • AUD_add_downlinkpath() : aud_drv.cpp
  • AUD_add_uplinkpath() : aud_drv.cpp
  • AUD_allocate_resource() : aud_drv.cpp
  • AUD_amp_disable() : aud_drv.cpp
  • AUD_amp_enable() : aud_drv.cpp
  • aud_drv_check_timeout() : aud_drv.cpp
  • aud_drv_restart_hf() : aud_drv.cpp
  • aud_drv_tst_buzzer_melody() : aud_drv.cpp
  • aud_drv_tst_buzzer_tone() : aud_drv.cpp
  • aud_drv_tst_buzzer_tune() : aud_drv.cpp
  • aud_drv_tst_dsp_parm_ready() : aud_drv.cpp
  • aud_drv_tst_external_devices() : aud_drv.cpp
  • aud_drv_tst_read_dsp_audio_parms() : aud_drv.cpp
  • aud_drv_tst_set_audio_parm() : aud_drv.cpp
  • aud_drv_tst_start_testing_poly_tone_chip() : aud_drv.cpp
  • aud_drv_tst_stop_testing_poly_tone_chip() : aud_drv.cpp
  • AUD_get_downlnk_parallel_path_configuration() : aud_drv.cpp
  • AUD_get_uplink_parallel_path_configuration() : aud_drv.cpp
  • AUD_info_driver_status() : aud_drv.cpp
  • AUD_info_hw_available() : aud_drv.cpp
  • AUD_init() : aud_drv.cpp
  • AUD_mapi() : aud_drv.cpp
  • AUD_misc_set_accessory() : aud_drv.cpp
  • AUD_misc_set_vmic() : aud_drv.cpp
  • AUD_mp3_backward() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_mp3_fastforward() : HostAudioDriver.cpp, aud_drv.cpp
  • Aud_mp3_get_buffer_function() : aud_drv.cpp
  • Aud_mp3_get_current_frame() : HostAudioDriver.cpp
  • AUD_mp3_get_play_position() : HostAudioDriver.cpp
  • AUD_mp3_get_total_playtime() : HostAudioDriver.cpp
  • AUD_mp3_pause() : aud_drv.cpp
  • AUD_mp3_resume() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_mp3_seek() : aud_drv.cpp
  • AUD_mp3_set() : aud_drv.cpp
  • Aud_mp3_set_getbuffer_function() : HostAudioDriver.cpp
  • AUD_mp3_set_play_position() : HostAudioDriver.cpp
  • AUD_mp3_set_volume() : aud_drv.cpp
  • AUD_mp3_start() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_mp3_stop() : HostAudioDriver.cpp
  • AUD_mp3_stop_suspend() : HostAudioDriver.cpp
  • AUD_mp3_suspend() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_mute_master() : aud_drv.cpp
  • AUD_mute_resource() : aud_drv.cpp
  • AUD_pcm_intern_get_play_position() : aud_drv.cpp
  • AUD_pcm_intern_get_total_playtime() : aud_drv.cpp
  • AUD_pcm_intern_getbuffer_function() : HostAudioDriver.cpp
  • AUD_pcm_intern_resume() : aud_drv.cpp
  • AUD_pcm_intern_set_play_position() : aud_drv.cpp
  • AUD_pcm_intern_start_playback() : HostAudioDriver.cpp
  • AUD_pcm_intern_start_recording() : HostAudioDriver.cpp
  • AUD_pcm_intern_stop_playback() : HostAudioDriver.cpp
  • AUD_pcm_intern_stop_recording() : HostAudioDriver.cpp
  • AUD_pcm_intern_suspend() : aud_drv.cpp
  • AUD_radio_disable() : aud_drv.cpp
  • AUD_radio_enable() : aud_drv.cpp
  • AUD_radio_rds_subscribe() : aud_drv.cpp
  • AUD_radio_rssi_subscribe() : aud_drv.cpp
  • AUD_radio_set_station() : aud_drv.cpp
  • AUD_release_resource() : aud_drv.cpp
  • AUD_remove_downlinkpath() : aud_drv.cpp
  • AUD_remove_uplinkpath() : aud_drv.cpp
  • AUD_ringer_get_playposition() : aud_drv.cpp
  • AUD_ringer_get_total_playtime() : aud_drv.cpp
  • AUD_ringer_resume() : aud_drv.cpp
  • AUD_ringer_set_channel_volume() : aud_drv.cpp
  • AUD_ringer_set_playposition() : aud_drv.cpp
  • AUD_ringer_set_volume() : aud_drv.cpp
  • AUD_ringer_start() : aud_drv.cpp
  • AUD_ringer_start_user_tone() : aud_drv.cpp
  • AUD_ringer_stop() : aud_drv.cpp
  • AUD_ringer_stop_suspend() : aud_drv.cpp
  • AUD_ringer_suspend() : aud_drv.cpp
  • AUD_set_EC_NR() : aud_drv.cpp
  • AUD_set_master_volume() : aud_drv.cpp
  • AUD_set_resource_volume() : aud_drv.cpp
  • AUD_set_volume() : aud_drv.cpp
  • AUD_speech_disable() : aud_drv.cpp
  • AUD_speech_enable() : aud_drv.cpp
  • AUD_speech_mute() : aud_drv.cpp
  • AUD_speech_set_volume() : aud_drv.cpp
  • AUD_tone_get_play_position() : aud_drv.cpp
  • AUD_tone_get_total_playtime() : aud_drv.cpp
  • AUD_tone_resume() : aud_drv.cpp
  • AUD_tone_set_play_position() : aud_drv.cpp
  • AUD_tone_start() : aud_drv.cpp
  • AUD_tone_start_user_tone() : aud_drv.cpp
  • AUD_tone_stop() : aud_drv.cpp
  • AUD_tone_suspend() : aud_drv.cpp
  • AUD_tst_set_dai() : aud_drv.cpp
  • AUD_vibrator_start() : aud_drv.cpp
  • AUD_vibrator_stop() : aud_drv.cpp
  • AUD_vm_get_play_position() : aud_drv.cpp
  • AUD_vm_get_total_playtime() : aud_drv.cpp
  • AUD_vm_resume() : aud_drv.cpp
  • AUD_vm_set_play_position() : aud_drv.cpp
  • AUD_vm_start_playback() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_vm_start_recording() : HostAudioDriver.cpp, aud_drv.cpp
  • AUD_vm_stop_playback() : HostAudioDriver.cpp
  • AUD_vm_stop_recording() : HostAudioDriver.cpp
  • AUD_vm_suspend() : aud_drv.cpp
  • Aud_vms_set_getbuffer_function() : HostAudioDriver.cpp
  • AudioGetMutex() : audio_private.hpp, audio_private.cpp
  • AudioPmAutomaticResume() : AudioPriorityManager.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- j -

  • jpeg_free_large() : jmemnobs_APOXI.cpp
  • jpeg_free_small() : jmemnobs_APOXI.cpp
  • jpeg_get_large() : jmemnobs_APOXI.cpp
  • jpeg_get_small() : jmemnobs_APOXI.cpp
  • jpeg_mem_available() : jmemnobs_APOXI.cpp
  • jpeg_mem_init() : jmemnobs_APOXI.cpp
  • jpeg_mem_term() : jmemnobs_APOXI.cpp
  • jpeg_open_backing_store() : jmemnobs_APOXI.cpp
  • JVMa_getFileFromJar() : Unzipper.hpp, Unzipper.cpp
  • JVMc_getFileFromJarResponse() : Unzipper.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • Latin1ToUtf8() : parsifal.cpp
  • LocateFileBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • LocateFileFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • LToW() : WStrUtil.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • main() : UdpServer.cpp
  • MakeFree() : HeapVector.cpp
  • MakeOccupied() : HeapVector.cpp
  • MapFindData() : HostCoreFsSim.cpp
  • Maximum() : Types.hpp
  • memcpy() : InternalTracer.cpp
  • Minimum() : Types.hpp
  • MmiSendGddViewfinderEnabled() : SocketTestVersion.cpp, ApbVersion.cpp
  • months_to_days() : RealTimeClock.cpp
  • msap_retrieve_brsf() : BtHfService.cpp, BtHfController.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • native2percent() : audio_private.hpp, audio_private.cpp
  • NoSimKeyboardAllowed() : SimChvHandler.cpp
  • NoSimMenuAllowed() : SimChvHandler.cpp
  • NvRamGetWin32FilePath() : NvRam.cpp
  • NvRamOpenEmuFile() : NvRam.cpp
  • NvRamRead() : NvRam.hpp, NvRam.cpp
  • NvRamWrite() : NvRam.hpp, NvRam.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • OnMinuteTickCheck() : RealTimeClock.cpp
  • OnRequestStateChange() : BtBipServerService.cpp
  • OnTime() : RealTimeClock.cpp
  • OnTimer() : MdhSignalProcessor.cpp
  • OpenBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • OpenCurrentFileBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • OpenCurrentFileFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • OpenDownlink() : TchInterface.cpp
  • OpenFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • OpenTch() : TchInterface.cpp
  • OpenUplink() : TchInterface.cpp
  • operator delete() : Allocator.hpp
  • operator new() : Allocator.hpp
  • operator!=() : ObexOperationId.hpp, ObexChannel.hpp, BtObexServiceTable.hpp, BtUtility.hpp, BtUtility.cpp, BtSvrDataElement.hpp, BtSvrDataElement.cpp, NiSharedPtr.hpp, ByteBuffer.hpp, ResourceID.hpp
  • operator<() : ResourceID.hpp
  • operator<<() : UibMsgTypes.cpp, GltpAppMsgTypes.cpp, SmsSettingsRecord.cpp, ObexVCardMsg.cpp, MsgTypes.cpp, EmServThreadMsg.cpp
  • operator==() : ObexOperationId.hpp, ObexChannel.hpp, BtObexServiceTable.hpp, BtUtility.hpp, BtUtility.cpp, BtSvrDataElement.hpp, BtSvrDataElement.cpp, NiSharedPtr.hpp, ByteBuffer.hpp, ResourceID.hpp, RfsTemplates.cpp
  • operator>() : ResourceID.hpp
  • operator>>() : UibMsgTypes.cpp, GltpAppMsgTypes.cpp, SmsSettingsRecord.cpp, ObexVCardMsg.cpp, EditBox.hpp, EditBox.cpp, MsgTypes.cpp, EmServThreadMsg.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • BcdByteToInt() : ValidityPeriod.hpp
  • Between() : Types.hpp
  • BinarySearch() : BinarySearch.hpp
  • BlockPageTest() : HeapManager.cpp
  • BufferedIStream_Free() : bistream.cpp
  • BufferedIStream_Init() : bistream.cpp
  • BufferedIStream_Peek() : bistream.cpp
  • BufferedIStream_Read() : bistream.cpp
  • BufferedIStream_ToString() : bistream.cpp
  • ByteBufferAccessOperatorTest() : ByteBuffer.cpp
  • ByteBufferAssignmentOperators() : ByteBuffer.cpp
  • ByteBufferConstructorTest() : ByteBuffer.cpp
  • ByteBufferMiscMethodsTest() : ByteBuffer.cpp
  • ByteBufferTest() : ByteBuffer.hpp, ByteBuffer.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • CastMsg() : Message.hpp
  • CbplaybackRenderFrame() : EmApoxiVideoRenderer.cpp
  • CharToLower() : StrUtil.hpp
  • CharToUpper() : StrUtil.hpp
  • CheckComputeUsage() : HeapVector.cpp
  • CheckRange() : Win32.cpp
  • CLEANUP_ATTS_fn() : parsifal.cpp
  • CloseBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • CloseCurrentFileBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • CloseCurrentFileFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • CloseDownlink() : TchInterface.cpp
  • CloseFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • CloseTch() : TchInterface.cpp
  • CloseUplink() : TchInterface.cpp
  • cmpbcdbuffer() : PhoneNumber.cpp
  • Color() : GetPixelColor_Planes.cpp, GetPixelColor_8Bpp.cpp, GetPixelColor_32Bpp.cpp, GetPixelColor_24Bpp.cpp, GetPixelColor_16Bpp.cpp
  • ConvertAACToGCIFormat() : AtiUtils.cpp
  • ConvertAMRToGCIFormat() : AtiUtils.cpp
  • ConvertFromGCIFormat() : AtiUtils.cpp
  • ConvertToGCIFormat() : AtiUtils.cpp
  • ConvertUtf8ToWString() : BtUtility.hpp, BtUtility.cpp
  • copybcdbuffer() : PhoneNumber.cpp
  • CorrectSimKeyboardAllowed() : SimChvHandler.cpp
  • CorrectSimMenuAllowed() : SimChvHandler.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • DataItemTestSuite() : DataItem.hpp, DataItem.cpp
  • DDrvDimToAtomBitIdx() : Ddrv.cpp
  • DDrvGetScanlineInc() : Ddrv.cpp
  • DeleteDirRecursive() : HostCoreFsSim.cpp
  • DetectShiftValue() : HeapVector.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • EaadCreate() : EmApoxiAudioDeviceImpl.cpp
  • EaadDeInit() : EmApoxiAudioDeviceImpl.cpp
  • EaadDestroy() : EmApoxiAudioDeviceImpl.cpp
  • EaadDummyCreate() : EmApoxiAudioDeviceImpl.cpp
  • EaadDummyDestroy() : EmApoxiAudioDeviceImpl.cpp
  • EaadGetNumChannels() : EmApoxiAudioUtils.cpp
  • EaadGetPlaybackSampleRate() : EmApoxiAudioUtils.cpp
  • EaadGetProperty() : EmApoxiAudioDeviceImpl.cpp
  • EaadGetRecordSamplingRate() : EmApoxiAudioUtils.cpp
  • EaadInit() : EmApoxiAudioDeviceImpl.cpp
  • EaadResume() : EmApoxiAudioDeviceImpl.cpp
  • EaadSetProperty() : EmApoxiAudioDeviceImpl.cpp
  • EaadStartPlayBack() : EmApoxiAudioDeviceImpl.cpp
  • EaadStartRecording() : EmApoxiAudioDeviceImpl.cpp
  • EaadStopPlayBack() : EmApoxiAudioDeviceImpl.cpp
  • EaadStopRecording() : EmApoxiAudioDeviceImpl.cpp
  • EaadSuspend() : EmApoxiAudioDeviceImpl.cpp
  • EmApoxiFFS_get_raw_free_space_in_global_pool() : EmApoxiOs.cpp
  • EmApoxiPostMessageToServiceThread() : EmApoxiMsgDispatcher.cpp
  • EmApoxiTranslate() : EmApoxiVideoUtils.cpp
  • EmApoxiVideoRendererCreate() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererDelete() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererDisable() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererEnable() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererRenderFrame() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererSetImageFormat() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererSetLCDParams() : EmApoxiVideoRenderer.cpp
  • EmApoxiVideoRendererSetRectangle() : EmApoxiVideoRenderer.cpp
  • emz_free() : EmzCodecsLib.cpp
  • emz_malloc() : EmzCodecsLib.cpp
  • emz_realloc() : EmzCodecsLib.cpp
  • EncodeIStreamBuffer() : parsifal.cpp
  • enlarge_memory() : utils.cpp
  • ExtendUuidTo128Bit() : BtUtility.hpp, BtUtility.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • FFS_append() : FfsSim.hpp, FfsSim.cpp
  • FFS_append_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_calculate_file_overhead() : FfsSim.hpp, FfsSim.cpp
  • FFS_close() : FfsSim.hpp, FfsSim.cpp
  • FFS_close_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_copy() : FfsSim.hpp, FfsSim.cpp
  • FFS_copy_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_create() : FfsSim.hpp, FfsSim.cpp
  • FFS_create_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_deactivate() : FfsSim.hpp, FfsSim.cpp
  • FFS_delete() : FfsSim.hpp, FfsSim.cpp
  • FFS_delete_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_file_exists() : FfsSim.hpp, FfsSim.cpp
  • FFS_file_exists_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_findfirst() : FfsSim.hpp, FfsSim.cpp
  • FFS_findfirst_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_findnext() : FfsSim.hpp, FfsSim.cpp
  • FFS_findnext_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_file_id() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_file_info() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_file_info_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_file_name() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_free_space() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_free_space_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_free_space_in_global_pool() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_next_free_id() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_nof_files() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_nof_files_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_raw_free_space_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_raw_free_space_in_global_pool() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_reserved_space_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_reserved_space_in_global_pool() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_used_space() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_used_space_by_type() : FfsSim.hpp, FfsSim.cpp
  • FFS_get_used_space_in_global_pool() : FfsSim.hpp, FfsSim.cpp
  • FFS_initialize() : FfsSim.hpp, FfsSim.cpp
  • FFS_modify() : FfsSim.hpp, FfsSim.cpp
  • FFS_modify_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_open() : FfsSim.hpp, FfsSim.cpp
  • FFS_open_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_read() : FfsSim.hpp, FfsSim.cpp
  • FFS_read_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_ready() : FfsSim.hpp, FfsSim.cpp
  • FFS_rename() : FfsSim.hpp, FfsSim.cpp
  • FFS_rename_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_set_drm_attrib() : FfsSim.hpp, FfsSim.cpp
  • FFS_set_drm_attrib_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_truncate() : FfsSim.hpp, FfsSim.cpp
  • FFS_truncate_fn() : FfsSim.hpp, FfsSim.cpp
  • FFS_write() : FfsSim.hpp, FfsSim.cpp
  • FFS_write_fn() : FfsSim.hpp, FfsSim.cpp
  • FfsDelete() : FfsSim.cpp
  • FfsSetDrmAttrib() : FfsSim.cpp
  • FileDataClose() : EmApoxiFile.cpp
  • FileDataGetSize() : EmApoxiFile.cpp
  • FileDataOpen() : EmApoxiFile.cpp
  • FileDataRead() : EmApoxiFile.cpp
  • FileDataWrite() : EmApoxiFile.cpp
  • FindFirstByte() : SimAuxHandler.hpp, SimAuxHandler.cpp
  • FindNotUsedHandlePos() : HostCoreFsSim.cpp
  • FindSSString() : PhoneNumber.cpp
  • for() : ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp, ConvertToColorValue_Planes.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • ForAllPlanes() : SetPixel_Planes.cpp, ScrollHorizontal_Planes.cpp, GetPixelColor_Planes.cpp, FillRect_Planes.cpp, DrawChar_Planes.cpp, BitBlit_Planes.cpp, Ddrv.cpp
  • FS_assign_driveletter() : FatSim.hpp, FatSim.cpp
  • FS_close() : FatSim.hpp, FatSim.cpp
  • FS_deactivate() : FatSim.hpp, FatSim.cpp
  • FS_delete() : FatSim.hpp, FatSim.cpp
  • FS_device_notify() : FatSim.hpp, FatSim.cpp
  • FS_diskabort() : FatSim.hpp, FatSim.cpp
  • FS_diskclose() : FatSim.hpp, FatSim.cpp
  • FS_diskflush() : FatSim.hpp, FatSim.cpp
  • FS_diskinfo() : FatSim.hpp, FatSim.cpp
  • FS_diskopen() : FatSim.hpp, FatSim.cpp
  • FS_finddone() : FatSim.hpp, FatSim.cpp
  • FS_findfirst() : FatSim.hpp, FatSim.cpp
  • FS_findnext() : FatSim.hpp, FatSim.cpp
  • FS_flush() : FatSim.hpp, FatSim.cpp
  • FS_format() : FatSim.hpp, FatSim.cpp
  • FS_free() : FatSim.hpp, FatSim.cpp
  • FS_get_attributes() : FatSim.hpp, FatSim.cpp
  • FS_get_default_device() : FatSim.hpp, FatSim.cpp
  • FS_get_file_length_streaming() : FatSim.hpp, FatSim.cpp
  • FS_get_file_pos_streaming() : FatSim.hpp, FatSim.cpp
  • FS_get_last_device_error() : FatSim.hpp, FatSim.cpp
  • FS_get_last_error() : FatSim.hpp, FatSim.cpp
  • FS_get_registered_devices() : FatSim.hpp, FatSim.cpp
  • FS_getcwd() : FatSim.hpp, FatSim.cpp
  • FS_init_rtos() : FatSim.hpp, FatSim.cpp
  • FS_isdir() : FatSim.hpp, FatSim.cpp
  • FS_mkdir() : FatSim.hpp, FatSim.cpp
  • FS_MS_AssignStatusNotificationFunction() : FatSim.hpp
  • FS_open() : FatSim.hpp, FatSim.cpp
  • FS_read() : FatSim.hpp, FatSim.cpp
  • FS_read_max() : FatSim.hpp, FatSim.cpp
  • FS_read_streaming() : FatSim.hpp, FatSim.cpp
  • FS_register_media_status_notification() : FatSim.hpp, FatSim.cpp
  • FS_rename() : FatSim.hpp, FatSim.cpp
  • FS_rmdir() : FatSim.hpp, FatSim.cpp
  • FS_seek() : FatSim.hpp, FatSim.cpp
  • FS_set_attributes() : FatSim.hpp, FatSim.cpp
  • FS_set_default_device() : FatSim.hpp, FatSim.cpp
  • FS_set_file_pos_streaming() : FatSim.hpp, FatSim.cpp
  • FS_setcwd() : FatSim.hpp, FatSim.cpp
  • FS_stat() : FatSim.hpp, FatSim.cpp
  • FS_truncate() : FatSim.hpp, FatSim.cpp
  • FS_write() : FatSim.hpp, FatSim.cpp
  • FS_write_streaming() : FatSim.hpp, FatSim.cpp
  • FSM_DEFINE_STATE() : ObexServerPort.cpp, ObexClientPort.cpp, ObexAbstractPort.cpp
  • FSM_STATE_ELSE() : ObexServerPort.cpp, ObexClientPort.cpp, ObexAbstractPort.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • GDDCameraFrameRate() : EmApoxiVideoUtils.cpp
  • GDDCameraImageFormatType() : EmApoxiVideoUtils.cpp
  • GDDVideoDataFormatType() : EmApoxiVideoUtils.cpp
  • get_ringbuffer() : RingBuffer.hpp, RingBuffer.cpp
  • get_sw_version() : SocketTestVersion.hpp, SocketTestVersion.cpp, ApbVersion.hpp, ApbVersion.cpp
  • get_sw_version_text() : SocketTestVersion.hpp, SocketTestVersion.cpp, ApbVersion.hpp, ApbVersion.cpp
  • GetAvailableHW() : MiscAudioDevice.cpp
  • GetBlockCount() : HeapVector.cpp
  • GetClirSetting() : AdcInterface.hpp, AdcInterface.cpp
  • GetContrastLimits() : Camera.cpp
  • GetCugSetting() : AdcInterface.hpp, AdcInterface.cpp
  • GetCurrentContext() : InternalTracer.cpp
  • GetCurrentFileInfoBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • GetCurrentFileInfoFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • GetDeviceId() : FatSim.cpp
  • GetEccWString() : EccProvider.cpp
  • GetGcd() : Fraction.cpp
  • GetGenericStatus() : SimAccessor.cpp
  • GetMp3Head() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • GetNvRamSize() : NvRam.hpp, NvRam.cpp
  • GetNvRamStartAddress() : NvRam.hpp, NvRam.cpp
  • GetOpenFilePos() : HostCoreFsSim.cpp
  • GetPlaybackState() : AudioPriorityManager.cpp
  • GetPowerStatus() : MiscAudioDevice.cpp
  • getrawbcdlength() : PhoneNumber.cpp
  • GetRawTpduStatus() : Tpdu.hpp
  • GetRegistrationState() : AdcInterface.hpp, AdcInterface.cpp
  • GetSimIconDescription() : SimTkHandler.cpp
  • GetSimImage() : SimTkHandler.cpp
  • GetSimRegistrationMask() : PowerHandler.cpp
  • GetStoredCameraBuffer() : CameraCaptureWin.cpp, StillCamera.cpp
  • GetStringLen() : OsStrLib.hpp, OsStrLib.cpp
  • GetSurvivorRef() : AudioPriorityManager.cpp
  • GetUsimPbAddTypeName() : UsimPbTypes.hpp, UsimPbTypes.cpp
  • GetUsimPbLinkTypeName() : UsimPbTypes.hpp, UsimPbTypes.cpp
  • GetUsimPbRefTypeName() : UsimPbTypes.hpp, UsimPbTypes.cpp
  • GetWStringLen() : OsStrLib.hpp, OsStrLib.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • HashTable_Create() : hash.cpp
  • HashTable_Destroy() : hash.cpp
  • HashTable_Enumerate() : hash.cpp
  • HashTable_Insert() : hash.cpp
  • HashTable_Lookup() : hash.cpp
  • HashTable_Remove() : hash.cpp
  • HexToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • HostInitFatFsStorageDevices() : FatSim.hpp, FatSim.cpp
  • HugeVarPageTest() : HeapManager.cpp
  • hwtrc_putchars() : InternalTracer.cpp
  • hwtrc_send_apoxi_msg() : InternalTracer.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • if() : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_Planes.cpp, FillRect_16Bpp.cpp, BitBlit_Planes.cpp, BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp
  • InfoElementTestSuite() : InformationElement.hpp, InformationElement.cpp
  • InitShmemEvent() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • InputAnalyzerTest() : InputAction.hpp, InputAction.cpp
  • Int32ToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • Internal_change_dir() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_close() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_copy() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_delete() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_exists() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_filename_to_full_path() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_finddone() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_findfirst() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_findnext() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_format_device() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_get_attributes() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_get_cwd() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_get_file_info() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_get_test_path() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_is_dir() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_make_dir() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_open() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_read() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_remove_dir() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_rename() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_seek() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_set_attributes() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_truncate() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • Internal_write() : HostCoreFsSim.hpp, HostCoreFsSim.cpp
  • InternalCallStackAdr() : InternalTracer.cpp
  • IntToBcdByte() : ValidityPeriod.hpp
  • IntToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • Is7BitChar() : AlphaCoding.cpp
  • IsBDigit() : StrPrintf.cpp
  • IsDDigit() : StrPrintf.cpp
  • IsDownlinkConnected() : TchInterface.cpp
  • IsFree() : HeapVector.cpp
  • isleap() : RealTimeClock.cpp
  • IsMinusSign() : StrPrintf.cpp
  • IsODigit() : StrPrintf.cpp
  • IsPlusSign() : StrPrintf.cpp
  • IsRedialingActive() : AdcInterface.hpp, AdcInterface.cpp
  • IsSign() : StrPrintf.cpp
  • IsSimMemoryError() : SignalTypes.hpp
  • IsSimSecretCodeLockedError() : SignalTypes.hpp
  • IsSimSecurityError() : SignalTypes.hpp
  • IsSimTechnicalProblemWithNoDiagnosticError() : SignalTypes.hpp
  • IsTchConnected() : TchInterface.cpp
  • IsTpduSentStatus() : Tpdu.hpp
  • IsUnused() : HeapVector.cpp
  • IsUplinkConnected() : TchInterface.cpp
  • IsValidCriteria() : SimPduHandler.cpp
  • IsWbDigit() : WStrUtil.hpp, WStrUtil.cpp
  • IsWdDigit() : WStrUtil.hpp, WStrUtil.cpp
  • IsWhiteSpace() : StrPrintf.cpp
  • IsWminusSign() : WStrUtil.hpp, WStrUtil.cpp
  • IsWoDigit() : WStrUtil.hpp, WStrUtil.cpp
  • IsWplusSign() : WStrUtil.hpp, WStrUtil.cpp
  • IsWsign() : WStrUtil.hpp, WStrUtil.cpp
  • IsWwhiteSpace() : WStrUtil.hpp, WStrUtil.cpp
  • IsWxDigit() : WStrUtil.hpp, WStrUtil.cpp
  • IsXDigit() : StrPrintf.cpp
  • IToW() : WStrUtil.cpp
Generated on Wed Jan 25 02:31:17 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • percent2native() : audio_private.hpp, audio_private.cpp
  • PhoneNumberAssignmentTest() : PhoneNumber.cpp
  • PhoneNumberConstructorTest() : PhoneNumber.cpp
  • PhoneNumberPersistentTest() : PhoneNumber.cpp
  • PhoneNumberTest() : PhoneNumber.hpp, PhoneNumber.cpp
  • PlayAmrCallback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayAmrStreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayDtmf() : Audio.cpp
  • PlayMp3Callback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayMp3StreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayPcmCallback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayPcmStreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • PlayTone() : Audio.cpp
  • PostMtcConfIndArg() : CallMiscSignalProcessor.cpp
  • PostMtcSetupIndArg() : CallMiscSignalProcessor.cpp
  • put_ringbuffer() : RingBuffer.hpp, RingBuffer.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • RandomHugeFragVarPageTest() : HeapManager.cpp
  • RandomHugeVarPageTest() : HeapManager.cpp
  • RandomVarPageTest() : HeapManager.cpp
  • ReadCurrentFileBinData() : UnzipBinData.hpp, UnzipBinData.cpp
  • ReadCurrentFileFfs() : UnzipFfs.hpp, UnzipFfs.cpp
  • RecAmrCallback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • RecAmrStreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • RecordFileSpec() : HostCoreFsSim.cpp
  • RecPcmCallback() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • RecPcmStreamFile() : HostAudioDriver.hpp, HostAudioDriver.cpp
  • REGISTER_GATI_SERVER() : MmiSimServer.cpp, HostAudioGatiServer.cpp, AragonServer.cpp, GatiManager.hpp
  • RetrieveClock() : InternalTracer.cpp
  • return() : ConvertToColorValue_Planes.cpp
  • RTC_OnEvent() : RealTimeClock.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • scalar_to_ymd() : RealTimeClock.cpp
  • sEmApoxiAudioDecoderFrameDecodedCb() : EmApoxiAudioDecoder.cpp
  • sEmApoxiInBufFreeCb() : EmApoxiVideoDecoder.cpp
  • sEmApoxiVideoDecoderFrameDecodedCb() : EmApoxiVideoDecoder.cpp
  • sEmApoxiVideoEncoderFrameEncodedCb() : EmApoxiVideoEncoder.cpp
  • SendMessageToDispatcherToApp() : EmApoxiMsgDispatcher.cpp
  • SendPowerUpArgs() : PowerHandler.cpp
  • SendTchStatusUpdateToMn() : TchInterface.cpp
  • SetPlaybackState() : AudioPriorityManager.cpp
  • SetUnused() : HeapVector.cpp
  • SetUsed() : HeapVector.cpp
  • Sign() : Types.hpp
  • stkInit() : stk.cpp
  • stkPop() : stk.cpp
  • stkPush() : stk.cpp
  • StreamingCallback() : File.cpp
  • StringTest() : String.hpp
  • strlen() : FunctionTracer.hpp
  • strprintf() : StrUtil.hpp, StrPrintf.cpp
  • StrPrintf() : StrUtil.hpp, StrPrintf.cpp
  • StrToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • SvgFixPoint_Scalar_Mul() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Scalar_Print() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_Init() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_Print() : SvgFixPoint.hpp
  • SvgFixPoint_Transform_Rotate() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_Scale() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_Translate() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SvgFixPoint_Transform_XY_Scale() : SvgFixPoint.hpp, SvgFixPoint.cpp
  • SwapBytes() : SimAuxHandler.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • T9HandleRequest() : T9Wrapper.cpp
  • T9HandleRequest_Chinese() : ChineseT9Wrapper.hpp, ChineseT9Wrapper.cpp
  • T9ReadLdbData_Chinese() : ChineseT9Wrapper.cpp
  • TestAtKeyParser() : AtKeyParser.hpp, AtKeyParser.cpp
  • TestBit() : Types.hpp
  • TestHeaps() : HeapManager.hpp, HeapManager.cpp
  • TestMimeCoding() : MimeCoding.cpp
  • ToProfile() : BtUtility.hpp, BtUtility.cpp
  • ToResultCode() : BtUtility.hpp, BtUtility.cpp
  • Tr() : LanguageManager.hpp, LanguageManager.cpp
  • TraceDataHelper() : FunctionTracer.hpp
  • TransformRatToUsimAct() : NetworkTypes.hpp
  • TransformUsimActToRat() : NetworkTypes.hpp
  • TranslateAacFormatType() : EmApoxiCodecUtils.cpp
  • TranslateApplicationCategoriesFlagsType() : EmApoxiCodecUtils.cpp
  • TranslateAudioDecoderDecodingFctType() : EmApoxiCodecUtils.cpp
  • TranslateAudioDecoderParameterType() : EmApoxiCodecUtils.cpp
  • TranslateCodecResultType() : EmApoxiCodecUtils.cpp
  • TranslateCodecType() : EmApoxiCodecUtils.cpp
  • TranslateLocationType() : EmApoxiCodecUtils.cpp
  • TranslateMimeType() : EmApoxiMimeTypeTable.cpp
  • TranslateMmfModeType() : EmApoxiUtilities.cpp
  • TranslatePlayerState() : EmApoxiUtilities.cpp
  • TranslateRecorderState() : EmApoxiUtilities.cpp
  • TranslateVideoDecoderFlagsType() : EmApoxiCodecUtils.cpp
  • TranslateVideoDecoderParameterType() : EmApoxiCodecUtils.cpp
  • TranslateVideoEncoderCodingType() : EmApoxiCodecUtils.cpp
  • TranslateVideoEncoderParameterType() : EmApoxiCodecUtils.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • UInt32ToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • UIntToWStr() : WStrUtil.hpp, WStrUtil.cpp
  • UnicodeFromUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeGetUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeIndexToOffset() : Unicode.hpp, Unicode.cpp
  • UnicodeLastUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeNextUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeOffsetToIndex() : Unicode.hpp, Unicode.cpp
  • UnicodePreviousUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodePutUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeStrcmp() : Unicode.hpp, Unicode.cpp
  • UnicodeStringWidth() : Unicode.hpp, Unicode.cpp
  • UnicodeStrlen() : Unicode.hpp, Unicode.cpp
  • UnicodeStrncmp() : Unicode.hpp, Unicode.cpp
  • UnicodeStrncpy() : Unicode.hpp, Unicode.cpp
  • UnicodeStrstr() : Unicode.hpp, Unicode.cpp
  • UnicodeToUtf8() : Unicode.hpp, Unicode.cpp
  • UnicodeUtf8Strchr() : Unicode.hpp, Unicode.cpp
  • UnicodeUtf8Strlen() : Unicode.hpp, Unicode.cpp
  • UnicodeUtf8Validate() : Unicode.hpp, Unicode.cpp
  • UnlockedDbgOut() : HeapManager.cpp
  • Unused() : Macros.hpp
  • Utf8FromUnicode() : Unicode.hpp, Unicode.cpp
  • Utf8ToUnicode() : Unicode.hpp, Unicode.cpp
  • Utf8Validator() : parsifal.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • VarPageTest() : HeapManager.cpp
  • Vector_Append() : vector.cpp
  • Vector_Create() : vector.cpp
  • Vector_Free() : vector.cpp
  • Vector_Resize() : vector.cpp
  • VIB_init() : vib_drv.cpp
  • VIB_pause() : vib_drv.cpp
  • VIB_start() : vib_drv.cpp
  • VIB_status() : vib_drv.cpp
  • VIB_stop() : vib_drv.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • WbDigitValue() : WStrUtil.hpp, WStrUtil.cpp
  • wc_strncmp() : WildcardStrncmp.hpp, WildcardStrncmp.cpp
  • wc_strncmp< CHAR >() : WildcardStrncmp.cpp, AuxiliaryTemplates.cpp
  • wc_strncmp< WCHAR >() : WildcardStrncmp.cpp, AuxiliaryTemplates.cpp
  • WCharStrToLower() : WStrUtil.hpp, WStrUtil.cpp
  • WCharStrToUpper() : WStrUtil.hpp, WStrUtil.cpp
  • WCharToLower() : WStrUtil.hpp, WCattr.cpp
  • WCharToUpper() : WStrUtil.hpp, WCattr.cpp
  • WdDigitValue() : WStrUtil.hpp, WStrUtil.cpp
  • WDecompose() : WCattr.hpp, WCattr.cpp
  • while() : DrawChar_16Bpp.cpp
  • WIsComposed() : WCattr.hpp, WCattr.cpp
  • WIsUnicode() : WCattr.hpp, WCattr.cpp
  • WminusSign() : WStrUtil.hpp, WStrUtil.cpp
  • WoDigitValue() : WStrUtil.hpp, WStrUtil.cpp
  • WrongSimKeyboardAllowed() : SimChvHandler.cpp
  • WrongSimStartupAllowed() : SimChvHandler.cpp
  • WStrCat() : WStrUtil.hpp, WStrUtil.cpp
  • WStrChr() : WStrUtil.hpp, WStrUtil.cpp
  • WStrCmp() : WStrUtil.hpp, WStrUtil.cpp
  • WStrCpy() : WStrUtil.hpp, WStrUtil.cpp
  • WStringAccessOperatorTest() : WString.cpp
  • WStringAccessTest() : WString.cpp
  • WStringAssignmentOperators() : WString.cpp
  • WStringCompareOperatorTest() : WString.cpp
  • WStringConstructorTest() : WString.cpp
  • WStringFindTest() : WString.cpp
  • WStringFormatTest() : WString.cpp
  • WStringManipulationTest() : WString.cpp
  • WStringStreamOperators() : WString.cpp
  • WStringTest() : WString.hpp, WString.cpp
  • WStrLen() : WStrUtil.hpp, WStrUtil.cpp
  • WStrnCat() : WStrUtil.hpp, WStrUtil.cpp
  • WStrnCmp() : WStrUtil.hpp, WStrUtil.cpp
  • WStrnCpy() : WStrUtil.hpp, WStrUtil.cpp
  • WStrPrINTD() : WStrUtil.cpp
  • WStrPrintD() : WStrUtil.hpp
  • wstrprintf() : WStrUtil.hpp, Wsprintf.cpp
  • WStrPrintf() : WStrUtil.hpp, Wsprintf.cpp
  • WStrrChr() : WStrUtil.hpp, WStrUtil.cpp
  • WStrrStr() : WStrUtil.hpp, WStrUtil.cpp
  • WStrrStrn() : WStrUtil.hpp, WStrUtil.cpp
  • wstrscanf() : WStrUtil.hpp, Wsscanf.cpp
  • WStrScanf() : WStrUtil.hpp, Wsscanf.cpp
  • WStrStr() : WStrUtil.hpp, WStrUtil.cpp
  • WStrStrn() : WStrUtil.hpp, WStrUtil.cpp
  • WStrToInt() : WStrUtil.hpp, WStrUtil.cpp
  • WStrToInt32() : WStrUtil.hpp, WStrUtil.cpp
  • WStrToStr() : WStrUtil.hpp, WStrUtil.cpp
  • WType() : WCattr.hpp, WCattr.cpp
  • WxDigit() : WStrUtil.hpp, WStrUtil.cpp
  • WxDigitValue() : WStrUtil.hpp, WStrUtil.cpp
  • WXStrCmp() : WStrUtil.hpp, WStrUtil.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • xml_MemAlloc() : utils.cpp
  • xml_MemFree() : utils.cpp
  • xml_strdup() : utils.cpp
  • XMLParser_GetNamedItem() : parsifal.cpp
  • XMLParser_MiniCreate() : parsifal.cpp
  • XMLParser_MiniFree() : parsifal.cpp
  • XMLParser_Parse() : parsifal.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • years_to_days() : RealTimeClock.cpp
  • ymd_to_scalar() : RealTimeClock.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • ActionPropertiesChangedMsg : MsgTypes.hpp
  • AdcTracer : Trace.hpp
  • AdcTracerLevel2 : Trace.hpp
  • AdcTracerLevel3 : Trace.hpp
  • ApcTracer : Trace.hpp
  • ApcTracerLevel2 : Trace.hpp
  • ApcTracerLevel3 : Trace.hpp
  • ApoxiNewHandlerFn : Allocator.hpp
  • App1Tracer : Trace.hpp
  • App1TracerLevel2 : Trace.hpp
  • App1TracerLevel3 : Trace.hpp
  • App2Tracer : Trace.hpp
  • App2TracerLevel2 : Trace.hpp
  • App2TracerLevel3 : Trace.hpp
  • App3Tracer : Trace.hpp
  • App3TracerLevel2 : Trace.hpp
  • App3TracerLevel3 : Trace.hpp
  • App4Tracer : Trace.hpp
  • App4TracerLevel2 : Trace.hpp
  • App4TracerLevel3 : Trace.hpp
  • AppContainerRoutingTable : AppContainerRoutingTable.hpp
  • AppElemList : AppContainerRoutingTable.hpp
  • ApplicationID : ApplicationID.hpp
  • ApplicationMsg : Message.hpp
  • AppRoutingTable : AppRoutingTable.hpp
  • AppTracer : Trace.hpp
  • AscTracer : Trace.hpp
  • AscTracerLevel2 : Trace.hpp
  • AscTracerLevel3 : Trace.hpp
  • AtlPropertyEditor : AtlPropertyEditor.hpp
  • AuthProviderPtr : AuthProvider.hpp
  • AuthType : DataConnTextMaps.hpp
  • AuxTracer : Trace.hpp
  • AuxTracerLevel2 : Trace.hpp
  • AuxTracerLevel3 : Trace.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- j -

  • JarExtractId : Unzipper.hpp, Unzipper.cpp
  • JarFileGlobalInfo : Unzip.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- k -

  • KernelTracer : Trace.hpp
  • KernelTracerLevel2 : Trace.hpp
  • KernelTracerLevel3 : Trace.hpp
  • KeyDownComparePred : InputMap.cpp
  • KeyDownMapSearcher : InputMap.cpp
  • KeyUpComparePred : InputMap.cpp
  • KeyUpMapSearcher : InputMap.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • Lac : NetworkTypes.hpp
  • Language : SignalTypes.hpp
  • LanguageData : AcacTypes.hpp
  • LineAlignment : EditorDocument.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • MainHandlerList : MainHandler.hpp
  • MapItemType : InputMap.hpp
  • Mcc : NetworkTypes.hpp
  • MdhTimeStamp : MdhTypes.hpp
  • MdhViewHdl : MdhTypes.hpp
  • MediaRefPtr : MediaRefContainer.hpp
  • MenuID : MenuID.hpp
  • MenuListModel : MenuList.hpp
  • MenuResourceTable : MenuResourceTable.hpp
  • MimeType : MimeTypeTable.hpp
  • MmiTracer : Trace.hpp
  • MmiTracerLevel2 : Trace.hpp
  • MmiTracerLevel3 : Trace.hpp
  • Mnc : NetworkTypes.hpp
  • MnCause : SignalTypes.hpp
  • MsapPackedData : SimTkTypes.hpp
  • MsgCategory : MsgCategory.hpp
  • MsgId : MsgCategory.hpp
  • MyDataConnProfileStorage : MyDataConnProfileStorage.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • Native16BitBase : MachType.hpp
  • Native32BitBase : MachType.hpp
  • NewHandlerFn : Allocator.hpp
  • NotificationType : InputMapper.hpp
  • Number : DataItem.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • ObexAddrPtr : ObexAddrPtr.hpp
  • ObexAddrTypeId : ObexTypes.hpp
  • ObexServerId : ObexTypes.hpp
  • ObexTransportId : ObexTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • BatteryLoadLevel : SignalTypes.hpp
  • BcdMcc : NetworkTypes.hpp
  • BcdMnc : NetworkTypes.hpp
  • Behaviour : Grid.hpp
  • BitField16 : BitField.hpp
  • BitField32 : BitField.hpp
  • BitField8 : BitField.hpp
  • BOOL : FfsSim.hpp, FatSim.hpp
  • BrushStyle : Brush.hpp
  • BtBipAttachmentDescPtr : BtBipTypes.hpp
  • BtBipAttachmentFormatPtr : BtBipTypes.hpp
  • BtBipAttachmentPtr : BtBipTypes.hpp
  • BtBipImageDescPtr : BtBipTypes.hpp
  • BtBipImageFormatPtr : BtBipTypes.hpp
  • BtBipImageHdlDescPtr : BtBipTypes.hpp
  • BtBipImageHdlPtr : BtBipTypes.hpp
  • BtBipImageListPtr : BtBipTypes.hpp
  • BtBipImagePropertiesPtr : BtBipTypes.hpp
  • BtBipImagePtr : BtBipTypes.hpp
  • BtBipImagingCapabilitiesPtr : BtBipTypes.hpp
  • BtBipMsgArgPtr : BtBipMsgArg.hpp
  • BtBipServerNotificationMsgArgPtr : BtBipNotificationMsgArg.hpp
  • BtOperationPtr : BtOperationBase.hpp
  • byte : FfsSim.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CallbackMethod : PdpContextManager.host.cpp, PdpContext.host.cpp
  • CallIndex : Types.hpp
  • Cb_function_ptr : NotificationTable.hpp
  • CcbsAction : SignalTypes.hpp
  • CcbsStatus : SignalTypes.hpp
  • CellId : NetworkTypes.hpp
  • ChannelData : SimTkTypes.hpp
  • ChannelNo : Types.hpp
  • CharComparePred : InputMap.cpp
  • CharMapSearcher : InputMap.cpp
  • CheckBoxListModel : CheckBoxList.hpp
  • ChvAttempts : SignalTypes.hpp
  • ColorValue : Color.hpp
  • COMM_ROOT_CERT : HttpWapMgrBase.hpp
  • COMM_USER_CERT : HttpWapMgrBase.hpp
  • CompareFunction : DataItem.hpp
  • ContextID : ContextID.hpp
  • CPGlyph : AcacTypes.hpp
  • CreateFunction : DataItem.hpp
  • CriticalSection : Win32.hpp
  • CustFileData : AcacTypes.hpp
  • CustomizationPackData : AcacTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • DataConnProfileId : SocketTypes.hpp
  • DataConnProfileIdSet : SocketTypes.hpp
  • DataConnProfilePtr : DataConnProfile.hpp
  • DataConnProfileType : DataConnApp.hpp
  • DataConnPropertyType : DataConnApp.hpp
  • DataConnPtr : Win32SysDnsClient.hpp, LwipSysDnsClient.hpp, DataConnProfile.hpp
  • DataConnTempProfileIdSet : SocketTypes.hpp
  • DataPackHeaderData : AcacTypes.hpp
  • DataPackId : AcacTypes.hpp
  • DataRecordId : DataRecord.hpp
  • DataSinkPtr : DataSink.hpp
  • DataSourcePtr : DataSourceBinData.hpp, DataSource.hpp
  • DateFormat : Date.hpp
  • DATESTR : FatSim.hpp
  • DcError : SignalTypes.hpp
  • Dcs : LcsTypes.hpp
  • DDrvAtom : Ddrv.cpp
  • DDrvColorBits16 : Ddrv.cpp
  • DDrvColorBits32 : Ddrv.cpp
  • DDrvColorBits8 : Ddrv.cpp
  • DeleteFunction : DataItem.hpp
  • DeviceMap : FatStorageDeviceImp.cpp
  • dir_id_type : FfsSim.hpp
  • DirectoryIteratorPtr : RootFileSystem.hpp
  • DispatcherActionList : DispatcherAction.hpp, AppRoutingTable.hpp
  • DlSc : NetworkTypes.hpp
  • Dmr_DMObjectData : RegistryTypes.hpp
  • DrmKey : DrmCore.hpp
  • DrmLocalId : DrmCore.hpp
  • DrmROStore : DrmRightsStore.hpp
  • DrmUid : DrmCore.hpp
  • DSTAT : FatSim.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • EditBoxShiftState : EditBox.hpp
  • EmApoxiVideoRenderer : EmApoxiVideoRenderer.cpp
  • EntryId : AcacTypes.hpp
  • EnumTextTable : EnumTextMap.hpp
  • ExtIndicator : SignalTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • FatHandle : FatTypes.hpp
  • FatTimeRecord : FatTypes.hpp
  • FeatureID : FeatureID.hpp
  • FeatureItemContainerID : FeatureItemContainerID.hpp
  • ffs_handle_type : FfsSim.hpp
  • ffsError : FfsTestError.hpp
  • FfsFileId : FfsTypes.hpp
  • FfsHandle : FfsTypes.hpp
  • FileDataSinkPtr : FileDataSink.hpp
  • FileDataSourcePtr : FileDataSource.hpp
  • FileFilterPtr : RootFileSystem.hpp, FileVisitor.hpp
  • FileInfo : Unzip.hpp
  • FileInfoInternal : Unzip.hpp
  • FilePackData : AcacTypes.hpp
  • FilePtr : MediaRefContainer.hpp, RootFileSystem.hpp, FileDataSource.hpp, FileDataSink.hpp, FileBinData.hpp
  • FLAG : RegEncoderDecoder.hpp
  • FontAlign : TextFormat.hpp
  • FontData : AcacTypes.hpp
  • FontFamily : AcacTypes.hpp
  • FontPackData : AcacTypes.hpp
  • FrameType : Control.hpp
  • fs_dstat_type : FatSim.hpp
  • fs_fd_type : FatSim.hpp
  • FS_MS_StatusNotificationFunction_type : FatSim.hpp
  • fs_stat_type : FatSim.hpp
  • FtpAuthProviderPtr : FtpAuthProvider.hpp
  • FtpClientPtr : FtpClient.hpp
  • FtpDataServerSocketPtr : FtpDataServerSocket.hpp
  • FtpDataSocketPtr : FtpDataSocket.hpp
  • FtpInTransferPtr : FtpInTransfer.hpp
  • FtpOutTransferPtr : FtpOutTransfer.hpp
  • FtpServerConfigPtr : FtpServerConfig.hpp
  • FtpServerPtr : FtpServer.hpp
  • FtpServerSocketPtr : FtpServerSocket.hpp
  • FtpSocketPtr : FtpSocket.hpp
  • FtpTransferPtr : FtpTransfer.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GenericTypeId : GenericObject.hpp
  • GlyphData : AcacTypes.hpp
  • GuiTracer : Trace.hpp
  • GuiTracerLevel2 : Trace.hpp
  • GuiTracerLevel3 : Trace.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • HandlerList : HandlerList.hpp
  • HashKey : HashTable.hpp
  • HeapDataSinkPtr : HeapDataSource.hpp, HeapDataSink.hpp
  • HeapDataSourcePtr : HeapDataSource.hpp
  • HostDirectoryIteratorMap : FatSim.cpp
  • HostFatFsDeviceDescMap : FatSim.hpp
  • HostFatFsDeviceDescMapPtr : FatSim.hpp
  • HostFfsIterMap : FfsSim.cpp
  • HttpAuthProviderPtr : HttpAuthProvider.hpp
  • HttpClientPtr : HttpClient.hpp
  • HttpRequestHeaders : HttpRequest.hpp
  • HttpResponseHeaders : HttpResponse.hpp
  • HttpServerConfigPtr : HttpServerConfig.hpp
  • HttpServerPtr : HttpServer.hpp
  • HttpServerSocketPtr : HttpServerSocket.hpp
  • HttpSocketPtr : HttpSocket.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • IndicatorBarID : IndicatorBarID.hpp
  • IndicatorID : IndicatorID.hpp
  • InputMapperVector : EditConfig.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PB_RESULT : UsimPbTypes.hpp
  • PchClient : PdpTypes.hpp
  • PdpAddress : PdpTypes.hpp
  • PdpArray : PdpTypes.hpp
  • PdpAttachState : PdpTypes.hpp
  • PdpAuthentification : PdpTypes.hpp
  • PdpCid : PdpTypes.hpp
  • PdpCidArray : PdpTypes.hpp
  • PdpCidStatArray : PdpTypes.hpp
  • PdpContextData : PdpTypes.hpp
  • PdpPacketFilterPtr : PsdDataConnProfile.hpp
  • PdpQos : PdpTypes.hpp
  • PdpQosArray : PdpTypes.hpp
  • PenStyle : Pen.hpp
  • PlayerData : MediaPlayer.cpp
  • PlmnPlacementIndicator : NetworkTypes.hpp
  • PlmnScanList : PlmnScanList.hpp
  • PppCallback : SysSocketBase.hpp
  • ProcessId : SignalTypes.hpp
  • ProcessPtr : SignalMapTableEntry.hpp
  • PropertyEditorID : PropertyEditorID.hpp
  • PropertyID : PropertyID.hpp
  • ProviderId : ProvIds.hpp
  • ProviderPtrList : MainProvider.hpp
  • PsdIfCallback : SysSocketBase.hpp
  • ptEAADevice : EmApoxiAudioDeviceImpl.cpp
  • ptr_GetAudioBufferFunction : aud_drv.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- q -

  • QoS : DataConnTextMaps.hpp
  • Qos : PdpTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • RadioButtonListModel : RadioButtonList.hpp
  • RamDataSinkPtr : RamDataSource.hpp, RamDataSink.hpp
  • RamDataSourcePtr : RamDataSource.hpp
  • RamFilePtr : RamFile.hpp
  • RamHandle : RamFileNode.hpp
  • RasterOp : DeviceContext.hpp
  • RegBackupHeader : RegMemoryPool.hpp
  • RegDeletionBuffer : RegMemoryPool.hpp
  • ReleaseComplete : SignalTypes.hpp
  • ResetStateFunc : PdpContextManager.host.cpp
  • RootStorageDeviceIteratorPtr : StorageDeviceIterator.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • SdlBoolean : SignalTypes.hpp
  • SdlByte : SignalTypes.hpp
  • SdlCharacter : SignalTypes.hpp
  • SdlInteger : SignalTypes.hpp
  • SdlSignalId : SignalMapTableEntry.hpp
  • SdlSignalName : SignalMapTableEntry.hpp
  • SdlUlong : SignalTypes.hpp
  • SdlWord : SignalTypes.hpp
  • SerialClientSocketPtr : SioSocketAdapter.hpp
  • SerialServerSocketPtr : SioSocketAdapter.hpp
  • ServerClientPtr : ServerClient.hpp
  • ServerConfigPtr : ServerConfig.hpp
  • ServerPtr : Server.hpp
  • ServiceResult : Service.hpp
  • SharedMem : Win32.hpp
  • SiBearerDesc : SimTkTypes.hpp
  • SiBearerList : SimTkTypes.hpp
  • SiDuration : SimTkTypes.hpp
  • SignalQualityLevel : SignalTypes.hpp
  • SignalStrengthLevel : SignalTypes.hpp
  • SiIpAddress : SimTkTypes.hpp
  • SimChangedState : SimMiscTypes.hpp
  • SimDummy : SimDataTypes.hpp
  • SimErrorCode : SignalTypes.hpp
  • SimFileId : SignalTypes.hpp
  • SimIconId : SimDataTypes.hpp
  • SimItemIdentifierList : SimDataTypes.hpp
  • SimLaunchBrowserPromptReq : SimTkTypes.hpp
  • SimPhase : SignalTypes.hpp
  • SimReferenceNumber : SimDataTypes.hpp
  • SiProvFileRef : SimTkTypes.hpp
  • SiText : SimTkTypes.hpp
  • slong : FatSim.hpp
  • SmsBox : SmsSettingsRecord.hpp
  • SmsPortNo : InformationElement.hpp
  • SmsReferenceNumber : SimDataTypes.hpp
  • SocketTracer : Trace.hpp
  • SocketTracerLevel2 : Trace.hpp
  • SocketTracerLevel3 : Trace.hpp
  • SsCode : SignalTypes.hpp
  • sshort : FatSim.hpp
  • StackAtom : Scheduler.hpp
  • StackMsgArgId : StackMsgArgument.hpp
  • StackMsgArgName : StackMsgMapTableEntry.hpp
  • STAT : FatSim.hpp
  • StateFunc : StateMachine.hpp
  • StaticValueMappingPropertyDescriptor : ValueMappingPropertyDescriptor.hpp
  • STDENTITIES : parsifal.cpp
  • StorageDeviceFilterPtr : StorageDeviceVisitor.hpp, RootFileSystem.hpp
  • StorageDeviceIteratorPtr : RootFileSystem.hpp
  • StorageDevicePtr : StorageDeviceVisitor.hpp, StorageDeviceFilter.hpp, RootFileSystem.hpp
  • SvgFixPoint : SvgFixPoint.hpp
  • SvgFixPointTrans : SvgFixPoint.hpp
  • SystemColor : Color.hpp
  • SystemColorId : Color.hpp
  • SystemFontId : Font.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • T9LdbData : AcacTypes.hpp
  • T9PackData : AcacTypes.hpp
  • T_PB_DATA : UsimPbTypes.hpp
  • T_PB_LINK_TYPE : UsimPbTypes.hpp
  • T_PB_LOCATION : UsimPbTypes.hpp
  • T_PB_REF : UsimPbTypes.hpp
  • T_PB_SIGNAL_TYPE : UsimPbTypes.hpp
  • TAlphaIdentifier : SimTkTypes.hpp
  • Task : Nuc32.hpp
  • tCallbackFnPtr : EmServThreadMsg.hpp
  • tEAADevice : EmApoxiAudioDeviceImpl.cpp
  • tEmApoxiAudioState : EmApoxiAudioDeviceImpl.cpp
  • TextAlign : TextFormat.hpp
  • TextAttr : TextFormat.hpp
  • TextPackData : AcacTypes.hpp
  • ThreadDataIndex : Win32.hpp
  • ThreadId : Thread.hpp
  • ThreadName : Win32.hpp, Nuc32.hpp
  • ThreadPriority : Win32.hpp, Nuc32.hpp
  • TI_PD : LcsTypes.hpp
  • TimeFormat : Time.hpp
  • TimerList : Timer.hpp
  • Tipd : SignalTypes.hpp
  • TLLVector : TextList.hpp
  • TlvAtom : Tlv.hpp
  • Tracer : Trace.hpp
  • TranslationTable : AcacTypes.hpp
  • TrapCB : Trap.hpp
  • TSiIconID : SimTkTypes.hpp
  • TSiUrl : SimTkTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • Uarfcn : NetworkTypes.hpp
  • ubyte : FatSim.hpp
  • UCHAR : InternalTracer.cpp, WinInc.hpp
  • ulong : FfsSim.hpp, FatSim.hpp
  • ushort : FatSim.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • ValueItem : ValueItem.hpp
  • Volume : SignalTypes.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • WapProfileId : WapProfile.hpp
  • Wav : aud_drv.cpp
  • word : FfsSim.hpp
  • WrapPolicy : EditorDocument.hpp
Generated on Wed Jan 25 02:31:19 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- a -

  • A_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • acb : FillRect_Planes.cpp
  • acb_brushstyle : FillRect_Planes.cpp
  • AdjustToneRpt : SignalTypes.hpp
  • AID_DATA_FNAME : GltpProviderImpl.cpp
  • AlarmToneRpt : SignalTypes.hpp
  • AMR_SM_WORDS : HostAudioDriver.hpp
  • apoxi_stack_init_val : Thread.cpp, Nuc32.cpp
  • ApoxiNewHandler : Allocator.hpp, Allocator.cpp
  • append_text_sample : FfsTests.cpp
  • atom_bit : SetPixel_Planes.cpp, GetPixelColor_Planes.cpp
  • atom_brushstyle_bits : FillRect_Planes.cpp
  • atoms_per_scanline : DrawChar_Planes.cpp, DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp
  • aud_tone_alarm_1_data : Audio.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- j -

  • jpeg_image : SampleImages.hpp, SampleImages.cpp
  • jpeg_image_size : SampleImages.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- k -

  • key_tone_1_data : Audio.cpp
  • key_tone_2_data : Audio.cpp
  • key_tone_3_data : Audio.cpp
  • key_tone_4_data : Audio.cpp
  • KeyToneRpt : SignalTypes.hpp
  • kissing : SampleImages.hpp, SampleImages.cpp
  • kissing_size : SampleImages.hpp
  • knockyourhead : SampleIMelodies.hpp, SampleIMelodies.cpp
  • knockyourhead_size : SampleIMelodies.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- l -

  • left : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • left_atom : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • left_atom_idx : BitBlit_Planes.cpp
  • left_clip : BitBlit_Planes.cpp
  • left_clip_inc : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • left_mask : ScrollVertical_Planes.cpp, FillRect_Planes.cpp
  • left_mask_1 : BitBlit_Planes.cpp
  • left_mask_2 : BitBlit_Planes.cpp
  • len : VCard.cpp
  • line_inc : ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, FillRect_16Bpp.cpp, DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp, ScrollVertical_16Bpp.cpp, DrawChar_16Bpp.cpp
  • LowBattToneRpt : SignalTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- m -

  • m_currpos : MdhSignalProcessor.cpp
  • m_lastpos : MdhSignalProcessor.cpp
  • m_lastrange : MdhSignalProcessor.cpp
  • m_process_ptr : MdhSignalProcessor.cpp
  • m_rangestart : MdhSignalProcessor.cpp
  • m_smscount : MdhSignalProcessor.cpp
  • m_timer : MdhSignalProcessor.cpp
  • m_view : MdhSignalProcessor.cpp
  • mambo : SampleIMelodies.hpp, SampleIMelodies.cpp
  • mambo_size : SampleIMelodies.hpp
  • mask : SetPixel_Planes.cpp
  • mask_dest : ScrollHorizontal_Planes.cpp
  • mask_src : ScrollHorizontal_Planes.cpp
  • max_calendar_description_len : CalendarRecord.hpp
  • MAX_EXPONENT : LcsUtils.cpp
  • MAX_K_VALUE : LcsUtils.hpp
  • MAX_SATS : LcsTypes.hpp
  • MC_APP : MsgCategory.hpp
  • MC_AT : MsgCategory.hpp
  • MC_BROADCAST : MsgCategory.hpp
  • MC_CONTEXT : MsgCategory.hpp
  • MC_CONTROL : MsgCategory.hpp
  • MC_FOCUS : MsgCategory.hpp
  • MC_IPC : MsgCategory.hpp
  • MC_NOT_VALID : MsgCategory.hpp
  • MC_SIGNAL : MsgCategory.hpp
  • MC_STACK_CONTROL : MsgCategory.hpp
  • MC_SYSTEM : MsgCategory.hpp
  • MC_WIN : MsgCategory.hpp
  • MdhInitTimeStamp : MdhTypes.hpp
  • message_tone_10_data : Audio.cpp
  • message_tone_1_data : Audio.cpp
  • message_tone_2_data : Audio.cpp
  • message_tone_3_data : Audio.cpp
  • message_tone_4_data : Audio.cpp
  • message_tone_5_data : Audio.cpp
  • message_tone_6_data : Audio.cpp
  • message_tone_7_data : Audio.cpp
  • message_tone_8_data : Audio.cpp
  • message_tone_9_data : Audio.cpp
  • message_tone_single_beep_data : Audio.cpp
  • middle_mask_1 : BitBlit_Planes.cpp
  • middle_mask_2 : BitBlit_Planes.cpp
  • min_distance : ConvertToColorValue_Planes.cpp
  • MpegLayer : HostAudioDriver.cpp
  • MpegV1Freq : HostAudioDriver.cpp
  • MpegV1L3Br : HostAudioDriver.cpp
  • MpegV2Freq : HostAudioDriver.cpp
  • MpegV2L3Br : HostAudioDriver.cpp
  • MpegVersion : HostAudioDriver.cpp
  • MsgAlertRpt : SignalTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- n -

  • n_delta : BitBlit_Planes.cpp
  • n_left_mask_1 : BitBlit_Planes.cpp
  • n_left_mask_2 : BitBlit_Planes.cpp
  • n_right_mask_1 : BitBlit_Planes.cpp
  • n_right_mask_2 : BitBlit_Planes.cpp
  • name : VCard.cpp
  • ndelta : DrawChar_Planes.cpp
  • new_file_name : FfsTests.cpp
  • NewHandler : Allocator.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- o -

  • overwrite_text_sample : FfsTests.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- b -

  • BASE_10 : LcsUtils.cpp
  • bitmap : SetPixel_Planes.cpp, ScrollVertical_Planes.cpp, ScrollHorizontal_Planes.cpp, FillRect_Planes.cpp
  • black_and_white_theme : BlackAndWhiteTheme.hpp, BlackAndWhiteTheme.cpp
  • blue_exp_2 : ConvertToColorValue_Planes.cpp
  • blue_sky_chinese_theme : BlueSkyChineseTheme.hpp, BlueSkyChineseTheme.cpp
  • blue_sky_theme : BlueSkyTheme.hpp, BlueSkyTheme.cpp
  • bmp_width : BitBlit_16Bpp.cpp
  • bottom : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • broadcast_tone_1_data : Audio.cpp
  • broadcast_tone_2_data : Audio.cpp
  • broadcast_tone_3_data : Audio.cpp
  • broadcast_tone_4_data : Audio.cpp
  • bt_c_empty_device_address : BtDeviceAddress.hpp, BtDeviceAddress.cpp
  • bt_c_empty_device_list : BtDeviceList.hpp
  • bt_c_unknown_device : BtDevice.hpp, BtDevice.cpp
  • bt_device_address_generic_object_type_id : BtDeviceListsWindows.cpp
  • bt_device_list_address_column_id : BtDeviceListsWindows.cpp
  • bt_device_list_device_major_class_column_id : BtDeviceListsWindows.cpp
  • bt_device_list_device_minor_class_column_id : BtDeviceListsWindows.cpp
  • bt_device_list_name_column_id : BtDeviceListsWindows.cpp
  • bt_device_list_provider_id : BtDeviceListsWindows.cpp
  • BUFFER_SIZE : RegAppWin.cpp
  • byte_count : FillRect_16Bpp.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- c -

  • c_2_letter_iso639_code_id : ProviderIds.hpp
  • c_3_letter_iso639_code_id : ProviderIds.hpp
  • c_abstract_menu_list_imid : InputMap.hpp
  • c_acm_rec_size : SimAccessor.hpp
  • c_alarm_manager_max_entries : AlarmManager.hpp
  • c_apn_name_len_max : SocketTypes.hpp
  • c_apoxi_base_gentypes : GenericObject.hpp
  • c_apoxi_powersaving_timer_alignment_lower_bound : Os.hpp
  • c_apoxi_powersaving_timer_alignment_upper_bound : Os.hpp
  • c_append_row : Provider.hpp
  • c_ati_codec_max_num_of_mpeg4_dec_inst : AtiMpeg4Decoder.hpp
  • c_ati_codec_mpeg4_dec_out_buf_def_count : AtiMpeg4Decoder.cpp
  • c_ati_codec_mpeg4_dec_out_buf_max_count : AtiMpeg4Decoder.cpp
  • c_ati_codec_mpeg4_dec_out_buf_min_count : AtiMpeg4Decoder.cpp
  • c_ati_codec_mpeg4_enc_out_buf_def_count : AtiMpeg4Encoder.cpp
  • c_ati_codec_mpeg4_enc_out_buf_max_count : AtiMpeg4Encoder.cpp
  • c_ati_codec_mpeg4_enc_out_buf_min_count : AtiMpeg4Encoder.cpp
  • c_ati_codecs_max_num_of_mpeg4_enc_inst : AtiMpeg4Encoder.hpp
  • c_attempts_left_undefined : SimChvHandler.hpp
  • c_bip_client_put_packet_size : BtBipPutReq.cpp, BtBipPutImageRsp.cpp
  • c_bip_client_read_buf_size : BtBipClientService.hpp, BtBipClientService.cpp
  • c_bip_convert_buf_size : BtBipMecelXmlConverter.cpp
  • c_bip_invalid_res : BtBipTypes.hpp, BtBipTypes.cpp
  • c_bip_max_image_hdl : BtBipTypes.hpp, BtBipTypes.cpp
  • c_bip_server_read_buf_size : BtBipServerService.cpp
  • c_black_and_white_system_color_table : BlackAndWhiteTheme.cpp
  • c_black_and_white_system_font_table : BlackAndWhiteTheme.cpp
  • c_blobobject_type : BlobObject.hpp
  • c_blobptr_type : BlobPtr.hpp
  • c_blue_sky_chinese_system_font_table : BlueSkyChineseTheme.cpp
  • c_blue_sky_system_color_table : BlueSkyTheme.cpp, BlueSkyChineseTheme.cpp
  • c_blue_sky_system_font_table : BlueSkyTheme.cpp
  • c_broker_table_size : ServiceBroker.hpp
  • c_bytes_per_pixel_of_rawdata : VideoCamera.cpp
  • c_Cancel_imid : InputMap.hpp
  • c_cbs_default_active_timer : Cbs.hpp
  • c_cbs_default_sleep_timer : Cbs.hpp
  • c_ccp_rec_size : SimAccessor.hpp
  • c_check_box_imid : InputMap.hpp
  • c_check_box_list_imid : InputMap.hpp
  • c_CheckBoxChangeStatus_imid : InputMap.hpp
  • c_chv_padding_char : ChvStackMsgArgs.hpp
  • c_common_setting_editable : DataConnApp.cpp
  • c_compound_sms_item_type : CompoundSmsItem.hpp
  • c_compound_tpdu_item_type : CompoundSmsItem.hpp
  • c_Confirm_imid : InputMap.hpp
  • c_control_imid : InputMap.hpp
  • c_cphs_sst_count : SimCphsHandler.hpp
  • c_cphs_sst_len : SimCphsHandler.hpp
  • c_cr : TextEditorDocument.cpp
  • c_crossover_win_id : LocResController.cpp
  • c_csd_setting_editable : DataConnApp.cpp
  • c_csms_pid_check_enabled : SimPduHandler.cpp
  • c_data_conn_profile_count : SocketTypes.hpp
  • c_data_conn_temp_profile_count : SocketTypes.hpp
  • c_dcs_language_code_id : ProviderIds.hpp
  • c_default_chinese_system_color_table : DefaultChineseTheme.cpp
  • c_default_chinese_system_font_table : DefaultChineseTheme.cpp
  • c_default_csms_state_changeable : SimPduHandler.cpp
  • c_default_data_conn_profile_id : SocketTypes.hpp
  • c_default_depth : PhoneNumber.hpp
  • c_default_max_pdu_per_sms : SimPduHandler.hpp
  • c_default_system_color_table : DefaultTheme.cpp
  • c_default_tpdu_cache_size : SimPduHandler.cpp
  • c_df_cingular_id : SimAccessor.hpp
  • c_df_graphics_id : SimAccessor.hpp
  • c_df_gsm_id : SimAccessor.hpp
  • c_df_mexe_id : SimAccessor.hpp
  • c_df_mf_id : SimAccessor.hpp
  • c_df_orange_id : SimAccessor.hpp
  • c_df_telecom_id : SimAccessor.hpp
  • c_drm_invalid_local_id : DrmCore.hpp
  • c_ecc_rec_size : SimAccessor.hpp
  • c_edit_box_imid : InputMap.hpp
  • c_EditBoxCursorDown_imid : InputMap.hpp
  • c_EditBoxCursorLeft_imid : InputMap.hpp
  • c_EditBoxCursorRight_imid : InputMap.hpp
  • c_EditBoxCursorUp_imid : InputMap.hpp
  • c_EditBoxDeleteCharacter_imid : InputMap.hpp
  • c_EditBoxDtmfSeparator_imid : InputMap.hpp
  • c_EditBoxPlus_imid : InputMap.hpp
  • c_EditBoxShiftKey_imid : InputMap.hpp
  • c_EditBoxWildcard_imid : InputMap.hpp
  • c_ef_acm_id : SimAccessor.hpp
  • c_ef_acmmax_id : SimAccessor.hpp
  • c_ef_ad_id : SimAccessor.hpp
  • c_ef_adn_id : SimAccessor.hpp
  • c_ef_arpk_id : SimAccessor.hpp
  • c_ef_bdn_id : SimAccessor.hpp
  • c_ef_call_fwrd_id : SimAccessor.hpp
  • c_ef_cbmi_id : SimAccessor.hpp
  • c_ef_cbmid_id : SimAccessor.hpp
  • c_ef_cbmir_id : SimAccessor.hpp
  • c_ef_ccp_id : SimAccessor.hpp
  • c_ef_cfis_id : SimAccessor.hpp
  • c_ef_cmi_id : SimAccessor.hpp
  • c_ef_cphs_info_no_id : SimAccessor.hpp
  • c_ef_cphsinfo_id : SimAccessor.hpp
  • c_ef_cust_serv_id : SimAccessor.hpp
  • c_ef_dynamic2_id : SimAccessor.hpp
  • c_ef_dynamic_id : SimAccessor.hpp
  • c_ef_ecc_id : SimAccessor.hpp
  • c_ef_elp_id : SimAccessor.hpp
  • c_ef_emlpp_id : SimAccessor.hpp
  • c_ef_ext1_id : SimAccessor.hpp
  • c_ef_ext2_id : SimAccessor.hpp
  • c_ef_ext3_id : SimAccessor.hpp
  • c_ef_ext4_id : SimAccessor.hpp
  • c_ef_ext6_id : SimAccessor.hpp
  • c_ef_ext7_id : SimAccessor.hpp
  • c_ef_fdn_id : SimAccessor.hpp
  • c_ef_img_id : SimAccessor.hpp
  • c_ef_imsi_id : SimAccessor.hpp
  • c_ef_lnd_id : SimAccessor.hpp
  • c_ef_loci_id : SimAccessor.hpp
  • c_ef_lp_id : SimAccessor.hpp
  • c_ef_mbdn_id : SimAccessor.hpp
  • c_ef_mbi_id : SimAccessor.hpp
  • c_ef_mbox_no_id : SimAccessor.hpp
  • c_ef_mexest_id : SimAccessor.hpp
  • c_ef_msisdn_id : SimAccessor.hpp
  • c_ef_opl_id : SimAccessor.hpp
  • c_ef_opn_str_srt_id : SimAccessor.hpp
  • c_ef_opname_str_id : SimAccessor.hpp
  • c_ef_orpk_id : SimAccessor.hpp
  • c_ef_param_id : SimAccessor.hpp
  • c_ef_plmnsel_id : SimAccessor.hpp
  • c_ef_plmnselwact_id : SimAccessor.hpp
  • c_ef_pnn_id : SimAccessor.hpp
  • c_ef_puct_id : SimAccessor.hpp
  • c_ef_sdn_id : SimAccessor.hpp
  • c_ef_sms_id : SimAccessor.hpp
  • c_ef_smsp_id : SimAccessor.hpp
  • c_ef_smsr_id : SimAccessor.hpp
  • c_ef_smss_id : SimAccessor.hpp
  • c_ef_spdi_id : SimAccessor.hpp
  • c_ef_spn_id : SimAccessor.hpp
  • c_ef_sst_id : SimAccessor.hpp
  • c_ef_tprpk_id : SimAccessor.hpp
  • c_ef_tst_id : SimAccessor.hpp
  • c_ef_vbs_id : SimAccessor.hpp
  • c_ef_vbss_id : SimAccessor.hpp
  • c_ef_vgcs_id : SimAccessor.hpp
  • c_ef_vgcss_id : SimAccessor.hpp
  • c_ef_vmsg_wtng_id : SimAccessor.hpp
  • c_email_id : PbProvIds.hpp
  • c_emergency_list_length : EccProvider.cpp
  • c_emergency_list_length_sim : EccProvider.cpp
  • c_empty_internal_refno : SimPduHandler.cpp
  • c_empty_reload_entry : SimPduHandler.cpp
  • c_empty_string : PbConfig.hpp
  • c_emz_codec_aac_dec_multi_frame_out_buf_max_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_multi_frame_out_buf_max_len : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_multi_frame_out_buf_min_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_op_queue_max_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_single_frame_out_buf_max_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_single_frame_out_buf_min_count : EmzAacDecoder.cpp
  • c_emz_codec_aac_dec_thread_prio : EmzAacDecoderThread.cpp
  • c_emz_codec_aac_dec_thread_stacksize : EmzAacDecoderThread.cpp
  • c_emz_codec_h264_dec_op_queue_max_count : EmzH264Decoder.cpp
  • c_emz_codec_h264_dec_out_buf_max_count : EmzH264Decoder.cpp
  • c_emz_codec_h264_dec_out_buf_min_count : EmzH264Decoder.cpp
  • c_emz_codec_h264_dec_thread_prio : EmzH264DecoderThread.cpp
  • c_emz_codec_h264_dec_thread_stacksize : EmzH264DecoderThread.cpp
  • c_emz_codec_max_num_of_aac_dec_inst : EmzAacDecoder.hpp
  • c_emz_codec_max_num_of_h264_dec_inst : EmzH264Decoder.hpp
  • c_emz_codec_max_num_of_mp3_dec_inst : EmzMp3Decoder.hpp
  • c_emz_codec_max_num_of_mpeg4_dec_inst : EmzMpeg4Decoder.hpp
  • c_emz_codec_max_num_of_sbc_enc_inst : EmzSbcEncoder.hpp
  • c_emz_codec_mp3_dec_multi_frame_out_buf_max_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_multi_frame_out_buf_max_len : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_multi_frame_out_buf_min_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_op_queue_max_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_single_frame_out_buf_max_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_single_frame_out_buf_min_count : EmzMp3Decoder.cpp
  • c_emz_codec_mp3_dec_thread_prio : EmzMp3DecoderThread.cpp
  • c_emz_codec_mp3_dec_thread_stacksize : EmzMp3DecoderThread.cpp
  • c_emz_codec_mpeg4_dec_op_queue_max_count : EmzMpeg4Decoder.cpp
  • c_emz_codec_mpeg4_dec_out_buf_max_count : EmzMpeg4Decoder.cpp
  • c_emz_codec_mpeg4_dec_out_buf_min_count : EmzMpeg4Decoder.cpp
  • c_emz_codec_mpeg4_dec_thread_prio : EmzMpeg4DecoderThread.cpp
  • c_emz_codec_mpeg4_dec_thread_stacksize : EmzMpeg4DecoderThread.cpp
  • c_emz_codec_mpeg4_enc_op_queue_max_count : EmzMpeg4Encoder.cpp
  • c_emz_codec_mpeg4_enc_out_buf_max_count : EmzMpeg4Encoder.cpp
  • c_emz_codec_mpeg4_enc_out_buf_min_count : EmzMpeg4Encoder.cpp
  • c_emz_codec_mpeg4_enc_thread_prio : EmzMpeg4EncoderThread.cpp
  • c_emz_codec_mpeg4_enc_thread_stacksize : EmzMpeg4EncoderThread.cpp
  • c_emz_codec_sbc_enc_multi_frame_out_buf_max_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_multi_frame_out_buf_max_len : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_multi_frame_out_buf_min_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_op_queue_max_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_single_frame_out_buf_max_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_single_frame_out_buf_min_count : EmzSbcEncoder.cpp
  • c_emz_codec_sbc_enc_thread_prio : EmzSbcEncoderThread.cpp
  • c_emz_codec_sbc_enc_thread_stacksize : EmzSbcEncoderThread.cpp
  • c_emz_codecs_max_num_of_mpeg4_enc_inst : EmzMpeg4Encoder.hpp
  • c_ff_svr_addr : ServerAddressWin.cpp
  • c_ffs_block_header_size : FfsTypes.hpp
  • c_ffs_streaming : FfsTypes.hpp
  • c_filebrowser_for_voicememo : VoiceMemoRecordWin.cpp
  • c_first_provider_id : ProviderIds.hpp
  • c_first_provider_row_id : ProviderIds.hpp
  • c_fix_data_title_text : LocationResultWin.cpp
  • c_FocusNextControl_imid : InputMap.hpp
  • c_FocusPreviousControl_imid : InputMap.hpp
  • c_foggy_system_color : FoggyTheme.cpp
  • c_foggy_system_color_table : FoggyTheme.cpp
  • c_free_tone : AudioPresetStore.hpp, AudioPresetStore.cpp
  • c_fsize_data_conn_profiles : MyDataConnProfileStorage.hpp
  • c_full_name_ie : SimAuxHandler.cpp
  • c_gati_manager_connections_max : GatiManager.hpp
  • c_gati_manager_database_max : GatiManager.hpp
  • c_gati_manager_port : GatiManager.hpp
  • c_gl_aid_svr_addr : ServerAddressWin.cpp
  • c_gltp_mode_value : AidingDataWin.cpp
  • c_grid_imid : InputMap.hpp
  • c_GridMoveDown_imid : InputMap.hpp
  • c_GridMoveLeft_imid : InputMap.hpp
  • c_GridMoveRight_imid : InputMap.hpp
  • c_GridMoveUp_imid : InputMap.hpp
  • c_grp_prov_id : PbProvIds.hpp
  • c_gsm_code_id : ProviderIds.hpp
  • c_heapid : HeapManager.cpp
  • c_host_name_len_max : SocketTypes.hpp
  • c_icc_id_id : PbProvIds.hpp
  • c_image_ref_ptr_type : ImageRefGenContainer.hpp
  • c_img_obt_type : ImgObtObj.hpp
  • c_insert_width : DefaultCaret.cpp
  • c_invalid_call_id : MmTypes.hpp
  • c_invalid_colid : Provider.hpp
  • c_invalid_context_id : HeapVector.hpp
  • c_invalid_data_conn_profile_id : SocketTypes.hpp
  • c_invalid_date : ToDoRecord.hpp
  • c_invalid_nibble : PhoneNumber.hpp
  • c_invalid_parsed_number : InputAction.hpp
  • c_invalid_position : SimPbEntryCont.hpp
  • c_it_buffer_size : AtResponseIterator.hpp
  • c_it_read_size : AtResponseIterator.hpp
  • c_item_ptr_type : ItemObj.hpp
  • c_key_column_id : ProviderIds.hpp
  • c_language_code_table : LanguageCodeRes.hpp, LanguageCodeRes.cpp
  • c_language_name_id : ProviderIds.hpp
  • c_language_provider_id : ProviderIds.hpp
  • c_language_table_entry_count : LanguageCodeRes.hpp, LanguageCodeRes.cpp
  • c_large_animation_size : InformationElement.hpp
  • c_large_picture_size : InformationElement.hpp
  • c_last_deleted_unique_id : PbProvIds.hpp
  • c_latitude_value : AidingDataWin.cpp
  • c_level_max : BidiManager.cpp
  • c_lf : TextEditorDocument.cpp, ParagraphCompoundItem.cpp
  • c_list_box_imid : InputMap.hpp
  • c_ListBoxNextItem_imid : InputMap.hpp
  • c_ListBoxPreviousItem_imid : InputMap.hpp
  • c_loc_res_title_text : LocationResultWin.cpp
  • c_longitude_value : AidingDataWin.cpp
  • c_ls : BidiManager.cpp
  • c_mark_unmark_icon_table : ToDoProvider.cpp
  • c_max_allowed_time_for_uib_update : UibPerformanceTest.cpp
  • c_max_at_cmd_params : AtCommand.hpp
  • c_max_at_req_alpha_id_size : AtcTypes.hpp
  • c_max_at_resp_params : AtResponse.hpp
  • c_max_bcd_number_size : PhoneNumber.hpp
  • c_max_calls : Types.hpp
  • c_max_cbmi : SimAuxHandler.hpp
  • c_max_cbmir : SimAuxHandler.hpp
  • c_max_ccp : SimAuxHandler.hpp
  • c_max_channels : Types.hpp
  • c_max_char_visible_in_listbox_todolist : ToDoProvider.hpp
  • c_max_chvs : SignalTypes.hpp
  • c_max_cmi_alpha_id_size : SignalTypes.hpp
  • c_max_cmi_records : SimAuxHandler.hpp
  • c_max_cname_string_len : SignalTypes.hpp
  • c_max_customizable_codes : EccProvider.hpp
  • c_max_data_conn_profile_id : SocketTypes.hpp
  • c_max_ecc_network_elements : SignalTypes.hpp
  • c_max_ecc_network_number_length : SignalTypes.hpp
  • c_max_ecc_records : SimAuxHandler.hpp
  • c_max_email_len : PbConfig.hpp
  • c_max_ext_lang_buffer_size : SimAuxHandler.hpp
  • c_max_extlanguages : SimAuxHandler.hpp
  • c_max_fat_filename_len : FatTypes.hpp
  • c_max_fat_max_no_open_files : FatTypes.hpp
  • c_max_filename_len : FfsTypes.hpp
  • c_max_groups : GroupProvider.hpp
  • c_max_inet_socket_count : SocketTypes.hpp
  • c_max_ip_str_len : IpAddr.cpp
  • c_max_lang_buffer_size : SimAuxHandler.hpp
  • c_max_languages : SimAuxHandler.hpp
  • c_max_loc_win_id : LocResController.cpp
  • c_max_mbi_record_length : SimAuxHandler.hpp
  • c_max_mem_ptr : HeapManager.cpp
  • c_max_mpty_members : Types.hpp
  • c_max_name_len : PbConfig.hpp
  • c_max_nibble_range : PhoneNumber.hpp
  • c_max_no_basic_service_groups : SignalTypes.hpp
  • c_max_no_sec_locks : LockTypes.hpp
  • c_max_nvram_pdus : SimPduHandler.hpp
  • c_max_pb_name_entries : PbConfig.hpp
  • c_max_pb_number_entries : PbConfig.hpp
  • c_max_pdus : SimPduHandler.hpp
  • c_max_phonebook_descriptors : AtcTypes.hpp
  • c_max_phonebook_entry_len : SignalTypes.hpp
  • c_max_phonenos : PbConfig.hpp
  • c_max_plmn_buffer_size : SimAuxHandler.hpp
  • c_max_plmns : SimAuxHandler.hpp
  • c_max_rb_size : CalendarDialogWin.hpp
  • c_max_reloadable_pdus : SimPduHandler.hpp
  • c_max_serial_terminals : ExternalPsdContextListener.hpp, SerialTerminal.hpp
  • c_max_sim_pdus : SimPduHandler.hpp
  • c_max_size_telephone_nr : SignalTypes.hpp
  • c_max_size_ussd_string : SignalTypes.hpp
  • c_max_slots : DwdPlayer.hpp
  • c_max_smsparam_entry_len : SignalTypes.hpp
  • c_max_smsparameters : SimSmsParamHandler.hpp
  • c_max_smsr_in_ram : SimPduHandler.hpp
  • c_max_smsr_length : SimPduHandler.hpp
  • c_max_smsr_pdus : SimPduHandler.hpp
  • c_max_specific_at_resp_params : AtCommand.hpp
  • c_max_sst_services : SignalTypes.hpp
  • c_max_table1 : SimPduHandler.hpp
  • c_max_table2 : SimPduHandler.hpp
  • c_max_telnr_size : PhoneNumber.hpp
  • c_max_total_ffs_memory : FfsTypes.hpp
  • c_max_unique_id : PbMergeProvider.hpp
  • c_max_uus1_out_buffer_len : SignalTypes.hpp
  • c_maxno_usim_langs : SignalTypes.hpp
  • c_maxno_usim_plmns : NetworkTypes.hpp
  • c_maxpending_messages : SimAccessor.hpp
  • c_mdh_max_ext_data : MdhTypes.hpp
  • c_menu_desc_ptr_type : MenuDescObj.hpp
  • c_menu_id_ptr_type : MenuIdObj.hpp
  • c_MenuItemSelected_imid : InputMap.hpp
  • c_merged_provider_id : ProviderIds.hpp
  • c_merged_row_id : ProviderIds.hpp
  • c_mm_call_terminal_data_bits : MmCallHandler.hpp
  • c_mm_call_terminal_speed : MmCallHandler.hpp
  • c_mm_call_terminal_stop_bits : MmCallHandler.hpp
  • c_mp_high_max : MergeProvider.cpp
  • c_mp_low_max : MergeProvider.cpp
  • c_mp_merge_max : MergeProvider.cpp
  • c_mpty_indication : Types.hpp
  • c_msg_queue_yield_period : MsgQueue.cpp
  • c_msg_waiting_priority : SmsIndicationState.hpp
  • c_mtc_mask : SignalTypes.hpp
  • c_mutex_timeout : Types.hpp
  • c_name_key_id : PbProvIds.hpp
  • c_name_prov_id : PbProvIds.hpp
  • c_new_recno_id : PbProvIds.hpp
  • c_new_sms_priority : SmsIndicationState.hpp
  • c_new_status_report_priority : SmsIndicationState.hpp
  • c_no_aas_record_value : UsimPbTypes.hpp
  • c_no_data_record_id : DataRecord.hpp
  • c_no_group_value : UsimPbTypes.hpp
  • c_no_id_id : PbProvIds.hpp
  • c_no_of_extlanguages_array : SignalTypes.hpp
  • c_no_of_languages_array : SignalTypes.hpp
  • c_no_prov_id : PbProvIds.hpp
  • c_no_row : Provider.hpp
  • c_no_tipd : SignalTypes.hpp
  • c_no_tonepairs : AudioTypes.cpp
  • c_note_max_length : ToDoRecord.hpp
  • c_null_call_index : Types.hpp
  • c_null_channel_no : Types.hpp
  • c_null_tipd : SignalTypes.hpp
  • c_offset_dcs : SimSmsParamHandler.cpp
  • c_offset_dest_address : SimSmsParamHandler.cpp
  • c_offset_protocol_id : SimSmsParamHandler.cpp
  • c_offset_sc_address : SimSmsParamHandler.cpp
  • c_offset_vp : SimSmsParamHandler.cpp
  • c_on_sim_id : PbProvIds.hpp
  • c_op_srt_name_file_len : SimCphsHandler.hpp
  • c_overwrite_width : DefaultCaret.cpp
  • c_password_len : SignalTypes.hpp
  • c_pb_client_autoload_flag : UsimPbTypes.hpp
  • c_pb_max_file_type_per_record : UsimPbTypes.hpp
  • c_pb_max_groups : UsimPbTypes.hpp
  • c_pb_max_slices : UsimPbTypes.hpp
  • c_pending_priority : SmsIndicationState.hpp
  • c_phoneno_type_id : PbProvIds.hpp
  • c_plmn_rec_size : SimAccessor.hpp
  • c_preview_count : MultiTapCaret.cpp
  • c_psd_menu_item_count : DataConnAccessor.hpp
  • c_psd_setting_editable : DataConnApp.cpp
  • c_puct_rec_size : SimAccessor.hpp
  • c_push_button_imid : InputMap.hpp
  • c_PushButtonClick_imid : InputMap.hpp
  • c_PushButtonRelease_imid : InputMap.hpp
  • c_radio_button_imid : InputMap.hpp
  • c_radio_button_list_imid : InputMap.hpp
  • c_RadioButtonNextItem_imid : InputMap.hpp
  • c_RadioButtonPreviousItem_imid : InputMap.hpp
  • c_ram_storage_default_block_size : RamTypes.hpp
  • c_recno_id : PbProvIds.hpp
  • c_regblobobject_type : RegBlobObject.hpp
  • c_rep_interval_value : AidingDataWin.cpp
  • c_sat_graph_title_text : SatteliteGraphWin.cpp
  • c_sat_info_title_text : SatteliteInfoWin.cpp
  • c_scicos_codec_if_max_num_of_vid_dec_inst : ScicosMpeg4VideoDecoder.hpp
  • c_scicos_codec_if_max_num_of_vid_enc_inst : ScicosMpeg4VideoEncoder.hpp
  • c_second_provider_id : ProviderIds.hpp
  • c_second_provider_row_id : ProviderIds.hpp
  • c_sem_obtain_timeout : Types.hpp
  • c_ser_menu_item_count : DataConnAccessor.hpp
  • c_server_get_packet_size : BtBipGetRsp.cpp
  • c_short_name_ie : SimAuxHandler.cpp
  • c_show_satellite_graph : LocResController.cpp
  • c_shutdown_app_close_timeout : ShutDown.cpp
  • c_shutdown_check_applications_interval : ShutDown.cpp
  • c_sim_memory_error : SignalTypes.hpp
  • c_sim_recno_id : PbProvIds.hpp
  • c_sim_secret_code_locked_error : SignalTypes.hpp
  • c_sim_security_error : SignalTypes.hpp
  • c_single_beep : AudioPresetStore.hpp, AudioPresetStore.cpp
  • c_size_of_orange_param : SignalTypes.hpp
  • c_size_smsparameters : SimSmsParamHandler.hpp
  • c_sizeof_extlanguagearray : SignalTypes.hpp
  • c_sizeof_languagearray : SignalTypes.hpp
  • c_small_animation_size : InformationElement.hpp
  • c_small_picture_size : InformationElement.hpp
  • c_sms_time_out : MdhSignalProcessor.cpp
  • c_smsp_rw_buffer_len : SimSmsParamHandler.hpp
  • c_smsr_no_link : SimPduHandler.cpp
  • c_stack_magic_start : Scheduler.cpp
  • c_syncml_database_max : SyncMLManager.hpp
  • c_system_color : DefaultTheme.cpp, DefaultChineseTheme.cpp
  • c_t9_key_buf_len : ChineseT9Wrapper.cpp
  • c_t9_selectpage_buf_len : ChineseT9Wrapper.cpp
  • c_test_system_color_table : TestTheme.cpp
  • c_test_system_font_table : TestTheme.cpp
  • c_timeout_seconds : SimAccessor.hpp
  • c_tlv_len_byte_mask : Tlv.hpp
  • c_tlv_two_byte_len_sign : Tlv.hpp
  • c_tone_supervisory_call_waiting : AudioPresetStore.hpp, AudioPresetStore.cpp
  • c_tone_supervisory_subsciber_busy : AudioPresetStore.hpp, AudioPresetStore.cpp
  • c_trap_system_stack_log_size : Trap.cpp
  • c_tst_file_size : SimAccessor.hpp
  • c_undefined_pdu_pos : MdhTypes.hpp
  • c_undefined_view_handle : MdhTypes.hpp
  • c_unique_id : PbProvIds.hpp
  • c_unit_id_value : AidingDataWin.cpp
  • c_unread_entry : SimPbEntry.hpp
  • c_user_base_gentypes : GenericObject.hpp
  • c_wai_svr_addr : ServerAddressWin.cpp
  • c_wait_sms_range : MdhSignalProcessor.cpp
  • cb : FillRect_Planes.cpp
  • checked_bmp : BlueSkyRadioButtonView.cpp
  • ClearToneRpt : SignalTypes.hpp
  • clip_left_border : BitBlit_Planes.cpp
  • clip_right_border : BitBlit_Planes.cpp
  • col_bits : FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_16Bpp.cpp
  • col_idx : ConvertToColorValue_Planes.cpp
  • col_inc : ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • col_table : ConvertToColorValue_Planes.cpp
  • col_val : SetPixel_Planes.cpp, DrawChar_Planes.cpp
  • color_cont : ConvertToColorValue_Planes.cpp
  • color_value : GetPixelColor_Planes.cpp, GetPixelColor_8Bpp.cpp, GetPixelColor_32Bpp.cpp, GetPixelColor_24Bpp.cpp, GetPixelColor_16Bpp.cpp, ConvertToColorValue_Bpp.cpp
  • copy_text_sample : FfsTests.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- d -

  • data : DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp
  • default_chinese_theme : DefaultChineseTheme.hpp, DefaultChineseTheme.cpp
  • default_theme : DefaultTheme.hpp, DefaultTheme.cpp
  • DEFAULT_VIEWFINDER_FRAMERATE : Camera.cpp
  • DefaultLocalId : DrmCore.hpp
  • delta : DrawChar_Planes.cpp, BitBlit_Planes.cpp
  • dest_atom : ScrollHorizontal_Planes.cpp, BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp
  • dest_bmp : BitBlit_Planes.cpp
  • dest_col_start_atom : ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • dest_end_x : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • dest_end_y : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • dest_inc : DrawChar_Planes.cpp
  • dest_line_inc : BitBlit_Planes.cpp
  • dest_line_start_atom : ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp
  • dest_plane_inc : BitBlit_Planes.cpp
  • dest_root : DrawChar_Planes.cpp
  • dest_scanline_inc : BitBlit_Planes.cpp
  • dest_x : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • dest_y : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • devil : SampleImages.hpp, SampleImages.cpp
  • devil_size : SampleImages.hpp
  • dtmf_tone_0_data : Audio.cpp
  • dtmf_tone_1_data : Audio.cpp
  • dtmf_tone_2_data : Audio.cpp
  • dtmf_tone_3_data : Audio.cpp
  • dtmf_tone_4_data : Audio.cpp
  • dtmf_tone_5_data : Audio.cpp
  • dtmf_tone_6_data : Audio.cpp
  • dtmf_tone_7_data : Audio.cpp
  • dtmf_tone_8_data : Audio.cpp
  • dtmf_tone_9_data : Audio.cpp
  • dtmf_tone_hash_data : Audio.cpp
  • dtmf_tone_star_data : Audio.cpp
  • dx_atom : ScrollHorizontal_Planes.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- e -

  • EmptyFfsFileInfo : FfsTypes.hpp
  • end_atom_idx : BitBlit_Planes.cpp
  • end_y : BitBlit_Planes.cpp
  • ErrorToneRpt : SignalTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- f -

  • FALSE : Types.hpp
  • ffs_memory_pool_reservations : FfsSim.hpp
  • file_name : FfsTests.cpp
  • flag : VCard.cpp
  • foggy_theme : FoggyTheme.hpp, FoggyTheme.cpp
  • format : Audio.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- g -

  • g_alarm_day : RealTimeClock.cpp
  • g_alarm_hour : RealTimeClock.cpp
  • g_alarm_minute : RealTimeClock.cpp
  • g_alarm_month : RealTimeClock.cpp
  • g_alarm_second : RealTimeClock.cpp
  • g_alarm_year : RealTimeClock.cpp
  • g_audio_callback : HostAudioDriver.cpp
  • g_AudioMutex : audio_private.cpp
  • g_check : HostAudioDriver.cpp
  • g_data_ptr : HostAudioDriver.cpp
  • g_defaultlookup : DataHandler.cpp
  • g_drm_cd_j1k_data : SampleImages.hpp, SampleImages.cpp
  • g_drm_cd_res2_data : SampleImages.hpp, SampleImages.cpp
  • g_drm_fl_res2_data : SampleImages.hpp, SampleImages.cpp
  • g_drv_id : HostAudioGatiServer.cpp, aud_drv.cpp
  • g_echo_mode : UdpServer.cpp
  • g_fcts_block_page : HeapVector.hpp, HeapVector.cpp
  • g_fcts_huge_page : HeapVector.hpp, HeapVector.cpp
  • g_fcts_var_page : HeapVector.hpp, HeapVector.cpp
  • g_handle : HostAudioGatiServer.cpp, HostAudioDriver.cpp
  • g_hevent : HostAudioDriver.cpp
  • g_hmap_file : HostAudioGatiServer.cpp, HostAudioDriver.cpp
  • g_local_addr : UdpServer.cpp
  • g_mail_editor : PhonebookApp.cpp, PbAdvAddEditEntry.cpp
  • g_mail_text : PhonebookApp.cpp, PbAdvAddEditEntry.cpp
  • g_mp3param : HostAudioDriver.cpp
  • g_mute : Audio.cpp
  • g_notifn_size : HostAudioDriver.cpp
  • g_offset_day : RealTimeClock.cpp
  • g_offset_hour : RealTimeClock.cpp
  • g_offset_minute : RealTimeClock.cpp
  • g_offset_month : RealTimeClock.cpp
  • g_offset_second : RealTimeClock.cpp
  • g_offset_year : RealTimeClock.cpp
  • g_pbuf : HostAudioGatiServer.cpp, HostAudioDriver.cpp
  • g_pcmparam : HostAudioDriver.cpp
  • g_priority : aud_drv.cpp, Audio.cpp
  • g_random_packets : UdpServer.cpp
  • g_recorded_size : HostAudioGatiServer.cpp, HostAudioDriver.cpp
  • g_rem_rec_len : HostAudioDriver.cpp
  • g_started : Audio.cpp
  • g_tone_data : Audio.cpp
  • g_tones : Audio.cpp
  • g_trace_socket : InternalTracer.cpp
  • g_tracing_initialized : InternalTracer.cpp
  • g_user_data : HostAudioDriver.cpp
  • g_vmparam : HostAudioDriver.cpp
  • GciVolume : AtiConfig.hpp
  • gif_image : SampleImages.hpp, SampleImages.cpp
  • gif_image_size : SampleImages.hpp
  • green_exp_2 : ConvertToColorValue_Planes.cpp
  • Guid_NoGuid : Service.hpp, Service.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- h -

  • hdl : Audio.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- i -

  • i : SetPixel_Planes.cpp, ScrollVertical_Planes.cpp, GetPixelColor_Planes.cpp, FillRect_Planes.cpp, DrawChar_Planes.cpp, BitBlit_Planes.cpp
  • I1_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • I2_SIZE : WCattr.cpp, WCattr_tbl.hpp
  • i_atom : SetPixel_Planes.cpp, GetPixelColor_Planes.cpp
  • i_bit : SetPixel_Planes.cpp, GetPixelColor_Planes.cpp
  • i_dest : ScrollHorizontal_Planes.cpp
  • i_left : FillRect_Planes.cpp
  • i_right : ScrollVertical_Planes.cpp, FillRect_Planes.cpp
  • i_src : ScrollHorizontal_Planes.cpp
  • i_start_dest : ScrollHorizontal_Planes.cpp
  • i_start_src : ScrollHorizontal_Planes.cpp
  • i_stodest_atom : ScrollHorizontal_Planes.cpp
  • i_stosrc_atom : ScrollHorizontal_Planes.cpp
  • index : VCard.cpp
  • info_tone_connection_data : Audio.cpp
  • info_tone_device_in_data : Audio.cpp
  • info_tone_device_out_data : Audio.cpp
  • info_tone_disconnect_data : Audio.cpp
  • info_tone_free_data : Audio.cpp
  • info_tone_low_bat_data : Audio.cpp
  • info_tone_msg_full_data : Audio.cpp
  • info_tone_power_off_data : Audio.cpp
  • info_tone_power_on_data : Audio.cpp
  • info_tone_ussd_data : Audio.cpp
  • InvalidAcm : SignalTypes.hpp
  • InvalidBcdMcc : NetworkTypes.hpp
  • InvalidBcdMnc : NetworkTypes.hpp
  • InvalidCcpData : SignalTypes.hpp
  • InvalidCellId : NetworkTypes.hpp
  • InvalidEccArray : SignalTypes.hpp
  • InvalidExtLanguage : SignalTypes.hpp
  • InvalidExtLanguageVal : SignalTypes.hpp
  • InvalidImei : SignalTypes.hpp
  • InvalidLac : NetworkTypes.hpp
  • InvalidLanguage : SignalTypes.hpp
  • InvalidMcc : NetworkTypes.hpp
  • InvalidMnc : NetworkTypes.hpp
  • InvalidPuct : SignalTypes.hpp
  • InvalidSignalQualityLevel : SignalTypes.hpp
  • InvalidSignalStrengthLevel : SignalTypes.hpp
  • InvalidSimServiceTable : SignalTypes.hpp
  • InvalidSpn : SignalTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- p -

  • p : SetPixel_8Bpp.cpp, SetPixel_32Bpp.cpp, SetPixel_24Bpp.cpp, SetPixel_16Bpp.cpp, ScrollHorizontal_Planes.cpp, GetPixelColor_8Bpp.cpp, GetPixelColor_32Bpp.cpp, GetPixelColor_24Bpp.cpp, GetPixelColor_16Bpp.cpp, FillRect_8Bpp.cpp, FillRect_32Bpp.cpp, FillRect_24Bpp.cpp, FillRect_16Bpp.cpp, DrawChar_8Bpp.cpp, DrawChar_32Bpp.cpp, DrawChar_24Bpp.cpp, DrawChar_16Bpp.cpp, FillRect_16Bpp.cpp, DrawChar_16Bpp.cpp
  • png_image : SampleImages.hpp, SampleImages.cpp
  • png_image_size : SampleImages.hpp
  • publicIdNull : WbxmlParser.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- r -

  • RAISE_2_23 : LcsUtils.cpp
  • red_exp_2 : ConvertToColorValue_Planes.cpp
  • RELTags_v1_0 : DrmRelXml.cpp
  • rename_text_sample : FfsTests.cpp
  • right : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • right_clip : BitBlit_Planes.cpp
  • right_clip_inc : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • right_mask : ScrollVertical_Planes.cpp, FillRect_Planes.cpp
  • right_mask_1 : BitBlit_Planes.cpp
  • right_mask_2 : BitBlit_Planes.cpp
  • ringer_tone_infos : RingerAudioDevice.cpp
  • ringing_tone_10_data : Audio.cpp
  • ringing_tone_11_data : Audio.cpp
  • ringing_tone_12_data : Audio.cpp
  • ringing_tone_13_data : Audio.cpp
  • ringing_tone_14_data : Audio.cpp
  • ringing_tone_15_data : Audio.cpp
  • ringing_tone_16_data : Audio.cpp
  • ringing_tone_17_data : Audio.cpp
  • ringing_tone_18_data : Audio.cpp
  • ringing_tone_19_data : Audio.cpp
  • ringing_tone_1_data : Audio.cpp
  • ringing_tone_20_data : Audio.cpp
  • ringing_tone_21_data : Audio.cpp
  • ringing_tone_22_data : Audio.cpp
  • ringing_tone_23_data : Audio.cpp
  • ringing_tone_24_data : Audio.cpp
  • ringing_tone_25_data : Audio.cpp
  • ringing_tone_26_data : Audio.cpp
  • ringing_tone_27_data : Audio.cpp
  • ringing_tone_28_data : Audio.cpp
  • ringing_tone_29_data : Audio.cpp
  • ringing_tone_2_data : Audio.cpp
  • ringing_tone_30_data : Audio.cpp
  • ringing_tone_31_data : Audio.cpp
  • ringing_tone_32_data : Audio.cpp
  • ringing_tone_33_data : Audio.cpp
  • ringing_tone_34_data : Audio.cpp
  • ringing_tone_35_data : Audio.cpp
  • ringing_tone_36_data : Audio.cpp
  • ringing_tone_37_data : Audio.cpp
  • ringing_tone_38_data : Audio.cpp
  • ringing_tone_39_data : Audio.cpp
  • ringing_tone_3_data : Audio.cpp
  • ringing_tone_40_data : Audio.cpp
  • ringing_tone_41_data : Audio.cpp
  • ringing_tone_42_data : Audio.cpp
  • ringing_tone_43_data : Audio.cpp
  • ringing_tone_44_data : Audio.cpp
  • ringing_tone_45_data : Audio.cpp
  • ringing_tone_46_data : Audio.cpp
  • ringing_tone_47_data : Audio.cpp
  • ringing_tone_48_data : Audio.cpp
  • ringing_tone_4_data : Audio.cpp
  • ringing_tone_5_data : Audio.cpp
  • ringing_tone_6_data : Audio.cpp
  • ringing_tone_7_data : Audio.cpp
  • ringing_tone_8_data : Audio.cpp
  • ringing_tone_9_data : Audio.cpp
  • RingToneRpt : SignalTypes.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- s -

  • s_continue_msgs_handled : SocketTestApp.cpp
  • s_continue_msgs_sent : UdpTestSocket.cpp, TcpTestSocket.cpp, TcpServerTestSocket.cpp, SocketTestApp.cpp
  • saxStringNull : WbxmlParser.cpp
  • scanline_inc : BitBlit_16Bpp.cpp
  • scanline_width : FillRect_16Bpp.cpp
  • SdlFalse : SignalTypes.hpp
  • SdlTrue : SignalTypes.hpp
  • setting : apoxi.defines
  • src : ScrollHorizontal_Planes.cpp
  • src_atom : ScrollHorizontal_Planes.cpp
  • src_data : BitBlit_8Bpp.cpp, BitBlit_32Bpp.cpp, BitBlit_24Bpp.cpp, BitBlit_16Bpp.cpp
  • src_line_inc : BitBlit_Planes.cpp
  • src_mask : DrawChar_Planes.cpp, BitBlit_Planes.cpp
  • src_plane_inc : BitBlit_Planes.cpp
  • src_scanline_inc : BitBlit_Planes.cpp
  • start_atom_idx : BitBlit_Planes.cpp
  • start_y : BitBlit_Planes.cpp
  • string_max_buffer_size : String.hpp
  • supervisory_tone_call_waiting_data : Audio.cpp
  • supervisory_tone_congestion_data : Audio.cpp
  • supervisory_tone_error_data : Audio.cpp
  • supervisory_tone_radio_path_ack_data : Audio.cpp
  • supervisory_tone_radio_path_not_avail_data : Audio.cpp
  • supervisory_tone_subscriber_busy_data : Audio.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- t -

  • test_theme : TestTheme.hpp, TestTheme.cpp
  • timer_id : RealTimeClock.cpp
  • top : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, ScrollVertical_16Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • TRUE : Types.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- w -

  • wav : Audio.cpp
  • wav_out : Audio.cpp
  • withoutme : SampleIMelodies.hpp, SampleIMelodies.cpp
  • withoutme_size : SampleIMelodies.hpp
  • wow : SampleImages.hpp, SampleImages.cpp
  • wow_size : SampleImages.hpp
  • write_text_sample : FfsTests.cpp
  • wstring_max_buffer_size : WString.hpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- x -

  • x_start : ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • x_start_dest : ScrollHorizontal_Planes.cpp
  • x_stop : ScrollHorizontal_Planes.cpp, ScrollHorizontal_8Bpp.cpp, ScrollHorizontal_32Bpp.cpp, ScrollHorizontal_24Bpp.cpp, ScrollHorizontal_16Bpp.cpp
  • x_stop_dest : ScrollHorizontal_Planes.cpp
  • xlen : ScrollVertical_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • w
  • x
  • y

- y -

  • y : ScrollHorizontal_Planes.cpp, FillRect_Planes.cpp
  • y_start : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp
  • y_stop : ScrollVertical_Planes.cpp, ScrollVertical_8Bpp.cpp, ScrollVertical_32Bpp.cpp, ScrollVertical_24Bpp.cpp, ScrollVertical_16Bpp.cpp
  • ylen : ScrollHorizontal_16Bpp.cpp, FillRect_16Bpp.cpp, BitBlit_16Bpp.cpp
Generated on Wed Jan 25 02:31:18 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Namespace List
  • Namespace Members
  • All
  • Functions
Here is a list of all namespace members with links to the namespace documentation for each member:

  • ConvertAACToGCIFormat() : AtiUtils
  • ConvertAMRToGCIFormat() : AtiUtils
  • ConvertFromGCIFormat() : AtiUtils
  • ConvertToGCIFormat() : AtiUtils
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Data Fields

  • Namespace List
  • Namespace Members
  • All
  • Functions

  • ConvertAACToGCIFormat() : AtiUtils
  • ConvertAMRToGCIFormat() : AtiUtils
  • ConvertFromGCIFormat() : AtiUtils
  • ConvertToGCIFormat() : AtiUtils
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Page Index

APOXI Related Pages

Here is a list of all related documentation pages:
  • Deprecated List
Generated on Wed Jan 25 02:31:20 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Deprecated List

Deprecated List

Global AudioDeviceManager::CreateAudioReferenceFromFFS (const String &filename)
Get an AudioReference for the file in the Flash File System.

Global AudioDeviceManager::GetAudioPlayer (const AudioReference &file_reference)
Get an AudioPlayer capable of playing this reference:

Global AudioDeviceManager::GetDevice (AudioDeviceID device)

Global AudioDeviceManager::GetLinkedAccessory (SourceType source) const

Global AudioDeviceManager::LinkAccessory (SourceType source, AudioAccessoryDetails &accessory)

Global AudioReference::GetTotalPlayTime (UINT32 &total1, UINT32 &total2, UINT32 &total3, UINT32 &total4)
Generated on Wed Jan 25 02:24:12 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Graphical Class Hierarchy

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

APOXI Graphical Class Hierarchy

Go to the textual class hierarchy

Generated on Wed Jan 25 02:33:22 2006 for APOXI by doxygen 1.4.6-NO


Apoxi Overview

1 Introduction

APOXI is an object oriented application framework for development of man machine interface and applications for mobile terminals. It is designed to meet the special requirements of mobile, embedded devices and exposes APIs which are specific to mobile phones.

Please note - APOXI does not incorporate ready to use applications but only provides the means for rapid MMI and application development. MMI and applications are built on top of APOXI. More about Comneons offerings of ready to use MMI and applications at the end of this document.

An application framework frees developers from daily re-occurring tasks and the need of starting his implementation tasks from scratch. The developer starts his project with an functionally empty application template and fills this template with functionality of his application. To implement these functionality the developer uses services and APIs exposed by the framework. Well designed frameworks only leave implementation tasks to the developer which relate directly to the application functionality.

Application frameworks guide developers through development process and implement paradigms the developer can or should follow. This significantly reduces the training efforts for developers and speeds up implementation time. Developers using the APOXI framework do not need to be mobile application development experts, but will find themselves in a software environment which is very similar to desktop (e.g. Windows) development. Of course embedded devices still restrict implementation in terms of real time behavior, memory and computing resources which APOXI can’t overcome – but APOXI helps handling these issues. Developers using APOXI simply take profit from the vast experience of APOXI developers.

As no application framework can cover all functionality of all applications, frameworks specialize to specific domains. The popular framework Microsoft Foundation Classes (MFC) specializes on MS Windows Application development. Applications are implemented following the Model-View-Control (MVC) paradigm, which is one of most popular paradigms for implementing graphical user interfaces. Other domains covered by MFC are data base access etc.

System Architecture

Like MFC is specialized for Windows application development, APOXI is optimized for needs of mobile phone MMI and application development. For this, APOXI exposes services and APIs for following domains:

  • Graphical User Interface
    • Graphics Device Interface
    • Windowing toolkit
    • Controls (editors, menus, radio buttons etc.)
    • Drawable objects
    • Multi-language support
    • Dynamic themes (exchangeable look & feel)
  • Application control
    • Application container
    • Application class
    • Process and inter-process communication
  • APIs for Comneon signaling stack
    • Power up
    • Registration
    • Call handling
    • SMS
    • SS
    • IP
  • Services to store and retrieve persistent data
    • SIM data access
    • NVRAM
    • Flash file systems etc.
  • RTOS abstraction
    • Process control
    • Semaphores
    • Queues
    • Dynamic memory allocation
  • Abstraction of other hardware devices (audio, RTC etc.)
  • Supporting functionality
    • Unicode utilities
    • Encoding and decoding of BCD and GSM alphabet strings
    • PDU classes
    • Sorting algorithms
    • Container classes (vector, linked list)
    • String class
    • Compression / Decompression (LZW)
    • Buffer management
    • etc.

APOXI abstracts underlying system

The main components of APOXI are GUI services, ADC and ASC, and application control mechanism. Many of the other functionality are side products of the implementation of these basic building blocks.

APOXI counts more then 250 classes so far – small helpers to complex code monsters. These classes are implemented by a team of very experienced developers, most of them with vast experience in application development and object oriented programming. Thus developers using these classes do not only benefit from the functionality exposed by the framework, but also learn OO technologies from experts.

2 Libraries

The libraries Kernel and Auxiliary may be used from any library. The libraries AddOns and Compat are optional: AddOns contains extensions to the APOXI core libraries, which may be useful for an extended MMI. Compat contains obsolete classes to provide backward compatibility for applications written with older APOXI versions.

3 Using APOXI – A Simple Use Case

ASC exposes – among other services – interfaces for receiving and sending SMS PDUs. In order to ease the handling of these PDUs a wrapper class has been implemented that holds one or more PDUs (i.e. concatenated SMS). An application programmer must not know about PDU structure (header fields, data encoding etc).

When sending a text message, the programmer simply creates an instance of the PDU class and passes the message text to the SetText class method. The method internally handles encoding, partitioning the string into multiple PDUs if the string length exceeds the capacity of a single PDU, and initializes the according header fields (sequence number etc.). Other header fields are initialized as far as possible with default values. Thus sending a text message using this class only requires very little knowledge about SMS internals.

Experienced programmers can access all header fields and data area of PDU with other class methods.

If a concatenated SMS is sent, the developer must not care if the protocol stack supports sending concatenated SMS. He simply passes the PDU object to the according function and ASC will send single SMS messages if the signaling stack does not support that feature.


ADC Overview

1 Introduction

ADC (APOXI Data Control) component is described in this chapter. It is the APOXI subsystem which has access to SIM-data. It provides interface for accessing data which are stored in different mediums like SIM, RAM, etc. The ADC provides a generic C++ interface for APOXI and Reference MMI applications.

2 Overview

ADC is responsible for retrieving and manipulating structured data (e.g. phonebook) within APOXI. Also it offers the central point of storage of SIM/USIM. This kind of storage avoids data redundancy, ensure the consistency of SIM data, and helps to eliminate the consistency problems between applications.

ADC hides signal based access to SIM. All low-level calls (access to SIM) are implemented as non-blocking calls, which means that all messages and events received by applications are still processed i.e. message flow is not interrupted.

ADC is also capable of data caching. The use of data caching can massively increase the performance of applications. ADC uses generic data types, which means, all data input/output is done via “variant” data objects. These data objects are represented by the class DataItem.

3 Architecture

The architecture of ADC is given in the following figure (Figure 1).

Figure 1. ADC Architecture

4 DataControl

DataControl is the singelton which represents the core ADC functionality.

4.1 Data access through Provider Interface

Providers are generic interfaces provided by ADC for presenting data. The entry point for using the ADC’s functionality is the class MainProvider. The MainProvider enables an application, through its interface, to access all Provider objects which are registered within the system. Providers can execute basic functionalities like Sorting, Filtering, and Finding.

Providers are used for retrieving data from the SIM/USIM. The SIM/USIM features of ADC are listed in the following:

  • Phonebooks: ADN, FDN, BDN (CMI), LND, MSISDN, SDN, CPHS-MBox, CPHS-InfoNumbers
  • SMS: both SIM and Flash Phonebooks, SmsParameters
  • CBMI and CBMI-Ranges
  • Prefered Plmns: EF-Plmn and EF-PlmnwAct
  • Prefered Plmns: EF-Plmn and EF-PlmnwAct
  • Builtin Plmn and Country Lists
  • IMSI, IMEI, ICCID
  • ACM, ACMMAX, PUCT
  • ECC
  • SST, UST, EST
  • SPN, SPDI
  • EONS OPL and PNN
  • CPHS Phase, OperatorNames, ServiceTable, Orange Specifics Dynflags, CSP

4.2 Other Interfaces of DataControl

DataControl has some additional interfaces for retrieving certain states of the underlying SIM /USIM. It also have some complex methods for a more convenient direct access of data instead of using providers. These methods are used in some cases, where using providers are not so convenient. An example for such additional interfaces of DataControl is EONS - Enhanced Operators NameService.

4.3 Action Interfaces of DataControl

DataControl also provide some action interfaces. Examples for use cases of such interfaces are listed in the following:

  • PIN Verification
  • FDN Enabling Disabling


AES Overview

1 Introduction

AES decryption add-on for APOXI is intended to provide decryption of AES encrypted data using 128 bit keys and cipher block size of 16 bytes. Currently only Cipher Block Chaining (CBC) mode of AES is supported. These are the requirements for OMA DRM V1.0 which is supported by DRM Add On for APOXI.

2 Architecture

AES for APOXI is based on the free implementation of the AES algorithm in C++ by Prof. Brian Gladman (http://fp.gladman.plus.com/cryptography_technology/rijndael/). Basic algorithm is used by the APOXI implementation to provide CBC mode.

3 Features

The main features of AES are given in the following list:

  • AES Decryption
  • Block size: 128 bits
  • Key Size: 128 bits
  • CBC mode

4 AesCrypt Interface

AesCrypt is the class that offers the API to decrypt AES encrypted data. The API to be used is:

INT DECRYPTBUFFER(CONST BYTE* IN, BYTE* OUT,UINT BUF_LEN, PADDINGMETHOD PAD_METHOD,UINT START_BLOCK=0, UINT END_BLOCK=0);

To decrypt a buffer encrypted using AES, you need the following:

  • Cipher text
  • A 128 bit key used to encrypt the buffer
  • A 128 bit initialization vector used for encryption

For further details refer to the following block concept in AES

4.1 AES Block concept

To use the API, the block numbers are calculated as follows:

Incoming buffer:

In the figure, block 0 of the incoming buffer is the Initialization Vector (IV), hence it will not be used as cipher text. Block 1 in the incoming buffer is used as block 0 of the cipher text. The start_block and end_block can have values from 0 to (n-1). And the output buffer will have [end_block - start_block] number of blocks.


AFS Overview

1 Overview

AFS (APOXI File System) contains the following sub components:
  • APOXI Registry
  • APOXI Root File System
    • Flash File System Storage Device
    • Multi Media Card / SD Card Storage Device
    • Random Access Memory Storage Device
    • Virtual Root Storage Device
  • APOXI Flash File System Core

2 APOXI Registry

For purposes like device management it is necessary to store configuration data in a central storage in the mobile phone. Because the central storage has many similarities with the registry as found in Microsoft Windows®, it was decided to adopt this name as a working name. Apart from the storage responsibility, registry will also serve as a routing interface to other external Object Trees such as SyncML / DM Tree.
APOXI registry has easy-to-use synchronous interface to maintain configuration settings (load, store, modify, and delete). The registry uses Flash File System for storing the data.

2.1 Interfaces

APOXI registry interfaces are shown in Figure 1.

Figure 1. APOXI Registry Interfaces

As shown in Figure 1, Interface 1 is the interface to the APOXI Registry used by applications. Interface 2 is the interface handling Application Specific Object Trees (ASOT). Interface 3 constitutes the interface for managing the Local Tree Storage. This interface will only be used by the registry core.

2.2 Handling of Request by Registry

Any request received by the registry is handled depending on the URI header.

During startup any application that needs to maintain its ASOT, registers its ASOT with Registry. This information is maintained by registry core in GUID Service Table.

If a request arrives for a tree that is registered by an application, this request is forwarded to the application for further processing. If no registered tree can be found matching the URI header, the request is routed to the Local Object Tree.

2.3 Tree structure of Registry

There are two types of nodes in the tree structure: Interior nodes and leaf node. Interior nodes have further interior nodes or leaf nodes (analog to folders). Leaf nodes cannot have further nodes. They store the information related to the node (analog to files). The leaf nodes support the following types:

  • BOOLEAN
  • INT
  • STRING
  • BLOB

3 APOXI Root File System

The Root File System (RFS) provides an easy-to-use interface to load, store, modify, copy, move, and delete files.

3.1 Storage Devices

RFS integrates different storage devices utilizing one and the same interface. Currently, four storage devices are available. They are FFS, MMC, RAM, and Virtual Root. All available storage devices are supposed to be registered with the RFS.

3.1.1 Virtual Root Storage Device

The Virtual Root storage serves one special role: it unifies all the other currently registered storage devices under one root directory. So it is not a physical storage device and hence is called virtual. All the first level directories of this root directory are considered as storage device directories. Actually the virtual storage device constitutes a file system similar to the UNIX file system.

3.2 Paths, Pathnames, and Storage device IDs

A file is specified by a storage device ID and a pathname.

A storage device ID is a short string uniquely identifying the storage device within the system like “ffs”, “mmc”, “ram”, and “rfs“ (for the virtual root storage device).

A pathname like “/my_dir/my_sound_file.mp3” uniquely identifies a file within a distinct storage device.

The tuple of storage device ID and pathname constitutes a path.

3.3 Files

An application can access the files from the storage devices by using the GetFile(const Path &path) method of controller class RootFileSystem. This method returns a smart-pointer wrapping a file object. File object can be considered as a file handle and can be used to create, open, read, write, delete, or rename a file.

3.4 Directory Iterators

RFS uses iterators to easily traverse the entries of directories. It can be specified via a filter which entries the iterator shall return. Iterator can be set to any directory of any storage device.

3.5 File Filters

The different kinds of filters provided by AFS are listed in the following:

  • Image File Filter: It is a predefined file filter functor which filters image files. These are actually jpeg, gif, png, tiff, wbmp, and bmp files.
  • Name Pattern File Filter: It is a predefined file filter functor which filters files by comparing the filename to a name pattern which is allowed to contain the asterisk * and/or question mark? wildcards.
  • Sound File Filter: It is a predefined file filter functor which filters sound files. These are actually mid, mmf, and imy files.

4 APOXI Flash File System

The APOXI FFS (Flash File System) is an object-oriented interface for APOXI core modules to access the FFS to store, retrieve, and manipulate system-level data. The APOXI core modules must not use RFS to store systemlevel data because the RFS can be configured to not support the FFS, in such case storing system-level data would fail. Since the FFS core classes are always available, these have to be used for this purpose. Hence the FFS core classes can be viewed as means for accessing the system-level storage. Applications shall always use the RFS to store any data, the RFS provides a much more convenient interface.

The following dependency diagram (Figure 2) illustrates this view.

Figure 2. FFS: Dependency diagram

In general the whole functionality of the FFS is accessible via RFS, with one exception: while it is possible to store files with an ID only (without any name) with the core FFS classes, the RFS only supports named files.

APOXI FFS provides the following functionalities:

  • Accessibility for APOXI modules
  • Mechanism to handle multiple files opened for read/write
  • Access to a file via a unique ID
  • Access to a file via a unique filename
  • Retrieval of file-specific information such as file type, file size, etc
  • Standard file operations like create, open, read, write, copy, etc. on any file
  • Standard search operations like checking the file existence, get first file, get next file, etc.
  • Retrieval of storage information such as total FFS size, used space, available space, etc.


APC Overview

1 Introduction

APC (APOXI Process Control) is an an exchangeable layer for external communication (e.g. SDL-signal-driven, AT-command-driven, etc.). APC provides wrapper classes for accessing the protocol stack mainly needed by ASC and ADC. The only purpose of the APC is the transformation (mapping) of SDL-signals into C++ wrapper classes and back.

2 Sending SDL Signals from Applications to Stack

When applications want to send some SDL signals to stack, ToStackMsg with parameters will be sent to APC. APC will then convert the parameters to SDL arguments and send them to the Stack. ToStackMsg is a special message for carrying information from APOXI to the protocol stack.

3 Sending SDL Signals from Stack to Applications

Stack sends a SDL signal to APC and APC transforms these signals to APOXI arguments. These arguments will then be sent within a FromStackMessage to ASC (APOXI Stack Control). FromStackMessage is wrapper for APC arguments. ASC only needs to listen to FromStackMessages. APC thus provides better performance due to simplified routing.

4 Message Flow in APOXI

ADC and ASC provides no direct interface for MMI applications. MMI applications can communicate to ASC and ADC only through APC.

The message flow in APOXI is given in Figure 1.

Figure 1. Message Flow

5 APC Wrapper classes

Some of the wrapper classes provided by APC for protocol stack acces are listed in the following:

  • SMS classes
    • Tpdu: This class holds the raw data of a transfer protocol data unit
    • Sms: This class is a wrapper over a TPDU-reference
    • MessageTypeIndicator: This class is a wrapper over a data-stream (no data is copied)
    • Protocolidentifier
    • MessageStatus
    • UserData
    • ValidityPeriod: This class is a wrapper over a data-stream (no data is copied)
  • CBS classes: Describes the protocol for the cell broadcast service.
  • SimToolKit classes
  • Plmn handling classes
  • General Stack type classes


ASC Overview

1 Introduction

ASC (The APOXI Stack Control) offers an abstract interface to access mobile communication requirements, like GSM/GPRS/UMTS. It is designed to keep the application development as independent as possible to any proprietary protocol stack facilities. APOXI contains also an exchangeable layer (APC) for external communication The only purpose of the APC is the transformation of SDL-signals into C++-wrapper classes and back. The functionality for controlling the protocol stack resides in the ASC. ASC runs in context of the calling application, which makes it easy for custom applications to access its functionality.

ASC provides a common interface to various protocol stacks. The position of ASC within APOXI is shown in figure 1.

Figure 1. Position of ASC in APOXI

2 Handlers

One of the key concepts of the ASC is the “Handler concept”. The idea is to enable a separate activation of various stack functions like Call, SMS, Cell-Broadcast, Supplementary Services, etc. Every APOXI Handler hides the signal flow (from and to the protocol stack) from the application to ease the handling of its “real job“.

One special handler is the MainHandler. It is the main interface or the entry point of the APOXI Stack Control library. It provides a scalable use of the protocol stack functions. The MainHandler offers the possibility to mount, unmount and access APOXI handlers. Any application can access its MainHandler-functionalities simply by using the static StackControl() methods.

Every APOXI Handler beside the MainHandlers represents a collection of functions concerning the protocol stack (e.g. call handling, SMS handling, ...). The various handlers are mounted via the StackControl to the specific MainHandler of the calling application. They are all subclasses of the abstract base class BaseHandler, which defines their common interface.

Some of the Handlers are listed in the following:

  • CallHandler: Supports basic call handling functions. This basic functionality comprises features which neither are specific for mobile terminated nor originated calls, e.g., release of calls. Furthermore, there are methods for DMTF tone generation.
  • SimTkHandler: This is the SIM Toolkit Handler. It holds the functionality for receiving SIM Toolkit events coming up from the protocol stack and provides an interface for the application to react to these events.
  • SmsHandler: Supports handling of SMS.
  • PowerHandler: Provides an interface for the application to start up and terminate the protocol stack.
  • CrssHandler: Supports call related supplementary services like Hold, Retrieve, Swap, etc. Furthermore, there are methods for multi-party call support.

3 ASC Dispatchers

The ASC-dispatchers realize the asynchronous interface of the ASC-Handlers. Besides notifying the associated handlers about the triggered events, they often transform the triggered event into one or more messages applications may listen to.

4 Interaction between Handlers and Dispatchers

The various types of communication between ASC and applications are described in this section. There are both asynchronous communication and synchronous communication.

4.1 Asynchronous Communication

An example for simple communication between MMI application and stack is shown in the following figure.

As shown in the example, in such communication, when an application makes a function call, the handler sends that message to the stack.

The following figure shows the asynchronous messaging handled by the handlers and dispatchers in ASC.

In such an asynchronous communication, when an application makes a function call, the Handler sends the message to the stack and the message from the stack is caught by the Dispatcher. Dispatcher then dispatches the message to the application.

4.2 Synchronous communication

An example for the asynchronous communication handled by the ASC is shown in the following figure.

In a synchronous communication, when an application makes a function call, the Handler sends the message to the stack and enters into a wait mode by calling Wait() until it gets a response. The message is caught by the dispatcher and it sends the return value to the handler and handler then returns the result to the calling function.

5 Supplementary Services Handling

The ASC offers also a concept called Supplementary Services Handling. Its purpose is to offer an easy to use programming interface (API). This special API focuses on three parts:

  • Permanent scan of user input (Input analyzing)
  • Sending the supplementary request
  • Evaluation of the asynchronous result messages

The Input analyzing allows syntactical analyzing of MMI input strings as defined in 3GPP 22.030 V4.0.0. The Input analyzer iterates through a list of InputAction objects and returns the object when the string matches its rules. The ASC also includes a feature called Call Independent Supplementary Services. But the Supplementary service interface, in general, is an Active-wait-based interface for sending the supplementary service requests to the protocol stack. The received return value indicates if the request was accepted by the Mobile Network (MN).


ATL Overview

1 Introduction

APOXI module "ATL (Application Template Layer)" provides basic application management and customization functionality on top of APOXI.

The most important aims of the ATL module are the following:

  • Support factory customization of central parts of the user experience of a phone software
  • Support code size savings for applications

2 ATL Architecture

2.1 ATL Application and Application Plugin

The ATL application is the mandatory base class for an application intending to use ATL concepts. The ATL application plugin is the base class for implementing lightweight add-ons to an ATL application.

2.2 ATL GUI Controls

All ATL GUI controls extend existing APOXI GUI classes. The APOXI window extensions provided by ATL are:

  • ATL Window as mandatory base class for any application window.
  • List Window for displaying data of an APOXI Provider.
  • Menu Window, which is used by the ATL framework for displaying and handling full screen as well as popup menus. There is no need for an application developer to use this class directly.
  • Property Editor, which is the base class for any window to be used for viewing and changing setting values according to the Settings Framework specification.

3 Feature Handling

Features are functional entities provided by ATL applications or plugins. With the ATL Feature Broker, particular features of an application may be exported in order to be available globally and used as menu entries, shortcuts or other event triggered actions.

A feature is identified by a Feature ID, and it is linked to an application which handles the feature. Such an application is called Feature-providing application. When the feature is executed, the feature-providing application executes the functionality corresponding to the feature.

The different types of features provided by ATL are:

  • Context independent Features: Context independent features can be triggered by a menu or any other asynchronous event without the need to supply additional information. These features are typically used to open particular dialogs of applications (e.g. write an SMS, Open Phonebook, ….).
  • Context aware Features: These are features require a feature invocation argument. This argument is the context information, when they are invoked. E.g, to establish a call, a phone number has to be supplied. Then, a context aware feature "Setup Call" is initialized with a phone number as context information, before it is executed.
  • Platform Features: Platform Features are features not linked to a particular application, because they are provided by the platform. As an example, features using a service interface do not need to know which application implements the service.

3.1 Feature Broker

The Feature Broker provides access to all globally available features of a phone. It serves the following purposes:

  • Feature registration: In order to be able to access all features on the phone, feature-providing applications must register their features to the Feature Broker.
  • Feature retrieval: In order for client objects to use a feature, they must request the feature from the Feature Broker by specifying the Feature ID.

3.2 Menu Configuration

ATL menu structures are specified by menu descriptions. A menu description maps application features to menu items of the phone. According to the menu description, ATL creates feature items and item containers, which provide menu display as well as menu hierarchy information. GUI components use them for drawing as well as traversing through hierarchies.

3.3 Menu Window

ATL provides a menu window, which uses a menu description to display a menu node and let the user traverse through the hierarchy. The menu description has to be set by the client. Unavailable menu items are not displayed at all, disabled menu items are displayed as grayed.
The menu window listens for two virtual keys, namely:

  • Select Key triggers the selected menu item.
  • Back Key steps the hierarchy one level up. On level = 0 it closes the window.

4 Context Handling

A context specifies a particular state of the user interface. For each context, project configuration is able to assign a specific set of user experience elements.
A context is uniquely identified by a Context ID. In ATL, at least each window within the system possess a context. It is also possible to define more than one context for a window according to particular states of the window. The configurable user experience elements are key mappings, Window properties like window title, softkey assignments for the softkey bar.

4.1 Key Map Configuration

With context handling, the set of virtual keys, which are not represented by existing hardware keys, can be emulated per every context. The available key mappings are:

  • Mapping of hardware keys to virtual keys: The hardware keys can be mapped to virtual keys for doing different actions. For example, a particular hardware key may act as the virtual key Delete Key in one context and as virtual key Cancel Key in another context.
  • Mapping of virtual keys to trigger a feature: A virtual key can be mapped to trigger a particular feature. This virtual key is called feature key. With the Feature ID specified for the feature key, the key handling is able to fetch the feature from the Feature Broker and execute it if it is available. It is also possible to map a long or very long, or a sequence of hardware keys to a feature.

4.2 Softkey Configuration

The softkey configurations are described in the following:

  • Feature assigned to Softkey: If the Context Manager detects a feature configuration for a softkey, it fetches the feature from the Feature Broker and if that feature is available applies it to the global softkey bar. When the softkey is pressed, the mapped feature is executed.
  • Context Menu assigned to Softkey: Menus are identified by Menu ID. The Context Manager can use Menu IDs in order to fetch the corresponding menu description from the Feature Broker. A special feature indicating the text and possibly icon of the menu root node must be used to be applied to the global softkey bar. If that feature is triggered, a menu window parameterized with the menu description of the context menu will be opened.

4.3 Context Switching

A window based on the ATL window base class is contextable. If an ATL window becomes focused, the context of the window is set to the Context Manager. The context manager is responsible to fetch the corresponding context configuration data from the project configuration and to apply the configured user experience elements to the active context.

5 Settings Framework

The ATL Settings Framework provides properties. A property represents a particular setting maintained by an ATL application. Properties are special features and are available globally. They can be used as menu items, whereby a matching property editor must be configured. If the property item is triggered, the configured editor is used to view and change the property value. Storage of a changed property value is handled by the ATL application responsible for the property.


Audio Overview

1 Overview

APOXI Audio is an abstract layer to Audio Driver. The APOXI audio functionalities are listed in the following:

  • Hide the specific low-level implementation and specific details of the hardware.
  • Allow applications to use the audio API without coordinating/negotiating with each other.
  • Allow runtime discovery of properties that are specific to certain targets or factory customizations. For instance, presets.
  • Make it easy to play sounds. All sounds should be playable via the same simple method or syntax.
  • Implement a priority system: If a sound is already playing, with a lower or equal priority then it should be suspended and the new sound will play instead.
  • For SMAF phrases, which can play simultaneously on 4 channels, the priorities will be per-channel.
  • Allow accessories to be linked to "sources", after discovering which can be linked. The sources are "DSP" and "Ringer". Apparently each type of sound (e.g. AudioDevice) plays through one, and only one, of these sources. Accessories can only be linked to one source.

2 Polymorphic AudioReferences

The Audio API use a polymorphic hierarchy of AudioReferences to allow creation and use of specific sounds, but it will allow these to be manipulated polymorphically through the simple base class.

2.1 Creating an AudioReference

Some sounds do require special information to specify them, but those information should only need to be specified when creating the sound, and not afterward.

2.2 Playing an AudioReference

After the AudioReference is created, it is not needed to worry about what type of sound it is. For instance, the sounds can be played with a simple call of AudioDeviceManager::Play(*fileRef).

2.3 Controlling a Playing Sound

AudioReferences are also polymorphic when needed to stop them. AudioDeviceManager::Play() returns an AudioActiveReference. Calling Stop() on thisAudioActiveReference will stop the sound, regardless of the type of sound.

3 Recording a Sound

The API provides the possibility to record a sound in AMR(Voice memo) or PCM format. The StreamAudioReference and StreamAudioPlayer are used for this purpose.

3.1 Enabling Voice Recognition for Training/Recognition

When voice training/recognition has to be performed, the PCM recording has to be activated in the audio driver.

4 Playing/Recording a Sound using Advanced Frameworks

In addition to the already described ways to play a sound the AMR, PCM and MP3 audio formats can be played in so called streaming mode. The streaming mode requires existence of an advanced framework that is able to pass frames to the driver and can handle the synchronization issues. The StreamAudioReference and StreamAudioPlayer are the classes implemented to provide the needed functionalities to the framework to deal with such mode. The most important aspect is registration of the callback function that will be invoked by the driver whenever a new frame(s) has to be fetched by the driver.

5 Notification

Some applications need to know when a sound has been stopped. For instance, an MP3-playing application might want to show when something is playing, and when it is not.

The new audio API will send the "AudioStoppedMsg" APOXI message when a sound has stopped because it has reached its end. It will not send this message if the application explicitly stops the sound with the Stop() method.

This APOXI message will contain the AudioActiveReference so that the application can discover exactly which sound has stopped.
The suspension of a sound is also notified by the audio system. The "AudioSuspendedMsg" containing the AudioActiveReference information will be sent when the priority manager suspends a sound due to a priority conflict.

The "AudioErrorMsg" message is sent when an error has been returned by the driver. The list of available errors is handled by the AudioError class.

It is also possible that the application register its own callback to APOXI in order to get the audio notifications. But the way to get the audio notifications has to be the APOXI message system, callback method has to be used only if there are some reasons that the calling module is not able to receive APOXI messages.

6 Volume and Mute Concept

The simplest way to adjust the volume in percentages for any sound played on any audio device is using the AudioDeviceManager::SetMasterVolume().

Based on the audio device, it is possible to adjust the volume in percentages for each available device using AudioDeviceBase::SetVolume method. The master volume is like a mixer - where each input has its own volume control (device volume), and the outputs are mixed together with the global volume (master volume).

Using the AudioDeviceBase::SetVolume() to adjust the volume is not recommended. Best solution is always to use the master volume to control the volume and to leave the device volume to its default value.

Device volume should be used when it is necessary to reduce or increase only some specific type of sound without any effect on other devices. For instance, when reducing the tone volume without effecting the speech volume during the call.

It is also possible to set the device volume for only one playback instance. The AudioReference::SetVolume() method has to be used if device volume is to be set before playing the sound. To set it while playing, AudioActiveReference::SetVolume() should be used. This is useful for playing a sound at certain volume level, but with device volume staying at the same volume level after the playing as it was before.

7 Audio Path Manager

Due to more complex requirements of the audio paths and accessory linking the audio path manager is defined in order to cover the following tasks:

  • Allow runtime discovery of target-specific or factory-customized audio accessories.
  • Allow runtime discovery of connected and available audio accessories. (Detection of headset and CTM).
  • Provide human-readable canonical names for these audio accessories. This should include secondary names where appropriate. For instance, bluetooth headsets have their own specific ID name as well as a general accessory-type name.
  • Provide accessory priority system that allows to enable an accessory considering its priority, whether is active and available.
  • Audio system responds to a change of the activated accessories. For instance, a button press on the bluetooth headset means:
    • This accessory is now active
    • This accessory should take all sounds that it is able to take, including already-playing sounds (when in-band ringers will be support

7.1 Accessories

There are no restrictions of what accessories are supported by the current audio system. Any combination of audio paths uplink/downlink can be taken as being an accessory. Usually, accessories consist of one downlink and one uplink path, but it is also possible to define more then one downlink or uplink path for each accessory.

The available accessories are defined for each project in the Config file. The order of the registration is very important since the priority decreases from top to the bottom of the accessory list, the first added accessory having the highest priority. At the power up the accessories are loaded to the list and cannot be deleted afterwards.

When the accessory is activated, the audio paths are enabled and the audio manager will update install the audio paths. It is possible that some accessories, such as bluetooth, are activated and only in case of specific actions the audio paths should be setup.

During the creation, the conflict table of each accessory has to be specified. The table is used to determine what accessories can be active at the same time. The path manager takes into account the priority given to each registered accessory and using this matrix it will enable/disable the appropriate audio paths.

7.1.1 Mode Concept for Paths/Accessories

In the "mode" approach, an AudioReference has a mode member; this mode and the current availability state of accessories together determine which accessories should be used for rendering the sound. The desired accessories as a function of mode and availability are defined in a lookup table in the project-specific file AudioAccessoriesRegistration.cpp.

7.1.1.1 Definitions

Accessory availability: Availability is affected by calls to AudioAccessoryDetails::SetConnected for an accessory, "being available" does not mean that the corresponding paths are installed.

Mode: Semantically, mode corresponds to a usage, purpose / intention, or use case, of a sound, e.g. using a sound as a ringer may define one mode, using a sound in a media application might be another.

Desired accessories: Determined by mode and accessory availability. When rendering a sound, the paths corresponding to the desired accessories are installed.

7.1.1.2 Details of applying the path control lookup table

After obtaining the desired accessories from the lookup table, APOXI will remove the currently used accessories, and install the desired accessories.

The order of installation is given by the ordering of accessories in AudioAccessoriesRegistration the accessory with the highest priority is installed first. This ordering is important to obtain correct gain settings.

The results of the attempt of installing an accessory depend on the priority and conflict settings in AudioAccessoriesRegistration. For example, if both accessory A and B are in the desired accessories; A has higher priority than B (according to the positions in the accessory list); A cannot be used together with B (according to A's conflict/cooperation settings); then an attempt to install B will be made, but it will have no effect.

8 Priorities

Each sound should have a priority. If an application tries to play a second sound on the same "channel" while an existing sound is still playing, then the priority system will handle the conflict. For more information about priorities, please refer, UG_Devices_Audio_Priority_Manager.pdf.


Auxiliary Overview

1 Introduction

The Auxiliary module of APOXI provides helper-classes for APOXI and custom projects. It allows easy manipulation of data primitives, like strings, phonenumbers, date and time and provides commonly used data structures like linked lists, vectors and bitfields. The important classes provided by auxiliary module are described in the following sections.

2 Provider Base classes, DataItem

2.1 Providers

Providers make a specific interface available which standardizes the handling of tabular data. A Provider can be seen as a table of data with methods to read and write data and to get information about the column types.

The root class (Provider) does only specify an interface. Data Providers present real data to the application (like phonebook entries, preferred PLMNs, etc.).

Providers identified via unique IDs as shown in the following code:

virtual Provider * GetProvider(INT providerid);

There exists quiet a number of predefined Providers. Some examples of such Providers are listed in the following:

  • Phonebook Providers
  • SMS Providers: SmsProvider is the base Provider of all sms Providers. It allows retrieving pdus from and changing the state of the pdus on the sim. It presents all sms within the system
  • PlmnProvider: PlmnProvider is the Provider to retrieve data about plmns•CountryProvider: It is the Provider to retrieve data concerning country codes

APOXI also offers a set of generic Providers. They have the same interface as the APOXI Providers. The generic Providers help to obtain different views on data. This is accomplished by chaining Providers. For example, one can put a FilterProvider A "in front" of data Provider B. B is said to be the child of A. Of course one can put a third Provider C (e.g. a SortProvider) in front of A. The purpose of generic Providers is to simplify the sorting, finding and filtering of data (rows). They provides only a view of the child Provider.

Two types of Providers exist in APOXI, they are:

  • Data Providers: Data Providers work directly with data i.e, loading data, storing data etc.
  • View Providers :View Providers have the same interface as Data Providers. They are used for sorting (e.g. QuickSort Provider), finding( e.g. Find Provider) and filtering( Filter Provider) rows and provides only a view to the child Provider.They also provide cascading of more than one Providers.

2.1.1 Provider Interface

Providers present data as matrix of data elements (rows x columns). You can think of it as a grid - in terms of the arrangement - similar to a spread-sheet. All Providers have a unique constant numeric Provider-Id associated. Every column in the grid, which is associated to a specific Provider, has a unique Column-Id. These Ids are unique throughout APOXI.

Reading data is done by GetDataItem. Writing is done row by row. A row has to be locked first, data is modified by calls of SetDataItem, the changes have to be committed (either by Commit, AppendRow, DeleteRow, or InsertRow), and finally the procedure is closed by Unlock.

2.2 DataItem

DataItem is used to represent data of a Provider. It is used for transporting data to and from Providers.The class is able to store different types of data and therefore implements a versatile interface. DataItem class supports Provider, Number, String, WString, PhoneNumber, Date, Time, DateTime and GenericObject classes. DataItem always contains an object of one of these types but can be reused when storing new data inside the object.

The class DataItem offers constructors and copy constructors for all data types supported by it. The Type is determined by the enum DataType and Set'n'Get methods are provided for changing or retrieving the associated DataType. When a assignment ("Set") method gets called, the DataItem first destroys a preceding old value if present.

3 Collections

Using collections objects can be organized in to predefined data structures. In auxiliary, collections for different use cases are provided and iterators are used for implementing convenient access to items. An example for the use of collections is organizing e-mails in a mobile phone. Some use cases of collections in auxiliary are listed in the following:

  • Linkable Template: Enables class to be used inside a LinkedList and extends class with pointer to next linkable.
  • LinkedList Template: Links linkable objects to list.
  • IndexTable Template: Allows creation of a variable index table containing scalar types like LONG,INT16, INT and INT32.
  • FixedPtrArray Template: It is used to represent an array of pointers to classes. It is often used in combination with IndexTable.
  • Vector Template: Contains elements of certain type and access per index as efficient as accessing fixed array.
  • SimpleMap Template: Provides a trivially implemented associative array. An associative array is an array whose values can be referenced by passing a key-value which is not restricted to an integral data type.
  • HashTable: HashTable is a container taking objects of type Hashable. It provides a pretty fast access to the stored objects.

4 Bit manipulations

The Bit manipulation templates used in auxiliary are listed in the following:

  • BitField Template: Wraps scalar data types to access single bits and easy to use bit operation methods.
  • BitVector Template: Represents a bit field with n bits. It is easy to use because all C bit operations are hidden
  • DynamicBitVector Class: Used to represent a bit vector with a variable number of bits. It is instantiated with a variable number of bits at runtime.

5 Data Elements

The data element classes provided by auxiliary are WString class, String class, PhoneNumber Class, Date Class, Time Class, TimeSpan Class, DateTime Class, GenericObject Class, BlobPtr Class, BlobObject Class. These classes are described in the following sections.

5.1 PhoneNumber Class

PhoneNumber class implements phone numbers as defined in GSM 04.08. The properties of PhoneNumber class are listed in the following:

  • MOC, MTC and PDU types of presentation are supported
  • Large set of constructors, based on byte buffers or Wstrings
  • Access methods for TON/NPI or presentation indicators
  • Type of phone number can be changed inside the object
  • Implicit transformation to string objects with GetWString() or GetString()
  • Access methods to the BCD coded representation of the phone number
  • DataItem class support

5.2 Date Class

Date Class represents a date consisting of day, month and year. This class provides assignment and comparison operators and Format methods for string representation in different formats. In this class there are large set of string representation methods like:

  • MonthName()
  • ShortMonthName()
  • DayName()
  • ...

It also provides large set of helper methods such as:

  • IsLeapYear()
  • DayOfYear()
  • DayOfWeek()
  • ...

5.3 Time Class

Time class represents time consisting of hour, minute and (optional) second, millisecond values. This class supports DataItem class and provides assignment and comparison operators. Format methods for string representation in different formats are also available in this class. There are methods for setting and getting hour, minute, second, and millisecond values.

5.4 TimeSpan Class

TimeSpan class represents a period of time in seconds and the maximum representation is 2^32 seconds. This class is used for DateTime operations and contains large set of access methods for getting absolute weeks, days, hours, minutes, and seconds of the time period.

5.5 DateTime Class

DateTime Class represents a point of time consisting of date and time. This class is derived from Date class therefore it inherits all access methods from Date Class. It provides operators and methods for adding and subtracting TimeSpan values and allows computation of the period between two points of time. DataItem class is supported in the class.

5.6 GenericObject Class

GenericObject is an abstract base class, which can be used inside DataItems. Therefore derived classes can be used to transport data into and out of Providers.

5.7 BlobPtr Class

This class represents a pointer to a byte buffer and the buffer length and no allocation or deallocation of memory is done. BlobPtr contains a pointer to data and the length of the data. It can be used to export data from a Provider where data inside the Provider is not changed during the usage of the BlobPtr object.

5.8 BlobObject Class

It contains a byte buffer and its length and allocation, copying and deallocation of memory is done on construction and destruction. BlobObject contains a pointer to allocated data and the length of the data. All data are copied during construction time and deleted during destruction time.

6 String Handling

Auxiliary provides WString and String classes for string handling.

6.2 WString Class

WString class is an unicode string class containing 16-bit characters. Some characteristics of WString class are listed in the following:

  • Points always to dynamically allocated byte array with reference counting
  • Method Format(…) in the class follows the C-printf standard with variable number of parameters
  • Provides implicit transformation to String objects with ToString()
  • DataItem class support

6.2 String Class

String class contains 8-bit characters. Some characteristics of the String class is listed in the following:

  • Points always to dynamically allocated character array with reference counting
  • Implicit transformation to WString objects with ToWString()
  • DataItem class support

7 Data Buffering Classes

Some of the data buffering classes provided in the Auxiliary module are listed in the following:

  • BinData: BinData defines an interface to access binary data in a way that releases the user from memory management
  • RamData: Provides a BinData interface to a dynamically allocated or statically defined RAM memory area
  • BufferedData: Provides an internal copy of the buffer

8 GSM Decoding Classes

GSM decoding classes in auxiliary are listed in the following:

  • AlphaCoding: Implements string coding and decoding as defined in GSM 11.11 Annex B
  • DataCoding: Implements SMS coding and decoding as defined in GSM 03.38

9 Observer Base Classes

  • ObservableObject: An Observable-Object can be observed by several instances of the class Observer.
  • Observer: An Observer is informed about the change of a state of an ObservableObject. To get informed every Observer must attach itself to the Observable-Object. An Observer may attach itself to several Observable Objects.

10 Miscellaneous Classes

Some other important classes provided by Auxiliary module are described in the following:

  • NiSharedPtr: NiSharedPtr implements a shared reference-counting non-intrusive smart-pointer. This smart-pointer is non-intrusive with respect to the objects that get reference counted, i.e. the objects do not have to be derived from some dedicated base-class and may stay as they are
  • SharedPtr: It is a shared reference-counting smart-pointer, used only with classes that derive from ReferableObject
  • MimeTypeTable: Provides static methods for conversions between MIME type, file extension, and MIME type string. It also can tell whether MIME data is encoded in a binary or textual format
  • StateMachine: Base class for state machines


Bluetooth Overview

1 Introduction

Bluetooth is a computing and telecommunications industry specification that describes how mobile phones, computers and other BT devices can easily interconnect wireless with each other.

The APOXI Bluetooth framework forms a part of the APOXI framework and is used to support Bluetooth functionality to the MMI and MMI Applications. This Bluetooth functionality includes the dial up network, head set support, etc.

2 Architecture

The APOXI Bluetooth framework connects the Bluetooth MMI & MMI Applications to the Bluetooth API & Bluetooth Stack. The gray areas in the following figure form the APOXI Bluetooth framework.

The Bluetooth Java API forms the interface to the "BtAPOXI Base Classes", so that the can be used out of Java- Applications. The interface to Bluetooth Java-Applications is formed by Java classes that are implemented via the "Java Native Interface (JNI)" to gain access to the classes of the APOXI Bluetooth Framework, which are implemented.

Figure 1. Bluetooth Architecture

The lower level interface - the interface to the Bluetooth API and the Bluetooth Stack - is written in C and SDL. The BtAPOXI Base Classes do not communicate to the Bluetooth Stack directly. It always uses the Bluetooth API to query some information from the Bluetooth Stack or send commands to the Bluetooth Stack.

Bluetooth is defined of different profiles and each profile provides certain procedures and services.The most basic profile is the Generic Access Profile.

3 Generic Functionality

Bluetooth application is a composition of different BT profiles, specified by [BT-Profiles-Spec]. The basic application functionality provides a main entry point for the user and common functionality for each profile. Bluetooth application is unitized on profile level, which means, it is possible to add or remove functionality that is covered by profile without any impact to the applications architecture. Profiles are encapsulated as separate modules offering an API to other profiles. Profiles can interact using other profiles APIs.

4 General Overview of Packages

The General overview of packages in APOXI Bluetooth are shown in Figure 2.

Figure 2. General Overview of Packages

5 Bluetooth Profiles

Bluetooth uses several different "profiles" for different sorts of interaction. These are designed for a specific task, and not all devices support all profiles. The Bluetooth profiles provided by APOXI Bluetooth and their usecases are described in this section.

5.1 GAP & SDAP Profile

The use cases of GAP & SDAP Profile are explained in this section.

5.1.1 GAP (Generic Access Profile)

Defines the generic requirements for detecting and establishing a connection to a Bluetooth device. This profile defines the generic procedures related to discovery of Bluetooth devices,connecting to Bluetooth devices etc. This profile defines the usecases for the local device. The use cases are listed in the following:

  • Set Discoverability: If this is not set for local device, the other devices searching for Bluetooth devices will not be able to discover that particular device
  • Set Device Name : Sets the Bluetooth device name for the local device
  • Set Pairability: Sets the pairabilty for the local device or in other words enables the device to accept the pairing.
  • Set Connectivity: if connectivity is set on local device, other devices can connect to the device when it comes within their area of radio coverage
  • Pair: Pairing of devices means to make communication among devices available via a common communication code. To generate this communication code the user is prompted to enter a security code.:When no pairing is done, every time a remote device tries to connect to the local device, depending on the security settings of the requested profile, a request for a pin number is executed.
  • Unpair: Unpairing destroys a former created pairing of two Bluetooth Devices i.e, pairing with the selected device is cancelled. The user should be informed that the device is no longer a paired device.
  • Trust : This feature is only available if the state of the device is paired and not trusted. It is part of the context menu of the selected device and after selecting this feature the user should be informed that the device is marked as trusted. Marking a device as trusted device overcomes the authorization, i.e. confirming a connection request is no more required because the device is authorized to establish a connection.
  • Untrust: This feature is only available if the state of the device is paired and trusted. This feature makes a trusted device not trusted.

5.1.2 SDAP (Service Discovery Application Profile)

Bluetooth device to discover services registered in other Bluetooth devices.This profile is defined for remote devices. The use cases of this profile are listed in the following:

  • Search for devices: Search for other Bluetooth devices ready for communication
  • Querying service records

5.2 FAX and DUN Profile

The use cases of FAX Profile and DUN(Dial-up Networking Profile ) Profile are described in this section.

5.2.1 DUN Profile

Dial-up Networking Profile (DUN) profile defines the requirements for Bluetooth devices necessary to support the Dial-up networking use case. The Bluetooth mobile phone can be used as a wireless modem for connecting to a dial-up internet access server. The use cases of DUN Profile are listed in the following:

  • Remote Connect: Remote DUN-Serivce connects to local device
  • Remote Disconnect: Remote DUN-Serivce disconnects from the local device
  • Local Disconnect: Local device disconnects from the remote DUN-Serivce

5.2.2 FAX Profile

The Fax profile defines the requirements for Bluetooth devices necessary to support the Fax use case. The Bluetooth mobile phone can be used bas a wireless fax modem to send or receive a fax message.The use cases of FAX Profile are listed in the following:

  • Remote Connect: Remote FAX-Serivce connects to local device
  • Remote Disconnect: Remote FAX-Serivce disconnects from the local device
  • Local Disconnect: Local device disconnects from the remote FAX-Serivce

5.3 HS(Head Set) and HF(Hands Free) Profile

The use cases of HS Profile and HF Profile are described in this section.

5.3.1 HS Profile

The Headset (HS) Profile defines the requirements to support the Headset use case. The use cases are listed in the following:

  • Local Connect: Local device connects to the remote HS
  • Remote Connect: Remote HS connects to local device
  • Remote Disconnect: Remote HS disconnects from the local device
  • Local Disconnect: Local device disconnects from the remote HS
  • Local / Remote Volume control
  • Transfer audio to HS from HS or mobile phone: When there is an on-going call between the mobile and an external telephone, the user can transfer the call to the headset from mobile or from headset.
  • Transfer of audio from HS to mobile phone
  • Accept MTC (Mobile Terminated Call) on HS
  • Release ongoing call from mobile phone and HS

5.3.1 HF Profile

The use cases of HF (HandsFree) profile are same as those provided by the HS Profile. In addition, HF Profile also provides the possibility for multy party call.

  • Local Connect: Local device connects to the remote HF
  • Remote Connect: Remote HF connects to local device
  • Remote Disconnect: Remote HF disconnects from the local device
  • Local Disconnect: Local device disconnects from the remote HF
  • Local / Remote Volume control
  • Transfer audio to HF from HF or mobile phone: When there is an on-going call between the mobile and an external telephone, the user can transfer the call to the handsfree from mobile or from handsfree.
  • Transfer of audio from HF to mobile phone
  • Accept MTC (Mobile Terminated Call) on HF
  • Release ongoing call from mobile phone and HF
  • Voice Recognition
  • MOC from HF

5.4 OBEX Profile

OBEX profile is used to get and send data from the remote devices. With this profile it is possible to use a Bluetooth device for exchanging objects with another Bluetooth device. The Bluetooth device can be used as OBEX Server as well as OBEX Client. The Profile can be used in conjunction with the APOXI OBEX implementation via a callback interface and also as stand alone Bluetooth only implementation based on a message interface. It implements the standard OBEX operations like Connect, Disconnect, Put, Get, SetPath and Abort on both sides
(server and client).


Devices Overview

1 Introduction

Devices module defines the common interface to the devices such as display, keyboard and real time clock, camera, etc.

The class Device is a defined abstract interface, where the implementation is hardware-dependant. When changing the implementation of a device, it must be assured that the public interface is not changed. It is not necessary that the class stays binary compatible, as usually APOXI must be compiled anyway when major changes of devices are done.

2 Keyboard

The Keyboard in APOXI is configurable and there can be different keypads which differ in the number of keys and the position of keys as shown in the following figure.

2.1 Handling of keys

The keyboard driver provides the SDL signals indicating the key press and key release. It also provides a timestamp giving the time when the key has been pressed or released. All other events from the keyboard are handled by the keyboard device.

The applications can get the key states in two ways as described in the following:

1) Applications can ask for the key state of a particular key. An example for this key state checking is given in the following code:

Keyboard::GetKeyState(KeyboardConfig::GetNumber(5))

2) Whenever there is a keystate change, the keyboard device will send the corresponding message to the application. To receive these messages, applications should register for them. The messages send from the keyboard to applications are described in the following:

Key Down Message

This message is send to the application each time the user presses a key.

Key Up Message

This message is send to the application each time a key is pressed.

Long Key Press Message

This message is send to the application when ever a particular key is pressed for a specified duration of time. For example, suppose long key press time period has been specified as 1000 Millie seconds. In such case a long key press message will be send to the application whenever user presses a key and not releases it until 1000 milliseconds. The time limit for the long key press is defined in the KeyboardConfig.

Very Long Key Press Message

This message will be send to the application when the user presses a particular key for a very long time period. This time period is specified in the KeyboardConfig.

Key Auto Repeat Message

This message will be send when the user presses a key for a very long time period. It indicates the same effect as pressing a key severel times,i.e, auto repetitions of the key press. The application can use Key Auto Repeat information for some special actions. For example it can be used to move down or up through menu items by pressing the down or up key for a long time. The auto repeat delay and the auto repeat intervals are also specified in the KeyboardCofig.

Key locking

  • Unlocked: When the keyboard is in unlocked state, all the key messages will be sent out to the application when ever there is a keystate change for each key.
  • Locked: If the keyboard is locked, normal key messages will not be send out. In such locked state a Locked Key message will be send out whenever user presses a key. It is necessary for the applications to register for such a message for unlocking the keypad later.

Keyboard illumination

There are three states of keyboard illumination as listed in the following:

  • On: The illumination of the keyboard will be always on
  • Off: The illumination of the keyboard will be always off
  • Auto: If the keyboard illumination state is auto, then there will be a pre-defined time-out period. If there is no keystate change within that time-out period, the keyboard illumination will be automatically turned off. The illumination will again turned on, whenever there is a keystate change in the keyboard.

Multikey mode

Key board device supports multi key mode. When multi key mode is not enabled only a single key press message will be send to the application at a time even if the user presses more than one keys at a time. This is shown in the following figure 1.

Figure 1. Single key mode

As shown in Figure 1 key2 down message will be send to the application only after the release of the Key1 even though the key2 has been pressed before the release of key1.

When multikey mode is enabled, it is possible for the applications to get the message indicating multikey press when user presses more than one keys at the same time. This is illustrated in Figure 2.

Figure 1 MultiKey mode

As shown in Figure 2, when key2 is pressed before the release of key1, both key1 and key2 down messages will be send to the application.

3 Display

Display device provides methods for accessing the display in a generic way. The direct use of the display device bypasses the APOXI window system.

The display device use an internal frame buffer where all the drawings are done. After finishing the drawingprocess those parts which have changed on the frame buffer are copied to the display buffer by invoking Display::Refresh. The area which has been changed is defined by the so called blitting rectangle. The display has two buffer modes, they are:

  • Double buffering: Provides asynchronous support
  • Single buffering: Provides synchronous support

4 Video channel

The video channel is a separate part of the display device and can be retrieved by invoking Display::GetVideoChannel. Video channel is for playing video.

It is generally assumed that the content to be displayed via video channel is located in a separate buffer (or certain number of buffers), the process of transferring this content to the display is called rendering and is typically assisted by hardware (e.g. a companion chip). Rendering includes some transformation like color conversion, resizing, rotation, flipping/mirroring, clipping/cropping. Most crucial for rendering is the correct mixing of the content in this channel with the display content. This operation is called overlaying.

5 Led

Led is the APOXI device abstraction interface for LED hardware driver. APOXI Led Provides the following functionalities:

  • Multi color Support: Led Provides multi color (RGB) support. This multi color support is hardware dependent i.e, Led will not be able to support multi color if the hardware does not support multi color.
  • Turn on/off Led: It is possible to turn the LED on ad off
  • Fading the LED on and/or off
  • Streaming: Streaming is also supported in APOXI Led. It is the creation of color streams for special illumination scenarios.

6 Real Time Clock

RealTimeClock is the APOXI device abstraction interface for RTC hardware driver. The Real Time Clock provides the following functionalities:

  • Set Date and Time: Sets the date and time
  • Get Date and Time: Gets the current date and time
  • Handling of single Alarm:This interface helps to handle single alarm

Note: Kernel module provides an interface called AlarmManager for handling multiple alarms

7 Charger

The charger interface in APOXI provides the following functionalities:

  • Provides status of charger: The application can ask for the status of the charger. The status includes:
    • Disabled: This status indicates that the charger has not been initilized
    • WaitingForConnection: This means the charger is not connected yet
    • ConnectedAndCharging: This indicates that the charger is connected and charging is active
    • ConnectedAndBatteryFull: This indicates that the charger is connected but charging is inactive because the battery is full
    • DisconnectedAndBatteryFull: This status indicates that the battery is full and the charger has recently been removed
    • DisconnectedAndBatteryNotFull: This status indicates that the battery is not full and the charger has recently been removed
  • Provides the Capacity of charger: This indicates how much capacity is left and is expressed as percentage of full capacity. Value range: [0..100]

Some of message interfaces provided by charger are listed in the following:

  • ChargerRemoved: This message is send to the application when the charger is removed
  • ChargeBattery: This message is send when the battery is charging
  • LowBattery: This message is send to the application when the battery charge is low
  • BatteryEmpty: This message is send to the application when the battery is empty
  • ChargeEndBatteryIsFull: This message will be send to the application when the battery is full

8 Camera

Camera device is for accessing hardware cameras. The application has the possibility to obtain a special camera, which is bound to the hardware ID. The camera object is defined statically in the camera configuration (CameraConfig). For each camera device one camera object exists. Functionalities provided by the Camera device are described in the following:

  • Setting up ViewFinderSize and Display: When enabling the view finder, the viewing picture is scaled to the defined rectangle, which usually corresponds to the size of the view finder window. Nevertheless, the view finder rectangle can be limited in scaling due to hardware restrictions.
  • Setting up ViewFinder: For enabling, disabling and taking a picture, the Method SetViewFinderCommand() can be used. The given parameter indicates the command in which state the ViewFinder should be set. The different states that can be set in the ViewFinder are:
    • Disabled: It is the default state, where the ViewFinder is disabled.
    • Enabled: This means that the viewfinder is enabled and is drawing on the given display.
    • Capture ViewFinder: If ViewFinder is set to CaptureViewFinder, a picture is taken and will be processed by the camera device (e.g.converting to JPEG) and copied into the given buffer.
    • Show Captured Image: Displays the last captured Image again on the ViewFinder. This setting is optional. It is hardware dependent feature.
    • Freeze view finder: Stops of the ViewFinder (last frame is displayed). In the freezed state no image processing will be done. This is feature is hardware dependent and is optional.
  • Setting Color Format: Certain cameras may deliver different color formats, like RAW YUV data or encoded JPEG data. The APOXI Camera API allows to select a supported color format. In APOXI camera, it is possible to change and get the image data or color type. The method GetSupportedColorFormats delivers an array of the supported color formats of the companion chip.
  • Image Size: The image size returned by the camera can be set via SetImageSize. It determines the size of the image that will be returned natively, without resizing through the viewfinder. If the requested image size is not supported, the call is ignored and FALSE is returned. All possible image sizes can be retrieved by calling the method GetSupportedImageSizes().
  • Setting up Camera Properties: Certain camera properties such as brightness and contrast, can be set via a so called property. The property itself consist of property name, a property type and a property value.
  • Twilight Mode: By enabling twilight mode, the sensitivity of the companion chip will be increased. This results in better images in certain light conditions.
  • Mask: Some companion chips support masking the image. In APOXI there is a comfortable way to use transparency and even alpha blending. Masking and Blending is done via a DeviceContext. Internally there is blending mask which will be used for blending objects over the camera viewfinder. Therefore the user does not need to take care about the blending mask.
  • Anti-Flicker Mode: To reduce flicker problems, the anti flicker mode can be set to 50 or 60 Hz. This prevents dark streaks in the image when shooting pictures in electric light powered by either 50 or 60 Hz currents.
  • Flash: The on board flash can be enabled or disabled.
  • Zoom: In camera device it is possible to set the zoom levels.
  • Transformation: The transformation includes the rotation of the image in 90° steps, including mirroring.

9 Video Camera

The video camera device is derived from camera and offers all functionality of a still camera. In addition it has an extended interface for video capturing functionality. The functionalities of the video camera are listed in the following:

  • Video Capturing: Before starting capturing, some user defined values need to be set. These settings includes settings for still camera interface, such as setting up view finder, setting Image size, view finder size and display, color format, and additional parameters for video recording like size of the video.
  • Registering Callback Functions: The application has to set the required callback functions for the video capturing.
  • Setting up Capture Buffers: For video capturing a number of buffers are required. Those buffers can be both allocated and held by the device layer, or found on the companion chip.
  • Starting and Stopping Recording: Methods are provided in Video Camera interface for starting and stopping the recording.


DRM Overview

1 Introduction

APOXI DRM enables the programmers to create DRM (Digital Rights Management) enabled applications. APOXI DRM complies with OMA DRM (Open Mobile Alliance DRM) standards.

2 Architecture

OMA DRM in APOXI processes DRM Messages, provides a central storage of rights objects and makes the applications aware of constraints/restrictions on DRM operations (play, print, execute, display).

Figure 1. DRM Architecture

APOXI DRM provides interfaces for:

  • Processing DRM Messages
  • Validating access for a DRM asset
  • Rights management APIs
  • Media object access APIs (with decryption)
  • Configuration APIs
  • APOXI DRM sample application and API reference

2.1 Trust Model

Applications (Image browser, sound browser, MMS applications, WAP applications etc.) have to be adapted to support DRM. Applications need tight integration with APOXI DRM to validate rights before consuming DRM content. DRM enabled applications in APOXI are trusted to enforce rights by using APOXI DRM API.

2.2 APOXI Scope

The APOXI scope for DRM are listed in the following:

  • APIs to process DRM messages
  • DRM Asset abstraction
  • Persistence of DRM Rights
  • DRM (Push) user agent - to process rights messages for SD
  • APIs to validate asset
  • APIs to update rights on content consumption

2.3 Application Scope

The application scope for DRM are given in the following list:

  • Acquisition of assets (content)
  • Use APOXI DRM API to process message
  • Storage of processed message (asset) along with a key to access rights
  • Enforcing rights by calling APOXI API
  • Deletion of rights on expiry or on user request
  • Provide appropriate user interface to user for rights related information

3 APOXI DRM - Components/Modules

All those modules which are part of or interact with DRM are shown in the following figure.

Figure 2. APOXI DRM - Components/Modules

4 APOXI DRM Interfaces

APOXI DRM has two key classes, DRMAsset and DRMMessage abstracting the asset (content) and the incoming DRM message (FL, CD or SD) respectively. In addition to this it has a range of classes that abstracts the constraint, permission, rights object and the rights object store which are internal to the APOXI DRM Core.

4.1 DRMAsset

DRMAsset abstracts the DRM content, meaning the entire DRM Message. All DRM content (like Image, Mp3sound etc.) classes are (also) expected to derive from this class. It is a light-weight mix-in class that has only one data member - the local ID. It has APIs to validate rights and access/update data from the rights objects.

4.2 DRMMessage

DRMMessage is a message processor which can parse and store rights from an incoming DRM Message. The message could be FL, CD or SD (DCF). Applications will use this interface to process DRM Messages (including rights message, in case of SD). After processing the message, it returns a local ID, which the application stores in the Asset.

4.3 DRM Local ID

DRM Local ID is an internally generated ID to minimize the handling of UID, which is a long string. UID is defined by the DRM specification as content ID which is referred in the content as well as the rights object. A particular asset may be associated with multiple rights object (only in case of separate delivery) but still has the same local id.

APOXI DRM returns a local ID when the application processes the incoming DRM message. Applications are required to store this ID and use it as a key to DRM subsystem for further API calls. For this purpose, the FFS is extended to include DRM Local ID and the DRM Mime Type as file attributes. This also helps applications to distinguish DRM enabled content from regular content.

A value 0 indicates invalid DRM Local ID (thereby indicates that this may not be a valid DRM asset). APOXI DRM has maximum possible local IDs, which is configurable.


GUI Overview

1 Introduction

The main features of APOXI GUI are:

  • Event-based communication
  • Integrated window system
  • Dynamically changeable look and feel
  • Multilingual support (bidirectional input)
  • Hardware-independent graphical device interface

The document gives an overview of the APOXI-GUI-framework.

2 Application and Window

Two main parts of the APOXI-GUI-framework are the classes Application and Window. APOXI windows have the same features as windows known from modern operating systems on desktop personal computers:

  • They can change in size and position
  • They have themeable frames
  • They can have child windows, as commonly known from multiple document interfaces

An application may contain a variable number of windows. The drawing of the window and its content is done on a so called device-context. A device-context is implemented by the class DeviceContext and represents an abstract drawing area, with defined colors for pens and brushes, text-attributes and raster-operations.

It is very important to be aware that a window always belongs to one application and may not be accessed in a direct manner from other applications. This is because each application might run in its own thread. As a thumb rule:
Applications may only communicate with each other by posting messages. Direct access to the data of another application is not allowed.

3 Components

Every graphical object is derived from the class Component, which represents a graphical object with a rectangle as boundaries. Every component is able to handle and route messages. There are two groups of components, they are:

  • Drawable objects
  • Controls

3.1 Drawable Objects

Drawable objects are represented by the class DrawableObject, which is the base for all graphical objects, which do not interact with the user but receive messages. They can be drawn and have boundaries but have no distinction between frame and client area and cannot have focus. The classes ImageBox, ProgressBar and TextBox are examples for drawable objects.

Figure 1. Drawable Objects

3.2 Controls

Controls are represented by the class Control and can have one or more child-components which are layouted inside the control. A control can be drawn and has a distinction between a frame-area and a client-area. Messages send to a control are handled by the parent-control first and then forwarded to potential childcomponents. Controls can get the focus and hence interact with the user, as all key-messages are forwarded to the focused control. The classes CheckBoxControl, LineEditor and PushButton are examples for controls.

Figure 2. Controls

3.2.1 Window

The class Window extends the class Control and has the following additional optional features:

  • Title
  • Softkey bar
  • Can be opened modal or modeless

Opening a Window Modal vs. Opening Modeless

A window can be opened modal by invoking Window::OpenModal() or modeless by invoking Window::OpenModeless().

statement 1;
align="justify" class="Stil12">win.OpenModal();
align="justify" class="Stil12">statement 2;

In this case statement 1 is executed and the window is opened modeless. Statement 2 will be executed immediately after Window has been opened.

statement 1;
align="justify" class="Stil6">win.OpenModal();
align="justify" class="Stil6">statement 2;

Now statement 1 is executed and the window is opened modal. Statement 2 is executed only after the window has been closed.

3.3 Sample Application

The following implementation of a sample application should convey a feeling of APOXI.

3.3.1 Displaying "Hello World"

In order to write a "Hello world"-application on the mobile phone, a window needs to be created for drawing a text. The header-file for the class MyWindow is shown in the following:

#if !defined(Mmi_MyWindow_hpp)
#define Mmi_MyWindow_hpp

#include <GuiExtensions/MmiWindow.hpp>

class MyWindow : public Window
{

typedef MmiWindow Base;

protected:
virtual void OnPaint(const Rect& repaint_rect);

};

#endif // Mmi_MyWindow_hpp

3.3.2 The Implementation of MyWindow

The drawing of a window is done on the device context. All drawing operations done on the device context, which represents an abstract drawing area and has defined colors for pens and brushes, text-attributes and rasteroperations. Device context of control is retrieved via GetDeviceContext() and PaintDc provides comfortable usage of a standard device context. The MyWindow.cpp for "Hello World" is given in the following code:

#include "MyWindow.hpp"

void MyWindow::OnPaint(const Rect& repaint_rect)
{

Base::OnPaint(repaint_rect);
PaintDc pdc(GetDeviceContext());
pdc.DrawText(5, 10, Tr(L"Hello world"));

}

Windows also need to be embedded in a common context, which is provided by an application. So before opening any window, an application must be created.This application class should be derived from Application.

3.4 Getting Multilingual

In general, the usage of hardcoded strings should be avoided, because applications should support different languages. For this multilingual support, programmer simply has to pass all texts to the Tr()-method ("Translate") before displaying them. This performs fast lookup within current translation table and returns the translated string literal corresponding to the argument. If no translation table is provided, then the argument itself will be returned. E.g. Instead of L"Hello world" , Tr(L"Hello world") should be used as shown in the MyWindow.cpp example code.

3.5 Handling key events

Handling of a key event in APOXI is shown in the following figure.

Figure 3. Handling key event

The method Window::OnKeyDown() is invoked whenever a key has been pressed. In the example shown in figure 3 , when the window is opened MyWindow::OnPaint() is called and "No key pressed" is displayed. Pressing the key "2" invokes a call of MyWindow::OnKeyDown(). In MyWindow::OnKeyDown() the text in the MyWindow will be updated to display “Key 2 has been pressed”.

When changing data which should be displayed, the window must be invalidated to trigger a paint-event. This can be done by invoking Window::Invalidate(). Window::OnKeyDown() offers a BOOLEAN as return-value, which indicates whether a key has been dispatched. If the key is not treated, the base-method should be called.

3.6 Items

A lot of GUI controls like menus and lists use items for specifying their content. An Item is at least represented by a text and/or an icon. The drawing of the item properties (like the text or icon) is not done by the item itself but usually by a GUI-control (e. g. ItemMenu or ItemGrid). When creating an item it will be assigned to this control and the item informs the control when an item property like the text has been changed, so that the control can redraw itself to show the changed item properties. The benefit for the application developer is that it is possible to modify the item without the need of taking care which GUI-components must be updated, as this is done automatically.

The following example shows two windows which contains an ItemGrid and Item-menu with 3 embedded items:

Figure 4. Item Grid

3.6.1 AbstractItemContainer and ItemContainer

The class AbstractItemContainer is derived from Item and extends the item by an interface for embedding a variable number of items as part of the item-container. The class ItemContainer offers a default implementation and might be used for building a menu-hierarchy which might be displayed by the controls ItemMenu or ItemTree.

3.6.2 Actions

In GUI applications, various user events can be triggered by Menu entry, Button, Softkey etc. Actions bundle logical behaviour and graphical representation. Actions can be attached to Dispatchers (Application, Window, etc.). Dispatchers are informed with ActionExecutedMsg and if action is executed (only if dispatcher is a Window) OnActionExecuted(Action* action) is called.

Some predefined actions for common use cases are given in the following:

  • CheckBoxAction: Toggles between a selected/deselected state
  • RadioButtonAction: One of many choice within RadioButtonGroup
  • CloseWindowAction: Closes current window in its default behaviour

3.7 Device Context

All drawing operations in APOXI are done on the device context, which is represented by the class DeviceContext. A device-context offers methods for drawing lines, rectangles, text and much more. All drawing methods use the current set color, text-format and other attributes which may be modified for each instance of the class DeviceContext. All operations on a device-context must be encapsulated between BeginUpdate() and EndUpdate().


HTTP/WAP Interface Overview

1 Introduction

The access of the internet from mobile applications requires an implementation of the HTTP and WAP protocols and interfaces, which can be used by applications to access these protocols.

HTTP/WAP Interface provides a set of APIs for applications using WAP and HTTP connections while keeping the underlying HTTP or WAP stack vendor independent.

In particular, HTTP/WAP Interface architecture serves the following purposes:

  • It defines the interfaces to HTTP and WAP functionality for future applications.
  • It delineates applications needing HTTP/WAP functionality from the implementation of the HTTP/WAP stack.
  • It allows the implementation of the WAP stack to be in the form of a function calling interface as well as in the form of a service interface invoked by passing messages.
  • It describes the implementation of this interface for a 3rd Party WAP stack.
  • Implementation of WAP Profiles, which are used to store WAP Parameters (Logical/Physical/Authentication/Port Characteristic Sets), required for opening a WAP connection and appropriate methods to get/set their values.
  • Implementation of WAP Profile Manager Interface for applications to manage the Wap Profiles (like creating, storing, retrieving and deleting profiles from memory).

2 Architecture Overview

The following diagram gives an overview of the functional interaction of HTTP/WAP Interface with other modules of the complete system.

Figure 1. Architecture of HTTPWapInterface

2.1 HTTP Client Application

This is any application, which needs to act as an HTTP client. It accesses HTTP functionality in the HTTP/WAP Management package within APOXI.

2.2 MMS Application

This is another application, which needs HTTP functionality.

2.3 WAP Push Client Application

This is any application, which needs to act as a WAP push client, i.e. it will receive push messages. It accesses WAP functionality in the HTTP/WAP Management package within APOXI.

2.4 WapCoreApp Application

This application implements the WapService interface and acts as a wrapper for a 3rd Party WAP stack. The communication between HTTP/WAP management in APOXI and the WapCoreApp application is via messages in both directions.

2.5 WAP Profiles Application

The purpose of this application is to create, edit and delete WAP profiles. It accesses the WAP profiles by using the WAP Profiles management in APOXI. It works very similar to the existing DataConnApp application used to manage data connection profiles.

2.6 HTTP/WAP Management

This package has the task to initiate, manage and terminate HTTP/WAP connections, to handle HTTP requests and responses and to handle WAP push messages.

2.7 Function Called WAP Stack

This package is any future WAP stack with a function calling interface, as opposed to the message handling interface of WapCoreApp.

2.8 WAP Profiles Management

The task of this package is to create, edit and delete WAP profiles and to make them persistent. The primary classes are WapProfileMgr and WapProfile. It uses the Registry package to make profiles persistent.

2.9 APOXI Registry

This is the storage medium for profile data.

3 Overview HTTP/WAP Interface

This section contains description and usage model of HTTP/WAP interface and WAP Profile Management.

3.1 HTTP/WAP Interface

One of the motivations behind developing the HTTP/WAP interface is that applications do not need to be ported each time the underlying HTTP/WAP stack changes. To meet this goal the design has three major parts:

  • Http Service: The HTTP interface is implemented as a service. The functionality of the HTTP is embedded into the class HttpHandler. So applications those want to use HTTP should derive from the HttpHandler class.
  • Interface with WAP: The HTTP/WAP interface has a HttpWapMgrBase class which should be derived by the 3rd Party WAP stack and all the methods in it should be implemented by the 3rd party.
  • Wap Service: The Wap interface is implemented as a service. The functionality of the Wap interface is embedded into the class WapHandler So all the application who want to use the WAP should derive from the WapHandler class.

4 WAP Profile Management

A WAP Profile stores all the parameters required to open a WAP connection. A WapProfile object also holds an identifier of a data connection profile (class DataConnProfile) i.e., the bearer protocol details. WAP Profiles are managed by WapProfileMgr interface implemented by WapProfileMgr class. WapProfileMgr interface provides operations like creation, save, retrieve and deletion of a WapProfile for the applications to make use of it.

The parameters of the WapProfile object are stored in persistent memory and can be retrieved and used for editing. The identifier and the name of all the WAP Profiles are held in a linked list of objects of struct WapProfileInfo. For example, an application that needs the user to select a particular WapProfile can parse through this linked list of WapProfileInfo objects and retrieve the WapProfile name and its mapping identifier. As and when the user selects a particular name, then its corresponding profile id can be passed to the method which opens a WAP connection. WAP Profile Management is a library which can be used by an upper layer application to manage the WAP Profiles.


IrDA Overview

1 Introduction

IrDA stands for Infrared Data Association. Currently APOXI supports general transport related functionality like enabling or disabling the infrared port hardware for power saving purposes, setting the device nickname and setting IrDA hint bits.

Besides that APOXI IrDA can be used as transport for OBEX transfers. The OBEX transport adapter is used by the APOXI OBEX implementation. It should only be used through the APOXI OBEX interfaces not directly.

2 Overview

The following figure gives an overview of the APOXI IrDA components and their interaction with other system components.

Figure 1 APOXI IrDA Components

3 Architecture

The APOXI IrDA module consists of two main function blocks. They are:

  • Generic transport implementation IrdaTransport
  • OBEX related implementation consisting of IrdaObexTransport, IrdaObexAddr (both client and server) and IrdaObexImpl

3.1 IrdaTransport

IrdaTransport is inherited from AbstractTransport and extends the functionality by adding IrDA stack specific methods. IrdaTransport is a singleton class that is used to access the underlying IrDA stack implementation. When OBEX is supported it also contains an IrdaObexTransport instance.

3.1.1 Timer

The default time out for switching off the IrDA hardware is set to 10 minutes. This switching of of IrDA hardware helps to save the battery power during idle time.

3.2 IrdaObexTransport

The IrdaObexTransport class implements IrDA specific OBEX transport related functions and protocols. Address resolution is done by this class. It is also responsible for registering the IrDA OBEX implementation with the APOXI OBEX ObexMngr.

3.3 IrdaObexAddr

The IrdaObexClientAddr and IrdaObexServerAddr classes are used to specify an OBEX client or server address.

3.4 IrdaObexImpl

The IrdaObexImpl class is responsible of implementing the abstract ObexLayer interface. This interface is used by the APOXI OBEX module to start OBEX client commands and to get notified about incoming server commands.

In order to manage different client and server contexts there are two private helper classes inside IrdaObexImpl These helper classes include the data structures that are required by the IrDA stack internally. Besides private structs it also provides a buffer that is used by the IrDA stack to build outgoing headers.

As the context is passed to several callback functions by the IrDA stack, a reference to the IrdaObexImpl object included. The object also holds several variables that describe the current state of the context: ObexOperationId of the current operation and a flag whether an operation is currently running.

The IrdaObexImpl class holds an array of both APOXI_IRDA_OBEX_MAX_CHANNELS client and server channel pointers. Every time a new channel is requested by a client or server, an according object is created and the slot is filled with the new object.

3.5 Auto switch off of IrDA hardware

The auto switch off of IrDA hardware helps to save battery power during idle time. A timer is started when IrdaTransport::OnAvStateChanged() is called, and the following coditions are met:

  • IrLAP is not connected
  • IrDA monitoring is idle
  • IrComm has no active connections
  • IrDAObex has no active connections

The default time out for switching off the IrDA hardware is set to 10 minutes. This default time out can be overwritten by a function call from an application to set a new value, but use of this function is optional.

The time out specifies the amount of milliseconds the IrDA hardware remains active after last activity on the interface. The hardware will be switched off when the time out elapses.

Setting time out value to 0 milliseconds has a special meaning, this setting disables the time out and the IrDA hardware will not be switched off when it is idle. Application could use this feature, for instance, when the phone is connected to power supply and no power saving features are needed.


Kernel Overview

1 Introduction

Kernel module defines core-functionality of APOXI and the layer to the operating system. The kernel interfaces for some core functionalities of APOXI and OS layer are described in the following sections.

2 OS Layer Interfaces

Kernel provides a generalized OS interface for APOXI. OS interfaces provided by kernel are listed in the following:

  • Thread: It is the APOXI interface for mapping all OS thread functions. A thread is the basic unit to which the operating system allocates processor time.
  • Semaphore: Semaphore object is a synchronization object that maintains a count between zero and a specified maximum value. The count is decremented each time a thread completes a wait for the semaphore object and incriminated each time a thread releases the semaphore. When the count reaches zero, no more threads can successfully wait for the semaphore state to become signaled. Semaphore is useful in controlling a shared resource that can support a limited number of users.
  • SystemTimer: SystemTimer defines a generic interface for general purpose application timers to support timers also outside application context.
  • Scheduler: This Scheduler is the Nucleus Scheduler implementation. The Scheduler always runs in the context of the RTOS task. Scheduler functions in turn calls AppContext functions to switch the context. This scheduler is used for scheduling applications inside an application container.
  • Error handling
  • Debug information/ Tracing

3 Core Functionality

3.1 Application Container

An application container is an ApoxiThread and it maps to one operating system thread. Application container holds a number of applications. These applications are managed by an internal and resource-friendly APOXI scheduler, which assigns the threads processing time to the applications in a cooperative way.

When a message is received, the application container calls the applications which are registered for that particular message in a sequential manner to handle the message.

3.2 Application

An application is the instance for handling and routing messages. All incoming messages are treated in OnMessage() and routed to user-dispatchers and windows. Every application is part of an application container and can have one or more windows. To extend the handling and routing of messages in an easy manner it is possible to add user-defined dispatchers to an application.

3.3 Message Handling / Routing

The message handling structure includes, application container and application. Message routing is done by MessageRouter. It is a static class to perform the base functionality of APOXI message routing. Posting a message in general means to enqueue the message to those message queues of application containers or service threads which are ready to receive this message.

3.3.1 Message Handling in Application Container

Each application container contains a message queue and routing table. All the registered messages will be stored in the routing table and messages sent to application container will be pushed into the message queue. The message router routes the messages to application containers. There are several generally used message types: MC_SYSTEM, MC_APP, MC_FOCUS, MC_CONTROL, etc. Different message types are dispatched by message router and application container differently.

The example for handling of messages in application container is shown in figure 1.

Figure 1. Message Handling in Application Container

3.3.2 Message Handling in Application

Inside application, function RouteMessage() routes the message received. The messages will be first routed to the user dispatcher list. It contains a series of user defined dispatchers. If the messages cannot be dispatched in the user dispatcher list, MC_FOCUS type message will be routed directly to the focused window.

If the message is not MC_FOCUS type, it will be routed to the child window list of the application. The routing will not be finished until the message has been dispatched or all windows in the list have analyzed the message.

If the dispatching of the message to the child window is not successful, then this message will be processed by the HandleMessage() in the application.

3.4 Message Hooking

Message hooking enables the applications to hook into messages (especially indications, like new SMS, alarm expired..) and react on them before they are sent to the dedicated applications.

The message hook object holds a trigger method, which is called when a posted message matches the message hooks requirements. For the execution of this trigger method there are two policies defined:

  • Synchronous mode
  • Asynchronous mode

3.4.1 Hooking Mechanism

The hooking mechanism is based on a list of message hooks which is stored in a global scope. This list is only be accessed when message hooks are attached or detached and of course if a message is posted. This list consists of references to the real message hook instances held by the message hook owner (application/service thread). Every message hook can be reused as often as needed and is open to all applications.

Once there are entries in the global message hook list, every posted message is routed to the message hook’s method Suspend(). In this method the incoming message is checked against every message hook. If the message ID of message hook matches the message, then a notification of the owner of the message hook is done.

The main task of the notification is simply calling the trigger method OnMessage() of the hooking message hook instance. This notification can be either in asynchronous mode or the synchronous mode depending on the policy applied to the message hook.

Resuming of the message hook is called after the return of the message hook notification method. This return parameter is used in Resume() to describe whether that instance of message hook wants to discard the hooked message or mark it to be sent.

Message hook is detached from the global list of message hook references using the method Detach(). When detached, the message hook is marked to be deleted from the global list as soon as there is no pending hooked message referring to this message hook.

3.5 ServiceThread

ServiceThread is used to implement services, i.e. tasks which perform permanent background activity like network services. A service thread does not need any graphical user interface but needs to run as an own thread. It only awakes from idle when it receives a message or when a timer expires.

3.6 Timer

A timer can be started, stopped, resumed and restarted. It has a time-out value and when this expires, a time-out message will be sent. A timer always belongs to one application and may not be shared.

3.7 Alarm Manager

Alarm manager handles multiple alarms. It handles one alarm request per application. This means it holds a list of each application's next alarm time stamp.

Whenever an alarm expires, the corresponding application will get informed by sending the AlarmNotificationMsg. Applications which receive alarm notification message have to send its next alarm request if it has one. If more than one applications are requesting an alarm with the same point of time the alarm manager sends the alarm notification message to all applications.

When power is on the alarm manager sends the alarm notification message to all applications which had missed an alarm during power off. Each alarm can also be defined to power on the phone if it is turned off at alarm time.

3.8 Memory Management

One idea behind the APOXI memory management is that it is configurable for certain projects because projects differ in their memory requirements. So the memory configuration itself is divided from the algorithms which allocate and free memory. The algorithms are implemented in the kernel and are using the configuration table defined in MemoryConfig file.

The role of kernel in APOXI memory management is shown in the following figure.

As shown in the figure, kernel provides the HeapManager and HeapVector. The allocation/free methods are using the HeapManager which will find a block of requested memory and frees used memory blocks.

3.9 Generic Worker Task

The generic worker tasks runs on a lower priority than the rest of the system. Applications can submit work packages (threadlets) to the input queue of this task. The queue will be treated as FIFO queue. A threadlet exposes a generic interface to executing parts of an application in context of another thread (i.e the GenericWorkerTask). When the threadlet is executed, the application can decide to wait synchronously by the active wait mechanism. It can also start the threadlet asynchronously.


LCS Overview

1 Introduction

AGPS is a concept used for Global Positioning Systems which can provide accurate measurements of the position even when used indoors. The entire AGPS functionality is implemented as an additional plug and play module called "LCS" (LoCation Service) in APOXI. Applications using the AGPS feature can be developed over APOXI using the interfaces provided.

2 Modes of operation

There are three modes/protocols of operations supported currently in APOXI. they are listed in the following:

  • 3GPP
  • GLTP
  • Stand alone

The implementation of these protocols can be included/excluded by switching on/off compile time flags.

If supported in a release, these protocols can be loaded/unloaded at run time using Lcs Settings (See Section 18.5). But stand alone mode is supported by default if it is a part of the deliverable and can not be loaded/unloaded. LcsProvider selects one of the loaded protocols/modes for position fixes based upon the parameters passed in interface invocations.

3 Interfaces

The interfaces between LCS and MMI application are shown in Figure 1.

Figure 1. Interfaces between LCS and MMI application

I/F 1 is a function based interface and I/F 2 is message based interface.

3.1 Implementation

I/F 1 is a functional interface because this invocation is done by the MMI application and is predictable.

I/F 2 is asynchronous interface because these are the responses received from the network and are unpredictable. Also, in the latter case, MMI may want to wait for user inputs which may in turn block the execution of the thread.

The LcsProvider provides interfaces to the actual LCS functionality.

3.1.1 I/F 1

I/F 1 interfaces provided by Lcs are listed in the following:

  • SelfLocationReq: This interface can be used to perform a self-location. It is possible to instruct LcsProviderto select a particular mode based upon the cost of a position fix in different modes. Also, it is possible to repeat a position fix periodically.
  • TransferLocationReq: This interface can be used to transfer the location information of the MS to an external LCS client via a particular GMLC, if possible. Here also, it is possible to repeat the transfer of location periodically.
  • AbortSelfLocReq: This interface can be used to abort an ongoing self-location request.
  • SendVerificationResult: This interface is used to send the user's verification response for a MT- LR request to the network.

3.1.2 I/F 2

I/F 2 interfaces provided by Lcs are listed in the following:

  • LocationResMsg: This message is sent to the MMI application as a result of a position fix request by it. This message contains position fix details.
  • LocationErrMsg: This error message indicates the occurrence of error if any in a position fix process. This message contains error details.
  • AbortResMsg: This message is sent to the MMI application as a result of an abortion request by it. This message indicates that the abortion of an ongoing position fix is successful.
  • LocationNotifInvokeMsg: This message is sent to the MMI application to indicate that an MT-LR notification has been received from the network.

4 Lcs Implementation Details

4.1 SDL Signal Definition

All the SDL signals needed for Lcs are added to msap_signals_mn.pr file and a tool is used to generate the ms.h file.

4.2 Control Flow

The following diagram (Figure 2) depicts a typical control flow within MMI. The interfaces and the messages exchanged between the various blocks (MN, APC, etc).

Figure 2. AGPS Message Flow in MMI

4.2.1 MN Interface à APC

APC maintains a mapping between the incoming SDL signals and the corresponding processing functions in protocol specific SignalMapTableNode classes. The processing function extracts the parameters from the SDL signal and posts appropriate argument messages to the dispatcher. When a protocol is loaded/unloaded, these tables also get loaded/unloaded.

4.2.2 APC Interface à ASC

The SDL signal processing methods in APC posts appropriate argument messages to the dispatcher. The dispatcher implementation is actually a part of Lcs implementation. The processing method processes the argument message and takes appropriate action.

4.2.3 Lcs Interface à MMI App

The ASC message processing method in Lcs takes out relevant parameters of the argument object (embedded in the received message) and copies to the corresponding message to be sent to the MMI application. So again, a new MMI message is sent to the Lcs application.

4.2.4 MMI App à Lcs and Lcs à APC Interfaces

MMI application invokes the appropriate method of LcsProvider for any Lcs-related functionality. Lcs, in turn, processes the parameters and passes them to the corresponding method of the protocol specific message processor class in APC. When a protocol is loaded/unloaded, this class object also gets l oaded/unloaded.

4.2.5 MN Interfaces ß APC

The processing functions in APC constructs the appropriate SDL signal using the parameters passed and sends it to the SDL environment.

5 Lcs Settings

A settings application is also provided with the Lcs implementation. This application takes care of the following:

  1. Loading/unloading of protocols.
  2. Taking input parameters for a position fix so that user need not enter these details for every position fix. Inputs are different for different protocols.
  3. Software version information: Please note that the use of Lcs settings application implementation is optional and can be overwritten by any customer specific implementation.


MultiMedia Overview

1 Introduction

The Multimedia is an APOXI-AddOn. It contains classes for decoding JPEG, PNG, BMP, WBMP and GIF images. Additionally a multimedia editor is offered where animations and sound objects can be embedded and edited inside a text. Also it is possible to encode JPEG images in a synchronous and asynchronous manner.

2 MultiMediaEditor

The multimedia-editor can be used for displaying and editing texts in combination with bitmaps, animations and sounds. The editor itself does not care about the format when receiving or sending the data (e. g. EMS or MMS), but offers an easy interface to feed the editor-document with the corresponding data and retrieve the modified data.

MultiMediaEditor offers a multi-media-editor with the following features:

  • Suitable for the input-mappers for numbers, phonenumbers, multitap and predictive input like T9
  • Vertical scrolling including an optional position-indicator
  • Overwrite/insert mode
  • Allows embedding a variable number of images, animations, sound-objects and other customized editor-items
  • Support of paragraphs, which may aligned left, centered or right
  • Support of rich-text:
    • Bold, italic, underlined, strikethrough
    • Variable text-color and text-background-color
    • Variable font
  • Read-only mode which allows triggering actions on images, animations and sound-objects

An example for MultiMediaEditor editor is shown in the following figure 1.

Figure 1. MultiMedia Editor

The multimedia-editor uses the multimedia-editor-document for accessing and modifying the data. The multimedia-document can contain a variable number of compound-Items.

2.1 Compound-Items

A compound-Item contains a variable number of Items like characters or bitmaps. APOXI offers the following compound-Items:

  • Text-Compound-Item: Can contain a text of a variable length
  • Date-CompoundI-tem: Contains a dat
  • Time-Compound-Item: Contains a time
  • Ip-Address-Compound-Item: Contains an IP-address

In the multimedia-package of APOXI-Add-Ons the following compound-Items are available:

  • Rich-Text-Compound-Item: Can contain a text of a variable length, where the text can have a font, foreground-color, background-color and a text-attribute (derived from TextCompoundItem).
  • Paragraph-Compound-Item: Represents a text-paragraph, which can have a horizontal alignment (default, left, centered, right) and contains a variable number of compound-Items.
  • General-Compound-Item: Can contain a variable number of items which know their size themselve (e. g. an Image-Item).

The multimedia-document automatically takes care to split and merge the compound-Items when items are inserted or deleted. Hence always a minimum amount of compound-Items is assured.

2.2 Input-Method

The input-method can be any Input-Mapper offered by APOXI (e. g. MultiTab or Predictive) or an individual Input- Mapper.

2.3 Wrapping

Every compound-Item itself takes care for the wrapping. Different wrapping-modes are supported.


OBEX Overview

1 Introduction

OBEX stands for OBject EXchange protocol. It runs on top of Bluetooth, IrDA, USB and/or IP protocol. It is a protocol for exchanging objects which was initially designed by the Infrared Data Association, but has been adopted by Bluetooth and can also be used with USB, RS232 and WAP.

2 Overview

OBEX is a standardized way of exchanging data with other mobile or desktop computing devices across platform boundaries. OBEX-aware applications like phonebooks or organizers can either exchange industry-standard object formats like vCard or vCal which are characterized by their mime type or directly connect to a special application service offered by the server device under a target address.

Higher-level protocols such as SyncML can use OBEX as a platform-independent transport layer while OBEX itself can be run over various transport protocols such as Bluetooth, IrDA, USB and IP.

The position of OBEX within APOXI is shown in Figure 1.

Figure 1. Position of OBEX within APOXI

The APOXI OBEX extension provides an API which supports reception and transmission of arbitrary data using the OBEX protocol over different transports (e.g. Bluetooth, IrDA, USB) while isolating the different transport stack interfaces from the application layer.

3 Application Interface

Application interfaces are significant for OBEX Client and Server implementers (such as a SyncML-DS client). The application interfaces provided by OBEX are described in this section.

3.1 OBEX Server API

An OBEX server handles incoming requests and issues responses. Each response carries a response code which indicates the result of processing the request. The functionalities provided by OBEX Server is listed in the following:

  • Bind server to mime type, default server may be registered for unknown types
  • Bind server to Target, default server may be registered for unknown target addresses
  • Specify security settings (transport security)
  • Accept connection without authentication
  • Handle ’Connect’, 'Put', 'Get', ’Abort’,SetPath’, and ’Disconnect’ requests
  • Access transport-specific server information

3.2 ObexOppServer

ObexOppServer provides OPP protocol support as a server. By overriding the virtual On<whatever_event_occured> methods an application developer can respond to OPP Push or Pull requests and submit the corresponding responses.

3.3 OBEX Client API

An OBEX client issues requests to a server and handles the resulting responses. The functionalities provided by Obex Client are listed in the following:

  • Open transport connection
  • Establish connection using 'Connect' without authentication
  • Issue 'Put' request
  • Issue 'Get' request
  • Abort pending operation
  • Issue 'SetPath' request
  • Disconnect
  • Close transport connection
  • Access transport-specific client information

3.4 ObexOppClient

ObexOppClient enables application to act as an OPP client, which implies connecting to a remote server, issuing requests and collecting the responses.

3.5 Utility

The OBEX application interface utilities are listed in the following:

  • ObexObject: ObexObject manages an internal shared data object which contains a list of OBEX headers as well as optional flags and a response code.
  • ObexResult: Indicates success or failure of OBEX API functions and operations.
  • ObexBuffer: Provides exclusive access to a data buffer.
  • ObexHeader: Represents an OBEX header which consist of a Header identifier and the associated header data.
  • ObexHeaderList: List of OBEX headers

4 Transport Interface

The transport interface provided by OBEX is described in this section.

4.1 ObexLayer

ObexLayer is the Interface for direct access to the OBEX layer. Every transport adapter must provide an implementation of this interface.

4.2 ObexAbstractTransport

ObexAbstractTransport is the abstract interface for OBEX transports. This interface must be implemented for every transport protocol like Bluetooth, IrDA, etc. This interface provides access to the stack-specific OBEX implementation (and possibly to other profiles when supported by the stack) and abstracts transport stack and underlying hardware.

4.3 ObexProtocol

ObexProtocol is the interface base class for protocol layer access and handles the transport-centric aspects of them.

4.4 AbstractTransport

AbstractTransport is the abstract representation of communication hardware. This interface must be implemented for every transport subsystem like Bluetooth, IrDA, etc.

4.5 Low-level transport interface

The low-level transport interface is used to glue the transport protocol stacks to APOXI OBEX. Therefore the transport must be able to issue and handle all standard OBEX operations (Connect, Put, Get, SetPath, Abort, Disconnect) and to assemble and serialize all four OBEX header formats. Low-level Transport Interface is shown in Figure 2.

Figure 2. Low-level Transport Interface

Both client- and server applications must register with the transport. Servers must remain registered as long as they are listening for incoming connection requests. Clients only need to be registered for the lifetime of a connection.


Supplementary Services Architecture

Supplementary Services

1 Overview

This part of the documentation deals with the API for Call Independent Supplementary Services. These are Call Forwarding, Call Waiting, Call Barring, CLIP, CLIR, COLP, COLR and USSD. The Supplementary Service API makes use of the handler/dispatcher concept, that is widely known also in other parts of APOXI.
For each Supplementary Service there is one handler, that provides the interface necessary for working with the service. All Supplementary Service requests sent by the MMI are done via the Supplementary Service handlers. Operations allowed on a Supplementary Service is always a subset of the following:

  • Registration
  • Activation
  • Deactivation
  • Erasure
  • Status Request (Interrogation)
For Call Barring also change of the call barring net password is supported. For USSD these operations don't apply, the USSD Handlers provide only an interface for sending MO USSD requests and answering to MT USSD reqeusts.

Each request sent by a Supplementary Service handler causes a response from the GSM stack and/or network in form of stack signals. The stack signal content for Supplementary Services is wrapped into FromStackMsgs and StackMsgArgs by the APC layer. These messages are received by the SupplementaryServiceDispatcher. The dispatcher then analyses the content of the messages with help of the handler that was used to send the intial request. A corresponding message is then sent to the MMI. This way, all logic regarding a certain Supplementary Service is grouped in the handler.

Figure 1: Overview of central classes for Supplementary Service handling

2 Performing a request

The actual sending of any request is initiated by one of the special handlers (like the CallForwardingHandler). Based on the specific method call and the parameters of that method, the handler will generate a specific Supplementary Service control sequence. The control sequence is then passed to the SsMainHandler which sends it to the GSM stack. By sending an request to the GSM stack an Supplementary Service transaction is started. The transaction is now in a setup state. Until this transaction is completed or aborted no other Supplementary Service transaction can be started. The handler is responsible for storing all information (e.g. parameters) of the request that is needed for the further processing of the request.

Figure 2: Control flow for a simple Call Forwarding interrogation

After the request was processed by the GSM stack and/or network, a signal with the result for the request is sent to APOXI by the GSM Stack. This signal is picked up in the APC layer by the CommonSignalProcessor. The following methods are responsible for processing the signals:

Signal Name | Method
MN_SS_BEGIN_ACC | PostSsBeginAcc()
MN_SS_FACILITY_REJ | PostSsFacilityRej()
MN_SS_FORWARDING_IND | PostSsForwardingInd()
MN_SS_BARRING_IND | PostSsBarringInd
MN_SS_DATA_IND | PostSsDataInd()
MN_SS_NOTIFYSS_IND | PostSsNotifyInd()
MN_SS_INTERROGATE_IND | PostSsInterrogateInd()
MN_SS_PASSWORD_IND | PostSsPasswordInd()
MN_SS_UNSTRUCT_IND | PostSsUnstructInd()
MN_SS_FORWCHECK_IND | PostSsForwcheckInd()
MN_SS_RET_RES_IND | PostSsRetResInd()
MN_SS_END_IND | PostSsEndInd()
MN_SS_REJ | PostSsRej()
MN_SS_ERR_IND | PostSsErrInd()
MN_SS_GET_PASSWORD_IND | PostSsGetPasswordInd()
MN_SS_GET_PASSWORD_REJ | PostSsGetPasswordRej()
MN_SS_USSD_IND | PostSsUssdInd()
MN_SS_USSD_RESENT_INT | PostSsUssdResentInd()
Table 1: Signal overview

The results received by the GSM stack (contained in the signals) are initially wrapped in a specific StackMsgArg object and then dispatched using the regular Apoxi dispatch mechanism. If the argument is in any way Supplementary Service related it is picked up by the SupplementaryServiceDispatcher. See the argument map of the class for a list of arguments which are actually picked up. The SupplementaryServiceDispatcher then starts to process the argument.

The first signal always is MN_SS_BEGIN_ACC. This signal contains the TiPd of the Supplementary Service transaction which is used as identifier for the transaction. This TiPd is now included in every signal coming from the GSM stack, that belongs to this transaction. All data of the signal is wrapped into an SsBeginAccArg and sent to the SupplementaryServiceDispatcher, which sends an SsRequestAcceptedMsg to the MMI. Also the Supplementary Service transaction is brought from setup into established state. This step connects the handler that has sent the request with the TiPd of the transaction. This is needed for processing further results delivered by the GSM stack.

The second signal coming is the one that contains the actual (interesting) data (in our example MN_SS_INTERROGATE_IND). The CommonSignalProcessor wraps the data of this signal into a SsInterrogateIndArg and sends it to the SupplementaryServiceDispatcher.

The SupplementaryServiceDispatcher first wraps the argument in a SsStackMsgArgument. The purpose of this wrapper class is to cache often needed parameters of the argument like the TiPd or the release-complete flag. Unfortunately it is not possible to define a common super class for a certain set of arguments (like e.g. Supplementary Service arguments) to provide a common interface to access common member variables. Therefore to access e.g. the TiPd of the argument, which in fact is part of every Supplementary Service argument, the argument has to be identified first, then cast into its specific class and the apropriate get-method called. Clearly this process is cumbersome and extremely costly in terms of performance, let alone the duplicate code this would introduce.

After wrapping, the data is passed on the handler that was used for the initial request (here it's CallForwardingHandler). The code for parsing the contents of the argument and creating the result messages, which will be sent to the MMI is located at the specific handler, which was responsible for initiating the request in the first place. So the handlers are responsible for sending the request as well as processing the received results. Furthermore the handler is the only place to sensibly store additional data related to the transaction like the parameters of the initial request, which are needed for the result message as well.

The idea behind the separation of the logic for creating a message for MMI and for sending it is, that the system can be easily extended. All the logic that is special to a Supplementary Service is within the handler class. The whole transaction management is done in SupplementaryServiceDispatcher and SsMainHandler. This way, if a new Supplementary Service has to be added, it is sufficent to write a new handler and connect it to the rest of the system.

Finally the dispatcher checks with the handler if there is any message that needs to be sent. The dispatcher then retrieves the message and sends it on to the MMI using the MessageRouter. Each result signal contains a "release complete" flag, that indicates, if the transaction is over by arrival of the signal. If this flag is set in the result, the transaction is released and all data stored in the SsMainHandler and in the Supplementary Service handler is freed.

3 Supplementary Service notifications

Under some circumstances the GSM network may send notifications to the mobile station. The process for these notify messages is slightly different, since these notifications are not the result of a request sent by a handler, but are triggered by the network. Therefore the whole process of finding an associated handler and getting the argument parsed there is not necessary. The Supplementary ServiceDispatcher itself parses the argument and generates the result message. The message then will be sent to the MMI using the MessageRouter.

4 Call Control By Sim

Call Control by SIM means, that the SIM card is changing an outgoing call, a Supplementary Service or an USSD request into either an outgoing call, a Supplementary Service or an USSD request. The Supplementary Service implementation has to react to these changes. If something is changed to an Supplementary Service or an USSD request, the according handler has to be installed. If a Supplementary Service or an USSD is changed to a call, an started transaction has to be aborted.

When the SIM wants to change a MOC, Supplementary Service or USSD request, the requests sent to the GSM network are intercepted. The GSM stack sends one of the three signals:

  • MN_CALL_CONTROL_SETUP_IND - A call setup, Supplementary Service or USSD request is changed into a call
  • MN_CALL_CONTROL_SS_IND - A call setup, Supplementary Service or USSD request is changed into a Supplementary Service request
  • MN_CALL_CONTROL_USSD_IND - A call setup, Supplementary Service or USSD request is changed into a USSD request
The Call Control by SIM signal indicates, that the sent request was modified and sent to the GSM network. The signal contains the new request. This request must not be sent by APOXI, the signal is merely an information that Call Control by SIM occured.

Figure 3: Control flow for Call Control By Sim

If a Call Control by SIM signal arrives and a Supplementary Service or an USSD request are changed either to a Supplementary Service or an USSD request, the currently active handler (which was used to send the request in the first place) has to be exchanged by another one, which is appropriate for the changed request. How the changed request looks like can be seen from the data contained in the signal. The SsMainHandler releases all data of the active handler. Then the request is parsed using the InputAnalyzer resp. InputAction. These classes are also used by the MMI to parse user input. The parsing process delivers an instance of a subclass of InputAction (in the upper example its SsCallForwardingActionImpl). The Execute() method then calls the appropriate handler. From this point on, the request is handled the same way as if the changed request would have been sent in the first place. The control flow would now continue with an MN_SS_BEGIN_ACC signal.

5 Some words about Supplementary Service strings

This section should give you a little bit information about the requests - and the request strings. This section is not thought to exhaust the matter of Supplementary Service strings totally, but should merely give an free narrated overview of Supplementary Service strings and the problems encountered. Furthermore it is assumed that the reader has a basic knowledge about Supplementary Service strings. He ought to know how they look like and what their general meaning is.

The greatest challenge is to decide if an entered Supplementary Service string is a "normal" Supplementary Service or an USSD. 3GPP 22.030 can give you a good idea about that, nevertheless there is (or seems to be) room for interpretation. Most important is, that the GSM stack and the APOXI Supplementary Service implementation have the same ideas about what's a Supplementary Service and what's an USSD. If not, it may happen, that the GSM stack is sending a request as USSD which was meant to be a Supplementary Service in APOXI and the wrong handler gets activated. The handler than is not able to deal with the upcoming signals and has to throw an error.

First thing is, that there is no distinction between correct Supplementary Service string, wrong Supplementary String and USSD string. A request string is either a (correct) Supplementary Service string or an USSD string. When sending the request to the network, somewhere there is a bit that tells the network, if the string is for a "normal" Supplementary Service or5 an USSD.

The general decision that now has been taken is, that everything that forms a correct Supplementary Service string is sent as Supplementary Service, the rest is USSD. The following criterias have to be met to make as string a correct Supplementary Service string:

  • defined Supplementary Service code (see 3GPP TS 22.030)
  • correct number of parameters, but needed parameters may be missing
  • correct operation code (*, **, #, ## or *#)

To explain this some examples may come handy:

Supp. Service. | USSD | Description
*#21# | #*21# | Wrong operation code
*21*0123456*10# | *21*0123455*10*17# | Too much parameters
*21# |  | Parameters missing, doesn't matter
*21**# | *21***# | Too much parameters
*61***# | *61****# | Too much parameters
 | *999# | Undefined Service code
Table 2: Supplementary Service string examples

6 Known Issues

Facility Reject:
There are multiple occasions when the GSM stack can issue a FACILITY_REJ signal. Either to reject the initiation of a transaction or to reject an already accepted transaction. Unfortunately the FACILITY_REJ signal does not carry any transaction related data (like the TiPd) at all. In the case of two or more active transaction or an active transaction while another one is currently being initiated it is not possible to deduce which transaction the signal relates to.


Services Overview

1 Introduction

A service in APOXI is used by applications to provide functionality to other applications. This avoids dependencies between applications. In software engineering terms this is called loose coupling. Services initiate actions in other applications.

2 Service Broker

Every service has a Global Unique ID. So there must be one instance which oversees all available services within APOXI. This instance is the Service Broker. It knows about all services, and applications can query it for specific services. There are some analogies in this concept, when comparing it to other well-known object management models such as CORBA or Microsoft's COM.

Each service needs to register to the service Broker inorder to be available for other applications. The calling application has to make sure that the requested service is available before executing a service-call. However an available service can be temporarly inaccesible to the user.

3 Service Concept

The following example illustrates the service concept:

  1. A WAP Browser shows a page with a mail to link
  2. The user clicks on it
  3. The WAP application asks the Service Broker whether there is a SendMail service available
  4. If available, invoking the service results in opening a "Send Mail" Window

The WAP application in this example does not know which object has implemented the SendMail service. The Service Broker hides this information. The WAP application just knows about the interface the service is offering. To be independent from the service mplementation, the WAP application should not have knowledge about the specific service-implementing class (object) at compile-time.

Services are mainly used to exchange data or invoke actions at a foreign application without the need of returning a result.

Asynchronous execution is realized by internally forwarding the service-call by a post-message to the service implementing the application itself.

It is recommended to implement the service interface utilizing the facade-design pattern. The facade pattern provides a simple unified interface and the lower level implementation is Application depended and hidden to the user. E.g. the SMS and EMS service implementations use the same common service interface.

4 Implementing a Service

All the MMI services available in the system are defined in the file MmiServices. Each service has a system wide unique ID. All the service IDs are defined in the MmiServices file.


Sockets Overview

1 Introduction

APOXI Socket classes provide a generic interface to IP based protocols. The interfaces are based on the BSD Socket interface. The Socket module is an add-on APOXI module and can be added on demand.

2 System Architecture

With the help from APOXI Socket module, programmers can develop their own applications independent of the native TCP/IP protocol stack and use the common C++ coding style of APOXI. The TCP/IP protocol stack supported now is WINDOWS socket under the host simulator environment and lwIP on the target. APOXI Sockets provide easy to use C++ interfaces and they are easily portable to other systems.
APOXI Sockets will care for proper data connections such as:

  • CSD (Circuit Switched Data - GSM)
  • PSD (Package Switched Data - GPRS)
  • Serial (e.g. from mobile phone to PC via the serial interface)

APOXI Sockets do not implement UDP or TCP protocols themselves. They are utilizing an existing IP stack system with a BSD style socket interface. On top of this BSD style socket interface, APOXI Socket cares for correct connection handling and interaction with the rest of the system. The native BSD style socket interface is abstracted by class SysSocket, the native DNS resolution is abstracted by class SysDnsClient. Current implementations for SysSocket and SysDnsClient exist for Winsocks (Windows host simulation) and lwIP. Any other BSD style socket interface can easily be interfaced to by providing dedicated implementations of class SysSocket and
SysDnsClient.

The position of Sockets in APOXI is given in Figure 1.

Figure 1. Position of Socket module in APOXI

Currently, APOXI is using different implementations for UDP/IP and TCP/IP protocols as shown in Figure 2.

Figure 2. APOXI Sockets

3 Sockets

Most important classes of APOXI Sockets are InetSocket and its derived classes UdpSocket, TcpSocket, and TcpServerSocket. These classes expose the main interfaces to open the socket, send and receive data, and close the socket.

APOXI Sockets can be configured to work in non-blocking mode (default) and in blocking mode (deprecated). The socket class library available in APOXI is shown in Figure 3.

Figure 3. Class diagram of Sockets

  • InetSocket: InetSocket is the base class of other socket classes. InetSocket and its sub-classes are the main interfaces towards applications.
  • UdpSocket: Class UdpSocket is designed for UDP/IP. This is the client UDP socket base class and the programmer has to derive an own Socket class and overwrite OnAsyncEvent() for reading from/writing to the Socket.
  • TcpSocket: Class TcpSocket is designed for TCP/IP. This is the client TCP socket base class and the programmer has to derive an own Socket class and overwrite OnAsyncEvent() for reading from/writing to the Socket.
  • TcpServerSocket: Class TcpServerSocket is the client server socket base class. The programmer has to derive an own class and overwrite OnAsyncEvent() for accepting an incoming connection request, which is passed via a TcpSocket.

4 Data Connection

The notion of a data connection is one of the fundaments of APOXI Sockets. It defines a bearer for a socket, i.e. for an IP-connection over CSD, PSD, or Serial. The attributes of a data connection are defined in DataConnProfile and its derived classes. All the data connections are controlled by the DataConnManager.

A data connection uses two timers, an idle and a linger timer:

  • If sockets are attached to the data connection but no socket is transferring data for the amount of time specified by the idle timer then the data connection will close down automatically.
  • When the last socket detaches from the data connection then the data connection will not close down immediately. It will only close down after the amount of time specified by the linger timer has elapsed. When a socket tries to attach during linger state the data connection is still open and attaching is possible without any delay.

5 Data Connection Manager

The data connection manager is used to manage different data connections that may exist in the system. It allows to register, unregister, and access the currently available data connections.

6 Data Connection Profile, Data Connection Profile Manager, and Data Connection Profile Storage

DataConnProfile is the base class of data connection bearer settings. The data connection profiles are controlled by the DataConnProfileManager. The data connection profile manager stores persistent profiles using a DataConnProfileStorage. It also controls temporary profiles which are not stored.

DataConnProfileStorage defines an interface to a storage for DataConnProfile objects. It is used by DataConnProfileManager to store and retrieve DataConnProfile settings. Where to store the connection profile is up to the user of APOXI Sockets. DataConnProfileStorage functionality will be used exclusively by the DataConnProfileManager. In order to avoid dependencies on specifics of storing the profiles, APOXI does not provide an implementation of profile storage.

7 Connection Management - Control Flow

When an application opens a socket, the DataConnManager will care to setup the proper data connection according to the DataConnProfile that is referenced by the socket. If a socket is not referencing a specific DataConnProfile the DataConnManager uses the default DataConnProfile.

If a socket operation requires to open a data connection, the socket will internally request from DataConnManager to setup the data connection. If an appropriate connection already exists it will be shared. If not, DataConnManager sets up the connection according to the settings defined in the data connection profile.

A data connection can be shared between multiple sockets and applications. If a socket is opened and a data connection is already established for the same connection profile, the socket will use the existing data connection. When the last socket using the data connection has been closed, the data connection will be shut down automatically.

If a connection request conflicts with existing data connection, voice calls, or other system resources, the application will get an appropriate error code.

8 Data Transfer - Data Flow

When data is available for reading or the underlying system is able to send data, the OnAsyncEvent() method of the socket is invoked with the according event type. For this the RTOS task represented by class SocketRxThread is waiting on a BSD select for all existing sockets. If a socket event occurs, SocketRxThread will wake up and send a SocketControlMsg to the application that owns the socket. SocketHandler, a mandatory member of each application that wants to use APOXI Socket interfaces, will listen for the SocketControlMsg and call the OnAsyncEvent() method of the corresponding socket. Send or connect requests invoke directly the according SysSocket methods.


SyncML Overview

1 Introduction

A SyncML (Synchronization Markup Language) application has the task to synchronize databases on the mobile device with servers based on the SyncML protocol. To be part of APOXI, the SyncML application implementation has to rely on several interfaces, in particular, interfaces to the mobile device and interfaces to the databases.

There are components which are integrated into the APOXI framework and allow SyncML applications to work in APOXI, and there are class header definitions which must be implemented for database applications to provide access to the database for synchronization purposes.

2 Architecture

The following figure (Figure 1) depicts the software architecture of a SyncML client application which runs on the mobile device and is integrated into APOXI. As one can see, the SyncML application interacts with several components and the user. The user interacts with the SyncML application through a user interface. The user initiates synchronization processes for synchronizing a database with a remote server. The user also interacts with the database applications and makes changes in the databases.

Figure 1. SyncML Architecture

SyncML application does the synchronization, i.e., it reads device and database properties, reads and writes data from the data bases, builds and interprets the SyncML messages and interacts with the transport layer to receive and transmits SyncML messages. It accesses the databases exclusively through DBService interface components.

2.1 SyncMLManager

The SyncMLManager component is a singleton which is integrated as a fixed part into the APOXI framework . The SyncMLManager serves the following purposes:

  • Registration of the SyncMLApplication: The SyncMLManager has a method RegisterSyncMLApplication to allow the SyncML application to be registered when deployed on the device.
  • Registration of DBService components: The SyncMLManager is the component where all the DBServicecomponents of all synchronizable databases have to be registered and can be retrieved. Method RegisterDataStore() allows registering databases, GetServiceGuid() and GetDBServiceFromURI() allows getting the Guid and the pointer to the DBService component, respectively. The method GetNumOfDataStores() returns the number of data stores currently registered at the SyncMLManager, with GetRegisteredDataStore the URI and Guid of a specific data store can be queried.
  • Posting DBItemChangedMsg messages: Method PostItemChangedMsg() allows database applications to post messages - DBItemChangedMgs - when items in the database have changed.
  • Providing device information: The SyncMLManager has a method GetDeviceInfo() to retrieve device specific information which is needed according to the SyncML specification.

2.2 APOXI MessageRouter

The APOXI MessageRouter routes DBItemChangedMgs posted by the database applications through the SyncMLManager to the SyncML application. The SyncML application then can maintain the change log required for sychronization.

2.3 DBService

The DBService interface is the interface for the SyncML application for accessing databases. Any database which should be synchronized by the SyncMLApplication has to provide its own DBService component. DBService is a specialization of the APOXI Service class. Therefore DBServices are part of the Service framework and register with the APOXI service broker.


Themes Overview

1 Introduction

A Theme is a container for view-objects. Look of each component is defined by an instance of a view-object. For each component type (e.g. PushButton) there is a corresponding view type (e.g. PushButtonView). The look of a component changes automatically when changing the theme and this changing of theme can be done during runtime.

2 Theme-configuration

APOXI allows having a variable number of themes, which define the look of the used components like windows, push-buttons, softkeybars etc. Per default APOXI offers the themes Default Theme and Foggy Theme, which are located in APOXI/GlobalThemes. To use a theme, it must be embedded into the implementation of the class ThemeConfig, which specifies the theme-configuration.

Figure 1. APOXI Themes

Every Theme derives from AbstractTheme and if derived from implemented Theme, not all views have to be re-implemented. This is shown in the following figure.

3 Creating a New Theme

When creating a new theme, the following steps are necessary:

  • A class derived from Theme (e. g. MyTheme), must be implemented. The implementations for Default Theme and Foggy Theme of APOXI may be a reference.
  • This class MyTheme must be referenced by implementing the methods ThemeConfig::GetTheme and ThemeConfig::GetThemeCount.

4 Implementing a View

All components of APOXI delegate the drawing to their view-object. All instances of a component may share one instance of a view. For example one instance of the pushbutton-view is owned by the Default Theme and all instances of a pushbutton will use this instance for drawing themselves as shown in the following figure.

Figure 2. Implementing a View

The class Theme offers an abstract method GetPushButtonView(), which must return a pointer to an instance of the class PushButtonView.


USB Overview

1 Introduction

USB stands for Universal Serial Bus. It is used as a possible transport protocol by OBEX, which is a standard protocol used to exchange objects consisting of headers and data between a client and a server. It follows a request-response mechanism. In APOXI, Obex uses Bluetooth, IrDA and USB as the possible transport protocols. Tthe USB OBEX transport layer is the glue between the APOXI OBEX module and the Emsys Obex software.

2 Overview

The USB Obex layer in APOXI acts as the transport protocol and provides an abstraction over the Emsys Obex implementation.

ApoxiObex module allows applications to perform client-server communication as per the OBEX standard for the available transport protocols.

UsbObex provides the UsbObex transport implementation for the ApoxiObex module. The implementation of this module lies in /Apoxi/AddOns/Usb/Obex folder. UsbObex feature can be enabled or disabled using the compiler flag 'USB_OBEX'.

UsbTransport is independent of the UsbObex implementation. It provides the USB device specific information to its subscribers.

EmsysObex module provides the protocol implementation of OBEX over USB.

UsbApplication is a Mmi application which displays USB device connection information.

ObexAwareApp is any application that uses ApoxiObex for Obex functionality.

ObexApp is a Mmi application for the user to select one of the available transports, viz., Bluetooth, IrDA, USB.


Voice Recognition Overview

1 Introduction

APOXI Voice Recognition (VR) module provides an object oriented interface for APOXI applications and APOXI core modules to use Voice Recognition.

2 Overview

With APOXI VR, applications can start voice recognition for commands they need and train speaker dependent commands. APOXI VR is also used for managing the commands.

An overview of the VR system is given in the following dependency diagram (Figure 1).

Figure 1. VR Dependency Diagram

APOXI VR and the VR Host Task communication is done by using a function call from APOXI VR to VR. A callback registered by APOXI VR with VR which is called by VR whenever it wants to send data to APOXI VR.

APOXI VR is also responsible for allocating and freeing the audio device used for recording speech. This has to be done in APOXI VR because the APOXI audio priority mechanisms must not be disturbed by VR Host and VR Engine.

For storing the templates used by the VR Engine for recognition, APOXI VR makes use of the Root File System. By using the RFS, the storing of template data can be done using various medias like FFS, Memory Cards, etc.

3 Features of Voice Recognition

APOXI VR provides:Accessibility for APOXI modules and APOXI-based applications

  • Mechanism to start a voice recognition process
  • Mechanism to train speaker-dependent voice tags for commands/name dialing
  • Mechanism to create speaker independent voice tags based on ASCII-strings. This is provided only if the G2A feature is provided by the VR Engine
  • Mechanism to playback trained commands
  • Mechanism to manage templates (voice tags)

3.1 VR Templates

A VR template represents a voice tag for a command (e.g. name for dialing a phonebook entry, menu item, etc.). For each recognition process, the VR engine is fed with a set of VR templates to tell the engine, what it should listen for. Depending on the used recognition mode, one or more of the VR templates will be recognized.

There are three types of templates:

  1. System wide fixed templates: These VR templates can be used by every application
  2. VR Templates which are created by the applications and are stored to a file system Applications can list, create, and delete their own VR templates but cannot delete system wide fixed templates or templates of other applications. Applications can also playback speaker-dependent templates.

3.2 Start voice recognition

An application can start voice recognition with a set of templates, of which one or more shall be recognized. The application will be informed which of the templates has been recognized. If necessary it is possible to abort voice recognition when conflicts with other functions occur (e.g. an incoming call overrides voice recognition).

3.3 Train speaker dependent templates

An application can do training for a speaker-dependent command (e.g. name-dialing). The recorded template is stored in the system and can be used by the application until it decides to discard the template. If necessary it is possible to abort training when conflicts with other tasks occur (e.g. an incoming call overrides training).

3.4 Create speaker independent templates

A speaker-independent template based on an ASCII-string can be created by an application if G2A is provided by the VR Engine. The template is stored in the system and can be used by the application until it decides to discard the template.

4 Class architecture

The main class for APOXI VR are VrHandler. These class handle the communication between MMI and APOXI VR as well as between APOXI VR and VR Host Task.

The other important classes in APOXI VR are message classes, which are used to transport information from the VR Engine to MMI.


Start-Up Concept

APOXI Start-Up Concept

1 Introduction

Because of the growing size of the file MainStartup.cpp a new start-up concept is introduced, to start Applications embedded in AppContainers in a more comfortable and automated manner. With APOXI-1.10 there is a simple way to define a list of Applications which are started automatically by the system.

2 Overview

To start APOXI the protocol stack (PMI process) is calling the function Apoxi_startup which analyses the start-up cause and calls StartUp::Start. Here all the initialization and start of APOXI modules is triggered. In cooperation with the new project configuration file StartUpConfig also a start-up table is parsed to attach all Applications to the desired AppContainers and run them (start the threads).

Also it is possible to add some additional start-up code into the start process by implementing special methods in StartUpConfig. This allows to do some additional initialization in the very early start phase without changing APOXI code.

3 Architecture

The involved classes for starting APOXI are:

  • StartUp in Apoxi/Devices
  • StartUpConfig in Project/Config
  • AppContainer in Kernel
  • Application in Kernel

3.1 StartUp Device

In StartUp::Start the start-up sequence is implemented as following:

  1. Call of StartUpConfig::PreInitialization.
    This is the first place where the customer can add some additional start-up code. Because of no static object are initialized only C-Code can be called!
  2. Initialization of all static objects.
  3. Start of SubSystems with BootSequenceState ‘c_run_level_1’
  4. Initialization of all static Apoxi Devices.
    Currently these are: Keyboard, RealTimeClock, Audio, Charger, Led
  5. Initialization of the communication interface to the protocol stack (Apc/SignalHandler).
  6. Call of System::Init;
  7. Start of SubSystems with BootSequenceState c_run_level_3
  8. Call of StartUpConfig::Initialization.
    Another place where the customer can add some start-up code. Now also C++ Code can be executed and static objects can be used.
  9. Parsing the start-up table.
    Every Application is attached to the desired AppContainer (this also invokes the call of Application::OnStartup) and then all AppContainers are started.

3.2 StartUpConfig

The following methods have to be implemented similar to the example:

void StartUpConfig::PreInitialization()
{
    StartUp::Data startup_data = StartUp::GetStartupData();

    if (startup_data.IsCause(StartUp::NormalOn)) {
        PowerHandler::PowerUp();
        PowerHandler::StartMobileNetwork();
    }

    IntSramConfig::InitSram();	// initialize internal SRAM
}

void StartUpConfig::Initialization()
{
    ExtractSmsTextPlugin* extractsmstext_plugin =
        ExtractSmsTextPlugin::GetInstance();
    extractsmstext_plugin->Init(SmsApp::GetInstance());
    extractsmstext_plugin->Attach();

    NvRamStorage::SetNvRamStorageInfo(c_nv_ram_block_info);
}

AppContainer* StartUpConfig::GetAppContainerArray()
{
    static AppContainer app_cont[3];
    return app_cont;
}

INT StartUpConfig::GetAppContainerCount()
{
    return 3;
}

StartUp::Table* StartUpConfig::GetStartupTable(const StartUp::Data &startup_data)
{
    static StartUp::Table normal_on_table[] = {
        //  enabled, Application*, AppContainer ID, stacksize
        {TRUE, StartupShutdownApp::GetInstance(),   0, 0},
        {TRUE, MainApp::GetInstance(),              0, 0},
        {TRUE, CallHandlingApp::GetInstance(),      0, 0},
        {TRUE, BasicPbApp::GetInstance(),           0, 0},
        {TRUE, SmsApp::GetInstance(),               0, 0},
        {TRUE, StkApp::GetInstance(),               0, 0},
        {TRUE, SimLockApp::GetInstance(),           1, 0},
        {TRUE, CbsApp::GetInstance(),               1, 0},
        {TRUE, CallRecordsManager::GetInstance(),   1, 0},
        {TRUE, MmiChargingApp::GetInstance(),       2, 0},
        {FALSE, 0, 0, 0}        // mandatory last entry;
    };

    static StartUp::Table charger_on_table[] = {
        {TRUE, MmiChargingApp::GetInstance(),       2, 0},
        {FALSE, 0, 0, 0}        // mandatory last entry;
    };

    if (startup_data.IsCause(StartUp::NormalOn))
        return normal_on_table;
    else if (startup_data.IsCause(StartUp::ChargerOn))
        return charger_on_table;
    else
        return 0;
}

3.3 AppContainer

The first starting AppContainer also starts the SubSystems with BootSequenceState ‘c_run_level_5’. This allows SubSystems to start in the context of an AppContainer.

3.4 Application

The first Application which runs its OnOpen method starts the SubSystems with BootSequenceState c_run_level_7. This allows SubSystems to start in the context of an Application.


Shutdown Procedure

APOXI Shutdown Procedure

A shut-down of the phone can be triggered by calling System::ShutDown(BOOLEAN force = FALSE). When using the standard value FALSE for parameter 'force' the system asks all applications if a shut-down is allowed at the moment. By default this is allowed by all applications. In special situations like during a download or while encoding some data an application can prevent a shut-down by calling Application::SetShutdownAllowed(TRUE). From now on the system sends an ShutdownRequesetMsg to that application and so method Application::OnShutdownRequest() is called. Its default implementation is to return FALSE (the state of 'IsShutDownAllowned') and so no shut-down is taking place until SetShutdownAllowed(FALSE) is called.

By overwriting the virtual method Application::OnShutdownRequest() in the derived application class it is also possible change than default behavior. For example the application can open a modal dialog to ask the user if he phone should shut down at the moment or not. The return value decides if the shut-down will be triggered again (TRUE) or is really canceled (FALSE).

If all applications are allowing the shut-down the system sends an AppCloseMsg to all applications which automatically triggers the call of Application::OnClose(). Here all clean-up work should be done and as last statement there must be a call of Application::OnClose() to do all system internal work for closing the application. This is mainly removing the application out of the application container. If all applications inside an application container are closed the application container - which is a thread - terminates.

In the context of the last application which closes all SubSystems with c_run_level_7 are shut down. In the context of the last application container which terminates all SubSystems with c_run_level_7 are shut down.

When the system starts to close all applications a timer is started. With the compiler define APOXI_SHUTDOWN_APP_CLOSE_TIMEOUT (which is set to 20 seconds by default) the customer can define a maximum time period for shutting down. If the timer expires before all applications are closed the system will wait no longer for the following final shut-down work:

  • Shut-down of all SubSystems with c_run_level_3
  • Shut-down of all SubSystems with c_run_level_1
  • call of RealTimeClock::SetSleepMode()
  • call of PowerHandler::PowerDown(). This finally powers off the phone.


Message Routing

APOXI Message Routing

1 Introduction

In APOXI messages are treated by any instance of the class Dispatcher. Typical dispatchers are the classes Application and Control.

2 Application

When an application gets a message, the method Application::RouteMessage is invoked, which treats the message the following way:

Step 1:
The message is forwarded to the method Application::OnMessage, which may be overwritten to dispatch the message. Usually TRUE is returned, if the message has been dispatched and should not be routed anymore.

Step 2:
The message is forwarded to each embedded UserDispatcher until one dispatcher returns TRUE or no dispatcher is left anymore. A UserDispatcher may be embedded into the application by Application::AddDispatcher.

Step 3:
The routing of the message depends from the message category:

  • MC_FOCUS: The message is forwarded to the focused Window.
  • MC_CONTROL: The message is forwarded to the Control which should get the message
  • For messages which another category the message is broadcasted to all embedded controls of the application until one control returns TRUE or no control is left anymore.

Step 4:
For all messages where the class Application offers OnXxx-methods (e. g. OnGetFocus) the corresponding OnXxx-method is invoked.

3 Control

When a control gets a message, the method Control::RouteMessage is invoked, which treats the message the following way:

Step 1:
The message is forwarded to the method Control::OnMessage, which may be overwritten to dispatch the message. Usually TRUE is returned, if the message has been dispatched and should not be routed anymore.

Step 2:
The routing of the message depends from the message category:

  • MC_FOCUS: The message is forwarded to the focused child control.
  • MC_CONTROL: The message is forwarded to the child control which should get the message
  • For messages which another category the message is broadcasted to all embedded child controls of the control until one sub control returns TRUE or no sub control is left anymore.

Step 3:
For all messages where the class Control offers OnXxx-methods (e. g. OnGetFocus) the corresponding OnXxx-method is invoked.


Modal - Modeless

Service Threads

Until now every Application had to be placed into an ApplicationContainer in which it was running; the ApplicationContainer themselves are the threads that are handled by the OS scheduler, internally they schedule their Applications cooperativly. Recently several Applications, like multiplayer games need a thread in the background that for example keeps a connection alive or sends messages all the time. Those threads do not need any user interaction, which means most of the heavy (concerning memory and process time) gui interaction, that an Application would offer, is not needed for them. Out of this request the new class ServiceThread has been introduced and with it several other changes where made. Following there is a quick overview about what has changed and what still is handled as before.

ApoxiThread

This new class derives from Thread and provides a method GetContext() which returns the current active context (this method has to be implemented by derived classes). It is a base class to both, AppContainer and ServiceThread, one could see it as a thin layer between Thread and the underlying implementing classes. Calling ApoxiThread::GetContext() on an ApplicationContainer means that the current active Application is returned, calling it on a ServiceThread returns the ServiceThread itself.

ExecutionContext

ExecutionContext is the new base class to ServiceThread and Application. It defines the Context in which an ApoxiThread is running. An ExectuionContext can hold user defined dispatchers, handle messages which are registered for it, and process active waits using conditions. Some of this functionalities were previously implemented by Application others by ApplicationContainer, but as ServiceThread needed all those functionalities they were factorized into this common base class. Some of this methods are not handled by the Application directly, for example receiving a Message, which is done by the ApplicationContainer, therefore those methods are mapped back from Application to ApplicationContainer. The method ExecutionContext::GetCurrentContext() returns the context of the currently running ApoxiThread.

ServiceThread

Like an ApplicationContainer a ServiceThread runs in its own Context, which means it does not need to be put in an ApplicationContainer as Applications have to. As it needs no user interaction, lots of the things that an Application would provide would be heavy overhead. One could see it as a lightweight Application that runs in the background. It implements its own MessageHandling mechanism (the base class ServiceThread uses a MessageQueue, the same mechanism implemented by ApplicationContainer). Examples for ServiceThreads are all those Applications that need to run in the background all the time (like a service in MicrosoftWindows does for example).

ApplicationContainer

The ApplicationContainer holds a list of Applications as in earlier versions of APOXI. Deriving from ApoxiThread it needs to be able to return it's active context, which means returning the current active Application.

Application

An Appliccation is running in an ApplicationContainer (cooperativ scheduling) and is derived from ExecutionContext, which means it is able to handle messages and dispatchers. Some of this functionalities are not handled by the Application itself but mapped back to the ApplicationContainer like receiving a Message or passing it on to other Containers.


Modal - Modeless

How Modal and Modeless Windows work

There are two different possibilities how to open a Window: you can either open it Modal or Modeless. Modal Windows interrupt the Application flow like MessageBoxes or an OpenFileDialog do. The Application needs to wait for them to finish in order to be able to continue execution. Modeless Windows on the other hand just open, but the user is still able to switch between Windows, and proceed working in the Window from where he opened the ModelessWindow for example. Following there is a brief explanation how these Windows are realized within APOXI:

Modal Windows

Modal Windows are opened using the Window::OpenModal(const Rect& rect) method. The Window is implementing an active wait policy, which means that in the OpenModal method a CloseCondition is set for which the Window waits to be set. When the CloseCondition is set, the Window closes.

On the CallStack the call of the OpenModal() method looks like this:

Window::OpenModal(const Rect & {...}) line 369
Window::OnKeyDown(unsigned char 42) line 627 + 13 bytes
Control::HandleMessage(const Message & {...}) line 1848 + 24 bytes
Control::RouteMessage(const Message & {...}) line 1131 + 12 bytes
Application::RouteMessage(const Message & {...}) line 407 + 17 bytes
Dispatcher::SendSelf(const Message & {...}) line 38 + 17 bytes
AppContext::MsgLoop() line 163
AppContext::StartUp() line 122 + 13 bytes
MULTIMEDIATEST! class GenericWorkerTask  GenericWorkerTask::m_generic_worker_task + 1299604 bytes
AppContainer::ThreadFn() line 96 + 8 bytes
Thread::ThreadStartProc(void * 0x029efcd0 app_cont) line 54 + 13 bytes
KERNEL32! 7c57438b()

The method call remains on the CallStack. If another action is now triggered in the opened Window, it looks like the following:

ContextMenu::OnActionExecuted(Action * 0x029c1900) line 184 + 28 bytes
Window::OnMessage(const Message & {...}) line 471 + 25 bytes
ContextMenu::OnMessage(const Message & {...}) line 151
Control::RouteMessage(const Message & {...}) line 1112 + 17 bytes
Dispatcher::SendSelf(const Message & {...}) line 38 + 17 bytes
Action::Execute() line 113 + 21 bytes
Window::OnKeyDown(unsigned char 42) line 627 + 13 bytes
Control::HandleMessage(const Message & {...}) line 1848 + 24 bytes
Control::RouteMessage(const Message & {...}) line 1131 + 12 bytes
Application::RouteMessage(const Message & {...}) line 407 + 17 bytes
Dispatcher::SendSelf(const Message & {...}) line 38 + 17 bytes
AppContext::Wait(const Condition & {...}) line 139
Scheduler::Wait(const Application * 0x02800570 class DemoApp  DemoApp::m_app, const Condition & {...}) line 48 + 17 bytes
AppContainer::Wait(const Condition & {...}) line 64 + 59 bytes
Window::OpenModal(const Rect & {...}) line 377
Window::OnKeyDown(unsigned char 42) line 627 + 13 bytes
Control::HandleMessage(const Message & {...}) line 1848 + 24 bytes
Control::RouteMessage(const Message & {...}) line 1131 + 12 bytes
Application::RouteMessage(const Message & {...}) line 407 + 17 bytes
Dispatcher::SendSelf(const Message & {...}) line 38 + 17 bytes
AppContext::MsgLoop() line 163
AppContext::StartUp() line 122 + 13 bytes
MULTIMEDIATEST! class GenericWorkerTask  GenericWorkerTask::m_generic_worker_task + 1298448 bytes
AppContainer::ThreadFn() line 96 + 8 bytes
Thread::ThreadStartProc(void * 0x029efcd0 app_cont) line 54 + 13 bytes
KERNEL32! 7c574

If the CloseCondition is now set in the OnActionExecuted() method, the Window closes and both methods are removed from the CallStack.

Modeless Windows

Modeless Windows are opened using the Window::OpenModeless(const Rect& rect) method. In opposite to Modal Windows they do not block the rest of the Application until a condition is set, but allow the user to interact with the progam while the Window is opened.

Here's how it looks like on the CallStack:

Window::OpenModeless(const Rect & {...}) line 353
IdleScreenWin::OnActionExecuted(Action * 0x0280444c) line 266 + 26 bytes
Window::OnMessage(const Message & {...}) line 471 + 25 bytes
IdleScreenWin::OnMessage(const Message & {...}) line 137
Control::RouteMessage(const Message & {...}) line 1112 + 17 bytes
Dispatcher::SendSelf(const Message &  {...}) line 38 + 17 bytes
Action::Execute() line 113 + 21 bytes
Window::OnKeyDown(unsigned char 42) line 627 + 13 bytes
IdleScreenWin::OnKeyDown(unsigned char 42) line 169 + 12 bytes
Control::HandleMessage(const Message &  {...}) line 1848 + 24 bytes
Control::RouteMessage(const Message &  {...}) line 1131 + 12 bytes
Application::RouteMessage(const Message & {...}) line 407 + 17 bytes
Dispatcher::SendSelf(const Message &  {...}) line 38 + 17 bytes
AppContext::MsgLoop() line 163
AppContext::StartUp() line 122 + 13 bytes
MULTIMEDIATEST! class GenericWorkerTask  GenericWorkerTask::m_generic_worker_task + 1299604 bytes
AppContainer::ThreadFn() line 96 + 8 bytes
Thread::ThreadStartProc(void * 0x029efcd0 app_cont) line 54 + 13 bytes

Immediately after the call the (right after the Window has opened) the method is removed from the CallStack


1 Introduction

The features of the APOXI-GUI are:

  • Completely written in C++: All characteristics of an object orientated programming language, like polymorphism, inheritance and encapsulation, are used in a strict manner and lead to an easy to use, but powerful framework.
  • Event-based communication: All actions are triggered by events. The communication between the components is done by messages. This proven approach offers strong benefits in comparison to state-machines.
  • Integrated window-system: Support of overlapping and nested windows. Position, size and attributes of windows can be changed dynamically.
  • Controls for menus, radiobuttons, checkboxes, listboxes, editors, ... which can be integrated within windows in an easy manner.
  • Dynamically changeable look and feel: The look and feel of the menus, windows, buttons and other controls can be altered during runtime using the theme manager.
  • Multilingual support: The full integration of Unicode and the language manager facilitates a switch of languages at any time.
  • Image support: Encoders and decoders for a broad range of image formats are available.
  • Hardware independent graphical device interface: All graphical operations are hardware independent, but achieve optimal performance by relying on a hardware specification files represented as Devices.

[ Next: Concepts ]


2 Concepts

The chapter gives an overview about some basic terms and concepts used in the APOXI-GUI-framework.

2.1 Application and Window

Two main parts of the APOXI-GUI-framework are the classes Application and Window. APOXI windows have the same features as windows known from modern operating systems on desktop personal computers:

  • They can change in size and position.
  • They have themeable frames.
  • They can have child windows, as commonly known from multiple document interfaces.

An application may contain a variable number of windows. The drawing of the window and its content is done on a so called device-context. A device-context is implemented by the class DeviceContext and represents an abstract drawing area, with defined colors for pens and brushes, text-attributes and raster-operations.

It's very important to be aware that a window always belongs to one application and may not be accessed in a direct manner from other applications. This is because each application might run in its own thread. As a thumb rule:

Applications may only communicate with each other by posting messages. Direct access to the data of another application is not allowed.
More details regarding how to access windows from other applications are given in Chapter 5: Controls

2.2 Components

Every graphical object is derived from the class Component, which represents a graphical object with a rectangle as boundaries. Every component is able to handle and route messages. There are two groups of components: drawable objects and controls.

2.2.1 Drawable Objects

Drawable objects are represented by the class DrawableObject, which is the base for all graphical objects, which do not interact with the user. The classes ImageBox, ProgressBar and TextBox are examples for drawable objects:

ImageBox | ProgressBar | TextBox
ImageBox | ProgressBar | TextBox

2.2.1 Controls

Controls are represented by the class Control and can have one or more child-components which are layouted inside the control. Messages sent to a control are handled by the parent-control first and then forwarded to potential child-components. Controls can get the focus and hence interact with the user, as all key-messages are forwarded to the focused control. The classes CheckBoxControl, LineEditor and PushButton are examples for controls:

ImageBox | ProgressBar | TextBox
CheckBox | LineEditor | PushButton

[ Previous: Introduction ] [ Next: Sample Application ]


3 Sample Application

The following implementation of a sample application should convey a feeling for APOXI. Detailed descriptions about the used classes are given in later chapters.

3.1 Displaying "Hello World"

In order to write a "Hello world"-application on the mobile phone, a window needs to be created for drawing a text. Here is the header-file for the class MyWindow:

MyWindow.hpp
#include <Gui/Window.hpp>

class MyWindow : public Window {
    protected:
        virtual void OnPaint(const Rect& repaint_rect);
};

The class MyWindow is derived from the class Window and the method OnPaint must be implemented for the purpose of drawing the famous "Hello world". Here is the implementation of the class MyWindow:

MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::OnPaint(const Rect& repaint_rect)
{
    Window::OnPaint(repaint_rect);

    PaintDc pdc(GetDeviceContext());
    pdc.DrawText(5, 10, L"Hello world");
}

First of all OnPaint calls the base-method Window::OnPaint(). All drawing-operations are performed on the device-context. The current device-context is provided by the method Window::GetDeviceContext().

The class PaintDc provides comfortable usage of a standard device-context. A temporary paint device-context can be created by invoking PaintDc pdc(GetDeviceContext()). Next the text "Hello world" is drawn at the position (5, 10) by calling pdc.DrawText(5, 10, L"Hello world").

Those are all the steps required for defining a window, which displays "Hello world". But windows also need to be embedded in a common context, which is provided by an application. So before opening any window, an application must be created:

MyApplication.hpp
#include <Kernel/Application.hpp>
#include "MyWindow.hpp"

class MyApplication : public Application {
    protected:
        virtual void OnOpen();

    private:
        MyWindow m_my_window;
};

The class MyApplication is derived from Application. The member m_my_window is added for embedding the previously defined window within the application. m_my_window is an instance of MyWindow. Here is the implementation of the application:

MyApplication.cpp
#include "MyApplication.hpp"

void MyApplication::OnOpen()
{
    Application::OnOpen();
    m_my_window.Init();
    m_my_window.OpenModeless();
}

First of all the base class method Window::OnOpen() is called. Then the window is initialized by m_my_window.Init() and opened in modeless mode by invoking m_my_window.OpenModeless().

Alternatively it would have been possible to use a pointer to MyWindow and invoke m_my_window = new MyWindow() instead of m_my_window.Init(). The reason for using the method Init instead of dynamical allocation and using the constructors is explained in chapter 10 in detail.

The visual result of the code above does not look spectacular, but fulfils our demands of displaying "Hello world":

3.2 Getting Multilingual

In general, the usage of hardcoded strings should be avoided, as many applications have to be shipped supporting different languages. The next paragraph will point out how APOXI provides an easy way for creating localized applications.

The programmer simply has to pass all texts to the Tr()-method ("Translate") before displaying them. So instead of handing over "Hello world" to Window::DrawText directly:

pdc.DrawText(5, 10, L"Hello world")

the usage should look like this

pdc.DrawText(5, 10, Tr(L"Hello world"))

The translate method performs a fast lookup within a translation table and returns the translated text string. Tr() will return its argument, if no translation table is available. This means that during the development of an application no translation table is required and can be added at later stages.

3.3 Handling Key Events

Instead of displaying "Hello world" MyWindow will be modified to display "No key pressed" After pressing the key "2" the text should change to "Key 2 pressed":

Handling Key Events

MyWindow.hpp
#include <Gui/Window.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual void OnPaint(const Rect& repaint_rect);
        virtual BOOLEAN OnKeyDown(KeyCode key_code);

    private:
        const WCHAR* m_text;
};
MyWindow.cpp
#include "MyWindow.hpp"
#include <Config/KeyboardConfig.hpp>

void MyWindow::Init()
{
    Window::Init();
    SetTitle(Tr(L"Press key 2..."));
    m_text = Tr(L"No key pressed");
}

void MyWindow::OnPaint(const Rect& repaint_rect)
{
    Window::OnPaint(repaint_rect);

    PaintDc pdc(GetDeviceContext());
    pdc.DrawText(5, 10, m_text);
}

BOOLEAN MyWindow::OnKeyDown(KeyCode key_code)
{
    if (key_code == KeyboardConfig::GetNumber(2)) {
        m_text = Tr(L"Key 2 has been pressed");
        Invalidate();
        return TRUE;
    }
    else
        return Window::OnKeyDown(key_code);
}

The method Window::OnKeyDown() is invoked whenever a key has been pressed. MyWindow is extended by the member m_text which is a pointer to a string. This string should be modified when pressing the key "2".

In MyWindow::Init() m_text is initialized with "No key pressed". When the Window is opened MyWindow::OnPaint() is called and "No key pressed" is displayed. Pressing the key "2" invokes a call of MyWindow::OnKeyDown(). The key-code is submitted by the parameter key_code and can be compared with configurated key-codes. The configurated key-codes are defined by the class KeyboardConfig.

When changing data which should be displayed, the window must be invalidated to trigger a paint-event. This can be done by invoking Window::Invalidate(). Window::OnKeyDown() offers a BOOLEAN as return-value, which indicates whether a key has been dispatched. If the key is not treated, the base-method should be called.

3.4 Using a Drawable Object

Invalidating a window because data has been changed is not very comfortable and might lead to an inconistent state between display and data (e. g. when forgetting an invalidation). Drawable objects offer an easy way for encapsuling data which should be displayed.

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/TextLine.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual BOOLEAN OnKeyDown(KeyCode key_code);

    private:
        TextLine m_text_line;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    SetTitle(Tr(L"Press key 2..."));

    m_text_line.Init(this, Tr(L"No key pressed."));
    m_text_line.SetPos(5, 10);
}

BOOLEAN MyWindow::OnKeyDown(KeyCode key_code)
{
    if (key_code == KeyboardConfig::GetNumber(2)) {
        m_text_line.SetText(Tr(L"Key 2 has been pressed!"));
        return TRUE;
    }
    else
        return Window::OnKeyDown(key_code);
}

The drawable object TextLine is able to show a text on a given position. When the text is changed, the window will automatically be invalidated and hence redrawn where necessary. There is no need anymore to overwrite Window::OnPaint(), because every drawable object knows its position and size and is drawn automatically.

3.5 Layouting Components

When more than one component is embedded into a window, the components have to be layouted by assigning them a position and a size. This can be done in Window::Init(), but has the disadvantage that later changes on the size of the window are ignored. Hence APOXI offers another entry-point for doing the layout of components: When opening a window and whenever the size changes, the method Window::OnLayoutClient() will be called. In this method the components can be adjusted inside the client-area.

3.5.1 Layouting by Hand

In the following example the layouting is done by asking the window for its size and adjusting the size and position of the progressbar and a pushbutton.

MyWindow.hpp
#include <ApoxiLib.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual void OnLayoutClient();

    private:
        ProgressBar m_progress_bar;
        PushButton m_push_button;
        CloseWindowAction m_close_win_action;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
     SetTitle(Tr(L"Layouting by hand"));
    m_progress_bar.Init(this, 75);
    m_close_win_action(this, this, Tr(L"Close"));
    m_push_button.Init(this, &m_close_win_action);
}

void MyWindow::OnLayoutClient()
{
    Window::OnLayoutClient();

    m_progress_bar.SetPos(0, 0);
    m_progress_bar.SetSize(GetClientWidth(),
                         m_progress_bar.GetDefaultHeight());

    m_push_button.SetPos(0, GetClientHeight() / 2);
    m_push_button.SetSize(GetClientWidth(),
                        m_push_button.GetDefaultHeight());
}

This implementation is acceptable when having 2 or 3 controls, but when a complex layout with centered and nested controls is needed, this will get way too complicated.

Layouting by Hand

3.5.2 Using a Layouter

APOXI offers the class Layouter for this problem. For having a similar layout as above by using a layouter, the implementation of OnLayoutClient() will look like this:

void MyWindow::OnLayoutClient()
{
    Window::OnLayoutClient();

    Layouter layouter(1, 2, this);
    layouter.Arrange(0, 0, &m_progress_bar);
    layouter.Arrange(0, 1, &m_push_button);
}

The layouter is capable of layouting components and recursively other layouters inside a grid. The number of horizontal and vertical cells inside the grid can be specified in the constructor: The first parameter specifies the number of horizontal cells, the second parameter specifies the number of vertical cells. The layouter must know the available width and height for the grid. This is submitted by passing the Window. Invoking Layouter layouter(1, 2, this) results in a grid with 2 cells.

By layouter.Arrange(0, 0, &m_progress_bar) the progress-bar is arranged in the cell with the index (0, 0) (Note: the index starts at zero). layouter.Arrange(0, 1, &m_push_button) arranges the push-button in the cell with the index (0, 1).

In contrast to the layouting by hand the layouter respects default widths and heights from components and centers each component inside a cell instead of increasing the boundaries to the maximum available size:

Using a Layouter

[ Previous: Concepts ] [ Next: Items ]


4 Items

A lot of GUI controls like menus and lists use items for specifying their content. Before describing the GUI controls in chapter 5: Controls at first it is necessary to explain the concept behind items.

An Item is at least represented by a text and/or an icon...

... and can be disabled (usually shown as greyed text):

The drawing of the item properties (like the text or icon) is not done by the item itself but usually by a GUI-control (e. g. ItemMenu or ItemGrid) as this control knows best how to display the item properties inside the control-boundaries. When creating an item it will be assigned to this control and the item informs the control when an item property like the text has been changed, so that the control can redraw itself to show the changed item properties. The benefit for the application developer is that it is possible to modify the item without the need of taking care which GUI-components must be updated, as this is done automatically.

The following example shows a window which contains an ItemGrid with 3 embedded items:

4.1 AbstractItemContainer and ItemContainer

The class AbstractItemContainer is derived from Item and extends the item by an interface for embedding a variable number of items as part of the item-container. The class ItemContainer offers a default implementation and might be used for building a menu-hierarchy which might be displayed by the controls ItemMenu or ItemTree. Examples for using an item-container are shown in chapter 5: Controls; the following picture shows an ItemTree which opened item 1 represented by an item-container having 5 items:

4.2 Action

The class Action is derived from Item and extends the item with the ability to be executable. In GUI applications many commands can be invoked by e. g. menus, softkeys or push-buttons. Since the same action can be invoked by different GUI-components it is useful to represent a command as an Action to ensure a consistent state of the command and its representation. As an action is derived from the class Item every action has a text, may contain an icon and may be enabled/disabled. The dispatcher provided on initialization will be informed by messages when a property has been changed or the action has been executed.

Example: an action can be assigned to a PushButton and is executed, after the push button has been pressed. The same action also can be assigned to other controls like an ItemMenu or to the softkeys of a Window. Push Button

The following example shows the recommended usage of actions. Note that in this example no GUI controls are added, which contain and trigger the action. Examples for GUI controls which use actions are given in chapter 5: Controls.

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/Action.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        Action m_add_action;
        Action m_delete_action;
        Action m_rename_action;
        Action m_close_action;

        void Add();
        void Delete();
        void Rename();
        void Close();
}
MyWindow.cpp
#include "MyWindow.hpp"
...

void MyWindow::Init()
{
    Base::Init()
    m_add_action.Init(this, Tr(L"Add"), (Action::ExecFn)&MyWindow::Add);
    m_add_action.SetIcon(&confirm_bitmap);
    m_delete_action.Init(this, Tr(L"Delete"), (Action::ExecFn)&MyWindow::Delete);
    m_delete_action.SetIcon(&delete_bitmap);
    m_delete_action.SetEnabled(FALSE);
    m_rename_action.Init(this, Tr(L"Rename"), (Action::ExecFn)&MyWindow::Rename);
    m_close_action.Init(this, Tr(L"Close"), (Action::ExecFn)&MyWindow::Close);
}

void MyWindow::Add()
{
    // add code for adding here
}

void MyWindow::Delete()
{
    // add code for deleting here
}

void MyWindow::Rename()
{
    // add code for renaming here
}

void MyWindow::Close()
{
    // add code for closing here
}

In the implementation of MyWindow::Init() every action gets a pointer to a dispatcher, by providing the method Action::Init() with the this-pointer as first argument (each window is a dispatcher). The second argument specifies the name of the action. The third parameter specifies the member function which should be invoked when the action has been executed.

Alternatively instead of providing a member function it is possible to overwrite the virtual method Action::Execute and implement the behavior there.

The default implementation of Action::Execute informs the dispatcher that the action has been executed by sending the message ActionExecutedMsg. The class Window, which is also a dispatcher, automatically listens to this message and invokes Window::OnActionExecuted(Action* action) which provides a hook to know which action has been executed.

4.3 Rendering Items

It is not necessary for chapter 5: Controls to understand how to specify the rendering of the items, but it may be of interest later when customizing the look of the used menus and lists.

The GUI-controls which have embedded the items are responsible for drawing them. To allow a customizable look, the look is described in an abstract way by so called item renderer properties. Item renderer properties are given by an instance of the class ItemRendererProperties and can be assigned to each AbstractItemContainer and most GUI-controls using items.

Example: the default item renderer properties defined by the class GuiEngineConfig should be used by an ItemGrid:

const ItemRendererProperties* prop = GuiEngineConfig::GetDefaultItemRendererProperties();
m_item_grid.SetRenderer(prop);

The item renderer properties define the used item renderer. The item renderer is an instance of the class AbstractItemRenderer and is used by the item grid (and other controls) to render its items. It is possible to implement customized item renderer properties and customized item renderers, but the DefaultItemRenderer provided by APOXI should be sufficient for most use cases:

The item renderer properties are defined by:

  • Display type:
    • IconAndTextDisplayType: The text is aligned right beside the icon for languages written from left to right. For languages like Arabic the text is aligned left beside the icon.
             Text and icon (L2R) Text and icon (R2L)
    • TextAboveIconDisplayType: The text is aligned above the icon.
             Text above icon
    • TextBelowIconDisplayType: The text is aligned below the icon.
             Text below icon
    • TextOverlapsIconDisplayType: The icon uses the whole area of the item and the text overlaps the icon.
             Text overlaps icon
  • Animation Type: When the text does not fit into the available area, there is the possibility to animate the text by e. g. scrolling to the left.
    • NoAnimation: The text will be clipped if it does not fit into the available area.
    • CycleAnimation: The text will be scrolled to one direction. Shortly before disappearing, the text scrolls in again from the opposite side.
    • BounceAnimation: The text will be scrolled to one direction. Shortly before disappearing, the scroll-direction switches and the text scrolls back to the original position.
  • Scroll Delay:Delay in milliseconds until a scrolling of the text is done.
  • Scroll Gap: Gap in pixels for the textscrolling.
  • Textformat: Textformat of the text.
  • Transparent Flag: If set to TRUE, no background for the item should be drawn per default.
  • Multiline Flag: If set to TRUE, the text is wrapped horizontally and displayed in several lines.
  • Center Vertical Flag: If set to TRUE, the text will be vertically centered. The horizontal text alignment can be defined by setting the text format (see ItemRendererProperties::SetTextFormat).
  • Indicate Item Container Flag: If set to TRUE, an item container is indicated by an arrow on the right side.
  • Background Color: Specifies the background color of the item. Is only used, if the Transparent Flag is FALSE.
  • Height: Height of the item in pixels. If -1 is used, the height of the font specified by the Textformat is used.
  • Gap: Gap in pixels for the item-border (= red border).
    Item gap
  • Column count: Preferred number of columns, if several items are rendered inside a control. If a control may only contain one item, this parameter is ignored.
  • Start delay: Delay in milliseconds until the scrolling of the text is started.
  • Background image: Background image for the item. The transparent property must be set to TRUE to have a visible background image.
  • Text color: Color of the item text.

4.3.1 Implementing a Custom Item Renderer

The DefaultItemRenderer respects all renderer properties defined by ItemRendererProperties. But there is enough room for interpretation of those properties, so that it might be necessary to customize the rendering for extended properties or a different interpretation of existing properties.

4.3.1.1 Changing the Selection Background

As a first step a custom item renderer should be implemented, which draws a gradiented selection. The default item renderer draws a selected item with the color Color::SelectionBackground which is defined by the current APOXI Theme:

Default Selection

The outcome of the new class CustomItemRenderer, which will get derived from the class DefaultItemRenderer, should look like this:

CustomItemRenderer.hpp
#include <Gui/DefaultItemRenderer.hpp>

class CustomItemRenderer : public DefaultItemRenderer {
    typedef DefaultItemRenderer Base;

    public:
        CustomItemRenderer(const ItemRendererProperties* properties = 0);
        virtual ~CustomItemRenderer();
        virtual void DrawBackground(DeviceContext* dc,
                                    const Item& item,
                                    const Rect& bounds,
                                    INT item_style) const;
};
CustomItemRenderer.cpp
#include <Gui/PaintDc.hpp>

CustomItemRenderer::CustomItemRenderer(const ItemRendererProperties* properties) :
    Base(properties)
{
}

CustomItemRenderer::~CustomItemRenderer()
{
}
void CustomItemRenderer::DrawBackground(DeviceContext* dc,
                                        const Item& item,
                                        const Rect& bounds,
                                        INT item_style) const
{
    if (item_style == AbstractItemRenderer::SelectedStyle) {
        PaintDc pdc(dc);
        // Use grey as starting color for the top...
        Color color(200, 200, 200);
        for (XYDIM y = bounds.GetTop(); y <= bounds.GetBottom(); ++y) {
            pdc.SetPenColor(color);
            pdc.DrawLine(bounds.GetLeft(), y, bounds.GetRight(), y);

            // ... and do a gradient to red
            color.SetRed(color.GetRed() - 2);
            color.SetGreen(color.GetGreen() - 5);
            color.SetBlue(color.GetBlue() - 5);
        }
    }
    else {
        Base::DrawBackground(dc, item, bounds, item_style);
    }
}

The custom item renderer is derived from the DefaultItemRenderer and overwrites the method AbstractItemRenderer::DrawBackground. Only if the item style is marked as 'selected', the custom implementation drawing a gradient is used, otherwise the base implementation of the default item renderer is invoked.

The question remains how the used ItemGrid of the screenshots knows whether it should use the default item renderer or the custom item renderer: the item grid has a method SetRenderer() with the following signature:

void AbstractItemGrid::SetRenderer(const ItemRendererProperties* properties = 0);
This means that the properties define the used item renderer. For this the following customizable factory method is offered in the class GuiEngineConfig (the class GuiEngineConfig is located in the config directory of the project):
static AbstractItemRenderer* GuiEngineConfig::ObtainItemRenderer(const ItemRendererProperties* properties = 0);
The default implementation of ObtainItemRenderer looks like this:

AbstractItemRenderer* GuiEngineConfig::ObtainItemRenderer(const ItemRendererProperties* properties)
{
    return new DefaultItemRenderer(properties);
}

This means that the default item renderer is used for any kind of item renderer properties. When changing the implementation the following way, the custom item renderer is used instead:

AbstractItemRenderer* GuiEngineConfig::ObtainItemRenderer(const ItemRendererProperties* properties)
{
    return new CustomItemRenderer(properties);
}

It the custom item renderer should only be used if the item renderer properties have a height smaller than 20 pixels, the following implementation would be suitable:

AbstractItemRenderer* GuiEngineConfig::ObtainItemRenderer(const ItemRendererProperties* properties)
{
    if ((properties != 0) && (properties->GetHeight() < 20) {
        return new CustomItemRenderer(properties);
    }

    return new DefaultItemRenderer(properties);
}

4.3.1.2 Rendering Complex Items

In the MMI often more complex items are used, which contain more properties than the APOXI class Item offers. The following example shows how an item renderer can be customized to display those additional properties.

In the example is assumed that the MMI implements a custom item which extends the class Item by the properties 'optional icon' and 'time' (a use case might be items showing the current time zone, where the 'optional icon' might indicate day/night phases). A possible implementation of such a custom item might look like this:

CustomItem.hpp
#include <Gui/Item.hpp>
#include <Gui/ImageObtainer.hpp>
#include <Auxiliary/Time.hpp>

class CustomItem : public Item {
    typedef Item Base;

    public:
        enum {
            ID = 1000
        };

        CustomItem(Dispatcher* dispatcher,
                   const WString& text,
                   const ImageObtainer& default_icon,
                   const ImageObtainer& optional_icon,
                   const Time& time);
        virtual ~CustomItem();
        void SetOptionalIcon(const ImageObtainer& optional_icon);
        const ImageObtainer& GetOptionalIcon() const { return m_optional_icon; }
        void SetTime(const Time& time);
        const Time& GetTime() const { return m_time; }
        virtual BOOLEAN IsInstanceOf(INT id) const;

    private:
        ImageObtainer m_optional_icon;
        Time m_time;
};
CustomItem.cpp
CustomItem::CustomItem(Dispatcher* dispatcher,
                       const WString& text,
                       const ImageObtainer& default_icon,
                       const ImageObtainer& optional_icon,
                       const Time& time) :
    Base(dispatcher, text, default_icon),
    m_optional_icon(optional_icon),
    m_time(time)
{
}

CustomItem::~CustomItem()
{
}

void CustomItem::SetOptionalIcon(const ImageObtainer& optional_icon)
{
    m_optional_icon = optional_icon;
    NotifyPropertyChange(UnspecifiedPropertyId);
}

void CustomItem::SetTime(const Time& time)
{
    if (m_time != time) {
        m_time = time;
        NotifyPropertyChange(UnspecifiedPropertyId);
    }
}

BOOLEAN CustomItem::IsInstanceOf(INT id) const
{
    if (ID != id) {
        return Base::IsInstanceOf(id);
    }
    return TRUE;
}

The implementation is straight forward, but a note to the methods SetTime and SetOptionalIcon might be useful: invoking the method Item::NotifiyPropertyChange informs the dispatcher that a property has been changed and results in a redrawing of the item. This is very important as the application developer only needs to take care to change the properties of the item itself, he does not need to trigger a redraw of any GUI component itself.

If this custom item is added to an item grid, the item renderer does not draw the additional properties 'optional icon' and 'time'. For this the custom item renderer is extended by the implementation of the method DrawItem (new code is marked in bold):

CustomItemRenderer.hpp
#include <Gui/DefaultItemRenderer.hpp>

class CustomItemRenderer : public DefaultItemRenderer {
    typedef DefaultItemRenderer Base;

    public:
        CustomItemRenderer(const ItemRendererProperties* properties = 0);
        virtual ~CustomItemRenderer();
        virtual void DrawBackground(DeviceContext* dc,
                                    const Item& item,
                                    const Rect& bounds,
                                    INT item_style) const;
        virtual void DrawItem(DeviceContext* dc,
                              const Item& item,
                              const Rect& bounds,
                              INT item_style) const;
};
CustomItemRenderer.cpp
#include <Gui/PaintDc.hpp>

CustomItemRenderer::CustomItemRenderer(const ItemRendererProperties* properties) :
    Base(properties)
{
}

CustomItemRenderer::~CustomItemRenderer()
{
}
void CustomItemRenderer::DrawBackground(DeviceContext* dc,
                                        const Item& item,
                                        const Rect& bounds,
                                        INT item_style) const
{
    if (item_style == AbstractItemRenderer::SelectedStyle) {
        PaintDc pdc(dc);
        // Use grey as starting color for the top...
        Color color(200, 200, 200);
        for (XYDIM y = bounds.GetTop(); y <= bounds.GetBottom(); ++y) {
            pdc.SetPenColor(color);
            pdc.DrawLine(bounds.GetLeft(), y, bounds.GetRight(), y);

            // ... and do a gradient to red
            color.SetRed(color.GetRed() - 2);
            color.SetGreen(color.GetGreen() - 5);
            color.SetBlue(color.GetBlue() - 5);
        }
    }
    else {
        Base::DrawBackground(dc, item, bounds, item_style);
    }
}

void CustomItemRenderer::DrawItem(DeviceContext* dc,
                                  const Item& item,
                                  const Rect& bounds,
                                  INT item_style) const
{
    if (item.IsInstanceOf(CustomItem::ID)) {
        const CustomItem& custom_item = static_cast<const CustomItem&>(item);
        XYDIM x_start = bounds.GetLeft();
        XYDIM x_end = bounds.GetRight();

        PaintDc pdc(dc);

        // draw time property on the right border
        const WString time_text(custom_item.GetTime().GetWString(Time::TimeHM));
        const Font& font = pdc.GetFont();
        x_end -= font.GetTextWidth(time_text, pdc.GetTextAttr());
        pdc.DrawTextBox(Rect(x_end, bounds.GetTop(), bounds.GetRight(),bounds.GetBottom()), time_text);

        // draw optional icon left from the time property
        const ImageObtainer& optional_icon = custom_item.GetOptionalIcon();
        if (optional_icon.GetBitmap() != 0) {
            x_end -= optional_icon.GetWidth();
            pdc.DrawBitmap(x_end,
                           bounds.GetTop() + (bounds.GetHeight() - optional_icon.GetHeight()) / 2,
                           *optional_icon.GetBitmap());
        }

        // draw default icon on the left border
        const ImageObtainer& default_icon = custom_item.GetIcon();
        if (default_icon.GetBitmap() != 0) {
            pdc.DrawBitmap(x_start,
                           bounds.GetTop() + (bounds.GetHeight() - default_icon.GetHeight()) / 2,
                           *default_icon.GetBitmap());
            x_start += default_icon.GetWidth() + 2;
        }

        // draw text in the remaining space
        pdc.DrawTextBox(Rect(x_start, bounds.GetTop(), x_end, bounds.GetBottom()), custom_item.GetText());
    }
    else {
        Base::DrawItem(dc, item, bounds, item_style);
    }
}

The outcome of this implementation will look like this:

The method AbstractItemGrid::DrawItem is responsible for drawing all item properties. By checking whether the item represents a specific instance, it is possible to access the additional interfaces by the following code:

if (item.IsInstanceOf(CustomItem::ID)) {
     const CustomItem& custom_item = static_cast<const CustomItem&>(item);
     ...
}
This approach is useful when having a limited set of extended items or when having very generic items like the PropertyItems provided by ATL. It is in the hand of the customer to decide whether there should be one class of a custom item renderer which is capable of rendering all kind of items or whether there should be separate item renderer classes for each kind of item. A thumb of rule: if inside the drawing methods very much code using the runtime type information by Item::IsInstanceOf is used, it might be better to split up the code into several custom item renderer classes. Chosing the preferred item renderer can be done inside the method GuiEngineConfig::ObtainItemRenderer (some hints: the item renderer property 'renderer hint' is very useful, the item renderer also offers runtime type information by ItemRendererProperties::IsInstanceOf).

4.4 Items as Separators

Each item can act as separator by setting the corresponding property with Item::SetSeparator(BOOLEAN flag). It is in the hand of the control which displays the item how to show this property. Most times items acting as separator are used in ItemGrids or ItemMenus. The DefaultItemRenderer, which is responsible for drawing items of menus, draws separators the following way:

  • Per default the method Item::IsSeparator returns FALSE and an item might look like this:
  • If Item::SetSeparator(TRUE) is invoked for an item having a text and/or and icon, a thin separator is drawn below the text and the icon:
  • If Item::SetSeparator(TRUE) is invoked for an item which does not have a text or an icon, the item will be treated as "pure separator" and cannot be selected inside a menu. Whether a "pure separator" should be used or just a thin separator is in the hand of the application. It is recommended that User Interface Guidelines for the MMI are given which kind of separator should be used:
    .
  • If an item has a text and/or an icon, is disabled by Item::SetEnabled(FALSE) and marked as separator by Item::SetSeparator(TRUE), the item will be shown as "pure separator" having a text and/or icon. This might be useful as a nonselectable label for large menus:

4.5 Marking Items

Especially for menus it is useful that a variable number of items can get marked, so that an action can be applied to all those items. Items can easily marked by invoking Item::SetMarked(TRUE). In the following screenshot the items 1, 7 and 8 are marked, the item 4 is selected:

Marked items [ Previous: Sample Application ] [ Next: Controls ]


5 Controls

A control has the following characteristics:

  • has boundaries
  • can receive messages
  • can be drawn
  • may get the focus
  • has a distinction between a frame-area and a client-area:
    Control

5.1 Window

The class Window extends the class Control by the following points:

  • allows to set softkeys
  • can have a title
  • can be opened modal or modeless
It is very important to be aware, that a window may only be modified in the context of the application it belongs to in a synchronous manner. This is because each application might be represented by an own thread. Invoking methods from another application require that the method is explicitely marked as thread safe.

Example: the phonebook application wants to close a window from the call handling application. This may not be done the following way:

void PhonebookApp::OnKeyDown(...) {
    ...
    call_handling_win->Close(); // wrong! call_handling_win does not belong to the phonebook application
}
To close the window from the call handling application, the phonebook application has to to this in an asynchronous way by posting a message:
void PhonebookApp::OnKeyDown(...) {
   ...
   CloseWindowMsg(call_handling_win).Post();
}
This is valid for all other methods of a window too. To be more precise this not related to windows only, but is a general rule when communicating between threads. It's explicitely stated here because accessing windows from other applications is a common made mistake. As a thumb rule:
Applications may only communicate with each other by posting messages. Direct access to the data of another application is not allowed.

5.1.1 Adding Softkeys

Per default each application provides a Panel, which usually is placed at the bottom of the Desktop and shows the status of the softkeys. The number of softkeys is given by KeyboardConfig::GetSoftkeyCount(). Every softkey is represented by an instance of the class Action. The following code shows how to set the softkeys of a window and react on them:

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/Action.hpp>
#include <Gui/CloseWindowAction.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        Action m_ok_action;
        CloseWindowAction m_close_action;

        void OpenAlert();
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    SetTitle(Tr(L"Softkeys"));

    m_ok_action.Init(this, Tr(L"OK"), (Action::ExecFn)&MyWindow::OpenAlert);
    SetLeftSoftkey(&m_ok_action);

    m_close_action.Init(this, Tr(L"Close"));
    SetRightSoftkey(&m_close_action);
}

void MyWindow::OpenAlert()
{
    Alert alert(Tr(L"OK has been pressed");
    alert.OpenModal();
}

After initializing an action it is assigned to the corresponding softkey by SetLeftSoftkey(...) and SetRightSoftkey. When the m_ok_action has been executed by pressing the left softkey, an alert will be opened:

The methods Window::SetLeftSoftkey(Action* action) and
Window::SetRightSoftkey(Action* action) are just wrapper-methods for
the method Window::SetSoftkey(INT index, Action* action).

Important: to provide backward compatibility with APOXI-version below 1.8.0 per default no Desktop is instantiated. The desktop contains the Panel which is required to display the softkeys. To instantiate the desktop overwrite the method Application::OnStartup of one application (e. g. the main-application of the MMI) the following way:

void MyApp::OnStartup()
{
    Base::OnStartup();
    Desktop::CreateInstance();
}

5.1.1.1 Using More Than Two Softkeys

APOXI supports a variable number of softkeys. To make them available the following steps are necessary

  • Set the define APOXI_MAX_SOFTKEY_COUNT to the number of required softkeys in the build environment. This usually is done in the file project.cfg.default of the make directory.
  • Find out the keycode for the additional softkeys. Usually the keycode is defined by low level drivers and is outside the scope of APOXI. The keycode is required to adjust the following files:
    • The methods GetSoftkey() and GetSoftkeyCount() from the class KeyboardConfig must be implemented (the class KeyboardConfig is located in the directory 'config' of the project). Usually GetSoftkeyCount() just returns APOXI_MAX_SOFTKEY_COUNT and GetSoftkey() must be extended to return the corresponding keycode for the additional softkeys.
    • For the host simulator the file mmisim.xml must be adjusted to be able to click on the additional softkeys. It's recommended to use the tags <key name="SoftkeyLeft"...> and <key name="SoftkeyRight"...> as reference.
  • The MMI must set the corresponding actions to the additional softkeys.

5.1.2 Opening a Window Modal vs. Opening Modeless

A window can be opened modal by invoking Window::OpenModal() or modeless by invoking Window::OpenModeless().

statement 1;
win.OpenModeless();
statement 2;

In this case statement 1 is executed and the window is opened modeless. This means that when invoking win.OpenModeless() the window will be opened immediately and after the window has been opened statement 2 is executed, while the window still is open.

statement 1;
win.OpenModal();
statement 2;

Now statement 1 is executed and the window is opened modal. Opening a window modal means, that the method OpenModal is exited after the window has been closed, even if this takes e. g. some minutes. Hence statement 2 is executed after the window has been closed (e. g. when pressing OK or Cancel in the opened window). Please note that when opening a window modal the system is not blocked:

  • every application and window of the whole system will get its messages
  • also a window, which opened a modal window, will get its messages

This is possible by using a so called Active Wait in the implementation of Window::OpenModal. Opening a window modal makes sense especially for dialog-windows:

INT return_code = dialog_win.OpenModal();
if (return_code == DialogWindow::ConfirmId) {
    // the dialog-window has been exited by pressing OK
}
else {
    // the dialog-window has been exited by pressing Cancel
}

Opening windows modal burdens the callstack of the system, hence it should be avoided to open windows modal in a recursive manner.

When opening a window, the following methods of the class Window are invoked in this order:

  1. OnGetFocus: Usually when opening a window it will be opened in foreground and hence get the focus. In this case the method Control::OnGetFocus is invoked which might be overwritten to initialize focus dependand properties. The only case where the window cannot get the focus is if another window is already open which has a higher focus priority.
  2. OnOpen: Overwrite this method to initialize properties on each opening of the window. If expensive operations are done (like reading out data from a Provider) it is recommended to disable the window temporary by invoking Window::SetDisabled(TRUE) before the expensive operation and Window::SetDisabled(FALSE) at the end. This assures that the window does not react on e. g. key presses during the expensive operation.
  3. OnLayoutClient: Overwrite this method to layout the sub-components which are embedded inside the window.
  4. OnPaint:Overwrite this method to implement a customized drawing of the window content.
It is not allowed to open or close another window inside the context of the methods OnGetFocus, OnOpen, OnLayoutClient and OnPaint.

5.1.3 Closing a window

A window can be closed by invoking Window::Close. Note that closing a window is only allowed in the context of the application the window belongs to.

When closing a window, the following methods of the class Window are invoked in this order:

  1. OnClose: Overwrite this method to cleanup properties on closing the window.
  2. OnLoseFocus: Is invoked only, if the window has the focus.
It is not allowed to open or close another window inside the context of the methods OnLoseFocus and OnClose. If it is required to close a window inside those methods, this can be done asynchronously by invoking
CloseWindowMsg(win).Post();
By this command the window will be closed as soon as the next idle state is reached.

5.1.4 Multiple Display Support

APOXI supports a varible number of displays at the same time. To show a window on a specific display, the method Window::SetDisplayIndex(INT index) must be invoked, where index specifies the index of the display where the window should be shown. Usually the index 0, which is also the default value, indicates the main display. An already opened window can be moved to another display by invoking this method.

For the support of multiple display some configuration must be done:

  • In the class DisplayConfig the methods GetDisplayCount(), GetDisplayWidth(INT display_index), GetDisplayHeight(INT display_index) and GetFrameBuffer(INT display_index) must be adjusted. For example the implementation for two displays might look like this:
    UINT8 GDI_HUGE* DisplayConfig::GetFrameBuffer(INT display_idx)
{
    return (display_idx == 0) ? (UINT8 GDI_HUGE*)v_ram1 : (UINT8 GDI_HUGE*)v_ram2;
}

INT DisplayConfig::GetDisplayCount()
{
    return 2;
}

XYDIM DisplayConfig::GetWidth(INT display_idx)
{
    return (display_idx == 0) ? 128 : 80;
}

XYDIM DisplayConfig::GetHeight(INT display_idx)
{
    return (display_idx == 0) ? 160 : 100;
}
  • For the MMI Simulator the file display.xml must be adjusted to simulate multiple displays. For example the file display.xml for two displays might look like this (the required additional tags for the second display are noted in bold):
    <?xml version="1.0"?>

<displaylist>
  <display index="0">
    <xdim>128</xdim>
    <ydim>160</ydim>
    <bpp>16</bpp>
    <rgb_mask>
      <mask color="red" index="15" count="5"/>
      <mask color="green" index="10" count="6"/>
      <mask color="blue" index="4" count="5"/>
    </rgb_mask>
    <big_endian/>
  </display>

  <display index="1">
    <xdim>80</xdim>
    <ydim>100</ydim>
    <bpp>16</bpp>
    <rgb_mask>
      <mask color="red" index="15" count="5"/>
      <mask color="green" index="10" count="6"/>
      <mask color="blue" index="4" count="5"/>
    </rgb_mask>
    <big_endian/>
  </display>
</displaylist>
When working with multiple displays some restrictions must be respected:
  • The APOXI Resource Compiler in the current version is not aware about multiple displays yet, so the file display.xml must be reverted temporary to one display when starting the Resource Compiler.
  • The APOXI bitmap format is always organized in the same format as a display. This means that if the main display is a 16 bit color display and the second display is a monochrome display, an APOXI bitmap created for the main display cannot be shown on the second display. Complex images like JPEG, PNG and GIF don't have this restriction, but the result of showing a JPEG image on a monochrome display might not be as good than generating an optimized monochrome APOXI bitmap.

5.2 PushButton

After pressing a push-button the action will be executed, which has been assigned to the push-button.

The following example shows how to embed a push-button inside a window:

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/Action.hpp>
#include <Gui/PushButton.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        Action m_my_action;
        PushButton m_push_button;

        void OnButtonPressed();
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    m_my_action(this, Tr(L"OK"), (Action::ExecFn)&MyWindow::OnButtonPressed);
    m_push_button.Init(this, &m_my_action);
}

void MyWindow::OnButtonPressed()
{
    // add code for executing here (e. g. Close())
}

Usually a push-button is pressed by clicking on it with a pen, but due most mobile phones don't support pens, the push-button must be triggered manually by listening to a key, which invokes PushButton::Trigger() to execute the action of the push-button. The look may be adjusted by writing an own view as part of a theme. An available reference-implementation is available under:

  • Apoxi/GlobalThemes/DefaultTheme/DefaultPushButtonView.
  • Apoxi/GlobalThemes/FoggyTheme/FoggyPushButtonView.

5.3 CheckBoxControl

A CheckBoxControl represents a checkbox, which may be selected or unselected. In contrast to a radiobutton-control, checkboxes are independent from other checkboxes per definition.

In the following example two checkboxes are added to a window:

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/CheckBoxControl.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual void OnLayoutClient();

    private:
        CheckBoxControl m_checkbox_1;
        CheckBoxControl m_checkbox_2;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    m_checkbox_1.Init(this, Tr(L"Checkbox 1", TRUE);
    m_checkbox_2.Init(this, Tr(L"Checkbox 2", FALSE);
}

void MyWindow::OnLayoutClient()
{
    Window::OnLayoutClient();
    Layouter layouter(1, 2, this);
    layouter.Arrange(0, 0, &m_checkbox_1);
    layouter.Arrange(0, 1, &m_checkbox_2);
}

The image of the checkbox-control may be specified by the theme, by overwriting the method Theme::GetBitmap. An available reference-implementation is available under:

  • Apoxi/GlobalThemes/DefaultTheme/DefaultTheme.cpp
  • Apoxi/GlobalThemes/FoggyTheme/FoggyTheme.cpp

5.4 RadioButtonControl

A RadioButtonControl represents a radiobutton, which may be selected or unselected. A radiobutton defines a "one of many" choice and makes only sense as part of a radiobutton-group. A radiobutton-group is defined by the class RadioButtonGroup and takes care, that only one radiobutton is seleced.

In the following example two radiobuttons are added to a window:

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/RadioButtonControl.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual void OnLayoutClient();

    private:
        RadioButtonControl m_radiobutton_1;
        RadioButtonControl m_radiobutton_2;
        RadioButtonGroup m_rb_group;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    m_rb_group.Init();
    m_radiobutton_1.Init(this, &m_rb_group, Tr(L"Radiobutton 1", TRUE);
    m_radiobutton_2.Init(this, &m_rb_group, Tr(L"Radiobutton 2", FALSE);
}

void MyWindow::OnLayoutClient()
{
    Window::OnLayoutClient();
    Layouter layouter(1, 2, this);
    layouter.Arrange(0, 0, &m_radiobutton_1);
    layouter.Arrange(0, 1, &m_radiobutton_2);
}

The image of the radiobutton-control may be specified by the theme, by overwriting the method Theme::GetBitmap. An available reference-implementation is available under:

  • Apoxi/GlobalThemes/DefaultTheme/DefaultTheme.cpp
  • Apoxi/GlobalThemes/FoggyTheme/FoggyTheme.cpp

5.5 Menus and Lists

All menus and lists are build by adding instances of the classes Item and AbstractItemContainer to them.

5.5.1 ItemGrid

The class ItemGrid is just responsible for displaying a variable number of items. Per default the item-grid only has one column and hence behaves like a listbox. The currently selected item can be retrieved by invoking ItemGrid::GetSelectedItem(), the number of columns can be changed by invoking ItemGrid::SetColumnCount() or by specifying the column count in the ItemRendererProperties.

The following example shows how to embed 3 items inside an item-grid:

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/ItemGrid.hpp>
#include <Gui/Item.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        ItemGrid m_item_grid;
        Item m_item_1;
        Item m_item_2;
        Item m_item_3;

        CloseWindowAction m_close_win_action;
};
MyWindow.cpp
#include "MyWindow.hpp"

#include <Config/Resources/confirm_icon.hpp>
#include <Config/Resources/cancel_icon.hpp>

void MyWindow::Init()
{
    Window::Init();

    SetTitle(Tr(L"Item Grid"));

    m_item_1.Init(this, Tr(L"Item 1"), &confirm_icon);
    m_item_2.Init(this, Tr(L"Item 2"), &cancel_icon);
    m_item_2.SetEnabled(FALSE);
    m_item_3.Init(this, Tr(L"Item 3"));

    m_item_grid.Init(this);
    m_item_grid.AddItem(&m_item_1);
    m_item_grid.AddItem(&m_item_2);
    m_item_grid.AddItem(&m_item_3);

    m_close_win_action.Init(this, this, Tr(L"Close"));
    SetRightSoftkey(&m_close_win_action);
}

5.5.2 ItemMenu

In APOXI menus are implemented by the class ItemMenu. An item-menu may contain a variable number of items. One item is represented by the class Item. As there are also items which recursively may contain other items, it is possible to create a menu-tree.

Example: A window should be created which contains a menu with the following structure:

After pressing "Item 1" a sub-menu showing some radiobuttons and checkboxes should be displayed. When pressing "Item 2" an alert should be displayed, which shows "Item 2 has been triggered". Item 3 should stay disabled and hence cannot be triggered.

The following code shows the implementation of this menu-structure. The code needed for the hierarchical-menu is noted in bold.

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/ItemMenu.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        ItemMenu m_menu;

        // declarations for main-menu
        ItemContainer m_item_1;
        Action m_item_2;
        Action m_item_3;

        // declarations for sub-menu
        RadioButtonGroup m_rb_group;
        RadioButtonAction m_rb_action_1;
        RadioButtonAction m_rb_action_2;
        RadioButtonAction m_rb_action_3;
        CheckBoxAction m_cb_action_1;
        CheckBoxAction m_cb_action_2;

        Action m_select_action;
        Action m_close_action;

        void OnSelectPressed();
        void OnClosePressed();
        void OnItem2Pressed();
};
MyWindow.cpp
#include "MyWindow.hpp"

#include <Config/Resources/confirm_icon.hpp>
#include <Config/Resources/cancel_icon.hpp>

void MyWindow::Init()
{
    Window::Init();

    SetTitle(Tr(L"Main Menu"));

    // initialize sub-menu
    m_rb_group.Init();
    m_rb_action_1.Init(this, &m_rb_group, Tr(L"Radiobutton 1"), TRUE);
    m_rb_action_2.Init(this, &m_rb_group, Tr(L"Radiobutton 2"));
    m_rb_action_3.Init(this, &m_rb_group, Tr(L"Radiobutton 3"));
    m_cb_action_1.Init(this, Tr(L"Checkbox 1"), TRUE, TRUE);
    m_cb_action_2.Init(this, Tr(L"Checkbox 2"));

    m_item_1.Init(this, Tr(L"Item 1"), &confirm_icon);
    m_item_1.AddItem(&m_rb_action_1);
    m_item_1.AddItem(&m_rb_action_2);
    m_item_1.AddItem(&m_rb_action_3);
    m_item_1.AddItem(&m_cb_action_1);
    m_item_1.AddItem(&m_cb_action_2);

    // initialize main-menu
    m_item_2.Init(this, Tr(L"Item 2"), (Action::ExecFn)&MyWindow::OnItem2Pressed);
    m_item_2.SetIcon(&cancel_icon);
    m_item_3.Init(this, Tr(L"Item 3"), &cancel_icon);
    m_item_3.SetEnabled(FALSE);

    m_menu.Init(this);
    m_menu.AddItem(&m_item_1);
    m_menu.AddItem(&m_item_2);
    m_menu.AddItem(&m_item_3);

    // initialize softkeys
    m_select_action.Init(this, Tr(L"Select"), (Action::ExecFn)&MyWindow::OnSelectPressed);
    SetLeftSoftkey(&m_select_action);

    m_close_action.Init(this, Tr(L"Close"), (Action::ExecFn)&MyWindow::OnClosePressed);
    SetRightSoftkey(&m_close_action);
}

void MyWindow::OnSelectPressed()
{
    m_menu.Trigger();
}

void MyWindow::OnClosePressed()
{
    if (m_menu.GetLevel() == 0)
        Close();
    else
        m_menu.Back();
}

void MyWindow::OnItem2Pressed()
{
    Alert alert(Tr(L"Item 2 has been triggered."));
    alert.OpenModal();
}

In MyWindow::Init the actions of the sub-menu are initialized:

  • As shown in the chapter for the RadioButtonControl, each radiobutton must be part of a radiobutton-group to assure that only one radiobutton may get selected.
  • The checkboxes are independent from each other and hence don't need a group.
  • After initializing the actions, they are embedded into the sub-menu.

After the sub-menu the main-menu is initialized the same way:

  • The two remaining actions are initialized.
  • After the initialization the actions are embedded into the menu.

The function members OnSelectPressed, OnClosePressed and OnItem2Pressed have been asigned to the actions and are invoked as soon as the action has been executed.

5.5.3 ItemTree

The class ItemTree implements a tree-view for items. The interface for adding items to the item-tree is nearly identical to adding items to the item-menu (see example in the previous chapter). In opposite to the item-menu the item-tree does not offer the method Back, as the opening and closing of the tree is done by the method ItemTree::Trigger.

The following code shows the implementation of the same menu-hierarchy as in example for the item-menu (chapter 6.5) but using the item-tree. The code needed for the hierarchical-menu is noted in bold.

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/ItemMenu.hpp>
#include <Gui/CloseWindowAction.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        ItemTree m_menu;

        // declarations for main-menu
        ItemContainer m_item_1;
        Action m_item_2;
        Action m_item_3;

        // declarations for sub-menu
        RadioButtonGroup m_rb_group;
        RadioButtonAction m_rb_action_1;
        RadioButtonAction m_rb_action_2;
        RadioButtonAction m_rb_action_3;
        CheckBoxAction m_cb_action_1;
        CheckBoxAction m_cb_action_2;

        Action m_select_action;
        CloseWindowAction m_close_action;

        void OnSelectPressed();
        void OnItem2Pressed();
};
MyWindow.cpp
#include "MyWindow.hpp"

#include <Config/Resources/confirm_icon.hpp>
#include <Config/Resources/cancel_icon.hpp>

void MyWindow::Init()
{
    Window::Init();

    SetTitle(Tr(L"Main Menu"));

    // initialize sub-menu
    m_rb_group.Init();
    m_rb_action_1.Init(this, &m_rb_group, Tr(L"Radiobutton 1"), TRUE);
    m_rb_action_2.Init(this, &m_rb_group, Tr(L"Radiobutton 2"));
    m_rb_action_3.Init(this, &m_rb_group, Tr(L"Radiobutton 3"));
    m_cb_action_1.Init(this, Tr(L"Checkbox 1"), TRUE, TRUE);
    m_cb_action_2.Init(this, Tr(L"Checkbox 2"));

    m_item_1.Init(this, Tr(L"Item 1"), &confirm_icon);
    m_item_1.AddItem(&m_rb_action_1);
    m_item_1.AddItem(&m_rb_action_2);
    m_item_1.AddItem(&m_rb_action_3);
    m_item_1.AddItem(&m_cb_action_1);
    m_item_1.AddItem(&m_cb_action_2);

    // initialize main-menu
    m_item_2.Init(this, Tr(L"Item 2"), (Action::ExecFn)&MyWindow::OnItem2Pressed);
    m_item_2.SetIcon(&cancel_icon);
    m_item_3.Init(this, Tr(L"Item 3"), &cancel_icon);
    m_item_3.SetEnabled(FALSE);

    m_menu.Init(this);
    m_menu.AddItem(&m_item_1);
    m_menu.AddItem(&m_item_2);
    m_menu.AddItem(&m_item_3);

    // initialize softkeys
    m_select_action.Init(this, Tr(L"Select"), (Action::ExecFn)&MyWindow::OnSelectPressed);
    SetLeftSoftkey(&m_select_action);

    m_close_action.Init(this, this, Tr(L"Close"));
    SetRightSoftkey(&m_close_action);
}

void MyWindow::OnSelectPressed()
{
    m_menu.Trigger();
}

void MyWindow::OnItem2Pressed()
{
    Alert alert(Tr(L"Item 2 has been triggered."));
    alert.OpenModal();
}

5.5.4 ContextMenu

The class ContextMenu represents a context-menu which may contain a variable number of items. As items representing an instance of the class AbstractItemContainer recursively contain other items, a context-menu also may contain sub-menus. The following images show a sample-application, which opens a context-menu above the left softkey including a sub-menu:

No context menu Opened context menu Context menu with sub-menu

5.5.4.1 Using a OpenContextMenuAction

The most comfortable way to open a context-menu is by using a OpenContextMenuAction, which automatically opens a context-menu when it is executed. In the following example a context-menu-action is used for the left softkey:

MyWindow.hpp
#include <Gui/Window.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        ...
        OpenContextMenuAction m_options_action;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();

    ...
    // initialize items like m_insert, m_selection etc.
    ...

    m_options_action.Init(this, Tr(L"Options"));
    m_options_action.AddItem(&m_insert);
    m_options_action.AddItem(&m_selection);
    m_options_action.AddItem(&m_clear);
    m_options_action.AddItem(&m_switch_read_only);
    m_options_action.AddItem(&m_textformat_1);
    m_options_action.AddItem(&m_textformat_2);

    SetLeftSoftkey(&m_options_action);
}

The constructor and Init-method of the class OpenContextMenuAction offers parameters for setting an item-container and the position of the context-menu directly.

5.5.4.2 Customized Opening

Sometimes it might be useful, to build a context-menu without the need of having a context-menu-action. The following sample-code represents more or less the implementation of the context-menu-action:

// x ........... x-position of the context-menu
// y ........... y-position of the context-menu
// corner ...... Corner of the x- and y-position:
//               ContextMenu::TopLeft, ContextMenu::TopRight,
//               ContextMenu::BottomLeft or ContextMenu::BottomRight
// item_cont ... Item-Container which represents the items of the context-menu
ContextMenu* context_menu = new ContextMenu(x, y, corner, item_cont);
if (context_menu != 0) {
  // use the default item-renderer properties except for:
  // - the background color: the ContextMenuBackground color should be used
  // - an item-container should be indicated by an arrow to signalize a sub-menu
  const ItemRendererProperties* default_prop = GuiEngineConfig::GetDefaultItemRendererProperties();
  ItemRendererProperties prop(default_prop->GetDisplayType(),
                              default_prop->GetAnimType(),
                              default_prop->GetScrollDelay(),
                              default_prop->GetScrollGap(),
                              default_prop->GetTextFormat(),
                              default_prop->FullScreenPerItem(),
                              default_prop->IsTransparent(),
                              default_prop->IsMultiLine(),
                              default_prop->IsVerticalCentered(),
                              TRUE, // indicate item container
                              Color(Color::ContextMenuBackground)
                             );
  context_menu->SetRenderer(&prop);
  context_menu->OpenModal();
  delete context_menu;
}

Setting a specialized renderer for the context-menu is not a requirement, but it is recommended to have other renderer-properties as used for the items inside a window. For this example the background-color specified by the theme is used (e. g. usually context-menus have a kind of gray background) and items opening a sub-menu are indicated by a right-arrow.

Opening the context-menu modal burdens the callstack, but allows a deleting immediatly afterwards. If the context-menu should be openened modeless, then...

  • ... the application or window opening the context-menu must listen to the message ContextMenuClosedMsg, which will be send after the context-menu has been closed and allows to delete it.
  • ... the item renderer properties must declared static, to avoid that they are deleted when leaving the scope while the context menu is still open. Generally it is recommended that the MMI provides a set of static item renderer properties, which may be shared by the menus.

5.5.5 Embedding Images

When embedding complex images like PNG, JPEG or GIF inside an item, the decoding of such an image might take up to several seconds for very large images. To avoid a blocking user interface all menus and lists of APOXI are implemented in a way, that the decoding of such images is done asynchronously in a separate thread. During the decoding the menus and lists can be navigated as usual and the images are shown automatically as soon as the decoding has been finished. If it's requested to show the images without any delay, than the images must be converted to a Bitmap or NativeImage and embedded into the item. For a description of the difference between images and bitmaps have a look at chapter 6.6: ImageBox.

5.5.6 Scroll Behavior

The scroll behavior for all lists and menus can be defined by implementing the method GuiEngineConfig::GetScrollBehavior in the file GuiEngineConfig.cpp located in the Config directory. The following scroll behaviors are available:

  • DefaultBehavior: A line-by-line scrolling will be done if the selection reachs the top or bottom of the visible area. If the selection reaches the begin or end of all items, no scrolling is done. The scroll gap defined in OptionalConfig::GetSetting is respected.
  • BlockScrollBehavior: Same behavior as the DefaultBehavior, but if the top or bottom of the visible area has been reached, the items are not scrolled line-by-line but per page.
  • RotateBehavior: Same behavior as the DefaultBehavior, but if the selection reaches the begin or end of all items, the selection will be rotated to the other end of the list. The scroll gap defined in OptionalConfig::GetSetting is respected.
  • EndlessLoopBehavior: The items will be treated like a ring buffer: if the last item is selected, the next visible item is the first item. If the scroll gap defined in OptionalConfig::GetSetting is -1, the selection will always stay at the vertical center of the visible area.

5.5.7 Enlarged Selection

It is possible to specify that the selected item is enlarged:

Enlarged selection

This can be done by setting the selection height property inside the used ItemRendererProperties. Per default all menus use the item renderer properties returned by const ItemRendererProperties* GuiEngineConfig::GetDefaultItemRendererProperties(). If the selection height is set there, all menus will use this height per default.

If the setting should only be valid for one instance of a menu, the renderer of this menu must be initialized with corresponding item renderer properties. In the following example a copy of the default item renderer is used, the selection height is adjusted and assigned to a menu:

ItemRendererProperties* prop = new ItemRendererProperties();
if (prop != 0) {
  const ItemRendererProperties* default_prop = GuiEngineConfig::GetDefaultItemRendererProperties();
  ASSERT_DEBUG(default_prop != 0);
  *prop = *default_prop;
  prop->SetSelectionHeight(48);
  menu->SetRenderer(prop);
  ...
  // note that the renderer properties 'prop' may not get deleted as long as the menu is alive
}

As the selection is enlarged, it also might be required to use an enlarged and different icon for the selection:

Enlarged selection

Usually when assigning an icon to an item this is done by assigning a bitmap:

Bitmap* bmp = ...;
item.SetIcon(bmp);

... or an image embedded inside an image obtainer:

JpegImage* jpeg_image = new JpegImage(...);
item.SetIcon(ImageObtainer(jpeg_image, TRUE));

But it is also possible to assign an IconSet for an image. The icon set provides the sizes SmallSize, DefaultSize and LargeSize for the modes NormalMode, ActiveMode and DisabledMode:

Icon set

The icons for the different modes and sizes can be set the following way

NativeImage* default_img = new NativeImage(...);
NativeImage* default_active_img = new NativeImage(...);
NativeImage* large_active_img = new NativeImage(...);

IconSet icon_set(ImageObtainer(default_img, TRUE)); // default icon
icon_set.AddIcon(IconState(IconState::DefaultSize, IconState::ActiveMode),
                 ImageObtainer(default_active_img, TRUE));
icon_set.AddIcon(IconState(IconState::LargeSize, IconState::ActiveMode),
                 ImageObtainer(large_active_img, TRUE));
item.SetIcon(icon_set);

If an icon is not defined for a specific mode and size, the default icon (= mode is NormalMode, size is DefaultSize) will be used.

When the icon should be drawn, it is checked which mode is used: When the item is selected, the mode ActiveMode is used, if it is disabled the DisabledMode is used. Also it must be determined, which size should be used: The item renderer properties define the available size for the icon. As the icons usually should not get scaled, the available height is taken and compared to the preferred sizes for the modes SmallSize, DefaultSize and LargeSize, which are defined by static Size GuiEngineConfig::GetIconSize(IconState::Size size) inside the configuration class GuiEngineConfig:

Size GuiEngineConfig::GetIconSize(IconState::Size size)
{
    switch (size) {
        case IconState::LargeSize:      return Size(32, 32);
        case IconState::SmallSize:      return Size( 8,  8);
        case IconState::DefaultSize:
        default:                        return Size(24, 24);
    }
}

This means when e. g. a height of 28 pixels is available, the icon defined for DefaultSize will be used. Specifying the item renderer properties and the preferred sizes for the icon size states should be done in a coordinated manner and fit to the available icon sizes. The best results can be achieved if the icons have exactly the same size as defined for the icon size states.

The following restriction is given for icon sets: The menu controls only respect icon sets containing images which can be decoded synchronously (e. g. bitmaps or native images). This is because showing an icon set containing images which must be decoded asynchronously (e. g. JPEGs, GIFs, PNGs) would require a lot of memory for buffering all images.

5.6 Editor Controls

APOXI offers the following kind of editor controls:

  • line-editor
  • date-editor
  • time-editor
  • password-editor
  • multi-line-editor
  • multi-media-editor (as part of the APOXI-AddOn MultiMedia)

All editors have in common, that the input-method may be exchanged easily by so called input-mappers, which are derived from the class InputMapper. APOXI offers default input-mappers for the most usual input-methods, but this may be extended in an easy manner by customized input-mappers: The editor invokes the factory-method EditConfig::AllocInputMapper() with the given ID as input-mapper, which results in creating an instance of the requested input-mapper. This factory-method is customer-specific and must be overwritten in the configuration-file EditConfig.cpp.

If the editor has the focus it forwards each key-message to its input-mapper. The input-mapper interprets the key-message and controls the cursor and content of the editor by using the public interface of the editor.

The public interface of the editors distincts between atom-items and compound-items:

  • An atom-item is an instance of the class AtomItem and may not get splitted or wrapped by the editor. Examples for an atom-item are a character, an image or an animation. All interfaces of the editor concerning atom-items just require a const-reference as input-parameter. For example when inserting the character 'X' at the end of the editor-content, just editor->InsertItem(CharItem(L'X')) must be invoked. The editor itself takes care about storing the atom-item in an internal format, hence the atom-items may be created on the stack without doubts concerning dangling pointers or memory-leaks.
  • A compound-item is an instance of the class CompoundItem. A compound-item contains a variable number of atom-items or recursively other compound-items and may get splitted, merged and wrapped by the editor. An example of a compound-item is a paragraph. All interfaces concerning compound-items require a pointer to a compound-item. Usually an instance is created outside the editor but handled and obtained from the editor itself. Therefor instances may not be constructed directly using a constructor. Any derived class provides a static method CreateInstance(…) to create an instance:
    TextCompoundItem* text = TextCompoundItem::CreateInstance(L"Text");
    After passing a compound-item-pointer to the editor (e. g. by editor->InsertCompoundItem(text)) the compount item is obtained by this editor per definition and the releasing of the compound-item is done by the editor itself by invoking ReleaseInstance(). So never release a compound-item after passing it to the editor.

Examples how to insert atom-items and compound-items into the editor are given in the chapter "6.6.6 MultiMediaEditor".

5.6.1 LineEditor

The line-editor offers the following features:

  • suitable for the input-mappers for numbers, phonenumbers, multitap and predictive input like T9
  • horizontal scrolling
  • overwrite/insert mode
  • variable font and line height

In the following example a line-editor with an additional description is added to a window:

MyWindow.hpp
#include <ApoxiLib.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual void OnLayoutClient();

    private:
        TextLine m_descr;
        LineEditor m_editor;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    m_descr.Init(this, Tr(L"Enter a phone number:"));
    m_editor.Init(this, InputMapper::PhoneNumber);
}

void MyWindow::OnLayoutClient()
{
    Window::OnLayoutClient();
    Layouter layouter(1, 2, this);
    layouter.Arrange(0, 0, &m_descr);
    layouter.Arrange(0, 1, &m_editor);
}

5.6.2 DateEditor

Represents a line-editor, which uses a date-input-mapper for editing a date.

5.6.3 TimeEditor

Represents a line-editor, which uses a time-input-mapper for editing a time.

5.6.4 PasswordEditor

Represents a line-editor, which hides each character by a '*'.

5.6.5 MultiLineEditor

The multi-line-editor offers the following features:

  • suitable for the input-mappers for numbers, phonenumbers, multitap and predictive input like T9
  • vertical scrolling including an optional position-indicator
  • overwrite/insert mode
  • variable font and line-height
  • read-only mode

5.6.6 MultiMediaEditor

The APOXI-AddOn MultiMedia offers a multi-media-editor with the following features:

  • suitable for the input-mappers for numbers, phonenumbers, multitap and predictive input like T9
  • vertical scrolling including an optional position-indicator
  • overwrite/insert mode
  • allows embedding a variable number of images, animations, sound-objects and other customized editor-items.
  • support of paragraphs, which may aligned left, centered or right
  • support of rich-text:
    • bold, italic, underlined, strikethrough
    • variable text-color and text-background-color
    • variable font
  • read-only mode which allows triggering actions on images, animations and sound-objects

The following example shows how to the multi-media-editor with paragraphs containing rich-text and images.

MyWindow.hpp
#include <ApoxiLib.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        MultiMediaEditor m_editor;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    m_editor.Init(this, InputMapper::MultiTap);
    const Font& font = System::GetFont(Font::Client);

    // create a rich text with red color and grey background
    RichTextCompoundItem* rich_text_1 = RichTextCompoundItem::CreateInstance(font, L"Rich text compound item 1");
    rich_text_1->SetForegroundColor(Color(255, 0, 0));  // red text
    rich_text_1->SetBackgroundColor(Color(90, 90, 90)); // grey background

    // create a rich text with bold font
    RichTextCompoundItem* rich_text_2 = RichTextCompoundItem::CreateInstance(font, L"Rich text compound item 2");
    rich_text_2->SetTextAttr(TextFormat::Bold);

    // create a right aligned paragraph, which contains both rich texts
    ParagraphCompoundItem* paragraph_1 = ParagraphCompoundItem::CreateInstance(EditorDocument::RightAlign);
    paragraph_1->InsertCompoundItem(rich_text_1);
    paragraph_1->InsertCompoundItem(rich_text_2);

    // create two image-items
    Image* img_1 = ...;     // see chapter "7.7 ImageBox" for details
    ImageItem img_item_1(ImageObtainer(img_1));
    Image* img_2 = ...;     // see chapter "7.7 ImageBox" for details
    ImageItem img_item_2(ImageObtainer(img_2));

    // create a centered paragraph, which contains the image-items
    ParagraphCompoundItem* paragraph_2 = ParagraphCompoundItem::CreateInstance(EditorDocument::LeftAlign);
    paragraph_2->InsertItem(img_item_1);
    paragraph_2->InsertItem(img_item_2);

    // insert both paragraphs into the editor
    m_editor.InsertCompoundItem(paragraph_1);
    m_editor.InsertCompoundItem(paragraph_2);
}

When working with the multimedia editor it often is required to parse the document content and maybe to adjust compound items. The following code searchs a compound item which has the text "Hello" and adds an image in front of it:

before | after
Before | After
MultiMediaEditorDocument* doc = static_cast<MultiMediaEditorDocument*>(editor.GetDocument());
CompoundItemIterator it(doc);
if (it.Begin()) {
    BOOLEAN found = FALSE;
    do {
        INT start_index = 0;
        const CompoundItem* comp_item = it.Get(&start_index);
        if (comp_item->IsInstanceOf(TextCompoundItem::ID)) {
            const TextCompoundItem* text_comp_item = static_cast<const TextCompoundItem*>(comp_item);
            const WString& text = text_comp_item->GetText();
            if (text.CompareTo(L"Hello") == 0) {
                // Text compound item having "Hello" as content has been found.
                // Now add an image in front of it.
                Image* img = ...; // see chapter "7.7 ImageBox" for details
                ImageItem image_item(ImageObtainer(img));
                doc->InsertItem(image_item, start_index);

                // After the document has been modified directly the editor itself must be updated
                editor.Update();
                found = TRUE;
            }
        }
    } while (!found && it.Next());
}

The class CompoundItemIterator allows to traverse all leafs of the multimedia editor document. Note that the document content can be very complex and may contain nested compound items as soon as paragraphs are used. To know the internal document structure APOXI offers a hint on the host environment: when inserting the number 5002 to the file DbgOutRange.txt located in the APOXI_TEMP directory, DBG_OUT messages are shown when moving the cursor inside a multimedia editor. For example the output to the corresponding content looks like this:

Content of Multimedia-Document:
ParagraphCompoundItem (15)
    RichTextCompoundItem (4): "Abc "
    GeneralCompoundItem (1)
    RichTextCompoundItem (5): "Hello"
    RichTextCompoundItem (4): " Dfg"
    ParagraphMarker (1): "<--"

total items: 15
Content of Multimedia-Document:
ParagraphCompoundItem (65)
    RichTextCompoundItem (20): "This is a paragraph "
    RichTextCompoundItem (10): "containing"
    RichTextCompoundItem (28): " various rich text compound "
    RichTextCompoundItem (6): "items."
    ParagraphMarker (1): "<--"
ParagraphCompoundItem (103)
    RichTextCompoundItem (38): "This paragraph contains an animation, "
    GeneralCompoundItem (1)
    RichTextCompoundItem (61): " a yellow rich text compound item, an image and a sound item:"
    GeneralCompoundItem (2)
    ParagraphMarker (1): "<--"
ParagraphCompoundItem (83)
    RichTextCompoundItem (82): "This paragraph is horizontally centered between the left and right editor borders."
    ParagraphMarker (1): "<--"
ParagraphCompoundItem (61)
    RichTextCompoundItem (60): "This paragraph is aligned to the right border of the editor."
    ParagraphMarker (1): "<--"

total items: 312

5.6.7 Concept of Input Mappers

The editors use an InputMapper for interpreting pressed keys to modify the content of the document. E. g. when pressing the key 2 the NumericInputMapper inserts the number 2 into the document. The input mapper also takes care to navigate the caret of the editor. Every input mapper has a unique ID, where the following IDs are available per default in APOXI:

  • Numeric: Allows to input numeric numbers from 0 to 9.
  • MultiTap: Allows to input characters by the multi tap input method. The multi tap table can be configured depending from the locale settings inside the class LocaleConfig.
  • PhoneNumber: Allows to input a phone number including the numbers 0 to 9 and the characters +, * and #.
  • Predictive: Predictive input (e. g. T9 or Zi8). It depends on EditConfig::AllocInputMapper which instance of an input mapper is returned. Using 'Predictive' instead of 'T9' or 'Zi8' is useful when the application should not rely on a specific input method.
  • Date: Allows to input a date. The date format can be specified depending from the locale settings inside the class LocaleConfig. This input mapper ID is used per default for the editor DateEditor.
  • Time: Allows to input a time. The date format can be specified depending from the locale settings inside the class LocaleConfig. This input mapper ID is used per default for the editor TimeEditor.
  • Calculator: Allows to input characters useful for a calculator (0 - 9, +, -, /, *).
  • IpAddress: Allows to input an IP address. This input mapper ID is used per default for the editor IpAddressEditor.
  • Zi8: Uses the predictive input eZi text.
  • Url: Allows to enter an URL. APOXI does not offer a default implementation for this input mapper ID.
  • EMailAddress: Allows to enter an e-mail address. APOXI does not offer a default implementation for this input mapper ID.
  • T9: Uses the predictive input method T9.
  • Custom: Defined for custom input mappers. Note that the IDs 100 to 999 are reserved for ATL and third party applications.

The following sample code shows how a MultiTapInputMapper is assigned to a line editor:

multi tap input

MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/LineEditor.hpp>

class MyWindow : public Window {
    public:
        void Init();

    private:
        LineEditor m_editor;
};
MyWindow.cpp
#include "MyWindow.hpp"
#include <Gui/InputMapper.hpp>

void MyWindow::Init()
{
    Window::Init();
    m_editor.Init(this, InputMapper::MultiTap);
}

5.6.7.1 Customization

When initializing the editor with the input mapper ID, the instance of the input mapper is created by the factory method AllocInputMapper inside the class EditConfig:

InputMapper* EditConfig::AllocInputMapper(INT input_mapper_id)
{
    InputMapper* input_mapper = 0;

    switch (input_mapper_id) {
        case InputMapper::Calculator:
            input_mapper = new CalculatorInputMapper();
            break;

        case InputMapper::Date:
            input_mapper = new DateTimeInputMapper(TRUE);
            break;

        case InputMapper::Time:
            input_mapper = new DateTimeInputMapper(FALSE);
            break;

        case InputMapper::MultiTap:
            input_mapper = new MultiTapInputMapper();
            break;

        case InputMapper::Numeric:
            input_mapper = new NumericInputMapper();
            break;

        case InputMapper::PhoneNumber:
            input_mapper = new PhoneNumberInputMapper();
            break;

        case InputMapper::IpAddress:
            input_mapper = new IpAddrInputMapper();
            break;

        default:
            break;
    }
    return input_mapper;
}

The implementation of this method can be customized in any manner. For example it is possible to implement a custom class for the input mapper ID PhoneNumber. By this approach no application code must be changed when a different input mapper should be used for the phone number input method. Here is the original implementation of the class PhoneNumberInputMapper as sample for a custom implementation:

PhoneNumberInputMapper.hpp
#include <Gui/NumericInputMapper.hpp>

class PhoneNumberInputMapper : public NumericInputMapper {
    public:
        explicit PhoneNumberInputMapper();
        virtual ~PhoneNumberInputMapper();
        virtual INT GetId() const;
        virtual Alphabet GetAlphabet() const;

    protected:
        virtual BOOLEAN OnKeyDown(KeyCode key_code);
        virtual BOOLEAN OnLongKeyPress(KeyCode key_code);

    private:
        void InsertChar(WCHAR chr);
        void ReplaceChar(WCHAR chr);
};
PhoneNumberInputMapper.cpp
#include "PhoneNumberInputMapper.hpp"
#include <Gui/CharItem.hpp>
#include <Gui/AbstractEditor.hpp>
#include <Config/KeyboardConfig.hpp>
#include <Config/EditConfig.hpp>

PhoneNumberInputMapper::PhoneNumberInputMapper() : NumericInputMapper() {}
PhoneNumberInputMapper::~PhoneNumberInputMapper() {}
INT PhoneNumberInputMapper::GetId() const { return PhoneNumber; }
InputMapper::Alphabet PhoneNumberInputMapper::GetAlphabet() const { return SevenBitAlphabet; }

BOOLEAN PhoneNumberInputMapper::OnKeyDown(KeyCode key_code)
{
    BOOLEAN dispatched = TRUE;

    if (key_code == KeyboardConfig::GetCustomKey(L'*')) {
        InsertChar(L'*');
    }
    else if (key_code == KeyboardConfig::GetCustomKey(L'#')) {
        InsertChar(L'#');
    }
    else {
        dispatched = Base::OnKeyDown(key_code);
    }

    return dispatched;
}

BOOLEAN PhoneNumberInputMapper::OnLongKeyPress(KeyCode key_code)
{
    BOOLEAN dispatched = TRUE;

    if (key_code == KeyboardConfig::GetCustomKey(L'*')) {
        ReplaceChar(EditConfig::GetWildcard());
    }
    else if (key_code == KeyboardConfig::GetCustomKey(L'#')) {
        ReplaceChar(EditConfig::GetDtmfSeparator());
    }
    else if (key_code == KeyboardConfig::GetNumber(0)) {
        ReplaceChar(L'+');
    }
    else {
        dispatched = Base::OnLongKeyPress(key_code);
    }

    return dispatched;
}

void PhoneNumberInputMapper::InsertChar(WCHAR chr)
{
    AbstractEditor* editor = GetEditor();
    const CharItem ci(chr);
    if (editor->GetEditMode() == Caret::Overwrite) {
        editor->ReplaceItem(ci);
    }
    else {
        editor->InsertItem(ci);
    }

    editor->MoveCaret(+1);
}

void PhoneNumberInputMapper::ReplaceChar(WCHAR chr)
{
    AbstractEditor* editor = GetEditor();
    const CharItem ci(chr);
    const INT index = editor->GetCaretIndex() - 1;
    editor->ReplaceItem(ci, index);
}

The input mapper offers the hooks OnKeyDown, OnLongKeyPress and OnKeyUp which are invoked for each key press done inside the editor. The key press is translated into a character which can be added to the editor by invoking Editor::InsertItem or Editor::ReplaceItem. The caret of the editor can be moved by Editor::MoveCaret.

Note that the default input mappers offer some options in their constructor, which might fulfill requirements already so that no custom implementation is required. For example the input mappers DateTimeInputMapper and IpAddrInputMapper allow to highlight the currently entered field by passing TRUE for the parameter 'highlight_field':

Per default the following look is used ('highlight_field' is FALSE):

5.6.7.2 Caret

The input mapper has a factory method GetCaret, which may be overwritten to implement a customized Caret. Every caret is part of an editor and describes the position and the look of the cursor. The position is defined by the row and the column. The caret is allocated and freed by the input mapper; also the input mapper has to provide its caret by the necessary parameters for displaying the right hint or mode.

A good example about the capabilities of the caret is the MultiTapCaret:

  • Default multi tap caret:
  • Multi tap caret during input including the preview:
  • Multi tap caret in overwrite mode:

The class MultiTapCaret has overwritten the GetCaret method the following way:

Caret* MultiTapInputMapper::GetCaret()
{
    if (m_caret == 0) {
        m_caret = new MultiTapCaret(GetEditor(), EditConfig::GetBlinkRate(), (BOOLEAN)m_bits.show_preview);
    }
    return m_caret;
}

Usually the input mapper and it's caret work together quite close. In the case of the multi tap input mapper all the necessary information for displaying the preview in the multi tap caret is provided. There are a few basic hooks which are documented in detail inside Caret and InputMapper.

5.7 TabControl

A TabControl allows to embed controls inside a variable number of tab pages. The navigation between the tab pages is done by the left and right arrow key. A tab page is represented by a text, an icon and a control which acts as page content.

The following examples shows a tab control with three tab pages:
  • Tab page one contains a multiline editor.
  • Tab page two contains a text and two checkboxes.
  • Tab page three contains a list with 3 items.
TabControl TabControl TabControl
MyWindow.hpp
#include <Gui/Window.hpp>
#include <Gui/TabControl.hpp>
#include <Gui/MultiLineEditor.hpp>
#include <Gui/CheckBoxControl.hpp>

class MyWindow : public Window {
    public:
        MyWindow();
        virtual ~MyWindow();
        void Init();

    private:
        TabControl m_tab_control;

        // actions for softkeys
        Action m_ok_action;
        CloseWindowAction m_close_action;

        // content of tab page 1
        MultiLineEditor m_editor;

        // content of tab page 2
        GridLayout m_grid_layout;
        TextLine m_text_line;
        CheckBoxControl m_checkbox1;
        CheckBoxControl m_checkbox2;

        // content of tab page 3
        ItemGrid m_list;
        Item m_item_1;
        Item m_item_2;
        Item m_item_3;

        void OnOkPressed();     // will be executed if the OK softkey has been pressed
};
MyWindow.cpp
#include "MyWindow.hpp"
#include <Config/Resources/confirm_icon.hpp>
#include <Config/Resources/cancel_icon.hpp>

MyWindow::MyWindow()
{
}

MyWindow::~MyWindow()
{
}

void MyWindow::Init()
{
    Window::Init();

    SetTitle(Tr(L"TabControl Test"));
    Maximize();

    // initialize softkeys
    m_ok_action.Init(this, Tr(L"OK"), (Action::ExecFn)&MyWindow::OnOkPressed);
    SetLeftSoftkey(&m_ok_action);
    m_close_action.Init(this, this, Tr(L"Close"));
    SetRightSoftkey(&m_close_action);

    // initialize tab page 1
    m_editor.Init(this, InputMapper::MultiTap, L"This is a MultiLineEditor embedded into a tab page.");
    m_editor.SetReadOnly(TRUE);
    m_editor.SetFrameType(Control::NoFrame);

    // initialize tab page 2
    m_grid_layout.Init(this, 3, 1);
    m_text_line.Init(&m_grid_layout, Tr(L"Text"));
    m_checkbox1.Init(&m_grid_layout, Tr(L"Checkbox 1"));
    m_checkbox2.Init(&m_grid_layout, Tr(L"Checkbox 2"));
    m_grid_layout.SetCellProperties(0, 0, &m_text_line);
    m_grid_layout.SetCellProperties(1, 0, &m_checkbox1);
    m_grid_layout.SetCellProperties(2, 0, &m_checkbox2);

    // initialize tab page 3
    m_list.Init(this);
    m_item_1.Init(this, L"Max Headroom");
    m_item_2.Init(this, L"Jeff Wright");
    m_item_3.Init(this, L"Dennis Righthouse");
    m_list.AddItem(&m_item_1);
    m_list.AddItem(&m_item_2);
    m_list.AddItem(&m_item_3);

    m_tab_control.Init(this);
    m_tab_control.AddTab(&m_editor, Tr(L"Tab1"), &confirm_icon);
    m_tab_control.AddTab(&m_grid_layout, Tr(L"Tab2"), &cancel_icon);
    m_tab_control.AddTab(&m_list, Tr(L"Tab3"), &confirm_icon);
}

void MyWindow::OnOkPressed()
{
    // access the current tab control here e. g. toggling the  the checkboxes
    // can be done like this:
    const INT index = m_tab_control.GetActiveTab();
    if (m_tab_control.GetPage(index) == &m_grid_layout) {
        Control* focused_control = m_grid_layout.GetFocusedControl();
        if ((focused_control != 0) && focused_control->IsInstanceOf(CheckBoxControl::ID)) {
            CheckBoxControl* checkbox = (CheckBoxControl*)focused_control;
            checkbox->Toggle();
        }
    }
    else {
        Alert msg_box(Tr(L"OK has been pressed"));
        msg_box.OpenModal();
    }
}

When several controls should be part of a page, it is recommended to use a GridLayout as control representing the page. The grid layout allows to layout any kind of components inside the given boundaries. In the example the tab page two uses a grid layout containing 3 vertical aligned components.

How to access the content of an active page is shown inside the method MyWindow::OnOkPressed. The method TabControl::GetActiveTab returns the index of the active tab. This index can be used to get the control representing the page by TabControl::GetPage.

5.7.1 Header Line

Per default the text and the icon of a tab page are shown inside the tab button at the top. If the texts are very long and many tabs are shown, it might be useful to enable a header line to reduce clutter. Enabling the header line can be done by invoking the method TabControl::SetHeaderEnabled(TRUE):

TabControl TabControl TabControl

The text will be shown below the tab buttons using the full available width of the tab control.

5.7.2 Tab Button Size

The width and the height of a tab button is defined by the TabButtonView implemented by the current set theme (see Chapter 8: Themes for details). The following properties can be defined for the tab button:

  • Default height: If -1 is used, the height of the client font is used as default setting.
  • Default width: If -1 is used, the buttons are stretched in a way that all buttons are visible inside the available tab control width.
  • Minimum width: If a value < 1 is used, a minimum of 1 is assumed. Note that when the header line is turned on by TabControl::SetHeaderEnabled(TRUE), the minimum width is used for the width of the tab buttons instead of the default width, as the tab button will not contain any text.
  • Maximum width: If a value < 1 is used, no maximum is given.
  • Clipped width of a tab button: If not all tab buttons fit into the tab control width, the clipped width describes the preferred width of the clipped tab button on the left or right.

In the following screenshot a default width of 70 pixels has been used. As not all pages fit into the available width, a horizontal scrolling is done.

TabControl

The default theme of APOXI allows to customize the properties for the default height, default width, minimum width, maximum width and clipped inside the class OptionalConfig. For the settings TabButtonDefaultHeight, TabButtonDefaultWidth, TabButtonMinimumWidth, TabButtonMaximumWidth and TabButtonClippedWidth a corresponding value must be returned for the method BOOLEAN OptionalConfig::GetSetting(INT group_id, INT setting_id, INT &result)

5.7.3 Custom Look

The look of the tab control including the tab buttons can be customized by implementing a custom view object for TabButtonView and TabControlView. A sample implementation is available under Apoxi/GlobalThemes/DefaultTheme/DefaultTabButtonView.* and Apoxi/GlobalThemes/DefaultTheme/DefaultTabControlView.*. See also Chapter 8: Themes for details how to implement views for a custom theme.

[ Previous: Items ] [ Next: Drawable Objects ]


6 Drawable Objects

A drawable object has the following characteristics:

  • has boundaries
  • can receive messages
  • can be drawn
In opposite to a control a drawable-object has no distinction between a frame-area and client-area, also a drawable-object can never get the focus.

6.1 TextLine

The TextLine represents a text aligned into a line, which may have a custom font, textformat and color.

6.2 AnimatedTextLine

The class AnimatedTextLine extends the class TextLine with the ability of text-scrolling, if the text does not fit into the given width.

6.3 TextBox

The TextBox represents a text aligned into a box, where an automatic wrapping of the text is done. The text may have a custom font, textformat and color. Note that if the text is too long to fit into the box, the text will be clipped at the bottom. If a scrollbar is needed and hence also an interaction with the user, the controls TextList or MultiLineEditor (used in read-only-mode) should be used.

6.4 ProgressBar

The ProgressBar indicates a percentual progress. The look may be adjusted by writing an own view as part of a theme. An available reference-implementation is available under Apoxi/GlobalThemes/DefaultTheme/DefaultProgressBarView.*

6.5 PositionIndicator

Indicates the position of a range, which is partly visible. The range is defined by a minimum value and a maximum value, the current position by a value. Additionally it must be defined, how many values can be visible. A position-indicator can be aligned horizontal or vertical.

The look may be adjusted by writing an own view as part of a theme. An available reference-implementation is available under:

  • Apoxi/GlobalThemes/DefaultTheme/DefaultPositionIndicatorView.*
  • Apoxi/GlobalThemes/FoggyTheme/FoggyPositionIndicatorView.*

6.6 ImageBox

An ImageBox contains any kind of image represented either by a bitmap-resource or an image-obtainer. A bitmap-resource is implemented by BitmapRes, an image-obtainer by the class ImageObtainer. It is strongly recommended to use the image box for displaying images, as if necessary the image box is capable of decoding the images in a separate thread. This assures that the application is not blocked during the decoding of an image.

6.6.1 BitmapRes

A bitmap-resource represents an internal bitmap of APOXI. Every bitmap-resource is organized in the same way as the display. This allows a very fast drawing but has the drawback of needing more memory than e. g. a JPEG-image. All bitmap-resources are generated by the APOXI-tool Resource-Compiler. See APOXI_Tools_ResourceCompiler.pdf for more details.

Example: A bitmap-resource is added to an image-box.

MyWindow.hpp
class MyWindow : public Window {
    typedef Window Base;

    public:
        void Init();

    private:
        ImageBox m_image_box;
};
MyWindow.cpp:
#include <Config/Resources/img1.hpp>

void MyWindow::Init()
{
    Base::Init();
    m_image_box.Init(this, &img1);
}

6.6.2 ImageObtainer

An image-obtainer may contain any instance of the class Image, which is the base for e. g. JPEG-images and GIF-images. An image-obtainer does a reference-counting, hence when all image-obtainers referring to one instance of an image are destructed and the image-obtainer has been initialized to obtain a disposable image, the image itself will get deleted too:

Example 1: An animation is added to an image-box. The delay between the frames is set to 200 milliseconds in this example.

MyWindow.hpp
class MyWindow : public Window {
    typedef Window Base;

    public:
        void Init();

    private:
        NativeImage m_native_img;
        ImageBox m_image_box;
};
MyWindow.cpp:
#include <Config/Resources/img1.hpp>		// bitmap-resource 1
#include <Config/Resources/img2.hpp>		// bitmap-resource 2
#include <Config/Resources/img3.hpp>		// bitmap-resource 3

const BitmapRes* const c_img_anim[] = { &img1, &img2, &img3 };

void MyWindow::Init()
{
    Base::Init();
    m_native_img.Init(c_img_anim, 3, 200);
    m_image_box.Init(this, ImageObtainer(&m_native_img));
}

Example 2: A JPEG-image is added to an image-box. A JPEG-image reads from a binary data stream, which is explained in detail in the next chapter.

MyWindow.hpp
class MyWindow : public Window {
    typedef Window Base;

    public:
        void Init();

    private:
        JpegImage m_jpeg_img;
        ImageBox m_image_box;
};
MyWindow.cpp:
void MyWindow::Init()
{
    Base::Init();

    // c_jpeg-data must point to a buffer containing the jpeg-data,
    // c_data_length provides the length of the data in bytes
    const RamData* ram_data = RamData::CreateInstance(c_jpeg_data, c_data_length);
    m_jpeg_img.Init(ram_data);
    m_image_box.Init(this, ImageObtainer(&m_jpeg_img));
}

As the examples show it is recommended to allocate an image-obtainer on the stack, because there is no need to keep the image-obtainer alive after passing it to an object which is responsible for the image.

6.6.3 Image Buffering

An image box offers the possibility to buffer images and animations for performance reasons. If an animation can not be buffered completely, the image box automatically tries to buffer at least two frames, which are necessary to display all kind of animations correctly. This means that the animation is decoded synchronously which might lead to a less responsive GUI. But also in this case it is always possible to interrupt the decoding at any time.

6.6.4 Binary Data

The JPEG-image and most other image classes may read the data of the image from a binary data stream, represented by the class BinData.

BinData defines an interface to access binary data in a way that releases the user from memory management. Usually an instance is created from one class but handled and obtained from another class. Therefor instances may not be constructed directly using a constructor. Any derived class provides a static method CreateInstance(…) to create an instance:

const RamData* ram_data = RamData::CreateInstance(c_jpeg_data, c_data_length);
After passing a pointer to a binary data to any object (e. g. to an instance of the class JpegImage), the binary data is obtained by this object per definition and hence the releasing of the binary data is done by the object itself by invoking ReleaseInstance(). Hence never release a binary data after passing it to another object.

Per default APOXI offers the following kind of binary data:

  • RamData: provides a BinData interface to a dynamically allocated or statically defined RAM memory area. Note that RamData does not touch the memory area itself when being destructed.
  • BufferedData: Extends the class RamData to provide an internal copy of the buffer passed by CreateInstance. The internal buffer is allocated in CreateInstance and destroyed in ReleaseInstance. Hence when using this class the application-programmer may delete its buffer immediatly after invoking CreateInstance because the buffer is copied to the internal buffer.
  • FileBinData: Allows to read from a file.

6.6.5 Synchronous Drawing

Usually applications like WAP and JAVA use a synchronous drawing mechanism (for the difference between synchronous drawing and asynchronous drawing have a look at chapter 7.3). The image-box draws itself in an asynchronous way, which makes it necessary to take care about some issues when the application does the drawing in a synchronous way.

As example for possible issues and how to solve them a WAP-application is chosen. A typical WAP-application has a kind of rendering-engine, which reads the WML-content and builds its own object model. The rendering-engine might also draw the content as soon as possible in a synchronous way. Usually APOXI device-context methods like DrawText() are used. When it comes to draw an image it is not recommended to use the method Image::Draw directly, as it blocks the rendering-engine and also does not take care about animations (see chapter 6.7.5 for details). Instead the following steps should be done:

  • Create an instance of the class ImageBox with the WAP-browser-window as parent.
  • Set the position and size of the image-box.
When the content must be rerendered because the size of the window has changed or the content had to be scrolled, the rendering-engine just has to assure that the position of the image-box is adjusted by invoking ImageBox::SetPos().

If a window A is opened above the WAP-browser-window, the WAP-browser-window will get invalidated if the window A will be closed. The invalidation results in invoking the method WapWindow::OnPaint. Per default in the method Window::OnPaint the embedded components (e. g. the image-boxes) are drawn. Usually the method OnPaint must be overwritten by the WAP-browser-window to trigger the redrawing of the content in a synchronous way. There are two solutions for doing this:

Solution 1:
void WapWindow::OnPaint(const Rect& repaint_rect)
{
    Window::OnPaint(repaint_rect);
    m_rendering_engine->TriggerRedraw(...);
}

Solution 1 clears the window-content and draws all embedded components (e. g. image-boxes) in Window::OnPaint(). Afterwards the rendering-engine is triggered to redraw its content. In this case it is important that the rendering-engine does not clear the area where APOXI-components are already redrawn. As the rendering-engine has created the embedded components and also has set the position, this should be no problem.

Solution 2:
void WapWindow::OnPaint(const Rect& repaint_rect)
{
    m_rendering_engine->TriggerRedraw(...);
    Window::OnPaint(repaint_rect);
}

In solution 2 the rendering-engine does the redrawing first and afterwards the embedded components are redrawn by Window::OnPaint. This allows the rendering-engine to clear variable areas without taking care about embedded components, as they are drawn later. It is important that when constructing an instance of the WAP-browser-window that the automatical clearing of the window-background is switched off by invoking Window::SetAutoClearEnabled(FALSE), otherwise the drawn content from the rendering-engine would be cleared in Window::OnPaint().

6.6.6 Using Image::ConvertToBitmap and Image::Draw

As already mentioned it is strongly recommended to use the image box for drawing images. Especially the correct displaying of transparent GIF-animations in a non-blocking way can get very difficult when using the image-classes directly by invoking Image::ConvertToBitmap() or Image::Draw(). Anyway there might be situations where it is useful to display images without using an image box.

In APOXI the decoding and drawing of an image is done, when invoking the method Image::Draw(). It is important to be aware about the fact, that while decoding the image other applications inside the same application-container (represented by a thread) are blocked until the decoding has been finished. This is no problem for small images, which need only some milliseconds to decode, but it is not acceptable when having large images. The recommended way to solve this issue is to convert the image to a bitmap by the method Image::ConvertToBitmap(). When invoking this method, the image is decoded by the APOXI Worker Thread and converted to a bitmap. The APOXI Worker Thread is a thread which may get variable tasks from APOXI. When invoking Image::ConvertToBitmap() the application will be informed about the progress of the decoding by the message ImageDecodingProgressMsg, which contains the progress. The decoding has been finished, if the progress has reached the value 100. It is recommended to give the user a visual feedback about the progress by using the drawable object ProgressBar or show the current state of the bitmap when getting the message ImageDecodingProgressMsg.

Example: a JPEG-image is converted into a bitmap by the worker-thread. The progress of the converting is shown by displaying the bitmap in the method OnPaint(). It would also be possible to use a progress-bar, which must be set when catching the message ImageDecodingProgressMsg.

MyWindow.hpp
class MyWindow : public Window {
     typedef Window Base;
    public:
        void Init();
    protected:
        virtual void OnOpen();
        virtual void OnClose();
        virtual BOOLEAN OnMessage(const Message& msg);
        virtual void OnPaint(const Rect& repaint_rect);
    private:
        JpegImage m_image;
        Bitmap* m_conv_bmp;
};
MyWindow.cpp
#include "MyWindow.hpp"
void MyWindow::Init()
{
    Base::Init()
    m_image.Init(...);
    m_conv_img = 0;
}

void MyWindow::OnOpen()
{
    Base::OnOpen();
    GetApplication()->RegisterMessage(ImageDecodingProgressMsg::ID);
    m_conv_bmp = new Bitmap(100, 50);

    if ((m_conv_bmp != 0) && m_conv_bmp->IsValid())
        m_image->ConvertToBitmap(&m_conv_bmp, 0, FALSE);
}

void MyWindow::OnClose()
{
    GetApplication()->UnregisterMessage(ImageDecodingProgressMsg::ID);
    m_image.StopDecoding();
    delete m_conv_bmp;
    m_conv_bmp = 0;
    Base::OnClose();
}

BOOLEAN MyWindow::OnMessage(const Message& msg)
{
    BOOLEAN dispatched = FALSE;
    if (msg.Id() == ImageDecodingProgressMsg::ID) {
        ImageDecodingProgressMsg* progress_msg;
        CastMsg(progress_msg, &msg);
        if (progress_msg->GetImage() == &m_image) {
           // trigger a redraw of the window
           Invalidate();
           // If a progress-bar should be used, the
           // progress could be set by
           // m_progress_bar.SetProgress(progress_msg->GetProgress());
           // and no invalidate is needed.
           dispatched = TRUE;
        }
    }

    if (!dispatched)
        dispatched = Base::OnMessage(msg);

    return dispatched;
}

void MyWindow::OnPaint(const Rect& repaint_rect)
{
    Base::OnPaint(repaint_rect);
    if (m_conv_bmp != 0) {
         PaintDc pdc(GetDeviceContext());
         pdc.DrawBitmap(0, 0, *m_conv_bmp);
    }
}

Before deleting the image or the bitmap it must be assured, that the decoding is stopped when the method ConvertToBitmap has been invoked before. This is done by m_image.StopDecoding(). Alternatively it would have been possible to invoke m_image.WaitUntilDecodingIsFinished(), which waits until the decoding is finished but does not block the message-flow of applications. It is also possible to ask the image whether it is decoded currently by invoking the method IsCurrentlyDecoded.

6.7 Implementation of a Customized Drawable Object

A drawable object should be created, which draws a rectangle with the text "MyDrawableObject" as content.

MyDrawableObject.hpp
class MyDrawableObjectView : public DrawableObjectView {
    public:
        MyDrawableObjectView();
        virtual ~MyDrawableObjectView();
        virtual void Draw(const Component& component, DeviceContext* dc,
            const Rect& repaint_rect) const;
};

class MyDrawableObject : public DrawableObject {
    public:
        MyDrawableObject(Control* parent);
        virtual ~MyDrawableObject();
        const WCHAR* GetText() const { return L"MyDrawableObject"; }

    private:
        static MyDrawableObjectView m_view;
};
MyDrawableObject.cpp:
MyDrawableObjectView MyDrawableObject::m_view;

MyDrawableObjectView::MyDrawableObjectView () :
    DrawableObjectView(70, 20)
{
}

MyDrawableObjectView::~MyDrawableObjectView ()
{
}

void MyDrawableObjectView:: Draw(const Component& component, DeviceContext* dc,
    const Rect& repaint_rect) const
{
    const MyDrawableObject& my_obj = (const MyDrawableObject&)component;

    PaintDc pdc(dc);
    pdc.SetPenColor(Color::ClientForeground);
    pdc.DrawRect(my_obj.GetBoundingRect());
    pdc.DrawText(my_obj.GetLeft(), my_obj.GetTop(), my_obj.GetText());
}

MyDrawableObject::MyDrawableObject(Control* parent) :
    DrawableObject(parent, TRUE, &m_view)
{
}

MyDrawableObject::~MyDrawableObject()
{
}

Some notes to the implementation:

  • When initializing a view, the default height and default width may be provided by the constructor. These parameters are respected when e. g. using the Layouter in Control::OnLayoutClient(). In the implementation of MyDrawableObjectView the drawable object has a default width of 70 and a default height of 20. A width and height of -1 indicate no default setting and allow a stretching.
  • When implementing the method Draw of the view, it is useful to cast the input-parameter component to the corresponding class to have full access to the object. Note that the provided device-context dc is the device-context of the parent-control of the drawable-object, hence the coordinates when doing the drawing are relative to the parent-control.
  • When initializing a drawable-object, a pointer to the view-object must be provided in the constructor.

[ Previous: Controls ] [ Next: Device Context ]


7 Device Context

All drawing operations in APOXI are done on the device context, which is represented by the class DeviceContext. A device-context offers methods for drawing lines, rectangles, text and much more. All drawing methods use the current set color, text-format and other attributes which may be modified for each instance of the class DeviceContext.

All operations on a device-context must be encapsulated between BeginUpdate() and EndUpdate():

DeviceContext *dc = ...;
dc->BeginUpdate();
dc->SetTextAttr(TextFormat::Bold);
dc->DrawText(5, 10, L"Hello world");
dc->SetPenColorRgb(255, 0, 0);          // set pen color to red
dc->DrawLine(5, 10, 100, 100);
dc->SetBrushColorRgb(255, 255, 0);      // set brush color to yellow
dc->FillRect(5, 10, 20, 20);
dc->EndUpdate();

7.1 PaintDc

The default way in APOXI to do some drawing on a device-context is the following:

MyWindow.hpp
#include <Gui/Window.hpp>

class MyWindow : public Window {
    protected:
        virtual void OnPaint(const Rect& repaint_rect);
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::OnPaint(const Rect& repaint_rect)
{
    Window::OnPaint(repaint_rect);

    PaintDc pdc(GetDeviceContext());
    pdc.DrawText(5, 10, L"Hello world");
    pdc.SetPenColorRgb(255, 0, 0);     // set pen color to red
    pdc.DrawLine(5, 10, 100, 100);
    pdc.SetBrushColorRgb(255, 255, 0); // set brush color to yellow
    pdc.FillRect(5, 10, 20, 20);
}

The class PaintDc is derived from the class DeviceContext and offers a comfortable way to draw on a device-context without side-effects. When constructing the paint-device-context the method DeviceContext::BeginUpdate() is invoked automatically, when destructing DeviceContext::EndUpdate() is invoked.

7.2 BitmapDc

APOXI allows to draw inside a bitmap by using a bitmap-device-context represented by the class BitmapDc. Example:

Bitmap* bmp = ...;
BitmapDc bmp_dc(bmp);
bmp_dc.BeginUpdate();
// it is recommended to initialize the bitmap with the
// wanted background color first
bmp_dc.SetBrushColor(Color::ClientBackground);
bmp_dc.FillRect(0, 0, bmp->GetWidth() - 1, bmp->GetHeight() - 1);

// now the content of the bitmap can be drawn
bmp_dc->DrawLine(...);
...
bmp_dc->EndUpdate();

To show the bitmap it must be painted in Window::OnPaint() or automatically by embedding it into the drawable object ImageBox.

7.3 Asynchronous vs. Synchronous Drawing

The difference between asynchronous drawing and synchronous drawing is very important for applications which take care themselves about drawing the content of their window without using the APOXI-components like TextBox or ImageBox. Typical applications are a WAP-browser or the JAVA-engine.

7.3.1 Asynchronous Drawing

Usually the drawing in APOXI is done asynchronously, which means that an area of a window will be marked as invalid by invoking the method Window::Invalidate() and in the next idle-state APOXI will do a redraw of all invalid areas by invoking Window::OnPaint(), where the drawing of the window-content is done on a device-context. The asynchronous drawing has the benefit, that multiple invalidations are collected before any drawing is done which usually reduces the number of necessary drawing operations.

Example: A window uses the drawable object TextBox for drawing a text.
m_text_box.SetText(L"Abc");
...
m_text_box.SetText(L"Xyz");
When invoking TextBox::SetText just the state of the textbox is changed and the window containing the textbox is invalidated. No drawing is done when invoking TextBox::SetText. So invoking this method two times just results in two invalidations, the drawing itself is done after the thread gets idle and recognizes invalid areas of windows.

7.3.2 Synchronous Drawing

Synchronous drawing means, that the drawing on a device-context is not done in the method Window::OnPaint() but for example in other methods like Window::OnKeyDown the following way:

BOOLEAN MyWindow::OnKeyDown(KeyCode key_code)
{
    BOOLEAN dispatched = TRUE;
    if (key_code == KeyboardConfig::GetArrowUp()) {
        SyncPaintDc pdc(GetDeviceContext());
        pdc.SetPenColorRgb(255, 0, 0);
        pdc.DrawLine(0, 0, 100, 50);
    }
    else
        dispatched = Window::OnKeyDown(key_code);

    return dispatched;
}

It is required to use an instance of the class SyncPaintDc as device-context for synchronous drawing. The synchronous device-context takes care about locking the access to the display by other applications until the destructor has been invoked.

Some hints:

  • If the client-area of a window is completely filled by synchronous drawing, it is recommended to turn off the auto-clearing of the client-area after invalidation by invoking the method Control::SetAutoClearEnabled(FALSE)
  • When the method Control::OnPaint is invoked, an area of the control has been marked as invalid before. It is recommended to trigger the synchronous drawing mechanism in this case to update the content

7.4 Hints

The following chapter gives some hints regarding how to use some methods of the class DeviceContext.

7.4.1 Clipping

Per default APOXI assures that the clipping rectangle of a device context is set in an optimized manner. This means when only parts of a window are invalidated, the clipping rectangle of the device context used inside Window::OnPaint is already set to the invalidated area and not to the whole client area of the window. The application developer does not need to care about doing further optimizations.

If a custom clipping is still required, it is strongly recommended to intersect the custom clipping rectangle with the already optimized clipping rectangle. This assures the best possible performance and prevents that e. g. other components are overdrawn accidently. Assuming that a custom clipping rectangle should be set from the upper left position 10/10 to the lower right position 90/40 the following code is correct:

PaintDc pdc(GetDeviceContext());

const Rect custom_clip_rect(10, 10, 90, 40);
Rect clip_rect(pdc.GetClipRect());
clip_rect.Intersect(custom_clip_rect);
pdc.SetClipRect(clip_rect);

// the clipping rectangle is now intersected with the custom
// clipping rectangle and any drawing can be done now
pdc.DrawText(...);

7.4.2 Alpha blending

APOXI allows to define an alpha value for a color. When a graphical operation is done with this color, a mixing of the color with the already existing background is done. Example: a green rectangle with an alpha value of 128 is drawn above a bitmap:

Alpha Blending
PaintDc pdc(GetDeviceContext());
pdc.DrawBitmap(30, 30, bitmap);
pdc.SetBrushColorRgb(36, 221, 62, 128);
pdc.FillRect(20, 20, 90, 90);

Alpha blending requires a lot of performance and should be used with care.

[ Previous: Drawable Objects ] [ Next: Themes ]


8 Themes

APOXI allows having a variable number of themes, which define the look of the used components like windows, push-buttons, softkeybars etc. Per default APOXI offers the themes Default Theme and Foggy Theme, which are located in Apoxi/GlobalThemes. To use a theme, it must be embedded into the implementation of the class ThemeConfig, which specifies the theme-configuration.

A theme-configuration using the themes Default Theme and Foggy Theme could look like this (the file ThemeConfig.cpp is located in the folder Config of the MMI-project):

ThemeConfig.cpp

#include "ThemeConfig.hpp"
#include <GlobalThemes/DefaultTheme/DefaultTheme.hpp>
#include <GlobalThemes/FoggyTheme/FoggyTheme.hpp>

const Theme& ThemeConfig::GetTheme(INT index)
{
    return (index == 0) ? DefaultTheme::GetInstance() : FoggyTheme::GetInstance();
}

INT ThemeConfig::GetThemeCount()
{
    return 2;
}

INT ThemeConfig::GetFontId(SystemFontId id, const Theme& theme)
{
    return 0;
}

8.1 Creating a New Theme

When creating a new theme, the following steps are necessary:

  • A class derived from Theme (e. g. MyTheme), must be implemented. The implementations for Default Theme and Foggy Theme of APOXI may be a reference.
  • This class MyTheme must be referenced by implementing the methods ThemeConfig::GetTheme and ThemeConfig::GetThemeCount.

8.2 Implementing a View

All components of APOXI delegate the drawing to their view-object. All instances of a component may share one instance of a view. For example one instance of the pushbutton-view is owned by the Default Theme and all instances of a pushbutton will use this instance for drawing themselfes:

The class Theme offers an abstract method GetPushButtonView(), which must return a pointer to an instance of the class PushButtonView. A derived class from PushButtonView might look like this:

MyPushButtonView.hpp
#include <Gui/PushButton.hpp>

class MyPushButtonView : public PushButtonView {
    public:
        MyPushButtonView();
        virtual ~MyPushButtonView();

    protected:
        virtual void DrawPushButton(const PushButton& push_button,
            DeviceContext* dc, const Rect& repaint_rect) const;
};
MyPushButtonView.cpp
#include "DefaultPushButtonView.hpp"
#include <Gui/PaintDc.hpp>

MyPushButtonView::MyPushButtonView()
{
}

MyPushButtonView::~MyPushButtonView()
{
}

void MyPushButtonView::DrawPushButton(const PushButton& push_button,
    DeviceContext* dc, const Rect& repaint_rect) const
{
    PaintDc pdc(dc);

    // set color of background
    if (push_button.IsPressed())
        pdc.SetBrushColorRgb(200, 200, 200);
    else
        pdc.SetBrushColorRgb(120, 120, 120);

    // draw filled background rectangle
    XYDIM width = push_button.GetClientWidth();
    XYDIM height = push_button.GetClientHeight();
    pdc.FillRect(0, 0, width - 1, height - 1);

    // draw text
    pdc.DrawTextBox(Rect(0, 0, width - 1, height - 1),
        push_button.GetAction()->GetText());
}
[ Previous: Device Context ] [ Next: Multilingual Support ]


9 Multilingual Support

In general, the usage of hardcoded strings should be avoided, as many applications have to be shipped supporting different languages.

9.1 Using Tr()

The programmer simply has to pass all texts to the Tr()-method ("Translate") before displaying them or passing them to components. So instead of handing over a hardcoded string like "Main Menu" as input-parameter…

m_menu.Init(this, L"Main Menu");
...just embed the string into Tr():
m_menu.Init(this, Tr(L"Main Menu"));
The translate method performs a fast lookup within the current translation table and returns the text string (translation) corresponding to the argument. Tr() will simply return it's argument, if no translation table is provided. This means that an application will run just fine even if there are no translation tables. The translation table can be generated with the APOXI Language Tool.

As a thumb rule: use Tr() only with English strings, as English will represent the key-column in the language table . The key-column in the translation-table is the first column and is sorted alphabetically.

Example for a wrong usage: given is a language table which provides the languages English and German. Each language represents one column, where English is the key-column. If the active language is set to English, a Tr(L"Main Menu") returns "Main Menu". If German is used as active language, Tr(L"Main Menu") returns "Hauptmenü". It's important to know, that Tr(L"Hauptmenü") does not return "Main Menu" when the active language is set to English. This is because the input-parameter "Hauptmenü" is not part of the key-column of the language-table. For this case ReTranslate() must be used, which usually is just needed if the language is changed during runtime and the message LanguageChangedMsg is broadcasted.

9.2 Using ReTranslate()

When the language is changed during runtime by LanguageManager::SetLanguage(…), APOXI broadcasts the message LanguageChangedMsg to all applications. All components offer the method OnLanguageChanged, which is triggered by this message. When having a pointer to a string, which has been translated by Tr, it can be retranslated to any other language by invoking ReTranslate. This means that in opposite to Tr the method ReTranslate may get any string which is part of the translation table, not only strings from the key-column.

This comfortable usage has the drawback of being a very expensive operation. Hence it is recommended to use the method ReTranslate only inside the method OnLanguageChanged and not for initalizing components.

Please note that the retranslation cannot work for merged strings:

// current set language is German, m_text is a WString
m_text = Tr(L"Main Menu");   // "Hauptmenü" is returned
m_text << L"(2/10)";         // m_text contains "Hauptmenü (2/10)"
...
// language is changed to English from outside
LanguageManager::SetLanguage(english_id);
...
void ...::OnLanguageChanged()
{
    ...
    m_text = ReTranslate(m_text);    // does not work: the string "Hauptmenü (2/10)"
                                     // is not part of the translation table!
}

In this case OnLanguageChanged must look like this:

void ...::OnLanguageChanged()
{
    ...
    m_text = Tr(L"Main Menu") << L"(2/10");
}

Per default all APOXI-components having a text use ReTranslate in the implementation of OnLanguageChanged. Please take this into account when developing applications which use merged strings.

9.3 Initialization

The method System::InitLanguage(…) should be invoked, before the first invokement of Tr or ReTranslate. By invoking this method APOXI is informed about the current active language. It is recommended to invoke System::InitLanguage(…) in the method OnOpen of the main-application in MMI, which is started as first application. If this is not done, APOXI assumes that the used language is the first column of the translation table, which usually means English.

9.4 Non-Latin Scripts

APOXI supports bidirectional languages like Arabic and Hebrew, as well as languages which use a wide unicode range (e.g. Chinese) or are complex (e.g. with regard to diacritics like Thai). This chapter explains how to integrate the fonts for such languages into the APOXI-configuration.

9.4.1 General Tips

  • For testing APOXI language support: To easily generate an APOXI font which supports a wide range of characters, it is recommended to use the "Arial Unicode MS" font, which is installed together with some Microsoft products (e.g. Office). This font implements glyphs for most of the Unicode code pages.
  • The list of Unicode code pages can be found on the WWW page of the Unicode consortium: characters and symbols and punctuation.

9.4.2 Fonts

The APOXI Resource Compiler may generate fonts which cover the whole unicode-range, so that any kind of language can be displayed by using such a font. Because of the high memory demand and the fact, that a mobile phone will only support a subrange of all possible languages, this does not make sense. Hence it is important to generate a font, which covers the unicode-range of the selectable languages. This can be achieved by editing the file resources.xml and generate an APOXI-font with the APOXI Resource Compiler.

9.4.2.1 Thai

To handle Thai characters the following tags in resources.xml might be used (the range from 3585 to 3675 handles Thai glyphs):

<font>
    <output_folder>Config/Resources</output_folder>
    <infile>XxxFont</infile>
    <outfile>DefaultFont</outfile>
    <varname>default_font</varname>
    <range from="20" to="255"/>
    <range from="3585" to="3675"/>
    <size height="14"/>
    <unicodeunknown>32</unicodeunknown>
    <gap>0</gap>
</font>

9.4.2.2 Chinese

When chinese characters are needed, just

    <range from="19968" to="40959"/>
must be added into the font-tag. Further documentation is given in the document ResourceCompiler.pdf.

9.4.2.3 Japanese

Additionally to Kanji characters (i.e. the Unified CJK Ideographs also used for Chinese, above) there are two more syllabaries and some punctuation characters to be considered for Japanese.
    <!-- Japanese -->
        <!-- General Punctuation -->
    <range from="8216" to="8217"/>
    <range from="8220" to="8221"/>
    <range from="8240" to="8240"/>
    <range from="8242" to="8243"/>
        <!-- Letterlike Symbols -->
    <range from="8451" to="8451"/>
    <range from="8457" to="8457"/>
        <!-- CJK Symbols and Punctuation -->
    <range from="12289" to="12351"/>
        <!-- Hiragana -->
    <range from="12353" to="12447"/>
        <!-- Katakana -->
    <range from="12448" to="12543"/>
        <!-- Halfwidth and Fullwidth Forms -->
    <range from="65281" to="65518"/>

9.4.2.4 Arabic

Arabic resembles cursive writing even on computer terminals. This means that the shape of (some) characters changes according to their position within the word. Characters that do so are called binding letters. All characters have an Isolated form, however, if a letter is a binding letter, it also has a Final (at the end of word), Medial (within a word), and Initial (start of word) form. These are collectively known as presentation forms. The isolated forms are defined in the Arabic Unicode code page, while the other forms are defined in Arabic Presentation Forms A and Arabic Presentation Forms B. Farsi (Arabic script used in Iran) and Urdu (used in India) are also covered in Presentation Forms A and B. For African languages that are written with the Arabic script, there is the Arabic Supplement codepage. Thus, to get the collection of (non-African) Arabic characters, the range configuration in resources.xml must look something like this:

    <!-- Arabic (also for Urdu, Farsi) -->
    <range from="1569" to="1610"/>
    <range from="1632" to="1748"/>
    <range from="64336" to="64489"/>
    <range from="65152" to="65276"/>

9.4.2.5 Vietnamese

Besides using the usual Latin characters, characters required for Vietnamese are widely strewn throughout many Unicode code pages (C0 Controls and Basic Latin, C1 Controls and Latin-1 Supplement, Latin Extended-A, Latin Extended-B, and Latin Extended Additional). To simplify generating a font capable of displaying all characters, the ranges are listed below.

    <!-- Standard Latin -->
    <range from="20" to="255"/>

    <!-- Vietnamese additional to Latin -->
    <range from="258" to="259"/>
    <range from="272" to="273"/>
    <range from="296" to="297"/>
    <range from="360" to="361"/>
    <range from="416" to="417"/>
    <range from="431" to="432"/>
    <range from="768" to="771"/>
    <range from="774" to="774"/>
    <range from="777" to="777"/>
    <range from="795" to="795"/>
    <range from="803" to="803"/>
    <range from="7840" to="7929"/>

9.4.3 FontConfig

APOXI accesses to the font-configuration by the class FontConfig, which is implemented by FontConfig.cpp. Usually this file is located in the Config-directory of the MMI-project and may be adjusted to the required needs.

As APOXI allows having a variable number of fonts, it is recommended that each font supports all selectable languages. This makes it easy for applications to use an available font without taking care, which language is currently activated. If this approach would require too much memory (e. g. having 10 fonts where each font covers the chinese unicode-range), the applications must take care themselves to respect the selected language and use the font which covers the needed unicode-range. When the applications just use system-fonts, this can be done automatically by implementing the method ThemeConfig::GetFontId() of the file ThemeConfig.cpp (it is located in the folder Config of the MMI-project):

INT ThemeConfig::GetFontId(SystemFontId id, const Theme& theme)
{
    // the input-parameters in this implementation are ignored, but they
    // can be used for a more granular solution
    INT font_id = 0;     // use default font
    if (LanguageManager::GetActiveLanguageType() == LanguageManager::Thai)
        font_id = 1;     // assumed that this font covers Thai
    else if (LanguageManager::GetActiveLanguageType() == LanguageManager::Chinese)
        font_id = 2;     // assumed that this font covers Chinese
    return font_id;
}

9.4.4 Locale Settings

APOXI supports locale settings to have:

  • a specified date- and time-format
  • a decimal-separator
  • a thousands-separator
  • a currency symbol
  • a language
  • text-alignment (left-to-right or right-to-left)

When switching to another language by invoking System::SetLanguage(), only the language of the locale settings is changed (see documentation to the class Locale for the offered interfaces). This means that when switching to the the Arabic language by invoking System::SetLanguage() the text-aligment won't be changed automatically by APOXI, as this must be decided on the application-level (e. g. it would be possible, that the wished text-alignment should still be left-to-right, even Arabic is selected).

It is recommended to offer one locale-setting for each language, so when changing a language in the MMI, the following code will work:

INT lang_id = ...;		// selected language ID by the user
System::SetLanguage(lang_id);
Locale::Set(LocaleConfig::GetSetting(lang_id));

The class Locale, represented by the file LocaleConfig.cpp, does not force to have one locale setting for each language (e. g. it would be possible that one locale-setting would fit for a variable number of languages), but using one locale setting per language does not take much resources and allows an easy implementation for the MMI to select a language and adjust the locale settings.

9.4.5 Hints

  • The font of a multiline editor may be changed by invoking MultiLineEditor::SetFont(). If not all fonts support the glyphs of all possible languages, this font must be adjusted when the language is changed. Otherwise those glyphs may be shown as 'invalid glyphs', which usually are represented as space or as a square.
  • When using the multimedia editor, which allows to have richtext compound items, it also is important to check whether the used font of a richtext compound item is able to display all glyphs of the currently used language.
  • When custom controls or drawable-objects have to be implemented, the text-alignment should be respected. If the text-alignment is switched from left-to-right to right-to-left, the output of the text will be done on the left side of the given x-coordinate instead of the right side. The following code-snipplet shows, how this should might be handled:
    #include <Locale/LocaleConfig.hpp>

...

XYDIM y = ...;
XYDIM x = ...;

if (Locale::GetTextAlignment() == Locale::RightToLeft)
    x = GetClientWidth() - x;

PaintDc pdc(GetDeviceContext());
pdc.DrawText(x, y, L"Text");
  • It is recommended to use the class Layouter when overwriting the method Control::OnLayoutClient() to layout the components inside a control. This has the benefit that horizontally aligned cells are flipped automatically when the the alignment is changed to right-to-left.

9.5 Advance Translation Support

Since APOXI-2.7 a new feature is available which increases the performance of retranslating strings. The feature can be turned on by defining APOXI_ENABLE_ADVANCED_TRANSLATION and requires to regenerate the language translation table by the new APOXI Language Tool (the checkbox 'Advanced translation' must be set).

If the feature is not activated, 100 % backward compatibility with the classic format is given. When activating the feature, following adaptions have to be done:

  • The method MemoryConfig::IsInRom (located in Config/MemoryConfig.cpp) should be implemented like this:
    #include "LanguageRes.hpp"

BOOLEAN MemoryConfig::IsInRom(const void* ptr)
{
#if defined(APOXI_ENABLE_ADVANCED_TRANSLATION)
  return (ptr >= (const void*)c_translations) && (ptr <= (const void*)c_translations_end);
#else
  return FALSE;
#endif
}
  • The method LocaleConfig::GetLanguageCount (located in Config/LocaleConfig.cpp) should be implemented like this:
    INT LocaleConfig::GetLanguageCount()
{
#if defined(APOXI_ENABLE_ADVANCED_TRANSLATION)
  return c_language_count; // defined inside the generated file LanguageRes.hpp
#else
  return N_LANGUAGES;  // defined inside the generated file LanguageRes.hpp
#endif
}

The methods GetTranslationTable and GetStringCount from the class LocaleConfig (located in the config directory of the project) are not used by APOXI anymore and may get deleted or implemented in a way that 0 is returned.

Benefits:
  • The runtime complexity in the classic version to retranslate a string was s * l (where 's' is the number of strings and 'l' the number of languages). With the new translation table format the runtime complexity is 1 and means that a retranslation is as fast as the translation itself.
  • As the method MemoryConfig::IsInRom returns TRUE for all strings located in the language table, the strings are not copied anymore to the RAM dynamically when using WStrings. This reduces the heap demand a lot and improves the general performance of the MMI.
  • If more than 2 languages are used, the ROM demand decreases up to 1 byte per translated word in comparison to the old format.
Drawback:
  • The advanced translation table does not work on E-Gold platforms.
[ Previous: Themes ] [ Next: Aragon ]


10 Aragon

The GUI editor called APOXI Aragon Tool generates resource files which can be read out by APOXI GUI objects to initialize their properties themselves. The benefits of this approach are:

  • The behavior in applications is strictly separated from the look and layout of GUI objects.
  • The code of an application does not need to be changed, if the look or layout of GUI objects is modified.
  • The code size is decreased, as the resource file usually is smaller than the coded counterpart.
Drawbacks:
  • Not everything what can be solved with code can be described within a resource file.
  • Decreased performance, as the parsing requires some time.

10.1 Creating GUI Objects

One resource file might contain a variable number of GUI objects and images. Usually it makes sense to embedd all GUI objects and images belonging to one application into one resource file, but it is also possible to use several resource files for one application.

Example: Given is a resource file named "my_app_resources.rc" containing three windows and one JPEG image. Each GUI object which is part of the resource files gets a unique ID. In this example the ID for the first window is 100, for the second 200 and for the third 300 (the IDs can be assigned with the GUI editor). Creating and opening the window 1 can be done the following way:

Window* win = (Window*)ResourceManager::GetInstance().Construct(L"/ffs/my_app_resources.rc!100");
if (win != 0) {
    win->OpenModal();

The class ResourceManager is a singleton which is able to construct any GUI object out of a given resource file. For every call to Construct, a new object is created. Note that the ID of the object is added after the name of the resource file by !100.

10.2 Interacting with Created Objects

The created window 1 may contain a variable number of embedded GUI objects like e. g. a line editor, textlines or image boxes. Those GUI objects are described inside the resource file and have been created with the GUI editor. To interact with them the object ID is the key: each GUI object gets a unique ID assigned inside the GUI editor. Assuming that window 1 contains two line editors with the ID 101 and 102 the content of those editors can be read out the following way:

Window* win = (Window*)ResourceManager::GetInstance().Construct(L"/ffs/my_app_resources.rc!100");
if (win != 0) {
    win->OpenModal();

    const LineEditor* editor1 = (LineEditor*)win->GetComponent(101);
    const WString& text1 = editor1->GetText();

    const LineEditor* editor2 = (LineEditor*)win->GetComponent(102);
    const WString& text2 = editor2->GetText();
}

10.3 Destructing Created Objects

The ResourceManager internally keeps a list of created objects, hence when invoking

ResourceManager::GetInstance().Destruct(L"/ffs/my_app_resources.rc!100");

all the object specified by this URI will be destructed. To destroy only a single instance created from this URI, the destruct method must also receive the object as the second parameter:

Window* win = (Window*)ResourceManager::GetInstance().Construct(L"/ffs/my_app_resources.rc!100");
...
...
...
ResourceManager::GetInstance().Destruct(L"/ffs/my_app_resources.rc!100", (void*)win);
As this method presents a clear and present danger to inadvertedly delete more objects than really intended, this particular method has been marked as deprecated. The new, safer method for destructing an object and its associated objects only receives the object as the parameter:
Window* win = (Window*)ResourceManager::GetInstance().Construct(L"/ffs/my_app_resources.rc!100");
...
...
...
ResourceManager::GetInstance().Destruct((void*)win);
It is important that no other objects refer to this object anymore. For example an instance of the class window must be closed first before destructing it. Otherwise the application the window belongs to would access an already destructed object.

10.4 Accessing Embedded Images

In the example mentioned in 10.1 one GUI object is a JPEG image. Assuming that the image has the object ID 400, this image can assigned to an image box (in the example represented by m_image_box) the following way:

ImageObtainer* img_obtainer = (ImageObtainer*)ResourceManager::GetInstance().Construct(L"/ffs/my_app_resources.rc!400");
if (img_obtainer != 0)
    m_image_box.SetImageObtainer(*img_obtainer);
But it is also possible that the image box is already a resource (e. g. and has the object ID 401) and internally accesses to the image with the object ID 400:
ImageBox* img_box = (ImageBox*)ResourceManager::GetInstance().Construct(L"/ffs/my_app_resources.rc!401");

In the GUI editor the image property of the image box is specified by the object ID 400. This is hidden for the application in this case.

10.5 Extending the GuiObjectFactory

10.5.1 Adding new ClassTypes

If you want to add new classes that need to be generated by the GuiObjectFactory, a series of steps must be executed:

  1. Add a new entry at the end of the ClassType enum in GuiObjectFactory.hpp. Custom class types start with 2000:
    Before:
    enum ClassType {
    UnknownClassType = 255,
    ObjectReference = 0,
    ...
    PredefinedClassTypesCount = 68,			// number of class types that have been defined by APOXI
    ProgressPropertyDescriptorClassType = 2000,
    PasswordPropertyDescriptorClassType = 2001,
    // add new custom class types here and increase the next enum value accordingly
    CustomDefinedClassTypesCount = 2002		// one higher than the last customer defined class type
}
    After:
    enum ClassType {
    UnknownClassType = 255,
    ObjectReference = 0,
    ...
    PredefinedClassTypesCount = 68,			// number of class types that have been defined by APOXI
    ProgressPropertyDescriptorClassType = 2000,
    PasswordPropertyDescriptorClassType = 2001,
    NewClassType = 2002,
    // add new custom class types here and increase the next enum value accordingly
    CustomDefinedClassTypesCount = 2003		// one higher than the last customer defined class type
}
  2. In the ::Create(...) method in GuiObjectFactory.cpp, add the calls to create the class and to call its SetProperty method.
  3. In the ::Destroy(...) method in GuiObjectFactory.cpp, add the call to delete the object.
  4. If your object uses forward referencing in the resource file, i.e. referencing objects that are created after the rest of the object's properties are read, then add the setting of the affected property in the ::Finalize(...) method.

10.5.2 Adding new PropertyIDs

If you want to add new properties that can be set by ARAGON, please follow the steps below:

  1. Add a new entry at the end of the PropertyId enum in GuiObjectFactory.hpp. Custom property IDs start with 2000:
    Before:
    enum ClassType {
    UnknownClassType = 255,
    ObjectReference = 0,
    ...
    PredefinedPropCount = 133,		// number of property IDs that have been defined by APOXI
    // add new custom property IDs here and increase the next enum value accordingly
    CustomDefinedPropCount = 2000		// one higher than the last customer defined property count
}
    After:
    enum ClassType {
    UnknownClassType = 255,
    ObjectReference = 0,
    ...
    PredefinedPropCount = 133,		// number of property IDs that have been defined by APOXI
    NewProp = 2000,
    // add new custom property IDs here and increase the next enum value accordingly
    CustomDefinedPropCount = 2001		// one higher than the last customer defined property count
}
  2. In order for the ResourceParser to parse the new property, it must know of what type this property is. This is set in the GuiObjectFactory::MapPropertyIdToParseType(...) method. If the NewProp defined above is e.g. a UINT8 property, add it to the appropriate case block in the big switch statement. Before:
        // UINT8 properties:
    case GuiObjectFactory::TopLineGapProp:
    case GuiObjectFactory::BottomLineGapProp:
    case GuiObjectFactory::FocusPriorityProp:
    case GuiObjectFactory::FrameLayoutHintProp:
        return GuiObjectFactory::UInt8Type;
    After:
        // UINT8 properties:
    case GuiObjectFactory::TopLineGapProp:
    case GuiObjectFactory::BottomLineGapProp:
    case GuiObjectFactory::FocusPriorityProp:
    case GuiObjectFactory::FrameLayoutHintProp:
    case GuiObjectFactory::NewProp:
        return GuiObjectFactory::UInt8Type;

10.5.3 Adding new parsing types

If a new property was added that the ResourceParser cannot parse (e.g. structs), the GuiObjectFactory can be extended to read those, without the need to extend the ResourceParser itself. This can be achieved as follows:

  1. Assume that a new class has been created (NewClass), which contains a struct:
    struct NewClassProps {
    WString m_wstring;
    UINT16 m_uint16;
}
  2. Add a new ParsingType to the GuiObjectFactory.
    Before:
    enum ParseType {
    UnknownType,
    ...,
    TextIconPairType,
    AlignInfoPropsType
};
    After:
    enum ParseType {
    UnknownType,
    ...,
    TextIconPairType,
    AlignInfoPropsType,
    NewClassPropsType
};
  3. Add a new ClassType as described above (i.e. the ClassTypes enum will then contain a NewClassType value).
  4. Add a new PropertyId as described above (i.e. the PropertyId enum will then contain a NewClassProps value, and the GuiObjectFactory::MapPropertyIdToParseType(...) contains an entry that will map the NewClassProps to NewClassPropsType).
  5. Implement the parsing of the NewClassProps in GuiObjectFactory::GetPropertyValue(...). This method is called by the ResourceParser when it detects that it cannot parse the NewClassProps by itself. Parsing the properties will look something like this:
    /* ------------------------------------------------------------------------
   GetPropertyValue
   ------------------------------------------------------------------------ */
BOOLEAN GuiObjectFactory::GetPropertyValue(ResourceParser& parser, GuiObjectFactory::ParseType parse_type, void* value)
{
#ifdef APOXI_ARAGON_SUPPORT
    BOOLEAN success = FALSE;

    switch (parse_type) {
        ...
        case GuiObjectFactory::NewClassPropsType: {
            DBG_OUT((5008, L"NewClassProps\n"));

            NewClass::NewClassProps* res = (NewClass::NewClassProps*)value;
            res->m_wstring = parser.ReadWString();
            res->m_uint16 = parser.ReadUInt16();

            success = TRUE;

            break;
        }
        ...
    }
    return success;
#else
    return FALSE;
#endif
} // GetPropertyValue

    6. [ Previous: Multilingual Support ] [ Next: Image Handling ]


10 Appendix

 [ Previous: Aragon ] [ Next: Appendix ]

11 Image handling

11.1 Image encoding

APOXI offers a generic interface, which allows encoding of images from several formats to a specific industrial standard. Currently, a JPEG encoder is available for this purpose. Nevertheless, the I/F offers to implement any other kind of encoder, like PNG or GIF too. Benefits of APOXI encoder architecture:

  • Encoding can be done synchronously (blocking) or asynchronously (non-blocking).
  • During encoding, an application can receive encoding progress messages.
  • Encoding is done scanline by scanline or - depending on encoder architecture macro block-wise.
  • Encoding can be aborted immediatly during asynchronous encoding.

11.1.1 Jpeg Encoding

JPEG encoding currently supports following input formats:

  • RGB raw data with 16 or 24 Bits per pixel (e.g. APOXI Bitmap)
  • YUV 4:2:0 planar raw data
  • any APOXI image

Following, are some examples for different use cases on how the APOXI JPEG encoder can be utilized:

Example for encoding a YUV 4:2:0p RAW data image using asychronous encoding with a callback function. Encode() function returns immediatly and application gets information on encoding progress by ImageEncodingProgressMsg() and finally, when encoding has finished the given callback is called.

// create a data sink where the encoded data should be stored
// in our testcase it is a file on FFS
Pathname path_name(L"/yuv2jpg.jpg");
Path path(path_name, L"ffs");
FileDataSink file_sink = new FileDataSink(path, 0, TRUE);
ASSERT_DEBUG(m_file_sink != 0);

// now we need to create a source object, where we get the data from
// in our testcase we have a file on FFS, which contains the RAW data
const Pathname path_name_source(L"/lena-XGA-420-comp.yuv");
const Path path_source(path_name_source, L"ffs");

FileBinData* source = FileBinData::CreateInstance(path_source);
if (source == 0) {
    Alert alert(L"Could not find required source image.\nlena-XGA-420-comp.yuv is required!");
    alert.OpenModal();
    Cleanup();
    return;
}

// now we utilize the JpegEncoder with the proper parameters for YUV
JpegEncoder::EncodingParams encoding_params;
encoding_params.SetColorFormat(JpegEncoder::EncodingParameters::Yuv420pFormat);
encoding_params.SetQualityLevel(80);

// now we need to tell the jpeg encoder which format the RAW data has
// our picture has size of 1024x768 and YUV4:2:0 data is 24 Bits big
Image::MetaData source_prop;
source_prop.SetWidth(1024);
source_prop.SetHeight(768);
source_prop.SetBitsPerPixel(24);

// create a new jpeg encoder
JpegEncoder m_encoder = new JpegEncoder(encoding_params);

if ((file_sink == 0) || (encoder == 0)) {
    Cleanup();
    return;
}
BOOLEAN success = FALSE;
// don't forget to open the DataSink!
if (file_sink->Open()) {
    // now we can encode the image
    // we need to give the encoder our source, the source properties, the destination
    // FALSE stands for non-blocking and finally we give our context pointer and our callback for
    // the callback when image has been encoded.
    success =  m_encoder->Encode(*source, source_prop, *file_sink, FALSE, this, &CB_ImageEncoded);
    if (!success) {
        Alert alert(L"Could not encode the image.");
        alert.OpenModal();
        Cleanup();
    }
}

void CB_ImageEncoded(INT result, void* context, DataSink& dest)
{
    DBG_OUT((0, L"Callback of Encoded Image called with result: %d\n", result));
    // do cleanup of encoder of any other stuff when encoding has finished or aborted
}

Example for encoding asynchronously an APOXI Image using ImageEncodingProgress messages. Encode() function immediatly returns and applications gets information on encoding progress by progress messages.

// create data sink for final jpeg
Pathname path_name(L"/async.jpg");
Path path(path_name, L"ffs");

FileDataSink file_sink = new FileDataSink(path, 0, TRUE);

// initialize image
const Pathname path_name_source(L"/Pal_Int_VGA-V.png");
const Path path_source(path_name_source, L"ffs");

FileBinData* source = FileBinData::CreateInstance(path_source);
if (source == 0) {
    Alert alert(L"Could not find required source image.\nPal_Int_VGA-V.png is required!");
    alert.OpenModal();
    Cleanup();
    return;
}

Image* source_image = new PngImage(source);
if (source_image == 0)
    return;

// utilize the parameters, but we just want the jpeg being half size of the original one
JpegEncoder::EncodingParameters encoding_params;
encoding_params.SetQualityLevel(80);
encoding_params.SetWidth(source_image->GetWidth() / 2);
encoding_params.SetHeight(source_image->GetHeight() / 2);

JpegEncoder encoder = new JpegEncoder(encoding_params);

const BOOLEAN no_memory = (file_sink == 0) || (source_image == 0) || (encoder == 0);
if (no_memory) {
    Cleanup();
    return;
}

BOOLEAN success = FALSE;

if (file_sink->Open()) {
    success = encoder->Encode(*source_image, *file_sink, FALSE);
    if (!success) {
        Alert alert(L"Could not encode the image.");
        alert.OpenModal();
        Cleanup();
    }
}

Example for encoding synchronously an APOXI bitmap into a temporary RAM sink.

// this time we use shared pointer for DataSink
// RamDataSink creates a sink in RAM
RamDataSinkPtr ram_sink(new RamDataSink());
if (ram_sink.Get() == 0) {
    return TRUE;
}

// comneon is our source bitmap, it is stored as a resource generated by resource compiler
RamData* source = RamData::CreateInstance((void*)comneon.GetBits(), comneon.GetHeight() * comneon.GetWidth() * 16);
if (source == 0) {
    return TRUE;
}

// create the properties of the source image
Image::MetaData source_prop;
source_prop.SetWidth(comneon.GetHeight());
source_prop.SetHeight(comneon.GetWidth());
source_prop.SetBitsPerPixel(16);

JpegEncoder::EncodingParameters param;
param.SetQualityLevel(75);

// create a jpeg encoder
JpegEncoder enc(param);

if (ram_sink->Open() && enc.Encode(*source, source_prop, *ram_sink)) {
    Alert alert(Tr(L"Successfully encoded raw-image to temporary RAM-file"));
    alert.OpenModal();
    ram_sink->Close();

    // we sucessfully encoded the bitmap into a JPEG and now we want to display the jpeg
    // create a data source for the written ram_sink
    DataSourcePtr ram_source(new RamDataSource(ram_sink));
    if (ram_source.Get() == 0) {
        return TRUE;
    }

    DataSourceBinData *ram_source_bin_data = DataSourceBinData::CreateInstance(ram_source);
    if (ram_source_bin_data == 0) {
        return TRUE;
    }

    // create a new JpegImage out of the bin data
    Image *dest_image = new JpegImage(ram_source_bin_data);
    if (dest_image != 0) {
        // do the drawing of the new jpeg image
    }
}
else {
    Alert alert(Tr(L"Error when encoding raw-image to temporary RAM-file"));
    alert.OpenModal();
}
[ Previous: Aragon ] [ Next: Appendix ]


10 Appendix

 [ Previous: Image handling ]

12 Appendix

12.1 Obsolete Classes

With APOXI-1.9.0 items have been introduced, which are represented by the class Item. Due the new classes ItemGrid, ItemTree and ItemMenu it is a lot easier now in APOXI to create listboxes and menus. Still obsolete classes might be used in older projects, thats why the usage of those classes are explained in this chapter.

12.1.1 Menu

The class Menu has been replaced by the class ItemMenu. It is recommended to convert old code to use the class ItemMenu, as it takes less time for doing this change and the adaption of the look and feel of menus gets a lot easier (see also chapter 5 for a description of the class ItemMenu):

  • Replace the class Menu by ItemMenu
  • Replace the menu-accessors by an ItemContainer for the sub-menus and just drop the menu-accessors for the root-menu.
  • Instead of MenuAccessor::AddAction() write ItemContainer::AddItem().

The class Menu uses a menu-accessor for accessing and drawing the menu-items. A menu-accessor is described by the class AbstractMenuAccessor. It offers an interface for iterating over a variable number of menu-items, which may organized as a linear list of menu-items or as tree (e .g for hierarchical menus).

Example: a simple menu having a linear list of menu-items.

The class Menu is a control, which is responsible for:

  • Listening to the keys (e. g. up- and down-arrow-keys).
  • Move the selection for the highlighted menu-item.
  • Scroll the content, when necessary.
  • Provide a position-indicator.

The class AbstractMenuAccessor offers an interface for:

  • Iterating over a variable number of menu-items in linear or a hierarchical way.
  • Drawing a menu-item.

Example: A window should be created which contains a menu with the following structure:

After pressing "Item 1" a sub-menu showing some radiobuttons and checkboxes should be displayed. When pressing "Item 2" an alert should be display, which shows "Item 2 has been triggered". Item 3 should stay disabled and hence cannot be triggered.

The following code shows the implementation of this menu-structure. The code needed for the hierarchical-menu is noted in bold.

MyWindow.hpp
#include <ApoxiLib.hpp>

#include <AddOns/GuiMenuAccessors/SubMenuAction.hpp>
#include <AddOns/GuiMenuAccessors/TopMenu.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual BOOLEAN OnConfirm();
        virtual BOOLEAN OnCancel();
        virtual void OnActionExecuted(Action* action);

    private:
        TopLevelMenu m_menu;

        // declarations for main-menu
        SubMenuAction m_sub_menu;
        Action m_action_1;
        Action m_action_2;

        // declarations for sub-menu
        RadioButtonGroup m_rb_group;
        RadioButtonAction m_rb_action_1;
        RadioButtonAction m_rb_action_2;
        RadioButtonAction m_rb_action_3;
        CheckBoxAction m_cb_action_1;
        CheckBoxAction m_cb_action_2;

        ConfirmAction m_confirm_action;
        CancelAction m_cancel_action;
};
MyWindow.cpp
#include "MyWindow.hpp"

#include <Config/Resources/confirm_icon.hpp>
#include <Config/Resources/cancel_icon.hpp>

void MyWindow::Init()
{
    Window::Init();

    // initialize sub-menu
    m_rb_group.Init();
    m_rb_action_1.Init(this, &m_rb_group, Tr(L"Radiobutton 1"), TRUE);
    m_rb_action_2.Init(this, &m_rb_group, Tr(L"Radiobutton 2"));
    m_rb_action_3.Init(this, &m_rb_group, Tr(L"Radiobutton 3"));
    m_cb_action_1.Init(this, Tr(L"Checkbox 1"), TRUE, TRUE);
    m_cb_action_2.Init(this, Tr(L"Checkbox 2"));

    m_sub_menu.Init(this, Tr(L"Item 1"), &confirm_icon);
    m_sub_menu.AddAction(&m_rb_action_1);
    m_sub_menu.AddAction(&m_rb_action_2);
    m_sub_menu.AddAction(&m_rb_action_3);
    m_sub_menu.AddAction(&m_cb_action_1);
    m_sub_menu.AddAction(&m_cb_action_2);

    // initialize main-menu
    m_action_1.Init(this, Tr(L"Item 2"), &cancel_icon);
    m_action_2.Init(this, Tr(L"Item 3"), &cancel_icon);
    m_action_2.SetEnabled(FALSE);

    m_menu.Init(this, Tr(L"Main Menu"));
    m_main_accessor.AddAction(&m_sub_menu);
    m_main_accessor.AddAction(&m_action_1);
    m_main_accessor.AddAction(&m_action_2);

    // initialize softkeys
    m_confirm_action.Init(this, Tr(L"Select"));
    SetLeftSoftkey(&m_confirm_action);

    m_cancel_action.Init(this, Tr(L"Close"));
    SetRightSoftkey(&m_cancel_action);
}

BOOLEAN MyWindow::OnConfirm()
{
    m_menu.Trigger();
    return Base::OnConfirm();
}

BOOLEAN MyWindow::OnCancel()
{
    AbstractMenuAccessor* accessor = m_menu.GetMenuAccessor();
    ASSERT_DEBUG(accessor != 0);
    if (accessor->IsRoot())
        Close();
    else
        m_menu.Back();

    return Base::OnCancel();
}

void MyWindow::OnActionExecuted(Action* action)
{
    Base::OnActionExecuted(action);
    if (action == &m_action_2) {
        Alert alert(Tr(L"Item 2 has been triggered."));
        alert.OpenModal();
    }
    // else if (action == ...)
}

In MyWindow::Init the actions of the sub-menu are initialized:

  • As shown in the chapter for the RadioButtonControl, each radiobutton must be part of a radiobutton-group to assure that only one radiobutton may get selected.
  • The checkboxes are independent from each other and hence don't need a group.
  • After initializing the actions, they are embedded into the sub-menu.

After the sub-menu the main-menu is initialized the same way:

  • The two remaining actions representing the items are initialized.
  • After the initialization the actions are embedded into the main-action-accessor.

The method OnConfirm is invoked, when the left softkey has been pressed. In this case the currently selected menu-item is triggered by invoking m_menu.Trigger().

The method OnCancel is invoked, when the right softkey has been pressed. The window should only get closed, if the currently displayed menu represents a root-menu. Otherwise the menu should go one menu-level back, which is done by m_menu.Back().

As explained in the chapter for actions, the method OnActionExecuted may be used to react when an action has been executed.

12.1.2 AbstractListBox

APOXI offers only the class AbstractListBox as a base class for listboxes. The application developer has been forced to derive its own listbox for being able to create an instance of the class. Especially the handling of the listbox-model together with the listbox-control is very tricky and thats why this approach has been replaced by class ItemGrid. It is recommended to replace all derived classes from AbstractListBox by the item-grid.

10.2 Obsolete Methods

With APOXI-1.9.0 the methods Control::OnConfirm and Control::OnCancel got obsolete. Both methods are not needed anymore due providing the method Window::OnActionExecuted. A typical code which used those methods might look like this:

MyWindow.hpp
#include <ApoxiLib.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual BOOLEAN OnConfirm();
        virtual BOOLEAN OnCancel();

    private:
        ConfirmAction m_confirm_action;
        CancelAction m_cancel_action;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    ...
    m_confirm_action.Init(this, Tr(L"Confirm"));
    m_cancel_action.Init(this, Tr(L"Cancel"));
    ...
}

BOOLEAN MyWindow::OnConfirm()
{
    // execute code A
    return Base::OnConfirm();
}

BOOLEAN MyWindow::OnCancel()
{
    // execute code B
    return Base::OnCancel();
}

Replace this code the following way:

MyWindow.hpp
#include <ApoxiLib.hpp>

class MyWindow : public Window {
    public:
        void Init();

    protected:
        virtual void OnActionExecuted(Action* action);

    private:
        Action m_confirm_action;
        Action m_cancel_action;
};
MyWindow.cpp
#include "MyWindow.hpp"

void MyWindow::Init()
{
    Window::Init();
    ...
    m_confirm_action.Init(this, Tr(L"Confirm"));
    m_cancel_action.Init(this, Tr(L"Cancel"));
    ...
}

void MyWindow::OnActionExecuted(Action* action)
{
    Window::OnActionExecuted(action);
    if (action == &m_confirm_action)
        // execute code A
    else if (action == &m_cancel_action)
        // execute code B
}

12.3 Constructor vs. Init

When embedding components inside a class, there are two different ways for the implementation:

  1. Declare component-pointers in the header-file and allocate the instances in the constructor. Example:
    MyWindow.hpp
    class MyWindow : public Window {
    typedef Window Base;

    public:
        MyWindow();
        virtual ~MyWindow();

    private:
        LineEditor* m_editor;
};
    MyWindow.cpp
    #include "MyWindow.hpp"

MyWindow::MyWindow() :	Base()
{
    m_editor = new Editor(this, InputMapper::Numeric);
    ASSERT_DEBUG(m_editor != 0);
}

MyWindow::~MyWindow()
{
    delete m_editor;
    m_editor = 0;
}
  2. Declare the components as members in the header-file and initialize them by invoking Init:
    MyWindow.hpp
    class MyWindow : public Window {
    typedef Window Base;

    public:
        void Init();

    private:
        LineEditor m_editor;
};
    MyWindow.cpp
    #include "MyWindow.hpp"

void MyWindow::Init()
{
    Base::Init();
    m_editor.Init(this, InputMapper::Numeric);
}

The usual way in C++ is to declare component-pointers in the header-class and allocate the instances dynamically in the constructor. But with the current hardware-limitations of mobile phones this common way has some disadvantages:

  • Every new-operation might fail. This is case gets worse especially for mobile phones, where the amount of storage is still very limited. An error-message "Out of memory - cannot open the phonebook" must be prevented.
  • A lot of new-operations paired with delete-operations might lead to memory-fragmentation. APOXI uses memory-pools to prevent fragmentation of the memory, but still there is no guarantee that e. g. 1 KByte may be allocated in every use-case.
  • The new-operation is quite expensive concerning performance.

To fit the requirements of the limited hardware, APOXI offers the method Init which is a replica of the constructor for statically declared objects. Hence an application may be declared statically, this application may contain a variable number of windows, which themselves contain a variable number of sub-controls. When declaring objects statically, the order of executing the constructors is not defined, which leads to race-conditions. By using Init this can be bypassed quite easy: after APOXI has been started up, Application::OnOpen() is invoked for each application, which initializes its windows with Init. The windows initialize their sub-controls with Init too and so on.

The benefit of declaring the object statically is that the maximum amount of memory an application needs is defined on compile-time. For sure most applications still may have the requirement to allocate data dynamically, but it is a lot easier to find out the peak-values needed for the size of the heap, when the size of the application is as static as possible. Note that APOXI does not force the application-programmer to use Init: every constructor offers a Init-replica and vice versa.

Because Init should behave the same as the constructor, it must invoked only once for an instance of the class. Do not use Init to reinitialize an instance of a class!

Regarding the current hardware-limitations it is recommended to use the approach with Init, even this may look strange in the first sight as experienced C++-programmer.

[ Previous: Image handling ]


Application Memory Meter

1 Introduction

1.1 Scope

This document describes the usage of the application memory meter of the APOXI framework on SGOLD. The application memory meter gives a snapshot of the current stack memory used by all Apoxi applications and by all Apoxi application containers. The document also contains some hints concerning memory optimization.

1.2 SGold Stack Memory Overview

Usage of operating system Nucleus32 on SGOLD leads to following stack memory scenario:

  • Every application and every application container has its own stack memory region.
  • Every stack memory region is allocated separately for every application and separately for every application container at runtime using operator new.
  • Within its stack memory region every application and every application container stores all its temporary data, i.e. all local variables, but also the call hierarchy (stack frame). There exists only one stack memory region per application and per application container:

2 Application Stack Memory Meter

2.1 Usage

There are two ways to obtain the current stack memory usage: either via Trace (DbgOut) or via Lauterbach Debugger.

2.1.1 Read Memory Usage via Trace

To read memory usage via trace connect a trace terminal (for example tp-190.exe) to UART1 on the SGlobe(light) board. After booting Apoxi the SW goes to idle screen. By pressing the up-key (up-arrow) in the idle screen the current application stack memory usage is written to the current trace file. Attention: DbgOut has to be activated in the SW.

2.1.2 Read Memory Usage via Lauterbach Debugger

To read memory usage via Lauterbach debugger attach the Lauterbach debugger to the ARM controller on the SGold and load corresponding debug information (axf-file). After booting Apoxi, break the program flow in the debugger and do cmm-file "\lnz_mmi\Mmi\etc\t32\Edge\SG_stackmemoryusage.cmm". The current application stack memory usage is written to the Message Area of Lauterbach (View-->Message Area).

2.2 Output

The output is identical for both trace output and Lauterbach output. The output looks as follows:

The output contains the stack base ("StackBase"), the stack size ("StackSize") and a snapshot of the current memory usage ("Used") for every application and for every application container. As the stack is written from higher to lower addresses (stack pointer SP is decremented when writing to the stack), the stack actually starts at StackBase + StackSize and grows down towards StackBase. On SGold one StackAtom is 4 bytes.

3 Hints for Memory Optimization

The application stack memory meter can be used to optimize RAM memory usage.

3.1 Stack Memory Optimization for one Application

Every application's stack memory peak (overall maximum stack memory used by an application) can be obtained by stressing the application and afterwards reading out the application's stack memory usage using the application stack memory meter as described in the previous section.

After obtaining the application's stack memory peak the size of the application's stack memory region can be adapted either directly in the application (see for example the setting of the stack size for the SoundBrowserApplication to 3600 bytes):

    SoundBrowserApp::SoundBrowserApp() :
        Base(L"Sound Browser", 3600)
    {
        m_media_needs_refresh = FALSE;
    } // SoundBrowserApp

or in file "\lnz_projects\Project\Config\StartUpConfig.cpp" (see for example the setting of the stack size for the SoundBrowserApplication to 6142*4 bytes):

    StartUp::Table* StartUpConfig::GetStartupTable(const StartUp::Data & startup_data)
    {
        static StartUp::Table normal_on_table[] = {
    …
            #if defined(APPLICATION_SNDBROWSER)
                {TRUE, SoundBrowserApp::GetInstance(),		1, 6142*4},
            #endif
    …
    }

The setting in StartUpConfig overwrites the setting done within the application.

3.2 Overall RAM Optimization

After the stack memory has been optimized for every single application as described in the previous section (and after optimizing stack memory usage for every application container), the overall RAM usage can be optimized in file "\lnz_projects\Project\Config\MemoryConfig.cpp".

For further information please see documents "MemoryManagement.pdf" (and "MemoryManagement.doc") in subfolders of "\lnz_doc\NonDisclosables".


Supplementary Services Tutorial

1 Introduction

1.1 Purpose

The purpose of this document is to explain the usage of the Supplementary Service API of the APOXI framework. A Supplementary Service is an extension of the basic telecommunication services (e.g. telephony, fax, Short Message Service (SMS)), which supplies additional functionality.

1.2 Scope & Contents

The document describes which classes and objects are available for interaction with Supplementary Services, what their responsibilities are and how to use these classes in an MMI application environment. The Supplementary Service API resides within the Apoxi Stack Control (ASC). Please see the class reference of the Apoxi ASC module for details on the various classes and objects presented in this document.

1.3 Document Conventions

There are the following formats and document conventions used throughout the document:

  • Emphasis - Denoting words of higher importance or new terms being introduced.
  • SOURCECODE - Denoting source code snippets, EBNF definitions and control code sequences.

1.4 Intended Audience

The document is targeted at application developers and software architects who need to integrate Supplementary Service functionality into their applications. The document provides high-level description of the Supplementary Service API, its components and how to use them to initiate Supplementary Service requests and to receive the results back from the mobile network.

1.5 Reference

Supplementary Service-PROG-GUIDE Supplementary Services - Programmer's Guide to the GSM Stack Interface

2 Usage

2.1 Introduction

On the lowest level Supplementary Service interaction is nothing more than sending a specific control sequence to the mobile network and parsing the relevant data out of heaps of structures which are returned in response to the initial query. The control string is encoded to hold the type of the Supplementary Service, the desired action on that Supplementary Service and any further parameters. All the communication itself is handled via signals of the GSM stack.

APOXI simplifies that process for the MMI programmer by providing tailored interfaces for working with the Supplementary Services. These interfaces are implemented using handlers and messages.

2.2 Handlers

2.2.1 Introduction

The following is a short overview of the various operations and needed parameters the different Supplementary Services offer. Parameters marked with "(*)" are optional.
Please see Section 3.2 for a list of MMI Basic Service Groups.
Supplementary Service | Operation | Parameters
Call Barring | Activation | Password, MMI Basic Service Group(*)
 | Deactivation | Password, MMI Basic Service Group(*)
 | Interrogation | MMI Basic Service Group(*)
 | Password Change | Old password, new password, confirmation for new password
Call Forwarding | Registration | Destination number, MMI Basic Service Group(*), Time-out (CF on no reply, only)
 | Erasure | MMI Basic Service Group(*)
 | Activation | Destination number(*), MMI Basic Service Group(*), Time-out(*) (CF on no reply, only)
 | Deactivation | MMI Basic Service Group(*)
 | Interrogation | MMI Basic Service Group(*)
Call Waiting | Activation | MMI Basic Service Group(*)
 | Deactivation | MMI Basic Service Group(*)
 | Interrogation | MMI Basic Service Group(*)
Calling Line Identification Presentation (CLIP) | Interrogation |
Calling Line Identification Restriction (CLIR) | Interrogation |
Connected Line Identification Presentation (COLP) | Interrogation |
Connected Line Identification Restriction (COLR) | Interrogation |
Unstructured Supplementary Service Data | n/a | n/a

Handlers are the only means of interacting with the various Supplementary Services. Each handler is only responsible for a single Supplementary Service and provides various methods for using the service. The handler's interfaces resemble closely the different operations presented above. The advantages are, that the MMI programmer does not have to memorize the various Supplementary Service codes and different control sequences. He simply obtains the handler of the Supplementary Service he wants to use and calls a certain method. Furthermore the handler interface makes sure that the correct parameters are passed on to the GSM network making it impossible for the MMI programmer to omit mandatory parameters, to supply the wrong types of parameters or to mix up the order of the parameters. The handler also only features methods of valid requests for the specific service, thus further simplifying Supplementary Service interaction for the MMI programmer.

Although the handler names are straightforward, the following is a list of all handlers and their responsibilities:

  • CallBarringHandler - Call Barring Supplementary Service (BAOC, BAOIC, BOAIC-exHC, BAIC, BAIC-Roam).
  • CallForwardingHandler - Call Forwarding Supplementary Service (CFU, CFB, CFNRy, CFNRc).
  • CallWaitingHandler - Call Waiting Supplementary Service.
  • CLIPHandler - Calling Line Identification Presentation Supplementary Service.
  • CLIRHandler - Calling Line Identification Restriction Supplementary Service.
  • COLPHandler - Connected Line Identification Presentation Supplementary Service.
  • COLRHandler - Connected Line Identification Restriction Supplementary Service.
  • MobileOriginatedUSSDHandler - For mobile-originated USSD requests.
  • USSDHandler - For network-originated USSD requests.

2.2.2 Obtaining Handlers

A handler cannot be instantiated directly (in fact it is possible as such, but things will not work if it is done that way). A handler has to be obtained using the ASC StackControl class. This is the ASC master class, which administers the various handlers and makes sure that they are correctly linked into the system and that the message flow works.

The handler is obtained by passing the desired handler's identifier to the static GetHandler method of the StackControl class. The method will instantiate the specified handler and returns a base handler pointer to the new object, which needs to be cast to the specific handler object. Every handler defines a special anonymous enumeration, containing a single element called ID, which is set to the handler's actual identifier.

The following example should make things clear:

CallForwardingHandler *call_forwarding_handler;
BaseHandler *base_handler;

base_handler = StackControl::GetHandler(CallForwardingHandler::ID);
CastHandler(call_forwarding_handler, base_handler);

2.2.3 Using the Handlers

Every handler provides methods to interact with the service it is responsible for. These methods resemble closely the five basic operations for Supplementary Services and password change where applicable:

  • Registration - Register method
  • Erasure - Erase method
  • Activation - Activate method
  • Deactivation - Deactivate method
  • Interrogation - RequestStatus method
  • Change password - ChangePassword method (only available for the Call Barring Supplementary Service)

The availability of these methods may vary. Some handlers do not offer some methods (e.g. there is no registration method for the CLIR handler) simply because that operation isn't defined for the Supplementary Service . Upon invocation of such a method any parameters are checked for their plausibility, the correct control sequence string is built und sent to the mobile network.

The return values of the methods might vary depending on the parameter list and the type of action or service requested. All possible values are defined in the SsApiRc enumeration, which can be found in the ASC Types.hpp file and in the Appendix. The following are the most common values one might encounter:

  • Success - The request was successfully sent to the mobile network.
  • SupplementaryServicePending - There is already another Supplementary Service transaction active.
  • NormalServiceRequired - The network is not in a state, which allows the sending of the request.
The handler also provides state information during a transaction (including this return value) using several messages. Please see the following Section for details.

CallForwardingHandler *call_forwarding_handler;
BaseHandler *base_handler;

base_handler = StackControl::GetHandler(CallForwardingHandler::ID);
CastHandler(call_forwarding_handler, base_handler); call_forwarding_handler.Activate(Cfu, Telephony);

See the class documentation of each handler for details on the methods, parameters and return values.

This concludes the issue of using handlers and sending requests to the mobile network. The following Section describes how to receive the results returned by the mobile network.

2.3 Messages

2.3.1 Introduction

The communication with the Supplementary Service layer is completely asynchronous. That is although every handler method provides its result with a return value, messages are sent to indicate the current state of the handler and the transaction. Furthermore messages are the means of receiving any data sent from the mobile network in response to a request.

2.3.2 Receiving Messages

Any data received from the mobile network is transferred to a specific application message. The resulting message is then sent via the MessageRouter. Thus only the application, which initiated the request in the first place will get the result message.

After posting the message to the message router, the message router will call the OnMessage method of the specific application with the message as parameter. The application then has to decide what to do with the message and the data within.

Figure 2.1: Message creation and interaction

2.3.3 Handler Status Messages

As mentioned before the comminucation is completely asynchronous and the handlers provide some status information details on the transaction. The following messages are used for that purpose:

  • SsRequestSentMsg - This message indicates, that the handler has just sent the request to the GSM stack and is awaiting its response. The message contains the control sequence string sent to the stack.
  • SsRequestAcceptedMsg - This message indicates, that the GSM stack accepted the request. The GSM stack has already assigend a tipd to the request and is about to send it to the mobile network. The tipd is a unique transaction identifier. It is generated when the stack accepts a request and is used in any subsequent messages, which belong to that transaction. It is the only means of mapping incoming messages with initial requests or connecting multiple messages, which belong to the same transaction. The message contains the tipd of the transaction, as well as the specific Supplementary Service code, basic service group if any and any given positional parameters.
  • SsRequestRejectedMsg - This message indicates that an error occured during the sending of the request and that the stack did not accept the request. The message contains the handler's return value as well as the specific Supplementary Service code, basic service group if any and any given positional parameters of the initial request.

This leads to three possible message flows when initiating a request:

  • Successful transaction setup
    1. SsRequestSentMsg - The handler accepted the request and sent it on to the GSM stack.
    2. SsRequestAcceptedMsg - The GSM stack accepted the request and sent it on to the mobile network.
    3. Any result messages from the mobile network. These can include error messages that the mobile network was unable to handle the request.
    Figure 2.2 Successful transaction (example Call Forwarding status request)
  • Immediate rejection of the request
    1. SsRequestRejectedMsg - The request was rejected by the handler itself before it is sent to the GSM stack. Reasons for this to happen include, that the mobile network is not accessible at the moment or that another Supplementary Service request is already pending.
    Figure 2.3 Request rejected by handler (example Call Forwarding status request)
  • GSM stack rejects the request
    1. SsRequestSentMsg - The handler accepted the request and sent it on to the GSM stack.
    2. SsRequestRejectedMsg - The GSM stack immediately rejected the request. No data was sent to the mobile network and the transaction (which in fact has never started) is over.
    Figure 2.4 Request rejected by GSM stack or network (example Call Forwarding status request)

2.4 USSD Interaction

2.4.1 Introduction

Unstructured Supplementary Service Data (USSD) provides a session-oriented possibility for information exchange between the MS and the GSM network. The connection between the MS and the GSM network exists until it is terminated.

USSD is used to send data packets from between MS and GSM network in both directions. The data sent may consist of text as well as binary data. The receiver of the data must be able to read and understand it, otherwise the data is rejected.

Figure 2.5 shows an example of how USSD can be used to accomplish roaming for pre-paids. In this case the call request is sent to the home network via an USSD request. The home network checks the current billing status and sets up a callback call.

Figure 2.6 USSD example application, taken from http://www.symsoft.se/Files/USSD.html.

2.4.2 General USSD Interaction

USSD requests are handled slightly different than regular Supplementary Service request because they are session oriented. That means that a single session or transaction can consist of many requests being sent back and forth within the scope of that single transaction. Therefore the handler has to provide means to send requests within a given transaction context and to end that transaction.

The transaction is generally identified by its tipd (the unique transaction identifier, used to mark messages, which belong together). Therefore the handler's methods require a valid tipd to be specified. Alternatively and for convenience a previously received message can be specified from which the actual tipd is extracted. Furthermore the handler provides methods to end the transaction gracefully (which is indicated by an USSDEndMsg), alternatively to reject it or to signal an error to the mobile network.

Figure 2.7 USSD transaction

2.4.3 Network-Originated USSD Interaction

The interaction with network-originated USSD request is slightly different from the regular USSD transaction usage. In this case the transaction is initiated by the mobile network and not by an application using a handler. Therefore it is not known which application - if any - wants to react to the incoming request.

Upon reception of the first request a USSDBeginMsg is generated. The message does not contain any data. Its sole purpose is to identify the application, which wants to handle the incoming request. The message itself is a system message and thus sent to every application by default. When an application receives the message it can choose either to ignore it or to commence the USSD transaction by calling the BeginTransaction method of the message object. This will link the application to the USSD transaction und triggers the actual data message to be sent to the application.

The mobile network has two possiblities (apart from error indications of course) to reply to a USSD request. On the one hand it can send back another USSD request. The request might contain result data of the initial request, but it requires the mobile station to answer and supply additional data. So if a USSD request is received as a reply, additional data has to be sent to the mobile network.

On the other hand the mobile network can send back a USSD notification. A notification contains result data of the initial request and simply has to be acknowledged by the mobile station. Only an empty acknowledge message has to be sent back to the mobile network.

Note that there must not be more than one application reacting to the message in the system. The first application to react will be assigned the transaction. Any subsequent tries to register for the transaction will result in a Supplementary Service-pending error. If two or more apllications try to register simultaneously it is not determenistic, which application will actually be assigned and which will be denied. This leads to completely undeterministic and hard to track race conditions, which have to be avoided.

Figure 2.8 Network-originated USSD transaction initiation

2.5 Call Control by SIM

2.5.1 Introduction

Call control by SIM denotes a feature of the SIM card, which enables the card to intercept any request to the GSM network and transform it into another request, which will be sent instead. This means that e.g. a Supplementary Service request could be intercepted and transformed into a call, instead of sending the appropriate control sequence a call is set up. There are no limits concerning the transformation of requests. A call could be transferred into another a call, a Supplementary Service request or an USSD request, wheras a Supplementary Service request could be transferred into another Supplementary Service request, a call or an USSD request. For USSD requests applies the same as for Supplementary Service requests. In short everything can be transformed in everything else.

2.5.2 Usage

Call control by SIM is completely integrated into the Supplementary Service API and thus is completely transparent to the user. One has to distinguish three important cases. Firstly a Supplementary Service request or an USSD request being transformed into a call, secondly a call being transferred into a Supplementary Service request or an USSD request and thirldy a Supplementary Service request or an USSD request being transformed into another Supplementary Service request or USSD request.

A Supplementary Service request being transformed into a call is fairly straightforward. The initial request is intercepted on its way to the GSM stack and the requester is notified of the transformation. Thus the handler will send an SsRequestRejectedMsg containing the specific return code to indicate the transformation and the request is over. In the mean time a call is set up, which in fact is not of any importance to the Supplementary Service API.

The following return codes identify the different transformations of a Supplementary Service:

  • SupplementaryServiceChangedToSs - The Supplementary Service was transformed into another Supplementary Service.
  • SupplementaryServiceChangedToUssd - The Supplementary Service was transformed into an USSD request.
  • SupplementaryServiceChangedToMoc - The Supplementary Service was transformed into a mobile originated call (MOC).

A call being transformed into an Supplementary Service request is a bit complicated. The Supplementary Service API will be notified by the SIM card that a transformation just occured and that the Supplementary Service request was sent to the mobile network. The Supplementary Service API will then simulate that the request has in fact been initiated by the user and not the SIM card. Thus the according messages (a SsRequestSentMsg and a SsRequestAcceptedMsg) will be generated and dispatched to inform the MMI that a Supplementary Service request has just been sent. The answer to the request is again picked up wrapped in a message and sent to the MMI just as a regular Supplementary Service request would do. In the mean time the call setup was terminated, which again is of no importance to the Supplementary Service API.

A Supplementary Service request being transformed into another Supplementary Service request is a combination of the previous two scenarios. The initial Supplementary Service request is terminated as described in the first scenario and the handler will send an SsRequestRejectedMsg to the requester to indicate the termination of the inital request. The new request is setup according to the description in the second scenario. The Supplementary Service API simulates the new request and the processes the results just as if a regular Supplementary Service request was made.

3 Reference

3.1 Message Reference

3.1.1 Overview

Message Name | Short Description
CallBarringActivatedMsg | Triggered by a Call Barring activation request. Contains the initial parameters and a vector of call barring features, which contains the basic service groups for which call barring is activated.
CallBarringDeactivatedMsg | Triggered by a Call Barring deactivation request. Contains the initial parameters and a vector of call barring features, which contains the basic service groups for which call barring is deactivated.
CallBarringPasswordChangedMsg | Triggered by a Call Barring password change request. Contains the initial parameters and the new password.
CallBarringStatusMsg | Triggered by a Call Barring status interrogation request. Contains the initial parameters and a vector of basic service groups for which Call Waiting is activated.
CallForwardingActivatedMsg | Triggered by a Call Forwarding activation request. Contains the initial parameters and a vector of call forwarding features for which call forwarding is activated.
CallForwardingActiveMsg | Notification that Call Forwarding is active upon initiating a mobile originated call.
CallForwardingDeactivatedMsg | Triggered by a Call Forwarding deactivation request. Contains the initial parameters and a vector of call forwarding features for which call forwarding is deactivated.
CallForwardingErasedMsg | Triggered by a Call Forwarding erasure request. Contains the initial parameters and a vector of call forwarding features for which call forwarding is erased.
CallForwardingRegisteredMsg | Triggered by a Call Forwarding registration request. Contains the initial parameters and a vector of call forwarding features for which call forwarding is registered.
CallForwardingStatusMsg | Triggered by a Call Forwarding status interrogation request. Contains the initial parameters and either a vector of call forwarding features, or an empty vector but an overall status.
CallHeldMsg | Notification that the current call is held at the other party. This is the counterpart to the CallRetrievedMsg.
CallIsWaitingMsg | Notification that the current call is waiting at the other party.
CallRetrievedMsg | Notification that the current call is retrieved by the other party. This is the counterpart to the CallHeldMsg.
CallWaitingActivatedMsg | Triggered by a Call Waiting activation request. Contains the initial parameters and a vector of basic service groups for which Call Barring is activated.
CallWaitingDeactivatedMsg | Triggered by a Call Waiting deactivation request. Contains the initial parameters and a vector of basic service groups for which Call Barring is deactivated.
CallWaitingStatusMsg | Triggered by a Call Waiting status interrogation request. Contains the initial parameters and a vector of basic service groups for which Call Barring is activated.
ClipStatusMsg | Triggered by a CLIP status interrogation request. Contains the current CLIP status.
ClirNotSurpressedMsg | Notification that the the CLI is not surpressed at the other party, i.e. the number is shown.
ClirStatusMsg | Triggered by a CLIR status interrogation request. Contains the current CLIR status.
ColpStatusMsg | Triggered by a COLP status interrogation request. Contains the current COLP status.
ColrStatusMsg | Triggered by a COLR status interrogation request. Contains the current COLR status.
CugCallMsg | Notification that the incoming or outgoing call is a closed-user-group call.
EctActiveMsg | Indication that the current call has been transferred. This notifiaction is sent to the party being transferred as well as the party at the destination of the transfer.
EctAlertingMsg | Indication for the party being transferred that the transferred call is ringing at the destination party.
ForwardedCallIncomingMsg | Notification that the incoming call has been forwarded from a different party (Message received by C subscriber).
IncomingCallForwardedMsg | Notification that an incoming call was forwarded to a different party (Message received by B subscriber).
MultiPartyCallInvokedMsg | Notification that the current call was added to a multy-party call.
NetworkSsErrorMsg | Triggered if the mobile network signals an error while processing the request. Contains the error code sent by the mobile network.
NetworkSsRejectedMsg | Triggered if the mobile network rejects the request. Contains the tagged problem code sent by the mobile network.
OutgoingCallForwardedMsg | Notification that the outgoing call was forwarded to another destination (Message received by A subscriber).
SsErrorMsg | Triggered by an error during message generation. Contains the error code and an error text string.
SsRequestAcceptedMsg | This message indicates, that the GSM stack accepted the request. The GSM stack has already assigend a tipd to the request and is about to send it to the mobile network. The message contains the tipd of the transaction, as well as the specific Supplementary Service code, basic service group if any and any given positional parameters.
SsRequestRejectedMsg | This message indicates that an error occured during the sending of the request and that the stack did not accept the request. The message contains the handler's return value as well as the specific Supplementary Service code, basic service group if any and any given positional parameters of the initial request.
SsRequestSentMsg | This message indicates, that the handler has just sent the request to the GSM stack and is awaiting its response. The message contains the control sequence string sent to the stack.
StackSsRejectedMsg | This message indicates, that the GSM stack rejected the request after it has previously decided to accept it by sending the Begin_Acc signal.
UssdBeginMsg | Triggered by a network-originated USSD request. Used to determine the application which wants to commence the transaction.
UssdDataMsg | Triggered by the mobile network's response to a mobile originated USSD request. Contains the requested data.
UssdEndMsg | Triggered if the mobile network signals the end of an active USSD transaction.
UssdNotifyMsg | Triggered by an incoming USSD notification. Contains the notifiaction data. The application needs to acknowledge the reception of the notification.
UssdRequestMsg | Triggered by an incoming USSD request. Contains the request data. The application needs to send specific response data back.
UssdRequestResentMsg | Indication that the sending of the initial request with protocol version 2 failed and that the request was resent using protocol version 1.

Annotation for Call Forwarding:

  • A-Subscriber - A subscriber who is placing an outgoing call to a B-subscriber.
  • B-Subscriber - A subscriber who has call forwarding activated and is forwarding incoming calls.
  • C-Subscriber - The subscriber to whom the forwarded call is delivered.

3.1.2 Call Barring

CallBarringActivatedMsg

Parameter | Description
tipd | The tipd of the transaction.
call_barring_features | A vector of CallBarringFeature objects, which status equals active and operative. The feature object contains the status code and the MMI basic service group.
parameter_ss_code | The SsCode parameter of the initial request.
parameter_basic_service | The ServiceGroup parameter of the initial request.

CallBarringDeactivatedMsg

Parameter | Description
tipd | The tipd of the transaction.
call_barring_features | A vector of CallBarringFeature objects, which status equals provisioned and not active. The feature object contains the status code and the MMI basic service group.
parameter_ss_code | The SsCode parameter of the initial request.
parameter_basic_service | The ServiceGroup parameter of the initial request.

CallBarringPasswordChangedMsg

Parameter | Description
tipd | The tipd of the transaction.
new_password | The password string returned by the mobile network.
param_ss_code | The SsCode parameter of the initial request.
param_old_password | The old password parameter string of the initial request.
param_new_password | The new password parameter string of the initial request.
param_conf_password | The password confirmation parameter string of the initial request.

CallBarringStatusMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus). This is set to provisioned and activated, if no overall status, but a list of MMI basic service groups was provided.
basic_service_list | A vector of SsGroup objects, which contains the MMI basic service groups that are provisioned and active. The vector is empty if an overall status was provided
parameter_ss_code | The SsCode parameter of the initial request.
parameter_basic_service | The ServiceGroup parameter of the initial request.

3.1.3 Call Forwarding

CallForwardingActivatedMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying which Call Forwarding subservice has been activated.
forwarding_features | A vector of ForwardingFeature objects. Each element represents a MMI basic service group. It contains the group's identifier, the current status, the destination number of the call forwarding and the time-out for CFNRy. If the list is empty Call Forwarding was activated according to the initial parameters.
parameter_ss_code | The SsCode parameter of the initial request.
parameter_basic_service | The ServiceGroup parameter of the initial request.
parameter_phonenumber | The PhoneNumber parameter of the initial request.
parameter_time_out | The time-out parameter of the initial request.

CallForwardingDeactivatedMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying which Call Forwarding subservice has been deactivated.
forwarding_features | A vector of ForwardingFeature objects. Each element represents a MMI basic service group. It contains the group's identifier, the current status, the destination number of the call forwarding and the time-out for CFNRy. If the list is empty Call Forwarding was deactivated according to the initial parameters.
parameter_ss_code | The SsCode parameter of the initial request.
parameter_basic_service | The ServiceGroup parameter of the initial request.

CallForwardingErasedMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying which Call Forwarding subservice has been erased.
forwarding_features | A vector of ForwardingFeature objects. Each element represents a MMI basic service group. It contains the group's identifier, the current status, the destination number of the call forwarding and the time-out for CFNRy. If the list is empty Call Forwarding was erased according to the initial parameters.
parameter_ss_code | The SsCode parameter of the initial request.
parameter_basic_service | The ServiceGroup parameter of the initial request.

CallForwardingRegisteredMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying which Call Forwarding subservice has been registered.
forwarding_features | A vector of ForwardingFeature objects. Each element represents a MMI basic service group. It contains the group's identifier, the current status, the destination number of the call forwarding and the time-out for CFNRy. If the list is empty Call Forwarding was registered according to the initial parameters.
parameter_ss_code | The SsCode parameter of the initial request.
parameter_basic_service | The ServiceGroup parameter of the initial request.
parameter_phonenumber | The PhoneNumber parameter of the initial request.
parameter_time_out | The time-out parameter of the initial request.

CallForwardingStatusMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus). This is set to 0, if no overall status, but a list of forwarding features was provided.
forwarding_features | A vector of ForwardingFeature objects. Each element represents a MMI basic service group. It contains the group's identifier, the current status, the destination number of the call forwarding and the time-out for CFNRy. The list is empty if an overall status was provided.
parameter_ss_code | The SsCode parameter of the initial request.
parameter_basic_service | The ServiceGroup parameter of the initial request.

3.1.4 Call Waiting

CallWaitingActivatedMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus). This is active and operative.
basic_service_list | A vector of SsGroup objects, which contains the MMI basic service groups that are active and operative.
param_basic_service | The ServiceGroup parameter of the initial request.

CallWaitingDeactivatedMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus). This is provisioned and not active.
basic_service_list | A vector of SsGroup objects, which contains the MMI basic service groups that are provisioned and not active.
param_basic_service | The ServiceGroup parameter of the initial request.

CallWaitingStatusMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus). This is set to provisioned and activated, if no overall status, but a list of MMI basic service groups was provided.
basic_service_list | A vector of SsGroup objects, which contains the MMI basic service groups that are provisioned and active. The vector is empty if an overall status was provided

3.1.5 Line Identification

ClipStatusMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus).

ClirStatusMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus).
cli_restriction_option | The CliRestrictionOption indicating whether the CLIR setting is permanent, or if it can be changed and defaults either to allowed or to restricted. Possible values: Permanent, TemporaryDefaultRestricted or TemporaryDefaultAllowed.

ColpStatusMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus).

ColrStatusMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_status | The status of the service (SsStatus).

3.1.6 USSD

UssdBeginMsg

Parameter | Description
tipd | The tipd of the transaction.

UssdDataMsg

Parameter | Description
tipd | The tipd of the transaction.
data | The string containing the USSD data.
data_coding_scheme | The data coding scheme (DataCodingScheme) the data string is encoded in.

UssdEndMsg

Parameter | Description
tipd | The tipd of the transaction.

UssdNotifyMsg

Parameter | Description
tipd | The tipd of the transaction.
control_info | The string containing the USSD data.
data_coding_scheme | The data coding scheme (DataCodingScheme) the data string is encoded in.

UssdRequestMsg

Parameter | Description
tipd | The tipd of the transaction.
control_info | The string containing the USSD data.
data_coding_scheme | The data coding scheme (DataCodingScheme) the data string is encoded in.

UssdRequestResentMsg

Parameter | Description
new_tipd | The new tipd of the resent transaction.
old_tipd | The tipd of the failed transaction.

3.1.7 Notification Messages

CallForwardingActiveMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying the Call Forwarding subservice.

CallHeldMsg

Parameter | Description
tipd | The tipd of the transaction.

CallIsWaitingMsg

Parameter | Description
tipd | The tipd of the transaction.

CallRetrievedMsg

Parameter | Description
tipd | The tipd of the transaction.

ClirNotSurpressedMsg

Parameter | Description
tipd | The tipd of the transaction.

CugCallMsg

Parameter | Description
tipd | The tipd of the transaction.
cug_index | The index of the closed user group.

EctActiveMsg

Parameter | Description
tipd | The tipd of the transaction.
rdn_selector | Indicator (RdnChoice) specifying whether the other party's number is available and if its presentation is allowed.
address | The PhoneNumber of the other party.
sub_address | Meaning not known yet.

EctAlertingMsg

Parameter | Description
tipd | The tipd of the transaction.

ForwardedCallIncomingMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying the Call Forwarding subservice.

IncomingCallForwardedMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying the Call Forwarding subservice.

MultiPartyCallInvokedMsg

Parameter | Description
tipd | The tipd of the transaction.

OutgoingCallForwardedMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying the Call Forwarding subservice.

3.1.7 Network Error Messages

NetworkSsErrorMsg

Parameter | Description
tipd | The tipd of the transaction.
error_code | The SsErrorCode specifying the error.

NetworkSsRejectedMsg

Parameter | Description
tipd | The tipd of the transaction.
tagged_problem_code | The TaggedProblemCode describing the cause of the rejection.

3.1.8 Supplementary Service Framework Layer Messages

SsErrorMsg

Parameter | Description
tipd | The tipd of the transaction.
error_code | The error code (SsBaseHandler::ReturnCode) specifying the error.
error_text | A String describing the error in more detail.

SsRequestAcceptedMsg

Parameter | Description
tipd | The tipd of the transaction.
ss_code | The SsCode specifying the Supplementary Service.
basic_service | The ServiceGroup, if specified.
operation_code | The SsOperationCode specifying which operation is attempted on the Supplementary Service.
parameter1 | The string of the first positional parameter, if specified.
parameter2 | The string of the second positional parameter, if specified.
parameter3 | The string of the third positional parameter, if specified.

SsRequestRejectedMsg

Parameter | Description
error_code | The handler's return value (SsApiRc) specifying the error.
ss_code | The SsCode specifying the Supplementary Service.
basic_service | The ServiceGroup, if specified.
operation_code | The SsOperationCode specifying which operation is attempted on the Supplementary Service.
parameter1 | The string of the first positional parameter, if specified.
parameter2 | The string of the second positional parameter, if specified.
parameter3 | The string of the third positional parameter, if specified.
cause | The CallErrorCause describing why the request was rejected.

SsRequestSentMsg

Parameter | Description
ss_control_seq | The control sequence string sent to the GSM stack.
ss_code | The SsCode specifying the Supplementary Service.
basic_service | The ServiceGroup, if specified.
operation_code | The SsOperationCode specifying which operation is attempted on the Supplementary Service.
parameter1 | The string of the first positional parameter, if specified.
parameter2 | The string of the second positional parameter, if specified.
parameter3 | The string of the third positional parameter, if specified.

StackSsRejectedMsg

Parameter | Description
tipd | The tipd of the transaction.
cause | The CallErrorCause describing why the request was rejected.

3.2 MMI Basic Service Groups

Telecommunication Service | MMI Service Code
Telephony | 11
All data teleservices | 12
Facsimile services | 13
Short Message Service | 16
All teleservices except SMS | 19
Voice Group Service - Voice Group Call Service (VGCS) | 17
Voice Group Service - Voice Broadcast Service (VBS) | 18
All bearer services | 20
All async services | 21
All sync services | 22
All data circuit sync | 24
All data circuit async | 25
All dedicated packet access | 26
All dedicated PAD access | 27
All GPRS bearer services | 99

3.3 SsApiRc values

UnspecifedRc | Unspecifed MN return code.
Success | MN accepted supplementary service request.
SupplementaryServicePending | A supplementary service is currently pending.
SupplementaryServiceNotPending | Operation requires active supplementary service.
InvalidTipd | An invalid Tipd is assigned to supplementary service.
InvalidServiceCode | An invalid service code was passed to the handler method.
InvalidMmiServiceGroup | An invalid basic mmi service group was passed to the handler method.
InvalidBasicService | An invalid basic service was passed to the handler, either it was invalid or there is no MMI code for the basic service
InvalidTimeOut | An invalid time_out value (not in 5 <= value <= 30) was supplied.
InvalidPhoneNumber | An invalid or empty phone number was supplied.
SupplementaryServiceDenied | Supplementary service request rejected by MN.
NormalServiceRequired | Supplementary service requires normal service registration state.
SsDataLocked | Unable to access. Data locked by an other application.
ConfPasswordMismatch | Password mismatch between new password and confirmation
SupplementaryServiceChangedToMoc | Because of CallControl by Sim the SS was changed to a MOC.
SupplementaryServiceChangedToSs | Because of CallControl by Sim the SS was changed to another SS.
SupplementaryServiceChangedToUssd | Because of CallControl by Sim the SS was changed to a USSD.
UssdTransactionError | An error occurred trying to initiate a USSD transaction

Appendix I - Glossary

AoC
Advice of Charge
AoCC
AoC Charging
AoCI
AoC Information
APOXI
An object oriented application framework for development of man machine interface and applications for mobile terminals. The part of the mobile phone's software the simplifies the communication between MMI and GSM stack.
BAIC
Barring of All Incoming Calls
BAIC roaming
Barring of Incoming Calls when roaming outside the HPLMN country
BAOC
Barring of All Outgoing Calls
BOIC
Barring of Outgoing International Calls
BOIC exHC
Barring of Outgoing International Calls except Home Country
BS
Bearer Service - Basic Services for data transmission
CB
Call Barring
CCBS
Completion of Calls to Busy Subscriber
CD
Call Deflection
CF
Call Forwarding
CFB
Call Forwarding Busy
CFNRc
Call Forwarding Not Reachable
CFNRy
Call Forwarding No Reply
CFU
Call Forwarding Unconditional
CLI
Calling Line Identification
CLIP
CLI Presentation
CLIR
CLI Restriction
CNAP
Calling Name Presentation
COLP
Connected Line Identification Presentation
COLR
Connected Line Identification Restriction
CUG
Closed User Group
CW
Call Waiting (synonym for WAIT)
ECT
Explicit Call Transfer
eMLPP
enhanced Multi-Level Precedence and Pre-emption
Fixed Network
A wire-based phone network
GSM
Global System for Mobile Communication.
GSM Network
The whole infrastructure needed to operate mobile phones
GSM Stack
The part of a mobile phone's software that is managing the interaction between the MS and the GSM network
HLR
Home Location Register - A component of the GSM network
HOLD
Call Holding
HPLMN
Home PLMN - The GSM network of a subscriber's provider, where he has his contract.
ISDN
Integrated Services Digital Network
MMI
Man Machine Interface - The part of the mobile phone's software that is responsible for interacting with the user.
Mobile Network
Please see GSM Network
Mobile Subscriber
Any person operating a mobile phone
MPTY
Multi Party Service
MS
Mobile Station = Software (MMI + APOXI + GSM Stack) + Hardware.
PLMN
Public Lands Mobile Network - The GSM network infrastructure of one provider. If there are more then one provider in a country, there are also more PLMNs.
Service Provider
Entity providing the GSM network infrastructure and services.
Signal
Means of communication between the GSM stack and APOXI
SPNP
Support of Private Numbering Plan
Supplementary Service
Supplementary Service - Services which enhance Basic Services
Supplementary Service Control Sequence
Character string sent to the GSM network to invoke an operation on an Supplementary Service
Subscriber
Any person operating a phone
TS
Tele Service - Basic Services for speech and SMS transmission
UDUB
User Determined User Busy - Rejects an incoming call and sends the user busy signal.
USSD
Unstructured Supplementary Service Data
UUS
User-to-User Signaling
VPLMN
Visited PLMN - A GSM network where a subscriber is roaming in.
WAIT
Call Waiting


APOXI: Alphabetical List

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

APOXI Data Structure Index

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Z | _

A
CalendarGrid FtpDisconnectMessage OmRatChangeCnfArg SmsConfigIndArg
AbortResArg CalendarGridView FtpErrorMessage OmRatChangeIndArg SmsContext
AbortResMsg CalendarListWin FtpInTransfer OmRatChangeReqArg SmsControlIndArg
AbstractActionMenuAccessor CalendarMonthSelector FtpOutTransfer OmSetTermProfileCnfArg SmsControlIndMsg
AbstractAppContext CalendarMonthSelectorView FtpRequest OmSetTermProfileRejArg SmsCountProvider
AbstractButton CalendarMonthWin FtpRequestMessage OmSetTermProfileReqArg SmsDeliver
AbstractDelegationProvider CalendarProvider FtpServer OnDataRcvdMsg SmsDispatcher
AbstractDevice CalendarRecord FtpServerConfig OpenContextMenuAction SmsEditor
AbstractDevice::ControlArg CalendarRecord::Persist FtpServerSocket OpenPbWinMsg SmsFactory
AbstractEditBox CalendarRecordsList FtpServiceMessage OpenWindowAction SmsFolderProvider
AbstractEditBoxModel CalendarRecordsListBoxModel FtpSocket OplEntry SmsGetMoreMessageStatusIndArg
AbstractEditBoxView CallAcceptMsg FtpTransfer OptionalConfig SmsGetMoreMessageStatusReqArg
AbstractEditor CallBarredMsg FtpTransferMessage OptionalConfigBase SmsGsmServiceTextMap
AbstractEditorItem CallBarringActivatedMsg FunctionalityIndicator Os SmsHandler
AbstractExternalData CallBarringDeactivatedMsg
G
OutgoingCallForwardedMsg SmsIndicationState
AbstractGrid CallBarringFeature GatiManager OutputStream SmsInfoBox
AbstractGrid::SmoothScrollInfo CallBarringFeatureList GatiServer
P
SmsMessageWaitingChangedMsg
AbstractIMelodyParser CallBarringHandler GeneralCompoundItem PackedTimePeriod SmsMsgTypeTextMap
AbstractItemContainer CallBarringInfo GenericAudioDevice PagingMap SmsMsgTypeUsageTextMap
AbstractItemGrid CallBarringPasswordChangedMsg GenericFeatureData PagingMapEntry SmsMsgWaitingProvider
AbstractItemRenderer CallBarringStatusMsg GenericFeatureData::GenericTrackInfo PaintDc SmsNewMessageIndArg
AbstractLineEditor CallControlIndMsg GenericObject Palette SmsNewMessageMsg
AbstractLineEditorView CallControlInfoMsg GenericWorkerTask Panel SmsNewSocketDataMsg
AbstractListBox CallControlSetupIndArg GetFocusMsg PanelView SmsNewStatusReportIndArg
AbstractListBox::SmoothScrollInfo CallControlSsIndArg GetInkeyReqArg PaneObject SmsNewStatusReportMsg
AbstractListBoxModel CallControlUssdIndArg GetInkeyRspArg ParagraphCompoundItem SmsParamProvider
AbstractListBoxView CallDeflectionErrIndicationMsg GetInputReqArg ParagraphMarker SmsParamRecord
AbstractLockableDevice CallDeflectionHandler GetInputRspArg ParameterIndicator SmsPortDataRecvMsg
AbstractMenuAccessor CallDeflectionIndArg GetPasswordMsg PasswordChangeSsAction SmsPrefStorageMediaChangedMsg
AbstractMenuList CallDeflectionIndMsg GifImage PasswordEditor SmsProvider
AbstractMenuListModel CallDeflectionRejectedMsg GlassPane PasswordInquiryMsg SmsrData
AbstractMessageMapContainer CallDeflectSsReqArg GltpAidDataRequests PasswordReceivedArg SmsReadProvider
AbstractMultiLineEditor CallDiscIndArg GltpAidingDataWin PasswordReceivedMsg SmsResultTextMap
AbstractMultiLineEditorView CallDisconnectedMsg GltpAidingRequest PasswordRejectedMsg SmsSendCnfArg
AbstractPredictiveInputBox CallDisconnectingArg GltpAssistanceData Path SmsSendConfirmMsg
AbstractRenderer CallDisconnectingMsg GltpConnApp Pathname SmsSendDispatcher
AbstractScheduler CallDiscReqArg GltpConnStatusMsg Pathname::Iterator SmsSendingAnimation
AbstractSmsApp CalledPartyAlertingMsg GltpHelloRequest Pathname::ReverseIterator SmsSendingConfirmDialog
AbstractSmsComposeWin CallEvent GltpMsgProcessor PathProfile SmsSendRejArg
AbstractSmsUtilityProcessor CallEventMsg GltpMsmtRequest PathProfile::Persist SmsSendRejectMsg
AbstractSmsViewerWin CallForwardingActivatedMsg GltpPositionRequest PbAbstractWin SmsSendReqArg
AbstractStackMsgArgMapContainer CallForwardingActiveMsg GltpProviderImpl PbAction SmsSentProvider
AbstractTextObject CallForwardingDeactivatedMsg GltpRequest PbAddAction SmsServiceDocumentMsg
AbstractTextRenderer CallForwardingErasedMsg GltpSignalMapTableNode PbAddPhoneNoAction SmsServiceMsg
AbstractToggleAction CallForwardingHandler GltpSignalProcessor PbAdvAddEditEntry SmsSetMoreMessageReqArg
AbstractTransport CallForwardingRegisteredMsg GltpStackMsgArgsDestroyTableNode PbAdvDataHandler SmsSettingsProvider
AcacLanguage CallForwardingStatusMsg Glyph PbAdvDetailAction SmsSettingsRecord
AccDispatcher CallHandler GlyphHeader PbAdvDetails SmsSettingsRecord::Persist
AccessorAction CallHdl GlyphIndexTab PbAlphaTagRequestMsg SmsSocket
AccessorActionExtension CallHdlBase GmmParam PbBaseProvider SmsSocketListener
Accessory CallHeldMsg GprsAttachStatusMsg PbBaseWin SmsSocketSignalMapTableNode
AccessoryIndArg CallHoldCnfArg GprsClassIndArg PbCallAction SmsSpaceAvailableMsg
AccessoryIndMsg CallHoldRejArg GprsClassReqArg PbCancelAddNoAction SmsSpaceExceededMsg
AccHandler CallHoldRejectedMsg GprsParam PbCancelEditAction SmsStatus
AckNackCnt CallIndArg GprsStatusMsg PbChangeNoTypeAction SmsStatusReport
AckNackParamList CallIndCallControlInfoArg GpsFixData PbConfirmAddNoAction SmsStatusReportTextMap
AckNackTestparamCnt CallInfoArg GpsFixDataInt PbConfirmEditAction SmsStatusTextMap
Acm CallInfoMsg GreaterRule PbCopyHandler SmsStorageTypeTextMap
Action CallingName Grid PbCountIndArg SmsSubmit
ActionExecutedMsg CallIsWaitingMsg GridLayout PbCountReqArg SmsTelematicDeviceNameTable
ActionExtension CallNotifyMsg GridModel PbDataHandler SmsTemplateProvider
ActionMenuAccessor CallOnHoldMsg GridView PbDelAllAction SmsTemplateTextMap
ActiveWaitDispatcher CallProgressIndArg GroupProvider PbDeleteAction SmsTextEntry
AddAllToFdnAction CallRelatedSsCnfArg GroupProvider::GroupRec PbDelPhonenoAction SmsTextParser
AddEntryToFdnAction CallRelatedSsRejArg GsmBandList PbDetailAction SmsUnreadProvider
AddInfo CallRelatedSsReqArg GsmBandStateMsg PbDetailEditBox SmsUnsentProvider
AddNumberToFdnAction CallRelCnfArg Guid PbDetailListBox SmsUtility
AdvPbAction CallReleaseMsg GuidServiceTable PbDetailListBoxModel SmsViewerWin
AdvPbApp CallRelIndArg GuidUriTable PbDetailProvider SmsWStringCache
AdvPbWin CallRetrievedMsg GuiEngineConfig PbDetails SmsWStringCache::Entry
AesCrypt CallSetupBySimtTkReqArg GuiObjectFactory PbEditDetailAction Socket
AidingData CallSetupProgressArg
H
PbEntryReadIndArg SocketAddr
AlarmManager CallSetupProgressMsg HandlerData PbEntryReadReqArg SocketControlMsg
AlarmMsg CallSsAction HandlerFactory PbEntryRequestMsg SocketData
AlarmNotificationMsg CallTypeTable HandlerListEntry PbEntryShowAction SocketDataLock
Alert CallWaitingActivatedMsg Hashable PbEntryUpdIndArg SocketEventListener
Allocator CallWaitingDeactivatedMsg HashTable PbEntryUpdReqArg SocketHandler
AlphaCoding CallWaitingHandler HeaderData PbFfsNameHandler SocketPeer
AmplifierAudioDevice CallWaitingStatusMsg HeadSet PbFfsNumberHandler SocketRxThread
AmrSound Camera HeapArrayObject PbInfoReadIndArg SocketSerialTerminalListener
AnimatedTextLine Camera::ParameterLimits HeapDataSink PbInfoReadReqArg SocketSubSystem
AnimatedTextLineView CameraApp HeapDataSource PbLazySynchronizer SocketTestApp
Animation CameraCaptureWin HeapManager PbManualSynchronizer SocketTestApp::menuItems
AnimationBmpArrayIterator CameraMsgStartViewfinding HeapObject PbMergeProvider SocketTestMessage
AnimationBmpIterator CameraMsgStopViewfinding HeapVector PbNameEditBox SocketTestProgressWin
AnimationBmpPointerArrayIterator CameraOptionSettingsWin HeapVector::BlockPage PbNameFilterProvider SocketTestResultsWin
AnimationModel CameraSettings HeapVector::FctTable PbNameHandler SocketTestSettingsWin
AnimationView CameraSettingsWin HeapVector::HeapTableEntry PbNameNumberProvider SocketTestT
AocChargeData CameraViewFinderWin HeapVector::Page PbNameProvider SocketTestT1
AocChargingStatusMsg CamWin32 HeapVector::Stats PbNextFreeIdRecord SocketTestT2
AocDispatcher CancelAction HeapVector::VarPage PbNumberFilterProvider SocketTestT3
AocHandler Caret HindiTextRenderer PbNumberHandler SocketTestT4
AocIndArg CArray HlrDataCorruptedMsg PbNumberProvider SocketTestT5
apoxi_emcpp_OBEXAdapter CbmiData HlrSsDataCorruptMsg PbNumberRecord SocketTestT6
ApoxiCommandAction CbmiProvider HomezoneIndArg PbNumberRecord::Persist SocketTestT7
ApoxiThread CbmiRange HomezoneMsg PbNvRamNameHandler SocketTestT8
AppActionExecutedMsg CbmiRangeProvider HomezoneText PbNvRamNumberHandler SocketTestTests::TestGroupInfo
AppCloseMsg Cbs HostDebugTimeStamp PbPhoneNumberPrompt SocketTestWin
AppContainer Cbs::Filter HostFatFsDeviceDescriptor PbProvColListBox SoftkeyBar
AppContainerRoutingTableEntry Cbs::SerialNumber HostFileStatType PbProvColListBoxModel SoftkeyBarView
AppContext CbsDispatcher HostIniFile PbProviderListener SoftkeyDesc
AppendProvider CbsFilterList HostIterStatType PbProvListBox SoftkeyDescTableEntry
AppFeatureID CbsFilterList::CbsFilterListEntry HttpApplication PbProvListBoxModel SortedElementList
AppGetFocusMsg CbsHandler HttpApplicationSupplier PbRecord SortedLinkedList
Application CbsLimitIndArg HttpAuthProvider PbRecord::Persist SortedLinkedListBase
ApplicationAction CbsLimitMsg HttpClient PbRecordHandler SortProvider
ApplicationListEntry CbsNewDataIndArg HttpConnectMessage PbRecordProvider Sound
AppLoseFocusMsg CbsNewDataMsg HttpDisconnectMessage PbSecuredAction SoundBrowserApp
AppMutex CbsNewDataRejArg HttpErrorMessage PbSelectGroup SoundBrowserServiceMsg
AppOpenMsg CbsStartCnfArg HttpHandler PbSelectGroupAction SoundBrowserTestWin
AppRoutingTableEntry CbsStartDispatcher HttpRequest PbSelectNoType SoundBrowserWin
AppUpdateDisplayMsg CbsStartRejArg HttpRequest::ParamPair PbSelectNumberWin SoundFileFilter
ArabicTextRenderer CbsStartReqArg HttpRequestMessage PbSimProvider SoundFilter
AragonMsg CbsStopCnfArg HttpResponse PbSizeRequestMsg SoundItem
ArgumentDestroyEntry CbsStopDispatcher HttpServer PbSortedProvider SoundMetaData
ArgumentDestroyEntryCompare CbsStopRejArg HttpServerConfig PbSynchronizer SoundMetaDataRecord
AsTestparamDatabase CbsStopReqArg HttpServerSocket PbToggleAction SoundObtainer
AsyncUnitTestMsg CcbsEntry HttpServiceMessage PcmParam SoundRef
AtAccessoryNotificationIndArg CcbsList HttpSocket PdpAuthTable SoundRefContainer
AtAccessoryRegisterCnfArg CcbsRecallMsg HttpWapMgr PdpContext SpeechAudioDevice
AtAccessoryRegisterReqArg CcbsResultMsg HttpWapMgrBase PdpContext::ActivationStatus SpeechSimpleAudioDevice
AtAlphaTagCnfArg CcbsStatusMsg HttpWapMgrPlugin PdpContext::Address SsBarringIndArg
AtAlphaTagReqArg CcpData
I
PdpContext::Authentication SsBeginAccArg
AtcDispatcher Cell Iana PdpContext::PacketFilter SsCallBarringActionImpl
AtcHandler CellChangeCnts IccId PdpContext::PacketFilter::AddressAndMask SsCallForwardingActionImpl
AtCommand CellInfoIndArg IconDescReadIndArg PdpContext::QualityOfService SsCallWaitingActionImpl
AtCommandData CellInfoMsg IconDescReadReqArg PdpContextActivationStatusMsg SsCauseIndArg
AtCommandInfoTable CellParam IconIndicator PdpContextControl SsCcbsDispatcher
AtCommandMetaInfo CenteredTextIndicator IconSet PdpContextManager SsCcbsHandler
AtGenericCmdIndArg CfuDataIndArg IconState PdpContextManager::AttachStatus SsCcbsInvokeArg
AtGenericCmdReqArg CfuService IconTextIndicator PdpContextManager::DataCounters SsCcbsReCallIndArg
AtGenericCmdType CfuServiceArray IconValueIndicator PdpContextManagerControl SsCcbsReCallRequestArg
AtiAudioCapturerEncoder CfuStatusMsg IdentifierHandler PdpContextSignalMapTableNode SsCcbsRejectArg
AtiAudioDecoderRenderer ChannelData_s IdleScreenAvailEventArg PdpContextSignalProcessor SsCcbsResultIndArg
AtiAudioPlayerRtStreamingConn ChannelDataArray Image PdpQoSDelayTable SsCcbsStatusIndArg
AtiAudioPlayerRtStreamingSink ChargeIndArg Image::CleanupDrawingObtainer PdpQoSMeanRateTable SsClientRejArg
AtiCodecsLib Charger Image::MetaData PdpQoSPeakRateTable SsClipActionImpl
AtiMpeg4Decoder ChargeReqArg ImageBox PdpQoSPrecedenceTable SsClirActionImpl
AtiMpeg4Encoder ChargerInfoMsg ImageBoxView PdpQoSReliabilityTable SsCnapActionImpl
AtKeyParser ChargerSignalMapTableNode ImageBrowserApp Pen SsColpActionImpl
AtlApplication ChargerSignalProcessor ImageBrowserDeleteImageMsg PenDownMsg SsColrActionImpl
AtlApplicationPlugin ChargeUnitsIndArg ImageBrowserDetailWin PenUpMsg SsControlIndMsg
AtlApplicationPluginStartup ChargeUnitsReqArg ImageBrowserRenameImageMsg PersistDataConnProfile SsData
AtlApplicationPluginStartup::Table CharInputMapEntry ImageBrowserServiceMsg PhonebookApp SsDataIndArg
AtlConfig CharInputMapItem ImageBrowserTestWin PhoneBookInfo SsDataReceivedArg
AtlItemBox CharItem ImageBrowserWin PhonebookRenumberedMsg SsDataReceivedMsg
AtlItemGrid CheckBox ImageDecoder PhonebookWin SsDispatcher
AtlItemGridWindow CheckBoxAction ImageDecodingProgressMsg PhoneNumber SsEmlppActionImpl
AtlItemListWindow CheckBoxControl ImageDrawingInterruptedMsg PhoneNumber::Persist SsEndIndArg
AtlItemMenu CheckBoxControlView ImageEncoder PhoneNumberInputMapper SsEndMsg
AtlItemMenuWindow CheckBoxItem ImageEncoder::EncodingParameters PhoneNumberJoinRule SsErrIndArg
AtlItemRenderer CheckBoxList ImageEncodingProgressMsg PhoneNumberMatchRule SsErrIndicationMsg
AtlLabelListWindow CheckBoxListView ImageFactory PhoneNumberMergeProvider SsErrorCode
AtlWindow CheckBoxModel ImageFileFilter PinAction SsErrorMsg
AtomItem CheckBoxView ImageFilter PinDisableIndArg SsErrReqArg
AtPbInfoIndArg ChildBinData ImageIncrementalPdcUpdater PinDisableReqArg SsFacilityIndArg
AtPbListCnfArg ChineseQuickSortProvider ImageItem PinEnableIndArg SsFacilityRejArg
AtPbListReqArg ChineseT9InputMapper ImageListBoxModel PinEnableReqArg SsFacilityRejectedMsg
AtPbSelectCnfArg ChineseT9Wrapper ImageListBoxView PlayToneReqArg SsForwardingIndArg
AtPbSelectReqArg Chv1DisableIndArg ImageMetaData PlayToneRspArg SsForwcheckIndArg
AtResponse Chv1DisableReqArg ImageMetaDataRecord Plmn SsGetPasswordIndArg
AtResponseInfoTable Chv1EnableIndArg ImageObtainer PlmnDispatcher SsGetPasswordRejArg
AtResponseIterator Chv1EnableReqArg ImageReadIndArg PlmnHandler SsGetPasswordRspArg
AtResponseMetaInfo ChvAttemptsStruct ImageReadReqArg PlmnInfoReqArg SsGroup
AtResponseParameter ChvChangedMsg ImageRef PlmnListAbortArg SsGroupList
AttachAllowedIndArg ChvChangeIndArg ImageRefContainer PlmnListCnfArg SsHandler
AttachCnfArg ChvChangeReqArg ImageRefGenContainer PlmnListEntry SsInfoMsg
AttachRejArg ChvData ImageView PlmnListRejArg SsInterrogateIndArg
AttachReqArg ChvProvider ImageViewListBoxModel PlmnListReqArg SsMessage
Audio ChvRefreshIndArg Imei PlmnProvider SsNotification
Audio::SingleTone ChvUnblockIndArg ImeiReadIndArg PlmnRatDispatcher SsNotificationArg
Audio::SingleTone ChvUnblockReqArg ImeiReadReqArg PlmnScanDispatcher SsNotificationMsg
Audio::SingleTone ChvVerifyIndArg ImeiShowAction PlmnScanFinishedMsg SsNotifyIndArg
Audio::SingleTone ChvVerifyReqArg IMelody PngDecoder SsPasswordChangeActionImpl
Audio::SingleTone CiTestParam IMelodyData PngEncoder SsPasswordIndArg
Audio::ToneData CiTestParamList ImgObtObj PngEncoder::EncodingParameters SsRejArg
Audio::ToneData ClearBlackListCnfArg Imsi PngEncodingThreadlet SsRejectedMsg
Audio::ToneData ClearBlacklistReqArg IncomingCallForwardedMsg PngImage SsRejReqArg
Audio::ToneData ClientDc IncrementalPdcUpdater PnnEntry SsRequestAcceptedMsg
Audio::ToneData ClientDeregistrationArg IndexTable Point SsRequestRejectedMsg
AudioAccessoryConnectedMsg ClientId Indicator PortHeaderInformation SsRequestSentMsg
AudioAccessoryDetails ClientInfo IndicatorBar PositionIndicator SsRetResIndArg
AudioAccessoryStore ClientName IndicatorBarPaneObject PositionIndicatorView SsSendEndReqArg
AudioActiveReference ClientNetAdapter IndicatorBarUpdateMsg PowerDispatcher SsSendReqArg
AudioCapturerEncoder ClientRegistrationArg IndicatorBarView PowerDownCnfArg SsStatus
AudioContext ClipAction IndicatorDescription PowerDownDispatcher SsSuccessMsg
AudioDecoder ClipHandler IndicatorItem PowerDownIndArg SstProvider
AudioDecoderRenderer ClipStatusMsg IndicatorLocation PowerDownReqArg SsUnstructIndArg
AudioDeviceBase ClirAction IndicatorPaneObject PowerHandler SsUssdActionImpl
AudioDeviceManager CliRestrictionInfo InetSocket PowerModeIndMsg SsUssdIndArg
AudioDeviceStatusMsg ClirHandler InetSocketAddr PowerOffMsg SsUssdReqArg
AudioEncoder ClirNotSurpressedMsg InfoDialog PowerOnMsg SsUssdResentIndArg
AudioError ClirStatusMsg InformationElement PowerWakeupMsg SsUus1IndArg
AudioErrorMsg CloseAllMsg InputAction PppCallBackData SsUus1QueryIndArg
AudioFastForwardStartedMsg CloseDataConnMsg InputActionList PppDataConn SsUus1QueryRejArg
AudioFmRadioRdsAlternativeFrequenciesMsg CloseWindowAction InputActionPtr PppFrame SsUus1QueryReqArg
AudioFmRadioRdsInfoMsg CloseWindowMsg InputAnalyzer PppSetupCallBackData SsUus1ReqArg
AudioFmRadioRdsRadioTextMsg CmiProvider InputCharMsg PredefinedEmsImage SsWaitDispatcher
AudioFmRadioRdsRawDataMsg CmiRecord InputContext PredefinedEmsSound StackControl
AudioFmRadioRdsStationNameMsg CnapAction InputMap PredInputMapper StackInterface
AudioFmRadioRssiMsg CnapHandler InputMapEntry PrefExtLangProvider StackMsgActiveWaitDispatcher
AudioFmRadioSeekMsg CnapInfoReceivedMsg InputMapItem PrefLangProvider StackMsgArgDestroyTableNode
AudioGatiServer CnapStatusMsg InputMapper PrefPlmnChangeArg StackMsgArgMap
AudioGetPlayPositionMsg CodecDevice InputMapperFactory PrefPlmnProvider StackMsgArgMapContainer
AudioItem CodecDevice::AudioChannel InputParser PrefServiceSetReqArg StackMsgArgument
AudioMapiManager CodecDevice::AudioCodecCapabilities InputStream PreparedSound StackMsgDispatcher
AudioMapiManager::MapiCommandType CodecDevice::AudioDecoderParameters InteriorNodeRecord PresetAudioReference StackMsgMapTable
AudioMapiManager::RequestOutcomeType CodecDevice::AudioEncoderParameters InternalTracer ProactiveCauseMapper StackMsgMapTableEntry
AudioMsg CodecDevice::AudioIOBuffer InternalTracer::TraceHeader ProcessMolrMsg StackMsgMapTableNode
AudioPath CodecDevice::AudioStreamInfo InternalTracer::TsStruct ProcessNode StackMsgProcessor
AudioPathManager CodecDevice::Properties InterrogateCcbsResult ProgressBar StackSsRejectedMsg
AudioPlayer CodecDevice::VideoCodecCapabilities InterrogateSsResult ProgressBarView StackTranslator
AudioPlayerEvent CodecDevice::VideoDecoderInfo InterrogationResultArg Property StackWrapper
AudioPlayerStore CodecDevice::VideoDecoderParameters InterrogationResultMsg PropertyDescriptor StandardJoinRule
AudioPlayerStore::DataFormatDataSource CodecDevice::VideoEncoderInfo InvalidateMsg PropertyEditor StartDtmfCnfArg
AudioPlayTimeMsg CodecDevice::VideoEncoderParameters InvokeId PropertyEditorFactory StartDtmfRejArg
AudioPreset CodecDevice::VideoStreamInfo IpAddr PropertyItem StartDtmfReqArg
AudioPresetStore CodecManager IpAddrCompoundItem PropertyTriggerMsg StartSignalStrengthListeningArg
AudioRadioDeviceNotificationMsg CodedTimeStamp IpAddrEditor Protector StartSocketTestMsg
AudioRecordingStoppedMsg Color IpAddrEditorDocument ProtocolIdentifier StartUp
AudioReference ColorSegmentation IpAddrInputMapper ProvColListBoxWin StartUp::Data
AudioReference::TotalPlayTimeContainer ColorTable IpAddrPrompt ProvDetailListBoxWin StartUp::Table
AudioRestartedMsg ColpAction IpPortNo Provider StateMachine
AudioResumedMsg ColpHandler IrConnection Provider::Modification StateStruct
AudioRewindStartedMsg ColpStatusMsg IrdaApp ProviderChangedMsg StatusDispatcher
AudioStartedMsg ColrAction IrdaObexClientAddr ProviderListBox StatusProvider
AudioStoppedMsg ColrHandler IrdaObexImpl ProviderListBoxModel StillCamera
AudioStreamingSyncMsg ColrStatusMsg IrdaObexServerAddr ProviderListBoxView StopBatteryLoadListeningArg
AudioSuspendedMsg ColumnInfo IrdaObexSubSystem ProviderListener StopDtmfCnfArg
AudioTone comm_root_cert IrdaObexTransport ProviderProxyContainer StopDtmfReqArg
AudioToneDuration comm_user_cert IrdaTransport ProviderProxyItem StopSignalStrengthListeningArg
AudioUserDefinedMsg CommandType IrdaWin ProviderPtr StopSocketTestMsg
AudioUtility CommonSignalMapTableNode IrSocketAddr ProviderUpdateMsg StorageDevice
AudioVibratorDevice CommonSignalProcessor IsrDataContainer ProvListBoxWin StorageDeviceFilter
AudioVoiceMemoOutOfSpaceMsg CommonStackMsgArgsDestroyTableNode IsrDataManager PsdDataConn StorageDeviceIterator
AuthProvider CommonStackMsgMapTableNode IsrDataMarshaller PsdDataConnAccessor StorageDeviceVisitor
AutoCallRestrictIndArg CommonStackMsgProcessor Item PsdDataConnProfile StrData
AuxProvider Component ItemBox PsdDataConnProfile::Bit Stream
B
CompoundItem ItemBoxView PsdDataConnProfile::Persist StreamAudioPlayer
BackLight CompoundItemIterator ItemContainer PsdDataConnProvider StreamAudioReference
BackToIdleFeature CompoundItemReferrer ItemGrid PsdSettingsTable StreamingCallback
BackupFileHandler CompoundSmsItem ItemLabel PsLociData StreamingInfo
BandSelectionIndArg CompoundTpduItem ItemLabelView Puct StreamingReadInfo
BandSelectionMsg Condition ItemMenu PushButton StreamingWriteInfo
BandSelectionReqArg ConfirmAction ItemMenu::LevelInfo PushButtonView StreamObexImpl
BandStatusMsg ConnectionIndArg ItemObj
Q
StreamObexTransport
BarringInfoReceivedArg ConnectionStatusMsg ItemPropertiesChangedMsg QuickSortProvider StreamReader
BarringInfoReceivedMsg ContextDescription ItemRendererProperties QuotedPrintableCoder StreamWriter
BarringSsAction ContextExecuteMsg ItemRendererPropertiesChangedMsg
R
String
Base64Coder ContextFeature ItemTree RadioAudioDevice StringDataSink
BaseDataHandler ContextFeatureHandle
J
RadioAudioDevice::StationInfo StrokeBox
BaseInformationElement ContextFeatureItem JapaneseTextRenderer RadioButtonAction StrokeBoxView
BasicPackConnector ContextFeatureTriggerMsg JapaneseTranscoder RadioButtonControl Subaddress
BasicPbWin ContextManager JarBinDataStatusInfo RadioButtonControlView SubMenuAction
BasicSmsService ContextMenu JarFileGlobalInfo_s RadioButtonGroup SubstitutedText
BatteryLoadLevelMsg ContextMenuClosedMsg JarFileStatusInfo RadioButtonItem SubSystem
BcdPlmn ContextMsg JmpBuf RadioButtonList SubSystemManager
BdnIndArg ContextTable JoinProvider RadioButtonListView SubUnitReference
BdnReqArg ContextTableEntry JoinProviderListener RadioButtonModel SvgDecodingFinishedMsg
BidiManager ContextTableNode JoinRule RadioButtonView SvgFileWrapper
BidiManager::ParagraphContext ContextWakeupMsg JpegEncoder RamBlockData SvgGzFileWrapper
BigEndian16Bit ContinueSocketTestMsg JpegEncoder::EncodingParameters RamData SvgHyperlinkSelectMsg
BigEndian32Bit Control JpegEncodingThreadlet RamDataSink SvgImage
BinData Control::ComponentIterator JpegImage RamDataSource SvgImageFileWrapper
BinDataDataSource Control::NavigationGuidance JumpToRowMsg RamDirectoryIteratorImp SvgIoWrapper
BinDataInReadStatusInfo ControlDc
K
RamFile SvgMimeUtil
BitField ControlFrameView KeyAutoRepeatMsg RamFileImp SvgPlayer
Bitmap ControlHwDataOnlyArg Keyboard RamFileInfo SvgStatusMsg
BitmapDc ControlMsg KeyboardConfig RamFileNode SwitchedRleCompression
BitmapRes Conversion KeyDownInputMapEntry RamFileObj SwitchedRleCompression::Context
BitVector CopyHandler KeyDownInputMapItem RamFileSystem SyncAction
BlackAndWhiteTheme CopyToPbAction KeyDownMsg RamHandler SyncMLCTCap
BlerTrchInfo CountryProvider KeyManager RamStorageDeviceImp SyncMLCTParam
BlerTrchInfoList COverIList KeyMapping RamStorageMapper SyncMLCTProp
BlobObject CphsAuxProvider KeymapTableEntry RangeMappingPolicy SyncMLCTTypeVerCT
BlobPtr CphsCfufArray KeyMsgGenerator RangeRule SyncMLCTValueDef
BlockData CphsCfufReadIndArg KeyMsgGenerator::Key RatChangeModeChangedMsg SyncMLDataStoreProps
BlueSkyCheckBoxListView CphsCfufReadReqArg KeySequence RatStateMsg SyncMLDynamicProps
BlueSkyCheckBoxView CphsCfufUpdIndArg KeySequenceCandidate Rdn SyncMLItemMetaInfo
BlueSkyChineseTheme CphsCfufUpdReqArg KeyToneAudioDevice RealTimeClock SyncMLManager
BlueSkyControlFrameView CphsCspArray KeyToneAudioDevice::StartParam RealTimeClock::DateAndTime SyncPaintDc
BlueSkyPositionIndicatorView CphsCspReadIndArg KeyUpInputMapEntry Record SyncPhoneAction
BlueSkyProgressBarView CphsCspReadReqArg KeyUpInputMapItem RecordHandler SyncPhoneAllAction
BlueSkyPushButtonView CphsCspUpdIndArg KeyUpMsg RecordSettings SyncPhoneThreadlet
BlueSkyRadioButtonListView CphsCspUpdReqArg
L
Rect SyncProgressMsg
BlueSkyRadioButtonView CphsIstArray L1Param RedialIndArg SyncSimAction
BlueSkySoftkeyBarView CphsIstReadIndArg L2CapSocketAddr RediallingDisabledIndArg SyncSimAllAction
BlueSkyTextListView CphsIstReadReqArg Lai RedialQueryReqArg SysDnsClient
BlueSkyTheme CphsOnmName LanguageArray RedialRejArg SysSocket
BlueSkyWindowFrameView CphsOnmReadIndArg LanguageChangedMsg RedialSetupIndArg SysSocket::FdSet
BmpImage CphsOnmReadReqArg LanguageCodeTableEntry RedialSetupMsg SysSocket::FdSet
BooleanCondition CphsOnsName LanguageManager RedialStartedMsg SysSocket::FdSet
BootControl CphsOnsReadIndArg LanguageProvider RedialStatusIndArg SysSocketBase
BootDispatcher CphsOnsReadReqArg LanguageResetAction RedialStatusMsg SysSocketBase::LingerSetting
BootDispatchingArg CphsServPflProvider LanguageSelectEventArg RedialStopIndArg System
BootHandler CphsVmwfArray LanguageSettingIndArg RedialStoppedMsg SystemTimer
BootState CphsVmwfReadIndArg LanguageSettingReqArg RedialSuccessMsg
T
BoundedItem CphsVmwfReadReqArg LastLocationEstimate RedrawDisplayMsg T9AddWordMsg
BrowserRegisterReqArg CphsVmwfUpdIndArg LaunchBrowserIndArg ReferableObject T9EnteredUnknownWordMsg
BrowserSaveWin CphsVmwfUpdReqArg LaunchBrowserPromptIndArg ReferenceLocation T9InputConfig
BrowserTermEventArg CrssHandler Layouter ReferenceTime T9InputMapper
BrowserView CsdDataConn LcsAppRegisterForMtlrMsg RefreshComponentMsg T9MatrixModeKeypressed
BrowserViewContainer CsdDataConnAccessor LcsAppResWinMsg RegApp T9NoWordFoundMsg
Brush CsdDataConnProfile LcsAppTransferLocMsg RegAppCommon T9Pack
BtActiveDeviceWindow CsdDataConnProfile::Bit LcsAppUtils RegAppFirstWin T9PackConnector
BtAlertMessageWindow CsdDataConnProfile::Persist LcsArc RegAppWin T9PinyinBox
BtApplication CsdDataConnProvider LcsCommonMsgProcessor RegBlobObject T9PinyinBoxView
BtApplicationDevicePairRequest CsdSettingsTable LcsCommonSignalMapTableNode RegCbNotifyMsg T9PredictiveInputBox
BtApplicationDeviceSearchRequest CTControlFrameView LcsCommonSignalProcessor RegDeletionBufferEntry T9SymbolEntryRequestMsg
BtApplicationDeviceTrustRequest CtmInfoIndArg LcsCommonStackMsgArgsDestroyTableNode RegDirtyFile T9ThaiMatrixModeWindowInterface
BtApplicationDeviceUnpairRequest CtmInfoIndMsg LcsMainApp RegEncoderDecoder T_PB_CHANGED_FIELD
BtApplicationDeviceUntrustRequest CTPanelView LcsMainMenuWin RegEncoderDecoder::IteratorObjResult T_PB_CLIENT_FLAGS
BtApplicationMessage CTPositionIndicatorView LcsMmiQos RegEncoderDecoder::Mobile2PCMsg T_PB_DESCRIPTOR
BtApplicationQuerySupportedProfilesRequest CTProgressBarView LcsMolrResultArg RegEncoderDecoder::Mobile2PCMsg::msg T_PB_FILE_A
BtApplicationRespondAuthorizationRequest CTPushButtonView LcsMsgProcessor RegEncoderDecoder::Payload T_PB_FILE_DESC
BtApplicationSendPasskeyRequest CTResourcePack LcsOptionsMenuWin RegEncoderDecoder::PC2MobileMsg T_PB_FILE_IN_SLICE
BtApplicationServiceVerifyRequest CTWindowFrameView LcsPoint RegEncoderDecoder::PC2MobileMsg::msg T_PB_FILL_STATUS
BtApplicationSetRemoteDeviceNameRequest CugCallMsg LcsPointAltitudeUncertEllipsoid RegEncoderDecoder::RegIteratorNodeType T_PB_GROUP_NUMBER
BtAttributeId CugDescriptor LcsPointUncertCircle RegEncoderDecoder::Response T_PB_GROUPING
BtAudioAccessoryService CurrencyCode LcsPointUncertEllipse RegEncoderDecoder::SetUpMsg T_PB_LOC_REPORT
BtAuthorizationRequiredMessage CurrentCallMeterMsg LcsProvider RegEncoderDecoder::UriAndPayload T_PB_RECORD
BtAuthorizationRequiredWindow CurrentChargeDataMsg LcsProviderImpl RegFileHeader T_PB_REF_FILE
BtAvrcpAlertMessageWindow CustomizableTheme LcsProviderImplBase RegistrationAllowedMsg T_PB_REF_FILE_FILL_STATUS
BtAvrcpCommandInterface CustomRingerAudioReference LcsQos RegistrationChangeMsg T_PB_REF_FILE_FILL_STATUS_A
BtAvrcpConnectResponse CustomSmafPhraseAudioReference LcsRepeatTimer RegistrationSuccessMsg T_PB_REF_RECORD
BtAvrcpControllerApplicationWindow CustomToneAudioReference LcsReqProcessor Registry T_PB_REFERENCE
BtAvrcpControllerDeviceListItem
D
LcsSettingsApp RegistryInterface T_PB_STATE
BtAvrcpControllerDeviceListWindow DataCallContext LcsSettingsUtils RegIterator T_PB_UNIQUE_FILE
BtAvrcpDeRegisterRequest DataCallControl LcsSignalMapTableNode RegIterator::InteriorMetaData T_PB_UNIQUE_FILE_FILL_STATUS
BtAvrcpDeviceListWin DataCallHdl LcsSignalProcessor RegIterator::LeafMetaData T_STK_TRANSACTION_ID
BtAvrcpMessageArgumentsDestroyTableNode DataCallSignalMapTableNode LcsSocket RegManager TabButton
BtAvrcpNmaConnect DataCallSignalProcessor LcsStackMsgArgsDestroyTableNode RegMemoryBuffer TabButtonView
BtAvrcpNmaDisconnect DataCoding LcsTimer RegMemoryPool TabControl
BtAvrcpNmaPanelPassThrough DataCodingScheme LcsUtils RegNodeBuffer TabControlView
BtAvrcpNmaRawFrame DataCodingSchemeRange LcsWapIntf RegNodeFileHeader tagCPGlyph
BtAvrcpNotificationMessage DataConn LcsWString RegNodeRecord tagCustFileData
BtAvrcpOperationRequestResponse DataConnAccessor Led RegNotifyMsg tagCustomizationPack
BtAvrcpOperationService DataConnApp Led::Color RegObjectData tagDataPackHeader
BtAvrcpOperationServiceMessage DataConnApp::DataConnDescription Led::Frame RegStateIndArg tagFilePackData
BtAvrcpPanelApplication DataConnApp::EditableSettingTable Led::Stream RegTcpSocket tagFont
BtAvrcpPanelPassThroughParams DataConnCommonSettingsTable Led::StreamField RegUriMapFile tagFontFamily
BtAvrcpPanelPassThroughRequest DataConnInfoMsg LedNotificationMsg RejectCallsIndArg tagFontPack
BtAvrcpPanelService DataConnLbModel LedSignalMapTableNode RemotePartyActionMsg TaggedProblemCode
BtAvrcpPanelServiceImpl DataConnManager LedSignalProcessor RenameFileDialog tagGlyphData
BtAvrcpProfileOperationService DataConnOptionWin LessRule ResourceID tagLanguage
BtAvrcpProfileRegistrationService DataConnProfile LexAnalyzer ResourceManager tagLdbData
BtAvrcpRawFrameParams DataConnProfile::Bit LineEditor ResultWinBase tagT9Pack
BtAvrcpRawFrameRequest DataConnProfile::Persist Linkable RfcommSocketAddr tagTextPack
BtAvrcpRegisterParams DataConnProfileInfoMsg LinkableBase RfsMediaAvailableStatusMsg tagTranslationTable
BtAvrcpRegisterRequest DataConnProfileManager LinkedList RfsObexFtpServer TAlphaIdentifier_s
BtAvrcpRegistrationService DataConnProfileManager::ProfileInfo LinkedListBase RfsStorageDeviceRegistrationStatusMsg TAlphaIdentifierArray
BtAvrcpRequest DataConnProfileStorage ListPropertyDescriptor RichTextCompoundItem Task
BtAvrcpRequestStateChangedMessage DataConnProfileStorage::Header LittleEndian16Bit RingerAudioDevice TcpNetAdapter
BtAvrcpService DataConnProvider LittleEndian32Bit RingerAudioDevice::RingerToneInfo TcpServerSocket
BtAvrcpSubunitInfoEntry DataConnTypeWin LocalDataStore RingerAudioDevice::StartParam TcpServerTestSocket
BtAvrcpSubunitInfoParams DataConnWin Locale RomData TcpSocket
BtAvrcpSubunitInfoRequest DataControl Locale::LocaleData RomDataRes TcpSocketBase
BtAvrcpUnitInfoParams DataControlBootMsg LocaleConfig RomFont TcpTestSocket
BtAvrcpUnitInfoRequest DataControlBootProgressMsg LocationErrMsg RootDirectoryIteratorImp TelecaVrEngineParams
BtBipAbortIndArg DataControlEndBootMsg LocationEstimate RootFileImp TermRspCnfArg
BtBipAttachment DataControlModificationMsg LocationNotifInvokeArg RootFileSystem TermRspCnfMsg
BtBipAttachmentDesc DataControlPhonebookStateMsg LocationNotifInvokeMsg RootStorageDeviceImp TestCheckBoxListView
BtBipAttachmentFormat DataControlStartBootMsg LocationResMsg RootStorageDeviceIterator TestCheckBoxView
BtBipClientService DataHandler LocationResultWin RrcParam TestControlFrameView
BtBipConnectIndArg DataItem LocationVerifWin RrcProcessState TestparamReport
BtBipDeleteImageIndArg DataPack LociData RrParam TestparamReportArg
BtBipDisconnectIndArg DataRateTable LockedKeyDownMsg RtcAlarmReachedMsg TestparamReqArg
BtBipGetImageInd DataRecord LockedKeyMsg RtcDateChangedMsg TestPositionIndicatorView
BtBipGetImageIndArg DataRecordHandler LockProvider RtcInfoMsg TestPushButtonView
BtBipGetImagePropertiesInd DataSink LockTable RtcSignalMapTableNode TestRadioButtonListView
BtBipGetImagePropertiesIndArg DataSource LockTableEntry RtcSignalProcessor TestRadioButtonView
BtBipGetImagesListInd DataSourceBinData LockTableList RtcTimeChangedMsg TestSoftkeyBarView
BtBipGetImagesListIndArg DataSourceRtStreamingSource LocResController RtStreamingBuffer TestTheme
BtBipGetImagingCapabilitesIndArg Date LongKeyPressMsg RtStreamingConn TestWindowFrameView
BtBipGetImagingCapabilitiesIndArg Date::Persist LookupAlphaIdExtension RtStreamingEndPoint TestWriter
BtBipGetLinkedAttachmentInd DateCompoundItem LoseFocusMsg RtStreamingEndPoint::BufferInfo TextBox
BtBipGetLinkedAttachmentIndArg DateEditBox LsaIdentifier RtStreamingSink TextBoxView
BtBipGetLinkedThumbnailInd DateEditBoxModel LsaIdentifierArray RtStreamingSource TextCompoundItem
BtBipGetLinkedThumbnailIndArg DateEditBoxView LsaIdentityMsg
S
TextEditorDocument
BtBipImage DateEditor
M
S_SvgFixPointTrans TextFormat
BtBipImageDesc DateEditorDocument MainDesktop SaLocationErrArg TextIconPairArray
BtBipImageFormat DateEditorView MainHandler SaMolrResultArg TextIconPairArray::TextIconPair
BtBipImageFormat::ImageDim datestr MainHandlerAccess SaMsgProcessor TextIndicator
BtBipImageHdl DateStr MainProvider SaProviderImpl TextLine
BtBipImageHdlDesc DateTime MapiAudioPlayer SaSignalMapTableNode TextLineView
BtBipImageList DateTime::Persist MapiAudioReference SaSignalProcessor TextList
BtBipImageProperties DateTimeInputMapper MappingPolicy SaStackMsgArgsDestroyTableNode TextListLine
BtBipImagingCapabilities DbgDump MbiProvider SatelliteInfo TextListModel
BtBipMsgArg DbgTimingMeasurement MCServiceInterfaceMsg SatteliteGraphWin TextListView
BtBipOpFinishedArg DBItemChangedMsg MdhDeletionCmd SatteliteInfoWin TextMenuAccessor
BtBipProgressMsg DBService MdhDeregistrationCnfArg SaveEntryInPhonebookMsg TextPack
BtBipPutImageCompleteArg DBService::DBItemIterator MdhDeregistrationReqArg SaveNoAction TextPackConnector
BtBipPutImageIndArg DchReport MdhExtendedData SavingProgressWin ThaiTextRenderer
BtBipPutLinkedAttachmentCompleteArg DcsLanguageFilterRule MdhGors ScanlineAccessor ThaiTextRenderer::ThaiFontHint
BtBipPutLinkedAttachmentInd DebugOutputStream MdhMakeViewCnfArg Scheduler Theme
BtBipPutLinkedAttachmentIndArg DecodingThreadlet MdhMakeViewReqArg ScicosCodecIfLib ThemeChangedMsg
BtBipPutLinkedThumbnailCompleteArg DefaultCaret MdhNewStatusReportIndArg ScicosMpeg4VideoDecoder ThemeConfig
BtBipPutLinkedThumbnailIndArg DefaultCheckBoxListView MdhRegistrationCnfArg ScicosMpeg4VideoEncoder ThemeManager
BtBipServerNotificationMsgArg DefaultCheckBoxView MdhRegistrationReqArg SearchBox ThemeViewIterator
BtBipServerService DefaultChineseTheme MdhRemoveViewCnfArg SecLockCode Thread
BtBppClientService DefaultControlFrameView MdhRemoveViewReqArg SecLockCommand Threadlet
BtBppController DefaultDisplay MdhResult SecLockDescriptor ThreadletNotificationMsg
BtBppReq DefaultItemRenderer MdhSetConfigCnfArg SecLocks ThreadSafeProvider
BtBppRequestStateChangedMessage DefaultPanelView MdhSetConfigReqArg SecLockStates Ticks
BtBppServerService DefaultPositionIndicatorView MdhSetStorageCnfArg SecMmiConfigData TickValue
BtBppService DefaultProgressBarView MdhSetStorageReqArg SelectedLineRetriever Time
BtBppSndAbortReqRequest DefaultPushButtonView MdhSetWaitIndicator SelectionBox Time::Persist
BtBppSndFilePushReqRequest DefaultRadioButtonListView MdhSetWaitIndicatorArray SelectionBoxView TimeCompoundItem
BtBppSndGetRefObjRspRequest DefaultRadioButtonView MdhSmsConcRefNumIndArg SelectionChangedMsg TimeEditBox
BtCancelableBroadcastRequest DefaultSoftkeyBarView MdhSmsConcRefNumReqArg SelectItemReqArg TimeEditBoxModel
BtCancelableMulticastRequest DefaultTabButtonView MdhSmsDeletionIndArg SelectItemRspArg TimeEditBoxView
BtCancelableRequest DefaultTabControlView MdhSmsDeletionReqArg SelfLocationDialog TimeEditor
BtCancelSearchMessage DefaultTextListView MdhSmsExtendedDataIndArg Semaphore TimeEditorDocument
BtCancelVerifyMessage DefaultTheme MdhSmsExtendedDataReqArg SemObtainer TimeFeatureObject
BtChipBmscr DefaultWindowFrameView MdhSmsInitFinishedIndArg SendRequestMsg TimeoutCondition
BtChipBmu DelegationProviderListener MdhSmsNewMessageIndArg SendSmsMsg Timer
BtChipVersion DeleteComponentMsg MdhSmsReadIndArg SerDataConnAccessor TimerTimeoutMsg
BtCloseMessage DeletedNode MdhSmsReadReqArg SerDataConnProvider TimeSpan
BtConnectabilityMessage DeletedNodeList MdhSmsRefreshIndArg SerialClientSocket TimeZone
BtConnectionBasedController Desktop MdhSmsReportReadIndArg SerialIoAdapter TimeZoneAndTime
BtConnectionlessController DetachCnfArg MdhSmsReportReadReqArg SerialIoAdapter::SioErrorDesc TimeZoneMsg
BtConnectRequest DetachReqArg MdhSmsSetWaitingReqArg SerialIoSet TipdBasedActiveWaitDispatcher
BtController DeviceContext MdhSmsStatusIndArg SerialServerSocket Tlv
BtDevice DeviceManager MdhSmsStatusReqArg SerialSocket TMsapPackedDataArray
BtDeviceAddress DeviceManager::Iterator MdhSmsStorageRefreshIndArg SerialSocketData ToDoApp
BtDeviceAddressGenericObject DhChannelChangeStatusEventArg MdhSmsTransmitAckArg SerialSocketDataLock ToDoComposeWin
BtDeviceAndServiceClass DhChannelChangeStatusResArg MdhSmsTransmitIndArg SerialSocketSubSystem ToDoDateDialogWin
BtDeviceDetailWindow DhChannelChangeStatusResMsg MdhSmsTransmitStartAckArg SerialSocketThread ToDoListWin
BtDeviceFilter DhChannelCloseIndArg MdhSmsTransmitStartIndArg SerialTerminal ToDoPriorityDialogWin
BtDeviceList DhChannelCloseReqArg MdhSmsTransmitStopIndArg SerialTerminalArg ToDoProvider
BtDeviceList::BtDeviceListBidirectionalIterator DhChannelCloseReqMsg MdhSmsUpdStatusIndArg SerialTerminalListener ToDoRecord
BtDeviceList::BtDeviceListNode DhChannelDataAvailableResArg MdhSmsUpdStatusRefreshIndArg SerialTerminalMsgArgsDestroyTableNode ToDoRecord::Persist
BtDeviceListConstantIterator DhChannelDataAvailableResMsg MdhSmsUpdStatusReqArg SerialTerminalSocket ToggleActionGroup
BtDeviceListConstantReverseIterator DhChannelDataAvailEventArg MdhSmsWaitingIndArg SerSettingsTable ToneAudioDevice
BtDeviceListItem DhChannelOpenCnfArg MdhSmsWriteCnfArg Server ToneAudioDevice::StartParam
BtDeviceListIterator DhChannelOpenRejArg MdhSmsWriteReqArg ServerAddressWin ToneAudioDevice::UserTone
BtDeviceListProvider DhChannelOpenReqArg MdhViewConfig ServerClient TopLevelMenu
BtDeviceListReverseIterator DhChannelOpenReqMsg MdhWaitIndicator ServerConfig ToStackMsg
BtDeviceListWindow DhChannelReceiveIndArg MdhWaitIndicatorArray Service Tpdu
BtDevicePairMessage DhChannelReceiveReqArg MeasurementData ServiceBroker TpduCache
BtDevicePairRequest DhChannelReceiveReqMsg MeasurementDataArg ServiceProviderStruct TpduConc
BtDeviceSearchMessage DhChannelSendIndArg Media ServicePtr TpduHeaderInformation
BtDeviceSearchModeWindow DhChannelSendReqArg Media::Parameters ServiceThread TpduNode
BtDeviceSearchRequest DhChannelSendReqMsg MediaBox ServiceThreadStarter TpduPhoneNumberPersist
BtDeviceTrustMessage DiagnosticIndArg MediaBoxView ServiceThreadStarter::StartParam TraceOutputStream
BtDeviceTrustRequest DiagnosticIndMsg MediaBrowserUtils ServiceThreadTerminateMsg TRadioButtonItem
BtDeviceUnpairMessage DialogWindow MediaFilter SetAutoChargeArg TRadioButtonList
BtDeviceUnpairRequest DirectoryIterator MediaFrameworkCaps SetChargeUnitsArg Transaction
BtDeviceUntrustMessage DirtyFileHandler MediaInfo SetLanguageAction TransferLocationDialog
BtDeviceUntrustRequest DisabledFeatureTriggeredMsg MediaInfo::AudioTrackInfo SetThemeAction TransportNotificationMsg
BtDisconnectRequest Dispatcher MediaInfo::ClipInfo SettingsProvider Trap
BtDiscoverabilityMessage DispatcherAction MediaInfo::MediaTrackInfo SetupDataConnMsg TriggerKeyFeature
BtDunApplicationMessage Display MediaInfo::VideoTrackInfo SetupEventCnfArg TriggerTimer
BtDunAppPlugin Display::CustomFrameBuffer MediaManager SetupIdleModeTextReqArg TSiIconID_s
BtDunConnectMessage DisplayConfig MediaManagerMsg SetupIdleModeTextRspArg TSiUrl_s
BtDunDisconnectMessage DisplayDc MediaObtainer SetupMenuReqArg TtyInterface
BtDunProfileService DisplayInfoMsg MediaPathnameVisitor SetupMenuRspArg TypeOfAddress
BtDunRequestStateChangedMessage DisplayMemoryAction MediaPlayer SharedMemHdl
U
BtDunService DisplaySettings MediaRecorder SharedPtr UdpNetAdapter
BtEvent DisplayTextReqArg MediaRef SharedTimer UdpSocket
BtFaxApplicationMessage DisplayTextRspArg MediaRefContainer SharedTimerMsg UdpTestSocket
BtFaxAppPlugin DistinctProvider MediaRefLinkable SharedTriggerTimer UibAccessorTest
BtFaxConnectMessage DistinctRule MediaVisitor ShortMessageFailureCause UibActionAccessor
BtFaxDisconnectMessage DnsClient Melody ShortMessageStatus UibApp
BtFaxProfileService DnsClientTest MemMap ShutDown UibFolderWin
BtFaxRequestStateChangedMessage DownloadSettings MemoryConfig ShutdownRequestMsg UibInboxProvider
BtFaxService DrawableObject MemPool SiBearerDesc_s UibInboxTest
BtGapAndSdapApplicationMessage DrawableObjectView MemPoolEntry SiBearerDescArray UibListBoxModel
BtGapAndSdapNotificationMessage DrmAsset Menu SiBearerList_s UibMsgDisplayTest
BtGapAndSdapRemoteRequestMessage DrmConstraint MenuAccessor SiBearerListArray UibNotifyMsg
BtGapAndSdapRequestMessage DrmDcfHeader MenuDesc SiChannelCloseInfoIndArg UibNotifyTest
BtHfAppPlugin DrmDcfHeaderData MenuDescObj SiChannelCloseInfoIndMsg UibPerformanceTest
BtHfAudioPathWindow DrmDcfParser MenuIdObj SiChannelCloseInfoResArg UibRegisterMsg
BtHfCmaAtChldOneCommandReceived DrmInfo MenuItem SiChannelCloseReqArg UibServiceImpl
BtHfCmaAudioAsynchronous DrmInfoPersistStructure MenuList SiChannelOpenPromptReqArg UibSettingsProvider
BtHfCmaCheckPendingAudioCallback DrmMediaObject MenuListView SiChannelOpenPromptReqMsg UibSettingsRecord
BtHfCmaMOC DrmMessage MenuPool SiChannelOpenPromptResArg UibSettingsTest
BtHfCmaMTC DrmPermission MenuPool::FeatureItemContainerContentTableEntry SiChannelReceiveInfoIndArg UibSettingsWin
BtHfCmaPhoneNumberRequired DrmRelParser MenuPool::FeatureItemContainerTableEntry SiChannelReceiveInfoIndMsg UibSortingTest
BtHfFeatureListWin DrmRightsMapTableEntry MenuPool::MenuTableEntry SiChannelReceiveInfoResArg UibTest1
BtHfInbandSettingWin DrmRightsObject MenuProperties SiChannelSendInfoIndArg UibTest2
BtHfMessageArgumentsDestroyTableNode DrmRightsObjectContainer MenuSelectionRejArg SiChannelSendInfoIndMsg UibUpdateMsg
BtHfNmaAudioConnectionLost DrmRightsObjectFile MenuSelectionReqArg SiChannelSendInfoResArg UibUpdateThreadlet
BtHfNmaCallEvent DrmRightsObjectStore MenuTable SiDuration_s UmtsCellList
BtHfNmaConnect DrmROStoreSingleton MenuTableNode SigDispatcher UmtsMeasEvalParam
BtHfNmaDisconnect DrmSecurity MenuTextIterator SigHandler UmtsMeasIdParam
BtHfNmaLowPowerModeNotPossible DrmSubsystem MenuTextPtrArrayIterator SignalHandler UmtsNcellParam
BtHfNmaMicrophoneGain DrmUtils MenuView SignalMapTable UmtsNcellParamList
BtHfNmaSpeakerGain DrmWapPushMsg MenuWindow SignalMapTableEntry UmtsRrcScellParam
BtHfNmaTransferAudioToAccessory dstat MePhonebookDescription SignalMapTableNode UndefinedSsAction
BtHfNmaTransferAudioToPhone DtmfBufferCleanedMsg MePhonebookDescriptor SignalQualityLevelMsg UnlockAction
BtHfNotificationMessage DtmfBufferClearedIndArg MergeProvider SignalStrengthLevelIndArg UnsignedValue
BtHfProfileService DtmfRejectArg Message SignalStrengthLevelMsg Unzipper
BtHfProfileWindow DtmfRejectMsg MessageBox SignedValue UpdateContextItemMsg
BtHfProvider DtmfStartCnfArg MessageHook SiIpAddress_s UpdateItemMsg
BtHfRecord DtmfStartCnfMsg MessageIdentifier SiIpAddressArray UpdatePbThreadlet
BtHfRecord::Persist DtmfStopCnfMsg MessageIdentifierContainer SimAccessor Uplmn
BtHfRequestStateChangedMessage DualFilterProvider MessageIdentifierContainer::MessageIdentifierPair SimAcmMaxReadIndArg Uri
BtHfService DummyVrEngineParams MessageIdentifierRange SimAcmMaxReadReqArg UriMappingTable
BtHfSupportedProfileMessage DwdDevice MessageMap SimAcmMaxUpdIndArg UsbApp
BtHfVolumeSettingsWin DwdPlayer MessageMapContainer SimAcmMaxUpdReqArg UsbObexServerAddr
BtHsAppPlugin DynamicBitVector MessageMapDispatcher SimAcmReadIndArg UsbObexTransport
BtHsCmaAudioAsynchronous DynamicMenuPool MessageReferrer SimAcmReadReqArg UsbSubSystem
BtHsCmaAudioTransferOutOfCall
E
MessageRouter SimAcmUpdIndArg UsbTransport
BtHsCmaCheckPendingAudioCallback EccArray MessageTypeIndicator SimAcmUpdReqArg UserActivityEventArg
BtHsCmaEnterLowPowerMode EccCategory MetaData SimAlphaIdentifier UserActivityListener
BtHsCmaHangUp EccCustomization MetaDataRecord SimApdu UserData
BtHsConnectionSettingWin EccListIndArg MexeDescriptor SimApduData UserDataHeader
BtHsInbandSettingWin EccNetworkArray MidiSound SimAtom UserDispatcher
BtHsMessageArgumentsDestroyTableNode EccNetworkElement MimeCoder SimAuxHandler UsimCardTypeReadIndArg
BtHsNmaAudioConnectionLost EccNetworkNumber MimeCoding SimBrowserTermResArg UsimCardTypeReadReqArg
BtHsNmaCallEvent EccProvider MimeTypeFilter SimBrowserTermResMsg UsimCsLociReadIndArg
BtHsNmaConnect EctActiveMsg MimeTypeTable SimCallSetupMsg UsimCsLociReadReqArg
BtHsNmaDisconnect EctAlertingMsg MimeTypeTable::Partition SimCallSetupRejectedMsg UsimEccReadIndArg
BtHsNmaLowPowerModeNotPossible EctCnfArg MimeTypeTableEntry SimCbmiReadIndArg UsimEccReadReqArg
BtHsNmaMicrophoneGain EctIndicator MinuteTickMsg SimCbmiReadReqArg UsimEccRecord
BtHsNmaSpeakerGain EditBox MiscAudioDevice SimCbmirReadIndArg UsimEst
BtHsNmaTransferAudioToAccessory EditBoxBlinkTimer MiscAudioDevice::AvailableHW SimCbmirReadReqArg UsimEstReadIndArg
BtHsNmaTransferAudioToPhone EditBoxModel MiscAudioDevice::PowerStatus SimCbmirUpdIndArg UsimEstReadReqArg
BtHsNotificationMessage EditBoxPagingTimer MlcNumber SimCbmirUpdReqArg UsimFileProperty
BtHsProfileService EditBoxView MmAocChargingStatusMsg SimCbmiUpdIndArg UsimFilePropertyIndArg
BtHsRequestStateChangedMessage EditConfig MmCallAcceptMsg SimCbmiUpdReqArg UsimFilePropertyReqArg
BtHsService EditLine MmCallDisconnectingMsg SimCcpReadIndArg UsimLangReadIndArg
BtHsSupportedProfileMessage EditorDocument MmCallDispatcher SimCcpReadReqArg UsimLangReadReqArg
BtHsVolumeSettingsWin EditorDocumentObtainer MmCallHandler SimCcpUpdIndArg UsimLanguage
BtIndicatorMsg EditorItemNode MmCallHdl SimCcpUpdReqArg UsimLanguageList
BtJsr82Url EditorLine MmCallInfo SimChvHandler UsimLangUpdIndArg
BtJsr82Url::Token ElementList MmCallInfoMsg SimClutEntry UsimLangUpdReqArg
BtJsr82Url::Token::Keyword ElementListBase MmCallNotifyMsg SimCmiReadIndArg UsimPbChangedField
BtLocalNameMessage emcpp_apoxi_OBEXAdapter MmCallReleaseMsg SimCmiReadReqArg UsimPbFillStatus
BtLocalRequest EmlppAction MmCallSerialTerminalListener SimCphsHandler UsimPbFillStatusReqArg
BtLocalSettings EmlppHandler MmCallSetupProgressMsg SimData UsimPbFillStatusResArg
BtLocalSettingsMessage EmlppPriority MmCallStatusMsg SimDfParameters UsimPbGroups
BtMultiConnectionController EmlppRegisteredMsg MmCellChangeCnts SimDispatcher UsimPbLocationIndArg
BtMultiConnectionController::BtConnection EmlppStatusMsg MmCoordParam SimDisplayTextMsg UsimPbLocationReqArg
BtObexAbortRequest EmsApp MmcsParam SimDisplayTextOptions UsimPbLocReport
BtObexClientAbortEvent EmsComposeWin MmCurrentCallMeterMsg SimEfOrangeParam UsimPbReadAsyncIndArg
BtObexClientAddr EmsCreator MmCurrentChargeDataMsg SimEfParameters UsimPbReadCnfArg
BtObexClientAddrResultNotifier EmsCreator::SpaceInfo MmfPlayer SimEfRefresh UsimPbReadDataAsyncIndArg
BtObexClientConnectEvent EmsEditor MmfPlayer::MediaPlayerInstanceData SimEfRefreshTable UsimPbReadDataReqArg
BtObexClientDisconnectEvent EmsEditorListener MmiSimClient SimEndTransactionMsg UsimPbReadDataResArg
BtObexClientEvent EmServThreadMsg MmiSimMsg SimErrorIndArg UsimPbReadRefAsyncIndArg
BtObexClientGetEvent EmsIeParser MmiSimMsgArg SimErrorMsg UsimPbReadRefReqArg
BtObexClientNmaDataBufferIndication EmsImage MmiSimServer SimEventList UsimPbReadRefResArg
BtObexClientNmaDataInidication EmsInsertPrompt MmMocSetupAcceptMsg SimExtLangReadIndArg UsimPbReadReqArg
BtObexClientNmaHeaderIndication EmsInsertPromptListBoxModel MnInformationIndArg SimExtLangReadReqArg UsimPbReadResArg
BtObexClientNmaHeaderSent EmsResourceMaps MnNetworkSearchModeReqArg SimExtLangUpdIndArg UsimPbReadyIndArg
BtObexClientNmaTransportDisconnect EmsResourceMaps::AnimNode MnTriggerReqArg SimExtLangUpdReqArg UsimPbReadyMsg
BtObexClientNotificationMessage EmsViewerWin MobileOriginatedUssdHandler SimFileInfoIndArg UsimPbRefRecord
BtObexClientObserverImpl EmzAacDecoder MocAlertIndArg SimFileInfoReqArg UsimPbResetedMsg
BtObexClientOperationEvent EmzAacDecoderThread MoCallAction SimFullAccessIndArg UsimPbRwRecord
BtObexClientOperationRequest EmzCodecsLib MocSetupAccArg SimGenericIndArg UsimPbSelectReqArg
BtObexClientPutEvent EmzH264Decoder MocSetupAcceptMsg SimGenericReqArg UsimPbSelectResArg
BtObexClientRequestStateChangedMessage EmzH264DecoderThread MocSetupCnfArg SimGetInkeyMsg UsimPbStopReqArg
BtObexClientService EmzMp3Decoder MocSetupRejArg SimGetInkeyOptions UsimPbStopResArg
BtObexClientServiceImpl EmzMp3DecoderThread MocSetupRejectIndMsg SimGetInputMsg UsimPbUidRefreshIndArg
BtObexClientServiceObserver EmzMpeg4Decoder MocSetupRejIndArg SimGetInputOptions UsimPbUpdDataReqArg
BtObexClientSetPathEvent EmzMpeg4DecoderThread MocSetupReqArg SimHandler UsimPbUpdDataResArg
BtObexConnectRequest EmzMpeg4Encoder Model SimIconDescription UsimPbUpdRefReqArg
BtObexController EmzMpeg4EncoderThread MolrInfo SimIconIdentifier UsimPbUpdRefResArg
BtObexController::BtObexConnection EmzSbcEncoder MolrParams SimIconQualifier UsimPbUpdReqArg
BtObexDataBufferIndicationEvent EmzSbcEncoderThread MolrRepeatInfo SimImage UsimPbUpdResArg
BtObexDataIndicationEvent EmzUtils Mp3AudioDevice SimImageDescriptor UsimPlmn
BtObexDisconnectRequest EmzUtils::Queue Mp3AudioDevice::StartParam SimInfo UsimPlmnList
BtObexEvent EmzUtils::Queue MP3AudioPlayer SimInfoIndArg UsimPlmnReadIndArg
BtObexGetRequest EncodingThreadlet MP3AudioReference SimInitIndArg UsimPlmnReadReqArg
BtObexHeader EndSimToolkitIndArg Mp3Header SimItemId UsimPlmnUpdIndArg
BtObexHeaderIndicationEvent EngineeringModeControlRequestArg Mp3Param SimItemIdentifier UsimPlmnUpdReqArg
BtObexHeaderSentEvent EngineeringModeControlResponseArg MptyCallHdl SimLangReadIndArg UsimPsLociReadIndArg
BtObexImpl EngineeringModeControlResponseMsg MptyCallReleaseMsg SimLangReadReqArg UsimPsLociReadReqArg
BtObexMessageArgumentsDestroyTableNode EngineeringReportMsg MptyCnfArg SimLangUpdIndArg UsimReadRecordRejArg
BtObexPutRequest EnglishT9InputMapper MptyHoldRejectedMsg SimLangUpdReqArg UsimReadRejArg
BtObexRegisterClientEvent EngModeAction MptyOnHoldMsg SimLaunchBrowserPromptReq_s UsimSmsParamExtIndArg
BtObexRegisterClientRequest EnumTextMap MsapPackedData_s SimLaunchBrowserPromptReqArg UsimSmsParamReadIndArg
BtObexRegisterServerEvent EnumTextTableEntry MsgMetaData SimLaunchBrowserPromptReqMsg UsimSmsParamReadReqArg
BtObexRegisterServerRequest EnumTranslationTable MsgQueue SimLaunchBrowserReqArg UsimSmsParamUpdIndArg
BtObexRequest EqualsRule MtcAcceptArg SimLaunchBrowserReqMsg UsimSmsParamUpdReqArg
BtObexResponseCode EquivPlmnLists MtcAcceptRejArg SimLockStates UsimUpdCnfArg
BtObexSddbImpl EventData MtcAlertReqArg SimLockStatusIndArg UsimUpdRejArg
BtObexSddbServiceObserverImpl ExecutionContext MtcArrivedMsg SimLockStatusMsg UsimUst
BtObexServerAbortIndicationEvent ExternalCommunicationHandler MtcConfIndArg SimMccMncIndArg UsimUstReadIndArg
BtObexServerAddr ExternalPdpContextInfoMsg MtcReadyMsg SimMenuItemSelectionFailedMsg UsimUstReadReqArg
BtObexServerConnectIndicationEvent ExternalTimeoutMsg MtcSetupComplArg SimMexeCertificate UssdAction
BtObexServerDisconnectIndicationEvent ExtLanguage MtcSetupIndArg SimModifyLockIndArg UssdAnswerIndArg
BtObexServerEvent ExtLanguageArray MtlrInfo SimModifyLockReqArg UssdAnswerMsg
BtObexServerGetIndicationEvent ExtProactiveCmdCnfArg MultiLineEditor SimMruPropertyRefreshIndArg UssDataArg
BtObexServerNmaAbort ExtProactiveCmdIndArg MultiMediaEditor SimMruPropertyUpdCnfArg UssDataReceivedMsg
BtObexServerNmaConnect ExtProactiveCmdReqArg MultiMediaEditorDocument SimMruPropertyUpdReqArg UssdBeginMsg
BtObexServerNmaDataBufferIndication ExtPsdContextListener_SerialTerminal MultiMediaEditorDocument::TextManager SimNextActionIdentifier UssdControlIndMsg
BtObexServerNmaDataInidication ExtPsdContextListener_SerialTerminalListener MultiPartData SimODyn2ReadIndArg UssdDataMsg
BtObexServerNmaDisconnect ExtPsdContextListener_SioGlueSignalListener MultipartParser SimODyn2ReadReqArg UssdEndMsg
BtObexServerNmaGet ExtPsdContextListener_SioGlueWrapper MultiPartyCallInvokedMsg SimODyn2UpdIndArg UssdHandler
BtObexServerNmaHeaderIndication ExtPsdContextListener_SioGlueWrapper::SioCommId MultiSlotDispatcher SimODyn2UpdReqArg UssdIndicationMsg
BtObexServerNmaHeaderSent ExtPsdContextListener_SioGlueWrapper::TermIos MultiSlotHandler SimODynReadIndArg UssdNotifyMsg
BtObexServerNmaPut ExtPsdContextListenerImpl_SerialTerminalListener MultiSlotMode SimODynReadReqArg UssdRequestMsg
BtObexServerNmaSetPath
F
MultiTapCaret SimODynUpdIndArg UssdRequestResentMsg
BtObexServerNmaTransportDisconnect FatDirectoryIteratorImp MultiTapInputMapper SimODynUpdReqArg UssdResentMsg
BtObexServerNotificationMessage FatFile Mutex SimPbBaseHandler UtcStatusMessage
BtObexServerObserverImpl FatFileImp MutexObtainer SimPbEntry UtcTime
BtObexServerPutIndicationEvent FatFileInfo
N
SimPbEntryCont UusErasedMsg
BtObexServerRequestStateChangedMessage FatFindData NameIndicator SimPduHandler UusHandler
BtObexServerService FatFsUsbMassStorageReleaseMsg NamePatternFileFilter SimPhoneBookEntry UusNotificationMsg
BtObexServerServiceImpl FatFsUsbMassStorageRequestMsg NamePatternStorageDeviceFilter SimPlayToneMsg UusQueryRejectedMsg
BtObexServerServiceObserver FatHandler Native16Bit SimpleAppContext UusRegisteredMsg
BtObexServerSetPathIndicationEvent FatStorageDeviceImp Native32Bit SimpleAudioDevice UusStatusMsg
BtObexService FdnIndArg NativeImage SimpleMap UusText
BtObexServiceObserver FdnReqArg NeighbourCell SimpleMap::Iterator
V
BtObexServiceTable Feature NeighbourCellList SimpleMapElem ValidityPeriod
BtObexServiceTable::Entry FeatureBroker NetAdapter SimpleMutex ValidityPeriodFormat
BtObexServiceTable::ObexTarget FeatureChangedMsg NetAdapter::DataReceivedEventArgs SimpleScheduler ValueIndicator
BtObexServiceTable::Security FeatureHandle NetAdapter::DataSentEventArgs SimpleSemaphore ValueMappingPropertyDescriptor
BtObexServiceTable::ServiceInfo FeatureItem NetAdapter::EventArgs SimpleTextRenderer ValueTextMap
BtObexSetPathRequest FeatureItemContainer NetAdapterHandler SimPuctReadIndArg ValueTextMap::Table
BtObexSubSystem FeaturePool NetworkDispatcher SimPuctReadReqArg VCard
BtObexTransport FeatureTriggerMsg NetworkHandler SimPuctUpdIndArg VCardItem
BtObexTransportDisconnectEvent ffs_drm_attrib_type NetworkInformationMsg SimPuctUpdReqArg VCardParser
BtObexUnregisterClientRequest ffs_file_info_type NetworkSsErrorMsg SimRefreshIndArg VCardWriter
BtObexUnregisterEvent ffs_ref_type NetworkSsRejectedMsg SimRefreshMsg Vector
BtObexUnregisterServerRequest ffs_time_record_type NextSocketTestMsg SimRefreshReqArg Vector::Iterator
BtObservableService FfsDataConnProfileStorage NiSharedPtr SimRefreshResetMsg VersionInfo
BtOpenMessage FfsDrmAttrib NmeaUartSettings SimResetConfirmationMsg VersionInfo::Data
BtOperationBase FfsFile NodeFileHandler SimResetDoneMsg VeryLongKeyPressMsg
BtOperationSelectDevice FfsFileInfo NoMessage SimSelectItemMsg VibratorDevice
BtOperationSelectDeviceAndPerformServiceVerify FfsHandler NonCloneable SimSelectItemOptions VideoCamera
BtPairabilityMessage FfsMenu NonCopyable SimServices VideoCaptureParameters
BtPasskeyRequiredMessage FfsMimeTypeMap NonsharedBinDataDataSource SimServiceTable VideoChannel
BtPasskeyRequiredWindow FfsMimeTypeMapEntry NoStackMsgArg SimSetupIdleModeTextMsg VideoDecoder
BtPaSupportedProfileMessage FfsRefType NotEqualsRule SimSetupIdleModeTextOptions VideoEncoder
BtProfileActivationMessage FfsTestBase::FfsTestInfo NotificationArray SimSetupMenuMsg VideoEncoder::VideoEncoderDynParameters
BtQuerySupportedProfilesMessage FfsTestDispWin NotificationTable SimSetupMenuOptions VietnameseTextRenderer
BtQuerySupportedProfilesRequest FfsTestMenu NotificationTableEntry SimSmsParameter View
BtRemoteDeviceMessage FfsTestResultsMenu NotifyIndArg SimSmsParameter::Record ViewfinderErrorMsg
BtRemoteDeviceNameMessage FfsTestResultsSubMenu NotifySsArg SimSmsParamHandler VirtualDisplay
BtRemoteDevicePairMessage FfsTests NRegStateIndArg SimSmsrReadIndArg VmParam
BtRequest FfsTestSubMenu NumberIdentificationAction SimSmsrReadReqArg VoiceMemoApp
BtRequestMessage FfsTestThread NumberPrompt SimSmsrUpdIndArg VoiceMemoAudioDevice
BtRequestOperationMessage FfsTestThreadlet NumericInputMapper SimSmsrUpdReqArg VoiceMemoAudioDevice::StartParam
BtRequestRespondRequest FfsTimeRecord NvRamBlockInfo SimSmsSentMsg VoiceMemoMenuAccessor
BtRequestRunningWindow FifoLinkedList NvRamDataRecordHandler SimSpnReadIndArg VoiceMemoRecordWin
BtRequestStateChangedMessage File NvRamStorage SimSpnReadReqArg VoiceMemoWin
BtRespondAuthorizationMessage File::Attributes NwDiscStartIndMsg SimSsSentMsg VrAbortEngineIndArg
BtRespondAuthorizationRequest File::FileState
O
SimSstReadIndArg VrEngineParams
BtSddbDataElement FileBinData ObexAbstractPort SimSstReadReqArg VrErrorIndArg
BtSddbDataElementFactory FileChunkOperationProgressMsg ObexAbstractPort::AddressEvent SimStateChangedMsg VrErrorMsg
BtSddbDeAlternative FileChunkOperator ObexAbstractPort::CompleteEvent SimSubAddress VrG2AResultIndArg
BtSddbDeBaseCType FileDataSink ObexAbstractTransport SimTextString VrHandler
BtSddbDeBigSintBase FileDataSource ObexAddress SimTkCallSetupAccArg VrInitCnfArg
BtSddbDeBigUintBase FileFilter ObexAddrMsg SimTkCallSetupIndArg VrIntrmRecResultIndArg
BtSddbDeBoolean FileInfo_s ObexApp SimTkCallSetupRejArg VrLoadTemplateReqArg
BtSddbDeByteBlockType FileInfoInternal_s ObexAppMsg SimTkHandler VrParamReqArg
BtSddbDeContainer FileInputStream ObexBuffer SimTkInterfaceIndArg VrPlaybackFinishedMsg
BtSddbDeNil FileInReadStatusInfo ObexBuffer::Factory SimTkLanguageNotificationIndArg VrPromptMsg
BtSddbDeOneByteDescriptionType FileNameListBoxModel ObexBuffer::Reader SimTkLanguageNotificationMsg VrPropertyResultIndArg
BtSddbDeSequence FileNameView ObexBuffer::Writer SimTkLceService VrRecognitionAbortedMsg
BtSddbDeSint128 FileOutputStream ObexChannel SimTkMainMenuProvider VrRecognitionFailedMsg
BtSddbDeSint16 FilePack ObexClient SimTkProfile VrRecognitionStoppedMsg
BtSddbDeSint32 FilePackConnector ObexClientAddr SimTkProfileGetCnfMsg VrRecogResultIndArg
BtSddbDeSint64 FileVisitor ObexClientDispatcher SimTkProfileSetCnfMsg VrResultMsg
BtSddbDeSint8 FilterProvider ObexClientOppImpl SimTkProfileSetRejMsg VrSayNameIndArg
BtSddbDeSintBase FilterRule ObexClientPort SimTkRefreshCnfIndArg VrStackMsgArgTableDestroyTableNode
BtSddbDeString Find2Provider ObexDataServer SimTkRefreshCnfReqArg VrStopRecogIndArg
BtSddbDeUint128 FindProvider ObexDispatcher SimTkRefreshNewReqArg VrStoreTemplateReqArg
BtSddbDeUint16 FixedPtrArray ObexEventHandler SimTkRefreshNewRspArg VrTrainingAbortedMsg
BtSddbDeUint32 FlagCaretaker ObexFtpDataServer SimTkRefreshQueryReqArg VrTrainingFailedMsg
BtSddbDeUint64 FlashDirectoryIteratorImp ObexFtpServer SimTkRefreshQueryResArg VrTrainingResultMsg
BtSddbDeUint8 FlashFileImp ObexHeader SimTkRefreshReqArg VrTrainResultIndArg
BtSddbDeUintBase FlashStorageDeviceImp ObexHeaderBuilder SimTkRefreshResetReqArg VrWarningIndArg
BtSddbDeUrl FlipMsg ObexHeaderList SimTkRefreshResetRspArg VrWarningMsg
BtSddbDeUuid128 FlowLayout ObexHeaderList::ConstIterator SimTkRefreshRspArg
W
BtSddbDeUuid16 FlsFile ObexLayer SimTkRefreshStartMsg WaitSsAction
BtSddbDeUuid32 FmRadioApplication ObexMngr SimTkResetCnfArg WapHandler
BtSddbDeUuidBase FmRadioEditWin ObexMsg SimTkResetCnfIndArg WapProfile
BtSddbDeVariableLengthType FmRadioSelectStrongerFreq ObexObject SimTkResetCnfReqArg WapProfile::Ipv4E164
BtSddbEvent FmRadioSettingsProvider ObexObjectData SimTkRunAtCmdInfoIndArg WapProfile::PxLogicalCharacs
BtSddbRegisterServiceEvent FmRadioSettingsRecord ObexOperationId SimTkRunAtCmdInfoIndMsg WapProfile::PxLogicalCharacs::PxAuthInfoCharacs
BtSddbRequestStateChangedMessage FmRadioSettingsRecord::Persist ObexOppBinDataPushClient SimTkRunAtCmdInfoResArg WapProfile::PxLogicalCharacs::PxPhysicalCharacs
BtSddbService FmRadioStationsProvider ObexOppClient SimTkSendDtmfCnfArg WapProfile::PxLogicalCharacs::PxPortCharacs
BtSddbServiceAttribute FmRadioStationsRecord ObexOppClientOperation SimTkSendDtmfEndIndArg WapProfileMgr
BtSddbServiceObserver FmRadioStationsRecord::Persist ObexOppClientPull SimTkSendDtmfEndIndMsg WapProfileMgr::WapProfileInfo
BtSddbServiceRecord FmRadioWindow ObexOppClientPush SimTkSendDtmfIndArg WbmpImage
BtSddbUnregisterServiceEvent FocusNextControlMsg ObexOppDataSinkPushServer SimTkSendDtmfIndMsg WbxmlParserRel
BtSendPasskeyMessage FocusObtainer ObexOppServer SimTkSetupEventMsg WbxmlRelHandler
BtSendPasskeyRequest FocusPreviousControlMsg ObexProtocol SimTkSetupEventReqArg WbxmlVector
BtService FoggyPanelView ObexResult SimTkSmsPpIndArg Window
BtServiceMessage FoggyPositionIndicatorView ObexServer SimTkSmsPpRspArg WindowFrameView
BtServiceObserver FoggyPushButtonView ObexServerAddr SimTkSsIndArg WindowHierarchyIterator
BtServiceRequest FoggySoftkeyBarView ObexServerDispatcher SimTkSsRspArg WindowManager
BtServiceVerifyMessage FoggyTheme ObexServerInfo SimTkStopSendDtmfReqArg WinMenuItem
BtServiceVerifyRequest FoggyWindowFrameView ObexServerMngr SimTkTransactionId WinRect
BtServiceVerifyResult Font ObexServerOppImpl SimUserDispatcher WStrData
BtServiceVerifyResultMessage FontConfig ObexServerPort SingleArgHook WString
BtSetRemoteDeviceNameMessage FontEntry ObexServerVisitor SioGlueSignalListener
X
BtSetRemoteDeviceNameRequest FontManager ObexTransportMsg SioGlueWrapper XCallInfoResponseParser
BtSingleConnectionController FontPack ObexTransportSet SioGlueWrapper::SioCommId XMLParser
BtStateChangedMessage FontPackConnector ObexTransportSet::Iterator SioGlueWrapper::TermIos XmlParserRel
BtSvrDataElement FontRes ObexTransportWin SioSocketAdapter
Z
BtSvrServiceAttribute ForwardedCallIncomingMsg ObexTriggerMsg SioSocketAdapter::SioSocketCallbacks Zi8AddWordMsg
BtSvrServiceRecord ForwardingFeature ObexUrlStrParser SiProvFileRef_s Zi8AlphabetBox
BtTransport ForwardingFeatureList ObexVCardMsg SiProvFileRefArray Zi8AlphabetBoxView
BtTurnOnOffWindow ForwardingInfo ObjectDataConverter SiText_s Zi8EnteredUnknownWordMsg
BtUncancelablePointToPointRequest ForwardingInfoReceivedArg ObjectObtainer SiTextArray Zi8InputConfig
BtUncancelableRequest ForwardingInfoReceivedMsg ObjectTreeService SiUrlArray Zi8InputMapper
BtUUID ForwardingSsAction ObservableObject Size Zi8NoWordFoundMsg
BubbleSortProvider Fota Observer SkipSocketTestMsg Zi8PredictiveInputBox
BufferedData Fraction ObtainableObject SmafSound Zi8SelectionBox
BufferedOutputStream FrameDc OmBandStatusCnfArg Sms Zi8SelectionBoxView
BufferPoolManager FromStackMsg OmBandStatusReqArg SmsAlert Zi8StrokeBox
ByteBuffer fs_registered_info_type OmControlIndArg SmsApp Zi8StrokeBoxView
C
fs_stat OmFactoryResetIndArg SmsBasicProvider Zi8Wrapper
CachingSortProvider FsRegistrationInfo OmGetTermProfileCnfArg SmsCapacityAvailableArg
_
CalculatorInputMapper FtpAuthProvider OmGetTermProfileReqArg SmsCapacityExceededArg _ApplicationTracer
CalendarAddRecordWin FtpClient OmMultiSlotIndArg SmsClass0Provider _FunctionTracer
CalendarApp FtpConnectMessage OmMultiSlotIndMsg SmsCommand _JUMP_BUFFER
CalendarDialogWin FtpDataServerSocket OmMultiSlotReqArg SmsComposeWin _NullApplicationTracer
CalendarGotoDateWin FtpDataSocket OmPowerUpArg SmsConcatStatusTextMap _NullFunctionTracer

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Z | _

Generated on Wed Jan 25 00:53:37 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Wed Jan 25 02:31:21 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Devices

Devices
[Devices]

Namespaces

namespace | AtiUtils

Modules

Devices

Data Structures

class | AbstractDevice
class | AbstractLockableDevice
Abstract base class for all hardware devices. More...
class | AtiAudioDecoderRenderer
class | AtiMpeg4Decoder
class | AtiMpeg4Encoder
class | Audio
class | BufferPoolManager
class | Camera
class | Camera
class | Camera
class | Camera
class | Camera
class | Camera
class | Charger
class | DefaultDisplay
class | DefaultDisplay
class | DefaultDisplay
class | DefaultDisplay
class | DefaultDisplay
class | DefaultDisplay
class | DeviceManager
class | Display
class | EmzAacDecoder
class | EmzAacDecoder
class | EmzAacDecoderThread
class | EmzAacDecoderThread
class | EmzH264Decoder
class | EmzH264Decoder
class | EmzH264DecoderThread
class | EmzH264DecoderThread
class | EmzMp3Decoder
class | EmzMp3Decoder
class | EmzMp3DecoderThread
class | EmzMp3DecoderThread
class | EmzMpeg4Decoder
class | EmzMpeg4Decoder
class | EmzMpeg4DecoderThread
class | EmzMpeg4DecoderThread
class | EmzMpeg4Encoder
class | EmzMpeg4Encoder
class | EmzMpeg4EncoderThread
class | EmzMpeg4EncoderThread
class | EmzSbcEncoder
class | EmzSbcEncoderThread
class | EmzUtils
class | EmzUtils
class | Fota
class | Keyboard
Keyboard. More...
class | Led
Back light device. More...
class | RealTimeClock
class | ScanlineAccessor
class | ScanlineAccessor
class | ScanlineAccessor
class | ScanlineAccessor
class | ScanlineAccessor
class | ScicosMpeg4VideoDecoder
class | ScicosMpeg4VideoEncoder
class | SharedPtr< T_obj >
class | ShutDown
class | StartUp
class | StillCamera
class | StillCamera
class | StillCamera
class | StillCamera
class | StillCamera
class | StillCamera
class | VibratorDevice
class | VideoCamera
class | VideoCamera
class | VideoCamera
class | VideoCamera
class | VideoCamera
class | VideoCamera
class | VideoChannel
class | VideoChannel
class | VideoChannel
class | VideoChannel
class | VideoChannel
class | VideoChannel
class | VirtualDisplay
class | VirtualDisplay
class | VirtualDisplay
class | VirtualDisplay
class | VirtualDisplay

Defines

#define | APOXI_CAMERA_TWINVIEWFINDER_SUPPORT
#define | APOXI_MAX_DISPLAY_COUNT 2
#define | IMAGE_CAPTURED_OK (0)
#define | IMAGE_CAPTURED_OK (0)
#define | IMAGE_ENCODED_OK (0)
#define | IMAGE_ENCODED_OK (0)
#define | MAX_POOL_COUNT 10
#define | MEM_POOL 0
#define | STOPPED_BY_GDD_PROBLEM (3)
#define | STOPPED_BY_GDD_PROBLEM (3)
#define | STOPPED_BY_NO_BUFFER_FOUND (2)
#define | STOPPED_BY_NO_BUFFER_FOUND (2)
#define | STOPPED_BY_USER_CANCEL (1)
#define | STOPPED_BY_USER_CANCEL (1)
#define | STOPPED_NORMALLY (0)
#define | STOPPED_NORMALLY (0)

Functions

virtual void | SharedPtr::Clear ()
tGciAudioBitrate | AtiUtils::ConvertAACToGCIFormat (CodecDevice::EncQualityConfig input)
tGciAudioAmrBitrateConfig | AtiUtils::ConvertAMRToGCIFormat (CodecDevice::EncQualityConfig input)
CodecDevice::TimestampMSec | AtiUtils::ConvertFromGCIFormat (tGciAudioTimestampMSec input)
BOOLEAN | AtiUtils::ConvertFromGCIFormat (tGciBoolean input)
UINT8 * | AtiUtils::ConvertFromGCIFormat (UINT32 *input)
CodecDevice::AudioChannel | AtiUtils::ConvertFromGCIFormat (tGciAudioHandle input)
CodecDevice::ResultType | AtiUtils::ConvertFromGCIFormat (tGciResult input)
tGciAudioTimestampMSec | AtiUtils::ConvertToGCIFormat (CodecDevice::TimestampMSec input)
tGciBoolean | AtiUtils::ConvertToGCIFormat (BOOLEAN input)
UINT32 * | AtiUtils::ConvertToGCIFormat (const UINT8 *input)
tGciAudioFormat | AtiUtils::ConvertToGCIFormat (CodecDevice::CodecType codec)
tGciAudioMonoStereoConfiguration | AtiUtils::ConvertToGCIFormat (CodecDevice::MonoSteroConfig input)
tGciAudioSamplingFreqHz | AtiUtils::ConvertToGCIFormat (UINT16 input)
tGciAudioAacFormat | AtiUtils::ConvertToGCIFormat (CodecDevice::AacFormat input)
tGciAudioAmrDtxConfig | AtiUtils::ConvertToGCIFormat (CodecDevice::AmrDtxConfig input)
tGciAudioAmrInterfaceFormatConfig | AtiUtils::ConvertToGCIFormat (CodecDevice::AmrIfFormat input)
tGciAudioHandle | AtiUtils::ConvertToGCIFormat (CodecDevice::AudioChannel input)
INT | Camera::GetDisplayIndex () const
FrameRateType | VideoCamera::GetFrameRate () const
static IlluminationMode | Keyboard::GetIlluminationMode ()
INT | StillCamera::GetJpegQuality () const
INT | Camera::GetLastError () const
CameraState | Camera::GetState () const
static BOOLEAN | Keyboard::IsIlluminationOn ()
static BOOLEAN | Keyboard::IsLocked ()
static BOOLEAN | Keyboard::IsMultiKeyMode ()
const T_obj & | SharedPtr::operator * () const
T_obj & | SharedPtr::operator * ()
SharedPtr::operator bool () const
bool | SharedPtr::operator!= (const SharedPtr< T_obj > &src) const
Compare the underlying pointers for inequality.
T_obj * | SharedPtr::operator-> () const
SharedPtr & | SharedPtr::operator= (const SharedPtr< T_obj > &src)
Share ownership.
bool | SharedPtr::operator== (const SharedPtr< T_obj > &src) const
Compare the underlying pointers for equality.
void | SharedPtr::Ref ()
static void | Keyboard::SetIlluminationTimeout (UINT32 timeout)
static void | Keyboard::SetMultiKeyMode (BOOLEAN enable)
SharedPtr::SharedPtr (const SharedPtr< T_obj > &src)
SharedPtr::SharedPtr (T_obj *pobj)
SharedPtr::SharedPtr ()
void | SharedPtr::Unref ()
virtual | SharedPtr::~SharedPtr ()
Copy from different, but castable type.

Variables

const UINT8 | c_ati_codec_max_num_of_mpeg4_dec_inst = 1
const UINT8 | c_ati_codecs_max_num_of_mpeg4_enc_inst = 1
const UINT8 | c_emz_codec_max_num_of_aac_dec_inst = 1
const UINT8 | c_emz_codec_max_num_of_aac_dec_inst = 2
const UINT8 | c_emz_codec_max_num_of_h264_dec_inst = 1
const UINT8 | c_emz_codec_max_num_of_h264_dec_inst = 3
const UINT8 | c_emz_codec_max_num_of_mp3_dec_inst = 1
const UINT8 | c_emz_codec_max_num_of_mp3_dec_inst = 2
const UINT8 | c_emz_codec_max_num_of_mpeg4_dec_inst = 1
const UINT8 | c_emz_codec_max_num_of_mpeg4_dec_inst = 3
const UINT8 | c_emz_codec_max_num_of_sbc_enc_inst = 2
const UINT8 | c_emz_codecs_max_num_of_mpeg4_enc_inst = 1
const UINT8 | c_emz_codecs_max_num_of_mpeg4_enc_inst = 2
const UINT8 | c_scicos_codec_if_max_num_of_vid_dec_inst = 1
const UINT8 | c_scicos_codec_if_max_num_of_vid_enc_inst = 1

Define Documentation

#define APOXI_CAMERA_TWINVIEWFINDER_SUPPORT

#define APOXI_MAX_DISPLAY_COUNT 2

#define IMAGE_CAPTURED_OK (0)

#define IMAGE_CAPTURED_OK (0)

#define IMAGE_ENCODED_OK (0)

#define IMAGE_ENCODED_OK (0)

#define MAX_POOL_COUNT 10

#define MEM_POOL 0

#define STOPPED_BY_GDD_PROBLEM (3)

#define STOPPED_BY_GDD_PROBLEM (3)

#define STOPPED_BY_NO_BUFFER_FOUND (2)

#define STOPPED_BY_NO_BUFFER_FOUND (2)

#define STOPPED_BY_USER_CANCEL (1)

#define STOPPED_BY_USER_CANCEL (1)

#define STOPPED_NORMALLY (0)

#define STOPPED_NORMALLY (0)

Function Documentation

template<typename T_obj>
void SharedPtr< T_obj >::Clear ( ) [virtual, inherited]

Forget the instance. operator bool() will return false afterwards.

tGciAudioBitrate AtiUtils::ConvertAACToGCIFormat ( CodecDevice::EncQualityConfig input )

Converts the quality configuration used by CodecDevice to the bitrate (AAC) used by the lower layer (driver).

Parameters:
input The quality configuration to be converted
Returns:
The converted audio bitrate.

tGciAudioAmrBitrateConfig AtiUtils::ConvertAMRToGCIFormat ( CodecDevice::EncQualityConfig input )

Converts the quality configuration used by CodecDevice to the bitrate (AMR) used by the lower layer (driver).

Parameters:
input The EncQualityConfig to be converted
Returns:
The converted bitrate type.

CodecDevice::TimestampMSec AtiUtils::ConvertFromGCIFormat ( tGciAudioTimestampMSec input )

Converts the Timestamp type delivered by the lower layer (driver) into the Timestamp type used by CodecDevice.

Parameters:
input The timestamp to be converted
Returns:
The converted timestamp type.

BOOLEAN AtiUtils::ConvertFromGCIFormat ( tGciBoolean input )

Converts the Boolean type delivered by the lower layer (driver) into the boolean type used by CodecDevice.

Parameters:
input The Boolean type to be converted
Returns:
The converted boolean type.

UINT8 * AtiUtils::ConvertFromGCIFormat ( UINT32 * input )

Converts the buffer pointer delivered by the lower layer (driver) into the buffer pointer of the CodecDevice.

Parameters:
input The buffer pointer to be converted
Returns:
The converted buffer pointer.

CodecDevice::AudioChannel AtiUtils::ConvertFromGCIFormat ( tGciAudioHandle input )

Converts the audio handle delivered by the lower layer (driver) into the AudioChannel of the CodecDevice.

Parameters:
input The tGciAudioHandle to be converted
Returns:
The converted AudioChannel.

CodecDevice::ResultType AtiUtils::ConvertFromGCIFormat ( tGciResult input )

Converts the result code delivered by lower layer (driver) into the result code of the CodecDevice, i.e., into the enum ResultType.

Parameters:
result_code The result code to be converted
Returns:
The converted result code.

tGciAudioTimestampMSec AtiUtils::ConvertToGCIFormat ( CodecDevice::TimestampMSec input )

Converts the Timestamp type used by CodecDevice into the Timestamp type delivered by the lower layer (driver).

Parameters:
input The timestamp to be converted
Returns:
The converted timestamp type.

tGciBoolean AtiUtils::ConvertToGCIFormat ( BOOLEAN input )

Converts the boolean type used by CodecDeviceinto the boolean type delivered by the lower layer (driver) .

Parameters:
input The Boolean type to be converted
Returns:
The converted boolean type.

UINT32 * AtiUtils::ConvertToGCIFormat ( const UINT8 * input )

Converts the buffer pointer of the CodecDevice into the buffer pointer delivered by the lower layer (driver).

Parameters:
input The buffer pointer to be converted
Returns:
The converted buffer pointer.

tGciAudioFormat AtiUtils::ConvertToGCIFormat ( CodecDevice::CodecType codec )

Converts the Codec Type to the GCI Audio Format.

Parameters:
input The mono/stereo configuration to be converted
Returns:
The converted gci mono/stereo configuration.

tGciAudioMonoStereoConfiguration AtiUtils::ConvertToGCIFormat ( CodecDevice::MonoSteroConfig input )

Converts the mono/stereo configuration used by CodecDevice to the mono/stereo configuration used by the lower layer (driver).

Parameters:
input The mono/stereo configuration to be converted
Returns:
The converted gci mono/stereo configuration.

tGciAudioSamplingFreqHz AtiUtils::ConvertToGCIFormat ( UINT16 input )

Converts the UINT16 used by CodecDevice to the sampling frequency used by the lower layer (driver).

Parameters:
input The UINT16 to be converted
Returns:
The converted sampling frequency.

tGciAudioAacFormat AtiUtils::ConvertToGCIFormat ( CodecDevice::AacFormat input )

Converts the AacFormat used by CodecDevice to tGciAudioAacFormat used by the lower layer (driver).

Parameters:
input The AacFormat to be converted
Returns:
The converted tGciAudioAacFormat.

tGciAudioAmrDtxConfig AtiUtils::ConvertToGCIFormat ( CodecDevice::AmrDtxConfig input )

Converts the AmrDtxConfig used by CodecDevice to tGciAudioDtxConfig used by the lower layer (driver).

Parameters:
input The AmrDtxConfig to be converted
Returns:
The converted tGciAudioAmrDtxConfig.

tGciAudioAmrInterfaceFormatConfig AtiUtils::ConvertToGCIFormat ( CodecDevice::AmrIfFormat input )

Converts the AmrIfFormat used by CodecDevice to the interface format used by the lower layer (driver).

Parameters:
input The AmrIfFormat to be converted
Returns:
The converted interface format.

tGciAudioHandle AtiUtils::ConvertToGCIFormat ( CodecDevice::AudioChannel input )

Converts the AudioChannel used by CodecDevice to the AudioHandle used by the lower layer (driver).

Parameters:
input The AudioChannel to be converted
Returns:
The converted audio handle.

INT Camera::GetDisplayIndex ( ) const [inline, inherited]

Returns:
the current display device index on which the camera's viewfinder will be drawn at.

VideoCamera::FrameRateType VideoCamera::GetFrameRate ( ) const [inline, inherited]

Get current set framerate.

Returns:
returns the current selected frame rate for video capturing.

Keyboard::IlluminationMode Keyboard::GetIlluminationMode ( ) [inline, static, inherited]

Returns:
current mode of the illumination

INT StillCamera::GetJpegQuality ( ) const [inline, inherited]

Returns:
returns the current set quality value. Higher value means better image quality.

INT Camera::GetLastError ( ) const [inline, inherited]

Returns:
retrieves the last error from camera. If no error occurred, CamerError::NoError is returned.

Camera::CameraState Camera::GetState ( ) const [inline, inherited]

Returns:
retrieves the current state of the camera.

BOOLEAN Keyboard::IsIlluminationOn ( ) [inline, static, inherited]

Returns:
Status of illumination (on or off)

BOOLEAN Keyboard::IsLocked ( ) [inline, static, inherited]

BOOLEAN Keyboard::IsMultiKeyMode ( ) [inline, static, inherited]

template<typename T_obj>
const T_obj & SharedPtr< T_obj >::operator * ( ) const [inline, inherited]

Dereferencing.

template<typename T_obj>
T_obj & SharedPtr< T_obj >::operator * ( ) [inline, inherited]

Dereferencing.

template<class T_obj>
SharedPtr< T_obj >::operator bool ( ) const [inline, inherited]

Test whether the SharedPtr<> points to any underlying instance.

Mimics usage of ordinary pointers:

   if (ptr)
       do_something();

template<typename T_obj>
bool SharedPtr< T_obj >::operator!= ( const SharedPtr< T_obj > & src ) const [inherited]

Compare the underlying pointers for inequality.

template<typename T_obj>
T_obj * SharedPtr< T_obj >::operator-> ( ) const [inline, inherited]

Dereferencing.

Use the methods of the underlying instance like so: refptr->memberfun().

template<typename T_obj>
SharedPtr< T_obj > & SharedPtr< T_obj >::operator= ( const SharedPtr< T_obj > & src ) [inherited]

Share ownership.

Copy constructor (from different, but castable type).

Share ownership.

template<typename T_obj>
bool SharedPtr< T_obj >::operator== ( const SharedPtr< T_obj > & src ) const [inherited]

Compare the underlying pointers for equality.

template<class T_obj>
void SharedPtr< T_obj >::Ref ( ) [inline, protected, inherited]

void Keyboard::SetIlluminationTimeout ( UINT32 timeout ) [inline, static, inherited]

Parameters:
timeout Timeout value in milliseconds. After this time without calling ReactivateIllumination the illumination turns off.

void Keyboard::SetMultiKeyMode ( BOOLEAN enable ) [inline, static, inherited]

Parameters:
enable TRUE: enables multiple keystrokes, FALSE: only on keystroke is sent to APOXI

template<typename T_obj>
SharedPtr< T_obj >::SharedPtr ( const SharedPtr< T_obj > & src ) [inherited]

Copy constructor. Share ownership.

template<typename T_obj>
SharedPtr< T_obj >::SharedPtr ( T_obj * pobj ) [explicit, inherited]

Take ownership. You new-ed it and SharedPtr will delete it.

template<typename T_obj>
SharedPtr< T_obj >::SharedPtr ( ) [inherited]

There will be no underlying instance. operator bool() will return false afterwards.

template<class T_obj>
void SharedPtr< T_obj >::Unref ( ) [inline, protected, inherited]

template<typename T_obj>
SharedPtr< T_obj >::~SharedPtr ( ) [virtual, inherited]

Copy from different, but castable type.

Variable Documentation

const UINT8 c_ati_codec_max_num_of_mpeg4_dec_inst = 1

Maximum number of AtiMpeg4Decoder instances.

const UINT8 c_ati_codecs_max_num_of_mpeg4_enc_inst = 1

Maximum number of AtiMpeg4Encoder instances.

const UINT8 c_emz_codec_max_num_of_aac_dec_inst = 1

Maximum number of EmzAacDecoder instances.

const UINT8 c_emz_codec_max_num_of_aac_dec_inst = 2

Maximum number of EmzAacDecoder instances.

const UINT8 c_emz_codec_max_num_of_h264_dec_inst = 1

Maximum number of EmzH264Decoder instances.

const UINT8 c_emz_codec_max_num_of_h264_dec_inst = 3

Maximum number of EmzH264Decoder instances.

const UINT8 c_emz_codec_max_num_of_mp3_dec_inst = 1

Maximum number of EmzMp3Decoder instances.

const UINT8 c_emz_codec_max_num_of_mp3_dec_inst = 2

Maximum number of EmzMp3Decoder instances.

const UINT8 c_emz_codec_max_num_of_mpeg4_dec_inst = 1

Maximum number of EmzMpeg4Decoder instances.

const UINT8 c_emz_codec_max_num_of_mpeg4_dec_inst = 3

Maximum number of EmzMpeg4Decoder instances.

const UINT8 c_emz_codec_max_num_of_sbc_enc_inst = 2

Maximum number of EmzSbcEncoder instances.

const UINT8 c_emz_codecs_max_num_of_mpeg4_enc_inst = 1

Maximum number of EmzMpeg4Encoder instances.

const UINT8 c_emz_codecs_max_num_of_mpeg4_enc_inst = 2

Maximum number of EmzMpeg4Encoder instances.

const UINT8 c_scicos_codec_if_max_num_of_vid_dec_inst = 1

Maximum number of ScicosMpeg4VideoDecoder instances.

const UINT8 c_scicos_codec_if_max_num_of_vid_enc_inst = 1

Maximum number of ScicosMpeg4VideoEncoder instances.

Generated on Wed Jan 25 02:29:24 2006 for APOXI by doxygen 1.4.6-NO


APOXI: Main Page

APOXI Documentation (Version 2.10)

 Comneon

Modules

AddOns | Provides optional additions to APOXI like Auxiliary-Extensions, ADC-Extensions, GUI-Extensions, Multimedia and T9. | Config | Defines the common interface to the configuration-classes, which store the wished behavior and settings for APOXI dependend to a custom project.
Auxiliary | Provides helper-classes for APOXI and custom projects. | Devices | Defines the common interface to the devices display, audio, keyboard and realtimeclock.
ADC | Interface for accessing data which is stored on a variable medium like SIM, RAM, NVRAM etc. | GUI | = Graphical User Interface. Classes for creating windows, controls and other graphical objects needed for displaying data on the display and interaction with the user. It is recommended to read the GUI-Tutorial first.
APC | = APOXI Process Control. Wrapper classes for accessing the protocoll stack. Mostly needed by ASC and ADC. | Kernel | Defines core-functionality of APOXI and the layer to the operating system.
ASC | = APOXI Stack Control. Interface to access mobile communication requirements like GSM, GPRS and UMTS. | Socket | Classes for socket-handling.
AFS | = APOXI File System. | Bluetooth | Classes for bluetooth access.
ATL | = APOXI Template Layer. Template classes for IDEA concepts of the MMI.

General Documentation

Module Overviews: | APOXI, ADC, AES, AFS, APC, ASC, ATL, Audio, Auxiliary, Bluetooth, Devices, DRM, GUI, Http/Wap, IrDA, Kernel, LCS, Multimedia, OBEX, Suppl. Services Architecture, Services, Sockets, SyncML, Themes, USB, Voice Recognition
Concepts: | Startup Concept, Shutdown Procedure, Message Routing, Service Threads, Modal vs. Modeless
Tutorials: | GUI, Application Memory Meter, Suppl. Service
Compiler settings: | Features, Defines

APOXI Newsletter

There is the possibility to subscribe to the APOXI newsleter service, which will inform you of interface and implementation changes in advace of official APOXI releases. This newsletter is sent out periodically and gives a brief overview of differences between the current and the upcoming versions of APOXI.

Simply subscribe by sending an email to Support_Apoxi@comneon.com with the subject SUBSCRIBE. If you dont want to receive our newsletters any longer you may unsubscribe by sending an email to the above address with the subject UNSUBSCRIBE

Generated on Thu Feb 10 13:55:01 2005 for APOXI by doxygen 1.4.1